 所有类
AbsHTMLMaker
AbstractErrorMessage
AbstractLogger
AbstractTemplateSetting
AbstractToUsersCreator
AbstractValidator
AbstractXmlToObjConverter
ActionHandlerConfig
ActionParametersAnalyser
ActorHelper
ADCom
ADComs
AddEditFieldTemplate
ADFile
ADFilePos
ADFilePoss
ADFiles
AdjustJsLCListenerWidget
Adler32
AdmanageConfigServiceImpl
AdministratorCacheMgr
ADPos
ADPoss
ADType
ADTypes
AdvSearchNavHandler
Alertion
AllDDLMaker
AndinOraDB
ApdHostLCListener
AppAutoParameter
AppAutoParameters
Appendix
Appendixes
AppendixMgr
AppendixToXML
ApplyForm
ApplyFormConstants
ApplyFormDealLog
ApplyFormDealLogs
ApplyFormReplyHandler
ApplyForms
ApplyFormServiceProvider
ApplyFormToUsersCreator
ApplyFormTypeHandler
AttributesString
AuthHelper
AuthServer
AuthServerMgr
AuthServiceProvider
AutoBakConfig
AutoBakConfigs
AutoDocBakMgr
AutoDocBakService
AutoFillApplyFormHandler
AutoImageLibUtil
AutoToNextHandler
AutoTransmitMgr
BarChartProducer
BASE64DecoderStream
BASE64EncoderStream
Base64Util
BaseChannel
BaseChannelInfoEntity
BaseChannelLCListener4ExtField
BaseChannelLCListener4Region
BaseConfig
BaseConfigServer
BaseContextHelper
BaseDBLog
BaseFieldHTMLParser
BaseIdsMan
BaseInfoViewFieldValueCreator
BaseJob
BaseObj
BaseObjHandler
BaseObjHelper
BaseObjs
BaseObjsHandler
BaseObjToXmlConverter
BaseObjToXmlConverterForSpecialProperty
BasePropertiesBuilder
BaseScheduleWorker
BaseServer
BaseServiceDecorator
BaseStatefulJob
BaseStatefulScheduleWorker
BaseStatHandler
BaseStyle
BaseTagParser
BaseTagParser4List
BaseTagParserDefaultObjects
BaseValidator
BaseWCMObjectToXML
BaseWCMTagParserPreNextDocuments
BatchChannelCreateFromFileLogger
BatchDetailPageTask
BeanConfig
BeanConfigHelper
BeanConfigServer
BindingBean
BiTagValidator
BonusCalculator
BonusRule
BonusRuleMgr
BonusRules
BonusRuleServiceProvider
BookMark
BookMarkMgr
BookMarks
BookMarkService
BooleanXMLConvertorImpl
CabConstants
CabEntry
CabFile
CABFileExtractor
CachedObjectConfig
CachedPOMgr
CacheMgrConfig
CacheServer
CalculatedField
CAS400CLOB
CAUserSync
CAUserSync.UserInfo
CDB2DBCLOB
CDB2DBCLOB2
CDBKeyWords
CDBText
CDSServiceImpl
CellInfo
CellInfos
CellServiceProvider
CellsSaveListenerForPublish
Channel
ChannelAuthHelper
ChannelContentLink
ChannelContentLinks
ChannelCreateFromListenerForMetaView
ChannelCreateFromLogger
ChannelDocListenerForPublish
ChannelExporter
ChannelHelper
ChannelHitsCountHandler
ChannelImporter
ChannelImportLogger
ChannelLCListener4EPress
ChannelLCListenerForChannelSyn
ChannelLCListenerForDocument
ChannelLCListenerForExtField
ChannelLCListenerForFlow
ChannelLCListenerForSpeical
ChannelListenerForPublish
ChannelLogger
ChannelLoopValidator
ChannelMgr
ChannelMoveLogger
ChannelNameMgr
ChannelNavHandler
ChannelPorterVisitorForMetaView
ChannelRelated
ChannelRightHostImpl
ChannelRightObjImpl
Channels
ChannelService
ChannelServiceProvider
ChannelServiceProviderHelper
ChannelsTemplateSetting
ChannelSubstanceImplBase
ChannelsWithRightMaker
ChannelSyn
ChannelSyns
ChannelSynToXML
ChannelToXML
ChannelXmlConverter
CharsetDetector
CharSetFilter
ChartBuildException
ChartConstants
ChartOption
ChartStyle
ChartWriter
CheckedInputStream
CheckedOutputStream
Checksum
ChildrenCacheMgr
ChineseFinder
ChnlDept
ChnlDeptMgr
ChnlDeptMgrForCluster
ChnlDepts
ChnlDoc
ChnlDocLCListener4ClassInfo
ChnlDocLCListenerForAutoDocBak
ChnlDocLCListenerForFlow
ChnlDocLCListenerForInfoViewDB
ChnlDocLCListenerForPri
ChnlDocLCListenerForRecordNotEntity
ChnlDocLCListenerForSynToMetaData
ChnlDocLCListnerForPublish
ChnlDocLogger
ChnlDocs
ChnlDocServiceProvider
ChnlDocToXML
ChnlSynWorker
CImage
CKeyUtil
ClassDocumentsHelper
ClassDocumentsHelperTest
ClassInfo
ClassInfo
ClassInfoCacheMgr
ClassInfoChannelRightHelper
ClassInfoCountCacheForPublishImpl
ClassInfoImporter
ClassInfoListenerForViewData
ClassInfoMgr
ClassInfoNavHandler
ClassInfoPublishServiceProvider
ClassInfos
ClassInfoServiceProvider
ClassInfoServiceProviderForGB
ClassInfoToChannelHelper
ClassInfoToGroupCreator
ClassInfoUtil
ClassInfoView
ClassInfoViewMgr
ClassInfoViews
ClassInfoViewService
ClassInfoViewServiceProvider
ClassInfoXMLConvertor
ClusterConfigHelper
ClusterConstants
ClusterDBIdManager
ClusterLocker
ClusterMsgCenterImpl
ClusterSessionFileter
CMSBaseObjs
CMSConstants
CMSObj
CMSObjDefaultImpl
CmsObjUnlockTools
CMy3WLib
CMyBeanConfig
CMyBitsValue
CMyClassConfig
CMyDateTime
CMyDecimalBuddy
CMyDOM4jHelper
CMyEmail
CMyEncrypt
CMyErrors
CMyException
CMyFile
CMyFilenameFilter
CMyFileX
CMyFtp
CMyKeyGenerator
CMyMailException
CMyMailLog
CMyMemory
CMyParameter
CMyResultObjs
CMyResultSet
CMyResultSets
CMySign
CMySMS
CMySMTPServer
CMySoapClient
CMysqlText
CMyString
CMyTemplateWizard
CMyTimer
CMyTransformCoding
CMyUnzip
CMyUnZipFile
CMyURLEncoder
CMyXMLDoc
CMyXMLElement
CMyXMLHandler
CMyXMLParser
CMyZip
Column
CommentConstants
CommentParserEntity
CommentParserUtil
CommentService
CommentUpdator
CommonResourceBuilder
ComplexFieldData
ComplexFieldDatas
ComponentEntryConfigConstants
ComponentEntryConfigServiceImpl
ConditionHandlerConfig
ConditionHelper
Config
ConfigConstants
ConfigController
ConfigElementContentTester
ConfigFile
ConfigFiles
ConfigFilesFinder
ConfigFileTool4Refactor
ConfigHelper
ConfigLogger
ConfigObjectLoader
Configs
ConfigServer
ConnectionPool
ConnectPasswordEncrypter
Constants
Contact
ContactGrp
ContactGrps
ContactMgr
ContactMsgSender
Contacts
ContactService
ContentExtendValue
ContentExtendValues
ContentExtField
ContentExtFieldCListenerForDocProps
ContentExtFieldLCListenerForDocFields
ContentExtFieldMgr
ContentExtFields
ContentExtFieldToXML
ContentExtFieldXmlConverter
ContentLink
ContentLink2Xml
ContentLinkMgr
ContentLinkReplacer
ContentLinks
ContentLinkServiceProvider
ContentLinkType
ContentLinkTypes
ContentProcessInfo
ContentProcessInfoToXML
ContentPropertyHandler
ContentStyle
ContentStyleExporter
ContentStyleImporter
ContentStyleMgr
ContentStyles
ContentStyleServiceProvider
ContentStyleXmlConverter
ContentTypeConfig
ContentUpdateCommanderImpl
ContextHelper
ContextParameters
ContextTL
ConvertException
CopyOfTRSImportsOrgnize
COracleCLOB
CPager
CRC32
CreateThreadForPDF
CreateThreadForPDFOfWins
CRegister
CRightUtil
CrUserAsToUsersCreator
CSQLText
CSSResourceProcessor
CurrentDateCreator
CurrentDocStatusCreator
CurrentTimeCreator
CurrentUserNameCreator
CustomizedChannelIdsMan
CustomizeMgr
CustomizeMgrImpl
CustomizeService
CustomSiteCheckedInfo
CustomSiteCheckedInfos
CWasTree
DamengDB
DataAnalyzingException
DataDictionary
DataFormatException
DataFromNewshoo
DataFromRadar
DataFromRadarClient
DataGroup
DataOfV6To52
DatasFromTRSServer
DatasWithChnlDocFilterHelper
DataTransferEncodeFactory
DataType
DataType
DataTypeBuilder
DataTypeToXML
DataUtil
DB2AS400DB
DB2ReorgUtil
DB2UDB
DB2UDB2
DB2UDBV9
DB2UpdSqlMaker
DbConfig
DBConnectionConfig
DBConnectionConfigs
DBConnectionMapper
DbDDLMaker
DBIdManager
DBManager
DBMsgReceiver
DBService
DBTableConfig
DBType
DBTypes
DBUpdateLog
DBUpdateLogMgr
DBUpdateLogs
DbUpdSqlLogMaker
DDLMain
DebugTimer
DefaultChannelMakerCenter
DefaultDeleteLogger
DefaultHTMLMaker
DefaultObj
DefaultObjs
DefaultPropertiesBuilder
DefaultSaveLogger
DefaultStatHandler
DefaultWCMObjectsToXML
DefaultWhereSQLMaker
DefautlServiceProvider
Deflater
DeflaterOutputStream
DepartmentMgrImpl
DeptMgrAsToUsersCreator
DiffSqlMaker
DiscoveryFactoryBuddy
DistributeServiceProvider
DistributionChangeListener
DistributionTargetTypeToXML
DocBak
DocBakLCListenerForApd
DocBakMgr
DocBaks
DocCopyLogger
DocImportLogger
DocKeywordMgrImpl
DocKind
DocKinds
DocMoveLogger
DocOperDefine
DocPriDisableWorker
DocPublishTaskLogger
DocReply
DocReplyMgr
DocReplys
DocRightSetRightIndex
DocSaveLogger
DocsFromTRSServer
DocStatHandler4Channel
DocStatHandler4ChannelOfGroup
DocstatHandler4ChannelOfUser
DocStatHandler4ChnlDept
DocStatHandler4ChnlDeptChannel
DocStatHandler4ChnlDeptSite
DocStatHandler4SiteOfGroup
DocstatHandler4SiteOfUser
DocStatHandler4UserChannel
DocStatHandler4UserDept
DocStatHandler4UserDeptChannel
DocStatHandler4UserDeptSite
DocStatHandler4UserSite
DocStatusChangeLogger
DocTypeValidator
Document
DocumentAuthHelper
DocumentAuthServer
DocumentBakServiceProvider
DocumentExporter
DocumentFieldConfig
DocumentFieldHTMLParser
DocumentFieldsSynFactory
DocumentHitsCount
DocumentHitsCountHandler
DocumentHitsCounts
DocumentImporter
DocumentImportXmlHelper
DocumentLCLisenterForPhoto
DocumentLCListener4EPress
DocumentLCListenerForAutoDocBak
DocumentLCListenerForDocBak
DocumentLCListenerForDocReply
DocumentLCListenerForExternalFile
DocumentLCListenerForInfoViewDB
DocumentLCListenerForKeyword
DocumentLCListenerForPublish
DocumentLCListenerForRelation
DocumentLCListenerForRelDocs
DocumentLCListenerForSIMSearch
DocumentListenerForMetaViewData
DocumentListenerForPublish
DocumentLogger
DocumentMgr
DocumentMoveListenerForDocSiteRecode
DocumentPriMgr
DocumentPropertiesBuilder
DocumentPublishHelper
DocumentRightHostImpl
Documents
DocumentSchema
DocumentService
DocumentServiceProvider
DocumentsGetHelper
DocumentShowFieldConfig
DocumentsPageHelper
DocumentsTemp
DocumentsTimeRangeMgrImpl
DocumentSubstanceImplBase
DocumentSyn
DocumentSyns
DocumentSynServiceProvider
DocumentTopic
DocumentTopicRelationMgr
DocumentTopics
DocumentToXML
DocumentXmlConverter
DoingRuleHandler
DreamFactory
EmailSendWorker
EmbedAltValidator
EntryConfig
EntryConfigs
EnumCreator
EnumsConfig
EPressChannelCreateLogger
EPressChannelWrapper
EPressConf
EpressFolderWrapper
EPressHistoryGenerator
EPressHistoryIndexWorker
EPressHistoryPubLogger
EPressImporter
EPressServiceProvider
EPressSoapService
EPressXPlusImporter
ErrorMessagesFactory
Event
EventLCListenerForRemind
EventMgr
Events
EventService
EventShare
EventShareIdsMan
EventShares
EventsValidator
EventType
EventTypes
ExceptionMessages
ExceptionNumber
ExecuteContext
ExtendedField
ExtendedFieldLCListenerForDocBak
ExtendedFields
ExtendFieldServiceProvider
ExtensionConfigs
ExtFieldToXML
FieldInfo
FieldsTemplateSetting
FieldTemplate
FieldTemplateFactory
FieldValueCreatorConfigStartServer
FieldValueCreatorFactory
FileConfig
FileDistributeQueue
FileDistributeShip
FileDistributorFtpCacheMgr
FileDistributorFtpImpl
FileDistributorImpFileLocal
FileDistributorImpFtpByTRS
FileDistributorImpUnion
FileDistributorLocalImpl
FileMsgProcessor
FileNamedStyle
FileNameExtFilter
FileNew
FilePathFilter
FileProperty
FileService
FilesMan
FileType
FileTypes
FileUploader
FileWithdrawMsgReceiver
Flow
FlowAction
FlowActions
FlowCacheMgr
FlowCondition
FlowConditions
FlowConfigServer
FlowContentApplyFormImpl
FlowContentConfig
FlowContentConfigs
FlowContentDocumentImpl
FlowContentFactory
FlowContentField
FlowContentHelper
FlowContentLCListener
FlowContentsToXML
FlowContentTypeConfig
FlowContext
FlowContextOld
FlowConverterForWebsiteImporter
FlowDoc
FlowDocBak
FlowDocBaks
FlowdocLog
FlowdocLogs
FlowDocs
FlowDocToXML
FlowEmploy
FlowEmployCacheMgr
FlowEmployerLCListener
FlowEmployLCListenerForChange
FlowEmployLogger
FlowEmployMgr
FlowEmploys
FlowEngineHelper
FlowImporter
FlowingDocLogger
FlowingDocOptMarkScouter
FlowingDocQueryService
FlowMgr
FlowNextBranchInfo
FlowNode
FlowNodeBranch
FlowNodeBranchs
FlowNodeField
FlowNodeFields
FlowNodeLCListenerForForceEnd
FlowNodes
FlowNodeXmlConverter
FlowNotifyWorkerImpl
FlowOptMarkEnumParser
FlowParamers
FlowRule
FlowRuleCacheServerImpl
FlowRules
FlowRuleXMLConvertor
Flows
FlowSaveLogger
FlowServer
FlowServerImpl
FlowSetLogger
FlowToXML
FlowUserHelper
FlowXmlConverter
FolderPublishConfig
FolderPublishConfigCacheMgr
FolderPublishConfigLogger
FolderPublishConfigs
FolderPubStatusCacheMgrImpl
FolderTypeConfig
FormElementsValidator
FormProperty
FormSubmitValidator
FrameTitleValidator
FrameworkConstants
FtpConfig
FtpConnection
FtpConnectionCache
FtpConnectionImpFtp
FtpConnectionImpSSH
FtpConnectionPool
FtpMgr
FtpMgrTest
FtpSoap4Radar
GatewayConfig
GatewayPage
GovInfoIndexCreator
GovInfoLCListenerMetaView
GovInfoServiceProvider
GovInfoToXML
GovInfoViewFinder
Group
GroupAdminsAsToUsersCreator
GroupAdminsCacheMgr
GroupAdminsFromChnlAsToUsersCreator
GroupAdminsFromFlowAsToUsersCreator
GroupAdminsFromSupportPartAsToUsersCreator
GroupAuthServer
GroupMembersAsToUsersCreator
GroupMgr
GroupRightObjImpl
GroupRole
GroupRoleMgr
GroupRoles
Groups
GroupService
GroupServiceProvider
GroupUser
GroupUserCacheMgr
GroupUsers
GroupXmlConverter
GrpUserIdsMan
GZIPInputStream
GZIPOutputStream
HashCodeUtil
HitsCount
HitsCountConstant
HitsCountHelper
HitsCountParserSchedule
HitsCounts
HitsStatHandler4Channel
HitsStatHandler4ChnlDept
HitsStatHandler4User
HitsStatHandler4UserDept
HostObjDomain
HostObjDomains
HostObjHitsCount
HostObjHitsCounts
HTML
HTML.Attribute
HTML.Tag
HTML.UnknownTag
Html2text
HtmlAttribute
HtmlCharsetValidator
HtmlCleaner
HtmlComment
HTMLContent
HtmlDocument
HtmlElement
HtmlElementFinder
HtmlH1_H6Validator
HtmlH1Validator
HtmlLangValidator
HTMLMaker
HTMLMakerFactory
HtmlTitleValidator
HtmlUtil
HTMLUtil
HttpChecker
HttpClientBuddy
HttpGet
I18NMessage
I18NMessageStartUp
IActionHandler
IAdmanageConfigService
IAdministratorCacheMgr
IAppendix
IAppendixes
IAtomTask
IAtomTaskList
IAutoDocBakService
IBonusCalculator
IBonusRuleMgr
IBookMarkService
ICachedPOMgr
ICacheMgr
ICacheServer
ICDSService
IChannelImporterConverter
IChannelNameMgr
IChannelService
IChartBuilder
IChildrenMgr
IChnlDeptMgr
ICKMServer
ICKMServerTest
IClassInfoCacheMgr
IClassInfoCountCacheForPublish
IClassInfoMgr
IClassInfoViewMgr
IClusterMsgCenter
IClusterMsgReceiver
IClusterMsgSender
ICMSObjSubstanceContent
ICommentService
IComponentEntryConfigService
IConditionHandler
IConfigElement
IContactService
IContentStyleMgr
IContentStyleServiceProvider
ICustomizeMgr
ICustomizeService
IDataTransferEncode
IDBService
IDefaultChannelMaker
IDeleteServiceProvider
IDepartmentMgr
IDocKeywordMgr
IDocumentFieldsSyn
IDocumentImporterConverter
IDocumentService
IDocumentsTimeRangeMgr
IErrorMessages
IEventService
IFieldHTMLParser
IFileDistristributor
IFindByIdServiceProvider
IFindByIdsServiceProvider
IFlowCacheMgr
IFlowContent
IFlowNotifyWorker
IFlowRuleCacheServer
IFlowServer
IFolderPubStatusCacheMgr
IFtpMgr
IGlueServiceProvider
IGroupService
IHitsCountHandler
IImageLibConfig
IImageLibMgr
IImageLibService
IInfoEntity
IInfoViewDBMgr
IInfoViewEnumCreator
IInfoViewInitor
IInfoViewInitorValue
IInfoViewService
IInitValueCreator
IIntellMgr
IIntellResLocator
IKeyMaker
ILaborResourceMgr
ILayoutGenerator
ILayoutMgr
ILayoutServiceProvider
ILog
ILoginValidator
ILogMgr
ImageInfo
ImageKind
ImageLibConfigImpl
ImageLibConstants
ImageLibHelper
ImageLibMgrImpl
ImageLibServiceImpl
ImageMagickCmd
ImageMagickCmd.ImageObj
IMagicImage
IMasterMgr
IMasterServiceProvider
IMessageService
IMetaDataDefCacheMgr
IMetaDataDefMgr
IMetaDataFieldValueCreator
IMetaViewEmployerMgr
ImgAltValidator
ImgRec
ImpartTemplateLogger
ImportDocsContext
ImportDocsFromFile
ImportDocsFromHTMLFile
INavHandler
IndexDDLMaker
IndexList4Ora
Individuation
IndividuationMgr
Individuations
IndividuationServiceProvider
Inflater
InflaterHuffmanTree
InflaterInputStream
InfoEntities
InfoEntityFinder
InfoPathFileData
InfoView
InfoViewChnlDocFilterHelper
InfoViewConfig
InfoViewConstants
InfoViewContext
InfoViewData
InfoViewDataHelper
InfoViewDataHelper
InfoViewDataHelperImpl
InfoviewDataImportFilter
InfoviewDataProcessor
InfoViewDatas
InfoviewDataToolService
InfoViewDataType
InfoViewDataTypes
InfoViewDBMgr
InfoViewDBStoreServer
InfoViewDocImportService
InfoViewDocument
InfoViewDocuments
InfoViewDocumentServiceProvider
InfoViewDocumentToXML
InfoViewEmploy
InfoViewEmployLCListenerForChannel
InfoViewEmployMgr
InfoViewEmploys
InfoViewEnumCreatorImpl
InfoViewEnumHelper
InfoViewField
InfoViewFields
InfoViewFieldValueCreatorConfigStartServer
InfoViewFieldValueCreatorFactory
InfoViewGroup
InfoViewGroups
InfoViewHelper
InfoViewInitorImpl
InfoViewMgr
InfoViewNewQueryHelper
InfoViewQueryHelper
InfoViewQueryHelper
InfoViewQueryHelperImpl
InfoViewReplyNoticeSender
InfoViews
InfoViewSerial
InfoViewSerialGenerator
InfoviewService
InfoViewService
InfoviewSpecailTagParseHelper
InfoViewTemplateHelper
InfoViewView
InfoViewViews
InfoviewXMLDataUpdator
InnerExceptionNum
IntegerXMLConvertorImpl
IntellResLocatorImpl
IntelMgrImpl
InvocationObserver
InvocationTypes
IObjectLCListener
IObjectLCListenerOnAdd
IObjectLCListenerOnDel
IObjectLCListenerOnModify
IObjectMemberMgr
IObjLogger
IObjTypeLookup
IObserver
IObserverable
IOfficeDocumentService
IPageStyleMgr
IPageStyleServiceProvider
IPageTask
IPageTaskDispatcher
IPorterVisitor
IPreNextDocuments
IPropertiesBuilder
IPublishContent
IPublishElement
IPublishElements
IPublishElementsIterator
IPublishFolder
IPublishProgressMonitor
IPublishService
IPublishTaskDispatcher
IPublishTaskDocumentsCacheMgr
IPublishTaskMgr
IQueryFilter
IQueryFilterFactory
IQueryServiceProvider
IRecentService
IRelateResource
IRequestProcessor
IResourceService
IResourceStyleMgr
IResourceStyleServiceProvider
IRightHost
IRightMgr
IRightObj
IRoleService
ISaveServiceProvider
IScheduleService
ISecurityService
ISelfDefinedServiceProvider
ISendWorker
IServer
IServiceFilter
IServiceListener
IServiceProvider
ISOAPService
ISpecialMgr
ISpecialServiceProvider
IStatHandler
IStatResult
IStatResultFilter
IStatResults
IStatResultsFilter
IStatService
IStyleAndResourceMgr
IStyleCenterMgr
IStyleItemMgr
ISureformService
ISystemContentStyleMgr
ISystemResourceStyleMgr
ISystemWarner
ITagFormatter
ITagParser
ITagParser4List
ITemplateEmployCacheMgr
ITemplateParseService
ITemplateService
ITemplateService
ITemplateSetting
IToUsersCreator
IUpdateCommander
IURLParser
IUserCacheMgr
IUserLoginInfoMgr
IUserService
IValidator
IValidator
IVChannelParser
IVContentLinkParser
IVisualTemplateServiceProvider
IWCMProcessService
IWCMPublishElementService
IWidgetInstanceMgr
IWidgetInstParameterMgr
IWidgetMgr
IWidgetParameterMgr
IWidgetParameterServiceProvider
IWidgetServer
IWidgetServiceProvider
IXMLConvertor
IXmlPersistentObject
JavaCABFileExtractor
JavaScriptEscape
JavaScriptVARProcessor
JdbcTypeMap
JImageMarkUtil
JMarkUtilX
JobFailedResult
JobFailedResults
JobScheduler
JobScheduleServer
JobWorkerType
JobWorkerTypeLCListenerForSchedule
JobWorkerTypes
JsCombineFilter
JSONHelper
JspChecker
JspDenyFilter
JSPRequestParmasValidator
JSPRequestProcessor
JSPServiceContext
JVoteConstant
Keyword
Keywords
KingBaseDB
KMTRSServer
LaborResourceConfig
LaborResourceMgrImpl
LawGovTousersCreator
Layout
LayoutGenerator
LayoutMgr
Layouts
LayoutServiceProvider
LetterConvertor
License
LicenseException
LicenseMgr
LicenseUtil
LinkedEnumCreator
ListFieldTemplate
ListUtil
Loader
LoadingErrorReport
LocaleChecker
LocaleServer
LocaleTools
Localizer
Localizer2
LocalServerAuto
Locker
LockerMgr
LockManager
Log
LogBak
LogBaks
LoginCheckFilter
LogInfo
LoginHelper
LoginValidatorDefaultImpl
LoginValidatorFactory
LoginValidatorThreadLocalImpl
LogListUtil
LogMgr
Logo
Logos
Logs
LogServer
LogServiceProvider
LogType
LogXmlConverter
LoopException
MacAddressHelper
MachineCodeDetector
MagicImageImpl
MailConfig
MailConfigs
MailConfigsHelper
MailContentHelper
Main
Management
Manifest
MarkKind
MarkKinds
MarkShare
MarkShares
Master
MasterMgr
Masters
MasterServiceProvider
MD5
MediaBuilder
MediaRemindedAgent
MediaRemindedInfo
MediaRemindedInfos
MenuArea
MenuButton
Message
Messages
MessageSendingConfig
MessageSendingMapper
MessageServer
MessageServiceProvider
MessageToXML
MetaAppCreateMsgReceiver
MetaDataCenterClassInfoHelper
MetaDataCenterHelper
MetaDataCenterServiceProvider
MetaDataCenterServiceProviderForAgri
MetaDataCenterServiceProviderForGB
MetaDataCenterServiceProviderForZJH
MetaDataConstants
MetaDataDDLImporter
MetaDataDefCacheMgr
MetaDataDefHelper
MetaDataDefMgr
MetaDataDefServiceProvider
MetaDataLoader
MetaDataType
MetaDataTypes
MetaDBField
MetaDBFieldListenerForChannelSynRule
MetaDBFields
MetaDBFieldXMLConvertor
MetaDBTable
MetaDBTables
MetaTableXMLConvertor
MetaView
MetaViewData
MetaViewDataExporter
MetaViewDataImporter
MetaViewDataRelateSource
MetaViewDatas
MetaViewDataToExcel
MetaViewDataToXML
MetaViewEmployer
MetaViewEmployerMgr
MetaViewEmployers
MetaViewEmplyerConverterForChannelImporter
MetaViewExporter
MetaViewField
MetaViewFields
MetaViewFieldXMLConvertor
MetaViewHelper
MetaViewImporter
MetaViews
MetaViewXMLConvertor
MethodConfig
MethodContext
MethodContextHelper
MIMEBase64
MonitorHostConfig
MoveChannelListenerForChannel
MsgQueue
MsgQueues
MsgReceiver
MsgReceivers
MsgSendHandler
MsgSendWorker
MssqlUpdSqlMaker
MyBaseObj
MyBaseObjs
MyDate
MyDB
MyFlowContentDocumentImpl
MyPlugin
MySite
MysqlDB
MySSLSocketFactory
MySSLSocketFactory.MyX509TrustManager
MySystemInfo
MyTypes
NamesRegister
NavConstatns
NavHandlerFactory
NetSnapTool
NewChannelServiceProvider
NewRightSet
NewsComment
NoLoginServiceControler
NoSuchServiceException
NotificationConfig
NotificationSchemeConfig
NotificationServer
Notifier
NullValue
ObjectBodyValidator
ObjectLCListenerConfig
ObjectLCMonitorServer
ObjectLCMsgReceiver
ObjectMember
ObjectMemberMgr
ObjectMemberMgrForCluster
ObjectMembers
ObjectMemberServiceProvider
ObjectMonitored
ObjectsIterator
ObjectTypeConfig
ObjectTypeServer
ObjectTypesFinder
ObjLoggerBase
ObjSysLogger
ObjToXmlConverter
ObjToXmlConverterByDOM4j
ObjTypeLookupHelper
ObjTypeLookupImpl
OcrSoapClient
OfficeDocumentService
OperationConfig
OperationDefineOnCurrChannelConfig
OperationRelatedConfig
OperatorConfig
OperType
OperTypeHelper
OperTypes
OptimizeSystemWorker
OptionConverter
OptMarkParseException
Ora2DB2Convertor
OracleDB
OracleDB11G
OracleUpdSqlMaker
OraImpExtractDDL
OrderGroupAndRole
OrgnizeContextImports
OrignHomePublishException
OTop
OuterKMTRSServer
OverTimeHandler
PackageFile
PageDestoryTask
PageDestroyer
PageGenerator
PageHelper
PageNavHelper
PageOperator
PageOperators
PageOperatorsForServiceHelper
PageOpertatosToXML
PageParameter
PageParameters
PageStyle
PageStyleExporter
PageStyleImporter
PageStyleMgr
PageStyles
PageStyleServiceProvider
PageStyleXmlConverter
PageTaskWorker
PageUtil
PageViewConstants
PageViewUtil
ParamConfig
Parameter
Parameters
PathConfig
PathConfigLCListener
PhotoImporter
PhotoLibConfig
PhotoServiceProvider
PieChartProducer
PinyinHelper
PluginConfig
PluginConfig
PortalHelper
PorterUtil
PorterVisitorFactory
PositionComparator
PostDataParser
PostUserNameCreator
PreNextDocumentsImpl
PreNextDocumentsImplTest
PreviewChannelServiceProvider
ProcessConstants
ProcessService
ProgressMonitorImpl
PropertiesUtil
PropertiesVARProcessor
PublishConfigSaveLogger
PublishConstants
PublishContentActionHandler
PublishContentDefaultObjImpl
PublishContentDocumentImpl
PublishContentImplBase
PublishContentLCListener
PublishContentViewDataImpl
PublishContentViewFieldImpl
PublishContentViewImpl
PublishContentWrapper
PublishDistribution
PublishDistributionCacheMgr
PublishDistributionConfig
PublishDistributionLCListener
PublishDistributionList
PublishDistributionMgr
PublishDistributions
PublishDistributionTargetType
PublishElementConfig
PublishElementFactory
PublishElementsCMSListImpl
PublishElementsCMSObjsImpl
PublishElementsIteratorDocumentsImpl
PublishElementsListImpl
PublishElementType
PublishElementWrapper
PublishErrorLog
PublishErrorLogs
PublishFolderChannelImpl
PublishFolderClassImpl
PublishFolderImplBase
PublishFolderLCListener
PublishFolderWebSiteImpl
PublishFolderWrapper
PublishJobWorker
PublishListenerForPubGovInfo
PublishPageContext
PublishPathCompass
PublishServer
PublishServerConfig
PublishServerConfigMapper
PublishService
PublishServiceProvider
PublishSyncGlobalTuner
PublishTagContext
PublishTask
PublishTaskAnalyzer
PublishTaskContext
PublishTaskDispatcherImpl
PublishTaskDocumentsCacheMgr
PublishTaskLogger
PublishTaskMgrImpl
PublishTaskRuntime
PublishTasks
PublishTaskWorker
PublishUpdateCommderImpl
QueryDocumentCenter
QueryFilter
QueryFilterFactory
QueryFlowDocContext
RadarTreeCreator
Recent
RecentMgr
Recents
RecentService
RecycleClearLogger
RedirectObject
RefreshPropertyMsgReceiver
RegFromConfig
RegionCellInfoLogger
RegionEmploy
RegionEmployMgr
RegionEmploys
RegionEmployServiceProvider
RegionInfo
RegionInfoLogger
RegionInfos
RegionServiceProvider
Relation
RelationMgr
Relations
RelationToXML
Reminder
RemoteAddrUtil
Replace
ReplaceCacheMgr
ReplaceContentServiceProvider
ReplaceMgr
Replaces
ReplyAppendixNotifyHandler
ReplyNotifyHandler
Report
Reports
ReportsToXML
RequestHelper
RequestParamsProcessor
RequestParmasParseException
RequestParmasValidator
RequestXMLDataProcessor
ResetClassInfoOfViewData
ResouceService
ResourceAnalyzer
ResourceMgr
ResourceStyle
ResourceStyleExporter
ResourceStyleImporter
ResourceStyleMgr
ResourceStyles
ResourceStyleServiceProvider
ResourceStyleXmlConverter
ResponseBuddy
ResponseHelper
ResponseOutputException
RestoreObjLogger
ResyncTemplateApdLogger
Right
RightCacheMgr
RightConfigServer
RightDef
RightDefs
RightHelper
RightHostConfig
RightHostFactory
RightHostIndexsConfig
RightHostInfoViewField
RightHostInfoViewGroup
RightHostInfoViewView
RightHostLCListenerForInherit
RightLCListenerForSynSiteMember
RightLogger
RightMgr
RightObjectConfig
RightObjectFactory
Rights
RightSet
RightUpdaterForUser
RightValue
Role
RoleAsToUsersCreator
RoleAuthServer
RoleMgr
Roles
RoleService
RoleServiceProvider
RoleUser
RoleUserCacheMgr
RoleUserIdsMan
RoleUserLogger
RoleUsers
RoleXmlConverter
RollDocumentsChannelsFinder
RuleExecuteHelper
RuleHostLCListnerForCache
SaveMembersListenerForObjectMember
ScanContext
SceneAutoCreator
SceneConnector
SceneNode
SceneNode
SceneNodeAction
SceneNodeParser
SceneNodeToXML
ScenePathsParser
SceneServiceProvider
SceneXMLParser
Schedule
ScheduleLCListenerForFaieldResult
ScheduleLCListenerForServer
ScheduleLogger
ScheduleOper
Schedules
ScheduleService
SchemaCompare
SchemaUpdSqlMaker
SchemaUpdSqlMakerFactory
SecureKey
SecureKeyMgr
SecureKeys
SecureKeyUtil
Securities
Security
SecurityService
SendEmailForInfoViewHandler
ServerConfig
ServerControl
ServiceConfig
ServiceConfigHelper
ServiceConfigStartServer
ServiceConstants
ServiceContext
ServiceControler
ServiceCreationFailException
ServiceExcuteLogger
ServiceFilterConfig
ServiceFilterConfigs
ServiceFilterExample
ServiceHelper
ServiceInvocationException
ServiceListenerConfig
ServiceListenerConfigs
ServiceListenerExample
ServletInputStreamWrapper
SessionListener
SetEmployersOfTemplateLogger
SignUtil
SinglePageTask
SiteCreateFromLogger
SiteExporterForFlow
SiteHitsCountHandler
SiteImportLogger
SiteLicenseMgr
SiteMember
SiteMemberIdsMan
SiteMemberLCListner
SiteMemberMgr
SiteMembers
SiteNameCreator
SiteRecycleClearLogger
SMSSendWorker
SMSSocketSender
SMTPServerConfig
SMTPServerConfigMapper
SMTPServerConfigs
SOAPServiceImpl
Source
SourcePathHelper
Sources
SourceServiceProvider
SourceTypeMgr
Special
SpecialAuthServer
SpecialMgr
Specials
SpecialServiceProvider
SpringBean
SQLBuilder
SQLServerDB
SQLServerUpdateSQL
StartupServlet
StatAnalysisTool
StatAutoRunWorker
StatBonusDataForUser
StatBonusResultForUser
StatDataItem
StatDocCountByChannel
StatDocCountOfGroupByChannel
StatDocCountOfGroupByMetaClass
StatDocCountOfUserByMetaClass
StatefulJobTest
StatFieldMap
StatFieldMaps
StatHost
StatHosts
StatMgr
StatResult
StatResultHolder
StatResults
StatService
Status
Statuses
StatusServiceProvider
StatView
StatViewRel
StatViewRels
StatViews
StdDemoProviderImpl
StreamBuddy
StringXMLConvertorImpl
StyleAndResource
StyleAndResourceMgr
StyleAndResources
StyleCenterMgr
StyleConstants
StyleHelper
StyleItem
StyleItemMgr
StyleItems
StyleItemServiceProvider
StylePathHelper
StyleRepeatNameHelper
SubjectDataInitHelper
SureformService
SybaseASE
SybaseASEText
SybaseASEWithJtds
SymbolC2E
SynChildrenExecutorBase
SynChildrenExecutorForViewEmploy
SynChildrenOfChannelExecutorBase
SystemCollocationConfig
SystemContentStyleMgr
SystemResourceStyleMgr
SystemServiceProvider
SystemWarnerMsgImpl
Table
TableDiff
TableInfo
TableInfos
TableInfosMsgReceiver
TablesCleaner
TagBean
TagBeanAttrInfo
TagBeanAttrInfo.Type
TagBeanInfo
TagBeanInfo.BodyType
TagBeanInfoHelper
TagBeanLCListener
TagBeans
TagChannelChainParser
TagDocbakParser
TagDocument
TagDocumentReader
TagDocumentScanner
TagEBookDirParser
TagFieldInfoEntity
TagFormatHelper
TagFormatterConfig
TagItem
TagMapAreaParser
TagParseHelper
TagParserCMSObj
TagParserCMSObjBase
TagParserCondition
TagParserCondition.Operator
TagParserContentBase
TagParserCRUser
TagParserDateTime
TagParserDefaultObjects
TagParserDetailPage
TagParserDetailPages
TagParserEcho
TagParseResults
TagParserFactory
TagParserFolderBase
TagParserInfoView
TagParserInfoViewData
TagParserInfoViewHelper
TagParserInfoViewNav
TagParserInfoViewNavs
TagParserInfoViewPage
TagParserInfoViews
TagParserNestedTemplate
TagParserNewIcon
TagParserOddOrEven
TagParserOnlyLogic
TagParserPageNav
TagParserPageNav4Detail
TagParserRepeat
TagParserSequenceNumber
TagParserSystemConfig
TagParserUnimpl
TagParserUser
TagParserVariable
TagParserVariableEnum
TagParserVariableSet
TagParserVipMetaData
TagParserWmlImage
TagParserWmlImages
TagPreNextParser
TagWmlContentParser
TargetTypeConfig
TaskDispatcher
TaskWorker
TempApdRel
TempApdRels
TempAppendix
TempAppendixes
TempAppendixXmlConverter
Template
TemplateArgument
TemplateArgumentCacheMgr
TemplateArgumentLCListenerForEmployChanged
TemplateArgumentMgr
TemplateArguments
TemplateAuthHelper
TemplateCacheMgr
TemplateEmploy
TemplateEmployCacheMgrImpl
TemplateEmployDetail
TemplateEmployerIdsMan
TemplateEmployerToXML
TemplateEmployLogger
TemplateEmployMgr
TemplateEmployMgrHelper
TemplateEmploys
TemplateExporter
TemplateImporter
TemplateImportLogger
TemplateInfoEntity
TemplateLCListenerForNestedRename
TemplateLCListenerForTypeChanged
TemplateLCListenerVisualTemplate
TemplateLogger
TemplateMgr
TemplateNestMgr
TemplateParameter
TemplateParameter.Token
TemplateParameter.Type
TemplateParameterList
TemplateParseAngel
TemplateParseConfig
TemplateParseHelper
TemplateParseMgr
TemplateParseService
TemplateQuote
TemplateQuoteMgr
TemplateQuoteMgr0310
TemplateQuotes
TemplateRemoteException
TemplateRightObjImpl
Templates
TemplateSaveListenerForRegionEmploy
TemplateService
TemplateServiceConfig
TemplateServiceFactory
TemplateServiceHelperProvider
TemplateServiceImpl
TemplateServiceProvider
TemplateSettingFactory
TemplatesTemplateSetting
TemplateSyncLogger
TemplateToXML
TemplateXmlConverter
TemplateXmlGenerator
TempPathCleaner
Test
TestIPFD
TestTrsServer
ThreadPool
TimeRange
TimingChartBuilder
TimingChartData
TimingChartProducer
TopicedDocRelation
TopicedDocRelations
ToUsersCreatorConfig
TreeCreator
TreeCreatorTest
TreeItem
TreeNode
TreeNodeCalctor
TRSCKMServer
TRSClusterExtensionImpl
TRSConfigServer
TRSConnectionPool
TRSDBSchema
TRSDBSchemaTest
TRSImportsOrgnize
TRSJspAutoTool
TRSLocaleAuto
TRSMailer
TRSPageParameter
TRSParameter
TRSSearcher
TRSSearcherFactory
TRSSearchUtil
TRSTemplateFacade
TRSToWCMFilter
TRSWCMClusterServer
TrusteeInfo
TrusteeInfos
TxtFileParser
TxtFileParserForContentLink
TypeInfo
TypeInfoMap
TypeNames
UftpConnectionCacheManager
UpdateCommanderConfig
UpdateServer
UpdateSQLGenerator
UpdSqlMaker
UpdUserScheduleCreator
UpgradeObjectMember4SiteMember
URLCoder
URLParser
User
UserCacheMgr
UserDocumentMgr
UserInfoSyncUpdater
UserLCListenerForLogin
UserLicenseMgr
UserListenerForRecordLogin
UserLoginInfo
UserLoginInfoMgr
UserLoginInfos
UserLoginInfoServiceProvider
UserMgr
UserRelateInfoMaker
Users
UserService
UserServiceProvider
UserSetting
UserSettings
UserUtil
ValueConfig
VChannel
VChannelManager
VerifyCode
VerifyCodeServlet
View
ViewDataToXML
ViewDocument
ViewDocumentListenerForPubGovInfo
ViewDocuments
ViewDocumentServiceProvider
ViewDocumentToXML
ViewFieldTemplate
ViewRangeConstants
VisualTemplateServiceProvider
VOIDObject
Vote
VoteData
VoteDatas
VoteIPLog
VoteIPLogs
VoteItem
VoteItems
VoteOption
VoteOptions
Votes
VoteSoapClient
VoteSoapServer
Watermark
Watermark2Xml
Watermarks
WatermarkServiceProvider
WCAG2Helper
WCM52Actor
WCM61AutoList
WCMAJAXServiceHelper
WCMAppConfig
WCMAppendixGenerator
WCMApplyFormProcessServiceHelper
WCMContentPublishConfig
WCMContentPublishConfigToXML
WCMDatainvalidException
WCMDiscoveryFactory
WCMDocAppendixesParserForImporter
WCMDocumentHelper
WCMExcelData
WCMExcelDatas
WCMException
WCMFilter
WCMFilterMakerForContainsChildren
WCMFolderLCListener
WCMFolderPublishConfig
WCMFolderPublishConfigLCListener
WCMFolderPublishConfigToXML
WCMFormFields
WCMFormFieldses
WCMFormInfo
WCMFormInfos
WCMFormMgr
WCMHandler
WCMHelp
WCMHelps
WcmHelpUpdate
WcmIdFieldInit
WcmIdFieldInit
WCMJSPChecker
WCMJSPCheckerTest
WCMObjHelper
WCMObjsHandler
WCMOnlineService
WCMProcessServiceHelper
WCMProcessServiceImpl
WCMPublishElementServiceImpl
WCMPublishHelper
WCMPubStatusConfig
WCMPubStatusConfigs
WCMRightTypes
WCMSystemObject
WCMTagFormatterAllCata
WCMTagFormatterBigNews
WCMTagFormatterChannel
WCMTagFormatterChnlName
WCMTagFormatterColumn
WCMTagFormatterDocumentsBase
WCMTagFormatterOutline
WCMTagFormatterPicNews
WCMTagFormatterPicture
WCMTagFormatterRecPath
WCMTagFormatterRelNews
WCMTagFormatterTemplate
WCMTagParser4FolderHostBase
WCMTagParser4ObjsInChannelBase
WCMTagParserAppendix
WCMTagParserAppendix
WCMTagParserBaseOperation
WCMTagParserChannel
WCMTagParserChannelLogo
WCMTagParserChannels
WCMTagParserChnlInChnlOperation
WCMTagParserChnlOperation
WCMTagParserClassDocuments
WCMTagParserClassIndexGener
WCMTagParserClassInfo
WCMTagParserClassInfos
WCMTagParserCurPage
WCMTagParserDefaultObjectsInChannel
WCMTagParserDefaultObjectsInChannelBase
WCMTagParserDocInChnlOperation
WCMTagParserDocOperation
WCMTagParserDocReply
WCMTagParserDocument
WCMTagParserDocumentChannels
WCMTagParserDocumentForBJGOV
WCMTagParserDocumentLogo
WCMTagParserDocuments
WCMTagParserEPressNews
WCMTagParserEPressNews
WCMTagParserExistDataOfClassInfo
WCMTagParserExpertNews
WCMTagParserHelper
WCMTagParserIcon
WCMTagParserImage
WCMTagParserLayout
WCMTagParserLayoutCell
WCMTagParserLogoBase
WCMTagParserMapArea
WCMTagParserMyViewDatas
WCMTagParserNextDocuments
WCMTagParserPageStyle
WCMTagParserPreDocuments
WCMTagParserPrev
WCMTagParserPreWidget
WCMTagParserRegion
WCMTagParserRelNews
WCMTagParserRelNewsForViewData
WCMTagParserReplace
WCMTagParserResources
WCMTagParserRollDocuments
WCMTagParserSpecialAppendix
WCMTagParserSpecialLogo
WCMTagParserTagCreator
WCMTagparserTopIcon
WCMTagParserViewData
WCMTagParserViewDatas
WCMTagParserViewField
WCMTagParserViewFields
WCMTagParserWebSite
WCMTagParserWebSites
WCMTagParserWidget
WCMTagParserXDcouments
WCMTagParserXDocument
WCMTemplateChildIndexAnalyer
WCMTypes
WCMTypesX
WebServiceHelper
WebSite
WebSiteHelper
WebSiteInfoEntity
WebSiteLCListenerForAutoDocBak
WebSiteLCListenerForContentLink
WebSiteLCListenerForSiteUser
WebSiteLogger
WebSiteRestoreLogger
WebSiteRightHostImpl
WebSiteRightObjImpl
WebSites
WebSiteServiceProvider
WebSiteSubstanceImplBase
WebSiteToXML
WhereSQLMaker
Widget
WidgetConstants
WidgetInstance
WidgetInstanceMgr
WidgetInstances
WidgetInstParameter
WidgetInstParameterMgr
WidgetInstParameters
WidgetMgr
WidgetParameter
WidgetParameterMgr
WidgetParameters
WidgetParameterServiceProvider
WidgetParameterType
WidgetParameterTypes
WidgetPathHelper
Widgets
WidgetServer
WidgetServiceProvider
WidgetXmlConverter
WinCABFileExtractor
WithDrawJobWorker
WordFileService
XDocument
XDocuments
XmlCharCheckedInputStream
XMLConfig
XMLConfigServer
XMLContentRender
XMLConvertorConfigStartServer
XMLConvertorFactory
XMLDataProcessingHandler
XmlDocWithDom4j
XmlObject
XmlObjectPersistentor
XMLParamsValidator
XMLParseException
XMLParsingInfoHolder
XMLParsingPausedException
XMLParsingStatus
XMLToCMSObj
XmlToDocumentConverter
XMLToMetaDBTablesConvertor
XMLToMetaViewData
XMLToMetaViewDataTest
XmlToObjConverter
XmlToObjConverterByDOM4j
XmlToRightConvertor
XSLTViewBuilder
XSLTViewConstrainter
XTagParserObjsInChannelBase
XTemplateExporter
XuguDB
XWCMContImgTagParser
XWCMFileAppendixTagParser
XWCMImageAppendixTagParser
XWCMTagParserComment
XWCMTagParserPageGeneration
ZipEntry
ZipException
ZipFile
ZipInputStream
ZipOutputStream


常量字段值

目录
  • com.trs.*
com.trs.*

com.trs.ajaxservice.ServiceConstants
public static final int | FILTER_TYPE_1MONTH | 7
public static final int | FILTER_TYPE_1WEEK | 6
public static final int | FILTER_TYPE_3DAYS | 5
public static final int | FILTER_TYPE_ALL | 0
public static final int | FILTER_TYPE_DETAIL_TEMPLATE | 12
public static final int | FILTER_TYPE_EDITEDDOCUMENTS | 9
public static final int | FILTER_TYPE_NESTED_TEMPLATE | 10
public static final int | FILTER_TYPE_NEWDOCUMENTS | 1
public static final int | FILTER_TYPE_NODOCUMENTS | 8
public static final int | FILTER_TYPE_OUTLINE_TEMPLATE | 11
public static final int | FILTER_TYPE_PUBLISHDOCUMENTS | 2
public static final int | FILTER_TYPE_PUBLISHEDDOCUMENTS | 3
public static final int | FILTER_TYPE_SELF | 4
public static final int | FILTER_TYPE_UNUSE_TEMPLATE | 19
public static final int | FILTER_TYPE_USEING_TEMPLATE | 18

com.trs.cluster.ClusterConstants
public static final int | EVENT_TYPE_ADD | 1
public static final int | EVENT_TYPE_DELETE | 3
public static final int | EVENT_TYPE_EDIT | 2
public static final int | EVENT_TYPE_TALBE_RELOAD | 4
public static final java.lang.String | MESSAGE_FILE_MODIFIED | "FILE.UPD"
public static final java.lang.String | MESSAGE_FILE_WITHDRAW | "FILE.WITHDRAW"
public static final java.lang.String | MESSAGE_METADATA_APPCREATE | "META.CR"
public static final java.lang.String | MESSAGE_RELOAD_TABLE | "RELOAD.TABLE"
public static final java.lang.String | MESSAGE_REMOVE_TABLE | "REMOVE.TABLE"
public static final java.lang.String | MESSAGE_RREFRESH_PROPERTY | "PO.RP"

com.trs.cms.CMSConstants
public static final int | CONTENT_BODY_FILE | 40
public static final int | CONTENT_BODY_HTML | 20
public static final int | CONTENT_BODY_LINK | 30
public static final int | CONTENT_BODY_NORMAL | 10
public static final int | CONTENT_BODY_UNKNOWN | 0
public static final int | CONTENT_MODAL_COPY | 4
public static final int | CONTENT_MODAL_ENTITY | 1
public static final int | CONTENT_MODAL_LINK | 2
public static final int | CONTENT_MODAL_MIRROR | 3
public static final int | CONTENT_MODAL_QUOTE | 5
public static final int | CONTENT_MODAL_UNKNOWN | 0

com.trs.cms.auth.config.OperationConfig
public static final int MAX_OPERATION_COUNT 100

com.trs.cms.auth.domain.NewRightSet
public static final int | IMPART_MODE_ADD | 1
public static final int | IMPART_MODE_ALL | 4
public static final int | IMPART_MODE_DELETE | 3
public static final int | IMPART_MODE_MODIFY | 2
public static final int | IMPART_MODE_NODE | 0

com.trs.cms.auth.domain.UserMgr
public static final java.lang.String USER_DEFAULT_PASSWORD "trsadmin"

com.trs.cms.auth.persistent.Group
public static final java.lang.String | DB_ID_NAME | "GROUPID"
public static final java.lang.String | DB_TABLE_NAME | "WCMGROUP"
public static final int | OBJ_TYPE | 201

com.trs.cms.auth.persistent.GroupRole
public static final java.lang.String | DB_ID_NAME | "GRPROLEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMGRPROLE"
public static final int | OBJ_TYPE | -1243208931

com.trs.cms.auth.persistent.GroupUser
public static final java.lang.String | DB_ID_NAME | "GRPUSERID"
public static final java.lang.String | DB_TABLE_NAME | "WCMGRPUSER"
public static final int | OBJ_TYPE | -1209578322

com.trs.cms.auth.persistent.ObjectMember
public static final java.lang.String | DB_ID_NAME | "OBJECTMEMBERID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMOBJECTMEMBER"
public static final int | OBJ_TYPE | 547868197

com.trs.cms.auth.persistent.Right
public static final java.lang.String | DB_ID_NAME | "RIGHTID"
public static final java.lang.String | DB_TABLE_NAME | "WCMRIGHT"
public static final int | OBJ_TYPE | 202
public static final int | OPRTYPE_GROUP | 201
public static final int | OPRTYPE_ROLE | 203
public static final int | OPRTYPE_USER | 204

com.trs.cms.auth.persistent.RightDef
public static final java.lang.String | DB_ID_NAME | "RIGHTDEFID"
public static final java.lang.String | DB_TABLE_NAME | "WCMRIGHTDEF"
public static final int | OBJ_TYPE | 205

com.trs.cms.auth.persistent.RightValue
public static final long RIGHTVALUE_WHEN_NOT_EXISTS -1L

com.trs.cms.auth.persistent.Role
public static final int | ADMINISTRATORS_ID | 1
public static final java.lang.String | DB_ID_NAME | "ROLEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMROLE"
public static final int | EVERYONE_ID | 2
public static final int | OBJ_TYPE | 203
public static final int | RANGE_ADMINISTRATOR | -1
public static final int | RANGE_ALL | 1
public static final int | RANGE_GROUP | 0
public static final java.lang.String | ROLEMANAGERS_NAME | "RoleManagers"
public static final int | TYPE_NORMAL | 0
public static final int | TYPE_SITE | -2
public static final int | TYPE_SPECIAL | 0
public static final int | TYPE_SYSTEM | -1

com.trs.cms.auth.persistent.RoleUser
public static final java.lang.String | DB_ID_NAME | "ROLEUSERID"
public static final java.lang.String | DB_TABLE_NAME | "WCMROLEUSER"
public static final int | OBJ_TYPE | -1643208931
public static final int | SITEID_FOR_ALL_SITES | 0
public static final int | SITEID_FOR_SPECIAL_ROLE | -1

com.trs.cms.auth.persistent.TrusteeInfo
public static final java.lang.String | DB_ID_NAME | "TRUSTEEINFOID"
public static final java.lang.String | DB_TABLE_NAME | "WCMTRUSTEEINFO"
public static final int | MODULE_FLOW | 1
public static final int | OBJ_TYPE | 206

com.trs.cms.auth.persistent.User
public static final java.lang.String | DB_ID_NAME | "USERID"
public static final java.lang.String | DB_TABLE_NAME | "WCMUSER"
public static final int | OBJ_TYPE | 204
public static final java.lang.String | SYSTEM_USERNAME | "system"
public static final char | USER_DROPED_NAME_FLAG | 36
public static final int | USER_STATUS_ALL | -1
public static final int | USER_STATUS_APPLY | 0
public static final int | USER_STATUS_DEL | 10
public static final int | USER_STATUS_DROPED | 40
public static final int | USER_STATUS_FORBID | 20
public static final int | USER_STATUS_REG | 30

com.trs.cms.content.DefaultObj
public static final int OBJ_TYPE 8888

com.trs.cms.content.ExtendedField
public static final java.lang.String | DB_ID_NAME | "EXTFIELDID"
public static final java.lang.String | DB_TABLE_NAME | "WCMEXTFIELD"
public static final int | OBJ_TYPE | 4

com.trs.cms.content.WCMSystemObject
public static final int OBJ_TYPE 1

com.trs.cms.process.FlowingDocLogger
public static final int | ACTION_FLAG_NORMAL | 0
public static final int | ACTION_FLAG_PREPROCESS | 1

com.trs.cms.process.FlowingDocOptMarkScouter
public static final java.lang.String | FLOWING_DOC_OPT_MARK | "FLOWOPERATIONMARK"
public static final java.lang.String | FLOWING_DOC_OPT_MARK_ENUM | "FLOWOPERATIONMASKENUM"
public static final java.lang.String | FLOWING_DOC_PRE_OPT_MARK | "FLOWPREOPERATIONMARK"
public static final java.lang.String | IFLOWCONTENT_APPLYFORM_CLASSNAME | "com.trs.components.wcm.process.element.FlowContentApplyFormImpl"
public static final java.lang.String | MARK_FORCE_END | "RESERVED_FORCED_END"

com.trs.cms.process.FlowServerImpl
public static final float INCREASE_FIELD_LENGTH_FACTOR 1.5f

com.trs.cms.process.ProcessConstants
public static final java.lang.String | COMMENTS_DELIM | "~~"
public static final int | FLAG_AUTOTO | 3
public static final int | FLAG_BACK | 2
public static final int | FLAG_EXCEPTION | 6
public static final int | FLAG_FINISHED | 18
public static final int | FLAG_FORCEEND | 7
public static final int | FLAG_FORWARD | 1
public static final int | FLAG_JOIN_AND_AGREE | 10
public static final int | FLAG_JOIN_AND_LAST | 12
public static final int | FLAG_JOIN_SEPERATOR_AND_AGREE | 11
public static final int | FLAG_MAX_NEED_DOWITH | 4
public static final int | FLAG_OTHER_DOWITH | 9
public static final int | FLAG_PASSED | 5
public static final int | FLAG_REFUSED | 8
public static final int | FLAG_RESUBMIT | 4
public static final int | FLAG_START | 0
public static final int | OBJTYPE_FLOWEMPLPOY | 30001
public static final int | OPERATOR_EUQALS | 61
public static final int | OPERATOR_GREATER | 62
public static final int | OPERATOR_GREATER_EUQALS | 1983
public static final int | OPERATOR_LENGTH | -2053034266
public static final int | OPERATOR_LESS | 60
public static final int | OPERATOR_LESS_EUQALS | 1921
public static final int | OPERATOR_LIKE | 2336663
public static final int | OPERATOR_NOT_EUQALS | 1084
public static final int | OPERATOR_NOT_LIKE | -1964662556
public static final int | RULE_TRIGGER_ON_ACCEPT | 1
public static final int | RULE_TRIGGER_ON_BACK | 4
public static final int | RULE_TRIGGER_ON_DOING | 2
public static final int | RULE_TRIGGER_ON_END | 3
public static final int | RULE_TRIGGER_ON_ENTER | 5
public static final int | RULE_TRIGGER_ON_RECEIVE | 0
public static final int | RULE_TRIGGER_ON_REFUSE | 6
public static final java.lang.String | VARNAME_CONTENTTITLE | "CONTENTTITLE"
public static final java.lang.String | VARNAME_CURRDATETIME | "CurrDateTime"
public static final java.lang.String | VARNAME_RECEIVERNAME | "ReceiverName"
public static final java.lang.String | VARNAME_SENDERNAME | "SenderName"
public static final int | WORKMODAL_NORM | 0
public static final int | WORKMODAL_SEPERATOR_END | 3
public static final int | WORKMODAL_SEPERATOR_START | 2
public static final int | WORKMODAL_TOGETHER | 1

com.trs.cms.process.config.ToUsersCreatorConfig
public static final java.lang.String ATTRIBUTES_DILIM ";"

com.trs.cms.process.definition.Flow
public static final java.lang.String | DB_ID_NAME | "FLOWID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFLOW"
public static final int | OBJ_TYPE | 401

com.trs.cms.process.definition.FlowAction
public static final java.lang.String | DB_ID_NAME | "FLOWACTIONID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMFLOWACTION"
public static final int | OBJ_TYPE | 79689646

com.trs.cms.process.definition.FlowCondition
public static final java.lang.String | DB_ID_NAME | "FLOWCONDITIONID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMFLOWCONDITION"
public static final int | OBJ_TYPE | 2142183261

com.trs.cms.process.definition.FlowdocLog
public static final java.lang.String | DB_ID_NAME | "FLOWDOCLOGID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMFLOWDOCLOG"
public static final int | OBJ_TYPE | 1935654805

com.trs.cms.process.definition.FlowEmploy
public static final java.lang.String | DB_ID_NAME | "FLOWEMPLOYID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFLOWEMPLOY"
public static final int | OBJ_TYPE | 30001

com.trs.cms.process.definition.FlowEmployMgr
public static final java.lang.String | SQL_QUERY_FLOW_USED | "EXISTS(SELECT employ.FLOWID FROM WCMFLOWEMPLOY employ WHERE employ.EMPLOYERTYPE=? And employ.EMPLOYERID=? AND employ.FLOWID=WCMFLOW.FLOWID)"
public static final java.lang.String | SQL_QUERY_USEING_FLOW | "EXISTS(SELECT employ.EMPLOYERID FROM WCMFLOWEMPLOY employ WHERE employ.FLOWID=? AND employ.EMPLOYERTYPE=? AND employ.EMPLOYERID="

com.trs.cms.process.definition.FlowNode
public static final int | ACTION_DELETE | 1
public static final int | ACTION_EDIT | 0
public static final int | ACTION_PUBLISH | 2
public static final java.lang.String | DB_ID_NAME | "NODEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFLOWNODE"
public static final int | OBJ_TYPE | 403

com.trs.cms.process.definition.FlowNodeBranch
public static final java.lang.String | DB_ID_NAME | "BRANCHID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFLOWBRANCH"
public static final int | OBJ_TYPE | 404

com.trs.cms.process.definition.FlowNodeField
public static final java.lang.String | DB_ID_NAME | "FLOWNODEFIELDID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMFLOWNODEFIELD"
public static final int | NODE_FIELD_TYPE_GROUP | 1
public static final int | NODE_FIELD_TYPE_NORMAL | 0
public static final int | NODE_FIELD_TYPE_VIEW | 2
public static final int | OBJ_TYPE | 1813441049

com.trs.cms.process.definition.FlowRule
public static final java.lang.String | DB_ID_NAME | "FLOWRULEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMFLOWRULE"
public static final int | OBJ_TYPE | 201723508

com.trs.cms.process.engine.FlowContentConfig
public static final java.lang.String | DB_ID_NAME | "FLOWCONTENTCONFIGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFLOWCONTENTCONFIG"
public static final int | OBJ_TYPE | 2069049653

com.trs.cms.process.engine.FlowDoc
public static final java.lang.String | DB_ID_NAME | "FLOWDOCID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFLOWDOC"
public static final int | OBJ_TYPE | 405

com.trs.cms.process.engine.FlowDocBak
public static final java.lang.String | DB_ID_NAME | "FLOWDOCID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFLOWDOCBAK"
public static final int | OBJ_TYPE | 406

com.trs.components.ckm.TRSCKMServer
public static final java.lang.String | KEY_CKM_ENABLE_AUTOCHECK | "CKM_ENABLE_AUTOCHECK"
public static final java.lang.String | KEY_CKM_ENABLE_EXTRACT | "CKM_ENABLE_EXTRACT"
public static final java.lang.String | KEY_CKM_ENABLE_SIMSEARCH | "CKM_ENABLE_SIMSEARCH"
public static final java.lang.String | KEY_CKM_HAS_OPEN | "CKM_HAS_OPEN"
public static final java.lang.String | KEY_CKM_PASSWORD | "CKM_PASSWORD"
public static final java.lang.String | KEY_CKM_PORT | "CKM_PORT"
public static final java.lang.String | KEY_CKM_SERVER | "CKM_SERVER"
public static final java.lang.String | KEY_CKM_USERNAME | "CKM_USERNAME"

com.trs.components.comment.CommentConstants
public static final int | TOPIC_MOCK_CHANNELID | 2147483647
public static final int | TOPIC_MOCK_SITEID | 2147483647
public static final int | TOPIC_NULL_CHANNELID | -1
public static final java.lang.String | TOPIC_TOKEN_IDSEPERATOR | ","

com.trs.components.comment.domain.NewsComment.CommentEmitEnum
public static final java.lang.String | RANGE_DEFAULT | "TIME"
public static final java.lang.String | RANGE_HIT | "HIT"
public static final java.lang.String | RANGE_TIME | "TIME"
public static final int | STYLE_IPDISPLAY_COMPLETE | 0
public static final int | STYLE_IPDISPLAY_DEFAULT | 1
public static final int | STYLE_IPDISPLAY_HIDDENALL | 2
public static final int | STYLE_IPDISPLAY_HIDDENLAST | 1
public static final java.lang.String | TYPE_DEFAULT | "JS"
public static final java.lang.String | TYPE_JS | "JS"
public static final java.lang.String | TYPE_TEXT | "TEXT"
public static final java.lang.String | TYPE_XML | "XML"

com.trs.components.comment.persistent.DocumentTopic
public static final java.lang.String | DB_ID_NAME | "DOCUMENTTOPICID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMDOCUMENTTOPIC"
public static final int | OBJ_TYPE | 1723559682

com.trs.components.comment.persistent.TopicedDocRelation
public static final java.lang.String | DB_ID_NAME | "TOPICEDDOCRELATIONID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMTOPICEDDOCRELATION"
public static final int | OBJ_TYPE | 1589400188

com.trs.components.common.address.Contact
public static final java.lang.String | DB_ID_NAME | "CONTACTID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCONTACT"
public static final int | OBJ_TYPE | 304

com.trs.components.common.address.ContactGrp
public static final java.lang.String | DB_ID_NAME | "GROUPID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCONTGROUP"
public static final int | OBJ_TYPE | 305

com.trs.components.common.bookmark.BookMark
public static final java.lang.String | DB_ID_NAME | "MARKID"
public static final java.lang.String | DB_TABLE_NAME | "WCMBOOKMARK"
public static final int | OBJ_TYPE | 303

com.trs.components.common.bookmark.MarkKind
public static final java.lang.String | DB_ID_NAME | "KINDID"
public static final java.lang.String | DB_TABLE_NAME | "WCMMARKKIND"
public static final int | OBJ_TYPE | 307

com.trs.components.common.bookmark.MarkShare
public static final java.lang.String | DB_ID_NAME | "SHAREID"
public static final java.lang.String | DB_TABLE_NAME | "WCMMARKSHARE"
public static final int | MARKSHARE_STATE_ALLUSER | 0
public static final int | OBJ_TYPE | 308

com.trs.components.common.calendar.Event
public static final java.lang.String | DB_ID_NAME | "EVENTID"
public static final java.lang.String | DB_TABLE_NAME | "WCMEVENT"
public static final int | OBJ_TYPE | 306

com.trs.components.common.calendar.EventShare
public static final java.lang.String | DB_ID_NAME | "EVENTSHAREID"
public static final java.lang.String | DB_TABLE_NAME | "WCMEVENTSHARE"
public static final int | OBJ_TYPE | 1373899236

com.trs.components.common.calendar.EventType
public static final java.lang.String | DB_ID_NAME | "EVENTTYPEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMEVENTTYPE"
public static final int | OBJ_TYPE | 313
public static final int | TYPE_FLOW_EVENT | 9

com.trs.components.common.conjection.ComponentEntryConfigConstants
public static final int | TYPE_ADVERTISEMENT | 5
public static final int | TYPE_COMMENT | 4
public static final int | TYPE_INFOGATE | 6
public static final int | TYPE_INTERVIEW | 8
public static final int | TYPE_POLL | 3
public static final int | TYPE_SUBSCRIBE | 7

com.trs.components.common.conjection.persistent.EntryConfig
public static final java.lang.String | DB_ID_NAME | "ENTRYCONFIGID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMENTRYCONFIG"
public static final int | OBJ_TYPE | 1640423776

com.trs.components.common.job.JobWorkerType
public static final java.lang.String | DB_ID_NAME | "OPERID"
public static final java.lang.String | DB_TABLE_NAME | "WCMOPER"
public static final int | ID_CHANNEL_SYN | 5
public static final int | ID_CLEAN_TEMPPATH_SCHEDULE | 2
public static final int | ID_DOCUMENT_TOP | 6
public static final int | ID_PUBLISH_SCHEDULE | 4
public static final int | ID_REMIND_JOB | 1
public static final int | ID_STAT_AUTORUN | 7
public static final int | ID_USERDEF_FROM | 100
public static final int | OBJ_TYPE | -463614381

com.trs.components.common.job.Schedule
public static final java.lang.String | DB_ID_NAME | "SCHID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSCHEDULE"
public static final int | MODE_MORE_TIMES_DAY | 2
public static final int | MODE_ONE_TIME_DAY | 1
public static final int | MODE_ONE_TIME_ONLY | 3
public static final int | OBJ_TYPE | 501
public static final int | STATUS_CANCELED | 10
public static final int | STATUS_DONE | 7
public static final int | STATUS_EXPIRED | 8
public static final int | STATUS_FAILED | 9
public static final int | STATUS_NORMAL | 1
public static final int | STATUS_NOTSTART | 0
public static final int | STATUS_PARAM_INVALID | 11
public static final int | STATUS_RUN | 5
public static final int | STATUS_UNKNOWN | -1
public static final int | STATUS_WAIT | 1

com.trs.components.common.message.Message
public static final java.lang.String | DB_ID_NAME | "MSGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMMESSAGE"
public static final int | FLAG_CALLBOARD | 2
public static final int | FLAG_DELETE | 1
public static final int | FLAG_NODELETE | 0
public static final int | FLAG_UNKOWN | -1
public static final int | MESSAGE_STATE_CALLBOARD | 2
public static final int | MESSAGE_STATE_DELETE | 1
public static final int | MESSAGE_STATE_NODELETE | 0
public static final int | OBJ_TYPE | 309
public static final int | TYPE_NORM | 1
public static final int | TYPE_PUBLISH | 2
public static final int | TYPE_WORKFLOW | 3

com.trs.components.common.message.MsgQueue
public static final java.lang.String | DB_ID_NAME | "QUEUEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMMSGQUEUE"
public static final int | OBJ_TYPE | 310
public static final int | TYPE_FLOW_MSG | 2
public static final int | TYPE_NORMAL_MSG | 1
public static final int | TYPE_WARNING | 3

com.trs.components.common.message.MsgReceiver
public static final java.lang.String | DB_ID_NAME | "MSGRECEIVERID"
public static final java.lang.String | DB_TABLE_NAME | "WCMMSGRECEIVER"
public static final int | OBJ_TYPE | 10003

com.trs.components.common.publish.PublishConstants
public static final java.lang.String | DEF_PAGE_FILEEXT | "htm"
public static final java.lang.String | DEF_PAGE_FILENAME_OUTLINE | "index"
public static final int | LOAD_BATCH_CONTENTS_BY_ITERATOR | 2
public static final int | LOAD_BATCH_CONTENTS_BY_OBJECTS | 1
public static final int | OBJTYPE_FOLDERPUBLISHCONFIG | 956
public static final int | OBJTYPE_PUBLISHDISTRIBUTION | 955
public static final int | OBJTYPE_PUBLISHLOG | 826020995
public static final int | OBJTYPE_PUBLISHTASK | -1676813972
public static final int | OBJTYPE_TAGBEAN | 951
public static final int | OBJTYPE_TEMPAPDREL | 952
public static final int | OBJTYPE_TEMPAPPENDIX | 104
public static final int | OBJTYPE_TEMPLATE | 102
public static final int | OBJTYPE_TEMPLATE_ARGUMENT | 957
public static final int | OBJTYPE_TEMPLATEEMPLPOY | 953
public static final int | OBJTYPE_TEMPLATEQUOTE | 954
public static final java.lang.String | PARSE_MODE_EDIT | "EDIT"
public static final java.lang.String | PARSE_MODE_KEY | "_ParseMode_"
public static final java.lang.String | PARSE_MODE_NORM | "NORM"
public static final java.lang.String | PGVAR_ROOT_PATH | "${ROOT_PATH}"
public static final java.lang.String | PGVARNAME_CURREXTRA | "NAV_CURREXTRA"
public static final java.lang.String | PGVARNAME_HEADDESC | "NAV_HEADDESC"
public static final int | PGVARNAME_MAX_LENGTH | 20
public static final java.lang.String | PGVARNAME_NAVEXTRA | "NAV_EXTRA"
public static final java.lang.String | PGVARNAME_NAVIDPRE | "NAV_IDPRE"
public static final java.lang.String | PGVARNAME_NAVPAGES | "NAV_PAGES"
public static final java.lang.String | PGVARNAME_NAVSHOWHEADTAIL | "NAV_SHOWHT"
public static final java.lang.String | PGVARNAME_NAVSHOWPRENEXT | "NAV_SHOWPRENEXT"
public static final java.lang.String | PGVARNAME_NAVTARGET | "NAV_TARGET"
public static final java.lang.String | PGVARNAME_NEXTDESC | "NAV_NEXTDESC"
public static final java.lang.String | PGVARNAME_OUTLINENAV | "OUTLINE_NAV"
public static final java.lang.String | PGVARNAME_PAGECOUNT | "PAGE_COUNT"
public static final java.lang.String | PGVARNAME_PAGEEXT | "PAGE_EXT"
public static final java.lang.String | PGVARNAME_PAGEINDEX | "PAGE_INDEX"
public static final java.lang.String | PGVARNAME_PAGENAME | "PAGE_NAME"
public static final java.lang.String | PGVARNAME_PREDESC | "NAV_PREDESC"
public static final java.lang.String | PGVARNAME_RECORDCOUNT | "RECORD_COUNT"
public static final java.lang.String | PGVARNAME_ROOT_PATH | "ROOT_PATH"
public static final java.lang.String | PGVARNAME_TAILDESC | "NAV_TAILDESC"
public static final java.lang.String | PGVARNAME_WMLIMAGE | "PGVAR_WCMIMG"
public static final java.lang.String | PGVARNAME_WMLIMAGECOUNT | "PAGVAR_WMLIMGCOUNT"
public static final java.lang.String | PGVARNAME_WMLIMAGEDESC | "PAGVAR_WMIMGDESC"
public static final java.lang.String | PGVARNAME_WMLIMAGEFILE | "PAGVAR_WMLIMG"
public static final int | PUBLISH_CONTENT | 3
public static final int | PUBLISH_CONTENT_DIRECT | 10
public static final int | PUBLISH_FOLDER_FULLY | 2
public static final int | PUBLISH_FOLDER_INCREASING | 1
public static final int | PUBLISH_FOLDER_REFRESH | 5
public static final int | PUBLISH_FOLDER_REFRESH_ON_DEL_CONTENT | 12
public static final int | PUBLISH_FOLDER_SYNC | 9
public static final int | PUBLISH_MYSELF_ONLY | 8
public static final int | PUBLISH_RECALL | 7
public static final int | PUBLISH_UNKNOWN | 0
public static final int | QUOTE_FAMILYINDEX_MIN | -2
public static final int | QUOTE_FAMILYINDEX_PARENT | -2
public static final int | QUOTE_FAMILYINDEX_SELF | -1
public static final int | QUOTE_TYPE_ANY | 0
public static final int | QUOTE_TYPE_CONTENT | 1
public static final int | QUOTE_TYPE_FOLDER | 5
public static final java.lang.String | REG_REMOVE_COMMENT | "(?is)<TRS_COMMENT.*?>.*?</TRS_COMMENT>"
public static final java.lang.String | ROOTIMG_DATAPATH | "images/"
public static final int | STATUS_DELETED | 10
public static final int | STATUS_FORBIDDEN | 20
public static final int | STATUS_OPEN | 30
public static final int | STATUS_PUBLISHED | 50
public static final int | STATUS_PUBLISHING | 40
public static final int | STATUS_UNKNOWN | 0
public static final char | TAGID_ATTRIBUTE_FLAG | 35
public static final java.lang.String | TAGID_OWNER | "OWNER"
public static final int | TAGID_OWNER_HASHCODE | 75627155
public static final java.lang.String | TAGID_PARENT | "PARENT"
public static final int | TAGID_PARENT_HASHCODE | -1942094678
public static final java.lang.String | TAGID_RECURL | "_RECURL"
public static final java.lang.String | TAGID_SITE | "SITE"
public static final int | TAGID_SITE_HASHCODE | 2545479
public static final java.lang.String | TAGNAME_COMMENT | "TRS_COMMENT"
public static final java.lang.String | TAGNAME_EXISTSDATA | "TRS_EXISTSDATA"
public static final java.lang.String | TAGNAME_NOTEXISTSDATA | "TRS_NOTEXISTSDATA"
public static final java.lang.String | TAGNAME_PAGE_SEPARATOR | "TRS_PAGE_SEPARATOR"
public static final java.lang.String | TAGNAME_PAGE_SEPARATOR_DETAIL | "TRS_PAGENAV4DETAIL"
public static final java.lang.String | TAGNAME_RECORD | "TRS_RECORD"
public static final java.lang.String | TAGNAME_TEMPLATE | "TRS_TEMPLATE"
public static final java.lang.String | TAGNAME_VARIABLE | "TRS_VARIABLE"
public static final java.lang.String | TAGNAME_VARIABLE_ENUM | "TRS_ENUM"
public static final int | TASK_PRIORITY_HIGH | 9
public static final int | TASK_PRIORITY_LOW | 1
public static final int | TASK_PRIORITY_NORM | 5
public static final int | TASK_PRIORITY_REAL | 13
public static final int | TASK_STATUS_CANCELED | 10
public static final int | TASK_STATUS_EXPIRED | 8
public static final int | TASK_STATUS_FAILED | 9
public static final int | TASK_STATUS_FINISHED | 7
public static final int | TASK_STATUS_FINISHED_WITHWARNINGS | 6
public static final int | TASK_STATUS_PARAM_INVALID | 11
public static final int | TASK_STATUS_PAUSED | 12
public static final int | TASK_STATUS_RUNNING | 5
public static final int | TASK_STATUS_UNKNOWN | 0
public static final int | TASK_STATUS_WAITING | 1
public static final int | TEMPLATE_TYPE_ANY | -1
public static final int | TEMPLATE_TYPE_DETAIL | 2
public static final int | TEMPLATE_TYPE_INFOVIEWPRINT | 3
public static final int | TEMPLATE_TYPE_NESTED | 0
public static final int | TEMPLATE_TYPE_OUTLINE | 1
public static final java.lang.String | TRS_PAGE_SEPARATOR | "<TRS_PAGE_SEPARATOR></TRS_PAGE_SEPARATOR>"

com.trs.components.common.publish.config.persistent.FileNamedStyle
public static final int | NAMED_ID | 1
public static final int | NAMED_MULTIPLETEMPLATE | 3
public static final int | NAMED_PUBTIME | 2

com.trs.components.common.publish.domain.distribute.FileDistributeQueue
public static final int | DELETE_FILE | 2
public static final int | DELETE_PATH | 3
public static final int | UPLOAD_FILE | 1

com.trs.components.common.publish.domain.publisher.PublishTagContext
public static final java.lang.String ATTRNAME_CURR_NESTTAGITEM "CURR.NEST.TEMPNAM"

com.trs.components.common.publish.domain.tagparser.TagDocumentReader
public static final int | ST_ATTRNAME | 3
public static final int | ST_ATTRNAME_END | 4
public static final int | ST_ATTRVALUE_END | 7
public static final int | ST_ATTRVALUE_HASQUOTE | 5
public static final int | ST_ATTRVALUE_HASQUOTE_BEGIN | 13
public static final int | ST_ATTRVALUE_HASQUOTE_ENDCHECK | 14
public static final int | ST_ATTRVALUE_NOQUOTE | 6
public static final int | ST_CHILD_BEGIN | 9
public static final int | ST_CHILD_STRING | 11
public static final int | ST_CHILD_STRING_END | 12
public static final int | ST_CHILD_TAGITEM | 10
public static final int | ST_ENDTAG_CHECK | 93
public static final int | ST_SELFCLOSEDTAG_CHECK | 95
public static final int | ST_STARTTAG_END | 8
public static final int | ST_TAGNAME | 1
public static final int | ST_TAGNAME_END | 2

com.trs.components.common.publish.domain.tagparser.TagParseHelper
public static final int | AUTOFORMATTYPE_HTML | 1
public static final int | AUTOFORMATTYPE_HTMLVALUE | 2
public static final int | AUTOFORMATTYPE_JAVASCRIPT | 3
public static final int | AUTOFORMATTYPE_XML | 4

com.trs.components.common.publish.domain.taskdispatch.IAtomTask
public static final int | RESULT_CONTINUE | 0
public static final int | RESULT_FAILED | 2
public static final int | RESULT_SUSPEND | 1

com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker
public static final int RUN_INTERVAL 100

com.trs.components.common.publish.domain.template.TemplateExporter
public static final java.lang.String TEMPLATETYPEINFOS_XMLFILE "TemplateTypeInfos.xml"

com.trs.components.common.publish.persistent.distribute.PublishDistribution
public static final java.lang.String | DB_ID_NAME | "PUBLISHDISTRIBUTIONID"
public static final java.lang.String | DB_TABLE_NAME | "WCMPUBLISHDISTRIBUTION"
public static final int | OBJ_TYPE | 955

com.trs.components.common.publish.persistent.publisher.FolderPublishConfig
public static final java.lang.String | DB_ID_NAME | "FOLDERPUBLISHCONFIGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFOLDERPUBLISHCONFIG"
public static final int | OBJ_TYPE | 956

com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog
public static final java.lang.String | DB_ID_NAME | "PUBLISHERRORLOGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMPUBLISHERRORLOG"
public static final int | OBJ_TYPE | 826020995

com.trs.components.common.publish.persistent.taskdispatch.PublishTask
public static final java.lang.String | DB_ID_NAME | "PUBLISHTASKID"
public static final java.lang.String | DB_TABLE_NAME | "WCMPUBLISHTASK"
public static final int | OBJ_TYPE | -1676813972
public static final int | TITLE_LENGTH_MAX | 400

com.trs.components.common.publish.persistent.template.TagBean
public static final java.lang.String | DB_ID_NAME | "TAGBEANID"
public static final java.lang.String | DB_TABLE_NAME | "WCMTAGBEANS"
public static final int | OBJ_TYPE | 951

com.trs.components.common.publish.persistent.template.TempApdRel
public static final java.lang.String | DB_ID_NAME | "RECID"
public static final java.lang.String | DB_TABLE_NAME | "WCMTEMPAPDREL"
public static final int | OBJ_TYPE | 952

com.trs.components.common.publish.persistent.template.TempAppendix
public static final java.lang.String | DB_ID_NAME | "TEMPAPPENDIXID"
public static final java.lang.String | DB_TABLE_NAME | "WCMTEMPAPPENDIX"
public static final int | FLAG_DELETED | 1
public static final int | FLAG_NEW | 0
public static final int | FLAG_PUBLISHED | 3
public static final int | FLAG_UPDATED | 2
public static final int | OBJ_TYPE | 104

com.trs.components.common.publish.persistent.template.Template
public static final int | ALL_TEMPLATE | -1
public static final java.lang.String | DB_ID_NAME | "TEMPID"
public static final java.lang.String | DB_TABLE_NAME | "WCMTEMPLATE"
public static final int | DETAIL_TEMPLATE | 2
public static final int | INPUT_TEMPLATE | 0
public static final int | OBJ_TYPE | 102
public static final int | OUTLINE_TEMPLATE | 1

com.trs.components.common.publish.persistent.template.TemplateArgument
public static final java.lang.String | DB_ID_NAME | "TEMPLATEARGUMENTID"
public static final java.lang.String | DB_TABLE_NAME | "WCMTEMPLATEARGUMENT"
public static final int | OBJ_TYPE | 957

com.trs.components.common.publish.persistent.template.TemplateEmploy
public static final java.lang.String | DB_ID_NAME | "TEMPLATEEMPLOYID"
public static final java.lang.String | DB_TABLE_NAME | "WCMTEMPLATEEMPLOY"
public static final int | OBJ_TYPE | 953

com.trs.components.common.publish.persistent.template.TemplateQuote
public static final java.lang.String | DB_ID_NAME | "TEMPLATEQUOTEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMTEMPLATEQUOTE"
public static final int | OBJ_TYPE | 954

com.trs.components.common.publish.persistent.template.Templates
public static final int | DEAL_MODE_CHGNAME | 3
public static final int | DEAL_MODE_IGNORE | 2
public static final int | DEAL_MODE_QUIT | 4
public static final int | DEAL_MODE_UPDATE | 1
public static final int | DETAIL_TEMPLATE | 1
public static final int | INPUT_TEMPLATE | 0
public static final int | OUTLINE_TEMPLATE | 2

com.trs.components.common.publish.widget.ContentStyle
public static final java.lang.String | DB_ID_NAME | "CONTENTSTYLEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMCONTENTSTYLE"
public static final int | OBJ_TYPE | 1791765043

com.trs.components.common.publish.widget.ILayoutGenerator
public static final java.lang.String | COLUMN_CLASS | "trs_column"
public static final java.lang.String | EMPTY_COLUMN_HTML | "<div class=\'c-empty-column\'>\u70b9\u51fb\u6dfb\u52a0\u8d44\u6e90</div>"
public static final java.lang.String | LAYOUT_CLASS | "trs_layout"

com.trs.components.common.publish.widget.Layout
public static final java.lang.String | DB_ID_NAME | "LAYOUTID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMLAYOUT"
public static final int | OBJ_TYPE | 343695236

com.trs.components.common.publish.widget.Master
public static final java.lang.String | DB_ID_NAME | "MASTERID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMMASTER"
public static final int | MASTER_DETAIL | 3
public static final int | MASTER_INDEX | 1
public static final int | MASTER_OUTLINE | 2
public static final int | OBJ_TYPE | 372149948

com.trs.components.common.publish.widget.PageStyle
public static final java.lang.String | DB_ID_NAME | "PAGESTYLEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMPAGESTYLE"
public static final int | OBJ_TYPE | 368170809

com.trs.components.common.publish.widget.ResourceStyle
public static final java.lang.String | DB_ID_NAME | "RESOURCESTYLEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMRESOURCESTYLE"
public static final int | OBJ_TYPE | 1004807208

com.trs.components.common.publish.widget.SpecialAuthServer
public static final int | SPECIAL_ADD | 1
public static final int | SPECIAL_BROWSE | 4
public static final int | SPECIAL_DELETE | 3
public static final int | SPECIAL_EDIT | 2
public static final int | SPECIAL_PUBLISH | 5
public static final int | STYLE_ADD | 11
public static final int | STYLE_BROWSE | 14
public static final int | STYLE_DELETE | 13
public static final int | STYLE_EDIT | 12
public static final int | WIDGET_ADD | 21
public static final int | WIDGET_BROWSE | 24
public static final int | WIDGET_DELETE | 23
public static final int | WIDGET_EDIT | 22

com.trs.components.common.publish.widget.StyleAndResource
public static final java.lang.String | DB_ID_NAME | "STYLEANDRESOURCEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMSTYLEANDRESOURCE"
public static final int | OBJ_TYPE | 1547914097

com.trs.components.common.publish.widget.StyleCenterMgr
public static final int | PAGE_OTHERSTYLE_WCMTYPE | 1
public static final int | STYLE_IS_PRIVATE | 1
public static final int | STYLE_NOT_IS_PRIVATE | 0

com.trs.components.common.publish.widget.StyleConstants
public static final int | CONTENT_STYLE_TYPE | 3
public static final int | PAGE_STYLE_TYPE | 1
public static final java.lang.String | PAGESTYLE_DEFAULT_TEMPLATENAME | "body_template_1.css"
public static final java.lang.String | PAGESTYLE_OTHER_TEMPLATENAME | "other_template_1.css"
public static final int | RESOURCE_STYLE_TYPE | 2
public static final int | STYLE_DEAL_MODE_CHANGE | 3
public static final int | STYLE_DEAL_MODE_IGNORE | 2
public static final int | STYLE_DEAL_MODE_QUIT | 4
public static final int | STYLE_DEAL_MODE_UPDATE | 1

com.trs.components.common.publish.widget.StyleItem
public static final java.lang.String | DB_ID_NAME | "STYLEITEMID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMSTYLEITEM"
public static final int | OBJ_TYPE | 563996873

com.trs.components.common.publish.widget.StylePathHelper
public static final java.lang.String | m_sCommonPath | "style_common"
public static final java.lang.String | m_sCssPath | "style_css"
public static final java.lang.String | m_sCssTemplatePath | "css_template"
public static final java.lang.String | m_sSpecialPath | "special"
public static final java.lang.String | m_sStylePath | "style"
public static final java.lang.String | m_sWcmApp | "app"

com.trs.components.common.publish.widget.Widget
public static final java.lang.String | DB_ID_NAME | "WIDGETID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMWIDGET"
public static final int | OBJ_TYPE | 665370270

com.trs.components.common.publish.widget.WidgetConstants
public static final java.lang.String | CONTENT_STYLE_PARAMETER | "CSTYLEID"
public static final int | FIELD_TYPE_APPENDIX | 8
public static final int | FIELD_TYPE_CHECKBOX | 9
public static final int | FIELD_TYPE_CLASS | 10
public static final int | FIELD_TYPE_ENUMVALUE | -1
public static final int | FIELD_TYPE_HTML | 12
public static final int | FIELD_TYPE_HTML_CHAR | 16
public static final int | FIELD_TYPE_INPUT_SELECT | 15
public static final int | FIELD_TYPE_INT | 19
public static final int | FIELD_TYPE_MULTITEXT | 4
public static final int | FIELD_TYPE_NORMALTEXT | 3
public static final int | FIELD_TYPE_PASSWORD | 2
public static final int | FIELD_TYPE_RADIO | 6
public static final int | FIELD_TYPE_RELDOC | 14
public static final int | FIELD_TYPE_SELCHANNEL | 18
public static final int | FIELD_TYPE_SELECT | 7
public static final int | FIELD_TYPE_SELFDEFINE | 1
public static final int | FIELD_TYPE_SUGGESTION | 17
public static final int | FIELD_TYPE_TIMESTAMP | 11
public static final int | FIELD_TYPE_TRUEORFALSE | 5
public static final int | WIDGET_DEAL_MODE_CHANGE | 3
public static final int | WIDGET_DEAL_MODE_IGNORE | 2
public static final int | WIDGET_DEAL_MODE_UPDATE | 1
public static final java.lang.String | WIDGET_STYLE_PARAMETER | "WSTYLEID"

com.trs.components.common.publish.widget.WidgetInstance
public static final java.lang.String | DB_ID_NAME | "WIDGETINSTANCEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMWIDGETINSTANCE"
public static final int | OBJ_TYPE | 1899510099

com.trs.components.common.publish.widget.WidgetInstParameter
public static final java.lang.String | DB_ID_NAME | "WIDGETINSTPARAMETERID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMWIDGETINSTPARAMETER"
public static final int | MAX_BYTE_LENGTH_4_STRING | 1000
public static final int | OBJ_TYPE | 1568980485

com.trs.components.common.publish.widget.WidgetParameter
public static final java.lang.String | DB_ID_NAME | "WIDGETPARAMETERID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMWIDGETPARAMETER"
public static final int | OBJ_TYPE | 680634027
public static final char | PARAMETER_END_FLAG | 93
public static final char | PARAMETER_START_FLAG | 91

com.trs.components.common.publish.widget.WidgetPathHelper
public static final java.lang.String | m_sCommonPath | "ext-js"
public static final java.lang.String | m_sSpecialPath | "special"
public static final java.lang.String | m_sStylePath | "widget"
public static final java.lang.String | m_sWcmApp | "app"

com.trs.components.common.trsad.ADCom
public static final java.lang.String | DB_ID_NAME | "ADCOMID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMADCOM"
public static final int | OBJ_TYPE | 2024

com.trs.components.common.trsad.ADFile
public static final java.lang.String | DB_ID_NAME | "ADFILEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMADFILE"
public static final int | OBJ_TYPE | 2023

com.trs.components.common.trsad.ADFilePos
public static final java.lang.String | DB_ID_NAME | "ADFILEPOSID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMADFILEPOS"
public static final int | OBJ_TYPE | 2027

com.trs.components.common.trsad.ADPos
public static final java.lang.String | DB_ID_NAME | "ADPOSID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMADPOS"
public static final int | OBJ_TYPE | 2026

com.trs.components.common.trsad.ADType
public static final java.lang.String | DB_ID_NAME | "ADTYPEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMADTYPE"
public static final int | OBJ_TYPE | 2028

com.trs.components.common.trsvote.JVoteConstant
public static final java.lang.String | DB_FIELD_ITEMID | "ITEMID"
public static final java.lang.String | DB_FIELD_OPTIONID | "OPTIONID"
public static final java.lang.String | DB_FIELD_STYLE | "STYLE"
public static final java.lang.String | DB_FIELD_TITLE | "TITLE"
public static final java.lang.String | DB_FIELD_VOTEID | "VOTEID"
public static final java.lang.String | DB_PREFIX | "XWCMVOTE"
public static final java.lang.String | DB_TABLE_VOTE | "XWCMVOTE"
public static final int | OBJ_BASEVOTE | 2098
public static final int | OBJ_VOTE | 2099
public static final int | OBJ_VOTEDATA | 2102
public static final int | OBJ_VOTEIPLOG | 2103
public static final int | OBJ_VOTEITEM | 2100
public static final int | OBJ_VOTEOPTION | 2101
public static final java.lang.String | STYLE_CHECKBOX | "checkbox"
public static final java.lang.String | STYLE_RADIO | "radio"
public static final java.lang.String | TYPE_ITEM | "Item"
public static final java.lang.String | TYPE_OPTION | "Option"

com.trs.components.common.trsvote.Vote
public static final java.lang.String | DB_ID_NAME | "VOTEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMVOTE"
public static final int | OBJ_TYPE | 2099

com.trs.components.common.trsvote.VoteData
public static final java.lang.String | DB_ID_NAME | "DATAID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMVOTEDATA"
public static final int | OBJ_TYPE | 2102

com.trs.components.common.trsvote.VoteIPLog
public static final java.lang.String | DB_ID_NAME | "IPLOGID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMVOTEIPLOG"
public static final int | OBJ_TYPE | 2103

com.trs.components.common.trsvote.VoteItem
public static final java.lang.String | DB_ID_NAME | "ITEMID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMVOTEITEM"
public static final int | OBJ_TYPE | 2100

com.trs.components.common.trsvote.VoteOption
public static final java.lang.String | DB_ID_NAME | "OPTIONID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMVOTEOPTION"
public static final int | OBJ_TYPE | 2101

com.trs.components.gkml.sqgk.constant.ApplyFormConstants
public static final int | APPLY_CERTIFICATENAME_IDENTITY | 2
public static final int | APPLY_CERTIFICATENAME_OFFICER | 4
public static final int | APPLY_CERTIFICATENAME_STUDENT | 1
public static final int | APPLY_CERTIFICATENAME_WORKER | 3
public static final int | APPLYER_TYPE_COMPANY | 2
public static final int | APPLYER_TYPE_PERSON | 1
public static final int | DEAL_TYPE_DEALED | 1
public static final int | DEAL_TYPE_DEALING | 0
public static final int | DEAL_TYPE_REJECT | 2
public static final int | INFO_GET_TYPE_BYSELF | 16
public static final int | INFO_GET_TYPE_EMAIL | 4
public static final int | INFO_GET_TYPE_FIXMAIL | 8
public static final int | INFO_GET_TYPE_POSTMAIL | 1
public static final int | INFO_GET_TYPE_QUICKPOST | 2
public static final int | INFO_PROVIDER_TYPE_CD | 2
public static final int | INFO_PROVIDER_TYPE_DISK | 8
public static final int | INFO_PROVIDER_TYPE_EMAIL | 4
public static final int | INFO_PROVIDER_TYPE_PAGE | 1
public static final java.lang.String | PATH_OF_RESULT_MAIL_TEMPLATE | "/mailTemplateOfSQGK/result.html"
public static final java.lang.String | PATH_OF_SUBMIT_MAIL_TEMPLATE | "/mailTemplateOfSQGK/submit.html"

com.trs.components.gkml.sqgk.persistent.ApplyForm
public static final java.lang.String | DB_ID_NAME | "APPLYFORMID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMAPPLYFORM"
public static final int | OBJ_TYPE | 961799218

com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog
public static final java.lang.String | DB_ID_NAME | "APPLYFORMDEALLOGID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMAPPLYFORMDEALLOG"
public static final int | OBJ_TYPE | 1244921974

com.trs.components.gkml.sqgk.persistent.MailConfig
public static final java.lang.String | DB_ID_NAME | "MAILCONFIGID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMMAILCONFIG"
public static final int | OBJ_TYPE | 1590075171

com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler
public static final int | ATTACH_ALL_APPENDIX | 36182121
public static final int | ATTACH_FIRST_APPENDIX | 551880698

com.trs.components.infoview.InfoViewConstants
public static final java.lang.String | FIELD_ROOTELEMENT | "ROOTELEMENT"
public static final java.lang.String | FIELDNAME_CHANNEL_ID | "ChannelId"
public static final java.lang.String | FIELDNAME_INFOVIEW_ID | "InfoViewId"
public static final java.lang.String | FIELDNAME_INFOVIEWDATA_ID | "DocumentId"
public static final java.lang.String | PREFIX_DBFIELD_NAME | "IVField"
public static final java.lang.String | PREFIX_DBTABLE_NAME | "WCMIVTable"

com.trs.components.infoview.InfoViewDataHelper
public static final java.lang.String KEY_DOM4J "KEY_DOM4JDOCUMENT"

com.trs.components.infoview.InfoViewMgr
public static final float | INCREASE_FIELD_LENGTH_FACTOR | 1.5f
public static final java.lang.String | NS_XSL_URI | "http://www.w3.org/1999/XSL/Transform"
public static final java.lang.String | PUBLISH_SCRIPT_PATH | "infoview/"

com.trs.components.infoview.config.EnumsConfig
public static final int | ENUM_TYPE_LINKED | 1
public static final int | ENUM_TYPE_NORMAL | 0

com.trs.components.infoview.config.GatewayConfig
public static final java.lang.String ROOT_MARK "\\{infogate\\}"

com.trs.components.infoview.extract.XSLTViewBuilder
public static final java.lang.String | FLAG_TRS_OBJ_ID | "trs_obj_id"
public static final java.lang.String | FLAG_TRS_OBJ_PUB | "trs_obj_publish"
public static final java.lang.String | FLAG_TRS_OBJ_TYPE | "trs_obj_type"
public static final java.lang.String | FLAG_TRS_OBJ_TYPENAME | "trs_obj_typename"
public static final java.lang.String | NAME_DATA_FIELD | "DataField"
public static final java.lang.String | NAME_DATA_SECTION | "DataSection"

com.trs.components.infoview.helper.ComplexFieldData
public static final java.lang.String | DB_ID_NAME | "COMPLEXFIELDDATAID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMCOMPLEXFIELDDATA"
public static final int | OBJ_TYPE | 1768965483

com.trs.components.infoview.persistent.InfoView
public static final java.lang.String | DB_ID_NAME | "INFOVIEWID"
public static final java.lang.String | DB_TABLE_NAME | "WCMINFOVIEW"
public static final int | OBJ_TYPE | 1104

com.trs.components.infoview.persistent.InfoViewData
public static final int OBJ_TYPE 3013

com.trs.components.infoview.persistent.InfoViewDocuments
public static final java.lang.String DEFAULT_DOCUMENT_SELECTFIELDS "DocId,DocTitle,CrTime,CrUser,DocChannel"

com.trs.components.infoview.persistent.InfoViewEmploy
public static final java.lang.String | DB_ID_NAME | "INFOVIEWEMPLOYID"
public static final java.lang.String | DB_TABLE_NAME | "WCMINFOVIEWEMPLOY"
public static final int | OBJ_TYPE | 1106

com.trs.components.infoview.persistent.InfoViewField
public static final java.lang.String | DB_ID_NAME | "IVFIELDID"
public static final java.lang.String | DB_TABLE_NAME | "WCMINFOVIEWFIELD"
public static final int | OBJ_TYPE | 1105

com.trs.components.infoview.persistent.InfoViewGroup
public static final java.lang.String | DB_ID_NAME | "IVGROUPID"
public static final java.lang.String | DB_TABLE_NAME | "WCMINFOVIEWGROUP"
public static final int | OBJ_TYPE | 1107

com.trs.components.infoview.persistent.InfoViewSerial
public static final int | SERIAL_PERIOD_DAY | 0
public static final int | SERIAL_PERIOD_FORERVER | -1
public static final int | SERIAL_PERIOD_MONTH | 1
public static final int | SERIAL_PERIOD_YEAR | 2

com.trs.components.infoview.persistent.InfoViewView
public static final java.lang.String | DB_ID_NAME | "IVVIEWID"
public static final java.lang.String | DB_TABLE_NAME | "WCMINFOVIEWVIEW"
public static final int | OBJ_TYPE | 1108

com.trs.components.infoview.publish.tagparser.FormProperty
public static final java.lang.String | GATEWAY_FILE_UPLOAD_URL | "FILEUPLOAD"
public static final java.lang.String | GATEWAY_FORM_ACTION | "POSTACTION"
public static final java.lang.String | GATEWAY_INIT_PAGE | "INITPAGE"
public static final java.lang.String | GATEWAY_READ_FILE_URL | "READFILE"
public static final java.lang.String | GATEWAY_VALID_VERIFY_CODE_URL | "VALIDVERIFYCODEURL"
public static final java.lang.String | GATEWAY_VERIFY_CODE_URL | "VERIFYCODE"

com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs
public static final java.lang.String | KEY_HTTP_URL | "InfoViewNavs.HttpUrl"
public static final java.lang.String | KEY_INFOVIEW_VIEW | "InfoViewNavs.InfoViewView"
public static final java.lang.String | KEY_VIEW_INDEX | "InfoViewNavs.ViewIndex"

com.trs.components.infoview.publish.tagparser.TagParserInfoViews
public static final java.lang.String | KEY_HOSTID | "InfoViews.HostId"
public static final java.lang.String | KEY_INFOVIEW | "InfoViews.InfoView"
public static final java.lang.String | KEY_INFOVIEW_RESOURCE | "InfoViews.Resource"
public static final java.lang.String | KEY_INFOVIEW_VIEW | "InfoViews.InfoViewView"
public static final java.lang.String | KEY_INFOVIEW_VIEWS | "InfoViews.InfoViewViews"

com.trs.components.metadata.MetaDataConstants
public static final int | FIELD_TYPE_APPENDIX | 8
public static final int | FIELD_TYPE_CHECKBOX | 9
public static final int | FIELD_TYPE_CLASS | 10
public static final int | FIELD_TYPE_ENUMVALUE | -1
public static final int | FIELD_TYPE_HTML | 12
public static final int | FIELD_TYPE_HTML_CHAR | 16
public static final int | FIELD_TYPE_INPUT_SELECT | 15
public static final int | FIELD_TYPE_MULTITEXT | 4
public static final int | FIELD_TYPE_NORMALTEXT | 3
public static final int | FIELD_TYPE_PASSWORD | 2
public static final int | FIELD_TYPE_RADIO | 6
public static final int | FIELD_TYPE_RELDOC | 14
public static final int | FIELD_TYPE_SELECT | 7
public static final int | FIELD_TYPE_SELFDEFINE | 1
public static final int | FIELD_TYPE_SUGGESTION | 17
public static final int | FIELD_TYPE_TIMESTAMP | 11
public static final int | FIELD_TYPE_TRUEORFALSE | 5
public static final java.lang.String | FIELDNAME_CHANNEL_ID | "ChannelId"
public static final java.lang.String | FIELDNAME_METADATA_ID | "MetaDataId"
public static final float | INCREASE_FIELD_LENGTH_FACTOR | 1.5f
public static final int | INCREASE_FIELD_LENGTH_LIMIT | 1000
public static final java.lang.String | PREFIX_DBRELATION_NAME | "WCMMetaRelation"
public static final java.lang.String | PREFIX_DBTABLE_NAME | "WCMMetaTable"
public static final java.lang.String | PREFIX_DBVIEW_NAME | "WCMMetaView"

com.trs.components.metadata.center.ClassInfoView
public static final java.lang.String | DB_ID_NAME | "CLASSINFOVIEWID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMCLASSINFOVIEW"
public static final int | OBJ_TYPE | 1787436547

com.trs.components.metadata.center.MetaViewData
public static final int OBJ_TYPE 1936280531

com.trs.components.metadata.center.MetaViewDatas
public static final java.lang.String | DB_TABLE_NAME | "WCMCHNLDOC"
public static final java.lang.String | ID_FIELD_NAME | "RECID"

com.trs.components.metadata.center.MetaViewEmployer
public static final java.lang.String | DB_ID_NAME | "METAVIEWEMPLOYERID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMMETAVIEWEMPLOYER"
public static final int | OBJ_TYPE | 1569209521

com.trs.components.metadata.center.MetaViewEmployers
public static final java.lang.String | DB_ID_NAME | "METAVIEWEMPLOYERID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMMETAVIEWEMPLOYER"
public static final int | OBJ_TYPE | 1400855010

com.trs.components.metadata.definition.ClassInfo
public static final java.lang.String | DB_ID_NAME | "CLASSINFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMCLASSINFO"
public static final int | OBJ_TYPE | 694710472

com.trs.components.metadata.definition.MetaDBField
public static final java.lang.String | DB_FIELD_DBNAME_NAME | "FIELDNAME"
public static final java.lang.String | DB_FIELD_DBTYPE_NAME | "DBTYPE"
public static final java.lang.String | DB_ID_NAME | "DBFIELDINFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMDBFIELDINFO"
public static final int | OBJ_TYPE | 1269981572

com.trs.components.metadata.definition.MetaDBTable
public static final java.lang.String | DB_ID_NAME | "TABLEINFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMTABLEINFO"
public static final java.lang.String | FIELD_NAME_TABLE | "TABLENAME"
public static final int | OBJ_TYPE | 1621427854

com.trs.components.metadata.definition.MetaView
public static final java.lang.String | DB_ID_NAME | "VIEWINFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMVIEWINFO"
public static final int | OBJ_TYPE | 1874605631

com.trs.components.metadata.definition.MetaViewField
public static final java.lang.String | DB_FIELD_DBTYPE_NAME | "DBTYPE"
public static final java.lang.String | DB_ID_NAME | "VIEWFIELDINFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMVIEWFIELDINFO"
public static final int | OBJ_TYPE | 1886731157

com.trs.components.metadata.service.DefaultChannelMakerCenter
public static final java.lang.String SERVICE_ID "defaultChannelCenter"

com.trs.components.metadata.service.MetaDataDefServiceProvider
public static final int | POSITION_AFTER | 0
public static final int | POSITION_BEFORE | 1

com.trs.components.metadata.web.FieldTemplate
public static final int otherTableFieldType -100

com.trs.components.metadata.web.impl.FieldTemplateFactory
public static final int | TEMPLATE_TYPE_ADDEDIT | -1148080597
public static final int | TEMPLATE_TYPE_LSIT | 3322014
public static final int | TEMPLATE_TYPE_VIEW | 3619493

com.trs.components.special.Special
public static final java.lang.String | DB_ID_NAME | "SPECIALID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMSPECIAL"
public static final int | OBJ_TYPE | 1202599794

com.trs.components.special.SpecialMgr
public static final java.lang.String | SPEICAL_ROLENAME | "\u4e13\u9898\u7ef4\u62a4\u4eba\u5458"
public static final java.lang.String | SPEICAL_SITEDATAPATH | "special"
public static final java.lang.String | SPEICAL_SITENAME | "\u4e13\u9898\u5e93"

com.trs.components.stat.BonusRule
public static final java.lang.String | DB_ID_NAME | "BONUSRULEID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMBONUSRULE"
public static final int | HITS_BONUS | 2
public static final int | ISSUEDAMOUNT_BONUS | 1
public static final int | OBJ_TYPE | 631000141

com.trs.components.stat.ChnlDept
public static final java.lang.String | DB_ID_NAME | "CHNLDEPTID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMCHNLDEPT"
public static final int | OBJ_TYPE | 349392592

com.trs.components.stat.DocumentHitsCount
public static final java.lang.String | DB_ID_NAME | "DOCUMENTHITSCOUNTID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMDOCUMENTHITSCOUNT"
public static final int | OBJ_TYPE | 754425548

com.trs.components.stat.HitsCountConstant
public static final int | STAT_STEP_DAY | 5
public static final int | STAT_STEP_MONTH | 6
public static final int | STAT_STEP_YEAR | 7
public static final int | TYPE_1DAY | 1
public static final int | TYPE_1MONTH | 2
public static final int | TYPE_1YEAR | 4
public static final int | TYPE_3MONTH | 3
public static final int | TYPE_ALL | 0

com.trs.components.stat.HostObjDomain
public static final java.lang.String | DB_ID_NAME | "HOSTOBJDOMAINID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMHOSTOBJDOMAIN"
public static final int | OBJ_TYPE | 2071565259

com.trs.components.stat.HostObjHitsCount
public static final java.lang.String | DB_ID_NAME | "HOSTOBJHITSCOUNTID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMHOSTOBJHITSCOUNT"
public static final int | OBJ_TYPE | 1506679112

com.trs.components.stat.StatDocCountByChannel
public static final int | MODAL_STAT_NORM | 1
public static final int | MODAL_STAT_SNAP | 2

com.trs.components.stat.StatDocCountOfGroupByChannel
public static final int | MODAL_STAT_NORM | 1
public static final int | MODAL_STAT_SNAP | 2

com.trs.components.stat.StatDocCountOfGroupByMetaClass
public static final int | MODAL_STAT_NORM | 1
public static final int | MODAL_STAT_SNAP | 2

com.trs.components.stat.StatDocCountOfUserByMetaClass
public static final int | MODAL_STAT_NORM | 1
public static final int | MODAL_STAT_SNAP | 2

com.trs.components.stat.TimeRange
public static final int | STEP_DAY | 1
public static final int | STEP_MONTH | 2
public static final int | STEP_QUARTER | 4
public static final int | STEP_YEAR | 3

com.trs.components.stat.UserLoginInfo
public static final java.lang.String | DB_ID_NAME | "USERLOGININFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMUSERLOGININFO"
public static final int | OBJ_TYPE | 741922780

com.trs.components.wcm.content.ViewDocument
public static final java.lang.String | DB_TABLE_NAME | "WCMDOCUMENT"
public static final java.lang.String | ID_FIELD_NAME | "DOCID"

com.trs.components.wcm.content.ViewDocuments
public static final java.lang.String | DB_TABLE_NAME | "WCMCHNLDOC"
public static final java.lang.String | ID_FIELD_NAME | "RECID"

com.trs.components.wcm.content.domain.DocumentExporter
public static final java.lang.String | HTMFILE_DOCUMENT_LIST_EXPORT | "trs_wcm_viewer_index.htm"
public static final java.lang.String | HTMFILE_DOCUMENT_VIEW_EXPORT | "trs_wcm_viewer_doview.htm"
public static final java.lang.String | REFERENCE_XML | "reference.xml"
public static final java.lang.String | RESOURCE_XML | "resource.xml"

com.trs.components.wcm.content.domain.DocumentMgr
public static final int | POSITION_AFTER | 0
public static final int | POSITION_AFTER_NEW | -1
public static final int | POSITION_BEFORE | 1

com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl
public static final java.lang.String DOCUMENTS_TIMERANGE_INI "Documents.Time.Range.ini"

com.trs.components.wcm.content.persistent.Appendix
public static final int | APPENDIX_FLAG_ALL | -1
public static final int | APPENDIX_FLAG_DOCAPD | 10
public static final int | APPENDIX_FLAG_DOCCON | 0
public static final int | APPENDIX_FLAG_DOCPIC | 20
public static final int | APPENDIX_FLAG_HTMLPIC | 30
public static final int | APPENDIX_FLAG_LINK | 40
public static final java.lang.String | DB_ID_NAME | "APPENDIXID"
public static final java.lang.String | DB_TABLE_NAME | "WCMAPPENDIX"
public static final int | FLAG_ALL | -1
public static final int | FLAG_ALL_APD | 50
public static final int | FLAG_DOCAPD | 10
public static final int | FLAG_DOCCON | 0
public static final int | FLAG_DOCPIC | 20
public static final int | FLAG_HTMLPIC | 30
public static final int | FLAG_LINK | 40
public static final int | OBJ_TYPE | 601

com.trs.components.wcm.content.persistent.AutoBakConfig
public static final java.lang.String | DB_ID_NAME | "AUTOBAKCONFIGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMAUTOBAKCONFIG"
public static final int | OBJ_TYPE | 902
public static final int | OPER_DOC_EDIT | 10
public static final int | OPER_DOC_PUB | 30
public static final int | OPER_DOCSTATUS_CHANGE | 20

com.trs.components.wcm.content.persistent.BaseChannel
public static final int | STATUS_DEL | -1
public static final int | STATUS_NORM | 0
public static final int | STATUS_PARENT_DEL | -2
public static final int | TYPE_ALL | -1

com.trs.components.wcm.content.persistent.Channel
public static final java.lang.String | DB_ID_NAME | "CHANNELID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCHANNEL"
public static final java.lang.String | DEFAULT_CONTENTADDEDITPAGE | "../document/document_addedit.jsp"
public static final java.lang.String | DEFAULT_CONTENTLISTPAGE | "../document/document_list_of_channel.jsp"
public static final java.lang.String | DEFAULT_CONTENTSHOWPAGE | "../document/document_show.jsp"
public static final java.lang.String | DEFAULT_LINKCHANNELPAGE | "../document/document_list_of_linkchannel.jsp"
public static final int | DO_DEPT_FILTER | 11
public static final int | DRAFT_CHANNEL_ID | 0
public static final int | EXCLUDE_FROM_ORDER_MAX | 10
public static final int | MOVE_AS_BROTHER | 0
public static final int | MOVE_AS_CHILD | 1
public static final int | OBJ_TYPE | 101
public static final int | SET_CANPUB | 2
public static final int | SET_CHNL_USER | 9
public static final int | SET_CLICK_PREVIEW | 8
public static final int | SET_INHERIT_DETAIL | 4
public static final int | SET_INHERIT_EXTEND | 7
public static final int | SET_INHERIT_OUTLINE | 5
public static final int | SET_INHERIT_RIGHT | 6
public static final int | SET_ONLYMANAGER | 3
public static final int | SET_ONLYSEARCH | 1
public static final java.lang.String | SUREFORM_ATTR | "SUREFORMFILE"
public static final int | TIME_LIMITED_DEFAULT | 1
public static final int | TIME_LIMITED_NOT | 0
public static final int | TIME_LIMITED_SPECIAL_POINT | 3
public static final int | TIME_LIMITED_SPECIAL_RANGE | 2
public static final int | TYPE_DEFINE_MAX | 20
public static final int | TYPE_INFOVIEW | 13
public static final int | TYPE_LINK | 11
public static final int | TYPE_NORM | 0
public static final int | TYPE_SUREFORM | 12
public static final int | TYPE_TOP_NEWS | 2
public static final int | TYPE_TOP_PICS | 1

com.trs.components.wcm.content.persistent.ChannelContentLink
public static final java.lang.String | DB_ID_NAME | "LINKID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCHANNELCONTENTLINK"
public static final int | OBJ_TYPE | 1952046669

com.trs.components.wcm.content.persistent.ChannelNameMgr
public static final int MAX_CACHE_SIZE 1000

com.trs.components.wcm.content.persistent.ChannelSyn
public static final java.lang.String | DB_ID_NAME | "CHANNELSYNID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCHANNELSYN"
public static final int | OBJ_TYPE | 903

com.trs.components.wcm.content.persistent.ChnlDoc
public static final java.lang.String | DB_ID_NAME | "RECID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCHNLDOC"
public static final int | MODAL_ALL | 0
public static final int | MODAL_ENTITY | 1
public static final int | MODAL_LINK | 2
public static final int | MODAL_MIRROR | 3
public static final int | OBJ_TYPE | 614

com.trs.components.wcm.content.persistent.ContentExtField
public static final java.lang.String | DB_ID_NAME | "CONTENTEXTFIELDID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCONTENTEXTFIELD"
public static final int | OBJ_TYPE | 1319922479

com.trs.components.wcm.content.persistent.ContentLink
public static final java.lang.String | DB_ID_NAME | "CONTENTLINKID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCONTENTLINK"
public static final int | OBJ_TYPE | 106

com.trs.components.wcm.content.persistent.ContentLinkType
public static final java.lang.String | DB_ID_NAME | "CONTENTLINKTYPEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCONTENTLINKTYPE"
public static final int | OBJ_TYPE | 68828714

com.trs.components.wcm.content.persistent.DocBak
public static final java.lang.String | DB_ID_NAME | "DOCBAKID"
public static final java.lang.String | DB_TABLE_NAME | "WCMDOCBAK"
public static final int | OBJ_TYPE | 611

com.trs.components.wcm.content.persistent.DocReply
public static final java.lang.String | DB_ID_NAME | "DOCREPLYID"
public static final java.lang.String | DB_TABLE_NAME | "WCMDOCREPLY"
public static final int | OBJ_TYPE | 603

com.trs.components.wcm.content.persistent.Document
public static final java.lang.String | DB_ID_NAME | "DOCID"
public static final java.lang.String | DB_TABLE_NAME | "WCMDOCUMENT"
public static final int | DOC_FORM_AUDIO | 3
public static final int | DOC_FORM_LITERY | 1
public static final int | DOC_FORM_PIC | 2
public static final int | DOC_FORM_UNKNOWN | 0
public static final int | DOC_FORM_VIDEO | 4
public static final int | DOC_TYPE_FILE | 40
public static final int | DOC_TYPE_HTML | 20
public static final int | DOC_TYPE_LINK | 30
public static final int | DOC_TYPE_NORMAL | 10
public static final int | FLAG_DEFAULT | 0
public static final int | FLAG_UNKNOWN | -1
public static final int | FLAG_USER_DEFINE | 20
public static final int | GET_RELATEDDOC_BY_ALL | 0
public static final int | GET_RELATEDDOC_BY_KEYWORDS | 10
public static final int | GET_RELATEDDOC_BY_RELATION | 30
public static final int | GET_RELATEDDOC_BY_RELWORDS | 20
public static final int | OBJ_TYPE | 605
public static final int | TYPE_FILE | 40
public static final int | TYPE_HTML | 20
public static final int | TYPE_LINK | 30
public static final int | TYPE_NORMAL | 10
public static final int | TYPE_UNKNOWN | 0

com.trs.components.wcm.content.persistent.DocumentSyn
public static final java.lang.String | DB_ID_NAME | "DOCSYNID"
public static final java.lang.String | DB_TABLE_NAME | "WCMDOCSYN"
public static final int | OBJ_TYPE | -20395414

com.trs.components.wcm.content.persistent.HitsCount
public static final java.lang.String | DB_ID_NAME | "HITSCOUNTID"
public static final java.lang.String | DB_TABLE_NAME | "WCMHITSCOUNT"
public static final int | OBJ_TYPE | 613

com.trs.components.wcm.content.persistent.Relation
public static final java.lang.String | DB_ID_NAME | "RELATIONID"
public static final java.lang.String | DB_TABLE_NAME | "WCMRELATION"
public static final int | OBJ_TYPE | 609

com.trs.components.wcm.content.persistent.Replace
public static final java.lang.String | DB_ID_NAME | "REPLACEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMREPLACE"
public static final int | OBJ_TYPE | 105

com.trs.components.wcm.content.persistent.SiteMember
public static final java.lang.String | DB_ID_NAME | "SITEUSERID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSITEUSER"
public static final int | OBJ_TYPE | 1071614564

com.trs.components.wcm.content.persistent.WebSite
public static final int | AUTO_SAVE_CHG_STATUS | 1
public static final int | AUTO_SAVE_EDIT | 0
public static final java.lang.String | AUTO_SAVE_KEY | "SITE_AUTO_SAVE"
public static final int | AUTO_SAVE_PUBLISH | 2
public static final int | COMMON_SITE | 0
public static final java.lang.String | DB_ID_NAME | "SITEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMWEBSITE"
public static final int | OBJ_TYPE | 103
public static final int | PHOTO_SITE | 1
public static final int | PROP_INDEX_UPLOAD | 0
public static final java.lang.String | SAVE_STATUS_KEY | "SITE_SAVE_STATUS"
public static final int | VIDEO_SITE | 2

com.trs.components.wcm.content.trsserver.TRSSearcher
public static final int | SEARCHSCOPE_CONTAINSCHILDREN | 1
public static final int | SEARCHSCOPE_SINGLE | 0

com.trs.components.wcm.customize.UserSetting
public static final int | BOTTOM_REGION_NUMBER | 2
public static final int | CHANNEL_GROUP_TYPE | 800
public static final java.lang.String | DB_ID_NAME | "SETTINGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMUSERSETTING"
public static final int | LEFT_REGION_NUMBER | 3
public static final int | MIDDLE_REGION_NUMBER | 4
public static final int | OBJ_TYPE | 314
public static final int | RIGHT_REGION_NUMBER | 5
public static final int | TOP_REGION_NUMBER | 1

com.trs.components.wcm.individuation.CustomSiteCheckedInfo
public static final java.lang.String | DB_ID_NAME | "CUSTOMSITECHECKEDID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMCUSTOMSITECHECKEDINFO"
public static final int | OBJ_TYPE | 1768965489

com.trs.components.wcm.individuation.Individuation
public static final java.lang.String | DB_ID_NAME | "INDIVIDUATIONID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMINDIVIDUATION"
public static final int | OBJ_TYPE | 1576803201

com.trs.components.wcm.publish.WCMFolderPublishConfig
public static final java.lang.String | DB_ID_NAME | "FOLDERPUBLISHCONFIGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFOLDERPUBLISHINFO"
public static final int | OBJ_TYPE | 1326635776

com.trs.components.wcm.publish.WCMPubStatusConfig
public static final java.lang.String | DB_ID_NAME | "WCMPUBSTATUSCONFIGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMPUBSTATUSCONFIG"
public static final int | OBJ_TYPE | 864684658

com.trs.components.wcm.publish.logo.Logo
public static final java.lang.String | DB_ID_NAME | "LOGOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMLOGO"
public static final int | OBJ_TYPE | 1718600976

com.trs.components.wcm.publish.region.CellInfo
public static final java.lang.String | DB_ID_NAME | "CELLINFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMCELLINFO"
public static final int | OBJ_TYPE | 676972948

com.trs.components.wcm.publish.region.RegionEmploy
public static final java.lang.String | DB_ID_NAME | "REGIONEMPLOYID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMREGIONEMPLOY"
public static final int | OBJ_TYPE | 1209112354

com.trs.components.wcm.publish.region.RegionInfo
public static final java.lang.String | DB_ID_NAME | "REGIONINFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMREGIONINFO"
public static final int | OBJ_TYPE | 1911708670

com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments
public static final int | MODE_NEXT | 1
public static final int | MODE_PRE | 0

com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator
public static final int | RETURN_HTML | 2
public static final int | RETURN_NAME | 1
public static final int | RETURN_NONE | 0

com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer
public static final java.lang.String | INSERT_CHANNEL_CHILDINDEX_QUOTE | "insert into WCMChannelChildIndexQuote (TemplateId, FolderType, FolderId, QuoteChannelId) values(?, ?, ?, ?)"
public static final java.lang.String | QUERY_CHANNEL_CHILDINDEX_QUOTE | "select 1 from WCMChannelChildIndexQuote where FolderType = ? and FolderId=? and QuoteChannelId=?"

com.trs.components.wcm.recent.Recent
public static final java.lang.String | DB_ID_NAME | "RECENTID"
public static final java.lang.String | DB_TABLE_NAME | "WCMRECENT"
public static final int | OBJ_TYPE | 315

com.trs.components.wcm.resource.DocKind
public static final java.lang.String | DB_ID_NAME | "DOCKINDID"
public static final java.lang.String | DB_TABLE_NAME | "WCMDOCKIND"
public static final int | OBJ_TYPE | 602

com.trs.components.wcm.resource.FileType
public static final java.lang.String | DB_ID_NAME | "FILETYPEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFILETYPE"
public static final int | OBJ_TYPE | 604

com.trs.components.wcm.resource.Keyword
public static final java.lang.String | DB_ID_NAME | "KEYWORDID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMKEYWORD"
public static final int | OBJ_TYPE | 734050712

com.trs.components.wcm.resource.Security
public static final java.lang.String | DB_ID_NAME | "SECURITYID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSECURITY"
public static final int | OBJ_TYPE | 607

com.trs.components.wcm.resource.Source
public static final java.lang.String | DB_ID_NAME | "SOURCEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSOURCE"
public static final int | OBJ_TYPE | 608

com.trs.components.wcm.resource.Status
public static final java.lang.String | DB_ID_NAME | "STATUSID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSTATUS"
public static final int | OBJ_TYPE | 610
public static final int | STATUS_ID_AGAIN | 3
public static final int | STATUS_ID_EDITED | 2
public static final int | STATUS_ID_NEW | 1
public static final int | STATUS_ID_NO | 15
public static final int | STATUS_ID_PUBLISHED | 10
public static final int | STATUS_ID_SIGN | 16
public static final int | STATUS_ID_UNKNOWN | 0
public static final int | STATUS_ID_USERDEF | 30
public static final int | STATUS_ID_VERIFY | 18

com.trs.components.wcm.stat.StatFieldMap
public static final java.lang.String | DB_ID_NAME | "STATFIELDMAPID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSTATFIELDMAP"
public static final int | OBJ_TYPE | 1042580721

com.trs.components.wcm.stat.StatHost
public static final java.lang.String | DB_ID_NAME | "STATHOSTID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSTATHOST"
public static final int | OBJ_TYPE | 486152215

com.trs.components.wcm.stat.StatMgr
public static final java.lang.String StatMgrName "StatMgr"

com.trs.components.wcm.stat.StatView
public static final java.lang.String | DB_ID_NAME | "STATVIEWID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSTATVIEW"
public static final int | OBJ_TYPE | 486563092
public static final int | VIEW_TYPE_ALL | 0
public static final int | VIEW_TYPE_FIELD | 2
public static final int | VIEW_TYPE_MAX | 3
public static final int | VIEW_TYPE_MIN | 1
public static final int | VIEW_TYPE_QUERY | 3
public static final int | VIEW_TYPE_TEMPLATE | 1

com.trs.components.wcm.stat.StatViewRel
public static final java.lang.String | DB_ID_NAME | "STATVIEWRELID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSTATVIEWREL"
public static final int | OBJ_TYPE | 313468187

com.trs.components.wcm.stat.chart.BarChartProducer
public static final java.lang.String | PARAM_COMPAREDFIELD | "CompareField"
public static final java.lang.String | PARAM_UNIQUENAME | "UniquerName"
public static final java.lang.String | PARAM_VIEWID | "ViewId"

com.trs.components.wcm.stat.chart.PieChartProducer
public static final java.lang.String | PARAM_COMPAREDFIELD | "ComparedField"
public static final java.lang.String | PARAM_UNIQUENAME | "UniqueName"
public static final java.lang.String | PARAM_VIEWID | "ViewId"

com.trs.components.wcm.stat.domain.ChartConstants
public static final int | CATEGORY_BAR | 1
public static final int | CATEGORY_PIE | 0
public static final int | COUNTER_DIRCACHEFILES | 50
public static final int | DEFAULT_TRUNCLENGTH | 20
public static final java.lang.String | NAME_IMAGE_BOX | "charts"
public static final java.lang.String | NAME_IMAGE_PREFIX | "pc"

com.trs.components.wcm.stat.domain.ChartOption
public static final java.lang.String | GROUPBY_DEFAULT | "UserId"
public static final int | PERIOD_DAY | 0
public static final int | PERIOD_MONTH | 2
public static final int | PERIOD_WEEK | 1
public static final int | PERIOD_YEAR | 3

com.trs.components.wcm.stat.domain.ChartStyle
public static final int | DEFAULT_CATEGORY | 0
public static final int | DEFAULT_HEIGHT | 250
public static final int | DEFAULT_WIDTH | 300

com.trs.components.wcm.stat.domain.TimingChartData
public static final java.lang.String | KEY_DATASET_HEADER | "header"
public static final java.lang.String | KEY_DATASET_VALUES | "values"

com.trs.components.wcm.wcmx.common.WCMTypesX
public static final int | CHNL_TYPE_NEWS | 2
public static final int | CHNL_TYPE_PICS | 1
public static final int | CHNL_TYPE_TRSKEY | 22
public static final int | CHNL_TYPE_X | 21
public static final int | OBJ_ADCOM | 2024
public static final int | OBJ_ADFILE | 2023
public static final int | OBJ_ADFILEPOS | 2027
public static final int | OBJ_ADPOS | 2026
public static final int | OBJ_ADTYPE | 2028
public static final int | OBJ_BOOKINFO | 2100
public static final int | OBJ_DEMO | 2004
public static final int | OBJ_FORUMMSG | 2022
public static final int | OBJ_FORUMTOPIC | 2021
public static final int | OBJ_HUMANSRC | 2003
public static final int | OBJ_INFOVIEW_DATA | 3013
public static final int | OBJ_MYTEST | 2002
public static final int | OBJ_TRSDOC | 2001
public static final int | OBJ_TRSREGINFO | 2007
public static final int | OBJ_USERSIGN | 2006
public static final int | OBJ_WCMDICT | 2005
public static final int | OPERTYPE_WCMTOTRS | 123
public static final int | SPECIAL_CHNL_COUNT | 4

com.trs.components.wcm.wcmx.help.WCMHelp
public static final java.lang.String | DB_ID_NAME | "WCMHELPID"
public static final java.lang.String | DB_TABLE_NAME | "WCMHELP"
public static final int | OBJ_TYPE | 1458815411

com.trs.components.wcm.wcmx.media.MediaRemindedInfo
public static final java.lang.String | DB_ID_NAME | "MEDIAREMINDEDINFOID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMMEDIAREMINDEDINFO"
public static final int | OBJ_TYPE | 4001

com.trs.db.update.DBUpdateLog
public static final java.lang.String | DB_ID_NAME | "DBUPDATELOGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMDBUPDATELOG"
public static final int | DB_TYPE_DB2 | 3
public static final int | DB_TYPE_MYSQL | 7
public static final int | DB_TYPE_ORACLE | 1
public static final int | DB_TYPE_SQL | 2
public static final int | DB_TYPE_SYBASE | 4
public static final int | OBJ_TYPE | 3001
public static final int | TYPE_ADD | 2
public static final int | TYPE_UPDATE | 1

com.trs.infra.BaseServer
public static final java.lang.String APP_VERSION "5.1"

com.trs.infra.MyTypes
public static final int | NO | 0
public static final int | YES | 1

com.trs.infra.ServerControl
public static final java.lang.String APP_VERSION "6.0"

com.trs.infra.common.ContextParameters
public static final int | FILE_ENCODING | 9
public static final int | NESTED_TEMPLATE | 8
public static final int | SAVED_OBJID | 6
public static final int | SCHEDULE_PUBTASK | 7

com.trs.infra.common.WCMRightTypes
public static final int | ALL_BYPASS | -1
public static final int | BT_DATA_EDIT | 2
public static final int | BT_DATA_FILL | 1
public static final int | BT_DATA_VIEW | 0
public static final int | CHNL_ADD | 11
public static final int | CHNL_BROWSE | 14
public static final int | CHNL_DEL | 12
public static final int | CHNL_EDIT | 13
public static final int | CHNL_EXTEND | 19
public static final int | CHNL_MAX_INDEX | 19
public static final int | CHNL_MIN_INDEX | 11
public static final int | CHNL_MOVE | 12
public static final int | CHNL_PREVIEW | 15
public static final int | CHNL_PUB_ALL | 16
public static final int | CHNL_PUB_INC | 17
public static final int | CHNL_RECYCLE | 18
public static final int | CHNL_SETRIGHT | 55
public static final int | CHNL_SETTEMPLATE | 9
public static final int | DOC_ADD | 31
public static final int | DOC_AGAIN | 36
public static final int | DOC_BROWSE | 34
public static final int | DOC_COPY | 34
public static final int | DOC_COPY_ALL | 57
public static final int | DOC_DEL | 33
public static final int | DOC_DELALL | 56
public static final int | DOC_EDIT | 32
public static final int | DOC_MAX_INDEX | 40
public static final int | DOC_MIN_INDEX | 30
public static final int | DOC_MIRROR | 34
public static final int | DOC_MOVE | 18
public static final int | DOC_NEWEDIT | 35
public static final int | DOC_OUTLINE | 30
public static final int | DOC_POSITIONSET | 62
public static final int | DOC_PREVIEW | 38
public static final int | DOC_PUBLISH | 39
public static final int | DOC_QUOTE | 34
public static final int | DOC_RESTORE | 33
public static final int | DOC_RIGTH_SET | 61
public static final int | DOC_SAVE | 80
public static final int | DOC_SIGN | 37
public static final int | EXT_ADMANAGE | 55
public static final int | EXT_APTITUDE | 56
public static final int | EXT_COMMENT | 53
public static final int | EXT_GOVREFER_DEPT | 58
public static final int | EXT_GOVREFER_SITE | 57
public static final int | EXT_INFOGATE | 58
public static final int | EXT_INFOVIEW_MGR | 57
public static final int | EXT_INTERVIEW | 60
public static final int | EXT_INVESTMENT | 54
public static final int | EXT_MAX_INDEX | 60
public static final int | EXT_MIN_INDEX | 53
public static final int | EXT_SUBSCRIBE | 59
public static final int | FLOW_ADD | 41
public static final int | FLOW_DEL | 43
public static final int | FLOW_EDIT | 42
public static final int | FLOW_EXPORT | 44
public static final int | FLOW_IMPORT | 45
public static final int | FLOW_MAX_INDEX | 45
public static final int | FLOW_MIN_INDEX | 41
public static final int | FLOW_MON | 46
public static final int | FLOW_SETRIGHT | 55
public static final int | FLOW_STAT | 47
public static final int | GROUP_ADD_USER | 13
public static final int | GROUP_DEL | 12
public static final int | GROUP_DEL_USER | 14
public static final int | GROUP_SAVE | 11
public static final int | OBJ_ACCESS | 64
public static final long | RIGHTVALUE_WHEN_NOT_EXISTS | -1L
public static final int | ROLE_ADD_USER | 13
public static final int | ROLE_DEL | 12
public static final int | ROLE_DEL_USER | 14
public static final int | ROLE_SAVE | 11
public static final int | SITE_ADD | 0
public static final int | SITE_ADD_USER | 6
public static final int | SITE_DEL | 2
public static final int | SITE_EDIT | 1
public static final int | SITE_MAX_INDEX | 10
public static final int | SITE_MIN_INDEX | 0
public static final int | SITE_PREVIEW | 3
public static final int | SITE_PUB_ALL | 4
public static final int | SITE_PUB_INC | 5
public static final int | Site_SETRIGHT | 7
public static final int | SITE_SETTEMPLATE | 9
public static final int | STATISTIC_MAX_INDEX | 60
public static final int | STATISTIC_MIN_INDEX | 60
public static final int | SYS_CONTENTLINK | 45
public static final int | SYS_DOCSOURCE | 46
public static final int | SYS_DOCSTATUS | 47
public static final int | SYS_EVENTTYPE | 49
public static final int | SYS_MAX_INDEX | 52
public static final int | SYS_MIN_INDEX | 45
public static final int | SYS_OPERTYPE | 52
public static final int | SYS_RIGHT_SET | 59
public static final int | SYS_RIGHTDEF | 51
public static final int | SYS_SECURITY | 50
public static final int | SYS_STATISTIC | 60
public static final int | SYS_WCMBEAN | 48
public static final int | TEMPLATE_ADD | 21
public static final int | TEMPLATE_BACKUP | 27
public static final int | TEMPLATE_CHECK | 25
public static final int | TEMPLATE_DEL | 22
public static final int | TEMPLATE_EDIT | 23
public static final int | TEMPLATE_EXPORT | 24
public static final int | TEMPLATE_IMPORT | 21
public static final int | TEMPLATE_MAX_INDEX | 29
public static final int | TEMPLATE_MIN_INDEX | 21
public static final int | TEMPLATE_OUTLINE | 24
public static final int | TEMPLATE_PREVIEW | 24
public static final int | TEMPLATE_SAVE | 68
public static final int | TEMPLATE_SETARGS | 53
public static final int | TEMPLATE_SYN_APPENDIX | 28
public static final int | TEMPLATE_VIEW | 24
public static final int | USER_DEL | 12
public static final int | USER_SAVE | 11

com.trs.infra.common.WCMTypes
public static final int | LOG_EXCEPTION | 6
public static final int | LOG_FLOW | 3
public static final int | LOG_JOB | 5
public static final int | LOG_OTHER | 7
public static final int | LOG_PUB | 4
public static final int | LOG_SCHEDULE_PUB | 8
public static final int | LOG_SECURITY | 2
public static final int | LOG_SYSTEM | 1
public static final int | LOG_UNKOWN | -1
public static final int | MESSAGE_RECEIVED | 2
public static final int | MESSAGE_SENT | 1
public static final int | MESSAGE_UNREAD | 0
public static final int | NO | 0
public static final int | OBJ_ADDRESS | 301
public static final int | OBJ_ADDRESSGRP | 302
public static final int | OBJ_APPENDIX | 601
public static final int | OBJ_BIGTABLE | 1101
public static final int | OBJ_BIGTABLEFIELD | 1102
public static final int | OBJ_BIGTABLEMPLOY | 1103
public static final int | OBJ_BOOKMARK | 303
public static final int | OBJ_BULLETIN | 804
public static final int | OBJ_CHANNEL | 101
public static final int | OBJ_CHANNELSYN | 107
public static final int | OBJ_CHNLDOC | 614
public static final int | OBJ_CONDITIONBEAN | 411
public static final int | OBJ_CONFIG | 701
public static final int | OBJ_CONTACT | 304
public static final int | OBJ_CONTACTGRP | 305
public static final int | OBJ_CONTENTLINK | 106
public static final int | OBJ_DOCBAK | 611
public static final int | OBJ_DOCKIND | 602
public static final int | OBJ_DOCREPLY | 603
public static final int | OBJ_DOCUMENT | 605
public static final int | OBJ_EVENT | 306
public static final int | OBJ_EVENTTYPE | 313
public static final int | OBJ_EXPIRATION | 606
public static final int | OBJ_EXTENDEDFIELD | 4
public static final int | OBJ_EXTFIELD | 1319922479
public static final int | OBJ_FIELDINFO | 1
public static final int | OBJ_FILETYPE | 604
public static final int | OBJ_FLOW | 401
public static final int | OBJ_FLOWACTION | 402
public static final int | OBJ_FLOWDOC | 405
public static final int | OBJ_FLOWDOCBAK | 406
public static final int | OBJ_FLOWEMPLOYBEAN | 30001
public static final int | OBJ_FLOWEVENTCONDITION | 408
public static final int | OBJ_FLOWEVENTOPERATE | 409
public static final int | OBJ_FLOWNODE | 403
public static final int | OBJ_FLOWNODEBRANCH | 404
public static final int | OBJ_FLOWNODEEVENT | 407
public static final int | OBJ_GROUP | 201
public static final int | OBJ_HITSCOUNT | 613
public static final int | OBJ_INFOVIEW | 1104
public static final int | OBJ_INFOVIEWEMPLOY | 1106
public static final int | OBJ_INFOVIEWFIELD | 1105
public static final int | OBJ_INFOVIEWGROUP | 1107
public static final int | OBJ_INFOVIEWVIEW | 1108
public static final int | OBJ_JOB | 901
public static final int | OBJ_LOG | 702
public static final int | OBJ_LOGTYPE | 703
public static final int | OBJ_MARKKIND | 307
public static final int | OBJ_MARKSHARE | 308
public static final int | OBJ_MEETINGCONT | 802
public static final int | OBJ_MEETINGROOM | 801
public static final int | OBJ_MEETINGUSER | 803
public static final int | OBJ_MESSAGE | 309
public static final int | OBJ_MSGQUEUE | 310
public static final int | OBJ_OPERATIONBEAN | 410
public static final int | OBJ_OPERTYPE | 704
public static final int | OBJ_OTHER | 0
public static final int | OBJ_PUBLISHDISTRIBUTION | 955
public static final int | OBJ_RECENT | 315
public static final int | OBJ_REGIONCELL | 676972948
public static final int | OBJ_REGIONINFO | 1911708670
public static final int | OBJ_RELATION | 609
public static final int | OBJ_REPLACE | 105
public static final int | OBJ_RIGHT | 202
public static final int | OBJ_RIGHTDEF | 205
public static final int | OBJ_ROLE | 203
public static final int | OBJ_SCHEDULE | 501
public static final int | OBJ_SECURITY | 607
public static final int | OBJ_SOURCE | 608
public static final int | OBJ_STATUS | 610
public static final int | OBJ_TABLEINFO | 2
public static final int | OBJ_TASK | 311
public static final int | OBJ_TASKPOOL | 312
public static final int | OBJ_TRUSTEEINFO | 206
public static final int | OBJ_UNKNOWN | -1
public static final int | OBJ_USER | 204
public static final int | OBJ_USERDEF | 2000
public static final int | OBJ_USERSETTING | 314
public static final int | OBJ_WCMEXCELDATA | 612
public static final int | OBJ_WCMFORMFIELDS | 1002
public static final int | OBJ_WCMFORMINFO | 1001
public static final int | OBJ_WCMID | 3
public static final int | OBJ_WCMOBJTRIGGER | 5
public static final int | OBJ_WCMRESULTSET | 888
public static final int | OBJ_WEBSITE | 103
public static final int | OPER_CHNL_ADD | 201
public static final int | OPER_CHNL_DEL | 203
public static final int | OPER_CHNL_EDIT | 202
public static final int | OPER_CHNL_PUB | 204
public static final int | OPER_CHNL_RECYCLE | 205
public static final int | OPER_CHNL_RESCOVER | 206
public static final int | OPER_DOC_ADD | 301
public static final int | OPER_DOC_DEL | 303
public static final int | OPER_DOC_EDIT | 302
public static final int | OPER_DOC_PUB | 304
public static final int | OPER_FLOW_ADD | 401
public static final int | OPER_FLOW_DEL | 403
public static final int | OPER_FLOW_EDIT | 402
public static final int | OPER_OTHER | 0
public static final int | OPER_SCHEDULE_PUB | 107
public static final int | OPER_SITE_ADD | 101
public static final int | OPER_SITE_DEL | 103
public static final int | OPER_SITE_EDIT | 102
public static final int | OPER_SITE_PUB | 104
public static final int | OPER_SITE_RECYCLE | 105
public static final int | OPER_SITE_RESCOVER | 106
public static final int | OPER_SYSTEM_SET | 1
public static final int | OPER_SYSTEM_WARN | 603
public static final int | OPER_TEMPLATE_ADD | 501
public static final int | OPER_TEMPLATE_DEL | 503
public static final int | OPER_TEMPLATE_EDIT | 502
public static final int | OPER_UNKOWN | -1
public static final int | OPER_USER_DEFINE | 2000
public static final int | OPER_USER_LOGIN | 601
public static final int | OPER_USER_LOGOUT | 602
public static final int | PUBLISH_CHILD_NEED | 2
public static final int | PUBLISH_NOT_NEED | 0
public static final int | PUBLISH_SELF_NEED | 1
public static final int | REMIND_BYEMAIL | 1
public static final int | REMIND_BYMOBILE | 2
public static final int | REMIND_DONE | 2
public static final int | REMIND_NO | 0
public static final int | REMIND_ONLINE | 0
public static final int | REMIND_YES | 1
public static final int | TEMPLATE_COLUMN_TAG | 1
public static final int | TEMPLATE_DEAL_MODE_CHANGE | 3
public static final int | TEMPLATE_DEAL_MODE_IGNORE | 2
public static final int | TEMPLATE_DEAL_MODE_QUIT | 4
public static final int | TEMPLATE_DEAL_MODE_UPDATE | 1
public static final int | TEMPLATE_OUTLINE_TAG | 2
public static final int | TEMPLATE_RECORD_TAG | 4
public static final int | TEMPLATEAPD_DEAL_MODE_CHANGE | 3
public static final int | TEMPLATEAPD_DEAL_MODE_IGNORE | 2
public static final int | TEMPLATEAPD_DEAL_MODE_QUIT | 4
public static final int | TEMPLATEAPD_DEAL_MODE_UPDATE | 1
public static final int | XML_IMPORT_NEW | 1
public static final int | XML_IMPORT_RESTORE | 3
public static final int | XML_IMPORT_UPDATE | 2
public static final int | YES | 1

com.trs.infra.config.ConfigConstants
public static final int | ERR_FORMAT_INVALID | 3000
public static final java.lang.String | EXT_FILE_CONFIG | "xml"
public static final java.lang.String | NAME_FILE_BEAN | "beans.xml"
public static final java.lang.String | NAME_FILE_CONFIG | "config.xml"
public static final java.lang.String | NAME_FILE_MAPPING | "mapping.xml"
public static final java.lang.String | TAG_ATTRIBUTE_BEANCLASSNAME | "class"
public static final java.lang.String | TAG_ATTRIBUTE_BEANID | "id"
public static final java.lang.String | TAG_ATTRIBUTE_BEANISSINGLETON | "singleton"
public static final java.lang.String | TAG_ELEMENT_BEAN | "bean"
public static final java.lang.String | TAG_ELEMENT_BEANS | "beans"

com.trs.infra.persistent.BaseObjs
public static final int | BOOKMARK_CURRENT | 0
public static final int | BOOKMARK_FIRST | 1
public static final int | BOOKMARK_LAST | 2

com.trs.infra.persistent.CMyResultSet
public static final java.lang.String | DB_ID_NAME | "WCMRESULTSETID"
public static final java.lang.String | DB_TABLE_NAME | "WCMRESULTSET"
public static final int | OBJ_TYPE | 1000

com.trs.infra.persistent.listener.ObjectLCMonitorServer
public static final int | EVENT_TYPE_ADD | 1
public static final int | EVENT_TYPE_DELETE_AFTER | 4
public static final int | EVENT_TYPE_DELETE_BEFORE | 3
public static final int | EVENT_TYPE_EDIT_AFTER | 2
public static final int | EVENT_TYPE_EDIT_BEFORE | 5

com.trs.infra.support.config.Config
public static final java.lang.String | DB_ID_NAME | "CONFIGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMCONFIG"
public static final int | OBJ_TYPE | 701
public static final int | TYPE_CLUSTER_META | 13
public static final int | TYPE_CUSTOM_ADD | 20
public static final int | TYPE_FILE_PATH | 10
public static final int | TYPE_JOB_SERVER | 15
public static final int | TYPE_NORM | 0
public static final int | TYPE_SCHEDULE_SERVER | 16

com.trs.infra.support.config.ConfigServer
public static final java.lang.String INI_FILENAME "TRSWCMApp.ini"

com.trs.infra.support.config.PathConfig
public static final java.lang.String DELIM ";"

com.trs.infra.support.file.FilesMan
public static final int | FILENAME_DATE_LENGTH | 8
public static final int | FILENAME_FLAG_LENGTH | 2
public static final int | FILENAME_MIN_LENGTH | 22
public static final int | FILENAME_RANDOM_LENGTH | 4
public static final int | FILENAME_TIME_LENGTH | 8
public static final java.lang.String | FLAG_BIGTABLE | "BT"
public static final java.lang.String | FLAG_DOCUMENTSOURCE | "DS"
public static final java.lang.String | FLAG_HELPSEARCH | "HS"
public static final java.lang.String | FLAG_INFOVIEW | "IV"
public static final java.lang.String | FLAG_LOCALPREVIEW | "LV"
public static final java.lang.String | FLAG_LOCALPUB | "LP"
public static final java.lang.String | FLAG_NORMAL | "N0"
public static final java.lang.String | FLAG_PROTECTED | "P0"
public static final java.lang.String | FLAG_SITEFROM | "SF"
public static final java.lang.String | FLAG_SYSTEMTEMP | "ST"
public static final java.lang.String | FLAG_TEMPLATE | "TM"
public static final java.lang.String | FLAG_TRANSFORMER | "TF"
public static final java.lang.String | FLAG_UPLOAD | "U0"
public static final java.lang.String | FLAG_USERTEMP | "UT"
public static final java.lang.String | FLAG_WEBFILE | "W0"
public static final int | PATH_FTP | 2
public static final int | PATH_HTTP | 1
public static final int | PATH_LOCAL | 0

com.trs.infra.support.log.Log
public static final java.lang.String | DB_ID_NAME | "LOGID"
public static final java.lang.String | DB_TABLE_NAME | "WCMLOG"
public static final int | OBJ_TYPE | 702

com.trs.infra.support.log.LogBak
public static final java.lang.String | DB_ID_NAME | "LOGBAKID"
public static final java.lang.String | DB_TABLE_NAME | "WCMLOGBAK"
public static final int | OBJ_TYPE | 805

com.trs.infra.support.log.LogType
public static final int | ID_DEBUG | 4
public static final int | ID_ERROR | 1
public static final int | ID_FATAL | 0
public static final int | ID_INFO | 3
public static final int | ID_WARN | 2

com.trs.infra.support.log.OperType
public static final java.lang.String | DB_ID_NAME | "OPERTYPEID"
public static final java.lang.String | DB_TABLE_NAME | "WCMOPERTYPE"
public static final int | OBJ_TYPE | 123456
public static final int | UNKNOWN_OPERTYPE_ID | 0

com.trs.infra.support.security.SecureKey
public static final java.lang.String | DB_ID_NAME | "SECUREKEYID"
public static final java.lang.String | DB_TABLE_NAME | "WCMSECUREKEY"
public static final int | OBJ_TYPE | 559084253

com.trs.infra.util.AttributesString
public static final java.lang.String ATTRIBUTE_DELIM "&"

com.trs.infra.util.CMyDateTime
public static final long | ADAY_MILLIS | 86400000L
public static final int | DAY | 3
public static final int | DAY_OF_MONTH | 13
public static final int | DAY_OF_YEAR | 15
public static final java.lang.String | DEF_DATE_FORMAT_PRG | "yyyy-MM-dd"
public static final java.lang.String | DEF_DATETIME_FORMAT_DB | "YYYY-MM-DD HH24:MI:SS"
public static final java.lang.String | DEF_DATETIME_FORMAT_PRG | "yyyy-MM-dd HH:mm:ss"
public static final java.lang.String | DEF_TIME_FORMAT_PRG | "HH:mm:ss"
public static final int | FORMAT_DEFAULT | 0
public static final int | FORMAT_LONG | 1
public static final int | FORMAT_SHORT | 2
public static final int | HOUR | 4
public static final int | MINUTE | 5
public static final int | MONTH | 2
public static final int | QUATER | 11
public static final int | SECOND | 6
public static final int | WEEK | 12
public static final int | WEEK_OF_MONTH | 14
public static final int | WEEK_OF_YEAR | 16
public static final int | YEAR | 1

com.trs.infra.util.CopyOfTRSImportsOrgnize
public static final java.lang.String | FLAG_PAGE_START | "include file=\""
public static final int | TYPE_CODE_END | 4
public static final int | TYPE_CODE_START | 3
public static final int | TYPE_COMMENT | 5
public static final int | TYPE_HTML_VALUE | 2
public static final int | TYPE_INCLUDE | 1
public static final int | TYPE_NOFLAG | -1
public static final int | TYPE_PAGE_START | 0

com.trs.infra.util.CPager
public static final int DEFAULT_PAGE_SIZE 20

com.trs.infra.util.ExceptionNumber
public static final int | ERR_CLASS_CONFIG | 11
public static final int | ERR_CLASS_NOTFOUND | 13
public static final int | ERR_CONFIG_MISSING | 14
public static final int | ERR_CONNECTION_GETFAIL | 41
public static final int | ERR_DATACONVERT | 2
public static final int | ERR_DBOP_FAIL | 40
public static final int | ERR_DOC_DUPLICATED | 1300
public static final int | ERR_FACTORY_CONFIG | 1400
public static final int | ERR_FILE_NOTFOUND | 55
public static final int | ERR_FILEOP_CLOSE | 52
public static final int | ERR_FILEOP_FAIL | 50
public static final int | ERR_FILEOP_MOVE | 56
public static final int | ERR_FILEOP_OPEN | 51
public static final int | ERR_FILEOP_READ | 53
public static final int | ERR_FILEOP_WRITE | 54
public static final int | ERR_HOST_NOT_FOUND | 101100
public static final int | ERR_IMPORTFILE_INVALID | 1200
public static final int | ERR_INSTANCE_INVALID | 1351
public static final int | ERR_MESSAGE | 1008
public static final int | ERR_MESSAGE_UNKNOWN_SENDTYPE | 1354
public static final int | ERR_MYEXCEPTION | 1
public static final int | ERR_NET_OPENSTREAM | 111
public static final int | ERR_NEW_INSTANCE | 21
public static final int | ERR_NEWOBJ_INVALID | 1105
public static final int | ERR_NUMOP_FAIL | 30
public static final int | ERR_OBJ_LOCKED | 1013
public static final int | ERR_OBJ_NOTFOUND | 200006
public static final int | ERR_OBJ_NOTLOCKED | 1012
public static final int | ERR_OBJ_NULL | 20
public static final int | ERR_PARAM_INVALID | 10
public static final int | ERR_PROPERTY_NOT_EXIST | 1101
public static final int | ERR_PROPERTY_NOT_MODIFIED | 1107
public static final int | ERR_PROPERTY_NOT_SET | 1106
public static final int | ERR_PROPERTY_NOTALLOW_EDIT | 1102
public static final int | ERR_PROPERTY_TYPE_INVALID | 1103
public static final int | ERR_PROPERTY_VALUE_DUPLICATED | 1108
public static final int | ERR_PROPERTY_VALUE_INVALID | 1104
public static final int | ERR_PUBLISH | 220
public static final int | ERR_PUBLISH_ANALYZE_DETAIL_PAGE_TASK | 229
public static final int | ERR_PUBLISH_CANCEL_TASK | 225
public static final int | ERR_PUBLISH_CREATE_TASK | 224
public static final int | ERR_PUBLISH_DETAIL_TEMPLATE_REQUIRED | 231
public static final int | ERR_PUBLISH_FIlE_DISTRIBUTE | 236
public static final int | ERR_PUBLISH_OUTLINE_TEMPLATE_REQUIRED | 230
public static final int | ERR_PUBLISH_PAGE_GENERATE | 237
public static final int | ERR_PUBLISH_SERVER_NOTSTARTED | 221
public static final int | ERR_PUBLISH_TAG_PARSE | 234
public static final int | ERR_PUBLISH_TAG_PROPERTY_VALUE_INVALID | 235
public static final int | ERR_PUBLISH_TAGDOC_GRAMMAR_ILLEGAL | 232
public static final int | ERR_PUBLISH_TASK_STILLOPEN | 223
public static final int | ERR_PUBLISH_TEMPLATE_SEMANTIC_ANALYSE | 233
public static final int | ERR_PUBLISH_UNKNOWN_CONTENT_TYPE | 227
public static final int | ERR_PUBLISH_UNKNOWN_FOLDER_TYPE | 226
public static final int | ERR_PUBLISH_UNKNOWN_PUBLISH_TYPE | 228
public static final int | ERR_PUBLISH_UPDATE_QUOTING_FOLDERS | 222
public static final int | ERR_REFRESH_NOTIFICATION_SERVER | 1353
public static final int | ERR_RUNTIME_CONFIG | 12
public static final int | ERR_SEND_NOTIFICATION | 1352
public static final int | ERR_SYS_OBJECT_NOT_FOUND | 1100
public static final int | ERR_SYS_PARAM_INVALID | 1102
public static final int | ERR_SYS_PARAM_NOT_SET | 1101
public static final int | ERR_SYS_RUNTIME | 1103
public static final int | ERR_TEMPLATE_HOST_NOT_FOUND | 102101
public static final int | ERR_TEMPLATE_NOT_FOUND | 102100
public static final int | ERR_UNKNOWN | 0
public static final int | ERR_URL_MALFORMED | 110
public static final int | ERR_USER_NORIGHT | 1002
public static final int | ERR_USER_NOTLOGIN | 1001
public static final int | ERR_WCMEXCEPTION | 1100
public static final int | ERR_XML_PROPERTY_REQUIRED | 153
public static final int | ERR_XMLELEMENT_NOTFOUND | 152
public static final int | ERR_XMLFILE_PARSE | 150
public static final int | ERR_XMLSTRING_PARSE | 154
public static final int | ERR_XMLSTRUCTURE_NOTROOT | 151
public static final int | ERR_ZIP_UNZIP | 200
public static final int | INFO_ERROR_MSG | 11111
public static final int | MSG_NOT_SET_DETAIL_TEMPLATE | 200003
public static final int | MSG_NOT_SET_OUTLINE_TEMPLATE | 200002
public static final int | MSG_NOT_SET_PUBLISH_PROPERTIES | 200001
public static final int | MSG_SET_TO_CANNOT_PUBLISH | 200004
public static final int | MSG_STATUS_CANNOT_PUBLISH | 200005

com.trs.infra.util.HttpClientBuddy
public static final java.lang.String | DEFAULT_CONTENT_ENCODING | "UTF-8"
public static final java.lang.String | SERVICE_REQEUST_ENCODING | "ISO-8859-1"

com.trs.infra.util.HttpGet
public static final int TRY_INTERVAL 200

com.trs.infra.util.Report
public static final int | TYPE_DEBUG | 2
public static final int | TYPE_ERROR | 5
public static final int | TYPE_INFO | 3
public static final int | TYPE_WARN | 4

com.trs.infra.util.TRSImportsOrgnize
public static final java.lang.String | FLAG_PAGE_START | "include file=\""
public static final int | TYPE_CODE_END | 4
public static final int | TYPE_CODE_START | 3
public static final int | TYPE_COMMENT | 5
public static final int | TYPE_HTML_VALUE | 2
public static final int | TYPE_INCLUDE | 1
public static final int | TYPE_NOFLAG | -1
public static final int | TYPE_PAGE_START | 0

com.trs.infra.util.cabfile.CabConstants
public static final int | _A_ARCH | 32
public static final int | _A_EXEC | 64
public static final int | _A_HIDDEN | 2
public static final int | _A_NAME_IS_UTF | 128
public static final int | _A_RDONLY | 1
public static final int | _A_SYSTEM | 4
public static final int | cfhdrNEXT_CABINET | 2
public static final int | cfhdrPREV_CABINET | 1
public static final int | cfhdrRESERVE_PRESENT | 4
public static final int | tcompBAD | 15
public static final int | tcompMASK_TYPE | 15
public static final int | tcompTYPE_LZX | 3
public static final int | tcompTYPE_MSZIP | 1
public static final int | tcompTYPE_NONE | 0
public static final int | tcompTYPE_QUANTUM | 2

com.trs.infra.util.database.CDBKeyWords
public static final java.lang.String DB_KEYWORDS_RESOURCE "WCMDBKeyWords.properties"

com.trs.infra.util.database.CDBText
public static final boolean JDBC_IS2 false

com.trs.infra.util.database.DataType
public static final int LENGTH_UNKOWN 0

com.trs.infra.util.database.DBIdManager.IdSeq
public static final int CACHESIZE_DEFAULT 5

com.trs.infra.util.database.DBType
public static final int | DEFAULT_LENGTH | 255
public static final int | DEFAULT_PRECISION | 19
public static final int | DEFAULT_SCALE | 2
public static final int | MAX_PAGE_SIZE | 9999

com.trs.infra.util.database.DBTypes
public static final int | DB2AS400 | 6
public static final int | DB2UDB | 3
public static final int | DB2UDB2 | 5
public static final int | MYSQL | 7
public static final int | ORACLE | 1
public static final int | SQLSERVER | 2
public static final int | SybaseASE | 4
public static final int | UNKOWN | 0

com.trs.infra.util.email.CMyEmail
public static final int | FORMAT_HTML | 1
public static final int | FORMAT_TEXT | 0
public static final java.lang.String | MAIL_HTML_SEPARATOR | "----TRS_Email_Maker"
public static final java.lang.String | MAIL_SEPARATOR | "----TRS_Email_Maker"

com.trs.infra.util.email.CMyMailLog
public static final int | TYPE_RECEIVE_LOG | 2
public static final int | TYPE_SEND_LOG | 1

com.trs.infra.util.ftp.CMyFtp
public static final int | LIST_ALL | 0
public static final int | LIST_DIRS | 2
public static final int | LIST_FILES | 1

com.trs.infra.util.html.HTML
public static final java.lang.String NULL_ATTRIBUTE_VALUE "#DEFAULT"

com.trs.infra.util.html.HtmlComment
public static final java.lang.String | TAG_END | "-->"
public static final java.lang.String | TAG_START | "<!--"

com.trs.infra.util.html.HtmlElement
public static final int | CON_COMMENT | 1
public static final int | CON_ELEMENT | 2
public static final int | CON_TEXT | 3
public static final java.lang.String | TAG_ALONE | " AREA BR HR INPUT LI IMG META PARAM UL "
public static final java.lang.String | TAG_SHORT | " BR LI "
public static final java.lang.String | TAGS_TOSKIP | "p,form,div,span"

com.trs.infra.util.jazzlib.Deflater
public static final int | BEST_COMPRESSION | 9
public static final int | BEST_SPEED | 1
public static final int | DEFAULT_COMPRESSION | -1
public static final int | DEFAULT_STRATEGY | 0
public static final int | DEFLATED | 8
public static final int | FILTERED | 1
public static final int | HUFFMAN_ONLY | 2
public static final int | NO_COMPRESSION | 0

com.trs.infra.util.jazzlib.GZIPInputStream
public static final int | FCOMMENT | 16
public static final int | FEXTRA | 4
public static final int | FHCRC | 2
public static final int | FNAME | 8
public static final int | FTEXT | 1
public static final int | GZIP_MAGIC | 8075

com.trs.infra.util.jazzlib.GZIPOutputStream
public static final int | FCOMMENT | 16
public static final int | FEXTRA | 4
public static final int | FHCRC | 2
public static final int | FNAME | 8
public static final int | FTEXT | 1
public static final int | GZIP_MAGIC | 8075

com.trs.infra.util.jazzlib.ZipEntry
public static final int | DEFLATED | 8
public static final int | STORED | 0

com.trs.infra.util.jazzlib.ZipFile
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final int | CENSIG | 33639248
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDDCD | 6
public static final int | ENDHDR | 22
public static final int | ENDNRD | 4
public static final int | ENDOFF | 16
public static final int | ENDSIG | 101010256
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final int | EXTSIG | 134695760
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final int | LOCSIG | 67324752
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final int | OPEN_DELETE | 2
public static final int | OPEN_READ | 1

com.trs.infra.util.jazzlib.ZipInputStream
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final int | CENSIG | 33639248
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDDCD | 6
public static final int | ENDHDR | 22
public static final int | ENDNRD | 4
public static final int | ENDOFF | 16
public static final int | ENDSIG | 101010256
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final int | EXTSIG | 134695760
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final int | LOCSIG | 67324752
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

com.trs.infra.util.jazzlib.ZipOutputStream
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final int | CENSIG | 33639248
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | DEFLATED | 8
public static final int | ENDCOM | 20
public static final int | ENDDCD | 6
public static final int | ENDHDR | 22
public static final int | ENDNRD | 4
public static final int | ENDOFF | 16
public static final int | ENDSIG | 101010256
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final int | EXTSIG | 134695760
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final int | LOCSIG | 67324752
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final int | STORED | 0

com.trs.infra.util.job.JobFailedResult
public static final java.lang.String | DB_ID_NAME | "RESULTID"
public static final java.lang.String | DB_TABLE_NAME | "WCMJOBEXERESULT"

com.trs.infra.util.key.MacAddressHelper
public static final boolean IS_DEBUG false

com.trs.infra.util.upgrade.Constants
public static final java.lang.String SQL_ESCAPE "\""

com.trs.infra.util.upgrade.dbcompare.Table
public static final char ESCAPE_CHAR 34

com.trs.infra.util.upgrade.dbcompare.TableDiff
public static final int | TYPE_COLDEL | 2
public static final int | TYPE_COLNEW | 0
public static final int | TYPE_COLUPD | 1

com.trs.infra.util.upgrade.dbcompare.TypeInfo
public static final int | CRT_PARAMS_COUNT_NONE | 0
public static final int | CRT_PARAMS_COUNT_ONE | 1
public static final int | CRT_PARAMS_COUNT_TWO | 2

com.trs.infra.util.xml.XmlObjectPersistentor
public static final java.lang.String | DEFAULT_ENCODING | "GBK"
public static final java.lang.String | MAPPINGPATH | "mapping.xml"

com.trs.presentation.common.PageViewConstants
public static final java.lang.String | FILE_VIEW_CONFIG | "/TRSWCMView.ini"
public static final int | OPER_DOCUMENT_COPY | 20
public static final int | OPER_DOCUMENT_MIRROR | 40
public static final int | OPER_DOCUMENT_MOVE | 10
public static final int | OPER_DOCUMENT_QUOTE | 30
public static final java.lang.String | OPER_NODE_URL_KEY | "OPER_NODE_URL"
public static final java.lang.String | OPER_ROOT_URL_KEY | "OPER_ROOT_URL"
public static final int | TREE_OPERATION_DOCUMENT | 1
public static final int | TREE_OPERATION_GROUP_SEL | 19
public static final int | TREE_OPERATION_GRPUSER_MGR | 12
public static final int | TREE_OPERATION_GRPUSER_SEL | 11
public static final int | TREE_OPERATION_GRPUSER_SEL_SPECIAL | 23
public static final int | TREE_OPERATION_OTHER | 0
public static final int | TREE_OPERATION_PORTAL | 4
public static final int | TREE_OPERATION_ROLEUSER_MGR | 14
public static final int | TREE_OPERATION_ROLEUSER_SEL | 13
public static final int | TREE_OPERATION_SITE | 2
public static final int | TREE_OPERATION_SYSUSER_MGR | 10
public static final int | TREE_OPERATION_TEMPLATE | 3
public static final int | TREE_TYPE_CHECKBOX | 1
public static final int | TREE_TYPE_NORMAL | 0
public static final int | TREE_TYPE_RADIOBOX | 2

com.trs.presentation.nav.NavConstatns
public static final int | MULTI_MODE | 2
public static final int | SIMPLE_MODE | 1

com.trs.presentation.nav.TreeCreator
public static final int | VIEW_TYPE_CHECKBOX | 3
public static final int | VIEW_TYPE_NORMAL | 1
public static final int | VIEW_TYPE_RADIO | 2

com.trs.presentation.publish.template.CMyTemplateWizard
public static final int | PARAM_TYPE_BOOLEAN | 20
public static final int | PARAM_TYPE_ENUMER | 10
public static final int | PARAM_TYPE_ENUMER_EXT | 15
public static final int | PARAM_TYPE_INT | 30
public static final int | PARAM_TYPE_LONGTEXT | 50
public static final int | PARAM_TYPE_TEXT | 40

com.trs.presentation.util.LoginHelper
public static final int | ERR_PWD_WRONG | -1
public static final int | ERR_USER_DELETED | 10
public static final int | ERR_USER_FORBID | 20
public static final int | ERR_USER_LOCKED | -2
public static final int | ERR_USER_LOGINED | -3
public static final int | ERR_USER_NOREG | 0
public static final int | ERR_USER_NOTEXIST | -8
public static final int | ERR_USERDEF_FROM | -11
public static final java.lang.String | KEY_PRIVATE_LOGIN | "private_login.key"
public static final java.lang.String | KEY_PUBLIC_LOGIN | "public_login.key"
public static final java.lang.String | ONLINE_USER_VERSION | "OnlineUsersListVersion"
public static final int | RESULT_OK | 30
public static final java.lang.String | SESSION_NAME_USER | "WCM52.loginUser"

com.trs.presentation.util.PageParameter
public static final java.lang.String | TYPE_BOOLEAN | "boolean"
public static final int | TYPE_BOOLEAN_HASHCODE | 64711720
public static final java.lang.String | TYPE_DATE | "date"
public static final int | TYPE_DATE_HASHCODE | 3076014
public static final java.lang.String | TYPE_DATETIME | "datetime"
public static final int | TYPE_DATETIME_HASHCODE | 1793702779
public static final java.lang.String | TYPE_DOUBLE | "double"
public static final int | TYPE_DOUBLE_HASHCODE | -1325958191
public static final java.lang.String | TYPE_FLOAT | "float"
public static final int | TYPE_FLOAT_HASHCODE | 97526364
public static final java.lang.String | TYPE_INT | "int"
public static final int | TYPE_INT_HASHCODE | 104431
public static final java.lang.String | TYPE_LONG | "long"
public static final int | TYPE_LONG_HASHCODE | 3327612
public static final java.lang.String | TYPE_STRING | "string"
public static final int | TYPE_STRING_HASHCODE | -891985903
public static final java.lang.String | TYPE_TIME | "time"
public static final int | TYPE_TIME_HASHCODE | 3560141

com.trs.presentation.util.RequestHelper
public static final java.lang.String | PARAM_NAME_ORDER_FIELD | "OrderField"
public static final java.lang.String | PARAM_NAME_ORDER_TYPE | "OrderType"
public static final java.lang.String | PARAM_NAME_SEARCH_KEY | "SearchKey"
public static final java.lang.String | PARAM_NAME_SEARCH_TABLE | "SearchTable"
public static final java.lang.String | PARAM_NAME_SEARCH_VALUE | "SearchValue"

com.trs.presentation.util.WhereSQLMaker
public static final int | TYPE_BOOLEAN_HASHCODE | 64711720
public static final int | TYPE_DATE_HASHCODE | 3076014
public static final int | TYPE_DATETIME_HASHCODE | 1793702779
public static final int | TYPE_DOUBLE_HASHCODE | -1325958191
public static final int | TYPE_FLOAT_HASHCODE | 97526364
public static final int | TYPE_INT_HASHCODE | 104431
public static final int | TYPE_LONG_HASHCODE | 3327612
public static final int | TYPE_STRING_HASHCODE | -891985903
public static final int | TYPE_TIME_HASHCODE | 3560141

com.trs.scene.tools.SceneNode
public static final int | HEIGHT | 40
public static final int | TYPE_LINE | 3
public static final int | TYPE_NORM | 2
public static final int | TYPE_START | 1
public static final int | WIDTH | 80
public static final int | X_DISTANCE | 20
public static final int | Y_DISTANCE | 80

com.trs.template.InnerExceptionNum
public static final int | ERR_CMYEXCEPTION | 6
public static final int | ERR_LOADPROPERTY | 20
public static final int | ERR_NOSUPPORTEDENCRYPTING | 8
public static final int | ERR_PARAM_INVALID | 0
public static final int | ERR_USER_INVALID | 2
public static final int | ERR_USER_NOTEXIST | 1
public static final int | ERR_USER_NOTLOGIN | 4
public static final int | ERR_WCMEXCEPTION | 5
public static final int | ERR_WRONG_PASSWORD | 3
public static final int | TEST_NOEXCEPTION | -1

com.trs.template.domain.setting.TemplateSettingFactory
public static final java.lang.String PROPERTY_NAME_SETTING "setting.properties"

com.trs.wcm.config.PageOperator
public static final java.lang.String | DB_ID_NAME | "PAGEOPERATORID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMPAGEOPERATOR"
public static final int | OBJ_TYPE | 1766746836

com.trs.wcm.old.WCMExcelData
public static final java.lang.String | DB_ID_NAME | "RECID"
public static final java.lang.String | DB_TABLE_NAME | "WCMEXCELDATA"
public static final int | OBJ_TYPE | 612

com.trs.wcm.old.WCMFormFields
public static final java.lang.String | DB_ID_NAME | "WCMFORMFIELDSID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFORMFIELDS"
public static final int | OBJ_TYPE | 1002

com.trs.wcm.old.WCMFormInfo
public static final java.lang.String | DB_ID_NAME | "WCMFORMINFOID"
public static final java.lang.String | DB_TABLE_NAME | "WCMFORMINFO"
public static final int | OBJ_TYPE | 1001

com.trs.wcm.photo.IImageLibConfig
public static final java.lang.String | SCALE_STYLE_AUTO | "auto"
public static final java.lang.String | SCALE_STYLE_HEIGHT | "height"
public static final java.lang.String | SCALE_STYLE_WIDTH | "width"

com.trs.wcm.photo.ImageLibConstants
public static final java.lang.String | FILENAME_CONFIG | "TRSWCMPhoto.properties"
public static final int | TYPE_QUOTE_FILE | 1
public static final int | TYPE_QUOTE_NONE | 0
public static final int | TYPE_QUOTE_URL | 2

com.trs.wcm.photo.Watermark
public static final java.lang.String | DB_ID_NAME | "WATERMARKID"
public static final java.lang.String | DB_TABLE_NAME | "XWCMWATERMARK"
public static final int | OBJ_TYPE | 1377689707

com.trs.webframework.FrameworkConstants
public static final java.lang.String | ATTR_NAME_CURRPAGE | "CURRPAGE"
public static final java.lang.String | ATTR_NAME_METHODCONTEXT | "MethodContext"
public static final java.lang.String | ATTR_NAME_NUM | "NUM"
public static final java.lang.String | ATTR_NAME_PAGER | "PAGER"
public static final java.lang.String | ATTR_NAME_PAGESIZE | "PAGESIZE"
public static final java.lang.String | ATTR_NAME_RESULT | "RESULT"
public static final int | ATTR_VALUE_FIRST_PAGE_INDEX | 1
public static final int | CONVERTOR_TYPE_DEFAULT | 0
public static final int | CONVERTOR_TYPE_JSON | 4
public static final int | CONVERTOR_TYPE_URI | 1
public static final int | CONVERTOR_TYPE_URL | 2
public static final int | CONVERTOR_TYPE_XML | 3
public static final java.lang.String | DATA_TYPE_BOOLEAN | "boolean"
public static final int | DATA_TYPE_BOOLEAN_HASHCODE | 64711720
public static final java.lang.String | DATA_TYPE_DATE | "date"
public static final int | DATA_TYPE_DATE_HASHCODE | 3076014
public static final java.lang.String | DATA_TYPE_DATETIME | "datetime"
public static final int | DATA_TYPE_DATETIME_HASHCODE | 1793702779
public static final java.lang.String | DATA_TYPE_DOUBLE | "double"
public static final int | DATA_TYPE_DOUBLE_HASHCODE | -1325958191
public static final java.lang.String | DATA_TYPE_FLOAT | "float"
public static final int | DATA_TYPE_FLOAT_HASHCODE | 97526364
public static final java.lang.String | DATA_TYPE_INT | "int"
public static final int | DATA_TYPE_INT_HASHCODE | 104431
public static final java.lang.String | DATA_TYPE_LONG | "long"
public static final int | DATA_TYPE_LONG_HASHCODE | 3327612
public static final java.lang.String | DATA_TYPE_PINT | "pint"
public static final int | DATA_TYPE_PINT_HASHCODE | 3441023
public static final java.lang.String | DATA_TYPE_STRING | "string"
public static final int | DATA_TYPE_STRING_HASHCODE | -891985903
public static final java.lang.String | DATA_TYPE_TIME | "time"
public static final int | DATA_TYPE_TIME_HASHCODE | 3560141
public static final java.lang.String | FLAG_SELF_DEFINED_CONTENT_TYPE | "SelfDefinedContentType"
public static final java.lang.String | FLAG_UPLOAD_FILE_EXT | "FileExt"
public static final int | METHOD_TYPE_ALL | 96673
public static final int | METHOD_TYPE_DELETE | -1335458389
public static final int | METHOD_TYPE_FINDBYID | -678768405
public static final int | METHOD_TYPE_FINDBYIDS | 433016040
public static final int | METHOD_TYPE_QUERY | 107944136
public static final int | METHOD_TYPE_SAVE | 3522941
public static final java.lang.String | NAME_PARAMETER_FROM_TABLE | "FromTable"
public static final java.lang.String | NAME_PARAMETER_METHOD_NAME | "MethodName"
public static final java.lang.String | NAME_PARAMETER_OBJECT_ID | "ObjectId"
public static final java.lang.String | NAME_PARAMETER_OBJECT_IDS | "ObjectIds"
public static final java.lang.String | NAME_PARAMETER_ORDERBY_FIELD | "OrderBy"
public static final java.lang.String | NAME_PARAMETER_ORDERBY_TYPE | "OrderType"
public static final java.lang.String | NAME_PARAMETER_SELECTED_FIELDS | "SelectFields"
public static final java.lang.String | NAME_PARAMETER_SERVICE_ID | "ServiceId"

com.trs.webframework.context.MethodContextHelper
public static final java.lang.String | ATTR_NAME_SEARCHKEY | "SearchKey"
public static final java.lang.String | ATTR_NAME_SEARCHVALUE | "SearchValue"
public static final java.lang.String | NAME_PARAMETER_ORDERBY_FIELD | "OrderField"
public static final java.lang.String | NAME_PARAMETER_ORDERBY_TYPE | "OrderType"

com.trs.webframework.controler.servlet.BaseValidator
public static final java.lang.String | PARAM_NAME_ORDER_FIELD | "OrderField"
public static final java.lang.String | PARAM_NAME_ORDER_TYPE | "OrderType"
public static final java.lang.String | PARAM_NAME_SEARCH_KEY | "SearchKey"
public static final java.lang.String | PARAM_NAME_SEARCH_TABLE | "SearchTable"
public static final java.lang.String | PARAM_NAME_SEARCH_VALUE | "SearchValue"

com.trs.webframework.exception.ServiceInvocationException
public static final java.lang.String | ERROR_CODE_DEFAULT | "5000"
public static final java.lang.String | SUGGESTION_DEFAULT | ""

com.trs.webframework.xmlserver.parser.StreamBuddy
public static final java.lang.String STREAM_ENCODING_DEFAULT "UTF-8"

com.trs.webframework.xmlserver.parser.XMLParsingStatus
public static final int | BEFORE_PARSING | 0
public static final int | INVOCATION_DOCUMENTEND_DETECTED | 4
public static final int | INVOCATION_NAME_DETECTED | 2
public static final int | INVOCATION_PARAM_DETECTED | 3
public static final int | INVOCATION_TYPE_DETECTED | 1

com.trs.webframework.xmlserver.server.InvocationTypes
public static final int | DEFAULT | 4
public static final int | DELETE | 1
public static final int | FINDBYID | 5
public static final int | FINDBYIDS | 7
public static final int | QUERY | 3
public static final int | SAVE | 2
public static final int | SELF_DEFINED | 4
public static final java.lang.String | STR_DELETE | "delete"
public static final java.lang.String | STR_FINDBYID | "findbyid"
public static final java.lang.String | STR_FINDBYIDS | "findbyids"
public static final java.lang.String | STR_QUERY | "query"
public static final java.lang.String | STR_SAVE | "save"
public static final java.lang.String | STR_SELFDEFINED | "selfdefined"

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


已过时项目列表

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架

已过时的 API

目录
  • 已过时的类
  • 已过时的字段
  • 已过时的方法
  • 已过时的构造方法
已过时的类
com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr
使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM）
Description:
ftp cache manager for file distribution.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl
使用 FileDistributorImpFtpByTRS 代替 Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor implementation on ftp
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl
使用 FileDistributorImpFileLocal 代替,其实只是启用了新的名称,并没有实质性变化 Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor implementation on local disk.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
com.trs.components.infoview.extract.manifest.FileNew
实际并没有使用 /xsf:xDocumentClass/xsf:fileNew/xsf:initialXmlDocument

已过时的字段
com.trs.components.common.publish.persistent.template.Template.ALL_TEMPLATE
please use PublishConstants.TEMPLATE_TYPE_ANY
com.trs.components.common.publish.persistent.template.Template.DETAIL_TEMPLATE
please use PublishConstants.TEMPLATE_TYPE_DETAIL
com.trs.components.common.publish.persistent.template.Template.INPUT_TEMPLATE
please use PublishConstants.TEMPLATE_TYPE_NESTED
com.trs.components.common.publish.persistent.template.Template.OUTLINE_TEMPLATE
please use PublishConstants.TEMPLATE_TYPE_OUTLINE

已过时的方法
com.trs.cms.auth.domain.RoleMgr.addUser(User, Role)
权限模型调整，需要引入站点id.
com.trs.infra.persistent.BaseObj.cloneToNewWCMObj()
com.trs.infra.util.CMyString.cutStr(String, int)
已经由函数truncateStr替代
com.trs.service.impl.PublishService.delete(BaseChannel)
根本就没有没有使用，声明为废弃的，以标识
com.trs.service.impl.PublishService.delete(Document)
根本就没有没有使用，声明为废弃的，以标识
com.trs.service.impl.PublishService.delete(Document, Channel)
根本就没有没有使用，声明为废弃的，以标识
com.trs.service.impl.PublishService.delete(Documents)
根本就没有没有使用，声明为废弃的，以标识
com.trs.infra.util.CMyFile.deleteDir(String, boolean)
to use deleteDir(String _sPath) or deleteDir(File _path) instead.
com.trs.components.metadata.service.MetaDataCenterServiceProvider.deleteViewDatas(MethodContext)
改成Document的监听机制，转向调用ViewDocument.delete方法
com.trs.infra.util.CMyURLEncoder.encode(String)
The resulting string may vary depending on the platform's default encoding. Instead, use the encode(String,String) method to specify the encoding.
com.trs.infra.util.jazzlib.Inflater.end()
Just clear all references to inflater instead.
com.trs.infra.util.jazzlib.Deflater.end()
Just clear all references to deflater instead.
com.trs.components.common.publish.domain.tagparser.TagParseHelper.findNestedTemplate(TagItem, IPublishFolder)
Returns the template defined in the specified nested template tag item.
com.trs.components.common.publish.domain.tagparser.TagParseHelper.formatTextIfNeeded(TagItem, String)
Formats the text if AUTOFORMAT=true.
Related tag attributes: AUTOFORMAT, AUTOFORMATTYPE
com.trs.presentation.locale.LocaleServer.getDateTime(String)
no need?
com.trs.infra.support.file.FilesMan.getTempAppendixFilePath(int, int, boolean)
to use getTemplateAppendixPath(WebSite.OBJ_TYPE, _nSiteId, _nPathType, _bCreateWhenNotExists) instead please.
com.trs.infra.util.CMyString.isEmptyStr(String)
由函数 isEmpty 替换
com.trs.components.common.publish.domain.template.CSSResourceProcessor.parseContent(String, HashMap)
use processConent instead.
com.trs.cms.auth.domain.RoleMgr.removeUser(User, Role)
com.trs.ajaxservice.RoleServiceProvider.saveRoles(MethodContext)
com.trs.components.wcm.soap.WordFileService.sendFileBase64(String, String, String)
表达的意思和执行的操作不一致,已经使用新的接口[receiveFileByBase64]替代
com.trs.components.common.publish.domain.tagparser.TagParseHelper.separatePagesOld(String)
com.trs.components.comment.domain.Management.setNewsId(int)
被 setNews(int, String) 替代
com.trs.infra.persistent.db.DBManager.sqlExecuteQuery(String)
错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。
com.trs.infra.persistent.db.DBManager.sqlExecuteQuery(String, int)
错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。 获取指定SQL语句的字符集
com.trs.infra.util.CMyString.toUnicode(String)
含义模糊，已经使用toISO_8859替换
com.trs.components.common.publish.domain.tagparser.TagParseHelper.truncateTextIfNeeded(TagItem, String)
Truncates the text length if needed (when NUM>0).
Related properties in tag item: NUM, TRUNCATEDFLAG
if NUM>0, to truncate the text with the flag as tail.

已过时的构造方法
com.trs.components.common.publish.domain.publisher.PublishTagContext(IPublishElement, Map, PublishPageContext)
constructor
com.trs.components.common.publish.domain.publisher.PublishTagContext(IPublishElement, Map, PublishTagContext)
constructor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


API 帮助

上一个 下一个 框架 无框架

此 API 文档的组织方式

此 API（应用程序编程接口）文档包含对应于导航栏中的项目的页面，如下所述。

概述

概述 页面是此 API 文档的首页，提供了所有软件包的列表及其摘要。此页面也可能包含这些软件包的总体描述。

软件包

每个软件包都有一个页面，其中包含它的类和接口的列表及其摘要。此页面可以包含四个类别：

  • 接口（斜体）
  • 类
  • 枚举
  • 异常
  • 错误
  • 注释类型

类/接口

每个类、接口、嵌套类和嵌套接口都有各自的页面。其中每个页面都由三部分（类/接口描述、摘要表，以及详细的成员描述）组成：

  • 类继承图
  • 直接子类
  • 所有已知子接口
  • 所有已知实现类
  • 类/接口声明
  • 类/接口描述

  • 嵌套类摘要
  • 字段摘要
  • 构造方法摘要
  • 方法摘要

  • 字段详细信息
  • 构造方法详细信息
  • 方法详细信息
每个摘要条目都包含该项目的详细描述的第一句。摘要条目按字母顺序排列，而详细描述则按其在源代码中出现的顺序排列。这样保持了程序员所建立的逻辑分组。

注释类型

每个注释类型都有各自的页面，其中包含以下部分：

  • 注释类型声明
  • 注释类型描述
  • 必需元素摘要
  • 可选元素摘要
  • 元素详细信息

枚举

每个枚举都有各自的页面，其中包含以下部分：

  • 枚举声明
  • 枚举描述
  • 枚举常量摘要
  • 枚举常量详细信息

使用

每个已文档化的软件包、类和接口都有各自的“使用”页面。此页面介绍了使用给定类或软件包的任何部分的软件包、类、方法、构造方法和字段。对于给定的类或接口 A，其“使用”页面包含 A 的子类、声明为 A 的字段、返回 A 的方法，以及带有类型为 A 的参数的方法和构造方法。访问此页面的方法是：首先转至软件包、类或接口，然后单击导航栏中的“使用”链接。

树（类分层结构）

对于所有软件包，有一个 类分层结构 页面，以及每个软件包的分层结构。每个分层结构页面都包含类的列表和接口的列表。从 java.lang.Object 开始，按继承结构对类进行排列。接口不从 java.lang.Object 继承。
  • 查看“概述”页面时，单击“树”将显示所有软件包的分层结构。
  • 查看特定软件包、类或接口页面时，单击“树”将仅显示该软件包的分层结构。

已过时的 API

已过时的 API 页面列出了所有已过时的 API。一般由于进行了改进并且通常提供了替代的 API，所以建议不要使用已过时的 API。在将来的实施过程中，可能会删除已过时的 API。

索引

索引 包含按字母顺序排列的所有类、接口、构造方法、方法和字段的列表。

上一个/下一个

这些链接使您可以转至下一个或上一个类、接口、软件包或相关页面。

框架/无框架

这些链接用于显示和隐藏 HTML 框架。所有页面均具有有框架和无框架两种显示方式。

序列化表格

每个可序列化或可外部化的类都有其序列化字段和方法的描述。此信息对重新实现者有用，而对使用 API 的开发者则没有什么用处。尽管导航栏中没有链接，但您可以通过下列方式获取此信息：转至任何序列化类，然后单击类描述的“另请参见”部分中的“序列化表格”。

常量字段值

常量字段值页面列出了静态最终字段及其值。

此帮助文件适用于使用标准 doclet 生成的 API 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


概述列表

所有类

软件包
com.trs
com.trs.ajaxservice
com.trs.ajaxservice.listener
com.trs.ajaxservice.logger
com.trs.ajaxservice.xmlconvertors
com.trs.cluster
com.trs.cluster.receiver
com.trs.cms
com.trs.cms.auth
com.trs.cms.auth.config
com.trs.cms.auth.domain
com.trs.cms.auth.logger
com.trs.cms.auth.persistent
com.trs.cms.content
com.trs.cms.logger
com.trs.cms.process
com.trs.cms.process.config
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.cms.process.engine.creators
com.trs.cms.process.engine.handlers
com.trs.cms.process.xml
com.trs.components.ckm
com.trs.components.comment
com.trs.components.comment.domain
com.trs.components.comment.persistent
com.trs.components.comment.publish.helper
com.trs.components.comment.publish.tagparser
com.trs.components.comment.service
com.trs.components.common.address
com.trs.components.common.bookmark
com.trs.components.common.calendar
com.trs.components.common.conjection
com.trs.components.common.conjection.helper
com.trs.components.common.conjection.persistent
com.trs.components.common.conjection.service
com.trs.components.common.job
com.trs.components.common.message
com.trs.components.common.message.notify
com.trs.components.common.publish
com.trs.components.common.publish.config
com.trs.components.common.publish.config.persistent
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.auth
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.element
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.distribute
com.trs.components.common.publish.persistent.element
com.trs.components.common.publish.persistent.publisher
com.trs.components.common.publish.persistent.taskdispatch
com.trs.components.common.publish.persistent.template
com.trs.components.common.publish.widget
com.trs.components.common.publish.widget.tagparser
com.trs.components.common.reminder
com.trs.components.common.trsad
com.trs.components.common.trsvote
com.trs.components.filter
com.trs.components.gkml.sqgk.constant
com.trs.components.gkml.sqgk.persistent
com.trs.components.gkml.sqgk.process.element
com.trs.components.gkml.sqgk.process.engine.creators
com.trs.components.gkml.sqgk.process.engine.handlers
com.trs.components.govinfo
com.trs.components.infoview
com.trs.components.infoview.config
com.trs.components.infoview.db
com.trs.components.infoview.extract
com.trs.components.infoview.extract.manifest
com.trs.components.infoview.filter
com.trs.components.infoview.helper
com.trs.components.infoview.mad
com.trs.components.infoview.persistent
com.trs.components.infoview.process
com.trs.components.infoview.publish.tagparser
com.trs.components.metadata
com.trs.components.metadata.center
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition
com.trs.components.metadata.definition.xml
com.trs.components.metadata.publish
com.trs.components.metadata.right
com.trs.components.metadata.service
com.trs.components.metadata.service.domain
com.trs.components.metadata.service.listener
com.trs.components.metadata.service.portervisitors
com.trs.components.metadata.service.util
com.trs.components.metadata.service.xmlconvertors
com.trs.components.metadata.web
com.trs.components.metadata.web.impl
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm
com.trs.components.wcm.auth
com.trs.components.wcm.channel
com.trs.components.wcm.content
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.domain.auth
com.trs.components.wcm.content.domain.intelligence
com.trs.components.wcm.content.persistent
com.trs.components.wcm.content.service.portervisitors
com.trs.components.wcm.content.trsserver
com.trs.components.wcm.contentlink
com.trs.components.wcm.customize
com.trs.components.wcm.epress
com.trs.components.wcm.individuation
com.trs.components.wcm.logger
com.trs.components.wcm.newshoo
com.trs.components.wcm.process
com.trs.components.wcm.process.element
com.trs.components.wcm.process.service.domain
com.trs.components.wcm.process.service.flowexporter
com.trs.components.wcm.publish
com.trs.components.wcm.publish.domain
com.trs.components.wcm.publish.domain.job
com.trs.components.wcm.publish.element
com.trs.components.wcm.publish.logo
com.trs.components.wcm.publish.region
com.trs.components.wcm.publish.tagparser
com.trs.components.wcm.publish.tagparser.formater
com.trs.components.wcm.recent
com.trs.components.wcm.resource
com.trs.components.wcm.soap
com.trs.components.wcm.stat
com.trs.components.wcm.stat.chart
com.trs.components.wcm.stat.domain
com.trs.components.wcm.util
com.trs.components.wcm.wcmx.common
com.trs.components.wcm.wcmx.help
com.trs.components.wcm.wcmx.jsp
com.trs.components.wcm.wcmx.media
com.trs.components.wcm.wcmx.util
com.trs.components.wcm.wcmx.websites
com.trs.components.web
com.trs.components.web.document
com.trs.database.util
com.trs.db.schema
com.trs.db.update
com.trs.devhelper
com.trs.infra
com.trs.infra.common
com.trs.infra.config
com.trs.infra.config.domain
com.trs.infra.config.persistent
com.trs.infra.db
com.trs.infra.persistent
com.trs.infra.persistent.cache
com.trs.infra.persistent.db
com.trs.infra.persistent.listener
com.trs.infra.persistent.util
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.support.file
com.trs.infra.support.log
com.trs.infra.support.security
com.trs.infra.update
com.trs.infra.util
com.trs.infra.util.cabfile
com.trs.infra.util.database
com.trs.infra.util.email
com.trs.infra.util.file
com.trs.infra.util.ftp
com.trs.infra.util.html
com.trs.infra.util.jazzlib
com.trs.infra.util.job
com.trs.infra.util.key
com.trs.infra.util.soap
com.trs.infra.util.uftp
com.trs.infra.util.upgrade
com.trs.infra.util.upgrade.dataprocess
com.trs.infra.util.upgrade.dbcompare
com.trs.infra.util.upgrade.sql
com.trs.infra.util.xml
com.trs.km.auth
com.trs.license
com.trs.presentation.common
com.trs.presentation.documetimport.xml
com.trs.presentation.ids
com.trs.presentation.jsputil
com.trs.presentation.locale
com.trs.presentation.login
com.trs.presentation.nav
com.trs.presentation.navigation
com.trs.presentation.plugin
com.trs.presentation.portal
com.trs.presentation.publish.template
com.trs.presentation.right
com.trs.presentation.util
com.trs.presentation.valid
com.trs.presentation.wcm.content
com.trs.scene.parser
com.trs.scene.tools
com.trs.service
com.trs.service.impl
com.trs.servlet
com.trs.template
com.trs.template.domain
com.trs.template.domain.setting
com.trs.template.persistent
com.trs.template.service
com.trs.template.service.impl
com.trs.tools
com.trs.upgrade
com.trs.util
com.trs.wcag2
com.trs.wcag2.validator
com.trs.wcm.config
com.trs.wcm.customize
com.trs.wcm.old
com.trs.wcm.photo
com.trs.wcm.photo.impl
com.trs.wcm.photo.publish
com.trs.wcmonline
com.trs.webframework
com.trs.webframework.config
com.trs.webframework.context
com.trs.webframework.controler
com.trs.webframework.controler.servlet
com.trs.webframework.demo
com.trs.webframework.entity
com.trs.webframework.exception
com.trs.webframework.provider
com.trs.webframework.xmlserver
com.trs.webframework.xmlserver.convertors
com.trs.webframework.xmlserver.parser
com.trs.webframework.xmlserver.server
com.trs.weblet.util.verfiycode
com.trsothers
com.trsupdate
com.wcm.pdf


概述

上一个 下一个 框架 无框架

TRS WCM API

软件包
com.trs |
com.trs.ajaxservice |
com.trs.ajaxservice.listener |
com.trs.ajaxservice.logger |
com.trs.ajaxservice.xmlconvertors |
com.trs.cluster |
com.trs.cluster.receiver |
com.trs.cms |
com.trs.cms.auth |
com.trs.cms.auth.config |
com.trs.cms.auth.domain |
com.trs.cms.auth.logger |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.logger |
com.trs.cms.process |
com.trs.cms.process.config |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.cms.process.engine.creators |
com.trs.cms.process.engine.handlers |
com.trs.cms.process.xml |
com.trs.components.ckm |
com.trs.components.comment |
com.trs.components.comment.domain |
com.trs.components.comment.persistent |
com.trs.components.comment.publish.helper |
com.trs.components.comment.publish.tagparser |
com.trs.components.comment.service |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection |
com.trs.components.common.conjection.helper |
com.trs.components.common.conjection.persistent |
com.trs.components.common.conjection.service |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.message.notify |
com.trs.components.common.publish |
com.trs.components.common.publish.config |
com.trs.components.common.publish.config.persistent |
com.trs.components.common.publish.domain |
com.trs.components.common.publish.domain.auth |
com.trs.components.common.publish.domain.distribute |
com.trs.components.common.publish.domain.element |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.common.reminder |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.filter |
com.trs.components.gkml.sqgk.constant |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.gkml.sqgk.process.element |
com.trs.components.gkml.sqgk.process.engine.creators |
com.trs.components.gkml.sqgk.process.engine.handlers |
com.trs.components.govinfo |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.config |
com.trs.components.infoview.db |
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。
com.trs.components.infoview.extract.manifest |
com.trs.components.infoview.filter |
com.trs.components.infoview.helper |
com.trs.components.infoview.mad |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.infoview.process |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata |
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.definition |
com.trs.components.metadata.definition.xml |
com.trs.components.metadata.publish |
com.trs.components.metadata.right |
com.trs.components.metadata.service |
com.trs.components.metadata.service.domain |
com.trs.components.metadata.service.listener |
com.trs.components.metadata.service.portervisitors |
com.trs.components.metadata.service.util |
com.trs.components.metadata.service.xmlconvertors |
com.trs.components.metadata.web |
com.trs.components.metadata.web.impl |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm |
com.trs.components.wcm.auth |
com.trs.components.wcm.channel |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.domain.intelligence |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.service.portervisitors |
com.trs.components.wcm.content.trsserver |
com.trs.components.wcm.contentlink |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.logger |
com.trs.components.wcm.newshoo |
com.trs.components.wcm.process |
com.trs.components.wcm.process.element |
com.trs.components.wcm.process.service.domain |
com.trs.components.wcm.process.service.flowexporter |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.domain |
com.trs.components.wcm.publish.domain.job |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.publish.tagparser.formater |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.soap |
com.trs.components.wcm.stat |
com.trs.components.wcm.stat.chart |
com.trs.components.wcm.stat.domain |
com.trs.components.wcm.util |
com.trs.components.wcm.wcmx.common |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.jsp |
com.trs.components.wcm.wcmx.media |
com.trs.components.wcm.wcmx.util |
com.trs.components.wcm.wcmx.websites |
com.trs.components.web |
com.trs.components.web.document |
com.trs.database.util |
com.trs.db.schema |
com.trs.db.update |
com.trs.devhelper |
com.trs.infra |
com.trs.infra.common |
com.trs.infra.config |
com.trs.infra.config.domain |
com.trs.infra.config.persistent |
com.trs.infra.db |
com.trs.infra.persistent |
com.trs.infra.persistent.cache |
com.trs.infra.persistent.db |
com.trs.infra.persistent.listener |
com.trs.infra.persistent.util |
com.trs.infra.support.cache |
com.trs.infra.support.config |
com.trs.infra.support.file |
com.trs.infra.support.log |
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.infra.update |
com.trs.infra.util |
com.trs.infra.util.cabfile |
com.trs.infra.util.database |
com.trs.infra.util.email |
com.trs.infra.util.file |
com.trs.infra.util.ftp |
com.trs.infra.util.html |
com.trs.infra.util.jazzlib |
com.trs.infra.util.job |
com.trs.infra.util.key |
com.trs.infra.util.soap |
com.trs.infra.util.uftp | 提供一个使用FTP、及FTP类似协议进行远程发布的统一接口.
com.trs.infra.util.upgrade |
com.trs.infra.util.upgrade.dataprocess |
com.trs.infra.util.upgrade.dbcompare |
com.trs.infra.util.upgrade.sql |
com.trs.infra.util.xml |
com.trs.km.auth |
com.trs.license |
com.trs.presentation.common |
com.trs.presentation.documetimport.xml |
com.trs.presentation.ids |
com.trs.presentation.jsputil |
com.trs.presentation.locale |
com.trs.presentation.login |
com.trs.presentation.nav |
com.trs.presentation.navigation |
com.trs.presentation.plugin |
com.trs.presentation.portal |
com.trs.presentation.publish.template |
com.trs.presentation.right |
com.trs.presentation.util |
com.trs.presentation.valid |
com.trs.presentation.wcm.content |
com.trs.scene.parser |
com.trs.scene.tools |
com.trs.service |
com.trs.service.impl |
com.trs.servlet |
com.trs.template |
com.trs.template.domain |
com.trs.template.domain.setting |
com.trs.template.persistent |
com.trs.template.service |
com.trs.template.service.impl |
com.trs.tools |
com.trs.upgrade |
com.trs.util |
com.trs.wcag2 |
com.trs.wcag2.validator |
com.trs.wcm.config |
com.trs.wcm.customize |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |
com.trs.wcm.photo.publish |
com.trs.wcmonline |
com.trs.webframework |
com.trs.webframework.config |
com.trs.webframework.context |
com.trs.webframework.controler |
com.trs.webframework.controler.servlet |
com.trs.webframework.demo |
com.trs.webframework.entity |
com.trs.webframework.exception |
com.trs.webframework.provider |
com.trs.webframework.xmlserver |
com.trs.webframework.xmlserver.convertors |
com.trs.webframework.xmlserver.parser |
com.trs.webframework.xmlserver.server |
com.trs.weblet.util.verfiycode |
com.trsothers |
com.trsupdate |
com.wcm.pdf |

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


上一个 下一个 框架 无框架

所有软件包的分层结构

软件包分层结构：
com.trs, com.trs.ajaxservice, com.trs.ajaxservice.listener, com.trs.ajaxservice.logger, com.trs.ajaxservice.xmlconvertors, com.trs.cluster, com.trs.cluster.receiver, com.trs.cms, com.trs.cms.auth, com.trs.cms.auth.config, com.trs.cms.auth.domain, com.trs.cms.auth.logger, com.trs.cms.auth.persistent, com.trs.cms.content, com.trs.cms.logger, com.trs.cms.process, com.trs.cms.process.config, com.trs.cms.process.definition, com.trs.cms.process.engine, com.trs.cms.process.engine.creators, com.trs.cms.process.engine.handlers, com.trs.cms.process.xml, com.trs.components.ckm, com.trs.components.comment, com.trs.components.comment.domain, com.trs.components.comment.persistent, com.trs.components.comment.publish.helper, com.trs.components.comment.publish.tagparser, com.trs.components.comment.service, com.trs.components.common.address, com.trs.components.common.bookmark, com.trs.components.common.calendar, com.trs.components.common.conjection, com.trs.components.common.conjection.helper, com.trs.components.common.conjection.persistent, com.trs.components.common.conjection.service, com.trs.components.common.job, com.trs.components.common.message, com.trs.components.common.message.notify, com.trs.components.common.publish, com.trs.components.common.publish.config, com.trs.components.common.publish.config.persistent, com.trs.components.common.publish.domain, com.trs.components.common.publish.domain.auth, com.trs.components.common.publish.domain.distribute, com.trs.components.common.publish.domain.element, com.trs.components.common.publish.domain.publisher, com.trs.components.common.publish.domain.tagparser, com.trs.components.common.publish.domain.taskdispatch, com.trs.components.common.publish.domain.template, com.trs.components.common.publish.persistent.distribute, com.trs.components.common.publish.persistent.element, com.trs.components.common.publish.persistent.publisher, com.trs.components.common.publish.persistent.taskdispatch, com.trs.components.common.publish.persistent.template, com.trs.components.common.publish.widget, com.trs.components.common.publish.widget.tagparser, com.trs.components.common.reminder, com.trs.components.common.trsad, com.trs.components.common.trsvote, com.trs.components.filter, com.trs.components.gkml.sqgk.constant, com.trs.components.gkml.sqgk.persistent, com.trs.components.gkml.sqgk.process.element, com.trs.components.gkml.sqgk.process.engine.creators, com.trs.components.gkml.sqgk.process.engine.handlers, com.trs.components.govinfo, com.trs.components.infoview, com.trs.components.infoview.config, com.trs.components.infoview.db, com.trs.components.infoview.extract, com.trs.components.infoview.extract.manifest, com.trs.components.infoview.filter, com.trs.components.infoview.helper, com.trs.components.infoview.mad, com.trs.components.infoview.persistent, com.trs.components.infoview.process, com.trs.components.infoview.publish.tagparser, com.trs.components.metadata, com.trs.components.metadata.center, com.trs.components.metadata.center.xml, com.trs.components.metadata.definition, com.trs.components.metadata.definition.xml, com.trs.components.metadata.publish, com.trs.components.metadata.right, com.trs.components.metadata.service, com.trs.components.metadata.service.domain, com.trs.components.metadata.service.listener, com.trs.components.metadata.service.portervisitors, com.trs.components.metadata.service.util, com.trs.components.metadata.service.xmlconvertors, com.trs.components.metadata.web, com.trs.components.metadata.web.impl, com.trs.components.special, com.trs.components.stat, com.trs.components.wcm, com.trs.components.wcm.auth, com.trs.components.wcm.channel, com.trs.components.wcm.content, com.trs.components.wcm.content.domain, com.trs.components.wcm.content.domain.auth, com.trs.components.wcm.content.domain.intelligence, com.trs.components.wcm.content.persistent, com.trs.components.wcm.content.service.portervisitors, com.trs.components.wcm.content.trsserver, com.trs.components.wcm.contentlink, com.trs.components.wcm.customize, com.trs.components.wcm.epress, com.trs.components.wcm.individuation, com.trs.components.wcm.logger, com.trs.components.wcm.newshoo, com.trs.components.wcm.process, com.trs.components.wcm.process.element, com.trs.components.wcm.process.service.domain, com.trs.components.wcm.process.service.flowexporter, com.trs.components.wcm.publish, com.trs.components.wcm.publish.domain, com.trs.components.wcm.publish.domain.job, com.trs.components.wcm.publish.element, com.trs.components.wcm.publish.logo, com.trs.components.wcm.publish.region, com.trs.components.wcm.publish.tagparser, com.trs.components.wcm.publish.tagparser.formater, com.trs.components.wcm.recent, com.trs.components.wcm.resource, com.trs.components.wcm.soap, com.trs.components.wcm.stat, com.trs.components.wcm.stat.chart, com.trs.components.wcm.stat.domain, com.trs.components.wcm.util, com.trs.components.wcm.wcmx.common, com.trs.components.wcm.wcmx.help, com.trs.components.wcm.wcmx.jsp, com.trs.components.wcm.wcmx.media, com.trs.components.wcm.wcmx.util, com.trs.components.wcm.wcmx.websites, com.trs.components.web, com.trs.components.web.document, com.trs.database.util, com.trs.db.schema, com.trs.db.update, com.trs.devhelper, com.trs.infra, com.trs.infra.common, com.trs.infra.config, com.trs.infra.config.domain, com.trs.infra.config.persistent, com.trs.infra.db, com.trs.infra.persistent, com.trs.infra.persistent.cache, com.trs.infra.persistent.db, com.trs.infra.persistent.listener, com.trs.infra.persistent.util, com.trs.infra.support.cache, com.trs.infra.support.config, com.trs.infra.support.file, com.trs.infra.support.log, com.trs.infra.support.security, com.trs.infra.update, com.trs.infra.util, com.trs.infra.util.cabfile, com.trs.infra.util.database, com.trs.infra.util.email, com.trs.infra.util.file, com.trs.infra.util.ftp, com.trs.infra.util.html, com.trs.infra.util.jazzlib, com.trs.infra.util.job, com.trs.infra.util.key, com.trs.infra.util.soap, com.trs.infra.util.uftp, com.trs.infra.util.upgrade, com.trs.infra.util.upgrade.dataprocess, com.trs.infra.util.upgrade.dbcompare, com.trs.infra.util.upgrade.sql, com.trs.infra.util.xml, com.trs.km.auth, com.trs.license, com.trs.presentation.common, com.trs.presentation.documetimport.xml, com.trs.presentation.ids, com.trs.presentation.jsputil, com.trs.presentation.locale, com.trs.presentation.login, com.trs.presentation.nav, com.trs.presentation.navigation, com.trs.presentation.plugin, com.trs.presentation.portal, com.trs.presentation.publish.template, com.trs.presentation.right, com.trs.presentation.util, com.trs.presentation.valid, com.trs.presentation.wcm.content, com.trs.scene.parser, com.trs.scene.tools, com.trs.service, com.trs.service.impl, com.trs.servlet, com.trs.template, com.trs.template.domain, com.trs.template.domain.setting, com.trs.template.persistent, com.trs.template.service, com.trs.template.service.impl, com.trs.tools, com.trs.upgrade, com.trs.util, com.trs.wcag2, com.trs.wcag2.validator, com.trs.wcm.config, com.trs.wcm.customize, com.trs.wcm.old, com.trs.wcm.photo, com.trs.wcm.photo.impl, com.trs.wcm.photo.publish, com.trs.wcmonline, com.trs.webframework, com.trs.webframework.config, com.trs.webframework.context, com.trs.webframework.controler, com.trs.webframework.controler.servlet, com.trs.webframework.demo, com.trs.webframework.entity, com.trs.webframework.exception, com.trs.webframework.provider, com.trs.webframework.xmlserver, com.trs.webframework.xmlserver.convertors, com.trs.webframework.xmlserver.parser, com.trs.webframework.xmlserver.server, com.trs.weblet.util.verfiycode, com.trsothers, com.trsupdate, com.wcm.pdf

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.web.AbsHTMLMaker (implements com.trs.components.metadata.web.HTMLMaker)
      • com.trs.components.metadata.web.impl.DefaultHTMLMaker
    • com.trs.webframework.AbstractLogger (implements com.trs.webframework.ServiceExcuteLogger)
      • com.trs.ajaxservice.logger.BatchChannelCreateFromFileLogger
      • com.trs.ajaxservice.logger.ChannelCreateFromLogger
      • com.trs.ajaxservice.logger.ChannelImportLogger
      • com.trs.ajaxservice.logger.ChannelMoveLogger
      • com.trs.webframework.DefaultDeleteLogger (implements com.trs.webframework.ServiceExcuteLogger)
      • com.trs.webframework.DefaultSaveLogger (implements com.trs.webframework.ServiceExcuteLogger)
        • com.trs.ajaxservice.logger.DocSaveLogger
      • com.trs.ajaxservice.logger.DocCopyLogger
      • com.trs.ajaxservice.logger.DocImportLogger
      • com.trs.ajaxservice.logger.DocMoveLogger
      • com.trs.ajaxservice.logger.DocPublishTaskLogger
      • com.trs.ajaxservice.logger.DocStatusChangeLogger
      • com.trs.components.wcm.epress.EPressChannelCreateLogger
      • com.trs.components.wcm.epress.EPressHistoryPubLogger
      • com.trs.ajaxservice.logger.FlowSaveLogger
      • com.trs.ajaxservice.logger.FlowSetLogger
      • com.trs.ajaxservice.logger.ImpartTemplateLogger
      • com.trs.ajaxservice.logger.PublishConfigSaveLogger
      • com.trs.ajaxservice.logger.PublishTaskLogger
      • com.trs.ajaxservice.logger.RecycleClearLogger
      • com.trs.ajaxservice.logger.RestoreObjLogger
      • com.trs.ajaxservice.logger.ResyncTemplateApdLogger
      • com.trs.ajaxservice.logger.SetEmployersOfTemplateLogger
      • com.trs.ajaxservice.logger.SiteCreateFromLogger
      • com.trs.ajaxservice.logger.SiteImportLogger
      • com.trs.ajaxservice.logger.SiteRecycleClearLogger
      • com.trs.ajaxservice.logger.TemplateImportLogger
      • com.trs.ajaxservice.logger.TemplateSyncLogger
      • com.trs.ajaxservice.logger.WebSiteRestoreLogger
    • com.trs.template.domain.setting.AbstractTemplateSetting (implements com.trs.template.domain.setting.ITemplateSetting)
      • com.trs.template.domain.setting.ChannelsTemplateSetting
      • com.trs.template.domain.setting.FieldsTemplateSetting
      • com.trs.template.domain.setting.TemplatesTemplateSetting
    • com.trs.cms.process.engine.AbstractToUsersCreator (implements com.trs.cms.process.engine.IToUsersCreator)
      • com.trs.components.gkml.sqgk.process.engine.creators.ApplyFormToUsersCreator
      • com.trs.cms.process.engine.creators.CrUserAsToUsersCreator
      • com.trs.cms.process.engine.creators.DeptMgrAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupAdminsAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupAdminsFromChnlAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupAdminsFromFlowAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupAdminsFromSupportPartAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator
      • com.trs.components.gkml.sqgk.process.engine.creators.LawGovTousersCreator
      • com.trs.cms.process.engine.creators.RoleAsToUsersCreator
    • com.trs.wcag2.validator.AbstractValidator (implements com.trs.wcag2.validator.IValidator)
      • com.trs.wcag2.validator.BiTagValidator
      • com.trs.wcag2.validator.DocTypeValidator
      • com.trs.wcag2.validator.EmbedAltValidator
      • com.trs.wcag2.validator.EventsValidator
      • com.trs.wcag2.validator.FormElementsValidator
      • com.trs.wcag2.validator.FormSubmitValidator
      • com.trs.wcag2.validator.FrameTitleValidator
      • com.trs.wcag2.validator.HtmlCharsetValidator
      • com.trs.wcag2.validator.HtmlH1_H6Validator
      • com.trs.wcag2.validator.HtmlH1Validator
      • com.trs.wcag2.validator.HtmlLangValidator
      • com.trs.wcag2.validator.HtmlTitleValidator
      • com.trs.wcag2.validator.ImgAltValidator
      • com.trs.wcag2.validator.ObjectBodyValidator
    • com.trs.infra.persistent.AbstractXmlToObjConverter
      • com.trs.components.wcm.content.domain.XmlToDocumentConverter
      • com.trs.components.metadata.definition.xml.XMLToMetaDBTablesConvertor
      • com.trs.components.metadata.center.xml.XMLToMetaViewData
    • com.trs.cms.process.config.ActionHandlerConfig
    • com.trs.cms.process.engine.handlers.ActionParametersAnalyser
    • com.trs.presentation.ids.ActorHelper
    • com.trs.components.common.publish.widget.AdjustJsLCListenerWidget (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.infra.util.jazzlib.Adler32 (implements com.trs.infra.util.jazzlib.Checksum)
    • com.trs.components.common.conjection.service.AdmanageConfigServiceImpl (implements com.trs.components.common.conjection.service.IAdmanageConfigService)
    • com.trs.cms.auth.persistent.AdministratorCacheMgr (implements com.trs.cms.auth.persistent.IAdministratorCacheMgr)
    • com.trs.presentation.nav.AdvSearchNavHandler (implements com.trs.presentation.nav.INavHandler)
    • com.trs.wcag2.Alertion
    • com.trs.database.util.AllDDLMaker
    • com.trs.components.wcm.content.domain.ApdHostLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.AppendixMgr
    • com.trs.components.gkml.sqgk.constant.ApplyFormConstants
    • com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.ajaxservice.ApplyFormServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler (implements com.trs.cms.process.engine.IActionHandler)
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.trs.components.ckm.ICKMServerTest
        • com.trs.presentation.nav.TreeCreatorTest
        • com.trs.TRSWCMBaseTest
          • com.trs.components.metadata.center.ClassDocumentsHelperTest
          • com.trs.components.wcm.publish.domain.PreNextDocumentsImplTest
          • com.trs.db.schema.TRSDBSchemaTest
        • com.trs.components.metadata.service.util.WCMJSPCheckerTest
        • com.trs.components.metadata.center.xml.XMLToMetaViewDataTest
    • com.trs.infra.util.AttributesString
    • com.trs.cms.auth.AuthHelper
    • com.trs.cms.auth.domain.AuthServer
    • com.trs.components.metadata.right.AuthServerMgr
    • com.trs.ajaxservice.AuthServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.wcm.content.domain.AutoDocBakMgr
    • com.trs.service.impl.AutoDocBakService (implements com.trs.service.IAutoDocBakService)
    • com.trs.components.gkml.sqgk.process.engine.handlers.AutoFillApplyFormHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.wcm.photo.impl.AutoImageLibUtil
    • com.trs.cms.process.engine.handlers.AutoToNextHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.components.wcm.content.domain.AutoTransmitMgr
    • com.trs.components.wcm.stat.chart.BarChartProducer (implements de.laures.cewolf.DatasetProducer)
    • com.trs.infra.util.Base64Util
    • com.trs.template.persistent.BaseChannelInfoEntity (implements com.trs.template.persistent.IInfoEntity)
    • com.trs.components.wcm.content.domain.BaseChannelLCListener4ExtField (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.BaseChannelLCListener4Region (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.infra.BaseConfig
      • com.trs.infra.config.DBTableConfig
      • com.trs.infra.config.FileConfig
      • com.trs.infra.config.XMLConfig
    • com.trs.infra.common.BaseContextHelper
    • com.trs.components.web.BaseFieldHTMLParser (implements com.trs.components.web.IFieldHTMLParser)
      • com.trs.components.web.document.DocumentFieldHTMLParser
    • com.trs.infra.common.BaseIdsMan
      • com.trs.components.wcm.customize.CustomizedChannelIdsMan
      • com.trs.components.common.calendar.EventShareIdsMan
      • com.trs.cms.auth.domain.GrpUserIdsMan
      • com.trs.cms.auth.domain.RoleUserIdsMan
      • com.trs.components.wcm.content.domain.SiteMemberIdsMan
      • com.trs.components.common.publish.domain.template.TemplateEmployerIdsMan
    • com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.components.common.job.BaseScheduleWorker
        • com.trs.components.common.job.BaseStatefulScheduleWorker (implements org.quartz.StatefulJob)
          • com.trs.components.wcm.content.domain.ChnlSynWorker
          • com.trs.components.stat.HitsCountParserSchedule
          • com.trs.components.common.job.OptimizeSystemWorker
          • com.trs.components.wcm.publish.domain.job.PublishJobWorker
          • com.trs.components.common.job.TempPathCleaner
          • com.trs.components.wcm.publish.domain.job.WithDrawJobWorker
        • com.trs.components.wcm.content.domain.DocPriDisableWorker
        • com.trs.components.wcm.epress.EPressHistoryIndexWorker
        • com.trs.components.common.reminder.Reminder
        • com.trs.components.wcm.stat.StatAutoRunWorker
      • com.trs.infra.util.job.BaseStatefulJob (implements org.quartz.StatefulJob)
        • com.trs.cms.process.engine.handlers.DoingRuleHandler
        • com.trs.infra.util.job.StatefulJobTest
      • com.trs.cms.auth.domain.UserInfoSyncUpdater
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.infra.support.log.BaseDBLog (implements com.trs.infra.support.log.ILog)
        • com.trs.infra.support.log.Log
        • com.trs.infra.support.log.LogBak
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.trsad.ADCom
        • com.trs.components.common.trsad.ADFile
        • com.trs.components.common.trsad.ADFilePos
        • com.trs.components.common.trsad.ADPos
        • com.trs.components.common.trsad.ADType
        • com.trs.components.wcm.content.persistent.Appendix
        • com.trs.components.gkml.sqgk.persistent.ApplyForm
        • com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog
        • com.trs.components.wcm.content.persistent.AutoBakConfig
        • com.trs.components.wcm.content.persistent.BaseChannel
          • com.trs.components.wcm.content.persistent.Channel
          • com.trs.components.wcm.content.persistent.WebSite
        • com.trs.components.common.publish.widget.BaseStyle
          • com.trs.components.common.publish.widget.ContentStyle
          • com.trs.components.common.publish.widget.PageStyle
          • com.trs.components.common.publish.widget.ResourceStyle
        • com.trs.components.stat.BonusRule
        • com.trs.components.common.bookmark.BookMark
        • com.trs.components.wcm.publish.region.CellInfo
        • com.trs.components.wcm.content.persistent.ChannelContentLink
        • com.trs.components.wcm.content.persistent.ChannelSyn
        • com.trs.components.stat.ChnlDept
        • com.trs.components.wcm.content.persistent.ChnlDoc
        • com.trs.components.metadata.definition.ClassInfo
        • com.trs.components.metadata.center.ClassInfoView
        • com.trs.cms.content.CMSObjDefaultImpl
        • com.trs.components.infoview.helper.ComplexFieldData
        • com.trs.components.common.address.Contact
        • com.trs.components.common.address.ContactGrp
        • com.trs.ajaxservice.ContentExtendValue
        • com.trs.components.wcm.content.persistent.ContentExtField
        • com.trs.components.wcm.content.persistent.ContentLink
        • com.trs.components.wcm.content.persistent.ContentLinkType
        • com.trs.components.wcm.individuation.CustomSiteCheckedInfo
        • com.trs.cms.content.DefaultObj
        • com.trs.components.wcm.resource.DocKind
        • com.trs.components.wcm.content.persistent.DocReply
        • com.trs.components.wcm.content.persistent.Document
          • com.trs.components.wcm.content.persistent.DocBak
          • com.trs.wcm.old.WCMExcelData
        • com.trs.components.stat.DocumentHitsCount
        • com.trs.components.wcm.content.persistent.DocumentSyn
        • com.trs.components.comment.persistent.DocumentTopic
        • com.trs.components.common.conjection.persistent.EntryConfig
        • com.trs.components.common.calendar.Event
        • com.trs.components.common.calendar.EventShare
        • com.trs.components.common.calendar.EventType
        • com.trs.cms.content.ExtendedField
        • com.trs.components.wcm.resource.FileType
        • com.trs.cms.process.definition.Flow
        • com.trs.cms.process.definition.FlowAction
        • com.trs.cms.process.definition.FlowCondition
        • com.trs.cms.process.engine.FlowContentConfig
        • com.trs.cms.process.engine.FlowDoc
          • com.trs.cms.process.engine.FlowDocBak
        • com.trs.cms.process.definition.FlowdocLog
        • com.trs.cms.process.definition.FlowEmploy
        • com.trs.cms.process.definition.FlowNode
        • com.trs.cms.process.definition.FlowNodeBranch
        • com.trs.cms.process.definition.FlowNodeField
        • com.trs.cms.process.definition.FlowRule
        • com.trs.components.common.publish.persistent.publisher.FolderPublishConfig
        • com.trs.cms.auth.persistent.Group (implements java.io.Serializable)
        • com.trs.cms.auth.persistent.GroupRole
        • com.trs.cms.auth.persistent.GroupUser
        • com.trs.components.wcm.content.persistent.HitsCount
        • com.trs.components.stat.HostObjDomain
        • com.trs.components.stat.HostObjHitsCount
        • com.trs.components.wcm.individuation.Individuation
        • com.trs.components.infoview.persistent.InfoView
        • com.trs.components.infoview.persistent.InfoViewData
        • com.trs.components.infoview.persistent.InfoViewEmploy
        • com.trs.components.infoview.persistent.InfoViewField
        • com.trs.components.infoview.persistent.InfoViewGroup
        • com.trs.components.infoview.persistent.InfoViewView
        • com.trs.components.common.job.JobWorkerType
        • com.trs.components.wcm.resource.Keyword
        • com.trs.components.common.publish.widget.Layout
        • com.trs.components.wcm.publish.logo.Logo
        • com.trs.components.gkml.sqgk.persistent.MailConfig
        • com.trs.components.common.bookmark.MarkKind
        • com.trs.components.common.bookmark.MarkShare
        • com.trs.components.common.publish.widget.Master
        • com.trs.components.wcm.wcmx.media.MediaRemindedInfo
        • com.trs.components.common.message.Message
        • com.trs.components.metadata.definition.MetaDBField
        • com.trs.components.metadata.definition.MetaDBTable
        • com.trs.components.metadata.definition.MetaView
        • com.trs.components.metadata.center.MetaViewData
        • com.trs.components.metadata.definition.MetaViewField
        • com.trs.components.common.message.MsgQueue
        • com.trs.cms.auth.persistent.ObjectMember
        • com.trs.wcm.config.PageOperator
        • com.trs.components.common.publish.persistent.distribute.PublishDistribution
        • com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog
        • com.trs.components.common.publish.persistent.taskdispatch.PublishTask
        • com.trs.components.wcm.recent.Recent
        • com.trs.components.wcm.publish.region.RegionEmploy
        • com.trs.components.wcm.publish.region.RegionInfo
        • com.trs.components.wcm.content.persistent.Relation
        • com.trs.components.wcm.content.persistent.Replace
        • com.trs.cms.auth.persistent.Right
        • com.trs.cms.auth.persistent.RightDef
        • com.trs.cms.auth.persistent.Role (implements java.io.Serializable)
        • com.trs.cms.auth.persistent.RoleUser
        • com.trs.components.common.job.Schedule
        • com.trs.components.wcm.resource.Security
        • com.trs.components.wcm.content.persistent.SiteMember
        • com.trs.components.wcm.resource.Source
        • com.trs.components.special.Special
        • com.trs.components.wcm.stat.StatFieldMap
        • com.trs.components.wcm.stat.StatHost
        • com.trs.components.wcm.resource.Status
        • com.trs.components.wcm.stat.StatView
        • com.trs.components.wcm.stat.StatViewRel
        • com.trs.components.common.publish.widget.StyleAndResource
        • com.trs.components.common.publish.widget.StyleItem
        • com.trs.components.common.publish.persistent.template.TagBean
        • com.trs.components.common.publish.persistent.template.TempApdRel
        • com.trs.components.common.publish.persistent.template.TempAppendix
        • com.trs.components.common.publish.persistent.template.Template
        • com.trs.components.common.publish.persistent.template.TemplateArgument
        • com.trs.components.common.publish.persistent.template.TemplateEmploy
        • com.trs.components.common.publish.persistent.template.TemplateQuote
        • com.trs.components.comment.persistent.TopicedDocRelation
        • com.trs.cms.auth.persistent.TrusteeInfo
        • com.trs.cms.auth.persistent.User (implements java.io.Serializable)
        • com.trs.components.stat.UserLoginInfo
        • com.trs.components.wcm.customize.UserSetting
        • com.trs.components.wcm.content.ViewDocument
          • com.trs.components.infoview.persistent.InfoViewDocument
        • com.trs.components.common.trsvote.Vote
        • com.trs.components.common.trsvote.VoteData
        • com.trs.components.common.trsvote.VoteIPLog
        • com.trs.components.common.trsvote.VoteItem
        • com.trs.components.common.trsvote.VoteOption
        • com.trs.wcm.photo.Watermark
        • com.trs.components.wcm.publish.WCMFolderPublishConfig
        • com.trs.wcm.old.WCMFormFields
        • com.trs.wcm.old.WCMFormInfo
        • com.trs.components.wcm.wcmx.help.WCMHelp
        • com.trs.components.wcm.publish.WCMPubStatusConfig
        • com.trs.cms.content.WCMSystemObject
        • com.trs.components.common.publish.widget.Widget
        • com.trs.components.common.publish.widget.WidgetInstance
        • com.trs.components.common.publish.widget.WidgetInstParameter
        • com.trs.components.common.publish.widget.WidgetParameter
        • com.trs.components.wcm.content.persistent.XDocument
      • com.trs.infra.persistent.CMyResultSet
      • com.trs.infra.support.config.Config
      • com.trs.db.update.DBUpdateLog
      • com.trs.infra.util.job.JobFailedResult
      • com.trs.components.metadata.center.MetaViewEmployer
      • com.trs.components.common.message.MsgReceiver
      • com.trs.infra.persistent.MyBaseObj
      • com.trs.infra.support.log.OperType
      • com.trs.infra.support.security.SecureKey
    • com.trs.infra.persistent.BaseObjHelper
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.trsad.ADComs
        • com.trs.components.common.trsad.ADFilePoss
        • com.trs.components.common.trsad.ADFiles
        • com.trs.components.common.trsad.ADPoss
        • com.trs.components.common.trsad.ADTypes
        • com.trs.components.wcm.content.persistent.Appendixes
        • com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs
        • com.trs.components.gkml.sqgk.persistent.ApplyForms
        • com.trs.components.wcm.content.persistent.AutoBakConfigs
        • com.trs.components.stat.BonusRules
        • com.trs.components.common.bookmark.BookMarks
        • com.trs.components.wcm.publish.region.CellInfos
        • com.trs.components.wcm.content.persistent.ChannelContentLinks
        • com.trs.components.wcm.content.persistent.Channels
        • com.trs.components.wcm.content.persistent.ChannelSyns
        • com.trs.components.stat.ChnlDepts
        • com.trs.components.wcm.content.persistent.ChnlDocs
        • com.trs.components.metadata.definition.ClassInfos
        • com.trs.components.metadata.center.ClassInfoViews
        • com.trs.components.infoview.helper.ComplexFieldDatas
        • com.trs.components.common.address.ContactGrps
        • com.trs.components.common.address.Contacts
        • com.trs.ajaxservice.ContentExtendValues
        • com.trs.components.wcm.content.persistent.ContentExtFields
        • com.trs.components.wcm.content.persistent.ContentLinks
        • com.trs.components.wcm.content.persistent.ContentLinkTypes
        • com.trs.components.common.publish.widget.ContentStyles
        • com.trs.components.wcm.individuation.CustomSiteCheckedInfos
        • com.trs.cms.content.DefaultObjs
        • com.trs.components.wcm.content.persistent.DocBaks
        • com.trs.components.wcm.resource.DocKinds
        • com.trs.components.wcm.content.persistent.DocReplys
        • com.trs.components.stat.DocumentHitsCounts
        • com.trs.components.wcm.content.persistent.Documents
        • com.trs.components.wcm.content.persistent.DocumentSyns
        • com.trs.components.comment.persistent.DocumentTopics
        • com.trs.components.common.conjection.persistent.EntryConfigs
        • com.trs.components.common.calendar.Events
        • com.trs.components.common.calendar.EventShares
        • com.trs.components.common.calendar.EventTypes
        • com.trs.cms.content.ExtendedFields
        • com.trs.components.wcm.resource.FileTypes
        • com.trs.cms.process.definition.FlowActions
        • com.trs.cms.process.definition.FlowConditions
        • com.trs.cms.process.engine.FlowContentConfigs
        • com.trs.cms.process.definition.FlowdocLogs
        • com.trs.cms.process.engine.FlowDocs
          • com.trs.cms.process.engine.FlowDocBaks
        • com.trs.cms.process.definition.FlowEmploys
        • com.trs.cms.process.definition.FlowNodeBranchs
        • com.trs.cms.process.definition.FlowNodeFields
        • com.trs.cms.process.definition.FlowNodes
        • com.trs.cms.process.definition.FlowRules
        • com.trs.cms.process.definition.Flows
        • com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs
        • com.trs.cms.auth.persistent.GroupRoles
        • com.trs.cms.auth.persistent.Groups
        • com.trs.cms.auth.persistent.GroupUsers
        • com.trs.components.wcm.content.persistent.HitsCounts
        • com.trs.components.stat.HostObjDomains
        • com.trs.components.stat.HostObjHitsCounts
        • com.trs.components.wcm.individuation.Individuations
        • com.trs.components.infoview.persistent.InfoViewDatas
        • com.trs.components.infoview.persistent.InfoViewEmploys
        • com.trs.components.infoview.persistent.InfoViewFields
        • com.trs.components.infoview.persistent.InfoViewGroups
        • com.trs.components.infoview.persistent.InfoViews
        • com.trs.components.infoview.persistent.InfoViewViews
        • com.trs.components.common.job.JobWorkerTypes
        • com.trs.components.wcm.resource.Keywords
        • com.trs.components.common.publish.widget.Layouts
        • com.trs.components.wcm.publish.logo.Logos
        • com.trs.components.gkml.sqgk.persistent.MailConfigs
        • com.trs.components.common.bookmark.MarkKinds
        • com.trs.components.common.bookmark.MarkShares
        • com.trs.components.common.publish.widget.Masters
        • com.trs.components.wcm.wcmx.media.MediaRemindedInfos
        • com.trs.components.common.message.Messages
        • com.trs.components.metadata.definition.MetaDBFields
        • com.trs.components.metadata.definition.MetaDBTables
        • com.trs.components.metadata.center.MetaViewDatas
        • com.trs.components.metadata.definition.MetaViewFields
        • com.trs.components.metadata.definition.MetaViews
        • com.trs.components.common.message.MsgQueues
        • com.trs.cms.auth.persistent.ObjectMembers
        • com.trs.wcm.config.PageOperators
        • com.trs.components.common.publish.widget.PageStyles
        • com.trs.components.common.publish.persistent.distribute.PublishDistributions
        • com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs
        • com.trs.components.common.publish.persistent.taskdispatch.PublishTasks
        • com.trs.components.wcm.recent.Recents
        • com.trs.components.wcm.publish.region.RegionEmploys
        • com.trs.components.wcm.publish.region.RegionInfos
        • com.trs.components.wcm.content.persistent.Relations
        • com.trs.components.wcm.content.persistent.Replaces
        • com.trs.components.common.publish.widget.ResourceStyles
        • com.trs.cms.auth.persistent.RightDefs
        • com.trs.cms.auth.persistent.Rights
        • com.trs.cms.auth.persistent.Roles
        • com.trs.cms.auth.persistent.RoleUsers
        • com.trs.components.common.job.Schedules
        • com.trs.components.wcm.resource.Securities
        • com.trs.components.wcm.content.persistent.SiteMembers
        • com.trs.components.wcm.resource.Sources
        • com.trs.components.special.Specials
        • com.trs.components.wcm.stat.StatFieldMaps
        • com.trs.components.wcm.stat.StatHosts
        • com.trs.components.wcm.resource.Statuses
        • com.trs.components.wcm.stat.StatViewRels
        • com.trs.components.wcm.stat.StatViews
        • com.trs.components.common.publish.widget.StyleAndResources
        • com.trs.components.common.publish.widget.StyleItems
        • com.trs.components.common.publish.persistent.template.TagBeans
        • com.trs.components.common.publish.persistent.template.TempApdRels
        • com.trs.components.common.publish.persistent.template.TempAppendixes
        • com.trs.components.common.publish.persistent.template.TemplateArguments
        • com.trs.components.common.publish.persistent.template.TemplateEmploys
        • com.trs.components.common.publish.persistent.template.TemplateQuotes
        • com.trs.components.common.publish.persistent.template.Templates
        • com.trs.components.comment.persistent.TopicedDocRelations
        • com.trs.cms.auth.persistent.TrusteeInfos
        • com.trs.components.stat.UserLoginInfos
        • com.trs.cms.auth.persistent.Users
        • com.trs.components.wcm.customize.UserSettings
        • com.trs.components.wcm.content.ViewDocuments
          • com.trs.components.infoview.persistent.InfoViewDocuments
        • com.trs.components.common.trsvote.VoteDatas
        • com.trs.components.common.trsvote.VoteIPLogs
        • com.trs.components.common.trsvote.VoteItems
        • com.trs.components.common.trsvote.VoteOptions
        • com.trs.components.common.trsvote.Votes
        • com.trs.wcm.photo.Watermarks
        • com.trs.wcm.old.WCMExcelDatas
        • com.trs.wcm.old.WCMFormFieldses
        • com.trs.wcm.old.WCMFormInfos
        • com.trs.components.wcm.wcmx.help.WCMHelps
        • com.trs.components.wcm.publish.WCMPubStatusConfigs
        • com.trs.components.wcm.content.persistent.WebSites
        • com.trs.components.common.publish.widget.WidgetInstances
        • com.trs.components.common.publish.widget.WidgetInstParameters
        • com.trs.components.common.publish.widget.WidgetParameters
        • com.trs.components.common.publish.widget.Widgets
      • com.trs.infra.persistent.CMyResultObjs
        • com.trs.infra.persistent.CMyResultSets
        • com.trs.components.wcm.content.persistent.XDocuments
      • com.trs.infra.support.config.Configs
      • com.trs.db.update.DBUpdateLogs
      • com.trs.infra.util.job.JobFailedResults
      • com.trs.infra.support.log.LogBaks
      • com.trs.infra.support.log.Logs
      • com.trs.components.metadata.center.MetaViewEmployers
      • com.trs.components.common.message.MsgReceivers
      • com.trs.infra.persistent.MyBaseObjs
      • com.trs.infra.support.log.OperTypes
      • com.trs.infra.support.security.SecureKeys
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
        • com.trs.components.metadata.definition.xml.MetaDBFieldXMLConvertor
        • com.trs.components.metadata.center.xml.MetaViewDataToExcel
        • com.trs.components.metadata.center.xml.MetaViewDataToXML
        • com.trs.components.metadata.definition.xml.MetaViewFieldXMLConvertor
      • com.trs.components.wcm.content.persistent.ChannelXmlConverter
      • com.trs.components.metadata.definition.xml.ClassInfoXMLConvertor
      • com.trs.components.wcm.content.persistent.ContentExtFieldXmlConverter
      • com.trs.components.common.publish.widget.ContentStyleXmlConverter
      • com.trs.components.wcm.content.persistent.DocumentXmlConverter
      • com.trs.cms.process.xml.FlowNodeXmlConverter
      • com.trs.cms.process.xml.FlowRuleXMLConvertor
      • com.trs.cms.process.xml.FlowXmlConverter
      • com.trs.cms.auth.persistent.GroupXmlConverter
      • com.trs.infra.support.log.LogXmlConverter
      • com.trs.components.metadata.definition.xml.MetaTableXMLConvertor
      • com.trs.components.metadata.definition.xml.MetaViewXMLConvertor
      • com.trs.infra.persistent.ObjToXmlConverter
      • com.trs.infra.persistent.ObjToXmlConverterByDOM4j
      • com.trs.components.common.publish.widget.PageStyleXmlConverter
      • com.trs.components.common.publish.widget.ResourceStyleXmlConverter
      • com.trs.cms.auth.persistent.RoleXmlConverter
      • com.trs.components.common.publish.persistent.template.TempAppendixXmlConverter
      • com.trs.components.common.publish.persistent.template.TemplateXmlConverter
      • com.trs.components.common.publish.widget.WidgetXmlConverter
    • com.trs.components.web.BasePropertiesBuilder (implements com.trs.components.web.IPropertiesBuilder)
      • com.trs.components.web.DefaultPropertiesBuilder
      • com.trs.components.web.document.DocumentPropertiesBuilder
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.config.BaseConfigServer
        • com.trs.components.metadata.service.DefaultChannelMakerCenter
        • com.trs.components.metadata.center.FieldValueCreatorConfigStartServer
        • com.trs.components.infoview.helper.InfoViewFieldValueCreatorConfigStartServer
        • com.trs.webframework.config.ServiceConfigStartServer
        • com.trs.webframework.xmlserver.XMLConvertorConfigStartServer
      • com.trs.infra.config.BeanConfigServer
      • com.trs.infra.support.cache.CacheServer
      • com.trs.infra.support.config.ConfigServer (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
      • com.trs.infra.persistent.db.DBManager
      • com.trs.cms.process.config.FlowConfigServer
      • com.trs.cms.process.definition.FlowRuleCacheServerImpl (implements com.trs.cms.process.definition.IFlowRuleCacheServer)
      • com.trs.cms.process.FlowServer
      • com.trs.cms.process.FlowServerImpl (implements com.trs.cms.process.IFlowServer)
      • com.trs.components.infoview.db.InfoViewDBStoreServer
      • com.trs.components.common.job.JobScheduleServer
      • com.trs.components.wcm.content.trsserver.KMTRSServer
      • com.trs.presentation.locale.LocaleServer
      • com.trs.components.common.message.notify.NotificationServer (implements org.aton.container.IClearable)
      • com.trs.infra.persistent.listener.ObjectLCMonitorServer (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
      • com.trs.cms.ObjectTypeServer
      • com.trs.components.wcm.content.trsserver.OuterKMTRSServer
      • com.trs.components.common.publish.domain.PublishServer
      • com.trs.cms.auth.config.RightConfigServer
      • com.trs.components.ckm.TRSCKMServer (implements com.trs.components.ckm.ICKMServer)
      • com.trs.cluster.TRSWCMClusterServer
      • com.trs.infra.update.UpdateServer
      • com.trs.infra.config.XMLConfigServer
    • com.trs.webframework.provider.BaseServiceDecorator (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.stat.BaseStatHandler (implements com.trs.components.stat.IKeyMaker, com.trs.components.stat.IStatHandler)
      • com.trs.components.stat.DefaultStatHandler
      • com.trs.components.stat.DocStatHandler4Channel
      • com.trs.components.stat.DocStatHandler4ChannelOfGroup
      • com.trs.components.stat.DocstatHandler4ChannelOfUser
      • com.trs.components.stat.DocStatHandler4ChnlDept
      • com.trs.components.stat.DocStatHandler4ChnlDeptChannel
      • com.trs.components.stat.DocStatHandler4ChnlDeptSite
      • com.trs.components.stat.DocStatHandler4SiteOfGroup
      • com.trs.components.stat.DocstatHandler4SiteOfUser
      • com.trs.components.stat.DocStatHandler4UserChannel
      • com.trs.components.stat.DocStatHandler4UserDept
      • com.trs.components.stat.DocStatHandler4UserDeptChannel
      • com.trs.components.stat.DocStatHandler4UserDeptSite
      • com.trs.components.stat.DocStatHandler4UserSite
      • com.trs.components.stat.HitsStatHandler4Channel
      • com.trs.components.stat.HitsStatHandler4ChnlDept
      • com.trs.components.stat.HitsStatHandler4User
      • com.trs.components.stat.HitsStatHandler4UserDept
    • com.trs.components.common.publish.domain.tagparser.BaseTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.domain.tagparser.BaseTagParser4List (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
        • com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects
          • com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects
            • com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase
              • com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannel
        • com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments
          • com.trs.components.wcm.publish.tagparser.WCMTagParserNextDocuments
          • com.trs.components.wcm.publish.tagparser.WCMTagParserPreDocuments
        • com.trs.components.common.publish.domain.tagparser.TagParserDetailPages
        • com.trs.components.metadata.publish.WCMTagParserClassDocuments
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentChannels
        • com.trs.components.metadata.publish.WCMTagParserMyViewDatas
        • com.trs.components.metadata.publish.WCMTagParserViewDatas
        • com.trs.components.metadata.publish.WCMTagParserViewFields
        • com.trs.components.wcm.publish.tagparser.WCMTagParserWebSites
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation
        • com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlInChnlOperation
        • com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlOperation
        • com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation
        • com.trs.components.common.publish.widget.tagparser.WCMTagParserDocOperation
      • com.trs.components.metadata.publish.WCMTagParserClassInfos (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
      • com.trs.wcm.photo.publish.WCMTagParserImage
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserLayoutCell
      • com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase
        • com.trs.components.wcm.publish.tagparser.WCMTagParserChannelLogo
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentLogo
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserResources
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserWidget
      • com.trs.components.wcm.publish.tagparser.XWCMContImgTagParser
    • com.trs.webframework.controler.servlet.BaseValidator
      • com.trs.webframework.controler.JSPRequestParmasValidator
      • com.trs.webframework.controler.servlet.RequestParmasValidator
      • com.trs.webframework.controler.servlet.XMLParamsValidator
    • com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
      • com.trs.ajaxservice.xmlconvertors.AppendixToXML
      • com.trs.ajaxservice.xmlconvertors.ChannelSynToXML
      • com.trs.ajaxservice.xmlconvertors.ChannelToXML
      • com.trs.ajaxservice.xmlconvertors.ChnlDocToXML
      • com.trs.ajaxservice.xmlconvertors.ContentExtFieldToXML
      • com.trs.ajaxservice.xmlconvertors.ContentLink2Xml
      • com.trs.ajaxservice.xmlconvertors.DefaultWCMObjectsToXML
      • com.trs.ajaxservice.xmlconvertors.DocumentToXML
      • com.trs.ajaxservice.xmlconvertors.ExtFieldToXML
      • com.trs.ajaxservice.xmlconvertors.FlowDocToXML
      • com.trs.ajaxservice.xmlconvertors.FlowToXML
      • com.trs.ajaxservice.xmlconvertors.MessageToXML
      • com.trs.ajaxservice.xmlconvertors.PageOpertatosToXML
      • com.trs.ajaxservice.xmlconvertors.RelationToXML
      • com.trs.ajaxservice.xmlconvertors.TemplateEmployerToXML
      • com.trs.ajaxservice.xmlconvertors.TemplateToXML
      • com.trs.ajaxservice.xmlconvertors.ViewDocumentToXML
        • com.trs.ajaxservice.xmlconvertors.InfoViewDocumentToXML
      • com.trs.ajaxservice.xmlconvertors.Watermark2Xml
      • com.trs.ajaxservice.xmlconvertors.WebSiteToXML
    • com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask (implements org.aton.container.IClearable, com.trs.components.common.publish.domain.taskdispatch.IPageTask)
    • com.trs.infra.config.persistent.BeanConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.config.domain.BeanConfigHelper
    • com.trs.components.infoview.config.BindingBean
    • com.trs.components.stat.BonusCalculator (implements com.trs.components.stat.IBonusCalculator)
    • com.trs.components.stat.BonusRuleMgr (implements com.trs.components.stat.IBonusRuleMgr)
    • com.trs.components.stat.BonusRuleServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.common.bookmark.BookMarkMgr
    • com.trs.service.impl.BookMarkService (implements com.trs.service.IBookMarkService)
    • com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.infra.util.cabfile.CabEntry (implements com.trs.infra.util.cabfile.CabConstants)
    • com.trs.infra.util.cabfile.CabFile (implements com.trs.infra.util.cabfile.CabConstants)
    • com.trs.components.infoview.CABFileExtractor
      • com.trs.components.infoview.extract.JavaCABFileExtractor
      • com.trs.components.infoview.extract.WinCABFileExtractor
    • com.trs.infra.persistent.cache.CachedObjectConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.cache.CachedPOMgr (implements com.trs.infra.persistent.cache.ICachedPOMgr)
    • com.trs.infra.support.cache.CacheMgrConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.infoview.extract.manifest.CalculatedField
    • com.trs.infra.util.database.CAS400CLOB
    • com.trs.presentation.ids.CAUserSync
    • com.trs.presentation.ids.CAUserSync.UserInfo
    • com.trs.infra.util.database.CDB2DBCLOB
    • com.trs.infra.util.database.CDB2DBCLOB2
    • com.trs.infra.util.database.CDBKeyWords
    • com.trs.infra.util.database.CDBText
    • com.trs.service.impl.CDSServiceImpl (implements com.trs.service.ICDSService)
    • com.trs.components.wcm.publish.region.CellServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.publish.region.CellsSaveListenerForPublish (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.wcm.auth.ChannelAuthHelper
    • com.trs.components.metadata.service.listener.ChannelCreateFromListenerForMetaView (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.wcm.publish.region.ChannelDocListenerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.ChannelExporter
    • com.trs.ajaxservice.ChannelHelper
    • com.trs.components.stat.ChannelHitsCountHandler (implements com.trs.components.stat.IHitsCountHandler)
    • com.trs.components.wcm.content.domain.ChannelImporter
    • com.trs.components.wcm.epress.ChannelLCListener4EPress (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ChannelLCListenerForChannelSyn (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ChannelLCListenerForDocument (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.ChannelLCListenerForExtField (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.process.ChannelLCListenerForFlow (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.ChannelLCListenerForSpeical (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.publish.region.ChannelListenerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.persistent.ChannelLoopValidator
    • com.trs.components.wcm.content.domain.ChannelMgr
    • com.trs.components.wcm.content.persistent.ChannelNameMgr (implements com.trs.components.wcm.content.persistent.IChannelNameMgr)
    • com.trs.presentation.nav.ChannelNavHandler (implements com.trs.presentation.nav.INavHandler)
    • com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView (implements com.trs.components.wcm.content.service.portervisitors.IPorterVisitor)
    • com.trs.components.wcm.wcmx.websites.ChannelRelated
    • com.trs.components.wcm.auth.ChannelRightObjImpl (implements com.trs.cms.auth.domain.IRightObj)
    • com.trs.service.impl.ChannelService (implements com.trs.service.IChannelService)
    • com.trs.ajaxservice.ChannelServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.ChannelServiceProviderHelper
    • com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)
      • com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker
    • com.trs.infra.util.CharsetDetector
    • com.trs.servlet.CharSetFilter (implements javax.servlet.Filter)
    • com.trs.components.wcm.stat.domain.ChartConstants
    • com.trs.components.wcm.stat.domain.ChartOption
    • com.trs.components.wcm.stat.domain.ChartStyle
    • com.trs.components.wcm.stat.domain.ChartWriter
    • com.trs.components.wcm.content.persistent.ChildrenCacheMgr (implements com.trs.components.wcm.content.persistent.IChildrenMgr)
    • com.trs.tools.ChineseFinder
    • com.trs.components.stat.ChnlDeptMgr (implements com.trs.components.stat.IChnlDeptMgr)
    • com.trs.components.stat.ChnlDeptMgrForCluster (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ChnlDocLCListenerForAutoDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.process.ChnlDocLCListenerForFlow (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.metadata.center.ChnlDocLCListenerForSynToMetaData (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.ChnlDocLCListnerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.logger.ChnlDocLogger (implements com.trs.cms.logger.IObjLogger)
    • com.trs.ajaxservice.ChnlDocServiceProvider (implements com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.infra.util.CImage
    • com.trs.infra.util.key.CKeyUtil
    • com.trs.components.metadata.center.ClassDocumentsHelper
    • com.trs.components.wcm.content.trsserver.ClassInfo
    • com.trs.components.metadata.definition.ClassInfoCacheMgr (implements com.trs.components.metadata.definition.IClassInfoCacheMgr)
    • com.trs.components.metadata.service.ClassInfoChannelRightHelper
    • com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl (implements com.trs.components.metadata.publish.IClassInfoCountCacheForPublish)
    • com.trs.components.metadata.definition.xml.ClassInfoImporter
    • com.trs.components.metadata.definition.ClassInfoListenerForViewData (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.metadata.definition.ClassInfoMgr (implements com.trs.components.metadata.definition.IClassInfoMgr)
    • com.trs.presentation.nav.ClassInfoNavHandler (implements com.trs.presentation.nav.INavHandler)
    • com.trs.components.metadata.service.ClassInfoPublishServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.ClassInfoServiceProvider (implements com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.ClassInfoServiceProviderForGB (implements com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.ClassInfoToChannelHelper
    • com.trs.components.metadata.service.ClassInfoToGroupCreator
    • com.trs.components.metadata.definition.ClassInfoUtil
    • com.trs.components.metadata.center.ClassInfoViewMgr (implements com.trs.components.metadata.center.IClassInfoViewMgr)
    • com.trs.components.metadata.service.ClassInfoViewService
    • com.trs.components.metadata.service.ClassInfoViewServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.cluster.ClusterConfigHelper
    • com.trs.cluster.ClusterConstants
    • com.trs.infra.util.database.ClusterDBIdManager
    • com.trs.cms.content.ClusterLocker
    • com.trs.cluster.ClusterMsgCenterImpl (implements com.trs.cluster.IClusterMsgCenter)
    • com.trs.cms.CMSConstants
    • com.trs.presentation.util.CmsObjUnlockTools
    • com.trs.infra.util.CMy3WLib
    • com.trs.infra.util.CMyBitsValue (implements java.lang.Cloneable)
      • com.trs.cms.auth.persistent.RightValue
    • com.trs.infra.util.CMyDateTime (implements java.lang.Cloneable, java.io.Serializable)
    • com.trs.infra.util.CMyDecimalBuddy
    • com.trs.infra.util.CMyDOM4jHelper
    • com.trs.infra.util.email.CMyEmail
    • com.trs.infra.util.CMyEncrypt
    • com.trs.infra.util.CMyErrors
    • com.trs.infra.util.CMyFile
    • com.trs.infra.util.CMyFilenameFilter (implements java.io.FilenameFilter)
    • com.trs.infra.util.CMyFileX
    • com.trs.infra.util.ftp.CMyFtp (implements java.lang.Runnable)
    • com.trs.infra.util.CMyKeyGenerator
    • com.trs.infra.util.email.CMyMailLog
    • com.trs.infra.util.CMyMemory
    • com.trs.infra.persistent.CMyParameter
    • com.trs.infra.util.CMySign
    • com.trs.infra.util.CMySMS
    • com.trs.infra.util.soap.CMySoapClient
      • com.trs.infra.util.soap.OcrSoapClient
    • com.trs.infra.util.database.CMysqlText
    • com.trs.infra.util.CMyString
    • com.trs.presentation.publish.template.CMyTemplateWizard
    • com.trs.infra.util.CMyTransformCoding
    • com.trs.infra.util.CMyUnzip
    • com.trs.infra.util.CMyUnZipFile
    • com.trs.infra.util.CMyURLEncoder
    • com.trs.infra.util.CMyXMLDoc
    • com.trs.infra.util.CMyXMLElement
      • com.trs.infra.util.CMyBeanConfig
      • com.trs.infra.util.CMyClassConfig
        • com.trs.infra.util.email.CMySMTPServer
    • com.trs.infra.util.CMyXMLParser
    • com.trs.infra.util.CMyZip
    • com.trs.infra.util.upgrade.dbcompare.Column
    • com.trs.components.comment.CommentConstants
    • com.trs.components.comment.publish.helper.CommentParserEntity
    • com.trs.components.comment.publish.helper.CommentParserUtil
    • com.trs.components.comment.service.CommentService (implements com.trs.components.comment.service.ICommentService)
    • com.trs.components.comment.domain.CommentUpdator
    • com.trs.tools.CommonResourceBuilder
    • com.trs.components.common.conjection.ComponentEntryConfigConstants
    • com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl (implements com.trs.components.common.conjection.service.IComponentEntryConfigService)
    • com.trs.cms.process.config.ConditionHandlerConfig
    • com.trs.cms.process.engine.handlers.ConditionHelper
    • com.trs.infra.config.ConfigConstants
    • com.trs.infra.config.ConfigController
    • com.trs.infra.util.ConfigElementContentTester
    • com.trs.infra.config.persistent.ConfigFile
    • com.trs.infra.config.persistent.ConfigFiles
    • com.trs.infra.config.domain.ConfigFilesFinder
    • com.trs.ConfigFileTool4Refactor
    • com.trs.infra.config.domain.ConfigHelper
    • com.trs.infra.config.domain.ConfigObjectLoader
    • com.trs.infra.util.database.ConnectionPool
    • com.trs.infra.persistent.db.ConnectPasswordEncrypter
    • com.trs.infra.util.upgrade.Constants
    • com.trs.components.common.address.ContactMgr
    • com.trs.components.common.address.ContactMsgSender
    • com.trs.service.impl.ContactService (implements com.trs.service.IContactService)
    • com.trs.components.wcm.content.domain.ContentExtFieldCListenerForDocProps (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ContentExtFieldLCListenerForDocFields (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ContentExtFieldMgr
    • com.trs.components.wcm.content.domain.ContentLinkMgr
    • com.trs.infra.util.html.ContentLinkReplacer
    • com.trs.ajaxservice.ContentLinkServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.cms.process.engine.ContentProcessInfo
    • com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.cms.process.engine.handlers.ContentPropertyHandler (implements com.trs.cms.process.engine.IConditionHandler)
    • com.trs.components.common.publish.widget.ContentStyleExporter
    • com.trs.components.common.publish.widget.ContentStyleImporter
    • com.trs.components.common.publish.widget.ContentStyleMgr (implements com.trs.components.common.publish.widget.IContentStyleMgr)
    • com.trs.components.common.publish.widget.ContentStyleServiceProvider (implements com.trs.components.common.publish.widget.IContentStyleServiceProvider)
    • com.trs.components.wcm.content.ContentUpdateCommanderImpl (implements com.trs.infra.update.IUpdateCommander)
    • com.trs.cms.ContextHelper
    • com.trs.infra.common.ContextParameters
    • com.trs.infra.util.CopyOfTRSImportsOrgnize
    • com.trs.infra.util.database.COracleCLOB
    • com.trs.infra.util.CPager
    • com.trs.infra.util.jazzlib.CRC32 (implements com.trs.infra.util.jazzlib.Checksum)
    • com.wcm.pdf.CreateThreadForPDF
    • com.wcm.pdf.CreateThreadForPDFOfWins
    • com.trs.infra.util.key.CRegister
    • com.trs.components.wcm.util.CRightUtil
    • com.trs.infra.util.database.CSQLText
    • com.trs.components.common.publish.domain.template.CSSResourceProcessor
    • com.trs.cms.process.engine.creators.CurrentDateCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.cms.process.engine.creators.CurrentDocStatusCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.cms.process.engine.creators.CurrentTimeCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.cms.process.engine.creators.CurrentUserNameCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.components.wcm.customize.CustomizeMgr
    • com.trs.wcm.customize.CustomizeMgrImpl (implements com.trs.wcm.customize.ICustomizeMgr)
    • com.trs.service.impl.CustomizeService (implements com.trs.service.ICustomizeService)
    • com.trs.components.wcm.wcmx.util.CWasTree
    • com.trs.database.util.DataDictionary
    • com.trs.components.wcm.newshoo.DataFromNewshoo
    • com.trs.components.wcm.newshoo.DataFromRadar
    • com.trs.components.wcm.newshoo.DataFromRadarClient
    • com.trs.components.infoview.extract.DataGroup
    • com.trs.util.DataOfV6To52
    • com.trs.components.wcm.content.trsserver.DatasFromTRSServer
    • com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper
    • com.trs.template.DataTransferEncodeFactory
    • com.trs.components.infoview.extract.DataType (implements java.lang.Cloneable)
    • com.trs.infra.util.database.DataType
    • com.trs.components.infoview.extract.DataTypeBuilder
    • com.trs.ajaxservice.xmlconvertors.DataTypeToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.components.wcm.wcmx.jsp.DataUtil
    • com.trs.infra.util.database.DB2ReorgUtil
    • com.trs.infra.util.upgrade.DbConfig
    • com.trs.infra.persistent.db.DBConnectionConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.db.DBConnectionConfigs (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.db.DBConnectionMapper (implements org.aton.container.IClearable)
    • com.trs.database.util.DbDDLMaker
    • com.trs.infra.util.database.DBIdManager
    • com.trs.infra.util.database.DBIdManager.IdSeq
    • com.trs.cluster.receiver.DBMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.service.impl.DBService (implements com.trs.service.IDBService)
    • com.trs.infra.util.database.DBType
      • com.trs.infra.util.database.DB2AS400DB
      • com.trs.infra.util.database.DB2UDB
      • com.trs.infra.util.database.DB2UDB2
        • com.trs.infra.util.database.DB2UDBV9
      • com.trs.infra.util.database.MysqlDB
      • com.trs.infra.util.database.OracleDB
        • com.trs.infra.util.database.AndinOraDB
        • com.trs.infra.util.database.OracleDB11G
      • com.trs.infra.util.database.SQLServerDB
        • com.trs.infra.util.database.DamengDB
        • com.trs.infra.util.database.KingBaseDB
        • com.trs.infra.util.database.XuguDB
      • com.trs.infra.util.database.SybaseASE
      • com.trs.infra.util.database.SybaseASEWithJtds
    • com.trs.infra.util.database.DBTypes
    • com.trs.db.update.DBUpdateLogMgr
    • com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker
    • com.trs.database.util.DDLMain
    • com.trs.infra.util.DebugTimer
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.trs.infra.persistent.BaseObjHandler
      • com.trs.infra.persistent.BaseObjsHandler
      • com.trs.infra.util.CMyXMLHandler
      • com.trs.webframework.controler.PostDataParser
      • com.trs.cms.content.WCMHandler
      • com.trs.cms.content.WCMObjsHandler
      • com.trs.webframework.xmlserver.server.XMLDataProcessingHandler (implements com.trs.webframework.xmlserver.server.IObserverable)
    • com.trs.presentation.util.DefaultWhereSQLMaker
    • com.trs.webframework.provider.DefautlServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.infra.util.jazzlib.Deflater
    • com.trs.cms.auth.domain.DepartmentMgrImpl (implements com.trs.cms.auth.domain.IDepartmentMgr)
    • com.trs.infra.util.upgrade.sql.DiffSqlMaker
    • com.trs.infra.util.DiscoveryFactoryBuddy
    • com.trs.ajaxservice.DistributeServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.components.wcm.content.domain.DocBakLCListenerForApd (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.DocBakMgr
    • com.trs.components.wcm.content.domain.DocKeywordMgrImpl (implements com.trs.components.wcm.content.domain.IDocKeywordMgr)
    • com.trs.components.wcm.wcmx.jsp.DocOperDefine
    • com.trs.components.wcm.content.domain.DocReplyMgr
    • com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex
    • com.trs.components.wcm.content.trsserver.DocsFromTRSServer
    • com.trs.ajaxservice.DocumentAuthHelper
    • com.trs.components.wcm.content.domain.auth.DocumentAuthServer
    • com.trs.ajaxservice.DocumentBakServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.content.domain.DocumentExporter
    • com.trs.components.wcm.content.persistent.DocumentFieldConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.metadata.center.DocumentFieldsSynFactory
    • com.trs.components.stat.DocumentHitsCountHandler (implements com.trs.components.stat.IHitsCountHandler)
    • com.trs.components.wcm.content.domain.DocumentImporter
    • com.trs.presentation.documetimport.xml.DocumentImportXmlHelper
    • com.trs.wcm.photo.DocumentLCLisenterForPhoto (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.epress.DocumentLCListener4EPress (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForAutoDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForDocReply (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.DocumentLCListenerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForRelation (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.ckm.DocumentLCListenerForSIMSearch (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.metadata.center.DocumentListenerForMetaViewData (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.region.DocumentListenerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentMgr
    • com.trs.components.wcm.content.domain.DocumentMoveListenerForDocSiteRecode (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.wcm.content.domain.DocumentPriMgr
    • com.trs.ajaxservice.DocumentPublishHelper
    • com.trs.components.infoview.extract.manifest.DocumentSchema
    • com.trs.service.impl.DocumentService (implements com.trs.service.IDocumentService)
    • com.trs.ajaxservice.DocumentServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.content.domain.DocumentsGetHelper
    • com.trs.components.wcm.content.persistent.DocumentShowFieldConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.presentation.wcm.content.DocumentsPageHelper
    • com.trs.components.wcm.publish.tagparser.DocumentsTemp
    • com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl (implements com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr)
    • com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)
      • com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.ajaxservice.DocumentSynServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.comment.domain.DocumentTopicRelationMgr
    • com.trs.DreamFactory
    • com.trs.components.common.message.EmailSendWorker (implements com.trs.components.common.message.ISendWorker)
    • com.trs.components.infoview.config.EnumCreator
    • com.trs.components.infoview.config.EnumsConfig
    • com.trs.components.wcm.epress.EPressChannelWrapper
    • com.trs.components.wcm.epress.EPressConf
    • com.trs.components.wcm.epress.EPressHistoryGenerator
    • com.trs.components.wcm.epress.EPressImporter
    • com.trs.components.wcm.epress.EPressServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.wcm.epress.EPressSoapService
    • com.trs.components.wcm.epress.EPressXPlusImporter
    • com.trs.template.ErrorMessagesFactory
    • com.trs.components.common.calendar.EventLCListenerForRemind (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.calendar.EventMgr
    • com.trs.service.impl.EventService (implements com.trs.service.IEventService)
    • com.trs.infra.util.ExceptionMessages
    • com.trs.infra.util.ExceptionNumber
    • com.trs.cms.process.engine.ExecuteContext
    • com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.ajaxservice.ExtendFieldServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.infra.config.persistent.ExtensionConfigs (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.util.database.FieldInfo
    • com.trs.components.metadata.web.FieldTemplate
      • com.trs.components.metadata.web.impl.AddEditFieldTemplate
      • com.trs.components.metadata.web.impl.ListFieldTemplate
      • com.trs.components.metadata.web.impl.ViewFieldTemplate
    • com.trs.components.metadata.web.impl.FieldTemplateFactory
    • com.trs.components.metadata.center.FieldValueCreatorFactory
    • com.trs.components.common.publish.domain.distribute.FileDistributeQueue
    • com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item
    • com.trs.components.common.publish.domain.distribute.FileDistributeShip (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl (implements com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal (implements com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS (implements com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion (implements com.trs.components.common.publish.domain.distribute.DistributionChangeListener, com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl (implements com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.cluster.FileMsgProcessor
    • com.trs.components.common.publish.config.persistent.FileNamedStyle (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.util.FileNameExtFilter (implements java.io.FilenameFilter)
    • com.trs.components.infoview.extract.manifest.FileNew
    • com.trs.components.wcm.content.domain.intelligence.FilePathFilter (implements java.io.FileFilter)
    • com.trs.components.infoview.extract.manifest.FileProperty
    • com.trs.components.wcm.soap.FileService
    • com.trs.infra.support.file.FilesMan
    • com.trs.cluster.receiver.FileWithdrawMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.cms.process.definition.FlowCacheMgr (implements com.trs.infra.support.cache.ICacheMgr, com.trs.cms.process.IFlowCacheMgr)
    • com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl (implements com.trs.cms.process.IFlowContent)
    • com.trs.components.wcm.process.element.FlowContentDocumentImpl (implements com.trs.cms.process.IFlowContent)
      • com.trs.components.wcm.process.element.MyFlowContentDocumentImpl
    • com.trs.cms.process.FlowContentFactory
    • com.trs.cms.process.config.FlowContentField
    • com.trs.cms.process.engine.FlowContentHelper
    • com.trs.cms.process.engine.FlowContentLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.ajaxservice.xmlconvertors.FlowContentsToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.cms.process.config.FlowContentTypeConfig
    • com.trs.cms.process.engine.FlowContext
    • com.trs.cms.process.engine.FlowContextOld
    • com.trs.components.wcm.process.service.domain.FlowConverterForWebsiteImporter (implements com.trs.components.wcm.content.domain.IChannelImporterConverter)
    • com.trs.cms.process.definition.FlowEmployCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.cms.process.definition.FlowEmployerLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.process.FlowEmployLCListenerForChange (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.cms.process.definition.FlowEmployMgr
    • com.trs.cms.process.FlowEngineHelper
    • com.trs.cms.process.xml.FlowImporter
    • com.trs.cms.process.FlowingDocLogger
    • com.trs.cms.process.FlowingDocOptMarkScouter
    • com.trs.ajaxservice.FlowingDocQueryService (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.cms.process.definition.FlowMgr
    • com.trs.cms.process.engine.FlowNextBranchInfo
    • com.trs.cms.process.engine.FlowNodeLCListenerForForceEnd (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.process.FlowNotifyWorkerImpl (implements com.trs.cms.process.IFlowNotifyWorker)
    • com.trs.cms.process.definition.FlowOptMarkEnumParser
    • com.trs.cms.process.engine.FlowParamers
    • com.trs.cms.process.engine.FlowUserHelper
    • com.trs.components.common.publish.persistent.publisher.FolderPublishConfigCacheMgr
    • com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl (implements com.trs.components.wcm.publish.IFolderPubStatusCacheMgr)
    • com.trs.components.infoview.publish.tagparser.FormProperty
    • com.trs.webframework.FrameworkConstants
    • com.trs.infra.util.uftp.FtpConfig
    • com.trs.infra.util.uftp.FtpConnection
      • com.trs.infra.util.uftp.FtpConnectionImpFtp
      • com.trs.infra.util.uftp.FtpConnectionImpSSH
    • com.trs.infra.util.uftp.FtpConnectionCache (implements org.aton.container.IClearable)
    • com.trs.infra.util.ftp.FtpConnectionPool (implements org.aton.container.IClearable, java.lang.Runnable)
    • com.trs.infra.util.ftp.FtpMgr (implements com.trs.infra.util.ftp.IFtpMgr)
    • com.trs.infra.util.ftp.FtpMgrTest (implements java.lang.Runnable)
    • com.trs.service.impl.FtpSoap4Radar
    • com.trs.components.infoview.config.GatewayConfig
    • com.trs.components.infoview.config.GatewayPage
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • com.trs.webframework.controler.servlet.FileUploader
        • com.trs.webframework.controler.servlet.NoLoginServiceControler
        • com.trs.webframework.controler.servlet.ServiceControler
          • com.trs.components.infoview.filter.InfoviewDataImportFilter
        • com.trs.infra.StartupServlet
        • com.trs.weblet.util.verfiycode.VerifyCodeServlet
    • com.trs.components.metadata.service.GovInfoIndexCreator (implements com.trs.components.metadata.center.IMetaDataFieldValueCreator)
    • com.trs.components.govinfo.GovInfoLCListenerMetaView (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.metadata.service.GovInfoServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.GovInfoToXML
    • com.trs.components.govinfo.GovInfoViewFinder
    • com.trs.cms.auth.persistent.GroupAdminsCacheMgr (implements com.trs.infra.support.cache.ICacheMgr, com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.cms.auth.domain.GroupAuthServer
    • com.trs.cms.auth.domain.GroupMgr
    • com.trs.cms.auth.domain.GroupRightObjImpl (implements com.trs.cms.auth.domain.IRightObj)
    • com.trs.cms.auth.domain.GroupRoleMgr
    • com.trs.service.impl.GroupService (implements com.trs.service.IGroupService)
    • com.trs.ajaxservice.GroupServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.cms.auth.persistent.GroupUserCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.webframework.config.HashCodeUtil
    • com.trs.components.stat.HitsCountConstant
    • com.trs.components.stat.HitsCountHelper
    • com.trs.infra.util.html.HTML
    • com.trs.infra.util.html.HTML.Attribute
    • com.trs.infra.util.html.HTML.Tag
      • com.trs.infra.util.html.HTML.UnknownTag (implements java.io.Serializable)
    • com.trs.tools.Html2text
    • com.trs.infra.util.html.HtmlAttribute (implements java.lang.Cloneable)
    • com.trs.tools.HtmlCleaner
    • com.trs.infra.util.html.HtmlComment (implements java.lang.Cloneable)
    • com.trs.cms.content.HTMLContent
    • com.trs.infra.util.html.HtmlDocument
    • com.trs.infra.util.html.HtmlElement (implements java.lang.Cloneable)
    • com.trs.infra.util.html.HtmlElementFinder
    • com.trs.components.metadata.web.HTMLMakerFactory
    • com.trs.infra.util.html.HtmlUtil
    • com.trs.wcag2.HTMLUtil
    • com.trs.components.common.conjection.helper.HttpChecker
    • com.trs.infra.util.HttpClientBuddy
    • com.trs.infra.util.HttpGet
    • com.trs.infra.I18NMessage
    • com.trs.infra.I18NMessageStartUp (implements javax.servlet.ServletContextListener)
    • com.trs.wcm.photo.ImageInfo (implements java.lang.Cloneable)
    • com.trs.wcm.photo.ImageKind
    • com.trs.wcm.photo.impl.ImageLibConfigImpl (implements com.trs.wcm.photo.IImageLibConfig)
    • com.trs.wcm.photo.ImageLibConstants
    • com.trs.wcm.photo.ImageLibHelper
    • com.trs.wcm.photo.impl.ImageLibMgrImpl (implements com.trs.wcm.photo.IImageLibMgr)
    • com.trs.wcm.photo.impl.ImageLibServiceImpl (implements com.trs.wcm.photo.IImageLibService)
    • com.trs.wcm.photo.impl.ImageMagickCmd
    • com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj
    • com.trs.cms.content.ImgRec
    • com.trs.wcm.old.ImportDocsContext
    • com.trs.wcm.old.ImportDocsFromFile
      • com.trs.wcm.old.ImportDocsFromHTMLFile
    • com.trs.database.util.IndexDDLMaker
    • com.trs.database.util.IndexList4Ora
    • com.trs.components.wcm.individuation.IndividuationMgr
    • com.trs.ajaxservice.IndividuationServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.infra.util.jazzlib.Inflater
    • com.trs.infra.util.jazzlib.InflaterHuffmanTree
    • com.trs.template.persistent.InfoEntities (implements com.trs.infra.util.xml.IXmlPersistentObject)
    • com.trs.template.domain.InfoEntityFinder
    • com.trs.components.infoview.extract.InfoPathFileData
    • com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper
    • com.trs.components.infoview.InfoViewConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.infoview.InfoViewConstants
    • com.trs.service.InfoViewContext
    • com.trs.components.infoview.InfoViewDataHelper
    • com.trs.components.infoview.mad.InfoViewDataHelperImpl (implements com.trs.components.infoview.mad.InfoViewDataHelper)
    • com.trs.components.infoview.InfoviewDataProcessor
    • com.trs.ajaxservice.InfoviewDataToolService (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.infoview.db.InfoViewDataType
    • com.trs.components.infoview.db.InfoViewDataTypes
    • com.trs.components.infoview.db.InfoViewDBMgr (implements com.trs.components.infoview.db.IInfoViewDBMgr)
    • com.trs.service.impl.InfoViewDocImportService
    • com.trs.ajaxservice.InfoViewDocumentServiceProvider (implements com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd)
    • com.trs.components.infoview.InfoViewEmployMgr
    • com.trs.service.impl.InfoViewEnumCreatorImpl (implements com.trs.service.IInfoViewEnumCreator)
    • com.trs.components.infoview.config.InfoViewEnumHelper
    • com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory
    • com.trs.components.infoview.InfoViewHelper
    • com.trs.service.impl.InfoViewInitorImpl (implements com.trs.service.IInfoViewInitor)
    • com.trs.components.infoview.InfoViewMgr
    • com.trs.components.infoview.helper.InfoViewNewQueryHelper
    • com.trs.components.infoview.helper.InfoViewQueryHelper
    • com.trs.components.infoview.mad.InfoViewQueryHelperImpl (implements com.trs.components.infoview.mad.InfoViewQueryHelper)
    • com.trs.components.infoview.InfoViewReplyNoticeSender
    • com.trs.components.infoview.persistent.InfoViewSerial
    • com.trs.components.infoview.persistent.InfoViewSerialGenerator
    • com.trs.ajaxservice.InfoviewService (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.service.impl.InfoViewService (implements com.trs.service.IInfoViewService)
    • com.trs.components.infoview.publish.tagparser.InfoviewSpecailTagParseHelper
    • com.trs.components.infoview.helper.InfoViewTemplateHelper
    • com.trs.components.infoview.db.InfoviewXMLDataUpdator
    • com.trs.template.InnerExceptionNum
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • com.trs.infra.util.BASE64DecoderStream
        • com.trs.infra.util.jazzlib.CheckedInputStream
        • com.trs.infra.util.jazzlib.InflaterInputStream
          • com.trs.infra.util.jazzlib.GZIPInputStream
          • com.trs.infra.util.jazzlib.ZipInputStream
      • javax.servlet.ServletInputStream
        • com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper
      • com.trs.infra.util.XmlCharCheckedInputStream
    • com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl (implements com.trs.components.wcm.content.domain.intelligence.IIntellResLocator)
    • com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl (implements com.trs.components.wcm.content.domain.intelligence.IIntellMgr)
    • com.trs.webframework.xmlserver.server.InvocationObserver (implements com.trs.webframework.xmlserver.server.IObserver)
    • com.trs.webframework.xmlserver.server.InvocationTypes
    • com.trs.infra.util.file.JavaScriptEscape
    • com.trs.infra.util.JavaScriptVARProcessor
    • com.trs.infra.util.upgrade.dbcompare.JdbcTypeMap
    • com.trs.wcm.photo.impl.JImageMarkUtil
    • com.trs.wcm.photo.impl.JMarkUtilX
    • com.trs.infra.util.job.JobScheduler
    • com.trs.components.common.job.JobWorkerTypeLCListenerForSchedule (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.devhelper.JsCombineFilter (implements javax.servlet.Filter)
    • com.trs.ajaxservice.JSONHelper
    • com.trs.presentation.jsputil.JspChecker
    • com.trs.servlet.JspDenyFilter (implements javax.servlet.Filter)
    • com.trs.webframework.controler.JSPRequestProcessor
    • com.trs.components.common.trsvote.JVoteConstant
    • com.trs.components.common.publish.config.persistent.LaborResourceConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl (implements com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr)
    • com.trs.components.common.publish.widget.LayoutGenerator (implements com.trs.components.common.publish.widget.ILayoutGenerator)
    • com.trs.components.common.publish.widget.LayoutMgr (implements com.trs.components.common.publish.widget.ILayoutMgr)
    • com.trs.components.common.publish.widget.LayoutServiceProvider (implements com.trs.components.common.publish.widget.ILayoutServiceProvider)
    • com.trs.components.infoview.db.LetterConvertor
    • com.trs.infra.persistent.db.LicenseMgr
    • com.trs.license.LicenseUtil
    • com.trs.components.infoview.config.LinkedEnumCreator
    • com.trs.infra.util.ListUtil
    • com.trs.infra.util.Loader
    • com.trs.webframework.config.LoadingErrorReport
    • com.trs.tools.LocaleChecker
    • com.trs.tools.LocaleTools
    • com.trs.tools.Localizer
    • com.trs.tools.Localizer2
    • com.trs.tools.LocalServerAuto
    • com.trs.cms.content.Locker
    • com.trs.cms.content.LockerMgr
    • com.trs.cms.content.LockManager
    • com.trs.servlet.LoginCheckFilter (implements javax.servlet.Filter)
    • com.trs.cms.logger.LogInfo
    • com.trs.presentation.util.LoginHelper
    • com.trs.webframework.controler.servlet.LoginValidatorDefaultImpl (implements com.trs.webframework.controler.servlet.ILoginValidator)
    • com.trs.webframework.controler.servlet.LoginValidatorFactory
    • com.trs.webframework.controler.servlet.LoginValidatorThreadLocalImpl (implements com.trs.webframework.controler.servlet.ILoginValidator)
    • com.trs.infra.support.log.LogListUtil
    • com.trs.infra.support.log.LogMgr (implements com.trs.infra.support.log.ILogMgr)
    • com.trs.infra.support.log.LogServer
    • com.trsothers.LogServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.infra.support.log.LogType
    • com.trs.infra.util.key.MacAddressHelper
    • com.trs.infra.util.key.MachineCodeDetector
    • com.trs.wcm.photo.impl.MagicImageImpl (implements com.trs.wcm.photo.IMagicImage)
    • com.trs.components.metadata.service.MailConfigsHelper
    • com.trs.cms.process.MailContentHelper
    • com.trs.infra.util.upgrade.Main
    • com.trs.components.comment.domain.Management
    • com.trs.components.infoview.extract.manifest.Manifest
    • com.trs.components.common.publish.widget.MasterMgr (implements com.trs.components.common.publish.widget.IMasterMgr)
    • com.trs.components.common.publish.widget.MasterServiceProvider (implements com.trs.components.common.publish.widget.IMasterServiceProvider)
    • com.trs.infra.util.MD5
    • com.trs.tools.MediaBuilder
    • com.trs.components.wcm.wcmx.media.MediaRemindedAgent
    • com.trs.components.infoview.extract.manifest.MenuArea
    • com.trs.components.infoview.extract.manifest.MenuButton
    • com.trs.components.common.message.MessageSendingConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.message.MessageSendingMapper (implements org.aton.container.IClearable)
    • com.trs.components.common.message.MessageServer
    • com.trs.ajaxservice.MessageServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.cluster.receiver.MetaAppCreateMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.components.metadata.center.MetaDataCenterClassInfoHelper
    • com.trs.components.metadata.center.MetaDataCenterHelper
    • com.trs.components.metadata.service.MetaDataCenterServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.MetaDataConstants
    • com.trs.components.metadata.definition.xml.MetaDataDDLImporter
    • com.trs.components.metadata.definition.MetaDataDefCacheMgr (implements com.trs.components.metadata.definition.IMetaDataDefCacheMgr)
    • com.trs.components.metadata.definition.MetaDataDefHelper
    • com.trs.components.metadata.definition.MetaDataDefMgr (implements com.trs.components.metadata.definition.IMetaDataDefMgr)
    • com.trs.components.metadata.service.MetaDataDefServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.infra.util.upgrade.dbcompare.MetaDataLoader
    • com.trs.components.metadata.definition.MetaDataType
    • com.trs.components.metadata.definition.MetaDataTypes
    • com.trs.components.metadata.definition.MetaDBFieldListenerForChannelSynRule (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.metadata.center.xml.MetaViewDataExporter
    • com.trs.components.metadata.center.xml.MetaViewDataImporter
    • com.trs.components.metadata.publish.MetaViewDataRelateSource (implements com.trs.components.wcm.publish.element.IRelateResource)
    • com.trs.components.metadata.center.MetaViewEmployerMgr (implements com.trs.components.metadata.center.IMetaViewEmployerMgr)
    • com.trs.components.metadata.service.domain.MetaViewEmplyerConverterForChannelImporter (implements com.trs.components.wcm.content.domain.IChannelImporterConverter)
    • com.trs.components.metadata.definition.xml.MetaViewExporter
    • com.trs.components.metadata.center.MetaViewHelper
    • com.trs.components.metadata.service.MetaViewImporter
    • com.trs.webframework.config.MethodConfig
    • com.trs.webframework.context.MethodContext
    • com.trs.webframework.context.MethodContextHelper
    • com.trs.infra.util.email.MIMEBase64
    • com.trs.infra.persistent.listener.MonitorHostConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.ajaxservice.listener.MoveChannelListenerForChannel (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.cms.process.engine.handlers.MsgSendHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.components.common.message.MsgSendWorker (implements com.trs.components.common.message.ISendWorker)
    • com.trs.infra.persistent.db.MyDate (implements com.trs.license.License)
    • com.trs.components.wcm.MyDB (implements com.trs.license.License)
    • com.trs.components.wcm.MyPlugin
    • com.trs.components.wcm.content.MySite (implements com.trs.license.License)
    • com.trs.infra.util.MySSLSocketFactory (implements org.apache.commons.httpclient.protocol.ProtocolSocketFactory)
    • com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager (implements javax.net.ssl.X509TrustManager)
    • com.trs.components.wcm.content.persistent.MySystemInfo
    • com.trs.infra.MyTypes
    • com.trs.infra.util.NamesRegister (implements org.aton.container.IClearable)
    • com.trs.presentation.nav.NavConstatns
    • com.trs.presentation.nav.NavHandlerFactory
    • com.trs.service.impl.NetSnapTool
    • com.trs.ajaxservice.NewChannelServiceProvider (implements com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.cms.auth.domain.NewRightSet
    • com.trs.components.comment.domain.NewsComment
    • com.trs.components.comment.domain.NewsComment.CommentEmitEnum
    • com.trs.components.common.message.notify.NotificationConfig
    • com.trs.components.common.message.notify.NotificationSchemeConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.message.notify.Notifier
    • com.trs.infra.persistent.NullValue
    • com.trs.infra.persistent.listener.ObjectLCListenerConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cluster.receiver.ObjectLCMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.cms.auth.domain.ObjectMemberMgr (implements com.trs.cms.auth.domain.IObjectMemberMgr)
    • com.trs.cms.auth.domain.ObjectMemberMgrForCluster (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.ajaxservice.ObjectMemberServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.infra.persistent.listener.ObjectMonitored
    • com.trs.components.metadata.service.ObjectsIterator
    • com.trs.infra.persistent.ObjectTypeConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.ObjectTypesFinder
    • com.trs.cms.logger.ObjLoggerBase (implements com.trs.cms.logger.IObjLogger)
      • com.trs.components.wcm.logger.ChannelLogger
      • com.trs.components.wcm.logger.ConfigLogger
      • com.trs.components.wcm.logger.DocumentLogger
      • com.trs.components.wcm.logger.FlowEmployLogger
      • com.trs.components.wcm.logger.FolderPublishConfigLogger
      • com.trs.components.wcm.logger.RegionCellInfoLogger
      • com.trs.components.wcm.logger.RegionInfoLogger
      • com.trs.cms.auth.logger.RightLogger
      • com.trs.components.wcm.logger.ScheduleLogger
      • com.trs.components.wcm.logger.TemplateEmployLogger
      • com.trs.components.wcm.logger.TemplateLogger
      • com.trs.components.wcm.logger.WebSiteLogger
    • com.trs.cms.logger.ObjSysLogger
    • com.trs.infra.persistent.ObjTypeLookupHelper
    • com.trs.infra.persistent.ObjTypeLookupImpl (implements com.trs.infra.persistent.IObjTypeLookup)
    • com.trs.service.impl.OfficeDocumentService (implements com.trs.service.IOfficeDocumentService)
    • com.trs.cms.auth.config.OperationConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.config.OperationRelatedConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.process.config.OperatorConfig
    • com.trs.cms.logger.OperTypeHelper
    • com.trs.infra.util.OptionConverter
    • com.trs.database.util.Ora2DB2Convertor
    • com.trs.database.util.OraImpExtractDDL
    • com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole
    • com.trs.infra.util.OrgnizeContextImports
    • com.trs.database.util.OTop
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • com.trs.infra.util.BASE64EncoderStream
        • com.trs.infra.util.jazzlib.CheckedOutputStream
        • com.trs.infra.util.jazzlib.DeflaterOutputStream
          • com.trs.infra.util.jazzlib.GZIPOutputStream
          • com.trs.infra.util.jazzlib.ZipOutputStream
    • com.trs.cms.process.engine.handlers.OverTimeHandler (implements com.trs.cms.process.engine.IConditionHandler)
    • com.trs.components.infoview.extract.manifest.PackageFile
    • com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask (implements com.trs.components.common.publish.domain.taskdispatch.IPageTask)
    • com.trs.components.common.publish.domain.publisher.PageDestroyer
    • com.trs.components.common.publish.domain.publisher.PageGenerator
    • com.trs.presentation.util.PageHelper
    • com.trs.components.common.publish.domain.publisher.PageNavHelper
    • com.trs.ajaxservice.PageOperatorsForServiceHelper
    • com.trs.components.common.publish.widget.PageStyleExporter
    • com.trs.components.common.publish.widget.PageStyleImporter
    • com.trs.components.common.publish.widget.PageStyleMgr (implements com.trs.components.common.publish.widget.IPageStyleMgr)
    • com.trs.components.common.publish.widget.PageStyleServiceProvider (implements com.trs.components.common.publish.widget.IPageStyleServiceProvider)
    • com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker (implements org.aton.container.IClearable, java.lang.Runnable)
    • com.trs.components.wcm.wcmx.jsp.PageUtil
    • com.trs.presentation.common.PageViewConstants
    • com.trs.presentation.util.PageViewUtil
    • com.trs.cms.process.config.ParamConfig
    • com.trs.presentation.util.Parameter
      • com.trs.presentation.util.AppAutoParameter
      • com.trs.presentation.util.PageParameter
    • com.trs.presentation.util.Parameters
      • com.trs.presentation.util.AppAutoParameters
      • com.trs.presentation.util.PageParameters
    • com.trs.infra.support.config.PathConfig (implements java.lang.Cloneable)
    • com.trs.infra.support.file.PathConfigLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.wcm.photo.impl.PhotoImporter
    • com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig
    • com.trs.components.wcm.stat.chart.PieChartProducer (implements de.laures.cewolf.DatasetProducer)
    • com.trs.infra.util.PinyinHelper
    • com.trs.presentation.plugin.PluginConfig
    • com.trs.infra.config.persistent.PluginConfig
    • com.trs.presentation.portal.PortalHelper
    • com.trs.components.wcm.content.service.portervisitors.PorterUtil
    • com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory
    • com.trs.components.ckm.PositionComparator (implements java.util.Comparator)
    • com.trs.cms.process.engine.creators.PostUserNameCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.components.wcm.publish.domain.PreNextDocumentsImpl (implements com.trs.components.wcm.publish.domain.IPreNextDocuments)
    • com.trs.ajaxservice.PreviewChannelServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.cms.process.ProcessConstants
    • com.trs.ajaxservice.ProcessService (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl (implements com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor)
    • com.trs.infra.util.PropertiesUtil
    • com.trs.infra.util.PropertiesVARProcessor
    • com.trs.components.common.publish.PublishConstants
    • com.trs.cms.process.engine.handlers.PublishContentActionHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.components.common.publish.persistent.element.PublishContentImplBase (implements com.trs.components.common.publish.persistent.element.IPublishContent)
      • com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl
      • com.trs.components.wcm.publish.element.PublishContentDocumentImpl
      • com.trs.components.metadata.publish.PublishContentViewDataImpl
      • com.trs.components.metadata.publish.PublishContentViewFieldImpl
      • com.trs.components.metadata.publish.PublishContentViewImpl
    • com.trs.components.common.publish.domain.element.PublishContentLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.common.publish.config.persistent.PublishDistributionConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.distribute.PublishDistributionList
    • com.trs.components.common.publish.domain.distribute.PublishDistributionMgr
    • com.trs.components.common.publish.config.PublishDistributionTargetType
    • com.trs.components.common.publish.config.persistent.PublishElementConfig (implements com.trs.infra.config.persistent.IConfigElement)
      • com.trs.components.common.publish.config.persistent.ContentTypeConfig
      • com.trs.components.common.publish.config.persistent.FolderTypeConfig
    • com.trs.components.common.publish.persistent.element.PublishElementFactory
    • com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl (implements com.trs.components.common.publish.persistent.element.IPublishElements)
    • com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl (implements com.trs.components.common.publish.persistent.element.IPublishElements)
    • com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl (implements com.trs.components.common.publish.domain.taskdispatch.IPublishElementsIterator)
    • com.trs.components.common.publish.persistent.element.PublishElementsListImpl (implements com.trs.components.common.publish.persistent.element.IPublishElements)
    • com.trs.components.common.publish.config.PublishElementType
    • com.trs.components.common.publish.persistent.element.PublishElementWrapper (implements com.trs.components.common.publish.persistent.element.IPublishElement)
      • com.trs.components.common.publish.persistent.element.PublishContentWrapper (implements com.trs.components.common.publish.persistent.element.IPublishContent)
      • com.trs.components.common.publish.persistent.element.PublishFolderWrapper (implements com.trs.components.common.publish.persistent.element.IPublishFolder)
    • com.trs.components.common.publish.persistent.element.PublishFolderImplBase (implements com.trs.components.common.publish.persistent.element.IPublishFolder)
      • com.trs.components.wcm.publish.element.PublishFolderChannelImpl
        • com.trs.components.wcm.epress.EpressFolderWrapper (implements com.trs.components.common.publish.persistent.element.IPublishFolder)
      • com.trs.components.metadata.publish.PublishFolderClassImpl
      • com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl
    • com.trs.components.common.publish.domain.element.PublishFolderLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.metadata.service.listener.PublishListenerForPubGovInfo (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.common.publish.domain.publisher.PublishPageContext (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.publisher.PublishPathCompass (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.config.persistent.PublishServerConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.config.PublishServerConfigMapper (implements org.aton.container.IClearable)
    • com.trs.service.impl.PublishService (implements com.trs.service.IPublishService)
    • com.trs.ajaxservice.PublishServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.common.publish.domain.publisher.PublishSyncGlobalTuner
    • com.trs.components.common.publish.domain.publisher.PublishTagContext
    • com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.publisher.PublishTaskContext (implements org.aton.container.IClearable)
    • com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr (implements com.trs.components.wcm.publish.tagparser.IPublishTaskDocumentsCacheMgr)
    • com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl (implements com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr)
    • com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime
    • com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker (implements org.aton.container.IClearable, com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher, java.lang.Runnable)
    • com.trs.components.common.publish.PublishUpdateCommderImpl (implements com.trs.infra.update.IUpdateCommander)
    • com.trs.components.wcm.content.QueryDocumentCenter
    • com.trs.infra.db.QueryFilter (implements java.lang.Cloneable)
    • com.trs.components.filter.QueryFilterFactory (implements com.trs.components.filter.IQueryFilterFactory)
    • com.trs.cms.process.QueryFlowDocContext
    • com.trs.presentation.nav.RadarTreeCreator
    • com.trs.components.wcm.recent.RecentMgr
    • com.trs.service.impl.RecentService (implements com.trs.service.IRecentService)
    • com.trs.webframework.entity.RedirectObject
    • com.trs.cluster.receiver.RefreshPropertyMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.presentation.ids.RegFromConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.wcm.publish.region.RegionEmployMgr
    • com.trs.components.wcm.publish.region.RegionEmployServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.publish.region.RegionServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.content.domain.RelationMgr
    • com.trs.infra.util.RemoteAddrUtil
    • com.trs.components.wcm.content.persistent.ReplaceCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.ajaxservice.ReplaceContentServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.content.domain.ReplaceMgr
    • com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.infra.util.Report
    • com.trs.infra.util.Reports
    • com.trs.ajaxservice.xmlconvertors.ReportsToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.presentation.util.RequestHelper
    • com.trs.webframework.xmlserver.server.RequestParamsProcessor (implements com.trs.webframework.xmlserver.server.IRequestProcessor)
    • com.trs.webframework.xmlserver.server.RequestXMLDataProcessor (implements com.trs.webframework.xmlserver.server.IRequestProcessor)
    • com.trs.util.ResetClassInfoOfViewData
    • com.trs.service.impl.ResouceService (implements com.trs.service.IResourceService)
    • com.trs.tools.ResourceAnalyzer
    • com.trs.components.wcm.resource.ResourceMgr
    • com.trs.components.common.publish.widget.ResourceStyleExporter
    • com.trs.components.common.publish.widget.ResourceStyleImporter
    • com.trs.components.common.publish.widget.ResourceStyleMgr (implements com.trs.components.common.publish.widget.IResourceStyleMgr)
    • com.trs.components.common.publish.widget.ResourceStyleServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.infra.util.ResponseBuddy
    • com.trs.presentation.util.ResponseHelper
    • com.trs.cms.auth.domain.RightCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.presentation.right.RightHelper
    • com.trs.cms.auth.config.RightHostConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.domain.RightHostFactory
    • com.trs.cms.auth.config.RightHostIndexsConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.infoview.RightHostInfoViewField (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.components.infoview.RightHostInfoViewGroup (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.components.infoview.RightHostInfoViewView (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.cms.auth.domain.RightHostLCListenerForInherit (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd)
    • com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.cms.auth.domain.RightMgr (implements com.trs.cms.auth.domain.IRightMgr)
    • com.trs.cms.auth.config.RightObjectConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.domain.RightObjectFactory
    • com.trs.cms.auth.domain.RightSet
    • com.trsupdate.RightUpdaterForUser
    • com.trs.cms.auth.domain.RoleAuthServer
    • com.trs.cms.auth.domain.RoleMgr
    • com.trs.service.impl.RoleService (implements com.trs.service.IRoleService)
    • com.trs.ajaxservice.RoleServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.cms.auth.persistent.RoleUserCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.cms.auth.logger.RoleUserLogger (implements com.trs.cms.logger.IObjLogger)
    • com.trs.components.wcm.publish.tagparser.RollDocumentsChannelsFinder
    • com.trs.cms.process.engine.RuleExecuteHelper
    • com.trs.cms.process.definition.RuleHostLCListnerForCache (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.ajaxservice.listener.SaveMembersListenerForObjectMember (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.common.publish.domain.tagparser.ScanContext
    • com.trs.scene.tools.SceneAutoCreator
    • com.trs.scene.parser.SceneConnector
    • com.trs.scene.parser.SceneNode
    • com.trs.scene.tools.SceneNode
    • com.trs.scene.tools.SceneNodeAction
    • com.trs.scene.tools.SceneNodeParser
    • com.trs.scene.tools.SceneNodeToXML
    • com.trs.scene.parser.ScenePathsParser
    • com.trs.ajaxservice.SceneServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.scene.parser.SceneXMLParser
    • com.trs.components.common.job.ScheduleLCListenerForFaieldResult (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.common.job.ScheduleLCListenerForServer (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.infra.util.upgrade.dataprocess.ScheduleOper
    • com.trs.service.impl.ScheduleService (implements com.trs.service.IScheduleService)
    • com.trs.infra.util.upgrade.dbcompare.SchemaCompare
    • com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker
      • com.trs.infra.util.upgrade.sql.DB2UpdSqlMaker
      • com.trs.infra.util.upgrade.sql.MssqlUpdSqlMaker
      • com.trs.infra.util.upgrade.sql.OracleUpdSqlMaker
    • com.trs.infra.util.upgrade.sql.SchemaUpdSqlMakerFactory
    • com.trs.infra.support.security.SecureKeyMgr
    • com.trs.infra.support.security.SecureKeyUtil
    • com.trs.service.impl.SecurityService (implements com.trs.service.ISecurityService)
    • com.trs.components.infoview.process.SendEmailForInfoViewHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.infra.ServerConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.ServerControl
    • com.trs.webframework.config.ServiceConfig
    • com.trs.webframework.config.ServiceConfigHelper
    • com.trs.ajaxservice.ServiceConstants
    • com.trs.webframework.context.ServiceContext
      • com.trs.webframework.controler.JSPServiceContext
    • com.trs.webframework.config.ServiceFilterConfig
    • com.trs.webframework.config.ServiceFilterConfigs
    • com.trs.webframework.provider.ServiceFilterExample (implements com.trs.webframework.provider.IServiceFilter)
    • com.trs.service.ServiceHelper
    • com.trs.webframework.config.ServiceListenerConfig
    • com.trs.webframework.config.ServiceListenerConfigs
    • com.trs.webframework.provider.ServiceListenerExample (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.infra.session.util.SessionFilterBase (implements javax.servlet.Filter)
      • com.trs.infra.ClusterSessionFileter
    • com.trs.presentation.login.SessionListener (implements com.trs.infra.cluster.session.Acknowledged, javax.servlet.http.HttpSessionBindingListener, java.io.Serializable)
    • com.trs.components.comment.domain.SignUtil
    • com.trs.components.common.publish.domain.taskdispatch.SinglePageTask (implements com.trs.components.common.publish.domain.taskdispatch.IPageTask)
    • com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow (implements com.trs.components.wcm.content.service.portervisitors.IPorterVisitor)
    • com.trs.components.stat.SiteHitsCountHandler (implements com.trs.components.stat.IHitsCountHandler)
    • com.trs.components.wcm.content.persistent.SiteLicenseMgr
    • com.trs.components.wcm.content.domain.SiteMemberLCListner (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.SiteMemberMgr
    • com.trs.service.impl.SiteNameCreator (implements com.trs.service.IInfoViewInitorValue)
    • com.trs.components.common.message.SMSSendWorker (implements com.trs.components.common.message.ISendWorker)
    • com.trs.components.common.message.SMSSocketSender
    • com.trs.infra.util.email.SMTPServerConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.util.email.SMTPServerConfigMapper
    • com.trs.infra.util.email.SMTPServerConfigs (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.service.impl.SOAPServiceImpl (implements com.trs.service.ISOAPService)
    • com.trs.template.domain.SourcePathHelper
    • com.trs.ajaxservice.SourceServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.resource.SourceTypeMgr
    • com.trs.components.common.publish.widget.SpecialAuthServer
    • com.trs.components.special.SpecialMgr (implements com.trs.components.special.ISpecialMgr)
    • com.trs.components.special.SpecialServiceProvider (implements com.trs.components.special.ISpecialServiceProvider)
    • com.trs.SpringBean
    • com.trs.tools.SQLBuilder
    • com.trs.db.update.SQLServerUpdateSQL
    • com.trs.components.stat.StatAnalysisTool
    • com.trs.components.stat.StatBonusDataForUser
    • com.trs.components.stat.StatBonusResultForUser
    • com.trs.components.wcm.stat.domain.StatDataItem
    • com.trs.components.stat.StatDocCountByChannel
    • com.trs.components.stat.StatDocCountOfGroupByChannel
    • com.trs.components.stat.StatDocCountOfGroupByMetaClass
    • com.trs.components.stat.StatDocCountOfUserByMetaClass
    • com.trs.components.wcm.stat.StatMgr
    • com.trs.components.stat.StatResult (implements com.trs.components.stat.IStatResult)
    • com.trs.components.wcm.stat.StatResultHolder
    • com.trs.components.stat.StatResults (implements com.trs.components.stat.IStatResults)
    • com.trs.service.impl.StatService (implements com.trs.service.IStatService)
    • com.trs.ajaxservice.StatusServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.webframework.demo.StdDemoProviderImpl (implements com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider)
    • com.trs.idm.client.actor.StdHttpSessionBasedActor (implements com.trs.idm.client.actor.IServletAppActor)
      • com.trs.presentation.ids.WCM52Actor
    • com.trs.webframework.xmlserver.parser.StreamBuddy
    • com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.components.common.publish.widget.StyleAndResourceMgr (implements com.trs.components.common.publish.widget.IStyleAndResourceMgr)
    • com.trs.components.common.publish.widget.StyleCenterMgr (implements com.trs.components.common.publish.widget.IStyleCenterMgr)
    • com.trs.components.common.publish.widget.StyleConstants
    • com.trs.components.common.publish.widget.StyleHelper
    • com.trs.components.common.publish.widget.StyleItemMgr (implements com.trs.components.common.publish.widget.IStyleItemMgr)
    • com.trs.components.common.publish.widget.StyleItemServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.common.publish.widget.StylePathHelper
    • com.trs.components.common.publish.widget.StyleRepeatNameHelper
    • com.trs.components.common.publish.widget.SubjectDataInitHelper
    • com.trs.service.impl.SureformService (implements com.trs.service.ISureformService)
    • com.trs.infra.util.database.SybaseASEText
    • com.trs.tools.SymbolC2E
    • com.trs.infra.persistent.util.SynChildrenExecutorBase
      • com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase
        • com.trs.components.metadata.service.SynChildrenExecutorForViewEmploy
        • com.trs.components.metadata.service.WCMFilterMakerForContainsChildren
    • com.trs.infra.support.config.SystemCollocationConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.widget.SystemContentStyleMgr (implements com.trs.components.common.publish.widget.ISystemContentStyleMgr)
    • com.trs.components.common.publish.widget.SystemResourceStyleMgr (implements com.trs.components.common.publish.widget.ISystemResourceStyleMgr)
    • com.trs.ajaxservice.SystemServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.wcm.util.SystemWarnerMsgImpl (implements com.trs.components.wcm.util.ISystemWarner)
    • com.trs.infra.util.upgrade.dbcompare.Table
    • com.trs.infra.util.upgrade.dbcompare.TableDiff
    • com.trs.infra.util.database.TableInfo
    • com.trs.infra.util.database.TableInfos
    • com.trs.cluster.receiver.TableInfosMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.tools.TablesCleaner
    • com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo
    • com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type
    • com.trs.components.common.publish.domain.tagparser.TagBeanInfo
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation.TBI
    • com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType
    • com.trs.components.common.publish.domain.tagparser.TagBeanInfoHelper
    • com.trs.components.common.publish.domain.tagparser.TagBeanLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.tagparser.TagChannelChainParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagDocument (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.tagparser.TagDocumentReader
    • com.trs.components.common.publish.domain.tagparser.TagDocumentScanner
    • com.trs.components.wcm.epress.TagEBookDirParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.template.persistent.TagFieldInfoEntity (implements com.trs.template.persistent.IInfoEntity)
    • com.trs.components.common.publish.domain.tagparser.TagFormatHelper
    • com.trs.components.common.publish.config.persistent.TagFormatterConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.domain.tagparser.TagItem (implements org.aton.container.IClearable)
    • com.trs.components.wcm.epress.TagMapAreaParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParseHelper
    • com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.domain.tagparser.TagParserCMSObj
      • com.trs.components.common.publish.domain.tagparser.TagParserContentBase
        • com.trs.components.common.publish.domain.tagparser.TagParserDetailPage
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocument
          • com.trs.components.wcm.publish.tagparser.TagDocbakParser
          • com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentForBJGOV
        • com.trs.components.metadata.publish.WCMTagParserViewData
        • com.trs.components.metadata.publish.WCMTagParserViewField
        • com.trs.components.wcm.publish.tagparser.WCMTagParserXDocument
      • com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
        • com.trs.components.wcm.publish.tagparser.WCMTagParserChannel
        • com.trs.components.metadata.publish.WCMTagParserClassInfo
        • com.trs.components.wcm.publish.tagparser.WCMTagParserWebSite
      • com.trs.components.common.publish.domain.tagparser.TagParserUser
      • com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply
    • com.trs.components.common.publish.domain.tagparser.TagParserCondition (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserCondition.Operator
    • com.trs.components.wcm.publish.tagparser.TagParserCRUser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserDateTime (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserEcho (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParseResults (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.tagparser.TagParserFactory (implements org.aton.container.IClearable)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoView (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewData (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViews (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserNewIcon (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.epress.TagParserPageNav (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserRepeat (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserUnimpl (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserVariable (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserVariableSet (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.wcmonline.TagParserVipMetaData (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.TagParserWmlImage (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.TagParserWmlImages (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.epress.TagPreNextParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.TagWmlContentParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.config.persistent.TargetTypeConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.domain.taskdispatch.TaskWorker (implements java.lang.Runnable)
    • com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.template.TemplateArgumentMgr
    • com.trs.ajaxservice.TemplateAuthHelper
    • com.trs.components.common.publish.domain.template.TemplateCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl (implements com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr)
    • com.trs.components.common.publish.domain.template.TemplateEmployDetail
    • com.trs.components.common.publish.domain.template.TemplateEmployMgr
    • com.trs.ajaxservice.TemplateEmployMgrHelper
    • com.trs.components.common.publish.domain.template.TemplateExporter
    • com.trs.components.common.publish.domain.template.TemplateImporter
    • com.trs.template.persistent.TemplateInfoEntity (implements com.trs.template.persistent.IInfoEntity)
    • com.trs.components.common.publish.domain.template.TemplateLCListenerForNestedRename (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.template.TemplateLCListenerForTypeChanged (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.template.TemplateMgr
    • com.trs.components.common.publish.domain.template.TemplateNestMgr
    • com.trs.components.common.publish.domain.tagparser.TemplateParameter
    • com.trs.components.common.publish.domain.tagparser.TemplateParameter.Token
    • com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type
    • com.trs.components.common.publish.domain.tagparser.TemplateParameterList
    • com.trs.components.common.publish.config.persistent.TemplateParseConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.domain.template.TemplateParseHelper
    • com.trs.components.common.publish.domain.template.TemplateParseMgr (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.service.impl.TemplateParseService (implements com.trs.service.ITemplateParseService)
    • com.trs.components.common.publish.domain.template.TemplateQuoteMgr
    • com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310
    • com.trs.components.common.publish.domain.auth.TemplateRightObjImpl (implements com.trs.cms.auth.domain.IRightObj)
    • com.trs.components.wcm.publish.region.TemplateSaveListenerForRegionEmploy (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.service.impl.TemplateService (implements com.trs.service.ITemplateService)
    • com.trs.template.TemplateServiceConfig
    • com.trs.template.TemplateServiceFactory
    • com.trs.ajaxservice.TemplateServiceHelperProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.template.service.impl.TemplateServiceImpl (implements com.trs.template.service.ITemplateService)
    • com.trs.ajaxservice.TemplateServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.template.domain.setting.TemplateSettingFactory
    • com.trs.template.domain.TemplateXmlGenerator
    • com.trs.webframework.config.Test
    • com.trs.components.infoview.extract.TestIPFD
    • com.trs.components.wcm.content.trsserver.TestTrsServer
    • java.lang.Thread (implements java.lang.Runnable)
      • com.trs.infra.util.CMyTimer
      • com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl (implements org.aton.container.IClearable, com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher)
      • com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher (implements org.aton.container.IClearable, com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher)
      • com.trs.components.common.publish.domain.template.TemplateParseAngel
    • java.lang.ThreadLocal
      • com.trs.infra.common.ContextTL
    • com.trs.components.common.publish.domain.taskdispatch.ThreadPool
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.template.AbstractErrorMessage
        • com.trs.infra.util.CMyException
          • com.trs.infra.util.email.CMyMailException
          • com.trs.webframework.xmlserver.ConvertException
          • com.trs.infra.common.WCMException
            • com.trs.components.common.publish.OrignHomePublishException
            • com.trs.infra.common.WCMDatainvalidException
        • com.trs.infra.util.jazzlib.DataFormatException
        • java.io.IOException
          • java.rmi.RemoteException
            • org.apache.axis.AxisFault
              • com.trs.template.TemplateRemoteException (implements java.io.Serializable)
          • com.trs.infra.util.jazzlib.ZipException
        • com.trs.components.common.publish.domain.tagparser.LoopException
        • java.lang.RuntimeException
          • com.trs.components.wcm.stat.domain.ChartBuildException
          • com.trs.webframework.xmlserver.server.DataAnalyzingException
          • com.trs.license.LicenseException
          • com.trs.cms.process.definition.OptMarkParseException
          • com.trs.webframework.xmlserver.server.ResponseOutputException
          • com.trs.webframework.exception.ServiceInvocationException
            • com.trs.webframework.exception.NoSuchServiceException
            • com.trs.webframework.xmlserver.server.RequestParmasParseException
            • com.trs.webframework.exception.ServiceCreationFailException
          • com.trs.webframework.xmlserver.parser.XMLParseException
          • com.trs.webframework.xmlserver.server.XMLParsingPausedException
    • com.trs.components.stat.TimeRange
    • com.trs.components.wcm.stat.domain.TimingChartBuilder (implements com.trs.components.wcm.stat.domain.IChartBuilder)
    • com.trs.components.wcm.stat.domain.TimingChartData
    • com.trs.components.wcm.stat.domain.TimingChartProducer (implements de.laures.cewolf.DatasetProducer)
    • com.trs.cms.process.config.ToUsersCreatorConfig
    • com.trs.presentation.nav.TreeCreator
    • com.trs.presentation.navigation.TreeItem
    • com.trs.components.wcm.content.trsserver.TreeNode
    • com.trs.presentation.nav.TreeNodeCalctor
    • com.trs.cluster.TRSClusterExtensionImpl (implements com.trs.infra.cluster.Extension)
    • com.trs.infra.config.TRSConfigServer
    • com.trs.components.wcm.content.trsserver.TRSConnectionPool (implements java.lang.Runnable)
    • com.trs.db.schema.TRSDBSchema
    • com.trs.infra.util.TRSImportsOrgnize
    • com.trs.infra.util.TRSJspAutoTool
    • com.trs.infra.util.TRSLocaleAuto
    • com.trs.infra.util.email.TRSMailer
    • com.trs.webframework.config.TRSParameter
      • com.trs.webframework.config.TRSPageParameter
    • com.trs.components.wcm.content.trsserver.TRSSearcher
    • com.trs.components.wcm.content.trsserver.TRSSearcherFactory
    • com.trs.components.wcm.content.trsserver.TRSSearchUtil
    • com.trs.template.TRSTemplateFacade
    • com.trs.components.wcm.content.trsserver.TRSToWCMFilter
    • com.trs.components.wcm.channel.TxtFileParser (implements com.trs.components.wcm.channel.IVChannelParser)
    • com.trs.components.wcm.contentlink.TxtFileParserForContentLink (implements com.trs.components.wcm.contentlink.IVContentLinkParser)
    • com.trs.infra.util.upgrade.dbcompare.TypeInfo
    • com.trs.infra.util.upgrade.dbcompare.TypeInfoMap
    • com.trs.infra.util.database.TypeNames
    • com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager (implements org.aton.container.IClearable)
    • com.trs.infra.update.UpdateCommanderConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.db.update.UpdateSQLGenerator
    • com.trs.infra.util.upgrade.sql.UpdSqlMaker
    • com.trs.cms.auth.domain.UpdUserScheduleCreator
    • com.trs.upgrade.UpgradeObjectMember4SiteMember
    • com.trs.infra.util.URLCoder
    • com.trs.components.stat.URLParser (implements com.trs.components.stat.IURLParser)
    • com.trs.cms.auth.persistent.UserCacheMgr (implements com.trs.cms.auth.persistent.IUserCacheMgr)
    • com.trs.components.wcm.content.domain.UserDocumentMgr
    • com.trs.presentation.login.UserLCListenerForLogin (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.cms.auth.persistent.UserLicenseMgr
    • com.trs.km.auth.UserListenerForRecordLogin (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.stat.UserLoginInfoMgr (implements com.trs.components.stat.IUserLoginInfoMgr)
    • com.trs.components.stat.UserLoginInfoServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.cms.auth.domain.UserMgr
    • com.trs.components.metadata.service.UserRelateInfoMaker (implements com.trs.components.metadata.service.IDefaultChannelMaker)
    • com.trs.service.impl.UserService (implements com.trs.service.IUserService)
    • com.trs.ajaxservice.UserServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.wcmx.jsp.UserUtil
    • com.trs.cms.process.config.ValueConfig
    • com.trs.components.wcm.channel.VChannel
    • com.trs.components.wcm.channel.VChannelManager
    • com.trs.weblet.util.verfiycode.VerifyCode
    • com.trs.components.infoview.extract.manifest.View
    • com.trs.components.metadata.service.xmlconvertors.ViewDataToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.components.metadata.service.listener.ViewDocumentListenerForPubGovInfo (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.ajaxservice.ViewDocumentServiceProvider (implements com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
      • com.trs.ajaxservice.PhotoServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.metadata.service.ViewRangeConstants
    • com.trs.components.common.publish.widget.VisualTemplateServiceProvider (implements com.trs.components.common.publish.widget.IVisualTemplateServiceProvider)
    • com.trs.webframework.entity.VOIDObject
    • com.trs.components.common.trsvote.VoteSoapClient
    • com.trs.components.common.trsvote.VoteSoapServer
    • com.trs.ajaxservice.WatermarkServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.wcag2.WCAG2Helper
    • com.trs.tools.WCM61AutoList
    • com.trs.ajaxservice.WCMAJAXServiceHelper
    • com.trs.components.wcm.WCMAppConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator
    • com.trs.ajaxservice.WCMApplyFormProcessServiceHelper
    • com.trs.components.wcm.publish.WCMContentPublishConfig
    • com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.infra.util.WCMDiscoveryFactory
    • com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter
    • com.trs.ajaxservice.WCMDocumentHelper
    • com.trs.infra.persistent.WCMFilter (implements java.lang.Cloneable)
    • com.trs.components.wcm.publish.WCMFolderLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.wcm.old.WCMFormMgr
    • com.trs.components.wcm.wcmx.help.WcmHelpUpdate (implements com.trs.infra.update.IUpdateCommander)
    • com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit
    • com.trs.infra.util.upgrade.WcmIdFieldInit
    • com.trs.components.metadata.service.util.WCMJSPChecker
    • com.trs.cms.content.WCMObjHelper
    • com.trs.wcmonline.WCMOnlineService
    • com.trs.ajaxservice.WCMProcessServiceHelper
    • com.trs.service.impl.WCMProcessServiceImpl (implements com.trs.service.IWCMProcessService)
    • com.trs.service.impl.WCMPublishElementServiceImpl (implements com.trs.service.IWCMPublishElementService)
    • com.trs.components.wcm.publish.WCMPublishHelper
    • com.trs.infra.common.WCMRightTypes
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterAllCata (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChannel (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChnlName (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterColumn (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
      • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterBigNews
      • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterOutline
      • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicNews
      • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRelNews
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicture (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRecPath (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterTemplate (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
          • com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews
          • com.trs.components.wcm.epress.WCMTagParserEPressNews
          • com.trs.components.wcm.epress.WCMTagParserExpertNews
          • com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments
          • com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments
        • com.trs.components.wcm.publish.tagparser.XTagParserObjsInChannelBase
      • com.trs.components.wcm.publish.tagparser.WCMTagParserChannels (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
    • com.trs.components.metadata.publish.WCMTagParserAppendix (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.metadata.publish.WCMTagParserClassIndexGener (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserHelper
    • com.trs.components.wcm.publish.tagparser.WCMTagParserIcon (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserPrev (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.region.WCMTagParserRegion (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews (implements com.trs.components.common.publish.domain.tagparser.ITagParser, com.trs.components.common.publish.domain.tagparser.ITagParser4List)
    • com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData (implements com.trs.components.common.publish.domain.tagparser.ITagParser, com.trs.components.common.publish.domain.tagparser.ITagParser4List)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserReplace (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer
    • com.trs.infra.common.WCMTypes
    • com.trs.components.wcm.wcmx.common.WCMTypesX
    • com.trs.webframework.WebServiceHelper
    • com.trs.ajaxservice.WebSiteHelper
    • com.trs.template.persistent.WebSiteInfoEntity (implements com.trs.template.persistent.IInfoEntity)
    • com.trs.components.wcm.content.domain.WebSiteLCListenerForAutoDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.WebSiteLCListenerForContentLink (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.WebSiteLCListenerForSiteUser (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.auth.WebSiteRightObjImpl (implements com.trs.cms.auth.domain.IRightObj)
    • com.trs.ajaxservice.WebSiteServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)
      • com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.presentation.util.WhereSQLMaker
    • com.trs.components.common.publish.widget.WidgetConstants
    • com.trs.components.common.publish.widget.WidgetInstanceMgr (implements com.trs.components.common.publish.widget.IWidgetInstanceMgr)
    • com.trs.components.common.publish.widget.WidgetInstParameterMgr (implements com.trs.components.common.publish.widget.IWidgetInstParameterMgr)
    • com.trs.components.common.publish.widget.WidgetMgr (implements com.trs.components.common.publish.widget.IWidgetMgr)
    • com.trs.components.common.publish.widget.WidgetParameterMgr (implements com.trs.components.common.publish.widget.IWidgetParameterMgr)
    • com.trs.components.common.publish.widget.WidgetParameterServiceProvider (implements com.trs.components.common.publish.widget.IWidgetParameterServiceProvider)
    • com.trs.components.common.publish.widget.WidgetParameterType
    • com.trs.components.common.publish.widget.WidgetParameterTypes
    • com.trs.components.common.publish.widget.WidgetPathHelper
    • com.trs.components.common.publish.widget.WidgetServer (implements com.trs.components.common.publish.widget.IWidgetServer)
    • com.trs.components.common.publish.widget.WidgetServiceProvider (implements com.trs.components.common.publish.widget.IWidgetServiceProvider)
    • com.trs.components.wcm.soap.WordFileService
    • com.trs.components.infoview.db.XMLContentRender
    • com.trs.webframework.xmlserver.XMLConvertorFactory
    • com.trs.infra.util.XmlDocWithDom4j
    • com.trs.infra.persistent.XmlObject
    • com.trs.infra.util.xml.XmlObjectPersistentor
    • com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder
    • com.trs.webframework.xmlserver.parser.XMLParsingStatus
    • com.trs.ajaxservice.xmlconvertors.XMLToCMSObj
    • com.trs.infra.persistent.XmlToObjConverter
      • com.trs.ajaxservice.XmlToRightConvertor
    • com.trs.infra.persistent.XmlToObjConverterByDOM4j
    • com.trs.components.infoview.extract.XSLTViewBuilder
    • com.trs.components.infoview.extract.XSLTViewConstrainter
    • com.trs.template.domain.XTemplateExporter
    • com.trs.template.domain.XTemplateExporter.HierarchyEntity
    • com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.comment.publish.tagparser.XWCMTagParserComment (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.infra.util.jazzlib.ZipEntry (implements java.lang.Cloneable)
    • com.trs.infra.util.jazzlib.ZipFile

接口分层结构

  • com.trs.infra.util.cabfile.CabConstants
  • com.trs.infra.util.jazzlib.Checksum
  • com.trs.components.common.publish.domain.distribute.DistributionChangeListener
  • com.trs.components.metadata.web.HTMLMaker
  • com.trs.cms.process.engine.IActionHandler
  • com.trs.components.common.conjection.service.IAdmanageConfigService
  • com.trs.components.common.publish.persistent.element.IAppendix
  • com.trs.components.common.publish.persistent.element.IAppendixes
  • com.trs.components.common.publish.domain.taskdispatch.IAtomTask
  • com.trs.service.IAutoDocBakService
  • com.trs.components.stat.IBonusCalculator
  • com.trs.components.stat.IBonusRuleMgr
  • com.trs.service.IBookMarkService
  • com.trs.service.ICDSService
  • com.trs.components.wcm.content.domain.IChannelImporterConverter
  • com.trs.service.IChannelService
  • com.trs.components.wcm.stat.domain.IChartBuilder
  • com.trs.components.metadata.publish.IClassInfoCountCacheForPublish
  • com.trs.components.metadata.definition.IClassInfoMgr
  • com.trs.components.metadata.center.IClassInfoViewMgr
  • org.aton.container.IClearable
    • com.trs.components.common.publish.domain.taskdispatch.IAtomTaskList
    • com.trs.infra.util.ftp.IFtpMgr
    • com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr
    • com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor
    • com.trs.components.common.publish.domain.tagparser.ITagParser
  • com.trs.cluster.IClusterMsgCenter
  • com.trs.cluster.IClusterMsgReceiver
  • com.trs.cluster.IClusterMsgSender
  • com.trs.cms.content.ICMSObjSubstanceContent
    • com.trs.cms.process.IFlowContent
    • com.trs.components.common.publish.persistent.element.IPublishContent
    • com.trs.components.common.publish.persistent.element.IPublishElement
      • com.trs.components.common.publish.persistent.element.IPublishContent
      • com.trs.components.common.publish.persistent.element.IPublishFolder
    • com.trs.components.common.publish.persistent.element.IPublishFolder
    • com.trs.cms.auth.domain.IRightHost
    • com.trs.cms.auth.domain.IRightObj
  • com.trs.components.comment.service.ICommentService
  • com.trs.components.common.conjection.service.IComponentEntryConfigService
  • com.trs.cms.process.engine.IConditionHandler
  • com.trs.service.IContactService
  • com.trs.components.common.publish.widget.IContentStyleMgr
  • com.trs.wcm.customize.ICustomizeMgr
  • com.trs.service.ICustomizeService
  • com.trs.template.IDataTransferEncode
  • com.trs.service.IDBService
  • com.trs.components.metadata.service.IDefaultChannelMaker
  • com.trs.cms.auth.domain.IDepartmentMgr
  • com.trs.components.wcm.content.domain.IDocKeywordMgr
  • com.trs.components.metadata.center.IDocumentFieldsSyn
  • com.trs.components.wcm.content.domain.IDocumentImporterConverter
  • com.trs.service.IDocumentService
  • com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr
  • com.trs.template.IErrorMessages
  • com.trs.service.IEventService
  • com.trs.components.web.IFieldHTMLParser
  • com.trs.components.common.publish.domain.distribute.IFileDistristributor
  • com.trs.cms.process.IFlowCacheMgr
  • com.trs.cms.process.IFlowNotifyWorker
  • com.trs.service.IGroupService
  • com.trs.components.stat.IHitsCountHandler
  • com.trs.wcm.photo.IImageLibConfig
  • com.trs.wcm.photo.IImageLibMgr
  • com.trs.wcm.photo.IImageLibService
  • com.trs.components.infoview.db.IInfoViewDBMgr
  • com.trs.service.IInfoViewEnumCreator
  • com.trs.service.IInfoViewInitor
  • com.trs.service.IInfoViewInitorValue
  • com.trs.service.IInfoViewService
  • com.trs.cms.process.engine.IInitValueCreator
  • com.trs.components.wcm.content.domain.intelligence.IIntellMgr
  • com.trs.components.wcm.content.domain.intelligence.IIntellResLocator
  • com.trs.components.stat.IKeyMaker
  • com.trs.components.common.publish.widget.ILayoutGenerator
  • com.trs.components.common.publish.widget.ILayoutMgr
  • com.trs.infra.support.log.ILog
  • com.trs.webframework.controler.servlet.ILoginValidator
  • com.trs.infra.support.log.ILogMgr
  • com.trs.wcm.photo.IMagicImage
  • com.trs.components.common.publish.widget.IMasterMgr
  • com.trs.components.common.message.IMessageService
  • com.trs.components.metadata.definition.IMetaDataDefMgr
  • com.trs.components.metadata.center.IMetaDataFieldValueCreator
  • com.trs.components.metadata.center.IMetaViewEmployerMgr
  • com.trs.presentation.nav.INavHandler
  • com.trs.components.infoview.mad.InfoViewDataHelper
  • com.trs.components.infoview.mad.InfoViewQueryHelper
  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.cms.auth.persistent.IAdministratorCacheMgr
    • com.trs.infra.persistent.cache.ICachedPOMgr
    • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
      • com.trs.cms.auth.persistent.IAdministratorCacheMgr
      • com.trs.infra.persistent.cache.ICachedPOMgr
      • com.trs.components.wcm.content.persistent.IChannelNameMgr
      • com.trs.components.wcm.content.persistent.IChildrenMgr
      • com.trs.components.stat.IChnlDeptMgr
      • com.trs.components.metadata.definition.IClassInfoCacheMgr
      • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
      • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
      • com.trs.cms.auth.domain.IObjectMemberMgr
      • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
      • com.trs.cms.auth.persistent.IUserCacheMgr
    • com.trs.infra.support.cache.ICacheServer (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.persistent.IChannelNameMgr
    • com.trs.components.wcm.content.persistent.IChildrenMgr
    • com.trs.components.stat.IChnlDeptMgr
    • com.trs.components.metadata.definition.IClassInfoCacheMgr
    • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
    • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.cms.auth.persistent.IAdministratorCacheMgr
      • com.trs.infra.persistent.cache.ICachedPOMgr
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.cms.auth.persistent.IAdministratorCacheMgr
        • com.trs.infra.persistent.cache.ICachedPOMgr
        • com.trs.components.wcm.content.persistent.IChannelNameMgr
        • com.trs.components.wcm.content.persistent.IChildrenMgr
        • com.trs.components.stat.IChnlDeptMgr
        • com.trs.components.metadata.definition.IClassInfoCacheMgr
        • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
        • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
        • com.trs.cms.auth.domain.IObjectMemberMgr
        • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
        • com.trs.cms.auth.persistent.IUserCacheMgr
      • com.trs.infra.support.cache.ICacheServer (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
      • com.trs.components.wcm.content.persistent.IChannelNameMgr
      • com.trs.components.wcm.content.persistent.IChildrenMgr
      • com.trs.components.stat.IChnlDeptMgr
      • com.trs.components.metadata.definition.IClassInfoCacheMgr
      • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
      • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
      • com.trs.cms.auth.domain.IObjectMemberMgr
      • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
      • com.trs.cms.auth.persistent.IUserCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.cms.auth.persistent.IAdministratorCacheMgr
      • com.trs.infra.persistent.cache.ICachedPOMgr
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.cms.auth.persistent.IAdministratorCacheMgr
        • com.trs.infra.persistent.cache.ICachedPOMgr
        • com.trs.components.wcm.content.persistent.IChannelNameMgr
        • com.trs.components.wcm.content.persistent.IChildrenMgr
        • com.trs.components.stat.IChnlDeptMgr
        • com.trs.components.metadata.definition.IClassInfoCacheMgr
        • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
        • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
        • com.trs.cms.auth.domain.IObjectMemberMgr
        • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
        • com.trs.cms.auth.persistent.IUserCacheMgr
      • com.trs.infra.support.cache.ICacheServer (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
      • com.trs.components.wcm.content.persistent.IChannelNameMgr
      • com.trs.components.wcm.content.persistent.IChildrenMgr
      • com.trs.components.stat.IChnlDeptMgr
      • com.trs.components.metadata.definition.IClassInfoCacheMgr
      • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
      • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
      • com.trs.cms.auth.domain.IObjectMemberMgr
      • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
      • com.trs.cms.auth.persistent.IUserCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.cms.auth.persistent.IAdministratorCacheMgr
      • com.trs.infra.persistent.cache.ICachedPOMgr
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.cms.auth.persistent.IAdministratorCacheMgr
        • com.trs.infra.persistent.cache.ICachedPOMgr
        • com.trs.components.wcm.content.persistent.IChannelNameMgr
        • com.trs.components.wcm.content.persistent.IChildrenMgr
        • com.trs.components.stat.IChnlDeptMgr
        • com.trs.components.metadata.definition.IClassInfoCacheMgr
        • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
        • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
        • com.trs.cms.auth.domain.IObjectMemberMgr
        • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
        • com.trs.cms.auth.persistent.IUserCacheMgr
      • com.trs.infra.support.cache.ICacheServer (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
      • com.trs.components.wcm.content.persistent.IChannelNameMgr
      • com.trs.components.wcm.content.persistent.IChildrenMgr
      • com.trs.components.stat.IChnlDeptMgr
      • com.trs.components.metadata.definition.IClassInfoCacheMgr
      • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
      • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
      • com.trs.cms.auth.domain.IObjectMemberMgr
      • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
      • com.trs.cms.auth.persistent.IUserCacheMgr
    • com.trs.cms.auth.domain.IObjectMemberMgr
    • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
    • com.trs.cms.auth.persistent.IUserCacheMgr
  • com.trs.cms.logger.IObjLogger
  • com.trs.infra.persistent.IObjTypeLookup
  • com.trs.webframework.xmlserver.server.IObserver
  • com.trs.webframework.xmlserver.server.IObserverable
  • com.trs.service.IOfficeDocumentService
  • com.trs.components.common.publish.widget.IPageStyleMgr
  • com.trs.components.common.publish.domain.taskdispatch.IPageTask
  • com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher
  • com.trs.components.wcm.content.service.portervisitors.IPorterVisitor
  • com.trs.components.wcm.publish.domain.IPreNextDocuments
  • com.trs.components.web.IPropertiesBuilder
  • com.trs.components.common.publish.persistent.element.IPublishElements
  • com.trs.service.IPublishService
  • com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher
  • com.trs.components.wcm.publish.tagparser.IPublishTaskDocumentsCacheMgr
  • com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr
  • com.trs.components.filter.IQueryFilter
  • com.trs.components.filter.IQueryFilterFactory
  • com.trs.service.IRecentService
  • com.trs.components.wcm.publish.element.IRelateResource
  • com.trs.webframework.xmlserver.server.IRequestProcessor
  • com.trs.service.IResourceService
  • com.trs.components.common.publish.widget.IResourceStyleMgr
  • com.trs.cms.auth.domain.IRightMgr
  • com.trs.service.IRoleService
  • com.trs.service.IScheduleService
  • com.trs.service.ISecurityService
  • com.trs.components.common.message.ISendWorker
  • com.trs.infra.IServer
    • com.trs.components.ckm.ICKMServer
    • com.trs.cms.process.definition.IFlowRuleCacheServer
    • com.trs.cms.process.IFlowServer
  • com.trs.webframework.provider.IServiceFilter
  • com.trs.webframework.provider.IServiceListener
  • com.trs.webframework.provider.IServiceProvider
    • com.trs.components.common.publish.widget.IContentStyleServiceProvider
    • com.trs.webframework.provider.IDeleteServiceProvider
      • com.trs.components.common.publish.widget.IContentStyleServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.special.ISpecialServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
      • com.trs.components.common.publish.widget.ILayoutServiceProvider
      • com.trs.components.common.publish.widget.IMasterServiceProvider
      • com.trs.components.common.publish.widget.IPageStyleServiceProvider
      • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
      • com.trs.components.special.ISpecialServiceProvider
      • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
      • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
      • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.IFindByIdServiceProvider
      • com.trs.components.common.publish.widget.IContentStyleServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.special.ISpecialServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
      • com.trs.components.common.publish.widget.ILayoutServiceProvider
      • com.trs.components.common.publish.widget.IMasterServiceProvider
      • com.trs.components.common.publish.widget.IPageStyleServiceProvider
      • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
      • com.trs.components.special.ISpecialServiceProvider
      • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
      • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
      • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.IFindByIdsServiceProvider
      • com.trs.components.common.publish.widget.IContentStyleServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.special.ISpecialServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
      • com.trs.components.common.publish.widget.ILayoutServiceProvider
      • com.trs.components.common.publish.widget.IMasterServiceProvider
      • com.trs.components.common.publish.widget.IPageStyleServiceProvider
      • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
      • com.trs.components.special.ISpecialServiceProvider
      • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
      • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
      • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
      • com.trs.components.common.publish.widget.IContentStyleServiceProvider
      • com.trs.components.common.publish.widget.ILayoutServiceProvider
      • com.trs.components.common.publish.widget.IMasterServiceProvider
      • com.trs.components.common.publish.widget.IPageStyleServiceProvider
      • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
      • com.trs.components.special.ISpecialServiceProvider
      • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
      • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
      • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.components.common.publish.widget.ILayoutServiceProvider
    • com.trs.components.common.publish.widget.IMasterServiceProvider
    • com.trs.components.common.publish.widget.IPageStyleServiceProvider
    • com.trs.webframework.provider.IQueryServiceProvider
      • com.trs.components.common.publish.widget.IContentStyleServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.special.ISpecialServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
      • com.trs.components.common.publish.widget.ILayoutServiceProvider
      • com.trs.components.common.publish.widget.IMasterServiceProvider
      • com.trs.components.common.publish.widget.IPageStyleServiceProvider
      • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
      • com.trs.components.special.ISpecialServiceProvider
      • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
      • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
      • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
    • com.trs.webframework.provider.ISaveServiceProvider
      • com.trs.components.common.publish.widget.IContentStyleServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.special.ISpecialServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
      • com.trs.components.common.publish.widget.ILayoutServiceProvider
      • com.trs.components.common.publish.widget.IMasterServiceProvider
      • com.trs.components.common.publish.widget.IPageStyleServiceProvider
      • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
      • com.trs.components.special.ISpecialServiceProvider
      • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
      • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
      • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.ISelfDefinedServiceProvider
      • com.trs.components.common.publish.widget.IContentStyleServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.special.ISpecialServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
      • com.trs.components.common.publish.widget.ILayoutServiceProvider
      • com.trs.components.common.publish.widget.IMasterServiceProvider
      • com.trs.components.common.publish.widget.IPageStyleServiceProvider
      • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
      • com.trs.components.special.ISpecialServiceProvider
      • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
      • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
      • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.components.special.ISpecialServiceProvider
    • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
    • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
    • com.trs.components.common.publish.widget.IWidgetServiceProvider
  • com.trs.service.ISOAPService
  • com.trs.components.special.ISpecialMgr
  • com.trs.components.stat.IStatHandler
  • com.trs.components.stat.IStatResult
  • com.trs.components.stat.IStatResultFilter
  • com.trs.components.stat.IStatResults
  • com.trs.components.stat.IStatResultsFilter
  • com.trs.service.IStatService
  • com.trs.components.common.publish.widget.IStyleAndResourceMgr
  • com.trs.components.common.publish.widget.IStyleCenterMgr
  • com.trs.components.common.publish.widget.IStyleItemMgr
  • com.trs.service.ISureformService
  • com.trs.components.common.publish.widget.ISystemContentStyleMgr
  • com.trs.components.common.publish.widget.ISystemResourceStyleMgr
  • com.trs.components.wcm.util.ISystemWarner
  • com.trs.components.common.publish.domain.tagparser.ITagFormatter
  • com.trs.components.common.publish.domain.tagparser.ITagParser4List
  • com.trs.service.ITemplateParseService
  • com.trs.template.service.ITemplateService
  • com.trs.service.ITemplateService
  • com.trs.template.domain.setting.ITemplateSetting
  • java.util.Iterator
    • com.trs.components.common.publish.domain.taskdispatch.IPublishElementsIterator
  • com.trs.cms.process.engine.IToUsersCreator
  • com.trs.infra.update.IUpdateCommander
  • com.trs.components.stat.IURLParser
  • com.trs.components.stat.IUserLoginInfoMgr
  • com.trs.service.IUserService
  • com.trs.wcag2.validator.IValidator
  • com.trs.presentation.valid.IValidator
  • com.trs.components.wcm.channel.IVChannelParser
  • com.trs.components.wcm.contentlink.IVContentLinkParser
  • com.trs.service.IWCMProcessService
  • com.trs.service.IWCMPublishElementService
  • com.trs.components.common.publish.widget.IWidgetInstanceMgr
  • com.trs.components.common.publish.widget.IWidgetInstParameterMgr
  • com.trs.components.common.publish.widget.IWidgetMgr
  • com.trs.components.common.publish.widget.IWidgetParameterMgr
  • com.trs.components.common.publish.widget.IWidgetServer
  • com.trs.webframework.xmlserver.IXMLConvertor
  • com.trs.infra.util.xml.IXmlPersistentObject
    • com.trs.infra.config.persistent.IConfigElement
    • com.trs.template.persistent.IInfoEntity
  • com.trs.license.License
  • com.trs.webframework.ServiceExcuteLogger
概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


序列化表格

软件包 com.trs.cms.auth.persistent

类 com.trs.cms.auth.persistent.Group 继承 CMSObj 实现 Serializable

serialVersionUID: -2265204905756007169L

序列化字段

hAdministrator

java.util.Hashtable hAdministrator

类 com.trs.cms.auth.persistent.Role 继承 CMSObj 实现 Serializable

serialVersionUID: 7232302897977228998L

类 com.trs.cms.auth.persistent.User 继承 CMSObj 实现 Serializable

serialVersionUID: 1354095122078583355L

序列化方法

readObject

private void readObject(java.io.ObjectInputStream in)
                 throws java.io.IOException,
                        java.lang.ClassNotFoundException
抛出：
java.io.IOException
java.lang.ClassNotFoundException

writeObject

private void writeObject(java.io.ObjectOutputStream out)
                  throws java.io.IOException
抛出：
java.io.IOException
序列化字段

bLogined

boolean bLogined

dtLastLoginTime

CMyDateTime dtLastLoginTime
软件包 com.trs.cms.process.definition

类 com.trs.cms.process.definition.OptMarkParseException 继承 java.lang.RuntimeException 实现 Serializable

serialVersionUID: -7129201627155865781L

软件包 com.trs.components.common.publish

类 com.trs.components.common.publish.OrignHomePublishException 继承 WCMException 实现 Serializable

serialVersionUID: -2422605166034949069L

软件包 com.trs.components.common.publish.domain.tagparser

类 com.trs.components.common.publish.domain.tagparser.LoopException 继承 java.lang.Exception 实现 Serializable

serialVersionUID: 553279131604986353L

软件包 com.trs.components.infoview.filter

类 com.trs.components.infoview.filter.InfoviewDataImportFilter 继承 ServiceControler 实现 Serializable

serialVersionUID: 1L

软件包 com.trs.components.wcm.stat.chart

类 com.trs.components.wcm.stat.chart.BarChartProducer 继承 java.lang.Object 实现 Serializable

类 com.trs.components.wcm.stat.chart.PieChartProducer 继承 java.lang.Object 实现 Serializable

软件包 com.trs.components.wcm.stat.domain

类 com.trs.components.wcm.stat.domain.ChartBuildException 继承 java.lang.RuntimeException 实现 Serializable

serialVersionUID: 4360361344146148196L

类 com.trs.components.wcm.stat.domain.TimingChartProducer 继承 java.lang.Object 实现 Serializable

serialVersionUID: 1L

序列化字段

m_oOption

ChartOption m_oOption

m_oDataset

TimingChartData m_oDataset
软件包 com.trs.infra

类 com.trs.infra.StartupServlet 继承 javax.servlet.http.HttpServlet 实现 Serializable

软件包 com.trs.infra.common

类 com.trs.infra.common.WCMDatainvalidException 继承 WCMException 实现 Serializable

类 com.trs.infra.common.WCMException 继承 CMyException 实现 Serializable

serialVersionUID: 8819172007753214059L

软件包 com.trs.infra.util

类 com.trs.infra.util.CMyDateTime 继承 java.lang.Object 实现 Serializable

序列化字段

m_dtDate

java.util.Date m_dtDate

m_dtFormater

java.text.SimpleDateFormat m_dtFormater

类 com.trs.infra.util.CMyException 继承 java.lang.Exception 实现 Serializable

序列化字段

errNo

int errNo

rootCause

java.lang.Throwable rootCause
软件包 com.trs.infra.util.email

类 com.trs.infra.util.email.CMyMailException 继承 CMyException 实现 Serializable

软件包 com.trs.infra.util.html

类 com.trs.infra.util.html.HTML.UnknownTag 继承 HTML.Tag 实现 Serializable

序列化方法

readObject

private void readObject(java.io.ObjectInputStream s)
                 throws java.lang.ClassNotFoundException,
                        java.io.IOException
抛出：
java.lang.ClassNotFoundException
java.io.IOException

writeObject

private void writeObject(java.io.ObjectOutputStream s)
                  throws java.io.IOException
抛出：
java.io.IOException
软件包 com.trs.infra.util.jazzlib

类 com.trs.infra.util.jazzlib.DataFormatException 继承 java.lang.Exception 实现 Serializable

类 com.trs.infra.util.jazzlib.ZipException 继承 java.io.IOException 实现 Serializable

软件包 com.trs.license

类 com.trs.license.LicenseException 继承 java.lang.RuntimeException 实现 Serializable

软件包 com.trs.presentation.login

类 com.trs.presentation.login.SessionListener 继承 java.lang.Object 实现 Serializable

序列化字段

m_oUserKey

java.lang.Integer m_oUserKey
软件包 com.trs.template

类 com.trs.template.AbstractErrorMessage 继承 java.lang.Exception 实现 Serializable

序列化字段

m_Code

int m_Code
错误号码

m_Description

java.lang.String m_Description
错误描述

m_Solution

java.lang.String m_Solution
错误解决办法

类 com.trs.template.TemplateRemoteException 继承 org.apache.axis.AxisFault 实现 Serializable

serialVersionUID: 1L

序列化字段

m_FailCode

int m_FailCode
错误号，错误信息从配置文件中进行获取

m_FailDescription

java.lang.String m_FailDescription
错误描述

m_FailSolution

java.lang.String m_FailSolution
错误的解决方法

软件包 com.trs.webframework.controler.servlet

类 com.trs.webframework.controler.servlet.FileUploader 继承 javax.servlet.http.HttpServlet 实现 Serializable

serialVersionUID: -6116748461001338662L

类 com.trs.webframework.controler.servlet.NoLoginServiceControler 继承 javax.servlet.http.HttpServlet 实现 Serializable

serialVersionUID: -2124220278229482688L

序列化字段

m_pIPs

java.lang.String[] m_pIPs

m_sUserName

java.lang.String m_sUserName

m_sRedirectURI

java.lang.String m_sRedirectURI

类 com.trs.webframework.controler.servlet.ServiceControler 继承 javax.servlet.http.HttpServlet 实现 Serializable

serialVersionUID: -6830625166991280397L

软件包 com.trs.webframework.exception

类 com.trs.webframework.exception.NoSuchServiceException 继承 ServiceInvocationException 实现 Serializable

serialVersionUID: -3872181730269485408L

类 com.trs.webframework.exception.ServiceCreationFailException 继承 ServiceInvocationException 实现 Serializable

serialVersionUID: 4360361362146148196L

类 com.trs.webframework.exception.ServiceInvocationException 继承 java.lang.RuntimeException 实现 Serializable

serialVersionUID: -7129201627155865072L

序列化字段

rootCause

java.lang.Throwable rootCause

m_sErrorCode

java.lang.String m_sErrorCode

m_sSuggestion

java.lang.String m_sSuggestion
软件包 com.trs.webframework.xmlserver

类 com.trs.webframework.xmlserver.ConvertException 继承 CMyException 实现 Serializable

serialVersionUID: 8153957805510029258L

软件包 com.trs.webframework.xmlserver.parser

类 com.trs.webframework.xmlserver.parser.XMLParseException 继承 java.lang.RuntimeException 实现 Serializable

serialVersionUID: -9169114662003921140L

软件包 com.trs.webframework.xmlserver.server

类 com.trs.webframework.xmlserver.server.DataAnalyzingException 继承 java.lang.RuntimeException 实现 Serializable

serialVersionUID: -4526387864005484760L

类 com.trs.webframework.xmlserver.server.RequestParmasParseException 继承 ServiceInvocationException 实现 Serializable

serialVersionUID: -8527212694064950696L

类 com.trs.webframework.xmlserver.server.ResponseOutputException 继承 java.lang.RuntimeException 实现 Serializable

serialVersionUID: 300638738760732809L

类 com.trs.webframework.xmlserver.server.XMLParsingPausedException 继承 java.lang.RuntimeException 实现 Serializable

serialVersionUID: 9168249094940414332L

软件包 com.trs.weblet.util.verfiycode

类 com.trs.weblet.util.verfiycode.VerifyCodeServlet 继承 javax.servlet.http.HttpServlet 实现 Serializable

serialVersionUID: 1L

序列化字段

m_oVerifyCode

VerifyCode m_oVerifyCode
VerifyCode 实例对象

m_oRandomMake

java.util.Random m_oRandomMake
随机数生成器

m_iDigitLimit

int m_iDigitLimit
验证码的上限

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ConfigFileTool4Refactor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs
类 ConfigFileTool4Refactor

java.lang.Object
    继承者  com.trs.ConfigFileTool4Refactor

public class ConfigFileTool4Refactor
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
for copy config file.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConfigFileTool4Refactor()
方法摘要
java.lang.String[] | getFiles(java.lang.String rootpath)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConfigFileTool4Refactor

public ConfigFileTool4Refactor()
方法详细信息

getFiles

public java.lang.String[] getFiles(java.lang.String rootpath)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DreamFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs
类 DreamFactory

java.lang.Object
    继承者  com.trs.DreamFactory

public class DreamFactory
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
获取BeansConfig中配置的Bean实例
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DreamFactory()
方法摘要
static java.lang.Object | createObjectById(java.lang.String _sObjectId) 产生指定对象的实例
static void | destroy()
static java.lang.String | getBeanClassName(java.lang.String _sBeanId)
static java.lang.String[] | getBeanDefinitionNames()
static boolean | isSinglton(java.lang.String _sBeanId)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DreamFactory

public DreamFactory()
方法详细信息

createObjectById

public static java.lang.Object createObjectById(java.lang.String _sObjectId)
产生指定对象的实例

参数：
_sObjectId - 指定对象在配置文件中的Id,WCM一般配置为使用对象的类型名称
返回：

destroy

public static void destroy()

getBeanClassName

public static java.lang.String getBeanClassName(java.lang.String _sBeanId)
参数：
_sBeanId -
返回：
@throws CMyException

isSinglton

public static boolean isSinglton(java.lang.String _sBeanId)
参数：
_sResourceid -
返回：

main

public static void main(java.lang.String[] args)

getBeanDefinitionNames

public static java.lang.String[] getBeanDefinitionNames()
                                                 throws CMyException
返回：
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs
类
ConfigFileTool4Refactor
DreamFactory
SpringBean


com.trs

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs

类摘要
ConfigFileTool4Refactor | Title: TRS 内容协作平台（TRS WCM） Description: for copy config file.
DreamFactory | Title: TRS 内容协作平台（TRS WCM） Description: 获取BeansConfig中配置的Bean实例 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SpringBean | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个软件包 下一个软件包 框架 无框架


com.trs 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.ConfigFileTool4Refactor
    • com.trs.DreamFactory
    • com.trs.SpringBean
概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


软件包 com.trs 的使用

上一个 下一个 框架 无框架

软件包 com.trs
的使用

没有 com.trs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SpringBean

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs
类 SpringBean

java.lang.Object
    继承者  com.trs.SpringBean

public class SpringBean
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SpringBean()
方法摘要
void | destroy() 销毁资源
java.lang.Object | getBean(java.lang.String _sResourceId)
java.lang.Class | getBeanClass(java.lang.String _sResourceId)
java.lang.String | getBeanClassName(java.lang.String _sResourceId)
java.lang.String[] | getBeanDefinitionNames()
boolean | isSinglton(java.lang.String _sResourceid)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SpringBean

public SpringBean()
方法详细信息

getBean

public java.lang.Object getBean(java.lang.String _sResourceId)
                         throws CMyException
抛出：
CMyException

getBeanClassName

public java.lang.String getBeanClassName(java.lang.String _sResourceId)
                                  throws CMyException
抛出：
CMyException

getBeanClass

public java.lang.Class getBeanClass(java.lang.String _sResourceId)
                             throws CMyException
抛出：
CMyException

isSinglton

public boolean isSinglton(java.lang.String _sResourceid)
                   throws CMyException
抛出：
CMyException

getBeanDefinitionNames

public java.lang.String[] getBeanDefinitionNames()
                                          throws CMyException
抛出：
CMyException

destroy

public void destroy()
销毁资源

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ApplyFormServiceProvider

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ApplyFormServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ApplyFormServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class ApplyFormServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ApplyFormServiceProvider()
方法摘要
java.lang.String | getFlowingStat(MethodContext _context)
java.util.Map | parseFlowingPath(java.lang.String _sPath)
void | saveAppendixes(MethodContext _methodContext)
void | startDocumentInFlow(MethodContext _methodContext) 让文档开始流转
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ApplyFormServiceProvider

public ApplyFormServiceProvider()
方法详细信息

startDocumentInFlow

public void startDocumentInFlow(MethodContext _methodContext)
                         throws java.lang.Throwable
让文档开始流转

参数：
_methodContext -
抛出：
java.lang.Throwable

saveAppendixes

public void saveAppendixes(MethodContext _methodContext)
                    throws java.lang.Throwable
抛出：
java.lang.Throwable

getFlowingStat

public java.lang.String getFlowingStat(MethodContext _context)
                                throws java.lang.Throwable
抛出：
java.lang.Throwable

parseFlowingPath

public java.util.Map parseFlowingPath(java.lang.String _sPath)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AuthServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 AuthServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.AuthServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class AuthServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

构造方法摘要
AuthServiceProvider()
方法摘要
java.lang.String | deleteOperatorRight(MethodContext _methodContext)
java.lang.String | saveOperatorRights(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AuthServiceProvider

public AuthServiceProvider()
方法详细信息

saveOperatorRights

public java.lang.String saveOperatorRights(MethodContext _methodContext)
                                    throws java.lang.Exception
抛出：
java.lang.Exception

deleteOperatorRight

public java.lang.String deleteOperatorRight(MethodContext _methodContext)
                                     throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ChannelHelper

java.lang.Object
    继承者  com.trs.ajaxservice.ChannelHelper

public class ChannelHelper
extends java.lang.Object

构造方法摘要
ChannelHelper()
方法摘要
static Channels | getChildren(User _loginUser, BaseChannel _parent, WCMFilter _extraFilter)
static void | removeNoRightChannel(User _loginUser, Channels _channels, int _nRightIndex)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelHelper

public ChannelHelper()
方法详细信息

getChildren

public static Channels getChildren(User _loginUser,
                                   BaseChannel _parent,
                                   WCMFilter _extraFilter)
                            throws WCMException
参数：
_loginUser -
_parent -
_extraFilter -
返回：
抛出：
WCMException

removeNoRightChannel

public static void removeNoRightChannel(User _loginUser,
                                        Channels _channels,
                                        int _nRightIndex)
                                 throws WCMException
参数：
_loginUser -
_channels -
_nRightIndex -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ChannelServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ChannelServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ChannelServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

构造方法摘要
ChannelServiceProvider()
方法摘要
void | changeOrder(MethodContext _methodContext) 调整栏目顺序
java.lang.String | checkSQLValid(MethodContext _context)
void | clearRecycle(MethodContext _methodContext) 清空子栏目回收站
java.lang.String | createChannelTreeHTMLOfIds(MethodContext _methodContext) 产生指定栏目ID的子栏目序列树HTML
java.lang.String | createFrom(MethodContext _MethodContext) 类似创建栏目
void | createFromFile(MethodContext _methodContext)
void | delete(MethodContext _methContext)
java.lang.Object | existsSimilarDataPath(MethodContext _methodContext) 在指定的站点或者栏目下是否存在相同存放路径的栏目
boolean | existsSimilarName(MethodContext _methodContext) 是否存在相同名称的栏目
java.lang.String | export(MethodContext _MethodContext) 导出指定栏目
java.lang.Object | filterChannels(MethodContext _context) 通过检索条件查找匹配的栏目 add by liuyou@2008-2-14 下午02:03:43
java.lang.Object | findById(MethodContext _context)
java.lang.Object | findByIds(MethodContext _context)
PageOperators | getDocumentOperators(MethodContext _methContext) 获取进入当前栏目的文档列表时针对于当前栏目的操作
PageOperators | getOperators(MethodContext _methContext) 获取针对指定的单个或者多个栏目的操作集合
PageOperators | getOperatorsInChannel(MethodContext _methContext) 获取进入当前栏目的子栏目列表时针对于当前栏目的操作
Channels | getRecycleChannels(MethodContext _methodContext) 获取回收站的栏目列表
java.lang.String | importChannels(MethodContext _MethodContext) 导入栏目
void | moveAsChild(MethodContext _methodContext) 移动栏目
java.lang.Object | query(MethodContext _methContext)
void | restoreChannels(MethodContext _methodContext) 恢复回收站中的栏目
int | save(MethodContext _methodContext)
int | saveForSpecial(MethodContext _methContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelServiceProvider

public ChannelServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

filterChannels

public java.lang.Object filterChannels(MethodContext _context)
                                throws java.lang.Throwable
通过检索条件查找匹配的栏目 add by liuyou@2008-2-14 下午02:03:43

参数：
_context -
返回：
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getOperators

public PageOperators getOperators(MethodContext _methContext)
                           throws java.lang.Throwable
获取针对指定的单个或者多个栏目的操作集合

参数：
_methContext -
返回：
抛出：
java.lang.Throwable

getDocumentOperators

public PageOperators getDocumentOperators(MethodContext _methContext)
                                   throws java.lang.Throwable
获取进入当前栏目的文档列表时针对于当前栏目的操作

参数：
_methContext -
返回：
抛出：
java.lang.Throwable

getOperatorsInChannel

public PageOperators getOperatorsInChannel(MethodContext _methContext)
                                    throws java.lang.Throwable
获取进入当前栏目的子栏目列表时针对于当前栏目的操作

参数：
_methContext -
返回：
抛出：
java.lang.Throwable

export

public java.lang.String export(MethodContext _MethodContext)
                        throws java.lang.Throwable
导出指定栏目

参数：
_MethodContext -
返回：
抛出：
java.lang.Throwable

importChannels

public java.lang.String importChannels(MethodContext _MethodContext)
                                throws java.lang.Throwable
导入栏目

参数：
_MethodContext -
抛出：
java.lang.Throwable

createFrom

public java.lang.String createFrom(MethodContext _MethodContext)
                            throws java.lang.Throwable
类似创建栏目

参数：
_MethodContext -
抛出：
java.lang.Throwable

moveAsChild

public void moveAsChild(MethodContext _methodContext)
                 throws java.lang.Throwable
移动栏目

参数：
_methodContext -
抛出：
java.lang.Throwable

changeOrder

public void changeOrder(MethodContext _methodContext)
                 throws java.lang.Throwable
调整栏目顺序

参数：
_methodContext -
抛出：
java.lang.Throwable

getRecycleChannels

public Channels getRecycleChannels(MethodContext _methodContext)
                            throws java.lang.Throwable
获取回收站的栏目列表

参数：
_methodContext -
抛出：
java.lang.Throwable

restoreChannels

public void restoreChannels(MethodContext _methodContext)
                     throws java.lang.Throwable
恢复回收站中的栏目

参数：
_methodContext -
抛出：
java.lang.Throwable

clearRecycle

public void clearRecycle(MethodContext _methodContext)
                  throws java.lang.Throwable
清空子栏目回收站

参数：
_methodContext -
抛出：
java.lang.Throwable

existsSimilarName

public boolean existsSimilarName(MethodContext _methodContext)
                          throws java.lang.Throwable
是否存在相同名称的栏目

参数：
_methodContext -
抛出：
java.lang.Throwable

existsSimilarDataPath

public java.lang.Object existsSimilarDataPath(MethodContext _methodContext)
                                       throws java.lang.Throwable
在指定的站点或者栏目下是否存在相同存放路径的栏目

参数：
_methodContext -
抛出：
java.lang.Throwable

checkSQLValid

public java.lang.String checkSQLValid(MethodContext _context)
                               throws WCMException
抛出：
WCMException

createFromFile

public void createFromFile(MethodContext _methodContext)
                    throws WCMException
抛出：
WCMException

createChannelTreeHTMLOfIds

public java.lang.String createChannelTreeHTMLOfIds(MethodContext _methodContext)
                                            throws WCMException
产生指定栏目ID的子栏目序列树HTML

参数：
_methodContext -
抛出：
WCMException
java.lang.Throwable

saveForSpecial

public int saveForSpecial(MethodContext _methContext)
                   throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelServiceProviderHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ChannelServiceProviderHelper

java.lang.Object
    继承者  com.trs.ajaxservice.ChannelServiceProviderHelper

public final class ChannelServiceProviderHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

构造方法摘要
ChannelServiceProviderHelper()
方法摘要
static void | createRelatedEmployes(Channel sourceChannel, Channel newChannel)
static void | createRelatedEmployes(java.lang.String _sRawChnlId, BaseChannel _newChannel)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelServiceProviderHelper

public ChannelServiceProviderHelper()
方法详细信息

createRelatedEmployes

public static void createRelatedEmployes(Channel sourceChannel,
                                         Channel newChannel)
                                  throws WCMException
抛出：
WCMException

createRelatedEmployes

public static void createRelatedEmployes(java.lang.String _sRawChnlId,
                                         BaseChannel _newChannel)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDocServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ChnlDocServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ChnlDocServiceProvider
所有已实现的接口：
IDeleteServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ChnlDocServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider, IDeleteServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChnlDocServiceProvider()
方法摘要
void | changeStatus(MethodContext _methodContext) 改变多篇文档的状态
Reports | copy(MethodContext _methodContext) 拷贝文档
void | delete(MethodContext _methContext)
java.lang.String | export(MethodContext _methodContext) 导出指定的文档
Reports | mirror(MethodContext _methodContext) 镜像文档
Reports | move(MethodContext _methodContext) 移动文档
void | publish(MethodContext _methodContext)
Reports | quote(MethodContext _methodContext) 引用文档
ChnlDocs | search(MethodContext _methContext) 查询指定站点或者指定频道下的文档
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocServiceProvider

public ChnlDocServiceProvider()
方法详细信息

changeStatus

public void changeStatus(MethodContext _methodContext)
                  throws java.lang.Throwable
改变多篇文档的状态

参数：
_methodContext -
抛出：
java.lang.Throwable

copy

public Reports copy(MethodContext _methodContext)
             throws java.lang.Throwable
拷贝文档

参数：
_methodContext -
抛出：
java.lang.Throwable

quote

public Reports quote(MethodContext _methodContext)
              throws java.lang.Throwable
引用文档

参数：
_methodContext -
抛出：
java.lang.Throwable

mirror

public Reports mirror(MethodContext _methodContext)
               throws java.lang.Throwable
镜像文档

参数：
_methodContext -
抛出：
java.lang.Throwable

move

public Reports move(MethodContext _methodContext)
             throws java.lang.Throwable
移动文档

参数：
_methodContext -
抛出：
java.lang.Throwable

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

export

public java.lang.String export(MethodContext _methodContext)
                        throws java.lang.Throwable
导出指定的文档

参数：
_methodContext -
抛出：
java.lang.Throwable

publish

public void publish(MethodContext _methodContext)
             throws java.lang.Throwable
参数：
_methodContext -
抛出：
java.lang.Throwable

search

public ChnlDocs search(MethodContext _methContext)
                throws WCMException
查询指定站点或者指定频道下的文档

参数：
_methContext -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtendValue

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ContentExtendValue

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.ajaxservice.ContentExtendValue
所有已实现的接口：
java.lang.Cloneable
public class ContentExtendValue
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
虚对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentExtendValue()
ContentExtendValue(int id, java.lang.String _sName, java.lang.String _sDBName, java.lang.String _sValue)
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ContentExtendValue

public ContentExtendValue()

ContentExtendValue

public ContentExtendValue(int id,
                          java.lang.String _sName,
                          java.lang.String _sDBName,
                          java.lang.String _sValue)
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtendValues

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ContentExtendValues

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.ajaxservice.ContentExtendValues

public class ContentExtendValues
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ContentExtendValues(User _currUser)
ContentExtendValues(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
void | addElement(int _nId, java.lang.String _sName, java.lang.String _sDBName, java.lang.String _sValue)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentExtendValues

public ContentExtendValues(User _currUser)
参数：
_currUser -

ContentExtendValues

public ContentExtendValues(User _currUser,
                           int _initCapacity,
                           int _incCapacity)
参数：
_currUser -
_initCapacity -
_incCapacity -
方法详细信息

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

addElement

public void addElement(int _nId,
                       java.lang.String _sName,
                       java.lang.String _sDBName,
                       java.lang.String _sValue)
                throws WCMException
参数：
_nId -
_sName -
_sDBName -
_sValue -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentLinkServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ContentLinkServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ContentLinkServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ContentLinkServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
热词相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentLinkServiceProvider()
方法摘要
java.lang.Object | addLinkInChannel(MethodContext _context)
java.lang.Object | changeOrder(MethodContext _context)
void | createFromFile(MethodContext _context) 导入txt文件来批量创建热词
void | delete(MethodContext _methodContext)
java.lang.Object | editLinkInChannel(MethodContext _context)
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
java.lang.String | getParentChannelWhere(int _nChannelId, WCMFilter filter)
void | importSysLinks(MethodContext _context)
java.lang.Object | query(MethodContext _methodContext)
java.lang.Object | queryLinkType(MethodContext _context)
java.lang.Object | querySysLinks(MethodContext _methodContext)
java.lang.Object | queryTypes(MethodContext _context)
int | save(MethodContext _methodContext)
void | setLinkType(MethodContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentLinkServiceProvider

public ContentLinkServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

querySysLinks

public java.lang.Object querySysLinks(MethodContext _methodContext)
                               throws java.lang.Throwable
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methodContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

getParentChannelWhere

public java.lang.String getParentChannelWhere(int _nChannelId,
                                              WCMFilter filter)
                                       throws WCMException
抛出：
WCMException

queryLinkType

public java.lang.Object queryLinkType(MethodContext _context)
                               throws WCMException
抛出：
WCMException

queryTypes

public java.lang.Object queryTypes(MethodContext _context)
                            throws WCMException
抛出：
WCMException

setLinkType

public void setLinkType(MethodContext _context)
                 throws WCMException
抛出：
WCMException

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

addLinkInChannel

public java.lang.Object addLinkInChannel(MethodContext _context)
                                  throws WCMException
抛出：
WCMException

editLinkInChannel

public java.lang.Object editLinkInChannel(MethodContext _context)
                                   throws WCMException
抛出：
WCMException

createFromFile

public void createFromFile(MethodContext _context)
                    throws WCMException
导入txt文件来批量创建热词

参数：
_context -
抛出：
WCMException

importSysLinks

public void importSysLinks(MethodContext _context)
                    throws WCMException
抛出：
WCMException

changeOrder

public java.lang.Object changeOrder(MethodContext _context)
                             throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DistributeServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 DistributeServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.DistributeServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class DistributeServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
扩展字段服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DistributeServiceProvider()
方法摘要
void | delete(MethodContext _methContext)
java.lang.Object | findById(MethodContext _methContext)
java.lang.Object | findByIds(MethodContext _methContext)
java.lang.Object | query(MethodContext _methContext)
java.lang.Object[] | queryTargetTypes() 获取系统支持的分发目标类型
int | save(MethodContext _methodContext)
void | updateStatus(MethodContext _methodContext) 启用/关闭 分发服务
void | updateStatusAll(MethodContext _methodContext) 启用/关闭 所有分发服务
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DistributeServiceProvider

public DistributeServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

updateStatus

public void updateStatus(MethodContext _methodContext)
                  throws java.lang.Throwable
启用/关闭 分发服务

参数：
_methodContext -
抛出：
java.lang.Throwable

updateStatusAll

public void updateStatusAll(MethodContext _methodContext)
                     throws java.lang.Throwable
启用/关闭 所有分发服务

参数：
_methodContext -
抛出：
java.lang.Throwable

queryTargetTypes

public java.lang.Object[] queryTargetTypes()
                                    throws java.lang.Throwable
获取系统支持的分发目标类型

返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentAuthHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 DocumentAuthHelper

java.lang.Object
    继承者  com.trs.ajaxservice.DocumentAuthHelper

public class DocumentAuthHelper
extends java.lang.Object

构造方法摘要
DocumentAuthHelper()
方法摘要
static WCMFilter makeFilterWithRight(User _loginUser, BaseObjs _oSitesOrChannels)
构造当前用户在指定的栏目中带有权限的Filter
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentAuthHelper

public DocumentAuthHelper()
方法详细信息

makeFilterWithRight

public static WCMFilter makeFilterWithRight(User _loginUser,
                                            BaseObjs _oSitesOrChannels)
                                     throws WCMException
构造当前用户在指定的栏目中带有权限的Filter

参数：
_loginUser - 当前用户
_oSitesOrChannels - 指定的栏目
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentBakServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 DocumentBakServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.DocumentBakServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class DocumentBakServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
文档版本相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentBakServiceProvider()
方法摘要
java.lang.String | backup(MethodContext _methodContext) 保存指定文档的版本
void | delete(MethodContext _methodContext)
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
java.lang.Object | query(MethodContext _methodContext)
Appendixes | queryAppendixes(MethodContext _methodContext) 获取指定文档版本指定类型的附件
ContentExtendValues | queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息
Relations | queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档
void | recover(MethodContext _methodContext) 恢复文档的版本
int | save(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentBakServiceProvider

public DocumentBakServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methodContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

backup

public java.lang.String backup(MethodContext _methodContext)
                        throws java.lang.Throwable
保存指定文档的版本

参数：
_methodContext -
抛出：
java.lang.Throwable

recover

public void recover(MethodContext _methodContext)
             throws java.lang.Throwable
恢复文档的版本

参数：
_methodContext -
抛出：
java.lang.Throwable

queryAppendixes

public Appendixes queryAppendixes(MethodContext _methodContext)
                           throws java.lang.Throwable
获取指定文档版本指定类型的附件

参数：
_methodContext -
抛出：
java.lang.Throwable

queryRelations

public Relations queryRelations(MethodContext _methodContext)
                         throws java.lang.Throwable
获取指定文档手工设定的相关文档

参数：
_methodContext -
抛出：
java.lang.Throwable

queryExtendFields

public ContentExtendValues queryExtendFields(MethodContext _methodContext)
                                      throws java.lang.Throwable
获取文档的扩展字段信息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentPublishHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 DocumentPublishHelper

java.lang.Object
    继承者  com.trs.ajaxservice.DocumentPublishHelper

public class DocumentPublishHelper
extends java.lang.Object

构造方法摘要
DocumentPublishHelper()
方法摘要
static void | delete(Documents _documents, Channel _channel)
static void | delete(Documents _documents, Channel _channel, boolean _bAll)
static void | delete(java.lang.String _sDocIds, int _nChannelId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentPublishHelper

public DocumentPublishHelper()
方法详细信息

delete

public static void delete(java.lang.String _sDocIds,
                          int _nChannelId)
                   throws WCMException
抛出：
WCMException

delete

public static void delete(Documents _documents,
                          Channel _channel)
                   throws WCMException
抛出：
WCMException

delete

public static void delete(Documents _documents,
                          Channel _channel,
                          boolean _bAll)
                   throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 DocumentServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.DocumentServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class DocumentServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
提供文档相关服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static boolean SUPPORT_DEFINE_DOCUMENT_RIGHT
构造方法摘要
DocumentServiceProvider()
方法摘要
void | addAppendixes(MethodContext _methodContext) 添加指定文档的相关文档 只做新增
void | changeOrder(MethodContext _methodContext) 改变属性
void | changeStatus(MethodContext _methodContext) 改变多篇文档的状态
void | clearRecycle(MethodContext _methodContext) 恢复回收站中的文档
Reports | copy(MethodContext _methodContext) 拷贝文档
Reports | copyAll(MethodContext _methodContext) 复制全部文档到
void | delete(MethodContext _methContext)
java.lang.String | export(MethodContext _methodContext) 导出指定的文档
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
PageOperators | getOperators(MethodContext _methContext)
java.lang.String | getPageInfo(MethodContext _methContext)
Channels | getQuotedChannels(MethodContext _MethodContext) 获取所有引用指定文档的栏目集合
java.lang.String | importDocuments(MethodContext _methodContext) 导入文档
Reports | move(MethodContext _methodContext) 移动文档
java.lang.String | preview(MethodContext _methodContext) 文档编辑时的预览
java.lang.Object | query(MethodContext _methContext)
Appendixes | queryAppendixes(MethodContext _methodContext) 获取指定文档指定类型的附件
ContentExtendValues | queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息
Documents | queryRecycle(MethodContext _methContext) 获取回收站文档
Relations | queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档
Reports | quote(MethodContext _methodContext) 引用文档到...
void | restore(MethodContext _methodContext) 恢复回收站中的文档
int | save(MethodContext _methodContext)
void | saveAppendixes(MethodContext _methodContext) 保存指定文档的相关文档
void | saveRelation(MethodContext _methodContext) 保存指定文档的相关文档
Reports | setQuote(MethodContext _methodContext) 为文档指定引用,用于编辑器中维护文档的所有引用关系
void | setTopDocument(MethodContext _methodContext) 将文档置顶
void | startDocumentInFlow(MethodContext _methodContext) 让文档开始流转
Reports | transmit(MethodContext _methodContext) 转发文档
void | trsSaveToWCM(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SUPPORT_DEFINE_DOCUMENT_RIGHT

public static boolean SUPPORT_DEFINE_DOCUMENT_RIGHT
构造方法详细信息

DocumentServiceProvider

public DocumentServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

preview

public java.lang.String preview(MethodContext _methodContext)
                         throws java.lang.Throwable
文档编辑时的预览

参数：
_methodContext -
返回：
预览的链接地址
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getPageInfo

public java.lang.String getPageInfo(MethodContext _methContext)
                             throws java.lang.Throwable
参数：
_methContext -
返回：
抛出：
java.lang.Throwable

getOperators

public PageOperators getOperators(MethodContext _methContext)
                           throws java.lang.Throwable
参数：
_methContext -
返回：
抛出：
java.lang.Throwable

getQuotedChannels

public Channels getQuotedChannels(MethodContext _MethodContext)
                           throws java.lang.Throwable
获取所有引用指定文档的栏目集合

参数：
_MethodContext -
返回：
抛出：
java.lang.Throwable

move

public Reports move(MethodContext _methodContext)
             throws java.lang.Throwable
移动文档

参数：
_methodContext -
抛出：
java.lang.Throwable

copy

public Reports copy(MethodContext _methodContext)
             throws java.lang.Throwable
拷贝文档

参数：
_methodContext -
抛出：
java.lang.Throwable

startDocumentInFlow

public void startDocumentInFlow(MethodContext _methodContext)
                         throws java.lang.Throwable
让文档开始流转

参数：
_methodContext -
抛出：
java.lang.Throwable

transmit

public Reports transmit(MethodContext _methodContext)
                 throws java.lang.Throwable
转发文档

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryExtendFields

public ContentExtendValues queryExtendFields(MethodContext _methodContext)
                                      throws java.lang.Throwable
获取文档的扩展字段信息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

setTopDocument

public void setTopDocument(MethodContext _methodContext)
                    throws java.lang.Throwable
将文档置顶

参数：
_methodContext -
抛出：
java.lang.Throwable

copyAll

public Reports copyAll(MethodContext _methodContext)
                throws java.lang.Throwable
复制全部文档到

参数：
_methodContext -
抛出：
java.lang.Throwable

setQuote

public Reports setQuote(MethodContext _methodContext)
                 throws java.lang.Throwable
为文档指定引用,用于编辑器中维护文档的所有引用关系

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

quote

public Reports quote(MethodContext _methodContext)
              throws java.lang.Throwable
引用文档到...

参数：
_methodContext -
抛出：
java.lang.Throwable

changeOrder

public void changeOrder(MethodContext _methodContext)
                 throws java.lang.Throwable
改变属性

参数：
_methodContext -
抛出：
java.lang.Throwable

export

public java.lang.String export(MethodContext _methodContext)
                        throws java.lang.Throwable
导出指定的文档

参数：
_methodContext -
抛出：
java.lang.Throwable

importDocuments

public java.lang.String importDocuments(MethodContext _methodContext)
                                 throws java.lang.Throwable
导入文档

参数：
_methodContext -
抛出：
java.lang.Throwable

queryRelations

public Relations queryRelations(MethodContext _methodContext)
                         throws java.lang.Throwable
获取指定文档手工设定的相关文档

参数：
_methodContext -
抛出：
java.lang.Throwable

saveRelation

public void saveRelation(MethodContext _methodContext)
                  throws java.lang.Throwable
保存指定文档的相关文档

参数：
_methodContext -
抛出：
java.lang.Throwable

queryRecycle

public Documents queryRecycle(MethodContext _methContext)
                       throws java.lang.Throwable
获取回收站文档

参数：
_methContext -
返回：
抛出：
java.lang.Throwable

restore

public void restore(MethodContext _methodContext)
             throws java.lang.Throwable
恢复回收站中的文档

参数：
_methodContext -
抛出：
java.lang.Throwable

clearRecycle

public void clearRecycle(MethodContext _methodContext)
                  throws java.lang.Throwable
恢复回收站中的文档

参数：
_methodContext -
抛出：
java.lang.Throwable

queryAppendixes

public Appendixes queryAppendixes(MethodContext _methodContext)
                           throws java.lang.Throwable
获取指定文档指定类型的附件

参数：
_methodContext -
抛出：
java.lang.Throwable

saveAppendixes

public void saveAppendixes(MethodContext _methodContext)
                    throws java.lang.Throwable
保存指定文档的相关文档

参数：
_methodContext -
抛出：
java.lang.Throwable

addAppendixes

public void addAppendixes(MethodContext _methodContext)
                   throws java.lang.Throwable
添加指定文档的相关文档 只做新增

参数：
_methodContext -
抛出：
java.lang.Throwable

changeStatus

public void changeStatus(MethodContext _methodContext)
                  throws java.lang.Throwable
改变多篇文档的状态

参数：
_methodContext -
抛出：
java.lang.Throwable

trsSaveToWCM

public void trsSaveToWCM(MethodContext _methodContext)
                  throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentSynServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 DocumentSynServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.DocumentSynServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class DocumentSynServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
文档分发服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentSynServiceProvider()
方法摘要
void | delete(MethodContext _methodContext)
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
java.lang.String | isValidDocumentCollection(MethodContext _methodContext)
java.lang.String | isValidDocumentSyn(MethodContext _methodContext) 校验同步创建是否有效，如果有效返回长度为0的字符串，如果无效返回以逗号分隔的Ids
java.lang.Object | query(MethodContext _methodContext)
int | save(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentSynServiceProvider

public DocumentSynServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methodContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

isValidDocumentSyn

public java.lang.String isValidDocumentSyn(MethodContext _methodContext)
                                    throws java.lang.Throwable
校验同步创建是否有效，如果有效返回长度为0的字符串，如果无效返回以逗号分隔的Ids

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

isValidDocumentCollection

public java.lang.String isValidDocumentCollection(MethodContext _methodContext)
                                           throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExtendFieldServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ExtendFieldServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ExtendFieldServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ExtendFieldServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
扩展字段服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ExtendFieldServiceProvider()
方法摘要
void | delete(MethodContext _methContext)
java.lang.String | existsSimilarName(MethodContext _methodContext) 判断指定扩展字段是否有效
java.lang.Object | findById(MethodContext _methContext)
java.lang.Object | findByIds(MethodContext _methContext)
CMSObj | findParent(CMSObj _currObj) 根据当前对象，获取当前对象的父对象
int | getMaxOrder(CMSObj host)
PageOperators | getOperators(MethodContext _methContext) 获取扩展字段的操作
DataType[] | getSupportedDataTypes() 获取系统支持的数据类型
void | impartExtendFields(MethodContext _methodContext) 将扩展字段同步到指定对象的所有子对象上
void | inheritExtendFields(MethodContext _methodContext) 将当前传入的对象，继承父对象的扩展字段信息
void | inhertSpecificFromParent(MethodContext _methodContext) 继承父对象指定ID的扩展字段信息
java.lang.Object | query(MethodContext _methContext)
ExtendedFields | queryExtendFields(MethodContext _methodContext) 获取系统配置的物理字段
int | save(MethodContext _methContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExtendFieldServiceProvider

public ExtendFieldServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
获取系统支持的数据类型

参数：
_MethodContext -
返回：

getOperators

public PageOperators getOperators(MethodContext _methContext)
                           throws java.lang.Throwable
获取扩展字段的操作

参数：
_methContext -
返回：
抛出：
java.lang.Throwable

impartExtendFields

public void impartExtendFields(MethodContext _methodContext)
                        throws java.lang.Throwable
将扩展字段同步到指定对象的所有子对象上

参数：
_methodContext -
抛出：
java.lang.Throwable

inheritExtendFields

public void inheritExtendFields(MethodContext _methodContext)
                         throws java.lang.Throwable
将当前传入的对象，继承父对象的扩展字段信息

参数：
_methodContext -
抛出：
java.lang.Throwable

inhertSpecificFromParent

public void inhertSpecificFromParent(MethodContext _methodContext)
                              throws java.lang.Throwable
继承父对象指定ID的扩展字段信息

参数：
_methodContext -
抛出：
java.lang.Throwable

getMaxOrder

public int getMaxOrder(CMSObj host)
                throws java.lang.Throwable
抛出：
java.lang.Throwable

findParent

public CMSObj findParent(CMSObj _currObj)
                  throws java.lang.Throwable
根据当前对象，获取当前对象的父对象

参数：
_currObj -
抛出：
java.lang.Throwable

queryExtendFields

public ExtendedFields queryExtendFields(MethodContext _methodContext)
                                 throws java.lang.Throwable
获取系统配置的物理字段

参数：
_methodContext -
抛出：
java.lang.Throwable

existsSimilarName

public java.lang.String existsSimilarName(MethodContext _methodContext)
                                   throws java.lang.Throwable
判断指定扩展字段是否有效

参数：
_methodContext -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowingDocQueryService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 FlowingDocQueryService

java.lang.Object
    继承者  com.trs.ajaxservice.FlowingDocQueryService
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class FlowingDocQueryService
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

构造方法摘要
FlowingDocQueryService()
方法摘要
java.lang.String | getFlowingDocBySNO(MethodContext _context)
java.lang.String | getFlowingStatByChnl(MethodContext _context)
java.util.Map | parseFlowingPath(java.lang.String _sPath)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowingDocQueryService

public FlowingDocQueryService()
方法详细信息

getFlowingDocBySNO

public java.lang.String getFlowingDocBySNO(MethodContext _context)
                                    throws java.lang.Throwable
抛出：
java.lang.Throwable

getFlowingStatByChnl

public java.lang.String getFlowingStatByChnl(MethodContext _context)
                                      throws java.lang.Throwable
抛出：
java.lang.Throwable

parseFlowingPath

public java.util.Map parseFlowingPath(java.lang.String _sPath)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 GroupServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.GroupServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class GroupServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

作者：
hdg

构造方法摘要
GroupServiceProvider()
方法摘要
void | delete(MethodContext _methodContext)
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
Groups | getGroupsForCurrUser(MethodContext context) 获取当前登录用户可以管理的组织,也就是作为组管理员的组织
Groups | getGroupsForRole(MethodContext context) 获取指定角色关联的组织
java.lang.Object | query(MethodContext context)
int | save(MethodContext context)
void | saveGroups(MethodContext _methodContext) 保存用户新建和修改用户后的用户所属组织信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupServiceProvider

public GroupServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

saveGroups

public void saveGroups(MethodContext _methodContext)
                throws java.lang.Throwable
保存用户新建和修改用户后的用户所属组织信息

参数：
_methodContext -
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getGroupsForCurrUser

public Groups getGroupsForCurrUser(MethodContext context)
                            throws java.lang.Throwable
获取当前登录用户可以管理的组织,也就是作为组管理员的组织

参数：
context -
返回：
抛出：
java.lang.Throwable

getGroupsForRole

public Groups getGroupsForRole(MethodContext context)
                        throws java.lang.Throwable
获取指定角色关联的组织

参数：
context -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndividuationServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 IndividuationServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.IndividuationServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class IndividuationServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider, IGlueServiceProvider

构造方法摘要
IndividuationServiceProvider()
方法摘要
void | delete(MethodContext _methodContext)
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
java.lang.String | getPageInfo(MethodContext _methodContext)
java.lang.Object | query(MethodContext _methContext)
java.lang.Object | queryCustomSite(MethodContext _methContext)
int | save(MethodContext _methodContext)
boolean | setIsChecked(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IndividuationServiceProvider

public IndividuationServiceProvider()
方法详细信息

query

public java.lang.Object query(MethodContext _methContext)
                       throws WCMException
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
WCMException

queryCustomSite

public java.lang.Object queryCustomSite(MethodContext _methContext)
                                 throws WCMException
抛出：
WCMException

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

getPageInfo

public java.lang.String getPageInfo(MethodContext _methodContext)
                             throws java.lang.Throwable
抛出：
java.lang.Throwable

setIsChecked

public boolean setIsChecked(MethodContext _methodContext)
                     throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoviewDataToolService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 InfoviewDataToolService

java.lang.Object
    继承者  com.trs.ajaxservice.InfoviewDataToolService
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class InfoviewDataToolService
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoviewDataToolService()
方法摘要
void | adapterHistory(MethodContext _context) 1.为系统所有视图创建表结构 2.替换视图的检索字段，概览字段，自动生成相应的DB字段 3.替换栏目的检索字段，自动生成相应的DB字段 4.同步文档的DocFlag到ChnlDoc表中
void | autoCreateHistoryDocs(MethodContext _context) 遍历docflag>0的文档列表，保存相关的字段，生成新的表单数据
void | rebuildAllInfoViews(MethodContext _context) 为系统所有视图创建表结构
void | renderAllChannelOutlineFields(MethodContext _context) 替换栏目的检索字段，自动生成相应的DB字段
void | renderAllInfoViewSearchOutlineFields(MethodContext _context) 替换视图的检索字段，概览字段，自动生成相应的DB字段
void | syncChnlDocFlag(MethodContext _context) 同步文档的DocFlag到ChnlDoc表中
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoviewDataToolService

public InfoviewDataToolService()
方法详细信息

adapterHistory

public void adapterHistory(MethodContext _context)
                    throws WCMException
1.为系统所有视图创建表结构
2.替换视图的检索字段，概览字段，自动生成相应的DB字段
3.替换栏目的检索字段，自动生成相应的DB字段
4.同步文档的DocFlag到ChnlDoc表中

抛出：
WCMException

syncChnlDocFlag

public void syncChnlDocFlag(MethodContext _context)
                     throws WCMException
同步文档的DocFlag到ChnlDoc表中

参数：
_context -
抛出：
WCMException

autoCreateHistoryDocs

public void autoCreateHistoryDocs(MethodContext _context)
                           throws WCMException
遍历docflag>0的文档列表，保存相关的字段，生成新的表单数据

参数：
_context -
抛出：
WCMException

renderAllChannelOutlineFields

public void renderAllChannelOutlineFields(MethodContext _context)
                                   throws WCMException
替换栏目的检索字段，自动生成相应的DB字段

参数：
_context -
抛出：
WCMException

renderAllInfoViewSearchOutlineFields

public void renderAllInfoViewSearchOutlineFields(MethodContext _context)
                                          throws WCMException
替换视图的检索字段，概览字段，自动生成相应的DB字段

参数：
_context -
抛出：
WCMException

rebuildAllInfoViews

public void rebuildAllInfoViews(MethodContext _context)
                         throws WCMException
为系统所有视图创建表结构

参数：
_context -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDocumentServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 InfoViewDocumentServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.InfoViewDocumentServiceProvider
所有已实现的接口：
IFindByIdServiceProvider, IQueryServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class InfoViewDocumentServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider, IQueryServiceProvider, IFindByIdServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoViewDocumentServiceProvider()
方法摘要
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | query(MethodContext _methContext)
InfoViewDocuments | queryRecycle(MethodContext _methContext) 获取指定站点或者指定频道回收站下的文档
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewDocumentServiceProvider

public InfoViewDocumentServiceProvider()
方法详细信息

queryRecycle

public InfoViewDocuments queryRecycle(MethodContext _methContext)
                               throws java.lang.Exception
获取指定站点或者指定频道回收站下的文档

参数：
_methContext -
返回：
抛出：
WCMException
java.lang.Exception

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoviewService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 InfoviewService

java.lang.Object
    继承者  com.trs.ajaxservice.InfoviewService
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class InfoviewService
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoviewService()
方法摘要
void | assertSignData(MethodContext _context)
void | checkSysInfos(MethodContext _context)
void | delete(MethodContext context)
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.lang.String | generaterContent(MethodContext _context) _context 中参数 DocumentId InfoViewId/ChannelId TempIVType 缺省为detail Page 缺省为1
java.lang.String | getAbsolutePath(InfoView _oInfoView, java.lang.String sFileName)
InfoViews | getInfoViews()
java.lang.String | getInfoViewTemPath(InfoView _oInfoView)
java.lang.String | importInfoViewData(MethodContext _context)
java.lang.String | importInfoViewDataForCustom(MethodContext _context)
void | initInfoViewTemFileUrls()
java.io.File | makeTemplatesToZip(MethodContext _context)
void | putInfoViewTemplateInfoOnePath(java.lang.String _infoviewids)
java.lang.Object | query(MethodContext context)
java.lang.String | queryChannelUsableInfoviews(MethodContext _context)
java.lang.String | queryData(MethodContext _context)
java.lang.String | queryData2(MethodContext _context)
java.lang.String | queryData3(MethodContext _context)
InfoViews | queryFlowInfoviews(MethodContext _context)
java.lang.String | querySearchFields(MethodContext _context)
java.lang.String | retriveChannelInfo(MethodContext _context)
int | save(MethodContext context)
void | setEmployedInfoView(MethodContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoviewService

public InfoviewService()
方法详细信息

checkSysInfos

public void checkSysInfos(MethodContext _context)
                   throws java.lang.Exception
抛出：
java.lang.Exception

retriveChannelInfo

public java.lang.String retriveChannelInfo(MethodContext _context)
                                    throws java.lang.Exception
抛出：
java.lang.Exception

importInfoViewData

public java.lang.String importInfoViewData(MethodContext _context)
                                    throws java.lang.Exception
抛出：
java.lang.Exception

importInfoViewDataForCustom

public java.lang.String importInfoViewDataForCustom(MethodContext _context)
                                             throws java.lang.Exception
抛出：
java.lang.Exception

queryFlowInfoviews

public InfoViews queryFlowInfoviews(MethodContext _context)
                             throws WCMException
抛出：
WCMException

queryChannelUsableInfoviews

public java.lang.String queryChannelUsableInfoviews(MethodContext _context)
                                             throws WCMException
抛出：
WCMException

setEmployedInfoView

public void setEmployedInfoView(MethodContext _context)
                         throws WCMException
抛出：
WCMException

querySearchFields

public java.lang.String querySearchFields(MethodContext _context)
                                   throws WCMException
抛出：
WCMException

queryData

public java.lang.String queryData(MethodContext _context)
                           throws java.lang.Throwable
抛出：
java.lang.Throwable

queryData2

public java.lang.String queryData2(MethodContext _context)
                            throws java.lang.Throwable
抛出：
java.lang.Throwable

queryData3

public java.lang.String queryData3(MethodContext _context)
                            throws java.lang.Throwable
抛出：
java.lang.Throwable

generaterContent

public java.lang.String generaterContent(MethodContext _context)
                                  throws WCMException
_context 中参数 DocumentId InfoViewId/ChannelId TempIVType 缺省为detail Page 缺省为1

参数：
_context -
返回：
抛出：
WCMException

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

assertSignData

public void assertSignData(MethodContext _context)
                    throws java.lang.Throwable
抛出：
java.lang.Throwable

makeTemplatesToZip

public java.io.File makeTemplatesToZip(MethodContext _context)
                                throws java.io.IOException,
                                       CMyException
抛出：
java.io.IOException
CMyException

putInfoViewTemplateInfoOnePath

public void putInfoViewTemplateInfoOnePath(java.lang.String _infoviewids)
                                    throws java.io.IOException,
                                           WCMException
抛出：
java.io.IOException
WCMException

getInfoViews

public InfoViews getInfoViews()
                       throws WCMException
抛出：
WCMException

initInfoViewTemFileUrls

public void initInfoViewTemFileUrls()
                             throws WCMException
抛出：
WCMException

getInfoViewTemPath

public java.lang.String getInfoViewTemPath(InfoView _oInfoView)

getAbsolutePath

public java.lang.String getAbsolutePath(InfoView _oInfoView,
                                        java.lang.String sFileName)
                                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSONHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 JSONHelper

java.lang.Object
    继承者  com.trs.ajaxservice.JSONHelper

public class JSONHelper
extends java.lang.Object

构造方法摘要
JSONHelper()
方法摘要
static void | main(java.lang.String[] args)
static java.lang.String | toJSON(java.util.HashMap _map, int _nLevel) 将HashMap转换成一个JSON表达的JavaScript对象 HashMap中的Value支持String、String[]
static java.lang.String | toJSON(java.lang.Object[] _pObject, int _nLevel)
static java.lang.String | toJSON(java.lang.Object _oValue, java.lang.String _sTagName, int _nLevel) 根据传入的对象,返回JSON表达式
static java.lang.String | toJSON(java.lang.String[][] _pValues, int _nLevel) 将一个二维字符串[*][2]转换成一个JSON表达的JavaScript对象
static java.lang.String | toJSON(java.lang.String[] _pValues, java.lang.String _sTagName, int _nLevel) 将一个字符串数组转换成JSON表达的数组
static java.lang.String | toJSON(java.lang.String _sValue, java.lang.String _sTagName, int _nLevel)
static java.lang.String | toSimpleJSON(java.util.HashMap _map, int _nLevel)
static java.lang.String | toSimpleJSON(java.lang.Object[] _pObject, java.lang.String _sKey, int _nLevel)
static java.lang.String | toSimpleJSON(java.lang.Object _oValue, java.lang.String _sTagName, int _nLevel)
static java.lang.String | toSimpleJSON(java.lang.String[] _pValues, java.lang.String _sTagName, int _nLevel)
static java.lang.String | toSimpleJSON2(java.util.HashMap _map, int _nLevel) 与toSimpleJson同参方法的区别在于对String[][]的处理改为对Object[]的处理 对Object[]和Object以及递归HashMap的处理方法由toSimpleJSON==>toSimpleJSON2
static java.lang.String | toSimpleJSON2(java.lang.Object[] _pObject, java.lang.String _sKey, int _nLevel) 与toSimpleJson同参方法的区别在于对Object[]中的Object的处理方法由toSimpleJSON==>toSimpleJSON2
static java.lang.String | toSimpleJSON2(java.lang.Object _oValue, java.lang.String _sTagName, int _nLevel) 与toSimpleJson同参方法的区别在于对String[][]的处理改为对Object[]的处理
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JSONHelper

public JSONHelper()
方法详细信息

toJSON

public static java.lang.String toJSON(java.lang.Object _oValue,
                                      java.lang.String _sTagName,
                                      int _nLevel)
根据传入的对象,返回JSON表达式

参数：
_oValue -
返回：

toSimpleJSON

public static java.lang.String toSimpleJSON(java.lang.Object _oValue,
                                            java.lang.String _sTagName,
                                            int _nLevel)

toJSON

public static java.lang.String toJSON(java.lang.Object[] _pObject,
                                      int _nLevel)

toSimpleJSON

public static java.lang.String toSimpleJSON(java.lang.Object[] _pObject,
                                            java.lang.String _sKey,
                                            int _nLevel)

toJSON

public static java.lang.String toJSON(java.lang.String _sValue,
                                      java.lang.String _sTagName,
                                      int _nLevel)

toSimpleJSON

public static java.lang.String toSimpleJSON(java.util.HashMap _map,
                                            int _nLevel)

toJSON

public static java.lang.String toJSON(java.util.HashMap _map,
                                      int _nLevel)
将HashMap转换成一个JSON表达的JavaScript对象 HashMap中的Value支持String、String[]

参数：
_map -
返回：

toJSON

public static java.lang.String toJSON(java.lang.String[] _pValues,
                                      java.lang.String _sTagName,
                                      int _nLevel)
将一个字符串数组转换成JSON表达的数组

参数：
_pValues -
返回：

toSimpleJSON

public static java.lang.String toSimpleJSON(java.lang.String[] _pValues,
                                            java.lang.String _sTagName,
                                            int _nLevel)

toJSON

public static java.lang.String toJSON(java.lang.String[][] _pValues,
                                      int _nLevel)
将一个二维字符串[*][2]转换成一个JSON表达的JavaScript对象

参数：
_pValues - [*][2]的字符串数组
返回：

toSimpleJSON2

public static java.lang.String toSimpleJSON2(java.util.HashMap _map,
                                             int _nLevel)
与toSimpleJson同参方法的区别在于对String[][]的处理改为对Object[]的处理 对Object[]和Object以及递归HashMap的处理方法由toSimpleJSON==>toSimpleJSON2

参数：
_map -
_nLevel -
返回：

toSimpleJSON2

public static java.lang.String toSimpleJSON2(java.lang.Object[] _pObject,
                                             java.lang.String _sKey,
                                             int _nLevel)
与toSimpleJson同参方法的区别在于对Object[]中的Object的处理方法由toSimpleJSON==>toSimpleJSON2

参数：
_pObject -
_sKey -
_nLevel -
返回：

toSimpleJSON2

public static java.lang.String toSimpleJSON2(java.lang.Object _oValue,
                                             java.lang.String _sTagName,
                                             int _nLevel)
与toSimpleJson同参方法的区别在于对String[][]的处理改为对Object[]的处理

参数：
_oValue -
_sTagName -
_nLevel -
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 MessageServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.MessageServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class MessageServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
消息中心服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MessageServiceProvider()
方法摘要
void | clearInbox() 清空收件箱
void | clearOutbox() 清空发件箱
void | delete(MethodContext _methodContext)
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
boolean | hasUnreadMessage(MethodContext _methodContext) 获取当前用户没有阅读的消息
java.lang.Object | query(MethodContext _methodContext)
int | save(MethodContext _methodContext)
int | sendMessage(MethodContext _methodContext) 发送消息
void | setReadFlag(MethodContext _methodContext) 将消息设置为已读
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageServiceProvider

public MessageServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methodContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

hasUnreadMessage

public boolean hasUnreadMessage(MethodContext _methodContext)
                         throws java.lang.Throwable
获取当前用户没有阅读的消息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

sendMessage

public int sendMessage(MethodContext _methodContext)
                throws java.lang.Throwable
发送消息

参数：
_methodContext -
抛出：
java.lang.Throwable

setReadFlag

public void setReadFlag(MethodContext _methodContext)
                 throws java.lang.Throwable
将消息设置为已读

参数：
_methodContext -
抛出：
java.lang.Throwable

clearInbox

public void clearInbox()
                throws WCMException
清空收件箱

参数：
_context -
抛出：
WCMException

clearOutbox

public void clearOutbox()
                 throws WCMException
清空发件箱

参数：
_context -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NewChannelServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 NewChannelServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.NewChannelServiceProvider
所有已实现的接口：
ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class NewChannelServiceProvider
extends java.lang.Object
implements ISaveServiceProvider, ISelfDefinedServiceProvider

作者：
Administrator

构造方法摘要
NewChannelServiceProvider()
方法摘要
int | list(MethodContext _sContext)
int | save(MethodContext _sContext)
int | savepic(MethodContext _sContext)
int | savePro(MethodContext _sContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NewChannelServiceProvider

public NewChannelServiceProvider()
方法详细信息

list

public int list(MethodContext _sContext)
         throws java.lang.Throwable
抛出：
java.lang.Throwable

savePro

public int savePro(MethodContext _sContext)
            throws java.lang.Throwable
抛出：
java.lang.Throwable

savepic

public int savepic(MethodContext _sContext)
            throws java.lang.Throwable
抛出：
java.lang.Throwable

save

public int save(MethodContext _sContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectMemberServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ObjectMemberServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ObjectMemberServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ObjectMemberServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

作者：
Administrator

构造方法摘要
ObjectMemberServiceProvider()
方法摘要
void | delete(MethodContext _oContext)
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _oContext)
java.lang.Object | query(MethodContext _oContext)
ObjectMembers | queryMembersOfObject(MethodContext _methodContext) 返回对指定对象可见可操作的所有成员
ObjectMembers | queryObjectsOfMember(MethodContext _methodContext) 返回指定成员的所有可见可操作的对象
int | save(MethodContext _methodContext)
void | saveMembersOfObject(MethodContext _methodContext) 保存指定对象对其可见、可操作的成员
void | saveObjectsOfMember(MethodContext _methodContext) 保存指定成员所拥有的可见、可操作对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectMemberServiceProvider

public ObjectMemberServiceProvider()
方法详细信息

delete

public void delete(MethodContext _oContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _oContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _oContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

queryMembersOfObject

public ObjectMembers queryMembersOfObject(MethodContext _methodContext)
                                   throws java.lang.Exception
返回对指定对象可见可操作的所有成员

参数：
_methodContext -
返回：
抛出：
java.lang.Exception

queryObjectsOfMember

public ObjectMembers queryObjectsOfMember(MethodContext _methodContext)
                                   throws java.lang.Exception
返回指定成员的所有可见可操作的对象

参数：
_methodContext -
返回：
抛出：
java.lang.Exception

saveObjectsOfMember

public void saveObjectsOfMember(MethodContext _methodContext)
                         throws java.lang.Exception
保存指定成员所拥有的可见、可操作对象

参数：
_methodContext -
抛出：
java.lang.Exception

saveMembersOfObject

public void saveMembersOfObject(MethodContext _methodContext)
                         throws java.lang.Exception
保存指定对象对其可见、可操作的成员

参数：
_methodContext -
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.ajaxservice
类
ApplyFormServiceProvider
AuthServiceProvider
ChannelHelper
ChannelServiceProvider
ChannelServiceProviderHelper
ChnlDocServiceProvider
ContentExtendValue
ContentExtendValues
ContentLinkServiceProvider
DistributeServiceProvider
DocumentAuthHelper
DocumentBakServiceProvider
DocumentPublishHelper
DocumentServiceProvider
DocumentSynServiceProvider
ExtendFieldServiceProvider
FlowingDocQueryService
GroupServiceProvider
IndividuationServiceProvider
InfoviewDataToolService
InfoViewDocumentServiceProvider
InfoviewService
JSONHelper
MessageServiceProvider
NewChannelServiceProvider
ObjectMemberServiceProvider
PageOperatorsForServiceHelper
PhotoServiceProvider
PreviewChannelServiceProvider
ProcessService
PublishServiceProvider
ReplaceContentServiceProvider
RoleServiceProvider
SceneServiceProvider
ServiceConstants
SourceServiceProvider
StatusServiceProvider
SystemServiceProvider
TemplateAuthHelper
TemplateEmployMgrHelper
TemplateServiceHelperProvider
TemplateServiceProvider
UserServiceProvider
ViewDocumentServiceProvider
WatermarkServiceProvider
WCMAJAXServiceHelper
WCMApplyFormProcessServiceHelper
WCMDocumentHelper
WCMProcessServiceHelper
WebSiteHelper
WebSiteServiceProvider
XmlToRightConvertor


com.trs.ajaxservice

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.ajaxservice

类摘要
ApplyFormServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
AuthServiceProvider |
ChannelHelper |
ChannelServiceProvider |
ChannelServiceProviderHelper | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentExtendValue | Title: TRS 内容协作平台（TRS WCM） Description: 虚对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentExtendValues | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentLinkServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DistributeServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentAuthHelper |
DocumentBakServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentPublishHelper |
DocumentServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentSynServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ExtendFieldServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowingDocQueryService | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupServiceProvider |
IndividuationServiceProvider |
InfoviewDataToolService | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDocumentServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoviewService | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JSONHelper |
MessageServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
NewChannelServiceProvider |
ObjectMemberServiceProvider |
PageOperatorsForServiceHelper |
PhotoServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
PreviewChannelServiceProvider |
ProcessService | Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 发布服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ReplaceContentServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RoleServiceProvider |
SceneServiceProvider |
ServiceConstants |
SourceServiceProvider |
StatusServiceProvider |
SystemServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 系统服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateAuthHelper | Title: TRS 内容协作平台（TRS WCM） Description: 模板权限解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployMgrHelper | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateServiceHelperProvider |
TemplateServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UserServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocumentServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WatermarkServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WCMAJAXServiceHelper | Title: TRS 内容协作平台（TRS WCM） Description: WCM AJAX服务器端工具类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMApplyFormProcessServiceHelper | Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务辅助解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMDocumentHelper | Title: TRS 内容协作平台（TRS WCM） Description: 文档相关公用行为提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMProcessServiceHelper | Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务辅助解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteHelper | Title: TRS 内容协作平台（TRS WCM） Description: 站点相关的工具函数 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XmlToRightConvertor |

概述 软件包 类 使用 树 已过时 索引 帮助


com.trs.ajaxservice 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.ajaxservice 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.ajaxservice.ApplyFormServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.AuthServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.ajaxservice.ContentExtendValue
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.ajaxservice.ContentExtendValues
    • com.trs.ajaxservice.ChannelHelper
    • com.trs.ajaxservice.ChannelServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.ChannelServiceProviderHelper
    • com.trs.ajaxservice.ChnlDocServiceProvider (implements com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.ContentLinkServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.DistributeServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.DocumentAuthHelper
    • com.trs.ajaxservice.DocumentBakServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.DocumentPublishHelper
    • com.trs.ajaxservice.DocumentServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.DocumentSynServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.ExtendFieldServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.FlowingDocQueryService (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.GroupServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.IndividuationServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.InfoviewDataToolService (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.InfoViewDocumentServiceProvider (implements com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.InfoviewService (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.JSONHelper
    • com.trs.ajaxservice.MessageServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.NewChannelServiceProvider (implements com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.ObjectMemberServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.PageOperatorsForServiceHelper
    • com.trs.ajaxservice.PreviewChannelServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.ProcessService (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.PublishServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.ReplaceContentServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.RoleServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.SceneServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.ServiceConstants
    • com.trs.ajaxservice.SourceServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.StatusServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.SystemServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.ajaxservice.TemplateAuthHelper
    • com.trs.ajaxservice.TemplateEmployMgrHelper
    • com.trs.ajaxservice.TemplateServiceHelperProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.TemplateServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.UserServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.ViewDocumentServiceProvider (implements com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
      • com.trs.ajaxservice.PhotoServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.WatermarkServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.ajaxservice.WCMAJAXServiceHelper
    • com.trs.ajaxservice.WCMApplyFormProcessServiceHelper
    • com.trs.ajaxservice.WCMDocumentHelper
    • com.trs.ajaxservice.WCMProcessServiceHelper
    • com.trs.ajaxservice.WebSiteHelper
    • com.trs.ajaxservice.WebSiteServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.infra.persistent.XmlToObjConverter
      • com.trs.ajaxservice.XmlToRightConvertor


软件包 com.trs.ajaxservice 的使用

上一个 下一个 框架 无框架

软件包 com.trs.ajaxservice
的使用

使用 com.trs.ajaxservice 的软件包
com.trs.ajaxservice

com.trs.ajaxservice 使用的 com.trs.ajaxservice 中的类
ContentExtendValues
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocumentServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageOperatorsForServiceHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 PageOperatorsForServiceHelper

java.lang.Object
    继承者  com.trs.ajaxservice.PageOperatorsForServiceHelper

public class PageOperatorsForServiceHelper
extends java.lang.Object

构造方法摘要
PageOperatorsForServiceHelper()
方法摘要
static PageOperators | makeCMSBaseObjsOpertators(User _loginUser, java.lang.String _sObjectIds, CMSBaseObjs _objects)
static PageOperators | makeCMSObjOpertators(User _loginUser, java.lang.String _sObjectKey, CMSObj channel)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageOperatorsForServiceHelper

public PageOperatorsForServiceHelper()
方法详细信息

makeCMSObjOpertators

public static PageOperators makeCMSObjOpertators(User _loginUser,
                                                 java.lang.String _sObjectKey,
                                                 CMSObj channel)
                                          throws WCMException
参数：
_loginUser -
_channelOrSite -
_nObjectId -
返回：
抛出：
WCMException

makeCMSBaseObjsOpertators

public static PageOperators makeCMSBaseObjsOpertators(User _loginUser,
                                                      java.lang.String _sObjectIds,
                                                      CMSBaseObjs _objects)
                                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PhotoServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 PhotoServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ViewDocumentServiceProvider
        继承者  com.trs.ajaxservice.PhotoServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class PhotoServiceProvider
extends ViewDocumentServiceProvider
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
图片选件服务
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
PhotoServiceProvider()
方法摘要
java.lang.Object | addBorder(MethodContext _context)
java.lang.Object | cropImage(MethodContext _context) 用于裁剪图片
void | delete(MethodContext _context)
java.lang.Object | findById(MethodContext _context)
java.lang.Object | findByIds(MethodContext _context)
java.lang.Object | getDefaultBmpConverType(MethodContext _context)
java.lang.Object | getExtendedProps(MethodContext _context)
java.lang.Object | getOriginalUrls(MethodContext _context)
java.lang.Object | getPublishUrls(MethodContext _context) 得到一组图片的不同比例的发布路径
java.lang.Object | getQuoteDocs(MethodContext _context)
java.lang.Object | getQuoteKinds(MethodContext _context)
java.lang.Object | getSacledImages(MethodContext _context)
java.lang.Object | getSupportedFormat(MethodContext _context)
java.lang.Object | getSysPics(MethodContext _context)
java.lang.Object | importSysPics(MethodContext _context)
java.lang.Object | loadLibConf(MethodContext _context)
java.lang.Object | loadOriginImg(MethodContext _context) 获取原始图片的信息.
java.lang.Object | loadSysPicProps(MethodContext _context)
java.lang.Object | query(MethodContext _context) 获取指定站点或者指定频道下的文档
ViewDocuments | queryRecycle(MethodContext _context) 获取指定站点或者指定频道回收站下的文档
java.lang.Object | raiseImage(MethodContext _context)
java.lang.Object | rotateImage(MethodContext _context)
int | save(MethodContext _context)
void | saveExtif(MethodContext _context) 用于抽取图片Exit信息
java.lang.String | saveImageInfo(MethodContext _context)
void | saveLibConf(MethodContext _context)
java.lang.Object | saveOriginImg(MethodContext _context)
java.lang.Object | scaleImage(MethodContext _context)
从类 com.trs.ajaxservice.ViewDocumentServiceProvider 继承的方法
changeStatus, clearRecycle, cloneFile, copy, editDocuments, export, findChnlDocId, getDocumentRefrences, mirror, move, moveAll, preview, publish, queryAppendixes, queryExtendFields, queryForGroup, queryRelations, quote, replaceContentLink, restore, saveTRSConfig, trsQuery, uploadImg
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PhotoServiceProvider

public PhotoServiceProvider()
方法详细信息

delete

public void delete(MethodContext _context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
覆盖：
类 ViewDocumentServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _context)
                       throws java.lang.Exception
从类 ViewDocumentServiceProvider 复制的描述
获取指定站点或者指定频道下的文档

指定者：
接口 IQueryServiceProvider 中的 query
覆盖：
类 ViewDocumentServiceProvider 中的 query
抛出：
java.lang.Exception

queryRecycle

public ViewDocuments queryRecycle(MethodContext _context)
                           throws java.lang.Exception
从类 ViewDocumentServiceProvider 复制的描述
获取指定站点或者指定频道回收站下的文档

覆盖：
类 ViewDocumentServiceProvider 中的 queryRecycle
返回：
抛出：
WCMException
java.lang.Exception

getPublishUrls

public java.lang.Object getPublishUrls(MethodContext _context)
                                throws java.lang.Exception
得到一组图片的不同比例的发布路径

参数：
_context -
返回：
抛出：
java.lang.Exception

getOriginalUrls

public java.lang.Object getOriginalUrls(MethodContext _context)
                                 throws java.lang.Exception
抛出：
java.lang.Exception

save

public int save(MethodContext _context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

saveImageInfo

public java.lang.String saveImageInfo(MethodContext _context)
                               throws java.lang.Throwable
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
覆盖：
类 ViewDocumentServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getSupportedFormat

public java.lang.Object getSupportedFormat(MethodContext _context)
                                    throws java.lang.Throwable
抛出：
java.lang.Throwable

getSacledImages

public java.lang.Object getSacledImages(MethodContext _context)
                                 throws java.lang.Throwable
抛出：
java.lang.Throwable

loadLibConf

public java.lang.Object loadLibConf(MethodContext _context)
                             throws java.lang.Throwable
抛出：
java.lang.Throwable

saveLibConf

public void saveLibConf(MethodContext _context)
                 throws java.lang.Throwable
抛出：
java.lang.Throwable

getQuoteKinds

public java.lang.Object getQuoteKinds(MethodContext _context)
                               throws java.lang.Throwable
抛出：
java.lang.Throwable

getQuoteDocs

public java.lang.Object getQuoteDocs(MethodContext _context)
                              throws java.lang.Throwable
抛出：
java.lang.Throwable

getExtendedProps

public java.lang.Object getExtendedProps(MethodContext _context)
                                  throws java.lang.Throwable
抛出：
java.lang.Throwable

getDefaultBmpConverType

public java.lang.Object getDefaultBmpConverType(MethodContext _context)
                                         throws java.lang.Throwable
抛出：
java.lang.Throwable

loadOriginImg

public java.lang.Object loadOriginImg(MethodContext _context)
                               throws java.lang.Throwable
获取原始图片的信息.

参数：
_context - 方法上下文参数,需要photoid指定获取那个图片
返回：
返回json对象{fn:'xxx.jpg',width:100,height:200,libid:2,doctitle:'xxx'}
抛出：
java.lang.Throwable

scaleImage

public java.lang.Object scaleImage(MethodContext _context)
                            throws java.lang.Throwable
抛出：
java.lang.Throwable

rotateImage

public java.lang.Object rotateImage(MethodContext _context)
                             throws java.lang.Throwable
抛出：
java.lang.Throwable

addBorder

public java.lang.Object addBorder(MethodContext _context)
                           throws java.lang.Throwable
抛出：
java.lang.Throwable

raiseImage

public java.lang.Object raiseImage(MethodContext _context)
                            throws java.lang.Throwable
抛出：
java.lang.Throwable

saveOriginImg

public java.lang.Object saveOriginImg(MethodContext _context)
                               throws java.lang.Throwable
抛出：
java.lang.Throwable

getSysPics

public java.lang.Object getSysPics(MethodContext _context)
                            throws java.lang.Throwable
抛出：
java.lang.Throwable

importSysPics

public java.lang.Object importSysPics(MethodContext _context)
                               throws java.lang.Throwable
抛出：
java.lang.Throwable

loadSysPicProps

public java.lang.Object loadSysPicProps(MethodContext _context)
                                 throws WCMException
抛出：
WCMException

cropImage

public java.lang.Object cropImage(MethodContext _context)
                           throws java.lang.Throwable
用于裁剪图片

参数：
_context -
返回：
抛出：
java.lang.Throwable

saveExtif

public void saveExtif(MethodContext _context)
               throws java.lang.Throwable
用于抽取图片Exit信息

参数：
_context -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PreviewChannelServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 PreviewChannelServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.PreviewChannelServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class PreviewChannelServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

作者：
wyw

构造方法摘要
PreviewChannelServiceProvider()
方法摘要
 void previewChild(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PreviewChannelServiceProvider

public PreviewChannelServiceProvider()
方法详细信息

previewChild

public void previewChild(MethodContext _methodContext)
                  throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProcessService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ProcessService

java.lang.Object
    继承者  com.trs.ajaxservice.ProcessService
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ProcessService
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ProcessService()
方法摘要
boolean | backTo(MethodContext _methodContext) 要求返工
java.lang.String | createFrom(MethodContext _methodContext) 类似创建工作流，省得为了类似创建工作流时要导入+导出
void | delete(MethodContext _methodContext)
void | disableFlowToChannel(MethodContext _methodContext) 取消给指定栏目启用的工作流
boolean | doAccept(MethodContext _MethodContext)
boolean | doReceive(MethodContext _MethodContext)
void | enableFlowToChannel(MethodContext _methodContext) 给指定栏目启动启用指定的工作流
java.lang.String | exportFlows(MethodContext _methodContext)
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
boolean | forceEnd(MethodContext _methodContext) 强制结束
Reports | fromXML(MethodContext _methodContext) 使用XML的方式保存工作流
java.lang.String | getBranchInfo(MethodContext _methodContext)
Channels | getChannelsUseingFlow(MethodContext _methodContext) 获取使用了指定工作流的栏目列表
java.lang.String | getConfigContent() 获取工作流的配置信息
IFlowContent[] | getContentsInFlow(MethodContext _methodContext) 获取在指定的工作流中流转的内容列表
IFlowContent[] | getContentsOfUser(MethodContext _MethodContext) 获取需要用户处理的内容
java.lang.String | getEmploymentInfo(MethodContext _methContext)
FlowNodeFields | getFieldsInfoOfFlowDoc(MethodContext _methodContext) 获取当前轨迹处理中可读和可写的字段列表
FlowDocs | getFlowDocsOfContent(MethodContext _methodContext) 获取指定文档的流转轨迹
java.lang.String | getFlowOptionAuth(MethodContext _context)
Flow | getFlowUsedByChannel(MethodContext _methodContext) 获取指定栏目正在使用的工作流
FlowNodes | getNextNodes(MethodContext _methodContext) 获取当前节点下一个节点集合
ContentProcessInfo | getProcessInfoOfContent(MethodContext _methodContext) 获取指定内容的流转信息（是否已经结束、发起人）
Reports | importFlows(MethodContext _methodContext)
java.lang.Object | query(MethodContext _methodContext)
java.lang.Object | queryOptionalFlows(MethodContext _methodContext)
boolean | refuse(MethodContext _methodContext) 拒绝请求
void | removeChannelEmployersOfFlow(MethodContext _methodContext) 批量取消工作流的配置情况
void | reSubmitTo(MethodContext _methodContext) 重新处理
int | save(MethodContext _methodContext)
void | setChannelEmployersOfFlow(MethodContext _methodContext) 批量维护工作流的配置情况
void | startDocumentInFlow(MethodContext _methodContext) 让文档开始流转
void | submitTo(MethodContext _methodContext) 将需要处理的内容交给下一个环节处理
java.lang.String | toXML(MethodContext _methodContext) 将指定的工作流导出成XML
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ProcessService

public ProcessService()
方法详细信息

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methodContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

queryOptionalFlows

public java.lang.Object queryOptionalFlows(MethodContext _methodContext)
                                    throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

importFlows

public Reports importFlows(MethodContext _methodContext)
                    throws WCMException
抛出：
WCMException

exportFlows

public java.lang.String exportFlows(MethodContext _methodContext)
                             throws java.lang.Throwable
抛出：
java.lang.Throwable

getConfigContent

public java.lang.String getConfigContent()
                                  throws java.lang.Throwable
获取工作流的配置信息

返回：
抛出：
java.lang.Throwable

toXML

public java.lang.String toXML(MethodContext _methodContext)
                       throws java.lang.Throwable
将指定的工作流导出成XML

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

fromXML

public Reports fromXML(MethodContext _methodContext)
                throws java.lang.Throwable
使用XML的方式保存工作流

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

getFlowUsedByChannel

public Flow getFlowUsedByChannel(MethodContext _methodContext)
                          throws WCMException
获取指定栏目正在使用的工作流

参数：
_methodContext -
返回：
抛出：
WCMException

getChannelsUseingFlow

public Channels getChannelsUseingFlow(MethodContext _methodContext)
                               throws WCMException
获取使用了指定工作流的栏目列表

参数：
_methodContext -
返回：
抛出：
WCMException

getProcessInfoOfContent

public ContentProcessInfo getProcessInfoOfContent(MethodContext _methodContext)
                                           throws WCMException
获取指定内容的流转信息（是否已经结束、发起人）

参数：
_methodContext -
返回：
抛出：
WCMException

enableFlowToChannel

public void enableFlowToChannel(MethodContext _methodContext)
                         throws WCMException
给指定栏目启动启用指定的工作流

参数：
_methodContext -
抛出：
WCMException

disableFlowToChannel

public void disableFlowToChannel(MethodContext _methodContext)
                          throws WCMException
取消给指定栏目启用的工作流

参数：
_methodContext -
抛出：
WCMException

setChannelEmployersOfFlow

public void setChannelEmployersOfFlow(MethodContext _methodContext)
                               throws WCMException
批量维护工作流的配置情况

参数：
_methodContext -
抛出：
WCMException

removeChannelEmployersOfFlow

public void removeChannelEmployersOfFlow(MethodContext _methodContext)
                                  throws WCMException
批量取消工作流的配置情况

参数：
_methodContext -
抛出：
WCMException

getContentsInFlow

public IFlowContent[] getContentsInFlow(MethodContext _methodContext)
                                 throws WCMException
获取在指定的工作流中流转的内容列表

参数：
_methodContext -
返回：
抛出：
WCMException

getContentsOfUser

public IFlowContent[] getContentsOfUser(MethodContext _MethodContext)
                                 throws WCMException
获取需要用户处理的内容

返回：
抛出：
WCMException

getFlowDocsOfContent

public FlowDocs getFlowDocsOfContent(MethodContext _methodContext)
                              throws java.lang.Throwable
获取指定文档的流转轨迹

参数：
_methodContext -
抛出：
java.lang.Throwable

doReceive

public boolean doReceive(MethodContext _MethodContext)
                  throws WCMException
参数：
_MethodContext -
返回：
抛出：
WCMException

backTo

public boolean backTo(MethodContext _methodContext)
               throws java.lang.Throwable
要求返工

参数：
_methodContext -
抛出：
java.lang.Throwable

refuse

public boolean refuse(MethodContext _methodContext)
               throws java.lang.Throwable
拒绝请求

参数：
_methodContext -
抛出：
java.lang.Throwable

forceEnd

public boolean forceEnd(MethodContext _methodContext)
                 throws java.lang.Throwable
强制结束

参数：
_methodContext -
抛出：
java.lang.Throwable

submitTo

public void submitTo(MethodContext _methodContext)
              throws java.lang.Throwable
将需要处理的内容交给下一个环节处理

参数：
_methodContext -
抛出：
java.lang.Throwable

reSubmitTo

public void reSubmitTo(MethodContext _methodContext)
                throws java.lang.Throwable
重新处理

参数：
_methodContext -
抛出：
java.lang.Throwable

getNextNodes

public FlowNodes getNextNodes(MethodContext _methodContext)
                       throws java.lang.Throwable
获取当前节点下一个节点集合

参数：
_methodContext -
抛出：
java.lang.Throwable

doAccept

public boolean doAccept(MethodContext _MethodContext)
                 throws WCMException
参数：
_MethodContext -
返回：
抛出：
WCMException

getBranchInfo

public java.lang.String getBranchInfo(MethodContext _methodContext)
                               throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

getFieldsInfoOfFlowDoc

public FlowNodeFields getFieldsInfoOfFlowDoc(MethodContext _methodContext)
                                      throws java.lang.Throwable
获取当前轨迹处理中可读和可写的字段列表

参数：
_methodContext -
抛出：
java.lang.Throwable

getEmploymentInfo

public java.lang.String getEmploymentInfo(MethodContext _methContext)
                                   throws java.lang.Throwable
抛出：
java.lang.Throwable

getFlowOptionAuth

public java.lang.String getFlowOptionAuth(MethodContext _context)
                                   throws WCMException
抛出：
WCMException

startDocumentInFlow

public void startDocumentInFlow(MethodContext _methodContext)
                         throws java.lang.Throwable
让文档开始流转

参数：
_methodContext -
抛出：
java.lang.Throwable

createFrom

public java.lang.String createFrom(MethodContext _methodContext)
                            throws java.lang.Throwable
类似创建工作流，省得为了类似创建工作流时要导入+导出

参数：
_methodContext -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 PublishServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.PublishServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class PublishServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
发布服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishServiceProvider()
方法摘要
java.lang.Object | getPublishConfig(MethodContext _methodContext) 获取指定对象的发布信息,传入的参数： ObjectType ObjectId
java.lang.Object | getUnpubSchedule(MethodContext context)
java.lang.String | preview(MethodContext _methodContext)
void | publish(MethodContext _methodContext) 发布指定的对象
void | publishContents(MethodContext _methodContext) 在指定的栏目中发布指定的文档
boolean | savePublishConfig(MethodContext _methodContext)
void | setUnpubSchedule(MethodContext context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishServiceProvider

public PublishServiceProvider()
方法详细信息

getPublishConfig

public java.lang.Object getPublishConfig(MethodContext _methodContext)
                                  throws java.lang.Throwable
获取指定对象的发布信息,传入的参数： ObjectType ObjectId

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

savePublishConfig

public boolean savePublishConfig(MethodContext _methodContext)
                          throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

publish

public void publish(MethodContext _methodContext)
             throws java.lang.Throwable
发布指定的对象

参数：
_methodContext -
抛出：
java.lang.Throwable

preview

public java.lang.String preview(MethodContext _methodContext)
                         throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

publishContents

public void publishContents(MethodContext _methodContext)
                     throws java.lang.Throwable
在指定的栏目中发布指定的文档

参数：
_methodContext -
抛出：
java.lang.Throwable

getUnpubSchedule

public java.lang.Object getUnpubSchedule(MethodContext context)
                                  throws WCMException
抛出：
WCMException

setUnpubSchedule

public void setUnpubSchedule(MethodContext context)
                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReplaceContentServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ReplaceContentServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ReplaceContentServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ReplaceContentServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
替换内容管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ReplaceContentServiceProvider()
方法摘要
void | delete(MethodContext _methodContext)
boolean | existsSimilarName(MethodContext _methodContext) 是否存在相同名称的栏目
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
java.lang.Object | query(MethodContext _methodContext)
int | save(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ReplaceContentServiceProvider

public ReplaceContentServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methodContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

existsSimilarName

public boolean existsSimilarName(MethodContext _methodContext)
                          throws java.lang.Throwable
是否存在相同名称的栏目

参数：
_methodContext -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 RoleServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.RoleServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class RoleServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

作者：
hdg

构造方法摘要
RoleServiceProvider()
方法摘要
void | delete(MethodContext context)
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
Roles | getRolesForCurrUser(MethodContext context) 获取当前登录用户可以查看的所有角色信息
java.util.Map | getSiteRoleUsersInfo(MethodContext _context) 获取指定用户的站点角色用户信息，map格式为：
Roles | getSpecialRolesOfUser(MethodContext context) 获取指定用户的特定角色
Roles | getSystemRolesOfUser(MethodContext context) 获取指定用户在指定站点上的系统级角色
java.lang.Object | query(MethodContext context)
void | removeUsersFromCurrRole(MethodContext context) 在指定角色中删除指定用户，兼容系统级和特定角色
int | save(MethodContext context)
void | saveRoles(MethodContext _methodContext) 已过时。
void | saveRoleUsers(MethodContext context) 绑定角色,站点和用户的关联，同时将清除原来的关联,兼容系统级和非系统级
void | saveSpecialRolesOfUser(MethodContext context) 保存指定用户的特定角色
void | saveSystemRolesOfUser(MethodContext context) 保存指定用户在指定站点上的系统级角色
void | saveUsersOfSpecialRole(MethodContext context) 将用户添加到特定的角色上，同时将清除原来的关联
void | saveUsersOfSystemRoleOnSite(MethodContext context) 将用户添加到指定站点的系统级角色上，同时将清除原来的关联
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleServiceProvider

public RoleServiceProvider()
方法详细信息

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

saveRoles

public void saveRoles(MethodContext _methodContext)
               throws java.lang.Throwable
已过时。

保存用户新建和修改用户后的用户所属角色信息

参数：
_methodContext -
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

getRolesForCurrUser

public Roles getRolesForCurrUser(MethodContext context)
                          throws java.lang.Throwable
获取当前登录用户可以查看的所有角色信息

参数：
context -
返回：
抛出：
java.lang.Throwable

getSiteRoleUsersInfo

public java.util.Map getSiteRoleUsersInfo(MethodContext _context)
                                   throws WCMException
获取指定用户的站点角色用户信息，map格式为：

参数：
_context -
返回：
抛出：
WCMException

saveRoleUsers

public void saveRoleUsers(MethodContext context)
                   throws java.lang.Throwable
绑定角色,站点和用户的关联，同时将清除原来的关联,兼容系统级和非系统级

抛出：
java.lang.Throwable

saveUsersOfSystemRoleOnSite

public void saveUsersOfSystemRoleOnSite(MethodContext context)
                                 throws java.lang.Throwable
将用户添加到指定站点的系统级角色上，同时将清除原来的关联

参数：
context -
抛出：
java.lang.Throwable

saveUsersOfSpecialRole

public void saveUsersOfSpecialRole(MethodContext context)
                            throws java.lang.Throwable
将用户添加到特定的角色上，同时将清除原来的关联

参数：
context -
抛出：
java.lang.Throwable

removeUsersFromCurrRole

public void removeUsersFromCurrRole(MethodContext context)
                             throws java.lang.Throwable
在指定角色中删除指定用户，兼容系统级和特定角色

参数：
context -
抛出：
java.lang.Throwable

getSystemRolesOfUser

public Roles getSystemRolesOfUser(MethodContext context)
                           throws java.lang.Throwable
获取指定用户在指定站点上的系统级角色

参数：
context -
返回：
抛出：
java.lang.Throwable

saveSystemRolesOfUser

public void saveSystemRolesOfUser(MethodContext context)
                           throws java.lang.Throwable
保存指定用户在指定站点上的系统级角色

参数：
context -
抛出：
java.lang.Throwable

getSpecialRolesOfUser

public Roles getSpecialRolesOfUser(MethodContext context)
                            throws java.lang.Throwable
获取指定用户的特定角色

参数：
context -
返回：
抛出：
java.lang.Throwable

saveSpecialRolesOfUser

public void saveSpecialRolesOfUser(MethodContext context)
                            throws java.lang.Throwable
保存指定用户的特定角色

参数：
context -
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SceneServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 SceneServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.SceneServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class SceneServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

作者：
Administrator

构造方法摘要
SceneServiceProvider()
方法摘要
 Documents cloneFromOtherFlow(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SceneServiceProvider

public SceneServiceProvider()
方法详细信息

cloneFromOtherFlow

public Documents cloneFromOtherFlow(MethodContext _methodContext)
                             throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ServiceConstants

java.lang.Object
    继承者  com.trs.ajaxservice.ServiceConstants

public class ServiceConstants
extends java.lang.Object

字段摘要
static int | FILTER_TYPE_1MONTH
static int | FILTER_TYPE_1WEEK
static int | FILTER_TYPE_3DAYS
static int | FILTER_TYPE_ALL
static int | FILTER_TYPE_DETAIL_TEMPLATE
static int | FILTER_TYPE_EDITEDDOCUMENTS
static int | FILTER_TYPE_NESTED_TEMPLATE
static int | FILTER_TYPE_NEWDOCUMENTS
static int | FILTER_TYPE_NODOCUMENTS
static int | FILTER_TYPE_OUTLINE_TEMPLATE
static int | FILTER_TYPE_PUBLISHDOCUMENTS
static int | FILTER_TYPE_PUBLISHEDDOCUMENTS
static int | FILTER_TYPE_SELF
static int | FILTER_TYPE_UNUSE_TEMPLATE
static int | FILTER_TYPE_USEING_TEMPLATE
static java.lang.String[][] | FILTERS_DOCUMENTS_DEFAULT
构造方法摘要
ServiceConstants()
方法摘要
static CMyDateTime makeDateTime(int _nFilterType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FILTER_TYPE_ALL

public static final int FILTER_TYPE_ALL
另请参见：
常量字段值

FILTER_TYPE_NEWDOCUMENTS

public static final int FILTER_TYPE_NEWDOCUMENTS
另请参见：
常量字段值

FILTER_TYPE_PUBLISHDOCUMENTS

public static final int FILTER_TYPE_PUBLISHDOCUMENTS
另请参见：
常量字段值

FILTER_TYPE_PUBLISHEDDOCUMENTS

public static final int FILTER_TYPE_PUBLISHEDDOCUMENTS
另请参见：
常量字段值

FILTER_TYPE_SELF

public static final int FILTER_TYPE_SELF
另请参见：
常量字段值

FILTER_TYPE_3DAYS

public static final int FILTER_TYPE_3DAYS
另请参见：
常量字段值

FILTER_TYPE_1WEEK

public static final int FILTER_TYPE_1WEEK
另请参见：
常量字段值

FILTER_TYPE_1MONTH

public static final int FILTER_TYPE_1MONTH
另请参见：
常量字段值

FILTER_TYPE_NODOCUMENTS

public static final int FILTER_TYPE_NODOCUMENTS
另请参见：
常量字段值

FILTER_TYPE_EDITEDDOCUMENTS

public static final int FILTER_TYPE_EDITEDDOCUMENTS
另请参见：
常量字段值

FILTER_TYPE_NESTED_TEMPLATE

public static final int FILTER_TYPE_NESTED_TEMPLATE
另请参见：
常量字段值

FILTER_TYPE_OUTLINE_TEMPLATE

public static final int FILTER_TYPE_OUTLINE_TEMPLATE
另请参见：
常量字段值

FILTER_TYPE_DETAIL_TEMPLATE

public static final int FILTER_TYPE_DETAIL_TEMPLATE
另请参见：
常量字段值

FILTER_TYPE_USEING_TEMPLATE

public static final int FILTER_TYPE_USEING_TEMPLATE
另请参见：
常量字段值

FILTER_TYPE_UNUSE_TEMPLATE

public static final int FILTER_TYPE_UNUSE_TEMPLATE
另请参见：
常量字段值

FILTERS_DOCUMENTS_DEFAULT

public static final java.lang.String[][] FILTERS_DOCUMENTS_DEFAULT
构造方法详细信息

ServiceConstants

public ServiceConstants()
方法详细信息

makeDateTime

public static CMyDateTime makeDateTime(int _nFilterType)
                                throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SourceServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 SourceServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.SourceServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class SourceServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

构造方法摘要
SourceServiceProvider()
方法摘要
void | delete(MethodContext _methContext)
java.lang.Object | findById(MethodContext _methContext)
java.lang.Object | findByIds(MethodContext _methContext)
PageOperators | getOperators(MethodContext _methContext) 获取针对指定的单个或者多个来源的操作集合
java.lang.Object | query(MethodContext _methContext)
int | save(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SourceServiceProvider

public SourceServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getOperators

public PageOperators getOperators(MethodContext _methContext)
                           throws java.lang.Throwable
获取针对指定的单个或者多个来源的操作集合

参数：
_methContext -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatusServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 StatusServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.StatusServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class StatusServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

构造方法摘要
StatusServiceProvider()
方法摘要
void | delete(MethodContext _context)
java.lang.Object | findById(MethodContext _context)
java.lang.Object | findByIds(MethodContext _context)
PageOperators | getOperators(MethodContext _methContext) 获取针对指定的单个或者多个状态的操作集合
java.lang.Object | query(MethodContext _methContext)
Statuses | queryDocumentStatuses(MethodContext _methContext) 获取当前用户在指定频道下可以改变状态
int | save(MethodContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatusServiceProvider

public StatusServiceProvider()
方法详细信息

delete

public void delete(MethodContext _context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getOperators

public PageOperators getOperators(MethodContext _methContext)
                           throws java.lang.Throwable
获取针对指定的单个或者多个状态的操作集合

参数：
_methContext -
返回：
抛出：
java.lang.Throwable

queryDocumentStatuses

public Statuses queryDocumentStatuses(MethodContext _methContext)
                               throws java.lang.Throwable
获取当前用户在指定频道下可以改变状态

参数：
_methContext -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SystemServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 SystemServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.SystemServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class SystemServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
系统服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String[][] SITE_TYPES
构造方法摘要
SystemServiceProvider()
方法摘要
java.lang.String | findNodesByPath(MethodContext _methodContext) 根据用户输入的路径获取节点列表，路径以\分隔
static java.lang.String | getSiteTypeDesc(java.lang.String _sTypeId)
boolean | isValidChannelId(MethodContext _oMethodContext) 判断指定的栏目Id是否有效
boolean | isValidSiteId(MethodContext _oMethodContext) 判断指定的站点Id是否有效
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SITE_TYPES

public static java.lang.String[][] SITE_TYPES
构造方法详细信息

SystemServiceProvider

public SystemServiceProvider()
方法详细信息

findNodesByPath

public java.lang.String findNodesByPath(MethodContext _methodContext)
                                 throws java.lang.Throwable
根据用户输入的路径获取节点列表，路径以\分隔

参数：
_methodContext -
抛出：
java.lang.Throwable

isValidChannelId

public boolean isValidChannelId(MethodContext _oMethodContext)
                         throws WCMException
判断指定的栏目Id是否有效

参数：
_oMethodContext -
返回：
抛出：
WCMException

isValidSiteId

public boolean isValidSiteId(MethodContext _oMethodContext)
                      throws WCMException
判断指定的站点Id是否有效

参数：
_oMethodContext -
返回：
抛出：
WCMException

getSiteTypeDesc

public static java.lang.String getSiteTypeDesc(java.lang.String _sTypeId)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateAuthHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 TemplateAuthHelper

java.lang.Object
    继承者  com.trs.ajaxservice.TemplateAuthHelper

public class TemplateAuthHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
模板权限解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateAuthHelper()
方法摘要
static RightValue | makeHostRightValue(MethodContext _context, User _loginUser, IPublishFolder _host)
static RightValue | makeTemplateRightValue(MethodContext _context, User _loginUser, Template _template, IPublishFolder _host)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateAuthHelper

public TemplateAuthHelper()
方法详细信息

makeHostRightValue

public static RightValue makeHostRightValue(MethodContext _context,
                                            User _loginUser,
                                            IPublishFolder _host)
                                     throws WCMException
参数：
_context -
_loginUser -
_host -
抛出：
WCMException

makeTemplateRightValue

public static RightValue makeTemplateRightValue(MethodContext _context,
                                                User _loginUser,
                                                Template _template,
                                                IPublishFolder _host)
                                         throws WCMException
参数：
_context -
_loginUser -
_template -
_host -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmployMgrHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 TemplateEmployMgrHelper

java.lang.Object
    继承者  com.trs.ajaxservice.TemplateEmployMgrHelper

public class TemplateEmployMgrHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

构造方法摘要
TemplateEmployMgrHelper()
方法摘要
static int | clearEmploymentOfEmployer(IPublishElement _employer, Template _template)
static void | setOtherOutlinesOfChannels(MethodContext _context, Template _template)
static void | setOtherOutlinesOfSite(IPublishElement siteFolder, Template template)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateEmployMgrHelper

public TemplateEmployMgrHelper()
方法详细信息

setOtherOutlinesOfChannels

public static void setOtherOutlinesOfChannels(MethodContext _context,
                                              Template _template)
                                       throws WCMException
抛出：
WCMException

clearEmploymentOfEmployer

public static int clearEmploymentOfEmployer(IPublishElement _employer,
                                            Template _template)
                                     throws WCMException
抛出：
WCMException

setOtherOutlinesOfSite

public static void setOtherOutlinesOfSite(IPublishElement siteFolder,
                                          Template template)
                                   throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateServiceHelperProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 TemplateServiceHelperProvider

java.lang.Object
    继承者  com.trs.ajaxservice.TemplateServiceHelperProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class TemplateServiceHelperProvider
extends java.lang.Object
implements IGlueServiceProvider

构造方法摘要
TemplateServiceHelperProvider()
方法摘要
void | delete(MethodContext context)
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.lang.Object | query(MethodContext context)
int | save(MethodContext context)
void | setChannelEmployersOfTemplate(MethodContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateServiceHelperProvider

public TemplateServiceHelperProvider()
方法详细信息

setChannelEmployersOfTemplate

public void setChannelEmployersOfTemplate(MethodContext _context)
                                   throws java.lang.Throwable
抛出：
java.lang.Throwable

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 TemplateServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.TemplateServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class TemplateServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
模板类相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateServiceProvider()
方法摘要
void | cancelArgVal(MethodContext _context)
java.lang.String | check(MethodContext _methodContext) 校验选中的模板
java.lang.String | checkTemplateText(MethodContext _methodContext) 校验指定的模板内容
java.lang.String | checkWCAG2TemplateText(MethodContext _methodContext)
void | delete(MethodContext _methContext)
boolean | existsSimilarName(MethodContext _methodContext) 是否存在相同名称的模板
java.lang.String | export(MethodContext _methodContext) 导出指定的栏目或者站点下的模板
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methContext)
PageOperators | getOperators(MethodContext _methContext) 获取针对指定的单个或者多个模板的操作集合
Templates | getOptionalTemplates(MethodContext _MethodContext) 获取指定的对象可选择的模板
void | impartTemplateConfig(MethodContext _methodContext) 传递当前对象(站点/栏目)的模板配置到子对象上
java.lang.String | importTemplates(MethodContext _methodContext) 导入文档
java.lang.Object | query(MethodContext _methContext)
java.lang.String | queryArgs(MethodContext _methodContext) queryArgs
TemplateEmploys | queryEmployers(MethodContext _methodContext) 获取使用指定模板的对象
Templates | queryNestedTemplates(MethodContext _methodContext) 获取使用指定模板使用了那些嵌套模板
Templates | queryTemplatesNested(MethodContext _methodContext) 获取使用指定嵌套模板的模板
java.lang.String | redistributeAppendixes(MethodContext _methodContext) 重新分发模板的附件
int | save(MethodContext _methodContext)
int | saveArgument(MethodContext _methodContext) 保存用户在当前站点或者栏目设置的变量
void | setDefaultTemplate(MethodContext _methodContext)
void | setOtherOutlineTemplates(MethodContext _methodContext)
void | synTemplates(MethodContext _methodContext) 传递当前对象(站点/栏目)的模板配置到子对象上
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateServiceProvider

public TemplateServiceProvider()
方法详细信息

existsSimilarName

public boolean existsSimilarName(MethodContext _methodContext)
                          throws java.lang.Throwable
是否存在相同名称的模板

参数：
_methodContext -
抛出：
java.lang.Throwable

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getOptionalTemplates

public Templates getOptionalTemplates(MethodContext _MethodContext)
                               throws java.lang.Throwable
获取指定的对象可选择的模板

参数：
_MethodContext -
返回：
抛出：
java.lang.Throwable

getOperators

public PageOperators getOperators(MethodContext _methContext)
                           throws java.lang.Throwable
获取针对指定的单个或者多个模板的操作集合

参数：
_methContext -
返回：
抛出：
java.lang.Throwable

impartTemplateConfig

public void impartTemplateConfig(MethodContext _methodContext)
                          throws java.lang.Throwable
传递当前对象(站点/栏目)的模板配置到子对象上

参数：
_methodContext -
抛出：
java.lang.Throwable

synTemplates

public void synTemplates(MethodContext _methodContext)
                  throws java.lang.Throwable
传递当前对象(站点/栏目)的模板配置到子对象上

参数：
_methodContext -
抛出：
java.lang.Throwable

queryEmployers

public TemplateEmploys queryEmployers(MethodContext _methodContext)
                               throws java.lang.Throwable
获取使用指定模板的对象

参数：
_methodContext -
抛出：
java.lang.Throwable

queryTemplatesNested

public Templates queryTemplatesNested(MethodContext _methodContext)
                               throws java.lang.Throwable
获取使用指定嵌套模板的模板

参数：
_methodContext -
抛出：
java.lang.Throwable

queryNestedTemplates

public Templates queryNestedTemplates(MethodContext _methodContext)
                               throws java.lang.Throwable
获取使用指定模板使用了那些嵌套模板

参数：
_methodContext -
抛出：
java.lang.Throwable

export

public java.lang.String export(MethodContext _methodContext)
                        throws java.lang.Throwable
导出指定的栏目或者站点下的模板

参数：
_methodContext -
抛出：
java.lang.Throwable

importTemplates

public java.lang.String importTemplates(MethodContext _methodContext)
                                 throws java.lang.Throwable
导入文档

参数：
_methodContext -
抛出：
java.lang.Throwable

check

public java.lang.String check(MethodContext _methodContext)
                       throws java.lang.Throwable
校验选中的模板

参数：
_methodContext -
抛出：
java.lang.Throwable

checkTemplateText

public java.lang.String checkTemplateText(MethodContext _methodContext)
                                   throws java.lang.Throwable
校验指定的模板内容

参数：
_methodContext -
抛出：
java.lang.Throwable

checkWCAG2TemplateText

public java.lang.String checkWCAG2TemplateText(MethodContext _methodContext)
                                        throws java.lang.Throwable
抛出：
java.lang.Throwable

redistributeAppendixes

public java.lang.String redistributeAppendixes(MethodContext _methodContext)
                                        throws java.lang.Throwable
重新分发模板的附件

参数：
_methodContext -
抛出：
java.lang.Throwable

queryArgs

public java.lang.String queryArgs(MethodContext _methodContext)
                           throws java.lang.Throwable
queryArgs

参数：
_methodContext -
抛出：
java.lang.Throwable

saveArgument

public int saveArgument(MethodContext _methodContext)
                 throws java.lang.Throwable
保存用户在当前站点或者栏目设置的变量

参数：
_methodContext -
抛出：
java.lang.Throwable

cancelArgVal

public void cancelArgVal(MethodContext _context)
                  throws java.lang.Throwable
抛出：
java.lang.Throwable

setDefaultTemplate

public void setDefaultTemplate(MethodContext _methodContext)
                        throws java.lang.Throwable
参数：
_methodContext -
抛出：
java.lang.Throwable

setOtherOutlineTemplates

public void setOtherOutlineTemplates(MethodContext _methodContext)
                              throws java.lang.Throwable
参数：
_methodContext -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 UserServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.UserServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class UserServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
用户相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
UserServiceProvider()
方法摘要
void | delete(MethodContext _methodContext)
java.lang.Object | findById(MethodContext _methodContext)
java.lang.Object | findByIds(MethodContext _methodContext)
Users | getOnlineUsers() 获取系统在线用户
Users | getUsersByNames(MethodContext _context)
Users | getUsersOfGroup(MethodContext _context) 获取指定组织下的用户集合,适用于角色的添加用户页面
Users | getUsersOfRole(MethodContext _context) 获取指定角色和站点下的用户集合,兼容系统级角色和非系统级角色
Users | getUsersOfSpecialRole(MethodContext _context) 获取指定特定角色下的用户集合
Users | getUsersOfSystemRoleOnSite(MethodContext _context) 获取指定系统级角色和站点下的用户集合
java.lang.Object | query(MethodContext _methodContext)
int | save(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserServiceProvider

public UserServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methodContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methodContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getOnlineUsers

public Users getOnlineUsers()
                     throws java.lang.Throwable
获取系统在线用户

参数：
_methodContext -
抛出：
java.lang.Throwable

getUsersByNames

public Users getUsersByNames(MethodContext _context)
                      throws WCMException
抛出：
WCMException

getUsersOfRole

public Users getUsersOfRole(MethodContext _context)
                     throws WCMException
获取指定角色和站点下的用户集合,兼容系统级角色和非系统级角色

参数：
_context -
返回：
抛出：
WCMException

getUsersOfSystemRoleOnSite

public Users getUsersOfSystemRoleOnSite(MethodContext _context)
                                 throws WCMException
获取指定系统级角色和站点下的用户集合

参数：
_context -
返回：
抛出：
WCMException

getUsersOfSpecialRole

public Users getUsersOfSpecialRole(MethodContext _context)
                            throws WCMException
获取指定特定角色下的用户集合

参数：
_context -
返回：
抛出：
WCMException

getUsersOfGroup

public Users getUsersOfGroup(MethodContext _context)
                      throws WCMException
获取指定组织下的用户集合,适用于角色的添加用户页面

参数：
_context -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewDocumentServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 ViewDocumentServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.ViewDocumentServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IQueryServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
直接已知子类：
PhotoServiceProvider
public class ViewDocumentServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider, IDeleteServiceProvider, IQueryServiceProvider, IFindByIdServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ViewDocumentServiceProvider()
方法摘要
void | changeStatus(MethodContext _methodContext) 改变多篇文档的状态
void | clearRecycle(MethodContext _methodContext) 清空回收站所有的文档
java.lang.String | cloneFile(MethodContext _methodContext)
Reports | copy(MethodContext _methodContext) 拷贝文档
void | delete(MethodContext _methContext)
void | editDocuments(MethodContext _methContext) 批量修改文档属性
java.lang.String | export(MethodContext _methodContext) 导出指定的文档
java.lang.Object | findById(MethodContext _methodContext)
int | findChnlDocId(MethodContext _methodContext) 根据docid，channelid获取chnldocid
java.lang.String | getDocumentRefrences(MethodContext _methContext)
Reports | mirror(MethodContext _methodContext) 镜像文档
Reports | move(MethodContext _methodContext) 移动文档
Reports | moveAll(MethodContext _methodContext) 移动全部文档
java.lang.String | preview(MethodContext _methodContext)
Reports | publish(MethodContext _methodContext)
java.lang.Object | query(MethodContext _methContext) 获取指定站点或者指定频道下的文档
Appendixes | queryAppendixes(MethodContext _methodContext) 获取指定文档指定类型的附件
ContentExtendValues | queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息
java.lang.Object | queryForGroup(MethodContext _methContext)
ViewDocuments | queryRecycle(MethodContext _methContext) 获取指定站点或者指定频道回收站下的文档
Relations | queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档
Reports | quote(MethodContext _methodContext) 引用文档
Reports | replaceContentLink(MethodContext _methContext)
void | restore(MethodContext _methodContext) 恢复回收站中的文档
void | saveTRSConfig(MethodContext _methContext)
java.lang.Object | trsQuery(MethodContext _methContext)
java.lang.String | uploadImg(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ViewDocumentServiceProvider

public ViewDocumentServiceProvider()
方法详细信息

changeStatus

public void changeStatus(MethodContext _methodContext)
                  throws java.lang.Throwable
改变多篇文档的状态

参数：
_methodContext -
抛出：
java.lang.Throwable

copy

public Reports copy(MethodContext _methodContext)
             throws java.lang.Throwable
拷贝文档

参数：
_methodContext -
抛出：
java.lang.Throwable

quote

public Reports quote(MethodContext _methodContext)
              throws java.lang.Throwable
引用文档

参数：
_methodContext -
抛出：
java.lang.Throwable

mirror

public Reports mirror(MethodContext _methodContext)
               throws java.lang.Throwable
镜像文档

参数：
_methodContext -
抛出：
java.lang.Throwable

move

public Reports move(MethodContext _methodContext)
             throws java.lang.Throwable
移动文档

参数：
_methodContext -
抛出：
java.lang.Throwable

replaceContentLink

public Reports replaceContentLink(MethodContext _methContext)
                           throws java.lang.Throwable
抛出：
java.lang.Throwable

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

export

public java.lang.String export(MethodContext _methodContext)
                        throws java.lang.Throwable
导出指定的文档

参数：
_methodContext -
抛出：
java.lang.Throwable

publish

public Reports publish(MethodContext _methodContext)
                throws java.lang.Throwable
参数：
_methodContext -
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Exception
获取指定站点或者指定频道下的文档

指定者：
接口 IQueryServiceProvider 中的 query
参数：
_methContext -
返回：
抛出：
WCMException
java.lang.Exception

queryRelations

public Relations queryRelations(MethodContext _methodContext)
                         throws java.lang.Throwable
获取指定文档手工设定的相关文档

参数：
_methodContext -
抛出：
java.lang.Throwable

queryAppendixes

public Appendixes queryAppendixes(MethodContext _methodContext)
                           throws java.lang.Throwable
获取指定文档指定类型的附件

参数：
_methodContext -
抛出：
java.lang.Throwable

queryExtendFields

public ContentExtendValues queryExtendFields(MethodContext _methodContext)
                                      throws java.lang.Throwable
获取文档的扩展字段信息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryRecycle

public ViewDocuments queryRecycle(MethodContext _methContext)
                           throws java.lang.Exception
获取指定站点或者指定频道回收站下的文档

参数：
_methContext -
返回：
抛出：
WCMException
java.lang.Exception

preview

public java.lang.String preview(MethodContext _methodContext)
                         throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

restore

public void restore(MethodContext _methodContext)
             throws java.lang.Throwable
恢复回收站中的文档

参数：
_methodContext -
抛出：
java.lang.Throwable

clearRecycle

public void clearRecycle(MethodContext _methodContext)
                  throws java.lang.Throwable
清空回收站所有的文档

参数：
_methodContext -
抛出：
java.lang.Throwable

getDocumentRefrences

public java.lang.String getDocumentRefrences(MethodContext _methContext)
                                      throws java.lang.Exception
抛出：
java.lang.Exception

findChnlDocId

public int findChnlDocId(MethodContext _methodContext)
                  throws java.lang.Throwable
根据docid，channelid获取chnldocid

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

moveAll

public Reports moveAll(MethodContext _methodContext)
                throws java.lang.Throwable
移动全部文档

参数：
_methodContext -
抛出：
java.lang.Throwable

cloneFile

public java.lang.String cloneFile(MethodContext _methodContext)
                           throws java.lang.Throwable
抛出：
java.lang.Throwable

uploadImg

public java.lang.String uploadImg(MethodContext _methodContext)
                           throws java.lang.Throwable
抛出：
java.lang.Throwable

trsQuery

public java.lang.Object trsQuery(MethodContext _methContext)
                          throws java.lang.Exception
抛出：
java.lang.Exception

saveTRSConfig

public void saveTRSConfig(MethodContext _methContext)
                   throws java.lang.Exception
抛出：
java.lang.Exception

queryForGroup

public java.lang.Object queryForGroup(MethodContext _methContext)
                               throws java.lang.Exception
抛出：
java.lang.Exception

editDocuments

public void editDocuments(MethodContext _methContext)
                   throws java.lang.Exception
批量修改文档属性

参数：
_methContext -
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WatermarkServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 WatermarkServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.WatermarkServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class WatermarkServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
图片库水印服务提供者
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
WatermarkServiceProvider()
方法摘要
void | delete(MethodContext _context)
java.lang.Object | findById(MethodContext _context)
java.lang.Object | findByIds(MethodContext _context)
java.lang.Object | query(MethodContext _context)
int | save(MethodContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WatermarkServiceProvider

public WatermarkServiceProvider()
方法详细信息

delete

public void delete(MethodContext _context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMAJAXServiceHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 WCMAJAXServiceHelper

java.lang.Object
    继承者  com.trs.ajaxservice.WCMAJAXServiceHelper

public class WCMAJAXServiceHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
WCM AJAX服务器端工具类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMAJAXServiceHelper()
方法摘要
static CMSObj | setWCMObjectProperties(User _loginUser, MethodContext _methodContext, CMSObj _oCMSObj, java.lang.String[] _pLogicFields) 更新指定的对象
static void | validateFile(java.lang.String _sImportFile)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMAJAXServiceHelper

public WCMAJAXServiceHelper()
方法详细信息

setWCMObjectProperties

public static CMSObj setWCMObjectProperties(User _loginUser,
                                            MethodContext _methodContext,
                                            CMSObj _oCMSObj,
                                            java.lang.String[] _pLogicFields)
                                     throws WCMException
更新指定的对象

参数：
_loginUser -
_methodContext -
_oCMSObj -
_pLogicFields -
返回：
抛出：
WCMException

validateFile

public static void validateFile(java.lang.String _sImportFile)
                         throws WCMException
参数：
_sImportFile -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMApplyFormProcessServiceHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 WCMApplyFormProcessServiceHelper

java.lang.Object
    继承者  com.trs.ajaxservice.WCMApplyFormProcessServiceHelper

public class WCMApplyFormProcessServiceHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流服务辅助解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static ConfigServer m_oConfigServer
构造方法摘要
WCMApplyFormProcessServiceHelper()
方法摘要
static ConfigServer | getConfigServer()
static Flow | getFlow()
static void | startApplyFormInFlow(User _postUser, ApplyForm _applyForm, boolean _bUseDefaultFlowMode)
static void | startApplyFormInFlow(User _postUser, ApplyForm _applyForm, java.util.Map _hFlowContextInfo)
static void | startApplyFormInFlow(User _postUser, ApplyForm _applyForm, MethodContext _oMethodContext)
static void | validateWorkFlowRight(User _loginUser, BaseObj _content, int _nFlowDocId, int _nActionIndex, java.lang.String _sOperDesc)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

m_oConfigServer

public static ConfigServer m_oConfigServer
构造方法详细信息

WCMApplyFormProcessServiceHelper

public WCMApplyFormProcessServiceHelper()
方法详细信息

getConfigServer

public static ConfigServer getConfigServer()

getFlow

public static Flow getFlow()
                    throws WCMException
抛出：
WCMException

startApplyFormInFlow

public static void startApplyFormInFlow(User _postUser,
                                        ApplyForm _applyForm,
                                        MethodContext _oMethodContext)
                                 throws WCMException
抛出：
WCMException

startApplyFormInFlow

public static void startApplyFormInFlow(User _postUser,
                                        ApplyForm _applyForm,
                                        boolean _bUseDefaultFlowMode)
                                 throws WCMException
抛出：
WCMException

startApplyFormInFlow

public static void startApplyFormInFlow(User _postUser,
                                        ApplyForm _applyForm,
                                        java.util.Map _hFlowContextInfo)
                                 throws WCMException
抛出：
WCMException

validateWorkFlowRight

public static void validateWorkFlowRight(User _loginUser,
                                         BaseObj _content,
                                         int _nFlowDocId,
                                         int _nActionIndex,
                                         java.lang.String _sOperDesc)
                                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMDocumentHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 WCMDocumentHelper

java.lang.Object
    继承者  com.trs.ajaxservice.WCMDocumentHelper

public class WCMDocumentHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文档相关公用行为提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMDocumentHelper()
方法摘要
static ViewDocuments | findViewDocumentsByIds(User _loginUser, java.lang.String _sChnlDocIds)
static java.lang.String | makeRightValue(MethodContext _methodContext, User _loginUser, Channel _currChannel, Document _document) 构造指定文档在指定栏目中的权限
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMDocumentHelper

public WCMDocumentHelper()
方法详细信息

makeRightValue

public static java.lang.String makeRightValue(MethodContext _methodContext,
                                              User _loginUser,
                                              Channel _currChannel,
                                              Document _document)
                                       throws WCMException
构造指定文档在指定栏目中的权限

参数：
_methodContext -
_loginUser -
_currChannel -
_document -
返回：
抛出：
WCMException

findViewDocumentsByIds

public static ViewDocuments findViewDocumentsByIds(User _loginUser,
                                                   java.lang.String _sChnlDocIds)
                                            throws WCMException
参数：
_loginUser -
_sChnlDocIds -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMProcessServiceHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 WCMProcessServiceHelper

java.lang.Object
    继承者  com.trs.ajaxservice.WCMProcessServiceHelper

public class WCMProcessServiceHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流服务辅助解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMProcessServiceHelper()
方法摘要
static boolean | hasFlowingActionRight(User _loginUser, int _nFlowdocId, int _nRightIndex)
static java.lang.String | makeFlowContextInfo(Flow _flow)
static java.util.Map | makeFlowContextInfoMap(java.lang.String _sFlowContextInfo)
static java.lang.String | makeXMLNode(java.lang.String _sNodeName, java.lang.String _sVal)
static java.lang.String | makeXMLNode(java.lang.String _sNodeName, java.lang.String _sVal, boolean _bWithCdata)
static void | startDocumentInFlow(User _postUser, Document _document, boolean _bUseDefaultFlowMode)
static void | startDocumentInFlow(User _postUser, Document _document, Flow _oFlow, MethodContext _oMethodContext)
static void | startDocumentInFlow(User _postUser, Document _document, java.util.Map _hFlowContextInfo)
static void | startDocumentInFlow(User _postUser, Document _document, MethodContext _oMethodContext)
static void | validateWorkFlowRight(User _loginUser, BaseObj _content, int _nFlowDocId, int _nActionIndex, java.lang.String _sOperDesc)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMProcessServiceHelper

public WCMProcessServiceHelper()
方法详细信息

startDocumentInFlow

public static void startDocumentInFlow(User _postUser,
                                       Document _document,
                                       MethodContext _oMethodContext)
                                throws WCMException
抛出：
WCMException

startDocumentInFlow

public static void startDocumentInFlow(User _postUser,
                                       Document _document,
                                       Flow _oFlow,
                                       MethodContext _oMethodContext)
                                throws WCMException
抛出：
WCMException

startDocumentInFlow

public static void startDocumentInFlow(User _postUser,
                                       Document _document,
                                       boolean _bUseDefaultFlowMode)
                                throws WCMException
抛出：
WCMException

startDocumentInFlow

public static void startDocumentInFlow(User _postUser,
                                       Document _document,
                                       java.util.Map _hFlowContextInfo)
                                throws WCMException
抛出：
WCMException

validateWorkFlowRight

public static void validateWorkFlowRight(User _loginUser,
                                         BaseObj _content,
                                         int _nFlowDocId,
                                         int _nActionIndex,
                                         java.lang.String _sOperDesc)
                                  throws WCMException
抛出：
WCMException

hasFlowingActionRight

public static boolean hasFlowingActionRight(User _loginUser,
                                            int _nFlowdocId,
                                            int _nRightIndex)
                                     throws WCMException
抛出：
WCMException

makeFlowContextInfoMap

public static java.util.Map makeFlowContextInfoMap(java.lang.String _sFlowContextInfo)

makeFlowContextInfo

public static java.lang.String makeFlowContextInfo(Flow _flow)
                                            throws WCMException
抛出：
WCMException

makeXMLNode

public static java.lang.String makeXMLNode(java.lang.String _sNodeName,
                                           java.lang.String _sVal)

makeXMLNode

public static java.lang.String makeXMLNode(java.lang.String _sNodeName,
                                           java.lang.String _sVal,
                                           boolean _bWithCdata)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 WebSiteHelper

java.lang.Object
    继承者  com.trs.ajaxservice.WebSiteHelper

public class WebSiteHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
站点相关的工具函数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WebSiteHelper()
方法摘要
static WebSites | getWebSitesByRightIndex(User _loginUser, int _nRightIndex, WCMFilter extraFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual) 获取某个用户能操作的站点集合
static WebSites | getWebSitesByType(User _loginUser, int _nSiteType, WCMFilter queryFilter)
static WebSites | getWebSitesByTypeWithIndividual(User _loginUser, int _nSiteType, WCMFilter queryFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual)
static boolean | isVisible(User _loginUser, WebSite _site) 判断用户对于指定站点是否可见
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteHelper

public WebSiteHelper()
方法详细信息

getWebSitesByType

public static WebSites getWebSitesByType(User _loginUser,
                                         int _nSiteType,
                                         WCMFilter queryFilter)
                                  throws WCMException
参数：
_loginUser -
_nSiteType -
queryFilter -
返回：
抛出：
WCMException

getWebSitesByTypeWithIndividual

public static WebSites getWebSitesByTypeWithIndividual(User _loginUser,
                                                       int _nSiteType,
                                                       WCMFilter queryFilter,
                                                       java.util.Hashtable customSiteIdHt,
                                                       boolean _bForIndividual)
                                                throws WCMException
抛出：
WCMException

isVisible

public static boolean isVisible(User _loginUser,
                                WebSite _site)
                         throws WCMException
判断用户对于指定站点是否可见

参数：
_loginUser -
_site -
返回：
抛出：
WCMException

getWebSitesByRightIndex

public static WebSites getWebSitesByRightIndex(User _loginUser,
                                               int _nRightIndex,
                                               WCMFilter extraFilter,
                                               java.util.Hashtable customSiteIdHt,
                                               boolean _bForIndividual)
                                        throws WCMException
获取某个用户能操作的站点集合

参数：
_loginUser -
_nRightIndex - 将判断的权限位
extraFilter -
customSiteIdHt -
_bForIndividual -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 WebSiteServiceProvider

java.lang.Object
    继承者  com.trs.ajaxservice.WebSiteServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class WebSiteServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
站点相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WebSiteServiceProvider()
方法摘要
int | autoCreate(MethodContext _methodContext) 智能建站
void | changeOrder(MethodContext _methodContext) 调整栏目顺序
void | clearRecycle() 清空站点回收站
java.lang.String | createFrom(MethodContext _MethodContext) 类似创建站点
void | createFromFile(MethodContext _methodContext)
void | delete(MethodContext _methContext)
java.lang.Object | existsSimilarDataPath(MethodContext _methodContext) 在指定的站点或者栏目下是否存在相同存放路径的栏目
boolean | existsSimilarName(MethodContext _methodContext) 是否存在相同名称的站点
java.lang.String | export(MethodContext _MethodContext) 导出指定的站点
java.lang.Object | findById(MethodContext _context)
java.lang.Object | findByIds(MethodContext _context)
static java.lang.String | findSiteTypeDesc(int _nSiteType)
java.lang.String | findSiteTypeDesc(MethodContext _MethodContext)
PageOperators | getDocumentOperators(MethodContext _methContext)
PageOperators | getOperators(MethodContext _methContext)
PageOperators | getOperatorsInSite(MethodContext _methContext) 获取进入当前站点在进入子栏目列表时候的操作
PageOperators | getOperatorsInSiteRoot()
WebSites | getRecycleSites(MethodContext _methodContext) 获取回收站中的站点列表
WebSites | getSitesForCurrUser(MethodContext _methodContext) 获取当前登录用户可以操作（默认为设置权限）的站点
java.lang.String | importSites(MethodContext _MethodContext) 导入栏目
java.lang.Object | query(MethodContext _methContext)
void | restoreSites(MethodContext _methodContext) 恢复回收站中的站点
int | save(MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteServiceProvider

public WebSiteServiceProvider()
方法详细信息

delete

public void delete(MethodContext _methContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _methContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _methodContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

getOperators

public PageOperators getOperators(MethodContext _methContext)
                           throws java.lang.Throwable
参数：
_methContext -
返回：
抛出：
java.lang.Throwable

getDocumentOperators

public PageOperators getDocumentOperators(MethodContext _methContext)
                                   throws java.lang.Throwable
参数：
_methContext -
返回：
抛出：
java.lang.Throwable

getOperatorsInSite

public PageOperators getOperatorsInSite(MethodContext _methContext)
                                 throws java.lang.Throwable
获取进入当前站点在进入子栏目列表时候的操作

参数：
_methContext -
返回：
抛出：
java.lang.Throwable

getOperatorsInSiteRoot

public PageOperators getOperatorsInSiteRoot()
                                     throws java.lang.Throwable
参数：
_methContext -
返回：
抛出：
java.lang.Throwable

findSiteTypeDesc

public java.lang.String findSiteTypeDesc(MethodContext _MethodContext)
                                  throws java.lang.Throwable
参数：
_MethodContext -
返回：
抛出：
java.lang.Throwable

findSiteTypeDesc

public static java.lang.String findSiteTypeDesc(int _nSiteType)
                                         throws java.lang.Throwable
参数：
_nSiteType -
返回：
抛出：
java.lang.Throwable

export

public java.lang.String export(MethodContext _MethodContext)
                        throws java.lang.Throwable
导出指定的站点

参数：
_MethodContext -
返回：
抛出：
java.lang.Throwable

importSites

public java.lang.String importSites(MethodContext _MethodContext)
                             throws java.lang.Throwable
导入栏目

参数：
_MethodContext -
抛出：
java.lang.Throwable

createFrom

public java.lang.String createFrom(MethodContext _MethodContext)
                            throws java.lang.Throwable
类似创建站点

参数：
_MethodContext -
抛出：
java.lang.Throwable

autoCreate

public int autoCreate(MethodContext _methodContext)
               throws java.lang.Throwable
智能建站

参数：
_methodContext -
抛出：
java.lang.Throwable

changeOrder

public void changeOrder(MethodContext _methodContext)
                 throws java.lang.Throwable
调整栏目顺序

参数：
_methodContext -
抛出：
java.lang.Throwable

getRecycleSites

public WebSites getRecycleSites(MethodContext _methodContext)
                         throws java.lang.Throwable
获取回收站中的站点列表

参数：
_methodContext -
抛出：
java.lang.Throwable

restoreSites

public void restoreSites(MethodContext _methodContext)
                  throws java.lang.Throwable
恢复回收站中的站点

参数：
_methodContext -
抛出：
java.lang.Throwable

clearRecycle

public void clearRecycle()
                  throws java.lang.Throwable
清空站点回收站

参数：
_methodContext -
抛出：
java.lang.Throwable

existsSimilarName

public boolean existsSimilarName(MethodContext _methodContext)
                          throws java.lang.Throwable
是否存在相同名称的站点

参数：
_methodContext -
抛出：
java.lang.Throwable

existsSimilarDataPath

public java.lang.Object existsSimilarDataPath(MethodContext _methodContext)
                                       throws java.lang.Throwable
在指定的站点或者栏目下是否存在相同存放路径的栏目

参数：
_methodContext -
抛出：
java.lang.Throwable

createFromFile

public void createFromFile(MethodContext _methodContext)
                    throws java.lang.Exception
抛出：
java.lang.Exception

getSitesForCurrUser

public WebSites getSitesForCurrUser(MethodContext _methodContext)
                             throws WCMException
获取当前登录用户可以操作（默认为设置权限）的站点

参数：
_methodContext -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlToRightConvertor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice
类 XmlToRightConvertor

java.lang.Object
    继承者  com.trs.infra.persistent.XmlToObjConverter
        继承者  com.trs.ajaxservice.XmlToRightConvertor

public class XmlToRightConvertor
extends XmlToObjConverter

构造方法摘要
XmlToRightConvertor(int _nImportType)
方法摘要
从类 com.trs.infra.persistent.XmlToObjConverter 继承的方法
convertXml, convertXml, getXmlEncoding, registPersistentObj, setXmlEncoding
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlToRightConvertor

public XmlToRightConvertor(int _nImportType)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.ajaxservice.ApplyFormServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ApplyFormServiceProvider
的使用

没有 com.trs.ajaxservice.ApplyFormServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.AuthServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.AuthServiceProvider
的使用

没有 com.trs.ajaxservice.AuthServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ChannelHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ChannelHelper
的使用

没有 com.trs.ajaxservice.ChannelHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ChannelServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ChannelServiceProvider
的使用

没有 com.trs.ajaxservice.ChannelServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ChannelServiceProviderHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ChannelServiceProviderHelper
的使用

没有 com.trs.ajaxservice.ChannelServiceProviderHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ChnlDocServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ChnlDocServiceProvider
的使用

没有 com.trs.ajaxservice.ChnlDocServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ContentExtendValue 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ContentExtendValue
的使用

没有 com.trs.ajaxservice.ContentExtendValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ContentExtendValues 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ContentExtendValues
的使用

使用 ContentExtendValues 的软件包
com.trs.ajaxservice

com.trs.ajaxservice 中 ContentExtendValues 的使用

返回 ContentExtendValues 的 com.trs.ajaxservice 中的方法
ContentExtendValues | ViewDocumentServiceProvider.queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息
ContentExtendValues | DocumentServiceProvider.queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息
ContentExtendValues | DocumentBakServiceProvider.queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ContentLinkServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ContentLinkServiceProvider
的使用

没有 com.trs.ajaxservice.ContentLinkServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.DistributeServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.DistributeServiceProvider
的使用

没有 com.trs.ajaxservice.DistributeServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.DocumentAuthHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.DocumentAuthHelper
的使用

没有 com.trs.ajaxservice.DocumentAuthHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.DocumentBakServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.DocumentBakServiceProvider
的使用

没有 com.trs.ajaxservice.DocumentBakServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.DocumentPublishHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.DocumentPublishHelper
的使用

没有 com.trs.ajaxservice.DocumentPublishHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.DocumentServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.DocumentServiceProvider
的使用

没有 com.trs.ajaxservice.DocumentServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.DocumentSynServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.DocumentSynServiceProvider
的使用

没有 com.trs.ajaxservice.DocumentSynServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ExtendFieldServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ExtendFieldServiceProvider
的使用

没有 com.trs.ajaxservice.ExtendFieldServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.FlowingDocQueryService 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.FlowingDocQueryService
的使用

没有 com.trs.ajaxservice.FlowingDocQueryService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.GroupServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.GroupServiceProvider
的使用

没有 com.trs.ajaxservice.GroupServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.IndividuationServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.IndividuationServiceProvider
的使用

没有 com.trs.ajaxservice.IndividuationServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.InfoviewDataToolService 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.InfoviewDataToolService
的使用

没有 com.trs.ajaxservice.InfoviewDataToolService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.InfoViewDocumentServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.InfoViewDocumentServiceProvider
的使用

没有 com.trs.ajaxservice.InfoViewDocumentServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.InfoviewService 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.InfoviewService
的使用

没有 com.trs.ajaxservice.InfoviewService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.JSONHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.JSONHelper
的使用

没有 com.trs.ajaxservice.JSONHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.MessageServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.MessageServiceProvider
的使用

没有 com.trs.ajaxservice.MessageServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.NewChannelServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.NewChannelServiceProvider
的使用

没有 com.trs.ajaxservice.NewChannelServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ObjectMemberServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ObjectMemberServiceProvider
的使用

没有 com.trs.ajaxservice.ObjectMemberServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.PageOperatorsForServiceHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.PageOperatorsForServiceHelper
的使用

没有 com.trs.ajaxservice.PageOperatorsForServiceHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.PhotoServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.PhotoServiceProvider
的使用

没有 com.trs.ajaxservice.PhotoServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.PreviewChannelServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.PreviewChannelServiceProvider
的使用

没有 com.trs.ajaxservice.PreviewChannelServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ProcessService 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ProcessService
的使用

没有 com.trs.ajaxservice.ProcessService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.PublishServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.PublishServiceProvider
的使用

没有 com.trs.ajaxservice.PublishServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ReplaceContentServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ReplaceContentServiceProvider
的使用

没有 com.trs.ajaxservice.ReplaceContentServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.RoleServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.RoleServiceProvider
的使用

没有 com.trs.ajaxservice.RoleServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.SceneServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.SceneServiceProvider
的使用

没有 com.trs.ajaxservice.SceneServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ServiceConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ServiceConstants
的使用

没有 com.trs.ajaxservice.ServiceConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.SourceServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.SourceServiceProvider
的使用

没有 com.trs.ajaxservice.SourceServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.StatusServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.StatusServiceProvider
的使用

没有 com.trs.ajaxservice.StatusServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.SystemServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.SystemServiceProvider
的使用

没有 com.trs.ajaxservice.SystemServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.TemplateAuthHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.TemplateAuthHelper
的使用

没有 com.trs.ajaxservice.TemplateAuthHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.TemplateEmployMgrHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.TemplateEmployMgrHelper
的使用

没有 com.trs.ajaxservice.TemplateEmployMgrHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.TemplateServiceHelperProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.TemplateServiceHelperProvider
的使用

没有 com.trs.ajaxservice.TemplateServiceHelperProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.TemplateServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.TemplateServiceProvider
的使用

没有 com.trs.ajaxservice.TemplateServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.UserServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.UserServiceProvider
的使用

没有 com.trs.ajaxservice.UserServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.ViewDocumentServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.ViewDocumentServiceProvider
的使用

使用 ViewDocumentServiceProvider 的软件包
com.trs.ajaxservice

com.trs.ajaxservice 中 ViewDocumentServiceProvider 的使用

com.trs.ajaxservice 中 ViewDocumentServiceProvider 的子类
 class PhotoServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
图片选件服务
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.WatermarkServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.WatermarkServiceProvider
的使用

没有 com.trs.ajaxservice.WatermarkServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.WCMAJAXServiceHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.WCMAJAXServiceHelper
的使用

没有 com.trs.ajaxservice.WCMAJAXServiceHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper
的使用

没有 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.WCMDocumentHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.WCMDocumentHelper
的使用

没有 com.trs.ajaxservice.WCMDocumentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.WCMProcessServiceHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.WCMProcessServiceHelper
的使用

没有 com.trs.ajaxservice.WCMProcessServiceHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.WebSiteHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.WebSiteHelper
的使用

没有 com.trs.ajaxservice.WebSiteHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.WebSiteServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.WebSiteServiceProvider
的使用

没有 com.trs.ajaxservice.WebSiteServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.XmlToRightConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.XmlToRightConvertor
的使用

没有 com.trs.ajaxservice.XmlToRightConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


MoveChannelListenerForChannel

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.listener
类 MoveChannelListenerForChannel

java.lang.Object
    继承者  com.trs.ajaxservice.listener.MoveChannelListenerForChannel
所有已实现的接口：
IServiceListener
public class MoveChannelListenerForChannel
extends java.lang.Object
implements IServiceListener

构造方法摘要
MoveChannelListenerForChannel()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MoveChannelListenerForChannel

public MoveChannelListenerForChannel()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig listenerConfig,
                                 MethodContext methodContext,
                                 java.lang.Object serviceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
listenerConfig - 当前Lisntener的设置对象
methodContext - 执行服务的当前上下文参数
serviceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.ajaxservice.listener
类
MoveChannelListenerForChannel
SaveMembersListenerForObjectMember


com.trs.ajaxservice.listener

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.ajaxservice.listener

类摘要
MoveChannelListenerForChannel
SaveMembersListenerForObjectMember


com.trs.ajaxservice.listener 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.ajaxservice.listener 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.ajaxservice.listener.MoveChannelListenerForChannel (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.ajaxservice.listener.SaveMembersListenerForObjectMember (implements com.trs.webframework.provider.IServiceListener)


软件包 com.trs.ajaxservice.listener 的使用

上一个 下一个 框架 无框架

软件包 com.trs.ajaxservice.listener
的使用

没有 com.trs.ajaxservice.listener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SaveMembersListenerForObjectMember

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.listener
类 SaveMembersListenerForObjectMember

java.lang.Object
    继承者  com.trs.ajaxservice.listener.SaveMembersListenerForObjectMember
所有已实现的接口：
IServiceListener
public class SaveMembersListenerForObjectMember
extends java.lang.Object
implements IServiceListener

构造方法摘要
SaveMembersListenerForObjectMember()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SaveMembersListenerForObjectMember

public SaveMembersListenerForObjectMember()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig listenerConfig,
                                 MethodContext methodContext,
                                 java.lang.Object serviceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
listenerConfig - 当前Lisntener的设置对象
methodContext - 执行服务的当前上下文参数
serviceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.ajaxservice.listener.MoveChannelListenerForChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.listener.MoveChannelListenerForChannel
的使用

没有 com.trs.ajaxservice.listener.MoveChannelListenerForChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.listener.SaveMembersListenerForObjectMember 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.listener.SaveMembersListenerForObjectMember
的使用

没有 com.trs.ajaxservice.listener.SaveMembersListenerForObjectMember 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BatchChannelCreateFromFileLogger

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 BatchChannelCreateFromFileLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.BatchChannelCreateFromFileLogger
所有已实现的接口：
ServiceExcuteLogger
public class BatchChannelCreateFromFileLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
批量创建日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
BatchChannelCreateFromFileLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BatchChannelCreateFromFileLogger

public BatchChannelCreateFromFileLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChannelCreateFromLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 ChannelCreateFromLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.ChannelCreateFromLogger
所有已实现的接口：
ServiceExcuteLogger
public class ChannelCreateFromLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
ChannelCreateFromLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelCreateFromLogger

public ChannelCreateFromLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelImportLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 ChannelImportLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.ChannelImportLogger
所有已实现的接口：
ServiceExcuteLogger
public class ChannelImportLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
导入频道操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
ChannelImportLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelImportLogger

public ChannelImportLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelMoveLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 ChannelMoveLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.ChannelMoveLogger
所有已实现的接口：
ServiceExcuteLogger
public class ChannelMoveLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
ChannelMoveLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelMoveLogger

public ChannelMoveLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocCopyLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 DocCopyLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.DocCopyLogger
所有已实现的接口：
ServiceExcuteLogger
public class DocCopyLogger
extends AbstractLogger

构造方法摘要
DocCopyLogger()
方法摘要
 int startLog(MethodConfig _oConf, MethodContext _oContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocCopyLogger

public DocCopyLogger()
方法详细信息

startLog

public int startLog(MethodConfig _oConf,
                    MethodContext _oContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocImportLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 DocImportLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.DocImportLogger
所有已实现的接口：
ServiceExcuteLogger
public class DocImportLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
DocImportLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocImportLogger

public DocImportLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocMoveLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 DocMoveLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.DocMoveLogger
所有已实现的接口：
ServiceExcuteLogger
public class DocMoveLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
文档移动日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
DocMoveLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocMoveLogger

public DocMoveLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocPublishTaskLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 DocPublishTaskLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.DocPublishTaskLogger
所有已实现的接口：
ServiceExcuteLogger
public class DocPublishTaskLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
文档发布日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
DocPublishTaskLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocPublishTaskLogger

public DocPublishTaskLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocSaveLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 DocSaveLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.webframework.DefaultSaveLogger
            继承者  com.trs.ajaxservice.logger.DocSaveLogger
所有已实现的接口：
ServiceExcuteLogger
public class DocSaveLogger
extends DefaultSaveLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
文档保存日志
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
DocSaveLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.DefaultSaveLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocSaveLogger

public DocSaveLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
指定者：
接口 ServiceExcuteLogger 中的 startLog
覆盖：
类 DefaultSaveLogger 中的 startLog
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatusChangeLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 DocStatusChangeLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.DocStatusChangeLogger
所有已实现的接口：
ServiceExcuteLogger
public class DocStatusChangeLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
文档状态改变日志记录
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
DocStatusChangeLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatusChangeLogger

public DocStatusChangeLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowSaveLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 FlowSaveLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.FlowSaveLogger
所有已实现的接口：
ServiceExcuteLogger
public class FlowSaveLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流保存日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
FlowSaveLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowSaveLogger

public FlowSaveLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowSetLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 FlowSetLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.FlowSetLogger
所有已实现的接口：
ServiceExcuteLogger
public class FlowSetLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
分配工作流到栏目日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
FlowSetLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowSetLogger

public FlowSetLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImpartTemplateLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 ImpartTemplateLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.ImpartTemplateLogger
所有已实现的接口：
ServiceExcuteLogger
public class ImpartTemplateLogger
extends AbstractLogger

构造方法摘要
ImpartTemplateLogger()
方法摘要
 int startLog(MethodConfig _oConf, MethodContext _oContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImpartTemplateLogger

public ImpartTemplateLogger()
方法详细信息

startLog

public int startLog(MethodConfig _oConf,
                    MethodContext _oContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.ajaxservice.logger
类
BatchChannelCreateFromFileLogger
ChannelCreateFromLogger
ChannelImportLogger
ChannelMoveLogger
DocCopyLogger
DocImportLogger
DocMoveLogger
DocPublishTaskLogger
DocSaveLogger
DocStatusChangeLogger
FlowSaveLogger
FlowSetLogger
ImpartTemplateLogger
PublishConfigSaveLogger
PublishTaskLogger
RecycleClearLogger
RestoreObjLogger
ResyncTemplateApdLogger
SetEmployersOfTemplateLogger
SiteCreateFromLogger
SiteImportLogger
SiteRecycleClearLogger
TemplateImportLogger
TemplateSyncLogger
WebSiteRestoreLogger


com.trs.ajaxservice.logger

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.ajaxservice.logger

类摘要
BatchChannelCreateFromFileLogger | Title: TRS 内容协作平台（TRS WCM） Description: 批量创建日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ChannelCreateFromLogger | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelImportLogger | Title: TRS 内容协作平台（TRS WCM） Description: 导入频道操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelMoveLogger | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DocCopyLogger |
DocImportLogger | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DocMoveLogger | Title: TRS 内容协作平台（TRS WCM） Description: 文档移动日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DocPublishTaskLogger | Title: TRS 内容协作平台（TRS WCM） Description: 文档发布日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocSaveLogger | Title: TRS 内容协作平台（TRS WCM） Description: 文档保存日志 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocStatusChangeLogger | Title: TRS 内容协作平台（TRS WCM） Description: 文档状态改变日志记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FlowSaveLogger | Title: TRS 内容协作平台（TRS WCM） Description: 工作流保存日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FlowSetLogger | Title: TRS 内容协作平台（TRS WCM） Description: 分配工作流到栏目日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ImpartTemplateLogger |
PublishConfigSaveLogger | Title: TRS 内容协作平台（TRS WCM） Description: 发布相关属性日志操作记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
PublishTaskLogger | Title: TRS 内容协作平台（TRS WCM） Description: 发布日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
RecycleClearLogger | Title: TRS 内容协作平台（TRS WCM） Description: 回收站清空日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
RestoreObjLogger | Title: TRS 内容协作平台（TRS WCM） Description: 恢复回收站日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ResyncTemplateApdLogger | Title: TRS 内容协作平台（TRS WCM） Description: 同步模板附件操作日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
SetEmployersOfTemplateLogger |
SiteCreateFromLogger | Title: TRS 内容协作平台（TRS WCM） Description: 类似创建站点日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
SiteImportLogger | Title: TRS 内容协作平台（TRS WCM） Description: 站点导入日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
SiteRecycleClearLogger | Title: TRS 内容协作平台（TRS WCM） Description: 清空站点回收站日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
TemplateImportLogger | Title: TRS 内容协作平台（TRS WCM） Description: 导入模板日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TemplateSyncLogger | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
WebSiteRestoreLogger | Title: TRS 内容协作平台（TRS WCM） Description: 站点恢复操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)


com.trs.ajaxservice.logger 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.ajaxservice.logger 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.AbstractLogger (implements com.trs.webframework.ServiceExcuteLogger)
      • com.trs.ajaxservice.logger.BatchChannelCreateFromFileLogger
      • com.trs.ajaxservice.logger.ChannelCreateFromLogger
      • com.trs.ajaxservice.logger.ChannelImportLogger
      • com.trs.ajaxservice.logger.ChannelMoveLogger
      • com.trs.webframework.DefaultSaveLogger (implements com.trs.webframework.ServiceExcuteLogger)
        • com.trs.ajaxservice.logger.DocSaveLogger
      • com.trs.ajaxservice.logger.DocCopyLogger
      • com.trs.ajaxservice.logger.DocImportLogger
      • com.trs.ajaxservice.logger.DocMoveLogger
      • com.trs.ajaxservice.logger.DocPublishTaskLogger
      • com.trs.ajaxservice.logger.DocStatusChangeLogger
      • com.trs.ajaxservice.logger.FlowSaveLogger
      • com.trs.ajaxservice.logger.FlowSetLogger
      • com.trs.ajaxservice.logger.ImpartTemplateLogger
      • com.trs.ajaxservice.logger.PublishConfigSaveLogger
      • com.trs.ajaxservice.logger.PublishTaskLogger
      • com.trs.ajaxservice.logger.RecycleClearLogger
      • com.trs.ajaxservice.logger.RestoreObjLogger
      • com.trs.ajaxservice.logger.ResyncTemplateApdLogger
      • com.trs.ajaxservice.logger.SetEmployersOfTemplateLogger
      • com.trs.ajaxservice.logger.SiteCreateFromLogger
      • com.trs.ajaxservice.logger.SiteImportLogger
      • com.trs.ajaxservice.logger.SiteRecycleClearLogger
      • com.trs.ajaxservice.logger.TemplateImportLogger
      • com.trs.ajaxservice.logger.TemplateSyncLogger
      • com.trs.ajaxservice.logger.WebSiteRestoreLogger


软件包 com.trs.ajaxservice.logger 的使用

上一个 下一个 框架 无框架

软件包 com.trs.ajaxservice.logger
的使用

没有 com.trs.ajaxservice.logger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishConfigSaveLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 PublishConfigSaveLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.PublishConfigSaveLogger
所有已实现的接口：
ServiceExcuteLogger
public class PublishConfigSaveLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
发布相关属性日志操作记录
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
PublishConfigSaveLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishConfigSaveLogger

public PublishConfigSaveLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTaskLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 PublishTaskLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.PublishTaskLogger
所有已实现的接口：
ServiceExcuteLogger
public class PublishTaskLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
发布日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
PublishTaskLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishTaskLogger

public PublishTaskLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RecycleClearLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 RecycleClearLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.RecycleClearLogger
所有已实现的接口：
ServiceExcuteLogger
public class RecycleClearLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
回收站清空日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
RecycleClearLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RecycleClearLogger

public RecycleClearLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RestoreObjLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 RestoreObjLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.RestoreObjLogger
所有已实现的接口：
ServiceExcuteLogger
public class RestoreObjLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
恢复回收站日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
RestoreObjLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RestoreObjLogger

public RestoreObjLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResyncTemplateApdLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 ResyncTemplateApdLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.ResyncTemplateApdLogger
所有已实现的接口：
ServiceExcuteLogger
public class ResyncTemplateApdLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
同步模板附件操作日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ResyncTemplateApdLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResyncTemplateApdLogger

public ResyncTemplateApdLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SetEmployersOfTemplateLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 SetEmployersOfTemplateLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.SetEmployersOfTemplateLogger
所有已实现的接口：
ServiceExcuteLogger
public class SetEmployersOfTemplateLogger
extends AbstractLogger

构造方法摘要
SetEmployersOfTemplateLogger()
方法摘要
 int startLog(MethodConfig _oConf, MethodContext _oContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SetEmployersOfTemplateLogger

public SetEmployersOfTemplateLogger()
方法详细信息

startLog

public int startLog(MethodConfig _oConf,
                    MethodContext _oContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteCreateFromLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 SiteCreateFromLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.SiteCreateFromLogger
所有已实现的接口：
ServiceExcuteLogger
public class SiteCreateFromLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
类似创建站点日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
SiteCreateFromLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteCreateFromLogger

public SiteCreateFromLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteImportLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 SiteImportLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.SiteImportLogger
所有已实现的接口：
ServiceExcuteLogger
public class SiteImportLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
站点导入日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
SiteImportLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteImportLogger

public SiteImportLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteRecycleClearLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 SiteRecycleClearLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.SiteRecycleClearLogger
所有已实现的接口：
ServiceExcuteLogger
public class SiteRecycleClearLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
清空站点回收站日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
SiteRecycleClearLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteRecycleClearLogger

public SiteRecycleClearLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateImportLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 TemplateImportLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.TemplateImportLogger
所有已实现的接口：
ServiceExcuteLogger
public class TemplateImportLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
导入模板日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TemplateImportLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateImportLogger

public TemplateImportLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateSyncLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 TemplateSyncLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.TemplateSyncLogger
所有已实现的接口：
ServiceExcuteLogger
public class TemplateSyncLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TemplateSyncLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateSyncLogger

public TemplateSyncLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteRestoreLogger

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.logger
类 WebSiteRestoreLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.ajaxservice.logger.WebSiteRestoreLogger
所有已实现的接口：
ServiceExcuteLogger
public class WebSiteRestoreLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
站点恢复操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
WebSiteRestoreLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteRestoreLogger

public WebSiteRestoreLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.ajaxservice.logger.BatchChannelCreateFromFileLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.BatchChannelCreateFromFileLogger
的使用

没有 com.trs.ajaxservice.logger.BatchChannelCreateFromFileLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.ChannelCreateFromLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.ChannelCreateFromLogger
的使用

没有 com.trs.ajaxservice.logger.ChannelCreateFromLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.ChannelImportLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.ChannelImportLogger
的使用

没有 com.trs.ajaxservice.logger.ChannelImportLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.ChannelMoveLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.ChannelMoveLogger
的使用

没有 com.trs.ajaxservice.logger.ChannelMoveLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.DocCopyLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.DocCopyLogger
的使用

没有 com.trs.ajaxservice.logger.DocCopyLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.DocImportLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.DocImportLogger
的使用

没有 com.trs.ajaxservice.logger.DocImportLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.DocMoveLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.DocMoveLogger
的使用

没有 com.trs.ajaxservice.logger.DocMoveLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.DocPublishTaskLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.DocPublishTaskLogger
的使用

没有 com.trs.ajaxservice.logger.DocPublishTaskLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.DocSaveLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.DocSaveLogger
的使用

没有 com.trs.ajaxservice.logger.DocSaveLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.DocStatusChangeLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.DocStatusChangeLogger
的使用

没有 com.trs.ajaxservice.logger.DocStatusChangeLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.FlowSaveLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.FlowSaveLogger
的使用

没有 com.trs.ajaxservice.logger.FlowSaveLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.FlowSetLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.FlowSetLogger
的使用

没有 com.trs.ajaxservice.logger.FlowSetLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.ImpartTemplateLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.ImpartTemplateLogger
的使用

没有 com.trs.ajaxservice.logger.ImpartTemplateLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.PublishConfigSaveLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.PublishConfigSaveLogger
的使用

没有 com.trs.ajaxservice.logger.PublishConfigSaveLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.PublishTaskLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.PublishTaskLogger
的使用

没有 com.trs.ajaxservice.logger.PublishTaskLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.RecycleClearLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.RecycleClearLogger
的使用

没有 com.trs.ajaxservice.logger.RecycleClearLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.RestoreObjLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.RestoreObjLogger
的使用

没有 com.trs.ajaxservice.logger.RestoreObjLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.ResyncTemplateApdLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.ResyncTemplateApdLogger
的使用

没有 com.trs.ajaxservice.logger.ResyncTemplateApdLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.SetEmployersOfTemplateLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.SetEmployersOfTemplateLogger
的使用

没有 com.trs.ajaxservice.logger.SetEmployersOfTemplateLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.SiteCreateFromLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.SiteCreateFromLogger
的使用

没有 com.trs.ajaxservice.logger.SiteCreateFromLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.SiteImportLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.SiteImportLogger
的使用

没有 com.trs.ajaxservice.logger.SiteImportLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.SiteRecycleClearLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.SiteRecycleClearLogger
的使用

没有 com.trs.ajaxservice.logger.SiteRecycleClearLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.TemplateImportLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.TemplateImportLogger
的使用

没有 com.trs.ajaxservice.logger.TemplateImportLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.TemplateSyncLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.TemplateSyncLogger
的使用

没有 com.trs.ajaxservice.logger.TemplateSyncLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.logger.WebSiteRestoreLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.logger.WebSiteRestoreLogger
的使用

没有 com.trs.ajaxservice.logger.WebSiteRestoreLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AppendixToXML

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 AppendixToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.AppendixToXML
所有已实现的接口：
IXMLConvertor
public class AppendixToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
附件的XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AppendixToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AppendixToXML

public AppendixToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BaseWCMObjectToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 BaseWCMObjectToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
所有已实现的接口：
IXMLConvertor
直接已知子类：
AppendixToXML, ChannelSynToXML, ChannelToXML, ChnlDocToXML, ContentExtFieldToXML, ContentLink2Xml, DefaultWCMObjectsToXML, DocumentToXML, ExtFieldToXML, FlowDocToXML, FlowToXML, MessageToXML, PageOpertatosToXML, RelationToXML, TemplateEmployerToXML, TemplateToXML, ViewDocumentToXML, Watermark2Xml, WebSiteToXML
public abstract class BaseWCMObjectToXML
extends java.lang.Object
implements IXMLConvertor

构造方法摘要
BaseWCMObjectToXML()
方法摘要
 java.lang.String toXmlString(MethodContext _methodContext, java.lang.Object _result)
将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.webframework.xmlserver.IXMLConvertor 继承的方法
registerTargetClassName

构造方法详细信息

BaseWCMObjectToXML

public BaseWCMObjectToXML()
方法详细信息

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelSynToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ChannelSynToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.ChannelSynToXML
所有已实现的接口：
IXMLConvertor
public class ChannelSynToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
文档同步XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelSynToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelSynToXML

public ChannelSynToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ChannelToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.ChannelToXML
所有已实现的接口：
IXMLConvertor
public class ChannelToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
栏目XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelToXML()
方法摘要
static void | doFilterRight(RightValue _rightValue, Channel _channel)
java.lang.String[] | registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelToXML

public ChannelToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：

doFilterRight

public static void doFilterRight(RightValue _rightValue,
                                 Channel _channel)
参数：
_rightValue -
_channel -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDocToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ChnlDocToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.ChnlDocToXML
所有已实现的接口：
IXMLConvertor
public class ChnlDocToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
频道文档XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChnlDocToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocToXML

public ChnlDocToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtFieldToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ContentExtFieldToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.ContentExtFieldToXML
所有已实现的接口：
IXMLConvertor
public class ContentExtFieldToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
扩展字段XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentExtFieldToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentExtFieldToXML

public ContentExtFieldToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentLink2Xml

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ContentLink2Xml

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.ContentLink2Xml
所有已实现的接口：
IXMLConvertor
public class ContentLink2Xml
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
ContentLink2Xml()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentLink2Xml

public ContentLink2Xml()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentProcessInfoToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ContentProcessInfoToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML
所有已实现的接口：
IXMLConvertor
public class ContentProcessInfoToXML
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
ContentProcessInfo的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentProcessInfoToXML()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentProcessInfoToXML

public ContentProcessInfoToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataTypeToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 DataTypeToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.DataTypeToXML
所有已实现的接口：
IXMLConvertor
public class DataTypeToXML
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
DataType的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DataTypeToXML()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataTypeToXML

public DataTypeToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultWCMObjectsToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 DefaultWCMObjectsToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.DefaultWCMObjectsToXML
所有已实现的接口：
IXMLConvertor
public class DefaultWCMObjectsToXML
extends BaseWCMObjectToXML

构造方法摘要
DefaultWCMObjectsToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultWCMObjectsToXML

public DefaultWCMObjectsToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DistributionTargetTypeToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 DistributionTargetTypeToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML
所有已实现的接口：
IXMLConvertor
public class DistributionTargetTypeToXML
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DistributionTargetTypeToXML()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DistributionTargetTypeToXML

public DistributionTargetTypeToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 DocumentToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.DocumentToXML
所有已实现的接口：
IXMLConvertor
public class DocumentToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentToXML

public DocumentToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExtFieldToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ExtFieldToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.ExtFieldToXML
所有已实现的接口：
IXMLConvertor
public class ExtFieldToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
扩展字段XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ExtFieldToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExtFieldToXML

public ExtFieldToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContentsToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 FlowContentsToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.FlowContentsToXML
所有已实现的接口：
IXMLConvertor
public class FlowContentsToXML
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
将IFlowContent数组转换为XML
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContentsToXML()
方法摘要
static void | main(java.lang.String[] args)
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContentsToXML

public FlowContentsToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowDocToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 FlowDocToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.FlowDocToXML
所有已实现的接口：
IXMLConvertor
public class FlowDocToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流轨迹XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowDocToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowDocToXML

public FlowDocToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 FlowToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.FlowToXML
所有已实现的接口：
IXMLConvertor
public class FlowToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流 To XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowToXML

public FlowToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDocumentToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 InfoViewDocumentToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.ViewDocumentToXML
            继承者  com.trs.ajaxservice.xmlconvertors.InfoViewDocumentToXML
所有已实现的接口：
IXMLConvertor
public class InfoViewDocumentToXML
extends ViewDocumentToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
ViewDocument的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoViewDocumentToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewDocumentToXML

public InfoViewDocumentToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
覆盖：
类 ViewDocumentToXML 中的 registerTargetClassName
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 MessageToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.MessageToXML
所有已实现的接口：
IXMLConvertor
public class MessageToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
Message XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MessageToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageToXML

public MessageToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.ajaxservice.xmlconvertors
类
AppendixToXML
BaseWCMObjectToXML
ChannelSynToXML
ChannelToXML
ChnlDocToXML
ContentExtFieldToXML
ContentLink2Xml
ContentProcessInfoToXML
DataTypeToXML
DefaultWCMObjectsToXML
DistributionTargetTypeToXML
DocumentToXML
ExtFieldToXML
FlowContentsToXML
FlowDocToXML
FlowToXML
InfoViewDocumentToXML
MessageToXML
PageOpertatosToXML
RelationToXML
ReportsToXML
TemplateEmployerToXML
TemplateToXML
ViewDocumentToXML
Watermark2Xml
WCMContentPublishConfigToXML
WCMFolderPublishConfigToXML
WebSiteToXML
XMLToCMSObj


com.trs.ajaxservice.xmlconvertors

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.ajaxservice.xmlconvertors

类摘要
AppendixToXML | Title: TRS 内容协作平台（TRS WCM） Description: 附件的XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseWCMObjectToXML |
ChannelSynToXML | Title: TRS 内容协作平台（TRS WCM） Description: 文档同步XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelToXML | Title: TRS 内容协作平台（TRS WCM） Description: 栏目XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocToXML | Title: TRS 内容协作平台（TRS WCM） Description: 频道文档XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentExtFieldToXML | Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentLink2Xml | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ContentProcessInfoToXML | Title: TRS 内容协作平台（TRS WCM） Description: ContentProcessInfo的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DataTypeToXML | Title: TRS 内容协作平台（TRS WCM） Description: DataType的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DefaultWCMObjectsToXML |
DistributionTargetTypeToXML | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentToXML | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ExtFieldToXML | Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentsToXML | Title: TRS 内容协作平台（TRS WCM） Description: 将IFlowContent数组转换为XML Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowDocToXML | Title: TRS 内容协作平台（TRS WCM） Description: 工作流轨迹XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowToXML | Title: TRS 内容协作平台（TRS WCM） Description: 工作流 To XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDocumentToXML | Title: TRS 内容协作平台（TRS WCM） Description: ViewDocument的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MessageToXML | Title: TRS 内容协作平台（TRS WCM） Description: Message XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PageOpertatosToXML |
RelationToXML | Title: TRS 内容协作平台（TRS WCM） Description: 相关文档XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ReportsToXML | Title: TRS 内容协作平台（TRS WCM） Description: Reports的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployerToXML | Title: TRS 内容协作平台（TRS WCM） Description: 模板使用者XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateToXML | Title: TRS 内容协作平台（TRS WCM） Description: 模板对象XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocumentToXML | Title: TRS 内容协作平台（TRS WCM） Description: ViewDocument的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Watermark2Xml | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WCMContentPublishConfigToXML | Title: TRS 内容协作平台（TRS WCM） Description: WCMFolderPublishConfig XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFolderPublishConfigToXML | Title: TRS 内容协作平台（TRS WCM） Description: WCMFolderPublishConfig XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteToXML | Title: TRS 内容协作平台（TRS WCM） Description: 栏目XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XMLToCMSObj | Title: TRS 内容协作平台（TRS WCM） Description: 将XML转换成CMSObj对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.ajaxservice.xmlconvertors 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.ajaxservice.xmlconvertors 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
      • com.trs.ajaxservice.xmlconvertors.AppendixToXML
      • com.trs.ajaxservice.xmlconvertors.ChannelSynToXML
      • com.trs.ajaxservice.xmlconvertors.ChannelToXML
      • com.trs.ajaxservice.xmlconvertors.ChnlDocToXML
      • com.trs.ajaxservice.xmlconvertors.ContentExtFieldToXML
      • com.trs.ajaxservice.xmlconvertors.ContentLink2Xml
      • com.trs.ajaxservice.xmlconvertors.DefaultWCMObjectsToXML
      • com.trs.ajaxservice.xmlconvertors.DocumentToXML
      • com.trs.ajaxservice.xmlconvertors.ExtFieldToXML
      • com.trs.ajaxservice.xmlconvertors.FlowDocToXML
      • com.trs.ajaxservice.xmlconvertors.FlowToXML
      • com.trs.ajaxservice.xmlconvertors.MessageToXML
      • com.trs.ajaxservice.xmlconvertors.PageOpertatosToXML
      • com.trs.ajaxservice.xmlconvertors.RelationToXML
      • com.trs.ajaxservice.xmlconvertors.TemplateEmployerToXML
      • com.trs.ajaxservice.xmlconvertors.TemplateToXML
      • com.trs.ajaxservice.xmlconvertors.ViewDocumentToXML
        • com.trs.ajaxservice.xmlconvertors.InfoViewDocumentToXML
      • com.trs.ajaxservice.xmlconvertors.Watermark2Xml
      • com.trs.ajaxservice.xmlconvertors.WebSiteToXML
    • com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.ajaxservice.xmlconvertors.DataTypeToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.ajaxservice.xmlconvertors.FlowContentsToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.ajaxservice.xmlconvertors.ReportsToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.ajaxservice.xmlconvertors.XMLToCMSObj


软件包 com.trs.ajaxservice.xmlconvertors 的使用

上一个 下一个 框架 无框架

软件包 com.trs.ajaxservice.xmlconvertors
的使用

使用 com.trs.ajaxservice.xmlconvertors 的软件包
com.trs.ajaxservice.xmlconvertors

com.trs.ajaxservice.xmlconvertors 使用的 com.trs.ajaxservice.xmlconvertors 中的类
BaseWCMObjectToXML
ViewDocumentToXML
Title: TRS 内容协作平台（TRS WCM）
Description:
ViewDocument的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageOpertatosToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 PageOpertatosToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.PageOpertatosToXML
所有已实现的接口：
IXMLConvertor
public class PageOpertatosToXML
extends BaseWCMObjectToXML

构造方法摘要
PageOpertatosToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageOpertatosToXML

public PageOpertatosToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 RelationToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.RelationToXML
所有已实现的接口：
IXMLConvertor
public class RelationToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
相关文档XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RelationToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RelationToXML

public RelationToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReportsToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ReportsToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.ReportsToXML
所有已实现的接口：
IXMLConvertor
public class ReportsToXML
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
Reports的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ReportsToXML()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ReportsToXML

public ReportsToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmployerToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 TemplateEmployerToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.TemplateEmployerToXML
所有已实现的接口：
IXMLConvertor
public class TemplateEmployerToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
模板使用者XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateEmployerToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateEmployerToXML

public TemplateEmployerToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 TemplateToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.TemplateToXML
所有已实现的接口：
IXMLConvertor
public class TemplateToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
模板对象XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateToXML

public TemplateToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewDocumentToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 ViewDocumentToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.ViewDocumentToXML
所有已实现的接口：
IXMLConvertor
直接已知子类：
InfoViewDocumentToXML
public class ViewDocumentToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
ViewDocument的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ViewDocumentToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ViewDocumentToXML

public ViewDocumentToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Watermark2Xml

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 Watermark2Xml

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.Watermark2Xml
所有已实现的接口：
IXMLConvertor
public class Watermark2Xml
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
Watermark2Xml()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Watermark2Xml

public Watermark2Xml()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMContentPublishConfigToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 WCMContentPublishConfigToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML
所有已实现的接口：
IXMLConvertor
public class WCMContentPublishConfigToXML
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
WCMFolderPublishConfig XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMContentPublishConfigToXML()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMContentPublishConfigToXML

public WCMContentPublishConfigToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFolderPublishConfigToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 WCMFolderPublishConfigToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML
所有已实现的接口：
IXMLConvertor
public class WCMFolderPublishConfigToXML
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
WCMFolderPublishConfig XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMFolderPublishConfigToXML()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMFolderPublishConfigToXML

public WCMFolderPublishConfigToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 WebSiteToXML

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
        继承者  com.trs.ajaxservice.xmlconvertors.WebSiteToXML
所有已实现的接口：
IXMLConvertor
public class WebSiteToXML
extends BaseWCMObjectToXML

Title: TRS 内容协作平台（TRS WCM）
Description:
栏目XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WebSiteToXML()
方法摘要
 java.lang.String[] registerTargetClassName()
从类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 继承的方法
toXmlString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteToXML

public WebSiteToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLToCMSObj

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.ajaxservice.xmlconvertors
类 XMLToCMSObj

java.lang.Object
    继承者  com.trs.ajaxservice.xmlconvertors.XMLToCMSObj

public class XMLToCMSObj
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
将XML转换成CMSObj对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
XMLToCMSObj(User _currUser, CMSObj _oSrcInstance)
方法摘要
void | cancelUpdate()
CMSObj[] | getCMSObjs()
java.lang.String | getObjectIds()
void | parse(java.lang.String _sXMLText)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLToCMSObj

public XMLToCMSObj(User _currUser,
                   CMSObj _oSrcInstance)
方法详细信息

parse

public void parse(java.lang.String _sXMLText)
           throws WCMException
抛出：
WCMException

cancelUpdate

public void cancelUpdate()

getCMSObjs

public CMSObj[] getCMSObjs()
返回：

getObjectIds

public java.lang.String getObjectIds()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.ajaxservice.xmlconvertors.AppendixToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.AppendixToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.AppendixToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML
的使用

使用 BaseWCMObjectToXML 的软件包
com.trs.ajaxservice.xmlconvertors

com.trs.ajaxservice.xmlconvertors 中 BaseWCMObjectToXML 的使用

com.trs.ajaxservice.xmlconvertors 中 BaseWCMObjectToXML 的子类
class | AppendixToXML Title: TRS 内容协作平台（TRS WCM） Description: 附件的XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelSynToXML Title: TRS 内容协作平台（TRS WCM） Description: 文档同步XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelToXML Title: TRS 内容协作平台（TRS WCM） Description: 栏目XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChnlDocToXML Title: TRS 内容协作平台（TRS WCM） Description: 频道文档XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContentExtFieldToXML Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContentLink2Xml Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DefaultWCMObjectsToXML
class | DocumentToXML Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtFieldToXML Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowDocToXML Title: TRS 内容协作平台（TRS WCM） Description: 工作流轨迹XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowToXML Title: TRS 内容协作平台（TRS WCM） Description: 工作流 To XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoViewDocumentToXML Title: TRS 内容协作平台（TRS WCM） Description: ViewDocument的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageToXML Title: TRS 内容协作平台（TRS WCM） Description: Message XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PageOpertatosToXML
class | RelationToXML Title: TRS 内容协作平台（TRS WCM） Description: 相关文档XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateEmployerToXML Title: TRS 内容协作平台（TRS WCM） Description: 模板使用者XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateToXML Title: TRS 内容协作平台（TRS WCM） Description: 模板对象XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ViewDocumentToXML Title: TRS 内容协作平台（TRS WCM） Description: ViewDocument的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Watermark2Xml Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteToXML Title: TRS 内容协作平台（TRS WCM） Description: 栏目XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ChannelSynToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ChannelSynToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.ChannelSynToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ChannelToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ChannelToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.ChannelToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ChnlDocToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ChnlDocToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.ChnlDocToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ContentExtFieldToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ContentExtFieldToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.ContentExtFieldToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ContentLink2Xml 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ContentLink2Xml
的使用

没有 com.trs.ajaxservice.xmlconvertors.ContentLink2Xml 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.DataTypeToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.DataTypeToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.DataTypeToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.DefaultWCMObjectsToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.DefaultWCMObjectsToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.DefaultWCMObjectsToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.DocumentToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.DocumentToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.DocumentToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ExtFieldToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ExtFieldToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.ExtFieldToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.FlowContentsToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.FlowContentsToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.FlowContentsToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.FlowDocToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.FlowDocToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.FlowDocToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.FlowToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.FlowToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.FlowToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.InfoViewDocumentToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.InfoViewDocumentToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.InfoViewDocumentToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.MessageToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.MessageToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.MessageToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.PageOpertatosToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.PageOpertatosToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.PageOpertatosToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.RelationToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.RelationToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.RelationToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ReportsToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ReportsToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.ReportsToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.TemplateEmployerToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.TemplateEmployerToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.TemplateEmployerToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.TemplateToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.TemplateToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.TemplateToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.ViewDocumentToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.ViewDocumentToXML
的使用

使用 ViewDocumentToXML 的软件包
com.trs.ajaxservice.xmlconvertors

com.trs.ajaxservice.xmlconvertors 中 ViewDocumentToXML 的使用

com.trs.ajaxservice.xmlconvertors 中 ViewDocumentToXML 的子类
 class InfoViewDocumentToXML
Title: TRS 内容协作平台（TRS WCM）
Description:
ViewDocument的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.Watermark2Xml 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.Watermark2Xml
的使用

没有 com.trs.ajaxservice.xmlconvertors.Watermark2Xml 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.WebSiteToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.WebSiteToXML
的使用

没有 com.trs.ajaxservice.xmlconvertors.WebSiteToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ajaxservice.xmlconvertors.XMLToCMSObj 的使用

上一个 下一个 框架 无框架

类 com.trs.ajaxservice.xmlconvertors.XMLToCMSObj
的使用

没有 com.trs.ajaxservice.xmlconvertors.XMLToCMSObj 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.ConfigFileTool4Refactor 的使用

上一个 下一个 框架 无框架

类 com.trs.ConfigFileTool4Refactor
的使用

没有 com.trs.ConfigFileTool4Refactor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.DreamFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.DreamFactory
的使用

没有 com.trs.DreamFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.SpringBean 的使用

上一个 下一个 框架 无框架

类 com.trs.SpringBean
的使用

没有 com.trs.SpringBean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ClusterConfigHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
类 ClusterConfigHelper

java.lang.Object
    继承者  com.trs.cluster.ClusterConfigHelper

public class ClusterConfigHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ClusterConfigHelper()
方法摘要
static com.trs.infra.cluster.ClusterConfig getConfig()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClusterConfigHelper

public ClusterConfigHelper()
方法详细信息

getConfig

public static final com.trs.infra.cluster.ClusterConfig getConfig()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ClusterConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
类 ClusterConstants

java.lang.Object
    继承者  com.trs.cluster.ClusterConstants

public class ClusterConstants
extends java.lang.Object

作者：
Administrator

字段摘要
static int | EVENT_TYPE_ADD 新增一个对象
static int | EVENT_TYPE_DELETE 删除指定对象
static int | EVENT_TYPE_EDIT 修改指定对象
static int | EVENT_TYPE_TALBE_RELOAD 表结构重新载入
static java.lang.String | MESSAGE_FILE_MODIFIED 文件更改消息
static java.lang.String | MESSAGE_FILE_WITHDRAW 发布文件撤除消息
static java.lang.String | MESSAGE_METADATA_APPCREATE
static java.lang.String | MESSAGE_RELOAD_TABLE 重新装入表的结构
static java.lang.String | MESSAGE_REMOVE_TABLE 删除表的结构
static java.lang.String | MESSAGE_RREFRESH_PROPERTY 强制刷新Cache对象中的指定字段的值
构造方法摘要
ClusterConstants()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

EVENT_TYPE_ADD

public static final int EVENT_TYPE_ADD
新增一个对象

另请参见：
常量字段值

EVENT_TYPE_EDIT

public static final int EVENT_TYPE_EDIT
修改指定对象

另请参见：
常量字段值

EVENT_TYPE_DELETE

public static final int EVENT_TYPE_DELETE
删除指定对象

另请参见：
常量字段值

EVENT_TYPE_TALBE_RELOAD

public static final int EVENT_TYPE_TALBE_RELOAD
表结构重新载入

另请参见：
常量字段值

MESSAGE_RELOAD_TABLE

public static final java.lang.String MESSAGE_RELOAD_TABLE
重新装入表的结构

另请参见：
常量字段值

MESSAGE_REMOVE_TABLE

public static final java.lang.String MESSAGE_REMOVE_TABLE
删除表的结构

另请参见：
常量字段值

MESSAGE_RREFRESH_PROPERTY

public static final java.lang.String MESSAGE_RREFRESH_PROPERTY
强制刷新Cache对象中的指定字段的值

另请参见：
常量字段值

MESSAGE_METADATA_APPCREATE

public static final java.lang.String MESSAGE_METADATA_APPCREATE
另请参见：
常量字段值

MESSAGE_FILE_MODIFIED

public static final java.lang.String MESSAGE_FILE_MODIFIED
文件更改消息

另请参见：
常量字段值

MESSAGE_FILE_WITHDRAW

public static final java.lang.String MESSAGE_FILE_WITHDRAW
发布文件撤除消息

另请参见：
常量字段值
构造方法详细信息

ClusterConstants

public ClusterConstants()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClusterMsgCenterImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
类 ClusterMsgCenterImpl

java.lang.Object
    继承者  com.trs.cluster.ClusterMsgCenterImpl
所有已实现的接口：
IClusterMsgCenter
public class ClusterMsgCenterImpl
extends java.lang.Object
implements IClusterMsgCenter

作者：
Administrator

构造方法摘要
ClusterMsgCenterImpl()
方法摘要
boolean | isStarted()
void | loadConfigs() 装载集群相关的配置
void | receive(int _nObjType, int _nObjId, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(int _nObjType, int _nObjId, int _nEventType, java.util.Hashtable _hProperties) 响应基于持久化对象拟定的消息
void | receive(java.lang.String _sContent, java.lang.String[] _pParameters) 响应自定义协议的消息
void | send(BaseObj _obj, int _nEventType)
void | send(int _nObjType, int _nObjId, int _nEventType, java.util.Hashtable _hProperties) 发送包含持久化对象的消息 仅仅只有非Cache对象删除时候需要传入Properties
void | send(java.lang.String _sContent, java.lang.String[] _pParameters) 发送出指定的消息，消息协议为自定义
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClusterMsgCenterImpl

public ClusterMsgCenterImpl()
方法详细信息

receive

public void receive(int _nObjType,
                    int _nObjId,
                    int _nEventType)
             throws java.lang.Exception
从接口 IClusterMsgCenter 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgCenter 中的 receive
抛出：
java.lang.Exception

receive

public void receive(int _nObjType,
                    int _nObjId,
                    int _nEventType,
                    java.util.Hashtable _hProperties)
             throws java.lang.Exception
从接口 IClusterMsgCenter 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgCenter 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String _sContent,
                    java.lang.String[] _pParameters)
             throws java.lang.Exception
从接口 IClusterMsgCenter 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgCenter 中的 receive
抛出：
java.lang.Exception

send

public void send(int _nObjType,
                 int _nObjId,
                 int _nEventType,
                 java.util.Hashtable _hProperties)
          throws java.lang.Exception
发送包含持久化对象的消息 仅仅只有非Cache对象删除时候需要传入Properties

指定者：
接口 IClusterMsgCenter 中的 send
参数：
_nObjType -
_nObjId -
_nEventType -
_hProperties - 仅仅只有非Cache对象删除时候需要传入Properties
抛出：
java.lang.Exception

send

public void send(java.lang.String _sContent,
                 java.lang.String[] _pParameters)
          throws java.lang.Exception
从接口 IClusterMsgCenter 复制的描述
发送出指定的消息，消息协议为自定义

指定者：
接口 IClusterMsgCenter 中的 send
抛出：
java.lang.Exception

loadConfigs

public void loadConfigs()
                 throws java.lang.Exception
从接口 IClusterMsgCenter 复制的描述
装载集群相关的配置

指定者：
接口 IClusterMsgCenter 中的 loadConfigs
抛出：
java.lang.Exception

isStarted

public boolean isStarted()
指定者：
接口 IClusterMsgCenter 中的 isStarted

send

public void send(BaseObj _obj,
                 int _nEventType)
          throws java.lang.Exception
指定者：
接口 IClusterMsgCenter 中的 send
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileMsgProcessor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
类 FileMsgProcessor

java.lang.Object
    继承者  com.trs.cluster.FileMsgProcessor

public class FileMsgProcessor
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文件更改集群消息处理工具类:没有在ClusterMsgCenterImpl处理是为了调用方便
一般地,修改文件后需要重启应用.
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
FileMsgProcessor()
方法摘要
static void send(java.lang.String filename)
更改消息发送
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileMsgProcessor

public FileMsgProcessor()
方法详细信息

send

public static void send(java.lang.String filename)
更改消息发送

参数：
filename - 更改的文件名(全路径)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IClusterMsgCenter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
接口 IClusterMsgCenter

所有已知实现类：
ClusterMsgCenterImpl
public interface IClusterMsgCenter

作者：
Administrator

方法摘要
boolean | isStarted()
void | loadConfigs() 装载集群相关的配置
void | receive(int _nObjType, int _nObjId, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(int _nObjType, int _nObjId, int _nEventType, java.util.Hashtable _hProperties) 响应基于持久化对象拟定的消息
void | receive(java.lang.String _sContent, java.lang.String[] _pParameters) 响应自定义协议的消息
void | send(BaseObj _obj, int _nEventType)
void | send(int _nObjType, int _nObjId, int _nEventType, java.util.Hashtable _hProperties) 发送出指定的消息，消息协议为基于持久化对象拟定
void | send(java.lang.String _sContent, java.lang.String[] _sParameters) 发送出指定的消息，消息协议为自定义

方法详细信息

send

void send(int _nObjType,
          int _nObjId,
          int _nEventType,
          java.util.Hashtable _hProperties)
          throws java.lang.Exception
发送出指定的消息，消息协议为基于持久化对象拟定

参数：
_nObjType -
_nObjId -
_nEventType -
_hProperties -
抛出：
java.lang.Exception

send

void send(BaseObj _obj,
          int _nEventType)
          throws java.lang.Exception
参数：
_obj -
_nEventType -
抛出：
java.lang.Exception

send

void send(java.lang.String _sContent,
          java.lang.String[] _sParameters)
          throws java.lang.Exception
发送出指定的消息，消息协议为自定义

参数：
_sContent -
_sParameters -
抛出：
java.lang.Exception

receive

void receive(int _nObjType,
             int _nObjId,
             int _nEventType)
             throws java.lang.Exception
响应基于持久化对象拟定的消息

参数：
_oEventObject -
_nEventType -
抛出：
java.lang.Exception

receive

void receive(int _nObjType,
             int _nObjId,
             int _nEventType,
             java.util.Hashtable _hProperties)
             throws java.lang.Exception
响应基于持久化对象拟定的消息

参数：
_nObjType -
_nObjId -
_nEventType -
_hProperties -
抛出：
java.lang.Exception

receive

void receive(java.lang.String _sContent,
             java.lang.String[] _pParameters)
             throws java.lang.Exception
响应自定义协议的消息

参数：
_sContent -
_nEventType -
抛出：
java.lang.Exception

loadConfigs

void loadConfigs()
                 throws java.lang.Exception
装载集群相关的配置

抛出：
java.lang.Exception

isStarted

boolean isStarted()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IClusterMsgReceiver

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
接口 IClusterMsgReceiver

所有已知实现类：
ChnlDeptMgrForCluster, DBMsgReceiver, FileWithdrawMsgReceiver, MetaAppCreateMsgReceiver, ObjectLCMsgReceiver, ObjectMemberMgrForCluster, RefreshPropertyMsgReceiver, TableInfosMsgReceiver
public interface IClusterMsgReceiver

作者：
CH

方法摘要
void | receive(BaseObj _oEventObject, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String _sContent, java.lang.String[] _pParameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作

方法详细信息

receive

void receive(BaseObj _oEventObject,
             int _nEventType)
             throws java.lang.Exception
响应基于持久化对象拟定的消息

参数：
_oEventObject -
_nEventType -
抛出：
java.lang.Exception

receive

void receive(java.lang.String _sContent,
             java.lang.String[] _pParameters)
             throws java.lang.Exception
响应自定义协议的消息

参数：
_sContent -
_sParameters -
抛出：
java.lang.Exception

registerMoniterWCMObjTypesOnAdd

int[] registerMoniterWCMObjTypesOnAdd()
当新增那些持久化对象时候触发操作

返回：

registerMoniterWCMObjTypesOnDel

int[] registerMoniterWCMObjTypesOnDel()
当删除那些持久化对象时候触发操作

返回：

registerMoniterWCMObjTypesOnModify

int[] registerMoniterWCMObjTypesOnModify()
当修改那些持久化对象时候触发操作

返回：

registerMoniterMessages

java.lang.String[] registerMoniterMessages()
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IClusterMsgSender

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
接口 IClusterMsgSender

public interface IClusterMsgSender

作者：
CH

方法摘要
void | send(int _nObjType, int _nObjId, int _nEventType) 发送出指定的消息，消息协议为基于持久化对象拟定
void | send(java.lang.String _sContent, int _nEventType) 发送出指定的消息，消息协议为自定义

方法详细信息

send

void send(int _nObjType,
          int _nObjId,
          int _nEventType)
          throws java.lang.Exception
发送出指定的消息，消息协议为基于持久化对象拟定

参数：
_nObjType -
_nObjId -
_nEventType -
抛出：
java.lang.Exception

send

void send(java.lang.String _sContent,
          int _nEventType)
          throws java.lang.Exception
发送出指定的消息，消息协议为自定义

参数：
_sContent -
_nEventType -
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cluster
接口
IClusterMsgCenter
IClusterMsgReceiver
IClusterMsgSender
类
ClusterConfigHelper
ClusterConstants
ClusterMsgCenterImpl
FileMsgProcessor
TRSClusterExtensionImpl
TRSWCMClusterServer


com.trs.cluster

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cluster

接口摘要
IClusterMsgCenter
IClusterMsgReceiver
IClusterMsgSender

类摘要
ClusterConfigHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ClusterConstants |
ClusterMsgCenterImpl |
FileMsgProcessor | Title: TRS 内容协作平台（TRS WCM） Description: 文件更改集群消息处理工具类:没有在ClusterMsgCenterImpl处理是为了调用方便 一般地,修改文件后需要重启应用.
TRSClusterExtensionImpl |
TRSWCMClusterServer |


com.trs.cluster 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cluster 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.cluster.TRSWCMClusterServer
    • com.trs.cluster.ClusterConfigHelper
    • com.trs.cluster.ClusterConstants
    • com.trs.cluster.ClusterMsgCenterImpl (implements com.trs.cluster.IClusterMsgCenter)
    • com.trs.cluster.FileMsgProcessor
    • com.trs.cluster.TRSClusterExtensionImpl (implements com.trs.infra.cluster.Extension)

接口分层结构

  • com.trs.cluster.IClusterMsgCenter
  • com.trs.cluster.IClusterMsgReceiver
  • com.trs.cluster.IClusterMsgSender


软件包 com.trs.cluster 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cluster
的使用

使用 com.trs.cluster 的软件包
com.trs.cluster
com.trs.cluster.receiver
com.trs.cms.auth.domain
com.trs.components.stat

com.trs.cluster 使用的 com.trs.cluster 中的类
IClusterMsgCenter

com.trs.cluster.receiver 使用的 com.trs.cluster 中的类
IClusterMsgReceiver

com.trs.cms.auth.domain 使用的 com.trs.cluster 中的类
IClusterMsgReceiver

com.trs.components.stat 使用的 com.trs.cluster 中的类
IClusterMsgReceiver

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TRSClusterExtensionImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
类 TRSClusterExtensionImpl

java.lang.Object
    继承者  com.trs.cluster.TRSClusterExtensionImpl
所有已实现的接口：
com.trs.infra.cluster.Extension
public class TRSClusterExtensionImpl
extends java.lang.Object
implements com.trs.infra.cluster.Extension

作者：
Administrator

构造方法摘要
TRSClusterExtensionImpl(java.lang.String _sExtensionId)
方法摘要
java.lang.Object | callByCluster(java.lang.Object _oArgs, com.trs.infra.cluster.Member _oCaller)
java.lang.String | getExtensionId()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSClusterExtensionImpl

public TRSClusterExtensionImpl(java.lang.String _sExtensionId)
方法详细信息

callByCluster

public java.lang.Object callByCluster(java.lang.Object _oArgs,
                                      com.trs.infra.cluster.Member _oCaller)
指定者：
接口 com.trs.infra.cluster.Extension 中的 callByCluster

getExtensionId

public java.lang.String getExtensionId()
指定者：
接口 com.trs.infra.cluster.Extension 中的 getExtensionId
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSWCMClusterServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster
类 TRSWCMClusterServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.cluster.TRSWCMClusterServer
所有已实现的接口：
IServer
public class TRSWCMClusterServer
extends BaseServer

作者：
Administrator

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
TRSWCMClusterServer()
方法摘要
com.trs.infra.cluster.ClusterContext | getContext()
void | sendMsg(java.io.Serializable _args) 发送消息
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSWCMClusterServer

public TRSWCMClusterServer()
方法详细信息

sendMsg

public void sendMsg(java.io.Serializable _args)
发送消息

参数：
_args -

getContext

public com.trs.infra.cluster.ClusterContext getContext()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cluster.ClusterConfigHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.ClusterConfigHelper
的使用

没有 com.trs.cluster.ClusterConfigHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.ClusterConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.ClusterConstants
的使用

没有 com.trs.cluster.ClusterConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.ClusterMsgCenterImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.ClusterMsgCenterImpl
的使用

没有 com.trs.cluster.ClusterMsgCenterImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.FileMsgProcessor 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.FileMsgProcessor
的使用

没有 com.trs.cluster.FileMsgProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cluster.IClusterMsgCenter 的使用

上一个 下一个 框架 无框架

接口 com.trs.cluster.IClusterMsgCenter
的使用

使用 IClusterMsgCenter 的软件包
com.trs.cluster

com.trs.cluster 中 IClusterMsgCenter 的使用

实现 IClusterMsgCenter 的 com.trs.cluster 中的类
 class ClusterMsgCenterImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cluster.IClusterMsgReceiver 的使用

上一个 下一个 框架 无框架

接口 com.trs.cluster.IClusterMsgReceiver
的使用

使用 IClusterMsgReceiver 的软件包
com.trs.cluster.receiver
com.trs.cms.auth.domain
com.trs.components.stat

com.trs.cluster.receiver 中 IClusterMsgReceiver 的使用

实现 IClusterMsgReceiver 的 com.trs.cluster.receiver 中的类
class | DBMsgReceiver
class | FileWithdrawMsgReceiver Title: TRS 内容协作平台（TRS WCM） Description: 文件撤除消息处理 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | MetaAppCreateMsgReceiver Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ObjectLCMsgReceiver
class | RefreshPropertyMsgReceiver
class | TableInfosMsgReceiver

com.trs.cms.auth.domain 中 IClusterMsgReceiver 的使用

实现 IClusterMsgReceiver 的 com.trs.cms.auth.domain 中的类
 class ObjectMemberMgrForCluster
ObjectMember缓冲处理.接收集群消息,根据相应的操作刷新缓冲.

com.trs.components.stat 中 IClusterMsgReceiver 的使用

实现 IClusterMsgReceiver 的 com.trs.components.stat 中的类
 class ChnlDeptMgrForCluster
Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDept缓冲处理.接收集群消息,根据相应的操作刷新缓冲.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cluster.IClusterMsgSender 的使用

上一个 下一个 框架 无框架

接口 com.trs.cluster.IClusterMsgSender
的使用

没有 com.trs.cluster.IClusterMsgSender 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.TRSClusterExtensionImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.TRSClusterExtensionImpl
的使用

没有 com.trs.cluster.TRSClusterExtensionImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.TRSWCMClusterServer 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.TRSWCMClusterServer
的使用

没有 com.trs.cluster.TRSWCMClusterServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DBMsgReceiver

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster.receiver
类 DBMsgReceiver

java.lang.Object
    继承者  com.trs.cluster.receiver.DBMsgReceiver
所有已实现的接口：
IClusterMsgReceiver
public class DBMsgReceiver
extends java.lang.Object
implements IClusterMsgReceiver

作者：
Administrator

构造方法摘要
DBMsgReceiver()
方法摘要
void | receive(BaseObj _oEventObject, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String _sContent, java.lang.String[] _pParameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBMsgReceiver

public DBMsgReceiver()
方法详细信息

receive

public void receive(BaseObj _oEventObject,
                    int _nEventType)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String _sContent,
                    java.lang.String[] _pParameters)
             throws WCMException
从接口 IClusterMsgReceiver 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
WCMException

registerMoniterMessages

public java.lang.String[] registerMoniterMessages()
从接口 IClusterMsgReceiver 复制的描述
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterMessages
返回：

registerMoniterWCMObjTypesOnAdd

public int[] registerMoniterWCMObjTypesOnAdd()
从接口 IClusterMsgReceiver 复制的描述
当新增那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnAdd
返回：

registerMoniterWCMObjTypesOnDel

public int[] registerMoniterWCMObjTypesOnDel()
从接口 IClusterMsgReceiver 复制的描述
当删除那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnDel
返回：

registerMoniterWCMObjTypesOnModify

public int[] registerMoniterWCMObjTypesOnModify()
从接口 IClusterMsgReceiver 复制的描述
当修改那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnModify
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FileWithdrawMsgReceiver

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster.receiver
类 FileWithdrawMsgReceiver

java.lang.Object
    继承者  com.trs.cluster.receiver.FileWithdrawMsgReceiver
所有已实现的接口：
IClusterMsgReceiver
public class FileWithdrawMsgReceiver
extends java.lang.Object
implements IClusterMsgReceiver

Title: TRS 内容协作平台（TRS WCM）
Description:
文件撤除消息处理
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
FileWithdrawMsgReceiver()
方法摘要
static void | main(java.lang.String[] args)
void | receive(BaseObj eventObject, int eventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String content, java.lang.String[] parameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileWithdrawMsgReceiver

public FileWithdrawMsgReceiver()
方法详细信息

receive

public void receive(BaseObj eventObject,
                    int eventType)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String content,
                    java.lang.String[] parameters)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

registerMoniterMessages

public java.lang.String[] registerMoniterMessages()
从接口 IClusterMsgReceiver 复制的描述
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterMessages
返回：

registerMoniterWCMObjTypesOnAdd

public int[] registerMoniterWCMObjTypesOnAdd()
从接口 IClusterMsgReceiver 复制的描述
当新增那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnAdd
返回：

registerMoniterWCMObjTypesOnDel

public int[] registerMoniterWCMObjTypesOnDel()
从接口 IClusterMsgReceiver 复制的描述
当删除那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnDel
返回：

registerMoniterWCMObjTypesOnModify

public int[] registerMoniterWCMObjTypesOnModify()
从接口 IClusterMsgReceiver 复制的描述
当修改那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnModify
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaAppCreateMsgReceiver

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster.receiver
类 MetaAppCreateMsgReceiver

java.lang.Object
    继承者  com.trs.cluster.receiver.MetaAppCreateMsgReceiver
所有已实现的接口：
IClusterMsgReceiver
public class MetaAppCreateMsgReceiver
extends java.lang.Object
implements IClusterMsgReceiver

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
MetaAppCreateMsgReceiver()
方法摘要
void | receive(BaseObj eventObject, int eventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String content, java.lang.String[] parameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaAppCreateMsgReceiver

public MetaAppCreateMsgReceiver()
方法详细信息

receive

public void receive(BaseObj eventObject,
                    int eventType)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String content,
                    java.lang.String[] parameters)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

registerMoniterMessages

public java.lang.String[] registerMoniterMessages()
从接口 IClusterMsgReceiver 复制的描述
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterMessages
返回：

registerMoniterWCMObjTypesOnAdd

public int[] registerMoniterWCMObjTypesOnAdd()
从接口 IClusterMsgReceiver 复制的描述
当新增那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnAdd
返回：

registerMoniterWCMObjTypesOnDel

public int[] registerMoniterWCMObjTypesOnDel()
从接口 IClusterMsgReceiver 复制的描述
当删除那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnDel
返回：

registerMoniterWCMObjTypesOnModify

public int[] registerMoniterWCMObjTypesOnModify()
从接口 IClusterMsgReceiver 复制的描述
当修改那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnModify
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectLCMsgReceiver

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster.receiver
类 ObjectLCMsgReceiver

java.lang.Object
    继承者  com.trs.cluster.receiver.ObjectLCMsgReceiver
所有已实现的接口：
IClusterMsgReceiver
public class ObjectLCMsgReceiver
extends java.lang.Object
implements IClusterMsgReceiver

作者：
Administrator

字段摘要
static java.lang.String[] LISTENER_NAMES
构造方法摘要
ObjectLCMsgReceiver()
方法摘要
void | receive(BaseObj _oEventObject, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String _sContent, java.lang.String[] _pParameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LISTENER_NAMES

public static final java.lang.String[] LISTENER_NAMES
构造方法详细信息

ObjectLCMsgReceiver

public ObjectLCMsgReceiver()
方法详细信息

receive

public void receive(BaseObj _oEventObject,
                    int _nEventType)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String _sContent,
                    java.lang.String[] _pParameters)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

registerMoniterMessages

public java.lang.String[] registerMoniterMessages()
从接口 IClusterMsgReceiver 复制的描述
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterMessages
返回：

registerMoniterWCMObjTypesOnAdd

public int[] registerMoniterWCMObjTypesOnAdd()
从接口 IClusterMsgReceiver 复制的描述
当新增那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnAdd
返回：

registerMoniterWCMObjTypesOnDel

public int[] registerMoniterWCMObjTypesOnDel()
从接口 IClusterMsgReceiver 复制的描述
当删除那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnDel
返回：

registerMoniterWCMObjTypesOnModify

public int[] registerMoniterWCMObjTypesOnModify()
从接口 IClusterMsgReceiver 复制的描述
当修改那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnModify
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cluster.receiver
类
DBMsgReceiver
FileWithdrawMsgReceiver
MetaAppCreateMsgReceiver
ObjectLCMsgReceiver
RefreshPropertyMsgReceiver
TableInfosMsgReceiver


com.trs.cluster.receiver

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cluster.receiver

类摘要
DBMsgReceiver |
FileWithdrawMsgReceiver | Title: TRS 内容协作平台（TRS WCM） Description: 文件撤除消息处理 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
MetaAppCreateMsgReceiver | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ObjectLCMsgReceiver |
RefreshPropertyMsgReceiver |
TableInfosMsgReceiver |


com.trs.cluster.receiver 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cluster.receiver 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cluster.receiver.DBMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.cluster.receiver.FileWithdrawMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.cluster.receiver.MetaAppCreateMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.cluster.receiver.ObjectLCMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.cluster.receiver.RefreshPropertyMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.cluster.receiver.TableInfosMsgReceiver (implements com.trs.cluster.IClusterMsgReceiver)


软件包 com.trs.cluster.receiver 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cluster.receiver
的使用

没有 com.trs.cluster.receiver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RefreshPropertyMsgReceiver

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster.receiver
类 RefreshPropertyMsgReceiver

java.lang.Object
    继承者  com.trs.cluster.receiver.RefreshPropertyMsgReceiver
所有已实现的接口：
IClusterMsgReceiver
public class RefreshPropertyMsgReceiver
extends java.lang.Object
implements IClusterMsgReceiver

作者：
Administrator

构造方法摘要
RefreshPropertyMsgReceiver()
方法摘要
void | receive(BaseObj _oEventObject, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String _sContent, java.lang.String[] _pParameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RefreshPropertyMsgReceiver

public RefreshPropertyMsgReceiver()
方法详细信息

receive

public void receive(BaseObj _oEventObject,
                    int _nEventType)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String _sContent,
                    java.lang.String[] _pParameters)
             throws WCMException
从接口 IClusterMsgReceiver 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
WCMException

registerMoniterMessages

public java.lang.String[] registerMoniterMessages()
从接口 IClusterMsgReceiver 复制的描述
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterMessages
返回：

registerMoniterWCMObjTypesOnAdd

public int[] registerMoniterWCMObjTypesOnAdd()
从接口 IClusterMsgReceiver 复制的描述
当新增那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnAdd
返回：

registerMoniterWCMObjTypesOnDel

public int[] registerMoniterWCMObjTypesOnDel()
从接口 IClusterMsgReceiver 复制的描述
当删除那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnDel
返回：

registerMoniterWCMObjTypesOnModify

public int[] registerMoniterWCMObjTypesOnModify()
从接口 IClusterMsgReceiver 复制的描述
当修改那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnModify
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableInfosMsgReceiver

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cluster.receiver
类 TableInfosMsgReceiver

java.lang.Object
    继承者  com.trs.cluster.receiver.TableInfosMsgReceiver
所有已实现的接口：
IClusterMsgReceiver
public class TableInfosMsgReceiver
extends java.lang.Object
implements IClusterMsgReceiver

作者：
Administrator

构造方法摘要
TableInfosMsgReceiver()
方法摘要
void | receive(BaseObj _oEventObject, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String _sContent, java.lang.String[] _pParameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableInfosMsgReceiver

public TableInfosMsgReceiver()
方法详细信息

receive

public void receive(BaseObj _oEventObject,
                    int _nEventType)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String _sContent,
                    java.lang.String[] _pParameters)
             throws WCMException
从接口 IClusterMsgReceiver 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
WCMException

registerMoniterMessages

public java.lang.String[] registerMoniterMessages()
从接口 IClusterMsgReceiver 复制的描述
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterMessages
返回：

registerMoniterWCMObjTypesOnAdd

public int[] registerMoniterWCMObjTypesOnAdd()
从接口 IClusterMsgReceiver 复制的描述
当新增那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnAdd
返回：

registerMoniterWCMObjTypesOnDel

public int[] registerMoniterWCMObjTypesOnDel()
从接口 IClusterMsgReceiver 复制的描述
当删除那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnDel
返回：

registerMoniterWCMObjTypesOnModify

public int[] registerMoniterWCMObjTypesOnModify()
从接口 IClusterMsgReceiver 复制的描述
当修改那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnModify
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cluster.receiver.DBMsgReceiver 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.receiver.DBMsgReceiver
的使用

没有 com.trs.cluster.receiver.DBMsgReceiver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.receiver.FileWithdrawMsgReceiver
的使用

没有 com.trs.cluster.receiver.FileWithdrawMsgReceiver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver
的使用

没有 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.receiver.ObjectLCMsgReceiver 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.receiver.ObjectLCMsgReceiver
的使用

没有 com.trs.cluster.receiver.ObjectLCMsgReceiver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver
的使用

没有 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cluster.receiver.TableInfosMsgReceiver 的使用

上一个 下一个 框架 无框架

类 com.trs.cluster.receiver.TableInfosMsgReceiver
的使用

没有 com.trs.cluster.receiver.TableInfosMsgReceiver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CMSConstants

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms
类 CMSConstants

java.lang.Object
    继承者  com.trs.cms.CMSConstants

public class CMSConstants
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | CONTENT_BODY_FILE content body type: external file
static int | CONTENT_BODY_HTML content body type：HTML
static int | CONTENT_BODY_LINK content body type：link
static int | CONTENT_BODY_NORMAL content body type：normal (text)
static int | CONTENT_BODY_UNKNOWN content body type：unknown
static int | CONTENT_MODAL_COPY
static int | CONTENT_MODAL_ENTITY content modal: as an entity, whose substance is stored in the current folder
static int | CONTENT_MODAL_LINK content modal: as a link in the current folder, whose substance is stored in another folder and has the same view.
static int | CONTENT_MODAL_MIRROR content modal: as a mirror, whose substance is stored in another folder but has different views.
static int | CONTENT_MODAL_QUOTE
static int | CONTENT_MODAL_UNKNOWN content modal: unknown
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CONTENT_BODY_UNKNOWN

public static final int CONTENT_BODY_UNKNOWN
content body type：unknown

另请参见：
常量字段值

CONTENT_BODY_NORMAL

public static final int CONTENT_BODY_NORMAL
content body type：normal (text)

另请参见：
常量字段值

CONTENT_BODY_HTML

public static final int CONTENT_BODY_HTML
content body type：HTML

另请参见：
常量字段值

CONTENT_BODY_LINK

public static final int CONTENT_BODY_LINK
content body type：link

另请参见：
常量字段值

CONTENT_BODY_FILE

public static final int CONTENT_BODY_FILE
content body type: external file

另请参见：
常量字段值

CONTENT_MODAL_UNKNOWN

public static final int CONTENT_MODAL_UNKNOWN
content modal: unknown

另请参见：
常量字段值

CONTENT_MODAL_ENTITY

public static final int CONTENT_MODAL_ENTITY
content modal: as an entity, whose substance is stored in the current folder

另请参见：
常量字段值

CONTENT_MODAL_LINK

public static final int CONTENT_MODAL_LINK
content modal: as a link in the current folder, whose substance is stored in another folder and has the same view.

另请参见：
常量字段值

CONTENT_MODAL_MIRROR

public static final int CONTENT_MODAL_MIRROR
content modal: as a mirror, whose substance is stored in another folder but has different views.

另请参见：
常量字段值

CONTENT_MODAL_COPY

public static final int CONTENT_MODAL_COPY
另请参见：
常量字段值

CONTENT_MODAL_QUOTE

public static final int CONTENT_MODAL_QUOTE
另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ContextHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms
类 ContextHelper

java.lang.Object
    继承者  com.trs.cms.ContextHelper

public class ContextHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
使用ThreadLocal方式在各个功能模块间传递参数的管理模块
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContextHelper()
方法摘要
static void | clear()
static java.lang.Object | getArg(int _nIndex) 获得扩展参数列表中第_nIndex位置上的参数 处理策略： 1.
static User | getLoginUser() 获得当前线程的登录用户，委托给ContextTL 处理策略： 1.
static org.apache.batik.dom.util.HashTable | getTestValues() 获得当前线程的登录用户，委托给ContextTL 处理策略： 1.
static void | initContext(User _loginUser) 初始化时，同时初始化登录用户参数
static int | setArg(int _nIndex, java.lang.Object _currObj) 在扩展参数列表的第_nIndex个位置设置参数对象_currObj 处理策略： 1.
static void | setLoginUser(User _currUser) 设置当前线程的登录用户
static void | setTestValues(org.apache.batik.dom.util.HashTable _hValues) 设置当前线程的登录用户
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContextHelper

public ContextHelper()
方法详细信息

initContext

public static void initContext(User _loginUser)
初始化时，同时初始化登录用户参数

getLoginUser

public static User getLoginUser()
获得当前线程的登录用户，委托给ContextTL 处理策略：
1. 接口为静态方法

返回：
当共享参数存在时，直接返回ContextTL的loginUser（当前登录用户）；当共享参数不存在时，返回空（NULL）

setLoginUser

public static void setLoginUser(User _currUser)
设置当前线程的登录用户

参数：
_currUser - 登录用户

getTestValues

public static org.apache.batik.dom.util.HashTable getTestValues()
获得当前线程的登录用户，委托给ContextTL 处理策略：
1. 接口为静态方法

返回：
当共享参数存在时，直接返回ContextTL的loginUser（当前登录用户）；当共享参数不存在时，返回空（NULL）

setTestValues

public static void setTestValues(org.apache.batik.dom.util.HashTable _hValues)
设置当前线程的登录用户

参数：
_currUser - 登录用户

getArg

public static java.lang.Object getArg(int _nIndex)
获得扩展参数列表中第_nIndex位置上的参数 处理策略：
1. 从ArrayList中定位到第_nIndex个位置 2. 取出来的对象使用前要做类型强制转换

参数：
_nIndex - ：扩展参数列表中参数的存放位置
返回：
如果指定位置上有对象，则返回该对象；如果没有则返回NULL（异常？）

setArg

public static int setArg(int _nIndex,
                         java.lang.Object _currObj)
在扩展参数列表的第_nIndex个位置设置参数对象_currObj 处理策略：
1. 如果该位置上已经存在参数，则替换原有参数

参数：
_nIndex - ：扩展参数列表中的位置
_currObj - ：设置的参数

clear

public static void clear()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectTypeServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms
类 ObjectTypeServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.cms.ObjectTypeServer
所有已实现的接口：
IServer
public class ObjectTypeServer
extends BaseServer

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
ObjectTypeServer()
方法摘要
static java.lang.Class | get(int _nObjType)
static void | register(java.lang.Class _oClazz)
static void | register(int _nObjType, java.lang.Class _oClazz)
static void | register(java.lang.Integer _oObjType, java.lang.Class _oClazz)
static void | register(int _nObjType, java.lang.String _sClazz)
void | register(java.lang.String _sClazz)
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectTypeServer

public ObjectTypeServer()
方法详细信息

register

public void register(java.lang.String _sClazz)

register

public static void register(java.lang.Class _oClazz)

register

public static void register(int _nObjType,
                            java.lang.String _sClazz)

register

public static void register(int _nObjType,
                            java.lang.Class _oClazz)

register

public static void register(java.lang.Integer _oObjType,
                            java.lang.Class _oClazz)

get

public static java.lang.Class get(int _nObjType)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms
类
CMSConstants
ContextHelper
ObjectTypeServer


com.trs.cms

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms

类摘要
CMSConstants | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContextHelper | Title: TRS 内容协作平台（TRS WCM） Description: 使用ThreadLocal方式在各个功能模块间传递参数的管理模块 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectTypeServer |


com.trs.cms 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.cms.ObjectTypeServer
    • com.trs.cms.CMSConstants
    • com.trs.cms.ContextHelper


软件包 com.trs.cms 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms
的使用

没有 com.trs.cms 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AuthHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth
类 AuthHelper

java.lang.Object
    继承者  com.trs.cms.auth.AuthHelper

public class AuthHelper
extends java.lang.Object

构造方法摘要
AuthHelper()
方法摘要
static boolean | hasRightOnSelf(User _currUser, CMSObj _objCurrent, int[] _pRightIndex)
static boolean | hasSuperRight(User _currUser, CMSObj _currObj)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AuthHelper

public AuthHelper()
方法详细信息

hasSuperRight

public static boolean hasSuperRight(User _currUser,
                                    CMSObj _currObj)
                             throws WCMException
参数：
_currUser - 当前操作用户
_currObj - 当前对象
返回：
抛出：
WCMException

hasRightOnSelf

public static boolean hasRightOnSelf(User _currUser,
                                     CMSObj _objCurrent,
                                     int[] _pRightIndex)
                              throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.auth
类
AuthHelper


com.trs.cms.auth

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.auth

类摘要
AuthHelper


com.trs.cms.auth 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.auth.AuthHelper


软件包 com.trs.cms.auth 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth
的使用

没有 com.trs.cms.auth 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.AuthHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.AuthHelper
的使用

没有 com.trs.cms.auth.AuthHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


OperationConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.config
类 OperationConfig

java.lang.Object
    继承者  com.trs.cms.auth.config.OperationConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class OperationConfig
extends java.lang.Object
implements IConfigElement

字段摘要
static int MAX_OPERATION_COUNT
构造方法摘要
OperationConfig()
方法摘要
OperationRelatedConfig | getDepends()
java.lang.String | getDesc()
java.lang.String | getDispName()
OperationRelatedConfig | getIncludeOperations()
int | getIndex()
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getType()
void | setDepends(OperationRelatedConfig depends)
void | setDesc(java.lang.String desc)
void | setDispName(java.lang.String _sDispName)
void | setIncludeOperations(OperationRelatedConfig includeOperations)
void | setIndex(int index)
void | setName(java.lang.String name) 设置配置对象的名称
void | setType(java.lang.String type)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

MAX_OPERATION_COUNT

public static final int MAX_OPERATION_COUNT
另请参见：
常量字段值
构造方法详细信息

OperationConfig

public OperationConfig()
方法详细信息

getIndex

public int getIndex()

setIndex

public void setIndex(int index)

getDesc

public java.lang.String getDesc()

setDesc

public void setDesc(java.lang.String desc)

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

setName

public void setName(java.lang.String name)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
name - 配置对象的名称

getDepends

public OperationRelatedConfig getDepends()

setDepends

public void setDepends(OperationRelatedConfig depends)

getIncludeOperations

public OperationRelatedConfig getIncludeOperations()

setIncludeOperations

public void setIncludeOperations(OperationRelatedConfig includeOperations)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getDispName

public java.lang.String getDispName()

setDispName

public void setDispName(java.lang.String _sDispName)

getType

public java.lang.String getType()
返回：

setType

public void setType(java.lang.String type)
参数：
type -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


OperationDefineOnCurrChannelConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.config
类 OperationDefineOnCurrChannelConfig

java.lang.Object
    继承者  com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class OperationDefineOnCurrChannelConfig
extends java.lang.Object
implements IConfigElement

构造方法摘要
OperationDefineOnCurrChannelConfig()
方法摘要
java.lang.String | getName() 获取配置对象的名称
java.util.ArrayList | getOperations()
int | getSiteId() 获取相关站点ID
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setOperations(java.util.ArrayList operations)
void | setSiteId(int siteId) 设置相关站点ID
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OperationDefineOnCurrChannelConfig

public OperationDefineOnCurrChannelConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getOperations

public java.util.ArrayList getOperations()

setOperations

public void setOperations(java.util.ArrayList operations)

getSiteId

public int getSiteId()
获取相关站点ID

返回：

setSiteId

public void setSiteId(int siteId)
设置相关站点ID

参数：
siteId -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OperationRelatedConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.config
类 OperationRelatedConfig

java.lang.Object
    继承者  com.trs.cms.auth.config.OperationRelatedConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class OperationRelatedConfig
extends java.lang.Object
implements IConfigElement

构造方法摘要
OperationRelatedConfig()
方法摘要
java.lang.String | getName() 获取配置对象的名称
java.util.ArrayList | getOperations()
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setOperations(java.util.ArrayList operations)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OperationRelatedConfig

public OperationRelatedConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getOperations

public java.util.ArrayList getOperations()

setOperations

public void setOperations(java.util.ArrayList operations)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.auth.config
类
OperationConfig
OperationDefineOnCurrChannelConfig
OperationRelatedConfig
RightConfigServer
RightHostConfig
RightHostIndexsConfig
RightObjectConfig


com.trs.cms.auth.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.auth.config

类摘要
OperationConfig |
OperationDefineOnCurrChannelConfig |
OperationRelatedConfig |
RightConfigServer | Title: TRS 内容协作平台（TRS WCM） Description: 权限配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostConfig | Title: TRS 内容协作平台（TRS WCM） Description: Right Object实现配置信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostIndexsConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightObjectConfig | Title: TRS 内容协作平台（TRS WCM） Description: Right Object实现配置信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.cms.auth.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.cms.auth.config.RightConfigServer
    • com.trs.cms.auth.config.OperationConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.config.OperationRelatedConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.config.RightHostConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.config.RightHostIndexsConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.cms.auth.config.RightObjectConfig (implements com.trs.infra.config.persistent.IConfigElement)


软件包 com.trs.cms.auth.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth.config
的使用

使用 com.trs.cms.auth.config 的软件包
com.trs.cms.auth.config

com.trs.cms.auth.config 使用的 com.trs.cms.auth.config 中的类
OperationRelatedConfig
RightConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:
权限配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RightConfigServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.config
类 RightConfigServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.cms.auth.config.RightConfigServer
所有已实现的接口：
IServer
public class RightConfigServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
权限配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
RightConfigServer()
方法摘要
int[][] | getDependIndexs()
int[] | getDependIndexs(int _nOperationIndex)
static RightConfigServer | getInstance()
java.util.List | getOperationConfigs(java.lang.String _sTypeName)
int | getRightIndexByOperName(java.lang.String _sOperName)
int[] | getRightIndexDefineOnCurrChannel(int _nSiteId)
int[][] | getSimilarIndexs()
int[] | getSimilarIndexs(int _nOperationIndex)
IRightHost | makeRightHostInstance(int _nHostType)
IRightObj | makeRightObjectInstance(int _nObjType)
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightConfigServer

public RightConfigServer()
方法详细信息

getInstance

public static RightConfigServer getInstance()
返回：

makeRightObjectInstance

public IRightObj makeRightObjectInstance(int _nObjType)
参数：
_nObjType -
返回：

makeRightHostInstance

public IRightHost makeRightHostInstance(int _nHostType)
参数：
_nHostType -
返回：

getSimilarIndexs

public int[] getSimilarIndexs(int _nOperationIndex)

getDependIndexs

public int[] getDependIndexs(int _nOperationIndex)

getOperationConfigs

public java.util.List getOperationConfigs(java.lang.String _sTypeName)

getRightIndexByOperName

public int getRightIndexByOperName(java.lang.String _sOperName)

getRightIndexDefineOnCurrChannel

public int[] getRightIndexDefineOnCurrChannel(int _nSiteId)

getSimilarIndexs

public int[][] getSimilarIndexs()
返回：

getDependIndexs

public int[][] getDependIndexs()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightHostConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.config
类 RightHostConfig

java.lang.Object
    继承者  com.trs.cms.auth.config.RightHostConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class RightHostConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
Right Object实现配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightHostConfig()
方法摘要
java.lang.String | getClassName()
java.lang.String | getName() 获取配置对象的名称
IRightHost | getRightHost()
IRightHost | makeNewHostInstance() 构造一个新的RightHost实例
void | setClassName(java.lang.String className)
void | setName(java.lang.String _sName) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightHostConfig

public RightHostConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String className)
参数：
className -

makeNewHostInstance

public IRightHost makeNewHostInstance()
构造一个新的RightHost实例

返回：
一个新的RightHost实例

getRightHost

public IRightHost getRightHost()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightHostIndexsConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.config
类 RightHostIndexsConfig

java.lang.Object
    继承者  com.trs.cms.auth.config.RightHostIndexsConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class RightHostIndexsConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightHostIndexsConfig()
方法摘要
int | getBeginIndex()
int | getEndIndex()
int[] | getIndexs()
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getRangeIndexs()
void | setBeginIndex(int beginIndex)
void | setEndIndex(int endIndex)
void | setIndexs(int[] indexs)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setRangeIndexs(java.lang.String rangeIndexs)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightHostIndexsConfig

public RightHostIndexsConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getBeginIndex

public int getBeginIndex()
返回：

setBeginIndex

public void setBeginIndex(int beginIndex)
参数：
beginIndex -

getEndIndex

public int getEndIndex()
返回：

setEndIndex

public void setEndIndex(int endIndex)
参数：
endIndex -

getIndexs

public int[] getIndexs()
返回：

setIndexs

public void setIndexs(int[] indexs)
参数：
indexs -

getRangeIndexs

public java.lang.String getRangeIndexs()
返回：

setRangeIndexs

public void setRangeIndexs(java.lang.String rangeIndexs)
参数：
rangeIndexs -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightObjectConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.config
类 RightObjectConfig

java.lang.Object
    继承者  com.trs.cms.auth.config.RightObjectConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class RightObjectConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
Right Object实现配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightObjectConfig()
方法摘要
java.lang.String | getClassName()
java.lang.String | getName() 获取配置对象的名称
IRightObj | getRightObject()
IRightObj | makeNewHostInstance() 构造一个新的RightHost实例
void | setClassName(java.lang.String className)
void | setName(java.lang.String _sName) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightObjectConfig

public RightObjectConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String className)
参数：
className -

makeNewHostInstance

public IRightObj makeNewHostInstance()
构造一个新的RightHost实例

返回：
一个新的RightHost实例

getRightObject

public IRightObj getRightObject()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.auth.config.OperationConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.config.OperationConfig
的使用

没有 com.trs.cms.auth.config.OperationConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig
的使用

没有 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.config.OperationRelatedConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.config.OperationRelatedConfig
的使用

使用 OperationRelatedConfig 的软件包
com.trs.cms.auth.config

com.trs.cms.auth.config 中 OperationRelatedConfig 的使用

返回 OperationRelatedConfig 的 com.trs.cms.auth.config 中的方法
OperationRelatedConfig | OperationConfig.getDepends()
OperationRelatedConfig | OperationConfig.getIncludeOperations()

参数类型为 OperationRelatedConfig 的 com.trs.cms.auth.config 中的方法
void | OperationConfig.setDepends(OperationRelatedConfig depends)
void | OperationConfig.setIncludeOperations(OperationRelatedConfig includeOperations)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.config.RightConfigServer 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.config.RightConfigServer
的使用

使用 RightConfigServer 的软件包
com.trs.cms.auth.config

com.trs.cms.auth.config 中 RightConfigServer 的使用

返回 RightConfigServer 的 com.trs.cms.auth.config 中的方法
static RightConfigServer RightConfigServer.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.config.RightHostConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.config.RightHostConfig
的使用

没有 com.trs.cms.auth.config.RightHostConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.config.RightHostIndexsConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.config.RightHostIndexsConfig
的使用

没有 com.trs.cms.auth.config.RightHostIndexsConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.config.RightObjectConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.config.RightObjectConfig
的使用

没有 com.trs.cms.auth.config.RightObjectConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AuthServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 AuthServer

java.lang.Object
    继承者  com.trs.cms.auth.domain.AuthServer

public class AuthServer
extends java.lang.Object

作者：
han xiao 独立于domain和service的server

构造方法摘要
AuthServer()
方法摘要
static java.lang.String | getLogicalRightValue(CMSObj _currObj, User _currOpUser, int[] _rightIndexes) 获取当前逻辑权限值，包含了继承关系
static RightValue | getRightValue(CMSObj _currObj, CMSObj _currOperator) 获取当前操作权限值
static RightValue | getRightValue(CMSObj _currObj, User _currOpUser) 获取当前权限值
static boolean | hasAttributeRight(User _currUser) 判断当前用户对于系统属性是否具有进入权限
static boolean | hasExtendedRight(User _currUser)
static boolean | hasExtendedRight(User _currUser, int _nRightIndex)
static boolean | hasMgrDocSourceRight(User _currUser) 添加一个判断是否有管理文档来源的权限判断方法
static boolean | hasRight(CMSObj _operator, CMSObj _currObj, int _nRightIndex)
static boolean | hasRight(long _lRightValue, int _index)
static boolean | hasRight(RightValue aRightValue, int _index)
static boolean | hasRight(User _currUser, CMSObj _currObj) 判断用户对特定对象是否有“访问权限”
static boolean | hasRight(User _currUser, CMSObj _objCurrent, int _index) 判断当前用户对于指定的频道对象是否具有指定索引的权限
static boolean | hasRightInObjects(User _currUser, CMSBaseObjs _objects, int _index)
static boolean | hasRightOnSelf(User _currUser, CMSObj _objCurrent, int _index)
static boolean | hasRightOnSelf(User _currUser, int _nObjType, int _nObjId, int _index) 判断当前用户对指定的对象是否具有指定权限
static boolean | hasStatisticRight(User _currUser)
static boolean | hasStatisticRight(User _currUser, int _nRightIndex)
static boolean | hasSuperRight(User _currUser, CMSObj _currObj) Created: 2004-11-25 17:27:12 Last Modified: 2004-11-25/2004-11-25 Description: class AuthServer.java 判断当前用户是否有特权(用户是管理员,对象创建者等) wenyh
static boolean | isManagerOfUser(User _loginUser, User _dstUser) 判断当前用户loginUser是否可以管理用户_dstUser
static IRightHost | makeRightHost(int _nHostType, int _nHostId) 通过指定的HostType和HostId构造IRightHost的实现
static boolean | setSystemMgrRights(int _nObjId, java.util.List _currRightList)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AuthServer

public AuthServer()
方法详细信息

hasRight

public static boolean hasRight(User _currUser,
                               CMSObj _objCurrent,
                               int _index)
                        throws WCMException
判断当前用户对于指定的频道对象是否具有指定索引的权限

参数：
_currUser - 当前操作用户
_currChnl - 当前频道
_index - 权限索引
返回：
抛出：
WCMException

hasRightInObjects

public static boolean hasRightInObjects(User _currUser,
                                        CMSBaseObjs _objects,
                                        int _index)
                                 throws WCMException
参数：
_currUser -
_objects -
_index -
返回：
抛出：
WCMException

hasAttributeRight

public static boolean hasAttributeRight(User _currUser)
                                 throws WCMException
判断当前用户对于系统属性是否具有进入权限

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

hasExtendedRight

public static boolean hasExtendedRight(User _currUser)
                                throws WCMException
抛出：
WCMException

hasExtendedRight

public static boolean hasExtendedRight(User _currUser,
                                       int _nRightIndex)
                                throws WCMException
抛出：
WCMException

hasStatisticRight

public static boolean hasStatisticRight(User _currUser)
                                 throws WCMException
抛出：
WCMException

hasStatisticRight

public static boolean hasStatisticRight(User _currUser,
                                        int _nRightIndex)
                                 throws WCMException
抛出：
WCMException

hasRightOnSelf

public static boolean hasRightOnSelf(User _currUser,
                                     int _nObjType,
                                     int _nObjId,
                                     int _index)
                              throws WCMException
判断当前用户对指定的对象是否具有指定权限

参数：
_currUser - 当前操作用户
_objType - 对象类型
_objId - 对象ID
返回：
抛出：
WCMException

hasRightOnSelf

public static boolean hasRightOnSelf(User _currUser,
                                     CMSObj _objCurrent,
                                     int _index)
                              throws WCMException
抛出：
WCMException

hasRight

public static boolean hasRight(CMSObj _operator,
                               CMSObj _currObj,
                               int _nRightIndex)
                        throws WCMException
抛出：
WCMException

hasRight

public static boolean hasRight(RightValue aRightValue,
                               int _index)
                        throws WCMException
参数：
aRightValue -
_index -
返回：
抛出：
WCMException

hasRight

public static boolean hasRight(long _lRightValue,
                               int _index)

hasRight

public static boolean hasRight(User _currUser,
                               CMSObj _currObj)
                        throws WCMException
判断用户对特定对象是否有“访问权限”

参数：
_currUser -
_currObj -
返回：
抛出：
WCMException

hasSuperRight

public static boolean hasSuperRight(User _currUser,
                                    CMSObj _currObj)
                             throws WCMException
Created: 2004-11-25 17:27:12 Last Modified: 2004-11-25/2004-11-25 Description: class AuthServer.java 判断当前用户是否有特权(用户是管理员,对象创建者等) wenyh

参数：
_currUser - 当前操作用户
_currObj - 当前对象
返回：
抛出：
WCMException

setSystemMgrRights

public static boolean setSystemMgrRights(int _nObjId,
                                         java.util.List _currRightList)
                                  throws WCMException
抛出：
WCMException

makeRightHost

public static IRightHost makeRightHost(int _nHostType,
                                       int _nHostId)
                                throws WCMException
通过指定的HostType和HostId构造IRightHost的实现

参数：
_nHostType - 指定的Host类型
_nHostId - 指定的HostId
返回：
IRightHost的实现
抛出：
WCMException - 如果指定Type的元素对象没有实现IRightHost将会抛出异常

getRightValue

public static RightValue getRightValue(CMSObj _currObj,
                                       User _currOpUser)
                                throws WCMException
获取当前权限值

参数：
_currObj -
_currOpUser -
返回：
抛出：
WCMException

getRightValue

public static RightValue getRightValue(CMSObj _currObj,
                                       CMSObj _currOperator)
                                throws WCMException
获取当前操作权限值

参数：
_currObj -
_currOpUser -
返回：
抛出：
WCMException

getLogicalRightValue

public static java.lang.String getLogicalRightValue(CMSObj _currObj,
                                                    User _currOpUser,
                                                    int[] _rightIndexes)
                                             throws WCMException
获取当前逻辑权限值，包含了继承关系

参数：
_currObj -
_currOpUser -
_rightIndexes -
返回：
抛出：
WCMException

isManagerOfUser

public static boolean isManagerOfUser(User _loginUser,
                                      User _dstUser)
                               throws WCMException
判断当前用户loginUser是否可以管理用户_dstUser

参数：
_loginUser - 当前用户
_dstUser - 被管理的用户
返回：
抛出：
WCMException

hasMgrDocSourceRight

public static boolean hasMgrDocSourceRight(User _currUser)
                                    throws WCMException
添加一个判断是否有管理文档来源的权限判断方法

参数：
_currUser -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DepartmentMgrImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 DepartmentMgrImpl

java.lang.Object
    继承者  com.trs.cms.auth.domain.DepartmentMgrImpl
所有已实现的接口：
IDepartmentMgr
public class DepartmentMgrImpl
extends java.lang.Object
implements IDepartmentMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DepartmentMgrImpl()
方法摘要
java.lang.String | getDepartmentInfo(User _user) 获取指定用户的所属部门描述信息，多级默认以/分隔
java.lang.String | getDepartmentInfo(User _user, java.lang.String _sDelimit) 获取指定用户的所属部门描述信息，多级以_sDelimit指定的分隔符分开，默认为\
Groups | getDeptGroups(User _user) 获取指定用户所属的组织结构
Groups | getDeptGroupTree(User _user) 获取指定用户的所属部门组织树，按照树形结构组织
Group | getRootDepartmentGroup() 获取描述组织结构的根组织
boolean | isDepartmentAdmin(User _user) 判断用户是否是所在用户组的管理员
void | reload() 重新加载相关信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DepartmentMgrImpl

public DepartmentMgrImpl()
方法详细信息

getDeptGroups

public Groups getDeptGroups(User _user)
                     throws WCMException
从接口 IDepartmentMgr 复制的描述
获取指定用户所属的组织结构

指定者：
接口 IDepartmentMgr 中的 getDeptGroups
返回：
抛出：
WCMException

getDepartmentInfo

public java.lang.String getDepartmentInfo(User _user)
                                   throws WCMException
从接口 IDepartmentMgr 复制的描述
获取指定用户的所属部门描述信息，多级默认以/分隔

指定者：
接口 IDepartmentMgr 中的 getDepartmentInfo
参数：
_user - 指定用户
返回：
抛出：
WCMException

getDepartmentInfo

public java.lang.String getDepartmentInfo(User _user,
                                          java.lang.String _sDelimit)
                                   throws WCMException
从接口 IDepartmentMgr 复制的描述
获取指定用户的所属部门描述信息，多级以_sDelimit指定的分隔符分开，默认为\

指定者：
接口 IDepartmentMgr 中的 getDepartmentInfo
参数：
_user - 指定的用户
_sDelimit - 多级部门之间的分隔符
返回：
抛出：
WCMException

getRootDepartmentGroup

public Group getRootDepartmentGroup()
                             throws WCMException
从接口 IDepartmentMgr 复制的描述
获取描述组织结构的根组织

指定者：
接口 IDepartmentMgr 中的 getRootDepartmentGroup
返回：
抛出：
WCMException

reload

public void reload()
            throws WCMException
从接口 IDepartmentMgr 复制的描述
重新加载相关信息

指定者：
接口 IDepartmentMgr 中的 reload
抛出：
WCMException

isDepartmentAdmin

public boolean isDepartmentAdmin(User _user)
                          throws WCMException
从接口 IDepartmentMgr 复制的描述
判断用户是否是所在用户组的管理员

指定者：
接口 IDepartmentMgr 中的 isDepartmentAdmin
返回：
抛出：
WCMException

getDeptGroupTree

public Groups getDeptGroupTree(User _user)
                        throws WCMException
从接口 IDepartmentMgr 复制的描述
获取指定用户的所属部门组织树，按照树形结构组织

指定者：
接口 IDepartmentMgr 中的 getDeptGroupTree
参数：
_user - 指定用户
返回：
按照倒序依次存放在集合中， 例如： A\A1\A11对应为 Groups.0-->A11 Groups.1-->A1 Groups.2-->A
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupAuthServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 GroupAuthServer

java.lang.Object
    继承者  com.trs.cms.auth.domain.GroupAuthServer

public class GroupAuthServer
extends java.lang.Object

构造方法摘要
GroupAuthServer()
方法摘要
static boolean hasRight(User _loginUser, Group group, int _nRightIndex)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupAuthServer

public GroupAuthServer()
方法详细信息

hasRight

public static boolean hasRight(User _loginUser,
                               Group group,
                               int _nRightIndex)
                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 GroupMgr

java.lang.Object
    继承者  com.trs.cms.auth.domain.GroupMgr

public class GroupMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
GroupMgr()
方法摘要
boolean | addUser(User _userToAdd, Group _theGroup) 将用户加到指定组织中去
boolean | delete(Group _dstGroup) 删除组织
Users | getAdmins(Group _dstGroup) 获取指定组织的管理员集合
Groups | getChildren(Group _parentGroup) 获取子组织
Groups | getChildren(Group _parentGroup, WCMFilter _filter) 获取子组织
Groups | getGroups(User _user, WCMFilter _filter) 根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织
GroupUsers | getGroupUsers(Group _theGroup, WCMFilter _filter) 获取指定组织所有的用户(用户组织关联对象)
java.lang.String | getOffspringGroupIds(java.lang.String _sGroupIds, boolean _bContainSelf) 返回所有的子孙组IDs,确定是否包含自身
Groups | getOffspringGroups(Group _theGroup, boolean _bContainSelf, WCMFilter _filter) 返回所有的子孙组,确定是否包含自身
Groups | getOffspringGroups(User _user, WCMFilter _filter) 根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织,同时包含子孙组织
Users | getUsers(Group _theGroup, WCMFilter _filter) 获取属于某组织的所有用户集合
Users | getUsers(Group _theGroup, WCMFilter _filter, boolean _bContainsChildGrp) 获取指定组织所有的用户(用户组织关联对象),包含所有的子组织的用户
boolean | isAdministrator(Group _group, User _user, boolean _bContainAncestor) 判断某个用户是否为某个组织的组管理员
boolean | moveUser(User _dstUser, Group _srcGroup, Group _dstGroup) 更改指定用户的组织
boolean | removeUser(User _dstUser, Group _theGroup) 删除组织中的某个用户
Group | save(Group _dstGroup) 保存组织（新建、编辑）
boolean | setGroupManager(User _dstUser, Group _theGroup, boolean _isAdministrator) 设置组管理员(设置或取消指定用户的组管理员身份)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupMgr

public GroupMgr()
方法详细信息

addUser

public boolean addUser(User _userToAdd,
                       Group _theGroup)
                throws WCMException
将用户加到指定组织中去

参数：
_userToAdd - 要添加的用户
_theGroup - 指定的组织
_isAdministrator - 是否作为组管理员添加
返回：
添加成功返回true
抛出：
WCMException

removeUser

public boolean removeUser(User _dstUser,
                          Group _theGroup)
                   throws WCMException
删除组织中的某个用户

参数：
_dstUser - 要删除的用户
_theGroup - 目的组织
返回：
@throws WCMException
抛出：
WCMException

setGroupManager

public boolean setGroupManager(User _dstUser,
                               Group _theGroup,
                               boolean _isAdministrator)
                        throws WCMException
设置组管理员(设置或取消指定用户的组管理员身份)

参数：
_dstUser - 要指定的用户
_theGroup - 要指定管理员的组
_isAdministrator - 是否指定为组管理员,true为管理员
抛出：
WCMException

getUsers

public Users getUsers(Group _theGroup,
                      WCMFilter _filter)
               throws WCMException
获取属于某组织的所有用户集合

参数：
_opUser - 当前操作用户
_theGroup - 指定的组织
_sOrder - 指定排序(如果为空/空串,则不排序)
返回：
@throws WCMException
抛出：
WCMException

getChildren

public Groups getChildren(Group _parentGroup)
                   throws WCMException
获取子组织

参数：
_parentGroup - 父组织(如果为空,返回所有一级组织)
返回：
@throws WCMException
抛出：
WCMException

getChildren

public Groups getChildren(Group _parentGroup,
                          WCMFilter _filter)
                   throws WCMException
获取子组织

参数：
_parentGroup - 父组织(如果为空,返回所有一级组织)
返回：
@throws WCMException
抛出：
WCMException

getAdmins

public Users getAdmins(Group _dstGroup)
                throws WCMException
获取指定组织的管理员集合

参数：
_dstGroup - 指定的组织
返回：
@throws WCMException
抛出：
WCMException

moveUser

public boolean moveUser(User _dstUser,
                        Group _srcGroup,
                        Group _dstGroup)
                 throws WCMException
更改指定用户的组织

参数：
_dstUser - 指定用户
_srcGroup - 用户所在的在组织
_dstGroup - 要把用户更改到的新组织
返回：
@throws WCMException
抛出：
WCMException

save

public Group save(Group _dstGroup)
           throws WCMException
保存组织（新建、编辑）

参数：
_dstGroup -
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(Group _dstGroup)
               throws WCMException
删除组织

参数：
_dstGroup - 要删除的组织
返回：
@throws WCMException
抛出：
WCMException

getGroupUsers

public GroupUsers getGroupUsers(Group _theGroup,
                                WCMFilter _filter)
                         throws WCMException
获取指定组织所有的用户(用户组织关联对象)

参数：
_theGroup - 指定的组织
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getOffspringGroups

public Groups getOffspringGroups(Group _theGroup,
                                 boolean _bContainSelf,
                                 WCMFilter _filter)
                          throws WCMException
返回所有的子孙组,确定是否包含自身

参数：
_theGroup -
_bContainSelf -
返回：
抛出：
WCMException

getOffspringGroupIds

public java.lang.String getOffspringGroupIds(java.lang.String _sGroupIds,
                                             boolean _bContainSelf)
                                      throws WCMException
返回所有的子孙组IDs,确定是否包含自身

参数：
_theGroup -
_bContainSelf -
返回：
抛出：
WCMException

getUsers

public Users getUsers(Group _theGroup,
                      WCMFilter _filter,
                      boolean _bContainsChildGrp)
               throws WCMException
获取指定组织所有的用户(用户组织关联对象),包含所有的子组织的用户

参数：
_theGroup -
_filter -
_bContainsChildGrp -
返回：
抛出：
WCMException

getGroups

public Groups getGroups(User _user,
                        WCMFilter _filter)
                 throws WCMException
根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织

参数：
_user -
_filter -
返回：
抛出：
WCMException

getOffspringGroups

public Groups getOffspringGroups(User _user,
                                 WCMFilter _filter)
                          throws WCMException
根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织,同时包含子孙组织

参数：
_user -
_filter -
返回：
抛出：
WCMException

isAdministrator

public boolean isAdministrator(Group _group,
                               User _user,
                               boolean _bContainAncestor)
                        throws WCMException
判断某个用户是否为某个组织的组管理员

参数：
_group -
_user -
_bContainAncestor - 是否递归判断父组织
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupRightObjImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 GroupRightObjImpl

java.lang.Object
    继承者  com.trs.cms.auth.domain.GroupRightObjImpl
所有已实现的接口：
IRightObj, ICMSObjSubstanceContent
public class GroupRightObjImpl
extends java.lang.Object
implements IRightObj

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static boolean IS_WITH_PARENT
是否开启子组控制
构造方法摘要
GroupRightObjImpl()
GroupRightObjImpl(CMSObj _cmsObj)
GroupRightObjImpl(int _nId)
方法摘要
boolean | equals(java.lang.Object _another)
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | hasRight(User _currUser, int _nRightIndex) 判断用户对于指定的对象是否具有指定的权限
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_WITH_PARENT

public static boolean IS_WITH_PARENT
是否开启子组控制

构造方法详细信息

GroupRightObjImpl

public GroupRightObjImpl()

GroupRightObjImpl

public GroupRightObjImpl(int _nId)
                  throws WCMException
抛出：
WCMException

GroupRightObjImpl

public GroupRightObjImpl(CMSObj _cmsObj)
方法详细信息

hasRight

public boolean hasRight(User _currUser,
                        int _nRightIndex)
                 throws WCMException
从接口 IRightObj 复制的描述
判断用户对于指定的对象是否具有指定的权限

指定者：
接口 IRightObj 中的 hasRight
参数：
_currUser - 指定的用户
_nRightIndex - 指定的权限值（定义在WCMRightTypes中）
返回：
如果具有，返回true;否则返回false
抛出：
WCMException

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupRoleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 GroupRoleMgr

java.lang.Object
    继承者  com.trs.cms.auth.domain.GroupRoleMgr

public class GroupRoleMgr
extends java.lang.Object

构造方法摘要
GroupRoleMgr()
方法摘要
boolean | addGroup(Group _dstGroup, Role _theRole)
Groups | getGroups(Role _dstRole, WCMFilter _filter) 获取指定角色的关联的组织
Roles | getRoles(Group _dstGroup, WCMFilter _filter) 获取指定组织的所有角色
boolean | removeGroup(Group _dstGroup, Role _theRole)
void | setGroups(Role role, Groups groups) 绑定角色role和组织groups的关联，同时将清除原来的关联
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupRoleMgr

public GroupRoleMgr()
方法详细信息

addGroup

public boolean addGroup(Group _dstGroup,
                        Role _theRole)
                 throws WCMException
抛出：
WCMException

removeGroup

public boolean removeGroup(Group _dstGroup,
                           Role _theRole)
                    throws WCMException
抛出：
WCMException

getGroups

public Groups getGroups(Role _dstRole,
                        WCMFilter _filter)
                 throws WCMException
获取指定角色的关联的组织

参数：
_dstRole - 指定的角色
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getRoles

public Roles getRoles(Group _dstGroup,
                      WCMFilter _filter)
               throws WCMException
获取指定组织的所有角色

参数：
_dstGroup - 指定的组织
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

setGroups

public void setGroups(Role role,
                      Groups groups)
               throws WCMException
绑定角色role和组织groups的关联，同时将清除原来的关联

参数：
role -
groups -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GrpUserIdsMan

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 GrpUserIdsMan

java.lang.Object
    继承者  com.trs.infra.common.BaseIdsMan
        继承者  com.trs.cms.auth.domain.GrpUserIdsMan

public class GrpUserIdsMan
extends BaseIdsMan

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
GrpUserIdsMan(int _nGroupId)
方法摘要
从类 com.trs.infra.common.BaseIdsMan 继承的方法
dowithIds
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GrpUserIdsMan

public GrpUserIdsMan(int _nGroupId)
              throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDepartmentMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
接口 IDepartmentMgr

所有已知实现类：
DepartmentMgrImpl
public interface IDepartmentMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
组织结构管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String | getDepartmentInfo(User _user) 获取指定用户的所属部门描述信息，多级默认以/分隔
java.lang.String | getDepartmentInfo(User _user, java.lang.String _sDelimit) 获取指定用户的所属部门描述信息，多级以_sDelimit指定的分隔符分开，默认为\
Groups | getDeptGroups(User _user) 获取指定用户所属的组织结构
Groups | getDeptGroupTree(User _user) 获取指定用户的所属部门组织树，按照树形结构组织
Group | getRootDepartmentGroup() 获取描述组织结构的根组织
boolean | isDepartmentAdmin(User _user) 判断用户是否是所在用户组的管理员
void | reload() 重新加载相关信息

方法详细信息

getRootDepartmentGroup

Group getRootDepartmentGroup()
                             throws WCMException
获取描述组织结构的根组织

返回：
抛出：
WCMException

reload

void reload()
            throws WCMException
重新加载相关信息

抛出：
WCMException

getDepartmentInfo

java.lang.String getDepartmentInfo(User _user)
                                   throws WCMException
获取指定用户的所属部门描述信息，多级默认以/分隔

参数：
_user - 指定用户
返回：
抛出：
WCMException

getDepartmentInfo

java.lang.String getDepartmentInfo(User _user,
                                   java.lang.String _sDelimit)
                                   throws WCMException
获取指定用户的所属部门描述信息，多级以_sDelimit指定的分隔符分开，默认为\

参数：
_user - 指定的用户
_sDelimit - 多级部门之间的分隔符
返回：
抛出：
WCMException

getDeptGroups

Groups getDeptGroups(User _user)
                     throws WCMException
获取指定用户所属的组织结构

参数：
_user -
返回：
抛出：
WCMException

getDeptGroupTree

Groups getDeptGroupTree(User _user)
                        throws WCMException
获取指定用户的所属部门组织树，按照树形结构组织

参数：
_user - 指定用户
返回：
按照倒序依次存放在集合中， 例如： A\A1\A11对应为 Groups.0-->A11 Groups.1-->A1 Groups.2-->A
抛出：
WCMException

isDepartmentAdmin

boolean isDepartmentAdmin(User _user)
                          throws WCMException
判断用户是否是所在用户组的管理员

参数：
_user -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IObjectMemberMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
接口 IObjectMemberMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
ObjectMemberMgr
public interface IObjectMemberMgr
extends ICacheMgr

方法摘要
boolean | canOperate(CMSObj _currOperator, int _nObjType, int _nObjId) 判断当前操作者对于指定对象是否可操作
boolean | canOperate(Group _currGroup, int _nObjType, int _nObjId) 判断当前组织对于指定对象是否可操作
boolean | canOperate(Role _currRole, int _nObjType, int _nObjId) 判断当前角色对于指定对象是否可操作
boolean | canOperate(User _currUser, int _nObjType, int _nObjId) 判断当前用户对于指定对象是否可操作
ObjectMember | getObjectMember(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId) 获取可访问可操作对象
boolean | isVisible(CMSObj _currOperator, int _nObjType, int _nObjId) 判断当前操作者对于指定对象是否可见
boolean | isVisible(Group _currGroup, int _nObjType, int _nObjId) 判断当前组织对于指定对象是否可见
boolean | isVisible(Role _currRole, int _nObjType, int _nObjId) 判断当前角色对于指定对象是否可见
boolean | isVisible(User _currUser, int _nObjType, int _nObjId) 判断当前用户对于指定对象是否可见
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

isVisible

boolean isVisible(User _currUser,
                  int _nObjType,
                  int _nObjId)
                  throws WCMException
判断当前用户对于指定对象是否可见

参数：
_currUser -
_nObjType -
_nObjId -
返回：
抛出：
WCMException

isVisible

boolean isVisible(Group _currGroup,
                  int _nObjType,
                  int _nObjId)
                  throws WCMException
判断当前组织对于指定对象是否可见

参数：
_currGroup -
_nObjType -
_nObjId -
返回：
抛出：
WCMException

isVisible

boolean isVisible(Role _currRole,
                  int _nObjType,
                  int _nObjId)
                  throws WCMException
判断当前角色对于指定对象是否可见

参数：
_currRole -
_nObjType -
_nObjId -
返回：
抛出：
WCMException

isVisible

boolean isVisible(CMSObj _currOperator,
                  int _nObjType,
                  int _nObjId)
                  throws WCMException
判断当前操作者对于指定对象是否可见

参数：
_currOperator -
_nObjType -
_nObjId -
返回：
抛出：
WCMException

canOperate

boolean canOperate(User _currUser,
                   int _nObjType,
                   int _nObjId)
                   throws WCMException
判断当前用户对于指定对象是否可操作

参数：
_currUser -
_nObjType -
_nObjId -
返回：
抛出：
WCMException

canOperate

boolean canOperate(Group _currGroup,
                   int _nObjType,
                   int _nObjId)
                   throws WCMException
判断当前组织对于指定对象是否可操作

参数：
_currGroup -
_nObjType -
_nObjId -
返回：
抛出：
WCMException

canOperate

boolean canOperate(Role _currRole,
                   int _nObjType,
                   int _nObjId)
                   throws WCMException
判断当前角色对于指定对象是否可操作

参数：
_currRole -
_nObjType -
_nObjId -
返回：
抛出：
WCMException

canOperate

boolean canOperate(CMSObj _currOperator,
                   int _nObjType,
                   int _nObjId)
                   throws WCMException
判断当前操作者对于指定对象是否可操作

参数：
_currOperator -
_nObjType -
_nObjId -
返回：
抛出：
WCMException

getObjectMember

ObjectMember getObjectMember(int _nMemberType,
                             int _nMemberId,
                             int _nObjType,
                             int _nObjId)
                             throws WCMException
获取可访问可操作对象

参数：
_nMemberType -
_nMemberId -
_nObjType -
_nObjId -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IRightHost

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
接口 IRightHost

所有超级接口：
ICMSObjSubstanceContent
所有已知实现类：
ChannelRightHostImpl, DocumentRightHostImpl, RightHostInfoViewField, RightHostInfoViewGroup, RightHostInfoViewView, WebSiteRightHostImpl
public interface IRightHost
extends ICMSObjSubstanceContent

Title: TRS 内容协作平台（TRS WCM）
Description:
可设置权限的对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
IRightHost[] | getChildren() 获取当前对象的一级子对象
IRightHost | getParent() 获取父对象
java.lang.String[] | getRightTypeIds() 获取可以在这类对象上支持的权限类别Id
java.lang.String[] | getRightTypeNames() 获取可以在这类对象上支持的权限类别名称
void | validateCanDoSetRight(User _user) 判断指定的用户是否有权给当前对象设置权限
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

方法详细信息

validateCanDoSetRight

void validateCanDoSetRight(User _user)
                           throws WCMException
判断指定的用户是否有权给当前对象设置权限

参数：
_user - 指定的User
抛出：
WCMException

getChildren

IRightHost[] getChildren()
                         throws WCMException
获取当前对象的一级子对象

返回：
抛出：
WCMException

getParent

IRightHost getParent()
                     throws WCMException
获取父对象

返回：
抛出：
WCMException

getRightTypeIds

java.lang.String[] getRightTypeIds()
获取可以在这类对象上支持的权限类别Id

返回：

getRightTypeNames

java.lang.String[] getRightTypeNames()
获取可以在这类对象上支持的权限类别名称

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IRightMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
接口 IRightMgr

所有已知实现类：
RightMgr
public interface IRightMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
Right | deleteRight(Right _delRight) 删除指定的权限
Right | getRight(CMSObj _currObj, CMSObj _currOperator) 获取指定对象指定操作者的权限对象
Right | getRight(int _objType, int _objId, int _oprType, int _oprId) 获取指定对象指定操作者的权限对象
Rights | getRights(CMSObj _currObj)
Rights | getRights(CMSObj _currObj, int _operatorType)
Rights | getRights(CMSObj _currObj, java.lang.String _groupIds, java.lang.String _roleIds) 获取指定对象指定群和组织的权限对象
Rights | getRights(int objType, int objId)
RightValue | getRightValue(CMSObj _currObj, CMSObj _currOperator)
Right | saveRight(Right _saveRight) 保存权限

方法详细信息

getRight

Right getRight(int _objType,
               int _objId,
               int _oprType,
               int _oprId)
               throws WCMException
获取指定对象指定操作者的权限对象

参数：
_objType - 指定对象的类型
_objId - 指定对象的ID
_oprType - 指定操作对象的类型
_oprId - 指定操作对象的ID
返回：
权限对象 Right
抛出：
WCMException

getRight

Right getRight(CMSObj _currObj,
               CMSObj _currOperator)
               throws WCMException
获取指定对象指定操作者的权限对象

参数：
_currObj - 指定对象
_currOperator - 指定操作者
返回：
权限对象（Right）
抛出：
WCMException

getRights

Rights getRights(CMSObj _currObj,
                 java.lang.String _groupIds,
                 java.lang.String _roleIds)
                 throws WCMException
获取指定对象指定群和组织的权限对象

参数：
_currObj - 指定对象
_groupIds - 组织id序列
_roleIds - 角色id序列
返回：
权限对象（Right）
抛出：
WCMException

saveRight

Right saveRight(Right _saveRight)
                throws WCMException
保存权限

参数：
_saveRight - 待保存的权限对象
返回：
权限对象
抛出：
WCMException

deleteRight

Right deleteRight(Right _delRight)
                  throws WCMException
删除指定的权限

参数：
_delRight - 待删除的权限
返回：
删除后的权限
抛出：
WCMException

getRights

Rights getRights(CMSObj _currObj,
                 int _operatorType)
                 throws WCMException
抛出：
WCMException

getRights

Rights getRights(CMSObj _currObj)
                 throws WCMException
抛出：
WCMException

getRights

Rights getRights(int objType,
                 int objId)
                 throws WCMException
抛出：
WCMException

getRightValue

RightValue getRightValue(CMSObj _currObj,
                         CMSObj _currOperator)
                         throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IRightObj

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
接口 IRightObj

所有超级接口：
ICMSObjSubstanceContent
所有已知实现类：
ChannelRightObjImpl, GroupRightObjImpl, TemplateRightObjImpl, WebSiteRightObjImpl
public interface IRightObj
extends ICMSObjSubstanceContent

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 boolean hasRight(User _currUser, int _nRightIndex)
判断用户对于指定的对象是否具有指定的权限
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

方法详细信息

hasRight

boolean hasRight(User _currUser,
                 int _nRightIndex)
                 throws WCMException
判断用户对于指定的对象是否具有指定的权限

参数：
_currUser - 指定的用户
_nRightIndex - 指定的权限值（定义在WCMRightTypes中）
返回：
如果具有，返回true;否则返回false
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NewRightSet

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 NewRightSet

java.lang.Object
    继承者  com.trs.cms.auth.domain.NewRightSet

public class NewRightSet
extends java.lang.Object

字段摘要
static int | IMPART_MODE_ADD
static int | IMPART_MODE_ALL
static int | IMPART_MODE_DELETE
static int | IMPART_MODE_MODIFY
static int | IMPART_MODE_NODE
构造方法摘要
NewRightSet(User _loginUser, IRightHost _rightHost, java.util.List _currRightList, int[] _pImpartMode)
方法摘要
void | inheritRights(User _loginUser, IRightHost _rightHost, boolean _bDropOldRights) 继承父对象的权限
boolean | save()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IMPART_MODE_NODE

public static final int IMPART_MODE_NODE
另请参见：
常量字段值

IMPART_MODE_ADD

public static final int IMPART_MODE_ADD
另请参见：
常量字段值

IMPART_MODE_MODIFY

public static final int IMPART_MODE_MODIFY
另请参见：
常量字段值

IMPART_MODE_DELETE

public static final int IMPART_MODE_DELETE
另请参见：
常量字段值

IMPART_MODE_ALL

public static final int IMPART_MODE_ALL
另请参见：
常量字段值
构造方法详细信息

NewRightSet

public NewRightSet(User _loginUser,
                   IRightHost _rightHost,
                   java.util.List _currRightList,
                   int[] _pImpartMode)
方法详细信息

save

public boolean save()
             throws WCMException
抛出：
WCMException

inheritRights

public void inheritRights(User _loginUser,
                          IRightHost _rightHost,
                          boolean _bDropOldRights)
                   throws WCMException
继承父对象的权限

参数：
_loginUser -
_rightHost -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectMemberMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 ObjectMemberMgr

java.lang.Object
    继承者  com.trs.cms.auth.domain.ObjectMemberMgr
所有已实现的接口：
IObjectMemberMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class ObjectMemberMgr
extends java.lang.Object
implements IObjectMemberMgr

可见可操作对象的缓冲管理.

构造方法摘要
ObjectMemberMgr()
方法摘要
boolean | canOperate(CMSObj _oOperator, int _nObjType, int _nObjId) 判断当前操作者对于指定对象是否可操作
boolean | canOperate(Group _oGroup, int _nObjType, int _nObjId) 判断当前组织对于指定对象是否可操作
boolean | canOperate(Role _oRole, int _nObjType, int _nObjId) 判断当前角色对于指定对象是否可操作
boolean | canOperate(User _oUser, int _nObjType, int _nObjId) 判断当前用户对于指定对象是否可操作
void | clear() 清除系统所有的Cache
ObjectMember | getObjectMember(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId) 获取ObjectMember
boolean | init() 初始化当前的Cache
boolean | isVisible(CMSObj _oOperator, int _nObjType, int _nObjId) 判断当前操作者对于指定对象是否可见
boolean | isVisible(Group _oGroup, int _nObjType, int _nObjId) 判断当前组织对于指定对象是否可见
boolean | isVisible(Role _oRole, int _nObjType, int _nObjId) 判断当前角色对于指定对象是否可见
boolean | isVisible(User _oUser, int _nObjType, int _nObjId) 判断当前用户对于指定对象是否可见
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectMemberMgr

public ObjectMemberMgr()
方法详细信息

canOperate

public boolean canOperate(User _oUser,
                          int _nObjType,
                          int _nObjId)
                   throws WCMException
从接口 IObjectMemberMgr 复制的描述
判断当前用户对于指定对象是否可操作

指定者：
接口 IObjectMemberMgr 中的 canOperate
返回：
抛出：
WCMException

canOperate

public boolean canOperate(Group _oGroup,
                          int _nObjType,
                          int _nObjId)
                   throws WCMException
从接口 IObjectMemberMgr 复制的描述
判断当前组织对于指定对象是否可操作

指定者：
接口 IObjectMemberMgr 中的 canOperate
返回：
抛出：
WCMException

canOperate

public boolean canOperate(Role _oRole,
                          int _nObjType,
                          int _nObjId)
                   throws WCMException
从接口 IObjectMemberMgr 复制的描述
判断当前角色对于指定对象是否可操作

指定者：
接口 IObjectMemberMgr 中的 canOperate
返回：
抛出：
WCMException

canOperate

public boolean canOperate(CMSObj _oOperator,
                          int _nObjType,
                          int _nObjId)
                   throws WCMException
从接口 IObjectMemberMgr 复制的描述
判断当前操作者对于指定对象是否可操作

指定者：
接口 IObjectMemberMgr 中的 canOperate
返回：
抛出：
WCMException

isVisible

public boolean isVisible(User _oUser,
                         int _nObjType,
                         int _nObjId)
                  throws WCMException
从接口 IObjectMemberMgr 复制的描述
判断当前用户对于指定对象是否可见

指定者：
接口 IObjectMemberMgr 中的 isVisible
返回：
抛出：
WCMException

isVisible

public boolean isVisible(Group _oGroup,
                         int _nObjType,
                         int _nObjId)
                  throws WCMException
从接口 IObjectMemberMgr 复制的描述
判断当前组织对于指定对象是否可见

指定者：
接口 IObjectMemberMgr 中的 isVisible
返回：
抛出：
WCMException

isVisible

public boolean isVisible(Role _oRole,
                         int _nObjType,
                         int _nObjId)
                  throws WCMException
从接口 IObjectMemberMgr 复制的描述
判断当前角色对于指定对象是否可见

指定者：
接口 IObjectMemberMgr 中的 isVisible
返回：
抛出：
WCMException

isVisible

public boolean isVisible(CMSObj _oOperator,
                         int _nObjType,
                         int _nObjId)
                  throws WCMException
从接口 IObjectMemberMgr 复制的描述
判断当前操作者对于指定对象是否可见

指定者：
接口 IObjectMemberMgr 中的 isVisible
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

getObjectMember

public ObjectMember getObjectMember(int _nMemberType,
                                    int _nMemberId,
                                    int _nObjType,
                                    int _nObjId)
                             throws WCMException
获取ObjectMember

指定者：
接口 IObjectMemberMgr 中的 getObjectMember
参数：
_nMemberType -
_nMemberId -
_nObjType -
_nObjId -
返回：
如果存在，则返回ObjectMember；不存在，则返回null
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectMemberMgrForCluster

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 ObjectMemberMgrForCluster

java.lang.Object
    继承者  com.trs.cms.auth.domain.ObjectMemberMgrForCluster
所有已实现的接口：
IClusterMsgReceiver
public class ObjectMemberMgrForCluster
extends java.lang.Object
implements IClusterMsgReceiver

ObjectMember缓冲处理.接收集群消息,根据相应的操作刷新缓冲.

构造方法摘要
ObjectMemberMgrForCluster()
方法摘要
void | receive(BaseObj _oEventObject, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String _sContent, java.lang.String[] _pParameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectMemberMgrForCluster

public ObjectMemberMgrForCluster()
方法详细信息

receive

public void receive(BaseObj _oEventObject,
                    int _nEventType)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String _sContent,
                    java.lang.String[] _pParameters)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

registerMoniterMessages

public java.lang.String[] registerMoniterMessages()
从接口 IClusterMsgReceiver 复制的描述
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterMessages
返回：

registerMoniterWCMObjTypesOnAdd

public int[] registerMoniterWCMObjTypesOnAdd()
从接口 IClusterMsgReceiver 复制的描述
当新增那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnAdd
返回：

registerMoniterWCMObjTypesOnDel

public int[] registerMoniterWCMObjTypesOnDel()
从接口 IClusterMsgReceiver 复制的描述
当删除那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnDel
返回：

registerMoniterWCMObjTypesOnModify

public int[] registerMoniterWCMObjTypesOnModify()
从接口 IClusterMsgReceiver 复制的描述
当修改那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnModify
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.auth.domain
接口
IDepartmentMgr
IObjectMemberMgr
IRightHost
IRightMgr
IRightObj
类
AuthServer
DepartmentMgrImpl
GroupAuthServer
GroupMgr
GroupRightObjImpl
GroupRoleMgr
GrpUserIdsMan
NewRightSet
ObjectMemberMgr
ObjectMemberMgrForCluster
RightCacheMgr
RightHostFactory
RightHostLCListenerForInherit
RightMgr
RightObjectFactory
RightSet
RoleAuthServer
RoleMgr
RoleUserIdsMan
UpdUserScheduleCreator
UserInfoSyncUpdater
UserMgr


com.trs.cms.auth.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.auth.domain

接口摘要
IDepartmentMgr | Title: TRS 内容协作平台（TRS WCM） Description: 组织结构管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectMemberMgr |
IRightHost | Title: TRS 内容协作平台（TRS WCM） Description: 可设置权限的对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IRightMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IRightObj | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
AuthServer |
DepartmentMgrImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAuthServer |
GroupMgr | Title: TRS 内容协作平台（TRS WCM） Description:
GroupRightObjImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupRoleMgr |
GrpUserIdsMan | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
NewRightSet |
ObjectMemberMgr | 可见可操作对象的缓冲管理.
ObjectMemberMgrForCluster | ObjectMember缓冲处理.接收集群消息,根据相应的操作刷新缓冲.
RightCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostFactory | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostLCListenerForInherit | Title: TRS 内容协作平台（TRS WCM） Description: 权限对象新增创建监听器，为了继承父对象的权限权限 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightMgr | Title: TRS 内容协作平台（TRS WCM） Description: 权限管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightObjectFactory | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightSet |
RoleAuthServer |
RoleMgr | Title: TRS 内容协作平台（TRS WCM） Description:
RoleUserIdsMan | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UpdUserScheduleCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
UserInfoSyncUpdater | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
UserMgr | Title: TRS 内容协作平台（TRS WCM） Description:


com.trs.cms.auth.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.auth.domain.AuthServer
    • com.trs.infra.common.BaseIdsMan
      • com.trs.cms.auth.domain.GrpUserIdsMan
      • com.trs.cms.auth.domain.RoleUserIdsMan
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.cms.auth.domain.UserInfoSyncUpdater
    • com.trs.cms.auth.domain.DepartmentMgrImpl (implements com.trs.cms.auth.domain.IDepartmentMgr)
    • com.trs.cms.auth.domain.GroupAuthServer
    • com.trs.cms.auth.domain.GroupMgr
    • com.trs.cms.auth.domain.GroupRightObjImpl (implements com.trs.cms.auth.domain.IRightObj)
    • com.trs.cms.auth.domain.GroupRoleMgr
    • com.trs.cms.auth.domain.NewRightSet
    • com.trs.cms.auth.domain.ObjectMemberMgr (implements com.trs.cms.auth.domain.IObjectMemberMgr)
    • com.trs.cms.auth.domain.ObjectMemberMgrForCluster (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.cms.auth.domain.RightCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.cms.auth.domain.RightHostFactory
    • com.trs.cms.auth.domain.RightHostLCListenerForInherit (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd)
    • com.trs.cms.auth.domain.RightMgr (implements com.trs.cms.auth.domain.IRightMgr)
    • com.trs.cms.auth.domain.RightObjectFactory
    • com.trs.cms.auth.domain.RightSet
    • com.trs.cms.auth.domain.RoleAuthServer
    • com.trs.cms.auth.domain.RoleMgr
    • com.trs.cms.auth.domain.UpdUserScheduleCreator
    • com.trs.cms.auth.domain.UserMgr

接口分层结构

  • com.trs.cms.content.ICMSObjSubstanceContent
    • com.trs.cms.auth.domain.IRightHost
    • com.trs.cms.auth.domain.IRightObj
  • com.trs.cms.auth.domain.IDepartmentMgr
  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.cms.auth.domain.IObjectMemberMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.cms.auth.domain.IObjectMemberMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.cms.auth.domain.IObjectMemberMgr
  • com.trs.cms.auth.domain.IRightMgr


软件包 com.trs.cms.auth.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth.domain
的使用

使用 com.trs.cms.auth.domain 的软件包
com.trs.cms.auth.config |
com.trs.cms.auth.domain |
com.trs.components.common.publish.domain.auth |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.wcm.auth |
com.trs.components.wcm.content.domain.auth |
com.trs.presentation.ids |

com.trs.cms.auth.config 使用的 com.trs.cms.auth.domain 中的类
IRightHost
Title: TRS 内容协作平台（TRS WCM）
Description:
可设置权限的对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRightObj
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.domain 使用的 com.trs.cms.auth.domain 中的类
IDepartmentMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
组织结构管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectMemberMgr
IRightHost
Title: TRS 内容协作平台（TRS WCM）
Description:
可设置权限的对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRightMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRightObj
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.auth 使用的 com.trs.cms.auth.domain 中的类
IRightObj
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview 使用的 com.trs.cms.auth.domain 中的类
IRightHost
Title: TRS 内容协作平台（TRS WCM）
Description:
可设置权限的对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.auth 使用的 com.trs.cms.auth.domain 中的类
IRightObj
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain.auth 使用的 com.trs.cms.auth.domain 中的类
IRightHost
Title: TRS 内容协作平台（TRS WCM）
Description:
可设置权限的对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.ids 使用的 com.trs.cms.auth.domain 中的类
GroupMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
UserMgr
Title: TRS 内容协作平台（TRS WCM）
Description:

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RightCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RightCacheMgr

java.lang.Object
    继承者  com.trs.cms.auth.domain.RightCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class RightCacheMgr
extends java.lang.Object
implements ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int MAX_RIGHT_CACHE_SIZE
构造方法摘要
RightCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
RightValue | getRightValue(int _objType, int _objId, int _oprType, int _oprId)
long | getRightValue(int _objType, int _objId, int _oprType, int _oprId, long _lDefaultValue)
boolean | init() 初始化当前的Cache
boolean | isExistsRight(int _nObjType, int _nObjId)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAX_RIGHT_CACHE_SIZE

public static int MAX_RIGHT_CACHE_SIZE
构造方法详细信息

RightCacheMgr

public RightCacheMgr()
方法详细信息

getRightValue

public RightValue getRightValue(int _objType,
                                int _objId,
                                int _oprType,
                                int _oprId)
                         throws WCMException
抛出：
WCMException

getRightValue

public long getRightValue(int _objType,
                          int _objId,
                          int _oprType,
                          int _oprId,
                          long _lDefaultValue)
                   throws WCMException
抛出：
WCMException

isExistsRight

public boolean isExistsRight(int _nObjType,
                             int _nObjId)
                      throws WCMException
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightHostFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RightHostFactory

java.lang.Object
    继承者  com.trs.cms.auth.domain.RightHostFactory

public class RightHostFactory
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightHostFactory()
方法摘要
static IRightHost | makeRightHostFrom(CMSObj _oCMSObj)
static IRightHost | makeRightHostFrom(int _nHostType, int _nHostId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightHostFactory

public RightHostFactory()
方法详细信息

makeRightHostFrom

public static IRightHost makeRightHostFrom(CMSObj _oCMSObj)
                                    throws WCMException
抛出：
WCMException

makeRightHostFrom

public static IRightHost makeRightHostFrom(int _nHostType,
                                           int _nHostId)
                                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightHostLCListenerForInherit

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RightHostLCListenerForInherit

java.lang.Object
    继承者  com.trs.cms.auth.domain.RightHostLCListenerForInherit
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd
public class RightHostLCListenerForInherit
extends java.lang.Object
implements IObjectLCListenerOnAdd

Title: TRS 内容协作平台（TRS WCM）
Description:
权限对象新增创建监听器，为了继承父对象的权限权限
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightHostLCListenerForInherit()
方法摘要
void | inheritObjectMembers(Channel _oChannel)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightHostLCListenerForInherit

public RightHostLCListenerForInherit()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

inheritObjectMembers

public void inheritObjectMembers(Channel _oChannel)
                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RightMgr

java.lang.Object
    继承者  com.trs.cms.auth.domain.RightMgr
所有已实现的接口：
IRightMgr
public class RightMgr
extends java.lang.Object
implements IRightMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
权限管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightMgr()
方法摘要
Right | deleteRight(Right _delRight) 删除指定的权限
Right | getRight(CMSObj _currObj, CMSObj _currOperator) 获取指定对象指定操作者的权限对象
Right | getRight(int _objType, int _objId, int _oprType, int _oprId) 获取指定对象指定操作者的权限对象
Rights | getRights(CMSObj _currObj)
Rights | getRights(CMSObj _currObj, int _operatorType)
Rights | getRights(CMSObj _currObj, java.lang.String _groupIds, java.lang.String _roleIds) 获取指定对象指定群和组织的权限对象
Rights | getRights(int objType, int objId)
RightValue | getRightValue(CMSObj _currObj, CMSObj _currOperator)
Right | saveRight(Right _saveRight) 保存权限
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightMgr

public RightMgr()
方法详细信息

getRight

public Right getRight(int _objType,
                      int _objId,
                      int _oprType,
                      int _oprId)
               throws WCMException
从接口 IRightMgr 复制的描述
获取指定对象指定操作者的权限对象

指定者：
接口 IRightMgr 中的 getRight
参数：
_objType - 指定对象的类型
_objId - 指定对象的ID
_oprType - 指定操作对象的类型
_oprId - 指定操作对象的ID
返回：
权限对象 Right
抛出：
WCMException

getRight

public Right getRight(CMSObj _currObj,
                      CMSObj _currOperator)
               throws WCMException
从接口 IRightMgr 复制的描述
获取指定对象指定操作者的权限对象

指定者：
接口 IRightMgr 中的 getRight
参数：
_currObj - 指定对象
_currOperator - 指定操作者
返回：
权限对象（Right）
抛出：
WCMException

saveRight

public Right saveRight(Right _saveRight)
                throws WCMException
从接口 IRightMgr 复制的描述
保存权限

指定者：
接口 IRightMgr 中的 saveRight
参数：
_saveRight - 待保存的权限对象
返回：
权限对象
抛出：
WCMException

deleteRight

public Right deleteRight(Right _delRight)
                  throws WCMException
从接口 IRightMgr 复制的描述
删除指定的权限

指定者：
接口 IRightMgr 中的 deleteRight
参数：
_delRight - 待删除的权限
返回：
删除后的权限
抛出：
WCMException

getRights

public Rights getRights(CMSObj _currObj,
                        int _operatorType)
                 throws WCMException
指定者：
接口 IRightMgr 中的 getRights
抛出：
WCMException

getRights

public Rights getRights(CMSObj _currObj)
                 throws WCMException
指定者：
接口 IRightMgr 中的 getRights
抛出：
WCMException

getRights

public Rights getRights(CMSObj _currObj,
                        java.lang.String _groupIds,
                        java.lang.String _roleIds)
                 throws WCMException
从接口 IRightMgr 复制的描述
获取指定对象指定群和组织的权限对象

指定者：
接口 IRightMgr 中的 getRights
参数：
_currObj - 指定对象
_groupIds - 组织id序列
_roleIds - 角色id序列
返回：
权限对象（Right）
抛出：
WCMException

getRights

public Rights getRights(int objType,
                        int objId)
                 throws WCMException
指定者：
接口 IRightMgr 中的 getRights
抛出：
WCMException

getRightValue

public RightValue getRightValue(CMSObj _currObj,
                                CMSObj _currOperator)
                         throws WCMException
指定者：
接口 IRightMgr 中的 getRightValue
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightObjectFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RightObjectFactory

java.lang.Object
    继承者  com.trs.cms.auth.domain.RightObjectFactory

public class RightObjectFactory
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightObjectFactory()
方法摘要
static IRightObj | makeRightObjectFrom(CMSObj _oCMSObj)
static IRightObj | makeRightObjectFrom(int _nObjectType, int _nObjectId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightObjectFactory

public RightObjectFactory()
方法详细信息

makeRightObjectFrom

public static IRightObj makeRightObjectFrom(CMSObj _oCMSObj)
                                     throws WCMException
抛出：
WCMException

makeRightObjectFrom

public static IRightObj makeRightObjectFrom(int _nObjectType,
                                            int _nObjectId)
                                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightSet

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RightSet

java.lang.Object
    继承者  com.trs.cms.auth.domain.RightSet

public class RightSet
extends java.lang.Object

构造方法摘要
RightSet()
方法摘要
void | inheritRights(User _loginUser, IRightHost _rightHost, boolean _bDropOldRights) 继承父对象的权限
boolean | setRights(User loginUser, IRightHost _rightHost, java.util.List _currRightList, boolean _bSetChildrenRight)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightSet

public RightSet()
方法详细信息

setRights

public boolean setRights(User loginUser,
                         IRightHost _rightHost,
                         java.util.List _currRightList,
                         boolean _bSetChildrenRight)
                  throws WCMException
抛出：
WCMException

inheritRights

public void inheritRights(User _loginUser,
                          IRightHost _rightHost,
                          boolean _bDropOldRights)
                   throws WCMException
继承父对象的权限

参数：
_loginUser -
_rightHost -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleAuthServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RoleAuthServer

java.lang.Object
    继承者  com.trs.cms.auth.domain.RoleAuthServer

public class RoleAuthServer
extends java.lang.Object

构造方法摘要
RoleAuthServer()
方法摘要
static boolean hasRight(User _loginUser, Role _role, int _nRightIndex)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleAuthServer

public RoleAuthServer()
方法详细信息

hasRight

public static boolean hasRight(User _loginUser,
                               Role _role,
                               int _nRightIndex)
                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RoleMgr

java.lang.Object
    继承者  com.trs.cms.auth.domain.RoleMgr

public class RoleMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RoleMgr()
方法摘要
boolean | addUser(Role _theRole, int _nSiteId, User _dstUser) 添加指定用户到指定的角色
boolean | addUser(User _dstUser, Role _theRole) 已过时。 权限模型调整，需要引入站点id.
boolean | delete(Role _roleToDelete, boolean _bDrop) 删除角色
Role | findRoleByName(java.lang.String sRoleName) 根据角色名称，获取到第一个匹配的角色，优先获取id值更大的角色
Roles | getRoles() 获取系统中的所有角色集合
Roles | getRolesForUser(User _user, WCMFilter _filter) 获取指定用户可见的角色
RoleUsers | getRoleUsers(Role _theRole, WCMFilter _filter) 获取指定角色下的角色用户信息
RoleUsers | getRoleUsers(User _theUser, WCMFilter _filter) 获取指定用户下的角色用户信息
Roles | getSpecialRolesOfUser(User _user, WCMFilter _filter) 获取指定用户上设置的特定角色
Roles | getSystemRolesOfUser(User _user, int nSiteId, WCMFilter _filter) 获取指定用户在指定站点上设置的角色信息
Users | getUsers(Role _dstRole, int _nSiteId, WCMFilter _filter) 获取某角色在某站点下的所有用户集合
Users | getUsers(Role _dstRole, WCMFilter _filter) 获取担任某角色的所有用户集合
Users | getUsersBySpecailForUser(Role _dstRole, WCMFilter _filter) 获取当前登录用户可以查看的某特定角色的所有用户集合
Users | getUsersBySystemRoleForUser(Role _dstRole, int _nSiteId, WCMFilter _filter) 获取当前登录用户可以查看的某系统级角色的所有用户集合
boolean | isRoleManagers(User _user) 判断指定用户是否为角色管理员
boolean | removeUser(Role _theRole, int _nSiteId, User _dstUser) 将指定的用户从指定的角色和站点中删除
boolean | removeUser(User _dstUser, Role _theRole) 已过时。
Role | save(Role _currRole) 保存指定的角色
void | setRoleUsers(Role role, int _nSiteId, Users _users) 绑定角色,站点和用户的关联，同时将清除原来的关联
void | setSpecailRolesOfUser(User _user, Roles _roles) 设置用户的特定角色，同时将清除原来的特定角色d关联
void | setSystemRolesOfUser(User _user, int _nSiteId, Roles roles) 设置用户在指定站点上的系统级角色，同时将清除原来的关联
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleMgr

public RoleMgr()
方法详细信息

addUser

public boolean addUser(User _dstUser,
                       Role _theRole)
                throws WCMException
已过时。 权限模型调整，需要引入站点id.

添加指定用户到指定的角色

参数：
_dstUser - 指定要添加的用户
_theRole - 指定的角色
返回：
@throws WCMException
抛出：
WCMException

addUser

public boolean addUser(Role _theRole,
                       int _nSiteId,
                       User _dstUser)
                throws WCMException
添加指定用户到指定的角色

参数：
_theRole -
_nSiteId - 由于siteid存在为-1和0的情况，所以不好为WebSite对象
_dstUser -
返回：
抛出：
WCMException

removeUser

public boolean removeUser(User _dstUser,
                          Role _theRole)
                   throws WCMException
已过时。

将指定的用户从指定的角色中删除

参数：
_dstUser - 指定要删除的用户
_theRole - 指定的角色
返回：
@throws WCMException
抛出：
WCMException

removeUser

public boolean removeUser(Role _theRole,
                          int _nSiteId,
                          User _dstUser)
                   throws WCMException
将指定的用户从指定的角色和站点中删除

参数：
_theRole -
_nSiteId - 由于siteid存在为-1和0的情况，所以不好为WebSite对象
_dstUser -
返回：
抛出：
WCMException

getRoles

public Roles getRoles()
               throws WCMException
获取系统中的所有角色集合

返回：
抛出：
WCMException

getUsers

public Users getUsers(Role _dstRole,
                      int _nSiteId,
                      WCMFilter _filter)
               throws WCMException
获取某角色在某站点下的所有用户集合

参数：
_dstRole - 指定的角色
_nSiteId - 站点id
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getUsers

public Users getUsers(Role _dstRole,
                      WCMFilter _filter)
               throws WCMException
获取担任某角色的所有用户集合

参数：
_dstRole - 指定的角色
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getUsersBySystemRoleForUser

public Users getUsersBySystemRoleForUser(Role _dstRole,
                                         int _nSiteId,
                                         WCMFilter _filter)
                                  throws WCMException
获取当前登录用户可以查看的某系统级角色的所有用户集合

参数：
_dstRole - 指定的角色
_nSiteId - 站点id
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getUsersBySpecailForUser

public Users getUsersBySpecailForUser(Role _dstRole,
                                      WCMFilter _filter)
                               throws WCMException
获取当前登录用户可以查看的某特定角色的所有用户集合

参数：
_dstRole - 指定的角色
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(Role _roleToDelete,
                      boolean _bDrop)
               throws WCMException
删除角色

参数：
_roleToDelete - 需要删除的角色
_bDrop - 是否彻底删除(暂保留?)
返回：
@throws WCMException
抛出：
WCMException

save

public Role save(Role _currRole)
          throws WCMException
保存指定的角色

参数：
_currRole - 需要保存的角色
返回：
@throws WCMException
抛出：
WCMException

getRoleUsers

public RoleUsers getRoleUsers(Role _theRole,
                              WCMFilter _filter)
                       throws WCMException
获取指定角色下的角色用户信息

参数：
_theRole -
_filter -
返回：
抛出：
WCMException

getRoleUsers

public RoleUsers getRoleUsers(User _theUser,
                              WCMFilter _filter)
                       throws WCMException
获取指定用户下的角色用户信息

参数：
_theUser -
_filter -
返回：
抛出：
WCMException

isRoleManagers

public boolean isRoleManagers(User _user)
                       throws WCMException
判断指定用户是否为角色管理员

参数：
_user -
返回：
抛出：
WCMException

getRolesForUser

public Roles getRolesForUser(User _user,
                             WCMFilter _filter)
                      throws WCMException
获取指定用户可见的角色

参数：
_user -
返回：
抛出：
WCMException

setRoleUsers

public void setRoleUsers(Role role,
                         int _nSiteId,
                         Users _users)
                  throws WCMException
绑定角色,站点和用户的关联，同时将清除原来的关联

参数：
role -
groups -
抛出：
WCMException

getSystemRolesOfUser

public Roles getSystemRolesOfUser(User _user,
                                  int nSiteId,
                                  WCMFilter _filter)
                           throws WCMException
获取指定用户在指定站点上设置的角色信息

参数：
_user -
nSiteId -
返回：
抛出：
WCMException

getSpecialRolesOfUser

public Roles getSpecialRolesOfUser(User _user,
                                   WCMFilter _filter)
                            throws WCMException
获取指定用户上设置的特定角色

参数：
_user -
_filter -
返回：
抛出：
WCMException

setSystemRolesOfUser

public void setSystemRolesOfUser(User _user,
                                 int _nSiteId,
                                 Roles roles)
                          throws WCMException
设置用户在指定站点上的系统级角色，同时将清除原来的关联

参数：
role -
groups -
抛出：
WCMException

setSpecailRolesOfUser

public void setSpecailRolesOfUser(User _user,
                                  Roles _roles)
                           throws WCMException
设置用户的特定角色，同时将清除原来的特定角色d关联

参数：
role -
groups -
抛出：
WCMException

findRoleByName

public Role findRoleByName(java.lang.String sRoleName)
                    throws WCMException
根据角色名称，获取到第一个匹配的角色，优先获取id值更大的角色

参数：
sRoleName -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleUserIdsMan

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 RoleUserIdsMan

java.lang.Object
    继承者  com.trs.infra.common.BaseIdsMan
        继承者  com.trs.cms.auth.domain.RoleUserIdsMan

public class RoleUserIdsMan
extends BaseIdsMan

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RoleUserIdsMan(int _nRoleId)
方法摘要
从类 com.trs.infra.common.BaseIdsMan 继承的方法
dowithIds
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleUserIdsMan

public RoleUserIdsMan(int _nRoleId)
               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UpdUserScheduleCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 UpdUserScheduleCreator

java.lang.Object
    继承者  com.trs.cms.auth.domain.UpdUserScheduleCreator

public class UpdUserScheduleCreator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
UpdUserScheduleCreator()
方法摘要
static void scheduleUpdUserRelatedInfo(User userToBeDeleted, User user)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UpdUserScheduleCreator

public UpdUserScheduleCreator()
方法详细信息

scheduleUpdUserRelatedInfo

public static void scheduleUpdUserRelatedInfo(User userToBeDeleted,
                                              User user)
                                       throws WCMException
参数：
userToBeDeleted -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserInfoSyncUpdater

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 UserInfoSyncUpdater

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.cms.auth.domain.UserInfoSyncUpdater
所有已实现的接口：
org.quartz.Job
public class UserInfoSyncUpdater
extends BaseJob

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
UserInfoSyncUpdater()
方法摘要
从类 com.trs.infra.util.job.BaseJob 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserInfoSyncUpdater

public UserInfoSyncUpdater()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserMgr

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.domain
类 UserMgr

java.lang.Object
    继承者  com.trs.cms.auth.domain.UserMgr

public class UserMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String USER_DEFAULT_PASSWORD
构造方法摘要
UserMgr()
方法摘要
boolean | changeUserRegStatus(User _dstUser, int _nNewStatusId) 更改用户的注册状态
boolean | delete(User _aUserToBeDeleted, boolean _bDrop) 删除一个用户
Users | getConsignUsers(int _nModuleType) 获取当前用户的托管人
Groups | getGroups(User _dstUser) 获取当前用户所在的所有组织
Rights | getMyRights(int _nOperatorType, int _nOperatorId, int _nObjType) 获取指定操作者在某类对象上的操作权限
RightValue | getMyRightValue(CMSObj _obj) 取用户在指定对象上的操作权限值
RightValue | getMyRightValue(int _objType, int _objId) 取用户在指定对象上的操作权限值
Roles | getRoles(User _dstUser) 获取当前用户担任的所有角色
Rights | getUserRightsOnWCMObj(int _nObjType) 获取当前用户在指定类型的对象上的权限集合
boolean | isAdminOfGroup(User _user) 判断指定用户是否在系统中担任组管理员
boolean | isManagerOfRole(User _user) 判断指定用户是否在系统中担任角色维护员
boolean | isManagerOfUser(User _user) 判断当前登录用户是否能够管理指定的用户
boolean | resetPassword(User _dstUser) 系统管理员重设指定用户的密码为默认密码,用于密码恢复
boolean | resetPassword(User _dstUser, java.lang.String _sNewPassword) 重置用户密码为新密码
boolean | resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword) 重设指定用户的密码
User | save(User _dstUser) 保存用户
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

USER_DEFAULT_PASSWORD

public static final java.lang.String USER_DEFAULT_PASSWORD
另请参见：
常量字段值
构造方法详细信息

UserMgr

public UserMgr()
方法详细信息

getUserRightsOnWCMObj

public Rights getUserRightsOnWCMObj(int _nObjType)
                             throws WCMException
获取当前用户在指定类型的对象上的权限集合

参数：
_nObjType - 指定的对象类型
返回：
@throws WCMException
抛出：
WCMException

getMyRightValue

public RightValue getMyRightValue(CMSObj _obj)
                           throws WCMException
取用户在指定对象上的操作权限值

参数：
_obj - 指定对象
返回：
用户在指定对象上的操作权限值
抛出：
WCMException

getMyRightValue

public RightValue getMyRightValue(int _objType,
                                  int _objId)
                           throws WCMException
取用户在指定对象上的操作权限值

参数：
_objType - 指定对象的类型
_objId - 指定对象的ID
返回：
用户在指定对象上的操作权限值（RightValue）
抛出：
WCMException

getGroups

public Groups getGroups(User _dstUser)
                 throws WCMException
获取当前用户所在的所有组织

参数：
_dstUser - 当前用户
返回：
@throws WCMException
抛出：
WCMException

getRoles

public Roles getRoles(User _dstUser)
               throws WCMException
获取当前用户担任的所有角色

参数：
_dstUser - 当前操作用户
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(User _aUserToBeDeleted,
                      boolean _bDrop)
               throws WCMException
删除一个用户

参数：
_aUserToBeDeleted - 要删除的用户
_bDrop - 是否彻底删除,false表示不删除,把要删除的用户置为删除状态.true则从系统中彻底删除
返回：
@throws WCMException
抛出：
WCMException

changeUserRegStatus

public boolean changeUserRegStatus(User _dstUser,
                                   int _nNewStatusId)
                            throws WCMException
更改用户的注册状态

参数：
_dstUser - 要更改的用户
_nNewStatusId - 新状态Id(User.USER_STATUS_REG/DEL)等
抛出：
WCMException

getConsignUsers

public Users getConsignUsers(int _nModuleType)
                      throws WCMException
获取当前用户的托管人

参数：
_nModuleType - 托管模块的类型(TrusteeInfo.FLOW_DOC等)
返回：
@throws WCMException
抛出：
WCMException

getMyRights

public Rights getMyRights(int _nOperatorType,
                          int _nOperatorId,
                          int _nObjType)
                   throws WCMException
获取指定操作者在某类对象上的操作权限

参数：
_nOperatorType - 操作者的类型(User.OBJ_TYPE/Role.OBJ_TYPE/Group.OBJ_TYPE等)
_nOperatorId - 操作者id
_nObjType - 操作对象的类型(Channel.OBJ_TYPE等)
返回：
@throws WCMException
抛出：
WCMException

save

public User save(User _dstUser)
          throws WCMException
保存用户

参数：
_dstUser - 要保存的用户
抛出：
WCMException

resetPassword

public boolean resetPassword(User _dstUser,
                             java.lang.String _sOldPassword,
                             java.lang.String _sNewPassword)
                      throws WCMException
重设指定用户的密码

参数：
_dstUser - 指定的用户
_sOldPassword - 旧密码
_sNewPassword - 新密码
返回：
@throws WCMException
抛出：
WCMException

resetPassword

public boolean resetPassword(User _dstUser)
                      throws WCMException
系统管理员重设指定用户的密码为默认密码,用于密码恢复

参数：
_dstUser - 指定用户
返回：
@throws WCMException
抛出：
WCMException

resetPassword

public boolean resetPassword(User _dstUser,
                             java.lang.String _sNewPassword)
                      throws WCMException
重置用户密码为新密码

参数：
_dstUser -
_sNewPassword -
返回：
抛出：
WCMException

isAdminOfGroup

public boolean isAdminOfGroup(User _user)
                       throws WCMException
判断指定用户是否在系统中担任组管理员

参数：
_user - 指定用户
返回：
如果有则返回 true
抛出：
WCMException

isManagerOfRole

public boolean isManagerOfRole(User _user)
                        throws WCMException
判断指定用户是否在系统中担任角色维护员

参数：
_user - 指定用户
返回：
如果有则返回 true
抛出：
WCMException

isManagerOfUser

public boolean isManagerOfUser(User _user)
                        throws WCMException
判断当前登录用户是否能够管理指定的用户

参数：
_user - 指定用户
返回：
如果有则返回 true
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.auth.domain.AuthServer 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.AuthServer
的使用

没有 com.trs.cms.auth.domain.AuthServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.DepartmentMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.DepartmentMgrImpl
的使用

没有 com.trs.cms.auth.domain.DepartmentMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.GroupAuthServer 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.GroupAuthServer
的使用

没有 com.trs.cms.auth.domain.GroupAuthServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.GroupMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.GroupMgr
的使用

使用 GroupMgr 的软件包
com.trs.presentation.ids

com.trs.presentation.ids 中 GroupMgr 的使用

返回 GroupMgr 的 com.trs.presentation.ids 中的方法
static GroupMgr ActorHelper.getGroupMgr()
获取GroupMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.GroupRightObjImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.GroupRightObjImpl
的使用

没有 com.trs.cms.auth.domain.GroupRightObjImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.GroupRoleMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.GroupRoleMgr
的使用

没有 com.trs.cms.auth.domain.GroupRoleMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.GrpUserIdsMan 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.GrpUserIdsMan
的使用

没有 com.trs.cms.auth.domain.GrpUserIdsMan 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.auth.domain.IDepartmentMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.auth.domain.IDepartmentMgr
的使用

使用 IDepartmentMgr 的软件包
com.trs.cms.auth.domain

com.trs.cms.auth.domain 中 IDepartmentMgr 的使用

实现 IDepartmentMgr 的 com.trs.cms.auth.domain 中的类
 class DepartmentMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.auth.domain.IObjectMemberMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.auth.domain.IObjectMemberMgr
的使用

使用 IObjectMemberMgr 的软件包
com.trs.cms.auth.domain

com.trs.cms.auth.domain 中 IObjectMemberMgr 的使用

实现 IObjectMemberMgr 的 com.trs.cms.auth.domain 中的类
 class ObjectMemberMgr
可见可操作对象的缓冲管理.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.auth.domain.IRightHost 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.auth.domain.IRightHost
的使用

使用 IRightHost 的软件包
com.trs.cms.auth.config |
com.trs.cms.auth.domain |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.wcm.content.domain.auth |

com.trs.cms.auth.config 中 IRightHost 的使用

返回 IRightHost 的 com.trs.cms.auth.config 中的方法
IRightHost | RightHostConfig.getRightHost()
IRightHost | RightHostConfig.makeNewHostInstance() 构造一个新的RightHost实例
IRightHost | RightConfigServer.makeRightHostInstance(int _nHostType)

com.trs.cms.auth.domain 中 IRightHost 的使用

返回 IRightHost 的 com.trs.cms.auth.domain 中的方法
IRightHost[] | IRightHost.getChildren() 获取当前对象的一级子对象
IRightHost | IRightHost.getParent() 获取父对象
static IRightHost | AuthServer.makeRightHost(int _nHostType, int _nHostId) 通过指定的HostType和HostId构造IRightHost的实现
static IRightHost | RightHostFactory.makeRightHostFrom(CMSObj _oCMSObj)
static IRightHost | RightHostFactory.makeRightHostFrom(int _nHostType, int _nHostId)

参数类型为 IRightHost 的 com.trs.cms.auth.domain 中的方法
void | NewRightSet.inheritRights(User _loginUser, IRightHost _rightHost, boolean _bDropOldRights) 继承父对象的权限
void | RightSet.inheritRights(User _loginUser, IRightHost _rightHost, boolean _bDropOldRights) 继承父对象的权限
boolean | RightSet.setRights(User loginUser, IRightHost _rightHost, java.util.List _currRightList, boolean _bSetChildrenRight)

参数类型为 IRightHost 的 com.trs.cms.auth.domain 中的构造方法
NewRightSet(User _loginUser, IRightHost _rightHost, java.util.List _currRightList, int[] _pImpartMode)

com.trs.components.infoview 中 IRightHost 的使用

实现 IRightHost 的 com.trs.components.infoview 中的类
class | RightHostInfoViewField
class | RightHostInfoViewGroup
class | RightHostInfoViewView

返回 IRightHost 的 com.trs.components.infoview 中的方法
IRightHost[] | RightHostInfoViewField.getChildren()
IRightHost[] | RightHostInfoViewGroup.getChildren()
IRightHost[] | RightHostInfoViewView.getChildren()
IRightHost | RightHostInfoViewField.getParent()
IRightHost | RightHostInfoViewGroup.getParent()
IRightHost | RightHostInfoViewView.getParent()

com.trs.components.wcm.content.domain.auth 中 IRightHost 的使用

实现 IRightHost 的 com.trs.components.wcm.content.domain.auth 中的类
class | ChannelRightHostImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentRightHostImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteRightHostImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IRightHost 的 com.trs.components.wcm.content.domain.auth 中的方法
IRightHost[] | WebSiteRightHostImpl.getChildren()
IRightHost[] | ChannelRightHostImpl.getChildren()
IRightHost[] | DocumentRightHostImpl.getChildren()
IRightHost | WebSiteRightHostImpl.getParent()
IRightHost | ChannelRightHostImpl.getParent()
IRightHost | DocumentRightHostImpl.getParent()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.auth.domain.IRightMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.auth.domain.IRightMgr
的使用

使用 IRightMgr 的软件包
com.trs.cms.auth.domain

com.trs.cms.auth.domain 中 IRightMgr 的使用

实现 IRightMgr 的 com.trs.cms.auth.domain 中的类
 class RightMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
权限管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.auth.domain.IRightObj 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.auth.domain.IRightObj
的使用

使用 IRightObj 的软件包
com.trs.cms.auth.config
com.trs.cms.auth.domain
com.trs.components.common.publish.domain.auth
com.trs.components.wcm.auth

com.trs.cms.auth.config 中 IRightObj 的使用

返回 IRightObj 的 com.trs.cms.auth.config 中的方法
IRightObj | RightObjectConfig.getRightObject()
IRightObj | RightObjectConfig.makeNewHostInstance() 构造一个新的RightHost实例
IRightObj | RightConfigServer.makeRightObjectInstance(int _nObjType)

com.trs.cms.auth.domain 中 IRightObj 的使用

实现 IRightObj 的 com.trs.cms.auth.domain 中的类
 class GroupRightObjImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IRightObj 的 com.trs.cms.auth.domain 中的方法
static IRightObj | RightObjectFactory.makeRightObjectFrom(CMSObj _oCMSObj)
static IRightObj | RightObjectFactory.makeRightObjectFrom(int _nObjectType, int _nObjectId)

com.trs.components.common.publish.domain.auth 中 IRightObj 的使用

实现 IRightObj 的 com.trs.components.common.publish.domain.auth 中的类
 class TemplateRightObjImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
模板权限判断的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.auth 中 IRightObj 的使用

实现 IRightObj 的 com.trs.components.wcm.auth 中的类
class | ChannelRightObjImpl
class | WebSiteRightObjImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.NewRightSet 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.NewRightSet
的使用

没有 com.trs.cms.auth.domain.NewRightSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.ObjectMemberMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.ObjectMemberMgr
的使用

没有 com.trs.cms.auth.domain.ObjectMemberMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster
的使用

没有 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RightCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RightCacheMgr
的使用

没有 com.trs.cms.auth.domain.RightCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RightHostFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RightHostFactory
的使用

没有 com.trs.cms.auth.domain.RightHostFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RightHostLCListenerForInherit 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RightHostLCListenerForInherit
的使用

没有 com.trs.cms.auth.domain.RightHostLCListenerForInherit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RightMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RightMgr
的使用

没有 com.trs.cms.auth.domain.RightMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RightObjectFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RightObjectFactory
的使用

没有 com.trs.cms.auth.domain.RightObjectFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RightSet 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RightSet
的使用

没有 com.trs.cms.auth.domain.RightSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RoleAuthServer 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RoleAuthServer
的使用

没有 com.trs.cms.auth.domain.RoleAuthServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RoleMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RoleMgr
的使用

没有 com.trs.cms.auth.domain.RoleMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.RoleUserIdsMan 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.RoleUserIdsMan
的使用

没有 com.trs.cms.auth.domain.RoleUserIdsMan 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.UpdUserScheduleCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.UpdUserScheduleCreator
的使用

没有 com.trs.cms.auth.domain.UpdUserScheduleCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.UserInfoSyncUpdater 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.UserInfoSyncUpdater
的使用

没有 com.trs.cms.auth.domain.UserInfoSyncUpdater 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.domain.UserMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.domain.UserMgr
的使用

使用 UserMgr 的软件包
com.trs.presentation.ids

com.trs.presentation.ids 中 UserMgr 的使用

返回 UserMgr 的 com.trs.presentation.ids 中的方法
static UserMgr ActorHelper.getUserMgr()
获取UserMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.cms.auth.logger
类
RightLogger
RoleUserLogger


com.trs.cms.auth.logger

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.auth.logger

类摘要
RightLogger | Title: TRS 内容协作平台（TRS WCM） Description: 权限对象操作日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
RoleUserLogger | Title: TRS 内容协作平台（TRS WCM） Description: 角色用户日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)


com.trs.cms.auth.logger 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth.logger 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.logger.ObjLoggerBase (implements com.trs.cms.logger.IObjLogger)
      • com.trs.cms.auth.logger.RightLogger
    • com.trs.cms.auth.logger.RoleUserLogger (implements com.trs.cms.logger.IObjLogger)


软件包 com.trs.cms.auth.logger 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth.logger
的使用

没有 com.trs.cms.auth.logger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RightLogger

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.logger
类 RightLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.cms.auth.logger.RightLogger
所有已实现的接口：
IObjLogger
public class RightLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
权限对象操作日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
RightLogger()
方法摘要
 int getLogObjType()
获取该日志是记录那个对象的
从类 com.trs.cms.logger.ObjLoggerBase 继承的方法
makeLogOnAdd, makeLogOnDel, makeLogOnModify
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightLogger

public RightLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


RoleUserLogger

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.logger
类 RoleUserLogger

java.lang.Object
    继承者  com.trs.cms.auth.logger.RoleUserLogger
所有已实现的接口：
IObjLogger
public class RoleUserLogger
extends java.lang.Object
implements IObjLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
角色用户日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
RoleUserLogger()
方法摘要
int | getLogObjType() 获取该日志是记录那个对象的
LogInfo | makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleUserLogger

public RoleUserLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()

makeLogOnAdd

public LogInfo makeLogOnAdd(BaseObj newobj)
从接口 IObjLogger 复制的描述
根据指定的对象构造新增日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnAdd
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnDel

public LogInfo makeLogOnDel(BaseObj objdeleted)
从接口 IObjLogger 复制的描述
根据指定的对象构造删除日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnDel
参数：
objdeleted - 删除的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnModify

public LogInfo makeLogOnModify(BaseObj objmodified)
从接口 IObjLogger 复制的描述
根据指定的对象构造修改日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnModify
参数：
objmodified - 修改的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.auth.logger.RightLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.logger.RightLogger
的使用

没有 com.trs.cms.auth.logger.RightLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.logger.RoleUserLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.logger.RoleUserLogger
的使用

没有 com.trs.cms.auth.logger.RoleUserLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AdministratorCacheMgr

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 AdministratorCacheMgr

java.lang.Object
    继承者  com.trs.cms.auth.persistent.AdministratorCacheMgr
所有已实现的接口：
IAdministratorCacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class AdministratorCacheMgr
extends java.lang.Object
implements IAdministratorCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
管理员角色用户缓冲管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AdministratorCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
Users | getAdminUsers()
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdministratorCacheMgr

public AdministratorCacheMgr()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO

getAdminUsers

public Users getAdminUsers()
                    throws WCMException
指定者：
接口 IAdministratorCacheMgr 中的 getAdminUsers
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Group

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 Group

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.Group
所有已实现的接口：
java.io.Serializable, java.lang.Cloneable
public class Group
extends CMSObj
implements java.io.Serializable

另请参见：
序列化表格

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
Group()
方法摘要
void | addAdministrator(User _user) 更新用户所属用户组缓冲区（添加）
boolean | addUser(int _addedUserId, User _opUser) 添加新的用户到该组
boolean | addUser(int _addedUserId, User _opUser, boolean _isAdministrator)
boolean | addUser(User _userToAdd, User _opUser)
boolean | addUser(User _userToAdd, User _opUser, boolean _isAdministrator) 添加新的用户到该组
static Group | createNewInstance() 产生当前对象[Group]的实例
static Group | findById(int _nId) 提取指定ID的对象
static Group | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Users | getAdministrator(User _opUser) 取用户所属组对象集合
Groups | getChildren(User _currUser) 取组的子组集合
Groups | getChildren(User _currUser, java.lang.String _sOrder) 获取按照指定的排序方式排序的组的子组集合
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 获取组的描述
java.lang.String | getEmail() 获取组的邮件地址 说明：若有多个邮件地址，则用";"分割
int | getGroupOrder() 提取属性：GroupOrder
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getName() 获取组的名称
Group | getParent() 获取组的父对象（Group）
int | getParentId() 获取组的父对象ID
Users | getUsers(User _currUser) 取组内所有用户集合（Users）
Users | getUsers(User _currUser, java.lang.String _sOrder) 获取按照一定排序方式取组内所有用户集合（Users）
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
boolean | isAdministrator(User _currUser) 判断用户是否是本组的管理员
boolean | isValid() 检查对象数据的有效性
void | removeAdministrator(User _user) 更新用户所属用户组缓冲区（删除）
boolean | setDesc(java.lang.String _desc) 设置组的描述
boolean | setEmail(java.lang.String _email) 设置组的邮件地址 说明：若有多个邮件地址，则用";"分割
boolean | setGroupOrder(int _nOrder) 设置属性：GroupOrder
boolean | setName(java.lang.String _name) 设置组的名称 要求：名称不重复 处理：名称区分大小写。
boolean | setParent(Group _parent) 设置父对象：仅新增模式下有效
boolean | setParent(int _parentId) 设置父对象：仅新增模式下有效
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Group

public Group()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getParentId

public int getParentId()
获取组的父对象ID

返回：
组的父对象ID

getParent

public Group getParent()
                throws WCMException
获取组的父对象（Group）

返回：
组的父对象（Group）
抛出：
WCMException

setParent

public boolean setParent(int _parentId)
                  throws WCMException
设置父对象：仅新增模式下有效

参数：
_parentId - 组的父对象ID
返回：
设置成功返回true;否则返回false
抛出：
WCMException

setParent

public boolean setParent(Group _parent)
                  throws WCMException
设置父对象：仅新增模式下有效

参数：
_parent - 组的父对象（Group）
返回：
设置成功返回true;否则返回false
抛出：
WCMException - 当组_parent无效时会抛出异常

getName

public java.lang.String getName()
获取组的名称

返回：
组的名称（String）

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置组的名称 要求：名称不重复 处理：名称区分大小写。由isValid函数检查并处理。

参数：
_name - 组的名称
返回：
设置成功返回true;否则返回false
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取组的描述

返回：
组的描述（String）

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置组的描述

参数：
_desc - 组的描述（String）
返回：
设置成功返回true;否则返回false
抛出：
WCMException

getEmail

public java.lang.String getEmail()
获取组的邮件地址

说明：若有多个邮件地址，则用";"分割

返回：
组的邮件地址

setEmail

public boolean setEmail(java.lang.String _email)
                 throws WCMException
设置组的邮件地址

说明：若有多个邮件地址，则用";"分割

参数：
_email - 组的邮件地址
返回：
设置成功返回true;否则返回false
抛出：
WCMException

getGroupOrder

public int getGroupOrder()
提取属性：GroupOrder

返回：
GroupOrder

setGroupOrder

public boolean setGroupOrder(int _nOrder)
                      throws WCMException
设置属性：GroupOrder

参数：
GroupOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检查对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
数据合法返回true
抛出：
WCMException - 不合法的数据将会抛出异常

getUsers

public Users getUsers(User _currUser)
               throws WCMException
取组内所有用户集合（Users）

参数：
_currUser - 当前操作用户
返回：
组内所有用户集合（Users）
抛出：
WCMException

getUsers

public Users getUsers(User _currUser,
                      java.lang.String _sOrder)
               throws WCMException
获取按照一定排序方式取组内所有用户集合（Users）

参数：
_currUser - 当前操作用户
_sOrder - 排序方式（String）可以忽略，不指定任何排序方式
返回：
按照一定排序规则取组内所有用户集合（Users）
抛出：
WCMException

getChildren

public Groups getChildren(User _currUser)
                   throws WCMException
取组的子组集合

参数：
_currUser - 当前操作用户
返回：
组的子组集合（Groups）
抛出：
WCMException

getChildren

public Groups getChildren(User _currUser,
                          java.lang.String _sOrder)
                   throws WCMException
获取按照指定的排序方式排序的组的子组集合

参数：
_currUser - 当前操作用户
_sOrder - 排序方式（String）可以忽略，为不指定任何排序方式
返回：
按照指定的排序方式排序的组的子组集合
抛出：
WCMException

addUser

public boolean addUser(int _addedUserId,
                       User _opUser)
                throws WCMException
添加新的用户到该组

参数：
_addedUserId - 要添加用户ID
_opUser - 当前操作用户
返回：
若用户已经在组中，则返回false;若成功，则返回true
抛出：
WCMException - 若参数_addedUserId无效，则抛出异常；

addUser

public boolean addUser(int _addedUserId,
                       User _opUser,
                       boolean _isAdministrator)
                throws WCMException
抛出：
WCMException

addUser

public boolean addUser(User _userToAdd,
                       User _opUser)
                throws WCMException
抛出：
WCMException
另请参见：
addUser( User _userToAdd, User _opUser, boolean _isAdministrator )

addUser

public boolean addUser(User _userToAdd,
                       User _opUser,
                       boolean _isAdministrator)
                throws WCMException
添加新的用户到该组

参数：
_userToAdd - 要添加用户对象
_opUser - 当前操作用户
_isAdministrator - 是否是组的管理员
返回：
若用户已经在组中，则返回false;若成功，则返回true
抛出：
WCMException - 若参数_userToAdd无效，则抛出异常；

addAdministrator

public void addAdministrator(User _user)
更新用户所属用户组缓冲区（添加）

参数：
_group - 用户所属用户组
抛出：
WCMException

removeAdministrator

public void removeAdministrator(User _user)
更新用户所属用户组缓冲区（删除）

参数：
_group - 用户所属用户组
抛出：
WCMException

getAdministrator

public Users getAdministrator(User _opUser)
                       throws WCMException
取用户所属组对象集合

参数：
_opUser - 执行操作的用户
返回：
用户所属组对象集合
抛出：
WCMException

isAdministrator

public boolean isAdministrator(User _currUser)
                        throws WCMException
判断用户是否是本组的管理员

参数：
_currUser - 判断用户
返回：
如果是，返回true；否则返回false;
抛出：
WCMException
WCMException

findById

public static final Group findById(int _nId)
                            throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Group createNewInstance()
                                     throws WCMException
产生当前对象[Group]的实例

返回：
当前对象的实例[Group]
抛出：
WCMException

findByKey

public static final Group findByKey(java.lang.Object _oKey)
                             throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupAdminsCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 GroupAdminsCacheMgr

java.lang.Object
    继承者  com.trs.cms.auth.persistent.GroupAdminsCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class GroupAdminsCacheMgr
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
用户组织管理员缓冲管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
GroupAdminsCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
Users | getAdmins(Group _group) 获取指定用户组的管理员集合
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupAdminsCacheMgr

public GroupAdminsCacheMgr()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

getAdmins

public Users getAdmins(Group _group)
                throws WCMException
获取指定用户组的管理员集合

参数：
_group - 指定的管理员
返回：
用户组管理员集合
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupRole

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 GroupRole

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.GroupRole
所有已实现的接口：
java.lang.Cloneable
public class GroupRole
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
GroupRole()
构造函数：保留默认接口
方法摘要
static GroupRole | createNewInstance() 产生当前对象[GroupRole]的实例
static GroupRole | findById(int _nId) 提取指定ID的对象
static GroupRole | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getGroupId() 提取属性：GroupId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getRoleId() 提取属性：RoleId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setGroupId(int _nGroupId) 设置属性：GroupId
boolean | setRoleId(int _nRoleId) 设置属性：RoleId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

GroupRole

public GroupRole()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getRoleId

public int getRoleId()
提取属性：RoleId

返回：
RoleId

setRoleId

public boolean setRoleId(int _nRoleId)
                  throws WCMException
设置属性：RoleId

参数：
_nRoleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getGroupId

public int getGroupId()
提取属性：GroupId

返回：
GroupId

setGroupId

public boolean setGroupId(int _nGroupId)
                   throws WCMException
设置属性：GroupId

参数：
_nGroupId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final GroupRole findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final GroupRole createNewInstance()
                                         throws WCMException
产生当前对象[GroupRole]的实例

返回：
当前对象的实例[GroupRole]
抛出：
WCMException

findByKey

public static final GroupRole findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupRoles

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 GroupRoles

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.GroupRoles

public class GroupRoles
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
GroupRoles(User _currUser)
构造函数
GroupRoles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static GroupRoles | creatNewInstance(User _currUser) 产生一个当前集合对象[RoleUsers]的实例
static GroupRoles | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static GroupRoles | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RoleUsers]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupRoles

public GroupRoles(User _currUser)
构造函数

另请参见：
GroupRoles( User _currUser, int _initCapacity, int _incCapacity );

GroupRoles

public GroupRoles(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final GroupRoles findByIds(User _currUser,
                                         java.lang.String _sIds)
                                  throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final GroupRoles openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[RoleUsers]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[RoleUsers]
抛出：
WCMException

creatNewInstance

public static GroupRoles creatNewInstance(User _currUser)
                                   throws WCMException
产生一个当前集合对象[RoleUsers]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Groups

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 Groups

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.Groups

public class Groups
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Groups(User _currUser)
Groups(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Groups | createNewInstance(User _currUser) 产生当前集合对象[Groups]的实例
static Groups | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 获取用户组的Class(Group.class)
java.lang.String | getIdFieldName() 获取用户组对象的ID名称
BaseObjs | newInstance() 生成新的集合对象实例
static Groups | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Groups]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Groups

public Groups(User _currUser)

Groups

public Groups(User _currUser,
              int initialCapacity,
              int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
获取用户组对象的ID名称

指定者：
类 BaseObjs 中的 getIdFieldName
返回：

getElementClass

public java.lang.Class getElementClass()
获取用户组的Class(Group.class)

指定者：
类 BaseObjs 中的 getElementClass
返回：

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
抛出：
java.lang.Exception

findByIds

public static final Groups findByIds(User _currUser,
                                     java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Groups）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Groups openWCMObjs(User _currUser,
                                       WCMFilter _filter)
                                throws WCMException
通过指定一个Filter获取当前集合[Groups]

参数：
_filter - 指定的Filter
返回：
当前集合[Groups]
抛出：
WCMException

createNewInstance

public static Groups createNewInstance(User _currUser)
产生当前集合对象[Groups]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 GroupUser

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.GroupUser
所有已实现的接口：
java.lang.Cloneable
public class GroupUser
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
GroupUser()
构造函数：保留默认接口
方法摘要
static GroupUser | createNewInstance() 产生当前对象[GroupUser]的实例
static GroupUser | findById(int _nId) 提取指定ID的对象
static GroupUser | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getGroupId() 提取属性：GroupId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getIsAdministrator() 提取属性：IsAdministrator
int | getUserId() 提取属性：UserId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isAdministrator()
boolean | isValid() 检验对象数据有效性
boolean | setGroupId(int _nGroupId) 设置属性：GroupId
boolean | setIsAdministrator(int _nIsAdministrator) 设置属性：IsAdministrator
boolean | setUserId(int _nUserId) 设置属性：UserId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

GroupUser

public GroupUser()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getGroupId

public int getGroupId()
提取属性：GroupId

返回：
GroupId

setGroupId

public boolean setGroupId(int _nGroupId)
                   throws WCMException
设置属性：GroupId

参数：
_nGroupId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getUserId

public int getUserId()
提取属性：UserId

返回：
UserId

setUserId

public boolean setUserId(int _nUserId)
                  throws WCMException
设置属性：UserId

参数：
_nUserId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isAdministrator

public boolean isAdministrator()

getIsAdministrator

public int getIsAdministrator()
提取属性：IsAdministrator

返回：
IsAdministrator

setIsAdministrator

public boolean setIsAdministrator(int _nIsAdministrator)
                           throws WCMException
设置属性：IsAdministrator

参数：
_nIsAdministrator - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final GroupUser findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final GroupUser createNewInstance()
                                         throws WCMException
产生当前对象[GroupUser]的实例

返回：
当前对象的实例[GroupUser]
抛出：
WCMException

findByKey

public static final GroupUser findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupUserCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 GroupUserCacheMgr

java.lang.Object
    继承者  com.trs.cms.auth.persistent.GroupUserCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class GroupUserCacheMgr
extends java.lang.Object
implements ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
组织用户的缓冲.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int MAX_CACHE_SIZE
构造方法摘要
GroupUserCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAX_CACHE_SIZE

public static int MAX_CACHE_SIZE
构造方法详细信息

GroupUserCacheMgr

public GroupUserCacheMgr()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupUsers

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 GroupUsers

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.GroupUsers

public class GroupUsers
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
组织用户关联对象集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
GroupUsers(User _currUser)
构造函数
GroupUsers(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static GroupUsers | creatNewInstance(User _currUser) 产生一个当前集合对象[GroupUsers]的实例
static GroupUsers | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static GroupUsers | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[GroupUsers]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupUsers

public GroupUsers(User _currUser)
构造函数

另请参见：
GroupUsers( User _currUser, int _initCapacity, int _incCapacity );

GroupUsers

public GroupUsers(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final GroupUsers findByIds(User _currUser,
                                         java.lang.String _sIds)
                                  throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final GroupUsers openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[GroupUsers]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[GroupUsers]
抛出：
WCMException

creatNewInstance

public static GroupUsers creatNewInstance(User _currUser)
                                   throws WCMException
产生一个当前集合对象[GroupUsers]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 GroupXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.cms.auth.persistent.GroupXmlConverter

public class GroupXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
组织对象到XML转换对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
GroupXmlConverter()
方法摘要
boolean | isWithChildren()
void | setWithChildren(boolean withChildren)
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupXmlConverter

public GroupXmlConverter()
方法详细信息

isWithChildren

public boolean isWithChildren()

setWithChildren

public void setWithChildren(boolean withChildren)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IAdministratorCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
接口 IAdministratorCacheMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
AdministratorCacheMgr
public interface IAdministratorCacheMgr
extends ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
IAdministratorCacheMgr,接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 Users getAdminUsers()
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

getAdminUsers

Users getAdminUsers()
                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IUserCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
接口 IUserCacheMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
UserCacheMgr
public interface IUserCacheMgr
extends ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
用户缓冲管理接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 User _getUserByName(java.lang.String _sUserName)
通过指定的用户名获取用户对象
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

_getUserByName

User _getUserByName(java.lang.String _sUserName)
通过指定的用户名获取用户对象

参数：
_sUserName - 指定的用户名
返回：
@throws WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectMember

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 ObjectMember

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.ObjectMember
所有已实现的接口：
java.lang.Cloneable
public class ObjectMember
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ObjectMember()
构造函数：保留默认接口
方法摘要
static ObjectMember | createNewInstance() 产生当前对象[ObjectMember]的实例
static ObjectMember | findById(int _nId) 提取指定ID的对象
static ObjectMember | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static ObjectMember | findByMemberObj(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId)
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getMemberId() 提取属性：MemberId
int | getMemberType() 提取属性：MemberType
int | getObjId() 提取属性：ObjId
int | getObjType() 提取属性：ObjType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isDoOperation() 提取属性：DoOperation
boolean | isValid() 检验对象数据有效性
boolean | isVisible() 提取属性：Visible
boolean | setDoOperation(boolean _bDoOperation) 设置属性：DoOperation
boolean | setMember(int _nMemberType, int _nMemberId)
boolean | setMemberId(int _nMemberId) 设置属性：MemberId
boolean | setMemberType(int _nMemberType) 设置属性：MemberType
boolean | setObj(int _nObjType, int _nObjId)
boolean | setObjId(int _nObjId) 设置属性：ObjId
boolean | setObjType(int _nObjType) 设置属性：ObjType
boolean | setVisible(boolean _bVisible) 设置属性：Visible
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ObjectMember

public ObjectMember()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getMemberType

public int getMemberType()
提取属性：MemberType

返回：
MemberType

setMemberType

public boolean setMemberType(int _nMemberType)
                      throws WCMException
设置属性：MemberType

参数：
_nMemberType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMemberId

public int getMemberId()
提取属性：MemberId

返回：
MemberId

setMemberId

public boolean setMemberId(int _nMemberId)
                    throws WCMException
设置属性：MemberId

参数：
_nMemberId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setMember

public boolean setMember(int _nMemberType,
                         int _nMemberId)
                  throws WCMException
抛出：
WCMException

getObjType

public int getObjType()
提取属性：ObjType

返回：
ObjType

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
设置属性：ObjType

参数：
_nObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

public int getObjId()
提取属性：ObjId

返回：
ObjId

setObjId

public boolean setObjId(int _nObjId)
                 throws WCMException
设置属性：ObjId

参数：
_nObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setObj

public boolean setObj(int _nObjType,
                      int _nObjId)
               throws WCMException
抛出：
WCMException

isVisible

public boolean isVisible()
提取属性：Visible

返回：
Visible

setVisible

public boolean setVisible(boolean _bVisible)
                   throws WCMException
设置属性：Visible

参数：
_bVisible - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isDoOperation

public boolean isDoOperation()
提取属性：DoOperation

返回：
DoOperation

setDoOperation

public boolean setDoOperation(boolean _bDoOperation)
                       throws WCMException
设置属性：DoOperation

参数：
_bDoOperation - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final ObjectMember findById(int _nId)
                                   throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ObjectMember createNewInstance()
                                            throws WCMException
产生当前对象[ObjectMember]的实例

返回：
当前对象的实例[ObjectMember]
抛出：
WCMException

findByKey

public static final ObjectMember findByKey(java.lang.Object _oKey)
                                    throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByMemberObj

public static final ObjectMember findByMemberObj(int _nMemberType,
                                                 int _nMemberId,
                                                 int _nObjType,
                                                 int _nObjId)
                                          throws WCMException
参数：
_nMemberType -
_nMemberId -
_nObjType -
_nObjId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectMembers

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 ObjectMembers

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.ObjectMembers

public class ObjectMembers
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ObjectMembers(User _currUser)
构造函数
ObjectMembers(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ObjectMembers | createNewInstance(User _currUser) 产生当前集合对象[ObjectMembers]的实例
static ObjectMembers | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ObjectMembers | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ObjectMembers]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectMembers

public ObjectMembers(User _currUser)
构造函数

另请参见：
ObjectMembers( User _currUser, int _initCapacity, int _incCapacity );

ObjectMembers

public ObjectMembers(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ObjectMembers findByIds(User _currUser,
                                            java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectMembers）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ObjectMembers openWCMObjs(User _currUser,
                                              WCMFilter _filter)
                                       throws WCMException
通过指定一个Filter获取当前集合[ObjectMembers]

参数：
_filter - 指定的Filter
返回：
当前集合[ObjectMembers]
抛出：
WCMException

createNewInstance

public static ObjectMembers createNewInstance(User _currUser)
产生当前集合对象[ObjectMembers]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.auth.persistent
接口
IAdministratorCacheMgr
IUserCacheMgr
类
AdministratorCacheMgr
Group
GroupAdminsCacheMgr
GroupRole
GroupRoles
Groups
GroupUser
GroupUserCacheMgr
GroupUsers
GroupXmlConverter
ObjectMember
ObjectMembers
Right
RightDef
RightDefs
Rights
RightValue
Role
Roles
RoleUser
RoleUserCacheMgr
RoleUsers
RoleXmlConverter
TrusteeInfo
TrusteeInfos
User
UserCacheMgr
UserLicenseMgr
Users


com.trs.cms.auth.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.auth.persistent

接口摘要
IAdministratorCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: IAdministratorCacheMgr,接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IUserCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 用户缓冲管理接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
AdministratorCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 管理员角色用户缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Group |
GroupAdminsCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 用户组织管理员缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupRole |
GroupRoles |
Groups |
GroupUser |
GroupUserCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
GroupUsers | Title: TRS 内容协作平台（TRS WCM） Description: 组织用户关联对象集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 组织对象到XML转换对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectMember |
ObjectMembers |
Right |
RightDef |
RightDefs |
Rights |
RightValue |
Role |
Roles |
RoleUser | Title: TRS 内容协作平台（TRS WCM） Description: 角色/用户关联对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RoleUserCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
RoleUsers | Title: TRS 内容协作平台（TRS WCM） Description: 角色/用户关联对象集合的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RoleXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 角色对象转换为XML数据格式对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TrusteeInfo |
TrusteeInfos |
User | Title: TRS 内容协作平台（TRS WCM） Description: 用户对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UserCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 用户名缓冲器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UserLicenseMgr | Title: TRS 内容协作平台（TRS WCM） Description: License protected validator Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Users |


com.trs.cms.auth.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.auth.persistent.AdministratorCacheMgr (implements com.trs.cms.auth.persistent.IAdministratorCacheMgr)
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.cms.auth.persistent.Group (implements java.io.Serializable)
        • com.trs.cms.auth.persistent.GroupRole
        • com.trs.cms.auth.persistent.GroupUser
        • com.trs.cms.auth.persistent.ObjectMember
        • com.trs.cms.auth.persistent.Right
        • com.trs.cms.auth.persistent.RightDef
        • com.trs.cms.auth.persistent.Role (implements java.io.Serializable)
        • com.trs.cms.auth.persistent.RoleUser
        • com.trs.cms.auth.persistent.TrusteeInfo
        • com.trs.cms.auth.persistent.User (implements java.io.Serializable)
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.cms.auth.persistent.GroupRoles
        • com.trs.cms.auth.persistent.Groups
        • com.trs.cms.auth.persistent.GroupUsers
        • com.trs.cms.auth.persistent.ObjectMembers
        • com.trs.cms.auth.persistent.RightDefs
        • com.trs.cms.auth.persistent.Rights
        • com.trs.cms.auth.persistent.Roles
        • com.trs.cms.auth.persistent.RoleUsers
        • com.trs.cms.auth.persistent.TrusteeInfos
        • com.trs.cms.auth.persistent.Users
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.cms.auth.persistent.GroupXmlConverter
      • com.trs.cms.auth.persistent.RoleXmlConverter
    • com.trs.infra.util.CMyBitsValue (implements java.lang.Cloneable)
      • com.trs.cms.auth.persistent.RightValue
    • com.trs.cms.auth.persistent.GroupAdminsCacheMgr (implements com.trs.infra.support.cache.ICacheMgr, com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.cms.auth.persistent.GroupUserCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.cms.auth.persistent.RoleUserCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.cms.auth.persistent.UserCacheMgr (implements com.trs.cms.auth.persistent.IUserCacheMgr)
    • com.trs.cms.auth.persistent.UserLicenseMgr

接口分层结构

  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.cms.auth.persistent.IAdministratorCacheMgr
        • com.trs.cms.auth.persistent.IUserCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.cms.auth.persistent.IAdministratorCacheMgr
        • com.trs.cms.auth.persistent.IUserCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.cms.auth.persistent.IAdministratorCacheMgr
        • com.trs.cms.auth.persistent.IUserCacheMgr


软件包 com.trs.cms.auth.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.auth.persistent
的使用

使用 com.trs.cms.auth.persistent 的软件包
com.trs.ajaxservice |
com.trs.ajaxservice.xmlconvertors |
com.trs.cms |
com.trs.cms.auth |
com.trs.cms.auth.domain |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.logger |
com.trs.cms.process |
com.trs.cms.process.config |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.cms.process.engine.creators |
com.trs.cms.process.xml |
com.trs.components.comment.persistent |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.domain.auth |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.gkml.sqgk.process.element |
com.trs.components.gkml.sqgk.process.engine.creators |
com.trs.components.govinfo |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.definition |
com.trs.components.metadata.definition.xml |
com.trs.components.metadata.publish |
com.trs.components.metadata.right |
com.trs.components.metadata.service |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.auth |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.trsserver |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.process |
com.trs.components.wcm.process.element |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.util |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.jsp |
com.trs.components.wcm.wcmx.media |
com.trs.components.wcm.wcmx.websites |
com.trs.infra.persistent.util |
com.trs.presentation.ids |
com.trs.presentation.locale |
com.trs.presentation.nav |
com.trs.presentation.right |
com.trs.presentation.util |
com.trs.presentation.wcm.content |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.config |
com.trs.wcm.customize |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |
com.trsupdate |

com.trs.ajaxservice 使用的 com.trs.cms.auth.persistent 中的类
Groups
ObjectMembers
RightValue
Roles
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.ajaxservice.xmlconvertors 使用的 com.trs.cms.auth.persistent 中的类
RightValue
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.domain 使用的 com.trs.cms.auth.persistent 中的类
Group
Groups
GroupUsers
Title: TRS 内容协作平台（TRS WCM）
Description:
组织用户关联对象集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectMember
Right
Rights
RightValue
Role
Roles
RoleUsers
Title: TRS 内容协作平台（TRS WCM）
Description:
角色/用户关联对象集合的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.cms.auth.persistent 使用的 com.trs.cms.auth.persistent 中的类
Group
GroupRole
GroupRoles
Groups
GroupUser
GroupUsers
Title: TRS 内容协作平台（TRS WCM）
Description:
组织用户关联对象集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IAdministratorCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
IAdministratorCacheMgr,接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IUserCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
用户缓冲管理接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectMember
ObjectMembers
Right
RightDef
RightDefs
Rights
RightValue
Role
Roles
RoleUser
Title: TRS 内容协作平台（TRS WCM）
Description:
角色/用户关联对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RoleUsers
Title: TRS 内容协作平台（TRS WCM）
Description:
角色/用户关联对象集合的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
UserLicenseMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.cms.content 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.logger 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.cms.process.config 使用的 com.trs.cms.auth.persistent 中的类
Group
Users

com.trs.cms.process.definition 使用的 com.trs.cms.auth.persistent 中的类
Groups
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.cms.process.engine 使用的 com.trs.cms.auth.persistent 中的类
Group
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.cms.process.engine.creators 使用的 com.trs.cms.auth.persistent 中的类
Group
Users

com.trs.cms.process.xml 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.comment.persistent 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.address 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.bookmark 使用的 com.trs.cms.auth.persistent 中的类
Groups
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.components.common.calendar 使用的 com.trs.cms.auth.persistent 中的类
Groups
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.components.common.conjection.persistent 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.components.common.publish.domain.auth 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.template 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.distribute 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.element 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.publisher 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.taskdispatch 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.template 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 使用的 com.trs.cms.auth.persistent 中的类
RightValue
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget.tagparser 使用的 com.trs.cms.auth.persistent 中的类
RightValue
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.trsad 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.trsvote 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.persistent 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.engine.creators 使用的 com.trs.cms.auth.persistent 中的类
Users

com.trs.components.govinfo 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.db 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.helper 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.persistent 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.center 使用的 com.trs.cms.auth.persistent 中的类
RightValue
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.center.xml 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition.xml 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.publish 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.right 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 使用的 com.trs.cms.auth.persistent 中的类
Group
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.special 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.cms.auth.persistent 中的类
Group
Groups
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.auth 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 使用的 com.trs.cms.auth.persistent 中的类
RightValue
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.cms.auth.persistent 中的类
Group
Groups
Role
Roles
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.components.wcm.content.domain.auth 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.trsserver 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.customize 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.individuation 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.components.wcm.process.element 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.element 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.logo 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.recent 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.resource 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.stat 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.util 使用的 com.trs.cms.auth.persistent 中的类
RightDefs
Rights
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.help 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.jsp 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.media 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.components.wcm.wcmx.websites 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.util 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.ids 使用的 com.trs.cms.auth.persistent 中的类
Group
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.locale 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.nav 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.right 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.util 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.presentation.wcm.content 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service 使用的 com.trs.cms.auth.persistent 中的类
Group
Groups
Role
Roles
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.service.impl 使用的 com.trs.cms.auth.persistent 中的类
Group
Groups
Role
Roles
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Users

com.trs.wcm.config 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.customize 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.old 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo.impl 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trsupdate 使用的 com.trs.cms.auth.persistent 中的类
User
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Right

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 Right

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.Right
所有已实现的接口：
java.lang.Cloneable
public class Right
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
static int | OPRTYPE_GROUP 操作者类型:组
static int | OPRTYPE_ROLE 操作者类型:角色
static int | OPRTYPE_USER 操作者类型:单个用户
构造方法摘要
Right()
方法摘要
static Right | createNewInstance() 产生当前对象[Right]的实例
static Right | findBy(int _nObjType, int _nObjId, int _nOprType, int _nOprId)
static Right | findById(int _nId) 提取指定ID的对象
static Right | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
static Groups | getGroupsWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的角色集合
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getObjId() 获取操作对象（WCMObj）ID
int | getObjType() 获取操作对象（WCMObj）类型（定义在WCMTypes中）
CMSObj | getOperator() 获取权限操作者对象（用户/角色）
int | getOperatorId() 获取权限操作者（用户/角色）ID
int | getOperatorType() 获取权限操作者（用户/角色）类型(定义在WCMTypes)
static Roles | getRolesWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的角色集合
static Users | getUsersWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的集合用户
RightValue | getValue() 获得权限值对象
long | getValueAsInt() 获得整型的权限值
long | getValueAsLong() 获取长整型的权限值
int | getWCMType() 取得该对象的类型编号（定义在WCMTypes中）
boolean | isValid() 效验数据的有效性
boolean | setObject(CMSObj _obj) 设置操作对象（WCMObj）
boolean | setObject(int _nObjectType, int _nObjectId)
boolean | setObjId(int _objId) 设置操作对象（WCMObj）ID
boolean | setObjType(int _objType) 设置操作对象（WCMObj）类型（定义在WCMTypes中）
boolean | setOperator(CMSObj _operator) 设置权限操作者对象（用户或角色） 说明：仅添加时可用
boolean | setOperator(int _nOperType, int _nOperId)
boolean | setOperatorId(int _operatorId) 设置权限操作者（用户/角色）ID
boolean | setOperatorType(int _operatorType) 设置权限操作者（用户/角色）类型(定义在WCMTypes)
boolean | setValue(long _lValue) 使用长整型数设定权限值
boolean | setValue(RightValue _rightValue) 使用RightValue对象定权限值
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

OPRTYPE_USER

public static final int OPRTYPE_USER
操作者类型:单个用户

另请参见：
常量字段值

OPRTYPE_ROLE

public static final int OPRTYPE_ROLE
操作者类型:角色

另请参见：
常量字段值

OPRTYPE_GROUP

public static final int OPRTYPE_GROUP
操作者类型:组

另请参见：
常量字段值
构造方法详细信息

Right

public Right()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getObjType

public int getObjType()
获取操作对象（WCMObj）类型（定义在WCMTypes中）

返回：

setObjType

public boolean setObjType(int _objType)
                   throws WCMException
设置操作对象（WCMObj）类型（定义在WCMTypes中）

参数：
_objType - 操作对象（WCMObj）类型（定义在WCMTypes中）
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

public int getObjId()
获取操作对象（WCMObj）ID

返回：
操作对象（WCMObj）ID

setObjId

public boolean setObjId(int _objId)
                 throws WCMException
设置操作对象（WCMObj）ID

参数：
_objId - 操作对象（WCMObj）ID
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setObject

public boolean setObject(CMSObj _obj)
                  throws WCMException
设置操作对象（WCMObj）

参数：
_obj - 操作对象（WCMObj）
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setObject

public boolean setObject(int _nObjectType,
                         int _nObjectId)
                  throws WCMException
抛出：
WCMException

getOperatorType

public int getOperatorType()
获取权限操作者（用户/角色）类型(定义在WCMTypes)

返回：
权限操作者（用户/角色）类型(定义在WCMTypes)

setOperatorType

public boolean setOperatorType(int _operatorType)
                        throws WCMException
设置权限操作者（用户/角色）类型(定义在WCMTypes)

参数：
_operatorType - 权限操作者（用户/角色）类型(定义在WCMTypes)
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOperatorId

public int getOperatorId()
获取权限操作者（用户/角色）ID

返回：

setOperatorId

public boolean setOperatorId(int _operatorId)
                      throws WCMException
设置权限操作者（用户/角色）ID

参数：
_operatorId -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOperator

public CMSObj getOperator()
                   throws WCMException
获取权限操作者对象（用户/角色）

返回：
权限操作者对象（用户/角色）
抛出：
WCMException

setOperator

public boolean setOperator(CMSObj _operator)
                    throws WCMException
设置权限操作者对象（用户或角色） 说明：仅添加时可用

参数：
_operator - 操作者对象（必须是User,Role中的一个）
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setOperator

public boolean setOperator(int _nOperType,
                           int _nOperId)
                    throws WCMException
抛出：
WCMException

getValueAsLong

public long getValueAsLong()
获取长整型的权限值

返回：
长整型的权限值

getValueAsInt

public long getValueAsInt()
获得整型的权限值

返回：
整型的权限值

getValue

public RightValue getValue()
获得权限值对象

返回：
权限值对象

setValue

public boolean setValue(RightValue _rightValue)
                 throws WCMException
使用RightValue对象定权限值

参数：
_rightValue - 权限值解析对象
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setValue

public boolean setValue(long _lValue)
                 throws WCMException
使用长整型数设定权限值

参数：
_lValue - 长整型的权限值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
效验数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
数据合法返回true；否则返回false
抛出：
WCMException - 数据无效时会抛出异常

getUsersWithRight

public static Users getUsersWithRight(User _currUser,
                                      int _objType,
                                      int _objId,
                                      boolean _blHasRight)
                               throws WCMException
获取在指定对象上设置了权限（/没有设置权限）的集合用户

参数：
_currUser - 当前操作用户
_app - 应用服务器
_objType - 对象类型
_objId - 对象ID
_blHasRight - 指定返回设置了权限的还是没有设置权限的；

true表示设置权限的;false表示没有设置权限的

返回：
在指定对象上设置了权限（/没有设置权限）的用户集合（Users）
抛出：
WCMException

getRolesWithRight

public static Roles getRolesWithRight(User _currUser,
                                      int _objType,
                                      int _objId,
                                      boolean _blHasRight)
                               throws WCMException
获取在指定对象上设置了权限（/没有设置权限）的角色集合

参数：
_currUser - 当前操作用户
_app - 应用服务器
_objType - 对象类型
_objId - 对象ID
_blHasRight - 指定返回设置了权限的还是没有设置权限的；

true表示设置权限的;false表示没有设置权限的

返回：
在指定对象上设置了权限（/没有设置权限）的角色集合（Roles）
抛出：
WCMException

getGroupsWithRight

public static Groups getGroupsWithRight(User _currUser,
                                        int _objType,
                                        int _objId,
                                        boolean _blHasRight)
                                 throws WCMException
获取在指定对象上设置了权限（/没有设置权限）的角色集合

参数：
_currUser - 当前操作用户
_app - 应用服务器
_objType - 对象类型
_objId - 对象ID
_blHasRight - 指定返回设置了权限的还是没有设置权限的；

true表示设置权限的;false表示没有设置权限的

返回：
在指定对象上设置了权限（/没有设置权限）的用户组集合（Groups）
抛出：
WCMException

findBy

public static final Right findBy(int _nObjType,
                                 int _nObjId,
                                 int _nOprType,
                                 int _nOprId)
                          throws WCMException
抛出：
WCMException

findById

public static final Right findById(int _nId)
                            throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Right createNewInstance()
                                     throws WCMException
产生当前对象[Right]的实例

返回：
当前对象的实例[Right]
抛出：
WCMException

findByKey

public static final Right findByKey(java.lang.Object _oKey)
                             throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightDef

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 RightDef

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.RightDef
所有已实现的接口：
java.lang.Cloneable
public class RightDef
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
RightDef()
方法摘要
static RightDef | createNewInstance() 产生当前对象[RightDef]的实例
static RightDef | findById(int _nId) 提取指定ID的对象
static RightDef | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc()
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getIndex()
java.lang.String | getName()
int | getObjType()
int | getWCMType() 取得该对象的类型编号（定义在WCMTypes中）
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isSysDefined()
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setDesc(java.lang.String _desc)
boolean | setIndex(int _index)
boolean | setName(java.lang.String _name)
boolean | setObjType(int _nObjType)
boolean | setSysDefined(boolean _bSysDefined)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

RightDef

public RightDef()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getObjType

public int getObjType()

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
抛出：
WCMException

getIndex

public int getIndex()

setIndex

public boolean setIndex(int _index)
                 throws WCMException
抛出：
WCMException

getName

public java.lang.String getName()

setName

public boolean setName(java.lang.String _name)
                throws WCMException
抛出：
WCMException

isSysDefined

public boolean isSysDefined()

setSysDefined

public boolean setSysDefined(boolean _bSysDefined)
                      throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

findById

public static final RightDef findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final RightDef createNewInstance()
                                        throws WCMException
产生当前对象[RightDef]的实例

返回：
当前对象的实例[RightDef]
抛出：
WCMException

findByKey

public static final RightDef findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightDefs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 RightDefs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.RightDefs

public class RightDefs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
RightDefs(User _currUser)
RightDefs(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static RightDefs | createNewInstance(User _currUser) 产生一个当前集合对象[RightDefs]的实例
static RightDefs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
int[] | getAllIndexes()
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
static void | main(java.lang.String[] args)
BaseObjs | newInstance() 生成新的集合对象实例
void | open(int _nObjType, boolean _bIndexDesc)
static RightDefs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RightDefs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightDefs

public RightDefs(User _currUser)

RightDefs

public RightDefs(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

open

public void open(int _nObjType,
                 boolean _bIndexDesc)
          throws WCMException
抛出：
WCMException

getAllIndexes

public int[] getAllIndexes()

findByIds

public static final RightDefs findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final RightDefs openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[RightDefs]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[RightDefs]
抛出：
WCMException

createNewInstance

public static RightDefs createNewInstance(User _currUser)
                                   throws WCMException
产生一个当前集合对象[RightDefs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Rights

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 Rights

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.Rights

public class Rights
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Rights(User _currUser)
Rights(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Rights | createNewInstance(User _currUser) 产生当前集合对象[Rights]的实例
static Rights | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
int | indexOf(CMSObj _operator, CMSObj _obj) 获取指定操作者对于指定对象权限在集合中的索引
int | indexOf(int _operatorType, int _operatorId, int _objType, int _objId) 获取指定操作者对于指定对象权限在集合中的索引
BaseObjs | newInstance() 生成新的集合对象实例
static Rights | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Rights]
CMyBitsValue | orAll() 将所有权限对象的权限值，做位或操作
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Rights

public Rights(User _currUser)

Rights

public Rights(User _currUser,
              int initialCapacity,
              int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

orAll

public CMyBitsValue orAll()
将所有权限对象的权限值，做位或操作

返回：
CMyBitsValue计算结果

若集合中无任何元素，则返回null;

否则，返回集合中所有权限对象的权限值位或操作结果

indexOf

public int indexOf(CMSObj _operator,
                   CMSObj _obj)
获取指定操作者对于指定对象权限在集合中的索引

参数：
_operator - 操作者
_obj - 操作对象
返回：
若存在指定的权限，返回>=0的索引；否则返回-1

indexOf

public int indexOf(int _operatorType,
                   int _operatorId,
                   int _objType,
                   int _objId)
获取指定操作者对于指定对象权限在集合中的索引

参数：
_operatorType - 操作者类型
_operatorId - 操作者ID
_objType - 操作对象类型
_objId - 操作对象ID
返回：
若存在指定的权限，返回>=0的索引；否则返回-1

findByIds

public static final Rights findByIds(User _currUser,
                                     java.lang.String _sIds)
                              throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Rights openWCMObjs(User _currUser,
                                       WCMFilter _filter)
                                throws WCMException
通过指定一个Filter获取当前集合[Rights]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[Rights]
抛出：
WCMException

createNewInstance

public static Rights createNewInstance(User _currUser)
                                throws WCMException
产生当前集合对象[Rights]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightValue

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 RightValue

java.lang.Object
    继承者  com.trs.infra.util.CMyBitsValue
        继承者  com.trs.cms.auth.persistent.RightValue
所有已实现的接口：
java.lang.Cloneable
public class RightValue
extends CMyBitsValue

字段摘要
static long | RIGHTVALUE_WHEN_NOT_EXISTS
static long | VALUE_ADMINISTRATOR
构造方法摘要
RightValue()
使用权限值为0的整数构造对象
RightValue(long _lValue)
使用长整型数构造对象
RightValue(RightValue _rightValue)
使用权限值对象构造对象
RightValue(java.lang.String _sValue)
使用0或1表示的权限字符串构造对象
方法摘要
void | copy(RightValue _rightValue) 权限值的复制
static RightValue | getAdministratorRightValue()
static java.lang.String | getAdministratorValues()
static WebSite | getSite(int _nObjType, int _nObjId) 由于角色和站点绑定，所以这个地方需要获取站点的id，将RightValue和站点依赖不太好，目前没有找到相应的解决办法, 除非每一个对象实现一个getHost的方法
boolean | isHasRight(int _index) 判断对指定权限索引是否具有权限
void | load(Group _group, int _objType, int _objId) 载入角色在指定对象的权限值
void | load(int _operatorType, int _operatorId, int _objType, int _objId) 载入指定操作者在指定操作对象的权限值
void | load(Role _role, int _objType, int _objId) 载入角色在指定对象的权限值
void | load(User _user, int _objType, int _objId) 载入用户在指定对象的权限值（综合了用户所属角色的权限）
void | load(User _user, int _objType, int _objId, boolean _bIncludeGrpAndRole)
static void | main(java.lang.String[] args)
void | setHasRight(int _index, boolean _blHasRight) 设置指定权限索引的权限
RightValue | setRight(int _index, boolean _blHasRight) 设置指定权限索引的权限，并返回自身以支持链式操作
从类 com.trs.infra.util.CMyBitsValue 继承的方法
and, and, clone, copy, getBit, getBit, getBitOfInt, getRealLength, getValue, getValueAsInt, or, or, setBit, setBit, setValue, setValue, toString, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

RIGHTVALUE_WHEN_NOT_EXISTS

public static final long RIGHTVALUE_WHEN_NOT_EXISTS
另请参见：
常量字段值

VALUE_ADMINISTRATOR

public static long VALUE_ADMINISTRATOR
构造方法详细信息

RightValue

public RightValue()
使用权限值为0的整数构造对象

RightValue

public RightValue(long _lValue)
使用长整型数构造对象

参数：
_lValue -

RightValue

public RightValue(java.lang.String _sValue)
使用0或1表示的权限字符串构造对象

参数：
_sValue -

RightValue

public RightValue(RightValue _rightValue)
使用权限值对象构造对象

参数：
_rightValue -
方法详细信息

isHasRight

public boolean isHasRight(int _index)
判断对指定权限索引是否具有权限

参数：
_index - 权限索引
返回：
允许（true）/禁止（false）

setHasRight

public void setHasRight(int _index,
                        boolean _blHasRight)
设置指定权限索引的权限

参数：
_index - 权限索引
_blHasRight - 表示禁止(false)/允许(true)

setRight

public RightValue setRight(int _index,
                           boolean _blHasRight)
设置指定权限索引的权限，并返回自身以支持链式操作

参数：
_index - 权限索引
_blHasRight - 表示禁止(false)/允许(true)
返回：
自身

copy

public void copy(RightValue _rightValue)
权限值的复制

参数：
_rightValue - 被复制的权限值对象

load

public void load(int _operatorType,
                 int _operatorId,
                 int _objType,
                 int _objId)
          throws WCMException
载入指定操作者在指定操作对象的权限值

参数：
_app - 关联的Application
_operatorType - 操作者类型
_operatorId - 操作者ID
_objType - 操作对象类型
_objId - 操作对象ID
抛出：
WCMException - 无效的操作者或载入失败会抛出异常

load

public void load(User _user,
                 int _objType,
                 int _objId)
          throws WCMException
载入用户在指定对象的权限值（综合了用户所属角色的权限）

参数：
_app - 关联的Application
_user - 指定用户
_objType - 操作对象类型
_objId - 操作对象ID
抛出：
WCMException

load

public void load(User _user,
                 int _objType,
                 int _objId,
                 boolean _bIncludeGrpAndRole)
          throws WCMException
抛出：
WCMException

getSite

public static WebSite getSite(int _nObjType,
                              int _nObjId)
                       throws WCMException
由于角色和站点绑定，所以这个地方需要获取站点的id，将RightValue和站点依赖不太好，目前没有找到相应的解决办法, 除非每一个对象实现一个getHost的方法

返回：
抛出：
WCMException

load

public void load(Role _role,
                 int _objType,
                 int _objId)
          throws WCMException
载入角色在指定对象的权限值

参数：
_app - 关联的Application
_role - 指定角色
_objType - 操作对象类型
_objId - 操作对象ID
抛出：
WCMException - 无效的角色对象或载入不成功时都会抛出异常

load

public void load(Group _group,
                 int _objType,
                 int _objId)
          throws WCMException
载入角色在指定对象的权限值

参数：
_app - 关联的Application
_group - 指定的用户组
_objType - 操作对象类型
_objId - 操作对象ID
抛出：
WCMException - 无效的角色对象或载入不成功时都会抛出异常

main

public static void main(java.lang.String[] args)

getAdministratorRightValue

public static RightValue getAdministratorRightValue()
返回：

getAdministratorValues

public static java.lang.String getAdministratorValues()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Role

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 Role

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.Role
所有已实现的接口：
java.io.Serializable, java.lang.Cloneable
public class Role
extends CMSObj
implements java.io.Serializable

作者：
Administrator
另请参见：
序列化表格

字段摘要
static int | ADMINISTRATORS_ID 系统管理员固定的ID值
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | EVERYONE_ID Everyone角色固定的ID值
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
static int | RANGE_ADMINISTRATOR 仅对管理员可见的角色
static int | RANGE_ALL 对所有组织都可见的角色
static int | RANGE_GROUP 仅对部分组织可见的角色
static java.lang.String | ROLEMANAGERS_NAME RoleManagers角色固定的名称, 固定Name，不固定id主要是避免升级困难， by huxiejin 2010-01-07
static int | TYPE_NORMAL
static int | TYPE_SITE 目前已经废弃
static int | TYPE_SPECIAL TYPE_SPECIAL这个名字更能表达实际涵义，但为了兼容，所以让其等于TYPE_NORMAL
static int | TYPE_SYSTEM
构造方法摘要
Role()
方法摘要
static Role | createNewInstance() 产生当前对象[Role]的实例
static Role | findById(int _nId) 提取指定ID的对象
static Role | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获取对象所对应的数据表名
java.lang.String | getDesc() 获取角色描述
java.lang.String | getEmail() 获取角色的邮件（String） 说明：如果有多个邮件，邮件之间通过“;”进行分割。
java.util.StringTokenizer | getEmails() 获取角色的邮件（StringTokenizer）
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
Rights | getMyRights(int _objType) 取角色在指定类型的操作对象上的权限集合
RightValue | getMyRightValue(CMSObj _obj) 取角色在指定对象上的操作权限值
RightValue | getMyRightValue(int _objType, int _objId)
java.lang.String | getName() 获取角色名称
long | getRightValue() 获取角色的权限（可以做的所有操作）
int | getRoleOrder() 提取属性：RoleOrder
int | getRoleRange() 获取角色所属范围
int | getRoleType() 获取角色所属类型
Users | getUsers(User _currUser) 取属于该角色的所有用户
int | getWCMType() 取得该对象的类型编号（定义在WCMTypes中）
boolean | isAdministrators() 判断角色是否为系统管理员 说明：判断的依据，是固定ID=1(由系统预定义的)
boolean | isEveryone() 判断角色是否为Everyone角色，默认包含所有的人 说明：判断的依据，是固定ID=2(由系统预定义的)
boolean | isRemoveable() 角色是否可以删除
boolean | isRoleManagers() 判断角色是否为角色维护人员角色
boolean | isSysDefined() 判断角色是否是系统预定义的
boolean | isSystemRole() 判断当前角色是否是系统级角色
boolean | isValid() 更新前检验数据是否有效
boolean | isViewable() 角色是否在应用可见
boolean | setDesc(java.lang.String _desc) 设置角色描述
boolean | setEmail(java.lang.String _email) 设置角色Email地址
boolean | setName(java.lang.String _name) 设置角色名称
boolean | setRemoveable(boolean _bRemoveable) 设置角色是否可以删除
boolean | setRightValue(long _lRightValue) 设置角色的权限（可以做的所有操作）
boolean | setRoleOrder(int _nOrder) 设置属性：RoleOrder
boolean | setRoleRange(int _nRoleRange) 设置角色所属范围，默认为0，
boolean | setRoleType(int _nRoleType) 设置角色所属类型，默认为0，
boolean | setSysDefined(boolean _bSysDefined) 设置角色系统预定义的属性
boolean | setViewable(boolean _bVeiwable) 设置角色是否在应用可见
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

ADMINISTRATORS_ID

public static final int ADMINISTRATORS_ID
系统管理员固定的ID值

另请参见：
常量字段值

EVERYONE_ID

public static final int EVERYONE_ID
Everyone角色固定的ID值

另请参见：
常量字段值

ROLEMANAGERS_NAME

public static final java.lang.String ROLEMANAGERS_NAME
RoleManagers角色固定的名称, 固定Name，不固定id主要是避免升级困难， by huxiejin 2010-01-07

另请参见：
常量字段值

TYPE_NORMAL

public static final int TYPE_NORMAL
另请参见：
常量字段值

TYPE_SPECIAL

public static final int TYPE_SPECIAL
TYPE_SPECIAL这个名字更能表达实际涵义，但为了兼容，所以让其等于TYPE_NORMAL

另请参见：
常量字段值

TYPE_SYSTEM

public static final int TYPE_SYSTEM
另请参见：
常量字段值

TYPE_SITE

public static final int TYPE_SITE
目前已经废弃

另请参见：
常量字段值

RANGE_ADMINISTRATOR

public static final int RANGE_ADMINISTRATOR
仅对管理员可见的角色

另请参见：
常量字段值

RANGE_ALL

public static final int RANGE_ALL
对所有组织都可见的角色

另请参见：
常量字段值

RANGE_GROUP

public static final int RANGE_GROUP
仅对部分组织可见的角色

另请参见：
常量字段值
构造方法详细信息

Role

public Role()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
获取对象所对应的数据表名

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getName

public java.lang.String getName()
获取角色名称

返回：
角色名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置角色名称

参数：
_name - 角色名称
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
获取角色描述

返回：
角色描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置角色描述

参数：
_desc - 角色描述
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEmail

public java.lang.String getEmail()
获取角色的邮件（String） 说明：如果有多个邮件，邮件之间通过“;”进行分割。

返回：
角色的邮件

getEmails

public java.util.StringTokenizer getEmails()
获取角色的邮件（StringTokenizer）

返回：
角色的邮件列表

setEmail

public boolean setEmail(java.lang.String _email)
                 throws WCMException
设置角色Email地址

参数：
_email - Email地址
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isSysDefined

public boolean isSysDefined()
判断角色是否是系统预定义的

返回：
如果是返回true;否则返回false

setSysDefined

public boolean setSysDefined(boolean _bSysDefined)
                      throws WCMException
设置角色系统预定义的属性

参数：
_bSysDefined - 是否为系统预定义（true：是系统预定义；false：不是）
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isViewable

public boolean isViewable()
角色是否在应用可见

返回：

setViewable

public boolean setViewable(boolean _bVeiwable)
                    throws WCMException
设置角色是否在应用可见

参数：
_bVeiwable -
返回：
@throws WCMException
抛出：
WCMException

isRemoveable

public boolean isRemoveable()
角色是否可以删除

返回：

setRemoveable

public boolean setRemoveable(boolean _bRemoveable)
                      throws WCMException
设置角色是否可以删除

参数：
_bRemoveable -
返回：
@throws WCMException
抛出：
WCMException

setRoleType

public boolean setRoleType(int _nRoleType)
                    throws WCMException
设置角色所属类型，默认为0，

参数：
_nRoleType -
抛出：
WCMException

getRoleType

public int getRoleType()
获取角色所属类型

返回：

isSystemRole

public boolean isSystemRole()
判断当前角色是否是系统级角色

返回：

setRoleRange

public boolean setRoleRange(int _nRoleRange)
                     throws WCMException
设置角色所属范围，默认为0，

参数：
_nRoleRange -
抛出：
WCMException

getRoleRange

public int getRoleRange()
获取角色所属范围

返回：

setRightValue

public boolean setRightValue(long _lRightValue)
                      throws WCMException
设置角色的权限（可以做的所有操作）

参数：
_lRightValue - 长整型的权限值，每一位表示一个操作
返回：
抛出：
WCMException

getRightValue

public long getRightValue()
获取角色的权限（可以做的所有操作）

返回：

getRoleOrder

public int getRoleOrder()
提取属性：RoleOrder

返回：
RoleOrder

setRoleOrder

public boolean setRoleOrder(int _nOrder)
                     throws WCMException
设置属性：RoleOrder

参数：
RoleOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
更新前检验数据是否有效

指定者：
类 BaseObj 中的 isValid
返回：
如果有效返回true;否则返回false
抛出：
WCMException

getUsers

public Users getUsers(User _currUser)
               throws WCMException
取属于该角色的所有用户

参数：
_currUser - 执行操作的用户
返回：
属于该角色的所有用户（Users）
抛出：
WCMException

getMyRights

public Rights getMyRights(int _objType)
                   throws WCMException
取角色在指定类型的操作对象上的权限集合

参数：
_objType - 操作对象的类型（定义在WCMTypes中）
返回：
角色在指定类型的操作对象上的权限集合（Rights）
抛出：
WCMException

getMyRightValue

public RightValue getMyRightValue(CMSObj _obj)
                           throws WCMException
取角色在指定对象上的操作权限值

参数：
_obj - 指定的对象（WCMObj）
返回：
角色在指定对象上的操作权限值
抛出：
WCMException

getMyRightValue

public RightValue getMyRightValue(int _objType,
                                  int _objId)
                           throws WCMException
参数：
_objType -
_objId -
返回：
@throws WCMException
抛出：
WCMException

isAdministrators

public boolean isAdministrators()
判断角色是否为系统管理员 说明：判断的依据，是固定ID=1(由系统预定义的)

返回：

isEveryone

public boolean isEveryone()
判断角色是否为Everyone角色，默认包含所有的人 说明：判断的依据，是固定ID=2(由系统预定义的)

返回：

isRoleManagers

public boolean isRoleManagers()
判断角色是否为角色维护人员角色

返回：

findById

public static final Role findById(int _nId)
                           throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Role createNewInstance()
                                    throws WCMException
产生当前对象[Role]的实例

返回：
当前对象的实例[Role]
抛出：
WCMException

findByKey

public static final Role findByKey(java.lang.Object _oKey)
                            throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Roles

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 Roles

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.Roles

public class Roles
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Roles(User _currUser)
构造函数
Roles(User _currUser, int initialCapacity, int capacityIncrement)
构造函数
方法摘要
static Roles | createNewInstance(User _currUser) 产生当前集合对象[Roles]的实例
static Roles | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Roles | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Roles]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Roles

public Roles(User _currUser)
构造函数

另请参见：
TrusteeInfos( User _currUser, int _initCapacity, int _incCapacity );

Roles

public Roles(User _currUser,
             int initialCapacity,
             int capacityIncrement)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final Roles findByIds(User _currUser,
                                    java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Roles）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Roles openWCMObjs(User _currUser,
                                      WCMFilter _filter)
                               throws WCMException
通过指定一个Filter获取当前集合[Roles]

参数：
_filter - 指定的Filter
返回：
当前集合[Roles]
抛出：
WCMException

createNewInstance

public static Roles createNewInstance(User _currUser)
产生当前集合对象[Roles]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 RoleUser

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.RoleUser
所有已实现的接口：
java.lang.Cloneable
public class RoleUser
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
角色/用户关联对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
static int | SITEID_FOR_ALL_SITES 作用于所有站点的siteid标识
static int | SITEID_FOR_SPECIAL_ROLE 特定角色使用的siteid标识
构造方法摘要
RoleUser()
构造函数：保留默认接口
方法摘要
static RoleUser | createNewInstance() 产生当前对象[RoleUser]的实例
static RoleUser | findById(int _nId) 提取指定ID的对象
static RoleUser | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getRoleId() 提取属性：RoleId
int | getSiteId() 提取属性：SiteId
int | getUserId() 提取属性：UserId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setRoleId(int _nRoleId) 设置属性：RoleId
boolean | setSiteId(int _nSiteId) 设置属性：SiteId
boolean | setUserId(int _nUserId) 设置属性：UserId
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

SITEID_FOR_SPECIAL_ROLE

public static final int SITEID_FOR_SPECIAL_ROLE
特定角色使用的siteid标识

另请参见：
常量字段值

SITEID_FOR_ALL_SITES

public static final int SITEID_FOR_ALL_SITES
作用于所有站点的siteid标识

另请参见：
常量字段值
构造方法详细信息

RoleUser

public RoleUser()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getRoleId

public int getRoleId()
提取属性：RoleId

返回：
RoleId

setRoleId

public boolean setRoleId(int _nRoleId)
                  throws WCMException
设置属性：RoleId

参数：
_nRoleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getUserId

public int getUserId()
提取属性：UserId

返回：
UserId

setUserId

public boolean setUserId(int _nUserId)
                  throws WCMException
设置属性：UserId

参数：
_nUserId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSiteId

public int getSiteId()
提取属性：SiteId

返回：
SiteId

setSiteId

public boolean setSiteId(int _nSiteId)
                  throws WCMException
设置属性：SiteId

参数：
_nSiteId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final RoleUser findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final RoleUser createNewInstance()
                                        throws WCMException
产生当前对象[RoleUser]的实例

返回：
当前对象的实例[RoleUser]
抛出：
WCMException

findByKey

public static final RoleUser findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleUserCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 RoleUserCacheMgr

java.lang.Object
    继承者  com.trs.cms.auth.persistent.RoleUserCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class RoleUserCacheMgr
extends java.lang.Object
implements ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
组织用户的缓冲.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RoleUserCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
Roles | getRoles(User _currUser, WebSite _currSite)
boolean | init() 初始化当前的Cache
static void | main(java.lang.String[] args)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleUserCacheMgr

public RoleUserCacheMgr()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO

getRoles

public final Roles getRoles(User _currUser,
                            WebSite _currSite)
                     throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleUsers

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 RoleUsers

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.RoleUsers

public class RoleUsers
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
角色/用户关联对象集合的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
RoleUsers(User _currUser)
构造函数
RoleUsers(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static RoleUsers | creatNewInstance(User _currUser) 产生一个当前集合对象[RoleUsers]的实例
static RoleUsers | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static RoleUsers | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RoleUsers]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleUsers

public RoleUsers(User _currUser)
构造函数

另请参见：
RoleUsers( User _currUser, int _initCapacity, int _incCapacity );

RoleUsers

public RoleUsers(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final RoleUsers findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final RoleUsers openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[RoleUsers]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[RoleUsers]
抛出：
WCMException

creatNewInstance

public static RoleUsers creatNewInstance(User _currUser)
                                  throws WCMException
产生一个当前集合对象[RoleUsers]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 RoleXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.cms.auth.persistent.RoleXmlConverter

public class RoleXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
角色对象转换为XML数据格式对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RoleXmlConverter()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleXmlConverter

public RoleXmlConverter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TrusteeInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 TrusteeInfo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.TrusteeInfo
所有已实现的接口：
java.lang.Cloneable
public class TrusteeInfo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | MODULE_FLOW 托管模块常量定义
static int | OBJ_TYPE 对象类型编号
构造方法摘要
TrusteeInfo()
构造函数：保留默认接口
方法摘要
CMyDateTime | getCrTime() 提取属性：CrTime
User | getCrUserById()
int | getCrUserId() 提取属性：CrUserId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
CMyDateTime | getEndTime() 提取属性：EndTime
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getModule() 提取属性：Module
java.lang.String | getModuleName()
CMyDateTime | getStartTime() 提取属性：StartTime
int | getStatus() 提取属性：Status
User | getTrustee()
int | getTrusteeId() 提取属性：Trustee
int | getWCMType() 取得该对象的类型编号（定义在WCMTypes中）
void | insert(User _currUser) 将对象数据写入数据库
boolean | isCancel()
boolean | isValid() 检验对象数据有效性
boolean | setCancel(boolean _bCancel)
boolean | setCrTime(CMyDateTime _dtCrTime) 设置属性：CrTime
boolean | setCrUserId(int _nCrUserId) 设置属性：CrUserId
boolean | setEndTime(CMyDateTime _dtEndTime) 设置属性：EndTime
boolean | setModule(int _nModule) 设置属性：Module
boolean | setStartTime(CMyDateTime _dtStartTime) 设置属性：StartTime
boolean | setStatus(int _nStatus) 设置属性：Status
boolean | setTrustee(int _nTrustee) 设置属性：Trustee
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

MODULE_FLOW

public static final int MODULE_FLOW
托管模块常量定义

另请参见：
常量字段值

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

TrusteeInfo

public TrusteeInfo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getStatus

public int getStatus()
提取属性：Status

返回：
Status

isCancel

public boolean isCancel()

setStatus

public boolean setStatus(int _nStatus)
                  throws WCMException
设置属性：Status

参数：
Status - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setCancel

public boolean setCancel(boolean _bCancel)
                  throws WCMException
抛出：
WCMException

getTrusteeId

public int getTrusteeId()
提取属性：Trustee

返回：
Trustee

getTrustee

public User getTrustee()
                throws WCMException
抛出：
WCMException

setTrustee

public boolean setTrustee(int _nTrustee)
                   throws WCMException
设置属性：Trustee

参数：
Trustee - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStartTime

public CMyDateTime getStartTime()
提取属性：StartTime

返回：
StartTime

setStartTime

public boolean setStartTime(CMyDateTime _dtStartTime)
                     throws WCMException
设置属性：StartTime

参数：
StartTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEndTime

public CMyDateTime getEndTime()
提取属性：EndTime

返回：
EndTime

setEndTime

public boolean setEndTime(CMyDateTime _dtEndTime)
                   throws WCMException
设置属性：EndTime

参数：
EndTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getModule

public int getModule()
提取属性：Module

返回：
Module

getModuleName

public java.lang.String getModuleName()

setModule

public boolean setModule(int _nModule)
                  throws WCMException
设置属性：Module

参数：
Module - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCrUserId

public int getCrUserId()
提取属性：CrUserId

返回：
CrUserId

getCrUserById

public User getCrUserById()
                   throws WCMException
抛出：
WCMException

setCrUserId

public boolean setCrUserId(int _nCrUserId)
                    throws WCMException
设置属性：CrUserId

参数：
CrUserId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCrTime

public CMyDateTime getCrTime()
提取属性：CrTime

覆盖：
类 BaseObj 中的 getCrTime
返回：
CrTime

setCrTime

public boolean setCrTime(CMyDateTime _dtCrTime)
                  throws WCMException
设置属性：CrTime

参数：
CrTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TrusteeInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 TrusteeInfos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.TrusteeInfos

public class TrusteeInfos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
TrusteeInfos(User _currUser)
构造函数
TrusteeInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TrusteeInfos

public TrusteeInfos(User _currUser)
构造函数

另请参见：
TrusteeInfos( User _currUser, int _initCapacity, int _incCapacity );

TrusteeInfos

public TrusteeInfos(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


User

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 User

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.auth.persistent.User
所有已实现的接口：
java.io.Serializable, java.lang.Cloneable
public class User
extends CMSObj
implements java.io.Serializable

Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
static java.lang.String | SYSTEM_USERNAME 系统用户（虚拟的）名称
static char | USER_DROPED_NAME_FLAG
static int | USER_STATUS_ALL 用户状态: 所有定义的用户状态(新用户、已删除、停用、正常等)
static int | USER_STATUS_APPLY 用户状态：正在申请（新用户）
static int | USER_STATUS_DEL 用户状态：已经删除（用户已删除）
static int | USER_STATUS_DROPED
static int | USER_STATUS_FORBID 用户状态：禁止使用（用户停用）
static int | USER_STATUS_REG 用户状态：已经注册（正常状态）
构造方法摘要
User()
构造函数：保留默认接口
方法摘要
static User | createNewInstance() 产生当前对象[User]的实例
boolean | equals(java.lang.Object _another) 用户对象比较
static User | findById(int _nId) 提取指定ID的对象
static User | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static User | findByName(java.lang.String _sUserName)
java.lang.String | getAddress() 获取联系地址
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getEmail() 获取Email 邮件地址，若有多个，用";"分割
Groups | getGroups() 取用户所属组对象集合
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
CMyDateTime | getLastLoginTime() 取上次登录时间
java.lang.String | getLoginIP()
CMyDateTime | getLoginTime() 获取当前登录时间
int | getLoginTimes() 获取登录次数
java.lang.String | getMobile() 获取移动通讯联系地址
int | getMsgInterval() 设置用户信息刷新时间
Rights | getMyRights(int _objType) 取用户在指定类型的操作对象上的权限集合
RightValue | getMyRightValue(CMSObj _obj) 取用户在指定对象上的操作权限值
RightValue | getMyRightValue(int _objType, int _objId) 取用户在指定对象上的操作权限值
java.lang.String | getName() 获取用户名
java.lang.String | getNickName() 获取昵称
int | getPasswordLev() 获取用户密码的安全级别 0 ： 安全级别未标记 >=1 ： 用户安全级别，值越高越安全
int | getPrice() 获得用户个人的稿件单价
CMyDateTime | getRegTime() 获取注册时间
java.lang.String | getReminderAnswer() 获取找回密码时的答案
java.lang.String | getReminderQuestion() 获取找回密码时的问题
Roles | getRoles() 获取用户所属的特定角色以及作用于所有站点的角色.
int | getStatus() 获取用户当前状态
java.lang.String | getStatusString() 获取用户当前状态信息
static java.lang.String | getStatusString(int _status) 获得用户状态描述
static User | getSystem()
java.lang.String | getTel() 获取联系电话
java.lang.String | getTrueName() 获取真实姓名
static IUserCacheMgr | getUserCacheMgr()
int | getViewInterval() 获取ViewInterval:视图刷新时间（秒）
int | getWCMType() 取得该对象的类型编号（定义在WCMTypes中）
void | insert(User _currUser) 添加用户记录到数据库
boolean | isAdministrator() 判断用户是否是系统管理员
boolean | isDeleted() 提取属性:ISDELETED
boolean | isForbidden() 判断用户是否被停用
boolean | isLogined() 判断用户是否已经登录
boolean | isPubMyInfo() 判断是否公开个人信息
boolean | isSystem() 判断用户是否是系统自定义的用户
boolean | isValid() 检查对象数据的有效性
boolean | isValidInstance() 检测当前对象是否是一个已经存在的实例对象
int | login(java.lang.String _password, java.lang.String _sRemoteAddr) 用户登录处理
void | logout()
static void | main(java.lang.String[] args)
boolean | nameIs(java.lang.String _name) 判断是否为指定的用户名
boolean | passwordIs(java.lang.String _password) 判断密码是否正确
boolean | setAddress(java.lang.String _address) 设置联系地址
boolean | setDeleted(boolean _bDeleted) 设置属性:ISDELETED
boolean | setEmail(java.lang.String _email) 设置用户Email 邮件地址，若有多个，用";"分割
boolean | setMobile(java.lang.String _mobile) 设置移动通讯联系地址
boolean | setMsgInterval(int _msgInterval) 获取用户信息刷新时间
boolean | setName(java.lang.String _name) 设置用户名
boolean | setNickName(java.lang.String _nickName) 设置昵称
boolean | setPassword(java.lang.String _password) 设置密码 密码长度不少于8个字符
boolean | setPasswordLev(int _nPasswordLev) 保存用户密码的安全级别
boolean | setPrice(int _nPrice) 设置用户个人的稿件单价
boolean | setPubMyInfo(boolean _bPubMyInfo) 设置是否公开个人信息
boolean | setReminderAnswer(java.lang.String _reminderAnswer) 设置找回密码时的答案
boolean | setReminderQuestion(java.lang.String _reminderQuestion) 设置找回密码时的问题
boolean | setStatus(int _status) 设置用户当前状态
boolean | setTel(java.lang.String _tel) 设置联系电话
boolean | setTrueName(java.lang.String _trueName) 设置真实姓名
boolean | setViewInterval(int _viewInterval) 设置ViewInterval:视图刷新时间（秒）
java.lang.String | toString()
void | update(User _currUser) 更新修改。
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

USER_STATUS_APPLY

public static final int USER_STATUS_APPLY
用户状态：正在申请（新用户）

另请参见：
常量字段值

USER_STATUS_DEL

public static final int USER_STATUS_DEL
用户状态：已经删除（用户已删除）

另请参见：
常量字段值

USER_STATUS_FORBID

public static final int USER_STATUS_FORBID
用户状态：禁止使用（用户停用）

另请参见：
常量字段值

USER_STATUS_REG

public static final int USER_STATUS_REG
用户状态：已经注册（正常状态）

另请参见：
常量字段值

USER_STATUS_ALL

public static final int USER_STATUS_ALL
用户状态: 所有定义的用户状态(新用户、已删除、停用、正常等)

另请参见：
常量字段值

USER_STATUS_DROPED

public static final int USER_STATUS_DROPED
另请参见：
常量字段值

USER_DROPED_NAME_FLAG

public static final char USER_DROPED_NAME_FLAG
另请参见：
常量字段值

SYSTEM_USERNAME

public static final java.lang.String SYSTEM_USERNAME
系统用户（虚拟的）名称

另请参见：
常量字段值
构造方法详细信息

User

public User()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

isValidInstance

public boolean isValidInstance()
检测当前对象是否是一个已经存在的实例对象

覆盖：
类 BaseObj 中的 isValidInstance
返回：
如果是返回true；否则返回false

isSystem

public boolean isSystem()
判断用户是否是系统自定义的用户

返回：
如果用户为系统自定义的用户，返回true；否则返回false

isForbidden

public boolean isForbidden()
判断用户是否被停用

返回：
如果用户被停用，返回true；否则返回false

equals

public boolean equals(java.lang.Object _another)
用户对象比较

覆盖：
类 BaseObj 中的 equals
参数：
_anotherUser - 需要比较的用户对象
返回：
如果是同一个用户返回true

getName

public java.lang.String getName()
获取用户名

返回：
用户名

nameIs

public boolean nameIs(java.lang.String _name)
判断是否为指定的用户名

参数：
_name - 如果是
返回：

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置用户名

参数：
_name - 用户名
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setPassword

public boolean setPassword(java.lang.String _password)
                    throws WCMException
设置密码 密码长度不少于8个字符

参数：
_password - 密码
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 密码长度少于8个字符时抛出WCMException异常、属性值无效、设置失败都会抛出异常。

getReminderQuestion

public java.lang.String getReminderQuestion()
获取找回密码时的问题

返回：
找回密码时的问题

setReminderQuestion

public boolean setReminderQuestion(java.lang.String _reminderQuestion)
                            throws WCMException
设置找回密码时的问题

参数：
_reminderQuestion -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getReminderAnswer

public java.lang.String getReminderAnswer()
获取找回密码时的答案

返回：
找回密码时的答案

setReminderAnswer

public boolean setReminderAnswer(java.lang.String _reminderAnswer)
                          throws WCMException
设置找回密码时的答案

参数：
_reminderAnswer - 找回密码时的答案
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getNickName

public java.lang.String getNickName()
获取昵称

返回：
昵称

setNickName

public boolean setNickName(java.lang.String _nickName)
                    throws WCMException
设置昵称

参数：
_nickName - 昵称
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTrueName

public java.lang.String getTrueName()
获取真实姓名

返回：
真实姓名

setTrueName

public boolean setTrueName(java.lang.String _trueName)
                    throws WCMException
设置真实姓名

参数：
_trueName - 真实姓名
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAddress

public java.lang.String getAddress()
获取联系地址

返回：
联系地址

setAddress

public boolean setAddress(java.lang.String _address)
                   throws WCMException
设置联系地址

参数：
_address - 联系地址
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTel

public java.lang.String getTel()
获取联系电话

返回：

setTel

public boolean setTel(java.lang.String _tel)
               throws WCMException
设置联系电话

参数：
_tel - 联系电话
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMobile

public java.lang.String getMobile()
获取移动通讯联系地址

返回：
移动通讯联系地址

setMobile

public boolean setMobile(java.lang.String _mobile)
                  throws WCMException
设置移动通讯联系地址

参数：
_mobile - 移动通讯联系地址
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEmail

public java.lang.String getEmail()
获取Email 邮件地址，若有多个，用";"分割

返回：
Email 邮件地址，若有多个，用";"分割

setEmail

public boolean setEmail(java.lang.String _email)
                 throws WCMException
设置用户Email 邮件地址，若有多个，用";"分割

参数：
_email - 用户EEmail 邮件地址，若有多个，用";"分割
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStatus

public int getStatus()
获取用户当前状态

返回：
用户当前状态（定义在User中）

setStatus

public boolean setStatus(int _status)
                  throws WCMException
设置用户当前状态

参数：
_status - 用户当前状态（定义在User中）
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStatusString

public java.lang.String getStatusString()
获取用户当前状态信息

返回：
用户当前状态信息

getLoginTimes

public int getLoginTimes()
获取登录次数

返回：
登录次数

getRegTime

public CMyDateTime getRegTime()
获取注册时间

返回：

getLoginTime

public CMyDateTime getLoginTime()
获取当前登录时间

返回：
当前登录时间

getLastLoginTime

public CMyDateTime getLastLoginTime()
取上次登录时间

返回：
上次登录时间

isPubMyInfo

public boolean isPubMyInfo()
判断是否公开个人信息

返回：
公开返回true；否则返回false

setPubMyInfo

public boolean setPubMyInfo(boolean _bPubMyInfo)
                     throws WCMException
设置是否公开个人信息

参数：
_bPubMyInfo - 是否公开个人信息
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMsgInterval

public int getMsgInterval()
设置用户信息刷新时间

返回：
用户信息刷新时间

setMsgInterval

public boolean setMsgInterval(int _msgInterval)
                       throws WCMException
获取用户信息刷新时间

参数：
_msgInterval - 用户信息刷新时间
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewInterval

public int getViewInterval()
获取ViewInterval:视图刷新时间（秒）

返回：
ViewInterval:视图刷新时间

setViewInterval

public boolean setViewInterval(int _viewInterval)
                        throws WCMException
设置ViewInterval:视图刷新时间（秒）

参数：
_viewInterval -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPrice

public int getPrice()
获得用户个人的稿件单价

返回：
用户个人的稿件单价

setPrice

public boolean setPrice(int _nPrice)
                 throws WCMException
设置用户个人的稿件单价

参数：
_nPrice - 用户个人
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLoginIP

public java.lang.String getLoginIP()

isDeleted

public boolean isDeleted()
提取属性:ISDELETED

返回：

setDeleted

public boolean setDeleted(boolean _bDeleted)
                   throws WCMException
设置属性:ISDELETED

参数：
_bDeleted -
返回：
抛出：
WCMException

getPasswordLev

public int getPasswordLev()
获取用户密码的安全级别 0 ： 安全级别未标记 >=1 ： 用户安全级别，值越高越安全

返回：

setPasswordLev

public boolean setPasswordLev(int _nPasswordLev)
                       throws WCMException
保存用户密码的安全级别

参数：
_nPasswordLev -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
数据有效返回true;否则返回false
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加用户记录到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 执行操作的用户
抛出：
WCMException

update

public void update(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 CMSObj 中的 update
参数：
_currUser - 操作用户
抛出：
WCMException

isLogined

public boolean isLogined()
判断用户是否已经登录

返回：
已经登录返回true；否则返回false

passwordIs

public boolean passwordIs(java.lang.String _password)
判断密码是否正确

参数：
_password - 登录密码
返回：
密码正确返回true；否则返回false

login

public int login(java.lang.String _password,
                 java.lang.String _sRemoteAddr)
          throws WCMException
用户登录处理

参数：
_password - 登录密码
返回：
（1）若用户名不存在或者密码错误，返回-1； （2）若用户对象属性不能修改，返回-2 （3）其它，返回用户当前状态（正在申请、已批准、已禁止、已删除）
抛出：
WCMException

logout

public void logout()

getStatusString

public static java.lang.String getStatusString(int _status)
获得用户状态描述

参数：
_status - 指定状态
返回：
用户状态描述

isAdministrator

public boolean isAdministrator()
                        throws WCMException
判断用户是否是系统管理员

返回：
如果用户是管理员，返回true；否则返回false
抛出：
WCMException

getGroups

public Groups getGroups()
                 throws WCMException
取用户所属组对象集合

参数：
_currUser - 执行操作的用户
返回：
用户所属组对象集合
抛出：
WCMException

getRoles

public Roles getRoles()
               throws WCMException
获取用户所属的特定角色以及作用于所有站点的角色.

返回：
抛出：
WCMException

getMyRights

public Rights getMyRights(int _objType)
                   throws WCMException
取用户在指定类型的操作对象上的权限集合

参数：
_objType - 指定对象类型（定义在WCMTypes中）
返回：
用户在指定类型的操作对象上的权限集合（Rights）
抛出：
WCMException

getMyRightValue

public RightValue getMyRightValue(CMSObj _obj)
                           throws WCMException
取用户在指定对象上的操作权限值

参数：
_obj - 指定对象
返回：
用户在指定对象上的操作权限值
抛出：
WCMException

getMyRightValue

public RightValue getMyRightValue(int _objType,
                                  int _objId)
                           throws WCMException
取用户在指定对象上的操作权限值

参数：
_objType - 指定对象的类型
_objId - 指定对象的ID
返回：
用户在指定对象上的操作权限值（RightValue）
抛出：
WCMException

findById

public static final User findById(int _nId)
                           throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final User createNewInstance()
                                    throws WCMException
产生当前对象[User]的实例

返回：
当前对象的实例[User]
抛出：
WCMException

findByKey

public static final User findByKey(java.lang.Object _oKey)
                            throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getUserCacheMgr

public static IUserCacheMgr getUserCacheMgr()
                                     throws WCMException
抛出：
WCMException

findByName

public static final User findByName(java.lang.String _sUserName)

getSystem

public static final User getSystem()

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 UserCacheMgr

java.lang.Object
    继承者  com.trs.cms.auth.persistent.UserCacheMgr
所有已实现的接口：
IUserCacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class UserCacheMgr
extends java.lang.Object
implements IUserCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
用户名缓冲器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int MAX_USERNAME_CACHE_SIZE
构造方法摘要
UserCacheMgr()
方法摘要
User | _getUserByName(java.lang.String _sUserName) 通过指定的用户名获取用户对象
void | clear() 清除系统所有的Cache
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAX_USERNAME_CACHE_SIZE

public static int MAX_USERNAME_CACHE_SIZE
构造方法详细信息

UserCacheMgr

public UserCacheMgr()
方法详细信息

_getUserByName

public User _getUserByName(java.lang.String _sUserName)
从接口 IUserCacheMgr 复制的描述
通过指定的用户名获取用户对象

指定者：
接口 IUserCacheMgr 中的 _getUserByName
参数：
_sUserName - 指定的用户名
返回：
@throws WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserLicenseMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 UserLicenseMgr

java.lang.Object
    继承者  com.trs.cms.auth.persistent.UserLicenseMgr

public class UserLicenseMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
UserLicenseMgr()
方法摘要
static UserLicenseMgr | getInstance()
int | getMaxUserNum()
void | validateUserLicense()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserLicenseMgr

public UserLicenseMgr()
方法详细信息

getInstance

public static UserLicenseMgr getInstance()

getMaxUserNum

public int getMaxUserNum()

validateUserLicense

public void validateUserLicense()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Users

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.auth.persistent
类 Users

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.auth.persistent.Users

public class Users
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Users(User _currUser)
构造函数
Users(User _currUser, int initialCapacity, int capacityIncrement)
构造函数
方法摘要
static Users | createNewInstance(User _currUser) 产生当前集合对象[Users]的实例
static Users | findAdministrators()
static Users | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
User | getByName(java.lang.String _sName) 通过用户名从集合中获取用户对象
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Users | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Users]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Users

public Users(User _currUser)
构造函数

另请参见：
Users( User _currUser, int _initCapacity, int _incCapacity );

Users

public Users(User _currUser,
             int initialCapacity,
             int capacityIncrement)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

getByName

public User getByName(java.lang.String _sName)
通过用户名从集合中获取用户对象

参数：
_sName -
返回：
若成功，集合指针定位到该元素； 否则，指针指向POS_EOF，返回null

findByIds

public static final Users findByIds(User _currUser,
                                    java.lang.String _sIds)
                             throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Users openWCMObjs(User _currUser,
                                      WCMFilter _filter)
                               throws WCMException
通过指定一个Filter获取当前集合[Users]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[Users]
抛出：
WCMException

createNewInstance

public static Users createNewInstance(User _currUser)
                               throws WCMException
产生当前集合对象[Users]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
抛出：
WCMException

findAdministrators

public static Users findAdministrators()
                                throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.auth.persistent.AdministratorCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.AdministratorCacheMgr
的使用

没有 com.trs.cms.auth.persistent.AdministratorCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.Group 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.Group
的使用

使用 Group 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.config
com.trs.cms.process.engine
com.trs.cms.process.engine.creators
com.trs.components.metadata.service
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.presentation.ids
com.trs.service
com.trs.service.impl

com.trs.cms.auth.domain 中 Group 的使用

返回 Group 的 com.trs.cms.auth.domain 中的方法
Group | IDepartmentMgr.getRootDepartmentGroup() 获取描述组织结构的根组织
Group | DepartmentMgrImpl.getRootDepartmentGroup()
Group | GroupMgr.save(Group _dstGroup) 保存组织（新建、编辑）

参数类型为 Group 的 com.trs.cms.auth.domain 中的方法
boolean | GroupRoleMgr.addGroup(Group _dstGroup, Role _theRole)
boolean | GroupMgr.addUser(User _userToAdd, Group _theGroup) 将用户加到指定组织中去
boolean | ObjectMemberMgr.canOperate(Group _oGroup, int _nObjType, int _nObjId)
boolean | IObjectMemberMgr.canOperate(Group _currGroup, int _nObjType, int _nObjId) 判断当前组织对于指定对象是否可操作
boolean | GroupMgr.delete(Group _dstGroup) 删除组织
Users | GroupMgr.getAdmins(Group _dstGroup) 获取指定组织的管理员集合
Groups | GroupMgr.getChildren(Group _parentGroup) 获取子组织
Groups | GroupMgr.getChildren(Group _parentGroup, WCMFilter _filter) 获取子组织
GroupUsers | GroupMgr.getGroupUsers(Group _theGroup, WCMFilter _filter) 获取指定组织所有的用户(用户组织关联对象)
Groups | GroupMgr.getOffspringGroups(Group _theGroup, boolean _bContainSelf, WCMFilter _filter) 返回所有的子孙组,确定是否包含自身
Roles | GroupRoleMgr.getRoles(Group _dstGroup, WCMFilter _filter) 获取指定组织的所有角色
Users | GroupMgr.getUsers(Group _theGroup, WCMFilter _filter) 获取属于某组织的所有用户集合
Users | GroupMgr.getUsers(Group _theGroup, WCMFilter _filter, boolean _bContainsChildGrp) 获取指定组织所有的用户(用户组织关联对象),包含所有的子组织的用户
static boolean | GroupAuthServer.hasRight(User _loginUser, Group group, int _nRightIndex)
boolean | GroupMgr.isAdministrator(Group _group, User _user, boolean _bContainAncestor) 判断某个用户是否为某个组织的组管理员
boolean | ObjectMemberMgr.isVisible(Group _oGroup, int _nObjType, int _nObjId)
boolean | IObjectMemberMgr.isVisible(Group _currGroup, int _nObjType, int _nObjId) 判断当前组织对于指定对象是否可见
boolean | GroupMgr.moveUser(User _dstUser, Group _srcGroup, Group _dstGroup) 更改指定用户的组织
boolean | GroupRoleMgr.removeGroup(Group _dstGroup, Role _theRole)
boolean | GroupMgr.removeUser(User _dstUser, Group _theGroup) 删除组织中的某个用户
Group | GroupMgr.save(Group _dstGroup) 保存组织（新建、编辑）
boolean | GroupMgr.setGroupManager(User _dstUser, Group _theGroup, boolean _isAdministrator) 设置组管理员(设置或取消指定用户的组管理员身份)

com.trs.cms.auth.persistent 中 Group 的使用

返回 Group 的 com.trs.cms.auth.persistent 中的方法
static Group | Group.createNewInstance() 产生当前对象[Group]的实例
static Group | Group.findById(int _nId) 提取指定ID的对象
static Group | Group.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Group | Group.getParent() 获取组的父对象（Group）

参数类型为 Group 的 com.trs.cms.auth.persistent 中的方法
Users | GroupAdminsCacheMgr.getAdmins(Group _group) 获取指定用户组的管理员集合
void | RightValue.load(Group _group, int _objType, int _objId) 载入角色在指定对象的权限值
boolean | Group.setParent(Group _parent) 设置父对象：仅新增模式下有效

com.trs.cms.process.config 中 Group 的使用

返回 Group 的 com.trs.cms.process.config 中的方法
 Group ToUsersCreatorConfig.getGroupRange(FlowContext _context)

com.trs.cms.process.engine 中 Group 的使用

返回 Group 的 com.trs.cms.process.engine 中的方法
Group | FlowNextBranchInfo.getGroupRange()
Group | AbstractToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)
Group | IToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig) 限定了用户选择范围（在特定组内选择）

参数类型为 Group 的 com.trs.cms.process.engine 中的方法
 void FlowNextBranchInfo.setGroupRange(Group groupRange)

com.trs.cms.process.engine.creators 中 Group 的使用

返回 Group 的 com.trs.cms.process.engine.creators 中的方法
 Group GroupMembersAsToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)

com.trs.components.metadata.service 中 Group 的使用

参数类型为 Group 的 com.trs.components.metadata.service 中的方法
void | ClassInfoToGroupCreator.createGroups(ClassInfo _oDeptClassInfoRoot, Group _hostGroup, int _nMaxLevel)
static void | ClassInfoChannelRightHelper.resetClassInfoChannelRight(WebSite _site, Group _rootGroup)

com.trs.components.stat 中 Group 的使用

参数类型为 Group 的 com.trs.components.stat 中的方法
java.util.List | IChnlDeptMgr.getChnlIdsByDep(Group group) 根据组织返回栏目的id数组
java.util.List | ChnlDeptMgr.getChnlIdsByDep(Group _group) 根据组织获取组织相关的栏目ID列表

com.trs.components.wcm.content.domain 中 Group 的使用

参数类型为 Group 的 com.trs.components.wcm.content.domain 中的方法
void | SiteMemberMgr.addSiteGroup(WebSite _site, Group _group) 添加站点用户组 将指定的用户组添加到指定的站点
boolean | SiteMemberMgr.isBelongToSite(Group _group, WebSite _site) 判断指定的用户组是否属于指定的站点
void | SiteMemberMgr.removeSiteGroup(WebSite _site, Group _group) 删除站点用户组 将指定的用户组从指定的站点删除

com.trs.presentation.ids 中 Group 的使用

返回 Group 的 com.trs.presentation.ids 中的方法
Group | WCM52Actor.getGroupByPath(java.lang.String[] groupNames) 从路径中获取组织
static Group | ActorHelper.getGroupFromSSOGroup(com.trs.idm.client.actor.SSOGroup _group) 从IDS的组织中获取当前应用的组织
static Group | ActorHelper.saveGroup(com.trs.idm.client.actor.SSOGroup _group, Group currGroup, int parentId) 本地应用的保存组织操作

参数类型为 Group 的 com.trs.presentation.ids 中的方法
static Group ActorHelper.saveGroup(com.trs.idm.client.actor.SSOGroup _group, Group currGroup, int parentId)
本地应用的保存组织操作

com.trs.service 中 Group 的使用

返回 Group 的 com.trs.service 中的方法
Group | IGroupService.moveTo(Group _fromGroup, Group _toGroup) 移动组织，将一个组织移动到另一个组织下
Group | IGroupService.save(Group _dstGroup) 保存指定的组织

参数类型为 Group 的 com.trs.service 中的方法
boolean | IGroupService.addManager(User _adminToAdd, Group _dstGroup) 将指定用户设置为某个组的管理员 注意: 指定的用户必须在指定组中
void | IChannelService.addSitesToGroup(java.lang.String _sSiteIds, Group _group) 给指定的用户组添加指定的站点
boolean | IGroupService.addUser(User _userToAdd, Group _dstGroup) 将指定用户添加个指定的组中
void | IEventService.cancelShare(Event _aEvent, Group _assignToGroup) 取消指派给另外一个组织的Event
boolean | IGroupService.delete(Group _groupToDelete) 删除某个特定的组织
Users | IGroupService.getAdmins(Group _dstGroup) 获取指定组的管理员集合
Groups | IGroupService.getChildren(Group _parentGroup) 获取某个组的子组集合
Groups | IGroupService.getChildren(Group _parentGroup, boolean _bContainsChildren)
Groups | IGroupService.getChildren(Group _parentGroup, boolean _bContainsChildren, WCMFilter _filter)
Users | IGroupService.getUsers(Group _dstGroup, WCMFilter _filter) 获取指定组中的所有用户
Users | IGroupService.getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildren)
Group | IGroupService.moveTo(Group _fromGroup, Group _toGroup) 移动组织，将一个组织移动到另一个组织下
boolean | IGroupService.moveUser(User _userToMove, Group _srcGroup, Group _dstGroup) 将指定用户从某个组移动到指定的另外一个组中
boolean | IGroupService.moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups) 将指定的用户从某个组移动到指定的多个组中
boolean | IGroupService.removeManager(User _adminToCancel, Group _dstGroup) 取消指定用户在某个组的管理员身份 注意: 指定的用户必须在指定组中
void | IChannelService.removeSitesFromGroup(java.lang.String _sSiteIds, Group _group) 删除指定的用户组上指定的站点
boolean | IGroupService.removeUser(User _userToRemove, Group _dstGroup) 将指定组从指定的组中删除
boolean | IGroupService.removeUser(User _userToRemove, Group _dstGroup, boolean _bRemoveOffspring)
Group | IGroupService.save(Group _dstGroup) 保存指定的组织
User | IUserService.save(User _userToSave, Group _currGrp)
void | IEventService.shareTo(Event _aEvent, Group _assignToGroup) 当前用户把一个Event指派给一个组织

com.trs.service.impl 中 Group 的使用

返回 Group 的 com.trs.service.impl 中的方法
Group | GroupService.moveTo(Group _fromGroup, Group _toGroup)
Group | GroupService.save(Group _dstGroup)

参数类型为 Group 的 com.trs.service.impl 中的方法
boolean | GroupService.addManager(User _adminToAdd, Group _dstGroup)
void | ChannelService.addSitesToGroup(java.lang.String _sSiteIds, Group _group)
boolean | GroupService.addUser(User _userToAdd, Group _dstGroup)
void | EventService.cancelShare(Event _aEvent, Group _assignToGroup)
boolean | GroupService.delete(Group _groupToDelete)
Users | GroupService.getAdmins(Group _dstGroup)
Groups | GroupService.getChildren(Group _parentGroup)
Groups | GroupService.getChildren(Group _parentGroup, boolean _bContainsChild)
Groups | GroupService.getChildren(Group _parentGroup, boolean _bContainsChild, WCMFilter _filter)
Users | GroupService.getUsers(Group _dstGroup, WCMFilter _filter)
Users | GroupService.getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildGrp)
Group | GroupService.moveTo(Group _fromGroup, Group _toGroup)
boolean | GroupService.moveUser(User _userToMove, Group _srcGroup, Group _dstGroup)
boolean | GroupService.moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups)
boolean | GroupService.removeManager(User _adminToCancel, Group _dstGroup)
void | ChannelService.removeSitesFromGroup(java.lang.String _sSiteIds, Group _group)
boolean | GroupService.removeUser(User _userToRemove, Group _dstGroup)
boolean | GroupService.removeUser(User _userToRemove, Group _dstGroup, boolean _bContainsChildren)
Group | GroupService.save(Group _dstGroup)
User | UserService.save(User _userToSave, Group _currGrp)
void | EventService.shareTo(Event _aEvent, Group _assignToGroup)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr
的使用

没有 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.GroupRole 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.GroupRole
的使用

使用 GroupRole 的软件包
com.trs.cms.auth.persistent

com.trs.cms.auth.persistent 中 GroupRole 的使用

返回 GroupRole 的 com.trs.cms.auth.persistent 中的方法
static GroupRole | GroupRole.createNewInstance() 产生当前对象[GroupRole]的实例
static GroupRole | GroupRole.findById(int _nId) 提取指定ID的对象
static GroupRole | GroupRole.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.GroupRoles 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.GroupRoles
的使用

使用 GroupRoles 的软件包
com.trs.cms.auth.persistent

com.trs.cms.auth.persistent 中 GroupRoles 的使用

返回 GroupRoles 的 com.trs.cms.auth.persistent 中的方法
static GroupRoles | GroupRoles.creatNewInstance(User _currUser) 产生一个当前集合对象[RoleUsers]的实例
static GroupRoles | GroupRoles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static GroupRoles | GroupRoles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RoleUsers]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.Groups 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.Groups
的使用

使用 Groups 的软件包
com.trs.ajaxservice
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.components.common.bookmark
com.trs.components.common.calendar
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 Groups 的使用

返回 Groups 的 com.trs.ajaxservice 中的方法
Groups | GroupServiceProvider.getGroupsForCurrUser(MethodContext context) 获取当前登录用户可以管理的组织,也就是作为组管理员的组织
Groups | GroupServiceProvider.getGroupsForRole(MethodContext context) 获取指定角色关联的组织

com.trs.cms.auth.domain 中 Groups 的使用

返回 Groups 的 com.trs.cms.auth.domain 中的方法
Groups | GroupMgr.getChildren(Group _parentGroup) 获取子组织
Groups | GroupMgr.getChildren(Group _parentGroup, WCMFilter _filter) 获取子组织
Groups | IDepartmentMgr.getDeptGroups(User _user) 获取指定用户所属的组织结构
Groups | DepartmentMgrImpl.getDeptGroups(User _user)
Groups | IDepartmentMgr.getDeptGroupTree(User _user) 获取指定用户的所属部门组织树，按照树形结构组织
Groups | DepartmentMgrImpl.getDeptGroupTree(User _user)
Groups | GroupRoleMgr.getGroups(Role _dstRole, WCMFilter _filter) 获取指定角色的关联的组织
Groups | UserMgr.getGroups(User _dstUser) 获取当前用户所在的所有组织
Groups | GroupMgr.getGroups(User _user, WCMFilter _filter) 根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织
Groups | GroupMgr.getOffspringGroups(Group _theGroup, boolean _bContainSelf, WCMFilter _filter) 返回所有的子孙组,确定是否包含自身
Groups | GroupMgr.getOffspringGroups(User _user, WCMFilter _filter) 根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织,同时包含子孙组织

参数类型为 Groups 的 com.trs.cms.auth.domain 中的方法
 void GroupRoleMgr.setGroups(Role role, Groups groups)
绑定角色role和组织groups的关联，同时将清除原来的关联

com.trs.cms.auth.persistent 中 Groups 的使用

返回 Groups 的 com.trs.cms.auth.persistent 中的方法
static Groups | Groups.createNewInstance(User _currUser) 产生当前集合对象[Groups]的实例
static Groups | Groups.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Groups | Group.getChildren(User _currUser) 取组的子组集合
Groups | Group.getChildren(User _currUser, java.lang.String _sOrder) 获取按照指定的排序方式排序的组的子组集合
Groups | User.getGroups() 取用户所属组对象集合
static Groups | Right.getGroupsWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的角色集合
static Groups | Groups.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Groups]

com.trs.cms.process.definition 中 Groups 的使用

返回 Groups 的 com.trs.cms.process.definition 中的方法
Groups | Flow.getMonitorGroups(User _currUser) 取工作流的监控用户组
Groups | FlowNode.getOperGroups(User _currUser) 取节点上的操作用户组

com.trs.components.common.bookmark 中 Groups 的使用

返回 Groups 的 com.trs.components.common.bookmark 中的方法
 Groups BookMarkMgr.getSharedGroups(int _nTypeId, CMSObj _currObj)

com.trs.components.common.calendar 中 Groups 的使用

返回 Groups 的 com.trs.components.common.calendar 中的方法
 Groups EventMgr.getGroups(Event _anEvent)
获取共享指定日程安排的所有组织

com.trs.components.stat 中 Groups 的使用

参数类型为 Groups 的 com.trs.components.stat 中的方法
java.lang.String | IChnlDeptMgr.getChnlIdsByDepts(Groups groups) 根据组织返回栏目的id数组
java.lang.String | ChnlDeptMgr.getChnlIdsByDepts(Groups groups) 通过组织集合查找所有组织相关的栏目

com.trs.components.wcm.content.domain 中 Groups 的使用

返回 Groups 的 com.trs.components.wcm.content.domain 中的方法
 Groups SiteMemberMgr.getSiteGroups(WebSite _site, WCMFilter _filter)
获取站点中的用户组集合

com.trs.service 中 Groups 的使用

返回 Groups 的 com.trs.service 中的方法
Groups | IGroupService.getChildren(Group _parentGroup) 获取某个组的子组集合
Groups | IGroupService.getChildren(Group _parentGroup, boolean _bContainsChildren)
Groups | IGroupService.getChildren(Group _parentGroup, boolean _bContainsChildren, WCMFilter _filter)
Groups | IUserService.getGroups() 获取当前登录用户所在的组织.
Groups | IUserService.getGroups(User _currUser) 获取指定用户所在的组织集合
Groups | IEventService.getSharedGroups(Event _aEvent) 获取一个Event被AssignTo的Group
Groups | IBookMarkService.getSharedGroups(int _nObjType, int _nObjId) 获取共享组织
Groups | IChannelService.getSiteGroups(WebSite _site, WCMFilter _filter) 获取指定站点的所属用户组集合

参数类型为 Groups 的 com.trs.service 中的方法
boolean | IGroupService.delete(Groups _groupsToDelete) 删除一批组织（在组织列表页面中用到）
boolean | IGroupService.moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups) 将指定的用户从某个组移动到指定的多个组中
void | IEventService.shareTo(Event _aEvent, Groups _assignToGroups)

com.trs.service.impl 中 Groups 的使用

返回 Groups 的 com.trs.service.impl 中的方法
Groups | GroupService.getChildren(Group _parentGroup)
Groups | GroupService.getChildren(Group _parentGroup, boolean _bContainsChild)
Groups | GroupService.getChildren(Group _parentGroup, boolean _bContainsChild, WCMFilter _filter)
Groups | UserService.getGroups()
Groups | UserService.getGroups(User _currUser)
Groups | EventService.getSharedGroups(Event _aEvent)
Groups | BookMarkService.getSharedGroups(int _nObjType, int _nObjId)
Groups | ChannelService.getSiteGroups(WebSite _site, WCMFilter _filter)

参数类型为 Groups 的 com.trs.service.impl 中的方法
boolean | GroupService.delete(Groups _groupsToDelete)
boolean | GroupService.moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups)
void | EventService.shareTo(Event _aEvent, Groups _assignToGroups)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.GroupUser 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.GroupUser
的使用

使用 GroupUser 的软件包
com.trs.cms.auth.persistent

com.trs.cms.auth.persistent 中 GroupUser 的使用

返回 GroupUser 的 com.trs.cms.auth.persistent 中的方法
static GroupUser | GroupUser.createNewInstance() 产生当前对象[GroupUser]的实例
static GroupUser | GroupUser.findById(int _nId) 提取指定ID的对象
static GroupUser | GroupUser.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.GroupUserCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.GroupUserCacheMgr
的使用

没有 com.trs.cms.auth.persistent.GroupUserCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.GroupUsers 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.GroupUsers
的使用

使用 GroupUsers 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent

com.trs.cms.auth.domain 中 GroupUsers 的使用

返回 GroupUsers 的 com.trs.cms.auth.domain 中的方法
 GroupUsers GroupMgr.getGroupUsers(Group _theGroup, WCMFilter _filter)
获取指定组织所有的用户(用户组织关联对象)

com.trs.cms.auth.persistent 中 GroupUsers 的使用

返回 GroupUsers 的 com.trs.cms.auth.persistent 中的方法
static GroupUsers | GroupUsers.creatNewInstance(User _currUser) 产生一个当前集合对象[GroupUsers]的实例
static GroupUsers | GroupUsers.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static GroupUsers | GroupUsers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[GroupUsers]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.GroupXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.GroupXmlConverter
的使用

没有 com.trs.cms.auth.persistent.GroupXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.auth.persistent.IAdministratorCacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.auth.persistent.IAdministratorCacheMgr
的使用

使用 IAdministratorCacheMgr 的软件包
com.trs.cms.auth.persistent

com.trs.cms.auth.persistent 中 IAdministratorCacheMgr 的使用

实现 IAdministratorCacheMgr 的 com.trs.cms.auth.persistent 中的类
 class AdministratorCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
管理员角色用户缓冲管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.auth.persistent.IUserCacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.auth.persistent.IUserCacheMgr
的使用

使用 IUserCacheMgr 的软件包
com.trs.cms.auth.persistent

com.trs.cms.auth.persistent 中 IUserCacheMgr 的使用

实现 IUserCacheMgr 的 com.trs.cms.auth.persistent 中的类
 class UserCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
用户名缓冲器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IUserCacheMgr 的 com.trs.cms.auth.persistent 中的方法
static IUserCacheMgr User.getUserCacheMgr()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.ObjectMember 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.ObjectMember
的使用

使用 ObjectMember 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent

com.trs.cms.auth.domain 中 ObjectMember 的使用

返回 ObjectMember 的 com.trs.cms.auth.domain 中的方法
ObjectMember | ObjectMemberMgr.getObjectMember(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId) 获取ObjectMember
ObjectMember | IObjectMemberMgr.getObjectMember(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId) 获取可访问可操作对象

com.trs.cms.auth.persistent 中 ObjectMember 的使用

返回 ObjectMember 的 com.trs.cms.auth.persistent 中的方法
static ObjectMember | ObjectMember.createNewInstance() 产生当前对象[ObjectMember]的实例
static ObjectMember | ObjectMember.findById(int _nId) 提取指定ID的对象
static ObjectMember | ObjectMember.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static ObjectMember | ObjectMember.findByMemberObj(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.ObjectMembers 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.ObjectMembers
的使用

使用 ObjectMembers 的软件包
com.trs.ajaxservice
com.trs.cms.auth.persistent

com.trs.ajaxservice 中 ObjectMembers 的使用

返回 ObjectMembers 的 com.trs.ajaxservice 中的方法
ObjectMembers | ObjectMemberServiceProvider.queryMembersOfObject(MethodContext _methodContext) 返回对指定对象可见可操作的所有成员
ObjectMembers | ObjectMemberServiceProvider.queryObjectsOfMember(MethodContext _methodContext) 返回指定成员的所有可见可操作的对象

com.trs.cms.auth.persistent 中 ObjectMembers 的使用

返回 ObjectMembers 的 com.trs.cms.auth.persistent 中的方法
static ObjectMembers | ObjectMembers.createNewInstance(User _currUser) 产生当前集合对象[ObjectMembers]的实例
static ObjectMembers | ObjectMembers.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ObjectMembers | ObjectMembers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ObjectMembers]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.Right 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.Right
的使用

使用 Right 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent

com.trs.cms.auth.domain 中 Right 的使用

返回 Right 的 com.trs.cms.auth.domain 中的方法
Right | IRightMgr.deleteRight(Right _delRight) 删除指定的权限
Right | RightMgr.deleteRight(Right _delRight)
Right | IRightMgr.getRight(CMSObj _currObj, CMSObj _currOperator) 获取指定对象指定操作者的权限对象
Right | RightMgr.getRight(CMSObj _currObj, CMSObj _currOperator)
Right | IRightMgr.getRight(int _objType, int _objId, int _oprType, int _oprId) 获取指定对象指定操作者的权限对象
Right | RightMgr.getRight(int _objType, int _objId, int _oprType, int _oprId)
Right | IRightMgr.saveRight(Right _saveRight) 保存权限
Right | RightMgr.saveRight(Right _saveRight)

参数类型为 Right 的 com.trs.cms.auth.domain 中的方法
Right | IRightMgr.deleteRight(Right _delRight) 删除指定的权限
Right | RightMgr.deleteRight(Right _delRight)
Right | IRightMgr.saveRight(Right _saveRight) 保存权限
Right | RightMgr.saveRight(Right _saveRight)

com.trs.cms.auth.persistent 中 Right 的使用

返回 Right 的 com.trs.cms.auth.persistent 中的方法
static Right | Right.createNewInstance() 产生当前对象[Right]的实例
static Right | Right.findBy(int _nObjType, int _nObjId, int _nOprType, int _nOprId)
static Right | Right.findById(int _nId) 提取指定ID的对象
static Right | Right.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.RightDef 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.RightDef
的使用

使用 RightDef 的软件包
com.trs.cms.auth.persistent

com.trs.cms.auth.persistent 中 RightDef 的使用

返回 RightDef 的 com.trs.cms.auth.persistent 中的方法
static RightDef | RightDef.createNewInstance() 产生当前对象[RightDef]的实例
static RightDef | RightDef.findById(int _nId) 提取指定ID的对象
static RightDef | RightDef.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.RightDefs 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.RightDefs
的使用

使用 RightDefs 的软件包
com.trs.cms.auth.persistent
com.trs.components.wcm.util

com.trs.cms.auth.persistent 中 RightDefs 的使用

返回 RightDefs 的 com.trs.cms.auth.persistent 中的方法
static RightDefs | RightDefs.createNewInstance(User _currUser) 产生一个当前集合对象[RightDefs]的实例
static RightDefs | RightDefs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static RightDefs | RightDefs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RightDefs]

com.trs.components.wcm.util 中 RightDefs 的使用

参数类型为 RightDefs 的 com.trs.components.wcm.util 中的方法
java.lang.String | CRightUtil.getSetRightTbl(RightDefs _currRightDefs, Rights _userRights, Rights _roleRights, Rights _groupRights, java.lang.String _sTblId)
java.lang.String | CRightUtil.getSetRightTbl(RightDefs _currRightDefs, java.lang.String _sTblId)
void | CRightUtil.setRightDefs(RightDefs _currRightDefs)

参数类型为 RightDefs 的 com.trs.components.wcm.util 中的构造方法
CRightUtil(RightDefs _currRightDefs)
CRightUtil(RightDefs _currRightDefs, Rights _userRights, Rights _roleRights, Rights _groupRights)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.Rights 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.Rights
的使用

使用 Rights 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.components.wcm.util

com.trs.cms.auth.domain 中 Rights 的使用

返回 Rights 的 com.trs.cms.auth.domain 中的方法
Rights | UserMgr.getMyRights(int _nOperatorType, int _nOperatorId, int _nObjType) 获取指定操作者在某类对象上的操作权限
Rights | IRightMgr.getRights(CMSObj _currObj)
Rights | RightMgr.getRights(CMSObj _currObj)
Rights | IRightMgr.getRights(CMSObj _currObj, int _operatorType)
Rights | RightMgr.getRights(CMSObj _currObj, int _operatorType)
Rights | IRightMgr.getRights(CMSObj _currObj, java.lang.String _groupIds, java.lang.String _roleIds) 获取指定对象指定群和组织的权限对象
Rights | RightMgr.getRights(CMSObj _currObj, java.lang.String _groupIds, java.lang.String _roleIds)
Rights | IRightMgr.getRights(int objType, int objId)
Rights | RightMgr.getRights(int objType, int objId)
Rights | UserMgr.getUserRightsOnWCMObj(int _nObjType) 获取当前用户在指定类型的对象上的权限集合

com.trs.cms.auth.persistent 中 Rights 的使用

返回 Rights 的 com.trs.cms.auth.persistent 中的方法
static Rights | Rights.createNewInstance(User _currUser) 产生当前集合对象[Rights]的实例
static Rights | Rights.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Rights | User.getMyRights(int _objType) 取用户在指定类型的操作对象上的权限集合
Rights | Role.getMyRights(int _objType) 取角色在指定类型的操作对象上的权限集合
static Rights | Rights.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Rights]

com.trs.components.wcm.util 中 Rights 的使用

参数类型为 Rights 的 com.trs.components.wcm.util 中的方法
 java.lang.String CRightUtil.getSetRightTbl(RightDefs _currRightDefs, Rights _userRights, Rights _roleRights, Rights _groupRights, java.lang.String _sTblId)

参数类型为 Rights 的 com.trs.components.wcm.util 中的构造方法
CRightUtil(RightDefs _currRightDefs, Rights _userRights, Rights _roleRights, Rights _groupRights)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.RightValue 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.RightValue
的使用

使用 RightValue 的软件包
com.trs.ajaxservice
com.trs.ajaxservice.xmlconvertors
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.components.common.publish.widget
com.trs.components.common.publish.widget.tagparser
com.trs.components.metadata.center
com.trs.components.wcm.content

com.trs.ajaxservice 中 RightValue 的使用

返回 RightValue 的 com.trs.ajaxservice 中的方法
static RightValue | TemplateAuthHelper.makeHostRightValue(MethodContext _context, User _loginUser, IPublishFolder _host)
static RightValue | TemplateAuthHelper.makeTemplateRightValue(MethodContext _context, User _loginUser, Template _template, IPublishFolder _host)

com.trs.ajaxservice.xmlconvertors 中 RightValue 的使用

参数类型为 RightValue 的 com.trs.ajaxservice.xmlconvertors 中的方法
static void ChannelToXML.doFilterRight(RightValue _rightValue, Channel _channel)

com.trs.cms.auth.domain 中 RightValue 的使用

返回 RightValue 的 com.trs.cms.auth.domain 中的方法
RightValue | UserMgr.getMyRightValue(CMSObj _obj) 取用户在指定对象上的操作权限值
RightValue | UserMgr.getMyRightValue(int _objType, int _objId) 取用户在指定对象上的操作权限值
static RightValue | AuthServer.getRightValue(CMSObj _currObj, CMSObj _currOperator) 获取当前操作权限值
RightValue | IRightMgr.getRightValue(CMSObj _currObj, CMSObj _currOperator)
RightValue | RightMgr.getRightValue(CMSObj _currObj, CMSObj _currOperator)
static RightValue | AuthServer.getRightValue(CMSObj _currObj, User _currOpUser) 获取当前权限值
RightValue | RightCacheMgr.getRightValue(int _objType, int _objId, int _oprType, int _oprId)

参数类型为 RightValue 的 com.trs.cms.auth.domain 中的方法
static boolean AuthServer.hasRight(RightValue aRightValue, int _index)

com.trs.cms.auth.persistent 中 RightValue 的使用

返回 RightValue 的 com.trs.cms.auth.persistent 中的方法
static RightValue | RightValue.getAdministratorRightValue()
RightValue | User.getMyRightValue(CMSObj _obj) 取用户在指定对象上的操作权限值
RightValue | Role.getMyRightValue(CMSObj _obj) 取角色在指定对象上的操作权限值
RightValue | User.getMyRightValue(int _objType, int _objId) 取用户在指定对象上的操作权限值
RightValue | Role.getMyRightValue(int _objType, int _objId)
RightValue | Right.getValue() 获得权限值对象
RightValue | RightValue.setRight(int _index, boolean _blHasRight) 设置指定权限索引的权限，并返回自身以支持链式操作

参数类型为 RightValue 的 com.trs.cms.auth.persistent 中的方法
void | RightValue.copy(RightValue _rightValue) 权限值的复制
boolean | Right.setValue(RightValue _rightValue) 使用RightValue对象定权限值

参数类型为 RightValue 的 com.trs.cms.auth.persistent 中的构造方法
RightValue(RightValue _rightValue)
使用权限值对象构造对象

com.trs.components.common.publish.widget 中 RightValue 的使用

返回 RightValue 的 com.trs.components.common.publish.widget 中的方法
static RightValue | SpecialAuthServer.getRightValue(CMSObj operator, java.lang.Class clazz) 获取指定用户在指定对象类型上的权限值，如是否能新建，导入等
static RightValue | SpecialAuthServer.getRightValue(CMSObj operator, CMSObj obj) 获取指定用户在指定对象上的权限值

com.trs.components.common.publish.widget.tagparser 中 RightValue 的使用

返回 RightValue 的 com.trs.components.common.publish.widget.tagparser 中的方法
 RightValue WCMTagParserBaseOperation.getChannelRightValue(User _currUser, BaseChannel _oBaseChannel)
获取栏目的权限

com.trs.components.metadata.center 中 RightValue 的使用

返回 RightValue 的 com.trs.components.metadata.center 中的方法
 RightValue MetaViewData.getRightValue(User _currUser)
获取当前ViewDocument的RightValue

com.trs.components.wcm.content 中 RightValue 的使用

返回 RightValue 的 com.trs.components.wcm.content 中的方法
 RightValue ViewDocument.getRightValue(User _currUser)
获取当前ViewDocument的RightValue

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.Role 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.Role
的使用

使用 Role 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.components.wcm.content.domain
com.trs.service
com.trs.service.impl

com.trs.cms.auth.domain 中 Role 的使用

返回 Role 的 com.trs.cms.auth.domain 中的方法
Role | RoleMgr.findRoleByName(java.lang.String sRoleName) 根据角色名称，获取到第一个匹配的角色，优先获取id值更大的角色
Role | RoleMgr.save(Role _currRole) 保存指定的角色

参数类型为 Role 的 com.trs.cms.auth.domain 中的方法
boolean | GroupRoleMgr.addGroup(Group _dstGroup, Role _theRole)
boolean | RoleMgr.addUser(Role _theRole, int _nSiteId, User _dstUser) 添加指定用户到指定的角色
boolean | RoleMgr.addUser(User _dstUser, Role _theRole) 已过时。 权限模型调整，需要引入站点id.
boolean | ObjectMemberMgr.canOperate(Role _oRole, int _nObjType, int _nObjId)
boolean | IObjectMemberMgr.canOperate(Role _currRole, int _nObjType, int _nObjId) 判断当前角色对于指定对象是否可操作
boolean | RoleMgr.delete(Role _roleToDelete, boolean _bDrop) 删除角色
Groups | GroupRoleMgr.getGroups(Role _dstRole, WCMFilter _filter) 获取指定角色的关联的组织
RoleUsers | RoleMgr.getRoleUsers(Role _theRole, WCMFilter _filter) 获取指定角色下的角色用户信息
Users | RoleMgr.getUsers(Role _dstRole, int _nSiteId, WCMFilter _filter) 获取某角色在某站点下的所有用户集合
Users | RoleMgr.getUsers(Role _dstRole, WCMFilter _filter) 获取担任某角色的所有用户集合
Users | RoleMgr.getUsersBySpecailForUser(Role _dstRole, WCMFilter _filter) 获取当前登录用户可以查看的某特定角色的所有用户集合
Users | RoleMgr.getUsersBySystemRoleForUser(Role _dstRole, int _nSiteId, WCMFilter _filter) 获取当前登录用户可以查看的某系统级角色的所有用户集合
static boolean | RoleAuthServer.hasRight(User _loginUser, Role _role, int _nRightIndex)
boolean | ObjectMemberMgr.isVisible(Role _oRole, int _nObjType, int _nObjId)
boolean | IObjectMemberMgr.isVisible(Role _currRole, int _nObjType, int _nObjId) 判断当前角色对于指定对象是否可见
boolean | GroupRoleMgr.removeGroup(Group _dstGroup, Role _theRole)
boolean | RoleMgr.removeUser(Role _theRole, int _nSiteId, User _dstUser) 将指定的用户从指定的角色和站点中删除
boolean | RoleMgr.removeUser(User _dstUser, Role _theRole) 已过时。
Role | RoleMgr.save(Role _currRole) 保存指定的角色
void | GroupRoleMgr.setGroups(Role role, Groups groups) 绑定角色role和组织groups的关联，同时将清除原来的关联
void | RoleMgr.setRoleUsers(Role role, int _nSiteId, Users _users) 绑定角色,站点和用户的关联，同时将清除原来的关联

com.trs.cms.auth.persistent 中 Role 的使用

返回 Role 的 com.trs.cms.auth.persistent 中的方法
static Role | Role.createNewInstance() 产生当前对象[Role]的实例
static Role | Role.findById(int _nId) 提取指定ID的对象
static Role | Role.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

参数类型为 Role 的 com.trs.cms.auth.persistent 中的方法
 void RightValue.load(Role _role, int _objType, int _objId)
载入角色在指定对象的权限值

com.trs.components.wcm.content.domain 中 Role 的使用

参数类型为 Role 的 com.trs.components.wcm.content.domain 中的方法
 boolean SiteMemberMgr.isBelongToSite(Role _role, WebSite _site)
判断指定的角色是否属于指定的站点

com.trs.service 中 Role 的使用

返回 Role 的 com.trs.service 中的方法
 Role IRoleService.save(Role _roleToSave)
保存指定的角色

参数类型为 Role 的 com.trs.service 中的方法
User | IRoleService.addUser(User _dstUser, Role _toRole) 添加指定的用户到指定的角色
boolean | IRoleService.delete(Role _roleToDelete) 删除指定的角色
Users | IRoleService.getUsers(Role _dstRole, WCMFilter _filter) 获取指定角色的所有用户
boolean | IRoleService.removeUser(User _dstUser, Role _fromRole) 从指定的角色中删除指定的用户
Role | IRoleService.save(Role _roleToSave) 保存指定的角色

com.trs.service.impl 中 Role 的使用

返回 Role 的 com.trs.service.impl 中的方法
 Role RoleService.save(Role _roleToSave)

参数类型为 Role 的 com.trs.service.impl 中的方法
User | RoleService.addUser(User _dstUser, Role _toRole)
boolean | RoleService.delete(Role _roleToDelete)
Users | RoleService.getUsers(Role _dstRole, WCMFilter _filter)
boolean | RoleService.removeUser(User _dstUser, Role _fromRole)
Role | RoleService.save(Role _roleToSave)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.Roles 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.Roles
的使用

使用 Roles 的软件包
com.trs.ajaxservice
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.components.wcm.content.domain
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 Roles 的使用

返回 Roles 的 com.trs.ajaxservice 中的方法
Roles | RoleServiceProvider.getRolesForCurrUser(MethodContext context) 获取当前登录用户可以查看的所有角色信息
Roles | RoleServiceProvider.getSpecialRolesOfUser(MethodContext context) 获取指定用户的特定角色
Roles | RoleServiceProvider.getSystemRolesOfUser(MethodContext context) 获取指定用户在指定站点上的系统级角色

com.trs.cms.auth.domain 中 Roles 的使用

返回 Roles 的 com.trs.cms.auth.domain 中的方法
Roles | RoleMgr.getRoles() 获取系统中的所有角色集合
Roles | GroupRoleMgr.getRoles(Group _dstGroup, WCMFilter _filter) 获取指定组织的所有角色
Roles | UserMgr.getRoles(User _dstUser) 获取当前用户担任的所有角色
Roles | RoleMgr.getRolesForUser(User _user, WCMFilter _filter) 获取指定用户可见的角色
Roles | RoleMgr.getSpecialRolesOfUser(User _user, WCMFilter _filter) 获取指定用户上设置的特定角色
Roles | RoleMgr.getSystemRolesOfUser(User _user, int nSiteId, WCMFilter _filter) 获取指定用户在指定站点上设置的角色信息

参数类型为 Roles 的 com.trs.cms.auth.domain 中的方法
void | RoleMgr.setSpecailRolesOfUser(User _user, Roles _roles) 设置用户的特定角色，同时将清除原来的特定角色d关联
void | RoleMgr.setSystemRolesOfUser(User _user, int _nSiteId, Roles roles) 设置用户在指定站点上的系统级角色，同时将清除原来的关联

com.trs.cms.auth.persistent 中 Roles 的使用

返回 Roles 的 com.trs.cms.auth.persistent 中的方法
static Roles | Roles.createNewInstance(User _currUser) 产生当前集合对象[Roles]的实例
static Roles | Roles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Roles | User.getRoles() 获取用户所属的特定角色以及作用于所有站点的角色.
Roles | RoleUserCacheMgr.getRoles(User _currUser, WebSite _currSite)
static Roles | Right.getRolesWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的角色集合
static Roles | Roles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Roles]

com.trs.components.wcm.content.domain 中 Roles 的使用

返回 Roles 的 com.trs.components.wcm.content.domain 中的方法
 Roles SiteMemberMgr.getSiteRoles(WebSite _site, WCMFilter _fitler)

com.trs.service 中 Roles 的使用

返回 Roles 的 com.trs.service 中的方法
Roles | IUserService.getRoles() 获取当前登录用户所担任的角色.
Roles | IUserService.getRoles(User _currUser) 获取指定用户所属的角色集合
Roles | IChannelService.getSiteRoles(WebSite _site, WCMFilter _filter) 获取指定站点的所属角色集合

参数类型为 Roles 的 com.trs.service 中的方法
 boolean IRoleService.delete(Roles _rolesToDelete)
删除指定的角色集合

com.trs.service.impl 中 Roles 的使用

返回 Roles 的 com.trs.service.impl 中的方法
Roles | UserService.getRoles()
Roles | UserService.getRoles(User _currUser)
Roles | ChannelService.getSiteRoles(WebSite _site, WCMFilter _filter)

参数类型为 Roles 的 com.trs.service.impl 中的方法
 boolean RoleService.delete(Roles _rolesToDelete)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.RoleUser 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.RoleUser
的使用

使用 RoleUser 的软件包
com.trs.cms.auth.persistent

com.trs.cms.auth.persistent 中 RoleUser 的使用

返回 RoleUser 的 com.trs.cms.auth.persistent 中的方法
static RoleUser | RoleUser.createNewInstance() 产生当前对象[RoleUser]的实例
static RoleUser | RoleUser.findById(int _nId) 提取指定ID的对象
static RoleUser | RoleUser.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.RoleUserCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.RoleUserCacheMgr
的使用

没有 com.trs.cms.auth.persistent.RoleUserCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.RoleUsers 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.RoleUsers
的使用

使用 RoleUsers 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent

com.trs.cms.auth.domain 中 RoleUsers 的使用

返回 RoleUsers 的 com.trs.cms.auth.domain 中的方法
RoleUsers | RoleMgr.getRoleUsers(Role _theRole, WCMFilter _filter) 获取指定角色下的角色用户信息
RoleUsers | RoleMgr.getRoleUsers(User _theUser, WCMFilter _filter) 获取指定用户下的角色用户信息

com.trs.cms.auth.persistent 中 RoleUsers 的使用

返回 RoleUsers 的 com.trs.cms.auth.persistent 中的方法
static RoleUsers | RoleUsers.creatNewInstance(User _currUser) 产生一个当前集合对象[RoleUsers]的实例
static RoleUsers | RoleUsers.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static RoleUsers | RoleUsers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RoleUsers]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.RoleXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.RoleXmlConverter
的使用

没有 com.trs.cms.auth.persistent.RoleXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.TrusteeInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.TrusteeInfo
的使用

没有 com.trs.cms.auth.persistent.TrusteeInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.TrusteeInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.TrusteeInfos
的使用

没有 com.trs.cms.auth.persistent.TrusteeInfos 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.User 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.User
的使用

使用 User 的软件包
com.trs.ajaxservice |
com.trs.ajaxservice.xmlconvertors |
com.trs.cms |
com.trs.cms.auth |
com.trs.cms.auth.domain |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.logger |
com.trs.cms.process |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.cms.process.xml |
com.trs.components.comment.persistent |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.domain.auth |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.gkml.sqgk.process.element |
com.trs.components.govinfo |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.definition |
com.trs.components.metadata.definition.xml |
com.trs.components.metadata.publish |
com.trs.components.metadata.right |
com.trs.components.metadata.service |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.auth |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.trsserver |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.process |
com.trs.components.wcm.process.element |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.util |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.jsp |
com.trs.components.wcm.wcmx.media |
com.trs.components.wcm.wcmx.websites |
com.trs.infra.persistent.util |
com.trs.presentation.ids |
com.trs.presentation.locale |
com.trs.presentation.nav |
com.trs.presentation.right |
com.trs.presentation.util |
com.trs.presentation.wcm.content |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.config |
com.trs.wcm.customize |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |
com.trsupdate |

com.trs.ajaxservice 中 User 的使用

参数类型为 User 的 com.trs.ajaxservice 中的方法
static ViewDocuments | WCMDocumentHelper.findViewDocumentsByIds(User _loginUser, java.lang.String _sChnlDocIds)
static Channels | ChannelHelper.getChildren(User _loginUser, BaseChannel _parent, WCMFilter _extraFilter)
static WebSites | WebSiteHelper.getWebSitesByRightIndex(User _loginUser, int _nRightIndex, WCMFilter extraFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual) 获取某个用户能操作的站点集合
static WebSites | WebSiteHelper.getWebSitesByType(User _loginUser, int _nSiteType, WCMFilter queryFilter)
static WebSites | WebSiteHelper.getWebSitesByTypeWithIndividual(User _loginUser, int _nSiteType, WCMFilter queryFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual)
static boolean | WCMProcessServiceHelper.hasFlowingActionRight(User _loginUser, int _nFlowdocId, int _nRightIndex)
static boolean | WebSiteHelper.isVisible(User _loginUser, WebSite _site) 判断用户对于指定站点是否可见
static PageOperators | PageOperatorsForServiceHelper.makeCMSBaseObjsOpertators(User _loginUser, java.lang.String _sObjectIds, CMSBaseObjs _objects)
static PageOperators | PageOperatorsForServiceHelper.makeCMSObjOpertators(User _loginUser, java.lang.String _sObjectKey, CMSObj channel)
static WCMFilter | DocumentAuthHelper.makeFilterWithRight(User _loginUser, BaseObjs _oSitesOrChannels) 构造当前用户在指定的栏目中带有权限的Filter
static RightValue | TemplateAuthHelper.makeHostRightValue(MethodContext _context, User _loginUser, IPublishFolder _host)
static java.lang.String | WCMDocumentHelper.makeRightValue(MethodContext _methodContext, User _loginUser, Channel _currChannel, Document _document) 构造指定文档在指定栏目中的权限
static RightValue | TemplateAuthHelper.makeTemplateRightValue(MethodContext _context, User _loginUser, Template _template, IPublishFolder _host)
static void | ChannelHelper.removeNoRightChannel(User _loginUser, Channels _channels, int _nRightIndex)
static CMSObj | WCMAJAXServiceHelper.setWCMObjectProperties(User _loginUser, MethodContext _methodContext, CMSObj _oCMSObj, java.lang.String[] _pLogicFields) 更新指定的对象
static void | WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, boolean _bUseDefaultFlowMode)
static void | WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, java.util.Map _hFlowContextInfo)
static void | WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, MethodContext _oMethodContext)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, boolean _bUseDefaultFlowMode)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, Flow _oFlow, MethodContext _oMethodContext)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, java.util.Map _hFlowContextInfo)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, MethodContext _oMethodContext)
static void | WCMApplyFormProcessServiceHelper.validateWorkFlowRight(User _loginUser, BaseObj _content, int _nFlowDocId, int _nActionIndex, java.lang.String _sOperDesc)
static void | WCMProcessServiceHelper.validateWorkFlowRight(User _loginUser, BaseObj _content, int _nFlowDocId, int _nActionIndex, java.lang.String _sOperDesc)

参数类型为 User 的 com.trs.ajaxservice 中的构造方法
ContentExtendValues(User _currUser)
ContentExtendValues(User _currUser, int _initCapacity, int _incCapacity)

com.trs.ajaxservice.xmlconvertors 中 User 的使用

参数类型为 User 的 com.trs.ajaxservice.xmlconvertors 中的构造方法
XMLToCMSObj(User _currUser, CMSObj _oSrcInstance)

com.trs.cms 中 User 的使用

返回 User 的 com.trs.cms 中的方法
static User ContextHelper.getLoginUser()
获得当前线程的登录用户，委托给ContextTL 处理策略：
1.

参数类型为 User 的 com.trs.cms 中的方法
static void | ContextHelper.initContext(User _loginUser) 初始化时，同时初始化登录用户参数
static void | ContextHelper.setLoginUser(User _currUser) 设置当前线程的登录用户

com.trs.cms.auth 中 User 的使用

参数类型为 User 的 com.trs.cms.auth 中的方法
static boolean | AuthHelper.hasRightOnSelf(User _currUser, CMSObj _objCurrent, int[] _pRightIndex)
static boolean | AuthHelper.hasSuperRight(User _currUser, CMSObj _currObj)

com.trs.cms.auth.domain 中 User 的使用

返回 User 的 com.trs.cms.auth.domain 中的方法
 User UserMgr.save(User _dstUser)
保存用户

参数类型为 User 的 com.trs.cms.auth.domain 中的方法
boolean | RoleMgr.addUser(Role _theRole, int _nSiteId, User _dstUser) 添加指定用户到指定的角色
boolean | GroupMgr.addUser(User _userToAdd, Group _theGroup) 将用户加到指定组织中去
boolean | RoleMgr.addUser(User _dstUser, Role _theRole) 已过时。 权限模型调整，需要引入站点id.
boolean | ObjectMemberMgr.canOperate(User _oUser, int _nObjType, int _nObjId)
boolean | IObjectMemberMgr.canOperate(User _currUser, int _nObjType, int _nObjId) 判断当前用户对于指定对象是否可操作
boolean | UserMgr.changeUserRegStatus(User _dstUser, int _nNewStatusId) 更改用户的注册状态
boolean | UserMgr.delete(User _aUserToBeDeleted, boolean _bDrop) 删除一个用户
java.lang.String | IDepartmentMgr.getDepartmentInfo(User _user) 获取指定用户的所属部门描述信息，多级默认以/分隔
java.lang.String | DepartmentMgrImpl.getDepartmentInfo(User _user)
java.lang.String | IDepartmentMgr.getDepartmentInfo(User _user, java.lang.String _sDelimit) 获取指定用户的所属部门描述信息，多级以_sDelimit指定的分隔符分开，默认为\
java.lang.String | DepartmentMgrImpl.getDepartmentInfo(User _user, java.lang.String _sDelimit)
Groups | IDepartmentMgr.getDeptGroups(User _user) 获取指定用户所属的组织结构
Groups | DepartmentMgrImpl.getDeptGroups(User _user)
Groups | IDepartmentMgr.getDeptGroupTree(User _user) 获取指定用户的所属部门组织树，按照树形结构组织
Groups | DepartmentMgrImpl.getDeptGroupTree(User _user)
Groups | UserMgr.getGroups(User _dstUser) 获取当前用户所在的所有组织
Groups | GroupMgr.getGroups(User _user, WCMFilter _filter) 根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织
static java.lang.String | AuthServer.getLogicalRightValue(CMSObj _currObj, User _currOpUser, int[] _rightIndexes) 获取当前逻辑权限值，包含了继承关系
Groups | GroupMgr.getOffspringGroups(User _user, WCMFilter _filter) 根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织,同时包含子孙组织
static RightValue | AuthServer.getRightValue(CMSObj _currObj, User _currOpUser) 获取当前权限值
Roles | UserMgr.getRoles(User _dstUser) 获取当前用户担任的所有角色
Roles | RoleMgr.getRolesForUser(User _user, WCMFilter _filter) 获取指定用户可见的角色
RoleUsers | RoleMgr.getRoleUsers(User _theUser, WCMFilter _filter) 获取指定用户下的角色用户信息
Roles | RoleMgr.getSpecialRolesOfUser(User _user, WCMFilter _filter) 获取指定用户上设置的特定角色
Roles | RoleMgr.getSystemRolesOfUser(User _user, int nSiteId, WCMFilter _filter) 获取指定用户在指定站点上设置的角色信息
static boolean | AuthServer.hasAttributeRight(User _currUser) 判断当前用户对于系统属性是否具有进入权限
static boolean | AuthServer.hasExtendedRight(User _currUser)
static boolean | AuthServer.hasExtendedRight(User _currUser, int _nRightIndex)
static boolean | AuthServer.hasMgrDocSourceRight(User _currUser) 添加一个判断是否有管理文档来源的权限判断方法
static boolean | AuthServer.hasRight(User _currUser, CMSObj _currObj) 判断用户对特定对象是否有“访问权限”
static boolean | AuthServer.hasRight(User _currUser, CMSObj _objCurrent, int _index) 判断当前用户对于指定的频道对象是否具有指定索引的权限
static boolean | GroupAuthServer.hasRight(User _loginUser, Group group, int _nRightIndex)
boolean | GroupRightObjImpl.hasRight(User _currUser, int _nRightIndex)
boolean | IRightObj.hasRight(User _currUser, int _nRightIndex) 判断用户对于指定的对象是否具有指定的权限
static boolean | RoleAuthServer.hasRight(User _loginUser, Role _role, int _nRightIndex)
static boolean | AuthServer.hasRightInObjects(User _currUser, CMSBaseObjs _objects, int _index)
static boolean | AuthServer.hasRightOnSelf(User _currUser, CMSObj _objCurrent, int _index)
static boolean | AuthServer.hasRightOnSelf(User _currUser, int _nObjType, int _nObjId, int _index) 判断当前用户对指定的对象是否具有指定权限
static boolean | AuthServer.hasStatisticRight(User _currUser)
static boolean | AuthServer.hasStatisticRight(User _currUser, int _nRightIndex)
static boolean | AuthServer.hasSuperRight(User _currUser, CMSObj _currObj) Created: 2004-11-25 17:27:12 Last Modified: 2004-11-25/2004-11-25 Description: class AuthServer.java 判断当前用户是否有特权(用户是管理员,对象创建者等) wenyh
void | NewRightSet.inheritRights(User _loginUser, IRightHost _rightHost, boolean _bDropOldRights) 继承父对象的权限
void | RightSet.inheritRights(User _loginUser, IRightHost _rightHost, boolean _bDropOldRights) 继承父对象的权限
boolean | GroupMgr.isAdministrator(Group _group, User _user, boolean _bContainAncestor) 判断某个用户是否为某个组织的组管理员
boolean | UserMgr.isAdminOfGroup(User _user) 判断指定用户是否在系统中担任组管理员
boolean | IDepartmentMgr.isDepartmentAdmin(User _user) 判断用户是否是所在用户组的管理员
boolean | DepartmentMgrImpl.isDepartmentAdmin(User _user)
boolean | UserMgr.isManagerOfRole(User _user) 判断指定用户是否在系统中担任角色维护员
boolean | UserMgr.isManagerOfUser(User _user) 判断当前登录用户是否能够管理指定的用户
static boolean | AuthServer.isManagerOfUser(User _loginUser, User _dstUser) 判断当前用户loginUser是否可以管理用户_dstUser
boolean | RoleMgr.isRoleManagers(User _user) 判断指定用户是否为角色管理员
boolean | ObjectMemberMgr.isVisible(User _oUser, int _nObjType, int _nObjId)
boolean | IObjectMemberMgr.isVisible(User _currUser, int _nObjType, int _nObjId) 判断当前用户对于指定对象是否可见
boolean | GroupMgr.moveUser(User _dstUser, Group _srcGroup, Group _dstGroup) 更改指定用户的组织
boolean | RoleMgr.removeUser(Role _theRole, int _nSiteId, User _dstUser) 将指定的用户从指定的角色和站点中删除
boolean | GroupMgr.removeUser(User _dstUser, Group _theGroup) 删除组织中的某个用户
boolean | RoleMgr.removeUser(User _dstUser, Role _theRole) 已过时。
boolean | UserMgr.resetPassword(User _dstUser) 系统管理员重设指定用户的密码为默认密码,用于密码恢复
boolean | UserMgr.resetPassword(User _dstUser, java.lang.String _sNewPassword) 重置用户密码为新密码
boolean | UserMgr.resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword) 重设指定用户的密码
User | UserMgr.save(User _dstUser) 保存用户
static void | UpdUserScheduleCreator.scheduleUpdUserRelatedInfo(User userToBeDeleted, User user)
boolean | GroupMgr.setGroupManager(User _dstUser, Group _theGroup, boolean _isAdministrator) 设置组管理员(设置或取消指定用户的组管理员身份)
boolean | RightSet.setRights(User loginUser, IRightHost _rightHost, java.util.List _currRightList, boolean _bSetChildrenRight)
void | RoleMgr.setSpecailRolesOfUser(User _user, Roles _roles) 设置用户的特定角色，同时将清除原来的特定角色d关联
void | RoleMgr.setSystemRolesOfUser(User _user, int _nSiteId, Roles roles) 设置用户在指定站点上的系统级角色，同时将清除原来的关联
void | IRightHost.validateCanDoSetRight(User _user) 判断指定的用户是否有权给当前对象设置权限

参数类型为 User 的 com.trs.cms.auth.domain 中的构造方法
NewRightSet(User _loginUser, IRightHost _rightHost, java.util.List _currRightList, int[] _pImpartMode)

com.trs.cms.auth.persistent 中 User 的使用

返回 User 的 com.trs.cms.auth.persistent 中的方法
User | IUserCacheMgr._getUserByName(java.lang.String _sUserName) 通过指定的用户名获取用户对象
User | UserCacheMgr._getUserByName(java.lang.String _sUserName)
static User | User.createNewInstance() 产生当前对象[User]的实例
static User | User.findById(int _nId) 提取指定ID的对象
static User | User.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static User | User.findByName(java.lang.String _sUserName)
User | Users.getByName(java.lang.String _sName) 通过用户名从集合中获取用户对象
User | TrusteeInfo.getCrUserById()
static User | User.getSystem()
User | TrusteeInfo.getTrustee()

参数类型为 User 的 com.trs.cms.auth.persistent 中的方法
void | Group.addAdministrator(User _user) 更新用户所属用户组缓冲区（添加）
boolean | Group.addUser(int _addedUserId, User _opUser) 添加新的用户到该组
boolean | Group.addUser(int _addedUserId, User _opUser, boolean _isAdministrator)
boolean | Group.addUser(User _userToAdd, User _opUser)
boolean | Group.addUser(User _userToAdd, User _opUser, boolean _isAdministrator) 添加新的用户到该组
static ObjectMembers | ObjectMembers.createNewInstance(User _currUser) 产生当前集合对象[ObjectMembers]的实例
static RightDefs | RightDefs.createNewInstance(User _currUser) 产生一个当前集合对象[RightDefs]的实例
static Users | Users.createNewInstance(User _currUser) 产生当前集合对象[Users]的实例
static Rights | Rights.createNewInstance(User _currUser) 产生当前集合对象[Rights]的实例
static Groups | Groups.createNewInstance(User _currUser) 产生当前集合对象[Groups]的实例
static Roles | Roles.createNewInstance(User _currUser) 产生当前集合对象[Roles]的实例
static GroupUsers | GroupUsers.creatNewInstance(User _currUser) 产生一个当前集合对象[GroupUsers]的实例
static RoleUsers | RoleUsers.creatNewInstance(User _currUser) 产生一个当前集合对象[RoleUsers]的实例
static GroupRoles | GroupRoles.creatNewInstance(User _currUser) 产生一个当前集合对象[RoleUsers]的实例
static ObjectMembers | ObjectMembers.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static RightDefs | RightDefs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Users | Users.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Rights | Rights.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Groups | Groups.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Roles | Roles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static GroupUsers | GroupUsers.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static RoleUsers | RoleUsers.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static GroupRoles | GroupRoles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Users | Group.getAdministrator(User _opUser) 取用户所属组对象集合
Groups | Group.getChildren(User _currUser) 取组的子组集合
Groups | Group.getChildren(User _currUser, java.lang.String _sOrder) 获取按照指定的排序方式排序的组的子组集合
static Groups | Right.getGroupsWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的角色集合
Roles | RoleUserCacheMgr.getRoles(User _currUser, WebSite _currSite)
static Roles | Right.getRolesWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的角色集合
Users | Group.getUsers(User _currUser) 取组内所有用户集合（Users）
Users | Role.getUsers(User _currUser) 取属于该角色的所有用户
Users | Group.getUsers(User _currUser, java.lang.String _sOrder) 获取按照一定排序方式取组内所有用户集合（Users）
static Users | Right.getUsersWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的集合用户
void | User.insert(User _currUser) 添加用户记录到数据库
void | TrusteeInfo.insert(User _currUser) 将对象数据写入数据库
void | RoleUser.insert(User _currUser) 将对象数据写入数据库
void | ObjectMember.insert(User _currUser) 将对象数据写入数据库
void | RightDef.insert(User _currUser)
void | GroupRole.insert(User _currUser) 将对象数据写入数据库
void | GroupUser.insert(User _currUser) 将对象数据写入数据库
boolean | Group.isAdministrator(User _currUser) 判断用户是否是本组的管理员
void | RightValue.load(User _user, int _objType, int _objId) 载入用户在指定对象的权限值（综合了用户所属角色的权限）
void | RightValue.load(User _user, int _objType, int _objId, boolean _bIncludeGrpAndRole)
static ObjectMembers | ObjectMembers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ObjectMembers]
static RightDefs | RightDefs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RightDefs]
static Users | Users.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Users]
static Rights | Rights.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Rights]
static Groups | Groups.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Groups]
static Roles | Roles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Roles]
static GroupUsers | GroupUsers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[GroupUsers]
static RoleUsers | RoleUsers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RoleUsers]
static GroupRoles | GroupRoles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RoleUsers]
void | Group.removeAdministrator(User _user) 更新用户所属用户组缓冲区（删除）
void | User.update(User _currUser)

参数类型为 User 的 com.trs.cms.auth.persistent 中的构造方法
GroupRoles(User _currUser)
构造函数
GroupRoles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Groups(User _currUser)
Groups(User _currUser, int initialCapacity, int capacityIncrement)
GroupUsers(User _currUser)
构造函数
GroupUsers(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ObjectMembers(User _currUser)
构造函数
ObjectMembers(User _currUser, int _initCapacity, int _incCapacity)
构造函数
RightDefs(User _currUser)
RightDefs(User _currUser, int _initCapacity, int _incCapacity)
Rights(User _currUser)
Rights(User _currUser, int initialCapacity, int capacityIncrement)
Roles(User _currUser)
构造函数
Roles(User _currUser, int initialCapacity, int capacityIncrement)
构造函数
RoleUsers(User _currUser)
构造函数
RoleUsers(User _currUser, int _initCapacity, int _incCapacity)
构造函数
TrusteeInfos(User _currUser)
构造函数
TrusteeInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Users(User _currUser)
构造函数
Users(User _currUser, int initialCapacity, int capacityIncrement)
构造函数

com.trs.cms.content 中 User 的使用

返回 User 的 com.trs.cms.content 中的方法
User | CMSObj.getCrUser()
User | CMSBaseObjs.getCurrUser() 获得CurrUser：当前用户
User | CMSObj.getLockerUser() 取本对象的加锁人
User | Locker.getLockUser() 获取锁定的用户

参数类型为 User 的 com.trs.cms.content 中的方法
void | CMSObj.cancelUpdate(User _user) 撤销更新操作，清除更新缓冲区
boolean | CMSObj.canEdit(User _user)
boolean | CMSObj.canEdit(User _user, int _nLockTimeOut) 检测是否允许编辑，在指定的时间内锁定对象
static CMSBaseObjs | CMSBaseObjs.createInstance(User _currUser, java.lang.Class _classObjs) 产生指定集合对象的实例
static CMSBaseObjs | CMSBaseObjs.createInstance(User _currUser, java.lang.String _sObjsClassName) 产生指定集合对象的实例
static DefaultObjs | DefaultObjs.createNewInstance(User _currUser) 产生当前集合对象[DefaultObjs]的实例
static ExtendedFields | ExtendedFields.createNewInstance(User _currUser) 产生当前集合对象[ExtendedFields]的实例
int | CMSObj.delete(User _currUser) 从数据中删除对象信息
int | ExtendedField.delete(User _currUser) 删除扩展字段对象，重载父类接口：删除该对象之前，必须确保无任何频道使用该字段
static ExtendedFields | ExtendedFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DefaultObjs | DefaultObjs.findByIds(User _currUser, java.lang.String _sIds, java.lang.String _sDbTableName, java.lang.String _sIdFieldName) 提取指定ID序列的对象集合
static CMSBaseObjs | CMSBaseObjs.findWCMObjsByIds(User _currUser, java.lang.Class _classObjs, java.lang.String _sObjIds)
static CMSBaseObjs | CMSBaseObjs.findWCMObjsByIds(User _currUser, java.lang.String _sObjsClassName, java.lang.String _sObjIds) 根据ID序列获取一个指定的集合
void | LockManager.freeLockedObjBy(User _currUser) 释放所有由特定用户锁定的对象.
void | LockerMgr.freeLockedObjBy(User _currUser) 释放所有由特定用户锁定的对象.
void | CMSObj.insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
void | ExtendedField.insert(User _currUser) 添加对象到数据库，重载WCMObj接口
boolean | CMSObj.lock(User _lockUser)
boolean | Locker.lock(User _lockUser) 指定用户在默认的锁定时间内锁定对象
boolean | CMSObj.lock(User _lockUser, int _lockTimeOut) 锁定对象，默认锁定时间在系统配置中可以设置
boolean | Locker.lock(User _lockUser, int _lockTimeOut) 指定用户在指定的时间内锁定对象
boolean | Locker.lockUserIs(User _user) 判断指定用户是否为锁定人
static CMSBaseObjs | CMSBaseObjs.openWCMObjs(User _currUser, java.lang.Class _objsClass, WCMFilter _filter) 根据指定的Filter打开指定的集合
static CMSBaseObjs | CMSBaseObjs.openWCMObjs(User _currUser, java.lang.String _sObjsClassName, WCMFilter _filter) 根据指定的Filter打开指定的集合
static ExtendedFields | ExtendedFields.openWCMObjs(User _currUser, WCMFilter _filter)
static DefaultObjs | DefaultObjs.openWCMObjs(User _currUser, WCMFilter _filter, java.lang.String _sDbTableName, java.lang.String _sIdFieldName) 通过指定一个Filter获取当前集合[DefaultObjs]
void | CMSObj.save(User _currUser) 对象保存自己
boolean | CMSObj.setCrUser(User _crUser)
void | CMSBaseObjs.setCurrUser(User user)
static CMSObj | WCMObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, User _loginUser, int _nObjId, java.lang.Class _oWCMObjClass) 解析传入的XML内容，生成传入WCMOBJ对象。
static java.util.List | WCMObjHelper.toWCMObjList(java.lang.String _sWCMObjsXMLContent, CMSObj _obj, User _loginUser) 解析传入的XML内容，生成包含指定类型WCMObj的List。
static void | WCMObjHelper.unlock(int _nObjType, int _nObjId, User _unlockerUser) 指定的用户给指定的对象解锁
void | CMSObj.update(User _user) 更新修改。
void | CMSObj.validCanDeleteAndLock(User _user)
void | CMSObj.validCanEditAndLock(User _user)
void | CMSObj.validCanEditAndLock(User _user, int _nLockTimeOut)

参数类型为 User 的 com.trs.cms.content 中的构造方法
ClusterLocker(User lockuser, CMSObj lockedObj)
CMSBaseObjs(User _currUser)
构造函数
CMSBaseObjs(User _currUser, int _initCapacity, int _incCapacity)
构造函数（默认不指定容量，建立指定）
DefaultObjs(User _currUser)
DefaultObjs(User _currUser, int _initCapacity, int _incCapacity)
DefaultObjs(User _currUser, java.lang.String _sDbTableName, java.lang.String _sIdFieldName)
ExtendedFields(User _currUser)
ExtendedFields(User _currUser, int initialCapacity, int capacityIncrement)

com.trs.cms.logger 中 User 的使用

参数类型为 User 的 com.trs.cms.logger 中的方法
int | ObjSysLogger.startLogDeleting(User curruser, BaseObj object) 开始记录一个删除记录的日志
int | ObjSysLogger.startLogInserting(User curruser, BaseObj object) 开始记录一个新增记录的日志
int | ObjSysLogger.startLogModifying(User curruser, BaseObj object) 开始记录一个修改记录的日志

com.trs.cms.process 中 User 的使用

返回 User 的 com.trs.cms.process 中的方法
User | IFlowContent.getCrUser()
User | QueryFlowDocContext.getCurrUser()

参数类型为 User 的 com.trs.cms.process 中的方法
void | IFlowNotifyWorker.addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, int _nNotify)
void | IFlowNotifyWorker.addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)
void | IFlowNotifyWorker.addMsgEvent(User _currUser, User _toUser, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)
void | IFlowContent.cancelUpdate(User user) 取消本次更新
boolean | IFlowContent.canEdit(User _currUser) 判断当前操作用户是否可以对当前流转的内容进行修改
void | FlowServer.forceDocToEnd(IFlowContent _currDoc, User _currUser)
static Users | FlowServer.getConsignUsers(User _operator, int _nModule) 获得指定模块的所有的委托人，默认为公文管理(TrusteeInfo.MODULE_FLOW)
IFlowContent[] | FlowServerImpl.getFlowContentsDoneByUser(User _currUser)
IFlowContent[] | IFlowServer.getFlowContentsDoneByUser(User _currUser) 获取指定用户已经处理过的内容
IFlowContent[] | FlowServerImpl.getFlowContentsDoneByUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsDoneByUser(User _currUser, CPager _cpager) 获取指定用户已经处理过的内容
IFlowContent[] | FlowServerImpl.getFlowContentsOfUser(User _currUser)
IFlowContent[] | IFlowServer.getFlowContentsOfUser(User _currUser) 获取指定用户可以处理的内容
IFlowContent[] | FlowServerImpl.getFlowContentsOfUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsOfUser(User _currUser, CPager _cpager) 获取指定用户可以处理的内容
IFlowContent[] | FlowServerImpl.getFlowContentsStartByUser(User _currUser)
IFlowContent[] | IFlowServer.getFlowContentsStartByUser(User _currUser) 获取指定用户已经启动的内容
IFlowContent[] | FlowServerImpl.getFlowContentsStartByUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsStartByUser(User _currUser, CPager _cpager) 获取指定用户已经启动的内容
FlowDocs | FlowServer.getFlowDocs(User _operator, int _nFlag, WCMFilter _filter)
FlowDocs | FlowServer.getSubmitFlowDocs(User _operator, WCMFilter _filter)
FlowDoc | FlowServer.removeFlowDoc(IFlowContent _doc, User _currUser) 从FlowServer移去指定的FlowDoc对象
FlowDoc | FlowServer.removeFlowDoc(int _nObjType, int _nObjId, User _currUser) 从FlowServer移去指定的FlowDoc对象
void | QueryFlowDocContext.setCurrUser(User _sCurrUser)
FlowDoc | FlowServer.startContentInFlow(User _currUser, IFlowContent _doc)
FlowDoc | FlowServer.startContentInFlow(User _currUser, IFlowContent _content, java.lang.String _sPostDesc) 为文档对象添加新的FlowDoc对象，使文档进入工作流流转
void | FlowServer.submitAgain(User user, int flowDocId, java.lang.String opinion)
FlowDoc | FlowServer.submitBack(User _currUser, IFlowContent _doc, java.lang.String _sPostDesc)
FlowDoc | FlowServer.submitBack(User _currUser, IFlowContent _content, java.lang.String _sOpinion, int _nStatusId) 将文档返回到上一个节点，并返回给指定的用户
void | IFlowContent.updateStatus(User user, int statusId) 更新当前内容的工作流状态

com.trs.cms.process.definition 中 User 的使用

参数类型为 User 的 com.trs.cms.process.definition 中的方法
static FlowEmploys | FlowEmploys.createNewInstance(User _currUser) 产生当前集合对象[FlowEmploys]的实例
static FlowActions | FlowActions.createNewInstance(User _currUser) 产生当前集合对象[FlowActions]的实例
static FlowRules | FlowRules.createNewInstance(User _currUser) 产生当前集合对象[FlowRules]的实例
static Flows | Flows.createNewInstance(User _currUser) 产生当前集合对象[Flows]的实例
static FlowConditions | FlowConditions.createNewInstance(User _currUser) 产生当前集合对象[FlowConditions]的实例
static FlowNodes | FlowNodes.createNewInstance(User _currUser) 产生当前集合对象[FlowNodes]的实例
static FlowNodeFields | FlowNodeFields.createNewInstance(User _currUser) 产生当前集合对象[FlowNodeFields]的实例
static FlowdocLogs | FlowdocLogs.createNewInstance(User _currUser) 产生当前集合对象[FlowdocLogs]的实例
static FlowNodeBranchs | FlowNodeBranchs.createNewInstance(User _currUser) 产生当前集合对象[FlowNodeBranchs]的实例
int | FlowNode.delete(User _currUser) 重载父类delete函数，删除与工作流节点相关的信息（流转中的文档、节点操作者、分支等）
int | Flow.delete(User _currUser) 重载父类delete函数，删除与工作流相关的信息（流转中的文档、节点、频道中工作流的设置等）
static FlowEmploys | FlowEmploys.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowActions | FlowActions.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowRules | FlowRules.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Flows | Flows.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowConditions | FlowConditions.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowNodes | FlowNodes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowNodeFields | FlowNodeFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowdocLogs | FlowdocLogs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowNodeBranchs | FlowNodeBranchs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowRules | FlowRules.findOf(User _currUser, CMSObj _host) 根据Host获取相关的规则
static FlowNodeFields | FlowNodeFields.findOf(User _currUser, FlowNode _node)
static FlowRules | FlowRules.findOf(User _currUser, int _nHostType, int _nHostId) 根据Host获取相关的规则
FlowActions | FlowRule.getActions(User _currUser) 获取规则中设定的所有操作
FlowNodeBranchs | FlowNode.getBranchs(User _currUser) 取得节点上的所有工作流分支集合
FlowNodeBranch | FlowNode.getBranchTo(User _currUser, FlowNode _nextNode) 获得当前节点到指定节点的分支
FlowConditions | FlowRule.getConditions(User _currUser) 获取规则中设定的所有条件
FlowNodes | Flow.getFlowNodes(User _currUser) 取得工作流节点集合
Groups | Flow.getMonitorGroups(User _currUser) 取工作流的监控用户组
Users | Flow.getMonitorUsers(User _currUser) 取工作流的监控用户
FlowNode | FlowNodeBranch.getNextNode(User _currUser) 取下一个节点对象
FlowNodes | FlowNode.getNextNodes(User _currUser) 获取下一个节点集合
FlowNodes | FlowNode.getNextNodes(User _currUser, WCMFilter _filter)
Groups | FlowNode.getOperGroups(User _currUser) 取节点上的操作用户组
Users | FlowNode.getOperUsers(User _currUser) 取节点上的操作用户集合
Users | FlowNode.getOperUsers(User _currUser, boolean _bAll)
Users | FlowNode.getOperUsers(User _currUser, boolean _bAll, java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sOrder) 返回节点上定义的用户
void | FlowCondition.insert(User _currUser) 将对象数据写入数据库
void | FlowAction.insert(User _currUser) 将对象数据写入数据库
void | FlowEmploy.insert(User _currUser) 将对象数据写入数据库
void | FlowNode.insert(User _currUser) 重载父类的insert函数，以便设置产生时间
void | FlowdocLog.insert(User _currUser) 将对象数据写入数据库
void | FlowNodeField.insert(User _currUser) 将对象数据写入数据库
void | FlowRule.insert(User _currUser) 将对象数据写入数据库
static FlowEmploys | FlowEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowEmploys]
static FlowActions | FlowActions.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowActions]
static FlowRules | FlowRules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowRules]
static Flows | Flows.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Flows]
static FlowConditions | FlowConditions.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowConditions]
static FlowNodes | FlowNodes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodes]
static FlowNodeFields | FlowNodeFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodeFields]
static FlowdocLogs | FlowdocLogs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowdocLogs]
static FlowNodeBranchs | FlowNodeBranchs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodeBranchs]
void | FlowEmployMgr.setEmployersOfFlow(User _loginUser, int _nFlowId, int _nEmployerType, int[] _pEmployerIds) 批量维护指定工作流的配置关系
void | FlowNodeBranch.update(User _user) 重载父类的update函数，实现下一个节点修改的同步

参数类型为 User 的 com.trs.cms.process.definition 中的构造方法
FlowActions(User _currUser)
构造函数
FlowActions(User _currUser, int _initCapacity, int _incCapacity)
构造函数
FlowConditions(User _currUser)
构造函数
FlowConditions(User _currUser, int _initCapacity, int _incCapacity)
构造函数
FlowdocLogs(User _currUser)
构造函数
FlowdocLogs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
FlowEmploys(User _currUser)
FlowEmploys(User _currUser, int _initCapacity, int _incCapacity)
FlowNodeBranchs(User _currUser)
FlowNodeBranchs(User _currUser, int initialCapacity, int capacityIncrement)
FlowNodeFields(User _currUser)
构造函数
FlowNodeFields(User _currUser, int _initCapacity, int _incCapacity)
构造函数
FlowNodes(User _currUser)
FlowNodes(User _currUser, int initialCapacity, int capacityIncrement)
FlowRules(User _currUser)
构造函数
FlowRules(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Flows(User _currUser)
Flows(User _currUser, int initialCapacity, int capacityIncrement)

com.trs.cms.process.engine 中 User 的使用

返回 User 的 com.trs.cms.process.engine 中的方法
User | FlowContext.getCurrUser()
User | FlowParamers.getPostUser()
User | ExecuteContext.getPostUser() 获取处理人
User | FlowContext.getPostUser()
User | FlowDoc.getPostUser() 获取递交用户
User | FlowContextOld.getPostUser() 获取呈送文档的用户
User | ContentProcessInfo.getStartUser()
User | FlowDoc.getToUser() 获取接收者

参数类型为 User 的 com.trs.cms.process.engine 中的方法
 boolean FlowDoc.addToUser(User _user)
添加呈送人员
static FlowContentConfigs FlowContentConfigs.createNewInstance(User _currUser)
产生当前集合对象[FlowContentConfigs]的实例
static FlowDocs FlowDocs.createNewInstance(User _currUser)
产生当前集合对象[FlowDocs]的实例
static FlowContentConfigs FlowContentConfigs.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合
static FlowDocs FlowDocs.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合
static FlowDocs FlowDocs.findByIdsOfDealer(User _currUser, java.lang.String _sIds, User _dealer)
根据处理者或者与其相关的FlowDocs
static FlowDocs FlowDocs.findByIdsOfPoster(User _currUser, java.lang.String _sIds, User _poster)
static FlowDocs FlowDocs.findOfContent(User _currUser, int _nContentType, int _nContentId, WCMFilter _extraFilter)
获取与指定内容相关的轨迹
 FlowNodeBranch FlowDoc.getBranchComeFrom(User _currUser)
获取文档流转到当前状态经过的分支
 FlowDocs FlowDoc.getChildren(User _currUser, WCMFilter _filter)
获取当前轨迹的子轨迹列表
static Users FlowUserHelper.getDeptMgrsOfUserx(User _user)
获取用户所属部门的部门经理(管理员)
 FlowDoc FlowDocBak.getPrevious(User _currUser, boolean _bGoBack)
该方法与其父类中的同签名方法的行为定义有所不同。
 FlowDoc FlowDoc.getPrevious(User _currUser, boolean _bGoBack)
取前一个流转经过的FlowDoc对象 Sample: A->B->C，然后两次打回 C->B->A，在B处打回时需要将参数_bGoBack置为true
 Users FlowDoc.getToUsers(User _currUser)
获取所有呈送人员集合
 void FlowContentConfig.insert(User _currUser)
将对象数据写入数据库
 void FlowDoc.insert(User _currUser)
重载父类的insert函数，以便设置产生时间
static FlowContentConfigs FlowContentConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowContentConfigs]
static FlowDocs FlowDocs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowDocs]
 void FlowContext.setCurrUser(User currUser)
 void FlowParamers.setPostUser(User postUser)
 void FlowContext.setPostUser(User postUser)
 boolean FlowDoc.setPostUser(User _postUser)
设置递交用户
 void ContentProcessInfo.setStartUser(User startUser)
 boolean FlowDoc.setToUser(User _toUser)
设置接收者
 void FlowContentConfig.update(User _user)

参数类型为 User 的 com.trs.cms.process.engine 中的构造方法
ContentProcessInfo(boolean _bEnd, Flow _contentFlow, User _oStartUser)
FlowContentConfigs(User _currUser)
构造函数
FlowContentConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
FlowContext(User _currUser, IFlowContent _oFlowContent)
内容开始流转时候的FlowContext构造函数
FlowContext(User _currUser, IFlowContent _oFlowContent, java.lang.String _sPostDesc, Users _toUsers, Flow _flow)
内容开始流转时候的FlowContext构造函数
FlowContextOld(IFlowContent _currObj, FlowNode _currNode, User _postUser)
工作流环境变量记录对象的构造函数
FlowDocBaks(User _currUser)
FlowDocBaks(User _currUser, int initialCapacity, int capacityIncrement)
FlowDocs(User _currUser)
FlowDocs(User _currUser, int initialCapacity, int capacityIncrement)
FlowNextBranchInfo(User _currUser, FlowDoc _currFlowDoc, int _nNextNodeId, boolean _bResubmit)

com.trs.cms.process.xml 中 User 的使用

参数类型为 User 的 com.trs.cms.process.xml 中的构造方法
FlowImporter(User _loginUser, int _nImportType)

com.trs.components.comment.persistent 中 User 的使用

参数类型为 User 的 com.trs.components.comment.persistent 中的方法
static TopicedDocRelations | TopicedDocRelations.createNewInstance(User _currUser) 产生当前集合对象[TopicedDocRelations]的实例
static DocumentTopics | DocumentTopics.createNewInstance(User _currUser) 产生当前集合对象[DocumentTopics]的实例
static TopicedDocRelations | TopicedDocRelations.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DocumentTopics | DocumentTopics.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | TopicedDocRelation.insert(User _currUser) 将对象数据写入数据库
void | DocumentTopic.insert(User _currUser) 将对象数据写入数据库
static TopicedDocRelations | TopicedDocRelations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TopicedDocRelations]
static DocumentTopics | DocumentTopics.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocumentTopics]

参数类型为 User 的 com.trs.components.comment.persistent 中的构造方法
DocumentTopics(User _currUser)
构造函数
DocumentTopics(User _currUser, int _initCapacity, int _incCapacity)
构造函数
TopicedDocRelations(User _currUser)
构造函数
TopicedDocRelations(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.common.address 中 User 的使用

参数类型为 User 的 com.trs.components.common.address 中的方法
boolean | ContactGrp.addContact(Contact _Contact, User _opUser) 添加新的非系统用户到该组 参数：_Contact：要添加的非系统用户对象；_opUser：操作者（添加该用户的用户） 返回值：若参数_Contact无效，则抛出异常； 若已存在，则返回false; 若成功，则返回true
Contact | ContactMgr.addContactFromSystemUser(User _user) 导入系统用户为联系人
static ContactGrps | ContactGrps.createNewInstance(User _currUser) 产生当前集合对象[ContactGrps]的实例
static Contacts | Contacts.createNewInstance(User _currUser) 产生一个当前集合对象[Contacts]的实例
static ContactGrps | ContactGrps.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Contacts | Contacts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | Contact.insert(User _currUser) 添加对象到数据库
void | ContactGrp.insert(User _currUser) 添加对象到数据库
static ContactGrps | ContactGrps.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContactGrps]
static Contacts | Contacts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Contacts]
boolean | ContactGrp.removeContact(Contact _Contact, User _opUser) 从非系统用户组中删除指定的非系统用户 参数：_Contact:要删除的非系统用户；_opUser:执行操作的用户

参数类型为 User 的 com.trs.components.common.address 中的构造方法
ContactGrps(User _currUser)
ContactGrps(User _currUser, int _initCapacity, int _incCapacity)
Contacts(User _currUser)
Contacts(User _currUser, int _initCapacity, int _incCapacity)

com.trs.components.common.bookmark 中 User 的使用

参数类型为 User 的 com.trs.components.common.bookmark 中的方法
static MarkShares | MarkShares.createNewInstance(User _currUser) 产生一个当前集合对象[MarkShares]的实例
static MarkKinds | MarkKinds.createNewInstance(User _currUser) 产生一个当前集合对象[MarkKinds]的实例
static BookMarks | BookMarks.createNewInstance(User _currUser) 产生一个当前集合对象[BookMarks]的实例
static MarkShares | MarkShares.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static MarkKinds | MarkKinds.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static BookMarks | BookMarks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
BookMarks | MarkKind.getBookMarks(User _currUser) 取所有该类别的书签集合
MarkShares | MarkKind.getMarkShares(User _currUser) 得到MarkShares
MarkShares | BookMark.getMarkShares(User _currUser) 得到MarkShares
CMSObj | MarkShare.getObject(User _currUser) 取共享的对象（ BookMark / MarkKind ）
BookMarks | BookMarkMgr.getSharedBookMarks(User _aUser, WCMFilter _filter) 获取共享给当前登录用户的书签
MarkKinds | BookMarkMgr.getSharedMarkKinds(User _aUser, WCMFilter _filter) 获取共享给当前登录用户的书签分类
CMSObj | MarkShare.getViewer(User _currUser) 取得Viewer对象(User,Group,Role,Contact,ContactGrp)
void | MarkKind.insert(User _currUser) 添加对象到数据库
void | BookMark.insert(User _currUser) 添加对象到数据库
void | MarkShare.insert(User _currUser) 添加对象到数据库
boolean | MarkKind.isShared(User _currUser) 是否被共享
boolean | BookMark.isShared(User _currUser) 是否被共享
static MarkShares | MarkShares.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MarkShares]
static MarkKinds | MarkKinds.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MarkKinds]
static BookMarks | BookMarks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[BookMarks]

参数类型为 User 的 com.trs.components.common.bookmark 中的构造方法
BookMarks(User _currUser)
BookMarks(User _currUser, int _initCapacity, int _incCapacity)
MarkKinds(User _currUser)
MarkKinds(User _currUser, int _initCapacity, int _incCapacity)
MarkShares(User _currUser)
MarkShares(User _currUser, int _initCapacity, int _incCapacity)

com.trs.components.common.calendar 中 User 的使用

返回 User 的 com.trs.components.common.calendar 中的方法
 User Event.getOwner()

参数类型为 User 的 com.trs.components.common.calendar 中的方法
static Events | Events.createNewInstance(User _currUser) 产生一个当前集合对象[Events]的实例
static EventShares | EventShares.creatNewInstance(User _currUser) 产生一个当前集合对象[EventShares]的实例
static Events | Events.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static EventShares | EventShares.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Events | EventMgr.getEvents(User _currUser, CMyDateTime _date, boolean _bIncludingShared, WCMFilter _filter)
void | Event.insert(User _currUser) 添加对象到数据库
void | EventShare.insert(User _currUser) 将对象数据写入数据库
void | EventType.insert(User _currUser)
static Events | Events.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Events]
static EventShares | EventShares.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[EventShares]
boolean | Event.setOwner(User _owner)
void | Event.update(User _user) 重载父类接口，以处理提醒Job

参数类型为 User 的 com.trs.components.common.calendar 中的构造方法
Events(User _currUser)
Events(User _currUser, int _initCapacity, int _incCapacity)
EventShares(User _currUser)
构造函数
EventShares(User _currUser, int _initCapacity, int _incCapacity)
构造函数
EventTypes(User _currUser)
EventTypes(User _currUser, int initialCapacity, int capacityIncrement)

com.trs.components.common.conjection.persistent 中 User 的使用

参数类型为 User 的 com.trs.components.common.conjection.persistent 中的方法
static EntryConfigs | EntryConfigs.createNewInstance(User _currUser) 产生当前集合对象[EntryConfigs]的实例
static EntryConfigs | EntryConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | EntryConfig.insert(User _currUser) 将对象数据写入数据库
static EntryConfigs | EntryConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[EntryConfigs]

参数类型为 User 的 com.trs.components.common.conjection.persistent 中的构造方法
EntryConfigs(User _currUser)
构造函数
EntryConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.common.job 中 User 的使用

参数类型为 User 的 com.trs.components.common.job 中的方法
static Schedules | Schedules.createNewInstance(User _currUser) 产生当前集合对象[Schedules]的实例
static JobWorkerTypes | JobWorkerTypes.createNewInstance(User _currUser) 产生当前集合对象[JobWorkers]的实例
static Schedules | Schedules.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static JobWorkerTypes | JobWorkerTypes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Schedules | Schedules.findUnfinishedSchedules(User _currUser, CMyDateTime _dtTime)
void | Schedule.insert(User _currUser) 将对象数据写入数据库
boolean | Schedule.logicalDelete(User _currUser)
boolean | Schedule.logicalUndelete(User _currUser)
static Schedules | Schedules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Schedules]
static JobWorkerTypes | JobWorkerTypes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[JobWorkers]

参数类型为 User 的 com.trs.components.common.job 中的构造方法
JobWorkerTypes(User _currUser)
JobWorkerTypes(User _currUser, int _initCapacity, int _incCapacity)
Schedules(User _currUser)
Schedules(User _currUser, int initialCapacity, int capacityIncrement)

com.trs.components.common.message 中 User 的使用

返回 User 的 com.trs.components.common.message 中的方法
 User IMessageService.getLoginUser()
获得当前登录用户

参数类型为 User 的 com.trs.components.common.message 中的方法
static Messages | Messages.createNewInstance(User _currUser) 产生一个当前集合对象[Messages]的实例
static MsgQueues | MsgQueues.createNewInstance(User _currUser) 产生一个当前集合对象[MsgQueues]的实例
int | Message.delete(User _currUser) 删除对象 重载父类接口：同时删除相关数据
static void | MessageServer.delete(User _currUser, java.lang.String _sDelMsgIds) 删除消息集合 删除消息时，如果用户为发件人，则在Message表中做逻辑删除的标志 如果用户为收件人，则从关联关系表中删除该记录 如果用户既是发件人，又是收件人，则两个操作都做 删除时，如果关联表中已没有和Message关联的记录，Message中也时逻辑删除，则从Message中彻底删除该消息。
static void | MessageServer.emptyInbox(User _currUser) 清空用户的收件箱 将用户接收到的消息都删除掉 参照delete的逻辑
static void | MessageServer.emptyOutbox(User _currUser) 清空用户的已发消息 将用户接发送的消息都删除掉 参照delete的逻辑
static Message | MessageServer.findById(User _currUser, int _nMsgId)
static Messages | Messages.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static MsgQueues | MsgQueues.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Messages | MessageServer.findByIds(User _currUser, java.lang.String _sMsgIds)
Message | MsgQueue.getMessage(User _currUser) 取得Message对象
static Messages | MessageServer.getMessages(int _nReadFlag, User _loginUser, WCMFilter _aFilter) 根据指定的类型(未读/已收/已发)获取消息集合
MsgQueues | Message.getMsgQueues(User _currUser) 得到消息队列
static Messages | MessageServer.getReceivedMsgs(User _currUser, WCMFilter _currFiilter) 获得某用户的所有接收到的消息 接收的判断是所有用户为接收者的消息
static Messages | MessageServer.getSentMsgs(User _currUser, WCMFilter _currFiilter) 获得某用户的所有已发消息 已发的判断是从Message表中查询得到
static Messages | MessageServer.getUnreadMessages(User _currUser, WCMFilter _filter) 获得用户所有未读的消息 未读的定义即_currMsgUser为接收者，且消息的已读属性为false
static boolean | MessageServer.hasUnreadMessage(User _currUser) 判断用户是否有没有阅读的消息
static boolean | MessageServer.hasUnreadMessage(User _currUser, int[] _pMsgType) 判断用户是否有没有阅读指定类型的消息
void | MsgQueue.insert(User _currUser)
void | Message.insert(User _currUser) 添加对象到数据库
static boolean | MessageServer.isMessageReaded(Message _currMessage, User _currUser) 获得用户所接收消息的状态 状态包括已读和未读，通过状态标志来返回
boolean | Message.isQueue(User _currUser) 判断消息是否在队列中
static Messages | Messages.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Messages]
static MsgQueues | MsgQueues.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MsgQueues]
void | MsgSendWorker.send(Message _currMessage, User _currReceiver)
void | EmailSendWorker.send(Message _currMessage, User _currReceiver)
void | SMSSendWorker.send(Message _currMessage, User _currReceiver)
void | ISendWorker.send(Message _currMessage, User _currReceiver) 发送消息
static void | MessageServer.setMessageReaded(Message _currMessage, User _currUser, boolean _bMessageReaded) 设置接收到的消息的已读状态

参数类型为 User 的 com.trs.components.common.message 中的构造方法
Messages(User _currUser)
Messages(User _currUser, int _initCapacity, int _incCapacity)
MsgQueues(User _currUser)
MsgQueues(User _currUser, int _initCapacity, int _incCapacity)

com.trs.components.common.publish.domain.auth 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.domain.auth 中的方法
 boolean TemplateRightObjImpl.hasRight(User _currUser, int _nRightIndex)

com.trs.components.common.publish.domain.template 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.domain.template 中的方法
 void TemplateEmployMgr.setOtherOutlines(User loginUser, IPublishFolder _folder, java.lang.String _sTemplateIds)

com.trs.components.common.publish.persistent.distribute 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.persistent.distribute 中的方法
static PublishDistributions | PublishDistributions.createNewInstance(User _currUser) 产生当前集合对象[PublishDistributions]的实例
static PublishDistributions | PublishDistributions.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | PublishDistribution.insert(User _currUser) 将对象数据写入数据库
static PublishDistributions | PublishDistributions.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PublishDistributions]

参数类型为 User 的 com.trs.components.common.publish.persistent.distribute 中的构造方法
PublishDistributions(User _currUser)
构造函数
PublishDistributions(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.common.publish.persistent.element 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.persistent.element 中的方法
boolean | PublishElementWrapper.isCanDoSave(User _loginUser)
boolean | IPublishElement.isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | PublishContentDefaultObjImpl.isCanDoSave(User _loginUser)

com.trs.components.common.publish.persistent.publisher 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.persistent.publisher 中的方法
static FolderPublishConfigs | FolderPublishConfigs.createNewInstance(User _currUser) 产生当前集合对象[FolderPublishConfigs]的实例
int | FolderPublishConfig.delete(User _currUser)
static FolderPublishConfigs | FolderPublishConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | FolderPublishConfig.insert(User _currUser) 将对象数据写入数据库
static FolderPublishConfigs | FolderPublishConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FolderPublishConfigs]

参数类型为 User 的 com.trs.components.common.publish.persistent.publisher 中的构造方法
FolderPublishConfigs(User _currUser)
构造函数
FolderPublishConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.common.publish.persistent.taskdispatch 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
PublishErrorLog | PublishTask.addErrorLog(User _currUser, IPublishElement _publishElement, java.lang.String _sDesc, int _nResult, java.lang.String _sErrorDetail) add error log for a folder publish page task
PublishTask | PublishTask.duplicate(User _currUser, boolean _bInsert2DB) copy from this publish task and create a new one.
static PublishTasks | PublishTasks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
PublishErrorLogs | PublishTask.getErrorLogs(User _currUser, WCMFilter _filter) get the error logs of this task
void | PublishTask.insert(User _currUser) 将对象数据写入数据库
void | PublishErrorLog.insert(User _currUser) 将对象数据写入数据库

参数类型为 User 的 com.trs.components.common.publish.persistent.taskdispatch 中的构造方法
PublishErrorLogs(User _currUser)
构造函数
PublishErrorLogs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
PublishTasks(User _currUser)
构造函数
PublishTasks(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.common.publish.persistent.template 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.persistent.template 中的方法
TempAppendix | Template.addAppendix(User _currUser, java.lang.String _sFile, boolean _bAddRelation) 添加一个模板附件
static Templates | Templates.createNewInstance(User _currUser) 产生当前集合对象[Templates]的实例
static TemplateQuotes | TemplateQuotes.createNewInstance(User _currUser) 产生当前集合对象[TemplateQuotes]的实例
static TemplateEmploys | TemplateEmploys.createNewInstance(User _currUser) 产生当前集合对象[TemplateEmploys]的实例
static TemplateArguments | TemplateArguments.createNewInstance(User _currUser) TemplateArguments的对象实例
static TempAppendixes | TempAppendixes.createNewInstance(User _currUser) 产生一个当前集合对象[TempAppendixes]的实例
static TempApdRels | TempApdRels.createNewInstance(User _currUser) 产生一个当前集合对象[TempApdRels]的实例
static Templates | Templates.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TemplateQuotes | TemplateQuotes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TemplateEmploys | TemplateEmploys.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TemplateArguments | TemplateArguments.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TempAppendixes | TempAppendixes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TempApdRels | TempApdRels.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
TempAppendixes | Template.getAppendixes(User _currUser) 取模板的附件集合
TempAppendixes | Template.getAppendixes(User _currUser, int[] arrFlags) 取模板的附件集合
void | TemplateQuote.insert(User _currUser) 将对象数据写入数据库
void | TemplateEmploy.insert(User _currUser) 将对象数据写入数据库
void | Template.insert(User _currUser) 添加模板对象到数据库
void | TempAppendix.insert(User _currUser) 添加模板附件对象到数据库
void | TagBean.insert(User _currUser) 将对象数据写入数据库
static Templates | Templates.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Templates]
static TemplateQuotes | TemplateQuotes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateQuotes]
static TemplateEmploys | TemplateEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateEmploys]
static TemplateArguments | TemplateArguments.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateEmploys]
static TempAppendixes | TempAppendixes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TempAppendixes]
static TempApdRels | TempApdRels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TempApdRels]
void | Template.save(User _currUser)

参数类型为 User 的 com.trs.components.common.publish.persistent.template 中的构造方法
TagBeans(User _currUser)
置标解析组件集合的构造函数
TagBeans(User _currUser, int initialCapacity, int capacityIncrement)
置标解析组件集合的构造函数
TempApdRels(User _currUser)
构造函数
TempApdRels(User _currUser, int _initCapacity, int _incCapacity)
构造函数
TempAppendixes(User _currUser)
指定用户和应用服务器的构造函数
TempAppendixes(User _currUser, int _initCapacity, int _incCapacity)
指定用户和应用服务器的构造函数
TemplateArguments(User _currUser)
TemplateArguments(User _currUser, int _initCapacity, int _incCapacity)
TemplateEmploys(User _currUser)
构造函数
TemplateEmploys(User _currUser, int _initCapacity, int _incCapacity)
构造函数
TemplateQuotes(User _currUser)
构造函数
TemplateQuotes(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Templates(User _currUser)
Templates(User _currUser, int initialCapacity, int capacityIncrement)

com.trs.components.common.publish.widget 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.widget 中的方法
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle)
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports)
PageStyle | IPageStyleMgr.copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle) 仿照指定的页面风格创建一份新的风格
PageStyle | PageStyleMgr.copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle) 仿照PageStyle创建一份新的风格
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
void | ISystemResourceStyleMgr.copyFor(User user, PageStyle pageStyle) 根据系统默认的资源可用风格为指定的系统风格创建
void | ISystemContentStyleMgr.copyFor(User user, PageStyle pageStyle) 根据系统默认的内容可用风格为指定的系统风格创建
void | SystemContentStyleMgr.copyFor(User _currUser, PageStyle _targetPageStyle) 根据系统默认的内容可用风格为指定的系统风格创建
void | SystemResourceStyleMgr.copyFor(User _currUser, PageStyle _targetPageStyle) 根据系统默认的资源可用风格为指定的系统风格创建
void | IStyleCenterMgr.copySystemStyle(User loginUser, PageStyle pageStyle) 在新建页面风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格
void | StyleCenterMgr.copySystemStyle(User _currUser, PageStyle _targetPageStyle) 在新建风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格
static WidgetParameters | WidgetParameters.createNewInstance(User _currUser) 产生当前集合对象[WidgetParameters]的实例
static PageStyles | PageStyles.createNewInstance(User _currUser) 产生当前集合对象[PageStyles]的实例
static ContentStyles | ContentStyles.createNewInstance(User _currUser) 产生当前集合对象[ContentStyles]的实例
static WidgetInstParameters | WidgetInstParameters.createNewInstance(User _currUser) 产生当前集合对象[WidgetInstParameters]的实例
static ResourceStyles | ResourceStyles.createNewInstance(User _currUser) 产生当前集合对象[ResourceStyles]的实例
static Widgets | Widgets.createNewInstance(User _currUser) 产生当前集合对象[Widgets]的实例
static Masters | Masters.createNewInstance(User _currUser) 产生当前集合对象[Masters]的实例
static StyleAndResources | StyleAndResources.createNewInstance(User _currUser) 产生当前集合对象[StyleAndResources]的实例
static Layouts | Layouts.createNewInstance(User _currUser) 产生当前集合对象[Layouts]的实例
static StyleItems | StyleItems.createNewInstance(User _currUser) 产生当前集合对象[StyleItems]的实例
static WidgetInstances | WidgetInstances.createNewInstance(User _currUser) 产生当前集合对象[WidgetInstances]的实例
java.lang.String | IStyleCenterMgr.createStyleFile(User _currUser, PageStyle _currPageStyle) 生成风格文件
java.lang.String | StyleCenterMgr.createStyleFile(User _currUser, PageStyle _pageStyle)
void | IStyleItemMgr.delete(User loginUser, BaseStyle currBaseStyle) 删除指定风格对应的风格项（StyleItem）
void | StyleItemMgr.delete(User user, BaseStyle _baseStyle) 删除风格对应的风格项
void | IContentStyleMgr.delete(User _currUser, ContentStyle _contentStyle) 删除ContentStyle
void | ContentStyleMgr.delete(User _currUser, ContentStyle _contentStyle)
boolean | LayoutMgr.delete(User _oCurrUser, Layout _currLayout) 删除指定的布局
boolean | ILayoutMgr.delete(User _oCurrUser, Layouts _currLayouts) 删除布局
boolean | LayoutMgr.delete(User _oCurrUser, Layouts _oLayouts) 删除布局的集合
boolean | MasterMgr.delete(User _oCurrUser, Masters _oMasters) 删除母板
boolean | IMasterMgr.delete(User _oCurrUser, Masters _oMasters) 删除指定的母版
void | IPageStyleMgr.delete(User _currUser, PageStyle _pageStyle) 删除指定的页面风格
void | PageStyleMgr.delete(User _currUser, PageStyle pageStyle) 删除PageStyle
void | IResourceStyleMgr.delete(User _currUser, ResourceStyle _resourceStyle) 删除ResourceStyle
void | ResourceStyleMgr.delete(User _currUser, ResourceStyle _resourceStyle)
void | StyleAndResourceMgr.delete(User user, StyleAndResource _styleAndResource)
void | IStyleAndResourceMgr.delete(User _currUser, StyleAndResource _styleAndResource) 删除风格与资源的关联关系
void | IStyleItemMgr.delete(User _currUser, StyleItem _styleItem) 删除StyleItem
void | StyleItemMgr.delete(User _currUser, StyleItem styleItem)
boolean | IWidgetMgr.delete(User _oCurrUser, Widget _oCurrWidget) 删除资源
boolean | WidgetMgr.delete(User _oCurrUser, Widget _oCurrWidget)
boolean | IWidgetParameterMgr.delete(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 删除资源变量
boolean | WidgetParameterMgr.delete(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)
void | IPageStyleMgr.deletePageStyleInfos(User user, PageStyle pageStyle) 删除指定的页面风格的关联信息
void | PageStyleMgr.deletePageStyleInfos(User _currUser, PageStyle pageStyle) 删除页面风格的关联信息
static ContentStyle | ContentStyles.findByCssFlagAndPageStyle(User _currUser, java.lang.String _sCssFlag, int _nPageStyleId) 根据指定的风格标识和页面风格来获取内容风格
static ResourceStyle | ResourceStyles.findByCssFlagAndPageStyle(User _currUser, java.lang.String _sCssFlag, int _nPageStyleId) 根据指定的风格标识和页面风格来获取资源风格
static WidgetParameters | WidgetParameters.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static PageStyles | PageStyles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentStyles | ContentStyles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WidgetInstParameters | WidgetInstParameters.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ResourceStyles | ResourceStyles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Widgets | Widgets.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Masters | Masters.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static StyleAndResources | StyleAndResources.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Layouts | Layouts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static StyleItems | StyleItems.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WidgetInstances | WidgetInstances.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentStyle | ContentStyles.findByStyleNameAndPageStyle(User _currUser, java.lang.String _sStyleName, int _nPageStyleId) 根据指定的风格名称和页面风格来获取内容风格
Layout | ILayoutMgr.findLayoutByName(User _currUser, java.lang.String _sLayoutName) 根据传入的布局名称，返回找到的第一个布局对象，如果没有找到合适的布局对象，则返回null。
Layout | LayoutMgr.findLayoutByName(User _currUser, java.lang.String sLayoutName)
Widget | IWidgetMgr.findWidgetByName(User _oCurrUser, java.lang.String _sWidgetName) 根据传入的资源块名称，返回找到的第一个资源块对象，如果没有找到合适的资源块对象，则返回null。
Widget | WidgetMgr.findWidgetByName(User _oCurrUser, java.lang.String sWidgetName)
Reports | MasterMgr.importMasters(User _oCurrUser, java.lang.String _sImportMastersFileName) 导入母板
Reports | IMasterMgr.importMasters(User _oCurrUser, java.lang.String _sImportMastersFileName) 导入母版
void | WidgetInstance.insert(User _currUser) 将对象数据写入数据库
void | PageStyle.insert(User _currUser) 将对象数据写入数据库
void | WidgetInstParameter.insert(User _currUser) 将对象数据写入数据库
void | Master.insert(User _currUser) 将对象数据写入数据库
void | ContentStyle.insert(User _currUser) 将对象数据写入数据库
void | Widget.insert(User _currUser) 将对象数据写入数据库
void | StyleAndResource.insert(User _currUser) 将对象数据写入数据库
void | WidgetParameter.insert(User _currUser) 将对象数据写入数据库
void | Layout.insert(User _currUser) 将对象数据写入数据库
void | ResourceStyle.insert(User _currUser) 将对象数据写入数据库
void | StyleItem.insert(User _currUser) 将对象数据写入数据库
static WidgetParameters | WidgetParameters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetParameters]
static PageStyles | PageStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PageStyles]
static ContentStyles | ContentStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentStyles]
static WidgetInstParameters | WidgetInstParameters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetInstParameters]
static ResourceStyles | ResourceStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ResourceStyles]
static Widgets | Widgets.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Widgets]
static Masters | Masters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Masters]
static StyleAndResources | StyleAndResources.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StyleAndResources]
static Layouts | Layouts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Layouts]
static StyleItems | StyleItems.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StyleItems]
static WidgetInstances | WidgetInstances.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetInstances]
Widgets | IWidgetMgr.query(User _oCurrUser, WCMFilter _oFilter) 获取资源
WidgetParameters | IWidgetParameterMgr.query(User _oCurrUser, WCMFilter _oFilter) 获取某资源所具有的资源变量
Widgets | WidgetMgr.query(User _oCurrUser, WCMFilter _oFilter)
Masters | MasterMgr.query(User _oCurrUser, WCMFilter _oFilter) 查询系统指定的母板
Layouts | ILayoutMgr.query(User _currUser, WCMFilter _currFilter) 查询布局
WidgetParameters | WidgetParameterMgr.query(User _oCurrUser, WCMFilter _oFilter)
Layouts | LayoutMgr.query(User _currUser, WCMFilter _filter) 通过条件查询布局
Masters | IMasterMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询系统指定母版
StyleItem | IStyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem) 保存（新增、编辑）StyleItem
StyleItem | StyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem)
ContentStyle | IContentStyleMgr.save(User _currUser, ContentStyle _contentStyle) 保存（新增、编辑）ContentStyle
ContentStyle | ContentStyleMgr.save(User _currUser, ContentStyle _contentStyle)
Layout | ILayoutMgr.save(User _oCurrUser, Layout _currLayout) 新建或者保存布局
Layout | LayoutMgr.save(User _oCurrUser, Layout _currLayout) 保存当前布局，若ID为0则为创建布局,将样式文件写到文件上，不保存到HTML代码中
Master | MasterMgr.save(User _oUser, Master _oMaster) 保存当前母板
Master | IMasterMgr.save(User _oCurrUser, Master _oCurrMaster)
PageStyle | IPageStyleMgr.save(User _currUser, PageStyle _pageStyle) 保存（新增、编辑）页面风格
PageStyle | PageStyleMgr.save(User user, PageStyle pageStyle) 只保存风格的基本属性，不负责保存关联对象
ResourceStyle | IResourceStyleMgr.save(User _currUser, ResourceStyle _resourceStyle) 保存（新增、编辑）资源风格
ResourceStyle | ResourceStyleMgr.save(User _currUser, ResourceStyle _resourceStyle) 保存（新增、编辑）ResourceStyle
Master | MasterMgr.save(User _oUser, java.lang.String _sMasterName, java.lang.String _sFileName) 保存当前母板
Master | IMasterMgr.save(User _oCurrUser, java.lang.String _sMasterName, java.lang.String _sFileName) 保存当前母版
StyleAndResource | StyleAndResourceMgr.save(User user, StyleAndResource _styleAndResource)
StyleAndResource | IStyleAndResourceMgr.save(User _currUser, StyleAndResource _styleAndResource) 保存修改StyleAndResource
WidgetInstance | WidgetInstanceMgr.save(User _loginUser, WidgetInstance _WidgetInstance)
WidgetInstance | IWidgetInstanceMgr.save(User loginUser, WidgetInstance oWidgetInstance) 对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象
StyleItem | IStyleItemMgr.savePageOtherStyleItem(User loginUser, PageStyle pageStyle, StyleItem styleItem) 保存页面风格对应的其他风格属性
StyleItem | StyleItemMgr.savePageOtherStyleItem(User _currUser, PageStyle pageStyle, StyleItem _styleItem) 保存页面风格对应的其他风格属性
Widget | IWidgetMgr.saveWidget(User _oCurrUser, Widget _oCurrWidget) 保存资源
Widget | WidgetMgr.saveWidget(User _oCurrUser, Widget _oCurrWidget)
WidgetParameter | IWidgetParameterMgr.saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 保存资源变量
WidgetParameter | WidgetParameterMgr.saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)

参数类型为 User 的 com.trs.components.common.publish.widget 中的构造方法
ContentStyles(User _currUser)
构造函数
ContentStyles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Layouts(User _currUser)
构造函数
Layouts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Masters(User _currUser)
构造函数
Masters(User _currUser, int _initCapacity, int _incCapacity)
构造函数
PageStyles(User _currUser)
构造函数
PageStyles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ResourceStyles(User _currUser)
构造函数
ResourceStyles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
StyleAndResources(User _currUser)
构造函数
StyleAndResources(User _currUser, int _initCapacity, int _incCapacity)
构造函数
StyleItems(User _currUser)
构造函数
StyleItems(User _currUser, int _initCapacity, int _incCapacity)
构造函数
WidgetInstances(User _currUser)
构造函数
WidgetInstances(User _currUser, int _initCapacity, int _incCapacity)
构造函数
WidgetInstParameters(User _currUser)
构造函数
WidgetInstParameters(User _currUser, int _initCapacity, int _incCapacity)
构造函数
WidgetParameters(User _currUser)
构造函数
WidgetParameters(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Widgets(User _currUser)
构造函数
Widgets(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.common.publish.widget.tagparser 中 User 的使用

参数类型为 User 的 com.trs.components.common.publish.widget.tagparser 中的方法
 RightValue WCMTagParserBaseOperation.getChannelRightValue(User _currUser, BaseChannel _oBaseChannel)
获取栏目的权限

com.trs.components.common.trsad 中 User 的使用

参数类型为 User 的 com.trs.components.common.trsad 中的方法
void | ADPos.ChnlInit(Channel _chnl, User _user) 初始化栏目
void | ADPos.ChnlInit(WebSite _website, User _user) 初始化站点
int | ADPos.delete(User _currUser) 重载父类方法删除属于广告位的所有广告记录
int | ADFile.delete(User _currUser)
int | ADCom.delete(User _currUser) 删除公司同时删除该公司的所有广告
void | ADType.insert(User _currUser) 将对象数据写入数据库
void | ADPos.insert(User _currUser) 将对象数据写入数据库
void | ADFilePos.insert(User _currUser) 将对象数据写入数据库
void | ADFile.insert(User _currUser) 将对象数据写入数据库
void | ADCom.insert(User _currUser) 将对象数据写入数据库

参数类型为 User 的 com.trs.components.common.trsad 中的构造方法
ADComs(User _currUser)
构造函数
ADComs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ADFilePoss(User _currUser)
构造函数
ADFilePoss(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ADFiles(User _currUser)
构造函数
ADFiles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ADPoss(User _currUser)
构造函数
ADPoss(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ADTypes(User _currUser)
构造函数
ADTypes(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.common.trsvote 中 User 的使用

参数类型为 User 的 com.trs.components.common.trsvote 中的方法
VoteIPLogs | Vote.getIPLogs(User _currUser) 取得调查IP记录
Vote | VoteItem.getVote(User _currUser) 取得所属调查
VoteDatas | VoteOption.getVoteDatas(User _currUser) 取得调查选项的投票结果
VoteItem | VoteOption.getVoteItem(User _currUser) 取得调查选项所属的调查事项
VoteItems | Vote.getVoteItems(User _currUser) 取得调查事项
VoteOption | VoteData.getVoteOption(User _currUser) 取得调查数据所属的调查选项
VoteOptions | VoteItem.getVoteOptions(User _currUser) 取得调查选项

参数类型为 User 的 com.trs.components.common.trsvote 中的构造方法
VoteDatas(User _currUser)
构造函数
VoteDatas(User _currUser, int _initCapacity, int _incCapacity)
构造函数
VoteIPLogs(User _currUser)
构造函数
VoteIPLogs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
VoteItems(User _currUser)
构造函数
VoteItems(User _currUser, int _initCapacity, int _incCapacity)
构造函数
VoteOptions(User _currUser)
构造函数
VoteOptions(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Votes(User _currUser)
构造函数
Votes(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.gkml.sqgk.persistent 中 User 的使用

参数类型为 User 的 com.trs.components.gkml.sqgk.persistent 中的方法
static MailConfigs | MailConfigs.createNewInstance(User _currUser) 产生当前集合对象[MailConfigs]的实例
static ApplyForms | ApplyForms.createNewInstance(User _currUser) 产生当前集合对象[ApplyForms]的实例
static ApplyFormDealLogs | ApplyFormDealLogs.createNewInstance(User _currUser) 产生当前集合对象[ApplyFormDealLogs]的实例
static MailConfigs | MailConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ApplyForms | ApplyForms.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ApplyFormDealLogs | ApplyFormDealLogs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | MailConfig.insert(User _currUser) 将对象数据写入数据库
void | ApplyFormDealLog.insert(User _currUser) 将对象数据写入数据库
void | ApplyForm.insert(User _currUser) 将对象数据写入数据库
static MailConfigs | MailConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MailConfigs]
static ApplyForms | ApplyForms.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ApplyForms]
static ApplyFormDealLogs | ApplyFormDealLogs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ApplyFormDealLogs]

参数类型为 User 的 com.trs.components.gkml.sqgk.persistent 中的构造方法
ApplyFormDealLogs(User _currUser)
构造函数
ApplyFormDealLogs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ApplyForms(User _currUser)
构造函数
ApplyForms(User _currUser, int _initCapacity, int _incCapacity)
构造函数
MailConfigs(User _currUser)
构造函数
MailConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.gkml.sqgk.process.element 中 User 的使用

返回 User 的 com.trs.components.gkml.sqgk.process.element 中的方法
 User FlowContentApplyFormImpl.getCrUser()

参数类型为 User 的 com.trs.components.gkml.sqgk.process.element 中的方法
void | FlowContentApplyFormImpl.cancelUpdate(User user)
boolean | FlowContentApplyFormImpl.canEdit(User _currUser)
void | FlowContentApplyFormImpl.updateStatus(User user, int statusId)

com.trs.components.govinfo 中 User 的使用

参数类型为 User 的 com.trs.components.govinfo 中的方法
static MetaView | GovInfoViewFinder.findMetaViewOfChildGovInfo(User _loginUser)
static MetaView | GovInfoViewFinder.findMetaViewOfGovInfo(User _loginUser)

com.trs.components.infoview 中 User 的使用

参数类型为 User 的 com.trs.components.infoview 中的方法
boolean | RightHostInfoViewField.canDoSetRight(User _user)
boolean | RightHostInfoViewGroup.canDoSetRight(User _user)
boolean | RightHostInfoViewView.canDoSetRight(User _user)
void | RightHostInfoViewField.validateCanDoSetRight(User _user)
void | RightHostInfoViewGroup.validateCanDoSetRight(User _user)
void | RightHostInfoViewView.validateCanDoSetRight(User _user)

参数类型为 User 的 com.trs.components.infoview 中的构造方法
InfoviewDataProcessor(User _currUser, java.lang.String _sAppendixFilePath)

com.trs.components.infoview.db 中 User 的使用

参数类型为 User 的 com.trs.components.infoview.db 中的方法
void | InfoViewDBMgr.appendDefaultFields(User _currUser, int _nInfoViewId)
void | InfoViewDBMgr.createDBField(User user, InfoView _view, InfoViewField _viewField)
void | IInfoViewDBMgr.createDBField(User _currUser, InfoView _infoView, InfoViewField _infoViewField) 给当前表单的指定字段在数据库中创建对应物理字段
void | InfoViewDBMgr.createDBTable(User _currUser, int _nInfoViewId)
void | IInfoViewDBMgr.createDBTable(User _currUser, int _nInfoViewId) 新增或者修改系统表
void | InfoViewDBMgr.deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField)
void | IInfoViewDBMgr.deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField) 删除指定字段
void | InfoViewDBMgr.deleteDBTable(User _currUser, int _nInfoViewId)
void | IInfoViewDBMgr.deleteDBTable(User _currUser, int _nInfoViewId) 删除指定表

com.trs.components.infoview.helper 中 User 的使用

参数类型为 User 的 com.trs.components.infoview.helper 中的方法
static ComplexFieldDatas | ComplexFieldDatas.createNewInstance(User _currUser) 产生当前集合对象[ComplexFieldDatas]的实例
static ComplexFieldDatas | ComplexFieldDatas.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static java.lang.String | InfoViewTemplateHelper.generateContent(MethodContext _oContext, User _currUser)
void | ComplexFieldData.insert(User _currUser) 将对象数据写入数据库
static ComplexFieldDatas | ComplexFieldDatas.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ComplexFieldDatas]

参数类型为 User 的 com.trs.components.infoview.helper 中的构造方法
ComplexFieldDatas(User _currUser)
构造函数
ComplexFieldDatas(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.infoview.persistent 中 User 的使用

参数类型为 User 的 com.trs.components.infoview.persistent 中的方法
static InfoViewDocuments | InfoViewDocuments.createNewInstance(User _currUser) 产生一个当前集合对象[ChnlDocs]的实例
static InfoViewDatas | InfoViewDatas.findByDocIds(User _currUser, int _nInfoViewId, java.lang.String _sDocumentIds)
static InfoViewDatas | InfoViewDatas.findByIds(User _currUser, int _nInfoViewId, java.lang.String _sInfoViewDataIds)
static InfoViewEmploys | InfoViewEmploys.findByIds(User _currUser, java.lang.String _sIds)
static InfoViews | InfoViews.findByIds(User _currUser, java.lang.String _sIds) TODO Add javadoc for field findByIds
static InfoViewFields | InfoViewFields.findByIds(User _currUser, java.lang.String _sIds)

参数类型为 User 的 com.trs.components.infoview.persistent 中的构造方法
InfoViewDatas(User _currUser, int _initCapacity, int _incCapacity)
InfoViewDocuments(User _currUser)
构造函数
InfoViewDocuments(User _currUser, int _initCapacity, int _incCapacity)
构造函数
InfoViewEmploys(User _currUser)
TODO Add javadoc for InfoViewEmploys
InfoViewEmploys(User _currUser, int _initCapacity, int _incCapacity)
TODO Add javadoc for InfoViewEmploys
InfoViewFields(User _currUser)
InfoViewFields(User _currUser, int _initCapacity, int _incCapacity)
InfoViewGroups(User _currUser)
InfoViewGroups(User _currUser, int _initCapacity, int _incCapacity)
InfoViews(User _currUser)
TODO Add javadoc for InfoViews
InfoViews(User _currUser, int _initCapacity, int _incCapacity)
TODO Add javadoc for InfoViews
InfoViewViews(User _currUser)
InfoViewViews(User _currUser, int _initCapacity, int _incCapacity)

com.trs.components.metadata.center 中 User 的使用

参数类型为 User 的 com.trs.components.metadata.center 中的方法
void | MetaViewEmployerMgr.clearEmployer(User _currUser, Channel _channel)
void | IMetaViewEmployerMgr.clearEmployer(User _currUser, Channel _channel) 清除指定栏目所配置的视图关系
void | MetaViewEmployerMgr.clearEmployer(User _currUser, MetaView _view)
void | IMetaViewEmployerMgr.clearEmployer(User _currUser, MetaView _view) 清除指定视图所配置的使用关系
void | IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos destClassInfos, User currUser)
static ClassInfoViews | ClassInfoViews.createNewInstance(User _currUser) 产生当前集合对象[ClassInfoViews]的实例
int | MetaViewData.delete(User _currUser)
void | IClassInfoViewMgr.delete(User user, ClassInfo _oClassInfo) 删除_oClassInfo下的文档关联
void | ClassInfoViewMgr.delete(User user, ClassInfo _oClassInfo)
void | IClassInfoViewMgr.delete(User _currUser, MetaViewData oMetaViewData) 删除ClassInfoView中满足MetaDataID的记录
void | ClassInfoViewMgr.delete(User _currUser, MetaViewData oMetaViewData) 删除ClassInfoView中满足MetaDataID的记录
int | MetaViewData.deleteViewDataAndDoc(User _currUser)
static ClassInfoViews | ClassInfoViews.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static MetaViews | MetaViewHelper.findViews(User _currUser)
RightValue | MetaViewData.getRightValue(User _currUser) 获取当前ViewDocument的RightValue
boolean | MetaViewData.hasRight(User _loginUser, int _nRightIndex) 判断当前用户对于ViewDocument是否具有指定的权限
void | ClassInfoView.insert(User _currUser) 将对象数据写入数据库
void | MetaViewData.insert(User _currUser)
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | IClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo _oSrcClassInfo, int _nDestClassInfoId) 将记录的分类法由_oSrcClassInfo转换为_nDestClassInfoId 如果_nDestClassInfoId为0，则只删除记录的_oSrcClassInfo
void | ClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo srcClassInfo, int destClassInfoId)
void | IClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo _oSrcClassInfo, java.lang.String _destClassInfoId) 将记录的分类法由_oSrcClassInfo转换为_destClassInfoId 如果_destClassInfoId为null，则只删除记录的_oSrcClassInfo
void | ClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo oClassInfo, java.lang.String _sDestClassInfoId)
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
static ClassInfoViews | ClassInfoViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ClassInfoViews]
ClassInfos | IClassInfoViewMgr.queryClassInfos(User _currUser, Documents oDocuments, WCMFilter _filter) 根据文档对象集合获取获取分类法信息集合
ClassInfos | ClassInfoViewMgr.queryClassInfos(User user, Documents documents, WCMFilter _filter)
ClassInfos | IClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
ClassInfos | ClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
int | IClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo) 根据分类法对象返回相应的文档数目
int | ClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo) 根据分类法对象返回相应的文档数目
int | IClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)
int | ClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)
Documents | IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos _oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
Documents | ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
MetaViewDatas | IClassInfoViewMgr.queryViewDatas(User user, ClassInfo _oClassInfo, MetaView _oMetaView) 获取指定视图指定分类法下的数据集合
MetaViewDatas | ClassInfoViewMgr.queryViewDatas(User user, ClassInfo classInfo, MetaView metaView)
MetaViews | IClassInfoViewMgr.queryViews(User _currUser, ClassInfos _oClassInfo, WCMFilter _filter) 根据分类法ID序列返回视图对象集合
MetaViews | ClassInfoViewMgr.queryViews(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象返回相应的视图对象集合
void | IClassInfoViewMgr.save(User _currUser, MetaViewData oMetaViewData) 保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录
void | ClassInfoViewMgr.save(User _currUser, MetaViewData _oMetaViewData) 保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录
void | MetaViewEmployerMgr.setEmployer(User _currUser, Channel _channel, MetaView _view)
void | IMetaViewEmployerMgr.setEmployer(User _currUser, Channel _channel, MetaView _view) 给指定的栏目配置指定的视图
void | MetaViewDatas.setNeedWithAuthFilter(User _loginUser, boolean _bNeedWithAuthFilter)
void | MetaViewData.update(User _user)

参数类型为 User 的 com.trs.components.metadata.center 中的构造方法
ClassInfoViews(User _currUser)
构造函数
ClassInfoViews(User _currUser, int _initCapacity, int _incCapacity)
构造函数
MetaViewDatas(User _currUser, int _initCapacity, int _incCapacity)

com.trs.components.metadata.center.xml 中 User 的使用

参数类型为 User 的 com.trs.components.metadata.center.xml 中的构造方法
MetaViewDataImporter(User _currUser, MetaView _dstView, Channel _dstChannel)

com.trs.components.metadata.definition 中 User 的使用

参数类型为 User 的 com.trs.components.metadata.definition 中的方法
void | IMetaDataDefMgr.appendDefaultFields(User _curruser, MetaDBTable _oTable) 给自定的表追加默认的字段
void | MetaDataDefMgr.appendDefaultFields(User _currUser, MetaDBTable _oTable)
static ClassInfos | ClassInfos.createNewInstance(User _currUser) 产生当前集合对象[ClassInfos]的实例
static MetaDBFields | MetaDBFields.createNewInstance(User _currUser) 产生当前集合对象[DBFieldInfos]的实例
static MetaViews | MetaViews.createNewInstance(User _currUser) 产生当前集合对象[ViewInfos]的实例
static MetaDBTables | MetaDBTables.createNewInstance(User _currUser) 产生当前集合对象[TableInfos]的实例
static MetaViewFields | MetaViewFields.createNewInstance(User _currUser) 产生当前集合对象[ViewFieldInfos]的实例
java.lang.String | IMetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView) 视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
java.lang.String | MetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView)
java.lang.String | IMetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView, boolean generateApplication) 视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
java.lang.String | MetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView, boolean generateApplication)
void | IMetaDataDefMgr.delete(User _currUser, MetaDBField _oDBFieldInfo) 删除指定字段
void | MetaDataDefMgr.delete(User _currUser, MetaDBField _oDBFieldInfo)
void | IMetaDataDefMgr.delete(User _currUser, MetaDBTable _oTableInfo) 删除指定表
void | MetaDataDefMgr.delete(User _currUser, MetaDBTable _oTableInfo) 删除元数据的操作步骤如下： 删除元数据物理字段； 删除元数据对应物理表里的数据； 删除元数据物理表； 删除元数据； 删除所有以此元数据作为主表的视图； 获取所有以此元数据作为附表的视图； 删除附表视图和此元数据的关系； 删除附表视图中此元数据的字段； 如果此视图由多表变成单表，则删除此物理视图，并修改视图的viewName 重新生成视图；
void | IMetaDataDefMgr.delete(User _currUser, MetaView _oViewInfo) 删除指定表
void | MetaDataDefMgr.delete(User _currUser, MetaView _oView)
void | IMetaDataDefMgr.delete(User _currUser, MetaViewField _oViewField) 删除指定视图字段
void | MetaDataDefMgr.delete(User _currUser, MetaViewField _oViewField)
void | ClassInfoMgr.deleteClassInfo(User _currUser, ClassInfo _classInfo)
void | IClassInfoMgr.deleteClassInfo(User _currUser, ClassInfo _classInfo) 删除指定的分类
static ClassInfos | ClassInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static MetaDBFields | MetaDBFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static MetaViews | MetaViews.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static MetaDBTables | MetaDBTables.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static MetaViewFields | MetaViewFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
ClassInfos | IMetaDataDefMgr.getClassInfosUsingMetaView(User _currUser, MetaView oMetaView) 查询视图oMetaView使用了的所有分类法集合
ClassInfos | MetaDataDefMgr.getClassInfosUsingMetaView(User _currUser, MetaView oMetaView)
MetaDBFields | IMetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter) 获取指定表的指定字段列表
MetaDBFields | MetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter)
MetaViews | IMetaDataDefMgr.getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo) 查询使用了分类法oClassInfo的所有视图集合
MetaViews | MetaDataDefMgr.getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo)
MetaDBTables | MetaView.getOtherTables(User _currUser, WCMFilter _extraFilter)
MetaViewFields | IMetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViewFields | MetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViewFields | MetaView.getViewFields(User _currUser, WCMFilter _extraFilter)
MetaViews | IMetaDataDefMgr.getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo) 获取使用了物理字段_oDBFieldInfo的所有视图
MetaViews | MetaDataDefMgr.getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo)
void | MetaView.insert(User _currUser) 将对象数据写入数据库
void | MetaDBTable.insert(User _currUser) 将对象数据写入数据库
void | MetaViewField.insert(User _currUser) 将对象数据写入数据库
void | ClassInfo.insert(User _currUser) 将对象数据写入数据库
static ClassInfos | ClassInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ClassInfos]
static MetaDBFields | MetaDBFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DBFieldInfos]
static MetaViews | MetaViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ViewInfos]
static MetaDBTables | MetaDBTables.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TableInfos]
static MetaViewFields | MetaViewFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ViewFieldInfos]
ClassInfos | ClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
ClassInfos | IClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
java.lang.String | ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列,以逗号分隔
java.lang.String | IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的所有子分类，包括子孙分类Ids
java.lang.String | ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim) 得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列
java.lang.String | IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
java.lang.String | ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, int _nClassInfoId, WCMFilter _extraFilter)
java.lang.String | IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, int _nClassInfoId, WCMFilter _extraFilter)
java.lang.String | ClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的一级子分类的Ids
java.lang.String | IClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的一级子分类的Ids
java.lang.String | ClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
java.lang.String | IClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
void | IMetaDataDefMgr.recreateAll(User _currUser, MetaDBTables _oMetaDBTables) 重新产生所有的表结构和相关视图的应用
void | MetaDataDefMgr.recreateAll(User _currUser, MetaDBTables _oMetaDBTables)
void | MetaView.save(User _currUser)
MetaDBTable | IMetaDataDefMgr.save(User _currUser, MetaDBTable _oTableInfo) 新增或者修改系统表
MetaDBTable | MetaDataDefMgr.save(User _currUser, MetaDBTable _oTableInfo)
MetaDBField | IMetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo) 在指定表上，新增或者修改指定字段信息
MetaDBField | MetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo)
MetaView | IMetaDataDefMgr.save(User _currUser, MetaView _oViewInfo) 新增或修改视图信息
MetaView | MetaDataDefMgr.save(User _currUser, MetaView _oViewInfo)
MetaViewField | IMetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo) 在指定视图上，新增或者修改指定字段信息
MetaViewField | MetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo)
void | IMetaDataDefMgr.setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields) 设置
void | MetaDataDefMgr.setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields)

参数类型为 User 的 com.trs.components.metadata.definition 中的构造方法
ClassInfos(User _currUser)
构造函数
ClassInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
MetaDBFields(User _currUser)
构造函数
MetaDBFields(User _currUser, int _initCapacity, int _incCapacity)
构造函数
MetaDBTables(User _currUser)
构造函数
MetaDBTables(User _currUser, int _initCapacity, int _incCapacity)
构造函数
MetaViewFields(User _currUser)
构造函数
MetaViewFields(User _currUser, int _initCapacity, int _incCapacity)
构造函数
MetaViews(User _currUser)
构造函数
MetaViews(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.metadata.definition.xml 中 User 的使用

参数类型为 User 的 com.trs.components.metadata.definition.xml 中的构造方法
ClassInfoImporter(User _currUser)
MetaDataDDLImporter(User _currUser)

com.trs.components.metadata.publish 中 User 的使用

参数类型为 User 的 com.trs.components.metadata.publish 中的方法
boolean | PublishFolderClassImpl.isCanDoSave(User _loginUser)
boolean | PublishContentViewFieldImpl.isCanDoSave(User _loginUser)
boolean | PublishContentViewDataImpl.isCanDoSave(User _loginUser)
boolean | PublishContentViewImpl.isCanDoSave(User _loginUser)

com.trs.components.metadata.right 中 User 的使用

参数类型为 User 的 com.trs.components.metadata.right 中的方法
static boolean | AuthServerMgr.hasRight(User _loginUser, MetaDBTable _oDBTable)
static boolean | AuthServerMgr.hasRight(User _loginUser, MetaView _view)

com.trs.components.metadata.service 中 User 的使用

参数类型为 User 的 com.trs.components.metadata.service 中的方法
java.lang.String | ClassInfoServiceProvider.createClassInfoTreeHTML(User _currUser, int _nParentId) 产生指定父节点的分类信息
java.lang.String | ClassInfoServiceProviderForGB.createClassInfoTreeHTML(User _currUser, int _nParentId) 产生指定父节点的分类信息
void | ClassInfoServiceProvider.deleteClassInfo(User _currUser, int _nClassInfoId)
void | ClassInfoServiceProviderForGB.deleteClassInfo(User _currUser, int _nClassInfoId)
void | ClassInfoServiceProvider.deleteClassInfo(User _currUser, java.lang.String _sClassInfoIds)
void | ClassInfoServiceProviderForGB.deleteClassInfo(User _currUser, java.lang.String _sClassInfoIds)
Channels | DefaultChannelMakerCenter.getAvailableChannels(User _loginUser, int _nViewId) 获取当前用户在指定视图下可用的栏目,根据视图，获取视图绑定的栏目，在过滤到没有权限的栏目
Channel | DefaultChannelMakerCenter.makeDefaultChannel(User _loginUser, int _nViewId) 构造用户在指定视图上默认存储的栏目
Channel | IDefaultChannelMaker.makeDefaultChannel(User _loginUser, int _nViewId) 构造当前用户默认的栏目
Channel | UserRelateInfoMaker.makeDefaultChannel(User _loginUser, int _nViewId)
static ClassInfo | UserRelateInfoMaker.makeDefaultClassInfo(java.lang.String _sDeptClassInfoRootName, User _currUser) 构造指定用户对应的机构分类
ClassInfos | ClassInfoServiceProvider.queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)
ClassInfos | ClassInfoServiceProviderForGB.queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)
ClassInfos | ClassInfoViewService.queryClassInfos(User _currUser, java.lang.String _sDocumentIds, WCMFilter _filter) 根据分类法信息返回视图对象集合
Documents | ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfoIds, java.lang.String _sViewId, boolean _bContainChildClassInfo) 根据分类法的id序列和viewId得到文档集合对象
Documents | ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter) 根据传入的分类法对象获取文档集合对象
Documents | ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo) 根据传入的分类法对象获取文档集合对象
MetaViews | ClassInfoViewService.queryViews(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter) 根据分类法信息返回视图对象集合
MetaViews | ClassInfoViewService.queryViews(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo) 根据分类法信息返回视图对象集合
ClassInfo | ClassInfoServiceProvider.saveClassInfo(MethodContext _methodContext, User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode) 这个方法实现不太好，但只是为了兼容wcm6，因为wcm6的实现，字段都是写死的， 不能根据外界传入什么字段，向数据库中保存什么
ClassInfo | ClassInfoServiceProviderForGB.saveClassInfo(User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc) 保存分类法设置
ClassInfo | ClassInfoServiceProvider.saveClassInfo(User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode) 保存分类法设置

参数类型为 User 的 com.trs.components.metadata.service 中的构造方法
MetaViewImporter(User _currUser, MetaView _view)

com.trs.components.special 中 User 的使用

参数类型为 User 的 com.trs.components.special 中的方法
static Specials | Specials.createNewInstance(User _currUser) 产生当前集合对象[Specials]的实例
void | SpecialMgr.delete(User _curruser, Special _special)
void | ISpecialMgr.delete(User _curruser, Special _oSpecial) 删除指定的专题
static Specials | Specials.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Special | SpecialMgr.findSpecialByChnlId(User _oUser, int _nChnlId)
Special | ISpecialMgr.findSpecialByChnlId(User _oUser, int _nChnlId) 根据栏目的Id，获取栏目对应的专题对象
void | Special.insert(User _currUser) 将对象数据写入数据库
static Specials | Specials.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Specials]
Specials | SpecialMgr.query(User _curruser, WCMFilter _filter)
Specials | ISpecialMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询符合当前条件的专题
Special | SpecialMgr.save(User _curruser, Special _special, java.lang.String _sSpecialSiteHttp)
Special | ISpecialMgr.save(User _currUser, Special _currSpecial, java.lang.String _sSpecialSiteHttp) 保存当前专题

参数类型为 User 的 com.trs.components.special 中的构造方法
Specials(User _currUser)
构造函数
Specials(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.stat 中 User 的使用

参数类型为 User 的 com.trs.components.stat 中的方法
static DocumentHitsCounts | DocumentHitsCounts.createNewInstance(User _currUser) 产生当前集合对象[DocumentHitsCounts]的实例
static HostObjDomains | HostObjDomains.createNewInstance(User _currUser) 产生当前集合对象[HostObjDomains]的实例
static ChnlDepts | ChnlDepts.createNewInstance(User _currUser) 产生当前集合对象[ChnlDepts]的实例
static HostObjHitsCounts | HostObjHitsCounts.createNewInstance(User _currUser) 产生当前集合对象[HostObjHitsCounts]的实例
static UserLoginInfos | UserLoginInfos.createNewInstance(User _currUser) 产生当前集合对象[UserLoginInfos]的实例
static BonusRules | BonusRules.createNewInstance(User _currUser) 产生当前集合对象[BonusRules]的实例
boolean | BonusRuleMgr.delete(User _oCurrUser, BonusRules _oBonusRules) 删除指定的奖励规则
boolean | IBonusRuleMgr.delete(User _oCurrUser, BonusRules _oBonusRules) 删除指定的奖励规则
static DocumentHitsCounts | DocumentHitsCounts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static HostObjDomains | HostObjDomains.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ChnlDepts | ChnlDepts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static HostObjHitsCounts | HostObjHitsCounts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static UserLoginInfos | UserLoginInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static BonusRules | BonusRules.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.String | IUserLoginInfoMgr.getCurrUser(User _oUser) 获取普通用户自己的条件构造
java.lang.String | UserLoginInfoMgr.getCurrUser(User _oUser) 获取用户自己的构造条件，返回用户名的userId
java.lang.String | IChnlDeptMgr.getDepNamesByChannel(Channel channel, User user) 根据栏目获取组织名称或者用户获取组织
java.lang.String | ChnlDeptMgr.getDepNamesByChannel(Channel _channel, User _user) 通过栏目或用户获取组织名称
java.lang.String | IUserLoginInfoMgr.getUsersForGrpAdmin(User _oUser) 获取组管理员所在组的所有用户的条件构造
java.lang.String | UserLoginInfoMgr.getUsersForGrpAdmin(User _oUser) 获取组管理员所管理组的所有用户，返回所有用戶的userId
void | BonusRule.insert(User _currUser) 将对象数据写入数据库
void | HostObjHitsCount.insert(User _currUser) 将对象数据写入数据库
void | HostObjDomain.insert(User _currUser) 将对象数据写入数据库
void | UserLoginInfo.insert(User _currUser) 将对象数据写入数据库
void | ChnlDept.insert(User _currUser) 将对象数据写入数据库
void | DocumentHitsCount.insert(User _currUser) 将对象数据写入数据库
static DocumentHitsCounts | DocumentHitsCounts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocumentHitsCounts]
static HostObjDomains | HostObjDomains.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[HostObjDomains]
static ChnlDepts | ChnlDepts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChnlDepts]
static HostObjHitsCounts | HostObjHitsCounts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[HostObjHitsCounts]
static UserLoginInfos | UserLoginInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[UserLoginInfos]
static BonusRules | BonusRules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[BonusRules]
UserLoginInfos | IUserLoginInfoMgr.query(User _oCurrUser, WCMFilter _filter)
BonusRules | BonusRuleMgr.query(User _oCurrUser, WCMFilter _oFilter) 查询系统指定奖励规则
BonusRules | IBonusRuleMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询系统指定奖励规则
UserLoginInfos | UserLoginInfoMgr.query(User _oCurrUser, WCMFilter _filter) 查询指定条件下的用户登录信息
BonusRule | BonusRuleMgr.save(User _oCurrUser, BonusRule _oBonusRule)
BonusRule | IBonusRuleMgr.save(User _oCurrUser, BonusRule _oBonusRule)
BonusRule | BonusRuleMgr.save(User _oCurrUser, int _nBonusType, java.lang.String _sRange, float _fPricePerUnit) 保存当前奖励规则
BonusRule | IBonusRuleMgr.save(User _oCurrUser, int _nBonusType, java.lang.String _sRange, float _fPricePerUnit) 保存当前奖励规则
UserLoginInfo | IUserLoginInfoMgr.save(UserLoginInfo _oUserLoginInfo, User _oCurrUser)
UserLoginInfo | UserLoginInfoMgr.save(UserLoginInfo _oUserLoginInfo, User _oCurrUser) 保存当前用户登录信息

参数类型为 User 的 com.trs.components.stat 中的构造方法
BonusRules(User _currUser)
构造函数
BonusRules(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ChnlDepts(User _currUser)
构造函数
ChnlDepts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
DocumentHitsCounts(User _currUser)
构造函数
DocumentHitsCounts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
HostObjDomains(User _currUser)
构造函数
HostObjDomains(User _currUser, int _initCapacity, int _incCapacity)
构造函数
HostObjHitsCounts(User _currUser)
构造函数
HostObjHitsCounts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
UserLoginInfos(User _currUser)
构造函数
UserLoginInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.auth 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.auth 中的方法
static boolean | ChannelAuthHelper.hasRight(User _currUser, Channel _channel, int _nRightIndex)
boolean | WebSiteRightObjImpl.hasRight(User _currUser, int _nRightIndex)
boolean | ChannelRightObjImpl.hasRight(User _currUser, int _nRightIndex)

com.trs.components.wcm.content 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.content 中的方法
RightValue | ViewDocument.getRightValue(User _currUser) 获取当前ViewDocument的RightValue
boolean | ViewDocument.hasRight(User _loginUser, int _nRightIndex) 判断当前用户对于ViewDocument是否具有指定的权限
static Documents | QueryDocumentCenter.queryDocumentsForUser(User _currUser, BaseChannel _oChannelOrSite, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize, boolean _bContainsChildren, WCMFilter _filter)
static Documents | QueryDocumentCenter.queryDocumentsForUser(User _currUser, int _nChannelId, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize)
void | ViewDocuments.setNeedWithAuthFilter(User _loginUser, boolean _bNeedWithAuthFilter)

参数类型为 User 的 com.trs.components.wcm.content 中的构造方法
ViewDocuments(User _currUser)
ViewDocuments(User _currUser, int _initCapacity, int _incCapacity)

com.trs.components.wcm.content.domain 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.content.domain 中的方法
void | SiteMemberMgr.addSiteUser(WebSite _site, User _user) 添加站点用户 将指定的用户添加到指定的站点
void | DocumentMgr.clearAll(User _currUser, BaseChannel _oSiteOrChannel) 清空回收站
static java.io.File[] | DocumentImporter.getExistedMapingFiles(User _currUser)
static java.io.File[] | DocumentImporter.getExistedXslFiles(User _currUser)
static java.lang.String | DocumentImporter.getMyDocumentImportSourceFilePath(User _currUser)
WebSites | SiteMemberMgr.getUserSites(User _currUser, WCMFilter _filter) 获取当前用户所在站点集合
boolean | SiteMemberMgr.isBelongToSite(User _user, WebSite _site) 判断指定的用户是否属于指定的站点
boolean | SiteMemberMgr.isVisible(User _user, WebSite _site)
void | SiteMemberMgr.removeSiteUser(WebSite _site, User _user) 删除站点用户 将指定的用户从指定的站点删除
void | DocumentMgr.restoreAll(User _currUser, BaseChannel _oSiteOrChannel)
void | DatasWithChnlDocFilterHelper.setNeedWithAuthFilter(User _loginUser, boolean _bNeedWithAuthFilter)

com.trs.components.wcm.content.domain.auth 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.content.domain.auth 中的方法
static java.lang.String | DocumentAuthServer.formatLogicRightValue(User _loginUser, Document _currDocument, java.lang.String _sLogicValue)
static boolean | DocumentAuthServer.hasFlowDocRight(User _currUser, Document _document, int _nRightIndex)
static boolean | DocumentAuthServer.hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Document _document, int _nRightIndex) 判断指定用户在指定频道中对于指定的文档是否具有指定的权限
static boolean | DocumentAuthServer.hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Documents _documents, int _nRightIndex)
static boolean | DocumentAuthServer.hasRight(User _loginUser, ChnlDoc _chnlDoc, int _nRightIndex)
static java.lang.String | DocumentAuthServer.makeLogicRightValue(User _loginUser, Channel _currChannel, Document _currDocument) 构造用户对于指定栏目的指定文档的权限值
void | WebSiteRightHostImpl.validateCanDoSetRight(User _user)
void | ChannelRightHostImpl.validateCanDoSetRight(User _user)
void | DocumentRightHostImpl.validateCanDoSetRight(User _user)

com.trs.components.wcm.content.persistent 中 User 的使用

返回 User 的 com.trs.components.wcm.content.persistent 中的方法
User | Document.getAuditor() 获取审稿者(可能有多个)
User | DocBak.getBakUser() 获取备份用户对象
User | Document.getEditor() 获取修改者
User | ChnlDoc.getOperUser() 获得OperUser

参数类型为 User 的 com.trs.components.wcm.content.persistent 中的方法
static DocReplys | DocReplys.createNewInstance(User _currUser) 产生一个当前集合对象[DocReplys]的实例
static Documents | Documents.createNewInstance(User _currUser) 产生当前集合对象[Documents]的实例
static ChannelContentLinks | ChannelContentLinks.createNewInstance(User _currUser) 产生当前集合对象[ChannelContentLinks]的实例
static ChannelSyns | ChannelSyns.createNewInstance(User _currUser) 产生当前集合对象[ChannelSyns]的实例
static DocBaks | DocBaks.createNewInstance(User _currUser) 产生一个当前集合对象[DocBaks]的实例
static Appendixes | Appendixes.createNewInstance(User _currUser) 产生一个当前集合对象[Appendixes]的实例
static Relations | Relations.createNewInstance(User _currUser) 产生当前集合对象[Relations]的实例
static ContentLinks | ContentLinks.createNewInstance(User _currUser) 产生当前集合对象[ContentLinks]的实例
static DocumentSyns | DocumentSyns.createNewInstance(User _currUser) 产生当前集合对象[TransmittedDocs]的实例
static Replaces | Replaces.createNewInstance(User _currUser) 产生当前集合对象[Replaces]的实例
static SiteMembers | SiteMembers.createNewInstance(User _currUser) 产生一个当前集合对象[SiteUsers]的实例
static ContentExtFields | ContentExtFields.createNewInstance(User _currUser) 产生当前集合对象[ContentExtFields]的实例
static AutoBakConfigs | AutoBakConfigs.createNewInstance(User _currUser) 产生当前集合对象[AutoBakConfigs]的实例
static WebSites | WebSites.createNewInstance(User _currUser) 产生当前集合对象[WebSites]的实例
static ChnlDocs | ChnlDocs.createNewInstance(User _currUser) 产生一个当前集合对象[ChnlDocs]的实例
static ContentLinkTypes | ContentLinkTypes.createNewInstance(User _currUser) 产生当前集合对象[ContentLinkTypes]的实例
static Channels | Channels.createNewInstance(User _currUser) 产生一个当前集合对象[Channels]的实例
int | DocBak.delete(User _currUser) 重载父类delete函数 删除该版本的备份，同时需要删除该版本在相关附件上的引用关系
int | Document.delete(User _currUser)
int | Channel.delete(User _currUser)
int | Appendix.delete(User _currUser)
static DocReplys | DocReplys.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Documents | Documents.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ChannelContentLinks | ChannelContentLinks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ChannelSyns | ChannelSyns.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DocBaks | DocBaks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Appendixes | Appendixes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Relations | Relations.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentLinks | ContentLinks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DocumentSyns | DocumentSyns.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Replaces | Replaces.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static SiteMembers | SiteMembers.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentExtFields | ContentExtFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static AutoBakConfigs | AutoBakConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WebSites | WebSites.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ChnlDocs | ChnlDocs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentLinkTypes | ContentLinkTypes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Channels | Channels.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.util.List | BaseChannel.getAllChildren(User _currUser)
Statuses | AutoBakConfig.getCanSavedDocStatus(User _currUser) 获取可以进行自动保存的文档状态
java.util.List | BaseChannel.getChildren(User _currUser)
java.util.List | BaseChannel.getChildren(User _currUser, int _nType) 获取当前对象某种类型的子频道
java.util.List | BaseChannel.getChildren(User _currUser, int[] _nArrayTypes) 获取当前对象某几种类型的子频道
int | BaseChannel.getChildrenSize(User _currUser)
int | IChildrenMgr.getChildrenSize(User _currUser, BaseChannel _parent) 获取当前站点/频道的子频道数目
int | ChildrenCacheMgr.getChildrenSize(User _currUser, BaseChannel _parent)
Statuses | WebSite.getPubStatuses(User _currUser) 取所有允许发布的文档状态对象集合
Replaces | Channel.getReplaces(User _currUser) 获取频道上所有的替换内容对象
Statuses | WebSite.getSaveStatuses(User _currUser) 获取站点上允许发布的文档状态
Statuses | ChannelSyn.getStatuses(User _currUser)
void | SiteMember.insert(User _currUser) 将对象数据写入数据库
void | DocBak.insert(User _currUser)
void | Relation.insert(User _currUser)
void | ContentExtField.insert(User _currUser) 将对象数据写入数据库
void | DocReply.insert(User _currUser) 添加记录到数据库 为了设置产生时间特重载
void | HitsCount.insert(User _currUser) 将对象数据写入数据库
void | Appendix.insert(User _currUser)
void | ContentLinkType.insert(User _currUser) 将对象数据写入数据库
void | Documents.insertOtherTable(User _currUser, java.lang.String _sTableName)
void | Document.insertOtherTable(User _currUser, java.lang.String _sTableName)
java.util.List | IChildrenMgr.listChildren(User _currUser, BaseChannel _parent, int _nType) 获取子频道列表
java.util.List | ChildrenCacheMgr.listChildren(User _currUser, BaseChannel _parent, int _nType)
java.util.List | IChildrenMgr.listChildren(User _currUser, BaseChannel _parent, int[] _arrayTypes) 获取子频道列表
java.util.List | ChildrenCacheMgr.listChildren(User _currUser, BaseChannel _parent, int[] _arrayNeedType)
boolean | Document.logicalDelete(User _currUser) 逻辑删除
boolean | Document.logicalUndelete(User _currUser) 恢复文档
static DocReplys | DocReplys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocReplys]
static Documents | Documents.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Documents]
static ChannelContentLinks | ChannelContentLinks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChannelContentLinks]
static ChannelSyns | ChannelSyns.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 17:12:53 Last Modified: 2004-12-12/2004-12-12 Description:获取频道分发设置集合
static DocBaks | DocBaks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocBaks]
static Appendixes | Appendixes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Appendixes]
static Relations | Relations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Relations]
static ContentLinks | ContentLinks.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 17:19:37 Last Modified: 2004-12-12/2004-12-12 Description: 获取内容超链接对象集合
static DocumentSyns | DocumentSyns.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TransmittedDocs]
static Replaces | Replaces.openWCMObjs(User _currUser, WCMFilter _fitler) Created: 2004-12-12 17:23:52 Last Modified: 2004-12-12/2004-12-12 Description:获取内容替换对象集合
static SiteMembers | SiteMembers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[SiteUsers]
static ContentExtFields | ContentExtFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentExtFields]
static AutoBakConfigs | AutoBakConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[AutoBakConfigs]
static WebSites | WebSites.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WebSites]
static ChnlDocs | ChnlDocs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChnlDocs]
static ContentLinkTypes | ContentLinkTypes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentLinkTypes]
static Channels | Channels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Channels]
boolean | Document.setAuditor(User _auditor) 设置审稿者(可能有多个)
boolean | DocBak.setBakUser(User _bakUser) 设置备份用户
boolean | Document.setEditor(User _editor) 设置修改者
boolean | ChnlDoc.setOperUser(User _currUser) 设置删除操作的用户
boolean | BaseChannel.setOperUser(User _opUser) 记录站点/频道删除(恢复)的操作者
void | DocBak.update(User _user)
void | Channel.update(User _currUser)
void | Document.updateHitsCount(User _currUser) 需要改变频道的名称，故重载toXMLElement接口

参数类型为 User 的 com.trs.components.wcm.content.persistent 中的构造方法
Appendixes(User _currUser)
Appendixes(User _currUser, int _initCapacity, int _incCapacity)
AutoBakConfigs(User _currUser)
AutoBakConfigs(User _currUser, int _initCapacity, int _incCapacity)
ChannelContentLinks(User user)
ChannelContentLinks(User user, int initCapacity, int capacityInc)
Channels(User _currUser)
Channels(User _currUser, int initialCapacity, int capacityIncrement)
ChannelSyns(User _currUser)
构造函数
ChannelSyns(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ChnlDocs(User _currUser)
构造函数
ChnlDocs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ContentExtFields(User _currUser)
构造函数
ContentExtFields(User _currUser, int _initCapacity, int _incCapacity)
构造函数
ContentLinks(User _currUser)
ContentLinks(User _currUser, int initialCapacity, int capacityIncrement)
ContentLinkTypes(User _currUser)
构造函数
ContentLinkTypes(User _currUser, int _initCapacity, int _incCapacity)
构造函数
DocBaks(User _currUser)
DocBaks(User _currUser, int _initCapacity, int _incCapacity)
DocReplys(User _currUser)
DocReplys(User _currUser, int _initCapacity, int _incCapacity)
Documents(User _currUser)
Documents(User _currUser, int _initCapacity, int _incCapacity)
DocumentSyns(User _currUser)
DocumentSyns(User _currUser, int _initCapacity, int _incCapacity)
HitsCounts(User _currUser)
构造函数
HitsCounts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Relations(User _currUser)
Relations(User _currUser, int _initCapacity, int _incCapacity)
Replaces(User _currUser)
Replaces(User _currUser, int _initCapacity, int _incCapacity)
SiteMembers(User _currUser)
构造函数
SiteMembers(User _currUser, int _initCapacity, int _incCapacity)
构造函数
WebSites(User _currUser)
WebSites(User _currUser, int initialCapacity, int capacityIncrement)

com.trs.components.wcm.content.trsserver 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.content.trsserver 中的方法
static TRSSearcher | TRSSearcherFactory.buildSearcher(RequestHelper _currRequestHelper, User _loginUser) 构造TRS检索条件Searcher
static TRSSearcher | TRSSearcher.getTRSSearcher(RequestHelper _currRequestHelper, User _loginUser) 从当前请求中获取TRS检索对象
Documents | DocsFromTRSServer.openDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize) 通过TRS构造一个Document集合
Documents | DocsFromTRSServer.openDocs(User _currUser, WCMFilter _filter, int _nCurrPage, int _nPageSize)
Documents | DocsFromTRSServer.openDocsByLocal(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize) 通过TRS构造一个Document集合
java.lang.Object | DocsFromTRSServer.openViewDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize)

参数类型为 User 的 com.trs.components.wcm.content.trsserver 中的构造方法
ChannelsWithRightMaker(User _user, int _nRightIndex)
TreeNode(User _loginUser, int[] _pClassInfos)
构造函数
TreeNode(User _loginUser, java.lang.String _sClassInfos)

com.trs.components.wcm.customize 中 User 的使用

返回 User 的 com.trs.components.wcm.customize 中的方法
 User UserSetting.getOwner()

参数类型为 User 的 com.trs.components.wcm.customize 中的方法
static UserSettings | UserSettings.createNewInstance(User _currUser) 产生一个当前集合对象[UserSettings]的实例
UserSetting | CustomizeMgr.find(User _currUser, int _nRegionNumber)
static UserSettings | UserSettings.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static UserSetting | UserSetting.findOf(User _currUser, int _nObjType, int _nObjId) 获取指定类型指定ID的个性化配置
static UserSettings | UserSettings.findOf(User _currUser, int _nObjType, WCMFilter _filter)
Channel | UserSetting.getObjAsChannel(User _currUser) 若定制对象为频道，则取其对应的频道对象 //why: 2002-04-02 扩展接口 说明：若不是频道对象，则返回null.
void | UserSetting.insert(User _currUser) 添加对象到数据库
static UserSettings | UserSettings.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[UserSettings]
boolean | UserSetting.setUser(User _user) 设置登录用户

参数类型为 User 的 com.trs.components.wcm.customize 中的构造方法
CustomizedChannelIdsMan(User _currUser)
UserSettings(User _currUser)
UserSettings(User _currUser, int _initCapacity, int _incCapacity)

com.trs.components.wcm.epress 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.epress 中的方法
boolean | EpressFolderWrapper.isCanDoSave(User _loginUser)
Channel | EPressChannelWrapper.save(User _user, Channel _channel)

com.trs.components.wcm.individuation 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.individuation 中的方法
static Individuations | Individuations.createNewInstance(User _currUser) 产生当前集合对象[Individuations]的实例
static CustomSiteCheckedInfos | CustomSiteCheckedInfos.createNewInstance(User _currUser) 产生当前集合对象[CustomSiteCheckedInfos]的实例
static Individuations | Individuations.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static CustomSiteCheckedInfos | CustomSiteCheckedInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static CustomSiteCheckedInfo | CustomSiteCheckedInfo.getCustomSiteCheckInfo(int individuationId, User loginUser)
static CustomSiteCheckedInfos | CustomSiteCheckedInfo.getCustomSiteCheckInfoByIndividuationId(int individuationId, User loginUser)
void | Individuation.insert(User _currUser) 将对象数据写入数据库
void | CustomSiteCheckedInfo.insert(User _currUser) 将对象数据写入数据库
static Individuations | Individuations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Individuations]
static CustomSiteCheckedInfos | CustomSiteCheckedInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[CustomSiteCheckedInfos]

参数类型为 User 的 com.trs.components.wcm.individuation 中的构造方法
CustomSiteCheckedInfos(User _currUser)
构造函数
CustomSiteCheckedInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Individuations(User _currUser)
构造函数
Individuations(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.process 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.process 中的方法
void | FlowNotifyWorkerImpl.addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, int _nNotify)
void | FlowNotifyWorkerImpl.addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)
void | FlowNotifyWorkerImpl.addMsgEvent(User _currUser, User _toUser, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)

com.trs.components.wcm.process.element 中 User 的使用

返回 User 的 com.trs.components.wcm.process.element 中的方法
 User FlowContentDocumentImpl.getCrUser()

参数类型为 User 的 com.trs.components.wcm.process.element 中的方法
void | FlowContentDocumentImpl.cancelUpdate(User user)
boolean | FlowContentDocumentImpl.canEdit(User _currUser)
void | FlowContentDocumentImpl.updateStatus(User user, int statusId)

com.trs.components.wcm.publish 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.publish 中的方法
boolean | WCMFolderPublishConfig.canEdit(User user)
static WCMPubStatusConfigs | WCMPubStatusConfigs.createNewInstance(User _currUser) 产生当前集合对象[WCMPubStatusConfigs]的实例
static WCMPubStatusConfigs | WCMPubStatusConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | WCMFolderPublishConfig.insert(User _currUser)
void | WCMPubStatusConfig.insert(User _currUser) 将对象数据写入数据库
static WCMPubStatusConfigs | WCMPubStatusConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMPubStatusConfigs]
void | WCMFolderPublishConfig.save(User _currUser)
void | WCMFolderPublishConfig.update(User _user)

参数类型为 User 的 com.trs.components.wcm.publish 中的构造方法
WCMContentPublishConfig(User _currUser, IPublishContent _content)
WCMPubStatusConfigs(User _currUser)
构造函数
WCMPubStatusConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.publish.element 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.publish.element 中的方法
boolean | PublishFolderChannelImpl.isCanDoSave(User _loginUser)
boolean | PublishContentDocumentImpl.isCanDoSave(User _loginUser)
boolean | PublishFolderWebSiteImpl.isCanDoSave(User _loginUser)

com.trs.components.wcm.publish.logo 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.publish.logo 中的方法
static Logos | Logos.createNewInstance(User _currUser) 产生当前集合对象[Logos]的实例
static Logos | Logos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Logos | Logos.findOf(User _currUser, int _nHostType, int _nHostId, WCMFilter _filter) 获取指定对象的指定Logo集合
void | Logo.insert(User _currUser) 将对象数据写入数据库
static Logos | Logos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Logos]

参数类型为 User 的 com.trs.components.wcm.publish.logo 中的构造方法
Logos(User _currUser)
构造函数
Logos(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.publish.region 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.publish.region 中的方法
static RegionInfos | RegionInfos.createNewInstance(User _currUser) 产生当前集合对象[RegionInfos]的实例
static RegionEmploys | RegionEmploys.createNewInstance(User _currUser) 产生当前集合对象[RegionEmploys]的实例
static CellInfos | CellInfos.createNewInstance(User _currUser) 产生当前集合对象[CellInfos]的实例
static RegionInfos | RegionInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static RegionEmploys | RegionEmploys.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static CellInfos | CellInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static CellInfos | CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter, User _currUser) 获取指定区域中所有的单元格，默认按照行、列排序.
void | RegionInfo.insert(User _currUser) 将对象数据写入数据库
void | RegionEmploy.insert(User _currUser) 将对象数据写入数据库
void | CellInfo.insert(User _currUser) 将对象数据写入数据库
static RegionInfos | RegionInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RegionInfos]
static RegionEmploys | RegionEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RegionEmploys]
static CellInfos | CellInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[CellInfos]

参数类型为 User 的 com.trs.components.wcm.publish.region 中的构造方法
CellInfos(User _currUser)
构造函数
CellInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
RegionEmploys(User _currUser)
构造函数
RegionEmploys(User _currUser, int _initCapacity, int _incCapacity)
构造函数
RegionInfos(User _currUser)
构造函数
RegionInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.recent 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.recent 中的方法
static Recents | Recents.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | Recent.insert(User _currUser) 将对象数据写入数据库
static Recents | Recents.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Recents]

参数类型为 User 的 com.trs.components.wcm.recent 中的构造方法
Recents(User _currUser)
构造函数
Recents(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.resource 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.resource 中的方法
static Keywords | Keywords.createNewInstance(User _currUser) 产生当前集合对象[Keywords]的实例
static Securities | Securities.createNewInstance(User _currUser) 产生当前集合对象[Securities]的实例
static Sources | Sources.createNewInstance(User _currUser) 产生当前集合对象[Sources]的实例
static Statuses | Statuses.createNewInstance(User _currUser) 产生当前集合对象[Statuses]的实例
boolean | ResourceMgr.delete(User _currUser, CMSObj _currObj) 删除指定的配置资源对象
static Keywords | Keywords.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Securities | Securities.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Sources | Sources.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Statuses | Statuses.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
DocKinds | DocKind.getChildren(User _currUser)
void | Security.insert(User _currUser)
void | Source.insert(User _currUser)
void | Keyword.insert(User _currUser) 将对象数据写入数据库
void | FileType.insert(User _currUser)
void | Status.insert(User _currUser)
void | DocKind.insert(User _currUser)
static boolean | SourceTypeMgr.isSourceMgr(User _user)
static Keywords | Keywords.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Keywords]
static Securities | Securities.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Securities]
static Sources | Sources.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Sources]
static Statuses | Statuses.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Statuses]
CMSObj | ResourceMgr.save(User _currUser, CMSObj _currObj) 保存指定的配置资源对象

参数类型为 User 的 com.trs.components.wcm.resource 中的构造方法
DocKinds(User _currUser)
DocKinds(User _currUser, int initialCapacity, int capacityIncrement)
FileTypes(User _currUser)
FileTypes(User _currUser, int initialCapacity, int capacityIncrement)
Keywords(User _currUser)
构造函数
Keywords(User _currUser, int _initCapacity, int _incCapacity)
构造函数
Securities(User _currUser)
Securities(User _currUser, int initialCapacity, int capacityIncrement)
Sources(User _currUser)
Sources(User _currUser, int initialCapacity, int capacityIncrement)
Statuses(User _currUser)
Statuses(User _currUser, int initialCapacity, int capacityIncrement)

com.trs.components.wcm.stat 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.stat 中的方法
static StatViews | StatViews.createNewInstance(User _currUser) 产生当前集合对象[StatViews]的实例
static StatViewRels | StatViewRels.createNewInstance(User _currUser) 产生当前集合对象[StatViewRels]的实例
static StatHosts | StatHosts.createNewInstance(User _currUser) 产生当前集合对象[StatHosts]的实例
static StatFieldMaps | StatFieldMaps.createNewInstance(User _currUser) 产生当前集合对象[StatFieldsMaps]的实例
static StatViews | StatViews.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static StatViewRels | StatViewRels.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static StatHosts | StatHosts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static StatFieldMaps | StatFieldMaps.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | StatViewRel.insert(User _currUser) 将对象数据写入数据库
void | StatView.insert(User _currUser) 将对象数据写入数据库
void | StatHost.insert(User _currUser) 将对象数据写入数据库
void | StatFieldMap.insert(User _currUser) 将对象数据写入数据库
static StatViews | StatViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatViews]
static StatViewRels | StatViewRels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatViewRels]
static StatHosts | StatHosts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatHosts]
static StatFieldMaps | StatFieldMaps.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatFieldsMaps]

参数类型为 User 的 com.trs.components.wcm.stat 中的构造方法
StatFieldMaps(User _currUser)
构造函数
StatFieldMaps(User _currUser, int _initCapacity, int _incCapacity)
构造函数
StatHosts(User _currUser)
构造函数
StatHosts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
StatViewRels(User _currUser)
构造函数
StatViewRels(User _currUser, int _initCapacity, int _incCapacity)
构造函数
StatViews(User _currUser)
构造函数
StatViews(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.util 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.util 中的方法
void | SystemWarnerMsgImpl.sendWarning(java.lang.String _sTitle, java.lang.String _sInfo, User _userTo, java.lang.Object _objOperated, java.lang.String _sObjName)
void | ISystemWarner.sendWarning(java.lang.String _sTitle, java.lang.String _sInfo, User _userTo, java.lang.Object _objOperated, java.lang.String _sObjName) 发送警告信息到指定用户

com.trs.components.wcm.wcmx.help 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.wcmx.help 中的方法
static WCMHelps | WCMHelps.createNewInstance(User _currUser) 产生当前集合对象[WCMHelps]的实例
static WCMHelps | WCMHelps.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WCMHelp | WCMHelps.findByUrl(User _currUser, java.lang.String _sUrl) 提取指定ID序列的对象集合
void | WCMHelp.insert(User _currUser) 将对象数据写入数据库
static WCMHelps | WCMHelps.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMHelps]

参数类型为 User 的 com.trs.components.wcm.wcmx.help 中的构造方法
WCMHelps(User _currUser)
构造函数
WCMHelps(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.wcmx.jsp 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.wcmx.jsp 中的构造方法
UserUtil(User _currUser)

com.trs.components.wcm.wcmx.media 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.wcmx.media 中的方法
static MediaRemindedInfo | MediaRemindedInfo.addRemindedSource(User _currUser, int _nUserId, int _nSourceId, int _nRemindedReq) 指定的用户设置指定媒体提醒的频率
int | MediaRemindedInfo.delete(User _currUser)
static MediaRemindedInfo | MediaRemindedInfo.findById(User _currUser, int _nId, java.lang.String _sSelect) 提取指定ID的对象
static MediaRemindedInfo | MediaRemindedInfo.findByUserAndSrc(User _currUser, int _nUserId, int _nSourceId) 提取指定ID的对象
Sources | MediaRemindedAgent.getSourcesRemided(User _currUser) 获取用户需要提醒的媒体集合
void | MediaRemindedInfo.insert(User _currUser) 将对象数据写入数据库
void | MediaRemindedInfo.update(User _user) 重载父对象的update，执行缓冲区的更新操作

参数类型为 User 的 com.trs.components.wcm.wcmx.media 中的构造方法
MediaRemindedInfos(User _currUser)
构造函数
MediaRemindedInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.components.wcm.wcmx.websites 中 User 的使用

参数类型为 User 的 com.trs.components.wcm.wcmx.websites 中的方法
static java.lang.String ChannelRelated.getChnlOrderHtml(Channel _currChnl, User _currUser)
获取设置频道顺序的HTML代码

com.trs.infra.persistent.util 中 User 的使用

参数类型为 User 的 com.trs.infra.persistent.util 中的方法
 void SynChildrenExecutorBase.execute(User _currUser)

com.trs.presentation.ids 中 User 的使用

返回 User 的 com.trs.presentation.ids 中的方法
static User ActorHelper.getUserFromSSOUser(com.trs.idm.client.actor.SSOUser _user)
从IDS的用户中获取当前应用的用户

com.trs.presentation.locale 中 User 的使用

参数类型为 User 的 com.trs.presentation.locale 中的方法
static void | LocaleServer.setFavorLanguage(User _currUser, java.lang.String _sLanguageKey) 设置个人偏好
static void | LocaleServer.setFavorLocale(User _currUser, java.util.Locale _locale) 设置用户选用的Locale

com.trs.presentation.nav 中 User 的使用

参数类型为 User 的 com.trs.presentation.nav 中的构造方法
TreeCreator(User _loginUser, RequestHelper _requestHelper, javax.servlet.jsp.JspWriter _out)
TreeNodeCalctor(java.lang.String _sChannelIds, User _loginUser)

com.trs.presentation.right 中 User 的使用

参数类型为 User 的 com.trs.presentation.right 中的方法
static boolean RightHelper.hasRight(User _loginUser, CMSObj _currObj, int[] _rightIndexes)
判断用户对某个对象是否具有具有一系列权限中的一个

com.trs.presentation.util 中 User 的使用

返回 User 的 com.trs.presentation.util 中的方法
 User LoginHelper.getLoginUser()

参数类型为 User 的 com.trs.presentation.util 中的方法
boolean | LoginHelper.canReLogin(User _loginUser, java.lang.String _sPassword, java.lang.String _sRemoteAddr)
static void | LoginHelper.clearLoginErrNum(User _user) 将指定用户的登录失败次数清零
java.lang.String | LoginHelper.createEncodeUserInfo(User _loginUser, java.lang.String _sPrivateKeyFile)
java.lang.String | LoginHelper.createEncodeUserInfo(User _loginUser, java.lang.String _sPrivateKeyFile, java.lang.String _sParam)
static boolean | CmsObjUnlockTools.forceUnLocke(User _opUser, CMSObj _lockedobj)
int | LoginHelper.getLoginErrNum(User _user) 提取指定用户登录失败的次数
static javax.servlet.http.HttpSession | LoginHelper.getSessionByUser(User _oUser)
static void | LoginHelper.kickUser(User _operUser, User user)
static CMSBaseObjs | CmsObjUnlockTools.listLockedObjs(User _opUser, int _nObjType)

com.trs.presentation.wcm.content 中 User 的使用

参数类型为 User 的 com.trs.presentation.wcm.content 中的构造方法
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, BaseChannel _baseChannel)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, Channel _channel)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, WebSite _site)

com.trs.service 中 User 的使用

返回 User 的 com.trs.service 中的方法
User | IRoleService.addUser(User _dstUser, Role _toRole) 添加指定的用户到指定的角色
User | IResourceService.getLoginUser() 返回当前登录用户
User | IPublishService.getLoginUser()
User | IEventService.getLoginUser() 获取当前登录用户
User | IRecentService.getLoginUser() 获得当前登录用户
User | ICustomizeService.getLoginUser() 获取使用service的当前用户
User | IDocumentService.getLoginUser() 返回当前登录用户
User | InfoViewContext.getUser()
User | IUserService.save(User _userToSave) 保存一个用户
User | IUserService.save(User _userToSave, Group _currGrp)

参数类型为 User 的 com.trs.service 中的方法
Contact | IContactService.addContactFromSystemUser(User _user) 导入系统用户为联系人
boolean | IGroupService.addManager(User _adminToAdd, Group _dstGroup) 将指定用户设置为某个组的管理员 注意: 指定的用户必须在指定组中
void | IChannelService.addSitesToUser(java.lang.String _sSiteIds, User _currUser) 给指定的用户添加指定的站点
boolean | IGroupService.addUser(User _userToAdd, Group _dstGroup) 将指定用户添加个指定的组中
User | IRoleService.addUser(User _dstUser, Role _toRole) 添加指定的用户到指定的角色
void | IEventService.cancelShare(Event _aEvent, User _assignToUser) 取消指派给另外一个用户的Event
boolean | IUserService.delete(User _userToDelete, boolean _bDrop) 删除指定的用户
boolean | IUserService.disable(User _userToDisable) 设置一个用户为禁用状态
boolean | IUserService.enable(User _userToEnable) 开通一个用户
Groups | IUserService.getGroups(User _currUser) 获取指定用户所在的组织集合
Roles | IUserService.getRoles(User _currUser) 获取指定用户所属的角色集合
BookMarks | IBookMarkService.getSharedBookMarks(User _currUser, WCMFilter _fliter) 获取所有共享的书签
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date) 获取用户在指定日期内被Assign的所有Events
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll) 获取用户在指定日期内私有的或公有的Events
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter) 获取用户在指定filter限制下被Assign的Events
MarkKinds | IBookMarkService.getSharedMarkKinds(User _currUser, WCMFilter _filter) 获取所有共享的书签文件夹
FlowDocs | IWCMProcessService.getSubmitFlowDocs(User _operator, WCMFilter _filter) 获取用户[_operator]已经呈送的信息
WebSites | IChannelService.getUserSites(User _currUser, WCMFilter _currFilter) 获取指定用户所属的站点集合
boolean | IUserService.isAdminOfGroup(User _user) 判断指定用户是否在系统中担任组管理员
boolean | IUserService.isManagerOfRole(User _user) 判断指定用户是否在系统中担任角色维护员
boolean | IChannelService.isVisible(User _currUser, BaseChannel _currChannel) 判断指定的频道对象对于用户是否可见
boolean | IChannelService.isVisible(User _currUser, BaseChannel _currChannel, int _nRightIndex) 判断在指定的权限值下，指定的频道对象对于用户是否可见
boolean | IGroupService.moveUser(User _userToMove, Group _srcGroup, Group _dstGroup) 将指定用户从某个组移动到指定的另外一个组中
boolean | IGroupService.moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups) 将指定的用户从某个组移动到指定的多个组中
boolean | IGroupService.removeManager(User _adminToCancel, Group _dstGroup) 取消指定用户在某个组的管理员身份 注意: 指定的用户必须在指定组中
void | IChannelService.removeSitesFromUser(java.lang.String _sSiteIds, User _currUser) 删除指定的用户上指定的站点
boolean | IGroupService.removeUser(User _userToRemove, Group _dstGroup) 将指定组从指定的组中删除
boolean | IGroupService.removeUser(User _userToRemove, Group _dstGroup, boolean _bRemoveOffspring)
boolean | IRoleService.removeUser(User _dstUser, Role _fromRole) 从指定的角色中删除指定的用户
boolean | IUserService.resetPassword(User _dstUser) 重设指定用户的密码为缺省值(只能由系统管理员操作)
boolean | IUserService.resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword) 重设指定用户的登录密码
boolean | IUserService.restore(User _userToRestore) 恢复已删除的用户
User | IUserService.save(User _userToSave) 保存一个用户
User | IUserService.save(User _userToSave, Group _currGrp)
void | InfoViewContext.setUser(User _oUser)
void | IEventService.shareTo(Event _aEvent, User _assignToUser) 当前用户把一个Event指派给另外一个用户
void | IWCMProcessService.submitAgain(User _postUser, int _nFlowDocId, java.lang.String _sOpinion)
void | IWCMProcessService.submitBack(User _postUser, java.lang.String _sFromFlowDocId, java.lang.String _sOpinion) 指定的用户将指定的工作事项打回

com.trs.service.impl 中 User 的使用

返回 User 的 com.trs.service.impl 中的方法
User | RoleService.addUser(User _dstUser, Role _toRole)
User | ResouceService.getLoginUser()
User | EventService.getLoginUser()
User | CustomizeService.getLoginUser()
User | DocumentService.getLoginUser()
User | RecentService.getLoginUser()
User | PublishService.getLoginUser()
User | UserService.save(User _userToSave)
User | UserService.save(User _userToSave, Group _currGrp)

参数类型为 User 的 com.trs.service.impl 中的方法
Contact | ContactService.addContactFromSystemUser(User _user)
boolean | GroupService.addManager(User _adminToAdd, Group _dstGroup)
void | ChannelService.addSitesToUser(java.lang.String _sSiteIds, User _currUser)
boolean | GroupService.addUser(User _userToAdd, Group _dstGroup)
User | RoleService.addUser(User _dstUser, Role _toRole)
void | EventService.cancelShare(Event _aEvent, User _assignToUser)
boolean | UserService.delete(User _userToDelete, boolean _bDrop)
boolean | UserService.disable(User _userToDisable)
boolean | UserService.enable(User _userToEnable)
Groups | UserService.getGroups(User _currUser)
Roles | UserService.getRoles(User _currUser)
BookMarks | BookMarkService.getSharedBookMarks(User _currUser, WCMFilter _fliter)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter)
MarkKinds | BookMarkService.getSharedMarkKinds(User _currUser, WCMFilter _filter)
FlowDocs | WCMProcessServiceImpl.getSubmitFlowDocs(User _operator, WCMFilter _filter)
WebSites | ChannelService.getUserSites(User _currUser, WCMFilter _currFilter)
boolean | UserService.isAdminOfGroup(User _user) 判断指定用户是否在系统中担任组管理员
boolean | UserService.isManagerOfRole(User _user) 判断指定用户是否在系统中担任角色维护员
boolean | ChannelService.isVisible(User _currUser, BaseChannel _currChannel)
boolean | ChannelService.isVisible(User _currUser, BaseChannel _currChannel, int _nRightIndex)
boolean | GroupService.moveUser(User _userToMove, Group _srcGroup, Group _dstGroup)
boolean | GroupService.moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups)
boolean | GroupService.removeManager(User _adminToCancel, Group _dstGroup)
void | ChannelService.removeSitesFromUser(java.lang.String _sSiteIds, User _currUser)
boolean | GroupService.removeUser(User _userToRemove, Group _dstGroup)
boolean | GroupService.removeUser(User _userToRemove, Group _dstGroup, boolean _bContainsChildren)
boolean | RoleService.removeUser(User _dstUser, Role _fromRole)
boolean | UserService.resetPassword(User _dstUser)
boolean | UserService.resetPassword(User _dstUser, java.lang.String _sNewPassword) 重置用户密码为新密码
boolean | UserService.resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword)
boolean | UserService.restore(User _userToRestore)
User | UserService.save(User _userToSave)
User | UserService.save(User _userToSave, Group _currGrp)
void | EventService.shareTo(Event _aEvent, User _assignToUser)
void | WCMProcessServiceImpl.submitAgain(User _postUser, int _nFlowDocId, java.lang.String _sOpinion)
void | WCMProcessServiceImpl.submitBack(User _postUser, java.lang.String _sFromFlowDocId, java.lang.String _sOpinion)

com.trs.wcm.config 中 User 的使用

参数类型为 User 的 com.trs.wcm.config 中的方法
static PageOperators | PageOperators.createNewInstance(User _currUser) 产生当前集合对象[PageOperators]的实例
static PageOperators | PageOperators.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
void | PageOperator.insert(User _currUser) 将对象数据写入数据库
static PageOperators | PageOperators.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PageOperators]

参数类型为 User 的 com.trs.wcm.config 中的构造方法
PageOperators(User _currUser)
构造函数
PageOperators(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.wcm.customize 中 User 的使用

参数类型为 User 的 com.trs.wcm.customize 中的方法
PageOperators | ICustomizeMgr.getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter) 获取指定用户指定类型的操作
PageOperators | CustomizeMgrImpl.getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter)

com.trs.wcm.old 中 User 的使用

返回 User 的 com.trs.wcm.old 中的方法
 User ImportDocsContext.getCurrUser()
获取当前的交互用户

参数类型为 User 的 com.trs.wcm.old 中的方法
int | WCMFormInfo.delete(User _currUser) 重载父类删除接口，同步删除其字段列表
void | WCMFormInfo.insert(User _currUser) 将对象数据写入数据库
static WCMFormInfos | WCMFormInfos.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 16:42:24 Last Modified: 2004-12-12/2004-12-12 Description:获取表单集合
void | ImportDocsContext.setCurrUser(User _currUser) 设置当前的交互用户

参数类型为 User 的 com.trs.wcm.old 中的构造方法
WCMExcelDatas(User _currUser)
WCMExcelDatas(User _currUser, int _initCapacity, int _incCapacity)
WCMFormFieldses(User _currUser)
构造函数
WCMFormFieldses(User _currUser, int _initCapacity, int _incCapacity)
构造函数
WCMFormInfos(User _currUser)
构造函数
WCMFormInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.wcm.photo 中 User 的使用

参数类型为 User 的 com.trs.wcm.photo 中的方法
static Watermarks | Watermarks.createNewInstance(User _currUser) 产生当前集合对象[Watermarks]的实例
int | Watermark.delete(User _currUser)
static Watermarks | Watermarks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.util.List | IImageLibService.getChannels(User _user, int _nRightIndex) 获取指定用户可见的图片库的一级分类
java.util.List | IImageLibService.getChannels(User _user, int _nRightIndex, Channel _channel) 获取指定用户在指定分类可见的子分类列表
java.util.List | IImageLibService.getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter) 获取指定用户在指定分类可见的子分类列表
ImageInfo | IImageLibMgr.importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo) 导入指定的图片到图片库指定的分类中
void | Watermark.insert(User _currUser) 将对象数据写入数据库
static Watermarks | Watermarks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Watermarks]
void | Watermark.save(User _currUser)

参数类型为 User 的 com.trs.wcm.photo 中的构造方法
Watermarks(User _currUser)
构造函数
Watermarks(User _currUser, int _initCapacity, int _incCapacity)
构造函数

com.trs.wcm.photo.impl 中 User 的使用

参数类型为 User 的 com.trs.wcm.photo.impl 中的方法
java.util.List | ImageLibServiceImpl.getChannels(User _user, int _nRightIndex)
java.util.List | ImageLibServiceImpl.getChannels(User _user, int _nRightIndex, Channel _channel)
java.util.List | ImageLibServiceImpl.getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter)
ImageInfo | ImageLibMgrImpl.importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo)
static void | AutoImageLibUtil.saveImage(java.lang.String _fn, User _user)

com.trsupdate 中 User 的使用

参数类型为 User 的 com.trsupdate 中的构造方法
RightUpdaterForUser(User _currUser, java.lang.String _sTableNameOfWCM52Right)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.UserCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.UserCacheMgr
的使用

没有 com.trs.cms.auth.persistent.UserCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.UserLicenseMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.UserLicenseMgr
的使用

使用 UserLicenseMgr 的软件包
com.trs.cms.auth.persistent

com.trs.cms.auth.persistent 中 UserLicenseMgr 的使用

返回 UserLicenseMgr 的 com.trs.cms.auth.persistent 中的方法
static UserLicenseMgr UserLicenseMgr.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.auth.persistent.Users 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.auth.persistent.Users
的使用

使用 Users 的软件包
com.trs.ajaxservice
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process
com.trs.cms.process.config
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.cms.process.engine.creators
com.trs.components.common.bookmark
com.trs.components.common.calendar
com.trs.components.common.message
com.trs.components.gkml.sqgk.process.engine.creators
com.trs.components.wcm.content.domain
com.trs.components.wcm.process
com.trs.components.wcm.wcmx.media
com.trs.presentation.util
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 Users 的使用

返回 Users 的 com.trs.ajaxservice 中的方法
Users | UserServiceProvider.getOnlineUsers() 获取系统在线用户
Users | UserServiceProvider.getUsersByNames(MethodContext _context)
Users | UserServiceProvider.getUsersOfGroup(MethodContext _context) 获取指定组织下的用户集合,适用于角色的添加用户页面
Users | UserServiceProvider.getUsersOfRole(MethodContext _context) 获取指定角色和站点下的用户集合,兼容系统级角色和非系统级角色
Users | UserServiceProvider.getUsersOfSpecialRole(MethodContext _context) 获取指定特定角色下的用户集合
Users | UserServiceProvider.getUsersOfSystemRoleOnSite(MethodContext _context) 获取指定系统级角色和站点下的用户集合

com.trs.cms.auth.domain 中 Users 的使用

返回 Users 的 com.trs.cms.auth.domain 中的方法
Users | GroupMgr.getAdmins(Group _dstGroup) 获取指定组织的管理员集合
Users | UserMgr.getConsignUsers(int _nModuleType) 获取当前用户的托管人
Users | GroupMgr.getUsers(Group _theGroup, WCMFilter _filter) 获取属于某组织的所有用户集合
Users | GroupMgr.getUsers(Group _theGroup, WCMFilter _filter, boolean _bContainsChildGrp) 获取指定组织所有的用户(用户组织关联对象),包含所有的子组织的用户
Users | RoleMgr.getUsers(Role _dstRole, int _nSiteId, WCMFilter _filter) 获取某角色在某站点下的所有用户集合
Users | RoleMgr.getUsers(Role _dstRole, WCMFilter _filter) 获取担任某角色的所有用户集合
Users | RoleMgr.getUsersBySpecailForUser(Role _dstRole, WCMFilter _filter) 获取当前登录用户可以查看的某特定角色的所有用户集合
Users | RoleMgr.getUsersBySystemRoleForUser(Role _dstRole, int _nSiteId, WCMFilter _filter) 获取当前登录用户可以查看的某系统级角色的所有用户集合

参数类型为 Users 的 com.trs.cms.auth.domain 中的方法
 void RoleMgr.setRoleUsers(Role role, int _nSiteId, Users _users)
绑定角色,站点和用户的关联，同时将清除原来的关联

com.trs.cms.auth.persistent 中 Users 的使用

返回 Users 的 com.trs.cms.auth.persistent 中的方法
static Users | Users.createNewInstance(User _currUser) 产生当前集合对象[Users]的实例
static Users | Users.findAdministrators()
static Users | Users.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Users | Group.getAdministrator(User _opUser) 取用户所属组对象集合
Users | GroupAdminsCacheMgr.getAdmins(Group _group) 获取指定用户组的管理员集合
Users | AdministratorCacheMgr.getAdminUsers()
Users | IAdministratorCacheMgr.getAdminUsers()
Users | Group.getUsers(User _currUser) 取组内所有用户集合（Users）
Users | Role.getUsers(User _currUser) 取属于该角色的所有用户
Users | Group.getUsers(User _currUser, java.lang.String _sOrder) 获取按照一定排序方式取组内所有用户集合（Users）
static Users | Right.getUsersWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight) 获取在指定对象上设置了权限（/没有设置权限）的集合用户
static Users | Users.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Users]

com.trs.cms.process 中 Users 的使用

返回 Users 的 com.trs.cms.process 中的方法
static Users FlowServer.getConsignUsers(User _operator, int _nModule)
获得指定模块的所有的委托人，默认为公文管理(TrusteeInfo.MODULE_FLOW)

参数类型为 Users 的 com.trs.cms.process 中的方法
void | IFlowNotifyWorker.addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, int _nNotify)
void | IFlowNotifyWorker.addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)
FlowDoc | FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers)
FlowDoc | IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers) 自动将当前轨迹呈送到下一个节点

com.trs.cms.process.config 中 Users 的使用

返回 Users 的 com.trs.cms.process.config 中的方法
 Users ToUsersCreatorConfig.getToUsers(FlowContext _context)
根据当前的配置获取处理者

com.trs.cms.process.definition 中 Users 的使用

返回 Users 的 com.trs.cms.process.definition 中的方法
Users | Flow.getMonitorUsers(User _currUser) 取工作流的监控用户
Users | FlowNode.getOperUsers(User _currUser) 取节点上的操作用户集合
Users | FlowNode.getOperUsers(User _currUser, boolean _bAll)
Users | FlowNode.getOperUsers(User _currUser, boolean _bAll, java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sOrder) 返回节点上定义的用户

com.trs.cms.process.engine 中 Users 的使用

返回 Users 的 com.trs.cms.process.engine 中的方法
Users | IToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig) 根据当前上下文信息产生处理者信息
static Users | FlowUserHelper.getDeptMgrsByGrpIds(java.lang.String _sGroupIds) 获取指定部门的部门经理(管理员)
static Users | FlowUserHelper.getDeptMgrsByGrpName(java.lang.String _sGroupName) 获取指定部门的部门经理(管理员)
static Users | FlowUserHelper.getDeptMgrsOfUserx(User _user) 获取用户所属部门的部门经理(管理员)
Users | FlowParamers.getToUsers()
Users | FlowContext.getToUsers()
Users | FlowNextBranchInfo.getToUsers()
Users | FlowDoc.getToUsers(User _currUser) 获取所有呈送人员集合
Users | FlowNextBranchInfo.getUsersPassed()

参数类型为 Users 的 com.trs.cms.process.engine 中的方法
void | FlowParamers.setToUsers(Users users)
void | FlowContext.setToUsers(Users toUsers)
void | FlowNextBranchInfo.setToUsers(Users toUsers)

参数类型为 Users 的 com.trs.cms.process.engine 中的构造方法
FlowContext(User _currUser, IFlowContent _oFlowContent, java.lang.String _sPostDesc, Users _toUsers, Flow _flow)
内容开始流转时候的FlowContext构造函数

com.trs.cms.process.engine.creators 中 Users 的使用

返回 Users 的 com.trs.cms.process.engine.creators 中的方法
Users | GroupAdminsFromChnlAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupMembersAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsFromFlowAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | RoleAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | DeptMgrAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | CrUserAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsFromSupportPartAsToUsersCreator.createToUsers(FlowContext flowContext, ToUsersCreatorConfig _oCreatorConfig)

com.trs.components.common.bookmark 中 Users 的使用

返回 Users 的 com.trs.components.common.bookmark 中的方法
 Users BookMarkMgr.getSharedUsers(int _nTypeId, CMSObj _currObj)

com.trs.components.common.calendar 中 Users 的使用

返回 Users 的 com.trs.components.common.calendar 中的方法
 Users EventMgr.getUsers(Event _anEvent)
获取共享指定日程安排的所有用户

com.trs.components.common.message 中 Users 的使用

返回 Users 的 com.trs.components.common.message 中的方法
 Users Message.getReceivers()
获取消息的接收者集合

com.trs.components.gkml.sqgk.process.engine.creators 中 Users 的使用

返回 Users 的 com.trs.components.gkml.sqgk.process.engine.creators 中的方法
Users | LawGovTousersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | ApplyFormToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

com.trs.components.wcm.content.domain 中 Users 的使用

返回 Users 的 com.trs.components.wcm.content.domain 中的方法
 Users SiteMemberMgr.getSiteUsers(WebSite _site, WCMFilter _filter)
获取站点中的用户集合

com.trs.components.wcm.process 中 Users 的使用

参数类型为 Users 的 com.trs.components.wcm.process 中的方法
void | FlowNotifyWorkerImpl.addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, int _nNotify)
void | FlowNotifyWorkerImpl.addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)

com.trs.components.wcm.wcmx.media 中 Users 的使用

返回 Users 的 com.trs.components.wcm.wcmx.media 中的方法
 Users MediaRemindedAgent.getUsersByMediaReminded(int _nSourceId)
根据媒体ID获取设置了提醒的用户集合

com.trs.presentation.util 中 Users 的使用

返回 Users 的 com.trs.presentation.util 中的方法
static Users LoginHelper.getOnlineUsers()

com.trs.service 中 Users 的使用

返回 Users 的 com.trs.service 中的方法
Users | IGroupService.getAdmins(Group _dstGroup) 获取指定组的管理员集合
Users | IUserService.getCanMgrUsers(int _nUserRegStatus, WCMFilter _filter) 获取我可管理的用户
Users | IUserService.getMyUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所创建的用户列表
Users | IEventService.getSharedUsers(Event _aEvent) 获取一个Event被AssignTo的Users
Users | IBookMarkService.getSharedUsers(int _nObjType, int _nObjId) 获取共享用户
Users | IChannelService.getSiteUsers(WebSite _currSite, WCMFilter _currFilter) 获取指定站点的所属用户集合
Users | IGroupService.getUsers(Group _dstGroup, WCMFilter _filter) 获取指定组中的所有用户
Users | IGroupService.getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildren)
Users | IUserService.getUsers(int _nUserRegStatus, WCMFilter _filter) 获取系统中的某个注册状态的所有用户
Users | IRoleService.getUsers(Role _dstRole, WCMFilter _filter) 获取指定角色的所有用户

参数类型为 Users 的 com.trs.service 中的方法
void | IEventService.cancelShare(Event _aEvent, Users _assignToUsers) 取消指派给一个用户集合的Event
boolean | IUserService.delete(Users _usersToDelete, boolean _bDrop) 批量删除指定的用户
boolean | IUserService.restore(Users _usersToRestore) 恢复已删除的用户集合
void | IEventService.shareTo(Event _aEvent, Users _assignToUsers) 把一个Event指派给一个用户集合

com.trs.service.impl 中 Users 的使用

返回 Users 的 com.trs.service.impl 中的方法
Users | GroupService.getAdmins(Group _dstGroup)
Users | UserService.getCanMgrUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所能管理的用户
Users | UserService.getMyUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所创建的用户列表
Users | EventService.getSharedUsers(Event _aEvent)
Users | BookMarkService.getSharedUsers(int _nObjType, int _nObjId)
Users | ChannelService.getSiteUsers(WebSite _currSite, WCMFilter _currFilter)
Users | GroupService.getUsers(Group _dstGroup, WCMFilter _filter)
Users | GroupService.getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildGrp)
Users | UserService.getUsers(int _nUserRegStatus, WCMFilter _filter)
Users | RoleService.getUsers(Role _dstRole, WCMFilter _filter)

参数类型为 Users 的 com.trs.service.impl 中的方法
void | EventService.cancelShare(Event _aEvent, Users _assignToUsers)
boolean | UserService.delete(Users _usersToDelete, boolean _bDrop)
boolean | UserService.restore(Users _usersToRestore)
void | EventService.shareTo(Event _aEvent, Users _assignToUsers)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.CMSConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.CMSConstants
的使用

没有 com.trs.cms.CMSConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.ContextHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.ContextHelper
的使用

没有 com.trs.cms.ContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.ObjectTypeServer 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.ObjectTypeServer
的使用

没有 com.trs.cms.ObjectTypeServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ClusterLocker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 ClusterLocker

java.lang.Object
    继承者  com.trs.cms.content.ClusterLocker

public class ClusterLocker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
集群对象锁定
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ClusterLocker(User lockuser, CMSObj lockedObj)
方法摘要
boolean | lock()
boolean | unlock()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClusterLocker

public ClusterLocker(User lockuser,
                     CMSObj lockedObj)
方法详细信息

lock

public boolean lock()

unlock

public boolean unlock()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CMSBaseObjs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 CMSBaseObjs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
直接已知子类：
ADComs, ADFilePoss, ADFiles, ADPoss, ADTypes, Appendixes, ApplyFormDealLogs, ApplyForms, AutoBakConfigs, BonusRules, BookMarks, CellInfos, ChannelContentLinks, Channels, ChannelSyns, ChnlDepts, ChnlDocs, ClassInfos, ClassInfoViews, ComplexFieldDatas, ContactGrps, Contacts, ContentExtendValues, ContentExtFields, ContentLinks, ContentLinkTypes, ContentStyles, CustomSiteCheckedInfos, DefaultObjs, DocBaks, DocKinds, DocReplys, DocumentHitsCounts, Documents, DocumentSyns, DocumentTopics, EntryConfigs, Events, EventShares, EventTypes, ExtendedFields, FileTypes, FlowActions, FlowConditions, FlowContentConfigs, FlowdocLogs, FlowDocs, FlowEmploys, FlowNodeBranchs, FlowNodeFields, FlowNodes, FlowRules, Flows, FolderPublishConfigs, GroupRoles, Groups, GroupUsers, HitsCounts, HostObjDomains, HostObjHitsCounts, Individuations, InfoViewDatas, InfoViewEmploys, InfoViewFields, InfoViewGroups, InfoViews, InfoViewViews, JobWorkerTypes, Keywords, Layouts, Logos, MailConfigs, MarkKinds, MarkShares, Masters, MediaRemindedInfos, Messages, MetaDBFields, MetaDBTables, MetaViewDatas, MetaViewFields, MetaViews, MsgQueues, ObjectMembers, PageOperators, PageStyles, PublishDistributions, PublishErrorLogs, PublishTasks, Recents, RegionEmploys, RegionInfos, Relations, Replaces, ResourceStyles, RightDefs, Rights, Roles, RoleUsers, Schedules, Securities, SiteMembers, Sources, Specials, StatFieldMaps, StatHosts, Statuses, StatViewRels, StatViews, StyleAndResources, StyleItems, TagBeans, TempApdRels, TempAppendixes, TemplateArguments, TemplateEmploys, TemplateQuotes, Templates, TopicedDocRelations, TrusteeInfos, UserLoginInfos, Users, UserSettings, ViewDocuments, VoteDatas, VoteIPLogs, VoteItems, VoteOptions, Votes, Watermarks, WCMExcelDatas, WCMFormFieldses, WCMFormInfos, WCMHelps, WCMPubStatusConfigs, WebSites, WidgetInstances, WidgetInstParameters, WidgetParameters, Widgets
public abstract class CMSBaseObjs
extends BaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
CMSBaseObjs()
缺省构造函数
CMSBaseObjs(User _currUser)
构造函数
CMSBaseObjs(User _currUser, int _initCapacity, int _incCapacity)
构造函数（默认不指定容量，建立指定）
方法摘要
void | cancelUpdate() 取消当前元素的修改操作
void | cancelUpdateAll()
void | cancelUpdateAll(int _end) 取消集合中指定数量的元素的修改记录
boolean | canEdit() 检查当前元素是否可以修改；若可以修改，则锁定该元素
boolean | canEdit(int _nLockTime) 检查当前元素是否可以修改；若可以修改，则锁定该元素
boolean | canEditAll() 检查当前集合中是否都可以进行编辑；若可以修改，则锁定该集合中所有元素
static CMSBaseObjs | createInstance(User _currUser, java.lang.Class _classObjs) 产生指定集合对象的实例
static CMSBaseObjs | createInstance(User _currUser, java.lang.String _sObjsClassName) 产生指定集合对象的实例
static CMSBaseObjs | findWCMObjsByIds(User _currUser, java.lang.Class _classObjs, java.lang.String _sObjIds)
static CMSBaseObjs | findWCMObjsByIds(User _currUser, java.lang.String _sObjsClassName, java.lang.String _sObjIds) 根据ID序列获取一个指定的集合
User | getCurrUser() 获得CurrUser：当前用户
static CMSBaseObjs | openWCMObjs(User _currUser, java.lang.Class _objsClass, WCMFilter _filter) 根据指定的Filter打开指定的集合
static CMSBaseObjs | openWCMObjs(User _currUser, java.lang.String _sObjsClassName, WCMFilter _filter) 根据指定的Filter打开指定的集合
void | setCurrUser(User user)
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getElementClass, getFilter, getIdAt, getIdFieldName, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, newInstance, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMSBaseObjs

public CMSBaseObjs()
缺省构造函数

CMSBaseObjs

public CMSBaseObjs(User _currUser)
构造函数

参数：
_currUser - 当前操作用户

CMSBaseObjs

public CMSBaseObjs(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数（默认不指定容量，建立指定）

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getCurrUser

public User getCurrUser()
获得CurrUser：当前用户

返回：

setCurrUser

public void setCurrUser(User user)

canEditAll

public boolean canEditAll()
检查当前集合中是否都可以进行编辑；若可以修改，则锁定该集合中所有元素

返回：
boolean 如果可以返回true;否则返回false

canEdit

public boolean canEdit()
                throws WCMException
检查当前元素是否可以修改；若可以修改，则锁定该元素

返回：
boolean 如果可以返回true;否则返回false
抛出：
WCMException - 当前不是普通模式下时或锁定对象失败时

canEdit

public boolean canEdit(int _nLockTime)
                throws WCMException
检查当前元素是否可以修改；若可以修改，则锁定该元素

参数：
_nLockTime - 锁定时间，可以忽略，将采用系统的默认时间锁定
返回：
boolean 如果可以返回true;否则返回false
抛出：
WCMException - 当前不是普通模式下时或锁定对象失败时

cancelUpdateAll

public void cancelUpdateAll(int _end)
取消集合中指定数量的元素的修改记录

覆盖：
类 BaseObjs 中的 cancelUpdateAll
参数：
_end - 元素结束位置，默认为所有

cancelUpdateAll

public void cancelUpdateAll()
覆盖：
类 BaseObjs 中的 cancelUpdateAll

cancelUpdate

public void cancelUpdate()
取消当前元素的修改操作

覆盖：
类 BaseObjs 中的 cancelUpdate

createInstance

public static CMSBaseObjs createInstance(User _currUser,
                                         java.lang.String _sObjsClassName)
                                  throws WCMException
产生指定集合对象的实例

参数：
_currUser - 当前操作用户
_sObjsClassName - 指定集合对象的Class Name
返回：
@throws WCMException
抛出：
WCMException

createInstance

public static CMSBaseObjs createInstance(User _currUser,
                                         java.lang.Class _classObjs)
                                  throws WCMException
产生指定集合对象的实例

参数：
_currUser - 当前操作用户
_classObjs - 指定集合对象的Class
返回：
@throws WCMException
抛出：
WCMException

openWCMObjs

public static CMSBaseObjs openWCMObjs(User _currUser,
                                      java.lang.Class _objsClass,
                                      WCMFilter _filter)
                               throws WCMException
根据指定的Filter打开指定的集合

参数：
_currUser - 当前操作的用户
_objsClass - 指定的集合对象的Class
_filter - 指定的WCMFilter
返回：
打开后的集合对象(指定集合对象的实例)
抛出：
WCMException

openWCMObjs

public static CMSBaseObjs openWCMObjs(User _currUser,
                                      java.lang.String _sObjsClassName,
                                      WCMFilter _filter)
                               throws WCMException
根据指定的Filter打开指定的集合

参数：
_currUser - 当前操作的用户
_sObjsClassName - 指定的集合对象的Class Name
_filter - 指定的WCMFilter
返回：
打开后的集合对象(指定集合对象的实例)
抛出：
WCMException

findWCMObjsByIds

public static CMSBaseObjs findWCMObjsByIds(User _currUser,
                                           java.lang.Class _classObjs,
                                           java.lang.String _sObjIds)
                                    throws WCMException
参数：
_currUser -
_classObjs -
_sObjIds -
返回：
@throws WCMException
抛出：
WCMException

findWCMObjsByIds

public static CMSBaseObjs findWCMObjsByIds(User _currUser,
                                           java.lang.String _sObjsClassName,
                                           java.lang.String _sObjIds)
                                    throws WCMException
根据ID序列获取一个指定的集合

参数：
_currUser - 当前用户
_sObjsClassName - 当前
_sObjIds -
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMSObj

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 CMSObj

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
ADCom, ADFile, ADFilePos, ADPos, ADType, Appendix, ApplyForm, ApplyFormDealLog, AutoBakConfig, BaseChannel, BaseStyle, BonusRule, BookMark, CellInfo, ChannelContentLink, ChannelSyn, ChnlDept, ChnlDoc, ClassInfo, ClassInfoView, CMSObjDefaultImpl, ComplexFieldData, Contact, ContactGrp, ContentExtendValue, ContentExtField, ContentLink, ContentLinkType, CustomSiteCheckedInfo, DefaultObj, DocKind, DocReply, Document, DocumentHitsCount, DocumentSyn, DocumentTopic, EntryConfig, Event, EventShare, EventType, ExtendedField, FileType, Flow, FlowAction, FlowCondition, FlowContentConfig, FlowDoc, FlowdocLog, FlowEmploy, FlowNode, FlowNodeBranch, FlowNodeField, FlowRule, FolderPublishConfig, Group, GroupRole, GroupUser, HitsCount, HostObjDomain, HostObjHitsCount, Individuation, InfoView, InfoViewData, InfoViewEmploy, InfoViewField, InfoViewGroup, InfoViewView, JobWorkerType, Keyword, Layout, Logo, MailConfig, MarkKind, MarkShare, Master, MediaRemindedInfo, Message, MetaDBField, MetaDBTable, MetaView, MetaViewData, MetaViewField, MsgQueue, ObjectMember, PageOperator, PublishDistribution, PublishErrorLog, PublishTask, Recent, RegionEmploy, RegionInfo, Relation, Replace, Right, RightDef, Role, RoleUser, Schedule, Security, SiteMember, Source, Special, StatFieldMap, StatHost, Status, StatView, StatViewRel, StyleAndResource, StyleItem, TagBean, TempApdRel, TempAppendix, Template, TemplateArgument, TemplateEmploy, TemplateQuote, TopicedDocRelation, TrusteeInfo, User, UserLoginInfo, UserSetting, ViewDocument, Vote, VoteData, VoteIPLog, VoteItem, VoteOption, Watermark, WCMFolderPublishConfig, WCMFormFields, WCMFormInfo, WCMHelp, WCMPubStatusConfig, WCMSystemObject, Widget, WidgetInstance, WidgetInstParameter, WidgetParameter, XDocument
public abstract class CMSObj
extends BaseObj

构造方法摘要
CMSObj()
方法摘要
void | cancelUpdate(User _user) 撤销更新操作，清除更新缓冲区
boolean | canEdit(User _user)
boolean | canEdit(User _user, int _nLockTimeOut) 检测是否允许编辑，在指定的时间内锁定对象
int | delete() 建议使用delete(User)
int | delete(User _currUser) 从数据中删除对象信息
User | getCrUser()
java.lang.String | getCrUserName() 共用接口：属性创建用户CrUser读操作 说明：子类可以通过重载禁止使用
Locker | getLocker() 取本对象的加锁对象
User | getLockerUser() 取本对象的加锁人
java.lang.String | getLockerUserName() 取对象的加锁人的用户名
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isLocked() 检测当前是否已经锁定
boolean | lock(User _lockUser)
boolean | lock(User _lockUser, int _lockTimeOut) 锁定对象，默认锁定时间在系统配置中可以设置
void | save() 对象保存自己
void | save(User _currUser) 对象保存自己
boolean | setCrUser(java.lang.String _crUserName) 共用接口：属性创建用户CrUser写操作 说明：子类可以通过重载禁止使用
boolean | setCrUser(User _crUser)
java.lang.String | toString()
boolean | unlock() 给对象解锁
void | update(User _user) 更新修改。
void | validCanDeleteAndLock(User _user)
void | validCanEditAndLock(User _user)
void | validCanEditAndLock(User _user, int _nLockTimeOut)
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getDbTableName, getFinalPropertyAsString, getFinalPropertyAsString, getId, getIdFieldName, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, getWCMType, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValid, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMSObj

public CMSObj()
方法详细信息

getLocker

public Locker getLocker()
取本对象的加锁对象

返回：
锁定对象Locker

getLockerUser

public User getLockerUser()
取本对象的加锁人

返回：
用户对象(User)

getLockerUserName

public java.lang.String getLockerUserName()
取对象的加锁人的用户名

返回：
用户名（String）

isLocked

public boolean isLocked()
检测当前是否已经锁定

返回：
如果锁定返回true,否则返回false

lock

public boolean lock(User _lockUser,
                    int _lockTimeOut)
锁定对象，默认锁定时间在系统配置中可以设置

参数：
_lockUser - 加锁用户
_lockTimeOut - 锁定时间，以分钟为单位
返回：
加锁成功返回 true,否则返回false

lock

public boolean lock(User _lockUser)

unlock

public boolean unlock()
给对象解锁

返回：
解锁成功返回true,否则返回false

getCrUserName

public java.lang.String getCrUserName()
共用接口：属性创建用户CrUser读操作 说明：子类可以通过重载禁止使用

返回：

getCrUser

public User getCrUser()

setCrUser

public boolean setCrUser(java.lang.String _crUserName)
                  throws WCMException
共用接口：属性创建用户CrUser写操作 说明：子类可以通过重载禁止使用

参数：
_crUserName - 用户名
返回：
抛出：
WCMException

setCrUser

public boolean setCrUser(User _crUser)
                  throws WCMException
抛出：
WCMException

validCanEditAndLock

public void validCanEditAndLock(User _user,
                                int _nLockTimeOut)
                         throws WCMException
抛出：
WCMException

validCanEditAndLock

public void validCanEditAndLock(User _user)
                         throws WCMException
抛出：
WCMException

validCanDeleteAndLock

public void validCanDeleteAndLock(User _user)
                           throws WCMException
抛出：
WCMException

canEdit

public boolean canEdit(User _user,
                       int _nLockTimeOut)
检测是否允许编辑，在指定的时间内锁定对象

参数：
_user - 用户对象
_nLockTimeOut - 锁定的时间（以分钟为单位）
返回：
如果允许编辑返回false

canEdit

public boolean canEdit(User _user)

insert

public void insert(User _currUser)
            throws WCMException
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

参数：
_currUser - 目前操作用户
抛出：
WCMException

update

public void update(User _user)
            throws WCMException
更新修改。修改的属性值保存在hPropertyNew中

参数：
_user - 操作用户
抛出：
WCMException

cancelUpdate

public void cancelUpdate(User _user)
撤销更新操作，清除更新缓冲区

参数：
_user - 当前操作的用户

delete

public int delete()
           throws WCMException
建议使用delete(User)

覆盖：
类 BaseObj 中的 delete
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

delete

public int delete(User _currUser)
           throws WCMException
从数据中删除对象信息

参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

save

public void save(User _currUser)
          throws WCMException
对象保存自己

参数：
_currUser - 当前操作用户
抛出：
WCMException

save

public void save()
          throws WCMException
从类 BaseObj 复制的描述
对象保存自己

覆盖：
类 BaseObj 中的 save
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMSObjDefaultImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 CMSObjDefaultImpl

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.content.CMSObjDefaultImpl
所有已实现的接口：
java.lang.Cloneable
public class CMSObjDefaultImpl
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMSObjDefaultImpl(java.lang.String _sTableName, java.lang.String _sIdFieldName)
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMSObjDefaultImpl

public CMSObjDefaultImpl(java.lang.String _sTableName,
                         java.lang.String _sIdFieldName)
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultObj

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 DefaultObj

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.content.DefaultObj
所有已实现的接口：
java.lang.Cloneable
public class DefaultObj
extends CMSObj

字段摘要
static int OBJ_TYPE
构造方法摘要
DefaultObj()
DefaultObj(java.lang.String _sDbTableName, java.lang.String _sIdFieldName)
方法摘要
static DefaultObj | findById(int _nId, java.lang.String _sTableName, java.lang.String _sIdFieldName) 提取指定ID的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | setAddMode(boolean _bAddMode)
void | setDbTableName(java.lang.String dbTableName)
void | setIdFieldName(java.lang.String idFieldName)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值
构造方法详细信息

DefaultObj

public DefaultObj()

DefaultObj

public DefaultObj(java.lang.String _sDbTableName,
                  java.lang.String _sIdFieldName)
方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：

setAddMode

public void setAddMode(boolean _bAddMode)

setDbTableName

public void setDbTableName(java.lang.String dbTableName)
参数：
dbTableName -

setIdFieldName

public void setIdFieldName(java.lang.String idFieldName)
参数：
idFieldName -

findById

public static final DefaultObj findById(int _nId,
                                        java.lang.String _sTableName,
                                        java.lang.String _sIdFieldName)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultObjs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 DefaultObjs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.content.DefaultObjs

public class DefaultObjs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
DefaultObjs(User _currUser)
DefaultObjs(User _currUser, int _initCapacity, int _incCapacity)
DefaultObjs(User _currUser, java.lang.String _sDbTableName, java.lang.String _sIdFieldName)
方法摘要
static DefaultObjs | createNewInstance(User _currUser) 产生当前集合对象[DefaultObjs]的实例
static DefaultObjs | findByIds(User _currUser, java.lang.String _sIds, java.lang.String _sDbTableName, java.lang.String _sIdFieldName) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static DefaultObjs | openWCMObjs(User _currUser, WCMFilter _filter, java.lang.String _sDbTableName, java.lang.String _sIdFieldName) 通过指定一个Filter获取当前集合[DefaultObjs]
void | setDbTableName(java.lang.String dbTableName)
void | setIdFieldName(java.lang.String idFieldName)
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultObjs

public DefaultObjs(User _currUser)

DefaultObjs

public DefaultObjs(User _currUser,
                   java.lang.String _sDbTableName,
                   java.lang.String _sIdFieldName)

DefaultObjs

public DefaultObjs(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

setDbTableName

public void setDbTableName(java.lang.String dbTableName)
参数：
dbTableName -

setIdFieldName

public void setIdFieldName(java.lang.String idFieldName)
参数：
idFieldName -

findByIds

public static final DefaultObjs findByIds(User _currUser,
                                          java.lang.String _sIds,
                                          java.lang.String _sDbTableName,
                                          java.lang.String _sIdFieldName)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（DefaultObjs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final DefaultObjs openWCMObjs(User _currUser,
                                            WCMFilter _filter,
                                            java.lang.String _sDbTableName,
                                            java.lang.String _sIdFieldName)
                                     throws WCMException
通过指定一个Filter获取当前集合[DefaultObjs]

参数：
_filter - 指定的Filter
返回：
当前集合[DefaultObjs]
抛出：
WCMException

createNewInstance

public static DefaultObjs createNewInstance(User _currUser)
产生当前集合对象[DefaultObjs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExtendedField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 ExtendedField

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.content.ExtendedField
所有已实现的接口：
java.lang.Cloneable
public class ExtendedField
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象所对应的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型
构造方法摘要
ExtendedField()
方法摘要
static ExtendedField | createNewInstance() 产生当前对象[ExtendedField]的实例
int | delete(User _currUser) 删除扩展字段对象，重载父类接口：删除该对象之前，必须确保无任何频道使用该字段
boolean | equals(java.lang.Object obj) 判定本对象是否与指定对象相同
static ExtendedField | findById(int _nId) 提取指定ID的对象
static ExtendedField | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 获得扩展字段的扩展属性
java.lang.String | getDbTableName() 对象所对应的数据表名
java.lang.String | getDefaultValue() 获取扩展字段的默认值
int | getDefaultValueAsInt(int _default) 取整型默认值
java.lang.String | getDesc() 获得扩展字段描述信息
java.lang.String | getIdFieldName() 对象所对应的ID字段名
int | getMaxLength() 获得扩展字段最大长度
java.lang.String | getName() 扩展字段名称
int | getScale()
java.lang.String | getTableName() 扩展字段所属数据表名称
DataType | getType() 获取扩展字段类型对象
java.lang.String | getTypeDesc()
java.lang.String | getTypeName() 获取扩展字段类型名称
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库，重载WCMObj接口
boolean | isNullable() 判断扩展字段是否允许为空
boolean | isValid() 检查数据的有效性
boolean | setAttribute(java.lang.String _attribute) 设置扩展字段的扩展属性
boolean | setDesc(java.lang.String _sDesc) 设置扩展字段描述信息
boolean | setName(java.lang.String _sName) 设置扩展字段名称
boolean | setTableName(java.lang.String _tableName) 设置扩展字段所属数据表名称
boolean | setType(java.lang.String _typeName, int _maxLength)
boolean | setType(java.lang.String _typeName, int _maxLength, boolean _bNullable, java.lang.String _sDefaultValue) 设置扩展字段数据类型
boolean | setType(java.lang.String _typeName, int _maxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象所对应的ID字段名

另请参见：
常量字段值
构造方法详细信息

ExtendedField

public ExtendedField()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
对象所对应的数据表名

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象所对应的数据表名（String）

getIdFieldName

public java.lang.String getIdFieldName()
对象所对应的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getTableName

public java.lang.String getTableName()
扩展字段所属数据表名称

返回：

setTableName

public boolean setTableName(java.lang.String _tableName)
                     throws WCMException
设置扩展字段所属数据表名称

参数：
_tableName - 扩展字段所属数据表名称
返回：
设置成功返回true;否则返回false
抛出：
WCMException

getName

public java.lang.String getName()
扩展字段名称

返回：
扩展字段名称（String）

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置扩展字段名称

参数：
_sName - 扩展字段名称
返回：
设置成功返回true;否则返回false
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获得扩展字段描述信息

返回：
扩展字段描述信息（String）

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置扩展字段描述信息

参数：
_sDesc - 扩展字段描述信息
返回：
设置成功返回true;否则返回false
抛出：
WCMException

getTypeName

public java.lang.String getTypeName()
获取扩展字段类型名称

返回：
扩展字段类型名称

getTypeDesc

public java.lang.String getTypeDesc()
                             throws WCMException
返回：
抛出：
WCMException

getType

public DataType getType()
                 throws WCMException
获取扩展字段类型对象

返回：
扩展字段类型对象（com.trs.util.database.DataType）
抛出：
WCMException

getMaxLength

public int getMaxLength()
获得扩展字段最大长度

返回：
扩展字段最大长度（int）

getScale

public int getScale()

isNullable

public boolean isNullable()
判断扩展字段是否允许为空

返回：
如果扩展字段允许为空则返回true,否则返回false

getDefaultValue

public java.lang.String getDefaultValue()
获取扩展字段的默认值

返回：
扩展字段的默认值（String）

getDefaultValueAsInt

public int getDefaultValueAsInt(int _default)
                         throws WCMException
取整型默认值

参数：
_default - 当设定的默认值为空时，默认的返回值
返回：
整型默认值
抛出：
WCMException

setType

public boolean setType(java.lang.String _typeName,
                       int _maxLength)
                throws WCMException
参数：
_typeName -
_maxLength -
返回：
设置成功返回true;否则返回false
抛出：
WCMException

setType

public boolean setType(java.lang.String _typeName,
                       int _maxLength,
                       boolean _bNullable,
                       java.lang.String _sDefaultValue)
                throws WCMException
设置扩展字段数据类型

参数：
_typeName - 数据类型名称
_maxLength - 最大长度
_bNullable - 是否允许为空，可缺省（默认值为true）
_sDefaultValue - 默认值，可缺省（默认值为null） 说明：仅当_bNullable=false时候，_sDefaultValue有效。
返回：
设置成功返回true;否则返回false
抛出：
WCMException

setType

public boolean setType(java.lang.String _typeName,
                       int _maxLength,
                       boolean _bNullable,
                       java.lang.String _sDefaultValue,
                       int _nScale)
                throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
获得扩展字段的扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：
扩展字段的扩展属性（String）

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
设置扩展字段的扩展属性

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展字段的扩展属性
返回：
设置成功返回true;否则返回false
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
如果有效返回true;否则返回false
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库，重载WCMObj接口

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

delete

public int delete(User _currUser)
           throws WCMException
删除扩展字段对象，重载父类接口：删除该对象之前，必须确保无任何频道使用该字段

覆盖：
类 CMSObj 中的 delete
参数：
_currUser -
返回：
抛出：
WCMException

findById

public static final ExtendedField findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ExtendedField createNewInstance()
                                             throws WCMException
产生当前对象[ExtendedField]的实例

返回：
当前对象的实例[ExtendedField]
抛出：
WCMException

findByKey

public static final ExtendedField findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

equals

public boolean equals(java.lang.Object obj)
从类 BaseObj 复制的描述
判定本对象是否与指定对象相同

覆盖：
类 BaseObj 中的 equals
参数：
obj - 指定对象
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExtendedFields

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 ExtendedFields

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.content.ExtendedFields

public class ExtendedFields
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ExtendedFields(User _currUser)
ExtendedFields(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static ExtendedFields | createNewInstance(User _currUser) 产生当前集合对象[ExtendedFields]的实例
static ExtendedFields | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 获得扩展字段对象的Class
java.lang.String | getIdFieldName() 获得扩展字段所对应的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ExtendedFields | openWCMObjs(User _currUser, WCMFilter _filter)
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExtendedFields

public ExtendedFields(User _currUser)

ExtendedFields

public ExtendedFields(User _currUser,
                      int initialCapacity,
                      int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
获得扩展字段所对应的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
扩展字段所对应的ID字段名（String）

getElementClass

public java.lang.Class getElementClass()
获得扩展字段对象的Class

指定者：
类 BaseObjs 中的 getElementClass
返回：
ExtendedField.class

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象WCMBaseObjs，通过强制可转换为ExtendedFields对象
抛出：
java.lang.Exception

openWCMObjs

public static ExtendedFields openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
抛出：
WCMException

findByIds

public static final ExtendedFields findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ExtendedFields）
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static ExtendedFields createNewInstance(User _currUser)
产生当前集合对象[ExtendedFields]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLContent

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 HTMLContent

java.lang.Object
    继承者  com.trs.cms.content.HTMLContent

public class HTMLContent
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
HTMLContent(java.lang.String _sContent)
方法摘要
static java.lang.String | getBodyContent(java.lang.String _sHTMLContent)
java.util.List | getFiles() 获取HTML内容中的所有文件
java.util.List | getWCMFiles() 获取HTML内容中的WCM文件
static void | main(java.lang.String[] args)
java.lang.String | parseHTMLContent(java.lang.String _sImgSrcPre)
java.lang.String | parseHTMLContentWihtMultImgPre(java.lang.String[] _pImgSrcPre)
static java.lang.String | saveHtmlContent(java.lang.String _sHTMLContent)
static java.lang.String | saveHtmlContent(java.lang.String _sHTMLContent, boolean _bRecopyAllPics, boolean _bDownloadA)
static java.lang.String | saveHTMLContentFromOut(java.lang.String _sHTMLContent, java.util.HashMap _hmOutFile) 以外部资源为Src，保存HTMLContent中的资源
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLContent

public HTMLContent(java.lang.String _sContent)
方法详细信息

getFiles

public java.util.List getFiles()
                        throws WCMException
获取HTML内容中的所有文件

返回：
抛出：
WCMException

getWCMFiles

public java.util.List getWCMFiles()
                           throws WCMException
获取HTML内容中的WCM文件

返回：
抛出：
WCMException

parseHTMLContent

public java.lang.String parseHTMLContent(java.lang.String _sImgSrcPre)
                                  throws WCMException
参数：
_sImgSrcPre -
返回：
抛出：
WCMException

parseHTMLContentWihtMultImgPre

public java.lang.String parseHTMLContentWihtMultImgPre(java.lang.String[] _pImgSrcPre)
                                                throws WCMException
抛出：
WCMException

saveHtmlContent

public static java.lang.String saveHtmlContent(java.lang.String _sHTMLContent)
                                        throws WCMException
抛出：
WCMException

saveHtmlContent

public static java.lang.String saveHtmlContent(java.lang.String _sHTMLContent,
                                               boolean _bRecopyAllPics,
                                               boolean _bDownloadA)
                                        throws WCMException
抛出：
WCMException

saveHTMLContentFromOut

public static java.lang.String saveHTMLContentFromOut(java.lang.String _sHTMLContent,
                                                      java.util.HashMap _hmOutFile)
                                               throws WCMException
以外部资源为Src，保存HTMLContent中的资源

参数：
_sHTMLContent - 需要保存的HTML内容
_hmOutFile - 外部资源（key为小写的没有后缀名的文件名，value为绝对地址）
返回：
抛出：
WCMException

getBodyContent

public static java.lang.String getBodyContent(java.lang.String _sHTMLContent)
                                       throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICMSObjSubstanceContent

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
接口 ICMSObjSubstanceContent

所有已知子接口：
IFlowContent, IPublishContent, IPublishElement, IPublishFolder, IRightHost, IRightObj
所有已知实现类：
ChannelRightHostImpl, ChannelRightObjImpl, ChannelSubstanceImplBase, DocumentRightHostImpl, DocumentSubstanceImplBase, EpressFolderWrapper, FlowContentApplyFormImpl, FlowContentDocumentImpl, GroupRightObjImpl, MyFlowContentDocumentImpl, PublishContentDefaultObjImpl, PublishContentDocumentImpl, PublishContentImplBase, PublishContentViewDataImpl, PublishContentViewFieldImpl, PublishContentViewImpl, PublishContentWrapper, PublishElementWrapper, PublishFolderChannelImpl, PublishFolderClassImpl, PublishFolderImplBase, PublishFolderWebSiteImpl, PublishFolderWrapper, RightHostInfoViewField, RightHostInfoViewGroup, RightHostInfoViewView, TemplateRightObjImpl, WebSiteRightHostImpl, WebSiteRightObjImpl, WebSiteSubstanceImplBase
public interface ICMSObjSubstanceContent

Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce

方法详细信息

getType

int getType()
Returns the publish content type.

返回：
the publish content type

getId

int getId()
Returns the publish content id.

返回：
the publish content id

getSubstance

CMSObj getSubstance()
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj

setSubstance

void setSubstance(CMSObj _cmsObj)
Sets the substantce

参数：
_cmsObj - a CMS object

getInfo

java.lang.String getInfo()
Gets the information of the folder.

返回：
the information of the folder

loadById

boolean loadById(int _nId)
                 throws WCMException
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
java.lang.Exception - if the content is not found or failes to load data.
WCMException

makeFrom

void makeFrom(CMSObj _cmsObj)
              throws WCMException
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImgRec

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 ImgRec

java.lang.Object
    继承者  com.trs.cms.content.ImgRec

public class ImgRec
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
从DocMgr中的setHtmlContent中提出来的一个类，目前方法都是公有的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
int | oldId
java.lang.String | oldSrc
java.lang.String | pubSrc
java.lang.String | src
构造方法摘要
ImgRec()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

src

public java.lang.String src

oldSrc

public java.lang.String oldSrc

pubSrc

public java.lang.String pubSrc

oldId

public int oldId
构造方法详细信息

ImgRec

public ImgRec()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Locker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 Locker

java.lang.Object
    继承者  com.trs.cms.content.Locker

public class Locker
extends java.lang.Object

字段摘要
static int DEF_LOCKTIMEOUT
默认锁定时间为20分钟 20*60=1200
构造方法摘要
Locker()
方法摘要
int | getLockTimeOut() 获取锁定的有效时间，单位：秒；0 值表示永远锁定
User | getLockUser() 获取锁定的用户
boolean | isLocked() 检测当前是否已经锁定； 注意：如果上次加锁超时，自动解锁
boolean | isTimeOut() 判断锁定在当前时间是否失效
boolean | isTimeOut(java.util.Date _dNow) 判断锁定在指定时间内是否失效
boolean | lock(User _lockUser) 指定用户在默认的锁定时间内锁定对象
boolean | lock(User _lockUser, int _lockTimeOut) 指定用户在指定的时间内锁定对象
boolean | lockUserIs(User _user) 判断指定用户是否为锁定人
java.lang.String | toString()
boolean | unlock() 强制解锁
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEF_LOCKTIMEOUT

public static int DEF_LOCKTIMEOUT
默认锁定时间为20分钟 20*60=1200

构造方法详细信息

Locker

public Locker()
方法详细信息

getLockUser

public User getLockUser()
获取锁定的用户

返回：
锁定的用户(User)

getLockTimeOut

public int getLockTimeOut()
获取锁定的有效时间，单位：秒；0 值表示永远锁定

返回：
锁定的有效时间，单位：秒；0 值表示永远锁定

lockUserIs

public boolean lockUserIs(User _user)
判断指定用户是否为锁定人

参数：
_user - 指定用户
返回：
如果为锁定用户，返回true；否则返回false

isLocked

public boolean isLocked()
检测当前是否已经锁定； 注意：如果上次加锁超时，自动解锁

返回：
如果已经锁定，返回true；否则返回false

isTimeOut

public boolean isTimeOut()
判断锁定在当前时间是否失效

返回：
如果失效，返回true；否则返回false

isTimeOut

public boolean isTimeOut(java.util.Date _dNow)
判断锁定在指定时间内是否失效

参数：
_dNow - 指定的时间（CMyDateTime）可忽略，默认值为当前时间
返回：
如果失效，返回true；否则返回false

lock

public boolean lock(User _lockUser)
指定用户在默认的锁定时间内锁定对象

参数：
_lockUser - 锁定用户
返回：
加锁成功，返回true；否则，返回false.

lock

public boolean lock(User _lockUser,
                    int _lockTimeOut)
指定用户在指定的时间内锁定对象

参数：
_lockUser - 锁定用户（User）
_lockTimeOut - 锁定的时间，单位：秒；0 值表示永远锁定
返回：
锁定成功返回true;否则返回false

unlock

public boolean unlock()
强制解锁

返回：
解锁成功返回false

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LockerMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 LockerMgr

java.lang.Object
    继承者  com.trs.cms.content.LockerMgr

public class LockerMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LockerMgr()
方法摘要
void | freeLockedObjBy(User _currUser) 释放所有由特定用户锁定的对象.
java.lang.String | getLockedObjIds(int _nObjType) 获取已被锁定的对象id序列
Locker | getLocker(CMSObj _obj, boolean _bCreateWhenNotExists) 取指定WCMObj对象的加锁对象
Locker | getLocker(int _nObjType, int _nObjId, boolean _bCreateWhenNotExists)
Locker | removeLocker(CMSObj _obj) 从缓冲区中移去指定WCMObj对象的Locker
Locker | removeLocker(int _nObjType, int _nObjId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LockerMgr

public LockerMgr()
方法详细信息

getLocker

public Locker getLocker(CMSObj _obj,
                        boolean _bCreateWhenNotExists)
取指定WCMObj对象的加锁对象

参数：
_obj - 指定WCMObj对象
_bCreateWhenNotExists - 指定当Locker对象不存在时，是否创建
返回：

getLocker

public Locker getLocker(int _nObjType,
                        int _nObjId,
                        boolean _bCreateWhenNotExists)

removeLocker

public Locker removeLocker(CMSObj _obj)
从缓冲区中移去指定WCMObj对象的Locker

参数：
_obj - 指定的WCMObj对象
返回：

removeLocker

public Locker removeLocker(int _nObjType,
                           int _nObjId)

getLockedObjIds

public java.lang.String getLockedObjIds(int _nObjType)
获取已被锁定的对象id序列

参数：
_nObjType - 指定的对象类型,如 Document.OBJ_TYPE
返回：
以字符','分隔的字符串

freeLockedObjBy

public void freeLockedObjBy(User _currUser)
释放所有由特定用户锁定的对象.
在session失效时使用.

参数：
_currUser - 指定的用户,将释放所有由该用户锁定的对象.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LockManager

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 LockManager

java.lang.Object
    继承者  com.trs.cms.content.LockManager

public class LockManager
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
群锁管理 (依赖数据库实现)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

方法摘要
void | freeLockedObjBy(User _currUser) 释放所有由特定用户锁定的对象.
java.lang.String | getLockedObjIds(int _nObjType) 获取已被锁定的对象id序列
Locker | getLocker(CMSObj _obj, boolean _bCreateWhenNotExists) 取指定WCMObj对象的加锁对象
Locker | getLocker(int _nObjType, int _nObjId, boolean _bCreateWhenNotExists)
static LockManager | instance()
Locker | removeLocker(CMSObj _obj) 从缓冲区中移去指定WCMObj对象的Locker
Locker | removeLocker(int _nObjType, int _nObjId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

instance

public static LockManager instance()

getLocker

public Locker getLocker(CMSObj _obj,
                        boolean _bCreateWhenNotExists)
取指定WCMObj对象的加锁对象

参数：
_obj - 指定WCMObj对象
_bCreateWhenNotExists - 指定当Locker对象不存在时，是否创建
返回：

getLocker

public Locker getLocker(int _nObjType,
                        int _nObjId,
                        boolean _bCreateWhenNotExists)

removeLocker

public Locker removeLocker(CMSObj _obj)
从缓冲区中移去指定WCMObj对象的Locker

参数：
_obj - 指定的WCMObj对象
返回：

removeLocker

public Locker removeLocker(int _nObjType,
                           int _nObjId)

freeLockedObjBy

public void freeLockedObjBy(User _currUser)
释放所有由特定用户锁定的对象.
通常在session失效时使用.

参数：
_currUser - 指定的用户,将释放所有由该用户锁定的对象.

getLockedObjIds

public java.lang.String getLockedObjIds(int _nObjType)
获取已被锁定的对象id序列

参数：
_nObjType - 指定的对象类型,如 Document.OBJ_TYPE
返回：
以字符','分隔的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.content
接口
ICMSObjSubstanceContent
类
ClusterLocker
CMSBaseObjs
CMSObj
CMSObjDefaultImpl
DefaultObj
DefaultObjs
ExtendedField
ExtendedFields
HTMLContent
ImgRec
Locker
LockerMgr
LockManager
WCMHandler
WCMObjHelper
WCMObjsHandler
WCMSystemObject


com.trs.cms.content

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.content

接口摘要
ICMSObjSubstanceContent Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
ClusterLocker | Title: TRS 内容协作平台（TRS WCM） Description: 集群对象锁定 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
CMSBaseObjs |
CMSObj |
CMSObjDefaultImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DefaultObj |
DefaultObjs |
ExtendedField |
ExtendedFields |
HTMLContent | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImgRec | Title: TRS 内容协作平台（TRS WCM） Description: TODO 从DocMgr中的setHtmlContent中提出来的一个类，目前方法都是公有的 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Locker |
LockerMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LockManager | Title: TRS 内容协作平台（TRS WCM） Description: 群锁管理 (依赖数据库实现) Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
WCMHandler | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMObjHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMObjsHandler | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMSystemObject | Title: TRS 内容协作平台（TRS WCM） Description: 系统级虚对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.cms.content 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.content 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.cms.content.CMSObjDefaultImpl
        • com.trs.cms.content.DefaultObj
        • com.trs.cms.content.ExtendedField
        • com.trs.cms.content.WCMSystemObject
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.cms.content.DefaultObjs
        • com.trs.cms.content.ExtendedFields
    • com.trs.cms.content.ClusterLocker
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.trs.cms.content.WCMHandler
      • com.trs.cms.content.WCMObjsHandler
    • com.trs.cms.content.HTMLContent
    • com.trs.cms.content.ImgRec
    • com.trs.cms.content.Locker
    • com.trs.cms.content.LockerMgr
    • com.trs.cms.content.LockManager
    • com.trs.cms.content.WCMObjHelper

接口分层结构

  • com.trs.cms.content.ICMSObjSubstanceContent


软件包 com.trs.cms.content 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.content
的使用

使用 com.trs.cms.content 的软件包
com.trs.ajaxservice |
com.trs.ajaxservice.xmlconvertors |
com.trs.cms.auth |
com.trs.cms.auth.domain |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.process |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.cms.process.xml |
com.trs.components.comment.persistent |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.domain.auth |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.gkml.sqgk.process.element |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.definition |
com.trs.components.metadata.publish |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.auth |
com.trs.components.wcm.channel |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.process.element |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.media |
com.trs.presentation.nav |
com.trs.presentation.right |
com.trs.presentation.util |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.config |
com.trs.wcm.old |
com.trs.wcm.photo |

com.trs.ajaxservice 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj
ExtendedFields

com.trs.ajaxservice.xmlconvertors 使用的 com.trs.cms.content 中的类
CMSObj

com.trs.cms.auth 使用的 com.trs.cms.content 中的类
CMSObj

com.trs.cms.auth.domain 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.cms.content 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj
DefaultObj
DefaultObjs
ExtendedField
ExtendedFields
Locker
LockManager
Title: TRS 内容协作平台（TRS WCM）
Description:
群锁管理 (依赖数据库实现)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.cms.process 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.cms.process.engine 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.cms.process.xml 使用的 com.trs.cms.content 中的类
CMSObj

com.trs.components.comment.persistent 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.address 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.bookmark 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.calendar 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.conjection.persistent 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.job 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.message 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.publish.domain.auth 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.distribute 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.publish.persistent.element 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj
DefaultObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.publisher 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.publish.persistent.taskdispatch 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.publish.persistent.template 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.publish.widget 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.publish.widget.tagparser 使用的 com.trs.cms.content 中的类
CMSObj

com.trs.components.common.trsad 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.common.trsvote 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.gkml.sqgk.persistent 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.helper 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.infoview.persistent 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.metadata.center 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.metadata.definition 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.metadata.publish 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.special 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.stat 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.auth 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.channel 使用的 com.trs.cms.content 中的类
WCMSystemObject
Title: TRS 内容协作平台（TRS WCM）
Description:
系统级虚对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.content.domain 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.content.domain.auth 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.customize 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.epress 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.individuation 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.process.element 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.publish.element 使用的 com.trs.cms.content 中的类
CMSObj
ICMSObjSubstanceContent
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.logo 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.publish.region 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.recent 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.resource 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.stat 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.wcmx.help 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.components.wcm.wcmx.media 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.presentation.nav 使用的 com.trs.cms.content 中的类
CMSObj

com.trs.presentation.right 使用的 com.trs.cms.content 中的类
CMSObj

com.trs.presentation.util 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.service 使用的 com.trs.cms.content 中的类
CMSObj

com.trs.service.impl 使用的 com.trs.cms.content 中的类
CMSObj

com.trs.wcm.config 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.wcm.old 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

com.trs.wcm.photo 使用的 com.trs.cms.content 中的类
CMSBaseObjs
CMSObj

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 WCMHandler

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
        继承者  com.trs.cms.content.WCMHandler
所有已实现的接口：
org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class WCMHandler
extends org.xml.sax.helpers.DefaultHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMHandler(CMSObj _obj)
方法摘要
void | characters(char[] ch, int start, int length)
void | endElement(java.lang.String uri, java.lang.String localName, java.lang.String qName)
CMSObj | getWCMObj()
void | startElement(java.lang.String uri, java.lang.String localName, java.lang.String qName, org.xml.sax.Attributes attributes)
从类 org.xml.sax.helpers.DefaultHandler 继承的方法
endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMHandler

public WCMHandler(CMSObj _obj)
方法详细信息

startElement

public void startElement(java.lang.String uri,
                         java.lang.String localName,
                         java.lang.String qName,
                         org.xml.sax.Attributes attributes)
指定者：
接口 org.xml.sax.ContentHandler 中的 startElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 startElement

characters

public void characters(char[] ch,
                       int start,
                       int length)
指定者：
接口 org.xml.sax.ContentHandler 中的 characters
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 characters

endElement

public void endElement(java.lang.String uri,
                       java.lang.String localName,
                       java.lang.String qName)
                throws org.xml.sax.SAXException
指定者：
接口 org.xml.sax.ContentHandler 中的 endElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 endElement
抛出：
org.xml.sax.SAXException

getWCMObj

public CMSObj getWCMObj()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMObjHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 WCMObjHelper

java.lang.Object
    继承者  com.trs.cms.content.WCMObjHelper

public class WCMObjHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMObjHelper()
方法摘要
static java.lang.String | concatProperties(BaseObjs _oCurrBaseObjs, java.lang.String _sPropertyName) 将WCMObjects中的指定属性转换为以逗号隔开的字符串序列
static java.lang.String | concatProperties(BaseObjs _oCurrBaseObjs, java.lang.String _sPropertyName, java.lang.String _sDelim) 将WCMObjects中的指定属性转换为以逗号隔开的字符串序列
static java.lang.String | toIdsString(java.util.List _arWCMObj) 将WCMObj数组转换为以逗号隔开的Id序列
static java.lang.String | toIdsString(java.util.List _arWCMObj, java.lang.String _sDelim) 将WCMObj数组转换为Id序列
static CMSObj | toWCMObj(java.lang.String _sWCMObjXMLContent, CMSObj _oWCMObj) 解析传入的XML内容，生成传入WCMOBJ对象。
static CMSObj | toWCMObj(java.lang.String _sWCMObjXMLContent, User _loginUser, int _nObjId, java.lang.Class _oWCMObjClass) 解析传入的XML内容，生成传入WCMOBJ对象。
static java.util.List | toWCMObjList(java.lang.String _sWCMObjsXMLContent, CMSObj _obj, User _loginUser) 解析传入的XML内容，生成包含指定类型WCMObj的List。
static void | unlock(int _nObjType, int _nObjId, User _unlockerUser) 指定的用户给指定的对象解锁
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMObjHelper

public WCMObjHelper()
方法详细信息

toWCMObj

public static CMSObj toWCMObj(java.lang.String _sWCMObjXMLContent,
                              CMSObj _oWCMObj)
                       throws WCMException
解析传入的XML内容，生成传入WCMOBJ对象。

参数：
_sWCMObjXMLContent - 指定的XML内容，如这样的格式，XML中的属性必须和数据表保持一致
_oWCMObj - 指定的WCMObj对象
返回：
根据XML构造的WCMOBJ
样本：
<WCMOBJ>
    <PROPERTIES>
        <DOCID>0</DOCID>
        <DOCCHANNEL>62</DOCCHANNEL>
        <DOCTITLE><![CDATA[fdfsda]]></DOCTITLE>
        <DOCRELTIME><![CDATA[2004-12-21]]></DOCRELTIME>
        <DOCKEYWORDS><![CDATA[dfa]]></DOCKEYWORDS>
        <DOCRELWORDS><![CDATA[dffasd]]></DOCRELWORDS>
        <DOCABSTRACT><![CDATA[dsasfdasf]]></DOCABSTRACT>
        <DOCCONTENT><![CDATA[dfasd]]></DOCCONTENT>
    </PROPERTIES>
</WCMOBJ>
抛出：
WCMException

toWCMObj

public static CMSObj toWCMObj(java.lang.String _sWCMObjXMLContent,
                              User _loginUser,
                              int _nObjId,
                              java.lang.Class _oWCMObjClass)
                       throws WCMException
解析传入的XML内容，生成传入WCMOBJ对象。

参数：
_sWCMObjXMLContent - 指定的XML内容，如这样的格式，XML中的属性必须和数据表保持一致
_loginUser - 当前操作的用户
_nObjId - 对象ID， <=0表示为新增的对象，>0表示修改对象
_oWCMObjClass - 对象Class
返回：
设置完属性的WCMObj
抛出：
WCMException - XML数据格式不对或者对象已经被锁定会抛出异常
用例[保存文档]：
int nAppendixId = 1;
aAppendix = (Appendix)WCMObjHelper.toWCMObj(sXML, loginUser, nAppendixId, Appendix.class);
XML的格式：
<?xml version="1.0" encoding="GBK"?>
<WCMAPPENDIX Version="5.1">
<PROPERTIES>
<APPSERN>-1</APPSERN>
<APPENDIXID>1</APPENDIXID>
<APPFILETYPE>-1</APPFILETYPE>
<APPFLAG>30</APPFLAG>
<CRTIME>2002-08-12 22:39:37</CRTIME>
<CRUSER><![CDATA[system]]></CRUSER>
<USEDVERSIONS>1</USEDVERSIONS>
<APPDOCID>618</APPDOCID>
<APPFILE><![CDATA[W020020812815778615145.jpg]]></APPFILE>
<APPTIME>
</APPTIME>
</PROPERTIES>
</WCMAPPENDIX>

toWCMObjList

public static java.util.List toWCMObjList(java.lang.String _sWCMObjsXMLContent,
                                          CMSObj _obj,
                                          User _loginUser)
                                   throws java.lang.Exception
解析传入的XML内容，生成包含指定类型WCMObj的List。

参数：
_sWCMObjsXMLContent - 传入的XML内容
_obj - 指定的WCMObj
返回：
包含指定类型WCMObj的List。
抛出：
java.lang.Exception - XML数据格式不对或者对象已经被锁定会抛出异常
用例[产生一个附件List]：
List arResult = WCMObjHelper.toWCMObjList(sXML, Appendix.createNewInstance(), "WCMAPPENDIX", loginUser);

//3.查看结果
for(int i=0; i<arResult.size(); i++){
WCMObj currObj = (WCMObj)arResult.get(i);
logger.debug("第["+(i+1)+"]条记录" + currObj.getProperties());
}

toIdsString

public static java.lang.String toIdsString(java.util.List _arWCMObj)
将WCMObj数组转换为以逗号隔开的Id序列

参数：
_arWCMObj - WCMObj数组
返回：
以逗号隔开的Id序列

toIdsString

public static java.lang.String toIdsString(java.util.List _arWCMObj,
                                           java.lang.String _sDelim)
将WCMObj数组转换为Id序列

参数：
_arWCMObj - WCMObj数组
_sDelim - ID序列分隔符
返回：
以指定分隔符隔开的ID序列

concatProperties

public static java.lang.String concatProperties(BaseObjs _oCurrBaseObjs,
                                                java.lang.String _sPropertyName)
将WCMObjects中的指定属性转换为以逗号隔开的字符串序列

参数：
_oCurrBaseObjs - 需要处理的集合
_sPropertyName - 需要连接的属性
返回：

concatProperties

public static java.lang.String concatProperties(BaseObjs _oCurrBaseObjs,
                                                java.lang.String _sPropertyName,
                                                java.lang.String _sDelim)
将WCMObjects中的指定属性转换为以逗号隔开的字符串序列

参数：
_oCurrBaseObjs - 需要处理的集合
_sPropertyName - 需要连接的属性
_sDelim - 分隔符
返回：

unlock

public static void unlock(int _nObjType,
                          int _nObjId,
                          User _unlockerUser)
                   throws WCMException,
                          CMyException
指定的用户给指定的对象解锁

参数：
_nObjType - 指定对象类型
_nObjId - 指定对象的ID
_unlockerUser - 解锁用户
抛出：
WCMException - 如果锁定用户和解锁用户不一致，抛出异常！
CMyException
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMObjsHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 WCMObjsHandler

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
        继承者  com.trs.cms.content.WCMObjsHandler
所有已实现的接口：
org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class WCMObjsHandler
extends org.xml.sax.helpers.DefaultHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMObjsHandler(CMSObj _obj)
WCMObjsHandler(CMSObj _obj, java.lang.String _sTagName)
方法摘要
void | characters(char[] ch, int start, int length)
void | endElement(java.lang.String uri, java.lang.String localName, java.lang.String qName)
java.util.List | getWCMObjList()
void | startElement(java.lang.String uri, java.lang.String localName, java.lang.String qName, org.xml.sax.Attributes attributes)
从类 org.xml.sax.helpers.DefaultHandler 继承的方法
endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMObjsHandler

public WCMObjsHandler(CMSObj _obj,
                      java.lang.String _sTagName)

WCMObjsHandler

public WCMObjsHandler(CMSObj _obj)
方法详细信息

startElement

public void startElement(java.lang.String uri,
                         java.lang.String localName,
                         java.lang.String qName,
                         org.xml.sax.Attributes attributes)
指定者：
接口 org.xml.sax.ContentHandler 中的 startElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 startElement

characters

public void characters(char[] ch,
                       int start,
                       int length)
指定者：
接口 org.xml.sax.ContentHandler 中的 characters
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 characters

endElement

public void endElement(java.lang.String uri,
                       java.lang.String localName,
                       java.lang.String qName)
                throws org.xml.sax.SAXException
指定者：
接口 org.xml.sax.ContentHandler 中的 endElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 endElement
抛出：
org.xml.sax.SAXException

getWCMObjList

public java.util.List getWCMObjList()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMSystemObject

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.content
类 WCMSystemObject

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.content.WCMSystemObject
所有已实现的接口：
java.lang.Cloneable
public class WCMSystemObject
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
系统级虚对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int OBJ_TYPE
构造方法摘要
WCMSystemObject(int _nId)
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值
构造方法详细信息

WCMSystemObject

public WCMSystemObject(int _nId)
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.content.ClusterLocker 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.ClusterLocker
的使用

没有 com.trs.cms.content.ClusterLocker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.CMSBaseObjs 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.CMSBaseObjs
的使用

使用 CMSBaseObjs 的软件包
com.trs.ajaxservice |
com.trs.cms.auth.domain |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.components.comment.persistent |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.definition |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.customize |
com.trs.components.wcm.individuation |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.media |
com.trs.presentation.util |
com.trs.wcm.config |
com.trs.wcm.old |
com.trs.wcm.photo |

com.trs.ajaxservice 中 CMSBaseObjs 的使用

com.trs.ajaxservice 中 CMSBaseObjs 的子类
 class ContentExtendValues
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 CMSBaseObjs 的 com.trs.ajaxservice 中的方法
static PageOperators PageOperatorsForServiceHelper.makeCMSBaseObjsOpertators(User _loginUser, java.lang.String _sObjectIds, CMSBaseObjs _objects)

com.trs.cms.auth.domain 中 CMSBaseObjs 的使用

参数类型为 CMSBaseObjs 的 com.trs.cms.auth.domain 中的方法
static boolean AuthServer.hasRightInObjects(User _currUser, CMSBaseObjs _objects, int _index)

com.trs.cms.auth.persistent 中 CMSBaseObjs 的使用

com.trs.cms.auth.persistent 中 CMSBaseObjs 的子类
class | GroupRoles
class | Groups
class | GroupUsers Title: TRS 内容协作平台（TRS WCM） Description: 组织用户关联对象集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectMembers
class | RightDefs
class | Rights
class | Roles
class | RoleUsers Title: TRS 内容协作平台（TRS WCM） Description: 角色/用户关联对象集合的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TrusteeInfos
class | Users

com.trs.cms.content 中 CMSBaseObjs 的使用

com.trs.cms.content 中 CMSBaseObjs 的子类
class | DefaultObjs
class | ExtendedFields

返回 CMSBaseObjs 的 com.trs.cms.content 中的方法
static CMSBaseObjs | CMSBaseObjs.createInstance(User _currUser, java.lang.Class _classObjs) 产生指定集合对象的实例
static CMSBaseObjs | CMSBaseObjs.createInstance(User _currUser, java.lang.String _sObjsClassName) 产生指定集合对象的实例
static CMSBaseObjs | CMSBaseObjs.findWCMObjsByIds(User _currUser, java.lang.Class _classObjs, java.lang.String _sObjIds)
static CMSBaseObjs | CMSBaseObjs.findWCMObjsByIds(User _currUser, java.lang.String _sObjsClassName, java.lang.String _sObjIds) 根据ID序列获取一个指定的集合
static CMSBaseObjs | CMSBaseObjs.openWCMObjs(User _currUser, java.lang.Class _objsClass, WCMFilter _filter) 根据指定的Filter打开指定的集合
static CMSBaseObjs | CMSBaseObjs.openWCMObjs(User _currUser, java.lang.String _sObjsClassName, WCMFilter _filter) 根据指定的Filter打开指定的集合

com.trs.cms.process.definition 中 CMSBaseObjs 的使用

com.trs.cms.process.definition 中 CMSBaseObjs 的子类
class | FlowActions
class | FlowConditions
class | FlowdocLogs
class | FlowEmploys
class | FlowNodeBranchs
class | FlowNodeFields
class | FlowNodes
class | FlowRules
class | Flows

com.trs.cms.process.engine 中 CMSBaseObjs 的使用

com.trs.cms.process.engine 中 CMSBaseObjs 的子类
class | FlowContentConfigs
class | FlowDocBaks
class | FlowDocs

com.trs.components.comment.persistent 中 CMSBaseObjs 的使用

com.trs.components.comment.persistent 中 CMSBaseObjs 的子类
class | DocumentTopics
class | TopicedDocRelations

com.trs.components.common.address 中 CMSBaseObjs 的使用

com.trs.components.common.address 中 CMSBaseObjs 的子类
class | ContactGrps Title: TRS 内容协作平台（TRS WCM） Description: 联系人组集合对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Contacts Title: TRS 内容协作平台（TRS WCM） Description: 联系人集合对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.bookmark 中 CMSBaseObjs 的使用

com.trs.components.common.bookmark 中 CMSBaseObjs 的子类
class | BookMarks
class | MarkKinds
class | MarkShares

参数类型为 CMSBaseObjs 的 com.trs.components.common.bookmark 中的方法
void | BookMarkMgr.cancelShares(int _nObjType, CMSBaseObjs _currObjs)
void | BookMarkMgr.shareTo(int _nObjType, CMSBaseObjs _currObjs, int _nViewerType, java.lang.String _sViewerIds)

com.trs.components.common.calendar 中 CMSBaseObjs 的使用

com.trs.components.common.calendar 中 CMSBaseObjs 的子类
class | Events
class | EventShares
class | EventTypes

com.trs.components.common.conjection.persistent 中 CMSBaseObjs 的使用

com.trs.components.common.conjection.persistent 中 CMSBaseObjs 的子类
 class EntryConfigs

com.trs.components.common.job 中 CMSBaseObjs 的使用

com.trs.components.common.job 中 CMSBaseObjs 的子类
class | JobWorkerTypes Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Schedules

com.trs.components.common.message 中 CMSBaseObjs 的使用

com.trs.components.common.message 中 CMSBaseObjs 的子类
class | Messages
class | MsgQueues

com.trs.components.common.publish.persistent.distribute 中 CMSBaseObjs 的使用

com.trs.components.common.publish.persistent.distribute 中 CMSBaseObjs 的子类
 class PublishDistributions

com.trs.components.common.publish.persistent.element 中 CMSBaseObjs 的使用

参数类型为 CMSBaseObjs 的 com.trs.components.common.publish.persistent.element 中的方法
static IPublishElements PublishElementFactory.makeElementsFrom(CMSBaseObjs _cmsObjs)
Makes a publish elements collection from the specified CMS objects list.

参数类型为 CMSBaseObjs 的 com.trs.components.common.publish.persistent.element 中的构造方法
PublishElementsCMSObjsImpl(CMSBaseObjs _objs)
constructor

com.trs.components.common.publish.persistent.publisher 中 CMSBaseObjs 的使用

com.trs.components.common.publish.persistent.publisher 中 CMSBaseObjs 的子类
 class FolderPublishConfigs

com.trs.components.common.publish.persistent.taskdispatch 中 CMSBaseObjs 的使用

com.trs.components.common.publish.persistent.taskdispatch 中 CMSBaseObjs 的子类
class | PublishErrorLogs
class | PublishTasks

com.trs.components.common.publish.persistent.template 中 CMSBaseObjs 的使用

com.trs.components.common.publish.persistent.template 中 CMSBaseObjs 的子类
class | TagBeans
class | TempApdRels
class | TempAppendixes
class | TemplateArguments TemplateArgument对象的集合
class | TemplateEmploys
class | TemplateQuotes
class | Templates

com.trs.components.common.publish.widget 中 CMSBaseObjs 的使用

com.trs.components.common.publish.widget 中 CMSBaseObjs 的子类
class | ContentStyles
class | Layouts
class | Masters
class | PageStyles
class | ResourceStyles
class | StyleAndResources
class | StyleItems
class | WidgetInstances
class | WidgetInstParameters
class | WidgetParameters
class | Widgets

com.trs.components.common.trsad 中 CMSBaseObjs 的使用

com.trs.components.common.trsad 中 CMSBaseObjs 的子类
class | ADComs
class | ADFilePoss
class | ADFiles
class | ADPoss
class | ADTypes

com.trs.components.common.trsvote 中 CMSBaseObjs 的使用

com.trs.components.common.trsvote 中 CMSBaseObjs 的子类
class | VoteDatas
class | VoteIPLogs
class | VoteItems
class | VoteOptions
class | Votes

com.trs.components.gkml.sqgk.persistent 中 CMSBaseObjs 的使用

com.trs.components.gkml.sqgk.persistent 中 CMSBaseObjs 的子类
class | ApplyFormDealLogs
class | ApplyForms
class | MailConfigs

com.trs.components.infoview.helper 中 CMSBaseObjs 的使用

com.trs.components.infoview.helper 中 CMSBaseObjs 的子类
 class ComplexFieldDatas

com.trs.components.infoview.persistent 中 CMSBaseObjs 的使用

com.trs.components.infoview.persistent 中 CMSBaseObjs 的子类
class | InfoViewDatas Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoViewDocuments
class | InfoViewEmploys TODO Add javadoc for InfoViewEmploys
class | InfoViewFields
class | InfoViewGroups
class | InfoViews TODO Add javadoc for InfoViews
class | InfoViewViews

com.trs.components.metadata.center 中 CMSBaseObjs 的使用

com.trs.components.metadata.center 中 CMSBaseObjs 的子类
class | ClassInfoViews
class | MetaViewDatas Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 CMSBaseObjs 的 com.trs.components.metadata.center 中的方法
 void MetaViewDatas.open(CMSBaseObjs _oSitesOrChannels, WCMFilter _extraFilter)

com.trs.components.metadata.definition 中 CMSBaseObjs 的使用

com.trs.components.metadata.definition 中 CMSBaseObjs 的子类
class | ClassInfos
class | MetaDBFields
class | MetaDBTables
class | MetaViewFields
class | MetaViews

com.trs.components.special 中 CMSBaseObjs 的使用

com.trs.components.special 中 CMSBaseObjs 的子类
 class Specials

com.trs.components.stat 中 CMSBaseObjs 的使用

com.trs.components.stat 中 CMSBaseObjs 的子类
class | BonusRules
class | ChnlDepts
class | DocumentHitsCounts
class | HostObjDomains
class | HostObjHitsCounts
class | UserLoginInfos

com.trs.components.wcm.content 中 CMSBaseObjs 的使用

com.trs.components.wcm.content 中 CMSBaseObjs 的子类
 class ViewDocuments
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档集合对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 CMSBaseObjs 的 com.trs.components.wcm.content 中的方法
 void ViewDocuments.open(CMSBaseObjs _oSitesOrChannels, WCMFilter _extraFilter)

com.trs.components.wcm.content.domain 中 CMSBaseObjs 的使用

返回 CMSBaseObjs 的 com.trs.components.wcm.content.domain 中的方法
 CMSBaseObjs ChannelMgr.getChildren(BaseChannel _oChannel, int _nChannelType, boolean _bIncludingDeletedChannel, WCMFilter _filter)

com.trs.components.wcm.content.persistent 中 CMSBaseObjs 的使用

com.trs.components.wcm.content.persistent 中 CMSBaseObjs 的子类
class | Appendixes
class | AutoBakConfigs Title: TRS 内容协作平台（TRS WCM） Description: 版本自动保存配置信息集合对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelContentLinks Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | Channels
class | ChannelSyns
class | ChnlDocs
class | ContentExtFields
class | ContentLinks
class | ContentLinkTypes
class | DocBaks
class | DocReplys
class | Documents
class | DocumentSyns Title: TRS 内容协作平台（TRS WCM） Description: 已经转发过的文档记录集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | HitsCounts
class | Relations
class | Replaces Title: TRS 内容协作平台（TRS WCM） Description: 替换内容对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | SiteMembers
class | WebSites

com.trs.components.wcm.customize 中 CMSBaseObjs 的使用

com.trs.components.wcm.customize 中 CMSBaseObjs 的子类
 class UserSettings

com.trs.components.wcm.individuation 中 CMSBaseObjs 的使用

com.trs.components.wcm.individuation 中 CMSBaseObjs 的子类
class | CustomSiteCheckedInfos
class | Individuations

com.trs.components.wcm.publish 中 CMSBaseObjs 的使用

com.trs.components.wcm.publish 中 CMSBaseObjs 的子类
 class WCMPubStatusConfigs

com.trs.components.wcm.publish.logo 中 CMSBaseObjs 的使用

com.trs.components.wcm.publish.logo 中 CMSBaseObjs 的子类
 class Logos

com.trs.components.wcm.publish.region 中 CMSBaseObjs 的使用

com.trs.components.wcm.publish.region 中 CMSBaseObjs 的子类
class | CellInfos
class | RegionEmploys
class | RegionInfos

com.trs.components.wcm.recent 中 CMSBaseObjs 的使用

com.trs.components.wcm.recent 中 CMSBaseObjs 的子类
 class Recents

com.trs.components.wcm.resource 中 CMSBaseObjs 的使用

com.trs.components.wcm.resource 中 CMSBaseObjs 的子类
class | DocKinds
class | FileTypes
class | Keywords
class | Securities
class | Sources
class | Statuses

com.trs.components.wcm.stat 中 CMSBaseObjs 的使用

com.trs.components.wcm.stat 中 CMSBaseObjs 的子类
class | StatFieldMaps
class | StatHosts
class | StatViewRels
class | StatViews

com.trs.components.wcm.wcmx.help 中 CMSBaseObjs 的使用

com.trs.components.wcm.wcmx.help 中 CMSBaseObjs 的子类
 class WCMHelps

com.trs.components.wcm.wcmx.media 中 CMSBaseObjs 的使用

com.trs.components.wcm.wcmx.media 中 CMSBaseObjs 的子类
 class MediaRemindedInfos

com.trs.presentation.util 中 CMSBaseObjs 的使用

返回 CMSBaseObjs 的 com.trs.presentation.util 中的方法
static CMSBaseObjs CmsObjUnlockTools.listLockedObjs(User _opUser, int _nObjType)

com.trs.wcm.config 中 CMSBaseObjs 的使用

com.trs.wcm.config 中 CMSBaseObjs 的子类
 class PageOperators

com.trs.wcm.old 中 CMSBaseObjs 的使用

com.trs.wcm.old 中 CMSBaseObjs 的子类
class | WCMExcelDatas Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
class | WCMFormFieldses
class | WCMFormInfos

com.trs.wcm.photo 中 CMSBaseObjs 的使用

com.trs.wcm.photo 中 CMSBaseObjs 的子类
 class Watermarks

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.CMSObj 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.CMSObj
的使用

使用 CMSObj 的软件包
com.trs.ajaxservice |
com.trs.ajaxservice.xmlconvertors |
com.trs.cms.auth |
com.trs.cms.auth.domain |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.process |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.cms.process.xml |
com.trs.components.comment.persistent |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.domain.auth |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.gkml.sqgk.process.element |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.definition |
com.trs.components.metadata.publish |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.auth |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.process.element |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.media |
com.trs.presentation.nav |
com.trs.presentation.right |
com.trs.presentation.util |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.config |
com.trs.wcm.old |
com.trs.wcm.photo |

com.trs.ajaxservice 中 CMSObj 的使用

com.trs.ajaxservice 中 CMSObj 的子类
 class ContentExtendValue
Title: TRS 内容协作平台（TRS WCM）
Description:
虚对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 CMSObj 的 com.trs.ajaxservice 中的方法
CMSObj | ExtendFieldServiceProvider.findParent(CMSObj _currObj) 根据当前对象，获取当前对象的父对象
static CMSObj | WCMAJAXServiceHelper.setWCMObjectProperties(User _loginUser, MethodContext _methodContext, CMSObj _oCMSObj, java.lang.String[] _pLogicFields) 更新指定的对象

参数类型为 CMSObj 的 com.trs.ajaxservice 中的方法
CMSObj | ExtendFieldServiceProvider.findParent(CMSObj _currObj) 根据当前对象，获取当前对象的父对象
int | ExtendFieldServiceProvider.getMaxOrder(CMSObj host)
static PageOperators | PageOperatorsForServiceHelper.makeCMSObjOpertators(User _loginUser, java.lang.String _sObjectKey, CMSObj channel)
static CMSObj | WCMAJAXServiceHelper.setWCMObjectProperties(User _loginUser, MethodContext _methodContext, CMSObj _oCMSObj, java.lang.String[] _pLogicFields) 更新指定的对象

com.trs.ajaxservice.xmlconvertors 中 CMSObj 的使用

返回 CMSObj 的 com.trs.ajaxservice.xmlconvertors 中的方法
 CMSObj[] XMLToCMSObj.getCMSObjs()

参数类型为 CMSObj 的 com.trs.ajaxservice.xmlconvertors 中的构造方法
XMLToCMSObj(User _currUser, CMSObj _oSrcInstance)

com.trs.cms.auth 中 CMSObj 的使用

参数类型为 CMSObj 的 com.trs.cms.auth 中的方法
static boolean | AuthHelper.hasRightOnSelf(User _currUser, CMSObj _objCurrent, int[] _pRightIndex)
static boolean | AuthHelper.hasSuperRight(User _currUser, CMSObj _currObj)

com.trs.cms.auth.domain 中 CMSObj 的使用

返回 CMSObj 的 com.trs.cms.auth.domain 中的方法
 CMSObj GroupRightObjImpl.getSubstance()

参数类型为 CMSObj 的 com.trs.cms.auth.domain 中的方法
boolean | ObjectMemberMgr.canOperate(CMSObj _oOperator, int _nObjType, int _nObjId)
boolean | IObjectMemberMgr.canOperate(CMSObj _currOperator, int _nObjType, int _nObjId) 判断当前操作者对于指定对象是否可操作
static java.lang.String | AuthServer.getLogicalRightValue(CMSObj _currObj, User _currOpUser, int[] _rightIndexes) 获取当前逻辑权限值，包含了继承关系
RightValue | UserMgr.getMyRightValue(CMSObj _obj) 取用户在指定对象上的操作权限值
Right | IRightMgr.getRight(CMSObj _currObj, CMSObj _currOperator) 获取指定对象指定操作者的权限对象
Right | RightMgr.getRight(CMSObj _currObj, CMSObj _currOperator)
Rights | IRightMgr.getRights(CMSObj _currObj)
Rights | RightMgr.getRights(CMSObj _currObj)
Rights | IRightMgr.getRights(CMSObj _currObj, int _operatorType)
Rights | RightMgr.getRights(CMSObj _currObj, int _operatorType)
Rights | IRightMgr.getRights(CMSObj _currObj, java.lang.String _groupIds, java.lang.String _roleIds) 获取指定对象指定群和组织的权限对象
Rights | RightMgr.getRights(CMSObj _currObj, java.lang.String _groupIds, java.lang.String _roleIds)
static RightValue | AuthServer.getRightValue(CMSObj _currObj, CMSObj _currOperator) 获取当前操作权限值
RightValue | IRightMgr.getRightValue(CMSObj _currObj, CMSObj _currOperator)
RightValue | RightMgr.getRightValue(CMSObj _currObj, CMSObj _currOperator)
static RightValue | AuthServer.getRightValue(CMSObj _currObj, User _currOpUser) 获取当前权限值
static boolean | AuthServer.hasRight(CMSObj _operator, CMSObj _currObj, int _nRightIndex)
static boolean | AuthServer.hasRight(User _currUser, CMSObj _currObj) 判断用户对特定对象是否有“访问权限”
static boolean | AuthServer.hasRight(User _currUser, CMSObj _objCurrent, int _index) 判断当前用户对于指定的频道对象是否具有指定索引的权限
static boolean | AuthServer.hasRightOnSelf(User _currUser, CMSObj _objCurrent, int _index)
static boolean | AuthServer.hasSuperRight(User _currUser, CMSObj _currObj) Created: 2004-11-25 17:27:12 Last Modified: 2004-11-25/2004-11-25 Description: class AuthServer.java 判断当前用户是否有特权(用户是管理员,对象创建者等) wenyh
boolean | ObjectMemberMgr.isVisible(CMSObj _oOperator, int _nObjType, int _nObjId)
boolean | IObjectMemberMgr.isVisible(CMSObj _currOperator, int _nObjType, int _nObjId) 判断当前操作者对于指定对象是否可见
void | GroupRightObjImpl.makeFrom(CMSObj _cmsObj)
static IRightHost | RightHostFactory.makeRightHostFrom(CMSObj _oCMSObj)
static IRightObj | RightObjectFactory.makeRightObjectFrom(CMSObj _oCMSObj)
void | GroupRightObjImpl.setSubstance(CMSObj _cmsObj)

参数类型为 CMSObj 的 com.trs.cms.auth.domain 中的构造方法
GroupRightObjImpl(CMSObj _cmsObj)

com.trs.cms.auth.persistent 中 CMSObj 的使用

com.trs.cms.auth.persistent 中 CMSObj 的子类
class | Group
class | GroupRole
class | GroupUser
class | ObjectMember
class | Right
class | RightDef
class | Role
class | RoleUser Title: TRS 内容协作平台（TRS WCM） Description: 角色/用户关联对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TrusteeInfo
class | User Title: TRS 内容协作平台（TRS WCM） Description: 用户对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 CMSObj 的 com.trs.cms.auth.persistent 中的方法
 CMSObj Right.getOperator()
获取权限操作者对象（用户/角色）

参数类型为 CMSObj 的 com.trs.cms.auth.persistent 中的方法
RightValue | User.getMyRightValue(CMSObj _obj) 取用户在指定对象上的操作权限值
RightValue | Role.getMyRightValue(CMSObj _obj) 取角色在指定对象上的操作权限值
int | Rights.indexOf(CMSObj _operator, CMSObj _obj) 获取指定操作者对于指定对象权限在集合中的索引
boolean | Right.setObject(CMSObj _obj) 设置操作对象（WCMObj）
boolean | Right.setOperator(CMSObj _operator) 设置权限操作者对象（用户或角色） 说明：仅添加时可用

com.trs.cms.content 中 CMSObj 的使用

com.trs.cms.content 中 CMSObj 的子类
class | CMSObjDefaultImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DefaultObj
class | ExtendedField
class | WCMSystemObject Title: TRS 内容协作平台（TRS WCM） Description: 系统级虚对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 CMSObj 的 com.trs.cms.content 中的方法
CMSObj | ICMSObjSubstanceContent.getSubstance() Returns the substance object which is an instance of CMSObj.
CMSObj | WCMHandler.getWCMObj()
static CMSObj | WCMObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, CMSObj _oWCMObj) 解析传入的XML内容，生成传入WCMOBJ对象。
static CMSObj | WCMObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, User _loginUser, int _nObjId, java.lang.Class _oWCMObjClass) 解析传入的XML内容，生成传入WCMOBJ对象。

参数类型为 CMSObj 的 com.trs.cms.content 中的方法
Locker | LockManager.getLocker(CMSObj _obj, boolean _bCreateWhenNotExists) 取指定WCMObj对象的加锁对象
Locker | LockerMgr.getLocker(CMSObj _obj, boolean _bCreateWhenNotExists) 取指定WCMObj对象的加锁对象
void | ICMSObjSubstanceContent.makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
Locker | LockManager.removeLocker(CMSObj _obj) 从缓冲区中移去指定WCMObj对象的Locker
Locker | LockerMgr.removeLocker(CMSObj _obj) 从缓冲区中移去指定WCMObj对象的Locker
void | ICMSObjSubstanceContent.setSubstance(CMSObj _cmsObj) Sets the substantce
static CMSObj | WCMObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, CMSObj _oWCMObj) 解析传入的XML内容，生成传入WCMOBJ对象。
static java.util.List | WCMObjHelper.toWCMObjList(java.lang.String _sWCMObjsXMLContent, CMSObj _obj, User _loginUser) 解析传入的XML内容，生成包含指定类型WCMObj的List。

参数类型为 CMSObj 的 com.trs.cms.content 中的构造方法
ClusterLocker(User lockuser, CMSObj lockedObj)
WCMHandler(CMSObj _obj)
WCMObjsHandler(CMSObj _obj)
WCMObjsHandler(CMSObj _obj, java.lang.String _sTagName)

com.trs.cms.process 中 CMSObj 的使用

返回 CMSObj 的 com.trs.cms.process 中的方法
 CMSObj IFlowContent.getSubinstance()
获取流转内容关联的对象

参数类型为 CMSObj 的 com.trs.cms.process 中的方法
static IFlowContent | FlowContentFactory.makeFlowContent(CMSObj _substance)
void | IFlowContent.setSubinstance(CMSObj _subinstance)

com.trs.cms.process.definition 中 CMSObj 的使用

com.trs.cms.process.definition 中 CMSObj 的子类
class | Flow
class | FlowAction
class | FlowCondition
class | FlowdocLog
class | FlowEmploy
class | FlowNode
class | FlowNodeBranch
class | FlowNodeField
class | FlowRule

参数类型为 CMSObj 的 com.trs.cms.process.definition 中的方法
static FlowRules FlowRules.findOf(User _currUser, CMSObj _host)
根据Host获取相关的规则

com.trs.cms.process.engine 中 CMSObj 的使用

com.trs.cms.process.engine 中 CMSObj 的子类
class | FlowContentConfig
class | FlowDoc
class | FlowDocBak Title: TRS 内容协作平台（TRS WCM） Description: 文档流转对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 CMSObj 的 com.trs.cms.process.engine 中的方法
static IFlowContent FlowContentHelper.createFlowContent(CMSObj _subinstance)

com.trs.cms.process.xml 中 CMSObj 的使用

返回 CMSObj 的 com.trs.cms.process.xml 中的方法
 CMSObj FlowImporter.getOwner()

参数类型为 CMSObj 的 com.trs.cms.process.xml 中的方法
 void FlowImporter.setOwner(CMSObj owner)

com.trs.components.comment.persistent 中 CMSObj 的使用

com.trs.components.comment.persistent 中 CMSObj 的子类
class | DocumentTopic
class | TopicedDocRelation

com.trs.components.common.address 中 CMSObj 的使用

com.trs.components.common.address 中 CMSObj 的子类
class | Contact Title: TRS 内容协作平台（TRS WCM） Description: 联系人对象的定义及实现,用于通讯录 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContactGrp Title: TRS 内容协作平台（TRS WCM） Description: 联系入组对象的定义及实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.bookmark 中 CMSObj 的使用

com.trs.components.common.bookmark 中 CMSObj 的子类
class | BookMark
class | MarkKind
class | MarkShare

返回 CMSObj 的 com.trs.components.common.bookmark 中的方法
CMSObj | MarkShare.getObject(User _currUser) 取共享的对象（ BookMark / MarkKind ）
CMSObj | MarkShare.getViewer(User _currUser) 取得Viewer对象(User,Group,Role,Contact,ContactGrp)

参数类型为 CMSObj 的 com.trs.components.common.bookmark 中的方法
Groups | BookMarkMgr.getSharedGroups(int _nTypeId, CMSObj _currObj)
Users | BookMarkMgr.getSharedUsers(int _nTypeId, CMSObj _currObj)
void | MarkShare.setViewer(CMSObj _viewer) 设置Viewer（User,Group,Role,Contact,ContactGrp）对象

com.trs.components.common.calendar 中 CMSObj 的使用

com.trs.components.common.calendar 中 CMSObj 的子类
class | Event
class | EventShare
class | EventType

参数类型为 CMSObj 的 com.trs.components.common.calendar 中的方法
void | EventMgr.cancelShare(Event _anEvent, CMSObj _cmsObj) 取消对象某用户/组织的一个日程安排
void | EventMgr.shareTo(Event _anEvent, CMSObj _cmsObj)

com.trs.components.common.conjection.persistent 中 CMSObj 的使用

com.trs.components.common.conjection.persistent 中 CMSObj 的子类
 class EntryConfig

com.trs.components.common.job 中 CMSObj 的使用

com.trs.components.common.job 中 CMSObj 的子类
class | JobWorkerType Title: TRS 内容协作平台（TRS WCM） Description: 系统Job的定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Schedule

参数类型为 CMSObj 的 com.trs.components.common.job 中的方法
static Schedule | JobScheduleServer.deleteSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)
static Schedule | JobScheduleServer.findSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)
static Schedule | JobScheduleServer.saveSchedule(JobWorkerType _currWorkerType, Schedule _currSchedule, CMSObj _currObj)
boolean | Schedule.setSender(CMSObj _sender) 属性设置：发送者

com.trs.components.common.message 中 CMSObj 的使用

com.trs.components.common.message 中 CMSObj 的子类
class | Message
class | MsgQueue

参数类型为 CMSObj 的 com.trs.components.common.message 中的方法
 boolean MsgQueue.setObj(CMSObj _obj)

com.trs.components.common.publish.domain.auth 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.common.publish.domain.auth 中的方法
 CMSObj TemplateRightObjImpl.getSubstance()

参数类型为 CMSObj 的 com.trs.components.common.publish.domain.auth 中的方法
void | TemplateRightObjImpl.makeFrom(CMSObj _cmsObj)
void | TemplateRightObjImpl.setSubstance(CMSObj _cmsObj)

参数类型为 CMSObj 的 com.trs.components.common.publish.domain.auth 中的构造方法
TemplateRightObjImpl(CMSObj _cmsObj)

com.trs.components.common.publish.persistent.distribute 中 CMSObj 的使用

com.trs.components.common.publish.persistent.distribute 中 CMSObj 的子类
 class PublishDistribution

com.trs.components.common.publish.persistent.element 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.common.publish.persistent.element 中的方法
CMSObj | PublishElementWrapper.getSubstance()
CMSObj | PublishContentDefaultObjImpl.getSubstance()

参数类型为 CMSObj 的 com.trs.components.common.publish.persistent.element 中的方法
static IPublishContent | PublishElementFactory.makeContentFrom(CMSObj _cmsObj, IPublishFolder _oFolder) make a publish content from the specified CMS object.
static IPublishElement | PublishElementFactory.makeElementFrom(CMSObj _cmsObj) make a publish element from the specified CMS object.
void | PublishElementWrapper.makeFrom(CMSObj _cmsObj)
void | PublishContentDefaultObjImpl.makeFrom(CMSObj _cmsObj)
void | PublishElementWrapper.setSubstance(CMSObj _cmsObj)
void | PublishContentDefaultObjImpl.setSubstance(CMSObj _cmsObj)

com.trs.components.common.publish.persistent.publisher 中 CMSObj 的使用

com.trs.components.common.publish.persistent.publisher 中 CMSObj 的子类
 class FolderPublishConfig

com.trs.components.common.publish.persistent.taskdispatch 中 CMSObj 的使用

com.trs.components.common.publish.persistent.taskdispatch 中 CMSObj 的子类
class | PublishErrorLog
class | PublishTask

com.trs.components.common.publish.persistent.template 中 CMSObj 的使用

com.trs.components.common.publish.persistent.template 中 CMSObj 的子类
class | TagBean
class | TempApdRel
class | TempAppendix
class | Template Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateArgument 模板中的形式参数的实际值
class | TemplateEmploy
class | TemplateQuote

com.trs.components.common.publish.widget 中 CMSObj 的使用

com.trs.components.common.publish.widget 中 CMSObj 的子类
class | BaseStyle 风格抽象类
class | ContentStyle
class | Layout
class | Master
class | PageStyle
class | ResourceStyle
class | StyleAndResource
class | StyleItem
class | Widget
class | WidgetInstance
class | WidgetInstParameter
class | WidgetParameter

参数类型为 CMSObj 的 com.trs.components.common.publish.widget 中的方法
static RightValue | SpecialAuthServer.getRightValue(CMSObj operator, java.lang.Class clazz) 获取指定用户在指定对象类型上的权限值，如是否能新建，导入等
static RightValue | SpecialAuthServer.getRightValue(CMSObj operator, CMSObj obj) 获取指定用户在指定对象上的权限值
static boolean | SpecialAuthServer.hasRight(CMSObj operator, CMSObj obj, int nRightIndex) 判断当前操作者operator在对象obj上是否有权限nRightIndex

com.trs.components.common.publish.widget.tagparser 中 CMSObj 的使用

参数类型为 CMSObj 的 com.trs.components.common.publish.widget.tagparser 中的方法
 boolean WCMTagParserDocInChnlOperation.hasSuperRight(BaseChannel host, CMSObj _aUser)
判断当前Operator对于指定结点是否有Super权限

com.trs.components.common.trsad 中 CMSObj 的使用

com.trs.components.common.trsad 中 CMSObj 的子类
class | ADCom
class | ADFile
class | ADFilePos
class | ADPos
class | ADType

返回 CMSObj 的 com.trs.components.common.trsad 中的方法
 CMSObj ADPos.getWebObj()
得到站点或频道对象

com.trs.components.common.trsvote 中 CMSObj 的使用

com.trs.components.common.trsvote 中 CMSObj 的子类
class | Vote
class | VoteData
class | VoteIPLog
class | VoteItem
class | VoteOption

com.trs.components.gkml.sqgk.persistent 中 CMSObj 的使用

com.trs.components.gkml.sqgk.persistent 中 CMSObj 的子类
class | ApplyForm
class | ApplyFormDealLog
class | MailConfig

com.trs.components.gkml.sqgk.process.element 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.gkml.sqgk.process.element 中的方法
CMSObj | FlowContentApplyFormImpl.getSubinstance()
CMSObj | FlowContentApplyFormImpl.getSubstance()

参数类型为 CMSObj 的 com.trs.components.gkml.sqgk.process.element 中的方法
void | FlowContentApplyFormImpl.makeFrom(CMSObj _cmsObj)
void | FlowContentApplyFormImpl.setSubinstance(CMSObj _subinstance)
void | FlowContentApplyFormImpl.setSubstance(CMSObj _cmsObj)

com.trs.components.infoview 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.infoview 中的方法
CMSObj | RightHostInfoViewField.getSubstance()
CMSObj | RightHostInfoViewGroup.getSubstance()
CMSObj | RightHostInfoViewView.getSubstance()

参数类型为 CMSObj 的 com.trs.components.infoview 中的方法
int | InfoViewEmployMgr.clearByEmployer(CMSObj _oChnlOrSite)
java.util.List | InfoViewEmployMgr.getEmployedInfoViews(CMSObj _employer)
void | RightHostInfoViewField.makeFrom(CMSObj _cmsObj)
void | RightHostInfoViewGroup.makeFrom(CMSObj _cmsObj)
void | RightHostInfoViewView.makeFrom(CMSObj _cmsObj)
void | InfoViewEmployMgr.setEmployedInfoView(CMSObj _employer, int _iInfoViewID) TODO Add javadoc for field setEmployedInfoView
void | InfoViewEmployMgr.setEmployedInfoViews(CMSObj _employer, int[] _iInfoViewIDs) 注意： 在该函数执行后，参数数组_iInfoViewIDs的数据可能被破坏，因此如果需要，请调用该函数前备份
void | RightHostInfoViewField.setSubstance(CMSObj _cmsObj)
void | RightHostInfoViewGroup.setSubstance(CMSObj _cmsObj)
void | RightHostInfoViewView.setSubstance(CMSObj _cmsObj)

com.trs.components.infoview.helper 中 CMSObj 的使用

com.trs.components.infoview.helper 中 CMSObj 的子类
 class ComplexFieldData

com.trs.components.infoview.persistent 中 CMSObj 的使用

com.trs.components.infoview.persistent 中 CMSObj 的子类
class | InfoView TODO Add javadoc for InfoView
class | InfoViewData
class | InfoViewDocument
class | InfoViewEmploy TODO Add javadoc for InfoViewEmploy
class | InfoViewField
class | InfoViewGroup 描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table
class | InfoViewView 描述自定义表单的一个视图

返回 CMSObj 的 com.trs.components.infoview.persistent 中的方法
 CMSObj InfoViewEmploy.getEmployer()

参数类型为 CMSObj 的 com.trs.components.infoview.persistent 中的方法
 boolean InfoViewEmploy.setEmployer(CMSObj _employer)

com.trs.components.metadata.center 中 CMSObj 的使用

com.trs.components.metadata.center 中 CMSObj 的子类
class | ClassInfoView
class | MetaViewData

com.trs.components.metadata.definition 中 CMSObj 的使用

com.trs.components.metadata.definition 中 CMSObj 的子类
class | ClassInfo
class | MetaDBField
class | MetaDBTable
class | MetaView
class | MetaViewField

返回 CMSObj 的 com.trs.components.metadata.definition 中的方法
CMSObj | MetaView.getOwner() 获取视图所属对象
CMSObj | MetaDBTable.getOwner() 获取视图所属对象

com.trs.components.metadata.publish 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.metadata.publish 中的方法
CMSObj | PublishFolderClassImpl.getSubstance()
CMSObj | PublishContentViewFieldImpl.getSubstance()
CMSObj | PublishContentViewDataImpl.getSubstance()
CMSObj | PublishContentViewImpl.getSubstance()

参数类型为 CMSObj 的 com.trs.components.metadata.publish 中的方法
void | PublishFolderClassImpl.makeFrom(CMSObj _cmsObj)
void | PublishContentViewFieldImpl.makeFrom(CMSObj _cmsObj)
void | PublishContentViewDataImpl.makeFrom(CMSObj _cmsObj)
void | PublishContentViewImpl.makeFrom(CMSObj _cmsObj)
void | PublishFolderClassImpl.setSubstance(CMSObj _cmsObj)
void | PublishContentViewFieldImpl.setSubstance(CMSObj _cmsObj)
void | PublishContentViewDataImpl.setSubstance(CMSObj _cmsObj)
void | PublishContentViewImpl.setSubstance(CMSObj _cmsObj)

com.trs.components.special 中 CMSObj 的使用

com.trs.components.special 中 CMSObj 的子类
 class Special

com.trs.components.stat 中 CMSObj 的使用

com.trs.components.stat 中 CMSObj 的子类
class | BonusRule
class | ChnlDept
class | DocumentHitsCount
class | HostObjDomain
class | HostObjHitsCount
class | UserLoginInfo

com.trs.components.wcm.auth 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.wcm.auth 中的方法
CMSObj | WebSiteRightObjImpl.getSubstance()
CMSObj | ChannelRightObjImpl.getSubstance()

参数类型为 CMSObj 的 com.trs.components.wcm.auth 中的方法
void | WebSiteRightObjImpl.makeFrom(CMSObj _oObj)
void | ChannelRightObjImpl.makeFrom(CMSObj _oObj)
void | WebSiteRightObjImpl.setSubstance(CMSObj _oObj)
void | ChannelRightObjImpl.setSubstance(CMSObj _oObj)

com.trs.components.wcm.content 中 CMSObj 的使用

com.trs.components.wcm.content 中 CMSObj 的子类
 class ViewDocument
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档元素对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 中 CMSObj 的使用

参数类型为 CMSObj 的 com.trs.components.wcm.content.domain 中的方法
void | ContentExtFieldMgr.addExtField(CMSObj _host, ContentExtField _extfield, int i)
void | ContentExtFieldMgr.addExtFieldToChildren(CMSObj _host, ContentExtField _extfield)
void | ContentExtFieldMgr.delete(CMSObj _siteOrChannel, ContentExtField _extfield, boolean _bDoWithChildren)
ContentExtFields | ContentExtFieldMgr.getExtFields(CMSObj _host, WCMFilter _filter, boolean _bContainsChildren)
int | ContentExtFieldMgr.getMaxOrder(CMSObj host)
boolean | SiteMemberMgr.isBelongToSite(CMSObj _operator, WebSite _site) 判断指定的对象是否属于指定的站点
boolean | SiteMemberMgr.isVisible(CMSObj _operator, WebSite _site)
ContentExtField | ContentExtFieldMgr.save(CMSObj _host, ContentExtField _extfield, boolean _bDoWithChildren)

com.trs.components.wcm.content.domain.auth 中 CMSObj 的使用

参数类型为 CMSObj 的 com.trs.components.wcm.content.domain.auth 中的构造方法
ChannelRightHostImpl(CMSObj _cmsObj)
DocumentRightHostImpl(CMSObj _cmsObj)
WebSiteRightHostImpl(CMSObj _cmsObj)

com.trs.components.wcm.content.persistent 中 CMSObj 的使用

com.trs.components.wcm.content.persistent 中 CMSObj 的子类
class | Appendix
class | AutoBakConfig Title: TRS 内容协作平台（TRS WCM） Description: 自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseChannel Title: TRS 内容协作平台（TRS WCM） Description:
class | Channel
class | ChannelContentLink Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ChannelSyn
class | ChnlDoc
class | ContentExtField
class | ContentLink
class | ContentLinkType
class | DocBak
class | DocReply
class | Document
class | DocumentSyn Title: TRS 内容协作平台（TRS WCM） Description: 已经自动转发过的文档的记录 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | HitsCount
class | Relation
class | Replace
class | SiteMember
class | WebSite
class | XDocument

返回 CMSObj 的 com.trs.components.wcm.content.persistent 中的方法
CMSObj | ContentExtField.getHost()
CMSObj | ChannelSubstanceImplBase.getSubstance()
CMSObj | WebSiteSubstanceImplBase.getSubstance()
CMSObj | DocumentSubstanceImplBase.getSubstance()

参数类型为 CMSObj 的 com.trs.components.wcm.content.persistent 中的方法
void | ChannelSubstanceImplBase.makeFrom(CMSObj _cmsObj)
void | WebSiteSubstanceImplBase.makeFrom(CMSObj _cmsObj)
void | DocumentSubstanceImplBase.makeFrom(CMSObj _cmsObj)
void | ChannelSubstanceImplBase.setSubstance(CMSObj _cmsObj)
void | WebSiteSubstanceImplBase.setSubstance(CMSObj _cmsObj)
void | DocumentSubstanceImplBase.setSubstance(CMSObj _cmsObj)

参数类型为 CMSObj 的 com.trs.components.wcm.content.persistent 中的构造方法
ChannelSubstanceImplBase(CMSObj _cmsObj)
DocumentSubstanceImplBase(CMSObj _cmsObj)
WebSiteSubstanceImplBase(CMSObj _cmsObj)

com.trs.components.wcm.customize 中 CMSObj 的使用

com.trs.components.wcm.customize 中 CMSObj 的子类
 class UserSetting

com.trs.components.wcm.epress 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.wcm.epress 中的方法
 CMSObj EpressFolderWrapper.getSubstance()

参数类型为 CMSObj 的 com.trs.components.wcm.epress 中的方法
void | EpressFolderWrapper.makeFrom(CMSObj _cmsObj)
void | EpressFolderWrapper.setSubstance(CMSObj _cmsObj)

com.trs.components.wcm.individuation 中 CMSObj 的使用

com.trs.components.wcm.individuation 中 CMSObj 的子类
class | CustomSiteCheckedInfo
class | Individuation

com.trs.components.wcm.process.element 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.wcm.process.element 中的方法
CMSObj | FlowContentDocumentImpl.getSubinstance()
CMSObj | FlowContentDocumentImpl.getSubstance()

参数类型为 CMSObj 的 com.trs.components.wcm.process.element 中的方法
void | FlowContentDocumentImpl.makeFrom(CMSObj _cmsObj)
void | FlowContentDocumentImpl.setSubinstance(CMSObj _subinstance)
void | FlowContentDocumentImpl.setSubstance(CMSObj _cmsObj)

com.trs.components.wcm.publish 中 CMSObj 的使用

com.trs.components.wcm.publish 中 CMSObj 的子类
class | WCMFolderPublishConfig
class | WCMPubStatusConfig

com.trs.components.wcm.publish.element 中 CMSObj 的使用

返回 CMSObj 的 com.trs.components.wcm.publish.element 中的方法
CMSObj | PublishFolderChannelImpl.getSubstance()
CMSObj | PublishContentDocumentImpl.getSubstance()
CMSObj | PublishFolderWebSiteImpl.getSubstance()

参数类型为 CMSObj 的 com.trs.components.wcm.publish.element 中的方法
void | PublishFolderChannelImpl.makeFrom(CMSObj _cmsObj)
void | PublishContentDocumentImpl.makeFrom(CMSObj _cmsObj)
void | PublishFolderWebSiteImpl.makeFrom(CMSObj _cmsObj)
void | PublishFolderChannelImpl.setSubstance(CMSObj _cmsObj)
void | PublishContentDocumentImpl.setSubstance(CMSObj _cmsObj)
void | PublishFolderWebSiteImpl.setSubstance(CMSObj _cmsObj)

com.trs.components.wcm.publish.logo 中 CMSObj 的使用

com.trs.components.wcm.publish.logo 中 CMSObj 的子类
 class Logo

com.trs.components.wcm.publish.region 中 CMSObj 的使用

com.trs.components.wcm.publish.region 中 CMSObj 的子类
class | CellInfo
class | RegionEmploy
class | RegionInfo

com.trs.components.wcm.recent 中 CMSObj 的使用

com.trs.components.wcm.recent 中 CMSObj 的子类
 class Recent

参数类型为 CMSObj 的 com.trs.components.wcm.recent 中的方法
 boolean Recent.setObj(CMSObj _obj)
设置属性：ObjType

com.trs.components.wcm.resource 中 CMSObj 的使用

com.trs.components.wcm.resource 中 CMSObj 的子类
class | DocKind
class | FileType
class | Keyword
class | Security
class | Source
class | Status

返回 CMSObj 的 com.trs.components.wcm.resource 中的方法
 CMSObj ResourceMgr.save(User _currUser, CMSObj _currObj)
保存指定的配置资源对象

参数类型为 CMSObj 的 com.trs.components.wcm.resource 中的方法
boolean | ResourceMgr.delete(User _currUser, CMSObj _currObj) 删除指定的配置资源对象
CMSObj | ResourceMgr.save(User _currUser, CMSObj _currObj) 保存指定的配置资源对象

com.trs.components.wcm.stat 中 CMSObj 的使用

com.trs.components.wcm.stat 中 CMSObj 的子类
class | StatFieldMap
class | StatHost
class | StatView
class | StatViewRel

com.trs.components.wcm.wcmx.help 中 CMSObj 的使用

com.trs.components.wcm.wcmx.help 中 CMSObj 的子类
 class WCMHelp

com.trs.components.wcm.wcmx.media 中 CMSObj 的使用

com.trs.components.wcm.wcmx.media 中 CMSObj 的子类
 class MediaRemindedInfo

com.trs.presentation.nav 中 CMSObj 的使用

参数类型为 CMSObj 的 com.trs.presentation.nav 中的方法
 boolean TreeCreator.hasSuperRight(BaseChannel host, CMSObj _aUser)
判断当前Operator对于指定结点是否有Super权限

com.trs.presentation.right 中 CMSObj 的使用

参数类型为 CMSObj 的 com.trs.presentation.right 中的方法
static boolean RightHelper.hasRight(User _loginUser, CMSObj _currObj, int[] _rightIndexes)
判断用户对某个对象是否具有具有一系列权限中的一个

com.trs.presentation.util 中 CMSObj 的使用

返回 CMSObj 的 com.trs.presentation.util 中的方法
static CMSObj | CmsObjUnlockTools.findLockedObj(int _nObjType, int _nObjId)
CMSObj | AppAutoParameter.getElementInstance()
static CMSObj | AppAutoParameter.getWCMObj(java.lang.String _sClassName)

参数类型为 CMSObj 的 com.trs.presentation.util 中的方法
static boolean CmsObjUnlockTools.forceUnLocke(User _opUser, CMSObj _lockedobj)

com.trs.service 中 CMSObj 的使用

返回 CMSObj 的 com.trs.service 中的方法
 CMSObj IResourceService.save(CMSObj _currObjToSave)
保存资源配置

参数类型为 CMSObj 的 com.trs.service 中的方法
boolean | IResourceService.delete(CMSObj _currObjToDelete) 删除资源配置
java.util.List | IInfoViewService.getEmployedInfoViews(CMSObj _employer) 获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合
Templates | ITemplateService.getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) 获取站点/频道下管理的模板集合
Reports | ITemplateService.importFromHTML(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName) 从html文件导入模板
Reports | ITemplateService.importFromZip(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected) 从zip文件中导入模板
Reports | ITemplateService.redistributeAppendixes(CMSObj _chnlOrSite, boolean _zRecursive) 重新分发指定站点或者频道下的所有模板的附件，并且如果_zRecursive 为true ，则会进一步地重新分发子频道下的模板的附件。
CMSObj | IResourceService.save(CMSObj _currObjToSave) 保存资源配置
void | IInfoViewService.setEmployedInfoView(CMSObj _employer, InfoView _oInfoView) 设置雇主（通常是频道）雇佣的自定义表单的ID列表
void | IInfoViewService.setEmployedInfoViews(CMSObj _employer, java.lang.String _sInfoViewIDs) 设置雇主（通常是频道）雇佣的自定义表单的ID列表

com.trs.service.impl 中 CMSObj 的使用

返回 CMSObj 的 com.trs.service.impl 中的方法
 CMSObj ResouceService.save(CMSObj _currObjToSave)

参数类型为 CMSObj 的 com.trs.service.impl 中的方法
boolean | ResouceService.delete(CMSObj _currObjToDelete)
java.util.List | InfoViewService.getEmployedInfoViews(CMSObj _employer)
Templates | TemplateService.getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren)
Reports | TemplateService.importFromHTML(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName)
Reports | TemplateService.importFromZip(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected)
Reports | TemplateService.redistributeAppendixes(CMSObj _chnlOrSite, boolean _zRecursive)
CMSObj | ResouceService.save(CMSObj _currObjToSave)
void | InfoViewService.setEmployedInfoView(CMSObj _employer, InfoView _oInfoView)
void | InfoViewService.setEmployedInfoViews(CMSObj _employer, java.lang.String _sInfoViewIDs)

com.trs.wcm.config 中 CMSObj 的使用

com.trs.wcm.config 中 CMSObj 的子类
 class PageOperator

com.trs.wcm.old 中 CMSObj 的使用

com.trs.wcm.old 中 CMSObj 的子类
class | WCMExcelData Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
class | WCMFormFields
class | WCMFormInfo

返回 CMSObj 的 com.trs.wcm.old 中的方法
 CMSObj WCMFormInfo.getBean()
获得表单对象所对应的实例

com.trs.wcm.photo 中 CMSObj 的使用

com.trs.wcm.photo 中 CMSObj 的子类
 class Watermark

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.CMSObjDefaultImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.CMSObjDefaultImpl
的使用

没有 com.trs.cms.content.CMSObjDefaultImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.DefaultObj 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.DefaultObj
的使用

使用 DefaultObj 的软件包
com.trs.cms.content
com.trs.components.common.publish.persistent.element

com.trs.cms.content 中 DefaultObj 的使用

返回 DefaultObj 的 com.trs.cms.content 中的方法
static DefaultObj DefaultObj.findById(int _nId, java.lang.String _sTableName, java.lang.String _sIdFieldName)
提取指定ID的对象

com.trs.components.common.publish.persistent.element 中 DefaultObj 的使用

参数类型为 DefaultObj 的 com.trs.components.common.publish.persistent.element 中的构造方法
PublishContentDefaultObjImpl(DefaultObj _obj)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.DefaultObjs 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.DefaultObjs
的使用

使用 DefaultObjs 的软件包
com.trs.cms.content

com.trs.cms.content 中 DefaultObjs 的使用

返回 DefaultObjs 的 com.trs.cms.content 中的方法
static DefaultObjs | DefaultObjs.createNewInstance(User _currUser) 产生当前集合对象[DefaultObjs]的实例
static DefaultObjs | DefaultObjs.findByIds(User _currUser, java.lang.String _sIds, java.lang.String _sDbTableName, java.lang.String _sIdFieldName) 提取指定ID序列的对象集合
static DefaultObjs | DefaultObjs.openWCMObjs(User _currUser, WCMFilter _filter, java.lang.String _sDbTableName, java.lang.String _sIdFieldName) 通过指定一个Filter获取当前集合[DefaultObjs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.ExtendedField 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.ExtendedField
的使用

使用 ExtendedField 的软件包
com.trs.cms.content

com.trs.cms.content 中 ExtendedField 的使用

返回 ExtendedField 的 com.trs.cms.content 中的方法
static ExtendedField | ExtendedField.createNewInstance() 产生当前对象[ExtendedField]的实例
static ExtendedField | ExtendedField.findById(int _nId) 提取指定ID的对象
static ExtendedField | ExtendedField.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.ExtendedFields 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.ExtendedFields
的使用

使用 ExtendedFields 的软件包
com.trs.ajaxservice
com.trs.cms.content

com.trs.ajaxservice 中 ExtendedFields 的使用

返回 ExtendedFields 的 com.trs.ajaxservice 中的方法
 ExtendedFields ExtendFieldServiceProvider.queryExtendFields(MethodContext _methodContext)
获取系统配置的物理字段

com.trs.cms.content 中 ExtendedFields 的使用

返回 ExtendedFields 的 com.trs.cms.content 中的方法
static ExtendedFields | ExtendedFields.createNewInstance(User _currUser) 产生当前集合对象[ExtendedFields]的实例
static ExtendedFields | ExtendedFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ExtendedFields | ExtendedFields.openWCMObjs(User _currUser, WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.HTMLContent 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.HTMLContent
的使用

没有 com.trs.cms.content.HTMLContent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.content.ICMSObjSubstanceContent 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.content.ICMSObjSubstanceContent
的使用

使用 ICMSObjSubstanceContent 的软件包
com.trs.cms.auth.domain |
com.trs.cms.process |
com.trs.components.common.publish.domain.auth |
com.trs.components.common.publish.persistent.element |
com.trs.components.gkml.sqgk.process.element |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.metadata.publish |
com.trs.components.wcm.auth |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.epress |
com.trs.components.wcm.process.element |
com.trs.components.wcm.publish.element |

com.trs.cms.auth.domain 中 ICMSObjSubstanceContent 的使用

com.trs.cms.auth.domain 中 ICMSObjSubstanceContent 的子接口
interface | IRightHost Title: TRS 内容协作平台（TRS WCM） Description: 可设置权限的对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IRightObj Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 ICMSObjSubstanceContent 的 com.trs.cms.auth.domain 中的类
 class GroupRightObjImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process 中 ICMSObjSubstanceContent 的使用

com.trs.cms.process 中 ICMSObjSubstanceContent 的子接口
 interface IFlowContent
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.auth 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.common.publish.domain.auth 中的类
 class TemplateRightObjImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
模板权限判断的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.element 中 ICMSObjSubstanceContent 的使用

com.trs.components.common.publish.persistent.element 中 ICMSObjSubstanceContent 的子接口
interface | IPublishContent Title: TRS 内容协作平台（TRS WCM） Description: publish content interface, which is one kind of IPublishElement.
interface | IPublishElement Title: TRS 内容协作平台（TRS WCM） Description: the base interface of publish element, including IPublishFolder and IPublishContent.
interface | IPublishFolder Title: TRS 内容协作平台（TRS WCM） Description: publish folder interface, which is one kind of IPublishElement.

实现 ICMSObjSubstanceContent 的 com.trs.components.common.publish.persistent.element 中的类
class | PublishContentDefaultObjImpl
class | PublishContentImplBase Title: TRS 内容协作平台（TRS WCM） Description: implementation base for publish content.
class | PublishContentWrapper IPublishContent的代理实现
class | PublishElementWrapper IPublishElement的代理实现
class | PublishFolderImplBase Title: TRS 内容协作平台（TRS WCM） Description: implementation base for IPublishFolder.
class | PublishFolderWrapper IPublishFolder的代理实现

com.trs.components.gkml.sqgk.process.element 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.gkml.sqgk.process.element 中的类
 class FlowContentApplyFormImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
Document的FlowContent的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.infoview 中的类
class | RightHostInfoViewField
class | RightHostInfoViewGroup
class | RightHostInfoViewView

com.trs.components.metadata.publish 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.metadata.publish 中的类
class | PublishContentViewDataImpl
class | PublishContentViewFieldImpl
class | PublishContentViewImpl
class | PublishFolderClassImpl Title: TRS 内容协作平台（TRS WCM） Description: 分类Folder的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.auth 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.wcm.auth 中的类
class | ChannelRightObjImpl
class | WebSiteRightObjImpl

com.trs.components.wcm.content.domain.auth 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.wcm.content.domain.auth 中的类
class | ChannelRightHostImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentRightHostImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteRightHostImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.wcm.content.persistent 中的类
class | ChannelSubstanceImplBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSubstanceImplBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteSubstanceImplBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.wcm.epress 中的类
 class EpressFolderWrapper
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process.element 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.wcm.process.element 中的类
class | FlowContentDocumentImpl Title: TRS 内容协作平台（TRS WCM） Description: Document的FlowContent的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MyFlowContentDocumentImpl

com.trs.components.wcm.publish.element 中 ICMSObjSubstanceContent 的使用

实现 ICMSObjSubstanceContent 的 com.trs.components.wcm.publish.element 中的类
class | PublishContentDocumentImpl Title: TRS 内容协作平台（TRS WCM） Description: publis content implementation with document.
class | PublishFolderChannelImpl Title: TRS 内容协作平台（TRS WCM） Description: channel implementation of IPublishFolder Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishFolderWebSiteImpl Title: TRS 内容协作平台（TRS WCM） Description: website implementation of folder.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.ImgRec 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.ImgRec
的使用

没有 com.trs.cms.content.ImgRec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.Locker 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.Locker
的使用

使用 Locker 的软件包
com.trs.cms.content

com.trs.cms.content 中 Locker 的使用

返回 Locker 的 com.trs.cms.content 中的方法
Locker | CMSObj.getLocker() 取本对象的加锁对象
Locker | LockManager.getLocker(CMSObj _obj, boolean _bCreateWhenNotExists) 取指定WCMObj对象的加锁对象
Locker | LockerMgr.getLocker(CMSObj _obj, boolean _bCreateWhenNotExists) 取指定WCMObj对象的加锁对象
Locker | LockManager.getLocker(int _nObjType, int _nObjId, boolean _bCreateWhenNotExists)
Locker | LockerMgr.getLocker(int _nObjType, int _nObjId, boolean _bCreateWhenNotExists)
Locker | LockManager.removeLocker(CMSObj _obj) 从缓冲区中移去指定WCMObj对象的Locker
Locker | LockerMgr.removeLocker(CMSObj _obj) 从缓冲区中移去指定WCMObj对象的Locker
Locker | LockManager.removeLocker(int _nObjType, int _nObjId)
Locker | LockerMgr.removeLocker(int _nObjType, int _nObjId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.LockerMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.LockerMgr
的使用

没有 com.trs.cms.content.LockerMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.LockManager 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.LockManager
的使用

使用 LockManager 的软件包
com.trs.cms.content

com.trs.cms.content 中 LockManager 的使用

返回 LockManager 的 com.trs.cms.content 中的方法
static LockManager LockManager.instance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.WCMHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.WCMHandler
的使用

没有 com.trs.cms.content.WCMHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.WCMObjHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.WCMObjHelper
的使用

没有 com.trs.cms.content.WCMObjHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.WCMObjsHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.WCMObjsHandler
的使用

没有 com.trs.cms.content.WCMObjsHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.content.WCMSystemObject 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.content.WCMSystemObject
的使用

使用 WCMSystemObject 的软件包
com.trs.components.wcm.channel

com.trs.components.wcm.channel 中 WCMSystemObject 的使用

参数类型为 WCMSystemObject 的 com.trs.components.wcm.channel 中的方法
 void VChannelManager.save(WCMSystemObject _parent, VChannel _oVChannel)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IObjLogger

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.logger
接口 IObjLogger

所有已知实现类：
ChannelLogger, ChnlDocLogger, ConfigLogger, DocumentLogger, FlowEmployLogger, FolderPublishConfigLogger, ObjLoggerBase, RegionCellInfoLogger, RegionInfoLogger, RightLogger, RoleUserLogger, ScheduleLogger, TemplateEmployLogger, TemplateLogger, WebSiteLogger
public interface IObjLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志对象接口定义
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

方法摘要
int | getLogObjType() 获取该日志是记录那个对象的
LogInfo | makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录

方法详细信息

makeLogOnAdd

LogInfo makeLogOnAdd(BaseObj newobj)
根据指定的对象构造新增日志说明记录

参数：
newobj新增的对象 -
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnModify

LogInfo makeLogOnModify(BaseObj objmodified)
根据指定的对象构造修改日志说明记录

参数：
objmodified - 修改的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnDel

LogInfo makeLogOnDel(BaseObj objdeleted)
根据指定的对象构造删除日志说明记录

参数：
objdeleted - 删除的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

getLogObjType

int getLogObjType()
获取该日志是记录那个对象的

返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


LogInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.logger
类 LogInfo

java.lang.Object
    继承者  com.trs.cms.logger.LogInfo

public class LogInfo
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
日志信息对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
LogInfo(int optype, java.lang.String name, java.lang.String detail)
构造日志信息
方法摘要
 java.lang.String toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LogInfo

public LogInfo(int optype,
               java.lang.String name,
               java.lang.String detail)
构造日志信息

参数：
optype - 操作类型标识,@see OperType
name - 日志的对象名称
detail - 日志的详细信息
方法详细信息

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjLoggerBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.logger
类 ObjLoggerBase

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
所有已实现的接口：
IObjLogger
直接已知子类：
ChannelLogger, ConfigLogger, DocumentLogger, FlowEmployLogger, FolderPublishConfigLogger, RegionCellInfoLogger, RegionInfoLogger, RightLogger, ScheduleLogger, TemplateEmployLogger, TemplateLogger, WebSiteLogger
public abstract class ObjLoggerBase
extends java.lang.Object
implements IObjLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
Obj操作日志记录基础类
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ObjLoggerBase()
方法摘要
abstract int | getLogObjType() 获取该日志是记录那个对象的
LogInfo | makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjLoggerBase

public ObjLoggerBase()
方法详细信息

makeLogOnAdd

public LogInfo makeLogOnAdd(BaseObj newobj)
从接口 IObjLogger 复制的描述
根据指定的对象构造新增日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnAdd
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnDel

public LogInfo makeLogOnDel(BaseObj objdeleted)
从接口 IObjLogger 复制的描述
根据指定的对象构造删除日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnDel
参数：
objdeleted - 删除的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnModify

public LogInfo makeLogOnModify(BaseObj objmodified)
从接口 IObjLogger 复制的描述
根据指定的对象构造修改日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnModify
参数：
objmodified - 修改的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

getLogObjType

public abstract int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjSysLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.logger
类 ObjSysLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjSysLogger

public final class ObjSysLogger
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志总调度,通过Discovery得到需要记录的日志对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

方法摘要
void | finishLog(int _nLogId) 日志记录结束
void | finishLog(int _nLogId, int _nObjId) 结束日志记录
void | finishLog(int _nLogId, java.lang.Throwable error) 结束记录日志
static ObjSysLogger | instance()
int | startLogDeleting(User curruser, BaseObj object) 开始记录一个删除记录的日志
int | startLogInserting(User curruser, BaseObj object) 开始记录一个新增记录的日志
int | startLogModifying(User curruser, BaseObj object) 开始记录一个修改记录的日志
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

instance

public static ObjSysLogger instance()

startLogInserting

public int startLogInserting(User curruser,
                             BaseObj object)
开始记录一个新增记录的日志

参数：
curruser - 操作者
object - 新增的对象
返回：
记录的日志对象ID,用做后面finishLog方法的输入

startLogModifying

public int startLogModifying(User curruser,
                             BaseObj object)
开始记录一个修改记录的日志

参数：
curruser - 操作者
object - 修改的对象
返回：
记录的日志对象ID,用做后面finishLog方法的输入

startLogDeleting

public int startLogDeleting(User curruser,
                            BaseObj object)
开始记录一个删除记录的日志

参数：
curruser - 操作者
object - 删除的对象
返回：
记录的日志对象ID,用做后面finishLog方法的输入

finishLog

public void finishLog(int _nLogId)
日志记录结束

参数：
_nLogId - 日志对象的ID

finishLog

public void finishLog(int _nLogId,
                      int _nObjId)
结束日志记录

参数：
_nLogId - 日志对象的ID
_nObjId - 所记录的对象ID,通常用于成功新增记录

finishLog

public void finishLog(int _nLogId,
                      java.lang.Throwable error)
结束记录日志

参数：
_nLogId - 日志对象的ID
error - 所记录的操作出现的错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OperTypeHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.logger
类 OperTypeHelper

java.lang.Object
    继承者  com.trs.cms.logger.OperTypeHelper

public final class OperTypeHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
操作日志类型标识工具类
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
OperTypeHelper()
方法摘要
static int | getAddOp(BaseObj object)
static int | getDeleteOp(BaseObj object)
static int | getModifyOp(BaseObj object)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OperTypeHelper

public OperTypeHelper()
方法详细信息

getAddOp

public static int getAddOp(BaseObj object)

getModifyOp

public static int getModifyOp(BaseObj object)

getDeleteOp

public static int getDeleteOp(BaseObj object)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.logger
接口
IObjLogger
类
LogInfo
ObjLoggerBase
ObjSysLogger
OperTypeHelper


com.trs.cms.logger

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.logger

接口摘要
IObjLogger Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志对象接口定义
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

类摘要
LogInfo | Title: TRS 内容协作平台（TRS WCM） Description: 日志信息对象 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ObjLoggerBase | Title: TRS 内容协作平台（TRS WCM） Description: Obj操作日志记录基础类 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ObjSysLogger | Title: TRS 内容协作平台（TRS WCM） Description: 对象日志总调度,通过Discovery得到需要记录的日志对象 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OperTypeHelper | Title: TRS 内容协作平台（TRS WCM） Description: 操作日志类型标识工具类 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)


com.trs.cms.logger 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.logger 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.logger.LogInfo
    • com.trs.cms.logger.ObjLoggerBase (implements com.trs.cms.logger.IObjLogger)
    • com.trs.cms.logger.ObjSysLogger
    • com.trs.cms.logger.OperTypeHelper

接口分层结构

  • com.trs.cms.logger.IObjLogger


软件包 com.trs.cms.logger 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.logger
的使用

使用 com.trs.cms.logger 的软件包
com.trs.cms.auth.logger
com.trs.cms.logger
com.trs.components.wcm.logger

com.trs.cms.auth.logger 使用的 com.trs.cms.logger 中的类
IObjLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志对象接口定义
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
LogInfo
Title: TRS 内容协作平台（TRS WCM）
Description:
日志信息对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ObjLoggerBase
Title: TRS 内容协作平台（TRS WCM）
Description:
Obj操作日志记录基础类
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.cms.logger 使用的 com.trs.cms.logger 中的类
IObjLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志对象接口定义
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
LogInfo
Title: TRS 内容协作平台（TRS WCM）
Description:
日志信息对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ObjSysLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志总调度,通过Discovery得到需要记录的日志对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.logger 使用的 com.trs.cms.logger 中的类
IObjLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志对象接口定义
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
LogInfo
Title: TRS 内容协作平台（TRS WCM）
Description:
日志信息对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ObjLoggerBase
Title: TRS 内容协作平台（TRS WCM）
Description:
Obj操作日志记录基础类
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.logger.IObjLogger 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.logger.IObjLogger
的使用

使用 IObjLogger 的软件包
com.trs.cms.auth.logger
com.trs.cms.logger
com.trs.components.wcm.logger

com.trs.cms.auth.logger 中 IObjLogger 的使用

实现 IObjLogger 的 com.trs.cms.auth.logger 中的类
class | RightLogger Title: TRS 内容协作平台（TRS WCM） Description: 权限对象操作日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | RoleUserLogger Title: TRS 内容协作平台（TRS WCM） Description: 角色用户日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.cms.logger 中 IObjLogger 的使用

实现 IObjLogger 的 com.trs.cms.logger 中的类
 class ObjLoggerBase
Title: TRS 内容协作平台（TRS WCM）
Description:
Obj操作日志记录基础类
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.logger 中 IObjLogger 的使用

实现 IObjLogger 的 com.trs.components.wcm.logger 中的类
class | ChannelLogger Title: TRS 内容协作平台（TRS WCM） Description: 栏目对象操作日志记录者 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ChnlDocLogger Title: TRS 内容协作平台（TRS WCM） Description: chnldoc日志记录(主要是记录顺序变更) Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ConfigLogger Title: TRS 内容协作平台（TRS WCM） Description: 系统配置修改日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DocumentLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档对象日志记录者 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | FlowEmployLogger Title: TRS 内容协作平台（TRS WCM） Description: 工件流分配日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | FolderPublishConfigLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | RegionCellInfoLogger
class | RegionInfoLogger
class | ScheduleLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TemplateEmployLogger Title: TRS 内容协作平台（TRS WCM） Description: 模板配置日志记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TemplateLogger Title: TRS 内容协作平台（TRS WCM） Description: 模板日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | WebSiteLogger Title: TRS 内容协作平台（TRS WCM） Description: 站点日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.logger.LogInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.logger.LogInfo
的使用

使用 LogInfo 的软件包
com.trs.cms.auth.logger
com.trs.cms.logger
com.trs.components.wcm.logger

com.trs.cms.auth.logger 中 LogInfo 的使用

返回 LogInfo 的 com.trs.cms.auth.logger 中的方法
LogInfo | RoleUserLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | RoleUserLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | RoleUserLogger.makeLogOnModify(BaseObj objmodified)

com.trs.cms.logger 中 LogInfo 的使用

返回 LogInfo 的 com.trs.cms.logger 中的方法
LogInfo | ObjLoggerBase.makeLogOnAdd(BaseObj newobj)
LogInfo | IObjLogger.makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | ObjLoggerBase.makeLogOnDel(BaseObj objdeleted)
LogInfo | IObjLogger.makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | ObjLoggerBase.makeLogOnModify(BaseObj objmodified)
LogInfo | IObjLogger.makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录

com.trs.components.wcm.logger 中 LogInfo 的使用

返回 LogInfo 的 com.trs.components.wcm.logger 中的方法
LogInfo | TemplateEmployLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | RegionCellInfoLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | FlowEmployLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | ConfigLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | ChnlDocLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | TemplateEmployLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | RegionCellInfoLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | FlowEmployLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | ConfigLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | ChnlDocLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | TemplateEmployLogger.makeLogOnModify(BaseObj objmodified)
LogInfo | RegionCellInfoLogger.makeLogOnModify(BaseObj objmodified)
LogInfo | FlowEmployLogger.makeLogOnModify(BaseObj objmodified)
LogInfo | ConfigLogger.makeLogOnModify(BaseObj objmodified)
LogInfo | ChnlDocLogger.makeLogOnModify(BaseObj objmodified)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.logger.ObjLoggerBase 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.logger.ObjLoggerBase
的使用

使用 ObjLoggerBase 的软件包
com.trs.cms.auth.logger
com.trs.components.wcm.logger

com.trs.cms.auth.logger 中 ObjLoggerBase 的使用

com.trs.cms.auth.logger 中 ObjLoggerBase 的子类
 class RightLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
权限对象操作日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.logger 中 ObjLoggerBase 的使用

com.trs.components.wcm.logger 中 ObjLoggerBase 的子类
class | ChannelLogger Title: TRS 内容协作平台（TRS WCM） Description: 栏目对象操作日志记录者 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ConfigLogger Title: TRS 内容协作平台（TRS WCM） Description: 系统配置修改日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DocumentLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档对象日志记录者 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | FlowEmployLogger Title: TRS 内容协作平台（TRS WCM） Description: 工件流分配日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | FolderPublishConfigLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | RegionCellInfoLogger
class | RegionInfoLogger
class | ScheduleLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TemplateEmployLogger Title: TRS 内容协作平台（TRS WCM） Description: 模板配置日志记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TemplateLogger Title: TRS 内容协作平台（TRS WCM） Description: 模板日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | WebSiteLogger Title: TRS 内容协作平台（TRS WCM） Description: 站点日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.logger.ObjSysLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.logger.ObjSysLogger
的使用

使用 ObjSysLogger 的软件包
com.trs.cms.logger

com.trs.cms.logger 中 ObjSysLogger 的使用

返回 ObjSysLogger 的 com.trs.cms.logger 中的方法
static ObjSysLogger ObjSysLogger.instance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.logger.OperTypeHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.logger.OperTypeHelper
的使用

没有 com.trs.cms.logger.OperTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FlowContentFactory

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 FlowContentFactory

java.lang.Object
    继承者  com.trs.cms.process.FlowContentFactory

public class FlowContentFactory
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
产生可以流转的内容
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContentFactory()
方法摘要
static IFlowContent | makeFlowContent(CMSObj _substance)
static IFlowContent | makeFlowContent(int _nContentType, int _nContentId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContentFactory

public FlowContentFactory()
方法详细信息

makeFlowContent

public static IFlowContent makeFlowContent(int _nContentType,
                                           int _nContentId)
                                    throws WCMException
参数：
_nContentType -
_nContentId -
返回：
抛出：
WCMException

makeFlowContent

public static IFlowContent makeFlowContent(CMSObj _substance)
                                    throws WCMException
参数：
_substance -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FlowEngineHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 FlowEngineHelper

java.lang.Object
    继承者  com.trs.cms.process.FlowEngineHelper

public class FlowEngineHelper
extends java.lang.Object

构造方法摘要
FlowEngineHelper()
方法摘要
static void | main(java.lang.String[] args)
static java.lang.String | makeSeperateComments(FlowDoc _currFlowDoc) 产生并联审批结束时后合并的处理意见
static java.lang.String | makeTogetherComments(int _nParentFlowDocId) 产生合并后的处理意见
static java.lang.String[] | parseComments(FlowDoc _flowDoc) 解析处理过程中的意见，解析成偶数长度的数组
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowEngineHelper

public FlowEngineHelper()
方法详细信息

makeTogetherComments

public static java.lang.String makeTogetherComments(int _nParentFlowDocId)
                                             throws WCMException
产生合并后的处理意见

参数：
_nParentFlowDocId - 多个处理轨迹的父节点ID
返回：
抛出：
WCMException

makeSeperateComments

public static java.lang.String makeSeperateComments(FlowDoc _currFlowDoc)
                                             throws WCMException
产生并联审批结束时后合并的处理意见

参数：
_nParentFlowDocId - 多个处理轨迹的父节点ID
返回：
抛出：
WCMException

parseComments

public static java.lang.String[] parseComments(FlowDoc _flowDoc)
解析处理过程中的意见，解析成偶数长度的数组

参数：
_flowDoc - 处理轨迹
返回：
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowingDocLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 FlowingDocLogger

java.lang.Object
    继承者  com.trs.cms.process.FlowingDocLogger

public class FlowingDocLogger
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

字段摘要
static int | ACTION_FLAG_NORMAL
static int | ACTION_FLAG_PREPROCESS
方法摘要
static void info(FlowContext _context, java.lang.String _sActionDesc)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ACTION_FLAG_NORMAL

public static final int ACTION_FLAG_NORMAL
另请参见：
常量字段值

ACTION_FLAG_PREPROCESS

public static final int ACTION_FLAG_PREPROCESS
另请参见：
常量字段值
方法详细信息

info

public static void info(FlowContext _context,
                        java.lang.String _sActionDesc)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowingDocOptMarkScouter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 FlowingDocOptMarkScouter

java.lang.Object
    继承者  com.trs.cms.process.FlowingDocOptMarkScouter

public class FlowingDocOptMarkScouter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
流转中文档的操作标签监控器
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

字段摘要
static java.lang.String | FLOWING_DOC_OPT_MARK 文档操作标签: WCMDocument表的FlowOperationMark字段
static java.lang.String | FLOWING_DOC_OPT_MARK_ENUM 工作流文档操作标签枚举值: WCMDocument表的FlowOperationMaskEnum字段
static java.lang.String | FLOWING_DOC_PRE_OPT_MARK 文档前置操作标签(例如“收到”、“签收”等操作，暂时没有用到): WCMDocument表的FlowPreOperationMark字段
static java.lang.String | IFLOWCONTENT_APPLYFORM_CLASSNAME 依申请公开的实现的类名
static java.lang.String | MARK_FORCE_END 强制结束标记: 特殊的文档操作标签
方法摘要
static void | updateOperationMark(FlowContext _context)
static void | updateOperationMark(FlowContext _context, java.lang.String _sPreOptValue)
static void | updatePreOperationMark(FlowContext _context, java.lang.String _sPreOptValue)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FLOWING_DOC_OPT_MARK

public static final java.lang.String FLOWING_DOC_OPT_MARK
文档操作标签: WCMDocument表的FlowOperationMark字段

另请参见：
常量字段值

FLOWING_DOC_PRE_OPT_MARK

public static final java.lang.String FLOWING_DOC_PRE_OPT_MARK
文档前置操作标签(例如“收到”、“签收”等操作，暂时没有用到): WCMDocument表的FlowPreOperationMark字段

另请参见：
常量字段值

FLOWING_DOC_OPT_MARK_ENUM

public static final java.lang.String FLOWING_DOC_OPT_MARK_ENUM
工作流文档操作标签枚举值: WCMDocument表的FlowOperationMaskEnum字段

另请参见：
常量字段值

MARK_FORCE_END

public static final java.lang.String MARK_FORCE_END
强制结束标记: 特殊的文档操作标签

另请参见：
常量字段值

IFLOWCONTENT_APPLYFORM_CLASSNAME

public static final java.lang.String IFLOWCONTENT_APPLYFORM_CLASSNAME
依申请公开的实现的类名

另请参见：
常量字段值
方法详细信息

updateOperationMark

public static void updateOperationMark(FlowContext _context)
                                throws WCMException
抛出：
WCMException

updateOperationMark

public static void updateOperationMark(FlowContext _context,
                                       java.lang.String _sPreOptValue)
                                throws WCMException
抛出：
WCMException

updatePreOperationMark

public static void updatePreOperationMark(FlowContext _context,
                                          java.lang.String _sPreOptValue)
                                   throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 FlowServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.cms.process.FlowServer
所有已实现的接口：
IServer
public class FlowServer
extends BaseServer

字段摘要
static boolean IS_DEBUG
调试开关
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
FlowServer()
构造函数
方法摘要
void | forceDocToEnd(IFlowContent _currDoc, User _currUser)
static Users | getConsignUsers(User _operator, int _nModule) 获得指定模块的所有的委托人，默认为公文管理(TrusteeInfo.MODULE_FLOW)
int | getCurrFlowFlag(int contentType, int contentId)
FlowDoc | getFlowDoc(IFlowContent _content) 取指定文档对应的FlowDoc对象
FlowDoc | getFlowDoc(int _nObjType, int _nObjId) 取指定文档对应的FlowDoc对象
FlowDocs | getFlowDocs(User _operator, int _nFlag, WCMFilter _filter)
FlowDocs | getFlowDocsOfContent(int contentType, int contentId)
static FlowServer | getFlowServer()
FlowDocs | getSubmitFlowDocs(User _operator, WCMFilter _filter)
boolean | isCanInFlow(IFlowContent _content)
FlowDoc | removeFlowDoc(IFlowContent _doc)
FlowDoc | removeFlowDoc(IFlowContent _doc, User _currUser) 从FlowServer移去指定的FlowDoc对象
FlowDoc | removeFlowDoc(int _nObjType, int _nObjId)
FlowDoc | removeFlowDoc(int _nObjType, int _nObjId, User _currUser) 从FlowServer移去指定的FlowDoc对象
FlowDoc | startContentInFlow(User _currUser, IFlowContent _doc)
FlowDoc | startContentInFlow(User _currUser, IFlowContent _content, java.lang.String _sPostDesc) 为文档对象添加新的FlowDoc对象，使文档进入工作流流转
void | submitAgain(User user, int flowDocId, java.lang.String opinion)
FlowDoc | submitBack(User _currUser, IFlowContent _doc, java.lang.String _sPostDesc)
FlowDoc | submitBack(User _currUser, IFlowContent _content, java.lang.String _sOpinion, int _nStatusId) 将文档返回到上一个节点，并返回给指定的用户
FlowDoc | submitTo(FlowParamers _currParamers) 按照指定的方式处理文档
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_DEBUG

public static boolean IS_DEBUG
调试开关

构造方法详细信息

FlowServer

public FlowServer()
构造函数

参数：
_app - 应用服务器对象
方法详细信息

getFlowServer

public static FlowServer getFlowServer()
                                throws WCMException
抛出：
WCMException

getFlowDoc

public FlowDoc getFlowDoc(int _nObjType,
                          int _nObjId)
取指定文档对应的FlowDoc对象

参数：
_docId - 文档ID
返回：
指定文档对应的FlowDoc对象
抛出：
WCMException

getFlowDoc

public FlowDoc getFlowDoc(IFlowContent _content)
                   throws WCMException
取指定文档对应的FlowDoc对象

参数：
_content - 文档对象
返回：
指定文档对应的FlowDoc对象
抛出：
WCMException

removeFlowDoc

public FlowDoc removeFlowDoc(int _nObjType,
                             int _nObjId)
                      throws WCMException
抛出：
WCMException

removeFlowDoc

public FlowDoc removeFlowDoc(int _nObjType,
                             int _nObjId,
                             User _currUser)
                      throws WCMException
从FlowServer移去指定的FlowDoc对象

参数：
_nObjId - 与FlowDoc相关的文档ID
_currUser - 当前处理的用户
返回：
移去的FlowDoc对象
抛出：
WCMException

removeFlowDoc

public FlowDoc removeFlowDoc(IFlowContent _doc,
                             User _currUser)
                      throws WCMException
从FlowServer移去指定的FlowDoc对象

参数：
_doc - 与FlowDoc相关的文档对象
返回：
移去的FlowDoc对象
抛出：
WCMException

removeFlowDoc

public FlowDoc removeFlowDoc(IFlowContent _doc)
                      throws WCMException
抛出：
WCMException

startContentInFlow

public FlowDoc startContentInFlow(User _currUser,
                                  IFlowContent _doc)
                           throws WCMException
抛出：
WCMException
另请参见：
FlowDoc addFlowDoc( User _currUser, Document _doc ,String _sPostDesc) throws WCMException

isCanInFlow

public boolean isCanInFlow(IFlowContent _content)
                    throws WCMException
抛出：
WCMException

startContentInFlow

public FlowDoc startContentInFlow(User _currUser,
                                  IFlowContent _content,
                                  java.lang.String _sPostDesc)
                           throws WCMException
为文档对象添加新的FlowDoc对象，使文档进入工作流流转

参数：
_currUser - 当前操作用户
_content - 文档对象
_sPostDesc - 呈送描述（可省略，默认为“系统自动提交”）
返回：
添加的FlowDoc对象
抛出：
WCMException

submitTo

public FlowDoc submitTo(FlowParamers _currParamers)
                 throws WCMException
按照指定的方式处理文档

参数：
_currParamers - 处理方式的描述（FlowParamers）
返回：
处理结果（FlowDoc）
抛出：
WCMException

submitBack

public FlowDoc submitBack(User _currUser,
                          IFlowContent _doc,
                          java.lang.String _sPostDesc)
                   throws WCMException
抛出：
WCMException
另请参见：
FlowDoc submitDocBack( User _currUser, Document _doc, String _sPostDesc, int _nStatusId ) throws WCMException

submitBack

public FlowDoc submitBack(User _currUser,
                          IFlowContent _content,
                          java.lang.String _sOpinion,
                          int _nStatusId)
                   throws WCMException
将文档返回到上一个节点，并返回给指定的用户

参数：
_currUser - 当前操作用户
_content - 目前文档
_sOpinion - 处理意见
_nStatusId - 文档被打回后的状态
返回：
抛出：
WCMException

forceDocToEnd

public void forceDocToEnd(IFlowContent _currDoc,
                          User _currUser)
                   throws java.lang.Exception
抛出：
java.lang.Exception

getConsignUsers

public static Users getConsignUsers(User _operator,
                                    int _nModule)
                             throws WCMException
获得指定模块的所有的委托人，默认为公文管理(TrusteeInfo.MODULE_FLOW)

参数：
_currUser - 当前操作用户
_app - 缓冲区
_nModule - 指定模块（定义在TrusteeInfo常量种）
返回：
用户集合
抛出：
WCMException

getFlowDocs

public FlowDocs getFlowDocs(User _operator,
                            int _nFlag,
                            WCMFilter _filter)
                     throws WCMException
抛出：
WCMException

getSubmitFlowDocs

public FlowDocs getSubmitFlowDocs(User _operator,
                                  WCMFilter _filter)
                           throws WCMException
抛出：
WCMException

getCurrFlowFlag

public int getCurrFlowFlag(int contentType,
                           int contentId)
                    throws WCMException
参数：
contentType -
contentId -
返回：
抛出：
WCMException

getFlowDocsOfContent

public FlowDocs getFlowDocsOfContent(int contentType,
                                     int contentId)
                              throws WCMException
参数：
contentType -
contentId -
返回：
抛出：
WCMException

submitAgain

public void submitAgain(User user,
                        int flowDocId,
                        java.lang.String opinion)
                 throws WCMException
参数：
user -
flowDocId -
opinion -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowServerImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 FlowServerImpl

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.cms.process.FlowServerImpl
所有已实现的接口：
IFlowServer, IServer
public class FlowServerImpl
extends BaseServer
implements IFlowServer

Title: TRS 内容协作平台（TRS WCM）
Description:
FlowServer的默认实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static float INCREASE_FIELD_LENGTH_FACTOR
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
FlowServerImpl()
方法摘要
FlowDoc | autoToNextNode(FlowContext _context, FlowNode _nextNode) 自动将当前轨迹呈送到下一个节点
FlowDoc | autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers) 自动将当前轨迹呈送到下一个节点
boolean | backTo(FlowContext _oFlowContext) 要求返工
static FlowDoc | convertToFlowDocNotFlags(FlowDoc _flowDoc, int[] _pFlags)
boolean | doAccept(FlowContext _oFlowContext) 签收
boolean | doReceive(FlowContext _oFlowContext) 接收
boolean | forceEnd(FlowContext _oFlowContext) 强制结束
IFlowContent[] | getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户已经处理过的内容
IFlowContent[] | getFlowContentsDoneByUser(User _currUser) 获取指定用户已经处理过的内容
IFlowContent[] | getFlowContentsDoneByUser(User _currUser, CPager _cpager) 获取指定用户已经处理过的内容
IFlowContent[] | getFlowContentsInFlow(Flow _flow) 获取在指定流程中正在流转的内容
IFlowContent[] | getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户可以处理的内容
IFlowContent[] | getFlowContentsOfUser(User _currUser) 获取指定用户可以处理的内容
IFlowContent[] | getFlowContentsOfUser(User _currUser, CPager _cpager) 获取指定用户可以处理的内容
IFlowContent[] | getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户已经启动的内容
IFlowContent[] | getFlowContentsStartByUser(User _currUser) 获取指定用户已经启动的内容
IFlowContent[] | getFlowContentsStartByUser(User _currUser, CPager _cpager) 获取指定用户已经启动的内容
FlowDocs | getFlowDocs(IFlowContent _content, WCMFilter _extrFilter) 获取指定内容的流转轨迹
FlowNodes | getNextFlowNodes(FlowDoc _currFlowDoc, boolean _bIsResubmit) 获取当前轨迹的下一个处理节点
ContentProcessInfo | getProcessInfoOfContent(IFlowContent _content) 获取指定内容的流转情况
static FlowDoc | lookupRealBackFlowDocAgain(FlowDoc _flowDoc)
boolean | refuse(FlowContext _oFlowContext) 拒绝
boolean | resubmitTo(FlowContext _oFlowContext) 重新指派
boolean | submitTo(FlowContext _context) 处理内容
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.infra.IServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, restart, setServerName, shutdown, startup

字段详细信息

INCREASE_FIELD_LENGTH_FACTOR

public static final float INCREASE_FIELD_LENGTH_FACTOR
另请参见：
常量字段值
构造方法详细信息

FlowServerImpl

public FlowServerImpl()
方法详细信息

backTo

public boolean backTo(FlowContext _oFlowContext)
               throws WCMException
从接口 IFlowServer 复制的描述
要求返工

指定者：
接口 IFlowServer 中的 backTo
返回：
抛出：
WCMException

lookupRealBackFlowDocAgain

public static FlowDoc lookupRealBackFlowDocAgain(FlowDoc _flowDoc)
                                          throws WCMException
参数：
_flowDoc -
返回：
抛出：
WCMException

refuse

public boolean refuse(FlowContext _oFlowContext)
               throws WCMException
从接口 IFlowServer 复制的描述
拒绝

指定者：
接口 IFlowServer 中的 refuse
返回：
抛出：
WCMException

forceEnd

public boolean forceEnd(FlowContext _oFlowContext)
                 throws WCMException
从接口 IFlowServer 复制的描述
强制结束

指定者：
接口 IFlowServer 中的 forceEnd
返回：
抛出：
WCMException

doAccept

public boolean doAccept(FlowContext _oFlowContext)
                 throws WCMException
从接口 IFlowServer 复制的描述
签收

指定者：
接口 IFlowServer 中的 doAccept
返回：
抛出：
WCMException

doReceive

public boolean doReceive(FlowContext _oFlowContext)
                  throws WCMException
从接口 IFlowServer 复制的描述
接收

指定者：
接口 IFlowServer 中的 doReceive
返回：
抛出：
WCMException

getFlowContentsDoneByUser

public IFlowContent[] getFlowContentsDoneByUser(User _currUser)
                                         throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户已经处理过的内容

指定者：
接口 IFlowServer 中的 getFlowContentsDoneByUser
返回：
抛出：
WCMException

getFlowContentsDoneByUser

public IFlowContent[] getFlowContentsDoneByUser(User _currUser,
                                                CPager _cpager)
                                         throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户已经处理过的内容

指定者：
接口 IFlowServer 中的 getFlowContentsDoneByUser
返回：
抛出：
WCMException

getFlowContentsStartByUser

public IFlowContent[] getFlowContentsStartByUser(User _currUser,
                                                 CPager _cpager)
                                          throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户已经启动的内容

指定者：
接口 IFlowServer 中的 getFlowContentsStartByUser
返回：
抛出：
WCMException

getFlowContentsStartByUser

public IFlowContent[] getFlowContentsStartByUser(User _currUser)
                                          throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户已经启动的内容

指定者：
接口 IFlowServer 中的 getFlowContentsStartByUser
返回：
抛出：
WCMException

getFlowContentsInFlow

public IFlowContent[] getFlowContentsInFlow(Flow _flow)
                                     throws WCMException
从接口 IFlowServer 复制的描述
获取在指定流程中正在流转的内容

指定者：
接口 IFlowServer 中的 getFlowContentsInFlow
返回：
抛出：
WCMException

getFlowContentsOfUser

public IFlowContent[] getFlowContentsOfUser(User _currUser)
                                     throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户可以处理的内容

指定者：
接口 IFlowServer 中的 getFlowContentsOfUser
返回：
抛出：
WCMException

getFlowContentsOfUser

public IFlowContent[] getFlowContentsOfUser(User _currUser,
                                            CPager _cpager)
                                     throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户可以处理的内容

指定者：
接口 IFlowServer 中的 getFlowContentsOfUser
返回：
抛出：
WCMException

submitTo

public boolean submitTo(FlowContext _context)
                 throws WCMException
从接口 IFlowServer 复制的描述
处理内容

指定者：
接口 IFlowServer 中的 submitTo
返回：
抛出：
WCMException

getFlowDocs

public FlowDocs getFlowDocs(IFlowContent _content,
                            WCMFilter _extrFilter)
                     throws WCMException
从接口 IFlowServer 复制的描述
获取指定内容的流转轨迹

指定者：
接口 IFlowServer 中的 getFlowDocs
返回：
抛出：
WCMException

getNextFlowNodes

public FlowNodes getNextFlowNodes(FlowDoc _currFlowDoc,
                                  boolean _bIsResubmit)
                           throws WCMException
从接口 IFlowServer 复制的描述
获取当前轨迹的下一个处理节点

指定者：
接口 IFlowServer 中的 getNextFlowNodes
_bIsResubmit - 是否为重新提交的请求
返回：
抛出：
WCMException

convertToFlowDocNotFlags

public static FlowDoc convertToFlowDocNotFlags(FlowDoc _flowDoc,
                                               int[] _pFlags)
                                        throws WCMException
参数：
_flowDoc -
_pFlags -
返回：
抛出：
WCMException

getProcessInfoOfContent

public ContentProcessInfo getProcessInfoOfContent(IFlowContent _content)
                                           throws WCMException
从接口 IFlowServer 复制的描述
获取指定内容的流转情况

指定者：
接口 IFlowServer 中的 getProcessInfoOfContent
参数：
_content - 指定内容
返回：
抛出：
WCMException

autoToNextNode

public FlowDoc autoToNextNode(FlowContext _context,
                              FlowNode _nextNode)
                       throws WCMException
从接口 IFlowServer 复制的描述
自动将当前轨迹呈送到下一个节点

指定者：
接口 IFlowServer 中的 autoToNextNode
参数：
_context - 处理的上下文信息
_nextNode - 下一个节点
返回：
抛出：
WCMException

autoToNextNode

public FlowDoc autoToNextNode(FlowContext _context,
                              FlowNode _nextNode,
                              Users _toUsers)
                       throws WCMException
从接口 IFlowServer 复制的描述
自动将当前轨迹呈送到下一个节点

指定者：
接口 IFlowServer 中的 autoToNextNode
参数：
_context - 处理的上下文信息
_nextNode - 下一个节点
_toUsers - 指定的用户
返回：
抛出：
WCMException

resubmitTo

public boolean resubmitTo(FlowContext _oFlowContext)
                   throws WCMException
从接口 IFlowServer 复制的描述
重新指派

指定者：
接口 IFlowServer 中的 resubmitTo
返回：
抛出：
WCMException

getFlowContentsDoneByUser

public IFlowContent[] getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext)
                                         throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户已经处理过的内容

指定者：
接口 IFlowServer 中的 getFlowContentsDoneByUser
参数：
_oQueryFlowDocContext - 查询的上下文参数
返回：
抛出：
WCMException

getFlowContentsOfUser

public IFlowContent[] getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext)
                                     throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户可以处理的内容

指定者：
接口 IFlowServer 中的 getFlowContentsOfUser
参数：
_oQueryFlowDocContext - 查询的上下文参数
返回：
抛出：
WCMException

getFlowContentsStartByUser

public IFlowContent[] getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext)
                                          throws WCMException
从接口 IFlowServer 复制的描述
获取指定用户已经启动的内容

指定者：
接口 IFlowServer 中的 getFlowContentsStartByUser
参数：
_oQueryFlowDocContext - 查询的上下文参数
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFlowCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
接口 IFlowCacheMgr

所有已知实现类：
FlowCacheMgr
public interface IFlowCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 FlowNode findFlowNodeByName(int _nFlowId, java.lang.String _sNodeName)

方法详细信息

findFlowNodeByName

FlowNode findFlowNodeByName(int _nFlowId,
                            java.lang.String _sNodeName)
                            throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFlowContent

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
接口 IFlowContent

所有超级接口：
ICMSObjSubstanceContent
所有已知实现类：
FlowContentApplyFormImpl, FlowContentDocumentImpl, MyFlowContentDocumentImpl
public interface IFlowContent
extends ICMSObjSubstanceContent

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | cancelUpdate(User user) 取消本次更新
boolean | canEdit(User _currUser) 判断当前操作用户是否可以对当前流转的内容进行修改
java.lang.String | getContentAddEditPage() 获取内容的编辑页面
java.lang.String | getContentShowPage() 获取内容的查看页面
int | getContentType() 获取当前流转内容的类型
User | getCrUser()
java.lang.String | getDeletePage()
java.lang.String | getDesc() 获取当前流转内容的简要描述
FlowDoc | getFlowDoc() 获取FlowContent相关的FlowDoc
Flow | getOwnerFlow() 获取当前所属对象的工作流对象
java.lang.String | getProperty(java.lang.String _sName) 获取指定属性的名称
java.lang.String | getPublishPage()
long | getSerialNum() 获取内容被发起的SerialNum
CMyDateTime | getStartTime() 获取内容被发起的时间
java.lang.String | getStatusDesc() 获取状态的描述
int | getStatusId()
CMSObj | getSubinstance() 获取流转内容关联的对象
int | getSubinstanceId() 获取当前流转内容的ID
boolean | isDeleted()
void | setFlow(Flow flow)
void | setFlowDoc(FlowDoc _flowDoc) 设置FlowContent相关的FlowDoc
void | setSerialNum(long _lSerialNum) 设置内容被发起时候的SerialNum
void | setStartTime(CMyDateTime _dtStartTime) 设置内容被发起的时间
void | setSubinstance(CMSObj _subinstance)
void | setSubinstance(int _nSubinstanceId) 设置当前Content的关联ID
void | updateStatus(User user, int statusId) 更新当前内容的工作流状态
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

方法详细信息

canEdit

boolean canEdit(User _currUser)
                throws WCMException
判断当前操作用户是否可以对当前流转的内容进行修改

参数：
_currUser -
返回：
抛出：
WCMException

getOwnerFlow

Flow getOwnerFlow()
                  throws WCMException
获取当前所属对象的工作流对象

返回：
抛出：
WCMException

getDesc

java.lang.String getDesc()
                         throws WCMException
获取当前流转内容的简要描述

返回：
抛出：
WCMException

getContentType

int getContentType()
获取当前流转内容的类型

返回：

getSubinstanceId

int getSubinstanceId()
                     throws WCMException
获取当前流转内容的ID

返回：
抛出：
WCMException

setSubinstance

void setSubinstance(int _nSubinstanceId)
                    throws WCMException
设置当前Content的关联ID

参数：
_nSubinstanceId - 新的ID（比如文档ID）
抛出：
WCMException

setSubinstance

void setSubinstance(CMSObj _subinstance)
                    throws WCMException
抛出：
WCMException

getSubinstance

CMSObj getSubinstance()
                      throws WCMException
获取流转内容关联的对象

返回：
抛出：
WCMException

updateStatus

void updateStatus(User user,
                  int statusId)
                  throws WCMException
更新当前内容的工作流状态

参数：
user -
statusId -
抛出：
WCMException

cancelUpdate

void cancelUpdate(User user)
                  throws WCMException
取消本次更新

参数：
user -
抛出：
WCMException

getCrUser

User getCrUser()
               throws WCMException
返回：
抛出：
WCMException

getStatusId

int getStatusId()
                throws WCMException
返回：
抛出：
WCMException

getStatusDesc

java.lang.String getStatusDesc()
                               throws WCMException
获取状态的描述

返回：
抛出：
WCMException

getContentShowPage

java.lang.String getContentShowPage()
                                    throws WCMException
获取内容的查看页面

返回：
内容的查看页面
抛出：
WCMException

getDeletePage

java.lang.String getDeletePage()
                               throws WCMException
抛出：
WCMException

getPublishPage

java.lang.String getPublishPage()
                                throws WCMException
抛出：
WCMException

getContentAddEditPage

java.lang.String getContentAddEditPage()
                                       throws WCMException
获取内容的编辑页面

返回：
内容的编辑页面
抛出：
WCMException

setFlowDoc

void setFlowDoc(FlowDoc _flowDoc)
设置FlowContent相关的FlowDoc

参数：
_flowDoc -

getFlowDoc

FlowDoc getFlowDoc()
获取FlowContent相关的FlowDoc

返回：

getProperty

java.lang.String getProperty(java.lang.String _sName)
                             throws WCMException
获取指定属性的名称

参数：
_sName -
返回：
抛出：
WCMException

setStartTime

void setStartTime(CMyDateTime _dtStartTime)
设置内容被发起的时间

抛出：
WCMException

getStartTime

CMyDateTime getStartTime()
获取内容被发起的时间

返回：

setSerialNum

void setSerialNum(long _lSerialNum)
设置内容被发起时候的SerialNum

抛出：
WCMException

getSerialNum

long getSerialNum()
获取内容被发起的SerialNum

返回：

isDeleted

boolean isDeleted()
返回：

setFlow

void setFlow(Flow flow)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFlowNotifyWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
接口 IFlowNotifyWorker

所有已知实现类：
FlowNotifyWorkerImpl
public interface IFlowNotifyWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, int _nNotify)
void | addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)
void | addMsgEvent(User _currUser, User _toUser, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)

方法详细信息

addMsgEvent

void addMsgEvent(User _currUser,
                 Users _toUsers,
                 java.lang.String _sTitle,
                 java.lang.String _sDesc,
                 int _nNotify)

addMsgEvent

void addMsgEvent(User _currUser,
                 Users _toUsers,
                 java.lang.String _sTitle,
                 java.lang.String _sDesc,
                 java.lang.String _sNotifyTypes)

addMsgEvent

void addMsgEvent(User _currUser,
                 User _toUser,
                 java.lang.String _sTitle,
                 java.lang.String _sDesc,
                 java.lang.String _sNotifyTypes)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFlowServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
接口 IFlowServer

所有超级接口：
IServer
所有已知实现类：
FlowServerImpl
public interface IFlowServer
extends IServer

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流流转驱动器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
FlowDoc | autoToNextNode(FlowContext _context, FlowNode _nextNode) 自动将当前轨迹呈送到下一个节点
FlowDoc | autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers) 自动将当前轨迹呈送到下一个节点
boolean | backTo(FlowContext _oFlowContext) 要求返工
boolean | doAccept(FlowContext _oFlowContext) 签收
boolean | doReceive(FlowContext _oFlowContext) 接收
boolean | forceEnd(FlowContext _oFlowContext) 强制结束
IFlowContent[] | getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户已经处理过的内容
IFlowContent[] | getFlowContentsDoneByUser(User _currUser) 获取指定用户已经处理过的内容
IFlowContent[] | getFlowContentsDoneByUser(User _currUser, CPager _cpager) 获取指定用户已经处理过的内容
IFlowContent[] | getFlowContentsInFlow(Flow _flow) 获取在指定流程中正在流转的内容
IFlowContent[] | getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户可以处理的内容
IFlowContent[] | getFlowContentsOfUser(User _currUser) 获取指定用户可以处理的内容
IFlowContent[] | getFlowContentsOfUser(User _currUser, CPager _cpager) 获取指定用户可以处理的内容
IFlowContent[] | getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户已经启动的内容
IFlowContent[] | getFlowContentsStartByUser(User _currUser) 获取指定用户已经启动的内容
IFlowContent[] | getFlowContentsStartByUser(User _currUser, CPager _cpager) 获取指定用户已经启动的内容
FlowDocs | getFlowDocs(IFlowContent _content, WCMFilter _extrFilter) 获取指定内容的流转轨迹
FlowNodes | getNextFlowNodes(FlowDoc _currFlowDoc, boolean _bIsResubmit) 获取当前轨迹的下一个处理节点
ContentProcessInfo | getProcessInfoOfContent(IFlowContent _content) 获取指定内容的流转情况
boolean | refuse(FlowContext _oFlowContext) 拒绝
boolean | resubmitTo(FlowContext _oFlowContext) 重新指派
boolean | submitTo(FlowContext _oFlowContext) 处理内容
从接口 com.trs.infra.IServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, restart, setServerName, shutdown, startup

方法详细信息

submitTo

boolean submitTo(FlowContext _oFlowContext)
                 throws WCMException
处理内容

返回：
抛出：
WCMException

backTo

boolean backTo(FlowContext _oFlowContext)
               throws WCMException
要求返工

参数：
_oFlowContext -
返回：
抛出：
WCMException

refuse

boolean refuse(FlowContext _oFlowContext)
               throws WCMException
拒绝

参数：
_oFlowContext -
返回：
抛出：
WCMException

forceEnd

boolean forceEnd(FlowContext _oFlowContext)
                 throws WCMException
强制结束

参数：
_oFlowContext -
返回：
抛出：
WCMException

resubmitTo

boolean resubmitTo(FlowContext _oFlowContext)
                   throws WCMException
重新指派

参数：
_oFlowContext -
返回：
抛出：
WCMException

doReceive

boolean doReceive(FlowContext _oFlowContext)
                  throws WCMException
接收

参数：
_oFlowContext -
返回：
抛出：
WCMException

doAccept

boolean doAccept(FlowContext _oFlowContext)
                 throws WCMException
签收

参数：
_oFlowContext -
返回：
抛出：
WCMException

getFlowContentsOfUser

IFlowContent[] getFlowContentsOfUser(User _currUser)
                                     throws WCMException
获取指定用户可以处理的内容

参数：
_currUser -
返回：
抛出：
WCMException

getFlowContentsOfUser

IFlowContent[] getFlowContentsOfUser(User _currUser,
                                     CPager _cpager)
                                     throws WCMException
获取指定用户可以处理的内容

参数：
_currUser -
返回：
抛出：
WCMException

getFlowContentsOfUser

IFlowContent[] getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext)
                                     throws WCMException
获取指定用户可以处理的内容

参数：
_oQueryFlowDocContext - 查询的上下文参数
返回：
抛出：
WCMException

getFlowContentsDoneByUser

IFlowContent[] getFlowContentsDoneByUser(User _currUser)
                                         throws WCMException
获取指定用户已经处理过的内容

参数：
_currUser -
返回：
抛出：
WCMException

getFlowContentsDoneByUser

IFlowContent[] getFlowContentsDoneByUser(User _currUser,
                                         CPager _cpager)
                                         throws WCMException
获取指定用户已经处理过的内容

参数：
_currUser -
返回：
抛出：
WCMException

getFlowContentsDoneByUser

IFlowContent[] getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext)
                                         throws WCMException
获取指定用户已经处理过的内容

参数：
_oQueryFlowDocContext - 查询的上下文参数
返回：
抛出：
WCMException

getFlowContentsStartByUser

IFlowContent[] getFlowContentsStartByUser(User _currUser)
                                          throws WCMException
获取指定用户已经启动的内容

参数：
_currUser -
返回：
抛出：
WCMException

getFlowContentsStartByUser

IFlowContent[] getFlowContentsStartByUser(User _currUser,
                                          CPager _cpager)
                                          throws WCMException
获取指定用户已经启动的内容

参数：
_currUser -
返回：
抛出：
WCMException

getFlowContentsStartByUser

IFlowContent[] getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext)
                                          throws WCMException
获取指定用户已经启动的内容

参数：
_oQueryFlowDocContext - 查询的上下文参数
返回：
抛出：
WCMException

getFlowContentsInFlow

IFlowContent[] getFlowContentsInFlow(Flow _flow)
                                     throws WCMException
获取在指定流程中正在流转的内容

参数：
_currUser -
返回：
抛出：
WCMException

getFlowDocs

FlowDocs getFlowDocs(IFlowContent _content,
                     WCMFilter _extrFilter)
                     throws WCMException
获取指定内容的流转轨迹

参数：
_content -
_extrFilter -
返回：
抛出：
WCMException

getNextFlowNodes

FlowNodes getNextFlowNodes(FlowDoc _currFlowDoc,
                           boolean _bIsResubmit)
                           throws WCMException
获取当前轨迹的下一个处理节点

参数：
_currFlowDoc -
_bIsResubmit - 是否为重新提交的请求
返回：
抛出：
WCMException

getProcessInfoOfContent

ContentProcessInfo getProcessInfoOfContent(IFlowContent _content)
                                           throws WCMException
获取指定内容的流转情况

参数：
_content - 指定内容
返回：
抛出：
WCMException

autoToNextNode

FlowDoc autoToNextNode(FlowContext _context,
                       FlowNode _nextNode)
                       throws WCMException
自动将当前轨迹呈送到下一个节点

参数：
_context - 处理的上下文信息
_nextNode - 下一个节点
返回：
抛出：
WCMException

autoToNextNode

FlowDoc autoToNextNode(FlowContext _context,
                       FlowNode _nextNode,
                       Users _toUsers)
                       throws WCMException
自动将当前轨迹呈送到下一个节点

参数：
_context - 处理的上下文信息
_nextNode - 下一个节点
_toUsers - 指定的用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MailContentHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 MailContentHelper

java.lang.Object
    继承者  com.trs.cms.process.MailContentHelper

public class MailContentHelper
extends java.lang.Object

构造方法摘要
MailContentHelper()
方法摘要
static void | main(java.lang.String[] args)
static java.lang.String | makeEmailContent(java.util.Map _hParamValues)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MailContentHelper

public MailContentHelper()
方法详细信息

makeEmailContent

public static java.lang.String makeEmailContent(java.util.Map _hParamValues)
                                         throws java.lang.Exception
参数：
_hParamValues -
返回：
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.process
接口
IFlowCacheMgr
IFlowContent
IFlowNotifyWorker
IFlowServer
类
FlowContentFactory
FlowEngineHelper
FlowingDocLogger
FlowingDocOptMarkScouter
FlowServer
FlowServerImpl
MailContentHelper
ProcessConstants
QueryFlowDocContext


com.trs.cms.process

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.process

接口摘要
IFlowCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IFlowContent | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IFlowNotifyWorker | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IFlowServer | Title: TRS 内容协作平台（TRS WCM） Description: 工作流流转驱动器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
FlowContentFactory | Title: TRS 内容协作平台（TRS WCM） Description: 产生可以流转的内容 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowEngineHelper |
FlowingDocLogger | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowingDocOptMarkScouter | Title: TRS 内容协作平台（TRS WCM 6.0） Description: 流转中文档的操作标签监控器 Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowServer |
FlowServerImpl | Title: TRS 内容协作平台（TRS WCM） Description: FlowServer的默认实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MailContentHelper |
ProcessConstants | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
QueryFlowDocContext |


com.trs.cms.process 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.process 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.cms.process.FlowServer
      • com.trs.cms.process.FlowServerImpl (implements com.trs.cms.process.IFlowServer)
    • com.trs.cms.process.FlowContentFactory
    • com.trs.cms.process.FlowEngineHelper
    • com.trs.cms.process.FlowingDocLogger
    • com.trs.cms.process.FlowingDocOptMarkScouter
    • com.trs.cms.process.MailContentHelper
    • com.trs.cms.process.ProcessConstants
    • com.trs.cms.process.QueryFlowDocContext

接口分层结构

  • com.trs.cms.content.ICMSObjSubstanceContent
    • com.trs.cms.process.IFlowContent
  • com.trs.cms.process.IFlowCacheMgr
  • com.trs.cms.process.IFlowNotifyWorker
  • com.trs.infra.IServer
    • com.trs.cms.process.IFlowServer


软件包 com.trs.cms.process 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.process
的使用

使用 com.trs.cms.process 的软件包
com.trs.ajaxservice
com.trs.cms.process
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.components.gkml.sqgk.process.element
com.trs.components.wcm.process
com.trs.components.wcm.process.element

com.trs.ajaxservice 使用的 com.trs.cms.process 中的类
IFlowContent
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process 使用的 com.trs.cms.process 中的类
FlowServer
IFlowContent
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFlowServer
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流流转驱动器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
QueryFlowDocContext

com.trs.cms.process.definition 使用的 com.trs.cms.process 中的类
IFlowCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine 使用的 com.trs.cms.process 中的类
IFlowContent
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.cms.process 中的类
IFlowContent
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process 使用的 com.trs.cms.process 中的类
IFlowNotifyWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process.element 使用的 com.trs.cms.process 中的类
IFlowContent
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ProcessConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 ProcessConstants

java.lang.Object
    继承者  com.trs.cms.process.ProcessConstants

public class ProcessConstants
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | COMMENTS_DELIM 轨迹为会签用户同时产生意见标示
static int | FLAG_AUTOTO 文档流转标志：自动流转产生
static int | FLAG_BACK 文档流转标志：要求返工
static int | FLAG_EXCEPTION 文档流转标志：工作流发生异常
static int | FLAG_FINISHED 文档流转标志：已经结束
static int | FLAG_FORCEEND 文档流转标志：强行结束
static int | FLAG_FORWARD 文档流转标志：向前流转
static int | FLAG_JOIN_AND_AGREE 文档流转标志：参与会签并且同意
static int | FLAG_JOIN_AND_LAST 文档流转标志：会签最后一个人提交处理
static int | FLAG_JOIN_SEPERATOR_AND_AGREE 文档流转标志：参与并联审批并且同意
static int | FLAG_MAX_NEED_DOWITH 文档流转标志：需要人处理的Flag最大值
static int | FLAG_OTHER_DOWITH 文档流转标志：别人已经处理
static int | FLAG_PASSED 文档流转标志：已经经过
static int | FLAG_REFUSED 文档流转标志：拒绝
static int | FLAG_RESUBMIT 文档流转标志：重新处理
static int | FLAG_START 文档流转标志：起始位置
static int | OBJTYPE_FLOWEMPLPOY
static int | OPERATOR_EUQALS
static int | OPERATOR_GREATER
static int | OPERATOR_GREATER_EUQALS
static int | OPERATOR_LENGTH
static int | OPERATOR_LESS
static int | OPERATOR_LESS_EUQALS
static int | OPERATOR_LIKE
static int | OPERATOR_NOT_EUQALS
static int | OPERATOR_NOT_LIKE
static int | RULE_TRIGGER_ON_ACCEPT 签收时触发的规则
static int | RULE_TRIGGER_ON_BACK 打回时触发的规则
static int | RULE_TRIGGER_ON_DOING 处理过程中触发的规则
static int | RULE_TRIGGER_ON_END 结束处理时触发的规则
static int | RULE_TRIGGER_ON_ENTER 进入节点时候触发的规则
static int | RULE_TRIGGER_ON_RECEIVE 收到时候触发的规则
static int | RULE_TRIGGER_ON_REFUSE 拒绝时触发的规则
static int[] | RULE_TRIGGERS 定义的所有触发规则
static java.lang.String | VARNAME_CONTENTTITLE 内容标题
static java.lang.String | VARNAME_CURRDATETIME 当前时间
static java.lang.String | VARNAME_RECEIVERNAME 接受人名称
static java.lang.String | VARNAME_SENDERNAME 发送者名称
static int | WORKMODAL_NORM 一般处理模式，其中一个人处理，就可以继续流转
static int | WORKMODAL_SEPERATOR_END 并联审批处理结束模式，处理完以后，汇总后继续流转
static int | WORKMODAL_SEPERATOR_START 并联审批处理开始模式，各自处理，看不见对方处理记录
static int | WORKMODAL_TOGETHER 会签处理模式，需要都处理完，才能继续留转
构造方法摘要
ProcessConstants()
方法摘要
static java.lang.String | getFlagDesc(int _flag) 显示文档在工作流中的状态描述
static java.lang.String | getWorkModalDesc(int _nWorkModal) 获取处理模式描述
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RULE_TRIGGER_ON_RECEIVE

public static final int RULE_TRIGGER_ON_RECEIVE
收到时候触发的规则

另请参见：
常量字段值

RULE_TRIGGER_ON_ACCEPT

public static final int RULE_TRIGGER_ON_ACCEPT
签收时触发的规则

另请参见：
常量字段值

RULE_TRIGGER_ON_DOING

public static final int RULE_TRIGGER_ON_DOING
处理过程中触发的规则

另请参见：
常量字段值

RULE_TRIGGER_ON_END

public static final int RULE_TRIGGER_ON_END
结束处理时触发的规则

另请参见：
常量字段值

RULE_TRIGGER_ON_BACK

public static final int RULE_TRIGGER_ON_BACK
打回时触发的规则

另请参见：
常量字段值

RULE_TRIGGER_ON_ENTER

public static final int RULE_TRIGGER_ON_ENTER
进入节点时候触发的规则

另请参见：
常量字段值

RULE_TRIGGER_ON_REFUSE

public static final int RULE_TRIGGER_ON_REFUSE
拒绝时触发的规则

另请参见：
常量字段值

RULE_TRIGGERS

public static final int[] RULE_TRIGGERS
定义的所有触发规则

FLAG_START

public static final int FLAG_START
文档流转标志：起始位置

另请参见：
常量字段值

FLAG_FORWARD

public static final int FLAG_FORWARD
文档流转标志：向前流转

另请参见：
常量字段值

FLAG_BACK

public static final int FLAG_BACK
文档流转标志：要求返工

另请参见：
常量字段值

FLAG_AUTOTO

public static final int FLAG_AUTOTO
文档流转标志：自动流转产生

另请参见：
常量字段值

FLAG_RESUBMIT

public static final int FLAG_RESUBMIT
文档流转标志：重新处理

另请参见：
常量字段值

FLAG_MAX_NEED_DOWITH

public static final int FLAG_MAX_NEED_DOWITH
文档流转标志：需要人处理的Flag最大值

另请参见：
常量字段值

FLAG_PASSED

public static final int FLAG_PASSED
文档流转标志：已经经过

另请参见：
常量字段值

FLAG_EXCEPTION

public static final int FLAG_EXCEPTION
文档流转标志：工作流发生异常

另请参见：
常量字段值

FLAG_FORCEEND

public static final int FLAG_FORCEEND
文档流转标志：强行结束

另请参见：
常量字段值

FLAG_REFUSED

public static final int FLAG_REFUSED
文档流转标志：拒绝

另请参见：
常量字段值

FLAG_OTHER_DOWITH

public static final int FLAG_OTHER_DOWITH
文档流转标志：别人已经处理

另请参见：
常量字段值

FLAG_JOIN_AND_AGREE

public static final int FLAG_JOIN_AND_AGREE
文档流转标志：参与会签并且同意

另请参见：
常量字段值

FLAG_JOIN_SEPERATOR_AND_AGREE

public static final int FLAG_JOIN_SEPERATOR_AND_AGREE
文档流转标志：参与并联审批并且同意

另请参见：
常量字段值

FLAG_JOIN_AND_LAST

public static final int FLAG_JOIN_AND_LAST
文档流转标志：会签最后一个人提交处理

另请参见：
常量字段值

FLAG_FINISHED

public static final int FLAG_FINISHED
文档流转标志：已经结束

另请参见：
常量字段值

WORKMODAL_NORM

public static final int WORKMODAL_NORM
一般处理模式，其中一个人处理，就可以继续流转

另请参见：
常量字段值

WORKMODAL_TOGETHER

public static final int WORKMODAL_TOGETHER
会签处理模式，需要都处理完，才能继续留转

另请参见：
常量字段值

WORKMODAL_SEPERATOR_START

public static final int WORKMODAL_SEPERATOR_START
并联审批处理开始模式，各自处理，看不见对方处理记录

另请参见：
常量字段值

WORKMODAL_SEPERATOR_END

public static final int WORKMODAL_SEPERATOR_END
并联审批处理结束模式，处理完以后，汇总后继续流转

另请参见：
常量字段值

OBJTYPE_FLOWEMPLPOY

public static final int OBJTYPE_FLOWEMPLPOY
另请参见：
常量字段值

COMMENTS_DELIM

public static final java.lang.String COMMENTS_DELIM
轨迹为会签用户同时产生意见标示

另请参见：
常量字段值

VARNAME_RECEIVERNAME

public static final java.lang.String VARNAME_RECEIVERNAME
接受人名称

另请参见：
常量字段值

VARNAME_SENDERNAME

public static final java.lang.String VARNAME_SENDERNAME
发送者名称

另请参见：
常量字段值

VARNAME_CONTENTTITLE

public static final java.lang.String VARNAME_CONTENTTITLE
内容标题

另请参见：
常量字段值

VARNAME_CURRDATETIME

public static final java.lang.String VARNAME_CURRDATETIME
当前时间

另请参见：
常量字段值

OPERATOR_LIKE

public static final int OPERATOR_LIKE
另请参见：
常量字段值

OPERATOR_NOT_LIKE

public static final int OPERATOR_NOT_LIKE
另请参见：
常量字段值

OPERATOR_EUQALS

public static final int OPERATOR_EUQALS
另请参见：
常量字段值

OPERATOR_NOT_EUQALS

public static final int OPERATOR_NOT_EUQALS
另请参见：
常量字段值

OPERATOR_GREATER_EUQALS

public static final int OPERATOR_GREATER_EUQALS
另请参见：
常量字段值

OPERATOR_GREATER

public static final int OPERATOR_GREATER
另请参见：
常量字段值

OPERATOR_LESS

public static final int OPERATOR_LESS
另请参见：
常量字段值

OPERATOR_LESS_EUQALS

public static final int OPERATOR_LESS_EUQALS
另请参见：
常量字段值

OPERATOR_LENGTH

public static final int OPERATOR_LENGTH
另请参见：
常量字段值
构造方法详细信息

ProcessConstants

public ProcessConstants()
方法详细信息

getFlagDesc

public static java.lang.String getFlagDesc(int _flag)
显示文档在工作流中的状态描述

参数：
_flag - 工作流流转标志(FlowDoc.FLAG_START)
返回：
文档在工作流中的状态描述

getWorkModalDesc

public static java.lang.String getWorkModalDesc(int _nWorkModal)
获取处理模式描述

参数：
_nWorkModal -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


QueryFlowDocContext

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process
类 QueryFlowDocContext

java.lang.Object
    继承者  com.trs.cms.process.QueryFlowDocContext

public class QueryFlowDocContext
extends java.lang.Object

构造方法摘要
QueryFlowDocContext()
方法摘要
int | getContentType()
User | getCurrUser()
CPager | getPager()
java.lang.Object | getParameter(java.lang.String _sParameterName)
CMyDateTime | getParameter(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
int | getParameter(java.lang.String _sParameterName, int _nDefaultValue)
java.lang.String | getParameter(java.lang.String _sParameterName, java.lang.String _sDefaultValue)
void | setContentType(int _sContentType)
void | setCurrUser(User _sCurrUser)
void | setPager(CPager _sPager)
void | setParameter(java.lang.String _sParameterName, CMyDateTime _sValue)
void | setParameter(java.lang.String _sParameterName, int _nValue)
void | setParameter(java.lang.String _sParameterName, java.lang.String _sValue)
void | setParameterValue(java.lang.String _sParameterName, java.lang.Object _oParameterValue)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

QueryFlowDocContext

public QueryFlowDocContext()
方法详细信息

getPager

public CPager getPager()

setPager

public void setPager(CPager _sPager)

getContentType

public int getContentType()

setContentType

public void setContentType(int _sContentType)

getCurrUser

public User getCurrUser()

setCurrUser

public void setCurrUser(User _sCurrUser)

setParameterValue

public void setParameterValue(java.lang.String _sParameterName,
                              java.lang.Object _oParameterValue)

getParameter

public java.lang.Object getParameter(java.lang.String _sParameterName)

getParameter

public java.lang.String getParameter(java.lang.String _sParameterName,
                                     java.lang.String _sDefaultValue)

setParameter

public void setParameter(java.lang.String _sParameterName,
                         java.lang.String _sValue)

getParameter

public int getParameter(java.lang.String _sParameterName,
                        int _nDefaultValue)

setParameter

public void setParameter(java.lang.String _sParameterName,
                         int _nValue)

getParameter

public CMyDateTime getParameter(java.lang.String _sParameterName,
                                CMyDateTime _dtDefaultValue)

setParameter

public void setParameter(java.lang.String _sParameterName,
                         CMyDateTime _sValue)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.process.FlowContentFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.FlowContentFactory
的使用

没有 com.trs.cms.process.FlowContentFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.FlowEngineHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.FlowEngineHelper
的使用

没有 com.trs.cms.process.FlowEngineHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.FlowingDocLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.FlowingDocLogger
的使用

没有 com.trs.cms.process.FlowingDocLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.FlowingDocOptMarkScouter 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.FlowingDocOptMarkScouter
的使用

没有 com.trs.cms.process.FlowingDocOptMarkScouter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.FlowServer 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.FlowServer
的使用

使用 FlowServer 的软件包
com.trs.cms.process

com.trs.cms.process 中 FlowServer 的使用

返回 FlowServer 的 com.trs.cms.process 中的方法
static FlowServer FlowServer.getFlowServer()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.FlowServerImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.FlowServerImpl
的使用

没有 com.trs.cms.process.FlowServerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.IFlowCacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.IFlowCacheMgr
的使用

使用 IFlowCacheMgr 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 IFlowCacheMgr 的使用

实现 IFlowCacheMgr 的 com.trs.cms.process.definition 中的类
 class FlowCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流缓冲管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.IFlowContent 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.IFlowContent
的使用

使用 IFlowContent 的软件包
com.trs.ajaxservice
com.trs.cms.process
com.trs.cms.process.engine
com.trs.components.gkml.sqgk.process.element
com.trs.components.wcm.process.element

com.trs.ajaxservice 中 IFlowContent 的使用

返回 IFlowContent 的 com.trs.ajaxservice 中的方法
IFlowContent[] | ProcessService.getContentsInFlow(MethodContext _methodContext) 获取在指定的工作流中流转的内容列表
IFlowContent[] | ProcessService.getContentsOfUser(MethodContext _MethodContext) 获取需要用户处理的内容

com.trs.cms.process 中 IFlowContent 的使用

返回 IFlowContent 的 com.trs.cms.process 中的方法
IFlowContent[] | FlowServerImpl.getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext)
IFlowContent[] | IFlowServer.getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户已经处理过的内容
IFlowContent[] | FlowServerImpl.getFlowContentsDoneByUser(User _currUser)
IFlowContent[] | IFlowServer.getFlowContentsDoneByUser(User _currUser) 获取指定用户已经处理过的内容
IFlowContent[] | FlowServerImpl.getFlowContentsDoneByUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsDoneByUser(User _currUser, CPager _cpager) 获取指定用户已经处理过的内容
IFlowContent[] | FlowServerImpl.getFlowContentsInFlow(Flow _flow)
IFlowContent[] | IFlowServer.getFlowContentsInFlow(Flow _flow) 获取在指定流程中正在流转的内容
IFlowContent[] | FlowServerImpl.getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext)
IFlowContent[] | IFlowServer.getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户可以处理的内容
IFlowContent[] | FlowServerImpl.getFlowContentsOfUser(User _currUser)
IFlowContent[] | IFlowServer.getFlowContentsOfUser(User _currUser) 获取指定用户可以处理的内容
IFlowContent[] | FlowServerImpl.getFlowContentsOfUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsOfUser(User _currUser, CPager _cpager) 获取指定用户可以处理的内容
IFlowContent[] | FlowServerImpl.getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext)
IFlowContent[] | IFlowServer.getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户已经启动的内容
IFlowContent[] | FlowServerImpl.getFlowContentsStartByUser(User _currUser)
IFlowContent[] | IFlowServer.getFlowContentsStartByUser(User _currUser) 获取指定用户已经启动的内容
IFlowContent[] | FlowServerImpl.getFlowContentsStartByUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsStartByUser(User _currUser, CPager _cpager) 获取指定用户已经启动的内容
static IFlowContent | FlowContentFactory.makeFlowContent(CMSObj _substance)
static IFlowContent | FlowContentFactory.makeFlowContent(int _nContentType, int _nContentId)

参数类型为 IFlowContent 的 com.trs.cms.process 中的方法
void | FlowServer.forceDocToEnd(IFlowContent _currDoc, User _currUser)
FlowDoc | FlowServer.getFlowDoc(IFlowContent _content) 取指定文档对应的FlowDoc对象
FlowDocs | FlowServerImpl.getFlowDocs(IFlowContent _content, WCMFilter _extrFilter)
FlowDocs | IFlowServer.getFlowDocs(IFlowContent _content, WCMFilter _extrFilter) 获取指定内容的流转轨迹
ContentProcessInfo | FlowServerImpl.getProcessInfoOfContent(IFlowContent _content)
ContentProcessInfo | IFlowServer.getProcessInfoOfContent(IFlowContent _content) 获取指定内容的流转情况
boolean | FlowServer.isCanInFlow(IFlowContent _content)
FlowDoc | FlowServer.removeFlowDoc(IFlowContent _doc)
FlowDoc | FlowServer.removeFlowDoc(IFlowContent _doc, User _currUser) 从FlowServer移去指定的FlowDoc对象
FlowDoc | FlowServer.startContentInFlow(User _currUser, IFlowContent _doc)
FlowDoc | FlowServer.startContentInFlow(User _currUser, IFlowContent _content, java.lang.String _sPostDesc) 为文档对象添加新的FlowDoc对象，使文档进入工作流流转
FlowDoc | FlowServer.submitBack(User _currUser, IFlowContent _doc, java.lang.String _sPostDesc)
FlowDoc | FlowServer.submitBack(User _currUser, IFlowContent _content, java.lang.String _sOpinion, int _nStatusId) 将文档返回到上一个节点，并返回给指定的用户

com.trs.cms.process.engine 中 IFlowContent 的使用

返回 IFlowContent 的 com.trs.cms.process.engine 中的方法
static IFlowContent | FlowContentHelper.createFlowContent(CMSObj _subinstance)
static IFlowContent | FlowContentHelper.createFlowContent(int _nObjType, int _nObjId)
IFlowContent | ContentProcessInfo.getContent()
IFlowContent | FlowContentConfig.getFlowContent()
IFlowContent | FlowParamers.getFlowContent()
IFlowContent | ExecuteContext.getFlowContent() 获取当前正在处理的内容
IFlowContent | FlowContext.getFlowContent()
IFlowContent | FlowDoc.getFlowContent()
IFlowContent | FlowContextOld.getFlowContent() 获取当前处理的流转对象（WCMObj），可以是文档，也可以是其它的类

参数类型为 IFlowContent 的 com.trs.cms.process.engine 中的方法
void | ContentProcessInfo.setContent(IFlowContent content)
void | FlowDoc.setContent(IFlowContent flowContent) 设置相关内容
void | FlowParamers.setFlowContent(IFlowContent flowContent)
void | FlowContext.setFlowContent(IFlowContent flowContent)
boolean | FlowDoc.setFlowContent(IFlowContent _content) 设置所属文档

参数类型为 IFlowContent 的 com.trs.cms.process.engine 中的构造方法
ContentProcessInfo(boolean _bEnd, IFlowContent _content, java.lang.String _sUserName)
FlowContext(User _currUser, IFlowContent _oFlowContent)
内容开始流转时候的FlowContext构造函数
FlowContext(User _currUser, IFlowContent _oFlowContent, java.lang.String _sPostDesc, Users _toUsers, Flow _flow)
内容开始流转时候的FlowContext构造函数
FlowContextOld(IFlowContent _currObj, FlowNode _currNode, User _postUser)
工作流环境变量记录对象的构造函数

com.trs.components.gkml.sqgk.process.element 中 IFlowContent 的使用

实现 IFlowContent 的 com.trs.components.gkml.sqgk.process.element 中的类
 class FlowContentApplyFormImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
Document的FlowContent的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process.element 中 IFlowContent 的使用

实现 IFlowContent 的 com.trs.components.wcm.process.element 中的类
class | FlowContentDocumentImpl Title: TRS 内容协作平台（TRS WCM） Description: Document的FlowContent的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MyFlowContentDocumentImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.IFlowNotifyWorker 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.IFlowNotifyWorker
的使用

使用 IFlowNotifyWorker 的软件包
com.trs.components.wcm.process

com.trs.components.wcm.process 中 IFlowNotifyWorker 的使用

实现 IFlowNotifyWorker 的 com.trs.components.wcm.process 中的类
 class FlowNotifyWorkerImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.IFlowServer 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.IFlowServer
的使用

使用 IFlowServer 的软件包
com.trs.cms.process

com.trs.cms.process 中 IFlowServer 的使用

实现 IFlowServer 的 com.trs.cms.process 中的类
 class FlowServerImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
FlowServer的默认实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.MailContentHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.MailContentHelper
的使用

没有 com.trs.cms.process.MailContentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.ProcessConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.ProcessConstants
的使用

没有 com.trs.cms.process.ProcessConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.QueryFlowDocContext 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.QueryFlowDocContext
的使用

使用 QueryFlowDocContext 的软件包
com.trs.cms.process

com.trs.cms.process 中 QueryFlowDocContext 的使用

参数类型为 QueryFlowDocContext 的 com.trs.cms.process 中的方法
IFlowContent[] | FlowServerImpl.getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext)
IFlowContent[] | IFlowServer.getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户已经处理过的内容
IFlowContent[] | FlowServerImpl.getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext)
IFlowContent[] | IFlowServer.getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户可以处理的内容
IFlowContent[] | FlowServerImpl.getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext)
IFlowContent[] | IFlowServer.getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext) 获取指定用户已经启动的内容

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ActionHandlerConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 ActionHandlerConfig

java.lang.Object
    继承者  com.trs.cms.process.config.ActionHandlerConfig

public class ActionHandlerConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ActionHandlerConfig()
方法摘要
void | addParamConfig(ParamConfig ParamConfig)
java.lang.String | getClassName()
java.lang.String | getDesc()
java.lang.String | getName()
ParamConfig[] | getParamConfigs()
void | setClassName(java.lang.String className)
void | setDesc(java.lang.String desc)
void | setName(java.lang.String name)
void | setParamConfigs(ParamConfig[] paramConfigs)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActionHandlerConfig

public ActionHandlerConfig()
方法详细信息

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String className)
                  throws WCMException
参数：
className -
抛出：
WCMException

getDesc

public java.lang.String getDesc()
返回：

setDesc

public void setDesc(java.lang.String desc)
参数：
desc -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

addParamConfig

public void addParamConfig(ParamConfig ParamConfig)

getParamConfigs

public ParamConfig[] getParamConfigs()
返回：

setParamConfigs

public void setParamConfigs(ParamConfig[] paramConfigs)
参数：
paramConfigs -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ConditionHandlerConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 ConditionHandlerConfig

java.lang.Object
    继承者  com.trs.cms.process.config.ConditionHandlerConfig

public class ConditionHandlerConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的条件配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConditionHandlerConfig()
方法摘要
void | addParamConfig(ParamConfig ParamConfig)
java.lang.String | getClassName()
java.lang.String | getDesc()
java.lang.String | getName()
ParamConfig[] | getParamConfigs()
void | setClassName(java.lang.String className)
void | setDesc(java.lang.String desc)
void | setName(java.lang.String name)
void | setParamConfigs(ParamConfig[] paramConfigs)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConditionHandlerConfig

public ConditionHandlerConfig()
方法详细信息

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String className)
                  throws WCMException
参数：
className -
抛出：
WCMException

getDesc

public java.lang.String getDesc()
返回：

setDesc

public void setDesc(java.lang.String desc)
参数：
desc -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

addParamConfig

public void addParamConfig(ParamConfig ParamConfig)

getParamConfigs

public ParamConfig[] getParamConfigs()
返回：

setParamConfigs

public void setParamConfigs(ParamConfig[] paramConfigs)
参数：
paramConfigs -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowConfigServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 FlowConfigServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.cms.process.config.FlowConfigServer
所有已实现的接口：
IServer
public class FlowConfigServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流配置服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
FlowConfigServer()
方法摘要
void | addContentTypeConfig(FlowContentTypeConfig contentTypeConfig)
FlowContentTypeConfig | findContentTypeConfig(int _nContentType) 根据类型获取指定的内容配置信息
ActionHandlerConfig[] | getActionHandlerConfigs()
ConditionHandlerConfig[] | getConditionHandlerConfigs()
java.lang.String | getConfigFileContent() 获取配置文件的内容
org.dom4j.Element | getConfigFileRootElement()
FlowContentTypeConfig[] | getContentTypeConfigs()
ToUsersCreatorConfig | getToUsersCreatorConfigByName(java.lang.String _sName)
ToUsersCreatorConfig | getToUsersCreatorConfigByName(java.lang.String _sName, java.lang.String _sParams)
ToUsersCreatorConfig[] | getToUsersCreatorConfigs()
void | setContentTypeConfigs(FlowContentTypeConfig[] contentTypeConfigs)
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowConfigServer

public FlowConfigServer()
方法详细信息

getConditionHandlerConfigs

public ConditionHandlerConfig[] getConditionHandlerConfigs()
返回：

getActionHandlerConfigs

public ActionHandlerConfig[] getActionHandlerConfigs()
返回：

getToUsersCreatorConfigs

public ToUsersCreatorConfig[] getToUsersCreatorConfigs()
返回：

getToUsersCreatorConfigByName

public ToUsersCreatorConfig getToUsersCreatorConfigByName(java.lang.String _sName)
参数：
_sName -
返回：

getToUsersCreatorConfigByName

public ToUsersCreatorConfig getToUsersCreatorConfigByName(java.lang.String _sName,
                                                          java.lang.String _sParams)

getContentTypeConfigs

public FlowContentTypeConfig[] getContentTypeConfigs()
返回：

findContentTypeConfig

public FlowContentTypeConfig findContentTypeConfig(int _nContentType)
根据类型获取指定的内容配置信息

参数：
_nContentType -
返回：

setContentTypeConfigs

public void setContentTypeConfigs(FlowContentTypeConfig[] contentTypeConfigs)
参数：
contentTypeConfigs -

addContentTypeConfig

public void addContentTypeConfig(FlowContentTypeConfig contentTypeConfig)

getConfigFileRootElement

public org.dom4j.Element getConfigFileRootElement()
返回：

getConfigFileContent

public java.lang.String getConfigFileContent()
获取配置文件的内容

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContentField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 FlowContentField

java.lang.Object
    继承者  com.trs.cms.process.config.FlowContentField

public class FlowContentField
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
流转的内容字段描述对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContentField(FlowContentTypeConfig _FlowContentTypeConfig)
方法摘要
FlowContentTypeConfig | getContentTypeConfig()
java.lang.String | getDBName()
java.lang.String | getName()
void | setContentTypeConfig(FlowContentTypeConfig contentTypeConfig)
void | setDBName(java.lang.String name)
void | setName(java.lang.String name)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContentField

public FlowContentField(FlowContentTypeConfig _FlowContentTypeConfig)
方法详细信息

getContentTypeConfig

public FlowContentTypeConfig getContentTypeConfig()
返回：

setContentTypeConfig

public void setContentTypeConfig(FlowContentTypeConfig contentTypeConfig)
参数：
contentTypeConfig -

getDBName

public java.lang.String getDBName()
返回：

setDBName

public void setDBName(java.lang.String name)
参数：
name -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContentTypeConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 FlowContentTypeConfig

java.lang.Object
    继承者  com.trs.cms.process.config.FlowContentTypeConfig

public class FlowContentTypeConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
可以流转的对象配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContentTypeConfig()
方法摘要
void | addContentField(FlowContentField contentField)
java.lang.String | getClassName()
java.lang.Class | getContentClass()
FlowContentField[] | getContentFields()
int | getContentType()
java.lang.String | getDBTableName()
java.lang.String | getDesc()
java.lang.String | getName()
void | setClassName(java.lang.String className)
void | setContentFields(FlowContentField[] contentFields)
void | setDBTableName(java.lang.String tableName)
void | setDesc(java.lang.String desc)
void | setName(java.lang.String name)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FlowContentTypeConfig

public FlowContentTypeConfig()
方法详细信息

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String className)
                  throws WCMException
参数：
className -
抛出：
WCMException

getDBTableName

public java.lang.String getDBTableName()
返回：

setDBTableName

public void setDBTableName(java.lang.String tableName)
参数：
tableName -

getDesc

public java.lang.String getDesc()
返回：

setDesc

public void setDesc(java.lang.String desc)
参数：
desc -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getContentFields

public FlowContentField[] getContentFields()
返回：

setContentFields

public void setContentFields(FlowContentField[] contentFields)
参数：
contentFields -

addContentField

public void addContentField(FlowContentField contentField)

getContentType

public int getContentType()
返回：

getContentClass

public java.lang.Class getContentClass()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OperatorConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 OperatorConfig

java.lang.Object
    继承者  com.trs.cms.process.config.OperatorConfig

public class OperatorConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
OperatorConfig()
方法摘要
java.lang.String | getName()
java.lang.String | getValue()
void | setName(java.lang.String name)
void | setValue(java.lang.String value)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OperatorConfig

public OperatorConfig()
方法详细信息

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

getValue

public java.lang.String getValue()
返回：

setValue

public void setValue(java.lang.String value)
参数：
value -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.process.config
类
ActionHandlerConfig
ConditionHandlerConfig
FlowConfigServer
FlowContentField
FlowContentTypeConfig
OperatorConfig
ParamConfig
ToUsersCreatorConfig
ValueConfig


com.trs.cms.process.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.process.config

类摘要
ActionHandlerConfig | Title: TRS 内容协作平台（TRS WCM） Description: 工作流支持的操作配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ConditionHandlerConfig | Title: TRS 内容协作平台（TRS WCM） Description: 工作流支持的条件配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowConfigServer | Title: TRS 内容协作平台（TRS WCM） Description: 工作流配置服务器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentField | Title: TRS 内容协作平台（TRS WCM） Description: 流转的内容字段描述对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentTypeConfig | Title: TRS 内容协作平台（TRS WCM） Description: 可以流转的对象配置信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
OperatorConfig | Title: TRS 内容协作平台（TRS WCM） Description: 操作配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ParamConfig | Title: TRS 内容协作平台（TRS WCM） Description: 参数配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ToUsersCreatorConfig | Title: TRS 内容协作平台（TRS WCM） Description: 工作流支持的操作配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ValueConfig | Title: TRS 内容协作平台（TRS WCM） Description: 操作配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.cms.process.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.process.config.ActionHandlerConfig
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.cms.process.config.FlowConfigServer
    • com.trs.cms.process.config.ConditionHandlerConfig
    • com.trs.cms.process.config.FlowContentField
    • com.trs.cms.process.config.FlowContentTypeConfig
    • com.trs.cms.process.config.OperatorConfig
    • com.trs.cms.process.config.ParamConfig
    • com.trs.cms.process.config.ToUsersCreatorConfig
    • com.trs.cms.process.config.ValueConfig


软件包 com.trs.cms.process.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.config
的使用

使用 com.trs.cms.process.config 的软件包
com.trs.cms.process.config
com.trs.cms.process.engine
com.trs.cms.process.engine.creators
com.trs.components.gkml.sqgk.process.engine.creators

com.trs.cms.process.config 使用的 com.trs.cms.process.config 中的类
ActionHandlerConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConditionHandlerConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的条件配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentField
Title: TRS 内容协作平台（TRS WCM）
Description:
流转的内容字段描述对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentTypeConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
可以流转的对象配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OperatorConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ParamConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
参数配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ToUsersCreatorConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ValueConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine 使用的 com.trs.cms.process.config 中的类
ToUsersCreatorConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine.creators 使用的 com.trs.cms.process.config 中的类
ToUsersCreatorConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.engine.creators 使用的 com.trs.cms.process.config 中的类
ToUsersCreatorConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ParamConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 ParamConfig

java.lang.Object
    继承者  com.trs.cms.process.config.ParamConfig

public class ParamConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
参数配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ParamConfig()
方法摘要
void | addOperatorConfig(OperatorConfig OperatorConfig)
void | addValueConfig(ValueConfig ValueConfig)
java.lang.String | getDefaultValue()
java.lang.String | getDesc()
java.lang.String | getName()
OperatorConfig[] | getOperatorConfigs()
java.lang.String | getType()
java.lang.String | getUnit()
ValueConfig[] | getValueConfigs()
void | setDefaultValue(java.lang.String defaultValue)
void | setDesc(java.lang.String desc)
void | setName(java.lang.String name)
void | setOperatorConfigs(OperatorConfig[] operatorConfigs)
void | setType(java.lang.String type)
void | setUnit(java.lang.String unit)
void | setValueConfigs(ValueConfig[] operatorConfigs)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ParamConfig

public ParamConfig()
方法详细信息

getDesc

public java.lang.String getDesc()
返回：

setDesc

public void setDesc(java.lang.String desc)
参数：
desc -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

getType

public java.lang.String getType()
返回：

setType

public void setType(java.lang.String type)
参数：
type -

getUnit

public java.lang.String getUnit()
返回：

setUnit

public void setUnit(java.lang.String unit)
参数：
unit -

addOperatorConfig

public void addOperatorConfig(OperatorConfig OperatorConfig)

getOperatorConfigs

public OperatorConfig[] getOperatorConfigs()
返回：

setOperatorConfigs

public void setOperatorConfigs(OperatorConfig[] operatorConfigs)
参数：
operatorConfigs -

addValueConfig

public void addValueConfig(ValueConfig ValueConfig)

getValueConfigs

public ValueConfig[] getValueConfigs()
返回：

setValueConfigs

public void setValueConfigs(ValueConfig[] operatorConfigs)
参数：
operatorConfigs -

getDefaultValue

public java.lang.String getDefaultValue()
返回：

setDefaultValue

public void setDefaultValue(java.lang.String defaultValue)
参数：
defaultValue -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ToUsersCreatorConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 ToUsersCreatorConfig

java.lang.Object
    继承者  com.trs.cms.process.config.ToUsersCreatorConfig

public class ToUsersCreatorConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String ATTRIBUTES_DILIM
构造方法摘要
ToUsersCreatorConfig()
方法摘要
java.lang.String | getAttribute(java.lang.String _sName)
java.lang.String | getClassName()
Group | getGroupRange(FlowContext _context)
java.lang.String | getName()
Users | getToUsers(FlowContext _context) 根据当前的配置获取处理者
void | setAttribute(java.lang.String _sName, java.lang.String _sValue)
void | setAttributes(java.lang.String _sParams)
void | setClassName(java.lang.String className)
void | setName(java.lang.String name)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ATTRIBUTES_DILIM

public static final java.lang.String ATTRIBUTES_DILIM
另请参见：
常量字段值
构造方法详细信息

ToUsersCreatorConfig

public ToUsersCreatorConfig()
方法详细信息

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String className)
                  throws WCMException
参数：
className -
抛出：
WCMException

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

setAttribute

public void setAttribute(java.lang.String _sName,
                         java.lang.String _sValue)
参数：
_sName -
_sValue -

getAttribute

public java.lang.String getAttribute(java.lang.String _sName)
参数：
_sName -
返回：

getToUsers

public Users getToUsers(FlowContext _context)
                 throws WCMException
根据当前的配置获取处理者

参数：
_context -
返回：
抛出：
WCMException

getGroupRange

public Group getGroupRange(FlowContext _context)
                    throws WCMException
抛出：
WCMException

setAttributes

public void setAttributes(java.lang.String _sParams)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.config
类 ValueConfig

java.lang.Object
    继承者  com.trs.cms.process.config.ValueConfig

public class ValueConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ValueConfig()
方法摘要
java.lang.String | getDesc()
java.lang.String | getName()
void | setDesc(java.lang.String value)
void | setName(java.lang.String name)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ValueConfig

public ValueConfig()
方法详细信息

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

getDesc

public java.lang.String getDesc()
返回：

setDesc

public void setDesc(java.lang.String value)
参数：
value -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.process.config.ActionHandlerConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.ActionHandlerConfig
的使用

使用 ActionHandlerConfig 的软件包
com.trs.cms.process.config

com.trs.cms.process.config 中 ActionHandlerConfig 的使用

返回 ActionHandlerConfig 的 com.trs.cms.process.config 中的方法
 ActionHandlerConfig[] FlowConfigServer.getActionHandlerConfigs()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.config.ConditionHandlerConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.ConditionHandlerConfig
的使用

使用 ConditionHandlerConfig 的软件包
com.trs.cms.process.config

com.trs.cms.process.config 中 ConditionHandlerConfig 的使用

返回 ConditionHandlerConfig 的 com.trs.cms.process.config 中的方法
 ConditionHandlerConfig[] FlowConfigServer.getConditionHandlerConfigs()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.config.FlowConfigServer 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.FlowConfigServer
的使用

没有 com.trs.cms.process.config.FlowConfigServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.config.FlowContentField 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.FlowContentField
的使用

使用 FlowContentField 的软件包
com.trs.cms.process.config

com.trs.cms.process.config 中 FlowContentField 的使用

返回 FlowContentField 的 com.trs.cms.process.config 中的方法
 FlowContentField[] FlowContentTypeConfig.getContentFields()

参数类型为 FlowContentField 的 com.trs.cms.process.config 中的方法
void | FlowContentTypeConfig.addContentField(FlowContentField contentField)
void | FlowContentTypeConfig.setContentFields(FlowContentField[] contentFields)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.config.FlowContentTypeConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.FlowContentTypeConfig
的使用

使用 FlowContentTypeConfig 的软件包
com.trs.cms.process.config

com.trs.cms.process.config 中 FlowContentTypeConfig 的使用

返回 FlowContentTypeConfig 的 com.trs.cms.process.config 中的方法
FlowContentTypeConfig | FlowConfigServer.findContentTypeConfig(int _nContentType) 根据类型获取指定的内容配置信息
FlowContentTypeConfig | FlowContentField.getContentTypeConfig()
FlowContentTypeConfig[] | FlowConfigServer.getContentTypeConfigs()

参数类型为 FlowContentTypeConfig 的 com.trs.cms.process.config 中的方法
void | FlowConfigServer.addContentTypeConfig(FlowContentTypeConfig contentTypeConfig)
void | FlowContentField.setContentTypeConfig(FlowContentTypeConfig contentTypeConfig)
void | FlowConfigServer.setContentTypeConfigs(FlowContentTypeConfig[] contentTypeConfigs)

参数类型为 FlowContentTypeConfig 的 com.trs.cms.process.config 中的构造方法
FlowContentField(FlowContentTypeConfig _FlowContentTypeConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.config.OperatorConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.OperatorConfig
的使用

使用 OperatorConfig 的软件包
com.trs.cms.process.config

com.trs.cms.process.config 中 OperatorConfig 的使用

返回 OperatorConfig 的 com.trs.cms.process.config 中的方法
 OperatorConfig[] ParamConfig.getOperatorConfigs()

参数类型为 OperatorConfig 的 com.trs.cms.process.config 中的方法
void | ParamConfig.addOperatorConfig(OperatorConfig OperatorConfig)
void | ParamConfig.setOperatorConfigs(OperatorConfig[] operatorConfigs)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.config.ParamConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.ParamConfig
的使用

使用 ParamConfig 的软件包
com.trs.cms.process.config

com.trs.cms.process.config 中 ParamConfig 的使用

返回 ParamConfig 的 com.trs.cms.process.config 中的方法
ParamConfig[] | ActionHandlerConfig.getParamConfigs()
ParamConfig[] | ConditionHandlerConfig.getParamConfigs()

参数类型为 ParamConfig 的 com.trs.cms.process.config 中的方法
void | ActionHandlerConfig.addParamConfig(ParamConfig ParamConfig)
void | ConditionHandlerConfig.addParamConfig(ParamConfig ParamConfig)
void | ActionHandlerConfig.setParamConfigs(ParamConfig[] paramConfigs)
void | ConditionHandlerConfig.setParamConfigs(ParamConfig[] paramConfigs)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.config.ToUsersCreatorConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.ToUsersCreatorConfig
的使用

使用 ToUsersCreatorConfig 的软件包
com.trs.cms.process.config
com.trs.cms.process.engine
com.trs.cms.process.engine.creators
com.trs.components.gkml.sqgk.process.engine.creators

com.trs.cms.process.config 中 ToUsersCreatorConfig 的使用

返回 ToUsersCreatorConfig 的 com.trs.cms.process.config 中的方法
ToUsersCreatorConfig | FlowConfigServer.getToUsersCreatorConfigByName(java.lang.String _sName)
ToUsersCreatorConfig | FlowConfigServer.getToUsersCreatorConfigByName(java.lang.String _sName, java.lang.String _sParams)
ToUsersCreatorConfig[] | FlowConfigServer.getToUsersCreatorConfigs()

com.trs.cms.process.engine 中 ToUsersCreatorConfig 的使用

参数类型为 ToUsersCreatorConfig 的 com.trs.cms.process.engine 中的方法
Users | IToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig) 根据当前上下文信息产生处理者信息
Group | AbstractToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)
Group | IToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig) 限定了用户选择范围（在特定组内选择）

com.trs.cms.process.engine.creators 中 ToUsersCreatorConfig 的使用

参数类型为 ToUsersCreatorConfig 的 com.trs.cms.process.engine.creators 中的方法
Users | GroupAdminsFromChnlAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupMembersAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsFromFlowAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | RoleAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | DeptMgrAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | CrUserAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsFromSupportPartAsToUsersCreator.createToUsers(FlowContext flowContext, ToUsersCreatorConfig _oCreatorConfig)
Group | GroupMembersAsToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)

com.trs.components.gkml.sqgk.process.engine.creators 中 ToUsersCreatorConfig 的使用

参数类型为 ToUsersCreatorConfig 的 com.trs.components.gkml.sqgk.process.engine.creators 中的方法
Users | LawGovTousersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | ApplyFormToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.config.ValueConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.config.ValueConfig
的使用

使用 ValueConfig 的软件包
com.trs.cms.process.config

com.trs.cms.process.config 中 ValueConfig 的使用

返回 ValueConfig 的 com.trs.cms.process.config 中的方法
 ValueConfig[] ParamConfig.getValueConfigs()

参数类型为 ValueConfig 的 com.trs.cms.process.config 中的方法
void | ParamConfig.addValueConfig(ValueConfig ValueConfig)
void | ParamConfig.setValueConfigs(ValueConfig[] operatorConfigs)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Flow

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 Flow

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.Flow
所有已实现的接口：
java.lang.Cloneable
public class Flow
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
Flow()
构造函数：保留默认接口
方法摘要
static Flow | createNewInstance() 产生当前对象[Flow]的实例
int | delete(User _currUser) 重载父类delete函数，删除与工作流相关的信息（流转中的文档、节点、频道中工作流的设置等）
static Flow | findById(int _nId) 提取指定ID的对象
static Flow | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取工作流描述
FlowNode | getEndNode() 获取结束节点
java.lang.String | getEndNodeName() 设置结束节点名称
FlowNodes | getFlowNodes(User _currUser) 取得工作流节点集合
java.lang.String | getIdFieldName() 获得Id字段名。
Groups | getMonitorGroups(User _currUser) 取工作流的监控用户组
Users | getMonitorUsers(User _currUser) 取工作流的监控用户
java.lang.String | getName() 获取工作流名称
BaseObj | getOwner() 获取工作流所属的对象
int | getOwnerId()
int | getOwnerType()
int | getSiteId() 获取工作流所属的站点ID
FlowNode | getStartNode() 获取起始节点
java.lang.String | getStartNodeName() 获取起始节点名称
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检查对象数据是否有效
boolean | setAttribute(java.lang.String _sAttribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setDesc(java.lang.String _desc) 设置工作流描述
boolean | setEndNodeName(java.lang.String _sNodeName) 设置结束节点名称
boolean | setName(java.lang.String _name) 设置工作流名称
boolean | setOwner(int _nOwnerType, int _nOwnerId)
boolean | setOwnerId(int _nOwnerId)
boolean | setOwnerType(int _nOwnerType)
boolean | setStartNodeName(java.lang.String _sNodeName) 设置起始节点名称
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Flow

public Flow()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
CMSObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
CMSObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
CMSObj.getWCMType()

getName

public java.lang.String getName()
获取工作流名称

返回：
工作流名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置工作流名称

参数：
_name - 工作流名称
返回：
抛出：
WCMException

getStartNodeName

public java.lang.String getStartNodeName()
获取起始节点名称

返回：
起始节点名称

setStartNodeName

public boolean setStartNodeName(java.lang.String _sNodeName)
                         throws WCMException
设置起始节点名称

参数：
_sNodeName - 起始节点名称
返回：
抛出：
WCMException

getStartNode

public FlowNode getStartNode()
                      throws WCMException
获取起始节点

返回：
起始节点对象
抛出：
WCMException

getEndNodeName

public java.lang.String getEndNodeName()
设置结束节点名称

返回：
结束节点名称

setEndNodeName

public boolean setEndNodeName(java.lang.String _sNodeName)
                       throws WCMException
设置结束节点名称

参数：
_sNodeName - 结束节点名称
返回：
抛出：
WCMException

getEndNode

public FlowNode getEndNode()
                    throws WCMException
获取结束节点

返回：
结束节点对象
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取工作流描述

返回：
工作流描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置工作流描述

参数：
_desc - 工作流描述
返回：
抛出：
WCMException

getSiteId

public int getSiteId()
获取工作流所属的站点ID

返回：
工作流所属的站点ID

getOwner

public BaseObj getOwner()
                 throws WCMException
获取工作流所属的对象

返回：
工作流所属的对象(BaseObj)
抛出：
WCMException

setOwner

public boolean setOwner(int _nOwnerType,
                        int _nOwnerId)
                 throws WCMException
抛出：
WCMException

setOwnerType

public boolean setOwnerType(int _nOwnerType)
                     throws WCMException
抛出：
WCMException

getOwnerType

public int getOwnerType()

setOwnerId

public boolean setOwnerId(int _nOwnerId)
                   throws WCMException
抛出：
WCMException

getOwnerId

public int getOwnerId()

getAttribute

public java.lang.String getAttribute()
覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _sAttribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_sAttribute -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查对象数据是否有效

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 1、新增模式下，以下属性没有设置将会引起异常（工作流名称、所属站点、开始和结束节点名称） 2、工作流名称不唯一也会引起异常
另请参见：
CMSObj.isValid()

delete

public int delete(User _currUser)
           throws WCMException
重载父类delete函数，删除与工作流相关的信息（流转中的文档、节点、频道中工作流的设置等）

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException
另请参见：
CMSObj.delete( User _currUser)

getFlowNodes

public FlowNodes getFlowNodes(User _currUser)
                       throws WCMException
取得工作流节点集合

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

getMonitorUsers

public Users getMonitorUsers(User _currUser)
                      throws WCMException
取工作流的监控用户

参数：
_currUser - 当前操作用户
返回：
工作流的监控用户集合（Users）
抛出：
WCMException

getMonitorGroups

public Groups getMonitorGroups(User _currUser)
                        throws WCMException
取工作流的监控用户组

参数：
_currUser - 当前操作用户
返回：
工作流的监控用户组集合
抛出：
WCMException

findById

public static final Flow findById(int _nId)
                           throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Flow createNewInstance()
                                    throws WCMException
产生当前对象[Flow]的实例

返回：
当前对象的实例[Flow]
抛出：
WCMException

findByKey

public static final Flow findByKey(java.lang.Object _oKey)
                            throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FlowAction

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowAction

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.FlowAction
所有已实现的接口：
java.lang.Cloneable
public class FlowAction
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
FlowAction()
构造函数：保留默认接口
方法摘要
static FlowAction | createNewInstance() 产生当前对象[FlowAction]的实例
static FlowAction | findById(int _nId) 提取指定ID的对象
static FlowAction | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getHandler() 提取属性：Handler
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getOrder() 提取属性：Order
java.lang.String | getParams() 提取属性：Params
int | getRuleId() 提取属性：RuleId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setHandler(java.lang.Class _class)
boolean | setHandler(java.lang.String _sHandler) 设置属性：Handler
boolean | setOrder(int _nOrder) 设置属性：Order
boolean | setParams(java.lang.String _sParams) 设置属性：Params
boolean | setRuleId(int _nRuleId) 设置属性：RuleId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowAction

public FlowAction()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getParams

public java.lang.String getParams()
提取属性：Params

返回：
Params

setParams

public boolean setParams(java.lang.String _sParams)
                  throws WCMException
设置属性：Params

参数：
_sParams - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRuleId

public int getRuleId()
提取属性：RuleId

返回：
RuleId

setRuleId

public boolean setRuleId(int _nRuleId)
                  throws WCMException
设置属性：RuleId

参数：
_nRuleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHandler

public java.lang.String getHandler()
提取属性：Handler

返回：
Handler

setHandler

public boolean setHandler(java.lang.String _sHandler)
                   throws WCMException
设置属性：Handler

参数：
_sHandler - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setHandler

public boolean setHandler(java.lang.Class _class)
                   throws WCMException
参数：
_class -
返回：
抛出：
WCMException

getOrder

public int getOrder()
提取属性：Order

返回：
Order

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置属性：Order

参数：
_nOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final FlowAction findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowAction createNewInstance()
                                          throws WCMException
产生当前对象[FlowAction]的实例

返回：
当前对象的实例[FlowAction]
抛出：
WCMException

findByKey

public static final FlowAction findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowActions

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowActions

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.FlowActions

public class FlowActions
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowActions(User _currUser)
构造函数
FlowActions(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static FlowActions | createNewInstance(User _currUser) 产生当前集合对象[FlowActions]的实例
static FlowActions | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static FlowActions | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowActions]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowActions

public FlowActions(User _currUser)
构造函数

另请参见：
FlowActions( User _currUser, int _initCapacity, int _incCapacity );

FlowActions

public FlowActions(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final FlowActions findByIds(User _currUser,
                                          java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowActions）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowActions openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[FlowActions]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowActions]
抛出：
WCMException

createNewInstance

public static FlowActions createNewInstance(User _currUser)
产生当前集合对象[FlowActions]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowCacheMgr

java.lang.Object
    继承者  com.trs.cms.process.definition.FlowCacheMgr
所有已实现的接口：
IFlowCacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class FlowCacheMgr
extends java.lang.Object
implements ICacheMgr, IFlowCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流缓冲管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
FlowNode | findFlowNodeByName(int _nFlowId, java.lang.String _sNodeName)
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowCacheMgr

public FlowCacheMgr()
方法详细信息

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

findFlowNodeByName

public FlowNode findFlowNodeByName(int _nFlowId,
                                   java.lang.String _sNodeName)
                            throws WCMException
指定者：
接口 IFlowCacheMgr 中的 findFlowNodeByName
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowCondition

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowCondition

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.FlowCondition
所有已实现的接口：
java.lang.Cloneable
public class FlowCondition
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
FlowCondition()
构造函数：保留默认接口
方法摘要
static FlowCondition | createNewInstance() 产生当前对象[FlowCondition]的实例
static FlowCondition | findById(int _nId) 提取指定ID的对象
static FlowCondition | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getHandler() 提取属性：Handler
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getOrder() 提取属性：Order
java.lang.String | getParamName() 提取属性：ParamName
java.lang.String | getParamValue() 提取属性：ParamValue
java.lang.String | getRelationOperator() 提取属性：RelationOperator
int | getRuleId() 提取属性：RuleId
java.lang.String | getUnitValue() 提取属性：UnitValue
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isAndOperator() 提取属性：LogicOperator
boolean | isValid() 检验对象数据有效性
boolean | setHandler(java.lang.Class _class)
boolean | setHandler(java.lang.String _sHandler) 设置属性：Handler
boolean | setIsAndOperator(boolean _bIsAndOperator) 设置属性：LogicOperator
boolean | setOrder(int _nOrder) 设置属性：Order
boolean | setParamName(java.lang.String _sParamName) 设置属性：ParamName
boolean | setParamValue(java.lang.String _sParamValue) 设置属性：ParamValue
boolean | setRelationOperator(java.lang.String _sRelationOperator) 设置属性：RelationOperator
boolean | setRuleId(int _nRuleId) 设置属性：RuleId
boolean | setUnitValue(java.lang.String _sUnitValue) 设置属性：UnitValue
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowCondition

public FlowCondition()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getHandler

public java.lang.String getHandler()
提取属性：Handler

返回：
Handler

setHandler

public boolean setHandler(java.lang.String _sHandler)
                   throws WCMException
设置属性：Handler

参数：
_sHandler - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setHandler

public boolean setHandler(java.lang.Class _class)
                   throws WCMException
参数：
_class -
返回：
抛出：
WCMException

getParamName

public java.lang.String getParamName()
提取属性：ParamName

返回：
ParamName

setParamName

public boolean setParamName(java.lang.String _sParamName)
                     throws WCMException
设置属性：ParamName

参数：
_sParamName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getParamValue

public java.lang.String getParamValue()
提取属性：ParamValue

返回：
ParamValue

setParamValue

public boolean setParamValue(java.lang.String _sParamValue)
                      throws WCMException
设置属性：ParamValue

参数：
_sParamValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRelationOperator

public java.lang.String getRelationOperator()
提取属性：RelationOperator

返回：
RelationOperator

setRelationOperator

public boolean setRelationOperator(java.lang.String _sRelationOperator)
                            throws WCMException
设置属性：RelationOperator

参数：
_sRelationOperator - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getUnitValue

public java.lang.String getUnitValue()
提取属性：UnitValue

返回：
ParamName

setUnitValue

public boolean setUnitValue(java.lang.String _sUnitValue)
                     throws WCMException
设置属性：UnitValue

参数：
_sUnitValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isAndOperator

public boolean isAndOperator()
提取属性：LogicOperator

返回：
LogicOperator

setIsAndOperator

public boolean setIsAndOperator(boolean _bIsAndOperator)
                         throws WCMException
设置属性：LogicOperator

参数：
_bIsAndOperator - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRuleId

public int getRuleId()
提取属性：RuleId

返回：
RuleId

setRuleId

public boolean setRuleId(int _nRuleId)
                  throws WCMException
设置属性：RuleId

参数：
_nRuleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOrder

public int getOrder()
提取属性：Order

返回：
Order

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置属性：Order

参数：
_nOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final FlowCondition findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowCondition createNewInstance()
                                             throws WCMException
产生当前对象[FlowCondition]的实例

返回：
当前对象的实例[FlowCondition]
抛出：
WCMException

findByKey

public static final FlowCondition findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowConditions

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowConditions

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.FlowConditions

public class FlowConditions
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowConditions(User _currUser)
构造函数
FlowConditions(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static FlowConditions | createNewInstance(User _currUser) 产生当前集合对象[FlowConditions]的实例
static FlowConditions | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static FlowConditions | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowConditions]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowConditions

public FlowConditions(User _currUser)
构造函数

另请参见：
FlowConditions( User _currUser, int _initCapacity, int _incCapacity );

FlowConditions

public FlowConditions(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final FlowConditions findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowConditions）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowConditions openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[FlowConditions]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowConditions]
抛出：
WCMException

createNewInstance

public static FlowConditions createNewInstance(User _currUser)
产生当前集合对象[FlowConditions]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowdocLog

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowdocLog

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.FlowdocLog
所有已实现的接口：
java.lang.Cloneable
public class FlowdocLog
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
FlowdocLog()
构造函数：保留默认接口
方法摘要
static FlowdocLog | createNewInstance() 产生当前对象[FlowdocLog]的实例
static FlowdocLog | findById(int _nId) 提取指定ID的对象
static FlowdocLog | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getActionDesc() 提取属性：ActionDesc
int | getActionFlag() 提取属性：ActionFlag
int | getBranchId() 提取属性：BranchId
int | getChannelId() 提取属性：ChannelId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getFlowdocId() 提取属性：FlowdocId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getObjId() 提取属性：ObjId
int | getObjType() 提取属性：ObjType
java.lang.String | getPostUser() 提取属性：PostUser
int | getSiteId() 提取属性：SiteId
int | getUserGroupId() 提取属性：UserGroupId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isStarting() 提取属性：Starting
boolean | isValid() 检验对象数据有效性
boolean | setActionDesc(java.lang.String _sActionDesc) 设置属性：ActionDesc
boolean | setActionFlag(int _nActionFlag) 设置属性：ActionFlag
boolean | setBranchId(int _nBranchId) 设置属性：BranchId
boolean | setChannelId(int _nChannelId) 设置属性：ChannelId
boolean | setFlowdocId(int _nFlowdocId) 设置属性：FlowdocId
boolean | setObjId(int _nObjId) 设置属性：ObjId
boolean | setObjType(int _nObjType) 设置属性：ObjType
boolean | setPostUser(java.lang.String _sPostUser) 设置属性：PostUser
boolean | setSiteId(int _nSiteId) 设置属性：SiteId
boolean | setStarting(boolean _bStarting) 设置属性：Starting
boolean | setUserGroupId(int _nUserGroupId) 设置属性：UserGroupId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowdocLog

public FlowdocLog()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getPostUser

public java.lang.String getPostUser()
提取属性：PostUser

返回：
PostUser

setPostUser

public boolean setPostUser(java.lang.String _sPostUser)
                    throws WCMException
设置属性：PostUser

参数：
_sPostUser - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getActionDesc

public java.lang.String getActionDesc()
提取属性：ActionDesc

返回：
ActionDesc

setActionDesc

public boolean setActionDesc(java.lang.String _sActionDesc)
                      throws WCMException
设置属性：ActionDesc

参数：
_sActionDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getActionFlag

public int getActionFlag()
提取属性：ActionFlag

返回：
ActionFlag

setActionFlag

public boolean setActionFlag(int _nActionFlag)
                      throws WCMException
设置属性：ActionFlag

参数：
_nActionFlag - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

public int getObjId()
提取属性：ObjId

返回：
ObjId

setObjId

public boolean setObjId(int _nObjId)
                 throws WCMException
设置属性：ObjId

参数：
_nObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjType

public int getObjType()
提取属性：ObjType

返回：
ObjType

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
设置属性：ObjType

参数：
_nObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getChannelId

public int getChannelId()
提取属性：ChannelId

返回：
ChannelId

setChannelId

public boolean setChannelId(int _nChannelId)
                     throws WCMException
设置属性：ChannelId

参数：
_nChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSiteId

public int getSiteId()
提取属性：SiteId

返回：
SiteId

setSiteId

public boolean setSiteId(int _nSiteId)
                  throws WCMException
设置属性：SiteId

参数：
_nSiteId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFlowdocId

public int getFlowdocId()
提取属性：FlowdocId

返回：
FlowdocId

setFlowdocId

public boolean setFlowdocId(int _nFlowdocId)
                     throws WCMException
设置属性：FlowdocId

参数：
_nFlowdocId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getUserGroupId

public int getUserGroupId()
提取属性：UserGroupId

返回：
UserGroupId

setUserGroupId

public boolean setUserGroupId(int _nUserGroupId)
                       throws WCMException
设置属性：UserGroupId

参数：
_nUserGroupId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isStarting

public boolean isStarting()
提取属性：Starting

返回：
Starting

setStarting

public boolean setStarting(boolean _bStarting)
                    throws WCMException
设置属性：Starting

参数：
_bStarting - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getBranchId

public int getBranchId()
提取属性：BranchId

返回：
BranchId

setBranchId

public boolean setBranchId(int _nBranchId)
                    throws WCMException
设置属性：BranchId

参数：
_nBranchId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final FlowdocLog findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowdocLog createNewInstance()
                                          throws WCMException
产生当前对象[FlowdocLog]的实例

返回：
当前对象的实例[FlowdocLog]
抛出：
WCMException

findByKey

public static final FlowdocLog findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowdocLogs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowdocLogs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.FlowdocLogs

public class FlowdocLogs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowdocLogs(User _currUser)
构造函数
FlowdocLogs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static FlowdocLogs | createNewInstance(User _currUser) 产生当前集合对象[FlowdocLogs]的实例
static FlowdocLogs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static FlowdocLogs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowdocLogs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowdocLogs

public FlowdocLogs(User _currUser)
构造函数

另请参见：
FlowdocLogs( User _currUser, int _initCapacity, int _incCapacity );

FlowdocLogs

public FlowdocLogs(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final FlowdocLogs findByIds(User _currUser,
                                          java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowdocLogs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowdocLogs openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[FlowdocLogs]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowdocLogs]
抛出：
WCMException

createNewInstance

public static FlowdocLogs createNewInstance(User _currUser)
产生当前集合对象[FlowdocLogs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowEmploy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowEmploy

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.FlowEmploy
所有已实现的接口：
java.lang.Cloneable
public class FlowEmploy
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
FlowEmploy()
构造函数：保留默认接口
方法摘要
static FlowEmploy | createNewInstance() 产生当前对象[FlowEmploy]的实例
static FlowEmploy | findById(int _nId) 提取指定ID的对象
static FlowEmploy | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
BaseObj | getEmployer() get the employer instance
int | getEmployerId() 提取属性：EmployerId
int | getEmployerType() 提取属性：EmployerType
Flow | getFlow()
int | getFlowId() 提取属性：FlowId
int | getFlowType() 提取属性：FlowType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setEmployer(BaseObj _employer) set the employer
boolean | setEmployer(int _nType, int _nId) set the employer
boolean | setFlow(Flow _flow) set the flow used
boolean | setFlow(int _nFlowId) 设置属性：FlowId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowEmploy

public FlowEmploy()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getEmployerType

public int getEmployerType()
提取属性：EmployerType

返回：
EmployerType

getEmployerId

public int getEmployerId()
提取属性：EmployerId

返回：
EmployerId

getEmployer

public BaseObj getEmployer()
                    throws java.lang.Exception
get the employer instance

返回：
Returns the employer instance.
抛出：
java.lang.Exception - if failed to fetch the employer instance.

setEmployer

public boolean setEmployer(int _nType,
                           int _nId)
                    throws WCMException
set the employer

参数：
_nType - type of the employer
_nId - id of the employer
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setEmployer

public boolean setEmployer(BaseObj _employer)
                    throws WCMException
set the employer

参数：
_employer - the employer
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFlowId

public int getFlowId()
提取属性：FlowId

返回：
FlowId

getFlow

public Flow getFlow()
             throws WCMException
抛出：
WCMException

setFlow

public boolean setFlow(int _nFlowId)
                throws WCMException
设置属性：FlowId

参数：
_nFlowId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setFlow

public boolean setFlow(Flow _flow)
                throws WCMException
set the flow used

参数：
_flow - the flow
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFlowType

public int getFlowType()
提取属性：FlowType

返回：
FlowType

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final FlowEmploy findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowEmploy createNewInstance()
                                          throws WCMException
产生当前对象[FlowEmploy]的实例

返回：
当前对象的实例[FlowEmploy]
抛出：
WCMException

findByKey

public static final FlowEmploy findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowEmployCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowEmployCacheMgr

java.lang.Object
    继承者  com.trs.cms.process.definition.FlowEmployCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class FlowEmployCacheMgr
extends java.lang.Object
implements ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
Template Employ缓冲管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowEmployCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
boolean | init() 初始化当前的Cache
boolean | isDoNotify(int _nEventType, java.lang.Object _oCacheObj, java.lang.Object[] _data)
void | notify(int _nEventType, java.lang.Object _oCacheObj, java.lang.Object[] _data)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowEmployCacheMgr

public FlowEmployCacheMgr()
方法详细信息

notify

public void notify(int _nEventType,
                   java.lang.Object _oCacheObj,
                   java.lang.Object[] _data)

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

isDoNotify

public boolean isDoNotify(int _nEventType,
                          java.lang.Object _oCacheObj,
                          java.lang.Object[] _data)

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowEmployerLCListener

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowEmployerLCListener

java.lang.Object
    继承者  com.trs.cms.process.definition.FlowEmployerLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class FlowEmployerLCListener
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
Flow Employer监听器,只监听删除前
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowEmployerLCListener()
缺省构造方法
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowEmployerLCListener

public FlowEmployerLCListener()
缺省构造方法

方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowEmployMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowEmployMgr

java.lang.Object
    继承者  com.trs.cms.process.definition.FlowEmployMgr

public class FlowEmployMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
flow employ records manager.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | SQL_QUERY_FLOW_USED
static java.lang.String | SQL_QUERY_USEING_FLOW
构造方法摘要
FlowEmployMgr()
方法摘要
int | clearEmploysOfEmployer(BaseObj _employer) clear all the employ records of the specified element
int | clearEmploysOfEmployer(int _nEmployerType, int _nEmployerId) clear all the employ records of the specified element
int | clearEmploysOfFlow(Flow _flow) clear all the employ records of the specified flow
int | clearEmploysOfFlow(int _nFlowId) clear all the employ records of the specified flow
BaseObjs | getChannelsUseingFlow(Flow _flow, BaseObjs _baseObjects, int _nEmployerType, java.lang.String _sTableName, WCMFilter _extraFilter) 获取使用指定工作的指定类型的对象
Flows | getEmployedFlows(BaseObj _employer) get the flows collection employed by the publish element.
FlowEmploys | getEmployers(Flow _flow, WCMFilter _filter) get the employers who use the specified flow.
FlowEmploys | getEmploysOf(BaseObj _employer) Returns the employ records of the specified employer, which may be a folder or a content.
FlowEmploys | getEmploysOfEmployer(int _nEmployerType, int _nEmployerId) Returns the employ records of the specified employer, which may be a folder or a content.
Flow | getFlow(BaseObj _employer) get the detail flow of the specified element.
void | setEmployersOfFlow(User _loginUser, int _nFlowId, int _nEmployerType, int[] _pEmployerIds) 批量维护指定工作流的配置关系
void | setFlow(BaseObj _employer, int _nFlowId) set the flow of the specified employer.
void | setFlow(int _nEmployType, int _nEmployId, int _nFlowId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SQL_QUERY_FLOW_USED

public static final java.lang.String SQL_QUERY_FLOW_USED
另请参见：
常量字段值

SQL_QUERY_USEING_FLOW

public static final java.lang.String SQL_QUERY_USEING_FLOW
另请参见：
常量字段值
构造方法详细信息

FlowEmployMgr

public FlowEmployMgr()
方法详细信息

getEmploysOf

public FlowEmploys getEmploysOf(BaseObj _employer)
                         throws WCMException
Returns the employ records of the specified employer, which may be a folder or a content.
if the flow type is ANY (PublishConstances.FLOW_TYPE_ANY), returns all the flows of the sepcified employer.

参数：
_employer - the specified employer using flows.
返回：
the employ records of the specified employer.
抛出：
WCMException - if failed to query and fecth the employ records.

getEmploysOfEmployer

public FlowEmploys getEmploysOfEmployer(int _nEmployerType,
                                        int _nEmployerId)
                                 throws WCMException
Returns the employ records of the specified employer, which may be a folder or a content.
if the flow type is ANY (PublishConstances.FLOW_TYPE_ANY), returns all the flows of the sepcified employer.

参数：
_nEmployerType - type of the employer
_nEmployerId - id of the employer
返回：
the employ records of the specified employer.
抛出：
WCMException - if failed to query and fecth the employ records.

setFlow

public void setFlow(BaseObj _employer,
                    int _nFlowId)
             throws WCMException
set the flow of the specified employer.

参数：
_employer - the employer
_nFlowId - if of the flow.
抛出：
WCMException - if failed to update the flow employ setting.

setFlow

public void setFlow(int _nEmployType,
                    int _nEmployId,
                    int _nFlowId)
             throws WCMException
抛出：
WCMException

getEmployedFlows

public Flows getEmployedFlows(BaseObj _employer)
                       throws WCMException
get the flows collection employed by the publish element.

参数：
_employer - the publish element who uses the flows
_filter - the extra collection filter
返回：
Returns the flows collection.
抛出：
WCMException - if failed to fetch the flows collection.

getFlow

public Flow getFlow(BaseObj _employer)
             throws WCMException
get the detail flow of the specified element.

参数：
_employer - a publish element
返回：
Returns the detail flow.
抛出：
WCMException - if failed to fetch the flow.

getEmployers

public FlowEmploys getEmployers(Flow _flow,
                                WCMFilter _filter)
                         throws WCMException
get the employers who use the specified flow.

参数：
_flow - a flow.
_filter - extra filter for the collection.
返回：
Returns the flows collection.
抛出：
WCMException - if failed to query and fetch the flows.

clearEmploysOfEmployer

public int clearEmploysOfEmployer(BaseObj _employer)
                           throws WCMException
clear all the employ records of the specified element

参数：
_employer - the publish element using flow
返回：
Returns the employ records count deleted.
抛出：
WCMException - if failed to delete those employ records.

clearEmploysOfEmployer

public int clearEmploysOfEmployer(int _nEmployerType,
                                  int _nEmployerId)
                           throws WCMException
clear all the employ records of the specified element

参数：
_nEmployerType - type of the employer using flow
_nEmployerId - id of the employer using flow
返回：
Returns the employ records count deleted.
抛出：
WCMException - if failed to delete those employ records.

clearEmploysOfFlow

public int clearEmploysOfFlow(Flow _flow)
                       throws WCMException
clear all the employ records of the specified flow

参数：
_flow - the flow
返回：
Returns the employ records count deleted.
抛出：
WCMException - if failed to delete those employ records.

clearEmploysOfFlow

public int clearEmploysOfFlow(int _nFlowId)
                       throws WCMException
clear all the employ records of the specified flow

参数：
_nFlowId - id of the flow
返回：
Returns the employ records count deleted.
抛出：
WCMException - if failed to delete those employ records.

getChannelsUseingFlow

public BaseObjs getChannelsUseingFlow(Flow _flow,
                                      BaseObjs _baseObjects,
                                      int _nEmployerType,
                                      java.lang.String _sTableName,
                                      WCMFilter _extraFilter)
                               throws WCMException
获取使用指定工作的指定类型的对象

参数：
_flow -
_baseObjects -
_sTableName -
_extraFilter -
返回：
抛出：
WCMException

setEmployersOfFlow

public void setEmployersOfFlow(User _loginUser,
                               int _nFlowId,
                               int _nEmployerType,
                               int[] _pEmployerIds)
                        throws WCMException
批量维护指定工作流的配置关系

参数：
_loginUser -
_nFlowId -
_nEmployerType -
_pEmployerIds -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowEmploys

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowEmploys

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.FlowEmploys

public class FlowEmploys
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowEmploys(User _currUser)
FlowEmploys(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static FlowEmploys | createNewInstance(User _currUser) 产生当前集合对象[FlowEmploys]的实例
static FlowEmploys | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static FlowEmploys | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowEmploys]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowEmploys

public FlowEmploys(User _currUser)

FlowEmploys

public FlowEmploys(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final FlowEmploys findByIds(User _currUser,
                                          java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowEmploys）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowEmploys openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[FlowEmploys]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowEmploys]
抛出：
WCMException

createNewInstance

public static FlowEmploys createNewInstance(User _currUser)
产生当前集合对象[FlowEmploys]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowMgr

java.lang.Object
    继承者  com.trs.cms.process.definition.FlowMgr

public class FlowMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Flow Manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowMgr()
方法摘要
 void delete(Flow _currFlow)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowMgr

public FlowMgr()
方法详细信息

delete

public void delete(Flow _currFlow)
            throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNode

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowNode

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.FlowNode
所有已实现的接口：
java.lang.Cloneable
public class FlowNode
extends CMSObj

字段摘要
static int | ACTION_DELETE 节点上可以进行的操作类型：删除 1
static int | ACTION_EDIT 节点上可以进行的操作类型：编辑 0
static int | ACTION_PUBLISH 节点上可以进行的操作类型：发布 2
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
FlowNode()
构造函数：保留默认接口
方法摘要
boolean | canDelDoc() 判断是否可以在此节点上删除文档
boolean | canEditDoc() 判断是否可以在此节点上修改文档
boolean | canPubDoc() 判断是否可以在此节点上发布文档
static FlowNode | createNewInstance() 产生当前对象[FlowNode]的实例
int | delete(User _currUser) 重载父类delete函数，删除与工作流节点相关的信息（流转中的文档、节点操作者、分支等）
static FlowNode | findById(int _nId) 提取指定ID的对象
static FlowNode | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static FlowNode | findByName(int _nFlowId, java.lang.String _sNodeName)
FlowNodeBranchs | getBranchs(User _currUser) 取得节点上的所有工作流分支集合
FlowNodeBranch | getBranchTo(User _currUser, FlowNode _nextNode) 获得当前节点到指定节点的分支
int | getCenterX() 获取X坐标（用于可视化编辑）
int | getCenterY() 获取Y坐标（用于可视化编辑）
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取节点描述
CMyBitsValue | getDocActions() 获取在节点上定义的能够进行的文档操作（CMyBitsValue）
int | getDocActionsAsInt() 获取在节点上定义的能够进行的文档操作（int）
Flow | getFlow() 节点所在工作流对象
int | getFlowId() 节点所在工作流ID
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName() 获取节点名称
FlowNodes | getNextNodes(User _currUser) 获取下一个节点集合
FlowNodes | getNextNodes(User _currUser, WCMFilter _filter)
Groups | getOperGroups(User _currUser) 取节点上的操作用户组
Users | getOperUsers(User _currUser) 取节点上的操作用户集合
Users | getOperUsers(User _currUser, boolean _bAll)
Users | getOperUsers(User _currUser, boolean _bAll, java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sOrder) 返回节点上定义的用户
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
int | getWorkModal() 节点上的流转模式
void | insert(User _currUser) 重载父类的insert函数，以便设置产生时间
boolean | isCanDoWithDoc(int _actionType) 判断能够进行指定类型的文档操作
boolean | isEndNode() 判断该节点是否为所在工作流的结束节点
boolean | isNeedPostTogether() 判断是否需要会签
boolean | isStartNode() 判定该节点是否为所在工作流的起始节点
boolean | isToFirst()
boolean | isValid() 实现父类的isValid函数，进行数据的效验
boolean | setCeneterX(int _nCenterX) 设置X坐标（用于可视化编辑）
boolean | setCeneterY(int _nCenterY) 设置Y坐标（用于可视化编辑）
boolean | setDesc(java.lang.String _desc) 设置节点描述
boolean | setDocActions(int _actions) 使用整型值设置节点上允许的操作
boolean | setDocActions(int _actionType, boolean _bCanDo) 设定指定类型的文档操作许可
boolean | setFlow(Flow _flow) 设置节点所在工作流
boolean | setFlow(int _flowId) 设置节点所在工作流
boolean | setName(java.lang.String _name) 设置节点名称
boolean | setNeedPostTogether(boolean _bNeed) 设置是否需要会签属性
void | setToFirst(boolean _toFirst)
boolean | setWorkModal(int _nWorkModal) 设置节点上的流转模式
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

ACTION_EDIT

public static final int ACTION_EDIT
节点上可以进行的操作类型：编辑 0

另请参见：
常量字段值

ACTION_DELETE

public static final int ACTION_DELETE
节点上可以进行的操作类型：删除 1

另请参见：
常量字段值

ACTION_PUBLISH

public static final int ACTION_PUBLISH
节点上可以进行的操作类型：发布 2

另请参见：
常量字段值
构造方法详细信息

FlowNode

public FlowNode()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
CMSObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
CMSObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
CMSObj.getWCMType()

getFlowId

public int getFlowId()
节点所在工作流ID

返回：
节点所在工作流ID

getFlow

public Flow getFlow()
             throws WCMException
节点所在工作流对象

返回：
节点所在工作流对象
抛出：
WCMException

setFlow

public boolean setFlow(int _flowId)
                throws WCMException
设置节点所在工作流

参数：
_flowId - 节点所在工作流ID
返回：
抛出：
WCMException

setFlow

public boolean setFlow(Flow _flow)
                throws WCMException
设置节点所在工作流

参数：
_flow - 节点所在工作流对象
返回：
抛出：
WCMException

getName

public java.lang.String getName()
获取节点名称

返回：
节点名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置节点名称

参数：
_name - 节点名称
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取节点描述

返回：
节点描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置节点描述

参数：
_desc - 节点描述
返回：
抛出：
WCMException

getCenterX

public int getCenterX()
获取X坐标（用于可视化编辑）

返回：
X坐标（用于可视化编辑）

setCeneterX

public boolean setCeneterX(int _nCenterX)
                    throws WCMException
设置X坐标（用于可视化编辑）

参数：
_nCenterX - X坐标
返回：
抛出：
WCMException

getCenterY

public int getCenterY()
获取Y坐标（用于可视化编辑）

返回：
Y坐标（用于可视化编辑）

setCeneterY

public boolean setCeneterY(int _nCenterY)
                    throws WCMException
设置Y坐标（用于可视化编辑）

参数：
_nCenterY - Y坐标
返回：
抛出：
WCMException

getDocActionsAsInt

public int getDocActionsAsInt()
获取在节点上定义的能够进行的文档操作（int）

返回：
在节点上定义的能够进行的文档操作（int）

getDocActions

public CMyBitsValue getDocActions()
获取在节点上定义的能够进行的文档操作（CMyBitsValue）

返回：
在节点上定义的能够进行的文档操作（CMyBitsValue）

isCanDoWithDoc

public boolean isCanDoWithDoc(int _actionType)
判断能够进行指定类型的文档操作

参数：
_actionType - 操作类型（如FlowNode.ACTION_DELETE等)
返回：

setDocActions

public boolean setDocActions(int _actions)
                      throws WCMException
使用整型值设置节点上允许的操作

参数：
_actions - 节点上允许的操作
返回：
抛出：
WCMException

setDocActions

public boolean setDocActions(int _actionType,
                             boolean _bCanDo)
                      throws WCMException
设定指定类型的文档操作许可

参数：
_actionType - 操作类型（如FlowNode.ACTION_DELETE等)
_bCanDo - 是否允许操作
返回：
抛出：
WCMException

canDelDoc

public boolean canDelDoc()
判断是否可以在此节点上删除文档

返回：
true/false

canEditDoc

public boolean canEditDoc()
判断是否可以在此节点上修改文档

返回：
true/false

canPubDoc

public boolean canPubDoc()
判断是否可以在此节点上发布文档

返回：
true/false

isNeedPostTogether

public boolean isNeedPostTogether()
判断是否需要会签

返回：
需要会签,返回true;不需要返回false;

setNeedPostTogether

public boolean setNeedPostTogether(boolean _bNeed)
                            throws WCMException
设置是否需要会签属性

参数：
_bNeed - 是否需要会签标记
返回：
执行成功后返回true;否则返回false
抛出：
WCMException - 设置属性时可能会发生异常

getWorkModal

public int getWorkModal()
节点上的流转模式

返回：
节点上的流转模式

setWorkModal

public boolean setWorkModal(int _nWorkModal)
                     throws WCMException
设置节点上的流转模式

参数：
_nWorkModal - 节点上的流转模式
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
实现父类的isValid函数，进行数据的效验

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 1、新增模式下没有设置所属工作流、节点名称将会引起异常 2、名称不唯一将会引起异常
另请参见：
CMSObj.isValid()

insert

public void insert(User _currUser)
            throws WCMException
重载父类的insert函数，以便设置产生时间

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException
另请参见：
CMSObj.insert( User _currUser )

delete

public int delete(User _currUser)
           throws WCMException
重载父类delete函数，删除与工作流节点相关的信息（流转中的文档、节点操作者、分支等）

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException
另请参见：
CMSObj.delete( User _currUser)

isStartNode

public boolean isStartNode()
                    throws WCMException
判定该节点是否为所在工作流的起始节点

返回：
true/false
抛出：
WCMException

isEndNode

public boolean isEndNode()
                  throws WCMException
判断该节点是否为所在工作流的结束节点

返回：
true/false
抛出：
WCMException

getOperUsers

public Users getOperUsers(User _currUser)
                   throws WCMException
取节点上的操作用户集合

参数：
_currUser - 当前操作用户
返回：
节点上的操作用户集合
抛出：
WCMException

getOperUsers

public Users getOperUsers(User _currUser,
                          boolean _bAll)
                   throws WCMException
抛出：
WCMException
另请参见：
Users getOperUsers( User _currUser, boolean _bAll, String _sFrom, String _sWhere, String _sOrder )

getOperUsers

public Users getOperUsers(User _currUser,
                          boolean _bAll,
                          java.lang.String _sFrom,
                          java.lang.String _sWhere,
                          java.lang.String _sOrder)
                   throws WCMException
返回节点上定义的用户

参数：
_currUser - 当前用户
_bAll - 是否考虑节点上的用户组
_sFrom - 查询的表名(可省略， 默认为"")
_sWhere - 筛选条件(可省略， 默认为"")
_sOrder - 排序条件(可省略， 默认为"")
返回：
抛出：
WCMException

getOperGroups

public Groups getOperGroups(User _currUser)
                     throws WCMException
取节点上的操作用户组

参数：
_currUser - 当前操作用户
返回：
节点上的操作用户组（Groups）
抛出：
WCMException

getBranchs

public FlowNodeBranchs getBranchs(User _currUser)
                           throws WCMException
取得节点上的所有工作流分支集合

参数：
_currUser - 当前用户
返回：
节点上的所有工作流分支集合（FlowNodeBranchs）
抛出：
WCMException

getBranchTo

public FlowNodeBranch getBranchTo(User _currUser,
                                  FlowNode _nextNode)
                           throws WCMException
获得当前节点到指定节点的分支

参数：
_currUser - 当前操作用户
_nextNode - 下一个节点对象
返回：
当前节点到指定节点的分支
抛出：
WCMException

getNextNodes

public FlowNodes getNextNodes(User _currUser)
                       throws WCMException
获取下一个节点集合

参数：
_currUser - 当前操作用户
返回：
下一个节点集合（FlowNodes）
抛出：
WCMException

getNextNodes

public FlowNodes getNextNodes(User _currUser,
                              WCMFilter _filter)
                       throws WCMException
抛出：
WCMException

isToFirst

public boolean isToFirst()

setToFirst

public void setToFirst(boolean _toFirst)
                throws WCMException
抛出：
WCMException

findById

public static final FlowNode findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowNode createNewInstance()
                                        throws WCMException
产生当前对象[FlowNode]的实例

返回：
当前对象的实例[FlowNode]
抛出：
WCMException

findByKey

public static final FlowNode findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByName

public static FlowNode findByName(int _nFlowId,
                                  java.lang.String _sNodeName)
                           throws WCMException
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNodeBranch

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowNodeBranch

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.FlowNodeBranch
所有已实现的接口：
java.lang.Cloneable
public class FlowNodeBranch
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
FlowNodeBranch()
构造函数：保留默认接口
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName() 获取分支描述
FlowNode | getNextNode(User _currUser) 取下一个节点对象
java.lang.String | getNextNodeName() 获取下一个节点名称
FlowNode | getNode() 获取第一个节点对象
int | getNodeId() 获取第一个节点的ID
int | getNotify() 设置通知方式
java.lang.String | getNotifyTypes() 获取通知的方式
java.lang.String | getOperationMark()
Status | getStatus() 获取文档经过此分支时自动改变后的状态
int | getStatusId() 获取文档经过此分支时自动改变后的状态的ID
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isNotifyBy(int _notifyType) 判断是否设定了指定的通知方式
boolean | isOperationMarkEnable()
boolean | isValid() 实现父类的isValid函数，进行数据的效验
boolean | setNextNodeName(java.lang.String _NextName) 设置下一个节点名称
boolean | setNode(FlowNode _node) 设置第一个节点
boolean | setNode(int _nNodeId) 设置第一个节点
boolean | setNotify(long _notify) 设置通知方式
boolean | setNotifyBy(int _notifyType, boolean _bValue) 设定指定的通知方式
boolean | setStatus(int _statusId) 设置文档经过此分支时自动改变后的状态
boolean | setStatus(Status _status) 设置文档经过此分支时自动改变后的状态
void | update(User _user) 重载父类的update函数，实现下一个节点修改的同步
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowNodeBranch

public FlowNodeBranch()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getNodeId

public int getNodeId()
获取第一个节点的ID

返回：
第一个节点的ID

getNode

public FlowNode getNode()
                 throws WCMException
获取第一个节点对象

返回：
第一个节点对象
抛出：
WCMException

setNode

public boolean setNode(FlowNode _node)
                throws WCMException
设置第一个节点

参数：
_node - 第一个节点对象
返回：
抛出：
WCMException

setNode

public boolean setNode(int _nNodeId)
                throws WCMException
设置第一个节点

参数：
_nNodeId - 第一个节点ID
返回：
抛出：
WCMException

getNextNodeName

public java.lang.String getNextNodeName()
获取下一个节点名称

返回：
下一个节点名称

setNextNodeName

public boolean setNextNodeName(java.lang.String _NextName)
                        throws WCMException
设置下一个节点名称

参数：
_NextName - 下一个节点名称
返回：
抛出：
WCMException

getStatusId

public int getStatusId()
获取文档经过此分支时自动改变后的状态的ID

返回：
文档经过此分支时状态的改变值的ID

getStatus

public Status getStatus()
                 throws WCMException
获取文档经过此分支时自动改变后的状态

返回：
文档经过此分支时自动改变后的状态
抛出：
WCMException

setStatus

public boolean setStatus(int _statusId)
                  throws WCMException
设置文档经过此分支时自动改变后的状态

参数：
_statusId - 文档经过此分支时自动改变后的状态的ID
返回：
抛出：
WCMException

setStatus

public boolean setStatus(Status _status)
                  throws WCMException
设置文档经过此分支时自动改变后的状态

参数：
_status - 文档经过此分支时自动改变后的状态
返回：
抛出：
WCMException

getNotify

public int getNotify()
设置通知方式

返回：

getNotifyTypes

public java.lang.String getNotifyTypes()
获取通知的方式

返回：

setNotify

public boolean setNotify(long _notify)
                  throws WCMException
设置通知方式

参数：
_notify - 通知方式（采用二进制形式的长整型数表示，通知方式的索引定义在WCMTypes中，如WCMTypes.REMIND_ONLINE ）
返回：
抛出：
WCMException

isNotifyBy

public boolean isNotifyBy(int _notifyType)
判断是否设定了指定的通知方式

参数：
_notifyType - 通知方式（其索引定义在WCMTypes中，如WCMTypes.REMIND_ONLINE等）
返回：

setNotifyBy

public boolean setNotifyBy(int _notifyType,
                           boolean _bValue)
                    throws WCMException
设定指定的通知方式

参数：
_notifyType - 通知方式（其索引定义在WCMTypes中，如WCMTypes.REMIND_ONLINE等）
_bValue - 是否设定（true/false）
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
实现父类的isValid函数，进行数据的效验

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 1、新增模式下没有设置第一个节点
另请参见：
WCMObj.isValid()

update

public void update(User _user)
            throws WCMException
重载父类的update函数，实现下一个节点修改的同步

覆盖：
类 CMSObj 中的 update
参数：
_user - 操作用户
抛出：
WCMException
另请参见：
WCMObj.update( User _user )

getNextNode

public FlowNode getNextNode(User _currUser)
                     throws WCMException
取下一个节点对象

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

getName

public java.lang.String getName()
获取分支描述

返回：
抛出：
WCMException

getOperationMark

public java.lang.String getOperationMark()

isOperationMarkEnable

public boolean isOperationMarkEnable()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNodeBranchs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowNodeBranchs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.FlowNodeBranchs

public class FlowNodeBranchs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowNodeBranchs(User _currUser)
FlowNodeBranchs(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static FlowNodeBranchs | createNewInstance(User _currUser) 产生当前集合对象[FlowNodeBranchs]的实例
static FlowNodeBranchs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static FlowNodeBranchs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodeBranchs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowNodeBranchs

public FlowNodeBranchs(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

FlowNodeBranchs

public FlowNodeBranchs(User _currUser,
                       int initialCapacity,
                       int capacityIncrement)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final FlowNodeBranchs findByIds(User _currUser,
                                              java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowNodeBranchs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowNodeBranchs openWCMObjs(User _currUser,
                                                WCMFilter _filter)
                                         throws WCMException
通过指定一个Filter获取当前集合[FlowNodeBranchs]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowNodeBranchs]
抛出：
WCMException

createNewInstance

public static FlowNodeBranchs createNewInstance(User _currUser)
产生当前集合对象[FlowNodeBranchs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNodeField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowNodeField

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.FlowNodeField
所有已实现的接口：
java.lang.Cloneable
public class FlowNodeField
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | NODE_FIELD_TYPE_GROUP
static int | NODE_FIELD_TYPE_NORMAL
static int | NODE_FIELD_TYPE_VIEW
static int | OBJ_TYPE 对象类型编号
构造方法摘要
FlowNodeField()
构造函数：保留默认接口
方法摘要
static FlowNodeField | createNewInstance() 产生当前对象[FlowNodeField]的实例
static FlowNodeField | findById(int _nId) 提取指定ID的对象
static FlowNodeField | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getFieldDesc() 提取属性：FieldDesc
java.lang.String | getFieldName() 提取属性：FieldName
int | getFieldType() 返回字段类型
int | getFlowId() 提取属性：FlowId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getNodeId() 提取属性：NodeId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isReadField() 判断当前字段是否可读
boolean | isValid() 检验对象数据有效性
boolean | isWriteField() 判断当前字段是否可写
boolean | setFieldDesc(java.lang.String _sFieldDesc) 设置属性：FieldDesc
boolean | setFieldName(java.lang.String _sFieldName) 设置属性：FieldName
boolean | setFieldType(int _nFieldType) 设置字段类型,Field/Group/View
boolean | setFlowId(int _nFlowId) 设置属性：FlowId
boolean | setNodeId(int _nNodeId) 设置属性：NodeId
boolean | setReadField(boolean _bReadField) 设置字段为可读
boolean | setWriteField(boolean _bWriteField) 设置字段为可写
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

NODE_FIELD_TYPE_NORMAL

public static final int NODE_FIELD_TYPE_NORMAL
另请参见：
常量字段值

NODE_FIELD_TYPE_GROUP

public static final int NODE_FIELD_TYPE_GROUP
另请参见：
常量字段值

NODE_FIELD_TYPE_VIEW

public static final int NODE_FIELD_TYPE_VIEW
另请参见：
常量字段值
构造方法详细信息

FlowNodeField

public FlowNodeField()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getFlowId

public int getFlowId()
提取属性：FlowId

返回：
FlowId

setFlowId

public boolean setFlowId(int _nFlowId)
                  throws WCMException
设置属性：FlowId

参数：
_nFlowId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getNodeId

public int getNodeId()
提取属性：NodeId

返回：
NodeId

setNodeId

public boolean setNodeId(int _nNodeId)
                  throws WCMException
设置属性：NodeId

参数：
_nNodeId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldName

public java.lang.String getFieldName()
提取属性：FieldName

返回：
FieldName

setFieldName

public boolean setFieldName(java.lang.String _sFieldName)
                     throws WCMException
设置属性：FieldName

参数：
_sFieldName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldDesc

public java.lang.String getFieldDesc()
提取属性：FieldDesc

返回：
FieldDesc

setFieldDesc

public boolean setFieldDesc(java.lang.String _sFieldDesc)
                     throws WCMException
设置属性：FieldDesc

参数：
_sFieldDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isWriteField

public boolean isWriteField()
判断当前字段是否可写

返回：
抛出：
WCMException

setWriteField

public boolean setWriteField(boolean _bWriteField)
                      throws WCMException
设置字段为可写

参数：
_bWriteField -
返回：
抛出：
WCMException

isReadField

public boolean isReadField()
判断当前字段是否可读

返回：
抛出：
WCMException

setReadField

public boolean setReadField(boolean _bReadField)
                     throws WCMException
设置字段为可读

参数：
_bReadField -
返回：
抛出：
WCMException

getFieldType

public int getFieldType()
返回字段类型

返回：

setFieldType

public boolean setFieldType(int _nFieldType)
                     throws WCMException
设置字段类型,Field/Group/View

参数：
_nFieldType -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final FlowNodeField findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowNodeField createNewInstance()
                                             throws WCMException
产生当前对象[FlowNodeField]的实例

返回：
当前对象的实例[FlowNodeField]
抛出：
WCMException

findByKey

public static final FlowNodeField findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNodeFields

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowNodeFields

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.FlowNodeFields

public class FlowNodeFields
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowNodeFields(User _currUser)
构造函数
FlowNodeFields(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static FlowNodeFields | createNewInstance(User _currUser) 产生当前集合对象[FlowNodeFields]的实例
static FlowNodeFields | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowNodeFields | findOf(User _currUser, FlowNode _node)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static FlowNodeFields | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodeFields]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowNodeFields

public FlowNodeFields(User _currUser)
构造函数

另请参见：
FlowNodeFields( User _currUser, int _initCapacity, int _incCapacity );

FlowNodeFields

public FlowNodeFields(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final FlowNodeFields findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowNodeFields）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowNodeFields openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[FlowNodeFields]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowNodeFields]
抛出：
WCMException

createNewInstance

public static FlowNodeFields createNewInstance(User _currUser)
产生当前集合对象[FlowNodeFields]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findOf

public static FlowNodeFields findOf(User _currUser,
                                    FlowNode _node)
                             throws WCMException
参数：
_currUser -
_node -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNodes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowNodes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.FlowNodes

public class FlowNodes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowNodes(User _currUser)
FlowNodes(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static FlowNodes | createNewInstance(User _currUser) 产生当前集合对象[FlowNodes]的实例
static FlowNodes | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static FlowNodes | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodes]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowNodes

public FlowNodes(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

FlowNodes

public FlowNodes(User _currUser,
                 int initialCapacity,
                 int capacityIncrement)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final FlowNodes findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowNodes）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowNodes openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[FlowNodes]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowNodes]
抛出：
WCMException

createNewInstance

public static FlowNodes createNewInstance(User _currUser)
产生当前集合对象[FlowNodes]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowOptMarkEnumParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowOptMarkEnumParser

java.lang.Object
    继承者  com.trs.cms.process.definition.FlowOptMarkEnumParser

public class FlowOptMarkEnumParser
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

方法摘要
static java.lang.String getFlowOptMarkEnum(Flow _flow)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getFlowOptMarkEnum

public static java.lang.String getFlowOptMarkEnum(Flow _flow)
                                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowRule

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowRule

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.definition.FlowRule
所有已实现的接口：
java.lang.Cloneable
public class FlowRule
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
FlowRule()
构造函数：保留默认接口
方法摘要
void | clearCache() 清除缓存
static FlowRule | createNewInstance() 产生当前对象[FlowRule]的实例
static FlowRule | findById(int _nId) 提取指定ID的对象
static FlowRule | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
FlowActions | getActions(User _currUser) 获取规则中设定的所有操作
FlowConditions | getConditions(User _currUser) 获取规则中设定的所有条件
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getHostId() 提取属性：HostId
int | getHostType() 提取属性：HostType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getName() 提取属性：Name
int | getOrder() 提取属性：Order
int | getType() 提取属性：Type
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setHostId(int _nHostId) 设置属性：HostId
boolean | setHostType(int _nHostType) 设置属性：HostType
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setOrder(int _nOrder) 设置属性：Order
boolean | setType(int _nType) 设置属性：Type
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowRule

public FlowRule()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getType

public int getType()
提取属性：Type

返回：
Type

setType

public boolean setType(int _nType)
                throws WCMException
设置属性：Type

参数：
_nType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostType

public int getHostType()
提取属性：HostType

返回：
HostType

setHostType

public boolean setHostType(int _nHostType)
                    throws WCMException
设置属性：HostType

参数：
_nHostType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostId

public int getHostId()
提取属性：HostId

返回：
HostId

setHostId

public boolean setHostId(int _nHostId)
                  throws WCMException
设置属性：HostId

参数：
_nHostId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOrder

public int getOrder()
提取属性：Order

返回：
Order

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置属性：Order

参数：
_nOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

getConditions

public FlowConditions getConditions(User _currUser)
                             throws WCMException
获取规则中设定的所有条件

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

getActions

public FlowActions getActions(User _currUser)
                       throws WCMException
获取规则中设定的所有操作

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

clearCache

public void clearCache()
清除缓存

findById

public static final FlowRule findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowRule createNewInstance()
                                        throws WCMException
产生当前对象[FlowRule]的实例

返回：
当前对象的实例[FlowRule]
抛出：
WCMException

findByKey

public static final FlowRule findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowRuleCacheServerImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowRuleCacheServerImpl

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.cms.process.definition.FlowRuleCacheServerImpl
所有已实现的接口：
IFlowRuleCacheServer, IServer
public class FlowRuleCacheServerImpl
extends BaseServer
implements IFlowRuleCacheServer

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流规则缓冲维护器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
FlowRuleCacheServerImpl()
方法摘要
FlowRule[] | getRules(FlowNode _currNode, int _nRuleType) 获取定义在指定节点上指定类型的规则
FlowRule[] | getRules(int _nHostType, int _nHostId, int _nRuleType) 获取在指定对象上定义的指定类型的规则
void | reloadRuleCache(BaseObj _host) 重新装载指定对象(工作流/节点)的规则缓冲
void | removeRuleCache(BaseObj _host) 删除指定对象(工作流/节点)的规则缓冲
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.infra.IServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, restart, setServerName, shutdown, startup

构造方法详细信息

FlowRuleCacheServerImpl

public FlowRuleCacheServerImpl()
方法详细信息

getRules

public FlowRule[] getRules(FlowNode _currNode,
                           int _nRuleType)
从接口 IFlowRuleCacheServer 复制的描述
获取定义在指定节点上指定类型的规则

指定者：
接口 IFlowRuleCacheServer 中的 getRules
参数：
_currNode - 指定节点
_nRuleType - 规则类型 @see ProcessConstants
返回：

reloadRuleCache

public void reloadRuleCache(BaseObj _host)
                     throws WCMException
从接口 IFlowRuleCacheServer 复制的描述
重新装载指定对象(工作流/节点)的规则缓冲

指定者：
接口 IFlowRuleCacheServer 中的 reloadRuleCache
抛出：
WCMException

removeRuleCache

public void removeRuleCache(BaseObj _host)
从接口 IFlowRuleCacheServer 复制的描述
删除指定对象(工作流/节点)的规则缓冲

指定者：
接口 IFlowRuleCacheServer 中的 removeRuleCache

getRules

public FlowRule[] getRules(int _nHostType,
                           int _nHostId,
                           int _nRuleType)
                    throws WCMException
从接口 IFlowRuleCacheServer 复制的描述
获取在指定对象上定义的指定类型的规则

指定者：
接口 IFlowRuleCacheServer 中的 getRules
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowRules

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 FlowRules

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.FlowRules

public class FlowRules
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowRules(User _currUser)
构造函数
FlowRules(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static FlowRules | createNewInstance(User _currUser) 产生当前集合对象[FlowRules]的实例
static FlowRules | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowRules | findOf(User _currUser, CMSObj _host) 根据Host获取相关的规则
static FlowRules | findOf(User _currUser, int _nHostType, int _nHostId) 根据Host获取相关的规则
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static FlowRules | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowRules]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowRules

public FlowRules(User _currUser)
构造函数

另请参见：
FlowRules( User _currUser, int _initCapacity, int _incCapacity );

FlowRules

public FlowRules(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final FlowRules findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowRules）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowRules openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[FlowRules]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowRules]
抛出：
WCMException

createNewInstance

public static FlowRules createNewInstance(User _currUser)
产生当前集合对象[FlowRules]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findOf

public static FlowRules findOf(User _currUser,
                               CMSObj _host)
                        throws WCMException
根据Host获取相关的规则

参数：
_currUser -
_host -
返回：
抛出：
WCMException

findOf

public static FlowRules findOf(User _currUser,
                               int _nHostType,
                               int _nHostId)
                        throws WCMException
根据Host获取相关的规则

参数：
_currUser -
_nHostType -
_nHostId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Flows

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 Flows

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.definition.Flows

public class Flows
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Flows(User _currUser)
Flows(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Flows | createNewInstance(User _currUser) 产生当前集合对象[Flows]的实例
static Flows | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Flow | getByName(java.lang.String _sName) 根据工作流名称获取工作流
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Flows | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Flows]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Flows

public Flows(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

Flows

public Flows(User _currUser,
             int initialCapacity,
             int capacityIncrement)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

getByName

public Flow getByName(java.lang.String _sName)
根据工作流名称获取工作流

参数：
_sName - 工作流名称
返回：
指定工作流名称的工作流对象
抛出：
WCMException

findByIds

public static final Flows findByIds(User _currUser,
                                    java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Flows）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Flows openWCMObjs(User _currUser,
                                      WCMFilter _filter)
                               throws WCMException
通过指定一个Filter获取当前集合[Flows]

参数：
_filter - 指定的Filter
返回：
当前集合[Flows]
抛出：
WCMException

createNewInstance

public static Flows createNewInstance(User _currUser)
产生当前集合对象[Flows]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFlowRuleCacheServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
接口 IFlowRuleCacheServer

所有超级接口：
IServer
所有已知实现类：
FlowRuleCacheServerImpl
public interface IFlowRuleCacheServer
extends IServer

Title: TRS 内容协作平台（TRS WCM）
Description:
规则缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
FlowRule[] | getRules(FlowNode _currNode, int _nRuleType) 获取定义在指定节点上指定类型的规则
FlowRule[] | getRules(int _nHostType, int _nHostId, int _nRuleType) 获取在指定对象上定义的指定类型的规则
void | reloadRuleCache(BaseObj _host) 重新装载指定对象(工作流/节点)的规则缓冲
void | removeRuleCache(BaseObj _host) 删除指定对象(工作流/节点)的规则缓冲
从接口 com.trs.infra.IServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, restart, setServerName, shutdown, startup

方法详细信息

getRules

FlowRule[] getRules(FlowNode _currNode,
                    int _nRuleType)
                    throws WCMException
获取定义在指定节点上指定类型的规则

参数：
_currNode - 指定节点
_nRuleType - 规则类型 @see ProcessConstants
返回：
抛出：
WCMException

getRules

FlowRule[] getRules(int _nHostType,
                    int _nHostId,
                    int _nRuleType)
                    throws WCMException
获取在指定对象上定义的指定类型的规则

参数：
_nHostType -
_nHostId -
_nRuleType -
返回：
抛出：
WCMException

reloadRuleCache

void reloadRuleCache(BaseObj _host)
                     throws WCMException
重新装载指定对象(工作流/节点)的规则缓冲

参数：
_host -
抛出：
WCMException

removeRuleCache

void removeRuleCache(BaseObj _host)
                     throws WCMException
删除指定对象(工作流/节点)的规则缓冲

参数：
_host -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OptMarkParseException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 OptMarkParseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.cms.process.definition.OptMarkParseException
所有已实现的接口：
java.io.Serializable
public class OptMarkParseException
extends java.lang.RuntimeException

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)
另请参见：
序列化表格

构造方法摘要
OptMarkParseException(java.lang.String message)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OptMarkParseException

public OptMarkParseException(java.lang.String message)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.process.definition
接口
IFlowRuleCacheServer
类
Flow
FlowAction
FlowActions
FlowCacheMgr
FlowCondition
FlowConditions
FlowdocLog
FlowdocLogs
FlowEmploy
FlowEmployCacheMgr
FlowEmployerLCListener
FlowEmployMgr
FlowEmploys
FlowMgr
FlowNode
FlowNodeBranch
FlowNodeBranchs
FlowNodeField
FlowNodeFields
FlowNodes
FlowOptMarkEnumParser
FlowRule
FlowRuleCacheServerImpl
FlowRules
Flows
RuleHostLCListnerForCache
异常
OptMarkParseException


com.trs.cms.process.definition

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.process.definition

接口摘要
IFlowRuleCacheServer Title: TRS 内容协作平台（TRS WCM）
Description:
规则缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
Flow |
FlowAction |
FlowActions |
FlowCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 工作流缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowCondition |
FlowConditions |
FlowdocLog |
FlowdocLogs |
FlowEmploy |
FlowEmployCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: Template Employ缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowEmployerLCListener | Title: TRS 内容协作平台（TRS WCM） Description: Flow Employer监听器,只监听删除前 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowEmployMgr | Title: TRS 内容协作平台（TRS WCM） Description: flow employ records manager.
FlowEmploys |
FlowMgr | Title: TRS 内容协作平台（TRS WCM） Description: Flow Manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowNode |
FlowNodeBranch |
FlowNodeBranchs |
FlowNodeField |
FlowNodeFields |
FlowNodes |
FlowOptMarkEnumParser | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowRule |
FlowRuleCacheServerImpl | Title: TRS 内容协作平台（TRS WCM） Description: 工作流规则缓冲维护器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowRules |
Flows |
RuleHostLCListnerForCache | Title: TRS 内容协作平台（TRS WCM） Description: 工作流规则所属对象监听器，为了删除对象时候同步规则缓冲 由于修改和新增的时候规则可能还没有建立起来，所以需要在创建的逻辑中使用硬代码 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
OptMarkParseException Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.cms.process.definition 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.definition 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.cms.process.definition.Flow
        • com.trs.cms.process.definition.FlowAction
        • com.trs.cms.process.definition.FlowCondition
        • com.trs.cms.process.definition.FlowdocLog
        • com.trs.cms.process.definition.FlowEmploy
        • com.trs.cms.process.definition.FlowNode
        • com.trs.cms.process.definition.FlowNodeBranch
        • com.trs.cms.process.definition.FlowNodeField
        • com.trs.cms.process.definition.FlowRule
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.cms.process.definition.FlowActions
        • com.trs.cms.process.definition.FlowConditions
        • com.trs.cms.process.definition.FlowdocLogs
        • com.trs.cms.process.definition.FlowEmploys
        • com.trs.cms.process.definition.FlowNodeBranchs
        • com.trs.cms.process.definition.FlowNodeFields
        • com.trs.cms.process.definition.FlowNodes
        • com.trs.cms.process.definition.FlowRules
        • com.trs.cms.process.definition.Flows
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.cms.process.definition.FlowRuleCacheServerImpl (implements com.trs.cms.process.definition.IFlowRuleCacheServer)
    • com.trs.cms.process.definition.FlowCacheMgr (implements com.trs.infra.support.cache.ICacheMgr, com.trs.cms.process.IFlowCacheMgr)
    • com.trs.cms.process.definition.FlowEmployCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.cms.process.definition.FlowEmployerLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.cms.process.definition.FlowEmployMgr
    • com.trs.cms.process.definition.FlowMgr
    • com.trs.cms.process.definition.FlowOptMarkEnumParser
    • com.trs.cms.process.definition.RuleHostLCListnerForCache (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.trs.cms.process.definition.OptMarkParseException

接口分层结构

  • com.trs.infra.IServer
    • com.trs.cms.process.definition.IFlowRuleCacheServer


软件包 com.trs.cms.process.definition 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.definition
的使用

使用 com.trs.cms.process.definition 的软件包
com.trs.ajaxservice
com.trs.cms.process
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.cms.process.engine.handlers
com.trs.components.gkml.sqgk.process.element
com.trs.components.gkml.sqgk.process.engine.handlers
com.trs.components.infoview.process
com.trs.components.wcm.process.element
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 使用的 com.trs.cms.process.definition 中的类
Flow
FlowNodeFields
FlowNodes

com.trs.cms.process 使用的 com.trs.cms.process.definition 中的类
Flow
FlowNode
FlowNodes

com.trs.cms.process.definition 使用的 com.trs.cms.process.definition 中的类
Flow
FlowAction
FlowActions
FlowCondition
FlowConditions
FlowdocLog
FlowdocLogs
FlowEmploy
FlowEmploys
FlowNode
FlowNodeBranch
FlowNodeBranchs
FlowNodeField
FlowNodeFields
FlowNodes
FlowRule
FlowRules
Flows
IFlowRuleCacheServer
Title: TRS 内容协作平台（TRS WCM）
Description:
规则缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine 使用的 com.trs.cms.process.definition 中的类
Flow
FlowAction
FlowCondition
FlowNode
FlowNodeBranch
FlowRule

com.trs.cms.process.engine.handlers 使用的 com.trs.cms.process.definition 中的类
FlowAction
FlowCondition

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.cms.process.definition 中的类
Flow

com.trs.components.gkml.sqgk.process.engine.handlers 使用的 com.trs.cms.process.definition 中的类
FlowAction

com.trs.components.infoview.process 使用的 com.trs.cms.process.definition 中的类
FlowAction

com.trs.components.wcm.process.element 使用的 com.trs.cms.process.definition 中的类
Flow

com.trs.service 使用的 com.trs.cms.process.definition 中的类
Flow
Flows

com.trs.service.impl 使用的 com.trs.cms.process.definition 中的类
Flow
Flows

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RuleHostLCListnerForCache

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.definition
类 RuleHostLCListnerForCache

java.lang.Object
    继承者  com.trs.cms.process.definition.RuleHostLCListnerForCache
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class RuleHostLCListnerForCache
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流规则所属对象监听器，为了删除对象时候同步规则缓冲
由于修改和新增的时候规则可能还没有建立起来，所以需要在创建的逻辑中使用硬代码
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RuleHostLCListnerForCache()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RuleHostLCListnerForCache

public RuleHostLCListnerForCache()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.process.definition.Flow 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.Flow
的使用

使用 Flow 的软件包
com.trs.ajaxservice
com.trs.cms.process
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.components.gkml.sqgk.process.element
com.trs.components.wcm.process.element
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 Flow 的使用

返回 Flow 的 com.trs.ajaxservice 中的方法
static Flow | WCMApplyFormProcessServiceHelper.getFlow()
Flow | ProcessService.getFlowUsedByChannel(MethodContext _methodContext) 获取指定栏目正在使用的工作流

参数类型为 Flow 的 com.trs.ajaxservice 中的方法
static java.lang.String | WCMProcessServiceHelper.makeFlowContextInfo(Flow _flow)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, Flow _oFlow, MethodContext _oMethodContext)

com.trs.cms.process 中 Flow 的使用

返回 Flow 的 com.trs.cms.process 中的方法
 Flow IFlowContent.getOwnerFlow()
获取当前所属对象的工作流对象

参数类型为 Flow 的 com.trs.cms.process 中的方法
IFlowContent[] | FlowServerImpl.getFlowContentsInFlow(Flow _flow)
IFlowContent[] | IFlowServer.getFlowContentsInFlow(Flow _flow) 获取在指定流程中正在流转的内容
void | IFlowContent.setFlow(Flow flow)

com.trs.cms.process.definition 中 Flow 的使用

返回 Flow 的 com.trs.cms.process.definition 中的方法
static Flow | Flow.createNewInstance() 产生当前对象[Flow]的实例
static Flow | Flow.findById(int _nId) 提取指定ID的对象
static Flow | Flow.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Flow | Flows.getByName(java.lang.String _sName) 根据工作流名称获取工作流
Flow | FlowEmploy.getFlow()
Flow | FlowNode.getFlow() 节点所在工作流对象
Flow | FlowEmployMgr.getFlow(BaseObj _employer) get the detail flow of the specified element.

参数类型为 Flow 的 com.trs.cms.process.definition 中的方法
int | FlowEmployMgr.clearEmploysOfFlow(Flow _flow) clear all the employ records of the specified flow
void | FlowMgr.delete(Flow _currFlow)
BaseObjs | FlowEmployMgr.getChannelsUseingFlow(Flow _flow, BaseObjs _baseObjects, int _nEmployerType, java.lang.String _sTableName, WCMFilter _extraFilter) 获取使用指定工作的指定类型的对象
FlowEmploys | FlowEmployMgr.getEmployers(Flow _flow, WCMFilter _filter) get the employers who use the specified flow.
static java.lang.String | FlowOptMarkEnumParser.getFlowOptMarkEnum(Flow _flow)
boolean | FlowEmploy.setFlow(Flow _flow) set the flow used
boolean | FlowNode.setFlow(Flow _flow) 设置节点所在工作流

com.trs.cms.process.engine 中 Flow 的使用

返回 Flow 的 com.trs.cms.process.engine 中的方法
Flow | ContentProcessInfo.getContentFlow()
Flow | FlowContext.getCurrFlow()

参数类型为 Flow 的 com.trs.cms.process.engine 中的方法
 void ContentProcessInfo.setContentFlow(Flow contentFlow)

参数类型为 Flow 的 com.trs.cms.process.engine 中的构造方法
ContentProcessInfo(boolean _bEnd, Flow _contentFlow, java.lang.String _sUserName)
ContentProcessInfo(boolean _bEnd, Flow _contentFlow, User _oStartUser)
FlowContext(User _currUser, IFlowContent _oFlowContent, java.lang.String _sPostDesc, Users _toUsers, Flow _flow)
内容开始流转时候的FlowContext构造函数

com.trs.components.gkml.sqgk.process.element 中 Flow 的使用

返回 Flow 的 com.trs.components.gkml.sqgk.process.element 中的方法
 Flow FlowContentApplyFormImpl.getOwnerFlow()

参数类型为 Flow 的 com.trs.components.gkml.sqgk.process.element 中的方法
 void FlowContentApplyFormImpl.setFlow(Flow flow)

com.trs.components.wcm.process.element 中 Flow 的使用

返回 Flow 的 com.trs.components.wcm.process.element 中的方法
 Flow FlowContentDocumentImpl.getOwnerFlow()

参数类型为 Flow 的 com.trs.components.wcm.process.element 中的方法
 void FlowContentDocumentImpl.setFlow(Flow flow)

com.trs.service 中 Flow 的使用

返回 Flow 的 com.trs.service 中的方法
 Flow IWCMProcessService.getFlowOfEmployer(BaseObj _employer)

参数类型为 Flow 的 com.trs.service 中的方法
 java.lang.String IWCMProcessService.toFlowXMLString(Flow _currFlow)

com.trs.service.impl 中 Flow 的使用

返回 Flow 的 com.trs.service.impl 中的方法
 Flow WCMProcessServiceImpl.getFlowOfEmployer(BaseObj _employer)

参数类型为 Flow 的 com.trs.service.impl 中的方法
 java.lang.String WCMProcessServiceImpl.toFlowXMLString(Flow _currFlow)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowAction 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowAction
的使用

使用 FlowAction 的软件包
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.cms.process.engine.handlers
com.trs.components.gkml.sqgk.process.engine.handlers
com.trs.components.infoview.process

com.trs.cms.process.definition 中 FlowAction 的使用

返回 FlowAction 的 com.trs.cms.process.definition 中的方法
static FlowAction | FlowAction.createNewInstance() 产生当前对象[FlowAction]的实例
static FlowAction | FlowAction.findById(int _nId) 提取指定ID的对象
static FlowAction | FlowAction.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.cms.process.engine 中 FlowAction 的使用

参数类型为 FlowAction 的 com.trs.cms.process.engine 中的方法
 boolean IActionHandler.execute(ExecuteContext _context, FlowAction _action)

com.trs.cms.process.engine.handlers 中 FlowAction 的使用

参数类型为 FlowAction 的 com.trs.cms.process.engine.handlers 中的方法
boolean | MsgSendHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | PublishContentActionHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | AutoToNextHandler.execute(ExecuteContext _context, FlowAction _action)

com.trs.components.gkml.sqgk.process.engine.handlers 中 FlowAction 的使用

参数类型为 FlowAction 的 com.trs.components.gkml.sqgk.process.engine.handlers 中的方法
boolean | ReplyNotifyHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | ReplyAppendixNotifyHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | AutoFillApplyFormHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | ApplyFormTypeHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | ApplyFormReplyHandler.execute(ExecuteContext _context, FlowAction _action)

com.trs.components.infoview.process 中 FlowAction 的使用

参数类型为 FlowAction 的 com.trs.components.infoview.process 中的方法
 boolean SendEmailForInfoViewHandler.execute(ExecuteContext _context, FlowAction _action)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowActions 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowActions
的使用

使用 FlowActions 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowActions 的使用

返回 FlowActions 的 com.trs.cms.process.definition 中的方法
static FlowActions | FlowActions.createNewInstance(User _currUser) 产生当前集合对象[FlowActions]的实例
static FlowActions | FlowActions.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
FlowActions | FlowRule.getActions(User _currUser) 获取规则中设定的所有操作
static FlowActions | FlowActions.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowActions]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowCacheMgr
的使用

没有 com.trs.cms.process.definition.FlowCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowCondition 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowCondition
的使用

使用 FlowCondition 的软件包
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.cms.process.engine.handlers

com.trs.cms.process.definition 中 FlowCondition 的使用

返回 FlowCondition 的 com.trs.cms.process.definition 中的方法
static FlowCondition | FlowCondition.createNewInstance() 产生当前对象[FlowCondition]的实例
static FlowCondition | FlowCondition.findById(int _nId) 提取指定ID的对象
static FlowCondition | FlowCondition.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.cms.process.engine 中 FlowCondition 的使用

参数类型为 FlowCondition 的 com.trs.cms.process.engine 中的方法
 boolean IConditionHandler.isAccordWith(ExecuteContext _context, FlowCondition _condition)
是否与设定的条件相符合?

com.trs.cms.process.engine.handlers 中 FlowCondition 的使用

参数类型为 FlowCondition 的 com.trs.cms.process.engine.handlers 中的方法
boolean | OverTimeHandler.isAccordWith(ExecuteContext _context, FlowCondition _condition)
boolean | ContentPropertyHandler.isAccordWith(ExecuteContext _context, FlowCondition _condition)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowConditions 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowConditions
的使用

使用 FlowConditions 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowConditions 的使用

返回 FlowConditions 的 com.trs.cms.process.definition 中的方法
static FlowConditions | FlowConditions.createNewInstance(User _currUser) 产生当前集合对象[FlowConditions]的实例
static FlowConditions | FlowConditions.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
FlowConditions | FlowRule.getConditions(User _currUser) 获取规则中设定的所有条件
static FlowConditions | FlowConditions.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowConditions]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowdocLog 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowdocLog
的使用

使用 FlowdocLog 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowdocLog 的使用

返回 FlowdocLog 的 com.trs.cms.process.definition 中的方法
static FlowdocLog | FlowdocLog.createNewInstance() 产生当前对象[FlowdocLog]的实例
static FlowdocLog | FlowdocLog.findById(int _nId) 提取指定ID的对象
static FlowdocLog | FlowdocLog.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowdocLogs 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowdocLogs
的使用

使用 FlowdocLogs 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowdocLogs 的使用

返回 FlowdocLogs 的 com.trs.cms.process.definition 中的方法
static FlowdocLogs | FlowdocLogs.createNewInstance(User _currUser) 产生当前集合对象[FlowdocLogs]的实例
static FlowdocLogs | FlowdocLogs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowdocLogs | FlowdocLogs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowdocLogs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowEmploy 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowEmploy
的使用

使用 FlowEmploy 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowEmploy 的使用

返回 FlowEmploy 的 com.trs.cms.process.definition 中的方法
static FlowEmploy | FlowEmploy.createNewInstance() 产生当前对象[FlowEmploy]的实例
static FlowEmploy | FlowEmploy.findById(int _nId) 提取指定ID的对象
static FlowEmploy | FlowEmploy.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowEmployCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowEmployCacheMgr
的使用

没有 com.trs.cms.process.definition.FlowEmployCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowEmployerLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowEmployerLCListener
的使用

没有 com.trs.cms.process.definition.FlowEmployerLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowEmployMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowEmployMgr
的使用

没有 com.trs.cms.process.definition.FlowEmployMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowEmploys 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowEmploys
的使用

使用 FlowEmploys 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowEmploys 的使用

返回 FlowEmploys 的 com.trs.cms.process.definition 中的方法
static FlowEmploys | FlowEmploys.createNewInstance(User _currUser) 产生当前集合对象[FlowEmploys]的实例
static FlowEmploys | FlowEmploys.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
FlowEmploys | FlowEmployMgr.getEmployers(Flow _flow, WCMFilter _filter) get the employers who use the specified flow.
FlowEmploys | FlowEmployMgr.getEmploysOf(BaseObj _employer) Returns the employ records of the specified employer, which may be a folder or a content.
FlowEmploys | FlowEmployMgr.getEmploysOfEmployer(int _nEmployerType, int _nEmployerId) Returns the employ records of the specified employer, which may be a folder or a content.
static FlowEmploys | FlowEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowEmploys]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowMgr
的使用

没有 com.trs.cms.process.definition.FlowMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowNode 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowNode
的使用

使用 FlowNode 的软件包
com.trs.cms.process
com.trs.cms.process.definition
com.trs.cms.process.engine

com.trs.cms.process 中 FlowNode 的使用

返回 FlowNode 的 com.trs.cms.process 中的方法
 FlowNode IFlowCacheMgr.findFlowNodeByName(int _nFlowId, java.lang.String _sNodeName)

参数类型为 FlowNode 的 com.trs.cms.process 中的方法
FlowDoc | FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode)
FlowDoc | IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode) 自动将当前轨迹呈送到下一个节点
FlowDoc | FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers)
FlowDoc | IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers) 自动将当前轨迹呈送到下一个节点

com.trs.cms.process.definition 中 FlowNode 的使用

返回 FlowNode 的 com.trs.cms.process.definition 中的方法
static FlowNode | FlowNode.createNewInstance() 产生当前对象[FlowNode]的实例
static FlowNode | FlowNode.findById(int _nId) 提取指定ID的对象
static FlowNode | FlowNode.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static FlowNode | FlowNode.findByName(int _nFlowId, java.lang.String _sNodeName)
FlowNode | FlowCacheMgr.findFlowNodeByName(int _nFlowId, java.lang.String _sNodeName)
FlowNode | Flow.getEndNode() 获取结束节点
FlowNode | FlowNodeBranch.getNextNode(User _currUser) 取下一个节点对象
FlowNode | FlowNodeBranch.getNode() 获取第一个节点对象
FlowNode | Flow.getStartNode() 获取起始节点

参数类型为 FlowNode 的 com.trs.cms.process.definition 中的方法
static FlowNodeFields | FlowNodeFields.findOf(User _currUser, FlowNode _node)
FlowNodeBranch | FlowNode.getBranchTo(User _currUser, FlowNode _nextNode) 获得当前节点到指定节点的分支
FlowRule[] | FlowRuleCacheServerImpl.getRules(FlowNode _currNode, int _nRuleType)
FlowRule[] | IFlowRuleCacheServer.getRules(FlowNode _currNode, int _nRuleType) 获取定义在指定节点上指定类型的规则
boolean | FlowNodeBranch.setNode(FlowNode _node) 设置第一个节点

com.trs.cms.process.engine 中 FlowNode 的使用

返回 FlowNode 的 com.trs.cms.process.engine 中的方法
FlowNode | ExecuteContext.getCurrNode() 获取当前所处节点
FlowNode | FlowContext.getCurrNode()
FlowNode | FlowContextOld.getFlowNode() 获取当前处理的节点
FlowNode | FlowParamers.getNextNode()
FlowNode | FlowContext.getNextNode()
FlowNode | FlowDoc.getNode() 获取所在的节点对象
FlowNode | FlowParamers.getPreNode()
FlowNode | FlowDoc.getPreNode() 获取前一个节点

参数类型为 FlowNode 的 com.trs.cms.process.engine 中的方法
void | FlowContext.setCurrNode(FlowNode _currNode) 设置当前节点
void | FlowParamers.setNextNode(FlowNode nextNode)
void | FlowContext.setNextNode(FlowNode nextNode)
boolean | FlowDoc.setNode(FlowNode _flowNode) 设置所在的节点
void | FlowParamers.setPreNode(FlowNode preNode)
boolean | FlowDoc.setPreNode(FlowNode _flowNode) 设置前一个节点

参数类型为 FlowNode 的 com.trs.cms.process.engine 中的构造方法
FlowContextOld(IFlowContent _currObj, FlowNode _currNode, User _postUser)
工作流环境变量记录对象的构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowNodeBranch 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowNodeBranch
的使用

使用 FlowNodeBranch 的软件包
com.trs.cms.process.definition
com.trs.cms.process.engine

com.trs.cms.process.definition 中 FlowNodeBranch 的使用

返回 FlowNodeBranch 的 com.trs.cms.process.definition 中的方法
 FlowNodeBranch FlowNode.getBranchTo(User _currUser, FlowNode _nextNode)
获得当前节点到指定节点的分支

com.trs.cms.process.engine 中 FlowNodeBranch 的使用

返回 FlowNodeBranch 的 com.trs.cms.process.engine 中的方法
FlowNodeBranch | FlowParamers.getBranch()
FlowNodeBranch | FlowContext.getBranch() 获取当前操作轨迹的分支
FlowNodeBranch | FlowDoc.getBranchComeFrom(User _currUser) 获取文档流转到当前状态经过的分支

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowNodeBranchs 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowNodeBranchs
的使用

使用 FlowNodeBranchs 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowNodeBranchs 的使用

返回 FlowNodeBranchs 的 com.trs.cms.process.definition 中的方法
static FlowNodeBranchs | FlowNodeBranchs.createNewInstance(User _currUser) 产生当前集合对象[FlowNodeBranchs]的实例
static FlowNodeBranchs | FlowNodeBranchs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
FlowNodeBranchs | FlowNode.getBranchs(User _currUser) 取得节点上的所有工作流分支集合
static FlowNodeBranchs | FlowNodeBranchs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodeBranchs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowNodeField 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowNodeField
的使用

使用 FlowNodeField 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowNodeField 的使用

返回 FlowNodeField 的 com.trs.cms.process.definition 中的方法
static FlowNodeField | FlowNodeField.createNewInstance() 产生当前对象[FlowNodeField]的实例
static FlowNodeField | FlowNodeField.findById(int _nId) 提取指定ID的对象
static FlowNodeField | FlowNodeField.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowNodeFields 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowNodeFields
的使用

使用 FlowNodeFields 的软件包
com.trs.ajaxservice
com.trs.cms.process.definition

com.trs.ajaxservice 中 FlowNodeFields 的使用

返回 FlowNodeFields 的 com.trs.ajaxservice 中的方法
 FlowNodeFields ProcessService.getFieldsInfoOfFlowDoc(MethodContext _methodContext)
获取当前轨迹处理中可读和可写的字段列表

com.trs.cms.process.definition 中 FlowNodeFields 的使用

返回 FlowNodeFields 的 com.trs.cms.process.definition 中的方法
static FlowNodeFields | FlowNodeFields.createNewInstance(User _currUser) 产生当前集合对象[FlowNodeFields]的实例
static FlowNodeFields | FlowNodeFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowNodeFields | FlowNodeFields.findOf(User _currUser, FlowNode _node)
static FlowNodeFields | FlowNodeFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodeFields]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowNodes 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowNodes
的使用

使用 FlowNodes 的软件包
com.trs.ajaxservice
com.trs.cms.process
com.trs.cms.process.definition

com.trs.ajaxservice 中 FlowNodes 的使用

返回 FlowNodes 的 com.trs.ajaxservice 中的方法
 FlowNodes ProcessService.getNextNodes(MethodContext _methodContext)
获取当前节点下一个节点集合

com.trs.cms.process 中 FlowNodes 的使用

返回 FlowNodes 的 com.trs.cms.process 中的方法
FlowNodes | FlowServerImpl.getNextFlowNodes(FlowDoc _currFlowDoc, boolean _bIsResubmit)
FlowNodes | IFlowServer.getNextFlowNodes(FlowDoc _currFlowDoc, boolean _bIsResubmit) 获取当前轨迹的下一个处理节点

com.trs.cms.process.definition 中 FlowNodes 的使用

返回 FlowNodes 的 com.trs.cms.process.definition 中的方法
static FlowNodes | FlowNodes.createNewInstance(User _currUser) 产生当前集合对象[FlowNodes]的实例
static FlowNodes | FlowNodes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
FlowNodes | Flow.getFlowNodes(User _currUser) 取得工作流节点集合
FlowNodes | FlowNode.getNextNodes(User _currUser) 获取下一个节点集合
FlowNodes | FlowNode.getNextNodes(User _currUser, WCMFilter _filter)
static FlowNodes | FlowNodes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodes]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowOptMarkEnumParser 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowOptMarkEnumParser
的使用

没有 com.trs.cms.process.definition.FlowOptMarkEnumParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowRule 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowRule
的使用

使用 FlowRule 的软件包
com.trs.cms.process.definition
com.trs.cms.process.engine

com.trs.cms.process.definition 中 FlowRule 的使用

返回 FlowRule 的 com.trs.cms.process.definition 中的方法
static FlowRule | FlowRule.createNewInstance() 产生当前对象[FlowRule]的实例
static FlowRule | FlowRule.findById(int _nId) 提取指定ID的对象
static FlowRule | FlowRule.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
FlowRule[] | FlowRuleCacheServerImpl.getRules(FlowNode _currNode, int _nRuleType)
FlowRule[] | IFlowRuleCacheServer.getRules(FlowNode _currNode, int _nRuleType) 获取定义在指定节点上指定类型的规则
FlowRule[] | FlowRuleCacheServerImpl.getRules(int _nHostType, int _nHostId, int _nRuleType)
FlowRule[] | IFlowRuleCacheServer.getRules(int _nHostType, int _nHostId, int _nRuleType) 获取在指定对象上定义的指定类型的规则

com.trs.cms.process.engine 中 FlowRule 的使用

参数类型为 FlowRule 的 com.trs.cms.process.engine 中的方法
static void RuleExecuteHelper.executeRules(ExecuteContext _oExecContext, FlowRule[] _pRules)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowRuleCacheServerImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowRuleCacheServerImpl
的使用

没有 com.trs.cms.process.definition.FlowRuleCacheServerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.FlowRules 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.FlowRules
的使用

使用 FlowRules 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 FlowRules 的使用

返回 FlowRules 的 com.trs.cms.process.definition 中的方法
static FlowRules | FlowRules.createNewInstance(User _currUser) 产生当前集合对象[FlowRules]的实例
static FlowRules | FlowRules.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowRules | FlowRules.findOf(User _currUser, CMSObj _host) 根据Host获取相关的规则
static FlowRules | FlowRules.findOf(User _currUser, int _nHostType, int _nHostId) 根据Host获取相关的规则
static FlowRules | FlowRules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowRules]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.Flows 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.Flows
的使用

使用 Flows 的软件包
com.trs.cms.process.definition
com.trs.service
com.trs.service.impl

com.trs.cms.process.definition 中 Flows 的使用

返回 Flows 的 com.trs.cms.process.definition 中的方法
static Flows | Flows.createNewInstance(User _currUser) 产生当前集合对象[Flows]的实例
static Flows | Flows.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Flows | FlowEmployMgr.getEmployedFlows(BaseObj _employer) get the flows collection employed by the publish element.
static Flows | Flows.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Flows]

com.trs.service 中 Flows 的使用

返回 Flows 的 com.trs.service 中的方法
 Flows IWCMProcessService.getFlows(WCMFilter _filter)

com.trs.service.impl 中 Flows 的使用

返回 Flows 的 com.trs.service.impl 中的方法
 Flows WCMProcessServiceImpl.getFlows(WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.definition.IFlowRuleCacheServer 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.definition.IFlowRuleCacheServer
的使用

使用 IFlowRuleCacheServer 的软件包
com.trs.cms.process.definition

com.trs.cms.process.definition 中 IFlowRuleCacheServer 的使用

实现 IFlowRuleCacheServer 的 com.trs.cms.process.definition 中的类
 class FlowRuleCacheServerImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流规则缓冲维护器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.OptMarkParseException 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.OptMarkParseException
的使用

没有 com.trs.cms.process.definition.OptMarkParseException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.definition.RuleHostLCListnerForCache 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.definition.RuleHostLCListnerForCache
的使用

没有 com.trs.cms.process.definition.RuleHostLCListnerForCache 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AbstractToUsersCreator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 AbstractToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
所有已实现的接口：
IToUsersCreator
直接已知子类：
ApplyFormToUsersCreator, CrUserAsToUsersCreator, DeptMgrAsToUsersCreator, GroupAdminsAsToUsersCreator, GroupAdminsFromChnlAsToUsersCreator, GroupAdminsFromFlowAsToUsersCreator, GroupAdminsFromSupportPartAsToUsersCreator, GroupMembersAsToUsersCreator, LawGovTousersCreator, RoleAsToUsersCreator
public abstract class AbstractToUsersCreator
extends java.lang.Object
implements IToUsersCreator

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AbstractToUsersCreator()
方法摘要
Group | getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig) 限定了用户选择范围（在特定组内选择）
boolean | isRangedFromGroup() 指定是否需要从特定组内选择
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.cms.process.engine.IToUsersCreator 继承的方法
createToUsers

构造方法详细信息

AbstractToUsersCreator

public AbstractToUsersCreator()
方法详细信息

isRangedFromGroup

public boolean isRangedFromGroup()
从接口 IToUsersCreator 复制的描述
指定是否需要从特定组内选择

指定者：
接口 IToUsersCreator 中的 isRangedFromGroup
返回：

getGroupRange

public Group getGroupRange(FlowContext _context,
                           ToUsersCreatorConfig _creatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
限定了用户选择范围（在特定组内选择）

指定者：
接口 IToUsersCreator 中的 getGroupRange
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ContentProcessInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 ContentProcessInfo

java.lang.Object
    继承者  com.trs.cms.process.engine.ContentProcessInfo

public class ContentProcessInfo
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentProcessInfo(boolean _bEnd, Flow _contentFlow, java.lang.String _sUserName)
ContentProcessInfo(boolean _bEnd, Flow _contentFlow, User _oStartUser)
ContentProcessInfo(boolean _bEnd, IFlowContent _content, java.lang.String _sUserName)
方法摘要
boolean | canInFlow()
boolean | canReInFlow()
boolean | canStopFlow()
IFlowContent | getContent()
Flow | getContentFlow()
int | getContentFlowId()
User | getStartUser()
java.lang.String | getStartUserName()
boolean | isEnd()
void | setContent(IFlowContent content)
void | setContentFlow(Flow contentFlow)
void | setEnd(boolean end)
void | setStartUser(User startUser)
void | setStartUserName(java.lang.String userName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentProcessInfo

public ContentProcessInfo(boolean _bEnd,
                          Flow _contentFlow,
                          User _oStartUser)

ContentProcessInfo

public ContentProcessInfo(boolean _bEnd,
                          Flow _contentFlow,
                          java.lang.String _sUserName)

ContentProcessInfo

public ContentProcessInfo(boolean _bEnd,
                          IFlowContent _content,
                          java.lang.String _sUserName)
                   throws WCMException
抛出：
WCMException
方法详细信息

isEnd

public boolean isEnd()
返回：

setEnd

public void setEnd(boolean end)
参数：
end -

getStartUser

public User getStartUser()
返回：

setStartUser

public void setStartUser(User startUser)
参数：
startUser -

getStartUserName

public java.lang.String getStartUserName()
返回：

setStartUserName

public void setStartUserName(java.lang.String userName)
参数：
userName -

getContentFlow

public Flow getContentFlow()
                    throws WCMException
返回：
抛出：
WCMException

setContentFlow

public void setContentFlow(Flow contentFlow)
参数：
contentFlow -

getContentFlowId

public int getContentFlowId()

getContent

public IFlowContent getContent()
返回：

setContent

public void setContent(IFlowContent content)
参数：
content -

canReInFlow

public boolean canReInFlow()
                    throws WCMException
返回：
抛出：
WCMException

canInFlow

public boolean canInFlow()
                  throws WCMException
返回：
抛出：
WCMException

canStopFlow

public boolean canStopFlow()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExecuteContext

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 ExecuteContext

java.lang.Object
    继承者  com.trs.cms.process.engine.ExecuteContext

public class ExecuteContext
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流在驱动过程中上下文对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ExecuteContext(FlowContext _oFlowContext)
ExecuteContext(FlowDoc _flowDoc)
方法摘要
FlowDoc | getCurrFlowDoc() 获取当前相关的工作流轨迹
FlowNode | getCurrNode() 获取当前所处节点
IFlowContent | getFlowContent() 获取当前正在处理的内容
FlowContext | getFlowContext()
User | getPostUser() 获取处理人
void | setFlowContext(FlowContext flowContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExecuteContext

public ExecuteContext(FlowContext _oFlowContext)

ExecuteContext

public ExecuteContext(FlowDoc _flowDoc)
方法详细信息

getFlowContext

public FlowContext getFlowContext()
返回：

setFlowContext

public void setFlowContext(FlowContext flowContext)
参数：
flowContext -

getCurrNode

public FlowNode getCurrNode()
                     throws WCMException
获取当前所处节点

返回：
抛出：
WCMException

getPostUser

public User getPostUser()
获取处理人

返回：
抛出：
WCMException

getCurrFlowDoc

public FlowDoc getCurrFlowDoc()
获取当前相关的工作流轨迹

返回：
抛出：
WCMException

getFlowContent

public IFlowContent getFlowContent()
                            throws WCMException
获取当前正在处理的内容

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContentConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowContentConfig

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.engine.FlowContentConfig
所有已实现的接口：
java.lang.Cloneable
public class FlowContentConfig
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
FlowContentConfig()
构造函数：保留默认接口
FlowContentConfig(int _nObjType, java.lang.String _sClassName, java.lang.String _sDesc)
方法摘要
static FlowContentConfig | createNewInstance() 产生当前对象[FlowContentConfig]的实例
static FlowContentConfig | findById(int _nId) 提取指定ID的对象
static FlowContentConfig | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
IFlowContent | getFlowContent()
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.Class | getObjClass()
java.lang.String | getObjClassName() 提取属性：ObjClass
java.lang.String | getObjDesc() 提取属性：ObjDesc
int | getObjType() 提取属性：ObjType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setObjClass(java.lang.String _sObjClass) 设置属性：ObjClass
boolean | setObjDesc(java.lang.String _sObjDesc) 设置属性：ObjDesc
boolean | setObjType(int _nObjType) 设置属性：ObjType
void | update(User _user) 更新修改。
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowContentConfig

public FlowContentConfig()
构造函数：保留默认接口

FlowContentConfig

public FlowContentConfig(int _nObjType,
                         java.lang.String _sClassName,
                         java.lang.String _sDesc)
                  throws WCMException
抛出：
WCMException
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getObjType

public int getObjType()
提取属性：ObjType

返回：
ObjType

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
设置属性：ObjType

参数：
_nObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjClassName

public java.lang.String getObjClassName()
提取属性：ObjClass

返回：
ObjClass

getObjClass

public java.lang.Class getObjClass()
                            throws WCMException
抛出：
WCMException

getFlowContent

public IFlowContent getFlowContent()
                            throws WCMException
抛出：
WCMException

setObjClass

public boolean setObjClass(java.lang.String _sObjClass)
                    throws WCMException
设置属性：ObjClass

参数：
_sObjClass - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjDesc

public java.lang.String getObjDesc()
提取属性：ObjDesc

返回：
ObjDesc

setObjDesc

public boolean setObjDesc(java.lang.String _sObjDesc)
                   throws WCMException
设置属性：ObjDesc

参数：
_sObjDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final FlowContentConfig findById(int _nId)
                                        throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowContentConfig createNewInstance()
                                                 throws WCMException
产生当前对象[FlowContentConfig]的实例

返回：
当前对象的实例[FlowContentConfig]
抛出：
WCMException

findByKey

public static final FlowContentConfig findByKey(java.lang.Object _oKey)
                                         throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

update

public void update(User _user)
            throws WCMException
从类 CMSObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 CMSObj 中的 update
参数：
_user - 操作用户
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContentConfigs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowContentConfigs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.engine.FlowContentConfigs

public class FlowContentConfigs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowContentConfigs(User _currUser)
构造函数
FlowContentConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static FlowContentConfigs | createNewInstance(User _currUser) 产生当前集合对象[FlowContentConfigs]的实例
static FlowContentConfigs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static FlowContentConfigs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowContentConfigs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContentConfigs

public FlowContentConfigs(User _currUser)
构造函数

另请参见：
FlowContentConfigs( User _currUser, int _initCapacity, int _incCapacity );

FlowContentConfigs

public FlowContentConfigs(User _currUser,
                          int _initCapacity,
                          int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final FlowContentConfigs findByIds(User _currUser,
                                                 java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowContentConfigs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FlowContentConfigs openWCMObjs(User _currUser,
                                                   WCMFilter _filter)
                                            throws WCMException
通过指定一个Filter获取当前集合[FlowContentConfigs]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowContentConfigs]
抛出：
WCMException

createNewInstance

public static FlowContentConfigs createNewInstance(User _currUser)
产生当前集合对象[FlowContentConfigs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContentHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowContentHelper

java.lang.Object
    继承者  com.trs.cms.process.engine.FlowContentHelper

public class FlowContentHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
comment@2008-06-12 createFlowContent替换为新的实现

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContentHelper()
方法摘要
static IFlowContent | createFlowContent(CMSObj _subinstance)
static IFlowContent | createFlowContent(int _nObjType, int _nObjId)
static void | registerContent(int _nObjType, java.lang.Class _currContentClass)
static void | removeContent(int _nObjType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContentHelper

public FlowContentHelper()
方法详细信息

createFlowContent

public static IFlowContent createFlowContent(int _nObjType,
                                             int _nObjId)
                                      throws WCMException
抛出：
WCMException

createFlowContent

public static IFlowContent createFlowContent(CMSObj _subinstance)
                                      throws WCMException
抛出：
WCMException

registerContent

public static void registerContent(int _nObjType,
                                   java.lang.Class _currContentClass)
                            throws WCMException
抛出：
WCMException

removeContent

public static void removeContent(int _nObjType)
                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContentLCListener

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowContentLCListener

java.lang.Object
    继承者  com.trs.cms.process.engine.FlowContentLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class FlowContentLCListener
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
Flow Content生命周期监听器,只监听删除前
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContentLCListener()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContentLCListener

public FlowContentLCListener()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContext

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowContext

java.lang.Object
    继承者  com.trs.cms.process.engine.FlowContext

public class FlowContext
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流驱动过程上下文对象
Copyright: Copyright (c) 2004-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContext()
FlowContext(User _currUser, IFlowContent _oFlowContent)
内容开始流转时候的FlowContext构造函数
FlowContext(User _currUser, IFlowContent _oFlowContent, java.lang.String _sPostDesc, Users _toUsers, Flow _flow)
内容开始流转时候的FlowContext构造函数
方法摘要
FlowNodeBranch | getBranch() 获取当前操作轨迹的分支
long | getBranchSerialNum()
Flow | getCurrFlow()
FlowDoc | getCurrFlowDoc()
FlowNode | getCurrNode()
User | getCurrUser()
IFlowContent | getFlowContent()
FlowNode | getNextNode()
java.lang.String | getNotifyTypes()
java.lang.String | getPostDesc()
User | getPostUser()
long | getSerialNum()
Users | getToUsers()
int | getWorkModal()
boolean | isFromRule()
boolean | isStarting()
void | setCurrFlowDoc(FlowDoc currFlowDoc)
void | setCurrNode(FlowNode _currNode) 设置当前节点
void | setCurrUser(User currUser)
void | setFlowContent(IFlowContent flowContent)
void | setFromRule(boolean fromRule)
void | setNextNode(FlowNode nextNode)
void | setNotifyTypes(java.lang.String notifyTypes)
void | setPostDesc(java.lang.String postDesc)
void | setPostUser(User postUser)
void | setSerialNum(long serialNum)
void | setToUsers(Users toUsers)
void | validate() 校验上下文参数是否有效
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContext

public FlowContext()

FlowContext

public FlowContext(User _currUser,
                   IFlowContent _oFlowContent,
                   java.lang.String _sPostDesc,
                   Users _toUsers,
                   Flow _flow)
            throws WCMException
内容开始流转时候的FlowContext构造函数

参数：
_oFlowContent -
_sPostDesc -
_toUser -
_flow - 待流转的内容进入的流程，可以不指定，如果不指定
抛出：
WCMException

FlowContext

public FlowContext(User _currUser,
                   IFlowContent _oFlowContent)
            throws WCMException
内容开始流转时候的FlowContext构造函数

参数：
_oFlowContent -
_sPostDesc -
_toUser -
_flow - 待流转的内容进入的流程，可以不指定，如果不指定
抛出：
WCMException
方法详细信息

getCurrFlowDoc

public FlowDoc getCurrFlowDoc()
返回：

setCurrFlowDoc

public void setCurrFlowDoc(FlowDoc currFlowDoc)
参数：
currFlowDoc -

getPostUser

public User getPostUser()
返回：

setPostUser

public void setPostUser(User postUser)
参数：
postUser -

getToUsers

public Users getToUsers()
返回：

setToUsers

public void setToUsers(Users toUsers)
参数：
toUsers -

getPostDesc

public java.lang.String getPostDesc()
返回：

setPostDesc

public void setPostDesc(java.lang.String postDesc)
参数：
postDesc -

validate

public void validate()
              throws WCMException
校验上下文参数是否有效

抛出：
WCMException

getNextNode

public FlowNode getNextNode()
返回：

setNextNode

public void setNextNode(FlowNode nextNode)
参数：
nextNode -

getCurrUser

public User getCurrUser()
返回：

setCurrUser

public void setCurrUser(User currUser)
参数：
currUser -

isStarting

public boolean isStarting()
返回：

getWorkModal

public int getWorkModal()

getFlowContent

public IFlowContent getFlowContent()
                            throws WCMException
返回：
抛出：
WCMException

setFlowContent

public void setFlowContent(IFlowContent flowContent)
参数：
flowContent -

getNotifyTypes

public java.lang.String getNotifyTypes()
                                throws WCMException
返回：
抛出：
WCMException

getCurrNode

public FlowNode getCurrNode()
                     throws WCMException
返回：
抛出：
WCMException

setCurrNode

public void setCurrNode(FlowNode _currNode)
设置当前节点

参数：
_currNode -

setNotifyTypes

public void setNotifyTypes(java.lang.String notifyTypes)
参数：
notifyTypes -

getBranch

public FlowNodeBranch getBranch()
                         throws WCMException
获取当前操作轨迹的分支

返回：
抛出：
WCMException

getSerialNum

public long getSerialNum()
                  throws WCMException
返回：
抛出：
WCMException

setSerialNum

public void setSerialNum(long serialNum)
参数：
serialNum -

getBranchSerialNum

public long getBranchSerialNum()
                        throws WCMException
返回：
抛出：
WCMException

getCurrFlow

public Flow getCurrFlow()

isFromRule

public boolean isFromRule()

setFromRule

public void setFromRule(boolean fromRule)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowContextOld

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowContextOld

java.lang.Object
    继承者  com.trs.cms.process.engine.FlowContextOld

public class FlowContextOld
extends java.lang.Object

构造方法摘要
FlowContextOld()
FlowContextOld(IFlowContent _currObj, FlowNode _currNode, User _postUser)
工作流环境变量记录对象的构造函数
方法摘要
IFlowContent | getFlowContent() 获取当前处理的流转对象（WCMObj），可以是文档，也可以是其它的类
FlowNode | getFlowNode() 获取当前处理的节点
User | getPostUser() 获取呈送文档的用户
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContextOld

public FlowContextOld()

FlowContextOld

public FlowContextOld(IFlowContent _currObj,
                      FlowNode _currNode,
                      User _postUser)
工作流环境变量记录对象的构造函数

参数：
_app - 当前使用的Application对象
_currObj - 当前处理的流转对象（WCMObj），可以是文档，也可以是其它的类
_currNode - 当前处理的节点
_postUser - 当前呈送用户
方法详细信息

getFlowContent

public IFlowContent getFlowContent()
获取当前处理的流转对象（WCMObj），可以是文档，也可以是其它的类

返回：

getFlowNode

public FlowNode getFlowNode()
获取当前处理的节点

返回：

getPostUser

public User getPostUser()
获取呈送文档的用户

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowDoc

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowDoc

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.engine.FlowDoc
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
FlowDocBak
public class FlowDoc
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
FlowDoc()
构造函数：保留默认接口
方法摘要
 boolean addToUser(int _userId)
添加呈送人员
 boolean addToUser(User _user)
添加呈送人员
static FlowDoc createNewInstance()
产生当前对象[FlowDoc]的实例
static FlowDoc findById(int _nId)
提取指定ID的对象
static FlowDoc findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象
 CMyDateTime getAcceptTime()
 FlowNodeBranch getBranchComeFrom(User _currUser)
获取文档流转到当前状态经过的分支
 long getBranchSerialNum()
 FlowDocs getChildren(User _currUser, WCMFilter _filter)
获取当前轨迹的子轨迹列表
 int getContentId()
 int getContentType()
 java.lang.String getDbTableName()
获得数据库中存储该对象的数据表名称。
 int getFlag()
获取文档流转状态
 java.lang.String getFlagDesc()
获取文档流转状态描述
 IFlowContent getFlowContent()
 java.lang.String getIdFieldName()
获得Id字段名。
 FlowNode getNode()
获取所在的节点对象
 int getNodeId()
获取所在的节点ID
 FlowDoc getParent()
获取事务轨迹
 int getParentId()
获取事务轨迹ID
 java.lang.String getPostDesc()
获取递交说明
 CMyDateTime getPostTime()
获取递交时间
 User getPostUser()
获取递交用户
 java.lang.String getPostUserName()
获取递交用户的用户名
 java.lang.String getPostUserTrueName()
获取递交用户的真实用户名
 FlowDoc getPreFlowDoc()
获取上一次事务轨迹
 int getPreFlowDocId()
获取上一次事务轨迹ID
 FlowNode getPreNode()
获取前一个节点
 int getPreNodeId()
获取前一个节点ID
 FlowDoc getPrevious(User _currUser, boolean _bGoBack)
取前一个流转经过的FlowDoc对象 Sample: A->B->C，然后两次打回 C->B->A，在B处打回时需要将参数_bGoBack置为true
 java.lang.String getRealPostUserNames()
返回真实的处理用户
 CMyDateTime getReceiveTime()
 long getSerialNum()
 User getToUser()
获取接收者
 int getToUserId()
获取所在的节点ID
 java.lang.String getToUserIds()
获取所有呈送人员ID字符串（不同ID之间移字符','分割）
 java.lang.String getToUserNames()
 Users getToUsers(User _currUser)
获取所有呈送人员集合
 java.lang.String getToUserTrueNames()
添加了返回toUser的真实姓名的方法
 int getWCMType()
取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
 int getWorkModal()
获取处理模式
 java.lang.String getWorkModalDesc()
获取处理模式显示
 void insert(User _currUser)
重载父类的insert函数，以便设置产生时间
 boolean isAccepted()
用户是否已经签收
 boolean isReceived()
是否已经接收到
 boolean isValid()
实现父类的isValid函数，进行数据的效验
 boolean isWorked()
获取当前的轨迹是否处理过
 boolean setAccepted()
设置签收
 boolean setAcceptTime()
使用当前时间设置确认处理时间
 boolean setBranchSerialNum(long _lSerialNum)
 void setContent(IFlowContent flowContent)
设置相关内容
 boolean setContent(int contentType, int contentId)
设置相关内容
 boolean setContentId(int _nContentId)
 boolean setContentType(int _nContentType)
 boolean setFlag(int _flag)
设置文档流转状态
 boolean setFlowContent(IFlowContent _content)
设置所属文档
 boolean setFlowContent(int _nObjType, int _nObjId)
 boolean setNode(FlowNode _flowNode)
设置所在的节点
 boolean setNode(int _nodeId)
设置所在的节点
 boolean setParent(int _nParentId)
设置所属事务轨迹
 boolean setPostDesc(java.lang.String _desc)
设置递交说明
 boolean setPostTime(CMyDateTime _postTime)
设置递交时间
 boolean setPostUser(java.lang.String _userName)
设置递交用户
 boolean setPostUser(User _postUser)
设置递交用户
 boolean setPreFlowDoc(FlowDoc currFlowDoc)
设置前一个轨迹
 boolean setPreFlowDoc(int _nPreFlowDocId)
设置上一次事务轨迹
 boolean setPreNode(FlowNode _flowNode)
设置前一个节点
 boolean setPreNode(int _nodeId)
设置前一个节点
 boolean setReceiveTime()
使用当前时间设置接收时间
 boolean setSerialNum(long _lSerialNum)
 boolean setToUser(int _nToUserId)
设置接收者
 boolean setToUser(User _toUser)
设置接收者
 boolean setToUsers(java.lang.String _userIds)
设置呈送人员
 boolean setWorked(boolean _bWorked)
设置流转轨迹是否处理过
 boolean setWorkModal(int _nWorkModal)
设置事务处理模式
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowDoc

public FlowDoc()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
CMSObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
CMSObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
CMSObj.getWCMType()

getNodeId

public int getNodeId()
获取所在的节点ID

返回：
所在的节点ID

getNode

public FlowNode getNode()
                 throws WCMException
获取所在的节点对象

返回：
所在的节点对象
抛出：
WCMException

setNode

public boolean setNode(int _nodeId)
                throws WCMException
设置所在的节点

参数：
_nodeId - 所在的节点ID
返回：
抛出：
WCMException

setNode

public boolean setNode(FlowNode _flowNode)
                throws WCMException
设置所在的节点

参数：
_flowNode - 所在的节点对象
返回：
抛出：
WCMException

getToUserId

public int getToUserId()
获取所在的节点ID

返回：
所在的节点ID

getToUser

public User getToUser()
               throws WCMException
获取接收者

返回：
抛出：
WCMException

getToUserNames

public java.lang.String getToUserNames()
                                throws WCMException
返回：
抛出：
WCMException

setToUser

public boolean setToUser(int _nToUserId)
                  throws WCMException
设置接收者

参数：
_nToUserId -
返回：
抛出：
WCMException

setToUser

public boolean setToUser(User _toUser)
                  throws WCMException
设置接收者

参数：
_toUser -
返回：
抛出：
WCMException

getContentType

public int getContentType()

setContentType

public boolean setContentType(int _nContentType)
                       throws WCMException
抛出：
WCMException

getContentId

public int getContentId()

setContentId

public boolean setContentId(int _nContentId)
                     throws WCMException
抛出：
WCMException

getFlowContent

public IFlowContent getFlowContent()
                            throws WCMException
抛出：
WCMException

setFlowContent

public boolean setFlowContent(int _nObjType,
                              int _nObjId)
                       throws WCMException
抛出：
WCMException

setFlowContent

public boolean setFlowContent(IFlowContent _content)
                       throws WCMException
设置所属文档

参数：
_content - 所属文档对象
返回：
抛出：
WCMException

getFlag

public int getFlag()
获取文档流转状态

返回：
文档流转状态

getFlagDesc

public java.lang.String getFlagDesc()
获取文档流转状态描述

返回：
文档流转状态描述

setFlag

public boolean setFlag(int _flag)
                throws WCMException
设置文档流转状态

参数：
_flag - 文档流转状态（Flow.FLAG_FORWARD）
返回：
抛出：
WCMException

getWorkModal

public int getWorkModal()
获取处理模式

返回：

getWorkModalDesc

public java.lang.String getWorkModalDesc()
获取处理模式显示

返回：

setWorkModal

public boolean setWorkModal(int _nWorkModal)
                     throws WCMException
设置事务处理模式

参数：
_nWorkModal -
返回：
抛出：
WCMException

isWorked

public boolean isWorked()
获取当前的轨迹是否处理过

返回：
文档流转状态

setWorked

public boolean setWorked(boolean _bWorked)
                  throws WCMException
设置流转轨迹是否处理过

参数：
_bWorked - 是否处理过
返回：
抛出：
WCMException

getPreFlowDocId

public int getPreFlowDocId()
获取上一次事务轨迹ID

返回：

getPreFlowDoc

public FlowDoc getPreFlowDoc()
                      throws WCMException
获取上一次事务轨迹

返回：
抛出：
WCMException

setPreFlowDoc

public boolean setPreFlowDoc(int _nPreFlowDocId)
                      throws WCMException
设置上一次事务轨迹

参数：
_nPreFlowDocId -
返回：
抛出：
WCMException

getParentId

public int getParentId()
获取事务轨迹ID

返回：

getParent

public FlowDoc getParent()
                  throws WCMException
获取事务轨迹

返回：
抛出：
WCMException

setParent

public boolean setParent(int _nParentId)
                  throws WCMException
设置所属事务轨迹

参数：
_nParentId -
返回：
抛出：
WCMException

getPostUserName

public java.lang.String getPostUserName()
获取递交用户的用户名

返回：

getPostUserTrueName

public java.lang.String getPostUserTrueName()
获取递交用户的真实用户名

返回：

getRealPostUserNames

public java.lang.String getRealPostUserNames()
返回真实的处理用户

返回：

getPostUser

public User getPostUser()
获取递交用户

返回：
递交用户对象（User）
抛出：
WCMException

setPostUser

public boolean setPostUser(java.lang.String _userName)
                    throws WCMException
设置递交用户

参数：
_userName - 递交用户的用户名
返回：
抛出：
WCMException

setPostUser

public boolean setPostUser(User _postUser)
                    throws WCMException
设置递交用户

参数：
_postUser - 递交用户对象
返回：
抛出：
WCMException

getPostTime

public CMyDateTime getPostTime()
获取递交时间

返回：
递交时间

setPostTime

public boolean setPostTime(CMyDateTime _postTime)
                    throws WCMException
设置递交时间

参数：
_postTime - 递交时间
返回：
抛出：
WCMException

getPostDesc

public java.lang.String getPostDesc()
获取递交说明

返回：
递交说明

setPostDesc

public boolean setPostDesc(java.lang.String _desc)
                    throws WCMException
设置递交说明

参数：
_desc - 递交说明
返回：
抛出：
WCMException

getToUserIds

public java.lang.String getToUserIds()
获取所有呈送人员ID字符串（不同ID之间移字符','分割）

返回：
所有呈送人员ID字符串（不同ID之间移字符','分割）
抛出：
WCMException

getToUsers

public Users getToUsers(User _currUser)
                 throws WCMException
获取所有呈送人员集合

参数：
_currUser - 当前操作用户
返回：
所有呈送人员集合
抛出：
WCMException

setToUsers

public boolean setToUsers(java.lang.String _userIds)
                   throws WCMException
设置呈送人员

参数：
_userIds - 所有呈送人员ID字符串（不同ID之间移字符','分割）
返回：
抛出：
WCMException

addToUser

public boolean addToUser(int _userId)
                  throws WCMException
添加呈送人员

参数：
_userId - 呈送人员ID
返回：
抛出：
WCMException

addToUser

public boolean addToUser(User _user)
                  throws WCMException
添加呈送人员

参数：
_user - 呈送人员对象
返回：
抛出：
WCMException

getPreNodeId

public int getPreNodeId()
获取前一个节点ID

返回：
前一个节点ID

getPreNode

public FlowNode getPreNode()
                    throws WCMException
获取前一个节点

返回：
前一个节点
抛出：
WCMException

setPreNode

public boolean setPreNode(int _nodeId)
                   throws WCMException
设置前一个节点

参数：
_nodeId - 前一个节点ID
返回：
抛出：
WCMException

setPreNode

public boolean setPreNode(FlowNode _flowNode)
                   throws WCMException
设置前一个节点

参数：
_flowNode - 前一个节点对象
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
实现父类的isValid函数，进行数据的效验

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 1、新增模式下没有设置所属文档、所属节点将会引起异常
另请参见：
CMSObj.isValid()

insert

public void insert(User _currUser)
            throws WCMException
重载父类的insert函数，以便设置产生时间

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException
另请参见：
CMSObj.insert( User _currUser )

getPrevious

public FlowDoc getPrevious(User _currUser,
                           boolean _bGoBack)
                    throws WCMException
取前一个流转经过的FlowDoc对象 Sample: A->B->C，然后两次打回 C->B->A，在B处打回时需要将参数_bGoBack置为true

参数：
_currUser - 当前操作用户
_bGoBack - 是否为返回处理；用于文档打回后，再次打回时取得前一次流转路线时用
返回：
抛出：
WCMException

getBranchComeFrom

public FlowNodeBranch getBranchComeFrom(User _currUser)
                                 throws WCMException
获取文档流转到当前状态经过的分支

参数：
_currUser - 当前操作用户
返回：
若为打回的，则返回null
抛出：
WCMException

isReceived

public boolean isReceived()
是否已经接收到

返回：

setReceiveTime

public boolean setReceiveTime()
                       throws WCMException
使用当前时间设置接收时间

返回：
抛出：
WCMException

getReceiveTime

public CMyDateTime getReceiveTime()
返回：
抛出：
WCMException

setAcceptTime

public boolean setAcceptTime()
                      throws WCMException
使用当前时间设置确认处理时间

返回：
抛出：
WCMException

getAcceptTime

public CMyDateTime getAcceptTime()
返回：
抛出：
WCMException

isAccepted

public boolean isAccepted()
用户是否已经签收

返回：

setAccepted

public boolean setAccepted()
                    throws WCMException
设置签收

返回：
抛出：
WCMException

findById

public static final FlowDoc findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FlowDoc createNewInstance()
                                       throws WCMException
产生当前对象[FlowDoc]的实例

返回：
当前对象的实例[FlowDoc]
抛出：
WCMException

findByKey

public static final FlowDoc findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

setContent

public boolean setContent(int contentType,
                          int contentId)
                   throws WCMException
设置相关内容

参数：
contentType -
contentId -
返回：
抛出：
WCMException

getChildren

public FlowDocs getChildren(User _currUser,
                            WCMFilter _filter)
                     throws WCMException
获取当前轨迹的子轨迹列表

参数：
_currUser -
_filter -
返回：
抛出：
WCMException

setContent

public void setContent(IFlowContent flowContent)
                throws WCMException
设置相关内容

参数：
flowContent -
抛出：
WCMException

setPreFlowDoc

public boolean setPreFlowDoc(FlowDoc currFlowDoc)
                      throws WCMException
设置前一个轨迹

参数：
currFlowDoc -
返回：
抛出：
WCMException

getSerialNum

public long getSerialNum()
返回：

setSerialNum

public boolean setSerialNum(long _lSerialNum)
                     throws WCMException
参数：
_lSerialNum -
返回：
抛出：
WCMException

getBranchSerialNum

public long getBranchSerialNum()
返回：

setBranchSerialNum

public boolean setBranchSerialNum(long _lSerialNum)
                           throws WCMException
参数：
_lSerialNum -
返回：
抛出：
WCMException

getToUserTrueNames

public java.lang.String getToUserTrueNames()
                                    throws WCMException
添加了返回toUser的真实姓名的方法

参数：
_flowDoc -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowDocBak

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowDocBak

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.cms.process.engine.FlowDoc
                继承者  com.trs.cms.process.engine.FlowDocBak
所有已实现的接口：
java.lang.Cloneable
public class FlowDocBak
extends FlowDoc

Title: TRS 内容协作平台（TRS WCM） Description: 文档流转对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
FlowDocBak()
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
FlowDoc | getPrevious(User _currUser, boolean _bGoBack) 该方法与其父类中的同签名方法的行为定义有所不同。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
从类 com.trs.cms.process.engine.FlowDoc 继承的方法
addToUser, addToUser, createNewInstance, findById, findByKey, getAcceptTime, getBranchComeFrom, getBranchSerialNum, getChildren, getContentId, getContentType, getFlag, getFlagDesc, getFlowContent, getNode, getNodeId, getParent, getParentId, getPostDesc, getPostTime, getPostUser, getPostUserName, getPostUserTrueName, getPreFlowDoc, getPreFlowDocId, getPreNode, getPreNodeId, getRealPostUserNames, getReceiveTime, getSerialNum, getToUser, getToUserId, getToUserIds, getToUserNames, getToUsers, getToUserTrueNames, getWorkModal, getWorkModalDesc, insert, isAccepted, isReceived, isValid, isWorked, setAccepted, setAcceptTime, setBranchSerialNum, setContent, setContent, setContentId, setContentType, setFlag, setFlowContent, setFlowContent, setNode, setNode, setParent, setPostDesc, setPostTime, setPostUser, setPostUser, setPreFlowDoc, setPreFlowDoc, setPreNode, setPreNode, setReceiveTime, setSerialNum, setToUser, setToUser, setToUsers, setWorked, setWorkModal
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FlowDocBak

public FlowDocBak()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

覆盖：
类 FlowDoc 中的 getDbTableName
返回：
另请参见：
BaseObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

覆盖：
类 FlowDoc 中的 getIdFieldName
返回：
Id字段名
另请参见：
BaseObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

覆盖：
类 FlowDoc 中的 getWCMType
返回：
整型类型数
另请参见：
BaseObj.getWCMType()

getPrevious

public FlowDoc getPrevious(User _currUser,
                           boolean _bGoBack)
                    throws WCMException
该方法与其父类中的同签名方法的行为定义有所不同。 父类中的 getPrevious(User, boolean)方法返回的是正向流经转时到达该节点的前一个 FlowDoc对象，以正确处理打回再打回的情形。 该方法返回的只是前一个FlowDoc 对象，而不关心其是否正向流转。

覆盖：
类 FlowDoc 中的 getPrevious
参数：
_currUser - 当前操作用户
_bGoBack - 是否为返回处理；用于文档打回后，再次打回时取得前一次流转路线时用
返回：
抛出：
WCMException
另请参见：
FlowDoc.getPrevious(com.trs.cms.auth.persistent.User, boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowDocBaks

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowDocBaks

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.engine.FlowDocs
                继承者  com.trs.cms.process.engine.FlowDocBaks

public class FlowDocBaks
extends FlowDocs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowDocBaks(User _currUser)
FlowDocBaks(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.process.engine.FlowDocs 继承的方法
createNewInstance, findByIds, findByIdsOfDealer, findByIdsOfPoster, findOfContent, openWCMObjs
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowDocBaks

public FlowDocBaks(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

FlowDocBaks

public FlowDocBaks(User _currUser,
                   int initialCapacity,
                   int capacityIncrement)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

覆盖：
类 FlowDocs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

覆盖：
类 FlowDocs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

覆盖：
类 FlowDocs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowDocs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowDocs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.cms.process.engine.FlowDocs
直接已知子类：
FlowDocBaks
public class FlowDocs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FlowDocs(User _currUser)
FlowDocs(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static FlowDocs | createNewInstance(User _currUser) 产生当前集合对象[FlowDocs]的实例
static FlowDocs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowDocs | findByIdsOfDealer(User _currUser, java.lang.String _sIds, User _dealer) 根据处理者或者与其相关的FlowDocs
static FlowDocs | findByIdsOfPoster(User _currUser, java.lang.String _sIds, User _poster)
static FlowDocs | findOfContent(User _currUser, int _nContentType, int _nContentId, WCMFilter _extraFilter) 获取与指定内容相关的轨迹
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static FlowDocs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowDocs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowDocs

public FlowDocs(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

FlowDocs

public FlowDocs(User _currUser,
                int initialCapacity,
                int capacityIncrement)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final FlowDocs findByIds(User _currUser,
                                       java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FlowDocs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByIdsOfDealer

public static final FlowDocs findByIdsOfDealer(User _currUser,
                                               java.lang.String _sIds,
                                               User _dealer)
                                        throws WCMException
根据处理者或者与其相关的FlowDocs

参数：
_currUser -
_sIds -
_dealer -
返回：
抛出：
WCMException

findByIdsOfPoster

public static final FlowDocs findByIdsOfPoster(User _currUser,
                                               java.lang.String _sIds,
                                               User _poster)
                                        throws WCMException
抛出：
WCMException

findOfContent

public static final FlowDocs findOfContent(User _currUser,
                                           int _nContentType,
                                           int _nContentId,
                                           WCMFilter _extraFilter)
                                    throws WCMException
获取与指定内容相关的轨迹

参数：
_currUser -
_nContentType -
_nContentId -
_extraFilter -
返回：
抛出：
WCMException

openWCMObjs

public static final FlowDocs openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[FlowDocs]

参数：
_filter - 指定的Filter
返回：
当前集合[FlowDocs]
抛出：
WCMException

createNewInstance

public static FlowDocs createNewInstance(User _currUser)
产生当前集合对象[FlowDocs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNextBranchInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowNextBranchInfo

java.lang.Object
    继承者  com.trs.cms.process.engine.FlowNextBranchInfo

public class FlowNextBranchInfo
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
描述下一个节点
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowNextBranchInfo(User _currUser, FlowDoc _currFlowDoc, int _nNextNodeId, boolean _bResubmit)
方法摘要
Status | getChangeStatus()
FlowContext | getCurrFlowContext()
Group | getGroupRange()
java.lang.String | getNotifyTypes()
Users | getToUsers()
Users | getUsersPassed()
boolean | isResubmit()
void | setChangeStatus(Status changeStatus)
void | setCurrFlowContext(FlowContext currFlowContext)
void | setGroupRange(Group groupRange)
void | setNotifyTypes(java.lang.String notifyTypes)
void | setResubmit(boolean resubmit)
void | setToUsers(Users toUsers)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowNextBranchInfo

public FlowNextBranchInfo(User _currUser,
                          FlowDoc _currFlowDoc,
                          int _nNextNodeId,
                          boolean _bResubmit)
                   throws WCMException
抛出：
WCMException
方法详细信息

getChangeStatus

public Status getChangeStatus()
返回：

setChangeStatus

public void setChangeStatus(Status changeStatus)
参数：
changeStatus -

getToUsers

public Users getToUsers()
返回：

setToUsers

public void setToUsers(Users toUsers)
参数：
toUsers -

getNotifyTypes

public java.lang.String getNotifyTypes()
返回：

setNotifyTypes

public void setNotifyTypes(java.lang.String notifyTypes)
参数：
notifyTypes -

getUsersPassed

public Users getUsersPassed()
返回：

getCurrFlowContext

public FlowContext getCurrFlowContext()
                               throws WCMException
返回：
抛出：
WCMException

setCurrFlowContext

public void setCurrFlowContext(FlowContext currFlowContext)
参数：
currFlowContext -

isResubmit

public boolean isResubmit()
返回：

setResubmit

public void setResubmit(boolean resubmit)
参数：
resubmit -

getGroupRange

public Group getGroupRange()

setGroupRange

public void setGroupRange(Group groupRange)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNodeLCListenerForForceEnd

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowNodeLCListenerForForceEnd

java.lang.Object
    继承者  com.trs.cms.process.engine.FlowNodeLCListenerForForceEnd
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class FlowNodeLCListenerForForceEnd
extends java.lang.Object
implements IObjectLCListenerOnDel

监听工作流节点的删除

作者：
Martin (付成睿)

构造方法摘要
FlowNodeLCListenerForForceEnd()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowNodeLCListenerForForceEnd

public FlowNodeLCListenerForForceEnd()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowParamers

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowParamers

java.lang.Object
    继承者  com.trs.cms.process.engine.FlowParamers

public class FlowParamers
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
内容流转时的参数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowParamers()
方法摘要
FlowNodeBranch | getBranch()
FlowDoc | getCurrFlowDoc()
int | getDirection() 返回流转方向，只有两种可能：前向或者打回
IFlowContent | getFlowContent()
FlowNode | getNextNode()
int | getNotifyType()
java.lang.String | getOpinion()
User | getPostUser()
FlowNode | getPreNode()
Users | getToUsers()
void | setCurrFlowDoc(FlowDoc currFlowDoc)
void | setDirection(int iDirect) 设置流转方向
void | setFlowContent(IFlowContent flowContent)
void | setFlowContent(int _nContentType, int _nContentId)
void | setNextNode(FlowNode nextNode)
void | setNextNode(int _nNextNodeId)
void | setNotifyType(int _nNotifyType)
void | setOpinion(java.lang.String opinion)
void | setPostUser(User postUser)
void | setPreNode(FlowNode preNode)
void | setPreNode(int _nPreNodeId)
void | setToUsers(java.lang.String _sUserIds)
void | setToUsers(Users users)
void | validate()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowParamers

public FlowParamers()
方法详细信息

getFlowContent

public IFlowContent getFlowContent()
返回：

setFlowContent

public void setFlowContent(IFlowContent flowContent)
                    throws WCMException
参数：
flowContent -
抛出：
WCMException

setFlowContent

public void setFlowContent(int _nContentType,
                           int _nContentId)
                    throws WCMException
抛出：
WCMException

getNextNode

public FlowNode getNextNode()
返回：

setNextNode

public void setNextNode(FlowNode nextNode)
                 throws WCMException
参数：
nextNode -
抛出：
WCMException

setNextNode

public void setNextNode(int _nNextNodeId)
                 throws WCMException
抛出：
WCMException

getPreNode

public FlowNode getPreNode()
返回：

setPreNode

public void setPreNode(FlowNode preNode)
                throws WCMException
参数：
preNode -
抛出：
WCMException

setPreNode

public void setPreNode(int _nPreNodeId)
                throws WCMException
抛出：
WCMException

getDirection

public int getDirection()
返回流转方向，只有两种可能：前向或者打回

setDirection

public void setDirection(int iDirect)
设置流转方向

参数：
iDirect - 流转方向，只接受两种可能：前向或者打回，其他值将被忽略

getToUsers

public Users getToUsers()
返回：

setToUsers

public void setToUsers(Users users)
参数：
users -

setToUsers

public void setToUsers(java.lang.String _sUserIds)
                throws WCMException
抛出：
WCMException

getNotifyType

public int getNotifyType()
返回：

setNotifyType

public void setNotifyType(int _nNotifyType)
参数：
_nNotifyType -

getOpinion

public java.lang.String getOpinion()
返回：

setOpinion

public void setOpinion(java.lang.String opinion)
参数：
opinion -

getPostUser

public User getPostUser()
返回：

setPostUser

public void setPostUser(User postUser)
参数：
postUser -

validate

public void validate()
              throws WCMException
抛出：
WCMException

getBranch

public FlowNodeBranch getBranch()
                         throws WCMException
返回：
抛出：
WCMException

getCurrFlowDoc

public FlowDoc getCurrFlowDoc()
返回：

setCurrFlowDoc

public void setCurrFlowDoc(FlowDoc currFlowDoc)
参数：
currFlowDoc -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowUserHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 FlowUserHelper

java.lang.Object
    继承者  com.trs.cms.process.engine.FlowUserHelper

public class FlowUserHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流用户相关解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowUserHelper()
方法摘要
static Users | getDeptMgrsByGrpIds(java.lang.String _sGroupIds) 获取指定部门的部门经理(管理员)
static Users | getDeptMgrsByGrpName(java.lang.String _sGroupName) 获取指定部门的部门经理(管理员)
static Users | getDeptMgrsOfUserx(User _user) 获取用户所属部门的部门经理(管理员)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowUserHelper

public FlowUserHelper()
方法详细信息

getDeptMgrsOfUserx

public static Users getDeptMgrsOfUserx(User _user)
                                throws WCMException
获取用户所属部门的部门经理(管理员)

参数：
_user -
返回：
抛出：
WCMException

getDeptMgrsByGrpName

public static Users getDeptMgrsByGrpName(java.lang.String _sGroupName)
                                  throws WCMException
获取指定部门的部门经理(管理员)

参数：
_sGroupName - 指定部门的名称
返回：
抛出：
WCMException

getDeptMgrsByGrpIds

public static Users getDeptMgrsByGrpIds(java.lang.String _sGroupIds)
                                 throws WCMException
获取指定部门的部门经理(管理员)

参数：
_sGroupIds - 指定部门的ID序列
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IActionHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
接口 IActionHandler

所有已知实现类：
ApplyFormReplyHandler, ApplyFormTypeHandler, AutoFillApplyFormHandler, AutoToNextHandler, MsgSendHandler, PublishContentActionHandler, ReplyAppendixNotifyHandler, ReplyNotifyHandler, SendEmailForInfoViewHandler
public interface IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
触发的操作处理器接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 boolean execute(ExecuteContext _context, FlowAction _action)

方法详细信息

execute

boolean execute(ExecuteContext _context,
                FlowAction _action)
                throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IConditionHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
接口 IConditionHandler

所有已知实现类：
ContentPropertyHandler, OverTimeHandler
public interface IConditionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
条件处理器接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 boolean isAccordWith(ExecuteContext _context, FlowCondition _condition)
是否与设定的条件相符合?

方法详细信息

isAccordWith

boolean isAccordWith(ExecuteContext _context,
                     FlowCondition _condition)
                     throws WCMException
是否与设定的条件相符合?

参数：
_context - 工作流驱动过程中上下文对象
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IInitValueCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
接口 IInitValueCreator

所有已知实现类：
CurrentDateCreator, CurrentDocStatusCreator, CurrentTimeCreator, CurrentUserNameCreator, PostUserNameCreator
public interface IInitValueCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 java.lang.String createInitValue(FlowContext _oFlowContext)
根据当前上下文信息产生初始值

方法详细信息

createInitValue

java.lang.String createInitValue(FlowContext _oFlowContext)
                                 throws WCMException
根据当前上下文信息产生初始值

参数：
_oFlowContext -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IToUsersCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
接口 IToUsersCreator

所有已知实现类：
AbstractToUsersCreator, ApplyFormToUsersCreator, CrUserAsToUsersCreator, DeptMgrAsToUsersCreator, GroupAdminsAsToUsersCreator, GroupAdminsFromChnlAsToUsersCreator, GroupAdminsFromFlowAsToUsersCreator, GroupAdminsFromSupportPartAsToUsersCreator, GroupMembersAsToUsersCreator, LawGovTousersCreator, RoleAsToUsersCreator
public interface IToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
处理人产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
Users | createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig) 根据当前上下文信息产生处理者信息
Group | getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig) 限定了用户选择范围（在特定组内选择）
boolean | isRangedFromGroup() 指定是否需要从特定组内选择

方法详细信息

createToUsers

Users createToUsers(FlowContext _oFlowContext,
                    ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
根据当前上下文信息产生处理者信息

参数：
_oFlowContext -
_oCreatorConfig - TODO
返回：
抛出：
WCMException

isRangedFromGroup

boolean isRangedFromGroup()
指定是否需要从特定组内选择

返回：

getGroupRange

Group getGroupRange(FlowContext _context,
                    ToUsersCreatorConfig _creatorConfig)
                    throws WCMException
限定了用户选择范围（在特定组内选择）

参数：
_context -
_creatorConfig -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.process.engine
接口
IActionHandler
IConditionHandler
IInitValueCreator
IToUsersCreator
类
AbstractToUsersCreator
ContentProcessInfo
ExecuteContext
FlowContentConfig
FlowContentConfigs
FlowContentHelper
FlowContentLCListener
FlowContext
FlowContextOld
FlowDoc
FlowDocBak
FlowDocBaks
FlowDocs
FlowNextBranchInfo
FlowNodeLCListenerForForceEnd
FlowParamers
FlowUserHelper
RuleExecuteHelper


com.trs.cms.process.engine

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.process.engine

接口摘要
IActionHandler | Title: TRS 内容协作平台（TRS WCM） Description: 触发的操作处理器接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IConditionHandler | Title: TRS 内容协作平台（TRS WCM） Description: 条件处理器接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IInitValueCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IToUsersCreator | Title: TRS 内容协作平台（TRS WCM） Description: 处理人产生器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
AbstractToUsersCreator | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentProcessInfo | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ExecuteContext | Title: TRS 内容协作平台（TRS WCM） Description: 工作流在驱动过程中上下文对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentConfig |
FlowContentConfigs |
FlowContentHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn) comment@2008-06-12 createFlowContent替换为新的实现
FlowContentLCListener | Title: TRS 内容协作平台（TRS WCM） Description: Flow Content生命周期监听器,只监听删除前 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContext | Title: TRS 内容协作平台（TRS WCM） Description: 工作流驱动过程上下文对象 Copyright: Copyright (c) 2004-2007 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContextOld |
FlowDoc |
FlowDocBak | Title: TRS 内容协作平台（TRS WCM） Description: 文档流转对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowDocBaks |
FlowDocs |
FlowNextBranchInfo | Title: TRS 内容协作平台（TRS WCM） Description: 描述下一个节点 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowNodeLCListenerForForceEnd | 监听工作流节点的删除
FlowParamers | Title: TRS 内容协作平台（TRS WCM） Description: 内容流转时的参数 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowUserHelper | Title: TRS 内容协作平台（TRS WCM） Description: 工作流用户相关解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RuleExecuteHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.cms.process.engine 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.engine 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.process.engine.AbstractToUsersCreator (implements com.trs.cms.process.engine.IToUsersCreator)
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.cms.process.engine.FlowContentConfig
        • com.trs.cms.process.engine.FlowDoc
          • com.trs.cms.process.engine.FlowDocBak
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.cms.process.engine.FlowContentConfigs
        • com.trs.cms.process.engine.FlowDocs
          • com.trs.cms.process.engine.FlowDocBaks
    • com.trs.cms.process.engine.ContentProcessInfo
    • com.trs.cms.process.engine.ExecuteContext
    • com.trs.cms.process.engine.FlowContentHelper
    • com.trs.cms.process.engine.FlowContentLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.cms.process.engine.FlowContext
    • com.trs.cms.process.engine.FlowContextOld
    • com.trs.cms.process.engine.FlowNextBranchInfo
    • com.trs.cms.process.engine.FlowNodeLCListenerForForceEnd (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.cms.process.engine.FlowParamers
    • com.trs.cms.process.engine.FlowUserHelper
    • com.trs.cms.process.engine.RuleExecuteHelper

接口分层结构

  • com.trs.cms.process.engine.IActionHandler
  • com.trs.cms.process.engine.IConditionHandler
  • com.trs.cms.process.engine.IInitValueCreator
  • com.trs.cms.process.engine.IToUsersCreator


软件包 com.trs.cms.process.engine 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.engine
的使用

使用 com.trs.cms.process.engine 的软件包
com.trs.ajaxservice
com.trs.cms.process
com.trs.cms.process.config
com.trs.cms.process.engine
com.trs.cms.process.engine.creators
com.trs.cms.process.engine.handlers
com.trs.components.gkml.sqgk.process.element
com.trs.components.gkml.sqgk.process.engine.creators
com.trs.components.gkml.sqgk.process.engine.handlers
com.trs.components.infoview.process
com.trs.components.wcm.process.element
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 使用的 com.trs.cms.process.engine 中的类
ContentProcessInfo
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowDocs

com.trs.cms.process 使用的 com.trs.cms.process.engine 中的类
ContentProcessInfo
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流驱动过程上下文对象
Copyright: Copyright (c) 2004-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowDoc
FlowDocs
FlowParamers
Title: TRS 内容协作平台（TRS WCM）
Description:
内容流转时的参数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.config 使用的 com.trs.cms.process.engine 中的类
FlowContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流驱动过程上下文对象
Copyright: Copyright (c) 2004-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine 使用的 com.trs.cms.process.engine 中的类
ExecuteContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流在驱动过程中上下文对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentConfig
FlowContentConfigs
FlowContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流驱动过程上下文对象
Copyright: Copyright (c) 2004-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowDoc
FlowDocs
IToUsersCreator
Title: TRS 内容协作平台（TRS WCM）
Description:
处理人产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine.creators 使用的 com.trs.cms.process.engine 中的类
AbstractToUsersCreator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流驱动过程上下文对象
Copyright: Copyright (c) 2004-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInitValueCreator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IToUsersCreator
Title: TRS 内容协作平台（TRS WCM）
Description:
处理人产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine.handlers 使用的 com.trs.cms.process.engine 中的类
ExecuteContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流在驱动过程中上下文对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IActionHandler
Title: TRS 内容协作平台（TRS WCM）
Description:
触发的操作处理器接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IConditionHandler
Title: TRS 内容协作平台（TRS WCM）
Description:
条件处理器接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.cms.process.engine 中的类
FlowDoc

com.trs.components.gkml.sqgk.process.engine.creators 使用的 com.trs.cms.process.engine 中的类
AbstractToUsersCreator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流驱动过程上下文对象
Copyright: Copyright (c) 2004-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IToUsersCreator
Title: TRS 内容协作平台（TRS WCM）
Description:
处理人产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.engine.handlers 使用的 com.trs.cms.process.engine 中的类
ExecuteContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流在驱动过程中上下文对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IActionHandler
Title: TRS 内容协作平台（TRS WCM）
Description:
触发的操作处理器接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.process 使用的 com.trs.cms.process.engine 中的类
ExecuteContext
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流在驱动过程中上下文对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IActionHandler
Title: TRS 内容协作平台（TRS WCM）
Description:
触发的操作处理器接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process.element 使用的 com.trs.cms.process.engine 中的类
FlowDoc

com.trs.service 使用的 com.trs.cms.process.engine 中的类
FlowDoc
FlowDocs
FlowParamers
Title: TRS 内容协作平台（TRS WCM）
Description:
内容流转时的参数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service.impl 使用的 com.trs.cms.process.engine 中的类
FlowDoc
FlowDocs
FlowParamers
Title: TRS 内容协作平台（TRS WCM）
Description:
内容流转时的参数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RuleExecuteHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine
类 RuleExecuteHelper

java.lang.Object
    继承者  com.trs.cms.process.engine.RuleExecuteHelper

public class RuleExecuteHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RuleExecuteHelper()
方法摘要
static void executeRules(ExecuteContext _oExecContext, FlowRule[] _pRules)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RuleExecuteHelper

public RuleExecuteHelper()
方法详细信息

executeRules

public static void executeRules(ExecuteContext _oExecContext,
                                FlowRule[] _pRules)
                         throws WCMException
参数：
_oExecContext -
_pRules -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.process.engine.AbstractToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.AbstractToUsersCreator
的使用

使用 AbstractToUsersCreator 的软件包
com.trs.cms.process.engine.creators
com.trs.components.gkml.sqgk.process.engine.creators

com.trs.cms.process.engine.creators 中 AbstractToUsersCreator 的使用

com.trs.cms.process.engine.creators 中 AbstractToUsersCreator 的子类
class | CrUserAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DeptMgrAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsFromChnlAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: 根据频道名获取跟其名称一样的组织的管理员 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsFromFlowAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsFromSupportPartAsToUsersCreator
class | GroupMembersAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleAsToUsersCreator

com.trs.components.gkml.sqgk.process.engine.creators 中 AbstractToUsersCreator 的使用

com.trs.components.gkml.sqgk.process.engine.creators 中 AbstractToUsersCreator 的子类
class | ApplyFormToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | LawGovTousersCreator Title: TRS 内容协作平台（TRS WCM） Description: 法制办审核人构造器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.ContentProcessInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.ContentProcessInfo
的使用

使用 ContentProcessInfo 的软件包
com.trs.ajaxservice
com.trs.cms.process

com.trs.ajaxservice 中 ContentProcessInfo 的使用

返回 ContentProcessInfo 的 com.trs.ajaxservice 中的方法
 ContentProcessInfo ProcessService.getProcessInfoOfContent(MethodContext _methodContext)
获取指定内容的流转信息（是否已经结束、发起人）

com.trs.cms.process 中 ContentProcessInfo 的使用

返回 ContentProcessInfo 的 com.trs.cms.process 中的方法
ContentProcessInfo | FlowServerImpl.getProcessInfoOfContent(IFlowContent _content)
ContentProcessInfo | IFlowServer.getProcessInfoOfContent(IFlowContent _content) 获取指定内容的流转情况

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.ExecuteContext 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.ExecuteContext
的使用

使用 ExecuteContext 的软件包
com.trs.cms.process.engine
com.trs.cms.process.engine.handlers
com.trs.components.gkml.sqgk.process.engine.handlers
com.trs.components.infoview.process

com.trs.cms.process.engine 中 ExecuteContext 的使用

参数类型为 ExecuteContext 的 com.trs.cms.process.engine 中的方法
boolean | IActionHandler.execute(ExecuteContext _context, FlowAction _action)
static void | RuleExecuteHelper.executeRules(ExecuteContext _oExecContext, FlowRule[] _pRules)
boolean | IConditionHandler.isAccordWith(ExecuteContext _context, FlowCondition _condition) 是否与设定的条件相符合?

com.trs.cms.process.engine.handlers 中 ExecuteContext 的使用

参数类型为 ExecuteContext 的 com.trs.cms.process.engine.handlers 中的方法
java.lang.String | MsgSendHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
boolean | MsgSendHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | PublishContentActionHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | AutoToNextHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | OverTimeHandler.isAccordWith(ExecuteContext _context, FlowCondition _condition)
boolean | ContentPropertyHandler.isAccordWith(ExecuteContext _context, FlowCondition _condition)

com.trs.components.gkml.sqgk.process.engine.handlers 中 ExecuteContext 的使用

参数类型为 ExecuteContext 的 com.trs.components.gkml.sqgk.process.engine.handlers 中的方法
java.lang.String | ReplyNotifyHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
java.lang.String | ReplyAppendixNotifyHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
java.lang.String | ApplyFormTypeHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
java.lang.String | ApplyFormReplyHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
boolean | ReplyNotifyHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | ReplyAppendixNotifyHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | AutoFillApplyFormHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | ApplyFormTypeHandler.execute(ExecuteContext _context, FlowAction _action)
boolean | ApplyFormReplyHandler.execute(ExecuteContext _context, FlowAction _action)

com.trs.components.infoview.process 中 ExecuteContext 的使用

参数类型为 ExecuteContext 的 com.trs.components.infoview.process 中的方法
 boolean SendEmailForInfoViewHandler.execute(ExecuteContext _context, FlowAction _action)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowContentConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowContentConfig
的使用

使用 FlowContentConfig 的软件包
com.trs.cms.process.engine

com.trs.cms.process.engine 中 FlowContentConfig 的使用

返回 FlowContentConfig 的 com.trs.cms.process.engine 中的方法
static FlowContentConfig | FlowContentConfig.createNewInstance() 产生当前对象[FlowContentConfig]的实例
static FlowContentConfig | FlowContentConfig.findById(int _nId) 提取指定ID的对象
static FlowContentConfig | FlowContentConfig.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowContentConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowContentConfigs
的使用

使用 FlowContentConfigs 的软件包
com.trs.cms.process.engine

com.trs.cms.process.engine 中 FlowContentConfigs 的使用

返回 FlowContentConfigs 的 com.trs.cms.process.engine 中的方法
static FlowContentConfigs | FlowContentConfigs.createNewInstance(User _currUser) 产生当前集合对象[FlowContentConfigs]的实例
static FlowContentConfigs | FlowContentConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowContentConfigs | FlowContentConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowContentConfigs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowContentHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowContentHelper
的使用

没有 com.trs.cms.process.engine.FlowContentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowContentLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowContentLCListener
的使用

没有 com.trs.cms.process.engine.FlowContentLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowContext 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowContext
的使用

使用 FlowContext 的软件包
com.trs.cms.process
com.trs.cms.process.config
com.trs.cms.process.engine
com.trs.cms.process.engine.creators
com.trs.components.gkml.sqgk.process.engine.creators

com.trs.cms.process 中 FlowContext 的使用

参数类型为 FlowContext 的 com.trs.cms.process 中的方法
FlowDoc | FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode)
FlowDoc | IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode) 自动将当前轨迹呈送到下一个节点
FlowDoc | FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers)
FlowDoc | IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers) 自动将当前轨迹呈送到下一个节点
boolean | FlowServerImpl.backTo(FlowContext _oFlowContext)
boolean | IFlowServer.backTo(FlowContext _oFlowContext) 要求返工
boolean | FlowServerImpl.doAccept(FlowContext _oFlowContext)
boolean | IFlowServer.doAccept(FlowContext _oFlowContext) 签收
boolean | FlowServerImpl.doReceive(FlowContext _oFlowContext)
boolean | IFlowServer.doReceive(FlowContext _oFlowContext) 接收
boolean | FlowServerImpl.forceEnd(FlowContext _oFlowContext)
boolean | IFlowServer.forceEnd(FlowContext _oFlowContext) 强制结束
static void | FlowingDocLogger.info(FlowContext _context, java.lang.String _sActionDesc)
boolean | FlowServerImpl.refuse(FlowContext _oFlowContext)
boolean | IFlowServer.refuse(FlowContext _oFlowContext) 拒绝
boolean | FlowServerImpl.resubmitTo(FlowContext _oFlowContext)
boolean | IFlowServer.resubmitTo(FlowContext _oFlowContext) 重新指派
boolean | FlowServerImpl.submitTo(FlowContext _context)
boolean | IFlowServer.submitTo(FlowContext _oFlowContext) 处理内容
static void | FlowingDocOptMarkScouter.updateOperationMark(FlowContext _context)
static void | FlowingDocOptMarkScouter.updateOperationMark(FlowContext _context, java.lang.String _sPreOptValue)
static void | FlowingDocOptMarkScouter.updatePreOperationMark(FlowContext _context, java.lang.String _sPreOptValue)

com.trs.cms.process.config 中 FlowContext 的使用

参数类型为 FlowContext 的 com.trs.cms.process.config 中的方法
Group | ToUsersCreatorConfig.getGroupRange(FlowContext _context)
Users | ToUsersCreatorConfig.getToUsers(FlowContext _context) 根据当前的配置获取处理者

com.trs.cms.process.engine 中 FlowContext 的使用

返回 FlowContext 的 com.trs.cms.process.engine 中的方法
FlowContext | FlowNextBranchInfo.getCurrFlowContext()
FlowContext | ExecuteContext.getFlowContext()

参数类型为 FlowContext 的 com.trs.cms.process.engine 中的方法
java.lang.String | IInitValueCreator.createInitValue(FlowContext _oFlowContext) 根据当前上下文信息产生初始值
Users | IToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig) 根据当前上下文信息产生处理者信息
Group | AbstractToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)
Group | IToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig) 限定了用户选择范围（在特定组内选择）
void | FlowNextBranchInfo.setCurrFlowContext(FlowContext currFlowContext)
void | ExecuteContext.setFlowContext(FlowContext flowContext)

参数类型为 FlowContext 的 com.trs.cms.process.engine 中的构造方法
ExecuteContext(FlowContext _oFlowContext)

com.trs.cms.process.engine.creators 中 FlowContext 的使用

参数类型为 FlowContext 的 com.trs.cms.process.engine.creators 中的方法
java.lang.String | CurrentDocStatusCreator.createInitValue(FlowContext flowContext)
java.lang.String | CurrentTimeCreator.createInitValue(FlowContext _oFlowContext)
java.lang.String | PostUserNameCreator.createInitValue(FlowContext _oFlowContext)
java.lang.String | CurrentDateCreator.createInitValue(FlowContext _oFlowContext)
java.lang.String | CurrentUserNameCreator.createInitValue(FlowContext _oFlowContext)
Users | GroupAdminsFromChnlAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupMembersAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsFromFlowAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | RoleAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | DeptMgrAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | CrUserAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | GroupAdminsFromSupportPartAsToUsersCreator.createToUsers(FlowContext flowContext, ToUsersCreatorConfig _oCreatorConfig)
Group | GroupMembersAsToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)

com.trs.components.gkml.sqgk.process.engine.creators 中 FlowContext 的使用

参数类型为 FlowContext 的 com.trs.components.gkml.sqgk.process.engine.creators 中的方法
Users | LawGovTousersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
Users | ApplyFormToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowContextOld 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowContextOld
的使用

没有 com.trs.cms.process.engine.FlowContextOld 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowDoc 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowDoc
的使用

使用 FlowDoc 的软件包
com.trs.cms.process
com.trs.cms.process.engine
com.trs.components.gkml.sqgk.process.element
com.trs.components.wcm.process.element
com.trs.service
com.trs.service.impl

com.trs.cms.process 中 FlowDoc 的使用

返回 FlowDoc 的 com.trs.cms.process 中的方法
FlowDoc | FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode)
FlowDoc | IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode) 自动将当前轨迹呈送到下一个节点
FlowDoc | FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers)
FlowDoc | IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers) 自动将当前轨迹呈送到下一个节点
static FlowDoc | FlowServerImpl.convertToFlowDocNotFlags(FlowDoc _flowDoc, int[] _pFlags)
FlowDoc | IFlowContent.getFlowDoc() 获取FlowContent相关的FlowDoc
FlowDoc | FlowServer.getFlowDoc(IFlowContent _content) 取指定文档对应的FlowDoc对象
FlowDoc | FlowServer.getFlowDoc(int _nObjType, int _nObjId) 取指定文档对应的FlowDoc对象
static FlowDoc | FlowServerImpl.lookupRealBackFlowDocAgain(FlowDoc _flowDoc)
FlowDoc | FlowServer.removeFlowDoc(IFlowContent _doc)
FlowDoc | FlowServer.removeFlowDoc(IFlowContent _doc, User _currUser) 从FlowServer移去指定的FlowDoc对象
FlowDoc | FlowServer.removeFlowDoc(int _nObjType, int _nObjId)
FlowDoc | FlowServer.removeFlowDoc(int _nObjType, int _nObjId, User _currUser) 从FlowServer移去指定的FlowDoc对象
FlowDoc | FlowServer.startContentInFlow(User _currUser, IFlowContent _doc)
FlowDoc | FlowServer.startContentInFlow(User _currUser, IFlowContent _content, java.lang.String _sPostDesc) 为文档对象添加新的FlowDoc对象，使文档进入工作流流转
FlowDoc | FlowServer.submitBack(User _currUser, IFlowContent _doc, java.lang.String _sPostDesc)
FlowDoc | FlowServer.submitBack(User _currUser, IFlowContent _content, java.lang.String _sOpinion, int _nStatusId) 将文档返回到上一个节点，并返回给指定的用户
FlowDoc | FlowServer.submitTo(FlowParamers _currParamers) 按照指定的方式处理文档

参数类型为 FlowDoc 的 com.trs.cms.process 中的方法
static FlowDoc | FlowServerImpl.convertToFlowDocNotFlags(FlowDoc _flowDoc, int[] _pFlags)
FlowNodes | FlowServerImpl.getNextFlowNodes(FlowDoc _currFlowDoc, boolean _bIsResubmit)
FlowNodes | IFlowServer.getNextFlowNodes(FlowDoc _currFlowDoc, boolean _bIsResubmit) 获取当前轨迹的下一个处理节点
static FlowDoc | FlowServerImpl.lookupRealBackFlowDocAgain(FlowDoc _flowDoc)
static java.lang.String | FlowEngineHelper.makeSeperateComments(FlowDoc _currFlowDoc) 产生并联审批结束时后合并的处理意见
static java.lang.String[] | FlowEngineHelper.parseComments(FlowDoc _flowDoc) 解析处理过程中的意见，解析成偶数长度的数组
void | IFlowContent.setFlowDoc(FlowDoc _flowDoc) 设置FlowContent相关的FlowDoc

com.trs.cms.process.engine 中 FlowDoc 的使用

com.trs.cms.process.engine 中 FlowDoc 的子类
 class FlowDocBak
Title: TRS 内容协作平台（TRS WCM） Description: 文档流转对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 FlowDoc 的 com.trs.cms.process.engine 中的方法
static FlowDoc FlowDoc.createNewInstance()
产生当前对象[FlowDoc]的实例
static FlowDoc FlowDoc.findById(int _nId)
提取指定ID的对象
static FlowDoc FlowDoc.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象
 FlowDoc FlowParamers.getCurrFlowDoc()
 FlowDoc ExecuteContext.getCurrFlowDoc()
获取当前相关的工作流轨迹
 FlowDoc FlowContext.getCurrFlowDoc()
 FlowDoc FlowDoc.getParent()
获取事务轨迹
 FlowDoc FlowDoc.getPreFlowDoc()
获取上一次事务轨迹
 FlowDoc FlowDocBak.getPrevious(User _currUser, boolean _bGoBack)
该方法与其父类中的同签名方法的行为定义有所不同。
 FlowDoc FlowDoc.getPrevious(User _currUser, boolean _bGoBack)
取前一个流转经过的FlowDoc对象 Sample: A->B->C，然后两次打回 C->B->A，在B处打回时需要将参数_bGoBack置为true

参数类型为 FlowDoc 的 com.trs.cms.process.engine 中的方法
void | FlowParamers.setCurrFlowDoc(FlowDoc currFlowDoc)
void | FlowContext.setCurrFlowDoc(FlowDoc currFlowDoc)
boolean | FlowDoc.setPreFlowDoc(FlowDoc currFlowDoc) 设置前一个轨迹

参数类型为 FlowDoc 的 com.trs.cms.process.engine 中的构造方法
ExecuteContext(FlowDoc _flowDoc)
FlowNextBranchInfo(User _currUser, FlowDoc _currFlowDoc, int _nNextNodeId, boolean _bResubmit)

com.trs.components.gkml.sqgk.process.element 中 FlowDoc 的使用

返回 FlowDoc 的 com.trs.components.gkml.sqgk.process.element 中的方法
 FlowDoc FlowContentApplyFormImpl.getFlowDoc()

参数类型为 FlowDoc 的 com.trs.components.gkml.sqgk.process.element 中的方法
 void FlowContentApplyFormImpl.setFlowDoc(FlowDoc _flowDoc)

com.trs.components.wcm.process.element 中 FlowDoc 的使用

返回 FlowDoc 的 com.trs.components.wcm.process.element 中的方法
 FlowDoc FlowContentDocumentImpl.getFlowDoc()

参数类型为 FlowDoc 的 com.trs.components.wcm.process.element 中的方法
 void FlowContentDocumentImpl.setFlowDoc(FlowDoc _flowDoc)

com.trs.service 中 FlowDoc 的使用

返回 FlowDoc 的 com.trs.service 中的方法
FlowDoc | IWCMProcessService.getCurrentFlowDoc(int _nContentType, int _nContentId)
FlowDoc | IWCMProcessService.startContentInFlow(int _nContentType, int _nContentId)

com.trs.service.impl 中 FlowDoc 的使用

返回 FlowDoc 的 com.trs.service.impl 中的方法
FlowDoc | WCMProcessServiceImpl.getCurrentFlowDoc(int _nContentType, int _nContentId)
FlowDoc | WCMProcessServiceImpl.startContentInFlow(int _nContentType, int _nContentId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowDocBak 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowDocBak
的使用

没有 com.trs.cms.process.engine.FlowDocBak 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowDocBaks 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowDocBaks
的使用

没有 com.trs.cms.process.engine.FlowDocBaks 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowDocs 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowDocs
的使用

使用 FlowDocs 的软件包
com.trs.ajaxservice
com.trs.cms.process
com.trs.cms.process.engine
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 FlowDocs 的使用

返回 FlowDocs 的 com.trs.ajaxservice 中的方法
 FlowDocs ProcessService.getFlowDocsOfContent(MethodContext _methodContext)
获取指定文档的流转轨迹

com.trs.cms.process 中 FlowDocs 的使用

返回 FlowDocs 的 com.trs.cms.process 中的方法
FlowDocs | FlowServerImpl.getFlowDocs(IFlowContent _content, WCMFilter _extrFilter)
FlowDocs | IFlowServer.getFlowDocs(IFlowContent _content, WCMFilter _extrFilter) 获取指定内容的流转轨迹
FlowDocs | FlowServer.getFlowDocs(User _operator, int _nFlag, WCMFilter _filter)
FlowDocs | FlowServer.getFlowDocsOfContent(int contentType, int contentId)
FlowDocs | FlowServer.getSubmitFlowDocs(User _operator, WCMFilter _filter)

com.trs.cms.process.engine 中 FlowDocs 的使用

com.trs.cms.process.engine 中 FlowDocs 的子类
 class FlowDocBaks

返回 FlowDocs 的 com.trs.cms.process.engine 中的方法
static FlowDocs | FlowDocs.createNewInstance(User _currUser) 产生当前集合对象[FlowDocs]的实例
static FlowDocs | FlowDocs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FlowDocs | FlowDocs.findByIdsOfDealer(User _currUser, java.lang.String _sIds, User _dealer) 根据处理者或者与其相关的FlowDocs
static FlowDocs | FlowDocs.findByIdsOfPoster(User _currUser, java.lang.String _sIds, User _poster)
static FlowDocs | FlowDocs.findOfContent(User _currUser, int _nContentType, int _nContentId, WCMFilter _extraFilter) 获取与指定内容相关的轨迹
FlowDocs | FlowDoc.getChildren(User _currUser, WCMFilter _filter) 获取当前轨迹的子轨迹列表
static FlowDocs | FlowDocs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowDocs]

com.trs.service 中 FlowDocs 的使用

返回 FlowDocs 的 com.trs.service 中的方法
FlowDocs | IWCMProcessService.getFlowDocs(int _nFlag, WCMFilter _filter)
FlowDocs | IWCMProcessService.getFlowDocsOfContent(int _nContentType, int _nContentId) 获取当前内容的所有流转情况
FlowDocs | IWCMProcessService.getSubmitFlowDocs(User _operator, WCMFilter _filter) 获取用户[_operator]已经呈送的信息

com.trs.service.impl 中 FlowDocs 的使用

返回 FlowDocs 的 com.trs.service.impl 中的方法
FlowDocs | WCMProcessServiceImpl.getFlowDocs(int _nFlag, WCMFilter _filter)
FlowDocs | WCMProcessServiceImpl.getFlowDocsOfContent(int _nContentType, int _nContentId)
FlowDocs | WCMProcessServiceImpl.getSubmitFlowDocs(User _operator, WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowNextBranchInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowNextBranchInfo
的使用

没有 com.trs.cms.process.engine.FlowNextBranchInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowNodeLCListenerForForceEnd 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowNodeLCListenerForForceEnd
的使用

没有 com.trs.cms.process.engine.FlowNodeLCListenerForForceEnd 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowParamers 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowParamers
的使用

使用 FlowParamers 的软件包
com.trs.cms.process
com.trs.service
com.trs.service.impl

com.trs.cms.process 中 FlowParamers 的使用

参数类型为 FlowParamers 的 com.trs.cms.process 中的方法
 FlowDoc FlowServer.submitTo(FlowParamers _currParamers)
按照指定的方式处理文档

com.trs.service 中 FlowParamers 的使用

参数类型为 FlowParamers 的 com.trs.service 中的方法
 void IWCMProcessService.submitTo(FlowParamers _currParamerts)
将内容按照指定的方式呈送

com.trs.service.impl 中 FlowParamers 的使用

参数类型为 FlowParamers 的 com.trs.service.impl 中的方法
 void WCMProcessServiceImpl.submitTo(FlowParamers _currParamerts)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.FlowUserHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.FlowUserHelper
的使用

没有 com.trs.cms.process.engine.FlowUserHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.engine.IActionHandler 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.engine.IActionHandler
的使用

使用 IActionHandler 的软件包
com.trs.cms.process.engine.handlers
com.trs.components.gkml.sqgk.process.engine.handlers
com.trs.components.infoview.process

com.trs.cms.process.engine.handlers 中 IActionHandler 的使用

实现 IActionHandler 的 com.trs.cms.process.engine.handlers 中的类
class | AutoToNextHandler Title: TRS 内容协作平台（TRS WCM） Description: 自动流转到下一个节点的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MsgSendHandler Title: TRS 内容协作平台（TRS WCM） Description: 发送消息操作者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishContentActionHandler Title: TRS 内容协作平台（TRS WCM） Description: 发布文档操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.engine.handlers 中 IActionHandler 的使用

实现 IActionHandler 的 com.trs.components.gkml.sqgk.process.engine.handlers 中的类
class | ApplyFormReplyHandler Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ApplyFormTypeHandler Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | AutoFillApplyFormHandler Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplyAppendixNotifyHandler Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplyNotifyHandler Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.process 中 IActionHandler 的使用

实现 IActionHandler 的 com.trs.components.infoview.process 中的类
 class SendEmailForInfoViewHandler

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.engine.IConditionHandler 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.engine.IConditionHandler
的使用

使用 IConditionHandler 的软件包
com.trs.cms.process.engine.handlers

com.trs.cms.process.engine.handlers 中 IConditionHandler 的使用

实现 IConditionHandler 的 com.trs.cms.process.engine.handlers 中的类
class | ContentPropertyHandler Title: TRS 内容协作平台（TRS WCM） Description: 内容属性是否符合条件判断其 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | OverTimeHandler Title: TRS 内容协作平台（TRS WCM） Description: 超时判断处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.engine.IInitValueCreator 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.engine.IInitValueCreator
的使用

使用 IInitValueCreator 的软件包
com.trs.cms.process.engine.creators

com.trs.cms.process.engine.creators 中 IInitValueCreator 的使用

实现 IInitValueCreator 的 com.trs.cms.process.engine.creators 中的类
class | CurrentDateCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | CurrentDocStatusCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | CurrentTimeCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | CurrentUserNameCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PostUserNameCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.cms.process.engine.IToUsersCreator 的使用

上一个 下一个 框架 无框架

接口 com.trs.cms.process.engine.IToUsersCreator
的使用

使用 IToUsersCreator 的软件包
com.trs.cms.process.engine
com.trs.cms.process.engine.creators
com.trs.components.gkml.sqgk.process.engine.creators

com.trs.cms.process.engine 中 IToUsersCreator 的使用

实现 IToUsersCreator 的 com.trs.cms.process.engine 中的类
 class AbstractToUsersCreator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine.creators 中 IToUsersCreator 的使用

实现 IToUsersCreator 的 com.trs.cms.process.engine.creators 中的类
class | CrUserAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DeptMgrAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsFromChnlAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: 根据频道名获取跟其名称一样的组织的管理员 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsFromFlowAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsFromSupportPartAsToUsersCreator
class | GroupMembersAsToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleAsToUsersCreator

com.trs.components.gkml.sqgk.process.engine.creators 中 IToUsersCreator 的使用

实现 IToUsersCreator 的 com.trs.components.gkml.sqgk.process.engine.creators 中的类
class | ApplyFormToUsersCreator Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | LawGovTousersCreator Title: TRS 内容协作平台（TRS WCM） Description: 法制办审核人构造器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.RuleExecuteHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.RuleExecuteHelper
的使用

没有 com.trs.cms.process.engine.RuleExecuteHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CrUserAsToUsersCreator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 CrUserAsToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.cms.process.engine.creators.CrUserAsToUsersCreator
所有已实现的接口：
IToUsersCreator
public class CrUserAsToUsersCreator
extends AbstractToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CrUserAsToUsersCreator()
方法摘要
 Users createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CrUserAsToUsersCreator

public CrUserAsToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CurrentDateCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 CurrentDateCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.creators.CurrentDateCreator
所有已实现的接口：
IInitValueCreator
public class CurrentDateCreator
extends java.lang.Object
implements IInitValueCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CurrentDateCreator()
方法摘要
 java.lang.String createInitValue(FlowContext _oFlowContext)
根据当前上下文信息产生初始值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CurrentDateCreator

public CurrentDateCreator()
方法详细信息

createInitValue

public java.lang.String createInitValue(FlowContext _oFlowContext)
从接口 IInitValueCreator 复制的描述
根据当前上下文信息产生初始值

指定者：
接口 IInitValueCreator 中的 createInitValue
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentDocStatusCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 CurrentDocStatusCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.creators.CurrentDocStatusCreator
所有已实现的接口：
IInitValueCreator
public class CurrentDocStatusCreator
extends java.lang.Object
implements IInitValueCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

构造方法摘要
CurrentDocStatusCreator()
方法摘要
 java.lang.String createInitValue(FlowContext flowContext)
根据当前上下文信息产生初始值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CurrentDocStatusCreator

public CurrentDocStatusCreator()
方法详细信息

createInitValue

public java.lang.String createInitValue(FlowContext flowContext)
                                 throws WCMException
从接口 IInitValueCreator 复制的描述
根据当前上下文信息产生初始值

指定者：
接口 IInitValueCreator 中的 createInitValue
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentTimeCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 CurrentTimeCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.creators.CurrentTimeCreator
所有已实现的接口：
IInitValueCreator
public class CurrentTimeCreator
extends java.lang.Object
implements IInitValueCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CurrentTimeCreator()
方法摘要
 java.lang.String createInitValue(FlowContext _oFlowContext)
根据当前上下文信息产生初始值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CurrentTimeCreator

public CurrentTimeCreator()
方法详细信息

createInitValue

public java.lang.String createInitValue(FlowContext _oFlowContext)
从接口 IInitValueCreator 复制的描述
根据当前上下文信息产生初始值

指定者：
接口 IInitValueCreator 中的 createInitValue
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentUserNameCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 CurrentUserNameCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.creators.CurrentUserNameCreator
所有已实现的接口：
IInitValueCreator
public class CurrentUserNameCreator
extends java.lang.Object
implements IInitValueCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CurrentUserNameCreator()
方法摘要
 java.lang.String createInitValue(FlowContext _oFlowContext)
根据当前上下文信息产生初始值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CurrentUserNameCreator

public CurrentUserNameCreator()
方法详细信息

createInitValue

public java.lang.String createInitValue(FlowContext _oFlowContext)
从接口 IInitValueCreator 复制的描述
根据当前上下文信息产生初始值

指定者：
接口 IInitValueCreator 中的 createInitValue
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DeptMgrAsToUsersCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 DeptMgrAsToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.cms.process.engine.creators.DeptMgrAsToUsersCreator
所有已实现的接口：
IToUsersCreator
public class DeptMgrAsToUsersCreator
extends AbstractToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DeptMgrAsToUsersCreator()
方法摘要
 Users createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DeptMgrAsToUsersCreator

public DeptMgrAsToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupAdminsAsToUsersCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 GroupAdminsAsToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.cms.process.engine.creators.GroupAdminsAsToUsersCreator
所有已实现的接口：
IToUsersCreator
public class GroupAdminsAsToUsersCreator
extends AbstractToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gong.fuchang)

构造方法摘要
GroupAdminsAsToUsersCreator()
方法摘要
 Users createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupAdminsAsToUsersCreator

public GroupAdminsAsToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupAdminsFromChnlAsToUsersCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 GroupAdminsFromChnlAsToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.cms.process.engine.creators.GroupAdminsFromChnlAsToUsersCreator
所有已实现的接口：
IToUsersCreator
public class GroupAdminsFromChnlAsToUsersCreator
extends AbstractToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
根据频道名获取跟其名称一样的组织的管理员
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gong.fuchang)

构造方法摘要
GroupAdminsFromChnlAsToUsersCreator()
方法摘要
 Users createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupAdminsFromChnlAsToUsersCreator

public GroupAdminsFromChnlAsToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupAdminsFromFlowAsToUsersCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 GroupAdminsFromFlowAsToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.cms.process.engine.creators.GroupAdminsFromFlowAsToUsersCreator
所有已实现的接口：
IToUsersCreator
public class GroupAdminsFromFlowAsToUsersCreator
extends AbstractToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gong.fuchang)

构造方法摘要
GroupAdminsFromFlowAsToUsersCreator()
方法摘要
 Users createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupAdminsFromFlowAsToUsersCreator

public GroupAdminsFromFlowAsToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupAdminsFromSupportPartAsToUsersCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 GroupAdminsFromSupportPartAsToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.cms.process.engine.creators.GroupAdminsFromSupportPartAsToUsersCreator
所有已实现的接口：
IToUsersCreator
public class GroupAdminsFromSupportPartAsToUsersCreator
extends AbstractToUsersCreator

构造方法摘要
GroupAdminsFromSupportPartAsToUsersCreator()
方法摘要
 Users createToUsers(FlowContext flowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupAdminsFromSupportPartAsToUsersCreator

public GroupAdminsFromSupportPartAsToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext flowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupMembersAsToUsersCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 GroupMembersAsToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator
所有已实现的接口：
IToUsersCreator
public class GroupMembersAsToUsersCreator
extends AbstractToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
GroupMembersAsToUsersCreator()
方法摘要
Users | createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig) 根据当前上下文信息产生处理者信息
Group | getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig) 限定了用户选择范围（在特定组内选择）
boolean | isRangedFromGroup() 指定是否需要从特定组内选择
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupMembersAsToUsersCreator

public GroupMembersAsToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：

isRangedFromGroup

public boolean isRangedFromGroup()
从接口 IToUsersCreator 复制的描述
指定是否需要从特定组内选择

指定者：
接口 IToUsersCreator 中的 isRangedFromGroup
覆盖：
类 AbstractToUsersCreator 中的 isRangedFromGroup
返回：

getGroupRange

public Group getGroupRange(FlowContext _context,
                           ToUsersCreatorConfig _creatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
限定了用户选择范围（在特定组内选择）

指定者：
接口 IToUsersCreator 中的 getGroupRange
覆盖：
类 AbstractToUsersCreator 中的 getGroupRange
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.process.engine.creators
类
CrUserAsToUsersCreator
CurrentDateCreator
CurrentDocStatusCreator
CurrentTimeCreator
CurrentUserNameCreator
DeptMgrAsToUsersCreator
GroupAdminsAsToUsersCreator
GroupAdminsFromChnlAsToUsersCreator
GroupAdminsFromFlowAsToUsersCreator
GroupAdminsFromSupportPartAsToUsersCreator
GroupMembersAsToUsersCreator
PostUserNameCreator
RoleAsToUsersCreator


com.trs.cms.process.engine.creators

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.process.engine.creators

类摘要
CrUserAsToUsersCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CurrentDateCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CurrentDocStatusCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
CurrentTimeCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CurrentUserNameCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DeptMgrAsToUsersCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAdminsAsToUsersCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAdminsFromChnlAsToUsersCreator | Title: TRS 内容协作平台（TRS WCM） Description: 根据频道名获取跟其名称一样的组织的管理员 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAdminsFromFlowAsToUsersCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAdminsFromSupportPartAsToUsersCreator |
GroupMembersAsToUsersCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PostUserNameCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RoleAsToUsersCreator |


com.trs.cms.process.engine.creators 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.engine.creators 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.process.engine.AbstractToUsersCreator (implements com.trs.cms.process.engine.IToUsersCreator)
      • com.trs.cms.process.engine.creators.CrUserAsToUsersCreator
      • com.trs.cms.process.engine.creators.DeptMgrAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupAdminsAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupAdminsFromChnlAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupAdminsFromFlowAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupAdminsFromSupportPartAsToUsersCreator
      • com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator
      • com.trs.cms.process.engine.creators.RoleAsToUsersCreator
    • com.trs.cms.process.engine.creators.CurrentDateCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.cms.process.engine.creators.CurrentDocStatusCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.cms.process.engine.creators.CurrentTimeCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.cms.process.engine.creators.CurrentUserNameCreator (implements com.trs.cms.process.engine.IInitValueCreator)
    • com.trs.cms.process.engine.creators.PostUserNameCreator (implements com.trs.cms.process.engine.IInitValueCreator)


软件包 com.trs.cms.process.engine.creators 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.engine.creators
的使用

没有 com.trs.cms.process.engine.creators 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PostUserNameCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 PostUserNameCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.creators.PostUserNameCreator
所有已实现的接口：
IInitValueCreator
public class PostUserNameCreator
extends java.lang.Object
implements IInitValueCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PostUserNameCreator()
方法摘要
 java.lang.String createInitValue(FlowContext _oFlowContext)
根据当前上下文信息产生初始值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PostUserNameCreator

public PostUserNameCreator()
方法详细信息

createInitValue

public java.lang.String createInitValue(FlowContext _oFlowContext)
从接口 IInitValueCreator 复制的描述
根据当前上下文信息产生初始值

指定者：
接口 IInitValueCreator 中的 createInitValue
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleAsToUsersCreator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.creators
类 RoleAsToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.cms.process.engine.creators.RoleAsToUsersCreator
所有已实现的接口：
IToUsersCreator
public class RoleAsToUsersCreator
extends AbstractToUsersCreator

构造方法摘要
RoleAsToUsersCreator()
方法摘要
 Users createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleAsToUsersCreator

public RoleAsToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.process.engine.creators.CrUserAsToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.CrUserAsToUsersCreator
的使用

没有 com.trs.cms.process.engine.creators.CrUserAsToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.CurrentDateCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.CurrentDateCreator
的使用

没有 com.trs.cms.process.engine.creators.CurrentDateCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.CurrentDocStatusCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.CurrentDocStatusCreator
的使用

没有 com.trs.cms.process.engine.creators.CurrentDocStatusCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.CurrentTimeCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.CurrentTimeCreator
的使用

没有 com.trs.cms.process.engine.creators.CurrentTimeCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.CurrentUserNameCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.CurrentUserNameCreator
的使用

没有 com.trs.cms.process.engine.creators.CurrentUserNameCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.DeptMgrAsToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.DeptMgrAsToUsersCreator
的使用

没有 com.trs.cms.process.engine.creators.DeptMgrAsToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.GroupAdminsAsToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.GroupAdminsAsToUsersCreator
的使用

没有 com.trs.cms.process.engine.creators.GroupAdminsAsToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.GroupAdminsFromChnlAsToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.GroupAdminsFromChnlAsToUsersCreator
的使用

没有 com.trs.cms.process.engine.creators.GroupAdminsFromChnlAsToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.GroupAdminsFromFlowAsToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.GroupAdminsFromFlowAsToUsersCreator
的使用

没有 com.trs.cms.process.engine.creators.GroupAdminsFromFlowAsToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.GroupAdminsFromSupportPartAsToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.GroupAdminsFromSupportPartAsToUsersCreator
的使用

没有 com.trs.cms.process.engine.creators.GroupAdminsFromSupportPartAsToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator
的使用

没有 com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.PostUserNameCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.PostUserNameCreator
的使用

没有 com.trs.cms.process.engine.creators.PostUserNameCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.creators.RoleAsToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.creators.RoleAsToUsersCreator
的使用

没有 com.trs.cms.process.engine.creators.RoleAsToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ActionParametersAnalyser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.handlers
类 ActionParametersAnalyser

java.lang.Object
    继承者  com.trs.cms.process.engine.handlers.ActionParametersAnalyser

public class ActionParametersAnalyser
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ActionParametersAnalyser(java.lang.String _sParamsXML)
方法摘要
 java.lang.String getParameterValue(java.lang.String _sParameterName)
获取指定参数的值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActionParametersAnalyser

public ActionParametersAnalyser(java.lang.String _sParamsXML)
方法详细信息

getParameterValue

public java.lang.String getParameterValue(java.lang.String _sParameterName)
获取指定参数的值

参数：
_sParameterName -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AutoToNextHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.handlers
类 AutoToNextHandler

java.lang.Object
    继承者  com.trs.cms.process.engine.handlers.AutoToNextHandler
所有已实现的接口：
IActionHandler
public class AutoToNextHandler
extends java.lang.Object
implements IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
自动流转到下一个节点的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AutoToNextHandler()
方法摘要
 boolean execute(ExecuteContext _context, FlowAction _action)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AutoToNextHandler

public AutoToNextHandler()
方法详细信息

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
指定者：
接口 IActionHandler 中的 execute
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConditionHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.handlers
类 ConditionHelper

java.lang.Object
    继承者  com.trs.cms.process.engine.handlers.ConditionHelper

public class ConditionHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConditionHelper()
方法摘要
static boolean | compare(long _lContentValue, long _lParamValue, int _nOperator)
static boolean | compare(java.lang.String _sContentValue, java.lang.String _sParamValue, int _nOperator)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConditionHelper

public ConditionHelper()
方法详细信息

compare

public static boolean compare(java.lang.String _sContentValue,
                              java.lang.String _sParamValue,
                              int _nOperator)
参数：
_sContentValue -
_sParamValue -
返回：

compare

public static boolean compare(long _lContentValue,
                              long _lParamValue,
                              int _nOperator)

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentPropertyHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.handlers
类 ContentPropertyHandler

java.lang.Object
    继承者  com.trs.cms.process.engine.handlers.ContentPropertyHandler
所有已实现的接口：
IConditionHandler
public class ContentPropertyHandler
extends java.lang.Object
implements IConditionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
内容属性是否符合条件判断其
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentPropertyHandler()
方法摘要
boolean | isAccordWith(ExecuteContext _context, FlowCondition _condition) 是否与设定的条件相符合?
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentPropertyHandler

public ContentPropertyHandler()
方法详细信息

isAccordWith

public boolean isAccordWith(ExecuteContext _context,
                            FlowCondition _condition)
                     throws WCMException
从接口 IConditionHandler 复制的描述
是否与设定的条件相符合?

指定者：
接口 IConditionHandler 中的 isAccordWith
参数：
_context - 工作流驱动过程中上下文对象
返回：
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DoingRuleHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.handlers
类 DoingRuleHandler

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.infra.util.job.BaseStatefulJob
            继承者  com.trs.cms.process.engine.handlers.DoingRuleHandler
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
public class DoingRuleHandler
extends BaseStatefulJob

构造方法摘要
DoingRuleHandler()
方法摘要
 void execute()
从类 com.trs.infra.util.job.BaseJob 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

DoingRuleHandler

public DoingRuleHandler()
方法详细信息

execute

public void execute()
             throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MsgSendHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.handlers
类 MsgSendHandler

java.lang.Object
    继承者  com.trs.cms.process.engine.handlers.MsgSendHandler
所有已实现的接口：
IActionHandler
public class MsgSendHandler
extends java.lang.Object
implements IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
发送消息操作者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MsgSendHandler()
方法摘要
java.lang.String | doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
boolean | execute(ExecuteContext _context, FlowAction _action)
java.util.Map | getVarValues()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MsgSendHandler

public MsgSendHandler()
方法详细信息

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
                throws WCMException
指定者：
接口 IActionHandler 中的 execute
抛出：
WCMException

main

public static void main(java.lang.String[] args)

doPageVariablesParse

public java.lang.String doPageVariablesParse(java.lang.String _sContent,
                                             ExecuteContext _context)
                                      throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_context -
返回：
抛出：
WCMException

getVarValues

public java.util.Map getVarValues()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OverTimeHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.handlers
类 OverTimeHandler

java.lang.Object
    继承者  com.trs.cms.process.engine.handlers.OverTimeHandler
所有已实现的接口：
IConditionHandler
public class OverTimeHandler
extends java.lang.Object
implements IConditionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
超时判断处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
OverTimeHandler()
方法摘要
boolean | isAccordWith(ExecuteContext _context, FlowCondition _condition) 是否与设定的条件相符合?
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OverTimeHandler

public OverTimeHandler()
方法详细信息

isAccordWith

public boolean isAccordWith(ExecuteContext _context,
                            FlowCondition _condition)
从接口 IConditionHandler 复制的描述
是否与设定的条件相符合?

指定者：
接口 IConditionHandler 中的 isAccordWith
参数：
_context - 工作流驱动过程中上下文对象
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.process.engine.handlers
类
ActionParametersAnalyser
AutoToNextHandler
ConditionHelper
ContentPropertyHandler
DoingRuleHandler
MsgSendHandler
OverTimeHandler
PublishContentActionHandler


com.trs.cms.process.engine.handlers

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.process.engine.handlers

类摘要
ActionParametersAnalyser | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
AutoToNextHandler | Title: TRS 内容协作平台（TRS WCM） Description: 自动流转到下一个节点的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ConditionHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentPropertyHandler | Title: TRS 内容协作平台（TRS WCM） Description: 内容属性是否符合条件判断其 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DoingRuleHandler |
MsgSendHandler | Title: TRS 内容协作平台（TRS WCM） Description: 发送消息操作者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
OverTimeHandler | Title: TRS 内容协作平台（TRS WCM） Description: 超时判断处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishContentActionHandler | Title: TRS 内容协作平台（TRS WCM） Description: 发布文档操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.cms.process.engine.handlers 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.engine.handlers 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.process.engine.handlers.ActionParametersAnalyser
    • com.trs.cms.process.engine.handlers.AutoToNextHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.infra.util.job.BaseStatefulJob (implements org.quartz.StatefulJob)
        • com.trs.cms.process.engine.handlers.DoingRuleHandler
    • com.trs.cms.process.engine.handlers.ConditionHelper
    • com.trs.cms.process.engine.handlers.ContentPropertyHandler (implements com.trs.cms.process.engine.IConditionHandler)
    • com.trs.cms.process.engine.handlers.MsgSendHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.cms.process.engine.handlers.OverTimeHandler (implements com.trs.cms.process.engine.IConditionHandler)
    • com.trs.cms.process.engine.handlers.PublishContentActionHandler (implements com.trs.cms.process.engine.IActionHandler)


软件包 com.trs.cms.process.engine.handlers 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.engine.handlers
的使用

没有 com.trs.cms.process.engine.handlers 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishContentActionHandler

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.engine.handlers
类 PublishContentActionHandler

java.lang.Object
    继承者  com.trs.cms.process.engine.handlers.PublishContentActionHandler
所有已实现的接口：
IActionHandler
public class PublishContentActionHandler
extends java.lang.Object
implements IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
发布文档操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishContentActionHandler()
方法摘要
 boolean execute(ExecuteContext _context, FlowAction _action)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishContentActionHandler

public PublishContentActionHandler()
方法详细信息

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
                throws WCMException
指定者：
接口 IActionHandler 中的 execute
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.cms.process.engine.handlers.ActionParametersAnalyser 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.handlers.ActionParametersAnalyser
的使用

没有 com.trs.cms.process.engine.handlers.ActionParametersAnalyser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.handlers.AutoToNextHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.handlers.AutoToNextHandler
的使用

没有 com.trs.cms.process.engine.handlers.AutoToNextHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.handlers.ConditionHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.handlers.ConditionHelper
的使用

没有 com.trs.cms.process.engine.handlers.ConditionHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.handlers.ContentPropertyHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.handlers.ContentPropertyHandler
的使用

没有 com.trs.cms.process.engine.handlers.ContentPropertyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.handlers.DoingRuleHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.handlers.DoingRuleHandler
的使用

没有 com.trs.cms.process.engine.handlers.DoingRuleHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.handlers.MsgSendHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.handlers.MsgSendHandler
的使用

没有 com.trs.cms.process.engine.handlers.MsgSendHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.handlers.OverTimeHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.handlers.OverTimeHandler
的使用

没有 com.trs.cms.process.engine.handlers.OverTimeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.engine.handlers.PublishContentActionHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.engine.handlers.PublishContentActionHandler
的使用

没有 com.trs.cms.process.engine.handlers.PublishContentActionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FlowImporter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.xml
类 FlowImporter

java.lang.Object
    继承者  com.trs.cms.process.xml.FlowImporter

public class FlowImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
从XML导入工作流的配置的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
 int m_nCurrFlowId
构造方法摘要
FlowImporter(int _nImportType)
FlowImporter(User _loginUser, int _nImportType)
方法摘要
CMSObj | getOwner()
Reports | importFromFile(java.lang.String _sXmlFile, java.lang.String _sXslFile)
Reports | importFromXMLContent(java.lang.String _sXmlContent)
Reports | importFromXMLObj(XmlObject _sXmlObj)
boolean | isImportWithFlowNodeFields()
boolean | isImportWithInfoviewId()
boolean | isImportWithOptMarkEnum()
void | setImportWithFlowNodeFields(boolean importWithFlowNodeFields)
void | setImportWithInfoviewId(boolean _val)
void | setImportWithOptMarkEnum(boolean importWithOptMarkEnum)
void | setOwner(CMSObj owner)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

m_nCurrFlowId

public int m_nCurrFlowId
构造方法详细信息

FlowImporter

public FlowImporter(int _nImportType)

FlowImporter

public FlowImporter(User _loginUser,
                    int _nImportType)
方法详细信息

importFromFile

public Reports importFromFile(java.lang.String _sXmlFile,
                              java.lang.String _sXslFile)
                       throws WCMException
抛出：
WCMException

importFromXMLContent

public Reports importFromXMLContent(java.lang.String _sXmlContent)
                             throws WCMException
抛出：
WCMException

importFromXMLObj

public Reports importFromXMLObj(XmlObject _sXmlObj)
                         throws WCMException
抛出：
WCMException

getOwner

public CMSObj getOwner()
返回：

setOwner

public void setOwner(CMSObj owner)
参数：
owner -

isImportWithFlowNodeFields

public boolean isImportWithFlowNodeFields()

setImportWithFlowNodeFields

public void setImportWithFlowNodeFields(boolean importWithFlowNodeFields)

isImportWithOptMarkEnum

public boolean isImportWithOptMarkEnum()

setImportWithOptMarkEnum

public void setImportWithOptMarkEnum(boolean importWithOptMarkEnum)

setImportWithInfoviewId

public void setImportWithInfoviewId(boolean _val)

isImportWithInfoviewId

public boolean isImportWithInfoviewId()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FlowNodeXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.xml
类 FlowNodeXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.cms.process.xml.FlowNodeXmlConverter

public class FlowNodeXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流节点对象到XML转换的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowNodeXmlConverter()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowNodeXmlConverter

public FlowNodeXmlConverter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowRuleXMLConvertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.xml
类 FlowRuleXMLConvertor

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.cms.process.xml.FlowRuleXMLConvertor

public class FlowRuleXMLConvertor
extends BaseObjToXmlConverter

构造方法摘要
FlowRuleXMLConvertor()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowRuleXMLConvertor

public FlowRuleXMLConvertor()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowXmlConverter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.cms.process.xml
类 FlowXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.cms.process.xml.FlowXmlConverter

public class FlowXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
工作流对象到XML转换对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowXmlConverter()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowXmlConverter

public FlowXmlConverter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.cms.process.xml
类
FlowImporter
FlowNodeXmlConverter
FlowRuleXMLConvertor
FlowXmlConverter


com.trs.cms.process.xml

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.cms.process.xml

类摘要
FlowImporter | Title: TRS 内容协作平台（TRS WCM） Description: 从XML导入工作流的配置的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowNodeXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 工作流节点对象到XML转换的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowRuleXMLConvertor |
FlowXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 工作流对象到XML转换对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.cms.process.xml 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.xml 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.cms.process.xml.FlowNodeXmlConverter
      • com.trs.cms.process.xml.FlowRuleXMLConvertor
      • com.trs.cms.process.xml.FlowXmlConverter
    • com.trs.cms.process.xml.FlowImporter


软件包 com.trs.cms.process.xml 的使用

上一个 下一个 框架 无框架

软件包 com.trs.cms.process.xml
的使用

没有 com.trs.cms.process.xml 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.xml.FlowImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.xml.FlowImporter
的使用

没有 com.trs.cms.process.xml.FlowImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.xml.FlowNodeXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.xml.FlowNodeXmlConverter
的使用

没有 com.trs.cms.process.xml.FlowNodeXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.xml.FlowRuleXMLConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.xml.FlowRuleXMLConvertor
的使用

没有 com.trs.cms.process.xml.FlowRuleXMLConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.cms.process.xml.FlowXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.cms.process.xml.FlowXmlConverter
的使用

没有 com.trs.cms.process.xml.FlowXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DocumentLCListenerForSIMSearch

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.ckm
类 DocumentLCListenerForSIMSearch

java.lang.Object
    继承者  com.trs.components.ckm.DocumentLCListenerForSIMSearch
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class DocumentLCListenerForSIMSearch
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentLCListenerForSIMSearch()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForSIMSearch

public DocumentLCListenerForSIMSearch()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ICKMServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.ckm
接口 ICKMServer

所有超级接口：
IServer
所有已知实现类：
TRSCKMServer
public interface ICKMServer
extends IServer

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
com.trs.ckm.soap.CollErrorInfoDetail[] | collateText(java.lang.String _sContent)
void | deleteSimIndex(Document _oDocument)
void | enableCKMService(boolean _bSimSearch, boolean _bAutorExtract, boolean _bAutoCheck) 开启CKM服务器的某些服务
java.lang.String[] | extractAbstractAndKeywords(java.lang.String _sContent)
java.lang.String | getCKMServerIP()
java.lang.String | getCKMServerPassword() 获取CKMServer的Password
java.lang.String | getCKMServerPort() 获取CKMServer的IP
java.lang.String | getCKMServerUserName() 获取CKMServer的UserName
boolean | isEnableAutoCheck() 是否开启自动校对
boolean | isEnableAutoExtract() 是否开启自动抽取
boolean | isEnableSimSearch() 是否开启相似性检索
boolean | isNeedStartup()
boolean | isStarted()
void | setCKMServer(java.lang.String _sServerIP, java.lang.String _sServerPort, java.lang.String _sUserName, java.lang.String _sPassword) 设置CKM服务器
Documents | simSearch(int _nDocId, java.lang.String _sContent)
void | updateSimIndex(Document _oDocument)
void | updateSimIndex(int _nId, java.lang.String _sContent)
Reports | validateCKMServer() 校验系统配置的CKMServer是否有效
Reports | validateCKMServer(java.lang.String _sServerIP, java.lang.String _sServerPort, java.lang.String _sUserName, java.lang.String _sPassword) 校验CKM Service是否有效
从接口 com.trs.infra.IServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, restart, setServerName, shutdown, startup

方法详细信息

validateCKMServer

Reports validateCKMServer(java.lang.String _sServerIP,
                          java.lang.String _sServerPort,
                          java.lang.String _sUserName,
                          java.lang.String _sPassword)
校验CKM Service是否有效

参数：
_sServerIP - CKM服务器IP
_sServerPort - CKM服务器端口
_sUserName - 用户名
_sPassword - 密码
返回：
校验结果

validateCKMServer

Reports validateCKMServer()
校验系统配置的CKMServer是否有效

返回：
校验结果

setCKMServer

void setCKMServer(java.lang.String _sServerIP,
                  java.lang.String _sServerPort,
                  java.lang.String _sUserName,
                  java.lang.String _sPassword)
设置CKM服务器

参数：
_sServerIP - CKM服务器IP
_sServerPort - CKM服务器端口
_sUserName - 用户名
_sPassword - 密码

enableCKMService

void enableCKMService(boolean _bSimSearch,
                      boolean _bAutorExtract,
                      boolean _bAutoCheck)
开启CKM服务器的某些服务

参数：
_bSimSearch - 启用相似性检索服务
_bAutorExtract - 启用自动抽取摘要和关键字服务
_bAutoCheck - 启用自动校对服务

extractAbstractAndKeywords

java.lang.String[] extractAbstractAndKeywords(java.lang.String _sContent)
                                              throws WCMException
抛出：
WCMException

simSearch

Documents simSearch(int _nDocId,
                    java.lang.String _sContent)

collateText

com.trs.ckm.soap.CollErrorInfoDetail[] collateText(java.lang.String _sContent)
                                                   throws WCMException
抛出：
WCMException

updateSimIndex

void updateSimIndex(Document _oDocument)

updateSimIndex

void updateSimIndex(int _nId,
                    java.lang.String _sContent)

deleteSimIndex

void deleteSimIndex(Document _oDocument)

getCKMServerIP

java.lang.String getCKMServerIP()
返回：

getCKMServerPort

java.lang.String getCKMServerPort()
获取CKMServer的IP

返回：

getCKMServerUserName

java.lang.String getCKMServerUserName()
获取CKMServer的UserName

返回：

getCKMServerPassword

java.lang.String getCKMServerPassword()
获取CKMServer的Password

返回：

isEnableSimSearch

boolean isEnableSimSearch()
是否开启相似性检索

返回：

isEnableAutoExtract

boolean isEnableAutoExtract()
是否开启自动抽取

返回：

isEnableAutoCheck

boolean isEnableAutoCheck()
是否开启自动校对

返回：

isStarted

boolean isStarted()

isNeedStartup

boolean isNeedStartup()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICKMServerTest

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.ckm
类 ICKMServerTest

java.lang.Object
    继承者  junit.framework.Assert
        继承者  junit.framework.TestCase
            继承者  com.trs.components.ckm.ICKMServerTest
所有已实现的接口：
junit.framework.Test
public class ICKMServerTest
extends junit.framework.TestCase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ICKMServerTest()
方法摘要
void | testCollate()
void | testEnableCKMService()
void | testExtractAbstract()
void | testSetCKMServer()
void | testSimSearch()
void | testValidateCKMServer()
从类 junit.framework.TestCase 继承的方法
countTestCases, getName, run, run, runBare, setName, toString
从类 junit.framework.Assert 继承的方法
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ICKMServerTest

public ICKMServerTest()
方法详细信息

testValidateCKMServer

public void testValidateCKMServer()

testSetCKMServer

public void testSetCKMServer()

testEnableCKMService

public void testEnableCKMService()

testExtractAbstract

public void testExtractAbstract()

testCollate

public void testCollate()

testSimSearch

public void testSimSearch()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.ckm
接口
ICKMServer
类
DocumentLCListenerForSIMSearch
ICKMServerTest
PositionComparator
TRSCKMServer


com.trs.components.ckm

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.ckm

接口摘要
ICKMServer Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
DocumentLCListenerForSIMSearch | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ICKMServerTest | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PositionComparator | Title: TRS 内容协作平台（TRS WCM） Description: 对CKM返回数组进行排序，按pos升序排列 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TRSCKMServer | Title: TRS 内容协作平台（TRS WCM） Description: 智能信息处理服务器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.ckm 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.ckm 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.trs.components.ckm.ICKMServerTest
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.components.ckm.TRSCKMServer (implements com.trs.components.ckm.ICKMServer)
    • com.trs.components.ckm.DocumentLCListenerForSIMSearch (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.ckm.PositionComparator (implements java.util.Comparator)

接口分层结构

  • com.trs.infra.IServer
    • com.trs.components.ckm.ICKMServer


软件包 com.trs.components.ckm 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.ckm
的使用

使用 com.trs.components.ckm 的软件包
com.trs.components.ckm

com.trs.components.ckm 使用的 com.trs.components.ckm 中的类
ICKMServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PositionComparator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.ckm
类 PositionComparator

java.lang.Object
    继承者  com.trs.components.ckm.PositionComparator
所有已实现的接口：
java.util.Comparator
public class PositionComparator
extends java.lang.Object
implements java.util.Comparator

Title: TRS 内容协作平台（TRS WCM）
Description:
对CKM返回数组进行排序，按pos升序排列 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PositionComparator()
方法摘要
 int compare(java.lang.Object o1, java.lang.Object o2)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.util.Comparator 继承的方法
equals

构造方法详细信息

PositionComparator

public PositionComparator()
方法详细信息

compare

public int compare(java.lang.Object o1,
                   java.lang.Object o2)
指定者：
接口 java.util.Comparator 中的 compare
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSCKMServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.ckm
类 TRSCKMServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.components.ckm.TRSCKMServer
所有已实现的接口：
ICKMServer, IServer
public class TRSCKMServer
extends BaseServer
implements ICKMServer

Title: TRS 内容协作平台（TRS WCM）
Description:
智能信息处理服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | KEY_CKM_ENABLE_AUTOCHECK
static java.lang.String | KEY_CKM_ENABLE_EXTRACT
static java.lang.String | KEY_CKM_ENABLE_SIMSEARCH
static java.lang.String | KEY_CKM_HAS_OPEN
static java.lang.String | KEY_CKM_PASSWORD
static java.lang.String | KEY_CKM_PORT
static java.lang.String | KEY_CKM_SERVER
static java.lang.String | KEY_CKM_USERNAME
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
TRSCKMServer()
方法摘要
com.trs.ckm.soap.CollErrorInfoDetail[] | collateText(java.lang.String _sContent)
void | deleteSimIndex(Document _oDocument)
void | enableCKMService(boolean _bSimSearch, boolean _bAutorExtract, boolean _bAutoCheck) 开启CKM服务器的某些服务
java.lang.String[] | extractAbstractAndKeywords(java.lang.String _sContent)
java.lang.String | getCKMServerIP()
java.lang.String | getCKMServerPassword() 获取CKMServer的Password
java.lang.String | getCKMServerPort() 获取CKMServer的IP
java.lang.String | getCKMServerUserName() 获取CKMServer的UserName
static ICKMServer | getInstance()
boolean | isEnableAutoCheck() 是否开启自动校对
boolean | isEnableAutoExtract() 是否开启自动抽取
boolean | isEnableSimSearch() 是否开启相似性检索
boolean | isNeedStartup()
boolean | isOpenCKMServer()
void | setCKMServer(java.lang.String _sServerIP, java.lang.String _sServerPort, java.lang.String _sUserName, java.lang.String _sPassword) 设置CKM服务器
Documents | simSearch(int _nDocId, java.lang.String _sContent)
void | updateSimIndex(Document _oDocument)
void | updateSimIndex(int _nId, java.lang.String _sContent)
Reports | validateCKMServer() 校验系统配置的CKMServer是否有效
Reports | validateCKMServer(java.lang.String _sServerIP, java.lang.String _sServerPort, java.lang.String _sUserName, java.lang.String _sPassword) 校验CKM Service是否有效
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.ckm.ICKMServer 继承的方法
isStarted
从接口 com.trs.infra.IServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, restart, setServerName, shutdown, startup

字段详细信息

KEY_CKM_SERVER

public static final java.lang.String KEY_CKM_SERVER
另请参见：
常量字段值

KEY_CKM_PORT

public static final java.lang.String KEY_CKM_PORT
另请参见：
常量字段值

KEY_CKM_USERNAME

public static final java.lang.String KEY_CKM_USERNAME
另请参见：
常量字段值

KEY_CKM_PASSWORD

public static final java.lang.String KEY_CKM_PASSWORD
另请参见：
常量字段值

KEY_CKM_ENABLE_SIMSEARCH

public static final java.lang.String KEY_CKM_ENABLE_SIMSEARCH
另请参见：
常量字段值

KEY_CKM_ENABLE_EXTRACT

public static final java.lang.String KEY_CKM_ENABLE_EXTRACT
另请参见：
常量字段值

KEY_CKM_ENABLE_AUTOCHECK

public static final java.lang.String KEY_CKM_ENABLE_AUTOCHECK
另请参见：
常量字段值

KEY_CKM_HAS_OPEN

public static final java.lang.String KEY_CKM_HAS_OPEN
另请参见：
常量字段值
构造方法详细信息

TRSCKMServer

public TRSCKMServer()
方法详细信息

validateCKMServer

public Reports validateCKMServer(java.lang.String _sServerIP,
                                 java.lang.String _sServerPort,
                                 java.lang.String _sUserName,
                                 java.lang.String _sPassword)
从接口 ICKMServer 复制的描述
校验CKM Service是否有效

指定者：
接口 ICKMServer 中的 validateCKMServer
参数：
_sServerIP - CKM服务器IP
_sServerPort - CKM服务器端口
_sUserName - 用户名
_sPassword - 密码
返回：
校验结果

setCKMServer

public void setCKMServer(java.lang.String _sServerIP,
                         java.lang.String _sServerPort,
                         java.lang.String _sUserName,
                         java.lang.String _sPassword)
从接口 ICKMServer 复制的描述
设置CKM服务器

指定者：
接口 ICKMServer 中的 setCKMServer
参数：
_sServerIP - CKM服务器IP
_sServerPort - CKM服务器端口
_sUserName - 用户名
_sPassword - 密码

enableCKMService

public void enableCKMService(boolean _bSimSearch,
                             boolean _bAutorExtract,
                             boolean _bAutoCheck)
从接口 ICKMServer 复制的描述
开启CKM服务器的某些服务

指定者：
接口 ICKMServer 中的 enableCKMService
参数：
_bSimSearch - 启用相似性检索服务
_bAutorExtract - 启用自动抽取摘要和关键字服务
_bAutoCheck - 启用自动校对服务

getInstance

public static ICKMServer getInstance()

extractAbstractAndKeywords

public java.lang.String[] extractAbstractAndKeywords(java.lang.String _sContent)
                                              throws WCMException
指定者：
接口 ICKMServer 中的 extractAbstractAndKeywords
抛出：
WCMException

simSearch

public Documents simSearch(int _nDocId,
                           java.lang.String _sContent)
指定者：
接口 ICKMServer 中的 simSearch

collateText

public com.trs.ckm.soap.CollErrorInfoDetail[] collateText(java.lang.String _sContent)
                                                   throws WCMException
指定者：
接口 ICKMServer 中的 collateText
抛出：
WCMException

updateSimIndex

public void updateSimIndex(Document _oDocument)
指定者：
接口 ICKMServer 中的 updateSimIndex

updateSimIndex

public void updateSimIndex(int _nId,
                           java.lang.String _sContent)
指定者：
接口 ICKMServer 中的 updateSimIndex

deleteSimIndex

public void deleteSimIndex(Document _oDocument)
指定者：
接口 ICKMServer 中的 deleteSimIndex

validateCKMServer

public Reports validateCKMServer()
从接口 ICKMServer 复制的描述
校验系统配置的CKMServer是否有效

指定者：
接口 ICKMServer 中的 validateCKMServer
返回：
校验结果

getCKMServerIP

public java.lang.String getCKMServerIP()
指定者：
接口 ICKMServer 中的 getCKMServerIP
返回：

getCKMServerPort

public java.lang.String getCKMServerPort()
从接口 ICKMServer 复制的描述
获取CKMServer的IP

指定者：
接口 ICKMServer 中的 getCKMServerPort
返回：

getCKMServerUserName

public java.lang.String getCKMServerUserName()
从接口 ICKMServer 复制的描述
获取CKMServer的UserName

指定者：
接口 ICKMServer 中的 getCKMServerUserName
返回：

getCKMServerPassword

public java.lang.String getCKMServerPassword()
从接口 ICKMServer 复制的描述
获取CKMServer的Password

指定者：
接口 ICKMServer 中的 getCKMServerPassword
返回：

isEnableSimSearch

public boolean isEnableSimSearch()
从接口 ICKMServer 复制的描述
是否开启相似性检索

指定者：
接口 ICKMServer 中的 isEnableSimSearch
返回：

isEnableAutoExtract

public boolean isEnableAutoExtract()
从接口 ICKMServer 复制的描述
是否开启自动抽取

指定者：
接口 ICKMServer 中的 isEnableAutoExtract
返回：

isEnableAutoCheck

public boolean isEnableAutoCheck()
从接口 ICKMServer 复制的描述
是否开启自动校对

指定者：
接口 ICKMServer 中的 isEnableAutoCheck
返回：

isNeedStartup

public boolean isNeedStartup()
指定者：
接口 ICKMServer 中的 isNeedStartup

isOpenCKMServer

public boolean isOpenCKMServer()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.ckm.DocumentLCListenerForSIMSearch 的使用

上一个 下一个 框架 无框架

类 com.trs.components.ckm.DocumentLCListenerForSIMSearch
的使用

没有 com.trs.components.ckm.DocumentLCListenerForSIMSearch 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.ckm.ICKMServer 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.ckm.ICKMServer
的使用

使用 ICKMServer 的软件包
com.trs.components.ckm

com.trs.components.ckm 中 ICKMServer 的使用

实现 ICKMServer 的 com.trs.components.ckm 中的类
 class TRSCKMServer
Title: TRS 内容协作平台（TRS WCM）
Description:
智能信息处理服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 ICKMServer 的 com.trs.components.ckm 中的方法
static ICKMServer TRSCKMServer.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.ckm.ICKMServerTest 的使用

上一个 下一个 框架 无框架

类 com.trs.components.ckm.ICKMServerTest
的使用

没有 com.trs.components.ckm.ICKMServerTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.ckm.PositionComparator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.ckm.PositionComparator
的使用

没有 com.trs.components.ckm.PositionComparator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.ckm.TRSCKMServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.ckm.TRSCKMServer
的使用

没有 com.trs.components.ckm.TRSCKMServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CommentConstants

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment
类 CommentConstants

java.lang.Object
    继承者  com.trs.components.comment.CommentConstants

public final class CommentConstants
extends java.lang.Object

字段摘要
static int | TOPIC_MOCK_CHANNELID
static java.lang.String | TOPIC_MOCK_CHANNELTITLE
static java.lang.String | TOPIC_MOCK_SITEDESC
static int | TOPIC_MOCK_SITEID
static int | TOPIC_NULL_CHANNELID
static java.lang.String | TOPIC_TOKEN_IDSEPERATOR
构造方法摘要
CommentConstants()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TOPIC_NULL_CHANNELID

public static final int TOPIC_NULL_CHANNELID
另请参见：
常量字段值

TOPIC_TOKEN_IDSEPERATOR

public static final java.lang.String TOPIC_TOKEN_IDSEPERATOR
另请参见：
常量字段值

TOPIC_MOCK_CHANNELID

public static final int TOPIC_MOCK_CHANNELID
另请参见：
常量字段值

TOPIC_MOCK_SITEID

public static final int TOPIC_MOCK_SITEID
另请参见：
常量字段值

TOPIC_MOCK_SITEDESC

public static final java.lang.String TOPIC_MOCK_SITEDESC

TOPIC_MOCK_CHANNELTITLE

public static final java.lang.String TOPIC_MOCK_CHANNELTITLE
构造方法详细信息

CommentConstants

public CommentConstants()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.comment
类
CommentConstants


com.trs.components.comment

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.comment

类摘要
CommentConstants


com.trs.components.comment 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.comment 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.comment.CommentConstants


软件包 com.trs.components.comment 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.comment
的使用

没有 com.trs.components.comment 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.CommentConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.CommentConstants
的使用

没有 com.trs.components.comment.CommentConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CommentUpdator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.domain
类 CommentUpdator

java.lang.Object
    继承者  com.trs.components.comment.domain.CommentUpdator

public class CommentUpdator
extends java.lang.Object

在外交部项目中WCM和新闻评论协同时使用 用于在WCM中生成新闻的ID、标题、所属频道的ID和站点的ID，以及 该新闻发言控制的数字签名。

构造方法摘要
CommentUpdator()
缺省构造方法
CommentUpdator(java.lang.String s)
利用带有签名的数据还原“NewsComment”对象
方法摘要
java.lang.String | getDataWithSign() 返回带有数字签名的数据
java.lang.String | getRelatedDocIds()
int | getTopicId()
boolean | isDeleteFlag()
static void | main(java.lang.String[] args) for test
void | setDeleteFlag(boolean deleteFlag)
void | setRelatedDocIds(java.lang.String topicTitle)
void | setTopicId(int topicId)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CommentUpdator

public CommentUpdator()
缺省构造方法

CommentUpdator

public CommentUpdator(java.lang.String s)
               throws java.lang.Exception
利用带有签名的数据还原“NewsComment”对象

抛出：
java.lang.Exception
方法详细信息

getDataWithSign

public java.lang.String getDataWithSign()
                                 throws java.lang.Exception
返回带有数字签名的数据

抛出：
如果没有设置有效的新闻ID - ,站点ID,频道ID或者新闻标题，或者数字签名算法有问题。
java.lang.Exception

main

public static void main(java.lang.String[] args)
for test

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getTopicId

public int getTopicId()

setTopicId

public void setTopicId(int topicId)

getRelatedDocIds

public java.lang.String getRelatedDocIds()

setRelatedDocIds

public void setRelatedDocIds(java.lang.String topicTitle)

isDeleteFlag

public boolean isDeleteFlag()

setDeleteFlag

public void setDeleteFlag(boolean deleteFlag)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentTopicRelationMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.domain
类 DocumentTopicRelationMgr

java.lang.Object
    继承者  com.trs.components.comment.domain.DocumentTopicRelationMgr

public class DocumentTopicRelationMgr
extends java.lang.Object

构造方法摘要
DocumentTopicRelationMgr()
方法摘要
void | deleteTopicDocRelation(int documentTopicId)
void | deleteTopicDocRelation(int documentTopicId, int delDocumentId)
DocumentTopic | getDocumentTopic(int _nTopicId)
DocumentTopic | getDocumentTopic(int _DocId, int _ChnlId)
java.lang.String | getNoneRelatedDocIds(int _nTopicId, int _nDocChannelId)
java.lang.String | getRelatedDocIds(int _nTopicId)
java.lang.String | getRelatedDocIds(int _nTopicId, int _nDocChannelId)
boolean | isInRelatedTopic(int _nDocId, int _nDocChannelId)
boolean | isInRelatedTopic(java.lang.String _sRelatedDocIds, int _nDocId)
void | saveDocTopicRelation(int _nTopicId, int _nDocChannelId, int[] _arRelatedDocIds)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentTopicRelationMgr

public DocumentTopicRelationMgr()
方法详细信息

saveDocTopicRelation

public void saveDocTopicRelation(int _nTopicId,
                                 int _nDocChannelId,
                                 int[] _arRelatedDocIds)
                          throws CMyException
抛出：
CMyException

getDocumentTopic

public DocumentTopic getDocumentTopic(int _nTopicId)

getDocumentTopic

public DocumentTopic getDocumentTopic(int _DocId,
                                      int _ChnlId)
                               throws WCMException
抛出：
WCMException

getRelatedDocIds

public java.lang.String getRelatedDocIds(int _nTopicId,
                                         int _nDocChannelId)
                                  throws CMyException
抛出：
CMyException

getRelatedDocIds

public java.lang.String getRelatedDocIds(int _nTopicId)
                                  throws CMyException
抛出：
CMyException

isInRelatedTopic

public boolean isInRelatedTopic(int _nDocId,
                                int _nDocChannelId)
                         throws CMyException
参数：
docId -
chnlId -
返回：
抛出：
CMyException

isInRelatedTopic

public boolean isInRelatedTopic(java.lang.String _sRelatedDocIds,
                                int _nDocId)
                         throws WCMException
参数：
_sRelatedDocIds -
_nDocId -
返回：
抛出：
WCMException

getNoneRelatedDocIds

public java.lang.String getNoneRelatedDocIds(int _nTopicId,
                                             int _nDocChannelId)
                                      throws CMyException
抛出：
CMyException

deleteTopicDocRelation

public void deleteTopicDocRelation(int documentTopicId,
                                   int delDocumentId)
                            throws WCMException
抛出：
WCMException

deleteTopicDocRelation

public void deleteTopicDocRelation(int documentTopicId)
                            throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Management

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.domain
类 Management

java.lang.Object
    继承者  com.trs.components.comment.domain.Management

public class Management
extends java.lang.Object

在外交部项目中WCM和新闻评论以及邮件订阅协同时使用。仅仅因为兼容的目的而保留。

作者：
Martin (Fu Chengrui)

构造方法摘要
Management()
缺省构造方法
Management(java.lang.String s)
利用带有签名的数据构造“Management”对象
方法摘要
int | getChannelID() 返回WCM中的频道ID
java.lang.String | getChannelName() 返回WCM中的频道名
java.lang.String | getDataWithSign() 返回带有数字签名的数据
int | getNewsID() 返回WCM中的文档ID
java.lang.String | getNewsTitle() 返回WCM中的文档标题
int | getSiteID() 返回WCM中站点ID
java.lang.String | getSiteName() 返回WCM中的站点名
int | getTopicId()
java.lang.String | getTopicTitle()
int | getUserID() 返回WCM中的用户ID和用户名
java.lang.String | getUserName() 返回WCM中的和用户名
void | setChannel(int iChannelID, java.lang.String sChannelName) 设置WCM中的频道ID和频道名(可选的)
void | setNews(int iNewsID, java.lang.String sNewsTitle) 设置WCM中的文档ID和文档标题(可选的)
void | setNewsId(int iNewsID) 已过时。 被 setNews(int, String) 替代
void | setSite(int iSiteID, java.lang.String sSiteName) 设置WCM中站点ID和站点名(必须的)
void | setTopicId(int topicId)
void | setTopicTitle(java.lang.String topicTitle)
void | setUser(int iUserID, java.lang.String sUserName) 设置WCM中登录用户的用户ID和用户名(必须的)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Management

public Management()
缺省构造方法

Management

public Management(java.lang.String s)
           throws java.lang.Exception
利用带有签名的数据构造“Management”对象

参数：
s - 带有签名的数据
抛出：
java.lang.Exception - 如果数据有错误，或者签名不符
方法详细信息

getDataWithSign

public java.lang.String getDataWithSign()
                                 throws java.lang.Exception
返回带有数字签名的数据

返回：
带有数字签名的数据
抛出：
java.lang.Exception - 如果没有设置有效的新闻ID,站点ID,频道ID或者新闻标题，或者数字签名算法有问题。

getNewsID

public int getNewsID()
返回WCM中的文档ID

返回：
WCM中的文档ID

getNewsTitle

public java.lang.String getNewsTitle()
返回WCM中的文档标题

返回：
WCM中的文档标题

setNewsId

public void setNewsId(int iNewsID)
已过时。 被 setNews(int, String) 替代

设置WCM中的文档ID(可选的)

参数：
iNewsID - 文档ID

setNews

public void setNews(int iNewsID,
                    java.lang.String sNewsTitle)
设置WCM中的文档ID和文档标题(可选的)

参数：
iNewsID - 文档ID
sNewsTitle - 文档标题

getChannelID

public int getChannelID()
返回WCM中的频道ID

返回：
WCM中的频道ID

getChannelName

public java.lang.String getChannelName()
返回WCM中的频道名

返回：
WCM中的频道名

setChannel

public void setChannel(int iChannelID,
                       java.lang.String sChannelName)
设置WCM中的频道ID和频道名(可选的)

参数：
iChannelID - 频道ID
sChannelName - 频道名

getSiteID

public int getSiteID()
返回WCM中站点ID

返回：
站点ID

getSiteName

public java.lang.String getSiteName()
返回WCM中的站点名

返回：
WCM中的站点名

setSite

public void setSite(int iSiteID,
                    java.lang.String sSiteName)
设置WCM中站点ID和站点名(必须的)

参数：
iSiteID - 站点ID
sSiteName - 站点名

getUserID

public int getUserID()
返回WCM中的用户ID和用户名

返回：
用户ID

getUserName

public java.lang.String getUserName()
返回WCM中的和用户名

返回：
用户名

setUser

public void setUser(int iUserID,
                    java.lang.String sUserName)
设置WCM中登录用户的用户ID和用户名(必须的)

参数：
iUserID - 用户ID
sUserName - 用户名

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getTopicId

public int getTopicId()

setTopicId

public void setTopicId(int topicId)

getTopicTitle

public java.lang.String getTopicTitle()

setTopicTitle

public void setTopicTitle(java.lang.String topicTitle)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NewsComment.CommentEmitEnum

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.domain
类 NewsComment.CommentEmitEnum

java.lang.Object
    继承者  com.trs.components.comment.domain.NewsComment.CommentEmitEnum
包容类：
NewsComment
public class NewsComment.CommentEmitEnum
extends java.lang.Object

字段摘要
static java.lang.String | RANGE_DEFAULT
static java.lang.String | RANGE_HIT
static java.lang.String | RANGE_TIME
static int | STYLE_IPDISPLAY_COMPLETE
static int | STYLE_IPDISPLAY_DEFAULT
static int | STYLE_IPDISPLAY_HIDDENALL
static int | STYLE_IPDISPLAY_HIDDENLAST
static java.lang.String | TYPE_DEFAULT
static java.lang.String | TYPE_JS
static java.lang.String | TYPE_TEXT
static java.lang.String | TYPE_XML
构造方法摘要
NewsComment.CommentEmitEnum()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_JS

public static final java.lang.String TYPE_JS
另请参见：
常量字段值

TYPE_XML

public static final java.lang.String TYPE_XML
另请参见：
常量字段值

TYPE_TEXT

public static final java.lang.String TYPE_TEXT
另请参见：
常量字段值

TYPE_DEFAULT

public static final java.lang.String TYPE_DEFAULT
另请参见：
常量字段值

RANGE_TIME

public static final java.lang.String RANGE_TIME
另请参见：
常量字段值

RANGE_HIT

public static final java.lang.String RANGE_HIT
另请参见：
常量字段值

RANGE_DEFAULT

public static final java.lang.String RANGE_DEFAULT
另请参见：
常量字段值

STYLE_IPDISPLAY_COMPLETE

public static final int STYLE_IPDISPLAY_COMPLETE
另请参见：
常量字段值

STYLE_IPDISPLAY_HIDDENLAST

public static final int STYLE_IPDISPLAY_HIDDENLAST
另请参见：
常量字段值

STYLE_IPDISPLAY_HIDDENALL

public static final int STYLE_IPDISPLAY_HIDDENALL
另请参见：
常量字段值

STYLE_IPDISPLAY_DEFAULT

public static final int STYLE_IPDISPLAY_DEFAULT
另请参见：
常量字段值
构造方法详细信息

NewsComment.CommentEmitEnum

public NewsComment.CommentEmitEnum()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NewsComment

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.domain
类 NewsComment

java.lang.Object
    继承者  com.trs.components.comment.domain.NewsComment

public class NewsComment
extends java.lang.Object

在外交部项目中WCM和新闻评论协同时使用 用于在WCM中生成新闻的ID、标题、所属频道的ID和站点的ID，以及 该新闻发言控制的数字签名。

嵌套类摘要
 class NewsComment.CommentEmitEnum
构造方法摘要
NewsComment()
缺省构造方法
NewsComment(java.lang.String s)
利用带有签名的数据还原“NewsComment”对象
方法摘要
java.lang.String | getAdditionalData()
java.lang.String | getDataWithSign() 返回带有数字签名的数据
int | getTopicId()
java.lang.String | getTopicTitle()
static boolean | isValidContentType(java.lang.String _sConType)
static boolean | isValidTopRange(java.lang.String _sTopRan)
static void | main(java.lang.String[] args) for test
void | setAdditionalData(java.lang.String additionalData)
void | setChannelId(int iChannelID) 设置频道 ID
void | setLimit(int iLimit) 设置发言控制
void | setNewsId(int iNewsID) 设置新闻的ID
void | setNewsTitle(java.lang.String strNewsTitle) 设置新闻的标题
void | setSiteId(int iSiteID) 设置站点 ID
void | setTopicId(int topicId)
void | setTopicTitle(java.lang.String topicTitle)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NewsComment

public NewsComment()
缺省构造方法

NewsComment

public NewsComment(java.lang.String s)
            throws java.lang.Exception
利用带有签名的数据还原“NewsComment”对象

抛出：
java.lang.Exception
方法详细信息

getDataWithSign

public java.lang.String getDataWithSign()
                                 throws java.lang.Exception
返回带有数字签名的数据

抛出：
如果没有设置有效的新闻ID - ,站点ID,频道ID或者新闻标题，或者数字签名算法有问题。
java.lang.Exception

main

public static void main(java.lang.String[] args)
for test

setChannelId

public void setChannelId(int iChannelID)
设置频道 ID

setLimit

public void setLimit(int iLimit)
设置发言控制

setNewsId

public void setNewsId(int iNewsID)
设置新闻的ID

setNewsTitle

public void setNewsTitle(java.lang.String strNewsTitle)
设置新闻的标题

setSiteId

public void setSiteId(int iSiteID)
设置站点 ID

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getTopicId

public int getTopicId()

setTopicId

public void setTopicId(int topicId)

getTopicTitle

public java.lang.String getTopicTitle()

setTopicTitle

public void setTopicTitle(java.lang.String topicTitle)

getAdditionalData

public java.lang.String getAdditionalData()

setAdditionalData

public void setAdditionalData(java.lang.String additionalData)

isValidContentType

public static boolean isValidContentType(java.lang.String _sConType)

isValidTopRange

public static boolean isValidTopRange(java.lang.String _sTopRan)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.comment.domain
类
CommentUpdator
DocumentTopicRelationMgr
Management
NewsComment
SignUtil


com.trs.components.comment.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.comment.domain

类摘要
CommentUpdator | 在外交部项目中WCM和新闻评论协同时使用 用于在WCM中生成新闻的ID、标题、所属频道的ID和站点的ID，以及 该新闻发言控制的数字签名。
DocumentTopicRelationMgr |
Management | 在外交部项目中WCM和新闻评论以及邮件订阅协同时使用。
NewsComment | 在外交部项目中WCM和新闻评论协同时使用 用于在WCM中生成新闻的ID、标题、所属频道的ID和站点的ID，以及 该新闻发言控制的数字签名。
SignUtil | 签名和编码，仅供包内使用


com.trs.components.comment.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.comment.domain.CommentUpdator
    • com.trs.components.comment.domain.DocumentTopicRelationMgr
    • com.trs.components.comment.domain.Management
    • com.trs.components.comment.domain.NewsComment
    • com.trs.components.comment.domain.NewsComment.CommentEmitEnum
    • com.trs.components.comment.domain.SignUtil


软件包 com.trs.components.comment.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.domain
的使用

使用 com.trs.components.comment.domain 的软件包
com.trs.components.comment.domain

com.trs.components.comment.domain 使用的 com.trs.components.comment.domain 中的类
SignUtil
签名和编码，仅供包内使用

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SignUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.domain
类 SignUtil

java.lang.Object
    继承者  com.trs.components.comment.domain.SignUtil

public class SignUtil
extends java.lang.Object

签名和编码，仅供包内使用

方法摘要
byte[] | decodeRadix64(byte[] inbuf)
static SignUtil | getVerify() 此处插入方法说明。
boolean | verify(byte[] data, int iLength) 此处插入方法说明。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

decodeRadix64

public byte[] decodeRadix64(byte[] inbuf)

getVerify

public static SignUtil getVerify()
                          throws java.lang.Exception
此处插入方法说明。

抛出：
java.lang.Exception

verify

public boolean verify(byte[] data,
                      int iLength)
               throws java.lang.Exception
此处插入方法说明。

抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.comment.domain.CommentUpdator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.domain.CommentUpdator
的使用

没有 com.trs.components.comment.domain.CommentUpdator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.domain.DocumentTopicRelationMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.domain.DocumentTopicRelationMgr
的使用

没有 com.trs.components.comment.domain.DocumentTopicRelationMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.domain.Management 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.domain.Management
的使用

没有 com.trs.components.comment.domain.Management 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum
的使用

没有 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.domain.NewsComment 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.domain.NewsComment
的使用

没有 com.trs.components.comment.domain.NewsComment 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.domain.SignUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.domain.SignUtil
的使用

使用 SignUtil 的软件包
com.trs.components.comment.domain

com.trs.components.comment.domain 中 SignUtil 的使用

返回 SignUtil 的 com.trs.components.comment.domain 中的方法
static SignUtil SignUtil.getVerify()
此处插入方法说明。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DocumentTopic

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.persistent
类 DocumentTopic

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.comment.persistent.DocumentTopic
所有已实现的接口：
java.lang.Cloneable
public class DocumentTopic
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
DocumentTopic()
构造函数：保留默认接口
方法摘要
static DocumentTopic | createNewInstance() 产生当前对象[DocumentTopic]的实例
void | deleteOthersBeforeDelete()
static DocumentTopic | findById(int _nId) 提取指定ID的对象
static DocumentTopic | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getCategory() 提取属性：Category
Channel | getChannel() 取主题所属频道对象
int | getChannelId() 提取属性：ChannelId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDescription() 提取属性：Description
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
WebSite | getSite()
java.lang.String | getTitle() 提取属性：Title
java.lang.String | getUrl() 提取属性：Url
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setCategory(int _nCategory) 设置属性：Category
boolean | setChannelId(int _nChannelId) 设置属性：ChannelId
boolean | setDescription(java.lang.String _sDescription) 设置属性：Description
boolean | setTitle(java.lang.String _sTitle) 设置属性：Title
boolean | setUrl(java.lang.String _sUrl) 设置属性：Url
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

DocumentTopic

public DocumentTopic()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getTitle

public java.lang.String getTitle()
提取属性：Title

返回：
Title

setTitle

public boolean setTitle(java.lang.String _sTitle)
                 throws WCMException
设置属性：Title

参数：
_sTitle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getUrl

public java.lang.String getUrl()
提取属性：Url

返回：
Url

setUrl

public boolean setUrl(java.lang.String _sUrl)
               throws WCMException
设置属性：Url

参数：
_sUrl - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDescription

public java.lang.String getDescription()
提取属性：Description

返回：
Description

setDescription

public boolean setDescription(java.lang.String _sDescription)
                       throws WCMException
设置属性：Description

参数：
_sDescription - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCategory

public int getCategory()
提取属性：Category

返回：
Category

setCategory

public boolean setCategory(int _nCategory)
                    throws WCMException
设置属性：Category

参数：
_nCategory - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getChannelId

public int getChannelId()
提取属性：ChannelId

返回：
ChannelId

setChannelId

public boolean setChannelId(int _nChannelId)
                     throws WCMException
设置属性：ChannelId

参数：
_nChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getChannel

public Channel getChannel()
取主题所属频道对象

返回：
主题所属频道对象
抛出：
WCMException

getSite

public WebSite getSite()

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final DocumentTopic findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final DocumentTopic createNewInstance()
                                             throws WCMException
产生当前对象[DocumentTopic]的实例

返回：
当前对象的实例[DocumentTopic]
抛出：
WCMException

findByKey

public static final DocumentTopic findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

deleteOthersBeforeDelete

public void deleteOthersBeforeDelete()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentTopics

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.persistent
类 DocumentTopics

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.comment.persistent.DocumentTopics

public class DocumentTopics
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
DocumentTopics(User _currUser)
构造函数
DocumentTopics(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static DocumentTopics | createNewInstance(User _currUser) 产生当前集合对象[DocumentTopics]的实例
static DocumentTopics | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static DocumentTopics | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocumentTopics]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentTopics

public DocumentTopics(User _currUser)
构造函数

另请参见：
DocumentTopics( User _currUser, int _initCapacity, int _incCapacity );

DocumentTopics

public DocumentTopics(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final DocumentTopics findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（DocumentTopics）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final DocumentTopics openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[DocumentTopics]

参数：
_filter - 指定的Filter
返回：
当前集合[DocumentTopics]
抛出：
WCMException

createNewInstance

public static DocumentTopics createNewInstance(User _currUser)
产生当前集合对象[DocumentTopics]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.comment.persistent
类
DocumentTopic
DocumentTopics
TopicedDocRelation
TopicedDocRelations


com.trs.components.comment.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.comment.persistent

类摘要
DocumentTopic
DocumentTopics
TopicedDocRelation
TopicedDocRelations


com.trs.components.comment.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.comment.persistent.DocumentTopic
        • com.trs.components.comment.persistent.TopicedDocRelation
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.comment.persistent.DocumentTopics
        • com.trs.components.comment.persistent.TopicedDocRelations


软件包 com.trs.components.comment.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.persistent
的使用

使用 com.trs.components.comment.persistent 的软件包
com.trs.components.comment.domain
com.trs.components.comment.persistent
com.trs.components.comment.service

com.trs.components.comment.domain 使用的 com.trs.components.comment.persistent 中的类
DocumentTopic

com.trs.components.comment.persistent 使用的 com.trs.components.comment.persistent 中的类
DocumentTopic
DocumentTopics
TopicedDocRelation
TopicedDocRelations

com.trs.components.comment.service 使用的 com.trs.components.comment.persistent 中的类
DocumentTopic

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TopicedDocRelation

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.persistent
类 TopicedDocRelation

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.comment.persistent.TopicedDocRelation
所有已实现的接口：
java.lang.Cloneable
public class TopicedDocRelation
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
TopicedDocRelation()
构造函数：保留默认接口
方法摘要
static TopicedDocRelation | createNewInstance() 产生当前对象[TopicedDocRelation]的实例
static TopicedDocRelation | findById(int _nId) 提取指定ID的对象
static TopicedDocRelation | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDescription() 提取属性：Description
int | getDocChannelId() 提取属性：DocChannelId
int | getDocumentId() 提取属性：DocumentId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getTopicId() 提取属性：TopicId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setDescription(java.lang.String _sDescription) 设置属性：Description
boolean | setDocChannelId(int _nDocChannelId) 设置属性：DocChannelId
boolean | setDocumentId(int _nDocumentId) 设置属性：DocumentId
boolean | setTopicId(int _nTopicId) 设置属性：TopicId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

TopicedDocRelation

public TopicedDocRelation()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getDocumentId

public int getDocumentId()
提取属性：DocumentId

返回：
DocumentId

setDocumentId

public boolean setDocumentId(int _nDocumentId)
                      throws WCMException
设置属性：DocumentId

参数：
_nDocumentId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTopicId

public int getTopicId()
提取属性：TopicId

返回：
TopicId

setTopicId

public boolean setTopicId(int _nTopicId)
                   throws WCMException
设置属性：TopicId

参数：
_nTopicId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocChannelId

public int getDocChannelId()
提取属性：DocChannelId

返回：
DocChannelId

setDocChannelId

public boolean setDocChannelId(int _nDocChannelId)
                        throws WCMException
设置属性：DocChannelId

参数：
_nDocChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDescription

public java.lang.String getDescription()
提取属性：Description

返回：
Description

setDescription

public boolean setDescription(java.lang.String _sDescription)
                       throws WCMException
设置属性：Description

参数：
_sDescription - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final TopicedDocRelation findById(int _nId)
                                         throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final TopicedDocRelation createNewInstance()
                                                  throws WCMException
产生当前对象[TopicedDocRelation]的实例

返回：
当前对象的实例[TopicedDocRelation]
抛出：
WCMException

findByKey

public static final TopicedDocRelation findByKey(java.lang.Object _oKey)
                                          throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TopicedDocRelations

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.persistent
类 TopicedDocRelations

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.comment.persistent.TopicedDocRelations

public class TopicedDocRelations
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
TopicedDocRelations(User _currUser)
构造函数
TopicedDocRelations(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static TopicedDocRelations | createNewInstance(User _currUser) 产生当前集合对象[TopicedDocRelations]的实例
static TopicedDocRelations | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static TopicedDocRelations | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TopicedDocRelations]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TopicedDocRelations

public TopicedDocRelations(User _currUser)
构造函数

另请参见：
TopicedDocRelations( User _currUser, int _initCapacity, int _incCapacity );

TopicedDocRelations

public TopicedDocRelations(User _currUser,
                           int _initCapacity,
                           int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final TopicedDocRelations findByIds(User _currUser,
                                                  java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（TopicedDocRelations）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final TopicedDocRelations openWCMObjs(User _currUser,
                                                    WCMFilter _filter)
                                             throws WCMException
通过指定一个Filter获取当前集合[TopicedDocRelations]

参数：
_filter - 指定的Filter
返回：
当前集合[TopicedDocRelations]
抛出：
WCMException

createNewInstance

public static TopicedDocRelations createNewInstance(User _currUser)
产生当前集合对象[TopicedDocRelations]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.comment.persistent.DocumentTopic 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.persistent.DocumentTopic
的使用

使用 DocumentTopic 的软件包
com.trs.components.comment.domain
com.trs.components.comment.persistent
com.trs.components.comment.service

com.trs.components.comment.domain 中 DocumentTopic 的使用

返回 DocumentTopic 的 com.trs.components.comment.domain 中的方法
DocumentTopic | DocumentTopicRelationMgr.getDocumentTopic(int _nTopicId)
DocumentTopic | DocumentTopicRelationMgr.getDocumentTopic(int _DocId, int _ChnlId)

com.trs.components.comment.persistent 中 DocumentTopic 的使用

返回 DocumentTopic 的 com.trs.components.comment.persistent 中的方法
static DocumentTopic | DocumentTopic.createNewInstance() 产生当前对象[DocumentTopic]的实例
static DocumentTopic | DocumentTopic.findById(int _nId) 提取指定ID的对象
static DocumentTopic | DocumentTopic.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.components.comment.service 中 DocumentTopic 的使用

返回 DocumentTopic 的 com.trs.components.comment.service 中的方法
DocumentTopic | ICommentService.getDocumentTopic(int _nTopicId)
DocumentTopic | CommentService.getDocumentTopic(int _nTopicId)
DocumentTopic | ICommentService.getDocumentTopic(int _nDocId, int _nChnlId)
DocumentTopic | CommentService.getDocumentTopic(int _nDocId, int _nChnlId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.persistent.DocumentTopics 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.persistent.DocumentTopics
的使用

使用 DocumentTopics 的软件包
com.trs.components.comment.persistent

com.trs.components.comment.persistent 中 DocumentTopics 的使用

返回 DocumentTopics 的 com.trs.components.comment.persistent 中的方法
static DocumentTopics | DocumentTopics.createNewInstance(User _currUser) 产生当前集合对象[DocumentTopics]的实例
static DocumentTopics | DocumentTopics.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DocumentTopics | DocumentTopics.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocumentTopics]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.persistent.TopicedDocRelation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.persistent.TopicedDocRelation
的使用

使用 TopicedDocRelation 的软件包
com.trs.components.comment.persistent

com.trs.components.comment.persistent 中 TopicedDocRelation 的使用

返回 TopicedDocRelation 的 com.trs.components.comment.persistent 中的方法
static TopicedDocRelation | TopicedDocRelation.createNewInstance() 产生当前对象[TopicedDocRelation]的实例
static TopicedDocRelation | TopicedDocRelation.findById(int _nId) 提取指定ID的对象
static TopicedDocRelation | TopicedDocRelation.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.persistent.TopicedDocRelations 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.persistent.TopicedDocRelations
的使用

使用 TopicedDocRelations 的软件包
com.trs.components.comment.persistent

com.trs.components.comment.persistent 中 TopicedDocRelations 的使用

返回 TopicedDocRelations 的 com.trs.components.comment.persistent 中的方法
static TopicedDocRelations | TopicedDocRelations.createNewInstance(User _currUser) 产生当前集合对象[TopicedDocRelations]的实例
static TopicedDocRelations | TopicedDocRelations.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TopicedDocRelations | TopicedDocRelations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TopicedDocRelations]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CommentParserEntity

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.publish.helper
类 CommentParserEntity

java.lang.Object
    继承者  com.trs.components.comment.publish.helper.CommentParserEntity

public class CommentParserEntity
extends java.lang.Object

构造方法摘要
CommentParserEntity()
CommentParserEntity(int _nSiteId, int _nChnlId, int _nId, java.lang.String _sTitle, int _nTopicId, java.lang.String _sTopicTitle)
方法摘要
int | getChannelId()
int | getId()
int | getSiteId()
java.lang.String | getTitle()
int | getTopicId()
java.lang.String | getTopicTitle()
void | setChannelId(int channelId)
void | setId(int id)
void | setSiteId(int siteId)
void | setTitle(java.lang.String title)
void | setTopicId(int topicId)
void | setTopicTitle(java.lang.String topicTitle)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CommentParserEntity

public CommentParserEntity()

CommentParserEntity

public CommentParserEntity(int _nSiteId,
                           int _nChnlId,
                           int _nId,
                           java.lang.String _sTitle,
                           int _nTopicId,
                           java.lang.String _sTopicTitle)
方法详细信息

getId

public int getId()

setId

public void setId(int id)

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String title)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getChannelId

public int getChannelId()

setChannelId

public void setChannelId(int channelId)

getSiteId

public int getSiteId()

setSiteId

public void setSiteId(int siteId)

getTopicId

public int getTopicId()

setTopicId

public void setTopicId(int topicId)

getTopicTitle

public java.lang.String getTopicTitle()

setTopicTitle

public void setTopicTitle(java.lang.String topicTitle)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CommentParserUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.publish.helper
类 CommentParserUtil

java.lang.Object
    继承者  com.trs.components.comment.publish.helper.CommentParserUtil

public class CommentParserUtil
extends java.lang.Object

构造方法摘要
CommentParserUtil()
方法摘要
static CommentParserEntity getCommentParserEntity(Document doc, TagItem tagItem)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CommentParserUtil

public CommentParserUtil()
方法详细信息

getCommentParserEntity

public static CommentParserEntity getCommentParserEntity(Document doc,
                                                         TagItem tagItem)
                                                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.comment.publish.helper
类
CommentParserEntity
CommentParserUtil


com.trs.components.comment.publish.helper

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.comment.publish.helper

类摘要
CommentParserEntity
CommentParserUtil


com.trs.components.comment.publish.helper 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.publish.helper 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.comment.publish.helper.CommentParserEntity
    • com.trs.components.comment.publish.helper.CommentParserUtil


软件包 com.trs.components.comment.publish.helper 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.publish.helper
的使用

使用 com.trs.components.comment.publish.helper 的软件包
com.trs.components.comment.publish.helper

com.trs.components.comment.publish.helper 使用的 com.trs.components.comment.publish.helper 中的类
CommentParserEntity

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.publish.helper.CommentParserEntity 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.publish.helper.CommentParserEntity
的使用

使用 CommentParserEntity 的软件包
com.trs.components.comment.publish.helper

com.trs.components.comment.publish.helper 中 CommentParserEntity 的使用

返回 CommentParserEntity 的 com.trs.components.comment.publish.helper 中的方法
static CommentParserEntity CommentParserUtil.getCommentParserEntity(Document doc, TagItem tagItem)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.publish.helper.CommentParserUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.publish.helper.CommentParserUtil
的使用

没有 com.trs.components.comment.publish.helper.CommentParserUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.comment.publish.tagparser
类
XWCMTagParserComment


com.trs.components.comment.publish.tagparser

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.comment.publish.tagparser

类摘要
XWCMTagParserComment Title: TRS 内容协作平台（TRS WCM）
Description:
WCM TagParser For Comment
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.comment.publish.tagparser 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.publish.tagparser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.comment.publish.tagparser.XWCMTagParserComment (implements com.trs.components.common.publish.domain.tagparser.ITagParser)


软件包 com.trs.components.comment.publish.tagparser 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.publish.tagparser
的使用

没有 com.trs.components.comment.publish.tagparser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


XWCMTagParserComment

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.publish.tagparser
类 XWCMTagParserComment

java.lang.Object
    继承者  com.trs.components.comment.publish.tagparser.XWCMTagParserComment
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class XWCMTagParserComment
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
WCM TagParser For Comment
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
XWCMTagParserComment()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XWCMTagParserComment

public XWCMTagParserComment()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.comment.publish.tagparser.XWCMTagParserComment 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.publish.tagparser.XWCMTagParserComment
的使用

没有 com.trs.components.comment.publish.tagparser.XWCMTagParserComment 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CommentService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.service
类 CommentService

java.lang.Object
    继承者  com.trs.components.comment.service.CommentService
所有已实现的接口：
ICommentService
public class CommentService
extends java.lang.Object
implements ICommentService

构造方法摘要
CommentService()
方法摘要
void | cancelDocTopicRelation(int _nDocumentTopicId, int _nDelDocumentId)
DocumentTopic | getDocumentTopic(int _nTopicId)
DocumentTopic | getDocumentTopic(int _nDocId, int _nChnlId)
java.lang.String | getNoneRelatedDocIds(int _nTopicId, int _nDocChannelId)
java.lang.String | getRelatedDocIds(int _nTopicId)
java.lang.String | getRelatedDocIds(int _nTopicId, int _nDocChannelId)
Documents | getRelatedDocs(int _nTopicId, WCMFilter _oFilter)
boolean | isInRelatedTopic(java.lang.String _sRelatedDocIds, int _nDocId)
void | saveDocTopicRelation(int _nTopicId, int _nDocChannelId, java.lang.String _sRelatedDocIds)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CommentService

public CommentService()
方法详细信息

isInRelatedTopic

public boolean isInRelatedTopic(java.lang.String _sRelatedDocIds,
                                int _nDocId)
指定者：
接口 ICommentService 中的 isInRelatedTopic

saveDocTopicRelation

public void saveDocTopicRelation(int _nTopicId,
                                 int _nDocChannelId,
                                 java.lang.String _sRelatedDocIds)
                          throws WCMException
指定者：
接口 ICommentService 中的 saveDocTopicRelation
抛出：
WCMException

getDocumentTopic

public DocumentTopic getDocumentTopic(int _nTopicId)
指定者：
接口 ICommentService 中的 getDocumentTopic

getRelatedDocIds

public java.lang.String getRelatedDocIds(int _nTopicId,
                                         int _nDocChannelId)
                                  throws WCMException
指定者：
接口 ICommentService 中的 getRelatedDocIds
抛出：
WCMException

getRelatedDocIds

public java.lang.String getRelatedDocIds(int _nTopicId)
                                  throws WCMException
指定者：
接口 ICommentService 中的 getRelatedDocIds
抛出：
WCMException

getNoneRelatedDocIds

public java.lang.String getNoneRelatedDocIds(int _nTopicId,
                                             int _nDocChannelId)
                                      throws WCMException
指定者：
接口 ICommentService 中的 getNoneRelatedDocIds
抛出：
WCMException

getDocumentTopic

public DocumentTopic getDocumentTopic(int _nDocId,
                                      int _nChnlId)
                               throws WCMException
指定者：
接口 ICommentService 中的 getDocumentTopic
抛出：
WCMException

getRelatedDocs

public Documents getRelatedDocs(int _nTopicId,
                                WCMFilter _oFilter)
                         throws WCMException
指定者：
接口 ICommentService 中的 getRelatedDocs
抛出：
WCMException

cancelDocTopicRelation

public void cancelDocTopicRelation(int _nDocumentTopicId,
                                   int _nDelDocumentId)
                            throws WCMException
指定者：
接口 ICommentService 中的 cancelDocTopicRelation
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ICommentService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.comment.service
接口 ICommentService

所有已知实现类：
CommentService
public interface ICommentService

方法摘要
void | cancelDocTopicRelation(int _nDocumentTopicId, int _nDelDocumentId)
DocumentTopic | getDocumentTopic(int _nTopicId)
DocumentTopic | getDocumentTopic(int _nDocId, int _nChnlId)
java.lang.String | getNoneRelatedDocIds(int _nTopicId, int _nDocChannelId)
java.lang.String | getRelatedDocIds(int _nTopicId)
java.lang.String | getRelatedDocIds(int _nTopicId, int _nDocChannelId)
Documents | getRelatedDocs(int _nTopicId, WCMFilter _oFilter)
boolean | isInRelatedTopic(java.lang.String _sRelatedDocIds, int _nDocId)
void | saveDocTopicRelation(int _nTopicId, int _nDocChannelId, java.lang.String _sRelatedDocIds)

方法详细信息

isInRelatedTopic

boolean isInRelatedTopic(java.lang.String _sRelatedDocIds,
                         int _nDocId)
                         throws WCMException
抛出：
WCMException

saveDocTopicRelation

void saveDocTopicRelation(int _nTopicId,
                          int _nDocChannelId,
                          java.lang.String _sRelatedDocIds)
                          throws WCMException
抛出：
WCMException

getDocumentTopic

DocumentTopic getDocumentTopic(int _nTopicId)

getDocumentTopic

DocumentTopic getDocumentTopic(int _nDocId,
                               int _nChnlId)
                               throws WCMException
抛出：
WCMException

getRelatedDocIds

java.lang.String getRelatedDocIds(int _nTopicId)
                                  throws WCMException
抛出：
WCMException

getRelatedDocs

Documents getRelatedDocs(int _nTopicId,
                         WCMFilter _oFilter)
                         throws WCMException
抛出：
WCMException

getRelatedDocIds

java.lang.String getRelatedDocIds(int _nTopicId,
                                  int _nDocChannelId)
                                  throws WCMException
抛出：
WCMException

getNoneRelatedDocIds

java.lang.String getNoneRelatedDocIds(int _nTopicId,
                                      int _nDocChannelId)
                                      throws WCMException
抛出：
WCMException

cancelDocTopicRelation

void cancelDocTopicRelation(int _nDocumentTopicId,
                            int _nDelDocumentId)
                            throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.comment.service
接口
ICommentService
类
CommentService


com.trs.components.comment.service

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.comment.service

接口摘要
ICommentService

类摘要
CommentService


com.trs.components.comment.service 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.service 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.comment.service.CommentService (implements com.trs.components.comment.service.ICommentService)

接口分层结构

  • com.trs.components.comment.service.ICommentService


软件包 com.trs.components.comment.service 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.comment.service
的使用

使用 com.trs.components.comment.service 的软件包
com.trs.components.comment.service

com.trs.components.comment.service 使用的 com.trs.components.comment.service 中的类
ICommentService

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.comment.service.CommentService 的使用

上一个 下一个 框架 无框架

类 com.trs.components.comment.service.CommentService
的使用

没有 com.trs.components.comment.service.CommentService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.comment.service.ICommentService 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.comment.service.ICommentService
的使用

使用 ICommentService 的软件包
com.trs.components.comment.service

com.trs.components.comment.service 中 ICommentService 的使用

实现 ICommentService 的 com.trs.components.comment.service 中的类
 class CommentService

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Contact

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.address
类 Contact

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.address.Contact
所有已实现的接口：
java.lang.Cloneable
public class Contact
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
联系人对象的定义及实现,用于通讯录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE 常量定义
构造方法摘要
Contact()
方法摘要
static Contact | createNewInstance() 产生当前对象[Contact]的实例
static Contact | findById(int _nId) 提取指定ID的对象
static Contact | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAddress() 属性: Address 地址
java.lang.String | getAttribute() 属性: Attribute 扩展属性
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
java.lang.String | getDesc() 属性: Desc 详细描述
java.lang.String | getEmail() 属性: Email 邮件 说明：若有多个邮件地址，则不同邮件地址之间用","分割
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getMobile() 属性: Mobile 手机号
java.lang.String | getNickName() 属性: NickName 昵称
java.lang.String | getSystemUserId()
java.lang.String | getTel() 属性: Tel 电话
java.lang.String | getUserName() 属性: UserName 姓名
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库
boolean | isSystemUser()
boolean | isValid() 检查对象数据的有效性
boolean | setAddress(java.lang.String _address)
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setDesc(java.lang.String _desc)
boolean | setEmail(java.lang.String _email)
boolean | setMobile(java.lang.String _mobile)
boolean | setNickName(java.lang.String _nickName)
boolean | setTel(java.lang.String _tel)
boolean | setUserName(java.lang.String _userName)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

Contact

public Contact()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getUserName

public java.lang.String getUserName()
属性: UserName 姓名

返回：

setUserName

public boolean setUserName(java.lang.String _userName)
                    throws WCMException
抛出：
WCMException

getNickName

public java.lang.String getNickName()
属性: NickName 昵称

返回：

setNickName

public boolean setNickName(java.lang.String _nickName)
                    throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()
属性: Desc 详细描述

返回：

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
抛出：
WCMException

getEmail

public java.lang.String getEmail()
属性: Email 邮件 说明：若有多个邮件地址，则不同邮件地址之间用","分割

返回：

setEmail

public boolean setEmail(java.lang.String _email)
                 throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
属性: Attribute 扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

getMobile

public java.lang.String getMobile()
属性: Mobile 手机号

返回：

setMobile

public boolean setMobile(java.lang.String _mobile)
                  throws WCMException
抛出：
WCMException

getTel

public java.lang.String getTel()
属性: Tel 电话

返回：

setTel

public boolean setTel(java.lang.String _tel)
               throws WCMException
抛出：
WCMException

getAddress

public java.lang.String getAddress()
属性: Address 地址

返回：

setAddress

public boolean setAddress(java.lang.String _address)
                   throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
@throws WCMException
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

isSystemUser

public boolean isSystemUser()

getSystemUserId

public java.lang.String getSystemUserId()

findById

public static final Contact findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Contact createNewInstance()
                                       throws WCMException
产生当前对象[Contact]的实例

返回：
当前对象的实例[Contact]
抛出：
WCMException

findByKey

public static final Contact findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ContactGrp

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.address
类 ContactGrp

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.address.ContactGrp
所有已实现的接口：
java.lang.Cloneable
public class ContactGrp
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
联系入组对象的定义及实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE 常量定义
构造方法摘要
ContactGrp()
方法摘要
boolean | addContact(Contact _Contact, User _opUser) 添加新的非系统用户到该组 参数：_Contact：要添加的非系统用户对象；_opUser：操作者（添加该用户的用户） 返回值：若参数_Contact无效，则抛出异常； 若已存在，则返回false; 若成功，则返回true
static ContactGrp | createNewInstance() 产生当前对象[ContactGrp]的实例
static ContactGrp | findById(int _nId) 提取指定ID的对象
static ContactGrp | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 属性: Attribute 扩展属性
ContactGrps | getChildren() 取组的子对象
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
java.lang.String | getDesc() 属性: Desc 详细描述
java.lang.String | getEmail() 属性: Email
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName() 属性: Name,名称 （可以修改）
ContactGrp | getParent() 取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。
int | getParentId() 属性: Parent 父对象
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库
boolean | isValid() 验证对象数据的有效性
boolean | removeContact(Contact _Contact, User _opUser) 从非系统用户组中删除指定的非系统用户 参数：_Contact:要删除的非系统用户；_opUser:执行操作的用户
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setDesc(java.lang.String _desc)
boolean | setEmail(java.lang.String _email)
boolean | setName(java.lang.String _name)
boolean | setParent(ContactGrp _parent)
boolean | setParent(int _parentId) 设置父对象
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

ContactGrp

public ContactGrp()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getName

public java.lang.String getName()
属性: Name,名称 （可以修改）

返回：

setName

public boolean setName(java.lang.String _name)
                throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()
属性: Desc 详细描述

返回：

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
抛出：
WCMException

getEmail

public java.lang.String getEmail()
属性: Email

返回：

setEmail

public boolean setEmail(java.lang.String _email)
                 throws WCMException
抛出：
WCMException

getParentId

public int getParentId()
属性: Parent 父对象

返回：

getParent

public ContactGrp getParent()
                     throws WCMException
取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。

返回：
@throws WCMException
抛出：
WCMException

setParent

public boolean setParent(int _parentId)
                  throws WCMException
设置父对象

参数：
_parentId -
返回：
@throws WCMException
抛出：
WCMException

setParent

public boolean setParent(ContactGrp _parent)
                  throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
属性: Attribute 扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
验证对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
@throws WCMException
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

getChildren

public ContactGrps getChildren()
                        throws WCMException
取组的子对象

返回：
@throws WCMException
抛出：
WCMException

addContact

public boolean addContact(Contact _Contact,
                          User _opUser)
                   throws WCMException
添加新的非系统用户到该组 参数：_Contact：要添加的非系统用户对象；_opUser：操作者（添加该用户的用户） 返回值：若参数_Contact无效，则抛出异常； 若已存在，则返回false; 若成功，则返回true

参数：
_Contact -
_opUser -
返回：
@throws WCMException
抛出：
WCMException

removeContact

public boolean removeContact(Contact _Contact,
                             User _opUser)
                      throws WCMException
从非系统用户组中删除指定的非系统用户 参数：_Contact:要删除的非系统用户；_opUser:执行操作的用户

参数：
_Contact -
_opUser -
返回：
@throws WCMException
抛出：
WCMException

findById

public static final ContactGrp findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ContactGrp createNewInstance()
                                          throws WCMException
产生当前对象[ContactGrp]的实例

返回：
当前对象的实例[ContactGrp]
抛出：
WCMException

findByKey

public static final ContactGrp findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContactGrps

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.address
类 ContactGrps

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.address.ContactGrps

public class ContactGrps
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
联系人组集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ContactGrps(User _currUser)
ContactGrps(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static ContactGrps | createNewInstance(User _currUser) 产生当前集合对象[ContactGrps]的实例
static ContactGrps | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
ContactGrp | getByName(java.lang.String _sName, int _parentId) 通过名字取得ContactGrp对象
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static ContactGrps | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContactGrps]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContactGrps

public ContactGrps(User _currUser)

ContactGrps

public ContactGrps(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
@throws Exception
抛出：
java.lang.Exception

getByName

public ContactGrp getByName(java.lang.String _sName,
                            int _parentId)
通过名字取得ContactGrp对象

参数：
_sName -
_parentId -
返回：

findByIds

public static final ContactGrps findByIds(User _currUser,
                                          java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ContactGrps）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ContactGrps openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[ContactGrps]

参数：
_filter - 指定的Filter
返回：
当前集合[ContactGrps]
抛出：
WCMException

createNewInstance

public static ContactGrps createNewInstance(User _currUser)
产生当前集合对象[ContactGrps]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContactMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.address
类 ContactMgr

java.lang.Object
    继承者  com.trs.components.common.address.ContactMgr

public class ContactMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
联系人管理对象定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContactMgr()
方法摘要
Contact | addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
Contact | addContactFromSystemUser(User _user) 导入系统用户为联系人
void | changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup) 更改联系人所在的分组
void | deleteContact(Contact _contact) 删除指定的联系人
void | deleteContactGroup(ContactGrp _contactGrp) 删除指定的联系人分组
ContactGrps | getContactGroups(WCMFilter _filter) 获取当前用户的所有联系人分组
Contacts | getContacts(WCMFilter _filter) 获取当前登录用户所有的联系人
Contacts | getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人
ContactGrps | getGroups(Contact _contact) 获取一个联系人所在的所有分组
void | removeContact(Contact _contact, ContactGrp _contactGroup) 将指定的联系人从指定的联系人分组中删除
Contact | saveContact(Contact _contact) 保存一个联系人
ContactGrp | saveContactGroup(ContactGrp _contactGrp) 保存一个联系人分组
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContactMgr

public ContactMgr()
方法详细信息

addContactFromSystemUser

public Contact addContactFromSystemUser(User _user)
                                 throws WCMException
导入系统用户为联系人

参数：
_user - 要导入的用户
返回：
@throws WCMException
抛出：
WCMException

addContact

public Contact addContact(Contact _contact,
                          ContactGrp _contactGroup)
                   throws WCMException
添加联系人到指定的组中

参数：
_contact - 要添加的联系人
_contactGroup - 指定的组
返回：
@throws WCMException
抛出：
WCMException

saveContact

public Contact saveContact(Contact _contact)
                    throws WCMException
保存一个联系人

参数：
_contact - 要保存的联系人
返回：
@throws WCMException
抛出：
WCMException

deleteContact

public void deleteContact(Contact _contact)
                   throws WCMException
删除指定的联系人

参数：
_contact - 指定的联系人
抛出：
WCMException

saveContactGroup

public ContactGrp saveContactGroup(ContactGrp _contactGrp)
                            throws WCMException
保存一个联系人分组

参数：
_contactGrp -
返回：
@throws WCMException
抛出：
WCMException

deleteContactGroup

public void deleteContactGroup(ContactGrp _contactGrp)
                        throws WCMException
删除指定的联系人分组

参数：
_contactGrp - 要删除的联系人分组
抛出：
WCMException

getGroups

public ContactGrps getGroups(Contact _contact)
                      throws WCMException
获取一个联系人所在的所有分组

参数：
_contact - 指定的联系人
返回：
@throws WCMException
抛出：
WCMException

getContactGroups

public ContactGrps getContactGroups(WCMFilter _filter)
                             throws WCMException
获取当前用户的所有联系人分组

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getContacts

public Contacts getContacts(WCMFilter _filter,
                            ContactGrp _contactGroup)
                     throws WCMException
获取当前登录用户某个分组的联系人

参数：
_filter - 过滤器,额外的查询条件
_contactGroup - 指定的联系人分组
返回：
@throws WCMException
抛出：
WCMException
另请参见：
getContacts(WCMFilter)

getContacts

public Contacts getContacts(WCMFilter _filter)
                     throws WCMException
获取当前登录用户所有的联系人

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

removeContact

public void removeContact(Contact _contact,
                          ContactGrp _contactGroup)
                   throws WCMException
将指定的联系人从指定的联系人分组中删除

参数：
_contact - 指定的联系人
_contactGroup - 联系人分组
抛出：
WCMException

changeGroup

public void changeGroup(Contact _contact,
                        ContactGrp _srcGroup,
                        ContactGrp _destGroup)
                 throws WCMException
更改联系人所在的分组

参数：
_contact - 指定的联系人
_srcGroup - 联系人所在的分组
_destGroup - 更改后所在的分组
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContactMsgSender

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.address
类 ContactMsgSender

java.lang.Object
    继承者  com.trs.components.common.address.ContactMsgSender

public class ContactMsgSender
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
给联系人发送消息的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContactMsgSender()
方法摘要
static void send(java.lang.String _sTitle, java.lang.String _sContent, java.lang.String _sSendType, Contact _toContact)
给联系人发送消息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContactMsgSender

public ContactMsgSender()
方法详细信息

send

public static void send(java.lang.String _sTitle,
                        java.lang.String _sContent,
                        java.lang.String _sSendType,
                        Contact _toContact)
                 throws WCMException
给联系人发送消息

参数：
_sTitle - 消息主题
_sContent - 消息内容
_sSendType - 消息发送类型,以','分隔的字符串
_toContact - 联系人
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Contacts

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.address
类 Contacts

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.address.Contacts

public class Contacts
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
联系人集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Contacts(User _currUser)
Contacts(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static Contacts | createNewInstance(User _currUser) 产生一个当前集合对象[Contacts]的实例
static Contacts | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Contacts | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Contacts]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Contacts

public Contacts(User _currUser)

Contacts

public Contacts(User _currUser,
                int _initCapacity,
                int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
@throws Exception
抛出：
java.lang.Exception

findByIds

public static final Contacts findByIds(User _currUser,
                                       java.lang.String _sIds)
                                throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Contacts openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[Contacts]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[Contacts]
抛出：
WCMException

createNewInstance

public static Contacts createNewInstance(User _currUser)
                                  throws WCMException
产生一个当前集合对象[Contacts]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.address
类
Contact
ContactGrp
ContactGrps
ContactMgr
ContactMsgSender
Contacts


com.trs.components.common.address

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.address

类摘要
Contact | Title: TRS 内容协作平台（TRS WCM） Description: 联系人对象的定义及实现,用于通讯录 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrp | Title: TRS 内容协作平台（TRS WCM） Description: 联系入组对象的定义及实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrps | Title: TRS 内容协作平台（TRS WCM） Description: 联系人组集合对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContactMgr | Title: TRS 内容协作平台（TRS WCM） Description: 联系人管理对象定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContactMsgSender | Title: TRS 内容协作平台（TRS WCM） Description: 给联系人发送消息的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Contacts | Title: TRS 内容协作平台（TRS WCM） Description: 联系人集合对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.address 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.address 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.address.Contact
        • com.trs.components.common.address.ContactGrp
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.address.ContactGrps
        • com.trs.components.common.address.Contacts
    • com.trs.components.common.address.ContactMgr
    • com.trs.components.common.address.ContactMsgSender


软件包 com.trs.components.common.address 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.address
的使用

使用 com.trs.components.common.address 的软件包
com.trs.components.common.address
com.trs.service
com.trs.service.impl

com.trs.components.common.address 使用的 com.trs.components.common.address 中的类
Contact
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人对象的定义及实现,用于通讯录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrp
Title: TRS 内容协作平台（TRS WCM）
Description:
联系入组对象的定义及实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrps
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人组集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Contacts
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service 使用的 com.trs.components.common.address 中的类
Contact
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人对象的定义及实现,用于通讯录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrp
Title: TRS 内容协作平台（TRS WCM）
Description:
联系入组对象的定义及实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrps
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人组集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Contacts
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service.impl 使用的 com.trs.components.common.address 中的类
Contact
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人对象的定义及实现,用于通讯录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrp
Title: TRS 内容协作平台（TRS WCM）
Description:
联系入组对象的定义及实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrps
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人组集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Contacts
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.address.Contact 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.address.Contact
的使用

使用 Contact 的软件包
com.trs.components.common.address
com.trs.service
com.trs.service.impl

com.trs.components.common.address 中 Contact 的使用

返回 Contact 的 com.trs.components.common.address 中的方法
Contact | ContactMgr.addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
Contact | ContactMgr.addContactFromSystemUser(User _user) 导入系统用户为联系人
static Contact | Contact.createNewInstance() 产生当前对象[Contact]的实例
static Contact | Contact.findById(int _nId) 提取指定ID的对象
static Contact | Contact.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Contact | ContactMgr.saveContact(Contact _contact) 保存一个联系人

参数类型为 Contact 的 com.trs.components.common.address 中的方法
Contact | ContactMgr.addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
boolean | ContactGrp.addContact(Contact _Contact, User _opUser) 添加新的非系统用户到该组 参数：_Contact：要添加的非系统用户对象；_opUser：操作者（添加该用户的用户） 返回值：若参数_Contact无效，则抛出异常； 若已存在，则返回false; 若成功，则返回true
void | ContactMgr.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup) 更改联系人所在的分组
void | ContactMgr.deleteContact(Contact _contact) 删除指定的联系人
ContactGrps | ContactMgr.getGroups(Contact _contact) 获取一个联系人所在的所有分组
void | ContactMgr.removeContact(Contact _contact, ContactGrp _contactGroup) 将指定的联系人从指定的联系人分组中删除
boolean | ContactGrp.removeContact(Contact _Contact, User _opUser) 从非系统用户组中删除指定的非系统用户 参数：_Contact:要删除的非系统用户；_opUser:执行操作的用户
Contact | ContactMgr.saveContact(Contact _contact) 保存一个联系人
static void | ContactMsgSender.send(java.lang.String _sTitle, java.lang.String _sContent, java.lang.String _sSendType, Contact _toContact) 给联系人发送消息

com.trs.service 中 Contact 的使用

返回 Contact 的 com.trs.service 中的方法
Contact | IContactService.addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
Contact | IContactService.addContact(int _nContactId, int _nContactGrpId) 添加联系人到指定的组中
Contact | IContactService.addContactFromSystemUser(int _nUserId) 导入系统用户为联系人
Contact | IContactService.addContactFromSystemUser(User _user) 导入系统用户为联系人
Contact | IContactService.saveContact(Contact _contact) 保存一个联系人

参数类型为 Contact 的 com.trs.service 中的方法
Contact | IContactService.addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
void | IContactService.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup) 更改联系人所在的分组
void | IContactService.deleteContact(Contact _contact) 删除指定的联系人
ContactGrps | IContactService.getGroups(Contact _contact) 获取指定联系人所属的所有联系人分组
void | IContactService.removeContact(Contact _contact, ContactGrp _contactGroup) 将指定的联系人从指定的联系人分组中删除
Contact | IContactService.saveContact(Contact _contact) 保存一个联系人

com.trs.service.impl 中 Contact 的使用

返回 Contact 的 com.trs.service.impl 中的方法
Contact | ContactService.addContact(Contact _contact, ContactGrp _contactGroup)
Contact | ContactService.addContact(int _nContactId, int _nContactGrpId)
Contact | ContactService.addContactFromSystemUser(int _nUserId)
Contact | ContactService.addContactFromSystemUser(User _user)
Contact | ContactService.saveContact(Contact _contact)

参数类型为 Contact 的 com.trs.service.impl 中的方法
Contact | ContactService.addContact(Contact _contact, ContactGrp _contactGroup)
void | ContactService.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup)
void | ContactService.deleteContact(Contact _contact)
ContactGrps | ContactService.getGroups(Contact _contact)
void | ContactService.removeContact(Contact _contact, ContactGrp _contactGroup)
Contact | ContactService.saveContact(Contact _contact)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.address.ContactGrp 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.address.ContactGrp
的使用

使用 ContactGrp 的软件包
com.trs.components.common.address
com.trs.service
com.trs.service.impl

com.trs.components.common.address 中 ContactGrp 的使用

返回 ContactGrp 的 com.trs.components.common.address 中的方法
static ContactGrp | ContactGrp.createNewInstance() 产生当前对象[ContactGrp]的实例
static ContactGrp | ContactGrp.findById(int _nId) 提取指定ID的对象
static ContactGrp | ContactGrp.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
ContactGrp | ContactGrps.getByName(java.lang.String _sName, int _parentId) 通过名字取得ContactGrp对象
ContactGrp | ContactGrp.getParent() 取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。
ContactGrp | ContactMgr.saveContactGroup(ContactGrp _contactGrp) 保存一个联系人分组

参数类型为 ContactGrp 的 com.trs.components.common.address 中的方法
Contact | ContactMgr.addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
void | ContactMgr.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup) 更改联系人所在的分组
void | ContactMgr.deleteContactGroup(ContactGrp _contactGrp) 删除指定的联系人分组
Contacts | ContactMgr.getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人
void | ContactMgr.removeContact(Contact _contact, ContactGrp _contactGroup) 将指定的联系人从指定的联系人分组中删除
ContactGrp | ContactMgr.saveContactGroup(ContactGrp _contactGrp) 保存一个联系人分组
boolean | ContactGrp.setParent(ContactGrp _parent)

com.trs.service 中 ContactGrp 的使用

返回 ContactGrp 的 com.trs.service 中的方法
 ContactGrp IContactService.saveContactGroup(ContactGrp _contactGrp)
保存一个联系人分组

参数类型为 ContactGrp 的 com.trs.service 中的方法
Contact | IContactService.addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
void | IContactService.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup) 更改联系人所在的分组
void | IContactService.deleteContactGroup(ContactGrp _contactGrp) 删除指定的联系人分组
Contacts | IContactService.getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人
void | IContactService.removeContact(Contact _contact, ContactGrp _contactGroup) 将指定的联系人从指定的联系人分组中删除
ContactGrp | IContactService.saveContactGroup(ContactGrp _contactGrp) 保存一个联系人分组

com.trs.service.impl 中 ContactGrp 的使用

返回 ContactGrp 的 com.trs.service.impl 中的方法
 ContactGrp ContactService.saveContactGroup(ContactGrp _contactGrp)

参数类型为 ContactGrp 的 com.trs.service.impl 中的方法
Contact | ContactService.addContact(Contact _contact, ContactGrp _contactGroup)
void | ContactService.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup)
void | ContactService.deleteContactGroup(ContactGrp _contactGroup)
Contacts | ContactService.getContacts(WCMFilter _filter, ContactGrp _contactGroup)
void | ContactService.removeContact(Contact _contact, ContactGrp _contactGroup)
ContactGrp | ContactService.saveContactGroup(ContactGrp _contactGrp)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.address.ContactGrps 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.address.ContactGrps
的使用

使用 ContactGrps 的软件包
com.trs.components.common.address
com.trs.service
com.trs.service.impl

com.trs.components.common.address 中 ContactGrps 的使用

返回 ContactGrps 的 com.trs.components.common.address 中的方法
static ContactGrps | ContactGrps.createNewInstance(User _currUser) 产生当前集合对象[ContactGrps]的实例
static ContactGrps | ContactGrps.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
ContactGrps | ContactGrp.getChildren() 取组的子对象
ContactGrps | ContactMgr.getContactGroups(WCMFilter _filter) 获取当前用户的所有联系人分组
ContactGrps | ContactMgr.getGroups(Contact _contact) 获取一个联系人所在的所有分组
static ContactGrps | ContactGrps.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContactGrps]

com.trs.service 中 ContactGrps 的使用

返回 ContactGrps 的 com.trs.service 中的方法
ContactGrps | IContactService.getContactGroups(WCMFilter _filter) 获取当前用户的所有联系人分组
ContactGrps | IContactService.getGroups(Contact _contact) 获取指定联系人所属的所有联系人分组

参数类型为 ContactGrps 的 com.trs.service 中的方法
 void IContactService.deleteContactGroups(ContactGrps _contactGroups)
删除指定的联系人分组

com.trs.service.impl 中 ContactGrps 的使用

返回 ContactGrps 的 com.trs.service.impl 中的方法
ContactGrps | ContactService.getContactGroups(WCMFilter _filter)
ContactGrps | ContactService.getGroups(Contact _contact)

参数类型为 ContactGrps 的 com.trs.service.impl 中的方法
 void ContactService.deleteContactGroups(ContactGrps _contactGroups)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.address.ContactMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.address.ContactMgr
的使用

没有 com.trs.components.common.address.ContactMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.address.ContactMsgSender 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.address.ContactMsgSender
的使用

没有 com.trs.components.common.address.ContactMsgSender 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.address.Contacts 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.address.Contacts
的使用

使用 Contacts 的软件包
com.trs.components.common.address
com.trs.service
com.trs.service.impl

com.trs.components.common.address 中 Contacts 的使用

返回 Contacts 的 com.trs.components.common.address 中的方法
static Contacts | Contacts.createNewInstance(User _currUser) 产生一个当前集合对象[Contacts]的实例
static Contacts | Contacts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Contacts | ContactMgr.getContacts(WCMFilter _filter) 获取当前登录用户所有的联系人
Contacts | ContactMgr.getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人
static Contacts | Contacts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Contacts]

com.trs.service 中 Contacts 的使用

返回 Contacts 的 com.trs.service 中的方法
Contacts | IContactService.getContacts(WCMFilter _filter) 获取当前登录用户所有的联系人
Contacts | IContactService.getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人

参数类型为 Contacts 的 com.trs.service 中的方法
 void IContactService.deleteContacts(Contacts _contacts)
删除指定的联系人集合

com.trs.service.impl 中 Contacts 的使用

返回 Contacts 的 com.trs.service.impl 中的方法
Contacts | ContactService.getContacts(WCMFilter _filter)
Contacts | ContactService.getContacts(WCMFilter _filter, ContactGrp _contactGroup)

参数类型为 Contacts 的 com.trs.service.impl 中的方法
 void ContactService.deleteContacts(Contacts _contacts)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BookMark

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.bookmark
类 BookMark

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.bookmark.BookMark
所有已实现的接口：
java.lang.Cloneable
public class BookMark
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
BookMark()
方法摘要
static BookMark | createNewInstance() 产生当前对象[BookMark]的实例
static BookMark | findById(int _nId) 提取指定ID的对象
static BookMark | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 属性: Attribute 扩展属性
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
java.lang.String | getIcon() 属性: Icon 图标
java.lang.String | getIdFieldName() 获得Id字段名。
MarkKind | getKind() 取标签类型对象
int | getKindId() 属性: Kind 类别
java.lang.String | getLink() 属性: Link 链接
MarkShares | getMarkShares(User _currUser) 得到MarkShares
java.lang.String | getName() 属性: Name,名称
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库
boolean | isShared(User _currUser) 是否被共享
boolean | isValid() 验证对象数据的有效性
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setIcon(java.lang.String _icon)
boolean | setKind(int _nKindId)
boolean | setKind(MarkKind _markKind)
boolean | setLink(java.lang.String _link)
boolean | setName(java.lang.String _name) 名称要求不重复 处理：由函数isValid()检查，并区分大小写
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

BookMark

public BookMark()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getName

public java.lang.String getName()
属性: Name,名称

返回：

setName

public boolean setName(java.lang.String _name)
                throws WCMException
名称要求不重复 处理：由函数isValid()检查，并区分大小写

抛出：
WCMException

getLink

public java.lang.String getLink()
属性: Link 链接

返回：

setLink

public boolean setLink(java.lang.String _link)
                throws WCMException
抛出：
WCMException

getIcon

public java.lang.String getIcon()
属性: Icon 图标

返回：

setIcon

public boolean setIcon(java.lang.String _icon)
                throws WCMException
抛出：
WCMException

getKindId

public int getKindId()
属性: Kind 类别

返回：

getKind

public MarkKind getKind()
                 throws WCMException
取标签类型对象

返回：
@throws WCMException
抛出：
WCMException

setKind

public boolean setKind(int _nKindId)
                throws WCMException
抛出：
WCMException

setKind

public boolean setKind(MarkKind _markKind)
                throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
属性: Attribute 扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
验证对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
@throws WCMException
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

getMarkShares

public MarkShares getMarkShares(User _currUser)
                         throws WCMException
得到MarkShares

参数：
_currUser -
返回：
@throws WCMException
抛出：
WCMException

isShared

public boolean isShared(User _currUser)
                 throws WCMException
是否被共享

参数：
_currUser -
返回：
@throws WCMException
抛出：
WCMException

findById

public static final BookMark findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final BookMark createNewInstance()
                                        throws WCMException
产生当前对象[BookMark]的实例

返回：
当前对象的实例[BookMark]
抛出：
WCMException

findByKey

public static final BookMark findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BookMarkMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.bookmark
类 BookMarkMgr

java.lang.Object
    继承者  com.trs.components.common.bookmark.BookMarkMgr

public class BookMarkMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
BookMarkMgr Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BookMarkMgr()
方法摘要
void | cancelShares(int _nObjType, CMSBaseObjs _currObjs)
boolean | deleteBookMark(BookMark _aBookMark) 删除一个书签
boolean | deleteMarkKind(MarkKind _aMarkKind) 删除一个书签分类
BookMarks | getBookMarks(int _nMarkKindId, WCMFilter _filter) 获取当前登录用户的书签
BookMarks | getBookMarks(MarkKind _markKind, WCMFilter _filter)
BookMarks | getBookMarks(WCMFilter _filter)
MarkKinds | getChildren(MarkKind _parentMarkKind, WCMFilter _filter) 获取当前书签分类的子分类
MarkKinds | getMarkKinds(WCMFilter _filter) 获取当前登录用户的顶级书签分类
BookMarks | getSharedBookMarks(User _aUser, WCMFilter _filter) 获取共享给当前登录用户的书签
Groups | getSharedGroups(int _nTypeId, CMSObj _currObj)
MarkKinds | getSharedMarkKinds(User _aUser, WCMFilter _filter) 获取共享给当前登录用户的书签分类
Users | getSharedUsers(int _nTypeId, CMSObj _currObj)
MarkShares | getShareMarks(WCMFilter _filter) 获取当前登录用户可访问的共享书签
void | moveBookMark(BookMark _aBookMark, MarkKind _newParent) 将一个书签从移动新的分类中
void | moveMarkKind(MarkKind _markKind, MarkKind _newParent) 移动一个书签类别
BookMark | saveBookMark(BookMark _bookMark) 保存一个书签
MarkKind | saveMarkKind(MarkKind _markKind) 保存一个书类别
void | shareTo(int _nObjType, CMSBaseObjs _currObjs, int _nViewerType, java.lang.String _sViewerIds)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BookMarkMgr

public BookMarkMgr()
方法详细信息

moveBookMark

public void moveBookMark(BookMark _aBookMark,
                         MarkKind _newParent)
                  throws WCMException
将一个书签从移动新的分类中

参数：
_aBookMark - 要移动的书签
_newParent - 新的分类的id
抛出：
WCMException

moveMarkKind

public void moveMarkKind(MarkKind _markKind,
                         MarkKind _newParent)
                  throws WCMException
移动一个书签类别

参数：
_markKind -
_newParent -
抛出：
WCMException

getShareMarks

public MarkShares getShareMarks(WCMFilter _filter)
                         throws WCMException
获取当前登录用户可访问的共享书签

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getSharedBookMarks

public BookMarks getSharedBookMarks(User _aUser,
                                    WCMFilter _filter)
                             throws WCMException
获取共享给当前登录用户的书签

参数：
_aUser -
_filter -
返回：
@throws WCMException
抛出：
WCMException

getSharedMarkKinds

public MarkKinds getSharedMarkKinds(User _aUser,
                                    WCMFilter _filter)
                             throws WCMException
获取共享给当前登录用户的书签分类

参数：
_aUser -
_filter -
返回：
@throws WCMException
抛出：
WCMException

getBookMarks

public BookMarks getBookMarks(int _nMarkKindId,
                              WCMFilter _filter)
                       throws WCMException
获取当前登录用户的书签

参数：
_nMarkKindId - 书签分类id号,默认为0,顶级书签
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getBookMarks

public BookMarks getBookMarks(MarkKind _markKind,
                              WCMFilter _filter)
                       throws WCMException
抛出：
WCMException

getBookMarks

public BookMarks getBookMarks(WCMFilter _filter)
                       throws WCMException
抛出：
WCMException

getMarkKinds

public MarkKinds getMarkKinds(WCMFilter _filter)
                       throws WCMException
获取当前登录用户的顶级书签分类

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getChildren

public MarkKinds getChildren(MarkKind _parentMarkKind,
                             WCMFilter _filter)
                      throws WCMException
获取当前书签分类的子分类

参数：
_parentMarkKind - 指定的当前书签分类
返回：
@throws WCMException
抛出：
WCMException

deleteMarkKind

public boolean deleteMarkKind(MarkKind _aMarkKind)
                       throws WCMException
删除一个书签分类

参数：
_aMarkKind - 要删除的分类
返回：
@throws WCMException
抛出：
WCMException

deleteBookMark

public boolean deleteBookMark(BookMark _aBookMark)
                       throws WCMException
删除一个书签

参数：
_aBookMark - 要删除的书签
返回：
@throws WCMException
抛出：
WCMException

getSharedGroups

public Groups getSharedGroups(int _nTypeId,
                              CMSObj _currObj)
                       throws WCMException
抛出：
WCMException

getSharedUsers

public Users getSharedUsers(int _nTypeId,
                            CMSObj _currObj)
                     throws WCMException
抛出：
WCMException

saveBookMark

public BookMark saveBookMark(BookMark _bookMark)
                      throws WCMException
保存一个书签

参数：
_bookMark -
返回：
@throws WCMException
抛出：
WCMException

saveMarkKind

public MarkKind saveMarkKind(MarkKind _markKind)
                      throws WCMException
保存一个书类别

参数：
_markKind -
返回：
@throws WCMException
抛出：
WCMException

cancelShares

public void cancelShares(int _nObjType,
                         CMSBaseObjs _currObjs)
                  throws WCMException
抛出：
WCMException

shareTo

public void shareTo(int _nObjType,
                    CMSBaseObjs _currObjs,
                    int _nViewerType,
                    java.lang.String _sViewerIds)
             throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BookMarks

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.bookmark
类 BookMarks

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.bookmark.BookMarks

public class BookMarks
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
BookMarks(User _currUser)
BookMarks(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static BookMarks | createNewInstance(User _currUser) 产生一个当前集合对象[BookMarks]的实例
static BookMarks | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
BookMark | getByName(java.lang.String _name, int _kind) 通过名称从集合中获取用户对象 若成功，集合指针定位到该元素； 否则，指针指向POS_EOF
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static BookMarks | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[BookMarks]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BookMarks

public BookMarks(User _currUser)

BookMarks

public BookMarks(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

getByName

public BookMark getByName(java.lang.String _name,
                          int _kind)
通过名称从集合中获取用户对象 若成功，集合指针定位到该元素； 否则，指针指向POS_EOF

参数：
_name -
_kind -
返回：

findByIds

public static final BookMarks findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final BookMarks openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[BookMarks]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[BookMarks]
抛出：
WCMException

createNewInstance

public static BookMarks createNewInstance(User _currUser)
                                   throws WCMException
产生一个当前集合对象[BookMarks]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MarkKind

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.bookmark
类 MarkKind

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.bookmark.MarkKind
所有已实现的接口：
java.lang.Cloneable
public class MarkKind
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE 常量定义
构造方法摘要
MarkKind()
方法摘要
static MarkKind | createNewInstance() 产生当前对象[MarkKind]的实例
static MarkKind | findById(int _nId) 提取指定ID的对象
static MarkKind | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 属性: Attribute 扩展属性
BookMarks | getBookMarks(User _currUser) 取所有该类别的书签集合
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
java.lang.String | getDesc() 属性: Desc 详细描述
java.lang.String | getIdFieldName() 获得Id字段名。
MarkShares | getMarkShares(User _currUser) 得到MarkShares
java.lang.String | getName() 属性: Name 名称
MarkKind | getParent() 取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。
int | getParentId() 属性: ParentId 父对象
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库
boolean | isShared(User _currUser) 是否被共享
boolean | isValid() 验证对象数据的有效性
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setDesc(java.lang.String _desc)
boolean | setName(java.lang.String _name) 名称要求不重复 处理：由函数isValid()检查，区分大小写
boolean | setParent(int _parentId) 设置父对象
boolean | setParent(MarkKind _parent)
boolean | setParentId(int _parentId) setParentId：设置父对象Id（为保证以前版本兼容而保留）
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

MarkKind

public MarkKind()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getName

public java.lang.String getName()
属性: Name 名称

返回：

setName

public boolean setName(java.lang.String _name)
                throws WCMException
名称要求不重复 处理：由函数isValid()检查，区分大小写

参数：
_name -
返回：
@throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()
属性: Desc 详细描述

返回：

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
抛出：
WCMException

getParentId

public int getParentId()
属性: ParentId 父对象

返回：

getParent

public MarkKind getParent()
                   throws WCMException
取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。

返回：
@throws WCMException
抛出：
WCMException

setParentId

public boolean setParentId(int _parentId)
                    throws WCMException
setParentId：设置父对象Id（为保证以前版本兼容而保留）

参数：
_parentId -
返回：
@throws WCMException
抛出：
WCMException

setParent

public boolean setParent(int _parentId)
                  throws WCMException
设置父对象

参数：
_parentId -
返回：
@throws WCMException
抛出：
WCMException

setParent

public boolean setParent(MarkKind _parent)
                  throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
属性: Attribute 扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
验证对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
@throws WCMException
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

getBookMarks

public BookMarks getBookMarks(User _currUser)
                       throws WCMException
取所有该类别的书签集合

参数：
_currUser -
返回：
@throws WCMException
抛出：
WCMException

getMarkShares

public MarkShares getMarkShares(User _currUser)
                         throws WCMException
得到MarkShares

参数：
_currUser -
返回：
@throws WCMException
抛出：
WCMException

isShared

public boolean isShared(User _currUser)
                 throws WCMException
是否被共享

参数：
_currUser -
返回：
@throws WCMException
抛出：
WCMException

findById

public static final MarkKind findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MarkKind createNewInstance()
                                        throws WCMException
产生当前对象[MarkKind]的实例

返回：
当前对象的实例[MarkKind]
抛出：
WCMException

findByKey

public static final MarkKind findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MarkKinds

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.bookmark
类 MarkKinds

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.bookmark.MarkKinds

public class MarkKinds
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MarkKinds(User _currUser)
MarkKinds(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static MarkKinds | createNewInstance(User _currUser) 产生一个当前集合对象[MarkKinds]的实例
static MarkKinds | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
MarkKind | getByName(java.lang.String _name, int _parentId) 通过名称从集合中获取对象 若成功，集合指针定位到该元素； 否则，指针指向POS_EOF
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static MarkKinds | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MarkKinds]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MarkKinds

public MarkKinds(User _currUser)

MarkKinds

public MarkKinds(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
抛出：
java.lang.Exception

getByName

public MarkKind getByName(java.lang.String _name,
                          int _parentId)
通过名称从集合中获取对象 若成功，集合指针定位到该元素； 否则，指针指向POS_EOF

参数：
_name -
_parentId -
返回：

findByIds

public static final MarkKinds findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MarkKinds openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[MarkKinds]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[MarkKinds]
抛出：
WCMException

createNewInstance

public static MarkKinds createNewInstance(User _currUser)
                                   throws WCMException
产生一个当前集合对象[MarkKinds]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MarkShare

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.bookmark
类 MarkShare

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.bookmark.MarkShare
所有已实现的接口：
java.lang.Cloneable
public class MarkShare
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | MARKSHARE_STATE_ALLUSER
static int | OBJ_TYPE 常量定义
构造方法摘要
MarkShare()
方法摘要
java.lang.String | getAttribute() 属性: Attribute 扩展属性
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
java.lang.String | getIdFieldName() 获得Id字段名。
CMSObj | getObject(User _currUser) 取共享的对象（ BookMark / MarkKind ）
int | getObjId() 属性: ObjId 对象ID
int | getObjType() 属性: ObjType 对象类型
CMSObj | getViewer(User _currUser) 取得Viewer对象(User,Group,Role,Contact,ContactGrp)
int | getViewerId() 属性: ViewerId 浏览者ID
int | getViewerType() 属性: ViewerType 浏览者类型
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库
boolean | isValid() 有效性检验
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setObjId(int _objId)
boolean | setObjType(int _objType) setObjType允许的对象类型为两类 OBJ_BOOKMARK OBJ_MARKKIND
void | setViewer(CMSObj _viewer) 设置Viewer（User,Group,Role,Contact,ContactGrp）对象
boolean | setViewerId(int _viewerId)
boolean | setViewerType(int _viewerType) setViewerType允许的对象类型常量为6种 OBJ_USER OBJ_GROUP OBJ_ROLE OBJ_CONTACT OBJ_CONTACTGRP MARKSHARE_STATE_ALLUSER
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

MARKSHARE_STATE_ALLUSER

public static final int MARKSHARE_STATE_ALLUSER
另请参见：
常量字段值
构造方法详细信息

MarkShare

public MarkShare()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getObjType

public int getObjType()
属性: ObjType 对象类型

返回：

setObjType

public boolean setObjType(int _objType)
                   throws WCMException
setObjType允许的对象类型为两类 OBJ_BOOKMARK OBJ_MARKKIND

参数：
_objType -
返回：
抛出：
WCMException

getObjId

public int getObjId()
属性: ObjId 对象ID

返回：

setObjId

public boolean setObjId(int _objId)
                 throws WCMException
抛出：
WCMException

getViewerType

public int getViewerType()
属性: ViewerType 浏览者类型

返回：

setViewerType

public boolean setViewerType(int _viewerType)
                      throws WCMException
setViewerType允许的对象类型常量为6种 OBJ_USER OBJ_GROUP OBJ_ROLE OBJ_CONTACT OBJ_CONTACTGRP MARKSHARE_STATE_ALLUSER

参数：
_viewerType -
返回：
抛出：
WCMException

getViewerId

public int getViewerId()
属性: ViewerId 浏览者ID

返回：

setViewerId

public boolean setViewerId(int _viewerId)
                    throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
属性: Attribute 扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
有效性检验

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

setViewer

public void setViewer(CMSObj _viewer)
               throws WCMException
设置Viewer（User,Group,Role,Contact,ContactGrp）对象

参数：
_viewer -
抛出：
WCMException

getViewer

public CMSObj getViewer(User _currUser)
                 throws WCMException
取得Viewer对象(User,Group,Role,Contact,ContactGrp)

参数：
_currUser -
返回：
抛出：
WCMException

getObject

public CMSObj getObject(User _currUser)
                 throws WCMException
取共享的对象（ BookMark / MarkKind ）

参数：
_currUser -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MarkShares

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.bookmark
类 MarkShares

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.bookmark.MarkShares

public class MarkShares
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MarkShares(User _currUser)
MarkShares(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static MarkShares | createNewInstance(User _currUser) 产生一个当前集合对象[MarkShares]的实例
static MarkShares | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static MarkShares | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MarkShares]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MarkShares

public MarkShares(User _currUser)

MarkShares

public MarkShares(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
抛出：
java.lang.Exception

findByIds

public static final MarkShares findByIds(User _currUser,
                                         java.lang.String _sIds)
                                  throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MarkShares openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[MarkShares]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[MarkShares]
抛出：
WCMException

createNewInstance

public static MarkShares createNewInstance(User _currUser)
                                    throws WCMException
产生一个当前集合对象[MarkShares]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.bookmark
类
BookMark
BookMarkMgr
BookMarks
MarkKind
MarkKinds
MarkShare
MarkShares


com.trs.components.common.bookmark

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.bookmark

类摘要
BookMark |
BookMarkMgr | Title: TRS 内容协作平台（TRS WCM） Description: BookMarkMgr Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BookMarks |
MarkKind |
MarkKinds |
MarkShare |
MarkShares |


com.trs.components.common.bookmark 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.bookmark 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.bookmark.BookMark
        • com.trs.components.common.bookmark.MarkKind
        • com.trs.components.common.bookmark.MarkShare
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.bookmark.BookMarks
        • com.trs.components.common.bookmark.MarkKinds
        • com.trs.components.common.bookmark.MarkShares
    • com.trs.components.common.bookmark.BookMarkMgr


软件包 com.trs.components.common.bookmark 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.bookmark
的使用

使用 com.trs.components.common.bookmark 的软件包
com.trs.components.common.bookmark
com.trs.service
com.trs.service.impl

com.trs.components.common.bookmark 使用的 com.trs.components.common.bookmark 中的类
BookMark
BookMarks
MarkKind
MarkKinds
MarkShares

com.trs.service 使用的 com.trs.components.common.bookmark 中的类
BookMark
BookMarks
MarkKind
MarkKinds

com.trs.service.impl 使用的 com.trs.components.common.bookmark 中的类
BookMark
BookMarks
MarkKind
MarkKinds

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.bookmark.BookMark 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.bookmark.BookMark
的使用

使用 BookMark 的软件包
com.trs.components.common.bookmark
com.trs.service
com.trs.service.impl

com.trs.components.common.bookmark 中 BookMark 的使用

返回 BookMark 的 com.trs.components.common.bookmark 中的方法
static BookMark | BookMark.createNewInstance() 产生当前对象[BookMark]的实例
static BookMark | BookMark.findById(int _nId) 提取指定ID的对象
static BookMark | BookMark.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
BookMark | BookMarks.getByName(java.lang.String _name, int _kind) 通过名称从集合中获取用户对象 若成功，集合指针定位到该元素； 否则，指针指向POS_EOF
BookMark | BookMarkMgr.saveBookMark(BookMark _bookMark) 保存一个书签

参数类型为 BookMark 的 com.trs.components.common.bookmark 中的方法
boolean | BookMarkMgr.deleteBookMark(BookMark _aBookMark) 删除一个书签
void | BookMarkMgr.moveBookMark(BookMark _aBookMark, MarkKind _newParent) 将一个书签从移动新的分类中
BookMark | BookMarkMgr.saveBookMark(BookMark _bookMark) 保存一个书签

com.trs.service 中 BookMark 的使用

返回 BookMark 的 com.trs.service 中的方法
 BookMark IBookMarkService.save(BookMark _aBookMark)
保存一个BookMark

参数类型为 BookMark 的 com.trs.service 中的方法
 BookMark IBookMarkService.save(BookMark _aBookMark)
保存一个BookMark

com.trs.service.impl 中 BookMark 的使用

返回 BookMark 的 com.trs.service.impl 中的方法
 BookMark BookMarkService.save(BookMark _aBookMark)

参数类型为 BookMark 的 com.trs.service.impl 中的方法
 BookMark BookMarkService.save(BookMark _aBookMark)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.bookmark.BookMarkMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.bookmark.BookMarkMgr
的使用

没有 com.trs.components.common.bookmark.BookMarkMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.bookmark.BookMarks 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.bookmark.BookMarks
的使用

使用 BookMarks 的软件包
com.trs.components.common.bookmark
com.trs.service
com.trs.service.impl

com.trs.components.common.bookmark 中 BookMarks 的使用

返回 BookMarks 的 com.trs.components.common.bookmark 中的方法
static BookMarks | BookMarks.createNewInstance(User _currUser) 产生一个当前集合对象[BookMarks]的实例
static BookMarks | BookMarks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
BookMarks | BookMarkMgr.getBookMarks(int _nMarkKindId, WCMFilter _filter) 获取当前登录用户的书签
BookMarks | BookMarkMgr.getBookMarks(MarkKind _markKind, WCMFilter _filter)
BookMarks | MarkKind.getBookMarks(User _currUser) 取所有该类别的书签集合
BookMarks | BookMarkMgr.getBookMarks(WCMFilter _filter)
BookMarks | BookMarkMgr.getSharedBookMarks(User _aUser, WCMFilter _filter) 获取共享给当前登录用户的书签
static BookMarks | BookMarks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[BookMarks]

com.trs.service 中 BookMarks 的使用

返回 BookMarks 的 com.trs.service 中的方法
BookMarks | IBookMarkService.getBookMarks(int _nMarkKindId) 根据传入的MarkKind ID，获取它所包含的BookMarks
BookMarks | IBookMarkService.getBookMarks(int _nMarkKindId, WCMFilter _filter) 根据传入的MarkKind ID，获取它所包含的BookMarks
BookMarks | IBookMarkService.getBookMarks(WCMFilter _filter) 获取BookMarks集合
BookMarks | IBookMarkService.getSharedBookMarks(User _currUser, WCMFilter _fliter) 获取所有共享的书签

com.trs.service.impl 中 BookMarks 的使用

返回 BookMarks 的 com.trs.service.impl 中的方法
BookMarks | BookMarkService.getBookMarks(int _nMarkKindId)
BookMarks | BookMarkService.getBookMarks(int _nMarkKindId, WCMFilter _filter)
BookMarks | BookMarkService.getBookMarks(WCMFilter _filter)
BookMarks | BookMarkService.getSharedBookMarks(User _currUser, WCMFilter _fliter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.bookmark.MarkKind 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.bookmark.MarkKind
的使用

使用 MarkKind 的软件包
com.trs.components.common.bookmark
com.trs.service
com.trs.service.impl

com.trs.components.common.bookmark 中 MarkKind 的使用

返回 MarkKind 的 com.trs.components.common.bookmark 中的方法
static MarkKind | MarkKind.createNewInstance() 产生当前对象[MarkKind]的实例
static MarkKind | MarkKind.findById(int _nId) 提取指定ID的对象
static MarkKind | MarkKind.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
MarkKind | MarkKinds.getByName(java.lang.String _name, int _parentId) 通过名称从集合中获取对象 若成功，集合指针定位到该元素； 否则，指针指向POS_EOF
MarkKind | BookMark.getKind() 取标签类型对象
MarkKind | MarkKind.getParent() 取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。
MarkKind | BookMarkMgr.saveMarkKind(MarkKind _markKind) 保存一个书类别

参数类型为 MarkKind 的 com.trs.components.common.bookmark 中的方法
boolean | BookMarkMgr.deleteMarkKind(MarkKind _aMarkKind) 删除一个书签分类
BookMarks | BookMarkMgr.getBookMarks(MarkKind _markKind, WCMFilter _filter)
MarkKinds | BookMarkMgr.getChildren(MarkKind _parentMarkKind, WCMFilter _filter) 获取当前书签分类的子分类
void | BookMarkMgr.moveBookMark(BookMark _aBookMark, MarkKind _newParent) 将一个书签从移动新的分类中
void | BookMarkMgr.moveMarkKind(MarkKind _markKind, MarkKind _newParent) 移动一个书签类别
MarkKind | BookMarkMgr.saveMarkKind(MarkKind _markKind) 保存一个书类别
boolean | BookMark.setKind(MarkKind _markKind)
boolean | MarkKind.setParent(MarkKind _parent)

com.trs.service 中 MarkKind 的使用

返回 MarkKind 的 com.trs.service 中的方法
 MarkKind IBookMarkService.save(MarkKind _aMarkKind)
保存一个MarkKind

参数类型为 MarkKind 的 com.trs.service 中的方法
 MarkKind IBookMarkService.save(MarkKind _aMarkKind)
保存一个MarkKind

com.trs.service.impl 中 MarkKind 的使用

返回 MarkKind 的 com.trs.service.impl 中的方法
 MarkKind BookMarkService.save(MarkKind _aMarkKind)

参数类型为 MarkKind 的 com.trs.service.impl 中的方法
 MarkKind BookMarkService.save(MarkKind _aMarkKind)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.bookmark.MarkKinds 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.bookmark.MarkKinds
的使用

使用 MarkKinds 的软件包
com.trs.components.common.bookmark
com.trs.service
com.trs.service.impl

com.trs.components.common.bookmark 中 MarkKinds 的使用

返回 MarkKinds 的 com.trs.components.common.bookmark 中的方法
static MarkKinds | MarkKinds.createNewInstance(User _currUser) 产生一个当前集合对象[MarkKinds]的实例
static MarkKinds | MarkKinds.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
MarkKinds | BookMarkMgr.getChildren(MarkKind _parentMarkKind, WCMFilter _filter) 获取当前书签分类的子分类
MarkKinds | BookMarkMgr.getMarkKinds(WCMFilter _filter) 获取当前登录用户的顶级书签分类
MarkKinds | BookMarkMgr.getSharedMarkKinds(User _aUser, WCMFilter _filter) 获取共享给当前登录用户的书签分类
static MarkKinds | MarkKinds.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MarkKinds]

com.trs.service 中 MarkKinds 的使用

返回 MarkKinds 的 com.trs.service 中的方法
MarkKinds | IBookMarkService.getChildren(int _nMarkKindId, WCMFilter _filter) 根据传入的MarkKind ID，获取它的子MarkKinds
MarkKinds | IBookMarkService.getSharedMarkKinds(User _currUser, WCMFilter _filter) 获取所有共享的书签文件夹

com.trs.service.impl 中 MarkKinds 的使用

返回 MarkKinds 的 com.trs.service.impl 中的方法
MarkKinds | BookMarkService.getChildren(int _nMarkKindId, WCMFilter _filter)
MarkKinds | BookMarkService.getSharedMarkKinds(User _currUser, WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.bookmark.MarkShare 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.bookmark.MarkShare
的使用

没有 com.trs.components.common.bookmark.MarkShare 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.bookmark.MarkShares 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.bookmark.MarkShares
的使用

使用 MarkShares 的软件包
com.trs.components.common.bookmark

com.trs.components.common.bookmark 中 MarkShares 的使用

返回 MarkShares 的 com.trs.components.common.bookmark 中的方法
static MarkShares | MarkShares.createNewInstance(User _currUser) 产生一个当前集合对象[MarkShares]的实例
static MarkShares | MarkShares.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
MarkShares | MarkKind.getMarkShares(User _currUser) 得到MarkShares
MarkShares | BookMark.getMarkShares(User _currUser) 得到MarkShares
MarkShares | BookMarkMgr.getShareMarks(WCMFilter _filter) 获取当前登录用户可访问的共享书签
static MarkShares | MarkShares.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MarkShares]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Event

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 Event

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.calendar.Event
所有已实现的接口：
java.lang.Cloneable
public class Event
extends CMSObj

字段摘要
static int[] | ALL_REMIND_TYPES
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE 常量定义
构造方法摘要
Event()
方法摘要
static Event | createNewInstance() 产生当前对象[Event]的实例
static Event | findById(int _nId) 提取指定ID的对象
static Event | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getAheadRemindTime() 属性: AheadRemindTime 提前提醒的时间
java.lang.String | getAttribute() 属性: Attribute 扩展属性
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
java.lang.String | getDesc() 属性: Desc 详细描述
java.lang.String | getEmail() 属性: Email 若有多个邮件，则用","分割
CMyDateTime | getEndTime() property: EndTime 结束时间
java.lang.String | getIdFieldName() 获得Id字段名。
User | getOwner()
java.lang.String | getOwnerName() 属性：Owner 拥有者
int | getRemindMsgId()
java.lang.String | getSendTypes()
CMyDateTime | getStartTime() property: StartTime 开始时间
java.lang.String | getTitle() 属性: Title 标题
EventType | getType()
int | getTypeId() 属性: Type 类型
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库
boolean | isRemindBy(int _nRemindType) 是否按指定类型提醒 参数：_nRemindType 提醒类型（常量定义：WCMTypes.REMIND_ONLINE等）
boolean | isRemindDone(int _nRemindType) 指定类型的提醒是否已经完成 参数：_nRemindType 提醒类型（常量定义：WCMTypes.REMIND_ONLINE等）
boolean | isShared() 属性: isShareed 是否共享
boolean | isValid() TITLE暂时定为可以重复
boolean | setAheadRemindTime(int _nAheadRemindTime)
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setDesc(java.lang.String _desc)
boolean | setEmail(java.lang.String _email)
boolean | setEndTime(CMyDateTime _time)
boolean | setOwner(java.lang.String _ownerName)
boolean | setOwner(User _owner)
boolean | setRemindBy(int _nRemindType, boolean _bIfRemind)
boolean | setRemindDone(int _nRemindType) 置指定类型的提醒已经完成 说明：若当前提醒设置不是WCMTypes.YES，则抛出无效操作异常
boolean | setShare(boolean _bShared)
boolean | setStartTime(CMyDateTime _time)
boolean | setTitle(java.lang.String _title)
boolean | setType(EventType _type)
boolean | setType(int _typeId)
void | update(User _user) 重载父类接口，以处理提醒Job
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

ALL_REMIND_TYPES

public static final int[] ALL_REMIND_TYPES
构造方法详细信息

Event

public Event()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getTitle

public java.lang.String getTitle()
属性: Title 标题

返回：

setTitle

public boolean setTitle(java.lang.String _title)
                 throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()
属性: Desc 详细描述

返回：

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
抛出：
WCMException

getTypeId

public int getTypeId()
属性: Type 类型

返回：

getType

public EventType getType()
                  throws WCMException
抛出：
WCMException

setType

public boolean setType(int _typeId)
                throws WCMException
抛出：
WCMException

setType

public boolean setType(EventType _type)
                throws WCMException
抛出：
WCMException

getOwnerName

public java.lang.String getOwnerName()
属性：Owner 拥有者

返回：

getOwner

public User getOwner()

setOwner

public boolean setOwner(java.lang.String _ownerName)
                 throws WCMException
抛出：
WCMException

setOwner

public boolean setOwner(User _owner)
                 throws WCMException
抛出：
WCMException

getStartTime

public CMyDateTime getStartTime()
property: StartTime 开始时间

返回：

setStartTime

public boolean setStartTime(CMyDateTime _time)
                     throws WCMException
抛出：
WCMException

getEndTime

public CMyDateTime getEndTime()
property: EndTime 结束时间

返回：

setEndTime

public boolean setEndTime(CMyDateTime _time)
                   throws WCMException
抛出：
WCMException

isRemindBy

public boolean isRemindBy(int _nRemindType)
                   throws WCMException
是否按指定类型提醒 参数：_nRemindType 提醒类型（常量定义：WCMTypes.REMIND_ONLINE等）

参数：
_nRemindType -
返回：
@throws WCMException
抛出：
WCMException

getSendTypes

public java.lang.String getSendTypes()
                              throws WCMException
抛出：
WCMException

setRemindBy

public boolean setRemindBy(int _nRemindType,
                           boolean _bIfRemind)
                    throws WCMException
抛出：
WCMException

isRemindDone

public boolean isRemindDone(int _nRemindType)
                     throws WCMException
指定类型的提醒是否已经完成 参数：_nRemindType 提醒类型（常量定义：WCMTypes.REMIND_ONLINE等）

参数：
_nRemindType -
返回：
@throws WCMException
抛出：
WCMException

setRemindDone

public boolean setRemindDone(int _nRemindType)
                      throws WCMException
置指定类型的提醒已经完成 说明：若当前提醒设置不是WCMTypes.YES，则抛出无效操作异常

参数：
_nRemindType -
返回：
@throws WCMException
抛出：
WCMException

getAheadRemindTime

public int getAheadRemindTime()
属性: AheadRemindTime 提前提醒的时间

返回：

setAheadRemindTime

public boolean setAheadRemindTime(int _nAheadRemindTime)
                           throws WCMException
抛出：
WCMException

isShared

public boolean isShared()
属性: isShareed 是否共享

返回：

setShare

public boolean setShare(boolean _bShared)
                 throws WCMException
抛出：
WCMException

getEmail

public java.lang.String getEmail()
属性: Email 若有多个邮件，则用","分割

返回：

setEmail

public boolean setEmail(java.lang.String _email)
                 throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
属性: Attribute 扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
TITLE暂时定为可以重复

指定者：
类 BaseObj 中的 isValid
返回：
@throws WCMException
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

update

public void update(User _user)
            throws WCMException
重载父类接口，以处理提醒Job

覆盖：
类 CMSObj 中的 update
参数：
_user -
抛出：
WCMException

getRemindMsgId

public int getRemindMsgId()

findById

public static final Event findById(int _nId)
                            throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Event createNewInstance()
                                     throws WCMException
产生当前对象[Event]的实例

返回：
当前对象的实例[Event]
抛出：
WCMException

findByKey

public static final Event findByKey(java.lang.Object _oKey)
                             throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


EventLCListenerForRemind

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 EventLCListenerForRemind

java.lang.Object
    继承者  com.trs.components.common.calendar.EventLCListenerForRemind
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class EventLCListenerForRemind
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
日程提醒消息的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
EventLCListenerForRemind()
方法摘要
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventLCListenerForRemind

public EventLCListenerForRemind()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 EventMgr

java.lang.Object
    继承者  com.trs.components.common.calendar.EventMgr

public class EventMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
日程管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
EventMgr()
方法摘要
void | cancelShare(Event _anEvent, CMSObj _cmsObj) 取消对象某用户/组织的一个日程安排
void | cancelShares(Event _anEvent) 取消指定的Event所有指派
boolean | delete(Event _anEvent) 删除指定的Event
Events | getDailyEvents(CMyDateTime _date, WCMFilter _filter) 获取当前用户在指定日期的日程安排
Events | getEvents(User _currUser, CMyDateTime _date, boolean _bIncludingShared, WCMFilter _filter)
Events | getEvents(WCMFilter _filter) 获取系统中的日程安排
Groups | getGroups(Event _anEvent) 获取共享指定日程安排的所有组织
Users | getUsers(Event _anEvent) 获取共享指定日程安排的所有用户
Event | save(Event _anEvent) 保存日程安排
void | shareTo(Event _anEvent, CMSObj _cmsObj)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventMgr

public EventMgr()
方法详细信息

save

public Event save(Event _anEvent)
           throws WCMException
保存日程安排

参数：
_anEvent - 要保存的日程安排
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(Event _anEvent)
               throws WCMException
删除指定的Event

参数：
_anEvent - 要删除的Event
返回：
@throws WCMException
抛出：
WCMException

getDailyEvents

public Events getDailyEvents(CMyDateTime _date,
                             WCMFilter _filter)
                      throws WCMException
获取当前用户在指定日期的日程安排

参数：
_date - 指定的日期
_filter - 过滤器,额外的查询
返回：
@throws WCMException
抛出：
WCMException

getEvents

public Events getEvents(User _currUser,
                        CMyDateTime _date,
                        boolean _bIncludingShared,
                        WCMFilter _filter)
                 throws WCMException
抛出：
WCMException

getUsers

public Users getUsers(Event _anEvent)
               throws WCMException
获取共享指定日程安排的所有用户

参数：
_anEvent - 指定日程
返回：
@throws WCMException
抛出：
WCMException

getGroups

public Groups getGroups(Event _anEvent)
                 throws WCMException
获取共享指定日程安排的所有组织

参数：
_anEvent - 指定日程安排
返回：
@throws WCMException
抛出：
WCMException

getEvents

public Events getEvents(WCMFilter _filter)
                 throws WCMException
获取系统中的日程安排

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

shareTo

public void shareTo(Event _anEvent,
                    CMSObj _cmsObj)
             throws WCMException
抛出：
WCMException

cancelShare

public void cancelShare(Event _anEvent,
                        CMSObj _cmsObj)
                 throws WCMException
取消对象某用户/组织的一个日程安排

参数：
_anEvent - 指定日程安排
_cmsObj - 指定的用户/组织
抛出：
WCMException

cancelShares

public void cancelShares(Event _anEvent)
                  throws WCMException
取消指定的Event所有指派

参数：
_anEvent - 指定的Event
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Events

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 Events

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.calendar.Events

public class Events
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Events(User _currUser)
Events(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static Events | createNewInstance(User _currUser) 产生一个当前集合对象[Events]的实例
static Events | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Events | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Events]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Events

public Events(User _currUser)

Events

public Events(User _currUser,
              int _initCapacity,
              int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
抛出：
java.lang.Exception

findByIds

public static final Events findByIds(User _currUser,
                                     java.lang.String _sIds)
                              throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Events openWCMObjs(User _currUser,
                                       WCMFilter _filter)
                                throws WCMException
通过指定一个Filter获取当前集合[Events]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[Events]
抛出：
WCMException

createNewInstance

public static Events createNewInstance(User _currUser)
                                throws WCMException
产生一个当前集合对象[Events]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventShare

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 EventShare

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.calendar.EventShare
所有已实现的接口：
java.lang.Cloneable
public class EventShare
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
EventShare()
构造函数：保留默认接口
方法摘要
static EventShare | createNewInstance() 产生当前对象[EventShare]的实例
static EventShare | findById(int _nId) 提取指定ID的对象
static EventShare | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getEventId() 提取属性：EventId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getObjId() 提取属性：ObjId
int | getObjType() 提取属性：ObjType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setEventId(int _nEventId) 设置属性：EventId
boolean | setObjId(int _nObjId) 设置属性：ObjId
boolean | setObjType(int _nObjType) 设置属性：ObjType
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

EventShare

public EventShare()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getEventId

public int getEventId()
提取属性：EventId

返回：
EventId

setEventId

public boolean setEventId(int _nEventId)
                   throws WCMException
设置属性：EventId

参数：
_nEventId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

public int getObjId()
提取属性：ObjId

返回：
ObjId

setObjId

public boolean setObjId(int _nObjId)
                 throws WCMException
设置属性：ObjId

参数：
_nObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjType

public int getObjType()
提取属性：ObjType

返回：
ObjType

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
设置属性：ObjType

参数：
_nObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final EventShare findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final EventShare createNewInstance()
                                          throws WCMException
产生当前对象[EventShare]的实例

返回：
当前对象的实例[EventShare]
抛出：
WCMException

findByKey

public static final EventShare findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventShareIdsMan

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 EventShareIdsMan

java.lang.Object
    继承者  com.trs.infra.common.BaseIdsMan
        继承者  com.trs.components.common.calendar.EventShareIdsMan

public class EventShareIdsMan
extends BaseIdsMan

Title: TRS 内容协作平台（TRS WCM）
Description:
日程共享管理:处理共享日程时,维护指定的日程安排与共享者的关联关系
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
EventShareIdsMan(int _nEventId, int _nSharerType)
方法摘要
从类 com.trs.infra.common.BaseIdsMan 继承的方法
dowithIds
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventShareIdsMan

public EventShareIdsMan(int _nEventId,
                        int _nSharerType)
                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventShares

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 EventShares

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.calendar.EventShares

public class EventShares
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
EventShares(User _currUser)
构造函数
EventShares(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static EventShares | creatNewInstance(User _currUser) 产生一个当前集合对象[EventShares]的实例
static EventShares | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static EventShares | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[EventShares]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventShares

public EventShares(User _currUser)
构造函数

另请参见：
EventShares( User _currUser, int _initCapacity, int _incCapacity );

EventShares

public EventShares(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final EventShares findByIds(User _currUser,
                                          java.lang.String _sIds)
                                   throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final EventShares openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[EventShares]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[EventShares]
抛出：
WCMException

creatNewInstance

public static EventShares creatNewInstance(User _currUser)
                                    throws WCMException
产生一个当前集合对象[EventShares]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 EventType

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.calendar.EventType
所有已实现的接口：
java.lang.Cloneable
public class EventType
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE 常量定义
static int | TYPE_FLOW_EVENT
构造方法摘要
EventType()
方法摘要
static EventType | createNewInstance() 产生当前对象[EventType]的实例
static EventType | findById(int _nId) 提取指定ID的对象
static EventType | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 重载父类中的抽象接口函数
java.lang.String | getDesc() Desc: 详细描述
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName() Name: 名称
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isValid() 检查对象数据的有效性
boolean | setDesc(java.lang.String _desc)
boolean | setName(java.lang.String _name) 名称要求不重 处理：由函数isValid()检查，并区分大小写
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

TYPE_FLOW_EVENT

public static final int TYPE_FLOW_EVENT
另请参见：
常量字段值
构造方法详细信息

EventType

public EventType()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getName

public java.lang.String getName()
Name: 名称

返回：

setName

public boolean setName(java.lang.String _name)
                throws WCMException
名称要求不重 处理：由函数isValid()检查，并区分大小写

参数：
_name -
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
Desc: 详细描述

返回：

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

findById

public static final EventType findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final EventType createNewInstance()
                                         throws WCMException
产生当前对象[EventType]的实例

返回：
当前对象的实例[EventType]
抛出：
WCMException

findByKey

public static final EventType findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventTypes

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.calendar
类 EventTypes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.calendar.EventTypes

public class EventTypes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
EventTypes(User _currUser)
EventTypes(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventTypes

public EventTypes(User _currUser)

EventTypes

public EventTypes(User _currUser,
                  int initialCapacity,
                  int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.calendar
类
Event
EventLCListenerForRemind
EventMgr
Events
EventShare
EventShareIdsMan
EventShares
EventType
EventTypes


com.trs.components.common.calendar

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.calendar

类摘要
Event |
EventLCListenerForRemind | Title: TRS 内容协作平台（TRS WCM） Description: 日程提醒消息的监听 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
EventMgr | Title: TRS 内容协作平台（TRS WCM） Description: 日程管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Events |
EventShare |
EventShareIdsMan | Title: TRS 内容协作平台（TRS WCM） Description: 日程共享管理:处理共享日程时,维护指定的日程安排与共享者的关联关系 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
EventShares |
EventType |
EventTypes |


com.trs.components.common.calendar 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.calendar 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.common.BaseIdsMan
      • com.trs.components.common.calendar.EventShareIdsMan
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.calendar.Event
        • com.trs.components.common.calendar.EventShare
        • com.trs.components.common.calendar.EventType
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.calendar.Events
        • com.trs.components.common.calendar.EventShares
        • com.trs.components.common.calendar.EventTypes
    • com.trs.components.common.calendar.EventLCListenerForRemind (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.calendar.EventMgr


软件包 com.trs.components.common.calendar 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.calendar
的使用

使用 com.trs.components.common.calendar 的软件包
com.trs.components.common.calendar
com.trs.service
com.trs.service.impl

com.trs.components.common.calendar 使用的 com.trs.components.common.calendar 中的类
Event
Events
EventShare
EventShares
EventType

com.trs.service 使用的 com.trs.components.common.calendar 中的类
Event
Events

com.trs.service.impl 使用的 com.trs.components.common.calendar 中的类
Event
Events

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.Event 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.Event
的使用

使用 Event 的软件包
com.trs.components.common.calendar
com.trs.service
com.trs.service.impl

com.trs.components.common.calendar 中 Event 的使用

返回 Event 的 com.trs.components.common.calendar 中的方法
static Event | Event.createNewInstance() 产生当前对象[Event]的实例
static Event | Event.findById(int _nId) 提取指定ID的对象
static Event | Event.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Event | EventMgr.save(Event _anEvent) 保存日程安排

参数类型为 Event 的 com.trs.components.common.calendar 中的方法
void | EventMgr.cancelShare(Event _anEvent, CMSObj _cmsObj) 取消对象某用户/组织的一个日程安排
void | EventMgr.cancelShares(Event _anEvent) 取消指定的Event所有指派
boolean | EventMgr.delete(Event _anEvent) 删除指定的Event
Groups | EventMgr.getGroups(Event _anEvent) 获取共享指定日程安排的所有组织
Users | EventMgr.getUsers(Event _anEvent) 获取共享指定日程安排的所有用户
Event | EventMgr.save(Event _anEvent) 保存日程安排
void | EventMgr.shareTo(Event _anEvent, CMSObj _cmsObj)

com.trs.service 中 Event 的使用

返回 Event 的 com.trs.service 中的方法
 Event IEventService.save(Event _aEvent)
保存一个Event

参数类型为 Event 的 com.trs.service 中的方法
void | IEventService.cancelShare(Event _aEvent, Group _assignToGroup) 取消指派给另外一个组织的Event
void | IEventService.cancelShare(Event _aEvent, User _assignToUser) 取消指派给另外一个用户的Event
void | IEventService.cancelShare(Event _aEvent, Users _assignToUsers) 取消指派给一个用户集合的Event
void | IEventService.cancelShares(Event _aEvent) 取消所有共享
boolean | IEventService.delete(Event _aEvent) 根据指定的Event对象进行删除操作
Groups | IEventService.getSharedGroups(Event _aEvent) 获取一个Event被AssignTo的Group
Users | IEventService.getSharedUsers(Event _aEvent) 获取一个Event被AssignTo的Users
Event | IEventService.save(Event _aEvent) 保存一个Event
void | IEventService.shareTo(Event _aEvent, Group _assignToGroup) 当前用户把一个Event指派给一个组织
void | IEventService.shareTo(Event _aEvent, Groups _assignToGroups)
void | IEventService.shareTo(Event _aEvent, java.lang.String _sUserIds)
void | IEventService.shareTo(Event _aEvent, User _assignToUser) 当前用户把一个Event指派给另外一个用户
void | IEventService.shareTo(Event _aEvent, Users _assignToUsers) 把一个Event指派给一个用户集合

com.trs.service.impl 中 Event 的使用

返回 Event 的 com.trs.service.impl 中的方法
 Event EventService.save(Event _aEvent)

参数类型为 Event 的 com.trs.service.impl 中的方法
void | EventService.cancelShare(Event _aEvent, Group _assignToGroup)
void | EventService.cancelShare(Event _aEvent, User _assignToUser)
void | EventService.cancelShare(Event _aEvent, Users _assignToUsers)
void | EventService.cancelShares(Event _aEvent)
boolean | EventService.delete(Event _aEvent)
Groups | EventService.getSharedGroups(Event _aEvent)
Users | EventService.getSharedUsers(Event _aEvent)
Event | EventService.save(Event _aEvent)
void | EventService.shareEventTo(Event _eventToShare, java.lang.String _sSharerIds, int _nSharerType) 共享日程给指定的共享者
void | EventService.shareTo(Event _aEvent, Group _assignToGroup)
void | EventService.shareTo(Event _aEvent, Groups _assignToGroups)
void | EventService.shareTo(Event _aEvent, java.lang.String _sUserIds)
void | EventService.shareTo(Event _aEvent, User _assignToUser)
void | EventService.shareTo(Event _aEvent, Users _assignToUsers)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.EventLCListenerForRemind 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.EventLCListenerForRemind
的使用

没有 com.trs.components.common.calendar.EventLCListenerForRemind 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.EventMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.EventMgr
的使用

没有 com.trs.components.common.calendar.EventMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.Events 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.Events
的使用

使用 Events 的软件包
com.trs.components.common.calendar
com.trs.service
com.trs.service.impl

com.trs.components.common.calendar 中 Events 的使用

返回 Events 的 com.trs.components.common.calendar 中的方法
static Events | Events.createNewInstance(User _currUser) 产生一个当前集合对象[Events]的实例
static Events | Events.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Events | EventMgr.getDailyEvents(CMyDateTime _date, WCMFilter _filter) 获取当前用户在指定日期的日程安排
Events | EventMgr.getEvents(User _currUser, CMyDateTime _date, boolean _bIncludingShared, WCMFilter _filter)
Events | EventMgr.getEvents(WCMFilter _filter) 获取系统中的日程安排
static Events | Events.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Events]

com.trs.service 中 Events 的使用

返回 Events 的 com.trs.service 中的方法
Events | IEventService.getEvents(WCMFilter _filter) 根据指定的filter获取Events
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date) 获取用户在指定日期内被Assign的所有Events
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll) 获取用户在指定日期内私有的或公有的Events
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter) 获取用户在指定filter限制下被Assign的Events

参数类型为 Events 的 com.trs.service 中的方法
 boolean IEventService.delete(Events _aEvents)
根据指定的Events对象进行删除操作

com.trs.service.impl 中 Events 的使用

返回 Events 的 com.trs.service.impl 中的方法
Events | EventService.getEvents(WCMFilter _filter)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter)

参数类型为 Events 的 com.trs.service.impl 中的方法
 boolean EventService.delete(Events _anEvents)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.EventShare 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.EventShare
的使用

使用 EventShare 的软件包
com.trs.components.common.calendar

com.trs.components.common.calendar 中 EventShare 的使用

返回 EventShare 的 com.trs.components.common.calendar 中的方法
static EventShare | EventShare.createNewInstance() 产生当前对象[EventShare]的实例
static EventShare | EventShare.findById(int _nId) 提取指定ID的对象
static EventShare | EventShare.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.EventShareIdsMan 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.EventShareIdsMan
的使用

没有 com.trs.components.common.calendar.EventShareIdsMan 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.EventShares 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.EventShares
的使用

使用 EventShares 的软件包
com.trs.components.common.calendar

com.trs.components.common.calendar 中 EventShares 的使用

返回 EventShares 的 com.trs.components.common.calendar 中的方法
static EventShares | EventShares.creatNewInstance(User _currUser) 产生一个当前集合对象[EventShares]的实例
static EventShares | EventShares.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static EventShares | EventShares.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[EventShares]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.EventType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.EventType
的使用

使用 EventType 的软件包
com.trs.components.common.calendar

com.trs.components.common.calendar 中 EventType 的使用

返回 EventType 的 com.trs.components.common.calendar 中的方法
static EventType | EventType.createNewInstance() 产生当前对象[EventType]的实例
static EventType | EventType.findById(int _nId) 提取指定ID的对象
static EventType | EventType.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
EventType | Event.getType()

参数类型为 EventType 的 com.trs.components.common.calendar 中的方法
 boolean Event.setType(EventType _type)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.calendar.EventTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.calendar.EventTypes
的使用

没有 com.trs.components.common.calendar.EventTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ComponentEntryConfigConstants

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.conjection
类 ComponentEntryConfigConstants

java.lang.Object
    继承者  com.trs.components.common.conjection.ComponentEntryConfigConstants

public final class ComponentEntryConfigConstants
extends java.lang.Object

字段摘要
static int | TYPE_ADVERTISEMENT
static int | TYPE_COMMENT
static int | TYPE_INFOGATE
static int | TYPE_INTERVIEW
static int | TYPE_POLL
static int | TYPE_SUBSCRIBE
构造方法摘要
ComponentEntryConfigConstants()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_POLL

public static final int TYPE_POLL
另请参见：
常量字段值

TYPE_COMMENT

public static final int TYPE_COMMENT
另请参见：
常量字段值

TYPE_ADVERTISEMENT

public static final int TYPE_ADVERTISEMENT
另请参见：
常量字段值

TYPE_INFOGATE

public static final int TYPE_INFOGATE
另请参见：
常量字段值

TYPE_SUBSCRIBE

public static final int TYPE_SUBSCRIBE
另请参见：
常量字段值

TYPE_INTERVIEW

public static final int TYPE_INTERVIEW
另请参见：
常量字段值
构造方法详细信息

ComponentEntryConfigConstants

public ComponentEntryConfigConstants()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.conjection
类
ComponentEntryConfigConstants


com.trs.components.common.conjection

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.conjection

类摘要
ComponentEntryConfigConstants


com.trs.components.common.conjection 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.conjection 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.conjection.ComponentEntryConfigConstants


软件包 com.trs.components.common.conjection 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.conjection
的使用

没有 com.trs.components.common.conjection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.conjection.ComponentEntryConfigConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.conjection.ComponentEntryConfigConstants
的使用

没有 com.trs.components.common.conjection.ComponentEntryConfigConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


HttpChecker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.conjection.helper
类 HttpChecker

java.lang.Object
    继承者  com.trs.components.common.conjection.helper.HttpChecker

public class HttpChecker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
HttpChecker()
方法摘要
static int | getResponseCodeForHttp(java.lang.String _sTargetUrl)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HttpChecker

public HttpChecker()
方法详细信息

getResponseCodeForHttp

public static int getResponseCodeForHttp(java.lang.String _sTargetUrl)
                                  throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.conjection.helper
类
HttpChecker


com.trs.components.common.conjection.helper

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.conjection.helper

类摘要
HttpChecker Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.conjection.helper 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.conjection.helper 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.conjection.helper.HttpChecker


软件包 com.trs.components.common.conjection.helper 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.conjection.helper
的使用

没有 com.trs.components.common.conjection.helper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.conjection.helper.HttpChecker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.conjection.helper.HttpChecker
的使用

没有 com.trs.components.common.conjection.helper.HttpChecker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


EntryConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.conjection.persistent
类 EntryConfig

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.conjection.persistent.EntryConfig
所有已实现的接口：
java.lang.Cloneable
public class EntryConfig
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
EntryConfig()
构造函数：保留默认接口
方法摘要
static EntryConfig | createNewInstance() 产生当前对象[EntryConfig]的实例
static EntryConfig | findById(int _nId) 提取指定ID的对象
static EntryConfig | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDescription() 提取属性：Description
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getLinkPath() 提取属性：LinkPath
int | getType() 提取属性：Type
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isEnable() 提取属性：Enable
boolean | isEnterDirectly() 提取属性：EnterDirectly
boolean | isValid() 检验对象数据有效性
boolean | setDescription(java.lang.String _sDescription) 设置属性：Description
boolean | setEnable(boolean _bEnable) 设置属性：Enable
boolean | setEnterDirectly(boolean _bEnterDirectly) 设置属性：EnterDirectly
boolean | setLinkPath(java.lang.String _sLinkPath) 设置属性：LinkPath
boolean | setType(int _nType) 设置属性：Type
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

EntryConfig

public EntryConfig()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

isEnable

public boolean isEnable()
提取属性：Enable

返回：
Enable

setEnable

public boolean setEnable(boolean _bEnable)
                  throws WCMException
设置属性：Enable

参数：
_bEnable - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLinkPath

public java.lang.String getLinkPath()
提取属性：LinkPath

返回：
LinkPath

setLinkPath

public boolean setLinkPath(java.lang.String _sLinkPath)
                    throws WCMException
设置属性：LinkPath

参数：
_sLinkPath - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDescription

public java.lang.String getDescription()
提取属性：Description

返回：
Description

setDescription

public boolean setDescription(java.lang.String _sDescription)
                       throws WCMException
设置属性：Description

参数：
_sDescription - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isEnterDirectly

public boolean isEnterDirectly()
提取属性：EnterDirectly

返回：
EnterDirectly

setEnterDirectly

public boolean setEnterDirectly(boolean _bEnterDirectly)
                         throws WCMException
设置属性：EnterDirectly

参数：
_bEnterDirectly - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getType

public int getType()
提取属性：Type

返回：
Type

setType

public boolean setType(int _nType)
                throws WCMException
设置属性：Type

参数：
__nType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final EntryConfig findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final EntryConfig createNewInstance()
                                           throws WCMException
产生当前对象[EntryConfig]的实例

返回：
当前对象的实例[EntryConfig]
抛出：
WCMException

findByKey

public static final EntryConfig findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


EntryConfigs

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.conjection.persistent
类 EntryConfigs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.conjection.persistent.EntryConfigs

public class EntryConfigs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
EntryConfigs(User _currUser)
构造函数
EntryConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static EntryConfigs | createNewInstance(User _currUser) 产生当前集合对象[EntryConfigs]的实例
static EntryConfigs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static EntryConfigs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[EntryConfigs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EntryConfigs

public EntryConfigs(User _currUser)
构造函数

另请参见：
EntryConfigs( User _currUser, int _initCapacity, int _incCapacity );

EntryConfigs

public EntryConfigs(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final EntryConfigs findByIds(User _currUser,
                                           java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（EntryConfigs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final EntryConfigs openWCMObjs(User _currUser,
                                             WCMFilter _filter)
                                      throws WCMException
通过指定一个Filter获取当前集合[EntryConfigs]

参数：
_filter - 指定的Filter
返回：
当前集合[EntryConfigs]
抛出：
WCMException

createNewInstance

public static EntryConfigs createNewInstance(User _currUser)
产生当前集合对象[EntryConfigs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.conjection.persistent
类
EntryConfig
EntryConfigs


com.trs.components.common.conjection.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.conjection.persistent

类摘要
EntryConfig
EntryConfigs


com.trs.components.common.conjection.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.conjection.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.conjection.persistent.EntryConfig
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.conjection.persistent.EntryConfigs


软件包 com.trs.components.common.conjection.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.conjection.persistent
的使用

使用 com.trs.components.common.conjection.persistent 的软件包
com.trs.components.common.conjection.persistent
com.trs.components.common.conjection.service

com.trs.components.common.conjection.persistent 使用的 com.trs.components.common.conjection.persistent 中的类
EntryConfig
EntryConfigs

com.trs.components.common.conjection.service 使用的 com.trs.components.common.conjection.persistent 中的类
EntryConfig

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.conjection.persistent.EntryConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.conjection.persistent.EntryConfig
的使用

使用 EntryConfig 的软件包
com.trs.components.common.conjection.persistent
com.trs.components.common.conjection.service

com.trs.components.common.conjection.persistent 中 EntryConfig 的使用

返回 EntryConfig 的 com.trs.components.common.conjection.persistent 中的方法
static EntryConfig | EntryConfig.createNewInstance() 产生当前对象[EntryConfig]的实例
static EntryConfig | EntryConfig.findById(int _nId) 提取指定ID的对象
static EntryConfig | EntryConfig.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.components.common.conjection.service 中 EntryConfig 的使用

返回 EntryConfig 的 com.trs.components.common.conjection.service 中的方法
EntryConfig | IComponentEntryConfigService.getEntryConfig(int _nEntryId)
EntryConfig | ComponentEntryConfigServiceImpl.getEntryConfig(int _nEntryId)
EntryConfig | IComponentEntryConfigService.getTypedEntryConfig(int _nEntryType)
EntryConfig | ComponentEntryConfigServiceImpl.getTypedEntryConfig(int _nEntryType)

参数类型为 EntryConfig 的 com.trs.components.common.conjection.service 中的方法
void | IComponentEntryConfigService.saveComponentConfigInfo(EntryConfig _oEntry)
void | ComponentEntryConfigServiceImpl.saveComponentConfigInfo(EntryConfig _oEntry)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.conjection.persistent.EntryConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.conjection.persistent.EntryConfigs
的使用

使用 EntryConfigs 的软件包
com.trs.components.common.conjection.persistent

com.trs.components.common.conjection.persistent 中 EntryConfigs 的使用

返回 EntryConfigs 的 com.trs.components.common.conjection.persistent 中的方法
static EntryConfigs | EntryConfigs.createNewInstance(User _currUser) 产生当前集合对象[EntryConfigs]的实例
static EntryConfigs | EntryConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static EntryConfigs | EntryConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[EntryConfigs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AdmanageConfigServiceImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.conjection.service
类 AdmanageConfigServiceImpl

java.lang.Object
    继承者  com.trs.components.common.conjection.service.AdmanageConfigServiceImpl
所有已实现的接口：
IAdmanageConfigService
public class AdmanageConfigServiceImpl
extends java.lang.Object
implements IAdmanageConfigService

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AdmanageConfigServiceImpl()
方法摘要
java.lang.String | getAdManagerLinkPath()
boolean | isAdManagerEnable()
void | updateAdManageService()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdmanageConfigServiceImpl

public AdmanageConfigServiceImpl()
方法详细信息

isAdManagerEnable

public boolean isAdManagerEnable()
                          throws WCMException
指定者：
接口 IAdmanageConfigService 中的 isAdManagerEnable
抛出：
WCMException

updateAdManageService

public void updateAdManageService()
                           throws WCMException
指定者：
接口 IAdmanageConfigService 中的 updateAdManageService
抛出：
WCMException

getAdManagerLinkPath

public java.lang.String getAdManagerLinkPath()
                                      throws WCMException
指定者：
接口 IAdmanageConfigService 中的 getAdManagerLinkPath
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ComponentEntryConfigServiceImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.conjection.service
类 ComponentEntryConfigServiceImpl

java.lang.Object
    继承者  com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl
所有已实现的接口：
IComponentEntryConfigService
public class ComponentEntryConfigServiceImpl
extends java.lang.Object
implements IComponentEntryConfigService

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ComponentEntryConfigServiceImpl()
方法摘要
EntryConfig | getEntryConfig(int _nEntryId)
EntryConfig | getTypedEntryConfig(int _nEntryType)
void | saveComponentConfigInfo(EntryConfig _oEntry)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComponentEntryConfigServiceImpl

public ComponentEntryConfigServiceImpl()
方法详细信息

getEntryConfig

public EntryConfig getEntryConfig(int _nEntryId)
                           throws WCMException
指定者：
接口 IComponentEntryConfigService 中的 getEntryConfig
返回：
抛出：
WCMException

saveComponentConfigInfo

public void saveComponentConfigInfo(EntryConfig _oEntry)
                             throws WCMException
指定者：
接口 IComponentEntryConfigService 中的 saveComponentConfigInfo
参数：
_oEntry - TODO
抛出：
WCMException

getTypedEntryConfig

public EntryConfig getTypedEntryConfig(int _nEntryType)
                                throws WCMException
指定者：
接口 IComponentEntryConfigService 中的 getTypedEntryConfig
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IAdmanageConfigService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.conjection.service
接口 IAdmanageConfigService

所有已知实现类：
AdmanageConfigServiceImpl
public interface IAdmanageConfigService

方法摘要
java.lang.String | getAdManagerLinkPath()
boolean | isAdManagerEnable()
void | updateAdManageService()

方法详细信息

isAdManagerEnable

boolean isAdManagerEnable()
                          throws WCMException
抛出：
WCMException

updateAdManageService

void updateAdManageService()
                           throws WCMException
抛出：
WCMException

getAdManagerLinkPath

java.lang.String getAdManagerLinkPath()
                                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IComponentEntryConfigService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.conjection.service
接口 IComponentEntryConfigService

所有已知实现类：
ComponentEntryConfigServiceImpl
public interface IComponentEntryConfigService

方法摘要
EntryConfig | getEntryConfig(int _nEntryId)
EntryConfig | getTypedEntryConfig(int _nEntryType)
void | saveComponentConfigInfo(EntryConfig _oEntry)

方法详细信息

getEntryConfig

EntryConfig getEntryConfig(int _nEntryId)
                           throws WCMException
参数：
_nEntryId -
返回：
抛出：
WCMException

getTypedEntryConfig

EntryConfig getTypedEntryConfig(int _nEntryType)
                                throws WCMException
抛出：
WCMException

saveComponentConfigInfo

void saveComponentConfigInfo(EntryConfig _oEntry)
                             throws WCMException
参数：
_oEntry - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.conjection.service
接口
IAdmanageConfigService
IComponentEntryConfigService
类
AdmanageConfigServiceImpl
ComponentEntryConfigServiceImpl


com.trs.components.common.conjection.service

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.conjection.service

接口摘要
IAdmanageConfigService
IComponentEntryConfigService

类摘要
AdmanageConfigServiceImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ComponentEntryConfigServiceImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.conjection.service 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.conjection.service 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.conjection.service.AdmanageConfigServiceImpl (implements com.trs.components.common.conjection.service.IAdmanageConfigService)
    • com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl (implements com.trs.components.common.conjection.service.IComponentEntryConfigService)

接口分层结构

  • com.trs.components.common.conjection.service.IAdmanageConfigService
  • com.trs.components.common.conjection.service.IComponentEntryConfigService


软件包 com.trs.components.common.conjection.service 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.conjection.service
的使用

使用 com.trs.components.common.conjection.service 的软件包
com.trs.components.common.conjection.service

com.trs.components.common.conjection.service 使用的 com.trs.components.common.conjection.service 中的类
IAdmanageConfigService
IComponentEntryConfigService

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.conjection.service.AdmanageConfigServiceImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.conjection.service.AdmanageConfigServiceImpl
的使用

没有 com.trs.components.common.conjection.service.AdmanageConfigServiceImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl
的使用

没有 com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.conjection.service.IAdmanageConfigService 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.conjection.service.IAdmanageConfigService
的使用

使用 IAdmanageConfigService 的软件包
com.trs.components.common.conjection.service

com.trs.components.common.conjection.service 中 IAdmanageConfigService 的使用

实现 IAdmanageConfigService 的 com.trs.components.common.conjection.service 中的类
 class AdmanageConfigServiceImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.conjection.service.IComponentEntryConfigService 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.conjection.service.IComponentEntryConfigService
的使用

使用 IComponentEntryConfigService 的软件包
com.trs.components.common.conjection.service

com.trs.components.common.conjection.service 中 IComponentEntryConfigService 的使用

实现 IComponentEntryConfigService 的 com.trs.components.common.conjection.service 中的类
 class ComponentEntryConfigServiceImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseScheduleWorker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 BaseScheduleWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
所有已实现的接口：
org.quartz.Job
直接已知子类：
BaseStatefulScheduleWorker, DocPriDisableWorker, EPressHistoryIndexWorker, Reminder, StatAutoRunWorker
public abstract class BaseScheduleWorker
extends BaseJob

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseScheduleWorker()
方法摘要
 void execute(org.quartz.JobExecutionContext _currContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseScheduleWorker

public BaseScheduleWorker()
方法详细信息

execute

public void execute(org.quartz.JobExecutionContext _currContext)
指定者：
接口 org.quartz.Job 中的 execute
覆盖：
类 BaseJob 中的 execute
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BaseStatefulScheduleWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 BaseStatefulScheduleWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.common.job.BaseStatefulScheduleWorker
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
直接已知子类：
ChnlSynWorker, HitsCountParserSchedule, OptimizeSystemWorker, PublishJobWorker, TempPathCleaner, WithDrawJobWorker
public abstract class BaseStatefulScheduleWorker
extends BaseScheduleWorker
implements org.quartz.StatefulJob

Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseStatefulScheduleWorker()
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

BaseStatefulScheduleWorker

public BaseStatefulScheduleWorker()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobScheduleServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 JobScheduleServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.components.common.job.JobScheduleServer
所有已实现的接口：
IServer
public class JobScheduleServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
JobScheduleServer()
方法摘要
static Schedule | deleteSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)
static Schedule | findSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)
static void | main(java.lang.String[] args)
static Schedule | saveSchedule(JobWorkerType _currWorkerType, Schedule _currSchedule, CMSObj _currObj)
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JobScheduleServer

public JobScheduleServer()
方法详细信息

saveSchedule

public static Schedule saveSchedule(JobWorkerType _currWorkerType,
                                    Schedule _currSchedule,
                                    CMSObj _currObj)
                             throws WCMException
抛出：
WCMException

deleteSchedule

public static Schedule deleteSchedule(JobWorkerType _currWorkerType,
                                      CMSObj _currObj)
                               throws WCMException
抛出：
WCMException

findSchedule

public static Schedule findSchedule(JobWorkerType _currWorkerType,
                                    CMSObj _currObj)
                             throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobWorkerType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 JobWorkerType

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.job.JobWorkerType
所有已实现的接口：
java.lang.Cloneable
public class JobWorkerType
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
系统Job的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 数据表的ID字段名称
static java.lang.String | DB_TABLE_NAME 对象所使用的数据表
static int | ID_CHANNEL_SYN 操作类型：频道分发
static int | ID_CLEAN_TEMPPATH_SCHEDULE 操作类型：删除临时文件的计划执行
static int | ID_DOCUMENT_TOP 操作类型：文档置顶
static int | ID_PUBLISH_SCHEDULE 操作类型：文档/频道/站点 的计划发布
static int | ID_REMIND_JOB 操作类型：消息提醒
static int | ID_STAT_AUTORUN 操作类型：统计数据自动生成
static int | ID_USERDEF_FROM 操作类型：用户自定义操作类型的ID起始值
static int | OBJ_TYPE 对象类型
构造方法摘要
JobWorkerType()
默认的构造函数
方法摘要
static JobWorkerType | createNewInstance() 产生当前对象[JobWorker]的实例
static JobWorkerType | findByClassName(java.lang.String _sClassName)
static JobWorkerType | findById(int _nId) 提取指定ID的对象
static JobWorkerType | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc()
java.lang.String | getIdFieldName() 获得Id字段名。
int | getParamCount()
java.lang.String | getParamDisp(java.lang.String _sParamName)
java.lang.String | getParamName(int _nIndex)
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
java.lang.Object | getWorker()
java.lang.Class | getWorkerClass()
java.lang.String | getWorkerClassAsString()
java.lang.String | getWorkerName()
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | putParam(java.lang.String _sParamName, java.lang.String _sParamDisp)
boolean | setDesc(java.lang.String _sDesc)
boolean | setWorkerClass(java.lang.Class _sClassName)
boolean | setWorkerClass(java.lang.String _sClassName)
boolean | setWorkerName(java.lang.String _sWorkerName)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ID_REMIND_JOB

public static final int ID_REMIND_JOB
操作类型：消息提醒

另请参见：
常量字段值

ID_CLEAN_TEMPPATH_SCHEDULE

public static final int ID_CLEAN_TEMPPATH_SCHEDULE
操作类型：删除临时文件的计划执行

另请参见：
常量字段值

ID_PUBLISH_SCHEDULE

public static final int ID_PUBLISH_SCHEDULE
操作类型：文档/频道/站点 的计划发布

另请参见：
常量字段值

ID_CHANNEL_SYN

public static final int ID_CHANNEL_SYN
操作类型：频道分发

另请参见：
常量字段值

ID_DOCUMENT_TOP

public static final int ID_DOCUMENT_TOP
操作类型：文档置顶

另请参见：
常量字段值

ID_STAT_AUTORUN

public static final int ID_STAT_AUTORUN
操作类型：统计数据自动生成

另请参见：
常量字段值

ID_USERDEF_FROM

public static final int ID_USERDEF_FROM
操作类型：用户自定义操作类型的ID起始值

另请参见：
常量字段值

OBJ_TYPE

public static final int OBJ_TYPE
对象类型

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所使用的数据表

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
数据表的ID字段名称

另请参见：
常量字段值
构造方法详细信息

JobWorkerType

public JobWorkerType()
默认的构造函数

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getParamCount

public int getParamCount()

getParamDisp

public java.lang.String getParamDisp(java.lang.String _sParamName)

getParamName

public java.lang.String getParamName(int _nIndex)

putParam

public void putParam(java.lang.String _sParamName,
                     java.lang.String _sParamDisp)

getWorkerName

public java.lang.String getWorkerName()

setWorkerName

public boolean setWorkerName(java.lang.String _sWorkerName)
                      throws WCMException
抛出：
WCMException

getWorker

public java.lang.Object getWorker()
                           throws WCMException
抛出：
WCMException

getWorkerClass

public java.lang.Class getWorkerClass()
                               throws WCMException
抛出：
WCMException

getWorkerClassAsString

public java.lang.String getWorkerClassAsString()

setWorkerClass

public boolean setWorkerClass(java.lang.String _sClassName)
                       throws WCMException
抛出：
WCMException

setWorkerClass

public boolean setWorkerClass(java.lang.Class _sClassName)
                       throws WCMException
参数：
_sClassName -
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
返回：

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
参数：
_sDesc -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

findById

public static final JobWorkerType findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final JobWorkerType createNewInstance()
                                             throws WCMException
产生当前对象[JobWorker]的实例

返回：
当前对象的实例[JobWorker]
抛出：
WCMException

findByKey

public static final JobWorkerType findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByClassName

public static final JobWorkerType findByClassName(java.lang.String _sClassName)
                                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobWorkerTypeLCListenerForSchedule

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 JobWorkerTypeLCListenerForSchedule

java.lang.Object
    继承者  com.trs.components.common.job.JobWorkerTypeLCListenerForSchedule
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class JobWorkerTypeLCListenerForSchedule
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
计划同步删除
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
JobWorkerTypeLCListenerForSchedule()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JobWorkerTypeLCListenerForSchedule

public JobWorkerTypeLCListenerForSchedule()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobWorkerTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 JobWorkerTypes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.job.JobWorkerTypes

public class JobWorkerTypes
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
JobWorkerTypes(User _currUser)
JobWorkerTypes(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static JobWorkerTypes | createNewInstance(User _currUser) 产生当前集合对象[JobWorkers]的实例
static JobWorkerTypes | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static JobWorkerTypes | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[JobWorkers]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JobWorkerTypes

public JobWorkerTypes(User _currUser)

JobWorkerTypes

public JobWorkerTypes(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final JobWorkerTypes findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（JobWorkers）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final JobWorkerTypes openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[JobWorkers]

参数：
_filter - 指定的Filter
返回：
当前集合[JobWorkers]
抛出：
WCMException

createNewInstance

public static JobWorkerTypes createNewInstance(User _currUser)
产生当前集合对象[JobWorkers]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OptimizeSystemWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 OptimizeSystemWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.common.job.BaseStatefulScheduleWorker
                继承者  com.trs.components.common.job.OptimizeSystemWorker
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
public class OptimizeSystemWorker
extends BaseStatefulScheduleWorker

构造方法摘要
OptimizeSystemWorker()
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

OptimizeSystemWorker

public OptimizeSystemWorker()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.job
类
BaseScheduleWorker
BaseStatefulScheduleWorker
JobScheduleServer
JobWorkerType
JobWorkerTypeLCListenerForSchedule
JobWorkerTypes
OptimizeSystemWorker
Schedule
ScheduleLCListenerForFaieldResult
ScheduleLCListenerForServer
Schedules
TempPathCleaner


com.trs.components.common.job

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.job

类摘要
BaseScheduleWorker | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulScheduleWorker | Title: TRS 内容协作平台（TRS WCM） Description: 线程安全的Job Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JobScheduleServer | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JobWorkerType | Title: TRS 内容协作平台（TRS WCM） Description: 系统Job的定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JobWorkerTypeLCListenerForSchedule | Title: TRS 内容协作平台（TRS WCM） Description: 计划同步删除 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JobWorkerTypes | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
OptimizeSystemWorker |
Schedule |
ScheduleLCListenerForFaieldResult | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ScheduleLCListenerForServer | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Schedules |
TempPathCleaner |


com.trs.components.common.job 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.job 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.components.common.job.BaseScheduleWorker
        • com.trs.components.common.job.BaseStatefulScheduleWorker (implements org.quartz.StatefulJob)
          • com.trs.components.common.job.OptimizeSystemWorker
          • com.trs.components.common.job.TempPathCleaner
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.job.JobWorkerType
        • com.trs.components.common.job.Schedule
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.job.JobWorkerTypes
        • com.trs.components.common.job.Schedules
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.components.common.job.JobScheduleServer
    • com.trs.components.common.job.JobWorkerTypeLCListenerForSchedule (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.common.job.ScheduleLCListenerForFaieldResult (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.common.job.ScheduleLCListenerForServer (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)


软件包 com.trs.components.common.job 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.job
的使用

使用 com.trs.components.common.job 的软件包
com.trs.components.common.job
com.trs.components.common.reminder
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.epress
com.trs.components.wcm.publish
com.trs.components.wcm.publish.domain.job
com.trs.components.wcm.resource
com.trs.components.wcm.stat
com.trs.service
com.trs.service.impl

com.trs.components.common.job 使用的 com.trs.components.common.job 中的类
BaseScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobWorkerType
Title: TRS 内容协作平台（TRS WCM）
Description:
系统Job的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobWorkerTypes
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Schedule
Schedules

com.trs.components.common.reminder 使用的 com.trs.components.common.job 中的类
BaseScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.components.common.job 中的类
BaseScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.components.common.job 中的类
BaseScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Schedule

com.trs.components.wcm.epress 使用的 com.trs.components.common.job 中的类
BaseScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 使用的 com.trs.components.common.job 中的类
Schedule

com.trs.components.wcm.publish.domain.job 使用的 com.trs.components.common.job 中的类
BaseScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.resource 使用的 com.trs.components.common.job 中的类
Schedules

com.trs.components.wcm.stat 使用的 com.trs.components.common.job 中的类
BaseScheduleWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service 使用的 com.trs.components.common.job 中的类
Schedule

com.trs.service.impl 使用的 com.trs.components.common.job 中的类
Schedule

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Schedule

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 Schedule

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.job.Schedule
所有已实现的接口：
java.lang.Cloneable
public class Schedule
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
CMyDateTime | dtAddList
static int | MODE_MORE_TIMES_DAY 模式类型：每天执行多次
static int | MODE_ONE_TIME_DAY 模式类型：每天执行一次
static int | MODE_ONE_TIME_ONLY 模式类型：仅仅运行一次
static int | OBJ_TYPE
static int | STATUS_CANCELED
static int | STATUS_DONE
static int | STATUS_EXPIRED
static int | STATUS_FAILED
static int | STATUS_NORMAL 计划状态：正常
static int | STATUS_NOTSTART
static int | STATUS_PARAM_INVALID
static int | STATUS_RUN
static int | STATUS_UNKNOWN
static int | STATUS_WAIT
构造方法摘要
Schedule()
构造函数：保留默认接口
方法摘要
java.lang.Object | clone() 对象复制
static Schedule | createNewInstance() 产生当前对象[Schedule]的实例
static Schedule | findById(int _nId) 提取指定ID的对象
static Schedule | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static Schedule | findBySender(int _nWorkerId, BaseObj _currSender) 获取在指定对象上定义的指定类型的调度（Schedule）
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 属性提取：描述
CMyDateTime | getEndTime() 属性提取：执行结束时间，与开始时间共同指定计划执行所在的时间段。
CMyDateTime | getExeTime() 属性提取：执行时间
java.lang.String | getIdFieldName() 获得Id字段名。
int | getLasExeResult() 属性提取：上次执行结果
CMyDateTime | getLastExeTime() 取上次执行时间
int | getLastTimeUsed() 属性提取：上次执行所用时间
int | getMode() 属性提取：计划执行类型
java.lang.String | getName() 属性提取：名称
java.util.List | getOperArgNames() 获取所有的参数名称列表
java.lang.String | getOperArgs() 属性提取：操作参数
java.lang.String | getOperArgValue(java.lang.String _sArgName) 获取指定参数的数据
int | getParam() 属性提取：参数
int | getSenderId() 属性提取：发送者ID
int | getSenderType() 属性提取：发送者类型
CMyDateTime | getStartTime() 属性提取：开始执行时间，与结束时间共同指定计划执行所在的时间段。
int | getStatus() 属性提取：计划状态（注意：删除的计划，状态为负值）
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
JobWorkerType | getWorkerType()
int | getWorkerTypeId()
void | insert(User _currUser) 将对象数据写入数据库
boolean | isDeleted() 判断计划是否已经被删除
boolean | isFinished() 判断任务是否已经执行结束
boolean | isValid() 检验对象数据有效性
boolean | logicalDelete(User _currUser)
boolean | logicalUndelete(User _currUser)
boolean | setDeleted(boolean _bDeleted) 逻辑接口：设置计划设是否为已删除状态 说明：对于正常状态下的计划，setDeleted( true )将计划改为已删除（逻辑删除）； 对于已删除的计划，setDeleted( false )将计划恢复为正常状态
boolean | setDesc(java.lang.String _desc) 属性设置：描述
boolean | setEndTime(CMyDateTime _endTime)
boolean | setExeTime(CMyDateTime _exeTime) 属性设置：执行时间
boolean | setLastExeResult(int _nResult) 属性设置：上次执行结果
boolean | setLastExeTime() 设置上次执行时间为当前时间
boolean | setLastExeTime(CMyDateTime _time) 设置上次执行时间为指定时间
boolean | setLastTimeUsed(int _nTimeUsed) 属性设置：上次执行所用时间
boolean | setMode(int _nMode) 属性设置：计划执行类型
boolean | setName(java.lang.String _name) 属性设置：名称（要求名称不重复；区分大小写，由isValid处理）
boolean | setOperArgs(java.lang.String _sOpArgs) 属性设置：操作参数
boolean | setParam(int _nParam) 属性设置：参数
boolean | setSender(CMSObj _sender) 属性设置：发送者
boolean | setSender(int _senderType, int _senderId) 属性设置：发送者
boolean | setStartTime(CMyDateTime _startTime) 属性设置：开始执行时间
boolean | setStatus(int _status) 属性设置：计划状态
boolean | setWorkerType(int _nWorkerTypeId)
boolean | setWorkerType(JobWorkerType _worker)
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

MODE_ONE_TIME_DAY

public static final int MODE_ONE_TIME_DAY
模式类型：每天执行一次

另请参见：
常量字段值

MODE_MORE_TIMES_DAY

public static final int MODE_MORE_TIMES_DAY
模式类型：每天执行多次

另请参见：
常量字段值

MODE_ONE_TIME_ONLY

public static final int MODE_ONE_TIME_ONLY
模式类型：仅仅运行一次

另请参见：
常量字段值

STATUS_NORMAL

public static final int STATUS_NORMAL
计划状态：正常

另请参见：
常量字段值

STATUS_UNKNOWN

public static final int STATUS_UNKNOWN
另请参见：
常量字段值

STATUS_NOTSTART

public static final int STATUS_NOTSTART
另请参见：
常量字段值

STATUS_WAIT

public static final int STATUS_WAIT
另请参见：
常量字段值

STATUS_RUN

public static final int STATUS_RUN
另请参见：
常量字段值

STATUS_DONE

public static final int STATUS_DONE
另请参见：
常量字段值

STATUS_EXPIRED

public static final int STATUS_EXPIRED
另请参见：
常量字段值

STATUS_FAILED

public static final int STATUS_FAILED
另请参见：
常量字段值

STATUS_CANCELED

public static final int STATUS_CANCELED
另请参见：
常量字段值

STATUS_PARAM_INVALID

public static final int STATUS_PARAM_INVALID
另请参见：
常量字段值

dtAddList

public CMyDateTime dtAddList
构造方法详细信息

Schedule

public Schedule()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getName

public java.lang.String getName()
属性提取：名称

返回：
计划名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
属性设置：名称（要求名称不重复；区分大小写，由isValid处理）

参数：
_name - 名称
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
属性提取：描述

返回：
有关计划内容的描述信息

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
属性设置：描述

参数：
_desc - 描述信息
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSenderType

public int getSenderType()
属性提取：发送者类型

返回：
发送者类型（WCMObj对应其WCMType属性）

getSenderId

public int getSenderId()
属性提取：发送者ID

返回：
发送者ID，与SenderType共同指定发送者。

setSender

public boolean setSender(int _senderType,
                         int _senderId)
                  throws WCMException
属性设置：发送者

参数：
_senderType - 发送者类型
_senderId - 发送者ID
返回：
若属性有效且设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性无效或设置失败，会抛出异常。

setSender

public boolean setSender(CMSObj _sender)
                  throws WCMException
属性设置：发送者

参数：
_sender - 发送者对象
返回：
若属性有效且设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性无效或设置失败，会抛出异常。

getStatus

public int getStatus()
属性提取：计划状态（注意：删除的计划，状态为负值）

返回：
计划的当前状态值

setStatus

public boolean setStatus(int _status)
                  throws WCMException
属性设置：计划状态

参数：
_status - 状态值
返回：
若属性有效且设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性无效或设置失败，会抛出异常。

isDeleted

public boolean isDeleted()
判断计划是否已经被删除

返回：
若计划已经被删除，则返回true；否则返回false.

setDeleted

public boolean setDeleted(boolean _bDeleted)
                   throws WCMException
逻辑接口：设置计划设是否为已删除状态 说明：对于正常状态下的计划，setDeleted( true )将计划改为已删除（逻辑删除）；
对于已删除的计划，setDeleted( false )将计划恢复为正常状态

参数：
_bDeleted - 是否删除
返回：
若属性有效且设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性无效或设置失败，会抛出异常。

getWorkerTypeId

public int getWorkerTypeId()

getWorkerType

public JobWorkerType getWorkerType()
                            throws WCMException
抛出：
WCMException

setWorkerType

public boolean setWorkerType(int _nWorkerTypeId)
                      throws WCMException
抛出：
WCMException

setWorkerType

public boolean setWorkerType(JobWorkerType _worker)
                      throws WCMException
抛出：
WCMException

getOperArgs

public java.lang.String getOperArgs()
属性提取：操作参数

返回：
操作参数

getOperArgValue

public java.lang.String getOperArgValue(java.lang.String _sArgName)
获取指定参数的数据

参数：
_sArgName - 参数名称
返回：

getOperArgNames

public java.util.List getOperArgNames()
获取所有的参数名称列表

返回：
所有的参数名称列表（List）

setOperArgs

public boolean setOperArgs(java.lang.String _sOpArgs)
                    throws WCMException
属性设置：操作参数

参数：
_sOpArgs - 操作参数
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMode

public int getMode()
属性提取：计划执行类型

返回：
计划执行类型

setMode

public boolean setMode(int _nMode)
                throws WCMException
属性设置：计划执行类型

参数：
_nMode - 计划执行类型
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getExeTime

public CMyDateTime getExeTime()
属性提取：执行时间

返回：
执行时间

setExeTime

public boolean setExeTime(CMyDateTime _exeTime)
                   throws WCMException
属性设置：执行时间

参数：
_exeTime - 执行时间
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStartTime

public CMyDateTime getStartTime()
属性提取：开始执行时间，与结束时间共同指定计划执行所在的时间段。

返回：
开始执行时间

setStartTime

public boolean setStartTime(CMyDateTime _startTime)
                     throws WCMException
属性设置：开始执行时间

参数：
_startTime - 开始执行时间
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEndTime

public CMyDateTime getEndTime()
属性提取：执行结束时间，与开始时间共同指定计划执行所在的时间段。

返回：
执行结束时间

setEndTime

public boolean setEndTime(CMyDateTime _endTime)
                   throws WCMException
抛出：
WCMException

getParam

public int getParam()
属性提取：参数

返回：
参数

setParam

public boolean setParam(int _nParam)
                 throws WCMException
属性设置：参数

参数：
_nParam - 整型参数值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLastExeTime

public CMyDateTime getLastExeTime()
取上次执行时间

返回：
上次执行时间

setLastExeTime

public boolean setLastExeTime()
                       throws WCMException
设置上次执行时间为当前时间

抛出：
WCMException

setLastExeTime

public boolean setLastExeTime(CMyDateTime _time)
                       throws WCMException
设置上次执行时间为指定时间

参数：
_time - 指定的时间
返回：
若指定时间有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLasExeResult

public int getLasExeResult()
属性提取：上次执行结果

返回：
上次执行结果

setLastExeResult

public boolean setLastExeResult(int _nResult)
                         throws WCMException
属性设置：上次执行结果

参数：
_nResult - 执行结果
返回：
若指定时间有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLastTimeUsed

public int getLastTimeUsed()
属性提取：上次执行所用时间

返回：
上次执行所用时间

setLastTimeUsed

public boolean setLastTimeUsed(int _nTimeUsed)
                        throws WCMException
属性设置：上次执行所用时间

参数：
_timeUsed - 上次执行所用时间（单位：秒）
返回：
若指定时间有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或名称重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

logicalDelete

public boolean logicalDelete(User _currUser)
                      throws WCMException
抛出：
WCMException

logicalUndelete

public boolean logicalUndelete(User _currUser)
                        throws WCMException
抛出：
WCMException

clone

public java.lang.Object clone()
对象复制

覆盖：
类 BaseObj 中的 clone
返回：
返回Object对象

isFinished

public boolean isFinished()
判断任务是否已经执行结束

返回：
若任务已经执行结束（无论是否成功），则返回true；否则返回false.

findById

public static final Schedule findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Schedule createNewInstance()
                                        throws WCMException
产生当前对象[Schedule]的实例

返回：
当前对象的实例[Schedule]
抛出：
WCMException

findByKey

public static final Schedule findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findBySender

public static final Schedule findBySender(int _nWorkerId,
                                          BaseObj _currSender)
                                   throws WCMException
获取在指定对象上定义的指定类型的调度（Schedule）

参数：
_nWorkerId - 指定类型ID，WCMOpers中的记录ID
系统默认的定义在JobWorkerType中
_currSender - 指定对象
返回：
在指定对象上定义的指定类型的调度（Schedule）
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScheduleLCListenerForFaieldResult

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 ScheduleLCListenerForFaieldResult

java.lang.Object
    继承者  com.trs.components.common.job.ScheduleLCListenerForFaieldResult
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public final class ScheduleLCListenerForFaieldResult
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ScheduleLCListenerForFaieldResult()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScheduleLCListenerForFaieldResult

public ScheduleLCListenerForFaieldResult()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScheduleLCListenerForServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 ScheduleLCListenerForServer

java.lang.Object
    继承者  com.trs.components.common.job.ScheduleLCListenerForServer
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ScheduleLCListenerForServer
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ScheduleLCListenerForServer()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScheduleLCListenerForServer

public ScheduleLCListenerForServer()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Schedules

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 Schedules

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.job.Schedules

public class Schedules
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Schedules(User _currUser)
Schedules(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Schedules | createNewInstance(User _currUser) 产生当前集合对象[Schedules]的实例
static Schedules | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Schedules | findUnfinishedSchedules(User _currUser, CMyDateTime _dtTime)
Schedule | getByName(java.lang.String _sName)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Schedules | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Schedules]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Schedules

public Schedules(User _currUser)

Schedules

public Schedules(User _currUser,
                 int initialCapacity,
                 int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

getByName

public Schedule getByName(java.lang.String _sName)

findByIds

public static final Schedules findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Schedules openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[Schedules]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[Schedules]
抛出：
WCMException

createNewInstance

public static Schedules createNewInstance(User _currUser)
                                   throws WCMException
产生当前集合对象[Schedules]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

findUnfinishedSchedules

public static Schedules findUnfinishedSchedules(User _currUser,
                                                CMyDateTime _dtTime)
                                         throws WCMException
参数：
_currUser -
_dtTime -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TempPathCleaner

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.job
类 TempPathCleaner

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.common.job.BaseStatefulScheduleWorker
                继承者  com.trs.components.common.job.TempPathCleaner
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
public class TempPathCleaner
extends BaseStatefulScheduleWorker

构造方法摘要
TempPathCleaner()
构造函数，保留默认接口
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

TempPathCleaner

public TempPathCleaner()
构造函数，保留默认接口

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.job.BaseScheduleWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.BaseScheduleWorker
的使用

使用 BaseScheduleWorker 的软件包
com.trs.components.common.job
com.trs.components.common.reminder
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.epress
com.trs.components.wcm.publish.domain.job
com.trs.components.wcm.stat

com.trs.components.common.job 中 BaseScheduleWorker 的使用

com.trs.components.common.job 中 BaseScheduleWorker 的子类
class | BaseStatefulScheduleWorker Title: TRS 内容协作平台（TRS WCM） Description: 线程安全的Job Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | OptimizeSystemWorker
class | TempPathCleaner

com.trs.components.common.reminder 中 BaseScheduleWorker 的使用

com.trs.components.common.reminder 中 BaseScheduleWorker 的子类
 class Reminder

com.trs.components.stat 中 BaseScheduleWorker 的使用

com.trs.components.stat 中 BaseScheduleWorker 的子类
 class HitsCountParserSchedule

com.trs.components.wcm.content.domain 中 BaseScheduleWorker 的使用

com.trs.components.wcm.content.domain 中 BaseScheduleWorker 的子类
class | ChnlSynWorker
class | DocPriDisableWorker Title: TRS 内容协作平台（TRS WCM） Description: 根据文档置顶的截止时间撤销文档置顶的计划任务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 BaseScheduleWorker 的使用

com.trs.components.wcm.epress 中 BaseScheduleWorker 的子类
 class EPressHistoryIndexWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
计划发布产生概览索引(当天的数据)
Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.domain.job 中 BaseScheduleWorker 的使用

com.trs.components.wcm.publish.domain.job 中 BaseScheduleWorker 的子类
class | PublishJobWorker Title: TRS 内容协作平台（TRS WCM） Description: 计划发布执行者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WithDrawJobWorker Title: TRS 内容协作平台（TRS WCM） Description: 定时撤稿 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.stat 中 BaseScheduleWorker 的使用

com.trs.components.wcm.stat 中 BaseScheduleWorker 的子类
 class StatAutoRunWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
自动统计数据到临时表的Worker
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.BaseStatefulScheduleWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.BaseStatefulScheduleWorker
的使用

使用 BaseStatefulScheduleWorker 的软件包
com.trs.components.common.job
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.publish.domain.job

com.trs.components.common.job 中 BaseStatefulScheduleWorker 的使用

com.trs.components.common.job 中 BaseStatefulScheduleWorker 的子类
class | OptimizeSystemWorker
class | TempPathCleaner

com.trs.components.stat 中 BaseStatefulScheduleWorker 的使用

com.trs.components.stat 中 BaseStatefulScheduleWorker 的子类
 class HitsCountParserSchedule

com.trs.components.wcm.content.domain 中 BaseStatefulScheduleWorker 的使用

com.trs.components.wcm.content.domain 中 BaseStatefulScheduleWorker 的子类
 class ChnlSynWorker

com.trs.components.wcm.publish.domain.job 中 BaseStatefulScheduleWorker 的使用

com.trs.components.wcm.publish.domain.job 中 BaseStatefulScheduleWorker 的子类
class | PublishJobWorker Title: TRS 内容协作平台（TRS WCM） Description: 计划发布执行者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WithDrawJobWorker Title: TRS 内容协作平台（TRS WCM） Description: 定时撤稿 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.JobScheduleServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.JobScheduleServer
的使用

没有 com.trs.components.common.job.JobScheduleServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.JobWorkerType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.JobWorkerType
的使用

使用 JobWorkerType 的软件包
com.trs.components.common.job

com.trs.components.common.job 中 JobWorkerType 的使用

返回 JobWorkerType 的 com.trs.components.common.job 中的方法
static JobWorkerType | JobWorkerType.createNewInstance() 产生当前对象[JobWorker]的实例
static JobWorkerType | JobWorkerType.findByClassName(java.lang.String _sClassName)
static JobWorkerType | JobWorkerType.findById(int _nId) 提取指定ID的对象
static JobWorkerType | JobWorkerType.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
JobWorkerType | Schedule.getWorkerType()

参数类型为 JobWorkerType 的 com.trs.components.common.job 中的方法
static Schedule | JobScheduleServer.deleteSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)
static Schedule | JobScheduleServer.findSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)
static Schedule | JobScheduleServer.saveSchedule(JobWorkerType _currWorkerType, Schedule _currSchedule, CMSObj _currObj)
boolean | Schedule.setWorkerType(JobWorkerType _worker)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.JobWorkerTypeLCListenerForSchedule 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.JobWorkerTypeLCListenerForSchedule
的使用

没有 com.trs.components.common.job.JobWorkerTypeLCListenerForSchedule 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.JobWorkerTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.JobWorkerTypes
的使用

使用 JobWorkerTypes 的软件包
com.trs.components.common.job

com.trs.components.common.job 中 JobWorkerTypes 的使用

返回 JobWorkerTypes 的 com.trs.components.common.job 中的方法
static JobWorkerTypes | JobWorkerTypes.createNewInstance(User _currUser) 产生当前集合对象[JobWorkers]的实例
static JobWorkerTypes | JobWorkerTypes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static JobWorkerTypes | JobWorkerTypes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[JobWorkers]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.OptimizeSystemWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.OptimizeSystemWorker
的使用

没有 com.trs.components.common.job.OptimizeSystemWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.Schedule 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.Schedule
的使用

使用 Schedule 的软件包
com.trs.components.common.job
com.trs.components.wcm.content.domain
com.trs.components.wcm.publish
com.trs.service
com.trs.service.impl

com.trs.components.common.job 中 Schedule 的使用

返回 Schedule 的 com.trs.components.common.job 中的方法
static Schedule | Schedule.createNewInstance() 产生当前对象[Schedule]的实例
static Schedule | JobScheduleServer.deleteSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)
static Schedule | Schedule.findById(int _nId) 提取指定ID的对象
static Schedule | Schedule.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static Schedule | Schedule.findBySender(int _nWorkerId, BaseObj _currSender) 获取在指定对象上定义的指定类型的调度（Schedule）
static Schedule | JobScheduleServer.findSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)
Schedule | Schedules.getByName(java.lang.String _sName)
static Schedule | JobScheduleServer.saveSchedule(JobWorkerType _currWorkerType, Schedule _currSchedule, CMSObj _currObj)

参数类型为 Schedule 的 com.trs.components.common.job 中的方法
static Schedule JobScheduleServer.saveSchedule(JobWorkerType _currWorkerType, Schedule _currSchedule, CMSObj _currObj)

com.trs.components.wcm.content.domain 中 Schedule 的使用

返回 Schedule 的 com.trs.components.wcm.content.domain 中的方法
 Schedule DocumentPriMgr.findSchedule(ChnlDoc _currChnlDoc)
查找文档置顶计划中，当前ChnlDoc对应的计划发布任务

com.trs.components.wcm.publish 中 Schedule 的使用

返回 Schedule 的 com.trs.components.wcm.publish 中的方法
 Schedule WCMContentPublishConfig.getSchedule()

com.trs.service 中 Schedule 的使用

返回 Schedule 的 com.trs.service 中的方法
Schedule | IScheduleService.deletePublishSchedule(BaseChannel _currChannel) 删除指定站点或频道的计划发布
Schedule | IScheduleService.deletePublishSchedule(Document _currDocument) 删除指定文档的计划发布
Schedule | IScheduleService.findPublishSchedule(BaseChannel _currChannel) 获取指定站点或频道的计划发布信息
Schedule | IScheduleService.findPublishSchedule(Document _currDocument) 获取指定文档的计划发布信息
Schedule | IScheduleService.savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel) 给指定的站点或频道设置计划发布属性
Schedule | IScheduleService.savePublishSchedule(Schedule _currSchedule, Document _currDocument) 给指定的文档设置计划发布属性

参数类型为 Schedule 的 com.trs.service 中的方法
Schedule | IScheduleService.savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel) 给指定的站点或频道设置计划发布属性
Schedule | IScheduleService.savePublishSchedule(Schedule _currSchedule, Document _currDocument) 给指定的文档设置计划发布属性

com.trs.service.impl 中 Schedule 的使用

返回 Schedule 的 com.trs.service.impl 中的方法
Schedule | ScheduleService.deletePublishSchedule(BaseChannel _currChannel)
Schedule | ScheduleService.deletePublishSchedule(Document _currDocument)
Schedule | ScheduleService.findPublishSchedule(BaseChannel _currChannel)
Schedule | ScheduleService.findPublishSchedule(Document _currDocument)
Schedule | ScheduleService.savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel)
Schedule | ScheduleService.savePublishSchedule(Schedule _currSchedule, Document _currDocument)

参数类型为 Schedule 的 com.trs.service.impl 中的方法
Schedule | ScheduleService.savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel)
Schedule | ScheduleService.savePublishSchedule(Schedule _currSchedule, Document _currDocument)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.ScheduleLCListenerForFaieldResult 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.ScheduleLCListenerForFaieldResult
的使用

没有 com.trs.components.common.job.ScheduleLCListenerForFaieldResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.ScheduleLCListenerForServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.ScheduleLCListenerForServer
的使用

没有 com.trs.components.common.job.ScheduleLCListenerForServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.Schedules 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.Schedules
的使用

使用 Schedules 的软件包
com.trs.components.common.job
com.trs.components.wcm.resource

com.trs.components.common.job 中 Schedules 的使用

返回 Schedules 的 com.trs.components.common.job 中的方法
static Schedules | Schedules.createNewInstance(User _currUser) 产生当前集合对象[Schedules]的实例
static Schedules | Schedules.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Schedules | Schedules.findUnfinishedSchedules(User _currUser, CMyDateTime _dtTime)
static Schedules | Schedules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Schedules]

com.trs.components.wcm.resource 中 Schedules 的使用

返回 Schedules 的 com.trs.components.wcm.resource 中的方法
 Schedules ResourceMgr.getTempPathDeleteSchedules(WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.job.TempPathCleaner 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.job.TempPathCleaner
的使用

没有 com.trs.components.common.job.TempPathCleaner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


EmailSendWorker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 EmailSendWorker

java.lang.Object
    继承者  com.trs.components.common.message.EmailSendWorker
所有已实现的接口：
ISendWorker
public class EmailSendWorker
extends java.lang.Object
implements ISendWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
Email(邮件)发送者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
EmailSendWorker()
方法摘要
 void send(Message _currMessage, User _currReceiver)
发送消息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EmailSendWorker

public EmailSendWorker()
方法详细信息

send

public void send(Message _currMessage,
                 User _currReceiver)
从接口 ISendWorker 复制的描述
发送消息

指定者：
接口 ISendWorker 中的 send
参数：
_currMessage - 消息
_currReceiver - 接收者（单个User）
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IMessageService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
接口 IMessageService

public interface IMessageService

Title: TRS 内容协作平台（TRS WCM）
Description:
在线短消息管理的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | delete(int _nMessageId) 根据短消息ID删除短消息
boolean | delete(Message _delMessage) 删除短消息
boolean | delete(Messages _delMessages) 删除短消息集合
boolean | delete(java.lang.String _sDelIds) 根据对象的ID列表删除短消息集合
User | getLoginUser() 获得当前登录用户
Messages | getMessages(int _nMessageType, WCMFilter _aFilter) 获取WCM中特定的类型的消息，如已读消息、已发消息
boolean | send(java.lang.String _sMsgTitle, java.lang.String _sMsgBody, java.lang.String _sUserIds, boolean _bSendEmail, boolean _bSendMobile) 发送短消息给特定的用户集合

方法详细信息

getLoginUser

User getLoginUser()
获得当前登录用户

返回：
当前登录用户

getMessages

Messages getMessages(int _nMessageType,
                     WCMFilter _aFilter)
                     throws WCMException
获取WCM中特定的类型的消息，如已读消息、已发消息

参数：
_nMessageType - 消息类型
WCMTypes中增加三种 MESSAGE_READ为已读, MESSAGE_SENT为已发, MESSAGE_UNREAD为未读
_aFilter - 查询条件
返回：
符合条件的消息集合
抛出：
WCMException

send

boolean send(java.lang.String _sMsgTitle,
             java.lang.String _sMsgBody,
             java.lang.String _sUserIds,
             boolean _bSendEmail,
             boolean _bSendMobile)
             throws WCMException
发送短消息给特定的用户集合

参数：
_sMsgTitle - 消息标题
_sMsgBody - 消息正文
_sUserIds - 接收者的Id序列，以逗号分隔
_bSendEmail - 是否同时发送邮件
_bSendMobile - 是否同时发送到手机
返回：
抛出：
WCMException

delete

boolean delete(Message _delMessage)
               throws WCMException
删除短消息

参数：
_delMessage - 待删除的短消息对象
返回：
删除结果，true为成功，false为失败
抛出：
WCMException

delete

boolean delete(int _nMessageId)
               throws WCMException
根据短消息ID删除短消息

参数：
_nMessageId - 待删除的短消息ID
返回：
删除结果，true为成功，false为失败
抛出：
WCMException

delete

boolean delete(Messages _delMessages)
               throws WCMException
删除短消息集合

参数：
_delMessages - 待删除的短消息集合
返回：
删除结果，true为成功，false为失败
抛出：
WCMException

delete

boolean delete(java.lang.String _sDelIds)
               throws WCMException
根据对象的ID列表删除短消息集合

参数：
_sDelIds - 待删除的短消息ID序列，以逗号分隔
返回：
删除结果，true为成功，false为失败
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ISendWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
接口 ISendWorker

所有已知实现类：
EmailSendWorker, MsgSendWorker, SMSSendWorker
public interface ISendWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
发送者接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 void send(Message _currMessage, User _currReceiver)
发送消息

方法详细信息

send

void send(Message _currMessage,
          User _currReceiver)
发送消息

参数：
_currMessage - 消息
_currReceiver - 接收者（单个User）
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Message

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 Message

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.message.Message
所有已实现的接口：
java.lang.Cloneable
public class Message
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | FLAG_CALLBOARD
static int | FLAG_DELETE
static int | FLAG_NODELETE
static int | FLAG_UNKOWN 属性Flag有3种状态
static int | MESSAGE_STATE_CALLBOARD
static int | MESSAGE_STATE_DELETE
static int | MESSAGE_STATE_NODELETE 旧的常量，保留
static int | OBJ_TYPE 常量定义
static int | TYPE_NORM
static int | TYPE_PUBLISH
static int | TYPE_WORKFLOW
构造方法摘要
Message()
方法摘要
static Message | createNewInstance() 产生当前对象[Message]的实例
int | delete(User _currUser) 删除对象 重载父类接口：同时删除相关数据
static Message | findById(int _nId) 提取指定ID的对象
static Message | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 属性: Attribute 扩展属性
java.lang.String | getBody() 属性: Body 内容
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
int | getFlag() 属性Flag有3种状态1与0和2 MESSAGE_STATE_DELETE MESSAGE_STATE_NODELETE MESSAGE_STATE_CALLBOARD
java.lang.String | getIdFieldName() 获得Id字段名。
MsgQueues | getMsgQueues(User _currUser) 得到消息队列
Users | getReceivers() 获取消息的接收者集合
java.lang.String | getSendType()
java.lang.String | getTitle() 属性: Title 标题
CMyDateTime | getValidTime() property: ValidTime 有效期
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库
boolean | isQueue(User _currUser) 判断消息是否在队列中
boolean | isValid() 数据有效性检验
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setBody(java.lang.String _body)
boolean | setDeletedBySender() 删除已发送消息
boolean | setFlag(int _flag)
void | setReceivers(int _nReceiverType, java.lang.String _sReceiverIds) 设置消息的接收者
boolean | setSendTypes(java.lang.String _sSendType) 设置消息发送类型
boolean | setSendTypes(java.lang.String[] _arSendTypes) 设置消息发送类型
boolean | setTitle(java.lang.String _title)
boolean | setValidTime(CMyDateTime _time)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

FLAG_UNKOWN

public static final int FLAG_UNKOWN
属性Flag有3种状态

另请参见：
常量字段值

FLAG_NODELETE

public static final int FLAG_NODELETE
另请参见：
常量字段值

FLAG_DELETE

public static final int FLAG_DELETE
另请参见：
常量字段值

FLAG_CALLBOARD

public static final int FLAG_CALLBOARD
另请参见：
常量字段值

MESSAGE_STATE_NODELETE

public static final int MESSAGE_STATE_NODELETE
旧的常量，保留

另请参见：
常量字段值

MESSAGE_STATE_DELETE

public static final int MESSAGE_STATE_DELETE
另请参见：
常量字段值

MESSAGE_STATE_CALLBOARD

public static final int MESSAGE_STATE_CALLBOARD
另请参见：
常量字段值

TYPE_NORM

public static final int TYPE_NORM
另请参见：
常量字段值

TYPE_PUBLISH

public static final int TYPE_PUBLISH
另请参见：
常量字段值

TYPE_WORKFLOW

public static final int TYPE_WORKFLOW
另请参见：
常量字段值
构造方法详细信息

Message

public Message()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getTitle

public java.lang.String getTitle()
属性: Title 标题

返回：

setTitle

public boolean setTitle(java.lang.String _title)
                 throws WCMException
抛出：
WCMException

getBody

public java.lang.String getBody()
属性: Body 内容

返回：

setBody

public boolean setBody(java.lang.String _body)
                throws WCMException
抛出：
WCMException

getValidTime

public CMyDateTime getValidTime()
property: ValidTime 有效期

返回：

setValidTime

public boolean setValidTime(CMyDateTime _time)
                     throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
属性: Attribute 扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

getFlag

public int getFlag()
属性Flag有3种状态1与0和2 MESSAGE_STATE_DELETE MESSAGE_STATE_NODELETE MESSAGE_STATE_CALLBOARD

返回：

setFlag

public boolean setFlag(int _flag)
                throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
数据有效性检验

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

delete

public int delete(User _currUser)
           throws WCMException
删除对象 重载父类接口：同时删除相关数据

覆盖：
类 CMSObj 中的 delete
参数：
_currUser -
返回：
抛出：
WCMException

getMsgQueues

public MsgQueues getMsgQueues(User _currUser)
                       throws WCMException
得到消息队列

参数：
_currUser -
返回：
抛出：
WCMException

isQueue

public boolean isQueue(User _currUser)
                throws WCMException
判断消息是否在队列中

参数：
_currUser -
返回：
抛出：
WCMException

getSendType

public java.lang.String getSendType()

setSendTypes

public boolean setSendTypes(java.lang.String _sSendType)
                     throws WCMException
设置消息发送类型

参数：
_sSendType - 发送类型组成的字符串,以字符','分隔.
注意: 类型必须是在MessageServerConfig.xml中定义的发送类型
返回：
抛出：
WCMException

setSendTypes

public boolean setSendTypes(java.lang.String[] _arSendTypes)
                     throws WCMException
设置消息发送类型

参数：
_arSendTypes - 发送类型组成的字符数组
注意: 类型必须是在MessageServerConfig.xml中定义的发送类型
系统会把数组中的相同内容当作一个对待
返回：
抛出：
WCMException

setDeletedBySender

public boolean setDeletedBySender()
                           throws WCMException
删除已发送消息

返回：
抛出：
WCMException

findById

public static final Message findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Message createNewInstance()
                                       throws WCMException
产生当前对象[Message]的实例

返回：
当前对象的实例[Message]
抛出：
WCMException

findByKey

public static final Message findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

setReceivers

public void setReceivers(int _nReceiverType,
                         java.lang.String _sReceiverIds)
设置消息的接收者

参数：
_nReceiverType - 接收者类型(User.OBJ_TYPE/Group.OBJ_TYPE/Role.OBJ_TYPE);
_sReceiverIds - 接收者ID序列,以字符','分隔

getReceivers

public Users getReceivers()
                   throws WCMException
获取消息的接收者集合

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Messages

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 Messages

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.message.Messages

public class Messages
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Messages(User _currUser)
Messages(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static Messages | createNewInstance(User _currUser) 产生一个当前集合对象[Messages]的实例
static Messages | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Messages | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Messages]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Messages

public Messages(User _currUser)

Messages

public Messages(User _currUser,
                int _initCapacity,
                int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
抛出：
java.lang.Exception

findByIds

public static final Messages findByIds(User _currUser,
                                       java.lang.String _sIds)
                                throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Messages openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[Messages]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[Messages]
抛出：
WCMException

createNewInstance

public static Messages createNewInstance(User _currUser)
                                  throws WCMException
产生一个当前集合对象[Messages]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageSendingConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 MessageSendingConfig

java.lang.Object
    继承者  com.trs.components.common.message.MessageSendingConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class MessageSendingConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MessageSendingConfig()
方法摘要
java.lang.String | getDescription()
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getWorker()
void | setDescription(java.lang.String description)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setWorker(java.lang.String worker)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageSendingConfig

public MessageSendingConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)

getWorker

public java.lang.String getWorker()

setWorker

public void setWorker(java.lang.String worker)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageSendingMapper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 MessageSendingMapper

java.lang.Object
    继承者  com.trs.components.common.message.MessageSendingMapper
所有已实现的接口：
org.aton.container.IClearable
public class MessageSendingMapper
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
通过名称查找到相应SenderWorker的散列查找表，封装了操作配置文件逻辑
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MessageSendingMapper()
方法摘要
void | clear()
static MessageSendingMapper | getInstance()
MessageSendingConfig[] | getMsgSendingConfigs() 得到所有消息发送服务器关于message发送方式的配置信息
java.lang.String | getWorker(java.lang.String _sSenderName) 依据 SenderName 得到指定的 SendWorker 的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageSendingMapper

public MessageSendingMapper()
方法详细信息

getInstance

public static MessageSendingMapper getInstance()

getWorker

public java.lang.String getWorker(java.lang.String _sSenderName)
依据 SenderName 得到指定的 SendWorker 的名称

参数：
_sSenderName -
返回：
指定的 SendWorker 的名称

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

getMsgSendingConfigs

public MessageSendingConfig[] getMsgSendingConfigs()
得到所有消息发送服务器关于message发送方式的配置信息

返回：
所有消息发送服务器关于message发送方式的配置信息
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 MessageServer

java.lang.Object
    继承者  com.trs.components.common.message.MessageServer

public class MessageServer
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
消息服务提供者：MessageServer
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MessageServer()
方法摘要
static void | delete(User _currUser, java.lang.String _sDelMsgIds) 删除消息集合 删除消息时，如果用户为发件人，则在Message表中做逻辑删除的标志 如果用户为收件人，则从关联关系表中删除该记录 如果用户既是发件人，又是收件人，则两个操作都做 删除时，如果关联表中已没有和Message关联的记录，Message中也时逻辑删除，则从Message中彻底删除该消息。
static void | emptyInbox(User _currUser) 清空用户的收件箱 将用户接收到的消息都删除掉 参照delete的逻辑
static void | emptyOutbox(User _currUser) 清空用户的已发消息 将用户接发送的消息都删除掉 参照delete的逻辑
static Message | findById(User _currUser, int _nMsgId)
static Messages | findByIds(User _currUser, java.lang.String _sMsgIds)
static Messages | getMessages(int _nReadFlag, User _loginUser, WCMFilter _aFilter) 根据指定的类型(未读/已收/已发)获取消息集合
static Messages | getReceivedMsgs(User _currUser, WCMFilter _currFiilter) 获得某用户的所有接收到的消息 接收的判断是所有用户为接收者的消息
static java.lang.String | getReceiverNames(Message _currMsg, int _nReceiverType) 获取消息接收者名
static Messages | getSentMsgs(User _currUser, WCMFilter _currFiilter) 获得某用户的所有已发消息 已发的判断是从Message表中查询得到
static Messages | getUnreadMessages(User _currUser, WCMFilter _filter) 获得用户所有未读的消息 未读的定义即_currMsgUser为接收者，且消息的已读属性为false
static boolean | hasUnreadMessage(User _currUser) 判断用户是否有没有阅读的消息
static boolean | hasUnreadMessage(User _currUser, int[] _pMsgType) 判断用户是否有没有阅读指定类型的消息
static boolean | isMessageReaded(Message _currMessage, User _currUser) 获得用户所接收消息的状态 状态包括已读和未读，通过状态标志来返回
static void | send(Message _currMessage) 发送消息
static void | setMessageReaded(Message _currMessage, User _currUser, boolean _bMessageReaded) 设置接收到的消息的已读状态
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageServer

public MessageServer()
方法详细信息

send

public static void send(Message _currMessage)
                 throws WCMException
发送消息

参数：
_currMessage - 要发送的消息
抛出：
WCMException

getUnreadMessages

public static Messages getUnreadMessages(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
获得用户所有未读的消息
未读的定义即_currMsgUser为接收者，且消息的已读属性为false

参数：
_currUser - 用户
_filter - 过滤器,额外的查询条件
返回：
未读的消息集合
抛出：
WCMException
另请参见：
getReceivedMsgs(User, WCMFilter)

hasUnreadMessage

public static boolean hasUnreadMessage(User _currUser)
                                throws WCMException
判断用户是否有没有阅读的消息

参数：
_currUser - 指定的用户
返回：
如果有,返回true;否则,返回false
抛出：
WCMException

hasUnreadMessage

public static boolean hasUnreadMessage(User _currUser,
                                       int[] _pMsgType)
                                throws WCMException
判断用户是否有没有阅读指定类型的消息

参数：
_currUser - 指定的用户
返回：
如果有,返回true;否则,返回false
抛出：
WCMException

getSentMsgs

public static Messages getSentMsgs(User _currUser,
                                   WCMFilter _currFiilter)
                            throws WCMException
获得某用户的所有已发消息
已发的判断是从Message表中查询得到

参数：
_currMsgUser - 特定的用户
_currFiilter - 查询条件
返回：
抛出：
WCMException

getReceivedMsgs

public static Messages getReceivedMsgs(User _currUser,
                                       WCMFilter _currFiilter)
                                throws WCMException
获得某用户的所有接收到的消息
接收的判断是所有用户为接收者的消息

参数：
_currMsgUser - 特定的用户
_currFiilter - 查询条件
返回：
抛出：
WCMException

delete

public static void delete(User _currUser,
                          java.lang.String _sDelMsgIds)
                   throws WCMException
删除消息集合
删除消息时，如果用户为发件人，则在Message表中做逻辑删除的标志
如果用户为收件人，则从关联关系表中删除该记录
如果用户既是发件人，又是收件人，则两个操作都做
删除时，如果关联表中已没有和Message关联的记录，Message中也时逻辑删除，则从Message中彻底删除该消息。

参数：
_currUser - 当前用户
_sDelMsgIds - 消息Id序列，形如1,3,44
抛出：
WCMException

emptyInbox

public static void emptyInbox(User _currUser)
                       throws WCMException
清空用户的收件箱
将用户接收到的消息都删除掉
参照delete的逻辑

参数：
_currUser - 当前用户
抛出：
WCMException

emptyOutbox

public static void emptyOutbox(User _currUser)
                        throws WCMException
清空用户的已发消息
将用户接发送的消息都删除掉
参照delete的逻辑

参数：
_currUser - 当前用户
抛出：
WCMException

isMessageReaded

public static boolean isMessageReaded(Message _currMessage,
                                      User _currUser)
                               throws WCMException
获得用户所接收消息的状态
状态包括已读和未读，通过状态标志来返回

参数：
_currMessage - 消息
_currUser - 当前用户
返回：
已读和未读标志，false为未读，true为已读
抛出：
WCMException

setMessageReaded

public static void setMessageReaded(Message _currMessage,
                                    User _currUser,
                                    boolean _bMessageReaded)
                             throws WCMException
设置接收到的消息的已读状态

参数：
_currMessage - 消息
_currUser - 当前用户
_bMessageReaded - 消息是否已读的状态，false为未读，true为已读
抛出：
WCMException

getMessages

public static Messages getMessages(int _nReadFlag,
                                   User _loginUser,
                                   WCMFilter _aFilter)
                            throws WCMException
根据指定的类型(未读/已收/已发)获取消息集合

参数：
_nReadFlag -
_loginUser -
_aFilter -
返回：
抛出：
WCMException

getReceiverNames

public static java.lang.String getReceiverNames(Message _currMsg,
                                                int _nReceiverType)
                                         throws WCMException
获取消息接收者名

参数：
_currMsg - 指定的消息
_nReceiverType - 接收者类型(User.OBJ_TYPE等)
返回：
抛出：
WCMException

findById

public static Message findById(User _currUser,
                               int _nMsgId)
                        throws WCMException
抛出：
WCMException

findByIds

public static Messages findByIds(User _currUser,
                                 java.lang.String _sMsgIds)
                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MsgQueue

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 MsgQueue

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.message.MsgQueue
所有已实现的接口：
java.lang.Cloneable
public class MsgQueue
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE 常量定义
static int | TYPE_FLOW_MSG
static int | TYPE_NORMAL_MSG Msg类型，暂时为俩种 一般和工作流
static int | TYPE_WARNING
构造方法摘要
MsgQueue()
方法摘要
static MsgQueue | createNewInstance() 产生当前对象[MsgQueue]的实例
static MsgQueue | findById(int _nId) 提取指定ID的对象
static MsgQueue | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
java.lang.String | getIdFieldName() 获得Id字段名。
Message | getMessage(User _currUser) 取得Message对象
int | getMessageId() 属性: Message 消息对象 取消息对象ID
int | getMsgType() MsgType有两种类型1、2
int | getObjId() 属性: ObjId
int | getObjType() 属性: ObjType
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isReaded() 属性: Readed 允许的值有两种 MSGQUEUE_STATE_NOREAD 和 MSGQUEUE_STATE_READ
boolean | isValid() 验证有效性
boolean | setMessage(int _messageId)
boolean | setMessage(Message _message)
boolean | setMsgType(int _type)
boolean | setObj(CMSObj _obj)
boolean | setObjId(int _objId)
boolean | setObjType(int _objType)
boolean | setReaded(boolean _bReaded)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

TYPE_NORMAL_MSG

public static final int TYPE_NORMAL_MSG
Msg类型，暂时为俩种 一般和工作流

另请参见：
常量字段值

TYPE_FLOW_MSG

public static final int TYPE_FLOW_MSG
另请参见：
常量字段值

TYPE_WARNING

public static final int TYPE_WARNING
另请参见：
常量字段值
构造方法详细信息

MsgQueue

public MsgQueue()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getMessageId

public int getMessageId()
属性: Message 消息对象 取消息对象ID

返回：

getMessage

public Message getMessage(User _currUser)
                   throws WCMException
取得Message对象

参数：
_currUser -
返回：
@throws WCMException
抛出：
WCMException

setMessage

public boolean setMessage(int _messageId)
                   throws WCMException
抛出：
WCMException

setMessage

public boolean setMessage(Message _message)
                   throws WCMException
抛出：
WCMException

getObjType

public int getObjType()
属性: ObjType

返回：

setObjType

public boolean setObjType(int _objType)
                   throws WCMException
抛出：
WCMException

setObj

public boolean setObj(CMSObj _obj)
               throws WCMException
抛出：
WCMException

getObjId

public int getObjId()
属性: ObjId

返回：

setObjId

public boolean setObjId(int _objId)
                 throws WCMException
抛出：
WCMException

isReaded

public boolean isReaded()
属性: Readed 允许的值有两种 MSGQUEUE_STATE_NOREAD 和 MSGQUEUE_STATE_READ

返回：

setReaded

public boolean setReaded(boolean _bReaded)
                  throws WCMException
抛出：
WCMException

getMsgType

public int getMsgType()
MsgType有两种类型1、2

返回：

setMsgType

public boolean setMsgType(int _type)
                   throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
验证有效性

指定者：
类 BaseObj 中的 isValid
返回：
@throws WCMException
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

findById

public static final MsgQueue findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MsgQueue createNewInstance()
                                        throws WCMException
产生当前对象[MsgQueue]的实例

返回：
当前对象的实例[MsgQueue]
抛出：
WCMException

findByKey

public static final MsgQueue findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MsgQueues

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 MsgQueues

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.message.MsgQueues

public class MsgQueues
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MsgQueues(User _currUser)
MsgQueues(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static MsgQueues | createNewInstance(User _currUser) 产生一个当前集合对象[MsgQueues]的实例
static MsgQueues | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static MsgQueues | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MsgQueues]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MsgQueues

public MsgQueues(User _currUser)

MsgQueues

public MsgQueues(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
抛出：
java.lang.Exception

findByIds

public static final MsgQueues findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MsgQueues openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[MsgQueues]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[MsgQueues]
抛出：
WCMException

createNewInstance

public static MsgQueues createNewInstance(User _currUser)
                                   throws WCMException
产生一个当前集合对象[MsgQueues]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MsgReceiver

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 MsgReceiver

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.components.common.message.MsgReceiver
所有已实现的接口：
java.lang.Cloneable
public final class MsgReceiver
extends BaseObj

Title: TRS 内容协作平台（TRS WCM）
Description:
消息接收者对象,记录消息与消息接收者的联系
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
MsgReceiver()
方法摘要
static MsgReceiver | createNewInstance() 产生当前对象[MsgReceiver]的实例
static MsgReceiver | findById(int _nId) 提取指定ID的对象
static MsgReceiver | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getMsgId() 获取对应的Message的ID
int | getReceiverId() 获取接收者ID
java.lang.String | getReceiverName() 获取接收者的名称
int | getReceiverType() 获取接收者的类型
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setMsgId(int _nMsgId) 设置对应的Message的ID
boolean | setReceiverId(int _nReceiverId) 设置接收者ID
boolean | setReceiverName(java.lang.String _sReceiverName) 设置接收者的名称
boolean | setReceiverType(int _nReceiverType) 设置接收者的类型
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

MsgReceiver

public MsgReceiver()
方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

getMsgId

public int getMsgId()
获取对应的Message的ID

返回：

setMsgId

public boolean setMsgId(int _nMsgId)
                 throws WCMException
设置对应的Message的ID

参数：
_nMsgId -
返回：
@throws WCMException
抛出：
WCMException

getReceiverId

public int getReceiverId()
获取接收者ID

返回：

setReceiverId

public boolean setReceiverId(int _nReceiverId)
                      throws WCMException
设置接收者ID

参数：
_nReceiverId -
返回：
@throws WCMException
抛出：
WCMException

getReceiverType

public int getReceiverType()
获取接收者的类型

返回：
返回值可能是(User.OBJ_TYPE/Group.OBJ_TYPE/Role.OBJ_TYPE中的一个)

setReceiverType

public boolean setReceiverType(int _nReceiverType)
                        throws WCMException
设置接收者的类型

参数：
_nReceiverType -
返回：
@throws WCMException
抛出：
WCMException

getReceiverName

public java.lang.String getReceiverName()
获取接收者的名称

返回：

setReceiverName

public boolean setReceiverName(java.lang.String _sReceiverName)
                        throws WCMException
设置接收者的名称

参数：
_sReceiverName -
返回：
@throws WCMException
抛出：
WCMException

findById

public static final MsgReceiver findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MsgReceiver createNewInstance()
                                           throws WCMException
产生当前对象[MsgReceiver]的实例

返回：
当前对象的实例[MsgReceiver]
抛出：
WCMException

findByKey

public static final MsgReceiver findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MsgReceivers

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 MsgReceivers

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.components.common.message.MsgReceivers

public class MsgReceivers
extends BaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
消息接收者集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MsgReceivers()
方法摘要
static MsgReceivers | createNewInstance() 产生当前集合对象[MsgReceivers]的实例
static MsgReceivers | findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static MsgReceivers | openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[MsgReceivers]
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MsgReceivers

public MsgReceivers()
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final MsgReceivers findByIds(java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（MsgReceivers）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MsgReceivers openWCMObjs(WCMFilter _filter)
                                      throws WCMException
通过指定一个Filter获取当前集合[MsgReceivers]

参数：
_filter - 指定的Filter
返回：
当前集合[MsgReceivers]
抛出：
WCMException

createNewInstance

public static MsgReceivers createNewInstance()
产生当前集合对象[MsgReceivers]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MsgSendWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 MsgSendWorker

java.lang.Object
    继承者  com.trs.components.common.message.MsgSendWorker
所有已实现的接口：
ISendWorker
public class MsgSendWorker
extends java.lang.Object
implements ISendWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
短消息发送者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MsgSendWorker()
方法摘要
 void send(Message _currMessage, User _currReceiver)
发送消息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MsgSendWorker

public MsgSendWorker()
方法详细信息

send

public void send(Message _currMessage,
                 User _currReceiver)
从接口 ISendWorker 复制的描述
发送消息

指定者：
接口 ISendWorker 中的 send
参数：
_currMessage - 消息
_currReceiver - 接收者（单个User）
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.message
接口
IMessageService
ISendWorker
类
EmailSendWorker
Message
Messages
MessageSendingConfig
MessageSendingMapper
MessageServer
MsgQueue
MsgQueues
MsgReceiver
MsgReceivers
MsgSendWorker
SMSSendWorker
SMSSocketSender


com.trs.components.common.message

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.message

接口摘要
IMessageService | Title: TRS 内容协作平台（TRS WCM） Description: 在线短消息管理的接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ISendWorker | Title: TRS 内容协作平台（TRS WCM） Description: 发送者接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
EmailSendWorker | Title: TRS 内容协作平台（TRS WCM） Description: Email(邮件)发送者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Message |
Messages |
MessageSendingConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MessageSendingMapper | Title: TRS 内容协作平台（TRS WCM） Description: 通过名称查找到相应SenderWorker的散列查找表，封装了操作配置文件逻辑 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MessageServer | Title: TRS 内容协作平台（TRS WCM） Description: 消息服务提供者：MessageServer Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MsgQueue |
MsgQueues |
MsgReceiver | Title: TRS 内容协作平台（TRS WCM） Description: 消息接收者对象,记录消息与消息接收者的联系 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MsgReceivers | Title: TRS 内容协作平台（TRS WCM） Description: 消息接收者集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MsgSendWorker | Title: TRS 内容协作平台（TRS WCM） Description: 短消息发送者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SMSSendWorker | Title: TRS 内容协作平台（TRS WCM） Description: 手机短信发送者的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SMSSocketSender | Title: 网站内容管理（TRSWCM） Description: Copyright: Copyright (c) 2001 Company: www.trs.com.cn


com.trs.components.common.message 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.message 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.message.Message
        • com.trs.components.common.message.MsgQueue
      • com.trs.components.common.message.MsgReceiver
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.message.Messages
        • com.trs.components.common.message.MsgQueues
      • com.trs.components.common.message.MsgReceivers
    • com.trs.components.common.message.EmailSendWorker (implements com.trs.components.common.message.ISendWorker)
    • com.trs.components.common.message.MessageSendingConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.message.MessageSendingMapper (implements org.aton.container.IClearable)
    • com.trs.components.common.message.MessageServer
    • com.trs.components.common.message.MsgSendWorker (implements com.trs.components.common.message.ISendWorker)
    • com.trs.components.common.message.SMSSendWorker (implements com.trs.components.common.message.ISendWorker)
    • com.trs.components.common.message.SMSSocketSender

接口分层结构

  • com.trs.components.common.message.IMessageService
  • com.trs.components.common.message.ISendWorker


软件包 com.trs.components.common.message 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.message
的使用

使用 com.trs.components.common.message 的软件包
com.trs.components.common.message
com.trs.components.common.reminder

com.trs.components.common.message 使用的 com.trs.components.common.message 中的类
ISendWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
发送者接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Message
Messages
MessageSendingConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MessageSendingMapper
Title: TRS 内容协作平台（TRS WCM）
Description:
通过名称查找到相应SenderWorker的散列查找表，封装了操作配置文件逻辑
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MsgQueue
MsgQueues
MsgReceiver
Title: TRS 内容协作平台（TRS WCM）
Description:
消息接收者对象,记录消息与消息接收者的联系
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MsgReceivers
Title: TRS 内容协作平台（TRS WCM）
Description:
消息接收者集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.reminder 使用的 com.trs.components.common.message 中的类
Message

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SMSSendWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 SMSSendWorker

java.lang.Object
    继承者  com.trs.components.common.message.SMSSendWorker
所有已实现的接口：
ISendWorker
public class SMSSendWorker
extends java.lang.Object
implements ISendWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
手机短信发送者的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SMSSendWorker()
方法摘要
 void send(Message _currMessage, User _currReceiver)
发送消息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SMSSendWorker

public SMSSendWorker()
方法详细信息

send

public void send(Message _currMessage,
                 User _currReceiver)
从接口 ISendWorker 复制的描述
发送消息

指定者：
接口 ISendWorker 中的 send
参数：
_currMessage - 消息
_currReceiver - 接收者（单个User）
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SMSSocketSender

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message
类 SMSSocketSender

java.lang.Object
    继承者  com.trs.components.common.message.SMSSocketSender

public class SMSSocketSender
extends java.lang.Object

Title: 网站内容管理（TRSWCM）

Description:

Copyright: Copyright (c) 2001

Company: www.trs.com.cn

版本：
1.0
作者：
not attributable

构造方法摘要
SMSSocketSender(java.lang.String _strSMSIP, int _nSMSPort)
SMS短信发送者的默认构造函数
方法摘要
boolean | doSend(java.lang.String _strSMS) 发送短信给指定的接受者
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SMSSocketSender

public SMSSocketSender(java.lang.String _strSMSIP,
                       int _nSMSPort)
SMS短信发送者的默认构造函数

参数：
_strSMSIP - 发送者IP
_nSMSPort - 发送者端口
方法详细信息

doSend

public boolean doSend(java.lang.String _strSMS)
发送短信给指定的接受者

参数：
_strSMS - 短信内容
返回：
发送是否成功

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.message.EmailSendWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.EmailSendWorker
的使用

没有 com.trs.components.common.message.EmailSendWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.message.IMessageService 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.message.IMessageService
的使用

没有 com.trs.components.common.message.IMessageService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.message.ISendWorker 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.message.ISendWorker
的使用

使用 ISendWorker 的软件包
com.trs.components.common.message

com.trs.components.common.message 中 ISendWorker 的使用

实现 ISendWorker 的 com.trs.components.common.message 中的类
class | EmailSendWorker Title: TRS 内容协作平台（TRS WCM） Description: Email(邮件)发送者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MsgSendWorker Title: TRS 内容协作平台（TRS WCM） Description: 短消息发送者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | SMSSendWorker Title: TRS 内容协作平台（TRS WCM） Description: 手机短信发送者的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.Message 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.Message
的使用

使用 Message 的软件包
com.trs.components.common.message
com.trs.components.common.reminder

com.trs.components.common.message 中 Message 的使用

返回 Message 的 com.trs.components.common.message 中的方法
static Message | Message.createNewInstance() 产生当前对象[Message]的实例
static Message | Message.findById(int _nId) 提取指定ID的对象
static Message | MessageServer.findById(User _currUser, int _nMsgId)
static Message | Message.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Message | MsgQueue.getMessage(User _currUser) 取得Message对象

参数类型为 Message 的 com.trs.components.common.message 中的方法
boolean | IMessageService.delete(Message _delMessage) 删除短消息
static java.lang.String | MessageServer.getReceiverNames(Message _currMsg, int _nReceiverType) 获取消息接收者名
static boolean | MessageServer.isMessageReaded(Message _currMessage, User _currUser) 获得用户所接收消息的状态 状态包括已读和未读，通过状态标志来返回
static void | MessageServer.send(Message _currMessage) 发送消息
void | MsgSendWorker.send(Message _currMessage, User _currReceiver)
void | EmailSendWorker.send(Message _currMessage, User _currReceiver)
void | SMSSendWorker.send(Message _currMessage, User _currReceiver)
void | ISendWorker.send(Message _currMessage, User _currReceiver) 发送消息
boolean | MsgQueue.setMessage(Message _message)
static void | MessageServer.setMessageReaded(Message _currMessage, User _currUser, boolean _bMessageReaded) 设置接收到的消息的已读状态

com.trs.components.common.reminder 中 Message 的使用

参数类型为 Message 的 com.trs.components.common.reminder 中的方法
static void Reminder.createSchedule(Message _newMessage, CMyDateTime _dtRemind)
创建一个消息提醒

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.Messages 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.Messages
的使用

使用 Messages 的软件包
com.trs.components.common.message

com.trs.components.common.message 中 Messages 的使用

返回 Messages 的 com.trs.components.common.message 中的方法
static Messages | Messages.createNewInstance(User _currUser) 产生一个当前集合对象[Messages]的实例
static Messages | Messages.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Messages | MessageServer.findByIds(User _currUser, java.lang.String _sMsgIds)
static Messages | MessageServer.getMessages(int _nReadFlag, User _loginUser, WCMFilter _aFilter) 根据指定的类型(未读/已收/已发)获取消息集合
Messages | IMessageService.getMessages(int _nMessageType, WCMFilter _aFilter) 获取WCM中特定的类型的消息，如已读消息、已发消息
static Messages | MessageServer.getReceivedMsgs(User _currUser, WCMFilter _currFiilter) 获得某用户的所有接收到的消息 接收的判断是所有用户为接收者的消息
static Messages | MessageServer.getSentMsgs(User _currUser, WCMFilter _currFiilter) 获得某用户的所有已发消息 已发的判断是从Message表中查询得到
static Messages | MessageServer.getUnreadMessages(User _currUser, WCMFilter _filter) 获得用户所有未读的消息 未读的定义即_currMsgUser为接收者，且消息的已读属性为false
static Messages | Messages.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Messages]

参数类型为 Messages 的 com.trs.components.common.message 中的方法
 boolean IMessageService.delete(Messages _delMessages)
删除短消息集合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.MessageSendingConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.MessageSendingConfig
的使用

使用 MessageSendingConfig 的软件包
com.trs.components.common.message

com.trs.components.common.message 中 MessageSendingConfig 的使用

返回 MessageSendingConfig 的 com.trs.components.common.message 中的方法
 MessageSendingConfig[] MessageSendingMapper.getMsgSendingConfigs()
得到所有消息发送服务器关于message发送方式的配置信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.MessageSendingMapper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.MessageSendingMapper
的使用

使用 MessageSendingMapper 的软件包
com.trs.components.common.message

com.trs.components.common.message 中 MessageSendingMapper 的使用

返回 MessageSendingMapper 的 com.trs.components.common.message 中的方法
static MessageSendingMapper MessageSendingMapper.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.MessageServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.MessageServer
的使用

没有 com.trs.components.common.message.MessageServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.MsgQueue 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.MsgQueue
的使用

使用 MsgQueue 的软件包
com.trs.components.common.message

com.trs.components.common.message 中 MsgQueue 的使用

返回 MsgQueue 的 com.trs.components.common.message 中的方法
static MsgQueue | MsgQueue.createNewInstance() 产生当前对象[MsgQueue]的实例
static MsgQueue | MsgQueue.findById(int _nId) 提取指定ID的对象
static MsgQueue | MsgQueue.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.MsgQueues 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.MsgQueues
的使用

使用 MsgQueues 的软件包
com.trs.components.common.message

com.trs.components.common.message 中 MsgQueues 的使用

返回 MsgQueues 的 com.trs.components.common.message 中的方法
static MsgQueues | MsgQueues.createNewInstance(User _currUser) 产生一个当前集合对象[MsgQueues]的实例
static MsgQueues | MsgQueues.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
MsgQueues | Message.getMsgQueues(User _currUser) 得到消息队列
static MsgQueues | MsgQueues.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MsgQueues]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.MsgReceiver 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.MsgReceiver
的使用

使用 MsgReceiver 的软件包
com.trs.components.common.message

com.trs.components.common.message 中 MsgReceiver 的使用

返回 MsgReceiver 的 com.trs.components.common.message 中的方法
static MsgReceiver | MsgReceiver.createNewInstance() 产生当前对象[MsgReceiver]的实例
static MsgReceiver | MsgReceiver.findById(int _nId) 提取指定ID的对象
static MsgReceiver | MsgReceiver.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.MsgReceivers 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.MsgReceivers
的使用

使用 MsgReceivers 的软件包
com.trs.components.common.message

com.trs.components.common.message 中 MsgReceivers 的使用

返回 MsgReceivers 的 com.trs.components.common.message 中的方法
static MsgReceivers | MsgReceivers.createNewInstance() 产生当前集合对象[MsgReceivers]的实例
static MsgReceivers | MsgReceivers.findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
static MsgReceivers | MsgReceivers.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[MsgReceivers]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.MsgSendWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.MsgSendWorker
的使用

没有 com.trs.components.common.message.MsgSendWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.SMSSendWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.SMSSendWorker
的使用

没有 com.trs.components.common.message.SMSSendWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.SMSSocketSender 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.SMSSocketSender
的使用

没有 com.trs.components.common.message.SMSSocketSender 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


NotificationConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message.notify
类 NotificationConfig

java.lang.Object
    继承者  com.trs.components.common.message.notify.NotificationConfig

public class NotificationConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
NotificationConfig()
方法摘要
java.lang.String | getGroupIds()
java.lang.String | getRoleIds()
java.lang.String | getSendType()
java.lang.String | getUserNames()
void | setGroupIds(java.lang.String groupIds)
void | setRoleIds(java.lang.String roleIds)
void | setSendType(java.lang.String sendType)
void | setUserNames(java.lang.String userNames)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotificationConfig

public NotificationConfig()
方法详细信息

getSendType

public java.lang.String getSendType()
返回：
Returns the property of SendType.

setSendType

public void setSendType(java.lang.String sendType)
参数：
sendType - set the message send type.

getUserNames

public java.lang.String getUserNames()
返回：
Returns the user names list.

setUserNames

public void setUserNames(java.lang.String userNames)
参数：
userNames - name list of the users to receive the message.

getGroupIds

public java.lang.String getGroupIds()
返回：
Returns the group ids list.

setGroupIds

public void setGroupIds(java.lang.String groupIds)
参数：
groupIds - id list of the groups to receive the message.

getRoleIds

public java.lang.String getRoleIds()
返回：
Returns the role id list.

setRoleIds

public void setRoleIds(java.lang.String roleIds)
参数：
roleIds - id list of the roles to receive the message.

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
另请参见：
Object.toString()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


NotificationSchemeConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message.notify
类 NotificationSchemeConfig

java.lang.Object
    继承者  com.trs.components.common.message.notify.NotificationSchemeConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class NotificationSchemeConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
NotificationSchemeConfig()
方法摘要
java.lang.String | getEvent()
java.lang.String | getMsgBody()
java.lang.String | getName() 获取配置对象的名称
NotificationConfig | getNotification(int _nIndex)
java.util.ArrayList | getNotifications()
java.lang.String | getTitle()
boolean | isEnabled()
int | notificationsSize() logic for Notifications Collection
void | setEnabled(boolean enabled)
void | setEvent(java.lang.String event)
void | setMsgBody(java.lang.String msgBody)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setNotifications(java.util.ArrayList notifications)
void | setTitle(java.lang.String title)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotificationSchemeConfig

public NotificationSchemeConfig()
方法详细信息

isEnabled

public boolean isEnabled()

setEnabled

public void setEnabled(boolean enabled)

getEvent

public java.lang.String getEvent()

setEvent

public void setEvent(java.lang.String event)

getNotifications

public java.util.ArrayList getNotifications()

setNotifications

public void setNotifications(java.util.ArrayList notifications)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getMsgBody

public java.lang.String getMsgBody()

setMsgBody

public void setMsgBody(java.lang.String msgBody)

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String title)

notificationsSize

public int notificationsSize()
logic for Notifications Collection

getNotification

public NotificationConfig getNotification(int _nIndex)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
另请参见：
Object.toString()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotificationServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message.notify
类 NotificationServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.components.common.message.notify.NotificationServer
所有已实现的接口：
IServer, org.aton.container.IClearable
public class NotificationServer
extends BaseServer
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
notification server.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
NotificationServer()
constructor: default
方法摘要
void | clear()
static NotificationServer | getInstance()
NotificationSchemeConfig | lookupSchemeForEvent(java.lang.String _sEvent) lookup the notification scheme for the specified event.
boolean | needNotifyForEvent(java.lang.String _sEvent) check if it needs to notify for the specified event.
void | refresh() refresh the server configuration.
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NotificationServer

public NotificationServer()
constructor: default

方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

getInstance

public static NotificationServer getInstance()
返回：
Returns the server instance.

lookupSchemeForEvent

public NotificationSchemeConfig lookupSchemeForEvent(java.lang.String _sEvent)
lookup the notification scheme for the specified event.

参数：
_sEvent - event name
返回：
Returns the scheme found.

needNotifyForEvent

public boolean needNotifyForEvent(java.lang.String _sEvent)
check if it needs to notify for the specified event.

参数：
_sEvent - the event name.
返回：
Returns true if notification schemes are defined and also enabled for the event; otherwise, returns false .

refresh

public void refresh()
refresh the server configuration.

抛出：
WCMException - if failed to load the configuration.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Notifier

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.message.notify
类 Notifier

java.lang.Object
    继承者  com.trs.components.common.message.notify.Notifier

public class Notifier
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
worker to execute notification.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
Notifier()
constructor: default
方法摘要
void | execute(NotificationSchemeConfig _scheme) execute the specified notification scheme.
void | executeOnEvent(java.lang.String _sEvent) execute the notification on the specified event.
java.lang.String | getParameter(java.lang.String _sName) get the parameter value
void | setParameter(java.lang.String _sName, java.lang.String _sValue) set parameter value
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Notifier

public Notifier()
constructor: default

方法详细信息

setParameter

public void setParameter(java.lang.String _sName,
                         java.lang.String _sValue)
set parameter value

参数：
_sName - the parameter name
_sValue - the parameter value

getParameter

public java.lang.String getParameter(java.lang.String _sName)
get the parameter value

参数：
_sName - the parameter name
返回：
Returns the value of the specified parameter.

executeOnEvent

public void executeOnEvent(java.lang.String _sEvent)
                    throws WCMException
execute the notification on the specified event.

参数：
_sEvent - the event name.
抛出：
WCMException - if failed to execute the schme on the specified event.

execute

public void execute(NotificationSchemeConfig _scheme)
             throws WCMException
execute the specified notification scheme.

参数：
_scheme - the notification scheme.
抛出：
WCMException - if failed to execute the scheme.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.message.notify
类
NotificationConfig
NotificationSchemeConfig
NotificationServer
Notifier


com.trs.components.common.message.notify

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.message.notify

类摘要
NotificationConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
NotificationSchemeConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
NotificationServer | Title: TRS 内容协作平台（TRS WCM） Description: notification server.
Notifier | Title: TRS 内容协作平台（TRS WCM） Description: worker to execute notification.


com.trs.components.common.message.notify 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.message.notify 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.components.common.message.notify.NotificationServer (implements org.aton.container.IClearable)
    • com.trs.components.common.message.notify.NotificationConfig
    • com.trs.components.common.message.notify.NotificationSchemeConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.message.notify.Notifier


软件包 com.trs.components.common.message.notify 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.message.notify
的使用

使用 com.trs.components.common.message.notify 的软件包
com.trs.components.common.message.notify

com.trs.components.common.message.notify 使用的 com.trs.components.common.message.notify 中的类
NotificationConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
NotificationSchemeConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
NotificationServer
Title: TRS 内容协作平台（TRS WCM）
Description:
notification server.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.notify.NotificationConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.notify.NotificationConfig
的使用

使用 NotificationConfig 的软件包
com.trs.components.common.message.notify

com.trs.components.common.message.notify 中 NotificationConfig 的使用

返回 NotificationConfig 的 com.trs.components.common.message.notify 中的方法
 NotificationConfig NotificationSchemeConfig.getNotification(int _nIndex)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.notify.NotificationSchemeConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.notify.NotificationSchemeConfig
的使用

使用 NotificationSchemeConfig 的软件包
com.trs.components.common.message.notify

com.trs.components.common.message.notify 中 NotificationSchemeConfig 的使用

返回 NotificationSchemeConfig 的 com.trs.components.common.message.notify 中的方法
 NotificationSchemeConfig NotificationServer.lookupSchemeForEvent(java.lang.String _sEvent)
lookup the notification scheme for the specified event.

参数类型为 NotificationSchemeConfig 的 com.trs.components.common.message.notify 中的方法
 void Notifier.execute(NotificationSchemeConfig _scheme)
execute the specified notification scheme.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.notify.NotificationServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.notify.NotificationServer
的使用

使用 NotificationServer 的软件包
com.trs.components.common.message.notify

com.trs.components.common.message.notify 中 NotificationServer 的使用

返回 NotificationServer 的 com.trs.components.common.message.notify 中的方法
static NotificationServer NotificationServer.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.message.notify.Notifier 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.message.notify.Notifier
的使用

没有 com.trs.components.common.message.notify.Notifier 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


OrignHomePublishException

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish
类 OrignHomePublishException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.infra.util.CMyException
                继承者  com.trs.infra.common.WCMException
                    继承者  com.trs.components.common.publish.OrignHomePublishException
所有已实现的接口：
java.io.Serializable
public class OrignHomePublishException
extends WCMException

另请参见：
序列化表格

构造方法摘要
OrignHomePublishException(int _errNo)
OrignHomePublishException(int _errNo, java.lang.String _sMsg)
OrignHomePublishException(int _errNo, java.lang.String _sMsg, java.lang.Throwable _rootCause)
OrignHomePublishException(java.lang.String _sMsg)
OrignHomePublishException(java.lang.String _sMsg, java.lang.Throwable _rootCause)
方法摘要
从类 com.trs.infra.common.WCMException 继承的方法
catchException
从类 com.trs.infra.util.CMyException 继承的方法
getErrNo, getErrNoMsg, getLocalizedMessage, getMessage, getMyMessage, getRootCause, getStackTraceText, getStackTraceText, main, printStackTrace, printStackTrace, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getStackTrace, initCause, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OrignHomePublishException

public OrignHomePublishException(int _errNo)

OrignHomePublishException

public OrignHomePublishException(int _errNo,
                                 java.lang.String _sMsg)

OrignHomePublishException

public OrignHomePublishException(java.lang.String _sMsg)

OrignHomePublishException

public OrignHomePublishException(int _errNo,
                                 java.lang.String _sMsg,
                                 java.lang.Throwable _rootCause)

OrignHomePublishException

public OrignHomePublishException(java.lang.String _sMsg,
                                 java.lang.Throwable _rootCause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish
类
PublishConstants
PublishUpdateCommderImpl
异常
OrignHomePublishException


com.trs.components.common.publish

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish

类摘要
PublishConstants | Title: TRS 内容协作平台（TRS WCM） Description: constants for publish components.
PublishUpdateCommderImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
OrignHomePublishException


com.trs.components.common.publish 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.PublishConstants
    • com.trs.components.common.publish.PublishUpdateCommderImpl (implements com.trs.infra.update.IUpdateCommander)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.infra.util.CMyException
          • com.trs.infra.common.WCMException
            • com.trs.components.common.publish.OrignHomePublishException


软件包 com.trs.components.common.publish 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish
的使用

没有 com.trs.components.common.publish 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish
类 PublishConstants

java.lang.Object
    继承者  com.trs.components.common.publish.PublishConstants

public class PublishConstants
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
constants for publish components.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DEF_PAGE_FILEEXT default file extent of detail pages
static java.lang.String | DEF_PAGE_FILENAME_OUTLINE default file name of outline pages
static int | LOAD_BATCH_CONTENTS_BY_ITERATOR
static int | LOAD_BATCH_CONTENTS_BY_OBJECTS
static int | OBJTYPE_FOLDERPUBLISHCONFIG object type: folder publish config
static int | OBJTYPE_PUBLISHDISTRIBUTION object type: PublishDistributionConfig
static int | OBJTYPE_PUBLISHLOG object type: publish log
static int | OBJTYPE_PUBLISHTASK object type: publish task
static int | OBJTYPE_TAGBEAN object type: tag paser bean
static int | OBJTYPE_TEMPAPDREL object type: template appendix realation
static int | OBJTYPE_TEMPAPPENDIX object type: template appendix
static int | OBJTYPE_TEMPLATE object type: template
static int | OBJTYPE_TEMPLATE_ARGUMENT object type: template argument
static int | OBJTYPE_TEMPLATEEMPLPOY object type: template employ record
static int | OBJTYPE_TEMPLATEQUOTE object type: template quote record
static java.lang.String | PARSE_MODE_EDIT
static java.lang.String | PARSE_MODE_KEY
static java.lang.String | PARSE_MODE_NORM
static java.lang.String | PGVAR_ROOT_PATH page variable: root path
static java.lang.String | PGVARNAME_CURREXTRA
static java.lang.String | PGVARNAME_HEADDESC
static int | PGVARNAME_MAX_LENGTH “PGVARNAME_*”系列参数的参数名称的最大长度，在替换这些参数为实际值时会用到
static java.lang.String | PGVARNAME_NAVEXTRA
static java.lang.String | PGVARNAME_NAVIDPRE
static java.lang.String | PGVARNAME_NAVPAGES
static java.lang.String | PGVARNAME_NAVSHOWHEADTAIL
static java.lang.String | PGVARNAME_NAVSHOWPRENEXT
static java.lang.String | PGVARNAME_NAVTARGET
static java.lang.String | PGVARNAME_NEXTDESC
static java.lang.String | PGVARNAME_OUTLINENAV
static java.lang.String | PGVARNAME_PAGECOUNT page variable name: pages count
static java.lang.String | PGVARNAME_PAGEEXT page variable name: pages ext
static java.lang.String | PGVARNAME_PAGEINDEX page variable name: current page index
static java.lang.String | PGVARNAME_PAGENAME page variable name: pages name
static java.lang.String | PGVARNAME_PREDESC
static java.lang.String | PGVARNAME_RECORDCOUNT page variable name: record count
static java.lang.String | PGVARNAME_ROOT_PATH page variable name: root path
static java.lang.String | PGVARNAME_TAILDESC
static java.lang.String | PGVARNAME_WMLIMAGE
static java.lang.String | PGVARNAME_WMLIMAGECOUNT
static java.lang.String | PGVARNAME_WMLIMAGEDESC
static java.lang.String | PGVARNAME_WMLIMAGEFILE
static int | PUBLISH_CONTENT publish type: publish a content
static int | PUBLISH_CONTENT_DIRECT 文档的直接发布，绕开关于发布状态的限制，直接单篇（将来也许多篇）发布文档
static int | PUBLISH_FOLDER_FULLY publish type: full-publish folder, include the outline pages and all the detailed pages.
static int | PUBLISH_FOLDER_INCREASING publish type：increasing-publish folder, include the outline pages and all the contents who have not been published but can be published.
static int | PUBLISH_FOLDER_REFRESH publish type: refresh folder published page, just refreshing the outline pages.
static int | PUBLISH_FOLDER_REFRESH_ON_DEL_CONTENT 删除内容时候触发的栏目更新发布
static int | PUBLISH_FOLDER_SYNC 准确的说是分发任务，目录同步
static int | PUBLISH_MYSELF_ONLY publish type: publish the pages of myself only; for a folder, they are the outline pages; for a content, it is the detailed page.
static int | PUBLISH_RECALL publish type: recall the published pages
static int[] | PUBLISH_TYPES_OF_CONTENT all content publish types list
static int[] | PUBLISH_TYPES_OF_FOLDER all folder publish types list
static int | PUBLISH_UNKNOWN publish type: unknown
static int | QUOTE_FAMILYINDEX_MIN child index minimum value
static int | QUOTE_FAMILYINDEX_PARENT child index value when the quoted folder is the parent of current folder
static int | QUOTE_FAMILYINDEX_SELF child index value when the quoted folder is its self
static int | QUOTE_TYPE_ANY template quote type: any
static int | QUOTE_TYPE_CONTENT template quote type: using content information
static int | QUOTE_TYPE_FOLDER template quote type: using folder infomation
static java.lang.String | REG_REMOVE_COMMENT
static java.lang.String | ROOTIMG_DATAPATH data path of images in root
static int | STATUS_DELETED publish status: has been deleted
static int | STATUS_FORBIDDEN publish status: is forbidden to publish
static int | STATUS_OPEN publish status: is open and can be published
static int | STATUS_PUBLISHED publish status: has been published
static int | STATUS_PUBLISHING publish status: is during publishing process
static int | STATUS_UNKNOWN publish status: unknown
static char | TAGID_ATTRIBUTE_FLAG flag for CMSObj attribute in tag
static java.lang.String | TAGID_OWNER property id: myself
static int | TAGID_OWNER_HASHCODE hash code for TAGID_OWNER
static java.lang.String | TAGID_PARENT property id: my parent
static int | TAGID_PARENT_HASHCODE hash code for TAGID_PARENT
static java.lang.String | TAGID_RECURL property id: record path
static java.lang.String | TAGID_SITE property id: site
static int | TAGID_SITE_HASHCODE hash code for TAGID_SITE
static java.lang.String | TAGNAME_COMMENT
static java.lang.String | TAGNAME_EXISTSDATA tag name: ExistsData
static java.lang.String | TAGNAME_NOTEXISTSDATA tag name: NotExistsData
static java.lang.String | TAGNAME_PAGE_SEPARATOR
static java.lang.String | TAGNAME_PAGE_SEPARATOR_DETAIL
static java.lang.String | TAGNAME_RECORD tag name: record
static java.lang.String | TAGNAME_TEMPLATE tag name: nested template
static java.lang.String | TAGNAME_VARIABLE tag name: variable
static java.lang.String | TAGNAME_VARIABLE_ENUM tag name: variable enum
static int | TASK_PRIORITY_HIGH task level: urgent
static int | TASK_PRIORITY_LOW task level: low
static int | TASK_PRIORITY_NORM task level: normal
static int | TASK_PRIORITY_REAL 必须马上执行的任务
static int | TASK_STATUS_CANCELED task status: has been canceled
static int | TASK_STATUS_EXPIRED task status: time is expired
static int | TASK_STATUS_FAILED task status: failed
static int | TASK_STATUS_FINISHED task status: has been done
static int | TASK_STATUS_FINISHED_WITHWARNINGS task status: has been done but with warnings
static int | TASK_STATUS_PARAM_INVALID task status: parameter is invalid
static int | TASK_STATUS_PAUSED task status: has been paused
static int | TASK_STATUS_RUNNING task status: is running
static int | TASK_STATUS_UNKNOWN task status: unknown
static int | TASK_STATUS_WAITING task status: is waiting
static int | TEMPLATE_TYPE_ANY template type: any type
static int | TEMPLATE_TYPE_DETAIL template type: detail template
static int | TEMPLATE_TYPE_INFOVIEWPRINT template type: infoview print template
static int | TEMPLATE_TYPE_NESTED template type: nested template who will be included by other template
static int | TEMPLATE_TYPE_OUTLINE template type: outline template
static java.lang.String | TRS_PAGE_SEPARATOR page separator flag
方法摘要
static int[] | getAllTaskStatuses()
static java.lang.String | getPublishTypeName(int _nPublishType, java.lang.String _sDefault) get the name of a publish type
static java.lang.String | getPublishTypeName(int _nPublishType, java.lang.String _sDefault, boolean _bIsContent)
static boolean | isPublishTypeOfContent(int _nPublishType) check if a publish type is a folder publish type
static boolean | isPublishTypeOfFolder(int _nPublishType) check if a publish type is a folder publish type
static boolean | isTaskExecuted(int _nStatus) check if a task has been executed
static boolean | isTaskFailed(int _nStatus) check if a task is failed.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PARSE_MODE_EDIT

public static final java.lang.String PARSE_MODE_EDIT
另请参见：
常量字段值

PARSE_MODE_NORM

public static final java.lang.String PARSE_MODE_NORM
另请参见：
常量字段值

PARSE_MODE_KEY

public static final java.lang.String PARSE_MODE_KEY
另请参见：
常量字段值

LOAD_BATCH_CONTENTS_BY_OBJECTS

public static final int LOAD_BATCH_CONTENTS_BY_OBJECTS
另请参见：
常量字段值

LOAD_BATCH_CONTENTS_BY_ITERATOR

public static final int LOAD_BATCH_CONTENTS_BY_ITERATOR
另请参见：
常量字段值

OBJTYPE_TEMPLATE

public static final int OBJTYPE_TEMPLATE
object type: template

另请参见：
常量字段值

OBJTYPE_TEMPAPPENDIX

public static final int OBJTYPE_TEMPAPPENDIX
object type: template appendix

另请参见：
常量字段值

OBJTYPE_TAGBEAN

public static final int OBJTYPE_TAGBEAN
object type: tag paser bean

另请参见：
常量字段值

OBJTYPE_TEMPAPDREL

public static final int OBJTYPE_TEMPAPDREL
object type: template appendix realation

另请参见：
常量字段值

OBJTYPE_TEMPLATEEMPLPOY

public static final int OBJTYPE_TEMPLATEEMPLPOY
object type: template employ record

另请参见：
常量字段值

OBJTYPE_TEMPLATEQUOTE

public static final int OBJTYPE_TEMPLATEQUOTE
object type: template quote record

另请参见：
常量字段值

OBJTYPE_PUBLISHDISTRIBUTION

public static final int OBJTYPE_PUBLISHDISTRIBUTION
object type: PublishDistributionConfig

另请参见：
常量字段值

OBJTYPE_FOLDERPUBLISHCONFIG

public static final int OBJTYPE_FOLDERPUBLISHCONFIG
object type: folder publish config

另请参见：
常量字段值

OBJTYPE_TEMPLATE_ARGUMENT

public static final int OBJTYPE_TEMPLATE_ARGUMENT
object type: template argument

另请参见：
常量字段值

OBJTYPE_PUBLISHTASK

public static final int OBJTYPE_PUBLISHTASK
object type: publish task

另请参见：
常量字段值

OBJTYPE_PUBLISHLOG

public static final int OBJTYPE_PUBLISHLOG
object type: publish log

另请参见：
常量字段值

TEMPLATE_TYPE_ANY

public static final int TEMPLATE_TYPE_ANY
template type: any type

另请参见：
常量字段值

TEMPLATE_TYPE_NESTED

public static final int TEMPLATE_TYPE_NESTED
template type: nested template who will be included by other template

另请参见：
常量字段值

TEMPLATE_TYPE_OUTLINE

public static final int TEMPLATE_TYPE_OUTLINE
template type: outline template

另请参见：
常量字段值

TEMPLATE_TYPE_DETAIL

public static final int TEMPLATE_TYPE_DETAIL
template type: detail template

另请参见：
常量字段值

TEMPLATE_TYPE_INFOVIEWPRINT

public static final int TEMPLATE_TYPE_INFOVIEWPRINT
template type: infoview print template

另请参见：
常量字段值

PGVAR_ROOT_PATH

public static final java.lang.String PGVAR_ROOT_PATH
page variable: root path

另请参见：
常量字段值

PGVARNAME_MAX_LENGTH

public static final int PGVARNAME_MAX_LENGTH
“PGVARNAME_*”系列参数的参数名称的最大长度，在替换这些参数为实际值时会用到

另请参见：
常量字段值

PGVARNAME_ROOT_PATH

public static final java.lang.String PGVARNAME_ROOT_PATH
page variable name: root path

另请参见：
常量字段值

PGVARNAME_PAGECOUNT

public static final java.lang.String PGVARNAME_PAGECOUNT
page variable name: pages count

另请参见：
常量字段值

PGVARNAME_PAGENAME

public static final java.lang.String PGVARNAME_PAGENAME
page variable name: pages name

另请参见：
常量字段值

PGVARNAME_PAGEEXT

public static final java.lang.String PGVARNAME_PAGEEXT
page variable name: pages ext

另请参见：
常量字段值

PGVARNAME_PAGEINDEX

public static final java.lang.String PGVARNAME_PAGEINDEX
page variable name: current page index

另请参见：
常量字段值

PGVARNAME_RECORDCOUNT

public static final java.lang.String PGVARNAME_RECORDCOUNT
page variable name: record count

另请参见：
常量字段值

ROOTIMG_DATAPATH

public static final java.lang.String ROOTIMG_DATAPATH
data path of images in root

另请参见：
常量字段值

TRS_PAGE_SEPARATOR

public static final java.lang.String TRS_PAGE_SEPARATOR
page separator flag

另请参见：
常量字段值

TAGID_ATTRIBUTE_FLAG

public static final char TAGID_ATTRIBUTE_FLAG
flag for CMSObj attribute in tag

另请参见：
常量字段值

TAGID_RECURL

public static final java.lang.String TAGID_RECURL
property id: record path

另请参见：
常量字段值

TAGID_PARENT

public static final java.lang.String TAGID_PARENT
property id: my parent

另请参见：
常量字段值

TAGID_PARENT_HASHCODE

public static final int TAGID_PARENT_HASHCODE
hash code for TAGID_PARENT

另请参见：
常量字段值

TAGID_OWNER

public static final java.lang.String TAGID_OWNER
property id: myself

另请参见：
常量字段值

TAGID_OWNER_HASHCODE

public static final int TAGID_OWNER_HASHCODE
hash code for TAGID_OWNER

另请参见：
常量字段值

TAGID_SITE

public static final java.lang.String TAGID_SITE
property id: site

另请参见：
常量字段值

TAGID_SITE_HASHCODE

public static final int TAGID_SITE_HASHCODE
hash code for TAGID_SITE

另请参见：
常量字段值

TAGNAME_PAGE_SEPARATOR

public static final java.lang.String TAGNAME_PAGE_SEPARATOR
另请参见：
常量字段值

TAGNAME_PAGE_SEPARATOR_DETAIL

public static final java.lang.String TAGNAME_PAGE_SEPARATOR_DETAIL
另请参见：
常量字段值

TAGNAME_COMMENT

public static final java.lang.String TAGNAME_COMMENT
另请参见：
常量字段值

REG_REMOVE_COMMENT

public static final java.lang.String REG_REMOVE_COMMENT
另请参见：
常量字段值

TAGNAME_VARIABLE

public static final java.lang.String TAGNAME_VARIABLE
tag name: variable

另请参见：
常量字段值

TAGNAME_VARIABLE_ENUM

public static final java.lang.String TAGNAME_VARIABLE_ENUM
tag name: variable enum

另请参见：
常量字段值

TAGNAME_TEMPLATE

public static final java.lang.String TAGNAME_TEMPLATE
tag name: nested template

另请参见：
常量字段值

TAGNAME_RECORD

public static final java.lang.String TAGNAME_RECORD
tag name: record

另请参见：
常量字段值

TAGNAME_EXISTSDATA

public static final java.lang.String TAGNAME_EXISTSDATA
tag name: ExistsData

另请参见：
常量字段值

TAGNAME_NOTEXISTSDATA

public static final java.lang.String TAGNAME_NOTEXISTSDATA
tag name: NotExistsData

另请参见：
常量字段值

DEF_PAGE_FILENAME_OUTLINE

public static final java.lang.String DEF_PAGE_FILENAME_OUTLINE
default file name of outline pages

另请参见：
常量字段值

DEF_PAGE_FILEEXT

public static final java.lang.String DEF_PAGE_FILEEXT
default file extent of detail pages

另请参见：
常量字段值

QUOTE_FAMILYINDEX_PARENT

public static final int QUOTE_FAMILYINDEX_PARENT
child index value when the quoted folder is the parent of current folder

另请参见：
常量字段值

QUOTE_FAMILYINDEX_SELF

public static final int QUOTE_FAMILYINDEX_SELF
child index value when the quoted folder is its self

另请参见：
常量字段值

QUOTE_FAMILYINDEX_MIN

public static final int QUOTE_FAMILYINDEX_MIN
child index minimum value

另请参见：
常量字段值

QUOTE_TYPE_ANY

public static final int QUOTE_TYPE_ANY
template quote type: any

另请参见：
常量字段值

QUOTE_TYPE_CONTENT

public static final int QUOTE_TYPE_CONTENT
template quote type: using content information

另请参见：
常量字段值

QUOTE_TYPE_FOLDER

public static final int QUOTE_TYPE_FOLDER
template quote type: using folder infomation

另请参见：
常量字段值

PUBLISH_UNKNOWN

public static final int PUBLISH_UNKNOWN
publish type: unknown

另请参见：
常量字段值

PUBLISH_FOLDER_INCREASING

public static final int PUBLISH_FOLDER_INCREASING
publish type：increasing-publish folder, include the outline pages and all the contents who have not been published but can be published.

另请参见：
常量字段值

PUBLISH_FOLDER_FULLY

public static final int PUBLISH_FOLDER_FULLY
publish type: full-publish folder, include the outline pages and all the detailed pages.

另请参见：
常量字段值

PUBLISH_FOLDER_REFRESH

public static final int PUBLISH_FOLDER_REFRESH
publish type: refresh folder published page, just refreshing the outline pages.

另请参见：
常量字段值

PUBLISH_CONTENT

public static final int PUBLISH_CONTENT
publish type: publish a content

另请参见：
常量字段值

PUBLISH_MYSELF_ONLY

public static final int PUBLISH_MYSELF_ONLY
publish type: publish the pages of myself only; for a folder, they are the outline pages; for a content, it is the detailed page.

另请参见：
常量字段值

PUBLISH_RECALL

public static final int PUBLISH_RECALL
publish type: recall the published pages

另请参见：
常量字段值

PUBLISH_FOLDER_SYNC

public static final int PUBLISH_FOLDER_SYNC
准确的说是分发任务，目录同步

另请参见：
常量字段值

PUBLISH_CONTENT_DIRECT

public static final int PUBLISH_CONTENT_DIRECT
文档的直接发布，绕开关于发布状态的限制，直接单篇（将来也许多篇）发布文档

另请参见：
常量字段值

PUBLISH_FOLDER_REFRESH_ON_DEL_CONTENT

public static final int PUBLISH_FOLDER_REFRESH_ON_DEL_CONTENT
删除内容时候触发的栏目更新发布

另请参见：
常量字段值

PUBLISH_TYPES_OF_FOLDER

public static final int[] PUBLISH_TYPES_OF_FOLDER
all folder publish types list

PUBLISH_TYPES_OF_CONTENT

public static final int[] PUBLISH_TYPES_OF_CONTENT
all content publish types list

STATUS_UNKNOWN

public static final int STATUS_UNKNOWN
publish status: unknown

另请参见：
常量字段值

STATUS_DELETED

public static final int STATUS_DELETED
publish status: has been deleted

另请参见：
常量字段值

STATUS_FORBIDDEN

public static final int STATUS_FORBIDDEN
publish status: is forbidden to publish

另请参见：
常量字段值

STATUS_OPEN

public static final int STATUS_OPEN
publish status: is open and can be published

另请参见：
常量字段值

STATUS_PUBLISHING

public static final int STATUS_PUBLISHING
publish status: is during publishing process

另请参见：
常量字段值

STATUS_PUBLISHED

public static final int STATUS_PUBLISHED
publish status: has been published

另请参见：
常量字段值

TASK_PRIORITY_REAL

public static final int TASK_PRIORITY_REAL
必须马上执行的任务

另请参见：
常量字段值

TASK_PRIORITY_HIGH

public static final int TASK_PRIORITY_HIGH
task level: urgent

另请参见：
常量字段值

TASK_PRIORITY_NORM

public static final int TASK_PRIORITY_NORM
task level: normal

另请参见：
常量字段值

TASK_PRIORITY_LOW

public static final int TASK_PRIORITY_LOW
task level: low

另请参见：
常量字段值

TASK_STATUS_UNKNOWN

public static final int TASK_STATUS_UNKNOWN
task status: unknown

另请参见：
常量字段值

TASK_STATUS_WAITING

public static final int TASK_STATUS_WAITING
task status: is waiting

另请参见：
常量字段值

TASK_STATUS_RUNNING

public static final int TASK_STATUS_RUNNING
task status: is running

另请参见：
常量字段值

TASK_STATUS_FINISHED_WITHWARNINGS

public static final int TASK_STATUS_FINISHED_WITHWARNINGS
task status: has been done but with warnings

另请参见：
常量字段值

TASK_STATUS_FINISHED

public static final int TASK_STATUS_FINISHED
task status: has been done

另请参见：
常量字段值

TASK_STATUS_EXPIRED

public static final int TASK_STATUS_EXPIRED
task status: time is expired

另请参见：
常量字段值

TASK_STATUS_FAILED

public static final int TASK_STATUS_FAILED
task status: failed

另请参见：
常量字段值

TASK_STATUS_CANCELED

public static final int TASK_STATUS_CANCELED
task status: has been canceled

另请参见：
常量字段值

TASK_STATUS_PARAM_INVALID

public static final int TASK_STATUS_PARAM_INVALID
task status: parameter is invalid

另请参见：
常量字段值

TASK_STATUS_PAUSED

public static final int TASK_STATUS_PAUSED
task status: has been paused

另请参见：
常量字段值

PGVARNAME_NAVTARGET

public static final java.lang.String PGVARNAME_NAVTARGET
另请参见：
常量字段值

PGVARNAME_NAVIDPRE

public static final java.lang.String PGVARNAME_NAVIDPRE
另请参见：
常量字段值

PGVARNAME_NAVSHOWPRENEXT

public static final java.lang.String PGVARNAME_NAVSHOWPRENEXT
另请参见：
常量字段值

PGVARNAME_NAVSHOWHEADTAIL

public static final java.lang.String PGVARNAME_NAVSHOWHEADTAIL
另请参见：
常量字段值

PGVARNAME_NAVPAGES

public static final java.lang.String PGVARNAME_NAVPAGES
另请参见：
常量字段值

PGVARNAME_NAVEXTRA

public static final java.lang.String PGVARNAME_NAVEXTRA
另请参见：
常量字段值

PGVARNAME_CURREXTRA

public static final java.lang.String PGVARNAME_CURREXTRA
另请参见：
常量字段值

PGVARNAME_PREDESC

public static final java.lang.String PGVARNAME_PREDESC
另请参见：
常量字段值

PGVARNAME_NEXTDESC

public static final java.lang.String PGVARNAME_NEXTDESC
另请参见：
常量字段值

PGVARNAME_HEADDESC

public static final java.lang.String PGVARNAME_HEADDESC
另请参见：
常量字段值

PGVARNAME_TAILDESC

public static final java.lang.String PGVARNAME_TAILDESC
另请参见：
常量字段值

PGVARNAME_OUTLINENAV

public static final java.lang.String PGVARNAME_OUTLINENAV
另请参见：
常量字段值

PGVARNAME_WMLIMAGE

public static final java.lang.String PGVARNAME_WMLIMAGE
另请参见：
常量字段值

PGVARNAME_WMLIMAGEDESC

public static final java.lang.String PGVARNAME_WMLIMAGEDESC
另请参见：
常量字段值

PGVARNAME_WMLIMAGEFILE

public static final java.lang.String PGVARNAME_WMLIMAGEFILE
另请参见：
常量字段值

PGVARNAME_WMLIMAGECOUNT

public static final java.lang.String PGVARNAME_WMLIMAGECOUNT
另请参见：
常量字段值
方法详细信息

getPublishTypeName

public static java.lang.String getPublishTypeName(int _nPublishType,
                                                  java.lang.String _sDefault)
get the name of a publish type

参数：
_nPublishType - the publish type
_sDefault - default name if the publish type is unknown
返回：
Returns the default name if the type is unknown; othwise, returns the publish type name;

getPublishTypeName

public static java.lang.String getPublishTypeName(int _nPublishType,
                                                  java.lang.String _sDefault,
                                                  boolean _bIsContent)

isPublishTypeOfFolder

public static boolean isPublishTypeOfFolder(int _nPublishType)
check if a publish type is a folder publish type

参数：
_nPublishType - the specified publish type
返回：
Returns true if the publish type is a folder publish type; othserwise, returns false.

isPublishTypeOfContent

public static boolean isPublishTypeOfContent(int _nPublishType)
check if a publish type is a folder publish type

参数：
_nPublishType - the specified publish type
返回：
Returns true if the publish type is a folder publish type; othserwise, returns false.

isTaskExecuted

public static boolean isTaskExecuted(int _nStatus)
check if a task has been executed

参数：
_nStatus - status of the task
返回：
Returns true if the task has been executed; otherwise, returns false.

isTaskFailed

public static boolean isTaskFailed(int _nStatus)
check if a task is failed.

参数：
_nStatus - status of the task.
返回：
Returns true if the task is failed; otherwise, returns false.

getAllTaskStatuses

public static int[] getAllTaskStatuses()
返回：
Returns all the task statuses
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishUpdateCommderImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish
类 PublishUpdateCommderImpl

java.lang.Object
    继承者  com.trs.components.common.publish.PublishUpdateCommderImpl
所有已实现的接口：
IUpdateCommander
public class PublishUpdateCommderImpl
extends java.lang.Object
implements IUpdateCommander

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishUpdateCommderImpl()
方法摘要
 void doUpdate()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishUpdateCommderImpl

public PublishUpdateCommderImpl()
方法详细信息

doUpdate

public void doUpdate()
指定者：
接口 IUpdateCommander 中的 doUpdate
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.OrignHomePublishException 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.OrignHomePublishException
的使用

没有 com.trs.components.common.publish.OrignHomePublishException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.PublishConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.PublishConstants
的使用

没有 com.trs.components.common.publish.PublishConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.PublishUpdateCommderImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.PublishUpdateCommderImpl
的使用

没有 com.trs.components.common.publish.PublishUpdateCommderImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.publish.config
类
PublishDistributionTargetType
PublishElementType
PublishServerConfigMapper


com.trs.components.common.publish.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.config

类摘要
PublishDistributionTargetType | Title: TRS 内容协作平台（TRS WCM） Description: publish distribute target type.
PublishElementType | Title: TRS 内容协作平台（TRS WCM） Description: publish element type.
PublishServerConfigMapper | Title: TRS 内容协作平台（TRS WCM） Description: the publish server configuration.


com.trs.components.common.publish.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.config.PublishDistributionTargetType
    • com.trs.components.common.publish.config.PublishElementType
    • com.trs.components.common.publish.config.PublishServerConfigMapper (implements org.aton.container.IClearable)


软件包 com.trs.components.common.publish.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.config
的使用

使用 com.trs.components.common.publish.config 的软件包
com.trs.components.common.publish.config
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.config 使用的 com.trs.components.common.publish.config 中的类
PublishDistributionTargetType
Title: TRS 内容协作平台（TRS WCM）
Description:
publish distribute target type.
PublishElementType
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element type.
PublishServerConfigMapper
Title: TRS 内容协作平台（TRS WCM）
Description:
the publish server configuration.

com.trs.service 使用的 com.trs.components.common.publish.config 中的类
PublishDistributionTargetType
Title: TRS 内容协作平台（TRS WCM）
Description:
publish distribute target type.

com.trs.service.impl 使用的 com.trs.components.common.publish.config 中的类
PublishDistributionTargetType
Title: TRS 内容协作平台（TRS WCM）
Description:
publish distribute target type.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishDistributionTargetType

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config
类 PublishDistributionTargetType

java.lang.Object
    继承者  com.trs.components.common.publish.config.PublishDistributionTargetType

public class PublishDistributionTargetType
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
publish distribute target type.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishDistributionTargetType()
constructor: default
方法摘要
IFileDistristributor | createDistributor() create a distributor instance
void | fromConfigElement(TargetTypeConfig _element) read from a XML element
java.lang.String | getDesc()
java.lang.String | getDistributorClassName()
java.lang.String | getName()
AttributesString | getParameters() Returns the parameters config.
void | setDesc(java.lang.String desc)
void | setDistributorClassName(java.lang.String _sClassName)
void | setName(java.lang.String _sName)
void | setParameters(java.lang.String _sParameters) set the parameters config
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PublishDistributionTargetType

public PublishDistributionTargetType()
constructor: default

方法详细信息

getName

public java.lang.String getName()
返回：
Returns the type name

setName

public void setName(java.lang.String _sName)
             throws WCMException
参数：
_sName - type name
抛出：
WCMException

getDesc

public java.lang.String getDesc()
返回：
Returns the description.

setDesc

public void setDesc(java.lang.String desc)
参数：
desc - get the description.

getDistributorClassName

public java.lang.String getDistributorClassName()
返回：
Returns the class name of the shipper

setParameters

public void setParameters(java.lang.String _sParameters)
set the parameters config

参数：
_sParameters - the parameters config

getParameters

public AttributesString getParameters()
Returns the parameters config.
Format: <Parameter name(String), Parameter description(String)>

返回：
the parameters config

setDistributorClassName

public void setDistributorClassName(java.lang.String _sClassName)
                             throws WCMException
参数：
_sClassName - class name of the distributor
抛出：
WCMException

createDistributor

public IFileDistristributor createDistributor()
                                       throws WCMException
create a distributor instance

返回：
Returns the distributor instance created.
抛出：
WCMException - if failed to create new instance.

fromConfigElement

public void fromConfigElement(TargetTypeConfig _element)
                       throws WCMException
read from a XML element

参数：
_element - a XML element.
抛出：
WCMException - if failed to read the XML element.

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
另请参见：
Object.toString()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


PublishElementType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config
类 PublishElementType

java.lang.Object
    继承者  com.trs.components.common.publish.config.PublishElementType

public class PublishElementType
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
publish element type.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishElementType()
方法摘要
IPublishElement | createBean() create a new bean instance
void | fromConfigElement(PublishElementConfig _properties) read properties from CMyBaseConfig, which may be imported from a XML file.
java.lang.String | getClassName()
java.lang.String | getName()
int | getType()
boolean | isFolder() Returns true if this type is a folder.
void | setClassName(java.lang.String _sClassName)
void | setIsFolder(boolean _isFolder)
void | setName(java.lang.String name)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PublishElementType

public PublishElementType()
方法详细信息

getType

public int getType()
返回：
Returns the type number

getName

public java.lang.String getName()
返回：
Returns the name of this type

setName

public void setName(java.lang.String name)
参数：
name - the name of this type

getClassName

public java.lang.String getClassName()
返回：
Returns the java bean class name of this type, which is an implementation of IPublishFolder/IPublishContent

setClassName

public void setClassName(java.lang.String _sClassName)
参数：
_sClassName - the java bean class name implementation of this type

isFolder

public boolean isFolder()
Returns true if this type is a folder.

返回：
true if this type is a folder

setIsFolder

public void setIsFolder(boolean _isFolder)
参数：
_isFolder - if this type is a folder

createBean

public IPublishElement createBean()
                           throws WCMException
create a new bean instance

返回：
Returns the new publish factor instance created.
抛出：
WCMException - if failed to create new instance.

fromConfigElement

public void fromConfigElement(PublishElementConfig _properties)
                       throws WCMException
read properties from CMyBaseConfig, which may be imported from a XML file.

参数：
_properties -
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
另请参见：
Object.toString()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishServerConfigMapper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config
类 PublishServerConfigMapper

java.lang.Object
    继承者  com.trs.components.common.publish.config.PublishServerConfigMapper
所有已实现的接口：
org.aton.container.IClearable
public class PublishServerConfigMapper
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
the publish server configuration.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | clear()
static java.lang.String | getDefaultEncoding() Returns the default file encoding.
static FileNamedStyle | getDetailFileNamedStyle()
static FileNamedStyle | getDetailFileNamedStyle(java.lang.String _sFileNamedStyleId)
static java.lang.String | getDirDividedByDateFormat(boolean _bLocalFileSystemFormat) Returns the format to divide publish directory.
static PublishDistributionConfig | getDistributionConfig() Returns the distribution configuration.
static java.util.Map | getDistributionTargetTypes() Returns the distribution target types mapping.
static PublishElementType | getElementType(int _nType) lookup the folder type by type number
static PublishServerConfigMapper | getInstance() get the instance
static LaborResourceConfig | getLaborResourceConfig() get the labor resource configurator.
static int | getLoadBatchContentsModal()
static int | getLoadBatchContentsPageSize()
static java.lang.String | getPublishSrvId()
static java.util.List | getTagFormattersConfigs() Returns the tag formatter config.
static TemplateParseConfig | getTemplateParseConfig() get the template parse configuration.
static java.lang.String[] | getTemplateSupportedApdExts() Returns the supported template appendix extends.
static java.lang.String[] | getTemplateSupportedExts() Returns the supported template extends.
static java.lang.String[] | getTemplateTagsHavingSrc() Returns the names list of those tags having src.
static java.lang.String[] | getTemplateTagSrcAttributeNames() Returns the src attribute names of those tags having src.
static boolean | isAutoPublishDocInHomeWhenNeeded() Returns true if to publish automatically the document who has not been published in its home folder when to publish the link of it.
static boolean | isDetailPageSeperateTo51Style()
static boolean | isDirDividedByDate() Returns true if the publish directory is divided by date.
static boolean | isIgnoreIfHostNotFound() Returns true if to ignore the error when the host is not found in tag item; false otherwise.
boolean | isLoaded()
static boolean | isPublishInRootPath() 是否直接将文件发布到站点的根目录下
static boolean | isSendWarningIfFileNotFound() Returns true if to send warning when file is not found.
static PublishDistributionTargetType | lookupDistributionTargetTypeByName(java.lang.String _sName) lookup the distribution target type by name.
void | refresh() load and refresh the configuration from XML file.
static void | setPublishSrvId(java.lang.String publishSrvId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getInstance

public static PublishServerConfigMapper getInstance()
                                             throws WCMException
get the instance

返回：
Returns the config instance.
抛出：
WCMException - if failed to load configuration from XML.

isLoaded

public boolean isLoaded()
返回：
Returns true if the configuration has been loaded; otherwise, returns false.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

refresh

public void refresh()
             throws WCMException
load and refresh the configuration from XML file.

抛出：
WCMException - if failed to load from XML file.

isDirDividedByDate

public static boolean isDirDividedByDate()
                                  throws WCMException
Returns true if the publish directory is divided by date.

返回：
true if the publish directory is divided by date.
抛出：
WCMException - if failed to load the config.

isPublishInRootPath

public static boolean isPublishInRootPath()
                                   throws WCMException
是否直接将文件发布到站点的根目录下

返回：
是：返回true; 否: 返回false
抛出：
WCMException

isDetailPageSeperateTo51Style

public static boolean isDetailPageSeperateTo51Style()
                                             throws WCMException
抛出：
WCMException

getLoadBatchContentsModal

public static int getLoadBatchContentsModal()
                                     throws WCMException
抛出：
WCMException

getLoadBatchContentsPageSize

public static int getLoadBatchContentsPageSize()
                                        throws WCMException
抛出：
WCMException

getDirDividedByDateFormat

public static java.lang.String getDirDividedByDateFormat(boolean _bLocalFileSystemFormat)
                                                  throws WCMException
Returns the format to divide publish directory.

参数：
_bLocalFileSystemFormat -
返回：
the format to divide publish directory.
抛出：
WCMException - if failed to load the config.

isSendWarningIfFileNotFound

public static boolean isSendWarningIfFileNotFound()
                                           throws WCMException
Returns true if to send warning when file is not found.

返回：
true if to send warning when file is not found.
抛出：
WCMException - if failed to load config.

isIgnoreIfHostNotFound

public static boolean isIgnoreIfHostNotFound()
                                      throws WCMException
Returns true if to ignore the error when the host is not found in tag item; false otherwise.

返回：
true if to ignore the error when the host is not found in tag item; false otherwise.
抛出：
WCMException - if failed to load config.

isAutoPublishDocInHomeWhenNeeded

public static boolean isAutoPublishDocInHomeWhenNeeded()
                                                throws WCMException
Returns true if to publish automatically the document who has not been published in its home folder when to publish the link of it.

返回：
true if to publish automatically the document who has not been published in its home folder when to publish the link of it.
抛出：
WCMException - if failed to load the config.

getDefaultEncoding

public static java.lang.String getDefaultEncoding()
                                           throws WCMException
Returns the default file encoding.

返回：
the default file encoding.
抛出：
WCMException - if failed to load the config.

getElementType

public static PublishElementType getElementType(int _nType)
                                         throws WCMException
lookup the folder type by type number

参数：
_nType - number of the folder type
返回：
Returns the folder type if it is found.
抛出：
java.lang.Exception - if failed to seek the folder type
WCMException

getLaborResourceConfig

public static LaborResourceConfig getLaborResourceConfig()
                                                  throws WCMException
get the labor resource configurator.
Format: <Parameter name(String), Parameter value(String)>

返回：
Returns the labor resource configuration
抛出：
WCMException - if failed to load the configuration.

getTemplateParseConfig

public static TemplateParseConfig getTemplateParseConfig()
                                                  throws WCMException
get the template parse configuration.
Format: <Parameter name(String), Parameter value(String)>

返回：
Returns the template parse configuration.
抛出：
WCMException - if failed to load the configuration.

getTemplateTagsHavingSrc

public static java.lang.String[] getTemplateTagsHavingSrc()
                                                   throws WCMException
Returns the names list of those tags having src.

返回：
the names list of those tags having src
抛出：
WCMException

getTemplateTagSrcAttributeNames

public static java.lang.String[] getTemplateTagSrcAttributeNames()
                                                          throws WCMException
Returns the src attribute names of those tags having src.

返回：
the src attribute names of those tags having src.
抛出：
WCMException

getTemplateSupportedExts

public static java.lang.String[] getTemplateSupportedExts()
                                                   throws WCMException
Returns the supported template extends.

返回：
the supported template extends
抛出：
WCMException

getTemplateSupportedApdExts

public static java.lang.String[] getTemplateSupportedApdExts()
                                                      throws WCMException
Returns the supported template appendix extends.

返回：
the supported template appendix extends
抛出：
WCMException

getTagFormattersConfigs

public static java.util.List getTagFormattersConfigs()
                                              throws WCMException
Returns the tag formatter config.

返回：
the tag formatter config.
抛出：
WCMException

getDistributionConfig

public static PublishDistributionConfig getDistributionConfig()
                                                       throws WCMException
Returns the distribution configuration.
Format: <Parameter Name(String), Parameter Value(String)>

返回：
the distribution configuration
抛出：
WCMException

getDistributionTargetTypes

public static java.util.Map getDistributionTargetTypes()
                                                throws WCMException
Returns the distribution target types mapping.
Format: <Name(String), Type(PublishDistributionTargetType)>

返回：
the distribution target types mapping
抛出：
WCMException

lookupDistributionTargetTypeByName

public static PublishDistributionTargetType lookupDistributionTargetTypeByName(java.lang.String _sName)
                                                                        throws WCMException
lookup the distribution target type by name.

参数：
_sName - the target type name.
返回：
the distribution target type if found, other null.
抛出：
WCMException

getPublishSrvId

public static java.lang.String getPublishSrvId()

setPublishSrvId

public static void setPublishSrvId(java.lang.String publishSrvId)

getDetailFileNamedStyle

public static FileNamedStyle getDetailFileNamedStyle(java.lang.String _sFileNamedStyleId)

getDetailFileNamedStyle

public static FileNamedStyle getDetailFileNamedStyle()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.config.PublishDistributionTargetType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.PublishDistributionTargetType
的使用

使用 PublishDistributionTargetType 的软件包
com.trs.components.common.publish.config
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.config 中 PublishDistributionTargetType 的使用

返回 PublishDistributionTargetType 的 com.trs.components.common.publish.config 中的方法
static PublishDistributionTargetType PublishServerConfigMapper.lookupDistributionTargetTypeByName(java.lang.String _sName)
lookup the distribution target type by name.

com.trs.service 中 PublishDistributionTargetType 的使用

返回 PublishDistributionTargetType 的 com.trs.service 中的方法
 PublishDistributionTargetType IWCMPublishElementService.lookupDistributionTargetTypeByName(java.lang.String _sName)
lookup the distribution target type by name.

com.trs.service.impl 中 PublishDistributionTargetType 的使用

返回 PublishDistributionTargetType 的 com.trs.service.impl 中的方法
 PublishDistributionTargetType WCMPublishElementServiceImpl.lookupDistributionTargetTypeByName(java.lang.String _sName)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.PublishElementType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.PublishElementType
的使用

使用 PublishElementType 的软件包
com.trs.components.common.publish.config

com.trs.components.common.publish.config 中 PublishElementType 的使用

返回 PublishElementType 的 com.trs.components.common.publish.config 中的方法
static PublishElementType PublishServerConfigMapper.getElementType(int _nType)
lookup the folder type by type number

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.PublishServerConfigMapper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.PublishServerConfigMapper
的使用

使用 PublishServerConfigMapper 的软件包
com.trs.components.common.publish.config

com.trs.components.common.publish.config 中 PublishServerConfigMapper 的使用

返回 PublishServerConfigMapper 的 com.trs.components.common.publish.config 中的方法
static PublishServerConfigMapper PublishServerConfigMapper.getInstance()
get the instance

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ContentTypeConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 ContentTypeConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.PublishElementConfig
        继承者  com.trs.components.common.publish.config.persistent.ContentTypeConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class ContentTypeConfig
extends PublishElementConfig

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentTypeConfig()
方法摘要
从类 com.trs.components.common.publish.config.persistent.PublishElementConfig 继承的方法
getClassName, getName, setClassName, setName
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentTypeConfig

public ContentTypeConfig()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FileNamedStyle

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 FileNamedStyle

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.FileNamedStyle
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class FileNamedStyle
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
表征文件的命名规则，采用“三段式” ：前缀 + 标示体 + 附加字段
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | NAMED_ID
static int | NAMED_MULTIPLETEMPLATE
static int | NAMED_PUBTIME
构造方法摘要
FileNamedStyle()
constructor: default
FileNamedStyle(java.lang.String _prefix, java.lang.String _token, int _adden)
方法摘要
int | getAdden()
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getPattern()
java.lang.String | getPrefix()
java.lang.String | getToken()
void | setAdden(int adden)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setPattern(java.lang.String pattern)
void | setPrefix(java.lang.String prefix)
void | setToken(java.lang.String token)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NAMED_ID

public static final int NAMED_ID
另请参见：
常量字段值

NAMED_PUBTIME

public static final int NAMED_PUBTIME
另请参见：
常量字段值

NAMED_MULTIPLETEMPLATE

public static final int NAMED_MULTIPLETEMPLATE
另请参见：
常量字段值
构造方法详细信息

FileNamedStyle

public FileNamedStyle()
constructor: default

FileNamedStyle

public FileNamedStyle(java.lang.String _prefix,
                      java.lang.String _token,
                      int _adden)
方法详细信息

getPrefix

public java.lang.String getPrefix()

setPrefix

public void setPrefix(java.lang.String prefix)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getAdden

public int getAdden()

setAdden

public void setAdden(int adden)

getToken

public java.lang.String getToken()

setToken

public void setToken(java.lang.String token)

getPattern

public java.lang.String getPattern()
返回：
Returns the pattern.

setPattern

public void setPattern(java.lang.String pattern)
参数：
pattern - The pattern to set.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FolderTypeConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 FolderTypeConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.PublishElementConfig
        继承者  com.trs.components.common.publish.config.persistent.FolderTypeConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class FolderTypeConfig
extends PublishElementConfig

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FolderTypeConfig()
方法摘要
从类 com.trs.components.common.publish.config.persistent.PublishElementConfig 继承的方法
getClassName, getName, setClassName, setName
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FolderTypeConfig

public FolderTypeConfig()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LaborResourceConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 LaborResourceConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.LaborResourceConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class LaborResourceConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LaborResourceConfig()
方法摘要
int | getEachTaskLaborsMax()
int | getHighPriorityLaborsMax()
int | getLowPriorityLaborsMax()
java.lang.String | getName() 获取配置对象的名称
int | getRetryInterval()
int | getRetryTimeLimit()
void | setEachTaskLaborsMax(int eachTaskLaborsMax)
void | setHighPriorityLaborsMax(int highPriorityLaborsMax)
void | setLowPriorityLaborsMax(int lowPriorityLaborsMax)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setRetryInterval(int retryInterval)
void | setRetryTimeLimit(int retryTimeLimit)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LaborResourceConfig

public LaborResourceConfig()
方法详细信息

getEachTaskLaborsMax

public int getEachTaskLaborsMax()

setEachTaskLaborsMax

public void setEachTaskLaborsMax(int eachTaskLaborsMax)

getHighPriorityLaborsMax

public int getHighPriorityLaborsMax()

setHighPriorityLaborsMax

public void setHighPriorityLaborsMax(int highPriorityLaborsMax)

getLowPriorityLaborsMax

public int getLowPriorityLaborsMax()

setLowPriorityLaborsMax

public void setLowPriorityLaborsMax(int lowPriorityLaborsMax)

getRetryTimeLimit

public int getRetryTimeLimit()
返回：
Returns the retryTimeLimit.

setRetryTimeLimit

public void setRetryTimeLimit(int retryTimeLimit)
参数：
retryTimeLimit - The retryTimeLimit to set.

getRetryInterval

public int getRetryInterval()
返回：
Returns the retryInterval.

setRetryInterval

public void setRetryInterval(int retryInterval)
参数：
retryInterval - The retryInterval to set.

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.config.persistent
类
ContentTypeConfig
FileNamedStyle
FolderTypeConfig
LaborResourceConfig
PublishDistributionConfig
PublishElementConfig
PublishServerConfig
TagFormatterConfig
TargetTypeConfig
TemplateParseConfig


com.trs.components.common.publish.config.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.config.persistent

类摘要
ContentTypeConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FileNamedStyle | Title: TRS 内容协作平台（TRS WCM） Description: 表征文件的命名规则，采用“三段式” ：前缀 + 标示体 + 附加字段 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FolderTypeConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LaborResourceConfig | Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishDistributionConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishElementConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishServerConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagFormatterConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TargetTypeConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.publish.config.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.config.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.config.persistent.FileNamedStyle (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.config.persistent.LaborResourceConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.config.persistent.PublishDistributionConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.config.persistent.PublishElementConfig (implements com.trs.infra.config.persistent.IConfigElement)
      • com.trs.components.common.publish.config.persistent.ContentTypeConfig
      • com.trs.components.common.publish.config.persistent.FolderTypeConfig
    • com.trs.components.common.publish.config.persistent.PublishServerConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.config.persistent.TagFormatterConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.config.persistent.TargetTypeConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.common.publish.config.persistent.TemplateParseConfig (implements com.trs.infra.config.persistent.IConfigElement)


软件包 com.trs.components.common.publish.config.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.config.persistent
的使用

使用 com.trs.components.common.publish.config.persistent 的软件包
com.trs.components.common.publish.config
com.trs.components.common.publish.config.persistent
com.trs.components.common.publish.persistent.element

com.trs.components.common.publish.config 使用的 com.trs.components.common.publish.config.persistent 中的类
FileNamedStyle
Title: TRS 内容协作平台（TRS WCM）
Description:
表征文件的命名规则，采用“三段式” ：前缀 + 标示体 + 附加字段
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LaborResourceConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishDistributionConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishElementConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TargetTypeConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.config.persistent 使用的 com.trs.components.common.publish.config.persistent 中的类
LaborResourceConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishDistributionConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishElementConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.element 使用的 com.trs.components.common.publish.config.persistent 中的类
FileNamedStyle
Title: TRS 内容协作平台（TRS WCM）
Description:
表征文件的命名规则，采用“三段式” ：前缀 + 标示体 + 附加字段
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishDistributionConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 PublishDistributionConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.PublishDistributionConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class PublishDistributionConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishDistributionConfig()
方法摘要
int | getMaxTargetsEachFolder()
java.lang.String | getName() 获取配置对象的名称
java.util.ArrayList | getTargetTypes()
void | setMaxTargetsEachFolder(int maxTargetsExcheFolder)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setTargetTypes(java.util.ArrayList targetTypes)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishDistributionConfig

public PublishDistributionConfig()
方法详细信息

getMaxTargetsEachFolder

public int getMaxTargetsEachFolder()

setMaxTargetsEachFolder

public void setMaxTargetsEachFolder(int maxTargetsExcheFolder)

getTargetTypes

public java.util.ArrayList getTargetTypes()

setTargetTypes

public void setTargetTypes(java.util.ArrayList targetTypes)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishElementConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 PublishElementConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.PublishElementConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
直接已知子类：
ContentTypeConfig, FolderTypeConfig
public class PublishElementConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishElementConfig()
方法摘要
java.lang.String | getClassName()
java.lang.String | getName() 获取配置对象的名称
void | setClassName(java.lang.String className)
void | setName(java.lang.String name) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishElementConfig

public PublishElementConfig()
方法详细信息

getClassName

public java.lang.String getClassName()

setClassName

public void setClassName(java.lang.String className)

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

setName

public void setName(java.lang.String name)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
name - 配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishServerConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 PublishServerConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.PublishServerConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class PublishServerConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishServerConfig()
方法摘要
java.util.ArrayList | getContentTypes()
java.lang.String | getDefaultEncoding()
java.lang.String | getDirDividedByDateFormat()
java.util.ArrayList | getFolderTypes()
LaborResourceConfig | getLaborResource()
int | getLoadBatchContentsModal()
int | getLoadBatchContentsPageSize()
java.lang.String | getName() 获取配置对象的名称
PublishDistributionConfig | getPublishDistribution()
java.util.ArrayList | getTagFormatters()
TemplateParseConfig | getTemplateParse()
boolean | isAutoPublishDocInHomeWhenNeeded()
boolean | isDetailPageSeperateTo51Style()
boolean | isDirDividedByDate()
boolean | isIgnoreIfHostNotFound()
boolean | isPublishInRootPath()
boolean | isSendWarningIfFileNotFound()
void | setAutoPublishDocInHomeWhenNeeded(boolean autoPublishDocInHomeWhenNeeded)
void | setContentTypes(java.util.ArrayList contentType)
void | setDefaultEncoding(java.lang.String defaultEncoding)
void | setDetailPageSeperateTo51Style(boolean _bDetailPageSeperateTo51Style)
void | setDirDividedByDate(boolean dirDividedByDate)
void | setDirDividedByDateFormat(java.lang.String dirDividedByDateFormat)
void | setFolderTypes(java.util.ArrayList folderType)
void | setIgnoreIfHostNotFound(boolean ignoreIfHostNotFound)
void | setLaborResource(LaborResourceConfig laborResource)
void | setLoadBatchContentsModal(int loadBatchContentsModal)
void | setLoadBatchContentsPageSize(int loadBatchContentsPageSize)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setPublishDistribution(PublishDistributionConfig publishDistribution)
void | setPublishInRootPath(boolean _bPublishInRootPath)
void | setSendWarningIfFileNotFound(boolean sendWarningIfFileNotFound)
void | setTagFormatters(java.util.ArrayList templateFormat)
void | setTemplateParse(TemplateParseConfig templateParse)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishServerConfig

public PublishServerConfig()
方法详细信息

getContentTypes

public java.util.ArrayList getContentTypes()

setContentTypes

public void setContentTypes(java.util.ArrayList contentType)

getFolderTypes

public java.util.ArrayList getFolderTypes()

setFolderTypes

public void setFolderTypes(java.util.ArrayList folderType)

getLaborResource

public LaborResourceConfig getLaborResource()

setLaborResource

public void setLaborResource(LaborResourceConfig laborResource)

getPublishDistribution

public PublishDistributionConfig getPublishDistribution()

setPublishDistribution

public void setPublishDistribution(PublishDistributionConfig publishDistribution)

getTemplateParse

public TemplateParseConfig getTemplateParse()

setTemplateParse

public void setTemplateParse(TemplateParseConfig templateParse)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

isAutoPublishDocInHomeWhenNeeded

public boolean isAutoPublishDocInHomeWhenNeeded()

setAutoPublishDocInHomeWhenNeeded

public void setAutoPublishDocInHomeWhenNeeded(boolean autoPublishDocInHomeWhenNeeded)

isPublishInRootPath

public boolean isPublishInRootPath()

setPublishInRootPath

public void setPublishInRootPath(boolean _bPublishInRootPath)

isDetailPageSeperateTo51Style

public boolean isDetailPageSeperateTo51Style()

setDetailPageSeperateTo51Style

public void setDetailPageSeperateTo51Style(boolean _bDetailPageSeperateTo51Style)

isDirDividedByDate

public boolean isDirDividedByDate()

setDirDividedByDate

public void setDirDividedByDate(boolean dirDividedByDate)

isIgnoreIfHostNotFound

public boolean isIgnoreIfHostNotFound()

setIgnoreIfHostNotFound

public void setIgnoreIfHostNotFound(boolean ignoreIfHostNotFound)

isSendWarningIfFileNotFound

public boolean isSendWarningIfFileNotFound()

setSendWarningIfFileNotFound

public void setSendWarningIfFileNotFound(boolean sendWarningIfFileNotFound)

getTagFormatters

public java.util.ArrayList getTagFormatters()

setTagFormatters

public void setTagFormatters(java.util.ArrayList templateFormat)

getDefaultEncoding

public java.lang.String getDefaultEncoding()

setDefaultEncoding

public void setDefaultEncoding(java.lang.String defaultEncoding)

getDirDividedByDateFormat

public java.lang.String getDirDividedByDateFormat()

setDirDividedByDateFormat

public void setDirDividedByDateFormat(java.lang.String dirDividedByDateFormat)

getLoadBatchContentsModal

public int getLoadBatchContentsModal()
返回：

setLoadBatchContentsModal

public void setLoadBatchContentsModal(int loadBatchContentsModal)
参数：
loadBatchContentsModal -

getLoadBatchContentsPageSize

public int getLoadBatchContentsPageSize()
返回：

setLoadBatchContentsPageSize

public void setLoadBatchContentsPageSize(int loadBatchContentsPageSize)
参数：
loadBatchContentsPageSize -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagFormatterConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 TagFormatterConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.TagFormatterConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class TagFormatterConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagFormatterConfig()
方法摘要
java.lang.String | getClassName()
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getTagName()
void | setClassName(java.lang.String className)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setTagName(java.lang.String tagName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagFormatterConfig

public TagFormatterConfig()
方法详细信息

getClassName

public java.lang.String getClassName()

setClassName

public void setClassName(java.lang.String className)

getTagName

public java.lang.String getTagName()

setTagName

public void setTagName(java.lang.String tagName)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TargetTypeConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 TargetTypeConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.TargetTypeConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class TargetTypeConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TargetTypeConfig()
方法摘要
java.lang.String | getDesc()
java.lang.String | getDistributor()
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getParameters()
void | setDesc(java.lang.String desc)
void | setDistributor(java.lang.String distributor)
void | setName(java.lang.String name) 设置配置对象的名称
void | setParameters(java.lang.String parameters)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TargetTypeConfig

public TargetTypeConfig()
方法详细信息

getDesc

public java.lang.String getDesc()

setDesc

public void setDesc(java.lang.String desc)

getDistributor

public java.lang.String getDistributor()

setDistributor

public void setDistributor(java.lang.String distributor)

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

setName

public void setName(java.lang.String name)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
name - 配置对象的名称

getParameters

public java.lang.String getParameters()

setParameters

public void setParameters(java.lang.String parameters)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParseConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.config.persistent
类 TemplateParseConfig

java.lang.Object
    继承者  com.trs.components.common.publish.config.persistent.TemplateParseConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class TemplateParseConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateParseConfig()
方法摘要
int | getDomCacheMaxSize()
java.lang.String | getName() 获取配置对象的名称
int | getNameCacheMaxSize()
java.lang.String | getSupportedApdExts()
java.lang.String | getSupportedExts()
java.lang.String | getTagsHavingSrc()
java.lang.String | getTagSrcAttributeNames()
int | getWcmOutlineContentsMaxNum()
void | setDomCacheMaxSize(int resultCacheMaxSize)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setNameCacheMaxSize(int nameCacheMaxSize)
void | setSupportedApdExts(java.lang.String supportedApdExts)
void | setSupportedExts(java.lang.String supportedExts)
void | setTagsHavingSrc(java.lang.String tagsHavingSrc)
void | setTagSrcAttributeNames(java.lang.String tagSrcAttributeNames)
void | setWcmOutlineContentsMaxNum(int wcmOutlineContentsMaxNum)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateParseConfig

public TemplateParseConfig()
方法详细信息

getNameCacheMaxSize

public int getNameCacheMaxSize()

setNameCacheMaxSize

public void setNameCacheMaxSize(int nameCacheMaxSize)

getDomCacheMaxSize

public int getDomCacheMaxSize()

setDomCacheMaxSize

public void setDomCacheMaxSize(int resultCacheMaxSize)

getSupportedApdExts

public java.lang.String getSupportedApdExts()

setSupportedApdExts

public void setSupportedApdExts(java.lang.String supportedApdExts)

getSupportedExts

public java.lang.String getSupportedExts()

setSupportedExts

public void setSupportedExts(java.lang.String supportedExts)

getTagsHavingSrc

public java.lang.String getTagsHavingSrc()

setTagsHavingSrc

public void setTagsHavingSrc(java.lang.String tagsHavingSrc)

getTagSrcAttributeNames

public java.lang.String getTagSrcAttributeNames()

setTagSrcAttributeNames

public void setTagSrcAttributeNames(java.lang.String tagSrcAttributeNames)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getWcmOutlineContentsMaxNum

public int getWcmOutlineContentsMaxNum()

setWcmOutlineContentsMaxNum

public void setWcmOutlineContentsMaxNum(int wcmOutlineContentsMaxNum)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.config.persistent.ContentTypeConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.ContentTypeConfig
的使用

没有 com.trs.components.common.publish.config.persistent.ContentTypeConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.FileNamedStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.FileNamedStyle
的使用

使用 FileNamedStyle 的软件包
com.trs.components.common.publish.config
com.trs.components.common.publish.persistent.element

com.trs.components.common.publish.config 中 FileNamedStyle 的使用

返回 FileNamedStyle 的 com.trs.components.common.publish.config 中的方法
static FileNamedStyle | PublishServerConfigMapper.getDetailFileNamedStyle()
static FileNamedStyle | PublishServerConfigMapper.getDetailFileNamedStyle(java.lang.String _sFileNamedStyleId)

com.trs.components.common.publish.persistent.element 中 FileNamedStyle 的使用

返回 FileNamedStyle 的 com.trs.components.common.publish.persistent.element 中的方法
FileNamedStyle | PublishContentImplBase.getFileNamedStyle()
FileNamedStyle | IPublishContent.getFileNamedStyle()
FileNamedStyle | PublishContentWrapper.getFileNamedStyle()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.FolderTypeConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.FolderTypeConfig
的使用

没有 com.trs.components.common.publish.config.persistent.FolderTypeConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.LaborResourceConfig
的使用

使用 LaborResourceConfig 的软件包
com.trs.components.common.publish.config
com.trs.components.common.publish.config.persistent

com.trs.components.common.publish.config 中 LaborResourceConfig 的使用

返回 LaborResourceConfig 的 com.trs.components.common.publish.config 中的方法
static LaborResourceConfig PublishServerConfigMapper.getLaborResourceConfig()
get the labor resource configurator.

com.trs.components.common.publish.config.persistent 中 LaborResourceConfig 的使用

返回 LaborResourceConfig 的 com.trs.components.common.publish.config.persistent 中的方法
 LaborResourceConfig PublishServerConfig.getLaborResource()

参数类型为 LaborResourceConfig 的 com.trs.components.common.publish.config.persistent 中的方法
 void PublishServerConfig.setLaborResource(LaborResourceConfig laborResource)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig
的使用

使用 PublishDistributionConfig 的软件包
com.trs.components.common.publish.config
com.trs.components.common.publish.config.persistent

com.trs.components.common.publish.config 中 PublishDistributionConfig 的使用

返回 PublishDistributionConfig 的 com.trs.components.common.publish.config 中的方法
static PublishDistributionConfig PublishServerConfigMapper.getDistributionConfig()
Returns the distribution configuration.

com.trs.components.common.publish.config.persistent 中 PublishDistributionConfig 的使用

返回 PublishDistributionConfig 的 com.trs.components.common.publish.config.persistent 中的方法
 PublishDistributionConfig PublishServerConfig.getPublishDistribution()

参数类型为 PublishDistributionConfig 的 com.trs.components.common.publish.config.persistent 中的方法
 void PublishServerConfig.setPublishDistribution(PublishDistributionConfig publishDistribution)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.PublishElementConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.PublishElementConfig
的使用

使用 PublishElementConfig 的软件包
com.trs.components.common.publish.config
com.trs.components.common.publish.config.persistent

com.trs.components.common.publish.config 中 PublishElementConfig 的使用

参数类型为 PublishElementConfig 的 com.trs.components.common.publish.config 中的方法
 void PublishElementType.fromConfigElement(PublishElementConfig _properties)
read properties from CMyBaseConfig, which may be imported from a XML file.

com.trs.components.common.publish.config.persistent 中 PublishElementConfig 的使用

com.trs.components.common.publish.config.persistent 中 PublishElementConfig 的子类
class | ContentTypeConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FolderTypeConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.PublishServerConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.PublishServerConfig
的使用

没有 com.trs.components.common.publish.config.persistent.PublishServerConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.TagFormatterConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.TagFormatterConfig
的使用

没有 com.trs.components.common.publish.config.persistent.TagFormatterConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.TargetTypeConfig
的使用

使用 TargetTypeConfig 的软件包
com.trs.components.common.publish.config

com.trs.components.common.publish.config 中 TargetTypeConfig 的使用

参数类型为 TargetTypeConfig 的 com.trs.components.common.publish.config 中的方法
 void PublishDistributionTargetType.fromConfigElement(TargetTypeConfig _element)
read from a XML element

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.config.persistent.TemplateParseConfig
的使用

使用 TemplateParseConfig 的软件包
com.trs.components.common.publish.config
com.trs.components.common.publish.config.persistent

com.trs.components.common.publish.config 中 TemplateParseConfig 的使用

返回 TemplateParseConfig 的 com.trs.components.common.publish.config 中的方法
static TemplateParseConfig PublishServerConfigMapper.getTemplateParseConfig()
get the template parse configuration.

com.trs.components.common.publish.config.persistent 中 TemplateParseConfig 的使用

返回 TemplateParseConfig 的 com.trs.components.common.publish.config.persistent 中的方法
 TemplateParseConfig PublishServerConfig.getTemplateParse()

参数类型为 TemplateParseConfig 的 com.trs.components.common.publish.config.persistent 中的方法
 void PublishServerConfig.setTemplateParse(TemplateParseConfig templateParse)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.publish.domain
类
PublishServer


com.trs.components.common.publish.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.domain

类摘要
PublishServer Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.publish.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.components.common.publish.domain.PublishServer


软件包 com.trs.components.common.publish.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain
的使用

使用 com.trs.components.common.publish.domain 的软件包
com.trs.components.common.publish.domain

com.trs.components.common.publish.domain 使用的 com.trs.components.common.publish.domain 中的类
PublishServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain
类 PublishServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.components.common.publish.domain.PublishServer
所有已实现的接口：
IServer
public class PublishServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
PublishServer()
constructor: default
方法摘要
void | cancelTask(PublishTask _task) cancel the publish task if it has not been finished
void | cancelTask(PublishTasks _tasks) cancel each publish task in the collection
void | deleteContent(IPublishContent _content) delete a published content from the specified folder
void | deleteContents(IPublishElements _contents, IPublishFolder _folder) delete the published contents from the specified folder
void | deleteContents(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders)
void | deleteContents(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders, boolean _bUpdateStatus)
void | deleteContentsWithMirror(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders)
void | deleteFolder(IPublishFolder _folder) delete the content folder
void | deleteFolder(IPublishFolder _folder, boolean _bUpdateStatus)
void | deleteFolderSelfOnly(IPublishFolder _folder)
void | deleteTask(PublishTask _task) 删除单个任务
int | distributeFile(java.lang.String _sLocalFilePathName, IPublishElement _fileOwner) Distributes a specified file to the folder.
PublishTasks | getAllTasks(WCMFilter _filter) get all the publish tasks in the system
static PublishServer | getInstance() get the publish server instance
PublishTasks | getMyTasks(WCMFilter _filter) get the publish tasks of the specified user
PublishTask | getRunningTask(int iTaskID) 返回指定ID的正在执行的发布任务对象
java.util.Iterator | getRunningTasks() 返回所有的正在执行的任务
PublishTaskRuntime | getTaskRuntime(int iTaskID) 返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
static boolean | isValidateElement(int _nElementType, int _nElementId) 校验指定的发布元素合法性
static boolean | isValidateElement(IPublishElement _publishElement) 校验指定的发布元素合法性
void | pauseTask(PublishTask _task) 暂停指定任务的执行
java.lang.String | previewContent(IPublishContent _content, java.lang.String[] _warningsHolder) Previews a content and returns the URL of preview page.
java.lang.String | previewContent(IPublishContent _content, java.lang.String[] _warningsHolder, Template _template)
java.lang.String[] | previewFolder(IPublishFolder _folder, java.lang.String[] _warningsHolder) Previews a content folder and returns the URLs of preview pages.
java.lang.String[] | previewFolder(IPublishFolder _folder, java.lang.String[] _warningsHolder, Template _template)
void | publishConfirm(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile) 确认（批准）发布，其内部行为： 1.删除备份文件 2.重名名正式文件为备份文件 3.重名名临时文件为备份文件
void | publishContent(IPublishContent _content) publish a content in the specified folder
void | publishContent(IPublishContent _content, int _nPubType) publish a content in the specified folder with specified PubType
void | publishContent(IPublishContent _content, IPublishElements folders) 忽略文档的状态，在指定的Folder下发布文档
void | publishContents(IPublishElements _contents, IPublishFolder _folder, int _nPubType) publish the contents collection
void | publishFolder(IPublishFolder _folder, int _nPublishType) publish the content folder
void | redoTask(PublishTask _task) re-start a publish task
void | redoTask(PublishTasks _tasks) re-execute each publish task in the collection
void | resumeTask(PublishTask _task) 暂停指定任务的执行
static void | validateElement(int _nElementType, int _nElementId) 校验指定的发布对象是否有效
static void | validateElement(IPublishElement _publishElement) 校验指定的发布对象是否有效
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishServer

public PublishServer()
constructor: default

方法详细信息

getInstance

public static PublishServer getInstance()
get the publish server instance

返回：
Returns the publish server instance which has been started
抛出：
WCMException - if fails to create the publish server instance or fails to start the server.

previewFolder

public java.lang.String[] previewFolder(IPublishFolder _folder,
                                        java.lang.String[] _warningsHolder)
                                 throws WCMException
Previews a content folder and returns the URLs of preview pages.
If some warnings are found and the warnings holder is not null, those warnings will be stored in the first position of holder.

参数：
_folder - the content folder to preview
_warningsHolder - the holder to store the warnings during preview.
返回：
Returns the URL array of the content folder preview pages (one folder may have more than )
抛出：
java.lang.Exception - if the current user has no right or fails to preview
WCMException

previewFolder

public java.lang.String[] previewFolder(IPublishFolder _folder,
                                        java.lang.String[] _warningsHolder,
                                        Template _template)
                                 throws WCMException
抛出：
WCMException

previewContent

public java.lang.String previewContent(IPublishContent _content,
                                       java.lang.String[] _warningsHolder)
                                throws java.lang.Exception
Previews a content and returns the URL of preview page.
If some warnings are found and the warnings holder is not null, those warnings will be stored in the first position of holder.

参数：
_content - the content to preview
_warningsHolder - the holder to store the warnings during preview.
返回：
Returns the URL of the content preview page
抛出：
java.lang.Exception - if the current user has no right or fails to preview

previewContent

public java.lang.String previewContent(IPublishContent _content,
                                       java.lang.String[] _warningsHolder,
                                       Template _template)
                                throws java.lang.Exception
抛出：
java.lang.Exception

publishFolder

public void publishFolder(IPublishFolder _folder,
                          int _nPublishType)
                   throws WCMException
publish the content folder

参数：
_folder - the content folder to publish
_nPublishType - publish type which is defined in PublishConstants（eg. PUBLISH_ALL, PUBLISH_INC）
抛出：
java.lang.Exception - if the current user has no right or fails to publish the content folder
WCMException

deleteFolder

public void deleteFolder(IPublishFolder _folder)
                  throws java.lang.Exception
delete the content folder

参数：
_folder - a published content folder to delete
抛出：
java.lang.Exception - if the current user has no right or fails to delete the published folder

deleteFolder

public void deleteFolder(IPublishFolder _folder,
                         boolean _bUpdateStatus)
                  throws java.lang.Exception
参数：
_folder -
抛出：
java.lang.Exception

deleteFolderSelfOnly

public void deleteFolderSelfOnly(IPublishFolder _folder)
                          throws java.lang.Exception
抛出：
java.lang.Exception

publishContent

public void publishContent(IPublishContent _content,
                           IPublishElements folders)
                    throws WCMException
忽略文档的状态，在指定的Folder下发布文档

参数：
_content -
folders -
抛出：
WCMException

publishContent

public void publishContent(IPublishContent _content,
                           int _nPubType)
                    throws WCMException
publish a content in the specified folder with specified PubType

参数：
_content -
_nPubType -
抛出：
java.lang.Exception - if the current user has no right of fails to publish the content
WCMException

publishContent

public void publishContent(IPublishContent _content)
                    throws java.lang.Exception
publish a content in the specified folder

参数：
_content - the content to publish
抛出：
java.lang.Exception - if the current user has no right of fails to publish the content

publishContents

public void publishContents(IPublishElements _contents,
                            IPublishFolder _folder,
                            int _nPubType)
                     throws java.lang.Exception
publish the contents collection

参数：
_contents - the contents collection to publish
_folder - the folder which the contents lie in
_nPubType - Publish Type
抛出：
java.lang.Exception - if the current user has no right or fails to publish the contents

deleteContent

public void deleteContent(IPublishContent _content)
                   throws java.lang.Exception
delete a published content from the specified folder

参数：
_content - the published content to delete
抛出：
java.lang.Exception - if the current user has no right or fails to delete the content

deleteContents

public void deleteContents(IPublishElements _contents,
                           IPublishFolder _folder)
                    throws java.lang.Exception
delete the published contents from the specified folder

参数：
_contents - the published contents to delete
_folder - the folder which the contents lie in
抛出：
java.lang.Exception - if the current user has no right or fails to delete the published contents

deleteContents

public void deleteContents(IPublishElements _contents,
                           IPublishFolder _folder,
                           IPublishElements _folders)
                    throws java.lang.Exception
抛出：
java.lang.Exception

deleteContents

public void deleteContents(IPublishElements _contents,
                           IPublishFolder _folder,
                           IPublishElements _folders,
                           boolean _bUpdateStatus)
                    throws java.lang.Exception
抛出：
java.lang.Exception

deleteContentsWithMirror

public void deleteContentsWithMirror(IPublishElements _contents,
                                     IPublishFolder _folder,
                                     IPublishElements _folders)
                              throws java.lang.Exception
抛出：
java.lang.Exception

getMyTasks

public PublishTasks getMyTasks(WCMFilter _filter)
                        throws java.lang.Exception
get the publish tasks of the specified user

参数：
_filter - the collection filter
返回：
Returns the tasks collection of the current user
抛出：
java.lang.Exception - if failed to fetch the tasks collection

getAllTasks

public PublishTasks getAllTasks(WCMFilter _filter)
                         throws java.lang.Exception
get all the publish tasks in the system

参数：
_filter - the collection filter
返回：
Returns the tasks collection
抛出：
java.lang.Exception - if the current user has no publish tasks management right or fails to fetch the collection

pauseTask

public void pauseTask(PublishTask _task)
               throws WCMException
暂停指定任务的执行

抛出：
WCMException

resumeTask

public void resumeTask(PublishTask _task)
                throws WCMException
暂停指定任务的执行

抛出：
WCMException

getTaskRuntime

public PublishTaskRuntime getTaskRuntime(int iTaskID)
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。

参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回其运行时对象PublishTaskRuntime， 否则返回 null。

getRunningTask

public PublishTask getRunningTask(int iTaskID)
返回指定ID的正在执行的发布任务对象

参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回发布任务对象PublishTask， 否则返回 null。

getRunningTasks

public java.util.Iterator getRunningTasks()
返回所有的正在执行的任务

返回：
所有的正在执行的任务

cancelTask

public void cancelTask(PublishTask _task)
                throws WCMException
cancel the publish task if it has not been finished

参数：
_task - the publish task to cancel
抛出：
java.lang.Exception - if the current user has no publish tasks management right or fails to cancel the task
WCMException

deleteTask

public void deleteTask(PublishTask _task)
                throws java.lang.Exception
删除单个任务

参数：
_task -
抛出：
java.lang.Exception

cancelTask

public void cancelTask(PublishTasks _tasks)
                throws java.lang.Exception
cancel each publish task in the collection

参数：
_tasks - publish tasks collection to cancel
抛出：
java.lang.Exception - if the current user has no publish tasks management right or fails to cancel the tasks

redoTask

public void redoTask(PublishTask _task)
              throws java.lang.Exception
re-start a publish task

参数：
_task - the publish task to redo
抛出：
java.lang.Exception - if failed to re-start the task

redoTask

public void redoTask(PublishTasks _tasks)
              throws java.lang.Exception
re-execute each publish task in the collection

参数：
_tasks - publish tasks collection to cancel
抛出：
java.lang.Exception - if the current user has no publish tasks management right or fails to re-start the tasks

distributeFile

public int distributeFile(java.lang.String _sLocalFilePathName,
                          IPublishElement _fileOwner)
                   throws WCMException
Distributes a specified file to the folder.
Publish server will upload file to all the distribution targets of folder.

参数：
_sLocalFilePathName - the local file full path name
_fileOwner - the file owner (a folder or a content)
返回：
the number of distributions
抛出：
WCMException - if failed to distribute the file.

validateElement

public static void validateElement(int _nElementType,
                                   int _nElementId)
                            throws WCMException
校验指定的发布对象是否有效

参数：
_nElementType - 发布对象类型
_nElementId - 发布对象ID
抛出：
WCMException - 如果对象不存在,抛出异常
如果发布属性没有设置，抛出异常
如果发布对象所属的Folder不允许发布，抛出异常

validateElement

public static void validateElement(IPublishElement _publishElement)
                            throws WCMException
校验指定的发布对象是否有效

参数：
_publishElement - 指定的发布对象
抛出：
WCMException - 如果对象不存在,抛出异常
如果发布属性没有设置，抛出异常
如果发布对象所属的Folder不允许发布，抛出异常

isValidateElement

public static boolean isValidateElement(IPublishElement _publishElement)
校验指定的发布元素合法性

参数：
_publishElement - 指定的发布元素
返回：
如果合法，返回true;否则，返回false;

isValidateElement

public static boolean isValidateElement(int _nElementType,
                                        int _nElementId)
校验指定的发布元素合法性

参数：
_nElementType - 发布元素的类型
_nElementId - 发布元素的ID
返回：

publishConfirm

public void publishConfirm(IPublishFolder _folder,
                           java.lang.String _sSourceFile,
                           java.lang.String _sTargetFile,
                           java.lang.String _sBackupFile)
                    throws WCMException
确认（批准）发布，其内部行为： 1.删除备份文件 2.重名名正式文件为备份文件 3.重名名临时文件为备份文件

抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.domain.auth
类
TemplateRightObjImpl


com.trs.components.common.publish.domain.auth

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.domain.auth

类摘要
TemplateRightObjImpl Title: TRS 内容协作平台（TRS WCM）
Description:
模板权限判断的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.publish.domain.auth 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.auth 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.auth.TemplateRightObjImpl (implements com.trs.cms.auth.domain.IRightObj)


软件包 com.trs.components.common.publish.domain.auth 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.auth
的使用

没有 com.trs.components.common.publish.domain.auth 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TemplateRightObjImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.auth
类 TemplateRightObjImpl

java.lang.Object
    继承者  com.trs.components.common.publish.domain.auth.TemplateRightObjImpl
所有已实现的接口：
IRightObj, ICMSObjSubstanceContent
public class TemplateRightObjImpl
extends java.lang.Object
implements IRightObj

Title: TRS 内容协作平台（TRS WCM）
Description:
模板权限判断的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateRightObjImpl()
TemplateRightObjImpl(CMSObj _cmsObj)
TemplateRightObjImpl(int _nId)
方法摘要
boolean | equals(java.lang.Object _another)
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | hasRight(User _currUser, int _nRightIndex) 判断用户对于指定的对象是否具有指定的权限
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateRightObjImpl

public TemplateRightObjImpl()

TemplateRightObjImpl

public TemplateRightObjImpl(int _nId)
                     throws WCMException
抛出：
WCMException

TemplateRightObjImpl

public TemplateRightObjImpl(CMSObj _cmsObj)
方法详细信息

hasRight

public boolean hasRight(User _currUser,
                        int _nRightIndex)
                 throws WCMException
从接口 IRightObj 复制的描述
判断用户对于指定的对象是否具有指定的权限

指定者：
接口 IRightObj 中的 hasRight
参数：
_currUser - 指定的用户
_nRightIndex - 指定的权限值（定义在WCMRightTypes中）
返回：
如果具有，返回true;否则返回false
抛出：
WCMException

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl
的使用

没有 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.PublishServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.PublishServer
的使用

使用 PublishServer 的软件包
com.trs.components.common.publish.domain

com.trs.components.common.publish.domain 中 PublishServer 的使用

返回 PublishServer 的 com.trs.components.common.publish.domain 中的方法
static PublishServer PublishServer.getInstance()
get the publish server instance

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DistributionChangeListener

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
接口 DistributionChangeListener

所有已知实现类：
FileDistributorImpUnion
public interface DistributionChangeListener

在修改分发设置时（尤其是禁用），为了使已经在执行的分发任务获得即时的响应，而增加的接口

作者：
Martin (付成睿)

方法摘要
void | onChange(int iDistributionID) 指定ID的分发配置已经发生了实质性的改变，正在执行的分发任务，必须立即结束
void | onDelete(int iDistributionID) 指定ID的分发配置已经删除（也可能是禁用）

方法详细信息

onDelete

void onDelete(int iDistributionID)
指定ID的分发配置已经删除（也可能是禁用）

参数：
iDistributionID - 指定分发配置的ID

onChange

void onChange(int iDistributionID)
指定ID的分发配置已经发生了实质性的改变，正在执行的分发任务，必须立即结束

参数：
iDistributionID - 指定分发配置的ID
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FileDistributeQueue

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributeQueue

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributeQueue

public class FileDistributeQueue
extends java.lang.Object

TODO javadoc for com.trs.components.common.publish.domain.distribute.FileDistributeQueue

作者：
Martin (付成睿)

嵌套类摘要
 class FileDistributeQueue.Item
描述一个待分发的文件,及分发类型
字段摘要
static int | DELETE_FILE 删除文件
static int | DELETE_PATH 删除目录
static int | UPLOAD_FILE 分发文件
构造方法摘要
FileDistributeQueue(int iTaskID)
缺省构造方法
FileDistributeQueue(java.lang.String sFileName)
缺省构造方法
方法摘要
 FileDistributeQueue.Item getItem()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

UPLOAD_FILE

public static final int UPLOAD_FILE
分发文件

另请参见：
常量字段值

DELETE_FILE

public static final int DELETE_FILE
删除文件

另请参见：
常量字段值

DELETE_PATH

public static final int DELETE_PATH
删除目录

另请参见：
常量字段值
构造方法详细信息

FileDistributeQueue

public FileDistributeQueue(int iTaskID)
缺省构造方法

FileDistributeQueue

public FileDistributeQueue(java.lang.String sFileName)
缺省构造方法

方法详细信息

getItem

public FileDistributeQueue.Item getItem()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDistributeQueue.Item

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributeQueue.Item

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item
包容类：
FileDistributeQueue
public class FileDistributeQueue.Item
extends java.lang.Object

描述一个待分发的文件,及分发类型

构造方法摘要
FileDistributeQueue.Item()
缺省构造方法
方法摘要
java.lang.String | getLocalFile() 返回本地文件
boolean | getNoOverWrite() 返回是否禁止改写
java.lang.String | getRemotePath() 返回远程（目标）文件或者目录
int | getType() 返回分发类型
void | setLocalFile(java.lang.String local) 设置本地文件
void | setNoOverWrite(boolean notOver) 设置是否禁止改写
void | setRemotePath(java.lang.String remote) 设置远程（目标）文件或者目录
void | setType(int type) 设置分发类型
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileDistributeQueue.Item

public FileDistributeQueue.Item()
缺省构造方法

方法详细信息

getType

public final int getType()
返回分发类型

返回：
分发类型

setType

public final void setType(int type)
设置分发类型

参数：
type - 分发类型

getLocalFile

public final java.lang.String getLocalFile()
返回本地文件

返回：
本地文件

setLocalFile

public final void setLocalFile(java.lang.String local)
设置本地文件

参数：
local - 本地文件

getRemotePath

public final java.lang.String getRemotePath()
返回远程（目标）文件或者目录

返回：
远程（目标）文件或者目录

setRemotePath

public final void setRemotePath(java.lang.String remote)
设置远程（目标）文件或者目录

参数：
remote - 远程（目标）文件或者目录

getNoOverWrite

public boolean getNoOverWrite()
返回是否禁止改写

返回：
是否禁止改写

setNoOverWrite

public void setNoOverWrite(boolean notOver)
设置是否禁止改写

参数：
notOver - 是否禁止改写
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDistributeShip

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributeShip

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributeShip
所有已实现的接口：
org.aton.container.IClearable
public class FileDistributeShip
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
file distribute ship
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FileDistributeShip()
constructor: default
FileDistributeShip(PublishPathCompass _pathCompass)
constructor
方法摘要
void | clear()
int | distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner) Distributes a file to the specified folder.
int | distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner, java.lang.String _sSubDir) Distributes a file to the specified folder.
int | distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner, java.lang.String _sSubDir, boolean _bCheckDstFileExits)
boolean | getAsyncMode()
boolean | getBatchMode()
int | renameFile(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile)
int | renameFile(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath)
void | setAsyncMode(boolean asyncMode)
void | setBatchMode(boolean batchMode)
int | withdrawFile(java.lang.String _sFileName, IPublishElement _fileOwner) Withdraws a file.
int | withdrawFile(java.lang.String _sFileName, IPublishElement _fileOwner, java.lang.String _sFullDataPath)
int | withdrawFolder(IPublishFolder _folder) Withdraws a folder.
int | withdrawFolder(IPublishFolder _folder, java.util.List subdirs) 撤除指定folder的指定子目录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileDistributeShip

public FileDistributeShip()
constructor: default

FileDistributeShip

public FileDistributeShip(PublishPathCompass _pathCompass)
constructor

参数：
_pathCompass - the folder path compass (could be null)
方法详细信息

getAsyncMode

public boolean getAsyncMode()
返回：
Returns the asyncMode.

setAsyncMode

public void setAsyncMode(boolean asyncMode)
参数：
asyncMode - The asyncMode to set.

getBatchMode

public boolean getBatchMode()
返回：
Returns the batchMode.

setBatchMode

public void setBatchMode(boolean batchMode)
参数：
batchMode - The batchMode to set.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

distributeFile

public int distributeFile(java.lang.String _sLocalFile,
                          IPublishElement _fileOwner)
                   throws WCMException
Distributes a file to the specified folder.

参数：
_sLocalFile - the local file to distribute
_fileOwner - the file owner.
返回：
the number of distributions
抛出：
WCMException - if failed to distribute the file.

distributeFile

public int distributeFile(java.lang.String _sLocalFile,
                          IPublishElement _fileOwner,
                          java.lang.String _sSubDir)
                   throws WCMException
Distributes a file to the specified folder.

参数：
_sLocalFile - the local file to distribute
_fileOwner - the file owner.
_sSubDir - the sub directory in the file owner
返回：
the number of distributions
抛出：
WCMException - if failed to distribute the file.

distributeFile

public int distributeFile(java.lang.String _sLocalFile,
                          IPublishElement _fileOwner,
                          java.lang.String _sSubDir,
                          boolean _bCheckDstFileExits)
                   throws WCMException
抛出：
WCMException

withdrawFolder

public int withdrawFolder(IPublishFolder _folder)
                   throws WCMException
Withdraws a folder.

参数：
_folder - a publish folder.
返回：
the number of distrubitions withdrawed.
抛出：
WCMException - if failed to withdraw the folder.

withdrawFolder

public int withdrawFolder(IPublishFolder _folder,
                          java.util.List subdirs)
                   throws WCMException
撤除指定folder的指定子目录

参数：
_folder -
subdirs -
返回：
抛出：
WCMException

withdrawFile

public int withdrawFile(java.lang.String _sFileName,
                        IPublishElement _fileOwner)
                 throws WCMException
Withdraws a file.

参数：
_sFileName - the file name without path.
_fileOwner - the owner of the file
返回：
the number of distrubitions withdrawed.
抛出：
WCMException - if failed to withdraw the file.

withdrawFile

public int withdrawFile(java.lang.String _sFileName,
                        IPublishElement _fileOwner,
                        java.lang.String _sFullDataPath)
                 throws WCMException
抛出：
WCMException

renameFile

public int renameFile(IPublishFolder _folder,
                      java.lang.String _sSourceFile,
                      java.lang.String _sTargetFile)
               throws WCMException
抛出：
WCMException

renameFile

public int renameFile(IPublishFolder _folder,
                      java.lang.String _sSourceFile,
                      java.lang.String _sTargetFile,
                      java.lang.String _sFullDataPath)
               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDistributorFtpCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributorFtpCacheMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
已过时。 使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM）
Description:
ftp cache manager for file distribution.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

public class FileDistributorFtpCacheMgr
extends java.lang.Object
implements ICacheMgr

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FileDistributorFtpCacheMgr()
已过时。 constructor: defafult
方法摘要
void | clear() 已过时。 清除系统所有的Cache
boolean | init() 已过时。 初始化当前的Cache
FtpMgr | lookupFtpMgr(PublishDistribution _distribution) 已过时。 Returns the ftp manager of the specified distribution.
void | notifyOnAddObj(BaseObj _oObjAdded) 已过时。 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 已过时。 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 已过时。 修改一个对象后通知所有的Cache
boolean | reinit() 已过时。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileDistributorFtpCacheMgr

public FileDistributorFtpCacheMgr()
已过时。
constructor: defafult

方法详细信息

clear

public void clear()
已过时。
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

lookupFtpMgr

public FtpMgr lookupFtpMgr(PublishDistribution _distribution)
已过时。
Returns the ftp manager of the specified distribution.

参数：
_distribution - a publish distribution.
返回：
the ftp manager of the specified distribution.

init

public boolean init()
已过时。
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：

reinit

public boolean reinit()
已过时。
指定者：
接口 ICacheMgr 中的 reinit
返回：

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
已过时。
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
已过时。
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
已过时。
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDistributorFtpImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributorFtpImpl

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl
所有已实现的接口：
IFileDistristributor
已过时。 使用 FileDistributorImpFtpByTRS 代替 Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor implementation on ftp
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

public class FileDistributorFtpImpl
extends java.lang.Object
implements IFileDistristributor

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FileDistributorFtpImpl()
已过时。 constructor: default
方法摘要
void | distributeFile(java.lang.String _sLocalFilePathName, java.lang.String _sPathToSave, boolean _bCheckDstFileExits) 已过时。 Distributes a file.
int | getConfigID() 已过时。 返回相关配置项目的ID
boolean | renameFile(java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath) 已过时。 rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?
void | setTargetRoot(PublishDistribution _distribution) 已过时。 Sets the target root.
boolean | withdrawFile(java.lang.String _sFileName, java.lang.String _sPath) 已过时。 Withdraws a specified file in the path.
boolean | withdrawPath(java.lang.String _sPath) 已过时。 Withdraws a specified file path.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileDistributorFtpImpl

public FileDistributorFtpImpl()
已过时。
constructor: default

方法详细信息

getConfigID

public int getConfigID()
已过时。
从接口 IFileDistristributor 复制的描述
返回相关配置项目的ID

指定者：
接口 IFileDistristributor 中的 getConfigID
返回：
相关配置项目的ID

setTargetRoot

public void setTargetRoot(PublishDistribution _distribution)
已过时。
从接口 IFileDistristributor 复制的描述
Sets the target root.

指定者：
接口 IFileDistristributor 中的 setTargetRoot
参数：
_distribution - a publish distribution.
另请参见：
IFileDistristributor#setTargetRoot(PublishDistributionConfig)

distributeFile

public void distributeFile(java.lang.String _sLocalFilePathName,
                           java.lang.String _sPathToSave,
                           boolean _bCheckDstFileExits)
                    throws java.lang.Exception
已过时。
从接口 IFileDistristributor 复制的描述
Distributes a file.

指定者：
接口 IFileDistristributor 中的 distributeFile
参数：
_sLocalFilePathName - local file path name to distribute.
_sPathToSave - the path to save file.
_bCheckDstFileExits - 是否检查目标文件存在
抛出：
java.lang.Exception - if failed to distribute the file.
另请参见：
IFileDistristributor#distributeFile(String, String)

withdrawFile

public boolean withdrawFile(java.lang.String _sFileName,
                            java.lang.String _sPath)
                     throws java.lang.Exception
已过时。
从接口 IFileDistristributor 复制的描述
Withdraws a specified file in the path.

指定者：
接口 IFileDistristributor 中的 withdrawFile
参数：
_sFileName - the file to withdraw.
_sPath - the file path.
返回：
true if and only if the file is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the file.
另请参见：
IFileDistristributor.withdrawFile(String, String)

withdrawPath

public boolean withdrawPath(java.lang.String _sPath)
                     throws java.lang.Exception
已过时。
从接口 IFileDistristributor 复制的描述
Withdraws a specified file path.

指定者：
接口 IFileDistristributor 中的 withdrawPath
参数：
_sPath - the path to withdraw.
返回：
true if and only if the path is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the path.
另请参见：
IFileDistristributor.withdrawPath(String)

renameFile

public boolean renameFile(java.lang.String _sSourceFile,
                          java.lang.String _sTargetFile,
                          java.lang.String _sFullDataPath)
                   throws java.lang.Exception
已过时。
从接口 IFileDistristributor 复制的描述
rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?是不是叫作moveFile更合适一些?

指定者：
接口 IFileDistristributor 中的 renameFile
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDistributorImpFileLocal

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributorImpFileLocal

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal
所有已实现的接口：
IFileDistristributor
public class FileDistributorImpFileLocal
extends java.lang.Object
implements IFileDistristributor

IFileDistristributor的一个实现，使用本地文件系统进行分发。

作者：
Martin (付成睿)

构造方法摘要
FileDistributorImpFileLocal()
缺省构造方法
方法摘要
void | distributeFile(java.lang.String _sLocal, java.lang.String _sPath, boolean _bCheckDstFileExits) Distributes a file.
int | getConfigID() 返回相关配置项目的ID
boolean | renameFile(java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath) rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?
void | setTargetRoot(PublishDistribution _distribution) Sets the target root.
boolean | withdrawFile(java.lang.String _sFile, java.lang.String _sPath) Withdraws a specified file in the path.
boolean | withdrawPath(java.lang.String _sPath) Withdraws a specified file path.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileDistributorImpFileLocal

public FileDistributorImpFileLocal()
缺省构造方法

方法详细信息

getConfigID

public int getConfigID()
从接口 IFileDistristributor 复制的描述
返回相关配置项目的ID

指定者：
接口 IFileDistristributor 中的 getConfigID
返回：
相关配置项目的ID

setTargetRoot

public void setTargetRoot(PublishDistribution _distribution)
                   throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Sets the target root.

指定者：
接口 IFileDistristributor 中的 setTargetRoot
参数：
_distribution - a publish distribution.
抛出：
java.lang.Exception - if the target root is not set.

distributeFile

public void distributeFile(java.lang.String _sLocal,
                           java.lang.String _sPath,
                           boolean _bCheckDstFileExits)
                    throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Distributes a file.

指定者：
接口 IFileDistristributor 中的 distributeFile
参数：
_sLocal - local file path name to distribute.
_sPath - the path to save file.
_bCheckDstFileExits - 是否检查目标文件存在
抛出：
java.lang.Exception - if failed to distribute the file.

renameFile

public boolean renameFile(java.lang.String _sSourceFile,
                          java.lang.String _sTargetFile,
                          java.lang.String _sFullDataPath)
                   throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?是不是叫作moveFile更合适一些?

指定者：
接口 IFileDistristributor 中的 renameFile
返回：
抛出：
java.lang.Exception

withdrawFile

public boolean withdrawFile(java.lang.String _sFile,
                            java.lang.String _sPath)
                     throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Withdraws a specified file in the path.

指定者：
接口 IFileDistristributor 中的 withdrawFile
参数：
_sFile - the file to withdraw.
_sPath - the file path.
返回：
true if and only if the file is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the file.

withdrawPath

public boolean withdrawPath(java.lang.String _sPath)
                     throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Withdraws a specified file path.

指定者：
接口 IFileDistristributor 中的 withdrawPath
参数：
_sPath - the path to withdraw.
返回：
true if and only if the path is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the path.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDistributorImpFtpByTRS

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributorImpFtpByTRS

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS
所有已实现的接口：
IFileDistristributor
public class FileDistributorImpFtpByTRS
extends java.lang.Object
implements IFileDistristributor

IFileDistristributor的一个实现，使用FTP或者类似FTP的协议进行远程分发。

作者：
Martin (付成睿)

构造方法摘要
FileDistributorImpFtpByTRS()
缺省构造方法
方法摘要
void | distributeFile(java.lang.String sLocal, java.lang.String sPath, boolean _bCheckDstFileExits) Distributes a file.
int | getConfigID() 返回相关配置项目的ID
boolean | renameFile(java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath) rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?
void | setTargetRoot(PublishDistribution _distribution) Sets the target root.
boolean | withdrawFile(java.lang.String sFile, java.lang.String sPath) Withdraws a specified file in the path.
boolean | withdrawPath(java.lang.String sPath) Withdraws a specified file path.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileDistributorImpFtpByTRS

public FileDistributorImpFtpByTRS()
缺省构造方法

方法详细信息

getConfigID

public int getConfigID()
从接口 IFileDistristributor 复制的描述
返回相关配置项目的ID

指定者：
接口 IFileDistristributor 中的 getConfigID
返回：
相关配置项目的ID

setTargetRoot

public void setTargetRoot(PublishDistribution _distribution)
                   throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Sets the target root.

指定者：
接口 IFileDistristributor 中的 setTargetRoot
参数：
_distribution - a publish distribution.
抛出：
java.lang.Exception - if the target root is not set.

distributeFile

public void distributeFile(java.lang.String sLocal,
                           java.lang.String sPath,
                           boolean _bCheckDstFileExits)
                    throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Distributes a file.

指定者：
接口 IFileDistristributor 中的 distributeFile
参数：
sLocal - local file path name to distribute.
sPath - the path to save file.
_bCheckDstFileExits - 是否检查目标文件存在
抛出：
java.lang.Exception - if failed to distribute the file.

renameFile

public boolean renameFile(java.lang.String _sSourceFile,
                          java.lang.String _sTargetFile,
                          java.lang.String _sFullDataPath)
                   throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?是不是叫作moveFile更合适一些?

指定者：
接口 IFileDistristributor 中的 renameFile
返回：
抛出：
java.lang.Exception

withdrawFile

public boolean withdrawFile(java.lang.String sFile,
                            java.lang.String sPath)
                     throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Withdraws a specified file in the path.

指定者：
接口 IFileDistristributor 中的 withdrawFile
参数：
sFile - the file to withdraw.
sPath - the file path.
返回：
true if and only if the file is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the file.

withdrawPath

public boolean withdrawPath(java.lang.String sPath)
                     throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Withdraws a specified file path.

指定者：
接口 IFileDistristributor 中的 withdrawPath
参数：
sPath - the path to withdraw.
返回：
true if and only if the path is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the path.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDistributorImpUnion

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributorImpUnion

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion
所有已实现的接口：
DistributionChangeListener, IFileDistristributor
public class FileDistributorImpUnion
extends java.lang.Object
implements IFileDistristributor, DistributionChangeListener

分发点的聚合,以简化分发的客户端代码,并在分发点的配置发生变化时,实现实时地响应

作者：
Martin (付成睿)

方法摘要
void | distributeFile(java.lang.String _sLocal, java.lang.String _sPath, boolean _bCheckDstFileExits) Distributes a file.
int | getConfigID() 返回相关配置项目的ID
void | onChange(int iDistributionID) 指定ID的分发配置已经发生了实质性的改变，正在执行的分发任务，必须立即结束
void | onDelete(int iDistributionID) 指定ID的分发配置已经删除（也可能是禁用）
boolean | renameFile(java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath) rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?
void | setTargetRoot(PublishDistribution _distribution) Sets the target root.
int | size() 返回聚合中的分发点的个数
boolean | withdrawFile(java.lang.String _sFile, java.lang.String _sPath) Withdraws a specified file in the path.
boolean | withdrawPath(java.lang.String _sPath) Withdraws a specified file path.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

size

public int size()
返回聚合中的分发点的个数

返回：
聚合中的分发点的个数

getConfigID

public int getConfigID()
从接口 IFileDistristributor 复制的描述
返回相关配置项目的ID

指定者：
接口 IFileDistristributor 中的 getConfigID
返回：
相关配置项目的ID

setTargetRoot

public void setTargetRoot(PublishDistribution _distribution)
                   throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Sets the target root.

指定者：
接口 IFileDistristributor 中的 setTargetRoot
参数：
_distribution - a publish distribution.
抛出：
java.lang.Exception - if the target root is not set.

distributeFile

public void distributeFile(java.lang.String _sLocal,
                           java.lang.String _sPath,
                           boolean _bCheckDstFileExits)
                    throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Distributes a file.

指定者：
接口 IFileDistristributor 中的 distributeFile
参数：
_sLocal - local file path name to distribute.
_sPath - the path to save file.
_bCheckDstFileExits - 是否检查目标文件存在
抛出：
java.lang.Exception - if failed to distribute the file.

withdrawFile

public boolean withdrawFile(java.lang.String _sFile,
                            java.lang.String _sPath)
                     throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Withdraws a specified file in the path.

指定者：
接口 IFileDistristributor 中的 withdrawFile
参数：
_sFile - the file to withdraw.
_sPath - the file path.
返回：
true if and only if the file is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the file.

withdrawPath

public boolean withdrawPath(java.lang.String _sPath)
                     throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
Withdraws a specified file path.

指定者：
接口 IFileDistristributor 中的 withdrawPath
参数：
_sPath - the path to withdraw.
返回：
true if and only if the path is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the path.

onChange

public void onChange(int iDistributionID)
从接口 DistributionChangeListener 复制的描述
指定ID的分发配置已经发生了实质性的改变，正在执行的分发任务，必须立即结束

指定者：
接口 DistributionChangeListener 中的 onChange
参数：
iDistributionID - 指定分发配置的ID

onDelete

public void onDelete(int iDistributionID)
从接口 DistributionChangeListener 复制的描述
指定ID的分发配置已经删除（也可能是禁用）

指定者：
接口 DistributionChangeListener 中的 onDelete
参数：
iDistributionID - 指定分发配置的ID

renameFile

public boolean renameFile(java.lang.String _sSourceFile,
                          java.lang.String _sTargetFile,
                          java.lang.String _sFullDataPath)
                   throws java.lang.Exception
从接口 IFileDistristributor 复制的描述
rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?是不是叫作moveFile更合适一些?

指定者：
接口 IFileDistristributor 中的 renameFile
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDistributorLocalImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 FileDistributorLocalImpl

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl
所有已实现的接口：
IFileDistristributor
已过时。 使用 FileDistributorImpFileLocal 代替,其实只是启用了新的名称,并没有实质性变化 Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor implementation on local disk.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

public class FileDistributorLocalImpl
extends java.lang.Object
implements IFileDistristributor

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FileDistributorLocalImpl()
已过时。 constructor: default
方法摘要
void | distributeFile(java.lang.String _sLocalFilePathName, java.lang.String _sPathToSave, boolean _bCheckDstFileExits) 已过时。 Distributes a file.
int | getConfigID() 已过时。 返回相关配置项目的ID
boolean | renameFile(java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath) 已过时。 rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?
void | setTargetRoot(PublishDistribution _distribution) 已过时。 Sets the target root.
boolean | withdrawFile(java.lang.String _sFileName, java.lang.String _sPath) 已过时。 Withdraws a specified file in the path.
boolean | withdrawPath(java.lang.String _sPath) 已过时。 Withdraws a specified file path.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileDistributorLocalImpl

public FileDistributorLocalImpl()
已过时。
constructor: default

方法详细信息

getConfigID

public int getConfigID()
已过时。
从接口 IFileDistristributor 复制的描述
返回相关配置项目的ID

指定者：
接口 IFileDistristributor 中的 getConfigID
返回：
相关配置项目的ID

setTargetRoot

public void setTargetRoot(PublishDistribution _distribution)
                   throws java.lang.Exception
已过时。
从接口 IFileDistristributor 复制的描述
Sets the target root.

指定者：
接口 IFileDistristributor 中的 setTargetRoot
参数：
_distribution - a publish distribution.
抛出：
java.lang.Exception - if the target root is not set.
另请参见：
IFileDistristributor#setTargetRoot(PublishDistributionConfig)

distributeFile

public void distributeFile(java.lang.String _sLocalFilePathName,
                           java.lang.String _sPathToSave,
                           boolean _bCheckDstFileExits)
                    throws java.lang.Exception
已过时。
从接口 IFileDistristributor 复制的描述
Distributes a file.

指定者：
接口 IFileDistristributor 中的 distributeFile
参数：
_sLocalFilePathName - local file path name to distribute.
_sPathToSave - the path to save file.
_bCheckDstFileExits - 是否检查目标文件存在
抛出：
java.lang.Exception - if failed to distribute the file.
另请参见：
IFileDistristributor#distributeFile(String, String)

withdrawFile

public boolean withdrawFile(java.lang.String _sFileName,
                            java.lang.String _sPath)
已过时。
从接口 IFileDistristributor 复制的描述
Withdraws a specified file in the path.

指定者：
接口 IFileDistristributor 中的 withdrawFile
参数：
_sFileName - the file to withdraw.
_sPath - the file path.
返回：
true if and only if the file is successfully withdrawed; false otherwise
另请参见：
IFileDistristributor.withdrawFile(String, String)

withdrawPath

public boolean withdrawPath(java.lang.String _sPath)
已过时。
从接口 IFileDistristributor 复制的描述
Withdraws a specified file path.

指定者：
接口 IFileDistristributor 中的 withdrawPath
参数：
_sPath - the path to withdraw.
返回：
true if and only if the path is successfully withdrawed; false otherwise
另请参见：
IFileDistristributor.withdrawPath(String)

renameFile

public boolean renameFile(java.lang.String _sSourceFile,
                          java.lang.String _sTargetFile,
                          java.lang.String _sFullDataPath)
                   throws java.lang.Exception
已过时。
从接口 IFileDistristributor 复制的描述
rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?是不是叫作moveFile更合适一些?

指定者：
接口 IFileDistristributor 中的 renameFile
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFileDistristributor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
接口 IFileDistristributor

所有已知实现类：
FileDistributorFtpImpl, FileDistributorImpFileLocal, FileDistributorImpFtpByTRS, FileDistributorImpUnion, FileDistributorLocalImpl
public interface IFileDistristributor

Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor interface.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | distributeFile(java.lang.String _sLocal, java.lang.String _sPath, boolean _bCheckDstFileExits) Distributes a file.
int | getConfigID() 返回相关配置项目的ID
boolean | renameFile(java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath) rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?
void | setTargetRoot(PublishDistribution _distribution) Sets the target root.
boolean | withdrawFile(java.lang.String _sFile, java.lang.String _sPath) Withdraws a specified file in the path.
boolean | withdrawPath(java.lang.String _sPath) Withdraws a specified file path.

方法详细信息

getConfigID

int getConfigID()
返回相关配置项目的ID

返回：
相关配置项目的ID

setTargetRoot

void setTargetRoot(PublishDistribution _distribution)
                   throws java.lang.Exception
Sets the target root.

参数：
_distribution - a publish distribution.
抛出：
java.lang.Exception - if the target root is not set.

distributeFile

void distributeFile(java.lang.String _sLocal,
                    java.lang.String _sPath,
                    boolean _bCheckDstFileExits)
                    throws java.lang.Exception
Distributes a file.

参数：
_sLocal - local file path name to distribute.
_sPath - the path to save file.
_bCheckDstFileExits - 是否检查目标文件存在
抛出：
java.lang.Exception - if failed to distribute the file.

withdrawFile

boolean withdrawFile(java.lang.String _sFile,
                     java.lang.String _sPath)
                     throws java.lang.Exception
Withdraws a specified file in the path.

参数：
_sFile - the file to withdraw.
_sPath - the file path.
返回：
true if and only if the file is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the file.

withdrawPath

boolean withdrawPath(java.lang.String _sPath)
                     throws java.lang.Exception
Withdraws a specified file path.

参数：
_sPath - the path to withdraw.
返回：
true if and only if the path is successfully withdrawed; false otherwise
抛出：
java.lang.Exception - if failed to withdraw the path.

renameFile

boolean renameFile(java.lang.String _sSourceFile,
                   java.lang.String _sTargetFile,
                   java.lang.String _sFullDataPath)
                   throws java.lang.Exception
rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?是不是叫作moveFile更合适一些?

参数：
_sSourceFile -
_sTargetFile -
_sFullDataPath -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.domain.distribute
接口
DistributionChangeListener
IFileDistristributor
类
FileDistributeQueue
FileDistributeShip
FileDistributorFtpCacheMgr
FileDistributorFtpImpl
FileDistributorImpFileLocal
FileDistributorImpFtpByTRS
FileDistributorImpUnion
FileDistributorLocalImpl
PublishDistributionCacheMgr
PublishDistributionLCListener
PublishDistributionList
PublishDistributionMgr
UftpConnectionCacheManager


com.trs.components.common.publish.domain.distribute

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.domain.distribute

接口摘要
DistributionChangeListener | 在修改分发设置时（尤其是禁用），为了使已经在执行的分发任务获得即时的响应，而增加的接口
IFileDistristributor | Title: TRS 内容协作平台（TRS WCM） Description: file distributor interface.

类摘要
FileDistributeQueue | TODO javadoc for com.trs.components.common.publish.domain.distribute.FileDistributeQueue
FileDistributeShip | Title: TRS 内容协作平台（TRS WCM） Description: file distribute ship Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FileDistributorFtpCacheMgr | 已过时。 使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM） Description: ftp cache manager for file distribution.
FileDistributorFtpImpl | 已过时。 使用 FileDistributorImpFtpByTRS 代替 Title: TRS 内容协作平台（TRS WCM） Description: file distributor implementation on ftp Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FileDistributorImpFileLocal | IFileDistristributor的一个实现，使用本地文件系统进行分发。
FileDistributorImpFtpByTRS | IFileDistristributor的一个实现，使用FTP或者类似FTP的协议进行远程分发。
FileDistributorImpUnion | 分发点的聚合,以简化分发的客户端代码,并在分发点的配置发生变化时,实现实时地响应
FileDistributorLocalImpl | 已过时。 使用 FileDistributorImpFileLocal 代替,其实只是启用了新的名称,并没有实质性变化 Title: TRS 内容协作平台（TRS WCM） Description: file distributor implementation on local disk.
PublishDistributionCacheMgr | FolderType,FolderId 到 PublishDistributionList 的缓存，加速给定目录分发点的查找
PublishDistributionLCListener | Title: TRS 内容协作平台（TRS WCM） Description: 分发的新增/修改监听,需要的话,做一次同步模板附件操作.
PublishDistributionList | 用于描述给定的Folder下的所有的分发点列表
PublishDistributionMgr | Title: TRS 内容协作平台（TRS WCM） Description: publish distribution manager.
UftpConnectionCacheManager | 集中管理FTP协议和FTP类似协议连接的缓冲池


com.trs.components.common.publish.domain.distribute 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.distribute 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.distribute.FileDistributeQueue
    • com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item
    • com.trs.components.common.publish.domain.distribute.FileDistributeShip (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl (implements com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal (implements com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS (implements com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion (implements com.trs.components.common.publish.domain.distribute.DistributionChangeListener, com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl (implements com.trs.components.common.publish.domain.distribute.IFileDistristributor)
    • com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.distribute.PublishDistributionList
    • com.trs.components.common.publish.domain.distribute.PublishDistributionMgr
    • com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager (implements org.aton.container.IClearable)

接口分层结构

  • com.trs.components.common.publish.domain.distribute.DistributionChangeListener
  • com.trs.components.common.publish.domain.distribute.IFileDistristributor


软件包 com.trs.components.common.publish.domain.distribute 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.distribute
的使用

使用 com.trs.components.common.publish.domain.distribute 的软件包
com.trs.components.common.publish.config
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.publisher

com.trs.components.common.publish.config 使用的 com.trs.components.common.publish.domain.distribute 中的类
IFileDistristributor
Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor interface.

com.trs.components.common.publish.domain.distribute 使用的 com.trs.components.common.publish.domain.distribute 中的类
DistributionChangeListener
在修改分发设置时（尤其是禁用），为了使已经在执行的分发任务获得即时的响应，而增加的接口
FileDistributeQueue.Item
描述一个待分发的文件,及分发类型
FileDistributorImpUnion
分发点的聚合,以简化分发的客户端代码,并在分发点的配置发生变化时,实现实时地响应
IFileDistristributor
Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor interface.
PublishDistributionList
用于描述给定的Folder下的所有的分发点列表

com.trs.components.common.publish.domain.publisher 使用的 com.trs.components.common.publish.domain.distribute 中的类
FileDistributeShip
Title: TRS 内容协作平台（TRS WCM）
Description:
file distribute ship
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishDistributionCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 PublishDistributionCacheMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class PublishDistributionCacheMgr
extends java.lang.Object
implements ICacheMgr

FolderType,FolderId 到 PublishDistributionList 的缓存，加速给定目录分发点的查找

作者：
Martin (付成睿)

构造方法摘要
PublishDistributionCacheMgr()
缺省构造方法
方法摘要
void | addChangeListener(DistributionChangeListener listener) 增加监听配置信息改变的监听器
void | clear() 清除系统所有的Cache
FileDistributorImpUnion | getDistributorUnion(int iFolderType, int iFolderID) 返回指定目录上的分发点的聚合
FileDistributorImpUnion | getDistributorUnion(IPublishFolder _folder) 返回指定目录上的分发点的聚合
PublishDistributionList | getPublishDistributionList(int iFolderType, int iFolderID) 返回指定目录上的分发点的列表
PublishDistributionList | getPublishDistributionList(java.lang.String sKey) 返回和指定的缓存KEY绑定的分发点的列表
boolean | init() 初始化当前的Cache
static java.lang.String | makeCaheKey(int type, int id) 使用FolderType和FolderID构造缓存中的KEY
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
void | removeChangeListener(DistributionChangeListener listener) 删除监听配置信息改变的监听器
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishDistributionCacheMgr

public PublishDistributionCacheMgr()
缺省构造方法

方法详细信息

makeCaheKey

public static final java.lang.String makeCaheKey(int type,
                                                 int id)
使用FolderType和FolderID构造缓存中的KEY

getPublishDistributionList

public PublishDistributionList getPublishDistributionList(int iFolderType,
                                                          int iFolderID)
                                                   throws WCMException
返回指定目录上的分发点的列表

参数：
iFolderType - 指定目录的类型
iFolderID - 指定目录的ID
返回：
指定目录上的分发点的列表
抛出：
WCMException - 如果发生异常

getDistributorUnion

public FileDistributorImpUnion getDistributorUnion(IPublishFolder _folder)
                                            throws WCMException
返回指定目录上的分发点的聚合

参数：
_folder - 指定的目录对象
返回：
指定目录上的分发点的聚合
抛出：
WCMException - 如果发生异常

getDistributorUnion

public FileDistributorImpUnion getDistributorUnion(int iFolderType,
                                                   int iFolderID)
                                            throws WCMException
返回指定目录上的分发点的聚合

参数：
iFolderType - 指定目录的类型
iFolderID - 指定目录的ID
返回：
指定目录上的分发点的聚合
抛出：
WCMException - 如果发生异常

getPublishDistributionList

public PublishDistributionList getPublishDistributionList(java.lang.String sKey)
                                                   throws WCMException
返回和指定的缓存KEY绑定的分发点的列表

参数：
sKey - 指定的缓存KEY
返回：
和指定的缓存KEY绑定的分发点的列表
抛出：
WCMException - 如果发生异常

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

addChangeListener

public void addChangeListener(DistributionChangeListener listener)
增加监听配置信息改变的监听器

removeChangeListener

public void removeChangeListener(DistributionChangeListener listener)
删除监听配置信息改变的监听器

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishDistributionLCListener

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 PublishDistributionLCListener

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnModify
public class PublishDistributionLCListener
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
分发的新增/修改监听,需要的话,做一次同步模板附件操作.
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
PublishDistributionLCListener()
方法摘要
void | notifyOnAddObj(BaseObj objAdded) 新增一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj objModified, int eventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishDistributionLCListener

public PublishDistributionLCListener()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj objAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
objAdded - 新增的对象
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishDistributionList

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 PublishDistributionList

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.PublishDistributionList

public class PublishDistributionList
extends java.lang.Object

用于描述给定的Folder下的所有的分发点列表

作者：
Martin (付成睿)

构造方法摘要
PublishDistributionList()
缺省构造方法
方法摘要
void | delDistribution(PublishDistribution _distribution) 从列表中删除指定的分发点设置
FileDistributorImpUnion | getDistributorUnion() 返回有效分发点的聚合
void | putDistribution(PublishDistribution _distribution) 向列表中增加或者替换列表中的分发点设置
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishDistributionList

public PublishDistributionList()
缺省构造方法

方法详细信息

getDistributorUnion

public FileDistributorImpUnion getDistributorUnion()
                                            throws WCMException
返回有效分发点的聚合

返回：
有效分发点的聚合
抛出：
WCMException

putDistribution

public void putDistribution(PublishDistribution _distribution)
                     throws WCMException
向列表中增加或者替换列表中的分发点设置

参数：
_distribution - 待增加或者替换的分发点设置
抛出：
WCMException - 如果发生错误

delDistribution

public void delDistribution(PublishDistribution _distribution)
                     throws WCMException
从列表中删除指定的分发点设置

参数：
_distribution - 待删除的分发点设置
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishDistributionMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 PublishDistributionMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.PublishDistributionMgr

public class PublishDistributionMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
publish distribution manager.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int MAXTARGETS_EACHFOLDER
每个目录做多允许的分发点
构造方法摘要
PublishDistributionMgr()
constructor: default
方法摘要
void | delete(PublishDistribution _distribution) Deletes a publish distribution.
PublishDistributions | getDistributionsOf(IPublishFolder _folder, boolean _bExcludingDisabled, WCMFilter _filter) get the publish distributions of the specified folder.
static IFileDistristributor | makeDistristributor(PublishDistribution _distribution) 根据指定的分发点配置信息构造 IFileDistristributor 对象实例
void | save(PublishDistribution _distribution) Saves the distribution setting.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAXTARGETS_EACHFOLDER

public static int MAXTARGETS_EACHFOLDER
每个目录做多允许的分发点

构造方法详细信息

PublishDistributionMgr

public PublishDistributionMgr()
constructor: default

方法详细信息

makeDistristributor

public static final IFileDistristributor makeDistristributor(PublishDistribution _distribution)
                                                      throws WCMException
根据指定的分发点配置信息构造 IFileDistristributor 对象实例

参数：
_distribution - 指定的分发点配置信息
返回：
IFileDistristributor 对象实例
抛出：
WCMException - 如果发生错误

save

public void save(PublishDistribution _distribution)
          throws WCMException
Saves the distribution setting.

参数：
_distribution - a publish distribution.
抛出：
WCMException - if the distribution is invalid or failed to save.

delete

public void delete(PublishDistribution _distribution)
            throws WCMException
Deletes a publish distribution.

参数：
_distribution - a publish distribution
抛出：
WCMException - if failed to delete the publish distribution.

getDistributionsOf

public PublishDistributions getDistributionsOf(IPublishFolder _folder,
                                               boolean _bExcludingDisabled,
                                               WCMFilter _filter)
                                        throws WCMException
get the publish distributions of the specified folder.

参数：
_folder - a folder
_bExcludingDisabled - if to fetch the enabled distributions only.
_filter - a filter
返回：
Returns the publish distributions list.
抛出：
WCMException - if failed to fetch the publish distribution settings.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UftpConnectionCacheManager

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.distribute
类 UftpConnectionCacheManager

java.lang.Object
    继承者  com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager
所有已实现的接口：
org.aton.container.IClearable
public class UftpConnectionCacheManager
extends java.lang.Object
implements org.aton.container.IClearable

集中管理FTP协议和FTP类似协议连接的缓冲池

作者：
Martin (付成睿)

构造方法摘要
UftpConnectionCacheManager()
缺省构造方法
方法摘要
void | clear()
void | deleteDistribution(PublishDistribution _distribution) 删除和指定的PublishDistribution相关的FTP连接缓存管理器
FtpConnectionCache | getConnectionCache(PublishDistribution dist) 返回和指定的PublishDistribution相关的FTP连接缓存管理器
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UftpConnectionCacheManager

public UftpConnectionCacheManager()
缺省构造方法

方法详细信息

getConnectionCache

public FtpConnectionCache getConnectionCache(PublishDistribution dist)
                                      throws WCMException
返回和指定的PublishDistribution相关的FTP连接缓存管理器

参数：
dist - 指定的PublishDistribution对象
返回：
FTP连接缓存管理器
抛出：
WCMException - 如果发生错误

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

deleteDistribution

public void deleteDistribution(PublishDistribution _distribution)
                        throws WCMException
删除和指定的PublishDistribution相关的FTP连接缓存管理器

参数：
_distribution - 指定的PublishDistribution对象
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.common.publish.domain.distribute.DistributionChangeListener 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.distribute.DistributionChangeListener
的使用

使用 DistributionChangeListener 的软件包
com.trs.components.common.publish.domain.distribute

com.trs.components.common.publish.domain.distribute 中 DistributionChangeListener 的使用

实现 DistributionChangeListener 的 com.trs.components.common.publish.domain.distribute 中的类
 class FileDistributorImpUnion
分发点的聚合,以简化分发的客户端代码,并在分发点的配置发生变化时,实现实时地响应

参数类型为 DistributionChangeListener 的 com.trs.components.common.publish.domain.distribute 中的方法
void | PublishDistributionCacheMgr.addChangeListener(DistributionChangeListener listener) 增加监听配置信息改变的监听器
void | PublishDistributionCacheMgr.removeChangeListener(DistributionChangeListener listener) 删除监听配置信息改变的监听器

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue
的使用

没有 com.trs.components.common.publish.domain.distribute.FileDistributeQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item
的使用

使用 FileDistributeQueue.Item 的软件包
com.trs.components.common.publish.domain.distribute

com.trs.components.common.publish.domain.distribute 中 FileDistributeQueue.Item 的使用

返回 FileDistributeQueue.Item 的 com.trs.components.common.publish.domain.distribute 中的方法
 FileDistributeQueue.Item FileDistributeQueue.getItem()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributeShip
的使用

使用 FileDistributeShip 的软件包
com.trs.components.common.publish.domain.publisher

com.trs.components.common.publish.domain.publisher 中 FileDistributeShip 的使用

返回 FileDistributeShip 的 com.trs.components.common.publish.domain.publisher 中的方法
FileDistributeShip | PublishTaskContext.getFileDistributeShip() Returns the file distribute ship.
FileDistributeShip | PublishPageContext.getFileDistributeShip()
FileDistributeShip | PublishTagContext.getFileDistributeShip()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr
的使用

没有 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl
的使用

没有 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal
的使用

没有 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS
的使用

没有 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion
的使用

使用 FileDistributorImpUnion 的软件包
com.trs.components.common.publish.domain.distribute

com.trs.components.common.publish.domain.distribute 中 FileDistributorImpUnion 的使用

返回 FileDistributorImpUnion 的 com.trs.components.common.publish.domain.distribute 中的方法
FileDistributorImpUnion | PublishDistributionList.getDistributorUnion() 返回有效分发点的聚合
FileDistributorImpUnion | PublishDistributionCacheMgr.getDistributorUnion(int iFolderType, int iFolderID) 返回指定目录上的分发点的聚合
FileDistributorImpUnion | PublishDistributionCacheMgr.getDistributorUnion(IPublishFolder _folder) 返回指定目录上的分发点的聚合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl
的使用

没有 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.distribute.IFileDistristributor 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.distribute.IFileDistristributor
的使用

使用 IFileDistristributor 的软件包
com.trs.components.common.publish.config
com.trs.components.common.publish.domain.distribute

com.trs.components.common.publish.config 中 IFileDistristributor 的使用

返回 IFileDistristributor 的 com.trs.components.common.publish.config 中的方法
 IFileDistristributor PublishDistributionTargetType.createDistributor()
create a distributor instance

com.trs.components.common.publish.domain.distribute 中 IFileDistristributor 的使用

实现 IFileDistristributor 的 com.trs.components.common.publish.domain.distribute 中的类
class | FileDistributorFtpImpl 已过时。 使用 FileDistributorImpFtpByTRS 代替 Title: TRS 内容协作平台（TRS WCM） Description: file distributor implementation on ftp Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FileDistributorImpFileLocal IFileDistristributor的一个实现，使用本地文件系统进行分发。
class | FileDistributorImpFtpByTRS IFileDistristributor的一个实现，使用FTP或者类似FTP的协议进行远程分发。
class | FileDistributorImpUnion 分发点的聚合,以简化分发的客户端代码,并在分发点的配置发生变化时,实现实时地响应
class | FileDistributorLocalImpl 已过时。 使用 FileDistributorImpFileLocal 代替,其实只是启用了新的名称,并没有实质性变化 Title: TRS 内容协作平台（TRS WCM） Description: file distributor implementation on local disk. Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IFileDistristributor 的 com.trs.components.common.publish.domain.distribute 中的方法
static IFileDistristributor PublishDistributionMgr.makeDistristributor(PublishDistribution _distribution)
根据指定的分发点配置信息构造 IFileDistristributor 对象实例

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr
的使用

没有 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener
的使用

没有 com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.PublishDistributionList 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.PublishDistributionList
的使用

使用 PublishDistributionList 的软件包
com.trs.components.common.publish.domain.distribute

com.trs.components.common.publish.domain.distribute 中 PublishDistributionList 的使用

返回 PublishDistributionList 的 com.trs.components.common.publish.domain.distribute 中的方法
PublishDistributionList | PublishDistributionCacheMgr.getPublishDistributionList(int iFolderType, int iFolderID) 返回指定目录上的分发点的列表
PublishDistributionList | PublishDistributionCacheMgr.getPublishDistributionList(java.lang.String sKey) 返回和指定的缓存KEY绑定的分发点的列表

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr
的使用

没有 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager
的使用

没有 com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.publish.domain.element
类
PublishContentLCListener
PublishFolderLCListener


com.trs.components.common.publish.domain.element

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.domain.element

类摘要
PublishContentLCListener | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishFolderLCListener | Title: TRS 内容协作平台（TRS WCM） Description: 模板需要监控的其他相关对象的操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.publish.domain.element 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.element 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.element.PublishContentLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.common.publish.domain.element.PublishFolderLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)


软件包 com.trs.components.common.publish.domain.element 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.element
的使用

没有 com.trs.components.common.publish.domain.element 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishContentLCListener

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.element
类 PublishContentLCListener

java.lang.Object
    继承者  com.trs.components.common.publish.domain.element.PublishContentLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class PublishContentLCListener
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishContentLCListener()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishContentLCListener

public PublishContentLCListener()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


PublishFolderLCListener

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.element
类 PublishFolderLCListener

java.lang.Object
    继承者  com.trs.components.common.publish.domain.element.PublishFolderLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class PublishFolderLCListener
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
模板需要监控的其他相关对象的操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishFolderLCListener()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishFolderLCListener

public PublishFolderLCListener()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.domain.element.PublishContentLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.element.PublishContentLCListener
的使用

没有 com.trs.components.common.publish.domain.element.PublishContentLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.element.PublishFolderLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.element.PublishFolderLCListener
的使用

没有 com.trs.components.common.publish.domain.element.PublishFolderLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.publish.domain.publisher
类
PageDestroyer
PageGenerator
PageNavHelper
PublishPageContext
PublishPathCompass
PublishSyncGlobalTuner
PublishTagContext
PublishTaskContext


com.trs.components.common.publish.domain.publisher

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.domain.publisher

类摘要
PageDestroyer | Title: TRS 内容协作平台（TRS WCM） Description: published page destroyer.
PageGenerator | Title: TRS 内容协作平台（TRS WCM） Description: page generator for publish task.
PageNavHelper | Title: TRS 内容协作平台（TRS WCM） Description: 分页导航生成工具类,原来在PageGenerator类中。
PublishPageContext | Title: TRS 内容协作平台（TRS WCM） Description: context during page generating Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishPathCompass | Title: TRS 内容协作平台（TRS WCM） Description: Compass who can tell you all the path infomation of a folder.
PublishSyncGlobalTuner | Title: TRS 内容协作平台（TRS WCM） Description: synchronization tuner for publish threads.
PublishTagContext | Title: TRS 内容协作平台（TRS WCM） Description: tag parse context.
PublishTaskContext | Title: TRS 内容协作平台（TRS WCM） Description: context for publish task.


com.trs.components.common.publish.domain.publisher 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.publisher 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.publisher.PageDestroyer
    • com.trs.components.common.publish.domain.publisher.PageGenerator
    • com.trs.components.common.publish.domain.publisher.PageNavHelper
    • com.trs.components.common.publish.domain.publisher.PublishPageContext (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.publisher.PublishPathCompass (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.publisher.PublishSyncGlobalTuner
    • com.trs.components.common.publish.domain.publisher.PublishTagContext
    • com.trs.components.common.publish.domain.publisher.PublishTaskContext (implements org.aton.container.IClearable)


软件包 com.trs.components.common.publish.domain.publisher 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.publisher
的使用

使用 com.trs.components.common.publish.domain.publisher 的软件包
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain.distribute |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.helper |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.wcm.photo.publish |
com.trs.wcmonline |

com.trs.components.comment.publish.tagparser 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.components.common.publish.domain.distribute 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishPathCompass
Title: TRS 内容协作平台（TRS WCM）
Description:
Compass who can tell you all the path infomation of a folder.

com.trs.components.common.publish.domain.publisher 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishPageContext
Title: TRS 内容协作平台（TRS WCM）
Description:
context during page generating
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishPathCompass
Title: TRS 内容协作平台（TRS WCM）
Description:
Compass who can tell you all the path infomation of a folder.
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.
PublishTaskContext
Title: TRS 内容协作平台（TRS WCM）
Description:
context for publish task.

com.trs.components.common.publish.domain.tagparser 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.components.common.publish.domain.taskdispatch 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTaskContext
Title: TRS 内容协作平台（TRS WCM）
Description:
context for publish task.

com.trs.components.common.publish.widget.tagparser 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.components.infoview.helper 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishPageContext
Title: TRS 内容协作平台（TRS WCM）
Description:
context during page generating
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.publish.tagparser 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.components.metadata.publish 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.components.wcm.epress 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.components.wcm.publish.region 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.components.wcm.publish.tagparser 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.wcm.photo.publish 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

com.trs.wcmonline 使用的 com.trs.components.common.publish.domain.publisher 中的类
PublishTagContext
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageDestroyer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.publisher
类 PageDestroyer

java.lang.Object
    继承者  com.trs.components.common.publish.domain.publisher.PageDestroyer

public class PageDestroyer
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
published page destroyer.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PageDestroyer()
方法摘要
static void | withdraw(IPublishContent _content, PublishTaskContext _taskContext) Withdraws the detail pages of the specified content.
static void | withdraw(IPublishFolder _folder, PublishTaskContext _taskContext) Withdraws all the files in a specified folder.
static void | withDrawSelfOnly(IPublishFolder folder) 只撤除指定folder本身的内容,不包括子对象的内容.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageDestroyer

public PageDestroyer()
方法详细信息

withdraw

public static void withdraw(IPublishFolder _folder,
                            PublishTaskContext _taskContext)
                     throws java.lang.Exception
Withdraws all the files in a specified folder.

参数：
_folder - the contents folder
_taskContext - the publish task context which could be null.
抛出：
java.lang.Exception - if fails to delete the outline pages

withDrawSelfOnly

public static void withDrawSelfOnly(IPublishFolder folder)
                             throws java.lang.Exception
只撤除指定folder本身的内容,不包括子对象的内容.

参数：
folder - 指定的folder.
抛出：
java.lang.Exception

withdraw

public static void withdraw(IPublishContent _content,
                            PublishTaskContext _taskContext)
                     throws java.lang.Exception
Withdraws the detail pages of the specified content.

参数：
_content - the content
_taskContext - the publish task context which could be null.
抛出：
java.lang.Exception - if fails to delete the detail page
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


PageGenerator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.publisher
类 PageGenerator

java.lang.Object
    继承者  com.trs.components.common.publish.domain.publisher.PageGenerator

public class PageGenerator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
page generator for publish task.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static java.lang.String[] | generateContent(PublishPageContext _pageContext, Template _template)
static java.lang.String | generateDetail(PublishPageContext _pageContext) generate the content detail page file
static java.lang.String[] | generateOutlines(PublishPageContext _pageContext) generate the content folder outline page file
static java.lang.String | generatePage(PublishPageContext _pageContext, Template _template) Generates page with the specified template in the specified page context.
static java.lang.String | generatePage(PublishPageContext _pageContext, Template _template, boolean _bDiffContent)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

generateOutlines

public static java.lang.String[] generateOutlines(PublishPageContext _pageContext)
                                           throws WCMException
generate the content folder outline page file

参数：
_folder - the content folder
_bPreview - true: to preview; false: to publish
返回：
if it is to preview, returns the URL of the outline page; otherwise, returns the file local path name.
抛出：
java.lang.Exception - if encounter errors
WCMException

generateDetail

public static java.lang.String generateDetail(PublishPageContext _pageContext)
                                       throws java.lang.Exception
generate the content detail page file

参数：
_content - the content to publish
_bPreview - true: to preview; false: to publish
返回：
if it is to preview, returns the URL of the detail page (useful for the caller); otherwise, returns null or the file local path name (not useful for the caller as for now).
抛出：
java.lang.Exception - if encounter errors.

generatePage

public static java.lang.String generatePage(PublishPageContext _pageContext,
                                            Template _template)
                                     throws WCMException
Generates page with the specified template in the specified page context.

参数：
_pageContext - page publish context
_template - the specified template
返回：
if to preview, returns the URL of the generated page; otherwise, returns the file local path name.
抛出：
WCMException - if failed to generate the page.

generatePage

public static java.lang.String generatePage(PublishPageContext _pageContext,
                                            Template _template,
                                            boolean _bDiffContent)
                                     throws WCMException
抛出：
WCMException

generateContent

public static java.lang.String[] generateContent(PublishPageContext _pageContext,
                                                 Template _template)
                                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageNavHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.publisher
类 PageNavHelper

java.lang.Object
    继承者  com.trs.components.common.publish.domain.publisher.PageNavHelper

public class PageNavHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
分页导航生成工具类,原来在PageGenerator类中。独立出来,避免导航有变化时都需要修改该类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
PageNavHelper()
方法摘要
static java.lang.String makeNav(PublishPageContext context, java.lang.String fileName, java.lang.String fileExt, int pageCount, int currPage)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageNavHelper

public PageNavHelper()
方法详细信息

makeNav

public static java.lang.String makeNav(PublishPageContext context,
                                       java.lang.String fileName,
                                       java.lang.String fileExt,
                                       int pageCount,
                                       int currPage)
参数：
context - 发布页面上下文对象
fileName - 发布文件名
fileExt - 发布文件后缀
currPage - 当前页号
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishPageContext

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.publisher
类 PublishPageContext

java.lang.Object
    继承者  com.trs.components.common.publish.domain.publisher.PublishPageContext
所有已实现的接口：
org.aton.container.IClearable
public class PublishPageContext
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
context during page generating
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishPageContext(IPublishElement _pageElement, PublishTaskContext _taskContext)
constructor
PublishPageContext(IPublishElement _pageElement, PublishTaskContext _taskContext, IPublishProgressMonitor _monitor)
constructor
PublishPageContext(PublishPageContext pageContext)
constructor
方法摘要
void | addErrorLog(int iResult, java.lang.String sDesc, java.lang.String sError) 记录发布过程中产生的错误日志
void | addErrorLog(int iResult, java.lang.String sDesc, java.lang.Throwable t) 记录发布过程中产生的错误日志
void | addWarning(java.lang.String _sDesc) add warning
void | addWarning(java.lang.String _sObjName, int _nObjId, java.lang.String _sDesc) add warning
void | clear()
java.lang.String | getExtraAttribute(java.lang.String _sName) Returns the specified extra attribute.
FileDistributeShip | getFileDistributeShip()
java.lang.String | getFileName()
IPublishElement | getPageElement() Returns the element (a folder or a content) of this page to publish.
IPublishFolder | getPageFolder() Returns the folder where the current page lies.
java.lang.String | getPageHttpPath() Returns the http path of current page.
java.lang.String | getPageHttpURL() Returns the http URL of current page.
PublishPathCompass | getPathCompass()
IPublishProgressMonitor | getProgressMonitor()
IPublishFolder | getRoot()
PublishTaskContext | getTaskContext() Returns the current publish task context.
Template | getTemplate() 获取相关模板
java.lang.String | getVariableAttribute(java.lang.String _sName) 返回指定变量的赋值
java.lang.String | getWarnings() Returns the warnings as string; returns null if no warnings.
boolean | hasWarnings() Returns true if there is warnings.
void | incDetailPageCount() increase the detailPageCount.
void | incOutlinePageCount() increase the outlinePageCount.
boolean | isPreview()
void | log2Monitor(java.lang.String msg) 纪录信息到监控器
void | setExtraAttribute(java.lang.String _sName, java.lang.String _sValue)
void | setFileName(java.lang.String fileName)
void | setRoot(IPublishFolder root)
void | setTemplate(Template template) 设置相关模板
void | setVariableAttribute(java.lang.String _sName, java.lang.String _sValue) 给指定的变量赋值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishPageContext

public PublishPageContext(PublishPageContext pageContext)
constructor

参数：
pageContext - the Original PublishPageContext

PublishPageContext

public PublishPageContext(IPublishElement _pageElement,
                          PublishTaskContext _taskContext)
constructor

参数：
_pageElement - the folder where this page lies.
_taskContext - the publish task context.

PublishPageContext

public PublishPageContext(IPublishElement _pageElement,
                          PublishTaskContext _taskContext,
                          IPublishProgressMonitor _monitor)
constructor

参数：
_pageElement - the folder where this page lies.
_taskContext - the publish task context.
_monitor - the progress monitor
方法详细信息

getTaskContext

public PublishTaskContext getTaskContext()
Returns the current publish task context.

返回：
the current publish task context

getPageElement

public IPublishElement getPageElement()
Returns the element (a folder or a content) of this page to publish.

返回：
the element (a folder or a content) of this page to publish.

getPageFolder

public IPublishFolder getPageFolder()
Returns the folder where the current page lies.

返回：
the folder where the current page lies

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

isPreview

public boolean isPreview()
另请参见：
PublishTaskContext.isPreview()

getRoot

public IPublishFolder getRoot()
                       throws WCMException
抛出：
WCMException
另请参见：
PublishTaskContext.getRoot()

setRoot

public void setRoot(IPublishFolder root)

getPathCompass

public PublishPathCompass getPathCompass()
另请参见：
PublishTaskContext.getPathCompass()

getFileDistributeShip

public FileDistributeShip getFileDistributeShip()
另请参见：
PublishTaskContext.getFileDistributeShip()

incDetailPageCount

public void incDetailPageCount()
increase the detailPageCount.

incOutlinePageCount

public void incOutlinePageCount()
increase the outlinePageCount.

addWarning

public void addWarning(java.lang.String _sObjName,
                       int _nObjId,
                       java.lang.String _sDesc)
                throws WCMException
add warning

参数：
_sTitle - title of the warning
_sDesc - detailed description for the warning
抛出：
WCMException

addWarning

public void addWarning(java.lang.String _sDesc)
                throws WCMException
add warning

参数：
_sDesc - detailed description for the warning
抛出：
WCMException

getWarnings

public java.lang.String getWarnings()
Returns the warnings as string; returns null if no warnings.

返回：
the warnings as string; returns null if no warnings

hasWarnings

public boolean hasWarnings()
Returns true if there is warnings.

返回：
true if there is warnings

getPageHttpPath

public java.lang.String getPageHttpPath()
                                 throws WCMException
Returns the http path of current page.

返回：
the http path of current page
抛出：
WCMException - if failed to find the path.

getPageHttpURL

public java.lang.String getPageHttpURL()
                                throws WCMException
Returns the http URL of current page.

返回：
the http URL of current page
抛出：
WCMException - if failed to find the path.

getFileName

public java.lang.String getFileName()
返回：
Returns the fileName.

setFileName

public void setFileName(java.lang.String fileName)
参数：
fileName - The fileName to set.

log2Monitor

public void log2Monitor(java.lang.String msg)
纪录信息到监控器

getProgressMonitor

public IPublishProgressMonitor getProgressMonitor()
返回：
Returns the progressMonitor.

addErrorLog

public void addErrorLog(int iResult,
                        java.lang.String sDesc,
                        java.lang.String sError)
记录发布过程中产生的错误日志

addErrorLog

public void addErrorLog(int iResult,
                        java.lang.String sDesc,
                        java.lang.Throwable t)
记录发布过程中产生的错误日志

getExtraAttribute

public java.lang.String getExtraAttribute(java.lang.String _sName)
Returns the specified extra attribute.

参数：
_sName - style name
返回：
the specified attribute value.

setExtraAttribute

public void setExtraAttribute(java.lang.String _sName,
                              java.lang.String _sValue)

getTemplate

public Template getTemplate()
获取相关模板

返回：

setTemplate

public void setTemplate(Template template)
设置相关模板

参数：
template -

getVariableAttribute

public java.lang.String getVariableAttribute(java.lang.String _sName)
返回指定变量的赋值

参数：
_sName - 变量名称
返回：
变量的赋值

setVariableAttribute

public void setVariableAttribute(java.lang.String _sName,
                                 java.lang.String _sValue)
给指定的变量赋值

参数：
_sName - 变量名
_sValue - 变量值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishPathCompass

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.publisher
类 PublishPathCompass

java.lang.Object
    继承者  com.trs.components.common.publish.domain.publisher.PublishPathCompass
所有已实现的接口：
org.aton.container.IClearable
public class PublishPathCompass
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
Compass who can tell you all the path infomation of a folder.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishPathCompass()
constructor: default
方法摘要
static java.lang.String | calFullDataPath(IPublishContent _content, boolean _bLocalFileSystemFormat) Returns the full data path from the specified content to folder root.
static java.lang.String | calFullDataPath(IPublishElement _element, boolean _bLocalFileSystemFormat) Returns the full data path from the specified element to root.
static java.lang.String | calFullDataPath(IPublishFolder _folder, boolean _bLocalFileSystemFormat) Returns the full data path from the specified folder to root.
static java.lang.String | calSubDirectory(IPublishContent _content, boolean _bLocalFileSystemFormat) Calculates the sub directory of the specified content in its home.
void | clear()
java.lang.String | getAbsoluteHttpPath(IPublishContent _content) Returns the http path without file name of the specified content.
java.lang.String | getAbsoluteHttpPath(IPublishElement _element) Returns the http path of the specified element.
java.lang.String | getAbsoluteHttpPath(IPublishFolder _folder) Returns the http path of the specified folder.
java.lang.String | getFullDataPath(IPublishContent _content, boolean _bLocalFileSystemFormat) Returns the full data path of the specified content.
java.lang.String | getFullDataPath(IPublishElement _element, boolean _bLocalFileSystemFormat) Returns the full data path of the specified element.
java.lang.String | getFullDataPath(IPublishFolder _folder, boolean _bLocalFileSystemFormat) Returns the full data path of the specified folder.
java.lang.String | getHttpUrl(IPublishContent _content, int _nPageIndex) Returns the http path including file name of the specified content.
java.lang.String | getLocalPath(IPublishElement _element, boolean _bPreview) Returns the element local path.
java.lang.String | getPreviewHttpPath(IPublishElement _element) Returns the http path for the previewed pages of the specified element.
java.lang.String | getPreviewHttpUrl(IPublishContent _content, int _nPageIndex) 获取指定Content的预览地址
java.lang.String | getPreviewLocalPath(IPublishContent _content) Returns the local path for the previewed pages of the specified content.
java.lang.String | getPreviewLocalPath(IPublishElement _element) Returns the local path for the previewed pages of the specified element.
java.lang.String | getPreviewLocalPath(IPublishFolder _folder) Returns the local path for the previewed pages of the specified folder.
java.lang.String | getPublishHttpPath(IPublishElement _element)
java.lang.String | getPublishHttpUrl(IPublishContent _content, int _nPageIndex)
java.lang.String | getPublishLocalPath(IPublishContent _content) Returns the local path (without file name) for the published pages of the specified content in the folder.
java.lang.String | getPublishLocalPath(IPublishElement _element) Returns the local path for the published pages of the specified element.
java.lang.String | getPublishLocalPath(IPublishFolder _folder) Returns the local path for the published pages of the specified folder.
java.lang.String | getRootDomain(IPublishFolder _folder) Returns the root domain of the specified folder.
java.lang.String | getRootHttpPathFrom(IPublishElement _element) Returns the root http path from the specified publish element.
java.lang.String | getRootImageHttpPath(IPublishElement _element) Returns the http path of the images in root.
static java.lang.String | makeDetailPageFileName(IPublishContent _content) Returns the detail page file name of the specified content.
static java.lang.String | makeDetailPageFileName(IPublishContent _content, java.lang.String _sExt, int _nPageIndex) Returns the detail page file name of the specified content.
static java.lang.String | makePageFileName(java.lang.String _sFileName, java.lang.String _sExt, int _nPageIndex) Makes a page file name.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishPathCompass

public PublishPathCompass()
constructor: default

方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

calFullDataPath

public static java.lang.String calFullDataPath(IPublishElement _element,
                                               boolean _bLocalFileSystemFormat)
                                        throws WCMException
Returns the full data path from the specified element to root.

参数：
_folder - the specified publish element
_bLocalFileSystemFormat - true, to convert the path to local file system format.
返回：
the full data path from the specified element to root
抛出：
WCMException - if failed to find the element path.

calFullDataPath

public static java.lang.String calFullDataPath(IPublishFolder _folder,
                                               boolean _bLocalFileSystemFormat)
                                        throws WCMException
Returns the full data path from the specified folder to root.

参数：
_folder - the specified folder
_bLocalFileSystemFormat - true, to convert the path to local file system format.
返回：
the full data path from the specified folder to root
抛出：
WCMException - if failed to find the folder path.

calFullDataPath

public static java.lang.String calFullDataPath(IPublishContent _content,
                                               boolean _bLocalFileSystemFormat)
                                        throws WCMException
Returns the full data path from the specified content to folder root.

参数：
_content - the specified content
_bLocalFileSystemFormat - true, to convert the path to local file system format.
返回：
the full data path from the specified content to folder root
抛出：
WCMException - if failed to find the content path.

calSubDirectory

public static java.lang.String calSubDirectory(IPublishContent _content,
                                               boolean _bLocalFileSystemFormat)
                                        throws WCMException
Calculates the sub directory of the specified content in its home.
if config of DirDividedByDate in publish server is true, the sub directory will be made with the specified format in config.

参数：
_content - the specified content.
_bLocalFileSystemFormat - true, to convert the path to local file system format.
返回：
the sub directory of the specified content in its home.
抛出：
WCMException - if failed to calculate the directory.

makeDetailPageFileName

public static java.lang.String makeDetailPageFileName(IPublishContent _content,
                                                      java.lang.String _sExt,
                                                      int _nPageIndex)
Returns the detail page file name of the specified content.

参数：
_content - the specified content
_nPageIndex - index of the detail page if there are more than one detail pages.
返回：
the detail page file name of the specified content.

makeDetailPageFileName

public static java.lang.String makeDetailPageFileName(IPublishContent _content)
Returns the detail page file name of the specified content.

参数：
_content - the specified content
返回：
the detail page file name of the specified content.

makePageFileName

public static java.lang.String makePageFileName(java.lang.String _sFileName,
                                                java.lang.String _sExt,
                                                int _nPageIndex)
Makes a page file name.

参数：
_sFileName - the file name
_sExt - the file extent
_nPageIndex - the page index from 0
返回：
the page file full name.

getFullDataPath

public java.lang.String getFullDataPath(IPublishElement _element,
                                        boolean _bLocalFileSystemFormat)
                                 throws WCMException
Returns the full data path of the specified element.

参数：
_folder - the specified element
_bLocalFileSystemFormat - true, to convert the path to local file system format.
返回：
the full data path of the specified element
抛出：
WCMException - if failed to find the element path.

getFullDataPath

public java.lang.String getFullDataPath(IPublishFolder _folder,
                                        boolean _bLocalFileSystemFormat)
                                 throws WCMException
Returns the full data path of the specified folder.

参数：
_folder - the specified folder
_bLocalFileSystemFormat - true, to convert the path to local file system format.
返回：
the full data path of the specified folder
抛出：
WCMException - if failed to find the folder path.

getFullDataPath

public java.lang.String getFullDataPath(IPublishContent _content,
                                        boolean _bLocalFileSystemFormat)
                                 throws WCMException
Returns the full data path of the specified content.

参数：
_content - the specified content
_bLocalFileSystemFormat - true, to convert the path to local file system format.
返回：
the full data path of the specified content
抛出：
WCMException - if failed to find the content path.

getRootDomain

public java.lang.String getRootDomain(IPublishFolder _folder)
                               throws WCMException
Returns the root domain of the specified folder.

参数：
_folder - the specified folder
返回：
the root domain of the specified folder.
抛出：
WCMException - if failed to find the folder root domain.

getAbsoluteHttpPath

public java.lang.String getAbsoluteHttpPath(IPublishElement _element)
                                     throws WCMException
Returns the http path of the specified element.

参数：
_folder - the specified element.
返回：
the http path of the specified element.
抛出：
WCMException - if failed to calculate the element path.

getAbsoluteHttpPath

public java.lang.String getAbsoluteHttpPath(IPublishFolder _folder)
                                     throws WCMException
Returns the http path of the specified folder.

参数：
_folder - the specified folder.
返回：
the http path of the specified folder.
抛出：
WCMException - if failed to calculate the folder path.

getAbsoluteHttpPath

public java.lang.String getAbsoluteHttpPath(IPublishContent _content)
                                     throws WCMException
Returns the http path without file name of the specified content.

参数：
_content - the specified content
_nPageIndex - the page index
返回：
the http path including file name of the specified content.
抛出：
WCMException - if failed to calculate the content path.

getHttpUrl

public java.lang.String getHttpUrl(IPublishContent _content,
                                   int _nPageIndex)
                            throws WCMException
Returns the http path including file name of the specified content.

参数：
_content - the specified content
_nPageIndex - the page index
返回：
the http path including file name of the specified content.
抛出：
WCMException - if failed to calculate the content path.

getPreviewHttpUrl

public java.lang.String getPreviewHttpUrl(IPublishContent _content,
                                          int _nPageIndex)
                                   throws WCMException
获取指定Content的预览地址

参数：
_content - 指定的Content
_nPageIndex - 指定页面的索引
返回：
如果目录配置中LP设置了HTTP路径，那么返回的为包含HTTP的绝对地址 否则返回不包含HTTP的地址
抛出：
WCMException

getPublishHttpUrl

public java.lang.String getPublishHttpUrl(IPublishContent _content,
                                          int _nPageIndex)
                                   throws WCMException
抛出：
WCMException

getLocalPath

public java.lang.String getLocalPath(IPublishElement _element,
                                     boolean _bPreview)
                              throws WCMException
Returns the element local path.

参数：
_folder - the specified element
_bPreview - true, to get the preview path; other, to get the publish path.
返回：
true, the preview path; other, the publish path.
抛出：
WCMException - if failed to find the element path.

getPublishLocalPath

public java.lang.String getPublishLocalPath(IPublishElement _element)
                                     throws WCMException
Returns the local path for the published pages of the specified element.

参数：
_folder - the specified element
返回：
the local path for the published pages of the specified element
抛出：
WCMException - if failed to find the path.

getPublishLocalPath

public java.lang.String getPublishLocalPath(IPublishFolder _folder)
                                     throws WCMException
Returns the local path for the published pages of the specified folder.

参数：
_folder - the specified folder
返回：
the local path for the published pages of the specified folder
抛出：
WCMException - if failed to find the path.

getPublishLocalPath

public java.lang.String getPublishLocalPath(IPublishContent _content)
                                     throws WCMException
Returns the local path (without file name) for the published pages of the specified content in the folder.

参数：
_content - the specified content
返回：
the local path for the published pages of the specified content in the folder.
抛出：
WCMException - if failed to find the path.

getPreviewLocalPath

public java.lang.String getPreviewLocalPath(IPublishElement _element)
                                     throws WCMException
Returns the local path for the previewed pages of the specified element.

参数：
_folder - the specified element
返回：
the local path for the previewed pages of the specified element
抛出：
WCMException - if failed to find the path.

getPreviewLocalPath

public java.lang.String getPreviewLocalPath(IPublishFolder _folder)
                                     throws WCMException
Returns the local path for the previewed pages of the specified folder.

参数：
_folder - the specified folder
返回：
the local path for the previewed pages of the specified folder
抛出：
WCMException - if failed to find the path.

getPreviewLocalPath

public java.lang.String getPreviewLocalPath(IPublishContent _content)
                                     throws WCMException
Returns the local path for the previewed pages of the specified content.

参数：
_content - the specified content
返回：
the local path for the previewed pages of the specified content
抛出：
WCMException - if failed to find the path.

getPreviewHttpPath

public java.lang.String getPreviewHttpPath(IPublishElement _element)
                                    throws WCMException
Returns the http path for the previewed pages of the specified element.

参数：
_folder - the specified element
返回：
the http path for the previewed pages of the specified element
抛出：
WCMException - if failed to find the path.

getPublishHttpPath

public java.lang.String getPublishHttpPath(IPublishElement _element)
                                    throws WCMException
抛出：
WCMException

getRootImageHttpPath

public java.lang.String getRootImageHttpPath(IPublishElement _element)
                                      throws WCMException
Returns the http path of the images in root.
To keep the flexible farthest, returns the relative path from current page element to the root like ../../images/.

参数：
_element - current publish element in page.
抛出：
WCMException - if failed to calculate the path.

getRootHttpPathFrom

public java.lang.String getRootHttpPathFrom(IPublishElement _element)
                                     throws WCMException
Returns the root http path from the specified publish element.

参数：
_element - a publish element.
返回：
the root http path from the specified publish element.
抛出：
WCMException - if failed to calculte the relative path.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishSyncGlobalTuner

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.publisher
类 PublishSyncGlobalTuner

java.lang.Object
    继承者  com.trs.components.common.publish.domain.publisher.PublishSyncGlobalTuner

public class PublishSyncGlobalTuner
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
synchronization tuner for publish threads.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static java.io.File insureLocalPathExists(java.lang.String _sPath)
insure the specified path exists
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

insureLocalPathExists

public static java.io.File insureLocalPathExists(java.lang.String _sPath)
                                          throws WCMException
insure the specified path exists

参数：
_sPath - file path
返回：
object as the file path instance
抛出：
WCMException - if failed to create path
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTagContext

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.publisher
类 PublishTagContext

java.lang.Object
    继承者  com.trs.components.common.publish.domain.publisher.PublishTagContext

public class PublishTagContext
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String ATTRNAME_CURR_NESTTAGITEM
构造方法摘要
PublishTagContext(IPublishElement _upperHost, java.util.Map _extraAttributes, PublishPageContext _pageContext)
已过时。 constructor
PublishTagContext(IPublishElement _upperHost, java.util.Map _extraAttributes, PublishTagContext _parent)
已过时。 constructor
PublishTagContext(PublishPageContext _pageContext)
PublishTagContext(PublishTagContext _parent, TagItem _tagItem)
PublishTagContext(PublishTagContext _parent, TagItem _tagItem, IPublishElement _upperHost)
PublishTagContext(PublishTagContext _parent, TagItem _tagItem, ITagParser4List _tagParser4List)
方法摘要
void | addWarning(java.lang.String _sDesc)
void | addWarning(java.lang.String _sObjName, int _nObjId, java.lang.String _sDesc)
void | clearNestTemplateeContext() 清空上一次保存的模板状态
java.lang.String | getAttribute(java.lang.String _sName) get a attribute value
boolean | getAttribute(java.lang.String _sName, boolean _bDefault) get the boolean attribute value
int | getAttribute(java.lang.String _sName, int _nDefault) get the integer attribute value
java.util.HashMap | getAttributes()
java.lang.String | getAttributeTrim(java.lang.String _sName) get the timmed value of a attribute
boolean | getBooleanExtraAttribute(java.lang.String _sName, boolean _bDefault) Returns the boolean extra property.
java.lang.String | getExtraAttribute(java.lang.String _sName) Returns the specified extra attribute.
java.util.Map | getExtraAttributes() Returns the display styles.
FileDistributeShip | getFileDistributeShip()
PublishPageContext | getPageContext() Returns the page generate context
IPublishElement | getPageElement()
IPublishFolder | getPageFolder()
java.lang.String | getPageHttpPath()
PublishTagContext | getParent() Returns the parent tag parse context.
PublishPathCompass | getPathCompass()
java.lang.String | getPrefixOfArgument() 返回模板变量名称的前缀
IPublishFolder | getRoot()
int | getSequenceNumber()
TagItem | getTagItem()
ITagParser4List | getTagParser4List() 返回相关联的ITagParser4List对象
IPublishFolder | getUpperFolder() Returns the nearest upper folder in current context link.
IPublishElement | getUpperHost() Returns the upper host object.
boolean | isPreview()
void | log2Monitor(java.lang.String msg) 纪录信息到监控器
java.lang.String | parsePageVariables(java.lang.String _sContent)
void | saveNestTemplateContext() 保存当前嵌套模板的状态
void | setExtraAttributes(java.util.Map _displayStyles) Sets the display styles.
void | setParent(PublishTagContext _parent) Sets the parent tag parse context.
void | setPrefixOfArgument(java.lang.String prefixOfArgument) 设置模板变量名称的前缀
void | setSequenceNumber(int no)
void | setTagItem(TagItem _tagItem)
void | setUpperFolder(IPublishFolder folder) 设置当前置标正在发布对象的所在目录 该方法只应该在一类地方调用，就是在TRS_DOCUMENTS等概览置标切换了目录之后， 其他任何地方都不应该使用该方法。
void | setUpperHost(IPublishElement _upperHost) Sets the upper host object.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ATTRNAME_CURR_NESTTAGITEM

public static final java.lang.String ATTRNAME_CURR_NESTTAGITEM
另请参见：
常量字段值
构造方法详细信息

PublishTagContext

public PublishTagContext(IPublishElement _upperHost,
                         java.util.Map _extraAttributes,
                         PublishPageContext _pageContext)
已过时。 constructor

参数：
_upperHost - the upper host
_extraAttributes - the extra attributes which may be defined in parent tag item.
_pageContext - the page publish context

PublishTagContext

public PublishTagContext(IPublishElement _upperHost,
                         java.util.Map _extraAttributes,
                         PublishTagContext _parent)
已过时。 constructor

参数：
_upperHost - the upper host
_extraAttributes - the extra attributes which may be defined in parent tag item.
_parent - the parent tag parse context

PublishTagContext

public PublishTagContext(PublishPageContext _pageContext)

PublishTagContext

public PublishTagContext(PublishTagContext _parent,
                         TagItem _tagItem)

PublishTagContext

public PublishTagContext(PublishTagContext _parent,
                         TagItem _tagItem,
                         ITagParser4List _tagParser4List)

PublishTagContext

public PublishTagContext(PublishTagContext _parent,
                         TagItem _tagItem,
                         IPublishElement _upperHost)
方法详细信息

getTagParser4List

public ITagParser4List getTagParser4List()
返回相关联的ITagParser4List对象

返回：
相关联的ITagParser4List对象，或者null

getUpperHost

public IPublishElement getUpperHost()
Returns the upper host object.

返回：
the upper host object.

setUpperHost

public void setUpperHost(IPublishElement _upperHost)
Sets the upper host object.

参数：
_upperHost - the publish element like a folder or a content.

getParent

public PublishTagContext getParent()
Returns the parent tag parse context.

返回：
the parent tag parse context

setParent

public void setParent(PublishTagContext _parent)
Sets the parent tag parse context.

参数：
_parent - the parent tag parse context

getPageContext

public PublishPageContext getPageContext()
Returns the page generate context

返回：
the page generate context

getExtraAttributes

public java.util.Map getExtraAttributes()
Returns the display styles.

返回：
the display styles.

getExtraAttribute

public java.lang.String getExtraAttribute(java.lang.String _sName)
Returns the specified extra attribute.

参数：
_sName - style name
返回：
the specified attribute value.

getBooleanExtraAttribute

public boolean getBooleanExtraAttribute(java.lang.String _sName,
                                        boolean _bDefault)
Returns the boolean extra property.

参数：
_sName - the property name.
_bDefault - default value if the property value is not set.
返回：
the boolean extra property if the value is set; other, the default value.

setExtraAttributes

public void setExtraAttributes(java.util.Map _displayStyles)
Sets the display styles.

参数：
_displayStyles - display styles.

isPreview

public boolean isPreview()
另请参见：
PublishPageContext.isPreview()

getPageFolder

public IPublishFolder getPageFolder()
另请参见：
PublishPageContext.getPageFolder()

getPageElement

public IPublishElement getPageElement()
另请参见：
PublishPageContext.getPageElement()

getPageHttpPath

public java.lang.String getPageHttpPath()
                                 throws WCMException
抛出：
WCMException
另请参见：
PublishPageContext.getPageHttpPath()

getRoot

public IPublishFolder getRoot()
                       throws WCMException
抛出：
WCMException
另请参见：
PublishPageContext.getRoot()

addWarning

public void addWarning(java.lang.String _sObjName,
                       int _nObjId,
                       java.lang.String _sDesc)
                throws WCMException
抛出：
WCMException
另请参见：
PublishPageContext.addWarning(String, int, String)

addWarning

public void addWarning(java.lang.String _sDesc)
                throws WCMException
抛出：
WCMException

getPathCompass

public PublishPathCompass getPathCompass()
另请参见：
PublishPageContext.getPathCompass()

getFileDistributeShip

public FileDistributeShip getFileDistributeShip()
另请参见：
PublishPageContext.getFileDistributeShip()

getUpperFolder

public IPublishFolder getUpperFolder()
Returns the nearest upper folder in current context link.

返回：
the nearest upper folder in current context link.

setUpperFolder

public void setUpperFolder(IPublishFolder folder)
设置当前置标正在发布对象的所在目录 该方法只应该在一类地方调用，就是在TRS_DOCUMENTS等概览置标切换了目录之后， 其他任何地方都不应该使用该方法。

参数：
folder - 指定的目录对象

log2Monitor

public void log2Monitor(java.lang.String msg)
纪录信息到监控器

getTagItem

public TagItem getTagItem()

setTagItem

public void setTagItem(TagItem _tagItem)

getAttributes

public java.util.HashMap getAttributes()
返回：
Returns all the attributes.

getAttribute

public java.lang.String getAttribute(java.lang.String _sName)
get a attribute value

参数：
_sName - the attribute name
返回：
Returns the attribute value if found;
otherwise, returns null.

getAttributeTrim

public java.lang.String getAttributeTrim(java.lang.String _sName)
get the timmed value of a attribute

参数：
_sName - the attribute name.
返回：
Returns the trimmed value of the attribute if found;
otherwise, returns null.

getAttribute

public int getAttribute(java.lang.String _sName,
                        int _nDefault)
                 throws WCMException
get the integer attribute value

参数：
_sName - the attribute name.
_nDefault - default value if the attribute value is not set.
返回：
Returns the integer value of the attribute.
抛出：
WCMException - if the attribute value is not integer.

getAttribute

public boolean getAttribute(java.lang.String _sName,
                            boolean _bDefault)
get the boolean attribute value

参数：
_sName - the attribute name
_bDefault - the default value if the attribute is not found.
返回：
Returns the boolean value of the attribute if found;
otherwise, returns the default value.

getPrefixOfArgument

public java.lang.String getPrefixOfArgument()
返回模板变量名称的前缀

返回：
模板变量名称的前缀

setPrefixOfArgument

public void setPrefixOfArgument(java.lang.String prefixOfArgument)
设置模板变量名称的前缀

参数：
prefixOfArgument - 模板变量名称的前缀

getSequenceNumber

public int getSequenceNumber()
                      throws WCMException
抛出：
WCMException

setSequenceNumber

public void setSequenceNumber(int no)

saveNestTemplateContext

public void saveNestTemplateContext()
保存当前嵌套模板的状态

clearNestTemplateeContext

public void clearNestTemplateeContext()
清空上一次保存的模板状态

parsePageVariables

public java.lang.String parsePageVariables(java.lang.String _sContent)
                                    throws WCMException
抛出：
WCMException
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTaskContext

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.publisher
类 PublishTaskContext

java.lang.Object
    继承者  com.trs.components.common.publish.domain.publisher.PublishTaskContext
所有已实现的接口：
org.aton.container.IClearable
public class PublishTaskContext
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
context for publish task.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishTaskContext(PublishTask _task, IPublishFolder _startFolder)
constructor
方法摘要
void | addErrorLog(int iResult, IPublishElement element, java.lang.String sDesc, java.lang.String sError) 记录发布过程中产生的错误日志
void | addErrorLog(int iResult, IPublishElement element, java.lang.String sDesc, java.lang.Throwable t) 记录发布过程中产生的错误日志
void | clear()
java.lang.Object | getCachObject(java.lang.String _sKey)
int | getDetailPageCount()
FileDistributeShip | getFileDistributeShip() Returns the file distribute ship.
int | getOutlinePageCount()
PublishPathCompass | getPathCompass() Returns the folder path cache box.
IPublishFolder | getRoot() Returns the root of the published folder.
IPublishFolder | getStartFolder()
PublishTask | getTask()
void | incDetailPageCount() increase the detailPageCount.
void | incOutlinePageCount() increase the outlinePageCount.
boolean | isPreview() Returns true if on preview mode.
java.lang.Object | putInCache(java.lang.String _sKey, java.lang.Object _oCacheObject)
void | setStartFolder(IPublishFolder folder)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishTaskContext

public PublishTaskContext(PublishTask _task,
                          IPublishFolder _startFolder)
constructor

参数：
_task - the publish task.
_startFolder - the publish folder.
方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

getTask

public PublishTask getTask()
返回：
Returns the publish task.

getStartFolder

public IPublishFolder getStartFolder()
返回：
Returns the start publish folder.

setStartFolder

public void setStartFolder(IPublishFolder folder)
参数：
folder - The start publish folder to set.

isPreview

public boolean isPreview()
Returns true if on preview mode.

返回：
true if on preview mode.

getRoot

public IPublishFolder getRoot()
                       throws WCMException
Returns the root of the published folder.

返回：
the root of the published folder.
抛出：
WCMException

getPathCompass

public PublishPathCompass getPathCompass()
Returns the folder path cache box.

返回：
the folder path cache box

getFileDistributeShip

public FileDistributeShip getFileDistributeShip()
Returns the file distribute ship.

返回：
the file distribute ship

getDetailPageCount

public int getDetailPageCount()
返回：
Returns the detailPageCount.

incDetailPageCount

public void incDetailPageCount()
increase the detailPageCount.

getOutlinePageCount

public int getOutlinePageCount()
返回：
Returns the outlinePageCount.

incOutlinePageCount

public void incOutlinePageCount()
increase the outlinePageCount.

addErrorLog

public void addErrorLog(int iResult,
                        IPublishElement element,
                        java.lang.String sDesc,
                        java.lang.String sError)
记录发布过程中产生的错误日志

addErrorLog

public void addErrorLog(int iResult,
                        IPublishElement element,
                        java.lang.String sDesc,
                        java.lang.Throwable t)
记录发布过程中产生的错误日志

putInCache

public java.lang.Object putInCache(java.lang.String _sKey,
                                   java.lang.Object _oCacheObject)

getCachObject

public java.lang.Object getCachObject(java.lang.String _sKey)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.domain.publisher.PageDestroyer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.publisher.PageDestroyer
的使用

没有 com.trs.components.common.publish.domain.publisher.PageDestroyer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.publisher.PageGenerator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.publisher.PageGenerator
的使用

没有 com.trs.components.common.publish.domain.publisher.PageGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.publisher.PageNavHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.publisher.PageNavHelper
的使用

没有 com.trs.components.common.publish.domain.publisher.PageNavHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.publisher.PublishPageContext 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.publisher.PublishPageContext
的使用

使用 PublishPageContext 的软件包
com.trs.components.common.publish.domain.publisher
com.trs.components.infoview.helper

com.trs.components.common.publish.domain.publisher 中 PublishPageContext 的使用

返回 PublishPageContext 的 com.trs.components.common.publish.domain.publisher 中的方法
 PublishPageContext PublishTagContext.getPageContext()
Returns the page generate context

参数类型为 PublishPageContext 的 com.trs.components.common.publish.domain.publisher 中的方法
static java.lang.String[] | PageGenerator.generateContent(PublishPageContext _pageContext, Template _template)
static java.lang.String | PageGenerator.generateDetail(PublishPageContext _pageContext) generate the content detail page file
static java.lang.String[] | PageGenerator.generateOutlines(PublishPageContext _pageContext) generate the content folder outline page file
static java.lang.String | PageGenerator.generatePage(PublishPageContext _pageContext, Template _template) Generates page with the specified template in the specified page context.
static java.lang.String | PageGenerator.generatePage(PublishPageContext _pageContext, Template _template, boolean _bDiffContent)
static java.lang.String | PageNavHelper.makeNav(PublishPageContext context, java.lang.String fileName, java.lang.String fileExt, int pageCount, int currPage)

参数类型为 PublishPageContext 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishPageContext(PublishPageContext pageContext)
constructor
PublishTagContext(IPublishElement _upperHost, java.util.Map _extraAttributes, PublishPageContext _pageContext)
已过时。 constructor
PublishTagContext(PublishPageContext _pageContext)

com.trs.components.infoview.helper 中 PublishPageContext 的使用

参数类型为 PublishPageContext 的 com.trs.components.infoview.helper 中的方法
static Template InfoViewTemplateHelper.getDetailTemplate(PublishPageContext _pageContext)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.publisher.PublishPathCompass
的使用

使用 PublishPathCompass 的软件包
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.publisher

com.trs.components.common.publish.domain.distribute 中 PublishPathCompass 的使用

参数类型为 PublishPathCompass 的 com.trs.components.common.publish.domain.distribute 中的构造方法
FileDistributeShip(PublishPathCompass _pathCompass)
constructor

com.trs.components.common.publish.domain.publisher 中 PublishPathCompass 的使用

返回 PublishPathCompass 的 com.trs.components.common.publish.domain.publisher 中的方法
PublishPathCompass | PublishTaskContext.getPathCompass() Returns the folder path cache box.
PublishPathCompass | PublishPageContext.getPathCompass()
PublishPathCompass | PublishTagContext.getPathCompass()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.publisher.PublishSyncGlobalTuner 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.publisher.PublishSyncGlobalTuner
的使用

没有 com.trs.components.common.publish.domain.publisher.PublishSyncGlobalTuner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.publisher.PublishTagContext 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.publisher.PublishTagContext
的使用

使用 PublishTagContext 的软件包
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.wcm.photo.publish |
com.trs.wcmonline |

com.trs.components.comment.publish.tagparser 中 PublishTagContext 的使用

参数类型为 PublishTagContext 的 com.trs.components.comment.publish.tagparser 中的方法
 java.lang.String[] XWCMTagParserComment.parse(PublishTagContext _context)

com.trs.components.common.publish.domain.publisher 中 PublishTagContext 的使用

返回 PublishTagContext 的 com.trs.components.common.publish.domain.publisher 中的方法
 PublishTagContext PublishTagContext.getParent()
Returns the parent tag parse context.

参数类型为 PublishTagContext 的 com.trs.components.common.publish.domain.publisher 中的方法
 void PublishTagContext.setParent(PublishTagContext _parent)
Sets the parent tag parse context.

参数类型为 PublishTagContext 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishTagContext(IPublishElement _upperHost, java.util.Map _extraAttributes, PublishTagContext _parent)
已过时。 constructor
PublishTagContext(PublishTagContext _parent, TagItem _tagItem)
PublishTagContext(PublishTagContext _parent, TagItem _tagItem, IPublishElement _upperHost)
PublishTagContext(PublishTagContext _parent, TagItem _tagItem, ITagParser4List _tagParser4List)

com.trs.components.common.publish.domain.tagparser 中 PublishTagContext 的使用

返回 PublishTagContext 的 com.trs.components.common.publish.domain.tagparser 中的方法
PublishTagContext | ITagParser4List.getDelegatedContext() 返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
PublishTagContext | BaseTagParser4List.getDelegatedContext()
PublishTagContext | ITagParser4List.getNextRecordContext() Returns the tag parse context of the next record.
PublishTagContext | BaseTagParser4List.getNextRecordContext()
PublishTagContext | ITagParser4List.substantiateContext(PublishTagContext _tagConext) 实体化指定的PublishTagContext对象
PublishTagContext | BaseTagParser4List.substantiateContext(PublishTagContext _tagConext)

参数类型为 PublishTagContext 的 com.trs.components.common.publish.domain.tagparser 中的方法
static java.lang.String TagParseHelper.addAutoLink(java.lang.String _sUrl, java.lang.String _sValue, java.lang.String _sDefaultAltText, PublishTagContext _context)
生成带有链接的HTML文本
static java.lang.String TagParseHelper.addSpanStyleIfNeeded(PublishTagContext _context, java.lang.String _sText)
如果有必要在文本外面套上
static java.lang.String[] TagParseHelper.addSpanStyleIfNeeded(PublishTagContext _context, java.lang.String[] results)
如果有必要在文本外面套上 <span class="CLASSNAME">xxx</span>
static void TagParseHelper.distributionHTMLContentFiles(IPublishContent _content, PublishTagContext _context, java.util.List _listFiles)
static Template TagParseHelper.findNestedTemplate(PublishTagContext _context)
Returns the template defined in the specified nested template tag item.
static java.lang.String TagParseHelper.formatTextIfNeeded(PublishTagContext _context, java.lang.String _sText)
Formats the text if AUTOFORMAT=true.
static boolean TagParseHelper.isVisualParseMode(PublishTagContext context)
判断当前是否为可视化设计模式
 java.lang.String[] TagParserDateTime.parse(PublishTagContext _context)
 java.lang.String[] TagParserPageNav4Detail.parse(PublishTagContext _context)
 java.lang.String[] TagParserNestedTemplate.parse(PublishTagContext _context)
 java.lang.String[] TagParserCondition.parse(PublishTagContext _context)
 java.lang.String[] ITagParser.parse(PublishTagContext _context)
Parses the specified tag item and returns the result.
 java.lang.String[] TagParserUnimpl.parse(PublishTagContext _context)
 java.lang.String[] TagParserRepeat.parse(PublishTagContext _tagContext)
 java.lang.String[] TagParserOddOrEven.parse(PublishTagContext context)
 java.lang.String[] TagParserSequenceNumber.parse(PublishTagContext _context)
 java.lang.String[] TagParserEcho.parse(PublishTagContext _context)
 java.lang.String[] TagParserVariableEnum.parse(PublishTagContext _context)
 java.lang.String[] TagParserVariable.parse(PublishTagContext _context)
 java.lang.String[] TagParserOnlyLogic.parse(PublishTagContext _context)
 java.lang.String[] TagParserSystemConfig.parse(PublishTagContext _context)
 java.lang.String[] BaseTagParser4List.parse(PublishTagContext _context)
 java.lang.String[] TagParserVariableSet.parse(PublishTagContext _context)
 java.lang.String[] TagParserNewIcon.parse(PublishTagContext _context)
 java.lang.String[] TagParserCMSObjBase.parse(PublishTagContext _context)
static java.lang.String[] TagParseHelper.parse4Children(TagItem _tagItem, PublishTagContext _tagContext)
static java.lang.String[] TagParseHelper.parse4List(PublishTagContext _tagContext, ITagParser4List _parser4List)
static java.lang.String[] TagParseHelper.parse4List(TagItem _tagItem, PublishTagContext _tagContext, ITagParser4List _parser4List)
Parses objects list tag, eg.
static java.lang.String[] TagParseHelper.parseHtmlContent(java.lang.String _sHtmlContent, IPublishContent _content, PublishTagContext _context)
static java.lang.String[] TagParseHelper.parseItem(TagItem _item, PublishTagContext _context)
Parses a tag item and returns the results which may be more than one.
static java.lang.String[] TagParseHelper.parseItems(java.util.List _items, PublishTagContext _context)
Parses the tag items list and return the results which may be more than one.
 java.lang.String[] TagParserPageNav4Detail.separatePages(PublishTagContext _context, java.lang.String _sText)
 java.lang.String[] TagParserDetailPages.separatePages(PublishTagContext _context, java.lang.String _sText)
 PublishTagContext ITagParser4List.substantiateContext(PublishTagContext _tagConext)
实体化指定的PublishTagContext对象
 PublishTagContext BaseTagParser4List.substantiateContext(PublishTagContext _tagConext)
static java.lang.String TagParseHelper.truncateTextIfNeeded(PublishTagContext _context, java.lang.String _sText)
Truncates the text length if needed (when NUM>0).

com.trs.components.common.publish.widget.tagparser 中 PublishTagContext 的使用

参数类型为 PublishTagContext 的 com.trs.components.common.publish.widget.tagparser 中的方法
java.lang.String[] | WCMTagParserPageStyle.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserSpecialAppendix.parse(PublishTagContext _context) 解析
java.lang.String[] | WCMTagParserWidget.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserBaseOperation.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserLayout.parse(PublishTagContext context)
java.lang.String[] | WCMTagParserTagCreator.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserLayoutCell.parse(PublishTagContext context)
java.lang.String[] | WCMTagParserPreWidget.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserSpecialLogo.parse(PublishTagContext _context) 解析
java.lang.String[] | WCMTagParserResources.parse(PublishTagContext _context) 发布产生指定的资源

com.trs.components.infoview.publish.tagparser 中 PublishTagContext 的使用

参数类型为 PublishTagContext 的 com.trs.components.infoview.publish.tagparser 中的方法
java.lang.String[] | TagParserInfoViewNavs.parse(PublishTagContext _context)
java.lang.String[] | TagParserInfoViewHelper.parse(PublishTagContext _context)
java.lang.String[] | TagParserInfoViewData.parse(PublishTagContext _context)
java.lang.String[] | TagParserInfoViewNav.parse(PublishTagContext _context)
java.lang.String[] | TagParserInfoViewPage.parse(PublishTagContext _context)
java.lang.String[] | TagParserInfoViews.parse(PublishTagContext _context)
java.lang.String[] | TagParserInfoView.parse(PublishTagContext _context)
static java.lang.String[] | InfoviewSpecailTagParseHelper.parseChnlRelatedEnum(PublishTagContext _context)

com.trs.components.metadata.publish 中 PublishTagContext 的使用

返回 PublishTagContext 的 com.trs.components.metadata.publish 中的方法
PublishTagContext | WCMTagParserRelNewsForViewData.getDelegatedContext()
PublishTagContext | WCMTagParserClassInfos.getDelegatedContext()
PublishTagContext | WCMTagParserRelNewsForViewData.getNextRecordContext()
PublishTagContext | WCMTagParserClassInfos.getNextRecordContext()
PublishTagContext | WCMTagParserRelNewsForViewData.substantiateContext(PublishTagContext _tagConext)
PublishTagContext | WCMTagParserClassInfos.substantiateContext(PublishTagContext _tagConext)

参数类型为 PublishTagContext 的 com.trs.components.metadata.publish 中的方法
void | WCMTagParserViewDatas.makeCurrChannel(PublishTagContext _context)
java.lang.String[] | WCMTagParserAppendix.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserClassIndexGener.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserRelNewsForViewData.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserClassInfos.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserViewDatas.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserViewData.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserExistDataOfClassInfo.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserViewData.parseSubItems(PublishTagContext _context)
PublishTagContext | WCMTagParserRelNewsForViewData.substantiateContext(PublishTagContext _tagConext)
PublishTagContext | WCMTagParserClassInfos.substantiateContext(PublishTagContext _tagConext)

com.trs.components.wcm.epress 中 PublishTagContext 的使用

参数类型为 PublishTagContext 的 com.trs.components.wcm.epress 中的方法
java.lang.String[] | TagPreNextParser.parse(PublishTagContext _context)
java.lang.String[] | TagParserPageNav.parse(PublishTagContext _context)
java.lang.String[] | TagMapAreaParser.parse(PublishTagContext _context)
java.lang.String[] | TagEBookDirParser.parse(PublishTagContext _context)

com.trs.components.wcm.publish.region 中 PublishTagContext 的使用

参数类型为 PublishTagContext 的 com.trs.components.wcm.publish.region 中的方法
 java.lang.String[] WCMTagParserRegion.parse(PublishTagContext _context)

com.trs.components.wcm.publish.tagparser 中 PublishTagContext 的使用

返回 PublishTagContext 的 com.trs.components.wcm.publish.tagparser 中的方法
PublishTagContext | WCMTagParser4ObjsInChannelBase.getDelegatedContext()
PublishTagContext | WCMTagParserChannels.getDelegatedContext()
PublishTagContext | WCMTagParserRelNews.getDelegatedContext()
PublishTagContext | WCMTagParser4ObjsInChannelBase.getNextRecordContext()
PublishTagContext | WCMTagParserChannels.getNextRecordContext()
PublishTagContext | WCMTagParserRelNews.getNextRecordContext()
PublishTagContext | WCMTagParser4ObjsInChannelBase.substantiateContext(PublishTagContext _tagConext)
PublishTagContext | WCMTagParserChannels.substantiateContext(PublishTagContext _tagConext)
PublishTagContext | WCMTagParserRelNews.substantiateContext(PublishTagContext _tagConext)

参数类型为 PublishTagContext 的 com.trs.components.wcm.publish.tagparser 中的方法
static Document | WCMTagParserHelper.findDocumentHost(PublishTagContext _context)
static BaseChannel | WCMTagParserHelper.findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel) Returns the current host as a channel.
static BaseChannel | WCMTagParserHelper.findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel, boolean _bIsFromAllCataTag)
static BaseChannel | WCMTagParserHelper.findFolderHostByOldModal(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel)
abstract IPublishElement | WCMTagParserLogoBase.findHost(PublishTagContext _context)
IPublishElement | WCMTagParserDocumentLogo.findHost(PublishTagContext _context)
IPublishElement | WCMTagParserChannelLogo.findHost(PublishTagContext _context)
static java.lang.String | WCMAppendixGenerator.generateAppendix(Appendix _appendix, IPublishContent _apdOwner, PublishTagContext _context, int _nReturnMode) Generates a document appendix.
static java.lang.String | WCMAppendixGenerator.generateAppendixes(Document _doc, int _nApdType, PublishTagContext _context, int _nReturnMode) Generate the appendixes of a document.
static int | WCMTagParserHelper.getChildIndex(PublishTagContext _context) Returns the value of property ChildIndex in tag item.
java.lang.String[] | TagWmlContentParser.parse(PublishTagContext _context)
java.lang.String[] | TagChannelChainParser.parse(PublishTagContext _context)
java.lang.String[] | TagParserWmlImage.parse(PublishTagContext _context)
java.lang.String[] | XWCMContImgTagParser.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserLogoBase.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserCurPage.parse(PublishTagContext _context)
java.lang.String[] | TagParserCRUser.parse(PublishTagContext _context)
java.lang.String[] | XWCMTagParserPageGeneration.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserDefaultObjectsInChannelBase.parse(PublishTagContext _context)
java.lang.String[] | XTagParserObjsInChannelBase.parse(PublishTagContext _tagContext)
java.lang.String[] | WCMTagParserMapArea.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserAppendix.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserPrev.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserIcon.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParser4ObjsInChannelBase.parse(PublishTagContext _context)
java.lang.String[] | XWCMFileAppendixTagParser.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserChannels.parse(PublishTagContext _context)
java.lang.String[] | XWCMImageAppendixTagParser.parse(PublishTagContext _context) 通过图片全路径找到图片名称（带后缀名）
java.lang.String[] | WCMTagparserTopIcon.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserReplace.parse(PublishTagContext _context)
java.lang.String[] | TagParserWmlImages.parse(PublishTagContext _context)
java.lang.String[] | WCMTagParserRelNews.parse(PublishTagContext _context)
java.lang.String | WCMTagParserRollDocuments.parseAutoMore(IPublishFolder _currFolder, PublishTagContext _context)
java.lang.String | WCMTagParser4ObjsInChannelBase.parseAutoMore(IPublishFolder _currFolder, PublishTagContext _context) Parses the auto more HTML text.
PublishTagContext | WCMTagParser4ObjsInChannelBase.substantiateContext(PublishTagContext _tagConext)
PublishTagContext | WCMTagParserChannels.substantiateContext(PublishTagContext _tagConext)
PublishTagContext | WCMTagParserRelNews.substantiateContext(PublishTagContext _tagConext)

com.trs.wcm.photo.publish 中 PublishTagContext 的使用

参数类型为 PublishTagContext 的 com.trs.wcm.photo.publish 中的方法
 java.lang.String[] WCMTagParserImage.parse(PublishTagContext _context)

com.trs.wcmonline 中 PublishTagContext 的使用

参数类型为 PublishTagContext 的 com.trs.wcmonline 中的方法
 java.lang.String[] TagParserVipMetaData.parse(PublishTagContext _context)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.publisher.PublishTaskContext
的使用

使用 PublishTaskContext 的软件包
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.publisher 中 PublishTaskContext 的使用

返回 PublishTaskContext 的 com.trs.components.common.publish.domain.publisher 中的方法
 PublishTaskContext PublishPageContext.getTaskContext()
Returns the current publish task context.

参数类型为 PublishTaskContext 的 com.trs.components.common.publish.domain.publisher 中的方法
static void | PageDestroyer.withdraw(IPublishContent _content, PublishTaskContext _taskContext) Withdraws the detail pages of the specified content.
static void | PageDestroyer.withdraw(IPublishFolder _folder, PublishTaskContext _taskContext) Withdraws all the files in a specified folder.

参数类型为 PublishTaskContext 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishPageContext(IPublishElement _pageElement, PublishTaskContext _taskContext)
constructor
PublishPageContext(IPublishElement _pageElement, PublishTaskContext _taskContext, IPublishProgressMonitor _monitor)
constructor

com.trs.components.common.publish.domain.taskdispatch 中 PublishTaskContext 的使用

返回 PublishTaskContext 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
 PublishTaskContext PublishTaskRuntime.getTaskContext()

参数类型为 PublishTaskContext 的 com.trs.components.common.publish.domain.taskdispatch 中的构造方法
PageTaskWorker(IPageTaskDispatcher _dispatcher, PublishTaskContext _publishTaskContext)
constructor
PageTaskWorker(IPageTaskDispatcher _dispatcher, PublishTaskContext _publishTaskContext, IPublishProgressMonitor _monitor)
constructor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseTagParser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 BaseTagParser

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
直接已知子类：
BaseTagParser4List, WCMTagParserBaseOperation, WCMTagParserClassInfos, WCMTagParserImage, WCMTagParserLayout, WCMTagParserLayoutCell, WCMTagParserLogoBase, WCMTagParserPageStyle, WCMTagParserPreWidget, WCMTagParserResources, WCMTagParserSpecialAppendix, WCMTagParserSpecialLogo, WCMTagParserTagCreator, WCMTagParserWidget, XWCMContImgTagParser
public abstract class BaseTagParser
extends java.lang.Object
implements ITagParser

构造方法摘要
BaseTagParser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.domain.tagparser.ITagParser 继承的方法
parse

构造方法详细信息

BaseTagParser

public BaseTagParser()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BaseTagParser4List

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 BaseTagParser4List

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
直接已知子类：
BaseTagParserDefaultObjects, BaseWCMTagParserPreNextDocuments, TagParserDetailPages, WCMTagParserClassDocuments, WCMTagParserDocumentChannels, WCMTagParserMyViewDatas, WCMTagParserViewDatas, WCMTagParserViewFields, WCMTagParserWebSites
public abstract class BaseTagParser4List
extends BaseTagParser
implements ITagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseTagParser4List()
方法摘要
PublishTagContext | getDelegatedContext() 返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
PublishTagContext | getNextRecordContext() Returns the tag parse context of the next record.
int | getRecordSize() Returns the records number in thes list.
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setStartPos(int _nPos) Sets the start position
PublishTagContext | substantiateContext(PublishTagContext _tagConext) 实体化指定的PublishTagContext对象
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseTagParser4List

public BaseTagParser4List()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

getRecordSize

public int getRecordSize()
从接口 ITagParser4List 复制的描述
Returns the records number in thes list.

指定者：
接口 ITagParser4List 中的 getRecordSize
返回：
the records number in thes list.

setStartPos

public void setStartPos(int _nPos)
从接口 ITagParser4List 复制的描述
Sets the start position

指定者：
接口 ITagParser4List 中的 setStartPos

getNextRecordContext

public PublishTagContext getNextRecordContext()
                                       throws WCMException
从接口 ITagParser4List 复制的描述
Returns the tag parse context of the next record.

指定者：
接口 ITagParser4List 中的 getNextRecordContext
返回：
the tag parse context of the next record.
抛出：
WCMException - if failed to get the next record or to construct the tag parse context.
另请参见：
ITagParser4List.getNextRecordContext()

getDelegatedContext

public PublishTagContext getDelegatedContext()
从接口 ITagParser4List 复制的描述
返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。 所谓被被托管（托管这种说法可能不太准确）的PublishTagContext对象， 是指被延迟实体化的对象，也即延迟设定实际的UpperHost的对象，因为被实体化， 所以相应 ITagParser4List对象中游标也就没有发生实际的移动。 注意（2006.02.08）
事实上该方法和substantiateContext(PublishTagContext)组合使用， 应该可以替代 getNextRecordContext方法，而且这两套方法不能混合使用， 之所以要保留 getNextRecordContext，是为了使改动可以回退。

指定者：
接口 ITagParser4List 中的 getDelegatedContext
返回：
被托管的PublishTagContext对象，或者null。
另请参见：
ITagParser4List.substantiateContext(PublishTagContext), ITagParser4List.getNextRecordContext()

substantiateContext

public PublishTagContext substantiateContext(PublishTagContext _tagConext)
                                      throws WCMException
从接口 ITagParser4List 复制的描述
实体化指定的PublishTagContext对象

指定者：
接口 ITagParser4List 中的 substantiateContext
参数：
_tagConext - 指定的PublishTagContext对象
返回：
实体化后的PublishTagContext对象
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseTagParserDefaultObjects

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 BaseTagParserDefaultObjects

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
直接已知子类：
TagParserDefaultObjects
public abstract class BaseTagParserDefaultObjects
extends BaseTagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseTagParserDefaultObjects()
方法摘要
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseTagParserDefaultObjects

public BaseTagParserDefaultObjects()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ITagFormatter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
接口 ITagFormatter

所有已知实现类：
WCMTagFormatterAllCata, WCMTagFormatterBigNews, WCMTagFormatterChannel, WCMTagFormatterChnlName, WCMTagFormatterColumn, WCMTagFormatterDocumentsBase, WCMTagFormatterOutline, WCMTagFormatterPicNews, WCMTagFormatterPicture, WCMTagFormatterRecPath, WCMTagFormatterRelNews, WCMTagFormatterTemplate
public interface ITagFormatter

Title: TRS 内容协作平台（TRS WCM）
Description:
tag item format converter.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.

方法详细信息

standardize

void standardize(TagItem _item)
                 throws WCMException
Converts the tag item to standard format.

参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ITagParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
接口 ITagParser

所有超级接口：
org.aton.container.IClearable
所有已知实现类：
BaseTagParser, BaseTagParser4List, BaseTagParserDefaultObjects, BaseWCMTagParserPreNextDocuments, TagChannelChainParser, TagDocbakParser, TagEBookDirParser, TagMapAreaParser, TagParserCMSObj, TagParserCMSObjBase, TagParserCondition, TagParserContentBase, TagParserCRUser, TagParserDateTime, TagParserDefaultObjects, TagParserDetailPage, TagParserDetailPages, TagParserEcho, TagParserFolderBase, TagParserInfoView, TagParserInfoViewData, TagParserInfoViewHelper, TagParserInfoViewNav, TagParserInfoViewNavs, TagParserInfoViewPage, TagParserInfoViews, TagParserNestedTemplate, TagParserNewIcon, TagParserOddOrEven, TagParserOnlyLogic, TagParserPageNav, TagParserPageNav4Detail, TagParserRepeat, TagParserSequenceNumber, TagParserSystemConfig, TagParserUnimpl, TagParserUser, TagParserVariable, TagParserVariableEnum, TagParserVariableSet, TagParserVipMetaData, TagParserWmlImage, TagParserWmlImages, TagPreNextParser, TagWmlContentParser, WCMTagParser4FolderHostBase, WCMTagParser4ObjsInChannelBase, WCMTagParserAppendix, WCMTagParserAppendix, WCMTagParserBaseOperation, WCMTagParserChannel, WCMTagParserChannelLogo, WCMTagParserChannels, WCMTagParserChnlInChnlOperation, WCMTagParserChnlOperation, WCMTagParserClassDocuments, WCMTagParserClassIndexGener, WCMTagParserClassInfo, WCMTagParserClassInfos, WCMTagParserCurPage, WCMTagParserDefaultObjectsInChannel, WCMTagParserDefaultObjectsInChannelBase, WCMTagParserDocInChnlOperation, WCMTagParserDocOperation, WCMTagParserDocReply, WCMTagParserDocument, WCMTagParserDocumentChannels, WCMTagParserDocumentForBJGOV, WCMTagParserDocumentLogo, WCMTagParserDocuments, WCMTagParserEPressNews, WCMTagParserEPressNews, WCMTagParserExistDataOfClassInfo, WCMTagParserExpertNews, WCMTagParserIcon, WCMTagParserImage, WCMTagParserLayout, WCMTagParserLayoutCell, WCMTagParserLogoBase, WCMTagParserMapArea, WCMTagParserMyViewDatas, WCMTagParserNextDocuments, WCMTagParserPageStyle, WCMTagParserPreDocuments, WCMTagParserPrev, WCMTagParserPreWidget, WCMTagParserRegion, WCMTagParserRelNews, WCMTagParserRelNewsForViewData, WCMTagParserReplace, WCMTagParserResources, WCMTagParserRollDocuments, WCMTagParserSpecialAppendix, WCMTagParserSpecialLogo, WCMTagParserTagCreator, WCMTagparserTopIcon, WCMTagParserViewData, WCMTagParserViewDatas, WCMTagParserViewField, WCMTagParserViewFields, WCMTagParserWebSite, WCMTagParserWebSites, WCMTagParserWidget, WCMTagParserXDcouments, WCMTagParserXDocument, XTagParserObjsInChannelBase, XWCMContImgTagParser, XWCMFileAppendixTagParser, XWCMImageAppendixTagParser, XWCMTagParserComment, XWCMTagParserPageGeneration
public interface ITagParser
extends org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从接口 org.aton.container.IClearable 继承的方法
clear

方法详细信息

getBeanInfo

TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述

setTagItem

void setTagItem(TagItem _item)
Sets the tag item to parser.

参数：
_item - a tag item.

analyzeQuotes

TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
Analyzes the quote relations between this template and folders.

参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
_styles - display styles
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ITagParser4List

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
接口 ITagParser4List

所有已知实现类：
BaseTagParser4List, BaseTagParserDefaultObjects, BaseWCMTagParserPreNextDocuments, TagParserDefaultObjects, TagParserDetailPages, WCMTagParser4ObjsInChannelBase, WCMTagParserChannels, WCMTagParserClassDocuments, WCMTagParserClassInfos, WCMTagParserDefaultObjectsInChannel, WCMTagParserDefaultObjectsInChannelBase, WCMTagParserDocumentChannels, WCMTagParserDocuments, WCMTagParserEPressNews, WCMTagParserEPressNews, WCMTagParserExpertNews, WCMTagParserMyViewDatas, WCMTagParserNextDocuments, WCMTagParserPreDocuments, WCMTagParserRelNews, WCMTagParserRelNewsForViewData, WCMTagParserRollDocuments, WCMTagParserViewDatas, WCMTagParserViewFields, WCMTagParserWebSites, WCMTagParserXDcouments, XTagParserObjsInChannelBase
public interface ITagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
interface for those who support tag TRS_RECORD.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
PublishTagContext | getDelegatedContext() 返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
PublishTagContext | getNextRecordContext() Returns the tag parse context of the next record.
int | getRecordSize() Returns the records number in thes list.
void | setStartPos(int _nPos) Sets the start position
PublishTagContext | substantiateContext(PublishTagContext _tagConext) 实体化指定的PublishTagContext对象

方法详细信息

getRecordSize

int getRecordSize()
Returns the records number in thes list.

返回：
the records number in thes list.

setStartPos

void setStartPos(int _nPos)
Sets the start position

getNextRecordContext

PublishTagContext getNextRecordContext()
                                       throws WCMException
Returns the tag parse context of the next record.

返回：
the tag parse context of the next record.
抛出：
WCMException - if failed to get the next record or to construct the tag parse context.

getDelegatedContext

PublishTagContext getDelegatedContext()
返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。 所谓被被托管（托管这种说法可能不太准确）的PublishTagContext对象， 是指被延迟实体化的对象，也即延迟设定实际的UpperHost的对象，因为被实体化， 所以相应 ITagParser4List对象中游标也就没有发生实际的移动。 注意（2006.02.08）
事实上该方法和substantiateContext(PublishTagContext)组合使用， 应该可以替代 getNextRecordContext方法，而且这两套方法不能混合使用， 之所以要保留 getNextRecordContext，是为了使改动可以回退。

返回：
被托管的PublishTagContext对象，或者null。
另请参见：
substantiateContext(PublishTagContext), getNextRecordContext()

substantiateContext

PublishTagContext substantiateContext(PublishTagContext _tagConext)
                                      throws WCMException
实体化指定的PublishTagContext对象

参数：
_tagConext - 指定的PublishTagContext对象
返回：
实体化后的PublishTagContext对象
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoopException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 LoopException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.components.common.publish.domain.tagparser.LoopException
所有已实现的接口：
java.io.Serializable
public class LoopException
extends java.lang.Exception

Title: TRS 内容协作平台（TRS WCM）
Description:
回路异常标识
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
LoopException()
LoopException(java.lang.String message)
LoopException(java.lang.String message, java.lang.Throwable cause)
LoopException(java.lang.Throwable cause)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LoopException

public LoopException()

LoopException

public LoopException(java.lang.String message)
参数：
message -

LoopException

public LoopException(java.lang.Throwable cause)
参数：
cause -

LoopException

public LoopException(java.lang.String message,
                     java.lang.Throwable cause)
参数：
message -
cause -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.domain.tagparser
接口
ITagFormatter
ITagParser
ITagParser4List
类
BaseTagParser
BaseTagParser4List
BaseTagParserDefaultObjects
ScanContext
TagBeanAttrInfo
TagBeanAttrInfo.Type
TagBeanInfo
TagBeanInfo.BodyType
TagBeanInfoHelper
TagBeanLCListener
TagDocument
TagDocumentReader
TagDocumentScanner
TagFormatHelper
TagItem
TagParseHelper
TagParserCMSObj
TagParserCMSObjBase
TagParserCondition
TagParserCondition.Operator
TagParserContentBase
TagParserDateTime
TagParserDefaultObjects
TagParserDetailPage
TagParserDetailPages
TagParserEcho
TagParseResults
TagParserFactory
TagParserFolderBase
TagParserNestedTemplate
TagParserNewIcon
TagParserOddOrEven
TagParserOnlyLogic
TagParserPageNav4Detail
TagParserRepeat
TagParserSequenceNumber
TagParserSystemConfig
TagParserUnimpl
TagParserUser
TagParserVariable
TagParserVariableEnum
TagParserVariableSet
TemplateParameter
TemplateParameter.Token
TemplateParameter.Type
TemplateParameterList
异常
LoopException


com.trs.components.common.publish.domain.tagparser

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.domain.tagparser

接口摘要
ITagFormatter | Title: TRS 内容协作平台（TRS WCM） Description: tag item format converter.
ITagParser | Title: TRS 内容协作平台（TRS WCM） Description: tag parser interface.
ITagParser4List | Title: TRS 内容协作平台（TRS WCM） Description: interface for those who support tag TRS_RECORD.

类摘要
BaseTagParser |
BaseTagParser4List | Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseTagParserDefaultObjects | Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ScanContext | 扫描模板正文，把正文解析成为置标树的辅助类。
TagBeanAttrInfo | 用于描述 ITagParser 置标的属性的特性
TagBeanAttrInfo.Type |
TagBeanInfo | 用于描述 ITagParser 置标的特性
TagBeanInfo.BodyType |
TagBeanInfoHelper | TagBeanInfo的辅助类
TagBeanLCListener | Title: TRS 内容协作平台（TRS WCM） Description: life cycel listener for TagBean.
TagDocument | Title: TRS 内容协作平台（TRS WCM） Description: the tag document for template DOM.
TagDocumentReader | Title: TRS 内容协作平台（TRS WCM） Description: Tag Document reader.
TagDocumentScanner | 模板正文的文法分析器
TagFormatHelper | Title: TRS 内容协作平台（TRS WCM） Description: helper for tag format Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagItem | Title: TRS 内容协作平台（TRS WCM） Description: tag item Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParseHelper | Title: TRS 内容协作平台（TRS WCM） Description: helper for tag parsing Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserCMSObj | Title: TRS 内容协作平台（TRS WCM） Description: default implementation for CMSObj tag parser.
TagParserCMSObjBase | Title: TRS 内容协作平台（TRS WCM） Description: parser implementation base for CMSObj tag.
TagParserCondition | 条件执行置标，如果指定的条件为真，则继续执行解析该置标下的模板，如果指定的条件为假，则忽略其下的模板。
TagParserCondition.Operator | 比较运算符的抽象
TagParserContentBase | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserDateTime | Title: TRS 内容协作平台（TRS WCM） Description: Tag Parser For TRS_DATETIME Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserDefaultObjects | Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserDetailPage |
TagParserDetailPages |
TagParserEcho | 用于输出指定的内容到生成的文件中，在和模板变量配合使用时才有意义。
TagParseResults | Title: TRS 内容协作平台（TRS WCM） Description: tag parse result Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserFactory | Title: TRS 内容协作平台（TRS WCM） Description: tag parser factory.
TagParserFolderBase | Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserNestedTemplate | Title: TRS 内容协作平台（TRS WCM） Description: tag parser for nested template.
TagParserNewIcon | 该置标为比较新的文档（也可以是其他对象）增加是新文档的标志。
TagParserOddOrEven | Title: TRS 内容协作平台（TRS WCM） Description: 奇偶然样式置标 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
TagParserOnlyLogic |
TagParserPageNav4Detail |
TagParserRepeat | TODO javadoc for com.trs.components.common.publish.domain.tagparser.TagParserRepeat
TagParserSequenceNumber |
TagParserSystemConfig | 返回配置的属性字段的值
TagParserUnimpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserUser |
TagParserVariable | 用于在使用变量前，进行变量的声明。
TagParserVariableEnum | 在声明变量时，枚举变量的可用值
TagParserVariableSet | 给模板变量赋值的置标，一般情况下所赋之值来自其子置标的解析结果
TemplateParameter | 描述模板置标中的形式参数 因为按照目前的设计，置标中的形式参数不保存到数据库，而是解析后存在于缓存中，所以没有把该类放在包 “com.trs.components.common.publish.persistent.template”中。
TemplateParameter.Token | 形式参数的候选值
TemplateParameter.Type | 形式参数的类型
TemplateParameterList | 对象TemplateParameter的集合类

异常摘要
LoopException Title: TRS 内容协作平台（TRS WCM）
Description:
回路异常标识
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.publish.domain.tagparser 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.tagparser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.tagparser.BaseTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.domain.tagparser.BaseTagParser4List (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
        • com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects
          • com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects
        • com.trs.components.common.publish.domain.tagparser.TagParserDetailPages
    • com.trs.components.common.publish.domain.tagparser.ScanContext
    • com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo
    • com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type
    • com.trs.components.common.publish.domain.tagparser.TagBeanInfo
    • com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType
    • com.trs.components.common.publish.domain.tagparser.TagBeanInfoHelper
    • com.trs.components.common.publish.domain.tagparser.TagBeanLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.tagparser.TagDocument (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.tagparser.TagDocumentReader
    • com.trs.components.common.publish.domain.tagparser.TagDocumentScanner
    • com.trs.components.common.publish.domain.tagparser.TagFormatHelper
    • com.trs.components.common.publish.domain.tagparser.TagItem (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.tagparser.TagParseHelper
    • com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.domain.tagparser.TagParserCMSObj
      • com.trs.components.common.publish.domain.tagparser.TagParserContentBase
        • com.trs.components.common.publish.domain.tagparser.TagParserDetailPage
      • com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
      • com.trs.components.common.publish.domain.tagparser.TagParserUser
    • com.trs.components.common.publish.domain.tagparser.TagParserCondition (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserCondition.Operator
    • com.trs.components.common.publish.domain.tagparser.TagParserDateTime (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserEcho (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParseResults (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.tagparser.TagParserFactory (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserNewIcon (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserRepeat (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserUnimpl (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserVariable (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserVariableSet (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TemplateParameter
    • com.trs.components.common.publish.domain.tagparser.TemplateParameter.Token
    • com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type
    • com.trs.components.common.publish.domain.tagparser.TemplateParameterList
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.components.common.publish.domain.tagparser.LoopException

接口分层结构

  • org.aton.container.IClearable
    • com.trs.components.common.publish.domain.tagparser.ITagParser
  • com.trs.components.common.publish.domain.tagparser.ITagFormatter
  • com.trs.components.common.publish.domain.tagparser.ITagParser4List


软件包 com.trs.components.common.publish.domain.tagparser 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.tagparser
的使用

使用 com.trs.components.common.publish.domain.tagparser 的软件包
com.trs.components.comment.publish.helper |
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.publish.tagparser.formater |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.photo.publish |
com.trs.wcmonline |

com.trs.components.comment.publish.helper 使用的 com.trs.components.common.publish.domain.tagparser 中的类
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.comment.publish.tagparser 使用的 com.trs.components.common.publish.domain.tagparser 中的类
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
TagBeanInfo
用于描述 ITagParser 置标的特性
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.publisher 使用的 com.trs.components.common.publish.domain.tagparser 中的类
ITagParser4List
Title: TRS 内容协作平台（TRS WCM）
Description:
interface for those who support tag TRS_RECORD.
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.tagparser 使用的 com.trs.components.common.publish.domain.tagparser 中的类
BaseTagParser
BaseTagParser4List
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseTagParserDefaultObjects
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITagFormatter
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item format converter.
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
ITagParser4List
Title: TRS 内容协作平台（TRS WCM）
Description:
interface for those who support tag TRS_RECORD.
ScanContext
扫描模板正文，把正文解析成为置标树的辅助类。
TagBeanAttrInfo
用于描述 ITagParser 置标的属性的特性
TagBeanAttrInfo.Type
TagBeanInfo
用于描述 ITagParser 置标的特性
TagBeanInfo.BodyType
TagDocument
Title: TRS 内容协作平台（TRS WCM）
Description:
the tag document for template DOM.
TagDocumentScanner
模板正文的文法分析器
TagFormatHelper
Title: TRS 内容协作平台（TRS WCM）
Description:
helper for tag format
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserCMSObjBase
Title: TRS 内容协作平台（TRS WCM）
Description:
parser implementation base for CMSObj tag.
TagParserContentBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParseResults
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse result
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParameter
描述模板置标中的形式参数 因为按照目前的设计，置标中的形式参数不保存到数据库，而是解析后存在于缓存中，所以没有把该类放在包 “com.trs.components.common.publish.persistent.template”中。
TemplateParameter.Token
形式参数的候选值
TemplateParameter.Type
形式参数的类型
TemplateParameterList
对象TemplateParameter的集合类

com.trs.components.common.publish.domain.template 使用的 com.trs.components.common.publish.domain.tagparser 中的类
TagDocument
Title: TRS 内容协作平台（TRS WCM）
Description:
the tag document for template DOM.

com.trs.components.common.publish.persistent.template 使用的 com.trs.components.common.publish.domain.tagparser 中的类
TemplateParameterList
对象TemplateParameter的集合类

com.trs.components.common.publish.widget.tagparser 使用的 com.trs.components.common.publish.domain.tagparser 中的类
BaseTagParser
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
TagBeanInfo
用于描述 ITagParser 置标的特性
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.publish.tagparser 使用的 com.trs.components.common.publish.domain.tagparser 中的类
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
TagBeanInfo
用于描述 ITagParser 置标的特性
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.publish 使用的 com.trs.components.common.publish.domain.tagparser 中的类
BaseTagParser
BaseTagParser4List
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
ITagParser4List
Title: TRS 内容协作平台（TRS WCM）
Description:
interface for those who support tag TRS_RECORD.
TagBeanInfo
用于描述 ITagParser 置标的特性
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserCMSObjBase
Title: TRS 内容协作平台（TRS WCM）
Description:
parser implementation base for CMSObj tag.
TagParserContentBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserFolderBase
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.components.common.publish.domain.tagparser 中的类
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
ITagParser4List
Title: TRS 内容协作平台（TRS WCM）
Description:
interface for those who support tag TRS_RECORD.
TagBeanInfo
用于描述 ITagParser 置标的特性
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 使用的 com.trs.components.common.publish.domain.tagparser 中的类
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
TagBeanInfo
用于描述 ITagParser 置标的特性
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser 使用的 com.trs.components.common.publish.domain.tagparser 中的类
BaseTagParser
BaseTagParser4List
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseTagParserDefaultObjects
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
ITagParser4List
Title: TRS 内容协作平台（TRS WCM）
Description:
interface for those who support tag TRS_RECORD.
TagBeanInfo
用于描述 ITagParser 置标的特性
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserCMSObjBase
Title: TRS 内容协作平台（TRS WCM）
Description:
parser implementation base for CMSObj tag.
TagParserContentBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserDefaultObjects
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserFolderBase
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser.formater 使用的 com.trs.components.common.publish.domain.tagparser 中的类
ITagFormatter
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item format converter.
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service 使用的 com.trs.components.common.publish.domain.tagparser 中的类
TemplateParameterList
对象TemplateParameter的集合类

com.trs.service.impl 使用的 com.trs.components.common.publish.domain.tagparser 中的类
TemplateParameterList
对象TemplateParameter的集合类

com.trs.wcm.photo.publish 使用的 com.trs.components.common.publish.domain.tagparser 中的类
BaseTagParser
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
TagBeanInfo
用于描述 ITagParser 置标的特性

com.trs.wcmonline 使用的 com.trs.components.common.publish.domain.tagparser 中的类
ITagParser
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
TagBeanInfo
用于描述 ITagParser 置标的特性
TagItem
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ScanContext

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 ScanContext

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.ScanContext

public class ScanContext
extends java.lang.Object

扫描模板正文，把正文解析成为置标树的辅助类。

作者：
Martin (付成睿)

构造方法摘要
ScanContext(java.lang.String s)
构造方法
方法摘要
char | getChar() 返回当前字符,但是不移动指针
int | getColumn() 返回当前字符的列号
int | getLength() 返回正文的长度
int | getLineNo() 返回当前字符的行号
int | getOffset() 返回当前字符的偏移位置
boolean | hasChar() 判断是否还有未获取的字符
java.lang.String | lookAround(int iStartPos) 返回从指定的位置开始,到当前位置的一个描述
java.lang.String | lookAround(int iStartPos, int iClosePos) 返回指定启止位置的描述
void | mark() 标记当前位置
char | prevChar() 返回前一个字符,但是不移动指针
void | reset() 重置当前位置为上一次标记的位置
void | skipChar() 移动指针到下一个字符
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScanContext

public ScanContext(java.lang.String s)
构造方法

参数：
s - 模板正文
方法详细信息

hasChar

public boolean hasChar()
判断是否还有未获取的字符

getChar

public char getChar()
返回当前字符,但是不移动指针

prevChar

public char prevChar()
返回前一个字符,但是不移动指针

skipChar

public void skipChar()
移动指针到下一个字符

getColumn

public int getColumn()
返回当前字符的列号

getLineNo

public int getLineNo()
返回当前字符的行号

getOffset

public int getOffset()
返回当前字符的偏移位置

getLength

public int getLength()
返回正文的长度

mark

public void mark()
标记当前位置

reset

public void reset()
重置当前位置为上一次标记的位置

lookAround

public java.lang.String lookAround(int iStartPos)
返回从指定的位置开始,到当前位置的一个描述

参数：
iStartPos - 指定的开始位置

lookAround

public java.lang.String lookAround(int iStartPos,
                                   int iClosePos)
返回指定启止位置的描述

参数：
iStartPos - 指定的开始位置
iClosePos - 指定的结束位置
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagBeanAttrInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagBeanAttrInfo

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo

public class TagBeanAttrInfo
extends java.lang.Object

用于描述 ITagParser 置标的属性的特性

作者：
Martin (付成睿)

嵌套类摘要
static class TagBeanAttrInfo.Type
构造方法摘要
TagBeanAttrInfo()
缺省构造方法
TagBeanAttrInfo(java.lang.String name, TagBeanAttrInfo.Type type, java.lang.String sDef, java.lang.String[] aVal)
构造方法
方法摘要
java.lang.String | getDefaultValue() 返回属性的缺省值
java.lang.String | getDesc() 返回属性的详细描述
java.lang.String[] | getEnumValue() 返回有效的属性值的列表数组，如果属性值不是枚举类型，则返回null。
java.lang.String | getEnumValueString() 返回由有效的属性值构成的字符串，或者null。
java.lang.String | getName() 返回属性名称
boolean | getRequired() 返回对于当前置标该属性是不是必须的
TagBeanAttrInfo.Type | getType() 返回属性类型
boolean | getVariable() 返回设置属性值是不是可变的
void | setDefaultValue(java.lang.String sDefaultValue) 设置属性的缺省值
void | setDesc(java.lang.String desc) 设置属性的详细描述
void | setEnumValue(java.lang.String[] value) 设置有效的属性值的列表数组，如果属性值不是枚举类型，则可以设置为null。
void | setName(java.lang.String name) 设置属性名称
void | setRequired(boolean zRequired) 设置对于当前置标该属性是不是必须的
void | setType(TagBeanAttrInfo.Type type) 设置属性类型
void | setVariable(boolean variable) 设置属性值是不是可变的
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagBeanAttrInfo

public TagBeanAttrInfo()
缺省构造方法

TagBeanAttrInfo

public TagBeanAttrInfo(java.lang.String name,
                       TagBeanAttrInfo.Type type,
                       java.lang.String sDef,
                       java.lang.String[] aVal)
构造方法

参数：
name - 属性名称
type - 属性类型
sDef - 属性缺省值
aVal - 有效属性值的列表
方法详细信息

getName

public java.lang.String getName()
返回属性名称

返回：
属性名称

setName

public void setName(java.lang.String name)
设置属性名称

参数：
name - 属性名称

getDesc

public java.lang.String getDesc()
返回属性的详细描述

返回：
属性的详细描述

setDesc

public void setDesc(java.lang.String desc)
设置属性的详细描述

参数：
desc - 属性的详细描述

getType

public TagBeanAttrInfo.Type getType()
返回属性类型

返回：
属性类型

setType

public void setType(TagBeanAttrInfo.Type type)
设置属性类型

参数：
type - 属性类型

getRequired

public boolean getRequired()
返回对于当前置标该属性是不是必须的

返回：
对于当前置标该属性是不是必须的

setRequired

public void setRequired(boolean zRequired)
设置对于当前置标该属性是不是必须的

参数：
zRequired - 对于当前置标该属性是不是必须的

getVariable

public boolean getVariable()
返回设置属性值是不是可变的

返回：
属性值是否可以为变量

setVariable

public void setVariable(boolean variable)
设置属性值是不是可变的

参数：
variable - 属性值是否可以为变量

getDefaultValue

public java.lang.String getDefaultValue()
返回属性的缺省值

返回：
属性的缺省值

setDefaultValue

public void setDefaultValue(java.lang.String sDefaultValue)
设置属性的缺省值

参数：
sDefaultValue - 属性的缺省值

getEnumValue

public java.lang.String[] getEnumValue()
返回有效的属性值的列表数组，如果属性值不是枚举类型，则返回null。

返回：
有效的属性值的列表数组或者null

setEnumValue

public void setEnumValue(java.lang.String[] value)
设置有效的属性值的列表数组，如果属性值不是枚举类型，则可以设置为null。

参数：
value - 有效的属性值的列表数组或者null

getEnumValueString

public java.lang.String getEnumValueString()
返回由有效的属性值构成的字符串，或者null。

返回：
由有效的属性值构成的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagBeanAttrInfo.Type

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagBeanAttrInfo.Type

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type
包容类：
TagBeanAttrInfo
public static class TagBeanAttrInfo.Type
extends java.lang.Object

字段摘要
static TagBeanAttrInfo.Type | INTEGER 整数类型的属性，属性值必须是10个数字和减号
static TagBeanAttrInfo.Type | NUMBER 数值类型的属性，属性值必须是10个数字、减号和小数点
static TagBeanAttrInfo.Type | STRING 字符串类型的属性，属性值可以是任意字符串
方法摘要
java.lang.String | getName() 返回属性类型的名称
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

INTEGER

public static final TagBeanAttrInfo.Type INTEGER
整数类型的属性，属性值必须是10个数字和减号

NUMBER

public static final TagBeanAttrInfo.Type NUMBER
数值类型的属性，属性值必须是10个数字、减号和小数点

STRING

public static final TagBeanAttrInfo.Type STRING
字符串类型的属性，属性值可以是任意字符串

方法详细信息

getName

public java.lang.String getName()
返回属性类型的名称

返回：
属性类型的名称

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagBeanInfo.BodyType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagBeanInfo.BodyType

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType
包容类：
TagBeanInfo
public static class TagBeanInfo.BodyType
extends java.lang.Object

字段摘要
static TagBeanInfo.BodyType | ARGUMENT 在开始置标和结束置标之间是置标的参数，不能为空
static TagBeanInfo.BodyType | EMPTY 在开始置标和结束置标之间不能有任何内容
static TagBeanInfo.BodyType | HTML 在开始置标和结束置标之间是普通的HTML代码
static TagBeanInfo.BodyType | IGNORE 在开始置标和结束置标之间的任何内容都回忽略
static TagBeanInfo.BodyType | TAMPLATE 在开始置标和结束置标之间，可以是模板内容，既可以包括WCM置标
方法摘要
java.lang.String | getName() 返回属性类型的名称
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

HTML

public static final TagBeanInfo.BodyType HTML
在开始置标和结束置标之间是普通的HTML代码

EMPTY

public static final TagBeanInfo.BodyType EMPTY
在开始置标和结束置标之间不能有任何内容

IGNORE

public static final TagBeanInfo.BodyType IGNORE
在开始置标和结束置标之间的任何内容都回忽略

ARGUMENT

public static final TagBeanInfo.BodyType ARGUMENT
在开始置标和结束置标之间是置标的参数，不能为空

TAMPLATE

public static final TagBeanInfo.BodyType TAMPLATE
在开始置标和结束置标之间，可以是模板内容，既可以包括WCM置标

方法详细信息

getName

public java.lang.String getName()
返回属性类型的名称

返回：
属性类型的名称

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagBeanInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagBeanInfo

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagBeanInfo
直接已知子类：
WCMTagParserBaseOperation.TBI
public class TagBeanInfo
extends java.lang.Object

用于描述 ITagParser 置标的特性

作者：
Martin (付成睿)
另请参见：
ITagParser.getBeanInfo()

嵌套类摘要
static class TagBeanInfo.BodyType
构造方法摘要
TagBeanInfo()
缺省构造方法
TagBeanInfo(java.lang.String name, java.lang.String desc, TagBeanInfo.BodyType type)
构造方法
方法摘要
TagBeanAttrInfo | addAttrInfo(TagBeanAttrInfo tbai) 添加置标属性信息对象，如果相同名称的置标属性信息对象已经存在，则将被替换，并返回。
void | checkSemantic(IPublishFolder _folder, TagItem _tagItem, java.lang.StringBuffer _sbResult) 检查指定的置标实例的静态语义，如果有静态语义错误，则通过传入的StringBuffer对象返回错误信息。
TagBeanAttrInfo | getAttrInfo(java.lang.String name) 返回指定名称的置标属性信息对象。
int | getAttrInfoCount() 返回置标属性的个数
java.util.Iterator | getAttrInfos() 返回置标属性信息对象的，如果该置标没有属性，可以返回null。
java.lang.String | getDesc() 返回置标的详细描述
java.lang.String | getName() 返回置标的名称
TagBeanAttrInfo[] | getRequiredAttr() 返回该置标必须的属性数组
boolean | getThreadSafe() 返回相关联的ITagParser 实现是否线程安全，对于线程安全安全的实现， 可以不必为每一次解析都创建新的实例。
TagBeanInfo.BodyType | getType() 返回置标的类型
void | setDesc(java.lang.String desc) 设置置标的详细描述
void | setName(java.lang.String name) 设置置标的名称
void | setThreadSafe(boolean zSafe) 设置相关联的ITagParser 实现是否线程安全
void | setType(TagBeanInfo.BodyType type) 设置置标的类型
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagBeanInfo

public TagBeanInfo()
缺省构造方法

TagBeanInfo

public TagBeanInfo(java.lang.String name,
                   java.lang.String desc,
                   TagBeanInfo.BodyType type)
构造方法

参数：
name - 置标的名称
desc - 置标的详细描述
type - 置标的类型
方法详细信息

getName

public java.lang.String getName()
返回置标的名称

返回：
置标的名称

setName

public void setName(java.lang.String name)
设置置标的名称

参数：
name - 置标的名称

getDesc

public java.lang.String getDesc()
返回置标的详细描述

返回：
置标的详细描述

setDesc

public void setDesc(java.lang.String desc)
设置置标的详细描述

参数：
desc - 置标的详细描述

getType

public TagBeanInfo.BodyType getType()
返回置标的类型

返回：
置标的类型

setType

public void setType(TagBeanInfo.BodyType type)
设置置标的类型

参数：
type - 置标的类型

getThreadSafe

public boolean getThreadSafe()
返回相关联的ITagParser 实现是否线程安全，对于线程安全安全的实现， 可以不必为每一次解析都创建新的实例。

返回：
相关联的ITagParser 实现是否线程安全

setThreadSafe

public void setThreadSafe(boolean zSafe)
设置相关联的ITagParser 实现是否线程安全

参数：
zSafe - 相关联的ITagParser 实现是否线程安全

getAttrInfoCount

public int getAttrInfoCount()
返回置标属性的个数

返回：
置标属性的个数

getRequiredAttr

public TagBeanAttrInfo[] getRequiredAttr()
返回该置标必须的属性数组

返回：
该置标必须的属性数组

getAttrInfos

public java.util.Iterator getAttrInfos()
返回置标属性信息对象的，如果该置标没有属性，可以返回null。

返回：
置标属性信息对象的数组

getAttrInfo

public TagBeanAttrInfo getAttrInfo(java.lang.String name)
返回指定名称的置标属性信息对象。

参数：
name - 置标名称
返回：
置标属性信息对象，或者null，如果指定名称的属性不存在

addAttrInfo

public TagBeanAttrInfo addAttrInfo(TagBeanAttrInfo tbai)
添加置标属性信息对象，如果相同名称的置标属性信息对象已经存在，则将被替换，并返回。

参数：
tbai - 待添加的置标属性信息对象
返回：
原有的同名称的置标属性信息对象，或者null

checkSemantic

public void checkSemantic(IPublishFolder _folder,
                          TagItem _tagItem,
                          java.lang.StringBuffer _sbResult)
检查指定的置标实例的静态语义，如果有静态语义错误，则通过传入的StringBuffer对象返回错误信息。

参数：
_folder - 模板所属的目录，目前只可能是是站点
_tagItem - 指定的置标实例
_sbResult - [in/out]参数，如果有错，用于返回错误信息。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagBeanInfoHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagBeanInfoHelper

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagBeanInfoHelper

public final class TagBeanInfoHelper
extends java.lang.Object

TagBeanInfo的辅助类

作者：
Martin (付成睿)

方法摘要
static void checkChannelName(IPublishFolder _root, TagItem _tagItem, java.lang.StringBuffer _sbResult)
检查指定置标中使用的频道名称是否存在
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

checkChannelName

public static final void checkChannelName(IPublishFolder _root,
                                          TagItem _tagItem,
                                          java.lang.StringBuffer _sbResult)
检查指定置标中使用的频道名称是否存在

参数：
_root - 站点对象
_tagItem - 指定的置标
_sbResult - [in/out]参数，如果有错，用于返回错误信息。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagBeanLCListener

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagBeanLCListener

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagBeanLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class TagBeanLCListener
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
life cycel listener for TagBean.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagBeanLCListener()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagBeanLCListener

public TagBeanLCListener()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
另请参见：
com.trs.infra.persistent.listener.IObjectLCListener#notifyOnModifyObj(com.trs.infra.persistent.BaseObj)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagDocument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagDocument

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagDocument
所有已实现的接口：
org.aton.container.IClearable
public class TagDocument
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
the tag document for template DOM.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagDocument()
contructor: default
方法摘要
void | addItem(java.lang.String _str) add a string item
void | addItem(TagItem _item) add a TagItem item
void | clear()
java.util.Iterator | findItems(java.lang.String _sTagName)
java.lang.Object | getItemAt(int _index) get the item at the specified position.
int | getItemCount()
java.util.List | getItems()
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TagDocument

public TagDocument()
contructor: default

方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

getItems

public java.util.List getItems()
返回：
Returns the item list.

getItemCount

public int getItemCount()
返回：
Returns size of the items.

getItemAt

public java.lang.Object getItemAt(int _index)
get the item at the specified position.

参数：
_index - the item index.
返回：
Returns the item at the position.

addItem

public void addItem(TagItem _item)
add a TagItem item

参数：
_item - a TagItem item.

addItem

public void addItem(java.lang.String _str)
add a string item

参数：
_str - a string item.

findItems

public java.util.Iterator findItems(java.lang.String _sTagName)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagDocumentReader

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagDocumentReader

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagDocumentReader

public class TagDocumentReader
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Tag Document reader.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static boolean | IS_DEBUG debug modal switch
static int | ST_ATTRNAME status: on reading attribute name
static int | ST_ATTRNAME_END status: on attribute name end
static int | ST_ATTRVALUE_END status: on attribute value end
static int | ST_ATTRVALUE_HASQUOTE status: on reading attribute value having quote
static int | ST_ATTRVALUE_HASQUOTE_BEGIN status: on begining to read attribute value having quote
static int | ST_ATTRVALUE_HASQUOTE_ENDCHECK status: on to check attribute value end having quote
static int | ST_ATTRVALUE_NOQUOTE status: on reading attribute value with no quote
static int | ST_CHILD_BEGIN status: on begining to read a child
static int | ST_CHILD_STRING status: on reading String child
static int | ST_CHILD_STRING_END status: on a String child end
static int | ST_CHILD_TAGITEM status: on reading TagItem child
static int | ST_ENDTAG_CHECK status: on to check the endtag
static int | ST_SELFCLOSEDTAG_CHECK status: on to check the self-closed tag
static int | ST_STARTTAG_END status: on start-tag end
static int | ST_TAGNAME status: on reading tag name
static int | ST_TAGNAME_END status: on tag name end
方法摘要
static int | lookupNextStatus(int _nCurrentStatus, ScanContext sCtx) lookup the next status at the current condition.
static TagDocument | read(java.lang.String _text) read a tag document from the specified content.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_DEBUG

public static boolean IS_DEBUG
debug modal switch

ST_TAGNAME

public static final int ST_TAGNAME
status: on reading tag name

另请参见：
常量字段值

ST_TAGNAME_END

public static final int ST_TAGNAME_END
status: on tag name end

另请参见：
常量字段值

ST_ATTRNAME

public static final int ST_ATTRNAME
status: on reading attribute name

另请参见：
常量字段值

ST_ATTRNAME_END

public static final int ST_ATTRNAME_END
status: on attribute name end

另请参见：
常量字段值

ST_ATTRVALUE_HASQUOTE

public static final int ST_ATTRVALUE_HASQUOTE
status: on reading attribute value having quote

另请参见：
常量字段值

ST_ATTRVALUE_NOQUOTE

public static final int ST_ATTRVALUE_NOQUOTE
status: on reading attribute value with no quote

另请参见：
常量字段值

ST_ATTRVALUE_END

public static final int ST_ATTRVALUE_END
status: on attribute value end

另请参见：
常量字段值

ST_STARTTAG_END

public static final int ST_STARTTAG_END
status: on start-tag end

另请参见：
常量字段值

ST_CHILD_BEGIN

public static final int ST_CHILD_BEGIN
status: on begining to read a child

另请参见：
常量字段值

ST_CHILD_TAGITEM

public static final int ST_CHILD_TAGITEM
status: on reading TagItem child

另请参见：
常量字段值

ST_CHILD_STRING

public static final int ST_CHILD_STRING
status: on reading String child

另请参见：
常量字段值

ST_CHILD_STRING_END

public static final int ST_CHILD_STRING_END
status: on a String child end

另请参见：
常量字段值

ST_ENDTAG_CHECK

public static final int ST_ENDTAG_CHECK
status: on to check the endtag

另请参见：
常量字段值

ST_SELFCLOSEDTAG_CHECK

public static final int ST_SELFCLOSEDTAG_CHECK
status: on to check the self-closed tag

另请参见：
常量字段值

ST_ATTRVALUE_HASQUOTE_BEGIN

public static final int ST_ATTRVALUE_HASQUOTE_BEGIN
status: on begining to read attribute value having quote

另请参见：
常量字段值

ST_ATTRVALUE_HASQUOTE_ENDCHECK

public static final int ST_ATTRVALUE_HASQUOTE_ENDCHECK
status: on to check attribute value end having quote

另请参见：
常量字段值
方法详细信息

read

public static TagDocument read(java.lang.String _text)
                        throws java.lang.Exception
read a tag document from the specified content.

参数：
_text - the tag document content.
返回：
Returns the tag document read.
抛出：
java.lang.Exception - if failed to parse the document content.

lookupNextStatus

public static int lookupNextStatus(int _nCurrentStatus,
                                   ScanContext sCtx)
                            throws java.lang.Exception
lookup the next status at the current condition.

参数：
_nCurrentStatus - the current status.
_chars - the text characters.
_nPos - the current position in the characters.
返回：
Returns the next status if found.
抛出：
java.lang.Exception - if no route is defined for the current status.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagDocumentScanner

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagDocumentScanner

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagDocumentScanner

public final class TagDocumentScanner
extends java.lang.Object

模板正文的文法分析器

作者：
Martin (付成睿)

构造方法摘要
TagDocumentScanner()
方法摘要
static TagDocumentScanner | newScanner()
TagDocument | scan(java.lang.String _text)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagDocumentScanner

public TagDocumentScanner()
方法详细信息

newScanner

public static final TagDocumentScanner newScanner()

scan

public TagDocument scan(java.lang.String _text)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagFormatHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagFormatHelper

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagFormatHelper

public class TagFormatHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
helper for tag format
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static ITagFormatter | getFormatter(java.lang.String _sTagName) Returns the tag formmater of the specified tag.
static TagFormatHelper | getInstance() Returns the tag formmater helper instance.
void | refresh() Refreshs the tag formatters config.
static void | standardize(TagItem _item) Standardizes a specified tag item with the formatter configurated.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getInstance

public static TagFormatHelper getInstance()
                                   throws WCMException
Returns the tag formmater helper instance.

返回：
the tag formmater helper instance.
抛出：
WCMException - if failed to load the config.

refresh

public void refresh()
             throws WCMException
Refreshs the tag formatters config.

抛出：
WCMException - if failed to load the config.

getFormatter

public static ITagFormatter getFormatter(java.lang.String _sTagName)
                                  throws WCMException
Returns the tag formmater of the specified tag.

参数：
_sTagName - tag name
返回：
the tag formmater of the specified tag.
抛出：
WCMException - if failed to load the config.

standardize

public static void standardize(TagItem _item)
                        throws WCMException
Standardizes a specified tag item with the formatter configurated.

参数：
_item - a tag item
抛出：
WCMException - if failed to format.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagItem

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagItem

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagItem
所有已实现的接口：
org.aton.container.IClearable
public class TagItem
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagItem()
constructor: default
方法摘要
void | addChild(java.lang.String _child) add a string child
void | addChild(TagItem _child) add a TagItem child
void | clear()
boolean | containsChild(java.lang.String _sName) Returns true if this tag contains a child with the specified name; false, otherwise.
java.util.Iterator | findItems(java.lang.String[] itemNames) 从子节点(TagItem)开始往下找指定名称的节点 如果没有指定名称,则应该返回所有子孙节点
java.util.List | findParentItems() 获取祖先tagitems列表 从父元素开始回溯,直到第一个父元素结束
java.lang.String | getAttribute(java.lang.String _sName) get a attribute value
java.util.HashMap | getAttributes()
java.lang.String | getAttributeTrim(java.lang.String _sName) get the timmed value of a attribute
int | getBeginColumn() 返回置标的开始位置在模板正文中的列号
int | getBeginLineNo() 返回置标的开始位置在模板正文中的行号
boolean | getBooleanAttribute(java.lang.String _sName, boolean _bDefault) get the boolean attribute value
java.util.List | getChildren()
int | getCloseColumn() 返回置标的结束位置在模板正文中的列号
int | getCloseLineNo() 返回置标的结束位置在模板正文中的行号
java.lang.String | getDescWithPos() 返回置标的名称并附加上置标的开始位置在模板正文中的行和列信息的字符串描述
java.lang.String | getExtraAttributeValue(java.lang.String _sAttrName)
int | getIntAttribute(java.lang.String _sName, int _nDefault) get the integer attribute value
java.lang.String | getName()
TagItem | getParent() 获取父tagitem
java.lang.String | getRequiredAttribute(java.lang.String _sName) get a required attribute value
java.lang.String | getRequiredAttributeTrim(java.lang.String _sName) get the trimmed value of a required attribute.
java.lang.String | getText() Returns the first child if it is a string.
TemplateParameter | getVariableParameter(java.lang.String _sName) 返回指定名称的可变模板参数对象
java.util.HashMap | getVariableParameters() 以java.util.HashMap的形式返回所有的可变模板参数
boolean | hasChildren() Returns true if this tag item has children; false, otherwise.
static boolean | isVariableDeclare(java.lang.String _sTagName) 判断指定的置标名称是不是变量声名
static boolean | isVariableParameter(java.lang.String _sValue) 判断指定的值是不是模板变量
java.lang.String | removeAttribute(java.lang.String _sName) Removes a specified attribute and returns the old value if the attribute is removed.
void | setAttribute(java.lang.String _sName, boolean _bValue) Sets the value of a boolean property.
void | setAttribute(java.lang.String _sName, int _nValue) Sets the value of a attribute
void | setAttribute(java.lang.String _sName, java.lang.String _sValue) Sets the value of a attribute
void | setAttributes(java.util.HashMap _attributes)
void | setBeginColumn(int beginColumn) 设置置标的开始位置在模板正文中的列号
void | setBeginLineNo(int beginLineNo) 设置置标的开始位置在模板正文中的行号
void | setChildren(java.util.List _children)
void | setCloseColumn(int closeColumn) 设置置标的结束位置在模板正文中的列号
void | setCloseLineNo(int closeLineNo) 设置置标的结束位置在模板正文中的行号
void | setExtraAttribute(java.lang.String _sAttrName, java.lang.String _sValue) 设置置标的扩展属性(非置标原有属性，为逻辑属性)
void | setName(java.lang.String name)
void | setParent(TagItem _parentItem) 设置父tagitem
java.lang.String | setText(java.lang.String sNewValue) Returns the first child if it is a string.
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TagItem

public TagItem()
constructor: default

方法详细信息

isVariableParameter

public static final boolean isVariableParameter(java.lang.String _sValue)
判断指定的值是不是模板变量

isVariableDeclare

public static final boolean isVariableDeclare(java.lang.String _sTagName)
判断指定的置标名称是不是变量声名

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

getName

public java.lang.String getName()
返回：
Returns the tag name.

setName

public void setName(java.lang.String name)
参数：
name - the tag name.

getAttributes

public java.util.HashMap getAttributes()
返回：
Returns all the attributes.

getAttribute

public java.lang.String getAttribute(java.lang.String _sName)
get a attribute value

参数：
_sName - the attribute name
返回：
Returns the attribute value if found;
otherwise, returns null.

getAttributeTrim

public java.lang.String getAttributeTrim(java.lang.String _sName)
get the timmed value of a attribute

参数：
_sName - the attribute name.
返回：
Returns the trimmed value of the attribute if found;
otherwise, returns null.

getRequiredAttribute

public java.lang.String getRequiredAttribute(java.lang.String _sName)
                                      throws WCMException
get a required attribute value

参数：
_sName - the attribute name
返回：
Returns the attribute value.
抛出：
WCMException - if the attribute is not found.

getRequiredAttributeTrim

public java.lang.String getRequiredAttributeTrim(java.lang.String _sName)
                                          throws WCMException
get the trimmed value of a required attribute.

参数：
_sName - the attribute name.
返回：
Returns the trimmed value of the attribute if found.
抛出：
WCMException - if the attribute is not found or empty.

getIntAttribute

public int getIntAttribute(java.lang.String _sName,
                           int _nDefault)
                    throws WCMException
get the integer attribute value

参数：
_sName - the attribute name.
_nDefault - default value if the attribute value is not set.
返回：
Returns the integer value of the attribute.
抛出：
WCMException - if the attribute value is not integer.

getBooleanAttribute

public boolean getBooleanAttribute(java.lang.String _sName,
                                   boolean _bDefault)
get the boolean attribute value

参数：
_sName - the attribute name
_bDefault - the default value if the attribute is not found.
返回：
Returns the boolean value of the attribute if found;
otherwise, returns the default value.

setAttributes

public void setAttributes(java.util.HashMap _attributes)
参数：
_attributes - the attributes collection.

setAttribute

public void setAttribute(java.lang.String _sName,
                         java.lang.String _sValue)
                  throws WCMException
Sets the value of a attribute

参数：
_sName - the attribute name
_sValue - the attribute value.
抛出：
WCMException - if the attribute name is not specified.

setAttribute

public void setAttribute(java.lang.String _sName,
                         int _nValue)
                  throws WCMException
Sets the value of a attribute

参数：
_sName - the attribute name
_nValue - the attribute value.
抛出：
WCMException - if the attribute name is not specified.

setAttribute

public void setAttribute(java.lang.String _sName,
                         boolean _bValue)
                  throws WCMException
Sets the value of a boolean property.

参数：
_sName - the property name.
_bValue - the property value.
抛出：
WCMException - if failed to write attribute value.

removeAttribute

public java.lang.String removeAttribute(java.lang.String _sName)
Removes a specified attribute and returns the old value if the attribute is removed.

参数：
_sName - the attribute name
返回：
the old value if the attribute is found and removed.

getChildren

public java.util.List getChildren()
返回：
Returns the children list.

hasChildren

public boolean hasChildren()
Returns true if this tag item has children; false, otherwise.

返回：
true if this tag item has children; false, otherwise.

containsChild

public boolean containsChild(java.lang.String _sName)
Returns true if this tag contains a child with the specified name; false, otherwise.

参数：
_sName - the child tag name
返回：
true if this tag contains a child with the specified name; false, otherwise.

getText

public java.lang.String getText()
Returns the first child if it is a string.

返回：
the first child if it is a string; otherwise, return null

setText

public java.lang.String setText(java.lang.String sNewValue)
Returns the first child if it is a string.

返回：
the first child if it is a string; otherwise, return null

setChildren

public void setChildren(java.util.List _children)
参数：
_children - the children list.

addChild

public void addChild(TagItem _child)
add a TagItem child

参数：
_child - the child

addChild

public void addChild(java.lang.String _child)
add a string child

参数：
_child - the child

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
另请参见：
Object.toString()

getBeginColumn

public int getBeginColumn()
返回置标的开始位置在模板正文中的列号

返回：
置标的开始位置在模板正文中的列号

setBeginColumn

public void setBeginColumn(int beginColumn)
设置置标的开始位置在模板正文中的列号

参数：
置标的开始位置在模板正文中的列号 -

getBeginLineNo

public int getBeginLineNo()
返回置标的开始位置在模板正文中的行号

返回：
置标的开始位置在模板正文中的行号

setBeginLineNo

public void setBeginLineNo(int beginLineNo)
设置置标的开始位置在模板正文中的行号

参数：
置标的开始位置在模板正文中的行号 -

getCloseColumn

public int getCloseColumn()
返回置标的结束位置在模板正文中的列号

返回：
置标的结束位置在模板正文中的列号

setCloseColumn

public void setCloseColumn(int closeColumn)
设置置标的结束位置在模板正文中的列号

参数：
置标的结束位置在模板正文中的列号 -

getCloseLineNo

public int getCloseLineNo()
返回置标的结束位置在模板正文中的行号

返回：
置标的结束位置在模板正文中的行号

setCloseLineNo

public void setCloseLineNo(int closeLineNo)
设置置标的结束位置在模板正文中的行号

参数：
置标的结束位置在模板正文中的行号 -

getDescWithPos

public java.lang.String getDescWithPos()
返回置标的名称并附加上置标的开始位置在模板正文中的行和列信息的字符串描述

返回：
置标的名称并附加上置标的开始位置在模板正文中的行和列信息的字符串描述

setExtraAttribute

public void setExtraAttribute(java.lang.String _sAttrName,
                              java.lang.String _sValue)
设置置标的扩展属性(非置标原有属性，为逻辑属性)

参数：
_sAttrName -
_sValue -

getExtraAttributeValue

public java.lang.String getExtraAttributeValue(java.lang.String _sAttrName)
参数：
_sAttrName -
返回：

getVariableParameters

public java.util.HashMap getVariableParameters()
以java.util.HashMap的形式返回所有的可变模板参数

返回：
所有的可变模板参数

getVariableParameter

public TemplateParameter getVariableParameter(java.lang.String _sName)
返回指定名称的可变模板参数对象

返回：
可变模板参数对象或者null

findItems

public java.util.Iterator findItems(java.lang.String[] itemNames)
从子节点(TagItem)开始往下找指定名称的节点 如果没有指定名称,则应该返回所有子孙节点

参数：
itemNames - 指定的节点名称
返回：

setParent

public void setParent(TagItem _parentItem)
设置父tagitem

参数：
_parentItem -

getParent

public TagItem getParent()
获取父tagitem

返回：

findParentItems

public java.util.List findParentItems()
获取祖先tagitems列表 从父元素开始回溯,直到第一个父元素结束

返回：
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParseHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParseHelper

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParseHelper

public class TagParseHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
helper for tag parsing
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | AUTOFORMATTYPE_HTML
static int | AUTOFORMATTYPE_HTMLVALUE
static int | AUTOFORMATTYPE_JAVASCRIPT
static int | AUTOFORMATTYPE_XML
方法摘要
static java.lang.String addAutoLink(java.lang.String _sUrl, java.lang.String _sValue, java.lang.String _sDefaultAltText, PublishTagContext _context)
生成带有链接的HTML文本
static java.lang.String addSpanStyleIfNeeded(PublishTagContext _context, java.lang.String _sText)
如果有必要在文本外面套上
static java.lang.String[] addSpanStyleIfNeeded(PublishTagContext _context, java.lang.String[] results)
如果有必要在文本外面套上 <span class="CLASSNAME">xxx</span>
static void distributionHTMLContentFiles(IPublishContent _content, PublishTagContext _context, java.util.List _listFiles)
static Template findNestedTemplate(PublishTagContext _context)
Returns the template defined in the specified nested template tag item.
static Template findNestedTemplate(java.lang.String sTempName, IPublishFolder _root)
Returns the template defined in the specified nested template tag item.
static Template findNestedTemplate(TagItem _tagItem, IPublishFolder _root)
已过时。 Returns the template defined in the specified nested template tag item.
static java.lang.String formatTextIfNeeded(PublishTagContext _context, java.lang.String _sText)
Formats the text if AUTOFORMAT=true.
static java.lang.String formatTextIfNeeded(TagItem _currItem, java.lang.String _sText)
已过时。 Formats the text if AUTOFORMAT=true.
Related tag attributes: AUTOFORMAT, AUTOFORMATTYPE
static boolean isVisualParseMode(PublishTagContext context)
判断当前是否为可视化设计模式
static void main(java.lang.String[] args)
static java.util.ArrayList makeSelectFields(TagItem _item, java.lang.String _sContentTagName)
static java.lang.String[] parse4Children(TagItem _tagItem, PublishTagContext _tagContext)
static java.lang.String[] parse4List(PublishTagContext _tagContext, ITagParser4List _parser4List)
static java.lang.String[] parse4List(TagItem _tagItem, PublishTagContext _tagContext, ITagParser4List _parser4List)
Parses objects list tag, eg.
static java.lang.String[] parseContent(IPublishElement _pageElement, java.lang.String _sTemplateContent)
static java.lang.String[] parseContent(IPublishElement _pageElement, java.lang.String _sTemplateContent, java.lang.String _sParseType)
将一旦包含置标的文本解析
static java.lang.String parseDateFormat(java.lang.String _sFormat)
Parses a date format string.
static java.lang.String[] parseHtmlContent(java.lang.String _sHtmlContent, IPublishContent _content, PublishTagContext _context)
static java.lang.String[] parseItem(TagItem _item, PublishTagContext _context)
Parses a tag item and returns the results which may be more than one.
static java.lang.String[] parseItems(java.util.List _items, PublishTagContext _context)
Parses the tag items list and return the results which may be more than one.
static java.lang.String[] separatePages(java.lang.String _sText)
Separate pages from the specified text
static java.lang.String[] separatePagesOld(java.lang.String _sText)
已过时。
static TagItem strToTagItem(java.lang.String _sText)
Converts a string to TagItem.
static java.lang.String truncateTextIfNeeded(PublishTagContext _context, java.lang.String _sText)
Truncates the text length if needed (when NUM>0).
static java.lang.String truncateTextIfNeeded(TagItem _currItem, java.lang.String _sText)
已过时。 Truncates the text length if needed (when NUM>0).
Related properties in tag item: NUM, TRUNCATEDFLAG
if NUM>0, to truncate the text with the flag as tail.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

AUTOFORMATTYPE_HTML

public static final int AUTOFORMATTYPE_HTML
另请参见：
常量字段值

AUTOFORMATTYPE_HTMLVALUE

public static final int AUTOFORMATTYPE_HTMLVALUE
另请参见：
常量字段值

AUTOFORMATTYPE_JAVASCRIPT

public static final int AUTOFORMATTYPE_JAVASCRIPT
另请参见：
常量字段值

AUTOFORMATTYPE_XML

public static final int AUTOFORMATTYPE_XML
另请参见：
常量字段值
方法详细信息

strToTagItem

public static TagItem strToTagItem(java.lang.String _sText)
                            throws java.lang.Exception
Converts a string to TagItem.

参数：
_sText - a string text
返回：
the first tag item readed from text.
抛出：
java.lang.Exception - if the text is not according to the tag item grammer.

parseItem

public static java.lang.String[] parseItem(TagItem _item,
                                           PublishTagContext _context)
                                    throws WCMException
Parses a tag item and returns the results which may be more than one.

参数：
_item - the tag item to parse
_context - context to parse the tag item.
返回：
the parsed results which may be more than one.
抛出：
java.lang.Exception - if failed to parse the tag item.
WCMException

parseItems

public static java.lang.String[] parseItems(java.util.List _items,
                                            PublishTagContext _context)
                                     throws WCMException
Parses the tag items list and return the results which may be more than one.

参数：
_items - tag items list to parse
_context - tag item parse context
返回：
the parse result which may be more than one.
抛出：
java.lang.Exception - if failed to parse the items.
WCMException

parseDateFormat

public static java.lang.String parseDateFormat(java.lang.String _sFormat)
Parses a date format string.
Grammer :
[1] %Y --> yyyy
[2] %MON --> MM
[3] %m --> MM
[4] %DAY --> dd
[5] %d --> dd
[6] %H --> HH
[7] %M --> mm
[8] %S --> ss

参数：
_sFormat - a date format string
返回：
the parsed result which is a standard format of java date.

separatePagesOld

public static java.lang.String[] separatePagesOld(java.lang.String _sText)
已过时。

参数：
_sText -
返回：

separatePages

public static java.lang.String[] separatePages(java.lang.String _sText)
Separate pages from the specified text

参数：
_sText - the specified text
返回：
the pages array

truncateTextIfNeeded

public static java.lang.String truncateTextIfNeeded(TagItem _currItem,
                                                    java.lang.String _sText)
                                             throws WCMException
已过时。 Truncates the text length if needed (when NUM>0).
Related properties in tag item: NUM, TRUNCATEDFLAG
if NUM>0, to truncate the text with the flag as tail.

参数：
_currItem - the current TagItem
返回：
the formated result
抛出：
WcMException - if failed to format the string.
WCMException

truncateTextIfNeeded

public static java.lang.String truncateTextIfNeeded(PublishTagContext _context,
                                                    java.lang.String _sText)
                                             throws WCMException
Truncates the text length if needed (when NUM>0).
Related properties in tag item: NUM, TRUNCATEDFLAG
if NUM>0, to truncate the text with the flag as tail.

参数：
_currItem - the current TagItem
返回：
the formated result
抛出：
WcMException - if failed to format the string.
WCMException

formatTextIfNeeded

public static java.lang.String formatTextIfNeeded(TagItem _currItem,
                                                  java.lang.String _sText)
已过时。 Formats the text if AUTOFORMAT=true.
Related tag attributes: AUTOFORMAT, AUTOFORMATTYPE

参数：
_currItem - current tag item.
_sText - the text to format.
返回：
the formated result.

formatTextIfNeeded

public static java.lang.String formatTextIfNeeded(PublishTagContext _context,
                                                  java.lang.String _sText)
Formats the text if AUTOFORMAT=true.
Related tag attributes: AUTOFORMAT, AUTOFORMATTYPE

参数：
_currItem - current tag item.
_sText - the text to format.
返回：
the formated result.

findNestedTemplate

public static Template findNestedTemplate(PublishTagContext _context)
                                   throws WCMException
Returns the template defined in the specified nested template tag item.

参数：
_context - a nested template PublishTagContext.
返回：
the template defined in the specified nested template tag item.
抛出：
WCMException - if the tag item is illegal or failed to find the template.

findNestedTemplate

public static Template findNestedTemplate(TagItem _tagItem,
                                          IPublishFolder _root)
                                   throws WCMException
已过时。 Returns the template defined in the specified nested template tag item.

参数：
_tagItem - a nested template tag item.
_root - the folder root where the template lies.
返回：
the template defined in the specified nested template tag item.
抛出：
WCMException - if the tag item is illegal or failed to find the template.

findNestedTemplate

public static Template findNestedTemplate(java.lang.String sTempName,
                                          IPublishFolder _root)
                                   throws WCMException
Returns the template defined in the specified nested template tag item.

参数：
sTempName - the nested template name.
_root - the folder root where the template lies.
返回：
the template defined in the specified nested template tag item.
抛出：
WCMException - if the tag item is illegal or failed to find the template.

parse4List

public static java.lang.String[] parse4List(PublishTagContext _tagContext,
                                            ITagParser4List _parser4List)
                                     throws WCMException
抛出：
WCMException

parse4List

public static java.lang.String[] parse4List(TagItem _tagItem,
                                            PublishTagContext _tagContext,
                                            ITagParser4List _parser4List)
                                     throws WCMException
Parses objects list tag, eg. TRS_OUTLINE, TRS_CHANNELS, etc.

参数：
_tagItem - tag item to parse.
_parser4List - an IParser4List implementation.
_tagContext - tag parse context.
返回：
the parsed results which may be more than one.
抛出：
java.lang.Exception - if failed to parse the tag item.
WCMException

parse4Children

public static java.lang.String[] parse4Children(TagItem _tagItem,
                                                PublishTagContext _tagContext)
                                         throws WCMException
抛出：
WCMException

makeSelectFields

public static java.util.ArrayList makeSelectFields(TagItem _item,
                                                   java.lang.String _sContentTagName)

addAutoLink

public static java.lang.String addAutoLink(java.lang.String _sUrl,
                                           java.lang.String _sValue,
                                           java.lang.String _sDefaultAltText,
                                           PublishTagContext _context)
生成带有链接的HTML文本

参数：
_sUrl - 链接地址，是已经做好相对路径计算的相对地址，或者是不需要计算的绝对路径
_sValue - 链接上的文本
_sDefaultAltText - 缺省的"ALT"字符串
_context - 上下文环境
返回：
添加链接地址之后的HTML正文
抛出：
WCMException - 如果发生错误

addSpanStyleIfNeeded

public static java.lang.String addSpanStyleIfNeeded(PublishTagContext _context,
                                                    java.lang.String _sText)
如果有必要在文本外面套上

addSpanStyleIfNeeded

public static java.lang.String[] addSpanStyleIfNeeded(PublishTagContext _context,
                                                      java.lang.String[] results)
如果有必要在文本外面套上
<span class="CLASSNAME">xxx</span>

parseHtmlContent

public static java.lang.String[] parseHtmlContent(java.lang.String _sHtmlContent,
                                                  IPublishContent _content,
                                                  PublishTagContext _context)
                                           throws WCMException
抛出：
WCMException

distributionHTMLContentFiles

public static void distributionHTMLContentFiles(IPublishContent _content,
                                                PublishTagContext _context,
                                                java.util.List _listFiles)
                                         throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)

parseContent

public static java.lang.String[] parseContent(IPublishElement _pageElement,
                                              java.lang.String _sTemplateContent)
                                       throws java.lang.Exception
抛出：
java.lang.Exception

isVisualParseMode

public static boolean isVisualParseMode(PublishTagContext context)
判断当前是否为可视化设计模式

参数：
context -
返回：

parseContent

public static java.lang.String[] parseContent(IPublishElement _pageElement,
                                              java.lang.String _sTemplateContent,
                                              java.lang.String _sParseType)
                                       throws java.lang.Exception
将一旦包含置标的文本解析

参数：
_pageElement - 文本所处的页面对象
_sTemplateContent - 包含置标的文本
_sParseType - 解析的模式，定义在 PublishConstants中，例如PublishConstants.PARSE_MODE_NORM
返回：
抛出：
java.lang.Exception
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserCMSObj

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserCMSObj

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObj
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserCMSObj
extends TagParserCMSObjBase

Title: TRS 内容协作平台（TRS WCM）
Description:
default implementation for CMSObj tag parser.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParserCMSObj()
constructor: default
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserCMSObj

public TagParserCMSObj()
constructor: default

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserCMSObjBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserCMSObjBase

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
所有已实现的接口：
ITagParser, org.aton.container.IClearable
直接已知子类：
TagParserCMSObj, TagParserContentBase, TagParserFolderBase, TagParserUser, WCMTagParserDocReply
public abstract class TagParserCMSObjBase
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
parser implementation base for CMSObj tag.

 Tag format:
<TRS_CMSOBJNAME ID="字段名"[NUM="最大长度"
 [TRUNCATEDFLAG="长度裁减标记"]]
 [DATEFORMAT="日期格式"][AUTOFORMAT="自动格式化"]
[AUTOLINK="是否自动产生链接" [TARGET="窗口目标"]
 [EXTRA="扩展HTML内容"] [LINKALT="是否显示链接提示信息"]
 [LINKALTTEXT="链接提示信息文本"]] ></TRS_CMSOBJNAME>

Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParserCMSObjBase()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.domain.tagparser.ITagParser 继承的方法
getBeanInfo

构造方法详细信息

TagParserCMSObjBase

public TagParserCMSObjBase()
方法详细信息

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.
另请参见：
ITagParser.setTagItem(TagItem)

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
另请参见：
ITagParser.analyzeQuotes(IPublishFolder)

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.parse(PublishTagContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserCondition

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserCondition

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCondition
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserCondition
extends java.lang.Object
implements ITagParser

条件执行置标，如果指定的条件为真，则继续执行解析该置标下的模板，如果指定的条件为假，则忽略其下的模板。

作者：
Martin (付成睿)

嵌套类摘要
static class TagParserCondition.Operator
比较运算符的抽象
构造方法摘要
TagParserCondition()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserCondition

public TagParserCondition()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserCondition.Operator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserCondition.Operator

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCondition.Operator
包容类：
TagParserCondition
public abstract static class TagParserCondition.Operator
extends java.lang.Object

比较运算符的抽象

构造方法摘要
TagParserCondition.Operator()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserCondition.Operator

public TagParserCondition.Operator()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserContentBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserContentBase

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserContentBase
所有已实现的接口：
ITagParser, org.aton.container.IClearable
直接已知子类：
TagParserDetailPage, WCMTagParserDocument, WCMTagParserViewData, WCMTagParserViewField, WCMTagParserXDocument
public abstract class TagParserContentBase
extends TagParserCMSObjBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParserContentBase()
方法摘要
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.domain.tagparser.ITagParser 继承的方法
getBeanInfo

构造方法详细信息

TagParserContentBase

public TagParserContentBase()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserDateTime

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserDateTime

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserDateTime
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserDateTime
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
Tag Parser For TRS_DATETIME
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParserDateTime()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserDateTime

public TagParserDateTime()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserDefaultObjects

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserDefaultObjects

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects
                继承者  com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
直接已知子类：
WCMTagParserDefaultObjectsInChannelBase
public class TagParserDefaultObjects
extends BaseTagParserDefaultObjects

Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParserDefaultObjects()
方法摘要
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserDefaultObjects

public TagParserDefaultObjects()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserDetailPage

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserDetailPage

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserContentBase
            继承者  com.trs.components.common.publish.domain.tagparser.TagParserDetailPage
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserDetailPage
extends TagParserContentBase

作者：
micah

构造方法摘要
TagParserDetailPage()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserDetailPage

public TagParserDetailPage()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserDetailPages

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserDetailPages

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.common.publish.domain.tagparser.TagParserDetailPages
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class TagParserDetailPages
extends BaseTagParser4List

作者：
micah

构造方法摘要
TagParserDetailPages()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | separatePages(PublishTagContext _context, java.lang.String _sText)
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserDetailPages

public TagParserDetailPages()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

separatePages

public java.lang.String[] separatePages(PublishTagContext _context,
                                        java.lang.String _sText)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserEcho

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserEcho

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserEcho
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserEcho
extends java.lang.Object
implements ITagParser

用于输出指定的内容到生成的文件中，在和模板变量配合使用时才有意义。 有唯一的置标属性“VALUE”，在解析模板时，使用“VALUE”指定的内容 输出到HTML中替换该置标。

作者：
Martin (付成睿)

构造方法摘要
TagParserEcho()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserEcho

public TagParserEcho()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParseResults

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParseResults

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParseResults
所有已实现的接口：
org.aton.container.IClearable
public class TagParseResults
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse result
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParseResults()
constructor: default
方法摘要
TagParseResults | append(java.lang.String _sResult) Appends a string to each of current results
TagParseResults | append(java.lang.String[] _results) Appends the product of the specified results and current results.
void | clear()
java.lang.String | get(int _index) Returns the parse result at the specified position.
int | size() Returns the number of parsed results.
java.lang.String[] | toStrArray() Returns the parsed result as string array
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParseResults

public TagParseResults()
constructor: default

方法详细信息

size

public int size()
Returns the number of parsed results.

返回：
the number of parsed results

get

public java.lang.String get(int _index)
Returns the parse result at the specified position.

参数：
_index - the result position
返回：
the parse result at the specified position

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

toStrArray

public java.lang.String[] toStrArray()
Returns the parsed result as string array

返回：
the parsed result as string array

append

public TagParseResults append(java.lang.String _sResult)
Appends a string to each of current results

参数：
_sResult - a result to append
返回：
this parse results.

append

public TagParseResults append(java.lang.String[] _results)
                       throws WCMException
Appends the product of the specified results and current results.

参数：
_results - a result list to append
返回：
this parse results.
抛出：
java.lang.Exception - if failed.
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserFactory

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserFactory
所有已实现的接口：
org.aton.container.IClearable
public class TagParserFactory
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser factory.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | clear()
static ITagParser | createParserByName(java.lang.String _sTagName) Creates a parser instance for the specified tag.
java.lang.Class | getTagParserClass(java.lang.String _sTagName) Returns the parser class of the specified tag.
static boolean | isNestedTemplateTag(java.lang.String _sName) Returns true if the specified tag is nested template.
static void | notifyOnTagBeanAdded(TagBean _newBean) Updates cache when a new tag bean is created.
static void | notifyOnTagBeanDeleted(TagBean _bean) Removes cache when a tag bean is deleted.
static void | notifyOnTagBeanModified(TagBean _bean) Updates cache when a tag bean is modified.
void | refresh() Refreshs the cache in factory.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

refresh

public void refresh()
             throws WCMException
Refreshs the cache in factory.

抛出：
WCMException - if failed to load the tab beans.

getTagParserClass

public java.lang.Class getTagParserClass(java.lang.String _sTagName)
Returns the parser class of the specified tag.

参数：
_sTagName - name of the tag.
返回：
the parser class of the specified tag.

isNestedTemplateTag

public static boolean isNestedTemplateTag(java.lang.String _sName)
Returns true if the specified tag is nested template.

参数：
_sName - name of the specified tag
返回：
true if the specified tag is nested template.

createParserByName

public static ITagParser createParserByName(java.lang.String _sTagName)
                                     throws WCMException
Creates a parser instance for the specified tag.

参数：
_sTagName - name of the tag.
返回：
a tag parser instance.
抛出：
java.lang.Exception - if the tag is not supported or fails to create new parser instance.
WCMException

notifyOnTagBeanAdded

public static void notifyOnTagBeanAdded(TagBean _newBean)
                                 throws WCMException
Updates cache when a new tag bean is created.

参数：
_newBean - the new tag bean created
抛出：
WCMException - if failed to push the tag bean into cache.

notifyOnTagBeanDeleted

public static void notifyOnTagBeanDeleted(TagBean _bean)
                                   throws WCMException
Removes cache when a tag bean is deleted.

参数：
_bean - the tag bean which is deleted
抛出：
WCMException - if failed to remove the tag bean from cache.

notifyOnTagBeanModified

public static void notifyOnTagBeanModified(TagBean _bean)
                                    throws WCMException
Updates cache when a tag bean is modified.

参数：
_bean - the modified tag bean
抛出：
WCMException - if failed to update the cache.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserFolderBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserFolderBase

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
所有已实现的接口：
ITagParser, org.aton.container.IClearable
直接已知子类：
WCMTagParserChannel, WCMTagParserClassInfo, WCMTagParserWebSite
public abstract class TagParserFolderBase
extends TagParserCMSObjBase

Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParserFolderBase()
方法摘要
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.domain.tagparser.ITagParser 继承的方法
getBeanInfo

构造方法详细信息

TagParserFolderBase

public TagParserFolderBase()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserNestedTemplate

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserNestedTemplate

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserNestedTemplate
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for nested template.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParserNestedTemplate()
constructor: default
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserNestedTemplate

public TagParserNestedTemplate()
constructor: default

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.
另请参见：
ITagParser.setTagItem(TagItem)

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
另请参见：
ITagParser.analyzeQuotes(IPublishFolder)

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.parse(PublishTagContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserNewIcon

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserNewIcon

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserNewIcon
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserNewIcon
extends java.lang.Object
implements ITagParser

该置标为比较新的文档（也可以是其他对象）增加是新文档的标志。 有如下的两个置标属性

示例: 上面的置标的含义是，如果当前对象的创建时间(CRTIME)是在距离当前时间的一天以内， 就会输出新对象的标志 [image] ，如果创建时间不是在一天以内， 则不输出任何东西。 置标属性TIME的详细解释
属性名 | 缺省值 | 描述
FIELD | CRTIME | 取当前对象的哪一个时间字段，缺省为CRTIME，即创建时间
TIME | day | 从当前时间(发布的时间)算起，回退多长时间内的对象需要添加新对象的标志
取值 | 描述
day | 指定的时间在当天
week | 指定的时间在当周
month | 指定的时间在当月
m | 指定的时间在当前时间回退多少分钟内
h | 指定的时间在当前时间回退多少小时内
d | 指定的时间在当前时间回退多少天内
w | 指定的时间在当前时间回退多少天内
特殊情况下的行为定义 1.如果指定的时间字段不存在，则不输出任何内容。 2.如果当前对象的指定属性时间发生在当前时间之后，则认为系统错误不输出任何内容。

作者：
Martin (付成睿)

构造方法摘要
TagParserNewIcon()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserNewIcon

public TagParserNewIcon()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserOddOrEven

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserOddOrEven

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserOddOrEven
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
奇偶然样式置标
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wenyh

构造方法摘要
TagParserOddOrEven()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserOddOrEven

public TagParserOddOrEven()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserOnlyLogic

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserOnlyLogic

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserOnlyLogic
extends java.lang.Object
implements ITagParser

作者：
Administrator

构造方法摘要
TagParserOnlyLogic()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserOnlyLogic

public TagParserOnlyLogic()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserPageNav4Detail

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserPageNav4Detail

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserPageNav4Detail
extends java.lang.Object
implements ITagParser

作者：
huxuanlai

构造方法摘要
TagParserPageNav4Detail()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
java.lang.String[] | separatePages(PublishTagContext _context, java.lang.String _sText)
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserPageNav4Detail

public TagParserPageNav4Detail()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

separatePages

public java.lang.String[] separatePages(PublishTagContext _context,
                                        java.lang.String _sText)

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserRepeat

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserRepeat

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserRepeat
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserRepeat
extends java.lang.Object
implements ITagParser

TODO javadoc for com.trs.components.common.publish.domain.tagparser.TagParserRepeat

作者：
Martin (付成睿)

构造方法摘要
TagParserRepeat()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _tagContext) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserRepeat

public TagParserRepeat()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _tagContext)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_tagContext - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserSequenceNumber

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserSequenceNumber

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserSequenceNumber
extends java.lang.Object
implements ITagParser

构造方法摘要
TagParserSequenceNumber()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserSequenceNumber

public TagParserSequenceNumber()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserSystemConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserSystemConfig

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserSystemConfig
extends java.lang.Object
implements ITagParser

返回配置的属性字段的值

作者：
huxiejin

构造方法摘要
TagParserSystemConfig()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _s_root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _s_item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserSystemConfig

public TagParserSystemConfig()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _s_root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_s_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _s_item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_s_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserUnimpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserUnimpl

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserUnimpl
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserUnimpl
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagParserUnimpl()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserUnimpl

public TagParserUnimpl()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserUser

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserUser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserUser
extends TagParserCMSObjBase

构造方法摘要
TagParserUser()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserUser

public TagParserUser()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserVariable

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserVariable

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserVariable
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserVariable
extends java.lang.Object
implements ITagParser

用于在使用变量前，进行变量的声明。

作者：
Martin (付成睿)

构造方法摘要
TagParserVariable()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserVariable

public TagParserVariable()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserVariableEnum

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserVariableEnum

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserVariableEnum
extends java.lang.Object
implements ITagParser

在声明变量时，枚举变量的可用值

作者：
Martin (付成睿)

构造方法摘要
TagParserVariableEnum()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserVariableEnum

public TagParserVariableEnum()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserVariableSet

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TagParserVariableSet

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserVariableSet
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserVariableSet
extends java.lang.Object
implements ITagParser

给模板变量赋值的置标，一般情况下所赋之值来自其子置标的解析结果

作者：
Martin (付成睿)

构造方法摘要
TagParserVariableSet()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserVariableSet

public TagParserVariableSet()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParameter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TemplateParameter

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TemplateParameter

public class TemplateParameter
extends java.lang.Object

描述模板置标中的形式参数 因为按照目前的设计，置标中的形式参数不保存到数据库，而是解析后存在于缓存中，所以没有把该类放在包 “com.trs.components.common.publish.persistent.template”中。

作者：
Martin (付成睿)

嵌套类摘要
static class | TemplateParameter.Token 形式参数的候选值
static class | TemplateParameter.Type 形式参数的类型
构造方法摘要
TemplateParameter()
缺省构造方法
方法摘要
void | addEnumValue(java.lang.String value) 添加可选择变量值的枚举
void | addEnumValue(java.lang.String value, java.lang.String display) 添加可选择变量值的枚举
boolean | getCanCustom() 返回是否可以定制变量取值
char | getEnumSplit() 返回枚举值的分隔字符
TemplateParameter.Token[] | getEnumValue() 返回有效的变量值的列表数组，如果变量值不是枚举类型，则返回 null。
java.lang.String | getEnumValueDisplay(java.lang.String sEnumValue) 返回和指定的枚举值相关联的枚举显示名称，如果没有显示名称和该枚举值相关联， 则返回 null。
java.lang.String | getParameterDefault() 返回形式参数缺省值的完全设置
java.lang.String | getParameterDefaultDisplay() 返回形式参数缺省值的显示值
java.lang.String | getParameterDefaultValue() 返回形式参数缺省值的有效值
java.lang.String | getParameterName() 返回形式参数的名称
TemplateParameter.Type | getParameterType() 返回形式参数的类型
TemplateParameter | getPreDeclared() 返回预先声明同名变量时使用的对象
Template | getTemplate() 返回形式参数所在的模板
int | getTemplateId() 返回形式参数所在模板的ID
java.lang.String | getTemplateName() 返回形式参数所在模板的名称
void | setCanCustom(boolean canCustom) 设置是否可以定制变量取值，不能定制变量取值，即只能从现有的枚举值中选择。
void | setEnumSplit(char enumSplit) 设置枚举值的分隔字符
void | setParameterDefault(java.lang.String parameterDefault) 设置形式参数的缺省值
void | setParameterName(java.lang.String parameterName) 设置形式参数的名称
void | setParameterType(java.lang.String sTypeName) 设置形式参数的类型
void | setParameterType(TemplateParameter.Type parameterType) 设置形式参数的类型
void | setPreDeclared(TemplateParameter preDeclared) 设置预先声明同名变量时使用的对象
void | setTemplateId(int templateId) 设置模板的ID
void | setTemplateName(java.lang.String templateName) 设置模板的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateParameter

public TemplateParameter()
缺省构造方法

方法详细信息

getPreDeclared

public TemplateParameter getPreDeclared()
返回预先声明同名变量时使用的对象

返回：
预先声明同名变量时使用的对象

setPreDeclared

public void setPreDeclared(TemplateParameter preDeclared)
设置预先声明同名变量时使用的对象

参数：
preDeclared - 预先声明同名变量时使用的对象

getParameterName

public java.lang.String getParameterName()
返回形式参数的名称

返回：
形式参数的名称

setParameterName

public void setParameterName(java.lang.String parameterName)
设置形式参数的名称

参数：
parameterName - 形式参数的名称

getParameterType

public TemplateParameter.Type getParameterType()
返回形式参数的类型

返回：
形式参数的类型

setParameterType

public void setParameterType(TemplateParameter.Type parameterType)
设置形式参数的类型

参数：
parameterType - 形式参数的类型

setParameterType

public void setParameterType(java.lang.String sTypeName)
设置形式参数的类型

参数：
parameterType - 形式参数的类型的名称

getParameterDefault

public java.lang.String getParameterDefault()
返回形式参数缺省值的完全设置

返回：
形式参数的缺省值

getParameterDefaultValue

public java.lang.String getParameterDefaultValue()
返回形式参数缺省值的有效值

返回：
形式参数的缺省值

getParameterDefaultDisplay

public java.lang.String getParameterDefaultDisplay()
返回形式参数缺省值的显示值

返回：
形式参数的缺省值

setParameterDefault

public void setParameterDefault(java.lang.String parameterDefault)
设置形式参数的缺省值

参数：
parameterDefault - 形式参数的缺省值

getEnumValue

public TemplateParameter.Token[] getEnumValue()
返回有效的变量值的列表数组，如果变量值不是枚举类型，则返回 null。

返回：
有效的变量值的列表数组或者 null

addEnumValue

public void addEnumValue(java.lang.String value)
添加可选择变量值的枚举

参数：
value - 变量值的枚举值，认为其实际值和显示值采用 m_cEnumSplit 分隔
另请参见：
setEnumSplit(char), addEnumValue(String, String)

addEnumValue

public void addEnumValue(java.lang.String value,
                         java.lang.String display)
添加可选择变量值的枚举

参数：
value - 枚举值的实际值
display - 枚举值的显示值，可以为 null ，则显示值等于实际值

getEnumValueDisplay

public java.lang.String getEnumValueDisplay(java.lang.String sEnumValue)
返回和指定的枚举值相关联的枚举显示名称，如果没有显示名称和该枚举值相关联， 则返回 null。

返回：
和指定的枚举值相关联的枚举显示名称或者 null

getEnumSplit

public char getEnumSplit()
返回枚举值的分隔字符

返回：
枚举值的分隔字符

setEnumSplit

public void setEnumSplit(char enumSplit)
设置枚举值的分隔字符

参数：
enumSplit - 枚举值的分隔字符

getCanCustom

public boolean getCanCustom()
返回是否可以定制变量取值

返回：
是否可以定制

setCanCustom

public void setCanCustom(boolean canCustom)
设置是否可以定制变量取值，不能定制变量取值，即只能从现有的枚举值中选择。

参数：
canCustom - 是否可以定制

getTemplate

public Template getTemplate()
                     throws WCMException
返回形式参数所在的模板

返回：
形式参数所在的模板
抛出：
WCMException

getTemplateId

public int getTemplateId()
返回形式参数所在模板的ID

返回：
形式参数所在模板的ID

setTemplateId

public void setTemplateId(int templateId)
设置模板的ID

参数：
templateId - 模板的ID

getTemplateName

public java.lang.String getTemplateName()
返回形式参数所在模板的名称

返回：
形式参数所在模板的名称

setTemplateName

public void setTemplateName(java.lang.String templateName)
设置模板的名称

参数：
templateName - 模板的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParameter.Token

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TemplateParameter.Token

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TemplateParameter.Token
包容类：
TemplateParameter
public static class TemplateParameter.Token
extends java.lang.Object

形式参数的候选值

方法摘要
java.lang.String | getDisplay() 返回可用值的显示信息
java.lang.String | getValue() 返回可用值的值
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getValue

public java.lang.String getValue()
返回可用值的值

返回：
可用值的值

getDisplay

public java.lang.String getDisplay()
返回可用值的显示信息

返回：
可用值的显示信息

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParameter.Type

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TemplateParameter.Type

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type
包容类：
TemplateParameter
public static class TemplateParameter.Type
extends java.lang.Object

形式参数的类型

字段摘要
static TemplateParameter.Type | BOOLEAN 逻辑类型的变量，其值必须是10个数字和减号
static TemplateParameter.Type | INTEGER 整数类型的变量，其值必须是10个数字和减号
static TemplateParameter.Type | MULTI
static TemplateParameter.Type | NUMBER 数值类型的变量，其值必须是10个数字、减号和小数点
static TemplateParameter.Type | STRING 字符串类型的变量，其值可以是任意字符串
方法摘要
java.lang.String | getAlias() 返回变量类型的别名
java.lang.String | getName() 返回变量类型的名称
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

BOOLEAN

public static final TemplateParameter.Type BOOLEAN
逻辑类型的变量，其值必须是10个数字和减号

INTEGER

public static final TemplateParameter.Type INTEGER
整数类型的变量，其值必须是10个数字和减号

NUMBER

public static final TemplateParameter.Type NUMBER
数值类型的变量，其值必须是10个数字、减号和小数点

STRING

public static final TemplateParameter.Type STRING
字符串类型的变量，其值可以是任意字符串

MULTI

public static final TemplateParameter.Type MULTI
方法详细信息

getName

public java.lang.String getName()
返回变量类型的名称

返回：
变量类型的名称

getAlias

public java.lang.String getAlias()
返回变量类型的别名

返回：
变量类型的别名

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParameterList

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.tagparser
类 TemplateParameterList

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TemplateParameterList

public class TemplateParameterList
extends java.lang.Object

对象TemplateParameter的集合类

作者：
Martin (付成睿)

构造方法摘要
TemplateParameterList()
缺省构造方法
TemplateParameterList(boolean zBatch)
构造方法
方法摘要
void | addParameter(TemplateParameter _parameter) 向参数列表中增加参数
void | addParameterList(TemplateParameterList _list) 在批模式下，增加参数列表
java.util.HashMap | getNameMaps() 返回含有所有形式参数名的HashMap对象
boolean | getNestParsed() 判断是否已经设置过被嵌套模板的变量
TemplateParameter | getParameter(java.lang.String _name) 返回指定名称的形式参数对象
java.util.Iterator | parameters() 便利所有的形式参数
void | setNestParsed(boolean zFlag) 设置是否已经设置过被嵌套模板的变量
int | size() 返回其中形式参数的个数
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateParameterList

public TemplateParameterList()
缺省构造方法

TemplateParameterList

public TemplateParameterList(boolean zBatch)
构造方法

参数：
zBatch - 是否是列表的列表
方法详细信息

getNameMaps

public java.util.HashMap getNameMaps()
返回含有所有形式参数名的HashMap对象

getParameter

public TemplateParameter getParameter(java.lang.String _name)
返回指定名称的形式参数对象

参数：
_name - 指定的形式参数名称

addParameter

public void addParameter(TemplateParameter _parameter)
向参数列表中增加参数

参数：
_parameter - 待增加的参数

addParameterList

public void addParameterList(TemplateParameterList _list)
在批模式下，增加参数列表

参数：
_list - 待增加的参数列表

parameters

public java.util.Iterator parameters()
便利所有的形式参数

size

public int size()
返回其中形式参数的个数

返回：
形式参数的个数

getNestParsed

public boolean getNestParsed()
判断是否已经设置过被嵌套模板的变量

setNestParsed

public void setNestParsed(boolean zFlag)
设置是否已经设置过被嵌套模板的变量

参数：
zFlag - 是否已经设置过被嵌套模板的变量的标志
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.BaseTagParser
的使用

使用 BaseTagParser 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.widget.tagparser
com.trs.components.metadata.publish
com.trs.components.wcm.publish.tagparser
com.trs.wcm.photo.publish

com.trs.components.common.publish.domain.tagparser 中 BaseTagParser 的使用

com.trs.components.common.publish.domain.tagparser 中 BaseTagParser 的子类
class | BaseTagParser4List Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseTagParserDefaultObjects Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDefaultObjects Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDetailPages

com.trs.components.common.publish.widget.tagparser 中 BaseTagParser 的使用

com.trs.components.common.publish.widget.tagparser 中 BaseTagParser 的子类
class | WCMTagParserBaseOperation
class | WCMTagParserChnlInChnlOperation
class | WCMTagParserChnlOperation
class | WCMTagParserDocInChnlOperation
class | WCMTagParserDocOperation
class | WCMTagParserLayout 用于TRS_Layout置标生成HTML代码，一般用在母板中
class | WCMTagParserLayoutCell TRS_LayoutCell用于TRS_Layout置标内部，其发布产生的html代码，将作为布局列的内容，填充到布局对应的列中，一般用在母板中
class | WCMTagParserPageStyle 页面风格的置标解析 该置标是用于分发风格的样式文件以及图片文件
class | WCMTagParserPreWidget
class | WCMTagParserResources 用于在设计页面及发布页面引入相应的资源文件（包括js及css），如：设计页面引入的layout.js,widget.js等关于布局和资源块操作的js。
class | WCMTagParserSpecialAppendix 用于处理专题中的附件发布
class | WCMTagParserSpecialLogo 专题LOGO置标解析
class | WCMTagParserTagCreator
class | WCMTagParserWidget

com.trs.components.metadata.publish 中 BaseTagParser 的使用

com.trs.components.metadata.publish 中 BaseTagParser 的子类
class | WCMTagParserClassDocuments
class | WCMTagParserClassInfos Title: TRS 内容协作平台（TRS WCM） Description: TRS_ClassInfos 置标解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserMyViewDatas Title: TRS 内容协作平台（TRS WCM） Description: TRS_MyViewDatas解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserViewDatas
class | WCMTagParserViewFields Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser 中 BaseTagParser 的使用

com.trs.components.wcm.publish.tagparser 中 BaseTagParser 的子类
class | BaseWCMTagParserPreNextDocuments
class | WCMTagParserChannelLogo
class | WCMTagParserDefaultObjectsInChannel
class | WCMTagParserDefaultObjectsInChannelBase
class | WCMTagParserDocumentChannels
class | WCMTagParserDocumentLogo
class | WCMTagParserLogoBase
class | WCMTagParserNextDocuments
class | WCMTagParserPreDocuments
class | WCMTagParserWebSites
class | XWCMContImgTagParser

com.trs.wcm.photo.publish 中 BaseTagParser 的使用

com.trs.wcm.photo.publish 中 BaseTagParser 的子类
 class WCMTagParserImage
Title: TRS 内容协作平台（TRS WCM）
Description:
解析图片库置标TRS_IMAGE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
的使用

使用 BaseTagParser4List 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.metadata.publish
com.trs.components.wcm.publish.tagparser

com.trs.components.common.publish.domain.tagparser 中 BaseTagParser4List 的使用

com.trs.components.common.publish.domain.tagparser 中 BaseTagParser4List 的子类
class | BaseTagParserDefaultObjects Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDefaultObjects Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDetailPages

com.trs.components.metadata.publish 中 BaseTagParser4List 的使用

com.trs.components.metadata.publish 中 BaseTagParser4List 的子类
class | WCMTagParserClassDocuments
class | WCMTagParserMyViewDatas Title: TRS 内容协作平台（TRS WCM） Description: TRS_MyViewDatas解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserViewDatas
class | WCMTagParserViewFields Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser 中 BaseTagParser4List 的使用

com.trs.components.wcm.publish.tagparser 中 BaseTagParser4List 的子类
class | BaseWCMTagParserPreNextDocuments
class | WCMTagParserDefaultObjectsInChannel
class | WCMTagParserDefaultObjectsInChannelBase
class | WCMTagParserDocumentChannels
class | WCMTagParserNextDocuments
class | WCMTagParserPreDocuments
class | WCMTagParserWebSites

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects
的使用

使用 BaseTagParserDefaultObjects 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.wcm.publish.tagparser

com.trs.components.common.publish.domain.tagparser 中 BaseTagParserDefaultObjects 的使用

com.trs.components.common.publish.domain.tagparser 中 BaseTagParserDefaultObjects 的子类
 class TagParserDefaultObjects
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser 中 BaseTagParserDefaultObjects 的使用

com.trs.components.wcm.publish.tagparser 中 BaseTagParserDefaultObjects 的子类
class | WCMTagParserDefaultObjectsInChannel
class | WCMTagParserDefaultObjectsInChannelBase

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.tagparser.ITagFormatter 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.tagparser.ITagFormatter
的使用

使用 ITagFormatter 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.wcm.publish.tagparser.formater

com.trs.components.common.publish.domain.tagparser 中 ITagFormatter 的使用

返回 ITagFormatter 的 com.trs.components.common.publish.domain.tagparser 中的方法
static ITagFormatter TagFormatHelper.getFormatter(java.lang.String _sTagName)
Returns the tag formmater of the specified tag.

com.trs.components.wcm.publish.tagparser.formater 中 ITagFormatter 的使用

实现 ITagFormatter 的 com.trs.components.wcm.publish.tagparser.formater 中的类
class | WCMTagFormatterAllCata Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSALLCATA Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterBigNews Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSBigNews Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterChannel Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterChnlName Title: TRS 内容协作平台（TRS WCM） Description: tag formater for _TRSCHNLNAME Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterColumn Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for PICCONTENT Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterDocumentsBase Title: TRS 内容协作平台（TRS WCM） Description: WCM Tag格式化工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterOutline Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterPicNews Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSPicNews Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterPicture Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSPCITURE Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterRecPath Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSRECPATH Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterRelNews Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterTemplate 将name_of_template格式化为 的形式。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.tagparser.ITagParser 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.tagparser.ITagParser
的使用

使用 ITagParser 的软件包
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.wcm.photo.publish |
com.trs.wcmonline |

com.trs.components.comment.publish.tagparser 中 ITagParser 的使用

实现 ITagParser 的 com.trs.components.comment.publish.tagparser 中的类
 class XWCMTagParserComment
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM TagParser For Comment
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.tagparser 中 ITagParser 的使用

实现 ITagParser 的 com.trs.components.common.publish.domain.tagparser 中的类
class | BaseTagParser
class | BaseTagParser4List Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseTagParserDefaultObjects Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserCMSObj Title: TRS 内容协作平台（TRS WCM） Description: default implementation for CMSObj tag parser.
class | TagParserCMSObjBase Title: TRS 内容协作平台（TRS WCM） Description: parser implementation base for CMSObj tag.
class | TagParserCondition 条件执行置标，如果指定的条件为真，则继续执行解析该置标下的模板，如果指定的条件为假，则忽略其下的模板。
class | TagParserContentBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDateTime Title: TRS 内容协作平台（TRS WCM） Description: Tag Parser For TRS_DATETIME Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDefaultObjects Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDetailPage
class | TagParserDetailPages
class | TagParserEcho 用于输出指定的内容到生成的文件中，在和模板变量配合使用时才有意义。
class | TagParserFolderBase Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserNestedTemplate Title: TRS 内容协作平台（TRS WCM） Description: tag parser for nested template.
class | TagParserNewIcon 该置标为比较新的文档（也可以是其他对象）增加是新文档的标志。
class | TagParserOddOrEven Title: TRS 内容协作平台（TRS WCM） Description: 奇偶然样式置标 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | TagParserOnlyLogic
class | TagParserPageNav4Detail
class | TagParserRepeat TODO javadoc for com.trs.components.common.publish.domain.tagparser.TagParserRepeat
class | TagParserSequenceNumber
class | TagParserSystemConfig 返回配置的属性字段的值
class | TagParserUnimpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserUser
class | TagParserVariable 用于在使用变量前，进行变量的声明。
class | TagParserVariableEnum 在声明变量时，枚举变量的可用值
class | TagParserVariableSet 给模板变量赋值的置标，一般情况下所赋之值来自其子置标的解析结果

返回 ITagParser 的 com.trs.components.common.publish.domain.tagparser 中的方法
static ITagParser TagParserFactory.createParserByName(java.lang.String _sTagName)
Creates a parser instance for the specified tag.

com.trs.components.common.publish.widget.tagparser 中 ITagParser 的使用

实现 ITagParser 的 com.trs.components.common.publish.widget.tagparser 中的类
class | WCMTagParserBaseOperation
class | WCMTagParserChnlInChnlOperation
class | WCMTagParserChnlOperation
class | WCMTagParserDocInChnlOperation
class | WCMTagParserDocOperation
class | WCMTagParserLayout 用于TRS_Layout置标生成HTML代码，一般用在母板中
class | WCMTagParserLayoutCell TRS_LayoutCell用于TRS_Layout置标内部，其发布产生的html代码，将作为布局列的内容，填充到布局对应的列中，一般用在母板中
class | WCMTagParserPageStyle 页面风格的置标解析 该置标是用于分发风格的样式文件以及图片文件
class | WCMTagParserPreWidget
class | WCMTagParserResources 用于在设计页面及发布页面引入相应的资源文件（包括js及css），如：设计页面引入的layout.js,widget.js等关于布局和资源块操作的js。
class | WCMTagParserSpecialAppendix 用于处理专题中的附件发布
class | WCMTagParserSpecialLogo 专题LOGO置标解析
class | WCMTagParserTagCreator
class | WCMTagParserWidget

com.trs.components.infoview.publish.tagparser 中 ITagParser 的使用

实现 ITagParser 的 com.trs.components.infoview.publish.tagparser 中的类
class | TagParserInfoView 用于发布自定义表单的置标
class | TagParserInfoViewData
class | TagParserInfoViewHelper 用于发布自定义表单的置标
class | TagParserInfoViewNav Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserInfoViewNavs Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserInfoViewPage 用于发布自定义表单的置标
class | TagParserInfoViews 用于发布自定义表单的置标

com.trs.components.metadata.publish 中 ITagParser 的使用

实现 ITagParser 的 com.trs.components.metadata.publish 中的类
class | WCMTagParserAppendix Title: TRS 内容协作平台（TRS WCM） Description: TRS_APPENDIX解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserClassDocuments
class | WCMTagParserClassIndexGener Title: TRS 内容协作平台（TRS WCM） Description: 在指定栏目或者站点中产生分类法首页 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserClassInfo
class | WCMTagParserClassInfos Title: TRS 内容协作平台（TRS WCM） Description: TRS_ClassInfos 置标解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserExistDataOfClassInfo
class | WCMTagParserMyViewDatas Title: TRS 内容协作平台（TRS WCM） Description: TRS_MyViewDatas解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserRelNewsForViewData Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_RELNEWS Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserViewData
class | WCMTagParserViewDatas
class | WCMTagParserViewField Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserViewFields Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 ITagParser 的使用

实现 ITagParser 的 com.trs.components.wcm.epress 中的类
class | TagEBookDirParser Title: TRS 内容协作平台（TRS WCM） Description: 电子书目录置标(地方志等) Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | TagMapAreaParser Title: TRS 内容协作平台（TRS WCM） Description: 生成电子报map area相关信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserPageNav Title: TRS 内容协作平台（TRS WCM） Description: 分页置标 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | TagPreNextParser Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WCMTagParserExpertNews

com.trs.components.wcm.publish.region 中 ITagParser 的使用

实现 ITagParser 的 com.trs.components.wcm.publish.region 中的类
 class WCMTagParserRegion

com.trs.components.wcm.publish.tagparser 中 ITagParser 的使用

实现 ITagParser 的 com.trs.components.wcm.publish.tagparser 中的类
class | BaseWCMTagParserPreNextDocuments
class | TagChannelChainParser Title: TRS 内容协作平台（TRS WCM） Description: 获取栏目父子链属性 Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TagDocbakParser
class | TagParserCRUser Title: TRS 内容协作平台（TRS WCM） Description: 创建者属性发布置标 Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TagParserWmlImage Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TagParserWmlImages Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TagWmlContentParser Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | WCMTagParser4FolderHostBase Title: TRS 内容协作平台（TRS WCM） Description: base implementation of tag parser for channel host in WCM Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParser4ObjsInChannelBase Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_*** [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_***> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserChannel Title: TRS 内容协作平台（TRS WCM） Description: The Parser For TRS_CHANNEL Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserChannelLogo
class | WCMTagParserChannels Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_ALLCATA Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserCurPage Title: TRS 内容协作平台（TRS WCM） Description: tag parser for <_TRSCURPAGE>.
class | WCMTagParserDefaultObjectsInChannel
class | WCMTagParserDefaultObjectsInChannelBase
class | WCMTagParserDocReply Title: TRS 内容协作平台（TRS WCM） Description: 文档回复的发布置标解释器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDocument Title: TRS 内容协作平台（TRS WCM） Description: parser for Grammer: <TRS_COLUMN ID="字段名" [[NUM="最大长度" [TRUNCATEDFLAG="长度裁减标记"]] [DATEFORMAT="日期格式"][AUTOFORMAT="自动格式化"] [AUTOLINK="是否自动产生链接 "][TARGET="窗口目标"][EXTRA="扩展HTML内容"] ]>通用细览 </TRS_COLUMN> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDocumentChannels
class | WCMTagParserDocumentForBJGOV Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDocumentLogo
class | WCMTagParserDocuments Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_OUTLINE> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserEPressNews Title: TRS 内容协作平台（TRS WCM） Description: 电子报版面图 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserIcon Title: TRS 内容协作平台（TRS WCM） Description: WCMTagParser For TRS_ICON Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserLogoBase
class | WCMTagParserMapArea Title: TRS 内容协作平台（TRS WCM） Description: 生成电子报map area相关信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserNextDocuments
class | WCMTagParserPreDocuments
class | WCMTagParserPrev Title: TRS 内容协作平台（TRS WCM） Description: WCM TagParser For TRS_PREV Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserRelNews Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_RELNEWS Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserReplace Title: TRS 内容协作平台（TRS WCM） Description: WCM Tag Parser For TRS_REPLACE Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserRollDocuments
class | WCMTagparserTopIcon Title: TRS 内容协作平台（TRS WCM） Description: 置顶文档标识 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | WCMTagParserWebSite
class | WCMTagParserWebSites
class | WCMTagParserXDcouments Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WCMTagParserXDocument
class | XTagParserObjsInChannelBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | XWCMContImgTagParser
class | XWCMFileAppendixTagParser Title: TRS 内容协作平台（TRS WCM） Description: 解析文档包含的文件附件：支持自定义文件名 Copyright: Copyright (c) 2009-2010 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | XWCMImageAppendixTagParser Title: TRS 内容协作平台（TRS WCM） Description: 解析文档包含的图片附件：支持图片自动缩放 Copyright: Copyright (c) 2009-2010 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | XWCMTagParserPageGeneration

com.trs.wcm.photo.publish 中 ITagParser 的使用

实现 ITagParser 的 com.trs.wcm.photo.publish 中的类
 class WCMTagParserImage
Title: TRS 内容协作平台（TRS WCM）
Description:
解析图片库置标TRS_IMAGE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcmonline 中 ITagParser 的使用

实现 ITagParser 的 com.trs.wcmonline 中的类
 class TagParserVipMetaData
Title: TRS 内容协作平台（TRS WCM）
Description:
嘉宾访谈数据信息
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.tagparser.ITagParser4List 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.tagparser.ITagParser4List
的使用

使用 ITagParser4List 的软件包
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.tagparser
com.trs.components.metadata.publish
com.trs.components.wcm.epress
com.trs.components.wcm.publish.tagparser

com.trs.components.common.publish.domain.publisher 中 ITagParser4List 的使用

返回 ITagParser4List 的 com.trs.components.common.publish.domain.publisher 中的方法
 ITagParser4List PublishTagContext.getTagParser4List()
返回相关联的ITagParser4List对象

参数类型为 ITagParser4List 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishTagContext(PublishTagContext _parent, TagItem _tagItem, ITagParser4List _tagParser4List)

com.trs.components.common.publish.domain.tagparser 中 ITagParser4List 的使用

实现 ITagParser4List 的 com.trs.components.common.publish.domain.tagparser 中的类
class | BaseTagParser4List Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseTagParserDefaultObjects Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDefaultObjects Title: TRS 内容协作平台（TRS WCM） Description: TRS_DefObjects的解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDetailPages

参数类型为 ITagParser4List 的 com.trs.components.common.publish.domain.tagparser 中的方法
static java.lang.String[] | TagParseHelper.parse4List(PublishTagContext _tagContext, ITagParser4List _parser4List)
static java.lang.String[] | TagParseHelper.parse4List(TagItem _tagItem, PublishTagContext _tagContext, ITagParser4List _parser4List) Parses objects list tag, eg.

com.trs.components.metadata.publish 中 ITagParser4List 的使用

实现 ITagParser4List 的 com.trs.components.metadata.publish 中的类
class | WCMTagParserClassDocuments
class | WCMTagParserClassInfos Title: TRS 内容协作平台（TRS WCM） Description: TRS_ClassInfos 置标解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserMyViewDatas Title: TRS 内容协作平台（TRS WCM） Description: TRS_MyViewDatas解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserRelNewsForViewData Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_RELNEWS Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserViewDatas
class | WCMTagParserViewFields Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 ITagParser4List 的使用

实现 ITagParser4List 的 com.trs.components.wcm.epress 中的类
 class WCMTagParserExpertNews

com.trs.components.wcm.publish.tagparser 中 ITagParser4List 的使用

实现 ITagParser4List 的 com.trs.components.wcm.publish.tagparser 中的类
class | BaseWCMTagParserPreNextDocuments
class | WCMTagParser4ObjsInChannelBase Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_*** [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_***> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserChannels Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_ALLCATA Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDefaultObjectsInChannel
class | WCMTagParserDefaultObjectsInChannelBase
class | WCMTagParserDocumentChannels
class | WCMTagParserDocuments Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_OUTLINE> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserEPressNews Title: TRS 内容协作平台（TRS WCM） Description: 电子报版面图 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserNextDocuments
class | WCMTagParserPreDocuments
class | WCMTagParserRelNews Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_RELNEWS Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserRollDocuments
class | WCMTagParserWebSites
class | WCMTagParserXDcouments Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | XTagParserObjsInChannelBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.LoopException 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.LoopException
的使用

没有 com.trs.components.common.publish.domain.tagparser.LoopException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.ScanContext 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.ScanContext
的使用

使用 ScanContext 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 ScanContext 的使用

参数类型为 ScanContext 的 com.trs.components.common.publish.domain.tagparser 中的方法
static int TagDocumentReader.lookupNextStatus(int _nCurrentStatus, ScanContext sCtx)
lookup the next status at the current condition.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo
的使用

使用 TagBeanAttrInfo 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TagBeanAttrInfo 的使用

返回 TagBeanAttrInfo 的 com.trs.components.common.publish.domain.tagparser 中的方法
TagBeanAttrInfo | TagBeanInfo.addAttrInfo(TagBeanAttrInfo tbai) 添加置标属性信息对象，如果相同名称的置标属性信息对象已经存在，则将被替换，并返回。
TagBeanAttrInfo | TagBeanInfo.getAttrInfo(java.lang.String name) 返回指定名称的置标属性信息对象。
TagBeanAttrInfo[] | TagBeanInfo.getRequiredAttr() 返回该置标必须的属性数组

参数类型为 TagBeanAttrInfo 的 com.trs.components.common.publish.domain.tagparser 中的方法
 TagBeanAttrInfo TagBeanInfo.addAttrInfo(TagBeanAttrInfo tbai)
添加置标属性信息对象，如果相同名称的置标属性信息对象已经存在，则将被替换，并返回。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type
的使用

使用 TagBeanAttrInfo.Type 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TagBeanAttrInfo.Type 的使用

声明为 TagBeanAttrInfo.Type 的 com.trs.components.common.publish.domain.tagparser 中的字段
static TagBeanAttrInfo.Type | TagBeanAttrInfo.Type.INTEGER 整数类型的属性，属性值必须是10个数字和减号
static TagBeanAttrInfo.Type | TagBeanAttrInfo.Type.NUMBER 数值类型的属性，属性值必须是10个数字、减号和小数点
static TagBeanAttrInfo.Type | TagBeanAttrInfo.Type.STRING 字符串类型的属性，属性值可以是任意字符串

返回 TagBeanAttrInfo.Type 的 com.trs.components.common.publish.domain.tagparser 中的方法
 TagBeanAttrInfo.Type TagBeanAttrInfo.getType()
返回属性类型

参数类型为 TagBeanAttrInfo.Type 的 com.trs.components.common.publish.domain.tagparser 中的方法
 void TagBeanAttrInfo.setType(TagBeanAttrInfo.Type type)
设置属性类型

参数类型为 TagBeanAttrInfo.Type 的 com.trs.components.common.publish.domain.tagparser 中的构造方法
TagBeanAttrInfo(java.lang.String name, TagBeanAttrInfo.Type type, java.lang.String sDef, java.lang.String[] aVal)
构造方法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType
的使用

使用 TagBeanInfo.BodyType 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TagBeanInfo.BodyType 的使用

声明为 TagBeanInfo.BodyType 的 com.trs.components.common.publish.domain.tagparser 中的字段
static TagBeanInfo.BodyType | TagBeanInfo.BodyType.ARGUMENT 在开始置标和结束置标之间是置标的参数，不能为空
static TagBeanInfo.BodyType | TagBeanInfo.BodyType.EMPTY 在开始置标和结束置标之间不能有任何内容
static TagBeanInfo.BodyType | TagBeanInfo.BodyType.HTML 在开始置标和结束置标之间是普通的HTML代码
static TagBeanInfo.BodyType | TagBeanInfo.BodyType.IGNORE 在开始置标和结束置标之间的任何内容都回忽略
static TagBeanInfo.BodyType | TagBeanInfo.BodyType.TAMPLATE 在开始置标和结束置标之间，可以是模板内容，既可以包括WCM置标

返回 TagBeanInfo.BodyType 的 com.trs.components.common.publish.domain.tagparser 中的方法
 TagBeanInfo.BodyType TagBeanInfo.getType()
返回置标的类型

参数类型为 TagBeanInfo.BodyType 的 com.trs.components.common.publish.domain.tagparser 中的方法
 void TagBeanInfo.setType(TagBeanInfo.BodyType type)
设置置标的类型

参数类型为 TagBeanInfo.BodyType 的 com.trs.components.common.publish.domain.tagparser 中的构造方法
TagBeanInfo(java.lang.String name, java.lang.String desc, TagBeanInfo.BodyType type)
构造方法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo
的使用

使用 TagBeanInfo 的软件包
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.wcm.photo.publish |
com.trs.wcmonline |

com.trs.components.comment.publish.tagparser 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.components.comment.publish.tagparser 中的方法
 TagBeanInfo XWCMTagParserComment.getBeanInfo()

com.trs.components.common.publish.domain.tagparser 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.components.common.publish.domain.tagparser 中的方法
TagBeanInfo | TagParserDateTime.getBeanInfo()
TagBeanInfo | BaseTagParser.getBeanInfo()
TagBeanInfo | TagParserPageNav4Detail.getBeanInfo()
TagBeanInfo | TagParserUser.getBeanInfo()
TagBeanInfo | TagParserNestedTemplate.getBeanInfo()
TagBeanInfo | TagParserCondition.getBeanInfo()
TagBeanInfo | ITagParser.getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
TagBeanInfo | TagParserUnimpl.getBeanInfo()
TagBeanInfo | TagParserRepeat.getBeanInfo()
TagBeanInfo | TagParserOddOrEven.getBeanInfo()
TagBeanInfo | TagParserSequenceNumber.getBeanInfo()
TagBeanInfo | TagParserEcho.getBeanInfo()
TagBeanInfo | TagParserCMSObj.getBeanInfo()
TagBeanInfo | TagParserVariableEnum.getBeanInfo()
TagBeanInfo | TagParserDetailPage.getBeanInfo()
TagBeanInfo | TagParserVariable.getBeanInfo()
TagBeanInfo | TagParserDetailPages.getBeanInfo()
TagBeanInfo | TagParserOnlyLogic.getBeanInfo()
TagBeanInfo | TagParserSystemConfig.getBeanInfo()
TagBeanInfo | TagParserVariableSet.getBeanInfo()
TagBeanInfo | TagParserNewIcon.getBeanInfo()

com.trs.components.common.publish.widget.tagparser 中 TagBeanInfo 的使用

com.trs.components.common.publish.widget.tagparser 中 TagBeanInfo 的子类
 class WCMTagParserBaseOperation.TBI

返回 TagBeanInfo 的 com.trs.components.common.publish.widget.tagparser 中的方法
TagBeanInfo | WCMTagParserDocOperation.getBeanInfo()
TagBeanInfo | WCMTagParserPageStyle.getBeanInfo()
TagBeanInfo | WCMTagParserChnlOperation.getBeanInfo()
TagBeanInfo | WCMTagParserSpecialAppendix.getBeanInfo() 置标属性定义
TagBeanInfo | WCMTagParserLayout.getBeanInfo()
TagBeanInfo | WCMTagParserTagCreator.getBeanInfo()
TagBeanInfo | WCMTagParserDocInChnlOperation.getBeanInfo()
TagBeanInfo | WCMTagParserPreWidget.getBeanInfo()
TagBeanInfo | WCMTagParserSpecialLogo.getBeanInfo() 置标属性定义
TagBeanInfo | WCMTagParserResources.getBeanInfo() 置标属性定义
TagBeanInfo | WCMTagParserChnlInChnlOperation.getBeanInfo()

com.trs.components.infoview.publish.tagparser 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.components.infoview.publish.tagparser 中的方法
TagBeanInfo | TagParserInfoViewNavs.getBeanInfo()
TagBeanInfo | TagParserInfoViewHelper.getBeanInfo()
TagBeanInfo | TagParserInfoViewData.getBeanInfo()
TagBeanInfo | TagParserInfoViewNav.getBeanInfo()
TagBeanInfo | TagParserInfoViewPage.getBeanInfo()
TagBeanInfo | TagParserInfoViews.getBeanInfo()
TagBeanInfo | TagParserInfoView.getBeanInfo()

com.trs.components.metadata.publish 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.components.metadata.publish 中的方法
TagBeanInfo | WCMTagParserAppendix.getBeanInfo()
TagBeanInfo | WCMTagParserClassIndexGener.getBeanInfo()
TagBeanInfo | WCMTagParserRelNewsForViewData.getBeanInfo()
TagBeanInfo | WCMTagParserClassInfo.getBeanInfo()
TagBeanInfo | WCMTagParserViewData.getBeanInfo()
TagBeanInfo | WCMTagParserViewField.getBeanInfo()
TagBeanInfo | WCMTagParserExistDataOfClassInfo.getBeanInfo()

com.trs.components.wcm.epress 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.components.wcm.epress 中的方法
TagBeanInfo | WCMTagParserExpertNews.getBeanInfo()
TagBeanInfo | WCMTagParserEPressNews.getBeanInfo()
TagBeanInfo | TagPreNextParser.getBeanInfo()
TagBeanInfo | TagParserPageNav.getBeanInfo()
TagBeanInfo | TagMapAreaParser.getBeanInfo()
TagBeanInfo | TagEBookDirParser.getBeanInfo()

com.trs.components.wcm.publish.region 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.components.wcm.publish.region 中的方法
 TagBeanInfo WCMTagParserRegion.getBeanInfo()

com.trs.components.wcm.publish.tagparser 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.components.wcm.publish.tagparser 中的方法
TagBeanInfo | WCMTagParserWebSite.getBeanInfo()
TagBeanInfo | TagWmlContentParser.getBeanInfo()
TagBeanInfo | TagChannelChainParser.getBeanInfo()
TagBeanInfo | TagParserWmlImage.getBeanInfo()
TagBeanInfo | WCMTagParserCurPage.getBeanInfo()
TagBeanInfo | TagParserCRUser.getBeanInfo()
TagBeanInfo | WCMTagParserXDcouments.getBeanInfo()
TagBeanInfo | XWCMTagParserPageGeneration.getBeanInfo()
TagBeanInfo | WCMTagParserRollDocuments.getBeanInfo()
TagBeanInfo | WCMTagParserDocReply.getBeanInfo()
TagBeanInfo | WCMTagParserXDocument.getBeanInfo()
TagBeanInfo | WCMTagParserEPressNews.getBeanInfo()
TagBeanInfo | WCMTagParserMapArea.getBeanInfo()
TagBeanInfo | WCMTagParserAppendix.getBeanInfo()
TagBeanInfo | WCMTagParserChannel.getBeanInfo()
TagBeanInfo | WCMTagParserPrev.getBeanInfo()
TagBeanInfo | WCMTagParserIcon.getBeanInfo()
TagBeanInfo | BaseWCMTagParserPreNextDocuments.getBeanInfo()
TagBeanInfo | XWCMFileAppendixTagParser.getBeanInfo()
TagBeanInfo | WCMTagParserChannels.getBeanInfo()
TagBeanInfo | WCMTagParserWebSites.getBeanInfo()
TagBeanInfo | WCMTagParserDocument.getBeanInfo()
TagBeanInfo | XWCMImageAppendixTagParser.getBeanInfo()
TagBeanInfo | WCMTagparserTopIcon.getBeanInfo()
TagBeanInfo | WCMTagParserDocuments.getBeanInfo()
TagBeanInfo | WCMTagParserReplace.getBeanInfo()
TagBeanInfo | TagParserWmlImages.getBeanInfo()
TagBeanInfo | WCMTagParserRelNews.getBeanInfo()

com.trs.wcm.photo.publish 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.wcm.photo.publish 中的方法
 TagBeanInfo WCMTagParserImage.getBeanInfo()

com.trs.wcmonline 中 TagBeanInfo 的使用

返回 TagBeanInfo 的 com.trs.wcmonline 中的方法
 TagBeanInfo TagParserVipMetaData.getBeanInfo()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagBeanInfoHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagBeanInfoHelper
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagBeanInfoHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagBeanLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagBeanLCListener
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagBeanLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagDocument 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagDocument
的使用

使用 TagDocument 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.template

com.trs.components.common.publish.domain.tagparser 中 TagDocument 的使用

返回 TagDocument 的 com.trs.components.common.publish.domain.tagparser 中的方法
static TagDocument | TagDocumentReader.read(java.lang.String _text) read a tag document from the specified content.
TagDocument | TagDocumentScanner.scan(java.lang.String _text)

com.trs.components.common.publish.domain.template 中 TagDocument 的使用

返回 TagDocument 的 com.trs.components.common.publish.domain.template 中的方法
TagDocument | TemplateParseMgr.checkLexical(Template _template, Report _report) 对模板的正文进行文法检查，如果没有文法错误，则返回模板置标树，如果存在文法错误， 则通过传入参数 _report 报告错误信息。
TagDocument | TemplateParseMgr.parse(Template _template) parse the specified template

参数类型为 TagDocument 的 com.trs.components.common.publish.domain.template 中的方法
 boolean TemplateParseMgr.checkGrammar(TagDocument _tagDoc, Report _report)
检查模板置标树的语法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagDocumentScanner 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagDocumentScanner
的使用

使用 TagDocumentScanner 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TagDocumentScanner 的使用

返回 TagDocumentScanner 的 com.trs.components.common.publish.domain.tagparser 中的方法
static TagDocumentScanner TagDocumentScanner.newScanner()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagFormatHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagFormatHelper
的使用

使用 TagFormatHelper 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TagFormatHelper 的使用

返回 TagFormatHelper 的 com.trs.components.common.publish.domain.tagparser 中的方法
static TagFormatHelper TagFormatHelper.getInstance()
Returns the tag formmater helper instance.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagItem 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagItem
的使用

使用 TagItem 的软件包
com.trs.components.comment.publish.helper |
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.publish.tagparser.formater |
com.trs.wcmonline |

com.trs.components.comment.publish.helper 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.comment.publish.helper 中的方法
static CommentParserEntity CommentParserUtil.getCommentParserEntity(Document doc, TagItem tagItem)

com.trs.components.comment.publish.tagparser 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.comment.publish.tagparser 中的方法
 void XWCMTagParserComment.setTagItem(TagItem _item)

com.trs.components.common.publish.domain.publisher 中 TagItem 的使用

返回 TagItem 的 com.trs.components.common.publish.domain.publisher 中的方法
 TagItem PublishTagContext.getTagItem()

参数类型为 TagItem 的 com.trs.components.common.publish.domain.publisher 中的方法
 void PublishTagContext.setTagItem(TagItem _tagItem)

参数类型为 TagItem 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishTagContext(PublishTagContext _parent, TagItem _tagItem)
PublishTagContext(PublishTagContext _parent, TagItem _tagItem, IPublishElement _upperHost)
PublishTagContext(PublishTagContext _parent, TagItem _tagItem, ITagParser4List _tagParser4List)

com.trs.components.common.publish.domain.tagparser 中 TagItem 的使用

返回 TagItem 的 com.trs.components.common.publish.domain.tagparser 中的方法
TagItem | TagItem.getParent() 获取父tagitem
static TagItem | TagParseHelper.strToTagItem(java.lang.String _sText) Converts a string to TagItem.

参数类型为 TagItem 的 com.trs.components.common.publish.domain.tagparser 中的方法
void | TagItem.addChild(TagItem _child) add a TagItem child
void | TagDocument.addItem(TagItem _item) add a TagItem item
static void | TagBeanInfoHelper.checkChannelName(IPublishFolder _root, TagItem _tagItem, java.lang.StringBuffer _sbResult) 检查指定置标中使用的频道名称是否存在
void | TagBeanInfo.checkSemantic(IPublishFolder _folder, TagItem _tagItem, java.lang.StringBuffer _sbResult) 检查指定的置标实例的静态语义，如果有静态语义错误，则通过传入的StringBuffer对象返回错误信息。
static Template | TagParseHelper.findNestedTemplate(TagItem _tagItem, IPublishFolder _root) 已过时。 Returns the template defined in the specified nested template tag item.
static java.lang.String | TagParseHelper.formatTextIfNeeded(TagItem _currItem, java.lang.String _sText) 已过时。 Formats the text if AUTOFORMAT=true. Related tag attributes: AUTOFORMAT, AUTOFORMATTYPE
static java.util.ArrayList | TagParseHelper.makeSelectFields(TagItem _item, java.lang.String _sContentTagName)
static java.lang.String[] | TagParseHelper.parse4Children(TagItem _tagItem, PublishTagContext _tagContext)
static java.lang.String[] | TagParseHelper.parse4List(TagItem _tagItem, PublishTagContext _tagContext, ITagParser4List _parser4List) Parses objects list tag, eg.
static java.lang.String[] | TagParseHelper.parseItem(TagItem _item, PublishTagContext _context) Parses a tag item and returns the results which may be more than one.
void | TagItem.setParent(TagItem _parentItem) 设置父tagitem
void | TagParserDateTime.setTagItem(TagItem _item)
void | BaseTagParser.setTagItem(TagItem _item)
void | TagParserPageNav4Detail.setTagItem(TagItem _item)
void | TagParserNestedTemplate.setTagItem(TagItem _item)
void | TagParserCondition.setTagItem(TagItem _item)
void | ITagParser.setTagItem(TagItem _item) Sets the tag item to parser.
void | TagParserUnimpl.setTagItem(TagItem _item)
void | TagParserRepeat.setTagItem(TagItem _item)
void | TagParserOddOrEven.setTagItem(TagItem item)
void | TagParserSequenceNumber.setTagItem(TagItem _item)
void | TagParserEcho.setTagItem(TagItem _item)
void | TagParserVariableEnum.setTagItem(TagItem _item)
void | TagParserVariable.setTagItem(TagItem _item)
void | TagParserOnlyLogic.setTagItem(TagItem _item)
void | TagParserSystemConfig.setTagItem(TagItem _s_item)
void | TagParserVariableSet.setTagItem(TagItem _item)
void | TagParserNewIcon.setTagItem(TagItem _item)
void | TagParserCMSObjBase.setTagItem(TagItem _item)
static void | TagFormatHelper.standardize(TagItem _item) Standardizes a specified tag item with the formatter configurated.
void | ITagFormatter.standardize(TagItem _item) Converts the tag item to standard format.
static java.lang.String | TagParseHelper.truncateTextIfNeeded(TagItem _currItem, java.lang.String _sText) 已过时。 Truncates the text length if needed (when NUM>0). Related properties in tag item: NUM, TRUNCATEDFLAG if NUM>0, to truncate the text with the flag as tail.

com.trs.components.common.publish.widget.tagparser 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.common.publish.widget.tagparser 中的方法
 void WCMTagParserBaseOperation.TBI.checkSemantic(IPublishFolder _folder, TagItem _tagItem, java.lang.StringBuffer _sbResult)

com.trs.components.infoview.publish.tagparser 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.infoview.publish.tagparser 中的方法
void | TagParserInfoViewNavs.setTagItem(TagItem _item)
void | TagParserInfoViewHelper.setTagItem(TagItem _item)
void | TagParserInfoViewData.setTagItem(TagItem _item)
void | TagParserInfoViewNav.setTagItem(TagItem _item)
void | TagParserInfoViewPage.setTagItem(TagItem _item)
void | TagParserInfoViews.setTagItem(TagItem _item)
void | TagParserInfoView.setTagItem(TagItem _item)

com.trs.components.metadata.publish 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.metadata.publish 中的方法
void | WCMTagParserAppendix.setTagItem(TagItem _item)
void | WCMTagParserClassIndexGener.setTagItem(TagItem _item)
void | WCMTagParserRelNewsForViewData.setTagItem(TagItem _item)
void | WCMTagParserClassDocuments.setTagItem(TagItem _item)
void | WCMTagParserViewDatas.setTagItem(TagItem _item)
void | WCMTagParserExistDataOfClassInfo.setTagItem(TagItem _item)

com.trs.components.wcm.epress 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.wcm.epress 中的方法
void | TagPreNextParser.setTagItem(TagItem _item)
void | TagParserPageNav.setTagItem(TagItem _item)
void | TagMapAreaParser.setTagItem(TagItem _item)
void | TagEBookDirParser.setTagItem(TagItem _item)

com.trs.components.wcm.publish.region 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.wcm.publish.region 中的方法
 void WCMTagParserRegion.setTagItem(TagItem _item)

com.trs.components.wcm.publish.tagparser 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.wcm.publish.tagparser 中的方法
java.lang.String | RollDocumentsChannelsFinder.find(TagItem _tagItem)
static BaseChannel | WCMTagParserHelper.findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel) Returns the current host as a channel.
static BaseChannel | WCMTagParserHelper.findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel, boolean _bIsFromAllCataTag)
static BaseChannel | WCMTagParserHelper.findFolderHostByOldModal(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel)
static int | WCMTemplateChildIndexAnalyer.getAttribute(IPublishElement _element, TagItem _item, java.lang.String _sName, int _nDefault)
static int | WCMTagParserHelper.getChildIndex(TagItem _tagItem) Returns the value of property ChildIndex in tag item.
void | TagWmlContentParser.setTagItem(TagItem _item)
void | TagChannelChainParser.setTagItem(TagItem _item)
void | TagParserWmlImage.setTagItem(TagItem _item)
void | WCMTagParserCurPage.setTagItem(TagItem _item)
void | TagParserCRUser.setTagItem(TagItem _item)
void | XWCMTagParserPageGeneration.setTagItem(TagItem _item)
void | WCMTagParser4FolderHostBase.setTagItem(TagItem _item)
void | WCMTagParserMapArea.setTagItem(TagItem _item)
void | WCMTagParserAppendix.setTagItem(TagItem _item)
void | WCMTagParserPrev.setTagItem(TagItem _item)
void | WCMTagParserIcon.setTagItem(TagItem _item)
void | XWCMFileAppendixTagParser.setTagItem(TagItem _item)
void | XWCMImageAppendixTagParser.setTagItem(TagItem _item)
void | WCMTagparserTopIcon.setTagItem(TagItem _item)
void | WCMTagParserReplace.setTagItem(TagItem _item)
void | TagParserWmlImages.setTagItem(TagItem _item)
void | WCMTagParserRelNews.setTagItem(TagItem _item)

com.trs.components.wcm.publish.tagparser.formater 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.components.wcm.publish.tagparser.formater 中的方法
void | WCMTagFormatterTemplate.standardize(TagItem _item)
void | WCMTagFormatterRecPath.standardize(TagItem _item)
void | WCMTagFormatterPicture.standardize(TagItem _item)
void | WCMTagFormatterDocumentsBase.standardize(TagItem _item)
void | WCMTagFormatterColumn.standardize(TagItem _item)
void | WCMTagFormatterChnlName.standardize(TagItem _item)
void | WCMTagFormatterChannel.standardize(TagItem _item)
void | WCMTagFormatterAllCata.standardize(TagItem _item)

com.trs.wcmonline 中 TagItem 的使用

参数类型为 TagItem 的 com.trs.wcmonline 中的方法
 void TagParserVipMetaData.setTagItem(TagItem _item)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParseHelper
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParseHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObj 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObj
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserCMSObj 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
的使用

使用 TagParserCMSObjBase 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.metadata.publish
com.trs.components.wcm.publish.tagparser

com.trs.components.common.publish.domain.tagparser 中 TagParserCMSObjBase 的使用

com.trs.components.common.publish.domain.tagparser 中 TagParserCMSObjBase 的子类
class | TagParserCMSObj Title: TRS 内容协作平台（TRS WCM） Description: default implementation for CMSObj tag parser.
class | TagParserContentBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserDetailPage
class | TagParserFolderBase Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagParserUser

com.trs.components.metadata.publish 中 TagParserCMSObjBase 的使用

com.trs.components.metadata.publish 中 TagParserCMSObjBase 的子类
class | WCMTagParserClassInfo
class | WCMTagParserViewData
class | WCMTagParserViewField Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser 中 TagParserCMSObjBase 的使用

com.trs.components.wcm.publish.tagparser 中 TagParserCMSObjBase 的子类
class | TagDocbakParser
class | WCMTagParserChannel Title: TRS 内容协作平台（TRS WCM） Description: The Parser For TRS_CHANNEL Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDocReply Title: TRS 内容协作平台（TRS WCM） Description: 文档回复的发布置标解释器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDocument Title: TRS 内容协作平台（TRS WCM） Description: parser for Grammer: <TRS_COLUMN ID="字段名" [[NUM="最大长度" [TRUNCATEDFLAG="长度裁减标记"]] [DATEFORMAT="日期格式"][AUTOFORMAT="自动格式化"] [AUTOLINK="是否自动产生链接 "][TARGET="窗口目标"][EXTRA="扩展HTML内容"] ]>通用细览 </TRS_COLUMN> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDocumentForBJGOV Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserWebSite
class | WCMTagParserXDocument

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserCondition 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserCondition
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserCondition 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserCondition.Operator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserCondition.Operator
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserCondition.Operator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserContentBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserContentBase
的使用

使用 TagParserContentBase 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.metadata.publish
com.trs.components.wcm.publish.tagparser

com.trs.components.common.publish.domain.tagparser 中 TagParserContentBase 的使用

com.trs.components.common.publish.domain.tagparser 中 TagParserContentBase 的子类
 class TagParserDetailPage

com.trs.components.metadata.publish 中 TagParserContentBase 的使用

com.trs.components.metadata.publish 中 TagParserContentBase 的子类
class | WCMTagParserViewData
class | WCMTagParserViewField Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser 中 TagParserContentBase 的使用

com.trs.components.wcm.publish.tagparser 中 TagParserContentBase 的子类
class | TagDocbakParser
class | WCMTagParserDocument Title: TRS 内容协作平台（TRS WCM） Description: parser for Grammer: <TRS_COLUMN ID="字段名" [[NUM="最大长度" [TRUNCATEDFLAG="长度裁减标记"]] [DATEFORMAT="日期格式"][AUTOFORMAT="自动格式化"] [AUTOLINK="是否自动产生链接 "][TARGET="窗口目标"][EXTRA="扩展HTML内容"] ]>通用细览 </TRS_COLUMN> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDocumentForBJGOV Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserXDocument

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserDateTime 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserDateTime
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserDateTime 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects
的使用

使用 TagParserDefaultObjects 的软件包
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.publish.tagparser 中 TagParserDefaultObjects 的使用

com.trs.components.wcm.publish.tagparser 中 TagParserDefaultObjects 的子类
class | WCMTagParserDefaultObjectsInChannel
class | WCMTagParserDefaultObjectsInChannelBase

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPage 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPage
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserDetailPage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPages 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPages
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserDetailPages 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserEcho 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserEcho
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserEcho 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParseResults 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParseResults
的使用

使用 TagParseResults 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TagParseResults 的使用

返回 TagParseResults 的 com.trs.components.common.publish.domain.tagparser 中的方法
TagParseResults | TagParseResults.append(java.lang.String _sResult) Appends a string to each of current results
TagParseResults | TagParseResults.append(java.lang.String[] _results) Appends the product of the specified results and current results.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserFactory
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserFolderBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
的使用

使用 TagParserFolderBase 的软件包
com.trs.components.metadata.publish
com.trs.components.wcm.publish.tagparser

com.trs.components.metadata.publish 中 TagParserFolderBase 的使用

com.trs.components.metadata.publish 中 TagParserFolderBase 的子类
 class WCMTagParserClassInfo

com.trs.components.wcm.publish.tagparser 中 TagParserFolderBase 的使用

com.trs.components.wcm.publish.tagparser 中 TagParserFolderBase 的子类
class | WCMTagParserChannel Title: TRS 内容协作平台（TRS WCM） Description: The Parser For TRS_CHANNEL Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserWebSite

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserRepeat 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserRepeat
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserRepeat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserUser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserUser
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserUser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserVariable 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserVariable
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserVariable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet
的使用

没有 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TemplateParameter
的使用

使用 TemplateParameter 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TemplateParameter 的使用

返回 TemplateParameter 的 com.trs.components.common.publish.domain.tagparser 中的方法
TemplateParameter | TemplateParameterList.getParameter(java.lang.String _name) 返回指定名称的形式参数对象
TemplateParameter | TemplateParameter.getPreDeclared() 返回预先声明同名变量时使用的对象
TemplateParameter | TagItem.getVariableParameter(java.lang.String _sName) 返回指定名称的可变模板参数对象

参数类型为 TemplateParameter 的 com.trs.components.common.publish.domain.tagparser 中的方法
void | TemplateParameterList.addParameter(TemplateParameter _parameter) 向参数列表中增加参数
void | TemplateParameter.setPreDeclared(TemplateParameter preDeclared) 设置预先声明同名变量时使用的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Token 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Token
的使用

使用 TemplateParameter.Token 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TemplateParameter.Token 的使用

返回 TemplateParameter.Token 的 com.trs.components.common.publish.domain.tagparser 中的方法
 TemplateParameter.Token[] TemplateParameter.getEnumValue()
返回有效的变量值的列表数组，如果变量值不是枚举类型，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type
的使用

使用 TemplateParameter.Type 的软件包
com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.tagparser 中 TemplateParameter.Type 的使用

声明为 TemplateParameter.Type 的 com.trs.components.common.publish.domain.tagparser 中的字段
static TemplateParameter.Type | TemplateParameter.Type.BOOLEAN 逻辑类型的变量，其值必须是10个数字和减号
static TemplateParameter.Type | TemplateParameter.Type.INTEGER 整数类型的变量，其值必须是10个数字和减号
static TemplateParameter.Type | TemplateParameter.Type.MULTI
static TemplateParameter.Type | TemplateParameter.Type.NUMBER 数值类型的变量，其值必须是10个数字、减号和小数点
static TemplateParameter.Type | TemplateParameter.Type.STRING 字符串类型的变量，其值可以是任意字符串

返回 TemplateParameter.Type 的 com.trs.components.common.publish.domain.tagparser 中的方法
 TemplateParameter.Type TemplateParameter.getParameterType()
返回形式参数的类型

参数类型为 TemplateParameter.Type 的 com.trs.components.common.publish.domain.tagparser 中的方法
 void TemplateParameter.setParameterType(TemplateParameter.Type parameterType)
设置形式参数的类型

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList
的使用

使用 TemplateParameterList 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.persistent.template
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain.tagparser 中 TemplateParameterList 的使用

参数类型为 TemplateParameterList 的 com.trs.components.common.publish.domain.tagparser 中的方法
 void TemplateParameterList.addParameterList(TemplateParameterList _list)
在批模式下，增加参数列表

com.trs.components.common.publish.persistent.template 中 TemplateParameterList 的使用

返回 TemplateParameterList 的 com.trs.components.common.publish.persistent.template 中的方法
TemplateParameterList | Template.getTemplateParameters() 返回模板中所有形式参数的列表
TemplateParameterList | Template.getTemplateParameters(boolean zRecursion) 返回模板中所有形式参数的列表

参数类型为 TemplateParameterList 的 com.trs.components.common.publish.persistent.template 中的方法
 void Template.setTemplateParameters(TemplateParameterList list)
设置模板中的形式参数的列表 该方法仅供类型'TemplateParseMgr'调用，本来模板中的形式参数列表应该在模板类内部完成， 但是因为还涉及到参数实际值的清除，以及模板修改后形式参数列表的替换等问题，所以将形式 参数列表的构造移动到类型'TemplateParseMgr'中。

com.trs.service 中 TemplateParameterList 的使用

返回 TemplateParameterList 的 com.trs.service 中的方法
TemplateParameterList | ITemplateService.getTemplateParameters(IPublishElement _element) 返回指定发布对象使用的所有模板中的全部形式参数列表
TemplateParameterList | ITemplateService.getTemplateParameters(IPublishElement _element, boolean zRecursion) 返回指定发布对象使用的所有模板中的全部形式参数列表

com.trs.service.impl 中 TemplateParameterList 的使用

返回 TemplateParameterList 的 com.trs.service.impl 中的方法
TemplateParameterList | TemplateService.getTemplateParameters(IPublishElement _element)
TemplateParameterList | TemplateService.getTemplateParameters(IPublishElement _element, boolean zRecursion)

参数类型为 TemplateParameterList 的 com.trs.service.impl 中的方法
 void TemplateService.addNestedParameters(IPublishElement _element, Template template, TemplateParameterList list)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BatchDetailPageTask

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 BatchDetailPageTask

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask
所有已实现的接口：
IPageTask, org.aton.container.IClearable
public class BatchDetailPageTask
extends java.lang.Object
implements IPageTask, org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
batch page task.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BatchDetailPageTask(IPublishFolder _folder, boolean _bPublishAll)
Constructor.
BatchDetailPageTask(IPublishFolder _folder, boolean _bPublishAll, int _nBatchContentsModal)
方法摘要
void | clear()
java.lang.String | getInfo() Returns this page task information.
SinglePageTask | getNext() Returns the next page task to execute.
IPublishElement | getPublishElement()
boolean | isBatch() Returns true if this task is a batch task.
void | setPublishElement(IPublishElement _element)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BatchDetailPageTask

public BatchDetailPageTask(IPublishFolder _folder,
                           boolean _bPublishAll)
Constructor.

参数：
_folder - the contents folder.
_bPublishAll - true, to publish all the contents in the folder; otherwise, to publish increasing contents.

BatchDetailPageTask

public BatchDetailPageTask(IPublishFolder _folder,
                           boolean _bPublishAll,
                           int _nBatchContentsModal)
方法详细信息

getInfo

public java.lang.String getInfo()
从接口 IPageTask 复制的描述
Returns this page task information.

指定者：
接口 IPageTask 中的 getInfo
返回：
this page task information.
另请参见：
IPageTask.getInfo()

isBatch

public boolean isBatch()
从接口 IPageTask 复制的描述
Returns true if this task is a batch task.

指定者：
接口 IPageTask 中的 isBatch
返回：
true if this task is a batch task.
另请参见：
IPageTask.isBatch()

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

getNext

public SinglePageTask getNext()
                       throws WCMException
Returns the next page task to execute.

返回：
the next page task to execute.
抛出：
WCMException - if failed to get the next page task.

getPublishElement

public IPublishElement getPublishElement()
指定者：
接口 IPageTask 中的 getPublishElement

setPublishElement

public void setPublishElement(IPublishElement _element)
指定者：
接口 IPageTask 中的 setPublishElement
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IAtomTask

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 IAtomTask

public interface IAtomTask

原子任务。无法进一步分解的子任务，在原子任务执行期间，任务不能取消，也无法中断。

作者：
Martin (付成睿)

字段摘要
static int | RESULT_CONTINUE 执行结果，可以继续执行
static int | RESULT_FAILED 执行结果，已经执行失败
static int | RESULT_SUSPEND 执行结果，需要暂时挂起
方法摘要
 int execute()
执行该原子任务并返回执行结果 该方法的实现因该在其内部处理所有的异常信息，该方法抛出任何异常，都意味着整个发布任务失败。

字段详细信息

RESULT_CONTINUE

static final int RESULT_CONTINUE
执行结果，可以继续执行

另请参见：
常量字段值

RESULT_SUSPEND

static final int RESULT_SUSPEND
执行结果，需要暂时挂起

另请参见：
常量字段值

RESULT_FAILED

static final int RESULT_FAILED
执行结果，已经执行失败

另请参见：
常量字段值
方法详细信息

execute

int execute()
执行该原子任务并返回执行结果 该方法的实现因该在其内部处理所有的异常信息，该方法抛出任何异常，都意味着整个发布任务失败。 而且该方法的返回值必须是下列值之一，任何其他值也会导致整个发布任务失败。
RESULT_CONTINUE | 可以继续执行
RESULT_CONTINUE | 需要暂时挂起
RESULT_CONTINUE | 已经执行失败

返回：
执行结果
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IAtomTaskList

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 IAtomTaskList

所有超级接口：
org.aton.container.IClearable
public interface IAtomTaskList
extends org.aton.container.IClearable

批量原子任务的列表

作者：
Martin (付成睿)

方法摘要
java.lang.String | getInfo() 返回该任务列表的描述信息
IAtomTask | getNextTask() 返回列表中的下一个任务，如果列表中为空或者已经没有任务，则返回null。
从接口 org.aton.container.IClearable 继承的方法
clear

方法详细信息

getInfo

java.lang.String getInfo()
返回该任务列表的描述信息

返回：
任务列表的描述信息

getNextTask

IAtomTask getNextTask()
返回列表中的下一个任务，如果列表中为空或者已经没有任务，则返回null。

返回：
列表中的下一个任务，或者null
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ILaborResourceMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 ILaborResourceMgr

所有超级接口：
org.aton.container.IClearable
所有已知实现类：
LaborResourceMgrImpl
public interface ILaborResourceMgr
extends org.aton.container.IClearable

方法摘要
int | applyForLabor(int _nMaxNeed, int _nReqLevel) apply for labor
int | calMaxLaborNeeded(int _nTaskCount, int _nReqLevel) calculate the maximum count of the labor needed to finish the specified task
void | configure(IConfigElement _config) configure the manager
boolean | hasFreeLabor(int _nReqLevel)
void | releaseLabor(int _nCount, int _nReqLevel) release the labor who has finished its work
从接口 org.aton.container.IClearable 继承的方法
clear

方法详细信息

configure

void configure(IConfigElement _config)
               throws java.lang.Exception
configure the manager

参数：
_properties - the configuration which is stored as mappings.
抛出：
java.lang.Exception - if failed to save the configurations.

calMaxLaborNeeded

int calMaxLaborNeeded(int _nTaskCount,
                      int _nReqLevel)
calculate the maximum count of the labor needed to finish the specified task

参数：
_nTaskCount - count of the task
_nReqLevel - level of the request
返回：

hasFreeLabor

boolean hasFreeLabor(int _nReqLevel)
参数：
_nReqLevel - quest level: high, normal, low
返回：
Returns if has free labor

applyForLabor

int applyForLabor(int _nMaxNeed,
                  int _nReqLevel)
apply for labor

参数：
_nMaxNeed - maximum labor needed
_nReqLevel - quest level: high, normal, low
返回：
count of the labor applied

releaseLabor

void releaseLabor(int _nCount,
                  int _nReqLevel)
release the labor who has finished its work

参数：
_nCount - count of the labor to release
_nReqLevel - request level
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPageTask

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 IPageTask

所有已知实现类：
BatchDetailPageTask, PageDestoryTask, SinglePageTask
public interface IPageTask

Title: TRS 内容协作平台（TRS WCM）
Description:
page task interface.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String | getInfo() Returns this page task information.
IPublishElement | getPublishElement()
boolean | isBatch() Returns true if this task is a batch task.
void | setPublishElement(IPublishElement _element)

方法详细信息

getInfo

java.lang.String getInfo()
Returns this page task information.

返回：
this page task information.

isBatch

boolean isBatch()
Returns true if this task is a batch task.

返回：
true if this task is a batch task.

getPublishElement

IPublishElement getPublishElement()

setPublishElement

void setPublishElement(IPublishElement _element)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPageTaskDispatcher

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 IPageTaskDispatcher

所有已知实现类：
PublishTaskWorker
public interface IPageTaskDispatcher

Title: TRS 内容协作平台（TRS WCM）
Description:
page task dispatcher interface.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
IPageTask | getNextPageTask() Returns the next task to execute.
void | notifyPageTaskFinished(IPageTask _task) notify one page generating task has been finished
void | notifyPageTaskWorkerFinished(int _nResult) notify that one PageTaskWorker has finished.

方法详细信息

getNextPageTask

IPageTask getNextPageTask()
Returns the next task to execute.

返回：
the next task to execute.

notifyPageTaskFinished

void notifyPageTaskFinished(IPageTask _task)
notify one page generating task has been finished

参数：
_task - the page generating task

notifyPageTaskWorkerFinished

void notifyPageTaskWorkerFinished(int _nResult)
notify that one PageTaskWorker has finished.

参数：
_nResult - result of the work
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishElementsIterator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 IPublishElementsIterator

所有超级接口：
java.util.Iterator
所有已知实现类：
PublishElementsIteratorDocumentsImpl
public interface IPublishElementsIterator
extends java.util.Iterator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 void clear()
从接口 java.util.Iterator 继承的方法
hasNext, next, remove

方法详细信息

clear

void clear()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishProgressMonitor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 IPublishProgressMonitor

所有超级接口：
org.aton.container.IClearable
所有已知实现类：
ProgressMonitorImpl
public interface IPublishProgressMonitor
extends org.aton.container.IClearable

用于监控发布任务的执行进程，其实现应该缓存至少10条信息以供察看。

作者：
Martin (付成睿)

方法摘要
java.util.Iterator | buffer() 以java.util.Iterator的形式返回被缓存的信息，从 java.util.Iterator 中迭代得到对象是java.lang.String。
java.lang.String | getId() 返回监控器对象的标识，一般是线程的名称
void | info(java.lang.String msg) 纪录或者输出运行时的信息
从接口 org.aton.container.IClearable 继承的方法
clear

方法详细信息

getId

java.lang.String getId()
返回监控器对象的标识，一般是线程的名称

buffer

java.util.Iterator buffer()
以java.util.Iterator的形式返回被缓存的信息，从 java.util.Iterator 中迭代得到对象是java.lang.String。

info

void info(java.lang.String msg)
纪录或者输出运行时的信息

参数：
msg - 待纪录或输出的信息
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishTaskDispatcher

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 IPublishTaskDispatcher

所有已知实现类：
PublishTaskDispatcherImpl, TaskDispatcher
public interface IPublishTaskDispatcher

Title: TRS 内容协作平台（TRS WCM）
Description:
interface for publish task dispatcher.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | cancelTask(int _nTaskId) cancel a publish task by the specified id
boolean | changeTaskPriority(int iTask, int iPriority) 改变任务的优先级别，如果任务不是正在执行则什么都不作
PublishTask | getRunningTask(int iTaskID) 返回指定ID的正在执行的发布任务对象
java.util.Iterator | getRunningTasks() 返回所有的正在执行的任务
PublishTaskRuntime | getTaskRuntime(int iTaskID) 返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
boolean | pauseTask(int iTaskID) 暂停指定发布任务的执行,如果指定ID的发布任务还没有执行或者已经执行结束则什么都不作。
void | pushTask(PublishTask _task) push a publish task into the queue
boolean | resumeTask(int iTaskID) 恢复指定的已经暂停的发布任务的执行,如果指定的并不是处于暂停状态则什么都不作。
void | shutdown() shutdown the dispatcher
void | startup() startup the dispatcher

方法详细信息

startup

void startup()
             throws WCMException
startup the dispatcher

抛出：
WCMException - if failed to startup

shutdown

void shutdown()
shutdown the dispatcher

pushTask

void pushTask(PublishTask _task)
              throws WCMException
push a publish task into the queue

参数：
_task - the specified publish task
抛出：
WCMException - if failed to push the task into the waiting queue.

pauseTask

boolean pauseTask(int iTaskID)
                  throws WCMException
暂停指定发布任务的执行,如果指定ID的发布任务还没有执行或者已经执行结束则什么都不作。

参数：
iTaskID - 待操作的发布任务的ID
返回：
如果成功的暂停了任务则返回true，否则如果指定ID的发布任务不存在， 或者还没有执行或者已经执行，则返回false
抛出：
WCMException - 如果发生错误

resumeTask

boolean resumeTask(int iTaskID)
                   throws WCMException
恢复指定的已经暂停的发布任务的执行,如果指定的并不是处于暂停状态则什么都不作。

参数：
iTaskID - 待操作的发布任务的ID
返回：
如果成功的恢复了任务则返回true，否则如果指定ID的发布任务不存在， 或者并不是处于暂停状态，则返回 false
抛出：
WCMException - 如果发生错误

cancelTask

boolean cancelTask(int _nTaskId)
                   throws WCMException
cancel a publish task by the specified id

参数：
_nTaskId - id of the task
返回：
Returns true if the task has been found and canceled successfully; otherwise, returns false.
抛出：
WCMException - if encounters errors when to seek or cancel the publish task

changeTaskPriority

boolean changeTaskPriority(int iTask,
                           int iPriority)
改变任务的优先级别，如果任务不是正在执行则什么都不作

参数：
iTask - 指定任务的ID
iPriority - 新的优先级别
返回：
成功改变优先级则返回true，否则返回false

getTaskRuntime

PublishTaskRuntime getTaskRuntime(int iTaskID)
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。

参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回其运行时对象PublishTaskRuntime， 否则返回 null。

getRunningTask

PublishTask getRunningTask(int iTaskID)
返回指定ID的正在执行的发布任务对象

参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回发布任务对象，否则返回null。

getRunningTasks

java.util.Iterator getRunningTasks()
返回所有的正在执行的任务

返回：
所有的正在执行的任务
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishTaskMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
接口 IPublishTaskMgr

所有已知实现类：
PublishTaskMgrImpl
public interface IPublishTaskMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
PublishTask | createContentPublishTask(IPublishContent _content, int _nPublishType) create a content publish task
PublishTask | createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType) create a content publish task
PublishTask | createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)
PublishTask | createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)
PublishTask | createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders) 创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
PublishTask | createFolderPublishTask(IPublishFolder _folder, int _nPublishType) create a folder publish task
boolean | delete(PublishTask _task) delete a publish task
PublishTasks | getMyTasks(WCMFilter _filter) get the publish tasks created by the specified user
PublishTasks | getTasks(WCMFilter _filter) get the tasks collection with the specified filter
PublishTasks | getUnfinishedTasks() get the tasks collection who have not been finished.
PublishTask | save(PublishTask _task) save the publish task which is created or updated

方法详细信息

save

PublishTask save(PublishTask _task)
                 throws WCMException
save the publish task which is created or updated

参数：
_task - the publish task to save
返回：
Returns the save task
抛出：
WCMException - if fails to save the task data

delete

boolean delete(PublishTask _task)
               throws WCMException
delete a publish task

参数：
_task - the specified publish task
返回：
Returns true if the publish task is deleted successfully; otherwise, returns false.
抛出：
WCMException - if fails to delete the publish task.

getMyTasks

PublishTasks getMyTasks(WCMFilter _filter)
                        throws WCMException
get the publish tasks created by the specified user

参数：
_filter - the collection filter
返回：
Returns the tasks collection of the current user
抛出：
java.lang.Exception - if failed to fetch the tasks collection
WCMException

getTasks

PublishTasks getTasks(WCMFilter _filter)
                      throws WCMException
get the tasks collection with the specified filter

参数：
_filter - filter for the collection
返回：
Returns the tasks collection
抛出：
WCMException - if failed to fetch the publish tasks.

getUnfinishedTasks

PublishTasks getUnfinishedTasks()
                                throws WCMException
get the tasks collection who have not been finished.

返回：
Returns the unfinished tasks collection
抛出：
WCMException - if failed to fetch the unfinished tasks.

createFolderPublishTask

PublishTask createFolderPublishTask(IPublishFolder _folder,
                                    int _nPublishType)
                                    throws WCMException
create a folder publish task

参数：
_folder - the folder to publish
_nPublishType - the publish type which is defined in PublishConstants like PUBLISH_AlL, PUBLISH_INC etc.
返回：
Returns the publish task created.
抛出：
WCMException - if failed to create the publish task

createDeleteContentsSynPublishTask

PublishTask createDeleteContentsSynPublishTask(IPublishFolder _folder,
                                               IPublishElements _contents)
                                               throws WCMException
参数：
_folder -
_contents -
返回：
抛出：
WCMException

createDeleteContentsSynPublishTask

PublishTask createDeleteContentsSynPublishTask(IPublishFolder _folder,
                                               IPublishContent _content)
                                               throws WCMException
抛出：
WCMException

createContentPublishTask

PublishTask createContentPublishTask(IPublishContent _content,
                                     int _nPublishType)
                                     throws WCMException
create a content publish task

参数：
_content - the content to publish
_nPublishType - the publish type which is defined in PublishConstants like PUBLISH_AlL, PUBLISH_INC etc.
返回：
Returns the publish task created.
抛出：
WCMException - if failed to create the publish task

createContentPublishTask

PublishTask createContentPublishTask(IPublishElements _contents,
                                     IPublishFolder _folder,
                                     int _nPublishType)
                                     throws WCMException
create a content publish task

参数：
_contents - the collection of publish contents
_folder - the folder where the contents lie
_nPublishType - the publish type which is defined in PublishConstants like PUBLISH_AlL, PUBLISH_INC etc.
返回：
Returns the publish task created.
抛出：
WCMException - if failed to create the publish task

createContentPublishTask

PublishTask createContentPublishTask(IPublishContent _content,
                                     IPublishFolder _folder,
                                     IPublishElements _folders)
                                     throws WCMException
创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）

抛出：
WCMException

createDestroyPublishTask

PublishTask createDestroyPublishTask(IPublishElements _contents,
                                     IPublishFolder _folder,
                                     IPublishElements _folders)
                                     throws WCMException
创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）

抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LaborResourceMgrImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 LaborResourceMgrImpl

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl
所有已实现的接口：
ILaborResourceMgr, org.aton.container.IClearable
public class LaborResourceMgrImpl
extends java.lang.Object
implements ILaborResourceMgr

构造方法摘要
LaborResourceMgrImpl()
constructor: default
方法摘要
int | applyForLabor(int _nMaxNeed, int _nPriority) apply for labor
int | calMaxLaborNeeded(int _nTaskCount, int _nPriority) calculate the maximum count of the labor needed to finish the specified task
void | clear() clear the object
void | configure(IConfigElement _config) configure the manager
boolean | hasFreeLabor(int _nPriority)
void | releaseLabor(int _nCount, int _nPriority) release the labor who has finished its work
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LaborResourceMgrImpl

public LaborResourceMgrImpl()
constructor: default

方法详细信息

clear

public void clear()
clear the object

指定者：
接口 org.aton.container.IClearable 中的 clear

configure

public void configure(IConfigElement _config)
               throws java.lang.Exception
从接口 ILaborResourceMgr 复制的描述
configure the manager

指定者：
接口 ILaborResourceMgr 中的 configure
抛出：
java.lang.Exception - if failed to save the configurations.

calMaxLaborNeeded

public int calMaxLaborNeeded(int _nTaskCount,
                             int _nPriority)
calculate the maximum count of the labor needed to finish the specified task

指定者：
接口 ILaborResourceMgr 中的 calMaxLaborNeeded
参数：
_nTaskCount - count of the task
_nPriority - level of the request
返回：

hasFreeLabor

public boolean hasFreeLabor(int _nPriority)
指定者：
接口 ILaborResourceMgr 中的 hasFreeLabor
参数：
_nPriority - quest level: high, normal, low
返回：
Returns if has free labor

applyForLabor

public int applyForLabor(int _nMaxNeed,
                         int _nPriority)
apply for labor

指定者：
接口 ILaborResourceMgr 中的 applyForLabor
参数：
_nMaxNeed - maximum labor needed
_nPriority - quest level: high, normal, low
返回：
count of the labor applied

releaseLabor

public void releaseLabor(int _nCount,
                         int _nPriority)
release the labor who has finished its work

指定者：
接口 ILaborResourceMgr 中的 releaseLabor
参数：
_nCount - count of the labor to release
_nPriority - request level
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.domain.taskdispatch
接口
IAtomTask
IAtomTaskList
ILaborResourceMgr
IPageTask
IPageTaskDispatcher
IPublishElementsIterator
IPublishProgressMonitor
IPublishTaskDispatcher
IPublishTaskMgr
类
BatchDetailPageTask
LaborResourceMgrImpl
PageDestoryTask
PageTaskWorker
ProgressMonitorImpl
PublishTaskAnalyzer
PublishTaskDispatcherImpl
PublishTaskMgrImpl
PublishTaskRuntime
PublishTaskWorker
SinglePageTask
TaskDispatcher
TaskWorker
ThreadPool


com.trs.components.common.publish.domain.taskdispatch

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.domain.taskdispatch

接口摘要
IAtomTask | 原子任务。
IAtomTaskList | 批量原子任务的列表
ILaborResourceMgr |
IPageTask | Title: TRS 内容协作平台（TRS WCM） Description: page task interface.
IPageTaskDispatcher | Title: TRS 内容协作平台（TRS WCM） Description: page task dispatcher interface.
IPublishElementsIterator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IPublishProgressMonitor | 用于监控发布任务的执行进程，其实现应该缓存至少10条信息以供察看。
IPublishTaskDispatcher | Title: TRS 内容协作平台（TRS WCM） Description: interface for publish task dispatcher.
IPublishTaskMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
BatchDetailPageTask | Title: TRS 内容协作平台（TRS WCM） Description: batch page task.
LaborResourceMgrImpl |
PageDestoryTask | Title: TRS 内容协作平台（TRS WCM） Description: 撤销发布任务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PageTaskWorker | Title: TRS 内容协作平台（TRS WCM） Description: worker to execute the page task.
ProgressMonitorImpl | 发布进程监控器IPublishProgressMonitor的缺省实现
PublishTaskAnalyzer | Title: TRS 内容协作平台（TRS WCM） Description: publish task analyzer.
PublishTaskDispatcherImpl | Title: TRS 内容协作平台（TRS WCM） Description: the publish task dispatcher implementation.
PublishTaskMgrImpl | Title: TRS 内容协作平台（TRS WCM） Description: implementation for IPublishTaskMgr Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishTaskRuntime | 秒数发布任务的运行时状态
PublishTaskWorker | Title: TRS 内容协作平台（TRS WCM） Description: worker to execute publish task.
SinglePageTask | Title: TRS 内容协作平台（TRS WCM） Description: interface of page task.
TaskDispatcher | IPublishTaskDispatcher的新实现，用以替换 PublishTaskDispatcherImpl。
TaskWorker | 执行任务的Worker，执行原子任务 IAtomTask 的对象
ThreadPool | 线程池


com.trs.components.common.publish.domain.taskdispatch 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.taskdispatch 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask (implements org.aton.container.IClearable, com.trs.components.common.publish.domain.taskdispatch.IPageTask)
    • com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl (implements com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr)
    • com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask (implements com.trs.components.common.publish.domain.taskdispatch.IPageTask)
    • com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker (implements org.aton.container.IClearable, java.lang.Runnable)
    • com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl (implements com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor)
    • com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer (implements org.aton.container.IClearable)
    • com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl (implements com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr)
    • com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime
    • com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker (implements org.aton.container.IClearable, com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher, java.lang.Runnable)
    • com.trs.components.common.publish.domain.taskdispatch.SinglePageTask (implements com.trs.components.common.publish.domain.taskdispatch.IPageTask)
    • com.trs.components.common.publish.domain.taskdispatch.TaskWorker (implements java.lang.Runnable)
    • java.lang.Thread (implements java.lang.Runnable)
      • com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl (implements org.aton.container.IClearable, com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher)
      • com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher (implements org.aton.container.IClearable, com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher)
    • com.trs.components.common.publish.domain.taskdispatch.ThreadPool

接口分层结构

  • com.trs.components.common.publish.domain.taskdispatch.IAtomTask
  • org.aton.container.IClearable
    • com.trs.components.common.publish.domain.taskdispatch.IAtomTaskList
    • com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr
    • com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor
  • com.trs.components.common.publish.domain.taskdispatch.IPageTask
  • com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher
  • com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher
  • com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr
  • java.util.Iterator
    • com.trs.components.common.publish.domain.taskdispatch.IPublishElementsIterator


软件包 com.trs.components.common.publish.domain.taskdispatch 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.taskdispatch
的使用

使用 com.trs.components.common.publish.domain.taskdispatch 的软件包
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.persistent.element
com.trs.components.metadata.publish
com.trs.components.wcm.epress
com.trs.components.wcm.publish.element
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
PublishTaskRuntime
秒数发布任务的运行时状态

com.trs.components.common.publish.domain.publisher 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
IPublishProgressMonitor
用于监控发布任务的执行进程，其实现应该缓存至少10条信息以供察看。

com.trs.components.common.publish.domain.taskdispatch 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
IAtomTask
原子任务。
ILaborResourceMgr
IPageTask
Title: TRS 内容协作平台（TRS WCM）
Description:
page task interface.
IPageTaskDispatcher
Title: TRS 内容协作平台（TRS WCM）
Description:
page task dispatcher interface.
IPublishProgressMonitor
用于监控发布任务的执行进程，其实现应该缓存至少10条信息以供察看。
IPublishTaskDispatcher
Title: TRS 内容协作平台（TRS WCM）
Description:
interface for publish task dispatcher.
IPublishTaskMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishTaskRuntime
秒数发布任务的运行时状态
PublishTaskWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
worker to execute publish task.
SinglePageTask
Title: TRS 内容协作平台（TRS WCM）
Description:
interface of page task.

com.trs.components.common.publish.persistent.element 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
IPublishElementsIterator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.publish 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
IPublishElementsIterator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
IPublishElementsIterator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.element 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
IPublishElementsIterator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
PublishTaskRuntime
秒数发布任务的运行时状态

com.trs.service.impl 使用的 com.trs.components.common.publish.domain.taskdispatch 中的类
PublishTaskRuntime
秒数发布任务的运行时状态

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageDestoryTask

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 PageDestoryTask

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask
所有已实现的接口：
IPageTask
public class PageDestoryTask
extends java.lang.Object
implements IPageTask

Title: TRS 内容协作平台（TRS WCM）
Description:
撤销发布任务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PageDestoryTask(IPublishElement _element)
方法摘要
java.lang.String | getInfo() Returns this page task information.
IPublishElement | getPublishElement()
boolean | isBatch() Returns true if this task is a batch task.
void | setPublishElement(IPublishElement _element)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageDestoryTask

public PageDestoryTask(IPublishElement _element)
方法详细信息

getInfo

public java.lang.String getInfo()
从接口 IPageTask 复制的描述
Returns this page task information.

指定者：
接口 IPageTask 中的 getInfo
返回：
this page task information.

isBatch

public boolean isBatch()
从接口 IPageTask 复制的描述
Returns true if this task is a batch task.

指定者：
接口 IPageTask 中的 isBatch
返回：
true if this task is a batch task.

getPublishElement

public IPublishElement getPublishElement()
指定者：
接口 IPageTask 中的 getPublishElement

setPublishElement

public void setPublishElement(IPublishElement _element)
指定者：
接口 IPageTask 中的 setPublishElement
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageTaskWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 PageTaskWorker

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker
所有已实现的接口：
java.lang.Runnable, org.aton.container.IClearable
public class PageTaskWorker
extends java.lang.Object
implements java.lang.Runnable, org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
worker to execute the page task.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PageTaskWorker(IPageTaskDispatcher _dispatcher, PublishTaskContext _publishTaskContext)
constructor
PageTaskWorker(IPageTaskDispatcher _dispatcher, PublishTaskContext _publishTaskContext, IPublishProgressMonitor _monitor)
constructor
方法摘要
void | cancel() cancel the task work
void | clear()
java.lang.String | getName()
IPublishProgressMonitor | getProgressMonitor()
void | run()
void | start()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageTaskWorker

public PageTaskWorker(IPageTaskDispatcher _dispatcher,
                      PublishTaskContext _publishTaskContext)
constructor

参数：
_dispatcher - the page task dispatcher.
_publishTaskContext - the publish task context

PageTaskWorker

public PageTaskWorker(IPageTaskDispatcher _dispatcher,
                      PublishTaskContext _publishTaskContext,
                      IPublishProgressMonitor _monitor)
constructor

参数：
_dispatcher - the page task dispatcher.
_publishTaskContext - the publish task context
方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

cancel

public void cancel()
cancel the task work

run

public void run()
指定者：
接口 java.lang.Runnable 中的 run

getProgressMonitor

public IPublishProgressMonitor getProgressMonitor()
返回：
Returns the progressMonitor.

getName

public java.lang.String getName()

start

public void start()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProgressMonitorImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 ProgressMonitorImpl

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl
所有已实现的接口：
IPublishProgressMonitor, org.aton.container.IClearable
public class ProgressMonitorImpl
extends java.lang.Object
implements IPublishProgressMonitor

发布进程监控器IPublishProgressMonitor的缺省实现

作者：
Martin (付成睿)

构造方法摘要
ProgressMonitorImpl()
缺省构造方法
方法摘要
java.util.Iterator | buffer() 以java.util.Iterator的形式返回被缓存的信息，从 java.util.Iterator 中迭代得到对象是java.lang.String。
void | clear()
java.lang.String | getId() 返回监控器对象的标识，一般是线程的名称
void | info(java.lang.String msg) 纪录或者输出运行时的信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ProgressMonitorImpl

public ProgressMonitorImpl()
缺省构造方法

方法详细信息

getId

public java.lang.String getId()
从接口 IPublishProgressMonitor 复制的描述
返回监控器对象的标识，一般是线程的名称

指定者：
接口 IPublishProgressMonitor 中的 getId

buffer

public java.util.Iterator buffer()
从接口 IPublishProgressMonitor 复制的描述
以java.util.Iterator的形式返回被缓存的信息，从 java.util.Iterator 中迭代得到对象是java.lang.String。

指定者：
接口 IPublishProgressMonitor 中的 buffer

info

public void info(java.lang.String msg)
从接口 IPublishProgressMonitor 复制的描述
纪录或者输出运行时的信息

指定者：
接口 IPublishProgressMonitor 中的 info
参数：
msg - 待纪录或输出的信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTaskAnalyzer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 PublishTaskAnalyzer

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer
所有已实现的接口：
org.aton.container.IClearable
public class PublishTaskAnalyzer
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
publish task analyzer.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int RUN_INTERVAL
running interval time when to wait
构造方法摘要
PublishTaskAnalyzer()
constructor: default
方法摘要
void | cancel() cancel the analyzer
void | clear()
java.lang.String | getErrors() Returns the analyzing erros.
IPublishFolder | getFolder()
IPageTask | getNextPageTask() Fetchs next page task to execute.
int | getPageTaskCount()
int | getWaitingPageTaskCount()
boolean | isCanceld() Returns true if this analyzer has been canceled.
void | notifyPageTaskFinished(IPageTask _pageTask) Notifies one page task has finished
void | start(PublishTask _task) start to analyze the publish task.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RUN_INTERVAL

public static int RUN_INTERVAL
running interval time when to wait

构造方法详细信息

PublishTaskAnalyzer

public PublishTaskAnalyzer()
constructor: default

方法详细信息

getFolder

public IPublishFolder getFolder()
返回：
Returns the publish folder.

getPageTaskCount

public int getPageTaskCount()
返回：
Returns all the page tasks count.

getWaitingPageTaskCount

public int getWaitingPageTaskCount()
返回：
Returns count of the waiting page tasks.

isCanceld

public boolean isCanceld()
Returns true if this analyzer has been canceled.

返回：
true if this analyzer has been canceled.

getErrors

public java.lang.String getErrors()
Returns the analyzing erros.

返回：
the analyzing erros.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

cancel

public void cancel()
cancel the analyzer

start

public void start(PublishTask _task)
           throws java.lang.Exception
start to analyze the publish task.

参数：
_task - the publish task to execute
抛出：
java.lang.Exception - if failed to analyze the publish task.

getNextPageTask

public IPageTask getNextPageTask()
Fetchs next page task to execute.
Notice: the outline page tasks will be executed only after all the detail page tasks have been executed.

返回：
the page task if found and not canceled;
otherwise, returns null.

notifyPageTaskFinished

public void notifyPageTaskFinished(IPageTask _pageTask)
Notifies one page task has finished

参数：
_pageTask - the page task
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTaskDispatcherImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 PublishTaskDispatcherImpl

java.lang.Object
    继承者  java.lang.Thread
        继承者  com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl
所有已实现的接口：
IPublishTaskDispatcher, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, java.lang.Runnable, org.aton.container.IClearable
public class PublishTaskDispatcherImpl
extends java.lang.Thread
implements IPublishTaskDispatcher, org.aton.container.IClearable, IObjectLCListenerOnAdd, IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
the publish task dispatcher implementation.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

嵌套类摘要
从类 java.lang.Thread 继承的嵌套类/接口
java.lang.Thread.State, java.lang.Thread.UncaughtExceptionHandler
字段摘要
static int RUN_INTERVAL
interval time when running
从类 java.lang.Thread 继承的字段
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
构造方法摘要
PublishTaskDispatcherImpl()
constructor: default
方法摘要
boolean | cancelTask(int _nTaskId) cancel a publish task by the specified id
boolean | changeTaskPriority(int iTask, int iPriority) 改变任务的优先级别，如果任务不是正在执行则什么都不作
void | clear() clear the resouce
void | freeDeadLock() 消除死锁
java.util.Iterator | getRunningMonitors(int iTaskID)
PublishTask | getRunningTask(int iTaskID) 返回指定ID的正在执行的发布任务对象
java.util.Iterator | getRunningTasks() 返回所有的正在执行的任务
PublishTaskWorker | getRunningWorker(int iTaskID) 返回和指定的发布任务ID相关联的 PublishTaskWorker 对象，如果该发布任务当前正在运行的话。
PublishTaskRuntime | getTaskRuntime(int iTaskID) 返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
boolean | isRunning()
void | notifyOnAddObj(BaseObj objAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
boolean | pauseTask(int iTaskID) 暂停指定发布任务的执行,如果指定ID的发布任务还没有执行或者已经执行结束则什么都不作。
void | pushTask(PublishTask _task) push a publish task into the queue
boolean | resumeTask(int iTaskID) 恢复指定的已经暂停的发布任务的执行,如果指定的并不是处于暂停状态则什么都不作。
void | run() override Thread.run
void | shutdown() shutdown the dispatcher
void | startup() startup the dispatcher
从类 java.lang.Thread 继承的方法
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, stop, stop, suspend, toString, yield
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

RUN_INTERVAL

public static int RUN_INTERVAL
interval time when running

构造方法详细信息

PublishTaskDispatcherImpl

public PublishTaskDispatcherImpl()
constructor: default

方法详细信息

isRunning

public boolean isRunning()
返回：
Returns the running.

clear

public void clear()
clear the resouce

指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

freeDeadLock

public void freeDeadLock()
消除死锁

startup

public void startup()
             throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
startup the dispatcher

指定者：
接口 IPublishTaskDispatcher 中的 startup
抛出：
WCMException - if failed to startup

shutdown

public void shutdown()
从接口 IPublishTaskDispatcher 复制的描述
shutdown the dispatcher

指定者：
接口 IPublishTaskDispatcher 中的 shutdown

run

public void run()
override Thread.run

指定者：
接口 java.lang.Runnable 中的 run
覆盖：
类 java.lang.Thread 中的 run

pushTask

public void pushTask(PublishTask _task)
从接口 IPublishTaskDispatcher 复制的描述
push a publish task into the queue

指定者：
接口 IPublishTaskDispatcher 中的 pushTask
参数：
_task - the specified publish task
另请参见：
IPublishTaskDispatcher.pushTask(PublishTask)

cancelTask

public boolean cancelTask(int _nTaskId)
                   throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
cancel a publish task by the specified id

指定者：
接口 IPublishTaskDispatcher 中的 cancelTask
参数：
_nTaskId - id of the task
返回：
Returns true if the task has been found and canceled successfully; otherwise, returns false.
抛出：
WCMException - if encounters errors when to seek or cancel the publish task
另请参见：
IPublishTaskDispatcher#cancelTask(User, int)

getRunningWorker

public PublishTaskWorker getRunningWorker(int iTaskID)
返回和指定的发布任务ID相关联的 PublishTaskWorker 对象，如果该发布任务当前正在运行的话。 如果该任务没有运行（没有启动或者已经结束），则返回null。

参数：
iTaskID - 指定的任务ID
返回：

getRunningMonitors

public java.util.Iterator getRunningMonitors(int iTaskID)

getRunningTask

public PublishTask getRunningTask(int iTaskID)
从接口 IPublishTaskDispatcher 复制的描述
返回指定ID的正在执行的发布任务对象

指定者：
接口 IPublishTaskDispatcher 中的 getRunningTask
参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回发布任务对象，否则返回null。

getRunningTasks

public java.util.Iterator getRunningTasks()
从接口 IPublishTaskDispatcher 复制的描述
返回所有的正在执行的任务

指定者：
接口 IPublishTaskDispatcher 中的 getRunningTasks
返回：
所有的正在执行的任务

getTaskRuntime

public PublishTaskRuntime getTaskRuntime(int iTaskID)
从接口 IPublishTaskDispatcher 复制的描述
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。

指定者：
接口 IPublishTaskDispatcher 中的 getTaskRuntime
参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回其运行时对象PublishTaskRuntime， 否则返回 null。

pauseTask

public boolean pauseTask(int iTaskID)
                  throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
暂停指定发布任务的执行,如果指定ID的发布任务还没有执行或者已经执行结束则什么都不作。

指定者：
接口 IPublishTaskDispatcher 中的 pauseTask
参数：
iTaskID - 待操作的发布任务的ID
返回：
如果成功的暂停了任务则返回true，否则如果指定ID的发布任务不存在， 或者还没有执行或者已经执行，则返回false
抛出：
WCMException - 如果发生错误

resumeTask

public boolean resumeTask(int iTaskID)
                   throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
恢复指定的已经暂停的发布任务的执行,如果指定的并不是处于暂停状态则什么都不作。

指定者：
接口 IPublishTaskDispatcher 中的 resumeTask
参数：
iTaskID - 待操作的发布任务的ID
返回：
如果成功的恢复了任务则返回true，否则如果指定ID的发布任务不存在， 或者并不是处于暂停状态，则返回 false
抛出：
WCMException - 如果发生错误

changeTaskPriority

public boolean changeTaskPriority(int iTask,
                                  int iPriority)
从接口 IPublishTaskDispatcher 复制的描述
改变任务的优先级别，如果任务不是正在执行则什么都不作

指定者：
接口 IPublishTaskDispatcher 中的 changeTaskPriority
参数：
iTask - 指定任务的ID
iPriority - 新的优先级别
返回：
成功改变优先级则返回true，否则返回false

notifyOnAddObj

public void notifyOnAddObj(BaseObj objAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
objAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTaskMgrImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 PublishTaskMgrImpl

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl
所有已实现的接口：
IPublishTaskMgr
public class PublishTaskMgrImpl
extends java.lang.Object
implements IPublishTaskMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IPublishTaskMgr
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishTaskMgrImpl()
constructor: default
方法摘要
PublishTask | createContentPublishTask(IPublishContent _content, int _nPublishType) create a content publish task
PublishTask | createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType) create a content publish task
PublishTask | createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)
PublishTask | createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)
PublishTask | createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders) 创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
PublishTask | createFolderPublishTask(IPublishFolder _folder, int _nPublishType) create a folder publish task
boolean | delete(PublishTask _task) delete a publish task
PublishTasks | getMyTasks(WCMFilter _filter) get the publish tasks created by the specified user
PublishTasks | getTasks(WCMFilter _filter) get the tasks collection with the specified filter
PublishTasks | getUnfinishedTasks() get the tasks collection who have not been finished.
PublishTask | save(PublishTask _task) save the publish task which is created or updated
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishTaskMgrImpl

public PublishTaskMgrImpl()
constructor: default

方法详细信息

save

public PublishTask save(PublishTask _task)
                 throws WCMException
从接口 IPublishTaskMgr 复制的描述
save the publish task which is created or updated

指定者：
接口 IPublishTaskMgr 中的 save
参数：
_task - the publish task to save
返回：
Returns the save task
抛出：
WCMException - if fails to save the task data
另请参见：
IPublishTaskMgr.save(PublishTask)

delete

public boolean delete(PublishTask _task)
               throws WCMException
从接口 IPublishTaskMgr 复制的描述
delete a publish task

指定者：
接口 IPublishTaskMgr 中的 delete
参数：
_task - the specified publish task
返回：
Returns true if the publish task is deleted successfully; otherwise, returns false.
抛出：
WCMException - if fails to delete the publish task.
另请参见：
IPublishTaskMgr.delete(PublishTask)

getMyTasks

public PublishTasks getMyTasks(WCMFilter _filter)
                        throws WCMException
从接口 IPublishTaskMgr 复制的描述
get the publish tasks created by the specified user

指定者：
接口 IPublishTaskMgr 中的 getMyTasks
参数：
_filter - the collection filter
返回：
Returns the tasks collection of the current user
抛出：
WCMException

getTasks

public PublishTasks getTasks(WCMFilter _filter)
                      throws WCMException
从接口 IPublishTaskMgr 复制的描述
get the tasks collection with the specified filter

指定者：
接口 IPublishTaskMgr 中的 getTasks
参数：
_filter - filter for the collection
返回：
Returns the tasks collection
抛出：
WCMException - if failed to fetch the publish tasks.

getUnfinishedTasks

public PublishTasks getUnfinishedTasks()
                                throws WCMException
从接口 IPublishTaskMgr 复制的描述
get the tasks collection who have not been finished.

指定者：
接口 IPublishTaskMgr 中的 getUnfinishedTasks
返回：
Returns the unfinished tasks collection
抛出：
WCMException - if failed to fetch the unfinished tasks.

createFolderPublishTask

public PublishTask createFolderPublishTask(IPublishFolder _folder,
                                           int _nPublishType)
                                    throws WCMException
从接口 IPublishTaskMgr 复制的描述
create a folder publish task

指定者：
接口 IPublishTaskMgr 中的 createFolderPublishTask
参数：
_folder - the folder to publish
_nPublishType - the publish type which is defined in PublishConstants like PUBLISH_AlL, PUBLISH_INC etc.
返回：
Returns the publish task created.
抛出：
WCMException - if failed to create the publish task

createContentPublishTask

public PublishTask createContentPublishTask(IPublishContent _content,
                                            int _nPublishType)
                                     throws WCMException
从接口 IPublishTaskMgr 复制的描述
create a content publish task

指定者：
接口 IPublishTaskMgr 中的 createContentPublishTask
参数：
_content - the content to publish
_nPublishType - the publish type which is defined in PublishConstants like PUBLISH_AlL, PUBLISH_INC etc.
返回：
Returns the publish task created.
抛出：
WCMException - if failed to create the publish task

createContentPublishTask

public PublishTask createContentPublishTask(IPublishElements _contents,
                                            IPublishFolder _folder,
                                            int _nPublishType)
                                     throws WCMException
从接口 IPublishTaskMgr 复制的描述
create a content publish task

指定者：
接口 IPublishTaskMgr 中的 createContentPublishTask
参数：
_contents - the collection of publish contents
_folder - the folder where the contents lie
_nPublishType - the publish type which is defined in PublishConstants like PUBLISH_AlL, PUBLISH_INC etc.
返回：
Returns the publish task created.
抛出：
WCMException - if failed to create the publish task
另请参见：
IPublishTaskMgr.createContentPublishTask(IPublishElements, IPublishFolder, int)

createContentPublishTask

public PublishTask createContentPublishTask(IPublishContent _content,
                                            IPublishFolder _folder,
                                            IPublishElements _folders)
                                     throws WCMException
创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）

指定者：
接口 IPublishTaskMgr 中的 createContentPublishTask
抛出：
WCMException

createDestroyPublishTask

public PublishTask createDestroyPublishTask(IPublishElements _contents,
                                            IPublishFolder _folder,
                                            IPublishElements _folders)
                                     throws WCMException
创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）

指定者：
接口 IPublishTaskMgr 中的 createDestroyPublishTask
抛出：
WCMException

createDeleteContentsSynPublishTask

public PublishTask createDeleteContentsSynPublishTask(IPublishFolder _folder,
                                                      IPublishElements _contents)
                                               throws WCMException
指定者：
接口 IPublishTaskMgr 中的 createDeleteContentsSynPublishTask
返回：
抛出：
WCMException

createDeleteContentsSynPublishTask

public PublishTask createDeleteContentsSynPublishTask(IPublishFolder _folder,
                                                      IPublishContent _content)
                                               throws WCMException
指定者：
接口 IPublishTaskMgr 中的 createDeleteContentsSynPublishTask
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTaskRuntime

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 PublishTaskRuntime

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime

public class PublishTaskRuntime
extends java.lang.Object

秒数发布任务的运行时状态

作者：
Martin (付成睿)

构造方法摘要
PublishTaskRuntime()
缺省构造方法
方法摘要
java.util.Iterator | allProgressMonitor() 以java.util.Iterator的形式返回所有的任务监控器
int | getCurrentWorker() 返回当前的工作线程数
int | getDesiredWorker() 返回完成发布任务所预期的最佳工作线程数
PublishTask | getPublishTask()
PublishTaskContext | getTaskContext()
int | getTaskPriority() 返回发布任务的优先级
int | getWantingWorker() 返回欠缺的工作线程数，即还需要补充的工作线程数
void | setTaskPriority(int taskPriority) 设置发布任务的优先级
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishTaskRuntime

public PublishTaskRuntime()
缺省构造方法

方法详细信息

getPublishTask

public PublishTask getPublishTask()
返回：
Returns the publishTask.

getTaskContext

public PublishTaskContext getTaskContext()
返回：
Returns the taskContext.

getTaskPriority

public int getTaskPriority()
返回发布任务的优先级

返回：
发布任务的优先级

setTaskPriority

public void setTaskPriority(int taskPriority)
设置发布任务的优先级

参数：
taskPriority - 发布任务的优先级

getCurrentWorker

public int getCurrentWorker()
返回当前的工作线程数

返回：
当前的工作线程数

getDesiredWorker

public int getDesiredWorker()
返回完成发布任务所预期的最佳工作线程数

返回：
最佳工作线程数

getWantingWorker

public int getWantingWorker()
返回欠缺的工作线程数，即还需要补充的工作线程数

返回：
欠缺的工作线程数

allProgressMonitor

public java.util.Iterator allProgressMonitor()
以java.util.Iterator的形式返回所有的任务监控器

返回：
全部任务监控器的迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTaskWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 PublishTaskWorker

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker
所有已实现的接口：
IPageTaskDispatcher, java.lang.Runnable, org.aton.container.IClearable
public class PublishTaskWorker
extends java.lang.Object
implements java.lang.Runnable, IPageTaskDispatcher, org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
worker to execute publish task.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int RUN_INTERVAL
interval time during running
构造方法摘要
PublishTaskWorker()
constructor: default
方法摘要
java.util.Iterator | allProgressMonitor() 以java.util.Iterator的形式返回所有的任务监控器， 包括发布任务自身的监控器和分解后子任务的监控器。
void | cancel() cancel the task work
void | clear() clear object data
int | getDetailPageCount()
java.lang.String | getName()
IPageTask | getNextPageTask() Returns the next task to execute.
int | getOutlinePageCount()
IPublishProgressMonitor | getProgressMonitor() 返回发布任务自身的监控
PublishTask | getTask()
void | log2Monitor(java.lang.String msg) 纪录信息到监控器
void | notifyPageTaskFinished(IPageTask _task) notify one page generating task has been finished
void | notifyPageTaskWorkerFinished(int _nResult) notify that one PageTaskWorker has finished.
void | run() interface implementation：Runnable
void | setTask(PublishTask _task) set the task to execute
void | start()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RUN_INTERVAL

public static final int RUN_INTERVAL
interval time during running

另请参见：
常量字段值
构造方法详细信息

PublishTaskWorker

public PublishTaskWorker()
constructor: default

方法详细信息

clear

public void clear()
clear object data

指定者：
接口 org.aton.container.IClearable 中的 clear

setTask

public void setTask(PublishTask _task)
set the task to execute

参数：
_task - the specified task to execute

getTask

public PublishTask getTask()
返回：
current publish task which worker is executing

cancel

public void cancel()
cancel the task work

run

public void run()
interface implementation：Runnable

指定者：
接口 java.lang.Runnable 中的 run
另请参见：
Thread.run()

getNextPageTask

public IPageTask getNextPageTask()
从接口 IPageTaskDispatcher 复制的描述
Returns the next task to execute.

指定者：
接口 IPageTaskDispatcher 中的 getNextPageTask
返回：
the next task to execute.

notifyPageTaskFinished

public void notifyPageTaskFinished(IPageTask _task)
从接口 IPageTaskDispatcher 复制的描述
notify one page generating task has been finished

指定者：
接口 IPageTaskDispatcher 中的 notifyPageTaskFinished
参数：
_task - the page generating task

notifyPageTaskWorkerFinished

public void notifyPageTaskWorkerFinished(int _nResult)
从接口 IPageTaskDispatcher 复制的描述
notify that one PageTaskWorker has finished.

指定者：
接口 IPageTaskDispatcher 中的 notifyPageTaskWorkerFinished
参数：
_nResult - result of the work

log2Monitor

public void log2Monitor(java.lang.String msg)
纪录信息到监控器

getProgressMonitor

public IPublishProgressMonitor getProgressMonitor()
返回发布任务自身的监控

allProgressMonitor

public java.util.Iterator allProgressMonitor()
以java.util.Iterator的形式返回所有的任务监控器， 包括发布任务自身的监控器和分解后子任务的监控器。

getDetailPageCount

public int getDetailPageCount()
返回：
Returns the detailPageCount.

getOutlinePageCount

public int getOutlinePageCount()
返回：
Returns the outlinePageCount.

getName

public java.lang.String getName()

start

public void start()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SinglePageTask

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 SinglePageTask

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.SinglePageTask
所有已实现的接口：
IPageTask
public class SinglePageTask
extends java.lang.Object
implements IPageTask

Title: TRS 内容协作平台（TRS WCM）
Description:
interface of page task.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SinglePageTask(IPublishElement _element)
constructor: default
方法摘要
java.lang.String | getInfo() Returns this page task information.
IPublishElement | getPublishElement() Returns the element to publish.
boolean | isBatch() Returns true if this task is a batch task.
boolean | isOnDetailPage()
void | setPublishElement(IPublishElement publishElement)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SinglePageTask

public SinglePageTask(IPublishElement _element)
constructor: default

参数：
_element - the element to publish
方法详细信息

getPublishElement

public IPublishElement getPublishElement()
Returns the element to publish.

指定者：
接口 IPageTask 中的 getPublishElement
返回：
the element to publish

getInfo

public java.lang.String getInfo()
从接口 IPageTask 复制的描述
Returns this page task information.

指定者：
接口 IPageTask 中的 getInfo
返回：
this page task information.
另请参见：
IPageTask.getInfo()

isBatch

public boolean isBatch()
从接口 IPageTask 复制的描述
Returns true if this task is a batch task.

指定者：
接口 IPageTask 中的 isBatch
返回：
true if this task is a batch task.
另请参见：
IPageTask.isBatch()

isOnDetailPage

public boolean isOnDetailPage()
返回：
Returns true if this task is to generate detail page; otherwise, returns false.

setPublishElement

public void setPublishElement(IPublishElement publishElement)
指定者：
接口 IPageTask 中的 setPublishElement
参数：
publishElement -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TaskDispatcher

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 TaskDispatcher

java.lang.Object
    继承者  java.lang.Thread
        继承者  com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher
所有已实现的接口：
IPublishTaskDispatcher, java.lang.Runnable, org.aton.container.IClearable
public class TaskDispatcher
extends java.lang.Thread
implements IPublishTaskDispatcher, org.aton.container.IClearable

IPublishTaskDispatcher的新实现，用以替换 PublishTaskDispatcherImpl。

作者：
Martin (付成睿)

嵌套类摘要
从类 java.lang.Thread 继承的嵌套类/接口
java.lang.Thread.State, java.lang.Thread.UncaughtExceptionHandler
字段摘要
从类 java.lang.Thread 继承的字段
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
构造方法摘要
TaskDispatcher()
缺省构造方法
方法摘要
boolean | cancelTask(int _nTaskId) cancel a publish task by the specified id
boolean | changeTaskPriority(int iTask, int iPriority) 改变任务的优先级别，如果任务不是正在执行则什么都不作
void | clear()
PublishTask | getRunningTask(int iTaskID) 返回指定ID的正在执行的发布任务对象
java.util.Iterator | getRunningTasks() 返回所有的正在执行的任务
PublishTaskRuntime | getTaskRuntime(int iTaskID) 返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
boolean | isRunning() 返回是否正在运行
boolean | pauseTask(int iTaskID) 暂停指定发布任务的执行,如果指定ID的发布任务还没有执行或者已经执行结束则什么都不作。
void | pushTask(PublishTask _task) push a publish task into the queue
boolean | resumeTask(int iTaskID) 恢复指定的已经暂停的发布任务的执行,如果指定的并不是处于暂停状态则什么都不作。
void | run()
void | shutdown() shutdown the dispatcher
void | startup() startup the dispatcher
从类 java.lang.Thread 继承的方法
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, stop, stop, suspend, toString, yield
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TaskDispatcher

public TaskDispatcher()
缺省构造方法

方法详细信息

isRunning

public boolean isRunning()
返回是否正在运行

返回：
是否正在运行

run

public void run()
指定者：
接口 java.lang.Runnable 中的 run
覆盖：
类 java.lang.Thread 中的 run

startup

public void startup()
             throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
startup the dispatcher

指定者：
接口 IPublishTaskDispatcher 中的 startup
抛出：
WCMException - if failed to startup

shutdown

public void shutdown()
从接口 IPublishTaskDispatcher 复制的描述
shutdown the dispatcher

指定者：
接口 IPublishTaskDispatcher 中的 shutdown

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

pushTask

public void pushTask(PublishTask _task)
              throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
push a publish task into the queue

指定者：
接口 IPublishTaskDispatcher 中的 pushTask
参数：
_task - the specified publish task
抛出：
WCMException - if failed to push the task into the waiting queue.

pauseTask

public boolean pauseTask(int iTaskID)
                  throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
暂停指定发布任务的执行,如果指定ID的发布任务还没有执行或者已经执行结束则什么都不作。

指定者：
接口 IPublishTaskDispatcher 中的 pauseTask
参数：
iTaskID - 待操作的发布任务的ID
返回：
如果成功的暂停了任务则返回true，否则如果指定ID的发布任务不存在， 或者还没有执行或者已经执行，则返回false
抛出：
WCMException - 如果发生错误

resumeTask

public boolean resumeTask(int iTaskID)
                   throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
恢复指定的已经暂停的发布任务的执行,如果指定的并不是处于暂停状态则什么都不作。

指定者：
接口 IPublishTaskDispatcher 中的 resumeTask
参数：
iTaskID - 待操作的发布任务的ID
返回：
如果成功的恢复了任务则返回true，否则如果指定ID的发布任务不存在， 或者并不是处于暂停状态，则返回 false
抛出：
WCMException - 如果发生错误

cancelTask

public boolean cancelTask(int _nTaskId)
                   throws WCMException
从接口 IPublishTaskDispatcher 复制的描述
cancel a publish task by the specified id

指定者：
接口 IPublishTaskDispatcher 中的 cancelTask
参数：
_nTaskId - id of the task
返回：
Returns true if the task has been found and canceled successfully; otherwise, returns false.
抛出：
WCMException - if encounters errors when to seek or cancel the publish task

changeTaskPriority

public boolean changeTaskPriority(int iTask,
                                  int iPriority)
从接口 IPublishTaskDispatcher 复制的描述
改变任务的优先级别，如果任务不是正在执行则什么都不作

指定者：
接口 IPublishTaskDispatcher 中的 changeTaskPriority
参数：
iTask - 指定任务的ID
iPriority - 新的优先级别
返回：
成功改变优先级则返回true，否则返回false

getTaskRuntime

public PublishTaskRuntime getTaskRuntime(int iTaskID)
从接口 IPublishTaskDispatcher 复制的描述
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。

指定者：
接口 IPublishTaskDispatcher 中的 getTaskRuntime
参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回其运行时对象PublishTaskRuntime， 否则返回 null。

getRunningTask

public PublishTask getRunningTask(int iTaskID)
从接口 IPublishTaskDispatcher 复制的描述
返回指定ID的正在执行的发布任务对象

指定者：
接口 IPublishTaskDispatcher 中的 getRunningTask
参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回发布任务对象，否则返回null。

getRunningTasks

public java.util.Iterator getRunningTasks()
从接口 IPublishTaskDispatcher 复制的描述
返回所有的正在执行的任务

指定者：
接口 IPublishTaskDispatcher 中的 getRunningTasks
返回：
所有的正在执行的任务
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TaskWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 TaskWorker

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.TaskWorker
所有已实现的接口：
java.lang.Runnable
public class TaskWorker
extends java.lang.Object
implements java.lang.Runnable

执行任务的Worker，执行原子任务 IAtomTask 的对象

作者：
Martin (付成睿)

构造方法摘要
TaskWorker()
缺省构造方法
方法摘要
PublishTaskRuntime | getTaskRuntime()
void | run()
void | setTaskRuntime(PublishTaskRuntime taskRuntime)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TaskWorker

public TaskWorker()
缺省构造方法

方法详细信息

run

public void run()
指定者：
接口 java.lang.Runnable 中的 run

getTaskRuntime

public PublishTaskRuntime getTaskRuntime()
返回：
Returns the taskRuntime.

setTaskRuntime

public void setTaskRuntime(PublishTaskRuntime taskRuntime)
参数：
taskRuntime - The taskRuntime to set.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPool

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.taskdispatch
类 ThreadPool

java.lang.Object
    继承者  com.trs.components.common.publish.domain.taskdispatch.ThreadPool

public class ThreadPool
extends java.lang.Object

线程池

作者：
Martin (付成睿)

构造方法摘要
ThreadPool()
方法摘要
void | cleanup()
int | getIdleCount()
int | getMaxLimit()
int | getTotalCount()
boolean | runIt(java.lang.Runnable aRunnable)
void | startup(int iMaxLimit)
void | waitForWorker()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ThreadPool

public ThreadPool()
方法详细信息

getTotalCount

public int getTotalCount()
返回：
Returns the curCount.

getIdleCount

public int getIdleCount()
返回：
Returns the curIndex.

getMaxLimit

public int getMaxLimit()
返回：
Returns the maxLimit.

waitForWorker

public void waitForWorker()

startup

public void startup(int iMaxLimit)

cleanup

public void cleanup()

runIt

public boolean runIt(java.lang.Runnable aRunnable)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTask 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTask
的使用

使用 IAtomTask 的软件包
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.taskdispatch 中 IAtomTask 的使用

返回 IAtomTask 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
 IAtomTask IAtomTaskList.getNextTask()
返回列表中的下一个任务，如果列表中为空或者已经没有任务，则返回null。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTaskList 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTaskList
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.IAtomTaskList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr
的使用

使用 ILaborResourceMgr 的软件包
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.taskdispatch 中 ILaborResourceMgr 的使用

实现 ILaborResourceMgr 的 com.trs.components.common.publish.domain.taskdispatch 中的类
 class LaborResourceMgrImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.IPageTask 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.IPageTask
的使用

使用 IPageTask 的软件包
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.taskdispatch 中 IPageTask 的使用

实现 IPageTask 的 com.trs.components.common.publish.domain.taskdispatch 中的类
class | BatchDetailPageTask Title: TRS 内容协作平台（TRS WCM） Description: batch page task.
class | PageDestoryTask Title: TRS 内容协作平台（TRS WCM） Description: 撤销发布任务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | SinglePageTask Title: TRS 内容协作平台（TRS WCM） Description: interface of page task.

返回 IPageTask 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
IPageTask | PublishTaskAnalyzer.getNextPageTask() Fetchs next page task to execute.
IPageTask | IPageTaskDispatcher.getNextPageTask() Returns the next task to execute.
IPageTask | PublishTaskWorker.getNextPageTask()

参数类型为 IPageTask 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
void | PublishTaskAnalyzer.notifyPageTaskFinished(IPageTask _pageTask) Notifies one page task has finished
void | IPageTaskDispatcher.notifyPageTaskFinished(IPageTask _task) notify one page generating task has been finished
void | PublishTaskWorker.notifyPageTaskFinished(IPageTask _task)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher
的使用

使用 IPageTaskDispatcher 的软件包
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.taskdispatch 中 IPageTaskDispatcher 的使用

实现 IPageTaskDispatcher 的 com.trs.components.common.publish.domain.taskdispatch 中的类
 class PublishTaskWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
worker to execute publish task.

参数类型为 IPageTaskDispatcher 的 com.trs.components.common.publish.domain.taskdispatch 中的构造方法
PageTaskWorker(IPageTaskDispatcher _dispatcher, PublishTaskContext _publishTaskContext)
constructor
PageTaskWorker(IPageTaskDispatcher _dispatcher, PublishTaskContext _publishTaskContext, IPublishProgressMonitor _monitor)
constructor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.IPublishElementsIterator 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.IPublishElementsIterator
的使用

使用 IPublishElementsIterator 的软件包
com.trs.components.common.publish.persistent.element
com.trs.components.metadata.publish
com.trs.components.wcm.epress
com.trs.components.wcm.publish.element

com.trs.components.common.publish.persistent.element 中 IPublishElementsIterator 的使用

返回 IPublishElementsIterator 的 com.trs.components.common.publish.persistent.element 中的方法
IPublishElementsIterator | IPublishFolder.getAllContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderWrapper.getAllContentsIterator(WCMFilter _filter)
IPublishElementsIterator | IPublishFolder.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderWrapper.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishElementsListImpl.toIterator()
IPublishElementsIterator | PublishElementsCMSObjsImpl.toIterator()
IPublishElementsIterator | PublishElementsCMSListImpl.toIterator()

com.trs.components.metadata.publish 中 IPublishElementsIterator 的使用

返回 IPublishElementsIterator 的 com.trs.components.metadata.publish 中的方法
IPublishElementsIterator | PublishFolderClassImpl.getAllContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderClassImpl.getIncreasedContentsIterator(WCMFilter _filter)

com.trs.components.wcm.epress 中 IPublishElementsIterator 的使用

返回 IPublishElementsIterator 的 com.trs.components.wcm.epress 中的方法
IPublishElementsIterator | EpressFolderWrapper.getAllContentsIterator(WCMFilter _filter)
IPublishElementsIterator | EpressFolderWrapper.getIncreasedContentsIterator(WCMFilter _filter)

com.trs.components.wcm.publish.element 中 IPublishElementsIterator 的使用

实现 IPublishElementsIterator 的 com.trs.components.wcm.publish.element 中的类
 class PublishElementsIteratorDocumentsImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IPublishElementsIterator 的 com.trs.components.wcm.publish.element 中的方法
IPublishElementsIterator | PublishFolderChannelImpl.getAllContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderWebSiteImpl.getAllContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderChannelImpl.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderWebSiteImpl.getIncreasedContentsIterator(WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor
的使用

使用 IPublishProgressMonitor 的软件包
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.publisher 中 IPublishProgressMonitor 的使用

返回 IPublishProgressMonitor 的 com.trs.components.common.publish.domain.publisher 中的方法
 IPublishProgressMonitor PublishPageContext.getProgressMonitor()

参数类型为 IPublishProgressMonitor 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishPageContext(IPublishElement _pageElement, PublishTaskContext _taskContext, IPublishProgressMonitor _monitor)
constructor

com.trs.components.common.publish.domain.taskdispatch 中 IPublishProgressMonitor 的使用

实现 IPublishProgressMonitor 的 com.trs.components.common.publish.domain.taskdispatch 中的类
 class ProgressMonitorImpl
发布进程监控器IPublishProgressMonitor的缺省实现

返回 IPublishProgressMonitor 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
IPublishProgressMonitor | PageTaskWorker.getProgressMonitor()
IPublishProgressMonitor | PublishTaskWorker.getProgressMonitor() 返回发布任务自身的监控

参数类型为 IPublishProgressMonitor 的 com.trs.components.common.publish.domain.taskdispatch 中的构造方法
PageTaskWorker(IPageTaskDispatcher _dispatcher, PublishTaskContext _publishTaskContext, IPublishProgressMonitor _monitor)
constructor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher
的使用

使用 IPublishTaskDispatcher 的软件包
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.taskdispatch 中 IPublishTaskDispatcher 的使用

实现 IPublishTaskDispatcher 的 com.trs.components.common.publish.domain.taskdispatch 中的类
class | PublishTaskDispatcherImpl Title: TRS 内容协作平台（TRS WCM） Description: the publish task dispatcher implementation.
class | TaskDispatcher IPublishTaskDispatcher的新实现，用以替换 PublishTaskDispatcherImpl。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr
的使用

使用 IPublishTaskMgr 的软件包
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.taskdispatch 中 IPublishTaskMgr 的使用

实现 IPublishTaskMgr 的 com.trs.components.common.publish.domain.taskdispatch 中的类
 class PublishTaskMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IPublishTaskMgr
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime
的使用

使用 PublishTaskRuntime 的软件包
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.taskdispatch
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain 中 PublishTaskRuntime 的使用

返回 PublishTaskRuntime 的 com.trs.components.common.publish.domain 中的方法
 PublishTaskRuntime PublishServer.getTaskRuntime(int iTaskID)
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。

com.trs.components.common.publish.domain.taskdispatch 中 PublishTaskRuntime 的使用

返回 PublishTaskRuntime 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
PublishTaskRuntime | TaskWorker.getTaskRuntime()
PublishTaskRuntime | TaskDispatcher.getTaskRuntime(int iTaskID)
PublishTaskRuntime | IPublishTaskDispatcher.getTaskRuntime(int iTaskID) 返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
PublishTaskRuntime | PublishTaskDispatcherImpl.getTaskRuntime(int iTaskID)

参数类型为 PublishTaskRuntime 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
 void TaskWorker.setTaskRuntime(PublishTaskRuntime taskRuntime)

com.trs.service 中 PublishTaskRuntime 的使用

返回 PublishTaskRuntime 的 com.trs.service 中的方法
 PublishTaskRuntime IPublishService.getTaskRuntime(int iTaskID)
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。

com.trs.service.impl 中 PublishTaskRuntime 的使用

返回 PublishTaskRuntime 的 com.trs.service.impl 中的方法
 PublishTaskRuntime PublishService.getTaskRuntime(int iTaskID)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker
的使用

使用 PublishTaskWorker 的软件包
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.taskdispatch 中 PublishTaskWorker 的使用

返回 PublishTaskWorker 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
 PublishTaskWorker PublishTaskDispatcherImpl.getRunningWorker(int iTaskID)
返回和指定的发布任务ID相关联的 PublishTaskWorker 对象，如果该发布任务当前正在运行的话。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.SinglePageTask 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.SinglePageTask
的使用

使用 SinglePageTask 的软件包
com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.taskdispatch 中 SinglePageTask 的使用

返回 SinglePageTask 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
 SinglePageTask BatchDetailPageTask.getNext()
Returns the next page task to execute.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.TaskWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.TaskWorker
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.TaskWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool
的使用

没有 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CSSResourceProcessor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 CSSResourceProcessor

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.CSSResourceProcessor

public class CSSResourceProcessor
extends java.lang.Object

作者：
Administrator

构造方法摘要
CSSResourceProcessor()
方法摘要
java.lang.String[] | getRelateFiles()
static void | main(java.lang.String[] args)
java.lang.String | parseContent(java.lang.String _sCSSFileContent, java.util.HashMap _hExistsFileMap) 已过时。 use processConent instead.
java.lang.String | parseCSSFile(java.lang.String _sCSSFileName, java.util.HashMap _hExistsFileMap)
java.lang.String | processConent(java.lang.String _sContent, java.util.Map _hExsitsFileMap, java.lang.String _sAppendixLocalPath) 处理css文件中的url文件.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CSSResourceProcessor

public CSSResourceProcessor()
方法详细信息

getRelateFiles

public java.lang.String[] getRelateFiles()

parseCSSFile

public java.lang.String parseCSSFile(java.lang.String _sCSSFileName,
                                     java.util.HashMap _hExistsFileMap)
                              throws WCMException
参数：
_sCSSFileName -
_hExistsFileMap -
返回：
如果返回值是Null，说明CSS文件中没有处理过的内容，不需要继续
抛出：
WCMException

processConent

public java.lang.String processConent(java.lang.String _sContent,
                                      java.util.Map _hExsitsFileMap,
                                      java.lang.String _sAppendixLocalPath)
处理css文件中的url文件.

参数：
_sContent -
_hExsitsFileMap -
_sAppendixLocalPath -
返回：

parseContent

public java.lang.String parseContent(java.lang.String _sCSSFileContent,
                                     java.util.HashMap _hExistsFileMap)
已过时。 use processConent instead.

参数：
_sCSSFileContent -
_hExistsFileMap -
返回：
如果返回值是Null，说明CSS文件中没有处理过的内容，不需要继续

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ITemplateEmployCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
接口 ITemplateEmployCacheMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
TemplateEmployCacheMgrImpl
public interface ITemplateEmployCacheMgr
extends ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
Template | getDefaultOutlineTemplate(IPublishFolder _folder)
Template | getDetailTemplate(int _nPublishElementType, int _nPublishElementId)
Template | getDetailTemplate(IPublishElement _employer)
Templates | getOutlineTemplates(IPublishFolder _folder)
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

getDetailTemplate

Template getDetailTemplate(IPublishElement _employer)
                           throws WCMException
抛出：
WCMException

getDetailTemplate

Template getDetailTemplate(int _nPublishElementType,
                           int _nPublishElementId)
                           throws WCMException
抛出：
WCMException

getDefaultOutlineTemplate

Template getDefaultOutlineTemplate(IPublishFolder _folder)
                                   throws WCMException
抛出：
WCMException

getOutlineTemplates

Templates getOutlineTemplates(IPublishFolder _folder)
                              throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.domain.template
接口
ITemplateEmployCacheMgr
类
CSSResourceProcessor
TemplateArgumentCacheMgr
TemplateArgumentLCListenerForEmployChanged
TemplateArgumentMgr
TemplateCacheMgr
TemplateEmployCacheMgrImpl
TemplateEmployDetail
TemplateEmployerIdsMan
TemplateEmployMgr
TemplateExporter
TemplateImporter
TemplateLCListenerForNestedRename
TemplateLCListenerForTypeChanged
TemplateMgr
TemplateNestMgr
TemplateParseAngel
TemplateParseHelper
TemplateParseMgr
TemplateQuoteMgr
TemplateQuoteMgr0310


com.trs.components.common.publish.domain.template

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.domain.template

接口摘要
ITemplateEmployCacheMgr Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
CSSResourceProcessor |
TemplateArgumentCacheMgr | 缓存TemplateArguments对象，并监听TemplateArgument的增删改
TemplateArgumentLCListenerForEmployChanged | 在模板和频道的雇佣关系发生变化时，清除已经设置的模板变量
TemplateArgumentMgr | 模板参数实际值的管理器
TemplateCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: template cache manaager implementation.
TemplateEmployCacheMgrImpl | Title: TRS 内容协作平台（TRS WCM） Description: 模板和发布元素的配置缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployDetail | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployerIdsMan | Title: TRS 内容协作平台（TRS WCM） Description: Template Employee Ids manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployMgr | Title: TRS 内容协作平台（TRS WCM） Description: template employ records manager.
TemplateExporter | Title: TRS 内容协作平台（TRS WCM） Description: 负责管理模板导出相关的行为 模板导出过程中会涉及到模板附件的导出 由于目前顶已模板导出只伴随站点导出才导出，频道导出时不导出模板，所以模板附件的导出相对比较简单 以后再进行扩展 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateImporter | Title: TRS 内容协作平台（TRS WCM） Description: 管理和模板导入相关的行为 目前模板的导入只支持随着站点的导入一起进行，不支持单独的模板导入 目前提供的独立的模板导入、导出是通过独立的处理逻辑进行的，和XML的导入、导出没有关系 模板导入时，还需要考虑模板附件的导入 由于上面的约束，所以模板附件的导入相对比较简单，不需要考虑重名的处理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateLCListenerForNestedRename | 如果修改了模板的名称，则要检查模板是否被嵌套，如果模板被嵌套使用，则要同步修改所有的引用。
TemplateLCListenerForTypeChanged | Title: TRS 内容协作平台（TRS WCM） Description: 监听模板类型的变化,更新模板的使用情况 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateMgr | Title: TRS 内容协作平台（TRS WCM） Description:
TemplateNestMgr | Title: TRS 内容协作平台（TRS WCM） Description: template nest record manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseAngel | Title: TRS 内容协作平台（TRS WCM） Description: template parse agel which runs background.
TemplateParseHelper | Title: TRS 内容协作平台（TRS WCM） Description: file distribute ship Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseMgr | Title: TRS 内容协作平台（TRS WCM） Description: template parse manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateQuoteMgr | Title: TRS 内容协作平台（TRS WCM） Description: template quote records manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateQuoteMgr0310 | Title: TRS 内容协作平台（TRS WCM） Description: template quote records manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.publish.domain.template 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.template 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.common.BaseIdsMan
      • com.trs.components.common.publish.domain.template.TemplateEmployerIdsMan
    • com.trs.components.common.publish.domain.template.CSSResourceProcessor
    • com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.template.TemplateArgumentMgr
    • com.trs.components.common.publish.domain.template.TemplateCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl (implements com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr)
    • com.trs.components.common.publish.domain.template.TemplateEmployDetail
    • com.trs.components.common.publish.domain.template.TemplateEmployMgr
    • com.trs.components.common.publish.domain.template.TemplateExporter
    • com.trs.components.common.publish.domain.template.TemplateImporter
    • com.trs.components.common.publish.domain.template.TemplateLCListenerForNestedRename (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.template.TemplateLCListenerForTypeChanged (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.template.TemplateMgr
    • com.trs.components.common.publish.domain.template.TemplateNestMgr
    • com.trs.components.common.publish.domain.template.TemplateParseHelper
    • com.trs.components.common.publish.domain.template.TemplateParseMgr (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.domain.template.TemplateQuoteMgr
    • com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310
    • java.lang.Thread (implements java.lang.Runnable)
      • com.trs.components.common.publish.domain.template.TemplateParseAngel

接口分层结构

  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr


软件包 com.trs.components.common.publish.domain.template 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.domain.template
的使用

使用 com.trs.components.common.publish.domain.template 的软件包
com.trs.components.common.publish.domain.template

com.trs.components.common.publish.domain.template 使用的 com.trs.components.common.publish.domain.template 中的类
ITemplateEmployCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
template employ records manager.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TemplateArgumentCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateArgumentCacheMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class TemplateArgumentCacheMgr
extends java.lang.Object
implements ICacheMgr

缓存TemplateArguments对象，并监听TemplateArgument的增删改

作者：
Martin (付成睿)

构造方法摘要
TemplateArgumentCacheMgr()
缺省构造方法
方法摘要
void | clear() 清除系统所有的Cache
java.lang.String | getArgument(int _type, int _id, java.lang.String _name)
java.lang.String | getArgument(IPublishElement _employer, java.lang.String _name)
java.util.HashMap | getArguments(int _type, int _id)
java.util.HashMap | getArguments(IPublishElement _employer)
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateArgumentCacheMgr

public TemplateArgumentCacheMgr()
缺省构造方法

方法详细信息

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

getArgument

public java.lang.String getArgument(IPublishElement _employer,
                                    java.lang.String _name)
                             throws WCMException
参数：
_employer - 发布对象
_name - 参数名称
返回：
参数值
抛出：
WCMException

getArgument

public java.lang.String getArgument(int _type,
                                    int _id,
                                    java.lang.String _name)
                             throws WCMException
参数：
_type - 发布对象的类型
_id - 发布对象的ID
_name - 参数名称
返回：
抛出：
WCMException

getArguments

public java.util.HashMap getArguments(IPublishElement _employer)
                               throws WCMException
参数：
_employer - 发布对象
返回：
参数值列表
抛出：
WCMException

getArguments

public java.util.HashMap getArguments(int _type,
                                      int _id)
                               throws WCMException
参数：
_type - 发布对象的类型
_id - 发布对象的ID
返回：
参数值列表
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateArgumentLCListenerForEmployChanged

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateArgumentLCListenerForEmployChanged

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class TemplateArgumentLCListenerForEmployChanged
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

在模板和频道的雇佣关系发生变化时，清除已经设置的模板变量

作者：
Martin (付成睿)

构造方法摘要
TemplateArgumentLCListenerForEmployChanged()
缺省构造方法
方法摘要
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateArgumentLCListenerForEmployChanged

public TemplateArgumentLCListenerForEmployChanged()
缺省构造方法

方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateArgumentMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateArgumentMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateArgumentMgr

public class TemplateArgumentMgr
extends java.lang.Object

模板参数实际值的管理器

作者：
Martin (付成睿)

构造方法摘要
TemplateArgumentMgr()
缺省构造方法
方法摘要
boolean | delete(TemplateArgument _aArgument) 删除指定的TemplateArgument对象
TemplateArguments | getArguments(IPublishElement _element) 返回指定发布对象上的全部有效模板参数列表
TemplateArgument | save(TemplateArgument _aArgument) 保存指定的TemplateArgument对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateArgumentMgr

public TemplateArgumentMgr()
缺省构造方法

方法详细信息

getArguments

public TemplateArguments getArguments(IPublishElement _element)
                               throws WCMException
返回指定发布对象上的全部有效模板参数列表

参数：
_element - 指定的发布对象
返回：
有效的模板参数列表
抛出：
WCMException - 如果发生错误

delete

public boolean delete(TemplateArgument _aArgument)
               throws WCMException
删除指定的TemplateArgument对象

参数：
_aArgument - 待删除的TemplateArgument对象
返回：
是否删除成功
抛出：
WCMException - 如果发生错误

save

public TemplateArgument save(TemplateArgument _aArgument)
                      throws WCMException
保存指定的TemplateArgument对象

参数：
_aArgument - 待保存的TemplateArgument对象
返回：
保存后的TemplateArgument对象
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateCacheMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class TemplateCacheMgr
extends java.lang.Object
implements ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
template cache manaager implementation.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateCacheMgr()
constructor: default
方法摘要
void | clear() 清除系统所有的Cache
boolean | init() 初始化当前的Cache
Template | lookupByName(IPublishFolder _root, java.lang.String _sName) find the template by name
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateCacheMgr

public TemplateCacheMgr()
constructor: default

方法详细信息

init

public boolean init()
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：

reinit

public boolean reinit()
指定者：
接口 ICacheMgr 中的 reinit
返回：

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

lookupByName

public Template lookupByName(IPublishFolder _root,
                             java.lang.String _sName)
                      throws WCMException
find the template by name

参数：
_root - the folder root where the template lies.
_sName - the template name
返回：
Returns the template found.
抛出：
WCMException - if failed to lookup the template.

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmployCacheMgrImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateEmployCacheMgrImpl

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl
所有已实现的接口：
ITemplateEmployCacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class TemplateEmployCacheMgrImpl
extends java.lang.Object
implements ITemplateEmployCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
模板和发布元素的配置缓冲管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateEmployCacheMgrImpl()
方法摘要
void | clear() 清除系统所有的Cache
Template | getDefaultOutlineTemplate(IPublishFolder _folder)
Template | getDetailTemplate(int _nPublishElementType, int _nPublishElementId)
Template | getDetailTemplate(IPublishElement _employer)
Templates | getOutlineTemplates(IPublishFolder _folder)
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateEmployCacheMgrImpl

public TemplateEmployCacheMgrImpl()
方法详细信息

getDetailTemplate

public Template getDetailTemplate(IPublishElement _employer)
                           throws WCMException
指定者：
接口 ITemplateEmployCacheMgr 中的 getDetailTemplate
抛出：
WCMException

getDefaultOutlineTemplate

public Template getDefaultOutlineTemplate(IPublishFolder _folder)
                                   throws WCMException
指定者：
接口 ITemplateEmployCacheMgr 中的 getDefaultOutlineTemplate
抛出：
WCMException

getOutlineTemplates

public Templates getOutlineTemplates(IPublishFolder _folder)
                              throws WCMException
指定者：
接口 ITemplateEmployCacheMgr 中的 getOutlineTemplates
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

getDetailTemplate

public Template getDetailTemplate(int _nPublishElementType,
                                  int _nPublishElementId)
                           throws WCMException
指定者：
接口 ITemplateEmployCacheMgr 中的 getDetailTemplate
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmployDetail

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateEmployDetail

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateEmployDetail

public class TemplateEmployDetail
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateEmployDetail()
缺省构造方法
TemplateEmployDetail(int _nTemplateEmployId, int _nTemplateType, Template _template, boolean _bDefault)
TemplateEmployDetail(TemplateEmploy _employ)
方法摘要
Template | getDefaultDetailTemplate()
Template | getDefaultInfoviewPrintTemplate()
Template | getDefaultOutlineTemplate()
Templates | getOutlineTemplates()
boolean | isEmpty()
void | putEmploy(int _nTemplateEmployId, int _nTemplateType, Template _template, boolean _bDefault)
void | putEmploy(TemplateEmploy _employ)
void | removeDefaultDetailTemplate()
void | removeDefaultInfoviewPrintTemplate()
void | removeDefaultOutlineTemplate()
void | removeEmploy(TemplateEmploy _employ)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateEmployDetail

public TemplateEmployDetail()
缺省构造方法

TemplateEmployDetail

public TemplateEmployDetail(TemplateEmploy _employ)
                     throws WCMException
参数：
_employ -
抛出：
WCMException

TemplateEmployDetail

public TemplateEmployDetail(int _nTemplateEmployId,
                            int _nTemplateType,
                            Template _template,
                            boolean _bDefault)
方法详细信息

putEmploy

public void putEmploy(TemplateEmploy _employ)
               throws WCMException
抛出：
WCMException

putEmploy

public void putEmploy(int _nTemplateEmployId,
                      int _nTemplateType,
                      Template _template,
                      boolean _bDefault)

removeEmploy

public void removeEmploy(TemplateEmploy _employ)
                  throws WCMException
抛出：
WCMException

isEmpty

public boolean isEmpty()

getDefaultDetailTemplate

public Template getDefaultDetailTemplate()
返回：

removeDefaultDetailTemplate

public void removeDefaultDetailTemplate()
参数：
defaultDetailTemplate -

getDefaultInfoviewPrintTemplate

public Template getDefaultInfoviewPrintTemplate()
返回：

removeDefaultInfoviewPrintTemplate

public void removeDefaultInfoviewPrintTemplate()
参数：
defaultDetailTemplate -

getDefaultOutlineTemplate

public Template getDefaultOutlineTemplate()
返回：

removeDefaultOutlineTemplate

public void removeDefaultOutlineTemplate()
参数：
defaultOutlineTemplate -

getOutlineTemplates

public Templates getOutlineTemplates()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmployerIdsMan

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateEmployerIdsMan

java.lang.Object
    继承者  com.trs.infra.common.BaseIdsMan
        继承者  com.trs.components.common.publish.domain.template.TemplateEmployerIdsMan

public class TemplateEmployerIdsMan
extends BaseIdsMan

Title: TRS 内容协作平台（TRS WCM）
Description:
Template Employee Ids manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateEmployerIdsMan(IPublishElement _element, TemplateEmployMgr _manager, int _nTemplateType)
方法摘要
从类 com.trs.infra.common.BaseIdsMan 继承的方法
dowithIds
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateEmployerIdsMan

public TemplateEmployerIdsMan(IPublishElement _element,
                              TemplateEmployMgr _manager,
                              int _nTemplateType)
                       throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmployMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateEmployMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateEmployMgr

public class TemplateEmployMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
template employ records manager.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateEmployMgr()
方法摘要
int | clearEmploysOfEmployer(int _nEmployerType, int _nEmployerId) clear all the employ records of the specified element
int | clearEmploysOfEmployer(IPublishElement _employer) clear all the employ records of the specified element
int | clearEmploysOfTemplate(int _nTemplateId) clear all the employ records of the specified template
int | clearEmploysOfTemplate(Template _template) clear all the employ records of the specified template
Template | getDefaultOutlineTemplate(IPublishFolder _folder) Returns the default outline template of the specified folder.
Template | getDetailTemplate(int _nEmployerType, int _nEmployerId)
Template | getDetailTemplate(IPublishElement _employer) Returns the detail template of the specified publish element.
Template | getDetailTemplate(IPublishElement _employer, int _nTemplateType)
java.util.List | getEmployers(Template _template, int _nEmployerType) Returns the employers list of the specified type.
java.util.List | getEmployers(Template _template, WCMFilter _filter) get the employers who use the specified template.
TemplateEmploys | getEmploysOf(IPublishElement _employer)
TemplateEmploys | getEmploysOf(IPublishElement _employer, int _nTemplateType) Returns the employ records of the specified employer, which may be a folder or a content.
TemplateEmploys | getEmploysOfEmployer(int _nEmployerType, int _nEmployerId)
TemplateEmploys | getEmploysOfEmployer(int _nEmployerType, int _nEmployerId, int _nTemplateType) Returns the employ records of the specified employer, which may be a folder or a content.
Templates | getOtherOutlineTemplates(IPublishFolder _folder) 获取当前folder的其它概览模板集.
Templates | getOutlineTemplates(IPublishFolder _folder) get the outline templates of the specified folder.
TemplateEmploys | getTemplateEmployers(Template _template, WCMFilter _filter)
void | resetChildern(IPublishFolder _folder)
void | resetChildern(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bOutLine)
void | setDefaultOutline(IPublishFolder _folder, int _nNewDefaultTemplateId)
void | setDetailTemplate(IPublishElement _employer, int _nTemplateId, boolean _bResetChildren)
void | setDetailTemplate(IPublishElement _employer, int _nTemplateId, boolean _bResetChildren, int _nDetailTemplateType) set detail template of the specified element.
void | setOtherOutlines(User loginUser, IPublishFolder _folder, java.lang.String _sTemplateIds)
void | setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren) set outline template of the specified folder
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateEmployMgr

public TemplateEmployMgr()
方法详细信息

getEmploysOf

public TemplateEmploys getEmploysOf(IPublishElement _employer,
                                    int _nTemplateType)
                             throws WCMException
Returns the employ records of the specified employer, which may be a folder or a content.
if the template type is ANY (PublishConstances.TEMPLATE_TYPE_ANY), returns all the templates of the sepcified employer.

参数：
_employer - the specified employer using templates.
_nTemplateType - type of the used template; default TEMPLATE_TYPE_ANY which stands all the types.
返回：
the employ records of the specified employer.
抛出：
WCMException - if failed to query and fecth the employ records.

getEmploysOf

public TemplateEmploys getEmploysOf(IPublishElement _employer)
                             throws WCMException
抛出：
WCMException
另请参见：
getEmploysOf(IPublishElement, int)

getEmploysOfEmployer

public TemplateEmploys getEmploysOfEmployer(int _nEmployerType,
                                            int _nEmployerId,
                                            int _nTemplateType)
                                     throws WCMException
Returns the employ records of the specified employer, which may be a folder or a content.
if the template type is ANY (PublishConstances.TEMPLATE_TYPE_ANY), returns all the templates of the sepcified employer.

参数：
_nEmployerType - type of the employer
_nEmployerId - id of the employer
_nTemplateType - type of the used template; default TEMPLATE_TYPE_ANY which stands all the types.
返回：
the employ records of the specified employer.
抛出：
WCMException - if failed to query and fecth the employ records.

getEmploysOfEmployer

public TemplateEmploys getEmploysOfEmployer(int _nEmployerType,
                                            int _nEmployerId)
                                     throws WCMException
抛出：
WCMException
另请参见：
getEmploysOfEmployer(int, int, int)

getOutlineTemplates

public Templates getOutlineTemplates(IPublishFolder _folder)
                              throws WCMException
get the outline templates of the specified folder.

参数：
_folder - the folder
返回：
Returns the outline templates.
抛出：
WCMException - if failed to fetch the templates.

getOtherOutlineTemplates

public Templates getOtherOutlineTemplates(IPublishFolder _folder)
                                   throws WCMException
获取当前folder的其它概览模板集.

参数：
_folder -
返回：
抛出：
WCMException

getDefaultOutlineTemplate

public Template getDefaultOutlineTemplate(IPublishFolder _folder)
                                   throws WCMException
Returns the default outline template of the specified folder.

参数：
_folder - the folder
返回：
Returns the default outline template.
抛出：
WCMException - if failed to fetch the template.

getDetailTemplate

public Template getDetailTemplate(IPublishElement _employer)
                           throws WCMException
Returns the detail template of the specified publish element.

参数：
_employer - a publish element
返回：
Returns the detail template.
抛出：
WCMException - if failed to fetch the template.

getDetailTemplate

public Template getDetailTemplate(int _nEmployerType,
                                  int _nEmployerId)
                           throws WCMException
抛出：
WCMException

getDetailTemplate

public Template getDetailTemplate(IPublishElement _employer,
                                  int _nTemplateType)
                           throws WCMException
抛出：
WCMException

setOutlineTemplates

public void setOutlineTemplates(IPublishFolder _folder,
                                java.lang.String _sTemplateIds,
                                boolean _bResetChildren)
                         throws WCMException
set outline template of the specified folder

参数：
_folder - the folder
_sTemplateIds - the templates id sequence, seperated by char ','; and the first one is the default outline template.
_bResetChildren - to be reset the outline templates of the children folder or not; it will reset if true
抛出：
WCMException - if failed to add employ record.

setDefaultOutline

public void setDefaultOutline(IPublishFolder _folder,
                              int _nNewDefaultTemplateId)
                       throws WCMException
参数：
_folder -
arrTemplateIds -
抛出：
WCMException

setOtherOutlines

public void setOtherOutlines(User loginUser,
                             IPublishFolder _folder,
                             java.lang.String _sTemplateIds)
                      throws WCMException
抛出：
WCMException

setDetailTemplate

public void setDetailTemplate(IPublishElement _employer,
                              int _nTemplateId,
                              boolean _bResetChildren,
                              int _nDetailTemplateType)
                       throws WCMException
set detail template of the specified element.

参数：
_employer - the employer, a folder or a content.
_nTemplateId - the template id
_bResetChildren - to be reset the detail template of the children folder or not; it will reset if true and the _employer is a instance of @link IPublishFolder
_nDetailTemplateType - to determine the detail template type
抛出：
WCMException - if failed to add employ record.

setDetailTemplate

public void setDetailTemplate(IPublishElement _employer,
                              int _nTemplateId,
                              boolean _bResetChildren)
                       throws WCMException
抛出：
WCMException

getEmployers

public java.util.List getEmployers(Template _template,
                                   WCMFilter _filter)
                            throws WCMException
get the employers who use the specified template.

参数：
_template - a template.
_filter - extra filter for the collection.
返回：
Returns the templates collection.
抛出：
WCMException - if failed to query and fetch the templates.

getTemplateEmployers

public TemplateEmploys getTemplateEmployers(Template _template,
                                            WCMFilter _filter)
                                     throws WCMException
参数：
_template -
_filter -
返回：
抛出：
WCMException

getEmployers

public java.util.List getEmployers(Template _template,
                                   int _nEmployerType)
                            throws WCMException
Returns the employers list of the specified type.

参数：
_template - the template
_nEmployerType - type of the employers.
返回：
the employers list of the specified type.
抛出：
WCMException - if failed to query and fetch the employers list.

clearEmploysOfEmployer

public int clearEmploysOfEmployer(IPublishElement _employer)
                           throws WCMException
clear all the employ records of the specified element

参数：
_employer - the publish element using template
返回：
Returns the employ records count deleted.
抛出：
WCMException - if failed to delete those employ records.

clearEmploysOfEmployer

public int clearEmploysOfEmployer(int _nEmployerType,
                                  int _nEmployerId)
                           throws WCMException
clear all the employ records of the specified element

参数：
_nEmployerType - type of the employer using template
_nEmployerId - id of the employer using template
返回：
Returns the employ records count deleted.
抛出：
WCMException - if failed to delete those employ records.

clearEmploysOfTemplate

public int clearEmploysOfTemplate(Template _template)
                           throws WCMException
clear all the employ records of the specified template

参数：
_template - the template
返回：
Returns the employ records count deleted.
抛出：
WCMException - if failed to delete those employ records.

clearEmploysOfTemplate

public int clearEmploysOfTemplate(int _nTemplateId)
                           throws WCMException
clear all the employ records of the specified template

参数：
_nTemplateId - id of the template
返回：
Returns the employ records count deleted.
抛出：
WCMException - if failed to delete those employ records.

resetChildern

public void resetChildern(IPublishFolder _folder,
                          java.lang.String _sTemplateIds,
                          boolean _bOutLine)
                   throws WCMException
抛出：
WCMException

resetChildern

public void resetChildern(IPublishFolder _folder)
                   throws WCMException
抛出：
WCMException
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateExporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateExporter

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateExporter

public class TemplateExporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
负责管理模板导出相关的行为
模板导出过程中会涉及到模板附件的导出
由于目前顶已模板导出只伴随站点导出才导出，频道导出时不导出模板，所以模板附件的导出相对比较简单
以后再进行扩展
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String TEMPLATETYPEINFOS_XMLFILE
构造方法摘要
TemplateExporter()
constructor: default
方法摘要
java.lang.String | export(Templates _currTemplates) 导出模板集合
java.lang.String | exportToXMLFile(Template _currTemplate) 将WCM的模板导出成为WCM XML标准格式的文件
java.lang.String | exportToXMLFile(Templates _currTemplates) 将WCM的模板集合导出成为WCM XML标准格式的文件
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TEMPLATETYPEINFOS_XMLFILE

public static final java.lang.String TEMPLATETYPEINFOS_XMLFILE
另请参见：
常量字段值
构造方法详细信息

TemplateExporter

public TemplateExporter()
constructor: default

方法详细信息

exportToXMLFile

public java.lang.String exportToXMLFile(Template _currTemplate)
                                 throws WCMException
将WCM的模板导出成为WCM XML标准格式的文件

参数：
_fromChannel - 要导出的模板
_bWithRelated -
  • 是否导入相关对象，true为导出，false为不导出
  • 相关对象包括模板和模板附件的关系
  • 这个参数意义不大，可以不留着了
    返回：
    WCM导出的文件名，Temp（临时）目录下的文件
    抛出：
    WCMException

    • exportToXMLFile

    public java.lang.String exportToXMLFile(Templates _currTemplates)
                                 throws WCMException
    将WCM的模板集合导出成为WCM XML标准格式的文件

    参数：
    _currTemplates - 要导出的模板集合
    返回：
    WCM导出的文件名，Temp（临时）目录下的文件
    抛出：
    WCMException

    export

    public java.lang.String export(Templates _currTemplates)
                        throws WCMException
    导出模板集合

    参数：
    _currTemplates - 要导出的模板集合
    抛出：
    WCMException
    概述 软件包 类 使用 树 已过时 索引 帮助
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateImporter

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateImporter

public class TemplateImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
管理和模板导入相关的行为
目前模板的导入只支持随着站点的导入一起进行，不支持单独的模板导入
目前提供的独立的模板导入、导出是通过独立的处理逻辑进行的，和XML的导入、导出没有关系
模板导入时，还需要考虑模板附件的导入
由于上面的约束，所以模板附件的导入相对比较简单，不需要考虑重名的处理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateImporter()
constructor: default
方法摘要
java.lang.String[] | extractTemplateNamesFromZip(java.lang.String _sZipFileName) 得到模板名称列表
static java.lang.String[] | getSupportedTemplateFileExt() 获取系统支持的模板文件类型.
Reports | importFromHTML(IPublishFolder _folder, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName) 从html文件导入模板
Reports | importFromZip(IPublishFolder _folder, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected) 从zip文件中导入模板
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateImporter

public TemplateImporter()
constructor: default

方法详细信息

extractTemplateNamesFromZip

public java.lang.String[] extractTemplateNamesFromZip(java.lang.String _sZipFileName)
                                               throws WCMException
得到模板名称列表

参数：
_sZipFileName -
返回：
抛出：
WCMException

importFromZip

public Reports importFromZip(IPublishFolder _folder,
                             java.lang.String _sFileName,
                             int _nImportMode,
                             int _nPicMode,
                             java.lang.String[] _arSelected)
                      throws WCMException
从zip文件中导入模板

参数：
_folder - 站点/频道对象
_sFileName - 文件名(规则的WCM文件名)
_nImportMode - 模板导入模式,模板重名的处理方式(WCMTypes.TEMPLATE_DEAL_MODE_UPDATE等)
_nPicMode - 模板附件导入模式,附件重名的处理方式(WCMTypes.TEMPLATEAPD_DEAL_MODE_UPDATE等)
_arSelected - 用户已经选择的是模板的文件的列表
返回：
导入成功的模板名
抛出：
WCMException

importFromHTML

public Reports importFromHTML(IPublishFolder _folder,
                              java.lang.String _sFileName,
                              int _nImportMode,
                              java.lang.String _sSrcName)
                       throws WCMException
从html文件导入模板

参数：
_folder - 站点/频道对象
_sFileName - 文件名(WCM规则的文件名)
_nImportMode - 模板导入模式,模板重名的处理方式(WCMTypes.TEMPLATE_DEAL_MODE_UPDATE等)
_sSrcName - 模板原文件名(模板的入库文件名)
返回：
抛出：
WCMException

getSupportedTemplateFileExt

public static final java.lang.String[] getSupportedTemplateFileExt()
                                                            throws WCMException
获取系统支持的模板文件类型.
在 importFromHtmlFile时使用.

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateLCListenerForNestedRename

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateLCListenerForNestedRename

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateLCListenerForNestedRename
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class TemplateLCListenerForNestedRename
extends java.lang.Object
implements IObjectLCListenerOnModify

如果修改了模板的名称，则要检查模板是否被嵌套，如果模板被嵌套使用，则要同步修改所有的引用。

作者：
Martin (付成睿)

构造方法摘要
TemplateLCListenerForNestedRename()
缺省构造方法
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateLCListenerForNestedRename

public TemplateLCListenerForNestedRename()
缺省构造方法

方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateLCListenerForTypeChanged

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateLCListenerForTypeChanged

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateLCListenerForTypeChanged
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public final class TemplateLCListenerForTypeChanged
extends java.lang.Object
implements IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
监听模板类型的变化,更新模板的使用情况
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateLCListenerForTypeChanged()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateLCListenerForTypeChanged

public TemplateLCListenerForTypeChanged()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateMgr

public class TemplateMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateMgr()
constructor: default
方法摘要
Reports | copyVisualTempToChnls(Channels _toChannels, Template _srcTemplate) 在指定栏目下，类似创建可视化模板
boolean | delete(Template _templateToDelete) 删除指定的模板
Templates | getManagedTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) get the managed tempaltes in the specified folder
Templates | getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent) get the managed tempaltes in the specified folder
TempAppendixes | getTempAppendixesInRoot(int _nRootType, int _nRootId, WCMFilter _filter) get the template appendixes in the specified root
java.lang.String | getTextWithImgFilter(Template _template, java.lang.String sText, boolean _bRemoveExtraAttribute)
java.lang.String | preview(Template _currTemplate) 预览指定的模板
java.lang.String | processTemplateAppendixes(Template _template, java.lang.String sTempText, int _nPicMode) 将指定的內容处理成模板的格式，如：将里面的图片资源进行处理
Reports | redistributeAppendixes(IPublishFolder _folder, boolean _zRecursive) 重新分发指定站点或者频道下的所有模板的附件，并且如果 _zRecursive 为 true ，则会进一步地重新分发子频道下的模板的附件。
Reports | redistributeAppendixes(Templates _templates) 重新分发模板的所有附件
Template | save(Template _currTemplate, java.util.HashMap _tempapds, boolean _bDowithAppendix, int _nPicMode, boolean _zParseIfNecessary) 保存模板
Template | save(Template _currTemplate, java.lang.String _sTempApdPath, boolean _bDowithAppendix, int _nPicMode) 保存模板
void | updateNestedTemplateName(Templates templates, java.lang.String sOldName, java.lang.String sNewName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateMgr

public TemplateMgr()
constructor: default

方法详细信息

save

public Template save(Template _currTemplate,
                     java.lang.String _sTempApdPath,
                     boolean _bDowithAppendix,
                     int _nPicMode)
              throws WCMException
保存模板

参数：
_currTemplate - 要保存的模板
_sTempApdPath - 模板附件对应文件的路径
_bDowithAppendix - 是否处理附件。true为处理附件中的资源文件，false为不处理
_nPicMode - 资源文件重名时的更新方式，4中，参见WCMTypes.TEMMPLATEAPD_xxx
返回：
抛出：
WCMException

save

public Template save(Template _currTemplate,
                     java.util.HashMap _tempapds,
                     boolean _bDowithAppendix,
                     int _nPicMode,
                     boolean _zParseIfNecessary)
              throws WCMException
保存模板

参数：
_currTemplate - 要保存的模板
_tempapds - 模板附件对应文件的路径
_bDowithAppendix - 是否处理附件。true为处理附件中的资源文件，false为不处理
_nPicMode - 资源文件重名时的更新方式，4中，参见WCMTypes.TEMMPLATEAPD_xxx
_zParseIfNecessary - 如果需要是否解析模板。true为由模板的情况决定，false为肯定不解析
返回：
抛出：
WCMException

delete

public boolean delete(Template _templateToDelete)
               throws WCMException
删除指定的模板

参数：
_templateToDelete - 要删除的模板
返回：
抛出：
WCMException

preview

public java.lang.String preview(Template _currTemplate)
                         throws WCMException
预览指定的模板

参数：
_currTemplate - 要预览的模板
返回：
指定模板的内容
抛出：
WCMException

getTempAppendixesInRoot

public TempAppendixes getTempAppendixesInRoot(int _nRootType,
                                              int _nRootId,
                                              WCMFilter _filter)
                                       throws WCMException
get the template appendixes in the specified root

参数：
_nRootType - type of the root
_nRootId - id of the root
_filter - extra filter for the collection
返回：
Returns the template appendixes collection.
抛出：
WCMException - if failed to query and fetch the template appendixes.

getManagedTemplates

public Templates getManagedTemplates(IPublishFolder _folder,
                                     int _nTemplateType,
                                     WCMFilter _filter,
                                     boolean _bIncludingThoseInChildren)
                              throws WCMException
get the managed tempaltes in the specified folder

参数：
_folder - a publish folder
_nTemplateType - the template type which is defined in PublishConstants, like TEMPLATE_TYPE_OUTLINE
_filter - the extra filter for the collection.
_bIncludingThoseInChildren - if to fetch the templates in the children of the specified folder.
返回：
Returns the templates collection found.
抛出：
WCMException - if failed to query and fetch the templates collection.

getOptionalTemplates

public Templates getOptionalTemplates(IPublishFolder _folder,
                                      int _nTemplateType,
                                      WCMFilter _filter,
                                      boolean _bIncludingThoseInParent)
                               throws WCMException
get the managed tempaltes in the specified folder

参数：
_folder - a publish folder
_filter - the extra filter for the collection.
_nTemplateType - the template type which is defined in PublishConstants, like TEMPLATE_TYPE_OUTLINE
_bIncludingThoseInParent - if to fetch the templates in the children of the specified folder.
返回：
Returns the templates collection found.
抛出：
WCMException - if failed to query and fetch the templates collection.

redistributeAppendixes

public Reports redistributeAppendixes(IPublishFolder _folder,
                                      boolean _zRecursive)
                               throws WCMException
重新分发指定站点或者频道下的所有模板的附件，并且如果 _zRecursive 为 true ，则会进一步地重新分发子频道下的模板的附件。

参数：
_folder - 站点或者频道
_zRecursive - 是否递归子频道
返回：
执行结果
抛出：
WCMException - 如果发生异常

redistributeAppendixes

public Reports redistributeAppendixes(Templates _templates)
重新分发模板的所有附件

参数：
_templates -
返回：

updateNestedTemplateName

public void updateNestedTemplateName(Templates templates,
                                     java.lang.String sOldName,
                                     java.lang.String sNewName)
                              throws WCMException
抛出：
WCMException

processTemplateAppendixes

public java.lang.String processTemplateAppendixes(Template _template,
                                                  java.lang.String sTempText,
                                                  int _nPicMode)
                                           throws java.lang.Exception
将指定的內容处理成模板的格式，如：将里面的图片资源进行处理

参数：
_template -
stempText -
_nPicMode -
返回：
抛出：
java.lang.Exception

getTextWithImgFilter

public java.lang.String getTextWithImgFilter(Template _template,
                                             java.lang.String sText,
                                             boolean _bRemoveExtraAttribute)
                                      throws WCMException
抛出：
WCMException

copyVisualTempToChnls

public Reports copyVisualTempToChnls(Channels _toChannels,
                                     Template _srcTemplate)
                              throws WCMException
在指定栏目下，类似创建可视化模板

参数：
_toChannel - 要创建可视化模板的栏目
_srcTemplate - 源可视化模板
返回：
抛出：
java.lang.Exception
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateNestMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateNestMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateNestMgr

public class TemplateNestMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
template nest record manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateNestMgr()
方法摘要
boolean | addNestRecord(int _nTemplateId, int _nNestedTemplateId) add a template nest record
boolean | addNestRecord(int _nTemplateId, IPublishFolder _root, java.lang.String _sNestedTemplateName) add a template nest record
int | clearNestRecordsOf(Template _template) clear the nest records of the specified template
Templates | getNestedTemplates(Template _template) get the nested templates
Templates | getTemplatesNested(Template _template) 返回获取嵌套了指定模板的所有模板
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateNestMgr

public TemplateNestMgr()
方法详细信息

addNestRecord

public boolean addNestRecord(int _nTemplateId,
                             IPublishFolder _root,
                             java.lang.String _sNestedTemplateName)
                      throws WCMException
add a template nest record

参数：
_nTemplateId - the template id.
_root - the folder root where the template lies.
_sNestedTemplateName - name of the nested template.
返回：
Returns false if the nest record already exists; otherwise, returns true.
抛出：
WCMException - if failed to add the record.

addNestRecord

public boolean addNestRecord(int _nTemplateId,
                             int _nNestedTemplateId)
                      throws WCMException
add a template nest record

参数：
_nTemplateId - the template id who includes the nested template
_nNestedTemplateId - the nested template id
返回：
Returns true if
抛出：
WCMException

clearNestRecordsOf

public int clearNestRecordsOf(Template _template)
                       throws WCMException
clear the nest records of the specified template

参数：
_template - the template
返回：
Returns the records count deleted
抛出：
WCMException - if failed to delete the nest records.

getNestedTemplates

public Templates getNestedTemplates(Template _template)
                             throws WCMException
get the nested templates

参数：
_template - the template
返回：
Returns the nested templates collection.
抛出：
WCMException - if failed to lookup the nested templates.

getTemplatesNested

public Templates getTemplatesNested(Template _template)
                             throws WCMException
返回获取嵌套了指定模板的所有模板

参数：
_template - 指定的模板
返回：
嵌套了指定模板的所有模板
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParseAngel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateParseAngel

java.lang.Object
    继承者  java.lang.Thread
        继承者  com.trs.components.common.publish.domain.template.TemplateParseAngel
所有已实现的接口：
java.lang.Runnable
public class TemplateParseAngel
extends java.lang.Thread

Title: TRS 内容协作平台（TRS WCM）
Description:
template parse agel which runs background.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

嵌套类摘要
从类 java.lang.Thread 继承的嵌套类/接口
java.lang.Thread.State, java.lang.Thread.UncaughtExceptionHandler
字段摘要
从类 java.lang.Thread 继承的字段
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
方法摘要
void | run()
static void | scan(Template _template) Scans and parses a template.
static void | scanAll() Scans and parses all the unparsed templates in the system.
static void | scanIn(IPublishFolder _folder) Scans and parses the unparsed templates in the folder.
从类 java.lang.Thread 继承的方法
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, stop, stop, suspend, toString, yield
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

scanAll

public static void scanAll()
Scans and parses all the unparsed templates in the system.

scanIn

public static void scanIn(IPublishFolder _folder)
Scans and parses the unparsed templates in the folder.

参数：
_folder - a publish folder.

scan

public static void scan(Template _template)
Scans and parses a template.

参数：
_template - a template to parse.

run

public void run()
指定者：
接口 java.lang.Runnable 中的 run
覆盖：
类 java.lang.Thread 中的 run
另请参见：
Thread.run()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParseHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateParseHelper

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateParseHelper

public class TemplateParseHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
file distribute ship
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateParseHelper()
方法摘要
static java.util.ArrayList parseCssAndCopySrcFileAsTempAppedix(java.lang.String _sCSSFilePath, java.lang.String _sDestDir, Template _template)
ge add by gfc
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateParseHelper

public TemplateParseHelper()
方法详细信息

parseCssAndCopySrcFileAsTempAppedix

public static java.util.ArrayList parseCssAndCopySrcFileAsTempAppedix(java.lang.String _sCSSFilePath,
                                                                      java.lang.String _sDestDir,
                                                                      Template _template)
ge add by gfc

参数：
_sCSSFilePath - 要处理的css文件全路径
_sDestDir - 要拷贝到的目标文件目录
_template - 要附加到的模板对象
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParseMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateParseMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateParseMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class TemplateParseMgr
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
template parse manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateParseMgr()
constructor: default
方法摘要
boolean | checkGrammar(TagDocument _tagDoc, Report _report) 检查模板置标树的语法
TagDocument | checkLexical(Template _template, Report _report) 对模板的正文进行文法检查，如果没有文法错误，则返回模板置标树，如果存在文法错误， 则通过传入参数 _report 报告错误信息。
Report | checkTemplate(Template _template) 检查模板语法正确性
Report | checkTemplate(Template _template, boolean bCanEdit)
int | getCacheMaxSize() Returns the maximum size of the cache.
void | notifyOnAddObj(BaseObj objAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj objModified, int eventType) 修改一个对象后通知所有的Cache
void | notifyTemplateAdded(Template _template) Notifys template parse manager when a template is added.
void | notifyTemplateDeleted(Template _template) Notifys template parse manager wehn a template is deleted.
void | notifyTemplateModified(Template _template) Notifys template parse manager when a template is modified.
TagDocument | parse(Template _template) parse the specified template
void | setCacheMaxSize(int _nMaxSize) set the maximum size of the cache
void | uploadAppendixes(Template _template, boolean _bForceAll) Uploads the appendixes of the specified template.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateParseMgr

public TemplateParseMgr()
constructor: default

方法详细信息

setCacheMaxSize

public void setCacheMaxSize(int _nMaxSize)
set the maximum size of the cache

参数：
_nMaxSize - the maximum size which is 100 by default.

getCacheMaxSize

public int getCacheMaxSize()
Returns the maximum size of the cache.

返回：
the maximum size of the cache

parse

public TagDocument parse(Template _template)
                  throws java.lang.Exception
parse the specified template

参数：
_template - the template to parse.
返回：
Returns the parse result.
抛出：
java.lang.Exception - if failed to read and parse the template.

notifyTemplateAdded

public void notifyTemplateAdded(Template _template)
Notifys template parse manager when a template is added.
Template parse manager will run a background agent to parse the template.

参数：
_template - the template

notifyTemplateModified

public void notifyTemplateModified(Template _template)
                            throws WCMException
Notifys template parse manager when a template is modified.
Template parse manager will remove the parsed result of the specified template from cache.

参数：
_template - the template
抛出：
WCMException - if failed to update related data.

notifyTemplateDeleted

public void notifyTemplateDeleted(Template _template)
                           throws WCMException
Notifys template parse manager wehn a template is deleted.
Template parse manager will clear all the parsed result of the specified template from cache and database.

参数：
_template -
抛出：
WCMException

uploadAppendixes

public void uploadAppendixes(Template _template,
                             boolean _bForceAll)
                      throws WCMException
Uploads the appendixes of the specified template.

参数：
_template - a template.
_bForceAll - true, force to upload all appendixes.
抛出：
WCMException - if failed to upload the appendixes.

checkTemplate

public Report checkTemplate(Template _template)
检查模板语法正确性

参数：
_template - 需要检查的模板
返回：
报告对象，如果正确

checkTemplate

public Report checkTemplate(Template _template,
                            boolean bCanEdit)

checkLexical

public TagDocument checkLexical(Template _template,
                                Report _report)
对模板的正文进行文法检查，如果没有文法错误，则返回模板置标树，如果存在文法错误， 则通过传入参数 _report 报告错误信息。

参数：
_template - 模板的正文
_report - [in/out]参数，在有文法错误时返回错误信息
返回：
模板置标树

checkGrammar

public boolean checkGrammar(TagDocument _tagDoc,
                            Report _report)
检查模板置标树的语法

参数：
_tagDoc - 模板置标树
_report - [in/out]参数，在有语法错误时返回错误信息
返回：
如果没有语法错误，返回 true ，否则返回 false。

notifyOnAddObj

public void notifyOnAddObj(BaseObj objAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
objAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateQuoteMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateQuoteMgr

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateQuoteMgr

public class TemplateQuoteMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
template quote records manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateQuoteMgr()
constructor: default
方法摘要
int | clearQuotesOfFolder(int _nFolderType, int _nFolderId) Clears the quotes of the specified folder.
int | clearQuotesOfFolder(IPublishFolder _folder) Clears the quotes of the specified folder.
java.util.List | getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder _quotedFolder) find the folders whose outline quotes the contents of the specified folder.
void | save(java.util.List _quotes) saves the specified template quotes list.
void | save(TemplateQuote _quote) save a template quote
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateQuoteMgr

public TemplateQuoteMgr()
constructor: default

方法详细信息

save

public void save(TemplateQuote _quote)
          throws WCMException
save a template quote

参数：
_quote - template quote to save
抛出：
WCMException - if failed to save the quote record.

save

public void save(java.util.List _quotes)
          throws WCMException
saves the specified template quotes list.

参数：
_quotes - template quotes list.
抛出：
WCMException - if failed to save the quotes list.

clearQuotesOfFolder

public int clearQuotesOfFolder(IPublishFolder _folder)
                        throws WCMException
Clears the quotes of the specified folder.

参数：
_folder - the folder
返回：
Returns the number of the quotes which are cleared.
抛出：
WCMException - if failed to clear those quotes.

clearQuotesOfFolder

public int clearQuotesOfFolder(int _nFolderType,
                               int _nFolderId)
                        throws WCMException
Clears the quotes of the specified folder.

参数：
_nFolderType - type of the folder
_nFolderId - id of the folder
返回：
Returns the number of the quotes which are cleared.
抛出：
WCMException - if failed to clear those quotes.

getFoldersWhoseOutlineQuotesContentsOf

public java.util.List getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder _quotedFolder)
                                                      throws WCMException
find the folders whose outline quotes the contents of the specified folder.

参数：
_quotedFolder - a publish folder quoted by others
返回：
Returns the folders whose outline quotes the contents of the specified folder
抛出：
WCMException - if failed to query the folders.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateQuoteMgr0310

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.domain.template
类 TemplateQuoteMgr0310

java.lang.Object
    继承者  com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310

public class TemplateQuoteMgr0310
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
template quote records manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateQuoteMgr0310()
constructor: default
方法摘要
int | clearQuotesOfFolder(int _nFolderType, int _nFolderId) Clears the quotes of the specified folder.
int | clearQuotesOfFolder(IPublishFolder _folder) Clears the quotes of the specified folder.
java.util.List | getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder _quotedFolder) find the folders whose outline quotes the contents of the specified folder.
void | save(java.util.List _quotes) saves the specified template quotes list.
void | save(TemplateQuote _quote) save a template quote
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateQuoteMgr0310

public TemplateQuoteMgr0310()
constructor: default

方法详细信息

save

public void save(TemplateQuote _quote)
          throws WCMException
save a template quote

参数：
_quote - template quote to save
抛出：
WCMException - if failed to save the quote record.

save

public void save(java.util.List _quotes)
          throws WCMException
saves the specified template quotes list.

参数：
_quotes - template quotes list.
抛出：
WCMException - if failed to save the quotes list.

clearQuotesOfFolder

public int clearQuotesOfFolder(IPublishFolder _folder)
                        throws WCMException
Clears the quotes of the specified folder.

参数：
_folder - the folder
返回：
Returns the number of the quotes which are cleared.
抛出：
WCMException - if failed to clear those quotes.

clearQuotesOfFolder

public int clearQuotesOfFolder(int _nFolderType,
                               int _nFolderId)
                        throws WCMException
Clears the quotes of the specified folder.

参数：
_nFolderType - type of the folder
_nFolderId - id of the folder
返回：
Returns the number of the quotes which are cleared.
抛出：
WCMException - if failed to clear those quotes.

getFoldersWhoseOutlineQuotesContentsOf

public java.util.List getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder _quotedFolder)
                                                      throws WCMException
find the folders whose outline quotes the contents of the specified folder.

参数：
_quotedFolder - a publish folder quoted by others
返回：
Returns the folders whose outline quotes the contents of the specified folder
抛出：
WCMException - if failed to query the folders.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.domain.template.CSSResourceProcessor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.CSSResourceProcessor
的使用

没有 com.trs.components.common.publish.domain.template.CSSResourceProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr
的使用

使用 ITemplateEmployCacheMgr 的软件包
com.trs.components.common.publish.domain.template

com.trs.components.common.publish.domain.template 中 ITemplateEmployCacheMgr 的使用

实现 ITemplateEmployCacheMgr 的 com.trs.components.common.publish.domain.template 中的类
 class TemplateEmployCacheMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
模板和发布元素的配置缓冲管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr
的使用

没有 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged
的使用

没有 com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateArgumentMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateArgumentMgr
的使用

没有 com.trs.components.common.publish.domain.template.TemplateArgumentMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateCacheMgr
的使用

没有 com.trs.components.common.publish.domain.template.TemplateCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl
的使用

没有 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateEmployDetail
的使用

没有 com.trs.components.common.publish.domain.template.TemplateEmployDetail 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateEmployerIdsMan 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateEmployerIdsMan
的使用

没有 com.trs.components.common.publish.domain.template.TemplateEmployerIdsMan 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateEmployMgr
的使用

使用 TemplateEmployMgr 的软件包
com.trs.components.common.publish.domain.template

com.trs.components.common.publish.domain.template 中 TemplateEmployMgr 的使用

参数类型为 TemplateEmployMgr 的 com.trs.components.common.publish.domain.template 中的构造方法
TemplateEmployerIdsMan(IPublishElement _element, TemplateEmployMgr _manager, int _nTemplateType)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateExporter
的使用

没有 com.trs.components.common.publish.domain.template.TemplateExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateImporter
的使用

没有 com.trs.components.common.publish.domain.template.TemplateImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateLCListenerForNestedRename 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateLCListenerForNestedRename
的使用

没有 com.trs.components.common.publish.domain.template.TemplateLCListenerForNestedRename 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateLCListenerForTypeChanged 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateLCListenerForTypeChanged
的使用

没有 com.trs.components.common.publish.domain.template.TemplateLCListenerForTypeChanged 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateMgr
的使用

没有 com.trs.components.common.publish.domain.template.TemplateMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateNestMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateNestMgr
的使用

没有 com.trs.components.common.publish.domain.template.TemplateNestMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateParseAngel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateParseAngel
的使用

没有 com.trs.components.common.publish.domain.template.TemplateParseAngel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateParseHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateParseHelper
的使用

没有 com.trs.components.common.publish.domain.template.TemplateParseHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateParseMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateParseMgr
的使用

没有 com.trs.components.common.publish.domain.template.TemplateParseMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr
的使用

没有 com.trs.components.common.publish.domain.template.TemplateQuoteMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310
的使用

没有 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.publish.persistent.distribute
类
PublishDistribution
PublishDistributions


com.trs.components.common.publish.persistent.distribute

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.persistent.distribute

类摘要
PublishDistribution
PublishDistributions


com.trs.components.common.publish.persistent.distribute 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.distribute 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.publish.persistent.distribute.PublishDistribution
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.publish.persistent.distribute.PublishDistributions


软件包 com.trs.components.common.publish.persistent.distribute 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.distribute
的使用

使用 com.trs.components.common.publish.persistent.distribute 的软件包
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.persistent.distribute
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain.distribute 使用的 com.trs.components.common.publish.persistent.distribute 中的类
PublishDistribution
PublishDistributions

com.trs.components.common.publish.persistent.distribute 使用的 com.trs.components.common.publish.persistent.distribute 中的类
PublishDistribution
PublishDistributions

com.trs.service 使用的 com.trs.components.common.publish.persistent.distribute 中的类
PublishDistribution
PublishDistributions

com.trs.service.impl 使用的 com.trs.components.common.publish.persistent.distribute 中的类
PublishDistribution
PublishDistributions

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishDistribution

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.distribute
类 PublishDistribution

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.distribute.PublishDistribution
所有已实现的接口：
java.lang.Cloneable
public class PublishDistribution
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
PublishDistribution()
构造函数：保留默认接口
方法摘要
static PublishDistribution | createNewInstance() 产生当前对象[PublishDistributionConfig]的实例
static PublishDistribution | findById(int _nId) 提取指定ID的对象
static PublishDistribution | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDataPath() 提取属性：DataPath
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
IPublishFolder | getFolder()
int | getFolderId() 提取属性：FolderId
int | getFolderType() 提取属性：FolderTypeConfig
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getLoginPassword() 提取属性：LoginPassword
java.lang.String | getLoginUser() 提取属性：LoginUser
boolean | getPassiveMode() 提取属性：PASSIVEMODE，是否启用FTP协议中的Passive模式
int | getTargetPort() 提取属性：TargetPort，目标服务器的端口号
java.lang.String | getTargetServer() 提取属性：TargetServer
java.lang.String | getTargetType() 提取属性：TargetTypeConfig
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isAnonymous() 提取属性：ANONYMFTP，是否在FTP登录中使用匿名方式 为了避免在某些数据库中可能存在的冲突，所以没有使用“Anonymous”作为字段名，而是使用了“ANONYMFTP”
boolean | isEnabled() 提取属性：Enabled
boolean | isValid() 检验对象数据有效性
boolean | setAnonymous(boolean _zAnonymous) 设置属性：ANONYMFTP，是否在FTP登录中使用匿名方式 为了避免在某些数据库中可能存在的冲突，所以没有使用“Anonymous”作为字段名，而是使用了“ANONYMFTP”
boolean | setDataPath(java.lang.String _sDataPath) 设置属性：DataPath
boolean | setEnabled(boolean _bEnabled) 设置属性：Enabled
boolean | setFolder(int _nType, int _nId) 设置属性：FolderTypeConfig
boolean | setFolder(IPublishFolder _folder)
boolean | setLoginPassword(java.lang.String _sLoginPassword) 设置属性：LoginPassword
boolean | setLoginUser(java.lang.String _sLoginUser) 设置属性：LoginUser
boolean | setPassiveMode(boolean _bEnabled) 设置属性：PASSIVEMODE，禁用或者启用FTP协议中的Passive模式
boolean | setTargetPort(int _nServerPort) 设置属性：TargetPort，目标服务器的端口号
boolean | setTargetServer(java.lang.String _sServerAddress) 设置属性：TargetServer
boolean | setTargetType(java.lang.String _sName) 设置属性：TargetTypeConfig
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

PublishDistribution

public PublishDistribution()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getFolder

public IPublishFolder getFolder()
                         throws WCMException
抛出：
WCMException

getFolderType

public int getFolderType()
提取属性：FolderTypeConfig

返回：
FolderTypeConfig

getFolderId

public int getFolderId()
提取属性：FolderId

返回：
FolderId

setFolder

public boolean setFolder(int _nType,
                         int _nId)
                  throws WCMException
设置属性：FolderTypeConfig

参数：
_nType - folder type
_nId - folder id
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setFolder

public boolean setFolder(IPublishFolder _folder)
                  throws WCMException
抛出：
WCMException

getTargetType

public java.lang.String getTargetType()
提取属性：TargetTypeConfig

返回：
TargetTypeConfig

setTargetType

public boolean setTargetType(java.lang.String _sName)
                      throws WCMException
设置属性：TargetTypeConfig

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTargetServer

public java.lang.String getTargetServer()
提取属性：TargetServer

返回：
TargetServer

setTargetServer

public boolean setTargetServer(java.lang.String _sServerAddress)
                        throws WCMException
设置属性：TargetServer

参数：
_sServerAddress - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTargetPort

public int getTargetPort()
提取属性：TargetPort，目标服务器的端口号

返回：
目标服务器的端口号

setTargetPort

public boolean setTargetPort(int _nServerPort)
                      throws WCMException
设置属性：TargetPort，目标服务器的端口号

参数：
_nServerPort - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLoginUser

public java.lang.String getLoginUser()
提取属性：LoginUser

返回：
LoginUser

setLoginUser

public boolean setLoginUser(java.lang.String _sLoginUser)
                     throws WCMException
设置属性：LoginUser

参数：
_sLoginUser - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLoginPassword

public java.lang.String getLoginPassword()
提取属性：LoginPassword

返回：
LoginPassword

setLoginPassword

public boolean setLoginPassword(java.lang.String _sLoginPassword)
                         throws WCMException
设置属性：LoginPassword

参数：
_sLoginPassword - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDataPath

public java.lang.String getDataPath()
提取属性：DataPath

返回：
DataPath

setDataPath

public boolean setDataPath(java.lang.String _sDataPath)
                    throws WCMException
设置属性：DataPath

参数：
_sDataPath - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isAnonymous

public boolean isAnonymous()
提取属性：ANONYMFTP，是否在FTP登录中使用匿名方式 为了避免在某些数据库中可能存在的冲突，所以没有使用“Anonymous”作为字段名，而是使用了“ANONYMFTP”

返回：
Enabled

setAnonymous

public boolean setAnonymous(boolean _zAnonymous)
                     throws WCMException
设置属性：ANONYMFTP，是否在FTP登录中使用匿名方式 为了避免在某些数据库中可能存在的冲突，所以没有使用“Anonymous”作为字段名，而是使用了“ANONYMFTP”

参数：
_zAnonymous - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPassiveMode

public boolean getPassiveMode()
提取属性：PASSIVEMODE，是否启用FTP协议中的Passive模式

返回：
Enabled

setPassiveMode

public boolean setPassiveMode(boolean _bEnabled)
                       throws WCMException
设置属性：PASSIVEMODE，禁用或者启用FTP协议中的Passive模式

参数：
_bEnabled - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isEnabled

public boolean isEnabled()
提取属性：Enabled

返回：
Enabled

setEnabled

public boolean setEnabled(boolean _bEnabled)
                   throws WCMException
设置属性：Enabled

参数：
_bEnabled - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final PublishDistribution findById(int _nId)
                                          throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final PublishDistribution createNewInstance()
                                                   throws WCMException
产生当前对象[PublishDistributionConfig]的实例

返回：
当前对象的实例[PublishDistributionConfig]
抛出：
WCMException

findByKey

public static final PublishDistribution findByKey(java.lang.Object _oKey)
                                           throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


PublishDistributions

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.distribute
类 PublishDistributions

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.distribute.PublishDistributions

public class PublishDistributions
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
PublishDistributions(User _currUser)
构造函数
PublishDistributions(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static PublishDistributions | createNewInstance(User _currUser) 产生当前集合对象[PublishDistributions]的实例
static PublishDistributions | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static PublishDistributions | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PublishDistributions]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishDistributions

public PublishDistributions(User _currUser)
构造函数

另请参见：
PublishDistributions( User _currUser, int _initCapacity, int _incCapacity );

PublishDistributions

public PublishDistributions(User _currUser,
                            int _initCapacity,
                            int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final PublishDistributions findByIds(User _currUser,
                                                   java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（PublishDistributions）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final PublishDistributions openWCMObjs(User _currUser,
                                                     WCMFilter _filter)
                                              throws WCMException
通过指定一个Filter获取当前集合[PublishDistributions]

参数：
_filter - 指定的Filter
返回：
当前集合[PublishDistributions]
抛出：
WCMException

createNewInstance

public static PublishDistributions createNewInstance(User _currUser)
产生当前集合对象[PublishDistributions]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.distribute.PublishDistribution
的使用

使用 PublishDistribution 的软件包
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.persistent.distribute
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain.distribute 中 PublishDistribution 的使用

参数类型为 PublishDistribution 的 com.trs.components.common.publish.domain.distribute 中的方法
void | PublishDistributionList.delDistribution(PublishDistribution _distribution) 从列表中删除指定的分发点设置
void | PublishDistributionMgr.delete(PublishDistribution _distribution) Deletes a publish distribution.
void | UftpConnectionCacheManager.deleteDistribution(PublishDistribution _distribution) 删除和指定的PublishDistribution相关的FTP连接缓存管理器
FtpConnectionCache | UftpConnectionCacheManager.getConnectionCache(PublishDistribution dist) 返回和指定的PublishDistribution相关的FTP连接缓存管理器
FtpMgr | FileDistributorFtpCacheMgr.lookupFtpMgr(PublishDistribution _distribution) 已过时。 Returns the ftp manager of the specified distribution.
static IFileDistristributor | PublishDistributionMgr.makeDistristributor(PublishDistribution _distribution) 根据指定的分发点配置信息构造 IFileDistristributor 对象实例
void | PublishDistributionList.putDistribution(PublishDistribution _distribution) 向列表中增加或者替换列表中的分发点设置
void | PublishDistributionMgr.save(PublishDistribution _distribution) Saves the distribution setting.
void | FileDistributorImpFtpByTRS.setTargetRoot(PublishDistribution _distribution)
void | FileDistributorImpFileLocal.setTargetRoot(PublishDistribution _distribution)
void | IFileDistristributor.setTargetRoot(PublishDistribution _distribution) Sets the target root.
void | FileDistributorImpUnion.setTargetRoot(PublishDistribution _distribution)
void | FileDistributorFtpImpl.setTargetRoot(PublishDistribution _distribution) 已过时。
void | FileDistributorLocalImpl.setTargetRoot(PublishDistribution _distribution) 已过时。

com.trs.components.common.publish.persistent.distribute 中 PublishDistribution 的使用

返回 PublishDistribution 的 com.trs.components.common.publish.persistent.distribute 中的方法
static PublishDistribution | PublishDistribution.createNewInstance() 产生当前对象[PublishDistributionConfig]的实例
static PublishDistribution | PublishDistribution.findById(int _nId) 提取指定ID的对象
static PublishDistribution | PublishDistribution.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 PublishDistribution 的使用

返回 PublishDistribution 的 com.trs.service 中的方法
 PublishDistribution IWCMPublishElementService.save(WebSite _currSite, PublishDistribution _currPublishDistribution)
保存当前站点所设置的分发目录

参数类型为 PublishDistribution 的 com.trs.service 中的方法
 PublishDistribution IWCMPublishElementService.save(WebSite _currSite, PublishDistribution _currPublishDistribution)
保存当前站点所设置的分发目录

com.trs.service.impl 中 PublishDistribution 的使用

返回 PublishDistribution 的 com.trs.service.impl 中的方法
 PublishDistribution WCMPublishElementServiceImpl.save(WebSite _currSite, PublishDistribution _currPublishDistribution)

参数类型为 PublishDistribution 的 com.trs.service.impl 中的方法
 PublishDistribution WCMPublishElementServiceImpl.save(WebSite _currSite, PublishDistribution _currPublishDistribution)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.distribute.PublishDistributions
的使用

使用 PublishDistributions 的软件包
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.persistent.distribute
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain.distribute 中 PublishDistributions 的使用

返回 PublishDistributions 的 com.trs.components.common.publish.domain.distribute 中的方法
 PublishDistributions PublishDistributionMgr.getDistributionsOf(IPublishFolder _folder, boolean _bExcludingDisabled, WCMFilter _filter)
get the publish distributions of the specified folder.

com.trs.components.common.publish.persistent.distribute 中 PublishDistributions 的使用

返回 PublishDistributions 的 com.trs.components.common.publish.persistent.distribute 中的方法
static PublishDistributions | PublishDistributions.createNewInstance(User _currUser) 产生当前集合对象[PublishDistributions]的实例
static PublishDistributions | PublishDistributions.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static PublishDistributions | PublishDistributions.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PublishDistributions]

com.trs.service 中 PublishDistributions 的使用

返回 PublishDistributions 的 com.trs.service 中的方法
 PublishDistributions IWCMPublishElementService.findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter)
获取当前站点所设置的分发目录集合

com.trs.service.impl 中 PublishDistributions 的使用

返回 PublishDistributions 的 com.trs.service.impl 中的方法
 PublishDistributions WCMPublishElementServiceImpl.findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IAppendix

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
接口 IAppendix

public interface IAppendix

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IAppendixes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
接口 IAppendixes

public interface IAppendixes

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishContent

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
接口 IPublishContent

所有超级接口：
ICMSObjSubstanceContent, IPublishElement
所有已知实现类：
PublishContentDefaultObjImpl, PublishContentDocumentImpl, PublishContentImplBase, PublishContentViewDataImpl, PublishContentViewFieldImpl, PublishContentViewImpl, PublishContentWrapper
public interface IPublishContent
extends IPublishElement

Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
int | getBodyType() Returns the content body type
CMyDateTime | getCreatedTime() Returns the created time of this content.
Template | getDetailTemplate() Returns the detail template of this content.
java.lang.String | getFileName()
FileNamedStyle | getFileNamedStyle()
int | getModal() Returns the content modal in the curernt folder
IPublishFolder | getOriginalHome() Returns the folder where this content originally lies.
IPublishFolder | getRealHome() Returns the folder where this content currently lies.
java.util.Iterator | getRelatedResources() 获取Content相关的资源文件(如附件等)
boolean | isFile()
boolean | isPublishedInHome() Returns true if this content has been published in its home folder.
void | setFolder(IPublishFolder _folder) Sets the folder where this content currently lies.
void | setPublishStatus(int _nStatus) Sets the publish status of this content in the specified folder
void | setPublishTime(CMyDateTime _dtTime) 设置当前内容的发布时间
void | setPublishTimeAndURL(CMyDateTime _time, java.lang.String url) 设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
从接口 com.trs.components.common.publish.persistent.element.IPublishElement 继承的方法
canDoPreview, getEncoding, getFolder, getLinkUrl, getTemplateArguments, isCanDoSave, isFolder, isLink, isValidElement, validateCanDoPreview, validateCanDoPub
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

方法详细信息

setFolder

void setFolder(IPublishFolder _folder)
Sets the folder where this content currently lies.

参数：
_folder - the current folder
抛出：
WCMException - if failed.

getModal

int getModal()
             throws WCMException
Returns the content modal in the curernt folder

返回：
Returns the content modal type which is defined in CMSConstants like CONTENT_MODAL_ENTITY, CONTENT_MODAL_LINK, etc.
抛出：
WCMException - if failed to load this property.

getBodyType

int getBodyType()
Returns the content body type

返回：
Returns the content body type which is defined in CMSConstants like CONTENT_BODY_NORMAL, CONTENT_BODY_HTML, etc.

isPublishedInHome

boolean isPublishedInHome()
                          throws java.lang.Exception
Returns true if this content has been published in its home folder.

返回：
true if this content has been published in its home folder.
抛出：
java.lang.Exception - if failed to get the publish status of this content in its home.

setPublishStatus

void setPublishStatus(int _nStatus)
                      throws WCMException
Sets the publish status of this content in the specified folder

参数：
_currUser - the current user
_folder - the folder where this content lies
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, etc.
抛出：
java.lang.Exception - if fails to update the folder status
WCMException

setPublishTime

void setPublishTime(CMyDateTime _dtTime)
                    throws WCMException
设置当前内容的发布时间

参数：
_dtTime - CMyDateTime实例对象，如果为null表示页面被取消了
抛出：
WCMException - 如果发生错误

setPublishTimeAndURL

void setPublishTimeAndURL(CMyDateTime _time,
                          java.lang.String url)
                          throws WCMException
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消

参数：
_time - 发布的时间
url - 发布后的URL
抛出：
WCMException - 如果发生错误

getOriginalHome

IPublishFolder getOriginalHome()
                               throws WCMException
Returns the folder where this content originally lies.

返回：
the folder where this content originally lies.
抛出：
WCMException - if failed.

getRealHome

IPublishFolder getRealHome()
                           throws WCMException
Returns the folder where this content currently lies.

返回：
the folder where this content currently lies.
抛出：
WCMException - if failed.

getCreatedTime

CMyDateTime getCreatedTime()
Returns the created time of this content.

返回：
the created time of this content.

getDetailTemplate

Template getDetailTemplate()
Returns the detail template of this content.

返回：
the detail template of this content.
抛出：
WCMException - if failed to find the template.

isFile

boolean isFile()
返回：
true if the document is a link;
otherwise, returns false.

getFileName

java.lang.String getFileName()
返回：
the linked url if this document is a link;
otherwise, returns null.

getFileNamedStyle

FileNamedStyle getFileNamedStyle()

getRelatedResources

java.util.Iterator getRelatedResources()
                                       throws WCMException
获取Content相关的资源文件(如附件等)

返回：
相关资源文件的文件名集合,可能返回null
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishElement

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
接口 IPublishElement

所有超级接口：
ICMSObjSubstanceContent
所有已知子接口：
IPublishContent, IPublishFolder
所有已知实现类：
EpressFolderWrapper, PublishContentDefaultObjImpl, PublishContentDocumentImpl, PublishContentImplBase, PublishContentViewDataImpl, PublishContentViewFieldImpl, PublishContentViewImpl, PublishContentWrapper, PublishElementWrapper, PublishFolderChannelImpl, PublishFolderClassImpl, PublishFolderImplBase, PublishFolderWebSiteImpl, PublishFolderWrapper
public interface IPublishElement
extends ICMSObjSubstanceContent

Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | canDoPreview() 判断发布元素是否可以预览
java.lang.String | getEncoding() Returns the file encoding of this element.
IPublishFolder | getFolder() Returns the folder where this element currently lies.
java.lang.String | getLinkUrl()
java.util.HashMap | getTemplateArguments() 返回该发布对象已经进行了有效设置的全部模板参数列表
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isFolder() Returns true if current element is a folder.
boolean | isLink()
boolean | isValidElement() 判断是否为有效的发布元素
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
boolean | validateCanDoPub() Returns true if the folder is can be published.
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

方法详细信息

isFolder

boolean isFolder()
Returns true if current element is a folder.

返回：
true if current element is a folder.

getFolder

IPublishFolder getFolder()
Returns the folder where this element currently lies.

返回：
the folder where this element currently lies.

getEncoding

java.lang.String getEncoding()
                             throws WCMException
Returns the file encoding of this element.

返回：
the file encoding of this element
抛出：
WCMException - if failed to find the file encoding.

validateCanDoPub

boolean validateCanDoPub()
                         throws WCMException
Returns true if the folder is can be published.

返回：
true if the folder is can be published.
抛出：
WCMException

isValidElement

boolean isValidElement()
判断是否为有效的发布元素

返回：

isLink

boolean isLink()
返回：
true if the eliement is a link;
otherwise, returns false.

getLinkUrl

java.lang.String getLinkUrl()
返回：
the linked url if this eliement is a link;
otherwise, returns null.

validateCanDoPreview

void validateCanDoPreview()
                          throws WCMException
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

抛出：
WCMException

canDoPreview

boolean canDoPreview()
判断发布元素是否可以预览

返回：

getTemplateArguments

java.util.HashMap getTemplateArguments()
                                       throws WCMException
返回该发布对象已经进行了有效设置的全部模板参数列表

返回：
该发布对象已经进行了有效设置的全部模板参数列表
抛出：
WCMException

isCanDoSave

boolean isCanDoSave(User _loginUser)
                    throws WCMException
指定用户是否可以保存当前对象

参数：
_loginUser -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishElements

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
接口 IPublishElements

所有已知实现类：
PublishElementsCMSListImpl, PublishElementsCMSObjsImpl, PublishElementsListImpl
public interface IPublishElements

Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | add(java.lang.Object _element) Adds an element into the collection.
void | clear() Removes all the elements from this collection.
IPublishElement | get(int _nIndex) Returns the element at the specified position in this collection.
boolean | isEmpty() Returns true if this collection contains no elements.
void | remove(int _nIndex)
int | size() Returns the number of elements in this collection.

方法详细信息

size

int size()
Returns the number of elements in this collection.

返回：
the number of elements in this collection

isEmpty

boolean isEmpty()
Returns true if this collection contains no elements.

返回：
true if this collection contains no elements

clear

void clear()
Removes all the elements from this collection.

get

IPublishElement get(int _nIndex)
                    throws WCMException
Returns the element at the specified position in this collection.

参数：
_nIndex - index of the element to return.
返回：
the element at the specified position in this collection.
抛出：
java.lang.Exception
java.lang.IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= size()).
WCMException

add

void add(java.lang.Object _element)
         throws java.lang.Exception
Adds an element into the collection.

参数：
_element - an element to add.
抛出：
java.lang.Exception - if the speicified element is not a valid element type in collection.

remove

void remove(int _nIndex)
            throws WCMException
参数：
_nIndex -
抛出：
java.lang.Exception
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishFolder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
接口 IPublishFolder

所有超级接口：
ICMSObjSubstanceContent, IPublishElement
所有已知实现类：
EpressFolderWrapper, PublishFolderChannelImpl, PublishFolderClassImpl, PublishFolderImplBase, PublishFolderWebSiteImpl, PublishFolderWrapper
public interface IPublishFolder
extends IPublishElement

Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | canDoBatchDetailPageTask()
boolean | canDoDetailPageTask() check if can create detail page task
boolean | canDoOutlinePageTask() check if can create outline page task
IPublishElements | getAllContents(WCMFilter _filter) Returns all the contents to publish
IPublishElementsIterator | getAllContentsIterator(WCMFilter _filter)
IPublishElements | getChildren() get the children folders
java.lang.String | getDataPath()
Template | getDetailTemplate() get the detail template of the current folder.
java.util.Collection | getFoldersQuotingMe() Returns the content folders who are quoting this folder
IPublishElements | getIncreasedContents(WCMFilter _filter) Returns the increased contents to publish
IPublishElementsIterator | getIncreasedContentsIterator(WCMFilter _filter)
Templates | getOutlineTemplates() get the outline templates of the current folder.
IPublishFolder | getParent()
java.lang.String | getPathKey() 获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写
IPublishElements | getPublishedContents(WCMFilter _filter) Returns the contents which have been published.
IPublishFolder | getRoot()
java.lang.String | getRootDomain() Returns the root domain of current folder.
int | getSiblingIndex() Retuns index of this folder in its siblings.
boolean | isDeleted() 是否已经被假删除
boolean | isRoot()
void | setPublishStatus(int _nStatus) Sets the publish status of this folder
从接口 com.trs.components.common.publish.persistent.element.IPublishElement 继承的方法
canDoPreview, getEncoding, getFolder, getLinkUrl, getTemplateArguments, isCanDoSave, isFolder, isLink, isValidElement, validateCanDoPreview, validateCanDoPub
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

方法详细信息

getIncreasedContents

IPublishElements getIncreasedContents(WCMFilter _filter)
                                      throws java.lang.Exception
Returns the increased contents to publish

参数：
_filter - extra query filter for the collection
返回：
the contents collection, which are not published but can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getAllContents

IPublishElements getAllContents(WCMFilter _filter)
                                throws java.lang.Exception
Returns all the contents to publish

参数：
_filter - extra query filter for the collection
返回：
all the contents which have been published or can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getPublishedContents

IPublishElements getPublishedContents(WCMFilter _filter)
                                      throws java.lang.Exception
Returns the contents which have been published.

参数：
_filter - extra query filter for the collection
返回：
the contents which have been published
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getFoldersQuotingMe

java.util.Collection getFoldersQuotingMe()
                                         throws WCMException
Returns the content folders who are quoting this folder

返回：
the folders collection who are quoting this folder
抛出：
WCMException - if fails to fetch the folders collection

getOutlineTemplates

Templates getOutlineTemplates()
get the outline templates of the current folder.

返回：
the outline templates of current folder.
抛出：
java.lang.Exception - if encounter errors.

getDetailTemplate

Template getDetailTemplate()
get the detail template of the current folder.

返回：
the detail template of current folder.
抛出：
java.lang.Exception - if encounter errors.

getRootDomain

java.lang.String getRootDomain()
                               throws WCMException
Returns the root domain of current folder.

返回：
the root domain of current folder.
抛出：
WCMException - if failed to load the folder publish config.

getDataPath

java.lang.String getDataPath()
                             throws WCMException
返回：
the data path.
抛出：
WCMException

isRoot

boolean isRoot()
返回：
true if this folder is a root; otherwise, returns false.

getRoot

IPublishFolder getRoot()
                       throws WCMException
返回：
the root of this folder.
抛出：
WCMException - if failed to find the folder root.

getParent

IPublishFolder getParent()
                         throws WCMException
返回：
the parent of this folder.
抛出：
WCMException - if failed to fetch the parent folder.

getChildren

IPublishElements getChildren()
                             throws WCMException
get the children folders

返回：
the children folders collection.
抛出：
WCMException - if failed to fetch the children.

getSiblingIndex

int getSiblingIndex()
                    throws WCMException
Retuns index of this folder in its siblings.

返回：
index of this folder in its siblings.
抛出：
WCMException - if failed to calculate the index.

canDoOutlinePageTask

boolean canDoOutlinePageTask()
check if can create outline page task

返回：

canDoDetailPageTask

boolean canDoDetailPageTask()
check if can create detail page task

返回：

canDoBatchDetailPageTask

boolean canDoBatchDetailPageTask()

getIncreasedContentsIterator

IPublishElementsIterator getIncreasedContentsIterator(WCMFilter _filter)
                                                      throws java.lang.Exception
抛出：
java.lang.Exception

getAllContentsIterator

IPublishElementsIterator getAllContentsIterator(WCMFilter _filter)
                                                throws java.lang.Exception
抛出：
java.lang.Exception

isDeleted

boolean isDeleted()
是否已经被假删除

返回：

setPublishStatus

void setPublishStatus(int _nStatus)
                      throws WCMException
Sets the publish status of this folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, STATUS_DELETEDetc.
抛出：
java.lang.Exception - if fails to update the folder status
WCMException

getPathKey

java.lang.String getPathKey()
                            throws WCMException
获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.persistent.element
接口
IAppendix
IAppendixes
IPublishContent
IPublishElement
IPublishElements
IPublishFolder
类
PublishContentDefaultObjImpl
PublishContentImplBase
PublishContentWrapper
PublishElementFactory
PublishElementsCMSListImpl
PublishElementsCMSObjsImpl
PublishElementsListImpl
PublishElementWrapper
PublishFolderImplBase
PublishFolderWrapper


com.trs.components.common.publish.persistent.element

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.persistent.element

接口摘要
IAppendix | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IAppendixes | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IPublishContent | Title: TRS 内容协作平台（TRS WCM） Description: publish content interface, which is one kind of IPublishElement.
IPublishElement | Title: TRS 内容协作平台（TRS WCM） Description: the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements | Title: TRS 内容协作平台（TRS WCM） Description: publish element collection.
IPublishFolder | Title: TRS 内容协作平台（TRS WCM） Description: publish folder interface, which is one kind of IPublishElement.

类摘要
PublishContentDefaultObjImpl |
PublishContentImplBase | Title: TRS 内容协作平台（TRS WCM） Description: implementation base for publish content.
PublishContentWrapper | IPublishContent的代理实现
PublishElementFactory | Title: TRS 内容协作平台（TRS WCM） Description: factory of publish element instance.
PublishElementsCMSListImpl | Title: TRS 内容协作平台（TRS WCM） Description: PublishElements implementation with CMS object list.
PublishElementsCMSObjsImpl | Title: TRS 内容协作平台（TRS WCM） Description: publish elements collection CMS implementation.
PublishElementsListImpl | Title: TRS 内容协作平台（TRS WCM） Description: IPublishElements implementation with list.
PublishElementWrapper | IPublishElement的代理实现
PublishFolderImplBase | Title: TRS 内容协作平台（TRS WCM） Description: implementation base for IPublishFolder.
PublishFolderWrapper | IPublishFolder的代理实现


com.trs.components.common.publish.persistent.element 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.element 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.persistent.element.PublishContentImplBase (implements com.trs.components.common.publish.persistent.element.IPublishContent)
      • com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl
    • com.trs.components.common.publish.persistent.element.PublishElementFactory
    • com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl (implements com.trs.components.common.publish.persistent.element.IPublishElements)
    • com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl (implements com.trs.components.common.publish.persistent.element.IPublishElements)
    • com.trs.components.common.publish.persistent.element.PublishElementsListImpl (implements com.trs.components.common.publish.persistent.element.IPublishElements)
    • com.trs.components.common.publish.persistent.element.PublishElementWrapper (implements com.trs.components.common.publish.persistent.element.IPublishElement)
      • com.trs.components.common.publish.persistent.element.PublishContentWrapper (implements com.trs.components.common.publish.persistent.element.IPublishContent)
      • com.trs.components.common.publish.persistent.element.PublishFolderWrapper (implements com.trs.components.common.publish.persistent.element.IPublishFolder)
    • com.trs.components.common.publish.persistent.element.PublishFolderImplBase (implements com.trs.components.common.publish.persistent.element.IPublishFolder)

接口分层结构

  • com.trs.components.common.publish.persistent.element.IAppendix
  • com.trs.components.common.publish.persistent.element.IAppendixes
  • com.trs.cms.content.ICMSObjSubstanceContent
    • com.trs.components.common.publish.persistent.element.IPublishElement
      • com.trs.components.common.publish.persistent.element.IPublishContent
      • com.trs.components.common.publish.persistent.element.IPublishFolder
  • com.trs.components.common.publish.persistent.element.IPublishElements


软件包 com.trs.components.common.publish.persistent.element 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.element
的使用

使用 com.trs.components.common.publish.persistent.element 的软件包
com.trs.ajaxservice |
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.config |
com.trs.components.common.publish.domain |
com.trs.components.common.publish.domain.distribute |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.service |
com.trs.service.impl |
com.trs.template.service.impl |
com.trs.wcmonline |

com.trs.ajaxservice 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.comment.publish.tagparser 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.config 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.

com.trs.components.common.publish.domain 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.domain.distribute 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.domain.publisher 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.domain.tagparser 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.domain.taskdispatch 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.domain.template 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.persistent.distribute 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.persistent.element 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.
PublishContentImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for publish content.
PublishElementWrapper
IPublishElement的代理实现

com.trs.components.common.publish.persistent.publisher 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.persistent.taskdispatch 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.persistent.template 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.widget 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.common.publish.widget.tagparser 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.infoview.publish.tagparser 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.metadata.publish 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.
PublishContentImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for publish content.
PublishFolderImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for IPublishFolder.

com.trs.components.wcm.epress 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.
PublishFolderImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for IPublishFolder.

com.trs.components.wcm.publish 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.wcm.publish.element 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.
PublishContentImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for publish content.
PublishFolderImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for IPublishFolder.

com.trs.components.wcm.publish.region 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.components.wcm.publish.tagparser 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.service 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.service.impl 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishContent
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.template.service.impl 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

com.trs.wcmonline 使用的 com.trs.components.common.publish.persistent.element 中的类
IPublishFolder
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishContentDefaultObjImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishContentDefaultObjImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishContentImplBase
        继承者  com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl
所有已实现的接口：
ICMSObjSubstanceContent, IPublishContent, IPublishElement
public class PublishContentDefaultObjImpl
extends PublishContentImplBase

构造方法摘要
PublishContentDefaultObjImpl()
PublishContentDefaultObjImpl(DefaultObj _obj)
方法摘要
int | getBodyType() Returns the content body type
IPublishFolder | getOriginalHome() Returns the folder where this content originally lies.
java.util.Iterator | getRelatedResources() 获取Content相关的资源文件(如附件等)
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isPublishedInHome() Returns true if this content has been published in its home folder.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setPublishedStatus(int _nPublishedStatus)
void | setPublishStatus(int _nStatus) Sets the publish status of this content in the specified folder
void | setPublishTime(CMyDateTime _dtTime) 设置当前内容的发布时间
void | setPublishTimeAndURL(CMyDateTime _time, java.lang.String url) 设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
void | setPubTimeAndURLFieldName(java.lang.String _sPubTimeFieldName, java.lang.String _sURLFieldName)
void | setStatusFieldName(java.lang.String _sStatusFieldName)
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
从类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 继承的方法
canDoPreview, equals, getCreatedTime, getDetailTemplate, getDetailTemplateType, getEncoding, getFileName, getFileNamedStyle, getFolder, getId, getInfo, getLinkUrl, getModal, getRealHome, getTemplateArguments, isFile, isFolder, isLink, isValidElement, setDetailTemplateType, setFolder, validateCanDoPub
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishContentDefaultObjImpl

public PublishContentDefaultObjImpl()

PublishContentDefaultObjImpl

public PublishContentDefaultObjImpl(DefaultObj _obj)
方法详细信息

setStatusFieldName

public void setStatusFieldName(java.lang.String _sStatusFieldName)

setPubTimeAndURLFieldName

public void setPubTimeAndURLFieldName(java.lang.String _sPubTimeFieldName,
                                      java.lang.String _sURLFieldName)

setPublishedStatus

public void setPublishedStatus(int _nPublishedStatus)

getBodyType

public int getBodyType()
从接口 IPublishContent 复制的描述
Returns the content body type

返回：
Returns the content body type which is defined in CMSConstants like CONTENT_BODY_NORMAL, CONTENT_BODY_HTML, etc.

isPublishedInHome

public boolean isPublishedInHome()
                          throws java.lang.Exception
从接口 IPublishContent 复制的描述
Returns true if this content has been published in its home folder.

返回：
true if this content has been published in its home folder.
抛出：
java.lang.Exception - if failed to get the publish status of this content in its home.

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishContent 复制的描述
Sets the publish status of this content in the specified folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, etc.
抛出：
WCMException

setPublishTime

public void setPublishTime(CMyDateTime _dtTime)
                    throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容的发布时间

参数：
_dtTime - CMyDateTime实例对象，如果为null表示页面被取消了
抛出：
WCMException - 如果发生错误

setPublishTimeAndURL

public void setPublishTimeAndURL(CMyDateTime _time,
                                 java.lang.String url)
                          throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消

参数：
_time - 发布的时间
url - 发布后的URL
抛出：
WCMException - 如果发生错误

getOriginalHome

public IPublishFolder getOriginalHome()
从接口 IPublishContent 复制的描述
Returns the folder where this content originally lies.

返回：
the folder where this content originally lies.

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

抛出：
WCMException

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

返回：
the publish content type

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

参数：
_cmsObj - a CMS object

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

getRelatedResources

public java.util.Iterator getRelatedResources()
从接口 IPublishContent 复制的描述
获取Content相关的资源文件(如附件等)

返回：
相关资源文件的文件名集合,可能返回null

isCanDoSave

public boolean isCanDoSave(User _loginUser)
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishContentImplBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishContentImplBase

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishContentImplBase
所有已实现的接口：
ICMSObjSubstanceContent, IPublishContent, IPublishElement
直接已知子类：
PublishContentDefaultObjImpl, PublishContentDocumentImpl, PublishContentViewDataImpl, PublishContentViewFieldImpl, PublishContentViewImpl
public abstract class PublishContentImplBase
extends java.lang.Object
implements IPublishContent

Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for publish content.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishContentImplBase()
方法摘要
boolean | canDoPreview() 判断发布元素是否可以预览
boolean | equals(java.lang.Object _another)
CMyDateTime | getCreatedTime() Returns the created time of this content.
Template | getDetailTemplate() Returns the detail template of this content.
int | getDetailTemplateType()
java.lang.String | getEncoding() Returns the file encoding of this element.
java.lang.String | getFileName()
FileNamedStyle | getFileNamedStyle()
IPublishFolder | getFolder() Returns the folder where this element currently lies.
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
java.lang.String | getLinkUrl()
int | getModal() Returns the content modal in the curernt folder
IPublishFolder | getRealHome() Returns the folder where this content currently lies.
java.util.HashMap | getTemplateArguments() 返回该发布对象已经进行了有效设置的全部模板参数列表
boolean | isFile()
boolean | isFolder() Returns true if current element is a folder.
boolean | isLink()
boolean | isValidElement() 判断是否为有效的发布元素
void | setDetailTemplateType(int detailTemplateType)
void | setFolder(IPublishFolder _folder) Sets the folder where this content currently lies.
boolean | validateCanDoPub() Returns true if the folder is can be published.
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.persistent.element.IPublishContent 继承的方法
getBodyType, getOriginalHome, getRelatedResources, isPublishedInHome, setPublishStatus, setPublishTime, setPublishTimeAndURL
从接口 com.trs.components.common.publish.persistent.element.IPublishElement 继承的方法
isCanDoSave, validateCanDoPreview
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getSubstance, getType, loadById, makeFrom, setSubstance

构造方法详细信息

PublishContentImplBase

public PublishContentImplBase()
方法详细信息

isFolder

public boolean isFolder()
从接口 IPublishElement 复制的描述
Returns true if current element is a folder.

指定者：
接口 IPublishElement 中的 isFolder
返回：
true if current element is a folder.
另请参见：
IPublishElement.isFolder()

getFolder

public IPublishFolder getFolder()
从接口 IPublishElement 复制的描述
Returns the folder where this element currently lies.

指定者：
接口 IPublishElement 中的 getFolder
返回：
the folder where this element currently lies.
另请参见：
IPublishElement.getFolder()

setFolder

public void setFolder(IPublishFolder _folder)
从接口 IPublishContent 复制的描述
Sets the folder where this content currently lies.

指定者：
接口 IPublishContent 中的 setFolder
参数：
_folder - the current folder
另请参见：
IPublishContent.setFolder(IPublishFolder)

getEncoding

public java.lang.String getEncoding()
                             throws WCMException
从接口 IPublishElement 复制的描述
Returns the file encoding of this element.

指定者：
接口 IPublishElement 中的 getEncoding
返回：
the file encoding of this element
抛出：
WCMException - if failed to find the file encoding.
另请参见：
IPublishElement.getEncoding()

getRealHome

public IPublishFolder getRealHome()
                           throws WCMException
从接口 IPublishContent 复制的描述
Returns the folder where this content currently lies.

指定者：
接口 IPublishContent 中的 getRealHome
返回：
the folder where this content currently lies.
抛出：
WCMException - if failed.
另请参见：
IPublishContent.getRealHome()

getTemplateArguments

public java.util.HashMap getTemplateArguments()
                                       throws WCMException
从接口 IPublishElement 复制的描述
返回该发布对象已经进行了有效设置的全部模板参数列表

指定者：
接口 IPublishElement 中的 getTemplateArguments
返回：
该发布对象已经进行了有效设置的全部模板参数列表
抛出：
WCMException

getDetailTemplate

public Template getDetailTemplate()
从接口 IPublishContent 复制的描述
Returns the detail template of this content.

指定者：
接口 IPublishContent 中的 getDetailTemplate
返回：
the detail template of this content.
另请参见：
IPublishContent.getDetailTemplate()

getDetailTemplateType

public int getDetailTemplateType()

setDetailTemplateType

public void setDetailTemplateType(int detailTemplateType)

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder
另请参见：
ICMSObjSubstanceContent.getInfo()

canDoPreview

public boolean canDoPreview()
从接口 IPublishElement 复制的描述
判断发布元素是否可以预览

指定者：
接口 IPublishElement 中的 canDoPreview
返回：

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

isLink

public boolean isLink()
指定者：
接口 IPublishElement 中的 isLink
返回：
true if the eliement is a link;
otherwise, returns false.

getLinkUrl

public java.lang.String getLinkUrl()
指定者：
接口 IPublishElement 中的 getLinkUrl
返回：
the linked url if this eliement is a link;
otherwise, returns null.

getModal

public int getModal()
             throws WCMException
从接口 IPublishContent 复制的描述
Returns the content modal in the curernt folder

指定者：
接口 IPublishContent 中的 getModal
返回：
Returns the content modal type which is defined in CMSConstants like CONTENT_MODAL_ENTITY, CONTENT_MODAL_LINK, etc.
抛出：
WCMException - if failed to load this property.

validateCanDoPub

public boolean validateCanDoPub()
                         throws WCMException
从接口 IPublishElement 复制的描述
Returns true if the folder is can be published.

指定者：
接口 IPublishElement 中的 validateCanDoPub
返回：
true if the folder is can be published.
抛出：
WCMException

isValidElement

public boolean isValidElement()
从接口 IPublishElement 复制的描述
判断是否为有效的发布元素

指定者：
接口 IPublishElement 中的 isValidElement
返回：

getCreatedTime

public CMyDateTime getCreatedTime()
从接口 IPublishContent 复制的描述
Returns the created time of this content.

指定者：
接口 IPublishContent 中的 getCreatedTime
返回：
the created time of this content.

isFile

public boolean isFile()
指定者：
接口 IPublishContent 中的 isFile
返回：
true if the document is a link;
otherwise, returns false.

getFileName

public java.lang.String getFileName()
指定者：
接口 IPublishContent 中的 getFileName
返回：
the linked url if this document is a link;
otherwise, returns null.

getFileNamedStyle

public FileNamedStyle getFileNamedStyle()
指定者：
接口 IPublishContent 中的 getFileNamedStyle
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishContentWrapper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishContentWrapper

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishElementWrapper
        继承者  com.trs.components.common.publish.persistent.element.PublishContentWrapper
所有已实现的接口：
ICMSObjSubstanceContent, IPublishContent, IPublishElement
public class PublishContentWrapper
extends PublishElementWrapper
implements IPublishContent

IPublishContent的代理实现

作者：
Martin (付成睿)

构造方法摘要
PublishContentWrapper(IPublishContent content)
使用给定的 IPublishContent 实例构造 PublishContentWrapper 代理对象
方法摘要
int | getBodyType() Returns the content body type
CMyDateTime | getCreatedTime() Returns the created time of this content.
Template | getDetailTemplate() Returns the detail template of this content.
java.lang.String | getFileName()
FileNamedStyle | getFileNamedStyle()
int | getModal() Returns the content modal in the curernt folder
IPublishFolder | getOriginalHome() Returns the folder where this content originally lies.
IPublishFolder | getRealHome() Returns the folder where this content currently lies.
java.util.Iterator | getRelatedResources() 获取Content相关的资源文件(如附件等)
boolean | isFile()
boolean | isPublishedInHome() Returns true if this content has been published in its home folder.
void | setFolder(IPublishFolder _folder) Sets the folder where this content currently lies.
void | setPublishStatus(int _nStatus) Sets the publish status of this content in the specified folder
void | setPublishTime(CMyDateTime _dtTime) 设置当前内容的发布时间
void | setPublishTimeAndURL(CMyDateTime _time, java.lang.String url) 设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
从类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 继承的方法
canDoPreview, equals, getElement, getEncoding, getFolder, getId, getInfo, getLinkUrl, getSubstance, getTemplateArguments, getType, isCanDoSave, isFolder, isLink, isValidElement, loadById, makeFrom, setElement, setSubstance, validateCanDoPreview, validateCanDoPub
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.persistent.element.IPublishElement 继承的方法
canDoPreview, getEncoding, getFolder, getLinkUrl, getTemplateArguments, isCanDoSave, isFolder, isLink, isValidElement, validateCanDoPreview, validateCanDoPub
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

构造方法详细信息

PublishContentWrapper

public PublishContentWrapper(IPublishContent content)
使用给定的 IPublishContent 实例构造 PublishContentWrapper 代理对象

参数：
content - 被代理的实际对象
方法详细信息

getBodyType

public int getBodyType()
从接口 IPublishContent 复制的描述
Returns the content body type

指定者：
接口 IPublishContent 中的 getBodyType
返回：
Returns the content body type which is defined in CMSConstants like CONTENT_BODY_NORMAL, CONTENT_BODY_HTML, etc.

getCreatedTime

public CMyDateTime getCreatedTime()
从接口 IPublishContent 复制的描述
Returns the created time of this content.

指定者：
接口 IPublishContent 中的 getCreatedTime
返回：
the created time of this content.

getDetailTemplate

public Template getDetailTemplate()
从接口 IPublishContent 复制的描述
Returns the detail template of this content.

指定者：
接口 IPublishContent 中的 getDetailTemplate
返回：
the detail template of this content.

getFileName

public java.lang.String getFileName()
指定者：
接口 IPublishContent 中的 getFileName
返回：
the linked url if this document is a link;
otherwise, returns null.

getFileNamedStyle

public FileNamedStyle getFileNamedStyle()
指定者：
接口 IPublishContent 中的 getFileNamedStyle

getModal

public int getModal()
             throws WCMException
从接口 IPublishContent 复制的描述
Returns the content modal in the curernt folder

指定者：
接口 IPublishContent 中的 getModal
返回：
Returns the content modal type which is defined in CMSConstants like CONTENT_MODAL_ENTITY, CONTENT_MODAL_LINK, etc.
抛出：
WCMException - if failed to load this property.

getOriginalHome

public IPublishFolder getOriginalHome()
                               throws WCMException
从接口 IPublishContent 复制的描述
Returns the folder where this content originally lies.

指定者：
接口 IPublishContent 中的 getOriginalHome
返回：
the folder where this content originally lies.
抛出：
WCMException - if failed.

getRealHome

public IPublishFolder getRealHome()
                           throws WCMException
从接口 IPublishContent 复制的描述
Returns the folder where this content currently lies.

指定者：
接口 IPublishContent 中的 getRealHome
返回：
the folder where this content currently lies.
抛出：
WCMException - if failed.

isFile

public boolean isFile()
指定者：
接口 IPublishContent 中的 isFile
返回：
true if the document is a link;
otherwise, returns false.

isPublishedInHome

public boolean isPublishedInHome()
                          throws java.lang.Exception
从接口 IPublishContent 复制的描述
Returns true if this content has been published in its home folder.

指定者：
接口 IPublishContent 中的 isPublishedInHome
返回：
true if this content has been published in its home folder.
抛出：
java.lang.Exception - if failed to get the publish status of this content in its home.

setFolder

public void setFolder(IPublishFolder _folder)
从接口 IPublishContent 复制的描述
Sets the folder where this content currently lies.

指定者：
接口 IPublishContent 中的 setFolder
参数：
_folder - the current folder

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishContent 复制的描述
Sets the publish status of this content in the specified folder

指定者：
接口 IPublishContent 中的 setPublishStatus
参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, etc.
抛出：
WCMException

setPublishTime

public void setPublishTime(CMyDateTime _dtTime)
                    throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容的发布时间

指定者：
接口 IPublishContent 中的 setPublishTime
参数：
_dtTime - CMyDateTime实例对象，如果为null表示页面被取消了
抛出：
WCMException - 如果发生错误

setPublishTimeAndURL

public void setPublishTimeAndURL(CMyDateTime _time,
                                 java.lang.String url)
                          throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消

指定者：
接口 IPublishContent 中的 setPublishTimeAndURL
参数：
_time - 发布的时间
url - 发布后的URL
抛出：
WCMException - 如果发生错误

getRelatedResources

public java.util.Iterator getRelatedResources()
                                       throws WCMException
从接口 IPublishContent 复制的描述
获取Content相关的资源文件(如附件等)

指定者：
接口 IPublishContent 中的 getRelatedResources
返回：
相关资源文件的文件名集合,可能返回null
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishElementFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishElementFactory

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishElementFactory

public class PublishElementFactory
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
factory of publish element instance.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishElementFactory()
方法摘要
static IPublishElement | createElementOfType(int _nType) create an element instance for the specified type
static boolean | isContentType(int _nType) Returns true if the specified type is a content.
static boolean | isFolderType(int _nType) Returns true if the specified type is a folder.
static IPublishContent | lookupContent(int _nType, int _iID, IPublishFolder _oFolder) lookup a publish content object
static IPublishElement | lookupElement(int _nType, int _nId) lookup a publish element (folder/content)
static IPublishElements | lookupElements(int _nType, java.lang.String _sIds) lookup the contents collection by the specified type and ids.
static IPublishContent | makeContentFrom(CMSObj _cmsObj, IPublishFolder _oFolder) make a publish content from the specified CMS object.
static IPublishElement | makeElementFrom(CMSObj _cmsObj) make a publish element from the specified CMS object.
static IPublishElements | makeElementsFrom(CMSBaseObjs _cmsObjs) Makes a publish elements collection from the specified CMS objects list.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishElementFactory

public PublishElementFactory()
方法详细信息

isFolderType

public static boolean isFolderType(int _nType)
                            throws WCMException
Returns true if the specified type is a folder.

参数：
_nType - a publish element type.
返回：
true if the specified type is a folder.
抛出：
java.lang.Exception - if failed to lookup the element type.
WCMException

isContentType

public static boolean isContentType(int _nType)
                             throws WCMException
Returns true if the specified type is a content.

参数：
_nType - a publish element type.
返回：
true if the specified type is a content.
抛出：
java.lang.Exception - if failed to lookup the element type.
WCMException

createElementOfType

public static IPublishElement createElementOfType(int _nType)
                                           throws WCMException
create an element instance for the specified type

参数：
_nType - the element type
返回：
Returns the element instance created.
抛出：
java.lang.Exception - if the element type is unknown.
WCMException

lookupElement

public static IPublishElement lookupElement(int _nType,
                                            int _nId)
                                     throws WCMException
lookup a publish element (folder/content)

参数：
_nType - element type
_nId - element id
返回：
Returns the publish element instance found.
抛出：
java.lang.Exception - if failed to fetch the object instance.
WCMException

lookupContent

public static IPublishContent lookupContent(int _nType,
                                            int _iID,
                                            IPublishFolder _oFolder)
                                     throws WCMException
lookup a publish content object

参数：
_nType - content type
_iID - content id(Document ID)
_oFolder - which folder, or null
返回：
publish content object
抛出：
WCMException - if failed to fetch the object instance.

lookupElements

public static IPublishElements lookupElements(int _nType,
                                              java.lang.String _sIds)
                                       throws WCMException
lookup the contents collection by the specified type and ids.

参数：
_nType - the content type.
_sIds - id list of the contents, which is separated by ','
返回：
Returns the contents list found.
抛出：
java.lang.Exception - if failed to fetch the contents list.
WCMException

makeElementFrom

public static IPublishElement makeElementFrom(CMSObj _cmsObj)
                                       throws WCMException
make a publish element from the specified CMS object.

参数：
_cmsObj - a CMS object.
返回：
the publish element created.
抛出：
WCMException - if the CMS object is not a valid publish element type.

makeContentFrom

public static IPublishContent makeContentFrom(CMSObj _cmsObj,
                                              IPublishFolder _oFolder)
                                       throws WCMException
make a publish content from the specified CMS object.

参数：
_cmsObj - a CMS object.
__oFolder - which folder, or null
返回：
the publish element created.
抛出：
WCMException - if the CMS object is not a valid publish element type.

makeElementsFrom

public static IPublishElements makeElementsFrom(CMSBaseObjs _cmsObjs)
Makes a publish elements collection from the specified CMS objects list.

参数：
_cmsObjs - CMS object list
返回：
Returns the publish elements collection created.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishElementsCMSListImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishElementsCMSListImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl
所有已实现的接口：
IPublishElements
public class PublishElementsCMSListImpl
extends java.lang.Object
implements IPublishElements

Title: TRS 内容协作平台（TRS WCM）
Description:
PublishElements implementation with CMS object list.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishElementsCMSListImpl(java.util.List _list)
constructor
方法摘要
void | add(java.lang.Object _element) Adds an element into collection.
void | clear() Removes all the elements from this collection.
IPublishElement | get(int _nIndex) Returns the element at the specified position in this collection.
boolean | isEmpty() Returns true if this collection contains no elements.
void | remove(int _nIndex)
int | size() Returns the number of elements in this collection.
IPublishElementsIterator | toIterator()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishElementsCMSListImpl

public PublishElementsCMSListImpl(java.util.List _list)
constructor

参数：
_list - CMS object list
方法详细信息

size

public int size()
从接口 IPublishElements 复制的描述
Returns the number of elements in this collection.

指定者：
接口 IPublishElements 中的 size
返回：
the number of elements in this collection
另请参见：
IPublishElements.size()

isEmpty

public boolean isEmpty()
从接口 IPublishElements 复制的描述
Returns true if this collection contains no elements.

指定者：
接口 IPublishElements 中的 isEmpty
返回：
true if this collection contains no elements
另请参见：
IPublishElements.isEmpty()

clear

public void clear()
从接口 IPublishElements 复制的描述
Removes all the elements from this collection.

指定者：
接口 IPublishElements 中的 clear
另请参见：
IPublishElements.clear()

get

public IPublishElement get(int _nIndex)
                    throws WCMException
从接口 IPublishElements 复制的描述
Returns the element at the specified position in this collection.

指定者：
接口 IPublishElements 中的 get
参数：
_nIndex - index of the element to return.
返回：
the element at the specified position in this collection.
抛出：
WCMException
另请参见：
IPublishElements.get(int)

add

public void add(java.lang.Object _element)
         throws java.lang.Exception
Adds an element into collection.

指定者：
接口 IPublishElements 中的 add
参数：
_element - element which is an instance of CMSObj.
抛出：
java.lang.Exception - if the speicified element is not a valid element type in collection.

toIterator

public IPublishElementsIterator toIterator()
                                    throws WCMException
抛出：
WCMException

remove

public void remove(int _nIndex)
指定者：
接口 IPublishElements 中的 remove
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishElementsCMSObjsImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishElementsCMSObjsImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl
所有已实现的接口：
IPublishElements
public class PublishElementsCMSObjsImpl
extends java.lang.Object
implements IPublishElements

Title: TRS 内容协作平台（TRS WCM）
Description:
publish elements collection CMS implementation.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishElementsCMSObjsImpl(CMSBaseObjs _objs)
constructor
方法摘要
void | add(java.lang.Object _element) Adds an element into collection.
void | clear() Removes all the elements from this collection.
IPublishElement | get(int _nIndex) Returns the element at the specified position in this collection.
boolean | isEmpty() Returns true if this collection contains no elements.
void | remove(int _nIndex)
int | size() Returns the number of elements in this collection.
IPublishElementsIterator | toIterator()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishElementsCMSObjsImpl

public PublishElementsCMSObjsImpl(CMSBaseObjs _objs)
constructor

参数：
_objs - CMS object collection
方法详细信息

size

public int size()
从接口 IPublishElements 复制的描述
Returns the number of elements in this collection.

指定者：
接口 IPublishElements 中的 size
返回：
the number of elements in this collection

isEmpty

public boolean isEmpty()
从接口 IPublishElements 复制的描述
Returns true if this collection contains no elements.

指定者：
接口 IPublishElements 中的 isEmpty
返回：
true if this collection contains no elements

clear

public void clear()
从接口 IPublishElements 复制的描述
Removes all the elements from this collection.

指定者：
接口 IPublishElements 中的 clear

get

public IPublishElement get(int _nIndex)
                    throws WCMException
从接口 IPublishElements 复制的描述
Returns the element at the specified position in this collection.

指定者：
接口 IPublishElements 中的 get
参数：
_nIndex - index of the element to return.
返回：
the element at the specified position in this collection.
抛出：
WCMException

add

public void add(java.lang.Object _element)
         throws java.lang.Exception
Adds an element into collection.

指定者：
接口 IPublishElements 中的 add
参数：
_element - element which is an instance of CMSObj.
抛出：
java.lang.Exception - if the speicified element is not a valid element type in collection.

toIterator

public IPublishElementsIterator toIterator()
                                    throws WCMException
抛出：
WCMException

remove

public void remove(int _nIndex)
            throws WCMException
指定者：
接口 IPublishElements 中的 remove
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishElementsListImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishElementsListImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishElementsListImpl
所有已实现的接口：
IPublishElements
public class PublishElementsListImpl
extends java.lang.Object
implements IPublishElements

Title: TRS 内容协作平台（TRS WCM）
Description:
IPublishElements implementation with list.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishElementsListImpl()
constructor: default
方法摘要
void | add(java.lang.Object _element) Adds an element into collection.
void | clear() Removes all the elements from this collection.
IPublishElement | get(int _nIndex) Returns the element at the specified position in this collection.
boolean | isEmpty() Returns true if this collection contains no elements.
void | remove(int _nIndex)
int | size() Returns the number of elements in this collection.
IPublishElementsIterator | toIterator()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishElementsListImpl

public PublishElementsListImpl()
constructor: default

方法详细信息

size

public int size()
从接口 IPublishElements 复制的描述
Returns the number of elements in this collection.

指定者：
接口 IPublishElements 中的 size
返回：
the number of elements in this collection

isEmpty

public boolean isEmpty()
从接口 IPublishElements 复制的描述
Returns true if this collection contains no elements.

指定者：
接口 IPublishElements 中的 isEmpty
返回：
true if this collection contains no elements

clear

public void clear()
从接口 IPublishElements 复制的描述
Removes all the elements from this collection.

指定者：
接口 IPublishElements 中的 clear

get

public IPublishElement get(int _nIndex)
从接口 IPublishElements 复制的描述
Returns the element at the specified position in this collection.

指定者：
接口 IPublishElements 中的 get
参数：
_nIndex - index of the element to return.
返回：
the element at the specified position in this collection.

add

public void add(java.lang.Object _element)
         throws java.lang.Exception
Adds an element into collection.

指定者：
接口 IPublishElements 中的 add
参数：
_element - element which is an instance of IPublishElement.
抛出：
java.lang.Exception - if the speicified element is not a valid element type in collection.

toIterator

public IPublishElementsIterator toIterator()
                                    throws WCMException
抛出：
WCMException

remove

public void remove(int _nIndex)
指定者：
接口 IPublishElements 中的 remove
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishElementWrapper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishElementWrapper

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishElementWrapper
所有已实现的接口：
ICMSObjSubstanceContent, IPublishElement
直接已知子类：
PublishContentWrapper, PublishFolderWrapper
public class PublishElementWrapper
extends java.lang.Object
implements IPublishElement

IPublishElement的代理实现

作者：
Martin (付成睿)

构造方法摘要
PublishElementWrapper(IPublishElement element)
使用给定的 IPublishElement 实例构造 PublishElementWrapper 代理对象
方法摘要
boolean | canDoPreview() 判断发布元素是否可以预览
boolean | equals(java.lang.Object _another)
IPublishElement | getElement() 返回被代理的实际对象
java.lang.String | getEncoding() Returns the file encoding of this element.
IPublishFolder | getFolder() Returns the folder where this element currently lies.
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
java.lang.String | getLinkUrl()
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
java.util.HashMap | getTemplateArguments() 返回该发布对象已经进行了有效设置的全部模板参数列表
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isFolder() Returns true if current element is a folder.
boolean | isLink()
boolean | isValidElement() 判断是否为有效的发布元素
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setElement(IPublishElement element) 设置被代理的实际对象，可以将参数设置为null，以清除对实际被代理对象的引用。
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
boolean | validateCanDoPub() Returns true if the folder is can be published.
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishElementWrapper

public PublishElementWrapper(IPublishElement element)
使用给定的 IPublishElement 实例构造 PublishElementWrapper 代理对象

参数：
element - 被代理的实际对象
方法详细信息

getElement

public IPublishElement getElement()
返回被代理的实际对象

返回：
被代理的实际对象

setElement

public void setElement(IPublishElement element)
设置被代理的实际对象，可以将参数设置为null，以清除对实际被代理对象的引用。

参数：
element - 被代理的实际对象，可以为null

canDoPreview

public boolean canDoPreview()
从接口 IPublishElement 复制的描述
判断发布元素是否可以预览

指定者：
接口 IPublishElement 中的 canDoPreview
返回：

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals

getEncoding

public java.lang.String getEncoding()
                             throws WCMException
从接口 IPublishElement 复制的描述
Returns the file encoding of this element.

指定者：
接口 IPublishElement 中的 getEncoding
返回：
the file encoding of this element
抛出：
WCMException - if failed to find the file encoding.

getFolder

public IPublishFolder getFolder()
从接口 IPublishElement 复制的描述
Returns the folder where this element currently lies.

指定者：
接口 IPublishElement 中的 getFolder
返回：
the folder where this element currently lies.

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

getLinkUrl

public java.lang.String getLinkUrl()
指定者：
接口 IPublishElement 中的 getLinkUrl
返回：
the linked url if this eliement is a link;
otherwise, returns null.

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

getTemplateArguments

public java.util.HashMap getTemplateArguments()
                                       throws WCMException
从接口 IPublishElement 复制的描述
返回该发布对象已经进行了有效设置的全部模板参数列表

指定者：
接口 IPublishElement 中的 getTemplateArguments
返回：
该发布对象已经进行了有效设置的全部模板参数列表
抛出：
WCMException

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

isFolder

public boolean isFolder()
从接口 IPublishElement 复制的描述
Returns true if current element is a folder.

指定者：
接口 IPublishElement 中的 isFolder
返回：
true if current element is a folder.

isLink

public boolean isLink()
指定者：
接口 IPublishElement 中的 isLink
返回：
true if the eliement is a link;
otherwise, returns false.

isValidElement

public boolean isValidElement()
从接口 IPublishElement 复制的描述
判断是否为有效的发布元素

指定者：
接口 IPublishElement 中的 isValidElement
返回：

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

指定者：
接口 IPublishElement 中的 validateCanDoPreview
抛出：
WCMException

validateCanDoPub

public boolean validateCanDoPub()
                         throws WCMException
从接口 IPublishElement 复制的描述
Returns true if the folder is can be published.

指定者：
接口 IPublishElement 中的 validateCanDoPub
返回：
true if the folder is can be published.
抛出：
WCMException

isCanDoSave

public boolean isCanDoSave(User _loginUser)
                    throws WCMException
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

指定者：
接口 IPublishElement 中的 isCanDoSave
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishFolderImplBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishFolderImplBase

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishFolderImplBase
所有已实现的接口：
ICMSObjSubstanceContent, IPublishElement, IPublishFolder
直接已知子类：
PublishFolderChannelImpl, PublishFolderClassImpl, PublishFolderWebSiteImpl
public abstract class PublishFolderImplBase
extends java.lang.Object
implements IPublishFolder

Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for IPublishFolder.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static boolean INHERIT_ROOT_DETAIL_TEMPLATE
构造方法摘要
PublishFolderImplBase()
方法摘要
boolean | canDoPreview() 判断发布元素是否可以预览
boolean | equals(java.lang.Object _another)
java.lang.String | getDataPath()
Template | getDetailTemplate() get the detail template of the current folder.
java.lang.String | getEncoding() Returns the file encoding of this element.
IPublishFolder | getFolder() Returns the folder where this element currently lies.
java.util.Collection | getFoldersQuotingMe() Returns the content folders who are quoting this folder
java.lang.String | getInfo() Gets the information of the folder.
Templates | getOutlineTemplates() get the outline templates of the current folder.
java.lang.String | getPathKey() 获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写
java.lang.String | getRootDomain() Returns the root domain of current folder.
java.util.HashMap | getTemplateArguments() 返回该发布对象已经进行了有效设置的全部模板参数列表
boolean | isFolder() Returns true if current element is a folder.
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.persistent.element.IPublishFolder 继承的方法
canDoBatchDetailPageTask, canDoDetailPageTask, canDoOutlinePageTask, getAllContents, getAllContentsIterator, getChildren, getIncreasedContents, getIncreasedContentsIterator, getParent, getPublishedContents, getRoot, getSiblingIndex, isDeleted, isRoot, setPublishStatus
从接口 com.trs.components.common.publish.persistent.element.IPublishElement 继承的方法
getLinkUrl, isCanDoSave, isLink, isValidElement, validateCanDoPreview, validateCanDoPub
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getSubstance, getType, loadById, makeFrom, setSubstance

字段详细信息

INHERIT_ROOT_DETAIL_TEMPLATE

public static boolean INHERIT_ROOT_DETAIL_TEMPLATE
构造方法详细信息

PublishFolderImplBase

public PublishFolderImplBase()
方法详细信息

isFolder

public boolean isFolder()
从接口 IPublishElement 复制的描述
Returns true if current element is a folder.

指定者：
接口 IPublishElement 中的 isFolder
返回：
true if current element is a folder.
另请参见：
IPublishElement.isFolder()

getFolder

public IPublishFolder getFolder()
从接口 IPublishElement 复制的描述
Returns the folder where this element currently lies.

指定者：
接口 IPublishElement 中的 getFolder
返回：
the folder where this element currently lies.
另请参见：
IPublishElement.getFolder()

getEncoding

public java.lang.String getEncoding()
                             throws WCMException
从接口 IPublishElement 复制的描述
Returns the file encoding of this element.

指定者：
接口 IPublishElement 中的 getEncoding
返回：
the file encoding of this element
抛出：
WCMException - if failed to find the file encoding.

getTemplateArguments

public java.util.HashMap getTemplateArguments()
                                       throws WCMException
从接口 IPublishElement 复制的描述
返回该发布对象已经进行了有效设置的全部模板参数列表

指定者：
接口 IPublishElement 中的 getTemplateArguments
返回：
该发布对象已经进行了有效设置的全部模板参数列表
抛出：
WCMException

getFoldersQuotingMe

public java.util.Collection getFoldersQuotingMe()
                                         throws WCMException
从接口 IPublishFolder 复制的描述
Returns the content folders who are quoting this folder

指定者：
接口 IPublishFolder 中的 getFoldersQuotingMe
返回：
the folders collection who are quoting this folder
抛出：
WCMException - if fails to fetch the folders collection
另请参见：
IPublishFolder.getFoldersQuotingMe()

getOutlineTemplates

public Templates getOutlineTemplates()
从接口 IPublishFolder 复制的描述
get the outline templates of the current folder.

指定者：
接口 IPublishFolder 中的 getOutlineTemplates
返回：
the outline templates of current folder.
另请参见：
IPublishFolder#getOutlineTemplate()

getDetailTemplate

public Template getDetailTemplate()
从接口 IPublishFolder 复制的描述
get the detail template of the current folder.

指定者：
接口 IPublishFolder 中的 getDetailTemplate
返回：
the detail template of current folder.

getRootDomain

public java.lang.String getRootDomain()
                               throws WCMException
从接口 IPublishFolder 复制的描述
Returns the root domain of current folder.

指定者：
接口 IPublishFolder 中的 getRootDomain
返回：
the root domain of current folder.
抛出：
WCMException - if failed to load the folder publish config.
另请参见：
IPublishFolder.getRootDomain()

getDataPath

public java.lang.String getDataPath()
                             throws WCMException
指定者：
接口 IPublishFolder 中的 getDataPath
返回：
the data path.
抛出：
WCMException
另请参见：
IPublishFolder.getDataPath()

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder
另请参见：
ICMSObjSubstanceContent.getInfo()

canDoPreview

public boolean canDoPreview()
从接口 IPublishElement 复制的描述
判断发布元素是否可以预览

指定者：
接口 IPublishElement 中的 canDoPreview
返回：

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals

getPathKey

public java.lang.String getPathKey()
从接口 IPublishFolder 复制的描述
获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写

指定者：
接口 IPublishFolder 中的 getPathKey
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishFolderWrapper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.element
类 PublishFolderWrapper

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishElementWrapper
        继承者  com.trs.components.common.publish.persistent.element.PublishFolderWrapper
所有已实现的接口：
ICMSObjSubstanceContent, IPublishElement, IPublishFolder
public class PublishFolderWrapper
extends PublishElementWrapper
implements IPublishFolder

IPublishFolder的代理实现

作者：
Martin (付成睿)

构造方法摘要
PublishFolderWrapper(IPublishFolder folder)
使用给定的 IPublishFolder 实例构造 PublishFolderWrapper 代理对象
方法摘要
boolean | canDoBatchDetailPageTask()
boolean | canDoDetailPageTask() check if can create detail page task
boolean | canDoOutlinePageTask() check if can create outline page task
IPublishElements | getAllContents(WCMFilter _filter) Returns all the contents to publish
IPublishElementsIterator | getAllContentsIterator(WCMFilter _filter)
IPublishElements | getChildren() get the children folders
java.lang.String | getDataPath()
Template | getDetailTemplate() get the detail template of the current folder.
java.util.Collection | getFoldersQuotingMe() Returns the content folders who are quoting this folder
IPublishElements | getIncreasedContents(WCMFilter _filter) Returns the increased contents to publish
IPublishElementsIterator | getIncreasedContentsIterator(WCMFilter _filter)
Templates | getOutlineTemplates() get the outline templates of the current folder.
IPublishFolder | getParent()
java.lang.String | getPathKey() 获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写
IPublishElements | getPublishedContents(WCMFilter _filter) Returns the contents which have been published.
IPublishFolder | getRoot()
java.lang.String | getRootDomain() Returns the root domain of current folder.
int | getSiblingIndex() Retuns index of this folder in its siblings.
boolean | isDeleted() 是否已经被假删除
boolean | isRoot()
void | setPublishStatus(int _nStatus) Sets the publish status of this folder
从类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 继承的方法
canDoPreview, equals, getElement, getEncoding, getFolder, getId, getInfo, getLinkUrl, getSubstance, getTemplateArguments, getType, isCanDoSave, isFolder, isLink, isValidElement, loadById, makeFrom, setElement, setSubstance, validateCanDoPreview, validateCanDoPub
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.persistent.element.IPublishElement 继承的方法
canDoPreview, getEncoding, getFolder, getLinkUrl, getTemplateArguments, isCanDoSave, isFolder, isLink, isValidElement, validateCanDoPreview, validateCanDoPub
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

构造方法详细信息

PublishFolderWrapper

public PublishFolderWrapper(IPublishFolder folder)
使用给定的 IPublishFolder 实例构造 PublishFolderWrapper 代理对象

参数：
folder - 被代理的实际对象
方法详细信息

getIncreasedContents

public IPublishElements getIncreasedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the increased contents to publish

指定者：
接口 IPublishFolder 中的 getIncreasedContents
参数：
_filter - extra query filter for the collection
返回：
the contents collection, which are not published but can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getAllContents

public IPublishElements getAllContents(WCMFilter _filter)
                                throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns all the contents to publish

指定者：
接口 IPublishFolder 中的 getAllContents
参数：
_filter - extra query filter for the collection
返回：
all the contents which have been published or can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getPublishedContents

public IPublishElements getPublishedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the contents which have been published.

指定者：
接口 IPublishFolder 中的 getPublishedContents
参数：
_filter - extra query filter for the collection
返回：
the contents which have been published
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getFoldersQuotingMe

public java.util.Collection getFoldersQuotingMe()
                                         throws WCMException
从接口 IPublishFolder 复制的描述
Returns the content folders who are quoting this folder

指定者：
接口 IPublishFolder 中的 getFoldersQuotingMe
返回：
the folders collection who are quoting this folder
抛出：
WCMException - if fails to fetch the folders collection

getOutlineTemplates

public Templates getOutlineTemplates()
从接口 IPublishFolder 复制的描述
get the outline templates of the current folder.

指定者：
接口 IPublishFolder 中的 getOutlineTemplates
返回：
the outline templates of current folder.

getDetailTemplate

public Template getDetailTemplate()
从接口 IPublishFolder 复制的描述
get the detail template of the current folder.

指定者：
接口 IPublishFolder 中的 getDetailTemplate
返回：
the detail template of current folder.

getRootDomain

public java.lang.String getRootDomain()
                               throws WCMException
从接口 IPublishFolder 复制的描述
Returns the root domain of current folder.

指定者：
接口 IPublishFolder 中的 getRootDomain
返回：
the root domain of current folder.
抛出：
WCMException - if failed to load the folder publish config.

getDataPath

public java.lang.String getDataPath()
                             throws WCMException
指定者：
接口 IPublishFolder 中的 getDataPath
返回：
the data path.
抛出：
WCMException

isRoot

public boolean isRoot()
指定者：
接口 IPublishFolder 中的 isRoot
返回：
true if this folder is a root; otherwise, returns false.

getRoot

public IPublishFolder getRoot()
                       throws WCMException
指定者：
接口 IPublishFolder 中的 getRoot
返回：
the root of this folder.
抛出：
WCMException - if failed to find the folder root.

getParent

public IPublishFolder getParent()
                         throws WCMException
指定者：
接口 IPublishFolder 中的 getParent
返回：
the parent of this folder.
抛出：
WCMException - if failed to fetch the parent folder.

getChildren

public IPublishElements getChildren()
                             throws WCMException
从接口 IPublishFolder 复制的描述
get the children folders

指定者：
接口 IPublishFolder 中的 getChildren
返回：
the children folders collection.
抛出：
WCMException - if failed to fetch the children.

getSiblingIndex

public int getSiblingIndex()
                    throws WCMException
从接口 IPublishFolder 复制的描述
Retuns index of this folder in its siblings.

指定者：
接口 IPublishFolder 中的 getSiblingIndex
返回：
index of this folder in its siblings.
抛出：
WCMException - if failed to calculate the index.

canDoOutlinePageTask

public boolean canDoOutlinePageTask()
从接口 IPublishFolder 复制的描述
check if can create outline page task

指定者：
接口 IPublishFolder 中的 canDoOutlinePageTask
返回：

canDoDetailPageTask

public boolean canDoDetailPageTask()
从接口 IPublishFolder 复制的描述
check if can create detail page task

指定者：
接口 IPublishFolder 中的 canDoDetailPageTask
返回：

canDoBatchDetailPageTask

public boolean canDoBatchDetailPageTask()
指定者：
接口 IPublishFolder 中的 canDoBatchDetailPageTask

getIncreasedContentsIterator

public IPublishElementsIterator getIncreasedContentsIterator(WCMFilter _filter)
                                                      throws java.lang.Exception
指定者：
接口 IPublishFolder 中的 getIncreasedContentsIterator
抛出：
java.lang.Exception

getAllContentsIterator

public IPublishElementsIterator getAllContentsIterator(WCMFilter _filter)
                                                throws java.lang.Exception
指定者：
接口 IPublishFolder 中的 getAllContentsIterator
抛出：
java.lang.Exception

isDeleted

public boolean isDeleted()
从接口 IPublishFolder 复制的描述
是否已经被假删除

指定者：
接口 IPublishFolder 中的 isDeleted
返回：

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishFolder 复制的描述
Sets the publish status of this folder

指定者：
接口 IPublishFolder 中的 setPublishStatus
参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, STATUS_DELETEDetc.
抛出：
WCMException

getPathKey

public java.lang.String getPathKey()
从接口 IPublishFolder 复制的描述
获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写

指定者：
接口 IPublishFolder 中的 getPathKey
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.common.publish.persistent.element.IAppendix 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.persistent.element.IAppendix
的使用

没有 com.trs.components.common.publish.persistent.element.IAppendix 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.persistent.element.IAppendixes 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.persistent.element.IAppendixes
的使用

没有 com.trs.components.common.publish.persistent.element.IAppendixes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.persistent.element.IPublishContent 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.persistent.element.IPublishContent
的使用

使用 IPublishContent 的软件包
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.persistent.element
com.trs.components.common.publish.persistent.taskdispatch
com.trs.components.metadata.publish
com.trs.components.wcm.publish
com.trs.components.wcm.publish.element
com.trs.components.wcm.publish.tagparser
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.components.common.publish.domain 中的方法
void | PublishServer.deleteContent(IPublishContent _content) delete a published content from the specified folder
java.lang.String | PublishServer.previewContent(IPublishContent _content, java.lang.String[] _warningsHolder) Previews a content and returns the URL of preview page.
java.lang.String | PublishServer.previewContent(IPublishContent _content, java.lang.String[] _warningsHolder, Template _template)
void | PublishServer.publishContent(IPublishContent _content) publish a content in the specified folder
void | PublishServer.publishContent(IPublishContent _content, int _nPubType) publish a content in the specified folder with specified PubType
void | PublishServer.publishContent(IPublishContent _content, IPublishElements folders) 忽略文档的状态，在指定的Folder下发布文档

com.trs.components.common.publish.domain.publisher 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.components.common.publish.domain.publisher 中的方法
static java.lang.String | PublishPathCompass.calFullDataPath(IPublishContent _content, boolean _bLocalFileSystemFormat) Returns the full data path from the specified content to folder root.
static java.lang.String | PublishPathCompass.calSubDirectory(IPublishContent _content, boolean _bLocalFileSystemFormat) Calculates the sub directory of the specified content in its home.
java.lang.String | PublishPathCompass.getAbsoluteHttpPath(IPublishContent _content) Returns the http path without file name of the specified content.
java.lang.String | PublishPathCompass.getFullDataPath(IPublishContent _content, boolean _bLocalFileSystemFormat) Returns the full data path of the specified content.
java.lang.String | PublishPathCompass.getHttpUrl(IPublishContent _content, int _nPageIndex) Returns the http path including file name of the specified content.
java.lang.String | PublishPathCompass.getPreviewHttpUrl(IPublishContent _content, int _nPageIndex) 获取指定Content的预览地址
java.lang.String | PublishPathCompass.getPreviewLocalPath(IPublishContent _content) Returns the local path for the previewed pages of the specified content.
java.lang.String | PublishPathCompass.getPublishHttpUrl(IPublishContent _content, int _nPageIndex)
java.lang.String | PublishPathCompass.getPublishLocalPath(IPublishContent _content) Returns the local path (without file name) for the published pages of the specified content in the folder.
static java.lang.String | PublishPathCompass.makeDetailPageFileName(IPublishContent _content) Returns the detail page file name of the specified content.
static java.lang.String | PublishPathCompass.makeDetailPageFileName(IPublishContent _content, java.lang.String _sExt, int _nPageIndex) Returns the detail page file name of the specified content.
static void | PageDestroyer.withdraw(IPublishContent _content, PublishTaskContext _taskContext) Withdraws the detail pages of the specified content.

com.trs.components.common.publish.domain.tagparser 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.components.common.publish.domain.tagparser 中的方法
static void | TagParseHelper.distributionHTMLContentFiles(IPublishContent _content, PublishTagContext _context, java.util.List _listFiles)
static java.lang.String[] | TagParseHelper.parseHtmlContent(java.lang.String _sHtmlContent, IPublishContent _content, PublishTagContext _context)

com.trs.components.common.publish.domain.taskdispatch 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishContent _content, int _nPublishType) create a content publish task
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishContent _content, int _nPublishType)
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | IPublishTaskMgr.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)
PublishTask | PublishTaskMgrImpl.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)

com.trs.components.common.publish.persistent.element 中 IPublishContent 的使用

实现 IPublishContent 的 com.trs.components.common.publish.persistent.element 中的类
class | PublishContentDefaultObjImpl
class | PublishContentImplBase Title: TRS 内容协作平台（TRS WCM） Description: implementation base for publish content.
class | PublishContentWrapper IPublishContent的代理实现

返回 IPublishContent 的 com.trs.components.common.publish.persistent.element 中的方法
static IPublishContent | PublishElementFactory.lookupContent(int _nType, int _iID, IPublishFolder _oFolder) lookup a publish content object
static IPublishContent | PublishElementFactory.makeContentFrom(CMSObj _cmsObj, IPublishFolder _oFolder) make a publish content from the specified CMS object.

参数类型为 IPublishContent 的 com.trs.components.common.publish.persistent.element 中的构造方法
PublishContentWrapper(IPublishContent content)
使用给定的 IPublishContent 实例构造 PublishContentWrapper 代理对象

com.trs.components.common.publish.persistent.taskdispatch 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
boolean | PublishTask.setContent(IPublishContent _content) set the property of ContentTypeConfig
boolean | PublishErrorLog.setContent(IPublishContent _content) set the property of ContentTypeConfig

com.trs.components.metadata.publish 中 IPublishContent 的使用

实现 IPublishContent 的 com.trs.components.metadata.publish 中的类
class | PublishContentViewDataImpl
class | PublishContentViewFieldImpl
class | PublishContentViewImpl

参数类型为 IPublishContent 的 com.trs.components.metadata.publish 中的方法
 java.util.List MetaViewDataRelateSource.getResourceNames(IPublishContent content)

com.trs.components.wcm.publish 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.components.wcm.publish 中的构造方法
WCMContentPublishConfig(User _currUser, IPublishContent _content)

com.trs.components.wcm.publish.element 中 IPublishContent 的使用

实现 IPublishContent 的 com.trs.components.wcm.publish.element 中的类
 class PublishContentDocumentImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
publis content implementation with document.

参数类型为 IPublishContent 的 com.trs.components.wcm.publish.element 中的方法
 java.util.List IRelateResource.getResourceNames(IPublishContent content)
获取当前IPublishContent对象的相关文件(如正文中的图片等)
注意:实现时,即使没有相关的文件,也不能返回null.在没有相关文件的情况下,返回空集

com.trs.components.wcm.publish.tagparser 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.components.wcm.publish.tagparser 中的方法
static java.lang.String WCMAppendixGenerator.generateAppendix(Appendix _appendix, IPublishContent _apdOwner, PublishTagContext _context, int _nReturnMode)
Generates a document appendix.

com.trs.service 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.service 中的方法
void | ITemplateService.setDetailTemplate(IPublishContent _content, int _nTemplateId)
void | ITemplateService.setDetailTemplate(IPublishContent _content, int _nTemplateId, int _nDetailTemplateType) 为指定文档设定模板

com.trs.service.impl 中 IPublishContent 的使用

参数类型为 IPublishContent 的 com.trs.service.impl 中的方法
void | TemplateService.setDetailTemplate(IPublishContent _content, int _nTemplateId)
void | TemplateService.setDetailTemplate(IPublishContent _content, int _nTemplateId, int _nDetailTemplateType)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.persistent.element.IPublishElement 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.persistent.element.IPublishElement
的使用

使用 IPublishElement 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.config
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.element
com.trs.components.common.publish.persistent.taskdispatch
com.trs.components.common.publish.persistent.template
com.trs.components.common.publish.widget
com.trs.components.metadata.publish
com.trs.components.wcm.epress
com.trs.components.wcm.publish.element
com.trs.components.wcm.publish.tagparser
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.ajaxservice 中的方法
static int | TemplateEmployMgrHelper.clearEmploymentOfEmployer(IPublishElement _employer, Template _template)
static void | TemplateEmployMgrHelper.setOtherOutlinesOfSite(IPublishElement siteFolder, Template template)

com.trs.components.common.publish.config 中 IPublishElement 的使用

返回 IPublishElement 的 com.trs.components.common.publish.config 中的方法
 IPublishElement PublishElementType.createBean()
create a new bean instance

com.trs.components.common.publish.domain 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain 中的方法
int | PublishServer.distributeFile(java.lang.String _sLocalFilePathName, IPublishElement _fileOwner) Distributes a specified file to the folder.
static boolean | PublishServer.isValidateElement(IPublishElement _publishElement) 校验指定的发布元素合法性
static void | PublishServer.validateElement(IPublishElement _publishElement) 校验指定的发布对象是否有效

com.trs.components.common.publish.domain.distribute 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain.distribute 中的方法
int | FileDistributeShip.distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner) Distributes a file to the specified folder.
int | FileDistributeShip.distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner, java.lang.String _sSubDir) Distributes a file to the specified folder.
int | FileDistributeShip.distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner, java.lang.String _sSubDir, boolean _bCheckDstFileExits)
int | FileDistributeShip.withdrawFile(java.lang.String _sFileName, IPublishElement _fileOwner) Withdraws a file.
int | FileDistributeShip.withdrawFile(java.lang.String _sFileName, IPublishElement _fileOwner, java.lang.String _sFullDataPath)

com.trs.components.common.publish.domain.publisher 中 IPublishElement 的使用

返回 IPublishElement 的 com.trs.components.common.publish.domain.publisher 中的方法
IPublishElement | PublishPageContext.getPageElement() Returns the element (a folder or a content) of this page to publish.
IPublishElement | PublishTagContext.getPageElement()
IPublishElement | PublishTagContext.getUpperHost() Returns the upper host object.

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain.publisher 中的方法
void | PublishTaskContext.addErrorLog(int iResult, IPublishElement element, java.lang.String sDesc, java.lang.String sError) 记录发布过程中产生的错误日志
void | PublishTaskContext.addErrorLog(int iResult, IPublishElement element, java.lang.String sDesc, java.lang.Throwable t) 记录发布过程中产生的错误日志
static java.lang.String | PublishPathCompass.calFullDataPath(IPublishElement _element, boolean _bLocalFileSystemFormat) Returns the full data path from the specified element to root.
java.lang.String | PublishPathCompass.getAbsoluteHttpPath(IPublishElement _element) Returns the http path of the specified element.
java.lang.String | PublishPathCompass.getFullDataPath(IPublishElement _element, boolean _bLocalFileSystemFormat) Returns the full data path of the specified element.
java.lang.String | PublishPathCompass.getLocalPath(IPublishElement _element, boolean _bPreview) Returns the element local path.
java.lang.String | PublishPathCompass.getPreviewHttpPath(IPublishElement _element) Returns the http path for the previewed pages of the specified element.
java.lang.String | PublishPathCompass.getPreviewLocalPath(IPublishElement _element) Returns the local path for the previewed pages of the specified element.
java.lang.String | PublishPathCompass.getPublishHttpPath(IPublishElement _element)
java.lang.String | PublishPathCompass.getPublishLocalPath(IPublishElement _element) Returns the local path for the published pages of the specified element.
java.lang.String | PublishPathCompass.getRootHttpPathFrom(IPublishElement _element) Returns the root http path from the specified publish element.
java.lang.String | PublishPathCompass.getRootImageHttpPath(IPublishElement _element) Returns the http path of the images in root.
void | PublishTagContext.setUpperHost(IPublishElement _upperHost) Sets the upper host object.

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishPageContext(IPublishElement _pageElement, PublishTaskContext _taskContext)
constructor
PublishPageContext(IPublishElement _pageElement, PublishTaskContext _taskContext, IPublishProgressMonitor _monitor)
constructor
PublishTagContext(IPublishElement _upperHost, java.util.Map _extraAttributes, PublishPageContext _pageContext)
已过时。 constructor
PublishTagContext(IPublishElement _upperHost, java.util.Map _extraAttributes, PublishTagContext _parent)
已过时。 constructor
PublishTagContext(PublishTagContext _parent, TagItem _tagItem, IPublishElement _upperHost)

com.trs.components.common.publish.domain.tagparser 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain.tagparser 中的方法
static java.lang.String[] | TagParseHelper.parseContent(IPublishElement _pageElement, java.lang.String _sTemplateContent)
static java.lang.String[] | TagParseHelper.parseContent(IPublishElement _pageElement, java.lang.String _sTemplateContent, java.lang.String _sParseType) 将一旦包含置标的文本解析

com.trs.components.common.publish.domain.taskdispatch 中 IPublishElement 的使用

返回 IPublishElement 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
IPublishElement | IPageTask.getPublishElement()
IPublishElement | BatchDetailPageTask.getPublishElement()
IPublishElement | PageDestoryTask.getPublishElement()
IPublishElement | SinglePageTask.getPublishElement() Returns the element to publish.

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
void | IPageTask.setPublishElement(IPublishElement _element)
void | BatchDetailPageTask.setPublishElement(IPublishElement _element)
void | PageDestoryTask.setPublishElement(IPublishElement _element)
void | SinglePageTask.setPublishElement(IPublishElement publishElement)

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain.taskdispatch 中的构造方法
PageDestoryTask(IPublishElement _element)
SinglePageTask(IPublishElement _element)
constructor: default

com.trs.components.common.publish.domain.template 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain.template 中的方法
int | TemplateEmployMgr.clearEmploysOfEmployer(IPublishElement _employer) clear all the employ records of the specified element
java.lang.String | TemplateArgumentCacheMgr.getArgument(IPublishElement _employer, java.lang.String _name)
java.util.HashMap | TemplateArgumentCacheMgr.getArguments(IPublishElement _employer)
TemplateArguments | TemplateArgumentMgr.getArguments(IPublishElement _element) 返回指定发布对象上的全部有效模板参数列表
Template | ITemplateEmployCacheMgr.getDetailTemplate(IPublishElement _employer)
Template | TemplateEmployCacheMgrImpl.getDetailTemplate(IPublishElement _employer)
Template | TemplateEmployMgr.getDetailTemplate(IPublishElement _employer) Returns the detail template of the specified publish element.
Template | TemplateEmployMgr.getDetailTemplate(IPublishElement _employer, int _nTemplateType)
TemplateEmploys | TemplateEmployMgr.getEmploysOf(IPublishElement _employer)
TemplateEmploys | TemplateEmployMgr.getEmploysOf(IPublishElement _employer, int _nTemplateType) Returns the employ records of the specified employer, which may be a folder or a content.
void | TemplateEmployMgr.setDetailTemplate(IPublishElement _employer, int _nTemplateId, boolean _bResetChildren)
void | TemplateEmployMgr.setDetailTemplate(IPublishElement _employer, int _nTemplateId, boolean _bResetChildren, int _nDetailTemplateType) set detail template of the specified element.

参数类型为 IPublishElement 的 com.trs.components.common.publish.domain.template 中的构造方法
TemplateEmployerIdsMan(IPublishElement _element, TemplateEmployMgr _manager, int _nTemplateType)

com.trs.components.common.publish.persistent.element 中 IPublishElement 的使用

com.trs.components.common.publish.persistent.element 中 IPublishElement 的子接口
interface | IPublishContent Title: TRS 内容协作平台（TRS WCM） Description: publish content interface, which is one kind of IPublishElement.
interface | IPublishFolder Title: TRS 内容协作平台（TRS WCM） Description: publish folder interface, which is one kind of IPublishElement.

实现 IPublishElement 的 com.trs.components.common.publish.persistent.element 中的类
class | PublishContentDefaultObjImpl
class | PublishContentImplBase Title: TRS 内容协作平台（TRS WCM） Description: implementation base for publish content.
class | PublishContentWrapper IPublishContent的代理实现
class | PublishElementWrapper IPublishElement的代理实现
class | PublishFolderImplBase Title: TRS 内容协作平台（TRS WCM） Description: implementation base for IPublishFolder.
class | PublishFolderWrapper IPublishFolder的代理实现

返回 IPublishElement 的 com.trs.components.common.publish.persistent.element 中的方法
static IPublishElement | PublishElementFactory.createElementOfType(int _nType) create an element instance for the specified type
IPublishElement | PublishElementsListImpl.get(int _nIndex)
IPublishElement | PublishElementsCMSObjsImpl.get(int _nIndex)
IPublishElement | IPublishElements.get(int _nIndex) Returns the element at the specified position in this collection.
IPublishElement | PublishElementsCMSListImpl.get(int _nIndex)
IPublishElement | PublishElementWrapper.getElement() 返回被代理的实际对象
static IPublishElement | PublishElementFactory.lookupElement(int _nType, int _nId) lookup a publish element (folder/content)
static IPublishElement | PublishElementFactory.makeElementFrom(CMSObj _cmsObj) make a publish element from the specified CMS object.

参数类型为 IPublishElement 的 com.trs.components.common.publish.persistent.element 中的方法
 void PublishElementWrapper.setElement(IPublishElement element)
设置被代理的实际对象，可以将参数设置为null，以清除对实际被代理对象的引用。

参数类型为 IPublishElement 的 com.trs.components.common.publish.persistent.element 中的构造方法
PublishElementWrapper(IPublishElement element)
使用给定的 IPublishElement 实例构造 PublishElementWrapper 代理对象

com.trs.components.common.publish.persistent.taskdispatch 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
 PublishErrorLog PublishTask.addErrorLog(User _currUser, IPublishElement _publishElement, java.lang.String _sDesc, int _nResult, java.lang.String _sErrorDetail)
add error log for a folder publish page task

com.trs.components.common.publish.persistent.template 中 IPublishElement 的使用

返回 IPublishElement 的 com.trs.components.common.publish.persistent.template 中的方法
IPublishElement | TemplateEmploy.getEmployer() get the employer instance
IPublishElement | TemplateArgument.getEmployer() get the employer instance

参数类型为 IPublishElement 的 com.trs.components.common.publish.persistent.template 中的方法
static TemplateArguments | TemplateArguments.findOf(IPublishElement _employer) 提取指定ID序列的对象集合
Template | Template.getNestedTemplate(IPublishElement element, java.lang.String sIdentity)
boolean | TemplateEmploy.setEmployer(IPublishElement _employer) set the employer
boolean | TemplateArgument.setEmployer(IPublishElement _employer) set the employer

com.trs.components.common.publish.widget 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.components.common.publish.widget 中的方法
java.lang.String | IWidgetServer.parseToEditContent(IPublishElement _oPageElement, java.lang.String _sTemplateContent) 将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
java.lang.String | WidgetServer.parseToEditContent(IPublishElement _oPageElement, java.lang.String _sTemplateContent)
java.lang.String | IWidgetServer.parseToEditContent(IPublishElement _oPageElement, Template _oTemplateForEdit) 将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
java.lang.String | WidgetServer.parseToEditContent(IPublishElement _oPageElement, Template _oTemplateForEdit)
java.lang.String | IWidgetServer.parseToEditContent(IPublishElement _oPageElement, WidgetInstance _oWidgetInstance) 解析某一个资源块实例对象成可编辑的状态
java.lang.String | WidgetServer.parseToEditContent(IPublishElement pageElement, WidgetInstance widgetInstance)

com.trs.components.metadata.publish 中 IPublishElement 的使用

实现 IPublishElement 的 com.trs.components.metadata.publish 中的类
class | PublishContentViewDataImpl
class | PublishContentViewFieldImpl
class | PublishContentViewImpl
class | PublishFolderClassImpl Title: TRS 内容协作平台（TRS WCM） Description: 分类Folder的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IPublishElement 的 com.trs.components.metadata.publish 中的方法
 IPublishElement PublishFolderClassImpl.getHost()

参数类型为 IPublishElement 的 com.trs.components.metadata.publish 中的方法
 void PublishFolderClassImpl.setHost(IPublishElement upperHost)

com.trs.components.wcm.epress 中 IPublishElement 的使用

实现 IPublishElement 的 com.trs.components.wcm.epress 中的类
 class EpressFolderWrapper
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.element 中 IPublishElement 的使用

实现 IPublishElement 的 com.trs.components.wcm.publish.element 中的类
class | PublishContentDocumentImpl Title: TRS 内容协作平台（TRS WCM） Description: publis content implementation with document.
class | PublishFolderChannelImpl Title: TRS 内容协作平台（TRS WCM） Description: channel implementation of IPublishFolder Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishFolderWebSiteImpl Title: TRS 内容协作平台（TRS WCM） Description: website implementation of folder.

com.trs.components.wcm.publish.tagparser 中 IPublishElement 的使用

返回 IPublishElement 的 com.trs.components.wcm.publish.tagparser 中的方法
abstract IPublishElement | WCMTagParserLogoBase.findHost(PublishTagContext _context)
IPublishElement | WCMTagParserDocumentLogo.findHost(PublishTagContext _context)
IPublishElement | WCMTagParserChannelLogo.findHost(PublishTagContext _context)

参数类型为 IPublishElement 的 com.trs.components.wcm.publish.tagparser 中的方法
static int WCMTemplateChildIndexAnalyer.getAttribute(IPublishElement _element, TagItem _item, java.lang.String _sName, int _nDefault)

com.trs.service 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.service 中的方法
Template | ITemplateService.getDetailTemplate(IPublishElement _publishElement) 获得指定频道的细览模板
TemplateArguments | ITemplateService.getTemplateArguments(IPublishElement _element) 返回指定发布对象上的全部有效模板参数列表
TemplateParameterList | ITemplateService.getTemplateParameters(IPublishElement _element) 返回指定发布对象使用的所有模板中的全部形式参数列表
TemplateParameterList | ITemplateService.getTemplateParameters(IPublishElement _element, boolean zRecursion) 返回指定发布对象使用的所有模板中的全部形式参数列表

com.trs.service.impl 中 IPublishElement 的使用

参数类型为 IPublishElement 的 com.trs.service.impl 中的方法
void | TemplateService.addNestedParameters(IPublishElement _element, Template template, TemplateParameterList list)
Template | TemplateService.getDetailTemplate(IPublishElement _publishElement)
TemplateArguments | TemplateService.getTemplateArguments(IPublishElement _element)
TemplateParameterList | TemplateService.getTemplateParameters(IPublishElement _element)
TemplateParameterList | TemplateService.getTemplateParameters(IPublishElement _element, boolean zRecursion)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.persistent.element.IPublishElements 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.persistent.element.IPublishElements
的使用

使用 IPublishElements 的软件包
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.persistent.element
com.trs.components.common.publish.persistent.taskdispatch
com.trs.components.metadata.publish
com.trs.components.wcm.epress
com.trs.components.wcm.publish.element

com.trs.components.common.publish.domain 中 IPublishElements 的使用

参数类型为 IPublishElements 的 com.trs.components.common.publish.domain 中的方法
void | PublishServer.deleteContents(IPublishElements _contents, IPublishFolder _folder) delete the published contents from the specified folder
void | PublishServer.deleteContents(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders)
void | PublishServer.deleteContents(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders, boolean _bUpdateStatus)
void | PublishServer.deleteContentsWithMirror(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders)
void | PublishServer.publishContent(IPublishContent _content, IPublishElements folders) 忽略文档的状态，在指定的Folder下发布文档
void | PublishServer.publishContents(IPublishElements _contents, IPublishFolder _folder, int _nPubType) publish the contents collection

com.trs.components.common.publish.domain.taskdispatch 中 IPublishElements 的使用

参数类型为 IPublishElements 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType) create a content publish task
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType)
PublishTask | IPublishTaskMgr.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)
PublishTask | PublishTaskMgrImpl.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)
PublishTask | IPublishTaskMgr.createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders) 创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
PublishTask | PublishTaskMgrImpl.createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders) 创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）

com.trs.components.common.publish.persistent.element 中 IPublishElements 的使用

实现 IPublishElements 的 com.trs.components.common.publish.persistent.element 中的类
class | PublishElementsCMSListImpl Title: TRS 内容协作平台（TRS WCM） Description: PublishElements implementation with CMS object list.
class | PublishElementsCMSObjsImpl Title: TRS 内容协作平台（TRS WCM） Description: publish elements collection CMS implementation.
class | PublishElementsListImpl Title: TRS 内容协作平台（TRS WCM） Description: IPublishElements implementation with list.

返回 IPublishElements 的 com.trs.components.common.publish.persistent.element 中的方法
IPublishElements | IPublishFolder.getAllContents(WCMFilter _filter) Returns all the contents to publish
IPublishElements | PublishFolderWrapper.getAllContents(WCMFilter _filter)
IPublishElements | IPublishFolder.getChildren() get the children folders
IPublishElements | PublishFolderWrapper.getChildren()
IPublishElements | IPublishFolder.getIncreasedContents(WCMFilter _filter) Returns the increased contents to publish
IPublishElements | PublishFolderWrapper.getIncreasedContents(WCMFilter _filter)
IPublishElements | IPublishFolder.getPublishedContents(WCMFilter _filter) Returns the contents which have been published.
IPublishElements | PublishFolderWrapper.getPublishedContents(WCMFilter _filter)
static IPublishElements | PublishElementFactory.lookupElements(int _nType, java.lang.String _sIds) lookup the contents collection by the specified type and ids.
static IPublishElements | PublishElementFactory.makeElementsFrom(CMSBaseObjs _cmsObjs) Makes a publish elements collection from the specified CMS objects list.

com.trs.components.common.publish.persistent.taskdispatch 中 IPublishElements 的使用

返回 IPublishElements 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
IPublishElements | PublishTask.getContents() 获取Task所关联的内容集合
IPublishElements | PublishTask.getFolders() get the property of ContentIds

参数类型为 IPublishElements 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
 boolean PublishTask.setFolders(IPublishElements folders)
get the property of ContentIds

com.trs.components.metadata.publish 中 IPublishElements 的使用

返回 IPublishElements 的 com.trs.components.metadata.publish 中的方法
IPublishElements | PublishFolderClassImpl.getAllContents(WCMFilter _filter)
IPublishElements | PublishFolderClassImpl.getChildren()
IPublishElements | PublishFolderClassImpl.getIncreasedContents(WCMFilter _filter)
IPublishElements | PublishFolderClassImpl.getPublishedContents(WCMFilter _filter)

com.trs.components.wcm.epress 中 IPublishElements 的使用

返回 IPublishElements 的 com.trs.components.wcm.epress 中的方法
IPublishElements | EpressFolderWrapper.getAllContents(WCMFilter _filter)
IPublishElements | EpressFolderWrapper.getChildren()
IPublishElements | EpressFolderWrapper.getIncreasedContents(WCMFilter _filter)
IPublishElements | EpressFolderWrapper.getPublishedContents(WCMFilter _filter)

com.trs.components.wcm.publish.element 中 IPublishElements 的使用

返回 IPublishElements 的 com.trs.components.wcm.publish.element 中的方法
IPublishElements | PublishFolderChannelImpl.getAllContents(WCMFilter _filter)
IPublishElements | PublishFolderWebSiteImpl.getAllContents(WCMFilter _filter)
IPublishElements | PublishFolderChannelImpl.getChildren()
IPublishElements | PublishFolderWebSiteImpl.getChildren()
IPublishElements | PublishFolderChannelImpl.getIncreasedContents(WCMFilter _filter)
IPublishElements | PublishFolderWebSiteImpl.getIncreasedContents(WCMFilter _filter)
IPublishElements | PublishFolderChannelImpl.getPublishedContents(WCMFilter _filter)
IPublishElements | PublishFolderWebSiteImpl.getPublishedContents(WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.persistent.element.IPublishFolder 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.persistent.element.IPublishFolder
的使用

使用 IPublishFolder 的软件包
com.trs.ajaxservice |
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain |
com.trs.components.common.publish.domain.distribute |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.service |
com.trs.service.impl |
com.trs.template.service.impl |
com.trs.wcmonline |

com.trs.ajaxservice 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.ajaxservice 中的方法
static RightValue | TemplateAuthHelper.makeHostRightValue(MethodContext _context, User _loginUser, IPublishFolder _host)
static RightValue | TemplateAuthHelper.makeTemplateRightValue(MethodContext _context, User _loginUser, Template _template, IPublishFolder _host)

com.trs.components.comment.publish.tagparser 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.comment.publish.tagparser 中的方法
 TemplateQuote[] XWCMTagParserComment.analyzeQuotes(IPublishFolder _root)

com.trs.components.common.publish.domain 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.common.publish.domain 中的方法
void | PublishServer.deleteContents(IPublishElements _contents, IPublishFolder _folder) delete the published contents from the specified folder
void | PublishServer.deleteContents(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders)
void | PublishServer.deleteContents(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders, boolean _bUpdateStatus)
void | PublishServer.deleteContentsWithMirror(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders)
void | PublishServer.deleteFolder(IPublishFolder _folder) delete the content folder
void | PublishServer.deleteFolder(IPublishFolder _folder, boolean _bUpdateStatus)
void | PublishServer.deleteFolderSelfOnly(IPublishFolder _folder)
java.lang.String[] | PublishServer.previewFolder(IPublishFolder _folder, java.lang.String[] _warningsHolder) Previews a content folder and returns the URLs of preview pages.
java.lang.String[] | PublishServer.previewFolder(IPublishFolder _folder, java.lang.String[] _warningsHolder, Template _template)
void | PublishServer.publishConfirm(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile) 确认（批准）发布，其内部行为： 1.删除备份文件 2.重名名正式文件为备份文件 3.重名名临时文件为备份文件
void | PublishServer.publishContents(IPublishElements _contents, IPublishFolder _folder, int _nPubType) publish the contents collection
void | PublishServer.publishFolder(IPublishFolder _folder, int _nPublishType) publish the content folder

com.trs.components.common.publish.domain.distribute 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.common.publish.domain.distribute 中的方法
PublishDistributions | PublishDistributionMgr.getDistributionsOf(IPublishFolder _folder, boolean _bExcludingDisabled, WCMFilter _filter) get the publish distributions of the specified folder.
FileDistributorImpUnion | PublishDistributionCacheMgr.getDistributorUnion(IPublishFolder _folder) 返回指定目录上的分发点的聚合
int | FileDistributeShip.renameFile(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile)
int | FileDistributeShip.renameFile(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath)
int | FileDistributeShip.withdrawFolder(IPublishFolder _folder) Withdraws a folder.
int | FileDistributeShip.withdrawFolder(IPublishFolder _folder, java.util.List subdirs) 撤除指定folder的指定子目录

com.trs.components.common.publish.domain.publisher 中 IPublishFolder 的使用

返回 IPublishFolder 的 com.trs.components.common.publish.domain.publisher 中的方法
IPublishFolder | PublishPageContext.getPageFolder() Returns the folder where the current page lies.
IPublishFolder | PublishTagContext.getPageFolder()
IPublishFolder | PublishTaskContext.getRoot() Returns the root of the published folder.
IPublishFolder | PublishPageContext.getRoot()
IPublishFolder | PublishTagContext.getRoot()
IPublishFolder | PublishTaskContext.getStartFolder()
IPublishFolder | PublishTagContext.getUpperFolder() Returns the nearest upper folder in current context link.

参数类型为 IPublishFolder 的 com.trs.components.common.publish.domain.publisher 中的方法
static java.lang.String | PublishPathCompass.calFullDataPath(IPublishFolder _folder, boolean _bLocalFileSystemFormat) Returns the full data path from the specified folder to root.
java.lang.String | PublishPathCompass.getAbsoluteHttpPath(IPublishFolder _folder) Returns the http path of the specified folder.
java.lang.String | PublishPathCompass.getFullDataPath(IPublishFolder _folder, boolean _bLocalFileSystemFormat) Returns the full data path of the specified folder.
java.lang.String | PublishPathCompass.getPreviewLocalPath(IPublishFolder _folder) Returns the local path for the previewed pages of the specified folder.
java.lang.String | PublishPathCompass.getPublishLocalPath(IPublishFolder _folder) Returns the local path for the published pages of the specified folder.
java.lang.String | PublishPathCompass.getRootDomain(IPublishFolder _folder) Returns the root domain of the specified folder.
void | PublishPageContext.setRoot(IPublishFolder root)
void | PublishTaskContext.setStartFolder(IPublishFolder folder)
void | PublishTagContext.setUpperFolder(IPublishFolder folder) 设置当前置标正在发布对象的所在目录 该方法只应该在一类地方调用，就是在TRS_DOCUMENTS等概览置标切换了目录之后， 其他任何地方都不应该使用该方法。
static void | PageDestroyer.withdraw(IPublishFolder _folder, PublishTaskContext _taskContext) Withdraws all the files in a specified folder.
static void | PageDestroyer.withDrawSelfOnly(IPublishFolder folder) 只撤除指定folder本身的内容,不包括子对象的内容.

参数类型为 IPublishFolder 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishTaskContext(PublishTask _task, IPublishFolder _startFolder)
constructor

com.trs.components.common.publish.domain.tagparser 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.common.publish.domain.tagparser 中的方法
TemplateQuote[] | TagParserDateTime.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | BaseTagParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserPageNav4Detail.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserNestedTemplate.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserCondition.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | ITagParser.analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
TemplateQuote[] | TagParserUnimpl.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserRepeat.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserOddOrEven.analyzeQuotes(IPublishFolder root)
TemplateQuote[] | TagParserSequenceNumber.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserEcho.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserVariableEnum.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserVariable.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserOnlyLogic.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserSystemConfig.analyzeQuotes(IPublishFolder _s_root)
TemplateQuote[] | TagParserVariableSet.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserNewIcon.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserCMSObjBase.analyzeQuotes(IPublishFolder _root)
static void | TagBeanInfoHelper.checkChannelName(IPublishFolder _root, TagItem _tagItem, java.lang.StringBuffer _sbResult) 检查指定置标中使用的频道名称是否存在
void | TagBeanInfo.checkSemantic(IPublishFolder _folder, TagItem _tagItem, java.lang.StringBuffer _sbResult) 检查指定的置标实例的静态语义，如果有静态语义错误，则通过传入的StringBuffer对象返回错误信息。
static Template | TagParseHelper.findNestedTemplate(java.lang.String sTempName, IPublishFolder _root) Returns the template defined in the specified nested template tag item.
static Template | TagParseHelper.findNestedTemplate(TagItem _tagItem, IPublishFolder _root) 已过时。 Returns the template defined in the specified nested template tag item.

com.trs.components.common.publish.domain.taskdispatch 中 IPublishFolder 的使用

返回 IPublishFolder 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
 IPublishFolder PublishTaskAnalyzer.getFolder()

参数类型为 IPublishFolder 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType) create a content publish task
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType)
PublishTask | IPublishTaskMgr.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)
PublishTask | PublishTaskMgrImpl.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)
PublishTask | IPublishTaskMgr.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)
PublishTask | PublishTaskMgrImpl.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)
PublishTask | IPublishTaskMgr.createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders) 创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
PublishTask | PublishTaskMgrImpl.createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders) 创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
PublishTask | IPublishTaskMgr.createFolderPublishTask(IPublishFolder _folder, int _nPublishType) create a folder publish task
PublishTask | PublishTaskMgrImpl.createFolderPublishTask(IPublishFolder _folder, int _nPublishType)

参数类型为 IPublishFolder 的 com.trs.components.common.publish.domain.taskdispatch 中的构造方法
BatchDetailPageTask(IPublishFolder _folder, boolean _bPublishAll)
Constructor.
BatchDetailPageTask(IPublishFolder _folder, boolean _bPublishAll, int _nBatchContentsModal)

com.trs.components.common.publish.domain.template 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.common.publish.domain.template 中的方法
boolean | TemplateNestMgr.addNestRecord(int _nTemplateId, IPublishFolder _root, java.lang.String _sNestedTemplateName) add a template nest record
int | TemplateQuoteMgr0310.clearQuotesOfFolder(IPublishFolder _folder) Clears the quotes of the specified folder.
int | TemplateQuoteMgr.clearQuotesOfFolder(IPublishFolder _folder) Clears the quotes of the specified folder.
Template | ITemplateEmployCacheMgr.getDefaultOutlineTemplate(IPublishFolder _folder)
Template | TemplateEmployCacheMgrImpl.getDefaultOutlineTemplate(IPublishFolder _folder)
Template | TemplateEmployMgr.getDefaultOutlineTemplate(IPublishFolder _folder) Returns the default outline template of the specified folder.
java.util.List | TemplateQuoteMgr0310.getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder _quotedFolder) find the folders whose outline quotes the contents of the specified folder.
java.util.List | TemplateQuoteMgr.getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder _quotedFolder) find the folders whose outline quotes the contents of the specified folder.
Templates | TemplateMgr.getManagedTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) get the managed tempaltes in the specified folder
Templates | TemplateMgr.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent) get the managed tempaltes in the specified folder
Templates | TemplateEmployMgr.getOtherOutlineTemplates(IPublishFolder _folder) 获取当前folder的其它概览模板集.
Templates | ITemplateEmployCacheMgr.getOutlineTemplates(IPublishFolder _folder)
Templates | TemplateEmployCacheMgrImpl.getOutlineTemplates(IPublishFolder _folder)
Templates | TemplateEmployMgr.getOutlineTemplates(IPublishFolder _folder) get the outline templates of the specified folder.
Reports | TemplateImporter.importFromHTML(IPublishFolder _folder, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName) 从html文件导入模板
Reports | TemplateImporter.importFromZip(IPublishFolder _folder, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected) 从zip文件中导入模板
Template | TemplateCacheMgr.lookupByName(IPublishFolder _root, java.lang.String _sName) find the template by name
Reports | TemplateMgr.redistributeAppendixes(IPublishFolder _folder, boolean _zRecursive) 重新分发指定站点或者频道下的所有模板的附件，并且如果 _zRecursive 为 true ，则会进一步地重新分发子频道下的模板的附件。
void | TemplateEmployMgr.resetChildern(IPublishFolder _folder)
void | TemplateEmployMgr.resetChildern(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bOutLine)
static void | TemplateParseAngel.scanIn(IPublishFolder _folder) Scans and parses the unparsed templates in the folder.
void | TemplateEmployMgr.setDefaultOutline(IPublishFolder _folder, int _nNewDefaultTemplateId)
void | TemplateEmployMgr.setOtherOutlines(User loginUser, IPublishFolder _folder, java.lang.String _sTemplateIds)
void | TemplateEmployMgr.setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren) set outline template of the specified folder

com.trs.components.common.publish.persistent.distribute 中 IPublishFolder 的使用

返回 IPublishFolder 的 com.trs.components.common.publish.persistent.distribute 中的方法
 IPublishFolder PublishDistribution.getFolder()

参数类型为 IPublishFolder 的 com.trs.components.common.publish.persistent.distribute 中的方法
 boolean PublishDistribution.setFolder(IPublishFolder _folder)

com.trs.components.common.publish.persistent.element 中 IPublishFolder 的使用

实现 IPublishFolder 的 com.trs.components.common.publish.persistent.element 中的类
class | PublishFolderImplBase Title: TRS 内容协作平台（TRS WCM） Description: implementation base for IPublishFolder.
class | PublishFolderWrapper IPublishFolder的代理实现

返回 IPublishFolder 的 com.trs.components.common.publish.persistent.element 中的方法
IPublishFolder | PublishFolderImplBase.getFolder()
IPublishFolder | PublishContentImplBase.getFolder()
IPublishFolder | PublishElementWrapper.getFolder()
IPublishFolder | IPublishElement.getFolder() Returns the folder where this element currently lies.
IPublishFolder | IPublishContent.getOriginalHome() Returns the folder where this content originally lies.
IPublishFolder | PublishContentWrapper.getOriginalHome()
IPublishFolder | PublishContentDefaultObjImpl.getOriginalHome()
IPublishFolder | IPublishFolder.getParent()
IPublishFolder | PublishFolderWrapper.getParent()
IPublishFolder | PublishContentImplBase.getRealHome()
IPublishFolder | IPublishContent.getRealHome() Returns the folder where this content currently lies.
IPublishFolder | PublishContentWrapper.getRealHome()
IPublishFolder | IPublishFolder.getRoot()
IPublishFolder | PublishFolderWrapper.getRoot()

参数类型为 IPublishFolder 的 com.trs.components.common.publish.persistent.element 中的方法
static IPublishContent | PublishElementFactory.lookupContent(int _nType, int _iID, IPublishFolder _oFolder) lookup a publish content object
static IPublishContent | PublishElementFactory.makeContentFrom(CMSObj _cmsObj, IPublishFolder _oFolder) make a publish content from the specified CMS object.
void | PublishContentImplBase.setFolder(IPublishFolder _folder)
void | IPublishContent.setFolder(IPublishFolder _folder) Sets the folder where this content currently lies.
void | PublishContentWrapper.setFolder(IPublishFolder _folder)

参数类型为 IPublishFolder 的 com.trs.components.common.publish.persistent.element 中的构造方法
PublishFolderWrapper(IPublishFolder folder)
使用给定的 IPublishFolder 实例构造 PublishFolderWrapper 代理对象

com.trs.components.common.publish.persistent.publisher 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.common.publish.persistent.publisher 中的方法
static FolderPublishConfig | FolderPublishConfig.findOf(IPublishFolder _folder) find the publish config of the specified folder
boolean | FolderPublishConfig.setFolder(IPublishFolder _folder) set the publish folder

com.trs.components.common.publish.persistent.taskdispatch 中 IPublishFolder 的使用

返回 IPublishFolder 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
 IPublishFolder PublishTask.getFolder()

参数类型为 IPublishFolder 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
boolean | PublishTask.setFolder(IPublishFolder _folder) set the property of FolderTypeConfig
boolean | PublishErrorLog.setFolder(IPublishFolder _folder) set the property of FolderTypeConfig

com.trs.components.common.publish.persistent.template 中 IPublishFolder 的使用

返回 IPublishFolder 的 com.trs.components.common.publish.persistent.template 中的方法
IPublishFolder | Template.getFolder() get the folder where the template is located.
IPublishFolder | Template.getRoot() get the root folder where the template is located.
IPublishFolder | TempAppendix.getRoot() 获得模板附件所属的站点

参数类型为 IPublishFolder 的 com.trs.components.common.publish.persistent.template 中的方法
boolean | Template.isAccessibleFrom(IPublishFolder _folder) 判断从指定目录是否可以访问当前模板
boolean | Template.setFolder(IPublishFolder _folder) set the folder where the template is located
boolean | Template.setFolder(IPublishFolder _folder, IPublishFolder _root) set the folder where the template is located
boolean | TempAppendix.setRoot(IPublishFolder _root) 设置模板附件的所属文件夹根目录

com.trs.components.common.publish.widget 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.common.publish.widget 中的方法
Template | IWidgetServer.createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType) 根据母版内容，创建新的模板
Template | WidgetServer.createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType)

com.trs.components.common.publish.widget.tagparser 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.common.publish.widget.tagparser 中的方法
 void WCMTagParserBaseOperation.TBI.checkSemantic(IPublishFolder _folder, TagItem _tagItem, java.lang.StringBuffer _sbResult)

com.trs.components.infoview.publish.tagparser 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.infoview.publish.tagparser 中的方法
TemplateQuote[] | TagParserInfoViewNavs.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViewHelper.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViewData.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViewNav.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViewPage.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViews.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoView.analyzeQuotes(IPublishFolder _root)

com.trs.components.metadata.publish 中 IPublishFolder 的使用

实现 IPublishFolder 的 com.trs.components.metadata.publish 中的类
 class PublishFolderClassImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
分类Folder的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IPublishFolder 的 com.trs.components.metadata.publish 中的方法
IPublishFolder | PublishContentViewDataImpl.getFolder()
IPublishFolder | PublishContentViewFieldImpl.getOriginalHome()
IPublishFolder | PublishContentViewDataImpl.getOriginalHome()
IPublishFolder | PublishContentViewImpl.getOriginalHome()
IPublishFolder | PublishFolderClassImpl.getParent()
IPublishFolder | PublishFolderClassImpl.getRoot()

参数类型为 IPublishFolder 的 com.trs.components.metadata.publish 中的方法
TemplateQuote[] | WCMTagParserAppendix.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserClassIndexGener.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserRelNewsForViewData.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserClassDocuments.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserViewDatas.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserExistDataOfClassInfo.analyzeQuotes(IPublishFolder _root)
void | PublishFolderClassImpl.setRoot(IPublishFolder _root)

com.trs.components.wcm.epress 中 IPublishFolder 的使用

实现 IPublishFolder 的 com.trs.components.wcm.epress 中的类
 class EpressFolderWrapper
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

返回 IPublishFolder 的 com.trs.components.wcm.epress 中的方法
IPublishFolder | EpressFolderWrapper.getFolder()
IPublishFolder | EpressFolderWrapper.getParent()
IPublishFolder | EpressFolderWrapper.getRoot()

参数类型为 IPublishFolder 的 com.trs.components.wcm.epress 中的方法
TemplateQuote[] | TagPreNextParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserPageNav.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagMapAreaParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagEBookDirParser.analyzeQuotes(IPublishFolder _root)

参数类型为 IPublishFolder 的 com.trs.components.wcm.epress 中的构造方法
EpressFolderWrapper(IPublishFolder _folder)
EpressFolderWrapper(IPublishFolder _folder, CMyDateTime _history)

com.trs.components.wcm.publish 中 IPublishFolder 的使用

返回 IPublishFolder 的 com.trs.components.wcm.publish 中的方法
 IPublishFolder WCMFolderPublishConfig.getFolder()

参数类型为 IPublishFolder 的 com.trs.components.wcm.publish 中的构造方法
WCMFolderPublishConfig(IPublishFolder _folder)

com.trs.components.wcm.publish.element 中 IPublishFolder 的使用

实现 IPublishFolder 的 com.trs.components.wcm.publish.element 中的类
class | PublishFolderChannelImpl Title: TRS 内容协作平台（TRS WCM） Description: channel implementation of IPublishFolder Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishFolderWebSiteImpl Title: TRS 内容协作平台（TRS WCM） Description: website implementation of folder.

返回 IPublishFolder 的 com.trs.components.wcm.publish.element 中的方法
IPublishFolder | PublishContentDocumentImpl.getOriginalHome()
IPublishFolder | PublishFolderChannelImpl.getParent()
IPublishFolder | PublishFolderWebSiteImpl.getParent()
IPublishFolder | PublishFolderChannelImpl.getRoot()
IPublishFolder | PublishFolderWebSiteImpl.getRoot()

参数类型为 IPublishFolder 的 com.trs.components.wcm.publish.element 中的方法
 void PublishContentDocumentImpl.setFolder(IPublishFolder _folder)

com.trs.components.wcm.publish.region 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.wcm.publish.region 中的方法
 TemplateQuote[] WCMTagParserRegion.analyzeQuotes(IPublishFolder _o_root)

com.trs.components.wcm.publish.tagparser 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.components.wcm.publish.tagparser 中的方法
TemplateQuote[] | TagWmlContentParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagChannelChainParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserWmlImage.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserCurPage.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserCRUser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | XWCMTagParserPageGeneration.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserRollDocuments.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParser4FolderHostBase.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserMapArea.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserAppendix.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserPrev.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserIcon.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | XWCMFileAppendixTagParser.analyzeQuotes(IPublishFolder arg0)
TemplateQuote[] | WCMTagParserChannels.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | XWCMImageAppendixTagParser.analyzeQuotes(IPublishFolder arg0)
TemplateQuote[] | WCMTagparserTopIcon.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserReplace.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserWmlImages.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserRelNews.analyzeQuotes(IPublishFolder _root)
Documents | PublishTaskDocumentsCacheMgr.get(IPublishFolder _folder, WCMFilter _filter)
Documents | IPublishTaskDocumentsCacheMgr.get(IPublishFolder _folder, WCMFilter _filter)
java.lang.String | WCMTagParserRollDocuments.parseAutoMore(IPublishFolder _currFolder, PublishTagContext _context)
java.lang.String | WCMTagParser4ObjsInChannelBase.parseAutoMore(IPublishFolder _currFolder, PublishTagContext _context) Parses the auto more HTML text.
void | PublishTaskDocumentsCacheMgr.put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments)
void | IPublishTaskDocumentsCacheMgr.put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments) 将Folder根据Filter获取到的Documents缓存起来

参数类型为 IPublishFolder 的 com.trs.components.wcm.publish.tagparser 中的构造方法
RollDocumentsChannelsFinder(IPublishFolder _folder)
WCMTemplateChildIndexAnalyer(IPublishFolder _root)

com.trs.service 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.service 中的方法
Templates | ITemplateService.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseParent) 获取指定Folder中可选的模板集合
Templates | ITemplateService.getOutlineTemplates(IPublishFolder _folder) 获得指定频道的概览模板
void | ITemplateService.setDetailTemplate(IPublishFolder _folder, int _nTemplateId, boolean _bResetChildren) 为指定频道设定细览模板
void | ITemplateService.setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren) 为指定频道设定概览模板

com.trs.service.impl 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.service.impl 中的方法
Templates | TemplateService.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent)
Templates | TemplateService.getOutlineTemplates(IPublishFolder _folder)
void | TemplateService.setDetailTemplate(IPublishFolder _folder, int _nTemplateId, boolean _bResetChildren)
void | TemplateService.setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren)

com.trs.template.service.impl 中 IPublishFolder 的使用

返回 IPublishFolder 的 com.trs.template.service.impl 中的方法
 IPublishFolder TemplateServiceImpl.makeTemplateFolder(java.lang.String _sFormattedTempName, WebSite _oRootSite)

com.trs.wcmonline 中 IPublishFolder 的使用

参数类型为 IPublishFolder 的 com.trs.wcmonline 中的方法
 TemplateQuote[] TagParserVipMetaData.analyzeQuotes(IPublishFolder _root)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl
的使用

没有 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishContentImplBase
的使用

使用 PublishContentImplBase 的软件包
com.trs.components.common.publish.persistent.element
com.trs.components.metadata.publish
com.trs.components.wcm.publish.element

com.trs.components.common.publish.persistent.element 中 PublishContentImplBase 的使用

com.trs.components.common.publish.persistent.element 中 PublishContentImplBase 的子类
 class PublishContentDefaultObjImpl

com.trs.components.metadata.publish 中 PublishContentImplBase 的使用

com.trs.components.metadata.publish 中 PublishContentImplBase 的子类
class | PublishContentViewDataImpl
class | PublishContentViewFieldImpl
class | PublishContentViewImpl

com.trs.components.wcm.publish.element 中 PublishContentImplBase 的使用

com.trs.components.wcm.publish.element 中 PublishContentImplBase 的子类
 class PublishContentDocumentImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
publis content implementation with document.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishContentWrapper
的使用

没有 com.trs.components.common.publish.persistent.element.PublishContentWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishElementFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishElementFactory
的使用

没有 com.trs.components.common.publish.persistent.element.PublishElementFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl
的使用

没有 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl
的使用

没有 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl
的使用

没有 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishElementWrapper
的使用

使用 PublishElementWrapper 的软件包
com.trs.components.common.publish.persistent.element

com.trs.components.common.publish.persistent.element 中 PublishElementWrapper 的使用

com.trs.components.common.publish.persistent.element 中 PublishElementWrapper 的子类
class | PublishContentWrapper IPublishContent的代理实现
class | PublishFolderWrapper IPublishFolder的代理实现

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase
的使用

使用 PublishFolderImplBase 的软件包
com.trs.components.metadata.publish
com.trs.components.wcm.epress
com.trs.components.wcm.publish.element

com.trs.components.metadata.publish 中 PublishFolderImplBase 的使用

com.trs.components.metadata.publish 中 PublishFolderImplBase 的子类
 class PublishFolderClassImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
分类Folder的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 PublishFolderImplBase 的使用

com.trs.components.wcm.epress 中 PublishFolderImplBase 的子类
 class EpressFolderWrapper
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.element 中 PublishFolderImplBase 的使用

com.trs.components.wcm.publish.element 中 PublishFolderImplBase 的子类
class | PublishFolderChannelImpl Title: TRS 内容协作平台（TRS WCM） Description: channel implementation of IPublishFolder Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishFolderWebSiteImpl Title: TRS 内容协作平台（TRS WCM） Description: website implementation of folder.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper
的使用

没有 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FolderPublishConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.publisher
类 FolderPublishConfig

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.publisher.FolderPublishConfig
所有已实现的接口：
java.lang.Cloneable
public class FolderPublishConfig
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
FolderPublishConfig()
构造函数：保留默认接口
方法摘要
static FolderPublishConfig | createNewInstance() 产生当前对象[FolderPublishConfig]的实例
int | delete(User _currUser) 从数据中删除对象信息
static FolderPublishConfig | findById(int _nId) 提取指定ID的对象
static FolderPublishConfig | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static FolderPublishConfig | findOf(int _nFolderType, int _nFolderId) 根据Folder的类型和Id获取配置信息
static FolderPublishConfig | findOf(IPublishFolder _folder) find the publish config of the specified folder
java.lang.String | getDataPath() 提取属性：DataPath
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDetailFileExt() 提取属性：DetailFileName
int | getFolderId() 提取属性：FolderId
int | getFolderType() 提取属性：FolderTypeConfig
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getOutlineFileName() 提取属性：OutlineFileName
java.lang.String | getPageEncoding() 获取站点的页面编码 发布产生的静态页面使用的页面编码,默认为GBK
java.lang.String | getRootDomain()
int | getSiteLanguage() 获取站点的语言选项 发布产生的静态页面使用的语言
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setDataPath(java.lang.String _sDataPath) 设置属性：DataPath
boolean | setDetailFileExt(java.lang.String _sDetailFileExt) 设置属性：DetailFileName
boolean | setFolder(int _nType, int _nId) 设置属性：FolderId
boolean | setFolder(IPublishFolder _folder) set the publish folder
boolean | setOutlineFileName(java.lang.String _sOutlineFileName) 设置属性：OutlineFileName
boolean | setPageEncoding(java.lang.String _sPageEncoding) 设置站点的页面编码
boolean | setRootDomain(java.lang.String _sRootMain)
boolean | setSiteLanguage(int _nSiteLanguage) 设置站点的语言选项
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

FolderPublishConfig

public FolderPublishConfig()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getFolderType

public int getFolderType()
提取属性：FolderTypeConfig

返回：
FolderTypeConfig

getFolderId

public int getFolderId()
提取属性：FolderId

返回：
FolderId

setFolder

public boolean setFolder(int _nType,
                         int _nId)
                  throws WCMException
设置属性：FolderId

参数：
_nType - the folder type
_nId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setFolder

public boolean setFolder(IPublishFolder _folder)
                  throws WCMException
set the publish folder

参数：
_folder - the publish folder
返回：
true if the property is set successfully.
抛出：
WCMException - if the folder object is null.

getOutlineFileName

public java.lang.String getOutlineFileName()
提取属性：OutlineFileName

返回：
OutlineFileName

setOutlineFileName

public boolean setOutlineFileName(java.lang.String _sOutlineFileName)
                           throws WCMException
设置属性：OutlineFileName

参数：
_sOutlineFileName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDetailFileExt

public java.lang.String getDetailFileExt()
提取属性：DetailFileName

返回：
DetailFileName

setDetailFileExt

public boolean setDetailFileExt(java.lang.String _sDetailFileExt)
                         throws WCMException
设置属性：DetailFileName

参数：
_sDetailFileExt - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDataPath

public java.lang.String getDataPath()
提取属性：DataPath

返回：
DataPath

setDataPath

public boolean setDataPath(java.lang.String _sDataPath)
                    throws WCMException
设置属性：DataPath

参数：
_sDataPath - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRootDomain

public java.lang.String getRootDomain()

setRootDomain

public boolean setRootDomain(java.lang.String _sRootMain)
                      throws WCMException
抛出：
WCMException

getSiteLanguage

public int getSiteLanguage()
获取站点的语言选项
发布产生的静态页面使用的语言

返回：

setSiteLanguage

public boolean setSiteLanguage(int _nSiteLanguage)
                        throws WCMException
设置站点的语言选项

参数：
_nSiteLanguage - 发布产生的静态页面使用的语言
返回：
@throws WCMException
抛出：
WCMException

getPageEncoding

public java.lang.String getPageEncoding()
获取站点的页面编码
发布产生的静态页面使用的页面编码,默认为GBK

返回：

setPageEncoding

public boolean setPageEncoding(java.lang.String _sPageEncoding)
                        throws WCMException
设置站点的页面编码

参数：
_sPageEncoding - 发布产生的静态页面使用的页面编码
返回：
@throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

delete

public int delete(User _currUser)
           throws WCMException
从类 CMSObj 复制的描述
从数据中删除对象信息

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

findById

public static final FolderPublishConfig findById(int _nId)
                                          throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findOf

public static final FolderPublishConfig findOf(int _nFolderType,
                                               int _nFolderId)
                                        throws WCMException
根据Folder的类型和Id获取配置信息

参数：
_nFolderType - Folder的类型
_nFolderId - Folder的ID
返回：
FolderPublishConfig
抛出：
WCMException

findOf

public static final FolderPublishConfig findOf(IPublishFolder _folder)
                                        throws WCMException
find the publish config of the specified folder

参数：
_folder - publish folder
返回：
the publis config of the specified folder.
抛出：
WCMException - if failed to fetch the config.

createNewInstance

public static final FolderPublishConfig createNewInstance()
                                                   throws WCMException
产生当前对象[FolderPublishConfig]的实例

返回：
当前对象的实例[FolderPublishConfig]
抛出：
WCMException

findByKey

public static final FolderPublishConfig findByKey(java.lang.Object _oKey)
                                           throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FolderPublishConfigCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.publisher
类 FolderPublishConfigCacheMgr

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.publisher.FolderPublishConfigCacheMgr

public class FolderPublishConfigCacheMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int MAX_CACHE_SIZE
构造方法摘要
FolderPublishConfigCacheMgr()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAX_CACHE_SIZE

public static int MAX_CACHE_SIZE
构造方法详细信息

FolderPublishConfigCacheMgr

public FolderPublishConfigCacheMgr()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FolderPublishConfigs

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.publisher
类 FolderPublishConfigs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs

public class FolderPublishConfigs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FolderPublishConfigs(User _currUser)
构造函数
FolderPublishConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static FolderPublishConfigs | createNewInstance(User _currUser) 产生当前集合对象[FolderPublishConfigs]的实例
static FolderPublishConfigs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static FolderPublishConfigs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FolderPublishConfigs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FolderPublishConfigs

public FolderPublishConfigs(User _currUser)
构造函数

另请参见：
FolderPublishConfigs( User _currUser, int _initCapacity, int _incCapacity );

FolderPublishConfigs

public FolderPublishConfigs(User _currUser,
                            int _initCapacity,
                            int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final FolderPublishConfigs findByIds(User _currUser,
                                                   java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（FolderPublishConfigs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final FolderPublishConfigs openWCMObjs(User _currUser,
                                                     WCMFilter _filter)
                                              throws WCMException
通过指定一个Filter获取当前集合[FolderPublishConfigs]

参数：
_filter - 指定的Filter
返回：
当前集合[FolderPublishConfigs]
抛出：
WCMException

createNewInstance

public static FolderPublishConfigs createNewInstance(User _currUser)
产生当前集合对象[FolderPublishConfigs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.persistent.publisher
类
FolderPublishConfig
FolderPublishConfigCacheMgr
FolderPublishConfigs


com.trs.components.common.publish.persistent.publisher

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.persistent.publisher

类摘要
FolderPublishConfig |
FolderPublishConfigCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FolderPublishConfigs |


com.trs.components.common.publish.persistent.publisher 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.publisher 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.publish.persistent.publisher.FolderPublishConfig
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs
    • com.trs.components.common.publish.persistent.publisher.FolderPublishConfigCacheMgr


软件包 com.trs.components.common.publish.persistent.publisher 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.publisher
的使用

使用 com.trs.components.common.publish.persistent.publisher 的软件包
com.trs.components.common.publish.persistent.publisher

com.trs.components.common.publish.persistent.publisher 使用的 com.trs.components.common.publish.persistent.publisher 中的类
FolderPublishConfig
FolderPublishConfigs

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig
的使用

使用 FolderPublishConfig 的软件包
com.trs.components.common.publish.persistent.publisher

com.trs.components.common.publish.persistent.publisher 中 FolderPublishConfig 的使用

返回 FolderPublishConfig 的 com.trs.components.common.publish.persistent.publisher 中的方法
static FolderPublishConfig | FolderPublishConfig.createNewInstance() 产生当前对象[FolderPublishConfig]的实例
static FolderPublishConfig | FolderPublishConfig.findById(int _nId) 提取指定ID的对象
static FolderPublishConfig | FolderPublishConfig.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static FolderPublishConfig | FolderPublishConfig.findOf(int _nFolderType, int _nFolderId) 根据Folder的类型和Id获取配置信息
static FolderPublishConfig | FolderPublishConfig.findOf(IPublishFolder _folder) find the publish config of the specified folder

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigCacheMgr
的使用

没有 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs
的使用

使用 FolderPublishConfigs 的软件包
com.trs.components.common.publish.persistent.publisher

com.trs.components.common.publish.persistent.publisher 中 FolderPublishConfigs 的使用

返回 FolderPublishConfigs 的 com.trs.components.common.publish.persistent.publisher 中的方法
static FolderPublishConfigs | FolderPublishConfigs.createNewInstance(User _currUser) 产生当前集合对象[FolderPublishConfigs]的实例
static FolderPublishConfigs | FolderPublishConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static FolderPublishConfigs | FolderPublishConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FolderPublishConfigs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.publish.persistent.taskdispatch
类
PublishErrorLog
PublishErrorLogs
PublishTask
PublishTasks


com.trs.components.common.publish.persistent.taskdispatch

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.persistent.taskdispatch

类摘要
PublishErrorLog
PublishErrorLogs
PublishTask
PublishTasks


com.trs.components.common.publish.persistent.taskdispatch 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.taskdispatch 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog
        • com.trs.components.common.publish.persistent.taskdispatch.PublishTask
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs
        • com.trs.components.common.publish.persistent.taskdispatch.PublishTasks


软件包 com.trs.components.common.publish.persistent.taskdispatch 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.taskdispatch
的使用

使用 com.trs.components.common.publish.persistent.taskdispatch 的软件包
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.persistent.taskdispatch
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain 使用的 com.trs.components.common.publish.persistent.taskdispatch 中的类
PublishTask
PublishTasks

com.trs.components.common.publish.domain.publisher 使用的 com.trs.components.common.publish.persistent.taskdispatch 中的类
PublishTask

com.trs.components.common.publish.domain.taskdispatch 使用的 com.trs.components.common.publish.persistent.taskdispatch 中的类
PublishTask
PublishTasks

com.trs.components.common.publish.persistent.taskdispatch 使用的 com.trs.components.common.publish.persistent.taskdispatch 中的类
PublishErrorLog
PublishErrorLogs
PublishTask
PublishTasks

com.trs.service 使用的 com.trs.components.common.publish.persistent.taskdispatch 中的类
PublishTask
PublishTasks

com.trs.service.impl 使用的 com.trs.components.common.publish.persistent.taskdispatch 中的类
PublishTask
PublishTasks

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishErrorLog

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.taskdispatch
类 PublishErrorLog

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog
所有已实现的接口：
java.lang.Cloneable
public class PublishErrorLog
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
PublishErrorLog()
构造函数：保留默认接口
方法摘要
static PublishErrorLog | createNewInstance() 产生当前对象[PublishLog]的实例
static PublishErrorLog | findById(int _nId) 提取指定ID的对象
static PublishErrorLog | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getContentId() get the property of ContentId
int | getContentType() get the property of ContentTypeConfig
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 提取属性：Desc
java.lang.String | getErrorDetail() 提取属性：ErrorDetail
int | getFolderId() 提取属性：FolderId
int | getFolderType() 提取属性：FolderTypeConfig
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getPublishTaskId() 提取属性：PublishTaskId
int | getResult() 提取属性：Result
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setContent(int _nType, int _nId) set the property of ContentTypeConfig
boolean | setContent(IPublishContent _content) set the property of ContentTypeConfig
boolean | setDesc(java.lang.String _sDesc) 设置属性：Desc
boolean | setErrorDetail(java.lang.String _sDetail) 设置属性：ExeDetail
boolean | setFolder(int _nType, int _nId) 设置属性：FolderTypeConfig
boolean | setFolder(IPublishFolder _folder) set the property of FolderTypeConfig
boolean | setPublishTask(int _nPublishTaskId) 设置属性：PublishTaskId
boolean | setPublishTask(PublishTask _task) set the property of PublishTask
boolean | setResult(int _nResult) 设置属性：Result
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

PublishErrorLog

public PublishErrorLog()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getPublishTaskId

public int getPublishTaskId()
提取属性：PublishTaskId

返回：
PublishTaskId

setPublishTask

public boolean setPublishTask(int _nPublishTaskId)
                       throws WCMException
设置属性：PublishTaskId

参数：
_nPublishTaskId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setPublishTask

public boolean setPublishTask(PublishTask _task)
                       throws WCMException
set the property of PublishTask

参数：
_task - the publish task
返回：
Returns true if the property is valid and save successfully; otherwise, returns false.
抛出：
WCMException - if the property is invalid or fails to save the property value.

getFolderType

public int getFolderType()
提取属性：FolderTypeConfig

返回：
Returns the folder type.

getFolderId

public int getFolderId()
提取属性：FolderId

返回：
FolderId

setFolder

public boolean setFolder(int _nType,
                         int _nId)
                  throws WCMException
设置属性：FolderTypeConfig

参数：
_nType - type of the folder
_nId - id of the folder
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setFolder

public boolean setFolder(IPublishFolder _folder)
                  throws WCMException
set the property of FolderTypeConfig

参数：
_folder - the folder
返回：
Returns true if the property is set successfully; otherwise, returns false.
抛出：
WCMException - if fails to set the property value.

getContentType

public int getContentType()
get the property of ContentTypeConfig

返回：
Returns the type of the contents to publish

getContentId

public int getContentId()
get the property of ContentId

返回：
Returns the id of the content to publish

setContent

public boolean setContent(int _nType,
                          int _nId)
                   throws WCMException
set the property of ContentTypeConfig

参数：
_nType - type of the contents
_nId - id of the content
返回：
Returns true if the property is valid and save successfully; otherwise, returns false.
抛出：
WCMException - if the property is invalid or fails to save the property value.

setContent

public boolean setContent(IPublishContent _content)
                   throws WCMException
set the property of ContentTypeConfig

参数：
_content - the content to publish
返回：
Returns true if the property is valid and save successfully; otherwise, returns false.
抛出：
WCMException - if the property is invalid or fails to save the property value.

getResult

public int getResult()
提取属性：Result

返回：
Result

setResult

public boolean setResult(int _nResult)
                  throws WCMException
设置属性：Result

参数：
_nResult - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
提取属性：Desc

返回：
Desc

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置属性：Desc

参数：
_sDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getErrorDetail

public java.lang.String getErrorDetail()
提取属性：ErrorDetail

返回：
ErrorDetail

setErrorDetail

public boolean setErrorDetail(java.lang.String _sDetail)
                       throws WCMException
设置属性：ExeDetail

参数：
_sDetail - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final PublishErrorLog findById(int _nId)
                                      throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final PublishErrorLog createNewInstance()
                                               throws WCMException
产生当前对象[PublishLog]的实例

返回：
当前对象的实例[PublishLog]
抛出：
WCMException

findByKey

public static final PublishErrorLog findByKey(java.lang.Object _oKey)
                                       throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


PublishErrorLogs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.taskdispatch
类 PublishErrorLogs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs

public class PublishErrorLogs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
PublishErrorLogs(User _currUser)
构造函数
PublishErrorLogs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishErrorLogs

public PublishErrorLogs(User _currUser)
构造函数

另请参见：
PublishLogs( User _currUser, int _initCapacity, int _incCapacity );

PublishErrorLogs

public PublishErrorLogs(User _currUser,
                        int _initCapacity,
                        int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTask

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.taskdispatch
类 PublishTask

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.taskdispatch.PublishTask
所有已实现的接口：
java.lang.Cloneable
public class PublishTask
extends CMSObj

版本：
5.1
作者：
Why@TRSWCM

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
static int | TITLE_LENGTH_MAX 标题最大长度
构造方法摘要
PublishTask()
构造函数：保留默认接口
方法摘要
PublishErrorLog | addErrorLog(User _currUser, IPublishElement _publishElement, java.lang.String _sDesc, int _nResult, java.lang.String _sErrorDetail) add error log for a folder publish page task
static PublishTask | createNewInstance() 产生当前对象[PublishTask]的实例
PublishTask | duplicate(User _currUser, boolean _bInsert2DB) copy from this publish task and create a new one.
static PublishTask | findById(int _nId) 提取指定ID的对象
static PublishTask | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAnalyzeError() 提取属性：AnalyzeError
java.lang.String | getContentIds() get the property of ContentIds
IPublishElements | getContents() 获取Task所关联的内容集合
int | getContentType() get the property of ContentTypeConfig
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 提取属性：Desc
int | getDetailPageCount() 返回共计发布了多少细览页面
CMyDateTime | getEndTime() 提取属性：EndTime
PublishErrorLogs | getErrorLogs(User _currUser, WCMFilter _filter) get the error logs of this task
IPublishFolder | getFolder()
int | getFolderId() 提取属性：FolderId
java.lang.String | getFolderIds() 提取属性：FolderIds
IPublishElements | getFolders() get the property of ContentIds
int | getFolderType() 提取属性：FolderTypeConfig
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getOutlinePageCount() 返回共计发布了多少概览页面
int | getPageTaskCount() 提取属性：PageTaskCount
int | getPriority() get the property of Priority
int | getPublishType() 提取属性：PublishType
CMyDateTime | getStartTime() 提取属性：StartTime
int | getStatus() get the property of Status
int | getTimeUsed() 提取属性：TimeUsed
java.lang.String | getTitle() 提取属性：Title
java.lang.String[] | getURLs() 提取属性：URL
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isExecuted() check if this task has been executed
boolean | isHasWarnings() 提取属性：HasWarnings
boolean | isPublishContent()
boolean | isPublishFolder()
boolean | isSchedulePublishTask() 获取ISSCHEDULEDTASK属性,是否为计划发布
boolean | isValid() 检验对象数据有效性
boolean | setAnalyzeError(java.lang.String _sAnalyzeError) 设置属性：AnalyzeError
boolean | setContent(int _nType, java.lang.String _sIds) set the property of ContentTypeConfig
boolean | setContent(IPublishContent _content) set the property of ContentTypeConfig
boolean | setDesc(java.lang.String _sDesc) 设置属性：Desc
boolean | setDetailPageCount(int _nCount) 设置共计发布了多少细览页面
boolean | setEndTime(CMyDateTime _endTime) 设置属性：EndTime
boolean | setFolder(int _nType, int _nId) 设置属性：FolderTypeConfig
boolean | setFolder(IPublishFolder _folder) set the property of FolderTypeConfig
boolean | setFolders(IPublishElements folders) get the property of ContentIds
boolean | setFolders(java.lang.String sFolders) get the property of ContentIds
boolean | setHasWarnings(boolean _bHasWarnings) 设置属性：HasWarnings
boolean | setOutlinePageCount(int _nCount) 设置共计发布了多少概览页面
boolean | setPageTaskCount(int _nCount) 设置属性：PageTaskCount
void | setPriority(int _nPriority) set the property of Priority
boolean | setPublishType(int _nPublishType) 设置属性：PublishType
boolean | setSchedulePublishTask(boolean _bSchedulePublishTask) 设置ISSCHEDULEDTASK属性,是否为计划发布
boolean | setStartTime(CMyDateTime _startTime) 设置属性：StartTime
boolean | setStatus(int _nStatus) set the property of Status
boolean | setTimeUsed(int _nTimeUsed) 设置属性：TimeUsed
boolean | setTitle(java.lang.String _sTitle) 设置属性：Title
boolean | setURL(java.lang.String[] _sURL) 设置属性：URL
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

TITLE_LENGTH_MAX

public static final int TITLE_LENGTH_MAX
标题最大长度

另请参见：
常量字段值
构造方法详细信息

PublishTask

public PublishTask()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getPublishType

public int getPublishType()
提取属性：PublishType

返回：
PublishType

setPublishType

public boolean setPublishType(int _nPublishType)
                       throws WCMException
设置属性：PublishType

参数：
_nPublishType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPriority

public int getPriority()
get the property of Priority

返回：
Returns the task priority, which is defined in PublishConstants like TASK_PRIORITY_HIGH, TASK_PRIORITY_LOW, etc.

setPriority

public void setPriority(int _nPriority)
                 throws WCMException
set the property of Priority

参数：
_nPriority - the task priority, which is defined in PublishConstants like TASK_PRIORITY_HIGH, TASK_PRIORITY_LOW, etc.
抛出：
WCMException

getStatus

public int getStatus()
get the property of Status

返回：
Returns the status of this task, which is defined in PublishConstants like TASK_STATUS_WAITING, TASK_STATUS_RUNNING, etc.

isExecuted

public boolean isExecuted()
check if this task has been executed

返回：
Returns true if the task has been executed; otherwise, returns false.

setStatus

public boolean setStatus(int _nStatus)
                  throws WCMException
set the property of Status

参数：
_nStatus - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFolderType

public int getFolderType()
提取属性：FolderTypeConfig

返回：
Returns the folder type.

getFolderId

public int getFolderId()
提取属性：FolderId

返回：
FolderId

getFolder

public IPublishFolder getFolder()
                         throws WCMException
抛出：
WCMException

setFolder

public boolean setFolder(int _nType,
                         int _nId)
                  throws WCMException
设置属性：FolderTypeConfig

参数：
_nType - type of the folder
_nId - id of the folder
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setFolder

public boolean setFolder(IPublishFolder _folder)
                  throws WCMException
set the property of FolderTypeConfig

参数：
_folder - the folder to publish
返回：
Returns true if the property is set successfully; otherwise, returns false.
抛出：
WCMException - if fails to set the property value.

getContentType

public int getContentType()
get the property of ContentTypeConfig

返回：
Returns the type of the contents to publish

getContentIds

public java.lang.String getContentIds()
get the property of ContentIds

返回：
Returns the ids of the contents to publish

getContents

public IPublishElements getContents()
                             throws WCMException
获取Task所关联的内容集合

返回：
抛出：
WCMException

setContent

public boolean setContent(int _nType,
                          java.lang.String _sIds)
                   throws WCMException
set the property of ContentTypeConfig

参数：
_nType - type of the contents
_sIds - ids of the contents
返回：
Returns true if the property is valid and save successfully; otherwise, returns false.
抛出：
WCMException - if the property is invalid or fails to save the property value.

setContent

public boolean setContent(IPublishContent _content)
                   throws WCMException
set the property of ContentTypeConfig

参数：
_content - the content to publish
返回：
Returns true if the property is valid and save successfully; otherwise, returns false.
抛出：
WCMException - if the property is invalid or fails to save the property value.

getTitle

public java.lang.String getTitle()
提取属性：Title

返回：
Title

setTitle

public boolean setTitle(java.lang.String _sTitle)
                 throws WCMException
设置属性：Title

参数：
_sTitle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getURLs

public java.lang.String[] getURLs()
提取属性：URL

返回：
URL

setURL

public boolean setURL(java.lang.String[] _sURL)
               throws WCMException
设置属性：URL

参数：
_sURL - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
提取属性：Desc

返回：
Desc

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置属性：Desc

参数：
_sDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStartTime

public CMyDateTime getStartTime()
提取属性：StartTime

返回：
StartTime

setStartTime

public boolean setStartTime(CMyDateTime _startTime)
                     throws WCMException
设置属性：StartTime

参数：
_startTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEndTime

public CMyDateTime getEndTime()
提取属性：EndTime

返回：
EndTime

setEndTime

public boolean setEndTime(CMyDateTime _endTime)
                   throws WCMException
设置属性：EndTime

参数：
_endTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTimeUsed

public int getTimeUsed()
提取属性：TimeUsed

返回：
TimeUsed

setTimeUsed

public boolean setTimeUsed(int _nTimeUsed)
                    throws WCMException
设置属性：TimeUsed

参数：
_nTimeUsed - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isHasWarnings

public boolean isHasWarnings()
提取属性：HasWarnings

返回：
HasWarnings

setHasWarnings

public boolean setHasWarnings(boolean _bHasWarnings)
                       throws WCMException
设置属性：HasWarnings

参数：
_bHasWarnings - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPageTaskCount

public int getPageTaskCount()
提取属性：PageTaskCount

返回：
PageTaskCount

setPageTaskCount

public boolean setPageTaskCount(int _nCount)
                         throws WCMException
设置属性：PageTaskCount

参数：
_nCount - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAnalyzeError

public java.lang.String getAnalyzeError()
提取属性：AnalyzeError

返回：
AnalyzeError

setAnalyzeError

public boolean setAnalyzeError(java.lang.String _sAnalyzeError)
                        throws WCMException
设置属性：AnalyzeError

参数：
_sAnalyzeError - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDetailPageCount

public int getDetailPageCount()
返回共计发布了多少细览页面

返回：
共计发布了多少细览页面

setDetailPageCount

public boolean setDetailPageCount(int _nCount)
                           throws WCMException
设置共计发布了多少细览页面

参数：
_nCount - 共计发布了多少细览页面
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOutlinePageCount

public int getOutlinePageCount()
返回共计发布了多少概览页面

返回：
共计发布了多少概览页面

setOutlinePageCount

public boolean setOutlinePageCount(int _nCount)
                            throws WCMException
设置共计发布了多少概览页面

参数：
_nCount - 共计发布了多少概览页面
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final PublishTask findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final PublishTask createNewInstance()
                                           throws WCMException
产生当前对象[PublishTask]的实例

返回：
当前对象的实例[PublishTask]
抛出：
WCMException

findByKey

public static final PublishTask findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

isPublishContent

public boolean isPublishContent()
返回：
Returns true if the task is to publish a/some content(s); otherwise, returns false.

isPublishFolder

public boolean isPublishFolder()
返回：
Returns true if the task is to publish a folder; otherwise, returns false.

getErrorLogs

public PublishErrorLogs getErrorLogs(User _currUser,
                                     WCMFilter _filter)
                              throws WCMException
get the error logs of this task

参数：
_currUser - the current user
_filter - filter for the collection
返回：
Returns the error logs of the task
抛出：
WCMException - if fails to fetch the error logs.

addErrorLog

public PublishErrorLog addErrorLog(User _currUser,
                                   IPublishElement _publishElement,
                                   java.lang.String _sDesc,
                                   int _nResult,
                                   java.lang.String _sErrorDetail)
                            throws WCMException
add error log for a folder publish page task

参数：
_currUser - the current user
_folder - the folder to publish
_sDesc - the page task description
_nResult - the page task execute result
_sErrorDetail - the error detailed message
抛出：
WCMException - if failed to create error log

duplicate

public PublishTask duplicate(User _currUser,
                             boolean _bInsert2DB)
                      throws WCMException
copy from this publish task and create a new one.
Notice: only copy the task content, but not the executing information.

参数：
_currUser - the current user
_bInsert2DB - if to insert the new created task into database.
返回：
Returns the publish task duplicated.
抛出：
WCMException - if failed to copy and create the task.

getFolderIds

public java.lang.String getFolderIds()
提取属性：FolderIds

返回：
FolderIds

getFolders

public IPublishElements getFolders()
                            throws WCMException
get the property of ContentIds

返回：
Returns the ids of the contents to publish
抛出：
WCMException

setFolders

public boolean setFolders(IPublishElements folders)
                   throws WCMException
get the property of ContentIds

返回：
Returns the ids of the contents to publish
抛出：
WCMException

setFolders

public boolean setFolders(java.lang.String sFolders)
                   throws WCMException
get the property of ContentIds

返回：
Returns the ids of the contents to publish
抛出：
WCMException

isSchedulePublishTask

public boolean isSchedulePublishTask()
获取ISSCHEDULEDTASK属性,是否为计划发布

返回：

setSchedulePublishTask

public boolean setSchedulePublishTask(boolean _bSchedulePublishTask)
                               throws WCMException
设置ISSCHEDULEDTASK属性,是否为计划发布

参数：
_bSchedulePublishTask -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishTasks

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.taskdispatch
类 PublishTasks

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.taskdispatch.PublishTasks

public class PublishTasks
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
PublishTasks(User _currUser)
构造函数
PublishTasks(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static PublishTasks | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishTasks

public PublishTasks(User _currUser)
构造函数

另请参见：
PublishTasks( User _currUser, int _initCapacity, int _incCapacity );

PublishTasks

public PublishTasks(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final PublishTasks findByIds(User _currUser,
                                           java.lang.String _sIds)
                                    throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（PublishTasks）
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog
的使用

使用 PublishErrorLog 的软件包
com.trs.components.common.publish.persistent.taskdispatch

com.trs.components.common.publish.persistent.taskdispatch 中 PublishErrorLog 的使用

返回 PublishErrorLog 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
PublishErrorLog | PublishTask.addErrorLog(User _currUser, IPublishElement _publishElement, java.lang.String _sDesc, int _nResult, java.lang.String _sErrorDetail) add error log for a folder publish page task
static PublishErrorLog | PublishErrorLog.createNewInstance() 产生当前对象[PublishLog]的实例
static PublishErrorLog | PublishErrorLog.findById(int _nId) 提取指定ID的对象
static PublishErrorLog | PublishErrorLog.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs
的使用

使用 PublishErrorLogs 的软件包
com.trs.components.common.publish.persistent.taskdispatch

com.trs.components.common.publish.persistent.taskdispatch 中 PublishErrorLogs 的使用

返回 PublishErrorLogs 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
 PublishErrorLogs PublishTask.getErrorLogs(User _currUser, WCMFilter _filter)
get the error logs of this task

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask
的使用

使用 PublishTask 的软件包
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.persistent.taskdispatch
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain 中 PublishTask 的使用

返回 PublishTask 的 com.trs.components.common.publish.domain 中的方法
 PublishTask PublishServer.getRunningTask(int iTaskID)
返回指定ID的正在执行的发布任务对象

参数类型为 PublishTask 的 com.trs.components.common.publish.domain 中的方法
void | PublishServer.cancelTask(PublishTask _task) cancel the publish task if it has not been finished
void | PublishServer.deleteTask(PublishTask _task) 删除单个任务
void | PublishServer.pauseTask(PublishTask _task) 暂停指定任务的执行
void | PublishServer.redoTask(PublishTask _task) re-start a publish task
void | PublishServer.resumeTask(PublishTask _task) 暂停指定任务的执行

com.trs.components.common.publish.domain.publisher 中 PublishTask 的使用

返回 PublishTask 的 com.trs.components.common.publish.domain.publisher 中的方法
 PublishTask PublishTaskContext.getTask()

参数类型为 PublishTask 的 com.trs.components.common.publish.domain.publisher 中的构造方法
PublishTaskContext(PublishTask _task, IPublishFolder _startFolder)
constructor

com.trs.components.common.publish.domain.taskdispatch 中 PublishTask 的使用

返回 PublishTask 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishContent _content, int _nPublishType) create a content publish task
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishContent _content, int _nPublishType)
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders) 创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
PublishTask | IPublishTaskMgr.createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType) create a content publish task
PublishTask | PublishTaskMgrImpl.createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType)
PublishTask | IPublishTaskMgr.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)
PublishTask | PublishTaskMgrImpl.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)
PublishTask | IPublishTaskMgr.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)
PublishTask | PublishTaskMgrImpl.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)
PublishTask | IPublishTaskMgr.createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders) 创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
PublishTask | PublishTaskMgrImpl.createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders) 创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
PublishTask | IPublishTaskMgr.createFolderPublishTask(IPublishFolder _folder, int _nPublishType) create a folder publish task
PublishTask | PublishTaskMgrImpl.createFolderPublishTask(IPublishFolder _folder, int _nPublishType)
PublishTask | PublishTaskRuntime.getPublishTask()
PublishTask | TaskDispatcher.getRunningTask(int iTaskID)
PublishTask | IPublishTaskDispatcher.getRunningTask(int iTaskID) 返回指定ID的正在执行的发布任务对象
PublishTask | PublishTaskDispatcherImpl.getRunningTask(int iTaskID)
PublishTask | PublishTaskWorker.getTask()
PublishTask | IPublishTaskMgr.save(PublishTask _task) save the publish task which is created or updated
PublishTask | PublishTaskMgrImpl.save(PublishTask _task)

参数类型为 PublishTask 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
boolean | IPublishTaskMgr.delete(PublishTask _task) delete a publish task
boolean | PublishTaskMgrImpl.delete(PublishTask _task)
void | TaskDispatcher.pushTask(PublishTask _task)
void | IPublishTaskDispatcher.pushTask(PublishTask _task) push a publish task into the queue
void | PublishTaskDispatcherImpl.pushTask(PublishTask _task)
PublishTask | IPublishTaskMgr.save(PublishTask _task) save the publish task which is created or updated
PublishTask | PublishTaskMgrImpl.save(PublishTask _task)
void | PublishTaskWorker.setTask(PublishTask _task) set the task to execute
void | PublishTaskAnalyzer.start(PublishTask _task) start to analyze the publish task.

com.trs.components.common.publish.persistent.taskdispatch 中 PublishTask 的使用

返回 PublishTask 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
static PublishTask | PublishTask.createNewInstance() 产生当前对象[PublishTask]的实例
PublishTask | PublishTask.duplicate(User _currUser, boolean _bInsert2DB) copy from this publish task and create a new one.
static PublishTask | PublishTask.findById(int _nId) 提取指定ID的对象
static PublishTask | PublishTask.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

参数类型为 PublishTask 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
 boolean PublishErrorLog.setPublishTask(PublishTask _task)
set the property of PublishTask

com.trs.service 中 PublishTask 的使用

返回 PublishTask 的 com.trs.service 中的方法
 PublishTask IPublishService.getRunningTask(int iTaskID)
返回指定ID的正在执行的发布任务对象

com.trs.service.impl 中 PublishTask 的使用

返回 PublishTask 的 com.trs.service.impl 中的方法
 PublishTask PublishService.getRunningTask(int iTaskID)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.taskdispatch.PublishTasks 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.taskdispatch.PublishTasks
的使用

使用 PublishTasks 的软件包
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.persistent.taskdispatch
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain 中 PublishTasks 的使用

返回 PublishTasks 的 com.trs.components.common.publish.domain 中的方法
PublishTasks | PublishServer.getAllTasks(WCMFilter _filter) get all the publish tasks in the system
PublishTasks | PublishServer.getMyTasks(WCMFilter _filter) get the publish tasks of the specified user

参数类型为 PublishTasks 的 com.trs.components.common.publish.domain 中的方法
void | PublishServer.cancelTask(PublishTasks _tasks) cancel each publish task in the collection
void | PublishServer.redoTask(PublishTasks _tasks) re-execute each publish task in the collection

com.trs.components.common.publish.domain.taskdispatch 中 PublishTasks 的使用

返回 PublishTasks 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
PublishTasks | IPublishTaskMgr.getMyTasks(WCMFilter _filter) get the publish tasks created by the specified user
PublishTasks | PublishTaskMgrImpl.getMyTasks(WCMFilter _filter)
PublishTasks | IPublishTaskMgr.getTasks(WCMFilter _filter) get the tasks collection with the specified filter
PublishTasks | PublishTaskMgrImpl.getTasks(WCMFilter _filter)
PublishTasks | IPublishTaskMgr.getUnfinishedTasks() get the tasks collection who have not been finished.
PublishTasks | PublishTaskMgrImpl.getUnfinishedTasks()

com.trs.components.common.publish.persistent.taskdispatch 中 PublishTasks 的使用

返回 PublishTasks 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
static PublishTasks PublishTasks.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

com.trs.service 中 PublishTasks 的使用

返回 PublishTasks 的 com.trs.service 中的方法
PublishTasks | IPublishService.getAllTasks(WCMFilter _filter) 提取所有的发布任务；要求当前用户必须具有管理权限
PublishTasks | IPublishService.getMyTasks(WCMFilter _filter) 提取我的发布任务

com.trs.service.impl 中 PublishTasks 的使用

返回 PublishTasks 的 com.trs.service.impl 中的方法
PublishTasks | PublishService.getAllTasks(WCMFilter _filter)
PublishTasks | PublishService.getMyTasks(WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.publish.persistent.template
类
TagBean
TagBeans
TempApdRel
TempApdRels
TempAppendix
TempAppendixes
TempAppendixXmlConverter
Template
TemplateArgument
TemplateArguments
TemplateEmploy
TemplateEmploys
TemplateQuote
TemplateQuotes
Templates
TemplateXmlConverter


com.trs.components.common.publish.persistent.template

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.persistent.template

类摘要
TagBean |
TagBeans |
TempApdRel |
TempApdRels |
TempAppendix |
TempAppendixes |
TempAppendixXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 模板附件导出成为WCM的XML格式的转换管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Template | Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateArgument | 模板中的形式参数的实际值
TemplateArguments | TemplateArgument对象的集合
TemplateEmploy |
TemplateEmploys |
TemplateQuote |
TemplateQuotes |
Templates |
TemplateXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 将模板导入、导出成为WCM的XML对象 目前模板的导入只支持随着站点的导入一起进行，不支持单独的模板导入 目前提供的独立的模板导入、导出是通过独立的处理逻辑进行的，和XML的导入、导出没有关系 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.common.publish.persistent.template 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.template 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.publish.persistent.template.TagBean
        • com.trs.components.common.publish.persistent.template.TempApdRel
        • com.trs.components.common.publish.persistent.template.TempAppendix
        • com.trs.components.common.publish.persistent.template.Template
        • com.trs.components.common.publish.persistent.template.TemplateArgument
        • com.trs.components.common.publish.persistent.template.TemplateEmploy
        • com.trs.components.common.publish.persistent.template.TemplateQuote
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.publish.persistent.template.TagBeans
        • com.trs.components.common.publish.persistent.template.TempApdRels
        • com.trs.components.common.publish.persistent.template.TempAppendixes
        • com.trs.components.common.publish.persistent.template.TemplateArguments
        • com.trs.components.common.publish.persistent.template.TemplateEmploys
        • com.trs.components.common.publish.persistent.template.TemplateQuotes
        • com.trs.components.common.publish.persistent.template.Templates
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.components.common.publish.persistent.template.TempAppendixXmlConverter
      • com.trs.components.common.publish.persistent.template.TemplateXmlConverter


软件包 com.trs.components.common.publish.persistent.template 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.persistent.template
的使用

使用 com.trs.components.common.publish.persistent.template 的软件包
com.trs.ajaxservice |
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.infoview.helper |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.recent |
com.trs.service |
com.trs.service.impl |
com.trs.template.domain |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |
com.trs.wcmonline |

com.trs.ajaxservice 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmploys
Templates

com.trs.components.comment.publish.tagparser 使用的 com.trs.components.common.publish.persistent.template 中的类
TemplateQuote

com.trs.components.common.publish.domain 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.publisher 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.tagparser 使用的 com.trs.components.common.publish.persistent.template 中的类
TagBean
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateQuote

com.trs.components.common.publish.domain.template 使用的 com.trs.components.common.publish.persistent.template 中的类
TempAppendixes
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateArgument
模板中的形式参数的实际值
TemplateArguments
TemplateArgument对象的集合
TemplateEmploy
TemplateEmploys
TemplateQuote
Templates

com.trs.components.common.publish.persistent.element 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Templates

com.trs.components.common.publish.persistent.template 使用的 com.trs.components.common.publish.persistent.template 中的类
TagBean
TagBeans
TempApdRel
TempApdRels
TempAppendix
TempAppendixes
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateArgument
模板中的形式参数的实际值
TemplateArguments
TemplateArgument对象的集合
TemplateEmploy
TemplateEmploys
TemplateQuote
TemplateQuotes
Templates

com.trs.components.common.publish.widget 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.helper 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.publish.tagparser 使用的 com.trs.components.common.publish.persistent.template 中的类
TemplateQuote

com.trs.components.metadata.publish 使用的 com.trs.components.common.publish.persistent.template 中的类
TemplateQuote

com.trs.components.wcm.epress 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateQuote
Templates

com.trs.components.wcm.publish 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 使用的 com.trs.components.common.publish.persistent.template 中的类
TemplateQuote

com.trs.components.wcm.publish.tagparser 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateQuote

com.trs.components.wcm.recent 使用的 com.trs.components.common.publish.persistent.template 中的类
Templates

com.trs.service 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateArgument
模板中的形式参数的实际值
TemplateArguments
TemplateArgument对象的集合
Templates

com.trs.service.impl 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateArgument
模板中的形式参数的实际值
TemplateArguments
TemplateArgument对象的集合
Templates

com.trs.template.domain 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Templates

com.trs.wcm.photo 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo.impl 使用的 com.trs.components.common.publish.persistent.template 中的类
Template
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcmonline 使用的 com.trs.components.common.publish.persistent.template 中的类
TemplateQuote

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TagBean

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TagBean

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.template.TagBean
所有已实现的接口：
java.lang.Cloneable
public class TagBean
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
TagBean()
系统默认的TRS置标解析组件的构造函数
方法摘要
static TagBean | createNewInstance() 产生当前对象[TagBean]的实例
static TagBean | findById(int _nId) 提取指定ID的对象
static TagBean | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 返回TRS置标解析组件的数据库表名：TagBeans
java.lang.String | getIdFieldName() 返回TRS置标解析组件数据库表的标识字段名：TAGEBEANID
java.lang.String | getTagBean() 返回TRS置标解析组件的组件名
java.lang.String | getTagDesc() 获得TRS置标解析组件的描述
java.lang.String | getTagName() 返回TRS置标解析组件负责解析的置标名称
int | getWCMType() 获得TRS置标解析组件的对象类型（WCMTypes.OBJ_TAGBEAN）
void | insert(User _currUser) 将对象数据写入数据库
boolean | isEnabled() Returns the value of property Enabled.
boolean | isValid() 验证TRS置标解析组件是否有效
boolean | setEnabled(boolean _bEnabled) Sets the value of property Enabled.
boolean | setTagBean(java.lang.String _sBean) 设置TRS置标解析组件的组件名
boolean | setTagDesc(java.lang.String _sDesc) 设置TRS置标解析组件的描述
boolean | setTagName(java.lang.String _sName) 设置TRS置标解析组件负责解析的置标名称
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

TagBean

public TagBean()
系统默认的TRS置标解析组件的构造函数

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
返回TRS置标解析组件的数据库表名：TagBeans

指定者：
类 BaseObj 中的 getDbTableName
返回：
数据库表名

getIdFieldName

public java.lang.String getIdFieldName()
返回TRS置标解析组件数据库表的标识字段名：TAGEBEANID

指定者：
类 BaseObj 中的 getIdFieldName
返回：
标识字段

getWCMType

public int getWCMType()
获得TRS置标解析组件的对象类型（WCMTypes.OBJ_TAGBEAN）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象类型

getTagName

public java.lang.String getTagName()
返回TRS置标解析组件负责解析的置标名称

返回：
置标名

setTagName

public boolean setTagName(java.lang.String _sName)
                   throws WCMException
设置TRS置标解析组件负责解析的置标名称

参数：
_sName - 置标名
返回：
设置操作是否成功
抛出：
WCMException - 如果设置过程中发生错误，则抛出WCMException异常

getTagDesc

public java.lang.String getTagDesc()
获得TRS置标解析组件的描述

返回：
置标解析组件的描述

setTagDesc

public boolean setTagDesc(java.lang.String _sDesc)
                   throws WCMException
设置TRS置标解析组件的描述

参数：
_sDesc - 新的描述
返回：
描述设置是否成功
抛出：
WCMException - 如果设置过程中发生错误，则抛出WCMException异常

getTagBean

public java.lang.String getTagBean()
返回TRS置标解析组件的组件名

返回：
组件名

setTagBean

public boolean setTagBean(java.lang.String _sBean)
                   throws WCMException
设置TRS置标解析组件的组件名

参数：
_sBean - 新的解释组件名
返回：
设置是否成功
抛出：
WCMException - 如果设置过程中发生错误，则抛出WCMException异常

isEnabled

public boolean isEnabled()
Returns the value of property Enabled.

返回：
the value of propery Enabled.

setEnabled

public boolean setEnabled(boolean _bEnabled)
                   throws WCMException
Sets the value of property Enabled.

参数：
_bEnabled - property value.
返回：
true if the property value is set successfully.
抛出：
WCMException - if failed to set the property value.

isValid

public boolean isValid()
                throws WCMException
验证TRS置标解析组件是否有效

指定者：
类 BaseObj 中的 isValid
返回：
组件对象是否有效
抛出：
WCMException - 如果验证过程中发生错误，则抛出WCMException异常

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final TagBean findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final TagBean createNewInstance()
                                       throws WCMException
产生当前对象[TagBean]的实例

返回：
当前对象的实例[TagBean]
抛出：
WCMException

findByKey

public static final TagBean findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


TagBeans

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TagBeans

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.template.TagBeans

public class TagBeans
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
TagBeans(User _currUser)
置标解析组件集合的构造函数
TagBeans(User _currUser, int initialCapacity, int capacityIncrement)
置标解析组件集合的构造函数
方法摘要
TagBeans | copy()
java.lang.Class | getElementClass() 重载函数：返回置标解析组件的Class
java.lang.String | getIdFieldName() 重载函数：返回置标解析组件的数据表标识字段
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagBeans

public TagBeans(User _currUser)
置标解析组件集合的构造函数

参数：
_currUser - 当前构造集合的用户
_app - 当前构造集合所处的应用服务器

TagBeans

public TagBeans(User _currUser,
                int initialCapacity,
                int capacityIncrement)
置标解析组件集合的构造函数

参数：
_currUser - 当前构造集合的用户
_app - 当前构造集合所处的应用服务器
initialCapacity - 集合的初始大小
capacityIncrement - 集合的增量
方法详细信息

copy

public TagBeans copy()
              throws java.lang.Exception
抛出：
java.lang.Exception

getIdFieldName

public java.lang.String getIdFieldName()
重载函数：返回置标解析组件的数据表标识字段

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
标识字段

getElementClass

public java.lang.Class getElementClass()
重载函数：返回置标解析组件的Class

指定者：
类 BaseObjs 中的 getElementClass
返回：
TagBean.Class

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
新的集合对象
抛出：
java.lang.Exception - 如果生成过程中发生错误，则抛出WCMException异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TempApdRel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TempApdRel

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.template.TempApdRel
所有已实现的接口：
java.lang.Cloneable
public class TempApdRel
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
TempApdRel()
构造函数：保留默认接口
方法摘要
static TempApdRel | createNewInstance() 产生当前对象[TempApdRel]的实例
static TempApdRel | findById(int _nId) 提取指定ID的对象
static TempApdRel | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getId() 提取属性：RecId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getTempAppendixId() 提取属性：TempAppendixId
int | getTemplateId() 提取属性：TemplateId
int | getWCMType() 取得该对象的类型编号
boolean | isValid() 检验对象数据有效性
boolean | setTempAppendixId(int _nTempAppendixId) 设置属性：TempAppendixId
boolean | setTemplateId(int _nTemplateId) 设置属性：TemplateId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

TempApdRel

public TempApdRel()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getTemplateId

public int getTemplateId()
提取属性：TemplateId

返回：
TemplateId

setTemplateId

public boolean setTemplateId(int _nTemplateId)
                      throws WCMException
设置属性：TemplateId

参数：
_nTemplateId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTempAppendixId

public int getTempAppendixId()
提取属性：TempAppendixId

返回：
TempAppendixId

setTempAppendixId

public boolean setTempAppendixId(int _nTempAppendixId)
                          throws WCMException
设置属性：TempAppendixId

参数：
_nTempAppendixId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getId

public int getId()
提取属性：RecId

覆盖：
类 BaseObj 中的 getId
返回：
RecId

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

findById

public static final TempApdRel findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByKey

public static final TempApdRel findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final TempApdRel createNewInstance()
                                          throws WCMException
产生当前对象[TempApdRel]的实例

返回：
当前对象的实例[TempApdRel]
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TempApdRels

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TempApdRels

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.template.TempApdRels

public class TempApdRels
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
TempApdRels(User _currUser)
构造函数
TempApdRels(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static TempApdRels | createNewInstance(User _currUser) 产生一个当前集合对象[TempApdRels]的实例
static TempApdRels | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static TempApdRels | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TempApdRels]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TempApdRels

public TempApdRels(User _currUser)
构造函数

另请参见：
TempApdRels( User _currUser, Application _app, int _initCapacity, int _incCapacity );

TempApdRels

public TempApdRels(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final TempApdRels findByIds(User _currUser,
                                          java.lang.String _sIds)
                                   throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final TempApdRels openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[TempApdRels]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[TempApdRels]
抛出：
WCMException

createNewInstance

public static TempApdRels createNewInstance(User _currUser)
产生一个当前集合对象[TempApdRels]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TempAppendix

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TempAppendix

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.template.TempAppendix
所有已实现的接口：
java.lang.Cloneable
public class TempAppendix
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | FLAG_DELETED 附件标志：删除 1
static int | FLAG_NEW 附件标志：新增 0
static int | FLAG_PUBLISHED 附件标志：发布 3
static int | FLAG_UPDATED 附件标志：更新 2
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
TempAppendix()
构造函数：保留默认接口
方法摘要
boolean | addRelation(int _templateId) 增加模板和附件的关联
boolean | addRelation(Template _template) 增加模板和附件的关联
static TempAppendix | createNewInstance() 产生当前对象[TempAppendix]的实例
boolean | deleteRelation(int _templateId) 删除模板和附件的关联
boolean | deleteRelation(Template _template) 删除模板和附件的关联
static TempAppendix | findById(int _nId) 提取指定ID的对象
static TempAppendix | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得模板附件的数据存储
java.lang.String | getFile() 获得模板附件的文件名
int | getFlag() 获得模板附件的标记
java.lang.String | getIdFieldName() 获得模板附件的数据存储的标识字段
IPublishFolder | getRoot() 获得模板附件所属的站点
int | getRootId() 获得模板附件所属的文件夹根目录
int | getRootType()
int | getWCMType() 获得模板附件对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加模板附件对象到数据库
boolean | isValid() 检查模板附件对象数据的有效性
boolean | setFile(java.lang.String _sFile) 设置模板附件的文件名
boolean | setFlag(int _nFlag) 设置模板附件的标记
boolean | setRoot(int _nType, int _nId) 设置模板附件的所属文件夹根目录
boolean | setRoot(IPublishFolder _root) 设置模板附件的所属文件夹根目录
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

FLAG_NEW

public static final int FLAG_NEW
附件标志：新增 0

另请参见：
常量字段值

FLAG_DELETED

public static final int FLAG_DELETED
附件标志：删除 1

另请参见：
常量字段值

FLAG_UPDATED

public static final int FLAG_UPDATED
附件标志：更新 2

另请参见：
常量字段值

FLAG_PUBLISHED

public static final int FLAG_PUBLISHED
附件标志：发布 3

另请参见：
常量字段值
构造方法详细信息

TempAppendix

public TempAppendix()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
获得模板附件的数据存储

指定者：
类 BaseObj 中的 getDbTableName
返回：
表名(WCMTEMPAPPENDIX)

getIdFieldName

public java.lang.String getIdFieldName()
获得模板附件的数据存储的标识字段

指定者：
类 BaseObj 中的 getIdFieldName
返回：
标识字段(TEMPAPPENDIXID)

getWCMType

public int getWCMType()
获得模板附件对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象类型(OBJ_TEMPAPPENDIX)

getRootType

public int getRootType()
返回：
Returns the root type.

getRootId

public int getRootId()
获得模板附件所属的文件夹根目录

返回：
文件夹根目录编号

getRoot

public IPublishFolder getRoot()
                       throws java.lang.Exception
获得模板附件所属的站点

返回：
文件夹根目录对象
抛出：
java.lang.Exception - 如果发生错误，则抛出异常

setRoot

public boolean setRoot(int _nType,
                       int _nId)
                throws WCMException
设置模板附件的所属文件夹根目录

参数：
_nType - 文件夹类型
_nId - 文件夹根目录编号
返回：
设置是否成功
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

setRoot

public boolean setRoot(IPublishFolder _root)
                throws WCMException
设置模板附件的所属文件夹根目录

参数：
_root - 文件夹根目录对象
返回：
设置是否成功
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

getFlag

public int getFlag()
获得模板附件的标记

返回：
标记

setFlag

public boolean setFlag(int _nFlag)
                throws WCMException
设置模板附件的标记

参数：
_nFlag - 新的标记
返回：
设置是否成功
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

getFile

public java.lang.String getFile()
获得模板附件的文件名

返回：
文件名

setFile

public boolean setFile(java.lang.String _sFile)
                throws WCMException
设置模板附件的文件名

参数：
_sFile - 新的文件名
返回：
设置是否成功
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

isValid

public boolean isValid()
                throws WCMException
检查模板附件对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
是否有效
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

insert

public void insert(User _currUser)
            throws WCMException
添加模板附件对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 操作用户
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

addRelation

public boolean addRelation(int _templateId)
                    throws WCMException
增加模板和附件的关联

参数：
_templateId - 模板编号
返回：
增加是否成功
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

addRelation

public boolean addRelation(Template _template)
                    throws WCMException
增加模板和附件的关联

参数：
_template - 模板对象
返回：
增加是否成功
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

deleteRelation

public boolean deleteRelation(Template _template)
                       throws WCMException
删除模板和附件的关联

参数：
_template - 模板对象
返回：
删除是否成功
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

deleteRelation

public boolean deleteRelation(int _templateId)
                       throws WCMException
删除模板和附件的关联

参数：
_templateId - 模板编号
返回：
删除是否成功
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

findById

public static final TempAppendix findById(int _nId)
                                   throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final TempAppendix createNewInstance()
                                            throws WCMException
产生当前对象[TempAppendix]的实例

返回：
当前对象的实例[TempAppendix]
抛出：
WCMException

findByKey

public static final TempAppendix findByKey(java.lang.Object _oKey)
                                    throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TempAppendixes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TempAppendixes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.template.TempAppendixes

public class TempAppendixes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
TempAppendixes(User _currUser)
指定用户和应用服务器的构造函数
TempAppendixes(User _currUser, int _initCapacity, int _incCapacity)
指定用户和应用服务器的构造函数
方法摘要
static TempAppendixes | createNewInstance(User _currUser) 产生一个当前集合对象[TempAppendixes]的实例
static TempAppendixes | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 获得模板附件的Class
java.lang.String | getIdFieldName() 获得模板附件的数据库标识字段
BaseObjs | newInstance() 生成新的集合对象实例
static TempAppendixes | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TempAppendixes]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TempAppendixes

public TempAppendixes(User _currUser)
指定用户和应用服务器的构造函数

参数：
_currUser - 操作用户
_app - 正在运行的TRS WCM Application Server

TempAppendixes

public TempAppendixes(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
指定用户和应用服务器的构造函数

参数：
_currUser - 操作用户
_app - 正在运行的TRS WCM Application Server
_initCapacity - 集合初始容量
_incCapacity - 增量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
获得模板附件的数据库标识字段

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
标识字段

getElementClass

public java.lang.Class getElementClass()
获得模板附件的Class

指定者：
类 BaseObjs 中的 getElementClass
返回：
TempAppendix.class

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
新的集合对象
抛出：
java.lang.Exception - 如果发生错误，则抛出WCMException异常

findByIds

public static final TempAppendixes findByIds(User _currUser,
                                             java.lang.String _sIds)
                                      throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final TempAppendixes openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[TempAppendixes]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[TempAppendixes]
抛出：
WCMException

createNewInstance

public static TempAppendixes createNewInstance(User _currUser)
                                        throws WCMException
产生一个当前集合对象[TempAppendixes]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TempAppendixXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TempAppendixXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.common.publish.persistent.template.TempAppendixXmlConverter

public class TempAppendixXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
模板附件导出成为WCM的XML格式的转换管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TempAppendixXmlConverter()
constructor: default
方法摘要
 void initConverter(int _nRootType, int _nRootId, java.lang.String _sExportPath)
使用converter时必须初始化一些参数，否则无法正常进行相关操作
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TempAppendixXmlConverter

public TempAppendixXmlConverter()
constructor: default

方法详细信息

initConverter

public void initConverter(int _nRootType,
                          int _nRootId,
                          java.lang.String _sExportPath)
                   throws WCMException
使用converter时必须初始化一些参数，否则无法正常进行相关操作

参数：
_nRootId -
_sExportPath -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Template

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 Template

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.template.Template
所有已实现的接口：
java.lang.Cloneable
public class Template
extends CMSObj

Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | ALL_TEMPLATE 已过时。 please use PublishConstants.TEMPLATE_TYPE_ANY
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | DETAIL_TEMPLATE 已过时。 please use PublishConstants.TEMPLATE_TYPE_DETAIL
static int | INPUT_TEMPLATE 已过时。 please use PublishConstants.TEMPLATE_TYPE_NESTED
static int | OBJ_TYPE
static int | OUTLINE_TEMPLATE 已过时。 please use PublishConstants.TEMPLATE_TYPE_OUTLINE
构造方法摘要
Template()
方法摘要
TempAppendix | addAppendix(User _currUser, java.lang.String _sFile, boolean _bAddRelation) 添加一个模板附件
int | clearAppendixes() clear all appendxes of this template
static Template | createNewInstance() 产生当前对象[Template]的实例
boolean | deleteAppendix(int _appendixId) 删除一个模板附件，仅仅删除附件关联
boolean | deleteAppendix(TempAppendix _appendix) 删除一个模板附件，仅仅删除附件关联
static Template | findById(int _nId) 提取指定ID的对象
static Template | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getApdFilePubHttpPath() 取附件文件发布后的Http路径，如：/site1/image/
TempApdRels | getApdRels(WCMFilter _filter) get the template appendix relations
TempAppendixes | getAppendixes(User _currUser) 取模板的附件集合
TempAppendixes | getAppendixes(User _currUser, int[] arrFlags) 取模板的附件集合
java.lang.String | getCharSet() 获取模板的charset设置,如果模板本身没有设置,则返回从所属Folder所设置的发布语言.
java.lang.String | getDbTableName() 获得模板的数据表
java.lang.String | getDesc() 获得模板的描述
IPublishFolder | getFolder() get the folder where the template is located.
int | getFolderId()
int | getFolderType()
java.lang.String | getIdFieldName() 获得模板数据表的ID字段
java.lang.String | getInfo() Returns the template information.
java.lang.String | getName() 获得模板的名称
Template | getNestedTemplate(IPublishElement element, java.lang.String sIdentity)
java.lang.String | getOutputFileExt() 获得模板的扩展名；若没有设置，则返回htm(PublishConstants.DEF_PAGE_FILEEXT)
java.lang.String | getOutputFileName() 获取模板发布后生成的文件名(不含扩展名)；仅当模板为概览模板时有效。
java.lang.String | getPubText() 取模板发布正文，用于模板解析
IPublishFolder | getRoot() get the root folder where the template is located.
int | getRootId() 获得模板所属的文件夹根目录编号
int | getRootType()
TemplateParameterList | getTemplateParameters() 返回模板中所有形式参数的列表
TemplateParameterList | getTemplateParameters(boolean zRecursion) 返回模板中所有形式参数的列表
java.lang.String | getText() 获得模板内容文本
java.lang.String | getTextWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute) 模板文本图片过滤处理，用于模板正文的显示处理 处理过程：对模板正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于： [1]模板正文显示，使用 getTextWithImgFilter( "show-pic.jsp?
int | getType() 获得模板的类型
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
static int | guessTypeByName(java.lang.String _sTempName) 根据模板名称的特点，自动选择模板类型
void | insert(User _currUser) 添加模板对象到数据库
boolean | isAccessibleFrom(IPublishFolder _folder) 判断从指定目录是否可以访问当前模板
boolean | isApdModified() 判断模板附件是否修改
boolean | isHaveRelation(java.sql.Connection _oConn, int _nAppendixId) 判断模板与附件是否关联
boolean | isParsed()
boolean | isValid() 检查数据的有效性
java.util.Iterator | iterateNestedIdentity()
java.lang.String | makeNestedIndentiy(java.lang.String nestedName)
void | save(User _currUser) 对象保存自己
boolean | setApdModified(boolean _bModified) 设置模板附件是否被修改的标记
boolean | setCharSet(java.lang.String charset) 设置模板的字符集属性,应该模板内容中的charset一致.
boolean | setDesc(java.lang.String _desc) 设置模板的描述
boolean | setFolder(int _nType, int _nId) set the folder id
boolean | setFolder(int _nFolderType, int _nFolderId, int _nRootType, int _nRootId) set the folder where the template is located
boolean | setFolder(IPublishFolder _folder) set the folder where the template is located
boolean | setFolder(IPublishFolder _folder, IPublishFolder _root) set the folder where the template is located
boolean | setName(java.lang.String _name) 设置模板的名称
boolean | setOutputFileExt(java.lang.String _ext) 设置模板的扩展名
boolean | setOutputFileName(java.lang.String _sFileName) 设置模板发布后的输出文件名
boolean | setParsed(boolean _bParsed) set the property of Parsed.
boolean | setRoot(int _nType, int _nId) 设置模板的所属文件夹根目录，仅添加模板时可用，不允许修改该属性。
void | setTemplateParameters(TemplateParameterList list) 设置模板中的形式参数的列表 该方法仅供类型'TemplateParseMgr'调用，本来模板中的形式参数列表应该在模板类内部完成， 但是因为还涉及到参数实际值的清除，以及模板修改后形式参数列表的替换等问题，所以将形式 参数列表的构造移动到类型'TemplateParseMgr'中。
boolean | setText(java.lang.String _text) 设置模板正文
boolean | setType(int _type) 设置模板的类型
java.lang.String | toString()
void | updateAppendixStatus() 设置模板Text属性（Html文本格式）
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

INPUT_TEMPLATE

public static final int INPUT_TEMPLATE
已过时。 please use PublishConstants.TEMPLATE_TYPE_NESTED
嵌套模板

另请参见：
常量字段值

DETAIL_TEMPLATE

public static final int DETAIL_TEMPLATE
已过时。 please use PublishConstants.TEMPLATE_TYPE_DETAIL
细览模板

另请参见：
常量字段值

OUTLINE_TEMPLATE

public static final int OUTLINE_TEMPLATE
已过时。 please use PublishConstants.TEMPLATE_TYPE_OUTLINE
概览模板

另请参见：
常量字段值

ALL_TEMPLATE

public static final int ALL_TEMPLATE
已过时。 please use PublishConstants.TEMPLATE_TYPE_ANY
所有类型的模板 by wenyh@04-12-29

另请参见：
常量字段值
构造方法详细信息

Template

public Template()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
获得模板的数据表

指定者：
类 BaseObj 中的 getDbTableName
返回：
模板表(WCMTEMPLATE)

getIdFieldName

public java.lang.String getIdFieldName()
获得模板数据表的ID字段

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段(TEMPID)

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象类型

guessTypeByName

public static int guessTypeByName(java.lang.String _sTempName)
根据模板名称的特点，自动选择模板类型

参数：
_sTempName -
返回：
模板类型，参见Template中的常量

getName

public java.lang.String getName()
获得模板的名称

返回：
模板名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置模板的名称

参数：
_name - 新的模板名
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误，则抛出异常

setType

public boolean setType(int _type)
                throws WCMException
设置模板的类型

参数：
_type - 模板的类型
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误，则抛出异常

getType

public int getType()
获得模板的类型

返回：
模板的类型

getOutputFileName

public java.lang.String getOutputFileName()
获取模板发布后生成的文件名(不含扩展名)；仅当模板为概览模板时有效。
如果当前模板是概览模板,则返回PublishConstants.DEF_PAGE_FILEEXT_DETAIL

返回：

setOutputFileName

public boolean setOutputFileName(java.lang.String _sFileName)
                          throws WCMException
设置模板发布后的输出文件名

参数：
_sFileName -
抛出：
WCMException

getOutputFileExt

public java.lang.String getOutputFileExt()
获得模板的扩展名；若没有设置，则返回htm(PublishConstants.DEF_PAGE_FILEEXT)

返回：
模板扩展名

setOutputFileExt

public boolean setOutputFileExt(java.lang.String _ext)
                         throws WCMException
设置模板的扩展名

参数：
_ext - 新的模板扩展名
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误，则抛出异常

getRootType

public int getRootType()
返回：
Returns type of the root where the template is located.

getRootId

public int getRootId()
获得模板所属的文件夹根目录编号

返回：
Returns id of the root where the template is located.

getRoot

public IPublishFolder getRoot()
                       throws WCMException
get the root folder where the template is located.

返回：
Returns the root folder where the template is located.
抛出：
java.lang.Exception - 如果发生错误，则抛出异常
WCMException

setRoot

public boolean setRoot(int _nType,
                       int _nId)
                throws WCMException
设置模板的所属文件夹根目录，仅添加模板时可用，不允许修改该属性。

参数：
_nType - the root folder type.
_nId - the root folder id
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误，则抛出异常

getFolderType

public int getFolderType()
返回：
Returns type of the foler where the template is located.

getFolderId

public int getFolderId()
返回：
Returns id of the folder where the template is located.

getFolder

public IPublishFolder getFolder()
                         throws WCMException
get the folder where the template is located.

返回：
Returns the folder object.
抛出：
WCMException

setFolder

public boolean setFolder(int _nFolderType,
                         int _nFolderId,
                         int _nRootType,
                         int _nRootId)
                  throws WCMException
set the folder where the template is located

参数：
_nFolderType - type of the folder
_nFolderId - id of the folder
_nRootType - type of the folder root
_nRootId - id of the folder root
返回：
true if the property is set successfully.
抛出：
WCMException - if failed.

setFolder

public boolean setFolder(IPublishFolder _folder,
                         IPublishFolder _root)
                  throws WCMException
set the folder where the template is located

参数：
_folder - the folder where the template is located.
_root - root of the folder
返回：
true if the property is set successfully.
抛出：
WCMException - if failed.

setFolder

public boolean setFolder(int _nType,
                         int _nId)
                  throws WCMException
set the folder id

参数：
_nType - type of the folder
_nId - id of the folder where the template is located.
抛出：
WCMException - if failed.

setFolder

public boolean setFolder(IPublishFolder _folder)
                  throws WCMException
set the folder where the template is located

参数：
_folder - the folder where template is located.
返回：
true if the property is set successfully.
抛出：
WCMException - if failed.

getDesc

public java.lang.String getDesc()
获得模板的描述

返回：
模板描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置模板的描述

参数：
_desc - 新的模板描述
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误，则抛出异常

getText

public java.lang.String getText()
获得模板内容文本

返回：
模板内容

setText

public boolean setText(java.lang.String _text)
                throws WCMException
设置模板正文

参数：
_text -
返回：
抛出：
WCMException

isApdModified

public boolean isApdModified()
判断模板附件是否修改

返回：
是否修改

setApdModified

public boolean setApdModified(boolean _bModified)
                       throws WCMException
设置模板附件是否被修改的标记

参数：
_bModified - 是否修改
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误则抛出异常

isParsed

public boolean isParsed()
返回：
Returns true if the template has been parsed;
otherwise, returns false.

setParsed

public boolean setParsed(boolean _bParsed)
                  throws WCMException
set the property of Parsed.

参数：
_bParsed - if the template has been parsed.
返回：
Returns true if the property is set successfully.
抛出：
WCMException - if failed.

isValid

public boolean isValid()
                throws WCMException
检查数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
数据是否有效，true表示有效
抛出：
WCMException - 如果发生错误，则抛出异常

insert

public void insert(User _currUser)
            throws WCMException
添加模板对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 执行添加操作的用户
抛出：
WCMException - 如果发生错误，则抛出异常

save

public void save(User _currUser)
          throws WCMException
从类 CMSObj 复制的描述
对象保存自己

覆盖：
类 CMSObj 中的 save
参数：
_currUser - 当前操作用户
抛出：
WCMException

getAppendixes

public TempAppendixes getAppendixes(User _currUser)
                             throws WCMException
取模板的附件集合

参数：
_currUser - 执行操作的用户
返回：
附件集合
抛出：
WCMException - 如果发生错误，则抛出异常

getAppendixes

public TempAppendixes getAppendixes(User _currUser,
                                    int[] arrFlags)
                             throws WCMException
取模板的附件集合

参数：
_currUser - 执行操作的用户
arrFlags - 提取附件的类型
_bIncludeChilren - 是否包含嵌套模板的附件
返回：
附件集合
抛出：
WCMException

getApdRels

public TempApdRels getApdRels(WCMFilter _filter)
                       throws WCMException
get the template appendix relations

参数：
_filter - the extra filter for the collection
返回：
Returns the appendix relations collection
抛出：
WCMException - if failed to fetch the collection.

addAppendix

public TempAppendix addAppendix(User _currUser,
                                java.lang.String _sFile,
                                boolean _bAddRelation)
                         throws WCMException
添加一个模板附件

参数：
_currUser - 执行操作的用户
_sFile - 附件文件名
_bAddRelation - 是否仅添加关联
返回：
新建的模板附件对象
抛出：
WCMException

deleteAppendix

public boolean deleteAppendix(TempAppendix _appendix)
                       throws WCMException
删除一个模板附件，仅仅删除附件关联

参数：
_currUser - 执行操作的用户
_appendix - 附件对象
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误则抛出异常

deleteAppendix

public boolean deleteAppendix(int _appendixId)
                       throws WCMException
删除一个模板附件，仅仅删除附件关联

参数：
_currUser - 执行操作的用户
_appendixId - 附件对象的编号
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误则抛出异常

clearAppendixes

public int clearAppendixes()
                    throws WCMException
clear all appendxes of this template

返回：
Returns the appendixes count deleted.
抛出：
WCMException - if failed to delete the appendixes.

getApdFilePubHttpPath

public java.lang.String getApdFilePubHttpPath()
                                       throws java.lang.Exception
取附件文件发布后的Http路径，如：/site1/image/

返回：
附件发布后的Http路径
抛出：
java.lang.Exception

getPubText

public java.lang.String getPubText()
                            throws WCMException
取模板发布正文，用于模板解析

返回：
图片处理后的模板正文
抛出：
WCMException - 模板正文过滤处理中可能会抛出异常。

getTextWithImgFilter

public java.lang.String getTextWithImgFilter(java.lang.String _sImgSrcPre,
                                             boolean _bRemoveExtraAttribute)
                                      throws WCMException
模板文本图片过滤处理，用于模板正文的显示处理

处理过程：对模板正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src

可以用于：
[1]模板正文显示，使用 getTextWithImgFilter( "show-pic.jsp?File=", false );
[2]模板预览： 使用 getTextWithImgFilter( "show-pic.jsp?File=", true );
[3]模板解析： 使用 getTextWithImgFilter( getApdFilePubHttpPath(), true );

参数：
_sImgSrcPre - 用于构造图片src的前部分；如： show-pic.jsp?File=
_bRemoveExtraAttribute - 是否需要删除图片额外的属性（如：OLDSRC, OLDID，REALATED等）
返回：
过滤处理后的Html文本
抛出：
WCMException - Html文本处理中可能会抛出异常

updateAppendixStatus

public void updateAppendixStatus()
                          throws WCMException
设置模板Text属性（Html文本格式）

参数：
_currUser - 当前操作用户
_text - Html文本内容
抛出：
WCMException - 处理模板图片失败时可能抛出异常

isHaveRelation

public boolean isHaveRelation(java.sql.Connection _oConn,
                              int _nAppendixId)
                       throws java.lang.Exception
判断模板与附件是否关联

参数：
_nAppendixId - 附件ID
返回：
抛出：
WCMException
java.lang.Exception

findById

public static final Template findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Template createNewInstance()
                                        throws WCMException
产生当前对象[Template]的实例

返回：
当前对象的实例[Template]
抛出：
WCMException

findByKey

public static final Template findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

getInfo

public java.lang.String getInfo()
Returns the template information.

返回：
the template information.

getTemplateParameters

public TemplateParameterList getTemplateParameters()
返回模板中所有形式参数的列表

返回：
模板中所有形式参数的列表

getTemplateParameters

public TemplateParameterList getTemplateParameters(boolean zRecursion)
返回模板中所有形式参数的列表

返回：
模板中所有形式参数的列表

setTemplateParameters

public void setTemplateParameters(TemplateParameterList list)
设置模板中的形式参数的列表 该方法仅供类型'TemplateParseMgr'调用，本来模板中的形式参数列表应该在模板类内部完成， 但是因为还涉及到参数实际值的清除，以及模板修改后形式参数列表的替换等问题，所以将形式 参数列表的构造移动到类型'TemplateParseMgr'中。

参数：
list - 模板中的形式参数的列表

isAccessibleFrom

public boolean isAccessibleFrom(IPublishFolder _folder)
判断从指定目录是否可以访问当前模板

参数：
_folder - 指定的目录
返回：
如果可以访问，则返回true，否则返回false

getNestedTemplate

public Template getNestedTemplate(IPublishElement element,
                                  java.lang.String sIdentity)

makeNestedIndentiy

public java.lang.String makeNestedIndentiy(java.lang.String nestedName)

iterateNestedIdentity

public java.util.Iterator iterateNestedIdentity()

getCharSet

public java.lang.String getCharSet()
                            throws WCMException
获取模板的charset设置,如果模板本身没有设置,则返回从所属Folder所设置的发布语言.
如果该属性没有获取,则默认返回UTF-8.

返回：
抛出：
WCMException

setCharSet

public boolean setCharSet(java.lang.String charset)
                   throws WCMException
设置模板的字符集属性,应该模板内容中的charset一致.

参数：
charset - 指定有效的charset
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateArgument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TemplateArgument

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.template.TemplateArgument
所有已实现的接口：
java.lang.Cloneable
public class TemplateArgument
extends CMSObj

模板中的形式参数的实际值

作者：
Martin (付成睿)

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
TemplateArgument()
缺省构造方法
方法摘要
static TemplateArgument createNewInstance()
产生当前对象[TemplateArgument]的实例
static TemplateArgument findById(int _nId)
提取指定ID的对象
static TemplateArgument findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象
static TemplateArgument findOf(java.lang.String _sArgName, java.lang.String _sPrexName)
 java.lang.String getArgumentName()
提取属性：ArgumentName
 java.lang.String getArgumentValue()
提取属性：ArgumentValue
 java.lang.String getCacheKey()
返回用于在缓存标识当前对象的key，因为和BaseObj.getKey()的缺省返回类型不同,为了避免不必要的错误， 没有覆盖BaseObj.getKey()方法，而是使用了新的方法名称。
 java.lang.String getDbTableName()
获得数据库中存储该对象的数据表名称。
 IPublishElement getEmployer()
get the employer instance
 int getEmployerId()
提取属性：EmployerId
 int getEmployerType()
提取属性：EmployerType
 java.lang.String getIdFieldName()
获得Id字段名。
 java.lang.String getPrefixOfName()
提取属性：PrefixOfName
 Template getTemplate()
get the Template instance
 int getTemplateId()
提取属性：TemplateId
 int getWCMType()
取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
 boolean isValid()
检测对象属性是否有效 注意：子类必须重载！！
static java.lang.String makeCacheKey(java.lang.String sPrefix, java.lang.String sName)
使用指定的前缀和名称构造在缓存中用于标识对象的KEY
 boolean setArgumentName(java.lang.String _name)
设置属性：ArgumentName
 boolean setArgumentValue(boolean _value)
设置属性：ArgumentValue
 boolean setArgumentValue(int _value)
设置属性：ArgumentValue
 boolean setArgumentValue(java.lang.String _value)
设置属性：ArgumentValue
 boolean setEmployer(int _nType, int _nId)
set the employer
 boolean setEmployer(IPublishElement _employer)
set the employer
 boolean setPrefixOfName(java.lang.String _value)
设置属性：PrefixOfName
 boolean setTemplate(Template _template)
set the template
 boolean setTemplateId(int _nTemplateId)
设置属性：TemplateId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

TemplateArgument

public TemplateArgument()
缺省构造方法

方法详细信息

findById

public static final TemplateArgument findById(int _nId)
                                       throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final TemplateArgument createNewInstance()
                                                throws WCMException
产生当前对象[TemplateArgument]的实例

返回：
当前对象的实例[TemplateArgument]
抛出：
WCMException

makeCacheKey

public static final java.lang.String makeCacheKey(java.lang.String sPrefix,
                                                  java.lang.String sName)
使用指定的前缀和名称构造在缓存中用于标识对象的KEY

findByKey

public static final TemplateArgument findByKey(java.lang.Object _oKey)
                                        throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

getCacheKey

public java.lang.String getCacheKey()
返回用于在缓存标识当前对象的key，因为和BaseObj.getKey()的缺省返回类型不同,为了避免不必要的错误， 没有覆盖BaseObj.getKey()方法，而是使用了新的方法名称。

返回：
用于在缓存标识当前对象的key

getEmployerType

public int getEmployerType()
提取属性：EmployerType

返回：
EmployerType

getEmployerId

public int getEmployerId()
提取属性：EmployerId

返回：
EmployerId

getEmployer

public IPublishElement getEmployer()
                            throws java.lang.Exception
get the employer instance

返回：
Returns the employer instance.
抛出：
java.lang.Exception

setEmployer

public boolean setEmployer(int _nType,
                           int _nId)
                    throws WCMException
set the employer

参数：
_nType - type of the employer
_nId - id of the employer
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setEmployer

public boolean setEmployer(IPublishElement _employer)
                    throws WCMException
set the employer

参数：
_employer - the employer
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTemplateId

public int getTemplateId()
提取属性：TemplateId

返回：
TemplateId

setTemplateId

public boolean setTemplateId(int _nTemplateId)
                      throws WCMException
设置属性：TemplateId

参数：
_nTemplateId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTemplate

public Template getTemplate()
                     throws WCMException
get the Template instance

返回：
抛出：
WCMException

setTemplate

public boolean setTemplate(Template _template)
                    throws WCMException
set the template

参数：
_template - the template
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getArgumentName

public java.lang.String getArgumentName()
提取属性：ArgumentName

返回：
ArgumentName

setArgumentName

public boolean setArgumentName(java.lang.String _name)
                        throws WCMException
设置属性：ArgumentName

参数：
_name - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getArgumentValue

public java.lang.String getArgumentValue()
提取属性：ArgumentValue

返回：
ArgumentValue

setArgumentValue

public boolean setArgumentValue(java.lang.String _value)
                         throws WCMException
设置属性：ArgumentValue

参数：
_value - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setArgumentValue

public boolean setArgumentValue(int _value)
                         throws WCMException
设置属性：ArgumentValue

参数：
_value - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setArgumentValue

public boolean setArgumentValue(boolean _value)
                         throws WCMException
设置属性：ArgumentValue

参数：
_value - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPrefixOfName

public java.lang.String getPrefixOfName()
提取属性：PrefixOfName

返回：
PrefixOfName

setPrefixOfName

public boolean setPrefixOfName(java.lang.String _value)
                        throws WCMException
设置属性：PrefixOfName

参数：
_value - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

findOf

public static TemplateArgument findOf(java.lang.String _sArgName,
                                      java.lang.String _sPrexName)
                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateArguments

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TemplateArguments

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.template.TemplateArguments

public class TemplateArguments
extends CMSBaseObjs

TemplateArgument对象的集合

作者：
Martin (付成睿)

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
TemplateArguments(User _currUser)
TemplateArguments(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static TemplateArguments | createNewInstance(User _currUser) TemplateArguments的对象实例
static TemplateArguments | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TemplateArguments | findOf(int _nType, int _nId) 提取指定ID序列的对象集合
static TemplateArguments | findOf(IPublishElement _employer) 提取指定ID序列的对象集合
TemplateArgument | getArgument(java.lang.String _sName, java.lang.String _PrexName)
java.lang.String | getArgumentValue(java.lang.String _sName, java.lang.String _PrexName)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static TemplateArguments | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateEmploys]
java.util.HashMap | toHashMapForCache() 将列表转化为“参数key/参数值”的HashMap对象
java.util.HashMap | toHashMapForCheck() 将列表转化为“参数key/参数对象(TemplateArgument)”的HashMap对象， 用于在用户界面中检查相应的参数是否进行了设置。
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateArguments

public TemplateArguments(User _currUser)
参数：
_currUser -

TemplateArguments

public TemplateArguments(User _currUser,
                         int _initCapacity,
                         int _incCapacity)
参数：
_currUser -
_initCapacity -
_incCapacity -
方法详细信息

openWCMObjs

public static final TemplateArguments openWCMObjs(User _currUser,
                                                  WCMFilter _filter)
                                           throws WCMException
通过指定一个Filter获取当前集合[TemplateEmploys]

参数：
_filter - 指定的Filter
返回：
当前集合[TemplateEmploys]
抛出：
WCMException

createNewInstance

public static TemplateArguments createNewInstance(User _currUser)
TemplateArguments的对象实例

参数：
_currUser - 当前操作用户
返回：
TemplateArguments的对象实例

findByIds

public static final TemplateArguments findByIds(User _currUser,
                                                java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（TemplateEmploys）
抛出：
WCMException - 若提取对象失败，会抛出异常。

findOf

public static final TemplateArguments findOf(IPublishElement _employer)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（TemplateEmploys）
抛出：
WCMException - 若提取对象失败，会抛出异常。

findOf

public static final TemplateArguments findOf(int _nType,
                                             int _nId)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（TemplateEmploys）
抛出：
WCMException - 若提取对象失败，会抛出异常。

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

toHashMapForCache

public java.util.HashMap toHashMapForCache()
将列表转化为“参数key/参数值”的HashMap对象

toHashMapForCheck

public java.util.HashMap toHashMapForCheck()
将列表转化为“参数key/参数对象(TemplateArgument)”的HashMap对象， 用于在用户界面中检查相应的参数是否进行了设置。

getArgument

public TemplateArgument getArgument(java.lang.String _sName,
                                    java.lang.String _PrexName)

getArgumentValue

public java.lang.String getArgumentValue(java.lang.String _sName,
                                         java.lang.String _PrexName)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmploy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TemplateEmploy

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.template.TemplateEmploy
所有已实现的接口：
java.lang.Cloneable
public class TemplateEmploy
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
TemplateEmploy()
构造函数：保留默认接口
方法摘要
static TemplateEmploy | createNewInstance() 产生当前对象[TemplateEmploy]的实例
static TemplateEmploy | findById(int _nId) 提取指定ID的对象
static TemplateEmploy | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
IPublishElement | getEmployer() get the employer instance
int | getEmployerId() 提取属性：EmployerId
int | getEmployerType() 提取属性：EmployerType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
Template | getTemplate()
int | getTemplateId() 提取属性：TemplateId
int | getTemplateType() 提取属性：TemplateType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isDefault() 提取属性:IsDefault
boolean | isValid() 检验对象数据有效性
boolean | setDefault(boolean _isDefault) 设置属性:IsDefault
boolean | setEmployer(int _nType, int _nId) set the employer
boolean | setEmployer(IPublishElement _employer) set the employer
boolean | setTemplate(int _nTemplateType, int _nTemplateId) 设置属性：TemplateId
boolean | setTemplate(Template _template) set the template used
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

TemplateEmploy

public TemplateEmploy()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getEmployerType

public int getEmployerType()
提取属性：EmployerType

返回：
EmployerType

getEmployerId

public int getEmployerId()
提取属性：EmployerId

返回：
EmployerId

getEmployer

public IPublishElement getEmployer()
                            throws java.lang.Exception
get the employer instance

返回：
Returns the employer instance.
抛出：
java.lang.Exception - if failed to fetch the employer instance.

setEmployer

public boolean setEmployer(int _nType,
                           int _nId)
                    throws WCMException
set the employer

参数：
_nType - type of the employer
_nId - id of the employer
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setEmployer

public boolean setEmployer(IPublishElement _employer)
                    throws WCMException
set the employer

参数：
_employer - the employer
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTemplateId

public int getTemplateId()
提取属性：TemplateId

返回：
TemplateId

setTemplate

public boolean setTemplate(int _nTemplateType,
                           int _nTemplateId)
                    throws WCMException
设置属性：TemplateId

参数：
_nTemplateId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setTemplate

public boolean setTemplate(Template _template)
                    throws WCMException
set the template used

参数：
_template - the template
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTemplateType

public int getTemplateType()
提取属性：TemplateType

返回：
TemplateType

isDefault

public boolean isDefault()
提取属性:IsDefault

返回：
true,if the employ is default

setDefault

public boolean setDefault(boolean _isDefault)
                   throws WCMException
设置属性:IsDefault

参数：
_isDefault -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final TemplateEmploy findById(int _nId)
                                     throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final TemplateEmploy createNewInstance()
                                              throws WCMException
产生当前对象[TemplateEmploy]的实例

返回：
当前对象的实例[TemplateEmploy]
抛出：
WCMException

findByKey

public static final TemplateEmploy findByKey(java.lang.Object _oKey)
                                      throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getTemplate

public Template getTemplate()
                     throws WCMException
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmploys

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TemplateEmploys

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.template.TemplateEmploys

public class TemplateEmploys
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
TemplateEmploys(User _currUser)
构造函数
TemplateEmploys(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static TemplateEmploys | createNewInstance(User _currUser) 产生当前集合对象[TemplateEmploys]的实例
static TemplateEmploys | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static TemplateEmploys | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateEmploys]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateEmploys

public TemplateEmploys(User _currUser)
构造函数

另请参见：
TemplateEmploys( User _currUser, int _initCapacity, int _incCapacity );

TemplateEmploys

public TemplateEmploys(User _currUser,
                       int _initCapacity,
                       int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final TemplateEmploys findByIds(User _currUser,
                                              java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（TemplateEmploys）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final TemplateEmploys openWCMObjs(User _currUser,
                                                WCMFilter _filter)
                                         throws WCMException
通过指定一个Filter获取当前集合[TemplateEmploys]

参数：
_filter - 指定的Filter
返回：
当前集合[TemplateEmploys]
抛出：
WCMException

createNewInstance

public static TemplateEmploys createNewInstance(User _currUser)
产生当前集合对象[TemplateEmploys]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateQuote

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TemplateQuote

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.persistent.template.TemplateQuote
所有已实现的接口：
java.lang.Cloneable
public class TemplateQuote
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
TemplateQuote()
构造函数：保留默认接口
方法摘要
static TemplateQuote | createNewInstance() 产生当前对象[TemplateQuote]的实例
static TemplateQuote | findById(int _nId) 提取指定ID的对象
static TemplateQuote | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getFamilyIndex() 提取属性：ChildIndex
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getQuotedFolderId() 提取属性：QuotedFolderId
int | getQuotedFolderType() 提取属性：QuotedFolderType
int | getQuoteType() 提取属性：QuoteType
int | getTemplateId() 提取属性：TemplateId
int | getTemplateType() 提取属性：TemplateType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setQuotedFolder(int _nType, int _nId) Sets the quoted folder with a specified folder.
boolean | setQuotedFolder(int _nType, int _nId, int _nFamilyIndex) Sets the quoted folder property.
boolean | setQuotedFolderWithChild(int _nChildIndex) Sets the quoted folder with the child of current folder who employs this template.
boolean | setQuotedFolderWithParent() Set the quoted folder with the parent of current folder who employs this template.
boolean | setQuoteType(int _nQuoteType) 设置属性：QuoteType
boolean | setTemplate(int _nId, int _nTemplateType) 设置属性：TemplateId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

TemplateQuote

public TemplateQuote()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getTemplateId

public int getTemplateId()
提取属性：TemplateId

返回：
TemplateId

getTemplateType

public int getTemplateType()
提取属性：TemplateType

返回：
TemplateType

setTemplate

public boolean setTemplate(int _nId,
                           int _nTemplateType)
                    throws WCMException
设置属性：TemplateId

参数：
_nId - id of the template
_nTemplateType - type of the template which is defined in PublishConstants like TEMPLATE_TYPE_OUTLINE, TEMPLATE_TYPE_DETAIL etc.
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getQuotedFolderType

public int getQuotedFolderType()
提取属性：QuotedFolderType

返回：
QuotedFolderType

getQuotedFolderId

public int getQuotedFolderId()
提取属性：QuotedFolderId

返回：
QuotedFolderId

setQuotedFolder

public boolean setQuotedFolder(int _nType,
                               int _nId)
                        throws WCMException
Sets the quoted folder with a specified folder.

参数：
_nType - type of the quoted folder
_nId - id of the quoted folder
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setQuotedFolderWithParent

public boolean setQuotedFolderWithParent()
                                  throws WCMException
Set the quoted folder with the parent of current folder who employs this template.

返回：
Returns true if the quoted folder is set successfully.
抛出：
WCMException - if failed.

setQuotedFolderWithChild

public boolean setQuotedFolderWithChild(int _nChildIndex)
                                 throws WCMException
Sets the quoted folder with the child of current folder who employs this template.

参数：
_nChildIndex - index of child
返回：
Returns true if the quoted folder is set successfully.
抛出：
WCMException - if failed.

setQuotedFolder

public boolean setQuotedFolder(int _nType,
                               int _nId,
                               int _nFamilyIndex)
                        throws WCMException
Sets the quoted folder property.

参数：
_nType - type of the property.
_nId - id of the property
_nFamilyIndex - index of quoted folder in its family
返回：
Returns true if the quoted folder is set successfully.
抛出：
WCMException - if failed.

getFamilyIndex

public int getFamilyIndex()
提取属性：ChildIndex

返回：
ChildIndex

getQuoteType

public int getQuoteType()
提取属性：QuoteType

返回：
QuoteType

setQuoteType

public boolean setQuoteType(int _nQuoteType)
                     throws WCMException
设置属性：QuoteType

参数：
_nQuoteType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final TemplateQuote findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final TemplateQuote createNewInstance()
                                             throws WCMException
产生当前对象[TemplateQuote]的实例

返回：
当前对象的实例[TemplateQuote]
抛出：
WCMException

findByKey

public static final TemplateQuote findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateQuotes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TemplateQuotes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.template.TemplateQuotes

public class TemplateQuotes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
TemplateQuotes(User _currUser)
构造函数
TemplateQuotes(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static TemplateQuotes | createNewInstance(User _currUser) 产生当前集合对象[TemplateQuotes]的实例
static TemplateQuotes | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static TemplateQuotes | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateQuotes]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateQuotes

public TemplateQuotes(User _currUser)
构造函数

另请参见：
TemplateQuotes( User _currUser, int _initCapacity, int _incCapacity );

TemplateQuotes

public TemplateQuotes(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final TemplateQuotes findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（TemplateQuotes）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final TemplateQuotes openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[TemplateQuotes]

参数：
_filter - 指定的Filter
返回：
当前集合[TemplateQuotes]
抛出：
WCMException

createNewInstance

public static TemplateQuotes createNewInstance(User _currUser)
产生当前集合对象[TemplateQuotes]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Templates

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 Templates

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.persistent.template.Templates

public class Templates
extends CMSBaseObjs

字段摘要
static int | DEAL_MODE_CHGNAME
static int | DEAL_MODE_IGNORE
static int | DEAL_MODE_QUIT
static int | DEAL_MODE_UPDATE
static int | DETAIL_TEMPLATE
static int | INPUT_TEMPLATE
static int | OUTLINE_TEMPLATE
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Templates(User _currUser)
Templates(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Templates | createNewInstance(User _currUser) 产生当前集合对象[Templates]的实例
static Templates | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Template | findByName(java.lang.String _sTempName) 根据模板名称从模板集合中查找模板
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
Template | getTemplateByName(java.lang.String _name) 根据模板名称查找模板
BaseObjs | newInstance() 生成新的集合对象实例
static Templates | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Templates]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

INPUT_TEMPLATE

public static final int INPUT_TEMPLATE
另请参见：
常量字段值

DETAIL_TEMPLATE

public static final int DETAIL_TEMPLATE
另请参见：
常量字段值

OUTLINE_TEMPLATE

public static final int OUTLINE_TEMPLATE
另请参见：
常量字段值

DEAL_MODE_UPDATE

public static final int DEAL_MODE_UPDATE
另请参见：
常量字段值

DEAL_MODE_IGNORE

public static final int DEAL_MODE_IGNORE
另请参见：
常量字段值

DEAL_MODE_CHGNAME

public static final int DEAL_MODE_CHGNAME
另请参见：
常量字段值

DEAL_MODE_QUIT

public static final int DEAL_MODE_QUIT
另请参见：
常量字段值
构造方法详细信息

Templates

public Templates(User _currUser)

Templates

public Templates(User _currUser,
                 int initialCapacity,
                 int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByName

public Template findByName(java.lang.String _sTempName)
                    throws WCMException
根据模板名称从模板集合中查找模板

参数：
_sTempName - 模板名称
返回：
如果找到则返回模板对象，否则返回null
抛出：
WCMException - 如果发生错误，则抛出WCMException异常

getTemplateByName

public Template getTemplateByName(java.lang.String _name)
根据模板名称查找模板

参数：
_name - 模板名称
返回：
如果找到则返回模板对象，否则返回null

findByIds

public static final Templates findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Templates openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[Templates]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[Templates]
抛出：
WCMException

createNewInstance

public static Templates createNewInstance(User _currUser)
                                   throws WCMException
产生当前集合对象[Templates]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateXmlConverter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.persistent.template
类 TemplateXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.common.publish.persistent.template.TemplateXmlConverter

public class TemplateXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
将模板导入、导出成为WCM的XML对象
目前模板的导入只支持随着站点的导入一起进行，不支持单独的模板导入
目前提供的独立的模板导入、导出是通过独立的处理逻辑进行的，和XML的导入、导出没有关系
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateXmlConverter()
constructor: default
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateXmlConverter

public TemplateXmlConverter()
constructor: default

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.persistent.template.TagBean 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TagBean
的使用

使用 TagBean 的软件包
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.domain.tagparser 中 TagBean 的使用

参数类型为 TagBean 的 com.trs.components.common.publish.domain.tagparser 中的方法
static void | TagParserFactory.notifyOnTagBeanAdded(TagBean _newBean) Updates cache when a new tag bean is created.
static void | TagParserFactory.notifyOnTagBeanDeleted(TagBean _bean) Removes cache when a tag bean is deleted.
static void | TagParserFactory.notifyOnTagBeanModified(TagBean _bean) Updates cache when a tag bean is modified.

com.trs.components.common.publish.persistent.template 中 TagBean 的使用

返回 TagBean 的 com.trs.components.common.publish.persistent.template 中的方法
static TagBean | TagBean.createNewInstance() 产生当前对象[TagBean]的实例
static TagBean | TagBean.findById(int _nId) 提取指定ID的对象
static TagBean | TagBean.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TagBeans 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TagBeans
的使用

使用 TagBeans 的软件包
com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.persistent.template 中 TagBeans 的使用

返回 TagBeans 的 com.trs.components.common.publish.persistent.template 中的方法
 TagBeans TagBeans.copy()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TempApdRel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TempApdRel
的使用

使用 TempApdRel 的软件包
com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.persistent.template 中 TempApdRel 的使用

返回 TempApdRel 的 com.trs.components.common.publish.persistent.template 中的方法
static TempApdRel | TempApdRel.createNewInstance() 产生当前对象[TempApdRel]的实例
static TempApdRel | TempApdRel.findById(int _nId) 提取指定ID的对象
static TempApdRel | TempApdRel.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TempApdRels 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TempApdRels
的使用

使用 TempApdRels 的软件包
com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.persistent.template 中 TempApdRels 的使用

返回 TempApdRels 的 com.trs.components.common.publish.persistent.template 中的方法
static TempApdRels | TempApdRels.createNewInstance(User _currUser) 产生一个当前集合对象[TempApdRels]的实例
static TempApdRels | TempApdRels.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
TempApdRels | Template.getApdRels(WCMFilter _filter) get the template appendix relations
static TempApdRels | TempApdRels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TempApdRels]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TempAppendix 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TempAppendix
的使用

使用 TempAppendix 的软件包
com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.persistent.template 中 TempAppendix 的使用

返回 TempAppendix 的 com.trs.components.common.publish.persistent.template 中的方法
TempAppendix | Template.addAppendix(User _currUser, java.lang.String _sFile, boolean _bAddRelation) 添加一个模板附件
static TempAppendix | TempAppendix.createNewInstance() 产生当前对象[TempAppendix]的实例
static TempAppendix | TempAppendix.findById(int _nId) 提取指定ID的对象
static TempAppendix | TempAppendix.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

参数类型为 TempAppendix 的 com.trs.components.common.publish.persistent.template 中的方法
 boolean Template.deleteAppendix(TempAppendix _appendix)
删除一个模板附件，仅仅删除附件关联

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TempAppendixes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TempAppendixes
的使用

使用 TempAppendixes 的软件包
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.domain.template 中 TempAppendixes 的使用

返回 TempAppendixes 的 com.trs.components.common.publish.domain.template 中的方法
 TempAppendixes TemplateMgr.getTempAppendixesInRoot(int _nRootType, int _nRootId, WCMFilter _filter)
get the template appendixes in the specified root

com.trs.components.common.publish.persistent.template 中 TempAppendixes 的使用

返回 TempAppendixes 的 com.trs.components.common.publish.persistent.template 中的方法
static TempAppendixes | TempAppendixes.createNewInstance(User _currUser) 产生一个当前集合对象[TempAppendixes]的实例
static TempAppendixes | TempAppendixes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
TempAppendixes | Template.getAppendixes(User _currUser) 取模板的附件集合
TempAppendixes | Template.getAppendixes(User _currUser, int[] arrFlags) 取模板的附件集合
static TempAppendixes | TempAppendixes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TempAppendixes]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TempAppendixXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TempAppendixXmlConverter
的使用

没有 com.trs.components.common.publish.persistent.template.TempAppendixXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.Template 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.Template
的使用

使用 Template 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.domain
com.trs.components.common.publish.domain.publisher
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.element
com.trs.components.common.publish.persistent.template
com.trs.components.common.publish.widget
com.trs.components.infoview.helper
com.trs.components.wcm.epress
com.trs.components.wcm.publish
com.trs.components.wcm.publish.tagparser
com.trs.service
com.trs.service.impl
com.trs.template.domain
com.trs.wcm.photo
com.trs.wcm.photo.impl

com.trs.ajaxservice 中 Template 的使用

参数类型为 Template 的 com.trs.ajaxservice 中的方法
static int | TemplateEmployMgrHelper.clearEmploymentOfEmployer(IPublishElement _employer, Template _template)
static RightValue | TemplateAuthHelper.makeTemplateRightValue(MethodContext _context, User _loginUser, Template _template, IPublishFolder _host)
static void | TemplateEmployMgrHelper.setOtherOutlinesOfChannels(MethodContext _context, Template _template)
static void | TemplateEmployMgrHelper.setOtherOutlinesOfSite(IPublishElement siteFolder, Template template)

com.trs.components.common.publish.domain 中 Template 的使用

参数类型为 Template 的 com.trs.components.common.publish.domain 中的方法
java.lang.String | PublishServer.previewContent(IPublishContent _content, java.lang.String[] _warningsHolder, Template _template)
java.lang.String[] | PublishServer.previewFolder(IPublishFolder _folder, java.lang.String[] _warningsHolder, Template _template)

com.trs.components.common.publish.domain.publisher 中 Template 的使用

返回 Template 的 com.trs.components.common.publish.domain.publisher 中的方法
 Template PublishPageContext.getTemplate()
获取相关模板

参数类型为 Template 的 com.trs.components.common.publish.domain.publisher 中的方法
static java.lang.String[] | PageGenerator.generateContent(PublishPageContext _pageContext, Template _template)
static java.lang.String | PageGenerator.generatePage(PublishPageContext _pageContext, Template _template) Generates page with the specified template in the specified page context.
static java.lang.String | PageGenerator.generatePage(PublishPageContext _pageContext, Template _template, boolean _bDiffContent)
void | PublishPageContext.setTemplate(Template template) 设置相关模板

com.trs.components.common.publish.domain.tagparser 中 Template 的使用

返回 Template 的 com.trs.components.common.publish.domain.tagparser 中的方法
static Template | TagParseHelper.findNestedTemplate(PublishTagContext _context) Returns the template defined in the specified nested template tag item.
static Template | TagParseHelper.findNestedTemplate(java.lang.String sTempName, IPublishFolder _root) Returns the template defined in the specified nested template tag item.
static Template | TagParseHelper.findNestedTemplate(TagItem _tagItem, IPublishFolder _root) 已过时。 Returns the template defined in the specified nested template tag item.
Template | TemplateParameter.getTemplate() 返回形式参数所在的模板

com.trs.components.common.publish.domain.template 中 Template 的使用

返回 Template 的 com.trs.components.common.publish.domain.template 中的方法
Template | TemplateEmployDetail.getDefaultDetailTemplate()
Template | TemplateEmployDetail.getDefaultInfoviewPrintTemplate()
Template | TemplateEmployDetail.getDefaultOutlineTemplate()
Template | ITemplateEmployCacheMgr.getDefaultOutlineTemplate(IPublishFolder _folder)
Template | TemplateEmployCacheMgrImpl.getDefaultOutlineTemplate(IPublishFolder _folder)
Template | TemplateEmployMgr.getDefaultOutlineTemplate(IPublishFolder _folder) Returns the default outline template of the specified folder.
Template | ITemplateEmployCacheMgr.getDetailTemplate(int _nPublishElementType, int _nPublishElementId)
Template | TemplateEmployCacheMgrImpl.getDetailTemplate(int _nPublishElementType, int _nPublishElementId)
Template | TemplateEmployMgr.getDetailTemplate(int _nEmployerType, int _nEmployerId)
Template | ITemplateEmployCacheMgr.getDetailTemplate(IPublishElement _employer)
Template | TemplateEmployCacheMgrImpl.getDetailTemplate(IPublishElement _employer)
Template | TemplateEmployMgr.getDetailTemplate(IPublishElement _employer) Returns the detail template of the specified publish element.
Template | TemplateEmployMgr.getDetailTemplate(IPublishElement _employer, int _nTemplateType)
Template | TemplateCacheMgr.lookupByName(IPublishFolder _root, java.lang.String _sName) find the template by name
Template | TemplateMgr.save(Template _currTemplate, java.util.HashMap _tempapds, boolean _bDowithAppendix, int _nPicMode, boolean _zParseIfNecessary) 保存模板
Template | TemplateMgr.save(Template _currTemplate, java.lang.String _sTempApdPath, boolean _bDowithAppendix, int _nPicMode) 保存模板

参数类型为 Template 的 com.trs.components.common.publish.domain.template 中的方法
TagDocument | TemplateParseMgr.checkLexical(Template _template, Report _report) 对模板的正文进行文法检查，如果没有文法错误，则返回模板置标树，如果存在文法错误， 则通过传入参数 _report 报告错误信息。
Report | TemplateParseMgr.checkTemplate(Template _template) 检查模板语法正确性
Report | TemplateParseMgr.checkTemplate(Template _template, boolean bCanEdit)
int | TemplateEmployMgr.clearEmploysOfTemplate(Template _template) clear all the employ records of the specified template
int | TemplateNestMgr.clearNestRecordsOf(Template _template) clear the nest records of the specified template
Reports | TemplateMgr.copyVisualTempToChnls(Channels _toChannels, Template _srcTemplate) 在指定栏目下，类似创建可视化模板
boolean | TemplateMgr.delete(Template _templateToDelete) 删除指定的模板
java.lang.String | TemplateExporter.exportToXMLFile(Template _currTemplate) 将WCM的模板导出成为WCM XML标准格式的文件
java.util.List | TemplateEmployMgr.getEmployers(Template _template, int _nEmployerType) Returns the employers list of the specified type.
java.util.List | TemplateEmployMgr.getEmployers(Template _template, WCMFilter _filter) get the employers who use the specified template.
Templates | TemplateNestMgr.getNestedTemplates(Template _template) get the nested templates
TemplateEmploys | TemplateEmployMgr.getTemplateEmployers(Template _template, WCMFilter _filter)
Templates | TemplateNestMgr.getTemplatesNested(Template _template) 返回获取嵌套了指定模板的所有模板
java.lang.String | TemplateMgr.getTextWithImgFilter(Template _template, java.lang.String sText, boolean _bRemoveExtraAttribute)
void | TemplateParseMgr.notifyTemplateAdded(Template _template) Notifys template parse manager when a template is added.
void | TemplateParseMgr.notifyTemplateDeleted(Template _template) Notifys template parse manager wehn a template is deleted.
void | TemplateParseMgr.notifyTemplateModified(Template _template) Notifys template parse manager when a template is modified.
TagDocument | TemplateParseMgr.parse(Template _template) parse the specified template
static java.util.ArrayList | TemplateParseHelper.parseCssAndCopySrcFileAsTempAppedix(java.lang.String _sCSSFilePath, java.lang.String _sDestDir, Template _template) ge add by gfc
java.lang.String | TemplateMgr.preview(Template _currTemplate) 预览指定的模板
java.lang.String | TemplateMgr.processTemplateAppendixes(Template _template, java.lang.String sTempText, int _nPicMode) 将指定的內容处理成模板的格式，如：将里面的图片资源进行处理
void | TemplateEmployDetail.putEmploy(int _nTemplateEmployId, int _nTemplateType, Template _template, boolean _bDefault)
Template | TemplateMgr.save(Template _currTemplate, java.util.HashMap _tempapds, boolean _bDowithAppendix, int _nPicMode, boolean _zParseIfNecessary) 保存模板
Template | TemplateMgr.save(Template _currTemplate, java.lang.String _sTempApdPath, boolean _bDowithAppendix, int _nPicMode) 保存模板
static void | TemplateParseAngel.scan(Template _template) Scans and parses a template.
void | TemplateParseMgr.uploadAppendixes(Template _template, boolean _bForceAll) Uploads the appendixes of the specified template.

参数类型为 Template 的 com.trs.components.common.publish.domain.template 中的构造方法
TemplateEmployDetail(int _nTemplateEmployId, int _nTemplateType, Template _template, boolean _bDefault)

com.trs.components.common.publish.persistent.element 中 Template 的使用

返回 Template 的 com.trs.components.common.publish.persistent.element 中的方法
Template | PublishFolderImplBase.getDetailTemplate()
Template | PublishContentImplBase.getDetailTemplate()
Template | IPublishFolder.getDetailTemplate() get the detail template of the current folder.
Template | PublishFolderWrapper.getDetailTemplate()
Template | IPublishContent.getDetailTemplate() Returns the detail template of this content.
Template | PublishContentWrapper.getDetailTemplate()

com.trs.components.common.publish.persistent.template 中 Template 的使用

返回 Template 的 com.trs.components.common.publish.persistent.template 中的方法
static Template | Template.createNewInstance() 产生当前对象[Template]的实例
static Template | Template.findById(int _nId) 提取指定ID的对象
static Template | Template.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Template | Templates.findByName(java.lang.String _sTempName) 根据模板名称从模板集合中查找模板
Template | Template.getNestedTemplate(IPublishElement element, java.lang.String sIdentity)
Template | TemplateEmploy.getTemplate()
Template | TemplateArgument.getTemplate() get the Template instance
Template | Templates.getTemplateByName(java.lang.String _name) 根据模板名称查找模板

参数类型为 Template 的 com.trs.components.common.publish.persistent.template 中的方法
boolean | TempAppendix.addRelation(Template _template) 增加模板和附件的关联
boolean | TempAppendix.deleteRelation(Template _template) 删除模板和附件的关联
boolean | TemplateEmploy.setTemplate(Template _template) set the template used
boolean | TemplateArgument.setTemplate(Template _template) set the template

com.trs.components.common.publish.widget 中 Template 的使用

返回 Template 的 com.trs.components.common.publish.widget 中的方法
Template | IWidgetServer.createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType) 根据母版内容，创建新的模板
Template | WidgetServer.createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType)

参数类型为 Template 的 com.trs.components.common.publish.widget 中的方法
void | IWidgetServer.insertStyleTag(Special special, Template template) 专题设置页面风格时所触发的逻辑，将专题所属的首页模板插入含当前页面风格标识的置标，发布时完成风格的切换
void | WidgetServer.insertStyleTag(Special special, Template template)
java.lang.String | IWidgetServer.parseToEditContent(IPublishElement _oPageElement, Template _oTemplateForEdit) 将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
java.lang.String | WidgetServer.parseToEditContent(IPublishElement _oPageElement, Template _oTemplateForEdit)
void | IWidgetServer.synchronizeWidgetInstances(Template template) 将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。
void | WidgetServer.synchronizeWidgetInstances(Template template)

com.trs.components.infoview.helper 中 Template 的使用

返回 Template 的 com.trs.components.infoview.helper 中的方法
static Template InfoViewTemplateHelper.getDetailTemplate(PublishPageContext _pageContext)

com.trs.components.wcm.epress 中 Template 的使用

返回 Template 的 com.trs.components.wcm.epress 中的方法
 Template EpressFolderWrapper.getDetailTemplate()

com.trs.components.wcm.publish 中 Template 的使用

返回 Template 的 com.trs.components.wcm.publish 中的方法
 Template WCMContentPublishConfig.getDetailTemplate()

com.trs.components.wcm.publish.tagparser 中 Template 的使用

参数类型为 Template 的 com.trs.components.wcm.publish.tagparser 中的构造方法
WCMTemplateChildIndexAnalyer(Template _template)

com.trs.service 中 Template 的使用

返回 Template 的 com.trs.service 中的方法
Template | ITemplateService.findByName(int _nSiteId, java.lang.String _sTempName) 根据指定的SiteId，找到指定名称的模板
Template | ITemplateService.getDetailTemplate(IPublishElement _publishElement) 获得指定频道的细览模板
Template | ITemplateService.save(Template _currTemplateToSave) 保存模板，包括新增和修改，此接口一般用于从源代码方式下保存模板
Template | ITemplateService.save(Template _currTemplateToSave, boolean _bDowithAppendix, int _nPicMode) 保存模板，包括新增和修改

参数类型为 Template 的 com.trs.service 中的方法
Report | ITemplateParseService.checkTemplate(Template _aTemplate) 解析模板语法
boolean | ITemplateService.delete(Template _currTemplateToDelete) 彻底删除模板
java.lang.String | ITemplateService.export(Template _currTemplate) 导出模板到固定的文件中
Templates | ITemplateService.getNestedTemplates(Template _currTemplate) 获取当前模板中使用到的嵌套模板
java.util.List | ITemplateService.getTemplateEmployers(Template _currTemplate) 获取使用到当前模板的所有对象集合
java.util.List | ITemplateService.getTemplateEmployers(Template _currTemplate, int _nEmployerType) 获取使用到当前模板的指定类型的对象集合
Templates | ITemplateService.getTemplatesNested(Template _currTemplate) 获取嵌套了当前模板的所有模板
java.lang.String | ITemplateService.preview(Template _currTemplate) 预览指定的模板
Template | ITemplateService.save(Template _currTemplateToSave) 保存模板，包括新增和修改，此接口一般用于从源代码方式下保存模板
Template | ITemplateService.save(Template _currTemplateToSave, boolean _bDowithAppendix, int _nPicMode) 保存模板，包括新增和修改

com.trs.service.impl 中 Template 的使用

返回 Template 的 com.trs.service.impl 中的方法
Template | TemplateService.findByName(int _nSiteId, java.lang.String _sTempName)
Template | TemplateService.getDetailTemplate(IPublishElement _publishElement)
Template | TemplateService.save(Template _currTemplateToSave)
Template | TemplateService.save(Template _currTemplateToSave, boolean _bDowithAppendix, int _nPicMode)

参数类型为 Template 的 com.trs.service.impl 中的方法
void | TemplateService.addNestedParameters(IPublishElement _element, Template template, TemplateParameterList list)
Report | TemplateParseService.checkTemplate(Template _aTemplate)
boolean | TemplateService.delete(Template _template)
java.lang.String | TemplateService.export(Template _currTemplate)
Templates | TemplateService.getNestedTemplates(Template _template)
java.util.List | TemplateService.getTemplateEmployers(Template _template)
java.util.List | TemplateService.getTemplateEmployers(Template _template, int _nEmployerType)
Templates | TemplateService.getTemplatesNested(Template _template)
java.lang.String | PublishService.preview(Document _document, Channel _channel, java.lang.String[] holder, Template _template)
java.lang.String | TemplateService.preview(Template _template)
Template | TemplateService.save(Template _currTemplateToSave)
Template | TemplateService.save(Template _currTemplateToSave, boolean _bDowithAppendix, int _nPicMode)

com.trs.template.domain 中 Template 的使用

参数类型为 Template 的 com.trs.template.domain 中的方法
 XTemplateExporter.HierarchyEntity XTemplateExporter.makeHierarchicalDir4Template(Template _oTemplate)

com.trs.wcm.photo 中 Template 的使用

返回 Template 的 com.trs.wcm.photo 中的方法
Template | IImageLibConfig.getDefaultDetailTemplate() 获取图片库分类默认的细览模板
Template | IImageLibConfig.getDefaultOutlineTemplate() 获取图片库分类默认的概览模板

com.trs.wcm.photo.impl 中 Template 的使用

返回 Template 的 com.trs.wcm.photo.impl 中的方法
Template | ImageLibConfigImpl.getDefaultDetailTemplate()
Template | ImageLibConfigImpl.getDefaultOutlineTemplate()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TemplateArgument 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TemplateArgument
的使用

使用 TemplateArgument 的软件包
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.template
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain.template 中 TemplateArgument 的使用

返回 TemplateArgument 的 com.trs.components.common.publish.domain.template 中的方法
 TemplateArgument TemplateArgumentMgr.save(TemplateArgument _aArgument)
保存指定的TemplateArgument对象

参数类型为 TemplateArgument 的 com.trs.components.common.publish.domain.template 中的方法
boolean | TemplateArgumentMgr.delete(TemplateArgument _aArgument) 删除指定的TemplateArgument对象
TemplateArgument | TemplateArgumentMgr.save(TemplateArgument _aArgument) 保存指定的TemplateArgument对象

com.trs.components.common.publish.persistent.template 中 TemplateArgument 的使用

返回 TemplateArgument 的 com.trs.components.common.publish.persistent.template 中的方法
static TemplateArgument | TemplateArgument.createNewInstance() 产生当前对象[TemplateArgument]的实例
static TemplateArgument | TemplateArgument.findById(int _nId) 提取指定ID的对象
static TemplateArgument | TemplateArgument.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static TemplateArgument | TemplateArgument.findOf(java.lang.String _sArgName, java.lang.String _sPrexName)
TemplateArgument | TemplateArguments.getArgument(java.lang.String _sName, java.lang.String _PrexName)

com.trs.service 中 TemplateArgument 的使用

返回 TemplateArgument 的 com.trs.service 中的方法
 TemplateArgument ITemplateService.saveTemplateArgument(TemplateArgument _argument)
保存指定的TemplateArgument对象

参数类型为 TemplateArgument 的 com.trs.service 中的方法
boolean | ITemplateService.deleteTemplateArgument(TemplateArgument _argument) 删除指定的TemplateArgument对象
TemplateArgument | ITemplateService.saveTemplateArgument(TemplateArgument _argument) 保存指定的TemplateArgument对象

com.trs.service.impl 中 TemplateArgument 的使用

返回 TemplateArgument 的 com.trs.service.impl 中的方法
 TemplateArgument TemplateService.saveTemplateArgument(TemplateArgument _argument)

参数类型为 TemplateArgument 的 com.trs.service.impl 中的方法
boolean | TemplateService.deleteTemplateArgument(TemplateArgument _argument)
TemplateArgument | TemplateService.saveTemplateArgument(TemplateArgument _argument)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TemplateArguments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TemplateArguments
的使用

使用 TemplateArguments 的软件包
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.template
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain.template 中 TemplateArguments 的使用

返回 TemplateArguments 的 com.trs.components.common.publish.domain.template 中的方法
 TemplateArguments TemplateArgumentMgr.getArguments(IPublishElement _element)
返回指定发布对象上的全部有效模板参数列表

com.trs.components.common.publish.persistent.template 中 TemplateArguments 的使用

返回 TemplateArguments 的 com.trs.components.common.publish.persistent.template 中的方法
static TemplateArguments | TemplateArguments.createNewInstance(User _currUser) TemplateArguments的对象实例
static TemplateArguments | TemplateArguments.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TemplateArguments | TemplateArguments.findOf(int _nType, int _nId) 提取指定ID序列的对象集合
static TemplateArguments | TemplateArguments.findOf(IPublishElement _employer) 提取指定ID序列的对象集合
static TemplateArguments | TemplateArguments.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateEmploys]

com.trs.service 中 TemplateArguments 的使用

返回 TemplateArguments 的 com.trs.service 中的方法
 TemplateArguments ITemplateService.getTemplateArguments(IPublishElement _element)
返回指定发布对象上的全部有效模板参数列表

参数类型为 TemplateArguments 的 com.trs.service 中的方法
 void ITemplateService.deleteTemplateArguments(TemplateArguments _arguments)
删除指定的TemplateArguments对象集合

com.trs.service.impl 中 TemplateArguments 的使用

返回 TemplateArguments 的 com.trs.service.impl 中的方法
 TemplateArguments TemplateService.getTemplateArguments(IPublishElement _element)

参数类型为 TemplateArguments 的 com.trs.service.impl 中的方法
 void TemplateService.deleteTemplateArguments(TemplateArguments _arguments)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TemplateEmploy 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TemplateEmploy
的使用

使用 TemplateEmploy 的软件包
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.domain.template 中 TemplateEmploy 的使用

参数类型为 TemplateEmploy 的 com.trs.components.common.publish.domain.template 中的方法
void | TemplateEmployDetail.putEmploy(TemplateEmploy _employ)
void | TemplateEmployDetail.removeEmploy(TemplateEmploy _employ)

参数类型为 TemplateEmploy 的 com.trs.components.common.publish.domain.template 中的构造方法
TemplateEmployDetail(TemplateEmploy _employ)

com.trs.components.common.publish.persistent.template 中 TemplateEmploy 的使用

返回 TemplateEmploy 的 com.trs.components.common.publish.persistent.template 中的方法
static TemplateEmploy | TemplateEmploy.createNewInstance() 产生当前对象[TemplateEmploy]的实例
static TemplateEmploy | TemplateEmploy.findById(int _nId) 提取指定ID的对象
static TemplateEmploy | TemplateEmploy.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TemplateEmploys 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TemplateEmploys
的使用

使用 TemplateEmploys 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.template

com.trs.ajaxservice 中 TemplateEmploys 的使用

返回 TemplateEmploys 的 com.trs.ajaxservice 中的方法
 TemplateEmploys TemplateServiceProvider.queryEmployers(MethodContext _methodContext)
获取使用指定模板的对象

com.trs.components.common.publish.domain.template 中 TemplateEmploys 的使用

返回 TemplateEmploys 的 com.trs.components.common.publish.domain.template 中的方法
TemplateEmploys | TemplateEmployMgr.getEmploysOf(IPublishElement _employer)
TemplateEmploys | TemplateEmployMgr.getEmploysOf(IPublishElement _employer, int _nTemplateType) Returns the employ records of the specified employer, which may be a folder or a content.
TemplateEmploys | TemplateEmployMgr.getEmploysOfEmployer(int _nEmployerType, int _nEmployerId)
TemplateEmploys | TemplateEmployMgr.getEmploysOfEmployer(int _nEmployerType, int _nEmployerId, int _nTemplateType) Returns the employ records of the specified employer, which may be a folder or a content.
TemplateEmploys | TemplateEmployMgr.getTemplateEmployers(Template _template, WCMFilter _filter)

com.trs.components.common.publish.persistent.template 中 TemplateEmploys 的使用

返回 TemplateEmploys 的 com.trs.components.common.publish.persistent.template 中的方法
static TemplateEmploys | TemplateEmploys.createNewInstance(User _currUser) 产生当前集合对象[TemplateEmploys]的实例
static TemplateEmploys | TemplateEmploys.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TemplateEmploys | TemplateEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateEmploys]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TemplateQuote 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TemplateQuote
的使用

使用 TemplateQuote 的软件包
com.trs.components.comment.publish.tagparser |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.template |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.publish |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.wcmonline |

com.trs.components.comment.publish.tagparser 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.components.comment.publish.tagparser 中的方法
 TemplateQuote[] XWCMTagParserComment.analyzeQuotes(IPublishFolder _root)

com.trs.components.common.publish.domain.tagparser 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.components.common.publish.domain.tagparser 中的方法
TemplateQuote[] | TagParserDateTime.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | BaseTagParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserPageNav4Detail.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserNestedTemplate.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserCondition.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | ITagParser.analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
TemplateQuote[] | TagParserUnimpl.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserRepeat.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserOddOrEven.analyzeQuotes(IPublishFolder root)
TemplateQuote[] | TagParserSequenceNumber.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserEcho.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserVariableEnum.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserVariable.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserOnlyLogic.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserSystemConfig.analyzeQuotes(IPublishFolder _s_root)
TemplateQuote[] | TagParserVariableSet.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserNewIcon.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserCMSObjBase.analyzeQuotes(IPublishFolder _root)

com.trs.components.common.publish.domain.template 中 TemplateQuote 的使用

参数类型为 TemplateQuote 的 com.trs.components.common.publish.domain.template 中的方法
void | TemplateQuoteMgr0310.save(TemplateQuote _quote) save a template quote
void | TemplateQuoteMgr.save(TemplateQuote _quote) save a template quote

com.trs.components.common.publish.persistent.template 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.components.common.publish.persistent.template 中的方法
static TemplateQuote | TemplateQuote.createNewInstance() 产生当前对象[TemplateQuote]的实例
static TemplateQuote | TemplateQuote.findById(int _nId) 提取指定ID的对象
static TemplateQuote | TemplateQuote.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.components.infoview.publish.tagparser 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.components.infoview.publish.tagparser 中的方法
TemplateQuote[] | TagParserInfoViewNavs.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViewHelper.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViewData.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViewNav.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViewPage.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoViews.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserInfoView.analyzeQuotes(IPublishFolder _root)

com.trs.components.metadata.publish 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.components.metadata.publish 中的方法
TemplateQuote[] | WCMTagParserAppendix.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserClassIndexGener.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserRelNewsForViewData.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserClassDocuments.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserViewDatas.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserExistDataOfClassInfo.analyzeQuotes(IPublishFolder _root)

com.trs.components.wcm.epress 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.components.wcm.epress 中的方法
TemplateQuote[] | TagPreNextParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserPageNav.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagMapAreaParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagEBookDirParser.analyzeQuotes(IPublishFolder _root)

com.trs.components.wcm.publish.region 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.components.wcm.publish.region 中的方法
 TemplateQuote[] WCMTagParserRegion.analyzeQuotes(IPublishFolder _o_root)

com.trs.components.wcm.publish.tagparser 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.components.wcm.publish.tagparser 中的方法
TemplateQuote[] | TagWmlContentParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagChannelChainParser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserWmlImage.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserCurPage.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserCRUser.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | XWCMTagParserPageGeneration.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserRollDocuments.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParser4FolderHostBase.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserMapArea.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserAppendix.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserPrev.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserIcon.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | XWCMFileAppendixTagParser.analyzeQuotes(IPublishFolder arg0)
TemplateQuote[] | WCMTagParserChannels.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | XWCMImageAppendixTagParser.analyzeQuotes(IPublishFolder arg0)
TemplateQuote[] | WCMTagparserTopIcon.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserReplace.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | TagParserWmlImages.analyzeQuotes(IPublishFolder _root)
TemplateQuote[] | WCMTagParserRelNews.analyzeQuotes(IPublishFolder _root)

com.trs.wcmonline 中 TemplateQuote 的使用

返回 TemplateQuote 的 com.trs.wcmonline 中的方法
 TemplateQuote[] TagParserVipMetaData.analyzeQuotes(IPublishFolder _root)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TemplateQuotes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TemplateQuotes
的使用

使用 TemplateQuotes 的软件包
com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.persistent.template 中 TemplateQuotes 的使用

返回 TemplateQuotes 的 com.trs.components.common.publish.persistent.template 中的方法
static TemplateQuotes | TemplateQuotes.createNewInstance(User _currUser) 产生当前集合对象[TemplateQuotes]的实例
static TemplateQuotes | TemplateQuotes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static TemplateQuotes | TemplateQuotes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateQuotes]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.Templates 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.Templates
的使用

使用 Templates 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.element
com.trs.components.common.publish.persistent.template
com.trs.components.wcm.epress
com.trs.components.wcm.recent
com.trs.service
com.trs.service.impl
com.trs.template.domain

com.trs.ajaxservice 中 Templates 的使用

返回 Templates 的 com.trs.ajaxservice 中的方法
Templates | TemplateServiceProvider.getOptionalTemplates(MethodContext _MethodContext) 获取指定的对象可选择的模板
Templates | TemplateServiceProvider.queryNestedTemplates(MethodContext _methodContext) 获取使用指定模板使用了那些嵌套模板
Templates | TemplateServiceProvider.queryTemplatesNested(MethodContext _methodContext) 获取使用指定嵌套模板的模板

com.trs.components.common.publish.domain.template 中 Templates 的使用

返回 Templates 的 com.trs.components.common.publish.domain.template 中的方法
Templates | TemplateMgr.getManagedTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) get the managed tempaltes in the specified folder
Templates | TemplateNestMgr.getNestedTemplates(Template _template) get the nested templates
Templates | TemplateMgr.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent) get the managed tempaltes in the specified folder
Templates | TemplateEmployMgr.getOtherOutlineTemplates(IPublishFolder _folder) 获取当前folder的其它概览模板集.
Templates | TemplateEmployDetail.getOutlineTemplates()
Templates | ITemplateEmployCacheMgr.getOutlineTemplates(IPublishFolder _folder)
Templates | TemplateEmployCacheMgrImpl.getOutlineTemplates(IPublishFolder _folder)
Templates | TemplateEmployMgr.getOutlineTemplates(IPublishFolder _folder) get the outline templates of the specified folder.
Templates | TemplateNestMgr.getTemplatesNested(Template _template) 返回获取嵌套了指定模板的所有模板

参数类型为 Templates 的 com.trs.components.common.publish.domain.template 中的方法
java.lang.String | TemplateExporter.export(Templates _currTemplates) 导出模板集合
java.lang.String | TemplateExporter.exportToXMLFile(Templates _currTemplates) 将WCM的模板集合导出成为WCM XML标准格式的文件
Reports | TemplateMgr.redistributeAppendixes(Templates _templates) 重新分发模板的所有附件
void | TemplateMgr.updateNestedTemplateName(Templates templates, java.lang.String sOldName, java.lang.String sNewName)

com.trs.components.common.publish.persistent.element 中 Templates 的使用

返回 Templates 的 com.trs.components.common.publish.persistent.element 中的方法
Templates | PublishFolderImplBase.getOutlineTemplates()
Templates | IPublishFolder.getOutlineTemplates() get the outline templates of the current folder.
Templates | PublishFolderWrapper.getOutlineTemplates()

com.trs.components.common.publish.persistent.template 中 Templates 的使用

返回 Templates 的 com.trs.components.common.publish.persistent.template 中的方法
static Templates | Templates.createNewInstance(User _currUser) 产生当前集合对象[Templates]的实例
static Templates | Templates.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Templates | Templates.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Templates]

com.trs.components.wcm.epress 中 Templates 的使用

返回 Templates 的 com.trs.components.wcm.epress 中的方法
 Templates EpressFolderWrapper.getOutlineTemplates()

com.trs.components.wcm.recent 中 Templates 的使用

返回 Templates 的 com.trs.components.wcm.recent 中的方法
 Templates RecentMgr.getTemplates(WCMFilter _aFilter)
获得用户最近访问的模板列表，按访问时间逆序排列

com.trs.service 中 Templates 的使用

返回 Templates 的 com.trs.service 中的方法
Templates | ITemplateService.getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) 获取站点/频道下管理的模板集合
Templates | ITemplateService.getNestedTemplates(Template _currTemplate) 获取当前模板中使用到的嵌套模板
Templates | ITemplateService.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseParent) 获取指定Folder中可选的模板集合
Templates | ITemplateService.getOutlineTemplates(IPublishFolder _folder) 获得指定频道的概览模板
Templates | IRecentService.getTemplates(WCMFilter _aFilter) 返回用户最近访问的模板列表 按照访问的时间顺序排序
Templates | ITemplateService.getTemplatesNested(Template _currTemplate) 获取嵌套了当前模板的所有模板

参数类型为 Templates 的 com.trs.service 中的方法
boolean | ITemplateService.delete(Templates _currTemplatesToDelete) 彻底删除模板集合
java.lang.String | ITemplateService.export(Templates _currTemplates) 导出模板集合到临时目录的文件中

com.trs.service.impl 中 Templates 的使用

返回 Templates 的 com.trs.service.impl 中的方法
Templates | TemplateService.getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren)
Templates | TemplateService.getNestedTemplates(Template _template)
Templates | TemplateService.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent)
Templates | TemplateService.getOutlineTemplates(IPublishFolder _folder)
Templates | RecentService.getTemplates(WCMFilter _aFilter)
Templates | TemplateService.getTemplatesNested(Template _template)

参数类型为 Templates 的 com.trs.service.impl 中的方法
boolean | TemplateService.delete(Templates _currTemplatesToDelete)
java.lang.String | TemplateService.export(Templates _currTemplates)

com.trs.template.domain 中 Templates 的使用

参数类型为 Templates 的 com.trs.template.domain 中的方法
 java.lang.String XTemplateExporter.export(Templates _currTemplates)
导出模板集合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.persistent.template.TemplateXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.persistent.template.TemplateXmlConverter
的使用

没有 com.trs.components.common.publish.persistent.template.TemplateXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AdjustJsLCListenerWidget

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 AdjustJsLCListenerWidget

java.lang.Object
    继承者  com.trs.components.common.publish.widget.AdjustJsLCListenerWidget
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class AdjustJsLCListenerWidget
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

构造方法摘要
AdjustJsLCListenerWidget()
方法摘要
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj objModified, int eventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdjustJsLCListenerWidget

public AdjustJsLCListenerWidget()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BaseStyle

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 BaseStyle

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.BaseStyle
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
ContentStyle, PageStyle, ResourceStyle
public abstract class BaseStyle
extends CMSObj

风格抽象类

作者：
han

构造方法摘要
BaseStyle()
方法摘要
java.lang.String | getStyleDesc() 提取属性：风格描述
java.lang.String | getStyleName() 提取属性：风格名称
java.lang.String | getStyleThumb() 提取属性：风格缩略图
java.lang.String | getTemplate() 提取属性：风格的样式模板类型
boolean | setStyleDesc(java.lang.String _sStyleDesc) 设置属性：风格描述
boolean | setStyleName(java.lang.String _sStyleName) 设置属性：风格名称
boolean | setStyleThumb(java.lang.String _sStyleThumb) 设置属性：风格缩略图
boolean | setTemplate(java.lang.String _sTemplate) 设置属性：风格样式模板
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getDbTableName, getFinalPropertyAsString, getFinalPropertyAsString, getId, getIdFieldName, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, getWCMType, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValid, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BaseStyle

public BaseStyle()
方法详细信息

getStyleName

public java.lang.String getStyleName()
提取属性：风格名称

返回：
风格名称

setStyleName

public boolean setStyleName(java.lang.String _sStyleName)
                     throws WCMException
设置属性：风格名称

参数：
_sStyleName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyleDesc

public java.lang.String getStyleDesc()
提取属性：风格描述

返回：
当前风格对象的描述属性

setStyleDesc

public boolean setStyleDesc(java.lang.String _sStyleDesc)
                     throws WCMException
设置属性：风格描述

参数：
_sStyleDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyleThumb

public java.lang.String getStyleThumb()
提取属性：风格缩略图

返回：
当前风格对象的缩略图

setStyleThumb

public boolean setStyleThumb(java.lang.String _sStyleThumb)
                      throws WCMException
设置属性：风格缩略图

参数：
_sStyleThumb - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTemplate

public java.lang.String getTemplate()
提取属性：风格的样式模板类型

返回：
返回设置的样式模板

setTemplate

public boolean setTemplate(java.lang.String _sTemplate)
                    throws WCMException
设置属性：风格样式模板

参数：
_sTemplate - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentStyle

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ContentStyle

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.BaseStyle
                继承者  com.trs.components.common.publish.widget.ContentStyle
所有已实现的接口：
java.lang.Cloneable
public class ContentStyle
extends BaseStyle

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ContentStyle()
构造函数：保留默认接口
方法摘要
static ContentStyle | createNewInstance() 产生当前对象[ContentStyle]的实例
static ContentStyle | findById(int _nId) 提取指定ID的对象
static ContentStyle | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getCssFlag() 提取属性：风格标识
java.lang.String | getCustomStyle() 提取属性：自定义样式
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getIsPrivate() 提取属性：是否是私有对象
int | getPageStyleId() 提取属性：页面风格ID
int | getSrcContentStyleId() 提取属性：源内容风格ID
java.lang.String | getStyleThumb() 提取属性：风格缩略图
java.lang.String | getTemplate() 提取属性：样式模板
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setCssFlag(java.lang.String _sCssFlag) 设置属性：风格标识
boolean | setCustomStyle(java.lang.String _sCustomStyle) 设置属性：自定义样式
boolean | setIsPrivate(int _nIsPrivate) 设置属性：是否是私有对象
boolean | setPageStyleId(int _nPageStyleId) 设置属性：页面风格ID
boolean | setSrcContentStyleId(int _nSrcContentStyleId) 设置属性：源内容风格ID
boolean | setStyleThumb(java.lang.String _sStyleThumb) 设置属性：风格缩略图
boolean | setTemplate(java.lang.String _sTempalte) 设置属性：样式模板
从类 com.trs.components.common.publish.widget.BaseStyle 继承的方法
getStyleDesc, getStyleName, setStyleDesc, setStyleName
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ContentStyle

public ContentStyle()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getCssFlag

public java.lang.String getCssFlag()
提取属性：风格标识

返回：
当前风格对象的标识

setCssFlag

public boolean setCssFlag(java.lang.String _sCssFlag)
                   throws WCMException
设置属性：风格标识

参数：
_sCssFlag - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyleThumb

public java.lang.String getStyleThumb()
提取属性：风格缩略图

覆盖：
类 BaseStyle 中的 getStyleThumb
返回：
当前风格对象的缩略图

setStyleThumb

public boolean setStyleThumb(java.lang.String _sStyleThumb)
                      throws WCMException
设置属性：风格缩略图

覆盖：
类 BaseStyle 中的 setStyleThumb
参数：
_sStyleThumb - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPageStyleId

public int getPageStyleId()
提取属性：页面风格ID

返回：
所属的页面风格ID

setPageStyleId

public boolean setPageStyleId(int _nPageStyleId)
                       throws WCMException
设置属性：页面风格ID

参数：
_nPageStyleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSrcContentStyleId

public int getSrcContentStyleId()
提取属性：源内容风格ID

返回：
源内容风格ID

setSrcContentStyleId

public boolean setSrcContentStyleId(int _nSrcContentStyleId)
                             throws WCMException
设置属性：源内容风格ID

参数：
_nSrcContentStyleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTemplate

public java.lang.String getTemplate()
提取属性：样式模板

覆盖：
类 BaseStyle 中的 getTemplate
返回：
当前风格对像的样式模板

setTemplate

public boolean setTemplate(java.lang.String _sTempalte)
                    throws WCMException
设置属性：样式模板

覆盖：
类 BaseStyle 中的 setTemplate
参数：
_sTempalte - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCustomStyle

public java.lang.String getCustomStyle()
提取属性：自定义样式

返回：
当前风格的自定义样式

setCustomStyle

public boolean setCustomStyle(java.lang.String _sCustomStyle)
                       throws WCMException
设置属性：自定义样式

参数：
_sCustomStyle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIsPrivate

public int getIsPrivate()
提取属性：是否是私有对象

返回：
是否是私有对象

setIsPrivate

public boolean setIsPrivate(int _nIsPrivate)
                     throws WCMException
设置属性：是否是私有对象

参数：
_nIsPrivate - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final ContentStyle findById(int _nId)
                                   throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ContentStyle createNewInstance()
                                            throws WCMException
产生当前对象[ContentStyle]的实例

返回：
当前对象的实例[ContentStyle]
抛出：
WCMException

findByKey

public static final ContentStyle findByKey(java.lang.Object _oKey)
                                    throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentStyleExporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ContentStyleExporter

java.lang.Object
    继承者  com.trs.components.common.publish.widget.ContentStyleExporter

public class ContentStyleExporter
extends java.lang.Object

内容风格导出器

作者：
rey2008

构造方法摘要
ContentStyleExporter()
构造函数
方法摘要
java.lang.String | export(ContentStyles _currContentStyles, boolean _bReturnXMLContent) 导出一个内容风格到xml文件中。
void | setXMLEncoding(java.lang.String _sXMLEncoding) 设置导出文件的编码格式
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentStyleExporter

public ContentStyleExporter()
构造函数

方法详细信息

export

public java.lang.String export(ContentStyles _currContentStyles,
                               boolean _bReturnXMLContent)
                        throws java.lang.Exception
导出一个内容风格到xml文件中。

参数：
_currContentStyle - 页面风格对象
_bReturnXMLContent - 是否直接返回xml内容
返回：
抛出：
java.lang.Exception

setXMLEncoding

public void setXMLEncoding(java.lang.String _sXMLEncoding)
设置导出文件的编码格式

参数：
_sXMLEncoding -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentStyleImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ContentStyleImporter

java.lang.Object
    继承者  com.trs.components.common.publish.widget.ContentStyleImporter

public class ContentStyleImporter
extends java.lang.Object

内容风格的导入代码

作者：
rey2008

构造方法摘要
ContentStyleImporter()
构造函数
方法摘要
 Reports importFromFile(java.lang.String _sFile, int _nImportMode)
从zip文件中导入PageStyle的信息。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentStyleImporter

public ContentStyleImporter()
构造函数

方法详细信息

importFromFile

public Reports importFromFile(java.lang.String _sFile,
                              int _nImportMode)
                       throws java.lang.Exception
从zip文件中导入PageStyle的信息。

参数：
_sFile - zip文件的名称，如：ST20100526388775315675.zip
返回：
抛出：
WCMException
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ContentStyleMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.ContentStyleMgr
所有已实现的接口：
IContentStyleMgr
public class ContentStyleMgr
extends java.lang.Object
implements IContentStyleMgr

内容可用风格业务逻辑实现类

作者：
han

构造方法摘要
ContentStyleMgr()
构造方法
方法摘要
boolean | checkCssFlag(PageStyle _pageStyle, ContentStyle _currContentStyle, java.lang.String _cssFlag) 在指定的系统风格下校验CssFlag是否唯一
boolean | checkStyleName(PageStyle _pageStyle, ContentStyle _currContentStyle, java.lang.String _styleName) 在指定的系统风格下校验风格名称是否唯一
ContentStyle | copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
void | delete(User _currUser, ContentStyle _contentStyle) 删除ContentStyle
ContentStyles | findByCssFlagAndPageStyle(java.lang.String _sCssFlag, PageStyle _oPageStyle) 根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 内容风格集合
ContentStyles | findByStyleNameAndPageStyle(java.lang.String _sStyleName, PageStyle _oPageStyle) 根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 内容风格集合
java.lang.String | makeCssContent(ContentStyle _contentStyle) 生成指定PageStyle下可用的内容风格css文件
ContentStyles | query(PageStyle pageStyle, WCMFilter _filter) 在指定PageStyle下获取ContentStyle集合
ContentStyles | queryContenetStyles(PageStyle _pageStyle) 获取指定系统风格下的内容可用风格集合
ContentStyle | save(User _currUser, ContentStyle _contentStyle) 保存（新增、编辑）ContentStyle
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentStyleMgr

public ContentStyleMgr()
构造方法

方法详细信息

delete

public void delete(User _currUser,
                   ContentStyle _contentStyle)
            throws WCMException
从接口 IContentStyleMgr 复制的描述
删除ContentStyle

指定者：
接口 IContentStyleMgr 中的 delete
参数：
_currUser - 当前用户
_contentStyle - 当前内容风格对象
抛出：
WCMException

makeCssContent

public java.lang.String makeCssContent(ContentStyle _contentStyle)
                                throws WCMException
从接口 IContentStyleMgr 复制的描述
生成指定PageStyle下可用的内容风格css文件

指定者：
接口 IContentStyleMgr 中的 makeCssContent
参数：
_contentStyle - 当前内容风格
返回：
生成的内容风格的css内容
抛出：
WCMException

query

public ContentStyles query(PageStyle pageStyle,
                           WCMFilter _filter)
                    throws WCMException
从接口 IContentStyleMgr 复制的描述
在指定PageStyle下获取ContentStyle集合

指定者：
接口 IContentStyleMgr 中的 query
参数：
pageStyle - 当前页面风格对象
_filter - 外部组织的filter
返回：
抛出：
WCMException

save

public ContentStyle save(User _currUser,
                         ContentStyle _contentStyle)
                  throws WCMException
从接口 IContentStyleMgr 复制的描述
保存（新增、编辑）ContentStyle

指定者：
接口 IContentStyleMgr 中的 save
参数：
_currUser - 当前用户
_contentStyle - 当前内容风格对象
返回：
ContentStyle 返回保存后的内容风格对象
抛出：
WCMException

copy

public ContentStyle copy(User _currUser,
                         PageStyle _targetPageStyle,
                         ContentStyle _sourceContentStyle)
                  throws WCMException
从接口 IContentStyleMgr 复制的描述
仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle

指定者：
接口 IContentStyleMgr 中的 copy
参数：
_currUser - 当前用户
_targetPageStyle - 目标页面风格
_sourceContentStyle - 源内容风格
返回：
抛出：
WCMException

copy

public ContentStyle copy(User _currUser,
                         PageStyle _targetPageStyle,
                         ContentStyle _sourceContentStyle,
                         int _nCopyMode,
                         Reports oCopyReports)
                  throws WCMException
从接口 IContentStyleMgr 复制的描述
仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle

指定者：
接口 IContentStyleMgr 中的 copy
参数：
_currUser - 当前用户
_targetPageStyle - 目标页面风格
_sourceContentStyle - 源内容风格
_nCopyMode - 复制重名后的处理方式
返回：
抛出：
WCMException

queryContenetStyles

public ContentStyles queryContenetStyles(PageStyle _pageStyle)
                                  throws WCMException
获取指定系统风格下的内容可用风格集合

指定者：
接口 IContentStyleMgr 中的 queryContenetStyles
参数：
pageStyle -
返回：
抛出：
WCMException

checkCssFlag

public boolean checkCssFlag(PageStyle _pageStyle,
                            ContentStyle _currContentStyle,
                            java.lang.String _cssFlag)
                     throws WCMException
在指定的系统风格下校验CssFlag是否唯一

指定者：
接口 IContentStyleMgr 中的 checkCssFlag
参数：
_currContentStyle -
pageStyle -
cssFlag -
返回：
抛出：
WCMException

checkStyleName

public boolean checkStyleName(PageStyle _pageStyle,
                              ContentStyle _currContentStyle,
                              java.lang.String _styleName)
                       throws WCMException
在指定的系统风格下校验风格名称是否唯一

指定者：
接口 IContentStyleMgr 中的 checkStyleName
参数：
_currContentStyle -
pageStyle -
cssFlag -
返回：
抛出：
WCMException

findByCssFlagAndPageStyle

public ContentStyles findByCssFlagAndPageStyle(java.lang.String _sCssFlag,
                                               PageStyle _oPageStyle)
                                        throws WCMException
根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 内容风格集合

参数：
_sCssFlag -
_oPageStyle -
返回：
抛出：
WCMException - TrsArcher 2010-5-31下午02:12:07

findByStyleNameAndPageStyle

public ContentStyles findByStyleNameAndPageStyle(java.lang.String _sStyleName,
                                                 PageStyle _oPageStyle)
                                          throws WCMException
根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 内容风格集合

参数：
_sStyleName -
_oPageStyle -
返回：
抛出：
WCMException - TrsArcher 2010-5-31下午02:12:07
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentStyles

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ContentStyles

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.ContentStyles

public class ContentStyles
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ContentStyles(User _currUser)
构造函数
ContentStyles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ContentStyles | createNewInstance(User _currUser) 产生当前集合对象[ContentStyles]的实例
static ContentStyle | findByCssFlagAndPageStyle(User _currUser, java.lang.String _sCssFlag, int _nPageStyleId) 根据指定的风格标识和页面风格来获取内容风格
static ContentStyles | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentStyle | findByStyleNameAndPageStyle(User _currUser, java.lang.String _sStyleName, int _nPageStyleId) 根据指定的风格名称和页面风格来获取内容风格
static ContentStyles | findSameCssFlagStyles(java.lang.String _sCssFlag) 根据指定的风格标识来获取内容风格集合
static ContentStyles | findSameNameStyles(java.lang.String _sStyleName) 根据指定的风格名称来获取资源风格集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ContentStyles | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentStyles]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentStyles

public ContentStyles(User _currUser)
构造函数

另请参见：
ContentStyles( User _currUser, int _initCapacity, int _incCapacity );

ContentStyles

public ContentStyles(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ContentStyles findByIds(User _currUser,
                                            java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ContentStyles）
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByStyleNameAndPageStyle

public static final ContentStyle findByStyleNameAndPageStyle(User _currUser,
                                                             java.lang.String _sStyleName,
                                                             int _nPageStyleId)
                                                      throws WCMException
根据指定的风格名称和页面风格来获取内容风格

参数：
_currUser -
_sStyleName -
_nPageStyleId -
返回：
抛出：
WCMException

findByCssFlagAndPageStyle

public static final ContentStyle findByCssFlagAndPageStyle(User _currUser,
                                                           java.lang.String _sCssFlag,
                                                           int _nPageStyleId)
                                                    throws WCMException
根据指定的风格标识和页面风格来获取内容风格

参数：
_currUser -
_sCssFlag -
_nPageStyleId -
返回：
抛出：
WCMException

findSameCssFlagStyles

public static ContentStyles findSameCssFlagStyles(java.lang.String _sCssFlag)
                                           throws WCMException
根据指定的风格标识来获取内容风格集合

参数：
_sCssFlag -
返回：
抛出：
WCMException

findSameNameStyles

public static ContentStyles findSameNameStyles(java.lang.String _sStyleName)
                                        throws WCMException
根据指定的风格名称来获取资源风格集合

参数：
_sStyleName -
返回：
抛出：
WCMException

openWCMObjs

public static final ContentStyles openWCMObjs(User _currUser,
                                              WCMFilter _filter)
                                       throws WCMException
通过指定一个Filter获取当前集合[ContentStyles]

参数：
_filter - 指定的Filter
返回：
当前集合[ContentStyles]
抛出：
WCMException

createNewInstance

public static ContentStyles createNewInstance(User _currUser)
产生当前集合对象[ContentStyles]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentStyleServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ContentStyleServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.ContentStyleServiceProvider
所有已实现的接口：
IContentStyleServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ContentStyleServiceProvider
extends java.lang.Object
implements IContentStyleServiceProvider

内容可用风格服务层

作者：
han

构造方法摘要
ContentStyleServiceProvider()
构造方法
方法摘要
boolean | checkCssFlag(MethodContext _context) 在指定的系统风格下校验CssFlag是否唯一
boolean | checkCssFlagOrNameCanUse(MethodContext _context) 判断指定的风格标识和风格名称是否在指定的页面风格下存在
java.lang.String | copy(MethodContext context) 复制内容可用风格到页面页面风格或者系统内容风格下
void | delete(MethodContext context) 删除指定的风格
java.lang.String | exportContentStyleZip(MethodContext context) 导出一个内容风格对象到zip文件中，zip文件中包含这个内容风格的所有相关文件
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.util.HashMap | findCssFlagUsedInfo(MethodContext _context) 校验CssFlag是否可用。
java.util.HashMap | findStyleNameUsedInfo(MethodContext _context) 校验StyleName已经被使用的信息
java.lang.String | importContentStyleZip(MethodContext context) 从一个zip文件中导入内容风格的相关内容，包括该内容风格的所有相关内容 ContentStyleZipFile支持一个全路径
java.lang.String | makePreviewCssContent(MethodContext _context) 获取预览时需要的样式内容 在列表中预览时调用的方法，返回当前内容风格的css样式代码
java.lang.String | previewStyle(MethodContext _context) 预览风格根据当前填写的风格设置项 其中参数StyleItemXML的格式为一段xml，格式类似于
java.lang.Object | query(MethodContext context) 获取内容风格集合
ContentStyles | queryContentStyles(MethodContext context) 获取指定系统风格下的内容可用风格集合
void | resetContentStyle(MethodContext _oContext) 将当前 内容风格的设置 重置为 对应的系统级别的 内容风格的设置
int | save(MethodContext context) 保存当前风格
int | saveStyleThumb(MethodContext context) 保存上传的风格示意图，该缩略图必须已经上传到webpic下
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentStyleServiceProvider

public ContentStyleServiceProvider()
构造方法

方法详细信息

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
删除指定的风格

指定者：
接口 IDeleteServiceProvider 中的 delete
参数：
context -
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
获取内容风格集合

指定者：
接口 IQueryServiceProvider 中的 query
参数：
context -
返回：
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
保存当前风格

指定者：
接口 ISaveServiceProvider 中的 save
参数：
context -
返回：
抛出：
java.lang.Throwable

saveStyleThumb

public int saveStyleThumb(MethodContext context)
                   throws java.lang.Throwable
保存上传的风格示意图，该缩略图必须已经上传到webpic下

参数：
context -
返回：
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

copy

public java.lang.String copy(MethodContext context)
                      throws java.lang.Throwable
复制内容可用风格到页面页面风格或者系统内容风格下

指定者：
接口 IContentStyleServiceProvider 中的 copy
参数：
context -
返回：
抛出：
java.lang.Throwable

checkCssFlag

public boolean checkCssFlag(MethodContext _context)
                     throws java.lang.Throwable
在指定的系统风格下校验CssFlag是否唯一

参数：
_context -
返回：
抛出：
java.lang.Throwable

makePreviewCssContent

public java.lang.String makePreviewCssContent(MethodContext _context)
                                       throws java.lang.Throwable
获取预览时需要的样式内容 在列表中预览时调用的方法，返回当前内容风格的css样式代码

参数：
_context -
返回：
抛出：
java.lang.Throwable

queryContentStyles

public ContentStyles queryContentStyles(MethodContext context)
                                 throws java.lang.Throwable
获取指定系统风格下的内容可用风格集合

参数：
context -
返回：
抛出：
java.lang.Throwable

previewStyle

public java.lang.String previewStyle(MethodContext _context)
                              throws java.lang.Throwable
预览风格根据当前填写的风格设置项 其中参数StyleItemXML的格式为一段xml，格式类似于 ]]>

参数：
_context -
返回：
抛出：
java.lang.Throwable

findCssFlagUsedInfo

public java.util.HashMap findCssFlagUsedInfo(MethodContext _context)
                                      throws java.lang.Throwable
校验CssFlag是否可用。

参数：
_context -
返回：
返回的数据格式为一个HashMap，名称为ContentStyles，值为内容风格的集合对象 界面中返回内容格式如：legal@合法 或 illegal@该标识被以下风格使用: 资源风格[页面风格->资源风格];内容风格[页面风格->内容风格]
抛出：
java.lang.Throwable

findStyleNameUsedInfo

public java.util.HashMap findStyleNameUsedInfo(MethodContext _context)
                                        throws java.lang.Throwable
校验StyleName已经被使用的信息

参数：
_context -
返回：
返回的数据格式为一个HashMap，名称为ContentStyles，值内容风格的集合对象 在页面中返回内容的格式如：legal@合法 或 illegal@该名称被以下风格使用: 资源风格[页面风格->资源风格];内容风格[页面风格->内容风格]
抛出：
java.lang.Throwable

checkCssFlagOrNameCanUse

public boolean checkCssFlagOrNameCanUse(MethodContext _context)
                                 throws WCMException
判断指定的风格标识和风格名称是否在指定的页面风格下存在

参数：
_context -
返回：
抛出：
WCMException

resetContentStyle

public void resetContentStyle(MethodContext _oContext)
                       throws java.lang.Throwable
将当前 内容风格的设置 重置为 对应的系统级别的 内容风格的设置

参数：
_oContext -
抛出：
java.lang.Throwable - TrsArcher 2010-6-1下午01:12:48

exportContentStyleZip

public java.lang.String exportContentStyleZip(MethodContext context)
                                       throws java.lang.Throwable
导出一个内容风格对象到zip文件中，zip文件中包含这个内容风格的所有相关文件

参数：
context -
返回：
抛出：
java.lang.Throwable

importContentStyleZip

public java.lang.String importContentStyleZip(MethodContext context)
                                       throws java.lang.Throwable
从一个zip文件中导入内容风格的相关内容，包括该内容风格的所有相关内容 ContentStyleZipFile支持一个全路径

参数：
context -
抛出：
java.lang.Throwable
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentStyleXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ContentStyleXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.common.publish.widget.ContentStyleXmlConverter

public class ContentStyleXmlConverter
extends BaseObjToXmlConverter

内容风格导出xml转换器

作者：
rey2008

构造方法摘要
ContentStyleXmlConverter()
构造函数
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentStyleXmlConverter

public ContentStyleXmlConverter()
构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IContentStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IContentStyleMgr

所有已知实现类：
ContentStyleMgr
public interface IContentStyleMgr

内容可用风格业务逻辑层接口

作者：
han

方法摘要
boolean | checkCssFlag(PageStyle pageStyle, ContentStyle contentStyle, java.lang.String cssFlag) 在指定的页面风格下校验当前内容风格的风格标识（CssFlag）是否唯一
boolean | checkStyleName(PageStyle pageStyle, ContentStyle contentStyle, java.lang.String styleName) 在指定的页面风格下校验当前内容风格的风格名称（CssFlag）是否唯一
ContentStyle | copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
void | delete(User _currUser, ContentStyle _contentStyle) 删除ContentStyle
java.lang.String | makeCssContent(ContentStyle _contentStyle) 生成指定PageStyle下可用的内容风格css文件
ContentStyles | query(PageStyle _currPageStyle, WCMFilter _filter) 在指定PageStyle下获取ContentStyle集合
ContentStyles | queryContenetStyles(PageStyle pageStyle) 获取指定系统风格下的内容可用风格集合
ContentStyle | save(User _currUser, ContentStyle _contentStyle) 保存（新增、编辑）ContentStyle

方法详细信息

save

ContentStyle save(User _currUser,
                  ContentStyle _contentStyle)
                  throws WCMException
保存（新增、编辑）ContentStyle

参数：
_currUser - 当前用户
_contentStyle - 当前内容风格对象
返回：
ContentStyle 返回保存后的内容风格对象
抛出：
WCMException

delete

void delete(User _currUser,
            ContentStyle _contentStyle)
            throws WCMException
删除ContentStyle

参数：
_currUser - 当前用户
_contentStyle - 当前内容风格对象
抛出：
WCMException

query

ContentStyles query(PageStyle _currPageStyle,
                    WCMFilter _filter)
                    throws WCMException
在指定PageStyle下获取ContentStyle集合

参数：
_currPageStyle - 当前页面风格对象
_filter - 外部组织的filter
返回：
抛出：
WCMException

makeCssContent

java.lang.String makeCssContent(ContentStyle _contentStyle)
                                throws WCMException
生成指定PageStyle下可用的内容风格css文件

参数：
_contentStyle - 当前内容风格
返回：
生成的内容风格的css内容
抛出：
WCMException

copy

ContentStyle copy(User _currUser,
                  PageStyle _targetPageStyle,
                  ContentStyle _sourceContentStyle)
                  throws WCMException
仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle

参数：
_currUser - 当前用户
_targetPageStyle - 目标页面风格
_sourceContentStyle - 源内容风格
返回：
抛出：
WCMException

copy

ContentStyle copy(User _currUser,
                  PageStyle _targetPageStyle,
                  ContentStyle _sourceContentStyle,
                  int _nCopyMode,
                  Reports oCopyReports)
                  throws WCMException
仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle

参数：
_currUser - 当前用户
_targetPageStyle - 目标页面风格
_sourceContentStyle - 源内容风格
_nCopyMode - 复制重名后的处理方式
返回：
抛出：
WCMException

checkCssFlag

boolean checkCssFlag(PageStyle pageStyle,
                     ContentStyle contentStyle,
                     java.lang.String cssFlag)
                     throws WCMException
在指定的页面风格下校验当前内容风格的风格标识（CssFlag）是否唯一

参数：
_currContentStyle - 需要校验的当前内容风格
pageStyle - 指定的页面风格
cssFlag - 当前页面风格的风格标识
返回：
抛出：
WCMException

queryContenetStyles

ContentStyles queryContenetStyles(PageStyle pageStyle)
                                  throws WCMException
获取指定系统风格下的内容可用风格集合

参数：
pageStyle - 指定的页面风格对象
返回：
内容风格的集合对象
抛出：
WCMException

checkStyleName

boolean checkStyleName(PageStyle pageStyle,
                       ContentStyle contentStyle,
                       java.lang.String styleName)
                       throws WCMException
在指定的页面风格下校验当前内容风格的风格名称（CssFlag）是否唯一

参数：
_currContentStyle - 需要校验的当前内容风格
pageStyle - 指定的页面风格
styleName - 当前内容风格的风格名称
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IContentStyleServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IContentStyleServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知实现类：
ContentStyleServiceProvider
public interface IContentStyleServiceProvider
extends IGlueServiceProvider

内容可用风格服务层接口

作者：
han

方法摘要
 java.lang.String copy(MethodContext context)
复制内容可用风格
从接口 com.trs.webframework.provider.IDeleteServiceProvider 继承的方法
delete
从接口 com.trs.webframework.provider.IQueryServiceProvider 继承的方法
query
从接口 com.trs.webframework.provider.ISaveServiceProvider 继承的方法
save
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

方法详细信息

copy

java.lang.String copy(MethodContext context)
                      throws java.lang.Throwable
复制内容可用风格

参数：
context -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ILayoutGenerator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 ILayoutGenerator

所有已知实现类：
LayoutGenerator
public interface ILayoutGenerator

字段摘要
static java.lang.String | COLUMN_CLASS 布局列的class标识
static java.lang.String | EMPTY_COLUMN_HTML 列的初始内容
static java.lang.String | LAYOUT_CLASS 布局的class标识
方法摘要
void | deleteCss(Layout _currLayout) 删除当前布局对应的CSS样式内容
java.lang.String | generateHtml(Layout _currLayout, boolean _bCssInHtml) 生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可
java.lang.String | generateHtml(Layout _currLayout, boolean _bCssInHtml, boolean _bColIndexAsText) 生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可
boolean | validateHtml(Layout _currLayout) 对用户上传的HTML代码进行验证，查看是否符合相关规范，如果不允许用户上传，可以直接返回true

字段详细信息

LAYOUT_CLASS

static final java.lang.String LAYOUT_CLASS
布局的class标识

另请参见：
常量字段值

COLUMN_CLASS

static final java.lang.String COLUMN_CLASS
布局列的class标识

另请参见：
常量字段值

EMPTY_COLUMN_HTML

static final java.lang.String EMPTY_COLUMN_HTML
列的初始内容

另请参见：
常量字段值
方法详细信息

generateHtml

java.lang.String generateHtml(Layout _currLayout,
                              boolean _bCssInHtml)
                              throws WCMException
生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可

参数：
_currLayout - 当前布局
_bCssInHtml - 是否将CSS样式写到布局结构HTML中
返回：
抛出：
WCMException

generateHtml

java.lang.String generateHtml(Layout _currLayout,
                              boolean _bCssInHtml,
                              boolean _bColIndexAsText)
                              throws WCMException
生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可

参数：
_currLayout - 当前布局
_bCssInHtml - 是否将CSS样式写到布局结构HTML中
_bColIndexAsText - 是否使用布局的列索引作为布局的填充内容，使用索引填充的目的，是为了方便利用String.format接口，进行布局内容的替换， 如果为false，则可能使用默认文字进行填充
返回：
抛出：
WCMException

validateHtml

boolean validateHtml(Layout _currLayout)
                     throws WCMException
对用户上传的HTML代码进行验证，查看是否符合相关规范，如果不允许用户上传，可以直接返回true

参数：
_currLayout -
返回：
抛出：
WCMException

deleteCss

void deleteCss(Layout _currLayout)
               throws WCMException
删除当前布局对应的CSS样式内容

参数：
_currLayout -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ILayoutMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 ILayoutMgr

所有已知实现类：
LayoutMgr
public interface ILayoutMgr

方法摘要
boolean | delete(User _oCurrUser, Layouts _currLayouts) 删除布局
Layout | findLayoutByName(User _currUser, java.lang.String _sLayoutName) 根据传入的布局名称，返回找到的第一个布局对象，如果没有找到合适的布局对象，则返回null。
Layouts | query(User _currUser, WCMFilter _currFilter) 查询布局
Layout | save(User _oCurrUser, Layout _currLayout) 新建或者保存布局
boolean | validate(Layout _currLayout) 验证布局的各属性是否符合规范，包括布局比例值和布局的HTML代码 注：布局HTML代码的验证斩不实现，为用户提交HTML内容代码提供验证功能

方法详细信息

delete

boolean delete(User _oCurrUser,
               Layouts _currLayouts)
               throws WCMException
删除布局

参数：
_oCurrUser - 当前登录用户
_currLayout - 当前布局
返回：
抛出：
WCMException

save

Layout save(User _oCurrUser,
            Layout _currLayout)
            throws WCMException
新建或者保存布局

参数：
_oCurrUser - 当前登录用户
_currLayout - 当前布局
返回：
抛出：
WCMException

validate

boolean validate(Layout _currLayout)
                 throws WCMException
验证布局的各属性是否符合规范，包括布局比例值和布局的HTML代码 注：布局HTML代码的验证斩不实现，为用户提交HTML内容代码提供验证功能

参数：
_currLayout - 当前布局
返回：
抛出：
WCMException

query

Layouts query(User _currUser,
              WCMFilter _currFilter)
              throws WCMException
查询布局

参数：
_currFilter - 查询条件
返回：
抛出：
WCMException

findLayoutByName

Layout findLayoutByName(User _currUser,
                        java.lang.String _sLayoutName)
                        throws WCMException
根据传入的布局名称，返回找到的第一个布局对象，如果没有找到合适的布局对象，则返回null。id越大，获取时优先级越高

参数：
_sLayoutName - 布局的名称
返回：
抛出：
java.lang.Exception
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ILayoutServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 ILayoutServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知实现类：
LayoutServiceProvider
public interface ILayoutServiceProvider
extends IGlueServiceProvider

方法摘要
void | delete(MethodContext context)
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.lang.String | getLayoutHtml(MethodContext context) 通过获取比例类型和比例值来直接返回相应的HTML内容
java.lang.Object | query(MethodContext context)
int | save(MethodContext _context)

方法详细信息

save

int save(MethodContext _context)
         throws WCMException
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
WCMException

delete

void delete(MethodContext context)
            throws WCMException
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
WCMException

query

java.lang.Object query(MethodContext context)
                       throws WCMException
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
WCMException

findById

java.lang.Object findById(MethodContext context)
                          throws WCMException
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
WCMException

findByIds

java.lang.Object findByIds(MethodContext context)
                           throws WCMException
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
WCMException

getLayoutHtml

java.lang.String getLayoutHtml(MethodContext context)
                               throws WCMException
通过获取比例类型和比例值来直接返回相应的HTML内容

参数：
context -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMasterMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IMasterMgr

所有已知实现类：
MasterMgr
public interface IMasterMgr

方法摘要
boolean | delete(User _oCurrUser, Masters _oMasters) 删除指定的母版
boolean | existsMName(int _nObjectId, java.lang.String _sMName) 校验母板名称是否已存在
java.lang.String | export(Masters _oMasters) 导出指定的母版
java.lang.String | getMasterFileContent(Master _oMaster, int _nFileType) 获取指定母板中指定文件类型的文件内容
Reports | importMasters(User _oCurrUser, java.lang.String _sImportMastersFileName) 导入母版
Masters | query(User _oCurrUser, WCMFilter _currFilter) 查询系统指定母版
Master | save(User _oCurrUser, Master _oCurrMaster)
Master | save(User _oCurrUser, java.lang.String _sMasterName, java.lang.String _sFileName) 保存当前母版
java.lang.String | validateMasterFile(java.lang.String _sFileName) 校验母版文件的合法性

方法详细信息

save

Master save(User _oCurrUser,
            java.lang.String _sMasterName,
            java.lang.String _sFileName)
            throws WCMException
保存当前母版

参数：
_oCurrUser - 当前操作的用户
_sMasterName - 母版名称
_sFileName - 母版对应的文件，必须是WCM规则的文件名
返回：
抛出：
WCMException

save

Master save(User _oCurrUser,
            Master _oCurrMaster)
            throws WCMException
参数：
_oCurrUser - 当前操作的用户
_oCurrMaster - 当前的母版
返回：
抛出：
WCMException

delete

boolean delete(User _oCurrUser,
               Masters _oMasters)
               throws WCMException
删除指定的母版

参数：
_oCurrUser - 当前删除的用户
_oMasters - 将被删除的母版
返回：
抛出：
WCMException

query

Masters query(User _oCurrUser,
              WCMFilter _currFilter)
              throws WCMException
查询系统指定母版

参数：
_currFilter - 额外的查询和排序条件
返回：
抛出：
WCMException

export

java.lang.String export(Masters _oMasters)
                        throws WCMException
导出指定的母版

参数：
_oMasters - 将被导出的母版
返回：
抛出：
WCMException

importMasters

Reports importMasters(User _oCurrUser,
                      java.lang.String _sImportMastersFileName)
                      throws WCMException
导入母版

参数：
_oCurrUser - 当前操作的用户
_sImportMastersFileName - 要导入的母板文件名
返回：
抛出：
WCMException

validateMasterFile

java.lang.String validateMasterFile(java.lang.String _sFileName)
                                    throws WCMException
校验母版文件的合法性

参数：
_sFileName - 母版文件，文件名必须是符合WCM规则的文件名,后缀必须是一个ZIP
返回：
如果校验通过返回Null，如果校验不通过返回错误的信息
抛出：
WCMException

getMasterFileContent

java.lang.String getMasterFileContent(Master _oMaster,
                                      int _nFileType)
                                      throws WCMException
获取指定母板中指定文件类型的文件内容

参数：
_oMaster - 母板
_nFileType - 母版文件类型。MASTER_INDEX：专题首页基准模板，值为1；MASTER_OUTLINE：专题下分类首页模板，值为2； MASTER_DETAIL：专题下文档页面模板，值为3
返回：
如果母板中存在该文件，则返回文件内容；否则，返回null
抛出：
WCMException

existsMName

boolean existsMName(int _nObjectId,
                    java.lang.String _sMName)
                    throws java.lang.Exception
校验母板名称是否已存在

参数：
_nObjectId - 母板ID
_sMName - 母板名称
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMasterServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IMasterServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知实现类：
MasterServiceProvider
public interface IMasterServiceProvider
extends IGlueServiceProvider

方法摘要
boolean | existsMName(MethodContext _context) 检查母板名称是否已存在
java.lang.String | export(MethodContext _context) 导出指定ID的母版
java.lang.String | importMasters(MethodContext _context) 导入母版
Master | save(java.lang.String _sMasterName, java.lang.String _sFileName) 创建或者更新母板
java.lang.String | validateMasterFile(MethodContext _context) 校验母版文件的合法性
java.lang.String | validateMasterFile(java.lang.String _sFileName) 校验母版文件的合法性
从接口 com.trs.webframework.provider.IDeleteServiceProvider 继承的方法
delete
从接口 com.trs.webframework.provider.IQueryServiceProvider 继承的方法
query
从接口 com.trs.webframework.provider.ISaveServiceProvider 继承的方法
save
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

方法详细信息

save

Master save(java.lang.String _sMasterName,
            java.lang.String _sFileName)
            throws WCMException
创建或者更新母板

参数：
_sMasterName - 母版名称
_sFileName - 母版文件，在服务器端的文件 （可以是绝对，也可以是单个文件名，单个文件名必须是符合WCM规则的文件名） 后缀必须是一个ZIP
返回：
抛出：
WCMException

validateMasterFile

java.lang.String validateMasterFile(MethodContext _context)
                                    throws java.lang.Exception
校验母版文件的合法性

参数：
_context -
返回：
抛出：
java.lang.Exception

validateMasterFile

java.lang.String validateMasterFile(java.lang.String _sFileName)
                                    throws WCMException
校验母版文件的合法性

参数：
_sFileName - 母版文件，在服务器端的文件 （可以是绝对，也可以是单个文件名，单个文件名必须是符合WCM规则的文件名） 后缀必须是一个ZIP
返回：
如果校验通过返回Null，如果校验不通过返回错误的信息
抛出：
WCMException

export

java.lang.String export(MethodContext _context)
                        throws java.lang.Exception
导出指定ID的母版

参数：
_context -
返回：
抛出：
java.lang.Exception

importMasters

java.lang.String importMasters(MethodContext _context)
                               throws java.lang.Exception
导入母版

参数：
_context -
返回：
抛出：
java.lang.Exception

existsMName

boolean existsMName(MethodContext _context)
                    throws java.lang.Throwable
检查母板名称是否已存在

参数：
_context -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPageStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IPageStyleMgr

所有已知实现类：
PageStyleMgr
public interface IPageStyleMgr

PageStyle业务逻辑层接口

作者：
han

方法摘要
PageStyle | copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle) 仿照指定的页面风格创建一份新的风格
void | delete(User _currUser, PageStyle _pageStyle) 删除指定的页面风格
void | deletePageStyleInfos(User user, PageStyle pageStyle) 删除指定的页面风格的关联信息
java.lang.String | makeBaseStyleContent(PageStyle pageStyle) 生成页面风格基本特性样式
java.lang.String | makePageOtherStyleContent(PageStyle style) 生成页面其他样式
java.lang.String | previewStyle(PageStyle pageStyle, StyleItems styleItems) 获取预览时需要的样式内容
PageStyles | query(WCMFilter _filter) 获取页面风格集合
PageStyle | save(User _currUser, PageStyle _pageStyle) 保存（新增、编辑）页面风格

方法详细信息

save

PageStyle save(User _currUser,
               PageStyle _pageStyle)
               throws WCMException
保存（新增、编辑）页面风格

参数：
_currUser - 当前用户
_pageStyle - 当前页面风格
返回：
抛出：
WCMException

delete

void delete(User _currUser,
            PageStyle _pageStyle)
            throws WCMException
删除指定的页面风格

参数：
_pageStyle - 当前页面风格
抛出：
WCMException

query

PageStyles query(WCMFilter _filter)
                 throws WCMException
获取页面风格集合

参数：
_filter - 外部构造的当前wcmfilter
返回：
查询出来的页面风格集合对象
抛出：
WCMException

copy

PageStyle copy(User _currUser,
               PageStyle _sourcePageStyle,
               PageStyle _targetPageSytle)
               throws WCMException
仿照指定的页面风格创建一份新的风格

参数：
_sourcePageStyle - 指定的源页面风格
返回：
新创建的页面风格对象
抛出：
WCMException

makeBaseStyleContent

java.lang.String makeBaseStyleContent(PageStyle pageStyle)
                                      throws WCMException
生成页面风格基本特性样式

参数：
_pageStyle - 指定的页面风格
返回：
生成的css内容
抛出：
WCMException

previewStyle

java.lang.String previewStyle(PageStyle pageStyle,
                              StyleItems styleItems)
                              throws WCMException
获取预览时需要的样式内容

参数：
_pageStyle - 当前页面风格
_styleItems - 需要预览的样式内容
返回：
返回最后生成的样式内容
抛出：
WCMException

makePageOtherStyleContent

java.lang.String makePageOtherStyleContent(PageStyle style)
                                           throws WCMException
生成页面其他样式

参数：
style - 当前页面风格
返回：
最后生成的页面其他样式
抛出：
WCMException

deletePageStyleInfos

void deletePageStyleInfos(User user,
                          PageStyle pageStyle)
                          throws WCMException
删除指定的页面风格的关联信息

参数：
_pageStyle - 当前页面风格
抛出：
WCMException
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPageStyleServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IPageStyleServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知实现类：
PageStyleServiceProvider
public interface IPageStyleServiceProvider
extends IGlueServiceProvider

风格服务层接口

作者：
han

方法摘要
int | copy(MethodContext context) 类似创建风格,创建风格以及风格中的资源可用风格，内容可用风格等
java.lang.String | exportCssFile(MethodContext context) 导出Css文件
java.lang.String | makeCssFile(MethodContext context) 生成Css文件,返回文件名称
从接口 com.trs.webframework.provider.IDeleteServiceProvider 继承的方法
delete
从接口 com.trs.webframework.provider.IQueryServiceProvider 继承的方法
query
从接口 com.trs.webframework.provider.ISaveServiceProvider 继承的方法
save
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

方法详细信息

exportCssFile

java.lang.String exportCssFile(MethodContext context)
                               throws java.lang.Throwable
导出Css文件

参数：
context -
返回：
抛出：
WCMException
java.lang.Throwable

makeCssFile

java.lang.String makeCssFile(MethodContext context)
                             throws java.lang.Throwable
生成Css文件,返回文件名称

参数：
context -
返回：
抛出：
java.lang.Throwable

copy

int copy(MethodContext context)
         throws java.lang.Throwable
类似创建风格,创建风格以及风格中的资源可用风格，内容可用风格等

参数：
context -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IResourceStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IResourceStyleMgr

所有已知实现类：
ResourceStyleMgr
public interface IResourceStyleMgr

资源可用风格业务逻辑层接口

作者：
han

方法摘要
boolean | checkCssFlag(PageStyle pageStyle, ResourceStyle resourceStyle, java.lang.String cssFlag) 在指定的系统风格下校验指定资源的风格标识（CssFlag）是否唯一
boolean | checkStyleName(PageStyle pageStyle, ResourceStyle resourceStyle, java.lang.String styleName) 在指定的系统风格下校验指定资源的风格名称（StyleName）是否唯一
ResourceStyle | copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
void | delete(User _currUser, ResourceStyle _resourceStyle) 删除ResourceStyle
ResourceStyles | getResourceStyles(PageStyle pageStyle) 获取指定页面风格下的资源可用风格集合
java.lang.String | makeCssContent(ResourceStyle _currResourceStyle) 生成资源的可用风格内容
ResourceStyles | query(PageStyle _currPageStyle, WCMFilter _filter) 获取指定页面风格下的ResourceStyle集合
ResourceStyle | save(User _currUser, ResourceStyle _resourceStyle) 保存（新增、编辑）资源风格

方法详细信息

save

ResourceStyle save(User _currUser,
                   ResourceStyle _resourceStyle)
                   throws WCMException
保存（新增、编辑）资源风格

参数：
_currUser - 当前用户
_resourceStyle - 当前资源风格
返回：
保存后的资源风格对象
抛出：
WCMException

delete

void delete(User _currUser,
            ResourceStyle _resourceStyle)
            throws WCMException
删除ResourceStyle

参数：
_currUser - 当前用户
_resourceStyle - 当前资源风格
抛出：
WCMException

query

ResourceStyles query(PageStyle _currPageStyle,
                     WCMFilter _filter)
                     throws WCMException
获取指定页面风格下的ResourceStyle集合

参数：
_currPageStyle - 当前页面风格
_filter - 外部指定的需要查询的filter
返回：
查询返回的资源风格集合
抛出：
WCMException

makeCssContent

java.lang.String makeCssContent(ResourceStyle _currResourceStyle)
                                throws WCMException
生成资源的可用风格内容

参数：
_currResourceStyle - 当前资源风格
返回：
最后生成的样式内容
抛出：
WCMException

copy

ResourceStyle copy(User _currUser,
                   PageStyle _targetPageStyle,
                   ResourceStyle _sourceResourceStyle,
                   int _nCopyMode,
                   Reports oCopyReports)
                   throws WCMException
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

参数：
_targetPageStyle - 指定的目标页面风格
_sourceResourceStyle - 指定的源资源风格
返回：
新创建的资源风格
抛出：
WCMException

copy

ResourceStyle copy(User _currUser,
                   PageStyle _targetPageStyle,
                   ResourceStyle _sourceResourceStyle)
                   throws WCMException
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

参数：
_targetPageStyle - 指定的目标页面风格
_sourceResourceStyle - 指定的源资源风格
返回：
新创建的资源风格
抛出：
WCMException

checkCssFlag

boolean checkCssFlag(PageStyle pageStyle,
                     ResourceStyle resourceStyle,
                     java.lang.String cssFlag)
                     throws WCMException
在指定的系统风格下校验指定资源的风格标识（CssFlag）是否唯一

参数：
_pageStyle - 指定的页面风格
_currResourceStyle - 需要校验的资源风格
_cssFlag - 需要校验的资源风格的风格标识
返回：
抛出：
WCMException

getResourceStyles

ResourceStyles getResourceStyles(PageStyle pageStyle)
                                 throws WCMException
获取指定页面风格下的资源可用风格集合

参数：
pageStyle - 当前页面风格
返回：
抛出：
WCMException

checkStyleName

boolean checkStyleName(PageStyle pageStyle,
                       ResourceStyle resourceStyle,
                       java.lang.String styleName)
                       throws WCMException
在指定的系统风格下校验指定资源的风格名称（StyleName）是否唯一

参数：
_pageStyle - 指定的页面风格
_currResourceStyle - 需要校验的资源风格
_cssFlag - 需要校验的资源风格的风格名称
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IResourceStyleServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IResourceStyleServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public interface IResourceStyleServiceProvider
extends IGlueServiceProvider

资源可用风格服务层接口

作者：
han

方法摘要
 java.lang.Object copy(MethodContext context)
复制资源可用风格
从接口 com.trs.webframework.provider.IDeleteServiceProvider 继承的方法
delete
从接口 com.trs.webframework.provider.IQueryServiceProvider 继承的方法
query
从接口 com.trs.webframework.provider.ISaveServiceProvider 继承的方法
save
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

方法详细信息

copy

java.lang.Object copy(MethodContext context)
                      throws java.lang.Throwable
复制资源可用风格

参数：
context -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStyleAndResourceMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IStyleAndResourceMgr

所有已知实现类：
StyleAndResourceMgr
public interface IStyleAndResourceMgr

风格与资源的关联关系业务逻辑类

作者：
han

方法摘要
void | delete(User _currUser, StyleAndResource _styleAndResource) 删除风格与资源的关联关系
void | deleteUnuseCSRItems(Widget widget, java.lang.String objectIds) 删除资源与内容风格关联中没有使用的对象
java.util.HashMap | getContentStyleAndResourceMap(Widget systemResource, WCMFilter _filter)
ContentStyles | getContentStyles(Widget _systemResource, WCMFilter _filter) 获取资源对应的内容可用风格
StyleAndResource | save(User _currUser, StyleAndResource _styleAndResource) 保存修改StyleAndResource

方法详细信息

save

StyleAndResource save(User _currUser,
                      StyleAndResource _styleAndResource)
                      throws WCMException
保存修改StyleAndResource

参数：
_currUser -
_styleAndResource -
返回：
抛出：
WCMException

delete

void delete(User _currUser,
            StyleAndResource _styleAndResource)
            throws WCMException
删除风格与资源的关联关系

参数：
_currUser -
_styleAndResource -
抛出：
WCMException

getContentStyles

ContentStyles getContentStyles(Widget _systemResource,
                               WCMFilter _filter)
                               throws WCMException
获取资源对应的内容可用风格

参数：
_systemResource -
返回：
抛出：
WCMException

getContentStyleAndResourceMap

java.util.HashMap getContentStyleAndResourceMap(Widget systemResource,
                                                WCMFilter _filter)
                                                throws WCMException
参数：
systemResource -
apdsFilter -
返回：
抛出：
WCMException

deleteUnuseCSRItems

void deleteUnuseCSRItems(Widget widget,
                         java.lang.String objectIds)
                         throws WCMException
删除资源与内容风格关联中没有使用的对象

参数：
systemResource -
objectIds -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStyleCenterMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IStyleCenterMgr

所有已知实现类：
StyleCenterMgr
public interface IStyleCenterMgr

方法摘要
void | copySystemStyle(User loginUser, PageStyle pageStyle) 在新建页面风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格
void | copyToAllPageSylte(ContentStyle contentStyle) 给所有的风格下面都要建立当前这个内容风格
void | copyToAllPageSylte(ResourceStyle resourceStyle) 给所有的页面风格下面都要建立当前这个资源风格
void | createImgesDir(PageStyle pageStyle) 创建页面风格图片的存放目录
java.lang.String | createStyleFile(User _currUser, PageStyle _currPageStyle) 生成风格文件
void | delStyleThumb(java.lang.String oldStyleThumb) 删除上传的缩略图
java.lang.String | export(PageStyle pageStyle) 导出指定页面风格的样式文件
java.util.HashMap | findCssFlagUsedStyles(PageStyle pageStyle, BaseStyle _oCurrBaseStyle, java.lang.String cssFlag) 当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。
java.lang.String | findStyleImageDir(PageStyle pageStyle) 获取指定页面风格的图片所在目录
java.util.HashMap | findStyleNameUsedStyles(PageStyle _oPageStyle, BaseStyle _oBaseStyle, java.lang.String _sStyleName) 当前页面风格(_oPageStyle)下,除自己以外，名称为_sStyleName的资源风格以及内容风格。
java.io.File | getStyleFile(PageStyle _currPageStyle) 获取风格对应的样式文件
void | importCssFile(PageStyle pageStyle, java.lang.String uploadCssFile) 导入风格文件
java.lang.String | makePreviewCssContent(ContentStyle contentStyle) 获取内容可用风格预览时需要的样式内容
java.lang.String | makePreviewCssContent(ResourceStyle resourceStyle) 获取资源可用风格预览时需要的样式内容
java.lang.String | previewStyle(PageStyle pageStyle, java.lang.String cssFlag, java.lang.String templateName, StyleItems styleItems, java.lang.String customStyle) 预览时，获取风格的内容
void | resetStyle(BaseStyle baseStyle) 将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置
void | saveStyleThumb(java.lang.String styleThumb) 保存上传的缩略图
void | setResoruceStylePrivate(ContentStyle contentStyle) 设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。
void | setResourceStylePrivate(ResourceStyle resourceStyle) 设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。

方法详细信息

createStyleFile

java.lang.String createStyleFile(User _currUser,
                                 PageStyle _currPageStyle)
                                 throws java.lang.Exception
生成风格文件

参数：
_currUser - 当前用户
_currPageStyle - 当前页面风格
抛出：
WCMException
java.lang.Exception

getStyleFile

java.io.File getStyleFile(PageStyle _currPageStyle)
                          throws WCMException
获取风格对应的样式文件

参数：
_currPageStyle - 当前页面风格
返回：
样式文件
抛出：
WCMException

saveStyleThumb

void saveStyleThumb(java.lang.String styleThumb)
                    throws java.lang.Exception
保存上传的缩略图

参数：
styleThumb - 当前上传的缩略图
抛出：
java.lang.Exception

copyToAllPageSylte

void copyToAllPageSylte(ContentStyle contentStyle)
                        throws WCMException
给所有的风格下面都要建立当前这个内容风格

参数：
contentStyle - 内容风格
抛出：
WCMException

makePreviewCssContent

java.lang.String makePreviewCssContent(ContentStyle contentStyle)
                                       throws WCMException
获取内容可用风格预览时需要的样式内容

参数：
contentStyle - 内容风格
返回：
抛出：
WCMException

findCssFlagUsedStyles

java.util.HashMap findCssFlagUsedStyles(PageStyle pageStyle,
                                        BaseStyle _oCurrBaseStyle,
                                        java.lang.String cssFlag)
                                        throws WCMException
当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。

参数：
pageStyle - 指定的页面风格
_oCurrBaseStyle - 需要排除的资源风格或内容风格
cssFlag - 风格标识
返回：
抛出：
WCMException - TrsArcher 2010-5-31下午02:38:05

findStyleNameUsedStyles

java.util.HashMap findStyleNameUsedStyles(PageStyle _oPageStyle,
                                          BaseStyle _oBaseStyle,
                                          java.lang.String _sStyleName)
                                          throws WCMException
当前页面风格(_oPageStyle)下,除自己以外，名称为_sStyleName的资源风格以及内容风格。

参数：
_oPageStyle - 指定的页面风格
_oBaseStyle - 需要排除的资源风格或内容风格
_sStyleName - 风格名称
返回：
抛出：
WCMException - TrsArcher 2010-5-31下午02:38:05

createImgesDir

void createImgesDir(PageStyle pageStyle)
                    throws WCMException
创建页面风格图片的存放目录

参数：
_pageStyle - 指定的页面风格
抛出：
WCMException

copySystemStyle

void copySystemStyle(User loginUser,
                     PageStyle pageStyle)
                     throws java.lang.Exception
在新建页面风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格

参数：
_currUser - 当前用户
pageStyle - 新建的页面风格对象
抛出：
java.lang.Exception

export

java.lang.String export(PageStyle pageStyle)
                        throws java.lang.Exception
导出指定页面风格的样式文件

参数：
_pageStyle - 指定的页面风格
返回：
抛出：
java.lang.Exception

importCssFile

void importCssFile(PageStyle pageStyle,
                   java.lang.String uploadCssFile)
                   throws java.lang.Exception
导入风格文件

参数：
pageStyle - 指定的页面风格
uploadCssFile - 导入的文件
抛出：
java.lang.Exception

findStyleImageDir

java.lang.String findStyleImageDir(PageStyle pageStyle)
                                   throws WCMException
获取指定页面风格的图片所在目录

参数：
pageStyle - 指定的页面风格
返回：
抛出：
WCMException

copyToAllPageSylte

void copyToAllPageSylte(ResourceStyle resourceStyle)
                        throws WCMException
给所有的页面风格下面都要建立当前这个资源风格

参数：
resourceStyle - 指定的资源风格
抛出：
WCMException

makePreviewCssContent

java.lang.String makePreviewCssContent(ResourceStyle resourceStyle)
                                       throws WCMException
获取资源可用风格预览时需要的样式内容

参数：
resourceStyle - 当前资源风格
返回：
生成的样式内容
抛出：
WCMException

resetStyle

void resetStyle(BaseStyle baseStyle)
                throws WCMException
将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置

参数：
baseStyle - 指定的资源风格或内容风格
抛出：
java.lang.Throwable - TrsArcher 2010-6-1下午01:12:48
WCMException

previewStyle

java.lang.String previewStyle(PageStyle pageStyle,
                              java.lang.String cssFlag,
                              java.lang.String templateName,
                              StyleItems styleItems,
                              java.lang.String customStyle)
                              throws WCMException
预览时，获取风格的内容

参数：
_pageStyle -
sCssFlag -
sTemplateName -
_styleItems -
_customStyle -
返回：
抛出：
WCMException

delStyleThumb

void delStyleThumb(java.lang.String oldStyleThumb)
                   throws java.lang.Exception
删除上传的缩略图

参数：
styleThumb -
抛出：
java.lang.Exception

setResourceStylePrivate

void setResourceStylePrivate(ResourceStyle resourceStyle)
                             throws WCMException
设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。

参数：
_resourceStyle -
抛出：
WCMException

setResoruceStylePrivate

void setResoruceStylePrivate(ContentStyle contentStyle)
                             throws WCMException
设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。

参数：
contentStyle -
抛出：
WCMException
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStyleItemMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IStyleItemMgr

所有已知实现类：
StyleItemMgr
public interface IStyleItemMgr

风格内容项业务逻辑层接口

作者：
han

方法摘要
void | delete(User loginUser, BaseStyle currBaseStyle) 删除指定风格对应的风格项（StyleItem）
void | delete(User _currUser, StyleItem _styleItem) 删除StyleItem
void | deleteUnusePageOtherStyleItems(PageStyle pageStyle, java.lang.String objectIds) 删除页面style对应的没有使用的其他风格项
void | deleteUnuseStyleItems(BaseStyle baseStyle, java.lang.String objectIds) 删除指定风格没有使用的风格项
java.util.HashMap | queryPageOtherStyleItemMap(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
StyleItems | queryPageOtherStyleItems(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
java.util.HashMap | queryStyleItemMap(BaseStyle baseStyle, WCMFilter _filter) 获取指定风格的风格项
StyleItems | queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter) 获取某种（页面风格，资源可用风格，内容可用风格）风格下的StyleItem集合
StyleItem | save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem) 保存（新增、编辑）StyleItem
StyleItem | savePageOtherStyleItem(User loginUser, PageStyle pageStyle, StyleItem styleItem) 保存页面风格对应的其他风格属性

方法详细信息

save

StyleItem save(User _currUser,
               BaseStyle _baseStyle,
               StyleItem _styleItem)
               throws WCMException
保存（新增、编辑）StyleItem

参数：
_styleItem -
返回：
抛出：
WCMException

delete

void delete(User _currUser,
            StyleItem _styleItem)
            throws WCMException
删除StyleItem

参数：
_styleItem - 指定的样式元素对象
抛出：
WCMException

queryStyleItems

StyleItems queryStyleItems(BaseStyle _baseStyle,
                           WCMFilter _filter)
                           throws WCMException
获取某种（页面风格，资源可用风格，内容可用风格）风格下的StyleItem集合

参数：
_baseStyle - 指定的页面风格或者资源可用风格或者内容可用风格
_filter - 外部指定的filter
返回：
抛出：
WCMException

savePageOtherStyleItem

StyleItem savePageOtherStyleItem(User loginUser,
                                 PageStyle pageStyle,
                                 StyleItem styleItem)
                                 throws WCMException
保存页面风格对应的其他风格属性

参数：
loginUser - 当前用户
pageStyle - 指定的页面风格
styleItem - 指定的样式属性对象
抛出：
WCMException

delete

void delete(User loginUser,
            BaseStyle currBaseStyle)
            throws WCMException
删除指定风格对应的风格项（StyleItem）

参数：
user - 当前用户
pageStyle - 指定的页面风格或者资源风格或者内容风格
抛出：
WCMException

queryPageOtherStyleItems

StyleItems queryPageOtherStyleItems(PageStyle pageStyle,
                                    WCMFilter _filter)
                                    throws WCMException
获取页面其他风格样式项

参数：
_pageStyle -
_filter -
返回：
抛出：
WCMException

queryPageOtherStyleItemMap

java.util.HashMap queryPageOtherStyleItemMap(PageStyle pageStyle,
                                             WCMFilter _filter)
                                             throws WCMException
获取页面其他风格样式项

参数：
pageStyle -
_filter -
返回：
抛出：
WCMException

queryStyleItemMap

java.util.HashMap queryStyleItemMap(BaseStyle baseStyle,
                                    WCMFilter _filter)
                                    throws WCMException
获取指定风格的风格项

参数：
baseStyle -
_filter -
返回：
抛出：
WCMException

deleteUnuseStyleItems

void deleteUnuseStyleItems(BaseStyle baseStyle,
                           java.lang.String objectIds)
                           throws WCMException
删除指定风格没有使用的风格项

参数：
baseStyle -
objectIds -
抛出：
WCMException

deleteUnusePageOtherStyleItems

void deleteUnusePageOtherStyleItems(PageStyle pageStyle,
                                    java.lang.String objectIds)
                                    throws WCMException
删除页面style对应的没有使用的其他风格项

参数：
_pageStyle -
objectIds -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ISystemContentStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 ISystemContentStyleMgr

所有已知实现类：
SystemContentStyleMgr
public interface ISystemContentStyleMgr

方法摘要
 void copyFor(User user, PageStyle pageStyle)
根据系统默认的内容可用风格为指定的系统风格创建

方法详细信息

copyFor

void copyFor(User user,
             PageStyle pageStyle)
             throws WCMException
根据系统默认的内容可用风格为指定的系统风格创建

参数：
user -
pageStyle -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ISystemResourceStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 ISystemResourceStyleMgr

所有已知实现类：
SystemResourceStyleMgr
public interface ISystemResourceStyleMgr

方法摘要
 void copyFor(User user, PageStyle pageStyle)
根据系统默认的资源可用风格为指定的系统风格创建

方法详细信息

copyFor

void copyFor(User user,
             PageStyle pageStyle)
             throws WCMException
根据系统默认的资源可用风格为指定的系统风格创建

参数：
user -
pageStyle -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IVisualTemplateServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IVisualTemplateServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知实现类：
VisualTemplateServiceProvider
public interface IVisualTemplateServiceProvider
extends IGlueServiceProvider

方法摘要
java.lang.String | copyWidgetInstance(MethodContext _methodContext) 类似创建相同的资源实例，创建后的资源实例与原来的实例拥有相同的资源变量和值 返回创建后的资源实例的可视化编辑模板形式
void | deleteWidgetInstance(MethodContext _methodContext) 删除指定的资源块实例对象
java.lang.String | parseTemplate(MethodContext _methodContext) 将专题对应栏目的模板内容解析成可视化编辑模板形式的字符串
java.lang.String | parseWidgetInstance(MethodContext _methodContext) 将某一个资源块实例解析成可视化编辑模板形式的字符串
java.lang.String | preview(MethodContext _methodContext) 获取指定栏目或文档对象在指定模板内容下的预览内容
int | saveToTemplate(MethodContext _methodContext) 将传入的字符串文本，解析成模板，传入的文本为可视化设计的模板内容，解析之后将建立 资源块实例，资源块实例变量的关系
void | synchronizeWidgetInstances(MethodContext _methodContext) 将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。
从接口 com.trs.webframework.provider.IDeleteServiceProvider 继承的方法
delete
从接口 com.trs.webframework.provider.IQueryServiceProvider 继承的方法
query
从接口 com.trs.webframework.provider.ISaveServiceProvider 继承的方法
save
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

方法详细信息

saveToTemplate

int saveToTemplate(MethodContext _methodContext)
                   throws java.lang.Throwable
将传入的字符串文本，解析成模板，传入的文本为可视化设计的模板内容，解析之后将建立 资源块实例，资源块实例变量的关系

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

parseTemplate

java.lang.String parseTemplate(MethodContext _methodContext)
                               throws java.lang.Throwable
将专题对应栏目的模板内容解析成可视化编辑模板形式的字符串

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

parseWidgetInstance

java.lang.String parseWidgetInstance(MethodContext _methodContext)
                                     throws java.lang.Throwable
将某一个资源块实例解析成可视化编辑模板形式的字符串

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

deleteWidgetInstance

void deleteWidgetInstance(MethodContext _methodContext)
                          throws java.lang.Throwable
删除指定的资源块实例对象

参数：
_methodContext -
抛出：
java.lang.Throwable

synchronizeWidgetInstances

void synchronizeWidgetInstances(MethodContext _methodContext)
                                throws WCMException
将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。 为什么需要同步模板和资源实例的内容？是由于在可视化模板设计过程中 。并没有时刻将可视化模板的内容与使用的实例的内容保持一致，否则将不支持，撤销与同步操作。所以必须在可视化页面退出之后，再进行资源实例的同步处理。

参数：
_methodContext -
抛出：
WCMException

preview

java.lang.String preview(MethodContext _methodContext)
                         throws java.lang.Exception
获取指定栏目或文档对象在指定模板内容下的预览内容

参数：
_methodContext -
抛出：
WCMException
java.lang.Exception

copyWidgetInstance

java.lang.String copyWidgetInstance(MethodContext _methodContext)
                                    throws java.lang.Exception
类似创建相同的资源实例，创建后的资源实例与原来的实例拥有相同的资源变量和值 返回创建后的资源实例的可视化编辑模板形式

参数：
_methodContext -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWidgetInstanceMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IWidgetInstanceMgr

所有已知实现类：
WidgetInstanceMgr
public interface IWidgetInstanceMgr

方法摘要
void | delete(WidgetInstance widgetInstance) 删除资源块实例和其下的所有变量
WidgetInstance | save(User loginUser, WidgetInstance oWidgetInstance) 对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象
WidgetInstance | save(WidgetInstance oWidgetInstance, java.util.Map parameters) 修改指定的资源块实例的变量信息

方法详细信息

save

WidgetInstance save(User loginUser,
                    WidgetInstance oWidgetInstance)
                    throws WCMException
对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象

参数：
loginUser -
oWidgetInstance -
返回：
抛出：
WCMException

save

WidgetInstance save(WidgetInstance oWidgetInstance,
                    java.util.Map parameters)
                    throws WCMException
修改指定的资源块实例的变量信息

参数：
oWidgetInstance -
parameters -
返回：
抛出：
WCMException

delete

void delete(WidgetInstance widgetInstance)
            throws WCMException
删除资源块实例和其下的所有变量

参数：
widgetInstance -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWidgetInstParameterMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IWidgetInstParameterMgr

所有已知实现类：
WidgetInstParameterMgr
public interface IWidgetInstParameterMgr

方法摘要
WidgetInstParameters | addParameters(WidgetInstance oWidgetInstance, java.util.Map parameters) 给资源块实例对象设置相应的资源库实例变量,设置这些变量值之前，将清除该实例之前的所有变量
void | delete(WidgetInstance oWidgetInstance) 清除某个资源实例下的所有资源实例的变量信息
java.util.Map | getParameters(WidgetInstance oWidgetInstance) 根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写 修改说明：先取资源默认的资源变量值，再用资源变量实例值覆盖，防止添加资源变量后 在解析资源代码时有些变量不能替换的问题
java.util.Map | getParameters(WidgetInstance oWidgetInstance, java.lang.String sSelectFields) 根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写
WidgetInstParameter | getWidgetInstParameter(WidgetInstance widgetInstance, java.lang.String sParaName) 获取指定资源块实例下的资源块实例变量
WidgetInstParameters | getWidgetInstParameters(WidgetInstance oWidgetInstance, WCMFilter oFilter) 获取资源块实例关联的资源块实例变量对象集合
WidgetInstParameters | saveParameters(WidgetInstance oWidgetInstance, java.util.Map parameters) 给资源块实例对象设置相应的资源库实例变量，仅仅只是设置这些传入了的变量的值

方法详细信息

getParameters

java.util.Map getParameters(WidgetInstance oWidgetInstance)
                            throws WCMException
根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写 修改说明：先取资源默认的资源变量值，再用资源变量实例值覆盖，防止添加资源变量后 在解析资源代码时有些变量不能替换的问题

参数：
oWidgetInstance -
返回：
抛出：
WCMException

getParameters

java.util.Map getParameters(WidgetInstance oWidgetInstance,
                            java.lang.String sSelectFields)
                            throws WCMException
根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写

参数：
oWidgetInstance -
sSelectFields -
返回：
抛出：
WCMException

getWidgetInstParameters

WidgetInstParameters getWidgetInstParameters(WidgetInstance oWidgetInstance,
                                             WCMFilter oFilter)
                                             throws WCMException
获取资源块实例关联的资源块实例变量对象集合

参数：
oWidgetInstance -
oFilter -
返回：
抛出：
WCMException

getWidgetInstParameter

WidgetInstParameter getWidgetInstParameter(WidgetInstance widgetInstance,
                                           java.lang.String sParaName)
                                           throws WCMException
获取指定资源块实例下的资源块实例变量

参数：
widgetInstance -
sParaName -
返回：
抛出：
WCMException

saveParameters

WidgetInstParameters saveParameters(WidgetInstance oWidgetInstance,
                                    java.util.Map parameters)
                                    throws WCMException
给资源块实例对象设置相应的资源库实例变量，仅仅只是设置这些传入了的变量的值

参数：
oWidgetInstance -
parameters -
返回：
抛出：
WCMException

addParameters

WidgetInstParameters addParameters(WidgetInstance oWidgetInstance,
                                   java.util.Map parameters)
                                   throws WCMException
给资源块实例对象设置相应的资源库实例变量,设置这些变量值之前，将清除该实例之前的所有变量

参数：
oWidgetInstance -
parameters -
抛出：
WCMException

delete

void delete(WidgetInstance oWidgetInstance)
            throws WCMException
清除某个资源实例下的所有资源实例的变量信息

参数：
oWidgetInstance -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWidgetMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IWidgetMgr

所有已知实现类：
WidgetMgr
public interface IWidgetMgr

方法摘要
boolean | delete(User _oCurrUser, Widget _oCurrWidget) 删除资源
java.lang.String | export(Widgets _oWidgets) 导出资源
Widget | findWidgetByName(User _oCurrUser, java.lang.String _sWidgetName) 根据传入的资源块名称，返回找到的第一个资源块对象，如果没有找到合适的资源块对象，则返回null。
Reports | importWidgets(java.lang.String _sFile, int _nImportMode) 导入资源
Widgets | query(User _oCurrUser, WCMFilter _oFilter) 获取资源
Widget | saveWidget(User _oCurrUser, Widget _oCurrWidget) 保存资源

方法详细信息

saveWidget

Widget saveWidget(User _oCurrUser,
                  Widget _oCurrWidget)
                  throws java.lang.Exception
保存资源

参数：
_oCurrUser - 当前保存的用户
_oCurrWidget - 当前要保存的资源片段
返回：
抛出：
java.lang.Exception

query

Widgets query(User _oCurrUser,
              WCMFilter _oFilter)
              throws java.lang.Exception
获取资源

参数：
_oCurrUser - 当前用户
_oFilter - 查询条件
返回：
抛出：
java.lang.Exception

delete

boolean delete(User _oCurrUser,
               Widget _oCurrWidget)
               throws java.lang.Exception
删除资源

参数：
_oCurrUser - 删除的当前用户
_oCurrWidget - 当前要删除的资源片段对象
返回：
抛出：
java.lang.Exception

export

java.lang.String export(Widgets _oWidgets)
                        throws java.lang.Exception
导出资源

参数：
_oWidgets - 资源对象集
返回：
抛出：
java.lang.Exception

importWidgets

Reports importWidgets(java.lang.String _sFile,
                      int _nImportMode)
                      throws java.lang.Exception
导入资源

参数：
_sFile -
_sXslFile -
返回：
抛出：
java.lang.Exception

findWidgetByName

Widget findWidgetByName(User _oCurrUser,
                        java.lang.String _sWidgetName)
                        throws WCMException
根据传入的资源块名称，返回找到的第一个资源块对象，如果没有找到合适的资源块对象，则返回null。id越大，获取时优先级越高

参数：
_oCurrUser - 当前用户
_sWidgetName - 资源块的名称
返回：
抛出：
java.lang.Exception
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWidgetParameterMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IWidgetParameterMgr

所有已知实现类：
WidgetParameterMgr
public interface IWidgetParameterMgr

作者：
wyw

方法摘要
boolean | delete(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 删除资源变量
boolean | existWidgetParameter(Widget _oCurrWidget, WidgetParameter _oCurrWidgetParameter) 判断是否已经存在同名资源变量
WidgetParameter | findParameter(WidgetInstParameter _oWidgetInstParameter) 根据资源变量实例获取到资源变量
WidgetParameter | findParameterByName(Widget _oCurrWidget, java.lang.String sParameterName) 获取指定资源下，指定名称的资源变量
WidgetParameters | query(User _oCurrUser, WCMFilter _oFilter) 获取某资源所具有的资源变量
WidgetParameters | query(Widget _oCurrWidget) 获取资源的所有资源变量
WidgetParameter | saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 保存资源变量

方法详细信息

saveWidgetParameter

WidgetParameter saveWidgetParameter(User _oCurrUser,
                                    WidgetParameter _oCurrWidgetParameter)
                                    throws WCMException
保存资源变量

参数：
_oCurrUser - 保存资源变量的当前用户
_oCurrWidgetParameter - 将要保存的资源变量对象
返回：
抛出：
WCMException

query

WidgetParameters query(User _oCurrUser,
                       WCMFilter _oFilter)
                       throws WCMException
获取某资源所具有的资源变量

参数：
_oCurrUser - 当前用户
_oFilter - 列表查询条件
返回：
抛出：
WCMException

delete

boolean delete(User _oCurrUser,
               WidgetParameter _oCurrWidgetParameter)
               throws WCMException
删除资源变量

参数：
_oCurrUser - 当前删除操作的用户
_oCurrWidgetParameter - 将要删除的资源变量对象
返回：
抛出：
WCMException

existWidgetParameter

boolean existWidgetParameter(Widget _oCurrWidget,
                             WidgetParameter _oCurrWidgetParameter)
                             throws WCMException
判断是否已经存在同名资源变量

参数：
_oCurrWidget - 所属资源对象
_oCurrWidgetParameter - 资源变量对象
返回：
抛出：
WCMException

query

WidgetParameters query(Widget _oCurrWidget)
                       throws WCMException
获取资源的所有资源变量

参数：
_oCurrWidget - 资源对象
返回：
抛出：
java.lang.Exception
WCMException

findParameterByName

WidgetParameter findParameterByName(Widget _oCurrWidget,
                                    java.lang.String sParameterName)
                                    throws WCMException
获取指定资源下，指定名称的资源变量

参数：
_oCurrWidget -
sParameterName -
返回：
抛出：
WCMException

findParameter

WidgetParameter findParameter(WidgetInstParameter _oWidgetInstParameter)
                              throws WCMException
根据资源变量实例获取到资源变量

参数：
_oWidgetInstParameter -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWidgetParameterServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IWidgetParameterServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知实现类：
WidgetParameterServiceProvider
public interface IWidgetParameterServiceProvider
extends IGlueServiceProvider

作者：
wyw

方法摘要
void | changeOrder(MethodContext context) 改变资源变量的顺序
void | delete(MethodContext _context) 删除资源变量
boolean | existsSimilarName(MethodContext context) 判断是否存在相同名称的资源变量
java.lang.Object | query(MethodContext _context) 获取资源变量对象集
int | save(MethodContext _context) 保存当前资源变量
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

方法详细信息

save

int save(MethodContext _context)
         throws java.lang.Exception
保存当前资源变量

指定者：
接口 ISaveServiceProvider 中的 save
参数：
_context -
抛出：
java.lang.Exception

query

java.lang.Object query(MethodContext _context)
                       throws java.lang.Exception
获取资源变量对象集

指定者：
接口 IQueryServiceProvider 中的 query
参数：
_context -
抛出：
java.lang.Exception

delete

void delete(MethodContext _context)
            throws java.lang.Exception
删除资源变量

指定者：
接口 IDeleteServiceProvider 中的 delete
参数：
_context -
抛出：
java.lang.Exception

existsSimilarName

boolean existsSimilarName(MethodContext context)
                          throws java.lang.Exception
判断是否存在相同名称的资源变量

参数：
context -
返回：
抛出：
java.lang.Throwable
java.lang.Exception

changeOrder

void changeOrder(MethodContext context)
                 throws java.lang.Exception
改变资源变量的顺序

参数：
context -
抛出：
java.lang.Throwable
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWidgetServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IWidgetServer

所有已知实现类：
WidgetServer
public interface IWidgetServer

作者：
Administrator

方法摘要
Template | createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType) 根据母版内容，创建新的模板
void | insertStyleTag(Special special, Template template) 专题设置页面风格时所触发的逻辑，将专题所属的首页模板插入含当前页面风格标识的置标，发布时完成风格的切换
java.lang.String | parseToEditContent(IPublishElement _oPageElement, java.lang.String _sTemplateContent) 将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
java.lang.String | parseToEditContent(IPublishElement _oPageElement, Template _oTemplateForEdit) 将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
java.lang.String | parseToEditContent(IPublishElement _oPageElement, WidgetInstance _oWidgetInstance) 解析某一个资源块实例对象成可编辑的状态
java.lang.String | parseToTemplate(java.lang.String sVisaulTemplate) 将可视化模板的内容，解析成相应的模板
java.lang.String | replaceWidgetInstParameters(WidgetInstance widgetInstance) 通过资源实例，获取资源实例的内容，并替换其中的资源实例变量
void | synchronizeWidgetInstances(Template template) 将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。

方法详细信息

parseToEditContent

java.lang.String parseToEditContent(IPublishElement _oPageElement,
                                    java.lang.String _sTemplateContent)
                                    throws java.lang.Exception
将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态

参数：
_oPageElement - 需要解析的发布对象（一般为站点、栏目或文档）
_sTemplateContent - 需要编辑的模板内容
返回：
抛出：
java.lang.Exception

parseToEditContent

java.lang.String parseToEditContent(IPublishElement _oPageElement,
                                    Template _oTemplateForEdit)
                                    throws java.lang.Exception
将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态

参数：
_oPageElement - 需要解析的发布对象（一般为站点、栏目或文档）
_oTemplateForEdit - 需要编辑的模板
返回：
抛出：
java.lang.Exception

parseToEditContent

java.lang.String parseToEditContent(IPublishElement _oPageElement,
                                    WidgetInstance _oWidgetInstance)
                                    throws java.lang.Exception
解析某一个资源块实例对象成可编辑的状态

参数：
_oPageElement - 需要解析的发布对象（一般为站点、栏目或文档）
_oWidgetInstance - 需要解析的资源块实例
返回：
抛出：
java.lang.Exception

createTemplateFromMaster

Template createTemplateFromMaster(IPublishFolder _oPageFolder,
                                  Master _oMaster,
                                  int _nMasterType)
                                  throws WCMException
根据母版内容，创建新的模板

参数：
_oPageFolder - TODO
_oMaster - 依据的母版
返回：
考虑到母版中可能会定义首页、二级页面、细览页面，所以返回模板集合对象
抛出：
WCMException

parseToTemplate

java.lang.String parseToTemplate(java.lang.String sVisaulTemplate)
                                 throws WCMException
将可视化模板的内容，解析成相应的模板

参数：
sVisaulTemplate - 可视化模板的内容，其中的资源实例的html代码格式为：]*>@!@--(\\d+)--@!@，其中的 \\d+为资源实例的id
返回：
解析之后，可以作为模板内容的字符串
抛出：
java.lang.Exception
WCMException

replaceWidgetInstParameters

java.lang.String replaceWidgetInstParameters(WidgetInstance widgetInstance)
                                             throws WCMException
通过资源实例，获取资源实例的内容，并替换其中的资源实例变量

参数：
widgetInstance -
返回：
已经替换了资源实例变量的资源实例的内容
抛出：
java.lang.Exception
WCMException

synchronizeWidgetInstances

void synchronizeWidgetInstances(Template template)
                                throws WCMException
将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。 为什么需要同步模板和资源实例的内容？是由于在可视化模板设计过程中 。并没有时刻将可视化模板的内容与使用的实例的内容保持一致，否则将不支持，撤销与同步操作。所以必须在可视化页面退出之后，再进行资源实例的同步处理。

参数：
template -
抛出：
WCMException

insertStyleTag

void insertStyleTag(Special special,
                    Template template)
                    throws WCMException,
                           java.lang.Exception
专题设置页面风格时所触发的逻辑，将专题所属的首页模板插入含当前页面风格标识的置标，发布时完成风格的切换

参数：
template -
抛出：
WCMException
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWidgetServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
接口 IWidgetServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知实现类：
WidgetServiceProvider
public interface IWidgetServiceProvider
extends IGlueServiceProvider

方法摘要
void | delete(MethodContext _context) 删除资源片段
boolean | existsSimilarName(MethodContext _context) 检查是否有同名模板
java.lang.String | export(MethodContext _context) 导入资源
java.lang.String | importWidgets(MethodContext _context) 导出资源
java.lang.Object | query(MethodContext _context) 获取资源片段集
int | save(MethodContext _context) 保存当前资源片段
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

方法详细信息

save

int save(MethodContext _context)
         throws java.lang.Exception
保存当前资源片段

指定者：
接口 ISaveServiceProvider 中的 save
参数：
_context -
抛出：
java.lang.Exception

query

java.lang.Object query(MethodContext _context)
                       throws java.lang.Exception
获取资源片段集

指定者：
接口 IQueryServiceProvider 中的 query
参数：
_context -
抛出：
java.lang.Exception

delete

void delete(MethodContext _context)
            throws java.lang.Exception
删除资源片段

指定者：
接口 IDeleteServiceProvider 中的 delete
参数：
_context -
抛出：
java.lang.Exception

importWidgets

java.lang.String importWidgets(MethodContext _context)
                               throws java.lang.Exception
导出资源

参数：
_context -
返回：
抛出：
java.lang.Exception

export

java.lang.String export(MethodContext _context)
                        throws java.lang.Exception
导入资源

参数：
_context -
返回：
抛出：
java.lang.Exception

existsSimilarName

boolean existsSimilarName(MethodContext _context)
                          throws java.lang.Exception
检查是否有同名模板

参数：
_context -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Layout

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 Layout

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.Layout
所有已实现的接口：
java.lang.Cloneable
public class Layout
extends CMSObj

字段摘要
static java.lang.String | ADAPTIVE_CHAR 布局比例中表示自适应列的字符
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | MAX_COLUMNS 最大列数
static int | OBJ_TYPE 对象类型编号
static java.lang.String | RATIO_FIXED_WIDTH 布局固定比宽度单位
static java.lang.String | RATIO_PERCENTAGE_WIDTH 布局百分比单位
static java.lang.String | RATIO_SEPERATE 布局比例值间隔字符
static int | RATIO_TYPE_FIXED 布局比例类型，固定比
static int | RATIO_TYPE_PERCENTAGE 布局比例类型，百分比
构造方法摘要
Layout()
构造函数：保留默认接口
方法摘要
static Layout | createNewInstance() 产生当前对象[Layout]的实例
static Layout | findById(int _nId) 提取指定ID的对象
static Layout | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getColumns() 提取属性：Columns
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getHtmlContent() 提取属性：HtmlContent
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getName() 提取属性：Name
java.lang.String | getRatio() 提取属性：Ratio
int | getRatioType() 提取属性：RatioType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setColumns(int _nColumns) 设置属性：Columns
boolean | setHtmlContent(java.lang.String _sHtmlContent) 设置属性：HtmlContent
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setRatio(java.lang.String _sRatio) 设置属性：Ratio
boolean | setRatioType(int _nRatioType) 设置属性：RatioType
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

RATIO_TYPE_FIXED

public static int RATIO_TYPE_FIXED
布局比例类型，固定比

RATIO_TYPE_PERCENTAGE

public static int RATIO_TYPE_PERCENTAGE
布局比例类型，百分比

RATIO_FIXED_WIDTH

public static java.lang.String RATIO_FIXED_WIDTH
布局固定比宽度单位

RATIO_PERCENTAGE_WIDTH

public static java.lang.String RATIO_PERCENTAGE_WIDTH
布局百分比单位

MAX_COLUMNS

public static int MAX_COLUMNS
最大列数

RATIO_SEPERATE

public static java.lang.String RATIO_SEPERATE
布局比例值间隔字符

ADAPTIVE_CHAR

public static java.lang.String ADAPTIVE_CHAR
布局比例中表示自适应列的字符

构造方法详细信息

Layout

public Layout()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getColumns

public int getColumns()
提取属性：Columns

返回：
Columns

setColumns

public boolean setColumns(int _nColumns)
                   throws WCMException
设置属性：Columns

参数：
_nColumns - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRatioType

public int getRatioType()
提取属性：RatioType

返回：
RatioType

setRatioType

public boolean setRatioType(int _nRatioType)
                     throws WCMException
设置属性：RatioType

参数：
_nRatioType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRatio

public java.lang.String getRatio()
提取属性：Ratio

返回：
Ratio

setRatio

public boolean setRatio(java.lang.String _sRatio)
                 throws WCMException
设置属性：Ratio

参数：
_sRatio - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHtmlContent

public java.lang.String getHtmlContent()
提取属性：HtmlContent

返回：
HtmlContent

setHtmlContent

public boolean setHtmlContent(java.lang.String _sHtmlContent)
                       throws WCMException
设置属性：HtmlContent

参数：
_sHtmlContent - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final Layout findById(int _nId)
                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Layout createNewInstance()
                                      throws WCMException
产生当前对象[Layout]的实例

返回：
当前对象的实例[Layout]
抛出：
WCMException

findByKey

public static final Layout findByKey(java.lang.Object _oKey)
                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutGenerator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 LayoutGenerator

java.lang.Object
    继承者  com.trs.components.common.publish.widget.LayoutGenerator
所有已实现的接口：
ILayoutGenerator
public class LayoutGenerator
extends java.lang.Object
implements ILayoutGenerator

布局相关HTML代码和CSS样式生成类 实现接口：ILayoutGenerator

作者：
hdg

字段摘要
从接口 com.trs.components.common.publish.widget.ILayoutGenerator 继承的字段
COLUMN_CLASS, EMPTY_COLUMN_HTML, LAYOUT_CLASS
构造方法摘要
LayoutGenerator()
方法摘要
void | deleteCss(Layout _currLayout) 删除当前布局对应的css样式
java.lang.String | generateHtml(Layout _currLayout, boolean _bCssInHtml) 产生布局的相关HTML代码
java.lang.String | generateHtml(Layout _currLayout, boolean _bCssInHtml, boolean _bColIndexAsText) 产生布局的HTML代码和CSS代码
boolean | validateHtml(Layout layout) 验证布局的HTML内容是否符合规范 （扩展用，暂不实现）
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LayoutGenerator

public LayoutGenerator()
方法详细信息

generateHtml

public java.lang.String generateHtml(Layout _currLayout,
                                     boolean _bCssInHtml,
                                     boolean _bColIndexAsText)
                              throws WCMException
产生布局的HTML代码和CSS代码

指定者：
接口 ILayoutGenerator 中的 generateHtml
参数：
_currLayout - 当前布局
_bCssInHtml - 是否将样式内容写到HTML代码中，如果为false，则将创建一个布局对象。解析模板时将该参数设置成true;
_bColIndexAsText - 是否使用布局的列索引作为布局的填充内容，使用索引填充的目的，是为了方便利用String.format接口，进行布局内容的替换， 如果为false，则可能使用默认文字进行填充
返回：
抛出：
WCMException

generateHtml

public java.lang.String generateHtml(Layout _currLayout,
                                     boolean _bCssInHtml)
                              throws WCMException
产生布局的相关HTML代码

指定者：
接口 ILayoutGenerator 中的 generateHtml
参数：
_currLayout - 当前布局对象
_bCssInHtml - 是否将CSS样式附加到HTML代码中
返回：
抛出：
WCMException

deleteCss

public void deleteCss(Layout _currLayout)
               throws WCMException
删除当前布局对应的css样式

指定者：
接口 ILayoutGenerator 中的 deleteCss
参数：
_currLayout - 当前布局
抛出：
WCMException

validateHtml

public boolean validateHtml(Layout layout)
                     throws WCMException
验证布局的HTML内容是否符合规范 （扩展用，暂不实现）

指定者：
接口 ILayoutGenerator 中的 validateHtml
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 LayoutMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.LayoutMgr
所有已实现的接口：
ILayoutMgr
public class LayoutMgr
extends java.lang.Object
implements ILayoutMgr

专题布局业务层，处理布局保存，删除，查询等逻辑

作者：
hdg

构造方法摘要
LayoutMgr()
方法摘要
boolean | delete(User _oCurrUser, Layout _currLayout) 删除指定的布局
boolean | delete(User _oCurrUser, Layouts _oLayouts) 删除布局的集合
Layout | findLayoutByName(User _currUser, java.lang.String sLayoutName) 根据传入的布局名称，返回找到的第一个布局对象，如果没有找到合适的布局对象，则返回null。
Layouts | query(User _currUser, WCMFilter _filter) 通过条件查询布局
Layout | save(User _oCurrUser, Layout _currLayout) 保存当前布局，若ID为0则为创建布局,将样式文件写到文件上，不保存到HTML代码中
boolean | validate(Layout _currLayout) 验证布局属性信息，包括比例和HTML内容
boolean | validateRatio(Layout _currLayout) 验证布局比例是否符合规范(包括比例类型和比例值)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LayoutMgr

public LayoutMgr()
方法详细信息

save

public Layout save(User _oCurrUser,
                   Layout _currLayout)
            throws WCMException
保存当前布局，若ID为0则为创建布局,将样式文件写到文件上，不保存到HTML代码中

指定者：
接口 ILayoutMgr 中的 save
参数：
_oCurrUser - 当前登录用户
_currLayout - 需要保存的布局对象
返回：
抛出：
WCMException

delete

public boolean delete(User _oCurrUser,
                      Layout _currLayout)
               throws WCMException
删除指定的布局

参数：
_oCurrUser - 当前登录用户
_currLayout - 当前布局
返回：
抛出：
WCMException

delete

public boolean delete(User _oCurrUser,
                      Layouts _oLayouts)
               throws WCMException
删除布局的集合

指定者：
接口 ILayoutMgr 中的 delete
参数：
_oCurrUser - 当前登录用户
_oLayouts - 布局集合
返回：
抛出：
WCMException

validateRatio

public boolean validateRatio(Layout _currLayout)
                      throws WCMException
验证布局比例是否符合规范(包括比例类型和比例值)

参数：
_currLayout - 当前布局
返回：
抛出：
WCMException

validate

public boolean validate(Layout _currLayout)
                 throws WCMException
验证布局属性信息，包括比例和HTML内容

指定者：
接口 ILayoutMgr 中的 validate
参数：
_currLayout - 布局对象
返回：
抛出：
WCMException

query

public Layouts query(User _currUser,
                     WCMFilter _filter)
              throws WCMException
通过条件查询布局

指定者：
接口 ILayoutMgr 中的 query
参数：
_filter - 查询条件
返回：
抛出：
WCMException

findLayoutByName

public Layout findLayoutByName(User _currUser,
                               java.lang.String sLayoutName)
                        throws WCMException
从接口 ILayoutMgr 复制的描述
根据传入的布局名称，返回找到的第一个布局对象，如果没有找到合适的布局对象，则返回null。id越大，获取时优先级越高

指定者：
接口 ILayoutMgr 中的 findLayoutByName
sLayoutName - 布局的名称
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Layouts

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 Layouts

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.Layouts

public class Layouts
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Layouts(User _currUser)
构造函数
Layouts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Layouts | createNewInstance(User _currUser) 产生当前集合对象[Layouts]的实例
static Layouts | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Layouts | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Layouts]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Layouts

public Layouts(User _currUser)
构造函数

另请参见：
Layouts( User _currUser, int _initCapacity, int _incCapacity );

Layouts

public Layouts(User _currUser,
               int _initCapacity,
               int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final Layouts findByIds(User _currUser,
                                      java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Layouts）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Layouts openWCMObjs(User _currUser,
                                        WCMFilter _filter)
                                 throws WCMException
通过指定一个Filter获取当前集合[Layouts]

参数：
_filter - 指定的Filter
返回：
当前集合[Layouts]
抛出：
WCMException

createNewInstance

public static Layouts createNewInstance(User _currUser)
产生当前集合对象[Layouts]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 LayoutServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.LayoutServiceProvider
所有已实现的接口：
ILayoutServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class LayoutServiceProvider
extends java.lang.Object
implements ILayoutServiceProvider

构造方法摘要
LayoutServiceProvider()
方法摘要
void | delete(MethodContext context) 删除布局
java.lang.Object | findById(MethodContext context) 获取某个布局
java.lang.Object | findByIds(MethodContext context) 获取布局集合
java.lang.String | getLayoutHtml(MethodContext context) 通过web页面发送布局比例类型和布局比例信息来获取到相应的HTML代码,该服务需要将布局的样式信息写到HTML代码中
java.lang.Object | query(MethodContext context) 查询布局
int | save(MethodContext context) 保存布局
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LayoutServiceProvider

public LayoutServiceProvider()
方法详细信息

delete

public void delete(MethodContext context)
            throws WCMException
删除布局

指定者：
接口 ILayoutServiceProvider 中的 delete
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
WCMException

query

public java.lang.Object query(MethodContext context)
                       throws WCMException
查询布局

指定者：
接口 ILayoutServiceProvider 中的 query
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
WCMException

save

public int save(MethodContext context)
         throws WCMException
保存布局

指定者：
接口 ILayoutServiceProvider 中的 save
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
WCMException

getLayoutHtml

public java.lang.String getLayoutHtml(MethodContext context)
                               throws WCMException
通过web页面发送布局比例类型和布局比例信息来获取到相应的HTML代码,该服务需要将布局的样式信息写到HTML代码中

指定者：
接口 ILayoutServiceProvider 中的 getLayoutHtml
参数：
context -
返回：
抛出：
WCMException

findById

public java.lang.Object findById(MethodContext context)
                          throws WCMException
获取某个布局

指定者：
接口 ILayoutServiceProvider 中的 findById
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
WCMException

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws WCMException
获取布局集合

指定者：
接口 ILayoutServiceProvider 中的 findByIds
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Master

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 Master

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.Master
所有已实现的接口：
java.lang.Cloneable
public class Master
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | MASTER_DETAIL 专题下的文档页面模板
static int | MASTER_INDEX 专题下的首页基准模板
static int | MASTER_OUTLINE 专题下的分类首页模板
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Master()
构造函数：保留默认接口
方法摘要
static Master | createNewInstance() 产生当前对象[Master]的实例
static Master | findById(int _nId) 提取指定ID的对象
static Master | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getFileName() 提取属性：FileName
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getMDesc() 提取属性：MDesc
java.lang.String | getMName() 提取属性：MName
java.lang.String | getPicFileName() 提取属性：PicFileName
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setFileName(java.lang.String _sFileName) 设置属性：FileName
boolean | setMDesc(java.lang.String _sMDesc) 设置属性：MDesc
boolean | setMName(java.lang.String _sMName) 设置属性：MName
boolean | setPicFileName(java.lang.String _sPicFileName) 设置属性：PicFileName
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

MASTER_INDEX

public static final int MASTER_INDEX
专题下的首页基准模板

另请参见：
常量字段值

MASTER_OUTLINE

public static final int MASTER_OUTLINE
专题下的分类首页模板

另请参见：
常量字段值

MASTER_DETAIL

public static final int MASTER_DETAIL
专题下的文档页面模板

另请参见：
常量字段值
构造方法详细信息

Master

public Master()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getMName

public java.lang.String getMName()
提取属性：MName

返回：
MName

setMName

public boolean setMName(java.lang.String _sMName)
                 throws WCMException
设置属性：MName

参数：
_sMName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMDesc

public java.lang.String getMDesc()
提取属性：MDesc

返回：
MDesc

setMDesc

public boolean setMDesc(java.lang.String _sMDesc)
                 throws WCMException
设置属性：MDesc

参数：
_sMDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFileName

public java.lang.String getFileName()
提取属性：FileName

返回：
FileName

setFileName

public boolean setFileName(java.lang.String _sFileName)
                    throws WCMException
设置属性：FileName

参数：
_sFileName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPicFileName

public java.lang.String getPicFileName()
提取属性：PicFileName

返回：
PicFileName

setPicFileName

public boolean setPicFileName(java.lang.String _sPicFileName)
                       throws WCMException
设置属性：PicFileName

参数：
_sPicFileName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final Master findById(int _nId)
                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Master createNewInstance()
                                      throws WCMException
产生当前对象[Master]的实例

返回：
当前对象的实例[Master]
抛出：
WCMException

findByKey

public static final Master findByKey(java.lang.Object _oKey)
                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MasterMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 MasterMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.MasterMgr
所有已实现的接口：
IMasterMgr
public class MasterMgr
extends java.lang.Object
implements IMasterMgr

作者：
Administrator

构造方法摘要
MasterMgr()
方法摘要
boolean | delete(User _oCurrUser, Masters _oMasters) 删除母板
boolean | existsMName(int _nObjectId, java.lang.String _sMName) 校验母板名称是否已存在
java.lang.String | export(Masters _oMasters) 导出母板
java.lang.String | getMasterFileContent(Master oMaster, int _nFileType) 获取指定母板中指定文件类型的文件内容
Reports | importMasters(User _oCurrUser, java.lang.String _sImportMastersFileName) 导入母板
Masters | query(User _oCurrUser, WCMFilter _oFilter) 查询系统指定的母板
Master | save(User _oUser, Master _oMaster) 保存当前母板
Master | save(User _oUser, java.lang.String _sMasterName, java.lang.String _sFileName) 保存当前母板
java.lang.String | validateMasterFile(java.lang.String _sFileName) 校验母版文件的合法性
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MasterMgr

public MasterMgr()
方法详细信息

save

public Master save(User _oUser,
                   java.lang.String _sMasterName,
                   java.lang.String _sFileName)
            throws WCMException
保存当前母板

指定者：
接口 IMasterMgr 中的 save
参数：
_oCurrUser - 当前操作的用户
_sMasterName - 母版名称
_sFileName - 母版对应的文件，必须是WCM规则的文件名
返回：
抛出：
WCMException

save

public Master save(User _oUser,
                   Master _oMaster)
            throws WCMException
保存当前母板

指定者：
接口 IMasterMgr 中的 save
参数：
_oCurrUser - 当前操作的用户
_oMaster - 当前母板
返回：
抛出：
WCMException

delete

public boolean delete(User _oCurrUser,
                      Masters _oMasters)
               throws WCMException
删除母板

指定者：
接口 IMasterMgr 中的 delete
参数：
_oCurrUser - 当前操作的用户
_oMasters - 要删除的母版集合
返回：
抛出：
WCMException

export

public java.lang.String export(Masters _oMasters)
                        throws WCMException
导出母板

指定者：
接口 IMasterMgr 中的 export
参数：
_oMasters - 要导出的母版集合
返回：
抛出：
WCMException

importMasters

public Reports importMasters(User _oCurrUser,
                             java.lang.String _sImportMastersFileName)
                      throws WCMException
导入母板

指定者：
接口 IMasterMgr 中的 importMasters
参数：
_oCurrUser - 当前操作的用户
_sImportMastersFileName - 要导入的母板文件名
返回：
抛出：
WCMException

existsMName

public boolean existsMName(int _nObjectId,
                           java.lang.String _sMName)
                    throws java.lang.Exception
校验母板名称是否已存在

指定者：
接口 IMasterMgr 中的 existsMName
参数：
_nObjectId - 母板ID
_sMName - 母板名称
返回：
抛出：
java.lang.Exception

query

public Masters query(User _oCurrUser,
                     WCMFilter _oFilter)
              throws WCMException
查询系统指定的母板

指定者：
接口 IMasterMgr 中的 query
参数：
_oCurrUser - 当前操作的用户
_oFilter - 额外的查询和排序条件
返回：
抛出：
WCMException

validateMasterFile

public java.lang.String validateMasterFile(java.lang.String _sFileName)
                                    throws WCMException
校验母版文件的合法性

指定者：
接口 IMasterMgr 中的 validateMasterFile
参数：
_sFileName - 母版文件，文件名必须是符合WCM规则的文件名,后缀必须是一个ZIP
返回：
如果校验通过返回Null，如果校验不通过返回错误的信息
抛出：
WCMException

getMasterFileContent

public java.lang.String getMasterFileContent(Master oMaster,
                                             int _nFileType)
                                      throws WCMException
获取指定母板中指定文件类型的文件内容

指定者：
接口 IMasterMgr 中的 getMasterFileContent
参数：
_oMaster - 母板
_nFileType - 母版文件类型。MASTER_INDEX（1）：专题首页基准模板；MASTER_OUTLINE（2）：专题下分类首页模板； MASTER_DETAIL（3）：专题下文档页面模板
返回：
如果母板中存在该文件，则返回文件内容；否则，返回null
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Masters

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 Masters

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.Masters

public class Masters
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Masters(User _currUser)
构造函数
Masters(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Masters | createNewInstance(User _currUser) 产生当前集合对象[Masters]的实例
static Masters | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Masters | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Masters]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Masters

public Masters(User _currUser)
构造函数

另请参见：
Masters( User _currUser, int _initCapacity, int _incCapacity );

Masters

public Masters(User _currUser,
               int _initCapacity,
               int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final Masters findByIds(User _currUser,
                                      java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Masters）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Masters openWCMObjs(User _currUser,
                                        WCMFilter _filter)
                                 throws WCMException
通过指定一个Filter获取当前集合[Masters]

参数：
_filter - 指定的Filter
返回：
当前集合[Masters]
抛出：
WCMException

createNewInstance

public static Masters createNewInstance(User _currUser)
产生当前集合对象[Masters]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MasterServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 MasterServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.MasterServiceProvider
所有已实现的接口：
IMasterServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class MasterServiceProvider
extends java.lang.Object
implements IMasterServiceProvider

作者：
Administrator

构造方法摘要
MasterServiceProvider()
方法摘要
void | delete(MethodContext _oContext) 删除指定Id的母板
boolean | existsMName(MethodContext _oContext) 校验母板名称是否已存在
java.lang.String | export(MethodContext _oContext) 导出指定Id的母板
java.lang.Object | findById(MethodContext _oContext) 获取指定Id的母板
java.lang.Object | findByIds(MethodContext _oContext) 获取指定的Id序列的母板集合
java.lang.String | importMasters(MethodContext _oContext) 导入母板
java.lang.Object | query(MethodContext _oContext) 查询母板
java.lang.Object | queryMasterByContentType(MethodContext _oContext) 获取指定类型文件不为空的母版集合
int | save(MethodContext _oContext) 保存母板
Master | save(java.lang.String _sMasterName, java.lang.String _sFileName) 根据母板名称以及母板的文件名保存母板
java.lang.String | validateMasterFile(MethodContext _oContext) 校验母板文件的合法性
java.lang.String | validateMasterFile(java.lang.String _sFileName) 校验母板文件的合法性
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MasterServiceProvider

public MasterServiceProvider()
方法详细信息

export

public java.lang.String export(MethodContext _oContext)
                        throws java.lang.Exception
导出指定Id的母板

指定者：
接口 IMasterServiceProvider 中的 export
参数：
_oContext -
返回：
导出的母板文件名
抛出：
java.lang.Exception

save

public int save(MethodContext _oContext)
         throws java.lang.Throwable
保存母板

指定者：
接口 ISaveServiceProvider 中的 save
参数：
_oContext -
返回：
母板Id
抛出：
java.lang.Throwable

save

public Master save(java.lang.String _sMasterName,
                   java.lang.String _sFileName)
            throws WCMException
根据母板名称以及母板的文件名保存母板

指定者：
接口 IMasterServiceProvider 中的 save
参数：
_sMasterName - 母板名称
_sFileName - 母版文件，在服务器端的文件 （可以是绝对，也可以是单个文件名，单个文件名必须是符合WCM规则的文件名） 后缀必须是一个ZIP
返回：
母板
抛出：
WCMException

validateMasterFile

public java.lang.String validateMasterFile(MethodContext _oContext)
                                    throws java.lang.Exception
校验母板文件的合法性

指定者：
接口 IMasterServiceProvider 中的 validateMasterFile
参数：
_oContext -
返回：
校验通过返回null，校验不通过返回错误信息
抛出：
java.lang.Exception

validateMasterFile

public java.lang.String validateMasterFile(java.lang.String _sFileName)
                                    throws WCMException
校验母板文件的合法性

指定者：
接口 IMasterServiceProvider 中的 validateMasterFile
参数：
_sFileName - 母版文件，在服务器端的文件 （可以是绝对，也可以是单个文件名，单个文件名必须是符合WCM规则的文件名） 后缀必须是一个ZIP
返回：
校验通过返回null，校验不通过返回错误信息
抛出：
WCMException

delete

public void delete(MethodContext _oContext)
            throws java.lang.Throwable
删除指定Id的母板

指定者：
接口 IDeleteServiceProvider 中的 delete
参数：
_oContext -
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _oContext)
                       throws java.lang.Throwable
查询母板

指定者：
接口 IQueryServiceProvider 中的 query
参数：
_oContext -
返回：
得到的母板集合
抛出：
java.lang.Throwable

queryMasterByContentType

public java.lang.Object queryMasterByContentType(MethodContext _oContext)
                                          throws java.lang.Throwable
获取指定类型文件不为空的母版集合

返回：
母版集合
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _oContext)
                          throws java.lang.Throwable
获取指定Id的母板

指定者：
接口 IFindByIdServiceProvider 中的 findById
参数：
_oContext -
返回：
指定Id的母板
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _oContext)
                           throws java.lang.Throwable
获取指定的Id序列的母板集合

指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
参数：
_oContext -
返回：
母板集合
抛出：
java.lang.Throwable

importMasters

public java.lang.String importMasters(MethodContext _oContext)
                               throws java.lang.Exception
导入母板

指定者：
接口 IMasterServiceProvider 中的 importMasters
参数：
_oContext -
返回：
抛出：
java.lang.Exception

existsMName

public boolean existsMName(MethodContext _oContext)
                    throws java.lang.Throwable
校验母板名称是否已存在

指定者：
接口 IMasterServiceProvider 中的 existsMName
参数：
_oContext - 上下文对象
返回：
如果存在，则返回true；否则返回false。
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.publish.widget
接口
IContentStyleMgr
IContentStyleServiceProvider
ILayoutGenerator
ILayoutMgr
ILayoutServiceProvider
IMasterMgr
IMasterServiceProvider
IPageStyleMgr
IPageStyleServiceProvider
IResourceStyleMgr
IResourceStyleServiceProvider
IStyleAndResourceMgr
IStyleCenterMgr
IStyleItemMgr
ISystemContentStyleMgr
ISystemResourceStyleMgr
IVisualTemplateServiceProvider
IWidgetInstanceMgr
IWidgetInstParameterMgr
IWidgetMgr
IWidgetParameterMgr
IWidgetParameterServiceProvider
IWidgetServer
IWidgetServiceProvider
类
AdjustJsLCListenerWidget
BaseStyle
ContentStyle
ContentStyleExporter
ContentStyleImporter
ContentStyleMgr
ContentStyles
ContentStyleServiceProvider
ContentStyleXmlConverter
Layout
LayoutGenerator
LayoutMgr
Layouts
LayoutServiceProvider
Master
MasterMgr
Masters
MasterServiceProvider
PageStyle
PageStyleExporter
PageStyleImporter
PageStyleMgr
PageStyles
PageStyleServiceProvider
PageStyleXmlConverter
ResourceStyle
ResourceStyleExporter
ResourceStyleImporter
ResourceStyleMgr
ResourceStyles
ResourceStyleServiceProvider
ResourceStyleXmlConverter
SpecialAuthServer
StyleAndResource
StyleAndResourceMgr
StyleAndResources
StyleCenterMgr
StyleConstants
StyleHelper
StyleItem
StyleItemMgr
StyleItems
StyleItemServiceProvider
StylePathHelper
StyleRepeatNameHelper
SubjectDataInitHelper
SystemContentStyleMgr
SystemResourceStyleMgr
TemplateLCListenerVisualTemplate
VisualTemplateServiceProvider
Widget
WidgetConstants
WidgetInstance
WidgetInstanceMgr
WidgetInstances
WidgetInstParameter
WidgetInstParameterMgr
WidgetInstParameters
WidgetMgr
WidgetParameter
WidgetParameterMgr
WidgetParameters
WidgetParameterServiceProvider
WidgetParameterType
WidgetParameterTypes
WidgetPathHelper
Widgets
WidgetServer
WidgetServiceProvider
WidgetXmlConverter


com.trs.components.common.publish.widget

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.widget

接口摘要
IContentStyleMgr | 内容可用风格业务逻辑层接口
IContentStyleServiceProvider | 内容可用风格服务层接口
ILayoutGenerator |
ILayoutMgr |
ILayoutServiceProvider |
IMasterMgr |
IMasterServiceProvider |
IPageStyleMgr | PageStyle业务逻辑层接口
IPageStyleServiceProvider | 风格服务层接口
IResourceStyleMgr | 资源可用风格业务逻辑层接口
IResourceStyleServiceProvider | 资源可用风格服务层接口
IStyleAndResourceMgr | 风格与资源的关联关系业务逻辑类
IStyleCenterMgr |
IStyleItemMgr | 风格内容项业务逻辑层接口
ISystemContentStyleMgr |
ISystemResourceStyleMgr |
IVisualTemplateServiceProvider |
IWidgetInstanceMgr |
IWidgetInstParameterMgr |
IWidgetMgr |
IWidgetParameterMgr |
IWidgetParameterServiceProvider |
IWidgetServer |
IWidgetServiceProvider |

类摘要
AdjustJsLCListenerWidget | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
BaseStyle | 风格抽象类
ContentStyle |
ContentStyleExporter | 内容风格导出器
ContentStyleImporter | 内容风格的导入代码
ContentStyleMgr | 内容可用风格业务逻辑实现类
ContentStyles |
ContentStyleServiceProvider | 内容可用风格服务层
ContentStyleXmlConverter | 内容风格导出xml转换器
Layout |
LayoutGenerator | 布局相关HTML代码和CSS样式生成类 实现接口：ILayoutGenerator
LayoutMgr | 专题布局业务层，处理布局保存，删除，查询等逻辑
Layouts |
LayoutServiceProvider |
Master |
MasterMgr |
Masters |
MasterServiceProvider |
PageStyle |
PageStyleExporter | 页面风格的导出类。
PageStyleImporter |
PageStyleMgr | 系统风格业务逻辑类
PageStyles |
PageStyleServiceProvider | 页面风格服务层
PageStyleXmlConverter |
ResourceStyle |
ResourceStyleExporter |
ResourceStyleImporter | 资源风格的导入器
ResourceStyleMgr | 资源可用风格业务逻辑实现类
ResourceStyles |
ResourceStyleServiceProvider | 资源可用风格服务层
ResourceStyleXmlConverter |
SpecialAuthServer | 专题制作选件权限判断相关类，定义了一些权限索引位及权限判断接口; 按照使用专题制作选件的三类用户进行权限划分： 1.网站编辑，进行专题维护 2.美工，进行风格维护 3.技术人员，进行资源，布局及母板的扩展
StyleAndResource |
StyleAndResourceMgr |
StyleAndResources |
StyleCenterMgr |
StyleConstants | 定义风格所有常量
StyleHelper | 风格设计辅助类
StyleItem |
StyleItemMgr | 风格项业务逻辑类
StyleItems |
StyleItemServiceProvider | 风格项服务
StylePathHelper |
StyleRepeatNameHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
SubjectDataInitHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
SystemContentStyleMgr | 系统级别资源可用风格
SystemResourceStyleMgr |
TemplateLCListenerVisualTemplate | 当可视化模板进行保存或修改的时候，需要将模板和资源实例建立去关联关系。
VisualTemplateServiceProvider |
Widget |
WidgetConstants |
WidgetInstance |
WidgetInstanceMgr |
WidgetInstances |
WidgetInstParameter |
WidgetInstParameterMgr |
WidgetInstParameters |
WidgetMgr |
WidgetParameter |
WidgetParameterMgr |
WidgetParameters |
WidgetParameterServiceProvider |
WidgetParameterType |
WidgetParameterTypes |
WidgetPathHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
Widgets |
WidgetServer |
WidgetServiceProvider |
WidgetXmlConverter |


com.trs.components.common.publish.widget 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.widget 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.widget.AdjustJsLCListenerWidget (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.publish.widget.BaseStyle
          • com.trs.components.common.publish.widget.ContentStyle
          • com.trs.components.common.publish.widget.PageStyle
          • com.trs.components.common.publish.widget.ResourceStyle
        • com.trs.components.common.publish.widget.Layout
        • com.trs.components.common.publish.widget.Master
        • com.trs.components.common.publish.widget.StyleAndResource
        • com.trs.components.common.publish.widget.StyleItem
        • com.trs.components.common.publish.widget.Widget
        • com.trs.components.common.publish.widget.WidgetInstance
        • com.trs.components.common.publish.widget.WidgetInstParameter
        • com.trs.components.common.publish.widget.WidgetParameter
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.publish.widget.ContentStyles
        • com.trs.components.common.publish.widget.Layouts
        • com.trs.components.common.publish.widget.Masters
        • com.trs.components.common.publish.widget.PageStyles
        • com.trs.components.common.publish.widget.ResourceStyles
        • com.trs.components.common.publish.widget.StyleAndResources
        • com.trs.components.common.publish.widget.StyleItems
        • com.trs.components.common.publish.widget.WidgetInstances
        • com.trs.components.common.publish.widget.WidgetInstParameters
        • com.trs.components.common.publish.widget.WidgetParameters
        • com.trs.components.common.publish.widget.Widgets
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.components.common.publish.widget.ContentStyleXmlConverter
      • com.trs.components.common.publish.widget.PageStyleXmlConverter
      • com.trs.components.common.publish.widget.ResourceStyleXmlConverter
      • com.trs.components.common.publish.widget.WidgetXmlConverter
    • com.trs.components.common.publish.widget.ContentStyleExporter
    • com.trs.components.common.publish.widget.ContentStyleImporter
    • com.trs.components.common.publish.widget.ContentStyleMgr (implements com.trs.components.common.publish.widget.IContentStyleMgr)
    • com.trs.components.common.publish.widget.ContentStyleServiceProvider (implements com.trs.components.common.publish.widget.IContentStyleServiceProvider)
    • com.trs.components.common.publish.widget.LayoutGenerator (implements com.trs.components.common.publish.widget.ILayoutGenerator)
    • com.trs.components.common.publish.widget.LayoutMgr (implements com.trs.components.common.publish.widget.ILayoutMgr)
    • com.trs.components.common.publish.widget.LayoutServiceProvider (implements com.trs.components.common.publish.widget.ILayoutServiceProvider)
    • com.trs.components.common.publish.widget.MasterMgr (implements com.trs.components.common.publish.widget.IMasterMgr)
    • com.trs.components.common.publish.widget.MasterServiceProvider (implements com.trs.components.common.publish.widget.IMasterServiceProvider)
    • com.trs.components.common.publish.widget.PageStyleExporter
    • com.trs.components.common.publish.widget.PageStyleImporter
    • com.trs.components.common.publish.widget.PageStyleMgr (implements com.trs.components.common.publish.widget.IPageStyleMgr)
    • com.trs.components.common.publish.widget.PageStyleServiceProvider (implements com.trs.components.common.publish.widget.IPageStyleServiceProvider)
    • com.trs.components.common.publish.widget.ResourceStyleExporter
    • com.trs.components.common.publish.widget.ResourceStyleImporter
    • com.trs.components.common.publish.widget.ResourceStyleMgr (implements com.trs.components.common.publish.widget.IResourceStyleMgr)
    • com.trs.components.common.publish.widget.ResourceStyleServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.common.publish.widget.SpecialAuthServer
    • com.trs.components.common.publish.widget.StyleAndResourceMgr (implements com.trs.components.common.publish.widget.IStyleAndResourceMgr)
    • com.trs.components.common.publish.widget.StyleCenterMgr (implements com.trs.components.common.publish.widget.IStyleCenterMgr)
    • com.trs.components.common.publish.widget.StyleConstants
    • com.trs.components.common.publish.widget.StyleHelper
    • com.trs.components.common.publish.widget.StyleItemMgr (implements com.trs.components.common.publish.widget.IStyleItemMgr)
    • com.trs.components.common.publish.widget.StyleItemServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.common.publish.widget.StylePathHelper
    • com.trs.components.common.publish.widget.StyleRepeatNameHelper
    • com.trs.components.common.publish.widget.SubjectDataInitHelper
    • com.trs.components.common.publish.widget.SystemContentStyleMgr (implements com.trs.components.common.publish.widget.ISystemContentStyleMgr)
    • com.trs.components.common.publish.widget.SystemResourceStyleMgr (implements com.trs.components.common.publish.widget.ISystemResourceStyleMgr)
    • com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.common.publish.widget.VisualTemplateServiceProvider (implements com.trs.components.common.publish.widget.IVisualTemplateServiceProvider)
    • com.trs.components.common.publish.widget.WidgetConstants
    • com.trs.components.common.publish.widget.WidgetInstanceMgr (implements com.trs.components.common.publish.widget.IWidgetInstanceMgr)
    • com.trs.components.common.publish.widget.WidgetInstParameterMgr (implements com.trs.components.common.publish.widget.IWidgetInstParameterMgr)
    • com.trs.components.common.publish.widget.WidgetMgr (implements com.trs.components.common.publish.widget.IWidgetMgr)
    • com.trs.components.common.publish.widget.WidgetParameterMgr (implements com.trs.components.common.publish.widget.IWidgetParameterMgr)
    • com.trs.components.common.publish.widget.WidgetParameterServiceProvider (implements com.trs.components.common.publish.widget.IWidgetParameterServiceProvider)
    • com.trs.components.common.publish.widget.WidgetParameterType
    • com.trs.components.common.publish.widget.WidgetParameterTypes
    • com.trs.components.common.publish.widget.WidgetPathHelper
    • com.trs.components.common.publish.widget.WidgetServer (implements com.trs.components.common.publish.widget.IWidgetServer)
    • com.trs.components.common.publish.widget.WidgetServiceProvider (implements com.trs.components.common.publish.widget.IWidgetServiceProvider)

接口分层结构

  • com.trs.components.common.publish.widget.IContentStyleMgr
  • com.trs.components.common.publish.widget.ILayoutGenerator
  • com.trs.components.common.publish.widget.ILayoutMgr
  • com.trs.components.common.publish.widget.IMasterMgr
  • com.trs.components.common.publish.widget.IPageStyleMgr
  • com.trs.components.common.publish.widget.IResourceStyleMgr
  • com.trs.webframework.provider.IServiceProvider
    • com.trs.webframework.provider.IDeleteServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.IFindByIdServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.IFindByIdsServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.IQueryServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.ISaveServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
    • com.trs.webframework.provider.ISelfDefinedServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider)
        • com.trs.components.common.publish.widget.IContentStyleServiceProvider
        • com.trs.components.common.publish.widget.ILayoutServiceProvider
        • com.trs.components.common.publish.widget.IMasterServiceProvider
        • com.trs.components.common.publish.widget.IPageStyleServiceProvider
        • com.trs.components.common.publish.widget.IResourceStyleServiceProvider
        • com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
        • com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
        • com.trs.components.common.publish.widget.IWidgetServiceProvider
  • com.trs.components.common.publish.widget.IStyleAndResourceMgr
  • com.trs.components.common.publish.widget.IStyleCenterMgr
  • com.trs.components.common.publish.widget.IStyleItemMgr
  • com.trs.components.common.publish.widget.ISystemContentStyleMgr
  • com.trs.components.common.publish.widget.ISystemResourceStyleMgr
  • com.trs.components.common.publish.widget.IWidgetInstanceMgr
  • com.trs.components.common.publish.widget.IWidgetInstParameterMgr
  • com.trs.components.common.publish.widget.IWidgetMgr
  • com.trs.components.common.publish.widget.IWidgetParameterMgr
  • com.trs.components.common.publish.widget.IWidgetServer


软件包 com.trs.components.common.publish.widget 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.widget
的使用

使用 com.trs.components.common.publish.widget 的软件包
com.trs.components.common.publish.widget
com.trs.components.special

com.trs.components.common.publish.widget 使用的 com.trs.components.common.publish.widget 中的类
BaseStyle
风格抽象类
ContentStyle
ContentStyles
IContentStyleMgr
内容可用风格业务逻辑层接口
IContentStyleServiceProvider
内容可用风格服务层接口
ILayoutGenerator
ILayoutMgr
ILayoutServiceProvider
IMasterMgr
IMasterServiceProvider
IPageStyleMgr
PageStyle业务逻辑层接口
IPageStyleServiceProvider
风格服务层接口
IResourceStyleMgr
资源可用风格业务逻辑层接口
IStyleAndResourceMgr
风格与资源的关联关系业务逻辑类
IStyleCenterMgr
IStyleItemMgr
风格内容项业务逻辑层接口
ISystemContentStyleMgr
ISystemResourceStyleMgr
IVisualTemplateServiceProvider
IWidgetInstanceMgr
IWidgetInstParameterMgr
IWidgetMgr
IWidgetParameterMgr
IWidgetParameterServiceProvider
IWidgetServer
IWidgetServiceProvider
Layout
Layouts
Master
Masters
PageStyle
PageStyles
ResourceStyle
ResourceStyles
StyleAndResource
StyleAndResources
StyleItem
StyleItems
Widget
WidgetInstance
WidgetInstances
WidgetInstParameter
WidgetInstParameters
WidgetParameter
WidgetParameters
WidgetParameterType
WidgetParameterTypes
Widgets

com.trs.components.special 使用的 com.trs.components.common.publish.widget 中的类
PageStyle

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageStyle

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 PageStyle

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.BaseStyle
                继承者  com.trs.components.common.publish.widget.PageStyle
所有已实现的接口：
java.lang.Cloneable
public class PageStyle
extends BaseStyle

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
PageStyle()
构造函数：保留默认接口
方法摘要
static PageStyle | createNewInstance() 产生当前对象[PageStyle]的实例
static PageStyle | findById(int _nId) 提取指定ID的对象
static PageStyle | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static PageStyle | findByName(java.lang.String _sName) 获取指定名称的风格
java.lang.String | getCustomStyle() 提取属性：自定义样式
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getIsImport() 提取属性：是否是导入的对象
int | getIsPublish() 提取属性：是否发布
int | getSrcPageStyleId() 提取属性：源页面风格ID
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
void | setAddMode(boolean _bAddMode)
boolean | setCustomStyle(java.lang.String _sCustomStyle) 设置属性：自定义样式
boolean | setIsImport(int _nIsImport) 设置属性：是否是导入的对象
boolean | setIsPublish(int _nIsPublish) 设置属性：是否发布
boolean | setSrcPageStyleId(int _sSrcPageStyleId) 设置属性：源页面风格
从类 com.trs.components.common.publish.widget.BaseStyle 继承的方法
getStyleDesc, getStyleName, getStyleThumb, getTemplate, setStyleDesc, setStyleName, setStyleThumb, setTemplate
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

PageStyle

public PageStyle()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getCustomStyle

public java.lang.String getCustomStyle()
提取属性：自定义样式

返回：
自定义样式

setCustomStyle

public boolean setCustomStyle(java.lang.String _sCustomStyle)
                       throws WCMException
设置属性：自定义样式

参数：
_sCustomStyle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIsPublish

public int getIsPublish()
提取属性：是否发布

返回：
是否发布

setIsPublish

public boolean setIsPublish(int _nIsPublish)
                     throws WCMException
设置属性：是否发布

参数：
_nIsPublish - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIsImport

public int getIsImport()
提取属性：是否是导入的对象

返回：
是否是导入的对象

setIsImport

public boolean setIsImport(int _nIsImport)
                    throws WCMException
设置属性：是否是导入的对象

参数：
_nIsImport - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSrcPageStyleId

public int getSrcPageStyleId()
提取属性：源页面风格ID

返回：
源页面风格ID

setSrcPageStyleId

public boolean setSrcPageStyleId(int _sSrcPageStyleId)
                          throws WCMException
设置属性：源页面风格

参数：
_sSrcPageStyleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final PageStyle findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final PageStyle createNewInstance()
                                         throws WCMException
产生当前对象[PageStyle]的实例

返回：
当前对象的实例[PageStyle]
抛出：
WCMException

findByKey

public static final PageStyle findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByName

public static final PageStyle findByName(java.lang.String _sName)
                                  throws WCMException
获取指定名称的风格

参数：
_sName -
返回：
抛出：
WCMException

setAddMode

public void setAddMode(boolean _bAddMode)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageStyleExporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 PageStyleExporter

java.lang.Object
    继承者  com.trs.components.common.publish.widget.PageStyleExporter

public class PageStyleExporter
extends java.lang.Object

页面风格的导出类。导出对象为：PageStyle

作者：
rey2008

构造方法摘要
PageStyleExporter()
构造方法
方法摘要
java.lang.String | export(PageStyles _currPageStyles, boolean _bReturnXMLContent) 导出一个页面风格到xml文件中。
void | setXMLEncoding(java.lang.String _sXMLEncoding) 设置导出文件的编码格式
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageStyleExporter

public PageStyleExporter()
构造方法

方法详细信息

export

public java.lang.String export(PageStyles _currPageStyles,
                               boolean _bReturnXMLContent)
                        throws java.lang.Exception
导出一个页面风格到xml文件中。

参数：
_currPageStyle - 页面风格对象
_bReturnXMLContent - 是否直接返回xml内容
返回：
抛出：
java.lang.Exception

setXMLEncoding

public void setXMLEncoding(java.lang.String _sXMLEncoding)
设置导出文件的编码格式

参数：
_sXMLEncoding -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageStyleImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 PageStyleImporter

java.lang.Object
    继承者  com.trs.components.common.publish.widget.PageStyleImporter

public class PageStyleImporter
extends java.lang.Object

作者：
rey2008

构造方法摘要
PageStyleImporter()
构造函数
方法摘要
java.lang.String | checkPageStyleNameExists(java.lang.String _sZipFile) 检查当前上传的zip文件中的PageStyle对象名称是否已经存在
Reports | importFromFile(java.lang.String _sFile) 从zip文件中导入PageStyle的信息。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageStyleImporter

public PageStyleImporter()
构造函数

方法详细信息

importFromFile

public Reports importFromFile(java.lang.String _sFile)
                       throws java.lang.Exception
从zip文件中导入PageStyle的信息。

参数：
_sFile - zip文件的名称，如：ST20100526388775315675.zip
返回：
抛出：
WCMException
java.lang.Exception

checkPageStyleNameExists

public java.lang.String checkPageStyleNameExists(java.lang.String _sZipFile)
                                          throws java.lang.Exception
检查当前上传的zip文件中的PageStyle对象名称是否已经存在

参数：
_sZipFile -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 PageStyleMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.PageStyleMgr
所有已实现的接口：
IPageStyleMgr
public class PageStyleMgr
extends java.lang.Object
implements IPageStyleMgr

系统风格业务逻辑类

作者：
han

构造方法摘要
PageStyleMgr()
构造方法
方法摘要
boolean | checkStyleDesc(PageStyle _oCurrPageStyle) 判断是否已经存在同名的风格
boolean | checkStyleName(PageStyle _oCurrPageStyle) 判断是否已经存在同名的风格
PageStyle | copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle) 仿照PageStyle创建一份新的风格
void | delete(User _currUser, PageStyle pageStyle) 删除PageStyle
void | deletePageStyleInfos(User _currUser, PageStyle pageStyle) 删除页面风格的关联信息
java.lang.String | makeBaseStyleContent(PageStyle _pageStyle) 生成页面基本特性样式
java.lang.String | makePageOtherStyleContent(PageStyle _pageStyle) 生成页面其他样式
java.lang.String | previewStyle(PageStyle _pageStyle, StyleItems _styleItems) 获取预览时需要的样式内容
PageStyles | query(WCMFilter _filter) 获取PageStyle集合
PageStyle | save(User user, PageStyle pageStyle) 只保存风格的基本属性，不负责保存关联对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageStyleMgr

public PageStyleMgr()
构造方法

方法详细信息

copy

public PageStyle copy(User _currUser,
                      PageStyle _sourcePageStyle,
                      PageStyle _targetPageSytle)
               throws WCMException
仿照PageStyle创建一份新的风格

指定者：
接口 IPageStyleMgr 中的 copy
参数：
_sourcePageStyle -
返回：
抛出：
WCMException

delete

public void delete(User _currUser,
                   PageStyle pageStyle)
            throws WCMException
删除PageStyle

指定者：
接口 IPageStyleMgr 中的 delete
参数：
_pageStyle -
抛出：
WCMException

deletePageStyleInfos

public void deletePageStyleInfos(User _currUser,
                                 PageStyle pageStyle)
                          throws WCMException
删除页面风格的关联信息

指定者：
接口 IPageStyleMgr 中的 deletePageStyleInfos
参数：
_pageStyle -
抛出：
WCMException

query

public PageStyles query(WCMFilter _filter)
                 throws WCMException
获取PageStyle集合

指定者：
接口 IPageStyleMgr 中的 query
参数：
_filter -
返回：
抛出：
WCMException

save

public PageStyle save(User user,
                      PageStyle pageStyle)
               throws WCMException
只保存风格的基本属性，不负责保存关联对象

指定者：
接口 IPageStyleMgr 中的 save
参数：
user - 当前用户
pageStyle - 当前页面风格
返回：
抛出：
WCMException

makeBaseStyleContent

public java.lang.String makeBaseStyleContent(PageStyle _pageStyle)
                                      throws WCMException
生成页面基本特性样式

指定者：
接口 IPageStyleMgr 中的 makeBaseStyleContent
参数：
_pageStyle -
返回：
抛出：
WCMException

makePageOtherStyleContent

public java.lang.String makePageOtherStyleContent(PageStyle _pageStyle)
                                           throws WCMException
生成页面其他样式

指定者：
接口 IPageStyleMgr 中的 makePageOtherStyleContent
参数：
style -
返回：
抛出：
WCMException

previewStyle

public java.lang.String previewStyle(PageStyle _pageStyle,
                                     StyleItems _styleItems)
                              throws WCMException
获取预览时需要的样式内容

指定者：
接口 IPageStyleMgr 中的 previewStyle
参数：
_pageStyle -
_styleItems -
返回：
抛出：
WCMException

checkStyleName

public boolean checkStyleName(PageStyle _oCurrPageStyle)
                       throws WCMException
判断是否已经存在同名的风格

参数：
_oCurrPageStyle - 当前新建或修改的风格对象
返回：
抛出：
WCMException

checkStyleDesc

public boolean checkStyleDesc(PageStyle _oCurrPageStyle)
                       throws WCMException
判断是否已经存在同名的风格

参数：
_oCurrPageStyle - 当前新建或修改的风格对象
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageStyles

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 PageStyles

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.PageStyles

public class PageStyles
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
PageStyles(User _currUser)
构造函数
PageStyles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static PageStyles | createNewInstance(User _currUser) 产生当前集合对象[PageStyles]的实例
static PageStyles | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static PageStyles | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PageStyles]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageStyles

public PageStyles(User _currUser)
构造函数

另请参见：
PageStyles( User _currUser, int _initCapacity, int _incCapacity );

PageStyles

public PageStyles(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final PageStyles findByIds(User _currUser,
                                         java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（PageStyles）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final PageStyles openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[PageStyles]

参数：
_filter - 指定的Filter
返回：
当前集合[PageStyles]
抛出：
WCMException

createNewInstance

public static PageStyles createNewInstance(User _currUser)
产生当前集合对象[PageStyles]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageStyleServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 PageStyleServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.PageStyleServiceProvider
所有已实现的接口：
IPageStyleServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class PageStyleServiceProvider
extends java.lang.Object
implements IPageStyleServiceProvider

页面风格服务层

作者：
han

构造方法摘要
PageStyleServiceProvider()
构造方法
方法摘要
java.lang.String | checkExistPageStyle(MethodContext context) 检查当前上传的zip文件中的PageStyle对象名称是否已经存在！
boolean | checkStyleDesc(MethodContext context) 检查风格中文（显示）名称是否唯一
boolean | checkStyleName(MethodContext context) 检查风格英文名称是否唯一
int | copy(MethodContext context) 类似创建风格,创建风格以及风格中的资源可用风格，内容可用风格等
void | delete(MethodContext context) 删除指定的风格 context中需要传递参数ObjectIds，来指定待删除的风格id序列，多个id之间用逗号分隔
void | deleteUploadImages(MethodContext _context) 删除页面风格下指定名称的上传图片
java.lang.String | exportCssFile(MethodContext context) 导出Css文件
java.lang.String | exportPageStyleZip(MethodContext context) 导出一个页面风格对象到zip文件中，zip文件中包含这个页面风格的所有相关文件 组织好的待导出的文件是存放在系统临时目录下
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.lang.String | findStyleImageDir(MethodContext context) 获取风格中上传的图片路径(服务器端的物理地址)
void | importCssFile(MethodContext context) 导入风格文件
java.lang.String | importPageStyleZip(MethodContext context) 从一个zip文件中导入页面风格的相关内容，包括该页面风格的所有相关内容 其中参数PageStyleZipFile支持全路径
java.lang.String | makeCssFile(MethodContext context) 生成Css文件,返回文件名称，生成一个风格英文名称+.css的文件到wcmdata下的template/style/style_css
java.lang.String | makePreviewCssContent(MethodContext _context) 获取预览时需要的样式内容
java.lang.String | previewStyle(MethodContext _context) 获取预览页面基本特性时需要的样式内容 参数为ObjectId和StyleItemXML(一个xml串) StyleItemXML格式类似于
java.lang.Object | query(MethodContext context) 根据指定的条件获取页面风格集合
PageStyles | queryPageStyles(MethodContext _context) 获取系统所有可供选择的系统风格
java.util.ArrayList | queryUploadImageFileList(MethodContext _context) 获取指定页面风格下的所有上传的图片名称，图片名称放到一个ArrayList中
int | save(MethodContext context) 保存当前风格
int | saveBaseStyle(MethodContext context) 保存风格的页面特性 需要传递参数ObjectId和StyleItemXML是一个xml串， 格式类似于
int | saveCustomStyle(MethodContext context) 保存风格的自定义风格 服务中需要传递参数ObjectId和CustomStyle，CustomStyle是自定义的样式
int | savePageOtherStyle(MethodContext context) 保存风格的其他风格属性
int | saveStyleThumb(MethodContext context) 保存上传的风格示意图，该缩略图必须已经上传到webpic下
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageStyleServiceProvider

public PageStyleServiceProvider()
构造方法

方法详细信息

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
删除指定的风格 context中需要传递参数ObjectIds，来指定待删除的风格id序列，多个id之间用逗号分隔

指定者：
接口 IDeleteServiceProvider 中的 delete
参数：
context -
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
根据指定的条件获取页面风格集合

指定者：
接口 IQueryServiceProvider 中的 query
参数：
context -
返回：
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
保存当前风格

指定者：
接口 ISaveServiceProvider 中的 save
参数：
context -
返回：
抛出：
java.lang.Throwable

saveBaseStyle

public int saveBaseStyle(MethodContext context)
                  throws java.lang.Throwable
保存风格的页面特性 需要传递参数ObjectId和StyleItemXML是一个xml串， 格式类似于 ]]>

参数：
context -
返回：
返回当前风格的id
抛出：
java.lang.Throwable

saveCustomStyle

public int saveCustomStyle(MethodContext context)
                    throws java.lang.Throwable
保存风格的自定义风格 服务中需要传递参数ObjectId和CustomStyle，CustomStyle是自定义的样式

参数：
context -
返回：
抛出：
java.lang.Throwable

saveStyleThumb

public int saveStyleThumb(MethodContext context)
                   throws java.lang.Throwable
保存上传的风格示意图，该缩略图必须已经上传到webpic下

参数：
context -
返回：
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

exportCssFile

public java.lang.String exportCssFile(MethodContext context)
                               throws java.lang.Throwable
导出Css文件

指定者：
接口 IPageStyleServiceProvider 中的 exportCssFile
参数：
context -
返回：
风格文件名称
抛出：
WCMException
java.lang.Throwable

exportPageStyleZip

public java.lang.String exportPageStyleZip(MethodContext context)
                                    throws java.lang.Throwable
导出一个页面风格对象到zip文件中，zip文件中包含这个页面风格的所有相关文件 组织好的待导出的文件是存放在系统临时目录下

参数：
context -
返回：
抛出：
java.lang.Throwable

importPageStyleZip

public java.lang.String importPageStyleZip(MethodContext context)
                                    throws java.lang.Throwable
从一个zip文件中导入页面风格的相关内容，包括该页面风格的所有相关内容 其中参数PageStyleZipFile支持全路径

参数：
context -
抛出：
java.lang.Throwable

checkExistPageStyle

public java.lang.String checkExistPageStyle(MethodContext context)
                                     throws java.lang.Throwable
检查当前上传的zip文件中的PageStyle对象名称是否已经存在！

参数：
context -
返回：
抛出：
java.lang.Throwable

importCssFile

public void importCssFile(MethodContext context)
                   throws java.lang.Throwable
导入风格文件

参数：
context -
抛出：
java.lang.Throwable

makeCssFile

public java.lang.String makeCssFile(MethodContext context)
                             throws java.lang.Throwable
生成Css文件,返回文件名称，生成一个风格英文名称+.css的文件到wcmdata下的template/style/style_css

指定者：
接口 IPageStyleServiceProvider 中的 makeCssFile
参数：
context -
返回：
抛出：
java.lang.Throwable

copy

public int copy(MethodContext context)
         throws java.lang.Throwable
类似创建风格,创建风格以及风格中的资源可用风格，内容可用风格等

指定者：
接口 IPageStyleServiceProvider 中的 copy
参数：
context -
返回：
抛出：
java.lang.Throwable

checkStyleName

public boolean checkStyleName(MethodContext context)
                       throws WCMException
检查风格英文名称是否唯一

参数：
context -
返回：
抛出：
WCMException

checkStyleDesc

public boolean checkStyleDesc(MethodContext context)
                       throws WCMException
检查风格中文（显示）名称是否唯一

参数：
context -
返回：
抛出：
WCMException

findStyleImageDir

public java.lang.String findStyleImageDir(MethodContext context)
                                   throws WCMException
获取风格中上传的图片路径(服务器端的物理地址)

参数：
context -
返回：
抛出：
WCMException

makePreviewCssContent

public java.lang.String makePreviewCssContent(MethodContext _context)
                                       throws java.lang.Throwable
获取预览时需要的样式内容

参数：
_context -
返回：
抛出：
java.lang.Throwable

previewStyle

public java.lang.String previewStyle(MethodContext _context)
                              throws java.lang.Throwable
获取预览页面基本特性时需要的样式内容 参数为ObjectId和StyleItemXML(一个xml串) StyleItemXML格式类似于]]>

参数：
_context -
返回：
返回的内容为结合此xml以及样式的模板解析出来的一段css
抛出：
java.lang.Throwable

queryPageStyles

public PageStyles queryPageStyles(MethodContext _context)
                           throws java.lang.Throwable
获取系统所有可供选择的系统风格

参数：
_context -
返回：
抛出：
java.lang.Throwable

savePageOtherStyle

public int savePageOtherStyle(MethodContext context)
                       throws java.lang.Throwable
保存风格的其他风格属性

参数：
context -
返回：
抛出：
java.lang.Throwable

queryUploadImageFileList

public java.util.ArrayList queryUploadImageFileList(MethodContext _context)
                                             throws java.lang.Throwable
获取指定页面风格下的所有上传的图片名称，图片名称放到一个ArrayList中

参数：
context -
返回：
抛出：
java.lang.Throwable

deleteUploadImages

public void deleteUploadImages(MethodContext _context)
                        throws java.lang.Throwable
删除页面风格下指定名称的上传图片

参数：
_context -
抛出：
java.lang.Throwable
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageStyleXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 PageStyleXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.common.publish.widget.PageStyleXmlConverter

public class PageStyleXmlConverter
extends BaseObjToXmlConverter

作者：
rey2008

构造方法摘要
PageStyleXmlConverter()
构造函数
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageStyleXmlConverter

public PageStyleXmlConverter()
构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceStyle

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ResourceStyle

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.BaseStyle
                继承者  com.trs.components.common.publish.widget.ResourceStyle
所有已实现的接口：
java.lang.Cloneable
public class ResourceStyle
extends BaseStyle

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ResourceStyle()
构造函数：保留默认接口
方法摘要
static ResourceStyle | createNewInstance() 产生当前对象[ResourceStyle]的实例
static ResourceStyle | findById(int _nId) 提取指定ID的对象
static ResourceStyle | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getCssFlag() 提取属性：风格标识
java.lang.String | getCustomStyle() 提取属性：自定义的风格样式
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getIsPrivate() 提取属性：是否是私有对象
int | getPageStyleId() 提取属性：页面风格ID
int | getSrcResourceStyleId() 提取属性：源资源风格ID
java.lang.String | getStyleThumb() 提取属性：风格缩略图
java.lang.String | getTemplate() 提取属性：风格样式模板
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setCssFlag(java.lang.String _sCssFlag) 设置属性：风格标识
boolean | setCustomStyle(java.lang.String _sCustomStyle) 设置属性：自定义的风格样式
boolean | setIsPrivate(int _nIsPrivate) 设置属性：是否是私有对象
boolean | setPageStyleId(int _nPageStyleId) 设置属性：页面风格ID
boolean | setSrcResourceStyleId(int _nSrcResourceStyleId) 设置属性：源资源风格ID
boolean | setStyleThumb(java.lang.String _sStyleThumb) 设置属性：风格缩略图
boolean | setTemplate(java.lang.String _sTempalte) 设置属性：风格样式模板
从类 com.trs.components.common.publish.widget.BaseStyle 继承的方法
getStyleDesc, getStyleName, setStyleDesc, setStyleName
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ResourceStyle

public ResourceStyle()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getCssFlag

public java.lang.String getCssFlag()
提取属性：风格标识

返回：
当前对象的风格标识

setCssFlag

public boolean setCssFlag(java.lang.String _sCssFlag)
                   throws WCMException
设置属性：风格标识

参数：
_sCssFlag - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyleThumb

public java.lang.String getStyleThumb()
提取属性：风格缩略图

覆盖：
类 BaseStyle 中的 getStyleThumb
返回：
当前风格对象的缩略图

setStyleThumb

public boolean setStyleThumb(java.lang.String _sStyleThumb)
                      throws WCMException
设置属性：风格缩略图

覆盖：
类 BaseStyle 中的 setStyleThumb
参数：
_sStyleThumb - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPageStyleId

public int getPageStyleId()
提取属性：页面风格ID

返回：
页面风格ID

setPageStyleId

public boolean setPageStyleId(int _nPageStyleId)
                       throws WCMException
设置属性：页面风格ID

参数：
_nPageStyleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSrcResourceStyleId

public int getSrcResourceStyleId()
提取属性：源资源风格ID

返回：
当前对象的源资源风格ID

setSrcResourceStyleId

public boolean setSrcResourceStyleId(int _nSrcResourceStyleId)
                              throws WCMException
设置属性：源资源风格ID

参数：
_nSrcResourceStyleId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTemplate

public java.lang.String getTemplate()
提取属性：风格样式模板

覆盖：
类 BaseStyle 中的 getTemplate
返回：
风格样式模板

setTemplate

public boolean setTemplate(java.lang.String _sTempalte)
                    throws WCMException
设置属性：风格样式模板

覆盖：
类 BaseStyle 中的 setTemplate
参数：
_sTempalte - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCustomStyle

public java.lang.String getCustomStyle()
提取属性：自定义的风格样式

返回：
自定义的风格样式

setCustomStyle

public boolean setCustomStyle(java.lang.String _sCustomStyle)
                       throws WCMException
设置属性：自定义的风格样式

参数：
_sCustomStyle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIsPrivate

public int getIsPrivate()
提取属性：是否是私有对象

返回：
是否是私有对象

setIsPrivate

public boolean setIsPrivate(int _nIsPrivate)
                     throws WCMException
设置属性：是否是私有对象

参数：
_nIsPrivate - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final ResourceStyle findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ResourceStyle createNewInstance()
                                             throws WCMException
产生当前对象[ResourceStyle]的实例

返回：
当前对象的实例[ResourceStyle]
抛出：
WCMException

findByKey

public static final ResourceStyle findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceStyleExporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ResourceStyleExporter

java.lang.Object
    继承者  com.trs.components.common.publish.widget.ResourceStyleExporter

public class ResourceStyleExporter
extends java.lang.Object

作者：
rey2008

构造方法摘要
ResourceStyleExporter()
构造函数
方法摘要
java.lang.String | export(ResourceStyles _currResourceStyles, boolean _bReturnXMLContent) 导出一个页面风格到xml文件中。
void | setXMLEncoding(java.lang.String _sXMLEncoding) 设置导出文件的编码格式
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResourceStyleExporter

public ResourceStyleExporter()
构造函数

方法详细信息

export

public java.lang.String export(ResourceStyles _currResourceStyles,
                               boolean _bReturnXMLContent)
                        throws java.lang.Exception
导出一个页面风格到xml文件中。

参数：
_currPageStyle - 页面风格对象
_bReturnXMLContent - 是否直接返回xml内容
返回：
抛出：
java.lang.Exception

setXMLEncoding

public void setXMLEncoding(java.lang.String _sXMLEncoding)
设置导出文件的编码格式

参数：
_sXMLEncoding -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceStyleImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ResourceStyleImporter

java.lang.Object
    继承者  com.trs.components.common.publish.widget.ResourceStyleImporter

public class ResourceStyleImporter
extends java.lang.Object

资源风格的导入器

作者：
rey2008

构造方法摘要
ResourceStyleImporter()
构造函数
方法摘要
 Reports importFromFile(java.lang.String _sFile, int _nImportMode)
从zip文件中导入PageStyle的信息。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResourceStyleImporter

public ResourceStyleImporter()
构造函数

方法详细信息

importFromFile

public Reports importFromFile(java.lang.String _sFile,
                              int _nImportMode)
                       throws java.lang.Exception
从zip文件中导入PageStyle的信息。

参数：
_sFile - zip文件的名称，如：ST20100526388775315675.zip
返回：
抛出：
WCMException
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ResourceStyleMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.ResourceStyleMgr
所有已实现的接口：
IResourceStyleMgr
public class ResourceStyleMgr
extends java.lang.Object
implements IResourceStyleMgr

资源可用风格业务逻辑实现类

作者：
han

构造方法摘要
ResourceStyleMgr()
构造方法
方法摘要
boolean | checkCssFlag(PageStyle _pageStyle, ResourceStyle _currResourceStyle, java.lang.String _cssFlag) 在指定的系统风格下校验CssFlag是否唯一
boolean | checkStyleName(PageStyle _pageStyle, ResourceStyle _currResourceStyle, java.lang.String _styleName) 在指定的系统风格下校验风格名称是否唯一
ResourceStyle | copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
void | delete(User _currUser, ResourceStyle _resourceStyle) 删除ResourceStyle
ResourceStyles | findByCssFlagAndPageStyle(java.lang.String _sCssFlag, PageStyle _oPageStyle) 根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 资源风格集合
ResourceStyles | findByStyleNameAndPageStyle(java.lang.String _sStyleName, PageStyle _oPageStyle) 根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 资源风格集合
ResourceStyles | getResourceStyles(PageStyle _pageStyle) 获取指定系统风格下的资源可用风格集合
java.lang.String | makeCssContent(ResourceStyle _resourceStyle) 生成资源的可用风格内容
ResourceStyles | query(PageStyle pageStyle, WCMFilter _filter) 获取指定页面风格下的ResourceStyle集合
ResourceStyle | save(User _currUser, ResourceStyle _resourceStyle) 保存（新增、编辑）ResourceStyle
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResourceStyleMgr

public ResourceStyleMgr()
构造方法

方法详细信息

delete

public void delete(User _currUser,
                   ResourceStyle _resourceStyle)
            throws WCMException
从接口 IResourceStyleMgr 复制的描述
删除ResourceStyle

指定者：
接口 IResourceStyleMgr 中的 delete
参数：
_currUser - 当前用户
_resourceStyle - 当前资源风格
抛出：
WCMException

makeCssContent

public java.lang.String makeCssContent(ResourceStyle _resourceStyle)
                                throws WCMException
从接口 IResourceStyleMgr 复制的描述
生成资源的可用风格内容

指定者：
接口 IResourceStyleMgr 中的 makeCssContent
参数：
_resourceStyle - 当前资源风格
返回：
最后生成的样式内容
抛出：
WCMException

query

public ResourceStyles query(PageStyle pageStyle,
                            WCMFilter _filter)
                     throws WCMException
从接口 IResourceStyleMgr 复制的描述
获取指定页面风格下的ResourceStyle集合

指定者：
接口 IResourceStyleMgr 中的 query
参数：
pageStyle - 当前页面风格
_filter - 外部指定的需要查询的filter
返回：
查询返回的资源风格集合
抛出：
WCMException

save

public ResourceStyle save(User _currUser,
                          ResourceStyle _resourceStyle)
                   throws WCMException
保存（新增、编辑）ResourceStyle

指定者：
接口 IResourceStyleMgr 中的 save
参数：
_resourceStyle -
_currUser - 当前用户
返回：
抛出：
WCMException

copy

public ResourceStyle copy(User _currUser,
                          PageStyle _targetPageStyle,
                          ResourceStyle _sourceResourceStyle)
                   throws WCMException
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

指定者：
接口 IResourceStyleMgr 中的 copy
参数：
_targetPageStyle -
_sourceResourceStyle -
返回：
抛出：
WCMException

copy

public ResourceStyle copy(User _currUser,
                          PageStyle _targetPageStyle,
                          ResourceStyle _sourceResourceStyle,
                          int _nCopyMode,
                          Reports oCopyReports)
                   throws WCMException
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

指定者：
接口 IResourceStyleMgr 中的 copy
参数：
_targetPageStyle -
_sourceResourceStyle -
返回：
抛出：
WCMException

getResourceStyles

public ResourceStyles getResourceStyles(PageStyle _pageStyle)
                                 throws WCMException
获取指定系统风格下的资源可用风格集合

指定者：
接口 IResourceStyleMgr 中的 getResourceStyles
参数：
pageStyle -
返回：
抛出：
WCMException

checkCssFlag

public boolean checkCssFlag(PageStyle _pageStyle,
                            ResourceStyle _currResourceStyle,
                            java.lang.String _cssFlag)
                     throws WCMException
在指定的系统风格下校验CssFlag是否唯一

指定者：
接口 IResourceStyleMgr 中的 checkCssFlag
参数：
_pageStyle -
_currResourceStyle -
_cssFlag -
返回：
抛出：
WCMException

checkStyleName

public boolean checkStyleName(PageStyle _pageStyle,
                              ResourceStyle _currResourceStyle,
                              java.lang.String _styleName)
                       throws WCMException
在指定的系统风格下校验风格名称是否唯一

指定者：
接口 IResourceStyleMgr 中的 checkStyleName
参数：
_pageStyle -
_currResourceStyle -
_cssFlag -
返回：
抛出：
WCMException

findByCssFlagAndPageStyle

public ResourceStyles findByCssFlagAndPageStyle(java.lang.String _sCssFlag,
                                                PageStyle _oPageStyle)
                                         throws WCMException
根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 资源风格集合

参数：
_sCssFlag -
_oPageStyle -
返回：
抛出：
WCMException - TrsArcher 2010-5-31下午02:12:07

findByStyleNameAndPageStyle

public ResourceStyles findByStyleNameAndPageStyle(java.lang.String _sStyleName,
                                                  PageStyle _oPageStyle)
                                           throws WCMException
根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 资源风格集合

参数：
_sStyleName -
_oPageStyle -
返回：
抛出：
WCMException - TrsArcher 2010-5-31下午02:12:07
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceStyles

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ResourceStyles

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.ResourceStyles

public class ResourceStyles
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ResourceStyles(User _currUser)
构造函数
ResourceStyles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ResourceStyles | createNewInstance(User _currUser) 产生当前集合对象[ResourceStyles]的实例
static ResourceStyle | findByCssFlagAndPageStyle(User _currUser, java.lang.String _sCssFlag, int _nPageStyleId) 根据指定的风格标识和页面风格来获取资源风格
static ResourceStyles | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ResourceStyles | findSameCssFlagStyles(java.lang.String _sCssFlag) 根据指定的风格标识来获取资源风格集合
static ResourceStyles | findSameNameStyles(java.lang.String _sStyleName) 根据指定的风格名称来获取资源风格集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ResourceStyles | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ResourceStyles]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResourceStyles

public ResourceStyles(User _currUser)
构造函数

另请参见：
ResourceStyles( User _currUser, int _initCapacity, int _incCapacity );

ResourceStyles

public ResourceStyles(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ResourceStyles findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ResourceStyles）
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByCssFlagAndPageStyle

public static final ResourceStyle findByCssFlagAndPageStyle(User _currUser,
                                                            java.lang.String _sCssFlag,
                                                            int _nPageStyleId)
                                                     throws WCMException
根据指定的风格标识和页面风格来获取资源风格

参数：
_currUser -
_sCssFlag -
_nPageStyleId -
返回：
抛出：
WCMException

findSameCssFlagStyles

public static ResourceStyles findSameCssFlagStyles(java.lang.String _sCssFlag)
                                            throws WCMException
根据指定的风格标识来获取资源风格集合

参数：
_sCssFlag -
返回：
抛出：
WCMException

findSameNameStyles

public static ResourceStyles findSameNameStyles(java.lang.String _sStyleName)
                                         throws WCMException
根据指定的风格名称来获取资源风格集合

参数：
_sStyleName -
返回：
抛出：
WCMException

openWCMObjs

public static final ResourceStyles openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[ResourceStyles]

参数：
_filter - 指定的Filter
返回：
当前集合[ResourceStyles]
抛出：
WCMException

createNewInstance

public static ResourceStyles createNewInstance(User _currUser)
产生当前集合对象[ResourceStyles]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceStyleServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ResourceStyleServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.ResourceStyleServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ResourceStyleServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

资源可用风格服务层

作者：
han

构造方法摘要
ResourceStyleServiceProvider()
构造方法
方法摘要
boolean | checkCssFlag(MethodContext _context) 在指定的页面风格下校验CssFlag是否唯一
boolean | checkCssFlagOrNameCanUse(MethodContext _context) 判断指定的风格标识和风格名称是否在指定的页面风格下存在
java.lang.String | copy(MethodContext context) 复制资源可用风格到页面风格或者系统资源风格下
void | delete(MethodContext context) 删除指定的风格
java.lang.String | exportResourceStyleZip(MethodContext context) 导出一个资源风格对象到zip文件中，zip文件中包含这个资源风格的所有相关文件
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.util.HashMap | findCssFlagUsedInfo(MethodContext _context) 校验CssFlag已经被使用的信息
java.util.HashMap | findStyleNameUsedInfo(MethodContext _context) 校验StyleName已经被使用的信息
java.lang.String | importResourceStyleZip(MethodContext context) 从一个zip文件中导入资源风格的相关内容，包括该资源风格的所有相关内容 ResourceStyleZipFile支持一个全路径
java.lang.String | makePreviewCssContent(MethodContext _context) 获取预览时需要的样式内容 在列表中预览时调用的方法，返回当前资源风格的css样式代码
java.lang.String | previewStyle(MethodContext _context) 预览风格根据当前填写的风格设置项 其中参数StyleItemXML的格式为一段xml，格式类似于
java.lang.Object | query(MethodContext context) 获取资源风格集合
ResourceStyles | queryResourceStyles(MethodContext context) 获取指定页面风格下的资源可用风格集合
void | resetResourceStyle(MethodContext _oContext) 将当前 资源风格的设置 重置为 对应的系统级别的 资源风格的设置
int | save(MethodContext context) 保存当前风格
int | saveStyleThumb(MethodContext context) 保存上传的风格示意图，该缩略图必须已经上传到webpic下
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResourceStyleServiceProvider

public ResourceStyleServiceProvider()
构造方法

方法详细信息

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
删除指定的风格

指定者：
接口 IDeleteServiceProvider 中的 delete
参数：
context -
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
获取资源风格集合

指定者：
接口 IQueryServiceProvider 中的 query
参数：
context -
返回：
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
保存当前风格

指定者：
接口 ISaveServiceProvider 中的 save
参数：
context -
返回：
抛出：
java.lang.Throwable

saveStyleThumb

public int saveStyleThumb(MethodContext context)
                   throws java.lang.Throwable
保存上传的风格示意图，该缩略图必须已经上传到webpic下

参数：
context -
返回：
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

copy

public java.lang.String copy(MethodContext context)
                      throws java.lang.Throwable
复制资源可用风格到页面风格或者系统资源风格下

参数：
context -
返回：
抛出：
java.lang.Throwable

makePreviewCssContent

public java.lang.String makePreviewCssContent(MethodContext _context)
                                       throws java.lang.Throwable
获取预览时需要的样式内容 在列表中预览时调用的方法，返回当前资源风格的css样式代码

参数：
_context -
返回：
抛出：
java.lang.Throwable

checkCssFlag

public boolean checkCssFlag(MethodContext _context)
                     throws java.lang.Throwable
在指定的页面风格下校验CssFlag是否唯一

参数：
_context -
返回：
抛出：
java.lang.Throwable

queryResourceStyles

public ResourceStyles queryResourceStyles(MethodContext context)
                                   throws java.lang.Throwable
获取指定页面风格下的资源可用风格集合

参数：
context -
返回：
抛出：
java.lang.Throwable

previewStyle

public java.lang.String previewStyle(MethodContext _context)
                              throws java.lang.Throwable
预览风格根据当前填写的风格设置项 其中参数StyleItemXML的格式为一段xml，格式类似于 ]]>

参数：
_context -
返回：
抛出：
java.lang.Throwable

findCssFlagUsedInfo

public java.util.HashMap findCssFlagUsedInfo(MethodContext _context)
                                      throws java.lang.Throwable
校验CssFlag已经被使用的信息

参数：
_context -
返回：
返回的数据格式为一个HashMap，名称为ResourceStyles，值为资源风格的集合对象 在界面中返回的内容格式如：legal@合法 或 illegal@该标识被以下风格使用: 资源风格[页面风格->资源风格];内容风格[页面风格->内容风格]
抛出：
java.lang.Throwable

findStyleNameUsedInfo

public java.util.HashMap findStyleNameUsedInfo(MethodContext _context)
                                        throws java.lang.Throwable
校验StyleName已经被使用的信息

参数：
_context -
返回：
返回的数据格式为一个HashMap，名称为ResourceStyles，值为资源风格的集合对象 在页面中返回的内容格式如：legal@合法 或 illegal@该名称被以下风格使用: 资源风格[页面风格->资源风格];内容风格[页面风格->内容风格]
抛出：
java.lang.Throwable

checkCssFlagOrNameCanUse

public boolean checkCssFlagOrNameCanUse(MethodContext _context)
                                 throws WCMException
判断指定的风格标识和风格名称是否在指定的页面风格下存在

参数：
_context -
返回：
抛出：
WCMException

resetResourceStyle

public void resetResourceStyle(MethodContext _oContext)
                        throws java.lang.Throwable
将当前 资源风格的设置 重置为 对应的系统级别的 资源风格的设置

参数：
_oContext -
抛出：
java.lang.Throwable - TrsArcher 2010-6-1下午01:12:48

exportResourceStyleZip

public java.lang.String exportResourceStyleZip(MethodContext context)
                                        throws java.lang.Throwable
导出一个资源风格对象到zip文件中，zip文件中包含这个资源风格的所有相关文件

参数：
context -
返回：
抛出：
java.lang.Throwable

importResourceStyleZip

public java.lang.String importResourceStyleZip(MethodContext context)
                                        throws java.lang.Throwable
从一个zip文件中导入资源风格的相关内容，包括该资源风格的所有相关内容 ResourceStyleZipFile支持一个全路径

参数：
context -
抛出：
java.lang.Throwable
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceStyleXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 ResourceStyleXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.common.publish.widget.ResourceStyleXmlConverter

public class ResourceStyleXmlConverter
extends BaseObjToXmlConverter

构造方法摘要
ResourceStyleXmlConverter()
构造函数
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResourceStyleXmlConverter

public ResourceStyleXmlConverter()
构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpecialAuthServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 SpecialAuthServer

java.lang.Object
    继承者  com.trs.components.common.publish.widget.SpecialAuthServer

public class SpecialAuthServer
extends java.lang.Object

专题制作选件权限判断相关类，定义了一些权限索引位及权限判断接口;
按照使用专题制作选件的三类用户进行权限划分：
1.网站编辑，进行专题维护
2.美工，进行风格维护
3.技术人员，进行资源，布局及母板的扩展

作者：
hudao

字段摘要
static int | SPECIAL_ADD 新建专题的权限
static int | SPECIAL_BROWSE 查看专题的权限
static int | SPECIAL_DELETE 删除专题的权限
static int | SPECIAL_EDIT 修改专题的权限
static int | SPECIAL_PUBLISH 发布专题的权限
static int | STYLE_ADD 新建风格的权限
static int | STYLE_BROWSE 查看风格的权限
static int | STYLE_DELETE 删除风格的权限
static int | STYLE_EDIT 修改风格的权限
static int | WIDGET_ADD 新建资源的权限
static int | WIDGET_BROWSE 查看资源的权限
static int | WIDGET_DELETE 删除资源的权限
static int | WIDGET_EDIT 修改资源的权限
构造方法摘要
SpecialAuthServer()
方法摘要
static RightValue | getRightValue(CMSObj operator, java.lang.Class clazz) 获取指定用户在指定对象类型上的权限值，如是否能新建，导入等
static RightValue | getRightValue(CMSObj operator, CMSObj obj) 获取指定用户在指定对象上的权限值
static boolean | hasRight(CMSObj operator, CMSObj obj, int nRightIndex) 判断当前操作者operator在对象obj上是否有权限nRightIndex
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SPECIAL_ADD

public static final int SPECIAL_ADD
新建专题的权限

另请参见：
常量字段值

SPECIAL_EDIT

public static final int SPECIAL_EDIT
修改专题的权限

另请参见：
常量字段值

SPECIAL_DELETE

public static final int SPECIAL_DELETE
删除专题的权限

另请参见：
常量字段值

SPECIAL_BROWSE

public static final int SPECIAL_BROWSE
查看专题的权限

另请参见：
常量字段值

SPECIAL_PUBLISH

public static final int SPECIAL_PUBLISH
发布专题的权限

另请参见：
常量字段值

STYLE_ADD

public static final int STYLE_ADD
新建风格的权限

另请参见：
常量字段值

STYLE_EDIT

public static final int STYLE_EDIT
修改风格的权限

另请参见：
常量字段值

STYLE_DELETE

public static final int STYLE_DELETE
删除风格的权限

另请参见：
常量字段值

STYLE_BROWSE

public static final int STYLE_BROWSE
查看风格的权限

另请参见：
常量字段值

WIDGET_ADD

public static final int WIDGET_ADD
新建资源的权限

另请参见：
常量字段值

WIDGET_EDIT

public static final int WIDGET_EDIT
修改资源的权限

另请参见：
常量字段值

WIDGET_DELETE

public static final int WIDGET_DELETE
删除资源的权限

另请参见：
常量字段值

WIDGET_BROWSE

public static final int WIDGET_BROWSE
查看资源的权限

另请参见：
常量字段值
构造方法详细信息

SpecialAuthServer

public SpecialAuthServer()
方法详细信息

hasRight

public static boolean hasRight(CMSObj operator,
                               CMSObj obj,
                               int nRightIndex)
                        throws WCMException
判断当前操作者operator在对象obj上是否有权限nRightIndex

参数：
operator -
obj -
nRightIndex -
返回：
抛出：
WCMException

getRightValue

public static RightValue getRightValue(CMSObj operator,
                                       CMSObj obj)
                                throws WCMException
获取指定用户在指定对象上的权限值

参数：
operator -
obj -
返回：
抛出：
WCMException

getRightValue

public static RightValue getRightValue(CMSObj operator,
                                       java.lang.Class clazz)
                                throws WCMException
获取指定用户在指定对象类型上的权限值，如是否能新建，导入等

参数：
operator -
clazz -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleAndResource

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleAndResource

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.StyleAndResource
所有已实现的接口：
java.lang.Cloneable
public class StyleAndResource
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
StyleAndResource()
构造函数：保留默认接口
方法摘要
static StyleAndResource | createNewInstance() 产生当前对象[StyleAndResource]的实例
static StyleAndResource | findById(int _nId) 提取指定ID的对象
static StyleAndResource | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getCssFlag() 提取属性：CssFlag
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getResourceId() 提取属性：ResourceId
int | getStyleObjId() 提取属性：StyleObjId
int | getStyleObjType() 提取属性：StyleObjType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setCssFlag(java.lang.String _sCssFlag) 设置属性：CssFlag
boolean | setResourceId(int _nResourceId) 设置属性：ResourceId
boolean | setStyleObjId(int _nStyleObjId) 设置属性：StyleObjId
boolean | setStyleObjType(int _nStyleObjType) 设置属性：StyleObjType
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

StyleAndResource

public StyleAndResource()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getStyleObjType

public int getStyleObjType()
提取属性：StyleObjType

返回：
StyleObjType

setStyleObjType

public boolean setStyleObjType(int _nStyleObjType)
                        throws WCMException
设置属性：StyleObjType

参数：
_nStyleObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyleObjId

public int getStyleObjId()
提取属性：StyleObjId

返回：
StyleObjId

setStyleObjId

public boolean setStyleObjId(int _nStyleObjId)
                      throws WCMException
设置属性：StyleObjId

参数：
_nStyleObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getResourceId

public int getResourceId()
提取属性：ResourceId

返回：
ResourceId

setResourceId

public boolean setResourceId(int _nResourceId)
                      throws WCMException
设置属性：ResourceId

参数：
_nResourceId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCssFlag

public java.lang.String getCssFlag()
提取属性：CssFlag

返回：
CssFlag

setCssFlag

public boolean setCssFlag(java.lang.String _sCssFlag)
                   throws WCMException
设置属性：CssFlag

参数：
_sCssFlag - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final StyleAndResource findById(int _nId)
                                       throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final StyleAndResource createNewInstance()
                                                throws WCMException
产生当前对象[StyleAndResource]的实例

返回：
当前对象的实例[StyleAndResource]
抛出：
WCMException

findByKey

public static final StyleAndResource findByKey(java.lang.Object _oKey)
                                        throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleAndResourceMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleAndResourceMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.StyleAndResourceMgr
所有已实现的接口：
IStyleAndResourceMgr
public class StyleAndResourceMgr
extends java.lang.Object
implements IStyleAndResourceMgr

作者：
han

构造方法摘要
StyleAndResourceMgr()
方法摘要
void | delete(User user, StyleAndResource _styleAndResource) 删除风格与资源的关联关系
void | deleteUnuseCSRItems(Widget systemResource, java.lang.String _sUseingIds) 删除资源与内容风格关联中没有使用的对象
StyleAndResources | getContentStyleAndResource(Widget _systemResource, WCMFilter _filter) 获取内容风格和资源的关系
java.util.HashMap | getContentStyleAndResourceMap(Widget _systemResource, WCMFilter _filter) 获取内容风格和资源的关系
ContentStyles | getContentStyles(Widget _resource, WCMFilter _filter) 获取资源对应的内容可用风格
StyleAndResource | save(User user, StyleAndResource _styleAndResource) 保存修改StyleAndResource
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyleAndResourceMgr

public StyleAndResourceMgr()
方法详细信息

delete

public void delete(User user,
                   StyleAndResource _styleAndResource)
            throws WCMException
从接口 IStyleAndResourceMgr 复制的描述
删除风格与资源的关联关系

指定者：
接口 IStyleAndResourceMgr 中的 delete
抛出：
WCMException

getContentStyles

public ContentStyles getContentStyles(Widget _resource,
                                      WCMFilter _filter)
                               throws WCMException
从接口 IStyleAndResourceMgr 复制的描述
获取资源对应的内容可用风格

指定者：
接口 IStyleAndResourceMgr 中的 getContentStyles
返回：
抛出：
WCMException

save

public StyleAndResource save(User user,
                             StyleAndResource _styleAndResource)
                      throws WCMException
从接口 IStyleAndResourceMgr 复制的描述
保存修改StyleAndResource

指定者：
接口 IStyleAndResourceMgr 中的 save
返回：
抛出：
WCMException

deleteUnuseCSRItems

public void deleteUnuseCSRItems(Widget systemResource,
                                java.lang.String _sUseingIds)
                         throws WCMException
删除资源与内容风格关联中没有使用的对象

指定者：
接口 IStyleAndResourceMgr 中的 deleteUnuseCSRItems
参数：
systemResource -
objectIds -
抛出：
WCMException

getContentStyleAndResource

public StyleAndResources getContentStyleAndResource(Widget _systemResource,
                                                    WCMFilter _filter)
                                             throws WCMException
获取内容风格和资源的关系

参数：
systemResource -
apdsFilter -
返回：
抛出：
WCMException

getContentStyleAndResourceMap

public java.util.HashMap getContentStyleAndResourceMap(Widget _systemResource,
                                                       WCMFilter _filter)
                                                throws WCMException
获取内容风格和资源的关系

指定者：
接口 IStyleAndResourceMgr 中的 getContentStyleAndResourceMap
参数：
_systemResource -
_filter -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleAndResources

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleAndResources

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.StyleAndResources

public class StyleAndResources
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
StyleAndResources(User _currUser)
构造函数
StyleAndResources(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static StyleAndResources | createNewInstance(User _currUser) 产生当前集合对象[StyleAndResources]的实例
static StyleAndResources | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static StyleAndResources | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StyleAndResources]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyleAndResources

public StyleAndResources(User _currUser)
构造函数

另请参见：
StyleAndResources( User _currUser, int _initCapacity, int _incCapacity );

StyleAndResources

public StyleAndResources(User _currUser,
                         int _initCapacity,
                         int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final StyleAndResources findByIds(User _currUser,
                                                java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（StyleAndResources）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final StyleAndResources openWCMObjs(User _currUser,
                                                  WCMFilter _filter)
                                           throws WCMException
通过指定一个Filter获取当前集合[StyleAndResources]

参数：
_filter - 指定的Filter
返回：
当前集合[StyleAndResources]
抛出：
WCMException

createNewInstance

public static StyleAndResources createNewInstance(User _currUser)
产生当前集合对象[StyleAndResources]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleCenterMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleCenterMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.StyleCenterMgr
所有已实现的接口：
IStyleCenterMgr
public class StyleCenterMgr
extends java.lang.Object
implements IStyleCenterMgr

作者：
han

字段摘要
static int | PAGE_OTHERSTYLE_WCMTYPE 页面其他风格的wcmtype
static int | STYLE_IS_PRIVATE 风格是私有的值
static int | STYLE_NOT_IS_PRIVATE 风格不是私有的值
构造方法摘要
StyleCenterMgr()
构造方法
方法摘要
void | copySystemStyle(User _currUser, PageStyle _targetPageStyle) 在新建风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格
void | copyToAllPageSylte(ContentStyle _contentStyle) 给所有的风格下面都要建立当前这个内容风格
void | copyToAllPageSylte(ResourceStyle _resourceStyle) 给所有的风格下面都要建立当前这个资源风格
void | createImgesDir(PageStyle _pageStyle) 创建资源风格图片的存放目录
java.lang.String | createStyleFile(User _currUser, PageStyle _pageStyle) 生成风格文件
void | delStyleThumb(java.lang.String _styleThumb) 删除上传的缩略图
java.lang.String | export(PageStyle _pageStyle) 导出系统样式文件
java.util.HashMap | findCssFlagUsedStyles(PageStyle _oPageStyle, BaseStyle _oCurrBaseStyle, java.lang.String _sCssFlag) 当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。
java.lang.String | findStyleImageDir(PageStyle _pageStyle) 获取指定页面风格的图片所在目录
java.util.HashMap | findStyleNameUsedStyles(PageStyle _oPageStyle, BaseStyle _oCurrBaseStyle, java.lang.String _sStyleName) 当前页面风格(_oPageStyle)下,除自己以外，名称为_sCssFlag的资源风格以及内容风格。
java.io.File | getStyleFile(PageStyle pageStyle) 获取风格对应的样式文件
void | importCssFile(PageStyle _pageStyle, java.lang.String _sUploadCssFile) 导入风格文件
java.lang.String | makePreviewCssContent(ContentStyle _contentStyle) 获取内容可用风格预览时需要的样式内容
java.lang.String | makePreviewCssContent(ResourceStyle _resourceStyle) 获取资源可用风格预览时需要的样式内容
java.lang.String | previewStyle(PageStyle _pageStyle, java.lang.String sCssFlag, java.lang.String sTemplateName, StyleItems _styleItems, java.lang.String _customStyle) 预览时，获取风格的内容
void | resetStyle(BaseStyle _oCurrBaseStyle) 将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置
void | saveStyleThumb(java.lang.String _styleThumb) 保存上传的缩略图
void | setResoruceStylePrivate(ContentStyle _contentStyle) 设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。
void | setResourceStylePrivate(ResourceStyle _resourceStyle) 设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STYLE_IS_PRIVATE

public static final int STYLE_IS_PRIVATE
风格是私有的值

另请参见：
常量字段值

STYLE_NOT_IS_PRIVATE

public static final int STYLE_NOT_IS_PRIVATE
风格不是私有的值

另请参见：
常量字段值

PAGE_OTHERSTYLE_WCMTYPE

public static final int PAGE_OTHERSTYLE_WCMTYPE
页面其他风格的wcmtype

另请参见：
常量字段值
构造方法详细信息

StyleCenterMgr

public StyleCenterMgr()
构造方法

方法详细信息

getStyleFile

public java.io.File getStyleFile(PageStyle pageStyle)
                          throws WCMException
从接口 IStyleCenterMgr 复制的描述
获取风格对应的样式文件

指定者：
接口 IStyleCenterMgr 中的 getStyleFile
参数：
pageStyle - 当前页面风格
返回：
样式文件
抛出：
WCMException

findStyleImageDir

public java.lang.String findStyleImageDir(PageStyle _pageStyle)
                                   throws WCMException
从接口 IStyleCenterMgr 复制的描述
获取指定页面风格的图片所在目录

指定者：
接口 IStyleCenterMgr 中的 findStyleImageDir
参数：
pageStyle -
返回：
抛出：
WCMException

createStyleFile

public java.lang.String createStyleFile(User _currUser,
                                        PageStyle _pageStyle)
                                 throws java.lang.Exception
从接口 IStyleCenterMgr 复制的描述
生成风格文件

指定者：
接口 IStyleCenterMgr 中的 createStyleFile
参数：
_currUser - 当前用户
_pageStyle - 当前页面风格
抛出：
WCMException
java.lang.Exception

export

public java.lang.String export(PageStyle _pageStyle)
                        throws java.lang.Exception
导出系统样式文件

指定者：
接口 IStyleCenterMgr 中的 export
参数：
_pageStyle -
返回：
抛出：
java.lang.Exception

importCssFile

public void importCssFile(PageStyle _pageStyle,
                          java.lang.String _sUploadCssFile)
                   throws java.lang.Exception
导入风格文件

指定者：
接口 IStyleCenterMgr 中的 importCssFile
参数：
pageStyle -
uploadCssFile -
抛出：
java.lang.Exception

createImgesDir

public void createImgesDir(PageStyle _pageStyle)
                    throws WCMException
创建资源风格图片的存放目录

指定者：
接口 IStyleCenterMgr 中的 createImgesDir
参数：
_pageStyle -
抛出：
WCMException

copySystemStyle

public void copySystemStyle(User _currUser,
                            PageStyle _targetPageStyle)
                     throws java.lang.Exception
在新建风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格

指定者：
接口 IStyleCenterMgr 中的 copySystemStyle
参数：
pageStyle -
抛出：
java.lang.Exception

saveStyleThumb

public void saveStyleThumb(java.lang.String _styleThumb)
                    throws java.lang.Exception
保存上传的缩略图

指定者：
接口 IStyleCenterMgr 中的 saveStyleThumb
参数：
styleThumb -
抛出：
java.lang.Exception

delStyleThumb

public void delStyleThumb(java.lang.String _styleThumb)
                   throws java.lang.Exception
删除上传的缩略图

指定者：
接口 IStyleCenterMgr 中的 delStyleThumb
参数：
styleThumb -
抛出：
java.lang.Exception

copyToAllPageSylte

public void copyToAllPageSylte(ResourceStyle _resourceStyle)
                        throws WCMException
给所有的风格下面都要建立当前这个资源风格

指定者：
接口 IStyleCenterMgr 中的 copyToAllPageSylte
参数：
resourceStyle -
抛出：
WCMException

copyToAllPageSylte

public void copyToAllPageSylte(ContentStyle _contentStyle)
                        throws WCMException
给所有的风格下面都要建立当前这个内容风格

指定者：
接口 IStyleCenterMgr 中的 copyToAllPageSylte
参数：
resourceStyle -
抛出：
WCMException

makePreviewCssContent

public java.lang.String makePreviewCssContent(ContentStyle _contentStyle)
                                       throws WCMException
获取内容可用风格预览时需要的样式内容

指定者：
接口 IStyleCenterMgr 中的 makePreviewCssContent
参数：
resourceStyle -
返回：
抛出：
WCMException

makePreviewCssContent

public java.lang.String makePreviewCssContent(ResourceStyle _resourceStyle)
                                       throws WCMException
获取资源可用风格预览时需要的样式内容

指定者：
接口 IStyleCenterMgr 中的 makePreviewCssContent
参数：
resourceStyle -
返回：
抛出：
WCMException

previewStyle

public java.lang.String previewStyle(PageStyle _pageStyle,
                                     java.lang.String sCssFlag,
                                     java.lang.String sTemplateName,
                                     StyleItems _styleItems,
                                     java.lang.String _customStyle)
                              throws WCMException
预览时，获取风格的内容

指定者：
接口 IStyleCenterMgr 中的 previewStyle
参数：
_pageStyle -
sCssFlag -
sTemplateName -
_styleItems -
_customStyle -
返回：
抛出：
WCMException

findCssFlagUsedStyles

public java.util.HashMap findCssFlagUsedStyles(PageStyle _oPageStyle,
                                               BaseStyle _oCurrBaseStyle,
                                               java.lang.String _sCssFlag)
                                        throws WCMException
当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。

指定者：
接口 IStyleCenterMgr 中的 findCssFlagUsedStyles
参数：
_oPageStyle -
_oCurrResourceStyle -
_sCssFlag -
返回：
抛出：
WCMException - TrsArcher 2010-5-31下午02:38:05

findStyleNameUsedStyles

public java.util.HashMap findStyleNameUsedStyles(PageStyle _oPageStyle,
                                                 BaseStyle _oCurrBaseStyle,
                                                 java.lang.String _sStyleName)
                                          throws WCMException
当前页面风格(_oPageStyle)下,除自己以外，名称为_sCssFlag的资源风格以及内容风格。

指定者：
接口 IStyleCenterMgr 中的 findStyleNameUsedStyles
参数：
_oPageStyle -
_oCurrResourceStyle -
_sStyleName -
返回：
抛出：
WCMException - TrsArcher 2010-5-31下午02:38:05

resetStyle

public void resetStyle(BaseStyle _oCurrBaseStyle)
                throws WCMException
将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置

指定者：
接口 IStyleCenterMgr 中的 resetStyle
参数：
_oContext -
抛出：
java.lang.Throwable - TrsArcher 2010-6-1下午01:12:48
WCMException

setResourceStylePrivate

public void setResourceStylePrivate(ResourceStyle _resourceStyle)
                             throws WCMException
设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。

指定者：
接口 IStyleCenterMgr 中的 setResourceStylePrivate
参数：
_resourceStyle -
抛出：
WCMException

setResoruceStylePrivate

public void setResoruceStylePrivate(ContentStyle _contentStyle)
                             throws WCMException
设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。

指定者：
接口 IStyleCenterMgr 中的 setResoruceStylePrivate
参数：
contentStyle -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleConstants

java.lang.Object
    继承者  com.trs.components.common.publish.widget.StyleConstants

public class StyleConstants
extends java.lang.Object

定义风格所有常量

作者：
han

字段摘要
static int | CONTENT_STYLE_TYPE 为了复用同一个页面，添加了风格类型的常量:内容风格
static int | PAGE_STYLE_TYPE 为了复用同一个页面，添加了风格类型的常量:页面风格
static java.lang.String | PAGESTYLE_DEFAULT_TEMPLATENAME 页面特性默认模板名称
static java.lang.String | PAGESTYLE_OTHER_TEMPLATENAME 其他特性默认模板名称
static int | RESOURCE_STYLE_TYPE 为了复用同一个页面，添加了风格类型的常量:资源风格
static int | STYLE_DEAL_MODE_CHANGE fromXML时出现风格重名的处理方式 : 更名
static int | STYLE_DEAL_MODE_IGNORE fromXML时出现风格重名的处理方式 : 忽略
static int | STYLE_DEAL_MODE_QUIT fromXML时出现风格重名的处理方式 : 退出
static int | STYLE_DEAL_MODE_UPDATE fromXML时出现风格重名的处理方式 : 覆盖
构造方法摘要
StyleConstants()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PAGESTYLE_DEFAULT_TEMPLATENAME

public static final java.lang.String PAGESTYLE_DEFAULT_TEMPLATENAME
页面特性默认模板名称

另请参见：
常量字段值

PAGESTYLE_OTHER_TEMPLATENAME

public static final java.lang.String PAGESTYLE_OTHER_TEMPLATENAME
其他特性默认模板名称

另请参见：
常量字段值

STYLE_DEAL_MODE_UPDATE

public static final int STYLE_DEAL_MODE_UPDATE
fromXML时出现风格重名的处理方式 : 覆盖

另请参见：
常量字段值

STYLE_DEAL_MODE_IGNORE

public static final int STYLE_DEAL_MODE_IGNORE
fromXML时出现风格重名的处理方式 : 忽略

另请参见：
常量字段值

STYLE_DEAL_MODE_CHANGE

public static final int STYLE_DEAL_MODE_CHANGE
fromXML时出现风格重名的处理方式 : 更名

另请参见：
常量字段值

STYLE_DEAL_MODE_QUIT

public static final int STYLE_DEAL_MODE_QUIT
fromXML时出现风格重名的处理方式 : 退出

另请参见：
常量字段值

PAGE_STYLE_TYPE

public static final int PAGE_STYLE_TYPE
为了复用同一个页面，添加了风格类型的常量:页面风格

另请参见：
常量字段值

RESOURCE_STYLE_TYPE

public static final int RESOURCE_STYLE_TYPE
为了复用同一个页面，添加了风格类型的常量:资源风格

另请参见：
常量字段值

CONTENT_STYLE_TYPE

public static final int CONTENT_STYLE_TYPE
为了复用同一个页面，添加了风格类型的常量:内容风格

另请参见：
常量字段值
构造方法详细信息

StyleConstants

public StyleConstants()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleHelper

java.lang.Object
    继承者  com.trs.components.common.publish.widget.StyleHelper

public class StyleHelper
extends java.lang.Object

风格设计辅助类

作者：
han

构造方法摘要
StyleHelper()
方法摘要
static java.lang.String | getCssTemplateFilePath() 获取样式模板所在路径
static java.lang.String | makeCSSContent(java.lang.String _sCssFlag, java.lang.String _sCSSTemplateContent, StyleItems _items) 根据风格模板替换其中的标记生成可以使用的风格内容
static java.lang.String | makeCustomCssContent(java.lang.String _sCssFlag, java.lang.String _sCustomStyle) 产生自定义的风格内容
static java.util.List | parseCssContent(java.lang.String _cssContent) 将模板中的CSS内容解析成多个List对象 过滤了模板中的样式和多余的回车换行
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyleHelper

public StyleHelper()
方法详细信息

makeCSSContent

public static java.lang.String makeCSSContent(java.lang.String _sCssFlag,
                                              java.lang.String _sCSSTemplateContent,
                                              StyleItems _items)
                                       throws WCMException
根据风格模板替换其中的标记生成可以使用的风格内容

参数：
_sCssFlag - ，风格标识（如f01）
_sCSSTemplateContent - ，风格模板内容
_items -
返回：
抛出：
WCMException

parseCssContent

public static java.util.List parseCssContent(java.lang.String _cssContent)
                                      throws WCMException
将模板中的CSS内容解析成多个List对象
过滤了模板中的样式和多余的回车换行

参数：
_cssContent -
返回：
抛出：
WCMException

getCssTemplateFilePath

public static java.lang.String getCssTemplateFilePath()
                                               throws WCMException
获取样式模板所在路径

返回：
抛出：
WCMException

makeCustomCssContent

public static java.lang.String makeCustomCssContent(java.lang.String _sCssFlag,
                                                    java.lang.String _sCustomStyle)
                                             throws WCMException
产生自定义的风格内容

参数：
cssFlag -
_sCustomStyle -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleItem

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleItem

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.StyleItem
所有已实现的接口：
java.lang.Cloneable
public class StyleItem
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
StyleItem()
构造函数：保留默认接口
方法摘要
static StyleItem | createNewInstance() 产生当前对象[StyleItem]的实例
static StyleItem | findById(int _nId) 提取指定ID的对象
static StyleItem | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getClassName() 提取属性：ClassName
java.lang.String | getClassValue() 提取属性：ClassValue
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getStyleObjId() 提取属性：StyleObjId
int | getStyleObjType() 提取属性：StyleObjType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
void | setAddMode(boolean _bAddMode)
boolean | setClassName(java.lang.String _sClassName) 设置属性：ClassName
boolean | setClassValue(java.lang.String _sClassValue) 设置属性：ClassValue
boolean | setStyleObjId(int _nStyleObjId) 设置属性：StyleObjId
boolean | setStyleObjType(int _nStyleObjType) 设置属性：StyleObjType
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

StyleItem

public StyleItem()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getStyleObjType

public int getStyleObjType()
提取属性：StyleObjType

返回：
StyleObjType

setStyleObjType

public boolean setStyleObjType(int _nStyleObjType)
                        throws WCMException
设置属性：StyleObjType

参数：
_nStyleObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyleObjId

public int getStyleObjId()
提取属性：StyleObjId

返回：
StyleObjId

setStyleObjId

public boolean setStyleObjId(int _nStyleObjId)
                      throws WCMException
设置属性：StyleObjId

参数：
_nStyleObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getClassName

public java.lang.String getClassName()
提取属性：ClassName

返回：
ClassName

setClassName

public boolean setClassName(java.lang.String _sClassName)
                     throws WCMException
设置属性：ClassName

参数：
_sClassName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getClassValue

public java.lang.String getClassValue()
提取属性：ClassValue

返回：
ClassValue

setClassValue

public boolean setClassValue(java.lang.String _sClassValue)
                      throws WCMException
设置属性：ClassValue

参数：
_sClassValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final StyleItem findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final StyleItem createNewInstance()
                                         throws WCMException
产生当前对象[StyleItem]的实例

返回：
当前对象的实例[StyleItem]
抛出：
WCMException

findByKey

public static final StyleItem findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

setAddMode

public void setAddMode(boolean _bAddMode)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleItemMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleItemMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.StyleItemMgr
所有已实现的接口：
IStyleItemMgr
public class StyleItemMgr
extends java.lang.Object
implements IStyleItemMgr

风格项业务逻辑类

作者：
han

构造方法摘要
StyleItemMgr()
方法摘要
void | delete(User user, BaseStyle _baseStyle) 删除风格对应的风格项
void | delete(User _currUser, StyleItem styleItem) 删除StyleItem
void | deleteUnusePageOtherStyleItems(PageStyle _pageStyle, java.lang.String _sUseingIds) 删除页面style对应的没有使用的其他风格项
void | deleteUnuseStyleItems(BaseStyle baseStyle, java.lang.String _sUseingIds) 删除指定风格没有使用的风格项
StyleItems | query(WCMFilter _filter) 获取风格元素集合
java.util.HashMap | queryPageOtherStyleItemMap(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
StyleItems | queryPageOtherStyleItems(PageStyle _pageStyle, WCMFilter _filter) 获取页面其他风格样式项
java.util.HashMap | queryStyleItemMap(BaseStyle _baseStyle, WCMFilter _filter) 获取指定风格的风格项
StyleItems | queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter) 获取指定风格的风格项
StyleItem | save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem) 保存（新增、编辑）StyleItem
StyleItem | savePageOtherStyleItem(User _currUser, PageStyle pageStyle, StyleItem _styleItem) 保存页面风格对应的其他风格属性
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyleItemMgr

public StyleItemMgr()
方法详细信息

delete

public void delete(User _currUser,
                   StyleItem styleItem)
            throws WCMException
从接口 IStyleItemMgr 复制的描述
删除StyleItem

指定者：
接口 IStyleItemMgr 中的 delete
styleItem - 指定的样式元素对象
抛出：
WCMException

queryStyleItems

public StyleItems queryStyleItems(BaseStyle _baseStyle,
                                  WCMFilter _filter)
                           throws WCMException
获取指定风格的风格项

指定者：
接口 IStyleItemMgr 中的 queryStyleItems
参数：
_baseStyle -
_filter -
返回：
抛出：
WCMException

query

public StyleItems query(WCMFilter _filter)
                 throws WCMException
获取风格元素集合

参数：
_filter -
返回：
抛出：
WCMException

save

public StyleItem save(User _currUser,
                      BaseStyle _baseStyle,
                      StyleItem _styleItem)
               throws WCMException
从接口 IStyleItemMgr 复制的描述
保存（新增、编辑）StyleItem

指定者：
接口 IStyleItemMgr 中的 save
返回：
抛出：
WCMException

deleteUnuseStyleItems

public void deleteUnuseStyleItems(BaseStyle baseStyle,
                                  java.lang.String _sUseingIds)
                           throws WCMException
删除指定风格没有使用的风格项

指定者：
接口 IStyleItemMgr 中的 deleteUnuseStyleItems
参数：
baseStyle -
objectIds -
抛出：
WCMException

delete

public void delete(User user,
                   BaseStyle _baseStyle)
            throws WCMException
删除风格对应的风格项

指定者：
接口 IStyleItemMgr 中的 delete
参数：
user -
pageStyle -
抛出：
WCMException

queryStyleItemMap

public java.util.HashMap queryStyleItemMap(BaseStyle _baseStyle,
                                           WCMFilter _filter)
                                    throws WCMException
获取指定风格的风格项

指定者：
接口 IStyleItemMgr 中的 queryStyleItemMap
参数：
baseStyle -
object -
返回：
抛出：
WCMException

deleteUnusePageOtherStyleItems

public void deleteUnusePageOtherStyleItems(PageStyle _pageStyle,
                                           java.lang.String _sUseingIds)
                                    throws WCMException
删除页面style对应的没有使用的其他风格项

指定者：
接口 IStyleItemMgr 中的 deleteUnusePageOtherStyleItems
参数：
_pageStyle -
objectIds -
抛出：
WCMException

savePageOtherStyleItem

public StyleItem savePageOtherStyleItem(User _currUser,
                                        PageStyle pageStyle,
                                        StyleItem _styleItem)
                                 throws WCMException
保存页面风格对应的其他风格属性

指定者：
接口 IStyleItemMgr 中的 savePageOtherStyleItem
参数：
loginUser -
pageStyle -
styleItem -
抛出：
WCMException

queryPageOtherStyleItems

public StyleItems queryPageOtherStyleItems(PageStyle _pageStyle,
                                           WCMFilter _filter)
                                    throws WCMException
获取页面其他风格样式项

指定者：
接口 IStyleItemMgr 中的 queryPageOtherStyleItems
参数：
_pageStyle -
_filter -
返回：
抛出：
WCMException

queryPageOtherStyleItemMap

public java.util.HashMap queryPageOtherStyleItemMap(PageStyle pageStyle,
                                                    WCMFilter _filter)
                                             throws WCMException
获取页面其他风格样式项

指定者：
接口 IStyleItemMgr 中的 queryPageOtherStyleItemMap
参数：
pageStyle -
object -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleItems

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleItems

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.StyleItems

public class StyleItems
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
StyleItems(User _currUser)
构造函数
StyleItems(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static StyleItems | createNewInstance(User _currUser) 产生当前集合对象[StyleItems]的实例
static StyleItems | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static StyleItems | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StyleItems]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyleItems

public StyleItems(User _currUser)
构造函数

另请参见：
StyleItems( User _currUser, int _initCapacity, int _incCapacity );

StyleItems

public StyleItems(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final StyleItems findByIds(User _currUser,
                                         java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（StyleItems）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final StyleItems openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[StyleItems]

参数：
_filter - 指定的Filter
返回：
当前集合[StyleItems]
抛出：
WCMException

createNewInstance

public static StyleItems createNewInstance(User _currUser)
产生当前集合对象[StyleItems]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleItemServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleItemServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.StyleItemServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class StyleItemServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

风格项服务

作者：
han

构造方法摘要
StyleItemServiceProvider()
构造方法
方法摘要
java.util.HashMap | queryStyleItemMap(MethodContext context) 获取指定风格对应的风格项集合
java.lang.Object | queryStyleItems(MethodContext context) 获取指定风格对应的风格项集合
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyleItemServiceProvider

public StyleItemServiceProvider()
构造方法

方法详细信息

queryStyleItems

public java.lang.Object queryStyleItems(MethodContext context)
                                 throws WCMException
获取指定风格对应的风格项集合

参数：
context -
返回：
抛出：
WCMException

queryStyleItemMap

public java.util.HashMap queryStyleItemMap(MethodContext context)
                                    throws WCMException
获取指定风格对应的风格项集合

参数：
context -
返回：
{classname=StyleItem}
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StylePathHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StylePathHelper

java.lang.Object
    继承者  com.trs.components.common.publish.widget.StylePathHelper

public class StylePathHelper
extends java.lang.Object

字段摘要
static java.lang.String | m_sCommonPath 风格资源公共的路径
static java.lang.String | m_sCssPath 风格样式文件的路径
static java.lang.String | m_sCssTemplatePath 风格样式文件的模板路径
static java.lang.String | m_sSpecialPath 专题的路径
static java.lang.String | m_sStylePath 风格的路径
static java.lang.String | m_sWcmApp 65应用的主要目录
构造方法摘要
StylePathHelper()
方法摘要
static java.lang.String | getCssTemplateFilePath() 获取风格样式文件的模板文件路径
static java.lang.String | getStyleCommonDir() 获取风格资源文件所在的路径
static java.lang.String | getStyleCommonDir(java.lang.String _sStyleName) 获取指定风格资源文件所在的路径
static java.lang.String | getStyleCssDir() 获取生成的风格样式文件路径
static java.lang.String | getWcmdataTemplatePath() 获取WCMDATA中的template所在的目录，风格的一些资源图片以及样式存放在此
static java.lang.String | getWcmServerDir() 获取WCM应用所在的路径，通过WCM_PATH获取
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

m_sWcmApp

public static final java.lang.String m_sWcmApp
65应用的主要目录

另请参见：
常量字段值

m_sSpecialPath

public static final java.lang.String m_sSpecialPath
专题的路径

另请参见：
常量字段值

m_sStylePath

public static final java.lang.String m_sStylePath
风格的路径

另请参见：
常量字段值

m_sCommonPath

public static final java.lang.String m_sCommonPath
风格资源公共的路径

另请参见：
常量字段值

m_sCssPath

public static final java.lang.String m_sCssPath
风格样式文件的路径

另请参见：
常量字段值

m_sCssTemplatePath

public static final java.lang.String m_sCssTemplatePath
风格样式文件的模板路径

另请参见：
常量字段值
构造方法详细信息

StylePathHelper

public StylePathHelper()
方法详细信息

getWcmServerDir

public static java.lang.String getWcmServerDir()
                                        throws WCMException
获取WCM应用所在的路径，通过WCM_PATH获取

返回：
抛出：
WCMException

getWcmdataTemplatePath

public static java.lang.String getWcmdataTemplatePath()
获取WCMDATA中的template所在的目录，风格的一些资源图片以及样式存放在此

返回：

getStyleCommonDir

public static java.lang.String getStyleCommonDir()
                                          throws WCMException
获取风格资源文件所在的路径

返回：
抛出：
WCMException

getStyleCommonDir

public static java.lang.String getStyleCommonDir(java.lang.String _sStyleName)
                                          throws WCMException
获取指定风格资源文件所在的路径

返回：
抛出：
WCMException

getStyleCssDir

public static java.lang.String getStyleCssDir()
                                       throws WCMException
获取生成的风格样式文件路径

返回：
抛出：
WCMException

getCssTemplateFilePath

public static java.lang.String getCssTemplateFilePath()
                                               throws WCMException
获取风格样式文件的模板文件路径

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleRepeatNameHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 StyleRepeatNameHelper

java.lang.Object
    继承者  com.trs.components.common.publish.widget.StyleRepeatNameHelper

public class StyleRepeatNameHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

构造方法摘要
StyleRepeatNameHelper()
方法摘要
static java.lang.String | processCssFlag(java.lang.String _sRealCssFlag, int _nImportMode, int _nStyleType) 处理风格名称
static java.lang.String | processStyleName(java.lang.String _sRealName, int _nImportMode, int _nStyleType) 处理风格名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyleRepeatNameHelper

public StyleRepeatNameHelper()
方法详细信息

processStyleName

public static java.lang.String processStyleName(java.lang.String _sRealName,
                                                int _nImportMode,
                                                int _nStyleType)
                                         throws WCMException
处理风格名称

参数：
_sRealName - 风格名
_nImportMode - 风格导入方式
返回：
抛出：
WCMException

processCssFlag

public static java.lang.String processCssFlag(java.lang.String _sRealCssFlag,
                                              int _nImportMode,
                                              int _nStyleType)
                                       throws WCMException
处理风格名称

参数：
_sRealName - 风格名
_nImportMode - 风格导入方式
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SubjectDataInitHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 SubjectDataInitHelper

java.lang.Object
    继承者  com.trs.components.common.publish.widget.SubjectDataInitHelper

public class SubjectDataInitHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

构造方法摘要
SubjectDataInitHelper()
方法摘要
static java.lang.String | getSpecialInitDataPath(javax.servlet.http.HttpServletRequest req)
static void | importDemoDatasContentStyle(java.lang.String sTestDataRootPath)
static void | importDemoDatasDocument(java.lang.String sTestDataRootPath)
static void | importDemoDatasMaster(java.lang.String sTestDataRootPath)
static void | importDemoDatasPageStyle(java.lang.String sTestDataRootPath)
static void | importDemoDatasResourceStyle(java.lang.String sTestDataRootPath)
static void | importDemoDatasWebSite(java.lang.String sTestDataRootPath) 初始化测试数据站点
static void | importDemoDatasWidget(java.lang.String sTestDataRootPath)
static void | initData(javax.servlet.http.HttpServletRequest req)
static void | setRelationDoc()
static void | setRelationForDocs(Documents targetDocs, Documents sourceDocs)
static void | updateDemoDataWidgetParamtersAndRegion()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SubjectDataInitHelper

public SubjectDataInitHelper()
方法详细信息

getSpecialInitDataPath

public static java.lang.String getSpecialInitDataPath(javax.servlet.http.HttpServletRequest req)
                                               throws WCMException
抛出：
WCMException

importDemoDatasWebSite

public static void importDemoDatasWebSite(java.lang.String sTestDataRootPath)
初始化测试数据站点

抛出：
WCMException

importDemoDatasDocument

public static void importDemoDatasDocument(java.lang.String sTestDataRootPath)

setRelationDoc

public static void setRelationDoc()

setRelationForDocs

public static void setRelationForDocs(Documents targetDocs,
                                      Documents sourceDocs)

importDemoDatasMaster

public static void importDemoDatasMaster(java.lang.String sTestDataRootPath)

importDemoDatasWidget

public static void importDemoDatasWidget(java.lang.String sTestDataRootPath)

importDemoDatasResourceStyle

public static void importDemoDatasResourceStyle(java.lang.String sTestDataRootPath)

importDemoDatasContentStyle

public static void importDemoDatasContentStyle(java.lang.String sTestDataRootPath)

importDemoDatasPageStyle

public static void importDemoDatasPageStyle(java.lang.String sTestDataRootPath)

updateDemoDataWidgetParamtersAndRegion

public static void updateDemoDataWidgetParamtersAndRegion()
                                                   throws WCMException
抛出：
WCMException

initData

public static void initData(javax.servlet.http.HttpServletRequest req)
                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SystemContentStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 SystemContentStyleMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.SystemContentStyleMgr
所有已实现的接口：
ISystemContentStyleMgr
public class SystemContentStyleMgr
extends java.lang.Object
implements ISystemContentStyleMgr

系统级别资源可用风格

作者：
han

构造方法摘要
SystemContentStyleMgr()
方法摘要
void | copyFor(User _currUser, PageStyle _targetPageStyle) 根据系统默认的内容可用风格为指定的系统风格创建
ContentStyles | getSystemContentStyles() 获取系统级资源可用风格
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SystemContentStyleMgr

public SystemContentStyleMgr()
方法详细信息

copyFor

public void copyFor(User _currUser,
                    PageStyle _targetPageStyle)
             throws WCMException
根据系统默认的内容可用风格为指定的系统风格创建

指定者：
接口 ISystemContentStyleMgr 中的 copyFor
参数：
user -
pageStyle -
抛出：
WCMException

getSystemContentStyles

public ContentStyles getSystemContentStyles()
                                     throws WCMException
获取系统级资源可用风格

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SystemResourceStyleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 SystemResourceStyleMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.SystemResourceStyleMgr
所有已实现的接口：
ISystemResourceStyleMgr
public class SystemResourceStyleMgr
extends java.lang.Object
implements ISystemResourceStyleMgr

作者：
han

构造方法摘要
SystemResourceStyleMgr()
方法摘要
void | copyFor(User _currUser, PageStyle _targetPageStyle) 根据系统默认的资源可用风格为指定的系统风格创建
ResourceStyles | getSystemResourceStyles() 获取系统级资源可用风格
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SystemResourceStyleMgr

public SystemResourceStyleMgr()
方法详细信息

copyFor

public void copyFor(User _currUser,
                    PageStyle _targetPageStyle)
             throws WCMException
根据系统默认的资源可用风格为指定的系统风格创建

指定者：
接口 ISystemResourceStyleMgr 中的 copyFor
参数：
user -
pageStyle -
抛出：
WCMException

getSystemResourceStyles

public ResourceStyles getSystemResourceStyles()
                                       throws WCMException
获取系统级资源可用风格

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateLCListenerVisualTemplate

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 TemplateLCListenerVisualTemplate

java.lang.Object
    继承者  com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class TemplateLCListenerVisualTemplate
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnAdd, IObjectLCListenerOnModify

当可视化模板进行保存或修改的时候，需要将模板和资源实例建立去关联关系。 即需要记录模板中使用了哪些资源实例 在删除可视化模板时，也需要把可视化模板关联的资源实例及变量删除

作者：
hudao

构造方法摘要
TemplateLCListenerVisualTemplate()
方法摘要
void | notifyOnAddObj(BaseObj objAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj objModified, int eventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateLCListenerVisualTemplate

public TemplateLCListenerVisualTemplate()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj objAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
objAdded - 新增的对象
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VisualTemplateServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 VisualTemplateServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.VisualTemplateServiceProvider
所有已实现的接口：
IVisualTemplateServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class VisualTemplateServiceProvider
extends java.lang.Object
implements IVisualTemplateServiceProvider

构造方法摘要
VisualTemplateServiceProvider()
方法摘要
Reports | copyVisualTemplate(MethodContext _context) 类似创建功能，在指定栏目下创建新的可视化模板
java.lang.String | copyWidgetInstance(MethodContext context) 类似创建功能，创建的新的资源实例
void | delete(MethodContext context)
void | deleteWidgetInstance(MethodContext context) 删除指定的资源块实例对象
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.lang.String | parseTemplate(MethodContext context) 将专题对应栏目的模板内容解析成可视化编辑模板形式的字符串
java.lang.String | parseWidgetInstance(MethodContext context) 将某一个资源块实例解析成可视化编辑模板形式的字符串
java.lang.String | preview(MethodContext context) 获取指定栏目或文档对象在指定模板内容下的预览内容
java.lang.Object | query(MethodContext context)
int | save(MethodContext context)
int | saveToTemplate(MethodContext context) 将传入的字符串文本，解析成模板，传入的文本为可视化设计的模板内容，解析之后将建立 资源块实例，资源块实例变量的关系
int | saveWidgetInstance(MethodContext context)
int | saveWidgetInstParameters(MethodContext context)
void | synchronizeWidgetInstances(MethodContext methodContext) 将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VisualTemplateServiceProvider

public VisualTemplateServiceProvider()
方法详细信息

parseTemplate

public java.lang.String parseTemplate(MethodContext context)
                               throws java.lang.Throwable
从接口 IVisualTemplateServiceProvider 复制的描述
将专题对应栏目的模板内容解析成可视化编辑模板形式的字符串

指定者：
接口 IVisualTemplateServiceProvider 中的 parseTemplate
返回：
抛出：
java.lang.Throwable

parseWidgetInstance

public java.lang.String parseWidgetInstance(MethodContext context)
                                     throws java.lang.Throwable
从接口 IVisualTemplateServiceProvider 复制的描述
将某一个资源块实例解析成可视化编辑模板形式的字符串

指定者：
接口 IVisualTemplateServiceProvider 中的 parseWidgetInstance
返回：
抛出：
java.lang.Throwable

saveToTemplate

public int saveToTemplate(MethodContext context)
                   throws java.lang.Throwable
从接口 IVisualTemplateServiceProvider 复制的描述
将传入的字符串文本，解析成模板，传入的文本为可视化设计的模板内容，解析之后将建立 资源块实例，资源块实例变量的关系

指定者：
接口 IVisualTemplateServiceProvider 中的 saveToTemplate
返回：
抛出：
java.lang.Throwable

synchronizeWidgetInstances

public void synchronizeWidgetInstances(MethodContext methodContext)
                                throws WCMException
从接口 IVisualTemplateServiceProvider 复制的描述
将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。 为什么需要同步模板和资源实例的内容？是由于在可视化模板设计过程中 。并没有时刻将可视化模板的内容与使用的实例的内容保持一致，否则将不支持，撤销与同步操作。所以必须在可视化页面退出之后，再进行资源实例的同步处理。

指定者：
接口 IVisualTemplateServiceProvider 中的 synchronizeWidgetInstances
抛出：
WCMException

preview

public java.lang.String preview(MethodContext context)
                         throws java.lang.Exception
从接口 IVisualTemplateServiceProvider 复制的描述
获取指定栏目或文档对象在指定模板内容下的预览内容

指定者：
接口 IVisualTemplateServiceProvider 中的 preview
抛出：
WCMException
java.lang.Exception

saveWidgetInstance

public int saveWidgetInstance(MethodContext context)
                       throws java.lang.Throwable
抛出：
java.lang.Throwable

saveWidgetInstParameters

public int saveWidgetInstParameters(MethodContext context)
                             throws java.lang.Throwable
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

deleteWidgetInstance

public void deleteWidgetInstance(MethodContext context)
                          throws java.lang.Throwable
从接口 IVisualTemplateServiceProvider 复制的描述
删除指定的资源块实例对象

指定者：
接口 IVisualTemplateServiceProvider 中的 deleteWidgetInstance
抛出：
java.lang.Throwable

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

copyWidgetInstance

public java.lang.String copyWidgetInstance(MethodContext context)
                                    throws java.lang.Exception
类似创建功能，创建的新的资源实例

指定者：
接口 IVisualTemplateServiceProvider 中的 copyWidgetInstance
参数：
context -
返回：
抛出：
java.lang.Exception

copyVisualTemplate

public Reports copyVisualTemplate(MethodContext _context)
                           throws java.lang.Exception
类似创建功能，在指定栏目下创建新的可视化模板

参数：
_context -
返回：
新创建的模板Id
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Widget

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 Widget

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.Widget
所有已实现的接口：
java.lang.Cloneable
public class Widget
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Widget()
构造函数：保留默认接口
方法摘要
static Widget | createNewInstance() 产生当前对象[Widget]的实例
static Widget | findById(int _nId) 提取指定ID的对象
static Widget | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getCDefaultStyle() 提取属性：CDefaultStyle
java.lang.String | getContentStyle() 提取属性：ContentStyle
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdentityFlag(java.lang.String _sWidgetName) 提取唯一标识：IdentityFlag
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getWCMType() 取得该对象的类型编号
java.lang.String | getWDefaultStyle() 提取属性：WDefaultStyle
java.lang.String | getWdesc() 提取属性：Wdesc
java.lang.String | getWidgetAttrURL() 提取属性：WidgetAttrURL
java.lang.String | getWidgetcontent() 提取属性：Widgetcontent
java.lang.String | getWidgetpic() 提取属性：Widgetpic
int | getWidgetType() 提取属性：WidgetType
java.lang.String | getWname() 提取属性：Wname
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setCDefaultStyle(int _nCDefaultStyle) 设置属性：CDefaultStyle
boolean | setContentStyle(java.lang.String _sContentStyle) 设置属性：ContentStyle
boolean | setWDefaultStyle(java.lang.String _sWDefaultStyle) 设置属性：WDefaultStyle
boolean | setWdesc(java.lang.String _sWdesc) 设置属性：Wdesc
boolean | setWidgetAttrURL(java.lang.String _sWidgetAttrURL) 设置属性：WidgetAttrURL
boolean | setWidgetcontent(java.lang.String _sWidgetcontent) 设置属性：Widgetcontent
boolean | setWidgetpic(java.lang.String _sWidgetpic) 设置属性：Widgetpic
boolean | setWidgetType(int _nWidgetType) 设置属性：WidgetType
boolean | setWname(java.lang.String _sWname) 设置属性：Wname
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Widget

public Widget()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getWname

public java.lang.String getWname()
提取属性：Wname

返回：
Wname

setWname

public boolean setWname(java.lang.String _sWname)
                 throws WCMException
设置属性：Wname

参数：
_sWname - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWdesc

public java.lang.String getWdesc()
提取属性：Wdesc

返回：
Wdesc

setWdesc

public boolean setWdesc(java.lang.String _sWdesc)
                 throws WCMException
设置属性：Wdesc

参数：
_sWdesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWidgetcontent

public java.lang.String getWidgetcontent()
提取属性：Widgetcontent

返回：
Widgetcontent

setWidgetcontent

public boolean setWidgetcontent(java.lang.String _sWidgetcontent)
                         throws WCMException
设置属性：Widgetcontent

参数：
_sWidgetcontent - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWidgetpic

public java.lang.String getWidgetpic()
提取属性：Widgetpic

返回：
Widgetpic

setWidgetpic

public boolean setWidgetpic(java.lang.String _sWidgetpic)
                     throws WCMException
设置属性：Widgetpic

参数：
_sWidgetpic - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWDefaultStyle

public java.lang.String getWDefaultStyle()
提取属性：WDefaultStyle

返回：
WDefaultStyle

setWDefaultStyle

public boolean setWDefaultStyle(java.lang.String _sWDefaultStyle)
                         throws WCMException
设置属性：WDefaultStyle

参数：
_nWDefaultStyle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCDefaultStyle

public java.lang.String getCDefaultStyle()
提取属性：CDefaultStyle

返回：
CDefaultStyle

setCDefaultStyle

public boolean setCDefaultStyle(int _nCDefaultStyle)
                         throws WCMException
设置属性：CDefaultStyle

参数：
_nCDefaultStyle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWidgetAttrURL

public java.lang.String getWidgetAttrURL()
提取属性：WidgetAttrURL

返回：
WidgetAttrURL

setWidgetAttrURL

public boolean setWidgetAttrURL(java.lang.String _sWidgetAttrURL)
                         throws WCMException
设置属性：WidgetAttrURL

参数：
_sWidgetAttrURL - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getContentStyle

public java.lang.String getContentStyle()
提取属性：ContentStyle

返回：
ContentStyle

setContentStyle

public boolean setContentStyle(java.lang.String _sContentStyle)
                        throws WCMException
设置属性：ContentStyle

参数：
_sContentStyle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWidgetType

public int getWidgetType()
提取属性：WidgetType

返回：
WidgetType

setWidgetType

public boolean setWidgetType(int _nWidgetType)
                      throws WCMException
设置属性：WidgetType

参数：
_nWidgetType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIdentityFlag

public java.lang.String getIdentityFlag(java.lang.String _sWidgetName)
                                 throws WCMException
提取唯一标识：IdentityFlag

参数：
_sWidgetName -
返回：
返回可唯一标识当前资源块的字符串.
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final Widget findById(int _nId)
                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Widget createNewInstance()
                                      throws WCMException
产生当前对象[Widget]的实例

返回：
当前对象的实例[Widget]
抛出：
WCMException

findByKey

public static final Widget findByKey(java.lang.Object _oKey)
                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetConstants

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetConstants

public class WidgetConstants
extends java.lang.Object

作者：
wyw

字段摘要
static java.lang.String | CONTENT_STYLE_PARAMETER 内容风格固有变量
static int | FIELD_TYPE_APPENDIX 附件类型变量
static int | FIELD_TYPE_CHECKBOX 多选类型变量
static int | FIELD_TYPE_CLASS 分类法类型变量
static int | FIELD_TYPE_ENUMVALUE 枚举类型变量
static int | FIELD_TYPE_HTML 复杂编辑器类型变量
static int | FIELD_TYPE_HTML_CHAR 编辑器类型变量
static int | FIELD_TYPE_INPUT_SELECT 可输入下拉类型变量
static int | FIELD_TYPE_INT 整数类型变量
static int | FIELD_TYPE_MULTITEXT 多行文本类型变量
static int | FIELD_TYPE_NORMALTEXT 普通文本类型变量
static int | FIELD_TYPE_PASSWORD 密码类型变量
static int | FIELD_TYPE_RADIO 单选类型变量
static int | FIELD_TYPE_RELDOC 相关文档类型变量
static int | FIELD_TYPE_SELCHANNEL 栏目选择类型变量
static int | FIELD_TYPE_SELECT 下拉选择类型变量
static int | FIELD_TYPE_SELFDEFINE 自定义类型变量
static int | FIELD_TYPE_SUGGESTION suggestion类型变量
static int | FIELD_TYPE_TIMESTAMP 日期类型变量
static int | FIELD_TYPE_TRUEORFALSE 是否类型变量
static java.lang.String[][] | FIEXED_PARAMETERS
static int | WIDGET_DEAL_MODE_CHANGE 导入时出现资源重名的处理方式 : 更名
static int | WIDGET_DEAL_MODE_IGNORE 导入时出现资源重名的处理方式 : 忽略
static int | WIDGET_DEAL_MODE_UPDATE 导入时出现资源重名的处理方式 : 覆盖
static java.lang.String | WIDGET_STYLE_PARAMETER 资源风格固有变量
static WidgetParameterTypes | WidgetParameter_TYPES
构造方法摘要
WidgetConstants()
方法摘要
static boolean isFixedParameter(java.lang.String sParameterName)
判断是否是固有变量
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

WIDGET_DEAL_MODE_UPDATE

public static final int WIDGET_DEAL_MODE_UPDATE
导入时出现资源重名的处理方式 : 覆盖

另请参见：
常量字段值

WIDGET_DEAL_MODE_IGNORE

public static final int WIDGET_DEAL_MODE_IGNORE
导入时出现资源重名的处理方式 : 忽略

另请参见：
常量字段值

WIDGET_DEAL_MODE_CHANGE

public static final int WIDGET_DEAL_MODE_CHANGE
导入时出现资源重名的处理方式 : 更名

另请参见：
常量字段值

FIELD_TYPE_ENUMVALUE

public static final int FIELD_TYPE_ENUMVALUE
枚举类型变量

另请参见：
常量字段值

FIELD_TYPE_APPENDIX

public static final int FIELD_TYPE_APPENDIX
附件类型变量

另请参见：
常量字段值

FIELD_TYPE_CLASS

public static final int FIELD_TYPE_CLASS
分类法类型变量

另请参见：
常量字段值

FIELD_TYPE_HTML

public static final int FIELD_TYPE_HTML
复杂编辑器类型变量

另请参见：
常量字段值

FIELD_TYPE_RELDOC

public static final int FIELD_TYPE_RELDOC
相关文档类型变量

另请参见：
常量字段值

FIELD_TYPE_INPUT_SELECT

public static final int FIELD_TYPE_INPUT_SELECT
可输入下拉类型变量

另请参见：
常量字段值

FIELD_TYPE_HTML_CHAR

public static final int FIELD_TYPE_HTML_CHAR
编辑器类型变量

另请参见：
常量字段值

FIELD_TYPE_SUGGESTION

public static final int FIELD_TYPE_SUGGESTION
suggestion类型变量

另请参见：
常量字段值

FIELD_TYPE_RADIO

public static final int FIELD_TYPE_RADIO
单选类型变量

另请参见：
常量字段值

FIELD_TYPE_SELECT

public static final int FIELD_TYPE_SELECT
下拉选择类型变量

另请参见：
常量字段值

FIELD_TYPE_CHECKBOX

public static final int FIELD_TYPE_CHECKBOX
多选类型变量

另请参见：
常量字段值

FIELD_TYPE_NORMALTEXT

public static final int FIELD_TYPE_NORMALTEXT
普通文本类型变量

另请参见：
常量字段值

FIELD_TYPE_PASSWORD

public static final int FIELD_TYPE_PASSWORD
密码类型变量

另请参见：
常量字段值

FIELD_TYPE_MULTITEXT

public static final int FIELD_TYPE_MULTITEXT
多行文本类型变量

另请参见：
常量字段值

FIELD_TYPE_TRUEORFALSE

public static final int FIELD_TYPE_TRUEORFALSE
是否类型变量

另请参见：
常量字段值

FIELD_TYPE_SELFDEFINE

public static final int FIELD_TYPE_SELFDEFINE
自定义类型变量

另请参见：
常量字段值

FIELD_TYPE_TIMESTAMP

public static final int FIELD_TYPE_TIMESTAMP
日期类型变量

另请参见：
常量字段值

FIELD_TYPE_SELCHANNEL

public static final int FIELD_TYPE_SELCHANNEL
栏目选择类型变量

另请参见：
常量字段值

FIELD_TYPE_INT

public static final int FIELD_TYPE_INT
整数类型变量

另请参见：
常量字段值

WIDGET_STYLE_PARAMETER

public static final java.lang.String WIDGET_STYLE_PARAMETER
资源风格固有变量

另请参见：
常量字段值

CONTENT_STYLE_PARAMETER

public static final java.lang.String CONTENT_STYLE_PARAMETER
内容风格固有变量

另请参见：
常量字段值

FIEXED_PARAMETERS

public static final java.lang.String[][] FIEXED_PARAMETERS

WidgetParameter_TYPES

public static final WidgetParameterTypes WidgetParameter_TYPES
构造方法详细信息

WidgetConstants

public WidgetConstants()
方法详细信息

isFixedParameter

public static boolean isFixedParameter(java.lang.String sParameterName)
判断是否是固有变量

参数：
sParameterName -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetInstance

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetInstance

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.WidgetInstance
所有已实现的接口：
java.lang.Cloneable
public class WidgetInstance
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
WidgetInstance()
构造函数：保留默认接口
方法摘要
static WidgetInstance | createNewInstance() 产生当前对象[WidgetInstance]的实例
static WidgetInstance | findById(int _nId) 提取指定ID的对象
static WidgetInstance | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getTemplateId() 提取属性：TemplateId
int | getWCMType() 取得该对象的类型编号
Widget | getWidget()
int | getWidgetId() 提取属性：WidgetId
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setTemplateId(int _nTemplateId) 设置属性：TemplateId
boolean | setWidgetId(int _nWidgetId) 设置属性：WidgetId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

WidgetInstance

public WidgetInstance()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getWidgetId

public int getWidgetId()
提取属性：WidgetId

返回：
WidgetId

setWidgetId

public boolean setWidgetId(int _nWidgetId)
                    throws WCMException
设置属性：WidgetId

参数：
_nWidgetId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTemplateId

public int getTemplateId()
提取属性：TemplateId

返回：
TemplateId

setTemplateId

public boolean setTemplateId(int _nTemplateId)
                      throws WCMException
设置属性：TemplateId

参数：
_nTemplateId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final WidgetInstance findById(int _nId)
                                     throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final WidgetInstance createNewInstance()
                                              throws WCMException
产生当前对象[WidgetInstance]的实例

返回：
当前对象的实例[WidgetInstance]
抛出：
WCMException

findByKey

public static final WidgetInstance findByKey(java.lang.Object _oKey)
                                      throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getWidget

public Widget getWidget()
                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetInstanceMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetInstanceMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetInstanceMgr
所有已实现的接口：
IWidgetInstanceMgr
public class WidgetInstanceMgr
extends java.lang.Object
implements IWidgetInstanceMgr

构造方法摘要
WidgetInstanceMgr()
方法摘要
void | delete(WidgetInstance widgetInstance) 删除资源块实例和其下的所有变量
WidgetInstance | save(User _loginUser, WidgetInstance _WidgetInstance) 对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象
WidgetInstance | save(WidgetInstance widgetInstance, java.util.Map parameters) 修改指定的资源块实例的变量信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetInstanceMgr

public WidgetInstanceMgr()
方法详细信息

save

public WidgetInstance save(User _loginUser,
                           WidgetInstance _WidgetInstance)
                    throws WCMException
从接口 IWidgetInstanceMgr 复制的描述
对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象

指定者：
接口 IWidgetInstanceMgr 中的 save
返回：
抛出：
WCMException

save

public WidgetInstance save(WidgetInstance widgetInstance,
                           java.util.Map parameters)
                    throws WCMException
从接口 IWidgetInstanceMgr 复制的描述
修改指定的资源块实例的变量信息

指定者：
接口 IWidgetInstanceMgr 中的 save
返回：
抛出：
WCMException

delete

public void delete(WidgetInstance widgetInstance)
            throws WCMException
从接口 IWidgetInstanceMgr 复制的描述
删除资源块实例和其下的所有变量

指定者：
接口 IWidgetInstanceMgr 中的 delete
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetInstances

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetInstances

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.WidgetInstances

public class WidgetInstances
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WidgetInstances(User _currUser)
构造函数
WidgetInstances(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static WidgetInstances | createNewInstance(User _currUser) 产生当前集合对象[WidgetInstances]的实例
static WidgetInstances | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static WidgetInstances | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetInstances]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetInstances

public WidgetInstances(User _currUser)
构造函数

另请参见：
WidgetInstances( User _currUser, int _initCapacity, int _incCapacity );

WidgetInstances

public WidgetInstances(User _currUser,
                       int _initCapacity,
                       int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final WidgetInstances findByIds(User _currUser,
                                              java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（WidgetInstances）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final WidgetInstances openWCMObjs(User _currUser,
                                                WCMFilter _filter)
                                         throws WCMException
通过指定一个Filter获取当前集合[WidgetInstances]

参数：
_filter - 指定的Filter
返回：
当前集合[WidgetInstances]
抛出：
WCMException

createNewInstance

public static WidgetInstances createNewInstance(User _currUser)
产生当前集合对象[WidgetInstances]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetInstParameter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetInstParameter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.WidgetInstParameter
所有已实现的接口：
java.lang.Cloneable
public class WidgetInstParameter
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | MAX_BYTE_LENGTH_4_STRING
static int | OBJ_TYPE 对象类型编号
构造方法摘要
WidgetInstParameter()
构造函数：保留默认接口
方法摘要
static WidgetInstParameter | createNewInstance() 产生当前对象[WidgetInstParameter]的实例
static WidgetInstParameter | findById(int _nId) 提取指定ID的对象
static WidgetInstParameter | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getParamName() 提取属性：ParamName
java.lang.String | getParamValue() 提取属性：ParamValue
int | getWCMType() 取得该对象的类型编号
int | getWidgetInstId() 提取属性：WidgetInstId
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setParamName(java.lang.String _sParamName) 设置属性：ParamName
boolean | setParamValue(java.lang.String _sParamValue) 设置属性：ParamValue
boolean | setWidgetInstId(int _nWidgetInstId) 设置属性：WidgetInstId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

MAX_BYTE_LENGTH_4_STRING

public static final int MAX_BYTE_LENGTH_4_STRING
另请参见：
常量字段值
构造方法详细信息

WidgetInstParameter

public WidgetInstParameter()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getWidgetInstId

public int getWidgetInstId()
提取属性：WidgetInstId

返回：
WidgetInstId

setWidgetInstId

public boolean setWidgetInstId(int _nWidgetInstId)
                        throws WCMException
设置属性：WidgetInstId

参数：
_nWidgetInstId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getParamName

public java.lang.String getParamName()
提取属性：ParamName

返回：
ParamName

setParamName

public boolean setParamName(java.lang.String _sParamName)
                     throws WCMException
设置属性：ParamName

参数：
_sParamName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getParamValue

public java.lang.String getParamValue()
提取属性：ParamValue

返回：
ParamValue

setParamValue

public boolean setParamValue(java.lang.String _sParamValue)
                      throws WCMException
设置属性：ParamValue

参数：
_sParamValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final WidgetInstParameter findById(int _nId)
                                          throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final WidgetInstParameter createNewInstance()
                                                   throws WCMException
产生当前对象[WidgetInstParameter]的实例

返回：
当前对象的实例[WidgetInstParameter]
抛出：
WCMException

findByKey

public static final WidgetInstParameter findByKey(java.lang.Object _oKey)
                                           throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetInstParameterMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetInstParameterMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetInstParameterMgr
所有已实现的接口：
IWidgetInstParameterMgr
public class WidgetInstParameterMgr
extends java.lang.Object
implements IWidgetInstParameterMgr

构造方法摘要
WidgetInstParameterMgr()
方法摘要
WidgetInstParameters | addParameters(WidgetInstance oWidgetInstance, java.util.Map parameters) 给资源块实例对象设置相应的资源库实例变量,设置这些变量值之前，将清除该实例之前的所有变量
void | delete(WidgetInstance oWidgetInstance) 清除某个资源实例下的所有资源实例的变量信息
java.util.Map | getParameters(WidgetInstance widgetInstance) 根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写 修改说明：先取资源默认的资源变量值，再用资源变量实例值覆盖，防止添加资源变量后 在解析资源代码时有些变量不能替换的问题
java.util.Map | getParameters(WidgetInstance widgetInstance, java.lang.String selectFields) 根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写
WidgetInstParameter | getWidgetInstParameter(WidgetInstance widgetInstance, java.lang.String paraName) 获取指定资源块实例下的资源块实例变量
WidgetInstParameters | getWidgetInstParameters(WidgetInstance widgetInstance, WCMFilter filter) 获取资源块实例关联的资源块实例变量对象集合
WidgetInstParameters | saveParameters(WidgetInstance oWidgetInstance, java.util.Map parameters) 给资源块实例对象设置相应的资源库实例变量，仅仅只是设置这些传入了的变量的值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetInstParameterMgr

public WidgetInstParameterMgr()
方法详细信息

getParameters

public java.util.Map getParameters(WidgetInstance widgetInstance)
                            throws WCMException
从接口 IWidgetInstParameterMgr 复制的描述
根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写 修改说明：先取资源默认的资源变量值，再用资源变量实例值覆盖，防止添加资源变量后 在解析资源代码时有些变量不能替换的问题

指定者：
接口 IWidgetInstParameterMgr 中的 getParameters
返回：
抛出：
WCMException

getParameters

public java.util.Map getParameters(WidgetInstance widgetInstance,
                                   java.lang.String selectFields)
                            throws WCMException
从接口 IWidgetInstParameterMgr 复制的描述
根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写

指定者：
接口 IWidgetInstParameterMgr 中的 getParameters
返回：
抛出：
WCMException

getWidgetInstParameters

public WidgetInstParameters getWidgetInstParameters(WidgetInstance widgetInstance,
                                                    WCMFilter filter)
                                             throws WCMException
从接口 IWidgetInstParameterMgr 复制的描述
获取资源块实例关联的资源块实例变量对象集合

指定者：
接口 IWidgetInstParameterMgr 中的 getWidgetInstParameters
返回：
抛出：
WCMException

getWidgetInstParameter

public WidgetInstParameter getWidgetInstParameter(WidgetInstance widgetInstance,
                                                  java.lang.String paraName)
                                           throws WCMException
从接口 IWidgetInstParameterMgr 复制的描述
获取指定资源块实例下的资源块实例变量

指定者：
接口 IWidgetInstParameterMgr 中的 getWidgetInstParameter
返回：
抛出：
WCMException

saveParameters

public WidgetInstParameters saveParameters(WidgetInstance oWidgetInstance,
                                           java.util.Map parameters)
                                    throws WCMException
从接口 IWidgetInstParameterMgr 复制的描述
给资源块实例对象设置相应的资源库实例变量，仅仅只是设置这些传入了的变量的值

指定者：
接口 IWidgetInstParameterMgr 中的 saveParameters
返回：
抛出：
WCMException

addParameters

public WidgetInstParameters addParameters(WidgetInstance oWidgetInstance,
                                          java.util.Map parameters)
                                   throws WCMException
从接口 IWidgetInstParameterMgr 复制的描述
给资源块实例对象设置相应的资源库实例变量,设置这些变量值之前，将清除该实例之前的所有变量

指定者：
接口 IWidgetInstParameterMgr 中的 addParameters
抛出：
WCMException

delete

public void delete(WidgetInstance oWidgetInstance)
            throws WCMException
从接口 IWidgetInstParameterMgr 复制的描述
清除某个资源实例下的所有资源实例的变量信息

指定者：
接口 IWidgetInstParameterMgr 中的 delete
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetInstParameters

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetInstParameters

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.WidgetInstParameters

public class WidgetInstParameters
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WidgetInstParameters(User _currUser)
构造函数
WidgetInstParameters(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static WidgetInstParameters | createNewInstance(User _currUser) 产生当前集合对象[WidgetInstParameters]的实例
static WidgetInstParameters | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static WidgetInstParameters | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetInstParameters]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetInstParameters

public WidgetInstParameters(User _currUser)
构造函数

另请参见：
WidgetInstParameters( User _currUser, int _initCapacity, int _incCapacity );

WidgetInstParameters

public WidgetInstParameters(User _currUser,
                            int _initCapacity,
                            int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final WidgetInstParameters findByIds(User _currUser,
                                                   java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（WidgetInstParameters）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final WidgetInstParameters openWCMObjs(User _currUser,
                                                     WCMFilter _filter)
                                              throws WCMException
通过指定一个Filter获取当前集合[WidgetInstParameters]

参数：
_filter - 指定的Filter
返回：
当前集合[WidgetInstParameters]
抛出：
WCMException

createNewInstance

public static WidgetInstParameters createNewInstance(User _currUser)
产生当前集合对象[WidgetInstParameters]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetMgr
所有已实现的接口：
IWidgetMgr
public class WidgetMgr
extends java.lang.Object
implements IWidgetMgr

作者：
wyw

构造方法摘要
WidgetMgr()
方法摘要
boolean | delete(User _oCurrUser, Widget _oCurrWidget) 删除资源
boolean | existSimilarWidget(Widget _oCurrWidget) 判断是否已经存在同名的资源
java.lang.String | export(Widgets _oWidgets) 导出资源
Widget | findWidgetByName(User _oCurrUser, java.lang.String sWidgetName) 根据传入的资源块名称，返回找到的第一个资源块对象，如果没有找到合适的资源块对象，则返回null。
Reports | importWidgets(java.lang.String _sFile, int _nImportMode) 导入资源
Widgets | query(User _oCurrUser, WCMFilter _oFilter) 获取资源
Widget | saveWidget(User _oCurrUser, Widget _oCurrWidget) 保存资源
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetMgr

public WidgetMgr()
方法详细信息

delete

public boolean delete(User _oCurrUser,
                      Widget _oCurrWidget)
               throws java.lang.Exception
从接口 IWidgetMgr 复制的描述
删除资源

指定者：
接口 IWidgetMgr 中的 delete
参数：
_oCurrUser - 删除的当前用户
_oCurrWidget - 当前要删除的资源片段对象
返回：
抛出：
java.lang.Exception

query

public Widgets query(User _oCurrUser,
                     WCMFilter _oFilter)
              throws java.lang.Exception
从接口 IWidgetMgr 复制的描述
获取资源

指定者：
接口 IWidgetMgr 中的 query
参数：
_oCurrUser - 当前用户
_oFilter - 查询条件
返回：
抛出：
java.lang.Exception

saveWidget

public Widget saveWidget(User _oCurrUser,
                         Widget _oCurrWidget)
                  throws java.lang.Exception
从接口 IWidgetMgr 复制的描述
保存资源

指定者：
接口 IWidgetMgr 中的 saveWidget
参数：
_oCurrUser - 当前保存的用户
_oCurrWidget - 当前要保存的资源片段
返回：
抛出：
java.lang.Exception

existSimilarWidget

public boolean existSimilarWidget(Widget _oCurrWidget)
                           throws WCMException
判断是否已经存在同名的资源

参数：
_oCurrWidget - 当前新建或修改的资源对象
返回：
抛出：
WCMException

export

public java.lang.String export(Widgets _oWidgets)
                        throws WCMException
从接口 IWidgetMgr 复制的描述
导出资源

指定者：
接口 IWidgetMgr 中的 export
参数：
_oWidgets - 资源对象集
返回：
抛出：
WCMException

importWidgets

public Reports importWidgets(java.lang.String _sFile,
                             int _nImportMode)
                      throws WCMException
从接口 IWidgetMgr 复制的描述
导入资源

指定者：
接口 IWidgetMgr 中的 importWidgets
返回：
抛出：
WCMException

findWidgetByName

public Widget findWidgetByName(User _oCurrUser,
                               java.lang.String sWidgetName)
                        throws WCMException
从接口 IWidgetMgr 复制的描述
根据传入的资源块名称，返回找到的第一个资源块对象，如果没有找到合适的资源块对象，则返回null。id越大，获取时优先级越高

指定者：
接口 IWidgetMgr 中的 findWidgetByName
参数：
_oCurrUser - 当前用户
sWidgetName - 资源块的名称
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetParameter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetParameter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.publish.widget.WidgetParameter
所有已实现的接口：
java.lang.Cloneable
public class WidgetParameter
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
static char | PARAMETER_END_FLAG 资源块变量的开始标记
static char[] | PARAMETER_FLAG 资源块变量的标记
static char | PARAMETER_START_FLAG 资源块变量的开始标记
构造方法摘要
WidgetParameter()
构造函数：保留默认接口
方法摘要
static WidgetParameter | createNewInstance() 产生当前对象[WidgetParameter]的实例
static WidgetParameter | findById(int _nId) 提取指定ID的对象
static WidgetParameter | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getClassId() 提取属性：CLASSID
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDefaultValue() 提取属性：DefaultValue
java.lang.String | getEnmvalue() 提取属性：Enmvalue
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getNotEdit() 提取属性：NotEdit
int | getNotnull() 提取属性：Notnull
int | getOrder() 提取属性：Order
int | getRadorchk() 提取属性：Radorchk
java.lang.String | getValidator() 提取属性：Validator
int | getWCMType() 取得该对象的类型编号
int | getWidgetId() 提取属性：WidgetId
java.lang.String | getWidgetParamDesc() 提取属性：WidgetParamDesc
java.lang.String | getWidgetParamName() 提取属性：WidgetParamName
int | getWidgetParamType() 提取属性：WidgetParamType
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setClassId(int _nClassId) 设置属性：CLASSID
boolean | setDefaultValue(java.lang.String _sDefaultValue) 设置属性：DefaultValue
boolean | setEnmvalue(java.lang.String _sEnmvalue) 设置属性：Enmvalue
boolean | setNotEdit(int _nNotEdit) 设置属性：NotEdit
boolean | setNotnull(int _nNotnull) 设置属性：Notnull
boolean | setOrder(int _nOrder) 设置属性：Order
boolean | setRadorchk(int _nRadorchk) 设置属性：Radorchk
boolean | setValidator(java.lang.String _sValidator) 设置属性：Validator
boolean | setWidgetId(int _nWidgetId) 设置属性：WidgetId
boolean | setWidgetParamDesc(java.lang.String _sWidgetParamDesc) 设置属性：WidgetParamDesc
boolean | setWidgetParamName(java.lang.String _sWidgetParamName) 设置属性：WidgetParamName
boolean | setWidgetParamType(int _nWidgetParamType) 设置属性：WidgetParamType
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

PARAMETER_START_FLAG

public static final char PARAMETER_START_FLAG
资源块变量的开始标记

另请参见：
常量字段值

PARAMETER_END_FLAG

public static final char PARAMETER_END_FLAG
资源块变量的开始标记

另请参见：
常量字段值

PARAMETER_FLAG

public static final char[] PARAMETER_FLAG
资源块变量的标记

构造方法详细信息

WidgetParameter

public WidgetParameter()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getWidgetId

public int getWidgetId()
提取属性：WidgetId

返回：
WidgetId

setWidgetId

public boolean setWidgetId(int _nWidgetId)
                    throws WCMException
设置属性：WidgetId

参数：
_nWidgetId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWidgetParamName

public java.lang.String getWidgetParamName()
提取属性：WidgetParamName

返回：
WidgetParamName

setWidgetParamName

public boolean setWidgetParamName(java.lang.String _sWidgetParamName)
                           throws WCMException
设置属性：WidgetParamName

参数：
_sWidgetParamName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWidgetParamDesc

public java.lang.String getWidgetParamDesc()
提取属性：WidgetParamDesc

返回：
WidgetParamDesc

setWidgetParamDesc

public boolean setWidgetParamDesc(java.lang.String _sWidgetParamDesc)
                           throws WCMException
设置属性：WidgetParamDesc

参数：
_sWidgetParamDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWidgetParamType

public int getWidgetParamType()
提取属性：WidgetParamType

返回：
WidgetParamType

setWidgetParamType

public boolean setWidgetParamType(int _nWidgetParamType)
                           throws WCMException
设置属性：WidgetParamType

参数：
_nWidgetParamType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDefaultValue

public java.lang.String getDefaultValue()
提取属性：DefaultValue

返回：
DefaultValue

setDefaultValue

public boolean setDefaultValue(java.lang.String _sDefaultValue)
                        throws WCMException
设置属性：DefaultValue

参数：
_sDefaultValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEnmvalue

public java.lang.String getEnmvalue()
提取属性：Enmvalue

返回：
Enmvalue

setEnmvalue

public boolean setEnmvalue(java.lang.String _sEnmvalue)
                    throws WCMException
设置属性：Enmvalue

参数：
_sEnmvalue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getNotnull

public int getNotnull()
提取属性：Notnull

返回：
Notnull

setNotnull

public boolean setNotnull(int _nNotnull)
                   throws WCMException
设置属性：Notnull

参数：
_nNotnull - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getClassId

public int getClassId()
提取属性：CLASSID

返回：
CLASSID

setClassId

public boolean setClassId(int _nClassId)
                   throws WCMException
设置属性：CLASSID

参数：
_nClassId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getValidator

public java.lang.String getValidator()
提取属性：Validator

返回：
Validator

setValidator

public boolean setValidator(java.lang.String _sValidator)
                     throws WCMException
设置属性：Validator

参数：
_sValidator - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getNotEdit

public int getNotEdit()
提取属性：NotEdit

返回：
NotEdit

setNotEdit

public boolean setNotEdit(int _nNotEdit)
                   throws WCMException
设置属性：NotEdit

参数：
_nNotEdit - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOrder

public int getOrder()
提取属性：Order

返回：
Order

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置属性：Order

参数：
_nOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRadorchk

public int getRadorchk()
提取属性：Radorchk

返回：
Radorchk

setRadorchk

public boolean setRadorchk(int _nRadorchk)
                    throws WCMException
设置属性：Radorchk

参数：
_nRadorchk - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final WidgetParameter findById(int _nId)
                                      throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final WidgetParameter createNewInstance()
                                               throws WCMException
产生当前对象[WidgetParameter]的实例

返回：
当前对象的实例[WidgetParameter]
抛出：
WCMException

findByKey

public static final WidgetParameter findByKey(java.lang.Object _oKey)
                                       throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetParameterMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetParameterMgr

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetParameterMgr
所有已实现的接口：
IWidgetParameterMgr
public class WidgetParameterMgr
extends java.lang.Object
implements IWidgetParameterMgr

作者：
wyw

构造方法摘要
WidgetParameterMgr()
方法摘要
boolean | delete(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 删除资源变量
boolean | existWidgetParameter(Widget _oCurrWidget, WidgetParameter _oCurrWidgetParameter) 判断是否已经存在同名资源变量
WidgetParameter | findParameter(WidgetInstParameter widgetInstParameter) 根据资源变量实例获取到资源变量
WidgetParameter | findParameterByName(Widget _oCurrWidget, java.lang.String sParameterName) 获取指定资源下，指定名称的资源变量
WidgetParameters | query(User _oCurrUser, WCMFilter _oFilter) 获取某资源所具有的资源变量
WidgetParameters | query(Widget _oCurrWidget) 获取资源的所有资源变量
WidgetParameter | saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 保存资源变量
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetParameterMgr

public WidgetParameterMgr()
方法详细信息

saveWidgetParameter

public WidgetParameter saveWidgetParameter(User _oCurrUser,
                                           WidgetParameter _oCurrWidgetParameter)
                                    throws WCMException
从接口 IWidgetParameterMgr 复制的描述
保存资源变量

指定者：
接口 IWidgetParameterMgr 中的 saveWidgetParameter
参数：
_oCurrUser - 保存资源变量的当前用户
_oCurrWidgetParameter - 将要保存的资源变量对象
返回：
抛出：
WCMException

delete

public boolean delete(User _oCurrUser,
                      WidgetParameter _oCurrWidgetParameter)
               throws WCMException
从接口 IWidgetParameterMgr 复制的描述
删除资源变量

指定者：
接口 IWidgetParameterMgr 中的 delete
参数：
_oCurrUser - 当前删除操作的用户
_oCurrWidgetParameter - 将要删除的资源变量对象
返回：
抛出：
WCMException

query

public WidgetParameters query(User _oCurrUser,
                              WCMFilter _oFilter)
                       throws WCMException
从接口 IWidgetParameterMgr 复制的描述
获取某资源所具有的资源变量

指定者：
接口 IWidgetParameterMgr 中的 query
参数：
_oCurrUser - 当前用户
_oFilter - 列表查询条件
返回：
抛出：
WCMException

existWidgetParameter

public boolean existWidgetParameter(Widget _oCurrWidget,
                                    WidgetParameter _oCurrWidgetParameter)
                             throws WCMException
从接口 IWidgetParameterMgr 复制的描述
判断是否已经存在同名资源变量

指定者：
接口 IWidgetParameterMgr 中的 existWidgetParameter
参数：
_oCurrWidget - 所属资源对象
_oCurrWidgetParameter - 资源变量对象
返回：
抛出：
WCMException

query

public WidgetParameters query(Widget _oCurrWidget)
                       throws WCMException
从接口 IWidgetParameterMgr 复制的描述
获取资源的所有资源变量

指定者：
接口 IWidgetParameterMgr 中的 query
参数：
_oCurrWidget - 资源对象
返回：
抛出：
WCMException

findParameterByName

public WidgetParameter findParameterByName(Widget _oCurrWidget,
                                           java.lang.String sParameterName)
                                    throws WCMException
从接口 IWidgetParameterMgr 复制的描述
获取指定资源下，指定名称的资源变量

指定者：
接口 IWidgetParameterMgr 中的 findParameterByName
返回：
抛出：
WCMException

findParameter

public WidgetParameter findParameter(WidgetInstParameter widgetInstParameter)
                              throws WCMException
从接口 IWidgetParameterMgr 复制的描述
根据资源变量实例获取到资源变量

指定者：
接口 IWidgetParameterMgr 中的 findParameter
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetParameters

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetParameters

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.WidgetParameters

public class WidgetParameters
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WidgetParameters(User _currUser)
构造函数
WidgetParameters(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static WidgetParameters | createNewInstance(User _currUser) 产生当前集合对象[WidgetParameters]的实例
static WidgetParameters | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static WidgetParameters | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetParameters]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetParameters

public WidgetParameters(User _currUser)
构造函数

另请参见：
WidgetParameters( User _currUser, int _initCapacity, int _incCapacity );

WidgetParameters

public WidgetParameters(User _currUser,
                        int _initCapacity,
                        int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final WidgetParameters findByIds(User _currUser,
                                               java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（WidgetParameters）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final WidgetParameters openWCMObjs(User _currUser,
                                                 WCMFilter _filter)
                                          throws WCMException
通过指定一个Filter获取当前集合[WidgetParameters]

参数：
_filter - 指定的Filter
返回：
当前集合[WidgetParameters]
抛出：
WCMException

createNewInstance

public static WidgetParameters createNewInstance(User _currUser)
产生当前集合对象[WidgetParameters]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetParameterServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetParameterServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetParameterServiceProvider
所有已实现的接口：
IWidgetParameterServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class WidgetParameterServiceProvider
extends java.lang.Object
implements IWidgetParameterServiceProvider

作者：
wyw

构造方法摘要
WidgetParameterServiceProvider()
方法摘要
void | changeOrder(MethodContext context) 改变资源变量的顺序
void | delete(MethodContext _context) 删除资源变量
boolean | existsSimilarName(MethodContext context) 判断是否存在相同名称的资源变量
java.lang.Object | findById(MethodContext context) 暂时没有用到，没有实现
java.lang.Object | findByIds(MethodContext context) 暂时没有用到，没有实现
java.lang.Object | query(MethodContext _context) 获取资源变量对象集
int | save(MethodContext _context) 保存当前资源变量
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetParameterServiceProvider

public WidgetParameterServiceProvider()
方法详细信息

delete

public void delete(MethodContext _context)
            throws java.lang.Exception
从接口 IWidgetParameterServiceProvider 复制的描述
删除资源变量

指定者：
接口 IWidgetParameterServiceProvider 中的 delete
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Exception

query

public java.lang.Object query(MethodContext _context)
                       throws java.lang.Exception
从接口 IWidgetParameterServiceProvider 复制的描述
获取资源变量对象集

指定者：
接口 IWidgetParameterServiceProvider 中的 query
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Exception

save

public int save(MethodContext _context)
         throws java.lang.Exception
从接口 IWidgetParameterServiceProvider 复制的描述
保存当前资源变量

指定者：
接口 IWidgetParameterServiceProvider 中的 save
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Exception

existsSimilarName

public boolean existsSimilarName(MethodContext context)
                          throws java.lang.Exception
从接口 IWidgetParameterServiceProvider 复制的描述
判断是否存在相同名称的资源变量

指定者：
接口 IWidgetParameterServiceProvider 中的 existsSimilarName
返回：
抛出：
java.lang.Exception

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
暂时没有用到，没有实现

指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable
另请参见：
com.trs.webframework.provider.IFindByIdServiceProvider#findById(com.trs .webframework.context.MethodContext)

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
暂时没有用到，没有实现

指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
另请参见：
com.trs.webframework.provider.IFindByIdsServiceProvider#findByIds(com .trs.webframework.context.MethodContext)

changeOrder

public void changeOrder(MethodContext context)
                 throws java.lang.Exception
从接口 IWidgetParameterServiceProvider 复制的描述
改变资源变量的顺序

指定者：
接口 IWidgetParameterServiceProvider 中的 changeOrder
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetParameterType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetParameterType

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetParameterType

public class WidgetParameterType
extends java.lang.Object

作者：
wyw

构造方法摘要
WidgetParameterType(int _nWidgetParameterType, java.lang.String _sWidgetParameterTypeDesc, java.lang.String _sKey)
方法摘要
java.lang.String | getKey() 获取注册的变量的key
int | getWidgetParameterType() 获取变量类型
java.lang.String | getWidgetParameterTypeDesc() 获取变量类型描述
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetParameterType

public WidgetParameterType(int _nWidgetParameterType,
                           java.lang.String _sWidgetParameterTypeDesc,
                           java.lang.String _sKey)
方法详细信息

getWidgetParameterType

public int getWidgetParameterType()
获取变量类型

返回：

getWidgetParameterTypeDesc

public java.lang.String getWidgetParameterTypeDesc()
获取变量类型描述

返回：

getKey

public java.lang.String getKey()
获取注册的变量的key

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetParameterTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetParameterTypes

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetParameterTypes

public class WidgetParameterTypes
extends java.lang.Object

作者：
wyw

构造方法摘要
WidgetParameterTypes()
方法摘要
int | getParameterTypesCount() 获取类型的个数
WidgetParameterType | getWidgetParameterTypeAt(int _nIndex) 根据索引获取变量类型对象
WidgetParameterType | getWidgetParameterTypeById(int _nTypeId) 根据变量类型的TypeId，获取变量类型对象
void | registerWidgetParameterType(int _nTypeId, java.lang.String _sWidgetParameterTypeDesc, java.lang.String _sKey) 注册新的资源变量类型
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetParameterTypes

public WidgetParameterTypes()
方法详细信息

registerWidgetParameterType

public void registerWidgetParameterType(int _nTypeId,
                                        java.lang.String _sWidgetParameterTypeDesc,
                                        java.lang.String _sKey)
注册新的资源变量类型

参数：
_nTypeId -
_sWidgetParameterTypeDesc -
_nSqlDataType -

getParameterTypesCount

public int getParameterTypesCount()
获取类型的个数

返回：

getWidgetParameterTypeAt

public WidgetParameterType getWidgetParameterTypeAt(int _nIndex)
根据索引获取变量类型对象

参数：
_nIndex -
返回：

getWidgetParameterTypeById

public WidgetParameterType getWidgetParameterTypeById(int _nTypeId)
根据变量类型的TypeId，获取变量类型对象

参数：
_nTypeId -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetPathHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetPathHelper

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetPathHelper

public class WidgetPathHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

字段摘要
static java.lang.String | m_sCommonPath 资源块内嵌JS的路径
static java.lang.String | m_sSpecialPath 专题的路径
static java.lang.String | m_sStylePath 资源块的路径
static java.lang.String | m_sWcmApp 65应用的主要目录
构造方法摘要
WidgetPathHelper()
方法摘要
static java.lang.String getPath()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

m_sWcmApp

public static final java.lang.String m_sWcmApp
65应用的主要目录

另请参见：
常量字段值

m_sSpecialPath

public static final java.lang.String m_sSpecialPath
专题的路径

另请参见：
常量字段值

m_sStylePath

public static final java.lang.String m_sStylePath
资源块的路径

另请参见：
常量字段值

m_sCommonPath

public static final java.lang.String m_sCommonPath
资源块内嵌JS的路径

另请参见：
常量字段值
构造方法详细信息

WidgetPathHelper

public WidgetPathHelper()
方法详细信息

getPath

public static java.lang.String getPath()
                                throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Widgets

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 Widgets

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.publish.widget.Widgets

public class Widgets
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Widgets(User _currUser)
构造函数
Widgets(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Widgets | createNewInstance(User _currUser) 产生当前集合对象[Widgets]的实例
static Widgets | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Widgets | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Widgets]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Widgets

public Widgets(User _currUser)
构造函数

另请参见：
Widgets( User _currUser, int _initCapacity, int _incCapacity );

Widgets

public Widgets(User _currUser,
               int _initCapacity,
               int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final Widgets findByIds(User _currUser,
                                      java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Widgets）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Widgets openWCMObjs(User _currUser,
                                        WCMFilter _filter)
                                 throws WCMException
通过指定一个Filter获取当前集合[Widgets]

参数：
_filter - 指定的Filter
返回：
当前集合[Widgets]
抛出：
WCMException

createNewInstance

public static Widgets createNewInstance(User _currUser)
产生当前集合对象[Widgets]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetServer

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetServer
所有已实现的接口：
IWidgetServer
public class WidgetServer
extends java.lang.Object
implements IWidgetServer

作者：
Administrator

构造方法摘要
WidgetServer()
方法摘要
Template | createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType) 根据母版内容，创建新的模板
void | insertStyleTag(Special special, Template template) 专题设置页面风格时所触发的逻辑，将专题所属的首页模板插入含当前页面风格标识的置标，发布时完成风格的切换
java.lang.String | parseToEditContent(IPublishElement _oPageElement, java.lang.String _sTemplateContent) 将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
java.lang.String | parseToEditContent(IPublishElement _oPageElement, Template _oTemplateForEdit) 将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
java.lang.String | parseToEditContent(IPublishElement pageElement, WidgetInstance widgetInstance) 解析某一个资源块实例对象成可编辑的状态
java.lang.String | parseToTemplate(java.lang.String sVisualHtml) 将可视化模板的内容，解析成相应的模板
java.lang.String | replaceWidgetInstParameters(WidgetInstance widgetInstance) 通过资源实例，获取资源实例的内容，并替换其中的资源实例变量
void | synchronizeWidgetInstances(Template template) 将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetServer

public WidgetServer()
方法详细信息

createTemplateFromMaster

public Template createTemplateFromMaster(IPublishFolder _oPageFolder,
                                         Master _oMaster,
                                         int _nMasterType)
                                  throws WCMException
从接口 IWidgetServer 复制的描述
根据母版内容，创建新的模板

指定者：
接口 IWidgetServer 中的 createTemplateFromMaster
参数：
_oPageFolder - TODO
_oMaster - 依据的母版
返回：
考虑到母版中可能会定义首页、二级页面、细览页面，所以返回模板集合对象
抛出：
WCMException

parseToEditContent

public java.lang.String parseToEditContent(IPublishElement _oPageElement,
                                           java.lang.String _sTemplateContent)
                                    throws java.lang.Exception
从接口 IWidgetServer 复制的描述
将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态

指定者：
接口 IWidgetServer 中的 parseToEditContent
参数：
_oPageElement - 需要解析的发布对象（一般为站点、栏目或文档）
_sTemplateContent - 需要编辑的模板内容
返回：
抛出：
java.lang.Exception

parseToEditContent

public java.lang.String parseToEditContent(IPublishElement _oPageElement,
                                           Template _oTemplateForEdit)
                                    throws java.lang.Exception
从接口 IWidgetServer 复制的描述
将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态

指定者：
接口 IWidgetServer 中的 parseToEditContent
参数：
_oPageElement - 需要解析的发布对象（一般为站点、栏目或文档）
_oTemplateForEdit - 需要编辑的模板
返回：
抛出：
java.lang.Exception

parseToEditContent

public java.lang.String parseToEditContent(IPublishElement pageElement,
                                           WidgetInstance widgetInstance)
                                    throws java.lang.Exception
从接口 IWidgetServer 复制的描述
解析某一个资源块实例对象成可编辑的状态

指定者：
接口 IWidgetServer 中的 parseToEditContent
参数：
pageElement - 需要解析的发布对象（一般为站点、栏目或文档）
widgetInstance - 需要解析的资源块实例
返回：
抛出：
java.lang.Exception

replaceWidgetInstParameters

public java.lang.String replaceWidgetInstParameters(WidgetInstance widgetInstance)
                                             throws WCMException
从接口 IWidgetServer 复制的描述
通过资源实例，获取资源实例的内容，并替换其中的资源实例变量

指定者：
接口 IWidgetServer 中的 replaceWidgetInstParameters
返回：
已经替换了资源实例变量的资源实例的内容
抛出：
WCMException

parseToTemplate

public java.lang.String parseToTemplate(java.lang.String sVisualHtml)
                                 throws WCMException
从接口 IWidgetServer 复制的描述
将可视化模板的内容，解析成相应的模板

指定者：
接口 IWidgetServer 中的 parseToTemplate
参数：
sVisualHtml - 可视化模板的内容，其中的资源实例的html代码格式为：]*>@!@--(\\d+)--@!@，其中的 \\d+为资源实例的id
返回：
解析之后，可以作为模板内容的字符串
抛出：
WCMException

synchronizeWidgetInstances

public void synchronizeWidgetInstances(Template template)
                                throws WCMException
从接口 IWidgetServer 复制的描述
将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。 为什么需要同步模板和资源实例的内容？是由于在可视化模板设计过程中 。并没有时刻将可视化模板的内容与使用的实例的内容保持一致，否则将不支持，撤销与同步操作。所以必须在可视化页面退出之后，再进行资源实例的同步处理。

指定者：
接口 IWidgetServer 中的 synchronizeWidgetInstances
抛出：
WCMException

insertStyleTag

public void insertStyleTag(Special special,
                           Template template)
                    throws WCMException,
                           java.lang.Exception
从接口 IWidgetServer 复制的描述
专题设置页面风格时所触发的逻辑，将专题所属的首页模板插入含当前页面风格标识的置标，发布时完成风格的切换

指定者：
接口 IWidgetServer 中的 insertStyleTag
抛出：
WCMException
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetServiceProvider

java.lang.Object
    继承者  com.trs.components.common.publish.widget.WidgetServiceProvider
所有已实现的接口：
IWidgetServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class WidgetServiceProvider
extends java.lang.Object
implements IWidgetServiceProvider

构造方法摘要
WidgetServiceProvider()
方法摘要
void | delete(MethodContext _context) 删除资源片段
boolean | existsSimilarName(MethodContext _context) 检查是否有同名模板
java.lang.String | export(MethodContext _context) 导入资源
java.lang.Object | findById(MethodContext context) 暂时没有用到，没有实现
java.lang.Object | findByIds(MethodContext context) 暂时没有用到，没有实现
java.lang.String | importWidgets(MethodContext _context) 导出资源
java.lang.Object | query(MethodContext _context) 获取资源片段集
int | save(MethodContext _context) 保存当前资源片段
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetServiceProvider

public WidgetServiceProvider()
方法详细信息

delete

public void delete(MethodContext _context)
            throws java.lang.Exception
从接口 IWidgetServiceProvider 复制的描述
删除资源片段

指定者：
接口 IWidgetServiceProvider 中的 delete
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Exception

query

public java.lang.Object query(MethodContext _context)
                       throws java.lang.Exception
从接口 IWidgetServiceProvider 复制的描述
获取资源片段集

指定者：
接口 IWidgetServiceProvider 中的 query
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Exception

save

public int save(MethodContext _context)
         throws java.lang.Exception
从接口 IWidgetServiceProvider 复制的描述
保存当前资源片段

指定者：
接口 IWidgetServiceProvider 中的 save
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Exception

existsSimilarName

public boolean existsSimilarName(MethodContext _context)
                          throws java.lang.Exception
从接口 IWidgetServiceProvider 复制的描述
检查是否有同名模板

指定者：
接口 IWidgetServiceProvider 中的 existsSimilarName
返回：
抛出：
java.lang.Exception

importWidgets

public java.lang.String importWidgets(MethodContext _context)
                               throws java.lang.Exception
从接口 IWidgetServiceProvider 复制的描述
导出资源

指定者：
接口 IWidgetServiceProvider 中的 importWidgets
返回：
抛出：
java.lang.Exception

export

public java.lang.String export(MethodContext _context)
                        throws java.lang.Exception
从接口 IWidgetServiceProvider 复制的描述
导入资源

指定者：
接口 IWidgetServiceProvider 中的 export
返回：
抛出：
java.lang.Exception

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
暂时没有用到，没有实现

指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable
另请参见：
com.trs.webframework.provider.IFindByIdServiceProvider#findById(com.trs .webframework.context.MethodContext)

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
暂时没有用到，没有实现

指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
另请参见：
com.trs.webframework.provider.IFindByIdsServiceProvider#findByIds(com .trs.webframework.context.MethodContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WidgetXmlConverter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget
类 WidgetXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.common.publish.widget.WidgetXmlConverter

public class WidgetXmlConverter
extends BaseObjToXmlConverter

作者：
wyw

构造方法摘要
WidgetXmlConverter()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WidgetXmlConverter

public WidgetXmlConverter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.widget.AdjustJsLCListenerWidget 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.AdjustJsLCListenerWidget
的使用

没有 com.trs.components.common.publish.widget.AdjustJsLCListenerWidget 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.BaseStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.BaseStyle
的使用

使用 BaseStyle 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 BaseStyle 的使用

com.trs.components.common.publish.widget 中 BaseStyle 的子类
class | ContentStyle
class | PageStyle
class | ResourceStyle

参数类型为 BaseStyle 的 com.trs.components.common.publish.widget 中的方法
void | IStyleItemMgr.delete(User loginUser, BaseStyle currBaseStyle) 删除指定风格对应的风格项（StyleItem）
void | StyleItemMgr.delete(User user, BaseStyle _baseStyle) 删除风格对应的风格项
void | IStyleItemMgr.deleteUnuseStyleItems(BaseStyle baseStyle, java.lang.String objectIds) 删除指定风格没有使用的风格项
void | StyleItemMgr.deleteUnuseStyleItems(BaseStyle baseStyle, java.lang.String _sUseingIds) 删除指定风格没有使用的风格项
java.util.HashMap | IStyleCenterMgr.findCssFlagUsedStyles(PageStyle pageStyle, BaseStyle _oCurrBaseStyle, java.lang.String cssFlag) 当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。
java.util.HashMap | StyleCenterMgr.findCssFlagUsedStyles(PageStyle _oPageStyle, BaseStyle _oCurrBaseStyle, java.lang.String _sCssFlag) 当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。
java.util.HashMap | IStyleCenterMgr.findStyleNameUsedStyles(PageStyle _oPageStyle, BaseStyle _oBaseStyle, java.lang.String _sStyleName) 当前页面风格(_oPageStyle)下,除自己以外，名称为_sStyleName的资源风格以及内容风格。
java.util.HashMap | StyleCenterMgr.findStyleNameUsedStyles(PageStyle _oPageStyle, BaseStyle _oCurrBaseStyle, java.lang.String _sStyleName) 当前页面风格(_oPageStyle)下,除自己以外，名称为_sCssFlag的资源风格以及内容风格。
java.util.HashMap | IStyleItemMgr.queryStyleItemMap(BaseStyle baseStyle, WCMFilter _filter) 获取指定风格的风格项
java.util.HashMap | StyleItemMgr.queryStyleItemMap(BaseStyle _baseStyle, WCMFilter _filter) 获取指定风格的风格项
StyleItems | IStyleItemMgr.queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter) 获取某种（页面风格，资源可用风格，内容可用风格）风格下的StyleItem集合
StyleItems | StyleItemMgr.queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter) 获取指定风格的风格项
void | IStyleCenterMgr.resetStyle(BaseStyle baseStyle) 将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置
void | StyleCenterMgr.resetStyle(BaseStyle _oCurrBaseStyle) 将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置
StyleItem | IStyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem) 保存（新增、编辑）StyleItem
StyleItem | StyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ContentStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ContentStyle
的使用

使用 ContentStyle 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ContentStyle 的使用

返回 ContentStyle 的 com.trs.components.common.publish.widget 中的方法
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle)
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports)
static ContentStyle | ContentStyle.createNewInstance() 产生当前对象[ContentStyle]的实例
static ContentStyle | ContentStyles.findByCssFlagAndPageStyle(User _currUser, java.lang.String _sCssFlag, int _nPageStyleId) 根据指定的风格标识和页面风格来获取内容风格
static ContentStyle | ContentStyle.findById(int _nId) 提取指定ID的对象
static ContentStyle | ContentStyle.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static ContentStyle | ContentStyles.findByStyleNameAndPageStyle(User _currUser, java.lang.String _sStyleName, int _nPageStyleId) 根据指定的风格名称和页面风格来获取内容风格
ContentStyle | IContentStyleMgr.save(User _currUser, ContentStyle _contentStyle) 保存（新增、编辑）ContentStyle
ContentStyle | ContentStyleMgr.save(User _currUser, ContentStyle _contentStyle)

参数类型为 ContentStyle 的 com.trs.components.common.publish.widget 中的方法
boolean | IContentStyleMgr.checkCssFlag(PageStyle pageStyle, ContentStyle contentStyle, java.lang.String cssFlag) 在指定的页面风格下校验当前内容风格的风格标识（CssFlag）是否唯一
boolean | ContentStyleMgr.checkCssFlag(PageStyle _pageStyle, ContentStyle _currContentStyle, java.lang.String _cssFlag) 在指定的系统风格下校验CssFlag是否唯一
boolean | IContentStyleMgr.checkStyleName(PageStyle pageStyle, ContentStyle contentStyle, java.lang.String styleName) 在指定的页面风格下校验当前内容风格的风格名称（CssFlag）是否唯一
boolean | ContentStyleMgr.checkStyleName(PageStyle _pageStyle, ContentStyle _currContentStyle, java.lang.String _styleName) 在指定的系统风格下校验风格名称是否唯一
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle)
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports)
void | IStyleCenterMgr.copyToAllPageSylte(ContentStyle contentStyle) 给所有的风格下面都要建立当前这个内容风格
void | StyleCenterMgr.copyToAllPageSylte(ContentStyle _contentStyle) 给所有的风格下面都要建立当前这个内容风格
void | IContentStyleMgr.delete(User _currUser, ContentStyle _contentStyle) 删除ContentStyle
void | ContentStyleMgr.delete(User _currUser, ContentStyle _contentStyle)
java.lang.String | IContentStyleMgr.makeCssContent(ContentStyle _contentStyle) 生成指定PageStyle下可用的内容风格css文件
java.lang.String | ContentStyleMgr.makeCssContent(ContentStyle _contentStyle)
java.lang.String | IStyleCenterMgr.makePreviewCssContent(ContentStyle contentStyle) 获取内容可用风格预览时需要的样式内容
java.lang.String | StyleCenterMgr.makePreviewCssContent(ContentStyle _contentStyle) 获取内容可用风格预览时需要的样式内容
ContentStyle | IContentStyleMgr.save(User _currUser, ContentStyle _contentStyle) 保存（新增、编辑）ContentStyle
ContentStyle | ContentStyleMgr.save(User _currUser, ContentStyle _contentStyle)
void | IStyleCenterMgr.setResoruceStylePrivate(ContentStyle contentStyle) 设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。
void | StyleCenterMgr.setResoruceStylePrivate(ContentStyle _contentStyle) 设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ContentStyleExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ContentStyleExporter
的使用

没有 com.trs.components.common.publish.widget.ContentStyleExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ContentStyleImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ContentStyleImporter
的使用

没有 com.trs.components.common.publish.widget.ContentStyleImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ContentStyleMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ContentStyleMgr
的使用

没有 com.trs.components.common.publish.widget.ContentStyleMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ContentStyles 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ContentStyles
的使用

使用 ContentStyles 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ContentStyles 的使用

返回 ContentStyles 的 com.trs.components.common.publish.widget 中的方法
static ContentStyles | ContentStyles.createNewInstance(User _currUser) 产生当前集合对象[ContentStyles]的实例
ContentStyles | ContentStyleMgr.findByCssFlagAndPageStyle(java.lang.String _sCssFlag, PageStyle _oPageStyle) 根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 内容风格集合
static ContentStyles | ContentStyles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
ContentStyles | ContentStyleMgr.findByStyleNameAndPageStyle(java.lang.String _sStyleName, PageStyle _oPageStyle) 根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 内容风格集合
static ContentStyles | ContentStyles.findSameCssFlagStyles(java.lang.String _sCssFlag) 根据指定的风格标识来获取内容风格集合
static ContentStyles | ContentStyles.findSameNameStyles(java.lang.String _sStyleName) 根据指定的风格名称来获取资源风格集合
ContentStyles | StyleAndResourceMgr.getContentStyles(Widget _resource, WCMFilter _filter)
ContentStyles | IStyleAndResourceMgr.getContentStyles(Widget _systemResource, WCMFilter _filter) 获取资源对应的内容可用风格
ContentStyles | SystemContentStyleMgr.getSystemContentStyles() 获取系统级资源可用风格
static ContentStyles | ContentStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentStyles]
ContentStyles | IContentStyleMgr.query(PageStyle _currPageStyle, WCMFilter _filter) 在指定PageStyle下获取ContentStyle集合
ContentStyles | ContentStyleMgr.query(PageStyle pageStyle, WCMFilter _filter)
ContentStyles | IContentStyleMgr.queryContenetStyles(PageStyle pageStyle) 获取指定系统风格下的内容可用风格集合
ContentStyles | ContentStyleMgr.queryContenetStyles(PageStyle _pageStyle) 获取指定系统风格下的内容可用风格集合
ContentStyles | ContentStyleServiceProvider.queryContentStyles(MethodContext context) 获取指定系统风格下的内容可用风格集合

参数类型为 ContentStyles 的 com.trs.components.common.publish.widget 中的方法
 java.lang.String ContentStyleExporter.export(ContentStyles _currContentStyles, boolean _bReturnXMLContent)
导出一个内容风格到xml文件中。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ContentStyleServiceProvider
的使用

没有 com.trs.components.common.publish.widget.ContentStyleServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ContentStyleXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ContentStyleXmlConverter
的使用

没有 com.trs.components.common.publish.widget.ContentStyleXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IContentStyleMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IContentStyleMgr
的使用

使用 IContentStyleMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IContentStyleMgr 的使用

实现 IContentStyleMgr 的 com.trs.components.common.publish.widget 中的类
 class ContentStyleMgr
内容可用风格业务逻辑实现类

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IContentStyleServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IContentStyleServiceProvider
的使用

使用 IContentStyleServiceProvider 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IContentStyleServiceProvider 的使用

实现 IContentStyleServiceProvider 的 com.trs.components.common.publish.widget 中的类
 class ContentStyleServiceProvider
内容可用风格服务层

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.ILayoutGenerator 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.ILayoutGenerator
的使用

使用 ILayoutGenerator 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ILayoutGenerator 的使用

实现 ILayoutGenerator 的 com.trs.components.common.publish.widget 中的类
 class LayoutGenerator
布局相关HTML代码和CSS样式生成类 实现接口：ILayoutGenerator

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.ILayoutMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.ILayoutMgr
的使用

使用 ILayoutMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ILayoutMgr 的使用

实现 ILayoutMgr 的 com.trs.components.common.publish.widget 中的类
 class LayoutMgr
专题布局业务层，处理布局保存，删除，查询等逻辑

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.ILayoutServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.ILayoutServiceProvider
的使用

使用 ILayoutServiceProvider 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ILayoutServiceProvider 的使用

实现 ILayoutServiceProvider 的 com.trs.components.common.publish.widget 中的类
 class LayoutServiceProvider

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IMasterMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IMasterMgr
的使用

使用 IMasterMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IMasterMgr 的使用

实现 IMasterMgr 的 com.trs.components.common.publish.widget 中的类
 class MasterMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IMasterServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IMasterServiceProvider
的使用

使用 IMasterServiceProvider 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IMasterServiceProvider 的使用

实现 IMasterServiceProvider 的 com.trs.components.common.publish.widget 中的类
 class MasterServiceProvider

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IPageStyleMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IPageStyleMgr
的使用

使用 IPageStyleMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IPageStyleMgr 的使用

实现 IPageStyleMgr 的 com.trs.components.common.publish.widget 中的类
 class PageStyleMgr
系统风格业务逻辑类

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IPageStyleServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IPageStyleServiceProvider
的使用

使用 IPageStyleServiceProvider 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IPageStyleServiceProvider 的使用

实现 IPageStyleServiceProvider 的 com.trs.components.common.publish.widget 中的类
 class PageStyleServiceProvider
页面风格服务层

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IResourceStyleMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IResourceStyleMgr
的使用

使用 IResourceStyleMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IResourceStyleMgr 的使用

实现 IResourceStyleMgr 的 com.trs.components.common.publish.widget 中的类
 class ResourceStyleMgr
资源可用风格业务逻辑实现类

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IResourceStyleServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IResourceStyleServiceProvider
的使用

没有 com.trs.components.common.publish.widget.IResourceStyleServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IStyleAndResourceMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IStyleAndResourceMgr
的使用

使用 IStyleAndResourceMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IStyleAndResourceMgr 的使用

实现 IStyleAndResourceMgr 的 com.trs.components.common.publish.widget 中的类
 class StyleAndResourceMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IStyleCenterMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IStyleCenterMgr
的使用

使用 IStyleCenterMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IStyleCenterMgr 的使用

实现 IStyleCenterMgr 的 com.trs.components.common.publish.widget 中的类
 class StyleCenterMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IStyleItemMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IStyleItemMgr
的使用

使用 IStyleItemMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IStyleItemMgr 的使用

实现 IStyleItemMgr 的 com.trs.components.common.publish.widget 中的类
 class StyleItemMgr
风格项业务逻辑类

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.ISystemContentStyleMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.ISystemContentStyleMgr
的使用

使用 ISystemContentStyleMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ISystemContentStyleMgr 的使用

实现 ISystemContentStyleMgr 的 com.trs.components.common.publish.widget 中的类
 class SystemContentStyleMgr
系统级别资源可用风格

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.ISystemResourceStyleMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.ISystemResourceStyleMgr
的使用

使用 ISystemResourceStyleMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ISystemResourceStyleMgr 的使用

实现 ISystemResourceStyleMgr 的 com.trs.components.common.publish.widget 中的类
 class SystemResourceStyleMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider
的使用

使用 IVisualTemplateServiceProvider 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IVisualTemplateServiceProvider 的使用

实现 IVisualTemplateServiceProvider 的 com.trs.components.common.publish.widget 中的类
 class VisualTemplateServiceProvider

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IWidgetInstanceMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IWidgetInstanceMgr
的使用

使用 IWidgetInstanceMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IWidgetInstanceMgr 的使用

实现 IWidgetInstanceMgr 的 com.trs.components.common.publish.widget 中的类
 class WidgetInstanceMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr
的使用

使用 IWidgetInstParameterMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IWidgetInstParameterMgr 的使用

实现 IWidgetInstParameterMgr 的 com.trs.components.common.publish.widget 中的类
 class WidgetInstParameterMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IWidgetMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IWidgetMgr
的使用

使用 IWidgetMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IWidgetMgr 的使用

实现 IWidgetMgr 的 com.trs.components.common.publish.widget 中的类
 class WidgetMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IWidgetParameterMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IWidgetParameterMgr
的使用

使用 IWidgetParameterMgr 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IWidgetParameterMgr 的使用

实现 IWidgetParameterMgr 的 com.trs.components.common.publish.widget 中的类
 class WidgetParameterMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IWidgetParameterServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IWidgetParameterServiceProvider
的使用

使用 IWidgetParameterServiceProvider 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IWidgetParameterServiceProvider 的使用

实现 IWidgetParameterServiceProvider 的 com.trs.components.common.publish.widget 中的类
 class WidgetParameterServiceProvider

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IWidgetServer 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IWidgetServer
的使用

使用 IWidgetServer 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IWidgetServer 的使用

实现 IWidgetServer 的 com.trs.components.common.publish.widget 中的类
 class WidgetServer

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.common.publish.widget.IWidgetServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.common.publish.widget.IWidgetServiceProvider
的使用

使用 IWidgetServiceProvider 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 IWidgetServiceProvider 的使用

实现 IWidgetServiceProvider 的 com.trs.components.common.publish.widget 中的类
 class WidgetServiceProvider

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.Layout 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.Layout
的使用

使用 Layout 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 Layout 的使用

返回 Layout 的 com.trs.components.common.publish.widget 中的方法
static Layout | Layout.createNewInstance() 产生当前对象[Layout]的实例
static Layout | Layout.findById(int _nId) 提取指定ID的对象
static Layout | Layout.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Layout | ILayoutMgr.findLayoutByName(User _currUser, java.lang.String _sLayoutName) 根据传入的布局名称，返回找到的第一个布局对象，如果没有找到合适的布局对象，则返回null。
Layout | LayoutMgr.findLayoutByName(User _currUser, java.lang.String sLayoutName)
Layout | ILayoutMgr.save(User _oCurrUser, Layout _currLayout) 新建或者保存布局
Layout | LayoutMgr.save(User _oCurrUser, Layout _currLayout) 保存当前布局，若ID为0则为创建布局,将样式文件写到文件上，不保存到HTML代码中

参数类型为 Layout 的 com.trs.components.common.publish.widget 中的方法
boolean | LayoutMgr.delete(User _oCurrUser, Layout _currLayout) 删除指定的布局
void | ILayoutGenerator.deleteCss(Layout _currLayout) 删除当前布局对应的CSS样式内容
void | LayoutGenerator.deleteCss(Layout _currLayout) 删除当前布局对应的css样式
java.lang.String | ILayoutGenerator.generateHtml(Layout _currLayout, boolean _bCssInHtml) 生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可
java.lang.String | LayoutGenerator.generateHtml(Layout _currLayout, boolean _bCssInHtml) 产生布局的相关HTML代码
java.lang.String | ILayoutGenerator.generateHtml(Layout _currLayout, boolean _bCssInHtml, boolean _bColIndexAsText) 生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可
java.lang.String | LayoutGenerator.generateHtml(Layout _currLayout, boolean _bCssInHtml, boolean _bColIndexAsText) 产生布局的HTML代码和CSS代码
Layout | ILayoutMgr.save(User _oCurrUser, Layout _currLayout) 新建或者保存布局
Layout | LayoutMgr.save(User _oCurrUser, Layout _currLayout) 保存当前布局，若ID为0则为创建布局,将样式文件写到文件上，不保存到HTML代码中
boolean | ILayoutMgr.validate(Layout _currLayout) 验证布局的各属性是否符合规范，包括布局比例值和布局的HTML代码 注：布局HTML代码的验证斩不实现，为用户提交HTML内容代码提供验证功能
boolean | LayoutMgr.validate(Layout _currLayout) 验证布局属性信息，包括比例和HTML内容
boolean | ILayoutGenerator.validateHtml(Layout _currLayout) 对用户上传的HTML代码进行验证，查看是否符合相关规范，如果不允许用户上传，可以直接返回true
boolean | LayoutGenerator.validateHtml(Layout layout) 验证布局的HTML内容是否符合规范 （扩展用，暂不实现）
boolean | LayoutMgr.validateRatio(Layout _currLayout) 验证布局比例是否符合规范(包括比例类型和比例值)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.LayoutGenerator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.LayoutGenerator
的使用

没有 com.trs.components.common.publish.widget.LayoutGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.LayoutMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.LayoutMgr
的使用

没有 com.trs.components.common.publish.widget.LayoutMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.Layouts 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.Layouts
的使用

使用 Layouts 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 Layouts 的使用

返回 Layouts 的 com.trs.components.common.publish.widget 中的方法
static Layouts | Layouts.createNewInstance(User _currUser) 产生当前集合对象[Layouts]的实例
static Layouts | Layouts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Layouts | Layouts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Layouts]
Layouts | ILayoutMgr.query(User _currUser, WCMFilter _currFilter) 查询布局
Layouts | LayoutMgr.query(User _currUser, WCMFilter _filter) 通过条件查询布局

参数类型为 Layouts 的 com.trs.components.common.publish.widget 中的方法
boolean | ILayoutMgr.delete(User _oCurrUser, Layouts _currLayouts) 删除布局
boolean | LayoutMgr.delete(User _oCurrUser, Layouts _oLayouts) 删除布局的集合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.LayoutServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.LayoutServiceProvider
的使用

没有 com.trs.components.common.publish.widget.LayoutServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.Master 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.Master
的使用

使用 Master 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 Master 的使用

返回 Master 的 com.trs.components.common.publish.widget 中的方法
static Master | Master.createNewInstance() 产生当前对象[Master]的实例
static Master | Master.findById(int _nId) 提取指定ID的对象
static Master | Master.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Master | IMasterServiceProvider.save(java.lang.String _sMasterName, java.lang.String _sFileName) 创建或者更新母板
Master | MasterServiceProvider.save(java.lang.String _sMasterName, java.lang.String _sFileName) 根据母板名称以及母板的文件名保存母板
Master | MasterMgr.save(User _oUser, Master _oMaster) 保存当前母板
Master | IMasterMgr.save(User _oCurrUser, Master _oCurrMaster)
Master | MasterMgr.save(User _oUser, java.lang.String _sMasterName, java.lang.String _sFileName) 保存当前母板
Master | IMasterMgr.save(User _oCurrUser, java.lang.String _sMasterName, java.lang.String _sFileName) 保存当前母版

参数类型为 Master 的 com.trs.components.common.publish.widget 中的方法
Template | IWidgetServer.createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType) 根据母版内容，创建新的模板
Template | WidgetServer.createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType)
java.lang.String | MasterMgr.getMasterFileContent(Master oMaster, int _nFileType) 获取指定母板中指定文件类型的文件内容
java.lang.String | IMasterMgr.getMasterFileContent(Master _oMaster, int _nFileType) 获取指定母板中指定文件类型的文件内容
Master | MasterMgr.save(User _oUser, Master _oMaster) 保存当前母板
Master | IMasterMgr.save(User _oCurrUser, Master _oCurrMaster)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.MasterMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.MasterMgr
的使用

没有 com.trs.components.common.publish.widget.MasterMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.Masters 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.Masters
的使用

使用 Masters 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 Masters 的使用

返回 Masters 的 com.trs.components.common.publish.widget 中的方法
static Masters | Masters.createNewInstance(User _currUser) 产生当前集合对象[Masters]的实例
static Masters | Masters.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Masters | Masters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Masters]
Masters | MasterMgr.query(User _oCurrUser, WCMFilter _oFilter) 查询系统指定的母板
Masters | IMasterMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询系统指定母版

参数类型为 Masters 的 com.trs.components.common.publish.widget 中的方法
boolean | MasterMgr.delete(User _oCurrUser, Masters _oMasters) 删除母板
boolean | IMasterMgr.delete(User _oCurrUser, Masters _oMasters) 删除指定的母版
java.lang.String | MasterMgr.export(Masters _oMasters) 导出母板
java.lang.String | IMasterMgr.export(Masters _oMasters) 导出指定的母版

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.MasterServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.MasterServiceProvider
的使用

没有 com.trs.components.common.publish.widget.MasterServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.PageStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.PageStyle
的使用

使用 PageStyle 的软件包
com.trs.components.common.publish.widget
com.trs.components.special

com.trs.components.common.publish.widget 中 PageStyle 的使用

返回 PageStyle 的 com.trs.components.common.publish.widget 中的方法
PageStyle | IPageStyleMgr.copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle) 仿照指定的页面风格创建一份新的风格
PageStyle | PageStyleMgr.copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle) 仿照PageStyle创建一份新的风格
static PageStyle | PageStyle.createNewInstance() 产生当前对象[PageStyle]的实例
static PageStyle | PageStyle.findById(int _nId) 提取指定ID的对象
static PageStyle | PageStyle.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static PageStyle | PageStyle.findByName(java.lang.String _sName) 获取指定名称的风格
PageStyle | IPageStyleMgr.save(User _currUser, PageStyle _pageStyle) 保存（新增、编辑）页面风格
PageStyle | PageStyleMgr.save(User user, PageStyle pageStyle) 只保存风格的基本属性，不负责保存关联对象

参数类型为 PageStyle 的 com.trs.components.common.publish.widget 中的方法
boolean | IContentStyleMgr.checkCssFlag(PageStyle pageStyle, ContentStyle contentStyle, java.lang.String cssFlag) 在指定的页面风格下校验当前内容风格的风格标识（CssFlag）是否唯一
boolean | ContentStyleMgr.checkCssFlag(PageStyle _pageStyle, ContentStyle _currContentStyle, java.lang.String _cssFlag) 在指定的系统风格下校验CssFlag是否唯一
boolean | IResourceStyleMgr.checkCssFlag(PageStyle pageStyle, ResourceStyle resourceStyle, java.lang.String cssFlag) 在指定的系统风格下校验指定资源的风格标识（CssFlag）是否唯一
boolean | ResourceStyleMgr.checkCssFlag(PageStyle _pageStyle, ResourceStyle _currResourceStyle, java.lang.String _cssFlag) 在指定的系统风格下校验CssFlag是否唯一
boolean | PageStyleMgr.checkStyleDesc(PageStyle _oCurrPageStyle) 判断是否已经存在同名的风格
boolean | PageStyleMgr.checkStyleName(PageStyle _oCurrPageStyle) 判断是否已经存在同名的风格
boolean | IContentStyleMgr.checkStyleName(PageStyle pageStyle, ContentStyle contentStyle, java.lang.String styleName) 在指定的页面风格下校验当前内容风格的风格名称（CssFlag）是否唯一
boolean | ContentStyleMgr.checkStyleName(PageStyle _pageStyle, ContentStyle _currContentStyle, java.lang.String _styleName) 在指定的系统风格下校验风格名称是否唯一
boolean | IResourceStyleMgr.checkStyleName(PageStyle pageStyle, ResourceStyle resourceStyle, java.lang.String styleName) 在指定的系统风格下校验指定资源的风格名称（StyleName）是否唯一
boolean | ResourceStyleMgr.checkStyleName(PageStyle _pageStyle, ResourceStyle _currResourceStyle, java.lang.String _styleName) 在指定的系统风格下校验风格名称是否唯一
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle)
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports)
PageStyle | IPageStyleMgr.copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle) 仿照指定的页面风格创建一份新的风格
PageStyle | PageStyleMgr.copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle) 仿照PageStyle创建一份新的风格
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
void | ISystemResourceStyleMgr.copyFor(User user, PageStyle pageStyle) 根据系统默认的资源可用风格为指定的系统风格创建
void | ISystemContentStyleMgr.copyFor(User user, PageStyle pageStyle) 根据系统默认的内容可用风格为指定的系统风格创建
void | SystemContentStyleMgr.copyFor(User _currUser, PageStyle _targetPageStyle) 根据系统默认的内容可用风格为指定的系统风格创建
void | SystemResourceStyleMgr.copyFor(User _currUser, PageStyle _targetPageStyle) 根据系统默认的资源可用风格为指定的系统风格创建
void | IStyleCenterMgr.copySystemStyle(User loginUser, PageStyle pageStyle) 在新建页面风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格
void | StyleCenterMgr.copySystemStyle(User _currUser, PageStyle _targetPageStyle) 在新建风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格
void | IStyleCenterMgr.createImgesDir(PageStyle pageStyle) 创建页面风格图片的存放目录
void | StyleCenterMgr.createImgesDir(PageStyle _pageStyle) 创建资源风格图片的存放目录
java.lang.String | IStyleCenterMgr.createStyleFile(User _currUser, PageStyle _currPageStyle) 生成风格文件
java.lang.String | StyleCenterMgr.createStyleFile(User _currUser, PageStyle _pageStyle)
void | IPageStyleMgr.delete(User _currUser, PageStyle _pageStyle) 删除指定的页面风格
void | PageStyleMgr.delete(User _currUser, PageStyle pageStyle) 删除PageStyle
void | IPageStyleMgr.deletePageStyleInfos(User user, PageStyle pageStyle) 删除指定的页面风格的关联信息
void | PageStyleMgr.deletePageStyleInfos(User _currUser, PageStyle pageStyle) 删除页面风格的关联信息
void | IStyleItemMgr.deleteUnusePageOtherStyleItems(PageStyle pageStyle, java.lang.String objectIds) 删除页面style对应的没有使用的其他风格项
void | StyleItemMgr.deleteUnusePageOtherStyleItems(PageStyle _pageStyle, java.lang.String _sUseingIds) 删除页面style对应的没有使用的其他风格项
java.lang.String | IStyleCenterMgr.export(PageStyle pageStyle) 导出指定页面风格的样式文件
java.lang.String | StyleCenterMgr.export(PageStyle _pageStyle) 导出系统样式文件
ContentStyles | ContentStyleMgr.findByCssFlagAndPageStyle(java.lang.String _sCssFlag, PageStyle _oPageStyle) 根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 内容风格集合
ResourceStyles | ResourceStyleMgr.findByCssFlagAndPageStyle(java.lang.String _sCssFlag, PageStyle _oPageStyle) 根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 资源风格集合
ContentStyles | ContentStyleMgr.findByStyleNameAndPageStyle(java.lang.String _sStyleName, PageStyle _oPageStyle) 根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 内容风格集合
ResourceStyles | ResourceStyleMgr.findByStyleNameAndPageStyle(java.lang.String _sStyleName, PageStyle _oPageStyle) 根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 资源风格集合
java.util.HashMap | IStyleCenterMgr.findCssFlagUsedStyles(PageStyle pageStyle, BaseStyle _oCurrBaseStyle, java.lang.String cssFlag) 当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。
java.util.HashMap | StyleCenterMgr.findCssFlagUsedStyles(PageStyle _oPageStyle, BaseStyle _oCurrBaseStyle, java.lang.String _sCssFlag) 当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。
java.lang.String | IStyleCenterMgr.findStyleImageDir(PageStyle pageStyle) 获取指定页面风格的图片所在目录
java.lang.String | StyleCenterMgr.findStyleImageDir(PageStyle _pageStyle)
java.util.HashMap | IStyleCenterMgr.findStyleNameUsedStyles(PageStyle _oPageStyle, BaseStyle _oBaseStyle, java.lang.String _sStyleName) 当前页面风格(_oPageStyle)下,除自己以外，名称为_sStyleName的资源风格以及内容风格。
java.util.HashMap | StyleCenterMgr.findStyleNameUsedStyles(PageStyle _oPageStyle, BaseStyle _oCurrBaseStyle, java.lang.String _sStyleName) 当前页面风格(_oPageStyle)下,除自己以外，名称为_sCssFlag的资源风格以及内容风格。
ResourceStyles | IResourceStyleMgr.getResourceStyles(PageStyle pageStyle) 获取指定页面风格下的资源可用风格集合
ResourceStyles | ResourceStyleMgr.getResourceStyles(PageStyle _pageStyle) 获取指定系统风格下的资源可用风格集合
java.io.File | IStyleCenterMgr.getStyleFile(PageStyle _currPageStyle) 获取风格对应的样式文件
java.io.File | StyleCenterMgr.getStyleFile(PageStyle pageStyle)
void | IStyleCenterMgr.importCssFile(PageStyle pageStyle, java.lang.String uploadCssFile) 导入风格文件
void | StyleCenterMgr.importCssFile(PageStyle _pageStyle, java.lang.String _sUploadCssFile) 导入风格文件
java.lang.String | IPageStyleMgr.makeBaseStyleContent(PageStyle pageStyle) 生成页面风格基本特性样式
java.lang.String | PageStyleMgr.makeBaseStyleContent(PageStyle _pageStyle) 生成页面基本特性样式
java.lang.String | IPageStyleMgr.makePageOtherStyleContent(PageStyle style) 生成页面其他样式
java.lang.String | PageStyleMgr.makePageOtherStyleContent(PageStyle _pageStyle) 生成页面其他样式
java.lang.String | IStyleCenterMgr.previewStyle(PageStyle pageStyle, java.lang.String cssFlag, java.lang.String templateName, StyleItems styleItems, java.lang.String customStyle) 预览时，获取风格的内容
java.lang.String | StyleCenterMgr.previewStyle(PageStyle _pageStyle, java.lang.String sCssFlag, java.lang.String sTemplateName, StyleItems _styleItems, java.lang.String _customStyle) 预览时，获取风格的内容
java.lang.String | IPageStyleMgr.previewStyle(PageStyle pageStyle, StyleItems styleItems) 获取预览时需要的样式内容
java.lang.String | PageStyleMgr.previewStyle(PageStyle _pageStyle, StyleItems _styleItems) 获取预览时需要的样式内容
ContentStyles | IContentStyleMgr.query(PageStyle _currPageStyle, WCMFilter _filter) 在指定PageStyle下获取ContentStyle集合
ContentStyles | ContentStyleMgr.query(PageStyle pageStyle, WCMFilter _filter)
ResourceStyles | IResourceStyleMgr.query(PageStyle _currPageStyle, WCMFilter _filter) 获取指定页面风格下的ResourceStyle集合
ResourceStyles | ResourceStyleMgr.query(PageStyle pageStyle, WCMFilter _filter)
ContentStyles | IContentStyleMgr.queryContenetStyles(PageStyle pageStyle) 获取指定系统风格下的内容可用风格集合
ContentStyles | ContentStyleMgr.queryContenetStyles(PageStyle _pageStyle) 获取指定系统风格下的内容可用风格集合
java.util.HashMap | IStyleItemMgr.queryPageOtherStyleItemMap(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
java.util.HashMap | StyleItemMgr.queryPageOtherStyleItemMap(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
StyleItems | IStyleItemMgr.queryPageOtherStyleItems(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
StyleItems | StyleItemMgr.queryPageOtherStyleItems(PageStyle _pageStyle, WCMFilter _filter) 获取页面其他风格样式项
PageStyle | IPageStyleMgr.save(User _currUser, PageStyle _pageStyle) 保存（新增、编辑）页面风格
PageStyle | PageStyleMgr.save(User user, PageStyle pageStyle) 只保存风格的基本属性，不负责保存关联对象
StyleItem | IStyleItemMgr.savePageOtherStyleItem(User loginUser, PageStyle pageStyle, StyleItem styleItem) 保存页面风格对应的其他风格属性
StyleItem | StyleItemMgr.savePageOtherStyleItem(User _currUser, PageStyle pageStyle, StyleItem _styleItem) 保存页面风格对应的其他风格属性

com.trs.components.special 中 PageStyle 的使用

返回 PageStyle 的 com.trs.components.special 中的方法
PageStyle | SpecialServiceProvider.getStyle(MethodContext _context)
PageStyle | ISpecialServiceProvider.getStyle(MethodContext _methodContext) 获取专题页面风格
PageStyle | SpecialMgr.getStyle(Special special)
PageStyle | ISpecialMgr.getStyle(Special _oSpecial) 获取专题风格

参数类型为 PageStyle 的 com.trs.components.special 中的方法
boolean | SpecialMgr.setStyle(Special special, PageStyle pageStyle)
boolean | ISpecialMgr.setStyle(Special _oSpecial, PageStyle _oPageStyle) 设置专题风格

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.PageStyleExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.PageStyleExporter
的使用

没有 com.trs.components.common.publish.widget.PageStyleExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.PageStyleImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.PageStyleImporter
的使用

没有 com.trs.components.common.publish.widget.PageStyleImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.PageStyleMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.PageStyleMgr
的使用

没有 com.trs.components.common.publish.widget.PageStyleMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.PageStyles 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.PageStyles
的使用

使用 PageStyles 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 PageStyles 的使用

返回 PageStyles 的 com.trs.components.common.publish.widget 中的方法
static PageStyles | PageStyles.createNewInstance(User _currUser) 产生当前集合对象[PageStyles]的实例
static PageStyles | PageStyles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static PageStyles | PageStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PageStyles]
PageStyles | IPageStyleMgr.query(WCMFilter _filter) 获取页面风格集合
PageStyles | PageStyleMgr.query(WCMFilter _filter) 获取PageStyle集合
PageStyles | PageStyleServiceProvider.queryPageStyles(MethodContext _context) 获取系统所有可供选择的系统风格

参数类型为 PageStyles 的 com.trs.components.common.publish.widget 中的方法
 java.lang.String PageStyleExporter.export(PageStyles _currPageStyles, boolean _bReturnXMLContent)
导出一个页面风格到xml文件中。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.PageStyleServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.PageStyleServiceProvider
的使用

没有 com.trs.components.common.publish.widget.PageStyleServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.PageStyleXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.PageStyleXmlConverter
的使用

没有 com.trs.components.common.publish.widget.PageStyleXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ResourceStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ResourceStyle
的使用

使用 ResourceStyle 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ResourceStyle 的使用

返回 ResourceStyle 的 com.trs.components.common.publish.widget 中的方法
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
static ResourceStyle | ResourceStyle.createNewInstance() 产生当前对象[ResourceStyle]的实例
static ResourceStyle | ResourceStyles.findByCssFlagAndPageStyle(User _currUser, java.lang.String _sCssFlag, int _nPageStyleId) 根据指定的风格标识和页面风格来获取资源风格
static ResourceStyle | ResourceStyle.findById(int _nId) 提取指定ID的对象
static ResourceStyle | ResourceStyle.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
ResourceStyle | IResourceStyleMgr.save(User _currUser, ResourceStyle _resourceStyle) 保存（新增、编辑）资源风格
ResourceStyle | ResourceStyleMgr.save(User _currUser, ResourceStyle _resourceStyle) 保存（新增、编辑）ResourceStyle

参数类型为 ResourceStyle 的 com.trs.components.common.publish.widget 中的方法
boolean | IResourceStyleMgr.checkCssFlag(PageStyle pageStyle, ResourceStyle resourceStyle, java.lang.String cssFlag) 在指定的系统风格下校验指定资源的风格标识（CssFlag）是否唯一
boolean | ResourceStyleMgr.checkCssFlag(PageStyle _pageStyle, ResourceStyle _currResourceStyle, java.lang.String _cssFlag) 在指定的系统风格下校验CssFlag是否唯一
boolean | IResourceStyleMgr.checkStyleName(PageStyle pageStyle, ResourceStyle resourceStyle, java.lang.String styleName) 在指定的系统风格下校验指定资源的风格名称（StyleName）是否唯一
boolean | ResourceStyleMgr.checkStyleName(PageStyle _pageStyle, ResourceStyle _currResourceStyle, java.lang.String _styleName) 在指定的系统风格下校验风格名称是否唯一
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
void | IStyleCenterMgr.copyToAllPageSylte(ResourceStyle resourceStyle) 给所有的页面风格下面都要建立当前这个资源风格
void | StyleCenterMgr.copyToAllPageSylte(ResourceStyle _resourceStyle) 给所有的风格下面都要建立当前这个资源风格
void | IResourceStyleMgr.delete(User _currUser, ResourceStyle _resourceStyle) 删除ResourceStyle
void | ResourceStyleMgr.delete(User _currUser, ResourceStyle _resourceStyle)
java.lang.String | IResourceStyleMgr.makeCssContent(ResourceStyle _currResourceStyle) 生成资源的可用风格内容
java.lang.String | ResourceStyleMgr.makeCssContent(ResourceStyle _resourceStyle)
java.lang.String | IStyleCenterMgr.makePreviewCssContent(ResourceStyle resourceStyle) 获取资源可用风格预览时需要的样式内容
java.lang.String | StyleCenterMgr.makePreviewCssContent(ResourceStyle _resourceStyle) 获取资源可用风格预览时需要的样式内容
ResourceStyle | IResourceStyleMgr.save(User _currUser, ResourceStyle _resourceStyle) 保存（新增、编辑）资源风格
ResourceStyle | ResourceStyleMgr.save(User _currUser, ResourceStyle _resourceStyle) 保存（新增、编辑）ResourceStyle
void | IStyleCenterMgr.setResourceStylePrivate(ResourceStyle resourceStyle) 设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。
void | StyleCenterMgr.setResourceStylePrivate(ResourceStyle _resourceStyle) 设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ResourceStyleExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ResourceStyleExporter
的使用

没有 com.trs.components.common.publish.widget.ResourceStyleExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ResourceStyleImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ResourceStyleImporter
的使用

没有 com.trs.components.common.publish.widget.ResourceStyleImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ResourceStyleMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ResourceStyleMgr
的使用

没有 com.trs.components.common.publish.widget.ResourceStyleMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ResourceStyles 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ResourceStyles
的使用

使用 ResourceStyles 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 ResourceStyles 的使用

返回 ResourceStyles 的 com.trs.components.common.publish.widget 中的方法
static ResourceStyles | ResourceStyles.createNewInstance(User _currUser) 产生当前集合对象[ResourceStyles]的实例
ResourceStyles | ResourceStyleMgr.findByCssFlagAndPageStyle(java.lang.String _sCssFlag, PageStyle _oPageStyle) 根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 资源风格集合
static ResourceStyles | ResourceStyles.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
ResourceStyles | ResourceStyleMgr.findByStyleNameAndPageStyle(java.lang.String _sStyleName, PageStyle _oPageStyle) 根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 资源风格集合
static ResourceStyles | ResourceStyles.findSameCssFlagStyles(java.lang.String _sCssFlag) 根据指定的风格标识来获取资源风格集合
static ResourceStyles | ResourceStyles.findSameNameStyles(java.lang.String _sStyleName) 根据指定的风格名称来获取资源风格集合
ResourceStyles | IResourceStyleMgr.getResourceStyles(PageStyle pageStyle) 获取指定页面风格下的资源可用风格集合
ResourceStyles | ResourceStyleMgr.getResourceStyles(PageStyle _pageStyle) 获取指定系统风格下的资源可用风格集合
ResourceStyles | SystemResourceStyleMgr.getSystemResourceStyles() 获取系统级资源可用风格
static ResourceStyles | ResourceStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ResourceStyles]
ResourceStyles | IResourceStyleMgr.query(PageStyle _currPageStyle, WCMFilter _filter) 获取指定页面风格下的ResourceStyle集合
ResourceStyles | ResourceStyleMgr.query(PageStyle pageStyle, WCMFilter _filter)
ResourceStyles | ResourceStyleServiceProvider.queryResourceStyles(MethodContext context) 获取指定页面风格下的资源可用风格集合

参数类型为 ResourceStyles 的 com.trs.components.common.publish.widget 中的方法
 java.lang.String ResourceStyleExporter.export(ResourceStyles _currResourceStyles, boolean _bReturnXMLContent)
导出一个页面风格到xml文件中。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider
的使用

没有 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.ResourceStyleXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.ResourceStyleXmlConverter
的使用

没有 com.trs.components.common.publish.widget.ResourceStyleXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.SpecialAuthServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.SpecialAuthServer
的使用

没有 com.trs.components.common.publish.widget.SpecialAuthServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleAndResource 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleAndResource
的使用

使用 StyleAndResource 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 StyleAndResource 的使用

返回 StyleAndResource 的 com.trs.components.common.publish.widget 中的方法
static StyleAndResource | StyleAndResource.createNewInstance() 产生当前对象[StyleAndResource]的实例
static StyleAndResource | StyleAndResource.findById(int _nId) 提取指定ID的对象
static StyleAndResource | StyleAndResource.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
StyleAndResource | StyleAndResourceMgr.save(User user, StyleAndResource _styleAndResource)
StyleAndResource | IStyleAndResourceMgr.save(User _currUser, StyleAndResource _styleAndResource) 保存修改StyleAndResource

参数类型为 StyleAndResource 的 com.trs.components.common.publish.widget 中的方法
void | StyleAndResourceMgr.delete(User user, StyleAndResource _styleAndResource)
void | IStyleAndResourceMgr.delete(User _currUser, StyleAndResource _styleAndResource) 删除风格与资源的关联关系
StyleAndResource | StyleAndResourceMgr.save(User user, StyleAndResource _styleAndResource)
StyleAndResource | IStyleAndResourceMgr.save(User _currUser, StyleAndResource _styleAndResource) 保存修改StyleAndResource

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleAndResourceMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleAndResourceMgr
的使用

没有 com.trs.components.common.publish.widget.StyleAndResourceMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleAndResources 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleAndResources
的使用

使用 StyleAndResources 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 StyleAndResources 的使用

返回 StyleAndResources 的 com.trs.components.common.publish.widget 中的方法
static StyleAndResources | StyleAndResources.createNewInstance(User _currUser) 产生当前集合对象[StyleAndResources]的实例
static StyleAndResources | StyleAndResources.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
StyleAndResources | StyleAndResourceMgr.getContentStyleAndResource(Widget _systemResource, WCMFilter _filter) 获取内容风格和资源的关系
static StyleAndResources | StyleAndResources.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StyleAndResources]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleCenterMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleCenterMgr
的使用

没有 com.trs.components.common.publish.widget.StyleCenterMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleConstants
的使用

没有 com.trs.components.common.publish.widget.StyleConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleHelper
的使用

没有 com.trs.components.common.publish.widget.StyleHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleItem 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleItem
的使用

使用 StyleItem 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 StyleItem 的使用

返回 StyleItem 的 com.trs.components.common.publish.widget 中的方法
static StyleItem | StyleItem.createNewInstance() 产生当前对象[StyleItem]的实例
static StyleItem | StyleItem.findById(int _nId) 提取指定ID的对象
static StyleItem | StyleItem.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
StyleItem | IStyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem) 保存（新增、编辑）StyleItem
StyleItem | StyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem)
StyleItem | IStyleItemMgr.savePageOtherStyleItem(User loginUser, PageStyle pageStyle, StyleItem styleItem) 保存页面风格对应的其他风格属性
StyleItem | StyleItemMgr.savePageOtherStyleItem(User _currUser, PageStyle pageStyle, StyleItem _styleItem) 保存页面风格对应的其他风格属性

参数类型为 StyleItem 的 com.trs.components.common.publish.widget 中的方法
void | IStyleItemMgr.delete(User _currUser, StyleItem _styleItem) 删除StyleItem
void | StyleItemMgr.delete(User _currUser, StyleItem styleItem)
StyleItem | IStyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem) 保存（新增、编辑）StyleItem
StyleItem | StyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem)
StyleItem | IStyleItemMgr.savePageOtherStyleItem(User loginUser, PageStyle pageStyle, StyleItem styleItem) 保存页面风格对应的其他风格属性
StyleItem | StyleItemMgr.savePageOtherStyleItem(User _currUser, PageStyle pageStyle, StyleItem _styleItem) 保存页面风格对应的其他风格属性

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleItemMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleItemMgr
的使用

没有 com.trs.components.common.publish.widget.StyleItemMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleItems 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleItems
的使用

使用 StyleItems 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 StyleItems 的使用

返回 StyleItems 的 com.trs.components.common.publish.widget 中的方法
static StyleItems | StyleItems.createNewInstance(User _currUser) 产生当前集合对象[StyleItems]的实例
static StyleItems | StyleItems.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static StyleItems | StyleItems.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StyleItems]
StyleItems | StyleItemMgr.query(WCMFilter _filter) 获取风格元素集合
StyleItems | IStyleItemMgr.queryPageOtherStyleItems(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
StyleItems | StyleItemMgr.queryPageOtherStyleItems(PageStyle _pageStyle, WCMFilter _filter) 获取页面其他风格样式项
StyleItems | IStyleItemMgr.queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter) 获取某种（页面风格，资源可用风格，内容可用风格）风格下的StyleItem集合
StyleItems | StyleItemMgr.queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter) 获取指定风格的风格项

参数类型为 StyleItems 的 com.trs.components.common.publish.widget 中的方法
static java.lang.String | StyleHelper.makeCSSContent(java.lang.String _sCssFlag, java.lang.String _sCSSTemplateContent, StyleItems _items) 根据风格模板替换其中的标记生成可以使用的风格内容
java.lang.String | IStyleCenterMgr.previewStyle(PageStyle pageStyle, java.lang.String cssFlag, java.lang.String templateName, StyleItems styleItems, java.lang.String customStyle) 预览时，获取风格的内容
java.lang.String | StyleCenterMgr.previewStyle(PageStyle _pageStyle, java.lang.String sCssFlag, java.lang.String sTemplateName, StyleItems _styleItems, java.lang.String _customStyle) 预览时，获取风格的内容
java.lang.String | IPageStyleMgr.previewStyle(PageStyle pageStyle, StyleItems styleItems) 获取预览时需要的样式内容
java.lang.String | PageStyleMgr.previewStyle(PageStyle _pageStyle, StyleItems _styleItems) 获取预览时需要的样式内容

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleItemServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleItemServiceProvider
的使用

没有 com.trs.components.common.publish.widget.StyleItemServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StylePathHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StylePathHelper
的使用

没有 com.trs.components.common.publish.widget.StylePathHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.StyleRepeatNameHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.StyleRepeatNameHelper
的使用

没有 com.trs.components.common.publish.widget.StyleRepeatNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.SubjectDataInitHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.SubjectDataInitHelper
的使用

没有 com.trs.components.common.publish.widget.SubjectDataInitHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.SystemContentStyleMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.SystemContentStyleMgr
的使用

没有 com.trs.components.common.publish.widget.SystemContentStyleMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.SystemResourceStyleMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.SystemResourceStyleMgr
的使用

没有 com.trs.components.common.publish.widget.SystemResourceStyleMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate
的使用

没有 com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider
的使用

没有 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.Widget 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.Widget
的使用

使用 Widget 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 Widget 的使用

返回 Widget 的 com.trs.components.common.publish.widget 中的方法
static Widget | Widget.createNewInstance() 产生当前对象[Widget]的实例
static Widget | Widget.findById(int _nId) 提取指定ID的对象
static Widget | Widget.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Widget | IWidgetMgr.findWidgetByName(User _oCurrUser, java.lang.String _sWidgetName) 根据传入的资源块名称，返回找到的第一个资源块对象，如果没有找到合适的资源块对象，则返回null。
Widget | WidgetMgr.findWidgetByName(User _oCurrUser, java.lang.String sWidgetName)
Widget | WidgetInstance.getWidget()
Widget | IWidgetMgr.saveWidget(User _oCurrUser, Widget _oCurrWidget) 保存资源
Widget | WidgetMgr.saveWidget(User _oCurrUser, Widget _oCurrWidget)

参数类型为 Widget 的 com.trs.components.common.publish.widget 中的方法
boolean | IWidgetMgr.delete(User _oCurrUser, Widget _oCurrWidget) 删除资源
boolean | WidgetMgr.delete(User _oCurrUser, Widget _oCurrWidget)
void | StyleAndResourceMgr.deleteUnuseCSRItems(Widget systemResource, java.lang.String _sUseingIds) 删除资源与内容风格关联中没有使用的对象
void | IStyleAndResourceMgr.deleteUnuseCSRItems(Widget widget, java.lang.String objectIds) 删除资源与内容风格关联中没有使用的对象
boolean | WidgetMgr.existSimilarWidget(Widget _oCurrWidget) 判断是否已经存在同名的资源
boolean | IWidgetParameterMgr.existWidgetParameter(Widget _oCurrWidget, WidgetParameter _oCurrWidgetParameter) 判断是否已经存在同名资源变量
boolean | WidgetParameterMgr.existWidgetParameter(Widget _oCurrWidget, WidgetParameter _oCurrWidgetParameter)
WidgetParameter | IWidgetParameterMgr.findParameterByName(Widget _oCurrWidget, java.lang.String sParameterName) 获取指定资源下，指定名称的资源变量
WidgetParameter | WidgetParameterMgr.findParameterByName(Widget _oCurrWidget, java.lang.String sParameterName)
StyleAndResources | StyleAndResourceMgr.getContentStyleAndResource(Widget _systemResource, WCMFilter _filter) 获取内容风格和资源的关系
java.util.HashMap | StyleAndResourceMgr.getContentStyleAndResourceMap(Widget _systemResource, WCMFilter _filter) 获取内容风格和资源的关系
java.util.HashMap | IStyleAndResourceMgr.getContentStyleAndResourceMap(Widget systemResource, WCMFilter _filter)
ContentStyles | StyleAndResourceMgr.getContentStyles(Widget _resource, WCMFilter _filter)
ContentStyles | IStyleAndResourceMgr.getContentStyles(Widget _systemResource, WCMFilter _filter) 获取资源对应的内容可用风格
WidgetParameters | IWidgetParameterMgr.query(Widget _oCurrWidget) 获取资源的所有资源变量
WidgetParameters | WidgetParameterMgr.query(Widget _oCurrWidget)
Widget | IWidgetMgr.saveWidget(User _oCurrUser, Widget _oCurrWidget) 保存资源
Widget | WidgetMgr.saveWidget(User _oCurrUser, Widget _oCurrWidget)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetConstants
的使用

没有 com.trs.components.common.publish.widget.WidgetConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetInstance 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetInstance
的使用

使用 WidgetInstance 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 WidgetInstance 的使用

返回 WidgetInstance 的 com.trs.components.common.publish.widget 中的方法
static WidgetInstance | WidgetInstance.createNewInstance() 产生当前对象[WidgetInstance]的实例
static WidgetInstance | WidgetInstance.findById(int _nId) 提取指定ID的对象
static WidgetInstance | WidgetInstance.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
WidgetInstance | WidgetInstanceMgr.save(User _loginUser, WidgetInstance _WidgetInstance)
WidgetInstance | IWidgetInstanceMgr.save(User loginUser, WidgetInstance oWidgetInstance) 对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象
WidgetInstance | WidgetInstanceMgr.save(WidgetInstance widgetInstance, java.util.Map parameters)
WidgetInstance | IWidgetInstanceMgr.save(WidgetInstance oWidgetInstance, java.util.Map parameters) 修改指定的资源块实例的变量信息

参数类型为 WidgetInstance 的 com.trs.components.common.publish.widget 中的方法
WidgetInstParameters | IWidgetInstParameterMgr.addParameters(WidgetInstance oWidgetInstance, java.util.Map parameters) 给资源块实例对象设置相应的资源库实例变量,设置这些变量值之前，将清除该实例之前的所有变量
WidgetInstParameters | WidgetInstParameterMgr.addParameters(WidgetInstance oWidgetInstance, java.util.Map parameters)
void | IWidgetInstParameterMgr.delete(WidgetInstance oWidgetInstance) 清除某个资源实例下的所有资源实例的变量信息
void | WidgetInstanceMgr.delete(WidgetInstance widgetInstance)
void | IWidgetInstanceMgr.delete(WidgetInstance widgetInstance) 删除资源块实例和其下的所有变量
void | WidgetInstParameterMgr.delete(WidgetInstance oWidgetInstance)
java.util.Map | IWidgetInstParameterMgr.getParameters(WidgetInstance oWidgetInstance) 根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写 修改说明：先取资源默认的资源变量值，再用资源变量实例值覆盖，防止添加资源变量后 在解析资源代码时有些变量不能替换的问题
java.util.Map | WidgetInstParameterMgr.getParameters(WidgetInstance widgetInstance)
java.util.Map | IWidgetInstParameterMgr.getParameters(WidgetInstance oWidgetInstance, java.lang.String sSelectFields) 根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写
java.util.Map | WidgetInstParameterMgr.getParameters(WidgetInstance widgetInstance, java.lang.String selectFields)
WidgetInstParameter | IWidgetInstParameterMgr.getWidgetInstParameter(WidgetInstance widgetInstance, java.lang.String sParaName) 获取指定资源块实例下的资源块实例变量
WidgetInstParameter | WidgetInstParameterMgr.getWidgetInstParameter(WidgetInstance widgetInstance, java.lang.String paraName)
WidgetInstParameters | IWidgetInstParameterMgr.getWidgetInstParameters(WidgetInstance oWidgetInstance, WCMFilter oFilter) 获取资源块实例关联的资源块实例变量对象集合
WidgetInstParameters | WidgetInstParameterMgr.getWidgetInstParameters(WidgetInstance widgetInstance, WCMFilter filter)
java.lang.String | IWidgetServer.parseToEditContent(IPublishElement _oPageElement, WidgetInstance _oWidgetInstance) 解析某一个资源块实例对象成可编辑的状态
java.lang.String | WidgetServer.parseToEditContent(IPublishElement pageElement, WidgetInstance widgetInstance)
java.lang.String | IWidgetServer.replaceWidgetInstParameters(WidgetInstance widgetInstance) 通过资源实例，获取资源实例的内容，并替换其中的资源实例变量
java.lang.String | WidgetServer.replaceWidgetInstParameters(WidgetInstance widgetInstance)
WidgetInstance | WidgetInstanceMgr.save(User _loginUser, WidgetInstance _WidgetInstance)
WidgetInstance | IWidgetInstanceMgr.save(User loginUser, WidgetInstance oWidgetInstance) 对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象
WidgetInstance | WidgetInstanceMgr.save(WidgetInstance widgetInstance, java.util.Map parameters)
WidgetInstance | IWidgetInstanceMgr.save(WidgetInstance oWidgetInstance, java.util.Map parameters) 修改指定的资源块实例的变量信息
WidgetInstParameters | IWidgetInstParameterMgr.saveParameters(WidgetInstance oWidgetInstance, java.util.Map parameters) 给资源块实例对象设置相应的资源库实例变量，仅仅只是设置这些传入了的变量的值
WidgetInstParameters | WidgetInstParameterMgr.saveParameters(WidgetInstance oWidgetInstance, java.util.Map parameters)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetInstanceMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetInstanceMgr
的使用

没有 com.trs.components.common.publish.widget.WidgetInstanceMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetInstances 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetInstances
的使用

使用 WidgetInstances 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 WidgetInstances 的使用

返回 WidgetInstances 的 com.trs.components.common.publish.widget 中的方法
static WidgetInstances | WidgetInstances.createNewInstance(User _currUser) 产生当前集合对象[WidgetInstances]的实例
static WidgetInstances | WidgetInstances.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WidgetInstances | WidgetInstances.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetInstances]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetInstParameter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetInstParameter
的使用

使用 WidgetInstParameter 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 WidgetInstParameter 的使用

返回 WidgetInstParameter 的 com.trs.components.common.publish.widget 中的方法
static WidgetInstParameter | WidgetInstParameter.createNewInstance() 产生当前对象[WidgetInstParameter]的实例
static WidgetInstParameter | WidgetInstParameter.findById(int _nId) 提取指定ID的对象
static WidgetInstParameter | WidgetInstParameter.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
WidgetInstParameter | IWidgetInstParameterMgr.getWidgetInstParameter(WidgetInstance widgetInstance, java.lang.String sParaName) 获取指定资源块实例下的资源块实例变量
WidgetInstParameter | WidgetInstParameterMgr.getWidgetInstParameter(WidgetInstance widgetInstance, java.lang.String paraName)

参数类型为 WidgetInstParameter 的 com.trs.components.common.publish.widget 中的方法
WidgetParameter | IWidgetParameterMgr.findParameter(WidgetInstParameter _oWidgetInstParameter) 根据资源变量实例获取到资源变量
WidgetParameter | WidgetParameterMgr.findParameter(WidgetInstParameter widgetInstParameter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetInstParameterMgr
的使用

没有 com.trs.components.common.publish.widget.WidgetInstParameterMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetInstParameters 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetInstParameters
的使用

使用 WidgetInstParameters 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 WidgetInstParameters 的使用

返回 WidgetInstParameters 的 com.trs.components.common.publish.widget 中的方法
WidgetInstParameters | IWidgetInstParameterMgr.addParameters(WidgetInstance oWidgetInstance, java.util.Map parameters) 给资源块实例对象设置相应的资源库实例变量,设置这些变量值之前，将清除该实例之前的所有变量
WidgetInstParameters | WidgetInstParameterMgr.addParameters(WidgetInstance oWidgetInstance, java.util.Map parameters)
static WidgetInstParameters | WidgetInstParameters.createNewInstance(User _currUser) 产生当前集合对象[WidgetInstParameters]的实例
static WidgetInstParameters | WidgetInstParameters.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
WidgetInstParameters | IWidgetInstParameterMgr.getWidgetInstParameters(WidgetInstance oWidgetInstance, WCMFilter oFilter) 获取资源块实例关联的资源块实例变量对象集合
WidgetInstParameters | WidgetInstParameterMgr.getWidgetInstParameters(WidgetInstance widgetInstance, WCMFilter filter)
static WidgetInstParameters | WidgetInstParameters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetInstParameters]
WidgetInstParameters | IWidgetInstParameterMgr.saveParameters(WidgetInstance oWidgetInstance, java.util.Map parameters) 给资源块实例对象设置相应的资源库实例变量，仅仅只是设置这些传入了的变量的值
WidgetInstParameters | WidgetInstParameterMgr.saveParameters(WidgetInstance oWidgetInstance, java.util.Map parameters)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetMgr
的使用

没有 com.trs.components.common.publish.widget.WidgetMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetParameter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetParameter
的使用

使用 WidgetParameter 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 WidgetParameter 的使用

返回 WidgetParameter 的 com.trs.components.common.publish.widget 中的方法
static WidgetParameter | WidgetParameter.createNewInstance() 产生当前对象[WidgetParameter]的实例
static WidgetParameter | WidgetParameter.findById(int _nId) 提取指定ID的对象
static WidgetParameter | WidgetParameter.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
WidgetParameter | IWidgetParameterMgr.findParameter(WidgetInstParameter _oWidgetInstParameter) 根据资源变量实例获取到资源变量
WidgetParameter | WidgetParameterMgr.findParameter(WidgetInstParameter widgetInstParameter)
WidgetParameter | IWidgetParameterMgr.findParameterByName(Widget _oCurrWidget, java.lang.String sParameterName) 获取指定资源下，指定名称的资源变量
WidgetParameter | WidgetParameterMgr.findParameterByName(Widget _oCurrWidget, java.lang.String sParameterName)
WidgetParameter | IWidgetParameterMgr.saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 保存资源变量
WidgetParameter | WidgetParameterMgr.saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)

参数类型为 WidgetParameter 的 com.trs.components.common.publish.widget 中的方法
boolean | IWidgetParameterMgr.delete(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 删除资源变量
boolean | WidgetParameterMgr.delete(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)
boolean | IWidgetParameterMgr.existWidgetParameter(Widget _oCurrWidget, WidgetParameter _oCurrWidgetParameter) 判断是否已经存在同名资源变量
boolean | WidgetParameterMgr.existWidgetParameter(Widget _oCurrWidget, WidgetParameter _oCurrWidgetParameter)
WidgetParameter | IWidgetParameterMgr.saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter) 保存资源变量
WidgetParameter | WidgetParameterMgr.saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetParameterMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetParameterMgr
的使用

没有 com.trs.components.common.publish.widget.WidgetParameterMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetParameters 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetParameters
的使用

使用 WidgetParameters 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 WidgetParameters 的使用

返回 WidgetParameters 的 com.trs.components.common.publish.widget 中的方法
static WidgetParameters | WidgetParameters.createNewInstance(User _currUser) 产生当前集合对象[WidgetParameters]的实例
static WidgetParameters | WidgetParameters.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WidgetParameters | WidgetParameters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetParameters]
WidgetParameters | IWidgetParameterMgr.query(User _oCurrUser, WCMFilter _oFilter) 获取某资源所具有的资源变量
WidgetParameters | WidgetParameterMgr.query(User _oCurrUser, WCMFilter _oFilter)
WidgetParameters | IWidgetParameterMgr.query(Widget _oCurrWidget) 获取资源的所有资源变量
WidgetParameters | WidgetParameterMgr.query(Widget _oCurrWidget)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider
的使用

没有 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetParameterType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetParameterType
的使用

使用 WidgetParameterType 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 WidgetParameterType 的使用

返回 WidgetParameterType 的 com.trs.components.common.publish.widget 中的方法
WidgetParameterType | WidgetParameterTypes.getWidgetParameterTypeAt(int _nIndex) 根据索引获取变量类型对象
WidgetParameterType | WidgetParameterTypes.getWidgetParameterTypeById(int _nTypeId) 根据变量类型的TypeId，获取变量类型对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetParameterTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetParameterTypes
的使用

使用 WidgetParameterTypes 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 WidgetParameterTypes 的使用

声明为 WidgetParameterTypes 的 com.trs.components.common.publish.widget 中的字段
static WidgetParameterTypes WidgetConstants.WidgetParameter_TYPES

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetPathHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetPathHelper
的使用

没有 com.trs.components.common.publish.widget.WidgetPathHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.Widgets 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.Widgets
的使用

使用 Widgets 的软件包
com.trs.components.common.publish.widget

com.trs.components.common.publish.widget 中 Widgets 的使用

返回 Widgets 的 com.trs.components.common.publish.widget 中的方法
static Widgets | Widgets.createNewInstance(User _currUser) 产生当前集合对象[Widgets]的实例
static Widgets | Widgets.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Widgets | Widgets.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Widgets]
Widgets | IWidgetMgr.query(User _oCurrUser, WCMFilter _oFilter) 获取资源
Widgets | WidgetMgr.query(User _oCurrUser, WCMFilter _oFilter)

参数类型为 Widgets 的 com.trs.components.common.publish.widget 中的方法
java.lang.String | IWidgetMgr.export(Widgets _oWidgets) 导出资源
java.lang.String | WidgetMgr.export(Widgets _oWidgets)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetServer
的使用

没有 com.trs.components.common.publish.widget.WidgetServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetServiceProvider
的使用

没有 com.trs.components.common.publish.widget.WidgetServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.WidgetXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.WidgetXmlConverter
的使用

没有 com.trs.components.common.publish.widget.WidgetXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.publish.widget.tagparser
类
WCMTagParserBaseOperation
WCMTagParserChnlInChnlOperation
WCMTagParserChnlOperation
WCMTagParserDocInChnlOperation
WCMTagParserDocOperation
WCMTagParserLayout
WCMTagParserLayoutCell
WCMTagParserPageStyle
WCMTagParserPreWidget
WCMTagParserResources
WCMTagParserSpecialAppendix
WCMTagParserSpecialLogo
WCMTagParserTagCreator
WCMTagParserWidget


com.trs.components.common.publish.widget.tagparser

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.publish.widget.tagparser

类摘要
WCMTagParserBaseOperation |
WCMTagParserChnlInChnlOperation |
WCMTagParserChnlOperation |
WCMTagParserDocInChnlOperation |
WCMTagParserDocOperation |
WCMTagParserLayout | 用于TRS_Layout置标生成HTML代码，一般用在母板中
WCMTagParserLayoutCell | TRS_LayoutCell用于TRS_Layout置标内部，其发布产生的html代码，将作为布局列的内容，填充到布局对应的列中，一般用在母板中
WCMTagParserPageStyle | 页面风格的置标解析 该置标是用于分发风格的样式文件以及图片文件
WCMTagParserPreWidget |
WCMTagParserResources | 用于在设计页面及发布页面引入相应的资源文件（包括js及css），如：设计页面引入的layout.js,widget.js等关于布局和资源块操作的js。
WCMTagParserSpecialAppendix | 用于处理专题中的附件发布
WCMTagParserSpecialLogo | 专题LOGO置标解析
WCMTagParserTagCreator |
WCMTagParserWidget |


com.trs.components.common.publish.widget.tagparser 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.widget.tagparser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.tagparser.BaseTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation
        • com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlInChnlOperation
        • com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlOperation
        • com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation
        • com.trs.components.common.publish.widget.tagparser.WCMTagParserDocOperation
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserLayoutCell
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserResources
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserWidget
    • com.trs.components.common.publish.domain.tagparser.TagBeanInfo
      • com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation.TBI


软件包 com.trs.components.common.publish.widget.tagparser 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.publish.widget.tagparser
的使用

使用 com.trs.components.common.publish.widget.tagparser 的软件包
com.trs.components.common.publish.widget.tagparser

com.trs.components.common.publish.widget.tagparser 使用的 com.trs.components.common.publish.widget.tagparser 中的类
WCMTagParserBaseOperation

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMTagParserBaseOperation

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserBaseOperation

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation
所有已实现的接口：
ITagParser, org.aton.container.IClearable
直接已知子类：
WCMTagParserChnlInChnlOperation, WCMTagParserChnlOperation, WCMTagParserDocInChnlOperation, WCMTagParserDocOperation
public abstract class WCMTagParserBaseOperation
extends BaseTagParser

嵌套类摘要
 class WCMTagParserBaseOperation.TBI
构造方法摘要
WCMTagParserBaseOperation()
方法摘要
RightValue | getChannelRightValue(User _currUser, BaseChannel _oBaseChannel) 获取栏目的权限
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserBaseOperation

public WCMTagParserBaseOperation()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.parse(PublishTagContext)

getChannelRightValue

public RightValue getChannelRightValue(User _currUser,
                                       BaseChannel _oBaseChannel)
                                throws WCMException
获取栏目的权限

参数：
_currUser -
_oChannel -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


WCMTagParserBaseOperation.TBI

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserBaseOperation.TBI

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagBeanInfo
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation.TBI
包容类：
WCMTagParserBaseOperation
public class WCMTagParserBaseOperation.TBI
extends TagBeanInfo

嵌套类摘要
从类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 继承的嵌套类/接口
TagBeanInfo.BodyType
构造方法摘要
WCMTagParserBaseOperation.TBI()
方法摘要
 void checkSemantic(IPublishFolder _folder, TagItem _tagItem, java.lang.StringBuffer _sbResult)
检查指定的置标实例的静态语义，如果有静态语义错误，则通过传入的StringBuffer对象返回错误信息。
从类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 继承的方法
addAttrInfo, getAttrInfo, getAttrInfoCount, getAttrInfos, getDesc, getName, getRequiredAttr, getThreadSafe, getType, setDesc, setName, setThreadSafe, setType
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserBaseOperation.TBI

public WCMTagParserBaseOperation.TBI()
方法详细信息

checkSemantic

public void checkSemantic(IPublishFolder _folder,
                          TagItem _tagItem,
                          java.lang.StringBuffer _sbResult)
从类 TagBeanInfo 复制的描述
检查指定的置标实例的静态语义，如果有静态语义错误，则通过传入的StringBuffer对象返回错误信息。

覆盖：
类 TagBeanInfo 中的 checkSemantic
参数：
_folder - 模板所属的目录，目前只可能是是站点
_tagItem - 指定的置标实例
_sbResult - [in/out]参数，如果有错，用于返回错误信息。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserChnlInChnlOperation

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserChnlInChnlOperation

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation
            继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlInChnlOperation
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserChnlInChnlOperation
extends WCMTagParserBaseOperation

嵌套类摘要
从类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 继承的嵌套类/接口
WCMTagParserBaseOperation.TBI
构造方法摘要
WCMTagParserChnlInChnlOperation()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 继承的方法
getChannelRightValue, parse
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserChnlInChnlOperation

public WCMTagParserChnlInChnlOperation()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserChnlOperation

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserChnlOperation

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation
            继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlOperation
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserChnlOperation
extends WCMTagParserBaseOperation

嵌套类摘要
从类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 继承的嵌套类/接口
WCMTagParserBaseOperation.TBI
构造方法摘要
WCMTagParserChnlOperation()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 继承的方法
getChannelRightValue, parse
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserChnlOperation

public WCMTagParserChnlOperation()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDocInChnlOperation

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserDocInChnlOperation

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation
            继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserDocInChnlOperation
extends WCMTagParserBaseOperation

嵌套类摘要
从类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 继承的嵌套类/接口
WCMTagParserBaseOperation.TBI
构造方法摘要
WCMTagParserDocInChnlOperation()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
boolean | hasSuperRight(BaseChannel host, CMSObj _aUser) 判断当前Operator对于指定结点是否有Super权限
从类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 继承的方法
getChannelRightValue, parse
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDocInChnlOperation

public WCMTagParserDocInChnlOperation()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

hasSuperRight

public boolean hasSuperRight(BaseChannel host,
                             CMSObj _aUser)
                      throws WCMException
判断当前Operator对于指定结点是否有Super权限

参数：
host -
_aUser -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDocOperation

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserDocOperation

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation
            继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserDocOperation
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserDocOperation
extends WCMTagParserBaseOperation

嵌套类摘要
从类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 继承的嵌套类/接口
WCMTagParserBaseOperation.TBI
构造方法摘要
WCMTagParserDocOperation()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 继承的方法
getChannelRightValue, parse
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDocOperation

public WCMTagParserDocOperation()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserLayout

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserLayout

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserLayout
extends BaseTagParser

用于TRS_Layout置标生成HTML代码，一般用在母板中

作者：
huxiejin

构造方法摘要
WCMTagParserLayout()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext context) Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserLayout

public WCMTagParserLayout()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserLayoutCell

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserLayoutCell

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserLayoutCell
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserLayoutCell
extends BaseTagParser

TRS_LayoutCell用于TRS_Layout置标内部，其发布产生的html代码，将作为布局列的内容，填充到布局对应的列中，一般用在母板中

作者：
huxiejin

构造方法摘要
WCMTagParserLayoutCell()
方法摘要
 java.lang.String[] parse(PublishTagContext context)
Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserLayoutCell

public WCMTagParserLayoutCell()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserPageStyle

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserPageStyle

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserPageStyle
extends BaseTagParser

页面风格的置标解析 该置标是用于分发风格的样式文件以及图片文件

构造方法摘要
WCMTagParserPageStyle()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserPageStyle

public WCMTagParserPageStyle()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserPreWidget

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserPreWidget

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserPreWidget
extends BaseTagParser

作者：
Administrator

构造方法摘要
WCMTagParserPreWidget()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserPreWidget

public WCMTagParserPreWidget()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserResources

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserResources

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserResources
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserResources
extends BaseTagParser

用于在设计页面及发布页面引入相应的资源文件（包括js及css），如：设计页面引入的layout.js,widget.js等关于布局和资源块操作的js。 根据是设计页面还是发布页面，将引入不同的资源。 根据发布类型的不同，确认是引入设计页面的资源还是发布页面的资源，设计页面直接引入special下的相关资源，发布页面需要拷贝到发布目录，再引入该资源；
支持加载指定目录下的所有资源，以便于后期在需要时扩展新的资源；
设计页面和发布页面需要引入共同的资源，为了避免多份，尝试放在一个公共目录common下；
设计页面自身引入的资源放在design目录下，发布页面自身引入的资源放在publish目录下；

作者：
hudao

构造方法摘要
WCMTagParserResources()
方法摘要
TagBeanInfo | getBeanInfo() 置标属性定义
java.lang.String[] | parse(PublishTagContext _context) 发布产生指定的资源
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserResources

public WCMTagParserResources()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
发布产生指定的资源

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
置标属性定义

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserSpecialAppendix

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserSpecialAppendix

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserSpecialAppendix
extends BaseTagParser

用于处理专题中的附件发布

作者：
huxiejin

构造方法摘要
WCMTagParserSpecialAppendix()
方法摘要
TagBeanInfo | getBeanInfo() 置标属性定义
java.lang.String[] | parse(PublishTagContext _context) 解析
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserSpecialAppendix

public WCMTagParserSpecialAppendix()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
置标属性定义

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
解析

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserSpecialLogo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserSpecialLogo

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserSpecialLogo
extends BaseTagParser

专题LOGO置标解析

构造方法摘要
WCMTagParserSpecialLogo()
方法摘要
TagBeanInfo | getBeanInfo() 置标属性定义
java.lang.String[] | parse(PublishTagContext _context) 解析
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserSpecialLogo

public WCMTagParserSpecialLogo()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
置标属性定义

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
解析

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserTagCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserTagCreator

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserTagCreator
extends BaseTagParser

构造方法摘要
WCMTagParserTagCreator()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserTagCreator

public WCMTagParserTagCreator()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserWidget

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.publish.widget.tagparser
类 WCMTagParserWidget

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.widget.tagparser.WCMTagParserWidget
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserWidget
extends BaseTagParser

构造方法摘要
WCMTagParserWidget()
方法摘要
 java.lang.String[] parse(PublishTagContext _context)
Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserWidget

public WCMTagParserWidget()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation
的使用

使用 WCMTagParserBaseOperation 的软件包
com.trs.components.common.publish.widget.tagparser

com.trs.components.common.publish.widget.tagparser 中 WCMTagParserBaseOperation 的使用

com.trs.components.common.publish.widget.tagparser 中 WCMTagParserBaseOperation 的子类
class | WCMTagParserChnlInChnlOperation
class | WCMTagParserChnlOperation
class | WCMTagParserDocInChnlOperation
class | WCMTagParserDocOperation

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation.TBI 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation.TBI
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation.TBI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlInChnlOperation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlInChnlOperation
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlInChnlOperation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlOperation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlOperation
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlOperation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocOperation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocOperation
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocOperation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayoutCell 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayoutCell
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayoutCell 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserResources 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserResources
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserResources 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.publish.widget.tagparser.WCMTagParserWidget 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.publish.widget.tagparser.WCMTagParserWidget
的使用

没有 com.trs.components.common.publish.widget.tagparser.WCMTagParserWidget 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.common.reminder
类
Reminder


com.trs.components.common.reminder

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.reminder

类摘要
Reminder


com.trs.components.common.reminder 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.reminder 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.components.common.job.BaseScheduleWorker
        • com.trs.components.common.reminder.Reminder


软件包 com.trs.components.common.reminder 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.reminder
的使用

没有 com.trs.components.common.reminder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Reminder

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.reminder
类 Reminder

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.common.reminder.Reminder
所有已实现的接口：
org.quartz.Job
public class Reminder
extends BaseScheduleWorker

构造方法摘要
Reminder()
保留默认构造函数
方法摘要
static void | createSchedule(Message _newMessage, CMyDateTime _dtRemind) 创建一个消息提醒
static void | main(java.lang.String[] args)
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Reminder

public Reminder()
保留默认构造函数

方法详细信息

createSchedule

public static void createSchedule(Message _newMessage,
                                  CMyDateTime _dtRemind)
                           throws WCMException
创建一个消息提醒

参数：
_newMessage - 消息对象
_dtRemind - 提醒的时间
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.reminder.Reminder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.reminder.Reminder
的使用

没有 com.trs.components.common.reminder.Reminder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ADCom

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADCom

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsad.ADCom
所有已实现的接口：
java.lang.Cloneable
public class ADCom
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ADCom()
构造函数：保留默认接口
方法摘要
int | delete(User _currUser) 删除公司同时删除该公司的所有广告
ADFiles | getADFiles() 得到ADFiles集合对象
java.lang.String | getComAddress() 提取属性：ComAddress公司联系地址
java.lang.String | getComContact() 提取属性：ComContact联系人
java.lang.String | getComConTit() 提取属性：ComConTit
CMyDateTime | getComCrtime() 提取属性：ComCrtime记录创建时间
java.lang.String | getComCruser() 提取属性：ComCruser记录创建人
java.lang.String | getComDesc() 提取属性：ComDesc公司介绍信息
java.lang.String | getComEmail() 提取属性：ComEmail公司Email
java.lang.String | getComMobile() 提取属性：ComMobile 公司联系人移动电话
java.lang.String | getComName() 提取属性：ComName公司名称
int | getComPeople() 提取属性：ComPeople
int | getComPubN() 提取属性：ComPubN
java.lang.String | getComTel() 提取属性：ComTel公司联系电话
java.lang.String | getComUrl() 提取属性：ComUrl公司网址
java.lang.String | getComZipcode() 提取属性：ComZipcode公司邮编
java.lang.String | getComZo() 提取属性：ComZo
java.lang.String | getComZone() 提取属性：ComZone公司区域
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setComAddress(java.lang.String _sComAddress) 设置属性：ComAddress公司联系地址
boolean | setComContact(java.lang.String _sComContact) 设置属性：ComContact联系人
boolean | setComConTit(java.lang.String _sComConTit) 设置属性：ComConTit
boolean | setComCrtime(CMyDateTime _dtComCrtime) 设置属性：ComCrtime记录创建时间
boolean | setComCruser(java.lang.String _sComCruser) 设置属性：ComCruser记录创建人
boolean | setComDesc(java.lang.String _sComDesc) 设置属性：ComDesc公司介绍信息
boolean | setComEmail(java.lang.String _sComEmail) 设置属性：ComEmail公司Email
boolean | setComMobile(java.lang.String _sComMobile) 设置属性：ComMobile 公司联系人移动电话
boolean | setComName(java.lang.String _sComName) 设置属性：ComName公司名称
boolean | setComPeople(int _nComPeople) 设置属性：ComPeople
boolean | setComPubN(int _sComPubN) 设置属性：ComPubN 该公司发布广告的数量
boolean | setComTel(java.lang.String _sComTel) 设置属性：ComTel公司联系电话
boolean | setComUrl(java.lang.String _sComUrl) 设置属性：ComUrl公司网址
boolean | setComZipcode(java.lang.String _sComZipcode) 设置属性：ComZipcode公司邮编
boolean | setComZo(java.lang.String _sComZo) 设置属性：ComZo
boolean | setComZone(java.lang.String _sComZone) 设置属性：ComZone公司区域
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ADCom

public ADCom()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getComName

public java.lang.String getComName()
提取属性：ComName公司名称

返回：
ComName

setComName

public boolean setComName(java.lang.String _sComName)
                   throws WCMException
设置属性：ComName公司名称

参数：
ComName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComUrl

public java.lang.String getComUrl()
提取属性：ComUrl公司网址

返回：
ComUrl

setComUrl

public boolean setComUrl(java.lang.String _sComUrl)
                  throws WCMException
设置属性：ComUrl公司网址

参数：
ComUrl - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComContact

public java.lang.String getComContact()
提取属性：ComContact联系人

返回：
ComContact

setComContact

public boolean setComContact(java.lang.String _sComContact)
                      throws WCMException
设置属性：ComContact联系人

参数：
ComContact - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComTel

public java.lang.String getComTel()
提取属性：ComTel公司联系电话

返回：
ComTel

setComTel

public boolean setComTel(java.lang.String _sComTel)
                  throws WCMException
设置属性：ComTel公司联系电话

参数：
ComTel - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComAddress

public java.lang.String getComAddress()
提取属性：ComAddress公司联系地址

返回：
ComAddress

setComAddress

public boolean setComAddress(java.lang.String _sComAddress)
                      throws WCMException
设置属性：ComAddress公司联系地址

参数：
ComAddress - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComDesc

public java.lang.String getComDesc()
提取属性：ComDesc公司介绍信息

返回：
ComDesc

setComDesc

public boolean setComDesc(java.lang.String _sComDesc)
                   throws WCMException
设置属性：ComDesc公司介绍信息

参数：
ComDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComCruser

public java.lang.String getComCruser()
提取属性：ComCruser记录创建人

返回：
ComCruser

setComCruser

public boolean setComCruser(java.lang.String _sComCruser)
                     throws WCMException
设置属性：ComCruser记录创建人

参数：
ComCruser - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComCrtime

public CMyDateTime getComCrtime()
提取属性：ComCrtime记录创建时间

返回：
ComCrtime

setComCrtime

public boolean setComCrtime(CMyDateTime _dtComCrtime)
                     throws WCMException
设置属性：ComCrtime记录创建时间

参数：
ComCrtime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComEmail

public java.lang.String getComEmail()
提取属性：ComEmail公司Email

返回：
ComEmail

setComEmail

public boolean setComEmail(java.lang.String _sComEmail)
                    throws WCMException
设置属性：ComEmail公司Email

参数：
ComEmail - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComPeople

public int getComPeople()
提取属性：ComPeople

返回：
ComPeople

setComPeople

public boolean setComPeople(int _nComPeople)
                     throws WCMException
设置属性：ComPeople

参数：
ComPeople - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComZipcode

public java.lang.String getComZipcode()
提取属性：ComZipcode公司邮编

返回：
ComZipcode

setComZipcode

public boolean setComZipcode(java.lang.String _sComZipcode)
                      throws WCMException
设置属性：ComZipcode公司邮编

参数：
ComZipcode - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComZone

public java.lang.String getComZone()
提取属性：ComZone公司区域

返回：
ComZone

setComZone

public boolean setComZone(java.lang.String _sComZone)
                   throws WCMException
设置属性：ComZone公司区域

参数：
ComZone - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComZo

public java.lang.String getComZo()
提取属性：ComZo

返回：
ComZo

setComZo

public boolean setComZo(java.lang.String _sComZo)
                 throws WCMException
设置属性：ComZo

参数：
ComZo - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComMobile

public java.lang.String getComMobile()
提取属性：ComMobile 公司联系人移动电话

返回：
ComMobile

setComMobile

public boolean setComMobile(java.lang.String _sComMobile)
                     throws WCMException
设置属性：ComMobile 公司联系人移动电话

参数：
ComMobile - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComPubN

public int getComPubN()
提取属性：ComPubN

返回：
ComPubN

setComPubN

public boolean setComPubN(int _sComPubN)
                   throws WCMException
设置属性：ComPubN 该公司发布广告的数量

参数：
ComPubN - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getComConTit

public java.lang.String getComConTit()
提取属性：ComConTit

返回：
ComConTit

setComConTit

public boolean setComConTit(java.lang.String _sComConTit)
                     throws WCMException
设置属性：ComConTit

参数：
ComConTit - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getADFiles

public ADFiles getADFiles()
                   throws WCMException
得到ADFiles集合对象

返回：
抛出：
WCMException

delete

public int delete(User _currUser)
           throws WCMException
删除公司同时删除该公司的所有广告

覆盖：
类 CMSObj 中的 delete
参数：
_currUser -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ADComs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADComs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsad.ADComs

public class ADComs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ADComs(User _currUser)
构造函数
ADComs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ADComs

public ADComs(User _currUser)
构造函数

另请参见：
ADCOMs( User _currUser, int _initCapacity, int _incCapacity );

ADComs

public ADComs(User _currUser,
              int _initCapacity,
              int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ADFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADFile

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsad.ADFile
所有已实现的接口：
java.lang.Cloneable
public class ADFile
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ADFile()
构造函数：保留默认接口
方法摘要
int | delete(User _currUser) 从数据中删除对象信息
java.lang.String | getAdAction() 提取属性：AdAction
java.lang.String | getAdAttribute() 提取属性：AdAttribute
CMyDateTime | getAdBegin() 提取属性：AdBegin
ADCom | getADCom()
int | getAdCompany() 提取属性：AdCompany
CMyDateTime | getAdCrTime() 提取属性：AdCrTime
java.lang.String | getAdCrUser() 提取属性：AdCrUser
java.lang.String | getAdDesc() 提取属性：AdDesc
CMyDateTime | getAdEnd() 提取属性：AdEnd
java.lang.String | getAdExt() 提取属性：AdExt
java.lang.String | getAdFileName() 提取属性：AdFileName广告文件名
int | getAdFlag() 提取属性：AdFlag
int | getAdHeight() 提取属性：AdHeight
int | getAdHit() 提取属性：AdHit
int | getAdIsWork() 提取属性：AdIsWork
java.lang.String | getAdName() 提取属性：AdName广告名称
int | getAdPrice() 提取属性：AdPrice
int | getAdType() 提取属性：AdType
java.lang.String | getAdUrl() 提取属性：AdUrl
int | getAdWidth() 提取属性：AdWidth
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setAdAction(java.lang.String _sAdAction) 设置属性：AdAction
boolean | setAdAttribute(java.lang.String _sAdAttribute) 设置属性：AdAttribute
boolean | setAdBegin(CMyDateTime _dtAdBegin) 设置属性：AdBegin
boolean | setAdCompany(int _nAdCompany) 设置属性：AdCompany
boolean | setAdCrTime(CMyDateTime _dtAdCrTime) 设置属性：AdCrTime
boolean | setAdCrUser(java.lang.String _sAdCrUser) 设置属性：AdCrUser
boolean | setAdDesc(java.lang.String _sAdDesc) 设置属性：AdDesc
boolean | setAdEnd(CMyDateTime _dtAdEnd) 设置属性：AdEnd
boolean | setAdExt(java.lang.String _sAdExt) 设置属性：AdExt
boolean | setAdFileName(java.lang.String _sAdName) 设置属性：AdFileName广告文件名
boolean | setAdFlag(int _nAdFlag) 设置属性：AdFlag
boolean | setAdHeight(int _nAdHeight) 设置属性：AdHeight
boolean | setAdHit(int _nAdHit) 设置属性：AdHit
boolean | setAdIsWork(int _nAdIsWork) 设置属性：AdIsWork
boolean | setAdName(java.lang.String _sAdName) 设置属性：AdName广告名称
boolean | setAdPrice(int _nAdPrice) 设置属性：AdPrice
boolean | setAdType(int _nAdType) 设置属性：AdType
boolean | setAdUrl(java.lang.String _sAdUrl) 设置属性：AdUrl
boolean | setAdWidth(int _nAdWidth) 设置属性：AdWidth
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ADFile

public ADFile()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getAdName

public java.lang.String getAdName()
提取属性：AdName广告名称

返回：
AdName

setAdName

public boolean setAdName(java.lang.String _sAdName)
                  throws WCMException
设置属性：AdName广告名称

参数：
AdName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdFileName

public java.lang.String getAdFileName()
提取属性：AdFileName广告文件名

返回：
AdFileName

setAdFileName

public boolean setAdFileName(java.lang.String _sAdName)
                      throws WCMException
设置属性：AdFileName广告文件名

参数：
AdFileName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdCompany

public int getAdCompany()
提取属性：AdCompany

返回：
AdCompany

setAdCompany

public boolean setAdCompany(int _nAdCompany)
                     throws WCMException
设置属性：AdCompany

参数：
AdCompany - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdUrl

public java.lang.String getAdUrl()
提取属性：AdUrl

返回：
AdUrl

setAdUrl

public boolean setAdUrl(java.lang.String _sAdUrl)
                 throws WCMException
设置属性：AdUrl

参数：
AdUrl - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdHit

public int getAdHit()
提取属性：AdHit

返回：
AdHit

setAdHit

public boolean setAdHit(int _nAdHit)
                 throws WCMException
设置属性：AdHit

参数：
AdHit - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdBegin

public CMyDateTime getAdBegin()
提取属性：AdBegin

返回：
AdBegin

setAdBegin

public boolean setAdBegin(CMyDateTime _dtAdBegin)
                   throws WCMException
设置属性：AdBegin

参数：
AdBegin - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdEnd

public CMyDateTime getAdEnd()
提取属性：AdEnd

返回：
AdEnd

setAdEnd

public boolean setAdEnd(CMyDateTime _dtAdEnd)
                 throws WCMException
设置属性：AdEnd

参数：
AdEnd - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdIsWork

public int getAdIsWork()
提取属性：AdIsWork

返回：
AdIsWork

setAdIsWork

public boolean setAdIsWork(int _nAdIsWork)
                    throws WCMException
设置属性：AdIsWork

参数：
AdIsWork - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdExt

public java.lang.String getAdExt()
提取属性：AdExt

返回：
AdExt

setAdExt

public boolean setAdExt(java.lang.String _sAdExt)
                 throws WCMException
设置属性：AdExt

参数：
AdExt - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdDesc

public java.lang.String getAdDesc()
提取属性：AdDesc

返回：
AdDesc

setAdDesc

public boolean setAdDesc(java.lang.String _sAdDesc)
                  throws WCMException
设置属性：AdDesc

参数：
AdDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdCrUser

public java.lang.String getAdCrUser()
提取属性：AdCrUser

返回：
AdCrUser

setAdCrUser

public boolean setAdCrUser(java.lang.String _sAdCrUser)
                    throws WCMException
设置属性：AdCrUser

参数：
AdCrUser - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdCrTime

public CMyDateTime getAdCrTime()
提取属性：AdCrTime

返回：
AdCrTime

setAdCrTime

public boolean setAdCrTime(CMyDateTime _dtAdCrTime)
                    throws WCMException
设置属性：AdCrTime

参数：
AdCrTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdWidth

public int getAdWidth()
提取属性：AdWidth

返回：
AdWidth

setAdWidth

public boolean setAdWidth(int _nAdWidth)
                   throws WCMException
设置属性：AdWidth

参数：
AdWidth - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdHeight

public int getAdHeight()
提取属性：AdHeight

返回：
AdHeight

setAdHeight

public boolean setAdHeight(int _nAdHeight)
                    throws WCMException
设置属性：AdHeight

参数：
AdHeight - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdType

public int getAdType()
提取属性：AdType

返回：
AdType

setAdType

public boolean setAdType(int _nAdType)
                  throws WCMException
设置属性：AdType

参数：
AdType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdFlag

public int getAdFlag()
提取属性：AdFlag

返回：
AdFlag

setAdFlag

public boolean setAdFlag(int _nAdFlag)
                  throws WCMException
设置属性：AdFlag

参数：
AdFlag - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdAttribute

public java.lang.String getAdAttribute()
提取属性：AdAttribute

返回：
AdAttribute

setAdAttribute

public boolean setAdAttribute(java.lang.String _sAdAttribute)
                       throws WCMException
设置属性：AdAttribute

参数：
AdAttribute - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdAction

public java.lang.String getAdAction()
提取属性：AdAction

返回：
AdAction

setAdAction

public boolean setAdAction(java.lang.String _sAdAction)
                    throws WCMException
设置属性：AdAction

参数：
AdAction - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdPrice

public int getAdPrice()
提取属性：AdPrice

返回：
AdPrice

setAdPrice

public boolean setAdPrice(int _nAdPrice)
                   throws WCMException
设置属性：AdPrice

参数：
AdPrice - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getADCom

public ADCom getADCom()
               throws WCMException
抛出：
WCMException

delete

public int delete(User _currUser)
           throws WCMException
从类 CMSObj 复制的描述
从数据中删除对象信息

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ADFilePos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADFilePos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsad.ADFilePos
所有已实现的接口：
java.lang.Cloneable
public class ADFilePos
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ADFilePos()
构造函数：保留默认接口
方法摘要
CMyDateTime | getAdBegin() 提取属性：AdBegin
CMyDateTime | getAdEnd() 提取属性：AdEnd
ADFile | getADFile()
int | getAdFileId() 提取属性：AdFileId
ADPos | getADPos()
int | getAdPosId() 提取属性：AdPosId
int | getAdTagHit() 提取属性：AdTagHit
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setAdBegin(CMyDateTime _dtAdBegin) 设置属性：AdBegin
boolean | setAdEnd(CMyDateTime _dtAdEnd) 设置属性：AdEnd
boolean | setAdFileId(int _nAdFileId) 设置属性：AdFileId
boolean | setAdPosId(int _nAdPosId) 设置属性：AdPosId
boolean | setAdTagHit(int _nAdTagHit) 设置属性：AdTagHit
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ADFilePos

public ADFilePos()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getAdFileId

public int getAdFileId()
提取属性：AdFileId

返回：
AdFileId

setAdFileId

public boolean setAdFileId(int _nAdFileId)
                    throws WCMException
设置属性：AdFileId

参数：
AdFileId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdPosId

public int getAdPosId()
提取属性：AdPosId

返回：
AdPosId

setAdPosId

public boolean setAdPosId(int _nAdPosId)
                   throws WCMException
设置属性：AdPosId

参数：
AdPosId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdBegin

public CMyDateTime getAdBegin()
提取属性：AdBegin

返回：
AdBegin

setAdBegin

public boolean setAdBegin(CMyDateTime _dtAdBegin)
                   throws WCMException
设置属性：AdBegin

参数：
AdBegin - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdEnd

public CMyDateTime getAdEnd()
提取属性：AdEnd

返回：
AdEnd

setAdEnd

public boolean setAdEnd(CMyDateTime _dtAdEnd)
                 throws WCMException
设置属性：AdEnd

参数：
AdEnd - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdTagHit

public int getAdTagHit()
提取属性：AdTagHit

返回：
AdTagHit

setAdTagHit

public boolean setAdTagHit(int _nAdTagHit)
                    throws WCMException
设置属性：AdTagHit

参数：
AdTagHit - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getADFile

public ADFile getADFile()
                 throws WCMException
抛出：
WCMException

getADPos

public ADPos getADPos()
               throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ADFilePoss

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADFilePoss

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsad.ADFilePoss

public class ADFilePoss
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ADFilePoss(User _currUser)
构造函数
ADFilePoss(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ADFilePoss

public ADFilePoss(User _currUser)
构造函数

另请参见：
ADFilePoss( User _currUser, int _initCapacity, int _incCapacity );

ADFilePoss

public ADFilePoss(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ADFiles

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADFiles

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsad.ADFiles

public class ADFiles
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ADFiles(User _currUser)
构造函数
ADFiles(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ADFiles

public ADFiles(User _currUser)
构造函数

另请参见：
ADFiles( User _currUser, int _initCapacity, int _incCapacity );

ADFiles

public ADFiles(User _currUser,
               int _initCapacity,
               int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ADPos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADPos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsad.ADPos
所有已实现的接口：
java.lang.Cloneable
public class ADPos
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | DEL_DETAIL_PCLASS
static boolean | ISSITE
static int | MAX_DETAIL_NUM
static int | MAX_OUTLINE_NUM
static int | OBJ_TYPE 对象类型编号
static int | WEB_OUTLINE_PCLASS
static int | WEN_INDEX_PCLASS
构造方法摘要
ADPos()
构造函数：保留默认接口
方法摘要
void | ChnlInit(Channel _chnl, User _user) 初始化栏目
void | ChnlInit(WebSite _website, User _user) 初始化站点
int | delete(User _currUser) 重载父类方法删除属于广告位的所有广告记录
ADFiles | getADFiles() 得到本广告位的广告的记录集
ADFiles | getCurrADFiles() 得到本广告位的当前可用广告的记录集
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getPAttribute() 提取属性：PAttribute
int | getPChnlId() 提取属性：PChnlId
java.lang.String | getPChnlName() 提取属性：PChnlName
int | getPClass() 提取属性：PClass
java.lang.String | getPDesc() 提取属性：PDesc
int | getPHeight() 提取属性：PHeight
int | getPNo() 提取属性：PNo
int | getPNum() 提取属性：PNum
int | getPPrice() 提取属性：PPrice
java.lang.String | getPStyle() 提取属性：PStyle
int | getPType() 提取属性：PType
int | getPWidth() 提取属性：PWidth
int | getWCMType() 取得该对象的类型编号
CMSObj | getWebObj() 得到站点或频道对象
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setPAttribute(java.lang.String _sPAttribute) 设置属性：PAttribute
boolean | setPChnlId(int _nPChnlId) 设置属性：PChnlId
boolean | setPChnlName(java.lang.String _sPChnlName) 设置属性：PChnlName
boolean | setPClass(int _sPClass) 设置属性：PClass
boolean | setPDesc(java.lang.String _sPDesc) 设置属性：PDesc
boolean | setPHeight(int _nPHeight) 设置属性：PHeight
boolean | setPNo(int _nPNo) 设置属性：PNo
boolean | setPNum(int _sPNum) 设置属性：PNum
boolean | setPPrice(int _iPPrice) 设置属性：PPrice
boolean | setPStyle(java.lang.String _sPStyle) 设置属性：PStyle
boolean | setPType(int _nPType) 设置属性：PType
boolean | setPWidth(int _nPWidth) 设置属性：PWidth
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

MAX_OUTLINE_NUM

public static int MAX_OUTLINE_NUM

MAX_DETAIL_NUM

public static int MAX_DETAIL_NUM

ISSITE

public static boolean ISSITE

WEN_INDEX_PCLASS

public static int WEN_INDEX_PCLASS

WEB_OUTLINE_PCLASS

public static int WEB_OUTLINE_PCLASS

DEL_DETAIL_PCLASS

public static int DEL_DETAIL_PCLASS
构造方法详细信息

ADPos

public ADPos()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getPChnlId

public int getPChnlId()
提取属性：PChnlId

返回：
PChnlId

setPChnlId

public boolean setPChnlId(int _nPChnlId)
                   throws WCMException
设置属性：PChnlId

参数：
PChnlId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPChnlName

public java.lang.String getPChnlName()
提取属性：PChnlName

返回：
PChnlName

setPChnlName

public boolean setPChnlName(java.lang.String _sPChnlName)
                     throws WCMException
设置属性：PChnlName

参数：
PChnlName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPWidth

public int getPWidth()
提取属性：PWidth

返回：
PWidth

setPWidth

public boolean setPWidth(int _nPWidth)
                  throws WCMException
设置属性：PWidth

参数：
PWidth - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPHeight

public int getPHeight()
提取属性：PHeight

返回：
PHeight

setPHeight

public boolean setPHeight(int _nPHeight)
                   throws WCMException
设置属性：PHeight

参数：
PHeight - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPType

public int getPType()
提取属性：PType

返回：
PType

setPType

public boolean setPType(int _nPType)
                 throws WCMException
设置属性：PType

参数：
PType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPStyle

public java.lang.String getPStyle()
提取属性：PStyle

返回：
PStyle

setPStyle

public boolean setPStyle(java.lang.String _sPStyle)
                  throws WCMException
设置属性：PStyle

参数：
PStyle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPAttribute

public java.lang.String getPAttribute()
提取属性：PAttribute

返回：
PAttribute

setPAttribute

public boolean setPAttribute(java.lang.String _sPAttribute)
                      throws WCMException
设置属性：PAttribute

参数：
PAttribute - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPNo

public int getPNo()
提取属性：PNo

返回：
PNo

setPNo

public boolean setPNo(int _nPNo)
               throws WCMException
设置属性：PNo

参数：
PNo - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPDesc

public java.lang.String getPDesc()
提取属性：PDesc

返回：
PDesc

setPDesc

public boolean setPDesc(java.lang.String _sPDesc)
                 throws WCMException
设置属性：PDesc

参数：
PDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPNum

public int getPNum()
提取属性：PNum

返回：
PNum

setPNum

public boolean setPNum(int _sPNum)
                throws WCMException
设置属性：PNum

参数：
PNum - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPPrice

public int getPPrice()
提取属性：PPrice

返回：
PPrice

setPPrice

public boolean setPPrice(int _iPPrice)
                  throws WCMException
设置属性：PPrice

参数：
PPrice - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPClass

public int getPClass()
提取属性：PClass

返回：
PClass

setPClass

public boolean setPClass(int _sPClass)
                  throws WCMException
设置属性：PClass

参数：
PClass - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

ChnlInit

public void ChnlInit(Channel _chnl,
                     User _user)
              throws WCMException
初始化栏目

参数：
_chnl -
_user -
_app -
抛出：
WCMException

ChnlInit

public void ChnlInit(WebSite _website,
                     User _user)
              throws WCMException
初始化站点

参数：
_website -
_user -
_app -
抛出：
WCMException

getWebObj

public CMSObj getWebObj()
                 throws WCMException
得到站点或频道对象

返回：
@throws WCMException
抛出：
WCMException

getADFiles

public ADFiles getADFiles()
                   throws WCMException
得到本广告位的广告的记录集

返回：
@throws WCMException
抛出：
WCMException

getCurrADFiles

public ADFiles getCurrADFiles()
                       throws WCMException
得到本广告位的当前可用广告的记录集

返回：
@throws WCMException
抛出：
WCMException

delete

public int delete(User _currUser)
           throws WCMException
重载父类方法删除属于广告位的所有广告记录

覆盖：
类 CMSObj 中的 delete
参数：
_currUser -
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ADPoss

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADPoss

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsad.ADPoss

public class ADPoss
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ADPoss(User _currUser)
构造函数
ADPoss(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getLeaveNos(int _currChnlId, int _pClass) getLeaveNos取得没有连续的广告位置；
int | getMaxPNo(int _pChnlId, int _pClass)
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ADPoss

public ADPoss(User _currUser)
构造函数

另请参见：
ADPoss( User _currUser, int _initCapacity, int _incCapacity );

ADPoss

public ADPoss(User _currUser,
              int _initCapacity,
              int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

getLeaveNos

public java.lang.String getLeaveNos(int _currChnlId,
                                    int _pClass)
                             throws WCMException
getLeaveNos取得没有连续的广告位置；

参数：
_currChnlId -
_pClass -
返回：
抛出：
WCMException

getMaxPNo

public int getMaxPNo(int _pChnlId,
                     int _pClass)
              throws WCMException
参数：
_pClass -
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ADType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADType

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsad.ADType
所有已实现的接口：
java.lang.Cloneable
public class ADType
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ADType()
构造函数：保留默认接口
方法摘要
int | getAdFileKind() 提取属性：AdFileKind
ADFiles | getADFiles()
java.lang.String | getAdTypeName() 提取属性：AdTypeName
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getOutString() 提取属性：OutString
CMyDateTime | getTypeCrTime() 提取属性：CrTime
java.lang.String | getTypeCrUser() 提取属性：CrUser
java.lang.String | getTypeDesc() 提取属性：TypeDesc
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setAdFileKind(int _nAdFileKind) 设置属性：AdFileKind
boolean | setAdTypeName(java.lang.String _sAdTypeName) 设置属性：AdTypeName
boolean | setOutString(java.lang.String _sOutString) 设置属性：OutString
boolean | setTypeCrTime(CMyDateTime _dtCrTime) 设置属性：CrTime
boolean | setTypeCrUser(java.lang.String _sCrUser) 设置属性：CrUser
boolean | setTypeDesc(java.lang.String _sTypeDesc) 设置属性：TypeDesc
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ADType

public ADType()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getAdTypeName

public java.lang.String getAdTypeName()
提取属性：AdTypeName

返回：
AdTypeName

setAdTypeName

public boolean setAdTypeName(java.lang.String _sAdTypeName)
                      throws WCMException
设置属性：AdTypeName

参数：
AdTypeName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAdFileKind

public int getAdFileKind()
提取属性：AdFileKind

返回：
AdFileKind

setAdFileKind

public boolean setAdFileKind(int _nAdFileKind)
                      throws WCMException
设置属性：AdFileKind

参数：
AdFileKind - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTypeCrUser

public java.lang.String getTypeCrUser()
提取属性：CrUser

返回：
CrUser

setTypeCrUser

public boolean setTypeCrUser(java.lang.String _sCrUser)
                      throws WCMException
设置属性：CrUser

参数：
CrUser - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTypeCrTime

public CMyDateTime getTypeCrTime()
提取属性：CrTime

返回：
CrTime

setTypeCrTime

public boolean setTypeCrTime(CMyDateTime _dtCrTime)
                      throws WCMException
设置属性：CrTime

参数：
CrTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOutString

public java.lang.String getOutString()
提取属性：OutString

返回：
OutString

setOutString

public boolean setOutString(java.lang.String _sOutString)
                     throws WCMException
设置属性：OutString

参数：
OutString - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTypeDesc

public java.lang.String getTypeDesc()
提取属性：TypeDesc

返回：
TypeDesc

setTypeDesc

public boolean setTypeDesc(java.lang.String _sTypeDesc)
                    throws WCMException
设置属性：TypeDesc

参数：
TypeDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getADFiles

public ADFiles getADFiles()
                   throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ADTypes

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsad
类 ADTypes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsad.ADTypes

public class ADTypes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ADTypes(User _currUser)
构造函数
ADTypes(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ADTypes

public ADTypes(User _currUser)
构造函数

另请参见：
ADTypes( User _currUser, int _initCapacity, int _incCapacity );

ADTypes

public ADTypes(User _currUser,
               int _initCapacity,
               int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.trsad
类
ADCom
ADComs
ADFile
ADFilePos
ADFilePoss
ADFiles
ADPos
ADPoss
ADType
ADTypes


com.trs.components.common.trsad

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.trsad

类摘要
ADCom
ADComs
ADFile
ADFilePos
ADFilePoss
ADFiles
ADPos
ADPoss
ADType
ADTypes


com.trs.components.common.trsad 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.trsad 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.trsad.ADCom
        • com.trs.components.common.trsad.ADFile
        • com.trs.components.common.trsad.ADFilePos
        • com.trs.components.common.trsad.ADPos
        • com.trs.components.common.trsad.ADType
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.trsad.ADComs
        • com.trs.components.common.trsad.ADFilePoss
        • com.trs.components.common.trsad.ADFiles
        • com.trs.components.common.trsad.ADPoss
        • com.trs.components.common.trsad.ADTypes


软件包 com.trs.components.common.trsad 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.trsad
的使用

使用 com.trs.components.common.trsad 的软件包
com.trs.components.common.trsad

com.trs.components.common.trsad 使用的 com.trs.components.common.trsad 中的类
ADCom
ADFile
ADFiles
ADPos

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADCom 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADCom
的使用

使用 ADCom 的软件包
com.trs.components.common.trsad

com.trs.components.common.trsad 中 ADCom 的使用

返回 ADCom 的 com.trs.components.common.trsad 中的方法
 ADCom ADFile.getADCom()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADComs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADComs
的使用

没有 com.trs.components.common.trsad.ADComs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADFile 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADFile
的使用

使用 ADFile 的软件包
com.trs.components.common.trsad

com.trs.components.common.trsad 中 ADFile 的使用

返回 ADFile 的 com.trs.components.common.trsad 中的方法
 ADFile ADFilePos.getADFile()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADFilePos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADFilePos
的使用

没有 com.trs.components.common.trsad.ADFilePos 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADFilePoss 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADFilePoss
的使用

没有 com.trs.components.common.trsad.ADFilePoss 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADFiles 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADFiles
的使用

使用 ADFiles 的软件包
com.trs.components.common.trsad

com.trs.components.common.trsad 中 ADFiles 的使用

返回 ADFiles 的 com.trs.components.common.trsad 中的方法
ADFiles | ADType.getADFiles()
ADFiles | ADPos.getADFiles() 得到本广告位的广告的记录集
ADFiles | ADCom.getADFiles() 得到ADFiles集合对象
ADFiles | ADPos.getCurrADFiles() 得到本广告位的当前可用广告的记录集

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADPos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADPos
的使用

使用 ADPos 的软件包
com.trs.components.common.trsad

com.trs.components.common.trsad 中 ADPos 的使用

返回 ADPos 的 com.trs.components.common.trsad 中的方法
 ADPos ADFilePos.getADPos()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADPoss 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADPoss
的使用

没有 com.trs.components.common.trsad.ADPoss 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADType
的使用

没有 com.trs.components.common.trsad.ADType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsad.ADTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsad.ADTypes
的使用

没有 com.trs.components.common.trsad.ADTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


JVoteConstant

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 JVoteConstant

java.lang.Object
    继承者  com.trs.components.common.trsvote.JVoteConstant

public final class JVoteConstant
extends java.lang.Object

Title: JVote网上调查系统

Description: class JVoteConstant -- 调查系统常量

Copyright: Copyright (c) 2003

Company: TRS Tech.

Website: www.trs.com.cn

Department: Guangzhou Office

版本：
1.1
作者：
林向容(lin.xiangrong@trs.com.cn)

字段摘要
static java.lang.String | DB_FIELD_ITEMID
static java.lang.String | DB_FIELD_OPTIONID
static java.lang.String | DB_FIELD_STYLE
static java.lang.String | DB_FIELD_TITLE
static java.lang.String | DB_FIELD_VOTEID
static java.lang.String | DB_PREFIX
static java.lang.String | DB_TABLE_DATA
static java.lang.String | DB_TABLE_GRPUSER
static java.lang.String | DB_TABLE_IPLOG
static java.lang.String | DB_TABLE_ITEM
static java.lang.String | DB_TABLE_OPTION
static java.lang.String | DB_TABLE_USER
static java.lang.String | DB_TABLE_VOTE
static int | OBJ_BASEVOTE
static int | OBJ_VOTE
static int | OBJ_VOTEDATA
static int | OBJ_VOTEIPLOG
static int | OBJ_VOTEITEM
static int | OBJ_VOTEOPTION
static java.lang.String | STYLE_CHECKBOX
static int | STYLE_CHECKBOX_INT
static java.lang.String | STYLE_RADIO
static int | STYLE_RADIO_INT
static java.lang.String | TYPE_ITEM
static java.lang.String | TYPE_OPTION
构造方法摘要
JVoteConstant()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DB_PREFIX

public static final java.lang.String DB_PREFIX
另请参见：
常量字段值

DB_TABLE_VOTE

public static final java.lang.String DB_TABLE_VOTE
另请参见：
常量字段值

DB_TABLE_ITEM

public static final java.lang.String DB_TABLE_ITEM

DB_TABLE_OPTION

public static final java.lang.String DB_TABLE_OPTION

DB_TABLE_DATA

public static final java.lang.String DB_TABLE_DATA

DB_TABLE_IPLOG

public static final java.lang.String DB_TABLE_IPLOG

OBJ_BASEVOTE

public static final int OBJ_BASEVOTE
另请参见：
常量字段值

OBJ_VOTE

public static final int OBJ_VOTE
另请参见：
常量字段值

OBJ_VOTEITEM

public static final int OBJ_VOTEITEM
另请参见：
常量字段值

OBJ_VOTEOPTION

public static final int OBJ_VOTEOPTION
另请参见：
常量字段值

OBJ_VOTEDATA

public static final int OBJ_VOTEDATA
另请参见：
常量字段值

OBJ_VOTEIPLOG

public static final int OBJ_VOTEIPLOG
另请参见：
常量字段值

DB_FIELD_TITLE

public static final java.lang.String DB_FIELD_TITLE
另请参见：
常量字段值

DB_FIELD_STYLE

public static final java.lang.String DB_FIELD_STYLE
另请参见：
常量字段值

DB_FIELD_VOTEID

public static final java.lang.String DB_FIELD_VOTEID
另请参见：
常量字段值

DB_FIELD_ITEMID

public static final java.lang.String DB_FIELD_ITEMID
另请参见：
常量字段值

DB_FIELD_OPTIONID

public static final java.lang.String DB_FIELD_OPTIONID
另请参见：
常量字段值

TYPE_ITEM

public static final java.lang.String TYPE_ITEM
另请参见：
常量字段值

TYPE_OPTION

public static final java.lang.String TYPE_OPTION
另请参见：
常量字段值

STYLE_RADIO_INT

public static int STYLE_RADIO_INT

STYLE_CHECKBOX_INT

public static int STYLE_CHECKBOX_INT

STYLE_RADIO

public static final java.lang.String STYLE_RADIO
另请参见：
常量字段值

STYLE_CHECKBOX

public static final java.lang.String STYLE_CHECKBOX
另请参见：
常量字段值

DB_TABLE_USER

public static final java.lang.String DB_TABLE_USER

DB_TABLE_GRPUSER

public static final java.lang.String DB_TABLE_GRPUSER
构造方法详细信息

JVoteConstant

public JVoteConstant()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.common.trsvote
类
JVoteConstant
Vote
VoteData
VoteDatas
VoteIPLog
VoteIPLogs
VoteItem
VoteItems
VoteOption
VoteOptions
Votes
VoteSoapClient
VoteSoapServer


com.trs.components.common.trsvote

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.common.trsvote

类摘要
JVoteConstant | Title: JVote网上调查系统 Description: class JVoteConstant -- 调查系统常量 Copyright: Copyright (c) 2003 Company: TRS Tech.
Vote |
VoteData |
VoteDatas |
VoteIPLog |
VoteIPLogs |
VoteItem |
VoteItems |
VoteOption |
VoteOptions |
Votes |
VoteSoapClient |
VoteSoapServer |


com.trs.components.common.trsvote 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.common.trsvote 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.common.trsvote.Vote
        • com.trs.components.common.trsvote.VoteData
        • com.trs.components.common.trsvote.VoteIPLog
        • com.trs.components.common.trsvote.VoteItem
        • com.trs.components.common.trsvote.VoteOption
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.common.trsvote.VoteDatas
        • com.trs.components.common.trsvote.VoteIPLogs
        • com.trs.components.common.trsvote.VoteItems
        • com.trs.components.common.trsvote.VoteOptions
        • com.trs.components.common.trsvote.Votes
    • com.trs.components.common.trsvote.JVoteConstant
    • com.trs.components.common.trsvote.VoteSoapClient
    • com.trs.components.common.trsvote.VoteSoapServer


软件包 com.trs.components.common.trsvote 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.common.trsvote
的使用

使用 com.trs.components.common.trsvote 的软件包
com.trs.components.common.trsvote

com.trs.components.common.trsvote 使用的 com.trs.components.common.trsvote 中的类
Vote
VoteDatas
VoteIPLogs
VoteItem
VoteItems
VoteOption
VoteOptions

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Vote

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 Vote

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsvote.Vote
所有已实现的接口：
java.lang.Cloneable
public class Vote
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Vote()
构造函数：保留默认接口
方法摘要
CMyDateTime | getCrTime() 提取属性：CrTime
int | getCrUserId() 提取属性：CrUserId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getGroupId() 提取属性：GroupId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getInnerIPBegin() 提取属性：InnerIPBegin
java.lang.String | getInnerIPEnd() 提取属性：InnerIPEnd
int | getInnerMultiCount() 提取属性：InnerMultiCount
VoteIPLogs | getIPLogs(User _currUser) 取得调查IP记录
int | getOuterMultiCount() 提取属性：OuterMultiCount
int | getSiteId() 提取属性：SITEID
CMyDateTime | getTimeBegin() 提取属性：TimeBegin
CMyDateTime | getTimeEnd() 提取属性：TimeEnd
java.lang.String | getTitle() 提取属性：Title
int | getVoteId() 提取属性：VoteId
VoteItems | getVoteItems(User _currUser) 取得调查事项
int | getWCMDocId() 提取属性：WCMDocId
int | getWCMType() 取得该对象的类型编号
boolean | isInnerMulti() 提取属性：InnerMulti
boolean | isOuterMulti() 提取属性：OuterMulti
boolean | isOuterPublic() 提取属性：OuterPublic
boolean | isStartup() 提取属性：Startup
boolean | isValid() 检验对象数据有效性
static void | main(java.lang.String[] args)
boolean | setCrTime(CMyDateTime _sCrTime) 设置属性：CrTime
boolean | setCrUserId(int _nCrUserId) 设置属性：CrUserId
boolean | setGroupId(int _nGroupId) 设置属性：GroupId
boolean | setInnerIPBegin(java.lang.String _sInnerIPBegin) 设置属性：InnerIPBegin
boolean | setInnerIPEnd(java.lang.String _sInnerIPEnd) 设置属性：InnerIPEnd
boolean | setInnerMulti(boolean _bInnerMulti) 设置属性：InnerMulti
boolean | setInnerMultiCount(int _nInnerMultiCount) 设置属性：InnerMultiCount
boolean | setOuterMulti(boolean _bOuterMulti) 设置属性：OuterMulti
boolean | setOuterMultiCount(int _nOuterMultiCount) 设置属性：OuterMultiCount
boolean | setOuterPublic(boolean _bOuterPublic) 设置属性：OuterPublic
boolean | setSiteId(int _nSiteId) 设置属性：SITEID
boolean | setStartup(boolean _bStartup) 设置属性：Startup
boolean | setTimeBegin(CMyDateTime _sTimeBegin) 设置属性：TimeBegin
boolean | setTimeEnd(CMyDateTime _sTimeEnd) 设置属性：TimeEnd
boolean | setTitle(java.lang.String _sTitle) 设置属性：Title
boolean | setWCMDocId(int _nWCMDocId) 设置属性：WCMDocId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Vote

public Vote()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getVoteId

public int getVoteId()
提取属性：VoteId

返回：
VoteId

getWCMDocId

public int getWCMDocId()
提取属性：WCMDocId

返回：
WCMDocId

setWCMDocId

public boolean setWCMDocId(int _nWCMDocId)
                    throws WCMException
设置属性：WCMDocId

参数：
WCMDocId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTitle

public java.lang.String getTitle()
提取属性：Title

返回：
Title

setTitle

public boolean setTitle(java.lang.String _sTitle)
                 throws WCMException
设置属性：Title

参数：
Title - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCrUserId

public int getCrUserId()
提取属性：CrUserId

返回：
CrUserId

setCrUserId

public boolean setCrUserId(int _nCrUserId)
                    throws WCMException
设置属性：CrUserId

参数：
CrUserId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getGroupId

public int getGroupId()
提取属性：GroupId

返回：
GroupId

setGroupId

public boolean setGroupId(int _nGroupId)
                   throws WCMException
设置属性：GroupId

参数：
GroupId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCrTime

public CMyDateTime getCrTime()
提取属性：CrTime

覆盖：
类 BaseObj 中的 getCrTime
返回：
CrTime

setCrTime

public boolean setCrTime(CMyDateTime _sCrTime)
                  throws WCMException
设置属性：CrTime

参数：
CrTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getInnerIPBegin

public java.lang.String getInnerIPBegin()
提取属性：InnerIPBegin

返回：
InnerIPBegin

setInnerIPBegin

public boolean setInnerIPBegin(java.lang.String _sInnerIPBegin)
                        throws WCMException
设置属性：InnerIPBegin

参数：
InnerIPBegin - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getInnerIPEnd

public java.lang.String getInnerIPEnd()
提取属性：InnerIPEnd

返回：
InnerIPEnd

setInnerIPEnd

public boolean setInnerIPEnd(java.lang.String _sInnerIPEnd)
                      throws WCMException
设置属性：InnerIPEnd

参数：
InnerIPEnd - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTimeBegin

public CMyDateTime getTimeBegin()
提取属性：TimeBegin

返回：
TimeBegin

setTimeBegin

public boolean setTimeBegin(CMyDateTime _sTimeBegin)
                     throws WCMException
设置属性：TimeBegin

参数：
TimeBegin - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTimeEnd

public CMyDateTime getTimeEnd()
提取属性：TimeEnd

返回：
TimeEnd

setTimeEnd

public boolean setTimeEnd(CMyDateTime _sTimeEnd)
                   throws WCMException
设置属性：TimeEnd

参数：
TimeEnd - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isInnerMulti

public boolean isInnerMulti()
提取属性：InnerMulti

返回：
InnerMulti

setInnerMulti

public boolean setInnerMulti(boolean _bInnerMulti)
                      throws WCMException
设置属性：InnerMulti

参数：
InnerMulti - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isOuterMulti

public boolean isOuterMulti()
提取属性：OuterMulti

返回：
OuterMulti

setOuterMulti

public boolean setOuterMulti(boolean _bOuterMulti)
                      throws WCMException
设置属性：OuterMulti

参数：
OuterMulti - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getInnerMultiCount

public int getInnerMultiCount()
提取属性：InnerMultiCount

返回：
InnerMultiCount

setInnerMultiCount

public boolean setInnerMultiCount(int _nInnerMultiCount)
                           throws WCMException
设置属性：InnerMultiCount

参数：
InnerMultiCount - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOuterMultiCount

public int getOuterMultiCount()
提取属性：OuterMultiCount

返回：
OuterMultiCount

setOuterMultiCount

public boolean setOuterMultiCount(int _nOuterMultiCount)
                           throws WCMException
设置属性：OuterMultiCount

参数：
OuterMultiCount - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSiteId

public int getSiteId()
提取属性：SITEID

返回：
SITEID

setSiteId

public boolean setSiteId(int _nSiteId)
                  throws WCMException
设置属性：SITEID

参数：
SITEID - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isOuterPublic

public boolean isOuterPublic()
提取属性：OuterPublic

返回：
OuterPublic

setOuterPublic

public boolean setOuterPublic(boolean _bOuterPublic)
                       throws WCMException
设置属性：OuterPublic

参数：
OuterPublic - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isStartup

public boolean isStartup()
提取属性：Startup

返回：
Startup

setStartup

public boolean setStartup(boolean _bStartup)
                   throws WCMException
设置属性：Startup

参数：
Startup - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

main

public static void main(java.lang.String[] args)

getVoteItems

public VoteItems getVoteItems(User _currUser)
                       throws WCMException
取得调查事项

返回：
返回一项调查的所有事项集合
抛出：
WCMException - 如有错误则抛出导常

getIPLogs

public VoteIPLogs getIPLogs(User _currUser)
                     throws WCMException
取得调查IP记录

返回：
返回一项调查的所有IP记录集合
抛出：
WCMException - 如有错误则抛出导常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteData

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsvote.VoteData
所有已实现的接口：
java.lang.Cloneable
public class VoteData
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
VoteData()
构造函数：保留默认接口
方法摘要
int | getDataId() 提取属性：DataId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getOptionId() 提取属性：OptionId
VoteOption | getVoteOption(User _currUser) 取得调查数据所属的调查选项
int | getWCMType() 取得该对象的类型编号
boolean | isValid() 检验对象数据有效性
boolean | setOptionId(int _nOptionId) 设置属性：OptionId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

VoteData

public VoteData()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getDataId

public int getDataId()
提取属性：DataId

返回：
DataId

getOptionId

public int getOptionId()
提取属性：OptionId

返回：
OptionId

setOptionId

public boolean setOptionId(int _nOptionId)
                    throws WCMException
设置属性：OptionId

参数：
OptionId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

getVoteOption

public VoteOption getVoteOption(User _currUser)
                         throws WCMException
取得调查数据所属的调查选项

返回：
返回一项调查数据所属的调查选项
抛出：
WCMException - 如有错误则抛出导常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteDatas

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteDatas

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsvote.VoteDatas

public class VoteDatas
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
VoteDatas(User _currUser)
构造函数
VoteDatas(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VoteDatas

public VoteDatas(User _currUser)
构造函数

另请参见：
VoteDatas( User _currUser, int _initCapacity, int _incCapacity );

VoteDatas

public VoteDatas(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteIPLog

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteIPLog

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsvote.VoteIPLog
所有已实现的接口：
java.lang.Cloneable
public class VoteIPLog
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
VoteIPLog()
构造函数：保留默认接口
方法摘要
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getIP() 提取属性：IP
int | getIPLogId() 提取属性：IPLogId
CMyDateTime | getLogTime() 提取属性：LogTime
int | getVoteId() 提取属性：VoteId
int | getWCMType() 取得该对象的类型编号
boolean | isValid() 检验对象数据有效性
boolean | setIP(java.lang.String _sIP) 设置属性：IP
boolean | setLogTime(CMyDateTime _dtLogTime) 设置属性：LogTime
boolean | setVoteId(int _nVoteId) 设置属性：VoteId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

VoteIPLog

public VoteIPLog()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getIPLogId

public int getIPLogId()
提取属性：IPLogId

返回：
IPLogId

getVoteId

public int getVoteId()
提取属性：VoteId

返回：
VoteId

setVoteId

public boolean setVoteId(int _nVoteId)
                  throws WCMException
设置属性：VoteId

参数：
VoteId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIP

public java.lang.String getIP()
提取属性：IP

返回：
IP

setIP

public boolean setIP(java.lang.String _sIP)
              throws WCMException
设置属性：IP

参数：
IP - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLogTime

public CMyDateTime getLogTime()
提取属性：LogTime

返回：
LogTime

setLogTime

public boolean setLogTime(CMyDateTime _dtLogTime)
                   throws WCMException
设置属性：LogTime

参数：
LogTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteIPLogs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteIPLogs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsvote.VoteIPLogs

public class VoteIPLogs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
VoteIPLogs(User _currUser)
构造函数
VoteIPLogs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VoteIPLogs

public VoteIPLogs(User _currUser)
构造函数

另请参见：
VoteIPLogs( User _currUser, int _initCapacity, int _incCapacity );

VoteIPLogs

public VoteIPLogs(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteItem

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteItem

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsvote.VoteItem
所有已实现的接口：
java.lang.Cloneable
public class VoteItem
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
VoteItem()
构造函数：保留默认接口
方法摘要
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getItemId() 提取属性：ItemId
int | getStyle() 提取属性：Style
java.lang.String | getTitle() 提取属性：Title
Vote | getVote(User _currUser) 取得所属调查
int | getVoteId() 提取属性：VoteId
VoteOptions | getVoteOptions(User _currUser) 取得调查选项
int | getWCMType() 取得该对象的类型编号
boolean | isValid() 检验对象数据有效性
boolean | setStyle(int _nStyle) 设置属性：Style
boolean | setTitle(java.lang.String _sTitle) 设置属性：Title
boolean | setVoteId(int _nVoteId) 设置属性：VoteId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

VoteItem

public VoteItem()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getItemId

public int getItemId()
提取属性：ItemId

返回：
ItemId

getTitle

public java.lang.String getTitle()
提取属性：Title

返回：
Title

setTitle

public boolean setTitle(java.lang.String _sTitle)
                 throws WCMException
设置属性：Title

参数：
Title - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyle

public int getStyle()
提取属性：Style

返回：
Style

setStyle

public boolean setStyle(int _nStyle)
                 throws WCMException
设置属性：Style

参数：
Style - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getVoteId

public int getVoteId()
提取属性：VoteId

返回：
VoteId

setVoteId

public boolean setVoteId(int _nVoteId)
                  throws WCMException
设置属性：VoteId

参数：
VoteId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

getVoteOptions

public VoteOptions getVoteOptions(User _currUser)
                           throws WCMException
取得调查选项

返回：
返回一项调查事项的所有选项
抛出：
WCMException - 如有错误则抛出导常

getVote

public Vote getVote(User _currUser)
             throws WCMException
取得所属调查

返回：
返回一项调查事项的所属调查
抛出：
WCMException - 如有错误则抛出导常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteItems

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteItems

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsvote.VoteItems

public class VoteItems
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
VoteItems(User _currUser)
构造函数
VoteItems(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VoteItems

public VoteItems(User _currUser)
构造函数

另请参见：
VoteItems( User _currUser, int _initCapacity, int _incCapacity );

VoteItems

public VoteItems(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteOption

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteOption

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.common.trsvote.VoteOption
所有已实现的接口：
java.lang.Cloneable
public class VoteOption
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
VoteOption()
构造函数：保留默认接口
方法摘要
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getItemId() 提取属性：ItemId
int | getOptionId() 提取属性：OptionId
int | getStyle() 提取属性：Style
java.lang.String | getTitle() 提取属性：Title
VoteDatas | getVoteDatas(User _currUser) 取得调查选项的投票结果
VoteItem | getVoteItem(User _currUser) 取得调查选项所属的调查事项
int | getWCMType() 取得该对象的类型编号
boolean | isValid() 检验对象数据有效性
boolean | setItemId(int _nItemId) 设置属性：ItemId
boolean | setStyle(int _nStyle) 设置属性：Style
boolean | setTitle(java.lang.String _sTitle) 设置属性：Title
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

VoteOption

public VoteOption()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getOptionId

public int getOptionId()
提取属性：OptionId

返回：
OptionId

getTitle

public java.lang.String getTitle()
提取属性：Title

返回：
Title

setTitle

public boolean setTitle(java.lang.String _sTitle)
                 throws WCMException
设置属性：Title

参数：
Title - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyle

public int getStyle()
提取属性：Style

返回：
Style

setStyle

public boolean setStyle(int _nStyle)
                 throws WCMException
设置属性：Style

参数：
Style - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getItemId

public int getItemId()
提取属性：ItemId

返回：
ItemId

setItemId

public boolean setItemId(int _nItemId)
                  throws WCMException
设置属性：ItemId

参数：
ItemId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

getVoteDatas

public VoteDatas getVoteDatas(User _currUser)
                       throws WCMException
取得调查选项的投票结果

返回：
返回一项调查选项的所有投票数据
抛出：
WCMException - 如有错误则抛出导常

getVoteItem

public VoteItem getVoteItem(User _currUser)
                     throws WCMException
取得调查选项所属的调查事项

返回：
返回一项调查选项所属的调查事项
抛出：
WCMException - 如有错误则抛出导常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteOptions

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteOptions

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsvote.VoteOptions

public class VoteOptions
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
VoteOptions(User _currUser)
构造函数
VoteOptions(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VoteOptions

public VoteOptions(User _currUser)
构造函数

另请参见：
VoteOptions( User _currUser, int _initCapacity, int _incCapacity );

VoteOptions

public VoteOptions(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Votes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 Votes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.common.trsvote.Votes

public class Votes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Votes(User _currUser)
构造函数
Votes(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Votes

public Votes(User _currUser)
构造函数

另请参见：
Votes( User _currUser, int _initCapacity, int _incCapacity );

Votes

public Votes(User _currUser,
             int _initCapacity,
             int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteSoapClient

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteSoapClient

java.lang.Object
    继承者  com.trs.components.common.trsvote.VoteSoapClient

public class VoteSoapClient
extends java.lang.Object

构造方法摘要
VoteSoapClient()
方法摘要
java.lang.String | getStatVote(java.lang.String sSoapUrl, java.lang.String sStatVoteUrl, java.lang.String sVoteId)
java.lang.String | getSubmitVote(java.lang.String sSoapUrl, java.lang.String sSubmitVoteUrl, java.lang.String sVoteId, java.lang.String sVoteClientIP, java.lang.String sElementCheckeds)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VoteSoapClient

public VoteSoapClient()
方法详细信息

getStatVote

public java.lang.String getStatVote(java.lang.String sSoapUrl,
                                    java.lang.String sStatVoteUrl,
                                    java.lang.String sVoteId)

getSubmitVote

public java.lang.String getSubmitVote(java.lang.String sSoapUrl,
                                      java.lang.String sSubmitVoteUrl,
                                      java.lang.String sVoteId,
                                      java.lang.String sVoteClientIP,
                                      java.lang.String sElementCheckeds)

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoteSoapServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.common.trsvote
类 VoteSoapServer

java.lang.Object
    继承者  com.trs.components.common.trsvote.VoteSoapServer

public class VoteSoapServer
extends java.lang.Object

构造方法摘要
VoteSoapServer()
方法摘要
static void | main(java.lang.String[] args)
java.lang.String | statVote(java.lang.String sStatVoteUrl, java.lang.String sVoteId)
java.lang.String | submitVote(java.lang.String sSubmitVoteUrl, java.lang.String sVoteId, java.lang.String sVoteClientIP, java.lang.String sElementCheckeds)
java.lang.String | testVoteSoapServer(java.lang.String name)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VoteSoapServer

public VoteSoapServer()
方法详细信息

statVote

public java.lang.String statVote(java.lang.String sStatVoteUrl,
                                 java.lang.String sVoteId)

submitVote

public java.lang.String submitVote(java.lang.String sSubmitVoteUrl,
                                   java.lang.String sVoteId,
                                   java.lang.String sVoteClientIP,
                                   java.lang.String sElementCheckeds)

testVoteSoapServer

public java.lang.String testVoteSoapServer(java.lang.String name)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.common.trsvote.JVoteConstant 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.JVoteConstant
的使用

没有 com.trs.components.common.trsvote.JVoteConstant 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.Vote 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.Vote
的使用

使用 Vote 的软件包
com.trs.components.common.trsvote

com.trs.components.common.trsvote 中 Vote 的使用

返回 Vote 的 com.trs.components.common.trsvote 中的方法
 Vote VoteItem.getVote(User _currUser)
取得所属调查

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteData
的使用

没有 com.trs.components.common.trsvote.VoteData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteDatas 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteDatas
的使用

使用 VoteDatas 的软件包
com.trs.components.common.trsvote

com.trs.components.common.trsvote 中 VoteDatas 的使用

返回 VoteDatas 的 com.trs.components.common.trsvote 中的方法
 VoteDatas VoteOption.getVoteDatas(User _currUser)
取得调查选项的投票结果

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteIPLog 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteIPLog
的使用

没有 com.trs.components.common.trsvote.VoteIPLog 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteIPLogs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteIPLogs
的使用

使用 VoteIPLogs 的软件包
com.trs.components.common.trsvote

com.trs.components.common.trsvote 中 VoteIPLogs 的使用

返回 VoteIPLogs 的 com.trs.components.common.trsvote 中的方法
 VoteIPLogs Vote.getIPLogs(User _currUser)
取得调查IP记录

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteItem 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteItem
的使用

使用 VoteItem 的软件包
com.trs.components.common.trsvote

com.trs.components.common.trsvote 中 VoteItem 的使用

返回 VoteItem 的 com.trs.components.common.trsvote 中的方法
 VoteItem VoteOption.getVoteItem(User _currUser)
取得调查选项所属的调查事项

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteItems 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteItems
的使用

使用 VoteItems 的软件包
com.trs.components.common.trsvote

com.trs.components.common.trsvote 中 VoteItems 的使用

返回 VoteItems 的 com.trs.components.common.trsvote 中的方法
 VoteItems Vote.getVoteItems(User _currUser)
取得调查事项

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteOption 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteOption
的使用

使用 VoteOption 的软件包
com.trs.components.common.trsvote

com.trs.components.common.trsvote 中 VoteOption 的使用

返回 VoteOption 的 com.trs.components.common.trsvote 中的方法
 VoteOption VoteData.getVoteOption(User _currUser)
取得调查数据所属的调查选项

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteOptions 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteOptions
的使用

使用 VoteOptions 的软件包
com.trs.components.common.trsvote

com.trs.components.common.trsvote 中 VoteOptions 的使用

返回 VoteOptions 的 com.trs.components.common.trsvote 中的方法
 VoteOptions VoteItem.getVoteOptions(User _currUser)
取得调查选项

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.Votes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.Votes
的使用

没有 com.trs.components.common.trsvote.Votes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteSoapClient 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteSoapClient
的使用

没有 com.trs.components.common.trsvote.VoteSoapClient 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.common.trsvote.VoteSoapServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.common.trsvote.VoteSoapServer
的使用

没有 com.trs.components.common.trsvote.VoteSoapServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IQueryFilter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.filter
接口 IQueryFilter

public interface IQueryFilter

方法摘要
 WCMFilter getFilter(MethodContext _mc)

方法详细信息

getFilter

WCMFilter getFilter(MethodContext _mc)
                    throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IQueryFilterFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.filter
接口 IQueryFilterFactory

所有已知实现类：
QueryFilterFactory
public interface IQueryFilterFactory

方法摘要
IQueryFilter | createQueryFilter(int nFilterType) 通过类型构造查询过滤器
void | register(int nFilterType, java.lang.Class oQueryFilterCls) 注册查询过滤器

方法详细信息

register

void register(int nFilterType,
              java.lang.Class oQueryFilterCls)
注册查询过滤器

参数：
nFilterType -
oQueryFilterCls -

createQueryFilter

IQueryFilter createQueryFilter(int nFilterType)
                               throws WCMException
通过类型构造查询过滤器

参数：
nFilterType -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.filter
接口
IQueryFilter
IQueryFilterFactory
类
QueryFilterFactory


com.trs.components.filter

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.filter

接口摘要
IQueryFilter
IQueryFilterFactory

类摘要
QueryFilterFactory


com.trs.components.filter 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.filter 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.filter.QueryFilterFactory (implements com.trs.components.filter.IQueryFilterFactory)

接口分层结构

  • com.trs.components.filter.IQueryFilter
  • com.trs.components.filter.IQueryFilterFactory


软件包 com.trs.components.filter 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.filter
的使用

使用 com.trs.components.filter 的软件包
com.trs.components.filter

com.trs.components.filter 使用的 com.trs.components.filter 中的类
IQueryFilter
IQueryFilterFactory

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


QueryFilterFactory

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.filter
类 QueryFilterFactory

java.lang.Object
    继承者  com.trs.components.filter.QueryFilterFactory
所有已实现的接口：
IQueryFilterFactory
public class QueryFilterFactory
extends java.lang.Object
implements IQueryFilterFactory

方法摘要
IQueryFilter | createQueryFilter(int nFilterType) 通过类型构造查询过滤器
static IQueryFilterFactory | getInstance() 获取一个Factory
void | register(int nFilterType, java.lang.Class OQueryFilterCls) 注册查询过滤器
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getInstance

public static IQueryFilterFactory getInstance()
获取一个Factory

返回：

register

public void register(int nFilterType,
                     java.lang.Class OQueryFilterCls)
从接口 IQueryFilterFactory 复制的描述
注册查询过滤器

指定者：
接口 IQueryFilterFactory 中的 register

createQueryFilter

public IQueryFilter createQueryFilter(int nFilterType)
                               throws WCMException
从接口 IQueryFilterFactory 复制的描述
通过类型构造查询过滤器

指定者：
接口 IQueryFilterFactory 中的 createQueryFilter
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.filter.IQueryFilter 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.filter.IQueryFilter
的使用

使用 IQueryFilter 的软件包
com.trs.components.filter

com.trs.components.filter 中 IQueryFilter 的使用

返回 IQueryFilter 的 com.trs.components.filter 中的方法
IQueryFilter | QueryFilterFactory.createQueryFilter(int nFilterType)
IQueryFilter | IQueryFilterFactory.createQueryFilter(int nFilterType) 通过类型构造查询过滤器

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.filter.IQueryFilterFactory 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.filter.IQueryFilterFactory
的使用

使用 IQueryFilterFactory 的软件包
com.trs.components.filter

com.trs.components.filter 中 IQueryFilterFactory 的使用

实现 IQueryFilterFactory 的 com.trs.components.filter 中的类
 class QueryFilterFactory

返回 IQueryFilterFactory 的 com.trs.components.filter 中的方法
static IQueryFilterFactory QueryFilterFactory.getInstance()
获取一个Factory

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.filter.QueryFilterFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.filter.QueryFilterFactory
的使用

没有 com.trs.components.filter.QueryFilterFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ApplyFormConstants

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.constant
类 ApplyFormConstants

java.lang.Object
    继承者  com.trs.components.gkml.sqgk.constant.ApplyFormConstants

public class ApplyFormConstants
extends java.lang.Object

字段摘要
static int | APPLY_CERTIFICATENAME_IDENTITY
static int | APPLY_CERTIFICATENAME_OFFICER
static int | APPLY_CERTIFICATENAME_STUDENT 证件类型
static int | APPLY_CERTIFICATENAME_WORKER
static int | APPLYER_TYPE_COMPANY
static int | APPLYER_TYPE_PERSON 申请者类型
static int | DEAL_TYPE_DEALED
static int | DEAL_TYPE_DEALING 申请的处理类型
static int | DEAL_TYPE_REJECT
static int | INFO_GET_TYPE_BYSELF
static int | INFO_GET_TYPE_EMAIL
static int | INFO_GET_TYPE_FIXMAIL
static int | INFO_GET_TYPE_POSTMAIL 获取信息的方式
static int | INFO_GET_TYPE_QUICKPOST
static int | INFO_PROVIDER_TYPE_CD
static int | INFO_PROVIDER_TYPE_DISK
static int | INFO_PROVIDER_TYPE_EMAIL
static int | INFO_PROVIDER_TYPE_PAGE 所需信息的指定提供方式
static java.lang.String | PATH_OF_RESULT_MAIL_TEMPLATE
static java.lang.String | PATH_OF_SUBMIT_MAIL_TEMPLATE
构造方法摘要
ApplyFormConstants()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

APPLYER_TYPE_PERSON

public static final int APPLYER_TYPE_PERSON
申请者类型

另请参见：
常量字段值

APPLYER_TYPE_COMPANY

public static final int APPLYER_TYPE_COMPANY
另请参见：
常量字段值

APPLY_CERTIFICATENAME_STUDENT

public static final int APPLY_CERTIFICATENAME_STUDENT
证件类型

另请参见：
常量字段值

APPLY_CERTIFICATENAME_IDENTITY

public static final int APPLY_CERTIFICATENAME_IDENTITY
另请参见：
常量字段值

APPLY_CERTIFICATENAME_WORKER

public static final int APPLY_CERTIFICATENAME_WORKER
另请参见：
常量字段值

APPLY_CERTIFICATENAME_OFFICER

public static final int APPLY_CERTIFICATENAME_OFFICER
另请参见：
常量字段值

INFO_GET_TYPE_POSTMAIL

public static final int INFO_GET_TYPE_POSTMAIL
获取信息的方式

另请参见：
常量字段值

INFO_GET_TYPE_QUICKPOST

public static final int INFO_GET_TYPE_QUICKPOST
另请参见：
常量字段值

INFO_GET_TYPE_EMAIL

public static final int INFO_GET_TYPE_EMAIL
另请参见：
常量字段值

INFO_GET_TYPE_FIXMAIL

public static final int INFO_GET_TYPE_FIXMAIL
另请参见：
常量字段值

INFO_GET_TYPE_BYSELF

public static final int INFO_GET_TYPE_BYSELF
另请参见：
常量字段值

INFO_PROVIDER_TYPE_PAGE

public static final int INFO_PROVIDER_TYPE_PAGE
所需信息的指定提供方式

另请参见：
常量字段值

INFO_PROVIDER_TYPE_EMAIL

public static final int INFO_PROVIDER_TYPE_EMAIL
另请参见：
常量字段值

INFO_PROVIDER_TYPE_CD

public static final int INFO_PROVIDER_TYPE_CD
另请参见：
常量字段值

INFO_PROVIDER_TYPE_DISK

public static final int INFO_PROVIDER_TYPE_DISK
另请参见：
常量字段值

PATH_OF_RESULT_MAIL_TEMPLATE

public static final java.lang.String PATH_OF_RESULT_MAIL_TEMPLATE
另请参见：
常量字段值

PATH_OF_SUBMIT_MAIL_TEMPLATE

public static final java.lang.String PATH_OF_SUBMIT_MAIL_TEMPLATE
另请参见：
常量字段值

DEAL_TYPE_DEALING

public static final int DEAL_TYPE_DEALING
申请的处理类型

另请参见：
常量字段值

DEAL_TYPE_DEALED

public static final int DEAL_TYPE_DEALED
另请参见：
常量字段值

DEAL_TYPE_REJECT

public static final int DEAL_TYPE_REJECT
另请参见：
常量字段值
构造方法详细信息

ApplyFormConstants

public ApplyFormConstants()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.gkml.sqgk.constant
类
ApplyFormConstants


com.trs.components.gkml.sqgk.constant

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.gkml.sqgk.constant

类摘要
ApplyFormConstants


com.trs.components.gkml.sqgk.constant 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.constant 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.gkml.sqgk.constant.ApplyFormConstants


软件包 com.trs.components.gkml.sqgk.constant 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.constant
的使用

没有 com.trs.components.gkml.sqgk.constant 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants
的使用

没有 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ApplyForm

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.persistent
类 ApplyForm

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.gkml.sqgk.persistent.ApplyForm
所有已实现的接口：
java.lang.Cloneable
public class ApplyForm
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ApplyForm()
构造函数：保留默认接口
方法摘要
static ApplyForm | createNewInstance() 产生当前对象[ApplyForm]的实例
static ApplyForm | findById(int _nId) 提取指定ID的对象
static ApplyForm | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAddress() 提取属性：Address
java.lang.String | getApplyDesc() 提取属性：ApplyDesc
java.lang.String | getApplyerName() 提取属性：ApplyerName
int | getApplyerType() 提取属性：ApplyerType
int | getApplyType() 提取属性：ApplyType
java.lang.String | getAssociationPerson() 提取属性：AssociationPerson
java.lang.String | getCertificateCode() 提取属性：CertificateCode
int | getCertificateName() 提取属性：CertificateName
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
CMyDateTime | getDealTime() 提取属性：DEALTIME
int | getDealType() 提取属性：DEALTYPE
java.lang.String | getDepartment() 提取属性：Department
java.lang.String | getEmail() 提取属性：Email
java.lang.String | getFax() 提取属性：Fax
int | getFlowStatusId() 提取属性：FlowStatusId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getIndexCode() 提取属性：IndexCode
long | getInfoGetType() 提取属性：InfoGetType
long | getInfoProviderType() 提取属性：InfoProviderType
java.lang.String | getLegalPerson() 提取属性：LegalPerson
java.lang.String | getMailBody() 提取属性：MailBody
java.lang.String | getMailTitle() 提取属性：MailTitle
java.lang.String | getOrganizeCode() 提取属性：OrganizeCode
java.lang.String | getPostCode() 提取属性：PostCode
java.lang.String | getPurpose() 提取属性：Purpose
java.lang.String | getQueryCode() 提取属性：QueryCode
Status | getStatus() 获取文档状态
int | getStatusId()
java.lang.String | getStatusName()
java.lang.String | getTelephone() 提取属性：Telephone
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isInfoGetType(int nInfoGetType) 判断是否是某种获取信息的方试
boolean | isInfoProviderType(int nInfoProviderType) 判断是否是某种所需信息的指定提供方式
boolean | isValid() 检验对象数据有效性
boolean | setAddress(java.lang.String _sAddress) 设置属性：Address
boolean | setApplyDesc(java.lang.String _sApplyDesc) 设置属性：ApplyDesc
boolean | setApplyerName(java.lang.String _sApplyerName) 设置属性：ApplyerName
boolean | setApplyerType(int _nApplyerType) 设置属性：ApplyerType
boolean | setApplyType(int _nApplyType) 设置属性：_nApplyType
boolean | setAssociationPerson(java.lang.String _sAssociationPerson) 设置属性：AssociationPerson
boolean | setCertificateCode(java.lang.String _sCertificateCode) 设置属性：CertificateCode
boolean | setCertificateName(int _nCertificateName) 设置属性：CertificateName
boolean | setDealTime(CMyDateTime _dtDealTime) 设置属性：DEALTIME
boolean | setDealType(int _nDealType) 设置属性：DealType
boolean | setDepartment(java.lang.String _sDepartment) 设置属性：Department
boolean | setEmail(java.lang.String _sEmail) 设置属性：Email
boolean | setFax(java.lang.String _sFax) 设置属性：Fax
boolean | setFlowStatus(int _nStatusId) 设置属性：_nStatusId
boolean | setIndexCode(java.lang.String _sIndexCode) 设置属性：IndexCode
boolean | setInfoGetType(long _lInfoGetType) 设置属性：InfoGetType
boolean | setInfoProviderType(long _lInfoProviderType) 设置属性：InfoProviderType
boolean | setLegalPerson(java.lang.String _sLegalPerson) 设置属性：LegalPerson
boolean | setMailBody(java.lang.String _sMailBody) 设置属性：MailBody
boolean | setMailTitle(java.lang.String _sMailTitle) 设置属性：MailTitle
boolean | setOrganizeCode(java.lang.String _sOrganizeCode) 设置属性：OrganizeCode
boolean | setPostCode(java.lang.String _sPostCode) 设置属性：PostCode
boolean | setPurpose(java.lang.String _sPurpose) 设置属性：Purpose
boolean | setQueryCode(java.lang.String _sQueryCode) 设置属性：QueryCode
boolean | setTelephone(java.lang.String _sTelephone) 设置属性：Telephone
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ApplyForm

public ApplyForm()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getApplyerName

public java.lang.String getApplyerName()
提取属性：ApplyerName

返回：
ApplyerName

setApplyerName

public boolean setApplyerName(java.lang.String _sApplyerName)
                       throws WCMException
设置属性：ApplyerName

参数：
_sApplyerName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDepartment

public java.lang.String getDepartment()
提取属性：Department

返回：
Department

setDepartment

public boolean setDepartment(java.lang.String _sDepartment)
                      throws WCMException
设置属性：Department

参数：
_sDepartment - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCertificateName

public int getCertificateName()
提取属性：CertificateName

返回：
CertificateName

setCertificateName

public boolean setCertificateName(int _nCertificateName)
                           throws WCMException
设置属性：CertificateName

参数：
_nCertificateName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCertificateCode

public java.lang.String getCertificateCode()
提取属性：CertificateCode

返回：
CertificateCode

setCertificateCode

public boolean setCertificateCode(java.lang.String _sCertificateCode)
                           throws WCMException
设置属性：CertificateCode

参数：
_sCertificateCode - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTelephone

public java.lang.String getTelephone()
提取属性：Telephone

返回：
Telephone

setTelephone

public boolean setTelephone(java.lang.String _sTelephone)
                     throws WCMException
设置属性：Telephone

参数：
_sTelephone - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPostCode

public java.lang.String getPostCode()
提取属性：PostCode

返回：
PostCode

setPostCode

public boolean setPostCode(java.lang.String _sPostCode)
                    throws WCMException
设置属性：PostCode

参数：
_sPostCode - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAddress

public java.lang.String getAddress()
提取属性：Address

返回：
Address

setAddress

public boolean setAddress(java.lang.String _sAddress)
                   throws WCMException
设置属性：Address

参数：
_sAddress - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFax

public java.lang.String getFax()
提取属性：Fax

返回：
Fax

setFax

public boolean setFax(java.lang.String _sFax)
               throws WCMException
设置属性：Fax

参数：
_sFax - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEmail

public java.lang.String getEmail()
提取属性：Email

返回：
Email

setEmail

public boolean setEmail(java.lang.String _sEmail)
                 throws WCMException
设置属性：Email

参数：
_sEmail - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOrganizeCode

public java.lang.String getOrganizeCode()
提取属性：OrganizeCode

返回：
OrganizeCode

setOrganizeCode

public boolean setOrganizeCode(java.lang.String _sOrganizeCode)
                        throws WCMException
设置属性：OrganizeCode

参数：
_sOrganizeCode - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLegalPerson

public java.lang.String getLegalPerson()
提取属性：LegalPerson

返回：
LegalPerson

setLegalPerson

public boolean setLegalPerson(java.lang.String _sLegalPerson)
                       throws WCMException
设置属性：LegalPerson

参数：
_sLegalPerson - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAssociationPerson

public java.lang.String getAssociationPerson()
提取属性：AssociationPerson

返回：
AssociationPerson

setAssociationPerson

public boolean setAssociationPerson(java.lang.String _sAssociationPerson)
                             throws WCMException
设置属性：AssociationPerson

参数：
_sAssociationPerson - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDealTime

public CMyDateTime getDealTime()
提取属性：DEALTIME

返回：
DEALTIME

setDealTime

public boolean setDealTime(CMyDateTime _dtDealTime)
                    throws WCMException
设置属性：DEALTIME

参数：
_dtDealTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPurpose

public java.lang.String getPurpose()
提取属性：Purpose

返回：
Purpose

setPurpose

public boolean setPurpose(java.lang.String _sPurpose)
                   throws WCMException
设置属性：Purpose

参数：
_sPurpose - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getApplyDesc

public java.lang.String getApplyDesc()
提取属性：ApplyDesc

返回：
ApplyDesc

setApplyDesc

public boolean setApplyDesc(java.lang.String _sApplyDesc)
                     throws WCMException
设置属性：ApplyDesc

参数：
_sApplyDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIndexCode

public java.lang.String getIndexCode()
提取属性：IndexCode

返回：
IndexCode

setIndexCode

public boolean setIndexCode(java.lang.String _sIndexCode)
                     throws WCMException
设置属性：IndexCode

参数：
_sIndexCode - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getApplyerType

public int getApplyerType()
提取属性：ApplyerType

返回：
ApplyerType

setApplyerType

public boolean setApplyerType(int _nApplyerType)
                       throws WCMException
设置属性：ApplyerType

参数：
_nApplyerType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDealType

public int getDealType()
提取属性：DEALTYPE

返回：
DEALTYPE

getStatusName

public java.lang.String getStatusName()
                               throws WCMException
抛出：
WCMException

getStatus

public Status getStatus()
                 throws WCMException
获取文档状态

返回：
文档状态对象
抛出：
WCMException

getStatusId

public int getStatusId()

setFlowStatus

public boolean setFlowStatus(int _nStatusId)
                      throws WCMException
设置属性：_nStatusId

参数：
_nStatusId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFlowStatusId

public int getFlowStatusId()
提取属性：FlowStatusId

返回：
FlowStatusId

setApplyType

public boolean setApplyType(int _nApplyType)
                     throws WCMException
设置属性：_nApplyType

参数：
_nApplyType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getApplyType

public int getApplyType()
提取属性：ApplyType

返回：
ApplyType

setDealType

public boolean setDealType(int _nDealType)
                    throws WCMException
设置属性：DealType

参数：
_nDealType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getInfoGetType

public long getInfoGetType()
提取属性：InfoGetType

返回：
InfoGetType

setInfoGetType

public boolean setInfoGetType(long _lInfoGetType)
                       throws WCMException
设置属性：InfoGetType

参数：
_lInfoGetType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getInfoProviderType

public long getInfoProviderType()
提取属性：InfoProviderType

返回：
InfoProviderType

setInfoProviderType

public boolean setInfoProviderType(long _lInfoProviderType)
                            throws WCMException
设置属性：InfoProviderType

参数：
_lInfoProviderType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMailTitle

public java.lang.String getMailTitle()
提取属性：MailTitle

返回：
ApplyDesc

setMailTitle

public boolean setMailTitle(java.lang.String _sMailTitle)
                     throws WCMException
设置属性：MailTitle

参数：
_sMailTitle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMailBody

public java.lang.String getMailBody()
提取属性：MailBody

返回：
MailBody

setMailBody

public boolean setMailBody(java.lang.String _sMailBody)
                    throws WCMException
设置属性：MailBody

参数：
_sMailBody - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getQueryCode

public java.lang.String getQueryCode()
提取属性：QueryCode

返回：
QueryCode

setQueryCode

public boolean setQueryCode(java.lang.String _sQueryCode)
                     throws WCMException
设置属性：QueryCode

参数：
_sQueryCode - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

isInfoGetType

public boolean isInfoGetType(int nInfoGetType)
判断是否是某种获取信息的方试

isInfoProviderType

public boolean isInfoProviderType(int nInfoProviderType)
判断是否是某种所需信息的指定提供方式

参数：
nInfoProviderType -
返回：

findById

public static final ApplyForm findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ApplyForm createNewInstance()
                                         throws WCMException
产生当前对象[ApplyForm]的实例

返回：
当前对象的实例[ApplyForm]
抛出：
WCMException

findByKey

public static final ApplyForm findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ApplyFormDealLog

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.persistent
类 ApplyFormDealLog

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog
所有已实现的接口：
java.lang.Cloneable
public class ApplyFormDealLog
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ApplyFormDealLog()
构造函数：保留默认接口
方法摘要
static ApplyFormDealLog | createNewInstance() 产生当前对象[ApplyFormDealLog]的实例
static ApplyFormDealLog | findById(int _nId) 提取指定ID的对象
static ApplyFormDealLog | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getApplyDesc() 提取属性：APPLYDESC
java.lang.String | getApplyerName() 提取属性：ApplyerName
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDealContent() 提取属性：DealContent
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setApplyDesc(java.lang.String _sApplyDesc) 设置属性：APPLYDESC
boolean | setApplyerName(java.lang.String _sApplyerName) 设置属性：ApplyerName
boolean | setDealContent(java.lang.String _sDealContent) 设置属性：DealContent
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ApplyFormDealLog

public ApplyFormDealLog()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getApplyerName

public java.lang.String getApplyerName()
提取属性：ApplyerName

返回：
ApplyerName

setApplyerName

public boolean setApplyerName(java.lang.String _sApplyerName)
                       throws WCMException
设置属性：ApplyerName

参数：
_sApplyerName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getApplyDesc

public java.lang.String getApplyDesc()
提取属性：APPLYDESC

返回：
APPLYDESC

setApplyDesc

public boolean setApplyDesc(java.lang.String _sApplyDesc)
                     throws WCMException
设置属性：APPLYDESC

参数：
_sApplyDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDealContent

public java.lang.String getDealContent()
提取属性：DealContent

返回：
DealContent

setDealContent

public boolean setDealContent(java.lang.String _sDealContent)
                       throws WCMException
设置属性：DealContent

参数：
_sDealContent - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final ApplyFormDealLog findById(int _nId)
                                       throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ApplyFormDealLog createNewInstance()
                                                throws WCMException
产生当前对象[ApplyFormDealLog]的实例

返回：
当前对象的实例[ApplyFormDealLog]
抛出：
WCMException

findByKey

public static final ApplyFormDealLog findByKey(java.lang.Object _oKey)
                                        throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ApplyFormDealLogs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.persistent
类 ApplyFormDealLogs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs

public class ApplyFormDealLogs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ApplyFormDealLogs(User _currUser)
构造函数
ApplyFormDealLogs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ApplyFormDealLogs | createNewInstance(User _currUser) 产生当前集合对象[ApplyFormDealLogs]的实例
static ApplyFormDealLogs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ApplyFormDealLogs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ApplyFormDealLogs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ApplyFormDealLogs

public ApplyFormDealLogs(User _currUser)
构造函数

另请参见：
ApplyFormDealLogs( User _currUser, int _initCapacity, int _incCapacity );

ApplyFormDealLogs

public ApplyFormDealLogs(User _currUser,
                         int _initCapacity,
                         int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ApplyFormDealLogs findByIds(User _currUser,
                                                java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ApplyFormDealLogs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ApplyFormDealLogs openWCMObjs(User _currUser,
                                                  WCMFilter _filter)
                                           throws WCMException
通过指定一个Filter获取当前集合[ApplyFormDealLogs]

参数：
_filter - 指定的Filter
返回：
当前集合[ApplyFormDealLogs]
抛出：
WCMException

createNewInstance

public static ApplyFormDealLogs createNewInstance(User _currUser)
产生当前集合对象[ApplyFormDealLogs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ApplyForms

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.persistent
类 ApplyForms

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.gkml.sqgk.persistent.ApplyForms

public class ApplyForms
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ApplyForms(User _currUser)
构造函数
ApplyForms(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ApplyForms | createNewInstance(User _currUser) 产生当前集合对象[ApplyForms]的实例
static ApplyForms | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ApplyForms | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ApplyForms]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ApplyForms

public ApplyForms(User _currUser)
构造函数

另请参见：
ApplyForms( User _currUser, int _initCapacity, int _incCapacity );

ApplyForms

public ApplyForms(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ApplyForms findByIds(User _currUser,
                                         java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ApplyForms）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ApplyForms openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[ApplyForms]

参数：
_filter - 指定的Filter
返回：
当前集合[ApplyForms]
抛出：
WCMException

createNewInstance

public static ApplyForms createNewInstance(User _currUser)
产生当前集合对象[ApplyForms]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MailConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.persistent
类 MailConfig

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.gkml.sqgk.persistent.MailConfig
所有已实现的接口：
java.lang.Cloneable
public class MailConfig
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
MailConfig()
构造函数：保留默认接口
方法摘要
static MailConfig | createNewInstance() 产生当前对象[MailConfig]的实例
static MailConfig | findById(int _nId) 提取指定ID的对象
static MailConfig | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getParamName() 提取属性：ParamName
java.lang.String | getParamValue() 提取属性：ParamValue
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setParamName(java.lang.String _sParamName) 设置属性：ParamName
boolean | setParamValue(java.lang.String _sParamValue) 设置属性：ParamValue
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

MailConfig

public MailConfig()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getParamName

public java.lang.String getParamName()
提取属性：ParamName

返回：
ParamName

setParamName

public boolean setParamName(java.lang.String _sParamName)
                     throws WCMException
设置属性：ParamName

参数：
_sParamName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getParamValue

public java.lang.String getParamValue()
提取属性：ParamValue

返回：
ParamValue

setParamValue

public boolean setParamValue(java.lang.String _sParamValue)
                      throws WCMException
设置属性：ParamValue

参数：
_sParamValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final MailConfig findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MailConfig createNewInstance()
                                          throws WCMException
产生当前对象[MailConfig]的实例

返回：
当前对象的实例[MailConfig]
抛出：
WCMException

findByKey

public static final MailConfig findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MailConfigs

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.persistent
类 MailConfigs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.gkml.sqgk.persistent.MailConfigs

public class MailConfigs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MailConfigs(User _currUser)
构造函数
MailConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static MailConfigs | createNewInstance(User _currUser) 产生当前集合对象[MailConfigs]的实例
static MailConfigs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static MailConfigs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MailConfigs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MailConfigs

public MailConfigs(User _currUser)
构造函数

另请参见：
MailConfigs( User _currUser, int _initCapacity, int _incCapacity );

MailConfigs

public MailConfigs(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final MailConfigs findByIds(User _currUser,
                                          java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（MailConfigs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MailConfigs openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[MailConfigs]

参数：
_filter - 指定的Filter
返回：
当前集合[MailConfigs]
抛出：
WCMException

createNewInstance

public static MailConfigs createNewInstance(User _currUser)
产生当前集合对象[MailConfigs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.gkml.sqgk.persistent
类
ApplyForm
ApplyFormDealLog
ApplyFormDealLogs
ApplyForms
MailConfig
MailConfigs


com.trs.components.gkml.sqgk.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.gkml.sqgk.persistent

类摘要
ApplyForm
ApplyFormDealLog
ApplyFormDealLogs
ApplyForms
MailConfig
MailConfigs


com.trs.components.gkml.sqgk.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.gkml.sqgk.persistent.ApplyForm
        • com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog
        • com.trs.components.gkml.sqgk.persistent.MailConfig
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs
        • com.trs.components.gkml.sqgk.persistent.ApplyForms
        • com.trs.components.gkml.sqgk.persistent.MailConfigs


软件包 com.trs.components.gkml.sqgk.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.persistent
的使用

使用 com.trs.components.gkml.sqgk.persistent 的软件包
com.trs.ajaxservice
com.trs.components.gkml.sqgk.persistent
com.trs.components.gkml.sqgk.process.element

com.trs.ajaxservice 使用的 com.trs.components.gkml.sqgk.persistent 中的类
ApplyForm

com.trs.components.gkml.sqgk.persistent 使用的 com.trs.components.gkml.sqgk.persistent 中的类
ApplyForm
ApplyFormDealLog
ApplyFormDealLogs
ApplyForms
MailConfig
MailConfigs

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.components.gkml.sqgk.persistent 中的类
ApplyForm

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.persistent.ApplyForm 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.persistent.ApplyForm
的使用

使用 ApplyForm 的软件包
com.trs.ajaxservice
com.trs.components.gkml.sqgk.persistent
com.trs.components.gkml.sqgk.process.element

com.trs.ajaxservice 中 ApplyForm 的使用

参数类型为 ApplyForm 的 com.trs.ajaxservice 中的方法
static void | WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, boolean _bUseDefaultFlowMode)
static void | WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, java.util.Map _hFlowContextInfo)
static void | WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, MethodContext _oMethodContext)

com.trs.components.gkml.sqgk.persistent 中 ApplyForm 的使用

返回 ApplyForm 的 com.trs.components.gkml.sqgk.persistent 中的方法
static ApplyForm | ApplyForm.createNewInstance() 产生当前对象[ApplyForm]的实例
static ApplyForm | ApplyForm.findById(int _nId) 提取指定ID的对象
static ApplyForm | ApplyForm.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.components.gkml.sqgk.process.element 中 ApplyForm 的使用

返回 ApplyForm 的 com.trs.components.gkml.sqgk.process.element 中的方法
 ApplyForm FlowContentApplyFormImpl.getApplyForm()

参数类型为 ApplyForm 的 com.trs.components.gkml.sqgk.process.element 中的方法
void | FlowContentApplyFormImpl.makeFrom(ApplyForm _cmsObj)
void | FlowContentApplyFormImpl.setSubinstance(ApplyForm _subinstance)
void | FlowContentApplyFormImpl.setSubstance(ApplyForm _cmsObj)

参数类型为 ApplyForm 的 com.trs.components.gkml.sqgk.process.element 中的构造方法
FlowContentApplyFormImpl(ApplyForm _oCmsObj)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog
的使用

使用 ApplyFormDealLog 的软件包
com.trs.components.gkml.sqgk.persistent

com.trs.components.gkml.sqgk.persistent 中 ApplyFormDealLog 的使用

返回 ApplyFormDealLog 的 com.trs.components.gkml.sqgk.persistent 中的方法
static ApplyFormDealLog | ApplyFormDealLog.createNewInstance() 产生当前对象[ApplyFormDealLog]的实例
static ApplyFormDealLog | ApplyFormDealLog.findById(int _nId) 提取指定ID的对象
static ApplyFormDealLog | ApplyFormDealLog.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs
的使用

使用 ApplyFormDealLogs 的软件包
com.trs.components.gkml.sqgk.persistent

com.trs.components.gkml.sqgk.persistent 中 ApplyFormDealLogs 的使用

返回 ApplyFormDealLogs 的 com.trs.components.gkml.sqgk.persistent 中的方法
static ApplyFormDealLogs | ApplyFormDealLogs.createNewInstance(User _currUser) 产生当前集合对象[ApplyFormDealLogs]的实例
static ApplyFormDealLogs | ApplyFormDealLogs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ApplyFormDealLogs | ApplyFormDealLogs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ApplyFormDealLogs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.persistent.ApplyForms 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.persistent.ApplyForms
的使用

使用 ApplyForms 的软件包
com.trs.components.gkml.sqgk.persistent

com.trs.components.gkml.sqgk.persistent 中 ApplyForms 的使用

返回 ApplyForms 的 com.trs.components.gkml.sqgk.persistent 中的方法
static ApplyForms | ApplyForms.createNewInstance(User _currUser) 产生当前集合对象[ApplyForms]的实例
static ApplyForms | ApplyForms.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ApplyForms | ApplyForms.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ApplyForms]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.persistent.MailConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.persistent.MailConfig
的使用

使用 MailConfig 的软件包
com.trs.components.gkml.sqgk.persistent

com.trs.components.gkml.sqgk.persistent 中 MailConfig 的使用

返回 MailConfig 的 com.trs.components.gkml.sqgk.persistent 中的方法
static MailConfig | MailConfig.createNewInstance() 产生当前对象[MailConfig]的实例
static MailConfig | MailConfig.findById(int _nId) 提取指定ID的对象
static MailConfig | MailConfig.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.persistent.MailConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.persistent.MailConfigs
的使用

使用 MailConfigs 的软件包
com.trs.components.gkml.sqgk.persistent

com.trs.components.gkml.sqgk.persistent 中 MailConfigs 的使用

返回 MailConfigs 的 com.trs.components.gkml.sqgk.persistent 中的方法
static MailConfigs | MailConfigs.createNewInstance(User _currUser) 产生当前集合对象[MailConfigs]的实例
static MailConfigs | MailConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static MailConfigs | MailConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MailConfigs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FlowContentApplyFormImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.process.element
类 FlowContentApplyFormImpl

java.lang.Object
    继承者  com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl
所有已实现的接口：
ICMSObjSubstanceContent, IFlowContent
public class FlowContentApplyFormImpl
extends java.lang.Object
implements IFlowContent

Title: TRS 内容协作平台（TRS WCM）
Description:
Document的FlowContent的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContentApplyFormImpl()
FlowContentApplyFormImpl(ApplyForm _oCmsObj)
FlowContentApplyFormImpl(int _nObjType, int _nId)
方法摘要
void | cancelUpdate(User user) 取消本次更新
boolean | canEdit(User _currUser) 判断当前操作用户是否可以对当前流转的内容进行修改
ApplyForm | getApplyForm()
static ConfigServer | getConfigServer()
java.lang.String | getContentAddEditPage() 获取内容的编辑页面
java.lang.String | getContentShowPage() 获取内容的查看页面
int | getContentType() 获取当前流转内容的类型
User | getCrUser()
java.lang.String | getDeletePage()
java.lang.String | getDesc() 获取当前流转内容的简要描述
FlowDoc | getFlowDoc() 获取FlowContent相关的FlowDoc
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
Flow | getOwnerFlow() 获取当前所属对象的工作流对象
java.lang.String | getProperty(java.lang.String _sName) 获取指定属性的名称
java.lang.String | getPublishPage()
long | getSerialNum() 获取内容被发起的SerialNum
CMyDateTime | getStartTime() 获取内容被发起的时间
java.lang.String | getStatusDesc() 获取状态的描述
int | getStatusId()
CMSObj | getSubinstance() 获取流转内容关联的对象
int | getSubinstanceId() 获取当前流转内容的ID
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isDeleted()
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(ApplyForm _cmsObj)
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setFlow(Flow flow)
void | setFlowDoc(FlowDoc _flowDoc) 设置FlowContent相关的FlowDoc
void | setSerialNum(long _lSerialNum) 设置内容被发起时候的SerialNum
void | setStartTime(CMyDateTime _dtStartTime) 设置内容被发起的时间
void | setSubinstance(ApplyForm _subinstance)
void | setSubinstance(CMSObj _subinstance)
void | setSubinstance(int _nSubinstanceId) 设置当前Content的关联ID
void | setSubstance(ApplyForm _cmsObj)
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | updateStatus(User user, int statusId) 更新当前内容的工作流状态
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContentApplyFormImpl

public FlowContentApplyFormImpl(ApplyForm _oCmsObj)

FlowContentApplyFormImpl

public FlowContentApplyFormImpl(int _nObjType,
                                int _nId)

FlowContentApplyFormImpl

public FlowContentApplyFormImpl()
方法详细信息

getApplyForm

public ApplyForm getApplyForm()

canEdit

public boolean canEdit(User _currUser)
                throws WCMException
从接口 IFlowContent 复制的描述
判断当前操作用户是否可以对当前流转的内容进行修改

指定者：
接口 IFlowContent 中的 canEdit
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
                         throws WCMException
从接口 IFlowContent 复制的描述
获取当前流转内容的简要描述

指定者：
接口 IFlowContent 中的 getDesc
返回：
抛出：
WCMException

getContentType

public int getContentType()
从接口 IFlowContent 复制的描述
获取当前流转内容的类型

指定者：
接口 IFlowContent 中的 getContentType
返回：

getSubinstanceId

public int getSubinstanceId()
从接口 IFlowContent 复制的描述
获取当前流转内容的ID

指定者：
接口 IFlowContent 中的 getSubinstanceId
返回：

setSubinstance

public void setSubinstance(int _nSubinstanceId)
从接口 IFlowContent 复制的描述
设置当前Content的关联ID

指定者：
接口 IFlowContent 中的 setSubinstance
参数：
_nSubinstanceId - 新的ID（比如文档ID）

cancelUpdate

public void cancelUpdate(User user)
                  throws WCMException
从接口 IFlowContent 复制的描述
取消本次更新

指定者：
接口 IFlowContent 中的 cancelUpdate
抛出：
WCMException

getCrUser

public User getCrUser()
               throws WCMException
指定者：
接口 IFlowContent 中的 getCrUser
返回：
抛出：
WCMException

getSubinstance

public CMSObj getSubinstance()
                      throws WCMException
从接口 IFlowContent 复制的描述
获取流转内容关联的对象

指定者：
接口 IFlowContent 中的 getSubinstance
返回：
抛出：
WCMException

setSubinstance

public void setSubinstance(ApplyForm _subinstance)

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

makeFrom

public void makeFrom(ApplyForm _cmsObj)

setSubstance

public void setSubstance(ApplyForm _cmsObj)

getFlowDoc

public FlowDoc getFlowDoc()
从接口 IFlowContent 复制的描述
获取FlowContent相关的FlowDoc

指定者：
接口 IFlowContent 中的 getFlowDoc
返回：

setFlowDoc

public void setFlowDoc(FlowDoc _flowDoc)
从接口 IFlowContent 复制的描述
设置FlowContent相关的FlowDoc

指定者：
接口 IFlowContent 中的 setFlowDoc

getProperty

public java.lang.String getProperty(java.lang.String _sName)
从接口 IFlowContent 复制的描述
获取指定属性的名称

指定者：
接口 IFlowContent 中的 getProperty
返回：

getStartTime

public CMyDateTime getStartTime()
从接口 IFlowContent 复制的描述
获取内容被发起的时间

指定者：
接口 IFlowContent 中的 getStartTime
返回：

setStartTime

public void setStartTime(CMyDateTime _dtStartTime)
从接口 IFlowContent 复制的描述
设置内容被发起的时间

指定者：
接口 IFlowContent 中的 setStartTime

getContentAddEditPage

public java.lang.String getContentAddEditPage()
                                       throws WCMException
从接口 IFlowContent 复制的描述
获取内容的编辑页面

指定者：
接口 IFlowContent 中的 getContentAddEditPage
返回：
内容的编辑页面
抛出：
WCMException

getContentShowPage

public java.lang.String getContentShowPage()
                                    throws WCMException
从接口 IFlowContent 复制的描述
获取内容的查看页面

指定者：
接口 IFlowContent 中的 getContentShowPage
返回：
内容的查看页面
抛出：
WCMException

getDeletePage

public java.lang.String getDeletePage()
                               throws WCMException
指定者：
接口 IFlowContent 中的 getDeletePage
抛出：
WCMException

getConfigServer

public static ConfigServer getConfigServer()

getOwnerFlow

public Flow getOwnerFlow()
                  throws WCMException
从接口 IFlowContent 复制的描述
获取当前所属对象的工作流对象

指定者：
接口 IFlowContent 中的 getOwnerFlow
返回：
抛出：
WCMException

getPublishPage

public java.lang.String getPublishPage()
                                throws WCMException
指定者：
接口 IFlowContent 中的 getPublishPage
抛出：
WCMException

getSerialNum

public long getSerialNum()
从接口 IFlowContent 复制的描述
获取内容被发起的SerialNum

指定者：
接口 IFlowContent 中的 getSerialNum
返回：

setSerialNum

public void setSerialNum(long _lSerialNum)
从接口 IFlowContent 复制的描述
设置内容被发起时候的SerialNum

指定者：
接口 IFlowContent 中的 setSerialNum

getStatusDesc

public java.lang.String getStatusDesc()
                               throws WCMException
从接口 IFlowContent 复制的描述
获取状态的描述

指定者：
接口 IFlowContent 中的 getStatusDesc
返回：
抛出：
WCMException

getStatusId

public int getStatusId()
                throws WCMException
指定者：
接口 IFlowContent 中的 getStatusId
返回：
抛出：
WCMException

isDeleted

public boolean isDeleted()
指定者：
接口 IFlowContent 中的 isDeleted
返回：

setSubinstance

public void setSubinstance(CMSObj _subinstance)
                    throws WCMException
指定者：
接口 IFlowContent 中的 setSubinstance
抛出：
WCMException

updateStatus

public void updateStatus(User user,
                         int statusId)
                  throws WCMException
从接口 IFlowContent 复制的描述
更新当前内容的工作流状态

指定者：
接口 IFlowContent 中的 updateStatus
抛出：
WCMException

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

setFlow

public void setFlow(Flow flow)
指定者：
接口 IFlowContent 中的 setFlow
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.gkml.sqgk.process.element
类
FlowContentApplyFormImpl


com.trs.components.gkml.sqgk.process.element

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.element

类摘要
FlowContentApplyFormImpl Title: TRS 内容协作平台（TRS WCM）
Description:
Document的FlowContent的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.gkml.sqgk.process.element 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.element 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl (implements com.trs.cms.process.IFlowContent)


软件包 com.trs.components.gkml.sqgk.process.element 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.element
的使用

没有 com.trs.components.gkml.sqgk.process.element 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl
的使用

没有 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ApplyFormToUsersCreator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.process.engine.creators
类 ApplyFormToUsersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.components.gkml.sqgk.process.engine.creators.ApplyFormToUsersCreator
所有已实现的接口：
IToUsersCreator
public class ApplyFormToUsersCreator
extends AbstractToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gong.fuchang)

构造方法摘要
ApplyFormToUsersCreator()
方法摘要
 Users createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ApplyFormToUsersCreator

public ApplyFormToUsersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


LawGovTousersCreator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.process.engine.creators
类 LawGovTousersCreator

java.lang.Object
    继承者  com.trs.cms.process.engine.AbstractToUsersCreator
        继承者  com.trs.components.gkml.sqgk.process.engine.creators.LawGovTousersCreator
所有已实现的接口：
IToUsersCreator
public class LawGovTousersCreator
extends AbstractToUsersCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
法制办审核人构造器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LawGovTousersCreator()
方法摘要
 Users createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息
从类 com.trs.cms.process.engine.AbstractToUsersCreator 继承的方法
getGroupRange, isRangedFromGroup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LawGovTousersCreator

public LawGovTousersCreator()
方法详细信息

createToUsers

public Users createToUsers(FlowContext _oFlowContext,
                           ToUsersCreatorConfig _oCreatorConfig)
                    throws WCMException
从接口 IToUsersCreator 复制的描述
根据当前上下文信息产生处理者信息

_oCreatorConfig - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.gkml.sqgk.process.engine.creators
类
ApplyFormToUsersCreator
LawGovTousersCreator


com.trs.components.gkml.sqgk.process.engine.creators

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.engine.creators

类摘要
ApplyFormToUsersCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LawGovTousersCreator | Title: TRS 内容协作平台（TRS WCM） Description: 法制办审核人构造器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.gkml.sqgk.process.engine.creators 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.engine.creators 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.cms.process.engine.AbstractToUsersCreator (implements com.trs.cms.process.engine.IToUsersCreator)
      • com.trs.components.gkml.sqgk.process.engine.creators.ApplyFormToUsersCreator
      • com.trs.components.gkml.sqgk.process.engine.creators.LawGovTousersCreator


软件包 com.trs.components.gkml.sqgk.process.engine.creators 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.engine.creators
的使用

没有 com.trs.components.gkml.sqgk.process.engine.creators 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.process.engine.creators.ApplyFormToUsersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.process.engine.creators.ApplyFormToUsersCreator
的使用

没有 com.trs.components.gkml.sqgk.process.engine.creators.ApplyFormToUsersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.process.engine.creators.LawGovTousersCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.process.engine.creators.LawGovTousersCreator
的使用

没有 com.trs.components.gkml.sqgk.process.engine.creators.LawGovTousersCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ApplyFormReplyHandler

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.process.engine.handlers
类 ApplyFormReplyHandler

java.lang.Object
    继承者  com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler
所有已实现的接口：
IActionHandler
public class ApplyFormReplyHandler
extends java.lang.Object
implements IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ApplyFormReplyHandler()
方法摘要
java.lang.String | doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
boolean | execute(ExecuteContext _context, FlowAction _action)
java.util.Map | getVarValues()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ApplyFormReplyHandler

public ApplyFormReplyHandler()
方法详细信息

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
                throws WCMException
指定者：
接口 IActionHandler 中的 execute
抛出：
WCMException

doPageVariablesParse

public java.lang.String doPageVariablesParse(java.lang.String _sContent,
                                             ExecuteContext _context)
                                      throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_context -
返回：
抛出：
WCMException

getVarValues

public java.util.Map getVarValues()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ApplyFormTypeHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.process.engine.handlers
类 ApplyFormTypeHandler

java.lang.Object
    继承者  com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler
所有已实现的接口：
IActionHandler
public class ApplyFormTypeHandler
extends java.lang.Object
implements IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ApplyFormTypeHandler()
方法摘要
java.lang.String | doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
boolean | execute(ExecuteContext _context, FlowAction _action)
java.util.Map | getVarValues()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ApplyFormTypeHandler

public ApplyFormTypeHandler()
方法详细信息

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
                throws WCMException
指定者：
接口 IActionHandler 中的 execute
抛出：
WCMException

doPageVariablesParse

public java.lang.String doPageVariablesParse(java.lang.String _sContent,
                                             ExecuteContext _context)
                                      throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_context -
返回：
抛出：
WCMException

getVarValues

public java.util.Map getVarValues()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AutoFillApplyFormHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.process.engine.handlers
类 AutoFillApplyFormHandler

java.lang.Object
    继承者  com.trs.components.gkml.sqgk.process.engine.handlers.AutoFillApplyFormHandler
所有已实现的接口：
IActionHandler
public class AutoFillApplyFormHandler
extends java.lang.Object
implements IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AutoFillApplyFormHandler()
方法摘要
 boolean execute(ExecuteContext _context, FlowAction _action)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AutoFillApplyFormHandler

public AutoFillApplyFormHandler()
方法详细信息

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
                throws WCMException
指定者：
接口 IActionHandler 中的 execute
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.gkml.sqgk.process.engine.handlers
类
ApplyFormReplyHandler
ApplyFormTypeHandler
AutoFillApplyFormHandler
ReplyAppendixNotifyHandler
ReplyNotifyHandler


com.trs.components.gkml.sqgk.process.engine.handlers

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.engine.handlers

类摘要
ApplyFormReplyHandler | Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ApplyFormTypeHandler | Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
AutoFillApplyFormHandler | Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ReplyAppendixNotifyHandler | Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ReplyNotifyHandler | Title: TRS 内容协作平台（TRS WCM） Description: 出具通知书的处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.gkml.sqgk.process.engine.handlers 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.engine.handlers 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.components.gkml.sqgk.process.engine.handlers.AutoFillApplyFormHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler (implements com.trs.cms.process.engine.IActionHandler)
    • com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler (implements com.trs.cms.process.engine.IActionHandler)


软件包 com.trs.components.gkml.sqgk.process.engine.handlers 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.gkml.sqgk.process.engine.handlers
的使用

没有 com.trs.components.gkml.sqgk.process.engine.handlers 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ReplyAppendixNotifyHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.process.engine.handlers
类 ReplyAppendixNotifyHandler

java.lang.Object
    继承者  com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler
所有已实现的接口：
IActionHandler
public class ReplyAppendixNotifyHandler
extends java.lang.Object
implements IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | ATTACH_ALL_APPENDIX
static int | ATTACH_FIRST_APPENDIX
构造方法摘要
ReplyAppendixNotifyHandler()
方法摘要
java.lang.String | doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
boolean | execute(ExecuteContext _context, FlowAction _action)
java.util.Map | getVarValues()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ATTACH_ALL_APPENDIX

public static final int ATTACH_ALL_APPENDIX
另请参见：
常量字段值

ATTACH_FIRST_APPENDIX

public static final int ATTACH_FIRST_APPENDIX
另请参见：
常量字段值
构造方法详细信息

ReplyAppendixNotifyHandler

public ReplyAppendixNotifyHandler()
方法详细信息

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
                throws WCMException
指定者：
接口 IActionHandler 中的 execute
抛出：
WCMException

doPageVariablesParse

public java.lang.String doPageVariablesParse(java.lang.String _sContent,
                                             ExecuteContext _context)
                                      throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_context -
返回：
抛出：
WCMException

getVarValues

public java.util.Map getVarValues()

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReplyNotifyHandler

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.gkml.sqgk.process.engine.handlers
类 ReplyNotifyHandler

java.lang.Object
    继承者  com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler
所有已实现的接口：
IActionHandler
public class ReplyNotifyHandler
extends java.lang.Object
implements IActionHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ReplyNotifyHandler()
方法摘要
java.lang.String | doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context) 替换内容中的变量
boolean | execute(ExecuteContext _context, FlowAction _action)
static java.lang.String | getNotifyRootPath()
java.util.Map | getVarValues()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ReplyNotifyHandler

public ReplyNotifyHandler()
方法详细信息

getNotifyRootPath

public static java.lang.String getNotifyRootPath()
                                          throws WCMException
抛出：
WCMException

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
                throws WCMException
指定者：
接口 IActionHandler 中的 execute
抛出：
WCMException

doPageVariablesParse

public java.lang.String doPageVariablesParse(java.lang.String _sContent,
                                             ExecuteContext _context)
                                      throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_context -
返回：
抛出：
WCMException

getVarValues

public java.util.Map getVarValues()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler
的使用

没有 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler
的使用

没有 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.process.engine.handlers.AutoFillApplyFormHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.process.engine.handlers.AutoFillApplyFormHandler
的使用

没有 com.trs.components.gkml.sqgk.process.engine.handlers.AutoFillApplyFormHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler
的使用

没有 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler
的使用

没有 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


GovInfoLCListenerMetaView

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.govinfo
类 GovInfoLCListenerMetaView

java.lang.Object
    继承者  com.trs.components.govinfo.GovInfoLCListenerMetaView
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class GovInfoLCListenerMetaView
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wyw

构造方法摘要
GovInfoLCListenerMetaView()
方法摘要
void | notifyOnAddObj(BaseObj objAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj objModified, int eventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GovInfoLCListenerMetaView

public GovInfoLCListenerMetaView()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj objAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
objAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


GovInfoViewFinder

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.govinfo
类 GovInfoViewFinder

java.lang.Object
    继承者  com.trs.components.govinfo.GovInfoViewFinder

public class GovInfoViewFinder
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wyw

构造方法摘要
GovInfoViewFinder()
方法摘要
static MetaView | findMetaViewOfChildGovInfo(User _loginUser)
static MetaView | findMetaViewOfGovInfo(User _loginUser)
static boolean | isGovInfoView(MetaView oMetaView)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GovInfoViewFinder

public GovInfoViewFinder()
方法详细信息

isGovInfoView

public static boolean isGovInfoView(MetaView oMetaView)

findMetaViewOfGovInfo

public static MetaView findMetaViewOfGovInfo(User _loginUser)
                                      throws WCMException
抛出：
WCMException

findMetaViewOfChildGovInfo

public static MetaView findMetaViewOfChildGovInfo(User _loginUser)
                                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.govinfo
类
GovInfoLCListenerMetaView
GovInfoViewFinder


com.trs.components.govinfo

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.govinfo

类摘要
GovInfoLCListenerMetaView | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
GovInfoViewFinder | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn


com.trs.components.govinfo 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.govinfo 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.govinfo.GovInfoLCListenerMetaView (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.govinfo.GovInfoViewFinder


软件包 com.trs.components.govinfo 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.govinfo
的使用

没有 com.trs.components.govinfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.govinfo.GovInfoLCListenerMetaView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.govinfo.GovInfoLCListenerMetaView
的使用

没有 com.trs.components.govinfo.GovInfoLCListenerMetaView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.govinfo.GovInfoViewFinder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.govinfo.GovInfoViewFinder
的使用

没有 com.trs.components.govinfo.GovInfoViewFinder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CABFileExtractor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 CABFileExtractor

java.lang.Object
    继承者  com.trs.components.infoview.CABFileExtractor
直接已知子类：
JavaCABFileExtractor, WinCABFileExtractor
public abstract class CABFileExtractor
extends java.lang.Object

TODO Add javadoc for CABFileExtractor

作者：
Martin (Fu Chengrui)

构造方法摘要
CABFileExtractor()
TODO Add javadoc for CABFileExtractor
方法摘要
abstract java.util.HashMap | extract(java.lang.String sCABFile, java.lang.String sTargetDiretory) TODO Add javadoc for field extract
void | init(InfoViewConfig config) TODO Add javadoc for field init
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CABFileExtractor

public CABFileExtractor()
TODO Add javadoc for CABFileExtractor

方法详细信息

init

public void init(InfoViewConfig config)
TODO Add javadoc for field init

参数：
config -

extract

public abstract java.util.HashMap extract(java.lang.String sCABFile,
                                          java.lang.String sTargetDiretory)
                                   throws java.io.IOException
TODO Add javadoc for field extract

参数：
sCABFile -
sTargetDiretory -
返回：
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InfoViewConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 InfoViewConfig

java.lang.Object
    继承者  com.trs.components.infoview.InfoViewConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class InfoViewConfig
extends java.lang.Object
implements IConfigElement

构造方法摘要
InfoViewConfig()
方法摘要
EnumsConfig | getEnumsConfig()
java.lang.String | getEnumsConfigFile()
java.lang.String | getExtractProgram()
GatewayConfig | getGatewayConfig()
java.util.List | getInfoviewBindings()
java.lang.String | getInnerFilloutAction()
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getPublicPasswordField()
java.lang.String | getPublicPasswordPattern()
java.lang.String | getPublicRandomSerialPattern()
boolean | getPublicRandomSerialRequired()
java.lang.String | getPubScriptURI()
java.lang.String | getPubStyleURI()
java.lang.String | getScriptURI()
java.lang.String | getStyleURI()
boolean | isPublicPasswordRequired()
void | setEnumsConfigFile(java.lang.String _enumsConfig)
void | setExtractProgram(java.lang.String extractProgram)
void | setGatewayConfig(GatewayConfig _gatewayConfig)
void | setInnerFilloutAction(java.lang.String innerFilloutAction)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setPublicPasswordField(java.lang.String publicPasswordField)
void | setPublicPasswordPattern(java.lang.String publicPasswordPattern)
void | setPublicPasswordRequired(boolean publicPasswordRequired)
void | setPublicRandomSerialPattern(java.lang.String publicRandomSerialPattern)
void | setPublicRandomSerialRequired(boolean publicRandomSerialRequired)
void | setPubScriptURI(java.lang.String scriptURI)
void | setPubStyleURI(java.lang.String styleURI)
void | setScriptURI(java.lang.String scriptURI)
void | setStyleURI(java.lang.String styleURI)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewConfig

public InfoViewConfig()
方法详细信息

getPublicPasswordField

public java.lang.String getPublicPasswordField()

setPublicPasswordField

public void setPublicPasswordField(java.lang.String publicPasswordField)

getPublicPasswordPattern

public java.lang.String getPublicPasswordPattern()

setPublicPasswordPattern

public void setPublicPasswordPattern(java.lang.String publicPasswordPattern)

isPublicPasswordRequired

public boolean isPublicPasswordRequired()

setPublicPasswordRequired

public void setPublicPasswordRequired(boolean publicPasswordRequired)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getExtractProgram

public java.lang.String getExtractProgram()

setExtractProgram

public void setExtractProgram(java.lang.String extractProgram)

getScriptURI

public java.lang.String getScriptURI()

setScriptURI

public void setScriptURI(java.lang.String scriptURI)

getStyleURI

public java.lang.String getStyleURI()

setStyleURI

public void setStyleURI(java.lang.String styleURI)

getPubScriptURI

public java.lang.String getPubScriptURI()

setPubScriptURI

public void setPubScriptURI(java.lang.String scriptURI)

getPubStyleURI

public java.lang.String getPubStyleURI()

setPubStyleURI

public void setPubStyleURI(java.lang.String styleURI)

getInnerFilloutAction

public java.lang.String getInnerFilloutAction()

setInnerFilloutAction

public void setInnerFilloutAction(java.lang.String innerFilloutAction)

getPublicRandomSerialPattern

public java.lang.String getPublicRandomSerialPattern()

setPublicRandomSerialPattern

public void setPublicRandomSerialPattern(java.lang.String publicRandomSerialPattern)

getPublicRandomSerialRequired

public boolean getPublicRandomSerialRequired()

setPublicRandomSerialRequired

public void setPublicRandomSerialRequired(boolean publicRandomSerialRequired)

getInfoviewBindings

public java.util.List getInfoviewBindings()

getGatewayConfig

public GatewayConfig getGatewayConfig()
返回：
the gatewayConfig

setGatewayConfig

public void setGatewayConfig(GatewayConfig _gatewayConfig)
参数：
_gatewayConfig - the gatewayConfig to set

getEnumsConfigFile

public java.lang.String getEnumsConfigFile()
返回：
the enumsConfig

getEnumsConfig

public EnumsConfig getEnumsConfig()
                           throws WCMException
抛出：
WCMException

setEnumsConfigFile

public void setEnumsConfigFile(java.lang.String _enumsConfig)
                        throws WCMException
参数：
_enumsConfig - the enumsConfig to set
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 InfoViewConstants

java.lang.Object
    继承者  com.trs.components.infoview.InfoViewConstants

public class InfoViewConstants
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static InfoViewDataTypes | DB_DATA_TYPES
static InfoViewDataTypes | DEFAULT_FIELDS
static java.lang.String | FIELD_ROOTELEMENT XML文档的根节点的元素名称字段的字段名
static java.lang.String | FIELDNAME_CHANNEL_ID
static java.lang.String | FIELDNAME_INFOVIEW_ID
static java.lang.String | FIELDNAME_INFOVIEWDATA_ID
static java.lang.String | PREFIX_DBFIELD_NAME 数据库中字段前缀名 增加前缀名便于记忆、管理；避免重名
static java.lang.String | PREFIX_DBTABLE_NAME 元数据物理表前缀名 增加前缀名便于记忆、管理；避免重名
static java.lang.String[] | SYNC_FIELD_NAMES
static java.lang.String[] | SYSTEM_FIELD_NAMES
static java.util.HashMap | SYSTEM_FIELD_NAMESMAP
构造方法摘要
InfoViewConstants()
方法摘要
static java.lang.String | getIdFieldName(java.lang.String _sTableName)
static java.lang.String | makeTrueFieldName(int _nIVFieldId)
static java.lang.String | makeTrueTableName(int _nInfoViewId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SYNC_FIELD_NAMES

public static final java.lang.String[] SYNC_FIELD_NAMES

FIELDNAME_INFOVIEWDATA_ID

public static final java.lang.String FIELDNAME_INFOVIEWDATA_ID
另请参见：
常量字段值

FIELDNAME_CHANNEL_ID

public static final java.lang.String FIELDNAME_CHANNEL_ID
另请参见：
常量字段值

FIELDNAME_INFOVIEW_ID

public static final java.lang.String FIELDNAME_INFOVIEW_ID
另请参见：
常量字段值

FIELD_ROOTELEMENT

public static final java.lang.String FIELD_ROOTELEMENT
XML文档的根节点的元素名称字段的字段名

另请参见：
常量字段值

SYSTEM_FIELD_NAMES

public static final java.lang.String[] SYSTEM_FIELD_NAMES

SYSTEM_FIELD_NAMESMAP

public static final java.util.HashMap SYSTEM_FIELD_NAMESMAP

DEFAULT_FIELDS

public static final InfoViewDataTypes DEFAULT_FIELDS

PREFIX_DBTABLE_NAME

public static final java.lang.String PREFIX_DBTABLE_NAME
元数据物理表前缀名 增加前缀名便于记忆、管理；避免重名

另请参见：
常量字段值

PREFIX_DBFIELD_NAME

public static final java.lang.String PREFIX_DBFIELD_NAME
数据库中字段前缀名 增加前缀名便于记忆、管理；避免重名

另请参见：
常量字段值

DB_DATA_TYPES

public static final InfoViewDataTypes DB_DATA_TYPES
构造方法详细信息

InfoViewConstants

public InfoViewConstants()
方法详细信息

makeTrueTableName

public static java.lang.String makeTrueTableName(int _nInfoViewId)

makeTrueFieldName

public static java.lang.String makeTrueFieldName(int _nIVFieldId)

getIdFieldName

public static java.lang.String getIdFieldName(java.lang.String _sTableName)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDataHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 InfoViewDataHelper

java.lang.Object
    继承者  com.trs.components.infoview.InfoViewDataHelper

public final class InfoViewDataHelper
extends java.lang.Object

获取表单数据项的工具类

作者：
Martin (Fu Chengrui)

字段摘要
static java.lang.String KEY_DOM4J
方法摘要
static java.lang.String | buildContent(InfoView _oInfoView, Document wcmDocument, org.dom4j.Document _oDom4jDocument)
static java.lang.String | getFieldValue(Document wcmDocument, java.lang.String field)
static java.lang.String | getProperty(Document wcmDocument, java.lang.String field) 返回指定表单文档的指定数据项的值 数据项的名称，可以只包括名称部分，也可以是完整的XPATH表述
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

KEY_DOM4J

public static final java.lang.String KEY_DOM4J
另请参见：
常量字段值
方法详细信息

getProperty

public static final java.lang.String getProperty(Document wcmDocument,
                                                 java.lang.String field)
                                          throws WCMException
返回指定表单文档的指定数据项的值 数据项的名称，可以只包括名称部分，也可以是完整的XPATH表述

参数：
wcmDocument - 指定表单文档
field - 数据项的名称
返回：
数据项的值，或者null
抛出：
WCMException - 如果发生错误

getFieldValue

public static final java.lang.String getFieldValue(Document wcmDocument,
                                                   java.lang.String field)
                                            throws WCMException
抛出：
WCMException

buildContent

public static java.lang.String buildContent(InfoView _oInfoView,
                                            Document wcmDocument,
                                            org.dom4j.Document _oDom4jDocument)
                                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoviewDataProcessor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 InfoviewDataProcessor

java.lang.Object
    继承者  com.trs.components.infoview.InfoviewDataProcessor

public class InfoviewDataProcessor
extends java.lang.Object

构造方法摘要
InfoviewDataProcessor(User _currUser, java.lang.String _sAppendixFilePath)
方法摘要
 Document processInfoViewAppendix(Document _document)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoviewDataProcessor

public InfoviewDataProcessor(User _currUser,
                             java.lang.String _sAppendixFilePath)
方法详细信息

processInfoViewAppendix

public Document processInfoViewAppendix(Document _document)
                                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewEmployMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 InfoViewEmployMgr

java.lang.Object
    继承者  com.trs.components.infoview.InfoViewEmployMgr

public class InfoViewEmployMgr
extends java.lang.Object

构造方法摘要
InfoViewEmployMgr()
方法摘要
int | clearByEmployer(CMSObj _oChnlOrSite)
int | clearByEmployer(int _nEmployerType, int _nEmployerId)
int | clearByInfoView(InfoView _oInfoView)
int | clearByInfoView(int nInfoViewId)
java.util.List | getEmployedInfoViews(CMSObj _employer)
java.util.List | getEmployedInfoViews(int _iEmployerType, int _iEmployerId) TODO Add javadoc for field getEmployedInfoViews
java.util.List | getEmployedInfoViews(int _iEmployerType, int _iEmployerId, WCMFilter _filter) TODO Add javadoc for field getEmployedInfoViews
java.util.List | getInfoViewEmployers(InfoView _employed)
java.util.List | getInfoViewEmployers(int _iInfoViewID)
java.util.List | getInfoViewEmployers(int _iInfoViewID, WCMFilter _filter)
void | setEmployedInfoView(CMSObj _employer, int _iInfoViewID) TODO Add javadoc for field setEmployedInfoView
void | setEmployedInfoViews(CMSObj _employer, int[] _iInfoViewIDs) 注意： 在该函数执行后，参数数组_iInfoViewIDs的数据可能被破坏，因此如果需要，请调用该函数前备份
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewEmployMgr

public InfoViewEmployMgr()
方法详细信息

clearByInfoView

public int clearByInfoView(InfoView _oInfoView)
                    throws WCMException
抛出：
WCMException

clearByInfoView

public int clearByInfoView(int nInfoViewId)
                    throws WCMException
抛出：
WCMException

clearByEmployer

public int clearByEmployer(CMSObj _oChnlOrSite)
                    throws WCMException
抛出：
WCMException

clearByEmployer

public int clearByEmployer(int _nEmployerType,
                           int _nEmployerId)
                    throws WCMException
抛出：
WCMException

getInfoViewEmployers

public java.util.List getInfoViewEmployers(InfoView _employed)
                                    throws WCMException
抛出：
WCMException

getInfoViewEmployers

public java.util.List getInfoViewEmployers(int _iInfoViewID)
                                    throws WCMException
抛出：
WCMException

getInfoViewEmployers

public java.util.List getInfoViewEmployers(int _iInfoViewID,
                                           WCMFilter _filter)
                                    throws WCMException
抛出：
WCMException

getEmployedInfoViews

public java.util.List getEmployedInfoViews(CMSObj _employer)
                                    throws WCMException
抛出：
WCMException

getEmployedInfoViews

public java.util.List getEmployedInfoViews(int _iEmployerType,
                                           int _iEmployerId)
                                    throws WCMException
TODO Add javadoc for field getEmployedInfoViews

参数：
_iEmployerType -
_iEmployerId -
返回：
抛出：
WCMException

getEmployedInfoViews

public java.util.List getEmployedInfoViews(int _iEmployerType,
                                           int _iEmployerId,
                                           WCMFilter _filter)
                                    throws WCMException
TODO Add javadoc for field getEmployedInfoViews

参数：
_iEmployerType -
_iEmployerId -
_filter -
返回：
抛出：
WCMException

setEmployedInfoView

public void setEmployedInfoView(CMSObj _employer,
                                int _iInfoViewID)
                         throws WCMException
TODO Add javadoc for field setEmployedInfoView

参数：
_employer -
_iInfoViewID -
抛出：
WCMException

setEmployedInfoViews

public void setEmployedInfoViews(CMSObj _employer,
                                 int[] _iInfoViewIDs)
                          throws WCMException
注意： 在该函数执行后，参数数组_iInfoViewIDs的数据可能被破坏，因此如果需要，请调用该函数前备份

参数：
_employer -
_iInfoViewIDs -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 InfoViewHelper

java.lang.Object
    继承者  com.trs.components.infoview.InfoViewHelper

public class InfoViewHelper
extends java.lang.Object

InfoView的工具类，定义了一些全局的静态方法

作者：
Martin (Fu Chengrui)

方法摘要
static void | buildComplexFields(java.util.List _datas, int _nInfoviewDataId) 新建复合表单字段所对应的数据纪录
static void | buildComplexFields(java.util.List _datas, int _nInfoviewDataId, boolean _bIsRestore) 建立复合表单字段所对应的数据纪录
static org.dom4j.Document | buildDOM4JDocument(java.lang.String sFilePath) 构造指定XML文件的DOM4J的Document对象
static void | clearComplexFieldDatas(int _nInfoviewDataId) 清除指定表单纪录所属的所有复合表单字段记录
static java.lang.String | getDBFieldByField(int _nInfoViewId, java.lang.String sInfoPathField, boolean bAppendTable)
static java.lang.String[] | getDBFieldsByFields(InfoView oInfoView, java.lang.String[] arrInfoPathFields, boolean bAppendTable)
static java.lang.String | getDBFieldsByFields(InfoView oInfoView, java.lang.String sInfoPathFields, boolean bAppendTable) 获取InfoPath字段名对应的数据库字段名
static InfoView | getInfoView(Channel _oChannel)
static InfoViewEmployMgr | getInfoViewEmployMgr()
static java.lang.String | infoPathToFieldName(java.lang.String infoPathField)
static boolean | isInfoViewDefaultField(java.lang.String fieldName)
static boolean | isSystemField(java.lang.String fieldName)
static ComplexFieldData | makeComplexFieldData(java.lang.String _sFieldId, java.lang.String _sFieldName, java.lang.String _sVal, java.lang.String _sParentFlag, InfoViewData _docData)
static java.lang.StringBuffer | parse2Json(java.lang.Object object) 转换Object对象为Json对象,目前只支持List,Map和String三类,其余统一使用toString转换成String
static org.dom4j.Document | parseToDocument(java.lang.String sXmlContent)
static void | restoreComplexFields(java.util.List _datas, int _nInfoviewDataId) 重建立复合表单字段所对应的数据纪录
static java.lang.String[] | splitSelectFields(java.lang.String sOutlineDBFields, java.lang.String sTrueTableName)
static void | writeDOM4JDocument(org.dom4j.Document document, java.lang.String sFilePath)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

buildDOM4JDocument

public static org.dom4j.Document buildDOM4JDocument(java.lang.String sFilePath)
                                             throws WCMException
构造指定XML文件的DOM4J的Document对象

参数：
sFilePath - 文件的全限定文件名
返回：
指定XML文件DOM4J的Document
抛出：
WCMException - 如果发生IO异常，或者DOM4J定义的异常

parseToDocument

public static org.dom4j.Document parseToDocument(java.lang.String sXmlContent)
                                          throws WCMException
抛出：
WCMException

writeDOM4JDocument

public static void writeDOM4JDocument(org.dom4j.Document document,
                                      java.lang.String sFilePath)
                               throws WCMException
抛出：
WCMException

parse2Json

public static java.lang.StringBuffer parse2Json(java.lang.Object object)
转换Object对象为Json对象,目前只支持List,Map和String三类,其余统一使用toString转换成String

参数：
object -
返回：
抛出：
java.lang.Exception

getDBFieldsByFields

public static java.lang.String getDBFieldsByFields(InfoView oInfoView,
                                                   java.lang.String sInfoPathFields,
                                                   boolean bAppendTable)
获取InfoPath字段名对应的数据库字段名

参数：
sInfoPathFields -
返回：

getDBFieldsByFields

public static java.lang.String[] getDBFieldsByFields(InfoView oInfoView,
                                                     java.lang.String[] arrInfoPathFields,
                                                     boolean bAppendTable)

getDBFieldByField

public static java.lang.String getDBFieldByField(int _nInfoViewId,
                                                 java.lang.String sInfoPathField,
                                                 boolean bAppendTable)

infoPathToFieldName

public static java.lang.String infoPathToFieldName(java.lang.String infoPathField)

isSystemField

public static boolean isSystemField(java.lang.String fieldName)

isInfoViewDefaultField

public static boolean isInfoViewDefaultField(java.lang.String fieldName)

getInfoViewEmployMgr

public static InfoViewEmployMgr getInfoViewEmployMgr()

getInfoView

public static InfoView getInfoView(Channel _oChannel)
                            throws WCMException
抛出：
WCMException

splitSelectFields

public static java.lang.String[] splitSelectFields(java.lang.String sOutlineDBFields,
                                                   java.lang.String sTrueTableName)
                                            throws WCMException
抛出：
WCMException

makeComplexFieldData

public static ComplexFieldData makeComplexFieldData(java.lang.String _sFieldId,
                                                    java.lang.String _sFieldName,
                                                    java.lang.String _sVal,
                                                    java.lang.String _sParentFlag,
                                                    InfoViewData _docData)

restoreComplexFields

public static void restoreComplexFields(java.util.List _datas,
                                        int _nInfoviewDataId)
                                 throws WCMException
重建立复合表单字段所对应的数据纪录

抛出：
WCMException

buildComplexFields

public static void buildComplexFields(java.util.List _datas,
                                      int _nInfoviewDataId)
                               throws WCMException
新建复合表单字段所对应的数据纪录

抛出：
WCMException

buildComplexFields

public static void buildComplexFields(java.util.List _datas,
                                      int _nInfoviewDataId,
                                      boolean _bIsRestore)
                               throws WCMException
建立复合表单字段所对应的数据纪录

参数：
_datas - 建立复合表单字段所需的ComplexFieldDatas对象
_nInfoviewDataId - 表单纪录的Id标识
_bIsRestore - 是否是重建操作
抛出：
WCMException - 检索、移除、或保存对象时出错

clearComplexFieldDatas

public static void clearComplexFieldDatas(int _nInfoviewDataId)
                                   throws WCMException
清除指定表单纪录所属的所有复合表单字段记录

参数：
_nInfoviewDataId - 表单纪录的Id标识
抛出：
WCMException - 检索或者移除对象时出错
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 InfoViewMgr

java.lang.Object
    继承者  com.trs.components.infoview.InfoViewMgr

public class InfoViewMgr
extends java.lang.Object

字段摘要
static float | INCREASE_FIELD_LENGTH_FACTOR
static java.lang.String | NS_XSL_URI
static java.lang.String | PUBLISH_SCRIPT_PATH 表单发布后，所依赖的JavaScript文件和图片在根的images下的子目录名
构造方法摘要
InfoViewMgr()
方法摘要
java.lang.String | appendJsAndCsses(java.lang.String html)
void | delete(InfoView _oInfoView)
void | delete(InfoViewField _oField)
void | delete(InfoViewGroup _oGroup)
void | delete(InfoViewView _oView)
InfoViewViews | filterByFlow(InfoViewViews _oInfoViewViews, int nFlowDocId) 通过工作流过滤可查看的表单视图
java.lang.String | filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int _nFlowDocId) 在工作流转中过滤文档中的不可读字段
java.lang.String | forFillOut(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int _nFlowDocId) 工作流转中xsl转化成html的过程
java.lang.String | forFillOutInner(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | forInfoGate(InfoView _oInfoView, FormProperty _oProperty)
java.lang.String | forMultiView(InfoView _oInfoView, InfoViewView _oPubView, java.util.List fileList)
java.lang.String | forPreview(InfoView _oInfoView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | forPreviewMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | forPublish(InfoView _oInfoView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | forPublishMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | getAbsolutePath(InfoView _oInfoView, java.lang.String sFileName)
java.lang.String | getDocumentTitle(InfoView _oInfoView, org.dom4j.Document _dom4jDocument)
java.lang.String | getDocumentTitle(InfoView _oInfoView, org.dom4j.Document _dom4jDocument, java.lang.String _sPostUserName)
java.lang.String | getDocumentTitleForUserName(InfoView _oInfoView, org.dom4j.Document _dom4jDocument, java.lang.String _sPostUserName)
static java.lang.String | getFileContent(java.lang.String file)
InfoViewConfig | getInfoViewConfig()
InfoViews | getInfoViews(WCMFilter _filter)
java.lang.String | getInfoViewSerial(InfoView _oInfoView)
java.lang.String | getInfoViewSerial(int _iInfoViewId)
java.lang.String[] | getPublicPassword() 获取表单文档外部查询随机密码
java.lang.String | getRandomSerial()
java.lang.String | getTemplateFileContent(InfoView _oInfoView)
java.lang.String | initTemplateInFlow(InfoView _oInfoView, int _nFlowDocId) 在工作流转中初始化表单的模板数据
void | rebuildXSLT(InfoView _oInfoView)
void | rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)
void | rebuildXSLTByGroups(InfoView _oInfoView, java.util.List _lstGroups)
void | save(InfoView _oInfoView)
void | save(InfoViewField _oField)
void | save(InfoViewGroup _oGroup)
void | save(InfoViewView _oView)
void | saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)
void | setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadOnly)
static java.util.Map | split2AttrMap(java.lang.String _sAttrStr)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PUBLISH_SCRIPT_PATH

public static final java.lang.String PUBLISH_SCRIPT_PATH
表单发布后，所依赖的JavaScript文件和图片在根的images下的子目录名

另请参见：
常量字段值

NS_XSL_URI

public static final java.lang.String NS_XSL_URI
另请参见：
常量字段值

INCREASE_FIELD_LENGTH_FACTOR

public static final float INCREASE_FIELD_LENGTH_FACTOR
另请参见：
常量字段值
构造方法详细信息

InfoViewMgr

public InfoViewMgr()
方法详细信息

getFileContent

public static final java.lang.String getFileContent(java.lang.String file)
                                             throws java.io.IOException
抛出：
java.io.IOException

getInfoViewConfig

public InfoViewConfig getInfoViewConfig()

delete

public void delete(InfoView _oInfoView)
            throws WCMException
抛出：
WCMException

delete

public void delete(InfoViewView _oView)
            throws WCMException
抛出：
WCMException

delete

public void delete(InfoViewGroup _oGroup)
            throws WCMException
抛出：
WCMException

delete

public void delete(InfoViewField _oField)
            throws WCMException
抛出：
WCMException

getInfoViews

public InfoViews getInfoViews(WCMFilter _filter)
                       throws WCMException
抛出：
WCMException

filterByFlow

public InfoViewViews filterByFlow(InfoViewViews _oInfoViewViews,
                                  int nFlowDocId)
                           throws java.lang.Throwable
通过工作流过滤可查看的表单视图

参数：
_oInfoViewViews -
nFlowDocId -
返回：
抛出：
java.lang.Throwable

getAbsolutePath

public java.lang.String getAbsolutePath(InfoView _oInfoView,
                                        java.lang.String sFileName)
                                 throws WCMException
抛出：
WCMException

forFillOut

public java.lang.String forFillOut(InfoView _oInfoView,
                                   InfoViewView _oView)
                            throws WCMException
为了在WCM内部填写表单而生成HTML页面

参数：
_oInfoView - 指定的表单
_oView - 指定的视图
返回：
生成HTML页面的内容
抛出：
WCMException - 如果发生错误

forFillOutInner

public java.lang.String forFillOutInner(InfoView _oInfoView,
                                        InfoViewView _oView)
                                 throws WCMException
为了在WCM内部填写表单而生成HTML页面

参数：
_oInfoView - 指定的表单
_oView - 指定的视图
返回：
生成HTML页面的内容
抛出：
WCMException - 如果发生错误

forFillOutInner

public java.lang.String forFillOutInner(InfoView _oInfoView,
                                        InfoViewView _oView,
                                        boolean _bNewDocInFlow)
                                 throws WCMException
为了在WCM内部填写表单而生成HTML页面

参数：
_oInfoView - 指定的表单
_oView - 指定的视图
_bNewDocInFlow - 否在配置了工作流的栏目中新建文档
返回：
生成HTML页面的内容
抛出：
WCMException - 如果发生错误

forFillOutInFlow

public java.lang.String forFillOutInFlow(InfoView _oInfoView,
                                         InfoViewView _oView,
                                         int _nFlowDocId)
                                  throws WCMException,
                                         java.lang.Throwable
工作流转中xsl转化成html的过程

参数：
_oInfoView -
_oView -
_nFlowDocId -
返回：
抛出：
WCMException
java.lang.Throwable

filterContentInFlow

public java.lang.String filterContentInFlow(InfoView _oInfoView,
                                            java.lang.String _sXmlContent,
                                            int _nFlowDocId)
                                     throws WCMException,
                                            java.lang.Throwable
在工作流转中过滤文档中的不可读字段

参数：
_oInfoView -
_sXmlContent -
_nFlowDocId -
返回：
抛出：
WCMException
java.lang.Throwable

initTemplateInFlow

public java.lang.String initTemplateInFlow(InfoView _oInfoView,
                                           int _nFlowDocId)
                                    throws WCMException,
                                           java.lang.Throwable
在工作流转中初始化表单的模板数据

参数：
_oInfoView -
_sXmlContent -
_nFlowDocId -
返回：
抛出：
WCMException
java.lang.Throwable

save

public void save(InfoView _oInfoView)
          throws WCMException
抛出：
WCMException

save

public void save(InfoViewView _oView)
          throws WCMException
抛出：
WCMException

save

public void save(InfoViewGroup _oGroup)
          throws WCMException
抛出：
WCMException

save

public void save(InfoViewField _oField)
          throws WCMException
抛出：
WCMException

setFieldsReadOnly

public void setFieldsReadOnly(InfoView _oInfoView,
                              InfoViewFields _oInfoViewFields,
                              boolean _bReadOnly)
                       throws WCMException
抛出：
WCMException

saveViewByFields

public void saveViewByFields(InfoView _oInfoView,
                             java.util.List _lstFields)
                      throws WCMException
抛出：
WCMException

rebuildXSLT

public void rebuildXSLT(InfoView _oInfoView)
                 throws WCMException
抛出：
WCMException

rebuildXSLTByGroups

public void rebuildXSLTByGroups(InfoView _oInfoView,
                                java.util.List _lstGroups)
                         throws WCMException
抛出：
WCMException

rebuildXSLTByFields

public void rebuildXSLTByFields(InfoView _oInfoView,
                                java.util.List _lstFields)
                         throws WCMException
抛出：
WCMException

forPreviewMultiView

public java.lang.String forPreviewMultiView(InfoView _oInfoView,
                                            InfoViewView _oPubView,
                                            FormProperty _oProperty,
                                            java.util.List fileList)
                                     throws WCMException
抛出：
WCMException

forPreview

public java.lang.String forPreview(InfoView _oInfoView,
                                   FormProperty _oProperty,
                                   java.util.List fileList)
                            throws WCMException
抛出：
WCMException

split2AttrMap

public static java.util.Map split2AttrMap(java.lang.String _sAttrStr)

appendJsAndCsses

public java.lang.String appendJsAndCsses(java.lang.String html)

forInfoGate

public java.lang.String forInfoGate(InfoView _oInfoView,
                                    FormProperty _oProperty)
                             throws WCMException
抛出：
WCMException

forPublishMultiView

public java.lang.String forPublishMultiView(InfoView _oInfoView,
                                            InfoViewView _oPubView,
                                            FormProperty _oProperty,
                                            java.util.List fileList)
                                     throws WCMException
抛出：
WCMException

forMultiView

public java.lang.String forMultiView(InfoView _oInfoView,
                                     InfoViewView _oPubView,
                                     java.util.List fileList)
                              throws WCMException
抛出：
WCMException

forPublish

public java.lang.String forPublish(InfoView _oInfoView,
                                   FormProperty _oProperty,
                                   java.util.List fileList)
                            throws WCMException
抛出：
WCMException

getInfoViewSerial

public java.lang.String getInfoViewSerial(int _iInfoViewId)
                                   throws WCMException
抛出：
WCMException

getInfoViewSerial

public java.lang.String getInfoViewSerial(InfoView _oInfoView)
                                   throws WCMException
抛出：
WCMException

getTemplateFileContent

public java.lang.String getTemplateFileContent(InfoView _oInfoView)
                                        throws WCMException
抛出：
WCMException

getDocumentTitle

public java.lang.String getDocumentTitle(InfoView _oInfoView,
                                         org.dom4j.Document _dom4jDocument)
                                  throws WCMException
抛出：
WCMException

getDocumentTitle

public java.lang.String getDocumentTitle(InfoView _oInfoView,
                                         org.dom4j.Document _dom4jDocument,
                                         java.lang.String _sPostUserName)
                                  throws WCMException
抛出：
WCMException

getDocumentTitleForUserName

public java.lang.String getDocumentTitleForUserName(InfoView _oInfoView,
                                                    org.dom4j.Document _dom4jDocument,
                                                    java.lang.String _sPostUserName)
                                             throws WCMException
抛出：
WCMException

getRandomSerial

public java.lang.String getRandomSerial()

getPublicPassword

public java.lang.String[] getPublicPassword()
获取表单文档外部查询随机密码

返回：
如果需要生成查询密码,则返回密码对应的属性字段及相应的密码.如([docpassword,JA-12345678]) 否则返回长度为0的数组
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewReplyNoticeSender

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 InfoViewReplyNoticeSender

java.lang.Object
    继承者  com.trs.components.infoview.InfoViewReplyNoticeSender

public class InfoViewReplyNoticeSender
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
表单文档回复通知发送者
如果需要发送邮件,setSendEmail(true);
如果需要发送系统短消息,setSendMessage(true) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoViewReplyNoticeSender(InfoView _oInfoView, Document _oDocument, DocReply _oInfoViewReply)
方法摘要
boolean | isSendEmail()
boolean | isSendMessage()
static void | main(java.lang.String[] args)
void | sendNotice()
void | setSendEmail(boolean sendEmail)
void | setSendMessage(boolean sendMessage)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewReplyNoticeSender

public InfoViewReplyNoticeSender(InfoView _oInfoView,
                                 Document _oDocument,
                                 DocReply _oInfoViewReply)
                          throws WCMException
抛出：
WCMException
方法详细信息

sendNotice

public void sendNotice()
                throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)

isSendEmail

public final boolean isSendEmail()

setSendEmail

public final void setSendEmail(boolean sendEmail)

isSendMessage

public final boolean isSendMessage()

setSendMessage

public final void setSendMessage(boolean sendMessage)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview
类
CABFileExtractor
InfoViewConfig
InfoViewConstants
InfoViewDataHelper
InfoviewDataProcessor
InfoViewEmployMgr
InfoViewHelper
InfoViewMgr
InfoViewReplyNoticeSender
RightHostInfoViewField
RightHostInfoViewGroup
RightHostInfoViewView


com.trs.components.infoview

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview

结合 MS InfoPath 实现自定义表单。

请参见：
描述

类摘要
CABFileExtractor | TODO Add javadoc for CABFileExtractor
InfoViewConfig |
InfoViewConstants | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDataHelper | 获取表单数据项的工具类
InfoviewDataProcessor |
InfoViewEmployMgr |
InfoViewHelper | InfoView的工具类，定义了一些全局的静态方法
InfoViewMgr |
InfoViewReplyNoticeSender | Title: TRS 内容协作平台（TRS WCM） Description: 表单文档回复通知发送者 如果需要发送邮件,setSendEmail(true); 如果需要发送系统短消息,setSendMessage(true) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostInfoViewField |
RightHostInfoViewGroup |
RightHostInfoViewView |

软件包 com.trs.components.infoview 的描述

结合 MS InfoPath 实现自定义表单。


com.trs.components.infoview 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.infoview.CABFileExtractor
    • com.trs.components.infoview.InfoViewConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.infoview.InfoViewConstants
    • com.trs.components.infoview.InfoViewDataHelper
    • com.trs.components.infoview.InfoviewDataProcessor
    • com.trs.components.infoview.InfoViewEmployMgr
    • com.trs.components.infoview.InfoViewHelper
    • com.trs.components.infoview.InfoViewMgr
    • com.trs.components.infoview.InfoViewReplyNoticeSender
    • com.trs.components.infoview.RightHostInfoViewField (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.components.infoview.RightHostInfoViewGroup (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.components.infoview.RightHostInfoViewView (implements com.trs.cms.auth.domain.IRightHost)


软件包 com.trs.components.infoview 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview
的使用

使用 com.trs.components.infoview 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。
com.trs.components.infoview.helper |

com.trs.components.infoview 使用的 com.trs.components.infoview 中的类
InfoViewConfig
InfoViewEmployMgr

com.trs.components.infoview.extract 使用的 com.trs.components.infoview 中的类
CABFileExtractor
TODO Add javadoc for CABFileExtractor
InfoViewConfig

com.trs.components.infoview.helper 使用的 com.trs.components.infoview 中的类
InfoViewEmployMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RightHostInfoViewField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 RightHostInfoViewField

java.lang.Object
    继承者  com.trs.components.infoview.RightHostInfoViewField
所有已实现的接口：
IRightHost, ICMSObjSubstanceContent
public class RightHostInfoViewField
extends java.lang.Object
implements IRightHost

构造方法摘要
RightHostInfoViewField()
RightHostInfoViewField(InfoViewField _oField)
方法摘要
boolean | canDoSetRight(User _user)
IRightHost[] | getChildren() 获取当前对象的一级子对象
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
IRightHost | getParent() 获取父对象
java.lang.String[] | getRightTypeIds() 获取可以在这类对象上支持的权限类别Id
java.lang.String[] | getRightTypeNames() 获取可以在这类对象上支持的权限类别名称
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoSetRight(User _user) 判断指定的用户是否有权给当前对象设置权限
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightHostInfoViewField

public RightHostInfoViewField()

RightHostInfoViewField

public RightHostInfoViewField(InfoViewField _oField)
方法详细信息

canDoSetRight

public boolean canDoSetRight(User _user)
                      throws WCMException
抛出：
WCMException

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

getChildren

public IRightHost[] getChildren()
                         throws WCMException
从接口 IRightHost 复制的描述
获取当前对象的一级子对象

指定者：
接口 IRightHost 中的 getChildren
返回：
抛出：
WCMException

getParent

public IRightHost getParent()
                     throws WCMException
从接口 IRightHost 复制的描述
获取父对象

指定者：
接口 IRightHost 中的 getParent
返回：
抛出：
WCMException

getRightTypeIds

public java.lang.String[] getRightTypeIds()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别Id

指定者：
接口 IRightHost 中的 getRightTypeIds
返回：

getRightTypeNames

public java.lang.String[] getRightTypeNames()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别名称

指定者：
接口 IRightHost 中的 getRightTypeNames
返回：

validateCanDoSetRight

public void validateCanDoSetRight(User _user)
                           throws WCMException
从接口 IRightHost 复制的描述
判断指定的用户是否有权给当前对象设置权限

指定者：
接口 IRightHost 中的 validateCanDoSetRight
参数：
_user - 指定的User
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightHostInfoViewGroup

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 RightHostInfoViewGroup

java.lang.Object
    继承者  com.trs.components.infoview.RightHostInfoViewGroup
所有已实现的接口：
IRightHost, ICMSObjSubstanceContent
public class RightHostInfoViewGroup
extends java.lang.Object
implements IRightHost

构造方法摘要
RightHostInfoViewGroup()
RightHostInfoViewGroup(InfoViewGroup _group)
方法摘要
boolean | canDoSetRight(User _user)
IRightHost[] | getChildren() 获取当前对象的一级子对象
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
IRightHost | getParent() 获取父对象
java.lang.String[] | getRightTypeIds() 获取可以在这类对象上支持的权限类别Id
java.lang.String[] | getRightTypeNames() 获取可以在这类对象上支持的权限类别名称
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoSetRight(User _user) 判断指定的用户是否有权给当前对象设置权限
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightHostInfoViewGroup

public RightHostInfoViewGroup()

RightHostInfoViewGroup

public RightHostInfoViewGroup(InfoViewGroup _group)
方法详细信息

canDoSetRight

public boolean canDoSetRight(User _user)
                      throws WCMException
抛出：
WCMException

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

getChildren

public IRightHost[] getChildren()
                         throws WCMException
从接口 IRightHost 复制的描述
获取当前对象的一级子对象

指定者：
接口 IRightHost 中的 getChildren
返回：
抛出：
WCMException

getParent

public IRightHost getParent()
                     throws WCMException
从接口 IRightHost 复制的描述
获取父对象

指定者：
接口 IRightHost 中的 getParent
返回：
抛出：
WCMException

getRightTypeIds

public java.lang.String[] getRightTypeIds()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别Id

指定者：
接口 IRightHost 中的 getRightTypeIds
返回：

getRightTypeNames

public java.lang.String[] getRightTypeNames()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别名称

指定者：
接口 IRightHost 中的 getRightTypeNames
返回：

validateCanDoSetRight

public void validateCanDoSetRight(User _user)
                           throws WCMException
从接口 IRightHost 复制的描述
判断指定的用户是否有权给当前对象设置权限

指定者：
接口 IRightHost 中的 validateCanDoSetRight
参数：
_user - 指定的User
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightHostInfoViewView

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview
类 RightHostInfoViewView

java.lang.Object
    继承者  com.trs.components.infoview.RightHostInfoViewView
所有已实现的接口：
IRightHost, ICMSObjSubstanceContent
public class RightHostInfoViewView
extends java.lang.Object
implements IRightHost

构造方法摘要
RightHostInfoViewView()
RightHostInfoViewView(InfoViewView _view)
方法摘要
boolean | canDoSetRight(User _user)
IRightHost[] | getChildren() 获取当前对象的一级子对象
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
IRightHost | getParent() 获取父对象
java.lang.String[] | getRightTypeIds() 获取可以在这类对象上支持的权限类别Id
java.lang.String[] | getRightTypeNames() 获取可以在这类对象上支持的权限类别名称
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoSetRight(User _user) 判断指定的用户是否有权给当前对象设置权限
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightHostInfoViewView

public RightHostInfoViewView()

RightHostInfoViewView

public RightHostInfoViewView(InfoViewView _view)
方法详细信息

canDoSetRight

public boolean canDoSetRight(User _user)
                      throws WCMException
抛出：
WCMException

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

getChildren

public IRightHost[] getChildren()
                         throws WCMException
从接口 IRightHost 复制的描述
获取当前对象的一级子对象

指定者：
接口 IRightHost 中的 getChildren
返回：
抛出：
WCMException

getParent

public IRightHost getParent()
                     throws WCMException
从接口 IRightHost 复制的描述
获取父对象

指定者：
接口 IRightHost 中的 getParent
返回：
抛出：
WCMException

getRightTypeIds

public java.lang.String[] getRightTypeIds()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别Id

指定者：
接口 IRightHost 中的 getRightTypeIds
返回：

getRightTypeNames

public java.lang.String[] getRightTypeNames()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别名称

指定者：
接口 IRightHost 中的 getRightTypeNames
返回：

validateCanDoSetRight

public void validateCanDoSetRight(User _user)
                           throws WCMException
从接口 IRightHost 复制的描述
判断指定的用户是否有权给当前对象设置权限

指定者：
接口 IRightHost 中的 validateCanDoSetRight
参数：
_user - 指定的User
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.infoview.CABFileExtractor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.CABFileExtractor
的使用

使用 CABFileExtractor 的软件包
com.trs.components.infoview.extract 抽取 MS InfoPath 的 XSN 文件的内容。

com.trs.components.infoview.extract 中 CABFileExtractor 的使用

com.trs.components.infoview.extract 中 CABFileExtractor 的子类
class | JavaCABFileExtractor
class | WinCABFileExtractor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.InfoViewConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.InfoViewConfig
的使用

使用 InfoViewConfig 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。

com.trs.components.infoview 中 InfoViewConfig 的使用

返回 InfoViewConfig 的 com.trs.components.infoview 中的方法
 InfoViewConfig InfoViewMgr.getInfoViewConfig()

参数类型为 InfoViewConfig 的 com.trs.components.infoview 中的方法
 void CABFileExtractor.init(InfoViewConfig config)
TODO Add javadoc for field init

com.trs.components.infoview.extract 中 InfoViewConfig 的使用

参数类型为 InfoViewConfig 的 com.trs.components.infoview.extract 中的方法
void | InfoPathFileData.build(java.lang.String diretory, java.util.HashMap mapFiles, InfoViewConfig ivConfig)
void | XSLTViewBuilder.init(InfoViewConfig ivConfig, Manifest manifest, java.util.List groupList, DataType rootType, java.util.List typeList)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.InfoViewConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.InfoViewConstants
的使用

没有 com.trs.components.infoview.InfoViewConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.InfoViewDataHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.InfoViewDataHelper
的使用

没有 com.trs.components.infoview.InfoViewDataHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.InfoviewDataProcessor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.InfoviewDataProcessor
的使用

没有 com.trs.components.infoview.InfoviewDataProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.InfoViewEmployMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.InfoViewEmployMgr
的使用

使用 InfoViewEmployMgr 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.helper |

com.trs.components.infoview 中 InfoViewEmployMgr 的使用

返回 InfoViewEmployMgr 的 com.trs.components.infoview 中的方法
static InfoViewEmployMgr InfoViewHelper.getInfoViewEmployMgr()

com.trs.components.infoview.helper 中 InfoViewEmployMgr 的使用

返回 InfoViewEmployMgr 的 com.trs.components.infoview.helper 中的方法
static InfoViewEmployMgr InfoViewNewQueryHelper.getInfoViewEmployMgr()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.InfoViewHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.InfoViewHelper
的使用

没有 com.trs.components.infoview.InfoViewHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.InfoViewMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.InfoViewMgr
的使用

没有 com.trs.components.infoview.InfoViewMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.InfoViewReplyNoticeSender 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.InfoViewReplyNoticeSender
的使用

没有 com.trs.components.infoview.InfoViewReplyNoticeSender 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.RightHostInfoViewField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.RightHostInfoViewField
的使用

没有 com.trs.components.infoview.RightHostInfoViewField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.RightHostInfoViewGroup 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.RightHostInfoViewGroup
的使用

没有 com.trs.components.infoview.RightHostInfoViewGroup 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.RightHostInfoViewView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.RightHostInfoViewView
的使用

没有 com.trs.components.infoview.RightHostInfoViewView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BindingBean

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.config
类 BindingBean

java.lang.Object
    继承者  com.trs.components.infoview.config.BindingBean

public class BindingBean
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
BindingBean()
方法摘要
java.lang.String | getClassname()
java.lang.String | getDataType()
java.lang.String | getDesc()
java.lang.String | getFormat()
java.lang.String | getName()
void | setClassname(java.lang.String _classname)
void | setDataType(java.lang.String dataType)
void | setDesc(java.lang.String _desc)
void | setFormat(java.lang.String _format)
void | setName(java.lang.String _name)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BindingBean

public BindingBean()
方法详细信息

getDesc

public java.lang.String getDesc()
返回：
the desc

setDesc

public void setDesc(java.lang.String _desc)
参数：
_desc - the desc to set

getFormat

public java.lang.String getFormat()
返回：
the format

setFormat

public void setFormat(java.lang.String _format)
参数：
_format - the format to set

getName

public java.lang.String getName()
返回：
the name

setName

public void setName(java.lang.String _name)
参数：
_name - the name to set

setClassname

public void setClassname(java.lang.String _classname)
参数：
_className - the className to set

getClassname

public java.lang.String getClassname()
返回：
the classname

getDataType

public java.lang.String getDataType()

setDataType

public void setDataType(java.lang.String dataType)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


EnumCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.config
类 EnumCreator

java.lang.Object
    继承者  com.trs.components.infoview.config.EnumCreator

public class EnumCreator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
EnumCreator()
方法摘要
java.lang.String | getCacheKey()
int | getInfoViewId()
java.lang.String | getKey()
java.lang.String | getSplitBy()
java.lang.String | getTemplateContent()
java.lang.String | getValueSplitBy()
void | setInfoViewId(int _infoView)
void | setKey(java.lang.String _key)
void | setSplitBy(java.lang.String _splitBy)
void | setTemplateContent(java.lang.String _templateContent)
void | setValueSplitBy(java.lang.String _valueSplitBy)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EnumCreator

public EnumCreator()
方法详细信息

getInfoViewId

public int getInfoViewId()
返回：
the infoView

setInfoViewId

public void setInfoViewId(int _infoView)
参数：
_infoView - the infoView to set

getKey

public java.lang.String getKey()
返回：
the key

getCacheKey

public java.lang.String getCacheKey()

setKey

public void setKey(java.lang.String _key)
参数：
_key - the key to set

getSplitBy

public java.lang.String getSplitBy()
返回：
the splitBy

setSplitBy

public void setSplitBy(java.lang.String _splitBy)
参数：
_splitBy - the splitBy to set

getTemplateContent

public java.lang.String getTemplateContent()
返回：
the templateContent

setTemplateContent

public void setTemplateContent(java.lang.String _templateContent)
参数：
_templateContent - the templateContent to set

getValueSplitBy

public java.lang.String getValueSplitBy()
返回：
the valueSplitBy

setValueSplitBy

public void setValueSplitBy(java.lang.String _valueSplitBy)
参数：
_valueSplitBy - the valueSplitBy to set
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EnumsConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.config
类 EnumsConfig

java.lang.Object
    继承者  com.trs.components.infoview.config.EnumsConfig

public class EnumsConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

字段摘要
static int | ENUM_TYPE_LINKED
static int | ENUM_TYPE_NORMAL
方法摘要
void | addEnumItem(int nInfoViewId, java.lang.String sKey, java.lang.Object oValue, int nType)
static EnumsConfig | build(java.lang.String _sFileName)
EnumCreator | getEnumCreator(int nInfoViewId, java.lang.String sKey)
EnumCreator[] | getEnumCreators(int nInfoViewId)
LinkedEnumCreator | getLinkedEnums(int nInfoViewId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ENUM_TYPE_NORMAL

public static final int ENUM_TYPE_NORMAL
另请参见：
常量字段值

ENUM_TYPE_LINKED

public static final int ENUM_TYPE_LINKED
另请参见：
常量字段值
方法详细信息

build

public static EnumsConfig build(java.lang.String _sFileName)

addEnumItem

public void addEnumItem(int nInfoViewId,
                        java.lang.String sKey,
                        java.lang.Object oValue,
                        int nType)

getEnumCreators

public EnumCreator[] getEnumCreators(int nInfoViewId)

getEnumCreator

public EnumCreator getEnumCreator(int nInfoViewId,
                                  java.lang.String sKey)

getLinkedEnums

public LinkedEnumCreator getLinkedEnums(int nInfoViewId)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GatewayConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.config
类 GatewayConfig

java.lang.Object
    继承者  com.trs.components.infoview.config.GatewayConfig

public class GatewayConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

字段摘要
static java.lang.String ROOT_MARK
构造方法摘要
GatewayConfig()
方法摘要
java.util.List | getGatewayBindings()
java.util.Map | getGatewayPageProperties()
java.util.List | getGatewayPages()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ROOT_MARK

public static final java.lang.String ROOT_MARK
另请参见：
常量字段值
构造方法详细信息

GatewayConfig

public GatewayConfig()
方法详细信息

getGatewayBindings

public java.util.List getGatewayBindings()

getGatewayPages

public java.util.List getGatewayPages()

getGatewayPageProperties

public java.util.Map getGatewayPageProperties()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GatewayPage

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.config
类 GatewayPage

java.lang.Object
    继承者  com.trs.components.infoview.config.GatewayPage

public class GatewayPage
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2007-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gong.fuchang)

构造方法摘要
GatewayPage()
方法摘要
java.lang.String | getDesc()
java.lang.String | getName()
java.lang.String | getUrl()
void | setDesc(java.lang.String _desc)
void | setName(java.lang.String _name)
void | setUrl(java.lang.String url)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GatewayPage

public GatewayPage()
方法详细信息

getDesc

public java.lang.String getDesc()
返回：
the desc

setDesc

public void setDesc(java.lang.String _desc)
参数：
_desc - the desc to set

getName

public java.lang.String getName()
返回：
the name

setName

public void setName(java.lang.String _name)
参数：
_name - the name to set

getUrl

public java.lang.String getUrl()

setUrl

public void setUrl(java.lang.String url)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewEnumHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.config
类 InfoViewEnumHelper

java.lang.Object
    继承者  com.trs.components.infoview.config.InfoViewEnumHelper

public class InfoViewEnumHelper
extends java.lang.Object

InfoView 下拉框,级联菜单相关的工具类，定义了一些全局的静态方法

作者：
Ly

方法摘要
static void | main(java.lang.String[] args)
static java.lang.String | parseChains2Script(java.lang.String sContent) 转换级联菜单的xml内容为script内容
static java.lang.String | split2Options(java.lang.String sKey, java.lang.String saValues)
static java.lang.String | split2Options(java.lang.String sKey, java.lang.String saValues, java.lang.String sSplitBy, java.lang.String sValueSplitBy)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

split2Options

public static java.lang.String split2Options(java.lang.String sKey,
                                             java.lang.String saValues,
                                             java.lang.String sSplitBy,
                                             java.lang.String sValueSplitBy)
参数：
sKey -
sSplitBy -
sValueSplitBy -
saValues -
返回：

split2Options

public static java.lang.String split2Options(java.lang.String sKey,
                                             java.lang.String saValues)

parseChains2Script

public static java.lang.String parseChains2Script(java.lang.String sContent)
                                           throws WCMException
转换级联菜单的xml内容为script内容

参数：
sContent -
返回：
抛出：
java.lang.Exception
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkedEnumCreator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.config
类 LinkedEnumCreator

java.lang.Object
    继承者  com.trs.components.infoview.config.LinkedEnumCreator

public class LinkedEnumCreator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
LinkedEnumCreator()
方法摘要
java.lang.String | getCacheKey()
int | getInfoViewId()
java.lang.String | getTemplateContent()
void | setInfoViewId(int _infoView)
void | setTemplateContent(java.lang.String _templateContent)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LinkedEnumCreator

public LinkedEnumCreator()
方法详细信息

getInfoViewId

public int getInfoViewId()
返回：
the infoView

setInfoViewId

public void setInfoViewId(int _infoView)
参数：
_infoView - the infoView to set

getCacheKey

public java.lang.String getCacheKey()

getTemplateContent

public java.lang.String getTemplateContent()
返回：
the templateContent

setTemplateContent

public void setTemplateContent(java.lang.String _templateContent)
参数：
_templateContent - the templateContent to set
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.config
类
BindingBean
EnumCreator
EnumsConfig
GatewayConfig
GatewayPage
InfoViewEnumHelper
LinkedEnumCreator


com.trs.components.infoview.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.config

类摘要
BindingBean | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
EnumCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
EnumsConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GatewayConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GatewayPage | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2007-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewEnumHelper | InfoView 下拉框,级联菜单相关的工具类，定义了一些全局的静态方法
LinkedEnumCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.infoview.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.infoview.config.BindingBean
    • com.trs.components.infoview.config.EnumCreator
    • com.trs.components.infoview.config.EnumsConfig
    • com.trs.components.infoview.config.GatewayConfig
    • com.trs.components.infoview.config.GatewayPage
    • com.trs.components.infoview.config.InfoViewEnumHelper
    • com.trs.components.infoview.config.LinkedEnumCreator


软件包 com.trs.components.infoview.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.config
的使用

使用 com.trs.components.infoview.config 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.config |
com.trs.service |
com.trs.service.impl |

com.trs.components.infoview 使用的 com.trs.components.infoview.config 中的类
EnumsConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GatewayConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.config 使用的 com.trs.components.infoview.config 中的类
EnumCreator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
EnumsConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LinkedEnumCreator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service 使用的 com.trs.components.infoview.config 中的类
BindingBean
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service.impl 使用的 com.trs.components.infoview.config 中的类
BindingBean
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.config.BindingBean 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.config.BindingBean
的使用

使用 BindingBean 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 BindingBean 的使用

参数类型为 BindingBean 的 com.trs.service 中的方法
 java.lang.Object IInfoViewInitorValue.getFieldValue(InfoViewContext _oContext, BindingBean _oBindingBean)

com.trs.service.impl 中 BindingBean 的使用

参数类型为 BindingBean 的 com.trs.service.impl 中的方法
java.lang.Object | InfoViewInitorImpl.getFieldValue(InfoViewContext _oContext, BindingBean _oBean)
java.lang.Object | SiteNameCreator.getFieldValue(InfoViewContext _context, BindingBean _bindingBean)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.config.EnumCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.config.EnumCreator
的使用

使用 EnumCreator 的软件包
com.trs.components.infoview.config

com.trs.components.infoview.config 中 EnumCreator 的使用

返回 EnumCreator 的 com.trs.components.infoview.config 中的方法
EnumCreator | EnumsConfig.getEnumCreator(int nInfoViewId, java.lang.String sKey)
EnumCreator[] | EnumsConfig.getEnumCreators(int nInfoViewId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.config.EnumsConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.config.EnumsConfig
的使用

使用 EnumsConfig 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.config |

com.trs.components.infoview 中 EnumsConfig 的使用

返回 EnumsConfig 的 com.trs.components.infoview 中的方法
 EnumsConfig InfoViewConfig.getEnumsConfig()

com.trs.components.infoview.config 中 EnumsConfig 的使用

返回 EnumsConfig 的 com.trs.components.infoview.config 中的方法
static EnumsConfig EnumsConfig.build(java.lang.String _sFileName)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.config.GatewayConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.config.GatewayConfig
的使用

使用 GatewayConfig 的软件包
com.trs.components.infoview 结合 MS InfoPath 实现自定义表单。

com.trs.components.infoview 中 GatewayConfig 的使用

返回 GatewayConfig 的 com.trs.components.infoview 中的方法
 GatewayConfig InfoViewConfig.getGatewayConfig()

参数类型为 GatewayConfig 的 com.trs.components.infoview 中的方法
 void InfoViewConfig.setGatewayConfig(GatewayConfig _gatewayConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.config.GatewayPage 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.config.GatewayPage
的使用

没有 com.trs.components.infoview.config.GatewayPage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.config.InfoViewEnumHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.config.InfoViewEnumHelper
的使用

没有 com.trs.components.infoview.config.InfoViewEnumHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.config.LinkedEnumCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.config.LinkedEnumCreator
的使用

使用 LinkedEnumCreator 的软件包
com.trs.components.infoview.config

com.trs.components.infoview.config 中 LinkedEnumCreator 的使用

返回 LinkedEnumCreator 的 com.trs.components.infoview.config 中的方法
 LinkedEnumCreator EnumsConfig.getLinkedEnums(int nInfoViewId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChnlDocLCListenerForInfoViewDB

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 ChnlDocLCListenerForInfoViewDB

java.lang.Object
    继承者  com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class ChnlDocLCListenerForInfoViewDB
extends java.lang.Object
implements IObjectLCListenerOnModify

字段摘要
static org.apache.log4j.Logger s_logger
构造方法摘要
ChnlDocLCListenerForInfoViewDB()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

s_logger

public static final org.apache.log4j.Logger s_logger
构造方法详细信息

ChnlDocLCListenerForInfoViewDB

public ChnlDocLCListenerForInfoViewDB()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForInfoViewDB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 DocumentLCListenerForInfoViewDB

java.lang.Object
    继承者  com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class DocumentLCListenerForInfoViewDB
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

构造方法摘要
DocumentLCListenerForInfoViewDB()
缺省构造方法
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForInfoViewDB

public DocumentLCListenerForInfoViewDB()
缺省构造方法

方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IInfoViewDBMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
接口 IInfoViewDBMgr

所有已知实现类：
InfoViewDBMgr
public interface IInfoViewDBMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | createDBField(User _currUser, InfoView _infoView, InfoViewField _infoViewField) 给当前表单的指定字段在数据库中创建对应物理字段
void | createDBTable(User _currUser, int _nInfoViewId) 新增或者修改系统表
void | deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField) 删除指定字段
void | deleteDBTable(User _currUser, int _nInfoViewId) 删除指定表

方法详细信息

createDBTable

void createDBTable(User _currUser,
                   int _nInfoViewId)
                   throws WCMException
新增或者修改系统表

参数：
_currUser -
_oTableInfo -
抛出：
WCMException

createDBField

void createDBField(User _currUser,
                   InfoView _infoView,
                   InfoViewField _infoViewField)
                   throws WCMException
给当前表单的指定字段在数据库中创建对应物理字段

参数：
_currUser -
_infoView -
_infoViewField -
抛出：
WCMException

deleteDBField

void deleteDBField(User _currUser,
                   InfoView _view,
                   InfoViewField _viewField)
                   throws WCMException
删除指定字段

参数：
_currUser -
_view -
_viewField -
抛出：
WCMException

deleteDBTable

void deleteDBTable(User _currUser,
                   int _nInfoViewId)
                   throws WCMException
删除指定表

参数：
_oDBFieldInfo -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDataType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 InfoViewDataType

java.lang.Object
    继承者  com.trs.components.infoview.db.InfoViewDataType

public class InfoViewDataType
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据类型定义对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoViewDataType(int _nDataType, java.lang.String _sDataTypeDesc, java.lang.String _sKey, int _nSqlDataType, int _nMaxLength)
方法摘要
int | getDataType()
java.lang.String | getDataTypeDesc()
java.lang.String | getKey()
int | getMaxLength()
int | getSqlDataType()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewDataType

public InfoViewDataType(int _nDataType,
                        java.lang.String _sDataTypeDesc,
                        java.lang.String _sKey,
                        int _nSqlDataType,
                        int _nMaxLength)
方法详细信息

getDataType

public int getDataType()
返回：

getSqlDataType

public int getSqlDataType()
返回：

getDataTypeDesc

public java.lang.String getDataTypeDesc()
返回：

getKey

public java.lang.String getKey()
返回：

getMaxLength

public int getMaxLength()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDataTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 InfoViewDataTypes

java.lang.Object
    继承者  com.trs.components.infoview.db.InfoViewDataTypes

public class InfoViewDataTypes
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据定义所支持的所有类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoViewDataTypes()
方法摘要
InfoViewDataType | getDataTypeAt(int _nIndex)
InfoViewDataType | getDataTypeById(int _nTypeId)
int | getDataTypesCount()
void | registerMetaDataType(int _nTypeId, java.lang.String _sDataTypeDesc, java.lang.String _sKey, int _nSqlDataType, int _nMaxLength) 注册新的数据类型
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewDataTypes

public InfoViewDataTypes()
方法详细信息

registerMetaDataType

public void registerMetaDataType(int _nTypeId,
                                 java.lang.String _sDataTypeDesc,
                                 java.lang.String _sKey,
                                 int _nSqlDataType,
                                 int _nMaxLength)
注册新的数据类型

参数：
_nTypeId -
_sDataTypeDesc -
_nSqlDataType -

getDataTypesCount

public int getDataTypesCount()
返回：

getDataTypeAt

public InfoViewDataType getDataTypeAt(int _nIndex)
参数：
_nIndex -
返回：

getDataTypeById

public InfoViewDataType getDataTypeById(int _nTypeId)
参数：
_nTypeId -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDBMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 InfoViewDBMgr

java.lang.Object
    继承者  com.trs.components.infoview.db.InfoViewDBMgr
所有已实现的接口：
IInfoViewDBMgr
public class InfoViewDBMgr
extends java.lang.Object
implements IInfoViewDBMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static double RATE_OF_FIELD_LENGTH
构造方法摘要
InfoViewDBMgr()
方法摘要
void | appendDefaultFields(User _currUser, int _nInfoViewId)
void | createDBField(User user, InfoView _view, InfoViewField _viewField) 给当前表单的指定字段在数据库中创建对应物理字段
void | createDBTable(User _currUser, int _nInfoViewId) 新增或者修改系统表
java.lang.String | createTableSQL(int _nInfoViewId)
void | deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField) 删除指定字段
void | deleteDBTable(User _currUser, int _nInfoViewId) 删除指定表
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RATE_OF_FIELD_LENGTH

public static double RATE_OF_FIELD_LENGTH
构造方法详细信息

InfoViewDBMgr

public InfoViewDBMgr()
方法详细信息

createDBTable

public void createDBTable(User _currUser,
                          int _nInfoViewId)
                   throws WCMException
从接口 IInfoViewDBMgr 复制的描述
新增或者修改系统表

指定者：
接口 IInfoViewDBMgr 中的 createDBTable
抛出：
WCMException

createTableSQL

public java.lang.String createTableSQL(int _nInfoViewId)
                                throws WCMException
抛出：
WCMException

deleteDBField

public void deleteDBField(User _currUser,
                          InfoView _view,
                          InfoViewField _viewField)
                   throws WCMException
从接口 IInfoViewDBMgr 复制的描述
删除指定字段

指定者：
接口 IInfoViewDBMgr 中的 deleteDBField
参数：
_currUser -
_view -
_viewField -
抛出：
WCMException

deleteDBTable

public void deleteDBTable(User _currUser,
                          int _nInfoViewId)
                   throws WCMException
从接口 IInfoViewDBMgr 复制的描述
删除指定表

指定者：
接口 IInfoViewDBMgr 中的 deleteDBTable
抛出：
WCMException

appendDefaultFields

public void appendDefaultFields(User _currUser,
                                int _nInfoViewId)
                         throws WCMException
抛出：
WCMException

createDBField

public void createDBField(User user,
                          InfoView _view,
                          InfoViewField _viewField)
                   throws WCMException
从接口 IInfoViewDBMgr 复制的描述
给当前表单的指定字段在数据库中创建对应物理字段

指定者：
接口 IInfoViewDBMgr 中的 createDBField
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDBStoreServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 InfoViewDBStoreServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.components.infoview.db.InfoViewDBStoreServer
所有已实现的接口：
IServer
public class InfoViewDBStoreServer
extends BaseServer

TODO Add javadoc for BigTableServer

作者：
Martin (Fu Chengrui)

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
InfoViewDBStoreServer()
方法摘要
void | changeChnnlOfInfoviewDatasaveInfoViewData(int _nInfoViewId, Document _oDocument, ChnlDoc _oChnDoc)
void | deleteInfoViewData(int _nInfoViewId, Document _oDocument)
void | saveInfoViewData(int _nInfoViewId, Document _oDocument)
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewDBStoreServer

public InfoViewDBStoreServer()
方法详细信息

saveInfoViewData

public void saveInfoViewData(int _nInfoViewId,
                             Document _oDocument)
                      throws WCMException
抛出：
WCMException

deleteInfoViewData

public void deleteInfoViewData(int _nInfoViewId,
                               Document _oDocument)
                        throws WCMException
抛出：
WCMException

changeChnnlOfInfoviewDatasaveInfoViewData

public void changeChnnlOfInfoviewDatasaveInfoViewData(int _nInfoViewId,
                                                      Document _oDocument,
                                                      ChnlDoc _oChnDoc)
                                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoviewXMLDataUpdator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 InfoviewXMLDataUpdator

java.lang.Object
    继承者  com.trs.components.infoview.db.InfoviewXMLDataUpdator

public class InfoviewXMLDataUpdator
extends java.lang.Object

构造方法摘要
InfoviewXMLDataUpdator(java.lang.String _sXMLContent)
方法摘要
void | addInfoViewField(java.lang.String _sFieldName, java.lang.String _sValue) 在xml中增加一个不存在的普通节点
void | addRepeatFieldGroup(java.lang.String _sFieldName, java.util.HashMap hValue) 增加一个重复表结构
void | addRepeatFieldLine(java.lang.String _sFieldName, java.util.HashMap _hRepeatData) 将需要新增加的重复表的一行记录下来
int | getAppenDixFieldSize(java.lang.String _sFieldName) 获取附件类型的字段中上传了几个附件
java.util.List | getComplexFieldDatas()
int | getFieldSize(java.lang.String _sFieldName) 获取一个重复表中某个字段的个数，其实就是返回这个字段所在的组的行数
java.util.List | getFieldValue(java.lang.String _sNodeName) 获取某个节点的值
int | getRepeatFieldElementSize(org.dom4j.Element _Xmlelement, java.lang.String _sFieldName)
int | getRepeatFieldSize(java.lang.String _sFieldName) 获取一个指定的重复表名称的行数 传递的参数是每行数据的GROUP NAME
static void | main(java.lang.String[] args)
void | setAppendixField(java.lang.String _sFieldName, java.lang.String _sValue, int _index) 给指定的附件类型设置字段值
void | setProperty(java.lang.String _sName, java.lang.String _sValue)
void | setRepeatField(java.lang.String _sName, java.lang.String _sValue, int _nOrder)
java.lang.String | update(java.lang.String[] saNameSpaceURI)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoviewXMLDataUpdator

public InfoviewXMLDataUpdator(java.lang.String _sXMLContent)
                       throws WCMException
抛出：
WCMException
方法详细信息

setProperty

public void setProperty(java.lang.String _sName,
                        java.lang.String _sValue)

setRepeatField

public void setRepeatField(java.lang.String _sName,
                           java.lang.String _sValue,
                           int _nOrder)
                    throws WCMException
抛出：
WCMException

getFieldValue

public java.util.List getFieldValue(java.lang.String _sNodeName)
                             throws WCMException
获取某个节点的值

抛出：
WCMException

addInfoViewField

public void addInfoViewField(java.lang.String _sFieldName,
                             java.lang.String _sValue)
在xml中增加一个不存在的普通节点

addRepeatFieldLine

public void addRepeatFieldLine(java.lang.String _sFieldName,
                               java.util.HashMap _hRepeatData)
将需要新增加的重复表的一行记录下来

addRepeatFieldGroup

public void addRepeatFieldGroup(java.lang.String _sFieldName,
                                java.util.HashMap hValue)
增加一个重复表结构

getRepeatFieldSize

public int getRepeatFieldSize(java.lang.String _sFieldName)
获取一个指定的重复表名称的行数 传递的参数是每行数据的GROUP NAME

getAppenDixFieldSize

public int getAppenDixFieldSize(java.lang.String _sFieldName)
获取附件类型的字段中上传了几个附件

setAppendixField

public void setAppendixField(java.lang.String _sFieldName,
                             java.lang.String _sValue,
                             int _index)
给指定的附件类型设置字段值

getFieldSize

public int getFieldSize(java.lang.String _sFieldName)
获取一个重复表中某个字段的个数，其实就是返回这个字段所在的组的行数

getRepeatFieldElementSize

public int getRepeatFieldElementSize(org.dom4j.Element _Xmlelement,
                                     java.lang.String _sFieldName)

update

public java.lang.String update(java.lang.String[] saNameSpaceURI)
                        throws WCMException
抛出：
WCMException

getComplexFieldDatas

public java.util.List getComplexFieldDatas()

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LetterConvertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 LetterConvertor

java.lang.Object
    继承者  com.trs.components.infoview.db.LetterConvertor

public class LetterConvertor
extends java.lang.Object

构造方法摘要
LetterConvertor()
方法摘要
static java.lang.String | convertToFirstLetter(java.lang.String _sOldValue)
static java.lang.String | convertToFirstLetter(java.lang.String _sOldValue, boolean _bConvertorFull, int _nLimitAutoToFirstLetter)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LetterConvertor

public LetterConvertor()
方法详细信息

convertToFirstLetter

public static java.lang.String convertToFirstLetter(java.lang.String _sOldValue)

convertToFirstLetter

public static java.lang.String convertToFirstLetter(java.lang.String _sOldValue,
                                                    boolean _bConvertorFull,
                                                    int _nLimitAutoToFirstLetter)
参数：
_sOldValue -
_bConvertorFull -
_nLimitAutoToFirstLetter - 如果转换以后的长度超过指定长度以后，自动取首字母
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.db
接口
IInfoViewDBMgr
类
ChnlDocLCListenerForInfoViewDB
DocumentLCListenerForInfoViewDB
InfoViewDataType
InfoViewDataTypes
InfoViewDBMgr
InfoViewDBStoreServer
InfoviewXMLDataUpdator
LetterConvertor
XMLContentRender


com.trs.components.infoview.db

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.db

接口摘要
IInfoViewDBMgr Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
ChnlDocLCListenerForInfoViewDB |
DocumentLCListenerForInfoViewDB |
InfoViewDataType | Title: TRS 内容协作平台（TRS WCM） Description: 元数据类型定义对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDataTypes | Title: TRS 内容协作平台（TRS WCM） Description: 元数据定义所支持的所有类型 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDBMgr | Title: TRS 内容协作平台（TRS WCM） Description: 元数据结构定义业务对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDBStoreServer | TODO Add javadoc for BigTableServer
InfoviewXMLDataUpdator |
LetterConvertor |
XMLContentRender |


com.trs.components.infoview.db 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.db 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.components.infoview.db.InfoViewDBStoreServer
    • com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.infoview.db.InfoViewDataType
    • com.trs.components.infoview.db.InfoViewDataTypes
    • com.trs.components.infoview.db.InfoViewDBMgr (implements com.trs.components.infoview.db.IInfoViewDBMgr)
    • com.trs.components.infoview.db.InfoviewXMLDataUpdator
    • com.trs.components.infoview.db.LetterConvertor
    • com.trs.components.infoview.db.XMLContentRender

接口分层结构

  • com.trs.components.infoview.db.IInfoViewDBMgr


软件包 com.trs.components.infoview.db 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.db
的使用

使用 com.trs.components.infoview.db 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |

com.trs.components.infoview 使用的 com.trs.components.infoview.db 中的类
InfoViewDataTypes
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据定义所支持的所有类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.db 使用的 com.trs.components.infoview.db 中的类
IInfoViewDBMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDataType
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据类型定义对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


XMLContentRender

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.db
类 XMLContentRender

java.lang.Object
    继承者  com.trs.components.infoview.db.XMLContentRender

public class XMLContentRender
extends java.lang.Object

构造方法摘要
XMLContentRender()
方法摘要
java.util.List | getComplexFieldDatas()
void | render(InfoViewData _oDocData, org.dom4j.Document xmlDocument, java.lang.String[] saNameSpaceURI)
void | render(InfoViewData _oDocData, java.lang.String sXMLContent, java.lang.String[] saNameSpaceURI)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLContentRender

public XMLContentRender()
方法详细信息

render

public void render(InfoViewData _oDocData,
                   java.lang.String sXMLContent,
                   java.lang.String[] saNameSpaceURI)
            throws WCMException
抛出：
WCMException

render

public void render(InfoViewData _oDocData,
                   org.dom4j.Document xmlDocument,
                   java.lang.String[] saNameSpaceURI)
            throws WCMException
抛出：
WCMException

getComplexFieldDatas

public java.util.List getComplexFieldDatas()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB
的使用

没有 com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB
的使用

没有 com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.infoview.db.IInfoViewDBMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.infoview.db.IInfoViewDBMgr
的使用

使用 IInfoViewDBMgr 的软件包
com.trs.components.infoview.db

com.trs.components.infoview.db 中 IInfoViewDBMgr 的使用

实现 IInfoViewDBMgr 的 com.trs.components.infoview.db 中的类
 class InfoViewDBMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.db.InfoViewDataType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.InfoViewDataType
的使用

使用 InfoViewDataType 的软件包
com.trs.components.infoview.db

com.trs.components.infoview.db 中 InfoViewDataType 的使用

返回 InfoViewDataType 的 com.trs.components.infoview.db 中的方法
InfoViewDataType | InfoViewDataTypes.getDataTypeAt(int _nIndex)
InfoViewDataType | InfoViewDataTypes.getDataTypeById(int _nTypeId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.db.InfoViewDataTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.InfoViewDataTypes
的使用

使用 InfoViewDataTypes 的软件包
com.trs.components.infoview 结合 MS InfoPath 实现自定义表单。

com.trs.components.infoview 中 InfoViewDataTypes 的使用

声明为 InfoViewDataTypes 的 com.trs.components.infoview 中的字段
static InfoViewDataTypes | InfoViewConstants.DB_DATA_TYPES
static InfoViewDataTypes | InfoViewConstants.DEFAULT_FIELDS

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.db.InfoViewDBMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.InfoViewDBMgr
的使用

没有 com.trs.components.infoview.db.InfoViewDBMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.db.InfoViewDBStoreServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.InfoViewDBStoreServer
的使用

没有 com.trs.components.infoview.db.InfoViewDBStoreServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.InfoviewXMLDataUpdator
的使用

没有 com.trs.components.infoview.db.InfoviewXMLDataUpdator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.db.LetterConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.LetterConvertor
的使用

没有 com.trs.components.infoview.db.LetterConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.db.XMLContentRender 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.db.XMLContentRender
的使用

没有 com.trs.components.infoview.db.XMLContentRender 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DataGroup

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 DataGroup

java.lang.Object
    继承者  com.trs.components.infoview.extract.DataGroup

public class DataGroup
extends java.lang.Object

方法摘要
void | enablePublish(boolean zPublish)
java.lang.String | getBindname()
java.lang.String | getName()
int | getViewID()
void | setTRSObjectID(int id)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getName

public java.lang.String getName()

getBindname

public java.lang.String getBindname()

getViewID

public int getViewID()

setTRSObjectID

public void setTRSObjectID(int id)

enablePublish

public void enablePublish(boolean zPublish)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DataType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 DataType

java.lang.Object
    继承者  com.trs.components.infoview.extract.DataType
所有已实现的接口：
java.lang.Cloneable
public class DataType
extends java.lang.Object
implements java.lang.Cloneable

方法摘要
void | addChild(DataType oChildDataType)
DataType | findDataType(java.lang.String sPath, java.lang.String sPrefix)
java.lang.String | getBaseName()
DataType | getBaseType()
org.dom4j.Element | getBindElement()
java.lang.String | getBindName()
java.util.ArrayList | getChildren()
static DataType | getComplexType()
java.lang.String | getDataName()
DataType | getDataType()
int | getDataTypeAsInt()
java.lang.String | getDisplayFieldType()
java.lang.String | getDisplayName()
static DataType | getInnerType()
int | getMaxLength()
int | getMinLength()
java.lang.String | getName()
java.lang.String | getNewBindName()
java.lang.String | getNillable()
java.lang.String | getRefName()
DataType | getRefType()
static DataType | getSimpleType()
java.lang.String | getTRSTypeName()
java.lang.String | getTypeName()
java.lang.String | getXSDTypeName()
boolean | isComplexType()
boolean | isDefaultNotNullType()
boolean | isInnerType()
boolean | isNillable()
boolean | isSimpleType()
void | setBaseName(java.lang.String baseName)
void | setBaseType(DataType baseType)
void | setBindName(java.lang.String bindName)
void | setComplexType(boolean complexType)
void | setDataName(java.lang.String dataName)
void | setDataType(DataType dataType)
void | setDisplayFieldType(java.lang.String _sType)
void | setDisplayName(java.lang.String displayName)
void | setInnerType(boolean innerType)
void | setMaxLength(int maxLength)
void | setMinLength(int minLength)
void | setName(java.lang.String name)
void | setNewBindName(java.lang.String newBindName)
void | setNillable(java.lang.String nillable)
void | setRefName(java.lang.String refName)
void | setRefType(DataType refType)
void | setSimpleType(boolean simpleType)
void | setTRSObjectID(int id)
void | setTypeName(java.lang.String typeName)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getInnerType

public static final DataType getInnerType()

getSimpleType

public static final DataType getSimpleType()

getComplexType

public static final DataType getComplexType()

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getXSDTypeName

public java.lang.String getXSDTypeName()

getTRSTypeName

public java.lang.String getTRSTypeName()

getDataTypeAsInt

public int getDataTypeAsInt()

findDataType

public DataType findDataType(java.lang.String sPath,
                             java.lang.String sPrefix)

addChild

public void addChild(DataType oChildDataType)

getChildren

public java.util.ArrayList getChildren()

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getTypeName

public java.lang.String getTypeName()

setTypeName

public void setTypeName(java.lang.String typeName)

getDataName

public java.lang.String getDataName()

setDataName

public void setDataName(java.lang.String dataName)

getDataType

public DataType getDataType()

setDataType

public void setDataType(DataType dataType)

getBaseName

public java.lang.String getBaseName()

setBaseName

public void setBaseName(java.lang.String baseName)

getBaseType

public DataType getBaseType()

setBaseType

public void setBaseType(DataType baseType)

getRefName

public java.lang.String getRefName()

setRefName

public void setRefName(java.lang.String refName)

getRefType

public DataType getRefType()

setRefType

public void setRefType(DataType refType)

isInnerType

public boolean isInnerType()

setInnerType

public void setInnerType(boolean innerType)

isSimpleType

public boolean isSimpleType()

setSimpleType

public void setSimpleType(boolean simpleType)

isComplexType

public boolean isComplexType()

setComplexType

public void setComplexType(boolean complexType)

getBindName

public java.lang.String getBindName()

setBindName

public void setBindName(java.lang.String bindName)

getNewBindName

public java.lang.String getNewBindName()

setNewBindName

public void setNewBindName(java.lang.String newBindName)

getDisplayName

public java.lang.String getDisplayName()

setDisplayName

public void setDisplayName(java.lang.String displayName)

isDefaultNotNullType

public boolean isDefaultNotNullType()

isNillable

public boolean isNillable()

getNillable

public java.lang.String getNillable()

setNillable

public void setNillable(java.lang.String nillable)

getMaxLength

public int getMaxLength()

setMaxLength

public void setMaxLength(int maxLength)

getMinLength

public int getMinLength()

setMinLength

public void setMinLength(int minLength)

getBindElement

public org.dom4j.Element getBindElement()

setTRSObjectID

public void setTRSObjectID(int id)

setDisplayFieldType

public void setDisplayFieldType(java.lang.String _sType)

getDisplayFieldType

public java.lang.String getDisplayFieldType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataTypeBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 DataTypeBuilder

java.lang.Object
    继承者  com.trs.components.infoview.extract.DataTypeBuilder

public class DataTypeBuilder
extends java.lang.Object

构造方法摘要
DataTypeBuilder()
方法摘要
void | build(org.dom4j.Document document)
DataType | getSchema(java.lang.String name)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataTypeBuilder

public DataTypeBuilder()
方法详细信息

build

public void build(org.dom4j.Document document)

getSchema

public DataType getSchema(java.lang.String name)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoPathFileData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 InfoPathFileData

java.lang.Object
    继承者  com.trs.components.infoview.extract.InfoPathFileData

public class InfoPathFileData
extends java.lang.Object

构造方法摘要
InfoPathFileData()
方法摘要
void | build(java.lang.String diretory, java.util.HashMap mapFiles, InfoViewConfig ivConfig)
java.lang.String | getAllFileList()
java.util.ArrayList | getFieldList()
static java.lang.String | getFileContent(java.lang.String file)
java.util.ArrayList | getGroupList()
java.lang.String | getSchemaFile()
java.lang.String | getSchemaRootElement()
java.lang.String | getSchemaURI()
java.lang.String | getTemplateFile()
java.util.ArrayList | getViewList()
java.util.HashMap | getViewMaps()
void | reform(int _iInfoViewId) 重构所有的的XSLT文件
void | reformTemplateXml() 重构所有的的Template.xml文件
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoPathFileData

public InfoPathFileData()
方法详细信息

getFileContent

public static final java.lang.String getFileContent(java.lang.String file)
                                             throws java.io.IOException
抛出：
java.io.IOException

build

public void build(java.lang.String diretory,
                  java.util.HashMap mapFiles,
                  InfoViewConfig ivConfig)
           throws java.lang.Exception
抛出：
java.lang.Exception

reform

public void reform(int _iInfoViewId)
            throws java.lang.Exception
重构所有的的XSLT文件

抛出：
java.lang.Exception

reformTemplateXml

public void reformTemplateXml()
                       throws java.lang.Exception
重构所有的的Template.xml文件

抛出：
java.lang.Exception

getAllFileList

public java.lang.String getAllFileList()

getSchemaFile

public java.lang.String getSchemaFile()

getSchemaRootElement

public java.lang.String getSchemaRootElement()

getSchemaURI

public java.lang.String getSchemaURI()

getTemplateFile

public java.lang.String getTemplateFile()

getViewList

public java.util.ArrayList getViewList()

getGroupList

public java.util.ArrayList getGroupList()

getFieldList

public java.util.ArrayList getFieldList()

getViewMaps

public java.util.HashMap getViewMaps()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JavaCABFileExtractor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 JavaCABFileExtractor

java.lang.Object
    继承者  com.trs.components.infoview.CABFileExtractor
        继承者  com.trs.components.infoview.extract.JavaCABFileExtractor

public class JavaCABFileExtractor
extends CABFileExtractor

构造方法摘要
JavaCABFileExtractor()
方法摘要
 java.util.HashMap extract(java.lang.String sCABFile, java.lang.String sTargetDiretory)
TODO Add javadoc for field extract
从类 com.trs.components.infoview.CABFileExtractor 继承的方法
init
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JavaCABFileExtractor

public JavaCABFileExtractor()
方法详细信息

extract

public java.util.HashMap extract(java.lang.String sCABFile,
                                 java.lang.String sTargetDiretory)
                          throws java.io.IOException
从类 CABFileExtractor 复制的描述
TODO Add javadoc for field extract

指定者：
类 CABFileExtractor 中的 extract
返回：
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.extract
类
DataGroup
DataType
DataTypeBuilder
InfoPathFileData
JavaCABFileExtractor
TestIPFD
WinCABFileExtractor
XSLTViewBuilder
XSLTViewConstrainter


com.trs.components.infoview.extract

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.extract

抽取 MS InfoPath 的 XSN 文件的内容。

请参见：
描述

类摘要
DataGroup
DataType
DataTypeBuilder
InfoPathFileData
JavaCABFileExtractor
TestIPFD
WinCABFileExtractor
XSLTViewBuilder
XSLTViewConstrainter

软件包 com.trs.components.infoview.extract 的描述

抽取 MS InfoPath 的 XSN 文件的内容。 这个Package的位置（名字）可能不它符合WCM的习惯，但是暂时只能放在这里。


com.trs.components.infoview.extract 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.extract 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.infoview.CABFileExtractor
      • com.trs.components.infoview.extract.JavaCABFileExtractor
      • com.trs.components.infoview.extract.WinCABFileExtractor
    • com.trs.components.infoview.extract.DataGroup
    • com.trs.components.infoview.extract.DataType (implements java.lang.Cloneable)
    • com.trs.components.infoview.extract.DataTypeBuilder
    • com.trs.components.infoview.extract.InfoPathFileData
    • com.trs.components.infoview.extract.TestIPFD
    • com.trs.components.infoview.extract.XSLTViewBuilder
    • com.trs.components.infoview.extract.XSLTViewConstrainter


软件包 com.trs.components.infoview.extract 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.extract
的使用

使用 com.trs.components.infoview.extract 的软件包
com.trs.components.infoview.extract 抽取 MS InfoPath 的 XSN 文件的内容。

com.trs.components.infoview.extract 使用的 com.trs.components.infoview.extract 中的类
DataType

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TestIPFD

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 TestIPFD

java.lang.Object
    继承者  com.trs.components.infoview.extract.TestIPFD

public class TestIPFD
extends java.lang.Object

构造方法摘要
TestIPFD()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TestIPFD

public TestIPFD()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WinCABFileExtractor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 WinCABFileExtractor

java.lang.Object
    继承者  com.trs.components.infoview.CABFileExtractor
        继承者  com.trs.components.infoview.extract.WinCABFileExtractor

public class WinCABFileExtractor
extends CABFileExtractor

构造方法摘要
WinCABFileExtractor()
方法摘要
 java.util.HashMap extract(java.lang.String sCABFile, java.lang.String sTargetDiretory)
TODO Add javadoc for field extract
从类 com.trs.components.infoview.CABFileExtractor 继承的方法
init
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WinCABFileExtractor

public WinCABFileExtractor()
方法详细信息

extract

public java.util.HashMap extract(java.lang.String sCABFile,
                                 java.lang.String sTargetDiretory)
                          throws java.io.IOException
从类 CABFileExtractor 复制的描述
TODO Add javadoc for field extract

指定者：
类 CABFileExtractor 中的 extract
返回：
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XSLTViewBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 XSLTViewBuilder

java.lang.Object
    继承者  com.trs.components.infoview.extract.XSLTViewBuilder

public class XSLTViewBuilder
extends java.lang.Object

字段摘要
static java.lang.String | FLAG_TRS_OBJ_ID
static java.lang.String | FLAG_TRS_OBJ_PUB
static java.lang.String | FLAG_TRS_OBJ_TYPE
static java.lang.String | FLAG_TRS_OBJ_TYPENAME
static java.lang.String | NAME_DATA_FIELD
static java.lang.String | NAME_DATA_SECTION
static java.lang.String | TYPE_DATA_FIELD
static java.lang.String | TYPE_DATA_SECTION
构造方法摘要
XSLTViewBuilder()
方法摘要
void | build(View view)
void | init(InfoViewConfig ivConfig, Manifest manifest, java.util.List groupList, DataType rootType, java.util.List typeList)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FLAG_TRS_OBJ_TYPENAME

public static final java.lang.String FLAG_TRS_OBJ_TYPENAME
另请参见：
常量字段值

FLAG_TRS_OBJ_TYPE

public static final java.lang.String FLAG_TRS_OBJ_TYPE
另请参见：
常量字段值

FLAG_TRS_OBJ_ID

public static final java.lang.String FLAG_TRS_OBJ_ID
另请参见：
常量字段值

FLAG_TRS_OBJ_PUB

public static final java.lang.String FLAG_TRS_OBJ_PUB
另请参见：
常量字段值

NAME_DATA_SECTION

public static final java.lang.String NAME_DATA_SECTION
另请参见：
常量字段值

NAME_DATA_FIELD

public static final java.lang.String NAME_DATA_FIELD
另请参见：
常量字段值

TYPE_DATA_SECTION

public static final java.lang.String TYPE_DATA_SECTION

TYPE_DATA_FIELD

public static final java.lang.String TYPE_DATA_FIELD
构造方法详细信息

XSLTViewBuilder

public XSLTViewBuilder()
方法详细信息

init

public void init(InfoViewConfig ivConfig,
                 Manifest manifest,
                 java.util.List groupList,
                 DataType rootType,
                 java.util.List typeList)

build

public void build(View view)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XSLTViewConstrainter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract
类 XSLTViewConstrainter

java.lang.Object
    继承者  com.trs.components.infoview.extract.XSLTViewConstrainter

public class XSLTViewConstrainter
extends java.lang.Object

构造方法摘要
XSLTViewConstrainter()
方法摘要
void | init(InfoView _oInfoView, InfoViewView _oInfoViewView)
void | init(InfoView _oInfoView, InfoViewView _oInfoViewView, java.util.List _lsGroups, java.util.List _lsFields)
boolean | rebuild(org.dom4j.Document _oXslDocument)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XSLTViewConstrainter

public XSLTViewConstrainter()
方法详细信息

init

public void init(InfoView _oInfoView,
                 InfoViewView _oInfoViewView)
          throws WCMException
抛出：
WCMException

init

public void init(InfoView _oInfoView,
                 InfoViewView _oInfoViewView,
                 java.util.List _lsGroups,
                 java.util.List _lsFields)
          throws WCMException
抛出：
WCMException

rebuild

public boolean rebuild(org.dom4j.Document _oXslDocument)
                throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.infoview.extract.DataGroup 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.DataGroup
的使用

没有 com.trs.components.infoview.extract.DataGroup 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.DataType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.DataType
的使用

使用 DataType 的软件包
com.trs.components.infoview.extract 抽取 MS InfoPath 的 XSN 文件的内容。

com.trs.components.infoview.extract 中 DataType 的使用

返回 DataType 的 com.trs.components.infoview.extract 中的方法
DataType | DataType.findDataType(java.lang.String sPath, java.lang.String sPrefix)
DataType | DataType.getBaseType()
static DataType | DataType.getComplexType()
DataType | DataType.getDataType()
static DataType | DataType.getInnerType()
DataType | DataType.getRefType()
DataType | DataTypeBuilder.getSchema(java.lang.String name)
static DataType | DataType.getSimpleType()

参数类型为 DataType 的 com.trs.components.infoview.extract 中的方法
void | DataType.addChild(DataType oChildDataType)
void | XSLTViewBuilder.init(InfoViewConfig ivConfig, Manifest manifest, java.util.List groupList, DataType rootType, java.util.List typeList)
void | DataType.setBaseType(DataType baseType)
void | DataType.setDataType(DataType dataType)
void | DataType.setRefType(DataType refType)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.DataTypeBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.DataTypeBuilder
的使用

没有 com.trs.components.infoview.extract.DataTypeBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.InfoPathFileData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.InfoPathFileData
的使用

没有 com.trs.components.infoview.extract.InfoPathFileData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.JavaCABFileExtractor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.JavaCABFileExtractor
的使用

没有 com.trs.components.infoview.extract.JavaCABFileExtractor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.TestIPFD 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.TestIPFD
的使用

没有 com.trs.components.infoview.extract.TestIPFD 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.WinCABFileExtractor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.WinCABFileExtractor
的使用

没有 com.trs.components.infoview.extract.WinCABFileExtractor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.XSLTViewBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.XSLTViewBuilder
的使用

没有 com.trs.components.infoview.extract.XSLTViewBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.XSLTViewConstrainter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.XSLTViewConstrainter
的使用

没有 com.trs.components.infoview.extract.XSLTViewConstrainter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CalculatedField

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 CalculatedField

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.CalculatedField

public class CalculatedField
extends java.lang.Object

/xsf:xDocumentClass/xsf:calculations/xsf:calculatedField

作者：
Martin (Fu Chengrui)

构造方法摘要
CalculatedField()
方法摘要
java.lang.String | getExpression()
java.lang.String | getRefresh()
java.lang.String | getRelativeTarget()
java.lang.String | getTarget()
void | setExpression(java.lang.String expression)
void | setRefresh(java.lang.String refresh)
void | setTarget(java.lang.String target)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CalculatedField

public CalculatedField()
方法详细信息

getExpression

public java.lang.String getExpression()

setExpression

public void setExpression(java.lang.String expression)

getRefresh

public java.lang.String getRefresh()

setRefresh

public void setRefresh(java.lang.String refresh)

getTarget

public java.lang.String getTarget()

getRelativeTarget

public java.lang.String getRelativeTarget()

setTarget

public void setTarget(java.lang.String target)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentSchema

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 DocumentSchema

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.DocumentSchema

public class DocumentSchema
extends java.lang.Object

/xsf:xDocumentClass/xsf:documentSchemas/xsf:documentSchema

作者：
Martin (Fu Chengrui)

构造方法摘要
DocumentSchema()
方法摘要
java.lang.String | getLocation()
java.lang.String | getNamespace()
java.lang.String | getRootElement()
java.lang.String | getRootSchema()
java.lang.String | getXSDFile()
java.lang.String | getXSDURI()
boolean | isRootSchema()
void | setLocation(java.lang.String location)
void | setNamespace(java.lang.String namespace)
void | setRootElement(java.lang.String rootElement)
void | setRootSchema(java.lang.String rootSchema)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DocumentSchema

public DocumentSchema()
方法详细信息

isRootSchema

public boolean isRootSchema()

getRootSchema

public java.lang.String getRootSchema()

setRootSchema

public void setRootSchema(java.lang.String rootSchema)

getLocation

public java.lang.String getLocation()

setLocation

public void setLocation(java.lang.String location)

getXSDFile

public java.lang.String getXSDFile()

getXSDURI

public java.lang.String getXSDURI()

getNamespace

public java.lang.String getNamespace()

setNamespace

public void setNamespace(java.lang.String namespace)

getRootElement

public java.lang.String getRootElement()

setRootElement

public void setRootElement(java.lang.String rootElement)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileNew

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 FileNew

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.FileNew
已过时。 实际并没有使用 /xsf:xDocumentClass/xsf:fileNew/xsf:initialXmlDocument

public class FileNew
extends java.lang.Object

作者：
Martin (Fu Chengrui)

构造方法摘要
FileNew()
已过时。
方法摘要
java.lang.String | getCaption() 已过时。
java.lang.String | getTemplate() 已过时。
void | setCaption(java.lang.String caption) 已过时。
void | setTemplate(java.lang.String template) 已过时。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileNew

public FileNew()
已过时。
方法详细信息

getCaption

public java.lang.String getCaption()
已过时。

setCaption

public void setCaption(java.lang.String caption)
已过时。

getTemplate

public java.lang.String getTemplate()
已过时。

setTemplate

public void setTemplate(java.lang.String template)
已过时。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileProperty

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 FileProperty

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.FileProperty

public class FileProperty
extends java.lang.Object

/xsf:xDocumentClass/xsf:package/xsf:files/xsf:file/xsf:fileProperties/xsf:property

作者：
Martin (Fu Chengrui)

构造方法摘要
FileProperty()
方法摘要
java.lang.String | getName()
java.lang.String | getType()
java.lang.String | getValue()
void | setName(java.lang.String name)
void | setType(java.lang.String type)
void | setValue(java.lang.String value)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FileProperty

public FileProperty()
方法详细信息

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getType

public java.lang.String getType()

setType

public void setType(java.lang.String type)

getValue

public java.lang.String getValue()

setValue

public void setValue(java.lang.String value)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Manifest

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 Manifest

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.Manifest

public class Manifest
extends java.lang.Object

描述InfoPath文件解压后的manifest.xsf文件

作者：
Martin (Fu Chengrui)

构造方法摘要
Manifest()
缺省构造方法
方法摘要
void | build(org.dom4j.Document document) 使用manifest.xsf的Document对象构造Manifest对象
java.util.HashMap | getAllSchemas() 返回InfoPath模版中定义的全部Schema，存储在一个HashMap中，以XSD文件的文件名作为KEY。
java.util.HashMap | getAllViews() 返回包括所有视图的HashMap对象
java.util.List | getAllViewsInOrder()
CalculatedField | getCalculatedField(java.lang.String sTarget) 返回计算目标为指定数据项的表达式，如果没有表达式以指定的数据项为目标，则返回null。
View | getDefaultView() 返回缺省视图对象
java.lang.String | getFileNewCaption() 新填写表单的表单数据的缺省标题 暂时没有使用
java.lang.String | getFileNewTemplate() 返回填写表单用的XML模版文件的文件名
DocumentSchema | getRootSchema() 返回根Schema
java.lang.String | getRootSchemaURI() 返回根Schema的URI定义
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Manifest

public Manifest()
缺省构造方法

方法详细信息

build

public void build(org.dom4j.Document document)
使用manifest.xsf的Document对象构造Manifest对象

参数：
document - manifest.xsf文件的DOM4J描述

getAllViews

public java.util.HashMap getAllViews()
返回包括所有视图的HashMap对象

返回：
包括所有视图的HashMap对象

getAllViewsInOrder

public java.util.List getAllViewsInOrder()

getDefaultView

public View getDefaultView()
返回缺省视图对象

返回：
缺省视图对象

getCalculatedField

public CalculatedField getCalculatedField(java.lang.String sTarget)
返回计算目标为指定数据项的表达式，如果没有表达式以指定的数据项为目标，则返回null。

参数：
sTarget - 指定数据项的XPATH，可以是绝对或者相对的
返回：
计算表达式对象com.trs.components.infoview.extract.manifest.CalculatedField实例

getAllSchemas

public java.util.HashMap getAllSchemas()
返回InfoPath模版中定义的全部Schema，存储在一个HashMap中，以XSD文件的文件名作为KEY。

返回：
InfoPath模版中定义的全部Schema

getRootSchema

public DocumentSchema getRootSchema()
返回根Schema

返回：
根Schema

getRootSchemaURI

public java.lang.String getRootSchemaURI()
返回根Schema的URI定义

返回：
根Schema的URI定义

getFileNewCaption

public java.lang.String getFileNewCaption()
新填写表单的表单数据的缺省标题 暂时没有使用

返回：
表单数据的缺省标题

getFileNewTemplate

public java.lang.String getFileNewTemplate()
返回填写表单用的XML模版文件的文件名

返回：
填写表单用的XML模版文件的文件名
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuArea

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 MenuArea

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.MenuArea

public class MenuArea
extends java.lang.Object

/xsf:xDocumentClass/xsf:views/xsf:view/xsf:menuArea

作者：
Martin (Fu Chengrui)

构造方法摘要
MenuArea()
方法摘要
void | addButton(MenuButton button)
MenuArea | build(org.dom4j.Element element)
java.util.ArrayList | getButton()
java.lang.String | getName()
void | setButton(java.util.ArrayList button)
void | setName(java.lang.String name)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MenuArea

public MenuArea()
方法详细信息

build

public MenuArea build(org.dom4j.Element element)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

addButton

public void addButton(MenuButton button)

getButton

public java.util.ArrayList getButton()

setButton

public void setButton(java.util.ArrayList button)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuButton

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 MenuButton

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.MenuButton

public class MenuButton
extends java.lang.Object

/xsf:xDocumentClass/xsf:views/xsf:view/xsf:menuArea/xsf:button

作者：
Martin (Fu Chengrui)

构造方法摘要
MenuButton()
方法摘要
java.lang.String | getAction()
java.lang.String | getBindAction()
java.lang.String | getCaption()
java.lang.String | getIcon()
java.lang.String | getName()
java.lang.String | getShowIf()
java.lang.String | getTooltip()
java.lang.String | getXMLToEdit()
void | setAction(java.lang.String action)
void | setCaption(java.lang.String caption)
void | setIcon(java.lang.String icon)
void | setName(java.lang.String name)
void | setShowIf(java.lang.String showIf)
void | setTooltip(java.lang.String tooltip)
void | setXMLToEdit(java.lang.String toEdit)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MenuButton

public MenuButton()
方法详细信息

getBindAction

public java.lang.String getBindAction()

getAction

public java.lang.String getAction()

setAction

public void setAction(java.lang.String action)

getCaption

public java.lang.String getCaption()

setCaption

public void setCaption(java.lang.String caption)

getIcon

public java.lang.String getIcon()

setIcon

public void setIcon(java.lang.String icon)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getShowIf

public java.lang.String getShowIf()

setShowIf

public void setShowIf(java.lang.String showIf)

getTooltip

public java.lang.String getTooltip()

setTooltip

public void setTooltip(java.lang.String tooltip)

getXMLToEdit

public java.lang.String getXMLToEdit()

setXMLToEdit

public void setXMLToEdit(java.lang.String toEdit)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PackageFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 PackageFile

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.PackageFile

public class PackageFile
extends java.lang.Object

/xsf:xDocumentClass/xsf:package/xsf:files/xsf:file

作者：
Martin (Fu Chengrui)

构造方法摘要
PackageFile()
方法摘要
java.util.HashMap | getFileProperties()
FileProperty | getFileProperty(java.lang.String key)
java.lang.String | getName()
void | setName(java.lang.String name)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PackageFile

public PackageFile()
方法详细信息

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getFileProperty

public FileProperty getFileProperty(java.lang.String key)

getFileProperties

public java.util.HashMap getFileProperties()

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.extract.manifest
类
CalculatedField
DocumentSchema
FileNew
FileProperty
Manifest
MenuArea
MenuButton
PackageFile
View


com.trs.components.infoview.extract.manifest

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.extract.manifest

类摘要
CalculatedField | /xsf:xDocumentClass/xsf:calculations/xsf:calculatedField
DocumentSchema | /xsf:xDocumentClass/xsf:documentSchemas/xsf:documentSchema
FileNew | 已过时。 实际并没有使用 /xsf:xDocumentClass/xsf:fileNew/xsf:initialXmlDocument
FileProperty | /xsf:xDocumentClass/xsf:package/xsf:files/xsf:file/xsf:fileProperties/xsf:property
Manifest | 描述InfoPath文件解压后的manifest.xsf文件
MenuArea | /xsf:xDocumentClass/xsf:views/xsf:view/xsf:menuArea
MenuButton | /xsf:xDocumentClass/xsf:views/xsf:view/xsf:menuArea/xsf:button
PackageFile | /xsf:xDocumentClass/xsf:package/xsf:files/xsf:file
View | /xsf:xDocumentClass/xsf:views/xsf:view


com.trs.components.infoview.extract.manifest 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.extract.manifest 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.infoview.extract.manifest.CalculatedField
    • com.trs.components.infoview.extract.manifest.DocumentSchema
    • com.trs.components.infoview.extract.manifest.FileNew
    • com.trs.components.infoview.extract.manifest.FileProperty
    • com.trs.components.infoview.extract.manifest.Manifest
    • com.trs.components.infoview.extract.manifest.MenuArea
    • com.trs.components.infoview.extract.manifest.MenuButton
    • com.trs.components.infoview.extract.manifest.PackageFile
    • com.trs.components.infoview.extract.manifest.View


软件包 com.trs.components.infoview.extract.manifest 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.extract.manifest
的使用

使用 com.trs.components.infoview.extract.manifest 的软件包
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。
com.trs.components.infoview.extract.manifest |

com.trs.components.infoview.extract 使用的 com.trs.components.infoview.extract.manifest 中的类
Manifest
描述InfoPath文件解压后的manifest.xsf文件
View
/xsf:xDocumentClass/xsf:views/xsf:view

com.trs.components.infoview.extract.manifest 使用的 com.trs.components.infoview.extract.manifest 中的类
CalculatedField
/xsf:xDocumentClass/xsf:calculations/xsf:calculatedField
DocumentSchema
/xsf:xDocumentClass/xsf:documentSchemas/xsf:documentSchema
FileProperty
/xsf:xDocumentClass/xsf:package/xsf:files/xsf:file/xsf:fileProperties/xsf:property
MenuArea
/xsf:xDocumentClass/xsf:views/xsf:view/xsf:menuArea
MenuButton
/xsf:xDocumentClass/xsf:views/xsf:view/xsf:menuArea/xsf:button
View
/xsf:xDocumentClass/xsf:views/xsf:view

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


View

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.extract.manifest
类 View

java.lang.Object
    继承者  com.trs.components.infoview.extract.manifest.View

public class View
extends java.lang.Object

/xsf:xDocumentClass/xsf:views/xsf:view

作者：
Martin (Fu Chengrui)

构造方法摘要
View()
方法摘要
void | addMenuArea(MenuArea menuarea)
java.lang.String | getCaption()
MenuArea | getContextMenuArea()
java.util.ArrayList | getContextMenuForBinding(java.lang.String sBinding)
java.util.ArrayList | getContextMenuForXMLToEdit(java.lang.String sXMLToEdit)
java.util.HashMap | getContextMenuMap()
org.dom4j.Document | getDOM4JDocument()
java.lang.String | getName()
java.lang.String | getNewTransform()
java.lang.String | getTransform()
int | getViewID()
java.lang.String | getViewWidth()
java.lang.String | getXSLPrefix()
boolean | isDefaultView()
void | setCaption(java.lang.String caption)
void | setContextMenuArea(MenuArea contextMenuArea)
void | setContextMenuMap(java.util.HashMap contextMenuMap)
void | setDefaultView(boolean defaultView)
void | setDOM4JDocument(org.dom4j.Document document)
void | setName(java.lang.String name)
void | setNewTransform(java.lang.String newTransform)
void | setTransform(java.lang.String transform)
void | setTRSObjectID(int id)
void | setViewWidth(java.lang.String viewWidth)
void | setXSLPrefix(java.lang.String _prefix)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

View

public View()
方法详细信息

getCaption

public java.lang.String getCaption()

setCaption

public void setCaption(java.lang.String caption)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String name)

getTransform

public java.lang.String getTransform()

setTransform

public void setTransform(java.lang.String transform)

addMenuArea

public void addMenuArea(MenuArea menuarea)

getContextMenuForBinding

public java.util.ArrayList getContextMenuForBinding(java.lang.String sBinding)

getContextMenuForXMLToEdit

public java.util.ArrayList getContextMenuForXMLToEdit(java.lang.String sXMLToEdit)

getContextMenuArea

public MenuArea getContextMenuArea()

setContextMenuArea

public void setContextMenuArea(MenuArea contextMenuArea)

getContextMenuMap

public java.util.HashMap getContextMenuMap()

setContextMenuMap

public void setContextMenuMap(java.util.HashMap contextMenuMap)

getViewWidth

public java.lang.String getViewWidth()

setViewWidth

public void setViewWidth(java.lang.String viewWidth)

isDefaultView

public boolean isDefaultView()

setDefaultView

public void setDefaultView(boolean defaultView)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getNewTransform

public java.lang.String getNewTransform()

setNewTransform

public void setNewTransform(java.lang.String newTransform)

getDOM4JDocument

public org.dom4j.Document getDOM4JDocument()

setDOM4JDocument

public void setDOM4JDocument(org.dom4j.Document document)

getViewID

public int getViewID()

setTRSObjectID

public void setTRSObjectID(int id)

getXSLPrefix

public java.lang.String getXSLPrefix()
返回：
the m_sXSLPrefix

setXSLPrefix

public void setXSLPrefix(java.lang.String _prefix)
参数：
_prefix - the m_sXSLPrefix to set
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.infoview.extract.manifest.CalculatedField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.CalculatedField
的使用

使用 CalculatedField 的软件包
com.trs.components.infoview.extract.manifest

com.trs.components.infoview.extract.manifest 中 CalculatedField 的使用

返回 CalculatedField 的 com.trs.components.infoview.extract.manifest 中的方法
 CalculatedField Manifest.getCalculatedField(java.lang.String sTarget)
返回计算目标为指定数据项的表达式，如果没有表达式以指定的数据项为目标，则返回null。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.manifest.DocumentSchema 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.DocumentSchema
的使用

使用 DocumentSchema 的软件包
com.trs.components.infoview.extract.manifest

com.trs.components.infoview.extract.manifest 中 DocumentSchema 的使用

返回 DocumentSchema 的 com.trs.components.infoview.extract.manifest 中的方法
 DocumentSchema Manifest.getRootSchema()
返回根Schema

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.manifest.FileNew 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.FileNew
的使用

没有 com.trs.components.infoview.extract.manifest.FileNew 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.manifest.FileProperty 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.FileProperty
的使用

使用 FileProperty 的软件包
com.trs.components.infoview.extract.manifest

com.trs.components.infoview.extract.manifest 中 FileProperty 的使用

返回 FileProperty 的 com.trs.components.infoview.extract.manifest 中的方法
 FileProperty PackageFile.getFileProperty(java.lang.String key)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.manifest.Manifest 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.Manifest
的使用

使用 Manifest 的软件包
com.trs.components.infoview.extract 抽取 MS InfoPath 的 XSN 文件的内容。

com.trs.components.infoview.extract 中 Manifest 的使用

参数类型为 Manifest 的 com.trs.components.infoview.extract 中的方法
 void XSLTViewBuilder.init(InfoViewConfig ivConfig, Manifest manifest, java.util.List groupList, DataType rootType, java.util.List typeList)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.manifest.MenuArea 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.MenuArea
的使用

使用 MenuArea 的软件包
com.trs.components.infoview.extract.manifest

com.trs.components.infoview.extract.manifest 中 MenuArea 的使用

返回 MenuArea 的 com.trs.components.infoview.extract.manifest 中的方法
MenuArea | MenuArea.build(org.dom4j.Element element)
MenuArea | View.getContextMenuArea()

参数类型为 MenuArea 的 com.trs.components.infoview.extract.manifest 中的方法
void | View.addMenuArea(MenuArea menuarea)
void | View.setContextMenuArea(MenuArea contextMenuArea)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.manifest.MenuButton 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.MenuButton
的使用

使用 MenuButton 的软件包
com.trs.components.infoview.extract.manifest

com.trs.components.infoview.extract.manifest 中 MenuButton 的使用

参数类型为 MenuButton 的 com.trs.components.infoview.extract.manifest 中的方法
 void MenuArea.addButton(MenuButton button)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.manifest.PackageFile 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.PackageFile
的使用

没有 com.trs.components.infoview.extract.manifest.PackageFile 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.extract.manifest.View 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.extract.manifest.View
的使用

使用 View 的软件包
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。
com.trs.components.infoview.extract.manifest |

com.trs.components.infoview.extract 中 View 的使用

参数类型为 View 的 com.trs.components.infoview.extract 中的方法
 void XSLTViewBuilder.build(View view)

com.trs.components.infoview.extract.manifest 中 View 的使用

返回 View 的 com.trs.components.infoview.extract.manifest 中的方法
 View Manifest.getDefaultView()
返回缺省视图对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


InfoviewDataImportFilter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.filter
类 InfoviewDataImportFilter

java.lang.Object
    继承者  javax.servlet.GenericServlet
        继承者  javax.servlet.http.HttpServlet
            继承者  com.trs.webframework.controler.servlet.ServiceControler
                继承者  com.trs.components.infoview.filter.InfoviewDataImportFilter
所有已实现的接口：
java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig
public class InfoviewDataImportFilter
extends ServiceControler

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
InfoviewDataImportFilter()
方法摘要
从类 javax.servlet.http.HttpServlet 继承的方法
service
从类 javax.servlet.GenericServlet 继承的方法
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, init, log, log
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoviewDataImportFilter

public InfoviewDataImportFilter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.filter
类
InfoviewDataImportFilter


com.trs.components.infoview.filter

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.filter

类摘要
InfoviewDataImportFilter Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.infoview.filter 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.filter 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • com.trs.webframework.controler.servlet.ServiceControler
          • com.trs.components.infoview.filter.InfoviewDataImportFilter


软件包 com.trs.components.infoview.filter 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.filter
的使用

没有 com.trs.components.infoview.filter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.filter.InfoviewDataImportFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.filter.InfoviewDataImportFilter
的使用

没有 com.trs.components.infoview.filter.InfoviewDataImportFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseInfoViewFieldValueCreator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 BaseInfoViewFieldValueCreator

java.lang.Object
    继承者  com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator

public abstract class BaseInfoViewFieldValueCreator
extends java.lang.Object

构造方法摘要
BaseInfoViewFieldValueCreator()
方法摘要
void | addInfoViewField(java.lang.String _sFieldName, java.lang.String _sValue) 增加一个普通的字段节点
void | addInfoViewRepeatData(java.lang.String _sFieldName, java.util.HashMap _hValue) 增加重复表的一行或者一个完整的重复表结构
void | createInfoviewXMLDataUpdator()
Document | getDocument()
java.util.List | getInfoViewFieldValue(java.lang.String sFieldName) 获取指定字段的值，因为可能是重复表字段，返回一个List
int | getRepeatFieldIndex(java.lang.String _sFieldName, java.lang.String _sFieldValue) 获取指定字段和值的序号位置
abstract int[] | registerRelateInfoViews() 注册值产生器相关的表单id列表
void | setDocument(Document _document)
void | setInfoViewFieldValue(java.lang.String _sFieldName, java.lang.String _sValue) 给一个普通的字段设置值
abstract void | setInfoViewFieldValueBeforeSaveDoc() 给当前表单数据对象的相关属性设置上自动产生的值
void | setInfoViewRepeatFieldValue(java.lang.String _sFieldName, java.lang.String _sValue, int index) 给指定位置的重复表字段设置值
void | updateDocument() 更新document内容
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseInfoViewFieldValueCreator

public BaseInfoViewFieldValueCreator()
方法详细信息

setDocument

public void setDocument(Document _document)

getDocument

public Document getDocument()

createInfoviewXMLDataUpdator

public void createInfoviewXMLDataUpdator()
                                  throws WCMException
抛出：
WCMException

setInfoViewFieldValue

public void setInfoViewFieldValue(java.lang.String _sFieldName,
                                  java.lang.String _sValue)
                           throws WCMException
给一个普通的字段设置值

参数：
_sFieldName -
_sValue -
抛出：
WCMException

getInfoViewFieldValue

public java.util.List getInfoViewFieldValue(java.lang.String sFieldName)
                                     throws WCMException
获取指定字段的值，因为可能是重复表字段，返回一个List

参数：
_sFieldName -
返回：
valueList
抛出：
WCMException

setInfoViewRepeatFieldValue

public void setInfoViewRepeatFieldValue(java.lang.String _sFieldName,
                                        java.lang.String _sValue,
                                        int index)
                                 throws WCMException
给指定位置的重复表字段设置值

参数：
_sFieldName -
_sValue -
抛出：
WCMException

addInfoViewRepeatData

public void addInfoViewRepeatData(java.lang.String _sFieldName,
                                  java.util.HashMap _hValue)
增加重复表的一行或者一个完整的重复表结构

参数：
_sFieldName - 包含一个完整路径的name 例如group9_group10
_hValue -

addInfoViewField

public void addInfoViewField(java.lang.String _sFieldName,
                             java.lang.String _sValue)
增加一个普通的字段节点

参数：
_sFieldName -
_sValue -

updateDocument

public void updateDocument()
                    throws WCMException
更新document内容

抛出：
WCMException

getRepeatFieldIndex

public int getRepeatFieldIndex(java.lang.String _sFieldName,
                               java.lang.String _sFieldValue)
                        throws WCMException
获取指定字段和值的序号位置

参数：
_sFieldName -
_sFieldValue -
返回：
抛出：
WCMException

registerRelateInfoViews

public abstract int[] registerRelateInfoViews()
注册值产生器相关的表单id列表

返回：
表单id数组

setInfoViewFieldValueBeforeSaveDoc

public abstract void setInfoViewFieldValueBeforeSaveDoc()
                                                 throws WCMException
给当前表单数据对象的相关属性设置上自动产生的值

参数：
_infoviewData - 当前表单数据对象
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ComplexFieldData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 ComplexFieldData

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.infoview.helper.ComplexFieldData
所有已实现的接口：
java.lang.Cloneable
public class ComplexFieldData
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ComplexFieldData()
构造函数：保留默认接口
方法摘要
static ComplexFieldData | createNewInstance() 产生当前对象[ComplexFieldData]的实例
static ComplexFieldData | findById(int _nId) 提取指定ID的对象
static ComplexFieldData | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getFieldId() 提取属性：FieldId
java.lang.String | getFieldName() 提取属性：FieldName
int | getFieldOrder()
java.lang.String | getFieldValue() 提取属性：FieldValue
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getInfoviewDataId() 提取属性：InfoviewDataId
int | getInfoviewId() 提取属性：InfoviewId
java.lang.String | getParentFlag() 提取属性：ParentFlag
CMyDateTime | getPostTime()
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setFieldId(java.lang.String _sFieldId) 设置属性：FieldId
boolean | setFieldName(java.lang.String _sFieldName) 设置属性：FieldName
boolean | setFieldOrder(int fieldOrder)
boolean | setFieldValue(java.lang.String _sFieldValue) 设置属性：FieldValue
boolean | setInfoviewDataId(int _nInfoviewDataId) 设置属性：InfoviewDataId
boolean | setInfoviewId(int _nInfoviewId) 设置属性：InfoviewId
boolean | setParentFlag(java.lang.String _sParentFlag) 设置属性：ParentFlag
boolean | setPostTime(CMyDateTime _postTime)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ComplexFieldData

public ComplexFieldData()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getInfoviewDataId

public int getInfoviewDataId()
提取属性：InfoviewDataId

返回：
InfoviewDataId

setInfoviewDataId

public boolean setInfoviewDataId(int _nInfoviewDataId)
                          throws WCMException
设置属性：InfoviewDataId

参数：
_nInfoviewDataId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldName

public java.lang.String getFieldName()
提取属性：FieldName

返回：
FieldName

setFieldName

public boolean setFieldName(java.lang.String _sFieldName)
                     throws WCMException
设置属性：FieldName

参数：
_sFieldName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldId

public java.lang.String getFieldId()
提取属性：FieldId

返回：
FieldId

setFieldId

public boolean setFieldId(java.lang.String _sFieldId)
                   throws WCMException
设置属性：FieldId

参数：
_sFieldId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getParentFlag

public java.lang.String getParentFlag()
提取属性：ParentFlag

返回：
ParentFlag

setParentFlag

public boolean setParentFlag(java.lang.String _sParentFlag)
                      throws WCMException
设置属性：ParentFlag

参数：
_sParentFlag - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldValue

public java.lang.String getFieldValue()
提取属性：FieldValue

返回：
FieldValue

setFieldValue

public boolean setFieldValue(java.lang.String _sFieldValue)
                      throws WCMException
设置属性：FieldValue

参数：
_sFieldValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getInfoviewId

public int getInfoviewId()
提取属性：InfoviewId

返回：
InfoviewId

setInfoviewId

public boolean setInfoviewId(int _nInfoviewId)
                      throws WCMException
设置属性：InfoviewId

参数：
_nInfoviewId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final ComplexFieldData findById(int _nId)
                                       throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ComplexFieldData createNewInstance()
                                                throws WCMException
产生当前对象[ComplexFieldData]的实例

返回：
当前对象的实例[ComplexFieldData]
抛出：
WCMException

findByKey

public static final ComplexFieldData findByKey(java.lang.Object _oKey)
                                        throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getPostTime

public CMyDateTime getPostTime()

setPostTime

public boolean setPostTime(CMyDateTime _postTime)
                    throws WCMException
抛出：
WCMException

getFieldOrder

public int getFieldOrder()

setFieldOrder

public boolean setFieldOrder(int fieldOrder)
                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComplexFieldDatas

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 ComplexFieldDatas

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.infoview.helper.ComplexFieldDatas

public class ComplexFieldDatas
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ComplexFieldDatas(User _currUser)
构造函数
ComplexFieldDatas(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ComplexFieldDatas | createNewInstance(User _currUser) 产生当前集合对象[ComplexFieldDatas]的实例
static ComplexFieldDatas | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ComplexFieldDatas | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ComplexFieldDatas]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComplexFieldDatas

public ComplexFieldDatas(User _currUser)
构造函数

另请参见：
ComplexFieldDatas( User _currUser, int _initCapacity, int _incCapacity );

ComplexFieldDatas

public ComplexFieldDatas(User _currUser,
                         int _initCapacity,
                         int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ComplexFieldDatas findByIds(User _currUser,
                                                java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ComplexFieldDatas）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ComplexFieldDatas openWCMObjs(User _currUser,
                                                  WCMFilter _filter)
                                           throws WCMException
通过指定一个Filter获取当前集合[ComplexFieldDatas]

参数：
_filter - 指定的Filter
返回：
当前集合[ComplexFieldDatas]
抛出：
WCMException

createNewInstance

public static ComplexFieldDatas createNewInstance(User _currUser)
产生当前集合对象[ComplexFieldDatas]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewChnlDocFilterHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 InfoViewChnlDocFilterHelper

java.lang.Object
    继承者  com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper

public class InfoViewChnlDocFilterHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
单表提取文档集合的功能对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoViewChnlDocFilterHelper(int _nInfoViewId)
方法摘要
WCMFilter | makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
WCMFilter | makeChannelFilter(Channel _channel, WCMFilter _filter)
WCMFilter | makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewChnlDocFilterHelper

public InfoViewChnlDocFilterHelper(int _nInfoViewId)
方法详细信息

makeChannelFilter

public WCMFilter makeChannelFilter(Channel _channel,
                                   WCMFilter _filter)
                            throws WCMException
参数：
_channel -
_filter -
抛出：
WCMException

makeChannelFilter

public WCMFilter makeChannelFilter(Channel _channel,
                                   WCMFilter _filter,
                                   boolean _bIncludeOrder,
                                   boolean _bFromRecycle)
                            throws WCMException
抛出：
WCMException

makeFilter

public WCMFilter makeFilter(WebSite _site,
                            WCMFilter _extraFilter,
                            boolean _bIncludeOrder,
                            boolean _bFromRecycle)

makeFilter

public WCMFilter makeFilter(WebSites _sites,
                            WCMFilter _extraFilter,
                            boolean _bIncludeOrder,
                            boolean _bFromRecycle)
参数：
_sites -
_extraFilter -
_bIncludeOrder -
返回：

makeChannelFilter

public WCMFilter makeChannelFilter(Channels _channels,
                                   WCMFilter _filter,
                                   boolean _bFromRecycle)
                            throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewFieldValueCreatorConfigStartServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 InfoViewFieldValueCreatorConfigStartServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.config.BaseConfigServer
            继承者  com.trs.components.infoview.helper.InfoViewFieldValueCreatorConfigStartServer
所有已实现的接口：
IServer
public class InfoViewFieldValueCreatorConfigStartServer
extends BaseConfigServer

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
InfoViewFieldValueCreatorConfigStartServer()
方法摘要
从类 com.trs.infra.config.BaseConfigServer 继承的方法
getConfigPath, setConfigPath
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewFieldValueCreatorConfigStartServer

public InfoViewFieldValueCreatorConfigStartServer()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewFieldValueCreatorFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 InfoViewFieldValueCreatorFactory

java.lang.Object
    继承者  com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory

public class InfoViewFieldValueCreatorFactory
extends java.lang.Object

构造方法摘要
InfoViewFieldValueCreatorFactory()
方法摘要
static java.util.List | createValueCreator(int nInfoViewId)
static void | registerValueCreator(BaseInfoViewFieldValueCreator convertor, int _nInfoViewId)
static void | registerValueCreator(java.lang.String _sCreatorClassName, int _nInfoViewId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewFieldValueCreatorFactory

public InfoViewFieldValueCreatorFactory()
方法详细信息

createValueCreator

public static java.util.List createValueCreator(int nInfoViewId)

registerValueCreator

public static void registerValueCreator(java.lang.String _sCreatorClassName,
                                        int _nInfoViewId)
                                 throws java.lang.Exception
参数：
_sCreatorClassName -
_nInfoViewId -
抛出：
java.lang.Exception

registerValueCreator

public static void registerValueCreator(BaseInfoViewFieldValueCreator convertor,
                                        int _nInfoViewId)
参数：
convertor -
_nInfoViewId -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewNewQueryHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 InfoViewNewQueryHelper

java.lang.Object
    继承者  com.trs.components.infoview.helper.InfoViewNewQueryHelper

public class InfoViewNewQueryHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
InfoViewNewQueryHelper()
方法摘要
static java.lang.String[] | getFieldNames(InfoView infoview, java.lang.String sSelectedFields)
static java.lang.String[] | getFieldsDisplay(java.lang.String[] arrFieldNames)
static java.lang.String | getFieldValue(InfoViewDocument _infoviewDoc, java.lang.String _sFieldName)
static InfoViewEmployMgr | getInfoViewEmployMgr()
static InfoViewDocuments | queryData(MethodContext _methodContext)
static InfoViewDocuments | queryData(RequestHelper requestHelper)
static java.lang.String | queryDataXML(MethodContext _context)
static java.lang.String | queryDataXML(RequestHelper _requestHelper)
static java.lang.String | queryDataXML2(MethodContext _context)
static java.lang.String | queryDataXML2(RequestHelper _requestHelper)
static java.lang.String | queryDataXML3(MethodContext _context)
static java.lang.String | queryDataXML3(RequestHelper _requestHelper)
static Documents | queryDocuments(MethodContext _methodContext)
static Documents | queryDocuments(RequestHelper requestHelper)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewNewQueryHelper

public InfoViewNewQueryHelper()
方法详细信息

getInfoViewEmployMgr

public static InfoViewEmployMgr getInfoViewEmployMgr()

getFieldNames

public static java.lang.String[] getFieldNames(InfoView infoview,
                                               java.lang.String sSelectedFields)
                                        throws WCMException
抛出：
WCMException

getFieldsDisplay

public static java.lang.String[] getFieldsDisplay(java.lang.String[] arrFieldNames)

queryData

public static InfoViewDocuments queryData(MethodContext _methodContext)
                                   throws CMyException
抛出：
CMyException

queryData

public static InfoViewDocuments queryData(RequestHelper requestHelper)
                                   throws CMyException
抛出：
CMyException

queryDocuments

public static Documents queryDocuments(MethodContext _methodContext)
                                throws CMyException
抛出：
CMyException

queryDocuments

public static Documents queryDocuments(RequestHelper requestHelper)
                                throws CMyException
抛出：
CMyException

queryDataXML

public static java.lang.String queryDataXML(MethodContext _context)
                                     throws CMyException
抛出：
CMyException

queryDataXML

public static java.lang.String queryDataXML(RequestHelper _requestHelper)
                                     throws CMyException
抛出：
CMyException

queryDataXML2

public static java.lang.String queryDataXML2(MethodContext _context)
                                      throws CMyException
抛出：
CMyException

queryDataXML2

public static java.lang.String queryDataXML2(RequestHelper _requestHelper)
                                      throws CMyException
抛出：
CMyException

queryDataXML3

public static java.lang.String queryDataXML3(MethodContext _context)
                                      throws CMyException
抛出：
CMyException

queryDataXML3

public static java.lang.String queryDataXML3(RequestHelper _requestHelper)
                                      throws CMyException
抛出：
CMyException

getFieldValue

public static java.lang.String getFieldValue(InfoViewDocument _infoviewDoc,
                                             java.lang.String _sFieldName)
                                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewQueryHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 InfoViewQueryHelper

java.lang.Object
    继承者  com.trs.components.infoview.helper.InfoViewQueryHelper

public class InfoViewQueryHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
InfoViewQueryHelper()
方法摘要
static int | getDocumentStatus(java.lang.String sLuceneId)
static java.lang.String[] | getFieldDisplay(java.lang.String[] sFieldName)
static java.lang.String | getStatusName(int status)
static void | main(java.lang.String[] args)
static void | testCase1()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewQueryHelper

public InfoViewQueryHelper()
方法详细信息

getFieldDisplay

public static java.lang.String[] getFieldDisplay(java.lang.String[] sFieldName)

getDocumentStatus

public static int getDocumentStatus(java.lang.String sLuceneId)
                             throws WCMException
抛出：
WCMException

getStatusName

public static java.lang.String getStatusName(int status)
                                      throws WCMException
抛出：
WCMException

testCase1

public static void testCase1()

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewTemplateHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.helper
类 InfoViewTemplateHelper

java.lang.Object
    继承者  com.trs.components.infoview.helper.InfoViewTemplateHelper

public class InfoViewTemplateHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
InfoViewTemplateHelper()
方法摘要
static java.lang.String | generateContent(MethodContext _oContext, User _currUser)
static java.lang.String | getContent(int nChannelId, java.lang.String sTemplateContent, java.lang.String sKey)
static Template | getDetailTemplate(PublishPageContext _pageContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewTemplateHelper

public InfoViewTemplateHelper()
方法详细信息

generateContent

public static java.lang.String generateContent(MethodContext _oContext,
                                               User _currUser)
                                        throws WCMException
抛出：
WCMException

getDetailTemplate

public static Template getDetailTemplate(PublishPageContext _pageContext)
                                  throws WCMException
抛出：
WCMException

getContent

public static java.lang.String getContent(int nChannelId,
                                          java.lang.String sTemplateContent,
                                          java.lang.String sKey)
                                   throws WCMException
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.helper
类
BaseInfoViewFieldValueCreator
ComplexFieldData
ComplexFieldDatas
InfoViewChnlDocFilterHelper
InfoViewFieldValueCreatorConfigStartServer
InfoViewFieldValueCreatorFactory
InfoViewNewQueryHelper
InfoViewQueryHelper
InfoViewTemplateHelper


com.trs.components.infoview.helper

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.helper

类摘要
BaseInfoViewFieldValueCreator |
ComplexFieldData |
ComplexFieldDatas |
InfoViewChnlDocFilterHelper | Title: TRS 内容协作平台（TRS WCM） Description: 单表提取文档集合的功能对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewFieldValueCreatorConfigStartServer |
InfoViewFieldValueCreatorFactory |
InfoViewNewQueryHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewQueryHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewTemplateHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.infoview.helper 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.helper 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.infoview.helper.ComplexFieldData
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.infoview.helper.ComplexFieldDatas
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.config.BaseConfigServer
        • com.trs.components.infoview.helper.InfoViewFieldValueCreatorConfigStartServer
    • com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper
    • com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory
    • com.trs.components.infoview.helper.InfoViewNewQueryHelper
    • com.trs.components.infoview.helper.InfoViewQueryHelper
    • com.trs.components.infoview.helper.InfoViewTemplateHelper


软件包 com.trs.components.infoview.helper 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.helper
的使用

使用 com.trs.components.infoview.helper 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview 使用的 com.trs.components.infoview.helper 中的类
ComplexFieldData

com.trs.components.infoview.helper 使用的 com.trs.components.infoview.helper 中的类
BaseInfoViewFieldValueCreator
ComplexFieldData
ComplexFieldDatas

com.trs.components.infoview.persistent 使用的 com.trs.components.infoview.helper 中的类
InfoViewChnlDocFilterHelper
Title: TRS 内容协作平台（TRS WCM）
Description:
单表提取文档集合的功能对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator
的使用

使用 BaseInfoViewFieldValueCreator 的软件包
com.trs.components.infoview.helper

com.trs.components.infoview.helper 中 BaseInfoViewFieldValueCreator 的使用

参数类型为 BaseInfoViewFieldValueCreator 的 com.trs.components.infoview.helper 中的方法
static void InfoViewFieldValueCreatorFactory.registerValueCreator(BaseInfoViewFieldValueCreator convertor, int _nInfoViewId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.ComplexFieldData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.ComplexFieldData
的使用

使用 ComplexFieldData 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.helper |

com.trs.components.infoview 中 ComplexFieldData 的使用

返回 ComplexFieldData 的 com.trs.components.infoview 中的方法
static ComplexFieldData InfoViewHelper.makeComplexFieldData(java.lang.String _sFieldId, java.lang.String _sFieldName, java.lang.String _sVal, java.lang.String _sParentFlag, InfoViewData _docData)

com.trs.components.infoview.helper 中 ComplexFieldData 的使用

返回 ComplexFieldData 的 com.trs.components.infoview.helper 中的方法
static ComplexFieldData | ComplexFieldData.createNewInstance() 产生当前对象[ComplexFieldData]的实例
static ComplexFieldData | ComplexFieldData.findById(int _nId) 提取指定ID的对象
static ComplexFieldData | ComplexFieldData.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.ComplexFieldDatas 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.ComplexFieldDatas
的使用

使用 ComplexFieldDatas 的软件包
com.trs.components.infoview.helper

com.trs.components.infoview.helper 中 ComplexFieldDatas 的使用

返回 ComplexFieldDatas 的 com.trs.components.infoview.helper 中的方法
static ComplexFieldDatas | ComplexFieldDatas.createNewInstance(User _currUser) 产生当前集合对象[ComplexFieldDatas]的实例
static ComplexFieldDatas | ComplexFieldDatas.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ComplexFieldDatas | ComplexFieldDatas.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ComplexFieldDatas]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper
的使用

使用 InfoViewChnlDocFilterHelper 的软件包
com.trs.components.infoview.persistent 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview.persistent 中 InfoViewChnlDocFilterHelper 的使用

返回 InfoViewChnlDocFilterHelper 的 com.trs.components.infoview.persistent 中的方法
 InfoViewChnlDocFilterHelper InfoViewDocuments.getInfoViewChnlDocFilterHelper()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorConfigStartServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorConfigStartServer
的使用

没有 com.trs.components.infoview.helper.InfoViewFieldValueCreatorConfigStartServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory
的使用

没有 com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.InfoViewNewQueryHelper
的使用

没有 com.trs.components.infoview.helper.InfoViewNewQueryHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.InfoViewQueryHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.InfoViewQueryHelper
的使用

没有 com.trs.components.infoview.helper.InfoViewQueryHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.helper.InfoViewTemplateHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.helper.InfoViewTemplateHelper
的使用

没有 com.trs.components.infoview.helper.InfoViewTemplateHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


InfoViewDataHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.mad
接口 InfoViewDataHelper

所有已知实现类：
InfoViewDataHelperImpl
public interface InfoViewDataHelper

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

方法摘要
java.lang.String | buildContent(InfoView infoView, Document _document, org.dom4j.Document dom4jDocument)
java.lang.String | getFieldValue(Document doc, java.lang.String fieldName)
java.lang.Object | getKEY_DOM4J()
java.lang.String | getProperty(Document doc, java.lang.String groupName)

方法详细信息

getFieldValue

java.lang.String getFieldValue(Document doc,
                               java.lang.String fieldName)
                               throws WCMException
抛出：
WCMException

getProperty

java.lang.String getProperty(Document doc,
                             java.lang.String groupName)
                             throws WCMException
抛出：
WCMException

buildContent

java.lang.String buildContent(InfoView infoView,
                              Document _document,
                              org.dom4j.Document dom4jDocument)
                              throws WCMException
抛出：
WCMException

getKEY_DOM4J

java.lang.Object getKEY_DOM4J()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InfoViewDataHelperImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.mad
类 InfoViewDataHelperImpl

java.lang.Object
    继承者  com.trs.components.infoview.mad.InfoViewDataHelperImpl
所有已实现的接口：
InfoViewDataHelper
public class InfoViewDataHelperImpl
extends java.lang.Object
implements InfoViewDataHelper

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

构造方法摘要
InfoViewDataHelperImpl()
方法摘要
java.lang.String | buildContent(InfoView infoView, Document _document, org.dom4j.Document dom4jDocument)
java.lang.String | getFieldValue(Document doc, java.lang.String fieldName)
java.lang.Object | getKEY_DOM4J()
java.lang.String | getProperty(Document doc, java.lang.String groupName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewDataHelperImpl

public InfoViewDataHelperImpl()
方法详细信息

getFieldValue

public java.lang.String getFieldValue(Document doc,
                                      java.lang.String fieldName)
                               throws WCMException
指定者：
接口 InfoViewDataHelper 中的 getFieldValue
抛出：
WCMException

getProperty

public java.lang.String getProperty(Document doc,
                                    java.lang.String groupName)
                             throws WCMException
指定者：
接口 InfoViewDataHelper 中的 getProperty
抛出：
WCMException

buildContent

public java.lang.String buildContent(InfoView infoView,
                                     Document _document,
                                     org.dom4j.Document dom4jDocument)
                              throws WCMException
指定者：
接口 InfoViewDataHelper 中的 buildContent
抛出：
WCMException

getKEY_DOM4J

public java.lang.Object getKEY_DOM4J()
指定者：
接口 InfoViewDataHelper 中的 getKEY_DOM4J
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewQueryHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.mad
接口 InfoViewQueryHelper

所有已知实现类：
InfoViewQueryHelperImpl
public interface InfoViewQueryHelper

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

方法摘要
int | findCurrDocIdBySNO(MethodContext _context)
Documents | getDocuments(Channel _channel, MethodContext _context)

方法详细信息

findCurrDocIdBySNO

int findCurrDocIdBySNO(MethodContext _context)
                       throws java.lang.Throwable
抛出：
java.lang.Throwable

getDocuments

Documents getDocuments(Channel _channel,
                       MethodContext _context)
                       throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewQueryHelperImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.mad
类 InfoViewQueryHelperImpl

java.lang.Object
    继承者  com.trs.components.infoview.mad.InfoViewQueryHelperImpl
所有已实现的接口：
InfoViewQueryHelper
public class InfoViewQueryHelperImpl
extends java.lang.Object
implements InfoViewQueryHelper

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

构造方法摘要
InfoViewQueryHelperImpl()
方法摘要
int | findCurrDocIdBySNO(MethodContext _context)
Documents | getDocuments(Channel _channel, MethodContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewQueryHelperImpl

public InfoViewQueryHelperImpl()
方法详细信息

findCurrDocIdBySNO

public int findCurrDocIdBySNO(MethodContext _context)
                       throws java.lang.Throwable
指定者：
接口 InfoViewQueryHelper 中的 findCurrDocIdBySNO
抛出：
java.lang.Throwable

getDocuments

public Documents getDocuments(Channel _channel,
                              MethodContext _context)
                       throws java.lang.Throwable
指定者：
接口 InfoViewQueryHelper 中的 getDocuments
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.mad
接口
InfoViewDataHelper
InfoViewQueryHelper
类
InfoViewDataHelperImpl
InfoViewQueryHelperImpl


com.trs.components.infoview.mad

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.mad

接口摘要
InfoViewDataHelper | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewQueryHelper | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
InfoViewDataHelperImpl | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewQueryHelperImpl | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.infoview.mad 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.mad 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.infoview.mad.InfoViewDataHelperImpl (implements com.trs.components.infoview.mad.InfoViewDataHelper)
    • com.trs.components.infoview.mad.InfoViewQueryHelperImpl (implements com.trs.components.infoview.mad.InfoViewQueryHelper)

接口分层结构

  • com.trs.components.infoview.mad.InfoViewDataHelper
  • com.trs.components.infoview.mad.InfoViewQueryHelper


软件包 com.trs.components.infoview.mad 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.mad
的使用

使用 com.trs.components.infoview.mad 的软件包
com.trs.components.infoview.mad

com.trs.components.infoview.mad 使用的 com.trs.components.infoview.mad 中的类
InfoViewDataHelper
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewQueryHelper
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.infoview.mad.InfoViewDataHelper 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.infoview.mad.InfoViewDataHelper
的使用

使用 InfoViewDataHelper 的软件包
com.trs.components.infoview.mad

com.trs.components.infoview.mad 中 InfoViewDataHelper 的使用

实现 InfoViewDataHelper 的 com.trs.components.infoview.mad 中的类
 class InfoViewDataHelperImpl
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.mad.InfoViewDataHelperImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.mad.InfoViewDataHelperImpl
的使用

没有 com.trs.components.infoview.mad.InfoViewDataHelperImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.infoview.mad.InfoViewQueryHelper 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.infoview.mad.InfoViewQueryHelper
的使用

使用 InfoViewQueryHelper 的软件包
com.trs.components.infoview.mad

com.trs.components.infoview.mad 中 InfoViewQueryHelper 的使用

实现 InfoViewQueryHelper 的 com.trs.components.infoview.mad 中的类
 class InfoViewQueryHelperImpl
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.mad.InfoViewQueryHelperImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.mad.InfoViewQueryHelperImpl
的使用

没有 com.trs.components.infoview.mad.InfoViewQueryHelperImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


InfoView

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoView

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.infoview.persistent.InfoView
所有已实现的接口：
java.lang.Cloneable
public class InfoView
extends CMSObj

TODO Add javadoc for InfoView

作者：
Martin (Fu Chengrui)

字段摘要
static java.lang.String | DB_ID_NAME TODO Add javadoc for field DB_ID_NAME
static java.lang.String | DB_TABLE_NAME TODO Add javadoc for field DB_TABLE_NAME
static int | OBJ_TYPE TODO Add javadoc for field OBJ_TYPE
构造方法摘要
InfoView()
TODO Add javadoc for InfoView
方法摘要
void | addField(InfoViewField field)
void | addGroup(InfoViewGroup group)
java.util.List | allFields()
java.util.List | allGroups()
static InfoView | createNewInstance() 产生对象InfoView的实例
static InfoView | findById(int id) 提取指定ID的对象
java.lang.String | getAllFileList()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc()
java.lang.String | getDocContentPattern() 获取正文构造器字段
InfoViewField | getField(java.lang.String name)
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getInfoPathFile()
java.lang.String | getInfoViewPath()
java.lang.String | getName()
java.lang.String | getNewInfoPathFile()
java.lang.String | getNewXSLTFile()
java.lang.String | getNoticeContentPattern() 获取回复内容模板
java.lang.String | getNoticeRelatedField() 获取回复通知目标相关联的表单项
java.lang.String | getNoticeSubjectPattern() 获取回复主题的模板
java.lang.String | getOutlineDBFields() 获取概览DB字段
java.lang.String | getOutlineFields() 获取概览字段
java.lang.String | getSchemaFile()
java.lang.String | getSearchDBFields() 获取检索DB字段
java.lang.String | getSearchFields() 获取检索字段
java.lang.String | getSerialField()
java.lang.String | getSerialPattern()
int | getSerialPeriod()
int | getSiteID()
java.lang.String | getTemplateFile()
java.lang.String | getTemplateFileContent()
java.lang.String | getTitlePattern()
java.lang.String | getTrueTableName()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
java.lang.String | getXSLTFile()
boolean | hasDocSerial()
boolean | isReplyNoticeRequired() 是否需要回复通知
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | removeField(InfoViewField field)
boolean | setAllFileList(java.lang.String _sAllFileList)
boolean | setDesc(java.lang.String _sDesc)
boolean | setDocContentPattern(java.lang.String _sDocContentPattern) 设置正文构造器字段
boolean | setDocSerial(boolean zDocSerial)
boolean | setInfoPathFile(java.lang.String _sInfoPathFile)
boolean | setInfoViewPath(java.lang.String _sInfoViewPath)
boolean | setName(java.lang.String _sName)
boolean | setNewXSLTFilet(java.lang.String _sXSLTFile)
boolean | setNoticeContentPattern(java.lang.String _sContentPattern) 设置回复主题模板
boolean | setNoticeRelatedField(java.lang.String _sRelatedField) 获取回复通知目标的相关表单项
boolean | setNoticeSubjectPattern(java.lang.String _sSubPattern) 设置回复主题模板
boolean | setOutlineDBFields(java.lang.String _sOutlineFields) 设置概览DB字段
boolean | setOutlineFields(java.lang.String _sOutlineFields) 设置概览字段
boolean | setReplyNoticeRequired(boolean _zRequired) 设置是否需要回复通知
boolean | setSchemaFile(java.lang.String _sSchemaFile)
boolean | setSearchDBFields(java.lang.String _sSearchFields) 设置检索DB字段
boolean | setSearchFields(java.lang.String _sSearchFields) 设置检索字段
boolean | setSerialField(java.lang.String _sTemplateFile)
boolean | setSerialPattern(java.lang.String _sTemplateFile)
boolean | setSerialPeriod(int _iSerialPeriod)
boolean | setSiteID(int _iSiteID)
boolean | setTemplateFile(java.lang.String _sTemplateFile)
boolean | setTitlePattern(java.lang.String _sTitlePattern)
boolean | setXSLTFilet(java.lang.String _sXSLTFile)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO Add javadoc for field OBJ_TYPE

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
TODO Add javadoc for field DB_TABLE_NAME

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
TODO Add javadoc for field DB_ID_NAME

另请参见：
常量字段值
构造方法详细信息

InfoView

public InfoView()
TODO Add javadoc for InfoView

方法详细信息

findById

public static final InfoView findById(int id)
                               throws WCMException
提取指定ID的对象

参数：
id - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final InfoView createNewInstance()
                                        throws WCMException
产生对象InfoView的实例

返回：
BigTableDefine的实例
抛出：
WCMException - 如果发生错误

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

addField

public void addField(InfoViewField field)

getField

public InfoViewField getField(java.lang.String name)

allFields

public java.util.List allFields()
                         throws WCMException
抛出：
WCMException

allGroups

public java.util.List allGroups()
                         throws WCMException
抛出：
WCMException

addGroup

public void addGroup(InfoViewGroup group)

removeField

public void removeField(InfoViewField field)

getSiteID

public int getSiteID()

setSiteID

public boolean setSiteID(int _iSiteID)
                  throws WCMException
抛出：
WCMException

getName

public java.lang.String getName()

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
抛出：
WCMException

getTitlePattern

public java.lang.String getTitlePattern()

setTitlePattern

public boolean setTitlePattern(java.lang.String _sTitlePattern)
                        throws WCMException
抛出：
WCMException

getInfoViewPath

public java.lang.String getInfoViewPath()

setInfoViewPath

public boolean setInfoViewPath(java.lang.String _sInfoViewPath)
                        throws WCMException
抛出：
WCMException

getInfoPathFile

public java.lang.String getInfoPathFile()

setInfoPathFile

public boolean setInfoPathFile(java.lang.String _sInfoPathFile)
                        throws WCMException
抛出：
WCMException

getNewInfoPathFile

public java.lang.String getNewInfoPathFile()

getAllFileList

public java.lang.String getAllFileList()

setAllFileList

public boolean setAllFileList(java.lang.String _sAllFileList)
                       throws WCMException
抛出：
WCMException

getXSLTFile

public java.lang.String getXSLTFile()

setXSLTFilet

public boolean setXSLTFilet(java.lang.String _sXSLTFile)
                     throws WCMException
抛出：
WCMException

getNewXSLTFile

public java.lang.String getNewXSLTFile()

setNewXSLTFilet

public boolean setNewXSLTFilet(java.lang.String _sXSLTFile)
                        throws WCMException
抛出：
WCMException

getSchemaFile

public java.lang.String getSchemaFile()

setSchemaFile

public boolean setSchemaFile(java.lang.String _sSchemaFile)
                      throws WCMException
抛出：
WCMException

getTemplateFile

public java.lang.String getTemplateFile()

setTemplateFile

public boolean setTemplateFile(java.lang.String _sTemplateFile)
                        throws WCMException
抛出：
WCMException

getTemplateFileContent

public java.lang.String getTemplateFileContent()
                                        throws WCMException
抛出：
WCMException

hasDocSerial

public boolean hasDocSerial()

setDocSerial

public boolean setDocSerial(boolean zDocSerial)
                     throws WCMException
抛出：
WCMException

getSerialPattern

public java.lang.String getSerialPattern()

setSerialPattern

public boolean setSerialPattern(java.lang.String _sTemplateFile)
                         throws WCMException
抛出：
WCMException

getSerialPeriod

public int getSerialPeriod()

setSerialPeriod

public boolean setSerialPeriod(int _iSerialPeriod)
                        throws WCMException
抛出：
WCMException

getSerialField

public java.lang.String getSerialField()

setSerialField

public boolean setSerialField(java.lang.String _sTemplateFile)
                       throws WCMException
抛出：
WCMException

isReplyNoticeRequired

public boolean isReplyNoticeRequired()
是否需要回复通知

返回：

setReplyNoticeRequired

public boolean setReplyNoticeRequired(boolean _zRequired)
                               throws WCMException
设置是否需要回复通知

参数：
_zRequired -
返回：
抛出：
WCMException

getNoticeRelatedField

public java.lang.String getNoticeRelatedField()
获取回复通知目标相关联的表单项

返回：
可能是表单中的某一项数据
也可能是系统用户(${user})

setNoticeRelatedField

public boolean setNoticeRelatedField(java.lang.String _sRelatedField)
                              throws WCMException
获取回复通知目标的相关表单项

参数：
_sRelatedField -
返回：
抛出：
WCMException

getNoticeSubjectPattern

public java.lang.String getNoticeSubjectPattern()
获取回复主题的模板

返回：

setNoticeSubjectPattern

public boolean setNoticeSubjectPattern(java.lang.String _sSubPattern)
                                throws WCMException
设置回复主题模板

参数：
_sSubPattern -
返回：
抛出：
WCMException

getNoticeContentPattern

public java.lang.String getNoticeContentPattern()
获取回复内容模板

返回：

setNoticeContentPattern

public boolean setNoticeContentPattern(java.lang.String _sContentPattern)
                                throws WCMException
设置回复主题模板

参数：
_sContentPattern -
返回：
抛出：
WCMException

getOutlineFields

public java.lang.String getOutlineFields()
获取概览字段

返回：

setOutlineFields

public boolean setOutlineFields(java.lang.String _sOutlineFields)
                         throws WCMException
设置概览字段

参数：
_sOutlineFields -
返回：
抛出：
WCMException

getSearchFields

public java.lang.String getSearchFields()
获取检索字段

返回：

setSearchFields

public boolean setSearchFields(java.lang.String _sSearchFields)
                        throws WCMException
设置检索字段

参数：
_sSearchFields -
返回：
抛出：
WCMException

getDocContentPattern

public java.lang.String getDocContentPattern()
获取正文构造器字段

返回：

setDocContentPattern

public boolean setDocContentPattern(java.lang.String _sDocContentPattern)
                             throws WCMException
设置正文构造器字段

参数：
_sDocContentPattern -
返回：
抛出：
WCMException

getOutlineDBFields

public java.lang.String getOutlineDBFields()
获取概览DB字段

返回：

setOutlineDBFields

public boolean setOutlineDBFields(java.lang.String _sOutlineFields)
                           throws WCMException
设置概览DB字段

参数：
_sOutlineFields -
返回：
抛出：
WCMException

getSearchDBFields

public java.lang.String getSearchDBFields()
获取检索DB字段

返回：

setSearchDBFields

public boolean setSearchDBFields(java.lang.String _sSearchFields)
                          throws WCMException
设置检索DB字段

参数：
_sSearchFields -
返回：
抛出：
WCMException

getTrueTableName

public java.lang.String getTrueTableName()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InfoViewData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewData

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.infoview.persistent.InfoViewData
所有已实现的接口：
java.lang.Cloneable
public class InfoViewData
extends CMSObj

字段摘要
static int OBJ_TYPE
构造方法摘要
InfoViewData()
方法摘要
static InfoViewData | createNewInstance() 产生当前对象[MetaViewData]的实例
static InfoViewData | createNewInstance(int _nInfoViewId, int _nDocumentId)
static InfoViewData | findByDocument(Document document)
static InfoViewData | findById(InfoView _oInfoView, int _nId) 提取指定ID的对象
static InfoViewData | findById(int _nDocumentId)
static InfoViewData | findById2(int _nInfoViewId, int _nDocumentId)
static InfoViewData | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Channel | getChannel()
int | getChannelId()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
Document | getDocument()
int | getDocumentId()
java.lang.String | getIdFieldName() 获得Id字段名。
int | getInfoViewId()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | setChannelId(int _nChannelId)
void | setDocumentId(int _nDocId)
void | setId(int _nId) 设置对象ID
void | setIdFieldName(java.lang.String _sIdFieldName)
void | setInfoViewId(int _nInfoViewId)
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值
构造方法详细信息

InfoViewData

public InfoViewData()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

setIdFieldName

public void setIdFieldName(java.lang.String _sIdFieldName)

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：

findById

public static final InfoViewData findById(InfoView _oInfoView,
                                          int _nId)
                                   throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final InfoViewData createNewInstance()
                                            throws WCMException
产生当前对象[MetaViewData]的实例

返回：
当前对象的实例[MetaViewData]
抛出：
WCMException

createNewInstance

public static final InfoViewData createNewInstance(int _nInfoViewId,
                                                   int _nDocumentId)
                                            throws WCMException
抛出：
WCMException

findByKey

public static final InfoViewData findByKey(java.lang.Object _oKey)
                                    throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getInfoViewId

public int getInfoViewId()
返回：

setInfoViewId

public void setInfoViewId(int _nInfoViewId)
                   throws WCMException
抛出：
WCMException

setDocumentId

public void setDocumentId(int _nDocId)
                   throws WCMException
抛出：
WCMException

setChannelId

public void setChannelId(int _nChannelId)
                  throws WCMException
抛出：
WCMException

getChannelId

public int getChannelId()

getChannel

public Channel getChannel()
                   throws WCMException
抛出：
WCMException

getDocument

public Document getDocument()
                     throws WCMException
抛出：
WCMException

getDocumentId

public int getDocumentId()

findById

public static InfoViewData findById(int _nDocumentId)
                             throws WCMException
抛出：
WCMException

findByDocument

public static InfoViewData findByDocument(Document document)
                                   throws WCMException
抛出：
WCMException

findById2

public static InfoViewData findById2(int _nInfoViewId,
                                     int _nDocumentId)
                              throws WCMException
抛出：
WCMException

setId

public void setId(int _nId)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDatas

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewDatas

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.infoview.persistent.InfoViewDatas

public class InfoViewDatas
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
InfoViewDatas()
InfoViewDatas(int infoViewId)
InfoViewDatas(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static InfoViewDatas | createNewInstance(int _nInfoViewId)
static InfoViewDatas | findByDocIds(User _currUser, int _nInfoViewId, java.lang.String _sDocumentIds)
static InfoViewDatas | findByIds(User _currUser, int _nInfoViewId, java.lang.String _sInfoViewDataIds)
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
int | getInfoViewId()
BaseObjs | newInstance() 生成新的集合对象实例
static InfoViewDatas | openWCMObjs(int nInfoViewId, WCMFilter _filter)
void | setIdFieldName(java.lang.String _sIdFieldName)
void | setInfoViewId(int infoViewId)
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewDatas

public InfoViewDatas()

InfoViewDatas

public InfoViewDatas(int infoViewId)

InfoViewDatas

public InfoViewDatas(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
参数：
_initCapacity -
_incCapacity -
方法详细信息

getInfoViewId

public int getInfoViewId()

setInfoViewId

public void setInfoViewId(int infoViewId)

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObjs 复制的描述
取对象数据存储的数据表名称

返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

setIdFieldName

public void setIdFieldName(java.lang.String _sIdFieldName)

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final InfoViewDatas findByIds(User _currUser,
                                            int _nInfoViewId,
                                            java.lang.String _sInfoViewDataIds)
                                     throws WCMException
抛出：
WCMException

findByDocIds

public static final InfoViewDatas findByDocIds(User _currUser,
                                               int _nInfoViewId,
                                               java.lang.String _sDocumentIds)
                                        throws WCMException
抛出：
WCMException

openWCMObjs

public static final InfoViewDatas openWCMObjs(int nInfoViewId,
                                              WCMFilter _filter)
                                       throws WCMException
抛出：
WCMException

createNewInstance

public static InfoViewDatas createNewInstance(int _nInfoViewId)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDocument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewDocument

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.ViewDocument
                继承者  com.trs.components.infoview.persistent.InfoViewDocument
所有已实现的接口：
java.lang.Cloneable
public class InfoViewDocument
extends ViewDocument

字段摘要
从类 com.trs.components.wcm.content.ViewDocument 继承的字段
DB_TABLE_NAME, ID_FIELD_NAME, KEY_CHANNEL_RIGHTVALUES, KEY_CURR_HOST
构造方法摘要
InfoViewDocument(java.util.HashMap _hsMap)
方法摘要
void | cloneDocumentProperties(Document _oDoc)
static InfoViewDocument | findByDocument(Document _oDocument, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument, java.lang.String _sSelectFieldsOfInfoView)
static InfoViewDocument | findById(BaseChannel _host, int _nChnlDocRecId, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument, int _nInfoViewId, java.lang.String _sSelectFieldsOfInfoView) 获取指定Id的ViewDocument
static InfoViewDocument | findSelfByDocument(Document _oDocument)
ChnlDoc | getChnlDoc()
int | getDocId()
Document | getDocument()
int | getId() 获取对象的ID
InfoViewData | getInfoViewData()
int | getInfoViewId()
java.lang.String | getTrueTableName()
boolean | isInfoViewDocument()
java.lang.String | toString()
从类 com.trs.components.wcm.content.ViewDocument 继承的方法
cloneDocumentProperties, findById, getChannel, getChannelId, getChnlDocProperties, getChnlDocProperty, getChnlDocProperty, getContent, getCurrChannelOrSite, getDbTableName, getDocChannel, getDocChannelId, getHtmlContent, getHtmlContentWithImgFilter, getHtmlContentWithImgFilter, getIdFieldName, getPubHtmlContent, getPublicCache, getRightValue, getSource, getSourceId, getStatus, getStatusId, getType, getTypeString, getWCMType, hasRight, isRightDefined, isTopped, isValid, readChnlDocPropertyFromRs, setChnlDocProperty, setDocChannel, setDocId, setId, setPublicCache
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InfoViewDocument

public InfoViewDocument(java.util.HashMap _hsMap)
方法详细信息

getChnlDoc

public ChnlDoc getChnlDoc()
                   throws WCMException
抛出：
WCMException

getInfoViewData

public InfoViewData getInfoViewData()
                             throws WCMException
抛出：
WCMException

getDocument

public Document getDocument()
                     throws WCMException
抛出：
WCMException

getId

public int getId()
从类 BaseObj 复制的描述
获取对象的ID

覆盖：
类 BaseObj 中的 getId
返回：

getDocId

public int getDocId()
覆盖：
类 ViewDocument 中的 getDocId

getInfoViewId

public int getInfoViewId()

isInfoViewDocument

public boolean isInfoViewDocument()

getTrueTableName

public java.lang.String getTrueTableName()

findSelfByDocument

public static InfoViewDocument findSelfByDocument(Document _oDocument)
                                           throws WCMException
抛出：
WCMException

cloneDocumentProperties

public void cloneDocumentProperties(Document _oDoc)

findByDocument

public static InfoViewDocument findByDocument(Document _oDocument,
                                              java.lang.String _sSelectFieldsOfChnlDoc,
                                              java.lang.String _sSelectFieldsOfDocument,
                                              java.lang.String _sSelectFieldsOfInfoView)
                                       throws WCMException
抛出：
WCMException

findById

public static InfoViewDocument findById(BaseChannel _host,
                                        int _nChnlDocRecId,
                                        java.lang.String _sSelectFieldsOfChnlDoc,
                                        java.lang.String _sSelectFieldsOfDocument,
                                        int _nInfoViewId,
                                        java.lang.String _sSelectFieldsOfInfoView)
                                 throws WCMException
获取指定Id的ViewDocument

参数：
_host -
_nChnlDocRecId -
_sSelectFieldsOfChnlDoc -
_sSelectFieldsOfDocument -
返回：
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDocuments

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewDocuments

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.ViewDocuments
                继承者  com.trs.components.infoview.persistent.InfoViewDocuments

public class InfoViewDocuments
extends ViewDocuments

字段摘要
static java.lang.String DEFAULT_DOCUMENT_SELECTFIELDS
从类 com.trs.components.wcm.content.ViewDocuments 继承的字段
DB_TABLE_NAME, ID_FIELD_NAME, ID_NOT_LOAD, MAX_FETCH_SIZE, QUERY_ACCORD_DOCUMENT_RIGHT
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, IS_DEBUG
构造方法摘要
InfoViewDocuments(User _currUser)
构造函数
InfoViewDocuments(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static InfoViewDocuments | createNewInstance(User _currUser) 产生一个当前集合对象[ChnlDocs]的实例
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
InfoViewChnlDocFilterHelper | getInfoViewChnlDocFilterHelper()
int | getInfoViewId()
java.lang.String | getSelectFieldsFromInfoView()
BaseObjs | newInstance() 生成新的集合对象实例
void | setInfoViewId(int _nInfoViewId)
void | setSelectFields(java.lang.String _sSelectFieldFromChnlDoc, java.lang.String _sSelectFieldsFromDocument, java.lang.String _sSelectFieldFromInfoView)
void | setSelectFieldsFromInfoView(java.lang.String _sSelectFieldFromInfoView)
java.lang.String | toString()
从类 com.trs.components.wcm.content.ViewDocuments 继承的方法
canSort, getCurrChannelOrSite, getPublicCache, getRightIndex, getSelectFieldsFromDocument, isFromRecycle, open, open, open, open, open, openTRSServerViewDocuments, openViewDocuments, setFromRecycle, setNeedWithAuthFilter, setRightIndex, setSelectFields, setSelectFieldsFromChnlDoc, setSelectFieldsFromDocument
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_DOCUMENT_SELECTFIELDS

public static final java.lang.String DEFAULT_DOCUMENT_SELECTFIELDS
另请参见：
常量字段值
构造方法详细信息

InfoViewDocuments

public InfoViewDocuments(User _currUser)
构造函数

另请参见：
ChnlDocs( User _currUser, int _initCapacity, int _incCapacity );

InfoViewDocuments

public InfoViewDocuments(User _currUser,
                         int _initCapacity,
                         int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

setInfoViewId

public void setInfoViewId(int _nInfoViewId)

getInfoViewId

public int getInfoViewId()

getInfoViewChnlDocFilterHelper

public InfoViewChnlDocFilterHelper getInfoViewChnlDocFilterHelper()
                                                           throws WCMException
抛出：
WCMException

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

覆盖：
类 ViewDocuments 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

覆盖：
类 ViewDocuments 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

覆盖：
类 ViewDocuments 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

createNewInstance

public static InfoViewDocuments createNewInstance(User _currUser)
                                           throws WCMException
产生一个当前集合对象[ChnlDocs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

setSelectFields

public void setSelectFields(java.lang.String _sSelectFieldFromChnlDoc,
                            java.lang.String _sSelectFieldsFromDocument,
                            java.lang.String _sSelectFieldFromInfoView)

setSelectFieldsFromInfoView

public void setSelectFieldsFromInfoView(java.lang.String _sSelectFieldFromInfoView)

getSelectFieldsFromInfoView

public java.lang.String getSelectFieldsFromInfoView()

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewEmploy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewEmploy

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.infoview.persistent.InfoViewEmploy
所有已实现的接口：
java.lang.Cloneable
public class InfoViewEmploy
extends CMSObj

TODO Add javadoc for InfoViewEmploy

作者：
Martin (Fu Chengrui)

字段摘要
static java.lang.String | DB_ID_NAME TODO Add javadoc for field DB_ID_NAME
static java.lang.String | DB_TABLE_NAME TODO Add javadoc for field DB_TABLE_NAME
static int | OBJ_TYPE TODO Add javadoc for field OBJ_TYPE
构造方法摘要
InfoViewEmploy()
TODO Add javadoc for InfoViewEmploy
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
CMSObj | getEmployer()
int | getEmployerId()
int | getEmployerType()
java.lang.String | getIdFieldName() 获得Id字段名。
InfoView | getInfoView()
int | getInfoViewId()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setEmployer(CMSObj _employer)
boolean | setEmployer(int _nType, int _nId)
boolean | setInfoView(InfoView _oInfoView)
boolean | setInfoViewId(int _iInfoViewID)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO Add javadoc for field OBJ_TYPE

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
TODO Add javadoc for field DB_TABLE_NAME

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
TODO Add javadoc for field DB_ID_NAME

另请参见：
常量字段值
构造方法详细信息

InfoViewEmploy

public InfoViewEmploy()
TODO Add javadoc for InfoViewEmploy

方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

getInfoViewId

public int getInfoViewId()
                  throws WCMException
抛出：
WCMException

setInfoViewId

public boolean setInfoViewId(int _iInfoViewID)
                      throws WCMException
抛出：
WCMException

getInfoView

public InfoView getInfoView()
                     throws WCMException
抛出：
WCMException

setInfoView

public boolean setInfoView(InfoView _oInfoView)
                    throws WCMException
抛出：
WCMException

getEmployer

public CMSObj getEmployer()
                   throws WCMException
抛出：
WCMException

setEmployer

public boolean setEmployer(CMSObj _employer)
                    throws WCMException
抛出：
WCMException

getEmployerType

public int getEmployerType()

getEmployerId

public int getEmployerId()

setEmployer

public boolean setEmployer(int _nType,
                           int _nId)
                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewEmploys

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewEmploys

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.infoview.persistent.InfoViewEmploys

public class InfoViewEmploys
extends CMSBaseObjs

TODO Add javadoc for InfoViewEmploys

作者：
Martin (Fu Chengrui)

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
InfoViewEmploys(User _currUser)
TODO Add javadoc for InfoViewEmploys
InfoViewEmploys(User _currUser, int _initCapacity, int _incCapacity)
TODO Add javadoc for InfoViewEmploys
方法摘要
static InfoViewEmploys | findByIds(User _currUser, java.lang.String _sIds)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewEmploys

public InfoViewEmploys(User _currUser)
TODO Add javadoc for InfoViewEmploys

参数：
_currUser -

InfoViewEmploys

public InfoViewEmploys(User _currUser,
                       int _initCapacity,
                       int _incCapacity)
TODO Add javadoc for InfoViewEmploys

参数：
_currUser -
_initCapacity -
_incCapacity -
方法详细信息

findByIds

public static final InfoViewEmploys findByIds(User _currUser,
                                              java.lang.String _sIds)
                                       throws WCMException
抛出：
WCMException

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewField

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.infoview.persistent.InfoViewField
所有已实现的接口：
java.lang.Cloneable
public class InfoViewField
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
InfoViewField()
方法摘要
static InfoViewField | createNewInstance() 产生对象InfoView的实例
static InfoViewField | findById(int id) 提取指定ID的对象
int | getClassId()
java.lang.String | getDataControl()
java.lang.String | getDataPattern()
int | getDataType()
java.lang.String | getDataTypeAsString()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDefaultValue()
java.lang.String | getDesc()
java.lang.String | getEnumValue()
java.lang.String | getFieldType()
int | getFixLength()
java.lang.String | getGateWayBinding()
java.lang.String | getIdFieldName() 获得Id字段名。
int | getInfoViewID()
int | getMaxLength()
int | getMinLength()
java.lang.String | getName()
java.lang.String | getTrueFieldName()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
java.lang.String | getXPath()
boolean | isBackReadOnly()
boolean | isNillable()
boolean | isOutlineField()
boolean | isPublicFill()
boolean | isPublicView()
boolean | isReadOnly()
boolean | isSearchField()
boolean | isSpecialRight()
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setBackReadOnly(boolean _bBackReadOnly)
boolean | setClassId(int _nClassId)
boolean | setDataControl(java.lang.String _sDataControl)
boolean | setDataPattern(java.lang.String _sDataPattern)
boolean | setDataType(int _nDataType)
boolean | setDefaultValue(java.lang.String _sDefaultValue)
boolean | setDesc(java.lang.String _sDesc)
boolean | setEnumValue(java.lang.String _sEnumValue)
boolean | setFieldType(java.lang.String _sFieldType)
boolean | setFixLength(int _iFixLength)
boolean | setGateWayBinding(java.lang.String _sGateWayBinding)
boolean | setInfoViewID(int _iInfoViewID)
boolean | setMaxLength(int _iMaxLength)
boolean | setMinLength(int _iMinLength)
boolean | setName(java.lang.String _sName)
boolean | setNillable(boolean _zNillable)
boolean | setOutlineField(boolean _bInOutline)
boolean | setPublicFill(boolean _zPublicFill)
boolean | setPublicView(boolean _zPublicView)
boolean | setReadOnly(boolean _bReadOnly)
boolean | setSearchField(boolean _bInSearch)
boolean | setSpecialRight(boolean _zSpecialRight)
boolean | setTrueFieldName(java.lang.String _sTrueFieldName)
boolean | setXPath(java.lang.String _sXPath)
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

InfoViewField

public InfoViewField()
方法详细信息

findById

public static final InfoViewField findById(int id)
                                    throws WCMException
提取指定ID的对象

参数：
id - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final InfoViewField createNewInstance()
                                             throws WCMException
产生对象InfoView的实例

返回：
BigTableDefine的实例
抛出：
WCMException - 如果发生错误

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

getName

public java.lang.String getName()

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
抛出：
WCMException

getXPath

public java.lang.String getXPath()

setXPath

public boolean setXPath(java.lang.String _sXPath)
                 throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
抛出：
WCMException

getInfoViewID

public int getInfoViewID()

setInfoViewID

public boolean setInfoViewID(int _iInfoViewID)
                      throws WCMException
抛出：
WCMException

isSpecialRight

public boolean isSpecialRight()

setSpecialRight

public boolean setSpecialRight(boolean _zSpecialRight)
                        throws WCMException
抛出：
WCMException

isPublicFill

public boolean isPublicFill()

setPublicFill

public boolean setPublicFill(boolean _zPublicFill)
                      throws WCMException
抛出：
WCMException

isPublicView

public boolean isPublicView()

setPublicView

public boolean setPublicView(boolean _zPublicView)
                      throws WCMException
抛出：
WCMException

isNillable

public boolean isNillable()

setNillable

public boolean setNillable(boolean _zNillable)
                    throws WCMException
抛出：
WCMException

getDataType

public int getDataType()

getDataTypeAsString

public java.lang.String getDataTypeAsString()

setDataType

public boolean setDataType(int _nDataType)
                    throws WCMException
抛出：
WCMException

getDataControl

public java.lang.String getDataControl()

setDataControl

public boolean setDataControl(java.lang.String _sDataControl)
                       throws WCMException
抛出：
WCMException

getDataPattern

public java.lang.String getDataPattern()

setDataPattern

public boolean setDataPattern(java.lang.String _sDataPattern)
                       throws WCMException
抛出：
WCMException

getFixLength

public int getFixLength()

setFixLength

public boolean setFixLength(int _iFixLength)
                     throws WCMException
抛出：
WCMException

getMaxLength

public int getMaxLength()

setMaxLength

public boolean setMaxLength(int _iMaxLength)
                     throws WCMException
抛出：
WCMException

getMinLength

public int getMinLength()

setMinLength

public boolean setMinLength(int _iMinLength)
                     throws WCMException
抛出：
WCMException

getFieldType

public java.lang.String getFieldType()

setFieldType

public boolean setFieldType(java.lang.String _sFieldType)
                     throws WCMException
抛出：
WCMException

getDefaultValue

public java.lang.String getDefaultValue()

setDefaultValue

public boolean setDefaultValue(java.lang.String _sDefaultValue)
                        throws WCMException
抛出：
WCMException

getEnumValue

public java.lang.String getEnumValue()

setEnumValue

public boolean setEnumValue(java.lang.String _sEnumValue)
                     throws WCMException
抛出：
WCMException

getClassId

public int getClassId()

setClassId

public boolean setClassId(int _nClassId)
                   throws WCMException
抛出：
WCMException

isOutlineField

public boolean isOutlineField()

setOutlineField

public boolean setOutlineField(boolean _bInOutline)
                        throws WCMException
抛出：
WCMException

isSearchField

public boolean isSearchField()

setSearchField

public boolean setSearchField(boolean _bInSearch)
                       throws WCMException
抛出：
WCMException

getGateWayBinding

public java.lang.String getGateWayBinding()

setGateWayBinding

public boolean setGateWayBinding(java.lang.String _sGateWayBinding)
                          throws WCMException
抛出：
WCMException

isReadOnly

public boolean isReadOnly()

setReadOnly

public boolean setReadOnly(boolean _bReadOnly)
                    throws WCMException
抛出：
WCMException

isBackReadOnly

public boolean isBackReadOnly()

setBackReadOnly

public boolean setBackReadOnly(boolean _bBackReadOnly)
                        throws WCMException
抛出：
WCMException

getTrueFieldName

public java.lang.String getTrueFieldName()
                                  throws WCMException
抛出：
WCMException

setTrueFieldName

public boolean setTrueFieldName(java.lang.String _sTrueFieldName)
                         throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewFields

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewFields

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.infoview.persistent.InfoViewFields

public class InfoViewFields
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
InfoViewFields(User _currUser)
InfoViewFields(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static InfoViewFields | findBy(InfoView _iv)
static InfoViewFields | findByIds(User _currUser, java.lang.String _sIds)
static InfoViewFields | findByName(java.lang.String _sName, int _nInfoViewId)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
static InfoViewFields | getOutlineFields(InfoView _iv)
static InfoViewFields | getSearchFields(InfoView _iv)
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewFields

public InfoViewFields(User _currUser)

InfoViewFields

public InfoViewFields(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
方法详细信息

findBy

public static final InfoViewFields findBy(InfoView _iv)
                                   throws WCMException
抛出：
WCMException

findByName

public static final InfoViewFields findByName(java.lang.String _sName,
                                              int _nInfoViewId)
                                       throws WCMException
抛出：
WCMException

findByIds

public static final InfoViewFields findByIds(User _currUser,
                                             java.lang.String _sIds)
                                      throws WCMException
抛出：
WCMException

getOutlineFields

public static final InfoViewFields getOutlineFields(InfoView _iv)
                                             throws WCMException
抛出：
WCMException

getSearchFields

public static final InfoViewFields getSearchFields(InfoView _iv)
                                            throws WCMException
抛出：
WCMException

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewGroup

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewGroup

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.infoview.persistent.InfoViewGroup
所有已实现的接口：
java.lang.Cloneable
public class InfoViewGroup
extends CMSObj

描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table

作者：
Martin (Fu Chengrui)

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
InfoViewGroup()
方法摘要
static InfoViewGroup | findById(int id) 提取指定ID的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc()
java.lang.String | getIdFieldName() 获得Id字段名。
InfoView | getInfoView()
int | getInfoViewID()
java.lang.String | getName()
InfoViewView | getView()
int | getViewID()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isPublicFill()
boolean | isPublicView()
boolean | isSpecialRight()
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setDesc(java.lang.String _sDesc)
boolean | setInfoView(InfoView _oInfoView)
boolean | setInfoViewID(int _iInfoViewID)
boolean | setName(java.lang.String _sName)
boolean | setPublicFill(boolean _zPublicFill)
boolean | setPublicView(boolean _zPublicView)
boolean | setSpecialRight(boolean _zSpecialRight)
boolean | setView(InfoViewView _oView)
boolean | setViewID(int _iViewID)
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

InfoViewGroup

public InfoViewGroup()
方法详细信息

findById

public static final InfoViewGroup findById(int id)
                                    throws WCMException
提取指定ID的对象

参数：
id - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

getName

public java.lang.String getName()

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
抛出：
WCMException

getInfoView

public InfoView getInfoView()
                     throws WCMException
抛出：
WCMException

setInfoView

public boolean setInfoView(InfoView _oInfoView)
                    throws WCMException
抛出：
WCMException

getInfoViewID

public int getInfoViewID()

setInfoViewID

public boolean setInfoViewID(int _iInfoViewID)
                      throws WCMException
抛出：
WCMException

getView

public InfoViewView getView()
                     throws WCMException
抛出：
WCMException

setView

public boolean setView(InfoViewView _oView)
                throws WCMException
抛出：
WCMException

getViewID

public int getViewID()

setViewID

public boolean setViewID(int _iViewID)
                  throws WCMException
抛出：
WCMException

isSpecialRight

public boolean isSpecialRight()

setSpecialRight

public boolean setSpecialRight(boolean _zSpecialRight)
                        throws WCMException
抛出：
WCMException

isPublicFill

public boolean isPublicFill()

setPublicFill

public boolean setPublicFill(boolean _zPublicFill)
                      throws WCMException
抛出：
WCMException

isPublicView

public boolean isPublicView()

setPublicView

public boolean setPublicView(boolean _zPublicView)
                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewGroups

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewGroups

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.infoview.persistent.InfoViewGroups

public class InfoViewGroups
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
InfoViewGroups(User _currUser)
InfoViewGroups(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static InfoViewGroups | findBy(InfoView _iv)
static InfoViewGroups | findByName(java.lang.String _sGroupName, int _nInfoViewId)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewGroups

public InfoViewGroups(User _currUser)

InfoViewGroups

public InfoViewGroups(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
方法详细信息

findBy

public static final InfoViewGroups findBy(InfoView _iv)
                                   throws WCMException
抛出：
WCMException

findByName

public static final InfoViewGroups findByName(java.lang.String _sGroupName,
                                              int _nInfoViewId)
                                       throws WCMException
抛出：
WCMException

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViews

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViews

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.infoview.persistent.InfoViews

public class InfoViews
extends CMSBaseObjs

TODO Add javadoc for InfoViews

作者：
Martin (Fu Chengrui)

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
InfoViews(User _currUser)
TODO Add javadoc for InfoViews
InfoViews(User _currUser, int _initCapacity, int _incCapacity)
TODO Add javadoc for InfoViews
方法摘要
static InfoViews | findByIds(User _currUser, java.lang.String _sIds) TODO Add javadoc for field findByIds
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViews

public InfoViews(User _currUser)
TODO Add javadoc for InfoViews

参数：
_currUser -

InfoViews

public InfoViews(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
TODO Add javadoc for InfoViews

参数：
_currUser -
_initCapacity -
_incCapacity -
方法详细信息

findByIds

public static final InfoViews findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
TODO Add javadoc for field findByIds

参数：
_currUser -
_sIds -
返回：
抛出：
WCMException

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewSerial

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewSerial

java.lang.Object
    继承者  com.trs.components.infoview.persistent.InfoViewSerial

public final class InfoViewSerial
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
表单序号
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | SERIAL_PERIOD_DAY 序号跳变精度标识:每天
static int | SERIAL_PERIOD_FORERVER 序号跳变精度标识:从不
static int | SERIAL_PERIOD_MONTH 序号跳变精度标识:每月
static int | SERIAL_PERIOD_YEAR 序号跳变精度标识:每年
方法摘要
java.lang.Integer | getNextSerial() 获取下一个可用序号
static void | main(java.lang.String[] args)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SERIAL_PERIOD_DAY

public static final int SERIAL_PERIOD_DAY
序号跳变精度标识:每天

另请参见：
常量字段值

SERIAL_PERIOD_MONTH

public static final int SERIAL_PERIOD_MONTH
序号跳变精度标识:每月

另请参见：
常量字段值

SERIAL_PERIOD_YEAR

public static final int SERIAL_PERIOD_YEAR
序号跳变精度标识:每年

另请参见：
常量字段值

SERIAL_PERIOD_FORERVER

public static final int SERIAL_PERIOD_FORERVER
序号跳变精度标识:从不

另请参见：
常量字段值
方法详细信息

getNextSerial

public java.lang.Integer getNextSerial()
                                throws WCMException
获取下一个可用序号

返回：
下一个序号
抛出：
WCMException - 如果从数据库中获取相关属性出现异常时

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewSerialGenerator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewSerialGenerator

java.lang.Object
    继承者  com.trs.components.infoview.persistent.InfoViewSerialGenerator

public class InfoViewSerialGenerator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
表单编号产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static InfoViewSerialGenerator | getInstance()
java.lang.Object[] | getNextSerial(int nInfoViewId, int nSerialPeriod, int nBaseSerial) 获取指定表单的下一个编号
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getInstance

public static InfoViewSerialGenerator getInstance()

getNextSerial

public java.lang.Object[] getNextSerial(int nInfoViewId,
                                        int nSerialPeriod,
                                        int nBaseSerial)
                                 throws WCMException
获取指定表单的下一个编号

参数：
nInfoViewId - 表单Id
nSerialPeriod - 序号跳变情况标识域
nBaseSerial - 序号起始值,一般来指定为从1开始
返回：
Object[0] :时间部分(java.util.Date)
Object[1] :编号部分(java.lang.Integer)
抛出：
WCMException - 如果从数据库中获取相关属性出现异常时
IllegalArgumentException 如果 nBaseSerial <= 0
另请参见：
InfoViewSerial

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewView

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewView

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.infoview.persistent.InfoViewView
所有已实现的接口：
java.lang.Cloneable
public class InfoViewView
extends CMSObj

描述自定义表单的一个视图

作者：
Martin (Fu Chengrui)

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
InfoViewView()
缺省构造方法
方法摘要
static InfoViewView | findById(int id) 返回指定ID的表单视图对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 返回视图的描述
java.lang.String | getIdFieldName() 获得Id字段名。
int | getInfoViewID() 返回视图所属表单的ID
java.lang.String | getName() 返回视图的名称
java.lang.String | getNewFile() 返回该视图的，经过系统修改、重整之后的XSL文件的文件名
java.lang.String | getOldFile() 返回该视图的、原始的、InfoPath中的、XSL文件的文件名
java.lang.String | getViewWidth() 返回视图的宽度（HTML页面中有效区域的宽度）
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
java.lang.String | getXSLPrefix()
boolean | isDefaultView() 返回该视图是否缺省视图
boolean | isPublicFill() 返回该视图是否公共可填写，即是否发布到公网
boolean | isPublicView() 返回该视图的数据是否任何人都可以查看 注意：到2006.07.13，尚未实现
boolean | isSpecialRight() 返回该视图是否单独设置过权限
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setDefaultView(boolean _zDefaultView) 设置该视图是否缺省视图
boolean | setDesc(java.lang.String _sDesc) 设置视图的描述
boolean | setInfoViewID(int _iInfoViewID) 设置视图所属表单的ID
boolean | setName(java.lang.String _sName) 设置视图的名称
boolean | setNewFile(java.lang.String _sFileName) 设置重整之后的XSL文件的文件名
boolean | setOldFile(java.lang.String _sFileName) 设置该视图原始XSL文件的文件名
boolean | setPublicFill(boolean _zPublicFill) 设置该视图是否公共可填写，即是否发布到公网
boolean | setPublicView(boolean _zPublicView) 设置该视图的数据是否任何人都可以查看 注意：到2006.07.13，尚未实现
boolean | setSpecialRight(boolean _zSpecialRight) 设置该视图是否单独设置过权限
boolean | setViewWidth(java.lang.String _sViewWidth) 设置视图的宽度（HTML页面中有效区域的宽度）
boolean | setXSLPrefix(java.lang.String _sXSLPrefix)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

InfoViewView

public InfoViewView()
缺省构造方法

方法详细信息

findById

public static final InfoViewView findById(int id)
                                   throws WCMException
返回指定ID的表单视图对象

参数：
id - 指定的视图ID
返回：
指定ID的视图对象
抛出：
WCMException - 如果发生错误

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

getName

public java.lang.String getName()
返回视图的名称

返回：
视图的名称

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置视图的名称

参数：
_sName - 视图的名称
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

getDesc

public java.lang.String getDesc()
返回视图的描述

返回：
视图的描述

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置视图的描述

参数：
_sName - 视图的描述
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

getInfoViewID

public int getInfoViewID()
返回视图所属表单的ID

返回：
视图所属表单的ID

setInfoViewID

public boolean setInfoViewID(int _iInfoViewID)
                      throws WCMException
设置视图所属表单的ID

参数：
_iInfoViewID - 视图所属表单的ID
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

isSpecialRight

public boolean isSpecialRight()
返回该视图是否单独设置过权限

返回：
该视图是否单独设置过权限

setSpecialRight

public boolean setSpecialRight(boolean _zSpecialRight)
                        throws WCMException
设置该视图是否单独设置过权限

参数：
_zSpecialRight - 该视图是否单独设置过权限
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

isDefaultView

public boolean isDefaultView()
返回该视图是否缺省视图

返回：
该视图是否缺省视图

setDefaultView

public boolean setDefaultView(boolean _zDefaultView)
                       throws WCMException
设置该视图是否缺省视图

参数：
_zDefaultView - 该视图是否缺省视图
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

isPublicFill

public boolean isPublicFill()
返回该视图是否公共可填写，即是否发布到公网

返回：
该视图是否公共可填写

setPublicFill

public boolean setPublicFill(boolean _zPublicFill)
                      throws WCMException
设置该视图是否公共可填写，即是否发布到公网

参数：
_zPublicFill - 该视图是否公共可填写
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

isPublicView

public boolean isPublicView()
返回该视图的数据是否任何人都可以查看 注意：到2006.07.13，尚未实现

返回：
该视图的数据是否任何人都可以查看

setPublicView

public boolean setPublicView(boolean _zPublicView)
                      throws WCMException
设置该视图的数据是否任何人都可以查看 注意：到2006.07.13，尚未实现

参数：
_zPublicView - 该视图的数据是否任何人都可以查看
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

getViewWidth

public java.lang.String getViewWidth()
返回视图的宽度（HTML页面中有效区域的宽度）

返回：
视图的宽度

setViewWidth

public boolean setViewWidth(java.lang.String _sViewWidth)
                     throws WCMException
设置视图的宽度（HTML页面中有效区域的宽度）

参数：
_sViewWidth - 视图的宽度（HTML页面中有效区域的宽度）
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

getOldFile

public java.lang.String getOldFile()
返回该视图的、原始的、InfoPath中的、XSL文件的文件名

返回：
该视图原始XSL文件的文件名

setOldFile

public boolean setOldFile(java.lang.String _sFileName)
                   throws WCMException
设置该视图原始XSL文件的文件名

参数：
_sFileName - 该视图原始XSL文件的文件名
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

getNewFile

public java.lang.String getNewFile()
返回该视图的，经过系统修改、重整之后的XSL文件的文件名

返回：
重整之后的XSL文件的文件名

setNewFile

public boolean setNewFile(java.lang.String _sFileName)
                   throws WCMException
设置重整之后的XSL文件的文件名

参数：
_sFileName - 重整之后的XSL文件的文件名
返回：
是否设置成功
抛出：
WCMException - 如果发生错误

getXSLPrefix

public java.lang.String getXSLPrefix()

setXSLPrefix

public boolean setXSLPrefix(java.lang.String _sXSLPrefix)
                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewViews

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.persistent
类 InfoViewViews

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.infoview.persistent.InfoViewViews

public class InfoViewViews
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
InfoViewViews(User _currUser)
InfoViewViews(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static InfoViewViews | findBy(InfoView _iv)
static InfoViewViews | findDefaultBy(InfoView _iv)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewViews

public InfoViewViews(User _currUser)

InfoViewViews

public InfoViewViews(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
方法详细信息

findDefaultBy

public static final InfoViewViews findDefaultBy(InfoView _iv)
                                         throws WCMException
抛出：
WCMException

findBy

public static final InfoViewViews findBy(InfoView _iv)
                                  throws WCMException
抛出：
WCMException

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.persistent
类
InfoView
InfoViewData
InfoViewDatas
InfoViewDocument
InfoViewDocuments
InfoViewEmploy
InfoViewEmploys
InfoViewField
InfoViewFields
InfoViewGroup
InfoViewGroups
InfoViews
InfoViewSerial
InfoViewSerialGenerator
InfoViewView
InfoViewViews


com.trs.components.infoview.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.persistent

结合 MS InfoPath 实现的自定义表单的持久化。

请参见：
描述

类摘要
InfoView | TODO Add javadoc for InfoView
InfoViewData |
InfoViewDatas | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDocument |
InfoViewDocuments |
InfoViewEmploy | TODO Add javadoc for InfoViewEmploy
InfoViewEmploys | TODO Add javadoc for InfoViewEmploys
InfoViewField |
InfoViewFields |
InfoViewGroup | 描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table
InfoViewGroups |
InfoViews | TODO Add javadoc for InfoViews
InfoViewSerial | Title: TRS 内容协作平台（TRS WCM） Description: 表单序号 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewSerialGenerator | Title: TRS 内容协作平台（TRS WCM） Description: 表单编号产生器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewView | 描述自定义表单的一个视图
InfoViewViews |

软件包 com.trs.components.infoview.persistent 的描述

结合 MS InfoPath 实现的自定义表单的持久化。


com.trs.components.infoview.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.infoview.persistent.InfoView
        • com.trs.components.infoview.persistent.InfoViewData
        • com.trs.components.infoview.persistent.InfoViewEmploy
        • com.trs.components.infoview.persistent.InfoViewField
        • com.trs.components.infoview.persistent.InfoViewGroup
        • com.trs.components.infoview.persistent.InfoViewView
        • com.trs.components.wcm.content.ViewDocument
          • com.trs.components.infoview.persistent.InfoViewDocument
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.infoview.persistent.InfoViewDatas
        • com.trs.components.infoview.persistent.InfoViewEmploys
        • com.trs.components.infoview.persistent.InfoViewFields
        • com.trs.components.infoview.persistent.InfoViewGroups
        • com.trs.components.infoview.persistent.InfoViews
        • com.trs.components.infoview.persistent.InfoViewViews
        • com.trs.components.wcm.content.ViewDocuments
          • com.trs.components.infoview.persistent.InfoViewDocuments
    • com.trs.components.infoview.persistent.InfoViewSerial
    • com.trs.components.infoview.persistent.InfoViewSerialGenerator


软件包 com.trs.components.infoview.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.persistent
的使用

使用 com.trs.components.infoview.persistent 的软件包
com.trs.ajaxservice |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。
com.trs.components.infoview.helper |
com.trs.components.infoview.mad |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.service |
com.trs.service.impl |

com.trs.ajaxservice 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewDocuments
InfoViews
TODO Add javadoc for InfoViews

com.trs.components.infoview 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewData
InfoViewField
InfoViewFields
InfoViewGroup
描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table
InfoViews
TODO Add javadoc for InfoViews
InfoViewView
描述自定义表单的一个视图
InfoViewViews

com.trs.components.infoview.db 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewData
InfoViewField

com.trs.components.infoview.extract 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewView
描述自定义表单的一个视图

com.trs.components.infoview.helper 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewDocument
InfoViewDocuments

com.trs.components.infoview.mad 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView

com.trs.components.infoview.persistent 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewData
InfoViewDatas
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDocument
InfoViewDocuments
InfoViewEmploys
TODO Add javadoc for InfoViewEmploys
InfoViewField
InfoViewFields
InfoViewGroup
描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table
InfoViewGroups
InfoViews
TODO Add javadoc for InfoViews
InfoViewSerialGenerator
Title: TRS 内容协作平台（TRS WCM）
Description:
表单编号产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewView
描述自定义表单的一个视图
InfoViewViews

com.trs.components.infoview.publish.tagparser 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewView
描述自定义表单的一个视图

com.trs.service 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewField
InfoViewFields
InfoViewGroup
描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table
InfoViews
TODO Add javadoc for InfoViews
InfoViewView
描述自定义表单的一个视图

com.trs.service.impl 使用的 com.trs.components.infoview.persistent 中的类
InfoView
TODO Add javadoc for InfoView
InfoViewField
InfoViewFields
InfoViewGroup
描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table
InfoViews
TODO Add javadoc for InfoViews
InfoViewView
描述自定义表单的一个视图

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoView
的使用

使用 InfoView 的软件包
com.trs.ajaxservice |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。
com.trs.components.infoview.helper |
com.trs.components.infoview.mad |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.service |
com.trs.service.impl |

com.trs.ajaxservice 中 InfoView 的使用

参数类型为 InfoView 的 com.trs.ajaxservice 中的方法
java.lang.String | InfoviewService.getAbsolutePath(InfoView _oInfoView, java.lang.String sFileName)
java.lang.String | InfoviewService.getInfoViewTemPath(InfoView _oInfoView)

com.trs.components.infoview 中 InfoView 的使用

返回 InfoView 的 com.trs.components.infoview 中的方法
static InfoView InfoViewHelper.getInfoView(Channel _oChannel)

参数类型为 InfoView 的 com.trs.components.infoview 中的方法
static java.lang.String | InfoViewDataHelper.buildContent(InfoView _oInfoView, Document wcmDocument, org.dom4j.Document _oDom4jDocument)
int | InfoViewEmployMgr.clearByInfoView(InfoView _oInfoView)
void | InfoViewMgr.delete(InfoView _oInfoView)
java.lang.String | InfoViewMgr.filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int _nFlowDocId) 在工作流转中过滤文档中的不可读字段
java.lang.String | InfoViewMgr.forFillOut(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | InfoViewMgr.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int _nFlowDocId) 工作流转中xsl转化成html的过程
java.lang.String | InfoViewMgr.forFillOutInner(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | InfoViewMgr.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | InfoViewMgr.forInfoGate(InfoView _oInfoView, FormProperty _oProperty)
java.lang.String | InfoViewMgr.forMultiView(InfoView _oInfoView, InfoViewView _oPubView, java.util.List fileList)
java.lang.String | InfoViewMgr.forPreview(InfoView _oInfoView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | InfoViewMgr.forPreviewMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | InfoViewMgr.forPublish(InfoView _oInfoView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | InfoViewMgr.forPublishMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | InfoViewMgr.getAbsolutePath(InfoView _oInfoView, java.lang.String sFileName)
static java.lang.String[] | InfoViewHelper.getDBFieldsByFields(InfoView oInfoView, java.lang.String[] arrInfoPathFields, boolean bAppendTable)
static java.lang.String | InfoViewHelper.getDBFieldsByFields(InfoView oInfoView, java.lang.String sInfoPathFields, boolean bAppendTable) 获取InfoPath字段名对应的数据库字段名
java.lang.String | InfoViewMgr.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document _dom4jDocument)
java.lang.String | InfoViewMgr.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document _dom4jDocument, java.lang.String _sPostUserName)
java.lang.String | InfoViewMgr.getDocumentTitleForUserName(InfoView _oInfoView, org.dom4j.Document _dom4jDocument, java.lang.String _sPostUserName)
java.util.List | InfoViewEmployMgr.getInfoViewEmployers(InfoView _employed)
java.lang.String | InfoViewMgr.getInfoViewSerial(InfoView _oInfoView)
java.lang.String | InfoViewMgr.getTemplateFileContent(InfoView _oInfoView)
java.lang.String | InfoViewMgr.initTemplateInFlow(InfoView _oInfoView, int _nFlowDocId) 在工作流转中初始化表单的模板数据
void | InfoViewMgr.rebuildXSLT(InfoView _oInfoView)
void | InfoViewMgr.rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)
void | InfoViewMgr.rebuildXSLTByGroups(InfoView _oInfoView, java.util.List _lstGroups)
void | InfoViewMgr.save(InfoView _oInfoView)
void | InfoViewMgr.saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)
void | InfoViewMgr.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadOnly)

参数类型为 InfoView 的 com.trs.components.infoview 中的构造方法
InfoViewReplyNoticeSender(InfoView _oInfoView, Document _oDocument, DocReply _oInfoViewReply)

com.trs.components.infoview.db 中 InfoView 的使用

参数类型为 InfoView 的 com.trs.components.infoview.db 中的方法
void | InfoViewDBMgr.createDBField(User user, InfoView _view, InfoViewField _viewField)
void | IInfoViewDBMgr.createDBField(User _currUser, InfoView _infoView, InfoViewField _infoViewField) 给当前表单的指定字段在数据库中创建对应物理字段
void | InfoViewDBMgr.deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField)
void | IInfoViewDBMgr.deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField) 删除指定字段

com.trs.components.infoview.extract 中 InfoView 的使用

参数类型为 InfoView 的 com.trs.components.infoview.extract 中的方法
void | XSLTViewConstrainter.init(InfoView _oInfoView, InfoViewView _oInfoViewView)
void | XSLTViewConstrainter.init(InfoView _oInfoView, InfoViewView _oInfoViewView, java.util.List _lsGroups, java.util.List _lsFields)

com.trs.components.infoview.helper 中 InfoView 的使用

参数类型为 InfoView 的 com.trs.components.infoview.helper 中的方法
static java.lang.String[] InfoViewNewQueryHelper.getFieldNames(InfoView infoview, java.lang.String sSelectedFields)

com.trs.components.infoview.mad 中 InfoView 的使用

参数类型为 InfoView 的 com.trs.components.infoview.mad 中的方法
java.lang.String | InfoViewDataHelper.buildContent(InfoView infoView, Document _document, org.dom4j.Document dom4jDocument)
java.lang.String | InfoViewDataHelperImpl.buildContent(InfoView infoView, Document _document, org.dom4j.Document dom4jDocument)

com.trs.components.infoview.persistent 中 InfoView 的使用

返回 InfoView 的 com.trs.components.infoview.persistent 中的方法
static InfoView | InfoView.createNewInstance() 产生对象InfoView的实例
static InfoView | InfoView.findById(int id) 提取指定ID的对象
InfoView | InfoViewEmploy.getInfoView()
InfoView | InfoViewGroup.getInfoView()

参数类型为 InfoView 的 com.trs.components.infoview.persistent 中的方法
static InfoViewViews | InfoViewViews.findBy(InfoView _iv)
static InfoViewFields | InfoViewFields.findBy(InfoView _iv)
static InfoViewGroups | InfoViewGroups.findBy(InfoView _iv)
static InfoViewData | InfoViewData.findById(InfoView _oInfoView, int _nId) 提取指定ID的对象
static InfoViewViews | InfoViewViews.findDefaultBy(InfoView _iv)
static InfoViewFields | InfoViewFields.getOutlineFields(InfoView _iv)
static InfoViewFields | InfoViewFields.getSearchFields(InfoView _iv)
boolean | InfoViewEmploy.setInfoView(InfoView _oInfoView)
boolean | InfoViewGroup.setInfoView(InfoView _oInfoView)

com.trs.components.infoview.publish.tagparser 中 InfoView 的使用

参数类型为 InfoView 的 com.trs.components.infoview.publish.tagparser 中的方法
 InfoViewView[] TagParserInfoViews.getPublishViews(InfoView _oInfoView, boolean _bPushlishAll, java.lang.String sPubViewNames)

com.trs.service 中 InfoView 的使用

返回 InfoView 的 com.trs.service 中的方法
InfoView | IInfoViewService.findById(int _iInfoViewID) 在指定的站点下查找指定ID的自定义表单
InfoView | InfoViewContext.getInfoView()

参数类型为 InfoView 的 com.trs.service 中的方法
void | IInfoViewService.delete(InfoView _oInfoView) 彻底删除指定的自定义表单
java.lang.String | IInfoViewService.filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int nFlowDocId)
java.lang.String | IInfoViewService.forFillOut(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面 事实上生成的HTML页面不仅用于内部填写表单、还用在表单预览、表单数据察看。
java.lang.String | IInfoViewService.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int nFlowDocId)
java.lang.String | IInfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView)
java.lang.String | IInfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)
java.lang.String | IInfoViewService.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument) 按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题
java.lang.String | IInfoViewService.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument, java.lang.String _oPostUserNmae) 按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题
java.lang.String | IInfoViewService.getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent) 按照相关表单的设定从XML文件抽取文档的标题
java.util.List | IInfoViewService.getInfoViewEmployers(InfoView _employed) 获取指定自定义表单的所有雇主（频道对象）的集合
java.lang.String | IInfoViewService.getInfoViewSerial(InfoView _oInfoView) 获取指定表单的编号
void | IInfoViewService.rebuildXSLT(InfoView _oInfoView)
void | IInfoViewService.rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)
void | IInfoViewService.save(InfoView _oInfoView) 保存指定的自定义表单
Document | IDocumentService.saveInfoViewDocument(Document _document, InfoView _infoView, java.util.Map _infoViewData)
void | IInfoViewService.saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)
void | IInfoViewService.sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage) 发送表单文档的回复通知 优先使用表单上的设置
void | IInfoViewService.setEmployedInfoView(CMSObj _employer, InfoView _oInfoView) 设置雇主（通常是频道）雇佣的自定义表单的ID列表
void | IInfoViewService.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadonly)

com.trs.service.impl 中 InfoView 的使用

返回 InfoView 的 com.trs.service.impl 中的方法
 InfoView InfoViewService.findById(int _iInfoViewID)

参数类型为 InfoView 的 com.trs.service.impl 中的方法
void | InfoViewService.delete(InfoView _oInfoView)
java.lang.String | InfoViewService.filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int nFlowDocId)
java.lang.String | InfoViewService.forFillOut(InfoView _oInfoView, InfoViewView _oView)
java.lang.String | InfoViewService.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int _flowDocId)
java.lang.String | InfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView)
java.lang.String | InfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)
java.lang.String | InfoViewService.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument)
java.lang.String | InfoViewService.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument, java.lang.String sPostUserName)
java.lang.String | InfoViewService.getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent)
java.lang.String | InfoViewService.getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent, java.lang.String sPostUserName)
java.util.List | InfoViewService.getInfoViewEmployers(InfoView _employed)
java.lang.String | InfoViewService.getInfoViewSerial(InfoView _oInfoView)
void | InfoViewService.rebuildXSLT(InfoView _oInfoView)
void | InfoViewService.rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)
void | InfoViewService.save(InfoView _oInfoView)
Document | DocumentService.saveInfoViewDocument(Document _document, InfoView _oInfoView, java.util.Map _oInfoViewData)
void | InfoViewService.saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)
void | InfoViewService.sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage)
void | InfoViewService.setEmployedInfoView(CMSObj _employer, InfoView _oInfoView)
void | InfoViewService.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadonly)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewData
的使用

使用 InfoViewData 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview 中 InfoViewData 的使用

参数类型为 InfoViewData 的 com.trs.components.infoview 中的方法
static ComplexFieldData InfoViewHelper.makeComplexFieldData(java.lang.String _sFieldId, java.lang.String _sFieldName, java.lang.String _sVal, java.lang.String _sParentFlag, InfoViewData _docData)

com.trs.components.infoview.db 中 InfoViewData 的使用

参数类型为 InfoViewData 的 com.trs.components.infoview.db 中的方法
void | XMLContentRender.render(InfoViewData _oDocData, org.dom4j.Document xmlDocument, java.lang.String[] saNameSpaceURI)
void | XMLContentRender.render(InfoViewData _oDocData, java.lang.String sXMLContent, java.lang.String[] saNameSpaceURI)

com.trs.components.infoview.persistent 中 InfoViewData 的使用

返回 InfoViewData 的 com.trs.components.infoview.persistent 中的方法
static InfoViewData | InfoViewData.createNewInstance() 产生当前对象[MetaViewData]的实例
static InfoViewData | InfoViewData.createNewInstance(int _nInfoViewId, int _nDocumentId)
static InfoViewData | InfoViewData.findByDocument(Document document)
static InfoViewData | InfoViewData.findById(InfoView _oInfoView, int _nId) 提取指定ID的对象
static InfoViewData | InfoViewData.findById(int _nDocumentId)
static InfoViewData | InfoViewData.findById2(int _nInfoViewId, int _nDocumentId)
static InfoViewData | InfoViewData.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
InfoViewData | InfoViewDocument.getInfoViewData()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewDatas 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewDatas
的使用

使用 InfoViewDatas 的软件包
com.trs.components.infoview.persistent 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview.persistent 中 InfoViewDatas 的使用

返回 InfoViewDatas 的 com.trs.components.infoview.persistent 中的方法
static InfoViewDatas | InfoViewDatas.createNewInstance(int _nInfoViewId)
static InfoViewDatas | InfoViewDatas.findByDocIds(User _currUser, int _nInfoViewId, java.lang.String _sDocumentIds)
static InfoViewDatas | InfoViewDatas.findByIds(User _currUser, int _nInfoViewId, java.lang.String _sInfoViewDataIds)
static InfoViewDatas | InfoViewDatas.openWCMObjs(int nInfoViewId, WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewDocument 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewDocument
的使用

使用 InfoViewDocument 的软件包
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview.helper 中 InfoViewDocument 的使用

参数类型为 InfoViewDocument 的 com.trs.components.infoview.helper 中的方法
static java.lang.String InfoViewNewQueryHelper.getFieldValue(InfoViewDocument _infoviewDoc, java.lang.String _sFieldName)

com.trs.components.infoview.persistent 中 InfoViewDocument 的使用

返回 InfoViewDocument 的 com.trs.components.infoview.persistent 中的方法
static InfoViewDocument | InfoViewDocument.findByDocument(Document _oDocument, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument, java.lang.String _sSelectFieldsOfInfoView)
static InfoViewDocument | InfoViewDocument.findById(BaseChannel _host, int _nChnlDocRecId, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument, int _nInfoViewId, java.lang.String _sSelectFieldsOfInfoView) 获取指定Id的ViewDocument
static InfoViewDocument | InfoViewDocument.findSelfByDocument(Document _oDocument)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewDocuments
的使用

使用 InfoViewDocuments 的软件包
com.trs.ajaxservice |
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.ajaxservice 中 InfoViewDocuments 的使用

返回 InfoViewDocuments 的 com.trs.ajaxservice 中的方法
 InfoViewDocuments InfoViewDocumentServiceProvider.queryRecycle(MethodContext _methContext)
获取指定站点或者指定频道回收站下的文档

com.trs.components.infoview.helper 中 InfoViewDocuments 的使用

返回 InfoViewDocuments 的 com.trs.components.infoview.helper 中的方法
static InfoViewDocuments | InfoViewNewQueryHelper.queryData(MethodContext _methodContext)
static InfoViewDocuments | InfoViewNewQueryHelper.queryData(RequestHelper requestHelper)

com.trs.components.infoview.persistent 中 InfoViewDocuments 的使用

返回 InfoViewDocuments 的 com.trs.components.infoview.persistent 中的方法
static InfoViewDocuments InfoViewDocuments.createNewInstance(User _currUser)
产生一个当前集合对象[ChnlDocs]的实例

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewEmploy 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewEmploy
的使用

没有 com.trs.components.infoview.persistent.InfoViewEmploy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewEmploys 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewEmploys
的使用

使用 InfoViewEmploys 的软件包
com.trs.components.infoview.persistent 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview.persistent 中 InfoViewEmploys 的使用

返回 InfoViewEmploys 的 com.trs.components.infoview.persistent 中的方法
static InfoViewEmploys InfoViewEmploys.findByIds(User _currUser, java.lang.String _sIds)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewField
的使用

使用 InfoViewField 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.service |
com.trs.service.impl |

com.trs.components.infoview 中 InfoViewField 的使用

参数类型为 InfoViewField 的 com.trs.components.infoview 中的方法
void | InfoViewMgr.delete(InfoViewField _oField)
void | InfoViewMgr.save(InfoViewField _oField)

参数类型为 InfoViewField 的 com.trs.components.infoview 中的构造方法
RightHostInfoViewField(InfoViewField _oField)

com.trs.components.infoview.db 中 InfoViewField 的使用

参数类型为 InfoViewField 的 com.trs.components.infoview.db 中的方法
void | InfoViewDBMgr.createDBField(User user, InfoView _view, InfoViewField _viewField)
void | IInfoViewDBMgr.createDBField(User _currUser, InfoView _infoView, InfoViewField _infoViewField) 给当前表单的指定字段在数据库中创建对应物理字段
void | InfoViewDBMgr.deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField)
void | IInfoViewDBMgr.deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField) 删除指定字段

com.trs.components.infoview.persistent 中 InfoViewField 的使用

返回 InfoViewField 的 com.trs.components.infoview.persistent 中的方法
static InfoViewField | InfoViewField.createNewInstance() 产生对象InfoView的实例
static InfoViewField | InfoViewField.findById(int id) 提取指定ID的对象
InfoViewField | InfoView.getField(java.lang.String name)

参数类型为 InfoViewField 的 com.trs.components.infoview.persistent 中的方法
void | InfoView.addField(InfoViewField field)
void | InfoView.removeField(InfoViewField field)

com.trs.service 中 InfoViewField 的使用

参数类型为 InfoViewField 的 com.trs.service 中的方法
 void IInfoViewService.save(InfoViewField _oField)
保存指定的自定义表单字段

com.trs.service.impl 中 InfoViewField 的使用

参数类型为 InfoViewField 的 com.trs.service.impl 中的方法
 void InfoViewService.save(InfoViewField _oField)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewFields 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewFields
的使用

使用 InfoViewFields 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.service |
com.trs.service.impl |

com.trs.components.infoview 中 InfoViewFields 的使用

参数类型为 InfoViewFields 的 com.trs.components.infoview 中的方法
 void InfoViewMgr.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadOnly)

com.trs.components.infoview.persistent 中 InfoViewFields 的使用

返回 InfoViewFields 的 com.trs.components.infoview.persistent 中的方法
static InfoViewFields | InfoViewFields.findBy(InfoView _iv)
static InfoViewFields | InfoViewFields.findByIds(User _currUser, java.lang.String _sIds)
static InfoViewFields | InfoViewFields.findByName(java.lang.String _sName, int _nInfoViewId)
static InfoViewFields | InfoViewFields.getOutlineFields(InfoView _iv)
static InfoViewFields | InfoViewFields.getSearchFields(InfoView _iv)

com.trs.service 中 InfoViewFields 的使用

参数类型为 InfoViewFields 的 com.trs.service 中的方法
 void IInfoViewService.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadonly)

com.trs.service.impl 中 InfoViewFields 的使用

参数类型为 InfoViewFields 的 com.trs.service.impl 中的方法
 void InfoViewService.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadonly)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewGroup 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewGroup
的使用

使用 InfoViewGroup 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.service |
com.trs.service.impl |

com.trs.components.infoview 中 InfoViewGroup 的使用

参数类型为 InfoViewGroup 的 com.trs.components.infoview 中的方法
void | InfoViewMgr.delete(InfoViewGroup _oGroup)
void | InfoViewMgr.save(InfoViewGroup _oGroup)

参数类型为 InfoViewGroup 的 com.trs.components.infoview 中的构造方法
RightHostInfoViewGroup(InfoViewGroup _group)

com.trs.components.infoview.persistent 中 InfoViewGroup 的使用

返回 InfoViewGroup 的 com.trs.components.infoview.persistent 中的方法
static InfoViewGroup InfoViewGroup.findById(int id)
提取指定ID的对象

参数类型为 InfoViewGroup 的 com.trs.components.infoview.persistent 中的方法
 void InfoView.addGroup(InfoViewGroup group)

com.trs.service 中 InfoViewGroup 的使用

参数类型为 InfoViewGroup 的 com.trs.service 中的方法
 void IInfoViewService.save(InfoViewGroup _oGroup)
保存指定的自定义表单数据节

com.trs.service.impl 中 InfoViewGroup 的使用

参数类型为 InfoViewGroup 的 com.trs.service.impl 中的方法
 void InfoViewService.save(InfoViewGroup _oGroup)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewGroups 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewGroups
的使用

使用 InfoViewGroups 的软件包
com.trs.components.infoview.persistent 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview.persistent 中 InfoViewGroups 的使用

返回 InfoViewGroups 的 com.trs.components.infoview.persistent 中的方法
static InfoViewGroups | InfoViewGroups.findBy(InfoView _iv)
static InfoViewGroups | InfoViewGroups.findByName(java.lang.String _sGroupName, int _nInfoViewId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViews
的使用

使用 InfoViews 的软件包
com.trs.ajaxservice |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.service |
com.trs.service.impl |

com.trs.ajaxservice 中 InfoViews 的使用

返回 InfoViews 的 com.trs.ajaxservice 中的方法
InfoViews | InfoviewService.getInfoViews()
InfoViews | InfoviewService.queryFlowInfoviews(MethodContext _context)

com.trs.components.infoview 中 InfoViews 的使用

返回 InfoViews 的 com.trs.components.infoview 中的方法
 InfoViews InfoViewMgr.getInfoViews(WCMFilter _filter)

com.trs.components.infoview.persistent 中 InfoViews 的使用

返回 InfoViews 的 com.trs.components.infoview.persistent 中的方法
static InfoViews InfoViews.findByIds(User _currUser, java.lang.String _sIds)
TODO Add javadoc for field findByIds

com.trs.service 中 InfoViews 的使用

返回 InfoViews 的 com.trs.service 中的方法
 InfoViews IInfoViewService.getInfoViews(WCMFilter _filter)
获取所有符合条件的自定义表单

参数类型为 InfoViews 的 com.trs.service 中的方法
 void IInfoViewService.delete(InfoViews _oInfoViews)
彻底删除指定的自定义表单集合 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。

com.trs.service.impl 中 InfoViews 的使用

返回 InfoViews 的 com.trs.service.impl 中的方法
 InfoViews InfoViewService.getInfoViews(WCMFilter _filter)

参数类型为 InfoViews 的 com.trs.service.impl 中的方法
 void InfoViewService.delete(InfoViews _oInfoViews)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewSerial 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewSerial
的使用

没有 com.trs.components.infoview.persistent.InfoViewSerial 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewSerialGenerator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewSerialGenerator
的使用

使用 InfoViewSerialGenerator 的软件包
com.trs.components.infoview.persistent 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview.persistent 中 InfoViewSerialGenerator 的使用

返回 InfoViewSerialGenerator 的 com.trs.components.infoview.persistent 中的方法
static InfoViewSerialGenerator InfoViewSerialGenerator.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewView
的使用

使用 InfoViewView 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.service |
com.trs.service.impl |

com.trs.components.infoview 中 InfoViewView 的使用

参数类型为 InfoViewView 的 com.trs.components.infoview 中的方法
void | InfoViewMgr.delete(InfoViewView _oView)
java.lang.String | InfoViewMgr.forFillOut(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | InfoViewMgr.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int _nFlowDocId) 工作流转中xsl转化成html的过程
java.lang.String | InfoViewMgr.forFillOutInner(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | InfoViewMgr.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow) 为了在WCM内部填写表单而生成HTML页面
java.lang.String | InfoViewMgr.forMultiView(InfoView _oInfoView, InfoViewView _oPubView, java.util.List fileList)
java.lang.String | InfoViewMgr.forPreviewMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | InfoViewMgr.forPublishMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)
void | InfoViewMgr.save(InfoViewView _oView)

参数类型为 InfoViewView 的 com.trs.components.infoview 中的构造方法
RightHostInfoViewView(InfoViewView _view)

com.trs.components.infoview.extract 中 InfoViewView 的使用

参数类型为 InfoViewView 的 com.trs.components.infoview.extract 中的方法
void | XSLTViewConstrainter.init(InfoView _oInfoView, InfoViewView _oInfoViewView)
void | XSLTViewConstrainter.init(InfoView _oInfoView, InfoViewView _oInfoViewView, java.util.List _lsGroups, java.util.List _lsFields)

com.trs.components.infoview.persistent 中 InfoViewView 的使用

返回 InfoViewView 的 com.trs.components.infoview.persistent 中的方法
static InfoViewView | InfoViewView.findById(int id) 返回指定ID的表单视图对象
InfoViewView | InfoViewGroup.getView()

参数类型为 InfoViewView 的 com.trs.components.infoview.persistent 中的方法
 boolean InfoViewGroup.setView(InfoViewView _oView)

com.trs.components.infoview.publish.tagparser 中 InfoViewView 的使用

返回 InfoViewView 的 com.trs.components.infoview.publish.tagparser 中的方法
 InfoViewView[] TagParserInfoViews.getPublishViews(InfoView _oInfoView, boolean _bPushlishAll, java.lang.String sPubViewNames)

com.trs.service 中 InfoViewView 的使用

返回 InfoViewView 的 com.trs.service 中的方法
 InfoViewView IInfoViewService.findViewById(int _iViewID)
查找指定ID的自定义表单视图

参数类型为 InfoViewView 的 com.trs.service 中的方法
java.lang.String | IInfoViewService.forFillOut(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面 事实上生成的HTML页面不仅用于内部填写表单、还用在表单预览、表单数据察看。
java.lang.String | IInfoViewService.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int nFlowDocId)
java.lang.String | IInfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView)
java.lang.String | IInfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)
void | IInfoViewService.save(InfoViewView _oView) 保存指定的自定义表单视图

com.trs.service.impl 中 InfoViewView 的使用

返回 InfoViewView 的 com.trs.service.impl 中的方法
 InfoViewView InfoViewService.findViewById(int _iViewID)

参数类型为 InfoViewView 的 com.trs.service.impl 中的方法
java.lang.String | InfoViewService.forFillOut(InfoView _oInfoView, InfoViewView _oView)
java.lang.String | InfoViewService.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int _flowDocId)
java.lang.String | InfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView)
java.lang.String | InfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)
void | InfoViewService.save(InfoViewView _oView)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.persistent.InfoViewViews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.persistent.InfoViewViews
的使用

使用 InfoViewViews 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview 中 InfoViewViews 的使用

返回 InfoViewViews 的 com.trs.components.infoview 中的方法
 InfoViewViews InfoViewMgr.filterByFlow(InfoViewViews _oInfoViewViews, int nFlowDocId)
通过工作流过滤可查看的表单视图

参数类型为 InfoViewViews 的 com.trs.components.infoview 中的方法
 InfoViewViews InfoViewMgr.filterByFlow(InfoViewViews _oInfoViewViews, int nFlowDocId)
通过工作流过滤可查看的表单视图

com.trs.components.infoview.persistent 中 InfoViewViews 的使用

返回 InfoViewViews 的 com.trs.components.infoview.persistent 中的方法
static InfoViewViews | InfoViewViews.findBy(InfoView _iv)
static InfoViewViews | InfoViewViews.findDefaultBy(InfoView _iv)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.infoview.process
类
SendEmailForInfoViewHandler


com.trs.components.infoview.process

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.process

类摘要
SendEmailForInfoViewHandler


com.trs.components.infoview.process 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.process 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.infoview.process.SendEmailForInfoViewHandler (implements com.trs.cms.process.engine.IActionHandler)


软件包 com.trs.components.infoview.process 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.process
的使用

没有 com.trs.components.infoview.process 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SendEmailForInfoViewHandler

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.process
类 SendEmailForInfoViewHandler

java.lang.Object
    继承者  com.trs.components.infoview.process.SendEmailForInfoViewHandler
所有已实现的接口：
IActionHandler
public class SendEmailForInfoViewHandler
extends java.lang.Object
implements IActionHandler

构造方法摘要
SendEmailForInfoViewHandler()
方法摘要
boolean | execute(ExecuteContext _context, FlowAction _action)
java.lang.String | parsePageVariables(java.lang.String _sContent, java.util.Map _variables)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SendEmailForInfoViewHandler

public SendEmailForInfoViewHandler()
方法详细信息

execute

public boolean execute(ExecuteContext _context,
                       FlowAction _action)
                throws WCMException
指定者：
接口 IActionHandler 中的 execute
抛出：
WCMException

parsePageVariables

public java.lang.String parsePageVariables(java.lang.String _sContent,
                                           java.util.Map _variables)
                                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.infoview.process.SendEmailForInfoViewHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.process.SendEmailForInfoViewHandler
的使用

没有 com.trs.components.infoview.process.SendEmailForInfoViewHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FormProperty

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 FormProperty

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.FormProperty

public class FormProperty
extends java.lang.Object

描述发布后表单FORM的一些属性 TODO;这个类应该放在哪一个package中

作者：
Martin (Fu Chengrui)

字段摘要
static java.lang.String | GATEWAY_FILE_UPLOAD_URL
static java.lang.String | GATEWAY_FORM_ACTION
static java.lang.String | GATEWAY_INIT_PAGE
static java.lang.String | GATEWAY_READ_FILE_URL
static java.util.Map | GATEWAY_RESERVED_PAGES
static java.lang.String | GATEWAY_VALID_VERIFY_CODE_URL
static java.lang.String | GATEWAY_VERIFY_CODE_URL
构造方法摘要
FormProperty()
方法摘要
int | getChannelID()
java.lang.String | getFileAction()
java.lang.String | getFormAction() 初始化wcm与网关的交互页配置 开始
java.lang.String | getFormEncoding()
java.lang.String | getFormExtra()
java.lang.String | getGateWayInitPage()
java.util.Map | getGatewayPageProperties()
java.lang.String | getGatewayPageProperty(java.lang.String _key) 初始化wcm与网关的交互页配置 结束
java.lang.String | getInfoviewTitle()
java.lang.String | getInfoViewViewName()
boolean | getNeedInit()
java.util.Map | getNonReservedGatewayPageProps()
java.lang.String | getReadFileURL()
java.lang.String | getSelfURL()
int | getSiteID()
java.lang.String | getSubmitButtonHTML()
java.lang.String | getValidVerifycodeUrl()
java.lang.String | getVerifyCodeURL()
boolean | isOnlyCached()
boolean | isPublishAllViews()
boolean | isResetButton()
boolean | isVerifyCodeEnable()
void | NeedInit(boolean bNeedInit)
void | normalize()
void | setChannelID(int channelID)
void | setFileAction(java.lang.String fileAction)
void | setFormAction(java.lang.String formAction)
void | setFormEncoding(java.lang.String formEncoding)
void | setFormExtra(java.lang.String _formExtra)
void | setGateWayInitPage(java.lang.String initPage)
void | setGatewayPageProperties(java.util.Map _hConfigProps)
void | setGatewayPageProperty(java.lang.String _key, java.lang.String _val)
void | setInfoviewTitle(java.lang.String _sInfoviewTitle)
void | setInfoViewViewName(java.lang.String _sViewName)
void | setOnlyCached(boolean onlyCached)
void | setPublishAllViews(boolean _bPublishAll)
void | setReadFileURL(java.lang.String readFileURL)
void | setResetButton(boolean resetButton)
void | setSelfURL(java.lang.String selfURL)
void | setSiteID(int siteID)
void | setSubmitButtonHTML(java.lang.String submitButtonHTML)
void | setValidVerifycodeUrl(java.lang.String validVerifyCodePage)
void | setVerifyCodeEnable(boolean verifyCode)
void | setVerifyCodeURL(java.lang.String verifyCodeURL)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

GATEWAY_FORM_ACTION

public static final java.lang.String GATEWAY_FORM_ACTION
另请参见：
常量字段值

GATEWAY_READ_FILE_URL

public static final java.lang.String GATEWAY_READ_FILE_URL
另请参见：
常量字段值

GATEWAY_FILE_UPLOAD_URL

public static final java.lang.String GATEWAY_FILE_UPLOAD_URL
另请参见：
常量字段值

GATEWAY_VERIFY_CODE_URL

public static final java.lang.String GATEWAY_VERIFY_CODE_URL
另请参见：
常量字段值

GATEWAY_INIT_PAGE

public static final java.lang.String GATEWAY_INIT_PAGE
另请参见：
常量字段值

GATEWAY_VALID_VERIFY_CODE_URL

public static final java.lang.String GATEWAY_VALID_VERIFY_CODE_URL
另请参见：
常量字段值

GATEWAY_RESERVED_PAGES

public static final java.util.Map GATEWAY_RESERVED_PAGES
构造方法详细信息

FormProperty

public FormProperty()
方法详细信息

normalize

public void normalize()

getSelfURL

public java.lang.String getSelfURL()

setSelfURL

public void setSelfURL(java.lang.String selfURL)

getChannelID

public int getChannelID()

setChannelID

public void setChannelID(int channelID)

getFormExtra

public java.lang.String getFormExtra()

setFormExtra

public void setFormExtra(java.lang.String _formExtra)

getFormEncoding

public java.lang.String getFormEncoding()

setFormEncoding

public void setFormEncoding(java.lang.String formEncoding)

isResetButton

public boolean isResetButton()

setResetButton

public void setResetButton(boolean resetButton)

isOnlyCached

public boolean isOnlyCached()

setOnlyCached

public void setOnlyCached(boolean onlyCached)

getSubmitButtonHTML

public java.lang.String getSubmitButtonHTML()

setSubmitButtonHTML

public void setSubmitButtonHTML(java.lang.String submitButtonHTML)

getSiteID

public int getSiteID()

setSiteID

public void setSiteID(int siteID)

getInfoViewViewName

public java.lang.String getInfoViewViewName()

setInfoViewViewName

public void setInfoViewViewName(java.lang.String _sViewName)

isPublishAllViews

public boolean isPublishAllViews()

setPublishAllViews

public void setPublishAllViews(boolean _bPublishAll)

getInfoviewTitle

public java.lang.String getInfoviewTitle()

setInfoviewTitle

public void setInfoviewTitle(java.lang.String _sInfoviewTitle)

isVerifyCodeEnable

public boolean isVerifyCodeEnable()

setVerifyCodeEnable

public void setVerifyCodeEnable(boolean verifyCode)

getNeedInit

public boolean getNeedInit()

NeedInit

public void NeedInit(boolean bNeedInit)

getFormAction

public java.lang.String getFormAction()
初始化wcm与网关的交互页配置 开始

setFormAction

public void setFormAction(java.lang.String formAction)

getReadFileURL

public java.lang.String getReadFileURL()

setReadFileURL

public void setReadFileURL(java.lang.String readFileURL)

getFileAction

public java.lang.String getFileAction()

setFileAction

public void setFileAction(java.lang.String fileAction)

getVerifyCodeURL

public java.lang.String getVerifyCodeURL()

setVerifyCodeURL

public void setVerifyCodeURL(java.lang.String verifyCodeURL)

getGateWayInitPage

public java.lang.String getGateWayInitPage()

setGateWayInitPage

public void setGateWayInitPage(java.lang.String initPage)

getValidVerifycodeUrl

public java.lang.String getValidVerifycodeUrl()

setValidVerifycodeUrl

public void setValidVerifycodeUrl(java.lang.String validVerifyCodePage)

getGatewayPageProperty

public java.lang.String getGatewayPageProperty(java.lang.String _key)
初始化wcm与网关的交互页配置 结束

setGatewayPageProperty

public void setGatewayPageProperty(java.lang.String _key,
                                   java.lang.String _val)

setGatewayPageProperties

public void setGatewayPageProperties(java.util.Map _hConfigProps)

getGatewayPageProperties

public java.util.Map getGatewayPageProperties()

getNonReservedGatewayPageProps

public java.util.Map getNonReservedGatewayPageProps()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InfoviewSpecailTagParseHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 InfoviewSpecailTagParseHelper

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.InfoviewSpecailTagParseHelper

public class InfoviewSpecailTagParseHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

方法摘要
static java.lang.String[] parseChnlRelatedEnum(PublishTagContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

parseChnlRelatedEnum

public static java.lang.String[] parseChnlRelatedEnum(PublishTagContext _context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.infoview.publish.tagparser
类
FormProperty
InfoviewSpecailTagParseHelper
TagParserInfoView
TagParserInfoViewData
TagParserInfoViewHelper
TagParserInfoViewNav
TagParserInfoViewNavs
TagParserInfoViewPage
TagParserInfoViews


com.trs.components.infoview.publish.tagparser

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.infoview.publish.tagparser

结合 MS InfoPath 实现的自定义表单的发布置标。

请参见：
描述

类摘要
FormProperty | 描述发布后表单FORM的一些属性 TODO;这个类应该放在哪一个package中
InfoviewSpecailTagParseHelper | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserInfoView | 用于发布自定义表单的置标
TagParserInfoViewData |
TagParserInfoViewHelper | 用于发布自定义表单的置标
TagParserInfoViewNav | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserInfoViewNavs | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserInfoViewPage | 用于发布自定义表单的置标
TagParserInfoViews | 用于发布自定义表单的置标

软件包 com.trs.components.infoview.publish.tagparser 的描述

结合 MS InfoPath 实现的自定义表单的发布置标。


com.trs.components.infoview.publish.tagparser 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.publish.tagparser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.infoview.publish.tagparser.FormProperty
    • com.trs.components.infoview.publish.tagparser.InfoviewSpecailTagParseHelper
    • com.trs.components.infoview.publish.tagparser.TagParserInfoView (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewData (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.infoview.publish.tagparser.TagParserInfoViews (implements com.trs.components.common.publish.domain.tagparser.ITagParser)


软件包 com.trs.components.infoview.publish.tagparser 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.infoview.publish.tagparser
的使用

使用 com.trs.components.infoview.publish.tagparser 的软件包
com.trs.components.infoview 结合 MS InfoPath 实现自定义表单。

com.trs.components.infoview 使用的 com.trs.components.infoview.publish.tagparser 中的类
FormProperty
描述发布后表单FORM的一些属性 TODO;这个类应该放在哪一个package中

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TagParserInfoView

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 TagParserInfoView

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.TagParserInfoView
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserInfoView
extends java.lang.Object
implements ITagParser

用于发布自定义表单的置标

作者：
Martin (Fu Chengrui)

构造方法摘要
TagParserInfoView()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserInfoView

public TagParserInfoView()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserInfoViewData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 TagParserInfoViewData

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.TagParserInfoViewData
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserInfoViewData
extends java.lang.Object
implements ITagParser

构造方法摘要
TagParserInfoViewData()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserInfoViewData

public TagParserInfoViewData()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserInfoViewHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 TagParserInfoViewHelper

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserInfoViewHelper
extends java.lang.Object
implements ITagParser

用于发布自定义表单的置标

作者：
LY

构造方法摘要
TagParserInfoViewHelper()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserInfoViewHelper

public TagParserInfoViewHelper()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserInfoViewNav

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 TagParserInfoViewNav

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserInfoViewNav
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
TagParserInfoViewNav()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserInfoViewNav

public TagParserInfoViewNav()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.
另请参见：
ITagParser.setTagItem(TagItem)

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserInfoViewNavs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 TagParserInfoViewNavs

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserInfoViewNavs
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

字段摘要
static java.lang.String | INFOVIEW_NAVS_ID
static java.lang.String | KEY_HTTP_URL
static java.lang.String | KEY_INFOVIEW_VIEW
static java.lang.String | KEY_VIEW_INDEX
构造方法摘要
TagParserInfoViewNavs()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

KEY_HTTP_URL

public static final java.lang.String KEY_HTTP_URL
另请参见：
常量字段值

KEY_VIEW_INDEX

public static final java.lang.String KEY_VIEW_INDEX
另请参见：
常量字段值

KEY_INFOVIEW_VIEW

public static final java.lang.String KEY_INFOVIEW_VIEW
另请参见：
常量字段值

INFOVIEW_NAVS_ID

public static java.lang.String INFOVIEW_NAVS_ID
构造方法详细信息

TagParserInfoViewNavs

public TagParserInfoViewNavs()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserInfoViewPage

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 TagParserInfoViewPage

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserInfoViewPage
extends java.lang.Object
implements ITagParser

用于发布自定义表单的置标

作者：
LY

构造方法摘要
TagParserInfoViewPage()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserInfoViewPage

public TagParserInfoViewPage()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserInfoViews

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.infoview.publish.tagparser
类 TagParserInfoViews

java.lang.Object
    继承者  com.trs.components.infoview.publish.tagparser.TagParserInfoViews
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserInfoViews
extends java.lang.Object
implements ITagParser

用于发布自定义表单的置标

作者：
LY

字段摘要
static java.lang.String | KEY_HOSTID
static java.lang.String | KEY_INFOVIEW
static java.lang.String | KEY_INFOVIEW_RESOURCE
static java.lang.String | KEY_INFOVIEW_VIEW
static java.lang.String | KEY_INFOVIEW_VIEWS
构造方法摘要
TagParserInfoViews()
缺省构造方法
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
InfoViewView[] | getPublishViews(InfoView _oInfoView, boolean _bPushlishAll, java.lang.String sPubViewNames)
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

KEY_INFOVIEW_VIEW

public static final java.lang.String KEY_INFOVIEW_VIEW
另请参见：
常量字段值

KEY_INFOVIEW_VIEWS

public static final java.lang.String KEY_INFOVIEW_VIEWS
另请参见：
常量字段值

KEY_HOSTID

public static final java.lang.String KEY_HOSTID
另请参见：
常量字段值

KEY_INFOVIEW

public static final java.lang.String KEY_INFOVIEW
另请参见：
常量字段值

KEY_INFOVIEW_RESOURCE

public static final java.lang.String KEY_INFOVIEW_RESOURCE
另请参见：
常量字段值
构造方法详细信息

TagParserInfoViews

public TagParserInfoViews()
缺省构造方法

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

getPublishViews

public InfoViewView[] getPublishViews(InfoView _oInfoView,
                                      boolean _bPushlishAll,
                                      java.lang.String sPubViewNames)
                               throws WCMException
参数：
_oInfoView -
_oProperty -
返回：
抛出：
WCMException

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.infoview.publish.tagparser.FormProperty 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.FormProperty
的使用

使用 FormProperty 的软件包
com.trs.components.infoview 结合 MS InfoPath 实现自定义表单。

com.trs.components.infoview 中 FormProperty 的使用

参数类型为 FormProperty 的 com.trs.components.infoview 中的方法
java.lang.String | InfoViewMgr.forInfoGate(InfoView _oInfoView, FormProperty _oProperty)
java.lang.String | InfoViewMgr.forPreview(InfoView _oInfoView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | InfoViewMgr.forPreviewMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | InfoViewMgr.forPublish(InfoView _oInfoView, FormProperty _oProperty, java.util.List fileList)
java.lang.String | InfoViewMgr.forPublishMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.publish.tagparser.InfoviewSpecailTagParseHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.InfoviewSpecailTagParseHelper
的使用

没有 com.trs.components.infoview.publish.tagparser.InfoviewSpecailTagParseHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.publish.tagparser.TagParserInfoView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.TagParserInfoView
的使用

没有 com.trs.components.infoview.publish.tagparser.TagParserInfoView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData
的使用

没有 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper
的使用

没有 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav
的使用

没有 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs
的使用

没有 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage
的使用

没有 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews
的使用

没有 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


MetaDataConstants

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata
类 MetaDataConstants

java.lang.Object
    继承者  com.trs.components.metadata.MetaDataConstants

public class MetaDataConstants
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static MetaDataTypes | DATA_TYPES
static MetaDataTypes | DB_DATA_TYPES
static MetaDataTypes | DEFAULT_FIELDS
static int | FIELD_TYPE_APPENDIX
static int | FIELD_TYPE_CHECKBOX
static int | FIELD_TYPE_CLASS
static int | FIELD_TYPE_ENUMVALUE
static int | FIELD_TYPE_HTML
static int | FIELD_TYPE_HTML_CHAR
static int | FIELD_TYPE_INPUT_SELECT
static int | FIELD_TYPE_MULTITEXT
static int | FIELD_TYPE_NORMALTEXT
static int | FIELD_TYPE_PASSWORD
static int | FIELD_TYPE_RADIO
static int | FIELD_TYPE_RELDOC
static int | FIELD_TYPE_SELECT
static int | FIELD_TYPE_SELFDEFINE
static int | FIELD_TYPE_SUGGESTION
static int | FIELD_TYPE_TIMESTAMP
static int | FIELD_TYPE_TRUEORFALSE
static java.lang.String | FIELDNAME_CHANNEL_ID
static java.lang.String | FIELDNAME_METADATA_ID
static float | INCREASE_FIELD_LENGTH_FACTOR
static int | INCREASE_FIELD_LENGTH_LIMIT
static java.lang.String | PREFIX_DBRELATION_NAME 数据库中多表视图记录关联关系的前缀名 增加前缀名便于记忆、管理；避免重名
static java.lang.String | PREFIX_DBTABLE_NAME 元数据物理表前缀名 增加前缀名便于记忆、管理；避免重名
static java.lang.String | PREFIX_DBVIEW_NAME 数据库中视图前缀名 增加前缀名便于记忆、管理；避免重名
构造方法摘要
MetaDataConstants()
方法摘要
static int | formatOfEnumValue(int _iType)
static int | getCompressLength(int _nOldLength) 传入一个数据库字段的长度，获取该字段能存储的数据长度
static int | getExpandLength(int _nOldLength) 传入一个长度整数，获取数据库存储该长度时，需要的字段长度
static java.lang.String | makeTrueTableName(java.lang.String _sTableName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FIELDNAME_METADATA_ID

public static final java.lang.String FIELDNAME_METADATA_ID
另请参见：
常量字段值

FIELDNAME_CHANNEL_ID

public static final java.lang.String FIELDNAME_CHANNEL_ID
另请参见：
常量字段值

INCREASE_FIELD_LENGTH_LIMIT

public static final int INCREASE_FIELD_LENGTH_LIMIT
另请参见：
常量字段值

INCREASE_FIELD_LENGTH_FACTOR

public static final float INCREASE_FIELD_LENGTH_FACTOR
另请参见：
常量字段值

DEFAULT_FIELDS

public static final MetaDataTypes DEFAULT_FIELDS

PREFIX_DBTABLE_NAME

public static final java.lang.String PREFIX_DBTABLE_NAME
元数据物理表前缀名 增加前缀名便于记忆、管理；避免重名

另请参见：
常量字段值

PREFIX_DBVIEW_NAME

public static final java.lang.String PREFIX_DBVIEW_NAME
数据库中视图前缀名 增加前缀名便于记忆、管理；避免重名

另请参见：
常量字段值

PREFIX_DBRELATION_NAME

public static final java.lang.String PREFIX_DBRELATION_NAME
数据库中多表视图记录关联关系的前缀名 增加前缀名便于记忆、管理；避免重名

另请参见：
常量字段值

FIELD_TYPE_ENUMVALUE

public static final int FIELD_TYPE_ENUMVALUE
另请参见：
常量字段值

FIELD_TYPE_APPENDIX

public static final int FIELD_TYPE_APPENDIX
另请参见：
常量字段值

FIELD_TYPE_CLASS

public static final int FIELD_TYPE_CLASS
另请参见：
常量字段值

FIELD_TYPE_HTML

public static final int FIELD_TYPE_HTML
另请参见：
常量字段值

FIELD_TYPE_RELDOC

public static final int FIELD_TYPE_RELDOC
另请参见：
常量字段值

FIELD_TYPE_INPUT_SELECT

public static final int FIELD_TYPE_INPUT_SELECT
另请参见：
常量字段值

FIELD_TYPE_HTML_CHAR

public static final int FIELD_TYPE_HTML_CHAR
另请参见：
常量字段值

FIELD_TYPE_SUGGESTION

public static final int FIELD_TYPE_SUGGESTION
另请参见：
常量字段值

FIELD_TYPE_RADIO

public static final int FIELD_TYPE_RADIO
另请参见：
常量字段值

FIELD_TYPE_SELECT

public static final int FIELD_TYPE_SELECT
另请参见：
常量字段值

FIELD_TYPE_CHECKBOX

public static final int FIELD_TYPE_CHECKBOX
另请参见：
常量字段值

FIELD_TYPE_NORMALTEXT

public static final int FIELD_TYPE_NORMALTEXT
另请参见：
常量字段值

FIELD_TYPE_PASSWORD

public static final int FIELD_TYPE_PASSWORD
另请参见：
常量字段值

FIELD_TYPE_MULTITEXT

public static final int FIELD_TYPE_MULTITEXT
另请参见：
常量字段值

FIELD_TYPE_TRUEORFALSE

public static final int FIELD_TYPE_TRUEORFALSE
另请参见：
常量字段值

FIELD_TYPE_SELFDEFINE

public static final int FIELD_TYPE_SELFDEFINE
另请参见：
常量字段值

FIELD_TYPE_TIMESTAMP

public static final int FIELD_TYPE_TIMESTAMP
另请参见：
常量字段值

DATA_TYPES

public static final MetaDataTypes DATA_TYPES

DB_DATA_TYPES

public static final MetaDataTypes DB_DATA_TYPES
构造方法详细信息

MetaDataConstants

public MetaDataConstants()
方法详细信息

makeTrueTableName

public static java.lang.String makeTrueTableName(java.lang.String _sTableName)
参数：
_sTableName -
返回：

formatOfEnumValue

public static int formatOfEnumValue(int _iType)

getExpandLength

public static int getExpandLength(int _nOldLength)
传入一个长度整数，获取数据库存储该长度时，需要的字段长度

参数：
_nOldLength -
返回：
如果该长度大于INCREASE_FIELD_LENGTH_LIMIT，则返回原指， 否则返回乘以INCREASE_FIELD_LENGTH_FACTOR之后的值

getCompressLength

public static int getCompressLength(int _nOldLength)
传入一个数据库字段的长度，获取该字段能存储的数据长度

参数：
_nOldLength -
返回：
返回传入的长度除于INCREASE_FIELD_LENGTH_FACTOR得到的结果向下取整
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata
类
MetaDataConstants


com.trs.components.metadata

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata

类摘要
MetaDataConstants Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.metadata 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.MetaDataConstants


软件包 com.trs.components.metadata 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata
的使用

没有 com.trs.components.metadata 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChnlDocLCListenerForSynToMetaData

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 ChnlDocLCListenerForSynToMetaData

java.lang.Object
    继承者  com.trs.components.metadata.center.ChnlDocLCListenerForSynToMetaData
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class ChnlDocLCListenerForSynToMetaData
extends java.lang.Object
implements IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChnlDocLCListenerForSynToMetaData()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocLCListenerForSynToMetaData

public ChnlDocLCListenerForSynToMetaData()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ClassDocumentsHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 ClassDocumentsHelper

java.lang.Object
    继承者  com.trs.components.metadata.center.ClassDocumentsHelper

public class ClassDocumentsHelper
extends java.lang.Object

构造方法摘要
ClassDocumentsHelper()
方法摘要
static MetaViewDatas queryMetaViewDatas(MetaView _view, ClassInfos _classInfos, boolean _bOnlyLeaf, WCMFilter _extraFilter)
获取指定视图中同时属于指定的多个分类（含下面的子分类）的文档 子分类仅仅只叶子节点
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassDocumentsHelper

public ClassDocumentsHelper()
方法详细信息

queryMetaViewDatas

public static MetaViewDatas queryMetaViewDatas(MetaView _view,
                                               ClassInfos _classInfos,
                                               boolean _bOnlyLeaf,
                                               WCMFilter _extraFilter)
                                        throws WCMException
获取指定视图中同时属于指定的多个分类（含下面的子分类）的文档 子分类仅仅只叶子节点

参数：
_view - 指定的视图
_classInfos - 指定的多个分类
_bOnlyLeaf - 是否仅仅只是限定叶子节点的分类
_extraFilter - 针对提前的数据设置的额外过滤条件，SelectFields也是通过这个Filter反映
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassDocumentsHelperTest

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 ClassDocumentsHelperTest

java.lang.Object
    继承者  junit.framework.Assert
        继承者  junit.framework.TestCase
            继承者  com.trs.TRSWCMBaseTest
                继承者  com.trs.components.metadata.center.ClassDocumentsHelperTest
所有已实现的接口：
junit.framework.Test
public class ClassDocumentsHelperTest
extends com.trs.TRSWCMBaseTest

构造方法摘要
ClassDocumentsHelperTest()
方法摘要
 void testQueryMetaViewDatas()
从类 junit.framework.TestCase 继承的方法
countTestCases, getName, run, run, runBare, setName, toString
从类 junit.framework.Assert 继承的方法
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ClassDocumentsHelperTest

public ClassDocumentsHelperTest()
方法详细信息

testQueryMetaViewDatas

public void testQueryMetaViewDatas()
                            throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoView

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 ClassInfoView

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.metadata.center.ClassInfoView
所有已实现的接口：
java.lang.Cloneable
public class ClassInfoView
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ClassInfoView()
构造函数：保留默认接口
方法摘要
static ClassInfoView | createNewInstance() 产生当前对象[ClassInfoView]的实例
static ClassInfoView | findById(int _nId) 提取指定ID的对象
static ClassInfoView | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getClassInfoId() 提取属性：ClassInfoId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getMetaDataID() 提取属性：MetaDataID
int | getViewID() 提取属性：ViewID
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setClassInfoId(int _nClassInfoId) 设置属性：ClassInfoId
boolean | setMetaDataID(int _nMetaDataID) 设置属性：MetaDataID
boolean | setViewID(int _nViewID) 设置属性：ViewID
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ClassInfoView

public ClassInfoView()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getClassInfoId

public int getClassInfoId()
提取属性：ClassInfoId

返回：
ClassInfoId

setClassInfoId

public boolean setClassInfoId(int _nClassInfoId)
                       throws WCMException
设置属性：ClassInfoId

参数：
_nClassInfoId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMetaDataID

public int getMetaDataID()
提取属性：MetaDataID

返回：
MetaDataID

setMetaDataID

public boolean setMetaDataID(int _nMetaDataID)
                      throws WCMException
设置属性：MetaDataID

参数：
_nMetaDataID - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewID

public int getViewID()
提取属性：ViewID

返回：
ViewID

setViewID

public boolean setViewID(int _nViewID)
                  throws WCMException
设置属性：ViewID

参数：
_nViewID - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final ClassInfoView findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ClassInfoView createNewInstance()
                                             throws WCMException
产生当前对象[ClassInfoView]的实例

返回：
当前对象的实例[ClassInfoView]
抛出：
WCMException

findByKey

public static final ClassInfoView findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoViewMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 ClassInfoViewMgr

java.lang.Object
    继承者  com.trs.components.metadata.center.ClassInfoViewMgr
所有已实现的接口：
IClassInfoViewMgr
public class ClassInfoViewMgr
extends java.lang.Object
implements IClassInfoViewMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
管理视图数据和分类法的关联影射
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ClassInfoViewMgr()
方法摘要
void | copyViewDataByClassInfos(MetaViewData viewData, ClassInfos destClassInfos, User currUser) 将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos
void | copyViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos destClassInfos, User currUser) 将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos
void | copyViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos destClassInfos, User currUser) 将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos
void | copyViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos destClassInfos, User currUser) 将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos
void | delete(User user, ClassInfo _oClassInfo) 删除_oClassInfo下的文档关联
void | delete(User _currUser, MetaViewData oMetaViewData) 删除ClassInfoView中满足MetaDataID的记录
IClassInfoMgr | getClassInfoMgr()
IMetaDataDefCacheMgr | getMetaDataDefCacheMgr()
IMetaDataDefMgr | getMetaDataDefMgr()
void | moveViewDataByClassInfos(MetaViewData viewData, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser) 将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | moveViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser) 将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | moveViewDatasByClassInfo(User user, ClassInfo srcClassInfo, int destClassInfoId) 将记录的分类法由_oSrcClassInfo转换为_nDestClassInfoId 如果_nDestClassInfoId为0，则只删除记录的_oSrcClassInfo
void | moveViewDatasByClassInfo(User user, ClassInfo oClassInfo, java.lang.String _sDestClassInfoId) 将记录的分类法由_oSrcClassInfo转换为_destClassInfoId 如果_destClassInfoId为null，则只删除记录的_oSrcClassInfo
void | moveViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser) 将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | moveViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser) 将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
ClassInfos | queryClassInfos(User user, Documents documents, WCMFilter _filter) 根据文档对象集合获取获取分类法信息集合
ClassInfos | queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
int | queryDocumentNum(User _currUser, ClassInfo _classInfo) 根据分类法对象返回相应的文档数目
int | queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)
Documents | queryDocuments(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
MetaViewDatas | queryViewDatas(User user, ClassInfo classInfo, MetaView metaView) 获取指定视图指定分类法下的数据集合
MetaViews | queryViews(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象返回相应的视图对象集合
void | save(User _currUser, MetaViewData _oMetaViewData) 保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoViewMgr

public ClassInfoViewMgr()
方法详细信息

getClassInfoMgr

public IClassInfoMgr getClassInfoMgr()

getMetaDataDefMgr

public IMetaDataDefMgr getMetaDataDefMgr()

getMetaDataDefCacheMgr

public IMetaDataDefCacheMgr getMetaDataDefCacheMgr()

save

public void save(User _currUser,
                 MetaViewData _oMetaViewData)
          throws WCMException
保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录

指定者：
接口 IClassInfoViewMgr 中的 save
参数：
_currUser -
oMetaViewField -
抛出：
WCMException

delete

public void delete(User _currUser,
                   MetaViewData oMetaViewData)
            throws WCMException
删除ClassInfoView中满足MetaDataID的记录

指定者：
接口 IClassInfoViewMgr 中的 delete
参数：
_currUser -
oMetaViewData -
抛出：
WCMException

queryDocuments

public Documents queryDocuments(User _currUser,
                                ClassInfo _oClassInfo,
                                WCMFilter _filter)
                         throws WCMException
根据分类法对象得到相应的文档集合对象

指定者：
接口 IClassInfoViewMgr 中的 queryDocuments
参数：
_currUser -
oClassInfos -
_filter -
返回：
抛出：
WCMException

queryDocuments

public Documents queryDocuments(User _currUser,
                                ClassInfos oClassInfos,
                                WCMFilter _filter)
                         throws WCMException
根据分类法集合对象得到相应的文档集合对象

指定者：
接口 IClassInfoViewMgr 中的 queryDocuments
参数：
_currUser -
oClassInfos -
_filter -
返回：
抛出：
WCMException

queryViews

public MetaViews queryViews(User _currUser,
                            ClassInfos oClassInfos,
                            WCMFilter _filter)
                     throws WCMException
根据分类法集合对象返回相应的视图对象集合

指定者：
接口 IClassInfoViewMgr 中的 queryViews
参数：
_currUser -
oClassInfos -
_filter -
返回：
抛出：
WCMException

queryClassInfos

public ClassInfos queryClassInfos(User _currUser,
                                  Document oDocument,
                                  WCMFilter _filter)
                           throws WCMException
根据文档对象获取获取分类法信息集合

指定者：
接口 IClassInfoViewMgr 中的 queryClassInfos
参数：
_currUser -
oDocument -
_filter -
返回：
抛出：
WCMException

queryDocumentNum

public int queryDocumentNum(User _currUser,
                            ClassInfo _classInfo)
                     throws WCMException
根据分类法对象返回相应的文档数目

指定者：
接口 IClassInfoViewMgr 中的 queryDocumentNum
参数：
_currUser -
oClassInfos -
_filter -
返回：
抛出：
WCMException

queryDocumentNum

public int queryDocumentNum(User _currUser,
                            ClassInfo _classInfo,
                            WCMFilter _filter)
                     throws WCMException
指定者：
接口 IClassInfoViewMgr 中的 queryDocumentNum
抛出：
WCMException

delete

public void delete(User user,
                   ClassInfo _oClassInfo)
            throws WCMException
从接口 IClassInfoViewMgr 复制的描述
删除_oClassInfo下的文档关联

指定者：
接口 IClassInfoViewMgr 中的 delete
抛出：
WCMException

queryViewDatas

public MetaViewDatas queryViewDatas(User user,
                                    ClassInfo classInfo,
                                    MetaView metaView)
                             throws WCMException
从接口 IClassInfoViewMgr 复制的描述
获取指定视图指定分类法下的数据集合

指定者：
接口 IClassInfoViewMgr 中的 queryViewDatas
返回：
抛出：
WCMException

moveViewDatasByClassInfo

public void moveViewDatasByClassInfo(User user,
                                     ClassInfo srcClassInfo,
                                     int destClassInfoId)
                              throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录的分类法由_oSrcClassInfo转换为_nDestClassInfoId 如果_nDestClassInfoId为0，则只删除记录的_oSrcClassInfo

指定者：
接口 IClassInfoViewMgr 中的 moveViewDatasByClassInfo
抛出：
WCMException

moveViewDatasByClassInfo

public void moveViewDatasByClassInfo(User user,
                                     ClassInfo oClassInfo,
                                     java.lang.String _sDestClassInfoId)
                              throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录的分类法由_oSrcClassInfo转换为_destClassInfoId 如果_destClassInfoId为null，则只删除记录的_oSrcClassInfo

指定者：
接口 IClassInfoViewMgr 中的 moveViewDatasByClassInfo
抛出：
WCMException

moveViewDatasByClassInfo

public void moveViewDatasByClassInfo(MetaViewData oViewData,
                                     ClassInfo oSrcClassInfo,
                                     ClassInfo oDestClassInfo,
                                     User currUser)
                              throws WCMException
获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值

指定者：
接口 IClassInfoViewMgr 中的 moveViewDatasByClassInfo
参数：
oViewData -
oSrcClassInfo -
oDestClassInfo -
currUser -
抛出：
WCMException

moveViewDatasByClassInfo

public void moveViewDatasByClassInfo(MetaViewDatas oViewDatas,
                                     ClassInfo oSrcClassInfo,
                                     ClassInfo oDestClassInfo,
                                     User currUser)
                              throws WCMException
获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值

指定者：
接口 IClassInfoViewMgr 中的 moveViewDatasByClassInfo
参数：
oViewDatas -
oSrcClassInfo -
oDestClassInfo -
currUser -
抛出：
WCMException

moveViewDatasByClassInfo

public void moveViewDatasByClassInfo(MetaViewData oViewData,
                                     MetaViewField oViewField,
                                     ClassInfo oSrcClassInfo,
                                     ClassInfo oDestClassInfo,
                                     User oCurrUser)
                              throws WCMException
将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类

指定者：
接口 IClassInfoViewMgr 中的 moveViewDatasByClassInfo
参数：
oViewData -
oViewField -
oSrcClassInfo -
oDestClassInfo -
oCurrUser -
抛出：
WCMException

queryClassInfos

public ClassInfos queryClassInfos(User user,
                                  Documents documents,
                                  WCMFilter _filter)
                           throws WCMException
从接口 IClassInfoViewMgr 复制的描述
根据文档对象集合获取获取分类法信息集合

指定者：
接口 IClassInfoViewMgr 中的 queryClassInfos
返回：
抛出：
WCMException

moveViewDatasByClassInfos

public void moveViewDatasByClassInfos(MetaViewDatas viewDatas,
                                      ClassInfos srcClassInfos,
                                      ClassInfo destClassInfo,
                                      User currUser)
                               throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类

指定者：
接口 IClassInfoViewMgr 中的 moveViewDatasByClassInfos
抛出：
WCMException

moveViewDataByClassInfos

public void moveViewDataByClassInfos(MetaViewData viewData,
                                     ClassInfos srcClassInfos,
                                     ClassInfo destClassInfo,
                                     User currUser)
                              throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类

指定者：
接口 IClassInfoViewMgr 中的 moveViewDataByClassInfos
抛出：
WCMException

moveViewDatasByClassInfos

public void moveViewDatasByClassInfos(MetaViewDatas viewDatas,
                                      MetaViewField viewField,
                                      ClassInfos srcClassInfos,
                                      ClassInfo destClassInfo,
                                      User currUser)
                               throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类

指定者：
接口 IClassInfoViewMgr 中的 moveViewDatasByClassInfos
抛出：
WCMException

moveViewDataByClassInfos

public void moveViewDataByClassInfos(MetaViewData viewData,
                                     MetaViewField viewField,
                                     ClassInfos srcClassInfos,
                                     ClassInfo destClassInfo,
                                     User currUser)
                              throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类

指定者：
接口 IClassInfoViewMgr 中的 moveViewDataByClassInfos
抛出：
WCMException

copyViewDatasByClassInfos

public void copyViewDatasByClassInfos(MetaViewDatas viewDatas,
                                      ClassInfos destClassInfos,
                                      User currUser)
                               throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos

指定者：
接口 IClassInfoViewMgr 中的 copyViewDatasByClassInfos
抛出：
WCMException

copyViewDatasByClassInfos

public void copyViewDatasByClassInfos(MetaViewDatas viewDatas,
                                      MetaViewField viewField,
                                      ClassInfos destClassInfos,
                                      User currUser)
                               throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos

指定者：
接口 IClassInfoViewMgr 中的 copyViewDatasByClassInfos
抛出：
WCMException

copyViewDataByClassInfos

public void copyViewDataByClassInfos(MetaViewData viewData,
                                     ClassInfos destClassInfos,
                                     User currUser)
                              throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos

指定者：
接口 IClassInfoViewMgr 中的 copyViewDataByClassInfos
抛出：
WCMException

copyViewDataByClassInfos

public void copyViewDataByClassInfos(MetaViewData viewData,
                                     MetaViewField viewField,
                                     ClassInfos destClassInfos,
                                     User currUser)
                              throws WCMException
从接口 IClassInfoViewMgr 复制的描述
将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos

指定者：
接口 IClassInfoViewMgr 中的 copyViewDataByClassInfos
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoViews

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 ClassInfoViews

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.metadata.center.ClassInfoViews

public class ClassInfoViews
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ClassInfoViews(User _currUser)
构造函数
ClassInfoViews(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ClassInfoViews | createNewInstance(User _currUser) 产生当前集合对象[ClassInfoViews]的实例
static ClassInfoViews | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ClassInfoViews | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ClassInfoViews]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoViews

public ClassInfoViews(User _currUser)
构造函数

另请参见：
ClassInfoViews( User _currUser, int _initCapacity, int _incCapacity );

ClassInfoViews

public ClassInfoViews(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ClassInfoViews findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ClassInfoViews）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ClassInfoViews openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[ClassInfoViews]

参数：
_filter - 指定的Filter
返回：
当前集合[ClassInfoViews]
抛出：
WCMException

createNewInstance

public static ClassInfoViews createNewInstance(User _currUser)
产生当前集合对象[ClassInfoViews]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentFieldsSynFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 DocumentFieldsSynFactory

java.lang.Object
    继承者  com.trs.components.metadata.center.DocumentFieldsSynFactory

public class DocumentFieldsSynFactory
extends java.lang.Object

构造方法摘要
DocumentFieldsSynFactory()
方法摘要
static java.util.List | getDocumentFieldSyn(java.lang.String sKey) 根据关键字获取IDocumentFieldsSyn对象
static void | registerDocumentFieldsSyn(java.lang.String sKey, java.lang.Class clazz) 注册和元数据关联处理的IDocumentFieldsSyn对象
static void | registerDocumentFieldsSyn(java.lang.String sKey, java.lang.String sClassName) 注册和元数据关联处理的IDocumentFieldsSyn对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentFieldsSynFactory

public DocumentFieldsSynFactory()
方法详细信息

registerDocumentFieldsSyn

public static void registerDocumentFieldsSyn(java.lang.String sKey,
                                             java.lang.String sClassName)
                                      throws WCMException
注册和元数据关联处理的IDocumentFieldsSyn对象

参数：
sKey -
sClassName -
抛出：
WCMException

registerDocumentFieldsSyn

public static void registerDocumentFieldsSyn(java.lang.String sKey,
                                             java.lang.Class clazz)
                                      throws WCMException
注册和元数据关联处理的IDocumentFieldsSyn对象

参数：
sKey -
clazz -
抛出：
WCMException

getDocumentFieldSyn

public static java.util.List getDocumentFieldSyn(java.lang.String sKey)
                                          throws WCMException
根据关键字获取IDocumentFieldsSyn对象

参数：
sKey -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentListenerForMetaViewData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 DocumentListenerForMetaViewData

java.lang.Object
    继承者  com.trs.components.metadata.center.DocumentListenerForMetaViewData
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class DocumentListenerForMetaViewData
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnAdd, IObjectLCListenerOnModify

构造方法摘要
DocumentListenerForMetaViewData()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentListenerForMetaViewData

public DocumentListenerForMetaViewData()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldValueCreatorConfigStartServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 FieldValueCreatorConfigStartServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.config.BaseConfigServer
            继承者  com.trs.components.metadata.center.FieldValueCreatorConfigStartServer
所有已实现的接口：
IServer
public class FieldValueCreatorConfigStartServer
extends BaseConfigServer

Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
FieldValueCreatorConfigStartServer()
方法摘要
从类 com.trs.infra.config.BaseConfigServer 继承的方法
getConfigPath, setConfigPath
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FieldValueCreatorConfigStartServer

public FieldValueCreatorConfigStartServer()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldValueCreatorFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 FieldValueCreatorFactory

java.lang.Object
    继承者  com.trs.components.metadata.center.FieldValueCreatorFactory

public class FieldValueCreatorFactory
extends java.lang.Object

构造方法摘要
FieldValueCreatorFactory()
方法摘要
static java.util.List | createValueCreator(java.lang.String _sTableName) 根据指定的对象的class产生将指定对象转换为XML的转换器
static void | registerValueCreator(IMetaDataFieldValueCreator convertor, java.lang.String _sRelateTableName)
static void | registerValueCreator(java.lang.String _sCreatorClassName, java.lang.String _sRelateTableName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FieldValueCreatorFactory

public FieldValueCreatorFactory()
方法详细信息

createValueCreator

public static java.util.List createValueCreator(java.lang.String _sTableName)
根据指定的对象的class产生将指定对象转换为XML的转换器

参数：
_objectClass -
返回：

registerValueCreator

public static void registerValueCreator(java.lang.String _sCreatorClassName,
                                        java.lang.String _sRelateTableName)
                                 throws java.lang.Exception
参数：
_sCreatorClassName -
_sRelateTableName -
抛出：
java.lang.Exception

registerValueCreator

public static void registerValueCreator(IMetaDataFieldValueCreator convertor,
                                        java.lang.String _sRelateTableName)
参数：
convertor -
_sTargetClassName -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IClassInfoViewMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
接口 IClassInfoViewMgr

所有已知实现类：
ClassInfoViewMgr
public interface IClassInfoViewMgr

方法摘要
void | copyViewDataByClassInfos(MetaViewData oViewData, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos
void | copyViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos
void | copyViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos
void | copyViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos
void | delete(User user, ClassInfo _oClassInfo) 删除_oClassInfo下的文档关联
void | delete(User _currUser, MetaViewData oMetaViewData) 删除ClassInfoView中满足MetaDataID的记录
void | moveViewDataByClassInfos(MetaViewData oViewData, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | moveViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | moveViewDatasByClassInfo(User user, ClassInfo _oSrcClassInfo, int _nDestClassInfoId) 将记录的分类法由_oSrcClassInfo转换为_nDestClassInfoId 如果_nDestClassInfoId为0，则只删除记录的_oSrcClassInfo
void | moveViewDatasByClassInfo(User user, ClassInfo _oSrcClassInfo, java.lang.String _destClassInfoId) 将记录的分类法由_oSrcClassInfo转换为_destClassInfoId 如果_destClassInfoId为null，则只删除记录的_oSrcClassInfo
void | moveViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | moveViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
ClassInfos | queryClassInfos(User _currUser, Documents oDocuments, WCMFilter _filter) 根据文档对象集合获取获取分类法信息集合
ClassInfos | queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
int | queryDocumentNum(User _currUser, ClassInfo _classInfo) 根据分类法对象返回相应的文档数目
int | queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)
Documents | queryDocuments(User _currUser, ClassInfos _oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
MetaViewDatas | queryViewDatas(User user, ClassInfo _oClassInfo, MetaView _oMetaView) 获取指定视图指定分类法下的数据集合
MetaViews | queryViews(User _currUser, ClassInfos _oClassInfo, WCMFilter _filter) 根据分类法ID序列返回视图对象集合
void | save(User _currUser, MetaViewData oMetaViewData) 保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录

方法详细信息

save

void save(User _currUser,
          MetaViewData oMetaViewData)
          throws WCMException
保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录

参数：
_currUser -
oMetaViewField -
抛出：
WCMException

delete

void delete(User _currUser,
            MetaViewData oMetaViewData)
            throws WCMException
删除ClassInfoView中满足MetaDataID的记录

参数：
_currUser -
oMetaViewData -
抛出：
WCMException

queryDocuments

Documents queryDocuments(User _currUser,
                         ClassInfos _oClassInfos,
                         WCMFilter _filter)
                         throws WCMException
根据分类法集合对象得到相应的文档集合对象

参数：
_currUser -
oClassInfos -
_filter -
返回：
抛出：
WCMException

queryDocuments

Documents queryDocuments(User _currUser,
                         ClassInfo _oClassInfo,
                         WCMFilter _filter)
                         throws WCMException
根据分类法对象得到相应的文档集合对象

参数：
_currUser -
oClassInfos -
_filter -
返回：
抛出：
WCMException

queryViews

MetaViews queryViews(User _currUser,
                     ClassInfos _oClassInfo,
                     WCMFilter _filter)
                     throws WCMException
根据分类法ID序列返回视图对象集合

参数：
_currUser -
_oClassInfo -
_filter -
_bContainChildClassInfo -
返回：
抛出：
WCMException

queryClassInfos

ClassInfos queryClassInfos(User _currUser,
                           Document oDocument,
                           WCMFilter _filter)
                           throws WCMException
根据文档对象获取获取分类法信息集合

参数：
_currUser -
oDocument -
_filter -
返回：
抛出：
WCMException

queryDocumentNum

int queryDocumentNum(User _currUser,
                     ClassInfo _classInfo)
                     throws WCMException
根据分类法对象返回相应的文档数目

参数：
_currUser -
oClassInfos -
_filter -
返回：
抛出：
WCMException

queryDocumentNum

int queryDocumentNum(User _currUser,
                     ClassInfo _classInfo,
                     WCMFilter _filter)
                     throws WCMException
抛出：
WCMException

delete

void delete(User user,
            ClassInfo _oClassInfo)
            throws WCMException
删除_oClassInfo下的文档关联

参数：
user -
_oClassInfo -
抛出：
WCMException

queryViewDatas

MetaViewDatas queryViewDatas(User user,
                             ClassInfo _oClassInfo,
                             MetaView _oMetaView)
                             throws WCMException
获取指定视图指定分类法下的数据集合

参数：
user -
_oClassInfo -
_oMetaView -
返回：
抛出：
WCMException

moveViewDatasByClassInfo

void moveViewDatasByClassInfo(User user,
                              ClassInfo _oSrcClassInfo,
                              java.lang.String _destClassInfoId)
                              throws WCMException
将记录的分类法由_oSrcClassInfo转换为_destClassInfoId 如果_destClassInfoId为null，则只删除记录的_oSrcClassInfo

参数：
user -
_srcClassInfoId -
_destClassInfoId -
抛出：
WCMException

moveViewDatasByClassInfo

void moveViewDatasByClassInfo(User user,
                              ClassInfo _oSrcClassInfo,
                              int _nDestClassInfoId)
                              throws WCMException
将记录的分类法由_oSrcClassInfo转换为_nDestClassInfoId 如果_nDestClassInfoId为0，则只删除记录的_oSrcClassInfo

参数：
user -
_srcClassInfoId -
_destClassInfoId -
抛出：
WCMException

moveViewDatasByClassInfo

void moveViewDatasByClassInfo(MetaViewData oViewData,
                              ClassInfo oSrcClassInfo,
                              ClassInfo oDestClassInfo,
                              User currUser)
                              throws WCMException
获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值

参数：
oViewData -
oSrcClassInfo -
oDestClassInfo -
currUser -
抛出：
WCMException

moveViewDatasByClassInfo

void moveViewDatasByClassInfo(MetaViewDatas oViewDatas,
                              ClassInfo oSrcClassInfo,
                              ClassInfo oDestClassInfo,
                              User currUser)
                              throws WCMException
获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值

参数：
oViewDatas -
oSrcClassInfo -
oDestClassInfo -
currUser -
抛出：
WCMException

moveViewDatasByClassInfo

void moveViewDatasByClassInfo(MetaViewData oViewData,
                              MetaViewField oViewField,
                              ClassInfo oSrcClassInfo,
                              ClassInfo oDestClassInfo,
                              User oCurrUser)
                              throws WCMException
将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类

参数：
oViewData -
oViewField -
oSrcClassInfo -
oDestClassInfo -
oCurrUser -
抛出：
WCMException

moveViewDataByClassInfos

void moveViewDataByClassInfos(MetaViewData oViewData,
                              ClassInfos oSrcClassInfos,
                              ClassInfo oDestClassInfo,
                              User oCurrUser)
                              throws WCMException
将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类

参数：
oViewData -
oSrcClassInfos -
oDestClassInfo -
oCurrUser -
抛出：
WCMException

moveViewDataByClassInfos

void moveViewDataByClassInfos(MetaViewData oViewData,
                              MetaViewField oViewField,
                              ClassInfos oSrcClassInfos,
                              ClassInfo oDestClassInfo,
                              User oCurrUser)
                              throws WCMException
将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类

参数：
oViewData -
oSrcClassInfos -
oDestClassInfo -
oCurrUser -
抛出：
WCMException

moveViewDatasByClassInfos

void moveViewDatasByClassInfos(MetaViewDatas oViewDatas,
                               ClassInfos oSrcClassInfos,
                               ClassInfo oDestClassInfo,
                               User oCurrUser)
                               throws WCMException
将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类

参数：
oViewData -
oSrcClassInfos -
oDestClassInfo -
oCurrUser -
抛出：
WCMException

moveViewDatasByClassInfos

void moveViewDatasByClassInfos(MetaViewDatas oViewDatas,
                               MetaViewField oViewField,
                               ClassInfos oSrcClassInfos,
                               ClassInfo oDestClassInfo,
                               User oCurrUser)
                               throws WCMException
将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类

参数：
oViewData -
oSrcClassInfos -
oDestClassInfo -
oCurrUser -
抛出：
WCMException

copyViewDataByClassInfos

void copyViewDataByClassInfos(MetaViewData oViewData,
                              ClassInfos oDestClassInfos,
                              User oCurrUser)
                              throws WCMException
将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos

参数：
oViewData -
oDestClassInfos -
oCurrUser -
抛出：
WCMException

copyViewDataByClassInfos

void copyViewDataByClassInfos(MetaViewData oViewData,
                              MetaViewField oViewField,
                              ClassInfos oDestClassInfos,
                              User oCurrUser)
                              throws WCMException
将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos

参数：
oViewData -
oViewField -
oDestClassInfos -
oCurrUser -
抛出：
WCMException

copyViewDatasByClassInfos

void copyViewDatasByClassInfos(MetaViewDatas oViewDatas,
                               ClassInfos oDestClassInfos,
                               User oCurrUser)
                               throws WCMException
将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos

参数：
oViewData -
oSrcClassInfos -
oDestClassInfo -
oCurrUser -
抛出：
WCMException

copyViewDatasByClassInfos

void copyViewDatasByClassInfos(MetaViewDatas oViewDatas,
                               MetaViewField oViewField,
                               ClassInfos oDestClassInfos,
                               User oCurrUser)
                               throws WCMException
将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos

参数：
oViewDatas -
oViewField -
oDestClassInfos -
oCurrUser -
抛出：
WCMException

queryClassInfos

ClassInfos queryClassInfos(User _currUser,
                           Documents oDocuments,
                           WCMFilter _filter)
                           throws WCMException
根据文档对象集合获取获取分类法信息集合

参数：
_currUser -
oDocument -
_filter -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDocumentFieldsSyn

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
接口 IDocumentFieldsSyn

public interface IDocumentFieldsSyn

方法摘要
java.lang.String[] | getRegisterTables() 返回需要注册的相关表
void | resetDocumentProperties(MetaView oMetaView) 给所有视图数据对象设置关联的document对象的值
void | setDocumentProperties(Document _document, MetaViewData _viewData) 根据视图数据对象设置关联的document对象的值

方法详细信息

getRegisterTables

java.lang.String[] getRegisterTables()
返回需要注册的相关表

返回：
表名数组

setDocumentProperties

void setDocumentProperties(Document _document,
                           MetaViewData _viewData)
                           throws WCMException
根据视图数据对象设置关联的document对象的值

参数：
_viewData - 当前元数据对象
抛出：
WCMException

resetDocumentProperties

void resetDocumentProperties(MetaView oMetaView)
                             throws WCMException
给所有视图数据对象设置关联的document对象的值

抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMetaDataFieldValueCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
接口 IMetaDataFieldValueCreator

所有已知实现类：
GovInfoIndexCreator
public interface IMetaDataFieldValueCreator

作者：
曹辉 元数据字段值产生器

方法摘要
java.lang.String | getCreatorName() 产生器的名称
java.lang.String[] | registerRelateTables() 注册值产生器相关的物理表列表
void | resetFieldValueOnMetaData() 给所有相关的元数据记录重新设置新的值
void | setFieldValueBeforeSaveMetaData(MetaViewData _viewData) 给当前元数据对象的相关属性设置上自动产生的值

方法详细信息

getCreatorName

java.lang.String getCreatorName()
产生器的名称

返回：

registerRelateTables

java.lang.String[] registerRelateTables()
注册值产生器相关的物理表列表

返回：
表名数组

setFieldValueBeforeSaveMetaData

void setFieldValueBeforeSaveMetaData(MetaViewData _viewData)
                                     throws WCMException
给当前元数据对象的相关属性设置上自动产生的值

参数：
_viewData - 当前元数据对象
抛出：
WCMException

resetFieldValueOnMetaData

void resetFieldValueOnMetaData()
                               throws WCMException
给所有相关的元数据记录重新设置新的值

抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMetaViewEmployerMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
接口 IMetaViewEmployerMgr

所有已知实现类：
MetaViewEmployerMgr
public interface IMetaViewEmployerMgr

方法摘要
void | clearEmployer(User _currUser, Channel _channel) 清除指定栏目所配置的视图关系
void | clearEmployer(User _currUser, MetaView _view) 清除指定视图所配置的使用关系
Channels | getEmployers(MetaView _view, WCMFilter _extraFilter) 获取使用了指定视图的所有栏目
MetaView | getViewOfEmployer(Channel _channel) 获取指定栏目配置的视图
void | setEmployer(User _currUser, Channel _channel, MetaView _view) 给指定的栏目配置指定的视图

方法详细信息

setEmployer

void setEmployer(User _currUser,
                 Channel _channel,
                 MetaView _view)
                 throws WCMException
给指定的栏目配置指定的视图

参数：
_channel - 指定的栏目
_view - 指定的视图
抛出：
WCMException

clearEmployer

void clearEmployer(User _currUser,
                   Channel _channel)
                   throws WCMException
清除指定栏目所配置的视图关系

参数：
_channel -
抛出：
WCMException

clearEmployer

void clearEmployer(User _currUser,
                   MetaView _view)
                   throws WCMException
清除指定视图所配置的使用关系

参数：
_view -
抛出：
WCMException

getEmployers

Channels getEmployers(MetaView _view,
                      WCMFilter _extraFilter)
                      throws WCMException
获取使用了指定视图的所有栏目

参数：
_view -
_extraFilter - TODO
返回：
抛出：
WCMException

getViewOfEmployer

MetaView getViewOfEmployer(Channel _channel)
                           throws WCMException
获取指定栏目配置的视图

参数：
_channel -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataCenterClassInfoHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 MetaDataCenterClassInfoHelper

java.lang.Object
    继承者  com.trs.components.metadata.center.MetaDataCenterClassInfoHelper

public class MetaDataCenterClassInfoHelper
extends java.lang.Object

构造方法摘要
MetaDataCenterClassInfoHelper()
方法摘要
static void | destory() 清除掉缓冲的资源
static void | init()
static MetaViewData | renderClassInfoFields(MetaViewData oViewData) 对元数据记录里面的分类法字段进行格式化处理，如：把分类法字段名称改成分类法id.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataCenterClassInfoHelper

public MetaDataCenterClassInfoHelper()
方法详细信息

init

public static void init()

renderClassInfoFields

public static MetaViewData renderClassInfoFields(MetaViewData oViewData)
                                          throws WCMException
对元数据记录里面的分类法字段进行格式化处理，如：把分类法字段名称改成分类法id.
修改规则：
如果是数字，说明是分类法的id，可以直接跳过 如果不是数字，则需要区分是否是全路径，如果是全路径，则通过全路径获取到分类的id 否则直接通过名称获取到分类的id，如果不符合上述条件，则清空当前的值

抛出：
WCMException

destory

public static void destory()
清除掉缓冲的资源

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataCenterHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 MetaDataCenterHelper

java.lang.Object
    继承者  com.trs.components.metadata.center.MetaDataCenterHelper

public class MetaDataCenterHelper
extends java.lang.Object

构造方法摘要
MetaDataCenterHelper()
方法摘要
static WCMFilter | makeFilterWithClassInfos(java.lang.String sClassInfoIds, boolean _bContainsChildren)
static void | rendHtmlFields(MetaViewData _oViewData)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataCenterHelper

public MetaDataCenterHelper()
方法详细信息

makeFilterWithClassInfos

public static WCMFilter makeFilterWithClassInfos(java.lang.String sClassInfoIds,
                                                 boolean _bContainsChildren)
                                          throws WCMException
参数：
_methodContext -
view -
filter -
抛出：
WCMException

rendHtmlFields

public static void rendHtmlFields(MetaViewData _oViewData)
                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 MetaViewData

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.metadata.center.MetaViewData
所有已实现的接口：
java.lang.Cloneable
public class MetaViewData
extends CMSObj

作者：
Administrator

字段摘要
static java.lang.Integer | KEY_CHANNEL_RIGHTVALUES
static java.lang.Integer | KEY_CURR_HOST
static int | OBJ_TYPE
构造方法摘要
MetaViewData()
MetaViewData(MetaView _view)
MetaViewData(MetaView _view, java.util.HashMap _hPublicCache)
MetaViewData(java.lang.String _sDbTableName)
MetaViewData(java.lang.String _sDbTableName, java.lang.String _sIdFieldName)
方法摘要
java.lang.String | abstractPicSrc(java.lang.String _htmlContent)
void | cloneDocumentProperties(MetaViewData _viewData)
BaseObj | cloneToNewObj() 由于视图字段的名称和元数据字段的名称可能不统一，在查看（findById)的时候，用 的是视图字段名称，而在保存（save）的时候用的是元数据字段名称，所以在此需要将视图字段的属性转化为元数据字段的属性
static MetaViewData | createNewInstance() 产生当前对象[MetaViewData]的实例
void | dealWithFieldsOfEnumValue() 处理新添加的枚举值
int | delete(User _currUser) 从数据中删除对象信息
int | deleteViewDataAndDoc(User _currUser)
static MetaViewData | findById(int _nMetaViewDataId)
static MetaViewData | findById(java.lang.String _sTableName, int _nId) 提取指定ID的对象
static MetaViewData | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAppendixProperty(java.lang.String _sPropertyName, int _nPathType)
Channel | getChannel() 获取文档当前所处的栏目
int | getChannelId()
ChnlDoc | getChnlDoc()
int | getChnlDocId()
java.util.Hashtable | getChnlDocProperties()
java.lang.String | getChnlDocProperty(java.lang.String _sFieldName)
int | getChnlDocProperty(java.lang.String _sFieldName, int _nDefault)
java.lang.String | getContent()
BaseChannel | getCurrChannelOrSite()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
Channel | getDocChannel()
int | getDocChannelId()
Document | getDocument()
int | getDocumentId()
Document | getDocumnent()
java.lang.String | getFinalPropertyAsString(java.lang.String _sName) 根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取
java.lang.String | getFinalPropertyAsString(java.lang.String _sName, java.lang.String _sDefaultValue) 根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取
java.lang.String | getIdFieldName() 获得Id字段名。
int | getMetaDataId()
MetaView | getMetaView()
int | getPropertyAsInt(java.lang.String _sName, int _nDefault) 取长整型属性值
java.util.HashMap | getPublicCache()
java.lang.String | getRealProperty(java.lang.String _sPropertyName)
RightValue | getRightValue(User _currUser) 获取当前ViewDocument的RightValue
java.lang.String | getSelectFields()
Status | getStatus()
int | getStatusId()
java.lang.String | getTitle()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | hasRight(User _loginUser, int _nRightIndex) 判断当前用户对于ViewDocument是否具有指定的权限
void | insert() 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isRightDefined() 判断当前文档是否自定义了权限
boolean | isTopped()
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
static void | main(java.lang.String[] args)
void | readChnlDocPropertyFromRs(java.sql.ResultSet _rsData, java.sql.ResultSetMetaData _rsmdData)
void | save() 对象保存自己
void | setChnlDocProperty(java.lang.String _sFieldName, java.lang.Object _value)
void | setDbTableName(java.lang.String dbTableName)
void | setId(int _nId) 设置对象ID
void | setIdFieldName(java.lang.String idFieldname)
void | setMetaDataId(int docId)
void | setMetaView(MetaView metaView)
boolean | setProperties(java.util.Map _properties)
void | setPublicCache(java.util.HashMap publicCache)
void | setSkipValid(boolean _bSkipValid) 是否跳过校验
void | setView(MetaView _view) 设置当前对象相关的视图
void | synDocumentFieldValueWithRule(Document _document) 按照栏目上设置的同步规则进行字段同步。
java.lang.String | toString()
void | translateFields() 由于视图字段的名称和元数据字段的名称可能不统一，在此方法中将视图字段的属性转化为元数据字段的属性, 在导入、复制视图数据的时候，可能需要用到这种功能
void | update() 更新修改。
void | update(User _user) 更新修改。
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, setCrUser, setCrUser, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsLong, getPropertyAsString, getPropertyAsString, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

KEY_CURR_HOST

public static final java.lang.Integer KEY_CURR_HOST

KEY_CHANNEL_RIGHTVALUES

public static final java.lang.Integer KEY_CHANNEL_RIGHTVALUES
构造方法详细信息

MetaViewData

public MetaViewData()

MetaViewData

public MetaViewData(MetaView _view)

MetaViewData

public MetaViewData(java.lang.String _sDbTableName)

MetaViewData

public MetaViewData(java.lang.String _sDbTableName,
                    java.lang.String _sIdFieldName)
参数：
_sDbTableName -
_sIdFieldName -

MetaViewData

public MetaViewData(MetaView _view,
                    java.util.HashMap _hPublicCache)
方法详细信息

setView

public void setView(MetaView _view)
设置当前对象相关的视图

参数：
_view -

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

setDbTableName

public void setDbTableName(java.lang.String dbTableName)
参数：
dbTableName -

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

setIdFieldName

public void setIdFieldName(java.lang.String idFieldname)
参数：
idFieldname -

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

setSkipValid

public void setSkipValid(boolean _bSkipValid)
是否跳过校验

参数：
_bSkipValid -

findById

public static final MetaViewData findById(java.lang.String _sTableName,
                                          int _nId)
                                   throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MetaViewData createNewInstance()
                                            throws WCMException
产生当前对象[MetaViewData]的实例

返回：
当前对象的实例[MetaViewData]
抛出：
WCMException

findByKey

public static final MetaViewData findByKey(java.lang.Object _oKey)
                                    throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getMetaView

public MetaView getMetaView()
返回：

setMetaView

public void setMetaView(MetaView metaView)
参数：
metaView -

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

synDocumentFieldValueWithRule

public void synDocumentFieldValueWithRule(Document _document)
                                   throws WCMException
按照栏目上设置的同步规则进行字段同步。

参数：
_document -
抛出：
WCMException

dealWithFieldsOfEnumValue

public void dealWithFieldsOfEnumValue()
                               throws WCMException
处理新添加的枚举值

抛出：
WCMException

getTitle

public java.lang.String getTitle()
                          throws WCMException
返回：
抛出：
WCMException

getContent

public java.lang.String getContent()
                            throws WCMException
返回：
抛出：
WCMException

update

public void update(User _user)
            throws WCMException
从类 CMSObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 CMSObj 中的 update
参数：
_user - 操作用户
抛出：
WCMException

insert

public void insert()
            throws WCMException
从类 BaseObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 BaseObj 中的 insert
抛出：
WCMException

update

public void update()
            throws WCMException
从类 BaseObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 BaseObj 中的 update
抛出：
WCMException

save

public void save()
          throws WCMException
从类 BaseObj 复制的描述
对象保存自己

覆盖：
类 CMSObj 中的 save
抛出：
WCMException

deleteViewDataAndDoc

public int deleteViewDataAndDoc(User _currUser)
                         throws WCMException
抛出：
WCMException

delete

public int delete(User _currUser)
           throws WCMException
从类 CMSObj 复制的描述
从数据中删除对象信息

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

getDocumnent

public Document getDocumnent()
                      throws WCMException
抛出：
WCMException

getDocumentId

public int getDocumentId()

getChnlDocId

public int getChnlDocId()

getChnlDoc

public ChnlDoc getChnlDoc()
                   throws WCMException
抛出：
WCMException

findById

public static MetaViewData findById(int _nMetaViewDataId)
                             throws WCMException
参数：
_nMetaViewId -
返回：
抛出：
WCMException

getDocument

public Document getDocument()

getSelectFields

public java.lang.String getSelectFields()
                                 throws WCMException
返回：
抛出：
WCMException

setProperties

public boolean setProperties(java.util.Map _properties)
参数：
_properties -
返回：

setId

public void setId(int _nId)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId

readChnlDocPropertyFromRs

public final void readChnlDocPropertyFromRs(java.sql.ResultSet _rsData,
                                            java.sql.ResultSetMetaData _rsmdData)
                                     throws WCMException
抛出：
WCMException

setChnlDocProperty

public void setChnlDocProperty(java.lang.String _sFieldName,
                               java.lang.Object _value)

getChnlDocProperty

public int getChnlDocProperty(java.lang.String _sFieldName,
                              int _nDefault)
参数：
_sFieldName -
_nDefault -
返回：

getChnlDocProperty

public java.lang.String getChnlDocProperty(java.lang.String _sFieldName)
参数：
_sFieldName -
返回：

cloneDocumentProperties

public void cloneDocumentProperties(MetaViewData _viewData)

getChnlDocProperties

public java.util.Hashtable getChnlDocProperties()
返回：

getMetaDataId

public int getMetaDataId()

setMetaDataId

public void setMetaDataId(int docId)
参数：
docId -

getChannelId

public int getChannelId()

getChannel

public Channel getChannel()
                   throws WCMException
获取文档当前所处的栏目

返回：
抛出：
WCMException

getDocChannelId

public int getDocChannelId()

getDocChannel

public Channel getDocChannel()
                      throws WCMException
抛出：
WCMException

getStatusId

public int getStatusId()

getStatus

public Status getStatus()
                 throws WCMException
抛出：
WCMException

isTopped

public boolean isTopped()

getPublicCache

public java.util.HashMap getPublicCache()
返回：

setPublicCache

public void setPublicCache(java.util.HashMap publicCache)
参数：
publicCache -

getCurrChannelOrSite

public BaseChannel getCurrChannelOrSite()
返回：

getRightValue

public RightValue getRightValue(User _currUser)
                         throws WCMException
获取当前ViewDocument的RightValue

返回：
抛出：
WCMException

isRightDefined

public boolean isRightDefined()
                       throws WCMException
判断当前文档是否自定义了权限

返回：
抛出：
WCMException

hasRight

public boolean hasRight(User _loginUser,
                        int _nRightIndex)
                 throws WCMException
判断当前用户对于ViewDocument是否具有指定的权限

参数：
_loginUser -
_nRightIndex -
返回：
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

getRealProperty

public java.lang.String getRealProperty(java.lang.String _sPropertyName)
                                 throws WCMException
抛出：
WCMException

getAppendixProperty

public java.lang.String getAppendixProperty(java.lang.String _sPropertyName,
                                            int _nPathType)
                                     throws WCMException
抛出：
WCMException

cloneToNewObj

public BaseObj cloneToNewObj()
                      throws WCMException
由于视图字段的名称和元数据字段的名称可能不统一，在查看（findById)的时候，用 的是视图字段名称，而在保存（save）的时候用的是元数据字段名称，所以在此需要将视图字段的属性转化为元数据字段的属性

覆盖：
类 BaseObj 中的 cloneToNewObj
返回：
返回Object对象
抛出：
WCMException

translateFields

public void translateFields()
                     throws WCMException
由于视图字段的名称和元数据字段的名称可能不统一，在此方法中将视图字段的属性转化为元数据字段的属性, 在导入、复制视图数据的时候，可能需要用到这种功能

抛出：
WCMException

getFinalPropertyAsString

public java.lang.String getFinalPropertyAsString(java.lang.String _sName)
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取

覆盖：
类 BaseObj 中的 getFinalPropertyAsString
参数：
_sName -
_sDefaultValue -
返回：

getFinalPropertyAsString

public java.lang.String getFinalPropertyAsString(java.lang.String _sName,
                                                 java.lang.String _sDefaultValue)
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取

覆盖：
类 BaseObj 中的 getFinalPropertyAsString
参数：
_sName -
_sDefaultValue -
返回：

abstractPicSrc

public java.lang.String abstractPicSrc(java.lang.String _htmlContent)
                                throws WCMException
抛出：
WCMException

getPropertyAsInt

public int getPropertyAsInt(java.lang.String _sName,
                            int _nDefault)
从类 BaseObj 复制的描述
取长整型属性值

覆盖：
类 BaseObj 中的 getPropertyAsInt
参数：
_sName - 属性字段名称
_nDefault - 默认值
返回：
int类型的属性值

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewDatas

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 MetaViewDatas

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.metadata.center.MetaViewDatas

public class MetaViewDatas
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_TABLE_NAME
static java.lang.String | ID_FIELD_NAME
static java.lang.Integer | ID_NOT_LOAD
static int | MAX_FETCH_SIZE
static int | MAX_ROW_NUM
static boolean | QUERY_ACCORD_DOCUMENT_RIGHT
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, IS_DEBUG
构造方法摘要
MetaViewDatas()
MetaViewDatas(MetaView _view)
MetaViewDatas(java.lang.String _sDbTableName)
MetaViewDatas(java.lang.String _sDbTableName, java.lang.String _sIdFieldName)
MetaViewDatas(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
boolean | canSort() 是否排序有效
static MetaViewDatas | createNewInstance(java.lang.String _sTableName) 产生当前集合对象[MetaViewDatas]的实例
static MetaViewDatas | findByIds(MetaView _view, java.lang.String _sIds)
static MetaViewDatas | findByIds(java.lang.String sIds) 返回一个MetaViewData的集合，注意sIds对应得视图必须相同
static MetaViewDatas | findByIds(java.lang.String _sTableName, java.lang.String _sIds) 提取指定ID序列的对象集合
BaseChannel | getCurrChannelOrSite()
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
MetaView | getMetaView()
int | getOpenMode()
int | getRecCount() 获取本次查询的记录个数
int | getRightIndex()
boolean | isFromRecycle()
void | loadViewDatas(WCMFilter _filter)
BaseObjs | newInstance() 生成新的集合对象实例
void | open(Channels _channels, WCMFilter _filter)
void | open(Channel _channel, WCMFilter _filter)
void | open(CMSBaseObjs _oSitesOrChannels, WCMFilter _extraFilter)
void | open(WCMFilter _filter) 打开集合
void | open(WCMFilter _filter, WCMFilter _countFilter)
void | open(WebSites _sites, WCMFilter _filter)
void | open(WebSite _site, WCMFilter _filter)
static MetaViewDatas | openWCMObjs(MetaView oMetaView, WCMFilter _filter)
static MetaViewDatas | openWCMObjs(java.lang.String _sTableName, WCMFilter _filter) 通过指定一个Filter获取当前集合[MetaViewDatas]
void | setDbTableName(java.lang.String dbTableName)
void | setFromRecycle(boolean fromRecycle)
void | setIdFieldName(java.lang.String idFieldname)
void | setLoadAllDatas(boolean bLoadAll) 是否一次载入所有数据，而不进行分页
void | setMetaView(MetaView oMetaView)
void | setNeedWithAuthFilter(User _loginUser, boolean _bNeedWithAuthFilter)
void | setOpenMode(int _sOpenMode)
void | setRecCount(int _nRecCount) 设置本次查询的记录个数
void | setRightIndex(int rightIndex)
void | setSelectFields(java.lang.String _sSelectFieldFromChnlDoc, java.lang.String _sSelectFieldsFromDocument)
void | setSelectFieldsFromChnlDoc(java.lang.String _sSelectFieldsFromChnlDoc)
void | setSelectFieldsOfMetaTable(java.lang.String selectFieldsFromDocument)
int | size() 获取集合的大小
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setSelect, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAX_ROW_NUM

public static int MAX_ROW_NUM

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

ID_FIELD_NAME

public static final java.lang.String ID_FIELD_NAME
另请参见：
常量字段值

ID_NOT_LOAD

public static final java.lang.Integer ID_NOT_LOAD

QUERY_ACCORD_DOCUMENT_RIGHT

public static boolean QUERY_ACCORD_DOCUMENT_RIGHT

MAX_FETCH_SIZE

public static int MAX_FETCH_SIZE
构造方法详细信息

MetaViewDatas

public MetaViewDatas(MetaView _view)

MetaViewDatas

public MetaViewDatas(java.lang.String _sDbTableName)

MetaViewDatas

public MetaViewDatas(java.lang.String _sDbTableName,
                     java.lang.String _sIdFieldName)
参数：
_sDbTableName -
_sIdFieldName -

MetaViewDatas

public MetaViewDatas(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
参数：
_initCapacity -
_incCapacity -

MetaViewDatas

public MetaViewDatas()
方法详细信息

setDbTableName

public void setDbTableName(java.lang.String dbTableName)
参数：
dbTableName -

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

setMetaView

public void setMetaView(MetaView oMetaView)

getMetaView

public MetaView getMetaView()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

setIdFieldName

public void setIdFieldName(java.lang.String idFieldname)
参数：
idFieldname -

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final MetaViewDatas findByIds(java.lang.String _sTableName,
                                            java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（MetaViewDatas）
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByIds

public static final MetaViewDatas findByIds(MetaView _view,
                                            java.lang.String _sIds)

openWCMObjs

public static final MetaViewDatas openWCMObjs(java.lang.String _sTableName,
                                              WCMFilter _filter)
                                       throws WCMException
通过指定一个Filter获取当前集合[MetaViewDatas]

参数：
_filter - 指定的Filter
返回：
当前集合[MetaViewDatas]
抛出：
WCMException

openWCMObjs

public static final MetaViewDatas openWCMObjs(MetaView oMetaView,
                                              WCMFilter _filter)
                                       throws WCMException
抛出：
WCMException

createNewInstance

public static MetaViewDatas createNewInstance(java.lang.String _sTableName)
产生当前集合对象[MetaViewDatas]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

getCurrChannelOrSite

public BaseChannel getCurrChannelOrSite()
返回：

canSort

public boolean canSort()
是否排序有效

返回：

open

public void open(Channels _channels,
                 WCMFilter _filter)
          throws WCMException
抛出：
WCMException

open

public void open(Channel _channel,
                 WCMFilter _filter)
          throws WCMException
抛出：
WCMException

open

public void open(WebSite _site,
                 WCMFilter _filter)
          throws WCMException
抛出：
WCMException

open

public void open(WebSites _sites,
                 WCMFilter _filter)
          throws WCMException
抛出：
WCMException

setLoadAllDatas

public void setLoadAllDatas(boolean bLoadAll)
是否一次载入所有数据，而不进行分页

loadViewDatas

public void loadViewDatas(WCMFilter _filter)
                   throws WCMException
参数：
_filter -
抛出：
WCMException

open

public void open(CMSBaseObjs _oSitesOrChannels,
                 WCMFilter _extraFilter)
          throws WCMException
抛出：
WCMException

isFromRecycle

public boolean isFromRecycle()
返回：

setFromRecycle

public void setFromRecycle(boolean fromRecycle)
参数：
fromRecycle -

setSelectFieldsFromChnlDoc

public void setSelectFieldsFromChnlDoc(java.lang.String _sSelectFieldsFromChnlDoc)
参数：
_sSelectFieldsFromChnlDoc -

setSelectFieldsOfMetaTable

public void setSelectFieldsOfMetaTable(java.lang.String selectFieldsFromDocument)
参数：
selectFieldsFromDocument -

setSelectFields

public void setSelectFields(java.lang.String _sSelectFieldFromChnlDoc,
                            java.lang.String _sSelectFieldsFromDocument)

getRightIndex

public int getRightIndex()
返回：

setRightIndex

public void setRightIndex(int rightIndex)
参数：
rightIndex -

findByIds

public static MetaViewDatas findByIds(java.lang.String sIds)
                               throws WCMException
返回一个MetaViewData的集合，注意sIds对应得视图必须相同

抛出：
WCMException

setNeedWithAuthFilter

public void setNeedWithAuthFilter(User _loginUser,
                                  boolean _bNeedWithAuthFilter)

getOpenMode

public int getOpenMode()

setOpenMode

public void setOpenMode(int _sOpenMode)

open

public void open(WCMFilter _filter)
          throws WCMException
从类 BaseObjs 复制的描述
打开集合

覆盖：
类 BaseObjs 中的 open
参数：
_filter - 筛选对象
抛出：
WCMException - 若集合打开失败，会抛出异常。

open

public void open(WCMFilter _filter,
                 WCMFilter _countFilter)
          throws WCMException
抛出：
WCMException

setRecCount

public void setRecCount(int _nRecCount)
设置本次查询的记录个数

覆盖：
类 BaseObjs 中的 setRecCount
参数：
_nRecCount - 记录个数

getRecCount

public int getRecCount()
获取本次查询的记录个数

覆盖：
类 BaseObjs 中的 getRecCount

size

public int size()
从类 BaseObjs 复制的描述
获取集合的大小

覆盖：
类 BaseObjs 中的 size
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewEmployer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 MetaViewEmployer

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.components.metadata.center.MetaViewEmployer
所有已实现的接口：
java.lang.Cloneable
public class MetaViewEmployer
extends BaseObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
MetaViewEmployer()
方法摘要
static MetaViewEmployer | findByChannelId(int _nChannelId)
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

MetaViewEmployer

public MetaViewEmployer()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

findByChannelId

public static MetaViewEmployer findByChannelId(int _nChannelId)
                                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewEmployerMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 MetaViewEmployerMgr

java.lang.Object
    继承者  com.trs.components.metadata.center.MetaViewEmployerMgr
所有已实现的接口：
IMetaViewEmployerMgr
public class MetaViewEmployerMgr
extends java.lang.Object
implements IMetaViewEmployerMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据视图使用关系维护对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaViewEmployerMgr()
方法摘要
void | clearEmployer(User _currUser, Channel _channel) 清除指定栏目所配置的视图关系
void | clearEmployer(User _currUser, MetaView _view) 清除指定视图所配置的使用关系
Channels | getEmployers(MetaView _view, WCMFilter _extraFilter) 获取使用了指定视图的所有栏目
MetaView | getViewOfEmployer(Channel _channel) 获取指定栏目配置的视图
void | setEmployer(User _currUser, Channel _channel, MetaView _view) 给指定的栏目配置指定的视图
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewEmployerMgr

public MetaViewEmployerMgr()
方法详细信息

clearEmployer

public void clearEmployer(User _currUser,
                          Channel _channel)
                   throws WCMException
从接口 IMetaViewEmployerMgr 复制的描述
清除指定栏目所配置的视图关系

指定者：
接口 IMetaViewEmployerMgr 中的 clearEmployer
抛出：
WCMException

clearEmployer

public void clearEmployer(User _currUser,
                          MetaView _view)
                   throws WCMException
从接口 IMetaViewEmployerMgr 复制的描述
清除指定视图所配置的使用关系

指定者：
接口 IMetaViewEmployerMgr 中的 clearEmployer
抛出：
WCMException

getEmployers

public Channels getEmployers(MetaView _view,
                             WCMFilter _extraFilter)
                      throws WCMException
从接口 IMetaViewEmployerMgr 复制的描述
获取使用了指定视图的所有栏目

指定者：
接口 IMetaViewEmployerMgr 中的 getEmployers
_extraFilter - TODO
返回：
抛出：
WCMException

getViewOfEmployer

public MetaView getViewOfEmployer(Channel _channel)
                           throws WCMException
从接口 IMetaViewEmployerMgr 复制的描述
获取指定栏目配置的视图

指定者：
接口 IMetaViewEmployerMgr 中的 getViewOfEmployer
返回：
抛出：
WCMException

setEmployer

public void setEmployer(User _currUser,
                        Channel _channel,
                        MetaView _view)
                 throws WCMException
从接口 IMetaViewEmployerMgr 复制的描述
给指定的栏目配置指定的视图

指定者：
接口 IMetaViewEmployerMgr 中的 setEmployer
_channel - 指定的栏目
_view - 指定的视图
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewEmployers

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 MetaViewEmployers

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.components.metadata.center.MetaViewEmployers

public class MetaViewEmployers
extends BaseObjs

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MetaViewEmployers()
方法摘要
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
int | getWCMType()
BaseObjs | newInstance() 生成新的集合对象实例
static MetaViewEmployers | openWCMObjs(WCMFilter _filter)
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

MetaViewEmployers

public MetaViewEmployers()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObjs 复制的描述
取对象数据存储的数据表名称

返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

openWCMObjs

public static final MetaViewEmployers openWCMObjs(WCMFilter _filter)
                                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center
类 MetaViewHelper

java.lang.Object
    继承者  com.trs.components.metadata.center.MetaViewHelper

public class MetaViewHelper
extends java.lang.Object

构造方法摘要
MetaViewHelper()
方法摘要
static MetaViews findViews(User _currUser)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewHelper

public MetaViewHelper()
方法详细信息

findViews

public static MetaViews findViews(User _currUser)
                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.center
接口
IClassInfoViewMgr
IDocumentFieldsSyn
IMetaDataFieldValueCreator
IMetaViewEmployerMgr
类
ChnlDocLCListenerForSynToMetaData
ClassDocumentsHelper
ClassDocumentsHelperTest
ClassInfoView
ClassInfoViewMgr
ClassInfoViews
DocumentFieldsSynFactory
DocumentListenerForMetaViewData
FieldValueCreatorConfigStartServer
FieldValueCreatorFactory
MetaDataCenterClassInfoHelper
MetaDataCenterHelper
MetaViewData
MetaViewDatas
MetaViewEmployer
MetaViewEmployerMgr
MetaViewEmployers
MetaViewHelper


com.trs.components.metadata.center

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.center

接口摘要
IClassInfoViewMgr
IDocumentFieldsSyn
IMetaDataFieldValueCreator
IMetaViewEmployerMgr

类摘要
ChnlDocLCListenerForSynToMetaData | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClassDocumentsHelper |
ClassDocumentsHelperTest |
ClassInfoView |
ClassInfoViewMgr | Title: TRS 内容协作平台（TRS WCM） Description: 管理视图数据和分类法的关联影射 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoViews |
DocumentFieldsSynFactory |
DocumentListenerForMetaViewData |
FieldValueCreatorConfigStartServer | Title: TRS 内容协作平台（TRS WCM） Description: 值产生器配置信息读取服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FieldValueCreatorFactory |
MetaDataCenterClassInfoHelper |
MetaDataCenterHelper |
MetaViewData |
MetaViewDatas | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewEmployer |
MetaViewEmployerMgr | Title: TRS 内容协作平台（TRS WCM） Description: 元数据视图使用关系维护对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewEmployers |
MetaViewHelper |


com.trs.components.metadata.center 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.center 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.trs.TRSWCMBaseTest
          • com.trs.components.metadata.center.ClassDocumentsHelperTest
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.metadata.center.ClassInfoView
        • com.trs.components.metadata.center.MetaViewData
      • com.trs.components.metadata.center.MetaViewEmployer
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.metadata.center.ClassInfoViews
        • com.trs.components.metadata.center.MetaViewDatas
      • com.trs.components.metadata.center.MetaViewEmployers
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.config.BaseConfigServer
        • com.trs.components.metadata.center.FieldValueCreatorConfigStartServer
    • com.trs.components.metadata.center.ChnlDocLCListenerForSynToMetaData (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.metadata.center.ClassDocumentsHelper
    • com.trs.components.metadata.center.ClassInfoViewMgr (implements com.trs.components.metadata.center.IClassInfoViewMgr)
    • com.trs.components.metadata.center.DocumentFieldsSynFactory
    • com.trs.components.metadata.center.DocumentListenerForMetaViewData (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.metadata.center.FieldValueCreatorFactory
    • com.trs.components.metadata.center.MetaDataCenterClassInfoHelper
    • com.trs.components.metadata.center.MetaDataCenterHelper
    • com.trs.components.metadata.center.MetaViewEmployerMgr (implements com.trs.components.metadata.center.IMetaViewEmployerMgr)
    • com.trs.components.metadata.center.MetaViewHelper

接口分层结构

  • com.trs.components.metadata.center.IClassInfoViewMgr
  • com.trs.components.metadata.center.IDocumentFieldsSyn
  • com.trs.components.metadata.center.IMetaDataFieldValueCreator
  • com.trs.components.metadata.center.IMetaViewEmployerMgr


软件包 com.trs.components.metadata.center 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.center
的使用

使用 com.trs.components.metadata.center 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition
com.trs.components.metadata.service

com.trs.components.metadata.center 使用的 com.trs.components.metadata.center 中的类
ClassInfoView
ClassInfoViews
IClassInfoViewMgr
IMetaDataFieldValueCreator
IMetaViewEmployerMgr
MetaViewData
MetaViewDatas
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewEmployer
MetaViewEmployers

com.trs.components.metadata.center.xml 使用的 com.trs.components.metadata.center 中的类
MetaViewDatas
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition 使用的 com.trs.components.metadata.center 中的类
IClassInfoViewMgr

com.trs.components.metadata.service 使用的 com.trs.components.metadata.center 中的类
IMetaDataFieldValueCreator
MetaViewData
MetaViewDatas
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.ChnlDocLCListenerForSynToMetaData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.ChnlDocLCListenerForSynToMetaData
的使用

没有 com.trs.components.metadata.center.ChnlDocLCListenerForSynToMetaData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.ClassDocumentsHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.ClassDocumentsHelper
的使用

没有 com.trs.components.metadata.center.ClassDocumentsHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.ClassDocumentsHelperTest 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.ClassDocumentsHelperTest
的使用

没有 com.trs.components.metadata.center.ClassDocumentsHelperTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.ClassInfoView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.ClassInfoView
的使用

使用 ClassInfoView 的软件包
com.trs.components.metadata.center

com.trs.components.metadata.center 中 ClassInfoView 的使用

返回 ClassInfoView 的 com.trs.components.metadata.center 中的方法
static ClassInfoView | ClassInfoView.createNewInstance() 产生当前对象[ClassInfoView]的实例
static ClassInfoView | ClassInfoView.findById(int _nId) 提取指定ID的对象
static ClassInfoView | ClassInfoView.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.ClassInfoViewMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.ClassInfoViewMgr
的使用

没有 com.trs.components.metadata.center.ClassInfoViewMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.ClassInfoViews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.ClassInfoViews
的使用

使用 ClassInfoViews 的软件包
com.trs.components.metadata.center

com.trs.components.metadata.center 中 ClassInfoViews 的使用

返回 ClassInfoViews 的 com.trs.components.metadata.center 中的方法
static ClassInfoViews | ClassInfoViews.createNewInstance(User _currUser) 产生当前集合对象[ClassInfoViews]的实例
static ClassInfoViews | ClassInfoViews.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ClassInfoViews | ClassInfoViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ClassInfoViews]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.DocumentFieldsSynFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.DocumentFieldsSynFactory
的使用

没有 com.trs.components.metadata.center.DocumentFieldsSynFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.DocumentListenerForMetaViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.DocumentListenerForMetaViewData
的使用

没有 com.trs.components.metadata.center.DocumentListenerForMetaViewData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.FieldValueCreatorConfigStartServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.FieldValueCreatorConfigStartServer
的使用

没有 com.trs.components.metadata.center.FieldValueCreatorConfigStartServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.FieldValueCreatorFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.FieldValueCreatorFactory
的使用

没有 com.trs.components.metadata.center.FieldValueCreatorFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.center.IClassInfoViewMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.center.IClassInfoViewMgr
的使用

使用 IClassInfoViewMgr 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.definition

com.trs.components.metadata.center 中 IClassInfoViewMgr 的使用

实现 IClassInfoViewMgr 的 com.trs.components.metadata.center 中的类
 class ClassInfoViewMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
管理视图数据和分类法的关联影射
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition 中 IClassInfoViewMgr 的使用

返回 IClassInfoViewMgr 的 com.trs.components.metadata.definition 中的方法
static IClassInfoViewMgr ClassInfoListenerForViewData.getClassInfoViewMgr()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.center.IDocumentFieldsSyn 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.center.IDocumentFieldsSyn
的使用

没有 com.trs.components.metadata.center.IDocumentFieldsSyn 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.center.IMetaDataFieldValueCreator 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.center.IMetaDataFieldValueCreator
的使用

使用 IMetaDataFieldValueCreator 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.service

com.trs.components.metadata.center 中 IMetaDataFieldValueCreator 的使用

参数类型为 IMetaDataFieldValueCreator 的 com.trs.components.metadata.center 中的方法
static void FieldValueCreatorFactory.registerValueCreator(IMetaDataFieldValueCreator convertor, java.lang.String _sRelateTableName)

com.trs.components.metadata.service 中 IMetaDataFieldValueCreator 的使用

实现 IMetaDataFieldValueCreator 的 com.trs.components.metadata.service 中的类
 class GovInfoIndexCreator

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.center.IMetaViewEmployerMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.center.IMetaViewEmployerMgr
的使用

使用 IMetaViewEmployerMgr 的软件包
com.trs.components.metadata.center

com.trs.components.metadata.center 中 IMetaViewEmployerMgr 的使用

实现 IMetaViewEmployerMgr 的 com.trs.components.metadata.center 中的类
 class MetaViewEmployerMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据视图使用关系维护对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.MetaDataCenterClassInfoHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.MetaDataCenterClassInfoHelper
的使用

没有 com.trs.components.metadata.center.MetaDataCenterClassInfoHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.MetaDataCenterHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.MetaDataCenterHelper
的使用

没有 com.trs.components.metadata.center.MetaDataCenterHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.MetaViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.MetaViewData
的使用

使用 MetaViewData 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.service

com.trs.components.metadata.center 中 MetaViewData 的使用

返回 MetaViewData 的 com.trs.components.metadata.center 中的方法
static MetaViewData | MetaViewData.createNewInstance() 产生当前对象[MetaViewData]的实例
static MetaViewData | MetaViewData.findById(int _nMetaViewDataId)
static MetaViewData | MetaViewData.findById(java.lang.String _sTableName, int _nId) 提取指定ID的对象
static MetaViewData | MetaViewData.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static MetaViewData | MetaDataCenterClassInfoHelper.renderClassInfoFields(MetaViewData oViewData) 对元数据记录里面的分类法字段进行格式化处理，如：把分类法字段名称改成分类法id.

参数类型为 MetaViewData 的 com.trs.components.metadata.center 中的方法
void | MetaViewData.cloneDocumentProperties(MetaViewData _viewData)
void | IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.delete(User _currUser, MetaViewData oMetaViewData) 删除ClassInfoView中满足MetaDataID的记录
void | ClassInfoViewMgr.delete(User _currUser, MetaViewData oMetaViewData) 删除ClassInfoView中满足MetaDataID的记录
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
static MetaViewData | MetaDataCenterClassInfoHelper.renderClassInfoFields(MetaViewData oViewData) 对元数据记录里面的分类法字段进行格式化处理，如：把分类法字段名称改成分类法id.
static void | MetaDataCenterHelper.rendHtmlFields(MetaViewData _oViewData)
void | IClassInfoViewMgr.save(User _currUser, MetaViewData oMetaViewData) 保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录
void | ClassInfoViewMgr.save(User _currUser, MetaViewData _oMetaViewData) 保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录
void | IDocumentFieldsSyn.setDocumentProperties(Document _document, MetaViewData _viewData) 根据视图数据对象设置关联的document对象的值
void | IMetaDataFieldValueCreator.setFieldValueBeforeSaveMetaData(MetaViewData _viewData) 给当前元数据对象的相关属性设置上自动产生的值

com.trs.components.metadata.service 中 MetaViewData 的使用

返回 MetaViewData 的 com.trs.components.metadata.service 中的方法
MetaViewData | MetaDataCenterServiceProvider.findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
MetaViewData | GovInfoServiceProvider.findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
MetaViewData | MetaDataCenterServiceProviderForGB.findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
MetaViewData | MetaDataCenterServiceProviderForAgri.findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
MetaViewData | MetaDataCenterServiceProvider.saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | GovInfoServiceProvider.saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | MetaDataCenterServiceProviderForGB.saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | MetaDataCenterServiceProviderForZJH.saveMetaViewData(MethodContext _methodContext) 保存来自政府的公开信息
MetaViewData | MetaDataCenterServiceProviderForAgri.saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | GovInfoServiceProvider.saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
MetaViewData | MetaDataCenterServiceProviderForGB.saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
MetaViewData | MetaDataCenterServiceProviderForZJH.saveMetaViewDataOfGov(MethodContext _methodContext)
MetaViewData | MetaDataCenterServiceProviderForAgri.saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
static MetaViewData | GovInfoServiceProvider.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForGB.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForZJH.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForAgri.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)

参数类型为 MetaViewData 的 com.trs.components.metadata.service 中的方法
void | GovInfoIndexCreator.setFieldValueBeforeSaveMetaData(MetaViewData _oMetaViewData)
static MetaViewData | GovInfoServiceProvider.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForGB.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForZJH.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForAgri.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.MetaViewDatas 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.MetaViewDatas
的使用

使用 MetaViewDatas 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.center.xml
com.trs.components.metadata.service

com.trs.components.metadata.center 中 MetaViewDatas 的使用

返回 MetaViewDatas 的 com.trs.components.metadata.center 中的方法
static MetaViewDatas | MetaViewDatas.createNewInstance(java.lang.String _sTableName) 产生当前集合对象[MetaViewDatas]的实例
static MetaViewDatas | MetaViewDatas.findByIds(MetaView _view, java.lang.String _sIds)
static MetaViewDatas | MetaViewDatas.findByIds(java.lang.String sIds) 返回一个MetaViewData的集合，注意sIds对应得视图必须相同
static MetaViewDatas | MetaViewDatas.findByIds(java.lang.String _sTableName, java.lang.String _sIds) 提取指定ID序列的对象集合
static MetaViewDatas | MetaViewDatas.openWCMObjs(MetaView oMetaView, WCMFilter _filter)
static MetaViewDatas | MetaViewDatas.openWCMObjs(java.lang.String _sTableName, WCMFilter _filter) 通过指定一个Filter获取当前集合[MetaViewDatas]
static MetaViewDatas | ClassDocumentsHelper.queryMetaViewDatas(MetaView _view, ClassInfos _classInfos, boolean _bOnlyLeaf, WCMFilter _extraFilter) 获取指定视图中同时属于指定的多个分类（含下面的子分类）的文档 子分类仅仅只叶子节点
MetaViewDatas | IClassInfoViewMgr.queryViewDatas(User user, ClassInfo _oClassInfo, MetaView _oMetaView) 获取指定视图指定分类法下的数据集合
MetaViewDatas | ClassInfoViewMgr.queryViewDatas(User user, ClassInfo classInfo, MetaView metaView)

参数类型为 MetaViewDatas 的 com.trs.components.metadata.center 中的方法
void | IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)

com.trs.components.metadata.center.xml 中 MetaViewDatas 的使用

参数类型为 MetaViewDatas 的 com.trs.components.metadata.center.xml 中的方法
java.lang.String | MetaViewDataExporter.exportToExcelZip(MetaViewDatas _viewDatas) 将指定视图下的数据连同附件导出成ZIP文件
java.lang.String | MetaViewDataExporter.exportToExcelZip(MetaViewDatas _viewDatas, java.lang.String _sSelectFields, boolean _bExportAppendix) 将指定视图下的数据连同附件导出成ZIP文件
java.lang.String | MetaViewDataExporter.exportToZip(MetaViewDatas _viewDatas) 将指定视图下的数据连同附件导出成ZIP文件
java.lang.String | MetaViewDataExporter.exportToZip(MetaViewDatas _viewDatas, java.lang.String _sSelectFields, boolean _bExportAppendix) 将指定视图下的数据连同附件导出成ZIP文件

com.trs.components.metadata.service 中 MetaViewDatas 的使用

返回 MetaViewDatas 的 com.trs.components.metadata.service 中的方法
MetaViewDatas | GovInfoServiceProvider.queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | MetaDataCenterServiceProviderForGB.queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | MetaDataCenterServiceProviderForAgri.queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | MetaDataCenterServiceProvider.queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | GovInfoServiceProvider.queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | MetaDataCenterServiceProviderForGB.queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | MetaDataCenterServiceProviderForAgri.queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | MetaDataCenterServiceProvider.queryViewDatasNoView(MethodContext _methodContext)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.MetaViewEmployer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.MetaViewEmployer
的使用

使用 MetaViewEmployer 的软件包
com.trs.components.metadata.center

com.trs.components.metadata.center 中 MetaViewEmployer 的使用

返回 MetaViewEmployer 的 com.trs.components.metadata.center 中的方法
static MetaViewEmployer MetaViewEmployer.findByChannelId(int _nChannelId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.MetaViewEmployerMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.MetaViewEmployerMgr
的使用

没有 com.trs.components.metadata.center.MetaViewEmployerMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.MetaViewEmployers 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.MetaViewEmployers
的使用

使用 MetaViewEmployers 的软件包
com.trs.components.metadata.center

com.trs.components.metadata.center 中 MetaViewEmployers 的使用

返回 MetaViewEmployers 的 com.trs.components.metadata.center 中的方法
static MetaViewEmployers MetaViewEmployers.openWCMObjs(WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.MetaViewHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.MetaViewHelper
的使用

没有 com.trs.components.metadata.center.MetaViewHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


MetaViewDataExporter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center.xml
类 MetaViewDataExporter

java.lang.Object
    继承者  com.trs.components.metadata.center.xml.MetaViewDataExporter

public class MetaViewDataExporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaViewDataExporter(MetaView _view)
方法摘要
java.lang.String | exportToExcelZip(MetaViewDatas _viewDatas) 将指定视图下的数据连同附件导出成ZIP文件
java.lang.String | exportToExcelZip(MetaViewDatas _viewDatas, java.lang.String _sSelectFields, boolean _bExportAppendix) 将指定视图下的数据连同附件导出成ZIP文件
java.lang.String | exportToZip(MetaViewDatas _viewDatas) 将指定视图下的数据连同附件导出成ZIP文件
java.lang.String | exportToZip(MetaViewDatas _viewDatas, java.lang.String _sSelectFields, boolean _bExportAppendix) 将指定视图下的数据连同附件导出成ZIP文件
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewDataExporter

public MetaViewDataExporter(MetaView _view)
方法详细信息

exportToZip

public java.lang.String exportToZip(MetaViewDatas _viewDatas,
                                    java.lang.String _sSelectFields,
                                    boolean _bExportAppendix)
                             throws WCMException
将指定视图下的数据连同附件导出成ZIP文件

参数：
_viewDatas -
返回：
抛出：
WCMException

exportToZip

public java.lang.String exportToZip(MetaViewDatas _viewDatas)
                             throws WCMException
将指定视图下的数据连同附件导出成ZIP文件

参数：
_viewDatas -
返回：
抛出：
WCMException

exportToExcelZip

public java.lang.String exportToExcelZip(MetaViewDatas _viewDatas,
                                         java.lang.String _sSelectFields,
                                         boolean _bExportAppendix)
                                  throws WCMException
将指定视图下的数据连同附件导出成ZIP文件

参数：
_viewDatas -
返回：
抛出：
WCMException

exportToExcelZip

public java.lang.String exportToExcelZip(MetaViewDatas _viewDatas)
                                  throws WCMException
将指定视图下的数据连同附件导出成ZIP文件

参数：
_viewDatas -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MetaViewDataImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center.xml
类 MetaViewDataImporter

java.lang.Object
    继承者  com.trs.components.metadata.center.xml.MetaViewDataImporter

public class MetaViewDataImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaViewDataImporter(User _currUser, MetaView _dstView, Channel _dstChannel)
方法摘要
static java.lang.String | converToAbsoluteFileName(java.lang.String _sFileName)
Reports | importFromFile(int _nImportType, java.lang.String _sImportFile, java.lang.String _sXslFile)
boolean | isImportToCurrChannel()
void | setImportToCurrChannel(boolean bImportToCurrChannel) 设置是否导入到当前栏目
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewDataImporter

public MetaViewDataImporter(User _currUser,
                            MetaView _dstView,
                            Channel _dstChannel)
方法详细信息

importFromFile

public Reports importFromFile(int _nImportType,
                              java.lang.String _sImportFile,
                              java.lang.String _sXslFile)
                       throws WCMException
抛出：
WCMException

setImportToCurrChannel

public void setImportToCurrChannel(boolean bImportToCurrChannel)
设置是否导入到当前栏目

isImportToCurrChannel

public boolean isImportToCurrChannel()

converToAbsoluteFileName

public static java.lang.String converToAbsoluteFileName(java.lang.String _sFileName)
                                                 throws WCMException
参数：
_sFileName -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewDataToExcel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center.xml
类 MetaViewDataToExcel

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
            继承者  com.trs.components.metadata.center.xml.MetaViewDataToExcel

public class MetaViewDataToExcel
extends BaseObjToXmlConverterForSpecialProperty

构造方法摘要
MetaViewDataToExcel(MetaView _view)
方法摘要
java.util.ArrayList | getAppFiles()
java.lang.String | getElementTag(BaseObj _baseObj)
java.lang.String | getElementTag(BaseObjs _baseObjs)
boolean | isAddVersion()
org.dom4j.Element | toXmlElement(BaseObjs _baseObjs, java.lang.String _sFieldsList) 为什么要重载这个方法？
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getXmlEncoding, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewDataToExcel

public MetaViewDataToExcel(MetaView _view)
方法详细信息

getAppFiles

public java.util.ArrayList getAppFiles()
返回：

toXmlElement

public org.dom4j.Element toXmlElement(BaseObjs _baseObjs,
                                      java.lang.String _sFieldsList)
                               throws WCMException
为什么要重载这个方法？ 因为Excel在识别xml文件的时候,xml文件至少要有两行记录, 所以在这个地方，将添加2条空记录

覆盖：
类 BaseObjToXmlConverter 中的 toXmlElement
抛出：
WCMException

getElementTag

public java.lang.String getElementTag(BaseObj _baseObj)
覆盖：
类 BaseObjToXmlConverter 中的 getElementTag

getElementTag

public java.lang.String getElementTag(BaseObjs _baseObjs)
覆盖：
类 BaseObjToXmlConverter 中的 getElementTag

isAddVersion

public boolean isAddVersion()
覆盖：
类 BaseObjToXmlConverter 中的 isAddVersion
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewDataToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center.xml
类 MetaViewDataToXML

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
            继承者  com.trs.components.metadata.center.xml.MetaViewDataToXML

public class MetaViewDataToXML
extends BaseObjToXmlConverterForSpecialProperty

Title: TRS 内容协作平台（TRS WCM）
Description:
将元数据转换成XML
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaViewDataToXML(MetaView _view)
方法摘要
java.util.ArrayList | getAppFiles()
java.lang.String | getElementTag(BaseObj _baseObj)
java.lang.String | getElementTag(BaseObjs _baseObjs)
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewDataToXML

public MetaViewDataToXML(MetaView _view)
方法详细信息

getAppFiles

public java.util.ArrayList getAppFiles()
返回：

getElementTag

public java.lang.String getElementTag(BaseObj _baseObj)
覆盖：
类 BaseObjToXmlConverter 中的 getElementTag

getElementTag

public java.lang.String getElementTag(BaseObjs _baseObjs)
覆盖：
类 BaseObjToXmlConverter 中的 getElementTag
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.center.xml
类
MetaViewDataExporter
MetaViewDataImporter
MetaViewDataToExcel
MetaViewDataToXML
XMLToMetaViewData
XMLToMetaViewDataTest


com.trs.components.metadata.center.xml

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.center.xml

类摘要
MetaViewDataExporter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewDataImporter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewDataToExcel |
MetaViewDataToXML | Title: TRS 内容协作平台（TRS WCM） Description: 将元数据转换成XML Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XMLToMetaViewData | Title: TRS 内容协作平台（TRS WCM） Description: XML to MetaViewData转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XMLToMetaViewDataTest |


com.trs.components.metadata.center.xml 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.center.xml 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.AbstractXmlToObjConverter
      • com.trs.components.metadata.center.xml.XMLToMetaViewData
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.trs.components.metadata.center.xml.XMLToMetaViewDataTest
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
        • com.trs.components.metadata.center.xml.MetaViewDataToExcel
        • com.trs.components.metadata.center.xml.MetaViewDataToXML
    • com.trs.components.metadata.center.xml.MetaViewDataExporter
    • com.trs.components.metadata.center.xml.MetaViewDataImporter


软件包 com.trs.components.metadata.center.xml 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.center.xml
的使用

没有 com.trs.components.metadata.center.xml 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


XMLToMetaViewData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center.xml
类 XMLToMetaViewData

java.lang.Object
    继承者  com.trs.infra.persistent.AbstractXmlToObjConverter
        继承者  com.trs.components.metadata.center.xml.XMLToMetaViewData

public class XMLToMetaViewData
extends AbstractXmlToObjConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
XML to MetaViewData转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
XMLToMetaViewData(int _nImportType)
方法摘要
从类 com.trs.infra.persistent.AbstractXmlToObjConverter 继承的方法
convertXml, getXmlEncoding, registPersistentObj, setXmlEncoding
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLToMetaViewData

public XMLToMetaViewData(int _nImportType)
参数：
_nImportType -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLToMetaViewDataTest

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.center.xml
类 XMLToMetaViewDataTest

java.lang.Object
    继承者  junit.framework.Assert
        继承者  junit.framework.TestCase
            继承者  com.trs.components.metadata.center.xml.XMLToMetaViewDataTest
所有已实现的接口：
junit.framework.Test
public class XMLToMetaViewDataTest
extends junit.framework.TestCase

构造方法摘要
XMLToMetaViewDataTest()
方法摘要
 void testBuildXML()
从类 junit.framework.TestCase 继承的方法
countTestCases, getName, run, run, runBare, setName, toString
从类 junit.framework.Assert 继承的方法
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XMLToMetaViewDataTest

public XMLToMetaViewDataTest()
方法详细信息

testBuildXML

public void testBuildXML()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.metadata.center.xml.MetaViewDataExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.xml.MetaViewDataExporter
的使用

没有 com.trs.components.metadata.center.xml.MetaViewDataExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.xml.MetaViewDataImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.xml.MetaViewDataImporter
的使用

没有 com.trs.components.metadata.center.xml.MetaViewDataImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.xml.MetaViewDataToExcel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.xml.MetaViewDataToExcel
的使用

没有 com.trs.components.metadata.center.xml.MetaViewDataToExcel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.xml.MetaViewDataToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.xml.MetaViewDataToXML
的使用

没有 com.trs.components.metadata.center.xml.MetaViewDataToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.xml.XMLToMetaViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.xml.XMLToMetaViewData
的使用

没有 com.trs.components.metadata.center.xml.XMLToMetaViewData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.center.xml.XMLToMetaViewDataTest 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.center.xml.XMLToMetaViewDataTest
的使用

没有 com.trs.components.metadata.center.xml.XMLToMetaViewDataTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.MetaDataConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.MetaDataConstants
的使用

没有 com.trs.components.metadata.MetaDataConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ClassInfo

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 ClassInfo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.metadata.definition.ClassInfo
所有已实现的接口：
java.lang.Cloneable
public class ClassInfo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ClassInfo()
构造函数：保留默认接口
方法摘要
static ClassInfo | createNewInstance() 产生当前对象[ClassInfo]的实例
static ClassInfo | findById(int _nId) 提取指定ID的对象
static ClassInfo | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static ClassInfo | findByName(java.lang.String _sClassInfoName) 根据名称获取分类
static ClassInfos | findRootClassInfos() 获取所有根节点
static ClassInfos | findRootClassInfos(boolean _bNotMakeNewObjs)
ClassInfos | getChildren() 获取当前对象的一级子分类
ClassInfos | getChildren(boolean _bNotMakeNewObjs)
java.lang.String | getCode() 提取属性：CODE
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 提取属性：Desc
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
static int | getMaxOrder(int _nParentId)
java.lang.String | getName() 提取属性：Name
int | getOrder() 分类顺序
ClassInfo | getParent()
int | getParentId() 提取属性：ParentId
int | getRootId() 提取属性：RootId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isLeaf() 是否是叶子节点
boolean | isRoot()
boolean | isValid() 检验对象数据有效性
boolean | setCode(java.lang.String _sCode) 设置属性：Code
boolean | setDesc(java.lang.String _sDesc) 设置属性：Desc
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setOrder(int _nOrder) 设置分类顺序
boolean | setParentId(int _nParentId) 设置属性：ParentId
boolean | setRootId(int _nRootId) 设置属性：RootId
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ClassInfo

public ClassInfo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
提取属性：Desc

返回：
Desc

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置属性：Desc

参数：
_sDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getParentId

public int getParentId()
提取属性：ParentId

返回：
ParentId

getParent

public ClassInfo getParent()
                    throws WCMException
抛出：
WCMException

setParentId

public boolean setParentId(int _nParentId)
                    throws WCMException
设置属性：ParentId

参数：
_nParentId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRootId

public int getRootId()
提取属性：RootId

返回：
RootId

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置分类顺序

参数：
_nOrder -
返回：
抛出：
WCMException

getOrder

public int getOrder()
分类顺序

返回：

setRootId

public boolean setRootId(int _nRootId)
                  throws WCMException
设置属性：RootId

参数：
_nRootId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCode

public java.lang.String getCode()
提取属性：CODE

返回：
CODE

setCode

public boolean setCode(java.lang.String _sCode)
                throws WCMException
设置属性：Code

参数：
_sCode - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

isRoot

public boolean isRoot()

isLeaf

public boolean isLeaf()
               throws WCMException
是否是叶子节点

返回：
抛出：
WCMException

getMaxOrder

public static int getMaxOrder(int _nParentId)
                       throws WCMException
抛出：
WCMException

findById

public static final ClassInfo findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ClassInfo createNewInstance()
                                         throws WCMException
产生当前对象[ClassInfo]的实例

返回：
当前对象的实例[ClassInfo]
抛出：
WCMException

findByKey

public static final ClassInfo findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

getChildren

public ClassInfos getChildren()
                       throws WCMException
获取当前对象的一级子分类

返回：
抛出：
WCMException

getChildren

public ClassInfos getChildren(boolean _bNotMakeNewObjs)
                       throws WCMException
抛出：
WCMException

findRootClassInfos

public static ClassInfos findRootClassInfos()
                                     throws WCMException
获取所有根节点

返回：
抛出：
WCMException

findRootClassInfos

public static ClassInfos findRootClassInfos(boolean _bNotMakeNewObjs)
                                     throws WCMException
抛出：
WCMException

findByName

public static ClassInfo findByName(java.lang.String _sClassInfoName)
                            throws WCMException
根据名称获取分类

参数：
_sClassInfoName -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ClassInfoCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 ClassInfoCacheMgr

java.lang.Object
    继承者  com.trs.components.metadata.definition.ClassInfoCacheMgr
所有已实现的接口：
IClassInfoCacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class ClassInfoCacheMgr
extends java.lang.Object
implements IClassInfoCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
子栏目管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ClassInfoCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
ClassInfo | findClassInfoByName(java.lang.String _sClassInfoName) 根据分类法名称获取分类法
ClassInfos | getChildren(int _nParentId) 获取指定分类的所有一级子分类
ClassInfos | getChildren(int _nParentId, boolean _bNotMakeNewObjs)
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoCacheMgr

public ClassInfoCacheMgr()
方法详细信息

getChildren

public ClassInfos getChildren(int _nParentId)
                       throws WCMException
获取指定分类的所有一级子分类

指定者：
接口 IClassInfoCacheMgr 中的 getChildren
参数：
_nParentId -
返回：
抛出：
WCMException

findClassInfoByName

public ClassInfo findClassInfoByName(java.lang.String _sClassInfoName)
                              throws WCMException
根据分类法名称获取分类法

指定者：
接口 IClassInfoCacheMgr 中的 findClassInfoByName
参数：
_sClassInfoName -
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

getChildren

public ClassInfos getChildren(int _nParentId,
                              boolean _bNotMakeNewObjs)
                       throws WCMException
指定者：
接口 IClassInfoCacheMgr 中的 getChildren
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoListenerForViewData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 ClassInfoListenerForViewData

java.lang.Object
    继承者  com.trs.components.metadata.definition.ClassInfoListenerForViewData
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class ClassInfoListenerForViewData
extends java.lang.Object
implements IObjectLCListenerOnDel

构造方法摘要
ClassInfoListenerForViewData()
方法摘要
static IClassInfoViewMgr | getClassInfoViewMgr()
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoListenerForViewData

public ClassInfoListenerForViewData()
方法详细信息

getClassInfoViewMgr

public static IClassInfoViewMgr getClassInfoViewMgr()

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 ClassInfoMgr

java.lang.Object
    继承者  com.trs.components.metadata.definition.ClassInfoMgr
所有已实现的接口：
IClassInfoMgr
public class ClassInfoMgr
extends java.lang.Object
implements IClassInfoMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ClassInfoMgr()
方法摘要
void | deleteClassInfo(User _currUser, ClassInfo _classInfo) 删除指定的分类
ClassInfo | getClassInfo(java.lang.String path) 根据分类法路径查找到指定的分类法
ClassInfo | getClassInfo(java.lang.String path, java.lang.String delim) 根据分类法路径查找到指定的分类法
ClassInfos | getClassInfosByName(int nClassInfoRootId, java.lang.String sClassInfoName) 通过名称获取分类法对象集合
ClassInfos | getClassInfosByName(java.lang.String sClassInfoName) 通过名称获取分类法对象集合
java.lang.String | getNamePath(ClassInfo _classInfo) 由指定的分类法得到从根节点到这个分类法节点的id序列
java.lang.String | getNamePath(ClassInfos _classInfos) 由指定的分类法得到从根节点到这个分类法节点的id序列
java.lang.String | getPath(ClassInfo _classInfo) 由指定的分类法得到从根节点到这个分类法节点的id序列
java.lang.String | getPath(ClassInfos _classInfos) 由指定的分类法得到从根节点到这个分类法节点的id序列
boolean | isAncestor(int _nAncestorId, int _nDescendantId) 判断nAncestorId是否为nDescendantId的祖先id
static void | main(java.lang.String[] args)
ClassInfos | queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
java.lang.String | queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列,以逗号分隔
java.lang.String | queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim) 得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列
java.lang.String | queryChildrenWithAllLevel(User _currUser, int _nClassInfoId, WCMFilter _extraFilter)
java.lang.String | queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的一级子分类的Ids
java.lang.String | queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoMgr

public ClassInfoMgr()
方法详细信息

deleteClassInfo

public void deleteClassInfo(User _currUser,
                            ClassInfo _classInfo)
                     throws WCMException
从接口 IClassInfoMgr 复制的描述
删除指定的分类

指定者：
接口 IClassInfoMgr 中的 deleteClassInfo
抛出：
WCMException

queryChildren

public ClassInfos queryChildren(User _currUser,
                                ClassInfo _classInfo,
                                WCMFilter _extraFilter)
                         throws WCMException
指定者：
接口 IClassInfoMgr 中的 queryChildren
返回：
抛出：
WCMException

queryChildrenWithFirstLevel

public java.lang.String queryChildrenWithFirstLevel(User _currUser,
                                                    ClassInfo _classInfo,
                                                    WCMFilter _extraFilter)
                                             throws WCMException
得到满足条件的当前分类的一级子分类的Ids

指定者：
接口 IClassInfoMgr 中的 queryChildrenWithFirstLevel
参数：
_currUser -
_classInfo -
_extraFilter -
返回：
抛出：
WCMException

queryChildrenWithFirstLevel

public java.lang.String queryChildrenWithFirstLevel(User _currUser,
                                                    ClassInfo _classInfo,
                                                    WCMFilter _extraFilter,
                                                    char _cDelim)
                                             throws WCMException
指定者：
接口 IClassInfoMgr 中的 queryChildrenWithFirstLevel
抛出：
WCMException

queryChildrenWithAllLevel

public java.lang.String queryChildrenWithAllLevel(User _currUser,
                                                  ClassInfo _classInfo,
                                                  WCMFilter _extraFilter)
                                           throws WCMException
得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列,以逗号分隔

指定者：
接口 IClassInfoMgr 中的 queryChildrenWithAllLevel
参数：
_currUser -
_classInfo -
_extraFilter -
返回：
抛出：
WCMException

queryChildrenWithAllLevel

public java.lang.String queryChildrenWithAllLevel(User _currUser,
                                                  ClassInfo _classInfo,
                                                  WCMFilter _extraFilter,
                                                  char _cDelim)
                                           throws WCMException
得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列

指定者：
接口 IClassInfoMgr 中的 queryChildrenWithAllLevel
参数：
_currUser -
_classInfo -
_extraFilter -
_sDelim - Ids序列分隔符
返回：
抛出：
WCMException

queryChildrenWithAllLevel

public java.lang.String queryChildrenWithAllLevel(User _currUser,
                                                  int _nClassInfoId,
                                                  WCMFilter _extraFilter)
                                           throws WCMException
指定者：
接口 IClassInfoMgr 中的 queryChildrenWithAllLevel
抛出：
WCMException

getPath

public java.lang.String getPath(ClassInfos _classInfos)
                         throws WCMException
由指定的分类法得到从根节点到这个分类法节点的id序列

指定者：
接口 IClassInfoMgr 中的 getPath
抛出：
WCMException

getPath

public java.lang.String getPath(ClassInfo _classInfo)
                         throws WCMException
由指定的分类法得到从根节点到这个分类法节点的id序列

指定者：
接口 IClassInfoMgr 中的 getPath
抛出：
WCMException

getClassInfo

public ClassInfo getClassInfo(java.lang.String path)
                       throws WCMException
从接口 IClassInfoMgr 复制的描述
根据分类法路径查找到指定的分类法

指定者：
接口 IClassInfoMgr 中的 getClassInfo
返回：
抛出：
WCMException

getClassInfo

public ClassInfo getClassInfo(java.lang.String path,
                              java.lang.String delim)
                       throws WCMException
从接口 IClassInfoMgr 复制的描述
根据分类法路径查找到指定的分类法

指定者：
接口 IClassInfoMgr 中的 getClassInfo
返回：
抛出：
WCMException

main

public static void main(java.lang.String[] args)
                 throws WCMException
抛出：
WCMException

getNamePath

public java.lang.String getNamePath(ClassInfos _classInfos)
                             throws WCMException
由指定的分类法得到从根节点到这个分类法节点的id序列

指定者：
接口 IClassInfoMgr 中的 getNamePath
抛出：
WCMException

getNamePath

public java.lang.String getNamePath(ClassInfo _classInfo)
                             throws WCMException
由指定的分类法得到从根节点到这个分类法节点的id序列

指定者：
接口 IClassInfoMgr 中的 getNamePath
抛出：
WCMException

getClassInfosByName

public ClassInfos getClassInfosByName(java.lang.String sClassInfoName)
                               throws WCMException
通过名称获取分类法对象集合

指定者：
接口 IClassInfoMgr 中的 getClassInfosByName
参数：
sClassInfoName -
返回：
抛出：
WCMException

getClassInfosByName

public ClassInfos getClassInfosByName(int nClassInfoRootId,
                                      java.lang.String sClassInfoName)
                               throws WCMException
通过名称获取分类法对象集合

指定者：
接口 IClassInfoMgr 中的 getClassInfosByName
参数：
nClassInfoRootId -
sClassInfoName -
返回：
抛出：
WCMException

isAncestor

public boolean isAncestor(int _nAncestorId,
                          int _nDescendantId)
                   throws WCMException
从接口 IClassInfoMgr 复制的描述
判断nAncestorId是否为nDescendantId的祖先id

指定者：
接口 IClassInfoMgr 中的 isAncestor
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 ClassInfos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.metadata.definition.ClassInfos

public class ClassInfos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ClassInfos(User _currUser)
构造函数
ClassInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ClassInfos | createNewInstance(User _currUser) 产生当前集合对象[ClassInfos]的实例
static ClassInfos | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ClassInfos | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ClassInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfos

public ClassInfos(User _currUser)
构造函数

另请参见：
ClassInfos( User _currUser, int _initCapacity, int _incCapacity );

ClassInfos

public ClassInfos(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ClassInfos findByIds(User _currUser,
                                         java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ClassInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ClassInfos openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[ClassInfos]

参数：
_filter - 指定的Filter
返回：
当前集合[ClassInfos]
抛出：
WCMException

createNewInstance

public static ClassInfos createNewInstance(User _currUser)
产生当前集合对象[ClassInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 ClassInfoUtil

java.lang.Object
    继承者  com.trs.components.metadata.definition.ClassInfoUtil

public class ClassInfoUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
分类法定义工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ClassInfoUtil()
方法摘要
boolean | importClassInfos(java.lang.String _sRootName, java.lang.String _sFileName, boolean bContainCode, int _nImportType)
boolean | importFormFileByCode(java.lang.String _sRootName, java.lang.String _sFileName, int _nImportType) 从文件中导入分类法，依靠分类法代码表示层次关系
boolean | importFormFileByName(java.lang.String _sRootName, java.lang.String _sFileName, int _nImportType)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoUtil

public ClassInfoUtil()
方法详细信息

importClassInfos

public boolean importClassInfos(java.lang.String _sRootName,
                                java.lang.String _sFileName,
                                boolean bContainCode,
                                int _nImportType)
                         throws java.lang.Exception
抛出：
java.lang.Exception

importFormFileByCode

public boolean importFormFileByCode(java.lang.String _sRootName,
                                    java.lang.String _sFileName,
                                    int _nImportType)
                             throws java.lang.Exception
从文件中导入分类法，依靠分类法代码表示层次关系

参数：
_sRootName -
_sFileName -
bJumpRepeat -
抛出：
java.lang.Exception

importFormFileByName

public boolean importFormFileByName(java.lang.String _sRootName,
                                    java.lang.String _sFileName,
                                    int _nImportType)
                             throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IClassInfoCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
接口 IClassInfoCacheMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
ClassInfoCacheMgr
public interface IClassInfoCacheMgr
extends ICacheMgr

方法摘要
ClassInfo | findClassInfoByName(java.lang.String _sClassInfoName)
ClassInfos | getChildren(int _nParentId)
ClassInfos | getChildren(int _nParentId, boolean _bNotMakeNewObjs)
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

getChildren

ClassInfos getChildren(int _nParentId,
                       boolean _bNotMakeNewObjs)
                       throws WCMException
参数：
_nParentId -
_bNotMakeNewObjs -
返回：
抛出：
WCMException

getChildren

ClassInfos getChildren(int _nParentId)
                       throws WCMException
参数：
_nParentId -
返回：
抛出：
WCMException

findClassInfoByName

ClassInfo findClassInfoByName(java.lang.String _sClassInfoName)
                              throws WCMException
参数：
_sClassInfoName -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IClassInfoMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
接口 IClassInfoMgr

所有已知实现类：
ClassInfoMgr
public interface IClassInfoMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
分类业务定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | deleteClassInfo(User _currUser, ClassInfo _classInfo) 删除指定的分类
ClassInfo | getClassInfo(java.lang.String _sPath) 根据分类法路径查找到指定的分类法
ClassInfo | getClassInfo(java.lang.String _sPath, java.lang.String _sDelim) 根据分类法路径查找到指定的分类法
ClassInfos | getClassInfosByName(int nClassInfoRootId, java.lang.String sClassInfoName) 通过名称获取分类法对象集合
ClassInfos | getClassInfosByName(java.lang.String sClassInfoName) 通过名称获取分类法对象集合
java.lang.String | getNamePath(ClassInfo _classInfo)
java.lang.String | getNamePath(ClassInfos _classInfos)
java.lang.String | getPath(ClassInfo _classInfo)
java.lang.String | getPath(ClassInfos _classInfos)
boolean | isAncestor(int nAncestorId, int nDescendantId) 判断nAncestorId是否为nDescendantId的祖先id
ClassInfos | queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
java.lang.String | queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的所有子分类，包括子孙分类Ids
java.lang.String | queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
java.lang.String | queryChildrenWithAllLevel(User _currUser, int _nClassInfoId, WCMFilter _extraFilter)
java.lang.String | queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的一级子分类的Ids
java.lang.String | queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)

方法详细信息

deleteClassInfo

void deleteClassInfo(User _currUser,
                     ClassInfo _classInfo)
                     throws WCMException
删除指定的分类

参数：
_currUser -
_classInfo -
抛出：
WCMException

queryChildren

ClassInfos queryChildren(User _currUser,
                         ClassInfo _classInfo,
                         WCMFilter _extraFilter)
                         throws WCMException
参数：
_currUser -
_nParentId -
_extraFilter -
返回：
抛出：
WCMException

queryChildrenWithFirstLevel

java.lang.String queryChildrenWithFirstLevel(User _currUser,
                                             ClassInfo _classInfo,
                                             WCMFilter _extraFilter)
                                             throws WCMException
得到满足条件的当前分类的一级子分类的Ids

参数：
_currUser -
_classInfo -
_extraFilter -
返回：
抛出：
WCMException

queryChildrenWithFirstLevel

java.lang.String queryChildrenWithFirstLevel(User _currUser,
                                             ClassInfo _classInfo,
                                             WCMFilter _extraFilter,
                                             char _cDelim)
                                             throws WCMException
抛出：
WCMException

queryChildrenWithAllLevel

java.lang.String queryChildrenWithAllLevel(User _currUser,
                                           ClassInfo _classInfo,
                                           WCMFilter _extraFilter)
                                           throws WCMException
得到满足条件的当前分类的所有子分类，包括子孙分类Ids

参数：
_currUser -
_classInfo -
_extraFilter -
返回：
抛出：
WCMException

queryChildrenWithAllLevel

java.lang.String queryChildrenWithAllLevel(User _currUser,
                                           int _nClassInfoId,
                                           WCMFilter _extraFilter)
                                           throws WCMException
抛出：
WCMException

queryChildrenWithAllLevel

java.lang.String queryChildrenWithAllLevel(User _currUser,
                                           ClassInfo _classInfo,
                                           WCMFilter _extraFilter,
                                           char _cDelim)
                                           throws WCMException
抛出：
WCMException

getNamePath

java.lang.String getNamePath(ClassInfos _classInfos)
                             throws WCMException
抛出：
WCMException

getNamePath

java.lang.String getNamePath(ClassInfo _classInfo)
                             throws WCMException
抛出：
WCMException

getPath

java.lang.String getPath(ClassInfos _classInfos)
                         throws WCMException
抛出：
WCMException

getPath

java.lang.String getPath(ClassInfo _classInfo)
                         throws WCMException
抛出：
WCMException

getClassInfo

ClassInfo getClassInfo(java.lang.String _sPath,
                       java.lang.String _sDelim)
                       throws WCMException
根据分类法路径查找到指定的分类法

参数：
_sPath -
_sDelim -
返回：
抛出：
WCMException

getClassInfo

ClassInfo getClassInfo(java.lang.String _sPath)
                       throws WCMException
根据分类法路径查找到指定的分类法

参数：
_sPath -
返回：
抛出：
WCMException

getClassInfosByName

ClassInfos getClassInfosByName(java.lang.String sClassInfoName)
                               throws WCMException
通过名称获取分类法对象集合

参数：
sClassInfoName -
返回：
抛出：
WCMException

getClassInfosByName

ClassInfos getClassInfosByName(int nClassInfoRootId,
                               java.lang.String sClassInfoName)
                               throws WCMException
通过名称获取分类法对象集合

参数：
nClassInfoRootId -
sClassInfoName -
返回：
抛出：
WCMException

isAncestor

boolean isAncestor(int nAncestorId,
                   int nDescendantId)
                   throws WCMException
判断nAncestorId是否为nDescendantId的祖先id

参数：
nAncestorId -
nDescendantId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMetaDataDefCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
接口 IMetaDataDefCacheMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
MetaDataDefCacheMgr
public interface IMetaDataDefCacheMgr
extends ICacheMgr

作者：
曹辉

方法摘要
MetaViewField | getMetaViewField(int _nViewId, java.lang.String _sViewFieldName)
java.util.HashMap | getMetaViewFields(int _nViewId) 获得指定视图下的所有视图字段
java.util.Map | getMetaViewFields(int _nViewId, int _nFieldType) 获取指定视图下，指定类型的视图字段
java.util.List | getSortedMetaViewFields(int _nViewId)
boolean | isEditorField(int _nViewId, java.lang.String _sViewFieldName) 判断是否为编辑器字段
boolean | isEditorField(MetaViewField oViewField) 判断是否为编辑器字段
boolean | isFieldWithType(int _nViewId, java.lang.String _sViewFieldName, int _nViewFieldType) 判断当前字段类型是否符合指定的类型
boolean | isTitleFieldName(int _nViewId, java.lang.String _sViewFieldName)
void | reloadViewCache(int _nViewId)
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

reloadViewCache

void reloadViewCache(int _nViewId)
                     throws WCMException
参数：
_nViewId -
抛出：
WCMException

isTitleFieldName

boolean isTitleFieldName(int _nViewId,
                         java.lang.String _sViewFieldName)
                         throws WCMException
参数：
_nViewId -
_sViewFieldName -
返回：
抛出：
WCMException

isFieldWithType

boolean isFieldWithType(int _nViewId,
                        java.lang.String _sViewFieldName,
                        int _nViewFieldType)
                        throws WCMException
判断当前字段类型是否符合指定的类型

参数：
_nViewId -
_sViewFieldName -
_nViewFieldType -
返回：
抛出：
WCMException

isEditorField

boolean isEditorField(MetaViewField oViewField)
                      throws WCMException
判断是否为编辑器字段

参数：
oViewField -
返回：
抛出：
WCMException

isEditorField

boolean isEditorField(int _nViewId,
                      java.lang.String _sViewFieldName)
                      throws WCMException
判断是否为编辑器字段

参数：
_nViewId -
_sViewFieldName -
返回：
抛出：
WCMException

getMetaViewField

MetaViewField getMetaViewField(int _nViewId,
                               java.lang.String _sViewFieldName)
                               throws WCMException
参数：
_nViewId -
_sViewFieldName -
返回：
抛出：
WCMException

getMetaViewFields

java.util.HashMap getMetaViewFields(int _nViewId)
                                    throws WCMException
获得指定视图下的所有视图字段

参数：
_nViewId -
返回：
抛出：
WCMException

getMetaViewFields

java.util.Map getMetaViewFields(int _nViewId,
                                int _nFieldType)
                                throws WCMException
获取指定视图下，指定类型的视图字段

参数：
_nViewId -
_nFieldType -
返回：
抛出：
WCMException

getSortedMetaViewFields

java.util.List getSortedMetaViewFields(int _nViewId)
                                       throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMetaDataDefMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
接口 IMetaDataDefMgr

所有已知实现类：
MetaDataDefMgr
public interface IMetaDataDefMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | appendDefaultFields(User _curruser, MetaDBTable _oTable) 给自定的表追加默认的字段
java.lang.String | createDDLSQL(MetaDBTable _oTableInfo) 产生指定表的定义SQL
java.lang.String | createDDLSQL(MetaView _oViewInfo) 产生指定视图的定义SQL
boolean | createViewApplication(MetaView _oView, java.lang.String _sTemplatePath, java.lang.String _sApplicationPath) 视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8
java.lang.String | createViewRelations(User _currUser, MetaView _oView) 视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
java.lang.String | createViewRelations(User _currUser, MetaView _oView, boolean generateApplication) 视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
void | delete(User _currUser, MetaDBField _oDBFieldInfo) 删除指定字段
void | delete(User _currUser, MetaDBTable _oTableInfo) 删除指定表
void | delete(User _currUser, MetaView _oViewInfo) 删除指定表
void | delete(User _currUser, MetaViewField _oViewField) 删除指定视图字段
ClassInfos | getClassInfosUsingMetaView(User _currUser, MetaView oMetaView) 查询视图oMetaView使用了的所有分类法集合
MetaDBFields | getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter) 获取指定表的指定字段列表
MetaViewField | getMetaViewField(MetaView _oView, int _iDbFieldId)
MetaViews | getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo) 查询使用了分类法oClassInfo的所有视图集合
MetaViewFields | getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViews | getViewsContainsTable(MetaDBTable _oTable) 获取使用指定表作为附表的视图
MetaViews | getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo) 获取使用了物理字段_oDBFieldInfo的所有视图
MetaViews | getViewsUsingTable(MetaDBTable _oTable) 获取正在使用指定表的视图
void | recreateAll(User _currUser, MetaDBTables _oMetaDBTables) 重新产生所有的表结构和相关视图的应用
MetaDBTable | save(User _currUser, MetaDBTable _oTableInfo) 新增或者修改系统表
MetaDBField | save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo) 在指定表上，新增或者修改指定字段信息
MetaView | save(User _currUser, MetaView _oViewInfo) 新增或修改视图信息
MetaViewField | save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo) 在指定视图上，新增或者修改指定字段信息
void | setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields) 设置

方法详细信息

getDFieldInfos

MetaDBFields getDFieldInfos(User _currUser,
                            MetaDBTable _oDBTableInfo,
                            WCMFilter _extraFilter)
                            throws WCMException
获取指定表的指定字段列表

参数：
_currUser -
_extraFilter -
返回：
抛出：
WCMException

getViewFields

MetaViewFields getViewFields(User _currUser,
                             MetaView _oView,
                             WCMFilter _extraFilter)
                             throws WCMException
参数：
_currUser -
_oView -
_extraFilter -
返回：
抛出：
WCMException

save

MetaDBTable save(User _currUser,
                 MetaDBTable _oTableInfo)
                 throws WCMException
新增或者修改系统表

参数：
_currUser -
_oTableInfo -
返回：
抛出：
WCMException

save

MetaDBField save(User _currUser,
                 MetaDBTable _oOwnerTable,
                 MetaDBField _oDBFieldInfo)
                 throws WCMException
在指定表上，新增或者修改指定字段信息

参数：
_currUser -
_oOwnerTable -
_oDBFieldInfo -
返回：
抛出：
WCMException

save

MetaView save(User _currUser,
              MetaView _oViewInfo)
              throws WCMException
新增或修改视图信息

参数：
_currUser -
_oViewInfo -
返回：
抛出：
WCMException

save

MetaViewField save(User _currUser,
                   MetaView _oOwnerView,
                   MetaViewField _oViewFieldInfo)
                   throws WCMException
在指定视图上，新增或者修改指定字段信息

参数：
_currUser -
_oOwnerView -
_oViewFieldInfo -
返回：
抛出：
WCMException

setViewFields

void setViewFields(User _currUser,
                   MetaView _oOwnerView,
                   MetaDBFields _dbFields)
                   throws WCMException
设置

参数：
_currUser -
_oOwnerView -
_dbFields -
抛出：
WCMException

delete

void delete(User _currUser,
            MetaDBField _oDBFieldInfo)
            throws WCMException
删除指定字段

参数：
_oDBFieldInfo -
抛出：
WCMException

delete

void delete(User _currUser,
            MetaDBTable _oTableInfo)
            throws WCMException
删除指定表

参数：
_oDBFieldInfo -
抛出：
WCMException

delete

void delete(User _currUser,
            MetaViewField _oViewField)
            throws WCMException
删除指定视图字段

参数：
_oViewField -
抛出：
WCMException

delete

void delete(User _currUser,
            MetaView _oViewInfo)
            throws WCMException
删除指定表

参数：
_oDBFieldInfo -
抛出：
WCMException

createDDLSQL

java.lang.String createDDLSQL(MetaDBTable _oTableInfo)
                              throws WCMException
产生指定表的定义SQL

参数：
_oTableInfo -
抛出：
WCMException

createDDLSQL

java.lang.String createDDLSQL(MetaView _oViewInfo)
                              throws WCMException
产生指定视图的定义SQL

参数：
_oViewInfo -
抛出：
WCMException

createViewRelations

java.lang.String createViewRelations(User _currUser,
                                     MetaView _oView)
                                     throws WCMException
视图定义完成，产生视图相关的信息（DB视图、相关的JSP）

参数：
_currUser - TODO
_oView -
返回：
抛出：
WCMException

createViewRelations

java.lang.String createViewRelations(User _currUser,
                                     MetaView _oView,
                                     boolean generateApplication)
                                     throws WCMException
视图定义完成，产生视图相关的信息（DB视图、相关的JSP）

参数：
_currUser - TODO
_oView -
generateApplication - 是否生成应用
返回：
抛出：
WCMException

createViewApplication

boolean createViewApplication(MetaView _oView,
                              java.lang.String _sTemplatePath,
                              java.lang.String _sApplicationPath)
                              throws WCMException
视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8

参数：
_oView -
_sTemplatePath -
_sApplicationPath -
返回：
抛出：
WCMException

appendDefaultFields

void appendDefaultFields(User _curruser,
                         MetaDBTable _oTable)
                         throws WCMException
给自定的表追加默认的字段

参数：
_curruser -
_oTable -
抛出：
WCMException

getViewsUsingTable

MetaViews getViewsUsingTable(MetaDBTable _oTable)
                             throws WCMException
获取正在使用指定表的视图

参数：
_oTable -
抛出：
WCMException

getViewsContainsTable

MetaViews getViewsContainsTable(MetaDBTable _oTable)
                                throws WCMException
获取使用指定表作为附表的视图

参数：
_oTable -
抛出：
WCMException

getMetaViewField

MetaViewField getMetaViewField(MetaView _oView,
                               int _iDbFieldId)
                               throws WCMException
抛出：
WCMException

getViewsUsingField

MetaViews getViewsUsingField(User _currUser,
                             MetaDBField _oDBFieldInfo)
                             throws WCMException
获取使用了物理字段_oDBFieldInfo的所有视图

参数：
_oDBFieldInfo -
返回：
抛出：
WCMException

recreateAll

void recreateAll(User _currUser,
                 MetaDBTables _oMetaDBTables)
                 throws WCMException
重新产生所有的表结构和相关视图的应用

参数：
_currUser -
_oMetaDBTables -
抛出：
WCMException

getClassInfosUsingMetaView

ClassInfos getClassInfosUsingMetaView(User _currUser,
                                      MetaView oMetaView)
                                      throws WCMException
查询视图oMetaView使用了的所有分类法集合

参数：
oMetaView -
返回：
抛出：
WCMException

getMetaViewsUsingClassInfo

MetaViews getMetaViewsUsingClassInfo(User _currUser,
                                     ClassInfo oClassInfo)
                                     throws WCMException
查询使用了分类法oClassInfo的所有视图集合

参数：
oClassInfo -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataDefCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDataDefCacheMgr

java.lang.Object
    继承者  com.trs.components.metadata.definition.MetaDataDefCacheMgr
所有已实现的接口：
IMetaDataDefCacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class MetaDataDefCacheMgr
extends java.lang.Object
implements IMetaDataDefCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataDefCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
MetaViewField | getMetaViewField(int _nViewId, java.lang.String _sViewFieldName)
java.util.HashMap | getMetaViewFields(int _nViewId) 获得指定视图下的所有视图字段
java.util.Map | getMetaViewFields(int viewId, int fieldType) 获取指定视图下，指定类型的视图字段
java.util.List | getSortedMetaViewFields(int _nViewId)
boolean | init() 初始化当前的Cache
boolean | isEditorField(int _nViewId, java.lang.String _sViewFieldName) 判断是否为编辑器字段
boolean | isEditorField(MetaViewField _oViewField) 判断是否为编辑器字段
boolean | isFieldWithType(int _nViewId, java.lang.String _sViewFieldName, int _nViewFieldType) 判断当前字段类型是否符合指定的类型
boolean | isTitleFieldName(int _nViewId, java.lang.String _sViewFieldName)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
void | reloadViewCache(int _nViewId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataDefCacheMgr

public MetaDataDefCacheMgr()
方法详细信息

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

getMetaViewField

public MetaViewField getMetaViewField(int _nViewId,
                                      java.lang.String _sViewFieldName)
                               throws WCMException
指定者：
接口 IMetaDataDefCacheMgr 中的 getMetaViewField
返回：
抛出：
WCMException

getMetaViewFields

public java.util.HashMap getMetaViewFields(int _nViewId)
                                    throws WCMException
从接口 IMetaDataDefCacheMgr 复制的描述
获得指定视图下的所有视图字段

指定者：
接口 IMetaDataDefCacheMgr 中的 getMetaViewFields
返回：
抛出：
WCMException

getMetaViewFields

public java.util.Map getMetaViewFields(int viewId,
                                       int fieldType)
                                throws WCMException
从接口 IMetaDataDefCacheMgr 复制的描述
获取指定视图下，指定类型的视图字段

指定者：
接口 IMetaDataDefCacheMgr 中的 getMetaViewFields
返回：
抛出：
WCMException

getSortedMetaViewFields

public java.util.List getSortedMetaViewFields(int _nViewId)
                                       throws WCMException
指定者：
接口 IMetaDataDefCacheMgr 中的 getSortedMetaViewFields
抛出：
WCMException

isTitleFieldName

public boolean isTitleFieldName(int _nViewId,
                                java.lang.String _sViewFieldName)
                         throws WCMException
指定者：
接口 IMetaDataDefCacheMgr 中的 isTitleFieldName
返回：
抛出：
WCMException

isFieldWithType

public boolean isFieldWithType(int _nViewId,
                               java.lang.String _sViewFieldName,
                               int _nViewFieldType)
                        throws WCMException
从接口 IMetaDataDefCacheMgr 复制的描述
判断当前字段类型是否符合指定的类型

指定者：
接口 IMetaDataDefCacheMgr 中的 isFieldWithType
返回：
抛出：
WCMException

isEditorField

public boolean isEditorField(MetaViewField _oViewField)
                      throws WCMException
从接口 IMetaDataDefCacheMgr 复制的描述
判断是否为编辑器字段

指定者：
接口 IMetaDataDefCacheMgr 中的 isEditorField
返回：
抛出：
WCMException

isEditorField

public boolean isEditorField(int _nViewId,
                             java.lang.String _sViewFieldName)
                      throws WCMException
从接口 IMetaDataDefCacheMgr 复制的描述
判断是否为编辑器字段

指定者：
接口 IMetaDataDefCacheMgr 中的 isEditorField
返回：
抛出：
WCMException

reloadViewCache

public void reloadViewCache(int _nViewId)
                     throws WCMException
指定者：
接口 IMetaDataDefCacheMgr 中的 reloadViewCache
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataDefHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDataDefHelper

java.lang.Object
    继承者  com.trs.components.metadata.definition.MetaDataDefHelper

public class MetaDataDefHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataDefHelper()
方法摘要
static java.lang.String | getViewApplicationPath(int _nViewId)
static java.lang.String | getViewApplicationRootPath()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataDefHelper

public MetaDataDefHelper()
方法详细信息

getViewApplicationPath

public static java.lang.String getViewApplicationPath(int _nViewId)
                                               throws WCMException
参数：
_nViewId -
返回：
抛出：
WCMException

getViewApplicationRootPath

public static java.lang.String getViewApplicationRootPath()
                                                   throws WCMException
参数：
_nViewId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataDefMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDataDefMgr

java.lang.Object
    继承者  com.trs.components.metadata.definition.MetaDataDefMgr
所有已实现的接口：
IMetaDataDefMgr
public class MetaDataDefMgr
extends java.lang.Object
implements IMetaDataDefMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataDefMgr()
方法摘要
void | appendDefaultFields(User _currUser, MetaDBTable _oTable) 给自定的表追加默认的字段
void | clearTitleField(MetaView oView) 清除视图oView下的标题字段,即原来是标题字段的，将不再作为标题字段
java.lang.String | createDDLSQL(MetaDBTable _oTableInfo) 产生指定表的定义SQL
java.lang.String | createDDLSQL(MetaView _oViewInfo) 产生指定视图的定义SQL
boolean | createViewApplication(MetaView _oView, java.lang.String _sTemplatePath, java.lang.String _sApplicationPath) 视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8
java.lang.String | createViewRelations(User _currUser, MetaView _oView) 视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
java.lang.String | createViewRelations(User _currUser, MetaView _oView, boolean generateApplication) 视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
void | delete(User _currUser, MetaDBField _oDBFieldInfo) 删除指定字段
void | delete(User _currUser, MetaDBTable _oTableInfo) 删除元数据的操作步骤如下： 删除元数据物理字段； 删除元数据对应物理表里的数据； 删除元数据物理表； 删除元数据； 删除所有以此元数据作为主表的视图； 获取所有以此元数据作为附表的视图； 删除附表视图和此元数据的关系； 删除附表视图中此元数据的字段； 如果此视图由多表变成单表，则删除此物理视图，并修改视图的viewName 重新生成视图；
void | delete(User _currUser, MetaView _oView) 删除指定表
void | delete(User _currUser, MetaViewField _oViewField) 删除指定视图字段
ClassInfos | getClassInfosUsingMetaView(User _currUser, MetaView oMetaView) 查询视图oMetaView使用了的所有分类法集合
MetaDBFields | getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter) 获取指定表的指定字段列表
MetaViewField | getMetaViewField(MetaView _oView, int _nDbFieldId)
MetaViews | getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo) 查询使用了分类法oClassInfo的所有视图集合
MetaViewFields | getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViews | getViewsContainsTable(MetaDBTable _oTable) 获取使用指定表作为附表的视图
MetaViews | getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo) 获取使用了物理字段_oDBFieldInfo的所有视图
MetaViews | getViewsUsingTable(MetaDBTable _oTable) 获取正在使用指定表的视图
void | recreateAll(User _currUser, MetaDBTables _oMetaDBTables) 重新产生所有的表结构和相关视图的应用
void | resetTitleField(MetaViewField oMetaViewField) 根据oMetaViewField的TitleField状态决定是否重置该视图下的标题字段 如果是新建一个标题字段，则需要清除原来的标题字段； 如果是修改一个字段,并且它的TitleField属性由0变成1，即由非标题字段变成标题字段， 则也需求清除原来的标题字段
MetaDBTable | save(User _currUser, MetaDBTable _oTableInfo) 新增或者修改系统表
MetaDBField | save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo) 在指定表上，新增或者修改指定字段信息
MetaView | save(User _currUser, MetaView _oViewInfo) 新增或修改视图信息
MetaViewField | save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo) 在指定视图上，新增或者修改指定字段信息
void | setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields) 设置
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataDefMgr

public MetaDataDefMgr()
方法详细信息

save

public MetaDBTable save(User _currUser,
                        MetaDBTable _oTableInfo)
                 throws WCMException
从接口 IMetaDataDefMgr 复制的描述
新增或者修改系统表

指定者：
接口 IMetaDataDefMgr 中的 save
返回：
抛出：
WCMException

save

public MetaDBField save(User _currUser,
                        MetaDBTable _oOwnerTable,
                        MetaDBField _oDBFieldInfo)
                 throws WCMException
从接口 IMetaDataDefMgr 复制的描述
在指定表上，新增或者修改指定字段信息

指定者：
接口 IMetaDataDefMgr 中的 save
返回：
抛出：
WCMException

save

public MetaView save(User _currUser,
                     MetaView _oViewInfo)
              throws WCMException
从接口 IMetaDataDefMgr 复制的描述
新增或修改视图信息

指定者：
接口 IMetaDataDefMgr 中的 save
返回：
抛出：
WCMException

save

public MetaViewField save(User _currUser,
                          MetaView _oOwnerView,
                          MetaViewField _oViewFieldInfo)
                   throws WCMException
从接口 IMetaDataDefMgr 复制的描述
在指定视图上，新增或者修改指定字段信息

指定者：
接口 IMetaDataDefMgr 中的 save
返回：
抛出：
WCMException

getMetaViewField

public MetaViewField getMetaViewField(MetaView _oView,
                                      int _nDbFieldId)
                               throws WCMException
指定者：
接口 IMetaDataDefMgr 中的 getMetaViewField
抛出：
WCMException

resetTitleField

public void resetTitleField(MetaViewField oMetaViewField)
                     throws WCMException
根据oMetaViewField的TitleField状态决定是否重置该视图下的标题字段
如果是新建一个标题字段，则需要清除原来的标题字段；
如果是修改一个字段,并且它的TitleField属性由0变成1，即由非标题字段变成标题字段，
则也需求清除原来的标题字段

参数：
oMetaViewField -
抛出：
WCMException

clearTitleField

public void clearTitleField(MetaView oView)
                     throws WCMException
清除视图oView下的标题字段,即原来是标题字段的，将不再作为标题字段

参数：
oView -
抛出：
WCMException

createDDLSQL

public java.lang.String createDDLSQL(MetaDBTable _oTableInfo)
                              throws WCMException
从接口 IMetaDataDefMgr 复制的描述
产生指定表的定义SQL

指定者：
接口 IMetaDataDefMgr 中的 createDDLSQL
抛出：
WCMException

createDDLSQL

public java.lang.String createDDLSQL(MetaView _oViewInfo)
                              throws WCMException
从接口 IMetaDataDefMgr 复制的描述
产生指定视图的定义SQL

指定者：
接口 IMetaDataDefMgr 中的 createDDLSQL
抛出：
WCMException

delete

public void delete(User _currUser,
                   MetaDBField _oDBFieldInfo)
            throws WCMException
从接口 IMetaDataDefMgr 复制的描述
删除指定字段

指定者：
接口 IMetaDataDefMgr 中的 delete
抛出：
WCMException

delete

public void delete(User _currUser,
                   MetaDBTable _oTableInfo)
            throws WCMException
删除元数据的操作步骤如下：
删除元数据物理字段；
删除元数据对应物理表里的数据；
删除元数据物理表；
删除元数据；
删除所有以此元数据作为主表的视图；
获取所有以此元数据作为附表的视图；
删除附表视图和此元数据的关系；
删除附表视图中此元数据的字段；
如果此视图由多表变成单表，则删除此物理视图，并修改视图的viewName
重新生成视图；

指定者：
接口 IMetaDataDefMgr 中的 delete
抛出：
WCMException

getDFieldInfos

public MetaDBFields getDFieldInfos(User _currUser,
                                   MetaDBTable _oDBTableInfo,
                                   WCMFilter _extraFilter)
                            throws WCMException
从接口 IMetaDataDefMgr 复制的描述
获取指定表的指定字段列表

指定者：
接口 IMetaDataDefMgr 中的 getDFieldInfos
返回：
抛出：
WCMException

createViewRelations

public java.lang.String createViewRelations(User _currUser,
                                            MetaView _oView)
                                     throws WCMException
从接口 IMetaDataDefMgr 复制的描述
视图定义完成，产生视图相关的信息（DB视图、相关的JSP）

指定者：
接口 IMetaDataDefMgr 中的 createViewRelations
参数：
_currUser - TODO
返回：
抛出：
WCMException

createViewRelations

public java.lang.String createViewRelations(User _currUser,
                                            MetaView _oView,
                                            boolean generateApplication)
                                     throws WCMException
从接口 IMetaDataDefMgr 复制的描述
视图定义完成，产生视图相关的信息（DB视图、相关的JSP）

指定者：
接口 IMetaDataDefMgr 中的 createViewRelations
参数：
_currUser - TODO
generateApplication - 是否生成应用
返回：
抛出：
WCMException

createViewApplication

public boolean createViewApplication(MetaView _oView,
                                     java.lang.String _sTemplatePath,
                                     java.lang.String _sApplicationPath)
                              throws WCMException
视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8

指定者：
接口 IMetaDataDefMgr 中的 createViewApplication
参数：
_oView -
_sTemplatePath -
_sApplicationPath -
返回：
抛出：
WCMException

getViewFields

public MetaViewFields getViewFields(User _currUser,
                                    MetaView _oView,
                                    WCMFilter _extraFilter)
                             throws WCMException
指定者：
接口 IMetaDataDefMgr 中的 getViewFields
返回：
抛出：
WCMException

appendDefaultFields

public void appendDefaultFields(User _currUser,
                                MetaDBTable _oTable)
                         throws WCMException
从接口 IMetaDataDefMgr 复制的描述
给自定的表追加默认的字段

指定者：
接口 IMetaDataDefMgr 中的 appendDefaultFields
抛出：
WCMException

setViewFields

public void setViewFields(User _currUser,
                          MetaView _oOwnerView,
                          MetaDBFields _dbFields)
                   throws WCMException
从接口 IMetaDataDefMgr 复制的描述
设置

指定者：
接口 IMetaDataDefMgr 中的 setViewFields
抛出：
WCMException

delete

public void delete(User _currUser,
                   MetaViewField _oViewField)
            throws WCMException
从接口 IMetaDataDefMgr 复制的描述
删除指定视图字段

指定者：
接口 IMetaDataDefMgr 中的 delete
抛出：
WCMException

delete

public void delete(User _currUser,
                   MetaView _oView)
            throws WCMException
从接口 IMetaDataDefMgr 复制的描述
删除指定表

指定者：
接口 IMetaDataDefMgr 中的 delete
抛出：
WCMException

getViewsUsingTable

public MetaViews getViewsUsingTable(MetaDBTable _oTable)
                             throws WCMException
从接口 IMetaDataDefMgr 复制的描述
获取正在使用指定表的视图

指定者：
接口 IMetaDataDefMgr 中的 getViewsUsingTable
抛出：
WCMException

getViewsContainsTable

public MetaViews getViewsContainsTable(MetaDBTable _oTable)
                                throws WCMException
从接口 IMetaDataDefMgr 复制的描述
获取使用指定表作为附表的视图

指定者：
接口 IMetaDataDefMgr 中的 getViewsContainsTable
抛出：
WCMException

getViewsUsingField

public MetaViews getViewsUsingField(User _currUser,
                                    MetaDBField _oDBFieldInfo)
                             throws WCMException
从接口 IMetaDataDefMgr 复制的描述
获取使用了物理字段_oDBFieldInfo的所有视图

指定者：
接口 IMetaDataDefMgr 中的 getViewsUsingField
返回：
抛出：
WCMException

recreateAll

public void recreateAll(User _currUser,
                        MetaDBTables _oMetaDBTables)
                 throws WCMException
从接口 IMetaDataDefMgr 复制的描述
重新产生所有的表结构和相关视图的应用

指定者：
接口 IMetaDataDefMgr 中的 recreateAll
抛出：
WCMException

getClassInfosUsingMetaView

public ClassInfos getClassInfosUsingMetaView(User _currUser,
                                             MetaView oMetaView)
                                      throws WCMException
从接口 IMetaDataDefMgr 复制的描述
查询视图oMetaView使用了的所有分类法集合

指定者：
接口 IMetaDataDefMgr 中的 getClassInfosUsingMetaView
返回：
抛出：
WCMException

getMetaViewsUsingClassInfo

public MetaViews getMetaViewsUsingClassInfo(User _currUser,
                                            ClassInfo oClassInfo)
                                     throws WCMException
从接口 IMetaDataDefMgr 复制的描述
查询使用了分类法oClassInfo的所有视图集合

指定者：
接口 IMetaDataDefMgr 中的 getMetaViewsUsingClassInfo
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDataType

java.lang.Object
    继承者  com.trs.components.metadata.definition.MetaDataType

public class MetaDataType
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据类型定义对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataType(int _nDataType, java.lang.String _sDataTypeDesc, java.lang.String _sKey, int _nSqlDataType, int _nMaxLength)
方法摘要
int | getDataType()
java.lang.String | getDataTypeDesc()
java.lang.String | getKey()
int | getMaxLength()
int | getSqlDataType()
boolean | isString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataType

public MetaDataType(int _nDataType,
                    java.lang.String _sDataTypeDesc,
                    java.lang.String _sKey,
                    int _nSqlDataType,
                    int _nMaxLength)
方法详细信息

getDataType

public int getDataType()
返回：

getSqlDataType

public int getSqlDataType()
返回：

getDataTypeDesc

public java.lang.String getDataTypeDesc()
返回：

getKey

public java.lang.String getKey()
返回：

getMaxLength

public int getMaxLength()

isString

public boolean isString()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDataTypes

java.lang.Object
    继承者  com.trs.components.metadata.definition.MetaDataTypes

public class MetaDataTypes
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
元数据定义所支持的所有类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataTypes()
方法摘要
MetaDataType | getDataTypeAt(int _nIndex)
MetaDataType | getDataTypeById(int _nTypeId)
int | getDataTypesCount()
void | registerMetaDataType(int _nTypeId, java.lang.String _sDataTypeDesc, java.lang.String _sKey, int _nSqlDataType, int _nMaxLength) 注册新的数据类型
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataTypes

public MetaDataTypes()
方法详细信息

registerMetaDataType

public void registerMetaDataType(int _nTypeId,
                                 java.lang.String _sDataTypeDesc,
                                 java.lang.String _sKey,
                                 int _nSqlDataType,
                                 int _nMaxLength)
注册新的数据类型

参数：
_nTypeId -
_sDataTypeDesc -
_nSqlDataType -

getDataTypesCount

public int getDataTypesCount()
返回：

getDataTypeAt

public MetaDataType getDataTypeAt(int _nIndex)
参数：
_nIndex -
返回：

getDataTypeById

public MetaDataType getDataTypeById(int _nTypeId)
参数：
_nTypeId -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDBField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDBField

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.metadata.definition.MetaDBField
所有已实现的接口：
java.lang.Cloneable
public class MetaDBField
extends CMSObj

字段摘要
static java.lang.String | DB_FIELD_DBNAME_NAME 对象数据存储物理字段名的字段
static java.lang.String | DB_FIELD_DBTYPE_NAME 对象数据存储物理字段类型的字段
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
MetaDBField()
构造函数：保留默认接口
方法摘要
static MetaDBField | createNewInstance() 产生当前对象[DBFieldInfo]的实例
static MetaDBField | findById(int _nId) 提取指定ID的对象
static MetaDBField | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAnotherName() 提取属性：AnotherName
int | getClassId() 提取属性：ClassId
java.lang.String | getClassName() 提取属性：ClassName
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getDBType() 提取属性：DBType
java.lang.String | getDBTypeDesc() 提取属性：DBTypeDesc
java.lang.String | getDefaultValue() 提取属性：DefaultValue
java.lang.String | getEnmValue() 提取属性：EnmValue
java.util.HashMap | getEnmValueMap(boolean valueAsKey) 获得枚举止的HashMap对象
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getLength() 提取属性：Length
MetaDBTable | getMetaDBTable()
java.lang.String | getName() 提取属性：Name
int | getScale() 提取属性：Scale
int | getSqlType()
int | getTableId() 提取属性：TableId
java.lang.String | getTableName() 提取属性：TableName
int | getType() 提取属性：Type
java.lang.String | getTypeDesc() 提取属性：TypeDesc
java.lang.String | getValidator() 提取属性：Validator
int | getWCMType() 取得该对象的类型编号
boolean | isModifyColumnProperties(boolean _bContainNull) 是否修改了栏目属性（长度、默认值、是否为空、位数）
boolean | isNotNull() 提取属性：NotNull
boolean | isRadioOrCheck() 提取属性：radioOrCheck
boolean | isStringField()
boolean | isValid() 检验对象数据有效性
boolean | setAnotherName(java.lang.String _sAnotherName) 设置属性：AnotherName
boolean | setClassId(int _nClassId) 设置属性：ClassId
boolean | setDBType(int _nDBType) 设置属性：DBType
boolean | setDefaultValue(java.lang.String _sDefaultValue) 设置属性：DefaultValue
boolean | setEnmValue(java.lang.String _sEnmValue) 设置属性：EnmValue
boolean | setLength(int _nLength) 设置属性：Length
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setNotNull(boolean _bNotNull) 设置属性：NotNull
boolean | setRadioOrCheck(boolean bRadioOrCheck) 设置属性：radioOrCheck
boolean | setScale(int _nScale) 设置属性：Scale
boolean | setTableId(int _nTableId) 设置属性：TableId
boolean | setTableName(java.lang.String _sTableName) 设置属性：TableName
boolean | setType(int _nType) 设置属性：Type
boolean | setValidator(java.lang.String _sValidatorExpress) 设置属性：Validator
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

DB_FIELD_DBNAME_NAME

public static final java.lang.String DB_FIELD_DBNAME_NAME
对象数据存储物理字段名的字段

另请参见：
常量字段值

DB_FIELD_DBTYPE_NAME

public static final java.lang.String DB_FIELD_DBTYPE_NAME
对象数据存储物理字段类型的字段

另请参见：
常量字段值
构造方法详细信息

MetaDBField

public MetaDBField()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getTableName

public java.lang.String getTableName()
提取属性：TableName

返回：
TableName

setTableName

public boolean setTableName(java.lang.String _sTableName)
                     throws WCMException
设置属性：TableName

参数：
_sTableName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTableId

public int getTableId()
提取属性：TableId

返回：
TableId

setTableId

public boolean setTableId(int _nTableId)
                   throws WCMException
设置属性：TableId

参数：
_nTableId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAnotherName

public java.lang.String getAnotherName()
提取属性：AnotherName

返回：
AnotherName

setAnotherName

public boolean setAnotherName(java.lang.String _sAnotherName)
                       throws WCMException
设置属性：AnotherName

参数：
_sAnotherName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getType

public int getType()
提取属性：Type

返回：
Type

setType

public boolean setType(int _nType)
                throws WCMException
设置属性：Type

参数：
_nType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDBType

public int getDBType()
提取属性：DBType

返回：
DBType

setDBType

public boolean setDBType(int _nDBType)
                  throws WCMException
设置属性：DBType

参数：
_nDBType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLength

public int getLength()
提取属性：Length

返回：
Length

setLength

public boolean setLength(int _nLength)
                  throws WCMException
设置属性：Length

参数：
_nLength - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getScale

public int getScale()
提取属性：Scale

返回：
Scale

setScale

public boolean setScale(int _nScale)
                 throws WCMException
设置属性：Scale

参数：
_nScale - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDefaultValue

public java.lang.String getDefaultValue()
提取属性：DefaultValue

返回：
DefaultValue

setDefaultValue

public boolean setDefaultValue(java.lang.String _sDefaultValue)
                        throws WCMException
设置属性：DefaultValue

参数：
_sDefaultValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getValidator

public java.lang.String getValidator()
提取属性：Validator

返回：
Validator

setValidator

public boolean setValidator(java.lang.String _sValidatorExpress)
                     throws WCMException
设置属性：Validator

参数：
_sValidatorExpress - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEnmValue

public java.lang.String getEnmValue()
提取属性：EnmValue

返回：
EnmValue

setEnmValue

public boolean setEnmValue(java.lang.String _sEnmValue)
                    throws WCMException
设置属性：EnmValue

参数：
_sEnmValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isNotNull

public boolean isNotNull()
提取属性：NotNull

返回：
NotNull

setNotNull

public boolean setNotNull(boolean _bNotNull)
                   throws WCMException
设置属性：NotNull

参数：
_bNotNull - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isRadioOrCheck

public boolean isRadioOrCheck()
提取属性：radioOrCheck

返回：
radioOrCheck

setRadioOrCheck

public boolean setRadioOrCheck(boolean bRadioOrCheck)
                        throws WCMException
设置属性：radioOrCheck

参数：
bRadioOrCheck - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getClassId

public int getClassId()
提取属性：ClassId

返回：
ClassId

setClassId

public boolean setClassId(int _nClassId)
                   throws WCMException
设置属性：ClassId

参数：
_nClassId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

getClassName

public java.lang.String getClassName()
提取属性：ClassName

返回：
ClassName

getTypeDesc

public java.lang.String getTypeDesc()
提取属性：TypeDesc

返回：
TypeDesc

getDBTypeDesc

public java.lang.String getDBTypeDesc()
提取属性：DBTypeDesc

返回：
DBTypeDesc

getSqlType

public int getSqlType()

isStringField

public boolean isStringField()

isModifyColumnProperties

public boolean isModifyColumnProperties(boolean _bContainNull)
是否修改了栏目属性（长度、默认值、是否为空、位数）

返回：

getEnmValueMap

public java.util.HashMap getEnmValueMap(boolean valueAsKey)
获得枚举止的HashMap对象

参数：
valueAsKey - true以value作为HashMap的key,否则以label作为HashMap的key.
返回：

getMetaDBTable

public MetaDBTable getMetaDBTable()
                           throws WCMException
抛出：
WCMException

findById

public static final MetaDBField findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MetaDBField createNewInstance()
                                           throws WCMException
产生当前对象[DBFieldInfo]的实例

返回：
当前对象的实例[DBFieldInfo]
抛出：
WCMException

findByKey

public static final MetaDBField findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDBFieldListenerForChannelSynRule

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDBFieldListenerForChannelSynRule

java.lang.Object
    继承者  com.trs.components.metadata.definition.MetaDBFieldListenerForChannelSynRule
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class MetaDBFieldListenerForChannelSynRule
extends java.lang.Object
implements IObjectLCListenerOnModify

构造方法摘要
MetaDBFieldListenerForChannelSynRule()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDBFieldListenerForChannelSynRule

public MetaDBFieldListenerForChannelSynRule()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDBFields

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDBFields

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.metadata.definition.MetaDBFields

public class MetaDBFields
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MetaDBFields(User _currUser)
构造函数
MetaDBFields(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static MetaDBFields | createNewInstance(User _currUser) 产生当前集合对象[DBFieldInfos]的实例
static MetaDBFields | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static MetaDBFields | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DBFieldInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDBFields

public MetaDBFields(User _currUser)
构造函数

另请参见：
DBFieldInfos( User _currUser, int _initCapacity, int _incCapacity );

MetaDBFields

public MetaDBFields(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final MetaDBFields findByIds(User _currUser,
                                           java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（DBFieldInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MetaDBFields openWCMObjs(User _currUser,
                                             WCMFilter _filter)
                                      throws WCMException
通过指定一个Filter获取当前集合[DBFieldInfos]

参数：
_filter - 指定的Filter
返回：
当前集合[DBFieldInfos]
抛出：
WCMException

createNewInstance

public static MetaDBFields createNewInstance(User _currUser)
产生当前集合对象[DBFieldInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDBTable

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDBTable

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.metadata.definition.MetaDBTable
所有已实现的接口：
java.lang.Cloneable
public class MetaDBTable
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static java.lang.String | FIELD_NAME_TABLE 对象的字段名称：表名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
MetaDBTable()
构造函数：保留默认接口
方法摘要
static MetaDBTable | createNewInstance() 产生当前对象[TableInfo]的实例
static MetaDBTable | findById(int _nId) 提取指定ID的对象
static MetaDBTable | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAnotherName() 提取属性：AnotherName
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 提取属性：Desc
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getName() 提取属性：Name
CMSObj | getOwner() 获取视图所属对象
int | getOwnerId() 获取视图所属对象ID
int | getOwnerType() 获取视图所属对象Type
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setAnotherName(java.lang.String _sAnotherName) 设置属性：AnotherName
boolean | setDesc(java.lang.String _sDesc) 设置属性：Desc
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setOwner(int _nOwnerType, int _nOwnerId) 设置视图所属对象
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

FIELD_NAME_TABLE

public static final java.lang.String FIELD_NAME_TABLE
对象的字段名称：表名

另请参见：
常量字段值
构造方法详细信息

MetaDBTable

public MetaDBTable()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAnotherName

public java.lang.String getAnotherName()
提取属性：AnotherName

返回：
AnotherName

setAnotherName

public boolean setAnotherName(java.lang.String _sAnotherName)
                       throws WCMException
设置属性：AnotherName

参数：
_sAnotherName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
提取属性：Desc

返回：
Desc

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置属性：Desc

参数：
_sDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOwner

public CMSObj getOwner()
                throws WCMException
获取视图所属对象

返回：
抛出：
WCMException

getOwnerId

public int getOwnerId()
获取视图所属对象ID

返回：

getOwnerType

public int getOwnerType()
获取视图所属对象Type

返回：

setOwner

public boolean setOwner(int _nOwnerType,
                        int _nOwnerId)
                 throws WCMException
设置视图所属对象

参数：
_nOwnerType -
_nOwnerId -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final MetaDBTable findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MetaDBTable createNewInstance()
                                           throws WCMException
产生当前对象[TableInfo]的实例

返回：
当前对象的实例[TableInfo]
抛出：
WCMException

findByKey

public static final MetaDBTable findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDBTables

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaDBTables

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.metadata.definition.MetaDBTables

public class MetaDBTables
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MetaDBTables(User _currUser)
构造函数
MetaDBTables(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static MetaDBTables | createNewInstance(User _currUser) 产生当前集合对象[TableInfos]的实例
static MetaDBTables | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static MetaDBTables | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TableInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDBTables

public MetaDBTables(User _currUser)
构造函数

另请参见：
TableInfos( User _currUser, int _initCapacity, int _incCapacity );

MetaDBTables

public MetaDBTables(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final MetaDBTables findByIds(User _currUser,
                                           java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（TableInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MetaDBTables openWCMObjs(User _currUser,
                                             WCMFilter _filter)
                                      throws WCMException
通过指定一个Filter获取当前集合[TableInfos]

参数：
_filter - 指定的Filter
返回：
当前集合[TableInfos]
抛出：
WCMException

createNewInstance

public static MetaDBTables createNewInstance(User _currUser)
产生当前集合对象[TableInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaView

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaView

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.metadata.definition.MetaView
所有已实现的接口：
java.lang.Cloneable
public class MetaView
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
MetaView()
构造函数：保留默认接口
方法摘要
static MetaView | createNewInstance() 产生当前对象[ViewInfo]的实例
static MetaView | findById(int _nId) 提取指定ID的对象
static MetaView | findByIdentity(java.lang.String sIdentityName, java.lang.String sIdentityValue) 根据唯一标识属性，获取第一个视图对象，由于视图名称和视图描述是唯一的，所以一般情况下可以作为sIdentityName
static MetaView | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 提取属性：Desc
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
MetaDBTable | getMainDBTableInfo()
MetaDBTable | getMainTable()
int | getMainTableId() 获取主表ID
java.lang.String | getMainTableName() 提取属性：MainTableName
java.lang.String | getName() 提取属性：Name
java.lang.String | getOtherTableIds() 获取其它相关的表
MetaDBTables | getOtherTables(User _currUser, WCMFilter _extraFilter)
CMSObj | getOwner() 获取视图所属对象
int | getOwnerId() 获取视图所属对象ID
int | getOwnerType() 获取视图所属对象Type
MetaViewField | getTitleField() 返回视图的标题字段
java.lang.String | getTrueTableName()
MetaViewFields | getViewFields(User _currUser, WCMFilter _extraFilter)
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isHiddenAppendix()
boolean | isModified(boolean zDeep)
boolean | isMultiTable() 是否为多表
boolean | isValid() 检验对象数据有效性
void | save(User _currUser) 对象保存自己
boolean | setDesc(java.lang.String _sDesc) 设置属性：Desc
boolean | setHiddenAppendix(boolean _zHide)
boolean | setMainTable(MetaDBTable _dbTableInfo)
boolean | setMainTableId(int _nTableId, java.lang.String _sTableName)
boolean | setName(java.lang.String _sName) 设置属性：Name
void | setOtherTableIds(java.lang.String otherTableIds)
boolean | setOwner(int _nOwnerType, int _nOwnerId) 设置视图所属对象
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

MetaView

public MetaView()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
提取属性：Desc

返回：
Desc

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置属性：Desc

参数：
_sDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMainTableName

public java.lang.String getMainTableName()
提取属性：MainTableName

返回：
MainTable

getMainTableId

public int getMainTableId()
获取主表ID

返回：

getMainTable

public MetaDBTable getMainTable()
                         throws WCMException
返回：
抛出：
WCMException

setMainTableId

public boolean setMainTableId(int _nTableId,
                              java.lang.String _sTableName)
                       throws WCMException
抛出：
WCMException

setMainTable

public boolean setMainTable(MetaDBTable _dbTableInfo)
                     throws WCMException
参数：
_dbTableInfo -
返回：
抛出：
WCMException

getMainDBTableInfo

public MetaDBTable getMainDBTableInfo()
                               throws WCMException
返回：
抛出：
WCMException

getOtherTableIds

public java.lang.String getOtherTableIds()
                                  throws WCMException
获取其它相关的表

返回：
抛出：
WCMException

getOtherTables

public MetaDBTables getOtherTables(User _currUser,
                                   WCMFilter _extraFilter)
                            throws WCMException
参数：
_currUser -
_extraFilter -
返回：
抛出：
WCMException

setOtherTableIds

public void setOtherTableIds(java.lang.String otherTableIds)
参数：
otherTableIds -

getOwner

public CMSObj getOwner()
                throws WCMException
获取视图所属对象

返回：
抛出：
WCMException

getOwnerId

public int getOwnerId()
获取视图所属对象ID

返回：

getOwnerType

public int getOwnerType()
获取视图所属对象Type

返回：

setOwner

public boolean setOwner(int _nOwnerType,
                        int _nOwnerId)
                 throws WCMException
设置视图所属对象

参数：
_nOwnerType -
_nOwnerId -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

getViewFields

public MetaViewFields getViewFields(User _currUser,
                                    WCMFilter _extraFilter)
                             throws WCMException
参数：
_currUser -
_extraFilter -
返回：
抛出：
WCMException

getTitleField

public MetaViewField getTitleField()
                            throws WCMException
返回视图的标题字段

返回：
抛出：
WCMException

findById

public static final MetaView findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByIdentity

public static final MetaView findByIdentity(java.lang.String sIdentityName,
                                            java.lang.String sIdentityValue)
                                     throws WCMException
根据唯一标识属性，获取第一个视图对象，由于视图名称和视图描述是唯一的，所以一般情况下可以作为sIdentityName

参数：
sIdentityName -
sIdentityValue -
返回：
抛出：
WCMException

createNewInstance

public static final MetaView createNewInstance()
                                        throws WCMException
产生当前对象[ViewInfo]的实例

返回：
当前对象的实例[ViewInfo]
抛出：
WCMException

findByKey

public static final MetaView findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

save

public void save(User _currUser)
          throws WCMException
从类 CMSObj 复制的描述
对象保存自己

覆盖：
类 CMSObj 中的 save
参数：
_currUser - 当前操作用户
抛出：
WCMException

isModified

public boolean isModified(boolean zDeep)
覆盖：
类 BaseObj 中的 isModified

getTrueTableName

public java.lang.String getTrueTableName()
返回：

isMultiTable

public boolean isMultiTable()
是否为多表

返回：

isHiddenAppendix

public boolean isHiddenAppendix()

setHiddenAppendix

public boolean setHiddenAppendix(boolean _zHide)
                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaViewField

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.metadata.definition.MetaViewField
所有已实现的接口：
java.lang.Cloneable
public class MetaViewField
extends CMSObj

字段摘要
static java.lang.String | DB_FIELD_DBTYPE_NAME 对象数据存储物理字段类型的字段
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
MetaViewField()
构造函数：保留默认接口
方法摘要
static MetaViewField | createNewInstance() 产生当前对象[ViewFieldInfo]的实例
static MetaViewField | findById(int _nId) 提取指定ID的对象
static MetaViewField | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAnotherName() 提取属性：AnotherName
int | getClassId() 提取属性：ClassId
java.lang.String | getClassName() 提取属性：ClassName
MetaDBField | getDBField()
int | getDBFieldId() 提取属性：DBField
java.lang.String | getDBName() 提取属性：物理字段名称
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getDBType() 提取属性：DBType
java.lang.String | getDBTypeDesc() 提取属性：DBTypeDesc
java.lang.String | getDefaultValue() 提取属性：DefaultValue
java.lang.String | getEnmValue() 提取属性：EnmValue
java.util.HashMap | getEnmValueMap(boolean valueAsKey) 获得枚举止的HashMap对象
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getLength() 提取属性：Length
java.lang.String | getName() 提取属性：Name
int | getOrder() 提取属性：Order
int | getScale() 提取属性：Scale
int | getTableId() 提取属性：TableId
java.lang.String | getTableName() 提取属性：TableName
int | getType() 提取属性：Type
java.lang.String | getTypeDesc() 提取属性：TypeDesc
java.lang.String | getValidator() 提取属性：Validator
java.lang.String | getValueFromLabel(java.lang.String _sLabel) 由枚举值的label获得枚举值的value
java.lang.String[] | getValuesFromLabel(java.lang.String _sLabel) 由枚举值的label获得枚举值的value
int | getViewId() 提取属性：OwnerView
int | getWCMType() 取得该对象的类型编号
void | inheritDBFieldInfo(MetaDBField _dbField) 设置物理字段的信息
void | insert(User _currUser) 将对象数据写入数据库
boolean | isEditable()
boolean | isFromMainTable() 是否来自于主表
boolean | isHidden()
boolean | isIdentityField() 提取属性：IdentityField
boolean | isInDetail() 提取属性：InDetail
boolean | isInMultiTable()
boolean | isInOutline() 提取属性：InOutline
boolean | isNotNull() 提取属性：NotNull
boolean | isRadioOrCheck() 提取属性：radioOrCheck
boolean | isSearchField() 提取属性：SearchField
boolean | isTitleField() 提取属性：TitleField
boolean | isValid() 检验对象数据有效性
boolean | setAnotherName(java.lang.String _sAnotherName) 设置属性：AnotherName
boolean | setClassId(int _nClassId) 设置属性：ClassId
boolean | setDBField(int _nDBField) 设置属性：DBField
boolean | setDBName(java.lang.String _sName) 设置属性：物理字段名称
boolean | setDBType(int _nDBType) 设置属性：DBType
boolean | setDefaultValue(java.lang.String _sDefaultValue) 设置属性：DefaultValue
boolean | setEditable(boolean _zEditable)
boolean | setEnmValue(java.lang.String _sEnmValue) 设置属性：EnmValue
boolean | setFromMainTable(boolean _bFromMainTable) 设置是否来自于主表
boolean | setHidden(boolean _zHidden)
boolean | setIdentityField(boolean _bIdentityField) 设置属性：IdentityField
boolean | setInDetail(boolean _bInDetail) 设置属性：InDetail
boolean | setInMultiTable(boolean _zInMultiTable)
boolean | setInOutline(boolean _bInOutline) 设置属性：InOutline
boolean | setLength(int _nLength) 设置属性：Length
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setNotNull(boolean _bNotNull) 设置属性：NotNull
boolean | setOrder(int _nOrder) 设置属性：Order
boolean | setRadioOrCheck(boolean bRadioOrCheck) 设置属性：radioOrCheck
boolean | setScale(int _nScale) 设置属性：Scale
boolean | setSearchField(boolean _bSearchField) 设置属性：SearchField
boolean | setTableId(int _nTableId) 设置属性：TableId
boolean | setTableName(java.lang.String _sTableName) 设置属性：TableName
boolean | setTitleField(boolean _bTitleField) 设置属性：TitleField
boolean | setType(int _nType) 设置属性：Type
boolean | setValidator(java.lang.String _sValidatorExpress) 设置属性：Validator
boolean | setView(int _nOwnerView) 设置属性：OwnerView
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

DB_FIELD_DBTYPE_NAME

public static final java.lang.String DB_FIELD_DBTYPE_NAME
对象数据存储物理字段类型的字段

另请参见：
常量字段值
构造方法详细信息

MetaViewField

public MetaViewField()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getTableName

public java.lang.String getTableName()
提取属性：TableName

返回：
TableName

setTableName

public boolean setTableName(java.lang.String _sTableName)
                     throws WCMException
设置属性：TableName

参数：
_sTableName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTableId

public int getTableId()
提取属性：TableId

返回：
TableId

setTableId

public boolean setTableId(int _nTableId)
                   throws WCMException
设置属性：TableId

参数：
_nTableId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDBName

public java.lang.String getDBName()
提取属性：物理字段名称

返回：
Name

setDBName

public boolean setDBName(java.lang.String _sName)
                  throws WCMException
设置属性：物理字段名称

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAnotherName

public java.lang.String getAnotherName()
提取属性：AnotherName

返回：
AnotherName

setAnotherName

public boolean setAnotherName(java.lang.String _sAnotherName)
                       throws WCMException
设置属性：AnotherName

参数：
_sAnotherName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getType

public int getType()
提取属性：Type

返回：
Type

setType

public boolean setType(int _nType)
                throws WCMException
设置属性：Type

参数：
_nType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDefaultValue

public java.lang.String getDefaultValue()
提取属性：DefaultValue

返回：
DefaultValue

setDefaultValue

public boolean setDefaultValue(java.lang.String _sDefaultValue)
                        throws WCMException
设置属性：DefaultValue

参数：
_sDefaultValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEnmValue

public java.lang.String getEnmValue()
提取属性：EnmValue

返回：
EnmValue

setEnmValue

public boolean setEnmValue(java.lang.String _sEnmValue)
                    throws WCMException
设置属性：EnmValue

参数：
_sEnmValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isNotNull

public boolean isNotNull()
提取属性：NotNull

返回：
NotNull

setNotNull

public boolean setNotNull(boolean _bNotNull)
                   throws WCMException
设置属性：NotNull

参数：
_bNotNull - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isRadioOrCheck

public boolean isRadioOrCheck()
提取属性：radioOrCheck

返回：
radioOrCheck

setRadioOrCheck

public boolean setRadioOrCheck(boolean bRadioOrCheck)
                        throws WCMException
设置属性：radioOrCheck

参数：
bRadioOrCheck - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getClassId

public int getClassId()
提取属性：ClassId

返回：
ClassId

setClassId

public boolean setClassId(int _nClassId)
                   throws WCMException
设置属性：ClassId

参数：
_nClassId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewId

public int getViewId()
提取属性：OwnerView

返回：
OwnerView

setView

public boolean setView(int _nOwnerView)
                throws WCMException
设置属性：OwnerView

参数：
_nOwnerView - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOrder

public int getOrder()
提取属性：Order

返回：
Order

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置属性：Order

参数：
_nOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isInOutline

public boolean isInOutline()
提取属性：InOutline

返回：
InOutline

setInOutline

public boolean setInOutline(boolean _bInOutline)
                     throws WCMException
设置属性：InOutline

参数：
_bInOutline - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isInDetail

public boolean isInDetail()
提取属性：InDetail

返回：
InDetail

setInDetail

public boolean setInDetail(boolean _bInDetail)
                    throws WCMException
设置属性：InDetail

参数：
_bInDetail - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isSearchField

public boolean isSearchField()
提取属性：SearchField

返回：
SearchField

setSearchField

public boolean setSearchField(boolean _bSearchField)
                       throws WCMException
设置属性：SearchField

参数：
_bSearchField - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isTitleField

public boolean isTitleField()
提取属性：TitleField

返回：
TitleField

setTitleField

public boolean setTitleField(boolean _bTitleField)
                      throws WCMException
设置属性：TitleField

参数：
_bTitleField - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isIdentityField

public boolean isIdentityField()
提取属性：IdentityField

返回：
IdentityField

setIdentityField

public boolean setIdentityField(boolean _bIdentityField)
                         throws WCMException
设置属性：IdentityField

参数：
_bIdentityField - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDBFieldId

public int getDBFieldId()
提取属性：DBField

返回：
DBField

getDBField

public MetaDBField getDBField()
                       throws WCMException
返回：
抛出：
WCMException

setDBField

public boolean setDBField(int _nDBField)
                   throws WCMException
设置属性：DBField

参数：
_nDBField - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getValidator

public java.lang.String getValidator()
提取属性：Validator

返回：
Validator

setValidator

public boolean setValidator(java.lang.String _sValidatorExpress)
                     throws WCMException
设置属性：Validator

参数：
_sValidatorExpress - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDBType

public int getDBType()
提取属性：DBType

返回：
DBType

setDBType

public boolean setDBType(int _nDBType)
                  throws WCMException
设置属性：DBType

参数：
_nDBType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLength

public int getLength()
提取属性：Length

返回：
Length

setLength

public boolean setLength(int _nLength)
                  throws WCMException
设置属性：Length

参数：
_nLength - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getScale

public int getScale()
提取属性：Scale

返回：
Scale

setScale

public boolean setScale(int _nScale)
                 throws WCMException
设置属性：Scale

参数：
_nScale - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isFromMainTable

public boolean isFromMainTable()
是否来自于主表

返回：

setFromMainTable

public boolean setFromMainTable(boolean _bFromMainTable)
                         throws WCMException
设置是否来自于主表

参数：
_bFromMainTable -
返回：
抛出：
WCMException

inheritDBFieldInfo

public void inheritDBFieldInfo(MetaDBField _dbField)
                        throws WCMException
设置物理字段的信息

参数：
_dbField - 相关的物理字段对象
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

getClassName

public java.lang.String getClassName()
提取属性：ClassName

返回：
ClassName

getTypeDesc

public java.lang.String getTypeDesc()
提取属性：TypeDesc

返回：
TypeDesc

getDBTypeDesc

public java.lang.String getDBTypeDesc()
提取属性：DBTypeDesc

返回：
DBTypeDesc

getEnmValueMap

public java.util.HashMap getEnmValueMap(boolean valueAsKey)
获得枚举止的HashMap对象

参数：
valueAsKey - true以value作为HashMap的key,否则以label作为HashMap的key.
返回：

getValueFromLabel

public java.lang.String getValueFromLabel(java.lang.String _sLabel)
由枚举值的label获得枚举值的value

参数：
_sLabel -
返回：

getValuesFromLabel

public java.lang.String[] getValuesFromLabel(java.lang.String _sLabel)
由枚举值的label获得枚举值的value

参数：
_sLabel -
返回：

findById

public static final MetaViewField findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MetaViewField createNewInstance()
                                             throws WCMException
产生当前对象[ViewFieldInfo]的实例

返回：
当前对象的实例[ViewFieldInfo]
抛出：
WCMException

findByKey

public static final MetaViewField findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

isHidden

public boolean isHidden()

setHidden

public boolean setHidden(boolean _zHidden)
                  throws WCMException
抛出：
WCMException

isEditable

public boolean isEditable()

setEditable

public boolean setEditable(boolean _zEditable)
                    throws WCMException
抛出：
WCMException

isInMultiTable

public boolean isInMultiTable()
                       throws WCMException
抛出：
WCMException

setInMultiTable

public boolean setInMultiTable(boolean _zInMultiTable)
                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewFields

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaViewFields

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.metadata.definition.MetaViewFields

public class MetaViewFields
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MetaViewFields(User _currUser)
构造函数
MetaViewFields(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static MetaViewFields | createNewInstance(User _currUser) 产生当前集合对象[ViewFieldInfos]的实例
static MetaViewFields | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static MetaViewFields | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ViewFieldInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewFields

public MetaViewFields(User _currUser)
构造函数

另请参见：
ViewFieldInfos( User _currUser, int _initCapacity, int _incCapacity );

MetaViewFields

public MetaViewFields(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final MetaViewFields findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ViewFieldInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MetaViewFields openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[ViewFieldInfos]

参数：
_filter - 指定的Filter
返回：
当前集合[ViewFieldInfos]
抛出：
WCMException

createNewInstance

public static MetaViewFields createNewInstance(User _currUser)
产生当前集合对象[ViewFieldInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViews

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition
类 MetaViews

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.metadata.definition.MetaViews

public class MetaViews
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MetaViews(User _currUser)
构造函数
MetaViews(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static MetaViews | createNewInstance(User _currUser) 产生当前集合对象[ViewInfos]的实例
static MetaViews | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static MetaViews | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ViewInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViews

public MetaViews(User _currUser)
构造函数

另请参见：
ViewInfos( User _currUser, int _initCapacity, int _incCapacity );

MetaViews

public MetaViews(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final MetaViews findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ViewInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final MetaViews openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[ViewInfos]

参数：
_filter - 指定的Filter
返回：
当前集合[ViewInfos]
抛出：
WCMException

createNewInstance

public static MetaViews createNewInstance(User _currUser)
产生当前集合对象[ViewInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.definition
接口
IClassInfoCacheMgr
IClassInfoMgr
IMetaDataDefCacheMgr
IMetaDataDefMgr
类
ClassInfo
ClassInfoCacheMgr
ClassInfoListenerForViewData
ClassInfoMgr
ClassInfos
ClassInfoUtil
MetaDataDefCacheMgr
MetaDataDefHelper
MetaDataDefMgr
MetaDataType
MetaDataTypes
MetaDBField
MetaDBFieldListenerForChannelSynRule
MetaDBFields
MetaDBTable
MetaDBTables
MetaView
MetaViewField
MetaViewFields
MetaViews


com.trs.components.metadata.definition

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.definition

接口摘要
IClassInfoCacheMgr |
IClassInfoMgr | Title: TRS 内容协作平台（TRS WCM） Description: 分类业务定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IMetaDataDefCacheMgr |
IMetaDataDefMgr | Title: TRS 内容协作平台（TRS WCM） Description: 元数据结构定义业务对象接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
ClassInfo |
ClassInfoCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoListenerForViewData |
ClassInfoMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfos |
ClassInfoUtil | Title: TRS 内容协作平台（TRS WCM） Description: 分类法定义工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataDefCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataDefHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataDefMgr | Title: TRS 内容协作平台（TRS WCM） Description: 元数据结构定义业务对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataType | Title: TRS 内容协作平台（TRS WCM） Description: 元数据类型定义对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataTypes | Title: TRS 内容协作平台（TRS WCM） Description: 元数据定义所支持的所有类型 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDBField |
MetaDBFieldListenerForChannelSynRule |
MetaDBFields |
MetaDBTable |
MetaDBTables |
MetaView |
MetaViewField |
MetaViewFields |
MetaViews |


com.trs.components.metadata.definition 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.definition 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.metadata.definition.ClassInfo
        • com.trs.components.metadata.definition.MetaDBField
        • com.trs.components.metadata.definition.MetaDBTable
        • com.trs.components.metadata.definition.MetaView
        • com.trs.components.metadata.definition.MetaViewField
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.metadata.definition.ClassInfos
        • com.trs.components.metadata.definition.MetaDBFields
        • com.trs.components.metadata.definition.MetaDBTables
        • com.trs.components.metadata.definition.MetaViewFields
        • com.trs.components.metadata.definition.MetaViews
    • com.trs.components.metadata.definition.ClassInfoCacheMgr (implements com.trs.components.metadata.definition.IClassInfoCacheMgr)
    • com.trs.components.metadata.definition.ClassInfoListenerForViewData (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.metadata.definition.ClassInfoMgr (implements com.trs.components.metadata.definition.IClassInfoMgr)
    • com.trs.components.metadata.definition.ClassInfoUtil
    • com.trs.components.metadata.definition.MetaDataDefCacheMgr (implements com.trs.components.metadata.definition.IMetaDataDefCacheMgr)
    • com.trs.components.metadata.definition.MetaDataDefHelper
    • com.trs.components.metadata.definition.MetaDataDefMgr (implements com.trs.components.metadata.definition.IMetaDataDefMgr)
    • com.trs.components.metadata.definition.MetaDataType
    • com.trs.components.metadata.definition.MetaDataTypes
    • com.trs.components.metadata.definition.MetaDBFieldListenerForChannelSynRule (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)

接口分层结构

  • com.trs.components.metadata.definition.IClassInfoMgr
  • com.trs.components.metadata.definition.IMetaDataDefMgr
  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.metadata.definition.IClassInfoCacheMgr
        • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.metadata.definition.IClassInfoCacheMgr
        • com.trs.components.metadata.definition.IMetaDataDefCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.components.metadata.definition.IClassInfoCacheMgr
        • com.trs.components.metadata.definition.IMetaDataDefCacheMgr


软件包 com.trs.components.metadata.definition 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.definition
的使用

使用 com.trs.components.metadata.definition 的软件包
com.trs.components.govinfo
com.trs.components.metadata
com.trs.components.metadata.center
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition
com.trs.components.metadata.definition.xml
com.trs.components.metadata.right
com.trs.components.metadata.service
com.trs.components.metadata.web

com.trs.components.govinfo 使用的 com.trs.components.metadata.definition 中的类
MetaView

com.trs.components.metadata 使用的 com.trs.components.metadata.definition 中的类
MetaDataTypes
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据定义所支持的所有类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.center 使用的 com.trs.components.metadata.definition 中的类
ClassInfo
ClassInfos
IClassInfoMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
分类业务定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IMetaDataDefCacheMgr
IMetaDataDefMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaView
MetaViewField
MetaViews

com.trs.components.metadata.center.xml 使用的 com.trs.components.metadata.definition 中的类
MetaView

com.trs.components.metadata.definition 使用的 com.trs.components.metadata.definition 中的类
ClassInfo
ClassInfos
IClassInfoCacheMgr
IClassInfoMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
分类业务定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IMetaDataDefCacheMgr
IMetaDataDefMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataType
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据类型定义对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDBField
MetaDBFields
MetaDBTable
MetaDBTables
MetaView
MetaViewField
MetaViewFields
MetaViews

com.trs.components.metadata.definition.xml 使用的 com.trs.components.metadata.definition 中的类
MetaViews

com.trs.components.metadata.right 使用的 com.trs.components.metadata.definition 中的类
MetaDBTable
MetaView

com.trs.components.metadata.service 使用的 com.trs.components.metadata.definition 中的类
ClassInfo
ClassInfos
MetaDBField
MetaDBFields
MetaDBTable
MetaDBTables
MetaView
MetaViewField
MetaViewFields
MetaViews

com.trs.components.metadata.web 使用的 com.trs.components.metadata.definition 中的类
MetaViewField

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.ClassInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.ClassInfo
的使用

使用 ClassInfo 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.metadata.service

com.trs.components.metadata.center 中 ClassInfo 的使用

参数类型为 ClassInfo 的 com.trs.components.metadata.center 中的方法
void | IClassInfoViewMgr.delete(User user, ClassInfo _oClassInfo) 删除_oClassInfo下的文档关联
void | ClassInfoViewMgr.delete(User user, ClassInfo _oClassInfo)
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser) 获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
void | IClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo _oSrcClassInfo, int _nDestClassInfoId) 将记录的分类法由_oSrcClassInfo转换为_nDestClassInfoId 如果_nDestClassInfoId为0，则只删除记录的_oSrcClassInfo
void | ClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo srcClassInfo, int destClassInfoId)
void | IClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo _oSrcClassInfo, java.lang.String _destClassInfoId) 将记录的分类法由_oSrcClassInfo转换为_destClassInfoId 如果_destClassInfoId为null，则只删除记录的_oSrcClassInfo
void | ClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo oClassInfo, java.lang.String _sDestClassInfoId)
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
int | IClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo) 根据分类法对象返回相应的文档数目
int | ClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo) 根据分类法对象返回相应的文档数目
int | IClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)
int | ClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)
Documents | IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
Documents | ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
MetaViewDatas | IClassInfoViewMgr.queryViewDatas(User user, ClassInfo _oClassInfo, MetaView _oMetaView) 获取指定视图指定分类法下的数据集合
MetaViewDatas | ClassInfoViewMgr.queryViewDatas(User user, ClassInfo classInfo, MetaView metaView)

com.trs.components.metadata.definition 中 ClassInfo 的使用

返回 ClassInfo 的 com.trs.components.metadata.definition 中的方法
static ClassInfo | ClassInfo.createNewInstance() 产生当前对象[ClassInfo]的实例
static ClassInfo | ClassInfo.findById(int _nId) 提取指定ID的对象
static ClassInfo | ClassInfo.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static ClassInfo | ClassInfo.findByName(java.lang.String _sClassInfoName) 根据名称获取分类
ClassInfo | ClassInfoCacheMgr.findClassInfoByName(java.lang.String _sClassInfoName) 根据分类法名称获取分类法
ClassInfo | IClassInfoCacheMgr.findClassInfoByName(java.lang.String _sClassInfoName)
ClassInfo | ClassInfoMgr.getClassInfo(java.lang.String path)
ClassInfo | IClassInfoMgr.getClassInfo(java.lang.String _sPath) 根据分类法路径查找到指定的分类法
ClassInfo | ClassInfoMgr.getClassInfo(java.lang.String path, java.lang.String delim)
ClassInfo | IClassInfoMgr.getClassInfo(java.lang.String _sPath, java.lang.String _sDelim) 根据分类法路径查找到指定的分类法
ClassInfo | ClassInfo.getParent()

参数类型为 ClassInfo 的 com.trs.components.metadata.definition 中的方法
void | ClassInfoMgr.deleteClassInfo(User _currUser, ClassInfo _classInfo)
void | IClassInfoMgr.deleteClassInfo(User _currUser, ClassInfo _classInfo) 删除指定的分类
MetaViews | IMetaDataDefMgr.getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo) 查询使用了分类法oClassInfo的所有视图集合
MetaViews | MetaDataDefMgr.getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo)
java.lang.String | ClassInfoMgr.getNamePath(ClassInfo _classInfo) 由指定的分类法得到从根节点到这个分类法节点的id序列
java.lang.String | IClassInfoMgr.getNamePath(ClassInfo _classInfo)
java.lang.String | ClassInfoMgr.getPath(ClassInfo _classInfo) 由指定的分类法得到从根节点到这个分类法节点的id序列
java.lang.String | IClassInfoMgr.getPath(ClassInfo _classInfo)
ClassInfos | ClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
ClassInfos | IClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
java.lang.String | ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列,以逗号分隔
java.lang.String | IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的所有子分类，包括子孙分类Ids
java.lang.String | ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim) 得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列
java.lang.String | IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
java.lang.String | ClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的一级子分类的Ids
java.lang.String | IClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的一级子分类的Ids
java.lang.String | ClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
java.lang.String | IClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)

com.trs.components.metadata.service 中 ClassInfo 的使用

返回 ClassInfo 的 com.trs.components.metadata.service 中的方法
static ClassInfo | UserRelateInfoMaker.makeDefaultClassInfo(java.lang.String _sDeptClassInfoRootName, User _currUser) 构造指定用户对应的机构分类
ClassInfo | ClassInfoServiceProvider.saveClassInfo(MethodContext _context)
ClassInfo | ClassInfoServiceProviderForGB.saveClassInfo(MethodContext _context)
ClassInfo | ClassInfoServiceProvider.saveClassInfo(MethodContext _methodContext, User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode) 这个方法实现不太好，但只是为了兼容wcm6，因为wcm6的实现，字段都是写死的， 不能根据外界传入什么字段，向数据库中保存什么
ClassInfo | ClassInfoServiceProviderForGB.saveClassInfo(User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc) 保存分类法设置
ClassInfo | ClassInfoServiceProvider.saveClassInfo(User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode) 保存分类法设置

参数类型为 ClassInfo 的 com.trs.components.metadata.service 中的方法
static void | ClassInfoToChannelHelper.createChannels(ClassInfo _oParentClassInfo, BaseChannel _host, MetaView _oView, int _nMaxLevel)
void | ClassInfoToGroupCreator.createGroups(ClassInfo _oDeptClassInfoRoot, Group _hostGroup, int _nMaxLevel)
static void | ClassInfoToChannelHelper.createSites(ClassInfo _oParentClassInfo, MetaView _oView, int _nMaxLevel, java.lang.String _sRootDomain)
static WCMFilter | GovInfoToXML.getMetaDatasFilter(ClassInfo _oClassInfo)
int | GovInfoServiceProvider.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
int | MetaDataCenterServiceProviderForGB.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
int | MetaDataCenterServiceProviderForAgri.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.ClassInfoCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.ClassInfoCacheMgr
的使用

没有 com.trs.components.metadata.definition.ClassInfoCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.ClassInfoListenerForViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.ClassInfoListenerForViewData
的使用

没有 com.trs.components.metadata.definition.ClassInfoListenerForViewData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.ClassInfoMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.ClassInfoMgr
的使用

没有 com.trs.components.metadata.definition.ClassInfoMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.ClassInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.ClassInfos
的使用

使用 ClassInfos 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.metadata.service

com.trs.components.metadata.center 中 ClassInfos 的使用

返回 ClassInfos 的 com.trs.components.metadata.center 中的方法
ClassInfos | IClassInfoViewMgr.queryClassInfos(User _currUser, Documents oDocuments, WCMFilter _filter) 根据文档对象集合获取获取分类法信息集合
ClassInfos | ClassInfoViewMgr.queryClassInfos(User user, Documents documents, WCMFilter _filter)
ClassInfos | IClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
ClassInfos | ClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合

参数类型为 ClassInfos 的 com.trs.components.metadata.center 中的方法
void | IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
Documents | IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos _oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
static MetaViewDatas | ClassDocumentsHelper.queryMetaViewDatas(MetaView _view, ClassInfos _classInfos, boolean _bOnlyLeaf, WCMFilter _extraFilter) 获取指定视图中同时属于指定的多个分类（含下面的子分类）的文档 子分类仅仅只叶子节点
MetaViews | IClassInfoViewMgr.queryViews(User _currUser, ClassInfos _oClassInfo, WCMFilter _filter) 根据分类法ID序列返回视图对象集合
MetaViews | ClassInfoViewMgr.queryViews(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象返回相应的视图对象集合

com.trs.components.metadata.definition 中 ClassInfos 的使用

返回 ClassInfos 的 com.trs.components.metadata.definition 中的方法
static ClassInfos | ClassInfos.createNewInstance(User _currUser) 产生当前集合对象[ClassInfos]的实例
static ClassInfos | ClassInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ClassInfos | ClassInfo.findRootClassInfos() 获取所有根节点
static ClassInfos | ClassInfo.findRootClassInfos(boolean _bNotMakeNewObjs)
ClassInfos | ClassInfo.getChildren() 获取当前对象的一级子分类
ClassInfos | ClassInfo.getChildren(boolean _bNotMakeNewObjs)
ClassInfos | ClassInfoCacheMgr.getChildren(int _nParentId) 获取指定分类的所有一级子分类
ClassInfos | IClassInfoCacheMgr.getChildren(int _nParentId)
ClassInfos | ClassInfoCacheMgr.getChildren(int _nParentId, boolean _bNotMakeNewObjs)
ClassInfos | IClassInfoCacheMgr.getChildren(int _nParentId, boolean _bNotMakeNewObjs)
ClassInfos | ClassInfoMgr.getClassInfosByName(int nClassInfoRootId, java.lang.String sClassInfoName) 通过名称获取分类法对象集合
ClassInfos | IClassInfoMgr.getClassInfosByName(int nClassInfoRootId, java.lang.String sClassInfoName) 通过名称获取分类法对象集合
ClassInfos | ClassInfoMgr.getClassInfosByName(java.lang.String sClassInfoName) 通过名称获取分类法对象集合
ClassInfos | IClassInfoMgr.getClassInfosByName(java.lang.String sClassInfoName) 通过名称获取分类法对象集合
ClassInfos | IMetaDataDefMgr.getClassInfosUsingMetaView(User _currUser, MetaView oMetaView) 查询视图oMetaView使用了的所有分类法集合
ClassInfos | MetaDataDefMgr.getClassInfosUsingMetaView(User _currUser, MetaView oMetaView)
static ClassInfos | ClassInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ClassInfos]
ClassInfos | ClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
ClassInfos | IClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)

参数类型为 ClassInfos 的 com.trs.components.metadata.definition 中的方法
java.lang.String | ClassInfoMgr.getNamePath(ClassInfos _classInfos) 由指定的分类法得到从根节点到这个分类法节点的id序列
java.lang.String | IClassInfoMgr.getNamePath(ClassInfos _classInfos)
java.lang.String | ClassInfoMgr.getPath(ClassInfos _classInfos) 由指定的分类法得到从根节点到这个分类法节点的id序列
java.lang.String | IClassInfoMgr.getPath(ClassInfos _classInfos)

com.trs.components.metadata.service 中 ClassInfos 的使用

返回 ClassInfos 的 com.trs.components.metadata.service 中的方法
ClassInfos | ClassInfoViewServiceProvider.queryClassInfos(MethodContext _methodContext) 根据文档的ids，获取在指定分类下的文档所在分类
ClassInfos | ClassInfoServiceProvider.queryClassInfos(MethodContext _methodContext) 获取指定的分类
ClassInfos | ClassInfoServiceProviderForGB.queryClassInfos(MethodContext _methodContext) 获取指定的分类
ClassInfos | ClassInfoServiceProvider.queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)
ClassInfos | ClassInfoServiceProviderForGB.queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)
ClassInfos | ClassInfoViewService.queryClassInfos(User _currUser, java.lang.String _sDocumentIds, WCMFilter _filter) 根据分类法信息返回视图对象集合
ClassInfos | ClassInfoViewServiceProvider.queryClassInfos1(MethodContext _methodContext)
ClassInfos | MetaDataDefServiceProvider.queryClassInfosUsingMetaView(MethodContext _methodContext) 获取系统所有使用了视图或指定视图的分类法树根

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.ClassInfoUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.ClassInfoUtil
的使用

没有 com.trs.components.metadata.definition.ClassInfoUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.definition.IClassInfoCacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.definition.IClassInfoCacheMgr
的使用

使用 IClassInfoCacheMgr 的软件包
com.trs.components.metadata.definition

com.trs.components.metadata.definition 中 IClassInfoCacheMgr 的使用

实现 IClassInfoCacheMgr 的 com.trs.components.metadata.definition 中的类
 class ClassInfoCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
子栏目管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.definition.IClassInfoMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.definition.IClassInfoMgr
的使用

使用 IClassInfoMgr 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.definition

com.trs.components.metadata.center 中 IClassInfoMgr 的使用

返回 IClassInfoMgr 的 com.trs.components.metadata.center 中的方法
 IClassInfoMgr ClassInfoViewMgr.getClassInfoMgr()

com.trs.components.metadata.definition 中 IClassInfoMgr 的使用

实现 IClassInfoMgr 的 com.trs.components.metadata.definition 中的类
 class ClassInfoMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr
的使用

使用 IMetaDataDefCacheMgr 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.definition

com.trs.components.metadata.center 中 IMetaDataDefCacheMgr 的使用

返回 IMetaDataDefCacheMgr 的 com.trs.components.metadata.center 中的方法
 IMetaDataDefCacheMgr ClassInfoViewMgr.getMetaDataDefCacheMgr()

com.trs.components.metadata.definition 中 IMetaDataDefCacheMgr 的使用

实现 IMetaDataDefCacheMgr 的 com.trs.components.metadata.definition 中的类
 class MetaDataDefCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.definition.IMetaDataDefMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.definition.IMetaDataDefMgr
的使用

使用 IMetaDataDefMgr 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.definition

com.trs.components.metadata.center 中 IMetaDataDefMgr 的使用

返回 IMetaDataDefMgr 的 com.trs.components.metadata.center 中的方法
 IMetaDataDefMgr ClassInfoViewMgr.getMetaDataDefMgr()

com.trs.components.metadata.definition 中 IMetaDataDefMgr 的使用

实现 IMetaDataDefMgr 的 com.trs.components.metadata.definition 中的类
 class MetaDataDefMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDataDefCacheMgr
的使用

没有 com.trs.components.metadata.definition.MetaDataDefCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDataDefHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDataDefHelper
的使用

没有 com.trs.components.metadata.definition.MetaDataDefHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDataDefMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDataDefMgr
的使用

没有 com.trs.components.metadata.definition.MetaDataDefMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDataType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDataType
的使用

使用 MetaDataType 的软件包
com.trs.components.metadata.definition

com.trs.components.metadata.definition 中 MetaDataType 的使用

返回 MetaDataType 的 com.trs.components.metadata.definition 中的方法
MetaDataType | MetaDataTypes.getDataTypeAt(int _nIndex)
MetaDataType | MetaDataTypes.getDataTypeById(int _nTypeId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDataTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDataTypes
的使用

使用 MetaDataTypes 的软件包
com.trs.components.metadata

com.trs.components.metadata 中 MetaDataTypes 的使用

声明为 MetaDataTypes 的 com.trs.components.metadata 中的字段
static MetaDataTypes | MetaDataConstants.DATA_TYPES
static MetaDataTypes | MetaDataConstants.DB_DATA_TYPES
static MetaDataTypes | MetaDataConstants.DEFAULT_FIELDS

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDBField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDBField
的使用

使用 MetaDBField 的软件包
com.trs.components.metadata.definition
com.trs.components.metadata.service

com.trs.components.metadata.definition 中 MetaDBField 的使用

返回 MetaDBField 的 com.trs.components.metadata.definition 中的方法
static MetaDBField | MetaDBField.createNewInstance() 产生当前对象[DBFieldInfo]的实例
static MetaDBField | MetaDBField.findById(int _nId) 提取指定ID的对象
static MetaDBField | MetaDBField.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
MetaDBField | MetaViewField.getDBField()
MetaDBField | IMetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo) 在指定表上，新增或者修改指定字段信息
MetaDBField | MetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo)

参数类型为 MetaDBField 的 com.trs.components.metadata.definition 中的方法
void | IMetaDataDefMgr.delete(User _currUser, MetaDBField _oDBFieldInfo) 删除指定字段
void | MetaDataDefMgr.delete(User _currUser, MetaDBField _oDBFieldInfo)
MetaViews | IMetaDataDefMgr.getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo) 获取使用了物理字段_oDBFieldInfo的所有视图
MetaViews | MetaDataDefMgr.getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo)
void | MetaViewField.inheritDBFieldInfo(MetaDBField _dbField) 设置物理字段的信息
MetaDBField | IMetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo) 在指定表上，新增或者修改指定字段信息
MetaDBField | MetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo)

com.trs.components.metadata.service 中 MetaDBField 的使用

返回 MetaDBField 的 com.trs.components.metadata.service 中的方法
MetaDBField | MetaDataDefServiceProvider.findDBFieldInfoById(MethodContext _methodContext) 根据ID获取元数据对象
MetaDBField | MetaDataDefServiceProvider.saveDBFieldInfo(MethodContext _methodContext) 保存元数据字段信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDBFieldListenerForChannelSynRule 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDBFieldListenerForChannelSynRule
的使用

没有 com.trs.components.metadata.definition.MetaDBFieldListenerForChannelSynRule 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDBFields 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDBFields
的使用

使用 MetaDBFields 的软件包
com.trs.components.metadata.definition
com.trs.components.metadata.service

com.trs.components.metadata.definition 中 MetaDBFields 的使用

返回 MetaDBFields 的 com.trs.components.metadata.definition 中的方法
static MetaDBFields | MetaDBFields.createNewInstance(User _currUser) 产生当前集合对象[DBFieldInfos]的实例
static MetaDBFields | MetaDBFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
MetaDBFields | IMetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter) 获取指定表的指定字段列表
MetaDBFields | MetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter)
static MetaDBFields | MetaDBFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DBFieldInfos]

参数类型为 MetaDBFields 的 com.trs.components.metadata.definition 中的方法
void | IMetaDataDefMgr.setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields) 设置
void | MetaDataDefMgr.setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields)

com.trs.components.metadata.service 中 MetaDBFields 的使用

返回 MetaDBFields 的 com.trs.components.metadata.service 中的方法
 MetaDBFields MetaDataDefServiceProvider.queryDBFieldInfos(MethodContext _methodContext)
查询指定表的字段集合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDBTable 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDBTable
的使用

使用 MetaDBTable 的软件包
com.trs.components.metadata.definition
com.trs.components.metadata.right
com.trs.components.metadata.service

com.trs.components.metadata.definition 中 MetaDBTable 的使用

返回 MetaDBTable 的 com.trs.components.metadata.definition 中的方法
static MetaDBTable | MetaDBTable.createNewInstance() 产生当前对象[TableInfo]的实例
static MetaDBTable | MetaDBTable.findById(int _nId) 提取指定ID的对象
static MetaDBTable | MetaDBTable.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
MetaDBTable | MetaView.getMainDBTableInfo()
MetaDBTable | MetaView.getMainTable()
MetaDBTable | MetaDBField.getMetaDBTable()
MetaDBTable | IMetaDataDefMgr.save(User _currUser, MetaDBTable _oTableInfo) 新增或者修改系统表
MetaDBTable | MetaDataDefMgr.save(User _currUser, MetaDBTable _oTableInfo)

参数类型为 MetaDBTable 的 com.trs.components.metadata.definition 中的方法
void | IMetaDataDefMgr.appendDefaultFields(User _curruser, MetaDBTable _oTable) 给自定的表追加默认的字段
void | MetaDataDefMgr.appendDefaultFields(User _currUser, MetaDBTable _oTable)
java.lang.String | IMetaDataDefMgr.createDDLSQL(MetaDBTable _oTableInfo) 产生指定表的定义SQL
java.lang.String | MetaDataDefMgr.createDDLSQL(MetaDBTable _oTableInfo)
void | IMetaDataDefMgr.delete(User _currUser, MetaDBTable _oTableInfo) 删除指定表
void | MetaDataDefMgr.delete(User _currUser, MetaDBTable _oTableInfo) 删除元数据的操作步骤如下： 删除元数据物理字段； 删除元数据对应物理表里的数据； 删除元数据物理表； 删除元数据； 删除所有以此元数据作为主表的视图； 获取所有以此元数据作为附表的视图； 删除附表视图和此元数据的关系； 删除附表视图中此元数据的字段； 如果此视图由多表变成单表，则删除此物理视图，并修改视图的viewName 重新生成视图；
MetaDBFields | IMetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter) 获取指定表的指定字段列表
MetaDBFields | MetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter)
MetaViews | IMetaDataDefMgr.getViewsContainsTable(MetaDBTable _oTable) 获取使用指定表作为附表的视图
MetaViews | MetaDataDefMgr.getViewsContainsTable(MetaDBTable _oTable)
MetaViews | IMetaDataDefMgr.getViewsUsingTable(MetaDBTable _oTable) 获取正在使用指定表的视图
MetaViews | MetaDataDefMgr.getViewsUsingTable(MetaDBTable _oTable)
MetaDBTable | IMetaDataDefMgr.save(User _currUser, MetaDBTable _oTableInfo) 新增或者修改系统表
MetaDBTable | MetaDataDefMgr.save(User _currUser, MetaDBTable _oTableInfo)
MetaDBField | IMetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo) 在指定表上，新增或者修改指定字段信息
MetaDBField | MetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo)
boolean | MetaView.setMainTable(MetaDBTable _dbTableInfo)

com.trs.components.metadata.right 中 MetaDBTable 的使用

参数类型为 MetaDBTable 的 com.trs.components.metadata.right 中的方法
static boolean AuthServerMgr.hasRight(User _loginUser, MetaDBTable _oDBTable)

com.trs.components.metadata.service 中 MetaDBTable 的使用

返回 MetaDBTable 的 com.trs.components.metadata.service 中的方法
MetaDBTable | MetaDataDefServiceProvider.findDBTableInfoById(MethodContext _methodContext) 根据ID获取元数据结构对象
MetaDBTable | MetaDataDefServiceProvider.saveDBTableInfo(MethodContext _methodContext) 保存元数据表的信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaDBTables 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaDBTables
的使用

使用 MetaDBTables 的软件包
com.trs.components.metadata.definition
com.trs.components.metadata.service

com.trs.components.metadata.definition 中 MetaDBTables 的使用

返回 MetaDBTables 的 com.trs.components.metadata.definition 中的方法
static MetaDBTables | MetaDBTables.createNewInstance(User _currUser) 产生当前集合对象[TableInfos]的实例
static MetaDBTables | MetaDBTables.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
MetaDBTables | MetaView.getOtherTables(User _currUser, WCMFilter _extraFilter)
static MetaDBTables | MetaDBTables.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TableInfos]

参数类型为 MetaDBTables 的 com.trs.components.metadata.definition 中的方法
void | IMetaDataDefMgr.recreateAll(User _currUser, MetaDBTables _oMetaDBTables) 重新产生所有的表结构和相关视图的应用
void | MetaDataDefMgr.recreateAll(User _currUser, MetaDBTables _oMetaDBTables)

com.trs.components.metadata.service 中 MetaDBTables 的使用

返回 MetaDBTables 的 com.trs.components.metadata.service 中的方法
MetaDBTables | MetaDataDefServiceProvider.findDBTableInfosByIds(MethodContext _methodContext) 根据ID序列获取元数据集合
MetaDBTables | MetaDataDefServiceProvider.queryDBTableInfos(MethodContext _oMethodContext)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaView
的使用

使用 MetaView 的软件包
com.trs.components.govinfo
com.trs.components.metadata.center
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition
com.trs.components.metadata.right
com.trs.components.metadata.service

com.trs.components.govinfo 中 MetaView 的使用

返回 MetaView 的 com.trs.components.govinfo 中的方法
static MetaView | GovInfoViewFinder.findMetaViewOfChildGovInfo(User _loginUser)
static MetaView | GovInfoViewFinder.findMetaViewOfGovInfo(User _loginUser)

参数类型为 MetaView 的 com.trs.components.govinfo 中的方法
static boolean GovInfoViewFinder.isGovInfoView(MetaView oMetaView)

com.trs.components.metadata.center 中 MetaView 的使用

返回 MetaView 的 com.trs.components.metadata.center 中的方法
MetaView | MetaViewData.getMetaView()
MetaView | MetaViewDatas.getMetaView()
MetaView | MetaViewEmployerMgr.getViewOfEmployer(Channel _channel)
MetaView | IMetaViewEmployerMgr.getViewOfEmployer(Channel _channel) 获取指定栏目配置的视图

参数类型为 MetaView 的 com.trs.components.metadata.center 中的方法
void | MetaViewEmployerMgr.clearEmployer(User _currUser, MetaView _view)
void | IMetaViewEmployerMgr.clearEmployer(User _currUser, MetaView _view) 清除指定视图所配置的使用关系
static MetaViewDatas | MetaViewDatas.findByIds(MetaView _view, java.lang.String _sIds)
Channels | MetaViewEmployerMgr.getEmployers(MetaView _view, WCMFilter _extraFilter)
Channels | IMetaViewEmployerMgr.getEmployers(MetaView _view, WCMFilter _extraFilter) 获取使用了指定视图的所有栏目
static MetaViewDatas | MetaViewDatas.openWCMObjs(MetaView oMetaView, WCMFilter _filter)
static MetaViewDatas | ClassDocumentsHelper.queryMetaViewDatas(MetaView _view, ClassInfos _classInfos, boolean _bOnlyLeaf, WCMFilter _extraFilter) 获取指定视图中同时属于指定的多个分类（含下面的子分类）的文档 子分类仅仅只叶子节点
MetaViewDatas | IClassInfoViewMgr.queryViewDatas(User user, ClassInfo _oClassInfo, MetaView _oMetaView) 获取指定视图指定分类法下的数据集合
MetaViewDatas | ClassInfoViewMgr.queryViewDatas(User user, ClassInfo classInfo, MetaView metaView)
void | IDocumentFieldsSyn.resetDocumentProperties(MetaView oMetaView) 给所有视图数据对象设置关联的document对象的值
void | MetaViewEmployerMgr.setEmployer(User _currUser, Channel _channel, MetaView _view)
void | IMetaViewEmployerMgr.setEmployer(User _currUser, Channel _channel, MetaView _view) 给指定的栏目配置指定的视图
void | MetaViewData.setMetaView(MetaView metaView)
void | MetaViewDatas.setMetaView(MetaView oMetaView)
void | MetaViewData.setView(MetaView _view) 设置当前对象相关的视图

参数类型为 MetaView 的 com.trs.components.metadata.center 中的构造方法
MetaViewData(MetaView _view)
MetaViewData(MetaView _view, java.util.HashMap _hPublicCache)
MetaViewDatas(MetaView _view)

com.trs.components.metadata.center.xml 中 MetaView 的使用

参数类型为 MetaView 的 com.trs.components.metadata.center.xml 中的构造方法
MetaViewDataExporter(MetaView _view)
MetaViewDataImporter(User _currUser, MetaView _dstView, Channel _dstChannel)
MetaViewDataToExcel(MetaView _view)
MetaViewDataToXML(MetaView _view)

com.trs.components.metadata.definition 中 MetaView 的使用

返回 MetaView 的 com.trs.components.metadata.definition 中的方法
static MetaView | MetaView.createNewInstance() 产生当前对象[ViewInfo]的实例
static MetaView | MetaView.findById(int _nId) 提取指定ID的对象
static MetaView | MetaView.findByIdentity(java.lang.String sIdentityName, java.lang.String sIdentityValue) 根据唯一标识属性，获取第一个视图对象，由于视图名称和视图描述是唯一的，所以一般情况下可以作为sIdentityName
static MetaView | MetaView.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
MetaView | IMetaDataDefMgr.save(User _currUser, MetaView _oViewInfo) 新增或修改视图信息
MetaView | MetaDataDefMgr.save(User _currUser, MetaView _oViewInfo)

参数类型为 MetaView 的 com.trs.components.metadata.definition 中的方法
void | MetaDataDefMgr.clearTitleField(MetaView oView) 清除视图oView下的标题字段,即原来是标题字段的，将不再作为标题字段
java.lang.String | IMetaDataDefMgr.createDDLSQL(MetaView _oViewInfo) 产生指定视图的定义SQL
java.lang.String | MetaDataDefMgr.createDDLSQL(MetaView _oViewInfo)
boolean | IMetaDataDefMgr.createViewApplication(MetaView _oView, java.lang.String _sTemplatePath, java.lang.String _sApplicationPath) 视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8
boolean | MetaDataDefMgr.createViewApplication(MetaView _oView, java.lang.String _sTemplatePath, java.lang.String _sApplicationPath) 视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8
java.lang.String | IMetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView) 视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
java.lang.String | MetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView)
java.lang.String | IMetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView, boolean generateApplication) 视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
java.lang.String | MetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView, boolean generateApplication)
void | IMetaDataDefMgr.delete(User _currUser, MetaView _oViewInfo) 删除指定表
void | MetaDataDefMgr.delete(User _currUser, MetaView _oView)
ClassInfos | IMetaDataDefMgr.getClassInfosUsingMetaView(User _currUser, MetaView oMetaView) 查询视图oMetaView使用了的所有分类法集合
ClassInfos | MetaDataDefMgr.getClassInfosUsingMetaView(User _currUser, MetaView oMetaView)
MetaViewField | IMetaDataDefMgr.getMetaViewField(MetaView _oView, int _iDbFieldId)
MetaViewField | MetaDataDefMgr.getMetaViewField(MetaView _oView, int _nDbFieldId)
MetaViewFields | IMetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViewFields | MetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaView | IMetaDataDefMgr.save(User _currUser, MetaView _oViewInfo) 新增或修改视图信息
MetaView | MetaDataDefMgr.save(User _currUser, MetaView _oViewInfo)
MetaViewField | IMetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo) 在指定视图上，新增或者修改指定字段信息
MetaViewField | MetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo)
void | IMetaDataDefMgr.setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields) 设置
void | MetaDataDefMgr.setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields)

com.trs.components.metadata.right 中 MetaView 的使用

参数类型为 MetaView 的 com.trs.components.metadata.right 中的方法
static boolean AuthServerMgr.hasRight(User _loginUser, MetaView _view)

com.trs.components.metadata.service 中 MetaView 的使用

返回 MetaView 的 com.trs.components.metadata.service 中的方法
MetaView | MetaDataDefServiceProvider.findViewByChannel(MethodContext _methodContext)
MetaView | MetaDataDefServiceProvider.findViewById(MethodContext _methodContext) 根据ID获取视图信息对象
MetaView | MetaDataDefServiceProvider.getViewFromChannel(MethodContext _methodContext)
MetaView | MetaViewImporter.importFromXML(java.lang.String _sXML) 从一个XML中导入视图的定义
MetaView | MetaDataDefServiceProvider.importViewFromXML(MethodContext _methodContext) 从XML文件创建视图
MetaView | MetaDataDefServiceProvider.saveView(MethodContext _methodContext) 保存指定的视图信息

参数类型为 MetaView 的 com.trs.components.metadata.service 中的方法
static void | ClassInfoToChannelHelper.createChannels(ClassInfo _oParentClassInfo, BaseChannel _host, MetaView _oView, int _nMaxLevel)
static void | ClassInfoToChannelHelper.createSites(ClassInfo _oParentClassInfo, MetaView _oView, int _nMaxLevel, java.lang.String _sRootDomain)
int | GovInfoServiceProvider.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
int | MetaDataCenterServiceProviderForGB.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
int | MetaDataCenterServiceProviderForAgri.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)

参数类型为 MetaView 的 com.trs.components.metadata.service 中的构造方法
MetaViewImporter(User _currUser, MetaView _view)
SynChildrenExecutorForViewEmploy(BaseChannel _oStartObj, MetaView _view, boolean _bClearEmploy)
SynChildrenExecutorForViewEmploy(BaseChannel _oStartObj, MetaView _view, boolean _bClearEmploy, boolean _bDoOnStartObj)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaViewField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaViewField
的使用

使用 MetaViewField 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.metadata.service
com.trs.components.metadata.web

com.trs.components.metadata.center 中 MetaViewField 的使用

参数类型为 MetaViewField 的 com.trs.components.metadata.center 中的方法
void | IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser) 将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos
void | ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos destClassInfos, User currUser)
void | IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)
void | IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser) 将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
void | IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser) 将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
void | ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)

com.trs.components.metadata.definition 中 MetaViewField 的使用

返回 MetaViewField 的 com.trs.components.metadata.definition 中的方法
static MetaViewField | MetaViewField.createNewInstance() 产生当前对象[ViewFieldInfo]的实例
static MetaViewField | MetaViewField.findById(int _nId) 提取指定ID的对象
static MetaViewField | MetaViewField.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
MetaViewField | MetaDataDefCacheMgr.getMetaViewField(int _nViewId, java.lang.String _sViewFieldName)
MetaViewField | IMetaDataDefCacheMgr.getMetaViewField(int _nViewId, java.lang.String _sViewFieldName)
MetaViewField | IMetaDataDefMgr.getMetaViewField(MetaView _oView, int _iDbFieldId)
MetaViewField | MetaDataDefMgr.getMetaViewField(MetaView _oView, int _nDbFieldId)
MetaViewField | MetaView.getTitleField() 返回视图的标题字段
MetaViewField | IMetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo) 在指定视图上，新增或者修改指定字段信息
MetaViewField | MetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo)

参数类型为 MetaViewField 的 com.trs.components.metadata.definition 中的方法
void | IMetaDataDefMgr.delete(User _currUser, MetaViewField _oViewField) 删除指定视图字段
void | MetaDataDefMgr.delete(User _currUser, MetaViewField _oViewField)
boolean | MetaDataDefCacheMgr.isEditorField(MetaViewField _oViewField)
boolean | IMetaDataDefCacheMgr.isEditorField(MetaViewField oViewField) 判断是否为编辑器字段
void | MetaDataDefMgr.resetTitleField(MetaViewField oMetaViewField) 根据oMetaViewField的TitleField状态决定是否重置该视图下的标题字段 如果是新建一个标题字段，则需要清除原来的标题字段； 如果是修改一个字段,并且它的TitleField属性由0变成1，即由非标题字段变成标题字段， 则也需求清除原来的标题字段
MetaViewField | IMetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo) 在指定视图上，新增或者修改指定字段信息
MetaViewField | MetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo)

com.trs.components.metadata.service 中 MetaViewField 的使用

返回 MetaViewField 的 com.trs.components.metadata.service 中的方法
MetaViewField | MetaDataDefServiceProvider.findViewFieldById(MethodContext _methodContext)
MetaViewField | MetaDataDefServiceProvider.saveViewField(MethodContext _methodContext) 保存视图字段信息

com.trs.components.metadata.web 中 MetaViewField 的使用

返回 MetaViewField 的 com.trs.components.metadata.web 中的方法
MetaViewField | HTMLMaker.getViewField() 获取当前HTMLMaker关联的MetaViewField对象
MetaViewField | AbsHTMLMaker.getViewField()

参数类型为 MetaViewField 的 com.trs.components.metadata.web 中的方法
java.lang.String | FieldTemplate.getTemplateContent(MetaViewField oViewField) 获取该视图字段对应的模板内容
void | HTMLMaker.setViewField(MetaViewField oViewField) 设置当前HTMLMaker关联的MetaViewField对象
void | AbsHTMLMaker.setViewField(MetaViewField _oViewField)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaViewFields 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaViewFields
的使用

使用 MetaViewFields 的软件包
com.trs.components.metadata.definition
com.trs.components.metadata.service

com.trs.components.metadata.definition 中 MetaViewFields 的使用

返回 MetaViewFields 的 com.trs.components.metadata.definition 中的方法
static MetaViewFields | MetaViewFields.createNewInstance(User _currUser) 产生当前集合对象[ViewFieldInfos]的实例
static MetaViewFields | MetaViewFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
MetaViewFields | IMetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViewFields | MetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViewFields | MetaView.getViewFields(User _currUser, WCMFilter _extraFilter)
static MetaViewFields | MetaViewFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ViewFieldInfos]

com.trs.components.metadata.service 中 MetaViewFields 的使用

返回 MetaViewFields 的 com.trs.components.metadata.service 中的方法
 MetaViewFields MetaDataDefServiceProvider.queryViewFieldInfos(MethodContext _methodContext)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.MetaViews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.MetaViews
的使用

使用 MetaViews 的软件包
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.metadata.definition.xml
com.trs.components.metadata.service

com.trs.components.metadata.center 中 MetaViews 的使用

返回 MetaViews 的 com.trs.components.metadata.center 中的方法
static MetaViews | MetaViewHelper.findViews(User _currUser)
MetaViews | IClassInfoViewMgr.queryViews(User _currUser, ClassInfos _oClassInfo, WCMFilter _filter) 根据分类法ID序列返回视图对象集合
MetaViews | ClassInfoViewMgr.queryViews(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象返回相应的视图对象集合

com.trs.components.metadata.definition 中 MetaViews 的使用

返回 MetaViews 的 com.trs.components.metadata.definition 中的方法
static MetaViews | MetaViews.createNewInstance(User _currUser) 产生当前集合对象[ViewInfos]的实例
static MetaViews | MetaViews.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
MetaViews | IMetaDataDefMgr.getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo) 查询使用了分类法oClassInfo的所有视图集合
MetaViews | MetaDataDefMgr.getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo)
MetaViews | IMetaDataDefMgr.getViewsContainsTable(MetaDBTable _oTable) 获取使用指定表作为附表的视图
MetaViews | MetaDataDefMgr.getViewsContainsTable(MetaDBTable _oTable)
MetaViews | IMetaDataDefMgr.getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo) 获取使用了物理字段_oDBFieldInfo的所有视图
MetaViews | MetaDataDefMgr.getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo)
MetaViews | IMetaDataDefMgr.getViewsUsingTable(MetaDBTable _oTable) 获取正在使用指定表的视图
MetaViews | MetaDataDefMgr.getViewsUsingTable(MetaDBTable _oTable)
static MetaViews | MetaViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ViewInfos]

com.trs.components.metadata.definition.xml 中 MetaViews 的使用

参数类型为 MetaViews 的 com.trs.components.metadata.definition.xml 中的方法
java.lang.String | MetaViewExporter.export(MetaViews _views) 导出指定的视图
java.lang.String | MetaViewExporter.export(MetaViews _views, java.lang.String _sFileName) 导出指定的视图

参数类型为 MetaViews 的 com.trs.components.metadata.definition.xml 中的构造方法
MetaTableXMLConvertor(MetaViews _oExportViews)

com.trs.components.metadata.service 中 MetaViews 的使用

返回 MetaViews 的 com.trs.components.metadata.service 中的方法
MetaViews | ClassInfoViewServiceProvider.queryViews(MethodContext _methodContext) 根据分类法信息获取视图信息
MetaViews | MetaDataDefServiceProvider.queryViews(MethodContext _methodContext) 获取系统所有视图
MetaViews | ClassInfoViewService.queryViews(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter) 根据分类法信息返回视图对象集合
MetaViews | ClassInfoViewService.queryViews(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo) 根据分类法信息返回视图对象集合
MetaViews | ClassInfoViewServiceProvider.queryViewsByClassInfo(MethodContext _methodContext) 获取使用了指定分类法的视图信息,如果分类法ID为0，则表示获取使用了分类法字段的所有视图
MetaViews | MetaDataDefServiceProvider.queryViewsUsingClassInfo(MethodContext _methodContext) 获取系统所有使用了分类法字段或指定分类法字段视图
MetaViews | MetaDataDefServiceProvider.queryViewsUsintTable(MethodContext _methodContext) 获取正在使用指定表的视图列表

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ClassInfoImporter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 ClassInfoImporter

java.lang.Object
    继承者  com.trs.components.metadata.definition.xml.ClassInfoImporter

public class ClassInfoImporter
extends java.lang.Object

作者：
Administrator

构造方法摘要
ClassInfoImporter(User _currUser)
方法摘要
Reports | getReports()
void | importFromXML(java.lang.String _sXMLFile, int _nImportType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoImporter

public ClassInfoImporter(User _currUser)
方法详细信息

getReports

public Reports getReports()

importFromXML

public void importFromXML(java.lang.String _sXMLFile,
                          int _nImportType)
                   throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ClassInfoXMLConvertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 ClassInfoXMLConvertor

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.metadata.definition.xml.ClassInfoXMLConvertor

public class ClassInfoXMLConvertor
extends BaseObjToXmlConverter

作者：
Administrator

构造方法摘要
ClassInfoXMLConvertor()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoXMLConvertor

public ClassInfoXMLConvertor()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataDDLImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 MetaDataDDLImporter

java.lang.Object
    继承者  com.trs.components.metadata.definition.xml.MetaDataDDLImporter

public class MetaDataDDLImporter
extends java.lang.Object

作者：
Administrator

构造方法摘要
MetaDataDDLImporter(User _currUser)
方法摘要
 void importFromXML(java.lang.String _sXMLFile, int _nImportType, Reports _oReports)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataDDLImporter

public MetaDataDDLImporter(User _currUser)
方法详细信息

importFromXML

public void importFromXML(java.lang.String _sXMLFile,
                          int _nImportType,
                          Reports _oReports)
                   throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDBFieldXMLConvertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 MetaDBFieldXMLConvertor

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
            继承者  com.trs.components.metadata.definition.xml.MetaDBFieldXMLConvertor

public class MetaDBFieldXMLConvertor
extends BaseObjToXmlConverterForSpecialProperty

作者：
Administrator

构造方法摘要
MetaDBFieldXMLConvertor()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDBFieldXMLConvertor

public MetaDBFieldXMLConvertor()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaTableXMLConvertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 MetaTableXMLConvertor

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.metadata.definition.xml.MetaTableXMLConvertor

public class MetaTableXMLConvertor
extends BaseObjToXmlConverter

作者：
Administrator

构造方法摘要
MetaTableXMLConvertor(MetaViews _oExportViews)
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaTableXMLConvertor

public MetaTableXMLConvertor(MetaViews _oExportViews)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewExporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 MetaViewExporter

java.lang.Object
    继承者  com.trs.components.metadata.definition.xml.MetaViewExporter

public class MetaViewExporter
extends java.lang.Object

作者：
Administrator

构造方法摘要
MetaViewExporter()
方法摘要
java.lang.String | export(MetaViews _views) 导出指定的视图
java.lang.String | export(MetaViews _views, java.lang.String _sFileName) 导出指定的视图
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewExporter

public MetaViewExporter()
方法详细信息

export

public java.lang.String export(MetaViews _views)
                        throws WCMException
导出指定的视图

参数：
_views -
返回：
符合WCM存放文件规则的文件名
抛出：
WCMException

export

public java.lang.String export(MetaViews _views,
                               java.lang.String _sFileName)
                        throws WCMException
导出指定的视图

参数：
_views -
_sFileName -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewFieldXMLConvertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 MetaViewFieldXMLConvertor

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
            继承者  com.trs.components.metadata.definition.xml.MetaViewFieldXMLConvertor

public class MetaViewFieldXMLConvertor
extends BaseObjToXmlConverterForSpecialProperty

作者：
Administrator

构造方法摘要
MetaViewFieldXMLConvertor()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewFieldXMLConvertor

public MetaViewFieldXMLConvertor()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewXMLConvertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 MetaViewXMLConvertor

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.metadata.definition.xml.MetaViewXMLConvertor

public class MetaViewXMLConvertor
extends BaseObjToXmlConverter

作者：
Administrator

构造方法摘要
MetaViewXMLConvertor()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewXMLConvertor

public MetaViewXMLConvertor()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.definition.xml
类
ClassInfoImporter
ClassInfoXMLConvertor
MetaDataDDLImporter
MetaDBFieldXMLConvertor
MetaTableXMLConvertor
MetaViewExporter
MetaViewFieldXMLConvertor
MetaViewXMLConvertor
XMLToMetaDBTablesConvertor


com.trs.components.metadata.definition.xml

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.definition.xml

类摘要
ClassInfoImporter
ClassInfoXMLConvertor
MetaDataDDLImporter
MetaDBFieldXMLConvertor
MetaTableXMLConvertor
MetaViewExporter
MetaViewFieldXMLConvertor
MetaViewXMLConvertor
XMLToMetaDBTablesConvertor


com.trs.components.metadata.definition.xml 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.definition.xml 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.AbstractXmlToObjConverter
      • com.trs.components.metadata.definition.xml.XMLToMetaDBTablesConvertor
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
        • com.trs.components.metadata.definition.xml.MetaDBFieldXMLConvertor
        • com.trs.components.metadata.definition.xml.MetaViewFieldXMLConvertor
      • com.trs.components.metadata.definition.xml.ClassInfoXMLConvertor
      • com.trs.components.metadata.definition.xml.MetaTableXMLConvertor
      • com.trs.components.metadata.definition.xml.MetaViewXMLConvertor
    • com.trs.components.metadata.definition.xml.ClassInfoImporter
    • com.trs.components.metadata.definition.xml.MetaDataDDLImporter
    • com.trs.components.metadata.definition.xml.MetaViewExporter


软件包 com.trs.components.metadata.definition.xml 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.definition.xml
的使用

没有 com.trs.components.metadata.definition.xml 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


XMLToMetaDBTablesConvertor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.definition.xml
类 XMLToMetaDBTablesConvertor

java.lang.Object
    继承者  com.trs.infra.persistent.AbstractXmlToObjConverter
        继承者  com.trs.components.metadata.definition.xml.XMLToMetaDBTablesConvertor

public class XMLToMetaDBTablesConvertor
extends AbstractXmlToObjConverter

作者：
Administrator

构造方法摘要
XMLToMetaDBTablesConvertor(int _nImportType)
方法摘要
从类 com.trs.infra.persistent.AbstractXmlToObjConverter 继承的方法
convertXml, getXmlEncoding, registPersistentObj, setXmlEncoding
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLToMetaDBTablesConvertor

public XMLToMetaDBTablesConvertor(int _nImportType)
参数：
_nImportType -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.metadata.definition.xml.ClassInfoImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.ClassInfoImporter
的使用

没有 com.trs.components.metadata.definition.xml.ClassInfoImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.xml.ClassInfoXMLConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.ClassInfoXMLConvertor
的使用

没有 com.trs.components.metadata.definition.xml.ClassInfoXMLConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.xml.MetaDataDDLImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.MetaDataDDLImporter
的使用

没有 com.trs.components.metadata.definition.xml.MetaDataDDLImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.xml.MetaDBFieldXMLConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.MetaDBFieldXMLConvertor
的使用

没有 com.trs.components.metadata.definition.xml.MetaDBFieldXMLConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.xml.MetaTableXMLConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.MetaTableXMLConvertor
的使用

没有 com.trs.components.metadata.definition.xml.MetaTableXMLConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.xml.MetaViewExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.MetaViewExporter
的使用

没有 com.trs.components.metadata.definition.xml.MetaViewExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.xml.MetaViewFieldXMLConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.MetaViewFieldXMLConvertor
的使用

没有 com.trs.components.metadata.definition.xml.MetaViewFieldXMLConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.xml.MetaViewXMLConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.MetaViewXMLConvertor
的使用

没有 com.trs.components.metadata.definition.xml.MetaViewXMLConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.definition.xml.XMLToMetaDBTablesConvertor 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.definition.xml.XMLToMetaDBTablesConvertor
的使用

没有 com.trs.components.metadata.definition.xml.XMLToMetaDBTablesConvertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ClassInfoCountCacheForPublishImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 ClassInfoCountCacheForPublishImpl

java.lang.Object
    继承者  com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl
所有已实现的接口：
IClassInfoCountCacheForPublish
public class ClassInfoCountCacheForPublishImpl
extends java.lang.Object
implements IClassInfoCountCacheForPublish

作者：
曹辉

构造方法摘要
ClassInfoCountCacheForPublishImpl()
方法摘要
int | getClassInfoDataCountOfChannel(int _nChannelId, int _nClassInfoId)
int | getClassInfoDataCountOfSite(int _nSiteId, int _nClassInfoId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoCountCacheForPublishImpl

public ClassInfoCountCacheForPublishImpl()
方法详细信息

getClassInfoDataCountOfChannel

public int getClassInfoDataCountOfChannel(int _nChannelId,
                                          int _nClassInfoId)
                                   throws WCMException
指定者：
接口 IClassInfoCountCacheForPublish 中的 getClassInfoDataCountOfChannel
返回：
抛出：
WCMException

getClassInfoDataCountOfSite

public int getClassInfoDataCountOfSite(int _nSiteId,
                                       int _nClassInfoId)
                                throws WCMException
指定者：
接口 IClassInfoCountCacheForPublish 中的 getClassInfoDataCountOfSite
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IClassInfoCountCacheForPublish

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
接口 IClassInfoCountCacheForPublish

所有已知实现类：
ClassInfoCountCacheForPublishImpl
public interface IClassInfoCountCacheForPublish

作者：
曹辉

方法摘要
int | getClassInfoDataCountOfChannel(int _nChannelId, int _nClassInfoId)
int | getClassInfoDataCountOfSite(int _nSiteId, int _nClassInfoId)

方法详细信息

getClassInfoDataCountOfSite

int getClassInfoDataCountOfSite(int _nSiteId,
                                int _nClassInfoId)
                                throws WCMException
参数：
_nSiteId -
_nClassInfoId -
_bInitAllClassInfo -
返回：
抛出：
WCMException

getClassInfoDataCountOfChannel

int getClassInfoDataCountOfChannel(int _nChannelId,
                                   int _nClassInfoId)
                                   throws WCMException
参数：
_nChannelId -
_nClassInfoId -
_bInitAllClassInfo -
_bInitAllChannelOfSite -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewDataRelateSource

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 MetaViewDataRelateSource

java.lang.Object
    继承者  com.trs.components.metadata.publish.MetaViewDataRelateSource
所有已实现的接口：
IRelateResource
public class MetaViewDataRelateSource
extends java.lang.Object
implements IRelateResource

Title: TRS 内容协作平台（TRS WCM）
Description:
获取相关文件
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
MetaViewDataRelateSource()
方法摘要
 java.util.List getResourceNames(IPublishContent content)
获取当前IPublishContent对象的相关文件(如正文中的图片等)
注意:实现时,即使没有相关的文件,也不能返回null.在没有相关文件的情况下,返回空集
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewDataRelateSource

public MetaViewDataRelateSource()
方法详细信息

getResourceNames

public java.util.List getResourceNames(IPublishContent content)
                                throws WCMException
从接口 IRelateResource 复制的描述
获取当前IPublishContent对象的相关文件(如正文中的图片等)
注意:实现时,即使没有相关的文件,也不能返回null.在没有相关文件的情况下,返回空集

指定者：
接口 IRelateResource 中的 getResourceNames
返回：
返回文件名集合,文件名可以是全路径,也可以是WCMData管理的文件名集.
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.publish
接口
IClassInfoCountCacheForPublish
类
ClassInfoCountCacheForPublishImpl
MetaViewDataRelateSource
PublishContentViewDataImpl
PublishContentViewFieldImpl
PublishContentViewImpl
PublishFolderClassImpl
WCMTagParserAppendix
WCMTagParserClassDocuments
WCMTagParserClassIndexGener
WCMTagParserClassInfo
WCMTagParserClassInfos
WCMTagParserExistDataOfClassInfo
WCMTagParserMyViewDatas
WCMTagParserRelNewsForViewData
WCMTagParserViewData
WCMTagParserViewDatas
WCMTagParserViewField
WCMTagParserViewFields


com.trs.components.metadata.publish

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.publish

接口摘要
IClassInfoCountCacheForPublish

类摘要
ClassInfoCountCacheForPublishImpl |
MetaViewDataRelateSource | Title: TRS 内容协作平台（TRS WCM） Description: 获取相关文件 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
PublishContentViewDataImpl |
PublishContentViewFieldImpl |
PublishContentViewImpl |
PublishFolderClassImpl | Title: TRS 内容协作平台（TRS WCM） Description: 分类Folder的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserAppendix | Title: TRS 内容协作平台（TRS WCM） Description: TRS_APPENDIX解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserClassDocuments |
WCMTagParserClassIndexGener | Title: TRS 内容协作平台（TRS WCM） Description: 在指定栏目或者站点中产生分类法首页 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserClassInfo |
WCMTagParserClassInfos | Title: TRS 内容协作平台（TRS WCM） Description: TRS_ClassInfos 置标解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserExistDataOfClassInfo |
WCMTagParserMyViewDatas | Title: TRS 内容协作平台（TRS WCM） Description: TRS_MyViewDatas解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserRelNewsForViewData | Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_RELNEWS Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserViewData |
WCMTagParserViewDatas |
WCMTagParserViewField | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserViewFields | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.metadata.publish 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.publish 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.tagparser.BaseTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.domain.tagparser.BaseTagParser4List (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
        • com.trs.components.metadata.publish.WCMTagParserClassDocuments
        • com.trs.components.metadata.publish.WCMTagParserMyViewDatas
        • com.trs.components.metadata.publish.WCMTagParserViewDatas
        • com.trs.components.metadata.publish.WCMTagParserViewFields
      • com.trs.components.metadata.publish.WCMTagParserClassInfos (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
    • com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl (implements com.trs.components.metadata.publish.IClassInfoCountCacheForPublish)
    • com.trs.components.metadata.publish.MetaViewDataRelateSource (implements com.trs.components.wcm.publish.element.IRelateResource)
    • com.trs.components.common.publish.persistent.element.PublishContentImplBase (implements com.trs.components.common.publish.persistent.element.IPublishContent)
      • com.trs.components.metadata.publish.PublishContentViewDataImpl
      • com.trs.components.metadata.publish.PublishContentViewFieldImpl
      • com.trs.components.metadata.publish.PublishContentViewImpl
    • com.trs.components.common.publish.persistent.element.PublishFolderImplBase (implements com.trs.components.common.publish.persistent.element.IPublishFolder)
      • com.trs.components.metadata.publish.PublishFolderClassImpl
    • com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.domain.tagparser.TagParserContentBase
        • com.trs.components.metadata.publish.WCMTagParserViewData
        • com.trs.components.metadata.publish.WCMTagParserViewField
      • com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
        • com.trs.components.metadata.publish.WCMTagParserClassInfo
    • com.trs.components.metadata.publish.WCMTagParserAppendix (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.metadata.publish.WCMTagParserClassIndexGener (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData (implements com.trs.components.common.publish.domain.tagparser.ITagParser, com.trs.components.common.publish.domain.tagparser.ITagParser4List)

接口分层结构

  • com.trs.components.metadata.publish.IClassInfoCountCacheForPublish


软件包 com.trs.components.metadata.publish 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.publish
的使用

使用 com.trs.components.metadata.publish 的软件包
com.trs.components.metadata.publish

com.trs.components.metadata.publish 使用的 com.trs.components.metadata.publish 中的类
IClassInfoCountCacheForPublish

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishContentViewDataImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 PublishContentViewDataImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishContentImplBase
        继承者  com.trs.components.metadata.publish.PublishContentViewDataImpl
所有已实现的接口：
ICMSObjSubstanceContent, IPublishContent, IPublishElement
public class PublishContentViewDataImpl
extends PublishContentImplBase

作者：
曹辉

构造方法摘要
PublishContentViewDataImpl()
方法摘要
int | getBodyType() Returns the content body type
IPublishFolder | getFolder() Returns the folder where this element currently lies.
int | getModal() Returns the content modal in the curernt folder
IPublishFolder | getOriginalHome() Returns the folder where this content originally lies.
java.util.Iterator | getRelatedResources() 获取Content相关的资源文件(如附件等)
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isPublishedInHome() Returns true if this content has been published in its home folder.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setPublishStatus(int _nStatus) Sets the publish status of this content in the specified folder
void | setPublishTime(CMyDateTime _dtTime) 设置当前内容的发布时间
void | setPublishTimeAndURL(CMyDateTime _time, java.lang.String url) 设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
从类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 继承的方法
canDoPreview, equals, getCreatedTime, getDetailTemplate, getDetailTemplateType, getEncoding, getFileName, getFileNamedStyle, getId, getInfo, getLinkUrl, getRealHome, getTemplateArguments, isFile, isFolder, isLink, isValidElement, setDetailTemplateType, setFolder, validateCanDoPub
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishContentViewDataImpl

public PublishContentViewDataImpl()
方法详细信息

getBodyType

public int getBodyType()
从接口 IPublishContent 复制的描述
Returns the content body type

返回：
Returns the content body type which is defined in CMSConstants like CONTENT_BODY_NORMAL, CONTENT_BODY_HTML, etc.

getModal

public int getModal()
             throws WCMException
从接口 IPublishContent 复制的描述
Returns the content modal in the curernt folder

指定者：
接口 IPublishContent 中的 getModal
覆盖：
类 PublishContentImplBase 中的 getModal
返回：
Returns the content modal type which is defined in CMSConstants like CONTENT_MODAL_ENTITY, CONTENT_MODAL_LINK, etc.
抛出：
WCMException - if failed to load this property.
另请参见：
IPublishContent.getModal()

getOriginalHome

public IPublishFolder getOriginalHome()
                               throws WCMException
从接口 IPublishContent 复制的描述
Returns the folder where this content originally lies.

返回：
the folder where this content originally lies.
抛出：
WCMException - if failed.

getRelatedResources

public java.util.Iterator getRelatedResources()
                                       throws WCMException
从接口 IPublishContent 复制的描述
获取Content相关的资源文件(如附件等)

返回：
相关资源文件的文件名集合,可能返回null
抛出：
WCMException

isPublishedInHome

public boolean isPublishedInHome()
                          throws java.lang.Exception
从接口 IPublishContent 复制的描述
Returns true if this content has been published in its home folder.

返回：
true if this content has been published in its home folder.
抛出：
java.lang.Exception - if failed to get the publish status of this content in its home.

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishContent 复制的描述
Sets the publish status of this content in the specified folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, etc.
抛出：
WCMException

setPublishTime

public void setPublishTime(CMyDateTime _dtTime)
                    throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容的发布时间

参数：
_dtTime - CMyDateTime实例对象，如果为null表示页面被取消了
抛出：
WCMException - 如果发生错误

setPublishTimeAndURL

public void setPublishTimeAndURL(CMyDateTime _time,
                                 java.lang.String url)
                          throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消

参数：
_time - 发布的时间
url - 发布后的URL
抛出：
WCMException - 如果发生错误

isCanDoSave

public boolean isCanDoSave(User _loginUser)
                    throws WCMException
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

返回：
抛出：
WCMException

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

抛出：
WCMException

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

返回：
the publish content type

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

参数：
_cmsObj - a CMS object

getFolder

public IPublishFolder getFolder()
从接口 IPublishElement 复制的描述
Returns the folder where this element currently lies.

指定者：
接口 IPublishElement 中的 getFolder
覆盖：
类 PublishContentImplBase 中的 getFolder
返回：
the folder where this element currently lies.
另请参见：
IPublishElement.getFolder()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishContentViewFieldImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 PublishContentViewFieldImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishContentImplBase
        继承者  com.trs.components.metadata.publish.PublishContentViewFieldImpl
所有已实现的接口：
ICMSObjSubstanceContent, IPublishContent, IPublishElement
public class PublishContentViewFieldImpl
extends PublishContentImplBase

作者：
曹辉

构造方法摘要
PublishContentViewFieldImpl()
方法摘要
int | getBodyType() Returns the content body type
IPublishFolder | getOriginalHome() Returns the folder where this content originally lies.
java.util.Iterator | getRelatedResources() 获取Content相关的资源文件(如附件等)
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isPublishedInHome() Returns true if this content has been published in its home folder.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setPublishStatus(int _nStatus) Sets the publish status of this content in the specified folder
void | setPublishTime(CMyDateTime _dtTime) 设置当前内容的发布时间
void | setPublishTimeAndURL(CMyDateTime _time, java.lang.String url) 设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
从类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 继承的方法
canDoPreview, equals, getCreatedTime, getDetailTemplate, getDetailTemplateType, getEncoding, getFileName, getFileNamedStyle, getFolder, getId, getInfo, getLinkUrl, getModal, getRealHome, getTemplateArguments, isFile, isFolder, isLink, isValidElement, setDetailTemplateType, setFolder, validateCanDoPub
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishContentViewFieldImpl

public PublishContentViewFieldImpl()
方法详细信息

getBodyType

public int getBodyType()
从接口 IPublishContent 复制的描述
Returns the content body type

返回：
Returns the content body type which is defined in CMSConstants like CONTENT_BODY_NORMAL, CONTENT_BODY_HTML, etc.

getOriginalHome

public IPublishFolder getOriginalHome()
                               throws WCMException
从接口 IPublishContent 复制的描述
Returns the folder where this content originally lies.

返回：
the folder where this content originally lies.
抛出：
WCMException - if failed.

getRelatedResources

public java.util.Iterator getRelatedResources()
                                       throws WCMException
从接口 IPublishContent 复制的描述
获取Content相关的资源文件(如附件等)

返回：
相关资源文件的文件名集合,可能返回null
抛出：
WCMException

isPublishedInHome

public boolean isPublishedInHome()
                          throws java.lang.Exception
从接口 IPublishContent 复制的描述
Returns true if this content has been published in its home folder.

返回：
true if this content has been published in its home folder.
抛出：
java.lang.Exception - if failed to get the publish status of this content in its home.

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishContent 复制的描述
Sets the publish status of this content in the specified folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, etc.
抛出：
WCMException

setPublishTime

public void setPublishTime(CMyDateTime _dtTime)
                    throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容的发布时间

参数：
_dtTime - CMyDateTime实例对象，如果为null表示页面被取消了
抛出：
WCMException - 如果发生错误

setPublishTimeAndURL

public void setPublishTimeAndURL(CMyDateTime _time,
                                 java.lang.String url)
                          throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消

参数：
_time - 发布的时间
url - 发布后的URL
抛出：
WCMException - 如果发生错误

isCanDoSave

public boolean isCanDoSave(User _loginUser)
                    throws WCMException
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

返回：
抛出：
WCMException

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

抛出：
WCMException

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

返回：
the publish content type

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

参数：
_cmsObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishContentViewImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 PublishContentViewImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishContentImplBase
        继承者  com.trs.components.metadata.publish.PublishContentViewImpl
所有已实现的接口：
ICMSObjSubstanceContent, IPublishContent, IPublishElement
public class PublishContentViewImpl
extends PublishContentImplBase

作者：
曹辉

构造方法摘要
PublishContentViewImpl()
方法摘要
int | getBodyType() Returns the content body type
IPublishFolder | getOriginalHome() Returns the folder where this content originally lies.
java.util.Iterator | getRelatedResources() 获取Content相关的资源文件(如附件等)
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isPublishedInHome() Returns true if this content has been published in its home folder.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setPublishStatus(int _nStatus) Sets the publish status of this content in the specified folder
void | setPublishTime(CMyDateTime _dtTime) 设置当前内容的发布时间
void | setPublishTimeAndURL(CMyDateTime _time, java.lang.String url) 设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
从类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 继承的方法
canDoPreview, equals, getCreatedTime, getDetailTemplate, getDetailTemplateType, getEncoding, getFileName, getFileNamedStyle, getFolder, getId, getInfo, getLinkUrl, getModal, getRealHome, getTemplateArguments, isFile, isFolder, isLink, isValidElement, setDetailTemplateType, setFolder, validateCanDoPub
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishContentViewImpl

public PublishContentViewImpl()
方法详细信息

getBodyType

public int getBodyType()
从接口 IPublishContent 复制的描述
Returns the content body type

返回：
Returns the content body type which is defined in CMSConstants like CONTENT_BODY_NORMAL, CONTENT_BODY_HTML, etc.

getOriginalHome

public IPublishFolder getOriginalHome()
                               throws WCMException
从接口 IPublishContent 复制的描述
Returns the folder where this content originally lies.

返回：
the folder where this content originally lies.
抛出：
WCMException - if failed.

getRelatedResources

public java.util.Iterator getRelatedResources()
                                       throws WCMException
从接口 IPublishContent 复制的描述
获取Content相关的资源文件(如附件等)

返回：
相关资源文件的文件名集合,可能返回null
抛出：
WCMException

isPublishedInHome

public boolean isPublishedInHome()
                          throws java.lang.Exception
从接口 IPublishContent 复制的描述
Returns true if this content has been published in its home folder.

返回：
true if this content has been published in its home folder.
抛出：
java.lang.Exception - if failed to get the publish status of this content in its home.

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishContent 复制的描述
Sets the publish status of this content in the specified folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, etc.
抛出：
WCMException

setPublishTime

public void setPublishTime(CMyDateTime _dtTime)
                    throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容的发布时间

参数：
_dtTime - CMyDateTime实例对象，如果为null表示页面被取消了
抛出：
WCMException - 如果发生错误

setPublishTimeAndURL

public void setPublishTimeAndURL(CMyDateTime _time,
                                 java.lang.String url)
                          throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消

参数：
_time - 发布的时间
url - 发布后的URL
抛出：
WCMException - 如果发生错误

isCanDoSave

public boolean isCanDoSave(User _loginUser)
                    throws WCMException
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

返回：
抛出：
WCMException

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

抛出：
WCMException

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

返回：
the publish content type

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

参数：
_cmsObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishFolderClassImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 PublishFolderClassImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishFolderImplBase
        继承者  com.trs.components.metadata.publish.PublishFolderClassImpl
所有已实现的接口：
ICMSObjSubstanceContent, IPublishElement, IPublishFolder
public class PublishFolderClassImpl
extends PublishFolderImplBase

Title: TRS 内容协作平台（TRS WCM）
Description:
分类Folder的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 继承的字段
INHERIT_ROOT_DETAIL_TEMPLATE
构造方法摘要
PublishFolderClassImpl()
方法摘要
boolean | canDoBatchDetailPageTask()
boolean | canDoDetailPageTask() check if can create detail page task
boolean | canDoOutlinePageTask() check if can create outline page task
IPublishElements | getAllContents(WCMFilter _filter) Returns all the contents to publish
IPublishElementsIterator | getAllContentsIterator(WCMFilter _filter)
IPublishElements | getChildren() get the children folders
java.lang.String | getDataPath()
IPublishElement | getHost()
int | getId() Returns the publish content id.
IPublishElements | getIncreasedContents(WCMFilter _filter) Returns the increased contents to publish
IPublishElementsIterator | getIncreasedContentsIterator(WCMFilter _filter)
java.lang.String | getLinkUrl()
IPublishFolder | getParent()
java.lang.String | getPathKey() 获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写
IPublishElements | getPublishedContents(WCMFilter _filter) Returns the contents which have been published.
IPublishFolder | getRoot()
int | getSiblingIndex() Retuns index of this folder in its siblings.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isDeleted() 是否已经被假删除
boolean | isLink()
boolean | isRoot()
boolean | isValidElement() 判断是否为有效的发布元素
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setHost(IPublishElement upperHost)
void | setPublishStatus(int _nStatus) Sets the publish status of this folder
void | setRoot(IPublishFolder _root)
void | setRootId(int _nRootId)
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
boolean | validateCanDoPub() Returns true if the folder is can be published.
从类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 继承的方法
canDoPreview, equals, getDetailTemplate, getEncoding, getFolder, getFoldersQuotingMe, getInfo, getOutlineTemplates, getRootDomain, getTemplateArguments, isFolder
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishFolderClassImpl

public PublishFolderClassImpl()
方法详细信息

canDoBatchDetailPageTask

public boolean canDoBatchDetailPageTask()

canDoDetailPageTask

public boolean canDoDetailPageTask()
从接口 IPublishFolder 复制的描述
check if can create detail page task

返回：

canDoOutlinePageTask

public boolean canDoOutlinePageTask()
从接口 IPublishFolder 复制的描述
check if can create outline page task

返回：

getAllContents

public IPublishElements getAllContents(WCMFilter _filter)
                                throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns all the contents to publish

参数：
_filter - extra query filter for the collection
返回：
all the contents which have been published or can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getAllContentsIterator

public IPublishElementsIterator getAllContentsIterator(WCMFilter _filter)
                                                throws java.lang.Exception
抛出：
java.lang.Exception

getChildren

public IPublishElements getChildren()
                             throws WCMException
从接口 IPublishFolder 复制的描述
get the children folders

返回：
the children folders collection.
抛出：
WCMException - if failed to fetch the children.

getIncreasedContents

public IPublishElements getIncreasedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the increased contents to publish

参数：
_filter - extra query filter for the collection
返回：
the contents collection, which are not published but can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getIncreasedContentsIterator

public IPublishElementsIterator getIncreasedContentsIterator(WCMFilter _filter)
                                                      throws java.lang.Exception
抛出：
java.lang.Exception

getParent

public IPublishFolder getParent()
                         throws WCMException
返回：
the parent of this folder.
抛出：
WCMException - if failed to fetch the parent folder.

getPublishedContents

public IPublishElements getPublishedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the contents which have been published.

参数：
_filter - extra query filter for the collection
返回：
the contents which have been published
抛出：
java.lang.Exception - if failed to fetch the contents collection.

getRoot

public IPublishFolder getRoot()
                       throws WCMException
返回：
the root of this folder.
抛出：
WCMException - if failed to find the folder root.

getSiblingIndex

public int getSiblingIndex()
从接口 IPublishFolder 复制的描述
Retuns index of this folder in its siblings.

返回：
index of this folder in its siblings.

isDeleted

public boolean isDeleted()
从接口 IPublishFolder 复制的描述
是否已经被假删除

返回：

isRoot

public boolean isRoot()
返回：
true if this folder is a root; otherwise, returns false.

setPublishStatus

public void setPublishStatus(int _nStatus)
从接口 IPublishFolder 复制的描述
Sets the publish status of this folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, STATUS_DELETEDetc.

getLinkUrl

public java.lang.String getLinkUrl()
返回：
the linked url if this eliement is a link;
otherwise, returns null.

isCanDoSave

public boolean isCanDoSave(User _loginUser)
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

返回：

isLink

public boolean isLink()
返回：
true if the eliement is a link;
otherwise, returns false.

isValidElement

public boolean isValidElement()
从接口 IPublishElement 复制的描述
判断是否为有效的发布元素

返回：

validateCanDoPreview

public void validateCanDoPreview()
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

validateCanDoPub

public boolean validateCanDoPub()
从接口 IPublishElement 复制的描述
Returns true if the folder is can be published.

返回：
true if the folder is can be published.

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

返回：
the publish content type

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

参数：
_cmsObj - a CMS object

getDataPath

public java.lang.String getDataPath()
                             throws WCMException
指定者：
接口 IPublishFolder 中的 getDataPath
覆盖：
类 PublishFolderImplBase 中的 getDataPath
返回：
the data path.
抛出：
WCMException
另请参见：
IPublishFolder.getDataPath()

setRootId

public void setRootId(int _nRootId)
               throws WCMException
抛出：
WCMException

setRoot

public void setRoot(IPublishFolder _root)

getHost

public IPublishElement getHost()

setHost

public void setHost(IPublishElement upperHost)

getPathKey

public java.lang.String getPathKey()
从接口 IPublishFolder 复制的描述
获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写

指定者：
接口 IPublishFolder 中的 getPathKey
覆盖：
类 PublishFolderImplBase 中的 getPathKey
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserAppendix

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserAppendix

java.lang.Object
    继承者  com.trs.components.metadata.publish.WCMTagParserAppendix
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserAppendix
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_APPENDIX解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserAppendix()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserAppendix

public WCMTagParserAppendix()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserClassDocuments

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserClassDocuments

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.metadata.publish.WCMTagParserClassDocuments
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserClassDocuments
extends BaseTagParser4List

作者：
曹辉

构造方法摘要
WCMTagParserClassDocuments()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
clear, getBeanInfo
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserClassDocuments

public WCMTagParserClassDocuments()
方法详细信息

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
覆盖：
类 BaseTagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
覆盖：
类 BaseTagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserClassIndexGener

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserClassIndexGener

java.lang.Object
    继承者  com.trs.components.metadata.publish.WCMTagParserClassIndexGener
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserClassIndexGener
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
在指定栏目或者站点中产生分类法首页
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserClassIndexGener()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserClassIndexGener

public WCMTagParserClassIndexGener()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserClassInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserClassInfo

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
            继承者  com.trs.components.metadata.publish.WCMTagParserClassInfo
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserClassInfo
extends TagParserFolderBase

作者：
曹辉

构造方法摘要
WCMTagParserClassInfo()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserClassInfo

public WCMTagParserClassInfo()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserClassInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserClassInfos

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.metadata.publish.WCMTagParserClassInfos
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserClassInfos
extends BaseTagParser
implements ITagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_ClassInfos 置标解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserClassInfos()
方法摘要
PublishTagContext | getDelegatedContext() 返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
PublishTagContext | getNextRecordContext() Returns the tag parse context of the next record.
int | getRecordSize() Returns the records number in thes list.
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setStartPos(int _nPos) Sets the start position
PublishTagContext | substantiateContext(PublishTagContext _tagConext) 实体化指定的PublishTagContext对象
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserClassInfos

public WCMTagParserClassInfos()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

getRecordSize

public int getRecordSize()
从接口 ITagParser4List 复制的描述
Returns the records number in thes list.

指定者：
接口 ITagParser4List 中的 getRecordSize
返回：
the records number in thes list.

setStartPos

public void setStartPos(int _nPos)
从接口 ITagParser4List 复制的描述
Sets the start position

指定者：
接口 ITagParser4List 中的 setStartPos

getNextRecordContext

public PublishTagContext getNextRecordContext()
                                       throws WCMException
从接口 ITagParser4List 复制的描述
Returns the tag parse context of the next record.

指定者：
接口 ITagParser4List 中的 getNextRecordContext
返回：
the tag parse context of the next record.
抛出：
WCMException - if failed to get the next record or to construct the tag parse context.
另请参见：
ITagParser4List.getNextRecordContext()

getDelegatedContext

public PublishTagContext getDelegatedContext()
从接口 ITagParser4List 复制的描述
返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。 所谓被被托管（托管这种说法可能不太准确）的PublishTagContext对象， 是指被延迟实体化的对象，也即延迟设定实际的UpperHost的对象，因为被实体化， 所以相应 ITagParser4List对象中游标也就没有发生实际的移动。 注意（2006.02.08）
事实上该方法和substantiateContext(PublishTagContext)组合使用， 应该可以替代 getNextRecordContext方法，而且这两套方法不能混合使用， 之所以要保留 getNextRecordContext，是为了使改动可以回退。

指定者：
接口 ITagParser4List 中的 getDelegatedContext
返回：
被托管的PublishTagContext对象，或者null。
另请参见：
ITagParser4List.substantiateContext(PublishTagContext), ITagParser4List.getNextRecordContext()

substantiateContext

public PublishTagContext substantiateContext(PublishTagContext _tagConext)
                                      throws WCMException
从接口 ITagParser4List 复制的描述
实体化指定的PublishTagContext对象

指定者：
接口 ITagParser4List 中的 substantiateContext
参数：
_tagConext - 指定的PublishTagContext对象
返回：
实体化后的PublishTagContext对象
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserExistDataOfClassInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserExistDataOfClassInfo

java.lang.Object
    继承者  com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserExistDataOfClassInfo
extends java.lang.Object
implements ITagParser

作者：
Administrator

构造方法摘要
WCMTagParserExistDataOfClassInfo()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserExistDataOfClassInfo

public WCMTagParserExistDataOfClassInfo()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserMyViewDatas

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserMyViewDatas

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.metadata.publish.WCMTagParserMyViewDatas
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserMyViewDatas
extends BaseTagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_MyViewDatas解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserMyViewDatas()
方法摘要
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserMyViewDatas

public WCMTagParserMyViewDatas()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserRelNewsForViewData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserRelNewsForViewData

java.lang.Object
    继承者  com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserRelNewsForViewData
extends java.lang.Object
implements ITagParser, ITagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_RELNEWS
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserRelNewsForViewData()
constructor: default
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
PublishTagContext | getDelegatedContext() 返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
PublishTagContext | getNextRecordContext() Returns the tag parse context of the next record.
int | getRecordSize() Returns the records number in thes list.
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setStartPos(int _nPos) Sets the start position
void | setTagItem(TagItem _item) Sets the tag item to parser.
PublishTagContext | substantiateContext(PublishTagContext _tagConext) 实体化指定的PublishTagContext对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserRelNewsForViewData

public WCMTagParserRelNewsForViewData()
constructor: default

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.
另请参见：
ITagParser.setTagItem(TagItem)

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
另请参见：
ITagParser.analyzeQuotes(IPublishFolder)

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.parse(PublishTagContext)

getRecordSize

public int getRecordSize()
从接口 ITagParser4List 复制的描述
Returns the records number in thes list.

指定者：
接口 ITagParser4List 中的 getRecordSize
返回：
the records number in thes list.
另请参见：
ITagParser4List.getRecordSize()

setStartPos

public void setStartPos(int _nPos)
从接口 ITagParser4List 复制的描述
Sets the start position

指定者：
接口 ITagParser4List 中的 setStartPos
另请参见：
ITagParser4List.setStartPos(int)

getNextRecordContext

public PublishTagContext getNextRecordContext()
                                       throws WCMException
从接口 ITagParser4List 复制的描述
Returns the tag parse context of the next record.

指定者：
接口 ITagParser4List 中的 getNextRecordContext
返回：
the tag parse context of the next record.
抛出：
WCMException - if failed to get the next record or to construct the tag parse context.
另请参见：
ITagParser4List.getNextRecordContext()

getDelegatedContext

public PublishTagContext getDelegatedContext()
从接口 ITagParser4List 复制的描述
返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。 所谓被被托管（托管这种说法可能不太准确）的PublishTagContext对象， 是指被延迟实体化的对象，也即延迟设定实际的UpperHost的对象，因为被实体化， 所以相应 ITagParser4List对象中游标也就没有发生实际的移动。 注意（2006.02.08）
事实上该方法和substantiateContext(PublishTagContext)组合使用， 应该可以替代 getNextRecordContext方法，而且这两套方法不能混合使用， 之所以要保留 getNextRecordContext，是为了使改动可以回退。

指定者：
接口 ITagParser4List 中的 getDelegatedContext
返回：
被托管的PublishTagContext对象，或者null。
另请参见：
ITagParser4List.substantiateContext(PublishTagContext), ITagParser4List.getNextRecordContext()

substantiateContext

public PublishTagContext substantiateContext(PublishTagContext _tagConext)
                                      throws WCMException
从接口 ITagParser4List 复制的描述
实体化指定的PublishTagContext对象

指定者：
接口 ITagParser4List 中的 substantiateContext
参数：
_tagConext - 指定的PublishTagContext对象
返回：
实体化后的PublishTagContext对象
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserViewData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserViewData

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserContentBase
            继承者  com.trs.components.metadata.publish.WCMTagParserViewData
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserViewData
extends TagParserContentBase

作者：
曹辉

构造方法摘要
WCMTagParserViewData()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
java.lang.String[] | parseSubItems(PublishTagContext _context)
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserViewData

public WCMTagParserViewData()
方法详细信息

parseSubItems

public java.lang.String[] parseSubItems(PublishTagContext _context)
                                 throws WCMException
抛出：
WCMException

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
覆盖：
类 TagParserCMSObjBase 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.parse(PublishTagContext)

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserViewDatas

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserViewDatas

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.metadata.publish.WCMTagParserViewDatas
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserViewDatas
extends BaseTagParser4List

作者：
曹辉

构造方法摘要
WCMTagParserViewDatas()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | makeCurrChannel(PublishTagContext _context)
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
clear, getBeanInfo
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserViewDatas

public WCMTagParserViewDatas()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
覆盖：
类 BaseTagParser4List 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

makeCurrChannel

public void makeCurrChannel(PublishTagContext _context)

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
覆盖：
类 BaseTagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
覆盖：
类 BaseTagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserViewField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserViewField

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserContentBase
            继承者  com.trs.components.metadata.publish.WCMTagParserViewField
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserViewField
extends TagParserContentBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserViewField()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserViewField

public WCMTagParserViewField()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserViewFields

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.publish
类 WCMTagParserViewFields

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.metadata.publish.WCMTagParserViewFields
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserViewFields
extends BaseTagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserViewFields()
方法摘要
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserViewFields

public WCMTagParserViewFields()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl
的使用

没有 com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.publish.IClassInfoCountCacheForPublish 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.publish.IClassInfoCountCacheForPublish
的使用

使用 IClassInfoCountCacheForPublish 的软件包
com.trs.components.metadata.publish

com.trs.components.metadata.publish 中 IClassInfoCountCacheForPublish 的使用

实现 IClassInfoCountCacheForPublish 的 com.trs.components.metadata.publish 中的类
 class ClassInfoCountCacheForPublishImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.MetaViewDataRelateSource 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.MetaViewDataRelateSource
的使用

没有 com.trs.components.metadata.publish.MetaViewDataRelateSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.PublishContentViewDataImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.PublishContentViewDataImpl
的使用

没有 com.trs.components.metadata.publish.PublishContentViewDataImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.PublishContentViewFieldImpl
的使用

没有 com.trs.components.metadata.publish.PublishContentViewFieldImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.PublishContentViewImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.PublishContentViewImpl
的使用

没有 com.trs.components.metadata.publish.PublishContentViewImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.PublishFolderClassImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.PublishFolderClassImpl
的使用

没有 com.trs.components.metadata.publish.PublishFolderClassImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserAppendix 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserAppendix
的使用

没有 com.trs.components.metadata.publish.WCMTagParserAppendix 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserClassDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserClassDocuments
的使用

没有 com.trs.components.metadata.publish.WCMTagParserClassDocuments 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserClassIndexGener 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserClassIndexGener
的使用

没有 com.trs.components.metadata.publish.WCMTagParserClassIndexGener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserClassInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserClassInfo
的使用

没有 com.trs.components.metadata.publish.WCMTagParserClassInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserClassInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserClassInfos
的使用

没有 com.trs.components.metadata.publish.WCMTagParserClassInfos 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo
的使用

没有 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserMyViewDatas 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserMyViewDatas
的使用

没有 com.trs.components.metadata.publish.WCMTagParserMyViewDatas 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData
的使用

没有 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserViewData
的使用

没有 com.trs.components.metadata.publish.WCMTagParserViewData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserViewDatas 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserViewDatas
的使用

没有 com.trs.components.metadata.publish.WCMTagParserViewDatas 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserViewField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserViewField
的使用

没有 com.trs.components.metadata.publish.WCMTagParserViewField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.publish.WCMTagParserViewFields 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.publish.WCMTagParserViewFields
的使用

没有 com.trs.components.metadata.publish.WCMTagParserViewFields 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AuthServerMgr

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.right
类 AuthServerMgr

java.lang.Object
    继承者  com.trs.components.metadata.right.AuthServerMgr

public class AuthServerMgr
extends java.lang.Object

构造方法摘要
AuthServerMgr()
方法摘要
static boolean | hasRight(User _loginUser, MetaDBTable _oDBTable)
static boolean | hasRight(User _loginUser, MetaView _view)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AuthServerMgr

public AuthServerMgr()
方法详细信息

hasRight

public static boolean hasRight(User _loginUser,
                               MetaDBTable _oDBTable)
                        throws WCMException
参数：
_loginUser -
_oDBTable -
返回：
抛出：
WCMException

hasRight

public static boolean hasRight(User _loginUser,
                               MetaView _view)
                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.right
类
AuthServerMgr


com.trs.components.metadata.right

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.right

类摘要
AuthServerMgr


com.trs.components.metadata.right 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.right 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.right.AuthServerMgr


软件包 com.trs.components.metadata.right 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.right
的使用

没有 com.trs.components.metadata.right 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.right.AuthServerMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.right.AuthServerMgr
的使用

没有 com.trs.components.metadata.right.AuthServerMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ClassInfoChannelRightHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ClassInfoChannelRightHelper

java.lang.Object
    继承者  com.trs.components.metadata.service.ClassInfoChannelRightHelper

public class ClassInfoChannelRightHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
分类法产生的栏目权限维护工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ClassInfoChannelRightHelper()
方法摘要
static void resetClassInfoChannelRight(WebSite _site, Group _rootGroup)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoChannelRightHelper

public ClassInfoChannelRightHelper()
方法详细信息

resetClassInfoChannelRight

public static void resetClassInfoChannelRight(WebSite _site,
                                              Group _rootGroup)
                                       throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ClassInfoPublishServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ClassInfoPublishServiceProvider

java.lang.Object
    继承者  com.trs.components.metadata.service.ClassInfoPublishServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class ClassInfoPublishServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
分类法发布服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ClassInfoPublishServiceProvider()
方法摘要
 void publishClassInfo(MethodContext _oMethodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoPublishServiceProvider

public ClassInfoPublishServiceProvider()
方法详细信息

publishClassInfo

public void publishClassInfo(MethodContext _oMethodContext)
                      throws WCMException
参数：
_currUser -
_sClassInfoIds -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ClassInfoServiceProvider

java.lang.Object
    继承者  com.trs.components.metadata.service.ClassInfoServiceProvider
所有已实现的接口：
IFindByIdServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ClassInfoServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider, IFindByIdServiceProvider

作者：
曹辉

构造方法摘要
ClassInfoServiceProvider()
方法摘要
void | changeOrder(MethodContext _methodContext) 调整分类法顺序
java.lang.String | createClassInfoTreeHTML(MethodContext _methodContext) 产生指定分类下所有子分类的HTML
java.lang.String | createClassInfoTreeHTML(User _currUser, int _nParentId) 产生指定父节点的分类信息
java.lang.String | createClassInfoTreeHTMLOfIds(MethodContext _methodContext) 产生指定ID序列的HTML type表示产生的方式，type=0表示沿着一条链一直展开，用于定位到一个未展开的节点 传入的ids有父子关系;type!
void | deleteClassInfo(MethodContext _methodContext) 删除指定的分类
void | deleteClassInfo(User _currUser, int _nClassInfoId)
void | deleteClassInfo(User _currUser, java.lang.String _sClassInfoIds)
java.lang.Object | exists(MethodContext _methodContext) 是否存在指定条件的分类信息
java.lang.String | exportClassInfos(MethodContext _oMethodContext) 导出指定的分类法
java.lang.Object | findById(MethodContext _methodContext)
java.lang.String | getPath(MethodContext _methodContext)
Reports | importClassInfos(MethodContext _methodContext) 从文件中导入分类法
void | moveAsChild(MethodContext _methodContext)
ClassInfos | queryClassInfos(MethodContext _methodContext) 获取指定的分类
ClassInfos | queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)
ClassInfo | saveClassInfo(MethodContext _context)
ClassInfo | saveClassInfo(MethodContext _methodContext, User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode) 这个方法实现不太好，但只是为了兼容wcm6，因为wcm6的实现，字段都是写死的， 不能根据外界传入什么字段，向数据库中保存什么
ClassInfo | saveClassInfo(User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode) 保存分类法设置
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoServiceProvider

public ClassInfoServiceProvider()
方法详细信息

createClassInfoTreeHTMLOfIds

public java.lang.String createClassInfoTreeHTMLOfIds(MethodContext _methodContext)
                                              throws java.lang.Throwable
产生指定ID序列的HTML type表示产生的方式，type=0表示沿着一条链一直展开，用于定位到一个未展开的节点 传入的ids有父子关系;type!=0表示定位到传入的ids序列，用于定位展开传入的Id; type默认为0

参数：
_methodContext -
抛出：
java.lang.Throwable

createClassInfoTreeHTML

public java.lang.String createClassInfoTreeHTML(MethodContext _methodContext)
                                         throws java.lang.Throwable
产生指定分类下所有子分类的HTML

参数：
_methodContext -
抛出：
java.lang.Throwable

createClassInfoTreeHTML

public java.lang.String createClassInfoTreeHTML(User _currUser,
                                                int _nParentId)
                                         throws WCMException
产生指定父节点的分类信息

参数：
_currUser -
_nParentId -
返回：
抛出：
WCMException

queryClassInfos

public ClassInfos queryClassInfos(MethodContext _methodContext)
                           throws java.lang.Throwable
获取指定的分类

参数：
_methodContext -
抛出：
java.lang.Throwable

queryClassInfos

public ClassInfos queryClassInfos(User _currUser,
                                  int _nParentId,
                                  WCMFilter _extraFilter)
                           throws WCMException
参数：
_currUser -
_nParentId -
返回：
抛出：
WCMException

deleteClassInfo

public void deleteClassInfo(MethodContext _methodContext)
                     throws java.lang.Throwable
删除指定的分类

参数：
_methodContext -
抛出：
java.lang.Throwable

deleteClassInfo

public void deleteClassInfo(User _currUser,
                            int _nClassInfoId)
                     throws WCMException
参数：
_currUser -
_nClassInfoId -
抛出：
WCMException

deleteClassInfo

public void deleteClassInfo(User _currUser,
                            java.lang.String _sClassInfoIds)
                     throws WCMException
参数：
_currUser -
_sClassInfoIds -
抛出：
WCMException

saveClassInfo

public ClassInfo saveClassInfo(MethodContext _context)
                        throws WCMException
参数：
_context -
返回：
抛出：
WCMException

saveClassInfo

public ClassInfo saveClassInfo(User _currUser,
                               int _nCurrId,
                               int _nParentId,
                               int _nPreviousId,
                               java.lang.String _sName,
                               java.lang.String _sDesc,
                               java.lang.String _sCCode)
                        throws WCMException
保存分类法设置

参数：
_currUser -
_nParentId -
_nCurrId -
_sName -
_sDesc -
返回：
抛出：
WCMException

saveClassInfo

public ClassInfo saveClassInfo(MethodContext _methodContext,
                               User _currUser,
                               int _nCurrId,
                               int _nParentId,
                               int _nPreviousId,
                               java.lang.String _sName,
                               java.lang.String _sDesc,
                               java.lang.String _sCCode)
                        throws WCMException
这个方法实现不太好，但只是为了兼容wcm6，因为wcm6的实现，字段都是写死的， 不能根据外界传入什么字段，向数据库中保存什么

参数：
_methodContext -
_currUser -
_nCurrId -
_nParentId -
_nPreviousId -
_sName -
_sDesc -
_sCCode -
返回：
抛出：
WCMException

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

exists

public java.lang.Object exists(MethodContext _methodContext)
                        throws WCMException
是否存在指定条件的分类信息

参数：
_methodContext -
抛出：
java.lang.Throwable
WCMException

getPath

public java.lang.String getPath(MethodContext _methodContext)
                         throws WCMException
抛出：
WCMException

importClassInfos

public Reports importClassInfos(MethodContext _methodContext)
                         throws java.lang.Exception
从文件中导入分类法

参数：
_methodContext -
返回：
抛出：
java.lang.Exception

changeOrder

public void changeOrder(MethodContext _methodContext)
                 throws java.lang.Throwable
调整分类法顺序

参数：
_methodContext -
抛出：
java.lang.Throwable

moveAsChild

public void moveAsChild(MethodContext _methodContext)
                 throws java.lang.Throwable
抛出：
java.lang.Throwable

exportClassInfos

public java.lang.String exportClassInfos(MethodContext _oMethodContext)
                                  throws WCMException
导出指定的分类法

参数：
_oMethodContext -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoServiceProviderForGB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ClassInfoServiceProviderForGB

java.lang.Object
    继承者  com.trs.components.metadata.service.ClassInfoServiceProviderForGB
所有已实现的接口：
IFindByIdServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class ClassInfoServiceProviderForGB
extends java.lang.Object
implements ISelfDefinedServiceProvider, IFindByIdServiceProvider

作者：
曹辉

构造方法摘要
ClassInfoServiceProviderForGB()
方法摘要
java.lang.String | createClassInfoTreeHTML(User _currUser, int _nParentId) 产生指定父节点的分类信息
java.lang.String | createClassInfoTreeHTMLForGB(MethodContext _methodContext) 产生指定分类下所有子分类的HTML
java.lang.String | createClassInfoTreeHTMLOfIds(MethodContext _methodContext) 产生指定ID序列的HTML type表示产生的方式，type=0表示沿着一条链一直展开，用于定位到一个未展开的节点 传入的ids有父子关系;type!
void | deleteClassInfo(MethodContext _methodContext) 删除指定的分类
void | deleteClassInfo(User _currUser, int _nClassInfoId)
void | deleteClassInfo(User _currUser, java.lang.String _sClassInfoIds)
java.lang.Object | exists(MethodContext _methodContext) 是否存在指定条件的分类信息
java.lang.Object | findById(MethodContext _methodContext)
java.lang.String | getPath(MethodContext _methodContext)
Reports | importClassInfos(MethodContext _methodContext) 从文件中导入分类法
ClassInfos | queryClassInfos(MethodContext _methodContext) 获取指定的分类
ClassInfos | queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)
ClassInfo | saveClassInfo(MethodContext _context)
ClassInfo | saveClassInfo(User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc) 保存分类法设置
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoServiceProviderForGB

public ClassInfoServiceProviderForGB()
方法详细信息

createClassInfoTreeHTMLOfIds

public java.lang.String createClassInfoTreeHTMLOfIds(MethodContext _methodContext)
                                              throws java.lang.Throwable
产生指定ID序列的HTML type表示产生的方式，type=0表示沿着一条链一直展开，用于定位到一个未展开的节点 传入的ids有父子关系;type!=0表示定位到传入的ids序列，用于定位展开传入的Id; type默认为0

参数：
_methodContext -
抛出：
java.lang.Throwable

createClassInfoTreeHTMLForGB

public java.lang.String createClassInfoTreeHTMLForGB(MethodContext _methodContext)
                                              throws java.lang.Throwable
产生指定分类下所有子分类的HTML

参数：
_methodContext -
抛出：
java.lang.Throwable

createClassInfoTreeHTML

public java.lang.String createClassInfoTreeHTML(User _currUser,
                                                int _nParentId)
                                         throws WCMException
产生指定父节点的分类信息

参数：
_currUser -
_nParentId -
返回：
抛出：
WCMException

queryClassInfos

public ClassInfos queryClassInfos(MethodContext _methodContext)
                           throws java.lang.Throwable
获取指定的分类

参数：
_methodContext -
抛出：
java.lang.Throwable

queryClassInfos

public ClassInfos queryClassInfos(User _currUser,
                                  int _nParentId,
                                  WCMFilter _extraFilter)
                           throws WCMException
参数：
_currUser -
_nParentId -
返回：
抛出：
WCMException

deleteClassInfo

public void deleteClassInfo(MethodContext _methodContext)
                     throws java.lang.Throwable
删除指定的分类

参数：
_methodContext -
抛出：
java.lang.Throwable

deleteClassInfo

public void deleteClassInfo(User _currUser,
                            int _nClassInfoId)
                     throws WCMException
参数：
_currUser -
_nClassInfoId -
抛出：
WCMException

deleteClassInfo

public void deleteClassInfo(User _currUser,
                            java.lang.String _sClassInfoIds)
                     throws WCMException
参数：
_currUser -
_sClassInfoIds -
抛出：
WCMException

saveClassInfo

public ClassInfo saveClassInfo(MethodContext _context)
                        throws WCMException
参数：
_context -
返回：
抛出：
WCMException

saveClassInfo

public ClassInfo saveClassInfo(User _currUser,
                               int _nCurrId,
                               int _nParentId,
                               int _nPreviousId,
                               java.lang.String _sName,
                               java.lang.String _sDesc)
                        throws WCMException
保存分类法设置

参数：
_currUser -
_nParentId -
_nCurrId -
_sName -
_sDesc -
返回：
抛出：
WCMException

findById

public java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

exists

public java.lang.Object exists(MethodContext _methodContext)
                        throws WCMException
是否存在指定条件的分类信息

参数：
_methodContext -
抛出：
java.lang.Throwable
WCMException

getPath

public java.lang.String getPath(MethodContext _methodContext)
                         throws WCMException
抛出：
WCMException

importClassInfos

public Reports importClassInfos(MethodContext _methodContext)
                         throws java.lang.Exception
从文件中导入分类法

参数：
_methodContext -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoToChannelHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ClassInfoToChannelHelper

java.lang.Object
    继承者  com.trs.components.metadata.service.ClassInfoToChannelHelper

public class ClassInfoToChannelHelper
extends java.lang.Object

构造方法摘要
ClassInfoToChannelHelper()
方法摘要
static void | createChannels(ClassInfo _oParentClassInfo, BaseChannel _host, MetaView _oView, int _nMaxLevel)
static void | createSites(ClassInfo _oParentClassInfo, MetaView _oView, int _nMaxLevel, java.lang.String _sRootDomain)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoToChannelHelper

public ClassInfoToChannelHelper()
方法详细信息

createSites

public static void createSites(ClassInfo _oParentClassInfo,
                               MetaView _oView,
                               int _nMaxLevel,
                               java.lang.String _sRootDomain)
                        throws WCMException
抛出：
WCMException

createChannels

public static void createChannels(ClassInfo _oParentClassInfo,
                                  BaseChannel _host,
                                  MetaView _oView,
                                  int _nMaxLevel)
                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoToGroupCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ClassInfoToGroupCreator

java.lang.Object
    继承者  com.trs.components.metadata.service.ClassInfoToGroupCreator

public class ClassInfoToGroupCreator
extends java.lang.Object

字段摘要
static java.lang.String ROLENAME_SFX_MGR
构造方法摘要
ClassInfoToGroupCreator()
方法摘要
void | createGroups(ClassInfo _oDeptClassInfoRoot, Group _hostGroup, int _nMaxLevel)
java.lang.String | getNewUserInfos()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ROLENAME_SFX_MGR

public static final java.lang.String ROLENAME_SFX_MGR
构造方法详细信息

ClassInfoToGroupCreator

public ClassInfoToGroupCreator()
方法详细信息

getNewUserInfos

public java.lang.String getNewUserInfos()

createGroups

public void createGroups(ClassInfo _oDeptClassInfoRoot,
                         Group _hostGroup,
                         int _nMaxLevel)
                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoViewService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ClassInfoViewService

java.lang.Object
    继承者  com.trs.components.metadata.service.ClassInfoViewService

public class ClassInfoViewService
extends java.lang.Object

构造方法摘要
ClassInfoViewService()
方法摘要
ClassInfos | queryClassInfos(User _currUser, java.lang.String _sDocumentIds, WCMFilter _filter) 根据分类法信息返回视图对象集合
Documents | queryDocuments(User _currUser, java.lang.String _sClassInfoIds, java.lang.String _sViewId, boolean _bContainChildClassInfo) 根据分类法的id序列和viewId得到文档集合对象
Documents | queryDocuments(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter) 根据传入的分类法对象获取文档集合对象
Documents | queryDocuments(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo) 根据传入的分类法对象获取文档集合对象
MetaViews | queryViews(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter) 根据分类法信息返回视图对象集合
MetaViews | queryViews(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo) 根据分类法信息返回视图对象集合
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoViewService

public ClassInfoViewService()
方法详细信息

queryDocuments

public Documents queryDocuments(User _currUser,
                                java.lang.String _sClassInfoId,
                                WCMFilter _filter,
                                boolean _bContainChildClassInfo)
                         throws WCMException
根据传入的分类法对象获取文档集合对象

参数：
_currUser -
_sClassInfoId -
_bContainChildClassInfo - 是否同时获取子分类法的文档
返回：
抛出：
WCMException

queryDocuments

public Documents queryDocuments(User _currUser,
                                java.lang.String _sClassInfo,
                                WCMFilter _filter)
                         throws WCMException
根据传入的分类法对象获取文档集合对象

参数：
_currUser -
_classInfo -
返回：
抛出：
WCMException

queryDocuments

public Documents queryDocuments(User _currUser,
                                java.lang.String _sClassInfoIds,
                                java.lang.String _sViewId,
                                boolean _bContainChildClassInfo)
                         throws WCMException
根据分类法的id序列和viewId得到文档集合对象

参数：
_currUser -
_sClassInfoIds -
_sViewId -
返回：
抛出：
WCMException

queryViews

public MetaViews queryViews(User _currUser,
                            java.lang.String _sClassInfoId,
                            WCMFilter _filter,
                            boolean _bContainChildClassInfo)
                     throws WCMException
根据分类法信息返回视图对象集合

参数：
_currUser -
_classInfo -
_filter -
_bContainChildClassInfo -
返回：
抛出：
WCMException

queryViews

public MetaViews queryViews(User _currUser,
                            java.lang.String _sClassInfo,
                            WCMFilter _filter)
                     throws WCMException
根据分类法信息返回视图对象集合

参数：
_currUser -
_classInfo -
_filter -
返回：
抛出：
WCMException

queryClassInfos

public ClassInfos queryClassInfos(User _currUser,
                                  java.lang.String _sDocumentIds,
                                  WCMFilter _filter)
                           throws WCMException
根据分类法信息返回视图对象集合

参数：
_currUser -
_classInfo -
_filter -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoViewServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ClassInfoViewServiceProvider

java.lang.Object
    继承者  com.trs.components.metadata.service.ClassInfoViewServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class ClassInfoViewServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

构造方法摘要
ClassInfoViewServiceProvider()
方法摘要
java.lang.String | preview(MethodContext _methodContext)
void | publish(MethodContext _methodContext)
ClassInfos | queryClassInfos(MethodContext _methodContext) 根据文档的ids，获取在指定分类下的文档所在分类
ClassInfos | queryClassInfos1(MethodContext _methodContext)
java.lang.String | queryDocNumMapping(MethodContext _methodContext) 根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
java.lang.String | queryDocNumMapping2(MethodContext _methodContext) 获取分类法和文档数目的一个隐射
Documents | queryDocuments(MethodContext _methodContext)
MetaViews | queryViews(MethodContext _methodContext) 根据分类法信息获取视图信息
MetaViews | queryViewsByClassInfo(MethodContext _methodContext) 获取使用了指定分类法的视图信息,如果分类法ID为0，则表示获取使用了分类法字段的所有视图
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoViewServiceProvider

public ClassInfoViewServiceProvider()
方法详细信息

queryViews

public MetaViews queryViews(MethodContext _methodContext)
                     throws java.lang.Throwable
根据分类法信息获取视图信息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryViewsByClassInfo

public MetaViews queryViewsByClassInfo(MethodContext _methodContext)
                                throws java.lang.Throwable
获取使用了指定分类法的视图信息,如果分类法ID为0，则表示获取使用了分类法字段的所有视图

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryDocuments

public Documents queryDocuments(MethodContext _methodContext)
                         throws java.lang.Throwable
抛出：
java.lang.Throwable

queryClassInfos

public ClassInfos queryClassInfos(MethodContext _methodContext)
                           throws java.lang.Throwable
根据文档的ids，获取在指定分类下的文档所在分类

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryClassInfos1

public ClassInfos queryClassInfos1(MethodContext _methodContext)
                            throws java.lang.Throwable
抛出：
java.lang.Throwable

queryDocNumMapping

public java.lang.String queryDocNumMapping(MethodContext _methodContext)
                                    throws java.lang.Throwable
根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryDocNumMapping2

public java.lang.String queryDocNumMapping2(MethodContext _methodContext)
                                     throws java.lang.Throwable
获取分类法和文档数目的一个隐射

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

preview

public java.lang.String preview(MethodContext _methodContext)
                         throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

publish

public void publish(MethodContext _methodContext)
             throws java.lang.Throwable
参数：
_methodContext -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultChannelMakerCenter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 DefaultChannelMakerCenter

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.config.BaseConfigServer
            继承者  com.trs.components.metadata.service.DefaultChannelMakerCenter
所有已实现的接口：
IServer
public class DefaultChannelMakerCenter
extends BaseConfigServer

Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String SERVICE_ID
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
DefaultChannelMakerCenter()
方法摘要
Channels | getAvailableChannels(User _loginUser, int _nViewId) 获取当前用户在指定视图下可用的栏目,根据视图，获取视图绑定的栏目，在过滤到没有权限的栏目
static DefaultChannelMakerCenter | getInstance() 获取Center的实例
Channel | makeDefaultChannel(User _loginUser, int _nViewId) 构造用户在指定视图上默认存储的栏目
从类 com.trs.infra.config.BaseConfigServer 继承的方法
getConfigPath, setConfigPath
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SERVICE_ID

public static final java.lang.String SERVICE_ID
另请参见：
常量字段值
构造方法详细信息

DefaultChannelMakerCenter

public DefaultChannelMakerCenter()
方法详细信息

makeDefaultChannel

public Channel makeDefaultChannel(User _loginUser,
                                  int _nViewId)
                           throws WCMException
构造用户在指定视图上默认存储的栏目

参数：
_loginUser -
_nViewId -
返回：
抛出：
WCMException

getAvailableChannels

public Channels getAvailableChannels(User _loginUser,
                                     int _nViewId)
                              throws WCMException
获取当前用户在指定视图下可用的栏目,根据视图，获取视图绑定的栏目，在过滤到没有权限的栏目

参数：
_loginUser -
_nViewId -
返回：
抛出：
WCMException

getInstance

public static DefaultChannelMakerCenter getInstance()
获取Center的实例

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GovInfoIndexCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 GovInfoIndexCreator

java.lang.Object
    继承者  com.trs.components.metadata.service.GovInfoIndexCreator
所有已实现的接口：
IMetaDataFieldValueCreator
public class GovInfoIndexCreator
extends java.lang.Object
implements IMetaDataFieldValueCreator

作者：
曹辉

构造方法摘要
GovInfoIndexCreator()
方法摘要
java.lang.String | getCreatorName() 产生器的名称
java.lang.String[] | registerRelateTables() 注册值产生器相关的物理表列表
void | resetFieldValueOnMetaData() 给所有相关的元数据记录重新设置新的值
void | setFieldValueBeforeSaveMetaData(MetaViewData _oMetaViewData) 给当前元数据对象的相关属性设置上自动产生的值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GovInfoIndexCreator

public GovInfoIndexCreator()
方法详细信息

getCreatorName

public java.lang.String getCreatorName()
从接口 IMetaDataFieldValueCreator 复制的描述
产生器的名称

指定者：
接口 IMetaDataFieldValueCreator 中的 getCreatorName
返回：

registerRelateTables

public java.lang.String[] registerRelateTables()
从接口 IMetaDataFieldValueCreator 复制的描述
注册值产生器相关的物理表列表

指定者：
接口 IMetaDataFieldValueCreator 中的 registerRelateTables
返回：
表名数组

setFieldValueBeforeSaveMetaData

public void setFieldValueBeforeSaveMetaData(MetaViewData _oMetaViewData)
                                     throws WCMException
从接口 IMetaDataFieldValueCreator 复制的描述
给当前元数据对象的相关属性设置上自动产生的值

指定者：
接口 IMetaDataFieldValueCreator 中的 setFieldValueBeforeSaveMetaData
参数：
_oMetaViewData - 当前元数据对象
抛出：
WCMException

resetFieldValueOnMetaData

public void resetFieldValueOnMetaData()
                               throws WCMException
从接口 IMetaDataFieldValueCreator 复制的描述
给所有相关的元数据记录重新设置新的值

指定者：
接口 IMetaDataFieldValueCreator 中的 resetFieldValueOnMetaData
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GovInfoServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 GovInfoServiceProvider

java.lang.Object
    继承者  com.trs.components.metadata.service.GovInfoServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class GovInfoServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
GovInfoServiceProvider()
方法摘要
Reports | copy(MethodContext _methodContext) 复制记录到...
Reports | deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
java.lang.String | exportViewDatas(MethodContext _methodContext) 导出元数据
MetaViewData | findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
Reports | importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
int | queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
java.lang.String | queryObjectsCountOfView(MethodContext _methodContext) 根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
MetaViewDatas | queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewData | saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
static MetaViewData | setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GovInfoServiceProvider

public GovInfoServiceProvider()
方法详细信息

saveMetaViewData

public MetaViewData saveMetaViewData(MethodContext _methodContext)
                              throws java.lang.Throwable
保存在指定视图下提交的数据信息

参数：
_methodContext -
抛出：
java.lang.Throwable

saveMetaViewDataOfGov

public MetaViewData saveMetaViewDataOfGov(MethodContext _methodContext)
                                   throws java.lang.Throwable
保存来自政府的公开信息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

importMetaViewDatas

public Reports importMetaViewDatas(MethodContext _methodContext)
                            throws java.lang.Throwable
在指定的栏目下导入指定的视图

参数：
_methodContext -
抛出：
java.lang.Throwable

queryViewDatas

public MetaViewDatas queryViewDatas(MethodContext _methodContext)
                             throws java.lang.Throwable
获取指定视图的数据

参数：
_methodContext -
抛出：
java.lang.Throwable

findViewDataById

public MetaViewData findViewDataById(MethodContext _methodContext)
                              throws java.lang.Throwable
根据ID获取指定视图数据的对象

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

deleteViewDatas

public Reports deleteViewDatas(MethodContext _methodContext)
                        throws java.lang.Throwable
删除视图数据信息

参数：
_methodContext -
抛出：
java.lang.Throwable

copy

public Reports copy(MethodContext _methodContext)
             throws java.lang.Throwable
复制记录到...

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

setViewDataProperties

public static MetaViewData setViewDataProperties(MethodContext _methodContext,
                                                 MetaViewData _oViewData)
                                          throws WCMException
参数：
_methodContext -
_oViewData -
返回：
抛出：
WCMException

queryObjectsOfView

public MetaViewDatas queryObjectsOfView(MethodContext _methodContext)
                                 throws java.lang.Throwable
抛出：
java.lang.Throwable

queryObjectsCountOfView

public java.lang.String queryObjectsCountOfView(MethodContext _methodContext)
                                         throws java.lang.Throwable
根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryObjectsCountOfClassInfo

public int queryObjectsCountOfClassInfo(MetaView _metaView,
                                        ClassInfo _classInfo,
                                        WCMFilter _filter)
                                 throws WCMException
抛出：
WCMException

exportViewDatas

public java.lang.String exportViewDatas(MethodContext _methodContext)
                                 throws java.lang.Throwable
导出元数据

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GovInfoToXML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 GovInfoToXML

java.lang.Object
    继承者  com.trs.components.metadata.service.GovInfoToXML

public class GovInfoToXML
extends java.lang.Object

构造方法摘要
GovInfoToXML()
方法摘要
static WCMFilter | getMetaDatasFilter(ClassInfo _oClassInfo)
static void | setClassInfoIds(java.lang.String sClassInfoIds) 设置要处理的分类法序列，如：214，349表示处理分类法id为214和349的分类法
void | setDebug(boolean isDebug) 设置是否输出状态信息
static void | setMetaViewId(int iMetaViewId) 设置要处理的视图Id
static void | setYearSpan(java.lang.String sYearSpan) 设置要处理的年份范围。
static org.dom4j.Element | toXML() 产生书对应的xml串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GovInfoToXML

public GovInfoToXML()
方法详细信息

setYearSpan

public static void setYearSpan(java.lang.String sYearSpan)
设置要处理的年份范围。如： 2007表示要生成2007年的； 2003,2005表示要生成2003年到2005年的

参数：
sYearSpan -

setClassInfoIds

public static void setClassInfoIds(java.lang.String sClassInfoIds)
设置要处理的分类法序列，如：214，349表示处理分类法id为214和349的分类法

参数：
sClassInfos -

setMetaViewId

public static void setMetaViewId(int iMetaViewId)
设置要处理的视图Id

参数：
iMetaViewId -

setDebug

public void setDebug(boolean isDebug)
设置是否输出状态信息

参数：
isDebug -

toXML

public static org.dom4j.Element toXML()
                               throws java.lang.Exception
产生书对应的xml串

返回：
抛出：
java.lang.Exception

getMetaDatasFilter

public static WCMFilter getMetaDatasFilter(ClassInfo _oClassInfo)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDefaultChannelMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
接口 IDefaultChannelMaker

所有已知实现类：
UserRelateInfoMaker
public interface IDefaultChannelMaker

方法摘要
Channel | makeDefaultChannel(User _loginUser, int _nViewId) 构造当前用户默认的栏目
int[] | registerViewIds() 注册构造器相关的视图ID

方法详细信息

makeDefaultChannel

Channel makeDefaultChannel(User _loginUser,
                           int _nViewId)
                           throws WCMException
构造当前用户默认的栏目

参数：
_loginUser -
_nViewId -
返回：
抛出：
WCMException

registerViewIds

int[] registerViewIds()
注册构造器相关的视图ID

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MailConfigsHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 MailConfigsHelper

java.lang.Object
    继承者  com.trs.components.metadata.service.MailConfigsHelper

public class MailConfigsHelper
extends java.lang.Object

构造方法摘要
MailConfigsHelper()
方法摘要
static java.lang.String | getConfig(java.lang.String sConfigName)
static java.util.Map | getConfigs()
static void | loadConfigs()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MailConfigsHelper

public MailConfigsHelper()
方法详细信息

loadConfigs

public static void loadConfigs()
                        throws WCMException
抛出：
WCMException

getConfig

public static java.lang.String getConfig(java.lang.String sConfigName)
                                  throws WCMException
抛出：
WCMException

getConfigs

public static java.util.Map getConfigs()
                                throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataCenterServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 MetaDataCenterServiceProvider

java.lang.Object
    继承者  com.trs.components.metadata.service.MetaDataCenterServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class MetaDataCenterServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataCenterServiceProvider()
方法摘要
Reports | copy(MethodContext _methodContext) 复制记录到...
void | copyViewDatas(MethodContext _methodContext) 将记录复制到另一个分类法下
Reports | deleteViewDatas(MethodContext _methodContext) 已过时。 改成Document的监听机制，转向调用ViewDocument.delete方法
java.lang.String | exportAllViewDatas(MethodContext _methodContext) 导出指定视图或栏目下的所有元数据记录
java.lang.String | exportViewDatas(MethodContext _methodContext) 导出元数据
MetaViewData | findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
Reports | importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
void | moveViewDatas(MethodContext _methodContext) 将某些分类法下的记录移动到另一个分类法下
MetaViewDatas | queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | queryViewDatasNoView(MethodContext _methodContext)
MetaViewData | saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataCenterServiceProvider

public MetaDataCenterServiceProvider()
方法详细信息

saveMetaViewData

public MetaViewData saveMetaViewData(MethodContext _methodContext)
                              throws java.lang.Throwable
保存在指定视图下提交的数据信息

参数：
_methodContext -
抛出：
java.lang.Throwable

importMetaViewDatas

public Reports importMetaViewDatas(MethodContext _methodContext)
                            throws java.lang.Throwable
在指定的栏目下导入指定的视图

参数：
_methodContext -
抛出：
java.lang.Throwable

queryViewDatas

public MetaViewDatas queryViewDatas(MethodContext _methodContext)
                             throws java.lang.Throwable
获取指定视图的数据

参数：
_methodContext -
抛出：
java.lang.Throwable

queryViewDatasNoView

public MetaViewDatas queryViewDatasNoView(MethodContext _methodContext)
                                   throws java.lang.Throwable
抛出：
java.lang.Throwable

findViewDataById

public MetaViewData findViewDataById(MethodContext _methodContext)
                              throws java.lang.Throwable
根据ID获取指定视图数据的对象

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

deleteViewDatas

public Reports deleteViewDatas(MethodContext _methodContext)
                        throws java.lang.Throwable
已过时。 改成Document的监听机制，转向调用ViewDocument.delete方法

删除视图数据信息

参数：
_methodContext -
抛出：
java.lang.Throwable

copy

public Reports copy(MethodContext _methodContext)
             throws java.lang.Throwable
复制记录到...

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

exportViewDatas

public java.lang.String exportViewDatas(MethodContext _methodContext)
                                 throws java.lang.Throwable
导出元数据

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

exportAllViewDatas

public java.lang.String exportAllViewDatas(MethodContext _methodContext)
                                    throws java.lang.Throwable
导出指定视图或栏目下的所有元数据记录

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

moveViewDatas

public void moveViewDatas(MethodContext _methodContext)
                   throws java.lang.Throwable
将某些分类法下的记录移动到另一个分类法下

参数：
_methodContext -
抛出：
java.lang.Throwable

copyViewDatas

public void copyViewDatas(MethodContext _methodContext)
                   throws java.lang.Throwable
将记录复制到另一个分类法下

参数：
_methodContext -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataCenterServiceProviderForAgri

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 MetaDataCenterServiceProviderForAgri

java.lang.Object
    继承者  com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class MetaDataCenterServiceProviderForAgri
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataCenterServiceProviderForAgri()
方法摘要
Reports | copy(MethodContext _methodContext) 复制记录到...
Reports | deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
java.lang.String | exportViewDatas(MethodContext _methodContext) 导出元数据
MetaViewData | findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
Reports | importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
int | queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
java.lang.String | queryObjectsCountOfView(MethodContext _methodContext) 根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
MetaViewDatas | queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewData | saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
static MetaViewData | setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataCenterServiceProviderForAgri

public MetaDataCenterServiceProviderForAgri()
方法详细信息

saveMetaViewData

public MetaViewData saveMetaViewData(MethodContext _methodContext)
                              throws java.lang.Throwable
保存在指定视图下提交的数据信息

参数：
_methodContext -
抛出：
java.lang.Throwable

saveMetaViewDataOfGov

public MetaViewData saveMetaViewDataOfGov(MethodContext _methodContext)
                                   throws java.lang.Throwable
保存来自政府的公开信息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

importMetaViewDatas

public Reports importMetaViewDatas(MethodContext _methodContext)
                            throws java.lang.Throwable
在指定的栏目下导入指定的视图

参数：
_methodContext -
抛出：
java.lang.Throwable

queryViewDatas

public MetaViewDatas queryViewDatas(MethodContext _methodContext)
                             throws java.lang.Throwable
获取指定视图的数据

参数：
_methodContext -
抛出：
java.lang.Throwable

findViewDataById

public MetaViewData findViewDataById(MethodContext _methodContext)
                              throws java.lang.Throwable
根据ID获取指定视图数据的对象

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

deleteViewDatas

public Reports deleteViewDatas(MethodContext _methodContext)
                        throws java.lang.Throwable
删除视图数据信息

参数：
_methodContext -
抛出：
java.lang.Throwable

copy

public Reports copy(MethodContext _methodContext)
             throws java.lang.Throwable
复制记录到...

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

setViewDataProperties

public static MetaViewData setViewDataProperties(MethodContext _methodContext,
                                                 MetaViewData _oViewData)
                                          throws WCMException
参数：
_methodContext -
_oViewData -
返回：
抛出：
WCMException

queryObjectsOfView

public MetaViewDatas queryObjectsOfView(MethodContext _methodContext)
                                 throws java.lang.Throwable
抛出：
java.lang.Throwable

queryObjectsCountOfView

public java.lang.String queryObjectsCountOfView(MethodContext _methodContext)
                                         throws java.lang.Throwable
根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryObjectsCountOfClassInfo

public int queryObjectsCountOfClassInfo(MetaView _metaView,
                                        ClassInfo _classInfo,
                                        WCMFilter _filter)
                                 throws WCMException
抛出：
WCMException

exportViewDatas

public java.lang.String exportViewDatas(MethodContext _methodContext)
                                 throws java.lang.Throwable
导出元数据

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataCenterServiceProviderForGB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 MetaDataCenterServiceProviderForGB

java.lang.Object
    继承者  com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class MetaDataCenterServiceProviderForGB
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataCenterServiceProviderForGB()
方法摘要
Reports | copy(MethodContext _methodContext) 复制记录到...
Reports | deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
java.lang.String | exportViewDatas(MethodContext _methodContext) 导出元数据
MetaViewData | findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
Reports | importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
int | queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
java.lang.String | queryObjectsCountOfView(MethodContext _methodContext) 根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
MetaViewDatas | queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewData | saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
static MetaViewData | setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataCenterServiceProviderForGB

public MetaDataCenterServiceProviderForGB()
方法详细信息

saveMetaViewData

public MetaViewData saveMetaViewData(MethodContext _methodContext)
                              throws java.lang.Throwable
保存在指定视图下提交的数据信息

参数：
_methodContext -
抛出：
java.lang.Throwable

saveMetaViewDataOfGov

public MetaViewData saveMetaViewDataOfGov(MethodContext _methodContext)
                                   throws java.lang.Throwable
保存来自政府的公开信息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

importMetaViewDatas

public Reports importMetaViewDatas(MethodContext _methodContext)
                            throws java.lang.Throwable
在指定的栏目下导入指定的视图

参数：
_methodContext -
抛出：
java.lang.Throwable

queryViewDatas

public MetaViewDatas queryViewDatas(MethodContext _methodContext)
                             throws java.lang.Throwable
获取指定视图的数据

参数：
_methodContext -
抛出：
java.lang.Throwable

findViewDataById

public MetaViewData findViewDataById(MethodContext _methodContext)
                              throws java.lang.Throwable
根据ID获取指定视图数据的对象

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

deleteViewDatas

public Reports deleteViewDatas(MethodContext _methodContext)
                        throws java.lang.Throwable
删除视图数据信息

参数：
_methodContext -
抛出：
java.lang.Throwable

copy

public Reports copy(MethodContext _methodContext)
             throws java.lang.Throwable
复制记录到...

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

setViewDataProperties

public static MetaViewData setViewDataProperties(MethodContext _methodContext,
                                                 MetaViewData _oViewData)
                                          throws WCMException
参数：
_methodContext -
_oViewData -
返回：
抛出：
WCMException

queryObjectsOfView

public MetaViewDatas queryObjectsOfView(MethodContext _methodContext)
                                 throws java.lang.Throwable
抛出：
java.lang.Throwable

queryObjectsCountOfView

public java.lang.String queryObjectsCountOfView(MethodContext _methodContext)
                                         throws java.lang.Throwable
根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryObjectsCountOfClassInfo

public int queryObjectsCountOfClassInfo(MetaView _metaView,
                                        ClassInfo _classInfo,
                                        WCMFilter _filter)
                                 throws WCMException
抛出：
WCMException

exportViewDatas

public java.lang.String exportViewDatas(MethodContext _methodContext)
                                 throws java.lang.Throwable
导出元数据

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataCenterServiceProviderForZJH

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 MetaDataCenterServiceProviderForZJH

java.lang.Object
    继承者  com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class MetaDataCenterServiceProviderForZJH
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaDataCenterServiceProviderForZJH()
方法摘要
MetaViewData | saveMetaViewData(MethodContext _methodContext) 保存来自政府的公开信息
MetaViewData | saveMetaViewDataOfGov(MethodContext _methodContext)
static MetaViewData | setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataCenterServiceProviderForZJH

public MetaDataCenterServiceProviderForZJH()
方法详细信息

saveMetaViewDataOfGov

public MetaViewData saveMetaViewDataOfGov(MethodContext _methodContext)
                                   throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

saveMetaViewData

public MetaViewData saveMetaViewData(MethodContext _methodContext)
                              throws java.lang.Throwable
保存来自政府的公开信息

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

setViewDataProperties

public static MetaViewData setViewDataProperties(MethodContext _methodContext,
                                                 MetaViewData _oViewData)
                                          throws WCMException
参数：
_methodContext -
_oViewData -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataDefServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 MetaDataDefServiceProvider

java.lang.Object
    继承者  com.trs.components.metadata.service.MetaDataDefServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class MetaDataDefServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台定义服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | POSITION_AFTER
static int | POSITION_BEFORE
构造方法摘要
MetaDataDefServiceProvider()
方法摘要
java.lang.String | buildAllFromTextFile(MethodContext _methodContext) 根据文本文件的定义，创建系统
void | changeViewFieldOrder(MethodContext _methodContext) 改变视图字段的顺序
Reports | createViewRelation(MethodContext _methodContext) 重新产生所有视图或者指定视图的应用
Reports | deleteDBFieldInfo(MethodContext _methodContext) 删除元数据字段信息
Reports | deleteDBTableInfo(MethodContext _methodContext) 删除元数据结构信息
Reports | deleteView(MethodContext _methodContext) 删除多个视图信息
Reports | deleteViewField(MethodContext _methodContext) 删除视图字段信息信息
java.lang.String | exportViews(MethodContext _oMethodContext) 导出指定的视图
MetaDBField | findDBFieldInfoById(MethodContext _methodContext) 根据ID获取元数据对象
MetaDBTable | findDBTableInfoById(MethodContext _methodContext) 根据ID获取元数据结构对象
MetaDBTables | findDBTableInfosByIds(MethodContext _methodContext) 根据ID序列获取元数据集合
java.lang.String | findSynRule(MethodContext _methodContext) 为栏目设置同步文档的规则
MetaView | findViewByChannel(MethodContext _methodContext)
MetaView | findViewById(MethodContext _methodContext) 根据ID获取视图信息对象
MetaViewField | findViewFieldById(MethodContext _methodContext)
MetaView | getViewFromChannel(MethodContext _methodContext)
MetaView | importViewFromXML(MethodContext _methodContext) 从XML文件创建视图
Reports | importViewsFromXML(MethodContext _oMethodContext) 从系统导出的XML创建视图（包括元数据表）
ClassInfos | queryClassInfosUsingMetaView(MethodContext _methodContext) 获取系统所有使用了视图或指定视图的分类法树根
MetaDBFields | queryDBFieldInfos(MethodContext _methodContext) 查询指定表的字段集合
MetaDBTables | queryDBTableInfos(MethodContext _oMethodContext)
MetaViewFields | queryViewFieldInfos(MethodContext _methodContext)
MetaViews | queryViews(MethodContext _methodContext) 获取系统所有视图
MetaViews | queryViewsUsingClassInfo(MethodContext _methodContext) 获取系统所有使用了分类法字段或指定分类法字段视图
MetaViews | queryViewsUsintTable(MethodContext _methodContext) 获取正在使用指定表的视图列表
void | recreateAllOfDBTableInfo(MethodContext _methodContext)
MetaDBField | saveDBFieldInfo(MethodContext _methodContext) 保存元数据字段信息
MetaDBTable | saveDBTableInfo(MethodContext _methodContext) 保存元数据表的信息
void | saveSynRule(MethodContext _methodContext) 为栏目设置同步文档的规则
MetaView | saveView(MethodContext _methodContext) 保存指定的视图信息
MetaViewField | saveViewField(MethodContext _methodContext) 保存视图字段信息
void | setViewEmployerByChannel(MethodContext _methodContext) 给指定栏目分配视图
void | setViewFields(MethodContext _methodContext) 维护视图选择的字段：目前仅仅适合单表模式
void | setViewFieldsInfo(MethodContext _methodContext) 设置多个视图字段的信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

POSITION_BEFORE

public static final int POSITION_BEFORE
另请参见：
常量字段值

POSITION_AFTER

public static final int POSITION_AFTER
另请参见：
常量字段值
构造方法详细信息

MetaDataDefServiceProvider

public MetaDataDefServiceProvider()
方法详细信息

saveDBTableInfo

public MetaDBTable saveDBTableInfo(MethodContext _methodContext)
                            throws java.lang.Throwable
保存元数据表的信息

参数：
_methodContext -
抛出：
java.lang.Throwable

saveDBFieldInfo

public MetaDBField saveDBFieldInfo(MethodContext _methodContext)
                            throws java.lang.Throwable
保存元数据字段信息

参数：
_methodContext -
抛出：
java.lang.Throwable

queryDBTableInfos

public MetaDBTables queryDBTableInfos(MethodContext _oMethodContext)
                               throws WCMException
参数：
_oMethodContext -
返回：
抛出：
WCMException

queryDBFieldInfos

public MetaDBFields queryDBFieldInfos(MethodContext _methodContext)
                               throws java.lang.Throwable
查询指定表的字段集合

参数：
_methodContext -
抛出：
java.lang.Throwable

queryViewFieldInfos

public MetaViewFields queryViewFieldInfos(MethodContext _methodContext)
                                   throws java.lang.Throwable
参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

getViewFromChannel

public MetaView getViewFromChannel(MethodContext _methodContext)
                            throws java.lang.Throwable
抛出：
java.lang.Throwable

queryViews

public MetaViews queryViews(MethodContext _methodContext)
                     throws java.lang.Throwable
获取系统所有视图

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryViewsUsingClassInfo

public MetaViews queryViewsUsingClassInfo(MethodContext _methodContext)
                                   throws java.lang.Throwable
获取系统所有使用了分类法字段或指定分类法字段视图

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryClassInfosUsingMetaView

public ClassInfos queryClassInfosUsingMetaView(MethodContext _methodContext)
                                        throws java.lang.Throwable
获取系统所有使用了视图或指定视图的分类法树根

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

queryViewsUsintTable

public MetaViews queryViewsUsintTable(MethodContext _methodContext)
                               throws java.lang.Throwable
获取正在使用指定表的视图列表

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

deleteDBTableInfo

public Reports deleteDBTableInfo(MethodContext _methodContext)
                          throws java.lang.Throwable
删除元数据结构信息

参数：
_methodContext -
抛出：
java.lang.Throwable

deleteDBFieldInfo

public Reports deleteDBFieldInfo(MethodContext _methodContext)
                          throws java.lang.Throwable
删除元数据字段信息

参数：
_methodContext -
抛出：
java.lang.Throwable

findDBFieldInfoById

public MetaDBField findDBFieldInfoById(MethodContext _methodContext)
                                throws java.lang.Throwable
根据ID获取元数据对象

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

findDBTableInfoById

public MetaDBTable findDBTableInfoById(MethodContext _methodContext)
                                throws java.lang.Throwable
根据ID获取元数据结构对象

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

findDBTableInfosByIds

public MetaDBTables findDBTableInfosByIds(MethodContext _methodContext)
                                   throws java.lang.Throwable
根据ID序列获取元数据集合

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

saveView

public MetaView saveView(MethodContext _methodContext)
                  throws java.lang.Throwable
保存指定的视图信息

参数：
_methodContext -
抛出：
java.lang.Throwable

saveViewField

public MetaViewField saveViewField(MethodContext _methodContext)
                            throws java.lang.Throwable
保存视图字段信息

参数：
_methodContext -
抛出：
java.lang.Throwable

deleteView

public Reports deleteView(MethodContext _methodContext)
                   throws java.lang.Throwable
删除多个视图信息

参数：
_methodContext -
抛出：
java.lang.Throwable

deleteViewField

public Reports deleteViewField(MethodContext _methodContext)
                        throws java.lang.Throwable
删除视图字段信息信息

参数：
_methodContext -
抛出：
java.lang.Throwable

importViewFromXML

public MetaView importViewFromXML(MethodContext _methodContext)
                           throws java.lang.Throwable
从XML文件创建视图

参数：
_methodContext -
抛出：
java.lang.Throwable

findViewById

public MetaView findViewById(MethodContext _methodContext)
                      throws java.lang.Throwable
根据ID获取视图信息对象

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

findViewFieldById

public MetaViewField findViewFieldById(MethodContext _methodContext)
                                throws java.lang.Throwable
抛出：
java.lang.Throwable

setViewFields

public void setViewFields(MethodContext _methodContext)
                   throws java.lang.Throwable
维护视图选择的字段：目前仅仅适合单表模式

参数：
_methodContext -
抛出：
java.lang.Throwable

setViewFieldsInfo

public void setViewFieldsInfo(MethodContext _methodContext)
                       throws java.lang.Throwable
设置多个视图字段的信息

参数：
_methodContext -
抛出：
java.lang.Throwable

changeViewFieldOrder

public void changeViewFieldOrder(MethodContext _methodContext)
                          throws java.lang.Throwable
改变视图字段的顺序

参数：
_methodContext -
抛出：
java.lang.Throwable

setViewEmployerByChannel

public void setViewEmployerByChannel(MethodContext _methodContext)
                              throws java.lang.Throwable
给指定栏目分配视图

参数：
_methodContext -
抛出：
java.lang.Throwable

findViewByChannel

public MetaView findViewByChannel(MethodContext _methodContext)
                           throws WCMException
参数：
_methodContext -
返回：
抛出：
WCMException

createViewRelation

public Reports createViewRelation(MethodContext _methodContext)
                           throws java.lang.Throwable
重新产生所有视图或者指定视图的应用

参数：
_methodContext -
抛出：
java.lang.Throwable

saveSynRule

public void saveSynRule(MethodContext _methodContext)
                 throws java.lang.Throwable
为栏目设置同步文档的规则

参数：
_methodContext -
抛出：
java.lang.Throwable

findSynRule

public java.lang.String findSynRule(MethodContext _methodContext)
                             throws java.lang.Throwable
为栏目设置同步文档的规则

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable

recreateAllOfDBTableInfo

public void recreateAllOfDBTableInfo(MethodContext _methodContext)
                              throws java.lang.Throwable
抛出：
java.lang.Throwable

buildAllFromTextFile

public java.lang.String buildAllFromTextFile(MethodContext _methodContext)
                                      throws java.lang.Throwable
根据文本文件的定义，创建系统

参数：
_methodContext -
抛出：
java.lang.Throwable

exportViews

public java.lang.String exportViews(MethodContext _oMethodContext)
                             throws WCMException
导出指定的视图

参数：
_oMethodContext -
返回：
抛出：
WCMException

importViewsFromXML

public Reports importViewsFromXML(MethodContext _oMethodContext)
                           throws WCMException
从系统导出的XML创建视图（包括元数据表）

参数：
_oMethodContext -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaViewImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 MetaViewImporter

java.lang.Object
    继承者  com.trs.components.metadata.service.MetaViewImporter

public class MetaViewImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
视图定义导入器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MetaViewImporter(User _currUser, MetaView _view)
方法摘要
 MetaView importFromXML(java.lang.String _sXML)
从一个XML中导入视图的定义
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewImporter

public MetaViewImporter(User _currUser,
                        MetaView _view)
方法详细信息

importFromXML

public MetaView importFromXML(java.lang.String _sXML)
                       throws java.lang.Exception
从一个XML中导入视图的定义

参数：
_sXML -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectsIterator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ObjectsIterator

java.lang.Object
    继承者  com.trs.components.metadata.service.ObjectsIterator

public abstract class ObjectsIterator
extends java.lang.Object

遍历对象的时候，执行一定的处理，如用于递归迭代中，对每个元素进行必要的处理。

作者：
huxiejin

构造方法摘要
ObjectsIterator()
方法摘要
boolean | accept(java.lang.Object _object) 判断当前传入的对象是否满足一定的条件
abstract void | execute(java.lang.Object _object) 对当前传入的对象执行一定的处理
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectsIterator

public ObjectsIterator()
方法详细信息

accept

public boolean accept(java.lang.Object _object)
               throws java.lang.Exception
判断当前传入的对象是否满足一定的条件

参数：
_object -
返回：
抛出：
java.lang.Exception

execute

public abstract void execute(java.lang.Object _object)
                      throws java.lang.Exception
对当前传入的对象执行一定的处理

参数：
_object -
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.service
接口
IDefaultChannelMaker
类
ClassInfoChannelRightHelper
ClassInfoPublishServiceProvider
ClassInfoServiceProvider
ClassInfoServiceProviderForGB
ClassInfoToChannelHelper
ClassInfoToGroupCreator
ClassInfoViewService
ClassInfoViewServiceProvider
DefaultChannelMakerCenter
GovInfoIndexCreator
GovInfoServiceProvider
GovInfoToXML
MailConfigsHelper
MetaDataCenterServiceProvider
MetaDataCenterServiceProviderForAgri
MetaDataCenterServiceProviderForGB
MetaDataCenterServiceProviderForZJH
MetaDataDefServiceProvider
MetaViewImporter
ObjectsIterator
SynChildrenExecutorForViewEmploy
UserRelateInfoMaker
ViewRangeConstants
WCMFilterMakerForContainsChildren


com.trs.components.metadata.service

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.service

接口摘要
IDefaultChannelMaker

类摘要
ClassInfoChannelRightHelper | Title: TRS 内容协作平台（TRS WCM） Description: 分类法产生的栏目权限维护工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoPublishServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 分类法发布服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoServiceProvider |
ClassInfoServiceProviderForGB |
ClassInfoToChannelHelper |
ClassInfoToGroupCreator |
ClassInfoViewService |
ClassInfoViewServiceProvider |
DefaultChannelMakerCenter | Title: TRS 内容协作平台（TRS WCM） Description: 值产生器配置信息读取服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GovInfoIndexCreator |
GovInfoServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
GovInfoToXML |
MailConfigsHelper |
MetaDataCenterServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataCenterServiceProviderForAgri | Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataCenterServiceProviderForGB | Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataCenterServiceProviderForZJH | Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataDefServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台定义服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewImporter | Title: TRS 内容协作平台（TRS WCM） Description: 视图定义导入器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectsIterator | 遍历对象的时候，执行一定的处理，如用于递归迭代中，对每个元素进行必要的处理。
SynChildrenExecutorForViewEmploy | Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UserRelateInfoMaker |
ViewRangeConstants |
WCMFilterMakerForContainsChildren | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.metadata.service 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.config.BaseConfigServer
        • com.trs.components.metadata.service.DefaultChannelMakerCenter
    • com.trs.components.metadata.service.ClassInfoChannelRightHelper
    • com.trs.components.metadata.service.ClassInfoPublishServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.ClassInfoServiceProvider (implements com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.ClassInfoServiceProviderForGB (implements com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.ClassInfoToChannelHelper
    • com.trs.components.metadata.service.ClassInfoToGroupCreator
    • com.trs.components.metadata.service.ClassInfoViewService
    • com.trs.components.metadata.service.ClassInfoViewServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.GovInfoIndexCreator (implements com.trs.components.metadata.center.IMetaDataFieldValueCreator)
    • com.trs.components.metadata.service.GovInfoServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.GovInfoToXML
    • com.trs.components.metadata.service.MailConfigsHelper
    • com.trs.components.metadata.service.MetaDataCenterServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.MetaDataDefServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.metadata.service.MetaViewImporter
    • com.trs.components.metadata.service.ObjectsIterator
    • com.trs.infra.persistent.util.SynChildrenExecutorBase
      • com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase
        • com.trs.components.metadata.service.SynChildrenExecutorForViewEmploy
        • com.trs.components.metadata.service.WCMFilterMakerForContainsChildren
    • com.trs.components.metadata.service.UserRelateInfoMaker (implements com.trs.components.metadata.service.IDefaultChannelMaker)
    • com.trs.components.metadata.service.ViewRangeConstants

接口分层结构

  • com.trs.components.metadata.service.IDefaultChannelMaker


软件包 com.trs.components.metadata.service 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service
的使用

使用 com.trs.components.metadata.service 的软件包
com.trs.components.metadata.service

com.trs.components.metadata.service 使用的 com.trs.components.metadata.service 中的类
DefaultChannelMakerCenter
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IDefaultChannelMaker

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SynChildrenExecutorForViewEmploy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 SynChildrenExecutorForViewEmploy

java.lang.Object
    继承者  com.trs.infra.persistent.util.SynChildrenExecutorBase
        继承者  com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase
            继承者  com.trs.components.metadata.service.SynChildrenExecutorForViewEmploy

public class SynChildrenExecutorForViewEmploy
extends SynChildrenOfChannelExecutorBase

Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SynChildrenExecutorForViewEmploy(BaseChannel _oStartObj, MetaView _view, boolean _bClearEmploy)
SynChildrenExecutorForViewEmploy(BaseChannel _oStartObj, MetaView _view, boolean _bClearEmploy, boolean _bDoOnStartObj)
方法摘要
从类 com.trs.infra.persistent.util.SynChildrenExecutorBase 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SynChildrenExecutorForViewEmploy

public SynChildrenExecutorForViewEmploy(BaseChannel _oStartObj,
                                        MetaView _view,
                                        boolean _bClearEmploy)
参数：
_oStartObj -

SynChildrenExecutorForViewEmploy

public SynChildrenExecutorForViewEmploy(BaseChannel _oStartObj,
                                        MetaView _view,
                                        boolean _bClearEmploy,
                                        boolean _bDoOnStartObj)
参数：
_oStartObj -
_bDoOnStartObj -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserRelateInfoMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 UserRelateInfoMaker

java.lang.Object
    继承者  com.trs.components.metadata.service.UserRelateInfoMaker
所有已实现的接口：
IDefaultChannelMaker
public class UserRelateInfoMaker
extends java.lang.Object
implements IDefaultChannelMaker

构造方法摘要
UserRelateInfoMaker()
方法摘要
Channel | makeDefaultChannel(User _loginUser, int _nViewId) 构造当前用户默认的栏目
static ClassInfo | makeDefaultClassInfo(java.lang.String _sDeptClassInfoRootName, User _currUser) 构造指定用户对应的机构分类
int[] | registerViewIds() 注册构造器相关的视图ID
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserRelateInfoMaker

public UserRelateInfoMaker()
方法详细信息

makeDefaultClassInfo

public static ClassInfo makeDefaultClassInfo(java.lang.String _sDeptClassInfoRootName,
                                             User _currUser)
                                      throws WCMException
构造指定用户对应的机构分类

参数：
_sDeptClassInfoRootName - 机构分类的根名称
_currUser - 指定用户
返回：
抛出：
WCMException

makeDefaultChannel

public Channel makeDefaultChannel(User _loginUser,
                                  int _nViewId)
                           throws WCMException
从接口 IDefaultChannelMaker 复制的描述
构造当前用户默认的栏目

指定者：
接口 IDefaultChannelMaker 中的 makeDefaultChannel
返回：
抛出：
WCMException

registerViewIds

public int[] registerViewIds()
从接口 IDefaultChannelMaker 复制的描述
注册构造器相关的视图ID

指定者：
接口 IDefaultChannelMaker 中的 registerViewIds
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewRangeConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 ViewRangeConstants

java.lang.Object
    继承者  com.trs.components.metadata.service.ViewRangeConstants

public class ViewRangeConstants
extends java.lang.Object

字段摘要
static int | ONLY_SELF 本栏目
static int | SAME_VIEW_CONTAIN_ALL 所有具有相同视图的栏目
static int | SAME_VIEW_CONTAIN_CHILDREN 本栏目及子栏目下所有具有相同视图的栏目
构造方法摘要
ViewRangeConstants()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ONLY_SELF

public static int ONLY_SELF
本栏目

SAME_VIEW_CONTAIN_CHILDREN

public static int SAME_VIEW_CONTAIN_CHILDREN
本栏目及子栏目下所有具有相同视图的栏目

SAME_VIEW_CONTAIN_ALL

public static int SAME_VIEW_CONTAIN_ALL
所有具有相同视图的栏目

构造方法详细信息

ViewRangeConstants

public ViewRangeConstants()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFilterMakerForContainsChildren

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service
类 WCMFilterMakerForContainsChildren

java.lang.Object
    继承者  com.trs.infra.persistent.util.SynChildrenExecutorBase
        继承者  com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase
            继承者  com.trs.components.metadata.service.WCMFilterMakerForContainsChildren

public class WCMFilterMakerForContainsChildren
extends SynChildrenOfChannelExecutorBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMFilterMakerForContainsChildren(BaseChannel _oStartObj)
WCMFilterMakerForContainsChildren(BaseChannel _oStartObj, boolean _bDoOnStartObj)
方法摘要
Channels | getCurrChannels()
WCMFilter | getCurrFilter()
从类 com.trs.infra.persistent.util.SynChildrenExecutorBase 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMFilterMakerForContainsChildren

public WCMFilterMakerForContainsChildren(BaseChannel _oStartObj)
参数：
_oStartObj -

WCMFilterMakerForContainsChildren

public WCMFilterMakerForContainsChildren(BaseChannel _oStartObj,
                                         boolean _bDoOnStartObj)
参数：
_oStartObj -
_bDoOnStartObj -
方法详细信息

getCurrFilter

public WCMFilter getCurrFilter()
返回：

getCurrChannels

public Channels getCurrChannels()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.metadata.service.ClassInfoChannelRightHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ClassInfoChannelRightHelper
的使用

没有 com.trs.components.metadata.service.ClassInfoChannelRightHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ClassInfoPublishServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ClassInfoPublishServiceProvider
的使用

没有 com.trs.components.metadata.service.ClassInfoPublishServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ClassInfoServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ClassInfoServiceProvider
的使用

没有 com.trs.components.metadata.service.ClassInfoServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB
的使用

没有 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ClassInfoToChannelHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ClassInfoToChannelHelper
的使用

没有 com.trs.components.metadata.service.ClassInfoToChannelHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ClassInfoToGroupCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ClassInfoToGroupCreator
的使用

没有 com.trs.components.metadata.service.ClassInfoToGroupCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ClassInfoViewService 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ClassInfoViewService
的使用

没有 com.trs.components.metadata.service.ClassInfoViewService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ClassInfoViewServiceProvider
的使用

没有 com.trs.components.metadata.service.ClassInfoViewServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.DefaultChannelMakerCenter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.DefaultChannelMakerCenter
的使用

使用 DefaultChannelMakerCenter 的软件包
com.trs.components.metadata.service

com.trs.components.metadata.service 中 DefaultChannelMakerCenter 的使用

返回 DefaultChannelMakerCenter 的 com.trs.components.metadata.service 中的方法
static DefaultChannelMakerCenter DefaultChannelMakerCenter.getInstance()
获取Center的实例

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.GovInfoIndexCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.GovInfoIndexCreator
的使用

没有 com.trs.components.metadata.service.GovInfoIndexCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.GovInfoServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.GovInfoServiceProvider
的使用

没有 com.trs.components.metadata.service.GovInfoServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.GovInfoToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.GovInfoToXML
的使用

没有 com.trs.components.metadata.service.GovInfoToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.service.IDefaultChannelMaker 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.service.IDefaultChannelMaker
的使用

使用 IDefaultChannelMaker 的软件包
com.trs.components.metadata.service

com.trs.components.metadata.service 中 IDefaultChannelMaker 的使用

实现 IDefaultChannelMaker 的 com.trs.components.metadata.service 中的类
 class UserRelateInfoMaker

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.MailConfigsHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.MailConfigsHelper
的使用

没有 com.trs.components.metadata.service.MailConfigsHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.MetaDataCenterServiceProvider
的使用

没有 com.trs.components.metadata.service.MetaDataCenterServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri
的使用

没有 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB
的使用

没有 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH
的使用

没有 com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.MetaDataDefServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.MetaDataDefServiceProvider
的使用

没有 com.trs.components.metadata.service.MetaDataDefServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.MetaViewImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.MetaViewImporter
的使用

没有 com.trs.components.metadata.service.MetaViewImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ObjectsIterator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ObjectsIterator
的使用

没有 com.trs.components.metadata.service.ObjectsIterator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.SynChildrenExecutorForViewEmploy 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.SynChildrenExecutorForViewEmploy
的使用

没有 com.trs.components.metadata.service.SynChildrenExecutorForViewEmploy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.UserRelateInfoMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.UserRelateInfoMaker
的使用

没有 com.trs.components.metadata.service.UserRelateInfoMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.ViewRangeConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.ViewRangeConstants
的使用

没有 com.trs.components.metadata.service.ViewRangeConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.WCMFilterMakerForContainsChildren 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.WCMFilterMakerForContainsChildren
的使用

没有 com.trs.components.metadata.service.WCMFilterMakerForContainsChildren 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


MetaViewEmplyerConverterForChannelImporter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service.domain
类 MetaViewEmplyerConverterForChannelImporter

java.lang.Object
    继承者  com.trs.components.metadata.service.domain.MetaViewEmplyerConverterForChannelImporter
所有已实现的接口：
IChannelImporterConverter
public class MetaViewEmplyerConverterForChannelImporter
extends java.lang.Object
implements IChannelImporterConverter

构造方法摘要
MetaViewEmplyerConverterForChannelImporter()
方法摘要
 void registerConverter(java.lang.Object _args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaViewEmplyerConverterForChannelImporter

public MetaViewEmplyerConverterForChannelImporter()
方法详细信息

registerConverter

public void registerConverter(java.lang.Object _args)
指定者：
接口 IChannelImporterConverter 中的 registerConverter
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.service.domain
类
MetaViewEmplyerConverterForChannelImporter


com.trs.components.metadata.service.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.service.domain

类摘要
MetaViewEmplyerConverterForChannelImporter


com.trs.components.metadata.service.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.service.domain.MetaViewEmplyerConverterForChannelImporter (implements com.trs.components.wcm.content.domain.IChannelImporterConverter)


软件包 com.trs.components.metadata.service.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.domain
的使用

没有 com.trs.components.metadata.service.domain 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.domain.MetaViewEmplyerConverterForChannelImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.domain.MetaViewEmplyerConverterForChannelImporter
的使用

没有 com.trs.components.metadata.service.domain.MetaViewEmplyerConverterForChannelImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChannelCreateFromListenerForMetaView

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service.listener
类 ChannelCreateFromListenerForMetaView

java.lang.Object
    继承者  com.trs.components.metadata.service.listener.ChannelCreateFromListenerForMetaView
所有已实现的接口：
IServiceListener
public class ChannelCreateFromListenerForMetaView
extends java.lang.Object
implements IServiceListener

构造方法摘要
ChannelCreateFromListenerForMetaView()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelCreateFromListenerForMetaView

public ChannelCreateFromListenerForMetaView()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig _oListenerConfig,
                                 MethodContext _oMethodContext,
                                 java.lang.Object _oServiceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
_oListenerConfig - 当前Lisntener的设置对象
_oMethodContext - 执行服务的当前上下文参数
_oServiceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.service.listener
类
ChannelCreateFromListenerForMetaView
PublishListenerForPubGovInfo
ViewDocumentListenerForPubGovInfo


com.trs.components.metadata.service.listener

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.service.listener

类摘要
ChannelCreateFromListenerForMetaView |
PublishListenerForPubGovInfo | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocumentListenerForPubGovInfo | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.metadata.service.listener 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.listener 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.service.listener.ChannelCreateFromListenerForMetaView (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.metadata.service.listener.PublishListenerForPubGovInfo (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.metadata.service.listener.ViewDocumentListenerForPubGovInfo (implements com.trs.webframework.provider.IServiceListener)


软件包 com.trs.components.metadata.service.listener 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.listener
的使用

没有 com.trs.components.metadata.service.listener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishListenerForPubGovInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service.listener
类 PublishListenerForPubGovInfo

java.lang.Object
    继承者  com.trs.components.metadata.service.listener.PublishListenerForPubGovInfo
所有已实现的接口：
IServiceListener
public class PublishListenerForPubGovInfo
extends java.lang.Object
implements IServiceListener

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishListenerForPubGovInfo()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishListenerForPubGovInfo

public PublishListenerForPubGovInfo()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig _oListenerConfig,
                                 MethodContext _oMethodContext,
                                 java.lang.Object _oServiceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
_oListenerConfig - 当前Lisntener的设置对象
_oMethodContext - 执行服务的当前上下文参数
_oServiceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewDocumentListenerForPubGovInfo

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service.listener
类 ViewDocumentListenerForPubGovInfo

java.lang.Object
    继承者  com.trs.components.metadata.service.listener.ViewDocumentListenerForPubGovInfo
所有已实现的接口：
IServiceListener
public class ViewDocumentListenerForPubGovInfo
extends java.lang.Object
implements IServiceListener

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ViewDocumentListenerForPubGovInfo()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ViewDocumentListenerForPubGovInfo

public ViewDocumentListenerForPubGovInfo()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig _oListenerConfig,
                                 MethodContext _oMethodContext,
                                 java.lang.Object _oServiceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
_oListenerConfig - 当前Lisntener的设置对象
_oMethodContext - 执行服务的当前上下文参数
_oServiceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.metadata.service.listener.ChannelCreateFromListenerForMetaView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.listener.ChannelCreateFromListenerForMetaView
的使用

没有 com.trs.components.metadata.service.listener.ChannelCreateFromListenerForMetaView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.listener.PublishListenerForPubGovInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.listener.PublishListenerForPubGovInfo
的使用

没有 com.trs.components.metadata.service.listener.PublishListenerForPubGovInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.listener.ViewDocumentListenerForPubGovInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.listener.ViewDocumentListenerForPubGovInfo
的使用

没有 com.trs.components.metadata.service.listener.ViewDocumentListenerForPubGovInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChannelPorterVisitorForMetaView

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service.portervisitors
类 ChannelPorterVisitorForMetaView

java.lang.Object
    继承者  com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView
所有已实现的接口：
IPorterVisitor
public class ChannelPorterVisitorForMetaView
extends java.lang.Object
implements IPorterVisitor

构造方法摘要
ChannelPorterVisitorForMetaView()
方法摘要
void | doExport(BaseObj _baseObj, java.lang.Object _extraArgs) 在导出_baseObj对象时,根据_baseObj对象做一些额外处理
void | doImport(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs) 在导入_baseObj对象时,根据当前xml串做一些额外处理
java.lang.String[] | registerTargetClassName()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelPorterVisitorForMetaView

public ChannelPorterVisitorForMetaView()
方法详细信息

doExport

public void doExport(BaseObj _baseObj,
                     java.lang.Object _extraArgs)
              throws java.lang.Exception
从接口 IPorterVisitor 复制的描述
在导出_baseObj对象时,根据_baseObj对象做一些额外处理

指定者：
接口 IPorterVisitor 中的 doExport
抛出：
java.lang.Exception

doImport

public void doImport(BaseObj _baseObj,
                     XmlObject _xmlObj,
                     java.lang.Object _extraArgs)
              throws java.lang.Exception
从接口 IPorterVisitor 复制的描述
在导入_baseObj对象时,根据当前xml串做一些额外处理

指定者：
接口 IPorterVisitor 中的 doImport
抛出：
java.lang.Exception

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IPorterVisitor 中的 registerTargetClassName
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.service.portervisitors
类
ChannelPorterVisitorForMetaView


com.trs.components.metadata.service.portervisitors

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.service.portervisitors

类摘要
ChannelPorterVisitorForMetaView


com.trs.components.metadata.service.portervisitors 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.portervisitors 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView (implements com.trs.components.wcm.content.service.portervisitors.IPorterVisitor)


软件包 com.trs.components.metadata.service.portervisitors 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.portervisitors
的使用

没有 com.trs.components.metadata.service.portervisitors 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView
的使用

没有 com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.metadata.service.util
类
WCMJSPChecker
WCMJSPCheckerTest


com.trs.components.metadata.service.util

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.service.util

类摘要
WCMJSPChecker | Title: TRS 内容协作平台（TRS WCM） Description: JSP正确性验证对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMJSPCheckerTest | Title: TRS 内容协作平台（TRS WCM） Description: 检查Jsp文件 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.metadata.service.util 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.trs.components.metadata.service.util.WCMJSPCheckerTest
    • com.trs.components.metadata.service.util.WCMJSPChecker


软件包 com.trs.components.metadata.service.util 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.util
的使用

没有 com.trs.components.metadata.service.util 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMJSPChecker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service.util
类 WCMJSPChecker

java.lang.Object
    继承者  com.trs.components.metadata.service.util.WCMJSPChecker

public class WCMJSPChecker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
JSP正确性验证对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMJSPChecker(java.lang.String jsprooturi)
WCMJSPChecker(java.lang.String _sApplicationRootPath, java.lang.String _sCheckPath, java.lang.String host, int port, java.lang.String _sApplicationName)
方法摘要
void | run()
void | setAuthDetail(java.lang.String username, java.lang.String password, java.lang.String authPage)
void | setResult(boolean needStore)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMJSPChecker

public WCMJSPChecker(java.lang.String jsprooturi)

WCMJSPChecker

public WCMJSPChecker(java.lang.String _sApplicationRootPath,
                     java.lang.String _sCheckPath,
                     java.lang.String host,
                     int port,
                     java.lang.String _sApplicationName)
方法详细信息

setAuthDetail

public void setAuthDetail(java.lang.String username,
                          java.lang.String password,
                          java.lang.String authPage)

setResult

public void setResult(boolean needStore)

run

public void run()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


WCMJSPCheckerTest

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service.util
类 WCMJSPCheckerTest

java.lang.Object
    继承者  junit.framework.Assert
        继承者  junit.framework.TestCase
            继承者  com.trs.components.metadata.service.util.WCMJSPCheckerTest
所有已实现的接口：
junit.framework.Test
public class WCMJSPCheckerTest
extends junit.framework.TestCase

Title: TRS 内容协作平台（TRS WCM）
Description:
检查Jsp文件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMJSPCheckerTest()
方法摘要
 void testJspFiles()
从类 junit.framework.TestCase 继承的方法
countTestCases, getName, run, run, runBare, setName, toString
从类 junit.framework.Assert 继承的方法
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

WCMJSPCheckerTest

public WCMJSPCheckerTest()
方法详细信息

testJspFiles

public void testJspFiles()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.metadata.service.util.WCMJSPChecker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.util.WCMJSPChecker
的使用

没有 com.trs.components.metadata.service.util.WCMJSPChecker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.service.util.WCMJSPCheckerTest 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.util.WCMJSPCheckerTest
的使用

没有 com.trs.components.metadata.service.util.WCMJSPCheckerTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.metadata.service.xmlconvertors
类
ViewDataToXML


com.trs.components.metadata.service.xmlconvertors

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.service.xmlconvertors

类摘要
ViewDataToXML Title: TRS 内容协作平台（TRS WCM）
Description:
ViewData的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.metadata.service.xmlconvertors 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.xmlconvertors 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.service.xmlconvertors.ViewDataToXML (implements com.trs.webframework.xmlserver.IXMLConvertor)


软件包 com.trs.components.metadata.service.xmlconvertors 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.service.xmlconvertors
的使用

没有 com.trs.components.metadata.service.xmlconvertors 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ViewDataToXML

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.service.xmlconvertors
类 ViewDataToXML

java.lang.Object
    继承者  com.trs.components.metadata.service.xmlconvertors.ViewDataToXML
所有已实现的接口：
IXMLConvertor
public class ViewDataToXML
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
ViewData的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ViewDataToXML()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ViewDataToXML

public ViewDataToXML()
方法详细信息

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.metadata.service.xmlconvertors.ViewDataToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.service.xmlconvertors.ViewDataToXML
的使用

没有 com.trs.components.metadata.service.xmlconvertors.ViewDataToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AbsHTMLMaker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web
类 AbsHTMLMaker

java.lang.Object
    继承者  com.trs.components.metadata.web.AbsHTMLMaker
所有已实现的接口：
HTMLMaker
直接已知子类：
DefaultHTMLMaker
public abstract class AbsHTMLMaker
extends java.lang.Object
implements HTMLMaker

构造方法摘要
AbsHTMLMaker()
方法摘要
FieldTemplate | getFieldTemplate() 获取视图字段的资源模板
MetaViewField | getViewField() 获取当前HTMLMaker关联的MetaViewField对象
void | setFieldTemplate(FieldTemplate _oFieldTemplate) 设置当前对象的视图字段资源模板
void | setViewField(MetaViewField _oViewField) 设置当前HTMLMaker关联的MetaViewField对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.metadata.web.HTMLMaker 继承的方法
getFieldTypes, makeHTML

构造方法详细信息

AbsHTMLMaker

public AbsHTMLMaker()
方法详细信息

getFieldTemplate

public FieldTemplate getFieldTemplate()
从接口 HTMLMaker 复制的描述
获取视图字段的资源模板

指定者：
接口 HTMLMaker 中的 getFieldTemplate
返回：

setFieldTemplate

public void setFieldTemplate(FieldTemplate _oFieldTemplate)
从接口 HTMLMaker 复制的描述
设置当前对象的视图字段资源模板

指定者：
接口 HTMLMaker 中的 setFieldTemplate

getViewField

public MetaViewField getViewField()
从接口 HTMLMaker 复制的描述
获取当前HTMLMaker关联的MetaViewField对象

指定者：
接口 HTMLMaker 中的 getViewField
返回：

setViewField

public void setViewField(MetaViewField _oViewField)
从接口 HTMLMaker 复制的描述
设置当前HTMLMaker关联的MetaViewField对象

指定者：
接口 HTMLMaker 中的 setViewField
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FieldTemplate

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web
类 FieldTemplate

java.lang.Object
    继承者  com.trs.components.metadata.web.FieldTemplate
直接已知子类：
AddEditFieldTemplate, ListFieldTemplate, ViewFieldTemplate
public abstract class FieldTemplate
extends java.lang.Object

字段摘要
static int otherTableFieldType
伪造的其它表视图字段类型
构造方法摘要
FieldTemplate()
方法摘要
 java.lang.String getTemplateContent(MetaViewField oViewField)
获取该视图字段对应的模板内容
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

otherTableFieldType

public static final int otherTableFieldType
伪造的其它表视图字段类型

另请参见：
常量字段值
构造方法详细信息

FieldTemplate

public FieldTemplate()
方法详细信息

getTemplateContent

public java.lang.String getTemplateContent(MetaViewField oViewField)
                                    throws WCMException
获取该视图字段对应的模板内容

参数：
oViewField -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web
接口 HTMLMaker

所有已知实现类：
AbsHTMLMaker, DefaultHTMLMaker
public interface HTMLMaker

方法摘要
FieldTemplate | getFieldTemplate() 获取视图字段的资源模板
int[] | getFieldTypes() 获取当前HTMLMaker需要处理的字段类型
MetaViewField | getViewField() 获取当前HTMLMaker关联的MetaViewField对象
java.lang.String | makeHTML() 返回解析之后的视图字段资源片段
void | setFieldTemplate(FieldTemplate _oFieldTemplate) 设置当前对象的视图字段资源模板
void | setViewField(MetaViewField oViewField) 设置当前HTMLMaker关联的MetaViewField对象

方法详细信息

makeHTML

java.lang.String makeHTML()
                          throws WCMException
返回解析之后的视图字段资源片段

返回：
抛出：
WCMException

getFieldTemplate

FieldTemplate getFieldTemplate()
获取视图字段的资源模板

返回：

setFieldTemplate

void setFieldTemplate(FieldTemplate _oFieldTemplate)
设置当前对象的视图字段资源模板

参数：
_oFieldTemplate -

getViewField

MetaViewField getViewField()
获取当前HTMLMaker关联的MetaViewField对象

返回：

setViewField

void setViewField(MetaViewField oViewField)
设置当前HTMLMaker关联的MetaViewField对象

getFieldTypes

int[] getFieldTypes()
获取当前HTMLMaker需要处理的字段类型

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLMakerFactory

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web
类 HTMLMakerFactory

java.lang.Object
    继承者  com.trs.components.metadata.web.HTMLMakerFactory

public class HTMLMakerFactory
extends java.lang.Object

构造方法摘要
HTMLMakerFactory()
方法摘要
static HTMLMaker | getHTMLMaker(int nFieldType) 根据视图字段的类型，返回指定的HTMLMaker
static void | register(int nFieldType, java.lang.Class objClass) 注册视图字段HTMLMaker
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLMakerFactory

public HTMLMakerFactory()
方法详细信息

register

public static void register(int nFieldType,
                            java.lang.Class objClass)
注册视图字段HTMLMaker

参数：
nFieldType -
objClass -

getHTMLMaker

public static HTMLMaker getHTMLMaker(int nFieldType)
根据视图字段的类型，返回指定的HTMLMaker

参数：
nFieldType -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.web
接口
HTMLMaker
类
AbsHTMLMaker
FieldTemplate
HTMLMakerFactory


com.trs.components.metadata.web

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.web

接口摘要
HTMLMaker

类摘要
AbsHTMLMaker
FieldTemplate
HTMLMakerFactory


com.trs.components.metadata.web 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.web 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.web.AbsHTMLMaker (implements com.trs.components.metadata.web.HTMLMaker)
    • com.trs.components.metadata.web.FieldTemplate
    • com.trs.components.metadata.web.HTMLMakerFactory

接口分层结构

  • com.trs.components.metadata.web.HTMLMaker


软件包 com.trs.components.metadata.web 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.web
的使用

使用 com.trs.components.metadata.web 的软件包
com.trs.components.metadata.web
com.trs.components.metadata.web.impl

com.trs.components.metadata.web 使用的 com.trs.components.metadata.web 中的类
FieldTemplate
HTMLMaker

com.trs.components.metadata.web.impl 使用的 com.trs.components.metadata.web 中的类
AbsHTMLMaker
FieldTemplate
HTMLMaker

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.web.AbsHTMLMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.web.AbsHTMLMaker
的使用

使用 AbsHTMLMaker 的软件包
com.trs.components.metadata.web.impl

com.trs.components.metadata.web.impl 中 AbsHTMLMaker 的使用

com.trs.components.metadata.web.impl 中 AbsHTMLMaker 的子类
 class DefaultHTMLMaker

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.web.FieldTemplate 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.web.FieldTemplate
的使用

使用 FieldTemplate 的软件包
com.trs.components.metadata.web
com.trs.components.metadata.web.impl

com.trs.components.metadata.web 中 FieldTemplate 的使用

返回 FieldTemplate 的 com.trs.components.metadata.web 中的方法
FieldTemplate | HTMLMaker.getFieldTemplate() 获取视图字段的资源模板
FieldTemplate | AbsHTMLMaker.getFieldTemplate()

参数类型为 FieldTemplate 的 com.trs.components.metadata.web 中的方法
void | HTMLMaker.setFieldTemplate(FieldTemplate _oFieldTemplate) 设置当前对象的视图字段资源模板
void | AbsHTMLMaker.setFieldTemplate(FieldTemplate _oFieldTemplate)

com.trs.components.metadata.web.impl 中 FieldTemplate 的使用

com.trs.components.metadata.web.impl 中 FieldTemplate 的子类
class | AddEditFieldTemplate
class | ListFieldTemplate
class | ViewFieldTemplate

返回 FieldTemplate 的 com.trs.components.metadata.web.impl 中的方法
static FieldTemplate FieldTemplateFactory.getFieldTemplate(java.lang.String sTemplateType)
根据视图资源类型，获取相应的视图资源模版

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.metadata.web.HTMLMaker 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.metadata.web.HTMLMaker
的使用

使用 HTMLMaker 的软件包
com.trs.components.metadata.web
com.trs.components.metadata.web.impl

com.trs.components.metadata.web 中 HTMLMaker 的使用

实现 HTMLMaker 的 com.trs.components.metadata.web 中的类
 class AbsHTMLMaker

返回 HTMLMaker 的 com.trs.components.metadata.web 中的方法
static HTMLMaker HTMLMakerFactory.getHTMLMaker(int nFieldType)
根据视图字段的类型，返回指定的HTMLMaker

com.trs.components.metadata.web.impl 中 HTMLMaker 的使用

实现 HTMLMaker 的 com.trs.components.metadata.web.impl 中的类
 class DefaultHTMLMaker

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.web.HTMLMakerFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.web.HTMLMakerFactory
的使用

没有 com.trs.components.metadata.web.HTMLMakerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AddEditFieldTemplate

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web.impl
类 AddEditFieldTemplate

java.lang.Object
    继承者  com.trs.components.metadata.web.FieldTemplate
        继承者  com.trs.components.metadata.web.impl.AddEditFieldTemplate

public class AddEditFieldTemplate
extends FieldTemplate

字段摘要
从类 com.trs.components.metadata.web.FieldTemplate 继承的字段
otherTableFieldType
构造方法摘要
AddEditFieldTemplate()
方法摘要
 java.lang.String getTemplatePath()
获取该视图字段模板内容存放的路径
从类 com.trs.components.metadata.web.FieldTemplate 继承的方法
getTemplateContent
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AddEditFieldTemplate

public AddEditFieldTemplate()
方法详细信息

getTemplatePath

public java.lang.String getTemplatePath()
从类 FieldTemplate 复制的描述
获取该视图字段模板内容存放的路径

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DefaultHTMLMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web.impl
类 DefaultHTMLMaker

java.lang.Object
    继承者  com.trs.components.metadata.web.AbsHTMLMaker
        继承者  com.trs.components.metadata.web.impl.DefaultHTMLMaker
所有已实现的接口：
HTMLMaker
public class DefaultHTMLMaker
extends AbsHTMLMaker

构造方法摘要
DefaultHTMLMaker()
方法摘要
int[] | getFieldTypes() 获取当前HTMLMaker需要处理的字段类型
java.lang.String | makeHTML() 返回解析之后的视图字段资源片段
从类 com.trs.components.metadata.web.AbsHTMLMaker 继承的方法
getFieldTemplate, getViewField, setFieldTemplate, setViewField
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultHTMLMaker

public DefaultHTMLMaker()
方法详细信息

getFieldTypes

public int[] getFieldTypes()
从接口 HTMLMaker 复制的描述
获取当前HTMLMaker需要处理的字段类型

返回：

makeHTML

public java.lang.String makeHTML()
                          throws WCMException
从接口 HTMLMaker 复制的描述
返回解析之后的视图字段资源片段

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldTemplateFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web.impl
类 FieldTemplateFactory

java.lang.Object
    继承者  com.trs.components.metadata.web.impl.FieldTemplateFactory

public class FieldTemplateFactory
extends java.lang.Object

字段摘要
static int | TEMPLATE_TYPE_ADDEDIT 新建修改页面类型的资源模板,addedit.hashCode
static int | TEMPLATE_TYPE_LSIT 列表页面类型的资源模板,list.hashCode
static int | TEMPLATE_TYPE_VIEW 查看页面类型的资源模板,view.hashCode
构造方法摘要
FieldTemplateFactory()
方法摘要
static FieldTemplate getFieldTemplate(java.lang.String sTemplateType)
根据视图资源类型，获取相应的视图资源模版
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TEMPLATE_TYPE_LSIT

public static final int TEMPLATE_TYPE_LSIT
列表页面类型的资源模板,list.hashCode

另请参见：
常量字段值

TEMPLATE_TYPE_ADDEDIT

public static final int TEMPLATE_TYPE_ADDEDIT
新建修改页面类型的资源模板,addedit.hashCode

另请参见：
常量字段值

TEMPLATE_TYPE_VIEW

public static final int TEMPLATE_TYPE_VIEW
查看页面类型的资源模板,view.hashCode

另请参见：
常量字段值
构造方法详细信息

FieldTemplateFactory

public FieldTemplateFactory()
方法详细信息

getFieldTemplate

public static FieldTemplate getFieldTemplate(java.lang.String sTemplateType)
根据视图资源类型，获取相应的视图资源模版

参数：
nTemplateType -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListFieldTemplate

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web.impl
类 ListFieldTemplate

java.lang.Object
    继承者  com.trs.components.metadata.web.FieldTemplate
        继承者  com.trs.components.metadata.web.impl.ListFieldTemplate

public class ListFieldTemplate
extends FieldTemplate

字段摘要
从类 com.trs.components.metadata.web.FieldTemplate 继承的字段
otherTableFieldType
构造方法摘要
ListFieldTemplate()
方法摘要
 java.lang.String getTemplatePath()
获取该视图字段模板内容存放的路径
从类 com.trs.components.metadata.web.FieldTemplate 继承的方法
getTemplateContent
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ListFieldTemplate

public ListFieldTemplate()
方法详细信息

getTemplatePath

public java.lang.String getTemplatePath()
从类 FieldTemplate 复制的描述
获取该视图字段模板内容存放的路径

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.metadata.web.impl
类
AddEditFieldTemplate
DefaultHTMLMaker
FieldTemplateFactory
ListFieldTemplate
ViewFieldTemplate


com.trs.components.metadata.web.impl

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.metadata.web.impl

类摘要
AddEditFieldTemplate
DefaultHTMLMaker
FieldTemplateFactory
ListFieldTemplate
ViewFieldTemplate


com.trs.components.metadata.web.impl 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.web.impl 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.metadata.web.AbsHTMLMaker (implements com.trs.components.metadata.web.HTMLMaker)
      • com.trs.components.metadata.web.impl.DefaultHTMLMaker
    • com.trs.components.metadata.web.FieldTemplate
      • com.trs.components.metadata.web.impl.AddEditFieldTemplate
      • com.trs.components.metadata.web.impl.ListFieldTemplate
      • com.trs.components.metadata.web.impl.ViewFieldTemplate
    • com.trs.components.metadata.web.impl.FieldTemplateFactory


软件包 com.trs.components.metadata.web.impl 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.metadata.web.impl
的使用

没有 com.trs.components.metadata.web.impl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ViewFieldTemplate

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.metadata.web.impl
类 ViewFieldTemplate

java.lang.Object
    继承者  com.trs.components.metadata.web.FieldTemplate
        继承者  com.trs.components.metadata.web.impl.ViewFieldTemplate

public class ViewFieldTemplate
extends FieldTemplate

字段摘要
从类 com.trs.components.metadata.web.FieldTemplate 继承的字段
otherTableFieldType
构造方法摘要
ViewFieldTemplate()
方法摘要
 java.lang.String getTemplatePath()
获取该视图字段模板内容存放的路径
从类 com.trs.components.metadata.web.FieldTemplate 继承的方法
getTemplateContent
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ViewFieldTemplate

public ViewFieldTemplate()
方法详细信息

getTemplatePath

public java.lang.String getTemplatePath()
从类 FieldTemplate 复制的描述
获取该视图字段模板内容存放的路径

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.metadata.web.impl.AddEditFieldTemplate 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.web.impl.AddEditFieldTemplate
的使用

没有 com.trs.components.metadata.web.impl.AddEditFieldTemplate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.web.impl.DefaultHTMLMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.web.impl.DefaultHTMLMaker
的使用

没有 com.trs.components.metadata.web.impl.DefaultHTMLMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.web.impl.FieldTemplateFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.web.impl.FieldTemplateFactory
的使用

没有 com.trs.components.metadata.web.impl.FieldTemplateFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.web.impl.ListFieldTemplate 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.web.impl.ListFieldTemplate
的使用

没有 com.trs.components.metadata.web.impl.ListFieldTemplate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.metadata.web.impl.ViewFieldTemplate 的使用

上一个 下一个 框架 无框架

类 com.trs.components.metadata.web.impl.ViewFieldTemplate
的使用

没有 com.trs.components.metadata.web.impl.ViewFieldTemplate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ISpecialMgr

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.special
接口 ISpecialMgr

所有已知实现类：
SpecialMgr
public interface ISpecialMgr

方法摘要
boolean | createFrom(Special _oSpecial) 根据源专题，类似创建新的专题
void | delete(User _curruser, Special _oSpecial) 删除指定的专题
boolean | existsSimilarName(int _nObjectId, java.lang.String _sSpecialName) 是否存在相同名称的专题
Special | findSpecialByChnlId(User _oUser, int _nChnlId) 根据栏目的Id，获取栏目对应的专题对象
PageStyle | getStyle(Special _oSpecial) 获取专题风格
Specials | query(User _oCurrUser, WCMFilter _currFilter) 查询符合当前条件的专题
Special | save(User _currUser, Special _currSpecial, java.lang.String _sSpecialSiteHttp) 保存当前专题
boolean | setStyle(Special _oSpecial, PageStyle _oPageStyle) 设置专题风格

方法详细信息

save

Special save(User _currUser,
             Special _currSpecial,
             java.lang.String _sSpecialSiteHttp)
             throws WCMException,
                    java.lang.Throwable
保存当前专题

参数：
_currUser - 当前操作的用户
_currSpecial - 当前专题
_sSpecialSiteHttp - 专题站点的发布路径
返回：
抛出：
WCMException
java.lang.Throwable

delete

void delete(User _curruser,
            Special _oSpecial)
            throws WCMException
删除指定的专题

参数：
_curruser - 当前删除的用户
_oSpecials - 将被删除的专题
抛出：
WCMException

query

Specials query(User _oCurrUser,
               WCMFilter _currFilter)
               throws WCMException
查询符合当前条件的专题

参数：
_curruser - 当前删除的用户
_currFilter - 额外的查询和排序条件
返回：
抛出：
WCMException

existsSimilarName

boolean existsSimilarName(int _nObjectId,
                          java.lang.String _sSpecialName)
                          throws java.lang.Exception
是否存在相同名称的专题

参数：
_nObjectId -
_sSpecialName - 当前专题的名称
返回：
抛出：
java.lang.Throwable
java.lang.Exception

setStyle

boolean setStyle(Special _oSpecial,
                 PageStyle _oPageStyle)
                 throws WCMException,
                        java.lang.Exception
设置专题风格

参数：
_oSpecial - 专题对象
_oPageStyle - 当前选中的页面风格
返回：
抛出：
WCMException
java.lang.Exception
java.lang.Throwable

getStyle

PageStyle getStyle(Special _oSpecial)
                   throws WCMException,
                          java.lang.Exception
获取专题风格

参数：
_oSpecial - 专题对象
返回：
PageStyle
抛出：
WCMException
java.lang.Exception

findSpecialByChnlId

Special findSpecialByChnlId(User _oUser,
                            int _nChnlId)
                            throws WCMException
根据栏目的Id，获取栏目对应的专题对象

参数：
_oUser - 当前登录用户
_nChnlId - 栏目Id
返回：
如果能够找到栏目对应的专题，则返回专题对象；否则返回null
抛出：
WCMException

createFrom

boolean createFrom(Special _oSpecial)
                   throws java.lang.Throwable
根据源专题，类似创建新的专题

参数：
_oSpecial - 专题对象
返回：
返回类似创建结果信息
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ISpecialServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.special
接口 ISpecialServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知实现类：
SpecialServiceProvider
public interface ISpecialServiceProvider
extends IGlueServiceProvider

方法摘要
boolean | createFrom(MethodContext _methodContext) 专题的类似创建
void | delete(MethodContext _context) 删除指定ID序列的专题
boolean | existsSimilarName(MethodContext _methodContext) 是否存在相同名称的专题
PageStyle | getStyle(MethodContext _methodContext) 获取专题页面风格
java.lang.Object | query(MethodContext _context) 获取符合条件的专题
int | save(MethodContext _context) 保存当前专题对象
boolean | setStyle(MethodContext _methodContext) 设置专题页面风格
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

方法详细信息

save

int save(MethodContext _context)
         throws java.lang.Exception,
                java.lang.Throwable
保存当前专题对象

指定者：
接口 ISaveServiceProvider 中的 save
参数：
_context -
抛出：
java.lang.Exception
java.lang.Throwable

delete

void delete(MethodContext _context)
            throws java.lang.Exception
删除指定ID序列的专题

指定者：
接口 IDeleteServiceProvider 中的 delete
参数：
_context -
抛出：
java.lang.Exception

query

java.lang.Object query(MethodContext _context)
                       throws java.lang.Exception
获取符合条件的专题

指定者：
接口 IQueryServiceProvider 中的 query
参数：
_context -
返回：
抛出：
java.lang.Exception

existsSimilarName

boolean existsSimilarName(MethodContext _methodContext)
                          throws java.lang.Exception
是否存在相同名称的专题

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable
java.lang.Exception

setStyle

boolean setStyle(MethodContext _methodContext)
                 throws java.lang.Exception,
                        java.lang.Throwable
设置专题页面风格

参数：
_methodContext -
返回：
抛出：
java.lang.Throwable
java.lang.Throwable
java.lang.Exception

getStyle

PageStyle getStyle(MethodContext _methodContext)
                   throws java.lang.Exception
获取专题页面风格

参数：
_methodContext -
返回：
抛出：
java.lang.Exception

createFrom

boolean createFrom(MethodContext _methodContext)
                   throws java.lang.Exception,
                          java.lang.Throwable
专题的类似创建

参数：
_methodContext -
返回：
抛出：
java.lang.Exception
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.special
接口
ISpecialMgr
ISpecialServiceProvider
类
Special
SpecialMgr
Specials
SpecialServiceProvider


com.trs.components.special

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.special

接口摘要
ISpecialMgr
ISpecialServiceProvider

类摘要
Special |
SpecialMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
Specials |
SpecialServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn


com.trs.components.special 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.special 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.special.Special
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.special.Specials
    • com.trs.components.special.SpecialMgr (implements com.trs.components.special.ISpecialMgr)
    • com.trs.components.special.SpecialServiceProvider (implements com.trs.components.special.ISpecialServiceProvider)

接口分层结构

  • com.trs.webframework.provider.IServiceProvider
    • com.trs.webframework.provider.IDeleteServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.special.ISpecialServiceProvider
    • com.trs.webframework.provider.IFindByIdServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.special.ISpecialServiceProvider
    • com.trs.webframework.provider.IFindByIdsServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.special.ISpecialServiceProvider
    • com.trs.webframework.provider.IQueryServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.special.ISpecialServiceProvider
    • com.trs.webframework.provider.ISaveServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
        • com.trs.components.special.ISpecialServiceProvider
    • com.trs.webframework.provider.ISelfDefinedServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider)
        • com.trs.components.special.ISpecialServiceProvider
  • com.trs.components.special.ISpecialMgr


软件包 com.trs.components.special 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.special
的使用

使用 com.trs.components.special 的软件包
com.trs.components.common.publish.widget
com.trs.components.special

com.trs.components.common.publish.widget 使用的 com.trs.components.special 中的类
Special

com.trs.components.special 使用的 com.trs.components.special 中的类
ISpecialMgr
ISpecialServiceProvider
Special
Specials

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Special

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.special
类 Special

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.special.Special
所有已实现的接口：
java.lang.Cloneable
public class Special
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Special()
构造函数：保留默认接口
方法摘要
static Special | createNewInstance() 产生当前对象[Special]的实例
static Special | findById(int _nId) 提取指定ID的对象
static Special | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getHostId() 提取属性：HostId
int | getHostType() 提取属性：HostType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getMasterId() 提取属性：MasteId
java.lang.String | getSpecialDesc() 提取属性：SpecialDesc
java.lang.String | getSpecialName() 提取属性：SpecialName
java.lang.String | getStyleName() 提取属性：StyleName
java.lang.String | getViewThumb() 提取属性：ViewThumb
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setHostId(int _nHostId) 设置属性：HostId
boolean | setHostType(int _nHostType) 设置属性：HostType
boolean | setMasteId(int _nMasteId) 设置属性：MasteId
boolean | setSpecialDesc(java.lang.String _sSpecialDesc) 设置属性：SpecialDesc
boolean | setSpecialName(java.lang.String _sSpecialName) 设置属性：SpecialName
boolean | setStyleName(java.lang.String _sStyleName) 设置属性：StyleName
boolean | setViewThumb(java.lang.String _sViewThumb) 设置属性：ViewThumb
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Special

public Special()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getHostId

public int getHostId()
提取属性：HostId

返回：
HostId

setHostId

public boolean setHostId(int _nHostId)
                  throws WCMException
设置属性：HostId

参数：
_nHostId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostType

public int getHostType()
提取属性：HostType

返回：
HostType

setHostType

public boolean setHostType(int _nHostType)
                    throws WCMException
设置属性：HostType

参数：
_nHostType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSpecialName

public java.lang.String getSpecialName()
提取属性：SpecialName

返回：
SpecialName

setSpecialName

public boolean setSpecialName(java.lang.String _sSpecialName)
                       throws WCMException
设置属性：SpecialName

参数：
_sSpecialName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSpecialDesc

public java.lang.String getSpecialDesc()
提取属性：SpecialDesc

返回：
SpecialDesc

setSpecialDesc

public boolean setSpecialDesc(java.lang.String _sSpecialDesc)
                       throws WCMException
设置属性：SpecialDesc

参数：
_sSpecialDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewThumb

public java.lang.String getViewThumb()
提取属性：ViewThumb

返回：
ViewThumb

setViewThumb

public boolean setViewThumb(java.lang.String _sViewThumb)
                     throws WCMException
设置属性：ViewThumb

参数：
_sViewThumb - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStyleName

public java.lang.String getStyleName()
提取属性：StyleName

返回：
StyleName

setStyleName

public boolean setStyleName(java.lang.String _sStyleName)
                     throws WCMException
设置属性：StyleName

参数：
_sStyleName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMasterId

public int getMasterId()
提取属性：MasteId

返回：
MasteId

setMasteId

public boolean setMasteId(int _nMasteId)
                   throws WCMException
设置属性：MasteId

参数：
_nMasteId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final Special findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Special createNewInstance()
                                       throws WCMException
产生当前对象[Special]的实例

返回：
当前对象的实例[Special]
抛出：
WCMException

findByKey

public static final Special findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpecialMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.special
类 SpecialMgr

java.lang.Object
    继承者  com.trs.components.special.SpecialMgr
所有已实现的接口：
ISpecialMgr
public class SpecialMgr
extends java.lang.Object
implements ISpecialMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
${user}

字段摘要
static java.lang.String | SPEICAL_ROLENAME
static java.lang.String | SPEICAL_SITEDATAPATH
static java.lang.String | SPEICAL_SITENAME
构造方法摘要
SpecialMgr()
方法摘要
boolean | createFrom(Special special) 根据源专题，类似创建新的专题
void | delete(User _curruser, Special _special) 删除指定的专题
boolean | existsSimilarName(int _nObjectId, java.lang.String _specialName) 是否存在相同名称的专题
Special | findSpecialByChnlId(User _oUser, int _nChnlId) 根据栏目的Id，获取栏目对应的专题对象
PageStyle | getStyle(Special special) 获取专题风格
Specials | query(User _curruser, WCMFilter _filter) 查询符合当前条件的专题
Special | save(User _curruser, Special _special, java.lang.String _sSpecialSiteHttp) 保存当前专题
boolean | setStyle(Special special, PageStyle pageStyle) 设置专题风格
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SPEICAL_SITENAME

public static final java.lang.String SPEICAL_SITENAME
另请参见：
常量字段值

SPEICAL_ROLENAME

public static final java.lang.String SPEICAL_ROLENAME
另请参见：
常量字段值

SPEICAL_SITEDATAPATH

public static final java.lang.String SPEICAL_SITEDATAPATH
另请参见：
常量字段值
构造方法详细信息

SpecialMgr

public SpecialMgr()
方法详细信息

delete

public void delete(User _curruser,
                   Special _special)
            throws WCMException
从接口 ISpecialMgr 复制的描述
删除指定的专题

指定者：
接口 ISpecialMgr 中的 delete
参数：
_curruser - 当前删除的用户
抛出：
WCMException

save

public Special save(User _curruser,
                    Special _special,
                    java.lang.String _sSpecialSiteHttp)
             throws java.lang.Throwable
从接口 ISpecialMgr 复制的描述
保存当前专题

指定者：
接口 ISpecialMgr 中的 save
参数：
_curruser - 当前操作的用户
_special - 当前专题
_sSpecialSiteHttp - 专题站点的发布路径
返回：
抛出：
WCMException
java.lang.Throwable

query

public Specials query(User _curruser,
                      WCMFilter _filter)
               throws WCMException
从接口 ISpecialMgr 复制的描述
查询符合当前条件的专题

指定者：
接口 ISpecialMgr 中的 query
_filter - 额外的查询和排序条件
返回：
抛出：
WCMException

existsSimilarName

public boolean existsSimilarName(int _nObjectId,
                                 java.lang.String _specialName)
                          throws java.lang.Exception
从接口 ISpecialMgr 复制的描述
是否存在相同名称的专题

指定者：
接口 ISpecialMgr 中的 existsSimilarName
_specialName - 当前专题的名称
返回：
抛出：
java.lang.Exception

setStyle

public boolean setStyle(Special special,
                        PageStyle pageStyle)
                 throws java.lang.Exception
从接口 ISpecialMgr 复制的描述
设置专题风格

指定者：
接口 ISpecialMgr 中的 setStyle
参数：
special - 专题对象
pageStyle - 当前选中的页面风格
返回：
抛出：
WCMException
java.lang.Exception

getStyle

public PageStyle getStyle(Special special)
                   throws java.lang.Exception
从接口 ISpecialMgr 复制的描述
获取专题风格

指定者：
接口 ISpecialMgr 中的 getStyle
参数：
special - 专题对象
返回：
PageStyle
抛出：
WCMException
java.lang.Exception

findSpecialByChnlId

public Special findSpecialByChnlId(User _oUser,
                                   int _nChnlId)
                            throws WCMException
从接口 ISpecialMgr 复制的描述
根据栏目的Id，获取栏目对应的专题对象

指定者：
接口 ISpecialMgr 中的 findSpecialByChnlId
参数：
_oUser - 当前登录用户
_nChnlId - 栏目Id
返回：
如果能够找到栏目对应的专题，则返回专题对象；否则返回null
抛出：
WCMException

createFrom

public boolean createFrom(Special special)
                   throws java.lang.Throwable
从接口 ISpecialMgr 复制的描述
根据源专题，类似创建新的专题

指定者：
接口 ISpecialMgr 中的 createFrom
参数：
special - 专题对象
返回：
返回类似创建结果信息
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Specials

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.special
类 Specials

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.special.Specials

public class Specials
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Specials(User _currUser)
构造函数
Specials(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Specials | createNewInstance(User _currUser) 产生当前集合对象[Specials]的实例
static Specials | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Specials | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Specials]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Specials

public Specials(User _currUser)
构造函数

另请参见：
Specials( User _currUser, int _initCapacity, int _incCapacity );

Specials

public Specials(User _currUser,
                int _initCapacity,
                int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final Specials findByIds(User _currUser,
                                       java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Specials）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Specials openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[Specials]

参数：
_filter - 指定的Filter
返回：
当前集合[Specials]
抛出：
WCMException

createNewInstance

public static Specials createNewInstance(User _currUser)
产生当前集合对象[Specials]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpecialServiceProvider

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.special
类 SpecialServiceProvider

java.lang.Object
    继承者  com.trs.components.special.SpecialServiceProvider
所有已实现的接口：
ISpecialServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class SpecialServiceProvider
extends java.lang.Object
implements ISpecialServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
${user}

构造方法摘要
SpecialServiceProvider()
方法摘要
boolean | createFrom(MethodContext _context) 专题的类似创建
void | delete(MethodContext _context) 删除指定ID序列的专题
boolean | existsSimilarName(MethodContext _context) 是否存在相同名称的专题
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
PageStyle | getStyle(MethodContext _context) 获取专题页面风格
java.lang.Object | query(MethodContext _context) 获取符合条件的专题
int | save(MethodContext _context) 保存当前专题对象
boolean | setStyle(MethodContext _context) 设置专题页面风格
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SpecialServiceProvider

public SpecialServiceProvider()
方法详细信息

delete

public void delete(MethodContext _context)
            throws java.lang.Exception
从接口 ISpecialServiceProvider 复制的描述
删除指定ID序列的专题

指定者：
接口 ISpecialServiceProvider 中的 delete
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Exception

existsSimilarName

public boolean existsSimilarName(MethodContext _context)
                          throws java.lang.Exception
从接口 ISpecialServiceProvider 复制的描述
是否存在相同名称的专题

指定者：
接口 ISpecialServiceProvider 中的 existsSimilarName
返回：
抛出：
java.lang.Exception

query

public java.lang.Object query(MethodContext _context)
                       throws java.lang.Exception
从接口 ISpecialServiceProvider 复制的描述
获取符合条件的专题

指定者：
接口 ISpecialServiceProvider 中的 query
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Exception

save

public int save(MethodContext _context)
         throws java.lang.Throwable
从接口 ISpecialServiceProvider 复制的描述
保存当前专题对象

指定者：
接口 ISpecialServiceProvider 中的 save
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

setStyle

public boolean setStyle(MethodContext _context)
                 throws java.lang.Throwable
从接口 ISpecialServiceProvider 复制的描述
设置专题页面风格

指定者：
接口 ISpecialServiceProvider 中的 setStyle
返回：
抛出：
java.lang.Throwable

getStyle

public PageStyle getStyle(MethodContext _context)
                   throws java.lang.Exception
从接口 ISpecialServiceProvider 复制的描述
获取专题页面风格

指定者：
接口 ISpecialServiceProvider 中的 getStyle
返回：
抛出：
java.lang.Exception

createFrom

public boolean createFrom(MethodContext _context)
                   throws java.lang.Throwable
从接口 ISpecialServiceProvider 复制的描述
专题的类似创建

指定者：
接口 ISpecialServiceProvider 中的 createFrom
返回：
抛出：
java.lang.Exception
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.special.ISpecialMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.special.ISpecialMgr
的使用

使用 ISpecialMgr 的软件包
com.trs.components.special

com.trs.components.special 中 ISpecialMgr 的使用

实现 ISpecialMgr 的 com.trs.components.special 中的类
 class SpecialMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.special.ISpecialServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.special.ISpecialServiceProvider
的使用

使用 ISpecialServiceProvider 的软件包
com.trs.components.special

com.trs.components.special 中 ISpecialServiceProvider 的使用

实现 ISpecialServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.special.Special 的使用

上一个 下一个 框架 无框架

类 com.trs.components.special.Special
的使用

使用 Special 的软件包
com.trs.components.common.publish.widget
com.trs.components.special

com.trs.components.common.publish.widget 中 Special 的使用

参数类型为 Special 的 com.trs.components.common.publish.widget 中的方法
void | IWidgetServer.insertStyleTag(Special special, Template template) 专题设置页面风格时所触发的逻辑，将专题所属的首页模板插入含当前页面风格标识的置标，发布时完成风格的切换
void | WidgetServer.insertStyleTag(Special special, Template template)

com.trs.components.special 中 Special 的使用

返回 Special 的 com.trs.components.special 中的方法
static Special | Special.createNewInstance() 产生当前对象[Special]的实例
static Special | Special.findById(int _nId) 提取指定ID的对象
static Special | Special.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Special | SpecialMgr.findSpecialByChnlId(User _oUser, int _nChnlId)
Special | ISpecialMgr.findSpecialByChnlId(User _oUser, int _nChnlId) 根据栏目的Id，获取栏目对应的专题对象
Special | SpecialMgr.save(User _curruser, Special _special, java.lang.String _sSpecialSiteHttp)
Special | ISpecialMgr.save(User _currUser, Special _currSpecial, java.lang.String _sSpecialSiteHttp) 保存当前专题

参数类型为 Special 的 com.trs.components.special 中的方法
boolean | SpecialMgr.createFrom(Special special)
boolean | ISpecialMgr.createFrom(Special _oSpecial) 根据源专题，类似创建新的专题
void | SpecialMgr.delete(User _curruser, Special _special)
void | ISpecialMgr.delete(User _curruser, Special _oSpecial) 删除指定的专题
PageStyle | SpecialMgr.getStyle(Special special)
PageStyle | ISpecialMgr.getStyle(Special _oSpecial) 获取专题风格
Special | SpecialMgr.save(User _curruser, Special _special, java.lang.String _sSpecialSiteHttp)
Special | ISpecialMgr.save(User _currUser, Special _currSpecial, java.lang.String _sSpecialSiteHttp) 保存当前专题
boolean | SpecialMgr.setStyle(Special special, PageStyle pageStyle)
boolean | ISpecialMgr.setStyle(Special _oSpecial, PageStyle _oPageStyle) 设置专题风格

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.special.SpecialMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.special.SpecialMgr
的使用

没有 com.trs.components.special.SpecialMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.special.Specials 的使用

上一个 下一个 框架 无框架

类 com.trs.components.special.Specials
的使用

使用 Specials 的软件包
com.trs.components.special

com.trs.components.special 中 Specials 的使用

返回 Specials 的 com.trs.components.special 中的方法
static Specials | Specials.createNewInstance(User _currUser) 产生当前集合对象[Specials]的实例
static Specials | Specials.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Specials | Specials.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Specials]
Specials | SpecialMgr.query(User _curruser, WCMFilter _filter)
Specials | ISpecialMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询符合当前条件的专题

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.special.SpecialServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.special.SpecialServiceProvider
的使用

没有 com.trs.components.special.SpecialServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseStatHandler

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 BaseStatHandler

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
所有已实现的接口：
IKeyMaker, IStatHandler
直接已知子类：
DefaultStatHandler, DocStatHandler4Channel, DocStatHandler4ChannelOfGroup, DocstatHandler4ChannelOfUser, DocStatHandler4ChnlDept, DocStatHandler4ChnlDeptChannel, DocStatHandler4ChnlDeptSite, DocStatHandler4SiteOfGroup, DocstatHandler4SiteOfUser, DocStatHandler4UserChannel, DocStatHandler4UserDept, DocStatHandler4UserDeptChannel, DocStatHandler4UserDeptSite, DocStatHandler4UserSite, HitsStatHandler4Channel, HitsStatHandler4ChnlDept, HitsStatHandler4User, HitsStatHandler4UserDept
public abstract class BaseStatHandler
extends java.lang.Object
implements IStatHandler, IKeyMaker

屏蔽key构造及反解的细节；屏蔽统计结果的数据存储结构

作者：
Administrator

构造方法摘要
BaseStatHandler()
方法摘要
IStatResult | getResult() 返回visitStatItem累积之后的结果集
void | initState() 由于统计Handler处理过程中，需要累积状态，为了能够重复利用此handler，需要在此接口中对已经累积的状态进行清零处理
java.lang.String[] | makeFields(java.lang.String sKey) 将sKey信息反解成统计SQL中的Select字段数组
java.lang.String | makeKey(java.lang.String[] keys) 将keys信息构造成相应的Key
void | visitEnd(int nSQLIndex) 在遍历完所有统计结果之后，需要执行的处理
void | visitStart(java.sql.ResultSet resultSet, int nSQLIndex) 在遍历每一条统计处理之前，需要执行的处理
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.stat.IStatHandler 继承的方法
visitStatItem

构造方法详细信息

BaseStatHandler

public BaseStatHandler()
方法详细信息

initState

public void initState()
从接口 IStatHandler 复制的描述
由于统计Handler处理过程中，需要累积状态，为了能够重复利用此handler，需要在此接口中对已经累积的状态进行清零处理

指定者：
接口 IStatHandler 中的 initState

getResult

public IStatResult getResult()
从接口 IStatHandler 复制的描述
返回visitStatItem累积之后的结果集

指定者：
接口 IStatHandler 中的 getResult
返回：

makeKey

public java.lang.String makeKey(java.lang.String[] keys)
将keys信息构造成相应的Key

指定者：
接口 IKeyMaker 中的 makeKey
参数：
keys -
返回：
抛出：
WCMException

makeFields

public java.lang.String[] makeFields(java.lang.String sKey)
将sKey信息反解成统计SQL中的Select字段数组

指定者：
接口 IKeyMaker 中的 makeFields
参数：
resultSet -
返回：

visitEnd

public void visitEnd(int nSQLIndex)
从接口 IStatHandler 复制的描述
在遍历完所有统计结果之后，需要执行的处理

指定者：
接口 IStatHandler 中的 visitEnd
参数：
nSQLIndex - 当前执行的第几条SQL索引

visitStart

public void visitStart(java.sql.ResultSet resultSet,
                       int nSQLIndex)
                throws WCMException
从接口 IStatHandler 复制的描述
在遍历每一条统计处理之前，需要执行的处理

指定者：
接口 IStatHandler 中的 visitStart
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BonusCalculator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 BonusCalculator

java.lang.Object
    继承者  com.trs.components.stat.BonusCalculator
所有已实现的接口：
IBonusCalculator
public class BonusCalculator
extends java.lang.Object
implements IBonusCalculator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
user1

构造方法摘要
BonusCalculator()
方法摘要
float | caclulateHitsBonus(int _nHitsCount) 根据点击量，计算点击量所获奖金
float | caclulateIssuedAmountBonus(int _nDocCount) 根据发稿量，计算发稿量所获奖金
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BonusCalculator

public BonusCalculator()
方法详细信息

caclulateIssuedAmountBonus

public float caclulateIssuedAmountBonus(int _nDocCount)
                                 throws WCMException
根据发稿量，计算发稿量所获奖金

指定者：
接口 IBonusCalculator 中的 caclulateIssuedAmountBonus
参数：
nDocCount - 发稿量
返回：
发稿量所获奖金
抛出：
WCMException

caclulateHitsBonus

public float caclulateHitsBonus(int _nHitsCount)
                         throws WCMException
根据点击量，计算点击量所获奖金

指定者：
接口 IBonusCalculator 中的 caclulateHitsBonus
参数：
nHitsCount - 点击量
返回：
点击量所获奖金
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BonusRule

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 BonusRule

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.stat.BonusRule
所有已实现的接口：
java.lang.Cloneable
public class BonusRule
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | HITS_BONUS 点击量类型
static int | ISSUEDAMOUNT_BONUS 发稿量类型
static int | OBJ_TYPE 对象类型编号
构造方法摘要
BonusRule()
构造函数：保留默认接口
方法摘要
static BonusRule | createNewInstance() 产生当前对象[BonusRule]的实例
static BonusRule | findById(int _nId) 提取指定ID的对象
static BonusRule | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getBonusType() 提取属性：BonusType，奖金类型：其中1表示发稿量奖金，2表示点击量奖金
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
float | getPricePerUnit() 提取属性：PricePerUnit 单篇奖金
java.lang.String | getRange() 提取属性：Range 奖励范围，如0到500，用0,500表示
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setBonusType(int _nBonusType) 设置属性：BonusType。
boolean | setPricePerUnit(float _fPricePerUnit) 设置属性：PricePerUnit
boolean | setRange(java.lang.String _sRange) 设置属性：Range
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

ISSUEDAMOUNT_BONUS

public static final int ISSUEDAMOUNT_BONUS
发稿量类型

另请参见：
常量字段值

HITS_BONUS

public static final int HITS_BONUS
点击量类型

另请参见：
常量字段值
构造方法详细信息

BonusRule

public BonusRule()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getBonusType

public int getBonusType()
提取属性：BonusType，奖金类型：其中1表示发稿量奖金，2表示点击量奖金

返回：
BonusType

setBonusType

public boolean setBonusType(int _nBonusType)
                     throws WCMException
设置属性：BonusType。

参数：
_nBonusType - 奖金类型，1表示发稿量奖金，2表示点击量奖金
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRange

public java.lang.String getRange()
提取属性：Range 奖励范围，如0到500，用0,500表示

返回：
Range

setRange

public boolean setRange(java.lang.String _sRange)
                 throws WCMException
设置属性：Range

参数：
_sRange - 奖励范围，如0到500，用0,500表示
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getPricePerUnit

public float getPricePerUnit()
提取属性：PricePerUnit 单篇奖金

返回：
PricePerUnit

setPricePerUnit

public boolean setPricePerUnit(float _fPricePerUnit)
                        throws WCMException
设置属性：PricePerUnit

参数：
_fPricePerUnit - 属性值，单篇奖金
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final BonusRule findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final BonusRule createNewInstance()
                                         throws WCMException
产生当前对象[BonusRule]的实例

返回：
当前对象的实例[BonusRule]
抛出：
WCMException

findByKey

public static final BonusRule findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BonusRuleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 BonusRuleMgr

java.lang.Object
    继承者  com.trs.components.stat.BonusRuleMgr
所有已实现的接口：
IBonusRuleMgr
public class BonusRuleMgr
extends java.lang.Object
implements IBonusRuleMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
奖励规则的业务逻辑处理类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
ffx

构造方法摘要
BonusRuleMgr()
方法摘要
boolean | delete(User _oCurrUser, BonusRules _oBonusRules) 删除指定的奖励规则
BonusRules | query(User _oCurrUser, WCMFilter _oFilter) 查询系统指定奖励规则
BonusRule | save(User _oCurrUser, BonusRule _oBonusRule)
BonusRule | save(User _oCurrUser, int _nBonusType, java.lang.String _sRange, float _fPricePerUnit) 保存当前奖励规则
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BonusRuleMgr

public BonusRuleMgr()
方法详细信息

delete

public boolean delete(User _oCurrUser,
                      BonusRules _oBonusRules)
               throws WCMException
删除指定的奖励规则

指定者：
接口 IBonusRuleMgr 中的 delete
参数：
_oCurrUser - 当前删除的用户
_oBonusRules - 将被删除的规则
返回：
抛出：
WCMException

query

public BonusRules query(User _oCurrUser,
                        WCMFilter _oFilter)
                 throws WCMException
查询系统指定奖励规则

指定者：
接口 IBonusRuleMgr 中的 query
参数：
_oCurrUser - 当前操作的用户
_currFilter - 额外的查询和排序条件
返回：
抛出：
WCMException

save

public BonusRule save(User _oCurrUser,
                      int _nBonusType,
                      java.lang.String _sRange,
                      float _fPricePerUnit)
               throws WCMException
保存当前奖励规则

指定者：
接口 IBonusRuleMgr 中的 save
参数：
_oCurrUser - 当前操作用户
_nBonusType - 奖金类型，1为发稿量奖金，2为点击率奖金
_sRange - 奖励范围，用逗号隔开的字符串表示，如0到500，使用“0,500”表示
_fPricePerUnit - 单篇奖金，用浮点数表示
返回：
保存的奖励规则
抛出：
WCMException

save

public BonusRule save(User _oCurrUser,
                      BonusRule _oBonusRule)
               throws WCMException
指定者：
接口 IBonusRuleMgr 中的 save
参数：
_oCurrUser - 当前操作的用户
_oCurrMaster - 当前奖励规则
返回：
当前保存的奖励规则
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BonusRules

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 BonusRules

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.stat.BonusRules

public class BonusRules
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
BonusRules(User _currUser)
构造函数
BonusRules(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static BonusRules | createNewInstance(User _currUser) 产生当前集合对象[BonusRules]的实例
static BonusRules | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static BonusRules | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[BonusRules]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BonusRules

public BonusRules(User _currUser)
构造函数

另请参见：
BonusRules( User _currUser, int _initCapacity, int _incCapacity );

BonusRules

public BonusRules(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final BonusRules findByIds(User _currUser,
                                         java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（BonusRules）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final BonusRules openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[BonusRules]

参数：
_filter - 指定的Filter
返回：
当前集合[BonusRules]
抛出：
WCMException

createNewInstance

public static BonusRules createNewInstance(User _currUser)
产生当前集合对象[BonusRules]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BonusRuleServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 BonusRuleServiceProvider

java.lang.Object
    继承者  com.trs.components.stat.BonusRuleServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class BonusRuleServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
奖励规则的服务层类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
ffx

构造方法摘要
BonusRuleServiceProvider()
方法摘要
void | delete(MethodContext context)
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.lang.Object | query(MethodContext context)
int | save(MethodContext context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BonusRuleServiceProvider

public BonusRuleServiceProvider()
方法详细信息

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelHitsCountHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 ChannelHitsCountHandler

java.lang.Object
    继承者  com.trs.components.stat.ChannelHitsCountHandler
所有已实现的接口：
IHitsCountHandler
public class ChannelHitsCountHandler
extends java.lang.Object
implements IHitsCountHandler

构造方法摘要
ChannelHitsCountHandler()
方法摘要
void | handle(BaseObj obj, java.util.Map properties) 更新指定对象obj的点击量
void | notifyComplete() 在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelHitsCountHandler

public ChannelHitsCountHandler()
方法详细信息

handle

public void handle(BaseObj obj,
                   java.util.Map properties)
            throws WCMException
从接口 IHitsCountHandler 复制的描述
更新指定对象obj的点击量

指定者：
接口 IHitsCountHandler 中的 handle
properties - 点击量相关信息
抛出：
WCMException

notifyComplete

public void notifyComplete()
从接口 IHitsCountHandler 复制的描述
在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。

指定者：
接口 IHitsCountHandler 中的 notifyComplete
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDept

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 ChnlDept

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.stat.ChnlDept
所有已实现的接口：
java.lang.Cloneable
public class ChnlDept
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ChnlDept()
构造函数：保留默认接口
方法摘要
static ChnlDept | createNewInstance() 产生当前对象[ChnlDept]的实例
static ChnlDept | findById(int _nId) 提取指定ID的对象
static ChnlDept | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getChannelId() 提取属性：ChannelId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getGroupId() 提取属性：GroupId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isContainsChildrenChnl() 提取属性：ContainsChildrenChnl
boolean | isValid() 检验对象数据有效性
boolean | setChannelId(int _nChannelId) 设置属性：ChannelId
boolean | setContainsChildrenChnl(boolean _bContainsChildrenChnl) 设置属性：ContainsChildrenChnl
boolean | setGroupId(int _nGroupId) 设置属性：GroupId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ChnlDept

public ChnlDept()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getChannelId

public int getChannelId()
提取属性：ChannelId

返回：
ChannelId

setChannelId

public boolean setChannelId(int _nChannelId)
                     throws WCMException
设置属性：ChannelId

参数：
_nChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getGroupId

public int getGroupId()
提取属性：GroupId

返回：
GroupId

setGroupId

public boolean setGroupId(int _nGroupId)
                   throws WCMException
设置属性：GroupId

参数：
_nGroupId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isContainsChildrenChnl

public boolean isContainsChildrenChnl()
提取属性：ContainsChildrenChnl

返回：
ContainsChildrenChnl

setContainsChildrenChnl

public boolean setContainsChildrenChnl(boolean _bContainsChildrenChnl)
                                throws WCMException
设置属性：ContainsChildrenChnl

参数：
_bContainsChildrenChnl - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final ChnlDept findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ChnlDept createNewInstance()
                                        throws WCMException
产生当前对象[ChnlDept]的实例

返回：
当前对象的实例[ChnlDept]
抛出：
WCMException

findByKey

public static final ChnlDept findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDeptMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 ChnlDeptMgr

java.lang.Object
    继承者  com.trs.components.stat.ChnlDeptMgr
所有已实现的接口：
IChnlDeptMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class ChnlDeptMgr
extends java.lang.Object
implements IChnlDeptMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
ffx

构造方法摘要
ChnlDeptMgr()
方法摘要
void | clear() 清除系统所有的Cache
java.util.List | getChnlIdsByDep(Group _group) 根据组织获取组织相关的栏目ID列表
java.lang.String | getChnlIdsByDepts(Groups groups) 通过组织集合查找所有组织相关的栏目
java.util.List | getDepIdsByChannel(Channel _channel) 通过栏目获取组织的ID序列
java.lang.String | getDepNamesByChannel(Channel _channel, User _user) 通过栏目或用户获取组织名称
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int eventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int eventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDeptMgr

public ChnlDeptMgr()
方法详细信息

getChnlIdsByDep

public java.util.List getChnlIdsByDep(Group _group)
                               throws WCMException
根据组织获取组织相关的栏目ID列表

指定者：
接口 IChnlDeptMgr 中的 getChnlIdsByDep
参数：
_group - 组织对象
返回：
栏目ID列表
抛出：
WCMException

getChnlIdsByDepts

public java.lang.String getChnlIdsByDepts(Groups groups)
                                   throws WCMException
通过组织集合查找所有组织相关的栏目

指定者：
接口 IChnlDeptMgr 中的 getChnlIdsByDepts
参数：
groups - 组织集合
返回：
组织相关的栏目ID序列
抛出：
WCMException

getDepIdsByChannel

public java.util.List getDepIdsByChannel(Channel _channel)
                                  throws WCMException
通过栏目获取组织的ID序列

指定者：
接口 IChnlDeptMgr 中的 getDepIdsByChannel
参数：
_channel - 栏目对象
返回：
组织的Id序列
抛出：
WCMException

getDepNamesByChannel

public java.lang.String getDepNamesByChannel(Channel _channel,
                                             User _user)
                                      throws WCMException
通过栏目或用户获取组织名称

指定者：
接口 IChnlDeptMgr 中的 getDepNamesByChannel
参数：
_channel - 栏目对象
_user - 用户对象
返回：
组织名称组成的字符串，如果没有关联组织，则返回“无”
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDeptMgrForCluster

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 ChnlDeptMgrForCluster

java.lang.Object
    继承者  com.trs.components.stat.ChnlDeptMgrForCluster
所有已实现的接口：
IClusterMsgReceiver
public class ChnlDeptMgrForCluster
extends java.lang.Object
implements IClusterMsgReceiver

Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDept缓冲处理.接收集群消息,根据相应的操作刷新缓冲.
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
ffx

构造方法摘要
ChnlDeptMgrForCluster()
方法摘要
void | receive(BaseObj _oEventObject, int _nEventType) 响应基于持久化对象拟定的消息
void | receive(java.lang.String content, java.lang.String[] parameters) 响应自定义协议的消息
java.lang.String[] | registerMoniterMessages() 注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
int[] | registerMoniterWCMObjTypesOnAdd() 当新增那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnDel() 当删除那些持久化对象时候触发操作
int[] | registerMoniterWCMObjTypesOnModify() 当修改那些持久化对象时候触发操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDeptMgrForCluster

public ChnlDeptMgrForCluster()
方法详细信息

receive

public void receive(BaseObj _oEventObject,
                    int _nEventType)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应基于持久化对象拟定的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

receive

public void receive(java.lang.String content,
                    java.lang.String[] parameters)
             throws java.lang.Exception
从接口 IClusterMsgReceiver 复制的描述
响应自定义协议的消息

指定者：
接口 IClusterMsgReceiver 中的 receive
抛出：
java.lang.Exception

registerMoniterMessages

public java.lang.String[] registerMoniterMessages()
从接口 IClusterMsgReceiver 复制的描述
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterMessages
返回：

registerMoniterWCMObjTypesOnAdd

public int[] registerMoniterWCMObjTypesOnAdd()
从接口 IClusterMsgReceiver 复制的描述
当新增那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnAdd
返回：

registerMoniterWCMObjTypesOnDel

public int[] registerMoniterWCMObjTypesOnDel()
从接口 IClusterMsgReceiver 复制的描述
当删除那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnDel
返回：

registerMoniterWCMObjTypesOnModify

public int[] registerMoniterWCMObjTypesOnModify()
从接口 IClusterMsgReceiver 复制的描述
当修改那些持久化对象时候触发操作

指定者：
接口 IClusterMsgReceiver 中的 registerMoniterWCMObjTypesOnModify
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDepts

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 ChnlDepts

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.stat.ChnlDepts

public class ChnlDepts
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ChnlDepts(User _currUser)
构造函数
ChnlDepts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ChnlDepts | createNewInstance(User _currUser) 产生当前集合对象[ChnlDepts]的实例
static ChnlDepts | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ChnlDepts | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChnlDepts]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDepts

public ChnlDepts(User _currUser)
构造函数

另请参见：
ChnlDepts( User _currUser, int _initCapacity, int _incCapacity );

ChnlDepts

public ChnlDepts(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ChnlDepts findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ChnlDepts）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ChnlDepts openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[ChnlDepts]

参数：
_filter - 指定的Filter
返回：
当前集合[ChnlDepts]
抛出：
WCMException

createNewInstance

public static ChnlDepts createNewInstance(User _currUser)
产生当前集合对象[ChnlDepts]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultStatHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DefaultStatHandler

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DefaultStatHandler
所有已实现的接口：
IKeyMaker, IStatHandler
public class DefaultStatHandler
extends BaseStatHandler

默认的统计处理类

作者：
Administrator

构造方法摘要
DefaultStatHandler()
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultStatHandler

public DefaultStatHandler()
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4Channel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4Channel

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4Channel
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4Channel
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wyw

构造方法摘要
DocStatHandler4Channel()
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int index)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4Channel

public DocStatHandler4Channel()
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int index)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
index - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4ChannelOfGroup

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4ChannelOfGroup

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4ChannelOfGroup
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4ChannelOfGroup
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wyw

构造方法摘要
DocStatHandler4ChannelOfGroup(int _nGroupId)
方法摘要
void | visitStart(java.sql.ResultSet resultSet, int nSQLIndex) 在遍历每一条统计处理之前，需要执行的处理
void | visitStatItem(java.sql.ResultSet resultSet, int index) 根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4ChannelOfGroup

public DocStatHandler4ChannelOfGroup(int _nGroupId)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int index)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
index - 当前执行的第几条SQL索引
抛出：
WCMException

visitStart

public void visitStart(java.sql.ResultSet resultSet,
                       int nSQLIndex)
                throws WCMException
从接口 IStatHandler 复制的描述
在遍历每一条统计处理之前，需要执行的处理

指定者：
接口 IStatHandler 中的 visitStart
覆盖：
类 BaseStatHandler 中的 visitStart
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocstatHandler4ChannelOfUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocstatHandler4ChannelOfUser

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocstatHandler4ChannelOfUser
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocstatHandler4ChannelOfUser
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wyw

构造方法摘要
DocstatHandler4ChannelOfUser(java.lang.String _sCrUser)
方法摘要
void | visitStart(java.sql.ResultSet resultSet, int nSQLIndex) 在遍历每一条统计处理之前，需要执行的处理
void | visitStatItem(java.sql.ResultSet resultSet, int index) 根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocstatHandler4ChannelOfUser

public DocstatHandler4ChannelOfUser(java.lang.String _sCrUser)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int index)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
index - 当前执行的第几条SQL索引
抛出：
WCMException

visitStart

public void visitStart(java.sql.ResultSet resultSet,
                       int nSQLIndex)
                throws WCMException
从接口 IStatHandler 复制的描述
在遍历每一条统计处理之前，需要执行的处理

指定者：
接口 IStatHandler 中的 visitStart
覆盖：
类 BaseStatHandler 中的 visitStart
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4ChnlDept

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4ChnlDept

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4ChnlDept
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4ChnlDept
extends BaseStatHandler

构造方法摘要
DocStatHandler4ChnlDept()
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4ChnlDept

public DocStatHandler4ChnlDept()
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4ChnlDeptChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4ChnlDeptChannel

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4ChnlDeptChannel
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4ChnlDeptChannel
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

构造方法摘要
DocStatHandler4ChnlDeptChannel(int _nChannelId)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4ChnlDeptChannel

public DocStatHandler4ChnlDeptChannel(int _nChannelId)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4ChnlDeptSite

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4ChnlDeptSite

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4ChnlDeptSite
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4ChnlDeptSite
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

构造方法摘要
DocStatHandler4ChnlDeptSite(int _nSiteId)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4ChnlDeptSite

public DocStatHandler4ChnlDeptSite(int _nSiteId)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4SiteOfGroup

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4SiteOfGroup

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4SiteOfGroup
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4SiteOfGroup
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wyw

构造方法摘要
DocStatHandler4SiteOfGroup(int _nGroupId)
方法摘要
void | visitStart(java.sql.ResultSet resultSet, int nSQLIndex) 在遍历每一条统计处理之前，需要执行的处理
void | visitStatItem(java.sql.ResultSet resultSet, int index) 根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4SiteOfGroup

public DocStatHandler4SiteOfGroup(int _nGroupId)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int index)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
index - 当前执行的第几条SQL索引
抛出：
WCMException

visitStart

public void visitStart(java.sql.ResultSet resultSet,
                       int nSQLIndex)
                throws WCMException
从接口 IStatHandler 复制的描述
在遍历每一条统计处理之前，需要执行的处理

指定者：
接口 IStatHandler 中的 visitStart
覆盖：
类 BaseStatHandler 中的 visitStart
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocstatHandler4SiteOfUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocstatHandler4SiteOfUser

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocstatHandler4SiteOfUser
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocstatHandler4SiteOfUser
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wyw

构造方法摘要
DocstatHandler4SiteOfUser(java.lang.String _sCrUser)
方法摘要
void | visitStart(java.sql.ResultSet resultSet, int nSQLIndex) 在遍历每一条统计处理之前，需要执行的处理
void | visitStatItem(java.sql.ResultSet resultSet, int index) 根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocstatHandler4SiteOfUser

public DocstatHandler4SiteOfUser(java.lang.String _sCrUser)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int index)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
index - 当前执行的第几条SQL索引
抛出：
WCMException

visitStart

public void visitStart(java.sql.ResultSet resultSet,
                       int nSQLIndex)
                throws WCMException
从接口 IStatHandler 复制的描述
在遍历每一条统计处理之前，需要执行的处理

指定者：
接口 IStatHandler 中的 visitStart
覆盖：
类 BaseStatHandler 中的 visitStart
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4UserChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4UserChannel

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4UserChannel
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4UserChannel
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

构造方法摘要
DocStatHandler4UserChannel(int _nChannelId)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4UserChannel

public DocStatHandler4UserChannel(int _nChannelId)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4UserDept

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4UserDept

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4UserDept
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4UserDept
extends BaseStatHandler

构造方法摘要
DocStatHandler4UserDept()
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4UserDept

public DocStatHandler4UserDept()
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4UserDeptChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4UserDeptChannel

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4UserDeptChannel
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4UserDeptChannel
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

构造方法摘要
DocStatHandler4UserDeptChannel(int _nChannelId)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4UserDeptChannel

public DocStatHandler4UserDeptChannel(int _nChannelId)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4UserDeptSite

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4UserDeptSite

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4UserDeptSite
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4UserDeptSite
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

构造方法摘要
DocStatHandler4UserDeptSite(int _nSiteId)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4UserDeptSite

public DocStatHandler4UserDeptSite(int _nSiteId)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocStatHandler4UserSite

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocStatHandler4UserSite

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.DocStatHandler4UserSite
所有已实现的接口：
IKeyMaker, IStatHandler
public class DocStatHandler4UserSite
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

构造方法摘要
DocStatHandler4UserSite(int _nSiteId)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocStatHandler4UserSite

public DocStatHandler4UserSite(int _nSiteId)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentHitsCount

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocumentHitsCount

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.stat.DocumentHitsCount
所有已实现的接口：
java.lang.Cloneable
public class DocumentHitsCount
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
DocumentHitsCount()
构造函数：保留默认接口
方法摘要
static DocumentHitsCount | createNewInstance() 产生当前对象[DocumentHitsCount]的实例
static DocumentHitsCount | findById(int _nId) 提取指定ID的对象
static DocumentHitsCount | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getChnlId() 提取属性：ChnlId 栏目ID
java.lang.String | getChnlName() 提取属性：ChnlName 栏目名称
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
CMyDateTime | getDocCrTime() 提取属性：DocCrTime 文档创建时间
java.lang.String | getDocCrUser() 提取属性：DocCrUser 文档创建者
int | getDocId() 提取属性：DocId 文档ID
java.lang.String | getDocTitle() 提取属性：DocTitle 文档标题
int | getHitsCount() 提取属性：HitsCount 点击量
CMyDateTime | getHitsTime() 提取属性：HitsTime 点击时间
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setChnlId(int _nChnlId) 设置属性：ChnlId 栏目ID
boolean | setChnlName(java.lang.String _sChnlName) 设置属性：ChnlName 栏目名称
boolean | setDocCrTime(CMyDateTime _dtDocCrTime) 设置属性：DocCrTime 文档创建时间
boolean | setDocCrUser(java.lang.String _sDocCrUser) 设置属性：DocCrUser 文档创建者
boolean | setDocId(int _nDocId) 设置属性：DocId 文档ID
boolean | setDocTitle(java.lang.String _sDocTitle) 设置属性：DocTitle 文档标题
boolean | setHitsCount(int _nHitsCount) 设置属性：HitsCount 点击量
boolean | setHitsTime(CMyDateTime _dtHitsTime) 设置属性：HitsTime 点击时间
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

DocumentHitsCount

public DocumentHitsCount()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getDocId

public int getDocId()
提取属性：DocId 文档ID

返回：
DocId

setDocId

public boolean setDocId(int _nDocId)
                 throws WCMException
设置属性：DocId 文档ID

参数：
_nDocId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocTitle

public java.lang.String getDocTitle()
提取属性：DocTitle 文档标题

返回：
DocTitle

setDocTitle

public boolean setDocTitle(java.lang.String _sDocTitle)
                    throws WCMException
设置属性：DocTitle 文档标题

参数：
_sDocTitle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getChnlId

public int getChnlId()
提取属性：ChnlId 栏目ID

返回：
ChnlId

setChnlId

public boolean setChnlId(int _nChnlId)
                  throws WCMException
设置属性：ChnlId 栏目ID

参数：
_nChnlId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getChnlName

public java.lang.String getChnlName()
提取属性：ChnlName 栏目名称

返回：
ChnlName

setChnlName

public boolean setChnlName(java.lang.String _sChnlName)
                    throws WCMException
设置属性：ChnlName 栏目名称

参数：
_sChnlName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocCrUser

public java.lang.String getDocCrUser()
提取属性：DocCrUser 文档创建者

返回：
DocCrUser

setDocCrUser

public boolean setDocCrUser(java.lang.String _sDocCrUser)
                     throws WCMException
设置属性：DocCrUser 文档创建者

参数：
_sDocCrUser - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocCrTime

public CMyDateTime getDocCrTime()
提取属性：DocCrTime 文档创建时间

返回：
DocCrTime

setDocCrTime

public boolean setDocCrTime(CMyDateTime _dtDocCrTime)
                     throws WCMException
设置属性：DocCrTime 文档创建时间

参数：
_dtDocCrTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHitsCount

public int getHitsCount()
提取属性：HitsCount 点击量

返回：
HitsCount

setHitsCount

public boolean setHitsCount(int _nHitsCount)
                     throws WCMException
设置属性：HitsCount 点击量

参数：
_nHitsCount - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHitsTime

public CMyDateTime getHitsTime()
提取属性：HitsTime 点击时间

返回：
HitsTime

setHitsTime

public boolean setHitsTime(CMyDateTime _dtHitsTime)
                    throws WCMException
设置属性：HitsTime 点击时间

参数：
_dtHitsTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final DocumentHitsCount findById(int _nId)
                                        throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final DocumentHitsCount createNewInstance()
                                                 throws WCMException
产生当前对象[DocumentHitsCount]的实例

返回：
当前对象的实例[DocumentHitsCount]
抛出：
WCMException

findByKey

public static final DocumentHitsCount findByKey(java.lang.Object _oKey)
                                         throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentHitsCountHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocumentHitsCountHandler

java.lang.Object
    继承者  com.trs.components.stat.DocumentHitsCountHandler
所有已实现的接口：
IHitsCountHandler
public class DocumentHitsCountHandler
extends java.lang.Object
implements IHitsCountHandler

处理文档对象的点击量更新

作者：
Administrator

构造方法摘要
DocumentHitsCountHandler()
方法摘要
void | handle(BaseObj obj, java.util.Map properties) 更新指定对象obj的点击量
void | notifyComplete() 在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentHitsCountHandler

public DocumentHitsCountHandler()
方法详细信息

handle

public void handle(BaseObj obj,
                   java.util.Map properties)
从接口 IHitsCountHandler 复制的描述
更新指定对象obj的点击量

指定者：
接口 IHitsCountHandler 中的 handle
properties - 点击量相关信息

notifyComplete

public void notifyComplete()
从接口 IHitsCountHandler 复制的描述
在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。

指定者：
接口 IHitsCountHandler 中的 notifyComplete
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentHitsCounts

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 DocumentHitsCounts

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.stat.DocumentHitsCounts

public class DocumentHitsCounts
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
DocumentHitsCounts(User _currUser)
构造函数
DocumentHitsCounts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static DocumentHitsCounts | createNewInstance(User _currUser) 产生当前集合对象[DocumentHitsCounts]的实例
static DocumentHitsCounts | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static DocumentHitsCounts | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocumentHitsCounts]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentHitsCounts

public DocumentHitsCounts(User _currUser)
构造函数

另请参见：
DocumentHitsCounts( User _currUser, int _initCapacity, int _incCapacity );

DocumentHitsCounts

public DocumentHitsCounts(User _currUser,
                          int _initCapacity,
                          int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final DocumentHitsCounts findByIds(User _currUser,
                                                 java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（DocumentHitsCounts）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final DocumentHitsCounts openWCMObjs(User _currUser,
                                                   WCMFilter _filter)
                                            throws WCMException
通过指定一个Filter获取当前集合[DocumentHitsCounts]

参数：
_filter - 指定的Filter
返回：
当前集合[DocumentHitsCounts]
抛出：
WCMException

createNewInstance

public static DocumentHitsCounts createNewInstance(User _currUser)
产生当前集合对象[DocumentHitsCounts]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsCountConstant

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HitsCountConstant

java.lang.Object
    继承者  com.trs.components.stat.HitsCountConstant

public class HitsCountConstant
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

字段摘要
static int | STAT_STEP_DAY
static int | STAT_STEP_MONTH
static int | STAT_STEP_YEAR
static int | TYPE_1DAY
static int | TYPE_1MONTH
static int | TYPE_1YEAR
static int | TYPE_3MONTH
static int | TYPE_ALL
构造方法摘要
HitsCountConstant()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_ALL

public static final int TYPE_ALL
另请参见：
常量字段值

TYPE_1DAY

public static final int TYPE_1DAY
另请参见：
常量字段值

TYPE_1MONTH

public static final int TYPE_1MONTH
另请参见：
常量字段值

TYPE_3MONTH

public static final int TYPE_3MONTH
另请参见：
常量字段值

TYPE_1YEAR

public static final int TYPE_1YEAR
另请参见：
常量字段值

STAT_STEP_DAY

public static final int STAT_STEP_DAY
另请参见：
常量字段值

STAT_STEP_MONTH

public static final int STAT_STEP_MONTH
另请参见：
常量字段值

STAT_STEP_YEAR

public static final int STAT_STEP_YEAR
另请参见：
常量字段值
构造方法详细信息

HitsCountConstant

public HitsCountConstant()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsCountHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HitsCountHelper

java.lang.Object
    继承者  com.trs.components.stat.HitsCountHelper

public class HitsCountHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

构造方法摘要
HitsCountHelper()
方法摘要
static java.lang.String[] | makeQueryComparedHitsTimeRands(int _nType) 构造比较的时间段
static java.lang.String[] | makeQueryHitsTimeRands(int _nType) 构造原时间段
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HitsCountHelper

public HitsCountHelper()
方法详细信息

makeQueryComparedHitsTimeRands

public static java.lang.String[] makeQueryComparedHitsTimeRands(int _nType)
                                                         throws CMyException
构造比较的时间段

参数：
_nType -
返回：
抛出：
CMyException

makeQueryHitsTimeRands

public static java.lang.String[] makeQueryHitsTimeRands(int _nType)
                                                 throws CMyException
构造原时间段

参数：
_nType -
返回：
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsCountParserSchedule

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HitsCountParserSchedule

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.common.job.BaseStatefulScheduleWorker
                继承者  com.trs.components.stat.HitsCountParserSchedule
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
public class HitsCountParserSchedule
extends BaseStatefulScheduleWorker

构造方法摘要
HitsCountParserSchedule()
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

HitsCountParserSchedule

public HitsCountParserSchedule()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsStatHandler4Channel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HitsStatHandler4Channel

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.HitsStatHandler4Channel
所有已实现的接口：
IKeyMaker, IStatHandler
public class HitsStatHandler4Channel
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

构造方法摘要
HitsStatHandler4Channel()
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HitsStatHandler4Channel

public HitsStatHandler4Channel()
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsStatHandler4ChnlDept

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HitsStatHandler4ChnlDept

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.HitsStatHandler4ChnlDept
所有已实现的接口：
IKeyMaker, IStatHandler
public class HitsStatHandler4ChnlDept
extends BaseStatHandler

构造方法摘要
HitsStatHandler4ChnlDept()
HitsStatHandler4ChnlDept(Channels currhannels)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HitsStatHandler4ChnlDept

public HitsStatHandler4ChnlDept()

HitsStatHandler4ChnlDept

public HitsStatHandler4ChnlDept(Channels currhannels)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsStatHandler4User

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HitsStatHandler4User

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.HitsStatHandler4User
所有已实现的接口：
IKeyMaker, IStatHandler
public class HitsStatHandler4User
extends BaseStatHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

构造方法摘要
HitsStatHandler4User()
HitsStatHandler4User(Documents currDocs)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HitsStatHandler4User

public HitsStatHandler4User()

HitsStatHandler4User

public HitsStatHandler4User(Documents currDocs)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsStatHandler4UserDept

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HitsStatHandler4UserDept

java.lang.Object
    继承者  com.trs.components.stat.BaseStatHandler
        继承者  com.trs.components.stat.HitsStatHandler4UserDept
所有已实现的接口：
IKeyMaker, IStatHandler
public class HitsStatHandler4UserDept
extends BaseStatHandler

构造方法摘要
HitsStatHandler4UserDept()
HitsStatHandler4UserDept(Documents currDocs)
方法摘要
 void visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
从类 com.trs.components.stat.BaseStatHandler 继承的方法
getResult, initState, makeFields, makeKey, visitEnd, visitStart
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HitsStatHandler4UserDept

public HitsStatHandler4UserDept()

HitsStatHandler4UserDept

public HitsStatHandler4UserDept(Documents currDocs)
方法详细信息

visitStatItem

public void visitStatItem(java.sql.ResultSet resultSet,
                          int nSQLIndex)
                   throws WCMException
从接口 IStatHandler 复制的描述
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HostObjDomain

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HostObjDomain

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.stat.HostObjDomain
所有已实现的接口：
java.lang.Cloneable
public class HostObjDomain
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
HostObjDomain()
构造函数：保留默认接口
方法摘要
static HostObjDomain | createNewInstance() 产生当前对象[HostObjDomain]的实例
static HostObjDomain | findById(int _nId) 提取指定ID的对象
static HostObjDomain | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getHostId() 提取属性：HostId
int | getHostType() 提取属性：HostType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getUrl() 提取属性：Url
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setHostId(int _nHostId) 设置属性：HostId
boolean | setHostType(int _nHostType) 设置属性：HostType
boolean | setUrl(java.lang.String _sUrl) 设置属性：Url
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

HostObjDomain

public HostObjDomain()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getHostId

public int getHostId()
提取属性：HostId

返回：
HostId

setHostId

public boolean setHostId(int _nHostId)
                  throws WCMException
设置属性：HostId

参数：
_nHostId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostType

public int getHostType()
提取属性：HostType

返回：
HostType

setHostType

public boolean setHostType(int _nHostType)
                    throws WCMException
设置属性：HostType

参数：
_nHostType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getUrl

public java.lang.String getUrl()
提取属性：Url

返回：
Url

setUrl

public boolean setUrl(java.lang.String _sUrl)
               throws WCMException
设置属性：Url

参数：
_sUrl - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final HostObjDomain findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final HostObjDomain createNewInstance()
                                             throws WCMException
产生当前对象[HostObjDomain]的实例

返回：
当前对象的实例[HostObjDomain]
抛出：
WCMException

findByKey

public static final HostObjDomain findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HostObjDomains

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HostObjDomains

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.stat.HostObjDomains

public class HostObjDomains
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
HostObjDomains(User _currUser)
构造函数
HostObjDomains(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static HostObjDomains | createNewInstance(User _currUser) 产生当前集合对象[HostObjDomains]的实例
static HostObjDomains | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static HostObjDomains | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[HostObjDomains]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HostObjDomains

public HostObjDomains(User _currUser)
构造函数

另请参见：
HostObjDomains( User _currUser, int _initCapacity, int _incCapacity );

HostObjDomains

public HostObjDomains(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final HostObjDomains findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（HostObjDomains）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final HostObjDomains openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[HostObjDomains]

参数：
_filter - 指定的Filter
返回：
当前集合[HostObjDomains]
抛出：
WCMException

createNewInstance

public static HostObjDomains createNewInstance(User _currUser)
产生当前集合对象[HostObjDomains]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HostObjHitsCount

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HostObjHitsCount

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.stat.HostObjHitsCount
所有已实现的接口：
java.lang.Cloneable
public class HostObjHitsCount
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
HostObjHitsCount()
构造函数：保留默认接口
方法摘要
static HostObjHitsCount | createNewInstance() 产生当前对象[HostObjHitsCount]的实例
static HostObjHitsCount | findById(int _nId) 提取指定ID的对象
static HostObjHitsCount | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getHitsCount() 提取属性：HitsCount
CMyDateTime | getHitsTime() 提取属性：HitsTime
int | getHostId() 提取属性：HostId
int | getHostType() 提取属性：HostType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
CMyDateTime | getObjCrTime() 提取属性：ObjCrTime
java.lang.String | getObjCrUser() 提取属性：ObjCrUser
java.lang.String | getObjName() 提取属性：ObjName
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isSpecial() 提取属性：IsSpecial
boolean | isValid() 检验对象数据有效性
boolean | setHitsCount(int _nHitsCount) 设置属性：HitsCount
boolean | setHitsTime(CMyDateTime _dtHitsTime) 设置属性：HitsTime
boolean | setHostId(int _nHostId) 设置属性：HostId
boolean | setHostType(int _nHostType) 设置属性：HostType
boolean | setObjCrTime(CMyDateTime _dtObjCrTime) 设置属性：ObjCrTime
boolean | setObjCrUser(java.lang.String _sObjCrUser) 设置属性：ObjCrUser
boolean | setObjName(java.lang.String _sObjName) 设置属性：ObjName
boolean | setSpecial(boolean _bIsSpecial) 设置属性：IsSpecial
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

HostObjHitsCount

public HostObjHitsCount()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getHostId

public int getHostId()
提取属性：HostId

返回：
HostId

setHostId

public boolean setHostId(int _nHostId)
                  throws WCMException
设置属性：HostId

参数：
_nHostId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostType

public int getHostType()
提取属性：HostType

返回：
HostType

setHostType

public boolean setHostType(int _nHostType)
                    throws WCMException
设置属性：HostType

参数：
_nHostType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjName

public java.lang.String getObjName()
提取属性：ObjName

返回：
ObjName

setObjName

public boolean setObjName(java.lang.String _sObjName)
                   throws WCMException
设置属性：ObjName

参数：
_sObjName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjCrTime

public CMyDateTime getObjCrTime()
提取属性：ObjCrTime

返回：
ObjCrTime

setObjCrTime

public boolean setObjCrTime(CMyDateTime _dtObjCrTime)
                     throws WCMException
设置属性：ObjCrTime

参数：
_dtObjCrTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjCrUser

public java.lang.String getObjCrUser()
提取属性：ObjCrUser

返回：
ObjCrUser

setObjCrUser

public boolean setObjCrUser(java.lang.String _sObjCrUser)
                     throws WCMException
设置属性：ObjCrUser

参数：
_sObjCrUser - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHitsCount

public int getHitsCount()
提取属性：HitsCount

返回：
HitsCount

setHitsCount

public boolean setHitsCount(int _nHitsCount)
                     throws WCMException
设置属性：HitsCount

参数：
_nHitsCount - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHitsTime

public CMyDateTime getHitsTime()
提取属性：HitsTime

返回：
HitsTime

setHitsTime

public boolean setHitsTime(CMyDateTime _dtHitsTime)
                    throws WCMException
设置属性：HitsTime

参数：
_dtHitsTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isSpecial

public boolean isSpecial()
提取属性：IsSpecial

返回：
IsSpecial

setSpecial

public boolean setSpecial(boolean _bIsSpecial)
                   throws WCMException
设置属性：IsSpecial

参数：
_bIsSpecial - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final HostObjHitsCount findById(int _nId)
                                       throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final HostObjHitsCount createNewInstance()
                                                throws WCMException
产生当前对象[HostObjHitsCount]的实例

返回：
当前对象的实例[HostObjHitsCount]
抛出：
WCMException

findByKey

public static final HostObjHitsCount findByKey(java.lang.Object _oKey)
                                        throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HostObjHitsCounts

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 HostObjHitsCounts

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.stat.HostObjHitsCounts

public class HostObjHitsCounts
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
HostObjHitsCounts(User _currUser)
构造函数
HostObjHitsCounts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static HostObjHitsCounts | createNewInstance(User _currUser) 产生当前集合对象[HostObjHitsCounts]的实例
static HostObjHitsCounts | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static HostObjHitsCounts | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[HostObjHitsCounts]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HostObjHitsCounts

public HostObjHitsCounts(User _currUser)
构造函数

另请参见：
HostObjHitsCounts( User _currUser, int _initCapacity, int _incCapacity );

HostObjHitsCounts

public HostObjHitsCounts(User _currUser,
                         int _initCapacity,
                         int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final HostObjHitsCounts findByIds(User _currUser,
                                                java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（HostObjHitsCounts）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final HostObjHitsCounts openWCMObjs(User _currUser,
                                                  WCMFilter _filter)
                                           throws WCMException
通过指定一个Filter获取当前集合[HostObjHitsCounts]

参数：
_filter - 指定的Filter
返回：
当前集合[HostObjHitsCounts]
抛出：
WCMException

createNewInstance

public static HostObjHitsCounts createNewInstance(User _currUser)
产生当前集合对象[HostObjHitsCounts]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IBonusCalculator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IBonusCalculator

所有已知实现类：
BonusCalculator
public interface IBonusCalculator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
user1

方法摘要
float | caclulateHitsBonus(int _nHitsCount) 根据点击量，计算点击量所获奖金
float | caclulateIssuedAmountBonus(int _nDocCount) 根据发稿量，计算发稿量所获奖金

方法详细信息

caclulateIssuedAmountBonus

float caclulateIssuedAmountBonus(int _nDocCount)
                                 throws WCMException
根据发稿量，计算发稿量所获奖金

参数：
nDocCount - 发稿量
返回：
抛出：
WCMException

caclulateHitsBonus

float caclulateHitsBonus(int _nHitsCount)
                         throws WCMException
根据点击量，计算点击量所获奖金

参数：
nHitsCount - 点击量
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IBonusRuleMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IBonusRuleMgr

所有已知实现类：
BonusRuleMgr
public interface IBonusRuleMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
奖励规则的业务逻辑层接口
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
ffx

方法摘要
boolean | delete(User _oCurrUser, BonusRules _oBonusRules) 删除指定的奖励规则
BonusRules | query(User _oCurrUser, WCMFilter _currFilter) 查询系统指定奖励规则
BonusRule | save(User _oCurrUser, BonusRule _oBonusRule)
BonusRule | save(User _oCurrUser, int _nBonusType, java.lang.String _sRange, float _fPricePerUnit) 保存当前奖励规则

方法详细信息

save

BonusRule save(User _oCurrUser,
               int _nBonusType,
               java.lang.String _sRange,
               float _fPricePerUnit)
               throws WCMException
保存当前奖励规则

参数：
_oCurrUser - 当前操作用户
_nBonusType - 奖金类型，1为发稿量奖金，2为点击率奖金
_sRange - 奖励范围，用逗号隔开的字符串表示，如0到500，使用“0,500”表示
_fPricePerUnit - 单篇奖金，用浮点数表示
返回：
保存的奖励规则
抛出：
WCMException

save

BonusRule save(User _oCurrUser,
               BonusRule _oBonusRule)
               throws WCMException
参数：
_oCurrUser - 当前操作的用户
_oCurrMaster - 当前奖励规则
返回：
当前保存的奖励规则
抛出：
WCMException

delete

boolean delete(User _oCurrUser,
               BonusRules _oBonusRules)
               throws WCMException
删除指定的奖励规则

参数：
_oCurrUser - 当前删除的用户
_oBonusRules - 将被删除的规则
返回：
抛出：
WCMException

query

BonusRules query(User _oCurrUser,
                 WCMFilter _currFilter)
                 throws WCMException
查询系统指定奖励规则

参数：
_oCurrUser - 当前操作的用户
_currFilter - 额外的查询和排序条件
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IChnlDeptMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IChnlDeptMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
ChnlDeptMgr
public interface IChnlDeptMgr
extends ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
user1

方法摘要
java.util.List | getChnlIdsByDep(Group group) 根据组织返回栏目的id数组
java.lang.String | getChnlIdsByDepts(Groups groups) 根据组织返回栏目的id数组
java.util.List | getDepIdsByChannel(Channel channel) 根据栏目返回组织的id数组
java.lang.String | getDepNamesByChannel(Channel channel, User user) 根据栏目获取组织名称或者用户获取组织
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

getDepIdsByChannel

java.util.List getDepIdsByChannel(Channel channel)
                                  throws WCMException
根据栏目返回组织的id数组

参数：
channel -
返回：
抛出：
WCMException

getChnlIdsByDep

java.util.List getChnlIdsByDep(Group group)
                               throws WCMException
根据组织返回栏目的id数组

参数：
group -
返回：
抛出：
WCMException

getChnlIdsByDepts

java.lang.String getChnlIdsByDepts(Groups groups)
                                   throws WCMException
根据组织返回栏目的id数组

参数：
group -
返回：
抛出：
WCMException

getDepNamesByChannel

java.lang.String getDepNamesByChannel(Channel channel,
                                      User user)
                                      throws WCMException
根据栏目获取组织名称或者用户获取组织

参数：
channel -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IHitsCountHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IHitsCountHandler

所有已知实现类：
ChannelHitsCountHandler, DocumentHitsCountHandler, SiteHitsCountHandler
public interface IHitsCountHandler

方法摘要
void | handle(BaseObj obj, java.util.Map properties) 更新指定对象obj的点击量
void | notifyComplete() 在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。

方法详细信息

handle

void handle(BaseObj obj,
            java.util.Map properties)
            throws WCMException
更新指定对象obj的点击量

参数：
obj -
properties - 点击量相关信息
抛出：
WCMException

notifyComplete

void notifyComplete()
                    throws WCMException
在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。

抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IKeyMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IKeyMaker

所有已知实现类：
BaseStatHandler, DefaultStatHandler, DocStatHandler4Channel, DocStatHandler4ChannelOfGroup, DocstatHandler4ChannelOfUser, DocStatHandler4ChnlDept, DocStatHandler4ChnlDeptChannel, DocStatHandler4ChnlDeptSite, DocStatHandler4SiteOfGroup, DocstatHandler4SiteOfUser, DocStatHandler4UserChannel, DocStatHandler4UserDept, DocStatHandler4UserDeptChannel, DocStatHandler4UserDeptSite, DocStatHandler4UserSite, HitsStatHandler4Channel, HitsStatHandler4ChnlDept, HitsStatHandler4User, HitsStatHandler4UserDept
public interface IKeyMaker

用于根据统计SQL中的select字段，构造统计存储结构中的Key信息

作者：
Administrator

方法摘要
java.lang.String[] | makeFields(java.lang.String sKey) 根据传入的sKey信息，返回构造之后的keys
java.lang.String | makeKey(java.lang.String[] keys) 根据传入的keys信息，返回构造之后的key

方法详细信息

makeKey

java.lang.String makeKey(java.lang.String[] keys)
根据传入的keys信息，返回构造之后的key

参数：
keys -
返回：

makeFields

java.lang.String[] makeFields(java.lang.String sKey)
根据传入的sKey信息，返回构造之后的keys

参数：
sKey -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStatHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IStatHandler

所有已知实现类：
BaseStatHandler, DefaultStatHandler, DocStatHandler4Channel, DocStatHandler4ChannelOfGroup, DocstatHandler4ChannelOfUser, DocStatHandler4ChnlDept, DocStatHandler4ChnlDeptChannel, DocStatHandler4ChnlDeptSite, DocStatHandler4SiteOfGroup, DocstatHandler4SiteOfUser, DocStatHandler4UserChannel, DocStatHandler4UserDept, DocStatHandler4UserDeptChannel, DocStatHandler4UserDeptSite, DocStatHandler4UserSite, HitsStatHandler4Channel, HitsStatHandler4ChnlDept, HitsStatHandler4User, HitsStatHandler4UserDept
public interface IStatHandler

StatAnalysisTool工具统计时将调用的工具类，StatAnalysisTool在处理统计结果中的每一条记录时， 将调用visitStatItem接口，同时在该接口调用过程中累积自身状态，最后将通过getResult接口返回统计结果

作者：
Administrator

方法摘要
IStatResult | getResult() 返回visitStatItem累积之后的结果集
void | initState() 由于统计Handler处理过程中，需要累积状态，为了能够重复利用此handler，需要在此接口中对已经累积的状态进行清零处理
void | visitEnd(int nSQLIndex) 在遍历完所有统计结果之后，需要执行的处理
void | visitStart(java.sql.ResultSet resultSet, int nSQLIndex) 在遍历每一条统计处理之前，需要执行的处理
void | visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex) 根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。

方法详细信息

initState

void initState()
由于统计Handler处理过程中，需要累积状态，为了能够重复利用此handler，需要在此接口中对已经累积的状态进行清零处理

visitStart

void visitStart(java.sql.ResultSet resultSet,
                int nSQLIndex)
                throws WCMException
在遍历每一条统计处理之前，需要执行的处理

参数：
resultSe -
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException

visitStatItem

void visitStatItem(java.sql.ResultSet resultSet,
                   int nSQLIndex)
                   throws WCMException
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
如：处理栏目下发稿量统计时，通过获取传入的文档id信息，进一步构造栏目的统计数据。

参数：
resultSet - 当前正在处理的某一条结果集
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException

visitEnd

void visitEnd(int nSQLIndex)
              throws WCMException
在遍历完所有统计结果之后，需要执行的处理

参数：
nSQLIndex - 当前执行的第几条SQL索引
抛出：
WCMException

getResult

IStatResult getResult()
返回visitStatItem累积之后的结果集

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStatResult

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IStatResult

所有已知实现类：
StatResult
public interface IStatResult

作者：
Administrator

方法摘要
IStatResult | filter(IStatResultFilter resultFilter) 使用过滤规则resultFilter对结果集进行过滤，返回过滤之后的新的结果集
int | getResult(int nSQLIndex, java.lang.String key) 返回第nIndex条统计SQL在key下的统计信息
int | getResult(int nSQLIndex, java.lang.String[] keys) 返回第nIndex条统计SQL在keys下的统计信息
int | getResult(java.lang.String key) 返回第1条统计SQL在key下的统计信息
int | getResult(java.lang.String[] keys) 返回第1条统计SQL在keys下的统计信息
java.util.List | list() 返回统计主体的集合
java.util.List | sort(boolean bSortDesc) 对第1条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序
java.util.List | sort(int nSQLIndex, int nKeyIndex, java.lang.String sKeyValue, boolean bSortDesc) 对第nSQLIndex条统计结果集中的，第nKeyIndex位key的sKeyValue值进行排序
java.util.List | sort(int nSQLIndex, java.lang.String sKeyValue, boolean bSortDesc) 对第nSQLIndex条统计结果集中的，第3位key的sKeyValue值进行排序
java.util.List | sortByMajorObject(boolean bSortDesc) 对第1条统计结果集中的，按主体对象进行排序
java.util.List | sortWithSQLIndex(int nSQLIndex, boolean bSortDesc) 对第nSQLIndex条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序 一般仅对select包含两个字段有效

方法详细信息

getResult

int getResult(java.lang.String key)
返回第1条统计SQL在key下的统计信息

参数：
key - 统计SQL的select部分中的字段信息
返回：

getResult

int getResult(int nSQLIndex,
              java.lang.String key)
返回第nIndex条统计SQL在key下的统计信息

参数：
nSQLIndex - 第几条统计SQL，索引值从1开始
key - 统计SQL的select部分中的字段信息
返回：

getResult

int getResult(java.lang.String[] keys)
返回第1条统计SQL在keys下的统计信息

参数：
keys - 统计SQL的select部分中的字段信息
返回：

getResult

int getResult(int nSQLIndex,
              java.lang.String[] keys)
返回第nIndex条统计SQL在keys下的统计信息

参数：
nSQLIndex - 第几条统计SQL，索引值从1开始
keys - 统计SQL的select部分中的字段信息
返回：

filter

IStatResult filter(IStatResultFilter resultFilter)
使用过滤规则resultFilter对结果集进行过滤，返回过滤之后的新的结果集

参数：
resultFilter -
返回：
返回过滤之后的结果集

sort

java.util.List sort(boolean bSortDesc)
                    throws WCMException
对第1条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序

参数：
bSortDesc - 是否为降序
返回：
返回排完序之后的主体key信息
抛出：
WCMException

sortWithSQLIndex

java.util.List sortWithSQLIndex(int nSQLIndex,
                                boolean bSortDesc)
                                throws WCMException
对第nSQLIndex条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序
一般仅对select包含两个字段有效

参数：
nSQLIndex - 第几条统计SQL，索引值从1开始
bSortDesc - 是否为降序
返回：
返回排完序之后的主体key信息，主体一般为第2个select字段
抛出：
WCMException

sortByMajorObject

java.util.List sortByMajorObject(boolean bSortDesc)
对第1条统计结果集中的，按主体对象进行排序

参数：
bSortDesc - 是否为降序
返回：
返回排完序之后的主体key信息，主体一般为第2个select字段

sort

java.util.List sort(int nSQLIndex,
                    java.lang.String sKeyValue,
                    boolean bSortDesc)
                    throws WCMException
对第nSQLIndex条统计结果集中的，第3位key的sKeyValue值进行排序

参数：
nSQLIndex - 第几条统计SQL，索引值从1开始计数
sKeyValue - select字段索引位为3的索引值
bSortDesc -
返回：
返回排完序之后的主体key信息，主体一般为第2个select字段
抛出：
WCMException

sort

java.util.List sort(int nSQLIndex,
                    int nKeyIndex,
                    java.lang.String sKeyValue,
                    boolean bSortDesc)
                    throws WCMException
对第nSQLIndex条统计结果集中的，第nKeyIndex位key的sKeyValue值进行排序

参数：
nSQLIndex - 第几条统计SQL，索引值从1开始计数
nKeyIndex - 某条统计SQL中，第几个select字段,从3开始计数
sKeyValue - 索引位为nKeyIndex的索引值
bSortDesc -
返回：
返回排完序之后的主体key信息，主体一般为第2个select字段
抛出：
WCMException

list

java.util.List list()
返回统计主体的集合

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStatResultFilter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IStatResultFilter

public interface IStatResultFilter

结果集过滤器，用于过滤统计结果集中符合条件的数据

作者：
Administrator

方法摘要
 boolean accept(java.lang.String sKey, IStatResult statResult)
过滤结果集中的数据

方法详细信息

accept

boolean accept(java.lang.String sKey,
               IStatResult statResult)
过滤结果集中的数据

参数：
sKey - 统计SQL语句中的统计主体
statResult - 当前需要过滤的结果集对象，可结合sKey参数，通过IStatResult.getResult接口，判断指定数据是否符合要求
返回：
如果此接口返回true，那么该条记录将被保留，否则将被丢弃
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStatResults

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IStatResults

所有已知实现类：
StatResults
public interface IStatResults

方法摘要
void | addResult(IStatResult result) 向结果集的集合中添加结果集
void | addXlabels(java.lang.String sCurrLabel) 添加页面中走势图的下标集合
IStatResults | filter(IStatResultsFilter resultsFilter) 使用过滤规则resultFilter对结果集集合进行过滤，返回过滤之后的新的结果集集合
java.util.List | getResult(int nIndex, java.lang.String sKey) 从结果集中根据所给的参数 sKey，返回第nIndex条SQL对应的结果list
java.util.List | getResult(int nIndex, java.lang.String[] sKey) 返回第n条SQL的，Key为数组的结果集
java.util.List | getResult(java.lang.String sKey) 从结果集中根据所给的参数 sKey，返回该参数所对应的结果list
java.util.List | getResult(java.lang.String[] sKey) 返回第一条SQL的，以key为关键数组的值
java.util.List | getXlabels() 获取走势图的X下标内容
java.util.List | list() 返回主体集合

方法详细信息

addResult

void addResult(IStatResult result)
向结果集的集合中添加结果集

参数：
result -

getResult

java.util.List getResult(java.lang.String sKey)
从结果集中根据所给的参数 sKey，返回该参数所对应的结果list

getResult

java.util.List getResult(int nIndex,
                         java.lang.String sKey)
从结果集中根据所给的参数 sKey，返回第nIndex条SQL对应的结果list

getResult

java.util.List getResult(int nIndex,
                         java.lang.String[] sKey)
返回第n条SQL的，Key为数组的结果集

参数：
nIndex -
sKey -
返回：

getResult

java.util.List getResult(java.lang.String[] sKey)
返回第一条SQL的，以key为关键数组的值

参数：
sKey -
返回：

filter

IStatResults filter(IStatResultsFilter resultsFilter)
                    throws WCMException
使用过滤规则resultFilter对结果集集合进行过滤，返回过滤之后的新的结果集集合

参数：
resultFilters -
返回：
返回过滤之后的结果集集合
抛出：
WCMException

list

java.util.List list()
返回主体集合

返回：

addXlabels

void addXlabels(java.lang.String sCurrLabel)
添加页面中走势图的下标集合

参数：
sCurrLabel -

getXlabels

java.util.List getXlabels()
获取走势图的X下标内容

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStatResultsFilter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IStatResultsFilter

public interface IStatResultsFilter

方法摘要
 boolean accept(java.lang.String sKey, IStatResults statResults)
过滤结果集集合中的数据

方法详细信息

accept

boolean accept(java.lang.String sKey,
               IStatResults statResults)
               throws WCMException
过滤结果集集合中的数据

参数：
sKey - 统计SQL语句中的统计主体
statResults - 当前需要过滤的结果集集合对象，可结合sKey参数，通过IStatResults.getResult接口，判断指定数据是否符合要求
返回：
如果此接口返回true，那么该条记录将被保留，否则将被丢弃
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IURLParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IURLParser

所有已知实现类：
URLParser
public interface IURLParser

方法摘要
 BaseObj parse(java.lang.String sUrl)
根据Url信息，返回该Url对应的BaseObj对象。

方法详细信息

parse

BaseObj parse(java.lang.String sUrl)
              throws WCMException
根据Url信息，返回该Url对应的BaseObj对象。 如:根据文档的发布地址，得到该文档； 根据栏目的地址，得到栏目对象； 同时需要考虑栏目二级域名的情况。

参数：
sUrl -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IUserLoginInfoMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
接口 IUserLoginInfoMgr

所有已知实现类：
UserLoginInfoMgr
public interface IUserLoginInfoMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
用户登录信息的业务逻辑层接口
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
chenchang

方法摘要
java.lang.String | getCurrUser(User _oUser) 获取普通用户自己的条件构造
java.lang.String | getSearchGroupName(java.lang.String _groupName) 获取部门名称检索的条件构造
java.lang.String | getSearchUserName(java.lang.String _userName) 获取用户名称检索的条件构造
java.lang.String | getUsersForGrpAdmin(User _oUser) 获取组管理员所在组的所有用户的条件构造
UserLoginInfos | query(User _oCurrUser, WCMFilter _filter)
UserLoginInfo | save(UserLoginInfo _oUserLoginInfo, User _oCurrUser)

方法详细信息

save

UserLoginInfo save(UserLoginInfo _oUserLoginInfo,
                   User _oCurrUser)
                   throws WCMException
参数：
_oCurrUser - 当前登陆的用户
_oLoginTime - 登录时间
_sIpAddress - IP地址
返回：
UserLoginInfo 返回用户登录信息
抛出：
WCMException

query

UserLoginInfos query(User _oCurrUser,
                     WCMFilter _filter)
                     throws WCMException
参数：
_oCurrUser - 当前登陆的用户
返回：
_filter 存储的是用户的查询和排序条件
抛出：
WCMException

getSearchUserName

java.lang.String getSearchUserName(java.lang.String _userName)
                                   throws WCMException
获取用户名称检索的条件构造

参数：
_userName - 用户名称
返回：
String 返回条件构造语句
抛出：
WCMException

getSearchGroupName

java.lang.String getSearchGroupName(java.lang.String _groupName)
                                    throws WCMException
获取部门名称检索的条件构造

参数：
_groupName - 部门名称
返回：
String 返回条件构造语句
抛出：
WCMException

getUsersForGrpAdmin

java.lang.String getUsersForGrpAdmin(User _oUser)
                                     throws WCMException
获取组管理员所在组的所有用户的条件构造

参数：
_oUser - 组管理员名称
返回：
String 返回条件构造语句
抛出：
WCMException

getCurrUser

java.lang.String getCurrUser(User _oUser)
                             throws WCMException
获取普通用户自己的条件构造

参数：
_oUser - 用户名称
返回：
String 返回条件构造语句
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.stat
接口
IBonusCalculator
IBonusRuleMgr
IChnlDeptMgr
IHitsCountHandler
IKeyMaker
IStatHandler
IStatResult
IStatResultFilter
IStatResults
IStatResultsFilter
IURLParser
IUserLoginInfoMgr
类
BaseStatHandler
BonusCalculator
BonusRule
BonusRuleMgr
BonusRules
BonusRuleServiceProvider
ChannelHitsCountHandler
ChnlDept
ChnlDeptMgr
ChnlDeptMgrForCluster
ChnlDepts
DefaultStatHandler
DocStatHandler4Channel
DocStatHandler4ChannelOfGroup
DocstatHandler4ChannelOfUser
DocStatHandler4ChnlDept
DocStatHandler4ChnlDeptChannel
DocStatHandler4ChnlDeptSite
DocStatHandler4SiteOfGroup
DocstatHandler4SiteOfUser
DocStatHandler4UserChannel
DocStatHandler4UserDept
DocStatHandler4UserDeptChannel
DocStatHandler4UserDeptSite
DocStatHandler4UserSite
DocumentHitsCount
DocumentHitsCountHandler
DocumentHitsCounts
HitsCountConstant
HitsCountHelper
HitsCountParserSchedule
HitsStatHandler4Channel
HitsStatHandler4ChnlDept
HitsStatHandler4User
HitsStatHandler4UserDept
HostObjDomain
HostObjDomains
HostObjHitsCount
HostObjHitsCounts
SiteHitsCountHandler
StatAnalysisTool
StatBonusDataForUser
StatBonusResultForUser
StatDocCountByChannel
StatDocCountOfGroupByChannel
StatDocCountOfGroupByMetaClass
StatDocCountOfUserByMetaClass
StatResult
StatResults
TimeRange
URLParser
UserLoginInfo
UserLoginInfoMgr
UserLoginInfos
UserLoginInfoServiceProvider


com.trs.components.stat

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.stat

接口摘要
IBonusCalculator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
IBonusRuleMgr | Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的业务逻辑层接口 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
IChnlDeptMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
IHitsCountHandler |
IKeyMaker | 用于根据统计SQL中的select字段，构造统计存储结构中的Key信息
IStatHandler | StatAnalysisTool工具统计时将调用的工具类，StatAnalysisTool在处理统计结果中的每一条记录时， 将调用visitStatItem接口，同时在该接口调用过程中累积自身状态，最后将通过getResult接口返回统计结果
IStatResult |
IStatResultFilter | 结果集过滤器，用于过滤统计结果集中符合条件的数据
IStatResults |
IStatResultsFilter |
IURLParser |
IUserLoginInfoMgr | Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的业务逻辑层接口 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

类摘要
BaseStatHandler | 屏蔽key构造及反解的细节；屏蔽统计结果的数据存储结构
BonusCalculator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
BonusRule |
BonusRuleMgr | Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的业务逻辑处理类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
BonusRules |
BonusRuleServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
ChannelHitsCountHandler |
ChnlDept |
ChnlDeptMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
ChnlDeptMgrForCluster | Title: TRS 内容协作平台（TRS WCM） Description: ChnlDept缓冲处理.接收集群消息,根据相应的操作刷新缓冲.
ChnlDepts |
DefaultStatHandler | 默认的统计处理类
DocStatHandler4Channel | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocStatHandler4ChannelOfGroup | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocstatHandler4ChannelOfUser | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocStatHandler4ChnlDept |
DocStatHandler4ChnlDeptChannel | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocStatHandler4ChnlDeptSite | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocStatHandler4SiteOfGroup | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocstatHandler4SiteOfUser | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocStatHandler4UserChannel | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocStatHandler4UserDept |
DocStatHandler4UserDeptChannel | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocStatHandler4UserDeptSite | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocStatHandler4UserSite | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
DocumentHitsCount |
DocumentHitsCountHandler | 处理文档对象的点击量更新
DocumentHitsCounts |
HitsCountConstant | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
HitsCountHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
HitsCountParserSchedule |
HitsStatHandler4Channel | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
HitsStatHandler4ChnlDept |
HitsStatHandler4User | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
HitsStatHandler4UserDept |
HostObjDomain |
HostObjDomains |
HostObjHitsCount |
HostObjHitsCounts |
SiteHitsCountHandler |
StatAnalysisTool | 执行统计分析的工具类.
StatBonusDataForUser | Title: TRS 内容协作平台（TRS WCM） Description: 用户奖金统计类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
StatBonusResultForUser | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
StatDocCountByChannel |
StatDocCountOfGroupByChannel |
StatDocCountOfGroupByMetaClass |
StatDocCountOfUserByMetaClass |
StatResult | 执行一批SQL之后，返回的统计结果集对象，该对象一般为StatAnalysisTool.stat的返回结果
StatResults |
TimeRange | 用于按照指定的步长，处理开始时间与结束时间
URLParser |
UserLoginInfo |
UserLoginInfoMgr | Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的业务逻辑处理类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
UserLoginInfos |
UserLoginInfoServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn


com.trs.components.stat 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.stat 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.components.common.job.BaseScheduleWorker
        • com.trs.components.common.job.BaseStatefulScheduleWorker (implements org.quartz.StatefulJob)
          • com.trs.components.stat.HitsCountParserSchedule
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.stat.BonusRule
        • com.trs.components.stat.ChnlDept
        • com.trs.components.stat.DocumentHitsCount
        • com.trs.components.stat.HostObjDomain
        • com.trs.components.stat.HostObjHitsCount
        • com.trs.components.stat.UserLoginInfo
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.stat.BonusRules
        • com.trs.components.stat.ChnlDepts
        • com.trs.components.stat.DocumentHitsCounts
        • com.trs.components.stat.HostObjDomains
        • com.trs.components.stat.HostObjHitsCounts
        • com.trs.components.stat.UserLoginInfos
    • com.trs.components.stat.BaseStatHandler (implements com.trs.components.stat.IKeyMaker, com.trs.components.stat.IStatHandler)
      • com.trs.components.stat.DefaultStatHandler
      • com.trs.components.stat.DocStatHandler4Channel
      • com.trs.components.stat.DocStatHandler4ChannelOfGroup
      • com.trs.components.stat.DocstatHandler4ChannelOfUser
      • com.trs.components.stat.DocStatHandler4ChnlDept
      • com.trs.components.stat.DocStatHandler4ChnlDeptChannel
      • com.trs.components.stat.DocStatHandler4ChnlDeptSite
      • com.trs.components.stat.DocStatHandler4SiteOfGroup
      • com.trs.components.stat.DocstatHandler4SiteOfUser
      • com.trs.components.stat.DocStatHandler4UserChannel
      • com.trs.components.stat.DocStatHandler4UserDept
      • com.trs.components.stat.DocStatHandler4UserDeptChannel
      • com.trs.components.stat.DocStatHandler4UserDeptSite
      • com.trs.components.stat.DocStatHandler4UserSite
      • com.trs.components.stat.HitsStatHandler4Channel
      • com.trs.components.stat.HitsStatHandler4ChnlDept
      • com.trs.components.stat.HitsStatHandler4User
      • com.trs.components.stat.HitsStatHandler4UserDept
    • com.trs.components.stat.BonusCalculator (implements com.trs.components.stat.IBonusCalculator)
    • com.trs.components.stat.BonusRuleMgr (implements com.trs.components.stat.IBonusRuleMgr)
    • com.trs.components.stat.BonusRuleServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.stat.ChannelHitsCountHandler (implements com.trs.components.stat.IHitsCountHandler)
    • com.trs.components.stat.ChnlDeptMgr (implements com.trs.components.stat.IChnlDeptMgr)
    • com.trs.components.stat.ChnlDeptMgrForCluster (implements com.trs.cluster.IClusterMsgReceiver)
    • com.trs.components.stat.DocumentHitsCountHandler (implements com.trs.components.stat.IHitsCountHandler)
    • com.trs.components.stat.HitsCountConstant
    • com.trs.components.stat.HitsCountHelper
    • com.trs.components.stat.SiteHitsCountHandler (implements com.trs.components.stat.IHitsCountHandler)
    • com.trs.components.stat.StatAnalysisTool
    • com.trs.components.stat.StatBonusDataForUser
    • com.trs.components.stat.StatBonusResultForUser
    • com.trs.components.stat.StatDocCountByChannel
    • com.trs.components.stat.StatDocCountOfGroupByChannel
    • com.trs.components.stat.StatDocCountOfGroupByMetaClass
    • com.trs.components.stat.StatDocCountOfUserByMetaClass
    • com.trs.components.stat.StatResult (implements com.trs.components.stat.IStatResult)
    • com.trs.components.stat.StatResults (implements com.trs.components.stat.IStatResults)
    • com.trs.components.stat.TimeRange
    • com.trs.components.stat.URLParser (implements com.trs.components.stat.IURLParser)
    • com.trs.components.stat.UserLoginInfoMgr (implements com.trs.components.stat.IUserLoginInfoMgr)
    • com.trs.components.stat.UserLoginInfoServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)

接口分层结构

  • com.trs.components.stat.IBonusCalculator
  • com.trs.components.stat.IBonusRuleMgr
  • com.trs.components.stat.IHitsCountHandler
  • com.trs.components.stat.IKeyMaker
  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.stat.IChnlDeptMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.stat.IChnlDeptMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.components.stat.IChnlDeptMgr
  • com.trs.components.stat.IStatHandler
  • com.trs.components.stat.IStatResult
  • com.trs.components.stat.IStatResultFilter
  • com.trs.components.stat.IStatResults
  • com.trs.components.stat.IStatResultsFilter
  • com.trs.components.stat.IURLParser
  • com.trs.components.stat.IUserLoginInfoMgr


软件包 com.trs.components.stat 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.stat
的使用

使用 com.trs.components.stat 的软件包
com.trs.components.stat

com.trs.components.stat 使用的 com.trs.components.stat 中的类
BaseStatHandler
屏蔽key构造及反解的细节；屏蔽统计结果的数据存储结构
BonusRule
BonusRules
ChnlDept
ChnlDepts
DocumentHitsCount
DocumentHitsCounts
HostObjDomain
HostObjDomains
HostObjHitsCount
HostObjHitsCounts
IBonusCalculator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
IBonusRuleMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
奖励规则的业务逻辑层接口
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
IChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
IHitsCountHandler
IKeyMaker
用于根据统计SQL中的select字段，构造统计存储结构中的Key信息
IStatHandler
StatAnalysisTool工具统计时将调用的工具类，StatAnalysisTool在处理统计结果中的每一条记录时， 将调用visitStatItem接口，同时在该接口调用过程中累积自身状态，最后将通过getResult接口返回统计结果
IStatResult
IStatResultFilter
结果集过滤器，用于过滤统计结果集中符合条件的数据
IStatResults
IStatResultsFilter
IURLParser
IUserLoginInfoMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
用户登录信息的业务逻辑层接口
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
StatBonusResultForUser
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
UserLoginInfo
UserLoginInfos

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SiteHitsCountHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 SiteHitsCountHandler

java.lang.Object
    继承者  com.trs.components.stat.SiteHitsCountHandler
所有已实现的接口：
IHitsCountHandler
public class SiteHitsCountHandler
extends java.lang.Object
implements IHitsCountHandler

构造方法摘要
SiteHitsCountHandler()
方法摘要
void | handle(BaseObj obj, java.util.Map properties) 更新指定对象obj的点击量
void | notifyComplete() 在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteHitsCountHandler

public SiteHitsCountHandler()
方法详细信息

handle

public void handle(BaseObj obj,
                   java.util.Map properties)
            throws WCMException
从接口 IHitsCountHandler 复制的描述
更新指定对象obj的点击量

指定者：
接口 IHitsCountHandler 中的 handle
properties - 点击量相关信息
抛出：
WCMException

notifyComplete

public void notifyComplete()
从接口 IHitsCountHandler 复制的描述
在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。

指定者：
接口 IHitsCountHandler 中的 notifyComplete
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatAnalysisTool

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatAnalysisTool

java.lang.Object
    继承者  com.trs.components.stat.StatAnalysisTool

public class StatAnalysisTool
extends java.lang.Object

执行统计分析的工具类.
该工具可以对符合规则的SQL进行统计,SQL的select规则如下：
1.第一个select字段为统计的总数，如DataCount;
2.第二个及后面的字段将作为检索的key信息;

作者：
administrator

构造方法摘要
StatAnalysisTool(java.lang.String[] aStatSQL)
使用默认的IStatHandler对象构造统计分析对象
StatAnalysisTool(java.lang.String[] aStatSQL, IStatHandler handler)
使用指定的IStatHandler对象构造统计分析对象
方法摘要
IStatResult | stat(CMyDateTime startDate, CMyDateTime endDate) 对指定的开始时间startDate与结束时间endDate进行统计，返回统计的结果集对象
IStatResults | stat(CMyDateTime startDate, CMyDateTime endDate, int nStepType) 对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。
IStatResult | stat(java.lang.String sStartDate, java.lang.String sEndDate) 对指定的开始时间sStartDate与结束时间sEndDate进行统计，返回统计的结果集对象
IStatResults | stat(java.lang.String sStartDate, java.lang.String sEndDate, int nStepType) 对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatAnalysisTool

public StatAnalysisTool(java.lang.String[] aStatSQL)
使用默认的IStatHandler对象构造统计分析对象

参数：
aStatSQL - 需要进行统计的SQL

StatAnalysisTool

public StatAnalysisTool(java.lang.String[] aStatSQL,
                        IStatHandler handler)
使用指定的IStatHandler对象构造统计分析对象

参数：
aStatSQL - 需要进行统计的SQL
handler - 统计过程中,对每一条记录执行的Handler
方法详细信息

stat

public IStatResult stat(java.lang.String sStartDate,
                        java.lang.String sEndDate)
                 throws WCMException
对指定的开始时间sStartDate与结束时间sEndDate进行统计，返回统计的结果集对象

参数：
sStartDate -
sEndData -
返回：
抛出：
WCMException

stat

public IStatResult stat(CMyDateTime startDate,
                        CMyDateTime endDate)
                 throws WCMException
对指定的开始时间startDate与结束时间endDate进行统计，返回统计的结果集对象

参数：
startDate -
endDate -
返回：
抛出：
WCMException

stat

public IStatResults stat(CMyDateTime startDate,
                         CMyDateTime endDate,
                         int nStepType)
                  throws WCMException
对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。 返回统计结果集的集合对象。

参数：
startDate - 统计的开始时间
endDate - 统计的结束时间
nStepType - 统计将采用的步长类型，可选值为 TimeRange.STEP_DAY,TimeRange.STEP_MONTH,TimeRange.STEP_QUARTER ,TimeRange.STEP_YEAR
返回：
抛出：
WCMException
CMyException

stat

public IStatResults stat(java.lang.String sStartDate,
                         java.lang.String sEndDate,
                         int nStepType)
                  throws WCMException
对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。 返回统计结果集的集合对象。

参数：
sStartDate - 统计的开始时间
sEndDate - 统计的结束时间
nStepType - 统计将采用的步长类型，可选值为 TimeRange.STEP_DAY,TimeRange.STEP_MONTH,TimeRange.STEP_QUARTER ,TimeRange.STEP_YEAR
返回：
抛出：
CMyException
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatBonusDataForUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatBonusDataForUser

java.lang.Object
    继承者  com.trs.components.stat.StatBonusDataForUser

public class StatBonusDataForUser
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
用户奖金统计类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
ffx

构造方法摘要
StatBonusDataForUser(java.lang.String _sStatSQL)
StatBonusDataForUser(java.lang.String[] _pStatSQL)
方法摘要
StatBonusResultForUser | stat(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
StatBonusResultForUser | stat(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, int _nSortBy, boolean _bSortDesc) 产生指定时间段的统计结果
StatBonusResultForUser | statHitsBonusByMonth(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, boolean _bSortDesc) 获取指定时间段的点击量奖金的统计结果
StatBonusResultForUser | statIssuedAmountBonusByMonth(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, boolean _bSortDesc) 获取发稿量奖金按月统计的结果
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatBonusDataForUser

public StatBonusDataForUser(java.lang.String _sStatSQL)

StatBonusDataForUser

public StatBonusDataForUser(java.lang.String[] _pStatSQL)
方法详细信息

stat

public StatBonusResultForUser stat(CMyDateTime _dtStartTime,
                                   CMyDateTime _dtEndTime)
                            throws java.lang.Exception
产生指定时间段的统计结果

参数：
_dtStartTime - 开始时间
_dtEndTime - 结束时间
返回：
返回统计结果对象
抛出：
java.lang.Exception

stat

public StatBonusResultForUser stat(CMyDateTime _dtStartTime,
                                   CMyDateTime _dtEndTime,
                                   int _nSortBy,
                                   boolean _bSortDesc)
                            throws java.lang.Exception
产生指定时间段的统计结果

参数：
_dtStartTime - 开始时间
_dtEndTime - 结束时间
_nSortBy - 排序字段，1为按照发稿量奖金排序，2为按照点击量奖金排序
_bSortDesc - 是否为降序
返回：
返回统计结果对象
抛出：
java.lang.Exception

statIssuedAmountBonusByMonth

public StatBonusResultForUser statIssuedAmountBonusByMonth(CMyDateTime _dtStartTime,
                                                           CMyDateTime _dtEndTime,
                                                           boolean _bSortDesc)
                                                    throws java.lang.Exception
获取发稿量奖金按月统计的结果

参数：
_dtStartTime - 开始时间
_dtEndTime - 结束时间
_bSortDesc - 是否按照降序排列
返回：
返回奖金统计结果的对象
抛出：
java.lang.Exception

statHitsBonusByMonth

public StatBonusResultForUser statHitsBonusByMonth(CMyDateTime _dtStartTime,
                                                   CMyDateTime _dtEndTime,
                                                   boolean _bSortDesc)
                                            throws java.lang.Exception
获取指定时间段的点击量奖金的统计结果

参数：
_dtStartTime - 开始时间
_dtEndTime - 结束时间
_bSortDesc - 是否为降序排列
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatBonusResultForUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatBonusResultForUser

java.lang.Object
    继承者  com.trs.components.stat.StatBonusResultForUser

public class StatBonusResultForUser
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
ffx

构造方法摘要
StatBonusResultForUser(int _nStatCount)
方法摘要
float | getBonus(java.lang.String _sUserName, int _nBonusType) 获取指定用户所获得的指定类型的奖金
java.util.List | getDocIds()
float | getHitsBonusOfMonth(java.lang.String _sUserName, int _nDocId, CMyDateTime _dateTime) 获取指定用户所发的指定文档，在指定月份的点击量奖金
int | getHitsCountOfMonth(java.lang.String _sUserName, int _nDocId, CMyDateTime _dateTime) 获取指定用户所发的指定文档，在指定月份的点击量
int | getIssuedAmountOfMonth(java.lang.String _sUserName, CMyDateTime _dateTime) 获取指定用户在指定月份的发稿量 (该方法用在按月份统计的时候，奖金的类型已经确定)
float | getIssuesAmountBonusOfMonth(java.lang.String _sUserName, CMyDateTime _dateTime) 获取指定用户在指定月份所获的奖金 (该方法在按月份统计的时候使用，这时奖金的类型已经确定)
float | getTotalBonus(java.lang.String _sUserName) 获取指定用户所获得的总奖金
java.util.List | getUserNames()
java.util.List | sort(int _nBonusType, boolean _bSortDesc) 根据指定的奖金类型进行对结果进行排序
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatBonusResultForUser

public StatBonusResultForUser(int _nStatCount)
方法详细信息

getBonus

public float getBonus(java.lang.String _sUserName,
                      int _nBonusType)
               throws WCMException
获取指定用户所获得的指定类型的奖金

参数：
_sUserName - 用户名
_nBonusType - 奖金类型
返回：
统计结果，一般大于等于0的float类型数据
抛出：
WCMException

getTotalBonus

public float getTotalBonus(java.lang.String _sUserName)
                    throws WCMException
获取指定用户所获得的总奖金

参数：
_sUserName - 用户名
返回：
总奖金，一般为大于等于0的float类型的数据
抛出：
WCMException

getIssuesAmountBonusOfMonth

public float getIssuesAmountBonusOfMonth(java.lang.String _sUserName,
                                         CMyDateTime _dateTime)
                                  throws java.lang.Exception
获取指定用户在指定月份所获的奖金 (该方法在按月份统计的时候使用，这时奖金的类型已经确定)

参数：
_sUserName - 用户名
_dateTime - 时间
返回：
统计结果，一般大于等于0的float类型的数据
抛出：
java.lang.Exception

getIssuedAmountOfMonth

public int getIssuedAmountOfMonth(java.lang.String _sUserName,
                                  CMyDateTime _dateTime)
                           throws java.lang.Exception
获取指定用户在指定月份的发稿量 (该方法用在按月份统计的时候，奖金的类型已经确定)

参数：
_sUserName - 用户名
_dateTime - 时间
返回：
统计结果，一般大于等于0的int类型的数据
抛出：
java.lang.Exception

getHitsBonusOfMonth

public float getHitsBonusOfMonth(java.lang.String _sUserName,
                                 int _nDocId,
                                 CMyDateTime _dateTime)
                          throws java.lang.Exception
获取指定用户所发的指定文档，在指定月份的点击量奖金

参数：
_sUserName - 用户名
_dateTime - 月份
返回：
统计结果，一般大于等于0的float类型的数据
抛出：
java.lang.Exception

getHitsCountOfMonth

public int getHitsCountOfMonth(java.lang.String _sUserName,
                               int _nDocId,
                               CMyDateTime _dateTime)
                        throws java.lang.Exception
获取指定用户所发的指定文档，在指定月份的点击量

参数：
_sUserName - 用户名
_dateTime - 月份
返回：
统计结果，一般大于等于0的float类型的数据
抛出：
java.lang.Exception

getUserNames

public java.util.List getUserNames()

getDocIds

public java.util.List getDocIds()

sort

public java.util.List sort(int _nBonusType,
                           boolean _bSortDesc)
根据指定的奖金类型进行对结果进行排序

参数：
_nBonusType - 奖金类型
_bSortDesc - 是否按照降序排列
返回：
排序之后的list
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatDocCountByChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatDocCountByChannel

java.lang.Object
    继承者  com.trs.components.stat.StatDocCountByChannel

public class StatDocCountByChannel
extends java.lang.Object

字段摘要
int | m_nStatModal
static int | MODAL_STAT_NORM
static int | MODAL_STAT_SNAP
构造方法摘要
StatDocCountByChannel(java.lang.String _sStatSQL)
方法摘要
CMyDateTime | createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
java.util.HashMap | stat(int _nSiteId, CMyDateTime _dtStartTime) 产生指定时间指定站点的统计结果
java.util.HashMap | stat(int _nSiteId, CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MODAL_STAT_NORM

public static final int MODAL_STAT_NORM
另请参见：
常量字段值

MODAL_STAT_SNAP

public static final int MODAL_STAT_SNAP
另请参见：
常量字段值

m_nStatModal

public int m_nStatModal
构造方法详细信息

StatDocCountByChannel

public StatDocCountByChannel(java.lang.String _sStatSQL)
方法详细信息

stat

public java.util.HashMap stat(int _nSiteId,
                              CMyDateTime _dtStartTime)
                       throws java.lang.Exception
产生指定时间指定站点的统计结果

参数：
_nSiteId -
_dtStartTime -
返回：
HashMap<栏目ID, 用户的文档数目HashMap<用户名称, 文档数目> >
抛出：
java.lang.Exception

stat

public java.util.HashMap stat(int _nSiteId,
                              CMyDateTime _dtStartTime,
                              CMyDateTime _dtEndTime)
                       throws java.lang.Exception
产生指定时间段的统计结果

参数：
_nSiteId -
_dtStartTime -
_dtEndTime -
返回：
HashMap<栏目ID, 用户的文档数目HashMap<用户名称, 文档数目> >
抛出：
java.lang.Exception

createStatDataInTempTableByDay

public CMyDateTime createStatDataInTempTableByDay(CMyDateTime _dtStartTime,
                                                  CMyDateTime _dtEndTime)
                                           throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatDocCountOfGroupByChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatDocCountOfGroupByChannel

java.lang.Object
    继承者  com.trs.components.stat.StatDocCountOfGroupByChannel

public class StatDocCountOfGroupByChannel
extends java.lang.Object

字段摘要
int | m_nStatModal
static int | MODAL_STAT_NORM
static int | MODAL_STAT_SNAP
构造方法摘要
StatDocCountOfGroupByChannel(java.lang.String _sStatSQL, int _nParentGroupId)
方法摘要
CMyDateTime | createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
java.util.HashMap | stat(int _nSiteId, CMyDateTime _dtStartTime) 产生指定时间指定站点的统计结果
java.util.HashMap | stat(int _nSiteId, CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MODAL_STAT_NORM

public static final int MODAL_STAT_NORM
另请参见：
常量字段值

MODAL_STAT_SNAP

public static final int MODAL_STAT_SNAP
另请参见：
常量字段值

m_nStatModal

public int m_nStatModal
构造方法详细信息

StatDocCountOfGroupByChannel

public StatDocCountOfGroupByChannel(java.lang.String _sStatSQL,
                                    int _nParentGroupId)
方法详细信息

stat

public java.util.HashMap stat(int _nSiteId,
                              CMyDateTime _dtStartTime)
                       throws java.lang.Exception
产生指定时间指定站点的统计结果

参数：
_nSiteId -
_dtStartTime -
返回：
HashMap<栏目ID, 组织的文档数目HashMap<组织名称_组织ID, 文档数目> >
抛出：
java.lang.Exception

stat

public java.util.HashMap stat(int _nSiteId,
                              CMyDateTime _dtStartTime,
                              CMyDateTime _dtEndTime)
                       throws java.lang.Exception
产生指定时间段的统计结果

参数：
_nSiteId -
_dtStartTime -
_dtEndTime -
返回：
HashMap<栏目ID, 组织的文档数目HashMap<组织名称_组织, 文档数目> >
抛出：
java.lang.Exception

createStatDataInTempTableByDay

public CMyDateTime createStatDataInTempTableByDay(CMyDateTime _dtStartTime,
                                                  CMyDateTime _dtEndTime)
                                           throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatDocCountOfGroupByMetaClass

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatDocCountOfGroupByMetaClass

java.lang.Object
    继承者  com.trs.components.stat.StatDocCountOfGroupByMetaClass

public class StatDocCountOfGroupByMetaClass
extends java.lang.Object

字段摘要
int | m_nStatModal
static int | MODAL_STAT_NORM
static int | MODAL_STAT_SNAP
构造方法摘要
StatDocCountOfGroupByMetaClass(java.lang.String _sStatSQL, int _nParentGroupId)
方法摘要
CMyDateTime | createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
java.util.HashMap | stat(int _nRootClassInfoId, CMyDateTime _dtStartTime) 产生指定时间指定站点的统计结果
java.util.HashMap | stat(int _nRootClassInfoId, CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MODAL_STAT_NORM

public static final int MODAL_STAT_NORM
另请参见：
常量字段值

MODAL_STAT_SNAP

public static final int MODAL_STAT_SNAP
另请参见：
常量字段值

m_nStatModal

public int m_nStatModal
构造方法详细信息

StatDocCountOfGroupByMetaClass

public StatDocCountOfGroupByMetaClass(java.lang.String _sStatSQL,
                                      int _nParentGroupId)
方法详细信息

stat

public java.util.HashMap stat(int _nRootClassInfoId,
                              CMyDateTime _dtStartTime)
                       throws java.lang.Exception
产生指定时间指定站点的统计结果

参数：
_nRootClassInfoId -
_dtStartTime -
返回：
HashMap<分类法ID, 用户的文档数目HashMap<用户名称, 文档数目> >
抛出：
java.lang.Exception

stat

public java.util.HashMap stat(int _nRootClassInfoId,
                              CMyDateTime _dtStartTime,
                              CMyDateTime _dtEndTime)
                       throws java.lang.Exception
产生指定时间段的统计结果

参数：
_nRootClassInfoId -
_dtStartTime -
_dtEndTime -
返回：
HashMap<分类法ID, 用户的文档数目HashMap<用户名称, 文档数目> >
抛出：
java.lang.Exception

createStatDataInTempTableByDay

public CMyDateTime createStatDataInTempTableByDay(CMyDateTime _dtStartTime,
                                                  CMyDateTime _dtEndTime)
                                           throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatDocCountOfUserByMetaClass

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatDocCountOfUserByMetaClass

java.lang.Object
    继承者  com.trs.components.stat.StatDocCountOfUserByMetaClass

public class StatDocCountOfUserByMetaClass
extends java.lang.Object

字段摘要
int | m_nStatModal
static int | MODAL_STAT_NORM
static int | MODAL_STAT_SNAP
构造方法摘要
StatDocCountOfUserByMetaClass(java.lang.String _sStatSQL)
方法摘要
CMyDateTime | createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
java.util.HashMap | stat(int _nRootClassInfoId, CMyDateTime _dtStartTime) 产生指定时间指定分类下的统计结果
java.util.HashMap | stat(int _nRootClassInfoId, CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MODAL_STAT_NORM

public static final int MODAL_STAT_NORM
另请参见：
常量字段值

MODAL_STAT_SNAP

public static final int MODAL_STAT_SNAP
另请参见：
常量字段值

m_nStatModal

public int m_nStatModal
构造方法详细信息

StatDocCountOfUserByMetaClass

public StatDocCountOfUserByMetaClass(java.lang.String _sStatSQL)
方法详细信息

stat

public java.util.HashMap stat(int _nRootClassInfoId,
                              CMyDateTime _dtStartTime)
                       throws java.lang.Exception
产生指定时间指定分类下的统计结果

参数：
_nRootClassInfoId -
_dtStartTime -
返回：
HashMap<分类法ID, 用户的文档数目HashMap<用户名称, 文档数目> >
抛出：
java.lang.Exception

stat

public java.util.HashMap stat(int _nRootClassInfoId,
                              CMyDateTime _dtStartTime,
                              CMyDateTime _dtEndTime)
                       throws java.lang.Exception
产生指定时间段的统计结果

参数：
_nRootClassInfoId -
_dtStartTime -
_dtEndTime -
返回：
HashMap<栏目ID, 用户的文档数目HashMap<用户名称, 文档数目> >
抛出：
java.lang.Exception

createStatDataInTempTableByDay

public CMyDateTime createStatDataInTempTableByDay(CMyDateTime _dtStartTime,
                                                  CMyDateTime _dtEndTime)
                                           throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatResult

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatResult

java.lang.Object
    继承者  com.trs.components.stat.StatResult
所有已实现的接口：
IStatResult
public class StatResult
extends java.lang.Object
implements IStatResult

执行一批SQL之后，返回的统计结果集对象，该对象一般为StatAnalysisTool.stat的返回结果

作者：
Administrator

构造方法摘要
StatResult(java.util.List _majorObjects, java.util.List _results, IKeyMaker _keyMaker)
方法摘要
IStatResult | filter(IStatResultFilter resultFilter) 使用过滤规则resultFilter对结果集进行过滤，返回过滤之后的新的结果集
int | getResult(int index, java.lang.String key) 返回第nIndex条统计SQL在key下的统计信息
int | getResult(int index, java.lang.String[] keys) 返回第nIndex条统计SQL在keys下的统计信息
int | getResult(java.lang.String key) 返回第1条统计SQL在key下的统计信息
int | getResult(java.lang.String[] keys) 返回第1条统计SQL在keys下的统计信息
java.util.List | list() 返回统计主体的集合
java.util.List | sort(boolean sortDesc) 对第1条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序
java.util.List | sort(int index, int keyIndex, java.lang.String keyValue, boolean sortDesc) 对第nSQLIndex条统计结果集中的，第nKeyIndex位key的sKeyValue值进行排序
java.util.List | sort(int index, java.lang.String keyValue, boolean sortDesc) 对第nSQLIndex条统计结果集中的，第3位key的sKeyValue值进行排序
java.util.List | sortByMajorObject(boolean sortDesc) 对第1条统计结果集中的，按主体对象进行排序
java.util.List | sortWithSQLIndex(int index, boolean sortDesc) 对第nSQLIndex条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序 一般仅对select包含两个字段有效
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatResult

public StatResult(java.util.List _majorObjects,
                  java.util.List _results,
                  IKeyMaker _keyMaker)
参数：
_majorObjects - 统计主体
_results - 统计结果集
_keyMaker - 统计结果集中key的构造器
方法详细信息

getResult

public int getResult(java.lang.String[] keys)
从接口 IStatResult 复制的描述
返回第1条统计SQL在keys下的统计信息

指定者：
接口 IStatResult 中的 getResult
参数：
keys - 统计SQL的select部分中的字段信息
返回：

getResult

public int getResult(int index,
                     java.lang.String[] keys)
从接口 IStatResult 复制的描述
返回第nIndex条统计SQL在keys下的统计信息

指定者：
接口 IStatResult 中的 getResult
参数：
index - 第几条统计SQL，索引值从1开始
keys - 统计SQL的select部分中的字段信息
返回：

getResult

public int getResult(int index,
                     java.lang.String key)
从接口 IStatResult 复制的描述
返回第nIndex条统计SQL在key下的统计信息

指定者：
接口 IStatResult 中的 getResult
参数：
index - 第几条统计SQL，索引值从1开始
key - 统计SQL的select部分中的字段信息
返回：

getResult

public int getResult(java.lang.String key)
从接口 IStatResult 复制的描述
返回第1条统计SQL在key下的统计信息

指定者：
接口 IStatResult 中的 getResult
参数：
key - 统计SQL的select部分中的字段信息
返回：

filter

public IStatResult filter(IStatResultFilter resultFilter)
从接口 IStatResult 复制的描述
使用过滤规则resultFilter对结果集进行过滤，返回过滤之后的新的结果集

指定者：
接口 IStatResult 中的 filter
返回：
返回过滤之后的结果集

sort

public java.util.List sort(boolean sortDesc)
                    throws WCMException
从接口 IStatResult 复制的描述
对第1条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序

指定者：
接口 IStatResult 中的 sort
参数：
sortDesc - 是否为降序
返回：
返回排完序之后的主体key信息
抛出：
WCMException

sort

public java.util.List sort(int index,
                           int keyIndex,
                           java.lang.String keyValue,
                           boolean sortDesc)
                    throws WCMException
从接口 IStatResult 复制的描述
对第nSQLIndex条统计结果集中的，第nKeyIndex位key的sKeyValue值进行排序

指定者：
接口 IStatResult 中的 sort
参数：
index - 第几条统计SQL，索引值从1开始计数
keyIndex - 某条统计SQL中，第几个select字段,从3开始计数
keyValue - 索引位为nKeyIndex的索引值
返回：
返回排完序之后的主体key信息，主体一般为第2个select字段
抛出：
WCMException

sort

public java.util.List sort(int index,
                           java.lang.String keyValue,
                           boolean sortDesc)
                    throws WCMException
从接口 IStatResult 复制的描述
对第nSQLIndex条统计结果集中的，第3位key的sKeyValue值进行排序

指定者：
接口 IStatResult 中的 sort
参数：
index - 第几条统计SQL，索引值从1开始计数
keyValue - select字段索引位为3的索引值
返回：
返回排完序之后的主体key信息，主体一般为第2个select字段
抛出：
WCMException

sortByMajorObject

public java.util.List sortByMajorObject(boolean sortDesc)
从接口 IStatResult 复制的描述
对第1条统计结果集中的，按主体对象进行排序

指定者：
接口 IStatResult 中的 sortByMajorObject
参数：
sortDesc - 是否为降序
返回：
返回排完序之后的主体key信息，主体一般为第2个select字段

sortWithSQLIndex

public java.util.List sortWithSQLIndex(int index,
                                       boolean sortDesc)
                                throws WCMException
从接口 IStatResult 复制的描述
对第nSQLIndex条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序
一般仅对select包含两个字段有效

指定者：
接口 IStatResult 中的 sortWithSQLIndex
参数：
index - 第几条统计SQL，索引值从1开始
sortDesc - 是否为降序
返回：
返回排完序之后的主体key信息，主体一般为第2个select字段
抛出：
WCMException

list

public java.util.List list()
从接口 IStatResult 复制的描述
返回统计主体的集合

指定者：
接口 IStatResult 中的 list
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatResults

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 StatResults

java.lang.Object
    继承者  com.trs.components.stat.StatResults
所有已实现的接口：
IStatResults
public class StatResults
extends java.lang.Object
implements IStatResults

构造方法摘要
StatResults()
StatResults(java.util.List _majorObjects, java.util.List _results, java.util.List _labels)
方法摘要
void | addMainObjs(IStatResult result) 添加主体对象
void | addResult(IStatResult result) 添加每一个步长的结果集到总结果集中
void | addXlabels(java.lang.String sCurrLabel) 添加页面中走势图的下标集合
IStatResults | filter(IStatResultsFilter resultsFilter) 使用过滤规则resultFilter对结果集集合进行过滤，返回过滤之后的新的结果集集合
java.util.List | getResult(int nIndex, java.lang.String sKey) 从结果集中根据所给的参数 sKey，返回第nIndex条SQL对应的结果list
java.util.List | getResult(int index, java.lang.String[] keys) 返回第n条SQL的，Key为数组的结果集
java.util.List | getResult(java.lang.String sKey) 从结果集中根据所给的参数 sKey，返回该参数所对应的结果list
java.util.List | getResult(java.lang.String[] keys) 返回第一条SQL的，以key为关键数组的值
java.util.List | getXlabels() 获取走势图的X下标内容
java.util.List | list() 返回主体集合
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatResults

public StatResults()

StatResults

public StatResults(java.util.List _majorObjects,
                   java.util.List _results,
                   java.util.List _labels)
参数：
_majorObjects - 统计主体
_results - 统计结果集
方法详细信息

addResult

public void addResult(IStatResult result)
添加每一个步长的结果集到总结果集中

指定者：
接口 IStatResults 中的 addResult

addMainObjs

public void addMainObjs(IStatResult result)
添加主体对象

参数：
result -

getResult

public java.util.List getResult(java.lang.String sKey)
从接口 IStatResults 复制的描述
从结果集中根据所给的参数 sKey，返回该参数所对应的结果list

指定者：
接口 IStatResults 中的 getResult

getResult

public java.util.List getResult(int nIndex,
                                java.lang.String sKey)
从接口 IStatResults 复制的描述
从结果集中根据所给的参数 sKey，返回第nIndex条SQL对应的结果list

指定者：
接口 IStatResults 中的 getResult

getResult

public java.util.List getResult(int index,
                                java.lang.String[] keys)
从接口 IStatResults 复制的描述
返回第n条SQL的，Key为数组的结果集

指定者：
接口 IStatResults 中的 getResult
返回：

getResult

public java.util.List getResult(java.lang.String[] keys)
从接口 IStatResults 复制的描述
返回第一条SQL的，以key为关键数组的值

指定者：
接口 IStatResults 中的 getResult
返回：

filter

public IStatResults filter(IStatResultsFilter resultsFilter)
                    throws WCMException
从接口 IStatResults 复制的描述
使用过滤规则resultFilter对结果集集合进行过滤，返回过滤之后的新的结果集集合

指定者：
接口 IStatResults 中的 filter
返回：
返回过滤之后的结果集集合
抛出：
WCMException

list

public java.util.List list()
从接口 IStatResults 复制的描述
返回主体集合

指定者：
接口 IStatResults 中的 list
返回：

addXlabels

public void addXlabels(java.lang.String sCurrLabel)
从接口 IStatResults 复制的描述
添加页面中走势图的下标集合

指定者：
接口 IStatResults 中的 addXlabels

getXlabels

public java.util.List getXlabels()
从接口 IStatResults 复制的描述
获取走势图的X下标内容

指定者：
接口 IStatResults 中的 getXlabels
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimeRange

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 TimeRange

java.lang.Object
    继承者  com.trs.components.stat.TimeRange

public class TimeRange
extends java.lang.Object

用于按照指定的步长，处理开始时间与结束时间

作者：
Administrator

字段摘要
static int | STEP_DAY
static int | STEP_MONTH
static int | STEP_QUARTER
static int | STEP_YEAR
构造方法摘要
TimeRange(CMyDateTime startDate, CMyDateTime endDate, int nStepType)
方法摘要
CMyDateTime | getRangeEnd() 获取当前位置下，指定步长之内，跨度的结束时间
CMyDateTime | getRangeStart() 获取当前位置下，指定步长之内，跨度的开始时间
java.lang.String | getXlabel() 根据当前的开始时间和结束时间获取X的坐标内容
boolean | next() 判断当前是否还能获取到下一步长的时间
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STEP_DAY

public static final int STEP_DAY
另请参见：
常量字段值

STEP_MONTH

public static final int STEP_MONTH
另请参见：
常量字段值

STEP_YEAR

public static final int STEP_YEAR
另请参见：
常量字段值

STEP_QUARTER

public static final int STEP_QUARTER
另请参见：
常量字段值
构造方法详细信息

TimeRange

public TimeRange(CMyDateTime startDate,
                 CMyDateTime endDate,
                 int nStepType)
参数：
startDate -
endDate -
nStepType -
方法详细信息

next

public boolean next()
             throws CMyException
判断当前是否还能获取到下一步长的时间

返回：
如果能获取到，则返回true；否则返回false
抛出：
CMyException

getXlabel

public java.lang.String getXlabel()
                           throws CMyException
根据当前的开始时间和结束时间获取X的坐标内容

返回：
抛出：
CMyException

getRangeStart

public CMyDateTime getRangeStart()
获取当前位置下，指定步长之内，跨度的开始时间

返回：

getRangeEnd

public CMyDateTime getRangeEnd()
获取当前位置下，指定步长之内，跨度的结束时间

返回：
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 URLParser

java.lang.Object
    继承者  com.trs.components.stat.URLParser
所有已实现的接口：
IURLParser
public class URLParser
extends java.lang.Object
implements IURLParser

构造方法摘要
URLParser()
方法摘要
 BaseObj parse(java.lang.String sUrl)
根据Url信息，返回该Url对应的BaseObj对象。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

URLParser

public URLParser()
方法详细信息

parse

public BaseObj parse(java.lang.String sUrl)
              throws WCMException
从接口 IURLParser 复制的描述
根据Url信息，返回该Url对应的BaseObj对象。 如:根据文档的发布地址，得到该文档； 根据栏目的地址，得到栏目对象； 同时需要考虑栏目二级域名的情况。

指定者：
接口 IURLParser 中的 parse
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserLoginInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 UserLoginInfo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.stat.UserLoginInfo
所有已实现的接口：
java.lang.Cloneable
public class UserLoginInfo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
UserLoginInfo()
构造函数：保留默认接口
方法摘要
static UserLoginInfo | createNewInstance() 产生当前对象[UserLoginInfo]的实例
static UserLoginInfo | findById(int _nId) 提取指定ID的对象
static UserLoginInfo | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getIpAddress() 提取属性：IpAddress，登录的IP地址
CMyDateTime | getLoginTime() 提取属性：LoginTime，用户登录时间
int | getUserId() 提取属性：UserId，用户ID
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setIpAddress(java.lang.String _sIpAddress) 设置属性：IpAddress，登陆的IP地址
boolean | setLoginTime(CMyDateTime _dtLoginTime) 设置属性：LoginTime，用户登录时间
boolean | setUserId(int _nUserId) 设置属性：UserId，用户ID
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

UserLoginInfo

public UserLoginInfo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getUserId

public int getUserId()
提取属性：UserId，用户ID

返回：
UserId

setUserId

public boolean setUserId(int _nUserId)
                  throws WCMException
设置属性：UserId，用户ID

参数：
_nUserId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLoginTime

public CMyDateTime getLoginTime()
提取属性：LoginTime，用户登录时间

返回：
LoginTime

setLoginTime

public boolean setLoginTime(CMyDateTime _dtLoginTime)
                     throws WCMException
设置属性：LoginTime，用户登录时间

参数：
_dtLoginTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIpAddress

public java.lang.String getIpAddress()
提取属性：IpAddress，登录的IP地址

返回：
IpAddress

setIpAddress

public boolean setIpAddress(java.lang.String _sIpAddress)
                     throws WCMException
设置属性：IpAddress，登陆的IP地址

参数：
_sIpAddress - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final UserLoginInfo findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final UserLoginInfo createNewInstance()
                                             throws WCMException
产生当前对象[UserLoginInfo]的实例

返回：
当前对象的实例[UserLoginInfo]
抛出：
WCMException

findByKey

public static final UserLoginInfo findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserLoginInfoMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 UserLoginInfoMgr

java.lang.Object
    继承者  com.trs.components.stat.UserLoginInfoMgr
所有已实现的接口：
IUserLoginInfoMgr
public class UserLoginInfoMgr
extends java.lang.Object
implements IUserLoginInfoMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
用户登录信息的业务逻辑处理类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
chenchang

构造方法摘要
UserLoginInfoMgr()
方法摘要
java.lang.String | getCurrUser(User _oUser) 获取用户自己的构造条件，返回用户名的userId
java.lang.String | getSearchGroupName(java.lang.String _groupName) 部门名称检索,返回所属部门所有用户的userId
java.lang.String | getSearchUserName(java.lang.String _userName) 用户名称检索,返回用户名的userId
java.lang.String | getUsersForGrpAdmin(User _oUser) 获取组管理员所管理组的所有用户，返回所有用戶的userId
UserLoginInfos | query(User _oCurrUser, WCMFilter _filter) 查询指定条件下的用户登录信息
UserLoginInfo | save(UserLoginInfo _oUserLoginInfo, User _oCurrUser) 保存当前用户登录信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserLoginInfoMgr

public UserLoginInfoMgr()
方法详细信息

query

public UserLoginInfos query(User _oCurrUser,
                            WCMFilter _filter)
                     throws WCMException
查询指定条件下的用户登录信息

指定者：
接口 IUserLoginInfoMgr 中的 query
参数：
_oCurrUser - 当前登录用户
_oFilter - 获取到的查询和排序条件
返回：
UserLoginInfos 返回的是用户登录信息结果集
抛出：
WCMException

save

public UserLoginInfo save(UserLoginInfo _oUserLoginInfo,
                          User _oCurrUser)
                   throws WCMException
保存当前用户登录信息

指定者：
接口 IUserLoginInfoMgr 中的 save
参数：
_oUserLoginInfo - 用户登录信息实体对象
_oCurrUser - 当前登录用户
返回：
UserLoginInfo 返回用户登录信息
抛出：
WCMException

getSearchUserName

public java.lang.String getSearchUserName(java.lang.String _userName)
用户名称检索,返回用户名的userId

指定者：
接口 IUserLoginInfoMgr 中的 getSearchUserName
参数：
_userName - 用户名称
返回：
sWhere 构造检索userId的sql语句，进行返回

getSearchGroupName

public java.lang.String getSearchGroupName(java.lang.String _groupName)
部门名称检索,返回所属部门所有用户的userId

指定者：
接口 IUserLoginInfoMgr 中的 getSearchGroupName
参数：
_groupName - 部门名称
返回：
sWhere 构造检索userId的sql语句，进行返回

getUsersForGrpAdmin

public java.lang.String getUsersForGrpAdmin(User _oUser)
获取组管理员所管理组的所有用户，返回所有用戶的userId

指定者：
接口 IUserLoginInfoMgr 中的 getUsersForGrpAdmin
参数：
_oUser - 组管理员名称 １、首先获取用户所能管理的所有组 ２、获取所属组织的所有用户
返回：
sWhere 构造检索userId的sql语句，进行返回

getCurrUser

public java.lang.String getCurrUser(User _oUser)
                             throws WCMException
获取用户自己的构造条件，返回用户名的userId

指定者：
接口 IUserLoginInfoMgr 中的 getCurrUser
参数：
_userName - 用户名称
返回：
sWhere 构造检索userId的sql语句，进行返回
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserLoginInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 UserLoginInfos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.stat.UserLoginInfos

public class UserLoginInfos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
UserLoginInfos(User _currUser)
构造函数
UserLoginInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static UserLoginInfos | createNewInstance(User _currUser) 产生当前集合对象[UserLoginInfos]的实例
static UserLoginInfos | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static UserLoginInfos | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[UserLoginInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserLoginInfos

public UserLoginInfos(User _currUser)
构造函数

另请参见：
UserLoginInfos( User _currUser, int _initCapacity, int _incCapacity );

UserLoginInfos

public UserLoginInfos(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final UserLoginInfos findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（UserLoginInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final UserLoginInfos openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[UserLoginInfos]

参数：
_filter - 指定的Filter
返回：
当前集合[UserLoginInfos]
抛出：
WCMException

createNewInstance

public static UserLoginInfos createNewInstance(User _currUser)
产生当前集合对象[UserLoginInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserLoginInfoServiceProvider

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.stat
类 UserLoginInfoServiceProvider

java.lang.Object
    继承者  com.trs.components.stat.UserLoginInfoServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class UserLoginInfoServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
用户登录信息的服务层类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
chenchang

构造方法摘要
UserLoginInfoServiceProvider()
方法摘要
void | delete(MethodContext context)
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.lang.Object | query(MethodContext context) 查询指定条件的记录。
int | save(MethodContext context) 这里要实现的是存储一条当前用户登陆信息。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserLoginInfoServiceProvider

public UserLoginInfoServiceProvider()
方法详细信息

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
查询指定条件的记录。 1、首先拼接检索条件 2、其次做权限判断 3、返回结果集

指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
这里要实现的是存储一条当前用户登陆信息。

指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.stat.BaseStatHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.BaseStatHandler
的使用

使用 BaseStatHandler 的软件包
com.trs.components.stat

com.trs.components.stat 中 BaseStatHandler 的使用

com.trs.components.stat 中 BaseStatHandler 的子类
class | DefaultStatHandler 默认的统计处理类
class | DocStatHandler4Channel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChannelOfGroup Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocstatHandler4ChannelOfUser Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChnlDept
class | DocStatHandler4ChnlDeptChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChnlDeptSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4SiteOfGroup Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocstatHandler4SiteOfUser Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserDept
class | DocStatHandler4UserDeptChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserDeptSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4Channel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4ChnlDept
class | HitsStatHandler4User Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4UserDept

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.BonusCalculator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.BonusCalculator
的使用

没有 com.trs.components.stat.BonusCalculator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.BonusRule 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.BonusRule
的使用

使用 BonusRule 的软件包
com.trs.components.stat

com.trs.components.stat 中 BonusRule 的使用

返回 BonusRule 的 com.trs.components.stat 中的方法
static BonusRule | BonusRule.createNewInstance() 产生当前对象[BonusRule]的实例
static BonusRule | BonusRule.findById(int _nId) 提取指定ID的对象
static BonusRule | BonusRule.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
BonusRule | BonusRuleMgr.save(User _oCurrUser, BonusRule _oBonusRule)
BonusRule | IBonusRuleMgr.save(User _oCurrUser, BonusRule _oBonusRule)
BonusRule | BonusRuleMgr.save(User _oCurrUser, int _nBonusType, java.lang.String _sRange, float _fPricePerUnit) 保存当前奖励规则
BonusRule | IBonusRuleMgr.save(User _oCurrUser, int _nBonusType, java.lang.String _sRange, float _fPricePerUnit) 保存当前奖励规则

参数类型为 BonusRule 的 com.trs.components.stat 中的方法
BonusRule | BonusRuleMgr.save(User _oCurrUser, BonusRule _oBonusRule)
BonusRule | IBonusRuleMgr.save(User _oCurrUser, BonusRule _oBonusRule)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.BonusRuleMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.BonusRuleMgr
的使用

没有 com.trs.components.stat.BonusRuleMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.BonusRules 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.BonusRules
的使用

使用 BonusRules 的软件包
com.trs.components.stat

com.trs.components.stat 中 BonusRules 的使用

返回 BonusRules 的 com.trs.components.stat 中的方法
static BonusRules | BonusRules.createNewInstance(User _currUser) 产生当前集合对象[BonusRules]的实例
static BonusRules | BonusRules.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static BonusRules | BonusRules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[BonusRules]
BonusRules | BonusRuleMgr.query(User _oCurrUser, WCMFilter _oFilter) 查询系统指定奖励规则
BonusRules | IBonusRuleMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询系统指定奖励规则

参数类型为 BonusRules 的 com.trs.components.stat 中的方法
boolean | BonusRuleMgr.delete(User _oCurrUser, BonusRules _oBonusRules) 删除指定的奖励规则
boolean | IBonusRuleMgr.delete(User _oCurrUser, BonusRules _oBonusRules) 删除指定的奖励规则

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.BonusRuleServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.BonusRuleServiceProvider
的使用

没有 com.trs.components.stat.BonusRuleServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.ChannelHitsCountHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.ChannelHitsCountHandler
的使用

没有 com.trs.components.stat.ChannelHitsCountHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.ChnlDept 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.ChnlDept
的使用

使用 ChnlDept 的软件包
com.trs.components.stat

com.trs.components.stat 中 ChnlDept 的使用

返回 ChnlDept 的 com.trs.components.stat 中的方法
static ChnlDept | ChnlDept.createNewInstance() 产生当前对象[ChnlDept]的实例
static ChnlDept | ChnlDept.findById(int _nId) 提取指定ID的对象
static ChnlDept | ChnlDept.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.ChnlDeptMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.ChnlDeptMgr
的使用

没有 com.trs.components.stat.ChnlDeptMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.ChnlDeptMgrForCluster 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.ChnlDeptMgrForCluster
的使用

没有 com.trs.components.stat.ChnlDeptMgrForCluster 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.ChnlDepts 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.ChnlDepts
的使用

使用 ChnlDepts 的软件包
com.trs.components.stat

com.trs.components.stat 中 ChnlDepts 的使用

返回 ChnlDepts 的 com.trs.components.stat 中的方法
static ChnlDepts | ChnlDepts.createNewInstance(User _currUser) 产生当前集合对象[ChnlDepts]的实例
static ChnlDepts | ChnlDepts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ChnlDepts | ChnlDepts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChnlDepts]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DefaultStatHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DefaultStatHandler
的使用

没有 com.trs.components.stat.DefaultStatHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4Channel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4Channel
的使用

没有 com.trs.components.stat.DocStatHandler4Channel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4ChannelOfGroup 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4ChannelOfGroup
的使用

没有 com.trs.components.stat.DocStatHandler4ChannelOfGroup 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocstatHandler4ChannelOfUser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocstatHandler4ChannelOfUser
的使用

没有 com.trs.components.stat.DocstatHandler4ChannelOfUser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4ChnlDept 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4ChnlDept
的使用

没有 com.trs.components.stat.DocStatHandler4ChnlDept 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4ChnlDeptChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4ChnlDeptChannel
的使用

没有 com.trs.components.stat.DocStatHandler4ChnlDeptChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4ChnlDeptSite 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4ChnlDeptSite
的使用

没有 com.trs.components.stat.DocStatHandler4ChnlDeptSite 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4SiteOfGroup 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4SiteOfGroup
的使用

没有 com.trs.components.stat.DocStatHandler4SiteOfGroup 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocstatHandler4SiteOfUser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocstatHandler4SiteOfUser
的使用

没有 com.trs.components.stat.DocstatHandler4SiteOfUser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4UserChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4UserChannel
的使用

没有 com.trs.components.stat.DocStatHandler4UserChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4UserDept 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4UserDept
的使用

没有 com.trs.components.stat.DocStatHandler4UserDept 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4UserDeptChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4UserDeptChannel
的使用

没有 com.trs.components.stat.DocStatHandler4UserDeptChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4UserDeptSite 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4UserDeptSite
的使用

没有 com.trs.components.stat.DocStatHandler4UserDeptSite 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocStatHandler4UserSite 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocStatHandler4UserSite
的使用

没有 com.trs.components.stat.DocStatHandler4UserSite 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocumentHitsCount 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocumentHitsCount
的使用

使用 DocumentHitsCount 的软件包
com.trs.components.stat

com.trs.components.stat 中 DocumentHitsCount 的使用

返回 DocumentHitsCount 的 com.trs.components.stat 中的方法
static DocumentHitsCount | DocumentHitsCount.createNewInstance() 产生当前对象[DocumentHitsCount]的实例
static DocumentHitsCount | DocumentHitsCount.findById(int _nId) 提取指定ID的对象
static DocumentHitsCount | DocumentHitsCount.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocumentHitsCountHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocumentHitsCountHandler
的使用

没有 com.trs.components.stat.DocumentHitsCountHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.DocumentHitsCounts 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.DocumentHitsCounts
的使用

使用 DocumentHitsCounts 的软件包
com.trs.components.stat

com.trs.components.stat 中 DocumentHitsCounts 的使用

返回 DocumentHitsCounts 的 com.trs.components.stat 中的方法
static DocumentHitsCounts | DocumentHitsCounts.createNewInstance(User _currUser) 产生当前集合对象[DocumentHitsCounts]的实例
static DocumentHitsCounts | DocumentHitsCounts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DocumentHitsCounts | DocumentHitsCounts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocumentHitsCounts]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HitsCountConstant 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HitsCountConstant
的使用

没有 com.trs.components.stat.HitsCountConstant 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HitsCountHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HitsCountHelper
的使用

没有 com.trs.components.stat.HitsCountHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HitsCountParserSchedule 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HitsCountParserSchedule
的使用

没有 com.trs.components.stat.HitsCountParserSchedule 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HitsStatHandler4Channel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HitsStatHandler4Channel
的使用

没有 com.trs.components.stat.HitsStatHandler4Channel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HitsStatHandler4ChnlDept 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HitsStatHandler4ChnlDept
的使用

没有 com.trs.components.stat.HitsStatHandler4ChnlDept 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HitsStatHandler4User 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HitsStatHandler4User
的使用

没有 com.trs.components.stat.HitsStatHandler4User 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HitsStatHandler4UserDept 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HitsStatHandler4UserDept
的使用

没有 com.trs.components.stat.HitsStatHandler4UserDept 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HostObjDomain 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HostObjDomain
的使用

使用 HostObjDomain 的软件包
com.trs.components.stat

com.trs.components.stat 中 HostObjDomain 的使用

返回 HostObjDomain 的 com.trs.components.stat 中的方法
static HostObjDomain | HostObjDomain.createNewInstance() 产生当前对象[HostObjDomain]的实例
static HostObjDomain | HostObjDomain.findById(int _nId) 提取指定ID的对象
static HostObjDomain | HostObjDomain.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HostObjDomains 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HostObjDomains
的使用

使用 HostObjDomains 的软件包
com.trs.components.stat

com.trs.components.stat 中 HostObjDomains 的使用

返回 HostObjDomains 的 com.trs.components.stat 中的方法
static HostObjDomains | HostObjDomains.createNewInstance(User _currUser) 产生当前集合对象[HostObjDomains]的实例
static HostObjDomains | HostObjDomains.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static HostObjDomains | HostObjDomains.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[HostObjDomains]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HostObjHitsCount 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HostObjHitsCount
的使用

使用 HostObjHitsCount 的软件包
com.trs.components.stat

com.trs.components.stat 中 HostObjHitsCount 的使用

返回 HostObjHitsCount 的 com.trs.components.stat 中的方法
static HostObjHitsCount | HostObjHitsCount.createNewInstance() 产生当前对象[HostObjHitsCount]的实例
static HostObjHitsCount | HostObjHitsCount.findById(int _nId) 提取指定ID的对象
static HostObjHitsCount | HostObjHitsCount.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.HostObjHitsCounts 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.HostObjHitsCounts
的使用

使用 HostObjHitsCounts 的软件包
com.trs.components.stat

com.trs.components.stat 中 HostObjHitsCounts 的使用

返回 HostObjHitsCounts 的 com.trs.components.stat 中的方法
static HostObjHitsCounts | HostObjHitsCounts.createNewInstance(User _currUser) 产生当前集合对象[HostObjHitsCounts]的实例
static HostObjHitsCounts | HostObjHitsCounts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static HostObjHitsCounts | HostObjHitsCounts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[HostObjHitsCounts]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IBonusCalculator 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IBonusCalculator
的使用

使用 IBonusCalculator 的软件包
com.trs.components.stat

com.trs.components.stat 中 IBonusCalculator 的使用

实现 IBonusCalculator 的 com.trs.components.stat 中的类
 class BonusCalculator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IBonusRuleMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IBonusRuleMgr
的使用

使用 IBonusRuleMgr 的软件包
com.trs.components.stat

com.trs.components.stat 中 IBonusRuleMgr 的使用

实现 IBonusRuleMgr 的 com.trs.components.stat 中的类
 class BonusRuleMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
奖励规则的业务逻辑处理类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IChnlDeptMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IChnlDeptMgr
的使用

使用 IChnlDeptMgr 的软件包
com.trs.components.stat

com.trs.components.stat 中 IChnlDeptMgr 的使用

实现 IChnlDeptMgr 的 com.trs.components.stat 中的类
 class ChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IHitsCountHandler 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IHitsCountHandler
的使用

使用 IHitsCountHandler 的软件包
com.trs.components.stat

com.trs.components.stat 中 IHitsCountHandler 的使用

实现 IHitsCountHandler 的 com.trs.components.stat 中的类
class | ChannelHitsCountHandler
class | DocumentHitsCountHandler 处理文档对象的点击量更新
class | SiteHitsCountHandler

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IKeyMaker 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IKeyMaker
的使用

使用 IKeyMaker 的软件包
com.trs.components.stat

com.trs.components.stat 中 IKeyMaker 的使用

实现 IKeyMaker 的 com.trs.components.stat 中的类
class | BaseStatHandler 屏蔽key构造及反解的细节；屏蔽统计结果的数据存储结构
class | DefaultStatHandler 默认的统计处理类
class | DocStatHandler4Channel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChannelOfGroup Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocstatHandler4ChannelOfUser Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChnlDept
class | DocStatHandler4ChnlDeptChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChnlDeptSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4SiteOfGroup Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocstatHandler4SiteOfUser Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserDept
class | DocStatHandler4UserDeptChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserDeptSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4Channel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4ChnlDept
class | HitsStatHandler4User Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4UserDept

参数类型为 IKeyMaker 的 com.trs.components.stat 中的构造方法
StatResult(java.util.List _majorObjects, java.util.List _results, IKeyMaker _keyMaker)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IStatHandler 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IStatHandler
的使用

使用 IStatHandler 的软件包
com.trs.components.stat

com.trs.components.stat 中 IStatHandler 的使用

实现 IStatHandler 的 com.trs.components.stat 中的类
class | BaseStatHandler 屏蔽key构造及反解的细节；屏蔽统计结果的数据存储结构
class | DefaultStatHandler 默认的统计处理类
class | DocStatHandler4Channel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChannelOfGroup Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocstatHandler4ChannelOfUser Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChnlDept
class | DocStatHandler4ChnlDeptChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4ChnlDeptSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4SiteOfGroup Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocstatHandler4SiteOfUser Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserDept
class | DocStatHandler4UserDeptChannel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserDeptSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | DocStatHandler4UserSite Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4Channel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4ChnlDept
class | HitsStatHandler4User Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | HitsStatHandler4UserDept

参数类型为 IStatHandler 的 com.trs.components.stat 中的构造方法
StatAnalysisTool(java.lang.String[] aStatSQL, IStatHandler handler)
使用指定的IStatHandler对象构造统计分析对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IStatResult 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IStatResult
的使用

使用 IStatResult 的软件包
com.trs.components.stat

com.trs.components.stat 中 IStatResult 的使用

实现 IStatResult 的 com.trs.components.stat 中的类
 class StatResult
执行一批SQL之后，返回的统计结果集对象，该对象一般为StatAnalysisTool.stat的返回结果

返回 IStatResult 的 com.trs.components.stat 中的方法
IStatResult | IStatResult.filter(IStatResultFilter resultFilter) 使用过滤规则resultFilter对结果集进行过滤，返回过滤之后的新的结果集
IStatResult | StatResult.filter(IStatResultFilter resultFilter)
IStatResult | BaseStatHandler.getResult()
IStatResult | IStatHandler.getResult() 返回visitStatItem累积之后的结果集
IStatResult | StatAnalysisTool.stat(CMyDateTime startDate, CMyDateTime endDate) 对指定的开始时间startDate与结束时间endDate进行统计，返回统计的结果集对象
IStatResult | StatAnalysisTool.stat(java.lang.String sStartDate, java.lang.String sEndDate) 对指定的开始时间sStartDate与结束时间sEndDate进行统计，返回统计的结果集对象

参数类型为 IStatResult 的 com.trs.components.stat 中的方法
boolean | IStatResultFilter.accept(java.lang.String sKey, IStatResult statResult) 过滤结果集中的数据
void | StatResults.addMainObjs(IStatResult result) 添加主体对象
void | IStatResults.addResult(IStatResult result) 向结果集的集合中添加结果集
void | StatResults.addResult(IStatResult result) 添加每一个步长的结果集到总结果集中

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IStatResultFilter 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IStatResultFilter
的使用

使用 IStatResultFilter 的软件包
com.trs.components.stat

com.trs.components.stat 中 IStatResultFilter 的使用

参数类型为 IStatResultFilter 的 com.trs.components.stat 中的方法
IStatResult | IStatResult.filter(IStatResultFilter resultFilter) 使用过滤规则resultFilter对结果集进行过滤，返回过滤之后的新的结果集
IStatResult | StatResult.filter(IStatResultFilter resultFilter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IStatResults 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IStatResults
的使用

使用 IStatResults 的软件包
com.trs.components.stat

com.trs.components.stat 中 IStatResults 的使用

实现 IStatResults 的 com.trs.components.stat 中的类
 class StatResults

返回 IStatResults 的 com.trs.components.stat 中的方法
IStatResults | IStatResults.filter(IStatResultsFilter resultsFilter) 使用过滤规则resultFilter对结果集集合进行过滤，返回过滤之后的新的结果集集合
IStatResults | StatResults.filter(IStatResultsFilter resultsFilter)
IStatResults | StatAnalysisTool.stat(CMyDateTime startDate, CMyDateTime endDate, int nStepType) 对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。
IStatResults | StatAnalysisTool.stat(java.lang.String sStartDate, java.lang.String sEndDate, int nStepType) 对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。

参数类型为 IStatResults 的 com.trs.components.stat 中的方法
 boolean IStatResultsFilter.accept(java.lang.String sKey, IStatResults statResults)
过滤结果集集合中的数据

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IStatResultsFilter 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IStatResultsFilter
的使用

使用 IStatResultsFilter 的软件包
com.trs.components.stat

com.trs.components.stat 中 IStatResultsFilter 的使用

参数类型为 IStatResultsFilter 的 com.trs.components.stat 中的方法
IStatResults | IStatResults.filter(IStatResultsFilter resultsFilter) 使用过滤规则resultFilter对结果集集合进行过滤，返回过滤之后的新的结果集集合
IStatResults | StatResults.filter(IStatResultsFilter resultsFilter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IURLParser 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IURLParser
的使用

使用 IURLParser 的软件包
com.trs.components.stat

com.trs.components.stat 中 IURLParser 的使用

实现 IURLParser 的 com.trs.components.stat 中的类
 class URLParser

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.stat.IUserLoginInfoMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.stat.IUserLoginInfoMgr
的使用

使用 IUserLoginInfoMgr 的软件包
com.trs.components.stat

com.trs.components.stat 中 IUserLoginInfoMgr 的使用

实现 IUserLoginInfoMgr 的 com.trs.components.stat 中的类
 class UserLoginInfoMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
用户登录信息的业务逻辑处理类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.SiteHitsCountHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.SiteHitsCountHandler
的使用

没有 com.trs.components.stat.SiteHitsCountHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatAnalysisTool 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatAnalysisTool
的使用

没有 com.trs.components.stat.StatAnalysisTool 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatBonusDataForUser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatBonusDataForUser
的使用

没有 com.trs.components.stat.StatBonusDataForUser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatBonusResultForUser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatBonusResultForUser
的使用

使用 StatBonusResultForUser 的软件包
com.trs.components.stat

com.trs.components.stat 中 StatBonusResultForUser 的使用

返回 StatBonusResultForUser 的 com.trs.components.stat 中的方法
StatBonusResultForUser | StatBonusDataForUser.stat(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
StatBonusResultForUser | StatBonusDataForUser.stat(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, int _nSortBy, boolean _bSortDesc) 产生指定时间段的统计结果
StatBonusResultForUser | StatBonusDataForUser.statHitsBonusByMonth(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, boolean _bSortDesc) 获取指定时间段的点击量奖金的统计结果
StatBonusResultForUser | StatBonusDataForUser.statIssuedAmountBonusByMonth(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, boolean _bSortDesc) 获取发稿量奖金按月统计的结果

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatDocCountByChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatDocCountByChannel
的使用

没有 com.trs.components.stat.StatDocCountByChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatDocCountOfGroupByChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatDocCountOfGroupByChannel
的使用

没有 com.trs.components.stat.StatDocCountOfGroupByChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatDocCountOfGroupByMetaClass 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatDocCountOfGroupByMetaClass
的使用

没有 com.trs.components.stat.StatDocCountOfGroupByMetaClass 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatDocCountOfUserByMetaClass 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatDocCountOfUserByMetaClass
的使用

没有 com.trs.components.stat.StatDocCountOfUserByMetaClass 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatResult 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatResult
的使用

没有 com.trs.components.stat.StatResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.StatResults 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.StatResults
的使用

没有 com.trs.components.stat.StatResults 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.TimeRange 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.TimeRange
的使用

没有 com.trs.components.stat.TimeRange 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.URLParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.URLParser
的使用

没有 com.trs.components.stat.URLParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.UserLoginInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.UserLoginInfo
的使用

使用 UserLoginInfo 的软件包
com.trs.components.stat

com.trs.components.stat 中 UserLoginInfo 的使用

返回 UserLoginInfo 的 com.trs.components.stat 中的方法
static UserLoginInfo | UserLoginInfo.createNewInstance() 产生当前对象[UserLoginInfo]的实例
static UserLoginInfo | UserLoginInfo.findById(int _nId) 提取指定ID的对象
static UserLoginInfo | UserLoginInfo.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
UserLoginInfo | IUserLoginInfoMgr.save(UserLoginInfo _oUserLoginInfo, User _oCurrUser)
UserLoginInfo | UserLoginInfoMgr.save(UserLoginInfo _oUserLoginInfo, User _oCurrUser) 保存当前用户登录信息

参数类型为 UserLoginInfo 的 com.trs.components.stat 中的方法
UserLoginInfo | IUserLoginInfoMgr.save(UserLoginInfo _oUserLoginInfo, User _oCurrUser)
UserLoginInfo | UserLoginInfoMgr.save(UserLoginInfo _oUserLoginInfo, User _oCurrUser) 保存当前用户登录信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.UserLoginInfoMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.UserLoginInfoMgr
的使用

没有 com.trs.components.stat.UserLoginInfoMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.UserLoginInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.UserLoginInfos
的使用

使用 UserLoginInfos 的软件包
com.trs.components.stat

com.trs.components.stat 中 UserLoginInfos 的使用

返回 UserLoginInfos 的 com.trs.components.stat 中的方法
static UserLoginInfos | UserLoginInfos.createNewInstance(User _currUser) 产生当前集合对象[UserLoginInfos]的实例
static UserLoginInfos | UserLoginInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static UserLoginInfos | UserLoginInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[UserLoginInfos]
UserLoginInfos | IUserLoginInfoMgr.query(User _oCurrUser, WCMFilter _filter)
UserLoginInfos | UserLoginInfoMgr.query(User _oCurrUser, WCMFilter _filter) 查询指定条件下的用户登录信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.stat.UserLoginInfoServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.stat.UserLoginInfoServiceProvider
的使用

没有 com.trs.components.stat.UserLoginInfoServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


MyDB

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm
类 MyDB

java.lang.Object
    继承者  com.trs.components.wcm.MyDB
所有已实现的接口：
License
public class MyDB
extends java.lang.Object
implements License

Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MyDB()
方法摘要
int | getMaxSiteNum() 获取最大站点数
int | getMaxUserNum() 获取最大用户数
int | getPluginCode() 获取选件的注册码
java.lang.String | validate() 校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MyDB

public MyDB()
方法详细信息

getMaxSiteNum

public int getMaxSiteNum()
从接口 License 复制的描述
获取最大站点数

指定者：
接口 License 中的 getMaxSiteNum
返回：

getMaxUserNum

public int getMaxUserNum()
从接口 License 复制的描述
获取最大用户数

指定者：
接口 License 中的 getMaxUserNum
返回：

getPluginCode

public int getPluginCode()
从接口 License 复制的描述
获取选件的注册码

指定者：
接口 License 中的 getPluginCode
返回：

validate

public java.lang.String validate()
从接口 License 复制的描述
校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息

指定者：
接口 License 中的 validate
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MyPlugin

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm
类 MyPlugin

java.lang.Object
    继承者  com.trs.components.wcm.MyPlugin

public class MyPlugin
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MyPlugin()
方法摘要
static int getPluginCode()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MyPlugin

public MyPlugin()
方法详细信息

getPluginCode

public static int getPluginCode()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm
类
MyDB
MyPlugin
WCMAppConfig


com.trs.components.wcm

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm

类摘要
MyDB | Title: TRS 内容协作平台（TRS WCM） Description: 时间处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MyPlugin | Title: TRS 内容协作平台（TRS WCM） Description: 时间处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMAppConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.MyDB (implements com.trs.license.License)
    • com.trs.components.wcm.MyPlugin
    • com.trs.components.wcm.WCMAppConfig (implements com.trs.infra.config.persistent.IConfigElement)


软件包 com.trs.components.wcm 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm
的使用

没有 com.trs.components.wcm 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMAppConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm
类 WCMAppConfig

java.lang.Object
    继承者  com.trs.components.wcm.WCMAppConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class WCMAppConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMAppConfig()
方法摘要
java.lang.String | getDocumentSynChnlDocFields()
java.lang.String | getName() 获取配置对象的名称
boolean | isDocumentsGetOptimize()
boolean | isDocumentSynChnlDoc()
void | setDocumentsGetOptimize(boolean _bDocumentsGetOptimize)
void | setDocumentSynChnlDoc(boolean _bDocumentSynChnlDoc)
void | setDocumentSynChnlDocFields(java.lang.String documentSynChnlDocFields)
void | setName(java.lang.String _sName) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMAppConfig

public WCMAppConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

isDocumentsGetOptimize

public boolean isDocumentsGetOptimize()
返回：

setDocumentsGetOptimize

public void setDocumentsGetOptimize(boolean _bDocumentsGetOptimize)
参数：
_bDocumentsGetOptimize -

isDocumentSynChnlDoc

public boolean isDocumentSynChnlDoc()
返回：

setDocumentSynChnlDoc

public void setDocumentSynChnlDoc(boolean _bDocumentSynChnlDoc)
参数：
_bDocumentSynChnlDoc -

getDocumentSynChnlDocFields

public java.lang.String getDocumentSynChnlDocFields()
返回：

setDocumentSynChnlDocFields

public void setDocumentSynChnlDocFields(java.lang.String documentSynChnlDocFields)
参数：
documentSynChnlDocFields -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChannelAuthHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.auth
类 ChannelAuthHelper

java.lang.Object
    继承者  com.trs.components.wcm.auth.ChannelAuthHelper

public class ChannelAuthHelper
extends java.lang.Object

构造方法摘要
ChannelAuthHelper()
方法摘要
static boolean hasRight(User _currUser, Channel _channel, int _nRightIndex)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelAuthHelper

public ChannelAuthHelper()
方法详细信息

hasRight

public static final boolean hasRight(User _currUser,
                                     Channel _channel,
                                     int _nRightIndex)
                              throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChannelRightObjImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.auth
类 ChannelRightObjImpl

java.lang.Object
    继承者  com.trs.components.wcm.auth.ChannelRightObjImpl
所有已实现的接口：
IRightObj, ICMSObjSubstanceContent
public class ChannelRightObjImpl
extends java.lang.Object
implements IRightObj

作者：
Administrator

构造方法摘要
ChannelRightObjImpl()
方法摘要
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | hasRight(User _currUser, int _nRightIndex) 判断用户对于指定的对象是否具有指定的权限
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _oObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _oObj) Sets the substantce
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelRightObjImpl

public ChannelRightObjImpl()
方法详细信息

hasRight

public boolean hasRight(User _currUser,
                        int _nRightIndex)
                 throws WCMException
从接口 IRightObj 复制的描述
判断用户对于指定的对象是否具有指定的权限

指定者：
接口 IRightObj 中的 hasRight
参数：
_currUser - 指定的用户
_nRightIndex - 指定的权限值（定义在WCMRightTypes中）
返回：
如果具有，返回true;否则返回false
抛出：
WCMException

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _oObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_oObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

setSubstance

public void setSubstance(CMSObj _oObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_oObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.auth
类
ChannelAuthHelper
ChannelRightObjImpl
WebSiteRightObjImpl


com.trs.components.wcm.auth

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.auth

类摘要
ChannelAuthHelper
ChannelRightObjImpl
WebSiteRightObjImpl


com.trs.components.wcm.auth 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.auth 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.auth.ChannelAuthHelper
    • com.trs.components.wcm.auth.ChannelRightObjImpl (implements com.trs.cms.auth.domain.IRightObj)
    • com.trs.components.wcm.auth.WebSiteRightObjImpl (implements com.trs.cms.auth.domain.IRightObj)


软件包 com.trs.components.wcm.auth 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.auth
的使用

没有 com.trs.components.wcm.auth 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WebSiteRightObjImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.auth
类 WebSiteRightObjImpl

java.lang.Object
    继承者  com.trs.components.wcm.auth.WebSiteRightObjImpl
所有已实现的接口：
IRightObj, ICMSObjSubstanceContent
public class WebSiteRightObjImpl
extends java.lang.Object
implements IRightObj

作者：
Administrator

构造方法摘要
WebSiteRightObjImpl()
方法摘要
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | hasRight(User _currUser, int _nRightIndex) 判断用户对于指定的对象是否具有指定的权限
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _oObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _oObj) Sets the substantce
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteRightObjImpl

public WebSiteRightObjImpl()
方法详细信息

hasRight

public boolean hasRight(User _currUser,
                        int _nRightIndex)
                 throws WCMException
从接口 IRightObj 复制的描述
判断用户对于指定的对象是否具有指定的权限

指定者：
接口 IRightObj 中的 hasRight
参数：
_currUser - 指定的用户
_nRightIndex - 指定的权限值（定义在WCMRightTypes中）
返回：
如果具有，返回true;否则返回false
抛出：
WCMException

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _oObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_oObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

setSubstance

public void setSubstance(CMSObj _oObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_oObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.auth.ChannelAuthHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.auth.ChannelAuthHelper
的使用

没有 com.trs.components.wcm.auth.ChannelAuthHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.auth.ChannelRightObjImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.auth.ChannelRightObjImpl
的使用

没有 com.trs.components.wcm.auth.ChannelRightObjImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.auth.WebSiteRightObjImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.auth.WebSiteRightObjImpl
的使用

没有 com.trs.components.wcm.auth.WebSiteRightObjImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IVChannelParser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.channel
接口 IVChannelParser

所有已知实现类：
TxtFileParser
public interface IVChannelParser

Title: TRS 内容协作平台（TRS WCM）
Description:
解释器
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

方法摘要
 VChannel parse(java.lang.String filename)
从文件内容中解释得到需要创建的对象.

方法详细信息

parse

VChannel parse(java.lang.String filename)
               throws WCMException
从文件内容中解释得到需要创建的对象.

参数：
filename - 源文件名.
返回：
创建的虚拟对象(VChannel)
抛出：
WCMException - 在解释文件出现异常时,将相应的异常包装为适当的WCMException抛出.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.channel
接口
IVChannelParser
类
TxtFileParser
VChannel
VChannelManager


com.trs.components.wcm.channel

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.channel

接口摘要
IVChannelParser Title: TRS 内容协作平台（TRS WCM）
Description:
解释器
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

类摘要
TxtFileParser | Title: TRS 内容协作平台（TRS WCM） Description: 普通文本解释 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
VChannel | Title: TRS 内容协作平台（TRS WCM） Description: 批量创建栏目,虚拟的栏目对象 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
VChannelManager | Title: TRS 内容协作平台（TRS WCM） Description: 批量创建栏目 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)


com.trs.components.wcm.channel 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.channel 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.channel.TxtFileParser (implements com.trs.components.wcm.channel.IVChannelParser)
    • com.trs.components.wcm.channel.VChannel
    • com.trs.components.wcm.channel.VChannelManager

接口分层结构

  • com.trs.components.wcm.channel.IVChannelParser


软件包 com.trs.components.wcm.channel 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.channel
的使用

使用 com.trs.components.wcm.channel 的软件包
com.trs.components.wcm.channel

com.trs.components.wcm.channel 使用的 com.trs.components.wcm.channel 中的类
IVChannelParser
Title: TRS 内容协作平台（TRS WCM）
Description:
解释器
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
VChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
批量创建栏目,虚拟的栏目对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TxtFileParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.channel
类 TxtFileParser

java.lang.Object
    继承者  com.trs.components.wcm.channel.TxtFileParser
所有已实现的接口：
IVChannelParser
public class TxtFileParser
extends java.lang.Object
implements IVChannelParser

Title: TRS 内容协作平台（TRS WCM）
Description:
普通文本解释
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TxtFileParser()
方法摘要
 VChannel parse(java.lang.String filename)
从文件内容中解释得到需要创建的对象.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TxtFileParser

public TxtFileParser()
方法详细信息

parse

public VChannel parse(java.lang.String filename)
               throws WCMException
从接口 IVChannelParser 复制的描述
从文件内容中解释得到需要创建的对象.

指定者：
接口 IVChannelParser 中的 parse
参数：
filename - 源文件名.
返回：
创建的虚拟对象(VChannel)
抛出：
WCMException - 在解释文件出现异常时,将相应的异常包装为适当的WCMException抛出.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.channel
类 VChannel

java.lang.Object
    继承者  com.trs.components.wcm.channel.VChannel

public class VChannel
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
批量创建栏目,虚拟的栏目对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
VChannel()
方法摘要
void | addChild(VChannel _oVChannel)
void | addChildren(java.util.List _oChildren)
java.lang.String | get(java.lang.String _sPropKey)
java.util.List | getChildren()
java.lang.String | getDataPath()
java.lang.String | getDesc()
java.lang.String | getName()
VChannel | getParent()
java.util.Map | getProperties()
java.lang.String | getRootDomain()
void | set(java.lang.String _sPropKey, java.lang.String _sPropValue)
void | setDataPath(java.lang.String _sDataPath)
void | setDesc(java.lang.String _sDesc)
void | setName(java.lang.String _sName)
void | setParent(VChannel parent)
void | setRootDomain(java.lang.String rootDomain)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

VChannel

public VChannel()
方法详细信息

get

public java.lang.String get(java.lang.String _sPropKey)

set

public void set(java.lang.String _sPropKey,
                java.lang.String _sPropValue)

getName

public java.lang.String getName()

setName

public void setName(java.lang.String _sName)

getDesc

public java.lang.String getDesc()

setDesc

public void setDesc(java.lang.String _sDesc)

getDataPath

public java.lang.String getDataPath()

setDataPath

public void setDataPath(java.lang.String _sDataPath)

getChildren

public java.util.List getChildren()

addChild

public void addChild(VChannel _oVChannel)

addChildren

public void addChildren(java.util.List _oChildren)

getProperties

public java.util.Map getProperties()

getParent

public VChannel getParent()

setParent

public void setParent(VChannel parent)

getRootDomain

public java.lang.String getRootDomain()
返回：
the rootDomain

setRootDomain

public void setRootDomain(java.lang.String rootDomain)
参数：
rootDomain - the rootDomain to set

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VChannelManager

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.channel
类 VChannelManager

java.lang.Object
    继承者  com.trs.components.wcm.channel.VChannelManager

public class VChannelManager
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
批量创建栏目
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
VChannelManager()
方法摘要
void | save(Channel _parent, VChannel _oVChannel)
void | save(WCMSystemObject _parent, VChannel _oVChannel)
void | save(WebSite _parent, VChannel _oVChannel)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VChannelManager

public VChannelManager()
方法详细信息

save

public void save(WebSite _parent,
                 VChannel _oVChannel)
          throws WCMException
抛出：
WCMException

save

public void save(Channel _parent,
                 VChannel _oVChannel)
          throws WCMException
抛出：
WCMException

save

public void save(WCMSystemObject _parent,
                 VChannel _oVChannel)
          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.wcm.channel.IVChannelParser 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.channel.IVChannelParser
的使用

使用 IVChannelParser 的软件包
com.trs.components.wcm.channel

com.trs.components.wcm.channel 中 IVChannelParser 的使用

实现 IVChannelParser 的 com.trs.components.wcm.channel 中的类
 class TxtFileParser
Title: TRS 内容协作平台（TRS WCM）
Description:
普通文本解释
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.channel.TxtFileParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.channel.TxtFileParser
的使用

没有 com.trs.components.wcm.channel.TxtFileParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.channel.VChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.channel.VChannel
的使用

使用 VChannel 的软件包
com.trs.components.wcm.channel

com.trs.components.wcm.channel 中 VChannel 的使用

返回 VChannel 的 com.trs.components.wcm.channel 中的方法
VChannel | VChannel.getParent()
VChannel | TxtFileParser.parse(java.lang.String filename)
VChannel | IVChannelParser.parse(java.lang.String filename) 从文件内容中解释得到需要创建的对象.

参数类型为 VChannel 的 com.trs.components.wcm.channel 中的方法
void | VChannel.addChild(VChannel _oVChannel)
void | VChannelManager.save(Channel _parent, VChannel _oVChannel)
void | VChannelManager.save(WCMSystemObject _parent, VChannel _oVChannel)
void | VChannelManager.save(WebSite _parent, VChannel _oVChannel)
void | VChannel.setParent(VChannel parent)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.channel.VChannelManager 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.channel.VChannelManager
的使用

没有 com.trs.components.wcm.channel.VChannelManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.MyDB 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.MyDB
的使用

没有 com.trs.components.wcm.MyDB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.MyPlugin 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.MyPlugin
的使用

没有 com.trs.components.wcm.MyPlugin 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.WCMAppConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.WCMAppConfig
的使用

没有 com.trs.components.wcm.WCMAppConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ContentUpdateCommanderImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content
类 ContentUpdateCommanderImpl

java.lang.Object
    继承者  com.trs.components.wcm.content.ContentUpdateCommanderImpl
所有已实现的接口：
IUpdateCommander
public class ContentUpdateCommanderImpl
extends java.lang.Object
implements IUpdateCommander

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static boolean UPDATE_FROM_DB
构造方法摘要
ContentUpdateCommanderImpl()
方法摘要
 void doUpdate()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

UPDATE_FROM_DB

public static boolean UPDATE_FROM_DB
构造方法详细信息

ContentUpdateCommanderImpl

public ContentUpdateCommanderImpl()
方法详细信息

doUpdate

public void doUpdate()
指定者：
接口 IUpdateCommander 中的 doUpdate
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MySite

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content
类 MySite

java.lang.Object
    继承者  com.trs.components.wcm.content.MySite
所有已实现的接口：
License
public class MySite
extends java.lang.Object
implements License

Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MySite()
方法摘要
int | getMaxSiteNum() 获取最大站点数
int | getMaxUserNum() 获取最大用户数
int | getPluginCode() 获取选件的注册码
java.lang.String | validate() 校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MySite

public MySite()
方法详细信息

getMaxSiteNum

public int getMaxSiteNum()
从接口 License 复制的描述
获取最大站点数

指定者：
接口 License 中的 getMaxSiteNum
返回：

getMaxUserNum

public int getMaxUserNum()
从接口 License 复制的描述
获取最大用户数

指定者：
接口 License 中的 getMaxUserNum
返回：

getPluginCode

public int getPluginCode()
从接口 License 复制的描述
获取选件的注册码

指定者：
接口 License 中的 getPluginCode
返回：

validate

public java.lang.String validate()
从接口 License 复制的描述
校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息

指定者：
接口 License 中的 validate
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.content
类
ContentUpdateCommanderImpl
MySite
QueryDocumentCenter
SynChildrenOfChannelExecutorBase
ViewDocument
ViewDocuments


com.trs.components.wcm.content

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.content

类摘要
ContentUpdateCommanderImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MySite | Title: TRS 内容协作平台（TRS WCM） Description: 时间处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
QueryDocumentCenter |
SynChildrenOfChannelExecutorBase | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocument | Title: TRS 内容协作平台（TRS WCM） Description: 视图文档元素对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocuments | Title: TRS 内容协作平台（TRS WCM） Description: 视图文档集合对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm.content 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.content.ViewDocument
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.content.ViewDocuments
    • com.trs.components.wcm.content.ContentUpdateCommanderImpl (implements com.trs.infra.update.IUpdateCommander)
    • com.trs.components.wcm.content.MySite (implements com.trs.license.License)
    • com.trs.components.wcm.content.QueryDocumentCenter
    • com.trs.infra.persistent.util.SynChildrenExecutorBase
      • com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase


软件包 com.trs.components.wcm.content 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content
的使用

使用 com.trs.components.wcm.content 的软件包
com.trs.ajaxservice |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.service |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |

com.trs.ajaxservice 使用的 com.trs.components.wcm.content 中的类
ViewDocuments
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档集合对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.persistent 使用的 com.trs.components.wcm.content 中的类
ViewDocument
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档元素对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocuments
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档集合对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 使用的 com.trs.components.wcm.content 中的类
SynChildrenOfChannelExecutorBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 使用的 com.trs.components.wcm.content 中的类
ViewDocument
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档元素对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.components.wcm.content 中的类
ViewDocuments
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档集合对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


QueryDocumentCenter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content
类 QueryDocumentCenter

java.lang.Object
    继承者  com.trs.components.wcm.content.QueryDocumentCenter

public class QueryDocumentCenter
extends java.lang.Object

构造方法摘要
QueryDocumentCenter()
方法摘要
static Documents | queryDocumentsForUser(User _currUser, BaseChannel _oChannelOrSite, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize, boolean _bContainsChildren, WCMFilter _filter)
static Documents | queryDocumentsForUser(User _currUser, int _nChannelId, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize)
static Documents | queryDocumentsOfCurrPage(WCMFilter _filter, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

QueryDocumentCenter

public QueryDocumentCenter()
方法详细信息

queryDocumentsOfCurrPage

public static Documents queryDocumentsOfCurrPage(WCMFilter _filter,
                                                 java.lang.String _sSelectFieldsOfDocument,
                                                 int _nPageIndex,
                                                 int _nPageSize)
                                          throws WCMException
抛出：
WCMException

queryDocumentsForUser

public static Documents queryDocumentsForUser(User _currUser,
                                              BaseChannel _oChannelOrSite,
                                              java.lang.String _sSelectFieldsOfDocument,
                                              int _nPageIndex,
                                              int _nPageSize,
                                              boolean _bContainsChildren,
                                              WCMFilter _filter)
                                       throws WCMException
抛出：
WCMException

queryDocumentsForUser

public static Documents queryDocumentsForUser(User _currUser,
                                              int _nChannelId,
                                              java.lang.String _sSelectFieldsOfDocument,
                                              int _nPageIndex,
                                              int _nPageSize)
                                       throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynChildrenOfChannelExecutorBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content
类 SynChildrenOfChannelExecutorBase

java.lang.Object
    继承者  com.trs.infra.persistent.util.SynChildrenExecutorBase
        继承者  com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase
直接已知子类：
SynChildrenExecutorForViewEmploy, WCMFilterMakerForContainsChildren
public abstract class SynChildrenOfChannelExecutorBase
extends SynChildrenExecutorBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SynChildrenOfChannelExecutorBase(BaseChannel _oStartObj)
SynChildrenOfChannelExecutorBase(BaseChannel _oStartObj, boolean _bDoOnStartObj)
方法摘要
从类 com.trs.infra.persistent.util.SynChildrenExecutorBase 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SynChildrenOfChannelExecutorBase

public SynChildrenOfChannelExecutorBase(BaseChannel _oStartObj)
参数：
_oStartObj -

SynChildrenOfChannelExecutorBase

public SynChildrenOfChannelExecutorBase(BaseChannel _oStartObj,
                                        boolean _bDoOnStartObj)
参数：
_oStartObj -
_bDoOnStartObj -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewDocument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content
类 ViewDocument

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.ViewDocument
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
InfoViewDocument
public class ViewDocument
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档元素对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_TABLE_NAME
static java.lang.String | ID_FIELD_NAME
static java.lang.Integer | KEY_CHANNEL_RIGHTVALUES
static java.lang.Integer | KEY_CURR_HOST
构造方法摘要
ViewDocument(java.util.HashMap _hPublicCache)
方法摘要
void | cloneDocumentProperties(ViewDocument _viewDocument)
static ViewDocument | findById(BaseChannel _host, int _nChnlDocRecId, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument) 获取指定Id的ViewDocument
Channel | getChannel() 获取文档当前所处的栏目
int | getChannelId()
java.util.Hashtable | getChnlDocProperties()
java.lang.String | getChnlDocProperty(java.lang.String _sFieldName)
int | getChnlDocProperty(java.lang.String _sFieldName, int _nDefault)
java.lang.String | getContent() 获取文档的文本正文
BaseChannel | getCurrChannelOrSite()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
Channel | getDocChannel()
int | getDocChannelId()
int | getDocId()
java.lang.String | getHtmlContent() 获取文档的Html文本
java.lang.String | getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute) 文档HTML内容过滤处理，用于文档HTML正文的显示处理 处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于： [1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?
java.lang.String | getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute, boolean _bFromPubHTMLContent)
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getPubHtmlContent() 获取文档的Html文本
java.util.HashMap | getPublicCache()
RightValue | getRightValue(User _currUser) 获取当前ViewDocument的RightValue
Source | getSource() 获取文档来源
int | getSourceId() 获取文档来源
Status | getStatus()
int | getStatusId()
int | getType() 获取文档类型
java.lang.String | getTypeString() 获取文档类型描述
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | hasRight(User _loginUser, int _nRightIndex) 判断当前用户对于ViewDocument是否具有指定的权限
boolean | isRightDefined() 判断当前文档是否自定义了权限
boolean | isTopped()
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | readChnlDocPropertyFromRs(java.sql.ResultSet _rsData, java.sql.ResultSetMetaData _rsmdData)
void | setChnlDocProperty(java.lang.String _sFieldName, java.lang.Object _value)
void | setDocChannel(Channel docChannel)
void | setDocId(int docId)
void | setId(int _nId) 设置对象ID
void | setPublicCache(java.util.HashMap publicCache)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

ID_FIELD_NAME

public static final java.lang.String ID_FIELD_NAME
另请参见：
常量字段值

KEY_CURR_HOST

public static final java.lang.Integer KEY_CURR_HOST

KEY_CHANNEL_RIGHTVALUES

public static final java.lang.Integer KEY_CHANNEL_RIGHTVALUES
构造方法详细信息

ViewDocument

public ViewDocument(java.util.HashMap _hPublicCache)
方法详细信息

setId

public void setId(int _nId)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：

setChnlDocProperty

public void setChnlDocProperty(java.lang.String _sFieldName,
                               java.lang.Object _value)

getChnlDocProperty

public int getChnlDocProperty(java.lang.String _sFieldName,
                              int _nDefault)
参数：
_sFieldName -
_nDefault -
返回：

getChnlDocProperty

public java.lang.String getChnlDocProperty(java.lang.String _sFieldName)
参数：
_sFieldName -
返回：

cloneDocumentProperties

public void cloneDocumentProperties(ViewDocument _viewDocument)

getChnlDocProperties

public java.util.Hashtable getChnlDocProperties()
返回：

getDocId

public int getDocId()

setDocId

public void setDocId(int docId)
参数：
docId -

getChannelId

public int getChannelId()

getChannel

public Channel getChannel()
                   throws WCMException
获取文档当前所处的栏目

返回：
抛出：
WCMException

getDocChannelId

public int getDocChannelId()

getDocChannel

public Channel getDocChannel()
                      throws WCMException
抛出：
WCMException

getStatusId

public int getStatusId()

getStatus

public Status getStatus()
                 throws WCMException
抛出：
WCMException

isTopped

public boolean isTopped()

getSourceId

public int getSourceId()
获取文档来源

返回：
文档来源对象ID

getSource

public Source getSource()
                 throws WCMException
获取文档来源

返回：
文档来源对象
抛出：
WCMException

getHtmlContentWithImgFilter

public java.lang.String getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre,
                                                    boolean _bRemoveExtraAttribute)
                                             throws WCMException
文档HTML内容过滤处理，用于文档HTML正文的显示处理

处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src

可以用于：
[1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?File=", false );
[2]文档HTML正文的预览： 使用 getTextWithImgFilter( "show-pic.jsp?File=", true );
[3]文档HTML正文的解析： 使用 getTextWithImgFilter( getApdFilePubHttpPath(), true );

参数：
_sImgSrcPre - 用于构造图片src的前部分；如： show-pic.jsp?File=
_bRemoveExtraAttribute - 是否需要删除图片额外的属性（如：OLDSRC, OLDID，REALATED等）
返回：
过滤处理后的Html文本
抛出：
WCMException - Html文本处理中可能会抛出异常

getHtmlContentWithImgFilter

public java.lang.String getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre,
                                                    boolean _bRemoveExtraAttribute,
                                                    boolean _bFromPubHTMLContent)
                                             throws WCMException
抛出：
WCMException

getPubHtmlContent

public java.lang.String getPubHtmlContent()
获取文档的Html文本

返回：
文档的Html文本

getHtmlContent

public java.lang.String getHtmlContent()
获取文档的Html文本

返回：
文档的Html文本

getType

public int getType()
获取文档类型

返回：
文档类型

getContent

public java.lang.String getContent()
获取文档的文本正文

返回：
文档的文本正文

getTypeString

public java.lang.String getTypeString()
获取文档类型描述

返回：
文档类型描述

getPublicCache

public java.util.HashMap getPublicCache()
返回：

setPublicCache

public void setPublicCache(java.util.HashMap publicCache)
参数：
publicCache -

getCurrChannelOrSite

public BaseChannel getCurrChannelOrSite()
返回：

getRightValue

public RightValue getRightValue(User _currUser)
                         throws WCMException
获取当前ViewDocument的RightValue

返回：
抛出：
WCMException

isRightDefined

public boolean isRightDefined()
                       throws WCMException
判断当前文档是否自定义了权限

返回：
抛出：
WCMException

hasRight

public boolean hasRight(User _loginUser,
                        int _nRightIndex)
                 throws WCMException
判断当前用户对于ViewDocument是否具有指定的权限

参数：
_loginUser -
_nRightIndex -
返回：
抛出：
WCMException

setDocChannel

public void setDocChannel(Channel docChannel)
参数：
docChannel -

findById

public static ViewDocument findById(BaseChannel _host,
                                    int _nChnlDocRecId,
                                    java.lang.String _sSelectFieldsOfChnlDoc,
                                    java.lang.String _sSelectFieldsOfDocument)
                             throws WCMException
获取指定Id的ViewDocument

参数：
_host -
_nChnlDocRecId -
_sSelectFieldsOfChnlDoc -
_sSelectFieldsOfDocument -
返回：
抛出：
WCMException

readChnlDocPropertyFromRs

public final void readChnlDocPropertyFromRs(java.sql.ResultSet _rsData,
                                            java.sql.ResultSetMetaData _rsmdData)
                                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewDocuments

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content
类 ViewDocuments

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.ViewDocuments
直接已知子类：
InfoViewDocuments
public class ViewDocuments
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档集合对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_TABLE_NAME
static java.lang.String | ID_FIELD_NAME
static java.lang.Integer | ID_NOT_LOAD
static int | MAX_FETCH_SIZE
static boolean | QUERY_ACCORD_DOCUMENT_RIGHT
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, IS_DEBUG
构造方法摘要
ViewDocuments(User _currUser)
ViewDocuments(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
boolean | canSort() 是否排序有效
BaseChannel | getCurrChannelOrSite()
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
java.util.HashMap | getPublicCache()
int | getRightIndex()
java.lang.String | getSelectFieldsFromDocument()
boolean | isFromRecycle()
BaseObjs | newInstance() 生成新的集合对象实例
void | open(Channels _channels, WCMFilter _filter)
void | open(Channel _channel, WCMFilter _filter)
void | open(CMSBaseObjs _oSitesOrChannels, WCMFilter _extraFilter)
void | open(WebSites _sites, WCMFilter _filter)
void | open(WebSite _site, WCMFilter _filter)
void | openTRSServerViewDocuments(com.eprobiti.trs.TRSResultSet _sTrsRs, TRSToWCMFilter _filter, CPager _sCurrPager)
void | openViewDocuments(WCMFilter _filter)
void | setFromRecycle(boolean fromRecycle)
void | setNeedWithAuthFilter(User _loginUser, boolean _bNeedWithAuthFilter)
void | setRightIndex(int rightIndex)
void | setSelectFields(java.lang.String _sSelectFieldFromChnlDoc, java.lang.String _sSelectFieldsFromDocument)
void | setSelectFieldsFromChnlDoc(java.lang.String _sSelectFieldsFromChnlDoc)
void | setSelectFieldsFromDocument(java.lang.String selectFieldsFromDocument)
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

ID_FIELD_NAME

public static final java.lang.String ID_FIELD_NAME
另请参见：
常量字段值

ID_NOT_LOAD

public static final java.lang.Integer ID_NOT_LOAD

QUERY_ACCORD_DOCUMENT_RIGHT

public static boolean QUERY_ACCORD_DOCUMENT_RIGHT

MAX_FETCH_SIZE

public static int MAX_FETCH_SIZE
构造方法详细信息

ViewDocuments

public ViewDocuments(User _currUser)
参数：
_currUser -

ViewDocuments

public ViewDocuments(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
参数：
_currUser -
_initCapacity -
_incCapacity -
方法详细信息

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

getCurrChannelOrSite

public BaseChannel getCurrChannelOrSite()
返回：

canSort

public boolean canSort()
是否排序有效

返回：

getPublicCache

public java.util.HashMap getPublicCache()

open

public void open(Channels _channels,
                 WCMFilter _filter)
          throws WCMException
抛出：
WCMException

open

public void open(Channel _channel,
                 WCMFilter _filter)
          throws WCMException
抛出：
WCMException

open

public void open(WebSite _site,
                 WCMFilter _filter)
          throws WCMException
抛出：
WCMException

open

public void open(WebSites _sites,
                 WCMFilter _filter)
          throws WCMException
抛出：
WCMException

openViewDocuments

public void openViewDocuments(WCMFilter _filter)
                       throws WCMException
参数：
_filter -
抛出：
WCMException

open

public void open(CMSBaseObjs _oSitesOrChannels,
                 WCMFilter _extraFilter)
          throws WCMException
抛出：
WCMException

isFromRecycle

public boolean isFromRecycle()
返回：

setFromRecycle

public void setFromRecycle(boolean fromRecycle)
参数：
fromRecycle -

setSelectFieldsFromChnlDoc

public void setSelectFieldsFromChnlDoc(java.lang.String _sSelectFieldsFromChnlDoc)
参数：
_sSelectFieldsFromChnlDoc -

setSelectFieldsFromDocument

public void setSelectFieldsFromDocument(java.lang.String selectFieldsFromDocument)
参数：
selectFieldsFromDocument -

getSelectFieldsFromDocument

public java.lang.String getSelectFieldsFromDocument()

setSelectFields

public void setSelectFields(java.lang.String _sSelectFieldFromChnlDoc,
                            java.lang.String _sSelectFieldsFromDocument)

getRightIndex

public int getRightIndex()
返回：

setRightIndex

public void setRightIndex(int rightIndex)
参数：
rightIndex -

setNeedWithAuthFilter

public void setNeedWithAuthFilter(User _loginUser,
                                  boolean _bNeedWithAuthFilter)

openTRSServerViewDocuments

public void openTRSServerViewDocuments(com.eprobiti.trs.TRSResultSet _sTrsRs,
                                       TRSToWCMFilter _filter,
                                       CPager _sCurrPager)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.content.ContentUpdateCommanderImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.ContentUpdateCommanderImpl
的使用

没有 com.trs.components.wcm.content.ContentUpdateCommanderImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.MySite 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.MySite
的使用

没有 com.trs.components.wcm.content.MySite 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.QueryDocumentCenter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.QueryDocumentCenter
的使用

没有 com.trs.components.wcm.content.QueryDocumentCenter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase
的使用

使用 SynChildrenOfChannelExecutorBase 的软件包
com.trs.components.metadata.service

com.trs.components.metadata.service 中 SynChildrenOfChannelExecutorBase 的使用

com.trs.components.metadata.service 中 SynChildrenOfChannelExecutorBase 的子类
class | SynChildrenExecutorForViewEmploy Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMFilterMakerForContainsChildren Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.ViewDocument 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.ViewDocument
的使用

使用 ViewDocument 的软件包
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.wcm.content |

com.trs.components.infoview.persistent 中 ViewDocument 的使用

com.trs.components.infoview.persistent 中 ViewDocument 的子类
 class InfoViewDocument

com.trs.components.wcm.content 中 ViewDocument 的使用

返回 ViewDocument 的 com.trs.components.wcm.content 中的方法
static ViewDocument ViewDocument.findById(BaseChannel _host, int _nChnlDocRecId, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument)
获取指定Id的ViewDocument

参数类型为 ViewDocument 的 com.trs.components.wcm.content 中的方法
 void ViewDocument.cloneDocumentProperties(ViewDocument _viewDocument)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.ViewDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.ViewDocuments
的使用

使用 ViewDocuments 的软件包
com.trs.ajaxservice |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.wcm.content.domain |

com.trs.ajaxservice 中 ViewDocuments 的使用

返回 ViewDocuments 的 com.trs.ajaxservice 中的方法
static ViewDocuments | WCMDocumentHelper.findViewDocumentsByIds(User _loginUser, java.lang.String _sChnlDocIds)
ViewDocuments | ViewDocumentServiceProvider.queryRecycle(MethodContext _methContext) 获取指定站点或者指定频道回收站下的文档
ViewDocuments | PhotoServiceProvider.queryRecycle(MethodContext _context)

com.trs.components.infoview.persistent 中 ViewDocuments 的使用

com.trs.components.infoview.persistent 中 ViewDocuments 的子类
 class InfoViewDocuments

com.trs.components.wcm.content.domain 中 ViewDocuments 的使用

参数类型为 ViewDocuments 的 com.trs.components.wcm.content.domain 中的方法
 Reports DocumentMgr.moveDocumentsToChannel(ViewDocuments _sViewDocuments, Channel _fromChannel, Channel _toChannel)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ApdHostLCListener

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ApdHostLCListener

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ApdHostLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ApdHostLCListener
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ApdHostLCListener()
方法摘要
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ApdHostLCListener

public ApdHostLCListener()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AppendixMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 AppendixMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.AppendixMgr

public class AppendixMgr
extends java.lang.Object

作者：
Han Xiao WCM52 Domain层的Manager Appendix相关的操作

构造方法摘要
AppendixMgr()
方法摘要
void | addAppendix(Document _currDocument, Appendix _currAppendix) 新增附件
void | copyAppendixes(Document _fromDocument, Document _newDocument) 复制某个特定文档的所有附件到一个新文档中
void | deleteUnuseAppendixes(Document _currDocument, java.lang.String _sUseingIds, int _nAppendixType) 删除指定文档指定类型没有使用的附件
void | editAppendix(Document _currDocument, Appendix _currAppendix) 修改附件
Appendix | getAppendixById(int _nId)
Appendixes | getAppendixes(Document _currDocument, int _nAppendixType) 获取当前文档某种类型的附件
Appendixes | getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档某种类型的附件
Appendixes | getAppendixes(Document _currDocument, WCMFilter _filter) 获取当前文档的附件(符合筛选条件)
Appendixes | getAppendixes(WCMFilter _aWCMFilter) 根据条件获得当前附件
void | saveAppendixes(Document _currDocument, java.util.List _currAppendixList) 保存特定的附件列表，包括添加、删除或者更新其中的具体附件 从private方法变成public方法，要小心 注意：保存文档相关的附件时，需要删除已经不再属于该文档的附件 050321，OO调整时进行的
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AppendixMgr

public AppendixMgr()
方法详细信息

saveAppendixes

public void saveAppendixes(Document _currDocument,
                           java.util.List _currAppendixList)
                    throws WCMException
保存特定的附件列表，包括添加、删除或者更新其中的具体附件
从private方法变成public方法，要小心
注意：保存文档相关的附件时，需要删除已经不再属于该文档的附件
050321，OO调整时进行的

参数：
_currDocument - 文档
_currAppendixList - 文档的附件列表
抛出：
WCMException

addAppendix

public void addAppendix(Document _currDocument,
                        Appendix _currAppendix)
                 throws WCMException
新增附件

参数：
ContextHelper - .getLoginUser()
_currAppendix -
_currDocument -
抛出：
WCMException

editAppendix

public void editAppendix(Document _currDocument,
                         Appendix _currAppendix)
                  throws WCMException
修改附件

参数：
ContextHelper - .getLoginUser()
_currAppendix -
_currDocument -
抛出：
WCMException

getAppendixes

public Appendixes getAppendixes(WCMFilter _aWCMFilter)
                         throws WCMException
根据条件获得当前附件

参数：
_aWCMFilter -
返回：
抛出：
WCMException

getAppendixById

public Appendix getAppendixById(int _nId)
                         throws WCMException
抛出：
WCMException

copyAppendixes

public void copyAppendixes(Document _fromDocument,
                           Document _newDocument)
                    throws WCMException
复制某个特定文档的所有附件到一个新文档中

参数：
_fromDocument - 原文档，是附件的来源
_newDocument - 目标文档，是附件要存放的宿主点
抛出：
WCMException

getAppendixes

public Appendixes getAppendixes(Document _currDocument,
                                int _nAppendixType)
                         throws WCMException
获取当前文档某种类型的附件

参数：
_currDocument - 当前文档
_nAppendixType - 附件类型(定义在Appendix)
返回：
当前文档的附件集合
抛出：
WCMException

getAppendixes

public Appendixes getAppendixes(Document _document,
                                int _nAppendixType,
                                WCMFilter _filter)
                         throws WCMException
获取当前文档某种类型的附件

参数：
_currDocument - 当前文档
_nAppendixType - 附件类型(定义在Appendix)
_filter - 过滤器,额外的查询条件
返回：
当前文档的附件集合
抛出：
WCMException

getAppendixes

public Appendixes getAppendixes(Document _currDocument,
                                WCMFilter _filter)
                         throws WCMException
获取当前文档的附件(符合筛选条件)

参数：
ContextHelper - .getLoginUser() 当前用户
_currDocument - 当前文档
返回：
当前文档的所有附件(附件集合)
抛出：
WCMException

deleteUnuseAppendixes

public void deleteUnuseAppendixes(Document _currDocument,
                                  java.lang.String _sUseingIds,
                                  int _nAppendixType)
                           throws WCMException
删除指定文档指定类型没有使用的附件

参数：
_currDocument -
_sUseingIds -
_nAppendixType -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AutoDocBakMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 AutoDocBakMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.AutoDocBakMgr

public class AutoDocBakMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文档版本自动保存的控制类，对Document的生命周期进行监控，触发自动备份操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AutoDocBakMgr()
方法摘要
void | autoBakDocument(Document _document)
void | autoBakDocument(Document _document, int _nOperType)
AutoBakConfig | getAutoSaveConfig(WebSite _currSite)
void | removeConfig(WebSite _currSite)
AutoBakConfig | save(AutoBakConfig _currConfig)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AutoDocBakMgr

public AutoDocBakMgr()
方法详细信息

autoBakDocument

public void autoBakDocument(Document _document,
                            int _nOperType)
                     throws WCMException
抛出：
WCMException

autoBakDocument

public void autoBakDocument(Document _document)
                     throws WCMException
抛出：
WCMException

save

public AutoBakConfig save(AutoBakConfig _currConfig)
                   throws WCMException
抛出：
WCMException

getAutoSaveConfig

public AutoBakConfig getAutoSaveConfig(WebSite _currSite)
                                throws WCMException
抛出：
WCMException

removeConfig

public void removeConfig(WebSite _currSite)
                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AutoTransmitMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 AutoTransmitMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.AutoTransmitMgr

public class AutoTransmitMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文档自动分发管理类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AutoTransmitMgr()
方法摘要
void | delete(ChannelSyn _currChnlSyn)
void | deleteDocumentSyn(DocumentSyn _currTransmittedDoc)
ChannelSyns | getChannelSyns(Channel _currChannel, WCMFilter _filter)
ChannelSyns | getChannelSyns(Channel _currChannel, WCMFilter _filter, boolean _bChannelAsTarget)
ChannelSyns | getRelatedChannelSyns(Channel _currChannel, WCMFilter _filter)
Channels | getSynSrcChannels(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | getSynToChannels(Channel _currChannel) 获取当前频分发文档的目标频道集合
ChannelSyn | save(ChannelSyn _currChnlSyn)
DocumentSyn | saveDocumentSyn(DocumentSyn _currTransmittedDoc)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AutoTransmitMgr

public AutoTransmitMgr()
方法详细信息

save

public ChannelSyn save(ChannelSyn _currChnlSyn)
                throws WCMException
抛出：
WCMException

saveDocumentSyn

public DocumentSyn saveDocumentSyn(DocumentSyn _currTransmittedDoc)
                            throws WCMException
抛出：
WCMException

delete

public void delete(ChannelSyn _currChnlSyn)
            throws WCMException
抛出：
WCMException

deleteDocumentSyn

public void deleteDocumentSyn(DocumentSyn _currTransmittedDoc)
                       throws WCMException
抛出：
WCMException

getChannelSyns

public ChannelSyns getChannelSyns(Channel _currChannel,
                                  WCMFilter _filter)
                           throws WCMException
抛出：
WCMException

getChannelSyns

public ChannelSyns getChannelSyns(Channel _currChannel,
                                  WCMFilter _filter,
                                  boolean _bChannelAsTarget)
                           throws WCMException
抛出：
WCMException

getRelatedChannelSyns

public ChannelSyns getRelatedChannelSyns(Channel _currChannel,
                                         WCMFilter _filter)
                                  throws WCMException
抛出：
WCMException

getSynSrcChannels

public Channels getSynSrcChannels(Channel _currChannel)
                           throws WCMException
获取给当前频道分发文档的频道集合

参数：
_currChannel - 当前频道
返回：
给当前频道分发文档的频道集合
抛出：
WCMException

getSynToChannels

public Channels getSynToChannels(Channel _currChannel)
                          throws WCMException
获取当前频分发文档的目标频道集合

参数：
_currChannel - 当前频道
返回：
当前频道分发文档的目标频道集合
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseChannelLCListener4ExtField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 BaseChannelLCListener4ExtField

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.BaseChannelLCListener4ExtField
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class BaseChannelLCListener4ExtField
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
BaseChannelLCListener4ExtField()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseChannelLCListener4ExtField

public BaseChannelLCListener4ExtField()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseChannelLCListener4Region

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 BaseChannelLCListener4Region

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.BaseChannelLCListener4Region
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class BaseChannelLCListener4Region
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

构造方法摘要
BaseChannelLCListener4Region()
方法摘要
 void notifyOnDelObj(BaseObj objDeleted, int eventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseChannelLCListener4Region

public BaseChannelLCListener4Region()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelExporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChannelExporter

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChannelExporter

public class ChannelExporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
站点/导出对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelExporter()
ChannelExporter(java.lang.String _sSiteFieldList, java.lang.String _sChannelFieldList)
方法摘要
java.lang.String | export(BaseChannel _siteOrChnl, boolean _bWithChildren, boolean _bWithRelate)
java.lang.String | export(Channels _channels, boolean _bWithChildren, boolean _bWithRelate)
java.lang.String | export(java.lang.Object _object, boolean _bWithChildren, boolean _bWithRelate)
java.lang.String | export(java.lang.Object _object, boolean _bWithChildren, boolean _bWithRelate, boolean _bReturnXMLContent)
java.lang.String | export(java.lang.Object _object, boolean _bWithChildren, boolean _bWithRelate, boolean _bReturnXMLContent, boolean _bForcedExportTempInfo)
java.lang.String | export(WebSites _sites, boolean _bWithChildren, boolean _bWithRelate)
java.lang.String | exportToXMLContent(java.lang.Object _object, boolean _bWithChildren, boolean _bWithRelate)
void | setXMLEncoding(java.lang.String _sXMLEncoding)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelExporter

public ChannelExporter()

ChannelExporter

public ChannelExporter(java.lang.String _sSiteFieldList,
                       java.lang.String _sChannelFieldList)
方法详细信息

setXMLEncoding

public void setXMLEncoding(java.lang.String _sXMLEncoding)

export

public java.lang.String export(Channels _channels,
                               boolean _bWithChildren,
                               boolean _bWithRelate)
                        throws WCMException
抛出：
WCMException

export

public java.lang.String export(WebSites _sites,
                               boolean _bWithChildren,
                               boolean _bWithRelate)
                        throws WCMException
抛出：
WCMException

export

public java.lang.String export(BaseChannel _siteOrChnl,
                               boolean _bWithChildren,
                               boolean _bWithRelate)
                        throws WCMException
抛出：
WCMException

export

public java.lang.String export(java.lang.Object _object,
                               boolean _bWithChildren,
                               boolean _bWithRelate)
                        throws WCMException
抛出：
WCMException

exportToXMLContent

public java.lang.String exportToXMLContent(java.lang.Object _object,
                                           boolean _bWithChildren,
                                           boolean _bWithRelate)
                                    throws WCMException
抛出：
WCMException

export

public java.lang.String export(java.lang.Object _object,
                               boolean _bWithChildren,
                               boolean _bWithRelate,
                               boolean _bReturnXMLContent)
                        throws WCMException
抛出：
WCMException

export

public java.lang.String export(java.lang.Object _object,
                               boolean _bWithChildren,
                               boolean _bWithRelate,
                               boolean _bReturnXMLContent,
                               boolean _bForcedExportTempInfo)
                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChannelImporter

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChannelImporter

public class ChannelImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
从XML文件中导入站点/频道数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelImporter()
方法摘要
static java.util.List | getImplementors()
java.lang.String | getNewSiteDesc()
java.lang.String | getNewSiteName()
Reports | importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl)
void | setNewSiteDesc(java.lang.String newSiteDesc)
void | setNewSiteName(java.lang.String newSiteName) 设置新的站点名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelImporter

public ChannelImporter()
方法详细信息

getNewSiteDesc

public java.lang.String getNewSiteDesc()
返回：

setNewSiteDesc

public void setNewSiteDesc(java.lang.String newSiteDesc)
参数：
newSiteDesc -

importFromFile

public Reports importFromFile(java.lang.String _sFile,
                              java.lang.String _sXslFile,
                              BaseChannel _destSiteOrChnl)
                       throws WCMException
抛出：
WCMException

getImplementors

public static java.util.List getImplementors()
                                      throws java.lang.Exception
抛出：
java.lang.Exception

getNewSiteName

public java.lang.String getNewSiteName()
返回：

setNewSiteName

public void setNewSiteName(java.lang.String newSiteName)
设置新的站点名称

参数：
newSiteName -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelLCListenerForChannelSyn

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChannelLCListenerForChannelSyn

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChannelLCListenerForChannelSyn
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class ChannelLCListenerForChannelSyn
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
监控频道被删除时，同步删除与该频道相关的频道分发设置 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelLCListenerForChannelSyn()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelLCListenerForChannelSyn

public ChannelLCListenerForChannelSyn()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelLCListenerForDocument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChannelLCListenerForDocument

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChannelLCListenerForDocument
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ChannelLCListenerForDocument
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
与文档相关的栏目生命周期监听处理.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelLCListenerForDocument()
方法摘要
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelLCListenerForDocument

public ChannelLCListenerForDocument()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelLCListenerForExtField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChannelLCListenerForExtField

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChannelLCListenerForExtField
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class ChannelLCListenerForExtField
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelLCListenerForExtField()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelLCListenerForExtField

public ChannelLCListenerForExtField()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelLCListenerForSpeical

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChannelLCListenerForSpeical

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChannelLCListenerForSpeical
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class ChannelLCListenerForSpeical
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
micah

构造方法摘要
ChannelLCListenerForSpeical()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelLCListenerForSpeical

public ChannelLCListenerForSpeical()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChannelMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChannelMgr

public class ChannelMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
管理栏目/站点相关的行为和操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelMgr()
constructor: default
方法摘要
void | delete(BaseChannel _oChannel, boolean _bDrop)
Channel | getChannelByName(int _nSiteId, java.lang.String _sChnlName) 根据栏目名称取栏目
Channels | getChannels(int _nSiteId, int _nChannelType, boolean _bIncludingDeletedChannel) 取当前站点下某类型的栏目集合
Channels | getChannels(int _nSiteId, WCMFilter _filter) 取符合一定条件的栏目集合
CMSBaseObjs | getChildren(BaseChannel _oChannel, int _nChannelType, boolean _bIncludingDeletedChannel, WCMFilter _filter)
BaseChannel | getHost(BaseChannel _oChannel) 获取栏目的父栏目,如果栏目是一级栏目,则返回该栏目所在的站点
Channels | getRecycleChannels(BaseChannel _oChannel, WCMFilter _chnlFilter) 获取符合一定条件的被删除的栏目
WebSites | getRecycleSites(WCMFilter _filter)
WebSites | getWebSites(WCMFilter _filter, boolean _bIncludeDel) 获取系统中的所有站点
void | moveTo(Channel _fromChannel, BaseChannel _toSiteOrChannel, int _nMoveToType)
void | moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType) 将栏目移动到栏目，作为兄弟或者子栏目
void | moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType) 将栏目移动到站点，作为兄弟或者子栏目
void | restore(BaseChannel _oChannel) 恢复回收站中的站点/栏目
void | restore(BaseChannel _oChannel, boolean _bSystemNotifyRestore)
BaseChannel | save(BaseChannel _oChannel) 保存（新增、编辑）栏目或者站点
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelMgr

public ChannelMgr()
constructor: default

方法详细信息

getChannelByName

public Channel getChannelByName(int _nSiteId,
                                java.lang.String _sChnlName)
根据栏目名称取栏目

参数：
_nSiteId - 栏目所在的站点Id
_sChnlName - 指定的栏目名称
返回：
抛出：
WCMException

getChannels

public Channels getChannels(int _nSiteId,
                            int _nChannelType,
                            boolean _bIncludingDeletedChannel)
                     throws WCMException
取当前站点下某类型的栏目集合

参数：
_nSiteId - 当前的站点ID
_nChannelType - 指定的栏目类型
_bIncludingDeletedChannel - 是否包含已被删除的栏目,默认为false,不包含
返回：
栏目集合
抛出：
WCMException

getChannels

public Channels getChannels(int _nSiteId,
                            WCMFilter _filter)
                     throws WCMException
取符合一定条件的栏目集合

参数：
_chnlFilter - 筛选条件
返回：
Channels对象,符合条件的栏目集合
抛出：
WCMException

getRecycleChannels

public Channels getRecycleChannels(BaseChannel _oChannel,
                                   WCMFilter _chnlFilter)
                            throws WCMException
获取符合一定条件的被删除的栏目

参数：
_chnlFilter - 筛选条件
返回：
符合条件的废弃栏目集合
抛出：
WCMException

getChildren

public CMSBaseObjs getChildren(BaseChannel _oChannel,
                               int _nChannelType,
                               boolean _bIncludingDeletedChannel,
                               WCMFilter _filter)
                        throws WCMException
参数：
_oChannel - 站点/父栏目
_nChannelType - 栏目类型
_bIncludingDeletedChannel - 是否包含已删除的栏目
_filter - 过滤器,额外的查询条件
返回：
抛出：
WCMException

save

public BaseChannel save(BaseChannel _oChannel)
                 throws WCMException
保存（新增、编辑）栏目或者站点

参数：
_oChannel -
返回：
抛出：
WCMException

getHost

public BaseChannel getHost(BaseChannel _oChannel)
                    throws WCMException
获取栏目的父栏目,如果栏目是一级栏目,则返回该栏目所在的站点

参数：
_currChannel - 当前栏目
返回：
抛出：
WCMException

restore

public void restore(BaseChannel _oChannel)
             throws WCMException
恢复回收站中的站点/栏目

参数：
_oChannel - 要恢复的站点/栏目
抛出：
WCMException

restore

public void restore(BaseChannel _oChannel,
                    boolean _bSystemNotifyRestore)
             throws WCMException
抛出：
WCMException

delete

public void delete(BaseChannel _oChannel,
                   boolean _bDrop)
            throws WCMException
参数：
_oChannel - 要删除的站点/栏目
_bDrop - 是否删除数据库中的数据,true为删除,数据不可恢复
抛出：
WCMException

getWebSites

public WebSites getWebSites(WCMFilter _filter,
                            boolean _bIncludeDel)
                     throws WCMException
获取系统中的所有站点

参数：
_filter - 额外的查询条件
_bIncludeDel - 是否包含已删除的站点
返回：
抛出：
WCMException

moveTo

public void moveTo(Channel _fromChannel,
                   BaseChannel _toSiteOrChannel,
                   int _nMoveToType)
            throws WCMException
抛出：
WCMException

moveTo

public void moveTo(Channel _fromChannel,
                   WebSite _toWebSite,
                   int _nMoveToType)
            throws WCMException
将栏目移动到站点，作为兄弟或者子栏目

参数：
_fromChannel - 欲移动的栏目
_toWebSite - 目标站点
_nMoveToType - 移动类型，1为作为目标站点的兄弟站点，2为作为目标站点的子站点
目前暂时不支持站点的移动
抛出：
WCMException

moveTo

public void moveTo(Channel _fromChannel,
                   Channel _toChannel,
                   int _nMoveToType)
            throws WCMException
将栏目移动到栏目，作为兄弟或者子栏目

参数：
_fromChannel - 欲移动的栏目
_toChannel - 目标栏目
_nMoveToType - 移动类型，1为作为目标站点的兄弟站点，2为作为目标站点的子站点
目前暂时不支持站点的移动
抛出：
WCMException

getRecycleSites

public WebSites getRecycleSites(WCMFilter _filter)
                         throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDocLCListener4ClassInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChnlDocLCListener4ClassInfo

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel
public class ChnlDocLCListener4ClassInfo
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
ChnlDocLCListener4ClassInfo()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocLCListener4ClassInfo

public ChnlDocLCListener4ClassInfo()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDocLCListenerForAutoDocBak

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChnlDocLCListenerForAutoDocBak

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChnlDocLCListenerForAutoDocBak
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class ChnlDocLCListenerForAutoDocBak
extends java.lang.Object
implements IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
监听ChnlDoc状态的修改,在满足一定条件时保存一个文档版本
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChnlDocLCListenerForAutoDocBak()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocLCListenerForAutoDocBak

public ChnlDocLCListenerForAutoDocBak()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDocLCListenerForPri

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChnlDocLCListenerForPri

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ChnlDocLCListenerForPri
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc LC Listener For Document Pri
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChnlDocLCListenerForPri()
方法摘要
static void | main(java.lang.String[] args)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocLCListenerForPri

public ChnlDocLCListenerForPri()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDocLCListenerForRecordNotEntity

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChnlDocLCListenerForRecordNotEntity

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel
public class ChnlDocLCListenerForRecordNotEntity
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel

构造方法摘要
ChnlDocLCListenerForRecordNotEntity()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocLCListenerForRecordNotEntity

public ChnlDocLCListenerForRecordNotEntity()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlSynWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ChnlSynWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.common.job.BaseStatefulScheduleWorker
                继承者  com.trs.components.wcm.content.domain.ChnlSynWorker
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
public class ChnlSynWorker
extends BaseStatefulScheduleWorker

字段摘要
static boolean NEW_MODE
构造方法摘要
ChnlSynWorker()
解析参数
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

字段详细信息

NEW_MODE

public static boolean NEW_MODE
构造方法详细信息

ChnlSynWorker

public ChnlSynWorker()
解析参数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtFieldCListenerForDocProps

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ContentExtFieldCListenerForDocProps

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ContentExtFieldCListenerForDocProps
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class ContentExtFieldCListenerForDocProps
extends java.lang.Object
implements IObjectLCListenerOnDel

作者：
wyw

构造方法摘要
ContentExtFieldCListenerForDocProps()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentExtFieldCListenerForDocProps

public ContentExtFieldCListenerForDocProps()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtFieldLCListenerForDocFields

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ContentExtFieldLCListenerForDocFields

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ContentExtFieldLCListenerForDocFields
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class ContentExtFieldLCListenerForDocFields
extends java.lang.Object
implements IObjectLCListenerOnDel

作者：
wyw

构造方法摘要
ContentExtFieldLCListenerForDocFields()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentExtFieldLCListenerForDocFields

public ContentExtFieldLCListenerForDocFields()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtFieldMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ContentExtFieldMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ContentExtFieldMgr

public class ContentExtFieldMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
内容扩展字段管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentExtFieldMgr()
方法摘要
void | addExtField(CMSObj _host, ContentExtField _extfield, int i)
void | addExtFieldToChildren(CMSObj _host, ContentExtField _extfield)
void | addExtFieldToSpeicficChildren(java.lang.String _sSiteids, java.lang.String _sChannelids, ContentExtField _extfield)
void | delete(CMSObj _siteOrChannel, ContentExtField _extfield, boolean _bDoWithChildren)
ContentExtFields | getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)
ContentExtFields | getExtFields(CMSObj _host, WCMFilter _filter, boolean _bContainsChildren)
int | getMaxOrder(CMSObj host)
ContentExtField | save(CMSObj _host, ContentExtField _extfield, boolean _bDoWithChildren)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentExtFieldMgr

public ContentExtFieldMgr()
方法详细信息

save

public ContentExtField save(CMSObj _host,
                            ContentExtField _extfield,
                            boolean _bDoWithChildren)
                     throws WCMException
抛出：
WCMException

addExtField

public void addExtField(CMSObj _host,
                        ContentExtField _extfield,
                        int i)
                 throws WCMException
抛出：
WCMException

addExtFieldToSpeicficChildren

public void addExtFieldToSpeicficChildren(java.lang.String _sSiteids,
                                          java.lang.String _sChannelids,
                                          ContentExtField _extfield)
                                   throws WCMException
抛出：
WCMException

addExtFieldToChildren

public void addExtFieldToChildren(CMSObj _host,
                                  ContentExtField _extfield)
                           throws WCMException
抛出：
WCMException

getMaxOrder

public int getMaxOrder(CMSObj host)
                throws WCMException
抛出：
WCMException

delete

public void delete(CMSObj _siteOrChannel,
                   ContentExtField _extfield,
                   boolean _bDoWithChildren)
            throws WCMException
抛出：
WCMException

getExtFields

public ContentExtFields getExtFields(BaseChannel _siteOrChannel,
                                     WCMFilter _filter)
                              throws WCMException
抛出：
WCMException

getExtFields

public ContentExtFields getExtFields(CMSObj _host,
                                     WCMFilter _filter,
                                     boolean _bContainsChildren)
                              throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentLinkMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ContentLinkMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ContentLinkMgr

public class ContentLinkMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
管理和内容超链接相关的行为
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentLinkMgr()
方法摘要
void | delete(ContentLink _contentLink) 删除内容超链接
void | delete(ContentLinks _contentLinks) 删除内容超链接集合
void | deleteContentLinks(WebSite _site)
ContentLinks | getContentLinks(int _nSiteId, WCMFilter _filter) 获取指定站点下的内容超链接
ContentLinks | getContentLinks(WebSite _currSite, WCMFilter _filter) 获取当前站点的所有内容超链接
ContentLink | save(ContentLink _contentLink) 保存一个内容超链接
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentLinkMgr

public ContentLinkMgr()
方法详细信息

getContentLinks

public ContentLinks getContentLinks(WebSite _currSite,
                                    WCMFilter _filter)
                             throws WCMException
获取当前站点的所有内容超链接

参数：
_currSite - 当前站点
返回：
抛出：
WCMException

save

public ContentLink save(ContentLink _contentLink)
                 throws WCMException
保存一个内容超链接

参数：
_contentLink -
抛出：
WCMException

getContentLinks

public ContentLinks getContentLinks(int _nSiteId,
                                    WCMFilter _filter)
                             throws WCMException
获取指定站点下的内容超链接

参数：
_nSiteId - 指定的站点ID
_filter - 过滤器,额外的查询条件
返回：
抛出：
WCMException

delete

public void delete(ContentLink _contentLink)
            throws WCMException
删除内容超链接

参数：
_contentLink - 要删除的内容超链接
抛出：
WCMException

delete

public void delete(ContentLinks _contentLinks)
            throws WCMException
删除内容超链接集合

参数：
_contentLinks - 需要删除的集合
抛出：
WCMException

deleteContentLinks

public void deleteContentLinks(WebSite _site)
                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatasWithChnlDocFilterHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DatasWithChnlDocFilterHelper

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper

public class DatasWithChnlDocFilterHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
单表提取文档集合的功能对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DatasWithChnlDocFilterHelper()
DatasWithChnlDocFilterHelper(java.lang.String _sTableName, java.lang.String _sIdFieldName)
方法摘要
static void | main(java.lang.String[] args)
WCMFilter | makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
WCMFilter | makeChannelFilter(Channel _channel, WCMFilter _filter)
WCMFilter | makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
void | setNeedWithAuthFilter(User _loginUser, boolean _bNeedWithAuthFilter)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DatasWithChnlDocFilterHelper

public DatasWithChnlDocFilterHelper()

DatasWithChnlDocFilterHelper

public DatasWithChnlDocFilterHelper(java.lang.String _sTableName,
                                    java.lang.String _sIdFieldName)
方法详细信息

makeChannelFilter

public WCMFilter makeChannelFilter(Channel _channel,
                                   WCMFilter _filter)
                            throws WCMException
参数：
_channel -
_filter -
抛出：
WCMException

makeChannelFilter

public WCMFilter makeChannelFilter(Channel _channel,
                                   WCMFilter _filter,
                                   boolean _bIncludeOrder,
                                   boolean _bFromRecycle)
                            throws WCMException
抛出：
WCMException

makeFilter

public WCMFilter makeFilter(WebSite _site,
                            WCMFilter _extraFilter,
                            boolean _bIncludeOrder,
                            boolean _bFromRecycle)

makeFilter

public WCMFilter makeFilter(WebSites _sites,
                            WCMFilter _extraFilter,
                            boolean _bIncludeOrder,
                            boolean _bFromRecycle)
参数：
_sites -
_extraFilter -
_bIncludeOrder -
返回：

makeChannelFilter

public WCMFilter makeChannelFilter(Channels _channels,
                                   WCMFilter _filter,
                                   boolean _bFromRecycle)
                            throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)

setNeedWithAuthFilter

public void setNeedWithAuthFilter(User _loginUser,
                                  boolean _bNeedWithAuthFilter)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocBakLCListenerForApd

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocBakLCListenerForApd

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocBakLCListenerForApd
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class DocBakLCListenerForApd
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocBakLCListenerForApd()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocBakLCListenerForApd

public DocBakLCListenerForApd()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocBakMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocBakMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocBakMgr

public class DocBakMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文档备份相关的行为
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocBakMgr()
方法摘要
DocBak | bakupDocument(Document _currDocument) 备份当前文档
void | deleteDocBak(DocBak _currDocBak) 删除一个文档备份(版本)
DocBaks | findDocBaks(Document _currDocument) 取文档的备份集合
DocBaks | findDocBaks(Document _currDocument, WCMFilter _filter) 取当前文档的备份集合
DocBak | getDocBak(Document _currDocument, int _nVersion) 取文档某个版本的备份
Document | recoverDocument(DocBak _aDocBak, Document _currDocument) 恢复当前文档的数据到某个(备份)版本
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocBakMgr

public DocBakMgr()
方法详细信息

findDocBaks

public DocBaks findDocBaks(Document _currDocument)
                    throws WCMException
取文档的备份集合

抛出：
WCMException

findDocBaks

public DocBaks findDocBaks(Document _currDocument,
                           WCMFilter _filter)
                    throws WCMException
取当前文档的备份集合

参数：
ContextHelper - .getLoginUser() 当前用户
_currDocument - 当前文档
_filter - 筛选器
返回：
符合筛选条件的文档备份集合
抛出：
WCMException

getDocBak

public DocBak getDocBak(Document _currDocument,
                        int _nVersion)
                 throws WCMException
取文档某个版本的备份

参数：
ContextHelper - .getLoginUser() 当前用户
_currDocument - 当前文档
_nVersion - 指定的版本
返回：
当前文档某版本备份
抛出：
WCMException

bakupDocument

public DocBak bakupDocument(Document _currDocument)
                     throws WCMException
备份当前文档

参数：
ContextHelper - .getLoginUser() 当前操作用户
_currDocument - 当前文档
返回：
产生的文档备份
抛出：
WCMException

deleteDocBak

public void deleteDocBak(DocBak _currDocBak)
                  throws WCMException
删除一个文档备份(版本)

参数：
ContextHelper - .getLoginUser() 当前操作用户
_currDocBak - 要删除的文档备份
抛出：
WCMException

recoverDocument

public Document recoverDocument(DocBak _aDocBak,
                                Document _currDocument)
                         throws WCMException
恢复当前文档的数据到某个(备份)版本

参数：
ContextHelper - .getLoginUser() 当前操作用户
_aDocBak - 目标备份
_currDocument - 当前文档
返回：
恢复后的文档
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocKeywordMgrImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocKeywordMgrImpl

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocKeywordMgrImpl
所有已实现的接口：
IDocKeywordMgr
public class DocKeywordMgrImpl
extends java.lang.Object
implements IDocKeywordMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static boolean GET_FROM_TRSSERVER
构造方法摘要
DocKeywordMgrImpl()
方法摘要
void | addNewDocKeywords(Document _document) 增加指定文档的相关新闻记录
Documents | getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter) 获取指定文档的所有相关文档
Documents | getAllRelatedDocumentsByKeywordsFromTRSServer(java.lang.String _sKeywords, WCMFilter _filter, int _nPageIndex)
Documents | getRelatedDocumentsByKeywords(Document _document, int _nMaxSize, java.lang.String _sSelectFields, int[] _pFilterStatusId, boolean _bMultiSite, java.util.ArrayList _arExistDocumentTitles) 根据标题排重 add by ly
void | removeDocKeywords(Document _document) 删除指定文档的相关新闻记录
void | updateDocKeywords(Document _document, java.lang.String _sOldKeywords, java.lang.String _sNewKeywords) 更新指定文档的相关文档记录信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

GET_FROM_TRSSERVER

public static boolean GET_FROM_TRSSERVER
构造方法详细信息

DocKeywordMgrImpl

public DocKeywordMgrImpl()
方法详细信息

addNewDocKeywords

public void addNewDocKeywords(Document _document)
                       throws WCMException
从接口 IDocKeywordMgr 复制的描述
增加指定文档的相关新闻记录

指定者：
接口 IDocKeywordMgr 中的 addNewDocKeywords
参数：
_document - 指定的文档对象
抛出：
WCMException

updateDocKeywords

public void updateDocKeywords(Document _document,
                              java.lang.String _sOldKeywords,
                              java.lang.String _sNewKeywords)
                       throws WCMException
从接口 IDocKeywordMgr 复制的描述
更新指定文档的相关文档记录信息

指定者：
接口 IDocKeywordMgr 中的 updateDocKeywords
参数：
_document - 指定的文档对象
_sOldKeywords - 老的关键词
_sNewKeywords - 新的关键词
抛出：
WCMException

removeDocKeywords

public void removeDocKeywords(Document _document)
                       throws WCMException
从接口 IDocKeywordMgr 复制的描述
删除指定文档的相关新闻记录

指定者：
接口 IDocKeywordMgr 中的 removeDocKeywords
参数：
_document - 指定的文档对象
抛出：
WCMException

getRelatedDocumentsByKeywords

public Documents getRelatedDocumentsByKeywords(Document _document,
                                               int _nMaxSize,
                                               java.lang.String _sSelectFields,
                                               int[] _pFilterStatusId,
                                               boolean _bMultiSite,
                                               java.util.ArrayList _arExistDocumentTitles)
                                        throws WCMException
根据标题排重 add by ly

指定者：
接口 IDocKeywordMgr 中的 getRelatedDocumentsByKeywords
参数：
_document - 指定的文档对象
_nMaxSize - 相关文档的最大数目
_sSelectFields - 提取的字段列表
_pFilterStatusId - 是否要求过来状态
_bMultiSite - 是否跨站点取相关文档,默认只取同站点的文档
返回：
抛出：
WCMException

getAllRelatedDocumentsByKeywords

public Documents getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords,
                                                  int _nExcludeDocId,
                                                  WCMFilter _filter)
                                           throws WCMException
从接口 IDocKeywordMgr 复制的描述
获取指定文档的所有相关文档

指定者：
接口 IDocKeywordMgr 中的 getAllRelatedDocumentsByKeywords
参数：
_sKeywords - 指定的文档对象
_nExcludeDocId - TODO
_filter - 指定filter（如果不指定，默认按照入库时间进行排序；没有额外的检索条件）
返回：
文档集合
抛出：
WCMException

getAllRelatedDocumentsByKeywordsFromTRSServer

public Documents getAllRelatedDocumentsByKeywordsFromTRSServer(java.lang.String _sKeywords,
                                                               WCMFilter _filter,
                                                               int _nPageIndex)
                                                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocPriDisableWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocPriDisableWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.wcm.content.domain.DocPriDisableWorker
所有已实现的接口：
org.quartz.Job
public class DocPriDisableWorker
extends BaseScheduleWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
根据文档置顶的截止时间撤销文档置顶的计划任务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocPriDisableWorker()
保留默认构造函数
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocPriDisableWorker

public DocPriDisableWorker()
保留默认构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocReplyMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocReplyMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocReplyMgr

public class DocReplyMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description: 文档回复相关行为的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocReplyMgr()
方法摘要
void | copyDocReplys(Document _fromDocument, Document _newDocument) 复制文档回复
DocReplys | getReplys(Document _currDocument) 获取文档的所有回复
DocReplys | getReplys(Document _currDocument, int _nReplyType) 获取当前文档某种类型的回复
void | saveDocReply(Document _currDocument, DocReply _docReply) 保存文档的一个回复
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocReplyMgr

public DocReplyMgr()
方法详细信息

copyDocReplys

public void copyDocReplys(Document _fromDocument,
                          Document _newDocument)
                   throws WCMException
复制文档回复

参数：
_fromDocument -
_currReplys -
抛出：
WCMException

saveDocReply

public void saveDocReply(Document _currDocument,
                         DocReply _docReply)
                  throws WCMException
保存文档的一个回复

参数：
ContextHelper - .getLoginUser() 当前操作用户
_currDocument - 当前文档
_docReply - 要保存的回复
抛出：
WCMException

getReplys

public DocReplys getReplys(Document _currDocument)
                    throws WCMException
获取文档的所有回复

抛出：
WCMException
另请参见：
DocReplys getReplys(Document _currDocument,int _nType)

getReplys

public DocReplys getReplys(Document _currDocument,
                           int _nReplyType)
                    throws WCMException
获取当前文档某种类型的回复

参数：
ContextHelper - .getLoginUser() 当前用户
_currDocument - 当前文档
_nReplyType - 回复的类型
返回：
文档的回复集合(DocReplys对象)
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentExporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentExporter

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentExporter

public class DocumentExporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文档导出,将文档(集合)导出为Zip/Xml文件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | HTMFILE_DOCUMENT_LIST_EXPORT
static java.lang.String | HTMFILE_DOCUMENT_VIEW_EXPORT
static java.lang.String | REFERENCE_XML
static java.lang.String | RESOURCE_XML
构造方法摘要
DocumentExporter()
方法摘要
java.lang.String | export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出文档集合
java.lang.String | export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出指定的文档
java.lang.String | export(int _nDocId, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出指定的文档
java.lang.String | export(java.lang.String _sDocIds, java.lang.String _sFieldsList, boolean _bWithAppendixes) 根据指定的ID序列导出文档
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

HTMFILE_DOCUMENT_VIEW_EXPORT

public static final java.lang.String HTMFILE_DOCUMENT_VIEW_EXPORT
另请参见：
常量字段值

HTMFILE_DOCUMENT_LIST_EXPORT

public static final java.lang.String HTMFILE_DOCUMENT_LIST_EXPORT
另请参见：
常量字段值

RESOURCE_XML

public static final java.lang.String RESOURCE_XML
另请参见：
常量字段值

REFERENCE_XML

public static final java.lang.String REFERENCE_XML
另请参见：
常量字段值
构造方法详细信息

DocumentExporter

public DocumentExporter()
方法详细信息

export

public java.lang.String export(int _nDocId,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes)
                        throws WCMException
导出指定的文档

参数：
_nDocId - 指定的文档ID
_sFieldsList - 要导出的字段列表
_bWithAppendixes - 是否一同导出文档的附件
返回：
@throws WCMException
抛出：
WCMException

export

public java.lang.String export(Document _document,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes)
                        throws WCMException
导出指定的文档

参数：
_document - 需要导出的文档
_sFieldsList - 需要导出的字段列表
_bWithAppendixes - 是否一同导出文档的附件
返回：
@throws WCMException
抛出：
WCMException

export

public java.lang.String export(java.lang.String _sDocIds,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes)
                        throws WCMException
根据指定的ID序列导出文档

参数：
_sDocIds - 指定的ID序列
_sFieldsList - 需要导出的字段列表
_bWithAppendixes - 是否一同导出文档的附件
返回：
@throws WCMException
抛出：
WCMException

export

public java.lang.String export(Documents _documents,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes)
                        throws WCMException
导出文档集合

参数：
_documents - 要导出的文档集合
_sFieldsList - 需要导出的字段列表
_bWithAppendixes - 是否一同导出文档的附件
返回：
返回systemtemp目录下的一个文件名
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentImporter

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentImporter

public class DocumentImporter
extends java.lang.Object

作者：
wyw

构造方法摘要
DocumentImporter()
方法摘要
static java.io.File[] | getExistedMapingFiles(User _currUser)
static java.io.File[] | getExistedXslFiles(User _currUser)
static java.util.List | getImplementors()
Reports | getImportReports()
static java.lang.String | getMyDocumentImportSourceFilePath(User _currUser)
Reports | importFromFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从文件中导入文档 支持从zip,xml,html,htm文件导入
Reports | importFromFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel, boolean bImportbyName)
Reports | importFromFileByName(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel, boolean bImportbyName)
Reports | importFromTRSFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sDefineXmlForTRServer, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从TRS文件中导入文档 支持从zip,xml,html,htm文件导入
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentImporter

public DocumentImporter()
方法详细信息

getImplementors

public static java.util.List getImplementors()
                                      throws java.lang.Exception
抛出：
java.lang.Exception

importFromFile

public Reports importFromFile(java.lang.String _sImportFile,
                              Channel _channel,
                              java.lang.String _sXslFile,
                              boolean _bExitWhenDocumentExisted,
                              boolean _bOmitOriginalChannel,
                              boolean bImportbyName)
                       throws WCMException
抛出：
WCMException

importFromFileByName

public Reports importFromFileByName(java.lang.String _sImportFile,
                                    Channel _channel,
                                    java.lang.String _sXslFile,
                                    boolean _bExitWhenDocumentExisted,
                                    boolean _bOmitOriginalChannel,
                                    boolean bImportbyName)
                             throws WCMException
抛出：
WCMException

importFromFile

public Reports importFromFile(java.lang.String _sImportFile,
                              Channel _channel,
                              java.lang.String _sXslFile,
                              boolean _bExitWhenDocumentExisted,
                              boolean _bOmitOriginalChannel)
                       throws WCMException
从文件中导入文档
支持从zip,xml,html,htm文件导入

参数：
_sImportFile - 导入的源文件
_channel - 要导入的目标栏目
_sXslFile - xml文件对应的转换文件
_bExitWhenDocumentExisted - 当出现重复文档时,是继续导入还是忽略该篇文档的导入
如果 true 则忽略
_bOmitOriginalChannel - 是否忽略文档原来的所属栏目属性 (如果导入的源数据中包含相关的信息)
如果 true 则忽略,将文档导入到指定的目标栏目
返回：
Reports
抛出：
WCMException

importFromTRSFile

public Reports importFromTRSFile(java.lang.String _sImportFile,
                                 Channel _channel,
                                 java.lang.String _sDefineXmlForTRServer,
                                 boolean _bExitWhenDocumentExisted,
                                 boolean _bOmitOriginalChannel)
                          throws WCMException
从TRS文件中导入文档
支持从zip,xml,html,htm文件导入

参数：
_sImportFile - 导入的源文件
_channel - 要导入的目标栏目
_sDefineXmlForTRServer - 指定的TRS映射文件
_bExitWhenDocumentExisted - 当出现重复文档时,是继续导入还是忽略该篇文档的导入
如果 true 则忽略
_bOmitOriginalChannel - 是否忽略文档原来的所属栏目属性 (如果导入的源数据中包含相关的信息)
如果 true 则忽略,将文档导入到指定的目标栏目
返回：
Reports
抛出：
WCMException

getImportReports

public Reports getImportReports()

getExistedXslFiles

public static java.io.File[] getExistedXslFiles(User _currUser)
                                         throws WCMException
抛出：
WCMException

getExistedMapingFiles

public static java.io.File[] getExistedMapingFiles(User _currUser)
                                            throws WCMException
抛出：
WCMException

getMyDocumentImportSourceFilePath

public static java.lang.String getMyDocumentImportSourceFilePath(User _currUser)
                                                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForAutoDocBak

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentLCListenerForAutoDocBak

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentLCListenerForAutoDocBak
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class DocumentLCListenerForAutoDocBak
extends java.lang.Object
implements IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentLCListenerForAutoDocBak()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForAutoDocBak

public DocumentLCListenerForAutoDocBak()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForDocBak

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentLCListenerForDocBak

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentLCListenerForDocBak
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class DocumentLCListenerForDocBak
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentLCListenerForDocBak()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForDocBak

public DocumentLCListenerForDocBak()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForDocReply

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentLCListenerForDocReply

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentLCListenerForDocReply
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class DocumentLCListenerForDocReply
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentLCListenerForDocReply()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForDocReply

public DocumentLCListenerForDocReply()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForExternalFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentLCListenerForExternalFile

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class DocumentLCListenerForExternalFile
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
外部文档的文件处理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentLCListenerForExternalFile()
方法摘要
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForExternalFile

public DocumentLCListenerForExternalFile()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForKeyword

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentLCListenerForKeyword

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class DocumentLCListenerForKeyword
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

作者：
wyw

构造方法摘要
DocumentLCListenerForKeyword()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded)
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForKeyword

public DocumentLCListenerForKeyword()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForRelation

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentLCListenerForRelation

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentLCListenerForRelation
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class DocumentLCListenerForRelation
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentLCListenerForRelation()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForRelation

public DocumentLCListenerForRelation()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForRelDocs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentLCListenerForRelDocs

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class DocumentLCListenerForRelDocs
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

构造方法摘要
DocumentLCListenerForRelDocs()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForRelDocs

public DocumentLCListenerForRelDocs()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentMgr

public class DocumentMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文档的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | POSITION_AFTER
static int | POSITION_AFTER_NEW
static int | POSITION_BEFORE
构造方法摘要
DocumentMgr()
方法摘要
void | changeStatus(Document _currDocument, Channel _currChannel, int _newStatusId)
void | changeStatus(Document _currDocument, Channel _currChannel, Status _newStatus) 修改ChnlDoc中对应的状态 如果是实体文档，则同步状态
void | changeStatus(int _newStatusId, ChnlDoc _currChnlDoc) 改变文档在指定频道下的状态
void | clearAll(User _currUser, BaseChannel _oSiteOrChannel) 清空回收站
Document | copyDocument(Document _fromDocument, Channel _fromChannel, Channel _toChannel) 复制文档到另一个频道上 不负责非依赖型关联对象的复制，如附件和相关文档 不能将一个文档从草稿箱或者复制到草稿箱 复制引用转发的文档相当于创建一个新的引用转发 复制实体文档，则需要在目标频道下创建一个新的实体文档
void | delete(Document _currDocument, Channel _currChannel, boolean _bDrop) 从某个频道下删除一篇文档 频道为一个真实频道，暂时不支持从回收站、草稿箱或其它特殊频道中删除。
void | deleteDocQuotes(Document _currDocument, java.lang.String _sExcludeChannelIds) 根据频道排除Id，删除所有特定类型的文档转发关系
ChnlDoc | findChnlDoc(Document _currDocument, Channel _currChannel) 根据文档和频道，找到对应的ChnlDoc
Documents | getAllDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的所有文档
Channels | getChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere) 获取所有与文档相关的频道
Status | getDocStatus(Document _currDocument, int _nChnlId) 获取当前文档在所有频道下的状态
Documents | getDocuments(BaseChannel _oChannel, WCMFilter _filter) 取站点/频道的(除了回收站外的)文档集合
CMyDateTime | getDocumentTopTime(Document _currDocument, Channel _currChannel) 获得文档置顶的截止时间 如果文档没有置顶，则直接返回null 如果置顶文档没有设置截止时间则返回null
WCMFilter | getFilterForDocuments(BaseChannel _oChannel, WCMFilter _docFitler)
ChnlDoc | getFirstChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内的第一个频道文档。
ChnlDoc | getLastChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内的最后一个频道文档。
int | getMaxToppedNum() 获得允许置顶的文档的总数 是从系统配置中获取，整个系统中有一个数值记录
ChnlDoc | getNextChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内，当前频道文档的后一个频道文档。
ChnlDoc | getPreviousChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内，当前频道文档的前一个频道文档。
Channels | getQutoedChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere) 获得实体文档对应的特定类型的频道集合 包括所有转发的频道、镜像的频道、实体频道和所有频道
Channels | getQutoedChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere, boolean _bIsIncludeTrashed)
Documents | getRecycleDocuments(BaseChannel _currChnl, WCMFilter _filter) 取频道的废稿
Documents | getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 相关文档的相关方法
Documents | getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites) 获取与当前文档相关的文档集合(指定获取的方式:相关表/关键词/相关词等)
Documents | getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档
int | getTopPosition(Channel _currChannel, Document _currDocument) 得到频道下文档的置顶位置
boolean | isDocumentTopped(Document _currDocument, Channel _currChannel) 判断一个频道下的文档是否是处于置顶状态
boolean | isTopEnabled() 判断置顶功能是否已经激活 > 从系统配置中获取，如果找不到，则从ChnlDoc的缺省配置中取
Report | mirrorTo(Document _fromDocument, Channel _toChannel) 将实体文档镜像转发到另一个频道 草稿箱中的文档无法转发 目标频道为空无法转发
Reports | moveAllDocumentsToChannel(Channel _fromChannel, Channel _toChannel) 移动当前栏目下现有文档到指定的频道
void | moveDocumentInChannel(Document _fromDocument, Document _toDocument, Channel _currChannel) 在频道中移动文档的顺序 如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后 通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作 置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
void | moveDocumentInChannel(Document _fromDocument, Document _toDocument, Channel _currChannel, int _nPosition) 在频道中移动文档的顺序 如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后 通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作 置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
Reports | moveDocumentsToChannel(ViewDocuments _sViewDocuments, Channel _fromChannel, Channel _toChannel)
Report | moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel) 将文档从一个频道移动到另一个频道 支持引用和镜像的移动 如果是草稿箱中的，则不支持移动；也不支持移动到草稿箱 如果目标频道下已经存在，则无法移动
Report | moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel, java.lang.String _sIsPhoto)
Report | quoteTo(Document _fromDocument, Channel _toChannel) 将实体文档引用转发到另一个频道 草稿箱中的文档无法转发 目标频道为空无法转发
Report | quoteTo(Document _fromDocument, Channel _toChannel, java.lang.String _sIsPhoto)
void | removeToppedDocument(Channel _currChannel, Document _currDocument) 取消特定频道下某文档的置顶标志 该文档将成为普通文档 注意，不是删除文档！
void | restore(ChnlDoc _oChnlDocDeleted) 恢复指定的ChnlDoc
void | restore(Document _delDocument, Channel _currChannel) 还原频道回收站中的一篇频道文档
void | restoreAll(User _currUser, BaseChannel _oSiteOrChannel)
Document | save(Document _currDocument) 在频道下保存/修改一篇文档 文档的频道属性不能在此被修改，而应该通过移动操作进行修改 文档的假删除、恢复 都需要调用相关接口，而不该通过修改接口 修改文档状态时，需要同步修改ChnlDoc的状态
void | setTopDocument(Channel _currChannel, Document _fromDocument, Document _toDocument, int _nPosition, CMyDateTime dtValid)
void | setTopDocument(Channel _currChannel, Document _currDocument, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶 如果特定的位置已经存在文档，则需要将该位置及其后的所有置顶向后移动一位 如果最后一个置顶项目也有占用，则自动将置顶位置扩展一位！
void | setTopedDocument(Document _document, Channel _channel, int _nTopOrder, CMyDateTime _dtTopedValid)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

POSITION_BEFORE

public static final int POSITION_BEFORE
另请参见：
常量字段值

POSITION_AFTER

public static final int POSITION_AFTER
另请参见：
常量字段值

POSITION_AFTER_NEW

public static final int POSITION_AFTER_NEW
另请参见：
常量字段值
构造方法详细信息

DocumentMgr

public DocumentMgr()
方法详细信息

delete

public void delete(Document _currDocument,
                   Channel _currChannel,
                   boolean _bDrop)
            throws WCMException
从某个频道下删除一篇文档
频道为一个真实频道，暂时不支持从回收站、草稿箱或其它特殊频道中删除。那些删除需要提供其它接口完成

参数：
_currDocument - 欲删除的文档实体
_currChannel - 文档所在频道
_bDrop - true:彻底删除，false:删除到回收站
抛出：
WCMException

findChnlDoc

public ChnlDoc findChnlDoc(Document _currDocument,
                           Channel _currChannel)
                    throws WCMException
根据文档和频道，找到对应的ChnlDoc

参数：
_currDocument - 文档实体
_currChannel - 文档所在频道
返回：
符合条件的ChnlDoc对象
抛出：
WCMException

getDocStatus

public Status getDocStatus(Document _currDocument,
                           int _nChnlId)
                    throws WCMException
获取当前文档在所有频道下的状态

参数：
_currDocument - 当前文档
_nChnlId - 文档所在的频道Id
返回：
当前文档的状态
抛出：
WCMException

changeStatus

public void changeStatus(Document _currDocument,
                         Channel _currChannel,
                         Status _newStatus)
                  throws WCMException
修改ChnlDoc中对应的状态
如果是实体文档，则同步状态

参数：
_currDocument -
_currChannel -
_newStatus -
抛出：
WCMException

changeStatus

public void changeStatus(Document _currDocument,
                         Channel _currChannel,
                         int _newStatusId)
                  throws WCMException
抛出：
WCMException

changeStatus

public void changeStatus(int _newStatusId,
                         ChnlDoc _currChnlDoc)
                  throws WCMException
改变文档在指定频道下的状态

参数：
_newStatusId - 新的状态
_currChnlDoc - 描述指定频道下的指定文档的对象
抛出：
WCMException

getAllDocuments

public Documents getAllDocuments(BaseChannel _oChannel,
                                 WCMFilter _filter)
                          throws WCMException
获取当前站点/频道下的所有文档

参数：
_oChannel - 当前站点/频道
_filter - 额外的查询条件
返回：
抛出：
WCMException

getDocuments

public Documents getDocuments(BaseChannel _oChannel,
                              WCMFilter _filter)
                       throws WCMException
取站点/频道的(除了回收站外的)文档集合

参数：
_oChannel - 当前站点/频道
_filter - 指定所取文档的筛选器
返回：
抛出：
WCMException

getRecycleDocuments

public Documents getRecycleDocuments(BaseChannel _currChnl,
                                     WCMFilter _filter)
                              throws WCMException
取频道的废稿

参数：
_currChnl - 当前频道
_filter - 筛选条件(filter对象)
返回：
文档集合@throws WCMException
抛出：
WCMException

getFilterForDocuments

public WCMFilter getFilterForDocuments(BaseChannel _oChannel,
                                       WCMFilter _docFitler)
                                throws WCMException
抛出：
WCMException

getMaxToppedNum

public int getMaxToppedNum()
获得允许置顶的文档的总数
是从系统配置中获取，整个系统中有一个数值记录

返回：
允许置顶的文档的总数，找不到配置则返回0
抛出：
WCMException

isTopEnabled

public boolean isTopEnabled()
判断置顶功能是否已经激活
> 从系统配置中获取，如果找不到，则从ChnlDoc的缺省配置中取

返回：
抛出：
WCMException

getToppedDocuments

public Documents getToppedDocuments(Channel _currChannel,
                                    WCMFilter _docFilter)
                             throws WCMException
获得特定频道下已设置为置顶的所有文档

参数：
_currChannel - 特定的频道
_docFilter - 文档的条件
返回：
该频道下置顶的文档集合，没有则返回空的Documents集合
抛出：
WCMException

isDocumentTopped

public boolean isDocumentTopped(Document _currDocument,
                                Channel _currChannel)
                         throws WCMException
判断一个频道下的文档是否是处于置顶状态

参数：
_currChannel - 文档所在频道
_currDocument - 文档
返回：
true为是置顶文档，false为不是置顶文档
抛出：
WCMException

setTopDocument

public void setTopDocument(Channel _currChannel,
                           Document _currDocument,
                           int _nToppedOrder,
                           CMyDateTime _dtValidUntil)
                    throws WCMException
将特定频道下的一篇文档设置为置顶
如果特定的位置已经存在文档，则需要将该位置及其后的所有置顶向后移动一位
如果最后一个置顶项目也有占用，则自动将置顶位置扩展一位！
文档从置顶变成非置顶后，文档的顺序应该回到原位

参数：
_currChannel - 文档所在频道
_currDocument - 文档
_nToppedOrder - 该文档在当前频道下置顶的顺序
如果置顶顺序为常量NOT_ON_TOP（0），则表示不置顶
_dtValidUntil - 置顶有效期为null，表示置顶用不过期，不触发计划任务
置顶的有效期（截止日期）
抛出：
WCMException - 如果置顶顺序大于最大顺序，则抛出异常
如果置顶位置上已存在文档，则抛出异常

setTopedDocument

public void setTopedDocument(Document _document,
                             Channel _channel,
                             int _nTopOrder,
                             CMyDateTime _dtTopedValid)
                      throws WCMException
抛出：
WCMException

removeToppedDocument

public void removeToppedDocument(Channel _currChannel,
                                 Document _currDocument)
                          throws WCMException
取消特定频道下某文档的置顶标志
该文档将成为普通文档
注意，不是删除文档！

参数：
_currChannel - 特定频道
_currDocument - 文档
抛出：
WCMException - 如果该文档不是置顶的，也不抛出异常

getTopPosition

public int getTopPosition(Channel _currChannel,
                          Document _currDocument)
                   throws WCMException
得到频道下文档的置顶位置

参数：
_currChannel -
_currDocument -
返回：
置顶位置，1为第一位，2为第二位；如果没有置顶则返回0
抛出：
WCMException

save

public Document save(Document _currDocument)
              throws WCMException
在频道下保存/修改一篇文档
文档的频道属性不能在此被修改，而应该通过移动操作进行修改
文档的假删除、恢复 都需要调用相关接口，而不该通过修改接口
修改文档状态时，需要同步修改ChnlDoc的状态

参数：
_currDocument - 新建/修改的文档
返回：
抛出：
WCMException

copyDocument

public Document copyDocument(Document _fromDocument,
                             Channel _fromChannel,
                             Channel _toChannel)
                      throws WCMException
复制文档到另一个频道上
不负责非依赖型关联对象的复制，如附件和相关文档
不能将一个文档从草稿箱或者复制到草稿箱
复制引用转发的文档相当于创建一个新的引用转发
复制实体文档，则需要在目标频道下创建一个新的实体文档

参数：
_fromDocument - 原始文档
_toChannel - 目标频道
返回：
抛出：
WCMException

getQutoedChannels

public Channels getQutoedChannels(Document _currDocument,
                                  int _nDocModal,
                                  java.lang.String _sExtraChnlDocWhere)
                           throws WCMException
获得实体文档对应的特定类型的频道集合
包括所有转发的频道、镜像的频道、实体频道和所有频道

参数：
_currDocument -
_nDocModal -
_sExtraChnlDocWhere - TODO
返回：
抛出：
WCMException

getQutoedChannels

public Channels getQutoedChannels(Document _currDocument,
                                  int _nDocModal,
                                  java.lang.String _sExtraChnlDocWhere,
                                  boolean _bIsIncludeTrashed)
                           throws WCMException
抛出：
WCMException

getChannels

public Channels getChannels(Document _currDocument,
                            int _nDocModal,
                            java.lang.String _sExtraChnlDocWhere)
                     throws WCMException
获取所有与文档相关的频道

参数：
_currDocument -
_nDocModal -
_sExtraChnlDocWhere -
返回：
抛出：
WCMException

moveTo

public Report moveTo(Document _fromDocument,
                     Channel _fromChannel,
                     Channel _toChannel)
              throws WCMException
将文档从一个频道移动到另一个频道
  • 支持引用和镜像的移动
  • 如果是草稿箱中的，则不支持移动；也不支持移动到草稿箱
  • 如果目标频道下已经存在，则无法移动

    参数：
    _fromDocument -
    _fromChannel -
    _toChannel -
    返回：
    抛出：
    WCMException

    • moveTo

    public Report moveTo(Document _fromDocument,
                     Channel _fromChannel,
                     Channel _toChannel,
                     java.lang.String _sIsPhoto)
              throws WCMException
    抛出：
    WCMException

    restore

    public void restore(Document _delDocument,
                    Channel _currChannel)
             throws WCMException
    还原频道回收站中的一篇频道文档

    参数：
    ContextHelper - .getLoginUser() 当前操作用户
    _delDocument - 要回复的文档
    抛出：
    WCMException

    restore

    public void restore(ChnlDoc _oChnlDocDeleted)
             throws WCMException
    恢复指定的ChnlDoc

    参数：
    _oChnlDocDeleted -
    抛出：
    WCMException

    restoreAll

    public void restoreAll(User _currUser,
                       BaseChannel _oSiteOrChannel)
                throws WCMException
    参数：
    _oSiteOrChannel -
    抛出：
    WCMException

    clearAll

    public void clearAll(User _currUser,
                     BaseChannel _oSiteOrChannel)
              throws WCMException
    清空回收站

    参数：
    _oSiteOrChannel -
    抛出：
    WCMException

    quoteTo

    public Report quoteTo(Document _fromDocument,
                      Channel _toChannel)
               throws WCMException
    将实体文档引用转发到另一个频道
  • 草稿箱中的文档无法转发
  • 目标频道为空无法转发

    参数：
    _fromDocument - 源实体转发文档，频道属性已经设置好
    _toChannel -
    抛出：
    WCMException

    • quoteTo

    public Report quoteTo(Document _fromDocument,
                      Channel _toChannel,
                      java.lang.String _sIsPhoto)
               throws WCMException
    抛出：
    WCMException

    mirrorTo

    public Report mirrorTo(Document _fromDocument,
                       Channel _toChannel)
                throws WCMException
    将实体文档镜像转发到另一个频道
  • 草稿箱中的文档无法转发
  • 目标频道为空无法转发

    参数：
    _fromDocument - 源实体转发文档，频道属性已经设置好
    _toChannel -
    抛出：
    WCMException

    • getRelatedDocuments

    public Documents getRelatedDocuments(Document _currDocument,
                                     int _nGetByWhich,
                                     WCMFilter _filter)
                              throws WCMException
    相关文档的相关方法

    抛出：
    WCMException

    getRelatedDocuments

    public Documents getRelatedDocuments(Document _currDocument,
                                     int _nGetByWhich,
                                     WCMFilter _filter,
                                     boolean _bExactMatch,
                                     boolean _bMultiSites)
                              throws WCMException
    获取与当前文档相关的文档集合(指定获取的方式:相关表/关键词/相关词等)

    参数：
    ContextHelper - .getLoginUser() 当前用户
    _currDocument - 当前文档
    _nGetByWhich - 获取相关文档的方式(Document.GET_RELATEDDOC_BY_RELATION等)
    _bExactMatch - 是否采用精确匹配
    _bMultiSites - 是否跨站点查询
    _filter - 过滤器(额外的查询条件)
    _nMaxSize - 指定取前几篇文档
    返回：
    与当前文档相关的文档集合
    抛出：
    WCMException

    getDocumentTopTime

    public CMyDateTime getDocumentTopTime(Document _currDocument,
                                      Channel _currChannel)
                               throws WCMException
    获得文档置顶的截止时间
  • 如果文档没有置顶，则直接返回null
  • 如果置顶文档没有设置截止时间则返回null

    参数：
    _currDocument - 置顶的文档
    _currChannel - 文档所在频道
    返回：
    返回置顶文档的截止时间（包含日期）
    抛出：
    WCMException

    • deleteDocQuotes

    public void deleteDocQuotes(Document _currDocument,
                            java.lang.String _sExcludeChannelIds)
                     throws WCMException
    根据频道排除Id，删除所有特定类型的文档转发关系

    参数：
    _currDocument - 文档对象
    _nDocModal - 查询的文档类型
    _sExcludeChannelIds - 目前文档需要的转发关联频道Ids，除了这些Ids的文档转发关联关系都要删除
    抛出：
    WCMException

    moveDocumentInChannel

    public void moveDocumentInChannel(Document _fromDocument,
                                  Document _toDocument,
                                  Channel _currChannel,
                                  int _nPosition)
                           throws WCMException
    在频道中移动文档的顺序
    如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
    通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
    置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档

    参数：
    _fromDocument - 要移动的文档
    _toDocument - 移动的目标文档
    _currChannel - 文档所在频道
    抛出：
    WCMException

    moveDocumentInChannel

    public void moveDocumentInChannel(Document _fromDocument,
                                  Document _toDocument,
                                  Channel _currChannel)
                           throws WCMException
    在频道中移动文档的顺序
    如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
    通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
    置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档

    参数：
    _fromDocument - 要移动的文档
    _toDocument - 移动的目标文档
    _currChannel - 文档所在频道
    抛出：
    WCMException

    getPreviousChnlDoc

    public ChnlDoc getPreviousChnlDoc(ChnlDoc _currChnlDoc,
                                  boolean _bIncludeTop)
                           throws WCMException
    得到频道内，当前频道文档的前一个频道文档。
    就是DocOrder比其大的第一个ChnlDoc

    参数：
    _currChnlDoc -
    _bIncludeTop - 是否包括置顶文档，false为不包括，true为包括
    返回：
    抛出：
    WCMException

    getNextChnlDoc

    public ChnlDoc getNextChnlDoc(ChnlDoc _currChnlDoc,
                              boolean _bIncludeTop)
                       throws WCMException
    得到频道内，当前频道文档的后一个频道文档。
    就是DocOrder比其小的第一个ChnlDoc

    参数：
    _currChnlDoc -
    _bIncludeTop - 是否包括置顶文档，false为不包括，true为包括
    返回：
    抛出：
    WCMException

    getFirstChnlDoc

    public ChnlDoc getFirstChnlDoc(ChnlDoc _currChnlDoc,
                               boolean _bIncludeTop)
                        throws WCMException
    得到频道内的第一个频道文档。
    就是DocOrder最大的一个ChnlDoc

    参数：
    _currChnlDoc -
    _bIncludeTop - 是否包括置顶文档，false为不包括，true为包括
    返回：
    抛出：
    WCMException

    getLastChnlDoc

    public ChnlDoc getLastChnlDoc(ChnlDoc _currChnlDoc,
                              boolean _bIncludeTop)
                       throws WCMException
    得到频道内的最后一个频道文档。
    就是DocOrder最小的一个ChnlDoc

    参数：
    _currChnlDoc -
    _bIncludeTop - 是否包括置顶文档，false为不包括，true为包括
    返回：
    抛出：
    WCMException

    moveAllDocumentsToChannel

    public Reports moveAllDocumentsToChannel(Channel _fromChannel,
                                         Channel _toChannel)
                                  throws WCMException
    移动当前栏目下现有文档到指定的频道

    参数：
    _sViewDocuments -
    _fromChannel -
    _toChannel -
    抛出：
    WCMException

    moveDocumentsToChannel

    public Reports moveDocumentsToChannel(ViewDocuments _sViewDocuments,
                                      Channel _fromChannel,
                                      Channel _toChannel)
                               throws WCMException
    抛出：
    WCMException

    setTopDocument

    public void setTopDocument(Channel _currChannel,
                           Document _fromDocument,
                           Document _toDocument,
                           int _nPosition,
                           CMyDateTime dtValid)
                    throws WCMException
    抛出：
    WCMException
    概述 软件包 类 使用 树 已过时 索引 帮助
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentMoveListenerForDocSiteRecode

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentMoveListenerForDocSiteRecode

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentMoveListenerForDocSiteRecode
所有已实现的接口：
IServiceListener
public class DocumentMoveListenerForDocSiteRecode
extends java.lang.Object
implements IServiceListener

构造方法摘要
DocumentMoveListenerForDocSiteRecode()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentMoveListenerForDocSiteRecode

public DocumentMoveListenerForDocSiteRecode()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig _oListenerConfig,
                                 MethodContext _oMethodContext,
                                 java.lang.Object _oServiceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
_oListenerConfig - 当前Lisntener的设置对象
_oMethodContext - 执行服务的当前上下文参数
_oServiceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentPriMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentPriMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentPriMgr

public class DocumentPriMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
管理和文档置顶相关的所有行为，包括监控生命周期的变化
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentPriMgr()
方法摘要
 Schedule findSchedule(ChnlDoc _currChnlDoc)
查找文档置顶计划中，当前ChnlDoc对应的计划发布任务
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentPriMgr

public DocumentPriMgr()
方法详细信息

findSchedule

public Schedule findSchedule(ChnlDoc _currChnlDoc)
                      throws WCMException
查找文档置顶计划中，当前ChnlDoc对应的计划发布任务

参数：
_currChnlDoc -
返回：
null表示没有找到，其他则返回当前的Schedule
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentsGetHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentsGetHelper

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentsGetHelper

public class DocumentsGetHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
单表提取文档集合的功能对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentsGetHelper()
方法摘要
static Documents | getDocuments(Channel _channel, WCMFilter _filter)
static Documents | getDocuments(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder)
static void | main(java.lang.String[] args)
static WCMFilter | makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
static WCMFilter | makeChannelFilter(Channel _channel, WCMFilter _filter)
static WCMFilter | makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
static WCMFilter | makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle, int _nTrueChannelId)
static WCMFilter | makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
static WCMFilter | makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentsGetHelper

public DocumentsGetHelper()
方法详细信息

getDocuments

public static Documents getDocuments(Channel _channel,
                                     WCMFilter _filter)
                              throws WCMException
抛出：
WCMException

getDocuments

public static Documents getDocuments(Channel _channel,
                                     WCMFilter _filter,
                                     boolean _bIncludeOrder)
                              throws WCMException
抛出：
WCMException

makeChannelFilter

public static WCMFilter makeChannelFilter(Channel _channel,
                                          WCMFilter _filter)
                                   throws WCMException
参数：
_channel -
_filter -
抛出：
WCMException

makeChannelFilter

public static WCMFilter makeChannelFilter(Channel _channel,
                                          WCMFilter _filter,
                                          boolean _bIncludeOrder,
                                          boolean _bFromRecycle)
                                   throws WCMException
抛出：
WCMException

makeChannelFilter

public static WCMFilter makeChannelFilter(Channel _channel,
                                          WCMFilter _filter,
                                          boolean _bIncludeOrder,
                                          boolean _bFromRecycle,
                                          int _nTrueChannelId)
                                   throws WCMException
抛出：
WCMException

makeFilter

public static WCMFilter makeFilter(WebSite _site,
                                   WCMFilter _extraFilter,
                                   boolean _bIncludeOrder,
                                   boolean _bFromRecycle)

makeFilter

public static WCMFilter makeFilter(WebSites _sites,
                                   WCMFilter _extraFilter,
                                   boolean _bIncludeOrder,
                                   boolean _bFromRecycle)
参数：
_sites -
_extraFilter -
_bIncludeOrder -
返回：

makeChannelFilter

public static WCMFilter makeChannelFilter(Channels _channels,
                                          WCMFilter _filter,
                                          boolean _bFromRecycle)
                                   throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentsTimeRangeMgrImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 DocumentsTimeRangeMgrImpl

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl
所有已实现的接口：
IDocumentsTimeRangeMgr
public class DocumentsTimeRangeMgrImpl
extends java.lang.Object
implements IDocumentsTimeRangeMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String DOCUMENTS_TIMERANGE_INI
构造方法摘要
DocumentsTimeRangeMgrImpl()
方法摘要
CMyDateTime | getStartDateTime(int _nChannelId) 获取指定频道提取文档的开始时间
CMyDateTime | getStartDateTime(int _nObjectId, int _nObjectType) 获取指定对象提取文档的开始时间
int | getTimeRange(int _nChannelId) 获取指定频道的限定时间(单位:天)
int | getTimeRange(int _nObjectId, int _nObjectType) 获取指定对象的限定时间(单位:天)
boolean | isSetTimeRange(int _nChannelId) 判断是否给指定的频道限定了时间范围
boolean | isSetTimeRange(int _nObjectId, int _nObjectType) 判断是否给指定的对象限定了时间范围
void | reloadTimeRangeConfig() 重新装载文档集合提取时间约束
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DOCUMENTS_TIMERANGE_INI

public static final java.lang.String DOCUMENTS_TIMERANGE_INI
另请参见：
常量字段值
构造方法详细信息

DocumentsTimeRangeMgrImpl

public DocumentsTimeRangeMgrImpl()
方法详细信息

reloadTimeRangeConfig

public void reloadTimeRangeConfig()
从接口 IDocumentsTimeRangeMgr 复制的描述
重新装载文档集合提取时间约束

指定者：
接口 IDocumentsTimeRangeMgr 中的 reloadTimeRangeConfig

isSetTimeRange

public boolean isSetTimeRange(int _nChannelId)
从接口 IDocumentsTimeRangeMgr 复制的描述
判断是否给指定的频道限定了时间范围

指定者：
接口 IDocumentsTimeRangeMgr 中的 isSetTimeRange
参数：
_nChannelId - 指定的频道ID
返回：
如果限定了,返回true; 否则返回false

getTimeRange

public int getTimeRange(int _nChannelId)
从接口 IDocumentsTimeRangeMgr 复制的描述
获取指定频道的限定时间(单位:天)

指定者：
接口 IDocumentsTimeRangeMgr 中的 getTimeRange
参数：
_nChannelId - 指定的频道ID
返回：
指定频道的限定时间(单位:天)

getStartDateTime

public CMyDateTime getStartDateTime(int _nChannelId)
从接口 IDocumentsTimeRangeMgr 复制的描述
获取指定频道提取文档的开始时间

指定者：
接口 IDocumentsTimeRangeMgr 中的 getStartDateTime
参数：
_nChannelId - 指定的频道ID
返回：
指定频道提取文档的开始时间

isSetTimeRange

public boolean isSetTimeRange(int _nObjectId,
                              int _nObjectType)
从接口 IDocumentsTimeRangeMgr 复制的描述
判断是否给指定的对象限定了时间范围

指定者：
接口 IDocumentsTimeRangeMgr 中的 isSetTimeRange
参数：
_nObjectId - 指定的对象ID
_nObjectType - 指定的对象类型
返回：
如果限定了,返回true; 否则返回false

getTimeRange

public int getTimeRange(int _nObjectId,
                        int _nObjectType)
从接口 IDocumentsTimeRangeMgr 复制的描述
获取指定对象的限定时间(单位:天)

指定者：
接口 IDocumentsTimeRangeMgr 中的 getTimeRange
参数：
_nObjectId - 指定的对象ID
_nObjectType - 指定的对象类型
返回：
指定对象的限定时间(单位:天)

getStartDateTime

public CMyDateTime getStartDateTime(int _nObjectId,
                                    int _nObjectType)
从接口 IDocumentsTimeRangeMgr 复制的描述
获取指定对象提取文档的开始时间

指定者：
接口 IDocumentsTimeRangeMgr 中的 getStartDateTime
参数：
_nObjectId - 指定的对象ID
_nObjectType - 指定的对象类型
返回：
指定对象提取文档的开始时间
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExtendedFieldLCListenerForDocBak

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ExtendedFieldLCListenerForDocBak

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ExtendedFieldLCListenerForDocBak
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnModify, IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ExtendedFieldLCListenerForDocBak()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjEdited, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExtendedFieldLCListenerForDocBak

public ExtendedFieldLCListenerForDocBak()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjEdited,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjEdited - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IChannelImporterConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
接口 IChannelImporterConverter

所有已知实现类：
FlowConverterForWebsiteImporter, MetaViewEmplyerConverterForChannelImporter
public interface IChannelImporterConverter

方法摘要
 void registerConverter(java.lang.Object _args)

方法详细信息

registerConverter

void registerConverter(java.lang.Object _args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDocKeywordMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
接口 IDocKeywordMgr

所有已知实现类：
DocKeywordMgrImpl
public interface IDocKeywordMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | addNewDocKeywords(Document _document) 增加指定文档的相关新闻记录
Documents | getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter) 获取指定文档的所有相关文档
Documents | getRelatedDocumentsByKeywords(Document _document, int _nMaxSize, java.lang.String _sSelectFields, int[] _pFilterStatusId, boolean _bMultiSite, java.util.ArrayList _arExistDocumentTitles) 获取指定文档的相关文档
void | removeDocKeywords(Document _document) 删除指定文档的相关新闻记录
void | updateDocKeywords(Document _document, java.lang.String _sOldKeywords, java.lang.String _sNewKeywords) 更新指定文档的相关文档记录信息

方法详细信息

addNewDocKeywords

void addNewDocKeywords(Document _document)
                       throws WCMException
增加指定文档的相关新闻记录

参数：
_document - 指定的文档对象
抛出：
WCMException

updateDocKeywords

void updateDocKeywords(Document _document,
                       java.lang.String _sOldKeywords,
                       java.lang.String _sNewKeywords)
                       throws WCMException
更新指定文档的相关文档记录信息

参数：
_document - 指定的文档对象
_sOldKeywords - 老的关键词
_sNewKeywords - 新的关键词
抛出：
WCMException

removeDocKeywords

void removeDocKeywords(Document _document)
                       throws WCMException
删除指定文档的相关新闻记录

参数：
_document - 指定的文档对象
抛出：
WCMException

getRelatedDocumentsByKeywords

Documents getRelatedDocumentsByKeywords(Document _document,
                                        int _nMaxSize,
                                        java.lang.String _sSelectFields,
                                        int[] _pFilterStatusId,
                                        boolean _bMultiSite,
                                        java.util.ArrayList _arExistDocumentTitles)
                                        throws WCMException
获取指定文档的相关文档

参数：
_document - 指定的文档对象
_nMaxSize - 相关文档的最大数目
_sSelectFields - 提取的字段列表
_pFilterStatusId - 是否要求过来状态
_bMultiSite - 是否跨站点取相关文档,默认只取同站点的文档
返回：
抛出：
WCMException

getAllRelatedDocumentsByKeywords

Documents getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords,
                                           int _nExcludeDocId,
                                           WCMFilter _filter)
                                           throws WCMException
获取指定文档的所有相关文档

参数：
_sKeywords - 指定的文档对象
_nExcludeDocId - TODO
_filter - 指定filter（如果不指定，默认按照入库时间进行排序；没有额外的检索条件）
返回：
文档集合
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDocumentImporterConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
接口 IDocumentImporterConverter

public interface IDocumentImporterConverter

方法摘要
 void registerConverter(java.lang.Object _args)

方法详细信息

registerConverter

void registerConverter(java.lang.Object _args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDocumentsTimeRangeMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
接口 IDocumentsTimeRangeMgr

所有已知实现类：
DocumentsTimeRangeMgrImpl
public interface IDocumentsTimeRangeMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
CMyDateTime | getStartDateTime(int _nChannelId) 获取指定频道提取文档的开始时间
CMyDateTime | getStartDateTime(int _nObjectId, int _nObjectType) 获取指定对象提取文档的开始时间
int | getTimeRange(int _nChannelId) 获取指定频道的限定时间(单位:天)
int | getTimeRange(int _nObjectId, int _nObjectType) 获取指定对象的限定时间(单位:天)
boolean | isSetTimeRange(int _nChannelId) 判断是否给指定的频道限定了时间范围
boolean | isSetTimeRange(int _nObjectId, int _nObjectType) 判断是否给指定的对象限定了时间范围
void | reloadTimeRangeConfig() 重新装载文档集合提取时间约束

方法详细信息

reloadTimeRangeConfig

void reloadTimeRangeConfig()
重新装载文档集合提取时间约束

isSetTimeRange

boolean isSetTimeRange(int _nChannelId)
判断是否给指定的频道限定了时间范围

参数：
_nChannelId - 指定的频道ID
返回：
如果限定了,返回true; 否则返回false

getTimeRange

int getTimeRange(int _nChannelId)
获取指定频道的限定时间(单位:天)

参数：
_nChannelId - 指定的频道ID
返回：
指定频道的限定时间(单位:天)

getStartDateTime

CMyDateTime getStartDateTime(int _nChannelId)
获取指定频道提取文档的开始时间

参数：
_nChannelId - 指定的频道ID
返回：
指定频道提取文档的开始时间

isSetTimeRange

boolean isSetTimeRange(int _nObjectId,
                       int _nObjectType)
判断是否给指定的对象限定了时间范围

参数：
_nObjectId - 指定的对象ID
_nObjectType - 指定的对象类型
返回：
如果限定了,返回true; 否则返回false

getTimeRange

int getTimeRange(int _nObjectId,
                 int _nObjectType)
获取指定对象的限定时间(单位:天)

参数：
_nObjectId - 指定的对象ID
_nObjectType - 指定的对象类型
返回：
指定对象的限定时间(单位:天)

getStartDateTime

CMyDateTime getStartDateTime(int _nObjectId,
                             int _nObjectType)
获取指定对象提取文档的开始时间

参数：
_nObjectId - 指定的对象ID
_nObjectType - 指定的对象类型
返回：
指定对象提取文档的开始时间
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewEmployLCListenerForChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 InfoViewEmployLCListenerForChannel

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd
public class InfoViewEmployLCListenerForChannel
extends java.lang.Object
implements IObjectLCListenerOnAdd

字段摘要
static org.apache.log4j.Logger s_logger
构造方法摘要
InfoViewEmployLCListenerForChannel()
方法摘要
 void notifyOnAddObj(BaseObj _objAdded)
新增一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

s_logger

public static final org.apache.log4j.Logger s_logger
构造方法详细信息

InfoViewEmployLCListenerForChannel

public InfoViewEmployLCListenerForChannel()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _objAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_objAdded - 新增的对象
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.content.domain
接口
IChannelImporterConverter
IDocKeywordMgr
IDocumentImporterConverter
IDocumentsTimeRangeMgr
类
ApdHostLCListener
AppendixMgr
AutoDocBakMgr
AutoTransmitMgr
BaseChannelLCListener4ExtField
BaseChannelLCListener4Region
ChannelExporter
ChannelImporter
ChannelLCListenerForChannelSyn
ChannelLCListenerForDocument
ChannelLCListenerForExtField
ChannelLCListenerForSpeical
ChannelMgr
ChnlDocLCListener4ClassInfo
ChnlDocLCListenerForAutoDocBak
ChnlDocLCListenerForPri
ChnlDocLCListenerForRecordNotEntity
ChnlSynWorker
ContentExtFieldCListenerForDocProps
ContentExtFieldLCListenerForDocFields
ContentExtFieldMgr
ContentLinkMgr
DatasWithChnlDocFilterHelper
DocBakLCListenerForApd
DocBakMgr
DocKeywordMgrImpl
DocPriDisableWorker
DocReplyMgr
DocumentExporter
DocumentImporter
DocumentLCListenerForAutoDocBak
DocumentLCListenerForDocBak
DocumentLCListenerForDocReply
DocumentLCListenerForExternalFile
DocumentLCListenerForKeyword
DocumentLCListenerForRelation
DocumentLCListenerForRelDocs
DocumentMgr
DocumentMoveListenerForDocSiteRecode
DocumentPriMgr
DocumentsGetHelper
DocumentsTimeRangeMgrImpl
ExtendedFieldLCListenerForDocBak
InfoViewEmployLCListenerForChannel
RelationMgr
ReplaceMgr
RightLCListenerForSynSiteMember
SiteMemberIdsMan
SiteMemberLCListner
SiteMemberMgr
UserDocumentMgr
WCMDocAppendixesParserForImporter
WebSiteLCListenerForAutoDocBak
WebSiteLCListenerForContentLink
WebSiteLCListenerForSiteUser
XmlToDocumentConverter


com.trs.components.wcm.content.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.content.domain

接口摘要
IChannelImporterConverter |
IDocKeywordMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IDocumentImporterConverter |
IDocumentsTimeRangeMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
ApdHostLCListener | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
AppendixMgr |
AutoDocBakMgr | Title: TRS 内容协作平台（TRS WCM） Description: 文档版本自动保存的控制类，对Document的生命周期进行监控，触发自动备份操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
AutoTransmitMgr | Title: TRS 内容协作平台（TRS WCM） Description: 文档自动分发管理类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseChannelLCListener4ExtField | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
BaseChannelLCListener4Region | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
ChannelExporter | Title: TRS 内容协作平台（TRS WCM） Description: 站点/导出对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelImporter | Title: TRS 内容协作平台（TRS WCM） Description: 从XML文件中导入站点/频道数据 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelLCListenerForChannelSyn | Title: TRS 内容协作平台（TRS WCM） Description: 监控频道被删除时，同步删除与该频道相关的频道分发设置 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelLCListenerForDocument | Title: TRS 内容协作平台（TRS WCM） Description: 与文档相关的栏目生命周期监听处理.
ChannelLCListenerForExtField | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelLCListenerForSpeical | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
ChannelMgr | Title: TRS 内容协作平台（TRS WCM） Description: 管理栏目/站点相关的行为和操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocLCListener4ClassInfo | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ChnlDocLCListenerForAutoDocBak | Title: TRS 内容协作平台（TRS WCM） Description: 监听ChnlDoc状态的修改,在满足一定条件时保存一个文档版本 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocLCListenerForPri | Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc LC Listener For Document Pri Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocLCListenerForRecordNotEntity |
ChnlSynWorker |
ContentExtFieldCListenerForDocProps |
ContentExtFieldLCListenerForDocFields |
ContentExtFieldMgr | Title: TRS 内容协作平台（TRS WCM） Description: 内容扩展字段管理者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentLinkMgr | Title: TRS 内容协作平台（TRS WCM） Description: 管理和内容超链接相关的行为 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DatasWithChnlDocFilterHelper | Title: TRS 内容协作平台（TRS WCM） Description: 单表提取文档集合的功能对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocBakLCListenerForApd | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocBakMgr | Title: TRS 内容协作平台（TRS WCM） Description: 文档备份相关的行为 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocKeywordMgrImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocPriDisableWorker | Title: TRS 内容协作平台（TRS WCM） Description: 根据文档置顶的截止时间撤销文档置顶的计划任务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocReplyMgr | Title: TRS 内容协作平台（TRS WCM） Description: 文档回复相关行为的管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentExporter | Title: TRS 内容协作平台（TRS WCM） Description: 文档导出,将文档(集合)导出为Zip/Xml文件 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentImporter |
DocumentLCListenerForAutoDocBak | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForDocBak | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForDocReply | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForExternalFile | Title: TRS 内容协作平台（TRS WCM） Description: 外部文档的文件处理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForKeyword |
DocumentLCListenerForRelation | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForRelDocs |
DocumentMgr | Title: TRS 内容协作平台（TRS WCM） Description: 文档的管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentMoveListenerForDocSiteRecode |
DocumentPriMgr | Title: TRS 内容协作平台（TRS WCM） Description: 管理和文档置顶相关的所有行为，包括监控生命周期的变化 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentsGetHelper | Title: TRS 内容协作平台（TRS WCM） Description: 单表提取文档集合的功能对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentsTimeRangeMgrImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ExtendedFieldLCListenerForDocBak | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewEmployLCListenerForChannel |
RelationMgr | Title: TRS 内容协作平台（TRS WCM） Description: 相关文档的行为管理 目前只描述文档和文档之间的关联关系，即相关文档 如果经过调整，可以描述相同类型对象间的关联关系，如相关频道、相关附件等概念 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ReplaceMgr | Title: TRS 内容协作平台（TRS WCM） Description: 管理和替换内容相关的行为 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RightLCListenerForSynSiteMember | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SiteMemberIdsMan | Title: TRS 内容协作平台（TRS WCM） Description: 站点用户关联处理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SiteMemberLCListner | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SiteMemberMgr | Title: TRS 内容协作平台（TRS WCM） Description: 站点用户/用户组管理者对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UserDocumentMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMDocAppendixesParserForImporter | Title: TRS 内容协作平台（TRS WCM） Description: 导入非WCM导出的文档时,文档附件的解释 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteLCListenerForAutoDocBak | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteLCListenerForContentLink | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteLCListenerForSiteUser | Title: TRS 内容协作平台（TRS WCM） Description: 站点用户/用户组监听 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XmlToDocumentConverter | Title: TRS 内容协作平台（TRS WCM） Description: Xml-->Document(WCM)对象的转换 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm.content.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.AbstractXmlToObjConverter
      • com.trs.components.wcm.content.domain.XmlToDocumentConverter
    • com.trs.components.wcm.content.domain.ApdHostLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.AppendixMgr
    • com.trs.components.wcm.content.domain.AutoDocBakMgr
    • com.trs.components.wcm.content.domain.AutoTransmitMgr
    • com.trs.components.wcm.content.domain.BaseChannelLCListener4ExtField (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.BaseChannelLCListener4Region (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.infra.common.BaseIdsMan
      • com.trs.components.wcm.content.domain.SiteMemberIdsMan
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.components.common.job.BaseScheduleWorker
        • com.trs.components.common.job.BaseStatefulScheduleWorker (implements org.quartz.StatefulJob)
          • com.trs.components.wcm.content.domain.ChnlSynWorker
        • com.trs.components.wcm.content.domain.DocPriDisableWorker
    • com.trs.components.wcm.content.domain.ChannelExporter
    • com.trs.components.wcm.content.domain.ChannelImporter
    • com.trs.components.wcm.content.domain.ChannelLCListenerForChannelSyn (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ChannelLCListenerForDocument (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.ChannelLCListenerForExtField (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ChannelLCListenerForSpeical (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ChannelMgr
    • com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ChnlDocLCListenerForAutoDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ContentExtFieldCListenerForDocProps (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ContentExtFieldLCListenerForDocFields (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.ContentExtFieldMgr
    • com.trs.components.wcm.content.domain.ContentLinkMgr
    • com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper
    • com.trs.components.wcm.content.domain.DocBakLCListenerForApd (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.DocBakMgr
    • com.trs.components.wcm.content.domain.DocKeywordMgrImpl (implements com.trs.components.wcm.content.domain.IDocKeywordMgr)
    • com.trs.components.wcm.content.domain.DocReplyMgr
    • com.trs.components.wcm.content.domain.DocumentExporter
    • com.trs.components.wcm.content.domain.DocumentImporter
    • com.trs.components.wcm.content.domain.DocumentLCListenerForAutoDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForDocReply (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForRelation (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.DocumentMgr
    • com.trs.components.wcm.content.domain.DocumentMoveListenerForDocSiteRecode (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.wcm.content.domain.DocumentPriMgr
    • com.trs.components.wcm.content.domain.DocumentsGetHelper
    • com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl (implements com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr)
    • com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd)
    • com.trs.components.wcm.content.domain.RelationMgr
    • com.trs.components.wcm.content.domain.ReplaceMgr
    • com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.content.domain.SiteMemberLCListner (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.SiteMemberMgr
    • com.trs.components.wcm.content.domain.UserDocumentMgr
    • com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter
    • com.trs.components.wcm.content.domain.WebSiteLCListenerForAutoDocBak (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.WebSiteLCListenerForContentLink (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.content.domain.WebSiteLCListenerForSiteUser (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)

接口分层结构

  • com.trs.components.wcm.content.domain.IChannelImporterConverter
  • com.trs.components.wcm.content.domain.IDocKeywordMgr
  • com.trs.components.wcm.content.domain.IDocumentImporterConverter
  • com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr


软件包 com.trs.components.wcm.content.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.domain
的使用

使用 com.trs.components.wcm.content.domain 的软件包
com.trs.components.metadata.service.domain
com.trs.components.wcm.content.domain
com.trs.components.wcm.process.service.domain
com.trs.service.impl

com.trs.components.metadata.service.domain 使用的 com.trs.components.wcm.content.domain 中的类
IChannelImporterConverter

com.trs.components.wcm.content.domain 使用的 com.trs.components.wcm.content.domain 中的类
IDocKeywordMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IDocumentsTimeRangeMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process.service.domain 使用的 com.trs.components.wcm.content.domain 中的类
IChannelImporterConverter

com.trs.service.impl 使用的 com.trs.components.wcm.content.domain 中的类
AppendixMgr
DocumentMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
文档的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RelationMgr
Title: TRS 内容协作平台（TRS WCM）
Description: 相关文档的行为管理
目前只描述文档和文档之间的关联关系，即相关文档
如果经过调整，可以描述相同类型对象间的关联关系，如相关频道、相关附件等概念

Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RelationMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 RelationMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.RelationMgr

public class RelationMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description: 相关文档的行为管理

  • 目前只描述文档和文档之间的关联关系，即相关文档
  • 如果经过调整，可以描述相同类型对象间的关联关系，如相关频道、相关附件等概念

    Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
    Company: TRS信息技术有限公司(www.trs.com.cn)

    版本：
    1.0
    作者：
    TRS信息技术有限公司

    构造方法摘要
    RelationMgr()
    方法摘要
     java.util.List copyRelationListByObj(BaseObj _currObj)
    以List方式获得文档所属关联文档集合
    在处理文档时是个有用的接口
    该接口应该是获得对象的关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用
    以后扩展应该也比较方便，增加一个对象类型ID即可
     void copyRelations(Document _fromDocument, Document _newDocument)
    复制某个特定文档的所有相关文档到一个新文档中
     void deleteRelations(Document _document)
     void deleteUnuseRelations(java.lang.String _sUseingIds, Document _document)
     Relations getRelations(Document _currDocument)
     Relations getRelations(Document _currDocument, WCMFilter _extraFilter)
     Relations getRelations(WCMFilter _aWCMFilter)
    根据条件获得相关文档
     void saveRelations(Document _currDocument, java.util.List _currRelationList)
    保存相关文档的信息，可能是添加或者修改时调用
    从类 java.lang.Object 继承的方法
    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    构造方法详细信息

    RelationMgr

    public RelationMgr()
    方法详细信息

    saveRelations

    public void saveRelations(Document _currDocument,
                          java.util.List _currRelationList)
                   throws WCMException
    保存相关文档的信息，可能是添加或者修改时调用

    参数：
    ContextHelper - .getLoginUser()
    _Relations -
    抛出：
    WCMException

    getRelations

    public Relations getRelations(Document _currDocument)
                       throws WCMException
    抛出：
    WCMException

    getRelations

    public Relations getRelations(Document _currDocument,
                              WCMFilter _extraFilter)
                       throws WCMException
    抛出：
    WCMException

    copyRelationListByObj

    public java.util.List copyRelationListByObj(BaseObj _currObj)
                                     throws WCMException
    以List方式获得文档所属关联文档集合
    在处理文档时是个有用的接口
    该接口应该是获得对象的关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用
    以后扩展应该也比较方便，增加一个对象类型ID即可

    参数：
    _currObj - 欲查询的主对象
    返回：
    对象关联对象的集合
    抛出：
    WCMException - 使用OpenObjs方法打开集合时可能的异常

    copyRelations

    public void copyRelations(Document _fromDocument,
                          Document _newDocument)
                   throws WCMException
    复制某个特定文档的所有相关文档到一个新文档中

    参数：
    _fromDocument - 原文档，是相关文档的来源
    _newDocument - 目标文档，是相关文档要存放的宿主点
    抛出：
    WCMException

    deleteUnuseRelations

    public void deleteUnuseRelations(java.lang.String _sUseingIds,
                                 Document _document)
                          throws WCMException
    抛出：
    WCMException

    getRelations

    public Relations getRelations(WCMFilter _aWCMFilter)
                       throws WCMException
    根据条件获得相关文档

    参数：
    _aWCMFilter -
    返回：
    抛出：
    WCMException

    deleteRelations

    public void deleteRelations(Document _document)
                     throws WCMException
    抛出：
    WCMException
    概述 软件包 类 使用 树 已过时 索引 帮助
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReplaceMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 ReplaceMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.ReplaceMgr

public class ReplaceMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
管理和替换内容相关的行为
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ReplaceMgr()
方法摘要
boolean | delete(Replace _aReplace) 删除指定的Replace对象
Replaces | getReplaces(Channel _oChannel, WCMFilter _filter) 获取当前频道下的替换内容
Replace | save(Replace _aReplace) 保存指定的Replace对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ReplaceMgr

public ReplaceMgr()
方法详细信息

getReplaces

public Replaces getReplaces(Channel _oChannel,
                            WCMFilter _filter)
                     throws WCMException
获取当前频道下的替换内容

参数：
_oChannel - 当前频道
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

save

public Replace save(Replace _aReplace)
             throws WCMException
保存指定的Replace对象

参数：
_aReplace - 要保存的对象
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(Replace _aReplace)
               throws WCMException
删除指定的Replace对象

参数：
_aReplace - 要删除的Replace对象
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RightLCListenerForSynSiteMember

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 RightLCListenerForSynSiteMember

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class RightLCListenerForSynSiteMember
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnModify, IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightLCListenerForSynSiteMember()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightLCListenerForSynSiteMember

public RightLCListenerForSynSiteMember()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteMemberIdsMan

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 SiteMemberIdsMan

java.lang.Object
    继承者  com.trs.infra.common.BaseIdsMan
        继承者  com.trs.components.wcm.content.domain.SiteMemberIdsMan

public class SiteMemberIdsMan
extends BaseIdsMan

Title: TRS 内容协作平台（TRS WCM）
Description:
站点用户关联处理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SiteMemberIdsMan(WebSite _site, int _nMemberType)
方法摘要
从类 com.trs.infra.common.BaseIdsMan 继承的方法
dowithIds
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteMemberIdsMan

public SiteMemberIdsMan(WebSite _site,
                        int _nMemberType)
                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteMemberLCListner

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 SiteMemberLCListner

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.SiteMemberLCListner
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class SiteMemberLCListner
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SiteMemberLCListner()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteMemberLCListner

public SiteMemberLCListner()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteMemberMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 SiteMemberMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.SiteMemberMgr

public class SiteMemberMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
站点用户/用户组管理者对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SiteMemberMgr()
方法摘要
void | addSiteGroup(WebSite _site, Group _group) 添加站点用户组 将指定的用户组添加到指定的站点
void | addSiteMember(int _nSiteId, int _nObjType, int _nObjId)
void | addSiteUser(WebSite _site, User _user) 添加站点用户 将指定的用户添加到指定的站点
Groups | getSiteGroups(WebSite _site, WCMFilter _filter) 获取站点中的用户组集合
Roles | getSiteRoles(WebSite _site, WCMFilter _fitler)
Users | getSiteUsers(WebSite _site, WCMFilter _filter) 获取站点中的用户集合
WebSites | getUserSites(User _currUser, WCMFilter _filter) 获取当前用户所在站点集合
WebSites | getWebSites(int _objType, int _objId, java.lang.String _sOrder) 获取某个对象（用户、组织、角色）可以管理的站点
boolean | isBelongToSite(CMSObj _operator, WebSite _site) 判断指定的对象是否属于指定的站点
boolean | isBelongToSite(Group _group, WebSite _site) 判断指定的用户组是否属于指定的站点
boolean | isBelongToSite(Role _role, WebSite _site) 判断指定的角色是否属于指定的站点
boolean | isBelongToSite(User _user, WebSite _site) 判断指定的用户是否属于指定的站点
boolean | isVisible(CMSObj _operator, WebSite _site)
boolean | isVisible(User _user, WebSite _site)
void | removeSiteGroup(WebSite _site, Group _group) 删除站点用户组 将指定的用户组从指定的站点删除
void | removeSiteMember(int _nSiteId, int _nObjType, int _nObjId)
void | removeSiteUser(WebSite _site, User _user) 删除站点用户 将指定的用户从指定的站点删除
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteMemberMgr

public SiteMemberMgr()
方法详细信息

addSiteUser

public void addSiteUser(WebSite _site,
                        User _user)
                 throws WCMException
添加站点用户
将指定的用户添加到指定的站点

参数：
_site - 指定的站点
_user - 指定的用户
抛出：
WCMException

removeSiteUser

public void removeSiteUser(WebSite _site,
                           User _user)
                    throws WCMException
删除站点用户
将指定的用户从指定的站点删除

参数：
_site - 指定的站点
_user - 指定的用户
抛出：
WCMException

addSiteGroup

public void addSiteGroup(WebSite _site,
                         Group _group)
                  throws WCMException
添加站点用户组
将指定的用户组添加到指定的站点

参数：
_site - 指定的站点
_group - 指定的用户组
抛出：
WCMException

removeSiteGroup

public void removeSiteGroup(WebSite _site,
                            Group _group)
                     throws WCMException
删除站点用户组
将指定的用户组从指定的站点删除

参数：
_site - 指定的站点
_group - 指定的用户组
抛出：
WCMException

getUserSites

public WebSites getUserSites(User _currUser,
                             WCMFilter _filter)
                      throws WCMException
获取当前用户所在站点集合

参数：
_currUser - 当前用户
_filter - 过滤器,额外的查询条件
返回：
抛出：
WCMException

getSiteUsers

public Users getSiteUsers(WebSite _site,
                          WCMFilter _filter)
                   throws WCMException
获取站点中的用户集合

参数：
_site - 指定站点
_filter - 过滤器,额外的查询条件
返回：
抛出：
WCMException

isVisible

public boolean isVisible(User _user,
                         WebSite _site)
                  throws WCMException
参数：
_user -
_site -
返回：
抛出：
WCMException

isVisible

public boolean isVisible(CMSObj _operator,
                         WebSite _site)
                  throws WCMException
参数：
_operator -
_site -
返回：
抛出：
WCMException

isBelongToSite

public boolean isBelongToSite(User _user,
                              WebSite _site)
                       throws WCMException
判断指定的用户是否属于指定的站点

参数：
_user - 指定的用户
_site - 指定的站点
返回：
如果属于，返回True;否则返回，返回false;
抛出：
WCMException

isBelongToSite

public boolean isBelongToSite(Group _group,
                              WebSite _site)
                       throws WCMException
判断指定的用户组是否属于指定的站点

参数：
_group - 指定的用户组
_site - 指定的站点
返回：
如果属于，返回True;否则返回，返回false;
抛出：
WCMException

isBelongToSite

public boolean isBelongToSite(Role _role,
                              WebSite _site)
                       throws WCMException
判断指定的角色是否属于指定的站点

参数：
_group - 指定的角色
_site - 指定的站点
返回：
如果属于，返回True;否则返回，返回false;
抛出：
WCMException

isBelongToSite

public boolean isBelongToSite(CMSObj _operator,
                              WebSite _site)
                       throws WCMException
判断指定的对象是否属于指定的站点

参数：
_group - 指定的对象
_site - 指定的站点
返回：
如果属于，返回True;否则返回，返回false;
抛出：
WCMException

getSiteGroups

public Groups getSiteGroups(WebSite _site,
                            WCMFilter _filter)
                     throws WCMException
获取站点中的用户组集合

参数：
_site - 指定的站点
_filter - 过滤器,额外的查询条件
返回：
抛出：
WCMException

getSiteRoles

public Roles getSiteRoles(WebSite _site,
                          WCMFilter _fitler)
                   throws WCMException
抛出：
WCMException

addSiteMember

public void addSiteMember(int _nSiteId,
                          int _nObjType,
                          int _nObjId)
                   throws WCMException
抛出：
WCMException

removeSiteMember

public void removeSiteMember(int _nSiteId,
                             int _nObjType,
                             int _nObjId)
                      throws WCMException
抛出：
WCMException

getWebSites

public WebSites getWebSites(int _objType,
                            int _objId,
                            java.lang.String _sOrder)
                     throws WCMException
获取某个对象（用户、组织、角色）可以管理的站点

参数：
_objType -
_objId -
_sOrder -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserDocumentMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 UserDocumentMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.UserDocumentMgr

public class UserDocumentMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
UserDocumentMgr()
方法摘要
Documents | getDocuments(WCMFilter _filter) 获取个人的所有有效文档
Documents | getDraft(WCMFilter _filter) 获取个人草稿
Documents | getRecycleDocuments(WCMFilter _filter) 获取个人回收站里的文档
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserDocumentMgr

public UserDocumentMgr()
方法详细信息

getDocuments

public Documents getDocuments(WCMFilter _filter)
                       throws WCMException
获取个人的所有有效文档

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getRecycleDocuments

public Documents getRecycleDocuments(WCMFilter _filter)
                              throws WCMException
获取个人回收站里的文档

参数：
_filter - 额外的查询用户
返回：
@throws WCMException
抛出：
WCMException

getDraft

public Documents getDraft(WCMFilter _filter)
                   throws WCMException
获取个人草稿

参数：
_filter - 额外的查询条件
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMDocAppendixesParserForImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 WCMDocAppendixesParserForImporter

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter

public class WCMDocAppendixesParserForImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
导入非WCM导出的文档时,文档附件的解释
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMDocAppendixesParserForImporter()
方法摘要
static org.w3c.dom.Document | getAppendixDoc(java.lang.String _sVal)
static java.lang.String | getDocContentString()
static org.w3c.dom.NodeList | getNodeList(java.lang.String _sVal)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMDocAppendixesParserForImporter

public WCMDocAppendixesParserForImporter()
方法详细信息

getAppendixDoc

public static org.w3c.dom.Document getAppendixDoc(java.lang.String _sVal)
                                           throws javax.xml.parsers.ParserConfigurationException,
                                                  javax.xml.parsers.FactoryConfigurationError
抛出：
javax.xml.parsers.ParserConfigurationException
javax.xml.parsers.FactoryConfigurationError

getNodeList

public static org.w3c.dom.NodeList getNodeList(java.lang.String _sVal)
                                        throws java.lang.Exception
抛出：
java.lang.Exception

getDocContentString

public static java.lang.String getDocContentString()
                                            throws javax.xml.parsers.ParserConfigurationException,
                                                   javax.xml.parsers.FactoryConfigurationError
抛出：
javax.xml.parsers.ParserConfigurationException
javax.xml.parsers.FactoryConfigurationError
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteLCListenerForAutoDocBak

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 WebSiteLCListenerForAutoDocBak

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.WebSiteLCListenerForAutoDocBak
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class WebSiteLCListenerForAutoDocBak
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WebSiteLCListenerForAutoDocBak()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteLCListenerForAutoDocBak

public WebSiteLCListenerForAutoDocBak()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteLCListenerForContentLink

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 WebSiteLCListenerForContentLink

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.WebSiteLCListenerForContentLink
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class WebSiteLCListenerForContentLink
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WebSiteLCListenerForContentLink()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteLCListenerForContentLink

public WebSiteLCListenerForContentLink()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteLCListenerForSiteUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 WebSiteLCListenerForSiteUser

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.WebSiteLCListenerForSiteUser
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class WebSiteLCListenerForSiteUser
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
站点用户/用户组监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WebSiteLCListenerForSiteUser()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteLCListenerForSiteUser

public WebSiteLCListenerForSiteUser()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlToDocumentConverter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain
类 XmlToDocumentConverter

java.lang.Object
    继承者  com.trs.infra.persistent.AbstractXmlToObjConverter
        继承者  com.trs.components.wcm.content.domain.XmlToDocumentConverter

public final class XmlToDocumentConverter
extends AbstractXmlToObjConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
Xml-->Document(WCM)对象的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
 java.util.HashMap Doc_ChannelName
构造方法摘要
XmlToDocumentConverter(int _nImportType)
方法摘要
从类 com.trs.infra.persistent.AbstractXmlToObjConverter 继承的方法
convertXml, getXmlEncoding, registPersistentObj, setXmlEncoding
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

Doc_ChannelName

public java.util.HashMap Doc_ChannelName
构造方法详细信息

XmlToDocumentConverter

public XmlToDocumentConverter(int _nImportType)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChannelRightHostImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.auth
类 ChannelRightHostImpl

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase
        继承者  com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl
所有已实现的接口：
IRightHost, ICMSObjSubstanceContent
public class ChannelRightHostImpl
extends ChannelSubstanceImplBase
implements IRightHost

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelRightHostImpl()
ChannelRightHostImpl(CMSObj _cmsObj)
ChannelRightHostImpl(int _nId)
方法摘要
IRightHost[] | getChildren() 获取当前对象的一级子对象
IRightHost | getParent() 获取父对象
java.lang.String[] | getRightTypeIds() 获取可以在这类对象上支持的权限类别Id
java.lang.String[] | getRightTypeNames() 获取可以在这类对象上支持的权限类别名称
void | validateCanDoSetRight(User _user) 判断指定的用户是否有权给当前对象设置权限
从类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 继承的方法
equals, getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

构造方法详细信息

ChannelRightHostImpl

public ChannelRightHostImpl()

ChannelRightHostImpl

public ChannelRightHostImpl(int _nId)
                     throws WCMException
参数：
_nId -
抛出：
WCMException

ChannelRightHostImpl

public ChannelRightHostImpl(CMSObj _cmsObj)
参数：
_cmsObj -
方法详细信息

validateCanDoSetRight

public void validateCanDoSetRight(User _user)
                           throws WCMException
从接口 IRightHost 复制的描述
判断指定的用户是否有权给当前对象设置权限

指定者：
接口 IRightHost 中的 validateCanDoSetRight
参数：
_user - 指定的User
抛出：
WCMException

getChildren

public IRightHost[] getChildren()
                         throws WCMException
从接口 IRightHost 复制的描述
获取当前对象的一级子对象

指定者：
接口 IRightHost 中的 getChildren
返回：
抛出：
WCMException

getRightTypeIds

public java.lang.String[] getRightTypeIds()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别Id

指定者：
接口 IRightHost 中的 getRightTypeIds
返回：

getRightTypeNames

public java.lang.String[] getRightTypeNames()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别名称

指定者：
接口 IRightHost 中的 getRightTypeNames
返回：

getParent

public IRightHost getParent()
                     throws WCMException
从接口 IRightHost 复制的描述
获取父对象

指定者：
接口 IRightHost 中的 getParent
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentAuthServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.auth
类 DocumentAuthServer

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.auth.DocumentAuthServer

public class DocumentAuthServer
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文档权限判断对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int[] INDEXES_OWNER_HAS
构造方法摘要
DocumentAuthServer()
方法摘要
static java.lang.String | formatLogicRightValue(User _loginUser, Document _currDocument, java.lang.String _sLogicValue)
static boolean | hasFlowDocRight(User _currUser, Document _document, int _nRightIndex)
static boolean | hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Document _document, int _nRightIndex) 判断指定用户在指定频道中对于指定的文档是否具有指定的权限
static boolean | hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Documents _documents, int _nRightIndex)
static boolean | hasRight(User _loginUser, ChnlDoc _chnlDoc, int _nRightIndex)
static boolean | isDefineRightOnDocument(Document _document) 判断当前文档是否自定义了权限
static boolean | isDefineRightOnDocument(int _nDocId)
static boolean | isRightIndexDefineOnChannel(int _nRightIndex, Channel _currChannel) 判断指定的权限值是否是从当前所属频道进行判断的权限
static java.lang.String | makeLogicRightValue(User _loginUser, Channel _currChannel, Document _currDocument) 构造用户对于指定栏目的指定文档的权限值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

INDEXES_OWNER_HAS

public static int[] INDEXES_OWNER_HAS
构造方法详细信息

DocumentAuthServer

public DocumentAuthServer()
方法详细信息

hasRight

public static boolean hasRight(User _loginUser,
                               ChnlDoc _chnlDoc,
                               int _nRightIndex)
                        throws WCMException
抛出：
WCMException

hasRight

public static boolean hasRight(User _loginUser,
                               BaseChannel _oSiteOrChannel,
                               Document _document,
                               int _nRightIndex)
                        throws WCMException
判断指定用户在指定频道中对于指定的文档是否具有指定的权限

参数：
_loginUser -
_oSiteOrChannel -
_document -
_nRightIndex -
返回：
抛出：
WCMException

hasRight

public static boolean hasRight(User _loginUser,
                               BaseChannel _oSiteOrChannel,
                               Documents _documents,
                               int _nRightIndex)
                        throws WCMException
参数：
_loginUser -
_oSiteOrChannel -
_document -
_nRightIndex -
返回：
抛出：
WCMException

makeLogicRightValue

public static java.lang.String makeLogicRightValue(User _loginUser,
                                                   Channel _currChannel,
                                                   Document _currDocument)
                                            throws WCMException
构造用户对于指定栏目的指定文档的权限值

参数：
_loginUser - 指定用户
_currChannel - 指定栏目
_currDocument - 指定文档
返回：
抛出：
WCMException

formatLogicRightValue

public static java.lang.String formatLogicRightValue(User _loginUser,
                                                     Document _currDocument,
                                                     java.lang.String _sLogicValue)
参数：
_loginUser -
_currDocument -
_sLogicValue -
返回：

hasFlowDocRight

public static boolean hasFlowDocRight(User _currUser,
                                      Document _document,
                                      int _nRightIndex)
                               throws WCMException
参数：
_currUser -
抛出：
WCMException

isRightIndexDefineOnChannel

public static boolean isRightIndexDefineOnChannel(int _nRightIndex,
                                                  Channel _currChannel)
判断指定的权限值是否是从当前所属频道进行判断的权限

参数：
_nRightIndex - 当前的权限索引
返回：

isDefineRightOnDocument

public static boolean isDefineRightOnDocument(Document _document)
                                       throws WCMException
判断当前文档是否自定义了权限

参数：
_nDocId -
返回：
抛出：
WCMException

isDefineRightOnDocument

public static boolean isDefineRightOnDocument(int _nDocId)
                                       throws WCMException
参数：
_nDocId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentRightHostImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.auth
类 DocumentRightHostImpl

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase
        继承者  com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl
所有已实现的接口：
IRightHost, ICMSObjSubstanceContent
public class DocumentRightHostImpl
extends DocumentSubstanceImplBase
implements IRightHost

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentRightHostImpl()
DocumentRightHostImpl(CMSObj _cmsObj)
DocumentRightHostImpl(int _nId)
方法摘要
IRightHost[] | getChildren() 获取当前对象的一级子对象
IRightHost | getParent() 获取父对象
java.lang.String[] | getRightTypeIds() 获取可以在这类对象上支持的权限类别Id
java.lang.String[] | getRightTypeNames() 获取可以在这类对象上支持的权限类别名称
void | validateCanDoSetRight(User _user) 判断指定的用户是否有权给当前对象设置权限
从类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 继承的方法
equals, getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

构造方法详细信息

DocumentRightHostImpl

public DocumentRightHostImpl()

DocumentRightHostImpl

public DocumentRightHostImpl(int _nId)
                      throws WCMException
参数：
_nId -
抛出：
WCMException

DocumentRightHostImpl

public DocumentRightHostImpl(CMSObj _cmsObj)
参数：
_cmsObj -
方法详细信息

validateCanDoSetRight

public void validateCanDoSetRight(User _user)
                           throws WCMException
从接口 IRightHost 复制的描述
判断指定的用户是否有权给当前对象设置权限

指定者：
接口 IRightHost 中的 validateCanDoSetRight
参数：
_user - 指定的User
抛出：
WCMException

getChildren

public IRightHost[] getChildren()
从接口 IRightHost 复制的描述
获取当前对象的一级子对象

指定者：
接口 IRightHost 中的 getChildren
返回：

getRightTypeIds

public java.lang.String[] getRightTypeIds()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别Id

指定者：
接口 IRightHost 中的 getRightTypeIds
返回：

getRightTypeNames

public java.lang.String[] getRightTypeNames()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别名称

指定者：
接口 IRightHost 中的 getRightTypeNames
返回：

getParent

public IRightHost getParent()
                     throws WCMException
从接口 IRightHost 复制的描述
获取父对象

指定者：
接口 IRightHost 中的 getParent
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.content.domain.auth
类
ChannelRightHostImpl
DocumentAuthServer
DocumentRightHostImpl
WebSiteRightHostImpl


com.trs.components.wcm.content.domain.auth

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.content.domain.auth

类摘要
ChannelRightHostImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentAuthServer | Title: TRS 内容协作平台（TRS WCM） Description: 文档权限判断对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentRightHostImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteRightHostImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm.content.domain.auth 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.domain.auth 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)
      • com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.components.wcm.content.domain.auth.DocumentAuthServer
    • com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)
      • com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl (implements com.trs.cms.auth.domain.IRightHost)
    • com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)
      • com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl (implements com.trs.cms.auth.domain.IRightHost)


软件包 com.trs.components.wcm.content.domain.auth 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.domain.auth
的使用

没有 com.trs.components.wcm.content.domain.auth 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WebSiteRightHostImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.auth
类 WebSiteRightHostImpl

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase
        继承者  com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl
所有已实现的接口：
IRightHost, ICMSObjSubstanceContent
public class WebSiteRightHostImpl
extends WebSiteSubstanceImplBase
implements IRightHost

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WebSiteRightHostImpl()
WebSiteRightHostImpl(CMSObj _cmsObj)
WebSiteRightHostImpl(int _nId)
方法摘要
IRightHost[] | getChildren() 获取当前对象的一级子对象
IRightHost | getParent() 获取父对象
java.lang.String[] | getRightTypeIds() 获取可以在这类对象上支持的权限类别Id
java.lang.String[] | getRightTypeNames() 获取可以在这类对象上支持的权限类别名称
void | validateCanDoSetRight(User _user) 判断指定的用户是否有权给当前对象设置权限
从类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 继承的方法
equals, getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.cms.content.ICMSObjSubstanceContent 继承的方法
getId, getInfo, getSubstance, getType, loadById, makeFrom, setSubstance

构造方法详细信息

WebSiteRightHostImpl

public WebSiteRightHostImpl()

WebSiteRightHostImpl

public WebSiteRightHostImpl(int _nId)
                     throws WCMException
参数：
_nId -
抛出：
WCMException

WebSiteRightHostImpl

public WebSiteRightHostImpl(CMSObj _cmsObj)
参数：
_cmsObj -
方法详细信息

validateCanDoSetRight

public void validateCanDoSetRight(User _user)
                           throws WCMException
从接口 IRightHost 复制的描述
判断指定的用户是否有权给当前对象设置权限

指定者：
接口 IRightHost 中的 validateCanDoSetRight
参数：
_user - 指定的User
抛出：
WCMException

getChildren

public IRightHost[] getChildren()
                         throws WCMException
从接口 IRightHost 复制的描述
获取当前对象的一级子对象

指定者：
接口 IRightHost 中的 getChildren
返回：
抛出：
WCMException

getRightTypeIds

public java.lang.String[] getRightTypeIds()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别Id

指定者：
接口 IRightHost 中的 getRightTypeIds
返回：

getRightTypeNames

public java.lang.String[] getRightTypeNames()
从接口 IRightHost 复制的描述
获取可以在这类对象上支持的权限类别名称

指定者：
接口 IRightHost 中的 getRightTypeNames
返回：

getParent

public IRightHost getParent()
从接口 IRightHost 复制的描述
获取父对象

指定者：
接口 IRightHost 中的 getParent
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl
的使用

没有 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer
的使用

没有 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl
的使用

没有 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl
的使用

没有 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ApdHostLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ApdHostLCListener
的使用

没有 com.trs.components.wcm.content.domain.ApdHostLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.AppendixMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.AppendixMgr
的使用

使用 AppendixMgr 的软件包
com.trs.service.impl

com.trs.service.impl 中 AppendixMgr 的使用

声明为 AppendixMgr 的 com.trs.service.impl 中的字段
 AppendixMgr DocumentService.m_oAppendixMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.AutoDocBakMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.AutoDocBakMgr
的使用

没有 com.trs.components.wcm.content.domain.AutoDocBakMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.AutoTransmitMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.AutoTransmitMgr
的使用

没有 com.trs.components.wcm.content.domain.AutoTransmitMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.BaseChannelLCListener4ExtField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.BaseChannelLCListener4ExtField
的使用

没有 com.trs.components.wcm.content.domain.BaseChannelLCListener4ExtField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.BaseChannelLCListener4Region 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.BaseChannelLCListener4Region
的使用

没有 com.trs.components.wcm.content.domain.BaseChannelLCListener4Region 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChannelExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChannelExporter
的使用

没有 com.trs.components.wcm.content.domain.ChannelExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChannelImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChannelImporter
的使用

没有 com.trs.components.wcm.content.domain.ChannelImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChannelLCListenerForChannelSyn 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChannelLCListenerForChannelSyn
的使用

没有 com.trs.components.wcm.content.domain.ChannelLCListenerForChannelSyn 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChannelLCListenerForDocument 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChannelLCListenerForDocument
的使用

没有 com.trs.components.wcm.content.domain.ChannelLCListenerForDocument 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChannelLCListenerForExtField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChannelLCListenerForExtField
的使用

没有 com.trs.components.wcm.content.domain.ChannelLCListenerForExtField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChannelLCListenerForSpeical 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChannelLCListenerForSpeical
的使用

没有 com.trs.components.wcm.content.domain.ChannelLCListenerForSpeical 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChannelMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChannelMgr
的使用

没有 com.trs.components.wcm.content.domain.ChannelMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo
的使用

没有 com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForAutoDocBak 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForAutoDocBak
的使用

没有 com.trs.components.wcm.content.domain.ChnlDocLCListenerForAutoDocBak 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri
的使用

没有 com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity
的使用

没有 com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ChnlSynWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ChnlSynWorker
的使用

没有 com.trs.components.wcm.content.domain.ChnlSynWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ContentExtFieldCListenerForDocProps 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ContentExtFieldCListenerForDocProps
的使用

没有 com.trs.components.wcm.content.domain.ContentExtFieldCListenerForDocProps 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ContentExtFieldLCListenerForDocFields 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ContentExtFieldLCListenerForDocFields
的使用

没有 com.trs.components.wcm.content.domain.ContentExtFieldLCListenerForDocFields 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ContentExtFieldMgr
的使用

没有 com.trs.components.wcm.content.domain.ContentExtFieldMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ContentLinkMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ContentLinkMgr
的使用

没有 com.trs.components.wcm.content.domain.ContentLinkMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper
的使用

没有 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocBakLCListenerForApd 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocBakLCListenerForApd
的使用

没有 com.trs.components.wcm.content.domain.DocBakLCListenerForApd 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocBakMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocBakMgr
的使用

没有 com.trs.components.wcm.content.domain.DocBakMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl
的使用

没有 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocPriDisableWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocPriDisableWorker
的使用

没有 com.trs.components.wcm.content.domain.DocPriDisableWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocReplyMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocReplyMgr
的使用

没有 com.trs.components.wcm.content.domain.DocReplyMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentExporter
的使用

没有 com.trs.components.wcm.content.domain.DocumentExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentImporter
的使用

没有 com.trs.components.wcm.content.domain.DocumentImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentLCListenerForAutoDocBak 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentLCListenerForAutoDocBak
的使用

没有 com.trs.components.wcm.content.domain.DocumentLCListenerForAutoDocBak 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentLCListenerForDocBak 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentLCListenerForDocBak
的使用

没有 com.trs.components.wcm.content.domain.DocumentLCListenerForDocBak 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentLCListenerForDocReply 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentLCListenerForDocReply
的使用

没有 com.trs.components.wcm.content.domain.DocumentLCListenerForDocReply 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile
的使用

没有 com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword
的使用

没有 com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelation
的使用

没有 com.trs.components.wcm.content.domain.DocumentLCListenerForRelation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs
的使用

没有 com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentMgr
的使用

使用 DocumentMgr 的软件包
com.trs.service.impl

com.trs.service.impl 中 DocumentMgr 的使用

声明为 DocumentMgr 的 com.trs.service.impl 中的字段
 DocumentMgr DocumentService.m_oDocumentMgr

返回 DocumentMgr 的 com.trs.service.impl 中的方法
 DocumentMgr InfoViewDocImportService.getDocumentMgr()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentMoveListenerForDocSiteRecode 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentMoveListenerForDocSiteRecode
的使用

没有 com.trs.components.wcm.content.domain.DocumentMoveListenerForDocSiteRecode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentPriMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentPriMgr
的使用

没有 com.trs.components.wcm.content.domain.DocumentPriMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentsGetHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentsGetHelper
的使用

没有 com.trs.components.wcm.content.domain.DocumentsGetHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl
的使用

没有 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak
的使用

没有 com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.content.domain.IChannelImporterConverter 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.domain.IChannelImporterConverter
的使用

使用 IChannelImporterConverter 的软件包
com.trs.components.metadata.service.domain
com.trs.components.wcm.process.service.domain

com.trs.components.metadata.service.domain 中 IChannelImporterConverter 的使用

实现 IChannelImporterConverter 的 com.trs.components.metadata.service.domain 中的类
 class MetaViewEmplyerConverterForChannelImporter

com.trs.components.wcm.process.service.domain 中 IChannelImporterConverter 的使用

实现 IChannelImporterConverter 的 com.trs.components.wcm.process.service.domain 中的类
 class FlowConverterForWebsiteImporter

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.content.domain.IDocKeywordMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.domain.IDocKeywordMgr
的使用

使用 IDocKeywordMgr 的软件包
com.trs.components.wcm.content.domain

com.trs.components.wcm.content.domain 中 IDocKeywordMgr 的使用

实现 IDocKeywordMgr 的 com.trs.components.wcm.content.domain 中的类
 class DocKeywordMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.content.domain.IDocumentImporterConverter 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.domain.IDocumentImporterConverter
的使用

没有 com.trs.components.wcm.content.domain.IDocumentImporterConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr
的使用

使用 IDocumentsTimeRangeMgr 的软件包
com.trs.components.wcm.content.domain

com.trs.components.wcm.content.domain 中 IDocumentsTimeRangeMgr 的使用

实现 IDocumentsTimeRangeMgr 的 com.trs.components.wcm.content.domain 中的类
 class DocumentsTimeRangeMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel
的使用

没有 com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.RelationMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.RelationMgr
的使用

使用 RelationMgr 的软件包
com.trs.service.impl

com.trs.service.impl 中 RelationMgr 的使用

声明为 RelationMgr 的 com.trs.service.impl 中的字段
 RelationMgr DocumentService.m_oRelationMgr

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.ReplaceMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.ReplaceMgr
的使用

没有 com.trs.components.wcm.content.domain.ReplaceMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember
的使用

没有 com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.SiteMemberIdsMan 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.SiteMemberIdsMan
的使用

没有 com.trs.components.wcm.content.domain.SiteMemberIdsMan 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.SiteMemberLCListner 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.SiteMemberLCListner
的使用

没有 com.trs.components.wcm.content.domain.SiteMemberLCListner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.SiteMemberMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.SiteMemberMgr
的使用

没有 com.trs.components.wcm.content.domain.SiteMemberMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.UserDocumentMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.UserDocumentMgr
的使用

没有 com.trs.components.wcm.content.domain.UserDocumentMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter
的使用

没有 com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.WebSiteLCListenerForAutoDocBak 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.WebSiteLCListenerForAutoDocBak
的使用

没有 com.trs.components.wcm.content.domain.WebSiteLCListenerForAutoDocBak 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.WebSiteLCListenerForContentLink 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.WebSiteLCListenerForContentLink
的使用

没有 com.trs.components.wcm.content.domain.WebSiteLCListenerForContentLink 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.WebSiteLCListenerForSiteUser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.WebSiteLCListenerForSiteUser
的使用

没有 com.trs.components.wcm.content.domain.WebSiteLCListenerForSiteUser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.XmlToDocumentConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.XmlToDocumentConverter
的使用

没有 com.trs.components.wcm.content.domain.XmlToDocumentConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FilePathFilter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.intelligence
类 FilePathFilter

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.intelligence.FilePathFilter
所有已实现的接口：
java.io.FileFilter
public class FilePathFilter
extends java.lang.Object
implements java.io.FileFilter

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FilePathFilter()
方法摘要
 boolean accept(java.io.File pathname)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FilePathFilter

public FilePathFilter()
方法详细信息

accept

public boolean accept(java.io.File pathname)
指定者：
接口 java.io.FileFilter 中的 accept
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IIntellMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.intelligence
接口 IIntellMgr

所有已知实现类：
IntelMgrImpl
public interface IIntellMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
Reports | createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName) 从指定站点指定样式中创建新的站点
Reports | createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName, java.lang.String _sNewSiteDesc)
java.lang.String | getSiteDataFile(java.lang.String _sKind, java.lang.String _sStyle) 获取指定站点指定样式的数据文件
java.lang.String | getSiteDemoLink(java.lang.String _sKind, java.lang.String _sStyle) 获取指定站点指定样式的演示地址
java.lang.String | getSiteIntroduceContent(java.lang.String _sKind, java.lang.String _sStyle) 获取指定站点指定样式的介绍内容
java.lang.String | getSiteIntroduceImgFilePath(java.lang.String _sKind, java.lang.String _sStyle) 获取指定站点指定样式的介绍图片
java.lang.String[] | getSiteKinds() 获取所有站点类型
java.lang.String[] | getSiteStyles(java.lang.String _sKindName) 获取指定类型的所有样式

方法详细信息

getSiteKinds

java.lang.String[] getSiteKinds()
                                throws WCMException
获取所有站点类型

返回：
抛出：
WCMException - TODO

getSiteStyles

java.lang.String[] getSiteStyles(java.lang.String _sKindName)
                                 throws WCMException
获取指定类型的所有样式

参数：
_sKindName - 指定类型
返回：
指定类型的所有样式
抛出：
WCMException - TODO

getSiteIntroduceImgFilePath

java.lang.String getSiteIntroduceImgFilePath(java.lang.String _sKind,
                                             java.lang.String _sStyle)
                                             throws WCMException
获取指定站点指定样式的介绍图片

参数：
_sKind - 指定类型
_sStyle - 指定样式
返回：
图片全路径名
抛出：
WCMException

getSiteDemoLink

java.lang.String getSiteDemoLink(java.lang.String _sKind,
                                 java.lang.String _sStyle)
                                 throws WCMException
获取指定站点指定样式的演示地址

参数：
_sKind - 指定类型
_sStyle - 指定样式
返回：
指定站点指定样式的演示地址(http://...)
抛出：
WCMException

getSiteIntroduceContent

java.lang.String getSiteIntroduceContent(java.lang.String _sKind,
                                         java.lang.String _sStyle)
                                         throws WCMException
获取指定站点指定样式的介绍内容

参数：
_sKind - 指定类型
_sStyle - 指定样式
返回：
介绍内容
抛出：
WCMException

createNewSiteFrom

Reports createNewSiteFrom(java.lang.String _sKind,
                          java.lang.String _sStyle,
                          java.lang.String _sNewSiteName)
                          throws WCMException
从指定站点指定样式中创建新的站点

参数：
_sKind - 指定类型
_sStyle - 指定样式
_sNewSiteName - 新的站点名称
返回：
创建后的情况
抛出：
WCMException

createNewSiteFrom

Reports createNewSiteFrom(java.lang.String _sKind,
                          java.lang.String _sStyle,
                          java.lang.String _sNewSiteName,
                          java.lang.String _sNewSiteDesc)
                          throws WCMException
抛出：
WCMException

getSiteDataFile

java.lang.String getSiteDataFile(java.lang.String _sKind,
                                 java.lang.String _sStyle)
                                 throws WCMException
获取指定站点指定样式的数据文件

参数：
_sKind - 指定类型
_sStyle - 指定样式
返回：
数据文件的全路径名
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIntellResLocator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.intelligence
接口 IIntellResLocator

所有已知实现类：
IntellResLocatorImpl
public interface IIntellResLocator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String[] | findSiteKinds(java.lang.String _sSrcPath) 从指定的路径中获取站点的类型
java.lang.String[] | findSiteStylesOfKind(java.lang.String _sSrcPath, java.lang.String _sKindName) 从指定路径中获取指定类型的样式
java.lang.String | getSiteKindPath(java.lang.String _sSrcPath, java.lang.String _sKindName) 根据给定路径下的类型得到真实的路径
java.lang.String | getSiteKindStylePath(java.lang.String _sSrcPath, java.lang.String _sKindName, java.lang.String _sStyle) 根据给定路径下的类型和样式得到真实的路径

方法详细信息

findSiteKinds

java.lang.String[] findSiteKinds(java.lang.String _sSrcPath)
                                 throws WCMException
从指定的路径中获取站点的类型

参数：
_sSrcPath - 指定路径
返回：
类型列表
抛出：
WCMException - TODO

findSiteStylesOfKind

java.lang.String[] findSiteStylesOfKind(java.lang.String _sSrcPath,
                                        java.lang.String _sKindName)
                                        throws WCMException
从指定路径中获取指定类型的样式

参数：
_sSrcPath - 指定路径
_sKindName - 类型名称
返回：
样式类别
抛出：
WCMException - TODO

getSiteKindPath

java.lang.String getSiteKindPath(java.lang.String _sSrcPath,
                                 java.lang.String _sKindName)
                                 throws WCMException
根据给定路径下的类型得到真实的路径

参数：
_sSrcPath -
_sKindName -
_sStyle -
返回：
抛出：
WCMException

getSiteKindStylePath

java.lang.String getSiteKindStylePath(java.lang.String _sSrcPath,
                                      java.lang.String _sKindName,
                                      java.lang.String _sStyle)
                                      throws WCMException
根据给定路径下的类型和样式得到真实的路径

参数：
_sSrcPath -
_sKindName -
_sStyle -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IntellResLocatorImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.intelligence
类 IntellResLocatorImpl

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl
所有已实现的接口：
IIntellResLocator
public class IntellResLocatorImpl
extends java.lang.Object
implements IIntellResLocator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
IntellResLocatorImpl()
方法摘要
java.lang.String[] | findSiteKinds(java.lang.String _sSrcPath) 从指定的路径中获取站点的类型
java.lang.String[] | findSiteStylesOfKind(java.lang.String _sSrcPath, java.lang.String _sKindName) 从指定路径中获取指定类型的样式
java.lang.String | getSiteKindPath(java.lang.String _sSrcPath, java.lang.String _sKindName) 根据给定路径下的类型得到真实的路径
java.lang.String | getSiteKindStylePath(java.lang.String _sSrcPath, java.lang.String _sKindName, java.lang.String _sStyle) 根据给定路径下的类型和样式得到真实的路径
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IntellResLocatorImpl

public IntellResLocatorImpl()
方法详细信息

findSiteKinds

public java.lang.String[] findSiteKinds(java.lang.String _sSrcPath)
                                 throws WCMException
从接口 IIntellResLocator 复制的描述
从指定的路径中获取站点的类型

指定者：
接口 IIntellResLocator 中的 findSiteKinds
参数：
_sSrcPath - 指定路径
返回：
类型列表
抛出：
WCMException - TODO

findSiteStylesOfKind

public java.lang.String[] findSiteStylesOfKind(java.lang.String _sSrcPath,
                                               java.lang.String _sKindName)
                                        throws WCMException
从接口 IIntellResLocator 复制的描述
从指定路径中获取指定类型的样式

指定者：
接口 IIntellResLocator 中的 findSiteStylesOfKind
参数：
_sSrcPath - 指定路径
_sKindName - 类型名称
返回：
样式类别
抛出：
WCMException - TODO

getSiteKindPath

public java.lang.String getSiteKindPath(java.lang.String _sSrcPath,
                                        java.lang.String _sKindName)
                                 throws WCMException
从接口 IIntellResLocator 复制的描述
根据给定路径下的类型得到真实的路径

指定者：
接口 IIntellResLocator 中的 getSiteKindPath
返回：
抛出：
WCMException

getSiteKindStylePath

public java.lang.String getSiteKindStylePath(java.lang.String _sSrcPath,
                                             java.lang.String _sKindName,
                                             java.lang.String _sStyle)
                                      throws WCMException
从接口 IIntellResLocator 复制的描述
根据给定路径下的类型和样式得到真实的路径

指定者：
接口 IIntellResLocator 中的 getSiteKindStylePath
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IntelMgrImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.domain.intelligence
类 IntelMgrImpl

java.lang.Object
    继承者  com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl
所有已实现的接口：
IIntellMgr
public class IntelMgrImpl
extends java.lang.Object
implements IIntellMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
IntelMgrImpl()
方法摘要
Reports | createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName) 从指定站点指定样式中创建新的站点
Reports | createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName, java.lang.String _sSiteDesc)
java.lang.String | getSiteDataFile(java.lang.String _sKind, java.lang.String _sStyle) 获取指定站点指定样式的数据文件
java.lang.String | getSiteDemoLink(java.lang.String _sKind, java.lang.String _sStyle) 获取指定站点指定样式的演示地址
java.lang.String | getSiteIntroduceContent(java.lang.String _sKind, java.lang.String _sStyle) 获取指定站点指定样式的介绍内容
java.lang.String | getSiteIntroduceImgFilePath(java.lang.String _sKind, java.lang.String _sStyle) 获取指定站点指定样式的介绍图片
java.lang.String[] | getSiteKinds() 获取所有站点类型
java.lang.String[] | getSiteStyles(java.lang.String _sKindName) 获取指定类型的所有样式
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IntelMgrImpl

public IntelMgrImpl()
方法详细信息

getSiteIntroduceImgFilePath

public java.lang.String getSiteIntroduceImgFilePath(java.lang.String _sKind,
                                                    java.lang.String _sStyle)
从接口 IIntellMgr 复制的描述
获取指定站点指定样式的介绍图片

指定者：
接口 IIntellMgr 中的 getSiteIntroduceImgFilePath
参数：
_sKind - 指定类型
_sStyle - 指定样式
返回：
图片全路径名

getSiteIntroduceContent

public java.lang.String getSiteIntroduceContent(java.lang.String _sKind,
                                                java.lang.String _sStyle)
                                         throws WCMException
从接口 IIntellMgr 复制的描述
获取指定站点指定样式的介绍内容

指定者：
接口 IIntellMgr 中的 getSiteIntroduceContent
参数：
_sKind - 指定类型
_sStyle - 指定样式
返回：
介绍内容
抛出：
WCMException

createNewSiteFrom

public Reports createNewSiteFrom(java.lang.String _sKind,
                                 java.lang.String _sStyle,
                                 java.lang.String _sNewSiteName)
                          throws WCMException
从接口 IIntellMgr 复制的描述
从指定站点指定样式中创建新的站点

指定者：
接口 IIntellMgr 中的 createNewSiteFrom
参数：
_sKind - 指定类型
_sStyle - 指定样式
_sNewSiteName - 新的站点名称
返回：
创建后的情况
抛出：
WCMException

createNewSiteFrom

public Reports createNewSiteFrom(java.lang.String _sKind,
                                 java.lang.String _sStyle,
                                 java.lang.String _sNewSiteName,
                                 java.lang.String _sSiteDesc)
                          throws WCMException
指定者：
接口 IIntellMgr 中的 createNewSiteFrom
抛出：
WCMException

getSiteKinds

public java.lang.String[] getSiteKinds()
                                throws WCMException
从接口 IIntellMgr 复制的描述
获取所有站点类型

指定者：
接口 IIntellMgr 中的 getSiteKinds
返回：
抛出：
WCMException - TODO

getSiteStyles

public java.lang.String[] getSiteStyles(java.lang.String _sKindName)
                                 throws WCMException
从接口 IIntellMgr 复制的描述
获取指定类型的所有样式

指定者：
接口 IIntellMgr 中的 getSiteStyles
参数：
_sKindName - 指定类型
返回：
指定类型的所有样式
抛出：
WCMException - TODO

getSiteDemoLink

public java.lang.String getSiteDemoLink(java.lang.String _sKind,
                                        java.lang.String _sStyle)
                                 throws WCMException
从接口 IIntellMgr 复制的描述
获取指定站点指定样式的演示地址

指定者：
接口 IIntellMgr 中的 getSiteDemoLink
参数：
_sKind - 指定类型
_sStyle - 指定样式
返回：
指定站点指定样式的演示地址(http://...)
抛出：
WCMException

getSiteDataFile

public java.lang.String getSiteDataFile(java.lang.String _sKind,
                                        java.lang.String _sStyle)
                                 throws WCMException
从接口 IIntellMgr 复制的描述
获取指定站点指定样式的数据文件

指定者：
接口 IIntellMgr 中的 getSiteDataFile
参数：
_sKind - 指定类型
_sStyle - 指定样式
返回：
数据文件的全路径名
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.content.domain.intelligence
接口
IIntellMgr
IIntellResLocator
类
FilePathFilter
IntellResLocatorImpl
IntelMgrImpl


com.trs.components.wcm.content.domain.intelligence

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.content.domain.intelligence

接口摘要
IIntellMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IIntellResLocator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
FilePathFilter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IntellResLocatorImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IntelMgrImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm.content.domain.intelligence 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.domain.intelligence 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.content.domain.intelligence.FilePathFilter (implements java.io.FileFilter)
    • com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl (implements com.trs.components.wcm.content.domain.intelligence.IIntellResLocator)
    • com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl (implements com.trs.components.wcm.content.domain.intelligence.IIntellMgr)

接口分层结构

  • com.trs.components.wcm.content.domain.intelligence.IIntellMgr
  • com.trs.components.wcm.content.domain.intelligence.IIntellResLocator


软件包 com.trs.components.wcm.content.domain.intelligence 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.domain.intelligence
的使用

使用 com.trs.components.wcm.content.domain.intelligence 的软件包
com.trs.components.wcm.content.domain.intelligence

com.trs.components.wcm.content.domain.intelligence 使用的 com.trs.components.wcm.content.domain.intelligence 中的类
IIntellMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IIntellResLocator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.intelligence.FilePathFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.intelligence.FilePathFilter
的使用

没有 com.trs.components.wcm.content.domain.intelligence.FilePathFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr
的使用

使用 IIntellMgr 的软件包
com.trs.components.wcm.content.domain.intelligence

com.trs.components.wcm.content.domain.intelligence 中 IIntellMgr 的使用

实现 IIntellMgr 的 com.trs.components.wcm.content.domain.intelligence 中的类
 class IntelMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.content.domain.intelligence.IIntellResLocator 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.domain.intelligence.IIntellResLocator
的使用

使用 IIntellResLocator 的软件包
com.trs.components.wcm.content.domain.intelligence

com.trs.components.wcm.content.domain.intelligence 中 IIntellResLocator 的使用

实现 IIntellResLocator 的 com.trs.components.wcm.content.domain.intelligence 中的类
 class IntellResLocatorImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl
的使用

没有 com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl
的使用

没有 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Appendix

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Appendix

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.Appendix
所有已实现的接口：
java.lang.Cloneable
public class Appendix
extends CMSObj

字段摘要
static int | APPENDIX_FLAG_ALL
static int | APPENDIX_FLAG_DOCAPD
static int | APPENDIX_FLAG_DOCCON
static int | APPENDIX_FLAG_DOCPIC
static int | APPENDIX_FLAG_HTMLPIC
static int | APPENDIX_FLAG_LINK
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | FLAG_ALL 附件类型标识：所有类型的附件
static int | FLAG_ALL_APD 附件类型标识：文档所有附件
static int | FLAG_DOCAPD 附件类型标识：文档附件
static int | FLAG_DOCCON 附件类型标识：正文附件
static int | FLAG_DOCPIC 附件类型标识：文档图片
static int | FLAG_HTMLPIC 附件类型标识：HTML
static int | FLAG_LINK 附件类型标识：链接附件
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
Appendix()
方法摘要
BaseObj | cloneToNewWCMObj() 由对象复制成一个新对象
static Appendix | createNewInstance() 产生当前对象[Appendix]的实例
int | delete(User _currUser) 从数据中删除对象信息
static Appendix | findById(int _nId) 提取指定ID的对象
static Appendix | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAlt() 获取附件显示的ALT
int | getApdProperty() 获取附件的属性
java.lang.String | getAttribute() 获取附件的属性
java.lang.String | getAuthor() 获取附件的作者
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取附件描述
int | getDocId() 获取附件所属文档编号
java.lang.String | getEditor() 获取附件的修改人
java.lang.String | getFile() 获取附件文件名（不包含）
java.lang.String | getFileExt() 获取附件的源文件名后缀名
FileType | getFileType() 获取附件文档类型对象
int | getFileTypeId() 获取附件的文件所属类型
int | getFlag() 获取
java.lang.String | getFlagString() 取类型标识字符串（用于显示）
static java.lang.String | getFlagString(int _nFlag) 获取附件类型的描述
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getRelatedColumn()
int | getSerialNo() 获取序号 说明：序号由系统自动生成
java.lang.String | getSrcFile() 获取附件的源文件名
CMyDateTime | getTime() 获取附件的时间
CMyBitsValue | getUsedVersions() 获取使用该附件的文档的版本号列表
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isDeleted() 是否为被删除的附件
boolean | isNotUsed()
boolean | isUsedByVersion(int _nVersion) 判断该附件是否被指定版本使用
boolean | isValid() 检查对象数据的有效性
boolean | isValidInstance() 检测当前对象是否是一个已经存在的实例对象
boolean | setAlt(java.lang.String _alt) 设置附件显示的ALT
boolean | setApdProperty(int _nProperty) 设置附件的属性
boolean | setAttribute(java.lang.String _attribute) 设置附件的属性
boolean | setAuthor(java.lang.String _author) 设置附件的作者
boolean | setDesc(java.lang.String _desc) 设置附件描述
boolean | setDocId(int _docId) 设置附件所属文档编号
boolean | setEditor(java.lang.String _editor) 设置附件的修改人
boolean | setFile(java.lang.String _file) 设置附件文件名
boolean | setFileExt(java.lang.String _fileExt) 设置附件的源文件名后缀名
boolean | setFlag(int _flag) 设置附件类型
void | setId(int _nId) 设置对象ID
void | setNextId() Created: 2004-12-22 11:48:34 Last Modified: 2004-12-22/2004-12-22 Description: 设置对象的ID值
boolean | setPropertyWithString(java.lang.String name, java.lang.String value) 用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象
boolean | setRelatedColumn(java.lang.String _relatedColumn)
void | setSerialNo(int _nNextSerialNo)
boolean | setSrcFile(java.lang.String _srcFile) 设置附件的源文件名
boolean | setTime(CMyDateTime _time) 设置附件的时间
boolean | setUsedByVersion(int _nVersion, boolean _bUsed) 设置指定的版本是否使用此附件
boolean | setUsedVersions(long _lUsedVersions) 设置使用该附件的文档的版本号
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

FLAG_DOCCON

public static final int FLAG_DOCCON
附件类型标识：正文附件

另请参见：
常量字段值

FLAG_DOCAPD

public static final int FLAG_DOCAPD
附件类型标识：文档附件

另请参见：
常量字段值

FLAG_DOCPIC

public static final int FLAG_DOCPIC
附件类型标识：文档图片

另请参见：
常量字段值

FLAG_HTMLPIC

public static final int FLAG_HTMLPIC
附件类型标识：HTML

另请参见：
常量字段值

FLAG_LINK

public static final int FLAG_LINK
附件类型标识：链接附件

另请参见：
常量字段值

FLAG_ALL_APD

public static final int FLAG_ALL_APD
附件类型标识：文档所有附件

另请参见：
常量字段值

FLAG_ALL

public static final int FLAG_ALL
附件类型标识：所有类型的附件

另请参见：
常量字段值

APPENDIX_FLAG_DOCCON

public static final int APPENDIX_FLAG_DOCCON
另请参见：
常量字段值

APPENDIX_FLAG_DOCAPD

public static final int APPENDIX_FLAG_DOCAPD
另请参见：
常量字段值

APPENDIX_FLAG_DOCPIC

public static final int APPENDIX_FLAG_DOCPIC
另请参见：
常量字段值

APPENDIX_FLAG_HTMLPIC

public static final int APPENDIX_FLAG_HTMLPIC
另请参见：
常量字段值

APPENDIX_FLAG_LINK

public static final int APPENDIX_FLAG_LINK
另请参见：
常量字段值

APPENDIX_FLAG_ALL

public static final int APPENDIX_FLAG_ALL
另请参见：
常量字段值
构造方法详细信息

Appendix

public Appendix()
另请参见：
WCMObj.WCMObj()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

isDeleted

public boolean isDeleted()
是否为被删除的附件

返回：

getDocId

public int getDocId()
获取附件所属文档编号

返回：
附件所属文档编号

setDocId

public boolean setDocId(int _docId)
                 throws WCMException
设置附件所属文档编号

参数：
_docId - 附件所属文档编号
返回：
抛出：
WCMException

getFlag

public int getFlag()
获取

返回：

getFlagString

public java.lang.String getFlagString()
取类型标识字符串（用于显示）

返回：

getFlagString

public static java.lang.String getFlagString(int _nFlag)
获取附件类型的描述

参数：
_nFlag - 附件类型（Appendix.FLAG_DOCCON等）
返回：
类型的描述

setFlag

public boolean setFlag(int _flag)
                throws WCMException
设置附件类型

参数：
_flag - 附件类型（Appendix.FLAG_DOCCON等）
返回：
抛出：
WCMException

setId

public void setId(int _nId)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId

setNextId

public void setNextId()
               throws WCMException
从类 BaseObj 复制的描述
Created: 2004-12-22 11:48:34 Last Modified: 2004-12-22/2004-12-22 Description: 设置对象的ID值

覆盖：
类 BaseObj 中的 setNextId
抛出：
WCMException

getFileTypeId

public int getFileTypeId()
获取附件的文件所属类型

返回：
附件的文件所属类型

getFileType

public FileType getFileType()
                     throws WCMException
获取附件文档类型对象

返回：
附件文档类型对象（FileType）
抛出：
WCMException

getFile

public java.lang.String getFile()
获取附件文件名（不包含）

返回：
附件文件名

setFile

public boolean setFile(java.lang.String _file)
                throws WCMException
设置附件文件名

参数：
_file - 附件文件名
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取附件描述

返回：
附件描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置附件描述

参数：
_desc - 附件描述
返回：
抛出：
WCMException

getAlt

public java.lang.String getAlt()
获取附件显示的ALT

返回：
附件显示的ALT

setAlt

public boolean setAlt(java.lang.String _alt)
               throws WCMException
设置附件显示的ALT

参数：
_alt - 附件显示的ALT
返回：
抛出：
WCMException

getApdProperty

public int getApdProperty()
获取附件的属性

返回：
附件的属性

setApdProperty

public boolean setApdProperty(int _nProperty)
                       throws WCMException
设置附件的属性

参数：
_nProperty - 附件的属性
返回：
抛出：
WCMException

getTime

public CMyDateTime getTime()
获取附件的时间

返回：
附件的时间

setTime

public boolean setTime(CMyDateTime _time)
                throws WCMException
设置附件的时间

参数：
_time - 附件的时间
返回：
抛出：
WCMException

getEditor

public java.lang.String getEditor()
获取附件的修改人

返回：
附件的修改人

setEditor

public boolean setEditor(java.lang.String _editor)
                  throws WCMException
设置附件的修改人

参数：
_editor - 附件的修改人
返回：
抛出：
WCMException

getAuthor

public java.lang.String getAuthor()
获取附件的作者

返回：
附件的作者

setAuthor

public boolean setAuthor(java.lang.String _author)
                  throws WCMException
设置附件的作者

参数：
_author - 附件的作者
返回：
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
获取附件的属性

覆盖：
类 BaseObj 中的 getAttribute
返回：
附件的属性

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
设置附件的属性

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute -
返回：
抛出：
WCMException

getSrcFile

public java.lang.String getSrcFile()
获取附件的源文件名

返回：
附件的源文件名

setSrcFile

public boolean setSrcFile(java.lang.String _srcFile)
                   throws WCMException
设置附件的源文件名

参数：
_srcFile - 附件的源文件名
返回：
抛出：
WCMException

getFileExt

public java.lang.String getFileExt()
获取附件的源文件名后缀名

返回：
附件的源文件名后缀名

setFileExt

public boolean setFileExt(java.lang.String _fileExt)
                   throws WCMException
设置附件的源文件名后缀名

参数：
_fileExt - 附件的源文件名后缀名
返回：
抛出：
WCMException

getSerialNo

public int getSerialNo()
获取序号 说明：序号由系统自动生成

返回：

setSerialNo

public void setSerialNo(int _nNextSerialNo)
                 throws WCMException
抛出：
WCMException

getUsedVersions

public CMyBitsValue getUsedVersions()
获取使用该附件的文档的版本号列表

返回：
使用该附件的文档的版本号列表

setUsedVersions

public boolean setUsedVersions(long _lUsedVersions)
                        throws WCMException
设置使用该附件的文档的版本号

参数：
_lUsedVersions - 使用该附件的文档的版本号列表
返回：
抛出：
WCMException

isUsedByVersion

public boolean isUsedByVersion(int _nVersion)
判断该附件是否被指定版本使用

参数：
_nVersion - 版本号
返回：

isNotUsed

public boolean isNotUsed()
返回：

setUsedByVersion

public boolean setUsedByVersion(int _nVersion,
                                boolean _bUsed)
                         throws WCMException
设置指定的版本是否使用此附件

参数：
_nVersion - 版本号
_bUsed - 是否使用
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 新增模式没有设置文档ID

delete

public int delete(User _currUser)
           throws WCMException
从类 CMSObj 复制的描述
从数据中删除对象信息

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException
另请参见：
WCMObj.delete(User _currUser)

cloneToNewWCMObj

public BaseObj cloneToNewWCMObj()
                         throws WCMException
由对象复制成一个新对象

覆盖：
类 BaseObj 中的 cloneToNewWCMObj
返回：
返回Object对象
抛出：
WCMException

findById

public static final Appendix findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Appendix createNewInstance()
                                        throws WCMException
产生当前对象[Appendix]的实例

返回：
当前对象的实例[Appendix]
抛出：
WCMException

findByKey

public static final Appendix findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

setPropertyWithString

public boolean setPropertyWithString(java.lang.String name,
                                     java.lang.String value)
                              throws WCMException
从类 BaseObj 复制的描述
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象

覆盖：
类 BaseObj 中的 setPropertyWithString
参数：
name - 属性名
value - 属性值
返回：
抛出：
WCMException

setRelatedColumn

public boolean setRelatedColumn(java.lang.String _relatedColumn)
                         throws WCMException
参数：
_relatedColumn -
返回：
抛出：
WCMException

getRelatedColumn

public java.lang.String getRelatedColumn()

isValidInstance

public boolean isValidInstance()
检测当前对象是否是一个已经存在的实例对象

覆盖：
类 BaseObj 中的 isValidInstance
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Appendixes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Appendixes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.Appendixes

public class Appendixes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Appendixes(User _currUser)
Appendixes(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static Appendixes | createNewInstance(User _currUser) 产生一个当前集合对象[Appendixes]的实例
static Appendixes | findAppendixesByObj(BaseObj _currObj) 获得文档所属附件集合 该接口应该是获得对象所属附件集合，由于Appendix对象目前只和Document对象耦合，所以先暂时这样使用 以后扩展应该也比较方便，增加一个对象类型ID即可
static Appendixes | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Appendixes | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Appendixes]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Appendixes

public Appendixes(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

Appendixes

public Appendixes(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int _initCapacity, int _incCapacity )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final Appendixes findByIds(User _currUser,
                                         java.lang.String _sIds)
                                  throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Appendixes openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[Appendixes]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[Appendixes]
抛出：
WCMException

createNewInstance

public static Appendixes createNewInstance(User _currUser)
                                    throws WCMException
产生一个当前集合对象[Appendixes]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

findAppendixesByObj

public static Appendixes findAppendixesByObj(BaseObj _currObj)
                                      throws WCMException
获得文档所属附件集合
该接口应该是获得对象所属附件集合，由于Appendix对象目前只和Document对象耦合，所以先暂时这样使用
以后扩展应该也比较方便，增加一个对象类型ID即可

参数：
_currObj - 欲查询的主对象
返回：
对象所属附件的集合
抛出：
WCMException - 使用OpenObjs方法打开集合时可能的异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AutoBakConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 AutoBakConfig

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.AutoBakConfig
所有已实现的接口：
java.lang.Cloneable
public class AutoBakConfig
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
static int | OPER_DOC_EDIT 文档修改操作
static int | OPER_DOC_PUB 文档发布操作
static int | OPER_DOCSTATUS_CHANGE 文档状态修改操作
构造方法摘要
AutoBakConfig()
构造函数：保留默认接口
方法摘要
static AutoBakConfig | createNewInstance() 产生当前对象[AutoBakConfig]的实例
static AutoBakConfig | findById(int _nId) 提取指定ID的对象
static AutoBakConfig | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Statuses | getCanSavedDocStatus(User _currUser) 获取可以进行自动保存的文档状态
java.lang.String | getCanSavedDocStatusIds() 获取可以进行自动保存的文档状态ID序列
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getOperTypes() 获取触发自动保存的操作类型
WebSite | getSite() 获取站点对象
int | getSiteId() 获取站点ID
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setCanSavedDocStatus(java.lang.String _sStatusIds) 设置可以自动保存的文档状态
boolean | setOperType(java.lang.String _sOperTypes) 设置可以触发自动保存的操作类型
boolean | setSiteId(int _nSiteId) 设置站点ID
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

OPER_DOC_EDIT

public static final int OPER_DOC_EDIT
文档修改操作

另请参见：
常量字段值

OPER_DOCSTATUS_CHANGE

public static final int OPER_DOCSTATUS_CHANGE
文档状态修改操作

另请参见：
常量字段值

OPER_DOC_PUB

public static final int OPER_DOC_PUB
文档发布操作

另请参见：
常量字段值
构造方法详细信息

AutoBakConfig

public AutoBakConfig()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

getSiteId

public int getSiteId()
获取站点ID

返回：
站点ID

getSite

public WebSite getSite()
                throws WCMException
获取站点对象

返回：
站点对象
抛出：
WCMException

getOperTypes

public java.lang.String getOperTypes()
获取触发自动保存的操作类型

返回：
操作类型值

getCanSavedDocStatus

public Statuses getCanSavedDocStatus(User _currUser)
                              throws WCMException
获取可以进行自动保存的文档状态

参数：
_currUser -
返回：
文档状态集合
抛出：
WCMException

getCanSavedDocStatusIds

public java.lang.String getCanSavedDocStatusIds()
获取可以进行自动保存的文档状态ID序列

返回：
文档状态ID序列

setSiteId

public boolean setSiteId(int _nSiteId)
                  throws WCMException
设置站点ID

参数：
_nSiteId -
返回：
抛出：
WCMException

setOperType

public boolean setOperType(java.lang.String _sOperTypes)
                    throws WCMException
设置可以触发自动保存的操作类型

参数：
_sOperTypes -
返回：
抛出：
WCMException

setCanSavedDocStatus

public boolean setCanSavedDocStatus(java.lang.String _sStatusIds)
                             throws WCMException
设置可以自动保存的文档状态

参数：
_sStatusIds -
返回：
抛出：
WCMException

findById

public static final AutoBakConfig findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final AutoBakConfig createNewInstance()
                                             throws WCMException
产生当前对象[AutoBakConfig]的实例

返回：
当前对象的实例[AutoBakConfig]
抛出：
WCMException

findByKey

public static final AutoBakConfig findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AutoBakConfigs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 AutoBakConfigs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.AutoBakConfigs

public class AutoBakConfigs
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
版本自动保存配置信息集合对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
AutoBakConfigs(User _currUser)
AutoBakConfigs(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static AutoBakConfigs | createNewInstance(User _currUser) 产生当前集合对象[AutoBakConfigs]的实例
static AutoBakConfigs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static AutoBakConfigs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[AutoBakConfigs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AutoBakConfigs

public AutoBakConfigs(User _currUser)

AutoBakConfigs

public AutoBakConfigs(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final AutoBakConfigs findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（AutoBakConfigs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final AutoBakConfigs openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[AutoBakConfigs]

参数：
_filter - 指定的Filter
返回：
当前集合[AutoBakConfigs]
抛出：
WCMException

createNewInstance

public static AutoBakConfigs createNewInstance(User _currUser)
产生当前集合对象[AutoBakConfigs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 BaseChannel

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.BaseChannel
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
Channel, WebSite
public abstract class BaseChannel
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | STATUS_DEL
static int | STATUS_NORM
static int | STATUS_PARENT_DEL
static int | TYPE_ALL
构造方法摘要
BaseChannel()
方法摘要
java.util.List | getAllChildren(User _currUser)
Channel | getChildAt(int _nIndex)
java.util.List | getChildren(User _currUser)
java.util.List | getChildren(User _currUser, int _nType) 获取当前对象某种类型的子频道
java.util.List | getChildren(User _currUser, int[] _nArrayTypes) 获取当前对象某几种类型的子频道
int | getChildrenSize(User _currUser)
abstract java.lang.String | getDesc() 获取对象的描述
java.lang.String | getDispDesc() 返回频道/站点的页面显示 说明：如果Desc为空则提取Name
abstract BaseChannel | getHost() 得到当前频道的父频道，在Channel和Site中分别定义
abstract java.lang.String | getInfo() Returns the object inforamtion
abstract java.lang.String | getName() 获取对象的名称
abstract int | getOrder()
int | getParentId()
int | getSiblingIndex() 获取当前频道或站点的位置
abstract WebSite | getSite()
abstract int | getSiteId()
int | getStatus() 获取站点/频道的状态值(STATUS_NORM等)
boolean | isDeleted() 判断站点/频道是否已被删除(在回收站中)
abstract boolean | isSite() 判断当前对象是否为站点
boolean | restore(boolean _bSystemNotifyRestore) 恢复站点/频道到正常状态(STATUS_NORM)
boolean | setDeleted(boolean _bSystemNotifyDelete) 设置站点/频道为已删除状态
abstract boolean | setName(java.lang.String _sName) 设置对象的名称
boolean | setOperTime() 记录站点/频道删除(恢复)操作的执行时间
boolean | setOperUser(java.lang.String _sUserName) 记录站点/频道删除(恢复)的操作者
boolean | setOperUser(User _opUser) 记录站点/频道删除(恢复)的操作者
abstract boolean | setParent(int _nParentId)
boolean | setStatus(int _nStatus) 设置站点/频道的状态值(STATUS_NORM等)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getDbTableName, getFinalPropertyAsString, getFinalPropertyAsString, getId, getIdFieldName, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, getWCMType, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValid, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

STATUS_NORM

public static final int STATUS_NORM
另请参见：
常量字段值

STATUS_DEL

public static final int STATUS_DEL
另请参见：
常量字段值

STATUS_PARENT_DEL

public static final int STATUS_PARENT_DEL
另请参见：
常量字段值

TYPE_ALL

public static final int TYPE_ALL
另请参见：
常量字段值
构造方法详细信息

BaseChannel

public BaseChannel()
方法详细信息

isDeleted

public boolean isDeleted()
判断站点/频道是否已被删除(在回收站中)

返回：
如果已删除(状态值小于0),返回true

getStatus

public int getStatus()
获取站点/频道的状态值(STATUS_NORM等)

返回：

setStatus

public boolean setStatus(int _nStatus)
                  throws WCMException
设置站点/频道的状态值(STATUS_NORM等)

抛出：
WCMException

setDeleted

public boolean setDeleted(boolean _bSystemNotifyDelete)
                   throws WCMException
设置站点/频道为已删除状态

参数：
_bSystemNotifyDelete - 要删除的站点/频道是否是在父站点/频道被删除时,由系统触发删除的
返回：
@throws WCMException
抛出：
WCMException

restore

public boolean restore(boolean _bSystemNotifyRestore)
                throws WCMException
恢复站点/频道到正常状态(STATUS_NORM)

参数：
_bSystemNotifyRestore - 要恢复的站点/频道是否是在父站点/频道被恢复时,由系统触发删除的
返回：
@throws WCMException
抛出：
WCMException

setOperUser

public boolean setOperUser(User _opUser)
                    throws WCMException
记录站点/频道删除(恢复)的操作者

参数：
_opUser - 执行删除/恢复操作的用户
返回：
@throws WCMException
抛出：
WCMException

setOperUser

public boolean setOperUser(java.lang.String _sUserName)
                    throws WCMException
记录站点/频道删除(恢复)的操作者

参数：
_sUserName - 执行删除/恢复操作的用户名
返回：
@throws WCMException
抛出：
WCMException

setOperTime

public boolean setOperTime()
                    throws WCMException
记录站点/频道删除(恢复)操作的执行时间

返回：
@throws WCMException
抛出：
WCMException

getParentId

public int getParentId()

isSite

public abstract boolean isSite()
判断当前对象是否为站点

返回：
如果是站点返回true,频道返回false

getSite

public abstract WebSite getSite()
                         throws WCMException
抛出：
WCMException

getSiteId

public abstract int getSiteId()

getDesc

public abstract java.lang.String getDesc()
获取对象的描述

返回：

getDispDesc

public java.lang.String getDispDesc()
返回频道/站点的页面显示

说明：如果Desc为空则提取Name

返回：

getInfo

public abstract java.lang.String getInfo()
Returns the object inforamtion

返回：
the object information

getName

public abstract java.lang.String getName()
获取对象的名称

返回：

setName

public abstract boolean setName(java.lang.String _sName)
                         throws WCMException
设置对象的名称

返回：
抛出：
WCMException

setParent

public abstract boolean setParent(int _nParentId)
                           throws WCMException
抛出：
WCMException

getOrder

public abstract int getOrder()

getHost

public abstract BaseChannel getHost()
                             throws WCMException
得到当前频道的父频道，在Channel和Site中分别定义

返回：
@throws WCMException
抛出：
WCMException

getChildren

public java.util.List getChildren(User _currUser,
                                  int _nType)
                           throws WCMException
获取当前对象某种类型的子频道

参数：
_currUser - 当前操作用户
_nType - 指定的频道类型
返回：
@throws WCMException
抛出：
WCMException

getChildren

public java.util.List getChildren(User _currUser,
                                  int[] _nArrayTypes)
                           throws WCMException
获取当前对象某几种类型的子频道

参数：
_currUser - 当前操作用户
_nArrayTypes - 指定的频道类型
返回：
@throws WCMException
抛出：
WCMException

getChildren

public java.util.List getChildren(User _currUser)
                           throws WCMException
抛出：
WCMException

getAllChildren

public java.util.List getAllChildren(User _currUser)
                              throws WCMException
抛出：
WCMException

getChildAt

public Channel getChildAt(int _nIndex)
                   throws WCMException
抛出：
WCMException

getSiblingIndex

public int getSiblingIndex()
                    throws WCMException
获取当前频道或站点的位置

返回：
所处位置的索引
抛出：
WCMException

getChildrenSize

public int getChildrenSize(User _currUser)
                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Channel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Channel

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.BaseChannel
                继承者  com.trs.components.wcm.content.persistent.Channel
所有已实现的接口：
java.lang.Cloneable
public class Channel
extends BaseChannel

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static java.lang.String | DEFAULT_CONTENTADDEDITPAGE
static java.lang.String | DEFAULT_CONTENTLISTPAGE
static java.lang.String | DEFAULT_CONTENTSHOWPAGE
static java.lang.String | DEFAULT_LINKCHANNELPAGE
static int | DO_DEPT_FILTER 频道属性索引：栏目文档列表是否做所属部门的过滤
static Channel | DRAFT_CHANNEL
static int | DRAFT_CHANNEL_ID
static int | EXCLUDE_FROM_ORDER_MAX 频道类型：不参与排序的频道类型的最大值（10）
static int | MOVE_AS_BROTHER 频道移动的方式：作为目标频道的兄弟移动
static int | MOVE_AS_CHILD 频道移动的方式：作为目标频道的子节点移动
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
static int | SET_CANPUB 频道属性索引：是否能够发布(2)
static int | SET_CHNL_USER 频道属性索引：文档流转是否考虑频道上的权限(9)
static int | SET_CLICK_PREVIEW 频道属性索引：点击文档直接打开预览页面(8)
static int | SET_INHERIT_DETAIL 频道属性索引：是否继承细览模板(4)
static int | SET_INHERIT_EXTEND 频道属性索引：是否继承父对象的扩展字段(7)
static int | SET_INHERIT_OUTLINE 频道属性索引：是否继承概览模板(5)
static int | SET_INHERIT_RIGHT 频道属性索引：是否继承权限设置(6)
static int | SET_ONLYMANAGER 频道属性索引：是否仅仅用于管理(3)
static int | SET_ONLYSEARCH 频道属性索引：是否只使用检索条件检索(1)
static java.lang.String | SUREFORM_ATTR
static int | TIME_LIMITED_DEFAULT
static int | TIME_LIMITED_NOT
static int | TIME_LIMITED_SPECIAL_POINT
static int | TIME_LIMITED_SPECIAL_RANGE
static int | TYPE_DEFINE_MAX 频道类型：用户自定义类型的起始值(20)
static int | TYPE_INFOVIEW 频道类型:TRS自定义表单
static int | TYPE_LINK 频道类型:链接型频道(3)
static int | TYPE_NORM 频道类型：一般频道(0)
static int | TYPE_SUREFORM 频道类型:链接型频道(3)
static int | TYPE_TOP_NEWS 频道类型：头条新闻(2)
static int | TYPE_TOP_PICS 频道类型：图片新闻(1)
从类 com.trs.components.wcm.content.persistent.BaseChannel 继承的字段
STATUS_DEL, STATUS_NORM, STATUS_PARENT_DEL, TYPE_ALL
构造方法摘要
Channel()
构造函数：保留默认接口
方法摘要
static Channel | createNewInstance() 产生当前对象[Channel]的实例
int | delete(User _currUser) 从数据中删除对象信息
static Channel | findById(int _nId) 提取指定ID的对象
static Channel | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static Channel | findByName(int _nSiteId, java.lang.String _sChannelName)
int | getChnlProperty() 获取频道属性
java.lang.String | getContentAddEditPage()
java.lang.String | getContentListPage()
java.lang.String | getContentShowPage()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取频道描述
java.lang.String | getDetailFile() 获取频道细览文件名
java.lang.String | getEditFile() 获取编辑文件名
java.lang.String | getEndTime() 获取频道指定的结束时间 *
BaseChannel | getHost() 得到当前频道的父频道，在Channel和Site中分别定义
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getInfo() Returns the object inforamtion
java.lang.String | getInputFile() 获取输入文件名
java.lang.String | getLinkUrl() Returns the link url of this folder if its type is link.
java.lang.String | getMetaSynFields()
java.lang.String | getName() 获取频道的名称
java.lang.String | getNewSureFormFileName() 在编辑模式下，获得用户新增加的书生表单文件名称
int | getOrder() 获取频道排序序号
java.lang.String | getOrderBy() 获取频道默认的排序方式
java.lang.String | getOutlineFields() 获取该在频道概览页面需要显示的字段列表，以逗号分隔
java.lang.String | getOutlineFile() 获取频道概览文件名
Channel | getParent() 获取父频道对象
int | getParentId() 获取父频道ID
java.lang.String | getQuery() 获取频道的查询条件
Replaces | getReplaces(User _currUser) 获取频道上所有的替换内容对象
WebSite | getSite() 频道所属的站点对象
int | getSiteId() 获取频道所属的站点ID
java.lang.String | getStartTime() 获取频道指定的开始时间 *
int | getStatus() 获取频道状态（Channel.STATUS_NORM等）
java.lang.String | getSureFormFileName() 得到书生表单文件名称
java.lang.String | getTable() 获取存储频道中文档的数据表的名称
int | getTimeLimitedMode()
int | getTimeRange() 获取频道指定的时间范围 *
int | getTimeRange(boolean _bSystem) 获取频道指定的时间范围 *
java.lang.String | getTimeWhere()
int | getType() 获取频道类型(Channel.TYPE_NORM等)
java.lang.String | getTypeDesc()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isCanPub() 判断是否允许发布
boolean | isClickPreview() 判断点击文档时是否直接预览页面
boolean | isCluster()
boolean | isContainsChildren()
boolean | isDoDeptFilter() 栏目文档列表是否做所属部门的过滤
boolean | isInheritDetail() 是否继承父频道的细览模板
boolean | isInheritExtend() 是否继承父系的扩展字段
boolean | isInheritOutline() 是否继承父频道的概览模板
boolean | isInheritRight() 是否继承父系的权限
boolean | isLink() Returns true if the type of this channel is link.
boolean | isListByTimeRange()
boolean | isListByTimeRange(boolean _bSystem) 判断频道是否指定了时间约束 *
boolean | isNormType() 判断是否是普通频道
boolean | isOnlyManager() 是否只作为管理节点
boolean | isOnlySearch() 是否只使用检索条件
boolean | isSite() 判断当前对象是否为站点
boolean | isToChnlUser() 判断文档流转时是否考虑频道的权限
boolean | isValid() 对象的有效性校验
boolean | isVirtual() 判断频道是否是虚拟频道（例如头条新闻、图片新闻等）
boolean | setCanPub(boolean _bCanPub) 设置是否允许发布
boolean | setChnlProperty(int _nProperty) 设置频道属性
boolean | setClickPreview(boolean _bClickPreview) 设置点击文档时是否直接预览页面
boolean | setCluster(boolean _bCluster)
boolean | setContainsChildren(boolean _bContainsChildren)
boolean | setDesc(java.lang.String _desc) 设置频道描述
boolean | setDetailFile(java.lang.String _sFile) 设置频道细览文件名
boolean | setDoDeptFilter(boolean _bIsDoDeptFilter) 栏目文档列表是否做所属部门的过滤
boolean | setEditFile(java.lang.String _sFile) 设置编辑文件名
void | setEndTime(CMyDateTime _dtEnd) 设置频道文档列表的结束时间
boolean | setInheritDetail(boolean _bInheritDetail) 设置是否继承父频道的细览模板
boolean | setInheritExtend(boolean _bInheritExtend) 设置是否继承父系的扩展字段
boolean | setInheritOutline(boolean _bInheritOutline) 设置是否继承父频道的概览模板
boolean | setInputFile(java.lang.String _sFile) 设置输入文件名
boolean | setLinkUrl(java.lang.String _sUrl) Sets the link url of this folder.
boolean | setMetaSynFields(java.lang.String _metaSynFieldValue)
boolean | setName(java.lang.String _name) 设置频道的名称 名称要求：同一级（即相同父频道）的频道，名称不重复 处理：由函数isValid()检查，区分大小写
boolean | setOnlyManager(boolean _bOnlyManager) 设置是否只作为管理节点
boolean | setOnlySearch(boolean _bOnlySearch) 设置是否只使用检索条件
boolean | setOrder(int _order) 设置频道排序序号
boolean | setOrderBy(java.lang.String _sOrderBy) 设置频道默认的排序方式
boolean | setOutlineFields(java.lang.String _sOutlineFields) 设置取该在频道概览页面需要显示的字段列表，以逗号分隔
boolean | setOutlineFile(java.lang.String _sFile) 设置频道概览文件名
boolean | setParent(BaseChannel _parent) Sets the parent of this channel.
boolean | setParent(int _parentId) 设置父频道
boolean | setQuery(java.lang.String _query) 设置频道的查询条件
boolean | setSite(int _nSiteId) 设置所属站点：仅添加频道时可用，不允许修改该属性
boolean | setSite(WebSite _website) 设置所属站点：仅添加频道时可用，不允许修改该属性
void | setStartTime(CMyDateTime _dtStart) 设置频道文档列表的开始时间
boolean | setStatus(int _status) 设置频道状态（Channel.STATUS_NORM等）
boolean | setSureFormFile(java.lang.String _sSureFormFileName) 设置书生表单文件名称
boolean | setTable(java.lang.String _table) 设置存储频道中文档的数据表的名称
void | setTimeLimitedMode(int _nTimeLimitedMode)
void | setTimeRange(int _nTimeRange) 设置本频道提取文档的时间范围（单位：天）
boolean | setToChnlUser(boolean _bToChnlUser) 判断文档流转时是否考虑频道的权限
boolean | setType(int _type) 设置频道类型(Channel.TYPE_NORM等)
java.lang.String | toString()
void | update(User _currUser) 更新修改。
void | validLoop()
从类 com.trs.components.wcm.content.persistent.BaseChannel 继承的方法
getAllChildren, getChildAt, getChildren, getChildren, getChildren, getChildrenSize, getDispDesc, getSiblingIndex, isDeleted, restore, setDeleted, setOperTime, setOperUser, setOperUser
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

SET_ONLYSEARCH

public static final int SET_ONLYSEARCH
频道属性索引：是否只使用检索条件检索(1)

另请参见：
常量字段值

SET_CANPUB

public static final int SET_CANPUB
频道属性索引：是否能够发布(2)

另请参见：
常量字段值

SET_ONLYMANAGER

public static final int SET_ONLYMANAGER
频道属性索引：是否仅仅用于管理(3)

另请参见：
常量字段值

SET_INHERIT_DETAIL

public static final int SET_INHERIT_DETAIL
频道属性索引：是否继承细览模板(4)

另请参见：
常量字段值

SET_INHERIT_OUTLINE

public static final int SET_INHERIT_OUTLINE
频道属性索引：是否继承概览模板(5)

另请参见：
常量字段值

SET_INHERIT_RIGHT

public static final int SET_INHERIT_RIGHT
频道属性索引：是否继承权限设置(6)

另请参见：
常量字段值

SET_INHERIT_EXTEND

public static final int SET_INHERIT_EXTEND
频道属性索引：是否继承父对象的扩展字段(7)

另请参见：
常量字段值

SET_CLICK_PREVIEW

public static final int SET_CLICK_PREVIEW
频道属性索引：点击文档直接打开预览页面(8)

另请参见：
常量字段值

SET_CHNL_USER

public static final int SET_CHNL_USER
频道属性索引：文档流转是否考虑频道上的权限(9)

另请参见：
常量字段值

DO_DEPT_FILTER

public static final int DO_DEPT_FILTER
频道属性索引：栏目文档列表是否做所属部门的过滤

另请参见：
常量字段值

TYPE_NORM

public static final int TYPE_NORM
频道类型：一般频道(0)

另请参见：
常量字段值

TYPE_TOP_PICS

public static final int TYPE_TOP_PICS
频道类型：图片新闻(1)

另请参见：
常量字段值

TYPE_TOP_NEWS

public static final int TYPE_TOP_NEWS
频道类型：头条新闻(2)

另请参见：
常量字段值

TYPE_LINK

public static final int TYPE_LINK
频道类型:链接型频道(3)

另请参见：
常量字段值

TYPE_SUREFORM

public static final int TYPE_SUREFORM
频道类型:链接型频道(3)

另请参见：
常量字段值

TYPE_INFOVIEW

public static final int TYPE_INFOVIEW
频道类型:TRS自定义表单

另请参见：
常量字段值

TYPE_DEFINE_MAX

public static final int TYPE_DEFINE_MAX
频道类型：用户自定义类型的起始值(20)

另请参见：
常量字段值

EXCLUDE_FROM_ORDER_MAX

public static final int EXCLUDE_FROM_ORDER_MAX
频道类型：不参与排序的频道类型的最大值（10）

另请参见：
常量字段值

MOVE_AS_BROTHER

public static final int MOVE_AS_BROTHER
频道移动的方式：作为目标频道的兄弟移动

另请参见：
常量字段值

MOVE_AS_CHILD

public static final int MOVE_AS_CHILD
频道移动的方式：作为目标频道的子节点移动

另请参见：
常量字段值

SUREFORM_ATTR

public static final java.lang.String SUREFORM_ATTR
另请参见：
常量字段值

DEFAULT_CONTENTLISTPAGE

public static final java.lang.String DEFAULT_CONTENTLISTPAGE
另请参见：
常量字段值

DEFAULT_CONTENTADDEDITPAGE

public static final java.lang.String DEFAULT_CONTENTADDEDITPAGE
另请参见：
常量字段值

DEFAULT_CONTENTSHOWPAGE

public static final java.lang.String DEFAULT_CONTENTSHOWPAGE
另请参见：
常量字段值

DEFAULT_LINKCHANNELPAGE

public static final java.lang.String DEFAULT_LINKCHANNELPAGE
另请参见：
常量字段值

DRAFT_CHANNEL_ID

public static final int DRAFT_CHANNEL_ID
另请参见：
常量字段值

DRAFT_CHANNEL

public static final Channel DRAFT_CHANNEL

TIME_LIMITED_NOT

public static final int TIME_LIMITED_NOT
另请参见：
常量字段值

TIME_LIMITED_DEFAULT

public static final int TIME_LIMITED_DEFAULT
另请参见：
常量字段值

TIME_LIMITED_SPECIAL_RANGE

public static final int TIME_LIMITED_SPECIAL_RANGE
另请参见：
常量字段值

TIME_LIMITED_SPECIAL_POINT

public static final int TIME_LIMITED_SPECIAL_POINT
另请参见：
常量字段值
构造方法详细信息

Channel

public Channel()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getSiteId

public int getSiteId()
获取频道所属的站点ID

指定者：
类 BaseChannel 中的 getSiteId
返回：
频道所属的站点ID

getSite

public WebSite getSite()
                throws WCMException
频道所属的站点对象

指定者：
类 BaseChannel 中的 getSite
返回：
频道所属的站点对象
抛出：
WCMException

setSite

public boolean setSite(int _nSiteId)
                throws WCMException
设置所属站点：仅添加频道时可用，不允许修改该属性

参数：
_nSiteId - 所属站点ID
返回：
抛出：
WCMException

setSite

public boolean setSite(WebSite _website)
                throws WCMException
设置所属站点：仅添加频道时可用，不允许修改该属性

参数：
_website - 所属站点对象
返回：
抛出：
WCMException

getName

public java.lang.String getName()
获取频道的名称

指定者：
类 BaseChannel 中的 getName
返回：

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置频道的名称 名称要求：同一级（即相同父频道）的频道，名称不重复 处理：由函数isValid()检查，区分大小写

指定者：
类 BaseChannel 中的 setName
参数：
_name - 频道的名称
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取频道描述

指定者：
类 BaseChannel 中的 getDesc
返回：
频道描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置频道描述

参数：
_desc - 频道描述
返回：
抛出：
WCMException

getTable

public java.lang.String getTable()
获取存储频道中文档的数据表的名称

返回：
存储频道中文档的数据表的名称

setTable

public boolean setTable(java.lang.String _table)
                 throws WCMException
设置存储频道中文档的数据表的名称

参数：
_table - 存储频道中文档的数据表的名称
返回：
抛出：
WCMException

getQuery

public java.lang.String getQuery()
获取频道的查询条件

返回：
设置频道的查询条件

setQuery

public boolean setQuery(java.lang.String _query)
                 throws WCMException
设置频道的查询条件

参数：
_query - 频道的查询条件
返回：
抛出：
WCMException

getChnlProperty

public int getChnlProperty()
获取频道属性

返回：

setChnlProperty

public boolean setChnlProperty(int _nProperty)
                        throws WCMException
设置频道属性

参数：
_nProperty - 频道属性
抛出：
WCMException

getParentId

public int getParentId()
获取父频道ID

覆盖：
类 BaseChannel 中的 getParentId
返回：
如果不是顶级频道返回>0的整数否则返回0

getParent

public Channel getParent()
                  throws WCMException
获取父频道对象

返回：
如果是顶级频道或父频道已经删除返回null;否则返回频道对象
抛出：
WCMException

setParent

public boolean setParent(BaseChannel _parent)
                  throws WCMException
Sets the parent of this channel.

参数：
_parent - a website or channel as parent
返回：
抛出：
WCMException

setParent

public boolean setParent(int _parentId)
                  throws WCMException
设置父频道

指定者：
类 BaseChannel 中的 setParent
参数：
_parentId - 父频道ID(如果不是顶级频道为>0的整数，否则为0)
返回：
抛出：
WCMException

getOrder

public int getOrder()
获取频道排序序号

指定者：
类 BaseChannel 中的 getOrder
返回：

setOrder

public boolean setOrder(int _order)
                 throws WCMException
设置频道排序序号

参数：
_order -
返回：
抛出：
WCMException

getOrderBy

public java.lang.String getOrderBy()
获取频道默认的排序方式

返回：
频道默认的排序方式

setOrderBy

public boolean setOrderBy(java.lang.String _sOrderBy)
                   throws WCMException
设置频道默认的排序方式

参数：
_sOrderBy - 频道默认的排序方式
返回：
抛出：
WCMException

getStatus

public int getStatus()
获取频道状态（Channel.STATUS_NORM等）

覆盖：
类 BaseChannel 中的 getStatus
返回：
频道状态（Channel.STATUS_NORM等）

setStatus

public boolean setStatus(int _status)
                  throws WCMException
设置频道状态（Channel.STATUS_NORM等）

覆盖：
类 BaseChannel 中的 setStatus
参数：
_status - 频道状态（Channel.STATUS_NORM等）
返回：
抛出：
WCMException

getType

public int getType()
获取频道类型(Channel.TYPE_NORM等)

返回：
频道类型(Channel.TYPE_NORM等)

getTypeDesc

public java.lang.String getTypeDesc()

setType

public boolean setType(int _type)
                throws WCMException
设置频道类型(Channel.TYPE_NORM等)

参数：
_type - 频道类型(Channel.TYPE_NORM等)
返回：
抛出：
WCMException

isNormType

public boolean isNormType()
判断是否是普通频道

返回：
如果是普通频道，则返回true否则返回false

isLink

public boolean isLink()
Returns true if the type of this channel is link.

返回：
true if the type of this channel is link

getLinkUrl

public java.lang.String getLinkUrl()
Returns the link url of this folder if its type is link.

返回：
the link url of this folder if its type is link.

setLinkUrl

public boolean setLinkUrl(java.lang.String _sUrl)
                   throws WCMException
Sets the link url of this folder.

参数：
_sUrl - link target url
返回：
true if the property is set successfully.
抛出：
WCMException - if failed to set the property.

isOnlySearch

public boolean isOnlySearch()
是否只使用检索条件

返回：

setOnlySearch

public boolean setOnlySearch(boolean _bOnlySearch)
                      throws WCMException
设置是否只使用检索条件

参数：
_bOnlySearch -
抛出：
WCMException

isCanPub

public boolean isCanPub()
判断是否允许发布

返回：
如果允许发布返回true；否则返回false

setCanPub

public boolean setCanPub(boolean _bCanPub)
                  throws WCMException
设置是否允许发布

参数：
_bCanPub - true：允许发布；false：不允许发布
抛出：
WCMException

isOnlyManager

public boolean isOnlyManager()
是否只作为管理节点

返回：
只作为管理节点返回true；否则返回false

setOnlyManager

public boolean setOnlyManager(boolean _bOnlyManager)
                       throws WCMException
设置是否只作为管理节点

参数：
_bOnlyManager - 只作为管理节点为true；否则为false
抛出：
WCMException

isClickPreview

public boolean isClickPreview()
判断点击文档时是否直接预览页面

返回：
直接预览页面－true；否则－false

setClickPreview

public boolean setClickPreview(boolean _bClickPreview)
                        throws WCMException
设置点击文档时是否直接预览页面

参数：
_bClickPreview - 直接预览页面－true；否则－false
抛出：
WCMException

isToChnlUser

public boolean isToChnlUser()
判断文档流转时是否考虑频道的权限

返回：
考虑－true；否则－false

setToChnlUser

public boolean setToChnlUser(boolean _bToChnlUser)
                      throws WCMException
判断文档流转时是否考虑频道的权限

参数：
_bClickPreview - 考虑－true；否则－false
抛出：
WCMException

isInheritDetail

public boolean isInheritDetail()
是否继承父频道的细览模板

返回：
继承父频道的细览模板－true；否则－false

setInheritDetail

public boolean setInheritDetail(boolean _bInheritDetail)
                         throws WCMException
设置是否继承父频道的细览模板

参数：
_bInheritDetail - 继承父频道的细览模板－true；否则－false
抛出：
WCMException

isInheritOutline

public boolean isInheritOutline()
是否继承父频道的概览模板

返回：
继承父频道的概览模板－true；否则－false

setInheritOutline

public boolean setInheritOutline(boolean _bInheritOutline)
                          throws WCMException
设置是否继承父频道的概览模板

参数：
_bInheritOutline - 继承父频道的概览模板－true；否则－false
抛出：
WCMException

isInheritRight

public boolean isInheritRight()
是否继承父系的权限

返回：
true：继承；false：不继承

isInheritExtend

public boolean isInheritExtend()
是否继承父系的扩展字段

返回：
true：继承；false：不继承

setInheritExtend

public boolean setInheritExtend(boolean _bInheritExtend)
                         throws WCMException
设置是否继承父系的扩展字段

参数：
_bInheritExtend - true：继承；false：不继承
抛出：
WCMException

isDoDeptFilter

public boolean isDoDeptFilter()
栏目文档列表是否做所属部门的过滤

返回：
true：过滤；false：不过滤

setDoDeptFilter

public boolean setDoDeptFilter(boolean _bIsDoDeptFilter)
                        throws WCMException
栏目文档列表是否做所属部门的过滤

参数：
_bIsDoDeptFilter - true：过滤；false：不过滤
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
对象的有效性校验

指定者：
类 BaseObj 中的 isValid
返回：
效验通过返回true;否则返回false
抛出：
WCMException -

1、同级频道下不允许重名

新增模式下：

1、没有设置名称

2、没有设置站点

3、没有设置父对象（ParentId）

4、同级频道下特殊频道只允许有一个

delete

public int delete(User _currUser)
           throws WCMException
从类 CMSObj 复制的描述
从数据中删除对象信息

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException
另请参见：
WCMObj.delete( User _currUser )

isVirtual

public boolean isVirtual()
判断频道是否是虚拟频道（例如头条新闻、图片新闻等）

返回：

getReplaces

public Replaces getReplaces(User _currUser)
                     throws WCMException
获取频道上所有的替换内容对象

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

setInputFile

public boolean setInputFile(java.lang.String _sFile)
                     throws WCMException
设置输入文件名

参数：
_sFile -
返回：
抛出：
java.lang.Exception
WCMException

getInputFile

public java.lang.String getInputFile()
获取输入文件名

返回：
抛出：
java.lang.Exception

setEditFile

public boolean setEditFile(java.lang.String _sFile)
                    throws WCMException
设置编辑文件名

参数：
_sFile -
返回：
抛出：
java.lang.Exception
WCMException

getEditFile

public java.lang.String getEditFile()
获取编辑文件名

返回：
抛出：
java.lang.Exception

setOutlineFile

public boolean setOutlineFile(java.lang.String _sFile)
                       throws WCMException
设置频道概览文件名

参数：
_sFile -
返回：
抛出：
java.lang.Exception
WCMException

getOutlineFile

public java.lang.String getOutlineFile()
获取频道概览文件名

返回：
抛出：
java.lang.Exception

setDetailFile

public boolean setDetailFile(java.lang.String _sFile)
                      throws WCMException
设置频道细览文件名

参数：
_sFile -
返回：
抛出：
java.lang.Exception
WCMException

getDetailFile

public java.lang.String getDetailFile()
获取频道细览文件名

返回：
抛出：
java.lang.Exception

getTimeWhere

public java.lang.String getTimeWhere()
                              throws java.lang.Exception
抛出：
java.lang.Exception

isListByTimeRange

public boolean isListByTimeRange()

isListByTimeRange

public boolean isListByTimeRange(boolean _bSystem)
判断频道是否指定了时间约束 *

getTimeRange

public int getTimeRange()
获取频道指定的时间范围 *

getTimeRange

public int getTimeRange(boolean _bSystem)
获取频道指定的时间范围 *

setTimeRange

public void setTimeRange(int _nTimeRange)
                  throws java.lang.Exception
设置本频道提取文档的时间范围（单位：天）

参数：
_nTimeRange - 本频道提取文档的时间范围（单位：天）
抛出：
java.lang.Exception

getStartTime

public java.lang.String getStartTime()
获取频道指定的开始时间 *

setStartTime

public void setStartTime(CMyDateTime _dtStart)
                  throws java.lang.Exception
设置频道文档列表的开始时间

参数：
_dtStart -
抛出：
java.lang.Exception

getEndTime

public java.lang.String getEndTime()
获取频道指定的结束时间 *

setEndTime

public void setEndTime(CMyDateTime _dtEnd)
                throws java.lang.Exception
设置频道文档列表的结束时间

参数：
_dtEnd -
抛出：
java.lang.Exception

getTimeLimitedMode

public int getTimeLimitedMode()

setTimeLimitedMode

public void setTimeLimitedMode(int _nTimeLimitedMode)
                        throws java.lang.Exception
抛出：
java.lang.Exception

isSite

public boolean isSite()
判断当前对象是否为站点

指定者：
类 BaseChannel 中的 isSite
返回：
站点对象返回true；频道对象返回false.

update

public void update(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 CMSObj 中的 update
参数：
_currUser - 操作用户
抛出：
WCMException

findById

public static final Channel findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Channel createNewInstance()
                                       throws WCMException
产生当前对象[Channel]的实例

返回：
当前对象的实例[Channel]
抛出：
WCMException

findByKey

public static final Channel findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getHost

public BaseChannel getHost()
                    throws WCMException
从类 BaseChannel 复制的描述
得到当前频道的父频道，在Channel和Site中分别定义

指定者：
类 BaseChannel 中的 getHost
返回：
@throws WCMException
抛出：
WCMException

findByName

public static Channel findByName(int _nSiteId,
                                 java.lang.String _sChannelName)

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

validLoop

public void validLoop()
               throws WCMException
抛出：
WCMException

setSureFormFile

public boolean setSureFormFile(java.lang.String _sSureFormFileName)
                        throws WCMException
设置书生表单文件名称

参数：
_sSureFormFileName - WCM标准的文件名，不包含路径，一般应该是在WebPic下的
从Service层访问应该先放在Upload中
返回：
抛出：
WCMException

getSureFormFileName

public java.lang.String getSureFormFileName()
得到书生表单文件名称

返回：

getNewSureFormFileName

public java.lang.String getNewSureFormFileName()
在编辑模式下，获得用户新增加的书生表单文件名称

返回：

getContentListPage

public java.lang.String getContentListPage()

getContentAddEditPage

public java.lang.String getContentAddEditPage()

getContentShowPage

public java.lang.String getContentShowPage()

getInfo

public java.lang.String getInfo()
从类 BaseChannel 复制的描述
Returns the object inforamtion

指定者：
类 BaseChannel 中的 getInfo
返回：
the object information
另请参见：
BaseChannel.getInfo()

getOutlineFields

public java.lang.String getOutlineFields()
获取该在频道概览页面需要显示的字段列表，以逗号分隔

返回：
该在频道概览页面需要显示的字段列表，或者null

setOutlineFields

public boolean setOutlineFields(java.lang.String _sOutlineFields)
                         throws WCMException
设置取该在频道概览页面需要显示的字段列表，以逗号分隔

参数：
_sOutlineFields - 字段列表，可以是null
返回：
是否设置成功
抛出：
如果发生错误
WCMException

isCluster

public boolean isCluster()

setCluster

public boolean setCluster(boolean _bCluster)
                   throws WCMException
抛出：
WCMException

isContainsChildren

public boolean isContainsChildren()

setContainsChildren

public boolean setContainsChildren(boolean _bContainsChildren)
                            throws WCMException
抛出：
WCMException

getMetaSynFields

public java.lang.String getMetaSynFields()

setMetaSynFields

public boolean setMetaSynFields(java.lang.String _metaSynFieldValue)
                         throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelContentLink

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChannelContentLink

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.ChannelContentLink
所有已实现的接口：
java.lang.Cloneable
public class ChannelContentLink
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE
构造方法摘要
ChannelContentLink()
构造函数：保留默认接口
方法摘要
static ChannelContentLink | createNewInstance() 产生当前对象[ChannelContentLink]的实例
static ChannelContentLink | findById(int _nId) 提取指定ID的对象
static ChannelContentLink | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Channel | getChannel() 获取所属栏目
int | getChnlId() 获取所属栏目Id
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getLinkTitle() 获取链接中的标题
java.lang.String | getLinkUrl() 获取链接
java.lang.String | getName() 获取名称
int | getOrder() 获取排序序号
int | getSiteId() 获取所属站点Id
int | getSysContentLinkId()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isUsedInChildren()
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
static void | main(java.lang.String[] args)
boolean | setChnlId(int _nChannelid) 设置所属栏目
boolean | setLinkTitle(java.lang.String _linkTitle) 设置链接中的标题
boolean | setLinkUrl(java.lang.String _linkUrl) 获取链接
boolean | setName(java.lang.String _name) 设置名称
boolean | setOrder(int _order) 设置排序
boolean | setSiteId(int _nSiteid) 设置所属站点
boolean | setSysContentLinkId(int _nSysId)
boolean | setUsedInChildren(boolean _bUsedInChildren)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ChannelContentLink

public ChannelContentLink()
构造函数：保留默认接口

方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置名称

参数：
_name - 名称
返回：
@throws WCMException
抛出：
WCMException

getName

public java.lang.String getName()
获取名称

返回：
名称

setLinkUrl

public boolean setLinkUrl(java.lang.String _linkUrl)
                   throws WCMException
获取链接

参数：
_linkUrl - 链接
返回：
@throws WCMException
抛出：
WCMException

getLinkUrl

public java.lang.String getLinkUrl()
获取链接

返回：
链接

setLinkTitle

public boolean setLinkTitle(java.lang.String _linkTitle)
                     throws WCMException
设置链接中的标题

参数：
_linkTitle - 链接中的标题
返回：
@throws WCMException
抛出：
WCMException

getLinkTitle

public java.lang.String getLinkTitle()
获取链接中的标题

返回：
链接中的标题

getOrder

public int getOrder()
获取排序序号

返回：

setOrder

public boolean setOrder(int _order)
                 throws WCMException
设置排序

参数：
_order -
返回：
抛出：
WCMException

setChnlId

public boolean setChnlId(int _nChannelid)
                  throws WCMException
设置所属栏目

参数：
_siteId - 站点ID
返回：
@throws WCMException
抛出：
WCMException

getChnlId

public int getChnlId()
获取所属栏目Id

返回：
所属栏目Id

setSiteId

public boolean setSiteId(int _nSiteid)
                  throws WCMException
设置所属站点

参数：
_siteId - 站点ID
返回：
@throws WCMException
抛出：
WCMException

getSiteId

public int getSiteId()
获取所属站点Id

返回：
所属站点Id

getChannel

public Channel getChannel()
                   throws WCMException
获取所属栏目

返回：
所属栏目对象
抛出：
WCMException

getSysContentLinkId

public int getSysContentLinkId()

setSysContentLinkId

public boolean setSysContentLinkId(int _nSysId)
                            throws WCMException
抛出：
WCMException

isUsedInChildren

public boolean isUsedInChildren()

setUsedInChildren

public boolean setUsedInChildren(boolean _bUsedInChildren)
                          throws WCMException
抛出：
WCMException

findById

public static final ChannelContentLink findById(int _nId)
                                         throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ChannelContentLink createNewInstance()
                                                  throws WCMException
产生当前对象[ChannelContentLink]的实例

返回：
当前对象的实例[ChannelContentLink]
抛出：
WCMException

findByKey

public static final ChannelContentLink findByKey(java.lang.Object _oKey)
                                          throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelContentLinks

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChannelContentLinks

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.ChannelContentLinks

public class ChannelContentLinks
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ChannelContentLinks(User user)
ChannelContentLinks(User user, int initCapacity, int capacityInc)
方法摘要
static ChannelContentLinks | createNewInstance(User _currUser) 产生当前集合对象[ChannelContentLinks]的实例
static ChannelContentLinks | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static ChannelContentLinks | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChannelContentLinks]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelContentLinks

public ChannelContentLinks(User user)

ChannelContentLinks

public ChannelContentLinks(User user,
                           int initCapacity,
                           int capacityInc)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final ChannelContentLinks findByIds(User _currUser,
                                                  java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ChannelContentLinks）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ChannelContentLinks openWCMObjs(User _currUser,
                                                    WCMFilter _filter)
                                             throws WCMException
通过指定一个Filter获取当前集合[ChannelContentLinks]

参数：
_filter - 指定的Filter
返回：
当前集合[ChannelContentLinks]
抛出：
WCMException

createNewInstance

public static ChannelContentLinks createNewInstance(User _currUser)
产生当前集合对象[ChannelContentLinks]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelLoopValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChannelLoopValidator

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.ChannelLoopValidator

public class ChannelLoopValidator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
父子关系的回路检测器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelLoopValidator()
方法摘要
void | validEditModeChannel(Channel _currChannel)
void | validHasExistsChannel(Channel _channel)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelLoopValidator

public ChannelLoopValidator()
方法详细信息

validHasExistsChannel

public void validHasExistsChannel(Channel _channel)
                           throws WCMException
抛出：
WCMException

validEditModeChannel

public void validEditModeChannel(Channel _currChannel)
                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelNameMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChannelNameMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.ChannelNameMgr
所有已实现的接口：
IChannelNameMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class ChannelNameMgr
extends java.lang.Object
implements IChannelNameMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
频道名称缓冲管理(LRU缓冲算法)
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int MAX_CACHE_SIZE
构造方法摘要
ChannelNameMgr()
构造函数
方法摘要
void | clear() 清除系统所有的Cache
Channel | findByName(int p_nSiteId, java.lang.String p_sName) 提取指定站点、指定名称的频道
org.aton.cache.LRUCacheContainer | getCache()
int | getMaxCacheSize() 取最大缓冲大小
boolean | init() 初始化当前的Cache
boolean | isDoNotify(BaseObj _currObj)
static void | main(java.lang.String[] args)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
void | setMaxCacheSize(int p_nMaxSize) 设置最大缓冲大小
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAX_CACHE_SIZE

public static final int MAX_CACHE_SIZE
另请参见：
常量字段值
构造方法详细信息

ChannelNameMgr

public ChannelNameMgr()
构造函数

参数：
p_application - 关联的应用服务器
p_nMaxSize - 名称缓冲的最大容量
方法详细信息

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

getMaxCacheSize

public int getMaxCacheSize()
取最大缓冲大小

返回：
最大缓冲大小

setMaxCacheSize

public void setMaxCacheSize(int p_nMaxSize)
设置最大缓冲大小

参数：
p_nMaxSize - 最大缓冲大小

findByName

public Channel findByName(int p_nSiteId,
                          java.lang.String p_sName)
                   throws WCMException
提取指定站点、指定名称的频道

指定者：
接口 IChannelNameMgr 中的 findByName
参数：
p_nSiteId - 站点ID
p_sName - 频道名称
返回：
频道对象
抛出：
WCMException - 提取频道失败会抛出异常。

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

isDoNotify

public boolean isDoNotify(BaseObj _currObj)

getCache

public org.aton.cache.LRUCacheContainer getCache()
                                          throws WCMException
返回：
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Channels

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Channels

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.Channels

public class Channels
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Channels(User _currUser)
Channels(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Channels | createNewInstance(User _currUser) 产生一个当前集合对象[Channels]的实例
static Channels | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Channels | getChildrenOf(int _parentId) 取当前集合ParentId为指定值的子集
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
Channels | getSubChannelsByParentId(int _parentId) 取当前集合ParentId为指定值的子集
BaseObjs | newInstance() 生成新的集合对象实例
static Channels | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Channels]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Channels

public Channels(User _currUser)

Channels

public Channels(User _currUser,
                int initialCapacity,
                int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名
另请参见：
CMSBaseObjs.getIdFieldName()

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类
另请参见：
CMSBaseObjs.getElementClass()

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

getChildrenOf

public Channels getChildrenOf(int _parentId)
                       throws WCMException
取当前集合ParentId为指定值的子集

参数：
_parentId - 指定的ParentId
返回：
抛出：
WCMException

getSubChannelsByParentId

public Channels getSubChannelsByParentId(int _parentId)
                                  throws WCMException
取当前集合ParentId为指定值的子集

参数：
_parentId - 指定的ParentId
返回：
抛出：
WCMException

findByIds

public static final Channels findByIds(User _currUser,
                                       java.lang.String _sIds)
                                throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Channels openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[Channels]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[Channels]
抛出：
WCMException

createNewInstance

public static Channels createNewInstance(User _currUser)
                                  throws WCMException
产生一个当前集合对象[Channels]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelSubstanceImplBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChannelSubstanceImplBase

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase
所有已实现的接口：
ICMSObjSubstanceContent
直接已知子类：
ChannelRightHostImpl
public abstract class ChannelSubstanceImplBase
extends java.lang.Object
implements ICMSObjSubstanceContent

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelSubstanceImplBase()
ChannelSubstanceImplBase(CMSObj _cmsObj)
ChannelSubstanceImplBase(int _nId)
方法摘要
boolean | equals(java.lang.Object _another)
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelSubstanceImplBase

public ChannelSubstanceImplBase()

ChannelSubstanceImplBase

public ChannelSubstanceImplBase(int _nId)
                         throws WCMException
抛出：
WCMException

ChannelSubstanceImplBase

public ChannelSubstanceImplBase(CMSObj _cmsObj)
方法详细信息

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelSyn

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChannelSyn

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.ChannelSyn
所有已实现的接口：
java.lang.Cloneable
public class ChannelSyn
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ChannelSyn()
构造函数：保留默认接口
方法摘要
boolean | addStatus(int _statusId)
boolean | addStatus(Status _status)
static ChannelSyn | createNewInstance() 产生当前对象[ChannelSyn]的实例
static ChannelSyn | findById(int _nId) 提取指定ID的对象
static ChannelSyn | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
CMyDateTime | getDocEndTime() 属性提取：文档结束时间
CMyDateTime | getDocStartTime() 属性提取：文档执行时间
CMyDateTime | getEndTime() 属性提取：执行结束时间
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
Channel | getSrcChannel() 获取源频道
int | getSrcChannelId() 提取属性：SrcChannelId
CMyDateTime | getStartTime() 属性提取：开始执行时间
Statuses | getStatuses(User _currUser)
java.lang.String | getStatusIds()
Channel | getToChannel() 获取目标频道
int | getToChannelId() 提取属性：ToChannelId
int | getTransmitType()
int | getWCMType() 取得该对象的类型编号
java.lang.String | getWhereSql() 提取属性：WhereSql
boolean | isValid() 检验对象数据有效性
static boolean | isValid(int _nSrcChannelId, int _nDstChannelId) 校验当前分发是否有效
boolean | setDocEndTime(CMyDateTime _endTime)
boolean | setDocStartTime(CMyDateTime _startTime) 属性设置：文档执行时间
boolean | setEndTime(CMyDateTime _endTime)
boolean | setSrcChannelId(int _nSrcChannelId) 设置属性：SrcChannelId
boolean | setStartTime(CMyDateTime _startTime) 属性设置：开始执行时间
boolean | setStatus(java.lang.String _statusIds)
boolean | setToChannelId(int _nToChannelId) 设置属性：ToChannelId
void | setTransmitType(int _nTransmitType)
boolean | setWhereSql(java.lang.String _sWhereSql) 设置属性：WhereSql
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ChannelSyn

public ChannelSyn()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getSrcChannelId

public int getSrcChannelId()
提取属性：SrcChannelId

返回：
SrcChannelId

getSrcChannel

public Channel getSrcChannel()
                      throws WCMException
获取源频道

返回：
Channel对象
抛出：
WCMException

setSrcChannelId

public boolean setSrcChannelId(int _nSrcChannelId)
                        throws WCMException
设置属性：SrcChannelId

参数：
SrcChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getToChannelId

public int getToChannelId()
提取属性：ToChannelId

返回：
ToChannelId

getToChannel

public Channel getToChannel()
                     throws WCMException
获取目标频道

返回：
Channel对象
抛出：
WCMException

setToChannelId

public boolean setToChannelId(int _nToChannelId)
                       throws WCMException
设置属性：ToChannelId

参数：
ToChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWhereSql

public java.lang.String getWhereSql()
提取属性：WhereSql

返回：
WhereSql

setWhereSql

public boolean setWhereSql(java.lang.String _sWhereSql)
                    throws WCMException
设置属性：WhereSql

参数：
WhereSql - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStartTime

public CMyDateTime getStartTime()
属性提取：开始执行时间

返回：
开始执行时间

setStartTime

public boolean setStartTime(CMyDateTime _startTime)
                     throws WCMException
属性设置：开始执行时间

参数：
_startTime - 开始执行时间
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEndTime

public CMyDateTime getEndTime()
属性提取：执行结束时间

返回：
执行结束时间

setEndTime

public boolean setEndTime(CMyDateTime _endTime)
                   throws WCMException
抛出：
WCMException

getDocStartTime

public CMyDateTime getDocStartTime()
属性提取：文档执行时间

返回：
文档执行时间

setDocStartTime

public boolean setDocStartTime(CMyDateTime _startTime)
                        throws WCMException
属性设置：文档执行时间

参数：
_startTime - 文档执行时间
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocEndTime

public CMyDateTime getDocEndTime()
属性提取：文档结束时间

返回：
文档结束时间

setDocEndTime

public boolean setDocEndTime(CMyDateTime _endTime)
                      throws WCMException
抛出：
WCMException

getStatusIds

public java.lang.String getStatusIds()

getStatuses

public Statuses getStatuses(User _currUser)
                     throws WCMException
抛出：
WCMException

setStatus

public boolean setStatus(java.lang.String _statusIds)
                  throws WCMException
抛出：
WCMException

addStatus

public boolean addStatus(int _statusId)
                  throws WCMException
抛出：
WCMException

addStatus

public boolean addStatus(Status _status)
                  throws WCMException
抛出：
WCMException

getTransmitType

public int getTransmitType()

setTransmitType

public void setTransmitType(int _nTransmitType)
                     throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

findById

public static final ChannelSyn findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ChannelSyn createNewInstance()
                                          throws WCMException
产生当前对象[ChannelSyn]的实例

返回：
当前对象的实例[ChannelSyn]
抛出：
WCMException

findByKey

public static final ChannelSyn findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

isValid

public static boolean isValid(int _nSrcChannelId,
                              int _nDstChannelId)
                       throws WCMException
校验当前分发是否有效

参数：
_nSrcChannelId -
_nDstChannelId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelSyns

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChannelSyns

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.ChannelSyns

public class ChannelSyns
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ChannelSyns(User _currUser)
构造函数
ChannelSyns(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ChannelSyns | createNewInstance(User _currUser) 产生当前集合对象[ChannelSyns]的实例
static ChannelSyns | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ChannelSyns | openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 17:12:53 Last Modified: 2004-12-12/2004-12-12 Description:获取频道分发设置集合
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelSyns

public ChannelSyns(User _currUser)
构造函数

另请参见：
ChannelSyns( User _currUser, int _initCapacity, int _incCapacity );

ChannelSyns

public ChannelSyns(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

openWCMObjs

public static ChannelSyns openWCMObjs(User _currUser,
                                      WCMFilter _filter)
                               throws WCMException
Created: 2004-12-12 17:12:53 Last Modified: 2004-12-12/2004-12-12 Description:获取频道分发设置集合

参数：
_currUser - 当前操作用户
_filter - 过滤器
返回：
抛出：
WCMException

findByIds

public static ChannelSyns findByIds(User _currUser,
                                    java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ChannelSyns）
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static ChannelSyns createNewInstance(User _currUser)
产生当前集合对象[ChannelSyns]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChannelXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.wcm.content.persistent.ChannelXmlConverter

public class ChannelXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
站点/频道到XML转换的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelXmlConverter(java.lang.String _sSiteFieldList, java.lang.String _sChannelFieldList)
方法摘要
boolean | isWithChildren()
boolean | isWithExtField()
boolean | isWithTemplates()
void | setWithChildren(boolean _bWwithChildren) 设置是否导出子对象(频道) 默认为false,不导出
void | setWithExtField(boolean _bWithExtField) 设置是否导出扩展字段对象
void | setWithTemp(boolean _bWithTemp, java.lang.String _sTempApdPath) 设置是否导出模板 因为导出模板的同时,会导出模板所使用的文件(JS,CSS等) 因此,需要指定文件的导出位置 默认为不导出
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelXmlConverter

public ChannelXmlConverter(java.lang.String _sSiteFieldList,
                           java.lang.String _sChannelFieldList)
方法详细信息

isWithChildren

public boolean isWithChildren()

setWithChildren

public void setWithChildren(boolean _bWwithChildren)
设置是否导出子对象(频道)
默认为false,不导出

参数：
_bWwithChildren -

isWithExtField

public boolean isWithExtField()

setWithExtField

public void setWithExtField(boolean _bWithExtField)
设置是否导出扩展字段对象

参数：
_bWithExtField -

isWithTemplates

public boolean isWithTemplates()

setWithTemp

public void setWithTemp(boolean _bWithTemp,
                        java.lang.String _sTempApdPath)
                 throws WCMException
设置是否导出模板
因为导出模板的同时,会导出模板所使用的文件(JS,CSS等)
因此,需要指定文件的导出位置
默认为不导出

参数：
_bWithTemp -
_sTempApdPath -
抛出：
WCMException - 当_bWithTemp=true时, 如果指定的文件置为空或空串,则抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChildrenCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChildrenCacheMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.ChildrenCacheMgr
所有已实现的接口：
IChildrenMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class ChildrenCacheMgr
extends java.lang.Object
implements IChildrenMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
子栏目管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChildrenCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
Channel | getChildAt(BaseChannel _parent, int _nIndex)
int | getChildrenSize(User _currUser, BaseChannel _parent) 获取当前站点/频道的子频道数目
int | getSiblingIndex(BaseChannel _channel) 获取指定频道/站点在其同级目录中的位置
boolean | init() 初始化当前的Cache
java.util.List | listChildren(User _currUser, BaseChannel _parent, int _nType) 获取子频道列表
java.util.List | listChildren(User _currUser, BaseChannel _parent, int[] _arrayNeedType) 获取子频道列表
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChildrenCacheMgr

public ChildrenCacheMgr()
方法详细信息

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

listChildren

public java.util.List listChildren(User _currUser,
                                   BaseChannel _parent,
                                   int _nType)
                            throws WCMException
从接口 IChildrenMgr 复制的描述
获取子频道列表

指定者：
接口 IChildrenMgr 中的 listChildren
参数：
_currUser - 当前登录用户
_parent - 父频道(站点)
_nType - 子频道类型(Channel.TYPE_NORM等)
返回：
@throws WCMException
抛出：
WCMException

listChildren

public final java.util.List listChildren(User _currUser,
                                         BaseChannel _parent,
                                         int[] _arrayNeedType)
                                  throws WCMException
从接口 IChildrenMgr 复制的描述
获取子频道列表

指定者：
接口 IChildrenMgr 中的 listChildren
参数：
_currUser - 当前登录用户
_parent - 父频道(站点)
_arrayNeedType - 子频道类型(Channel.TYPE_NORM等构成的int数组)
返回：
@throws WCMException
抛出：
WCMException

getChildrenSize

public int getChildrenSize(User _currUser,
                           BaseChannel _parent)
                    throws WCMException
从接口 IChildrenMgr 复制的描述
获取当前站点/频道的子频道数目

指定者：
接口 IChildrenMgr 中的 getChildrenSize
参数：
_currUser - 当前登录用户
_parent - 当前站点/频道
返回：
@throws WCMException
抛出：
WCMException

getChildAt

public Channel getChildAt(BaseChannel _parent,
                          int _nIndex)
                   throws WCMException
指定者：
接口 IChildrenMgr 中的 getChildAt
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

getSiblingIndex

public int getSiblingIndex(BaseChannel _channel)
                    throws WCMException
从接口 IChildrenMgr 复制的描述
获取指定频道/站点在其同级目录中的位置

指定者：
接口 IChildrenMgr 中的 getSiblingIndex
参数：
_channel - 指定频道/站点对象
返回：
位置索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDoc

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChnlDoc

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.ChnlDoc
所有已实现的接口：
java.lang.Cloneable
public class ChnlDoc
extends CMSObj

字段摘要
static java.lang.String | DB_DOCUMENT_FIELDS
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static java.util.Hashtable | H_DB_DOCUMENT_PROPERTIES
static boolean | IS_ORDER_BY_PRI 记录是否支持置顶功能
static int | MODAL_ALL 定义ChnlDoc类型： 所有类型
static int | MODAL_ENTITY 定义ChnlDoc类型：实体文档/源文档
static int | MODAL_LINK 定义ChnlDoc类型：引用转发
static int | MODAL_MIRROR 定义ChnlDoc类型：同源转发（镜像）
static int | NOT_ON_TOP
static int | OBJ_TYPE 对象类型编号
static int | PRI_DOCS_SIZE
构造方法摘要
ChnlDoc()
构造函数：保留默认接口
方法摘要
static ChnlDoc | createNewInstance() 产生当前对象[ChnlDoc]的实例
static ChnlDoc | findByDocAndChnl(Document _currDocument, Channel _currChannel) 根据文档和频道，找到对应的ChnlDoc
static ChnlDoc | findByDocAndChnl(int _nDocumentId, int _nChannelId)
static ChnlDoc | findByDocument(Document _currDocument) 根据文档，找到对应的ChnlDoc，只找实体文档本身对应的频道
static ChnlDoc | findById(int _nId) 提取指定ID的对象
static ChnlDoc | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Channel | getChannel() 取文档所属频道对象
int | getChannelId() 提取属性：ChannelId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getDocId() 提取属性：DocId
int | getDocOrder() 提取属性：DocOrder
int | getDocOrderPri() 获得置顶的顺序，如果没有置顶，则返回产量NOT_ON_TOP
int | getDocOrderPri(boolean _bReturnDBValue)
CMyDateTime | getDocPubTime() 提取属性：DocPubTime
java.lang.String | getDocPubURL() 提取属性：DocPubURL
Document | getDocument() 取文档所属频道对象
int | getDocumentId()
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
CMyDateTime | getInvalidTime() 获取文档置顶的有效时间（截止时间）
int | getModal() 获得ChnlDoc的类型，包括实体、引用、镜像
CMyDateTime | getOperTime() 获得操作时间
User | getOperUser() 获得OperUser
java.lang.String | getOperUserName() 获得操作用户的名字
int | getSiteId() 提取属性：SiteId
Status | getStatus() 提取ChnlDoc的状态
int | getStatusId() 提取属性：StatusId
java.lang.String | getStatusName() 获取状态名称
int | getWCMType() 取得该对象的类型编号
boolean | isDeleted() 是否为被删除了的ChnlDoc
boolean | isEntity() 判断当前ChnlDoc是否为实体
boolean | isPublished()
boolean | isTopped()
boolean | isValid() 检验对象数据有效性
boolean | setChannelId(int _nChannelId) 设置属性：ChannelId
boolean | setDeleted(boolean _bDeleted) 将文档设为已删除状态 说明：对于正常状态下的文档，setDeleted( true )将ChnlDoc改为已删除（逻辑删除）； 对于已删除的文档，setDeleted( false )将文档恢复为正常状态
boolean | setDocId(int _nDocId) 设置属性：DocId
boolean | setDocOrder(int _nDocOrder) 设置属性：DocOrder
boolean | setDocOrderPri(int _nDocOrderPri) 设置文档的置顶顺序，不判断是否大于系统允许最大的有效范围
boolean | setDocPubTime(CMyDateTime _dtDocPubTime) 设置属性：DocPubTime
boolean | setDocPubURL(java.lang.String _sDocPubURL) 设置属性：DocPubURL
boolean | setDocTopPriOrder(int _nOrder) 设置文档的置顶位置.
boolean | setDocument(Document _document, boolean _bOnlyCache)
void | setId(int _nId) 设置对象ID
boolean | setInvalidTime(CMyDateTime _dtInvalidTime) 设置文档置顶的有效时间（截止时间）
boolean | setModal(int _nModal) 设置ChnlDoc的类型
boolean | setOperTime() 设置操作时间
boolean | setOperUser(java.lang.String _sUserName) 设置删除操作的用户名
boolean | setOperUser(User _currUser) 设置删除操作的用户
boolean | setSiteId(int _nSiteId) 设置属性：SiteId
boolean | setStatusId(int _nStatusId) 设置属性：StatusId
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

IS_ORDER_BY_PRI

public static boolean IS_ORDER_BY_PRI
记录是否支持置顶功能

PRI_DOCS_SIZE

public static int PRI_DOCS_SIZE

NOT_ON_TOP

public static int NOT_ON_TOP

H_DB_DOCUMENT_PROPERTIES

public static final java.util.Hashtable H_DB_DOCUMENT_PROPERTIES

MODAL_ALL

public static final int MODAL_ALL
定义ChnlDoc类型： 所有类型

另请参见：
常量字段值

MODAL_ENTITY

public static final int MODAL_ENTITY
定义ChnlDoc类型：实体文档/源文档

另请参见：
常量字段值

MODAL_LINK

public static final int MODAL_LINK
定义ChnlDoc类型：引用转发

另请参见：
常量字段值

MODAL_MIRROR

public static final int MODAL_MIRROR
定义ChnlDoc类型：同源转发（镜像）

另请参见：
常量字段值

DB_DOCUMENT_FIELDS

public static java.lang.String DB_DOCUMENT_FIELDS
构造方法详细信息

ChnlDoc

public ChnlDoc()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getSiteId

public int getSiteId()
提取属性：SiteId

返回：
SiteId

setSiteId

public boolean setSiteId(int _nSiteId)
                  throws WCMException
设置属性：SiteId

参数：
_nSiteId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getChannelId

public int getChannelId()
提取属性：ChannelId

返回：
ChannelId

getChannel

public Channel getChannel()
                   throws WCMException
取文档所属频道对象

返回：
文档所属频道对象
抛出：
WCMException

setChannelId

public boolean setChannelId(int _nChannelId)
                     throws WCMException
设置属性：ChannelId

参数：
_nChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocId

public int getDocId()
提取属性：DocId

返回：
DocId

setDeleted

public boolean setDeleted(boolean _bDeleted)
                   throws WCMException

将文档设为已删除状态

说明：对于正常状态下的文档，setDeleted( true )将ChnlDoc改为已删除（逻辑删除）；

对于已删除的文档，setDeleted( false )将文档恢复为正常状态

参数：
_bDeleted - 是否删除
返回：
抛出：
WCMException

setDocId

public boolean setDocId(int _nDocId)
                 throws WCMException
设置属性：DocId

参数：
_nDocId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setDocument

public boolean setDocument(Document _document,
                           boolean _bOnlyCache)
                    throws WCMException
抛出：
WCMException

getStatusId

public int getStatusId()
提取属性：StatusId

返回：
StatusId

getStatus

public Status getStatus()
                 throws WCMException
提取ChnlDoc的状态

返回：
抛出：
WCMException

getStatusName

public java.lang.String getStatusName()
                               throws WCMException
获取状态名称

返回：
状态名称(String)
抛出：
WCMException - 如果从缓冲区获取数据失败，会抛出异常

setStatusId

public boolean setStatusId(int _nStatusId)
                    throws WCMException
设置属性：StatusId

参数：
_nStatusId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocOrder

public int getDocOrder()
提取属性：DocOrder

返回：
DocOrder

setDocOrder

public boolean setDocOrder(int _nDocOrder)
                    throws WCMException
设置属性：DocOrder

参数：
DocOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocPubTime

public CMyDateTime getDocPubTime()
提取属性：DocPubTime

返回：
DocPubTime

setDocPubTime

public boolean setDocPubTime(CMyDateTime _dtDocPubTime)
                      throws WCMException
设置属性：DocPubTime

参数：
DocPubTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocPubURL

public java.lang.String getDocPubURL()
提取属性：DocPubURL

返回：
DocPubURL

setDocPubURL

public boolean setDocPubURL(java.lang.String _sDocPubURL)
                     throws WCMException
设置属性：DocPubURL

参数：
DocPubURL - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocOrderPri

public int getDocOrderPri()
获得置顶的顺序，如果没有置顶，则返回产量NOT_ON_TOP

返回：

getDocOrderPri

public int getDocOrderPri(boolean _bReturnDBValue)

setDocOrderPri

public boolean setDocOrderPri(int _nDocOrderPri)
                       throws WCMException
设置文档的置顶顺序，不判断是否大于系统允许最大的有效范围

参数：
_nDocOrderPri - 置顶的顺序
返回：
抛出：
WCMException - 如果置顶的顺序小于0，则抛出异常

setDocTopPriOrder

public boolean setDocTopPriOrder(int _nOrder)
                          throws WCMException
设置文档的置顶位置.

参数：
_nOrder - 指定的文档置顶位置
有效值为1-@link ChnlDoc#PRI_DOCS_SIZE(系统可配置)
返回：
抛出：
WCMException

isTopped

public boolean isTopped()

getInvalidTime

public CMyDateTime getInvalidTime()
获取文档置顶的有效时间（截止时间）

返回：
截止时间

setInvalidTime

public boolean setInvalidTime(CMyDateTime _dtInvalidTime)
                       throws WCMException
设置文档置顶的有效时间（截止时间）

参数：
_dtInvalidTime - 截止时间
返回：
抛出：
WCMException

isDeleted

public boolean isDeleted()
是否为被删除了的ChnlDoc

返回：

setId

public void setId(int _nId)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

setOperUser

public boolean setOperUser(User _currUser)
                    throws WCMException
设置删除操作的用户

参数：
_currUser -
返回：
抛出：
WCMException

setOperUser

public boolean setOperUser(java.lang.String _sUserName)
                    throws WCMException
设置删除操作的用户名

参数：
_sUserName -
返回：
抛出：
WCMException

getOperUser

public User getOperUser()
获得OperUser

返回：

getOperUserName

public java.lang.String getOperUserName()
获得操作用户的名字

返回：

setOperTime

public boolean setOperTime()
                    throws WCMException
设置操作时间

返回：
抛出：
WCMException

getOperTime

public CMyDateTime getOperTime()
获得操作时间

返回：

getModal

public int getModal()
获得ChnlDoc的类型，包括实体、引用、镜像

返回：

isEntity

public boolean isEntity()
判断当前ChnlDoc是否为实体

返回：
如果为实体，返回true;否则返回false

setModal

public boolean setModal(int _nModal)
                 throws WCMException
设置ChnlDoc的类型

参数：
_nModal -
抛出：
WCMException

findById

public static final ChnlDoc findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ChnlDoc createNewInstance()
                                       throws WCMException
产生当前对象[ChnlDoc]的实例

返回：
当前对象的实例[ChnlDoc]
抛出：
WCMException

findByKey

public static final ChnlDoc findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getDocument

public Document getDocument()
                     throws WCMException
取文档所属频道对象

返回：
文档所属频道对象
抛出：
WCMException

getDocumentId

public int getDocumentId()

findByDocAndChnl

public static final ChnlDoc findByDocAndChnl(Document _currDocument,
                                             Channel _currChannel)
                                      throws WCMException
根据文档和频道，找到对应的ChnlDoc

参数：
_currDocument - 文档实体
_currChannel - 文档所在频道
返回：
符合条件的ChnlDoc对象，如果传入有为空，则返回空
抛出：
WCMException

findByDocAndChnl

public static ChnlDoc findByDocAndChnl(int _nDocumentId,
                                       int _nChannelId)
                                throws WCMException
抛出：
WCMException

findByDocument

public static final ChnlDoc findByDocument(Document _currDocument)
                                    throws WCMException
根据文档，找到对应的ChnlDoc，只找实体文档本身对应的频道

参数：
_currDocument - 文档实体
_currChannel - 文档所在频道
返回：
符合条件的ChnlDoc对象
抛出：
WCMException

isPublished

public boolean isPublished()
返回：

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChnlDocs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ChnlDocs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.ChnlDocs

public class ChnlDocs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ChnlDocs(User _currUser)
构造函数
ChnlDocs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ChnlDocs | createNewInstance(User _currUser) 产生一个当前集合对象[ChnlDocs]的实例
static ChnlDocs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ChnlDocs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChnlDocs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocs

public ChnlDocs(User _currUser)
构造函数

另请参见：
ChnlDocs( User _currUser, int _initCapacity, int _incCapacity );

ChnlDocs

public ChnlDocs(User _currUser,
                int _initCapacity,
                int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final ChnlDocs findByIds(User _currUser,
                                       java.lang.String _sIds)
                                throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ChnlDocs openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[ChnlDocs]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[ChnlDocs]
抛出：
WCMException

createNewInstance

public static ChnlDocs createNewInstance(User _currUser)
                                  throws WCMException
产生一个当前集合对象[ChnlDocs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtField

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ContentExtField

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.ContentExtField
所有已实现的接口：
java.lang.Cloneable
public class ContentExtField
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
ContentExtField()
构造函数：保留默认接口
方法摘要
static ContentExtField | createNewInstance() 产生当前对象[ContentExtField]的实例
static ContentExtField | findById(int _nId) 提取指定ID的对象
static ContentExtField | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 获得扩展字段的扩展属性
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDefaultValue() 获取扩展字段的默认值
int | getDefaultValueAsInt(int _nDefault) 取整型默认值
java.lang.String | getDesc() 提取属性：LogicFieldDesc
int | getExtFieldId()
java.lang.String | getExtFieldProperty(java.lang.String _sName)
CMSObj | getHost()
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getMaxLength() 获得扩展字段最大长度
java.lang.String | getName() 扩展字段名称
int | getObjId() 提取属性：ObjId
int | getObjType() 提取属性：ObjType
int | getScale()
java.lang.String | getTableName() 扩展字段所属数据表名称
DataType | getType() 获取扩展字段类型对象
java.lang.String | getTypeDesc() 获取类型的描述
java.lang.String | getTypeName() 获取扩展字段类型名称
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isNullable() 判断扩展字段是否允许为空
boolean | isValid() 检验对象数据有效性
boolean | setAttribute(java.lang.String _attribute) 设置扩展字段的扩展属性
boolean | setDesc(java.lang.String _sLogicFieldDesc) 设置属性：LogicFieldDesc
boolean | setExtFieldProperty(java.lang.String _sName, java.lang.String _attribute)
boolean | setName(java.lang.String _sName) 设置扩展字段名称
boolean | setObjId(int _nObjId) 设置属性：ObjId
boolean | setObjType(int _nObjType) 设置属性：ObjType
boolean | setTableName(java.lang.String _tableName) 设置扩展字段所属数据表名称
boolean | setType(java.lang.String _typeName, int _maxLength)
boolean | setType(java.lang.String _typeName, int _maxLength, boolean _bNullable, java.lang.String _sDefaultValue) 设置扩展字段数据类型
boolean | setType(java.lang.String _typeName, int _maxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ContentExtField

public ContentExtField()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getObjId

public int getObjId()
提取属性：ObjId

返回：
ObjId

setObjId

public boolean setObjId(int _nObjId)
                 throws WCMException
设置属性：ObjId

参数：
_nObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjType

public int getObjType()
提取属性：ObjType

返回：
ObjType

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
设置属性：ObjType

参数：
_nObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
提取属性：LogicFieldDesc

返回：
LogicFieldDesc

setDesc

public boolean setDesc(java.lang.String _sLogicFieldDesc)
                throws WCMException
设置属性：LogicFieldDesc

参数：
_sLogicFieldDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

getTableName

public java.lang.String getTableName()
扩展字段所属数据表名称

返回：

setTableName

public boolean setTableName(java.lang.String _tableName)
                     throws WCMException
设置扩展字段所属数据表名称

参数：
_tableName - 扩展字段所属数据表名称
返回：
设置成功返回true;否则返回false
抛出：
WCMException

getName

public java.lang.String getName()
扩展字段名称

返回：
扩展字段名称（String）

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置扩展字段名称

参数：
_sName - 扩展字段名称
返回：
设置成功返回true;否则返回false
抛出：
WCMException

getTypeName

public java.lang.String getTypeName()
获取扩展字段类型名称

返回：
扩展字段类型名称

getTypeDesc

public java.lang.String getTypeDesc()
                             throws WCMException
获取类型的描述

返回：
抛出：
WCMException

getType

public DataType getType()
                 throws WCMException
获取扩展字段类型对象

返回：
扩展字段类型对象（com.trs.util.database.DataType）
抛出：
WCMException

getMaxLength

public int getMaxLength()
获得扩展字段最大长度

返回：
扩展字段最大长度（int）

getScale

public int getScale()

isNullable

public boolean isNullable()
判断扩展字段是否允许为空

返回：
如果扩展字段允许为空则返回true,否则返回false

getDefaultValue

public java.lang.String getDefaultValue()
获取扩展字段的默认值

返回：
扩展字段的默认值（String）

getDefaultValueAsInt

public int getDefaultValueAsInt(int _nDefault)
                         throws WCMException
取整型默认值

参数：
_default - 当设定的默认值为空时，默认的返回值
返回：
整型默认值
抛出：
WCMException

setType

public boolean setType(java.lang.String _typeName,
                       int _maxLength)
                throws WCMException
参数：
_typeName -
_maxLength -
返回：
设置成功返回true;否则返回false
抛出：
WCMException

setType

public boolean setType(java.lang.String _typeName,
                       int _maxLength,
                       boolean _bNullable,
                       java.lang.String _sDefaultValue)
                throws WCMException
设置扩展字段数据类型

参数：
_typeName - 数据类型名称
_maxLength - 最大长度
_bNullable - 是否允许为空，可缺省（默认值为true）
_sDefaultValue - 默认值，可缺省（默认值为null） 说明：仅当_bNullable=false时候，_sDefaultValue有效。
返回：
设置成功返回true;否则返回false
抛出：
WCMException

setType

public boolean setType(java.lang.String _typeName,
                       int _maxLength,
                       boolean _bNullable,
                       java.lang.String _sDefaultValue,
                       int _nScale)
                throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
获得扩展字段的扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：
扩展字段的扩展属性（String）

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
设置扩展字段的扩展属性

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展字段的扩展属性
返回：
设置成功返回true;否则返回false
抛出：
WCMException

findById

public static final ContentExtField findById(int _nId)
                                      throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ContentExtField createNewInstance()
产生当前对象[ContentExtField]的实例

返回：
当前对象的实例[ContentExtField]
抛出：
WCMException

findByKey

public static final ContentExtField findByKey(java.lang.Object _oKey)
                                       throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getExtFieldId

public int getExtFieldId()

getHost

public CMSObj getHost()
               throws WCMException
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

setExtFieldProperty

public boolean setExtFieldProperty(java.lang.String _sName,
                                   java.lang.String _attribute)
                            throws WCMException
抛出：
WCMException

getExtFieldProperty

public java.lang.String getExtFieldProperty(java.lang.String _sName)
                                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtFields

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ContentExtFields

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.ContentExtFields

public class ContentExtFields
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ContentExtFields(User _currUser)
构造函数
ContentExtFields(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ContentExtFields | createNewInstance(User _currUser) 产生当前集合对象[ContentExtFields]的实例
static ContentExtFields | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ContentExtFields | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentExtFields]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentExtFields

public ContentExtFields(User _currUser)
构造函数

另请参见：
ContentExtFields( User _currUser, int _initCapacity, int _incCapacity );

ContentExtFields

public ContentExtFields(User _currUser,
                        int _initCapacity,
                        int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ContentExtFields findByIds(User _currUser,
                                               java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ContentExtFields）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ContentExtFields openWCMObjs(User _currUser,
                                                 WCMFilter _filter)
                                          throws WCMException
通过指定一个Filter获取当前集合[ContentExtFields]

参数：
_filter - 指定的Filter
返回：
当前集合[ContentExtFields]
抛出：
WCMException

createNewInstance

public static ContentExtFields createNewInstance(User _currUser)
产生当前集合对象[ContentExtFields]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentExtFieldXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ContentExtFieldXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.wcm.content.persistent.ContentExtFieldXmlConverter

public class ContentExtFieldXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContentExtFieldXmlConverter()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentExtFieldXmlConverter

public ContentExtFieldXmlConverter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentLink

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ContentLink

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.ContentLink
所有已实现的接口：
java.lang.Cloneable
public class ContentLink
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
ContentLink()
构造函数：保留默认接口
方法摘要
static ContentLink | createNewInstance() 产生当前对象[ContentLink]的实例
static ContentLink | findById(int _nId) 提取指定ID的对象
static ContentLink | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getLinkTitle() 获取链接中的标题
int | getLinkType()
java.lang.String | getLinkTypeName()
java.lang.String | getLinkUrl() 获取链接
java.lang.String | getName() 获取名称
WebSite | getSite() 获取所属站点对象
int | getSiteId() 获取所属站点ID
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 效验数据的有效性
boolean | setLinkTitle(java.lang.String _linkTitle) 设置链接中的标题
boolean | setLinkType(int _nType)
boolean | setLinkUrl(java.lang.String _linkUrl) 获取链接
boolean | setName(java.lang.String _name) 设置名称
boolean | setSiteId(int _siteId) 设置所属站点
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ContentLink

public ContentLink()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

isValid

public boolean isValid()
                throws WCMException
效验数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
如果有效返回true；否则返回false
抛出：
WCMException -

新增模式下：

1、没有设置链接名称

2、没有设置所属站点

3、没有设置链接

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置名称

参数：
_name - 名称
返回：
@throws WCMException
抛出：
WCMException

getName

public java.lang.String getName()
获取名称

返回：
名称

setLinkUrl

public boolean setLinkUrl(java.lang.String _linkUrl)
                   throws WCMException
获取链接

参数：
_linkUrl - 链接
返回：
@throws WCMException
抛出：
WCMException

getLinkUrl

public java.lang.String getLinkUrl()
获取链接

返回：
链接

setLinkTitle

public boolean setLinkTitle(java.lang.String _linkTitle)
                     throws WCMException
设置链接中的标题

参数：
_linkTitle - 链接中的标题
返回：
@throws WCMException
抛出：
WCMException

getLinkTitle

public java.lang.String getLinkTitle()
获取链接中的标题

返回：
链接中的标题

setSiteId

public boolean setSiteId(int _siteId)
                  throws WCMException
设置所属站点

参数：
_siteId - 站点ID
返回：
@throws WCMException
抛出：
WCMException

getSiteId

public int getSiteId()
获取所属站点ID

返回：
站点ID

getSite

public WebSite getSite()
                throws WCMException
获取所属站点对象

返回：
所属站点对象
抛出：
WCMException

findById

public static final ContentLink findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ContentLink createNewInstance()
                                           throws WCMException
产生当前对象[ContentLink]的实例

返回：
当前对象的实例[ContentLink]
抛出：
WCMException

findByKey

public static final ContentLink findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

getLinkType

public int getLinkType()

setLinkType

public boolean setLinkType(int _nType)
                    throws WCMException
抛出：
WCMException

getLinkTypeName

public java.lang.String getLinkTypeName()
                                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentLinks

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ContentLinks

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.ContentLinks

public class ContentLinks
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ContentLinks(User _currUser)
ContentLinks(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static ContentLinks | createNewInstance(User _currUser) 产生当前集合对象[ContentLinks]的实例
static ContentLinks | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static ContentLinks | openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 17:19:37 Last Modified: 2004-12-12/2004-12-12 Description: 获取内容超链接对象集合
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentLinks

public ContentLinks(User _currUser)

ContentLinks

public ContentLinks(User _currUser,
                    int initialCapacity,
                    int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名
另请参见：
CMSBaseObjs.getIdFieldName()

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类
另请参见：
CMSBaseObjs.getElementClass()

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

openWCMObjs

public static ContentLinks openWCMObjs(User _currUser,
                                       WCMFilter _filter)
                                throws WCMException
Created: 2004-12-12 17:19:37 Last Modified: 2004-12-12/2004-12-12 Description: 获取内容超链接对象集合

参数：
_currUser - 当前操作用户
_filter - 过滤器,筛选条件
返回：
抛出：
WCMException

findByIds

public static final ContentLinks findByIds(User _currUser,
                                           java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ContentLinks）
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static ContentLinks createNewInstance(User _currUser)
产生当前集合对象[ContentLinks]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentLinkType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ContentLinkType

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.ContentLinkType
所有已实现的接口：
java.lang.Cloneable
public class ContentLinkType
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
ContentLinkType()
构造函数：保留默认接口
方法摘要
static ContentLinkType | createNewInstance() 产生当前对象[ContentLinkType]的实例
static ContentLinkType | findById(int _nId) 提取指定ID的对象
static ContentLinkType | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getTypeDesc() 提取属性：TYPEDESC
java.lang.String | getTypeName() 提取属性：TYPENAME
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setTypeDesc(java.lang.String _sTypeDesc) 设置属性：TYPEDESC
boolean | setTypeName(java.lang.String _sTypeName) 设置属性：TYPENAME
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

ContentLinkType

public ContentLinkType()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getTypeName

public java.lang.String getTypeName()
提取属性：TYPENAME

返回：
TYPENAME

setTypeName

public boolean setTypeName(java.lang.String _sTypeName)
                    throws WCMException
设置属性：TYPENAME

参数：
_sTypeName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTypeDesc

public java.lang.String getTypeDesc()
提取属性：TYPEDESC

返回：
TYPEDESC

setTypeDesc

public boolean setTypeDesc(java.lang.String _sTypeDesc)
                    throws WCMException
设置属性：TYPEDESC

参数：
_sTypeDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final ContentLinkType findById(int _nId)
                                      throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final ContentLinkType createNewInstance()
产生当前对象[ContentLinkType]的实例

返回：
当前对象的实例[ContentLinkType]
抛出：
WCMException

findByKey

public static final ContentLinkType findByKey(java.lang.Object _oKey)
                                       throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentLinkTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ContentLinkTypes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.ContentLinkTypes

public class ContentLinkTypes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
ContentLinkTypes(User _currUser)
构造函数
ContentLinkTypes(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static ContentLinkTypes | createNewInstance(User _currUser) 产生当前集合对象[ContentLinkTypes]的实例
static ContentLinkTypes | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static ContentLinkTypes | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentLinkTypes]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentLinkTypes

public ContentLinkTypes(User _currUser)
构造函数

另请参见：
ContentLinkTypes( User _currUser, int _initCapacity, int _incCapacity );

ContentLinkTypes

public ContentLinkTypes(User _currUser,
                        int _initCapacity,
                        int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final ContentLinkTypes findByIds(User _currUser,
                                               java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（ContentLinkTypes）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final ContentLinkTypes openWCMObjs(User _currUser,
                                                 WCMFilter _filter)
                                          throws WCMException
通过指定一个Filter获取当前集合[ContentLinkTypes]

参数：
_filter - 指定的Filter
返回：
当前集合[ContentLinkTypes]
抛出：
WCMException

createNewInstance

public static ContentLinkTypes createNewInstance(User _currUser)
产生当前集合对象[ContentLinkTypes]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocBak

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocBak

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.Document
                继承者  com.trs.components.wcm.content.persistent.DocBak
所有已实现的接口：
java.lang.Cloneable
public class DocBak
extends Document

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
从类 com.trs.components.wcm.content.persistent.Document 继承的字段
ALL_TYPES, DOC_FORM_AUDIO, DOC_FORM_LITERY, DOC_FORM_PIC, DOC_FORM_UNKNOWN, DOC_FORM_VIDEO, DOC_TYPE_FILE, DOC_TYPE_HTML, DOC_TYPE_LINK, DOC_TYPE_NORMAL, DOCUMENTS_GET_OPTIMIZE, FLAG_DEFAULT, FLAG_UNKNOWN, FLAG_USER_DEFINE, g_bXMLforTRS, GET_RELATEDDOC_BY_ALL, GET_RELATEDDOC_BY_KEYWORDS, GET_RELATEDDOC_BY_RELATION, GET_RELATEDDOC_BY_RELWORDS, m_bXMLOnlySelf, SYNCHRONIZE_PROPERTIES_TO_CHNLDOC, SYNCHRONIZED_FIELDS, TYPE_FILE, TYPE_HTML, TYPE_LINK, TYPE_NORMAL, TYPE_UNKNOWN
构造方法摘要
DocBak()
方法摘要
static Document | createNewInstance() 产生当前对象[DocBak]的实例
int | delete(User _currUser) 重载父类delete函数 删除该版本的备份，同时需要删除该版本在相关附件上的引用关系
static Document | findById(int _nId) 提取指定ID的对象
static Document | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
CMyDateTime | getBakTime() 获取备份时间
User | getBakUser() 获取备份用户对象
java.lang.String | getBakUserName() 获取备份用户
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
int | getDocId() 获取备份的文档ID
Document | getDocument()
java.util.List | getHTMLWCMFiles()
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | setBakUser(java.lang.String _bakUserName) 设置备份用户
boolean | setBakUser(User _bakUser) 设置备份用户
boolean | setDocId(Document _doc) 设置备份的文档
boolean | setDocId(int _docId) 设置备份文档的ID
boolean | setProperty(java.lang.String _sName, java.lang.Object _oValue)
void | update(User _user) 更新修改。
从类 com.trs.components.wcm.content.persistent.Document 继承的方法
cloneToNewWCMObj, delete, findById, findById, getAbstract, getAuditor, getAuditorName, getAuthorName, getChannel, getChannelId, getChannelName, getContent, getEditor, getEditorName, getFlag, getFromVersion, getHitsCount, getHtmlContent, getHtmlContentWithImgFilter, getHtmlContentWithImgFilter, getHTMLFiles, getHTMLWCMFiles, getKeywords, getKind, getKindId, getOtherTableName, getOutUpId, getPeople, getPlace, getPubHtmlContent, getPubPathStartTime, getPubTime, getPubURL, getRandomSerial, getRelateWords, getReleaseTime, getSecurity, getSecurityId, getSource, getSourceId, getStatus, getStatusId, getStatusName, getSubTitle, getTitle, getTitleColor, getType, getTypeString, getTypeString, getValidTime, getVersion, getWordsCount, hasDocPro, insertOtherTable, isAttachPic, isDeleted, isDocumentObject, isDoDelete, isDoMove, isDoRecover, isDraft, isOutUp, isRightDefined, isSavePubFileByTime, isValid, isValidInstance, logicalDelete, logicalUndelete, main, setAbstract, setAttachPic, setAuditor, setAuditor, setAuthor, setChannel, setChannel, setContent, setDbTableName, setDeleted, setDocPro, setEditor, setEditor, setFlag, setFromVersion, setHitsCount, setHtmlContent, setId, setKeywords, setKind, setKind, setMyDocId, setOtherTableName, setOutUpId, setPeople, setPlace, setPubHtmlContent, setPubPathStartTime, setPubTime, setPubURL, setRandomSerial, setRelateWords, setReleaseTime, setRightDefined, setSecurity, setSecurity, setSource, setSource, setStatus, setStatus, setStatus, setSubTitle, setTitle, setTitleColor, setType, setValidTime, setVersion, toString, updateHitsCount
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

DocBak

public DocBak()
另请参见：
WCMObj.WCMObj()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

覆盖：
类 Document 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

覆盖：
类 Document 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

覆盖：
类 Document 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getDocId

public int getDocId()
获取备份的文档ID

覆盖：
类 Document 中的 getDocId
返回：

setDocId

public boolean setDocId(int _docId)
                 throws WCMException
设置备份文档的ID

参数：
_docId - 备份的文档ID
返回：
抛出：
WCMException

setDocId

public boolean setDocId(Document _doc)
                 throws WCMException
设置备份的文档

参数：
_doc - 备份的文档对象（Document）
返回：
抛出：
WCMException

getDocument

public Document getDocument()
                     throws WCMException
抛出：
WCMException

getBakUserName

public java.lang.String getBakUserName()
获取备份用户

返回：
备份用户

getBakUser

public User getBakUser()
获取备份用户对象

返回：
备份用户对象

setBakUser

public boolean setBakUser(java.lang.String _bakUserName)
                   throws WCMException
设置备份用户

参数：
_bakUserName - 备份用户的用户名
返回：
抛出：
WCMException

setBakUser

public boolean setBakUser(User _bakUser)
                   throws WCMException
设置备份用户

参数：
_bakUser - 备份用户对象
返回：
抛出：
WCMException

getBakTime

public CMyDateTime getBakTime()
获取备份时间

返回：
备份时间

setProperty

public boolean setProperty(java.lang.String _sName,
                           java.lang.Object _oValue)
                    throws WCMException
覆盖：
类 BaseObj 中的 setProperty
抛出：
WCMException - 如果修改文档备份对象将会抛出异常
另请参见：
( String _sName, Object _oValue ) throws WCMException

update

public void update(User _user)
            throws WCMException
从类 CMSObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 CMSObj 中的 update
参数：
_user - 操作用户
抛出：
WCMException - 如果修改文档备份对象将会抛出异常
另请参见：
throws WCMException{

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException - 如果修改文档备份对象将不执行任何操作
另请参见：
throws WCMException{

delete

public int delete(User _currUser)
           throws WCMException
重载父类delete函数

删除该版本的备份，同时需要删除该版本在相关附件上的引用关系

覆盖：
类 Document 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException
另请参见：
throws WCMException{

getHTMLWCMFiles

public java.util.List getHTMLWCMFiles()
覆盖：
类 Document 中的 getHTMLWCMFiles

findById

public static final Document findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Document createNewInstance()
                                        throws WCMException
产生当前对象[DocBak]的实例

返回：
当前对象的实例[DocBak]
抛出：
WCMException

findByKey

public static final Document findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocBaks

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocBaks

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.DocBaks

public class DocBaks
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
DocBaks(User _currUser)
DocBaks(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static DocBaks | createNewInstance(User _currUser) 产生一个当前集合对象[DocBaks]的实例
static DocBaks | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static DocBaks | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocBaks]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocBaks

public DocBaks(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

DocBaks

public DocBaks(User _currUser,
               int _initCapacity,
               int _incCapacity)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final DocBaks findByIds(User _currUser,
                                      java.lang.String _sIds)
                               throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final DocBaks openWCMObjs(User _currUser,
                                        WCMFilter _filter)
                                 throws WCMException
通过指定一个Filter获取当前集合[DocBaks]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[DocBaks]
抛出：
WCMException

createNewInstance

public static DocBaks createNewInstance(User _currUser)
                                 throws WCMException
产生一个当前集合对象[DocBaks]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocReply

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocReply

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.DocReply
所有已实现的接口：
java.lang.Cloneable
public class DocReply
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
DocReply()
方法摘要
static DocReply | createNewInstance() 产生当前对象[DocReply]的实例
static DocReply | findById(int _nId) 提取指定ID的对象
static DocReply | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getContent() 获取回复内容
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取描述
int | getDocId() 获取回复所属的文档ID
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getTitle() 获取回复标题
int | getType()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加记录到数据库 为了设置产生时间特重载
boolean | isValid() 检查对象数据的有效性
boolean | setContent(java.lang.String _content) 设置回复内容
boolean | setDesc(java.lang.String _desc) 设置描述
boolean | setDocId(int _docId) 设置回复所属的文档ID
boolean | setTitle(java.lang.String _title) 设置回复标题
boolean | setType(int _type)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

DocReply

public DocReply()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getDocId

public int getDocId()
获取回复所属的文档ID

返回：
回复所属的文档ID

setDocId

public boolean setDocId(int _docId)
                 throws WCMException
设置回复所属的文档ID

参数：
_docId - 回复所属的文档ID
返回：
抛出：
WCMException

getType

public int getType()

setType

public boolean setType(int _type)
                throws WCMException
抛出：
WCMException

getTitle

public java.lang.String getTitle()
获取回复标题

返回：
回复标题

setTitle

public boolean setTitle(java.lang.String _title)
                 throws WCMException
设置回复标题

参数：
_title - 回复标题
返回：
抛出：
WCMException

getContent

public java.lang.String getContent()
获取回复内容

返回：
回复内容

setContent

public boolean setContent(java.lang.String _content)
                   throws WCMException
设置回复内容

参数：
_content - 回复内容
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取描述

返回：
描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置描述

参数：
_desc - 描述
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 新增模式下： 1、没有设置回复所属文档 2、没有设置产生用户
另请参见：
WCMObj.isValid()

insert

public void insert(User _currUser)
            throws WCMException
添加记录到数据库 为了设置产生时间特重载

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException
另请参见：
WCMObj.insert(User _currUser)

findById

public static final DocReply findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final DocReply createNewInstance()
                                        throws WCMException
产生当前对象[DocReply]的实例

返回：
当前对象的实例[DocReply]
抛出：
WCMException

findByKey

public static final DocReply findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocReplys

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocReplys

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.DocReplys

public class DocReplys
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
DocReplys(User _currUser)
DocReplys(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static DocReplys | createNewInstance(User _currUser) 产生一个当前集合对象[DocReplys]的实例
static DocReplys | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static DocReplys | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocReplys]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocReplys

public DocReplys(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

DocReplys

public DocReplys(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final DocReplys findByIds(User _currUser,
                                        java.lang.String _sIds)
                                 throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final DocReplys openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[DocReplys]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[DocReplys]
抛出：
WCMException

createNewInstance

public static DocReplys createNewInstance(User _currUser)
                                   throws WCMException
产生一个当前集合对象[DocReplys]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Document

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Document

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.Document
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
DocBak, WCMExcelData
public class Document
extends CMSObj

字段摘要
static int[] | ALL_TYPES 所有文档类型
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | DOC_FORM_AUDIO
static int | DOC_FORM_LITERY
static int | DOC_FORM_PIC
static int | DOC_FORM_UNKNOWN
static int | DOC_FORM_VIDEO
static int | DOC_TYPE_FILE
static int | DOC_TYPE_HTML
static int | DOC_TYPE_LINK
static int | DOC_TYPE_NORMAL
static boolean | DOCUMENTS_GET_OPTIMIZE
static int | FLAG_DEFAULT 文档标志：默认文档 0
static int | FLAG_UNKNOWN 文档标志：未知
static int | FLAG_USER_DEFINE 文档标志：用户自定义的起始值 20
boolean | g_bXMLforTRS
static int | GET_RELATEDDOC_BY_ALL 取相关文档时所用的类型：任意类型的相关
static int | GET_RELATEDDOC_BY_KEYWORDS 取相关文档时所用的类型：通过关键字
static int | GET_RELATEDDOC_BY_RELATION 取相关文档时所用的类型：通过相关表
static int | GET_RELATEDDOC_BY_RELWORDS 取相关文档时所用的类型：通过相关词
boolean | m_bXMLOnlySelf
static int | OBJ_TYPE 对象类型（605）
static boolean | SYNCHRONIZE_PROPERTIES_TO_CHNLDOC 是否通过WCMDocument中的数据到WCMChnlDoc中
static java.lang.String[] | SYNCHRONIZED_FIELDS
static int | TYPE_FILE 文档类型：外部文件
static int | TYPE_HTML 文档类型：HTML文档
static int | TYPE_LINK 文档类型：链接文档
static int | TYPE_NORMAL 文档类型：纯文本
static int | TYPE_UNKNOWN 文档类型：未知
构造方法摘要
Document()
构造函数：保留默认接口
方法摘要
BaseObj | cloneToNewWCMObj()
static Document | createNewInstance() 产生当前对象[Document]的实例
int | delete() 建议使用delete(User)
int | delete(User _currUser) 从数据中删除对象信息
static Document | findById(int _nId) 提取指定ID的对象
static Document | findById(int _nId, java.lang.String _sSelectFields)
static Document | findById(int _nId, java.lang.String _sSelectFields, java.lang.String _sTableName)
static Document | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAbstract() 获取摘要
User | getAuditor() 获取审稿者(可能有多个)
java.lang.String | getAuditorName() 获取审稿者(可能有多个)
java.lang.String | getAuthorName() 获取作者
Channel | getChannel() 取文档所属频道对象
int | getChannelId() 取使用此文档的所在的频道
java.lang.String | getChannelName() 获取所属栏目
java.lang.String | getContent() 获取文档的文本正文
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
int | getDocId()
User | getEditor() 获取修改者
java.lang.String | getEditorName() 获取修改者名称
int | getFlag() 获取文档标志 目前系统只支持一种风格（对外发布的文档），其余风格的文档可在二次开发中定义
int | getFromVersion() 获取文档是从哪个版本恢复回来的 如果没有备份过，则返回0
int | getHitsCount() 获取文档的点击数
java.lang.String | getHtmlContent() 获取文档的Html文本
java.lang.String | getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute) 文档HTML内容过滤处理，用于文档HTML正文的显示处理 处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于： [1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?
java.lang.String | getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute, boolean _bFromPubHTMLContent)
java.util.List | getHTMLFiles() 获取当前文档所包含的HTML文件列表
java.util.List | getHTMLWCMFiles()
java.util.List | getHTMLWCMFiles(boolean _bFromPubHTMLContent)
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getKeywords() 获取关键词
DocKind | getKind() 获取文档分类对象
int | getKindId() 获取文档分类ID
java.lang.String | getOtherTableName()
int | getOutUpId() 获取外部上传ID
java.lang.String | getPeople() 获取人物
java.lang.String | getPlace() 获取地点
java.lang.String | getPubHtmlContent() 获取文档的Html文本
static CMyDateTime | getPubPathStartTime() 获取发布文件按照日期存放的起始时间
CMyDateTime | getPubTime() 获取发布时间
java.lang.String | getPubURL() 获取文档发布后的地址
java.lang.String | getRandomSerial()
java.lang.String | getRelateWords() 获取相关词（用于相关文档搜索）
CMyDateTime | getReleaseTime() 获取撰写时间
Security | getSecurity() 获取安全级别
int | getSecurityId() 获取安全级别
Source | getSource() 获取文档来源
int | getSourceId() 获取文档来源
Status | getStatus() 获取文档状态
int | getStatusId() 获取文档状态
java.lang.String | getStatusName() 获取状态名称
java.lang.String | getSubTitle() 获取文档副标题
java.lang.String | getTitle() 获取文档标题
java.lang.String | getTitleColor() 获取标题颜色
int | getType() 获取文档类型
java.lang.String | getTypeString() 获取文档类型描述
static java.lang.String | getTypeString(int _nType) 静态函数：取文档类型名称
CMyDateTime | getValidTime() 获取文档的有效时间
int | getVersion() 获取文档的版本号
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
int | getWordsCount() 获取正文字数
boolean | hasDocPro(int _nIndex)
void | insertOtherTable(User _currUser, java.lang.String _sTableName)
boolean | isAttachPic()
boolean | isDeleted() 判断文档是否已经被删除
boolean | isDocumentObject()
boolean | isDoDelete() 判断文档是否正在进行删除的操作 即判断文档是否从未删除状态变为了已删除状态 实际的判断逻辑是：如果前后状态的乘积小于0，且文档原先不是已删除状态，则为正在删除
boolean | isDoMove() 判断文档是否正在进移动的操作 即判断文档频道是否发生了修改
boolean | isDoRecover() 判断文档是否正在进行从回收站中恢复的操作 即判断文档是否从已删除状态变为了未删除状态 实际的判断逻辑是：如果前后状态的乘积小于0，且文档原先是已删除状态，则为正在恢复
boolean | isDraft() hanxiao@041012 判断文档是否是草稿
boolean | isOutUp() 判别文档是否来自外部上传
boolean | isRightDefined() 判断是否单独定义了用户的权限
boolean | isSavePubFileByTime()
boolean | isValid() 检查对象数据的有效性
boolean | isValidInstance() 检测当前对象是否是一个已经存在的实例对象
boolean | logicalDelete(User _currUser) 逻辑删除
boolean | logicalUndelete(User _currUser) 恢复文档
static void | main(java.lang.String[] args)
boolean | setAbstract(java.lang.String _abstract) 设置摘要
boolean | setAttachPic(boolean _bAttachPic)
boolean | setAuditor(java.lang.String _auditorName) 设置审稿者(可能有多个)
boolean | setAuditor(User _auditor) 设置审稿者(可能有多个)
boolean | setAuthor(java.lang.String _authorName) 设置作者
boolean | setChannel(Channel _channel) 设置文档所属频道
boolean | setChannel(int _channelId) 设置文档所属频道
boolean | setContent(java.lang.String _content) 设置文档的文本正文
void | setDbTableName(java.lang.String _sTableName) 设置当前对象相关的数据表名
boolean | setDeleted(boolean _bDeleted) 将文档设为已删除状态 说明：对于正常状态下的文档，setDeleted( true )将文档改为已删除（逻辑删除）； 对于已删除的文档，setDeleted( false )将文档恢复为正常状态
void | setDocPro(int _nIndex, boolean _bValue)
boolean | setEditor(java.lang.String _editorName) 设置修改者
boolean | setEditor(User _editor) 设置修改者
boolean | setFlag(int _flag) 设置文档标志 目前系统只支持一种风格（对外发布的文档），其余风格的文档可在二次开发中定义
boolean | setFromVersion(int _nFromVersion) 设置文档是从哪个版本恢复回来的
boolean | setHitsCount(int _hitsCount) 设置文档的点击数
boolean | setHtmlContent(java.lang.String _sHtmlContent)
void | setId(int _nId) 设置对象ID
boolean | setKeywords(java.lang.String _keywords) 设置关键词
boolean | setKind(DocKind _docKind) 设置文档分类
boolean | setKind(int _kindId) 设置文档分类
void | setMyDocId(int _id) 文档HTML内容过滤处理，用于文档HTML正文的显示处理 处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于： [1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?
boolean | setOtherTableName(java.lang.String _sOtherTableName)
boolean | setOutUpId(int _outUpId) 设置外部上传ID
boolean | setPeople(java.lang.String _people) 设置人物
boolean | setPlace(java.lang.String _place) 设置地点
boolean | setPubHtmlContent(java.lang.String _htmlContent) 设置文档的Html文本
static void | setPubPathStartTime(CMyDateTime _dtStart) 设置发布文件按照日期存放的起始时间
boolean | setPubTime(CMyDateTime _pubTime) 设置发布时间
boolean | setPubURL(java.lang.String _pubUrl) 设置文档发布后的地址
boolean | setRandomSerial(java.lang.String randomSerial)
boolean | setRelateWords(java.lang.String _relateWords) 设置相关词（用于相关文档搜索）
boolean | setReleaseTime(CMyDateTime _releaseTime) 设置撰写时间
boolean | setRightDefined(boolean _bSysDefined) 设置是否单独定义了用户的权限属性
boolean | setSecurity(int _securityId) 设置安全级别
boolean | setSecurity(Security _security) 设置安全级别
boolean | setSource(int _sourceId) 设置文档来源
boolean | setSource(Source _source) 设置文档来源
boolean | setStatus(int _statusId) 设置文档状态
boolean | setStatus(Status _status) 设置文档状态
boolean | setStatus(Status _status, boolean _bDeleted) 设置文档状态
boolean | setSubTitle(java.lang.String _title) 设置文档副标题
boolean | setTitle(java.lang.String _title) 设置文档标题
boolean | setTitleColor(java.lang.String _titleColor) 设置标题颜色
boolean | setType(int _type) 设置文档类型
boolean | setValidTime(CMyDateTime _valid) 设置文档的有效时间
boolean | setVersion(int _nVersion) 设置文档的版本号
java.lang.String | toString()
void | updateHitsCount(User _currUser) 需要改变频道的名称，故重载toXMLElement接口
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SYNCHRONIZE_PROPERTIES_TO_CHNLDOC

public static boolean SYNCHRONIZE_PROPERTIES_TO_CHNLDOC
是否通过WCMDocument中的数据到WCMChnlDoc中

DOCUMENTS_GET_OPTIMIZE

public static boolean DOCUMENTS_GET_OPTIMIZE

SYNCHRONIZED_FIELDS

public static java.lang.String[] SYNCHRONIZED_FIELDS

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（605）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

TYPE_UNKNOWN

public static final int TYPE_UNKNOWN
文档类型：未知

另请参见：
常量字段值

TYPE_NORMAL

public static final int TYPE_NORMAL
文档类型：纯文本

另请参见：
常量字段值

TYPE_HTML

public static final int TYPE_HTML
文档类型：HTML文档

另请参见：
常量字段值

TYPE_LINK

public static final int TYPE_LINK
文档类型：链接文档

另请参见：
常量字段值

TYPE_FILE

public static final int TYPE_FILE
文档类型：外部文件

另请参见：
常量字段值

DOC_TYPE_NORMAL

public static final int DOC_TYPE_NORMAL
另请参见：
常量字段值

DOC_TYPE_HTML

public static final int DOC_TYPE_HTML
另请参见：
常量字段值

DOC_TYPE_LINK

public static final int DOC_TYPE_LINK
另请参见：
常量字段值

DOC_TYPE_FILE

public static final int DOC_TYPE_FILE
另请参见：
常量字段值

DOC_FORM_UNKNOWN

public static final int DOC_FORM_UNKNOWN
另请参见：
常量字段值

DOC_FORM_LITERY

public static final int DOC_FORM_LITERY
另请参见：
常量字段值

DOC_FORM_PIC

public static final int DOC_FORM_PIC
另请参见：
常量字段值

DOC_FORM_AUDIO

public static final int DOC_FORM_AUDIO
另请参见：
常量字段值

DOC_FORM_VIDEO

public static final int DOC_FORM_VIDEO
另请参见：
常量字段值

FLAG_UNKNOWN

public static final int FLAG_UNKNOWN
文档标志：未知

另请参见：
常量字段值

FLAG_DEFAULT

public static final int FLAG_DEFAULT
文档标志：默认文档 0

另请参见：
常量字段值

FLAG_USER_DEFINE

public static final int FLAG_USER_DEFINE
文档标志：用户自定义的起始值 20

另请参见：
常量字段值

ALL_TYPES

public static final int[] ALL_TYPES
所有文档类型

GET_RELATEDDOC_BY_ALL

public static final int GET_RELATEDDOC_BY_ALL
取相关文档时所用的类型：任意类型的相关

另请参见：
常量字段值

GET_RELATEDDOC_BY_KEYWORDS

public static final int GET_RELATEDDOC_BY_KEYWORDS
取相关文档时所用的类型：通过关键字

另请参见：
常量字段值

GET_RELATEDDOC_BY_RELWORDS

public static final int GET_RELATEDDOC_BY_RELWORDS
取相关文档时所用的类型：通过相关词

另请参见：
常量字段值

GET_RELATEDDOC_BY_RELATION

public static final int GET_RELATEDDOC_BY_RELATION
取相关文档时所用的类型：通过相关表

另请参见：
常量字段值

g_bXMLforTRS

public boolean g_bXMLforTRS

m_bXMLOnlySelf

public boolean m_bXMLOnlySelf
构造方法详细信息

Document

public Document()
构造函数：保留默认接口

方法详细信息

getTypeString

public static java.lang.String getTypeString(int _nType)
静态函数：取文档类型名称

参数：
_nType - 文档类型
返回：
文档类型名称

setDbTableName

public void setDbTableName(java.lang.String _sTableName)
设置当前对象相关的数据表名

参数：
_sTableName - 相关的数据表名

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getDocId

public int getDocId()

isDeleted

public boolean isDeleted()
判断文档是否已经被删除

返回：

setDeleted

public boolean setDeleted(boolean _bDeleted)
                   throws WCMException

将文档设为已删除状态

说明：对于正常状态下的文档，setDeleted( true )将文档改为已删除（逻辑删除）；

对于已删除的文档，setDeleted( false )将文档恢复为正常状态

参数：
_bDeleted - 是否删除
返回：
抛出：
WCMException

getStatusId

public int getStatusId()
获取文档状态

返回：
文档状态ID（注意：删除的稿件，状态为负值）

getStatus

public Status getStatus()
                 throws WCMException
获取文档状态

返回：
文档状态对象
抛出：
WCMException

getStatusName

public java.lang.String getStatusName()
                               throws WCMException
获取状态名称

返回：
状态名称(String)
抛出：
WCMException - 如果从缓冲区获取数据失败，会抛出异常

setStatus

public boolean setStatus(int _statusId)
                  throws WCMException
设置文档状态

参数：
_statusId - 文档状态ID
返回：
抛出：
WCMException

setStatus

public boolean setStatus(Status _status)
                  throws WCMException
设置文档状态

参数：
_status - 文档状态对象
返回：
抛出：
WCMException

setStatus

public boolean setStatus(Status _status,
                         boolean _bDeleted)
                  throws WCMException
设置文档状态

参数：
_status - 文档状态对象
_bDeleted - 文档是否已经被删除
返回：
抛出：
WCMException

getSecurityId

public int getSecurityId()
获取安全级别

返回：
安全级别ID

getSecurity

public Security getSecurity()
                     throws WCMException
获取安全级别

返回：
安全级别对象
抛出：
WCMException

setSecurity

public boolean setSecurity(int _securityId)
                    throws WCMException
设置安全级别

参数：
_securityId - 安全级别ID
返回：
抛出：
WCMException

setSecurity

public boolean setSecurity(Security _security)
                    throws WCMException
设置安全级别

参数：
_security - 安全级别对象
返回：
抛出：
WCMException

getChannelId

public int getChannelId()
取使用此文档的所在的频道

返回：

getChannel

public Channel getChannel()
                   throws WCMException
取文档所属频道对象

返回：
文档所属频道对象
抛出：
WCMException

getChannelName

public java.lang.String getChannelName()
                                throws WCMException
获取所属栏目

返回：
所属栏目名称(String)
抛出：
WCMException

setChannel

public boolean setChannel(int _channelId)
                   throws WCMException
设置文档所属频道

参数：
_channelId - 文档所属频道ID
返回：
抛出：
WCMException

setChannel

public boolean setChannel(Channel _channel)
                   throws WCMException
设置文档所属频道

参数：
_channel - 文档所属频道对象
返回：
抛出：
WCMException

getSourceId

public int getSourceId()
获取文档来源

返回：
文档来源对象ID

getSource

public Source getSource()
                 throws WCMException
获取文档来源

返回：
文档来源对象
抛出：
WCMException

setSource

public boolean setSource(int _sourceId)
                  throws WCMException
设置文档来源

参数：
_sourceId - 文档来源ID
返回：
抛出：
WCMException

setSource

public boolean setSource(Source _source)
                  throws WCMException
设置文档来源

参数：
_source - 文档来源对象
返回：
抛出：
WCMException

getValidTime

public CMyDateTime getValidTime()
获取文档的有效时间

返回：
文档的有效时间

setValidTime

public boolean setValidTime(CMyDateTime _valid)
                     throws WCMException
设置文档的有效时间

参数：
_valid - 文档的有效时间
返回：
抛出：
WCMException

getEditorName

public java.lang.String getEditorName()
获取修改者名称

返回：

getEditor

public User getEditor()
获取修改者

返回：
修改者对象（User）

setEditor

public boolean setEditor(java.lang.String _editorName)
                  throws WCMException
设置修改者

参数：
_editorName - 修改者名称
返回：
抛出：
WCMException

setEditor

public boolean setEditor(User _editor)
                  throws WCMException
设置修改者

参数：
_editor - 修改者对象
返回：
抛出：
WCMException

getAuditorName

public java.lang.String getAuditorName()
获取审稿者(可能有多个)

返回：
审稿者名称

getAuditor

public User getAuditor()
获取审稿者(可能有多个)

返回：
审稿者对象

setAuditor

public boolean setAuditor(java.lang.String _auditorName)
                   throws WCMException
设置审稿者(可能有多个)

参数：
_auditorName - 审稿者用户名
返回：
抛出：
WCMException

setAuditor

public boolean setAuditor(User _auditor)
                   throws WCMException
设置审稿者(可能有多个)

参数：
_auditor - 审稿者对象
返回：
抛出：
WCMException

getFlag

public int getFlag()
获取文档标志

目前系统只支持一种风格（对外发布的文档），其余风格的文档可在二次开发中定义

返回：
文档标志

setFlag

public boolean setFlag(int _flag)
                throws WCMException
设置文档标志

目前系统只支持一种风格（对外发布的文档），其余风格的文档可在二次开发中定义

参数：
_flag - 文档标志
返回：
抛出：
WCMException

getHitsCount

public int getHitsCount()
获取文档的点击数

返回：
文档的点击数

setHitsCount

public boolean setHitsCount(int _hitsCount)
                     throws WCMException
设置文档的点击数

参数：
_hitsCount - 文档的点击数
返回：
抛出：
WCMException

getType

public int getType()
获取文档类型

返回：
文档类型

getTypeString

public java.lang.String getTypeString()
获取文档类型描述

返回：
文档类型描述

setType

public boolean setType(int _type)
                throws WCMException
设置文档类型

参数：
_type - 文档类型（Document.TYPE_NORMAL等）
返回：
抛出：
WCMException - 1、如果不是（TYPE_NORMAL、TYPE_HTML、TYPE_LINK。TYPE_FILE）中任何一种将会抛出异常

getKindId

public int getKindId()
获取文档分类ID

返回：

getKind

public DocKind getKind()
                throws WCMException
获取文档分类对象

返回：
文档分类对象
抛出：
WCMException

setKind

public boolean setKind(int _kindId)
                throws WCMException
设置文档分类

参数：
_kindId - 文档分类ID
返回：
抛出：
WCMException

setKind

public boolean setKind(DocKind _docKind)
                throws WCMException
设置文档分类

参数：
_docKind - 文档分类对象
返回：
抛出：
WCMException

getTitle

public java.lang.String getTitle()
获取文档标题

返回：
文档标题

setTitle

public boolean setTitle(java.lang.String _title)
                 throws WCMException
设置文档标题

参数：
_title - 文档标题
返回：
抛出：
WCMException

getSubTitle

public java.lang.String getSubTitle()
获取文档副标题

返回：
文档副标题

setSubTitle

public boolean setSubTitle(java.lang.String _title)
                    throws WCMException
设置文档副标题

参数：
_title - 文档副标题
返回：
抛出：
WCMException

getTitleColor

public java.lang.String getTitleColor()
获取标题颜色

返回：
标题颜色

setTitleColor

public boolean setTitleColor(java.lang.String _titleColor)
                      throws WCMException
设置标题颜色

参数：
_titleColor - 标题颜色
返回：
抛出：
WCMException

getPeople

public java.lang.String getPeople()
获取人物

返回：
人物

setPeople

public boolean setPeople(java.lang.String _people)
                  throws WCMException
设置人物

参数：
_people - 人物
返回：
抛出：
WCMException

getPlace

public java.lang.String getPlace()
获取地点

返回：
地点

setPlace

public boolean setPlace(java.lang.String _place)
                 throws WCMException
设置地点

参数：
_place - 地点
返回：
抛出：
WCMException

getAuthorName

public java.lang.String getAuthorName()
获取作者

返回：
作者

setAuthor

public boolean setAuthor(java.lang.String _authorName)
                  throws WCMException
设置作者

参数：
_authorName - 作者
返回：
抛出：
WCMException

getPubURL

public java.lang.String getPubURL()
获取文档发布后的地址

返回：

setPubURL

public boolean setPubURL(java.lang.String _pubUrl)
                  throws WCMException
设置文档发布后的地址

参数：
_pubUrl - 文档发布后的地址
返回：
文档发布后的地址
抛出：
WCMException

getContent

public java.lang.String getContent()
获取文档的文本正文

返回：
文档的文本正文

setContent

public boolean setContent(java.lang.String _content)
                   throws WCMException
设置文档的文本正文

参数：
_content - 文档的文本正文
返回：
抛出：
WCMException

getWordsCount

public int getWordsCount()
获取正文字数

返回：
正文字数

getHtmlContent

public java.lang.String getHtmlContent()
获取文档的Html文本

返回：
文档的Html文本

setHtmlContent

public boolean setHtmlContent(java.lang.String _sHtmlContent)
                       throws WCMException
抛出：
WCMException

getAbstract

public java.lang.String getAbstract()
获取摘要

返回：
摘要

setAbstract

public boolean setAbstract(java.lang.String _abstract)
                    throws WCMException
设置摘要

参数：
_abstract - 摘要
返回：
抛出：
WCMException

getKeywords

public java.lang.String getKeywords()
获取关键词

返回：
关键词

setKeywords

public boolean setKeywords(java.lang.String _keywords)
                    throws WCMException
设置关键词

参数：
_keywords - 关键词
返回：
抛出：
WCMException

getRelateWords

public java.lang.String getRelateWords()
获取相关词（用于相关文档搜索）

返回：
相关词

setRelateWords

public boolean setRelateWords(java.lang.String _relateWords)
                       throws WCMException
设置相关词（用于相关文档搜索）

参数：
_relateWords - 相关词
返回：
抛出：
WCMException

getPubTime

public CMyDateTime getPubTime()
获取发布时间

返回：
发布时间

setPubTime

public boolean setPubTime(CMyDateTime _pubTime)
                   throws WCMException
设置发布时间

参数：
_pubTime - 发布时间
返回：
抛出：
WCMException

getReleaseTime

public CMyDateTime getReleaseTime()
获取撰写时间

返回：
撰写时间

setReleaseTime

public boolean setReleaseTime(CMyDateTime _releaseTime)
                       throws WCMException
设置撰写时间

参数：
_releaseTime - 撰写时间
返回：
抛出：
WCMException

getOutUpId

public int getOutUpId()
获取外部上传ID

返回：

setOutUpId

public boolean setOutUpId(int _outUpId)
                   throws WCMException
设置外部上传ID

参数：
_outUpId - 外部上传ID
返回：
抛出：
WCMException

isOutUp

public boolean isOutUp()
判别文档是否来自外部上传

返回：

getVersion

public int getVersion()
获取文档的版本号

返回：

setVersion

public boolean setVersion(int _nVersion)
                   throws WCMException
设置文档的版本号

参数：
_nVersion - 文档的版本号
返回：
抛出：
WCMException

isRightDefined

public boolean isRightDefined()
判断是否单独定义了用户的权限

返回：

setRightDefined

public boolean setRightDefined(boolean _bSysDefined)
                        throws WCMException
设置是否单独定义了用户的权限属性

参数：
_bSysDefined - 是否单独定义了用户的权限
返回：
抛出：
WCMException

isAttachPic

public boolean isAttachPic()

setAttachPic

public boolean setAttachPic(boolean _bAttachPic)
                     throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 新增模式下 ： 1、没有设置文档所属频道 2、没有设置文档标题
另请参见：
WCMObj.isValid()

isDraft

public boolean isDraft()
hanxiao@041012 判断文档是否是草稿

返回：
抛出：
WCMException

isDocumentObject

public boolean isDocumentObject()

logicalDelete

public boolean logicalDelete(User _currUser)
                      throws WCMException
逻辑删除

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

logicalUndelete

public boolean logicalUndelete(User _currUser)
                        throws WCMException
恢复文档

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

updateHitsCount

public void updateHitsCount(User _currUser)
                     throws java.lang.Exception
需要改变频道的名称，故重载toXMLElement接口

抛出：
java.lang.Exception
另请参见：
Element toXMLElement( String _sFieldsList ) throws WCMException

setMyDocId

public void setMyDocId(int _id)
文档HTML内容过滤处理，用于文档HTML正文的显示处理

处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src

可以用于：
[1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?File=", false );
[2]文档HTML正文的预览： 使用 getTextWithImgFilter( "show-pic.jsp?File=", true );
[3]文档HTML正文的解析： 使用 getTextWithImgFilter( getApdFilePubHttpPath(), true );

参数：
_sImgSrcPre - 用于构造图片src的前部分；如： show-pic.jsp?File=
_bRemoveExtraAttribute - 是否需要删除图片额外的属性（如：OLDSRC, OLDID，REALATED等）
抛出：
WCMException - Html文本处理中可能会抛出异常

getPubHtmlContent

public java.lang.String getPubHtmlContent()
获取文档的Html文本

返回：
文档的Html文本

setPubHtmlContent

public boolean setPubHtmlContent(java.lang.String _htmlContent)
                          throws WCMException
设置文档的Html文本

参数：
_htmlContent - 文档的Html文本
返回：
抛出：
WCMException

getHtmlContentWithImgFilter

public java.lang.String getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre,
                                                    boolean _bRemoveExtraAttribute)
                                             throws WCMException
文档HTML内容过滤处理，用于文档HTML正文的显示处理

处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src

可以用于：
[1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?File=", false );
[2]文档HTML正文的预览： 使用 getTextWithImgFilter( "show-pic.jsp?File=", true );
[3]文档HTML正文的解析： 使用 getTextWithImgFilter( getApdFilePubHttpPath(), true );

参数：
_sImgSrcPre - 用于构造图片src的前部分；如： show-pic.jsp?File=
_bRemoveExtraAttribute - 是否需要删除图片额外的属性（如：OLDSRC, OLDID，REALATED等）
返回：
过滤处理后的Html文本
抛出：
WCMException - Html文本处理中可能会抛出异常

getHtmlContentWithImgFilter

public java.lang.String getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre,
                                                    boolean _bRemoveExtraAttribute,
                                                    boolean _bFromPubHTMLContent)
                                             throws WCMException
抛出：
WCMException

getHTMLFiles

public java.util.List getHTMLFiles()
                            throws WCMException
获取当前文档所包含的HTML文件列表

返回：
当前文档所包含的HTML文件列表（List）
抛出：
WCMException

getHTMLWCMFiles

public java.util.List getHTMLWCMFiles()
                               throws WCMException
抛出：
WCMException

getHTMLWCMFiles

public java.util.List getHTMLWCMFiles(boolean _bFromPubHTMLContent)
                               throws WCMException
抛出：
WCMException

setId

public void setId(int _nId)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId

isValidInstance

public boolean isValidInstance()
检测当前对象是否是一个已经存在的实例对象

覆盖：
类 BaseObj 中的 isValidInstance
返回：

isSavePubFileByTime

public boolean isSavePubFileByTime()

getPubPathStartTime

public static CMyDateTime getPubPathStartTime()
获取发布文件按照日期存放的起始时间

返回：
发布文件按照日期存放的起始时间

setPubPathStartTime

public static void setPubPathStartTime(CMyDateTime _dtStart)
设置发布文件按照日期存放的起始时间

参数：
_dtStart - 发布文件按照日期存放的起始时间

hasDocPro

public boolean hasDocPro(int _nIndex)

setDocPro

public void setDocPro(int _nIndex,
                      boolean _bValue)
               throws WCMException
抛出：
WCMException

cloneToNewWCMObj

public BaseObj cloneToNewWCMObj()
                         throws WCMException
覆盖：
类 BaseObj 中的 cloneToNewWCMObj
返回：
抛出：
WCMException

findById

public static Document findById(int _nId)
                         throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findById

public static Document findById(int _nId,
                                java.lang.String _sSelectFields)
                         throws WCMException
抛出：
WCMException

findById

public static Document findById(int _nId,
                                java.lang.String _sSelectFields,
                                java.lang.String _sTableName)
                         throws WCMException
抛出：
WCMException

createNewInstance

public static Document createNewInstance()
                                  throws WCMException
产生当前对象[Document]的实例

返回：
当前对象的实例[Document]
抛出：
WCMException

findByKey

public static Document findByKey(java.lang.Object _oKey)
                          throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

main

public static void main(java.lang.String[] args)

isDoDelete

public boolean isDoDelete()
判断文档是否正在进行删除的操作
即判断文档是否从未删除状态变为了已删除状态
实际的判断逻辑是：如果前后状态的乘积小于0，且文档原先不是已删除状态，则为正在删除

返回：
true:正在删除，false:不是正删除状态

isDoRecover

public boolean isDoRecover()
判断文档是否正在进行从回收站中恢复的操作
即判断文档是否从已删除状态变为了未删除状态
实际的判断逻辑是：如果前后状态的乘积小于0，且文档原先是已删除状态，则为正在恢复

返回：
true:正在恢复，false:不是正恢复状态

isDoMove

public boolean isDoMove()
判断文档是否正在进移动的操作
即判断文档频道是否发生了修改

返回：
true:正在移动，false:不是正在移动

getFromVersion

public int getFromVersion()
获取文档是从哪个版本恢复回来的
如果没有备份过，则返回0

返回：

setFromVersion

public boolean setFromVersion(int _nFromVersion)
                       throws WCMException
设置文档是从哪个版本恢复回来的

参数：
_nFromVersion - 恢复的DocBak的版本
返回：
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

delete

public int delete()
           throws WCMException
从类 CMSObj 复制的描述
建议使用delete(User)

覆盖：
类 CMSObj 中的 delete
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

delete

public int delete(User _currUser)
           throws WCMException
从类 CMSObj 复制的描述
从数据中删除对象信息

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

setOtherTableName

public boolean setOtherTableName(java.lang.String _sOtherTableName)
                          throws WCMException
抛出：
WCMException

getOtherTableName

public java.lang.String getOtherTableName()

insertOtherTable

public void insertOtherTable(User _currUser,
                             java.lang.String _sTableName)
                      throws WCMException
抛出：
WCMException

setRandomSerial

public boolean setRandomSerial(java.lang.String randomSerial)
                        throws WCMException
参数：
randomSerial -
抛出：
WCMException

getRandomSerial

public java.lang.String getRandomSerial()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentFieldConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocumentFieldConfig

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.DocumentFieldConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class DocumentFieldConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentFieldConfig()
方法摘要
java.lang.String | getDesc()
java.lang.String | getFields()
int | getImport()
java.lang.String | getName() 获取配置对象的名称
int | getType()
void | setDesc(java.lang.String _sDesc)
void | setFields(java.lang.String _sFields)
void | setImport(int _nImport)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setType(int _nType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentFieldConfig

public DocumentFieldConfig()
方法详细信息

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getFields

public java.lang.String getFields()

setFields

public void setFields(java.lang.String _sFields)

getDesc

public java.lang.String getDesc()

setDesc

public void setDesc(java.lang.String _sDesc)

getType

public int getType()

setType

public void setType(int _nType)

getImport

public int getImport()

setImport

public void setImport(int _nImport)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Documents

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Documents

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.Documents

public class Documents
extends CMSBaseObjs

字段摘要
 boolean m_bNotClearIdList
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Documents(User _currUser)
Documents(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
boolean | addElementById(int _id)
void | clear() 清空集合
static Documents | createNewInstance(User _currUser) 产生当前集合对象[Documents]的实例
static Documents | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
BaseObj | getAt(int _index) 通过指定索引获取对象
int | getCurrentStartIndex()
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
java.util.Vector | getIdList()
int | getRecCount() 获取本次查询的记录个数
void | insertOtherTable(User _currUser, java.lang.String _sTableName)
static void | main(java.lang.String[] args)
BaseObjs | newInstance() 生成新的集合对象实例
static Documents | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Documents]
void | setCurrentStartIndex(int _nCurrentStartIndex)
void | setDbTableName(java.lang.String _sTableName) 设置当前对象相关的数据表名
void | setIdList(java.util.Vector _vIdList, WCMFilter _filter, boolean _bNotClear)
void | setRecCount(int _nRecCount) 设置本次查询的记录个数
int | size() 获取集合的大小
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, createInstance, createInstance, filter, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setSelect, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

m_bNotClearIdList

public boolean m_bNotClearIdList
构造方法详细信息

Documents

public Documents(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

Documents

public Documents(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

setDbTableName

public void setDbTableName(java.lang.String _sTableName)
设置当前对象相关的数据表名

参数：
_sTableName - 相关的数据表名

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObjs 复制的描述
取对象数据存储的数据表名称

返回：
对象数据存储的数据表名称
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

addElementById

public boolean addElementById(int _id)
                       throws java.lang.Exception
抛出：
java.lang.Exception

setRecCount

public void setRecCount(int _nRecCount)
设置本次查询的记录个数

覆盖：
类 BaseObjs 中的 setRecCount
参数：
_nRecCount - 记录个数

getRecCount

public int getRecCount()
获取本次查询的记录个数

覆盖：
类 BaseObjs 中的 getRecCount

getCurrentStartIndex

public int getCurrentStartIndex()

setCurrentStartIndex

public void setCurrentStartIndex(int _nCurrentStartIndex)

size

public int size()
从类 BaseObjs 复制的描述
获取集合的大小

覆盖：
类 BaseObjs 中的 size
返回：

getAt

public BaseObj getAt(int _index)
从类 BaseObjs 复制的描述
通过指定索引获取对象

覆盖：
类 BaseObjs 中的 getAt
参数：
_index - 指定索引
返回：
WCMObj 元素对象

findByIds

public static final Documents findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Documents）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Documents openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[Documents]

参数：
_filter - 指定的Filter
返回：
当前集合[Documents]
抛出：
WCMException

createNewInstance

public static Documents createNewInstance(User _currUser)
产生当前集合对象[Documents]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

main

public static void main(java.lang.String[] args)

insertOtherTable

public void insertOtherTable(User _currUser,
                             java.lang.String _sTableName)
                      throws WCMException
抛出：
WCMException

getIdList

public java.util.Vector getIdList()

setIdList

public void setIdList(java.util.Vector _vIdList,
                      WCMFilter _filter,
                      boolean _bNotClear)

clear

public void clear()
从类 BaseObjs 复制的描述
清空集合

覆盖：
类 BaseObjs 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentShowFieldConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocumentShowFieldConfig

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.DocumentShowFieldConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class DocumentShowFieldConfig
extends java.lang.Object
implements IConfigElement

作者：
wyw

构造方法摘要
DocumentShowFieldConfig()
方法摘要
java.lang.String | getDesc()
java.lang.String | getFieldname()
java.lang.String | getName() 获取配置对象的名称
boolean | isRead()
boolean | isWrite()
void | setDesc(java.lang.String _sDesc)
void | setFieldname(java.lang.String _sFieldname)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setRead(boolean read)
void | setWrite(boolean write)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentShowFieldConfig

public DocumentShowFieldConfig()
方法详细信息

getDesc

public java.lang.String getDesc()

setDesc

public void setDesc(java.lang.String _sDesc)

getFieldname

public java.lang.String getFieldname()

setFieldname

public void setFieldname(java.lang.String _sFieldname)

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

isWrite

public boolean isWrite()

setWrite

public void setWrite(boolean write)

isRead

public boolean isRead()

setRead

public void setRead(boolean read)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentSubstanceImplBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocumentSubstanceImplBase

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase
所有已实现的接口：
ICMSObjSubstanceContent
直接已知子类：
DocumentRightHostImpl
public abstract class DocumentSubstanceImplBase
extends java.lang.Object
implements ICMSObjSubstanceContent

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentSubstanceImplBase()
DocumentSubstanceImplBase(CMSObj _cmsObj)
DocumentSubstanceImplBase(int _nId)
方法摘要
boolean | equals(java.lang.Object _another)
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentSubstanceImplBase

public DocumentSubstanceImplBase()

DocumentSubstanceImplBase

public DocumentSubstanceImplBase(int _nId)
                          throws WCMException
抛出：
WCMException

DocumentSubstanceImplBase

public DocumentSubstanceImplBase(CMSObj _cmsObj)
方法详细信息

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentSyn

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocumentSyn

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.DocumentSyn
所有已实现的接口：
java.lang.Cloneable
public class DocumentSyn
extends CMSObj

Title: TRS 内容协作平台（TRS WCM）
Description:
已经自动转发过的文档的记录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 数据表的ID字段名称
static java.lang.String | DB_TABLE_NAME 对象所使用的数据表
static int | OBJ_TYPE 对象类型
构造方法摘要
DocumentSyn()
默认的构造函数
方法摘要
static DocumentSyn | createNewInstance() 产生当前对象[TransmittedDoc]的实例
static DocumentSyn | findById(int _nId) 提取指定ID的对象
static DocumentSyn | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getChannelId()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
int | getDocumentId()
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setChannelId(int _nChannelId)
boolean | setDocumentId(int _nDocumentId)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所使用的数据表

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
数据表的ID字段名称

另请参见：
常量字段值
构造方法详细信息

DocumentSyn

public DocumentSyn()
默认的构造函数

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getChannelId

public int getChannelId()

setChannelId

public boolean setChannelId(int _nChannelId)
                     throws WCMException
抛出：
WCMException

getDocumentId

public int getDocumentId()

setDocumentId

public boolean setDocumentId(int _nDocumentId)
                      throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

findById

public static final DocumentSyn findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final DocumentSyn createNewInstance()
                                           throws WCMException
产生当前对象[TransmittedDoc]的实例

返回：
当前对象的实例[TransmittedDoc]
抛出：
WCMException

findByKey

public static final DocumentSyn findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentSyns

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocumentSyns

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.DocumentSyns

public class DocumentSyns
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
已经转发过的文档记录集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
DocumentSyns(User _currUser)
DocumentSyns(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static DocumentSyns | createNewInstance(User _currUser) 产生当前集合对象[TransmittedDocs]的实例
static DocumentSyns | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static DocumentSyns | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TransmittedDocs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentSyns

public DocumentSyns(User _currUser)

DocumentSyns

public DocumentSyns(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final DocumentSyns findByIds(User _currUser,
                                           java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（TransmittedDocs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final DocumentSyns openWCMObjs(User _currUser,
                                             WCMFilter _filter)
                                      throws WCMException
通过指定一个Filter获取当前集合[TransmittedDocs]

参数：
_filter - 指定的Filter
返回：
当前集合[TransmittedDocs]
抛出：
WCMException

createNewInstance

public static DocumentSyns createNewInstance(User _currUser)
产生当前集合对象[TransmittedDocs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 DocumentXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.components.wcm.content.persistent.DocumentXmlConverter

public class DocumentXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
负责和Document以XML方式导入、导出的方法
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentXmlConverter()
方法摘要
boolean | isWithAppendix()
void | setWithAppendix(boolean withAppendix)
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentXmlConverter

public DocumentXmlConverter()
方法详细信息

isWithAppendix

public boolean isWithAppendix()
返回：

setWithAppendix

public void setWithAppendix(boolean withAppendix)
参数：
withAppendix -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsCount

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 HitsCount

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.HitsCount
所有已实现的接口：
java.lang.Cloneable
public class HitsCount
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
HitsCount()
构造函数：保留默认接口
方法摘要
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getObjId() 提取属性：ObjId
int | getObjType() 提取属性：ObjType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setObjId(int _nObjId) 设置属性：ObjId
boolean | setObjType(int _nObjType) 设置属性：ObjType
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

HitsCount

public HitsCount()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getObjType

public int getObjType()
提取属性：ObjType

返回：
ObjType

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
设置属性：ObjType

参数：
ObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

public int getObjId()
提取属性：ObjId

返回：
ObjId

setObjId

public boolean setObjId(int _nObjId)
                 throws WCMException
设置属性：ObjId

参数：
ObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HitsCounts

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 HitsCounts

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.HitsCounts

public class HitsCounts
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
HitsCounts(User _currUser)
构造函数
HitsCounts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HitsCounts

public HitsCounts(User _currUser)
构造函数

另请参见：
HitsCounts( User _currUser, int _initCapacity, int _incCapacity );

HitsCounts

public HitsCounts(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IChannelNameMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
接口 IChannelNameMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
ChannelNameMgr
public interface IChannelNameMgr
extends ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
频道名称缓冲管理对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 Channel findByName(int p_nSiteId, java.lang.String p_sName)
提取指定站点、指定名称的频道
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

findByName

Channel findByName(int p_nSiteId,
                   java.lang.String p_sName)
                   throws WCMException
提取指定站点、指定名称的频道

参数：
p_nSiteId - 站点ID
p_sName - 频道名称
返回：
频道对象
抛出：
WCMException - 提取频道失败会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IChildrenMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
接口 IChildrenMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
ChildrenCacheMgr
public interface IChildrenMgr
extends ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
子频道获取管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
Channel | getChildAt(BaseChannel _parent, int _nIndex)
int | getChildrenSize(User _currUser, BaseChannel _parent) 获取当前站点/频道的子频道数目
int | getSiblingIndex(BaseChannel _channel) 获取指定频道/站点在其同级目录中的位置
java.util.List | listChildren(User _currUser, BaseChannel _parent, int _nType) 获取子频道列表
java.util.List | listChildren(User _currUser, BaseChannel _parent, int[] _arrayTypes) 获取子频道列表
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

getChildrenSize

int getChildrenSize(User _currUser,
                    BaseChannel _parent)
                    throws WCMException
获取当前站点/频道的子频道数目

参数：
_currUser - 当前登录用户
_parent - 当前站点/频道
返回：
@throws WCMException
抛出：
WCMException

listChildren

java.util.List listChildren(User _currUser,
                            BaseChannel _parent,
                            int _nType)
                            throws WCMException
获取子频道列表

参数：
_currUser - 当前登录用户
_parent - 父频道(站点)
_nType - 子频道类型(Channel.TYPE_NORM等)
_bIncludingDeleted - 结果集中是否包含逻辑删除的子频道
返回：
@throws WCMException
抛出：
WCMException

listChildren

java.util.List listChildren(User _currUser,
                            BaseChannel _parent,
                            int[] _arrayTypes)
                            throws WCMException
获取子频道列表

参数：
_currUser - 当前登录用户
_parent - 父频道(站点)
_arrayTypes - 子频道类型(Channel.TYPE_NORM等构成的int数组)
_bIncludingDeleted - 结果集中是否包含逻辑删除的子频道
返回：
@throws WCMException
抛出：
WCMException

getChildAt

Channel getChildAt(BaseChannel _parent,
                   int _nIndex)
                   throws WCMException
抛出：
WCMException

getSiblingIndex

int getSiblingIndex(BaseChannel _channel)
                    throws WCMException
获取指定频道/站点在其同级目录中的位置

参数：
_channel - 指定频道/站点对象
返回：
位置索引
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MySystemInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 MySystemInfo

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.MySystemInfo

public class MySystemInfo
extends java.lang.Object

字段摘要
static int SERIALNUM
构造方法摘要
MySystemInfo()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SERIALNUM

public static int SERIALNUM
构造方法详细信息

MySystemInfo

public MySystemInfo()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.content.persistent
接口
IChannelNameMgr
IChildrenMgr
类
Appendix
Appendixes
AutoBakConfig
AutoBakConfigs
BaseChannel
Channel
ChannelContentLink
ChannelContentLinks
ChannelLoopValidator
ChannelNameMgr
Channels
ChannelSubstanceImplBase
ChannelSyn
ChannelSyns
ChannelXmlConverter
ChildrenCacheMgr
ChnlDoc
ChnlDocs
ContentExtField
ContentExtFields
ContentExtFieldXmlConverter
ContentLink
ContentLinks
ContentLinkType
ContentLinkTypes
DocBak
DocBaks
DocReply
DocReplys
Document
DocumentFieldConfig
Documents
DocumentShowFieldConfig
DocumentSubstanceImplBase
DocumentSyn
DocumentSyns
DocumentXmlConverter
HitsCount
HitsCounts
MySystemInfo
Relation
Relations
Replace
ReplaceCacheMgr
Replaces
SiteLicenseMgr
SiteMember
SiteMembers
WebSite
WebSites
WebSiteSubstanceImplBase
XDocument
XDocuments


com.trs.components.wcm.content.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.content.persistent

接口摘要
IChannelNameMgr | Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IChildrenMgr | Title: TRS 内容协作平台（TRS WCM） Description: 子频道获取管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
Appendix |
Appendixes |
AutoBakConfig | Title: TRS 内容协作平台（TRS WCM） Description: 自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
AutoBakConfigs | Title: TRS 内容协作平台（TRS WCM） Description: 版本自动保存配置信息集合对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseChannel | Title: TRS 内容协作平台（TRS WCM） Description:
Channel |
ChannelContentLink | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelContentLinks | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelLoopValidator | Title: TRS 内容协作平台（TRS WCM） Description: 父子关系的回路检测器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelNameMgr | Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理(LRU缓冲算法) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Channels |
ChannelSubstanceImplBase | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelSyn |
ChannelSyns |
ChannelXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 站点/频道到XML转换的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChildrenCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDoc |
ChnlDocs |
ContentExtField |
ContentExtFields |
ContentExtFieldXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContentLink |
ContentLinks |
ContentLinkType |
ContentLinkTypes |
DocBak |
DocBaks |
DocReply |
DocReplys |
Document |
DocumentFieldConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Documents |
DocumentShowFieldConfig |
DocumentSubstanceImplBase | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentSyn | Title: TRS 内容协作平台（TRS WCM） Description: 已经自动转发过的文档的记录 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentSyns | Title: TRS 内容协作平台（TRS WCM） Description: 已经转发过的文档记录集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 负责和Document以XML方式导入、导出的方法 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
HitsCount |
HitsCounts |
MySystemInfo |
Relation |
Relations |
Replace |
ReplaceCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: 替换内容的缓冲 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Replaces | Title: TRS 内容协作平台（TRS WCM） Description: 替换内容对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SiteLicenseMgr | Title: TRS 内容协作平台（TRS WCM） Description: License protected validator Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SiteMember |
SiteMembers |
WebSite |
WebSites |
WebSiteSubstanceImplBase | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XDocument |
XDocuments |


com.trs.components.wcm.content.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.content.persistent.Appendix
        • com.trs.components.wcm.content.persistent.AutoBakConfig
        • com.trs.components.wcm.content.persistent.BaseChannel
          • com.trs.components.wcm.content.persistent.Channel
          • com.trs.components.wcm.content.persistent.WebSite
        • com.trs.components.wcm.content.persistent.ChannelContentLink
        • com.trs.components.wcm.content.persistent.ChannelSyn
        • com.trs.components.wcm.content.persistent.ChnlDoc
        • com.trs.components.wcm.content.persistent.ContentExtField
        • com.trs.components.wcm.content.persistent.ContentLink
        • com.trs.components.wcm.content.persistent.ContentLinkType
        • com.trs.components.wcm.content.persistent.DocReply
        • com.trs.components.wcm.content.persistent.Document
          • com.trs.components.wcm.content.persistent.DocBak
        • com.trs.components.wcm.content.persistent.DocumentSyn
        • com.trs.components.wcm.content.persistent.HitsCount
        • com.trs.components.wcm.content.persistent.Relation
        • com.trs.components.wcm.content.persistent.Replace
        • com.trs.components.wcm.content.persistent.SiteMember
        • com.trs.components.wcm.content.persistent.XDocument
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.content.persistent.Appendixes
        • com.trs.components.wcm.content.persistent.AutoBakConfigs
        • com.trs.components.wcm.content.persistent.ChannelContentLinks
        • com.trs.components.wcm.content.persistent.Channels
        • com.trs.components.wcm.content.persistent.ChannelSyns
        • com.trs.components.wcm.content.persistent.ChnlDocs
        • com.trs.components.wcm.content.persistent.ContentExtFields
        • com.trs.components.wcm.content.persistent.ContentLinks
        • com.trs.components.wcm.content.persistent.ContentLinkTypes
        • com.trs.components.wcm.content.persistent.DocBaks
        • com.trs.components.wcm.content.persistent.DocReplys
        • com.trs.components.wcm.content.persistent.Documents
        • com.trs.components.wcm.content.persistent.DocumentSyns
        • com.trs.components.wcm.content.persistent.HitsCounts
        • com.trs.components.wcm.content.persistent.Relations
        • com.trs.components.wcm.content.persistent.Replaces
        • com.trs.components.wcm.content.persistent.SiteMembers
        • com.trs.components.wcm.content.persistent.WebSites
      • com.trs.infra.persistent.CMyResultObjs
        • com.trs.components.wcm.content.persistent.XDocuments
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.components.wcm.content.persistent.ChannelXmlConverter
      • com.trs.components.wcm.content.persistent.ContentExtFieldXmlConverter
      • com.trs.components.wcm.content.persistent.DocumentXmlConverter
    • com.trs.components.wcm.content.persistent.ChannelLoopValidator
    • com.trs.components.wcm.content.persistent.ChannelNameMgr (implements com.trs.components.wcm.content.persistent.IChannelNameMgr)
    • com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)
    • com.trs.components.wcm.content.persistent.ChildrenCacheMgr (implements com.trs.components.wcm.content.persistent.IChildrenMgr)
    • com.trs.components.wcm.content.persistent.DocumentFieldConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.wcm.content.persistent.DocumentShowFieldConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)
    • com.trs.components.wcm.content.persistent.MySystemInfo
    • com.trs.components.wcm.content.persistent.ReplaceCacheMgr (implements com.trs.infra.support.cache.ICacheMgr)
    • com.trs.components.wcm.content.persistent.SiteLicenseMgr
    • com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase (implements com.trs.cms.content.ICMSObjSubstanceContent)

接口分层结构

  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.wcm.content.persistent.IChannelNameMgr
        • com.trs.components.wcm.content.persistent.IChildrenMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.wcm.content.persistent.IChannelNameMgr
        • com.trs.components.wcm.content.persistent.IChildrenMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.components.wcm.content.persistent.IChannelNameMgr
        • com.trs.components.wcm.content.persistent.IChildrenMgr


软件包 com.trs.components.wcm.content.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.persistent
的使用

使用 com.trs.components.wcm.content.persistent 的软件包
com.trs.ajaxservice |
com.trs.ajaxservice.xmlconvertors |
com.trs.cms.auth.domain |
com.trs.cms.auth.persistent |
com.trs.components.ckm |
com.trs.components.comment.persistent |
com.trs.components.comment.publish.helper |
com.trs.components.comment.service |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.common.trsad |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.helper |
com.trs.components.infoview.mad |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.service |
com.trs.components.stat |
com.trs.components.wcm.auth |
com.trs.components.wcm.channel |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.trsserver |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.process.element |
com.trs.components.wcm.process.service.flowexporter |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.domain |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.recent |
com.trs.components.wcm.wcmx.jsp |
com.trs.components.wcm.wcmx.util |
com.trs.components.wcm.wcmx.websites |
com.trs.components.web.document |
com.trs.presentation.nav |
com.trs.presentation.wcm.content |
com.trs.service |
com.trs.service.impl |
com.trs.template.service.impl |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |

com.trs.ajaxservice 使用的 com.trs.components.wcm.content.persistent 中的类
Appendixes
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Channels
ChnlDocs
Document
Documents
Relations
WebSite
WebSites

com.trs.ajaxservice.xmlconvertors 使用的 com.trs.components.wcm.content.persistent 中的类
Channel

com.trs.cms.auth.domain 使用的 com.trs.components.wcm.content.persistent 中的类
Channel

com.trs.cms.auth.persistent 使用的 com.trs.components.wcm.content.persistent 中的类
WebSite

com.trs.components.ckm 使用的 com.trs.components.wcm.content.persistent 中的类
Document
Documents

com.trs.components.comment.persistent 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
WebSite

com.trs.components.comment.publish.helper 使用的 com.trs.components.wcm.content.persistent 中的类
Document

com.trs.components.comment.service 使用的 com.trs.components.wcm.content.persistent 中的类
Documents

com.trs.components.common.publish.domain.template 使用的 com.trs.components.wcm.content.persistent 中的类
Channels

com.trs.components.common.publish.widget 使用的 com.trs.components.wcm.content.persistent 中的类
Documents

com.trs.components.common.publish.widget.tagparser 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.components.common.trsad 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
WebSite

com.trs.components.infoview 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
DocReply
Document

com.trs.components.infoview.db 使用的 com.trs.components.wcm.content.persistent 中的类
ChnlDoc
Document

com.trs.components.infoview.helper 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
Channels
Document
Documents
WebSite
WebSites

com.trs.components.infoview.mad 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
Document
Documents

com.trs.components.infoview.persistent 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
ChnlDoc
Document

com.trs.components.metadata.center 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Channels
ChnlDoc
Document
Documents
WebSite
WebSites

com.trs.components.metadata.center.xml 使用的 com.trs.components.wcm.content.persistent 中的类
Channel

com.trs.components.metadata.service 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Channels
Documents
WebSite

com.trs.components.stat 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
Channels
Documents

com.trs.components.wcm.auth 使用的 com.trs.components.wcm.content.persistent 中的类
Channel

com.trs.components.wcm.channel 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
WebSite

com.trs.components.wcm.content 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Channels
Documents
WebSite
WebSites

com.trs.components.wcm.content.domain 使用的 com.trs.components.wcm.content.persistent 中的类
Appendix
Appendixes
AutoBakConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Channels
ChannelSyn
ChannelSyns
ChnlDoc
ContentExtField
ContentExtFields
ContentLink
ContentLinks
DocBak
DocBaks
DocReply
DocReplys
Document
Documents
DocumentSyn
Title: TRS 内容协作平台（TRS WCM）
Description:
已经自动转发过的文档的记录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Relations
Replace
Replaces
Title: TRS 内容协作平台（TRS WCM） Description: 替换内容对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSite
WebSites

com.trs.components.wcm.content.domain.auth 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
ChannelSubstanceImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDoc
Document
Documents
DocumentSubstanceImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteSubstanceImplBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 使用的 com.trs.components.wcm.content.persistent 中的类
Appendix
Appendixes
AutoBakConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AutoBakConfigs
Title: TRS 内容协作平台（TRS WCM）
Description:
版本自动保存配置信息集合对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
ChannelContentLink
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelContentLinks
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
Channels
ChannelSyn
ChannelSyns
ChnlDoc
ChnlDocs
ContentExtField
ContentExtFields
ContentLink
ContentLinks
ContentLinkType
ContentLinkTypes
DocBaks
DocReply
DocReplys
Document
Documents
DocumentSyn
Title: TRS 内容协作平台（TRS WCM）
Description:
已经自动转发过的文档的记录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentSyns
Title: TRS 内容协作平台（TRS WCM）
Description:
已经转发过的文档记录集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IChannelNameMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
频道名称缓冲管理对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IChildrenMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
子频道获取管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Relation
Relations
Replace
Replaces
Title: TRS 内容协作平台（TRS WCM） Description: 替换内容对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SiteLicenseMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SiteMember
SiteMembers
WebSite
WebSites

com.trs.components.wcm.content.trsserver 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
Documents

com.trs.components.wcm.customize 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
Channels

com.trs.components.wcm.epress 使用的 com.trs.components.wcm.content.persistent 中的类
Channel

com.trs.components.wcm.process.element 使用的 com.trs.components.wcm.content.persistent 中的类
Document

com.trs.components.wcm.process.service.flowexporter 使用的 com.trs.components.wcm.content.persistent 中的类
WebSite

com.trs.components.wcm.publish 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.components.wcm.publish.domain 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
Document
Documents

com.trs.components.wcm.publish.element 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
Document
WebSite

com.trs.components.wcm.publish.tagparser 使用的 com.trs.components.wcm.content.persistent 中的类
Appendix
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Document
Documents

com.trs.components.wcm.recent 使用的 com.trs.components.wcm.content.persistent 中的类
Channels
ChnlDocs
Documents
WebSites

com.trs.components.wcm.wcmx.jsp 使用的 com.trs.components.wcm.content.persistent 中的类
Channel
Document

com.trs.components.wcm.wcmx.util 使用的 com.trs.components.wcm.content.persistent 中的类
Channels

com.trs.components.wcm.wcmx.websites 使用的 com.trs.components.wcm.content.persistent 中的类
Channel

com.trs.components.web.document 使用的 com.trs.components.wcm.content.persistent 中的类
Document

com.trs.presentation.nav 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Channels
WebSite
WebSites

com.trs.presentation.wcm.content 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Document
Documents
WebSite

com.trs.service 使用的 com.trs.components.wcm.content.persistent 中的类
Appendix
Appendixes
AutoBakConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Channels
ChannelSyn
ChannelSyns
ChnlDoc
ChnlDocs
ContentExtField
ContentExtFields
ContentLink
ContentLinks
DocBak
DocBaks
DocReply
Document
Documents
Relations
Replace
Replaces
Title: TRS 内容协作平台（TRS WCM） Description: 替换内容对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSite
WebSites

com.trs.service.impl 使用的 com.trs.components.wcm.content.persistent 中的类
Appendix
Appendixes
AutoBakConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Channels
ChannelSyn
ChannelSyns
ChnlDoc
ChnlDocs
ContentExtField
ContentExtFields
ContentLink
ContentLinks
DocBak
DocBaks
DocReply
Document
Documents
Relations
Replace
Replaces
Title: TRS 内容协作平台（TRS WCM） Description: 替换内容对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WebSite
WebSites

com.trs.template.service.impl 使用的 com.trs.components.wcm.content.persistent 中的类
WebSite

com.trs.wcm.old 使用的 com.trs.components.wcm.content.persistent 中的类
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Document
WebSite

com.trs.wcm.photo 使用的 com.trs.components.wcm.content.persistent 中的类
Appendix
Appendixes
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Document
Documents
WebSite

com.trs.wcm.photo.impl 使用的 com.trs.components.wcm.content.persistent 中的类
Appendixes
BaseChannel
Title: TRS 内容协作平台（TRS WCM）
Description:
Channel
Document
Documents
WebSite

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Relation

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Relation

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.Relation
所有已实现的接口：
java.lang.Cloneable
public class Relation
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
Relation()
方法摘要
static Relation | createNewInstance() 产生当前对象[Relation]的实例
static Relation | findById(int _nId) 提取指定ID的对象
static Relation | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
int | getDocId() 获取相关文档对象所属文档的ID
java.lang.String | getIdFieldName() 获得Id字段名。
int | getRelDocId() 获取相关文档的ID
int | getSerialNo() 获取序号
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isValid() 检查数据的有效性
boolean | setDocId(int _nDocId) 设置相关文档对象所属文档的ID
boolean | setRelDocId(int _nRelDocId) 设置相关文档的ID
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Relation

public Relation()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getDocId

public int getDocId()
获取相关文档对象所属文档的ID

返回：

setDocId

public boolean setDocId(int _nDocId)
                 throws WCMException
设置相关文档对象所属文档的ID

参数：
_nDocId - 相关文档对象所属文档的ID
返回：
抛出：
WCMException

getRelDocId

public int getRelDocId()
获取相关文档的ID

返回：
相关文档的ID

setRelDocId

public boolean setRelDocId(int _nRelDocId)
                    throws WCMException
设置相关文档的ID

参数：
_nRelDocId - 相关文档的ID
返回：
抛出：
WCMException

getSerialNo

public int getSerialNo()
获取序号

返回：
序号

isValid

public boolean isValid()
                throws WCMException
检查数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 新增模式下： 1、没有设置文档id 2、没有设置相关文档id
另请参见：
WCMObj.isValid()

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

findById

public static final Relation findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Relation createNewInstance()
                                        throws WCMException
产生当前对象[Relation]的实例

返回：
当前对象的实例[Relation]
抛出：
WCMException

findByKey

public static final Relation findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Relations

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Relations

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.Relations

public class Relations
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Relations(User _currUser)
Relations(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static Relations | createNewInstance(User _currUser) 产生当前集合对象[Relations]的实例
static Relations | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Relations | findRelationsByObj(BaseObj _currObj) 获得文档所属关联文档集合 该接口应该是获得对象所属关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用 以后扩展应该也比较方便，增加一个对象类型ID即可
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Relations | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Relations]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Relations

public Relations(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

Relations

public Relations(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findRelationsByObj

public static Relations findRelationsByObj(BaseObj _currObj)
                                    throws WCMException
获得文档所属关联文档集合
该接口应该是获得对象所属关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用
以后扩展应该也比较方便，增加一个对象类型ID即可

参数：
_currObj - 欲查询的主对象
返回：
和对象关联的对象集合
抛出：
WCMException - 使用OpenObjs方法打开集合时可能的异常

findByIds

public static final Relations findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Relations）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Relations openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[Relations]

参数：
_filter - 指定的Filter
返回：
当前集合[Relations]
抛出：
WCMException

createNewInstance

public static Relations createNewInstance(User _currUser)
产生当前集合对象[Relations]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Replace

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Replace

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.Replace
所有已实现的接口：
java.lang.Cloneable
public class Replace
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
Replace()
构造函数：保留默认接口
方法摘要
static Replace | createNewInstance() 产生当前对象[Replace]的实例
static Replace | findById(int _nId) 提取指定ID的对象
static Replace | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Channel | getChannel() 获取所属频道
int | getChnlId() 获取所属频道ID
java.lang.String | getContent() 获取替换内容
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName() 获取替换名称
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 效验数据的有效性
static java.lang.String | replace(int _nChannelId, java.lang.String _sName) 替换指定的内容
boolean | setChnlId(int _chnlid) 设置所属频道
boolean | setContent(java.lang.String _content) 设置替换内容
boolean | setName(java.lang.String _name) 设置替换名称
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Replace

public Replace()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

isValid

public boolean isValid()
                throws WCMException
效验数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
如果有效返回true；否则返回false
抛出：
WCMException - 1、同一个频道内的替换名称唯一 新增模式： 1、没有设置替换名称 2、没有设置所属频道

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置替换名称

参数：
_name - 替换名称
返回：
@throws WCMException
抛出：
WCMException

getName

public java.lang.String getName()
获取替换名称

返回：
替换名称

setContent

public boolean setContent(java.lang.String _content)
                   throws WCMException
设置替换内容

参数：
_content - 替换内容
返回：
@throws WCMException
抛出：
WCMException

getContent

public java.lang.String getContent()
获取替换内容

返回：
替换内容

setChnlId

public boolean setChnlId(int _chnlid)
                  throws WCMException
设置所属频道

参数：
_chnlid - 所属频道ID
返回：
@throws WCMException
抛出：
WCMException

getChnlId

public int getChnlId()
获取所属频道ID

返回：
所属频道ID

getChannel

public Channel getChannel()
                   throws WCMException
获取所属频道

返回：
频道对象（Channel）
抛出：
WCMException

findById

public static final Replace findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Replace createNewInstance()
                                       throws WCMException
产生当前对象[Replace]的实例

返回：
当前对象的实例[Replace]
抛出：
WCMException

findByKey

public static final Replace findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

replace

public static final java.lang.String replace(int _nChannelId,
                                             java.lang.String _sName)
                                      throws WCMException
替换指定的内容

参数：
_nChannelId -
_sName -
返回：
@throws WCMException
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReplaceCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 ReplaceCacheMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.ReplaceCacheMgr
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class ReplaceCacheMgr
extends java.lang.Object
implements ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
替换内容的缓冲
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ReplaceCacheMgr()
方法摘要
void | clear() 清除系统所有的Cache
java.util.Map | getRepalceCache()
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ReplaceCacheMgr

public ReplaceCacheMgr()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

getRepalceCache

public java.util.Map getRepalceCache()
                              throws WCMException
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Replaces

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 Replaces

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.Replaces

public class Replaces
extends CMSBaseObjs

Title: TRS 内容协作平台（TRS WCM）

Description:

替换内容对象的定义和实现

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Replaces(User _currUser)
Replaces(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static Replaces | createNewInstance(User _currUser) 产生当前集合对象[Replaces]的实例
static Replaces | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Replaces | openWCMObjs(User _currUser, WCMFilter _fitler) Created: 2004-12-12 17:23:52 Last Modified: 2004-12-12/2004-12-12 Description:获取内容替换对象集合
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Replaces

public Replaces(User _currUser)

Replaces

public Replaces(User _currUser,
                int _initCapacity,
                int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

openWCMObjs

public static Replaces openWCMObjs(User _currUser,
                                   WCMFilter _fitler)
                            throws WCMException
Created: 2004-12-12 17:23:52 Last Modified: 2004-12-12/2004-12-12 Description:获取内容替换对象集合

参数：
_currUser - 当前操作用户
_fitler - 过滤器,筛选条件
返回：
抛出：
WCMException

findByIds

public static Replaces findByIds(User _currUser,
                                 java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Replaces）
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static Replaces createNewInstance(User _currUser)
产生当前集合对象[Replaces]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteLicenseMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 SiteLicenseMgr

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.SiteLicenseMgr

public class SiteLicenseMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SiteLicenseMgr()
方法摘要
static SiteLicenseMgr | getInstance()
void | validateSiteLicense()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteLicenseMgr

public SiteLicenseMgr()
方法详细信息

getInstance

public static SiteLicenseMgr getInstance()

validateSiteLicense

public void validateSiteLicense()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteMember

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 SiteMember

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.SiteMember
所有已实现的接口：
java.lang.Cloneable
public class SiteMember
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
SiteMember()
构造函数：保留默认接口
方法摘要
static SiteMember | createNewInstance() 产生当前对象[SiteUser]的实例
static SiteMember | findById(int _nId) 提取指定ID的对象
static SiteMember | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getObjId()
int | getObjType()
int | getSiteId() 提取属性：SiteId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setObjId(int _nObjId)
boolean | setObjType(int _nObjType)
boolean | setSiteId(int _nSiteId) 设置属性：SiteId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

SiteMember

public SiteMember()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getSiteId

public int getSiteId()
提取属性：SiteId

返回：
SiteId

setSiteId

public boolean setSiteId(int _nSiteId)
                  throws WCMException
设置属性：SiteId

参数：
_nSiteId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final SiteMember findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final SiteMember createNewInstance()
                                          throws WCMException
产生当前对象[SiteUser]的实例

返回：
当前对象的实例[SiteUser]
抛出：
WCMException

findByKey

public static final SiteMember findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getObjId

public int getObjId()

setObjId

public boolean setObjId(int _nObjId)
                 throws WCMException
抛出：
WCMException

getObjType

public int getObjType()

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteMembers

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 SiteMembers

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.SiteMembers

public class SiteMembers
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
SiteMembers(User _currUser)
构造函数
SiteMembers(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static SiteMembers | createNewInstance(User _currUser) 产生一个当前集合对象[SiteUsers]的实例
static SiteMembers | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static SiteMembers | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[SiteUsers]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteMembers

public SiteMembers(User _currUser)
构造函数

另请参见：
SiteUsers( User _currUser, int _initCapacity, int _incCapacity );

SiteMembers

public SiteMembers(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final SiteMembers findByIds(User _currUser,
                                          java.lang.String _sIds)
                                   throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final SiteMembers openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[SiteUsers]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[SiteUsers]
抛出：
WCMException

createNewInstance

public static SiteMembers createNewInstance(User _currUser)
                                     throws WCMException
产生一个当前集合对象[SiteUsers]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSite

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 WebSite

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.BaseChannel
                继承者  com.trs.components.wcm.content.persistent.WebSite
所有已实现的接口：
java.lang.Cloneable
public class WebSite
extends BaseChannel

字段摘要
static int | AUTO_SAVE_CHG_STATUS 允许自动保存版本的文档操作索引：改变状态(1)
static int | AUTO_SAVE_EDIT 允许自动保存版本的文档操作索引：编辑文档(0)
static java.lang.String | AUTO_SAVE_KEY 站点保存版本配置关键字：允许自动保存的文档操作(SITE_AUTO_SAVE)
static int | AUTO_SAVE_PUBLISH 允许自动保存版本的文档操作索引：发布文档(2)
static int | COMMON_SITE
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
static int | PHOTO_SITE
static int | PROP_INDEX_UPLOAD 站点属性索引：上传文件(0)
static java.lang.String | SAVE_STATUS_KEY 站点保存版本配置关键字：允许保存的文档状态(SITE_SAVE_STATUS)
static int | VIDEO_SITE
从类 com.trs.components.wcm.content.persistent.BaseChannel 继承的字段
STATUS_DEL, STATUS_NORM, STATUS_PARENT_DEL, TYPE_ALL
构造方法摘要
WebSite()
方法摘要
boolean | addPubStatus(int _nStatusId) 添加站点的可发布文档状态
boolean | addPubStatus(Status _status) 添加站点的可发布文档状态
boolean | canFtpUpload() 判断站点是否需要上传文件
static WebSite | createNewInstance() 产生当前对象[WebSite]的实例
static WebSite | findById(int _nId) 提取指定ID的对象
static WebSite | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDataPath() 获取数据存放的本地路径（相对路径）
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取站点的描述
java.lang.String | getDetailExt() 获取细览页面的扩展名
java.lang.String | getFtpFolder() 获取站点ftp目录
java.lang.String | getFtpPassword() 获取ftp用户密码
java.lang.String | getFtpServer() 获取站点对应的ftp服务器地址
java.lang.String | getFtpUser() 获取站点对应的ftp服务器用户
BaseChannel | getHost() 得到当前频道的父频道，在Channel和Site中分别定义
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getInfo() Returns the object inforamtion
java.lang.String | getLocalFtpPath() 获取应用服务器上站点的FTP路径
java.lang.String | getLocalHttpPath() 获取应用服务器上站点的HTTP路径
java.lang.String | getLocalPath() 获取应用服务器上存放站点页面的绝对物理路径
java.lang.String | getMainFileExt() 获取主页面的扩展名
java.lang.String | getMainFileName() 获取主页面的文件名
java.lang.String | getName() 获取站点名称
int | getOrder() 获取站点排序序号
java.lang.String | getOrderBy() 获取站点默认的排序方式
java.lang.String | getOutlineExt() 获取概览页面的扩展名
java.lang.String | getOutlineName() 获取概览页面的文件名
WebSite | getParent()
int | getParentId()
Statuses | getPubStatuses(User _currUser) 取所有允许发布的文档状态对象集合
java.lang.String | getPubStatusIds() 取所有允许发布的文档状态对象ID集合（字符串，不同ID之间移字符','分割）
Statuses | getSaveStatuses(User _currUser) 获取站点上允许发布的文档状态
java.lang.String | getSaveStatusIds() 站点上允许发布的文档状态对象ID集合（字符串，不同ID之间移字符','分割）
WebSite | getSite()
int | getSiteId()
boolean | getSiteProp(int _index) 判断站点是否具有指定索引的属性
int | getType()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
java.lang.String | getWebHttp() 获取Web站点Http地址
boolean | isSite() 判断当前对象是否为站点
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setDataPath(java.lang.String _dataPath) 设置数据存放的本地路径（相对路径）
boolean | setDesc(java.lang.String _desc) 设置站点的描述
boolean | setDetailExt(java.lang.String _sExt) 设置细览页面的扩展名
boolean | setFtpFolder(java.lang.String _ftpFolder) 设置ftp目录
boolean | setFtpPassword(java.lang.String _password) 设置ftp用户密码
boolean | setFtpServer(java.lang.String _ftpServer) 设置站点对应的ftp服务器地址
boolean | setFtpUpload(boolean _isUpload) 设置站点是否需要上传文件
boolean | setFtpUser(java.lang.String _ftpUser) 设置站点对应的ftp服务器用户
boolean | setMainFileExt(java.lang.String _sExt) 设置主页面的扩展名
boolean | setMainFileName(java.lang.String _sName) 设置主页面的文件名
boolean | setName(java.lang.String _name) 设置站点名称
boolean | setOrder(int _nOrder) 设置站点的排序序号
boolean | setOrderBy(java.lang.String _sOrderBy) 设置站点的默认的排序方式 说明：目前没有体现
boolean | setOutlineExt(java.lang.String _sExt) 设置概览页面的扩展名
boolean | setOutlineName(java.lang.String _sName) 设置概览页面的文件名
boolean | setParent(int _parentId)
boolean | setParent(WebSite _parent)
boolean | setPubStatus(java.lang.String _statusIds) 设置站点的可发布文档状态
boolean | setSiteProp(int _index, boolean _value) 设置站点指定索引的属性
boolean | setType(int siteType)
boolean | setWebHttp(java.lang.String _webHttp) 设置Web站点Http地址
java.lang.String | toString()
从类 com.trs.components.wcm.content.persistent.BaseChannel 继承的方法
getAllChildren, getChildAt, getChildren, getChildren, getChildren, getChildrenSize, getDispDesc, getSiblingIndex, getStatus, isDeleted, restore, setDeleted, setOperTime, setOperUser, setOperUser, setStatus
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

SAVE_STATUS_KEY

public static final java.lang.String SAVE_STATUS_KEY
站点保存版本配置关键字：允许保存的文档状态(SITE_SAVE_STATUS)

另请参见：
常量字段值

AUTO_SAVE_KEY

public static final java.lang.String AUTO_SAVE_KEY
站点保存版本配置关键字：允许自动保存的文档操作(SITE_AUTO_SAVE)

另请参见：
常量字段值

AUTO_SAVE_EDIT

public static final int AUTO_SAVE_EDIT
允许自动保存版本的文档操作索引：编辑文档(0)

另请参见：
常量字段值

AUTO_SAVE_CHG_STATUS

public static final int AUTO_SAVE_CHG_STATUS
允许自动保存版本的文档操作索引：改变状态(1)

另请参见：
常量字段值

AUTO_SAVE_PUBLISH

public static final int AUTO_SAVE_PUBLISH
允许自动保存版本的文档操作索引：发布文档(2)

另请参见：
常量字段值

COMMON_SITE

public static final int COMMON_SITE
另请参见：
常量字段值

PHOTO_SITE

public static final int PHOTO_SITE
另请参见：
常量字段值

VIDEO_SITE

public static final int VIDEO_SITE
另请参见：
常量字段值

PROP_INDEX_UPLOAD

public static final int PROP_INDEX_UPLOAD
站点属性索引：上传文件(0)

另请参见：
常量字段值
构造方法详细信息

WebSite

public WebSite()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getName

public java.lang.String getName()
获取站点名称

指定者：
类 BaseChannel 中的 getName
返回：
站点名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置站点名称

指定者：
类 BaseChannel 中的 setName
参数：
_name - 站点名称
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取站点的描述

指定者：
类 BaseChannel 中的 getDesc
返回：
站点的描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置站点的描述

参数：
_desc - 站点的描述
返回：
抛出：
WCMException

getFtpServer

public java.lang.String getFtpServer()
获取站点对应的ftp服务器地址

返回：
站点对应的ftp服务器地址

setFtpServer

public boolean setFtpServer(java.lang.String _ftpServer)
                     throws WCMException
设置站点对应的ftp服务器地址

参数：
_ftpServer - 站点对应的ftp服务器地址
返回：
抛出：
WCMException

getFtpUser

public java.lang.String getFtpUser()
获取站点对应的ftp服务器用户

返回：
站点对应的ftp服务器用户

setFtpUser

public boolean setFtpUser(java.lang.String _ftpUser)
                   throws WCMException
设置站点对应的ftp服务器用户

参数：
_ftpUser -
返回：
抛出：
WCMException

getFtpPassword

public java.lang.String getFtpPassword()
获取ftp用户密码

返回：
ftp用户密码

setFtpPassword

public boolean setFtpPassword(java.lang.String _password)
                       throws WCMException
设置ftp用户密码

参数：
_password - ftp用户密码
返回：
抛出：
WCMException

getFtpFolder

public java.lang.String getFtpFolder()
获取站点ftp目录

返回：

setFtpFolder

public boolean setFtpFolder(java.lang.String _ftpFolder)
                     throws WCMException
设置ftp目录

参数：
_ftpFolder -
返回：
抛出：
WCMException

getDataPath

public java.lang.String getDataPath()
获取数据存放的本地路径（相对路径）

返回：

setDataPath

public boolean setDataPath(java.lang.String _dataPath)
                    throws WCMException
设置数据存放的本地路径（相对路径）

参数：
_dataPath - 数据存放的本地路径（相对路径）
返回：
抛出：
WCMException

getWebHttp

public java.lang.String getWebHttp()
获取Web站点Http地址

返回：

setWebHttp

public boolean setWebHttp(java.lang.String _webHttp)
                   throws WCMException
设置Web站点Http地址

参数：
_webHttp -
返回：
抛出：
WCMException

getParentId

public int getParentId()
覆盖：
类 BaseChannel 中的 getParentId

getParent

public WebSite getParent()
                  throws WCMException
抛出：
WCMException

setParent

public boolean setParent(int _parentId)
                  throws WCMException
指定者：
类 BaseChannel 中的 setParent
抛出：
WCMException

setParent

public boolean setParent(WebSite _parent)
                  throws WCMException
抛出：
WCMException

getOrder

public int getOrder()
获取站点排序序号

指定者：
类 BaseChannel 中的 getOrder
返回：

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置站点的排序序号

参数：
_nOrder - 站点排序序号
返回：
抛出：
WCMException

getOrderBy

public java.lang.String getOrderBy()
获取站点默认的排序方式

返回：
站点默认的排序方式

setOrderBy

public boolean setOrderBy(java.lang.String _sOrderBy)
                   throws WCMException
设置站点的默认的排序方式 说明：目前没有体现

参数：
_sOrderBy -
返回：
抛出：
WCMException

setMainFileName

public boolean setMainFileName(java.lang.String _sName)
                        throws WCMException
设置主页面的文件名

参数：
_sName - 主页面文件名
返回：
抛出：
WCMException

getMainFileName

public java.lang.String getMainFileName()
获取主页面的文件名

返回：
返回主页面的文件名

setMainFileExt

public boolean setMainFileExt(java.lang.String _sExt)
                       throws WCMException
设置主页面的扩展名

参数：
_sExt - 主页面文件名
返回：
抛出：
WCMException

getMainFileExt

public java.lang.String getMainFileExt()
获取主页面的扩展名

返回：
返回主页面的扩展名

setOutlineName

public boolean setOutlineName(java.lang.String _sName)
                       throws WCMException
设置概览页面的文件名

参数：
_sName - 概览页面的文件名
返回：
抛出：
WCMException

getOutlineName

public java.lang.String getOutlineName()
获取概览页面的文件名

返回：
返回概览页面的文件名

setOutlineExt

public boolean setOutlineExt(java.lang.String _sExt)
                      throws WCMException
设置概览页面的扩展名

参数：
_sExt - 概览页面的扩展名
返回：
抛出：
WCMException

getOutlineExt

public java.lang.String getOutlineExt()
获取概览页面的扩展名

返回：
返回概览页面的扩展名

setDetailExt

public boolean setDetailExt(java.lang.String _sExt)
                     throws WCMException
设置细览页面的扩展名

参数：
_sExt - 细览页面的扩展名
返回：
抛出：
WCMException

getDetailExt

public java.lang.String getDetailExt()
获取细览页面的扩展名

返回：
返回细览页面的扩展名

getPubStatusIds

public java.lang.String getPubStatusIds()
取所有允许发布的文档状态对象ID集合（字符串，不同ID之间移字符','分割）

返回：
所有允许发布的文档状态对象ID集合（字符串，不同ID之间移字符','分割）

getPubStatuses

public Statuses getPubStatuses(User _currUser)
                        throws WCMException
取所有允许发布的文档状态对象集合

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

setPubStatus

public boolean setPubStatus(java.lang.String _statusIds)
                     throws WCMException
设置站点的可发布文档状态

参数：
_statusIds - 文档状态ID字符串(以","分隔)
返回：
抛出：
WCMException

addPubStatus

public boolean addPubStatus(int _nStatusId)
                     throws WCMException
添加站点的可发布文档状态

参数：
_nStatusId - 文档状态ID
返回：
抛出：
WCMException

addPubStatus

public boolean addPubStatus(Status _status)
                     throws WCMException
添加站点的可发布文档状态

参数：
_status - 文档状态
返回：
抛出：
WCMException

setFtpUpload

public boolean setFtpUpload(boolean _isUpload)
                     throws WCMException
设置站点是否需要上传文件

参数：
_isUpload - true：表示需要上传文件；false：表示不需要上传
返回：
抛出：
WCMException

canFtpUpload

public boolean canFtpUpload()
判断站点是否需要上传文件

返回：
如果需要返回true;否则返回false

setSiteProp

public boolean setSiteProp(int _index,
                           boolean _value)
                    throws WCMException
设置站点指定索引的属性

参数：
_index - 指定属性的索引（WebSite.PROP_INDEX_UPLOAD）
_value - 是否具有指定的属性
返回：
抛出：
WCMException

getSiteProp

public boolean getSiteProp(int _index)
判断站点是否具有指定索引的属性

参数：
_index - 属性索引
返回：
如果具有返回true；否则返回false

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException
另请参见：
WCMObj.isValid()

getLocalPath

public java.lang.String getLocalPath()
                              throws WCMException
获取应用服务器上存放站点页面的绝对物理路径

返回：
抛出：
WCMException

getLocalHttpPath

public java.lang.String getLocalHttpPath()
                                  throws WCMException
获取应用服务器上站点的HTTP路径

返回：
抛出：
WCMException

getLocalFtpPath

public java.lang.String getLocalFtpPath()
                                 throws WCMException
获取应用服务器上站点的FTP路径

返回：
抛出：
WCMException

getSaveStatusIds

public java.lang.String getSaveStatusIds()
站点上允许发布的文档状态对象ID集合（字符串，不同ID之间移字符','分割）

返回：
允许发布的文档状态对象ID集合（字符串，不同ID之间移字符','分割）

getSaveStatuses

public Statuses getSaveStatuses(User _currUser)
                         throws WCMException
获取站点上允许发布的文档状态

参数：
_currUser - 当前操作用户
返回：
站点上允许发布的文档状态集合（Statuses）
抛出：
WCMException

getSite

public WebSite getSite()
指定者：
类 BaseChannel 中的 getSite
返回：
Returns the web site

getSiteId

public int getSiteId()
指定者：
类 BaseChannel 中的 getSiteId

isSite

public boolean isSite()
判断当前对象是否为站点

指定者：
类 BaseChannel 中的 isSite
返回：
站点对象返回true；频道对象返回false.

findById

public static final WebSite findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final WebSite createNewInstance()
                                       throws WCMException
产生当前对象[WebSite]的实例

返回：
当前对象的实例[WebSite]
抛出：
WCMException

findByKey

public static final WebSite findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getHost

public BaseChannel getHost()
从类 BaseChannel 复制的描述
得到当前频道的父频道，在Channel和Site中分别定义

指定者：
类 BaseChannel 中的 getHost
返回：
@throws WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

getInfo

public java.lang.String getInfo()
从类 BaseChannel 复制的描述
Returns the object inforamtion

指定者：
类 BaseChannel 中的 getInfo
返回：
the object information

getType

public int getType()

setType

public boolean setType(int siteType)
                throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSites

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 WebSites

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.content.persistent.WebSites

public class WebSites
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WebSites(User _currUser)
WebSites(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static WebSites | createNewInstance(User _currUser) 产生当前集合对象[WebSites]的实例
static WebSites | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static WebSites | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WebSites]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSites

public WebSites(User _currUser)

WebSites

public WebSites(User _currUser,
                int initialCapacity,
                int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final WebSites findByIds(User _currUser,
                                       java.lang.String _sIds)
                                throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final WebSites openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[WebSites]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[WebSites]
抛出：
WCMException

createNewInstance

public static WebSites createNewInstance(User _currUser)
                                  throws WCMException
产生当前集合对象[WebSites]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteSubstanceImplBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 WebSiteSubstanceImplBase

java.lang.Object
    继承者  com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase
所有已实现的接口：
ICMSObjSubstanceContent
直接已知子类：
WebSiteRightHostImpl
public abstract class WebSiteSubstanceImplBase
extends java.lang.Object
implements ICMSObjSubstanceContent

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WebSiteSubstanceImplBase()
WebSiteSubstanceImplBase(CMSObj _cmsObj)
WebSiteSubstanceImplBase(int _nId)
方法摘要
boolean | equals(java.lang.Object _another)
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setSubstance(CMSObj _cmsObj) Sets the substantce
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteSubstanceImplBase

public WebSiteSubstanceImplBase()

WebSiteSubstanceImplBase

public WebSiteSubstanceImplBase(int _nId)
                         throws WCMException
抛出：
WCMException

WebSiteSubstanceImplBase

public WebSiteSubstanceImplBase(CMSObj _cmsObj)
方法详细信息

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XDocument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 XDocument

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.XDocument
所有已实现的接口：
java.lang.Cloneable
public class XDocument
extends CMSObj

构造方法摘要
XDocument()
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | setId(int _id) 设置对象ID
void | setIdName(java.lang.String _sIdName)
boolean | setProperty(java.lang.String _sName, java.lang.Object _oValue)
void | setTableName(java.lang.String _sDbName)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XDocument

public XDocument()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

setId

public void setId(int _id)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId
参数：
_id -

setProperty

public boolean setProperty(java.lang.String _sName,
                           java.lang.Object _oValue)
                    throws WCMException
覆盖：
类 BaseObj 中的 setProperty
抛出：
WCMException

setIdName

public void setIdName(java.lang.String _sIdName)

setTableName

public void setTableName(java.lang.String _sDbName)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XDocuments

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.persistent
类 XDocuments

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.persistent.CMyResultObjs
            继承者  com.trs.components.wcm.content.persistent.XDocuments

public class XDocuments
extends CMyResultObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
XDocuments()
方法摘要
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDocIdFieldName()
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
void | open(java.lang.String _sTableName, int _nDocId, WCMFilter _extraFilter, java.lang.String _sIdFieldName)
void | setDbTableName(java.lang.String dbTableName)
void | setDocIdFieldName(java.lang.String docIdFieldName)
从类 com.trs.infra.persistent.CMyResultObjs 继承的方法
open, open, refresh
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XDocuments

public XDocuments()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObjs 复制的描述
取对象数据存储的数据表名称

返回：
对象数据存储的数据表名称

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

open

public void open(java.lang.String _sTableName,
                 int _nDocId,
                 WCMFilter _extraFilter,
                 java.lang.String _sIdFieldName)
          throws WCMException
抛出：
WCMException

getDocIdFieldName

public java.lang.String getDocIdFieldName()
返回：

setDocIdFieldName

public void setDocIdFieldName(java.lang.String docIdFieldName)
参数：
docIdFieldName -

setDbTableName

public void setDbTableName(java.lang.String dbTableName)
参数：
dbTableName -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.content.persistent.Appendix 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Appendix
的使用

使用 Appendix 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.publish.tagparser
com.trs.service
com.trs.service.impl
com.trs.wcm.photo

com.trs.components.wcm.content.domain 中 Appendix 的使用

返回 Appendix 的 com.trs.components.wcm.content.domain 中的方法
 Appendix AppendixMgr.getAppendixById(int _nId)

参数类型为 Appendix 的 com.trs.components.wcm.content.domain 中的方法
void | AppendixMgr.addAppendix(Document _currDocument, Appendix _currAppendix) 新增附件
void | AppendixMgr.editAppendix(Document _currDocument, Appendix _currAppendix) 修改附件

com.trs.components.wcm.content.persistent 中 Appendix 的使用

返回 Appendix 的 com.trs.components.wcm.content.persistent 中的方法
static Appendix | Appendix.createNewInstance() 产生当前对象[Appendix]的实例
static Appendix | Appendix.findById(int _nId) 提取指定ID的对象
static Appendix | Appendix.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.components.wcm.publish.tagparser 中 Appendix 的使用

参数类型为 Appendix 的 com.trs.components.wcm.publish.tagparser 中的方法
static java.lang.String WCMAppendixGenerator.generateAppendix(Appendix _appendix, IPublishContent _apdOwner, PublishTagContext _context, int _nReturnMode)
Generates a document appendix.

com.trs.service 中 Appendix 的使用

返回 Appendix 的 com.trs.service 中的方法
 Appendix ISureformService.makeAppendix(java.lang.String _sFormFile)
根据书生表单数据，构造一个文档附件
规则是先将数据打包成为一个在WebPic下的文件，然后做成附件并构造List返回
注意返回后，需要将DocId设置上，否则保存附件时会报错

com.trs.service.impl 中 Appendix 的使用

返回 Appendix 的 com.trs.service.impl 中的方法
 Appendix SureformService.makeAppendix(java.lang.String _sFormFile)

com.trs.wcm.photo 中 Appendix 的使用

参数类型为 Appendix 的 com.trs.wcm.photo 中的方法
static int ImageLibHelper.getTypeQuotedImageLib(Appendix _appendix)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Appendixes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Appendixes
的使用

使用 Appendixes 的软件包
com.trs.ajaxservice
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl
com.trs.wcm.photo
com.trs.wcm.photo.impl

com.trs.ajaxservice 中 Appendixes 的使用

返回 Appendixes 的 com.trs.ajaxservice 中的方法
Appendixes | ViewDocumentServiceProvider.queryAppendixes(MethodContext _methodContext) 获取指定文档指定类型的附件
Appendixes | DocumentServiceProvider.queryAppendixes(MethodContext _methodContext) 获取指定文档指定类型的附件
Appendixes | DocumentBakServiceProvider.queryAppendixes(MethodContext _methodContext) 获取指定文档版本指定类型的附件

com.trs.components.wcm.content.domain 中 Appendixes 的使用

返回 Appendixes 的 com.trs.components.wcm.content.domain 中的方法
Appendixes | AppendixMgr.getAppendixes(Document _currDocument, int _nAppendixType) 获取当前文档某种类型的附件
Appendixes | AppendixMgr.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档某种类型的附件
Appendixes | AppendixMgr.getAppendixes(Document _currDocument, WCMFilter _filter) 获取当前文档的附件(符合筛选条件)
Appendixes | AppendixMgr.getAppendixes(WCMFilter _aWCMFilter) 根据条件获得当前附件

com.trs.components.wcm.content.persistent 中 Appendixes 的使用

返回 Appendixes 的 com.trs.components.wcm.content.persistent 中的方法
static Appendixes | Appendixes.createNewInstance(User _currUser) 产生一个当前集合对象[Appendixes]的实例
static Appendixes | Appendixes.findAppendixesByObj(BaseObj _currObj) 获得文档所属附件集合 该接口应该是获得对象所属附件集合，由于Appendix对象目前只和Document对象耦合，所以先暂时这样使用 以后扩展应该也比较方便，增加一个对象类型ID即可
static Appendixes | Appendixes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Appendixes | Appendixes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Appendixes]

com.trs.service 中 Appendixes 的使用

返回 Appendixes 的 com.trs.service 中的方法
Appendixes | IDocumentService.getAppendixes(Document _currDocument) 获取当前文档的所有附件
Appendixes | IDocumentService.getAppendixes(Document _currDocument, int _nAppendixType) 获取当前文档的某种类型的附件
Appendixes | IDocumentService.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档的某种类型的附件
Appendixes | IDocumentService.getAppendixes(Document _currDocument, WCMFilter _filter) 获取当前文档的某种类型的附件

com.trs.service.impl 中 Appendixes 的使用

返回 Appendixes 的 com.trs.service.impl 中的方法
Appendixes | DocumentService.getAppendixes(Document _currDocument)
Appendixes | DocumentService.getAppendixes(Document _currDocument, int _nAppendixType)
Appendixes | DocumentService.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter)
Appendixes | DocumentService.getAppendixes(Document _currDocument, WCMFilter _apdFilter)

com.trs.wcm.photo 中 Appendixes 的使用

返回 Appendixes 的 com.trs.wcm.photo 中的方法
Appendixes | IImageLibService.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片
Appendixes | IImageLibMgr.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片

com.trs.wcm.photo.impl 中 Appendixes 的使用

返回 Appendixes 的 com.trs.wcm.photo.impl 中的方法
Appendixes | ImageLibServiceImpl.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)
Appendixes | ImageLibMgrImpl.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.AutoBakConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.AutoBakConfig
的使用

使用 AutoBakConfig 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 AutoBakConfig 的使用

返回 AutoBakConfig 的 com.trs.components.wcm.content.domain 中的方法
AutoBakConfig | AutoDocBakMgr.getAutoSaveConfig(WebSite _currSite)
AutoBakConfig | AutoDocBakMgr.save(AutoBakConfig _currConfig)

参数类型为 AutoBakConfig 的 com.trs.components.wcm.content.domain 中的方法
 AutoBakConfig AutoDocBakMgr.save(AutoBakConfig _currConfig)

com.trs.components.wcm.content.persistent 中 AutoBakConfig 的使用

返回 AutoBakConfig 的 com.trs.components.wcm.content.persistent 中的方法
static AutoBakConfig | AutoBakConfig.createNewInstance() 产生当前对象[AutoBakConfig]的实例
static AutoBakConfig | AutoBakConfig.findById(int _nId) 提取指定ID的对象
static AutoBakConfig | AutoBakConfig.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 AutoBakConfig 的使用

返回 AutoBakConfig 的 com.trs.service 中的方法
AutoBakConfig | IAutoDocBakService.getAutoSaveConfig(int _nSiteId) 获取指定站点上所有关于文档版本自动保存的配置信息
AutoBakConfig | IAutoDocBakService.save(AutoBakConfig _currConfig) 保存站点上关于文档版本自动保存的配置信息

参数类型为 AutoBakConfig 的 com.trs.service 中的方法
 AutoBakConfig IAutoDocBakService.save(AutoBakConfig _currConfig)
保存站点上关于文档版本自动保存的配置信息

com.trs.service.impl 中 AutoBakConfig 的使用

返回 AutoBakConfig 的 com.trs.service.impl 中的方法
AutoBakConfig | AutoDocBakService.getAutoSaveConfig(int _nSiteId)
AutoBakConfig | AutoDocBakService.save(AutoBakConfig _currConfig)

参数类型为 AutoBakConfig 的 com.trs.service.impl 中的方法
 AutoBakConfig AutoDocBakService.save(AutoBakConfig _currConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.AutoBakConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.AutoBakConfigs
的使用

使用 AutoBakConfigs 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 AutoBakConfigs 的使用

返回 AutoBakConfigs 的 com.trs.components.wcm.content.persistent 中的方法
static AutoBakConfigs | AutoBakConfigs.createNewInstance(User _currUser) 产生当前集合对象[AutoBakConfigs]的实例
static AutoBakConfigs | AutoBakConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static AutoBakConfigs | AutoBakConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[AutoBakConfigs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.BaseChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.BaseChannel
的使用

使用 BaseChannel 的软件包
com.trs.ajaxservice |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.service |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.tagparser |
com.trs.presentation.nav |
com.trs.presentation.wcm.content |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |

com.trs.ajaxservice 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.ajaxservice 中的方法
static void | ChannelServiceProviderHelper.createRelatedEmployes(java.lang.String _sRawChnlId, BaseChannel _newChannel)
static Channels | ChannelHelper.getChildren(User _loginUser, BaseChannel _parent, WCMFilter _extraFilter)

com.trs.components.common.publish.widget.tagparser 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.components.common.publish.widget.tagparser 中的方法
RightValue | WCMTagParserBaseOperation.getChannelRightValue(User _currUser, BaseChannel _oBaseChannel) 获取栏目的权限
boolean | WCMTagParserDocInChnlOperation.hasSuperRight(BaseChannel host, CMSObj _aUser) 判断当前Operator对于指定结点是否有Super权限

com.trs.components.infoview.persistent 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.components.infoview.persistent 中的方法
static InfoViewDocument InfoViewDocument.findById(BaseChannel _host, int _nChnlDocRecId, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument, int _nInfoViewId, java.lang.String _sSelectFieldsOfInfoView)
获取指定Id的ViewDocument

com.trs.components.metadata.center 中 BaseChannel 的使用

返回 BaseChannel 的 com.trs.components.metadata.center 中的方法
BaseChannel | MetaViewData.getCurrChannelOrSite()
BaseChannel | MetaViewDatas.getCurrChannelOrSite()

com.trs.components.metadata.service 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.components.metadata.service 中的方法
static void ClassInfoToChannelHelper.createChannels(ClassInfo _oParentClassInfo, BaseChannel _host, MetaView _oView, int _nMaxLevel)

参数类型为 BaseChannel 的 com.trs.components.metadata.service 中的构造方法
SynChildrenExecutorForViewEmploy(BaseChannel _oStartObj, MetaView _view, boolean _bClearEmploy)
SynChildrenExecutorForViewEmploy(BaseChannel _oStartObj, MetaView _view, boolean _bClearEmploy, boolean _bDoOnStartObj)
WCMFilterMakerForContainsChildren(BaseChannel _oStartObj)
WCMFilterMakerForContainsChildren(BaseChannel _oStartObj, boolean _bDoOnStartObj)

com.trs.components.wcm.content 中 BaseChannel 的使用

返回 BaseChannel 的 com.trs.components.wcm.content 中的方法
BaseChannel | ViewDocuments.getCurrChannelOrSite()
BaseChannel | ViewDocument.getCurrChannelOrSite()

参数类型为 BaseChannel 的 com.trs.components.wcm.content 中的方法
static ViewDocument | ViewDocument.findById(BaseChannel _host, int _nChnlDocRecId, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument) 获取指定Id的ViewDocument
static Documents | QueryDocumentCenter.queryDocumentsForUser(User _currUser, BaseChannel _oChannelOrSite, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize, boolean _bContainsChildren, WCMFilter _filter)

参数类型为 BaseChannel 的 com.trs.components.wcm.content 中的构造方法
SynChildrenOfChannelExecutorBase(BaseChannel _oStartObj)
SynChildrenOfChannelExecutorBase(BaseChannel _oStartObj, boolean _bDoOnStartObj)

com.trs.components.wcm.content.domain 中 BaseChannel 的使用

返回 BaseChannel 的 com.trs.components.wcm.content.domain 中的方法
BaseChannel | ChannelMgr.getHost(BaseChannel _oChannel) 获取栏目的父栏目,如果栏目是一级栏目,则返回该栏目所在的站点
BaseChannel | ChannelMgr.save(BaseChannel _oChannel) 保存（新增、编辑）栏目或者站点

参数类型为 BaseChannel 的 com.trs.components.wcm.content.domain 中的方法
void | DocumentMgr.clearAll(User _currUser, BaseChannel _oSiteOrChannel) 清空回收站
void | ChannelMgr.delete(BaseChannel _oChannel, boolean _bDrop)
java.lang.String | ChannelExporter.export(BaseChannel _siteOrChnl, boolean _bWithChildren, boolean _bWithRelate)
Documents | DocumentMgr.getAllDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的所有文档
CMSBaseObjs | ChannelMgr.getChildren(BaseChannel _oChannel, int _nChannelType, boolean _bIncludingDeletedChannel, WCMFilter _filter)
Documents | DocumentMgr.getDocuments(BaseChannel _oChannel, WCMFilter _filter) 取站点/频道的(除了回收站外的)文档集合
ContentExtFields | ContentExtFieldMgr.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)
WCMFilter | DocumentMgr.getFilterForDocuments(BaseChannel _oChannel, WCMFilter _docFitler)
BaseChannel | ChannelMgr.getHost(BaseChannel _oChannel) 获取栏目的父栏目,如果栏目是一级栏目,则返回该栏目所在的站点
Channels | ChannelMgr.getRecycleChannels(BaseChannel _oChannel, WCMFilter _chnlFilter) 获取符合一定条件的被删除的栏目
Documents | DocumentMgr.getRecycleDocuments(BaseChannel _currChnl, WCMFilter _filter) 取频道的废稿
Reports | ChannelImporter.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl)
void | ChannelMgr.moveTo(Channel _fromChannel, BaseChannel _toSiteOrChannel, int _nMoveToType)
void | ChannelMgr.restore(BaseChannel _oChannel) 恢复回收站中的站点/栏目
void | ChannelMgr.restore(BaseChannel _oChannel, boolean _bSystemNotifyRestore)
void | DocumentMgr.restoreAll(User _currUser, BaseChannel _oSiteOrChannel)
BaseChannel | ChannelMgr.save(BaseChannel _oChannel) 保存（新增、编辑）栏目或者站点

com.trs.components.wcm.content.domain.auth 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.components.wcm.content.domain.auth 中的方法
static boolean | DocumentAuthServer.hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Document _document, int _nRightIndex) 判断指定用户在指定频道中对于指定的文档是否具有指定的权限
static boolean | DocumentAuthServer.hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Documents _documents, int _nRightIndex)

com.trs.components.wcm.content.persistent 中 BaseChannel 的使用

com.trs.components.wcm.content.persistent 中 BaseChannel 的子类
class | Channel
class | WebSite

返回 BaseChannel 的 com.trs.components.wcm.content.persistent 中的方法
abstract BaseChannel | BaseChannel.getHost() 得到当前频道的父频道，在Channel和Site中分别定义
BaseChannel | Channel.getHost()
BaseChannel | WebSite.getHost()

参数类型为 BaseChannel 的 com.trs.components.wcm.content.persistent 中的方法
Channel | IChildrenMgr.getChildAt(BaseChannel _parent, int _nIndex)
Channel | ChildrenCacheMgr.getChildAt(BaseChannel _parent, int _nIndex)
int | IChildrenMgr.getChildrenSize(User _currUser, BaseChannel _parent) 获取当前站点/频道的子频道数目
int | ChildrenCacheMgr.getChildrenSize(User _currUser, BaseChannel _parent)
int | IChildrenMgr.getSiblingIndex(BaseChannel _channel) 获取指定频道/站点在其同级目录中的位置
int | ChildrenCacheMgr.getSiblingIndex(BaseChannel _channel)
java.util.List | IChildrenMgr.listChildren(User _currUser, BaseChannel _parent, int _nType) 获取子频道列表
java.util.List | ChildrenCacheMgr.listChildren(User _currUser, BaseChannel _parent, int _nType)
java.util.List | IChildrenMgr.listChildren(User _currUser, BaseChannel _parent, int[] _arrayTypes) 获取子频道列表
java.util.List | ChildrenCacheMgr.listChildren(User _currUser, BaseChannel _parent, int[] _arrayNeedType)
boolean | Channel.setParent(BaseChannel _parent) Sets the parent of this channel.

com.trs.components.wcm.publish 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.components.wcm.publish 中的方法
static java.lang.String | WCMPublishHelper.getDataPath(BaseChannel _channel)
void | WCMPubStatusConfig.setFolderType(BaseChannel _currChannel)

com.trs.components.wcm.publish.tagparser 中 BaseChannel 的使用

返回 BaseChannel 的 com.trs.components.wcm.publish.tagparser 中的方法
static BaseChannel | WCMTagParserHelper.findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel) Returns the current host as a channel.
static BaseChannel | WCMTagParserHelper.findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel, boolean _bIsFromAllCataTag)
static BaseChannel | WCMTagParserHelper.findFolderHostByOldModal(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel)
static BaseChannel | WCMTagParserHelper.findTopNewsOrPicChannel(BaseChannel _parent, int _nChannelType)

参数类型为 BaseChannel 的 com.trs.components.wcm.publish.tagparser 中的方法
static BaseChannel WCMTagParserHelper.findTopNewsOrPicChannel(BaseChannel _parent, int _nChannelType)

com.trs.presentation.nav 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.presentation.nav 中的方法
 boolean TreeCreator.hasSuperRight(BaseChannel host, CMSObj _aUser)
判断当前Operator对于指定结点是否有Super权限

com.trs.presentation.wcm.content 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.presentation.wcm.content 中的构造方法
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, BaseChannel _baseChannel)

com.trs.service 中 BaseChannel 的使用

返回 BaseChannel 的 com.trs.service 中的方法
 BaseChannel IChannelService.save(BaseChannel _currBaseChannel)
保存指定的站点/频道

参数类型为 BaseChannel 的 com.trs.service 中的方法
Reports | IChannelService.createFrom(Channel _srcChannel, BaseChannel _parent) 频道的类似创建的实现 从指定的频道获取频道的相关属性,创建一个新的频道 新频道与源频道有基本相同的属性.
Reports | IChannelService.createFrom(int _nChannelId, BaseChannel _parent) 频道的类似创建的实现
void | IPublishService.delete(BaseChannel _siteOrChannel) 删除指定站点/频道的发布页面
boolean | IChannelService.delete(BaseChannel _oChannel, boolean _bDrop) 删除站点/频道
void | IChannelService.deleteExtFields(BaseChannel _siteOrChannel, java.lang.String _extFieldIds, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
void | IChannelService.deleteExtFiled(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
Schedule | IScheduleService.deletePublishSchedule(BaseChannel _currChannel) 删除指定站点或频道的计划发布
java.lang.String | IChannelService.export(BaseChannel _fromChannel, boolean _bWithChildren, boolean _bWithRelated) 将WCM的站点、频道导出成为WCM XML标准格式的字符串
WCMFolderPublishConfig | IWCMPublishElementService.findFolderConfig(BaseChannel _currChannel) 获取当前站点或频道的发布配置信息
Schedule | IScheduleService.findPublishSchedule(BaseChannel _currChannel) 获取指定站点或频道的计划发布信息
java.lang.String | ICDSService.getChannelsXML(BaseChannel _oBaseChannel, boolean _bIncludeChildren) 获取指定站点或频道的树状结构信息
java.util.List | IChannelService.getChildren(BaseChannel _oChannel) 获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限
java.util.List | IChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex) 获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)
java.util.List | IChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex, int _nChannelType) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
java.util.List | IChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex, int[] _nArrayChannelType) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
java.util.List | IChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex, int[] _nArrayChannelType, java.lang.StringBuffer _sbNoRightIds) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
Documents | IChannelService.getDocuments(BaseChannel _oChannel) 获取当前站点/频道下的有效文档
Documents | IChannelService.getDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的有效文档
ContentExtFields | IChannelService.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter) 获取指定站点/频道下的扩展字段.
Channels | IChannelService.getRecycleChannels(BaseChannel _oChannel) 获取当前站点/频道下的废弃频道集合
Channels | IChannelService.getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的废弃频道集合
Documents | IChannelService.getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的废稿
Documents | IDocumentService.getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter) 获取当前站点或频道的回收站的文档
Reports | IChannelService.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl) 从zip/xml文件中导入站点/频道
boolean | IChannelService.isVisible(User _currUser, BaseChannel _currChannel) 判断指定的频道对象对于用户是否可见
boolean | IChannelService.isVisible(User _currUser, BaseChannel _currChannel, int _nRightIndex) 判断在指定的权限值下，指定的频道对象对于用户是否可见
java.lang.String[] | IPublishService.preview(BaseChannel _siteOrChannel, java.lang.String[] _warningsHolder) 预览指定的站点/频道，并返回预览页面的URL列表（若配置了多个概览模板，则可能有多个）。
void | IPublishService.publish(BaseChannel _siteOrChannel, int _nPublishType) 完全发布站点/频道
void | IPublishService.publishConfirm(BaseChannel _oSiteOrChnl, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile) 确认（批准）发布 用于先将站点或频道的首页发布到一个临时文件，在确认没有错误后，再把临时文件重名为正式的站点或频道首页。
void | IChannelService.restore(BaseChannel _oChannel) 恢复站点/频道
BaseChannel | IChannelService.save(BaseChannel _currBaseChannel) 保存指定的站点/频道
WCMFolderPublishConfig | IWCMPublishElementService.save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig) 保存当前站点或频道的发布配置信息
ContentExtField | IChannelService.saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited) 保存指定的扩展字段
Schedule | IScheduleService.savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel) 给指定的站点或频道设置计划发布属性

com.trs.service.impl 中 BaseChannel 的使用

返回 BaseChannel 的 com.trs.service.impl 中的方法
 BaseChannel ChannelService.save(BaseChannel _currBaseChannel)
保存指定的站点/频道

参数类型为 BaseChannel 的 com.trs.service.impl 中的方法
Reports | ChannelService.createFrom(Channel _srcChannel, BaseChannel _parent)
Reports | ChannelService.createFrom(int _nChannelId, BaseChannel _parent)
void | PublishService.delete(BaseChannel _siteOrChannel) 已过时。 根本就没有没有使用，声明为废弃的，以标识
boolean | ChannelService.delete(BaseChannel _oChannel, boolean _bDrop) 删除站点/频道
void | ChannelService.deleteExtFields(BaseChannel _siteOrChannel, java.lang.String _extFieldIds, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
void | ChannelService.deleteExtFiled(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
Schedule | ScheduleService.deletePublishSchedule(BaseChannel _currChannel)
java.lang.String | ChannelService.export(BaseChannel _fromChannel, boolean _bWithChildren, boolean _bWithRelated)
WCMFolderPublishConfig | WCMPublishElementServiceImpl.findFolderConfig(BaseChannel _currChannel)
Schedule | ScheduleService.findPublishSchedule(BaseChannel _currChannel)
java.lang.String | CDSServiceImpl.getChannelsXML(BaseChannel _oBaseChannel, boolean _bIncludeChildren)
java.util.List | ChannelService.getChildren(BaseChannel _oChannel) 获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限
java.util.List | ChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex) 获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)
java.util.List | ChannelService.getChildren(BaseChannel _parentChannel, int _nRightIndex, int _nChannelType) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
java.util.List | ChannelService.getChildren(BaseChannel _parentChannel, int _nRightIndex, int[] _nArrayChannelType) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
java.util.List | ChannelService.getChildren(BaseChannel _parentChannel, int _nRightIndex, int[] _nArrayChannelType, java.lang.StringBuffer _sbNoRightIds) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
Documents | ChannelService.getDocuments(BaseChannel _oChannel) 获取当前站点/频道下的有效文档
Documents | ChannelService.getDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的有效文档
ContentExtFields | ChannelService.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter) 获取指定站点/频道下的扩展字段.
Channels | ChannelService.getRecycleChannels(BaseChannel _oChannel) 获取当前站点/频道下的废弃频道集合
Channels | ChannelService.getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的废弃频道集合
Documents | DocumentService.getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter)
Documents | ChannelService.getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的废稿
Reports | ChannelService.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl) 站点、频道导出、类似创建相关的方法
boolean | ChannelService.isVisible(User _currUser, BaseChannel _currChannel)
boolean | ChannelService.isVisible(User _currUser, BaseChannel _currChannel, int _nRightIndex)
java.lang.String[] | PublishService.preview(BaseChannel _siteOrChannel, java.lang.String[] _warningsToReturn)
void | PublishService.publish(BaseChannel _siteOrChannel, int _nPublishType)
void | PublishService.publishConfirm(BaseChannel _oSiteOrChnl, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile)
void | ChannelService.restore(BaseChannel _oChannel) 恢复站点/频道
BaseChannel | ChannelService.save(BaseChannel _currBaseChannel) 保存指定的站点/频道
WCMFolderPublishConfig | WCMPublishElementServiceImpl.save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig)
ContentExtField | ChannelService.saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited) 保存指定的扩展字段
Schedule | ScheduleService.savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel)

com.trs.wcm.old 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.wcm.old 中的方法
 WCMFormInfos WCMFormMgr.getForms(BaseChannel _oChannel, boolean _bChildren, WCMFilter _filter)
获取站点/频道的自定义表单
从ChannelMgr中移动过来的 hx@050328

com.trs.wcm.photo 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.wcm.photo 中的方法
Documents | IImageLibService.getDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前分类下所有的图片
Appendixes | IImageLibService.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片
Appendixes | IImageLibMgr.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片

com.trs.wcm.photo.impl 中 BaseChannel 的使用

参数类型为 BaseChannel 的 com.trs.wcm.photo.impl 中的方法
Documents | ImageLibServiceImpl.getDocuments(BaseChannel _oChannel, WCMFilter _filter)
Appendixes | ImageLibServiceImpl.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)
Appendixes | ImageLibMgrImpl.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Channel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Channel
的使用

使用 Channel 的软件包
com.trs.ajaxservice |
com.trs.ajaxservice.xmlconvertors |
com.trs.cms.auth.domain |
com.trs.components.comment.persistent |
com.trs.components.common.trsad |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.helper |
com.trs.components.infoview.mad |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.service |
com.trs.components.stat |
com.trs.components.wcm.auth |
com.trs.components.wcm.channel |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.trsserver |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.publish.domain |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.wcmx.jsp |
com.trs.components.wcm.wcmx.websites |
com.trs.presentation.nav |
com.trs.presentation.wcm.content |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |

com.trs.ajaxservice 中 Channel 的使用

参数类型为 Channel 的 com.trs.ajaxservice 中的方法
static void | ChannelServiceProviderHelper.createRelatedEmployes(Channel sourceChannel, Channel newChannel)
static void | DocumentPublishHelper.delete(Documents _documents, Channel _channel)
static void | DocumentPublishHelper.delete(Documents _documents, Channel _channel, boolean _bAll)
static java.lang.String | WCMDocumentHelper.makeRightValue(MethodContext _methodContext, User _loginUser, Channel _currChannel, Document _document) 构造指定文档在指定栏目中的权限

com.trs.ajaxservice.xmlconvertors 中 Channel 的使用

参数类型为 Channel 的 com.trs.ajaxservice.xmlconvertors 中的方法
static void ChannelToXML.doFilterRight(RightValue _rightValue, Channel _channel)

com.trs.cms.auth.domain 中 Channel 的使用

参数类型为 Channel 的 com.trs.cms.auth.domain 中的方法
 void RightHostLCListenerForInherit.inheritObjectMembers(Channel _oChannel)

com.trs.components.comment.persistent 中 Channel 的使用

返回 Channel 的 com.trs.components.comment.persistent 中的方法
 Channel DocumentTopic.getChannel()
取主题所属频道对象

com.trs.components.common.trsad 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.common.trsad 中的方法
 void ADPos.ChnlInit(Channel _chnl, User _user)
初始化栏目

com.trs.components.infoview 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.infoview 中的方法
static InfoView InfoViewHelper.getInfoView(Channel _oChannel)

com.trs.components.infoview.helper 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.infoview.helper 中的方法
WCMFilter | InfoViewChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
WCMFilter | InfoViewChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)

com.trs.components.infoview.mad 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.infoview.mad 中的方法
Documents | InfoViewQueryHelper.getDocuments(Channel _channel, MethodContext _context)
Documents | InfoViewQueryHelperImpl.getDocuments(Channel _channel, MethodContext _context)

com.trs.components.infoview.persistent 中 Channel 的使用

返回 Channel 的 com.trs.components.infoview.persistent 中的方法
 Channel InfoViewData.getChannel()

com.trs.components.metadata.center 中 Channel 的使用

返回 Channel 的 com.trs.components.metadata.center 中的方法
Channel | MetaViewData.getChannel() 获取文档当前所处的栏目
Channel | MetaViewData.getDocChannel()

参数类型为 Channel 的 com.trs.components.metadata.center 中的方法
void | MetaViewEmployerMgr.clearEmployer(User _currUser, Channel _channel)
void | IMetaViewEmployerMgr.clearEmployer(User _currUser, Channel _channel) 清除指定栏目所配置的视图关系
MetaView | MetaViewEmployerMgr.getViewOfEmployer(Channel _channel)
MetaView | IMetaViewEmployerMgr.getViewOfEmployer(Channel _channel) 获取指定栏目配置的视图
void | MetaViewDatas.open(Channel _channel, WCMFilter _filter)
void | MetaViewEmployerMgr.setEmployer(User _currUser, Channel _channel, MetaView _view)
void | IMetaViewEmployerMgr.setEmployer(User _currUser, Channel _channel, MetaView _view) 给指定的栏目配置指定的视图

com.trs.components.metadata.center.xml 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.metadata.center.xml 中的构造方法
MetaViewDataImporter(User _currUser, MetaView _dstView, Channel _dstChannel)

com.trs.components.metadata.service 中 Channel 的使用

返回 Channel 的 com.trs.components.metadata.service 中的方法
Channel | DefaultChannelMakerCenter.makeDefaultChannel(User _loginUser, int _nViewId) 构造用户在指定视图上默认存储的栏目
Channel | IDefaultChannelMaker.makeDefaultChannel(User _loginUser, int _nViewId) 构造当前用户默认的栏目
Channel | UserRelateInfoMaker.makeDefaultChannel(User _loginUser, int _nViewId)

com.trs.components.stat 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.stat 中的方法
java.util.List | IChnlDeptMgr.getDepIdsByChannel(Channel channel) 根据栏目返回组织的id数组
java.util.List | ChnlDeptMgr.getDepIdsByChannel(Channel _channel) 通过栏目获取组织的ID序列
java.lang.String | IChnlDeptMgr.getDepNamesByChannel(Channel channel, User user) 根据栏目获取组织名称或者用户获取组织
java.lang.String | ChnlDeptMgr.getDepNamesByChannel(Channel _channel, User _user) 通过栏目或用户获取组织名称

com.trs.components.wcm.auth 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.wcm.auth 中的方法
static boolean ChannelAuthHelper.hasRight(User _currUser, Channel _channel, int _nRightIndex)

com.trs.components.wcm.channel 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.wcm.channel 中的方法
 void VChannelManager.save(Channel _parent, VChannel _oVChannel)

com.trs.components.wcm.content 中 Channel 的使用

返回 Channel 的 com.trs.components.wcm.content 中的方法
Channel | ViewDocument.getChannel() 获取文档当前所处的栏目
Channel | ViewDocument.getDocChannel()

参数类型为 Channel 的 com.trs.components.wcm.content 中的方法
void | ViewDocuments.open(Channel _channel, WCMFilter _filter)
void | ViewDocument.setDocChannel(Channel docChannel)

com.trs.components.wcm.content.domain 中 Channel 的使用

返回 Channel 的 com.trs.components.wcm.content.domain 中的方法
 Channel ChannelMgr.getChannelByName(int _nSiteId, java.lang.String _sChnlName)
根据栏目名称取栏目

参数类型为 Channel 的 com.trs.components.wcm.content.domain 中的方法
void | DocumentMgr.changeStatus(Document _currDocument, Channel _currChannel, int _newStatusId)
void | DocumentMgr.changeStatus(Document _currDocument, Channel _currChannel, Status _newStatus) 修改ChnlDoc中对应的状态 如果是实体文档，则同步状态
Document | DocumentMgr.copyDocument(Document _fromDocument, Channel _fromChannel, Channel _toChannel) 复制文档到另一个频道上 不负责非依赖型关联对象的复制，如附件和相关文档 不能将一个文档从草稿箱或者复制到草稿箱 复制引用转发的文档相当于创建一个新的引用转发 复制实体文档，则需要在目标频道下创建一个新的实体文档
void | DocumentMgr.delete(Document _currDocument, Channel _currChannel, boolean _bDrop) 从某个频道下删除一篇文档 频道为一个真实频道，暂时不支持从回收站、草稿箱或其它特殊频道中删除。
ChnlDoc | DocumentMgr.findChnlDoc(Document _currDocument, Channel _currChannel) 根据文档和频道，找到对应的ChnlDoc
ChannelSyns | AutoTransmitMgr.getChannelSyns(Channel _currChannel, WCMFilter _filter)
ChannelSyns | AutoTransmitMgr.getChannelSyns(Channel _currChannel, WCMFilter _filter, boolean _bChannelAsTarget)
static Documents | DocumentsGetHelper.getDocuments(Channel _channel, WCMFilter _filter)
static Documents | DocumentsGetHelper.getDocuments(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder)
CMyDateTime | DocumentMgr.getDocumentTopTime(Document _currDocument, Channel _currChannel) 获得文档置顶的截止时间 如果文档没有置顶，则直接返回null 如果置顶文档没有设置截止时间则返回null
ChannelSyns | AutoTransmitMgr.getRelatedChannelSyns(Channel _currChannel, WCMFilter _filter)
Replaces | ReplaceMgr.getReplaces(Channel _oChannel, WCMFilter _filter) 获取当前频道下的替换内容
Channels | AutoTransmitMgr.getSynSrcChannels(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | AutoTransmitMgr.getSynToChannels(Channel _currChannel) 获取当前频分发文档的目标频道集合
Documents | DocumentMgr.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档
int | DocumentMgr.getTopPosition(Channel _currChannel, Document _currDocument) 得到频道下文档的置顶位置
Reports | DocumentImporter.importFromFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从文件中导入文档 支持从zip,xml,html,htm文件导入
Reports | DocumentImporter.importFromFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel, boolean bImportbyName)
Reports | DocumentImporter.importFromFileByName(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel, boolean bImportbyName)
Reports | DocumentImporter.importFromTRSFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sDefineXmlForTRServer, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从TRS文件中导入文档 支持从zip,xml,html,htm文件导入
boolean | DocumentMgr.isDocumentTopped(Document _currDocument, Channel _currChannel) 判断一个频道下的文档是否是处于置顶状态
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle, int _nTrueChannelId)
Report | DocumentMgr.mirrorTo(Document _fromDocument, Channel _toChannel) 将实体文档镜像转发到另一个频道 草稿箱中的文档无法转发 目标频道为空无法转发
Reports | DocumentMgr.moveAllDocumentsToChannel(Channel _fromChannel, Channel _toChannel) 移动当前栏目下现有文档到指定的频道
void | DocumentMgr.moveDocumentInChannel(Document _fromDocument, Document _toDocument, Channel _currChannel) 在频道中移动文档的顺序 如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后 通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作 置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
void | DocumentMgr.moveDocumentInChannel(Document _fromDocument, Document _toDocument, Channel _currChannel, int _nPosition) 在频道中移动文档的顺序 如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后 通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作 置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
Reports | DocumentMgr.moveDocumentsToChannel(ViewDocuments _sViewDocuments, Channel _fromChannel, Channel _toChannel)
void | ChannelMgr.moveTo(Channel _fromChannel, BaseChannel _toSiteOrChannel, int _nMoveToType)
void | ChannelMgr.moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType) 将栏目移动到栏目，作为兄弟或者子栏目
void | ChannelMgr.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType) 将栏目移动到站点，作为兄弟或者子栏目
Report | DocumentMgr.moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel) 将文档从一个频道移动到另一个频道 支持引用和镜像的移动 如果是草稿箱中的，则不支持移动；也不支持移动到草稿箱 如果目标频道下已经存在，则无法移动
Report | DocumentMgr.moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel, java.lang.String _sIsPhoto)
Report | DocumentMgr.quoteTo(Document _fromDocument, Channel _toChannel) 将实体文档引用转发到另一个频道 草稿箱中的文档无法转发 目标频道为空无法转发
Report | DocumentMgr.quoteTo(Document _fromDocument, Channel _toChannel, java.lang.String _sIsPhoto)
void | DocumentMgr.removeToppedDocument(Channel _currChannel, Document _currDocument) 取消特定频道下某文档的置顶标志 该文档将成为普通文档 注意，不是删除文档！
void | DocumentMgr.restore(Document _delDocument, Channel _currChannel) 还原频道回收站中的一篇频道文档
void | DocumentMgr.setTopDocument(Channel _currChannel, Document _fromDocument, Document _toDocument, int _nPosition, CMyDateTime dtValid)
void | DocumentMgr.setTopDocument(Channel _currChannel, Document _currDocument, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶 如果特定的位置已经存在文档，则需要将该位置及其后的所有置顶向后移动一位 如果最后一个置顶项目也有占用，则自动将置顶位置扩展一位！
void | DocumentMgr.setTopedDocument(Document _document, Channel _channel, int _nTopOrder, CMyDateTime _dtTopedValid)

com.trs.components.wcm.content.domain.auth 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.wcm.content.domain.auth 中的方法
static boolean | DocumentAuthServer.isRightIndexDefineOnChannel(int _nRightIndex, Channel _currChannel) 判断指定的权限值是否是从当前所属频道进行判断的权限
static java.lang.String | DocumentAuthServer.makeLogicRightValue(User _loginUser, Channel _currChannel, Document _currDocument) 构造用户对于指定栏目的指定文档的权限值

com.trs.components.wcm.content.persistent 中 Channel 的使用

声明为 Channel 的 com.trs.components.wcm.content.persistent 中的字段
static Channel Channel.DRAFT_CHANNEL

返回 Channel 的 com.trs.components.wcm.content.persistent 中的方法
static Channel | Channel.createNewInstance() 产生当前对象[Channel]的实例
static Channel | Channel.findById(int _nId) 提取指定ID的对象
static Channel | Channel.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Channel | IChannelNameMgr.findByName(int p_nSiteId, java.lang.String p_sName) 提取指定站点、指定名称的频道
Channel | ChannelNameMgr.findByName(int p_nSiteId, java.lang.String p_sName) 提取指定站点、指定名称的频道
static Channel | Channel.findByName(int _nSiteId, java.lang.String _sChannelName)
Channel | ChnlDoc.getChannel() 取文档所属频道对象
Channel | Replace.getChannel() 获取所属频道
Channel | ChannelContentLink.getChannel() 获取所属栏目
Channel | Document.getChannel() 取文档所属频道对象
Channel | IChildrenMgr.getChildAt(BaseChannel _parent, int _nIndex)
Channel | ChildrenCacheMgr.getChildAt(BaseChannel _parent, int _nIndex)
Channel | BaseChannel.getChildAt(int _nIndex)
Channel | Channel.getParent() 获取父频道对象
Channel | ChannelSyn.getSrcChannel() 获取源频道
Channel | ChannelSyn.getToChannel() 获取目标频道

参数类型为 Channel 的 com.trs.components.wcm.content.persistent 中的方法
static ChnlDoc | ChnlDoc.findByDocAndChnl(Document _currDocument, Channel _currChannel) 根据文档和频道，找到对应的ChnlDoc
boolean | Document.setChannel(Channel _channel) 设置文档所属频道
void | ChannelLoopValidator.validEditModeChannel(Channel _currChannel)
void | ChannelLoopValidator.validHasExistsChannel(Channel _channel)

com.trs.components.wcm.content.trsserver 中 Channel 的使用

返回 Channel 的 com.trs.components.wcm.content.trsserver 中的方法
 Channel TreeNode.getChannel()

参数类型为 Channel 的 com.trs.components.wcm.content.trsserver 中的构造方法
TreeNode(Channel _channel, int _nChildMaxCount)

com.trs.components.wcm.customize 中 Channel 的使用

返回 Channel 的 com.trs.components.wcm.customize 中的方法
 Channel UserSetting.getObjAsChannel(User _currUser)
若定制对象为频道，则取其对应的频道对象 //why: 2002-04-02 扩展接口 说明：若不是频道对象，则返回null.

com.trs.components.wcm.epress 中 Channel 的使用

返回 Channel 的 com.trs.components.wcm.epress 中的方法
 Channel EPressChannelWrapper.save(User _user, Channel _channel)

参数类型为 Channel 的 com.trs.components.wcm.epress 中的方法
void | EPressImporter.importDocuments(java.lang.String _dataZipFile, Channel _channel)
void | EPressXPlusImporter.importFromXPlus(java.lang.String _zipData, java.lang.String _tcf, Channel _channel)
Channel | EPressChannelWrapper.save(User _user, Channel _channel)

参数类型为 Channel 的 com.trs.components.wcm.epress 中的构造方法
EPressHistoryGenerator(Channel _channel)
EPressHistoryGenerator(Channel _channel, boolean _zPubAction)

com.trs.components.wcm.publish.domain 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.wcm.publish.domain 中的方法
Documents[] | PreNextDocumentsImpl.getPreNextDocuments(Channel _channel, Document document, int num)
Documents[] | IPreNextDocuments.getPreNextDocuments(Channel _channel, Document _currDocument, int _nNum) 获取前/后N篇文档集合

com.trs.components.wcm.publish.element 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.wcm.publish.element 中的构造方法
PublishFolderChannelImpl(Channel _channel)
constructor

com.trs.components.wcm.wcmx.jsp 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.wcm.wcmx.jsp 中的方法
static java.lang.String | DocOperDefine.getDelFunc(Document _currDoc, Channel _currChnl) 获取删除文件的Javascript
static java.lang.String | DocOperDefine.getEditFunc(Document _currDoc, Channel _currChnl) 获取编辑文档的Javascript
static java.lang.String | DocOperDefine.getSaveBakFunc(Document _currDoc, Channel _currChnl) 获取保存版本的Javascript
static java.lang.String | DocOperDefine.getShowBakFunc(Document _currDoc, Channel _currChnl) 获取管理版本的Javascript
static java.lang.String | DocOperDefine.getTransmitFunc(Document _currDoc, Channel _currChnl) 获取转发文档的Javascript

com.trs.components.wcm.wcmx.websites 中 Channel 的使用

参数类型为 Channel 的 com.trs.components.wcm.wcmx.websites 中的方法
static java.lang.String ChannelRelated.getChnlOrderHtml(Channel _currChnl, User _currUser)
获取设置频道顺序的HTML代码

com.trs.presentation.nav 中 Channel 的使用

参数类型为 Channel 的 com.trs.presentation.nav 中的方法
 boolean TreeCreator.hasRight(Channel _channel)

com.trs.presentation.wcm.content 中 Channel 的使用

返回 Channel 的 com.trs.presentation.wcm.content 中的方法
 Channel DocumentsPageHelper.getDocChannel(Document _document)

参数类型为 Channel 的 com.trs.presentation.wcm.content 中的构造方法
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, Channel _channel)

com.trs.service 中 Channel 的使用

返回 Channel 的 com.trs.service 中的方法
 Channel InfoViewContext.getChannel()

参数类型为 Channel 的 com.trs.service 中的方法
void | IDocumentService.changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
void | IDocumentService.changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
Reports | IChannelService.createFrom(Channel _srcChannel, BaseChannel _parent) 频道的类似创建的实现 从指定的频道获取频道的相关属性,创建一个新的频道 新频道与源频道有基本相同的属性.
void | IPublishService.delete(Document _document, Channel _channel) 从指定频道上删除指定文档已发布的页面
boolean | IDocumentService.delete(Document _currDocument, Channel _currChannel, boolean _bDrop) 删除当前频道的一个文档
void | IPublishService.delete(Documents _documents, Channel _channel) 从指定频道上删除指定文档集合已发布的页面
boolean | IDocumentService.delete(Documents _aDocuments, Channel _currChannel, boolean _bDrop) 批量删除当前频道下的文档
boolean | IDocumentService.delete(int _nDocumentId, Channel _currChannel, boolean _bDrop) 删除当前频道下的一个文档
boolean | IDocumentService.delete(java.lang.String _sDocumentIds, Channel _currChannel, boolean _bDrop) 根据文档id序列批量删除当前频道下的文档
Replaces | IChannelService.getReplaces(Channel _oChannel, WCMFilter _filter) 获取指定频道下的替换内容对象集合
Channels | IChannelService.getSynSrcChannel(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | IChannelService.getSynToChannel(Channel _currChannel) 获取当前频道分发文档的目标频道集合
Documents | IDocumentService.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档
int | IDocumentService.getTopPosition(Document _currDocument, Channel _currChannel) 得到当前频道下的特定文档的置顶位置
CMyDateTime | IDocumentService.getTopTime(Document _currDocument, Channel _currChannel) 获得文档置顶的截止时间 如果文档没有置顶，则直接返回null 如果置顶文档没有设置截止时间则返回null
boolean | IDocumentService.isDocumentTopped(Document _currDocument, Channel _currChannel) 判断一个频道下的文档是否是处于置顶状态 应用层可以利用这个接口，在文档列表前加上图片标识
boolean | IDocumentService.isDocumentTopScheduled(Document _currDocument, Channel _currChannel) 判断频道下的文档如果置顶的话，是否已经加入了计划调度
void | IDocumentService.mirrorTo(Document _currDocument, Channel _toChannel) 将文档在另一个频道中建立一个同源异现的镜像
void | IChannelService.moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType) 将频道移动到另一个频道下，作为该频道的子频道或者兄弟
void | IChannelService.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType) 将频道移动到站点下，作为站点的一级子频道
java.lang.String | IPublishService.preview(Document _document, Channel _channel, java.lang.String[] _warningsHolder) 在指定的频道上预览文档，并返回预览页面的URL。
java.lang.String | IPublishService.previewInfoviewPrint(Document _document, Channel _channel, java.lang.String[] _waringsHolder, int _templateId)
void | IPublishService.publish(Document _document, Channel _channel, int _nPubType) 发布文档
void | IPublishService.publish(Documents _documents, Channel _channel, int _nPubType) 发布指定文档集合
void | IDocumentService.removeToppedDocument(Document _currDocument, Channel _currChannel) 取消特定频道下某文档的置顶标志 该文档将成为普通文档 注意，不是删除文档！
void | IDocumentService.restore(Document _currDocument, Channel _currChannel) 恢复回收站中的文档
void | IDocumentService.setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶

com.trs.service.impl 中 Channel 的使用

参数类型为 Channel 的 com.trs.service.impl 中的方法
void | DocumentService.changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus)
void | DocumentService.changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus)
Reports | ChannelService.createFrom(Channel _srcChannel, BaseChannel _parent)
void | PublishService.delete(Document _document, Channel _channel) 已过时。 根本就没有没有使用，声明为废弃的，以标识
boolean | DocumentService.delete(Document _currDocument, Channel _currChannel, boolean _bDrop)
void | PublishService.delete(Documents _documents, Channel _channel)
boolean | DocumentService.delete(Documents _currDocuments, Channel _currChannel, boolean _bDrop)
boolean | DocumentService.delete(int _nDocumentId, Channel _currChannel, boolean _bDrop)
boolean | DocumentService.delete(java.lang.String _sDocumentIds, Channel _currChannel, boolean _bDrop)
Replaces | ChannelService.getReplaces(Channel _oChannel, WCMFilter _filter)
Channels | ChannelService.getSynSrcChannel(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | ChannelService.getSynToChannel(Channel _currChannel) 获取当前频道分发文档的目标频道集合
Documents | DocumentService.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter)
int | DocumentService.getTopPosition(Document _currDocument, Channel _currChannel)
CMyDateTime | DocumentService.getTopTime(Document _currDocument, Channel _currChannel)
boolean | DocumentService.isDocumentTopped(Document _currDocument, Channel _currChannel)
boolean | DocumentService.isDocumentTopScheduled(Document _currDocument, Channel _currChannel)
void | DocumentService.mirrorTo(Document _currDocument, Channel _toChannel)
void | ChannelService.moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType)
void | ChannelService.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType)
java.lang.String | PublishService.preview(Document _document, Channel _channel, java.lang.String[] _warningsHolder)
java.lang.String | PublishService.preview(Document _document, Channel _channel, java.lang.String[] holder, Template _template)
java.lang.String | PublishService.previewInfoviewPrint(Document _document, Channel _channel, java.lang.String[] _warningsHolder, int _templateId)
void | PublishService.publish(Document _document, Channel _channel, int _nPubType)
void | PublishService.publish(Documents _documents, Channel _channel, int _nPubType)
void | DocumentService.removeToppedDocument(Document _currDocument, Channel _currChannel)
void | DocumentService.restore(Document _currDocument, Channel _currChannel)
void | DocumentService.setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil)

com.trs.wcm.old 中 Channel 的使用

返回 Channel 的 com.trs.wcm.old 中的方法
Channel | WCMFormInfo.getChannel() 获取表单的所属频道对象
Channel | WCMExcelData.getChannel() 取所属频道对象
Channel | ImportDocsContext.getCurrChannel() 返回当前栏目

参数类型为 Channel 的 com.trs.wcm.old 中的方法
boolean | WCMExcelData.setChannel(Channel _channel) 设置所属频道
void | ImportDocsContext.setCurrChannel(Channel _currChannel) 设置当前栏目

com.trs.wcm.photo 中 Channel 的使用

返回 Channel 的 com.trs.wcm.photo 中的方法
 Channel ImageKind.getRelatedChannel()

参数类型为 Channel 的 com.trs.wcm.photo 中的方法
java.util.List | IImageLibService.getChannels(User _user, int _nRightIndex, Channel _channel) 获取指定用户在指定分类可见的子分类列表
java.util.List | IImageLibService.getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter) 获取指定用户在指定分类可见的子分类列表

com.trs.wcm.photo.impl 中 Channel 的使用

参数类型为 Channel 的 com.trs.wcm.photo.impl 中的方法
java.util.List | ImageLibServiceImpl.getChannels(User _user, int _nRightIndex, Channel _channel)
java.util.List | ImageLibServiceImpl.getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter)
void | PhotoImporter.importViaZipFile(java.lang.String fn, Channel channel)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChannelContentLink 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChannelContentLink
的使用

使用 ChannelContentLink 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 ChannelContentLink 的使用

返回 ChannelContentLink 的 com.trs.components.wcm.content.persistent 中的方法
static ChannelContentLink | ChannelContentLink.createNewInstance() 产生当前对象[ChannelContentLink]的实例
static ChannelContentLink | ChannelContentLink.findById(int _nId) 提取指定ID的对象
static ChannelContentLink | ChannelContentLink.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChannelContentLinks 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChannelContentLinks
的使用

使用 ChannelContentLinks 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 ChannelContentLinks 的使用

返回 ChannelContentLinks 的 com.trs.components.wcm.content.persistent 中的方法
static ChannelContentLinks | ChannelContentLinks.createNewInstance(User _currUser) 产生当前集合对象[ChannelContentLinks]的实例
static ChannelContentLinks | ChannelContentLinks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ChannelContentLinks | ChannelContentLinks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChannelContentLinks]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChannelLoopValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChannelLoopValidator
的使用

没有 com.trs.components.wcm.content.persistent.ChannelLoopValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChannelNameMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChannelNameMgr
的使用

没有 com.trs.components.wcm.content.persistent.ChannelNameMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Channels 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Channels
的使用

使用 Channels 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.domain.template
com.trs.components.infoview.helper
com.trs.components.metadata.center
com.trs.components.metadata.service
com.trs.components.stat
com.trs.components.wcm.content
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.customize
com.trs.components.wcm.recent
com.trs.components.wcm.wcmx.util
com.trs.presentation.nav
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 Channels 的使用

返回 Channels 的 com.trs.ajaxservice 中的方法
Channels | ProcessService.getChannelsUseingFlow(MethodContext _methodContext) 获取使用了指定工作流的栏目列表
static Channels | ChannelHelper.getChildren(User _loginUser, BaseChannel _parent, WCMFilter _extraFilter)
Channels | DocumentServiceProvider.getQuotedChannels(MethodContext _MethodContext) 获取所有引用指定文档的栏目集合
Channels | ChannelServiceProvider.getRecycleChannels(MethodContext _methodContext) 获取回收站的栏目列表

参数类型为 Channels 的 com.trs.ajaxservice 中的方法
static void ChannelHelper.removeNoRightChannel(User _loginUser, Channels _channels, int _nRightIndex)

com.trs.components.common.publish.domain.template 中 Channels 的使用

参数类型为 Channels 的 com.trs.components.common.publish.domain.template 中的方法
 Reports TemplateMgr.copyVisualTempToChnls(Channels _toChannels, Template _srcTemplate)
在指定栏目下，类似创建可视化模板

com.trs.components.infoview.helper 中 Channels 的使用

参数类型为 Channels 的 com.trs.components.infoview.helper 中的方法
 WCMFilter InfoViewChnlDocFilterHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)

com.trs.components.metadata.center 中 Channels 的使用

返回 Channels 的 com.trs.components.metadata.center 中的方法
Channels | MetaViewEmployerMgr.getEmployers(MetaView _view, WCMFilter _extraFilter)
Channels | IMetaViewEmployerMgr.getEmployers(MetaView _view, WCMFilter _extraFilter) 获取使用了指定视图的所有栏目

参数类型为 Channels 的 com.trs.components.metadata.center 中的方法
 void MetaViewDatas.open(Channels _channels, WCMFilter _filter)

com.trs.components.metadata.service 中 Channels 的使用

返回 Channels 的 com.trs.components.metadata.service 中的方法
Channels | DefaultChannelMakerCenter.getAvailableChannels(User _loginUser, int _nViewId) 获取当前用户在指定视图下可用的栏目,根据视图，获取视图绑定的栏目，在过滤到没有权限的栏目
Channels | WCMFilterMakerForContainsChildren.getCurrChannels()

com.trs.components.stat 中 Channels 的使用

参数类型为 Channels 的 com.trs.components.stat 中的构造方法
HitsStatHandler4ChnlDept(Channels currhannels)

com.trs.components.wcm.content 中 Channels 的使用

参数类型为 Channels 的 com.trs.components.wcm.content 中的方法
 void ViewDocuments.open(Channels _channels, WCMFilter _filter)

com.trs.components.wcm.content.domain 中 Channels 的使用

返回 Channels 的 com.trs.components.wcm.content.domain 中的方法
Channels | DocumentMgr.getChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere) 获取所有与文档相关的频道
Channels | ChannelMgr.getChannels(int _nSiteId, int _nChannelType, boolean _bIncludingDeletedChannel) 取当前站点下某类型的栏目集合
Channels | ChannelMgr.getChannels(int _nSiteId, WCMFilter _filter) 取符合一定条件的栏目集合
Channels | DocumentMgr.getQutoedChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere) 获得实体文档对应的特定类型的频道集合 包括所有转发的频道、镜像的频道、实体频道和所有频道
Channels | DocumentMgr.getQutoedChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere, boolean _bIsIncludeTrashed)
Channels | ChannelMgr.getRecycleChannels(BaseChannel _oChannel, WCMFilter _chnlFilter) 获取符合一定条件的被删除的栏目
Channels | AutoTransmitMgr.getSynSrcChannels(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | AutoTransmitMgr.getSynToChannels(Channel _currChannel) 获取当前频分发文档的目标频道集合

参数类型为 Channels 的 com.trs.components.wcm.content.domain 中的方法
java.lang.String | ChannelExporter.export(Channels _channels, boolean _bWithChildren, boolean _bWithRelate)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)

com.trs.components.wcm.content.persistent 中 Channels 的使用

返回 Channels 的 com.trs.components.wcm.content.persistent 中的方法
static Channels | Channels.createNewInstance(User _currUser) 产生一个当前集合对象[Channels]的实例
static Channels | Channels.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Channels | Channels.getChildrenOf(int _parentId) 取当前集合ParentId为指定值的子集
Channels | Channels.getSubChannelsByParentId(int _parentId) 取当前集合ParentId为指定值的子集
static Channels | Channels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Channels]

com.trs.components.wcm.customize 中 Channels 的使用

返回 Channels 的 com.trs.components.wcm.customize 中的方法
 Channels CustomizeMgr.getChannels()
获取当前登录用户定制的频道集合

com.trs.components.wcm.recent 中 Channels 的使用

返回 Channels 的 com.trs.components.wcm.recent 中的方法
 Channels RecentMgr.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted)
获得用户最近访问的频道列表，按访问时间逆序排列

com.trs.components.wcm.wcmx.util 中 Channels 的使用

参数类型为 Channels 的 com.trs.components.wcm.wcmx.util 中的方法
void | CWasTree.CreatChnlTree(Channels aChnls)
void | CWasTree.CreatNavTree(Channels aChnls, int aNo)

com.trs.presentation.nav 中 Channels 的使用

参数类型为 Channels 的 com.trs.presentation.nav 中的构造方法
TreeNodeCalctor(WebSite _site, Channels _srcChannels)

com.trs.service 中 Channels 的使用

返回 Channels 的 com.trs.service 中的方法
Channels | ICustomizeService.getChannels() 获取当前用户定制的频道集合
Channels | IDocumentService.getChannels(Document _currDocument) 获得实体文档相关的引用、镜像等对应的所有频道
Channels | ICustomizeService.getChannels(int _nRightIndex) 获取当前用户定制的并且有指定操作权限的频道集合
Channels | IRecentService.getChannels(WCMFilter _aFilter) 返回用户最近访问的频道列表 按照访问的时间顺序排序
Channels | IRecentService.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道列表 按照访问的时间顺序排序
Channels | IRecentService.getChannels(WCMFilter _filter, boolean _bIncludeDeleted, int _nRightIndex) 获取用户最近访问的频道集合,并校验访问指定权限.
Channels | IRecentService.getChannelsWithRight(WCMFilter _filter) 获取用户最近访问的频道集合,并校验访问权限.
Channels | IDocumentService.getMirrorChannels(Document _currDocument) 获得源文档所有存在同源异现镜像的频道
Channels | IDocumentService.getQuoteChannels(Document _currDocument) 获取引用了当前指定文档的所有频道
Channels | IDocumentService.getQuoteChannels(int _nDocumentId) 获取引用了当前指定文档的所有频道
Channels | IChannelService.getRecycleChannels(BaseChannel _oChannel) 获取当前站点/频道下的废弃频道集合
Channels | IChannelService.getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的废弃频道集合
Channels | IChannelService.getSynSrcChannel(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | IChannelService.getSynToChannel(Channel _currChannel) 获取当前频道分发文档的目标频道集合

参数类型为 Channels 的 com.trs.service 中的方法
boolean | IChannelService.delete(Channels _currChannels, boolean _bDrop) 删除频道集合
java.lang.String | IChannelService.export(Channels _fromChannels, boolean _bWithChildren, boolean _bWithRelated)
void | IChannelService.restore(Channels _currChannels) 恢复频道集合

com.trs.service.impl 中 Channels 的使用

返回 Channels 的 com.trs.service.impl 中的方法
Channels | CustomizeService.getChannels()
Channels | DocumentService.getChannels(Document _currDocument)
Channels | CustomizeService.getChannels(int _nRightIndex)
Channels | RecentService.getChannels(WCMFilter _aFilter)
Channels | RecentService.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted)
Channels | RecentService.getChannels(WCMFilter _filter, boolean _bIncludeDeleted, int _nRightIndex)
Channels | RecentService.getChannelsWithRight(WCMFilter _filter)
Channels | DocumentService.getMirrorChannels(Document _currDocument)
Channels | DocumentService.getQuoteChannels(Document _currDocument)
Channels | DocumentService.getQuoteChannels(int _nDocumentId)
Channels | ChannelService.getRecycleChannels(BaseChannel _oChannel) 获取当前站点/频道下的废弃频道集合
Channels | ChannelService.getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的废弃频道集合
Channels | ChannelService.getSynSrcChannel(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | ChannelService.getSynToChannel(Channel _currChannel) 获取当前频道分发文档的目标频道集合

参数类型为 Channels 的 com.trs.service.impl 中的方法
boolean | ChannelService.delete(Channels _currChannels, boolean _bDrop) 删除频道集合
java.lang.String | ChannelService.export(Channels _fromChannels, boolean _bWithChildren, boolean _bWithRelated)
void | ChannelService.restore(Channels _currChannels)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase
的使用

使用 ChannelSubstanceImplBase 的软件包
com.trs.components.wcm.content.domain.auth

com.trs.components.wcm.content.domain.auth 中 ChannelSubstanceImplBase 的使用

com.trs.components.wcm.content.domain.auth 中 ChannelSubstanceImplBase 的子类
 class ChannelRightHostImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChannelSyn 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChannelSyn
的使用

使用 ChannelSyn 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 ChannelSyn 的使用

返回 ChannelSyn 的 com.trs.components.wcm.content.domain 中的方法
 ChannelSyn AutoTransmitMgr.save(ChannelSyn _currChnlSyn)

参数类型为 ChannelSyn 的 com.trs.components.wcm.content.domain 中的方法
void | AutoTransmitMgr.delete(ChannelSyn _currChnlSyn)
ChannelSyn | AutoTransmitMgr.save(ChannelSyn _currChnlSyn)

com.trs.components.wcm.content.persistent 中 ChannelSyn 的使用

返回 ChannelSyn 的 com.trs.components.wcm.content.persistent 中的方法
static ChannelSyn | ChannelSyn.createNewInstance() 产生当前对象[ChannelSyn]的实例
static ChannelSyn | ChannelSyn.findById(int _nId) 提取指定ID的对象
static ChannelSyn | ChannelSyn.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 ChannelSyn 的使用

返回 ChannelSyn 的 com.trs.service 中的方法
 ChannelSyn IChannelService.saveChannelSyn(ChannelSyn _currChnlSyn)

参数类型为 ChannelSyn 的 com.trs.service 中的方法
ChannelSyn | IChannelService.saveChannelSyn(ChannelSyn _currChnlSyn)
ChannelSyns | IChannelService.saveChannelSyns(ChannelSyn _currChnlSyn, java.lang.String _sToChannelIds)

com.trs.service.impl 中 ChannelSyn 的使用

返回 ChannelSyn 的 com.trs.service.impl 中的方法
 ChannelSyn ChannelService.saveChannelSyn(ChannelSyn _currChnlSyn)

参数类型为 ChannelSyn 的 com.trs.service.impl 中的方法
ChannelSyn | ChannelService.saveChannelSyn(ChannelSyn _currChnlSyn)
ChannelSyns | ChannelService.saveChannelSyns(ChannelSyn _currChnlSyn, java.lang.String _sToChannelIds)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChannelSyns 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChannelSyns
的使用

使用 ChannelSyns 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 ChannelSyns 的使用

返回 ChannelSyns 的 com.trs.components.wcm.content.domain 中的方法
ChannelSyns | AutoTransmitMgr.getChannelSyns(Channel _currChannel, WCMFilter _filter)
ChannelSyns | AutoTransmitMgr.getChannelSyns(Channel _currChannel, WCMFilter _filter, boolean _bChannelAsTarget)
ChannelSyns | AutoTransmitMgr.getRelatedChannelSyns(Channel _currChannel, WCMFilter _filter)

com.trs.components.wcm.content.persistent 中 ChannelSyns 的使用

返回 ChannelSyns 的 com.trs.components.wcm.content.persistent 中的方法
static ChannelSyns | ChannelSyns.createNewInstance(User _currUser) 产生当前集合对象[ChannelSyns]的实例
static ChannelSyns | ChannelSyns.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ChannelSyns | ChannelSyns.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 17:12:53 Last Modified: 2004-12-12/2004-12-12 Description:获取频道分发设置集合

com.trs.service 中 ChannelSyns 的使用

返回 ChannelSyns 的 com.trs.service 中的方法
ChannelSyns | IChannelService.getChannelSyns(int _nChannelId, WCMFilter _filter)
ChannelSyns | IChannelService.saveChannelSyns(ChannelSyn _currChnlSyn, java.lang.String _sToChannelIds)

com.trs.service.impl 中 ChannelSyns 的使用

返回 ChannelSyns 的 com.trs.service.impl 中的方法
ChannelSyns | ChannelService.getChannelSyns(int _nChannelId, WCMFilter _filter)
ChannelSyns | ChannelService.saveChannelSyns(ChannelSyn _currChnlSyn, java.lang.String _sToChannelIds)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChannelXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChannelXmlConverter
的使用

没有 com.trs.components.wcm.content.persistent.ChannelXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr
的使用

没有 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChnlDoc 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChnlDoc
的使用

使用 ChnlDoc 的软件包
com.trs.components.infoview.db |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.service |
com.trs.service.impl |

com.trs.components.infoview.db 中 ChnlDoc 的使用

参数类型为 ChnlDoc 的 com.trs.components.infoview.db 中的方法
 void InfoViewDBStoreServer.changeChnnlOfInfoviewDatasaveInfoViewData(int _nInfoViewId, Document _oDocument, ChnlDoc _oChnDoc)

com.trs.components.infoview.persistent 中 ChnlDoc 的使用

返回 ChnlDoc 的 com.trs.components.infoview.persistent 中的方法
 ChnlDoc InfoViewDocument.getChnlDoc()

com.trs.components.metadata.center 中 ChnlDoc 的使用

返回 ChnlDoc 的 com.trs.components.metadata.center 中的方法
 ChnlDoc MetaViewData.getChnlDoc()

com.trs.components.wcm.content.domain 中 ChnlDoc 的使用

返回 ChnlDoc 的 com.trs.components.wcm.content.domain 中的方法
ChnlDoc | DocumentMgr.findChnlDoc(Document _currDocument, Channel _currChannel) 根据文档和频道，找到对应的ChnlDoc
ChnlDoc | DocumentMgr.getFirstChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内的第一个频道文档。
ChnlDoc | DocumentMgr.getLastChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内的最后一个频道文档。
ChnlDoc | DocumentMgr.getNextChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内，当前频道文档的后一个频道文档。
ChnlDoc | DocumentMgr.getPreviousChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内，当前频道文档的前一个频道文档。

参数类型为 ChnlDoc 的 com.trs.components.wcm.content.domain 中的方法
void | DocumentMgr.changeStatus(int _newStatusId, ChnlDoc _currChnlDoc) 改变文档在指定频道下的状态
Schedule | DocumentPriMgr.findSchedule(ChnlDoc _currChnlDoc) 查找文档置顶计划中，当前ChnlDoc对应的计划发布任务
ChnlDoc | DocumentMgr.getFirstChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内的第一个频道文档。
ChnlDoc | DocumentMgr.getLastChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内的最后一个频道文档。
ChnlDoc | DocumentMgr.getNextChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内，当前频道文档的后一个频道文档。
ChnlDoc | DocumentMgr.getPreviousChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop) 得到频道内，当前频道文档的前一个频道文档。
void | DocumentMgr.restore(ChnlDoc _oChnlDocDeleted) 恢复指定的ChnlDoc

com.trs.components.wcm.content.domain.auth 中 ChnlDoc 的使用

参数类型为 ChnlDoc 的 com.trs.components.wcm.content.domain.auth 中的方法
static boolean DocumentAuthServer.hasRight(User _loginUser, ChnlDoc _chnlDoc, int _nRightIndex)

com.trs.components.wcm.content.persistent 中 ChnlDoc 的使用

返回 ChnlDoc 的 com.trs.components.wcm.content.persistent 中的方法
static ChnlDoc | ChnlDoc.createNewInstance() 产生当前对象[ChnlDoc]的实例
static ChnlDoc | ChnlDoc.findByDocAndChnl(Document _currDocument, Channel _currChannel) 根据文档和频道，找到对应的ChnlDoc
static ChnlDoc | ChnlDoc.findByDocAndChnl(int _nDocumentId, int _nChannelId)
static ChnlDoc | ChnlDoc.findByDocument(Document _currDocument) 根据文档，找到对应的ChnlDoc，只找实体文档本身对应的频道
static ChnlDoc | ChnlDoc.findById(int _nId) 提取指定ID的对象
static ChnlDoc | ChnlDoc.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 ChnlDoc 的使用

返回 ChnlDoc 的 com.trs.service 中的方法
 ChnlDoc IDocumentService.findChnldoc(int _currDocumentId, int _currChannelId)
根据频道和文档，找到对应的ChnlDoc

com.trs.service.impl 中 ChnlDoc 的使用

返回 ChnlDoc 的 com.trs.service.impl 中的方法
 ChnlDoc DocumentService.findChnldoc(int _currDocumentId, int _currChannelId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ChnlDocs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ChnlDocs
的使用

使用 ChnlDocs 的软件包
com.trs.ajaxservice
com.trs.components.wcm.content.persistent
com.trs.components.wcm.recent
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 ChnlDocs 的使用

返回 ChnlDocs 的 com.trs.ajaxservice 中的方法
 ChnlDocs ChnlDocServiceProvider.search(MethodContext _methContext)
查询指定站点或者指定频道下的文档

com.trs.components.wcm.content.persistent 中 ChnlDocs 的使用

返回 ChnlDocs 的 com.trs.components.wcm.content.persistent 中的方法
static ChnlDocs | ChnlDocs.createNewInstance(User _currUser) 产生一个当前集合对象[ChnlDocs]的实例
static ChnlDocs | ChnlDocs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ChnlDocs | ChnlDocs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChnlDocs]

com.trs.components.wcm.recent 中 ChnlDocs 的使用

返回 ChnlDocs 的 com.trs.components.wcm.recent 中的方法
 ChnlDocs RecentMgr.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted)
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

com.trs.service 中 ChnlDocs 的使用

返回 ChnlDocs 的 com.trs.service 中的方法
ChnlDocs | IRecentService.getChnlDocs(WCMFilter _aFilter) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
ChnlDocs | IRecentService.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序

参数类型为 ChnlDocs 的 com.trs.service 中的方法
boolean | IDocumentService.delete(ChnlDocs _delChnlDocs, boolean _bDrop) 批量删除当前频道下的文档
void | IPublishService.publish(ChnlDocs _chnlDocs, int _nPubType) 发布指定的ChnlDoc集合，用于“最近访问文档”的直接发布

com.trs.service.impl 中 ChnlDocs 的使用

返回 ChnlDocs 的 com.trs.service.impl 中的方法
ChnlDocs | RecentService.getChnlDocs(WCMFilter _aFilter)
ChnlDocs | RecentService.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted)

参数类型为 ChnlDocs 的 com.trs.service.impl 中的方法
boolean | DocumentService.delete(ChnlDocs _delChnlDocs, boolean _bDrop)
void | PublishService.publish(ChnlDocs _chnlDocs, int _nPubType)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ContentExtField 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ContentExtField
的使用

使用 ContentExtField 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 ContentExtField 的使用

返回 ContentExtField 的 com.trs.components.wcm.content.domain 中的方法
 ContentExtField ContentExtFieldMgr.save(CMSObj _host, ContentExtField _extfield, boolean _bDoWithChildren)

参数类型为 ContentExtField 的 com.trs.components.wcm.content.domain 中的方法
void | ContentExtFieldMgr.addExtField(CMSObj _host, ContentExtField _extfield, int i)
void | ContentExtFieldMgr.addExtFieldToChildren(CMSObj _host, ContentExtField _extfield)
void | ContentExtFieldMgr.addExtFieldToSpeicficChildren(java.lang.String _sSiteids, java.lang.String _sChannelids, ContentExtField _extfield)
void | ContentExtFieldMgr.delete(CMSObj _siteOrChannel, ContentExtField _extfield, boolean _bDoWithChildren)
ContentExtField | ContentExtFieldMgr.save(CMSObj _host, ContentExtField _extfield, boolean _bDoWithChildren)

com.trs.components.wcm.content.persistent 中 ContentExtField 的使用

返回 ContentExtField 的 com.trs.components.wcm.content.persistent 中的方法
static ContentExtField | ContentExtField.createNewInstance() 产生当前对象[ContentExtField]的实例
static ContentExtField | ContentExtField.findById(int _nId) 提取指定ID的对象
static ContentExtField | ContentExtField.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 ContentExtField 的使用

返回 ContentExtField 的 com.trs.service 中的方法
 ContentExtField IChannelService.saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited)
保存指定的扩展字段

参数类型为 ContentExtField 的 com.trs.service 中的方法
void | IChannelService.deleteExtFiled(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
ContentExtField | IChannelService.saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited) 保存指定的扩展字段

com.trs.service.impl 中 ContentExtField 的使用

返回 ContentExtField 的 com.trs.service.impl 中的方法
 ContentExtField ChannelService.saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited)
保存指定的扩展字段

参数类型为 ContentExtField 的 com.trs.service.impl 中的方法
void | ChannelService.deleteExtFiled(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
ContentExtField | ChannelService.saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited) 保存指定的扩展字段

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ContentExtFields 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ContentExtFields
的使用

使用 ContentExtFields 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 ContentExtFields 的使用

返回 ContentExtFields 的 com.trs.components.wcm.content.domain 中的方法
ContentExtFields | ContentExtFieldMgr.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)
ContentExtFields | ContentExtFieldMgr.getExtFields(CMSObj _host, WCMFilter _filter, boolean _bContainsChildren)

com.trs.components.wcm.content.persistent 中 ContentExtFields 的使用

返回 ContentExtFields 的 com.trs.components.wcm.content.persistent 中的方法
static ContentExtFields | ContentExtFields.createNewInstance(User _currUser) 产生当前集合对象[ContentExtFields]的实例
static ContentExtFields | ContentExtFields.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentExtFields | ContentExtFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentExtFields]

com.trs.service 中 ContentExtFields 的使用

返回 ContentExtFields 的 com.trs.service 中的方法
 ContentExtFields IChannelService.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)
获取指定站点/频道下的扩展字段.

com.trs.service.impl 中 ContentExtFields 的使用

返回 ContentExtFields 的 com.trs.service.impl 中的方法
 ContentExtFields ChannelService.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)
获取指定站点/频道下的扩展字段.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ContentExtFieldXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ContentExtFieldXmlConverter
的使用

没有 com.trs.components.wcm.content.persistent.ContentExtFieldXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ContentLink 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ContentLink
的使用

使用 ContentLink 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 ContentLink 的使用

返回 ContentLink 的 com.trs.components.wcm.content.domain 中的方法
 ContentLink ContentLinkMgr.save(ContentLink _contentLink)
保存一个内容超链接

参数类型为 ContentLink 的 com.trs.components.wcm.content.domain 中的方法
void | ContentLinkMgr.delete(ContentLink _contentLink) 删除内容超链接
ContentLink | ContentLinkMgr.save(ContentLink _contentLink) 保存一个内容超链接

com.trs.components.wcm.content.persistent 中 ContentLink 的使用

返回 ContentLink 的 com.trs.components.wcm.content.persistent 中的方法
static ContentLink | ContentLink.createNewInstance() 产生当前对象[ContentLink]的实例
static ContentLink | ContentLink.findById(int _nId) 提取指定ID的对象
static ContentLink | ContentLink.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 ContentLink 的使用

返回 ContentLink 的 com.trs.service 中的方法
 ContentLink IChannelService.saveContentLink(ContentLink _contentLink)

参数类型为 ContentLink 的 com.trs.service 中的方法
void | IChannelService.deleteContentLink(ContentLink _contentLink)
ContentLink | IChannelService.saveContentLink(ContentLink _contentLink)

com.trs.service.impl 中 ContentLink 的使用

返回 ContentLink 的 com.trs.service.impl 中的方法
 ContentLink ChannelService.saveContentLink(ContentLink _contentLink)

参数类型为 ContentLink 的 com.trs.service.impl 中的方法
void | ChannelService.deleteContentLink(ContentLink _contentLink)
ContentLink | ChannelService.saveContentLink(ContentLink _contentLink)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ContentLinks 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ContentLinks
的使用

使用 ContentLinks 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 ContentLinks 的使用

返回 ContentLinks 的 com.trs.components.wcm.content.domain 中的方法
ContentLinks | ContentLinkMgr.getContentLinks(int _nSiteId, WCMFilter _filter) 获取指定站点下的内容超链接
ContentLinks | ContentLinkMgr.getContentLinks(WebSite _currSite, WCMFilter _filter) 获取当前站点的所有内容超链接

参数类型为 ContentLinks 的 com.trs.components.wcm.content.domain 中的方法
 void ContentLinkMgr.delete(ContentLinks _contentLinks)
删除内容超链接集合

com.trs.components.wcm.content.persistent 中 ContentLinks 的使用

返回 ContentLinks 的 com.trs.components.wcm.content.persistent 中的方法
static ContentLinks | ContentLinks.createNewInstance(User _currUser) 产生当前集合对象[ContentLinks]的实例
static ContentLinks | ContentLinks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentLinks | ContentLinks.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 17:19:37 Last Modified: 2004-12-12/2004-12-12 Description: 获取内容超链接对象集合

com.trs.service 中 ContentLinks 的使用

返回 ContentLinks 的 com.trs.service 中的方法
 ContentLinks IChannelService.getContentLinks(WebSite _site, WCMFilter _filter)

参数类型为 ContentLinks 的 com.trs.service 中的方法
 void IChannelService.deleteContentLinks(ContentLinks _contentLinks)

com.trs.service.impl 中 ContentLinks 的使用

返回 ContentLinks 的 com.trs.service.impl 中的方法
 ContentLinks ChannelService.getContentLinks(WebSite _site, WCMFilter _filter)

参数类型为 ContentLinks 的 com.trs.service.impl 中的方法
 void ChannelService.deleteContentLinks(ContentLinks _contentLinks)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ContentLinkType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ContentLinkType
的使用

使用 ContentLinkType 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 ContentLinkType 的使用

返回 ContentLinkType 的 com.trs.components.wcm.content.persistent 中的方法
static ContentLinkType | ContentLinkType.createNewInstance() 产生当前对象[ContentLinkType]的实例
static ContentLinkType | ContentLinkType.findById(int _nId) 提取指定ID的对象
static ContentLinkType | ContentLinkType.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ContentLinkTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ContentLinkTypes
的使用

使用 ContentLinkTypes 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 ContentLinkTypes 的使用

返回 ContentLinkTypes 的 com.trs.components.wcm.content.persistent 中的方法
static ContentLinkTypes | ContentLinkTypes.createNewInstance(User _currUser) 产生当前集合对象[ContentLinkTypes]的实例
static ContentLinkTypes | ContentLinkTypes.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static ContentLinkTypes | ContentLinkTypes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentLinkTypes]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocBak 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocBak
的使用

使用 DocBak 的软件包
com.trs.components.wcm.content.domain
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 DocBak 的使用

返回 DocBak 的 com.trs.components.wcm.content.domain 中的方法
DocBak | DocBakMgr.bakupDocument(Document _currDocument) 备份当前文档
DocBak | DocBakMgr.getDocBak(Document _currDocument, int _nVersion) 取文档某个版本的备份

参数类型为 DocBak 的 com.trs.components.wcm.content.domain 中的方法
void | DocBakMgr.deleteDocBak(DocBak _currDocBak) 删除一个文档备份(版本)
Document | DocBakMgr.recoverDocument(DocBak _aDocBak, Document _currDocument) 恢复当前文档的数据到某个(备份)版本

com.trs.service 中 DocBak 的使用

返回 DocBak 的 com.trs.service 中的方法
DocBak | IDocumentService.backup(Document _currDocument) 备份当前文档,产生当前文档的一个版本 备份只针对实体文档，不针对引用转发或者镜像文档，所以只提供一个Document参数
DocBak | IDocumentService.getDocBak(Document _currDocument, int _nVersion) 获取当前文档指定版本的备份

参数类型为 DocBak 的 com.trs.service 中的方法
void | IDocumentService.deleteDocBak(DocBak _docbak) 删除指定的文档版本
Document | IDocumentService.recoverDocument(DocBak _aDocBak, Document _currDocument) 从文档备份版本中恢复文档

com.trs.service.impl 中 DocBak 的使用

返回 DocBak 的 com.trs.service.impl 中的方法
DocBak | DocumentService.backup(Document _currDocument)
DocBak | DocumentService.getDocBak(Document _currDocument, int _nVersion)

参数类型为 DocBak 的 com.trs.service.impl 中的方法
void | DocumentService.deleteDocBak(DocBak _docbak)
Document | DocumentService.recoverDocument(DocBak _aDocBak, Document _currDocument)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocBaks 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocBaks
的使用

使用 DocBaks 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 DocBaks 的使用

返回 DocBaks 的 com.trs.components.wcm.content.domain 中的方法
DocBaks | DocBakMgr.findDocBaks(Document _currDocument) 取文档的备份集合
DocBaks | DocBakMgr.findDocBaks(Document _currDocument, WCMFilter _filter) 取当前文档的备份集合

com.trs.components.wcm.content.persistent 中 DocBaks 的使用

返回 DocBaks 的 com.trs.components.wcm.content.persistent 中的方法
static DocBaks | DocBaks.createNewInstance(User _currUser) 产生一个当前集合对象[DocBaks]的实例
static DocBaks | DocBaks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DocBaks | DocBaks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocBaks]

com.trs.service 中 DocBaks 的使用

返回 DocBaks 的 com.trs.service 中的方法
DocBaks | IDocumentService.getDocBaks(Document _currDocument) 获取当前文档的备份
DocBaks | IDocumentService.getDocBaks(Document _currDocument, WCMFilter _filter) 获取当前文档的备份

参数类型为 DocBaks 的 com.trs.service 中的方法
 void IDocumentService.deleteDocBaks(DocBaks _docbaks)
删除指定的文档版本集合

com.trs.service.impl 中 DocBaks 的使用

返回 DocBaks 的 com.trs.service.impl 中的方法
DocBaks | DocumentService.getDocBaks(Document _currDocument)
DocBaks | DocumentService.getDocBaks(Document _currDocument, WCMFilter _filter)

参数类型为 DocBaks 的 com.trs.service.impl 中的方法
 void DocumentService.deleteDocBaks(DocBaks _docbaks)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocReply 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocReply
的使用

使用 DocReply 的软件包
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.persistent |
com.trs.service |
com.trs.service.impl |

com.trs.components.infoview 中 DocReply 的使用

参数类型为 DocReply 的 com.trs.components.infoview 中的构造方法
InfoViewReplyNoticeSender(InfoView _oInfoView, Document _oDocument, DocReply _oInfoViewReply)

com.trs.components.wcm.content.domain 中 DocReply 的使用

参数类型为 DocReply 的 com.trs.components.wcm.content.domain 中的方法
 void DocReplyMgr.saveDocReply(Document _currDocument, DocReply _docReply)
保存文档的一个回复

com.trs.components.wcm.content.persistent 中 DocReply 的使用

返回 DocReply 的 com.trs.components.wcm.content.persistent 中的方法
static DocReply | DocReply.createNewInstance() 产生当前对象[DocReply]的实例
static DocReply | DocReply.findById(int _nId) 提取指定ID的对象
static DocReply | DocReply.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 DocReply 的使用

参数类型为 DocReply 的 com.trs.service 中的方法
 void IInfoViewService.sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage)
发送表单文档的回复通知
优先使用表单上的设置

com.trs.service.impl 中 DocReply 的使用

参数类型为 DocReply 的 com.trs.service.impl 中的方法
 void InfoViewService.sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocReplys 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocReplys
的使用

使用 DocReplys 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.domain 中 DocReplys 的使用

返回 DocReplys 的 com.trs.components.wcm.content.domain 中的方法
DocReplys | DocReplyMgr.getReplys(Document _currDocument) 获取文档的所有回复
DocReplys | DocReplyMgr.getReplys(Document _currDocument, int _nReplyType) 获取当前文档某种类型的回复

com.trs.components.wcm.content.persistent 中 DocReplys 的使用

返回 DocReplys 的 com.trs.components.wcm.content.persistent 中的方法
static DocReplys | DocReplys.createNewInstance(User _currUser) 产生一个当前集合对象[DocReplys]的实例
static DocReplys | DocReplys.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DocReplys | DocReplys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocReplys]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Document 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Document
的使用

使用 Document 的软件包
com.trs.ajaxservice |
com.trs.components.ckm |
com.trs.components.comment.publish.helper |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.helper |
com.trs.components.infoview.mad |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.process.element |
com.trs.components.wcm.publish.domain |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.wcmx.jsp |
com.trs.components.web.document |
com.trs.presentation.wcm.content |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |

com.trs.ajaxservice 中 Document 的使用

参数类型为 Document 的 com.trs.ajaxservice 中的方法
static java.lang.String | WCMDocumentHelper.makeRightValue(MethodContext _methodContext, User _loginUser, Channel _currChannel, Document _document) 构造指定文档在指定栏目中的权限
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, boolean _bUseDefaultFlowMode)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, Flow _oFlow, MethodContext _oMethodContext)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, java.util.Map _hFlowContextInfo)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, MethodContext _oMethodContext)

com.trs.components.ckm 中 Document 的使用

参数类型为 Document 的 com.trs.components.ckm 中的方法
void | TRSCKMServer.deleteSimIndex(Document _oDocument)
void | ICKMServer.deleteSimIndex(Document _oDocument)
void | TRSCKMServer.updateSimIndex(Document _oDocument)
void | ICKMServer.updateSimIndex(Document _oDocument)

com.trs.components.comment.publish.helper 中 Document 的使用

参数类型为 Document 的 com.trs.components.comment.publish.helper 中的方法
static CommentParserEntity CommentParserUtil.getCommentParserEntity(Document doc, TagItem tagItem)

com.trs.components.infoview 中 Document 的使用

返回 Document 的 com.trs.components.infoview 中的方法
 Document InfoviewDataProcessor.processInfoViewAppendix(Document _document)

参数类型为 Document 的 com.trs.components.infoview 中的方法
static java.lang.String | InfoViewDataHelper.buildContent(InfoView _oInfoView, Document wcmDocument, org.dom4j.Document _oDom4jDocument)
static java.lang.String | InfoViewDataHelper.getFieldValue(Document wcmDocument, java.lang.String field)
static java.lang.String | InfoViewDataHelper.getProperty(Document wcmDocument, java.lang.String field) 返回指定表单文档的指定数据项的值 数据项的名称，可以只包括名称部分，也可以是完整的XPATH表述
Document | InfoviewDataProcessor.processInfoViewAppendix(Document _document)

参数类型为 Document 的 com.trs.components.infoview 中的构造方法
InfoViewReplyNoticeSender(InfoView _oInfoView, Document _oDocument, DocReply _oInfoViewReply)

com.trs.components.infoview.db 中 Document 的使用

参数类型为 Document 的 com.trs.components.infoview.db 中的方法
void | InfoViewDBStoreServer.changeChnnlOfInfoviewDatasaveInfoViewData(int _nInfoViewId, Document _oDocument, ChnlDoc _oChnDoc)
void | InfoViewDBStoreServer.deleteInfoViewData(int _nInfoViewId, Document _oDocument)
void | InfoViewDBStoreServer.saveInfoViewData(int _nInfoViewId, Document _oDocument)

com.trs.components.infoview.helper 中 Document 的使用

返回 Document 的 com.trs.components.infoview.helper 中的方法
 Document BaseInfoViewFieldValueCreator.getDocument()

参数类型为 Document 的 com.trs.components.infoview.helper 中的方法
 void BaseInfoViewFieldValueCreator.setDocument(Document _document)

com.trs.components.infoview.mad 中 Document 的使用

参数类型为 Document 的 com.trs.components.infoview.mad 中的方法
java.lang.String | InfoViewDataHelper.buildContent(InfoView infoView, Document _document, org.dom4j.Document dom4jDocument)
java.lang.String | InfoViewDataHelperImpl.buildContent(InfoView infoView, Document _document, org.dom4j.Document dom4jDocument)
java.lang.String | InfoViewDataHelper.getFieldValue(Document doc, java.lang.String fieldName)
java.lang.String | InfoViewDataHelperImpl.getFieldValue(Document doc, java.lang.String fieldName)
java.lang.String | InfoViewDataHelper.getProperty(Document doc, java.lang.String groupName)
java.lang.String | InfoViewDataHelperImpl.getProperty(Document doc, java.lang.String groupName)

com.trs.components.infoview.persistent 中 Document 的使用

返回 Document 的 com.trs.components.infoview.persistent 中的方法
Document | InfoViewData.getDocument()
Document | InfoViewDocument.getDocument()

参数类型为 Document 的 com.trs.components.infoview.persistent 中的方法
void | InfoViewDocument.cloneDocumentProperties(Document _oDoc)
static InfoViewData | InfoViewData.findByDocument(Document document)
static InfoViewDocument | InfoViewDocument.findByDocument(Document _oDocument, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument, java.lang.String _sSelectFieldsOfInfoView)
static InfoViewDocument | InfoViewDocument.findSelfByDocument(Document _oDocument)

com.trs.components.metadata.center 中 Document 的使用

返回 Document 的 com.trs.components.metadata.center 中的方法
Document | MetaViewData.getDocument()
Document | MetaViewData.getDocumnent()

参数类型为 Document 的 com.trs.components.metadata.center 中的方法
ClassInfos | IClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
ClassInfos | ClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
void | IDocumentFieldsSyn.setDocumentProperties(Document _document, MetaViewData _viewData) 根据视图数据对象设置关联的document对象的值
void | MetaViewData.synDocumentFieldValueWithRule(Document _document) 按照栏目上设置的同步规则进行字段同步。

com.trs.components.wcm.content.domain 中 Document 的使用

返回 Document 的 com.trs.components.wcm.content.domain 中的方法
Document | DocumentMgr.copyDocument(Document _fromDocument, Channel _fromChannel, Channel _toChannel) 复制文档到另一个频道上 不负责非依赖型关联对象的复制，如附件和相关文档 不能将一个文档从草稿箱或者复制到草稿箱 复制引用转发的文档相当于创建一个新的引用转发 复制实体文档，则需要在目标频道下创建一个新的实体文档
Document | DocBakMgr.recoverDocument(DocBak _aDocBak, Document _currDocument) 恢复当前文档的数据到某个(备份)版本
Document | DocumentMgr.save(Document _currDocument) 在频道下保存/修改一篇文档 文档的频道属性不能在此被修改，而应该通过移动操作进行修改 文档的假删除、恢复 都需要调用相关接口，而不该通过修改接口 修改文档状态时，需要同步修改ChnlDoc的状态

参数类型为 Document 的 com.trs.components.wcm.content.domain 中的方法
void | AppendixMgr.addAppendix(Document _currDocument, Appendix _currAppendix) 新增附件
void | DocKeywordMgrImpl.addNewDocKeywords(Document _document)
void | IDocKeywordMgr.addNewDocKeywords(Document _document) 增加指定文档的相关新闻记录
void | AutoDocBakMgr.autoBakDocument(Document _document)
void | AutoDocBakMgr.autoBakDocument(Document _document, int _nOperType)
DocBak | DocBakMgr.bakupDocument(Document _currDocument) 备份当前文档
void | DocumentMgr.changeStatus(Document _currDocument, Channel _currChannel, int _newStatusId)
void | DocumentMgr.changeStatus(Document _currDocument, Channel _currChannel, Status _newStatus) 修改ChnlDoc中对应的状态 如果是实体文档，则同步状态
void | AppendixMgr.copyAppendixes(Document _fromDocument, Document _newDocument) 复制某个特定文档的所有附件到一个新文档中
void | DocReplyMgr.copyDocReplys(Document _fromDocument, Document _newDocument) 复制文档回复
Document | DocumentMgr.copyDocument(Document _fromDocument, Channel _fromChannel, Channel _toChannel) 复制文档到另一个频道上 不负责非依赖型关联对象的复制，如附件和相关文档 不能将一个文档从草稿箱或者复制到草稿箱 复制引用转发的文档相当于创建一个新的引用转发 复制实体文档，则需要在目标频道下创建一个新的实体文档
void | RelationMgr.copyRelations(Document _fromDocument, Document _newDocument) 复制某个特定文档的所有相关文档到一个新文档中
void | DocumentMgr.delete(Document _currDocument, Channel _currChannel, boolean _bDrop) 从某个频道下删除一篇文档 频道为一个真实频道，暂时不支持从回收站、草稿箱或其它特殊频道中删除。
void | DocumentMgr.deleteDocQuotes(Document _currDocument, java.lang.String _sExcludeChannelIds) 根据频道排除Id，删除所有特定类型的文档转发关系
void | RelationMgr.deleteRelations(Document _document)
void | AppendixMgr.deleteUnuseAppendixes(Document _currDocument, java.lang.String _sUseingIds, int _nAppendixType) 删除指定文档指定类型没有使用的附件
void | RelationMgr.deleteUnuseRelations(java.lang.String _sUseingIds, Document _document)
void | AppendixMgr.editAppendix(Document _currDocument, Appendix _currAppendix) 修改附件
java.lang.String | DocumentExporter.export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出指定的文档
ChnlDoc | DocumentMgr.findChnlDoc(Document _currDocument, Channel _currChannel) 根据文档和频道，找到对应的ChnlDoc
DocBaks | DocBakMgr.findDocBaks(Document _currDocument) 取文档的备份集合
DocBaks | DocBakMgr.findDocBaks(Document _currDocument, WCMFilter _filter) 取当前文档的备份集合
Appendixes | AppendixMgr.getAppendixes(Document _currDocument, int _nAppendixType) 获取当前文档某种类型的附件
Appendixes | AppendixMgr.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档某种类型的附件
Appendixes | AppendixMgr.getAppendixes(Document _currDocument, WCMFilter _filter) 获取当前文档的附件(符合筛选条件)
Channels | DocumentMgr.getChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere) 获取所有与文档相关的频道
DocBak | DocBakMgr.getDocBak(Document _currDocument, int _nVersion) 取文档某个版本的备份
Status | DocumentMgr.getDocStatus(Document _currDocument, int _nChnlId) 获取当前文档在所有频道下的状态
CMyDateTime | DocumentMgr.getDocumentTopTime(Document _currDocument, Channel _currChannel) 获得文档置顶的截止时间 如果文档没有置顶，则直接返回null 如果置顶文档没有设置截止时间则返回null
Channels | DocumentMgr.getQutoedChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere) 获得实体文档对应的特定类型的频道集合 包括所有转发的频道、镜像的频道、实体频道和所有频道
Channels | DocumentMgr.getQutoedChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere, boolean _bIsIncludeTrashed)
Documents | DocumentMgr.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 相关文档的相关方法
Documents | DocumentMgr.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites) 获取与当前文档相关的文档集合(指定获取的方式:相关表/关键词/相关词等)
Documents | DocKeywordMgrImpl.getRelatedDocumentsByKeywords(Document _document, int _nMaxSize, java.lang.String _sSelectFields, int[] _pFilterStatusId, boolean _bMultiSite, java.util.ArrayList _arExistDocumentTitles) 根据标题排重 add by ly
Documents | IDocKeywordMgr.getRelatedDocumentsByKeywords(Document _document, int _nMaxSize, java.lang.String _sSelectFields, int[] _pFilterStatusId, boolean _bMultiSite, java.util.ArrayList _arExistDocumentTitles) 获取指定文档的相关文档
Relations | RelationMgr.getRelations(Document _currDocument)
Relations | RelationMgr.getRelations(Document _currDocument, WCMFilter _extraFilter)
DocReplys | DocReplyMgr.getReplys(Document _currDocument) 获取文档的所有回复
DocReplys | DocReplyMgr.getReplys(Document _currDocument, int _nReplyType) 获取当前文档某种类型的回复
int | DocumentMgr.getTopPosition(Channel _currChannel, Document _currDocument) 得到频道下文档的置顶位置
boolean | DocumentMgr.isDocumentTopped(Document _currDocument, Channel _currChannel) 判断一个频道下的文档是否是处于置顶状态
Report | DocumentMgr.mirrorTo(Document _fromDocument, Channel _toChannel) 将实体文档镜像转发到另一个频道 草稿箱中的文档无法转发 目标频道为空无法转发
void | DocumentMgr.moveDocumentInChannel(Document _fromDocument, Document _toDocument, Channel _currChannel) 在频道中移动文档的顺序 如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后 通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作 置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
void | DocumentMgr.moveDocumentInChannel(Document _fromDocument, Document _toDocument, Channel _currChannel, int _nPosition) 在频道中移动文档的顺序 如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后 通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作 置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
Report | DocumentMgr.moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel) 将文档从一个频道移动到另一个频道 支持引用和镜像的移动 如果是草稿箱中的，则不支持移动；也不支持移动到草稿箱 如果目标频道下已经存在，则无法移动
Report | DocumentMgr.moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel, java.lang.String _sIsPhoto)
Report | DocumentMgr.quoteTo(Document _fromDocument, Channel _toChannel) 将实体文档引用转发到另一个频道 草稿箱中的文档无法转发 目标频道为空无法转发
Report | DocumentMgr.quoteTo(Document _fromDocument, Channel _toChannel, java.lang.String _sIsPhoto)
Document | DocBakMgr.recoverDocument(DocBak _aDocBak, Document _currDocument) 恢复当前文档的数据到某个(备份)版本
void | DocKeywordMgrImpl.removeDocKeywords(Document _document)
void | IDocKeywordMgr.removeDocKeywords(Document _document) 删除指定文档的相关新闻记录
void | DocumentMgr.removeToppedDocument(Channel _currChannel, Document _currDocument) 取消特定频道下某文档的置顶标志 该文档将成为普通文档 注意，不是删除文档！
void | DocumentMgr.restore(Document _delDocument, Channel _currChannel) 还原频道回收站中的一篇频道文档
Document | DocumentMgr.save(Document _currDocument) 在频道下保存/修改一篇文档 文档的频道属性不能在此被修改，而应该通过移动操作进行修改 文档的假删除、恢复 都需要调用相关接口，而不该通过修改接口 修改文档状态时，需要同步修改ChnlDoc的状态
void | AppendixMgr.saveAppendixes(Document _currDocument, java.util.List _currAppendixList) 保存特定的附件列表，包括添加、删除或者更新其中的具体附件 从private方法变成public方法，要小心 注意：保存文档相关的附件时，需要删除已经不再属于该文档的附件 050321，OO调整时进行的
void | DocReplyMgr.saveDocReply(Document _currDocument, DocReply _docReply) 保存文档的一个回复
void | RelationMgr.saveRelations(Document _currDocument, java.util.List _currRelationList) 保存相关文档的信息，可能是添加或者修改时调用
void | DocumentMgr.setTopDocument(Channel _currChannel, Document _fromDocument, Document _toDocument, int _nPosition, CMyDateTime dtValid)
void | DocumentMgr.setTopDocument(Channel _currChannel, Document _currDocument, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶 如果特定的位置已经存在文档，则需要将该位置及其后的所有置顶向后移动一位 如果最后一个置顶项目也有占用，则自动将置顶位置扩展一位！
void | DocumentMgr.setTopedDocument(Document _document, Channel _channel, int _nTopOrder, CMyDateTime _dtTopedValid)
void | DocKeywordMgrImpl.updateDocKeywords(Document _document, java.lang.String _sOldKeywords, java.lang.String _sNewKeywords)
void | IDocKeywordMgr.updateDocKeywords(Document _document, java.lang.String _sOldKeywords, java.lang.String _sNewKeywords) 更新指定文档的相关文档记录信息

com.trs.components.wcm.content.domain.auth 中 Document 的使用

参数类型为 Document 的 com.trs.components.wcm.content.domain.auth 中的方法
static java.lang.String | DocumentAuthServer.formatLogicRightValue(User _loginUser, Document _currDocument, java.lang.String _sLogicValue)
static boolean | DocumentAuthServer.hasFlowDocRight(User _currUser, Document _document, int _nRightIndex)
static boolean | DocumentAuthServer.hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Document _document, int _nRightIndex) 判断指定用户在指定频道中对于指定的文档是否具有指定的权限
static boolean | DocumentAuthServer.isDefineRightOnDocument(Document _document) 判断当前文档是否自定义了权限
static java.lang.String | DocumentAuthServer.makeLogicRightValue(User _loginUser, Channel _currChannel, Document _currDocument) 构造用户对于指定栏目的指定文档的权限值

com.trs.components.wcm.content.persistent 中 Document 的使用

com.trs.components.wcm.content.persistent 中 Document 的子类
 class DocBak

返回 Document 的 com.trs.components.wcm.content.persistent 中的方法
static Document | DocBak.createNewInstance() 产生当前对象[DocBak]的实例
static Document | Document.createNewInstance() 产生当前对象[Document]的实例
static Document | DocBak.findById(int _nId) 提取指定ID的对象
static Document | Document.findById(int _nId) 提取指定ID的对象
static Document | Document.findById(int _nId, java.lang.String _sSelectFields)
static Document | Document.findById(int _nId, java.lang.String _sSelectFields, java.lang.String _sTableName)
static Document | DocBak.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static Document | Document.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Document | ChnlDoc.getDocument() 取文档所属频道对象
Document | DocBak.getDocument()

参数类型为 Document 的 com.trs.components.wcm.content.persistent 中的方法
static ChnlDoc | ChnlDoc.findByDocAndChnl(Document _currDocument, Channel _currChannel) 根据文档和频道，找到对应的ChnlDoc
static ChnlDoc | ChnlDoc.findByDocument(Document _currDocument) 根据文档，找到对应的ChnlDoc，只找实体文档本身对应的频道
boolean | DocBak.setDocId(Document _doc) 设置备份的文档
boolean | ChnlDoc.setDocument(Document _document, boolean _bOnlyCache)

com.trs.components.wcm.process.element 中 Document 的使用

返回 Document 的 com.trs.components.wcm.process.element 中的方法
 Document FlowContentDocumentImpl.getDocument()

参数类型为 Document 的 com.trs.components.wcm.process.element 中的构造方法
FlowContentDocumentImpl(Document _currDocument)
MyFlowContentDocumentImpl(Document _currDocument)

com.trs.components.wcm.publish.domain 中 Document 的使用

参数类型为 Document 的 com.trs.components.wcm.publish.domain 中的方法
Documents[] | PreNextDocumentsImpl.getPreNextDocuments(Channel _channel, Document document, int num)
Documents[] | IPreNextDocuments.getPreNextDocuments(Channel _channel, Document _currDocument, int _nNum) 获取前/后N篇文档集合

com.trs.components.wcm.publish.element 中 Document 的使用

参数类型为 Document 的 com.trs.components.wcm.publish.element 中的构造方法
PublishContentDocumentImpl(Document _doc)
constructor

com.trs.components.wcm.publish.tagparser 中 Document 的使用

返回 Document 的 com.trs.components.wcm.publish.tagparser 中的方法
static Document WCMTagParserHelper.findDocumentHost(PublishTagContext _context)

参数类型为 Document 的 com.trs.components.wcm.publish.tagparser 中的方法
static java.lang.String WCMAppendixGenerator.generateAppendixes(Document _doc, int _nApdType, PublishTagContext _context, int _nReturnMode)
Generate the appendixes of a document.

com.trs.components.wcm.wcmx.jsp 中 Document 的使用

参数类型为 Document 的 com.trs.components.wcm.wcmx.jsp 中的方法
static java.lang.String | DocOperDefine.getDelFunc(Document _currDoc, Channel _currChnl) 获取删除文件的Javascript
static java.lang.String | DocOperDefine.getEditFunc(Document _currDoc, Channel _currChnl) 获取编辑文档的Javascript
static java.lang.String | DocOperDefine.getReplyFunc(Document _currDoc) 获取回复文档的Javascript
static java.lang.String | DocOperDefine.getSaveBakFunc(Document _currDoc, Channel _currChnl) 获取保存版本的Javascript
static java.lang.String | DocOperDefine.getShowBakFunc(Document _currDoc, Channel _currChnl) 获取管理版本的Javascript
static java.lang.String | DocOperDefine.getSubmitAgainFunc(Document _currDoc) 获取再次呈送文档的Javascript
static java.lang.String | DocOperDefine.getSubmitFunc(Document _currDoc) 获取呈送文档的Javascript
static java.lang.String | DocOperDefine.getTransmitFunc(Document _currDoc, Channel _currChnl) 获取转发文档的Javascript

com.trs.components.web.document 中 Document 的使用

参数类型为 Document 的 com.trs.components.web.document 中的构造方法
DocumentPropertiesBuilder(Document obj)

com.trs.presentation.wcm.content 中 Document 的使用

参数类型为 Document 的 com.trs.presentation.wcm.content 中的方法
boolean | DocumentsPageHelper.canDoPreview(Document _document)
Channel | DocumentsPageHelper.getDocChannel(Document _document)
java.lang.String | DocumentsPageHelper.getLogicRightValue(Document _currDocument)
boolean | DocumentsPageHelper.hasRight(int _nRightIndex, Document _document)

com.trs.service 中 Document 的使用

返回 Document 的 com.trs.service 中的方法
Document | InfoViewContext.getDocument()
Document | IDocumentService.recoverDocument(DocBak _aDocBak, Document _currDocument) 从文档备份版本中恢复文档
Document | IDocumentService.save(Document _aDocument, java.util.List _aAppendixList, java.util.List _aRelationList) 添加文档、修改文档时的保存操作 由于对对象进行了重新划分，将AppendixList等从Document对象中提取出来 保持了Document对象和各个对象的独立性
Document | IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, int _nFlowdocId)
Document | IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo)
Document | IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.lang.String _sFlowContextInfo)
Document | IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc)
Document | IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.util.Map _hFlowContextInfo)
Document | IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.lang.String _sFlowContextInfo)
Document | IDocumentService.saveInfoViewDocument(Document _document, InfoView _infoView, java.util.Map _infoViewData)

参数类型为 Document 的 com.trs.service 中的方法
DocBak | IDocumentService.backup(Document _currDocument) 备份当前文档,产生当前文档的一个版本 备份只针对实体文档，不针对引用转发或者镜像文档，所以只提供一个Document参数
void | IDocumentService.changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
void | IPublishService.delete(Document _document) 删除指定文档已发布的页面
void | IPublishService.delete(Document _document, Channel _channel) 从指定频道上删除指定文档已发布的页面
boolean | IDocumentService.delete(Document _currDocument, Channel _currChannel, boolean _bDrop) 删除当前频道的一个文档
Schedule | IScheduleService.deletePublishSchedule(Document _currDocument) 删除指定文档的计划发布
java.lang.String | IDocumentService.export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出指定的文档
Schedule | IScheduleService.findPublishSchedule(Document _currDocument) 获取指定文档的计划发布信息
Appendixes | IDocumentService.getAppendixes(Document _currDocument) 获取当前文档的所有附件
Appendixes | IDocumentService.getAppendixes(Document _currDocument, int _nAppendixType) 获取当前文档的某种类型的附件
Appendixes | IDocumentService.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档的某种类型的附件
Appendixes | IDocumentService.getAppendixes(Document _currDocument, WCMFilter _filter) 获取当前文档的某种类型的附件
Channels | IDocumentService.getChannels(Document _currDocument) 获得实体文档相关的引用、镜像等对应的所有频道
DocBak | IDocumentService.getDocBak(Document _currDocument, int _nVersion) 获取当前文档指定版本的备份
DocBaks | IDocumentService.getDocBaks(Document _currDocument) 获取当前文档的备份
DocBaks | IDocumentService.getDocBaks(Document _currDocument, WCMFilter _filter) 获取当前文档的备份
Channels | IDocumentService.getMirrorChannels(Document _currDocument) 获得源文档所有存在同源异现镜像的频道
Channels | IDocumentService.getQuoteChannels(Document _currDocument) 获取引用了当前指定文档的所有频道
Documents | IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich) 指定检索条件获取与当前文档相关的文档
Documents | IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 指定检索条件获取与当前文档相关的文档
Documents | IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSite) 指定检索条件获取与当前文档相关的文档
Relations | IDocumentService.getRelations(Document _currDocument) 获取当前文档的Relations集合，即手工设定的相关文档
int | IDocumentService.getTopPosition(Document _currDocument, Channel _currChannel) 得到当前频道下的特定文档的置顶位置
CMyDateTime | IDocumentService.getTopTime(Document _currDocument, Channel _currChannel) 获得文档置顶的截止时间 如果文档没有置顶，则直接返回null 如果置顶文档没有设置截止时间则返回null
boolean | IDocumentService.isDocumentTopped(Document _currDocument, Channel _currChannel) 判断一个频道下的文档是否是处于置顶状态 应用层可以利用这个接口，在文档列表前加上图片标识
boolean | IDocumentService.isDocumentTopScheduled(Document _currDocument, Channel _currChannel) 判断频道下的文档如果置顶的话，是否已经加入了计划调度
void | IDocumentService.mirrorTo(Document _currDocument, Channel _toChannel) 将文档在另一个频道中建立一个同源异现的镜像
java.lang.String | IPublishService.preview(Document _document, Channel _channel, java.lang.String[] _warningsHolder) 在指定的频道上预览文档，并返回预览页面的URL。
java.lang.String | IPublishService.preview(Document _document, java.lang.String[] _warningsHolder) 在文档的存放点上预览文档，并返回预览页面的URL。
java.lang.String | IPublishService.previewInfoviewPrint(Document _document, Channel _channel, java.lang.String[] _waringsHolder, int _templateId)
void | IPublishService.publish(Document _document, Channel _channel, int _nPubType) 发布文档
void | IPublishService.publish(Document _document, int _nPubType) 发布文档
Reports | IDocumentService.quoteTo(Document _currDocument, java.lang.String _sToChannelIds) 维护单篇文档的引用转发关系 将单篇文档引用转发到目标频道列表中 一般用于在文档采编页面中，设置一篇文档的引用转发 这里的维护中包括删除所有无用的引用转发关系
Document | IDocumentService.recoverDocument(DocBak _aDocBak, Document _currDocument) 从文档备份版本中恢复文档
void | IDocumentService.removeToppedDocument(Document _currDocument, Channel _currChannel) 取消特定频道下某文档的置顶标志 该文档将成为普通文档 注意，不是删除文档！
void | IDocumentService.restore(Document _currDocument, Channel _currChannel) 恢复回收站中的文档
Document | IDocumentService.save(Document _aDocument, java.util.List _aAppendixList, java.util.List _aRelationList) 添加文档、修改文档时的保存操作 由于对对象进行了重新划分，将AppendixList等从Document对象中提取出来 保持了Document对象和各个对象的独立性
Document | IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, int _nFlowdocId)
Document | IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo)
Document | IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.lang.String _sFlowContextInfo)
Document | IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc)
Document | IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.util.Map _hFlowContextInfo)
Document | IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.lang.String _sFlowContextInfo)
Document | IDocumentService.saveInfoViewDocument(Document _document, InfoView _infoView, java.util.Map _infoViewData)
Schedule | IScheduleService.savePublishSchedule(Schedule _currSchedule, Document _currDocument) 给指定的文档设置计划发布属性
void | IInfoViewService.sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage) 发送表单文档的回复通知 优先使用表单上的设置
void | IDocumentService.setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶
void | IDocumentService.withdraw(Document _currDocument) 撤稿 ?

com.trs.service.impl 中 Document 的使用

返回 Document 的 com.trs.service.impl 中的方法
Document | DocumentService.recoverDocument(DocBak _aDocBak, Document _currDocument)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, int _nFlowDocId)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo, boolean _bNeedValidateRight)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.lang.String _sFlowContextInfo)
Document | DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc)
Document | DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.util.Map _hFlowContextInfo)
Document | DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.lang.String _sFlowContextInfo)
Document | DocumentService.saveInfoViewDocument(Document _document, InfoView _oInfoView, java.util.Map _oInfoViewData)

参数类型为 Document 的 com.trs.service.impl 中的方法
DocBak | DocumentService.backup(Document _currDocument)
void | DocumentService.changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus)
void | PublishService.delete(Document _document) 已过时。 根本就没有没有使用，声明为废弃的，以标识
void | PublishService.delete(Document _document, Channel _channel) 已过时。 根本就没有没有使用，声明为废弃的，以标识
boolean | DocumentService.delete(Document _currDocument, Channel _currChannel, boolean _bDrop)
Schedule | ScheduleService.deletePublishSchedule(Document _currDocument)
java.lang.String | DocumentService.export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes)
Schedule | ScheduleService.findPublishSchedule(Document _currDocument)
Appendixes | DocumentService.getAppendixes(Document _currDocument)
Appendixes | DocumentService.getAppendixes(Document _currDocument, int _nAppendixType)
Appendixes | DocumentService.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter)
Appendixes | DocumentService.getAppendixes(Document _currDocument, WCMFilter _apdFilter)
Channels | DocumentService.getChannels(Document _currDocument)
DocBak | DocumentService.getDocBak(Document _currDocument, int _nVersion)
DocBaks | DocumentService.getDocBaks(Document _currDocument)
DocBaks | DocumentService.getDocBaks(Document _currDocument, WCMFilter _filter)
Channels | DocumentService.getMirrorChannels(Document _currDocument)
Channels | DocumentService.getQuoteChannels(Document _currDocument)
Documents | DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich)
Documents | DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter)
Documents | DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites)
Relations | DocumentService.getRelations(Document _currDocument)
int | DocumentService.getTopPosition(Document _currDocument, Channel _currChannel)
CMyDateTime | DocumentService.getTopTime(Document _currDocument, Channel _currChannel)
boolean | DocumentService.isDocumentTopped(Document _currDocument, Channel _currChannel)
boolean | DocumentService.isDocumentTopScheduled(Document _currDocument, Channel _currChannel)
void | DocumentService.mirrorTo(Document _currDocument, Channel _toChannel)
java.lang.String | PublishService.preview(Document _document, Channel _channel, java.lang.String[] _warningsHolder)
java.lang.String | PublishService.preview(Document _document, Channel _channel, java.lang.String[] holder, Template _template)
java.lang.String | PublishService.preview(Document _document, java.lang.String[] _warningsHolder)
java.lang.String | PublishService.previewInfoviewPrint(Document _document, Channel _channel, java.lang.String[] _warningsHolder, int _templateId)
void | PublishService.publish(Document _document, Channel _channel, int _nPubType)
void | PublishService.publish(Document _document, int _nPubType)
Reports | DocumentService.quoteTo(Document _currDocument, java.lang.String _sToChannelIds)
Document | DocumentService.recoverDocument(DocBak _aDocBak, Document _currDocument)
void | DocumentService.removeToppedDocument(Document _currDocument, Channel _currChannel)
void | DocumentService.restore(Document _currDocument, Channel _currChannel)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, int _nFlowDocId)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo, boolean _bNeedValidateRight)
Document | DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.lang.String _sFlowContextInfo)
Document | DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc)
Document | DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.util.Map _hFlowContextInfo)
Document | DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.lang.String _sFlowContextInfo)
Document | DocumentService.saveInfoViewDocument(Document _document, InfoView _oInfoView, java.util.Map _oInfoViewData)
Schedule | ScheduleService.savePublishSchedule(Schedule _currSchedule, Document _currDocument)
void | InfoViewService.sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage)
void | DocumentService.setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil)
void | DocumentService.withdraw(Document _currDocument)

com.trs.wcm.old 中 Document 的使用

com.trs.wcm.old 中 Document 的子类
 class WCMExcelData
Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn

返回 Document 的 com.trs.wcm.old 中的方法
 Document WCMExcelData.getDocument()
获取所属的文档对象

参数类型为 Document 的 com.trs.wcm.old 中的方法
 void WCMExcelData.setPropertyByDocument(Document _doc)
使用文档对象给新的对象设置属性

com.trs.wcm.photo 中 Document 的使用

返回 Document 的 com.trs.wcm.photo 中的方法
 Document IImageLibService.saveImageDetail(Document _document)
保存图片的标注信息(标题、作者、地点、人物、时间)

参数类型为 Document 的 com.trs.wcm.photo 中的方法
static java.lang.String[] | ImageLibHelper.getAllImageFiles(Document _document)
static java.lang.String | ImageLibHelper.getImageFileNameByScale(Document _document, int _nScale)
static java.lang.String | ImageLibHelper.getImageFileNameByScale(Document _document, int _nScale, boolean _bOnlyFileName)
static java.lang.String | ImageLibHelper.getImageFileNameByScaleIndex(Document _document, int _nScaleIndex)
static java.lang.String | ImageLibHelper.getImageFileNameByScaleIndex(Document _document, int _nScaleIndex, boolean _bOnlyFileName)
static java.lang.String | ImageLibHelper.getOrigImageFileName(Document _document, boolean _bOnlyFileName)
static java.lang.String | ImageLibHelper.getOrigImageFilePath(Document _document, boolean _bOnlyFileName) 返回图片的原图的图径，若文档已发布，则返回该图的发布路径
Document | IImageLibService.saveImageDetail(Document _document) 保存图片的标注信息(标题、作者、地点、人物、时间)

com.trs.wcm.photo.impl 中 Document 的使用

返回 Document 的 com.trs.wcm.photo.impl 中的方法
 Document ImageLibServiceImpl.saveImageDetail(Document _document)

参数类型为 Document 的 com.trs.wcm.photo.impl 中的方法
 Document ImageLibServiceImpl.saveImageDetail(Document _document)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocumentFieldConfig
的使用

没有 com.trs.components.wcm.content.persistent.DocumentFieldConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Documents 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Documents
的使用

使用 Documents 的软件包
com.trs.ajaxservice
com.trs.components.ckm
com.trs.components.comment.service
com.trs.components.common.publish.widget
com.trs.components.infoview.helper
com.trs.components.infoview.mad
com.trs.components.metadata.center
com.trs.components.metadata.service
com.trs.components.stat
com.trs.components.wcm.content
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.domain.auth
com.trs.components.wcm.content.persistent
com.trs.components.wcm.content.trsserver
com.trs.components.wcm.publish.domain
com.trs.components.wcm.publish.tagparser
com.trs.components.wcm.recent
com.trs.presentation.wcm.content
com.trs.service
com.trs.service.impl
com.trs.wcm.photo
com.trs.wcm.photo.impl

com.trs.ajaxservice 中 Documents 的使用

返回 Documents 的 com.trs.ajaxservice 中的方法
Documents | SceneServiceProvider.cloneFromOtherFlow(MethodContext _methodContext)
Documents | DocumentServiceProvider.queryRecycle(MethodContext _methContext) 获取回收站文档

参数类型为 Documents 的 com.trs.ajaxservice 中的方法
static void | DocumentPublishHelper.delete(Documents _documents, Channel _channel)
static void | DocumentPublishHelper.delete(Documents _documents, Channel _channel, boolean _bAll)

com.trs.components.ckm 中 Documents 的使用

返回 Documents 的 com.trs.components.ckm 中的方法
Documents | TRSCKMServer.simSearch(int _nDocId, java.lang.String _sContent)
Documents | ICKMServer.simSearch(int _nDocId, java.lang.String _sContent)

com.trs.components.comment.service 中 Documents 的使用

返回 Documents 的 com.trs.components.comment.service 中的方法
Documents | ICommentService.getRelatedDocs(int _nTopicId, WCMFilter _oFilter)
Documents | CommentService.getRelatedDocs(int _nTopicId, WCMFilter _oFilter)

com.trs.components.common.publish.widget 中 Documents 的使用

参数类型为 Documents 的 com.trs.components.common.publish.widget 中的方法
static void SubjectDataInitHelper.setRelationForDocs(Documents targetDocs, Documents sourceDocs)

com.trs.components.infoview.helper 中 Documents 的使用

返回 Documents 的 com.trs.components.infoview.helper 中的方法
static Documents | InfoViewNewQueryHelper.queryDocuments(MethodContext _methodContext)
static Documents | InfoViewNewQueryHelper.queryDocuments(RequestHelper requestHelper)

com.trs.components.infoview.mad 中 Documents 的使用

返回 Documents 的 com.trs.components.infoview.mad 中的方法
Documents | InfoViewQueryHelper.getDocuments(Channel _channel, MethodContext _context)
Documents | InfoViewQueryHelperImpl.getDocuments(Channel _channel, MethodContext _context)

com.trs.components.metadata.center 中 Documents 的使用

返回 Documents 的 com.trs.components.metadata.center 中的方法
Documents | IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos _oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
Documents | ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象

参数类型为 Documents 的 com.trs.components.metadata.center 中的方法
ClassInfos | IClassInfoViewMgr.queryClassInfos(User _currUser, Documents oDocuments, WCMFilter _filter) 根据文档对象集合获取获取分类法信息集合
ClassInfos | ClassInfoViewMgr.queryClassInfos(User user, Documents documents, WCMFilter _filter)

com.trs.components.metadata.service 中 Documents 的使用

返回 Documents 的 com.trs.components.metadata.service 中的方法
Documents | ClassInfoViewServiceProvider.queryDocuments(MethodContext _methodContext)
Documents | ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfoIds, java.lang.String _sViewId, boolean _bContainChildClassInfo) 根据分类法的id序列和viewId得到文档集合对象
Documents | ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter) 根据传入的分类法对象获取文档集合对象
Documents | ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo) 根据传入的分类法对象获取文档集合对象

com.trs.components.stat 中 Documents 的使用

参数类型为 Documents 的 com.trs.components.stat 中的构造方法
HitsStatHandler4User(Documents currDocs)
HitsStatHandler4UserDept(Documents currDocs)

com.trs.components.wcm.content 中 Documents 的使用

返回 Documents 的 com.trs.components.wcm.content 中的方法
static Documents | QueryDocumentCenter.queryDocumentsForUser(User _currUser, BaseChannel _oChannelOrSite, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize, boolean _bContainsChildren, WCMFilter _filter)
static Documents | QueryDocumentCenter.queryDocumentsForUser(User _currUser, int _nChannelId, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize)
static Documents | QueryDocumentCenter.queryDocumentsOfCurrPage(WCMFilter _filter, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize)

com.trs.components.wcm.content.domain 中 Documents 的使用

返回 Documents 的 com.trs.components.wcm.content.domain 中的方法
Documents | DocumentMgr.getAllDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的所有文档
Documents | DocKeywordMgrImpl.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
Documents | IDocKeywordMgr.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter) 获取指定文档的所有相关文档
Documents | DocKeywordMgrImpl.getAllRelatedDocumentsByKeywordsFromTRSServer(java.lang.String _sKeywords, WCMFilter _filter, int _nPageIndex)
Documents | DocumentMgr.getDocuments(BaseChannel _oChannel, WCMFilter _filter) 取站点/频道的(除了回收站外的)文档集合
static Documents | DocumentsGetHelper.getDocuments(Channel _channel, WCMFilter _filter)
static Documents | DocumentsGetHelper.getDocuments(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder)
Documents | UserDocumentMgr.getDocuments(WCMFilter _filter) 获取个人的所有有效文档
Documents | UserDocumentMgr.getDraft(WCMFilter _filter) 获取个人草稿
Documents | DocumentMgr.getRecycleDocuments(BaseChannel _currChnl, WCMFilter _filter) 取频道的废稿
Documents | UserDocumentMgr.getRecycleDocuments(WCMFilter _filter) 获取个人回收站里的文档
Documents | DocumentMgr.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 相关文档的相关方法
Documents | DocumentMgr.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites) 获取与当前文档相关的文档集合(指定获取的方式:相关表/关键词/相关词等)
Documents | DocKeywordMgrImpl.getRelatedDocumentsByKeywords(Document _document, int _nMaxSize, java.lang.String _sSelectFields, int[] _pFilterStatusId, boolean _bMultiSite, java.util.ArrayList _arExistDocumentTitles) 根据标题排重 add by ly
Documents | IDocKeywordMgr.getRelatedDocumentsByKeywords(Document _document, int _nMaxSize, java.lang.String _sSelectFields, int[] _pFilterStatusId, boolean _bMultiSite, java.util.ArrayList _arExistDocumentTitles) 获取指定文档的相关文档
Documents | DocumentMgr.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档

参数类型为 Documents 的 com.trs.components.wcm.content.domain 中的方法
 java.lang.String DocumentExporter.export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes)
导出文档集合

com.trs.components.wcm.content.domain.auth 中 Documents 的使用

参数类型为 Documents 的 com.trs.components.wcm.content.domain.auth 中的方法
static boolean DocumentAuthServer.hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Documents _documents, int _nRightIndex)

com.trs.components.wcm.content.persistent 中 Documents 的使用

返回 Documents 的 com.trs.components.wcm.content.persistent 中的方法
static Documents | Documents.createNewInstance(User _currUser) 产生当前集合对象[Documents]的实例
static Documents | Documents.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Documents | Documents.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Documents]

com.trs.components.wcm.content.trsserver 中 Documents 的使用

返回 Documents 的 com.trs.components.wcm.content.trsserver 中的方法
Documents | DocsFromTRSServer.openDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize) 通过TRS构造一个Document集合
Documents | DocsFromTRSServer.openDocs(User _currUser, WCMFilter _filter, int _nCurrPage, int _nPageSize)
Documents | DocsFromTRSServer.openDocsByLocal(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize) 通过TRS构造一个Document集合

com.trs.components.wcm.publish.domain 中 Documents 的使用

返回 Documents 的 com.trs.components.wcm.publish.domain 中的方法
Documents[] | PreNextDocumentsImpl.getPreNextDocuments(Channel _channel, Document document, int num)
Documents[] | IPreNextDocuments.getPreNextDocuments(Channel _channel, Document _currDocument, int _nNum) 获取前/后N篇文档集合

com.trs.components.wcm.publish.tagparser 中 Documents 的使用

返回 Documents 的 com.trs.components.wcm.publish.tagparser 中的方法
Documents | PublishTaskDocumentsCacheMgr.get(IPublishFolder _folder, WCMFilter _filter)
Documents | IPublishTaskDocumentsCacheMgr.get(IPublishFolder _folder, WCMFilter _filter)

参数类型为 Documents 的 com.trs.components.wcm.publish.tagparser 中的方法
void | PublishTaskDocumentsCacheMgr.put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments)
void | IPublishTaskDocumentsCacheMgr.put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments) 将Folder根据Filter获取到的Documents缓存起来

com.trs.components.wcm.recent 中 Documents 的使用

返回 Documents 的 com.trs.components.wcm.recent 中的方法
 Documents RecentMgr.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted)
获得用户最近访问的文档列表，按访问时间逆序排列

com.trs.presentation.wcm.content 中 Documents 的使用

返回 Documents 的 com.trs.presentation.wcm.content 中的方法
 Documents DocumentsPageHelper.getDocuments(java.lang.String _sOrderFields, java.lang.String _sSelectFields)

com.trs.service 中 Documents 的使用

返回 Documents 的 com.trs.service 中的方法
Documents | IDocumentService.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
Documents | IUserService.getDocuments() 获取当前登录用户创建的有效文档集合
Documents | IChannelService.getDocuments(BaseChannel _oChannel) 获取当前站点/频道下的有效文档
Documents | IChannelService.getDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的有效文档
Documents | IChannelService.getDocuments(int _nChnlId) 获取当前频道下的有效文档
Documents | IChannelService.getDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的有效文档
Documents | IUserService.getDocuments(WCMFilter _filter) 获取当前登录用户创建的有效文档集合,设定查询条件
Documents | IRecentService.getDocuments(WCMFilter _aFilter) 返回用户最近访问的文档列表 由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
Documents | IRecentService.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的文档列表 由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
Documents | IUserService.getDraft() 获取当前登录用户创建的草稿集合
Documents | IUserService.getDraft(WCMFilter _filter) 获取当前登录用户创建的草稿集合,设定查询条件
Documents | IUserService.getRecycleDocuments() 获取当前登录用户创建的废稿集合
Documents | IChannelService.getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的废稿
Documents | IDocumentService.getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter) 获取当前站点或频道的回收站的文档
Documents | IChannelService.getRecycleDocuments(int _nChnlId) 获取当前频道下的废稿
Documents | IChannelService.getRecycleDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的废稿
Documents | IUserService.getRecycleDocuments(WCMFilter _filter) 获取当前登录用户创建的废稿集合,设定查询条件
Documents | IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich) 指定检索条件获取与当前文档相关的文档
Documents | IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 指定检索条件获取与当前文档相关的文档
Documents | IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSite) 指定检索条件获取与当前文档相关的文档
Documents | IDocumentService.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档

参数类型为 Documents 的 com.trs.service 中的方法
void | IDocumentService.changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
void | IPublishService.delete(Documents _documents) 删除指定文档集合已发布的页面
void | IPublishService.delete(Documents _documents, Channel _channel) 从指定频道上删除指定文档集合已发布的页面
boolean | IDocumentService.delete(Documents _aDocuments, Channel _currChannel, boolean _bDrop) 批量删除当前频道下的文档
java.lang.String | IDocumentService.export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出文档集合
void | IPublishService.publish(Documents _documents, Channel _channel, int _nPubType) 发布指定文档集合
void | IPublishService.publish(Documents _documents, int _nPubType) 发布指定文档集合
void | IDocumentService.restore(Documents _documents) 批量恢复回收站中的文档

com.trs.service.impl 中 Documents 的使用

返回 Documents 的 com.trs.service.impl 中的方法
Documents | DocumentService.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
Documents | UserService.getDocuments()
Documents | ChannelService.getDocuments(BaseChannel _oChannel) 获取当前站点/频道下的有效文档
Documents | ChannelService.getDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的有效文档
Documents | ChannelService.getDocuments(int _nChnlId) 获取当前频道下的有效文档
Documents | ChannelService.getDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的有效文档
Documents | RecentService.getDocuments(WCMFilter _aFilter)
Documents | UserService.getDocuments(WCMFilter _filter)
Documents | RecentService.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted)
Documents | UserService.getDraft()
Documents | UserService.getDraft(WCMFilter _filter)
Documents | UserService.getRecycleDocuments()
Documents | DocumentService.getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter)
Documents | ChannelService.getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的废稿
Documents | ChannelService.getRecycleDocuments(int _nChnlId) 获取当前频道下的废稿
Documents | ChannelService.getRecycleDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的废稿
Documents | UserService.getRecycleDocuments(WCMFilter _filter)
Documents | DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich)
Documents | DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter)
Documents | DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites)
Documents | DocumentService.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter)

参数类型为 Documents 的 com.trs.service.impl 中的方法
void | DocumentService.changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus)
void | PublishService.delete(Documents _documents) 已过时。 根本就没有没有使用，声明为废弃的，以标识
void | PublishService.delete(Documents _documents, Channel _channel)
boolean | DocumentService.delete(Documents _currDocuments, Channel _currChannel, boolean _bDrop)
java.lang.String | DocumentService.export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes)
void | PublishService.publish(Documents _documents, Channel _channel, int _nPubType)
void | PublishService.publish(Documents _documents, int _nPubType)
void | DocumentService.restore(Documents _documents)

com.trs.wcm.photo 中 Documents 的使用

返回 Documents 的 com.trs.wcm.photo 中的方法
Documents | IImageLibService.getDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前分类下所有的图片
Documents | IImageLibService.getDocumentsQuoteImage(int _nImageId) 获取使用指定图片的所有文档
Documents | IImageLibMgr.getDocumentsQuoteImage(int _nImageId) 获取使用指定图片的所有文档

com.trs.wcm.photo.impl 中 Documents 的使用

返回 Documents 的 com.trs.wcm.photo.impl 中的方法
Documents | ImageLibServiceImpl.getDocuments(BaseChannel _oChannel, WCMFilter _filter)
Documents | ImageLibServiceImpl.getDocumentsQuoteImage(int _nImageId)
Documents | ImageLibMgrImpl.getDocumentsQuoteImage(int _nImageId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig
的使用

没有 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase
的使用

使用 DocumentSubstanceImplBase 的软件包
com.trs.components.wcm.content.domain.auth

com.trs.components.wcm.content.domain.auth 中 DocumentSubstanceImplBase 的使用

com.trs.components.wcm.content.domain.auth 中 DocumentSubstanceImplBase 的子类
 class DocumentRightHostImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocumentSyn 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocumentSyn
的使用

使用 DocumentSyn 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.domain 中 DocumentSyn 的使用

返回 DocumentSyn 的 com.trs.components.wcm.content.domain 中的方法
 DocumentSyn AutoTransmitMgr.saveDocumentSyn(DocumentSyn _currTransmittedDoc)

参数类型为 DocumentSyn 的 com.trs.components.wcm.content.domain 中的方法
void | AutoTransmitMgr.deleteDocumentSyn(DocumentSyn _currTransmittedDoc)
DocumentSyn | AutoTransmitMgr.saveDocumentSyn(DocumentSyn _currTransmittedDoc)

com.trs.components.wcm.content.persistent 中 DocumentSyn 的使用

返回 DocumentSyn 的 com.trs.components.wcm.content.persistent 中的方法
static DocumentSyn | DocumentSyn.createNewInstance() 产生当前对象[TransmittedDoc]的实例
static DocumentSyn | DocumentSyn.findById(int _nId) 提取指定ID的对象
static DocumentSyn | DocumentSyn.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocumentSyns 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocumentSyns
的使用

使用 DocumentSyns 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 DocumentSyns 的使用

返回 DocumentSyns 的 com.trs.components.wcm.content.persistent 中的方法
static DocumentSyns | DocumentSyns.createNewInstance(User _currUser) 产生当前集合对象[TransmittedDocs]的实例
static DocumentSyns | DocumentSyns.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static DocumentSyns | DocumentSyns.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TransmittedDocs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.DocumentXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.DocumentXmlConverter
的使用

没有 com.trs.components.wcm.content.persistent.DocumentXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.HitsCount 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.HitsCount
的使用

没有 com.trs.components.wcm.content.persistent.HitsCount 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.HitsCounts 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.HitsCounts
的使用

没有 com.trs.components.wcm.content.persistent.HitsCounts 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.content.persistent.IChannelNameMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.persistent.IChannelNameMgr
的使用

使用 IChannelNameMgr 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 IChannelNameMgr 的使用

实现 IChannelNameMgr 的 com.trs.components.wcm.content.persistent 中的类
 class ChannelNameMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
频道名称缓冲管理(LRU缓冲算法)
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.content.persistent.IChildrenMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.persistent.IChildrenMgr
的使用

使用 IChildrenMgr 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 IChildrenMgr 的使用

实现 IChildrenMgr 的 com.trs.components.wcm.content.persistent 中的类
 class ChildrenCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
子栏目管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.MySystemInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.MySystemInfo
的使用

没有 com.trs.components.wcm.content.persistent.MySystemInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Relation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Relation
的使用

使用 Relation 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 Relation 的使用

返回 Relation 的 com.trs.components.wcm.content.persistent 中的方法
static Relation | Relation.createNewInstance() 产生当前对象[Relation]的实例
static Relation | Relation.findById(int _nId) 提取指定ID的对象
static Relation | Relation.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Relations 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Relations
的使用

使用 Relations 的软件包
com.trs.ajaxservice
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 Relations 的使用

返回 Relations 的 com.trs.ajaxservice 中的方法
Relations | ViewDocumentServiceProvider.queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档
Relations | DocumentServiceProvider.queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档
Relations | DocumentBakServiceProvider.queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档

com.trs.components.wcm.content.domain 中 Relations 的使用

返回 Relations 的 com.trs.components.wcm.content.domain 中的方法
Relations | RelationMgr.getRelations(Document _currDocument)
Relations | RelationMgr.getRelations(Document _currDocument, WCMFilter _extraFilter)
Relations | RelationMgr.getRelations(WCMFilter _aWCMFilter) 根据条件获得相关文档

com.trs.components.wcm.content.persistent 中 Relations 的使用

返回 Relations 的 com.trs.components.wcm.content.persistent 中的方法
static Relations | Relations.createNewInstance(User _currUser) 产生当前集合对象[Relations]的实例
static Relations | Relations.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Relations | Relations.findRelationsByObj(BaseObj _currObj) 获得文档所属关联文档集合 该接口应该是获得对象所属关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用 以后扩展应该也比较方便，增加一个对象类型ID即可
static Relations | Relations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Relations]

com.trs.service 中 Relations 的使用

返回 Relations 的 com.trs.service 中的方法
 Relations IDocumentService.getRelations(Document _currDocument)
获取当前文档的Relations集合，即手工设定的相关文档

com.trs.service.impl 中 Relations 的使用

返回 Relations 的 com.trs.service.impl 中的方法
 Relations DocumentService.getRelations(Document _currDocument)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Replace 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Replace
的使用

使用 Replace 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 Replace 的使用

返回 Replace 的 com.trs.components.wcm.content.domain 中的方法
 Replace ReplaceMgr.save(Replace _aReplace)
保存指定的Replace对象

参数类型为 Replace 的 com.trs.components.wcm.content.domain 中的方法
boolean | ReplaceMgr.delete(Replace _aReplace) 删除指定的Replace对象
Replace | ReplaceMgr.save(Replace _aReplace) 保存指定的Replace对象

com.trs.components.wcm.content.persistent 中 Replace 的使用

返回 Replace 的 com.trs.components.wcm.content.persistent 中的方法
static Replace | Replace.createNewInstance() 产生当前对象[Replace]的实例
static Replace | Replace.findById(int _nId) 提取指定ID的对象
static Replace | Replace.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 Replace 的使用

返回 Replace 的 com.trs.service 中的方法
 Replace IChannelService.saveReplace(Replace _aReplace)
保存替换内容对象

参数类型为 Replace 的 com.trs.service 中的方法
boolean | IChannelService.deleteReplace(Replace _aReplace) 删除替换内容对象
Replace | IChannelService.saveReplace(Replace _aReplace) 保存替换内容对象

com.trs.service.impl 中 Replace 的使用

返回 Replace 的 com.trs.service.impl 中的方法
 Replace ChannelService.saveReplace(Replace _aReplace)

参数类型为 Replace 的 com.trs.service.impl 中的方法
boolean | ChannelService.deleteReplace(Replace _aReplace)
Replace | ChannelService.saveReplace(Replace _aReplace)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr
的使用

没有 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.Replaces 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.Replaces
的使用

使用 Replaces 的软件包
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.service
com.trs.service.impl

com.trs.components.wcm.content.domain 中 Replaces 的使用

返回 Replaces 的 com.trs.components.wcm.content.domain 中的方法
 Replaces ReplaceMgr.getReplaces(Channel _oChannel, WCMFilter _filter)
获取当前频道下的替换内容

com.trs.components.wcm.content.persistent 中 Replaces 的使用

返回 Replaces 的 com.trs.components.wcm.content.persistent 中的方法
static Replaces | Replaces.createNewInstance(User _currUser) 产生当前集合对象[Replaces]的实例
static Replaces | Replaces.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Replaces | Channel.getReplaces(User _currUser) 获取频道上所有的替换内容对象
static Replaces | Replaces.openWCMObjs(User _currUser, WCMFilter _fitler) Created: 2004-12-12 17:23:52 Last Modified: 2004-12-12/2004-12-12 Description:获取内容替换对象集合

com.trs.service 中 Replaces 的使用

返回 Replaces 的 com.trs.service 中的方法
 Replaces IChannelService.getReplaces(Channel _oChannel, WCMFilter _filter)
获取指定频道下的替换内容对象集合

参数类型为 Replaces 的 com.trs.service 中的方法
 boolean IChannelService.deleteReplace(Replaces _aReplaces)
删除替换内容对象集合

com.trs.service.impl 中 Replaces 的使用

返回 Replaces 的 com.trs.service.impl 中的方法
 Replaces ChannelService.getReplaces(Channel _oChannel, WCMFilter _filter)

参数类型为 Replaces 的 com.trs.service.impl 中的方法
 boolean ChannelService.deleteReplace(Replaces _aReplaces)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.SiteLicenseMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.SiteLicenseMgr
的使用

使用 SiteLicenseMgr 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 SiteLicenseMgr 的使用

返回 SiteLicenseMgr 的 com.trs.components.wcm.content.persistent 中的方法
static SiteLicenseMgr SiteLicenseMgr.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.SiteMember 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.SiteMember
的使用

使用 SiteMember 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 SiteMember 的使用

返回 SiteMember 的 com.trs.components.wcm.content.persistent 中的方法
static SiteMember | SiteMember.createNewInstance() 产生当前对象[SiteUser]的实例
static SiteMember | SiteMember.findById(int _nId) 提取指定ID的对象
static SiteMember | SiteMember.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.SiteMembers 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.SiteMembers
的使用

使用 SiteMembers 的软件包
com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.persistent 中 SiteMembers 的使用

返回 SiteMembers 的 com.trs.components.wcm.content.persistent 中的方法
static SiteMembers | SiteMembers.createNewInstance(User _currUser) 产生一个当前集合对象[SiteUsers]的实例
static SiteMembers | SiteMembers.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static SiteMembers | SiteMembers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[SiteUsers]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.WebSite 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.WebSite
的使用

使用 WebSite 的软件包
com.trs.ajaxservice
com.trs.cms.auth.persistent
com.trs.components.comment.persistent
com.trs.components.common.trsad
com.trs.components.infoview.helper
com.trs.components.metadata.center
com.trs.components.metadata.service
com.trs.components.wcm.channel
com.trs.components.wcm.content
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.process.service.flowexporter
com.trs.components.wcm.publish.element
com.trs.presentation.nav
com.trs.presentation.wcm.content
com.trs.service
com.trs.service.impl
com.trs.template.service.impl
com.trs.wcm.old
com.trs.wcm.photo
com.trs.wcm.photo.impl

com.trs.ajaxservice 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.ajaxservice 中的方法
static boolean WebSiteHelper.isVisible(User _loginUser, WebSite _site)
判断用户对于指定站点是否可见

com.trs.cms.auth.persistent 中 WebSite 的使用

返回 WebSite 的 com.trs.cms.auth.persistent 中的方法
static WebSite RightValue.getSite(int _nObjType, int _nObjId)
由于角色和站点绑定，所以这个地方需要获取站点的id，将RightValue和站点依赖不太好，目前没有找到相应的解决办法, 除非每一个对象实现一个getHost的方法

参数类型为 WebSite 的 com.trs.cms.auth.persistent 中的方法
 Roles RoleUserCacheMgr.getRoles(User _currUser, WebSite _currSite)

com.trs.components.comment.persistent 中 WebSite 的使用

返回 WebSite 的 com.trs.components.comment.persistent 中的方法
 WebSite DocumentTopic.getSite()

com.trs.components.common.trsad 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.common.trsad 中的方法
 void ADPos.ChnlInit(WebSite _website, User _user)
初始化站点

com.trs.components.infoview.helper 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.infoview.helper 中的方法
 WCMFilter InfoViewChnlDocFilterHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)

com.trs.components.metadata.center 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.metadata.center 中的方法
 void MetaViewDatas.open(WebSite _site, WCMFilter _filter)

com.trs.components.metadata.service 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.metadata.service 中的方法
static void ClassInfoChannelRightHelper.resetClassInfoChannelRight(WebSite _site, Group _rootGroup)

com.trs.components.wcm.channel 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.wcm.channel 中的方法
 void VChannelManager.save(WebSite _parent, VChannel _oVChannel)

com.trs.components.wcm.content 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.wcm.content 中的方法
 void ViewDocuments.open(WebSite _site, WCMFilter _filter)

com.trs.components.wcm.content.domain 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.wcm.content.domain 中的方法
void | SiteMemberMgr.addSiteGroup(WebSite _site, Group _group) 添加站点用户组 将指定的用户组添加到指定的站点
void | SiteMemberMgr.addSiteUser(WebSite _site, User _user) 添加站点用户 将指定的用户添加到指定的站点
void | ContentLinkMgr.deleteContentLinks(WebSite _site)
AutoBakConfig | AutoDocBakMgr.getAutoSaveConfig(WebSite _currSite)
ContentLinks | ContentLinkMgr.getContentLinks(WebSite _currSite, WCMFilter _filter) 获取当前站点的所有内容超链接
Groups | SiteMemberMgr.getSiteGroups(WebSite _site, WCMFilter _filter) 获取站点中的用户组集合
Roles | SiteMemberMgr.getSiteRoles(WebSite _site, WCMFilter _fitler)
Users | SiteMemberMgr.getSiteUsers(WebSite _site, WCMFilter _filter) 获取站点中的用户集合
boolean | SiteMemberMgr.isBelongToSite(CMSObj _operator, WebSite _site) 判断指定的对象是否属于指定的站点
boolean | SiteMemberMgr.isBelongToSite(Group _group, WebSite _site) 判断指定的用户组是否属于指定的站点
boolean | SiteMemberMgr.isBelongToSite(Role _role, WebSite _site) 判断指定的角色是否属于指定的站点
boolean | SiteMemberMgr.isBelongToSite(User _user, WebSite _site) 判断指定的用户是否属于指定的站点
boolean | SiteMemberMgr.isVisible(CMSObj _operator, WebSite _site)
boolean | SiteMemberMgr.isVisible(User _user, WebSite _site)
static WCMFilter | DocumentsGetHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
void | ChannelMgr.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType) 将栏目移动到站点，作为兄弟或者子栏目
void | AutoDocBakMgr.removeConfig(WebSite _currSite)
void | SiteMemberMgr.removeSiteGroup(WebSite _site, Group _group) 删除站点用户组 将指定的用户组从指定的站点删除
void | SiteMemberMgr.removeSiteUser(WebSite _site, User _user) 删除站点用户 将指定的用户从指定的站点删除

参数类型为 WebSite 的 com.trs.components.wcm.content.domain 中的构造方法
SiteMemberIdsMan(WebSite _site, int _nMemberType)

com.trs.components.wcm.content.persistent 中 WebSite 的使用

返回 WebSite 的 com.trs.components.wcm.content.persistent 中的方法
static WebSite | WebSite.createNewInstance() 产生当前对象[WebSite]的实例
static WebSite | WebSite.findById(int _nId) 提取指定ID的对象
static WebSite | WebSite.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
WebSite | WebSite.getParent()
WebSite | ContentLink.getSite() 获取所属站点对象
abstract WebSite | BaseChannel.getSite()
WebSite | AutoBakConfig.getSite() 获取站点对象
WebSite | Channel.getSite() 频道所属的站点对象
WebSite | WebSite.getSite()

参数类型为 WebSite 的 com.trs.components.wcm.content.persistent 中的方法
boolean | WebSite.setParent(WebSite _parent)
boolean | Channel.setSite(WebSite _website) 设置所属站点：仅添加频道时可用，不允许修改该属性

com.trs.components.wcm.process.service.flowexporter 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.wcm.process.service.flowexporter 中的方法
 void SiteExporterForFlow.exportFlowsOfSite(WebSite oWebSite, java.lang.Object _args)

com.trs.components.wcm.publish.element 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.components.wcm.publish.element 中的构造方法
PublishFolderWebSiteImpl(WebSite _site)
constructor

com.trs.presentation.nav 中 WebSite 的使用

返回 WebSite 的 com.trs.presentation.nav 中的方法
 WebSite TreeNodeCalctor.getRoot()

参数类型为 WebSite 的 com.trs.presentation.nav 中的构造方法
TreeNodeCalctor(WebSite _site, Channels _srcChannels)

com.trs.presentation.wcm.content 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.presentation.wcm.content 中的构造方法
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, WebSite _site)

com.trs.service 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.service 中的方法
void | IChannelService.addGroupsToSite(java.lang.String _sGroupIds, WebSite _site) 给指定的站点添加指定的用户组
void | IChannelService.addRolesToSite(java.lang.String _sRoleIds, WebSite _site) 给指定的站点添加指定的角色
void | IChannelService.addUsersToSite(java.lang.String _sUserIds, WebSite _currSite) 给指定的站点添加指定的用户
Reports | IChannelService.createFrom(WebSite _srcSite, boolean _bWithRelated) 站点的类似创建的实现 从指定的站点获取站点的相关属性,创建一个新的站点.
void | IWCMPublishElementService.deletePublishDistributions(WebSite _currSite, java.lang.String _sPublishDistributionIds) 将当前站点的指定分发信息设置删除
PublishDistributions | IWCMPublishElementService.findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter) 获取当前站点所设置的分发目录集合
ContentLinks | IChannelService.getContentLinks(WebSite _site, WCMFilter _filter)
Groups | IChannelService.getSiteGroups(WebSite _site, WCMFilter _filter) 获取指定站点的所属用户组集合
Roles | IChannelService.getSiteRoles(WebSite _site, WCMFilter _filter) 获取指定站点的所属角色集合
Users | IChannelService.getSiteUsers(WebSite _currSite, WCMFilter _currFilter) 获取指定站点的所属用户集合
void | IChannelService.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType) 将频道移动到站点下，作为站点的一级子频道
void | IChannelService.moveTo(WebSite _fromWebSite, WebSite _toWebSite, int _nMoveToType) 将站点移动到另一个站点下，作为该站点的子站点或者兄弟
void | IChannelService.removeGroupsFromSite(java.lang.String _sGroupIds, WebSite _site) 删除指定的站点中的指定用户组
void | IChannelService.removeRolesFromSite(java.lang.String _sRoleIds, WebSite _site)
void | IChannelService.removeUsersFromSite(java.lang.String _sUserIds, WebSite _currSite) 删除指定的站点中的指定用户
PublishDistribution | IWCMPublishElementService.save(WebSite _currSite, PublishDistribution _currPublishDistribution) 保存当前站点所设置的分发目录
void | IWCMPublishElementService.setPubDistributionsEnable(WebSite _currSite, java.lang.String _sPublishDistributionIds, boolean _bEnable) 将当前站点的指定分发信息设置为无效
void | IChannelService.setSiteMembers(WebSite _site, int _nMemberType, java.lang.String _sMemberIds) 设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

com.trs.service.impl 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.service.impl 中的方法
void | ChannelService.addGroupsToSite(java.lang.String _sGroupIds, WebSite _site)
void | ChannelService.addRolesToSite(java.lang.String _sRoleIds, WebSite _site)
void | ChannelService.addUsersToSite(java.lang.String _sUserIds, WebSite _currSite)
Reports | ChannelService.createFrom(WebSite _srcSite, boolean _bWithRelated)
void | WCMPublishElementServiceImpl.deletePublishDistributions(WebSite _currSite, java.lang.String _sPublishDistributionIds)
PublishDistributions | WCMPublishElementServiceImpl.findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter)
ContentLinks | ChannelService.getContentLinks(WebSite _site, WCMFilter _filter)
Groups | ChannelService.getSiteGroups(WebSite _site, WCMFilter _filter)
Roles | ChannelService.getSiteRoles(WebSite _site, WCMFilter _filter)
Users | ChannelService.getSiteUsers(WebSite _currSite, WCMFilter _currFilter)
void | ChannelService.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType)
void | ChannelService.moveTo(WebSite _fromWebSite, WebSite _toWebSite, int _nMoveToType)
void | ChannelService.removeGroupsFromSite(java.lang.String _sGroupIds, WebSite _site)
void | ChannelService.removeRolesFromSite(java.lang.String _sRoleIds, WebSite _site)
void | ChannelService.removeUsersFromSite(java.lang.String _sUserIds, WebSite _currSite)
PublishDistribution | WCMPublishElementServiceImpl.save(WebSite _currSite, PublishDistribution _currPublishDistribution)
void | WCMPublishElementServiceImpl.setPubDistributionsEnable(WebSite _currSite, java.lang.String _sPublishDistributionIds, boolean _bEnable)
void | ChannelService.setSiteMembers(WebSite _site, int _nMemberType, java.lang.String _sMemberIds) 设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

com.trs.template.service.impl 中 WebSite 的使用

参数类型为 WebSite 的 com.trs.template.service.impl 中的方法
 IPublishFolder TemplateServiceImpl.makeTemplateFolder(java.lang.String _sFormattedTempName, WebSite _oRootSite)

com.trs.wcm.old 中 WebSite 的使用

返回 WebSite 的 com.trs.wcm.old 中的方法
 WebSite WCMFormInfo.getSite()
设置表单所属的站点

参数类型为 WebSite 的 com.trs.wcm.old 中的方法
 boolean WCMFormInfo.setSite(WebSite _website)
设置表单的所属站点，仅添加表单时有效，不允许修改

com.trs.wcm.photo 中 WebSite 的使用

返回 WebSite 的 com.trs.wcm.photo 中的方法
 WebSite IImageLibConfig.getRelateSite()
获取与图片库相关的站点

com.trs.wcm.photo.impl 中 WebSite 的使用

返回 WebSite 的 com.trs.wcm.photo.impl 中的方法
 WebSite ImageLibConfigImpl.getRelateSite()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.WebSites 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.WebSites
的使用

使用 WebSites 的软件包
com.trs.ajaxservice
com.trs.components.infoview.helper
com.trs.components.metadata.center
com.trs.components.wcm.content
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.recent
com.trs.presentation.nav
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 WebSites 的使用

返回 WebSites 的 com.trs.ajaxservice 中的方法
WebSites | WebSiteServiceProvider.getRecycleSites(MethodContext _methodContext) 获取回收站中的站点列表
WebSites | WebSiteServiceProvider.getSitesForCurrUser(MethodContext _methodContext) 获取当前登录用户可以操作（默认为设置权限）的站点
static WebSites | WebSiteHelper.getWebSitesByRightIndex(User _loginUser, int _nRightIndex, WCMFilter extraFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual) 获取某个用户能操作的站点集合
static WebSites | WebSiteHelper.getWebSitesByType(User _loginUser, int _nSiteType, WCMFilter queryFilter)
static WebSites | WebSiteHelper.getWebSitesByTypeWithIndividual(User _loginUser, int _nSiteType, WCMFilter queryFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual)

com.trs.components.infoview.helper 中 WebSites 的使用

参数类型为 WebSites 的 com.trs.components.infoview.helper 中的方法
 WCMFilter InfoViewChnlDocFilterHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)

com.trs.components.metadata.center 中 WebSites 的使用

参数类型为 WebSites 的 com.trs.components.metadata.center 中的方法
 void MetaViewDatas.open(WebSites _sites, WCMFilter _filter)

com.trs.components.wcm.content 中 WebSites 的使用

参数类型为 WebSites 的 com.trs.components.wcm.content 中的方法
 void ViewDocuments.open(WebSites _sites, WCMFilter _filter)

com.trs.components.wcm.content.domain 中 WebSites 的使用

返回 WebSites 的 com.trs.components.wcm.content.domain 中的方法
WebSites | ChannelMgr.getRecycleSites(WCMFilter _filter)
WebSites | SiteMemberMgr.getUserSites(User _currUser, WCMFilter _filter) 获取当前用户所在站点集合
WebSites | SiteMemberMgr.getWebSites(int _objType, int _objId, java.lang.String _sOrder) 获取某个对象（用户、组织、角色）可以管理的站点
WebSites | ChannelMgr.getWebSites(WCMFilter _filter, boolean _bIncludeDel) 获取系统中的所有站点

参数类型为 WebSites 的 com.trs.components.wcm.content.domain 中的方法
java.lang.String | ChannelExporter.export(WebSites _sites, boolean _bWithChildren, boolean _bWithRelate)
static WCMFilter | DocumentsGetHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)

com.trs.components.wcm.content.persistent 中 WebSites 的使用

返回 WebSites 的 com.trs.components.wcm.content.persistent 中的方法
static WebSites | WebSites.createNewInstance(User _currUser) 产生当前集合对象[WebSites]的实例
static WebSites | WebSites.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WebSites | WebSites.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WebSites]

com.trs.components.wcm.recent 中 WebSites 的使用

返回 WebSites 的 com.trs.components.wcm.recent 中的方法
 WebSites RecentMgr.getWebSites(WCMFilter _aFilter)
获得用户最近访问的模板列表，按访问时间逆序排列

com.trs.presentation.nav 中 WebSites 的使用

返回 WebSites 的 com.trs.presentation.nav 中的方法
WebSites | TreeNodeCalctor.getSites()
WebSites | TreeCreator.getWebSites(int _nSiteType)

com.trs.service 中 WebSites 的使用

返回 WebSites 的 com.trs.service 中的方法
WebSites | IChannelService.getRecycleSites(WCMFilter _filter) 获取系统回收站中的站点集合
WebSites | IChannelService.getUserSites(User _currUser, WCMFilter _currFilter) 获取指定用户所属的站点集合
WebSites | ICustomizeService.getWebSites() 获取个人定制的站点集合
WebSites | IChannelService.getWebSites(WCMFilter _filter) 获取当前用户可以看见的站点
WebSites | IRecentService.getWebSites(WCMFilter _aFilter) 返回用户最近访问的站点列表 按照访问的时间顺序排序

参数类型为 WebSites 的 com.trs.service 中的方法
java.lang.String | IChannelService.export(WebSites _fromWebSites, boolean _bWithChildren, boolean _bWithRelated)
void | IChannelService.restore(WebSites _currSites) 恢复站点集合

com.trs.service.impl 中 WebSites 的使用

返回 WebSites 的 com.trs.service.impl 中的方法
WebSites | ChannelService.getRecycleSites(WCMFilter _filter)
WebSites | ChannelService.getUserSites(User _currUser, WCMFilter _currFilter)
WebSites | CustomizeService.getWebSites()
WebSites | ChannelService.getWebSites(WCMFilter _filter) 获取当前用户可以看见的站点
WebSites | RecentService.getWebSites(WCMFilter _aFilter)

参数类型为 WebSites 的 com.trs.service.impl 中的方法
java.lang.String | ChannelService.export(WebSites _fromWebSites, boolean _bWithChildren, boolean _bWithRelated)
void | ChannelService.restore(WebSites _currSites)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase
的使用

使用 WebSiteSubstanceImplBase 的软件包
com.trs.components.wcm.content.domain.auth

com.trs.components.wcm.content.domain.auth 中 WebSiteSubstanceImplBase 的使用

com.trs.components.wcm.content.domain.auth 中 WebSiteSubstanceImplBase 的子类
 class WebSiteRightHostImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.XDocument 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.XDocument
的使用

没有 com.trs.components.wcm.content.persistent.XDocument 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.persistent.XDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.persistent.XDocuments
的使用

没有 com.trs.components.wcm.content.persistent.XDocuments 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IPorterVisitor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.service.portervisitors
接口 IPorterVisitor

所有已知实现类：
ChannelPorterVisitorForMetaView, SiteExporterForFlow
public interface IPorterVisitor

方法摘要
void | doExport(BaseObj _baseObj, java.lang.Object _extraArgs) 在导出_baseObj对象时,根据_baseObj对象做一些额外处理
void | doImport(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs) 在导入_baseObj对象时,根据当前xml串做一些额外处理
java.lang.String[] | registerTargetClassName()

方法详细信息

doExport

void doExport(BaseObj _baseObj,
              java.lang.Object _extraArgs)
              throws java.lang.Exception
在导出_baseObj对象时,根据_baseObj对象做一些额外处理

参数：
_baseObj -
_extraArgs -
抛出：
java.lang.Exception

doImport

void doImport(BaseObj _baseObj,
              XmlObject _xmlObj,
              java.lang.Object _extraArgs)
              throws java.lang.Exception
在导入_baseObj对象时,根据当前xml串做一些额外处理

参数：
_baseObj -
_xmlObj -
_extraArgs -
抛出：
java.lang.Exception

registerTargetClassName

java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.content.service.portervisitors
接口
IPorterVisitor
类
PorterUtil
PorterVisitorFactory


com.trs.components.wcm.content.service.portervisitors

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.content.service.portervisitors

接口摘要
IPorterVisitor

类摘要
PorterUtil
PorterVisitorFactory


com.trs.components.wcm.content.service.portervisitors 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.service.portervisitors 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.content.service.portervisitors.PorterUtil
    • com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory

接口分层结构

  • com.trs.components.wcm.content.service.portervisitors.IPorterVisitor


软件包 com.trs.components.wcm.content.service.portervisitors 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.service.portervisitors
的使用

使用 com.trs.components.wcm.content.service.portervisitors 的软件包
com.trs.components.metadata.service.portervisitors
com.trs.components.wcm.content.service.portervisitors
com.trs.components.wcm.process.service.flowexporter

com.trs.components.metadata.service.portervisitors 使用的 com.trs.components.wcm.content.service.portervisitors 中的类
IPorterVisitor

com.trs.components.wcm.content.service.portervisitors 使用的 com.trs.components.wcm.content.service.portervisitors 中的类
IPorterVisitor

com.trs.components.wcm.process.service.flowexporter 使用的 com.trs.components.wcm.content.service.portervisitors 中的类
IPorterVisitor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PorterUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.service.portervisitors
类 PorterUtil

java.lang.Object
    继承者  com.trs.components.wcm.content.service.portervisitors.PorterUtil

public class PorterUtil
extends java.lang.Object

构造方法摘要
PorterUtil()
方法摘要
static void | doExports(BaseObj _baseObj, java.lang.Object _extraArgs) 根据注册的导入/导出访问器类,在导出_baseObj时,执行所有已注册的访问器的导出定制操作
static void | doImports(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs) 根据注册的导入/导出访问器类,在导入_baseObj时,执行所有已注册的访问器的导入定制操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PorterUtil

public PorterUtil()
方法详细信息

doExports

public static void doExports(BaseObj _baseObj,
                             java.lang.Object _extraArgs)
根据注册的导入/导出访问器类,在导出_baseObj时,执行所有已注册的访问器的导出定制操作

参数：
_baseObj -
_xmlObj -

doImports

public static void doImports(BaseObj _baseObj,
                             XmlObject _xmlObj,
                             java.lang.Object _extraArgs)
根据注册的导入/导出访问器类,在导入_baseObj时,执行所有已注册的访问器的导入定制操作

参数：
_baseObj -
_xmlObj -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PorterVisitorFactory

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.service.portervisitors
类 PorterVisitorFactory

java.lang.Object
    继承者  com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory

public class PorterVisitorFactory
extends java.lang.Object

构造方法摘要
PorterVisitorFactory()
方法摘要
static java.util.List | createPorterVisitor(java.lang.String _sObjectClassName) 获取已注册的wcm对象导入/导出访问器
static java.util.List | createPorterVisotor(java.lang.Class _objectClass) 获取已注册的wcm对象导入/导出访问器
static void | registerPorterVisitor(IPorterVisitor _oElementGetter, java.lang.String _sTargetClassName) 注册wcm对象导入/导出访问器
static void | registerPorterVisitor(java.lang.String _sGetterClassName, java.lang.String _sTargetClassName) 注册wcm对象导入/导出访问器
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PorterVisitorFactory

public PorterVisitorFactory()
方法详细信息

createPorterVisotor

public static java.util.List createPorterVisotor(java.lang.Class _objectClass)
                                          throws java.lang.Exception
获取已注册的wcm对象导入/导出访问器

参数：
_objectClass -
返回：
抛出：
java.lang.Exception

createPorterVisitor

public static java.util.List createPorterVisitor(java.lang.String _sObjectClassName)
                                          throws java.lang.Exception
获取已注册的wcm对象导入/导出访问器

参数：
_sObjectClassName -
返回：
抛出：
java.lang.Exception

registerPorterVisitor

public static void registerPorterVisitor(IPorterVisitor _oElementGetter,
                                         java.lang.String _sTargetClassName)
                                  throws java.lang.Exception
注册wcm对象导入/导出访问器

参数：
_oElementGetter -
_sTargetClassName -
抛出：
java.lang.Exception

registerPorterVisitor

public static void registerPorterVisitor(java.lang.String _sGetterClassName,
                                         java.lang.String _sTargetClassName)
                                  throws java.lang.Exception
注册wcm对象导入/导出访问器

参数：
_sGetterClassName -
_sTargetClassName -
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.wcm.content.service.portervisitors.IPorterVisitor 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.content.service.portervisitors.IPorterVisitor
的使用

使用 IPorterVisitor 的软件包
com.trs.components.metadata.service.portervisitors
com.trs.components.wcm.content.service.portervisitors
com.trs.components.wcm.process.service.flowexporter

com.trs.components.metadata.service.portervisitors 中 IPorterVisitor 的使用

实现 IPorterVisitor 的 com.trs.components.metadata.service.portervisitors 中的类
 class ChannelPorterVisitorForMetaView

com.trs.components.wcm.content.service.portervisitors 中 IPorterVisitor 的使用

参数类型为 IPorterVisitor 的 com.trs.components.wcm.content.service.portervisitors 中的方法
static void PorterVisitorFactory.registerPorterVisitor(IPorterVisitor _oElementGetter, java.lang.String _sTargetClassName)
注册wcm对象导入/导出访问器

com.trs.components.wcm.process.service.flowexporter 中 IPorterVisitor 的使用

实现 IPorterVisitor 的 com.trs.components.wcm.process.service.flowexporter 中的类
 class SiteExporterForFlow

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.service.portervisitors.PorterUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.service.portervisitors.PorterUtil
的使用

没有 com.trs.components.wcm.content.service.portervisitors.PorterUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory
的使用

没有 com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChannelsWithRightMaker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 ChannelsWithRightMaker

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker

public class ChannelsWithRightMaker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
用户具有指定权限的栏目构造器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelsWithRightMaker(User _user, int _nRightIndex)
方法摘要
java.lang.String | getChannelIdsWithRight()
java.lang.String | getChannelIdsWithRight(java.lang.String _sChannelIds)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelsWithRightMaker

public ChannelsWithRightMaker(User _user,
                              int _nRightIndex)
方法详细信息

getChannelIdsWithRight

public java.lang.String getChannelIdsWithRight(java.lang.String _sChannelIds)
                                        throws WCMException
抛出：
WCMException

getChannelIdsWithRight

public java.lang.String getChannelIdsWithRight()
                                        throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ClassInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 ClassInfo

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.ClassInfo

public class ClassInfo
extends java.lang.Object

构造方法摘要
ClassInfo(com.eprobiti.trs.ClassInfo aClassInfo)
构造函数
方法摘要
int | getRecordNum() 获取分类的记录数
int | getValidNum() 获取可读取的记录数
java.lang.String | getValue() 获取当前分类字段对应的Value
void | setRecordNum(int recordNum) 设置分类的记录数
void | setValidNum(int validNum) 设置可读取的记录数
void | setValue(java.lang.String value) 设置当前分类字段对应的Value
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfo

public ClassInfo(com.eprobiti.trs.ClassInfo aClassInfo)
构造函数

参数：
aClassInfo - 日期：2006-12-12 9:37:29
方法详细信息

getRecordNum

public int getRecordNum()
获取分类的记录数

返回：

setRecordNum

public void setRecordNum(int recordNum)
设置分类的记录数

参数：
recordNum -

getValidNum

public int getValidNum()
获取可读取的记录数

返回：

setValidNum

public void setValidNum(int validNum)
设置可读取的记录数

参数：
validNum -

getValue

public java.lang.String getValue()
获取当前分类字段对应的Value

返回：

setValue

public void setValue(java.lang.String value)
设置当前分类字段对应的Value

参数：
value -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatasFromTRSServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 DatasFromTRSServer

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.DatasFromTRSServer

public class DatasFromTRSServer
extends java.lang.Object

构造方法摘要
DatasFromTRSServer()
构造函数
方法摘要
java.lang.Object | getDatasFromTRSServer(int _nCurrPage, int _nPageSize)
java.lang.Object | getDatasFromTRSServer(java.lang.String _sWhere, int _nCurrPage, int _nPageSize)
com.eprobiti.trs.TRSConnection | getValidConnection(java.lang.String host, java.lang.String port, java.lang.String username, java.lang.String password)
static void | main(java.lang.String[] args)
void | setOrder(java.lang.String _order) 设置排序条件
void | setSelect(java.lang.String _select) 设置抽取的字段名列表
void | setWhere(java.lang.String _where) 设置查询条件
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DatasFromTRSServer

public DatasFromTRSServer()
构造函数

方法详细信息

setSelect

public void setSelect(java.lang.String _select)
设置抽取的字段名列表

参数：
_select -

setWhere

public void setWhere(java.lang.String _where)
设置查询条件

参数：
_where - String对象SQL语句中Where部分，不包含Where关键字

setOrder

public void setOrder(java.lang.String _order)
设置排序条件

参数：
_order - String对象SQL语句中Order by部分，不包含Order by关键字

getDatasFromTRSServer

public java.lang.Object getDatasFromTRSServer(int _nCurrPage,
                                              int _nPageSize)
                                       throws WCMException
抛出：
WCMException

getDatasFromTRSServer

public java.lang.Object getDatasFromTRSServer(java.lang.String _sWhere,
                                              int _nCurrPage,
                                              int _nPageSize)
                                       throws WCMException
抛出：
WCMException

getValidConnection

public com.eprobiti.trs.TRSConnection getValidConnection(java.lang.String host,
                                                         java.lang.String port,
                                                         java.lang.String username,
                                                         java.lang.String password)
                                                  throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocsFromTRSServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 DocsFromTRSServer

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.DocsFromTRSServer

public class DocsFromTRSServer
extends java.lang.Object

Created by IntelliJ IDEA. User: Administrator Date: 2003-12-26 Time: 16:56:55 To change this template use Options | File Templates.

构造方法摘要
DocsFromTRSServer()
构造函数
方法摘要
static java.lang.String | filterForHTMLValue(java.lang.String _sContent) HTML元素value值过滤处理函数：将 & < >\ 等特殊字符作转化处理
static java.lang.String | getBodyCablet(java.lang.String strColName, com.eprobiti.trs.TRSResultSet _trsRs, java.lang.String _sColorValue)
java.lang.String | getClassField()
java.lang.String | getClassInfoAsString()
java.util.List | getClassInfos() 获取本次检索的分类统计信息
long | getSearchTime() 获取本次检索的花费时间
static java.lang.String | getTRSDocDBName() 获取WCM数据库中WCMDocument与TRS库中的表映射名
static java.lang.String | getTRSDocIdDBName() 获取WCM数据库WCMDocument表DocId字段与TRS库中的表映射名
static java.lang.String | getTRSWhere(javax.servlet.http.HttpServletRequest request)
static void | main(java.lang.String[] arArgs)
Documents | openDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize) 通过TRS构造一个Document集合
Documents | openDocs(User _currUser, WCMFilter _filter, int _nCurrPage, int _nPageSize)
Documents | openDocsByLocal(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize) 通过TRS构造一个Document集合
java.lang.Object | openViewDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize)
void | setClassField(java.lang.String classField)
static void | setTRSDocDBName(java.lang.String _sTRSDBName) 设置WCM数据库中WCMDocument与TRS库中的表映射名
static void | setTRSDocIdDBName(java.lang.String _sTRSIDDBName) 设置WCM数据库WCMDocument表DocId字段与TRS库中的表映射名
TRSToWCMFilter | toTRSFilter(WCMFilter _filter)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocsFromTRSServer

public DocsFromTRSServer()
构造函数

方法详细信息

setTRSDocDBName

public static void setTRSDocDBName(java.lang.String _sTRSDBName)
设置WCM数据库中WCMDocument与TRS库中的表映射名

参数：
_sTRSDBName - TRS库中的表映射名

getTRSDocDBName

public static java.lang.String getTRSDocDBName()
获取WCM数据库中WCMDocument与TRS库中的表映射名

返回：
TRS库中的表映射名

setTRSDocIdDBName

public static void setTRSDocIdDBName(java.lang.String _sTRSIDDBName)
设置WCM数据库WCMDocument表DocId字段与TRS库中的表映射名

参数：
_sTRSIDDBName - TRS库中的字段映射名

getTRSDocIdDBName

public static java.lang.String getTRSDocIdDBName()
获取WCM数据库WCMDocument表DocId字段与TRS库中的表映射名

返回：
TRS库中的字段映射名

filterForHTMLValue

public static java.lang.String filterForHTMLValue(java.lang.String _sContent)
HTML元素value值过滤处理函数：将 & < >\ 等特殊字符作转化处理

参数：
_sContent - 指定的文本内容
返回：
处理后的文本内容

getBodyCablet

public static java.lang.String getBodyCablet(java.lang.String strColName,
                                             com.eprobiti.trs.TRSResultSet _trsRs,
                                             java.lang.String _sColorValue)

openDocs

public Documents openDocs(User _currUser,
                          WCMFilter _filter,
                          int _nCurrPage,
                          int _nPageSize)
                   throws WCMException
抛出：
WCMException

toTRSFilter

public TRSToWCMFilter toTRSFilter(WCMFilter _filter)
                           throws WCMException
参数：
_filter -
返回：
抛出：
java.lang.Exception
WCMException

openViewDocs

public java.lang.Object openViewDocs(User _currUser,
                                     TRSToWCMFilter _filter,
                                     int _nCurrPage,
                                     int _nPageSize)
                              throws WCMException
抛出：
WCMException

openDocs

public Documents openDocs(User _currUser,
                          TRSToWCMFilter _filter,
                          int _nCurrPage,
                          int _nPageSize)
                   throws WCMException
通过TRS构造一个Document集合

参数：
_currUser -
_app -
_filter -
_nCurrPage -
_nPageSize -
返回：
抛出：
java.lang.Exception
WCMException

openDocsByLocal

public Documents openDocsByLocal(User _currUser,
                                 TRSToWCMFilter _filter,
                                 int _nCurrPage,
                                 int _nPageSize)
                          throws WCMException
通过TRS构造一个Document集合

参数：
_currUser -
_app -
_filter -
_nCurrPage -
_nPageSize -
返回：
抛出：
java.lang.Exception
WCMException

main

public static void main(java.lang.String[] arArgs)

getTRSWhere

public static java.lang.String getTRSWhere(javax.servlet.http.HttpServletRequest request)
                                    throws java.lang.Exception
抛出：
java.lang.Exception

getClassInfos

public java.util.List getClassInfos()
获取本次检索的分类统计信息

返回：

getClassInfoAsString

public java.lang.String getClassInfoAsString()

getSearchTime

public long getSearchTime()
获取本次检索的花费时间

返回：

getClassField

public java.lang.String getClassField()

setClassField

public void setClassField(java.lang.String classField)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KMTRSServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 KMTRSServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.components.wcm.content.trsserver.KMTRSServer
所有已实现的接口：
IServer
public class KMTRSServer
extends BaseServer

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
方法摘要
static boolean | connectTRS(java.lang.String _strServerHost, java.lang.String _strServerPort, java.lang.String _strUserName, java.lang.String _strPassWord)
void | freeConnection(com.eprobiti.trs.TRSConnection _oConn) 释放数据库连接
com.eprobiti.trs.TRSConnection | getConnection() 返回默认的TRSWCM数据库链接
static KMTRSServer | getKMTRSServer() 单体引用器
java.lang.String | getOpenProgram()
static boolean | initConnectionPool()
static boolean | reConnectTRS()
java.sql.PreparedStatement | setPrepareStatments(TRSToWCMFilter _filter, java.sql.PreparedStatement stmt)
static boolean | shutdownWCMForTRS()
static boolean | startWCMForTRS() 启动WCMForTRS
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getKMTRSServer

public static KMTRSServer getKMTRSServer()
单体引用器

返回：

getOpenProgram

public java.lang.String getOpenProgram()

shutdownWCMForTRS

public static boolean shutdownWCMForTRS()

startWCMForTRS

public static boolean startWCMForTRS()
启动WCMForTRS

返回：

connectTRS

public static boolean connectTRS(java.lang.String _strServerHost,
                                 java.lang.String _strServerPort,
                                 java.lang.String _strUserName,
                                 java.lang.String _strPassWord)
参数：
_strServerHost -
_strServerPort -
_strUserName -
_strPassWord -
返回：

reConnectTRS

public static boolean reConnectTRS()

initConnectionPool

public static boolean initConnectionPool()

freeConnection

public void freeConnection(com.eprobiti.trs.TRSConnection _oConn)
释放数据库连接

参数：
_oConn - 数据库连接对象

getConnection

public com.eprobiti.trs.TRSConnection getConnection()
                                             throws WCMException
返回默认的TRSWCM数据库链接

返回：
有效的数据库链接对象
抛出：
WCMException - 获取数据库链接对象过程中发生的异常 ================================================== Caller: Application.getConnection()

setPrepareStatments

public java.sql.PreparedStatement setPrepareStatments(TRSToWCMFilter _filter,
                                                      java.sql.PreparedStatement stmt)
                                               throws java.sql.SQLException
参数：
_filter -
stmt -
抛出：
java.sql.SQLException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OuterKMTRSServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 OuterKMTRSServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.components.wcm.content.trsserver.OuterKMTRSServer
所有已实现的接口：
IServer
public class OuterKMTRSServer
extends BaseServer

字段摘要
 boolean IS_DEBUG
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
方法摘要
void | freeConnection(com.eprobiti.trs.TRSConnection _oConn) 释放数据库连接
com.eprobiti.trs.TRSConnection | getConnection() 返回默认的TRSWCM数据库链接
static OuterKMTRSServer | getOuterKMTRSServer(java.lang.String host, java.lang.String port, java.lang.String username, java.lang.String password) 单体引用器
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_DEBUG

public boolean IS_DEBUG
方法详细信息

getOuterKMTRSServer

public static OuterKMTRSServer getOuterKMTRSServer(java.lang.String host,
                                                   java.lang.String port,
                                                   java.lang.String username,
                                                   java.lang.String password)
单体引用器

参数：
password -
username -
port -
host -
返回：

freeConnection

public void freeConnection(com.eprobiti.trs.TRSConnection _oConn)
释放数据库连接

参数：
_oConn - 数据库连接对象

getConnection

public com.eprobiti.trs.TRSConnection getConnection()
                                             throws WCMException
返回默认的TRSWCM数据库链接

返回：
有效的数据库链接对象
抛出：
WCMException - 获取数据库链接对象过程中发生的异常 ================================================== Caller: Application.getConnection()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.content.trsserver
类
ChannelsWithRightMaker
ClassInfo
DatasFromTRSServer
DocsFromTRSServer
KMTRSServer
OuterKMTRSServer
TestTrsServer
TreeNode
TRSConnectionPool
TRSSearcher
TRSSearcherFactory
TRSSearchUtil
TRSToWCMFilter


com.trs.components.wcm.content.trsserver

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.content.trsserver

类摘要
ChannelsWithRightMaker | Title: TRS 内容协作平台（TRS WCM） Description: 用户具有指定权限的栏目构造器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfo |
DatasFromTRSServer |
DocsFromTRSServer | Created by IntelliJ IDEA.
KMTRSServer |
OuterKMTRSServer |
TestTrsServer |
TreeNode |
TRSConnectionPool |
TRSSearcher | 默认的检索条件，基于TRS数据库 创建时间：2006-12-27 14:57:49
TRSSearcherFactory | TRS检索条件Searcher构造的工厂类 创建时间：2006-12-27 14:57:29
TRSSearchUtil | 类说明 创建时间：2006-12-12 13:54:50
TRSToWCMFilter | Created by IntelliJ IDEA.


com.trs.components.wcm.content.trsserver 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.trsserver 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.components.wcm.content.trsserver.KMTRSServer
      • com.trs.components.wcm.content.trsserver.OuterKMTRSServer
    • com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker
    • com.trs.components.wcm.content.trsserver.ClassInfo
    • com.trs.components.wcm.content.trsserver.DatasFromTRSServer
    • com.trs.components.wcm.content.trsserver.DocsFromTRSServer
    • com.trs.components.wcm.content.trsserver.TestTrsServer
    • com.trs.components.wcm.content.trsserver.TreeNode
    • com.trs.components.wcm.content.trsserver.TRSConnectionPool (implements java.lang.Runnable)
    • com.trs.components.wcm.content.trsserver.TRSSearcher
    • com.trs.components.wcm.content.trsserver.TRSSearcherFactory
    • com.trs.components.wcm.content.trsserver.TRSSearchUtil
    • com.trs.components.wcm.content.trsserver.TRSToWCMFilter


软件包 com.trs.components.wcm.content.trsserver 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.content.trsserver
的使用

使用 com.trs.components.wcm.content.trsserver 的软件包
com.trs.components.wcm.content
com.trs.components.wcm.content.trsserver

com.trs.components.wcm.content 使用的 com.trs.components.wcm.content.trsserver 中的类
TRSToWCMFilter
Created by IntelliJ IDEA.

com.trs.components.wcm.content.trsserver 使用的 com.trs.components.wcm.content.trsserver 中的类
KMTRSServer
OuterKMTRSServer
TreeNode
TRSSearcher
默认的检索条件，基于TRS数据库 创建时间：2006-12-27 14:57:49
TRSToWCMFilter
Created by IntelliJ IDEA.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TestTrsServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 TestTrsServer

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.TestTrsServer

public class TestTrsServer
extends java.lang.Object

构造方法摘要
TestTrsServer()
方法摘要
static void main(java.lang.String[] args)
测试程序入口
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TestTrsServer

public TestTrsServer()
方法详细信息

main

public static void main(java.lang.String[] args)
测试程序入口

参数：
args - 命令行参数
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeNode

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 TreeNode

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.TreeNode

public class TreeNode
extends java.lang.Object

构造方法摘要
TreeNode(Channel _channel, int _nChildMaxCount)
TreeNode(User _loginUser, int[] _pClassInfos)
构造函数
TreeNode(User _loginUser, java.lang.String _sClassInfos)
方法摘要
java.lang.String | getAllChildrenNodeIds()
Channel | getChannel()
int | getChildrenCount()
java.lang.String | getChildrenNodeIds()
TreeNode[] | getChildrenNodes()
int | getDocumentsCount()
TreeNode | getExpandNodeById(int _nChannelId)
void | setDocumentsCount(int documentsCount)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TreeNode

public TreeNode(User _loginUser,
                int[] _pClassInfos)
构造函数

参数：
_pClassInfos - 当前分类的信息，以,分隔，2*N个，奇数为频道ID，偶数为查询到的数目
_loginUser -

TreeNode

public TreeNode(User _loginUser,
                java.lang.String _sClassInfos)

TreeNode

public TreeNode(Channel _channel,
                int _nChildMaxCount)
方法详细信息

getChannel

public Channel getChannel()
返回：

getChildrenNodes

public TreeNode[] getChildrenNodes()
返回：

getAllChildrenNodeIds

public java.lang.String getAllChildrenNodeIds()

getChildrenNodeIds

public java.lang.String getChildrenNodeIds()

getExpandNodeById

public TreeNode getExpandNodeById(int _nChannelId)

getDocumentsCount

public int getDocumentsCount()
返回：

setDocumentsCount

public void setDocumentsCount(int documentsCount)
参数：
documentsCount -

getChildrenCount

public int getChildrenCount()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSConnectionPool

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 TRSConnectionPool

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.TRSConnectionPool
所有已实现的接口：
java.lang.Runnable
public class TRSConnectionPool
extends java.lang.Object
implements java.lang.Runnable

字段摘要
 boolean IS_DEBUG
构造方法摘要
TRSConnectionPool()
TRSConnectionPool(java.lang.String _sServer, java.lang.String _sServerPort, java.lang.String _sUserName, java.lang.String _sPassWord, int initialConnections, int maxConnections, boolean waitIfBusy)
方法摘要
void | closeAllConnections() 关闭所有连接
void | free(com.eprobiti.trs.TRSConnection connection) 释放连接
com.eprobiti.trs.TRSConnection | getConnection() 取得有效的数据库连接
boolean | isValid(com.eprobiti.trs.TRSConnection _currConnection)
void | reopenAllConnection()
void | run() 初始化数据库连接缓冲池
java.lang.String | toString() 获取数据库连接的信息
int | totalConnections() 获取缓冲池中连接总数
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

IS_DEBUG

public boolean IS_DEBUG
构造方法详细信息

TRSConnectionPool

public TRSConnectionPool()

TRSConnectionPool

public TRSConnectionPool(java.lang.String _sServer,
                         java.lang.String _sServerPort,
                         java.lang.String _sUserName,
                         java.lang.String _sPassWord,
                         int initialConnections,
                         int maxConnections,
                         boolean waitIfBusy)
                  throws java.lang.Exception
抛出：
java.lang.Exception
方法详细信息

closeAllConnections

public void closeAllConnections()
关闭所有连接

free

public void free(com.eprobiti.trs.TRSConnection connection)
释放连接

参数：
connection - 数据库连接对象(TRSConnection)

isValid

public boolean isValid(com.eprobiti.trs.TRSConnection _currConnection)

getConnection

public com.eprobiti.trs.TRSConnection getConnection()
                                             throws java.lang.Exception
取得有效的数据库连接

返回：
数据库连接对象(TRSConnection)
抛出：
java.lang.Exception

run

public void run()
初始化数据库连接缓冲池

指定者：
接口 java.lang.Runnable 中的 run

toString

public java.lang.String toString()
获取数据库连接的信息

覆盖：
类 java.lang.Object 中的 toString
返回：
数据库连接的信息（String）

totalConnections

public int totalConnections()
获取缓冲池中连接总数

返回：
缓冲池中连接总数（int）

reopenAllConnection

public void reopenAllConnection()
                         throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSSearcher

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 TRSSearcher

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.TRSSearcher

public class TRSSearcher
extends java.lang.Object

默认的检索条件，基于TRS数据库 创建时间：2006-12-27 14:57:49

作者：
TRS应用产品开发部 wcg

字段摘要
static int | SEARCHSCOPE_CONTAINSCHILDREN
static int | SEARCHSCOPE_SINGLE
方法摘要
void | buildSearcher() 构造当前TRS检索器的检索环境
java.lang.String | getChannelIds()
java.lang.String | getCurrSearch()
java.lang.String | getDateType()
java.lang.String | getDefaultCols() 获取默认检索字段
int | getDetailOpenType()
java.lang.String | getEndTime()
java.lang.String | getExtension()
java.lang.String | getLastSearch()
java.lang.String | getOption()
java.lang.String | getOrderBy()
int | getPageIndex()
int | getPageSize()
int | getSearchScope() 获取检索范围
java.lang.String | getSearchType()
java.lang.String | getSearchWord() 获取当前检索词
java.lang.String | getSiteIds() 获取检索条件对应的站点号
java.lang.String | getStartTime()
static TRSSearcher | getTRSSearcher(RequestHelper _currRequestHelper, User _loginUser) 从当前请求中获取TRS检索对象
java.lang.String | getWhere()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SEARCHSCOPE_CONTAINSCHILDREN

public static final int SEARCHSCOPE_CONTAINSCHILDREN
另请参见：
常量字段值

SEARCHSCOPE_SINGLE

public static final int SEARCHSCOPE_SINGLE
另请参见：
常量字段值
方法详细信息

getTRSSearcher

public static TRSSearcher getTRSSearcher(RequestHelper _currRequestHelper,
                                         User _loginUser)
从当前请求中获取TRS检索对象

参数：
_currRequestHelper -
_loginUser -
返回：

getSearchWord

public java.lang.String getSearchWord()
获取当前检索词

返回：

getOption

public java.lang.String getOption()

getExtension

public java.lang.String getExtension()

getSearchType

public java.lang.String getSearchType()

getLastSearch

public java.lang.String getLastSearch()

getStartTime

public java.lang.String getStartTime()

getEndTime

public java.lang.String getEndTime()

getPageSize

public int getPageSize()

getPageIndex

public int getPageIndex()

getDetailOpenType

public int getDetailOpenType()

getOrderBy

public java.lang.String getOrderBy()

getWhere

public java.lang.String getWhere()

getDateType

public java.lang.String getDateType()

getChannelIds

public java.lang.String getChannelIds()

getCurrSearch

public java.lang.String getCurrSearch()

buildSearcher

public void buildSearcher()
                   throws WCMException
构造当前TRS检索器的检索环境

抛出：
WCMException

getDefaultCols

public java.lang.String getDefaultCols()
获取默认检索字段

返回：

getSearchScope

public int getSearchScope()
获取检索范围

返回：

getSiteIds

public java.lang.String getSiteIds()
获取检索条件对应的站点号

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSSearcherFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 TRSSearcherFactory

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.TRSSearcherFactory

public class TRSSearcherFactory
extends java.lang.Object

TRS检索条件Searcher构造的工厂类 创建时间：2006-12-27 14:57:29

作者：
TRS应用产品开发部 wcg
另请参见：

构造方法摘要
TRSSearcherFactory()
方法摘要
static TRSSearcher buildSearcher(RequestHelper _currRequestHelper, User _loginUser)
构造TRS检索条件Searcher
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSSearcherFactory

public TRSSearcherFactory()
方法详细信息

buildSearcher

public static TRSSearcher buildSearcher(RequestHelper _currRequestHelper,
                                        User _loginUser)
                                 throws WCMException,
                                        java.lang.Exception
构造TRS检索条件Searcher

参数：
_currRequestHelper -
_loginUser -
返回：
抛出：
WCMException
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSSearchUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 TRSSearchUtil

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.TRSSearchUtil

public class TRSSearchUtil
extends java.lang.Object

类说明 创建时间：2006-12-12 13:54:50

作者：
TRS应用产品开发部 wcg
另请参见：

字段摘要
static char[] MARK_CHARS
当作标点符号的字符集
构造方法摘要
TRSSearchUtil()
方法摘要
static java.util.HashMap | getFavorite(javax.servlet.http.HttpServletRequest request) 获取用户的检索使用偏好
static java.lang.String | getStringWithCutsize(java.lang.String value, com.eprobiti.trs.TRSHitPoint[] hitPoints, int cutsize, java.lang.String strHitColorValue, java.lang.String charset) 根据命中点进行截断
static boolean | isMark(char pC) 返回当前字符是否为标点符号
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MARK_CHARS

public static final char[] MARK_CHARS
当作标点符号的字符集

构造方法详细信息

TRSSearchUtil

public TRSSearchUtil()
方法详细信息

getStringWithCutsize

public static java.lang.String getStringWithCutsize(java.lang.String value,
                                                    com.eprobiti.trs.TRSHitPoint[] hitPoints,
                                                    int cutsize,
                                                    java.lang.String strHitColorValue,
                                                    java.lang.String charset)
根据命中点进行截断

参数：
value -
hitPoints -
cutsize -
strHitColorValue -
charset -
返回：

isMark

public static boolean isMark(char pC)
返回当前字符是否为标点符号

参数：
pC -
返回：

getFavorite

public static java.util.HashMap getFavorite(javax.servlet.http.HttpServletRequest request)
                                     throws java.lang.Exception
获取用户的检索使用偏好

参数：
request -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSToWCMFilter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.content.trsserver
类 TRSToWCMFilter

java.lang.Object
    继承者  com.trs.components.wcm.content.trsserver.TRSToWCMFilter

public class TRSToWCMFilter
extends java.lang.Object

Created by IntelliJ IDEA. User: Administrator Date: 2003-12-26 Time: 17:14:45 To change this template use Options | File Templates.

构造方法摘要
TRSToWCMFilter()
TRSToWCMFilter(int _nSelectSize)
方法摘要
void | addSelectField(java.lang.String _sWCMField, java.lang.String _sTRSField)
java.lang.String | getCutSize() 获取CutSize
java.lang.String | getDefaultCols() 获取本次检索的检索字段
java.lang.String | getExtension() 获取自动扩展
java.lang.String | getIDFieldName()
java.lang.String | getOption() 获取检索时的检索选项掩码
java.util.Enumeration | getTRSFields()
java.lang.String | getTRSFrom()
java.lang.String | getTRSOrder()
java.lang.String | getTRSSelect()
java.lang.String | getTRSWhere()
java.lang.String | getWCMField(java.lang.String _sTRSField)
java.util.Enumeration | getWCMFields()
java.lang.String | getWCMSelect()
static void | main(java.lang.String[] arArgs)
void | setCutSize(java.lang.String sCutSize) 设置CutSize
void | setDefaultCols(java.lang.String defaultCols) 设置本次检索的检索字段
void | setExtension(java.lang.String sExtension) 设置自动扩展
void | setIDFieldName(java.lang.String _sTRSId)
void | setOption(java.lang.String sOption) 设置检索时的检索选项掩码
void | setSelect(java.lang.String _sWCMSelect, java.lang.String _sTRSSelect)
void | setTRSFrom(java.lang.String _sTRSFrom)
void | setTRSOrder(java.lang.String _sTRSOrder)
void | setTRSWhere(java.lang.String _sTRSWhere)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSToWCMFilter

public TRSToWCMFilter(int _nSelectSize)

TRSToWCMFilter

public TRSToWCMFilter()
方法详细信息

addSelectField

public void addSelectField(java.lang.String _sWCMField,
                           java.lang.String _sTRSField)

getTRSSelect

public java.lang.String getTRSSelect()

getWCMSelect

public java.lang.String getWCMSelect()

setSelect

public void setSelect(java.lang.String _sWCMSelect,
                      java.lang.String _sTRSSelect)
               throws WCMException
抛出：
WCMException

getWCMField

public java.lang.String getWCMField(java.lang.String _sTRSField)

getWCMFields

public java.util.Enumeration getWCMFields()

getTRSFields

public java.util.Enumeration getTRSFields()

setTRSWhere

public void setTRSWhere(java.lang.String _sTRSWhere)

getTRSWhere

public java.lang.String getTRSWhere()

setTRSFrom

public void setTRSFrom(java.lang.String _sTRSFrom)

getTRSFrom

public java.lang.String getTRSFrom()

setTRSOrder

public void setTRSOrder(java.lang.String _sTRSOrder)

getTRSOrder

public java.lang.String getTRSOrder()

setIDFieldName

public void setIDFieldName(java.lang.String _sTRSId)

getIDFieldName

public java.lang.String getIDFieldName()

main

public static void main(java.lang.String[] arArgs)

getCutSize

public java.lang.String getCutSize()
获取CutSize

返回：

setCutSize

public void setCutSize(java.lang.String sCutSize)
设置CutSize

参数：
sCutSize -

setExtension

public void setExtension(java.lang.String sExtension)
设置自动扩展

参数：
sExtension -

getExtension

public java.lang.String getExtension()
获取自动扩展

返回：

getOption

public java.lang.String getOption()
获取检索时的检索选项掩码

返回：

setOption

public void setOption(java.lang.String sOption)
设置检索时的检索选项掩码

参数：
sOption -

getDefaultCols

public java.lang.String getDefaultCols()
获取本次检索的检索字段

返回：

setDefaultCols

public void setDefaultCols(java.lang.String defaultCols)
设置本次检索的检索字段

参数：
defaultCols -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker
的使用

没有 com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.ClassInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.ClassInfo
的使用

没有 com.trs.components.wcm.content.trsserver.ClassInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer
的使用

没有 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer
的使用

没有 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.KMTRSServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.KMTRSServer
的使用

使用 KMTRSServer 的软件包
com.trs.components.wcm.content.trsserver

com.trs.components.wcm.content.trsserver 中 KMTRSServer 的使用

返回 KMTRSServer 的 com.trs.components.wcm.content.trsserver 中的方法
static KMTRSServer KMTRSServer.getKMTRSServer()
单体引用器

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.OuterKMTRSServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.OuterKMTRSServer
的使用

使用 OuterKMTRSServer 的软件包
com.trs.components.wcm.content.trsserver

com.trs.components.wcm.content.trsserver 中 OuterKMTRSServer 的使用

返回 OuterKMTRSServer 的 com.trs.components.wcm.content.trsserver 中的方法
static OuterKMTRSServer OuterKMTRSServer.getOuterKMTRSServer(java.lang.String host, java.lang.String port, java.lang.String username, java.lang.String password)
单体引用器

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.TestTrsServer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.TestTrsServer
的使用

没有 com.trs.components.wcm.content.trsserver.TestTrsServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.TreeNode 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.TreeNode
的使用

使用 TreeNode 的软件包
com.trs.components.wcm.content.trsserver

com.trs.components.wcm.content.trsserver 中 TreeNode 的使用

返回 TreeNode 的 com.trs.components.wcm.content.trsserver 中的方法
TreeNode[] | TreeNode.getChildrenNodes()
TreeNode | TreeNode.getExpandNodeById(int _nChannelId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.TRSConnectionPool
的使用

没有 com.trs.components.wcm.content.trsserver.TRSConnectionPool 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.TRSSearcher 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.TRSSearcher
的使用

使用 TRSSearcher 的软件包
com.trs.components.wcm.content.trsserver

com.trs.components.wcm.content.trsserver 中 TRSSearcher 的使用

返回 TRSSearcher 的 com.trs.components.wcm.content.trsserver 中的方法
static TRSSearcher | TRSSearcherFactory.buildSearcher(RequestHelper _currRequestHelper, User _loginUser) 构造TRS检索条件Searcher
static TRSSearcher | TRSSearcher.getTRSSearcher(RequestHelper _currRequestHelper, User _loginUser) 从当前请求中获取TRS检索对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.TRSSearcherFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.TRSSearcherFactory
的使用

没有 com.trs.components.wcm.content.trsserver.TRSSearcherFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.TRSSearchUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.TRSSearchUtil
的使用

没有 com.trs.components.wcm.content.trsserver.TRSSearchUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter
的使用

使用 TRSToWCMFilter 的软件包
com.trs.components.wcm.content
com.trs.components.wcm.content.trsserver

com.trs.components.wcm.content 中 TRSToWCMFilter 的使用

参数类型为 TRSToWCMFilter 的 com.trs.components.wcm.content 中的方法
 void ViewDocuments.openTRSServerViewDocuments(com.eprobiti.trs.TRSResultSet _sTrsRs, TRSToWCMFilter _filter, CPager _sCurrPager)

com.trs.components.wcm.content.trsserver 中 TRSToWCMFilter 的使用

返回 TRSToWCMFilter 的 com.trs.components.wcm.content.trsserver 中的方法
 TRSToWCMFilter DocsFromTRSServer.toTRSFilter(WCMFilter _filter)

参数类型为 TRSToWCMFilter 的 com.trs.components.wcm.content.trsserver 中的方法
Documents | DocsFromTRSServer.openDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize) 通过TRS构造一个Document集合
Documents | DocsFromTRSServer.openDocsByLocal(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize) 通过TRS构造一个Document集合
java.lang.Object | DocsFromTRSServer.openViewDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize)
java.sql.PreparedStatement | KMTRSServer.setPrepareStatments(TRSToWCMFilter _filter, java.sql.PreparedStatement stmt)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IVContentLinkParser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.contentlink
接口 IVContentLinkParser

所有已知实现类：
TxtFileParserForContentLink
public interface IVContentLinkParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

方法摘要
 java.util.Map parse(java.lang.String filename)
从文件内容中解释得到需要创建的对象.

方法详细信息

parse

java.util.Map parse(java.lang.String filename)
                    throws WCMException
从文件内容中解释得到需要创建的对象.

参数：
filename - 源文件名.
返回：
创建的虚拟对象(VContentLink)
抛出：
WCMException - 在解释文件出现异常时,将相应的异常包装为适当的WCMException抛出.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.contentlink
接口
IVContentLinkParser
类
TxtFileParserForContentLink


com.trs.components.wcm.contentlink

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.contentlink

接口摘要
IVContentLinkParser Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

类摘要
TxtFileParserForContentLink Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn


com.trs.components.wcm.contentlink 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.contentlink 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.contentlink.TxtFileParserForContentLink (implements com.trs.components.wcm.contentlink.IVContentLinkParser)

接口分层结构

  • com.trs.components.wcm.contentlink.IVContentLinkParser


软件包 com.trs.components.wcm.contentlink 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.contentlink
的使用

使用 com.trs.components.wcm.contentlink 的软件包
com.trs.components.wcm.contentlink

com.trs.components.wcm.contentlink 使用的 com.trs.components.wcm.contentlink 中的类
IVContentLinkParser
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TxtFileParserForContentLink

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.contentlink
类 TxtFileParserForContentLink

java.lang.Object
    继承者  com.trs.components.wcm.contentlink.TxtFileParserForContentLink
所有已实现的接口：
IVContentLinkParser
public class TxtFileParserForContentLink
extends java.lang.Object
implements IVContentLinkParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
lhm

构造方法摘要
TxtFileParserForContentLink()
方法摘要
static void | main(java.lang.String[] args)
java.util.Map | parse(java.lang.String filename) 从文件内容中解释得到需要创建的对象.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TxtFileParserForContentLink

public TxtFileParserForContentLink()
方法详细信息

parse

public java.util.Map parse(java.lang.String filename)
                    throws WCMException
从接口 IVContentLinkParser 复制的描述
从文件内容中解释得到需要创建的对象.

指定者：
接口 IVContentLinkParser 中的 parse
参数：
filename - 源文件名.
返回：
创建的虚拟对象(VContentLink)
抛出：
WCMException - 在解释文件出现异常时,将相应的异常包装为适当的WCMException抛出.

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.wcm.contentlink.IVContentLinkParser 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.contentlink.IVContentLinkParser
的使用

使用 IVContentLinkParser 的软件包
com.trs.components.wcm.contentlink

com.trs.components.wcm.contentlink 中 IVContentLinkParser 的使用

实现 IVContentLinkParser 的 com.trs.components.wcm.contentlink 中的类
 class TxtFileParserForContentLink
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.contentlink.TxtFileParserForContentLink 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.contentlink.TxtFileParserForContentLink
的使用

没有 com.trs.components.wcm.contentlink.TxtFileParserForContentLink 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CustomizedChannelIdsMan

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.customize
类 CustomizedChannelIdsMan

java.lang.Object
    继承者  com.trs.infra.common.BaseIdsMan
        继承者  com.trs.components.wcm.customize.CustomizedChannelIdsMan

public class CustomizedChannelIdsMan
extends BaseIdsMan

Title: TRS 内容协作平台（TRS WCM）
Description:
用户个性化定制频道的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CustomizedChannelIdsMan(User _currUser)
方法摘要
从类 com.trs.infra.common.BaseIdsMan 继承的方法
dowithIds
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CustomizedChannelIdsMan

public CustomizedChannelIdsMan(User _currUser)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CustomizeMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.customize
类 CustomizeMgr

java.lang.Object
    继承者  com.trs.components.wcm.customize.CustomizeMgr

public class CustomizeMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CustomizeMgr()
方法摘要
boolean | delete(int _nMoudelType) 删除定制的模块
boolean | deleteChannels(int[] _nArgChannelId) 删除定制的频道
UserSetting | find(User _currUser, int _nRegionNumber)
Channels | getChannels() 获取当前登录用户定制的频道集合
int[] | getMoudels() 获取定制的模块(不包定制的频道/站点)
boolean | hasCustomized() 判断当前登录用户是否有个性化定制内容
boolean | save(int _nMoudelType) 保存定制的功能模块
boolean | saveChannels(int[] _nArgChannelId) 保存定制的频道
void | saveSetting(BaseObj _baseObj, int _nOrder, int _nRegionNumber) 保存一个定制
void | saveSetting(BaseObj _baseObj, int _nOrder, int _nRegionNumber, java.lang.String _sValue) 保存一个定制
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CustomizeMgr

public CustomizeMgr()
方法详细信息

save

public boolean save(int _nMoudelType)
             throws WCMException
保存定制的功能模块

参数：
_nMoudelType - 模块类型
返回：
保存成功返回true
抛出：
WCMException

delete

public boolean delete(int _nMoudelType)
               throws WCMException
删除定制的模块

参数：
_nMoudelType - 模块类型
返回：
@throws WCMException
抛出：
WCMException

getMoudels

public int[] getMoudels()
                 throws WCMException
获取定制的模块(不包定制的频道/站点)

返回：
@throws WCMException
抛出：
WCMException

hasCustomized

public boolean hasCustomized()
                      throws java.lang.Exception
判断当前登录用户是否有个性化定制内容

返回：
如果有返回true
抛出：
java.lang.Exception

saveChannels

public boolean saveChannels(int[] _nArgChannelId)
                     throws WCMException
保存定制的频道

参数：
_nArgChannelId - 要保存的频道Id所组成的数组
返回：
成功返回true
抛出：
WCMException

deleteChannels

public boolean deleteChannels(int[] _nArgChannelId)
                       throws WCMException
删除定制的频道

参数：
_nArgChannelId - 要删除的定制频道Id组成的数组
返回：
操作成功返回true
抛出：
WCMException

getChannels

public Channels getChannels()
                     throws WCMException
获取当前登录用户定制的频道集合

返回：
如果没定制频道,近回空集
抛出：
WCMException

find

public UserSetting find(User _currUser,
                        int _nRegionNumber)
                 throws WCMException
抛出：
WCMException

saveSetting

public void saveSetting(BaseObj _baseObj,
                        int _nOrder,
                        int _nRegionNumber)
                 throws WCMException
保存一个定制

参数：
_baseObj - 要定制的模块.
_nOrder - 定制的顺序
_nRegionNumber - 定制的布局号
抛出：
WCMException

saveSetting

public void saveSetting(BaseObj _baseObj,
                        int _nOrder,
                        int _nRegionNumber,
                        java.lang.String _sValue)
                 throws WCMException
保存一个定制

参数：
_baseObj - 要定制的模块.
_nOrder - 定制的顺序
_nRegionNumber - 定制的布局号
_sValue - 定制的值(可以为空)
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.customize
类
CustomizedChannelIdsMan
CustomizeMgr
UserSetting
UserSettings


com.trs.components.wcm.customize

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.customize

类摘要
CustomizedChannelIdsMan | Title: TRS 内容协作平台（TRS WCM） Description: 用户个性化定制频道的管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CustomizeMgr | Title: TRS 内容协作平台（TRS WCM） Description: 个性化定制管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UserSetting |
UserSettings |


com.trs.components.wcm.customize 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.customize 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.common.BaseIdsMan
      • com.trs.components.wcm.customize.CustomizedChannelIdsMan
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.customize.UserSetting
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.customize.UserSettings
    • com.trs.components.wcm.customize.CustomizeMgr


软件包 com.trs.components.wcm.customize 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.customize
的使用

使用 com.trs.components.wcm.customize 的软件包
com.trs.components.wcm.customize

com.trs.components.wcm.customize 使用的 com.trs.components.wcm.customize 中的类
UserSetting
UserSettings

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


UserSetting

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.customize
类 UserSetting

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.customize.UserSetting
所有已实现的接口：
java.lang.Cloneable
public class UserSetting
extends CMSObj

字段摘要
static int | BOTTOM_REGION_NUMBER 底部
static int | CHANNEL_GROUP_TYPE
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | LEFT_REGION_NUMBER 左边
static int | MIDDLE_REGION_NUMBER 中部
static int | OBJ_TYPE 常量定义
static int | RIGHT_REGION_NUMBER 右边
static int | TOP_REGION_NUMBER 顶部
构造方法摘要
UserSetting()
方法摘要
static UserSetting | createNewInstance() 产生当前对象[UserSetting]的实例
static UserSetting | findById(int _nId) 提取指定ID的对象
static UserSetting | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static UserSetting | findOf(User _currUser, int _nObjType, int _nObjId) 获取指定类型指定ID的个性化配置
java.lang.String | getAttribute() 属性：Attribute 扩展属性
java.lang.String | getDbTableName() 重载父类中定义的抽象接口函数
java.lang.String | getIdFieldName() 获得Id字段名。
Channel | getObjAsChannel(User _currUser) 若定制对象为频道，则取其对应的频道对象 //why: 2002-04-02 扩展接口 说明：若不是频道对象，则返回null.
int | getObjId() 属性: ObjId, 对象ID，只读
int | getObjType() 属性: ObjType，只读，对象类型
int | getOrder() 属性: RangeIndex，只读，排列顺序
User | getOwner()
int | getRegion() 获取定制的布局区域号
int | getUser() 属性：UserId，只读，用户ID号
java.lang.String | getValue() 获取定制的值
int | getWCMType() 取得该对象的类型（定义在WCMTypes中）
void | insert(User _currUser) 添加对象到数据库
boolean | isValid() 验证对象数据的有效性
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setObjId(int _objId) 设置对象ID号，允许为空
boolean | setObjType(int _objType) 设置对象类型
boolean | setOrder(int _rangeIndex) 设置排列顺序
boolean | setRegion(int _nRegionNumber) 设置定制的布局区域号
boolean | setUser(int _userId) 设置登录用户ID号
boolean | setUser(User _user) 设置登录用户
boolean | setValue(java.lang.String _sValue) 设置定制的值
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
常量定义

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

CHANNEL_GROUP_TYPE

public static final int CHANNEL_GROUP_TYPE
另请参见：
常量字段值

TOP_REGION_NUMBER

public static final int TOP_REGION_NUMBER
顶部

另请参见：
常量字段值

BOTTOM_REGION_NUMBER

public static final int BOTTOM_REGION_NUMBER
底部

另请参见：
常量字段值

LEFT_REGION_NUMBER

public static final int LEFT_REGION_NUMBER
左边

另请参见：
常量字段值

MIDDLE_REGION_NUMBER

public static final int MIDDLE_REGION_NUMBER
中部

另请参见：
常量字段值

RIGHT_REGION_NUMBER

public static final int RIGHT_REGION_NUMBER
右边

另请参见：
常量字段值
构造方法详细信息

UserSetting

public UserSetting()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
重载父类中定义的抽象接口函数

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
取得该对象的类型（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：

getValue

public java.lang.String getValue()
获取定制的值

setValue

public boolean setValue(java.lang.String _sValue)
                 throws WCMException
设置定制的值

参数：
_sValue -
返回：
抛出：
WCMException

getRegion

public int getRegion()
获取定制的布局区域号

setRegion

public boolean setRegion(int _nRegionNumber)
                  throws WCMException
设置定制的布局区域号

抛出：
WCMException

getUser

public int getUser()
属性：UserId，只读，用户ID号

返回：

getOwner

public User getOwner()
              throws WCMException
抛出：
WCMException

setUser

public boolean setUser(int _userId)
                throws WCMException
设置登录用户ID号

参数：
_userId -
返回：
抛出：
WCMException

setUser

public boolean setUser(User _user)
                throws WCMException
设置登录用户

参数：
_user -
返回：
抛出：
WCMException

getObjType

public int getObjType()
属性: ObjType，只读，对象类型

返回：

setObjType

public boolean setObjType(int _objType)
                   throws WCMException
设置对象类型

参数：
_objType -
返回：
抛出：
WCMException

getObjId

public int getObjId()
属性: ObjId, 对象ID，只读

返回：

setObjId

public boolean setObjId(int _objId)
                 throws WCMException
设置对象ID号，允许为空

参数：
_objId -
返回：
抛出：
WCMException

getOrder

public int getOrder()
属性: RangeIndex，只读，排列顺序

返回：

setOrder

public boolean setOrder(int _rangeIndex)
                 throws WCMException
设置排列顺序

参数：
_rangeIndex -
返回：
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
属性：Attribute 扩展属性

覆盖：
类 BaseObj 中的 getAttribute
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
验证对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
添加对象到数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser -
抛出：
WCMException

getObjAsChannel

public Channel getObjAsChannel(User _currUser)
                        throws WCMException
若定制对象为频道，则取其对应的频道对象 //why: 2002-04-02 扩展接口 说明：若不是频道对象，则返回null.

参数：
_currUser -
返回：
抛出：
WCMException

findById

public static final UserSetting findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final UserSetting createNewInstance()
                                           throws WCMException
产生当前对象[UserSetting]的实例

返回：
当前对象的实例[UserSetting]
抛出：
WCMException

findByKey

public static final UserSetting findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findOf

public static final UserSetting findOf(User _currUser,
                                       int _nObjType,
                                       int _nObjId)
                                throws WCMException
获取指定类型指定ID的个性化配置

参数：
_nObjType -
_nObjId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserSettings

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.customize
类 UserSettings

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.customize.UserSettings

public class UserSettings
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
UserSettings(User _currUser)
UserSettings(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
static UserSettings | createNewInstance(User _currUser) 产生一个当前集合对象[UserSettings]的实例
static UserSettings | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static UserSettings | findOf(User _currUser, int _nObjType, WCMFilter _filter)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static UserSettings | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[UserSettings]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserSettings

public UserSettings(User _currUser)

UserSettings

public UserSettings(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
抛出：
java.lang.Exception

findByIds

public static final UserSettings findByIds(User _currUser,
                                           java.lang.String _sIds)
                                    throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final UserSettings openWCMObjs(User _currUser,
                                             WCMFilter _filter)
                                      throws WCMException
通过指定一个Filter获取当前集合[UserSettings]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[UserSettings]
抛出：
WCMException

createNewInstance

public static UserSettings createNewInstance(User _currUser)
                                      throws WCMException
产生一个当前集合对象[UserSettings]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

findOf

public static UserSettings findOf(User _currUser,
                                  int _nObjType,
                                  WCMFilter _filter)
                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.customize.CustomizedChannelIdsMan 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.customize.CustomizedChannelIdsMan
的使用

没有 com.trs.components.wcm.customize.CustomizedChannelIdsMan 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.customize.CustomizeMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.customize.CustomizeMgr
的使用

没有 com.trs.components.wcm.customize.CustomizeMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.customize.UserSetting 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.customize.UserSetting
的使用

使用 UserSetting 的软件包
com.trs.components.wcm.customize

com.trs.components.wcm.customize 中 UserSetting 的使用

返回 UserSetting 的 com.trs.components.wcm.customize 中的方法
static UserSetting | UserSetting.createNewInstance() 产生当前对象[UserSetting]的实例
UserSetting | CustomizeMgr.find(User _currUser, int _nRegionNumber)
static UserSetting | UserSetting.findById(int _nId) 提取指定ID的对象
static UserSetting | UserSetting.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static UserSetting | UserSetting.findOf(User _currUser, int _nObjType, int _nObjId) 获取指定类型指定ID的个性化配置

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.customize.UserSettings 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.customize.UserSettings
的使用

使用 UserSettings 的软件包
com.trs.components.wcm.customize

com.trs.components.wcm.customize 中 UserSettings 的使用

返回 UserSettings 的 com.trs.components.wcm.customize 中的方法
static UserSettings | UserSettings.createNewInstance(User _currUser) 产生一个当前集合对象[UserSettings]的实例
static UserSettings | UserSettings.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static UserSettings | UserSettings.findOf(User _currUser, int _nObjType, WCMFilter _filter)
static UserSettings | UserSettings.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[UserSettings]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChannelLCListener4EPress

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 ChannelLCListener4EPress

java.lang.Object
    继承者  com.trs.components.wcm.epress.ChannelLCListener4EPress
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel
public class ChannelLCListener4EPress
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnAdd

Title: TRS 内容协作平台（TRS WCM）
Description:
栏目删除监听
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ChannelLCListener4EPress()
方法摘要
void | notifyOnAddObj(BaseObj objAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelLCListener4EPress

public ChannelLCListener4EPress()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj objAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
objAdded - 新增的对象
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentLCListener4EPress

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 DocumentLCListener4EPress

java.lang.Object
    继承者  com.trs.components.wcm.epress.DocumentLCListener4EPress
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class DocumentLCListener4EPress
extends java.lang.Object
implements IObjectLCListenerOnModify, IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
修改重发相应的历史索引
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
DocumentLCListener4EPress()
方法摘要
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj objModified, int eventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListener4EPress

public DocumentLCListener4EPress()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressChannelCreateLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressChannelCreateLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.components.wcm.epress.EPressChannelCreateLogger
所有已实现的接口：
ServiceExcuteLogger
public class EPressChannelCreateLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
创建电子报栏目日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
EPressChannelCreateLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressChannelCreateLogger

public EPressChannelCreateLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressChannelWrapper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressChannelWrapper

java.lang.Object
    继承者  com.trs.components.wcm.epress.EPressChannelWrapper

public class EPressChannelWrapper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
栏目包装
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
EPressChannelWrapper(int _nPageNums, java.lang.String _sUid)
方法摘要
static void | main(java.lang.String[] args)
Channel | save(User _user, Channel _channel)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressChannelWrapper

public EPressChannelWrapper(int _nPageNums,
                            java.lang.String _sUid)
方法详细信息

save

public Channel save(User _user,
                    Channel _channel)
             throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressConf

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressConf

java.lang.Object
    继承者  com.trs.components.wcm.epress.EPressConf

public class EPressConf
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
电子报相关配置
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

方法摘要
void | add(java.lang.String key, int parentid)
boolean | existsEPress(int channelId)
boolean | existsEPress(java.lang.String uuid)
java.util.Map | getChannels(int channelId)
java.util.Map | getChannels(java.lang.String key)
static EPressConf | instance()
java.util.Iterator | keys()
void | notifyOnDelObj(BaseObj objDeleted)
void | reload()
java.lang.String | toXml(java.lang.String root)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

instance

public static final EPressConf instance()

keys

public java.util.Iterator keys()

add

public void add(java.lang.String key,
                int parentid)
         throws WCMException
抛出：
WCMException

getChannels

public java.util.Map getChannels(java.lang.String key)

getChannels

public java.util.Map getChannels(int channelId)

existsEPress

public boolean existsEPress(java.lang.String uuid)

existsEPress

public boolean existsEPress(int channelId)

reload

public void reload()

toXml

public java.lang.String toXml(java.lang.String root)

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EpressFolderWrapper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EpressFolderWrapper

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishFolderImplBase
        继承者  com.trs.components.wcm.publish.element.PublishFolderChannelImpl
            继承者  com.trs.components.wcm.epress.EpressFolderWrapper
所有已实现的接口：
ICMSObjSubstanceContent, IPublishElement, IPublishFolder
public class EpressFolderWrapper
extends PublishFolderChannelImpl
implements IPublishFolder

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

字段摘要
从类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 继承的字段
INHERIT_ROOT_DETAIL_TEMPLATE
构造方法摘要
EpressFolderWrapper(IPublishFolder _folder)
EpressFolderWrapper(IPublishFolder _folder, CMyDateTime _history)
方法摘要
boolean | canDoBatchDetailPageTask()
boolean | canDoDetailPageTask() check if can create detail page task
boolean | canDoOutlinePageTask() check if can create outline page task
boolean | canDoPreview() 判断发布元素是否可以预览
IPublishElements | getAllContents(WCMFilter _filter) Returns all the contents to publish
IPublishElementsIterator | getAllContentsIterator(WCMFilter _filter)
IPublishElements | getChildren() get the children folders
java.lang.String | getDataPath()
Template | getDetailTemplate() get the detail template of the current folder.
java.lang.String | getEncoding() Returns the file encoding of this element.
IPublishFolder | getFolder() Returns the folder where this element currently lies.
java.util.Collection | getFoldersQuotingMe() Returns the content folders who are quoting this folder
int | getId() Returns the publish content id.
IPublishElements | getIncreasedContents(WCMFilter _filter) Returns the increased contents to publish
IPublishElementsIterator | getIncreasedContentsIterator(WCMFilter _filter)
java.lang.String | getInfo() Gets the information of the folder.
java.lang.String | getLinkUrl()
Templates | getOutlineTemplates() get the outline templates of the current folder.
IPublishFolder | getParent()
java.lang.String | getPathKey() 获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写
IPublishElements | getPublishedContents(WCMFilter _filter) Returns the contents which have been published.
IPublishFolder | getRoot()
java.lang.String | getRootDomain() Returns the root domain of current folder.
int | getSiblingIndex() Retuns index of this folder in its siblings.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
java.util.HashMap | getTemplateArguments() 返回该发布对象已经进行了有效设置的全部模板参数列表
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isDeleted() 是否已经被假删除
boolean | isFolder() Returns true if current element is a folder.
boolean | isLink()
boolean | isRoot()
boolean | isValidElement() 判断是否为有效的发布元素
boolean | loadById(int _nId) Loads the content data by the specified id.
static void | main(java.lang.String[] args)
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setPublishStatus(int _nStatus) Sets the publish status of this folder
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
boolean | validateCanDoPub() Returns true if the folder is can be published.
从类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 继承的方法
toString
从类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 继承的方法
equals
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

EpressFolderWrapper

public EpressFolderWrapper(IPublishFolder _folder)

EpressFolderWrapper

public EpressFolderWrapper(IPublishFolder _folder,
                           CMyDateTime _history)
方法详细信息

getDataPath

public java.lang.String getDataPath()
                             throws WCMException
指定者：
接口 IPublishFolder 中的 getDataPath
覆盖：
类 PublishFolderImplBase 中的 getDataPath
返回：
the data path.
抛出：
WCMException
另请参见：
IPublishFolder.getDataPath()

getIncreasedContents

public IPublishElements getIncreasedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the increased contents to publish

指定者：
接口 IPublishFolder 中的 getIncreasedContents
覆盖：
类 PublishFolderChannelImpl 中的 getIncreasedContents
参数：
_filter - extra query filter for the collection
返回：
the contents collection, which are not published but can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getIncreasedContents(WCMFilter)

getAllContents

public IPublishElements getAllContents(WCMFilter _filter)
                                throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns all the contents to publish

指定者：
接口 IPublishFolder 中的 getAllContents
覆盖：
类 PublishFolderChannelImpl 中的 getAllContents
参数：
_filter - extra query filter for the collection
返回：
all the contents which have been published or can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getAllContents(WCMFilter)

getPublishedContents

public IPublishElements getPublishedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the contents which have been published.

指定者：
接口 IPublishFolder 中的 getPublishedContents
覆盖：
类 PublishFolderChannelImpl 中的 getPublishedContents
参数：
_filter - extra query filter for the collection
返回：
the contents which have been published
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getPublishedContents(WCMFilter)

getFoldersQuotingMe

public java.util.Collection getFoldersQuotingMe()
                                         throws WCMException
从接口 IPublishFolder 复制的描述
Returns the content folders who are quoting this folder

指定者：
接口 IPublishFolder 中的 getFoldersQuotingMe
覆盖：
类 PublishFolderImplBase 中的 getFoldersQuotingMe
返回：
the folders collection who are quoting this folder
抛出：
WCMException - if fails to fetch the folders collection
另请参见：
IPublishFolder.getFoldersQuotingMe()

getOutlineTemplates

public Templates getOutlineTemplates()
从接口 IPublishFolder 复制的描述
get the outline templates of the current folder.

指定者：
接口 IPublishFolder 中的 getOutlineTemplates
覆盖：
类 PublishFolderImplBase 中的 getOutlineTemplates
返回：
the outline templates of current folder.
另请参见：
IPublishFolder#getOutlineTemplate()

getDetailTemplate

public Template getDetailTemplate()
从接口 IPublishFolder 复制的描述
get the detail template of the current folder.

指定者：
接口 IPublishFolder 中的 getDetailTemplate
覆盖：
类 PublishFolderImplBase 中的 getDetailTemplate
返回：
the detail template of current folder.

getRootDomain

public java.lang.String getRootDomain()
                               throws WCMException
从接口 IPublishFolder 复制的描述
Returns the root domain of current folder.

指定者：
接口 IPublishFolder 中的 getRootDomain
覆盖：
类 PublishFolderImplBase 中的 getRootDomain
返回：
the root domain of current folder.
抛出：
WCMException - if failed to load the folder publish config.
另请参见：
IPublishFolder.getRootDomain()

isRoot

public boolean isRoot()
指定者：
接口 IPublishFolder 中的 isRoot
覆盖：
类 PublishFolderChannelImpl 中的 isRoot
返回：
true if this folder is a root; otherwise, returns false.
另请参见：
IPublishFolder.isRoot()

getRoot

public IPublishFolder getRoot()
                       throws WCMException
指定者：
接口 IPublishFolder 中的 getRoot
覆盖：
类 PublishFolderChannelImpl 中的 getRoot
返回：
the root of this folder.
抛出：
WCMException - if failed to find the folder root.
另请参见：
IPublishFolder.getRoot()

getParent

public IPublishFolder getParent()
                         throws WCMException
指定者：
接口 IPublishFolder 中的 getParent
覆盖：
类 PublishFolderChannelImpl 中的 getParent
返回：
the parent of this folder.
抛出：
WCMException - if failed to fetch the parent folder.
另请参见：
IPublishFolder.getParent()

getChildren

public IPublishElements getChildren()
                             throws WCMException
从接口 IPublishFolder 复制的描述
get the children folders

指定者：
接口 IPublishFolder 中的 getChildren
覆盖：
类 PublishFolderChannelImpl 中的 getChildren
返回：
the children folders collection.
抛出：
WCMException - if failed to fetch the children.
另请参见：
IPublishFolder.getChildren()

getSiblingIndex

public int getSiblingIndex()
                    throws WCMException
从接口 IPublishFolder 复制的描述
Retuns index of this folder in its siblings.

指定者：
接口 IPublishFolder 中的 getSiblingIndex
覆盖：
类 PublishFolderChannelImpl 中的 getSiblingIndex
返回：
index of this folder in its siblings.
抛出：
WCMException - if failed to calculate the index.
另请参见：
IPublishFolder.getSiblingIndex()

canDoOutlinePageTask

public boolean canDoOutlinePageTask()
从接口 IPublishFolder 复制的描述
check if can create outline page task

指定者：
接口 IPublishFolder 中的 canDoOutlinePageTask
覆盖：
类 PublishFolderChannelImpl 中的 canDoOutlinePageTask
返回：

canDoDetailPageTask

public boolean canDoDetailPageTask()
从接口 IPublishFolder 复制的描述
check if can create detail page task

指定者：
接口 IPublishFolder 中的 canDoDetailPageTask
覆盖：
类 PublishFolderChannelImpl 中的 canDoDetailPageTask
返回：

canDoBatchDetailPageTask

public boolean canDoBatchDetailPageTask()
指定者：
接口 IPublishFolder 中的 canDoBatchDetailPageTask
覆盖：
类 PublishFolderChannelImpl 中的 canDoBatchDetailPageTask

getIncreasedContentsIterator

public IPublishElementsIterator getIncreasedContentsIterator(WCMFilter _filter)
                                                      throws java.lang.Exception
指定者：
接口 IPublishFolder 中的 getIncreasedContentsIterator
覆盖：
类 PublishFolderChannelImpl 中的 getIncreasedContentsIterator
抛出：
java.lang.Exception

getAllContentsIterator

public IPublishElementsIterator getAllContentsIterator(WCMFilter _filter)
                                                throws java.lang.Exception
指定者：
接口 IPublishFolder 中的 getAllContentsIterator
覆盖：
类 PublishFolderChannelImpl 中的 getAllContentsIterator
抛出：
java.lang.Exception

isFolder

public boolean isFolder()
从接口 IPublishElement 复制的描述
Returns true if current element is a folder.

指定者：
接口 IPublishElement 中的 isFolder
覆盖：
类 PublishFolderImplBase 中的 isFolder
返回：
true if current element is a folder.
另请参见：
IPublishElement.isFolder()

getFolder

public IPublishFolder getFolder()
从接口 IPublishElement 复制的描述
Returns the folder where this element currently lies.

指定者：
接口 IPublishElement 中的 getFolder
覆盖：
类 PublishFolderImplBase 中的 getFolder
返回：
the folder where this element currently lies.
另请参见：
IPublishElement.getFolder()

getEncoding

public java.lang.String getEncoding()
                             throws WCMException
从接口 IPublishElement 复制的描述
Returns the file encoding of this element.

指定者：
接口 IPublishElement 中的 getEncoding
覆盖：
类 PublishFolderImplBase 中的 getEncoding
返回：
the file encoding of this element
抛出：
WCMException - if failed to find the file encoding.

validateCanDoPub

public boolean validateCanDoPub()
                         throws WCMException
从接口 IPublishElement 复制的描述
Returns true if the folder is can be published.

指定者：
接口 IPublishElement 中的 validateCanDoPub
覆盖：
类 PublishFolderChannelImpl 中的 validateCanDoPub
返回：
true if the folder is can be published.
抛出：
WCMException
另请参见：
IPublishElement.validateCanDoPub()

isValidElement

public boolean isValidElement()
从接口 IPublishElement 复制的描述
判断是否为有效的发布元素

指定者：
接口 IPublishElement 中的 isValidElement
覆盖：
类 PublishFolderChannelImpl 中的 isValidElement
返回：

isLink

public boolean isLink()
指定者：
接口 IPublishElement 中的 isLink
覆盖：
类 PublishFolderChannelImpl 中的 isLink
返回：
true if the eliement is a link;
otherwise, returns false.
另请参见：
IPublishElement.isLink()

getLinkUrl

public java.lang.String getLinkUrl()
指定者：
接口 IPublishElement 中的 getLinkUrl
覆盖：
类 PublishFolderChannelImpl 中的 getLinkUrl
返回：
the linked url if this eliement is a link;
otherwise, returns null.
另请参见：
IPublishElement.getLinkUrl()

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

指定者：
接口 IPublishElement 中的 validateCanDoPreview
覆盖：
类 PublishFolderChannelImpl 中的 validateCanDoPreview
抛出：
WCMException

canDoPreview

public boolean canDoPreview()
从接口 IPublishElement 复制的描述
判断发布元素是否可以预览

指定者：
接口 IPublishElement 中的 canDoPreview
覆盖：
类 PublishFolderChannelImpl 中的 canDoPreview
返回：

getTemplateArguments

public java.util.HashMap getTemplateArguments()
                                       throws WCMException
从接口 IPublishElement 复制的描述
返回该发布对象已经进行了有效设置的全部模板参数列表

指定者：
接口 IPublishElement 中的 getTemplateArguments
覆盖：
类 PublishFolderImplBase 中的 getTemplateArguments
返回：
该发布对象已经进行了有效设置的全部模板参数列表
抛出：
WCMException

isCanDoSave

public boolean isCanDoSave(User _loginUser)
                    throws WCMException
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

指定者：
接口 IPublishElement 中的 isCanDoSave
覆盖：
类 PublishFolderChannelImpl 中的 isCanDoSave
返回：
抛出：
WCMException

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
覆盖：
类 PublishFolderChannelImpl 中的 getType
返回：
the publish content type
另请参见：
ICMSObjSubstanceContent.getType()

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
覆盖：
类 PublishFolderChannelImpl 中的 getId
返回：
the publish content id
另请参见：
ICMSObjSubstanceContent.getId()

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
覆盖：
类 PublishFolderChannelImpl 中的 getSubstance
返回：
the substance object which is an instance of CMSObj
另请参见：
ICMSObjSubstanceContent.getSubstance()

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
覆盖：
类 PublishFolderChannelImpl 中的 setSubstance
参数：
_cmsObj - a CMS object
另请参见：
ICMSObjSubstanceContent.setSubstance(CMSObj)

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
覆盖：
类 PublishFolderImplBase 中的 getInfo
返回：
the information of the folder
另请参见：
ICMSObjSubstanceContent.getInfo()

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
覆盖：
类 PublishFolderChannelImpl 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException
另请参见：
ICMSObjSubstanceContent.loadById(int)

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
覆盖：
类 PublishFolderChannelImpl 中的 makeFrom
参数：
_cmsObj - a CMS object
另请参见：
ICMSObjSubstanceContent.makeFrom(CMSObj)

main

public static void main(java.lang.String[] args)

isDeleted

public boolean isDeleted()
从接口 IPublishFolder 复制的描述
是否已经被假删除

指定者：
接口 IPublishFolder 中的 isDeleted
覆盖：
类 PublishFolderChannelImpl 中的 isDeleted
返回：

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishFolder 复制的描述
Sets the publish status of this folder

指定者：
接口 IPublishFolder 中的 setPublishStatus
覆盖：
类 PublishFolderChannelImpl 中的 setPublishStatus
参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, STATUS_DELETEDetc.
抛出：
WCMException

getPathKey

public java.lang.String getPathKey()
从接口 IPublishFolder 复制的描述
获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写

指定者：
接口 IPublishFolder 中的 getPathKey
覆盖：
类 PublishFolderImplBase 中的 getPathKey
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressHistoryGenerator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressHistoryGenerator

java.lang.Object
    继承者  com.trs.components.wcm.epress.EPressHistoryGenerator

public class EPressHistoryGenerator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
电子报历史数据概览索引产生者
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
EPressHistoryGenerator(Channel _channel)
EPressHistoryGenerator(Channel _channel, boolean _zPubAction)
方法摘要
void | generate()
void | generate(CMyDateTime _history)
static void | main(java.lang.String[] arsgs)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressHistoryGenerator

public EPressHistoryGenerator(Channel _channel)

EPressHistoryGenerator

public EPressHistoryGenerator(Channel _channel,
                              boolean _zPubAction)
方法详细信息

generate

public void generate()
              throws WCMException
抛出：
WCMException

generate

public void generate(CMyDateTime _history)
              throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] arsgs)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressHistoryIndexWorker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressHistoryIndexWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.wcm.epress.EPressHistoryIndexWorker
所有已实现的接口：
org.quartz.Job
public class EPressHistoryIndexWorker
extends BaseScheduleWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
计划发布产生概览索引(当天的数据)
Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
EPressHistoryIndexWorker()
方法摘要
 void execute()
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressHistoryIndexWorker

public EPressHistoryIndexWorker()
方法详细信息

execute

public void execute()
             throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressHistoryPubLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressHistoryPubLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.components.wcm.epress.EPressHistoryPubLogger
所有已实现的接口：
ServiceExcuteLogger
public class EPressHistoryPubLogger
extends AbstractLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
发布历史索引日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
EPressHistoryPubLogger()
方法摘要
 int startLog(MethodConfig conf, MethodContext context)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressHistoryPubLogger

public EPressHistoryPubLogger()
方法详细信息

startLog

public int startLog(MethodConfig conf,
                    MethodContext context)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressImporter

java.lang.Object
    继承者  com.trs.components.wcm.epress.EPressImporter

public class EPressImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
电子报数据导入
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
EPressImporter()
方法摘要
void | importDocuments(java.lang.String _dataZipFile)
void | importDocuments(java.lang.String _dataZipFile, Channel _channel)
void | importDocuments(java.lang.String _dataZipFile, java.lang.String _epressKey)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressImporter

public EPressImporter()
方法详细信息

importDocuments

public void importDocuments(java.lang.String _dataZipFile)
                     throws WCMException
抛出：
WCMException

importDocuments

public void importDocuments(java.lang.String _dataZipFile,
                            Channel _channel)
                     throws WCMException
抛出：
WCMException

importDocuments

public void importDocuments(java.lang.String _dataZipFile,
                            java.lang.String _epressKey)
                     throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressServiceProvider

java.lang.Object
    继承者  com.trs.components.wcm.epress.EPressServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class EPressServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
电子报频道的相关ajax服务提供者
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
EPressServiceProvider()
方法摘要
boolean | checkUUID(MethodContext context)
int | createEPress(MethodContext context)
boolean | existsSimilarName(MethodContext context)
boolean | publishHistoryIndex(MethodContext context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressServiceProvider

public EPressServiceProvider()
方法详细信息

existsSimilarName

public boolean existsSimilarName(MethodContext context)
                          throws java.lang.Throwable
抛出：
java.lang.Throwable

checkUUID

public boolean checkUUID(MethodContext context)
                  throws java.lang.Throwable
抛出：
java.lang.Throwable

createEPress

public int createEPress(MethodContext context)
                 throws java.lang.Throwable
抛出：
java.lang.Throwable

publishHistoryIndex

public boolean publishHistoryIndex(MethodContext context)
                            throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressSoapService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressSoapService

java.lang.Object
    继承者  com.trs.components.wcm.epress.EPressSoapService

public class EPressSoapService
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
EPressSoapService()
方法摘要
java.lang.String | getEPressChannels()
java.lang.String | importEPressData(byte[] data, java.lang.String uuid)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressSoapService

public EPressSoapService()
方法详细信息

importEPressData

public java.lang.String importEPressData(byte[] data,
                                         java.lang.String uuid)

getEPressChannels

public java.lang.String getEPressChannels()

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EPressXPlusImporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 EPressXPlusImporter

java.lang.Object
    继承者  com.trs.components.wcm.epress.EPressXPlusImporter

public class EPressXPlusImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
XPlus数据文件导入
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
EPressXPlusImporter()
方法摘要
void | importFromXPlus(java.lang.String _zipData, java.lang.String _tcf, Channel _channel)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EPressXPlusImporter

public EPressXPlusImporter()
方法详细信息

importFromXPlus

public void importFromXPlus(java.lang.String _zipData,
                            java.lang.String _tcf,
                            Channel _channel)
                     throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.epress
类
ChannelLCListener4EPress
DocumentLCListener4EPress
EPressChannelCreateLogger
EPressChannelWrapper
EPressConf
EpressFolderWrapper
EPressHistoryGenerator
EPressHistoryIndexWorker
EPressHistoryPubLogger
EPressImporter
EPressServiceProvider
EPressSoapService
EPressXPlusImporter
TagEBookDirParser
TagMapAreaParser
TagParserPageNav
TagPreNextParser
WCMTagParserEPressNews
WCMTagParserExpertNews


com.trs.components.wcm.epress

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.epress

类摘要
ChannelLCListener4EPress | Title: TRS 内容协作平台（TRS WCM） Description: 栏目删除监听 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocumentLCListener4EPress | Title: TRS 内容协作平台（TRS WCM） Description: 修改重发相应的历史索引 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
EPressChannelCreateLogger | Title: TRS 内容协作平台（TRS WCM） Description: 创建电子报栏目日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
EPressChannelWrapper | Title: TRS 内容协作平台（TRS WCM） Description: 栏目包装 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressConf | Title: TRS 内容协作平台（TRS WCM） Description: 电子报相关配置 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EpressFolderWrapper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressHistoryGenerator | Title: TRS 内容协作平台（TRS WCM） Description: 电子报历史数据概览索引产生者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressHistoryIndexWorker | Title: TRS 内容协作平台（TRS WCM） Description: 计划发布产生概览索引(当天的数据) Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressHistoryPubLogger | Title: TRS 内容协作平台（TRS WCM） Description: 发布历史索引日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
EPressImporter | Title: TRS 内容协作平台（TRS WCM） Description: 电子报数据导入 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 电子报频道的相关ajax服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressSoapService | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressXPlusImporter | Title: TRS 内容协作平台（TRS WCM） Description: XPlus数据文件导入 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
TagEBookDirParser | Title: TRS 内容协作平台（TRS WCM） Description: 电子书目录置标(地方志等) Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
TagMapAreaParser | Title: TRS 内容协作平台（TRS WCM） Description: 生成电子报map area相关信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserPageNav | Title: TRS 内容协作平台（TRS WCM） Description: 分页置标 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
TagPreNextParser | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WCMTagParserEPressNews | Title: TRS 内容协作平台（TRS WCM） Description: 电子报版面图 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserExpertNews |


com.trs.components.wcm.epress 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.epress 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.AbstractLogger (implements com.trs.webframework.ServiceExcuteLogger)
      • com.trs.components.wcm.epress.EPressChannelCreateLogger
      • com.trs.components.wcm.epress.EPressHistoryPubLogger
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.components.common.job.BaseScheduleWorker
        • com.trs.components.wcm.epress.EPressHistoryIndexWorker
    • com.trs.components.wcm.epress.ChannelLCListener4EPress (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.components.wcm.epress.DocumentLCListener4EPress (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.epress.EPressChannelWrapper
    • com.trs.components.wcm.epress.EPressConf
    • com.trs.components.wcm.epress.EPressHistoryGenerator
    • com.trs.components.wcm.epress.EPressImporter
    • com.trs.components.wcm.epress.EPressServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.components.wcm.epress.EPressSoapService
    • com.trs.components.wcm.epress.EPressXPlusImporter
    • com.trs.components.common.publish.persistent.element.PublishFolderImplBase (implements com.trs.components.common.publish.persistent.element.IPublishFolder)
      • com.trs.components.wcm.publish.element.PublishFolderChannelImpl
        • com.trs.components.wcm.epress.EpressFolderWrapper (implements com.trs.components.common.publish.persistent.element.IPublishFolder)
    • com.trs.components.wcm.epress.TagEBookDirParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.epress.TagMapAreaParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.epress.TagParserPageNav (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.epress.TagPreNextParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
          • com.trs.components.wcm.epress.WCMTagParserEPressNews
          • com.trs.components.wcm.epress.WCMTagParserExpertNews


软件包 com.trs.components.wcm.epress 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.epress
的使用

使用 com.trs.components.wcm.epress 的软件包
com.trs.components.wcm.epress

com.trs.components.wcm.epress 使用的 com.trs.components.wcm.epress 中的类
EPressConf
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报相关配置
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TagEBookDirParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 TagEBookDirParser

java.lang.Object
    继承者  com.trs.components.wcm.epress.TagEBookDirParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagEBookDirParser
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
电子书目录置标(地方志等)
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
TagEBookDirParser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
static void | main(java.lang.String[] args)
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagEBookDirParser

public TagEBookDirParser()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagMapAreaParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 TagMapAreaParser

java.lang.Object
    继承者  com.trs.components.wcm.epress.TagMapAreaParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagMapAreaParser
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
生成电子报map area相关信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TagMapAreaParser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
static void | main(java.lang.String[] args)
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagMapAreaParser

public TagMapAreaParser()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserPageNav

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 TagParserPageNav

java.lang.Object
    继承者  com.trs.components.wcm.epress.TagParserPageNav
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserPageNav
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
分页置标
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
TagParserPageNav()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserPageNav

public TagParserPageNav()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagPreNextParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 TagPreNextParser

java.lang.Object
    继承者  com.trs.components.wcm.epress.TagPreNextParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagPreNextParser
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
TagPreNextParser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagPreNextParser

public TagPreNextParser()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserEPressNews

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 WCMTagParserEPressNews

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
                继承者  com.trs.components.wcm.epress.WCMTagParserEPressNews
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserEPressNews
extends WCMTagParserDocuments

Title: TRS 内容协作平台（TRS WCM）
Description:
电子报版面图
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserEPressNews()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
static void | main(java.lang.String[] args)
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 继承的方法
clear, getDelegatedContext, getNextRecordContext, getRecordSize, parse, parseAutoMore, setStartPos, substantiateContext
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
analyzeQuotes, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserEPressNews

public WCMTagParserEPressNews()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 WCMTagParserDocuments 中的 getBeanInfo
返回：
置标解析器的自我描述

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserExpertNews

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.epress
类 WCMTagParserExpertNews

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
                继承者  com.trs.components.wcm.epress.WCMTagParserExpertNews
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserExpertNews
extends WCMTagParserDocuments

构造方法摘要
WCMTagParserExpertNews()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 继承的方法
clear, getDelegatedContext, getNextRecordContext, getRecordSize, parse, parseAutoMore, setStartPos, substantiateContext
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
analyzeQuotes, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserExpertNews

public WCMTagParserExpertNews()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 WCMTagParserDocuments 中的 getBeanInfo
返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.epress.ChannelLCListener4EPress 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.ChannelLCListener4EPress
的使用

没有 com.trs.components.wcm.epress.ChannelLCListener4EPress 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.DocumentLCListener4EPress 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.DocumentLCListener4EPress
的使用

没有 com.trs.components.wcm.epress.DocumentLCListener4EPress 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressChannelCreateLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressChannelCreateLogger
的使用

没有 com.trs.components.wcm.epress.EPressChannelCreateLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressChannelWrapper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressChannelWrapper
的使用

没有 com.trs.components.wcm.epress.EPressChannelWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressConf 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressConf
的使用

使用 EPressConf 的软件包
com.trs.components.wcm.epress

com.trs.components.wcm.epress 中 EPressConf 的使用

返回 EPressConf 的 com.trs.components.wcm.epress 中的方法
static EPressConf EPressConf.instance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EpressFolderWrapper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EpressFolderWrapper
的使用

没有 com.trs.components.wcm.epress.EpressFolderWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressHistoryGenerator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressHistoryGenerator
的使用

没有 com.trs.components.wcm.epress.EPressHistoryGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressHistoryIndexWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressHistoryIndexWorker
的使用

没有 com.trs.components.wcm.epress.EPressHistoryIndexWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressHistoryPubLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressHistoryPubLogger
的使用

没有 com.trs.components.wcm.epress.EPressHistoryPubLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressImporter
的使用

没有 com.trs.components.wcm.epress.EPressImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressServiceProvider
的使用

没有 com.trs.components.wcm.epress.EPressServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressSoapService 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressSoapService
的使用

没有 com.trs.components.wcm.epress.EPressSoapService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.EPressXPlusImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.EPressXPlusImporter
的使用

没有 com.trs.components.wcm.epress.EPressXPlusImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.TagEBookDirParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.TagEBookDirParser
的使用

没有 com.trs.components.wcm.epress.TagEBookDirParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.TagMapAreaParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.TagMapAreaParser
的使用

没有 com.trs.components.wcm.epress.TagMapAreaParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.TagParserPageNav 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.TagParserPageNav
的使用

没有 com.trs.components.wcm.epress.TagParserPageNav 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.TagPreNextParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.TagPreNextParser
的使用

没有 com.trs.components.wcm.epress.TagPreNextParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.WCMTagParserEPressNews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.WCMTagParserEPressNews
的使用

没有 com.trs.components.wcm.epress.WCMTagParserEPressNews 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.epress.WCMTagParserExpertNews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.epress.WCMTagParserExpertNews
的使用

没有 com.trs.components.wcm.epress.WCMTagParserExpertNews 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CustomSiteCheckedInfo

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.individuation
类 CustomSiteCheckedInfo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.individuation.CustomSiteCheckedInfo
所有已实现的接口：
java.lang.Cloneable
public class CustomSiteCheckedInfo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
CustomSiteCheckedInfo()
构造函数：保留默认接口
方法摘要
static CustomSiteCheckedInfo | findById(int _nId) 提取指定ID的对象
int | getCheckedUserId() 提取属性：CheckedUser
static CustomSiteCheckedInfo | getCustomSiteCheckInfo(int individuationId, User loginUser)
static CustomSiteCheckedInfos | getCustomSiteCheckInfoByIndividuationId(int individuationId, User loginUser)
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getIndividuationId() 提取属性：IndividuationId
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setCheckedUser(int _nCheckedUserId) 设置属性：CheckedUser
boolean | setIndividuationId(int _nIndividuationId) 设置属性：IndividuationId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

CustomSiteCheckedInfo

public CustomSiteCheckedInfo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getIndividuationId

public int getIndividuationId()
提取属性：IndividuationId

返回：
IndividuationId

setIndividuationId

public boolean setIndividuationId(int _nIndividuationId)
                           throws WCMException
设置属性：IndividuationId

参数：
_nIndividuationId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCheckedUserId

public int getCheckedUserId()
提取属性：CheckedUser

返回：
CheckedUser

setCheckedUser

public boolean setCheckedUser(int _nCheckedUserId)
                       throws WCMException
设置属性：CheckedUser

参数：
_nCheckedUserId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final CustomSiteCheckedInfo findById(int _nId)
                                            throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getCustomSiteCheckInfo

public static CustomSiteCheckedInfo getCustomSiteCheckInfo(int individuationId,
                                                           User loginUser)
                                                    throws WCMException
抛出：
WCMException

getCustomSiteCheckInfoByIndividuationId

public static CustomSiteCheckedInfos getCustomSiteCheckInfoByIndividuationId(int individuationId,
                                                                             User loginUser)
                                                                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CustomSiteCheckedInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.individuation
类 CustomSiteCheckedInfos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.individuation.CustomSiteCheckedInfos

public class CustomSiteCheckedInfos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
CustomSiteCheckedInfos(User _currUser)
构造函数
CustomSiteCheckedInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static CustomSiteCheckedInfos | createNewInstance(User _currUser) 产生当前集合对象[CustomSiteCheckedInfos]的实例
static CustomSiteCheckedInfos | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static CustomSiteCheckedInfos | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[CustomSiteCheckedInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CustomSiteCheckedInfos

public CustomSiteCheckedInfos(User _currUser)
构造函数

另请参见：
CustomSiteCheckedInfos( User _currUser, int _initCapacity, int _incCapacity );

CustomSiteCheckedInfos

public CustomSiteCheckedInfos(User _currUser,
                              int _initCapacity,
                              int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

createNewInstance

public static CustomSiteCheckedInfos createNewInstance(User _currUser)
产生当前集合对象[CustomSiteCheckedInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

findByIds

public static final CustomSiteCheckedInfos findByIds(User _currUser,
                                                     java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（CustomSiteCheckedInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final CustomSiteCheckedInfos openWCMObjs(User _currUser,
                                                       WCMFilter _filter)
                                                throws WCMException
通过指定一个Filter获取当前集合[CustomSiteCheckedInfos]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[CustomSiteCheckedInfos]
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Individuation

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.individuation
类 Individuation

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.individuation.Individuation
所有已实现的接口：
java.lang.Cloneable
public class Individuation
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Individuation()
构造函数：保留默认接口
方法摘要
static Individuation | createNewInstance() 产生当前对象[Individuation]的实例
static Individuation | findById(int _nId) 提取指定ID的对象
static Individuation | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 提取属性：Attribute
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getObjectIdsValue() 提取属性：ObjectIdsValue
java.lang.String | getParamName() 提取属性：ParamName
java.lang.String | getParamValue() 提取属性：ParamValue
int | getUserId() 提取属性：UserId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isIsChecked() 提取属性：IsChecked
boolean | isIsShared() 提取属性：IsChecked
boolean | isValid() 检验对象数据有效性
boolean | setAttribute(java.lang.String _sAttribute) 设置属性：Attribute
boolean | setIsChecked(boolean _bIsChecked) 设置属性：IsChecked
boolean | setIsShared(boolean _bIsShared) 设置属性：IsChecked
boolean | setObjectIdsValue(java.lang.String _sObjectIdsValue) 设置属性：ObjectIdsValue
boolean | setParamName(java.lang.String _sParamName) 设置属性：ParamName
boolean | setParamValue(java.lang.String _sParamValue) 设置属性：ParamValue
boolean | setUserId(int _nUserId) 设置属性：UserId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Individuation

public Individuation()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getUserId

public int getUserId()
提取属性：UserId

返回：
UserId

setUserId

public boolean setUserId(int _nUserId)
                  throws WCMException
设置属性：UserId

参数：
_nUserId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAttribute

public java.lang.String getAttribute()
提取属性：Attribute

覆盖：
类 BaseObj 中的 getAttribute
返回：
Attribute

setAttribute

public boolean setAttribute(java.lang.String _sAttribute)
                     throws WCMException
设置属性：Attribute

覆盖：
类 BaseObj 中的 setAttribute
参数：
_sAttribute - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getParamName

public java.lang.String getParamName()
提取属性：ParamName

返回：
ParamName

setParamName

public boolean setParamName(java.lang.String _sParamName)
                     throws WCMException
设置属性：ParamName

参数：
_sParamName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getParamValue

public java.lang.String getParamValue()
提取属性：ParamValue

返回：
ParamValue

setParamValue

public boolean setParamValue(java.lang.String _sParamValue)
                      throws WCMException
设置属性：ParamValue

参数：
_sParamValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjectIdsValue

public java.lang.String getObjectIdsValue()
提取属性：ObjectIdsValue

返回：
ObjectIdsValue

setObjectIdsValue

public boolean setObjectIdsValue(java.lang.String _sObjectIdsValue)
                          throws WCMException
设置属性：ObjectIdsValue

参数：
_sObjectIdsValue - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isIsChecked

public boolean isIsChecked()
提取属性：IsChecked

返回：
IsChecked

setIsShared

public boolean setIsShared(boolean _bIsShared)
                    throws WCMException
设置属性：IsChecked

参数：
_bIsChecked - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isIsShared

public boolean isIsShared()
提取属性：IsChecked

返回：
IsChecked

setIsChecked

public boolean setIsChecked(boolean _bIsChecked)
                     throws WCMException
设置属性：IsChecked

参数：
_bIsChecked - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final Individuation findById(int _nId)
                                    throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Individuation createNewInstance()
                                             throws WCMException
产生当前对象[Individuation]的实例

返回：
当前对象的实例[Individuation]
抛出：
WCMException

findByKey

public static final Individuation findByKey(java.lang.Object _oKey)
                                     throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndividuationMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.individuation
类 IndividuationMgr

java.lang.Object
    继承者  com.trs.components.wcm.individuation.IndividuationMgr

public class IndividuationMgr
extends java.lang.Object

构造方法摘要
IndividuationMgr()
方法摘要
Individuations | getLoginUserIndividuationConfigs(java.lang.String[] paramNames, boolean isInclude)
java.lang.String | getObjectIdsAsString(int objType) 得到当前登陆用户的自定义站点或栏目id字符串序列
java.util.Hashtable | getObjectIdsHashtable(int objType) 得到当前登陆用户的自定义站点或栏目id的Hasttable对象(key:objectId,value:true)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IndividuationMgr

public IndividuationMgr()
方法详细信息

getLoginUserIndividuationConfigs

public Individuations getLoginUserIndividuationConfigs(java.lang.String[] paramNames,
                                                       boolean isInclude)
                                                throws WCMException
参数：
paramNames - 需要排除或包含的自定义变量名称
isInclude - true表示包含，false表示排除
返回：
抛出：
WCMException

getObjectIdsAsString

public java.lang.String getObjectIdsAsString(int objType)
                                      throws java.lang.Exception
得到当前登陆用户的自定义站点或栏目id字符串序列

参数：
objType - WCMTypes常量，如：WCMTypes.OBJ_CHANNEL,WCMTypes.OBJ_WEBSITE
返回：
当前登陆用户的自定义站点/栏目id的String对象
抛出：
java.lang.Exception

getObjectIdsHashtable

public java.util.Hashtable getObjectIdsHashtable(int objType)
                                          throws java.lang.Exception
得到当前登陆用户的自定义站点或栏目id的Hasttable对象(key:objectId,value:true)

参数：
objType - CMTypes常量，如：WCMTypes.OBJ_CHANNEL,WCMTypes.OBJ_WEBSITE
返回：
当前登陆用户的自定义站点/栏目id的Hasttable对象
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Individuations

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.individuation
类 Individuations

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.individuation.Individuations

public class Individuations
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Individuations(User _currUser)
构造函数
Individuations(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Individuations | createNewInstance(User _currUser) 产生当前集合对象[Individuations]的实例
static Individuations | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Individuations | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Individuations]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Individuations

public Individuations(User _currUser)
构造函数

另请参见：
Individuations( User _currUser, int _initCapacity, int _incCapacity );

Individuations

public Individuations(User _currUser,
                      int _initCapacity,
                      int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final Individuations findByIds(User _currUser,
                                             java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Individuations）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Individuations openWCMObjs(User _currUser,
                                               WCMFilter _filter)
                                        throws WCMException
通过指定一个Filter获取当前集合[Individuations]

参数：
_filter - 指定的Filter
返回：
当前集合[Individuations]
抛出：
WCMException

createNewInstance

public static Individuations createNewInstance(User _currUser)
产生当前集合对象[Individuations]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.individuation
类
CustomSiteCheckedInfo
CustomSiteCheckedInfos
Individuation
IndividuationMgr
Individuations


com.trs.components.wcm.individuation

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.individuation

类摘要
CustomSiteCheckedInfo
CustomSiteCheckedInfos
Individuation
IndividuationMgr
Individuations


com.trs.components.wcm.individuation 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.individuation 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.individuation.CustomSiteCheckedInfo
        • com.trs.components.wcm.individuation.Individuation
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.individuation.CustomSiteCheckedInfos
        • com.trs.components.wcm.individuation.Individuations
    • com.trs.components.wcm.individuation.IndividuationMgr


软件包 com.trs.components.wcm.individuation 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.individuation
的使用

使用 com.trs.components.wcm.individuation 的软件包
com.trs.components.wcm.individuation

com.trs.components.wcm.individuation 使用的 com.trs.components.wcm.individuation 中的类
CustomSiteCheckedInfo
CustomSiteCheckedInfos
Individuation
Individuations

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo
的使用

使用 CustomSiteCheckedInfo 的软件包
com.trs.components.wcm.individuation

com.trs.components.wcm.individuation 中 CustomSiteCheckedInfo 的使用

返回 CustomSiteCheckedInfo 的 com.trs.components.wcm.individuation 中的方法
static CustomSiteCheckedInfo | CustomSiteCheckedInfo.findById(int _nId) 提取指定ID的对象
static CustomSiteCheckedInfo | CustomSiteCheckedInfo.getCustomSiteCheckInfo(int individuationId, User loginUser)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos
的使用

使用 CustomSiteCheckedInfos 的软件包
com.trs.components.wcm.individuation

com.trs.components.wcm.individuation 中 CustomSiteCheckedInfos 的使用

返回 CustomSiteCheckedInfos 的 com.trs.components.wcm.individuation 中的方法
static CustomSiteCheckedInfos | CustomSiteCheckedInfos.createNewInstance(User _currUser) 产生当前集合对象[CustomSiteCheckedInfos]的实例
static CustomSiteCheckedInfos | CustomSiteCheckedInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static CustomSiteCheckedInfos | CustomSiteCheckedInfo.getCustomSiteCheckInfoByIndividuationId(int individuationId, User loginUser)
static CustomSiteCheckedInfos | CustomSiteCheckedInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[CustomSiteCheckedInfos]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.individuation.Individuation 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.individuation.Individuation
的使用

使用 Individuation 的软件包
com.trs.components.wcm.individuation

com.trs.components.wcm.individuation 中 Individuation 的使用

返回 Individuation 的 com.trs.components.wcm.individuation 中的方法
static Individuation | Individuation.createNewInstance() 产生当前对象[Individuation]的实例
static Individuation | Individuation.findById(int _nId) 提取指定ID的对象
static Individuation | Individuation.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.individuation.IndividuationMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.individuation.IndividuationMgr
的使用

没有 com.trs.components.wcm.individuation.IndividuationMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.individuation.Individuations 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.individuation.Individuations
的使用

使用 Individuations 的软件包
com.trs.components.wcm.individuation

com.trs.components.wcm.individuation 中 Individuations 的使用

返回 Individuations 的 com.trs.components.wcm.individuation 中的方法
static Individuations | Individuations.createNewInstance(User _currUser) 产生当前集合对象[Individuations]的实例
static Individuations | Individuations.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
Individuations | IndividuationMgr.getLoginUserIndividuationConfigs(java.lang.String[] paramNames, boolean isInclude)
static Individuations | Individuations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Individuations]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChannelLogger

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 ChannelLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.ChannelLogger
所有已实现的接口：
IObjLogger
public class ChannelLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
栏目对象操作日志记录者
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ChannelLogger()
方法摘要
 int getLogObjType()
获取该日志是记录那个对象的
从类 com.trs.cms.logger.ObjLoggerBase 继承的方法
makeLogOnAdd, makeLogOnDel, makeLogOnModify
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelLogger

public ChannelLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChnlDocLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 ChnlDocLogger

java.lang.Object
    继承者  com.trs.components.wcm.logger.ChnlDocLogger
所有已实现的接口：
IObjLogger
public class ChnlDocLogger
extends java.lang.Object
implements IObjLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
chnldoc日志记录(主要是记录顺序变更)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ChnlDocLogger()
方法摘要
int | getLogObjType() 获取该日志是记录那个对象的
LogInfo | makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocLogger

public ChnlDocLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()

makeLogOnAdd

public LogInfo makeLogOnAdd(BaseObj newobj)
从接口 IObjLogger 复制的描述
根据指定的对象构造新增日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnAdd
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnDel

public LogInfo makeLogOnDel(BaseObj objdeleted)
从接口 IObjLogger 复制的描述
根据指定的对象构造删除日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnDel
参数：
objdeleted - 删除的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnModify

public LogInfo makeLogOnModify(BaseObj objmodified)
从接口 IObjLogger 复制的描述
根据指定的对象构造修改日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnModify
参数：
objmodified - 修改的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 ConfigLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.ConfigLogger
所有已实现的接口：
IObjLogger
public class ConfigLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
系统配置修改日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ConfigLogger()
方法摘要
int | getLogObjType() 获取该日志是记录那个对象的
LogInfo | makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConfigLogger

public ConfigLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()

makeLogOnAdd

public LogInfo makeLogOnAdd(BaseObj newobj)
从接口 IObjLogger 复制的描述
根据指定的对象构造新增日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnAdd
覆盖：
类 ObjLoggerBase 中的 makeLogOnAdd
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnDel

public LogInfo makeLogOnDel(BaseObj objdeleted)
从接口 IObjLogger 复制的描述
根据指定的对象构造删除日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnDel
覆盖：
类 ObjLoggerBase 中的 makeLogOnDel
参数：
objdeleted - 删除的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnModify

public LogInfo makeLogOnModify(BaseObj objmodified)
从接口 IObjLogger 复制的描述
根据指定的对象构造修改日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnModify
覆盖：
类 ObjLoggerBase 中的 makeLogOnModify
参数：
objmodified - 修改的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 DocumentLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.DocumentLogger
所有已实现的接口：
IObjLogger
public class DocumentLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
文档对象日志记录者
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
DocumentLogger()
方法摘要
 int getLogObjType()
获取该日志是记录那个对象的
从类 com.trs.cms.logger.ObjLoggerBase 继承的方法
makeLogOnAdd, makeLogOnDel, makeLogOnModify
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLogger

public DocumentLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowEmployLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 FlowEmployLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.FlowEmployLogger
所有已实现的接口：
IObjLogger
public class FlowEmployLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
工件流分配日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
FlowEmployLogger()
方法摘要
int | getLogObjType() 获取该日志是记录那个对象的
LogInfo | makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowEmployLogger

public FlowEmployLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()

makeLogOnAdd

public LogInfo makeLogOnAdd(BaseObj newobj)
从接口 IObjLogger 复制的描述
根据指定的对象构造新增日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnAdd
覆盖：
类 ObjLoggerBase 中的 makeLogOnAdd
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnDel

public LogInfo makeLogOnDel(BaseObj objdeleted)
从接口 IObjLogger 复制的描述
根据指定的对象构造删除日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnDel
覆盖：
类 ObjLoggerBase 中的 makeLogOnDel
参数：
objdeleted - 删除的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnModify

public LogInfo makeLogOnModify(BaseObj objmodified)
从接口 IObjLogger 复制的描述
根据指定的对象构造修改日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnModify
覆盖：
类 ObjLoggerBase 中的 makeLogOnModify
参数：
objmodified - 修改的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FolderPublishConfigLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 FolderPublishConfigLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.FolderPublishConfigLogger
所有已实现的接口：
IObjLogger
public class FolderPublishConfigLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
FolderPublishConfigLogger()
方法摘要
 int getLogObjType()
获取该日志是记录那个对象的
从类 com.trs.cms.logger.ObjLoggerBase 继承的方法
makeLogOnAdd, makeLogOnDel, makeLogOnModify
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FolderPublishConfigLogger

public FolderPublishConfigLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.logger
类
ChannelLogger
ChnlDocLogger
ConfigLogger
DocumentLogger
FlowEmployLogger
FolderPublishConfigLogger
RegionCellInfoLogger
RegionInfoLogger
ScheduleLogger
TemplateEmployLogger
TemplateLogger
WebSiteLogger


com.trs.components.wcm.logger

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.logger

类摘要
ChannelLogger | Title: TRS 内容协作平台（TRS WCM） Description: 栏目对象操作日志记录者 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ChnlDocLogger | Title: TRS 内容协作平台（TRS WCM） Description: chnldoc日志记录(主要是记录顺序变更) Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ConfigLogger | Title: TRS 内容协作平台（TRS WCM） Description: 系统配置修改日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocumentLogger | Title: TRS 内容协作平台（TRS WCM） Description: 文档对象日志记录者 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FlowEmployLogger | Title: TRS 内容协作平台（TRS WCM） Description: 工件流分配日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FolderPublishConfigLogger | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
RegionCellInfoLogger |
RegionInfoLogger |
ScheduleLogger | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TemplateEmployLogger | Title: TRS 内容协作平台（TRS WCM） Description: 模板配置日志记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TemplateLogger | Title: TRS 内容协作平台（TRS WCM） Description: 模板日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
WebSiteLogger | Title: TRS 内容协作平台（TRS WCM） Description: 站点日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)


com.trs.components.wcm.logger 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.logger 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.logger.ChnlDocLogger (implements com.trs.cms.logger.IObjLogger)
    • com.trs.cms.logger.ObjLoggerBase (implements com.trs.cms.logger.IObjLogger)
      • com.trs.components.wcm.logger.ChannelLogger
      • com.trs.components.wcm.logger.ConfigLogger
      • com.trs.components.wcm.logger.DocumentLogger
      • com.trs.components.wcm.logger.FlowEmployLogger
      • com.trs.components.wcm.logger.FolderPublishConfigLogger
      • com.trs.components.wcm.logger.RegionCellInfoLogger
      • com.trs.components.wcm.logger.RegionInfoLogger
      • com.trs.components.wcm.logger.ScheduleLogger
      • com.trs.components.wcm.logger.TemplateEmployLogger
      • com.trs.components.wcm.logger.TemplateLogger
      • com.trs.components.wcm.logger.WebSiteLogger


软件包 com.trs.components.wcm.logger 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.logger
的使用

没有 com.trs.components.wcm.logger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RegionCellInfoLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 RegionCellInfoLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.RegionCellInfoLogger
所有已实现的接口：
IObjLogger
public class RegionCellInfoLogger
extends ObjLoggerBase

构造方法摘要
RegionCellInfoLogger()
方法摘要
int | getLogObjType() 获取该日志是记录那个对象的
LogInfo | makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RegionCellInfoLogger

public RegionCellInfoLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()

makeLogOnAdd

public LogInfo makeLogOnAdd(BaseObj newobj)
从接口 IObjLogger 复制的描述
根据指定的对象构造新增日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnAdd
覆盖：
类 ObjLoggerBase 中的 makeLogOnAdd
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnDel

public LogInfo makeLogOnDel(BaseObj objdeleted)
从接口 IObjLogger 复制的描述
根据指定的对象构造删除日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnDel
覆盖：
类 ObjLoggerBase 中的 makeLogOnDel
参数：
objdeleted - 删除的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnModify

public LogInfo makeLogOnModify(BaseObj objmodified)
从接口 IObjLogger 复制的描述
根据指定的对象构造修改日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnModify
覆盖：
类 ObjLoggerBase 中的 makeLogOnModify
参数：
objmodified - 修改的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegionInfoLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 RegionInfoLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.RegionInfoLogger
所有已实现的接口：
IObjLogger
public class RegionInfoLogger
extends ObjLoggerBase

构造方法摘要
RegionInfoLogger()
方法摘要
 int getLogObjType()
获取该日志是记录那个对象的
从类 com.trs.cms.logger.ObjLoggerBase 继承的方法
makeLogOnAdd, makeLogOnDel, makeLogOnModify
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RegionInfoLogger

public RegionInfoLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScheduleLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 ScheduleLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.ScheduleLogger
所有已实现的接口：
IObjLogger
public class ScheduleLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ScheduleLogger()
方法摘要
 int getLogObjType()
获取该日志是记录那个对象的
从类 com.trs.cms.logger.ObjLoggerBase 继承的方法
makeLogOnAdd, makeLogOnDel, makeLogOnModify
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScheduleLogger

public ScheduleLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateEmployLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 TemplateEmployLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.TemplateEmployLogger
所有已实现的接口：
IObjLogger
public class TemplateEmployLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
模板配置日志记录
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TemplateEmployLogger()
方法摘要
int | getLogObjType() 获取该日志是记录那个对象的
LogInfo | makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateEmployLogger

public TemplateEmployLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()

makeLogOnAdd

public LogInfo makeLogOnAdd(BaseObj newobj)
从接口 IObjLogger 复制的描述
根据指定的对象构造新增日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnAdd
覆盖：
类 ObjLoggerBase 中的 makeLogOnAdd
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnDel

public LogInfo makeLogOnDel(BaseObj objdeleted)
从接口 IObjLogger 复制的描述
根据指定的对象构造删除日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnDel
覆盖：
类 ObjLoggerBase 中的 makeLogOnDel
参数：
objdeleted - 删除的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null

makeLogOnModify

public LogInfo makeLogOnModify(BaseObj objmodified)
从接口 IObjLogger 复制的描述
根据指定的对象构造修改日志说明记录

指定者：
接口 IObjLogger 中的 makeLogOnModify
覆盖：
类 ObjLoggerBase 中的 makeLogOnModify
参数：
objmodified - 修改的对象
返回：
日志信息描述对象,如果不需要记录日志则返回null
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 TemplateLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.TemplateLogger
所有已实现的接口：
IObjLogger
public class TemplateLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
模板日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TemplateLogger()
方法摘要
 int getLogObjType()
获取该日志是记录那个对象的
从类 com.trs.cms.logger.ObjLoggerBase 继承的方法
makeLogOnAdd, makeLogOnDel, makeLogOnModify
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateLogger

public TemplateLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteLogger

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.logger
类 WebSiteLogger

java.lang.Object
    继承者  com.trs.cms.logger.ObjLoggerBase
        继承者  com.trs.components.wcm.logger.WebSiteLogger
所有已实现的接口：
IObjLogger
public class WebSiteLogger
extends ObjLoggerBase

Title: TRS 内容协作平台（TRS WCM）
Description:
站点日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
WebSiteLogger()
方法摘要
 int getLogObjType()
获取该日志是记录那个对象的
从类 com.trs.cms.logger.ObjLoggerBase 继承的方法
makeLogOnAdd, makeLogOnDel, makeLogOnModify
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteLogger

public WebSiteLogger()
方法详细信息

getLogObjType

public int getLogObjType()
从接口 IObjLogger 复制的描述
获取该日志是记录那个对象的

指定者：
接口 IObjLogger 中的 getLogObjType
指定者：
类 ObjLoggerBase 中的 getLogObjType
返回：
对象的类型标识值

实现注意:该方法应该固定返回所负责记录对象的类型标识,应该与 BaseObj.getWCMType() 返回结果保持一致

另请参见：
BaseObj.getWCMType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.logger.ChannelLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.ChannelLogger
的使用

没有 com.trs.components.wcm.logger.ChannelLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.ChnlDocLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.ChnlDocLogger
的使用

没有 com.trs.components.wcm.logger.ChnlDocLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.ConfigLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.ConfigLogger
的使用

没有 com.trs.components.wcm.logger.ConfigLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.DocumentLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.DocumentLogger
的使用

没有 com.trs.components.wcm.logger.DocumentLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.FlowEmployLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.FlowEmployLogger
的使用

没有 com.trs.components.wcm.logger.FlowEmployLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.FolderPublishConfigLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.FolderPublishConfigLogger
的使用

没有 com.trs.components.wcm.logger.FolderPublishConfigLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.RegionCellInfoLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.RegionCellInfoLogger
的使用

没有 com.trs.components.wcm.logger.RegionCellInfoLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.RegionInfoLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.RegionInfoLogger
的使用

没有 com.trs.components.wcm.logger.RegionInfoLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.ScheduleLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.ScheduleLogger
的使用

没有 com.trs.components.wcm.logger.ScheduleLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.TemplateEmployLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.TemplateEmployLogger
的使用

没有 com.trs.components.wcm.logger.TemplateEmployLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.TemplateLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.TemplateLogger
的使用

没有 com.trs.components.wcm.logger.TemplateLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.logger.WebSiteLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.logger.WebSiteLogger
的使用

没有 com.trs.components.wcm.logger.WebSiteLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DataFromNewshoo

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.newshoo
类 DataFromNewshoo

java.lang.Object
    继承者  com.trs.components.wcm.newshoo.DataFromNewshoo

public class DataFromNewshoo
extends java.lang.Object

Title: 网站内容管理（TRSWCM）

Description:

Copyright: Copyright (c) 2001

Company: www.trs.com.cn

版本：
1.0
作者：
not attributable

构造方法摘要
DataFromNewshoo()
方法摘要
java.lang.String | getTempFileName(java.lang.String Server, java.lang.String fileExt)
java.lang.String | importData(java.lang.String inBytes, java.lang.String Server)
static void | main(java.lang.String[] args)
static void | testNewsHoo()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataFromNewshoo

public DataFromNewshoo()
方法详细信息

getTempFileName

public java.lang.String getTempFileName(java.lang.String Server,
                                        java.lang.String fileExt)

importData

public java.lang.String importData(java.lang.String inBytes,
                                   java.lang.String Server)

main

public static void main(java.lang.String[] args)

testNewsHoo

public static void testNewsHoo()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DataFromRadar

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.newshoo
类 DataFromRadar

java.lang.Object
    继承者  com.trs.components.wcm.newshoo.DataFromRadar

public class DataFromRadar
extends java.lang.Object

构造方法摘要
DataFromRadar()
方法摘要
java.lang.String | getChannelXML(java.lang.String Server)
int | getMajorVersion()
java.lang.String | getTempFileName(java.lang.String Server, java.lang.String fileExt)
java.lang.String | importData(java.lang.String Server, java.lang.String Data)
java.lang.String | importData2(javax.activation.DataHandler dh, java.lang.String Server, java.lang.String fileExt)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataFromRadar

public DataFromRadar()
方法详细信息

getTempFileName

public java.lang.String getTempFileName(java.lang.String Server,
                                        java.lang.String fileExt)

importData2

public java.lang.String importData2(javax.activation.DataHandler dh,
                                    java.lang.String Server,
                                    java.lang.String fileExt)

importData

public java.lang.String importData(java.lang.String Server,
                                   java.lang.String Data)

getMajorVersion

public int getMajorVersion()

getChannelXML

public java.lang.String getChannelXML(java.lang.String Server)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataFromRadarClient

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.newshoo
类 DataFromRadarClient

java.lang.Object
    继承者  com.trs.components.wcm.newshoo.DataFromRadarClient

public class DataFromRadarClient
extends java.lang.Object

构造方法摘要
DataFromRadarClient()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataFromRadarClient

public DataFromRadarClient()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.newshoo
类
DataFromNewshoo
DataFromRadar
DataFromRadarClient


com.trs.components.wcm.newshoo

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.newshoo

类摘要
DataFromNewshoo | Title: 网站内容管理（TRSWCM） Description: Copyright: Copyright (c) 2001 Company: www.trs.com.cn
DataFromRadar |
DataFromRadarClient |


com.trs.components.wcm.newshoo 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.newshoo 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.newshoo.DataFromNewshoo
    • com.trs.components.wcm.newshoo.DataFromRadar
    • com.trs.components.wcm.newshoo.DataFromRadarClient


软件包 com.trs.components.wcm.newshoo 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.newshoo
的使用

没有 com.trs.components.wcm.newshoo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.newshoo.DataFromNewshoo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.newshoo.DataFromNewshoo
的使用

没有 com.trs.components.wcm.newshoo.DataFromNewshoo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.newshoo.DataFromRadar 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.newshoo.DataFromRadar
的使用

没有 com.trs.components.wcm.newshoo.DataFromRadar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.newshoo.DataFromRadarClient 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.newshoo.DataFromRadarClient
的使用

没有 com.trs.components.wcm.newshoo.DataFromRadarClient 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChannelLCListenerForFlow

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.process
类 ChannelLCListenerForFlow

java.lang.Object
    继承者  com.trs.components.wcm.process.ChannelLCListenerForFlow
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class ChannelLCListenerForFlow
extends java.lang.Object
implements IObjectLCListenerOnModify

在频道假删除（频道即如回收站）时，删除所有正在流转和已经流转结束的文档

作者：
Martin (付成睿)

构造方法摘要
ChannelLCListenerForFlow()
缺省构造方法
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelLCListenerForFlow

public ChannelLCListenerForFlow()
缺省构造方法

方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChnlDocLCListenerForFlow

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.process
类 ChnlDocLCListenerForFlow

java.lang.Object
    继承者  com.trs.components.wcm.process.ChnlDocLCListenerForFlow
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class ChnlDocLCListenerForFlow
extends java.lang.Object
implements IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChnlDocLCListenerForFlow()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocLCListenerForFlow

public ChnlDocLCListenerForFlow()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowEmployLCListenerForChange

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.process
类 FlowEmployLCListenerForChange

java.lang.Object
    继承者  com.trs.components.wcm.process.FlowEmployLCListenerForChange
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class FlowEmployLCListenerForChange
extends java.lang.Object
implements IObjectLCListenerOnModify

监听频道工作流设置的改变

作者：
Martin (付成睿)

构造方法摘要
FlowEmployLCListenerForChange()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowEmployLCListenerForChange

public FlowEmployLCListenerForChange()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowNotifyWorkerImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.process
类 FlowNotifyWorkerImpl

java.lang.Object
    继承者  com.trs.components.wcm.process.FlowNotifyWorkerImpl
所有已实现的接口：
IFlowNotifyWorker
public class FlowNotifyWorkerImpl
extends java.lang.Object
implements IFlowNotifyWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowNotifyWorkerImpl()
方法摘要
void | addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, int _nNotify)
void | addMsgEvent(User _currUser, Users _toUsers, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)
void | addMsgEvent(User _currUser, User _toUser, java.lang.String _sTitle, java.lang.String _sDesc, java.lang.String _sNotifyTypes)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowNotifyWorkerImpl

public FlowNotifyWorkerImpl()
方法详细信息

addMsgEvent

public void addMsgEvent(User _currUser,
                        Users _toUsers,
                        java.lang.String _sTitle,
                        java.lang.String _sDesc,
                        int _nNotify)
指定者：
接口 IFlowNotifyWorker 中的 addMsgEvent

addMsgEvent

public void addMsgEvent(User _currUser,
                        Users _toUsers,
                        java.lang.String _sTitle,
                        java.lang.String _sDesc,
                        java.lang.String _sNotifyTypes)
指定者：
接口 IFlowNotifyWorker 中的 addMsgEvent

addMsgEvent

public void addMsgEvent(User _currUser,
                        User _toUser,
                        java.lang.String _sTitle,
                        java.lang.String _sDesc,
                        java.lang.String _sNotifyTypes)
指定者：
接口 IFlowNotifyWorker 中的 addMsgEvent
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.process
类
ChannelLCListenerForFlow
ChnlDocLCListenerForFlow
FlowEmployLCListenerForChange
FlowNotifyWorkerImpl


com.trs.components.wcm.process

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.process

类摘要
ChannelLCListenerForFlow | 在频道假删除（频道即如回收站）时，删除所有正在流转和已经流转结束的文档
ChnlDocLCListenerForFlow | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowEmployLCListenerForChange | 监听频道工作流设置的改变
FlowNotifyWorkerImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm.process 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.process 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.process.ChannelLCListenerForFlow (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.process.ChnlDocLCListenerForFlow (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.process.FlowEmployLCListenerForChange (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.process.FlowNotifyWorkerImpl (implements com.trs.cms.process.IFlowNotifyWorker)


软件包 com.trs.components.wcm.process 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.process
的使用

没有 com.trs.components.wcm.process 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.process.ChannelLCListenerForFlow 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.process.ChannelLCListenerForFlow
的使用

没有 com.trs.components.wcm.process.ChannelLCListenerForFlow 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.process.ChnlDocLCListenerForFlow 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.process.ChnlDocLCListenerForFlow
的使用

没有 com.trs.components.wcm.process.ChnlDocLCListenerForFlow 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.process.FlowEmployLCListenerForChange 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.process.FlowEmployLCListenerForChange
的使用

没有 com.trs.components.wcm.process.FlowEmployLCListenerForChange 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.process.FlowNotifyWorkerImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.process.FlowNotifyWorkerImpl
的使用

没有 com.trs.components.wcm.process.FlowNotifyWorkerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FlowContentDocumentImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.process.element
类 FlowContentDocumentImpl

java.lang.Object
    继承者  com.trs.components.wcm.process.element.FlowContentDocumentImpl
所有已实现的接口：
ICMSObjSubstanceContent, IFlowContent
直接已知子类：
MyFlowContentDocumentImpl
public class FlowContentDocumentImpl
extends java.lang.Object
implements IFlowContent

Title: TRS 内容协作平台（TRS WCM）
Description:
Document的FlowContent的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FlowContentDocumentImpl()
FlowContentDocumentImpl(Document _currDocument)
FlowContentDocumentImpl(int _nId)
方法摘要
void | cancelUpdate(User user) 取消本次更新
boolean | canEdit(User _currUser) 判断当前操作用户是否可以对当前流转的内容进行修改
java.lang.String | getContentAddEditPage() 获取内容的编辑页面
java.lang.String | getContentShowPage() 获取内容的查看页面
int | getContentType() 获取当前流转内容的类型
User | getCrUser()
java.lang.String | getDeletePage()
java.lang.String | getDesc() 获取当前流转内容的简要描述
Document | getDocument()
FlowDoc | getFlowDoc() 获取FlowContent相关的FlowDoc
int | getId() Returns the publish content id.
java.lang.String | getInfo() Gets the information of the folder.
Flow | getOwnerFlow() 获取当前所属对象的工作流对象
java.lang.String | getProperty(java.lang.String _sName) 获取指定属性的名称
java.lang.String | getPublishPage()
long | getSerialNum() 获取内容被发起的SerialNum
CMyDateTime | getStartTime() 获取内容被发起的时间
java.lang.String | getStatusDesc() 获取状态的描述
int | getStatusId()
CMSObj | getSubinstance() 获取流转内容关联的对象
int | getSubinstanceId() 获取当前流转内容的ID
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isDeleted()
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setFlow(Flow flow)
void | setFlowDoc(FlowDoc _flowDoc) 设置FlowContent相关的FlowDoc
void | setSerialNum(long _lSerialNum) 设置内容被发起时候的SerialNum
void | setStartTime(CMyDateTime _dtStartTime) 设置内容被发起的时间
void | setSubinstance(CMSObj _subinstance)
void | setSubinstance(int _nSubinstanceId) 设置当前Content的关联ID
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | updateStatus(User user, int statusId) 更新当前内容的工作流状态
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowContentDocumentImpl

public FlowContentDocumentImpl(Document _currDocument)

FlowContentDocumentImpl

public FlowContentDocumentImpl(int _nId)

FlowContentDocumentImpl

public FlowContentDocumentImpl()
方法详细信息

getDocument

public Document getDocument()
                     throws WCMException
抛出：
WCMException

canEdit

public boolean canEdit(User _currUser)
                throws WCMException
从接口 IFlowContent 复制的描述
判断当前操作用户是否可以对当前流转的内容进行修改

指定者：
接口 IFlowContent 中的 canEdit
返回：
抛出：
WCMException

getOwnerFlow

public Flow getOwnerFlow()
                  throws WCMException
从接口 IFlowContent 复制的描述
获取当前所属对象的工作流对象

指定者：
接口 IFlowContent 中的 getOwnerFlow
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
                         throws WCMException
从接口 IFlowContent 复制的描述
获取当前流转内容的简要描述

指定者：
接口 IFlowContent 中的 getDesc
返回：
抛出：
WCMException

getContentType

public int getContentType()
从接口 IFlowContent 复制的描述
获取当前流转内容的类型

指定者：
接口 IFlowContent 中的 getContentType
返回：

getSubinstanceId

public int getSubinstanceId()
从接口 IFlowContent 复制的描述
获取当前流转内容的ID

指定者：
接口 IFlowContent 中的 getSubinstanceId
返回：

setSubinstance

public void setSubinstance(int _nSubinstanceId)
从接口 IFlowContent 复制的描述
设置当前Content的关联ID

指定者：
接口 IFlowContent 中的 setSubinstance
参数：
_nSubinstanceId - 新的ID（比如文档ID）

updateStatus

public void updateStatus(User user,
                         int statusId)
                  throws WCMException
从接口 IFlowContent 复制的描述
更新当前内容的工作流状态

指定者：
接口 IFlowContent 中的 updateStatus
抛出：
WCMException

cancelUpdate

public void cancelUpdate(User user)
                  throws WCMException
从接口 IFlowContent 复制的描述
取消本次更新

指定者：
接口 IFlowContent 中的 cancelUpdate
抛出：
WCMException

getCrUser

public User getCrUser()
               throws WCMException
指定者：
接口 IFlowContent 中的 getCrUser
返回：
抛出：
WCMException

getStatusId

public int getStatusId()
                throws WCMException
指定者：
接口 IFlowContent 中的 getStatusId
返回：
抛出：
WCMException

getStatusDesc

public java.lang.String getStatusDesc()
                               throws WCMException
从接口 IFlowContent 复制的描述
获取状态的描述

指定者：
接口 IFlowContent 中的 getStatusDesc
返回：
抛出：
WCMException

getSubinstance

public CMSObj getSubinstance()
                      throws WCMException
从接口 IFlowContent 复制的描述
获取流转内容关联的对象

指定者：
接口 IFlowContent 中的 getSubinstance
返回：
抛出：
WCMException

setSubinstance

public void setSubinstance(CMSObj _subinstance)
指定者：
接口 IFlowContent 中的 setSubinstance

getContentShowPage

public java.lang.String getContentShowPage()
                                    throws WCMException
从接口 IFlowContent 复制的描述
获取内容的查看页面

指定者：
接口 IFlowContent 中的 getContentShowPage
返回：
内容的查看页面
抛出：
WCMException

getContentAddEditPage

public java.lang.String getContentAddEditPage()
                                       throws WCMException
从接口 IFlowContent 复制的描述
获取内容的编辑页面

指定者：
接口 IFlowContent 中的 getContentAddEditPage
返回：
内容的编辑页面
抛出：
WCMException

getDeletePage

public java.lang.String getDeletePage()
                               throws WCMException
指定者：
接口 IFlowContent 中的 getDeletePage
抛出：
WCMException

getPublishPage

public java.lang.String getPublishPage()
                                throws WCMException
指定者：
接口 IFlowContent 中的 getPublishPage
抛出：
WCMException

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
返回：
the publish content id

getInfo

public java.lang.String getInfo()
从接口 ICMSObjSubstanceContent 复制的描述
Gets the information of the folder.

指定者：
接口 ICMSObjSubstanceContent 中的 getInfo
返回：
the information of the folder

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

指定者：
接口 ICMSObjSubstanceContent 中的 getSubstance
返回：
the substance object which is an instance of CMSObj

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

指定者：
接口 ICMSObjSubstanceContent 中的 getType
返回：
the publish content type

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

指定者：
接口 ICMSObjSubstanceContent 中的 loadById
参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException

makeFrom

public void makeFrom(CMSObj _cmsObj)
              throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

指定者：
接口 ICMSObjSubstanceContent 中的 makeFrom
参数：
_cmsObj - a CMS object
抛出：
WCMException - if the object is invalid or its type mismatchs.

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

指定者：
接口 ICMSObjSubstanceContent 中的 setSubstance
参数：
_cmsObj - a CMS object

getFlowDoc

public FlowDoc getFlowDoc()
从接口 IFlowContent 复制的描述
获取FlowContent相关的FlowDoc

指定者：
接口 IFlowContent 中的 getFlowDoc
返回：

setFlowDoc

public void setFlowDoc(FlowDoc _flowDoc)
从接口 IFlowContent 复制的描述
设置FlowContent相关的FlowDoc

指定者：
接口 IFlowContent 中的 setFlowDoc

getProperty

public java.lang.String getProperty(java.lang.String _sName)
从接口 IFlowContent 复制的描述
获取指定属性的名称

指定者：
接口 IFlowContent 中的 getProperty
返回：

getStartTime

public CMyDateTime getStartTime()
从接口 IFlowContent 复制的描述
获取内容被发起的时间

指定者：
接口 IFlowContent 中的 getStartTime
返回：

setStartTime

public void setStartTime(CMyDateTime _dtStartTime)
从接口 IFlowContent 复制的描述
设置内容被发起的时间

指定者：
接口 IFlowContent 中的 setStartTime

isDeleted

public boolean isDeleted()
指定者：
接口 IFlowContent 中的 isDeleted
返回：

getSerialNum

public long getSerialNum()
从接口 IFlowContent 复制的描述
获取内容被发起的SerialNum

指定者：
接口 IFlowContent 中的 getSerialNum
返回：

setSerialNum

public void setSerialNum(long _lSerialNum)
从接口 IFlowContent 复制的描述
设置内容被发起时候的SerialNum

指定者：
接口 IFlowContent 中的 setSerialNum

setFlow

public void setFlow(Flow flow)
指定者：
接口 IFlowContent 中的 setFlow
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MyFlowContentDocumentImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.process.element
类 MyFlowContentDocumentImpl

java.lang.Object
    继承者  com.trs.components.wcm.process.element.FlowContentDocumentImpl
        继承者  com.trs.components.wcm.process.element.MyFlowContentDocumentImpl
所有已实现的接口：
ICMSObjSubstanceContent, IFlowContent
public class MyFlowContentDocumentImpl
extends FlowContentDocumentImpl

构造方法摘要
MyFlowContentDocumentImpl()
MyFlowContentDocumentImpl(Document _currDocument)
MyFlowContentDocumentImpl(int _nId)
方法摘要
 java.lang.String getDesc()
获取当前流转内容的简要描述
从类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 继承的方法
cancelUpdate, canEdit, getContentAddEditPage, getContentShowPage, getContentType, getCrUser, getDeletePage, getDocument, getFlowDoc, getId, getInfo, getOwnerFlow, getProperty, getPublishPage, getSerialNum, getStartTime, getStatusDesc, getStatusId, getSubinstance, getSubinstanceId, getSubstance, getType, isDeleted, loadById, makeFrom, setFlow, setFlowDoc, setSerialNum, setStartTime, setSubinstance, setSubinstance, setSubstance, updateStatus
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MyFlowContentDocumentImpl

public MyFlowContentDocumentImpl(Document _currDocument)

MyFlowContentDocumentImpl

public MyFlowContentDocumentImpl(int _nId)

MyFlowContentDocumentImpl

public MyFlowContentDocumentImpl()
方法详细信息

getDesc

public java.lang.String getDesc()
                         throws WCMException
从接口 IFlowContent 复制的描述
获取当前流转内容的简要描述

指定者：
接口 IFlowContent 中的 getDesc
覆盖：
类 FlowContentDocumentImpl 中的 getDesc
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.process.element
类
FlowContentDocumentImpl
MyFlowContentDocumentImpl


com.trs.components.wcm.process.element

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.process.element

类摘要
FlowContentDocumentImpl | Title: TRS 内容协作平台（TRS WCM） Description: Document的FlowContent的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MyFlowContentDocumentImpl |


com.trs.components.wcm.process.element 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.process.element 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.process.element.FlowContentDocumentImpl (implements com.trs.cms.process.IFlowContent)
      • com.trs.components.wcm.process.element.MyFlowContentDocumentImpl


软件包 com.trs.components.wcm.process.element 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.process.element
的使用

使用 com.trs.components.wcm.process.element 的软件包
com.trs.components.wcm.process.element

com.trs.components.wcm.process.element 使用的 com.trs.components.wcm.process.element 中的类
FlowContentDocumentImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
Document的FlowContent的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.process.element.FlowContentDocumentImpl
的使用

使用 FlowContentDocumentImpl 的软件包
com.trs.components.wcm.process.element

com.trs.components.wcm.process.element 中 FlowContentDocumentImpl 的使用

com.trs.components.wcm.process.element 中 FlowContentDocumentImpl 的子类
 class MyFlowContentDocumentImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.process.element.MyFlowContentDocumentImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.process.element.MyFlowContentDocumentImpl
的使用

没有 com.trs.components.wcm.process.element.MyFlowContentDocumentImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FlowConverterForWebsiteImporter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.process.service.domain
类 FlowConverterForWebsiteImporter

java.lang.Object
    继承者  com.trs.components.wcm.process.service.domain.FlowConverterForWebsiteImporter
所有已实现的接口：
IChannelImporterConverter
public class FlowConverterForWebsiteImporter
extends java.lang.Object
implements IChannelImporterConverter

构造方法摘要
FlowConverterForWebsiteImporter()
方法摘要
 void registerConverter(java.lang.Object _args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowConverterForWebsiteImporter

public FlowConverterForWebsiteImporter()
方法详细信息

registerConverter

public void registerConverter(java.lang.Object _args)
指定者：
接口 IChannelImporterConverter 中的 registerConverter
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.process.service.domain
类
FlowConverterForWebsiteImporter


com.trs.components.wcm.process.service.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.process.service.domain

类摘要
FlowConverterForWebsiteImporter


com.trs.components.wcm.process.service.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.process.service.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.process.service.domain.FlowConverterForWebsiteImporter (implements com.trs.components.wcm.content.domain.IChannelImporterConverter)


软件包 com.trs.components.wcm.process.service.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.process.service.domain
的使用

没有 com.trs.components.wcm.process.service.domain 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.process.service.domain.FlowConverterForWebsiteImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.process.service.domain.FlowConverterForWebsiteImporter
的使用

没有 com.trs.components.wcm.process.service.domain.FlowConverterForWebsiteImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.wcm.process.service.flowexporter
类
SiteExporterForFlow


com.trs.components.wcm.process.service.flowexporter

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.process.service.flowexporter

类摘要
SiteExporterForFlow


com.trs.components.wcm.process.service.flowexporter 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.process.service.flowexporter 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow (implements com.trs.components.wcm.content.service.portervisitors.IPorterVisitor)


软件包 com.trs.components.wcm.process.service.flowexporter 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.process.service.flowexporter
的使用

没有 com.trs.components.wcm.process.service.flowexporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SiteExporterForFlow

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.process.service.flowexporter
类 SiteExporterForFlow

java.lang.Object
    继承者  com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow
所有已实现的接口：
IPorterVisitor
public class SiteExporterForFlow
extends java.lang.Object
implements IPorterVisitor

构造方法摘要
SiteExporterForFlow()
方法摘要
void | doExport(BaseObj _baseObj, java.lang.Object _args) 在导出_baseObj对象时,根据_baseObj对象做一些额外处理
void | doImport(BaseObj _baseObj, XmlObject _obj, java.lang.Object args) 在导入_baseObj对象时,根据当前xml串做一些额外处理
void | exportFlowsOfSite(WebSite oWebSite, java.lang.Object _args)
java.lang.String[] | registerTargetClassName()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteExporterForFlow

public SiteExporterForFlow()
方法详细信息

doExport

public void doExport(BaseObj _baseObj,
                     java.lang.Object _args)
              throws java.lang.Exception
从接口 IPorterVisitor 复制的描述
在导出_baseObj对象时,根据_baseObj对象做一些额外处理

指定者：
接口 IPorterVisitor 中的 doExport
抛出：
java.lang.Exception

doImport

public void doImport(BaseObj _baseObj,
                     XmlObject _obj,
                     java.lang.Object args)
              throws java.lang.Exception
从接口 IPorterVisitor 复制的描述
在导入_baseObj对象时,根据当前xml串做一些额外处理

指定者：
接口 IPorterVisitor 中的 doImport
抛出：
java.lang.Exception

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IPorterVisitor 中的 registerTargetClassName
返回：

exportFlowsOfSite

public void exportFlowsOfSite(WebSite oWebSite,
                              java.lang.Object _args)
                       throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow
的使用

没有 com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChnlDocLCListnerForPublish

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 ChnlDocLCListnerForPublish

java.lang.Object
    继承者  com.trs.components.wcm.publish.ChnlDocLCListnerForPublish
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ChnlDocLCListnerForPublish
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc发布内容同步删除监控器，监控ChnlDoc修改前、修改后和删除后
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChnlDocLCListnerForPublish()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChnlDocLCListnerForPublish

public ChnlDocLCListnerForPublish()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentLCListenerForPublish

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 DocumentLCListenerForPublish

java.lang.Object
    继承者  com.trs.components.wcm.publish.DocumentLCListenerForPublish
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class DocumentLCListenerForPublish
extends java.lang.Object
implements IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
为发布的相关同步监听文档的修改
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentLCListenerForPublish()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCListenerForPublish

public DocumentLCListenerForPublish()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FolderPubStatusCacheMgrImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 FolderPubStatusCacheMgrImpl

java.lang.Object
    继承者  com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl
所有已实现的接口：
IFolderPubStatusCacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class FolderPubStatusCacheMgrImpl
extends java.lang.Object
implements IFolderPubStatusCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FolderPubStatusCacheMgrImpl()
方法摘要
void | clear() 清除系统所有的Cache
int[] | findStatusesCanDoIncreasePub(int _nFolderType, int _nFolderId) 获取指定Folder的可增量发布的状态
int[] | findStatusesCanDoPub(int _nFolderType, int _nFolderId) 获取指定Folder的可完全发布的状态
boolean | init() 初始化当前的Cache
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FolderPubStatusCacheMgrImpl

public FolderPubStatusCacheMgrImpl()
方法详细信息

findStatusesCanDoPub

public int[] findStatusesCanDoPub(int _nFolderType,
                                  int _nFolderId)
                           throws WCMException
从接口 IFolderPubStatusCacheMgr 复制的描述
获取指定Folder的可完全发布的状态

指定者：
接口 IFolderPubStatusCacheMgr 中的 findStatusesCanDoPub
返回：
抛出：
WCMException

findStatusesCanDoIncreasePub

public int[] findStatusesCanDoIncreasePub(int _nFolderType,
                                          int _nFolderId)
                                   throws WCMException
从接口 IFolderPubStatusCacheMgr 复制的描述
获取指定Folder的可增量发布的状态

指定者：
接口 IFolderPubStatusCacheMgr 中的 findStatusesCanDoIncreasePub
返回：
抛出：
WCMException

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFolderPubStatusCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
接口 IFolderPubStatusCacheMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
FolderPubStatusCacheMgrImpl
public interface IFolderPubStatusCacheMgr
extends ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
int[] | findStatusesCanDoIncreasePub(int _nFolderType, int _nFolderId) 获取指定Folder的可增量发布的状态
int[] | findStatusesCanDoPub(int _nFolderType, int _nFolderId) 获取指定Folder的可完全发布的状态
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

findStatusesCanDoPub

int[] findStatusesCanDoPub(int _nFolderType,
                           int _nFolderId)
                           throws WCMException
获取指定Folder的可完全发布的状态

参数：
_nFolderType -
_nFolderId -
返回：
抛出：
WCMException

findStatusesCanDoIncreasePub

int[] findStatusesCanDoIncreasePub(int _nFolderType,
                                   int _nFolderId)
                                   throws WCMException
获取指定Folder的可增量发布的状态

参数：
_nFolderType -
_nFolderId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.publish
接口
IFolderPubStatusCacheMgr
类
ChnlDocLCListnerForPublish
DocumentLCListenerForPublish
FolderPubStatusCacheMgrImpl
WCMContentPublishConfig
WCMFolderLCListener
WCMFolderPublishConfig
WCMFolderPublishConfigLCListener
WCMPublishHelper
WCMPubStatusConfig
WCMPubStatusConfigs


com.trs.components.wcm.publish

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.publish

接口摘要
IFolderPubStatusCacheMgr Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
ChnlDocLCListnerForPublish | Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc发布内容同步删除监控器，监控ChnlDoc修改前、修改后和删除后 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForPublish | Title: TRS 内容协作平台（TRS WCM） Description: 为发布的相关同步监听文档的修改 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FolderPubStatusCacheMgrImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMContentPublishConfig |
WCMFolderLCListener | Title: TRS 内容协作平台（TRS WCM） Description: 站点或频道的删除同步撤除发布目录监听器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFolderPublishConfig |
WCMFolderPublishConfigLCListener | Title: TRS 内容协作平台（TRS WCM） Description: Folder发布的监听 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMPublishHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMPubStatusConfig |
WCMPubStatusConfigs |


com.trs.components.wcm.publish 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.publish.WCMFolderPublishConfig
        • com.trs.components.wcm.publish.WCMPubStatusConfig
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.publish.WCMPubStatusConfigs
    • com.trs.components.wcm.publish.ChnlDocLCListnerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.DocumentLCListenerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl (implements com.trs.components.wcm.publish.IFolderPubStatusCacheMgr)
    • com.trs.components.wcm.publish.WCMContentPublishConfig
    • com.trs.components.wcm.publish.WCMFolderLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.WCMPublishHelper

接口分层结构

  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.components.wcm.publish.IFolderPubStatusCacheMgr


软件包 com.trs.components.wcm.publish 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish
的使用

使用 com.trs.components.wcm.publish 的软件包
com.trs.components.wcm.publish
com.trs.service
com.trs.service.impl

com.trs.components.wcm.publish 使用的 com.trs.components.wcm.publish 中的类
IFolderPubStatusCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFolderPublishConfig
WCMPubStatusConfig
WCMPubStatusConfigs

com.trs.service 使用的 com.trs.components.wcm.publish 中的类
WCMFolderPublishConfig

com.trs.service.impl 使用的 com.trs.components.wcm.publish 中的类
WCMFolderPublishConfig

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMContentPublishConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 WCMContentPublishConfig

java.lang.Object
    继承者  com.trs.components.wcm.publish.WCMContentPublishConfig

public class WCMContentPublishConfig
extends java.lang.Object

构造方法摘要
WCMContentPublishConfig(User _currUser, IPublishContent _content)
方法摘要
Template | getDetailTemplate()
int | getDetailTemplateId()
Schedule | getSchedule()
java.lang.String | getScheduleTime()
java.lang.String | getURL()
boolean | isScheduled()
void | setDetialTemplate(int _nTemplateId)
void | setSchedulePublish(CMyDateTime _dtSchedulePublishTime)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMContentPublishConfig

public WCMContentPublishConfig(User _currUser,
                               IPublishContent _content)
方法详细信息

getURL

public java.lang.String getURL()
                        throws WCMException
返回：
抛出：
WCMException

getDetailTemplate

public Template getDetailTemplate()
                           throws WCMException
返回：
抛出：
WCMException

getDetailTemplateId

public int getDetailTemplateId()
                        throws WCMException
返回：
抛出：
WCMException

setDetialTemplate

public void setDetialTemplate(int _nTemplateId)
                       throws WCMException
抛出：
WCMException

setSchedulePublish

public void setSchedulePublish(CMyDateTime _dtSchedulePublishTime)
                        throws WCMException
抛出：
WCMException

getScheduleTime

public java.lang.String getScheduleTime()
                                 throws WCMException
抛出：
WCMException

getSchedule

public Schedule getSchedule()
                     throws WCMException
抛出：
WCMException

isScheduled

public boolean isScheduled()
                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFolderLCListener

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 WCMFolderLCListener

java.lang.Object
    继承者  com.trs.components.wcm.publish.WCMFolderLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class WCMFolderLCListener
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
站点或频道的删除同步撤除发布目录监听器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMFolderLCListener()
方法摘要
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMFolderLCListener

public WCMFolderLCListener()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFolderPublishConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 WCMFolderPublishConfig

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.publish.WCMFolderPublishConfig
所有已实现的接口：
java.lang.Cloneable
public class WCMFolderPublishConfig
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
WCMFolderPublishConfig()
构造函数：保留默认接口
WCMFolderPublishConfig(IPublishFolder _folder)
方法摘要
boolean | canEdit(User user)
static WCMFolderPublishConfig | createNewInstance() 产生当前对象[WCMFolderPublishConfig]的实例
static WCMFolderPublishConfig | findById(int _nId) 提取指定ID的对象
static WCMFolderPublishConfig | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static WCMFolderPublishConfig | findOf(int _nFolderType, int _nFolderId) 获取站点或频道的发布配置信息
java.lang.String | getDataPath() 提取属性：DataPath
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getDefaultOutlineTemplateId()
java.lang.String | getDetailFileExt() 提取属性：DetailFileExt
int | getDetailTemplateId() 提取属性：DetailTemplateId
java.lang.String | getEndTime() 提取属性：EndTime
java.lang.String | getExecTime() 提取属性：ExecTime
IPublishFolder | getFolder()
int | getFolderId() 提取属性：FolderId
int | getFolderType() 提取属性：FolderTypeConfig
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getInfoviewPrintTemplateId() 提取属性：DetailTemplateId
int | getInterval() 提取属性：Interval
java.lang.String | getOtherOutlineTemplateIds()
java.lang.String | getOutlineFileName() 提取属性：OutlineFileName
java.lang.String | getOutlineTemplateIds() 提取属性：OutlineTemplateId
java.lang.String | getPageEncoding() 获取站点的页面编码 发布产生的静态页面使用的页面编码
java.lang.String | getRootDomain() 提取属性：RootDomain
int | getScheduleId()
int | getScheduleMode() 提取属性：ScheduleMode
int | getSiteLanguage() 获取站点的语言选项 发布产生的静态页面使用的语言
java.lang.String | getStartTime() 提取属性：StartTime
java.lang.String | getStatusesCanDoPub() 提取属性：StatusesCanDoPub
int | getStatusIdAfterModify() 提取属性：StatusIdAfterModify
java.lang.String | getURL()
int | getWCMType() 取得该对象的类型编号
void | insert() 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isDefineFileRule() 提取属性：DefineFileRule
boolean | isDefineSchedule() 提取属性：DefineSchedule
boolean | isDefineStatus() 提取属性：DefineStatus
boolean | isResetChildrenTemplates() 提取属性:isResetChildrenTemplates
boolean | isSavePublishConfig()
boolean | isValid() 检验对象数据有效性
boolean | isValidInstance() 检测当前对象是否是一个已经存在的实例对象
void | save() 对象保存自己
void | save(User _currUser) 对象保存自己
boolean | setDataPath(java.lang.String _sDataPath) 设置属性：DataPath
boolean | setDefineFileRule(boolean _bDefineFileRule) 设置属性：DefineFileRule
boolean | setDefineSchedule(boolean _bDefineSchedule) 设置属性：DefineSchedule
boolean | setDefineStatus(boolean _bDefineStatus) 设置属性：DefineStatus
boolean | setDetailFileExt(java.lang.String _sDetailFileExt) 设置属性：DetailFileExt
boolean | setDetailTemplateId(int _nDetailTemplateId) 设置属性：DetailTemplateId
boolean | setEndTime(java.lang.String _sEndTime) 设置属性：EndTime
boolean | setExecTime(java.lang.String _sExecTime) 设置属性：ExecTime
boolean | setFolderType(int _nFolderType, int _nFolderId) 设置属性：FolderTypeConfig
boolean | setInfoviewPrintTemplateId(int _nInfoviewPrintTemplateId) 设置属性：_nInfoviewPrintTemplateId
boolean | setInterval(int _nInterval) 设置属性：Interval
boolean | setIsResetChildrenTemplates(boolean _bReset) 设置属性:isResetChildrenTemplates
boolean | setOutlineFileName(java.lang.String _sOutlineFileName) 设置属性：OutlineFileName
boolean | setOutlineTemplateId(java.lang.String _sOutlineTemplateId) 设置属性：OutlineTemplateId
boolean | setPageEncoding(java.lang.String _sPageEncoding) 设置站点的页面编码
boolean | setRootDomain(java.lang.String _sRootDomain) 设置属性：RootDomain
void | setSavePublishConfig(boolean isSavePublishConfig)
boolean | setScheduleMode(int _nScheduleMode) 设置属性：ScheduleMode
boolean | setSiteLanguage(int _nSiteLanguage) 设置站点的语言选项
boolean | setStartTime(java.lang.String _sStartTime) 设置属性：StartTime
boolean | setStatusesCanDoPub(java.lang.String _sStatusesCanDoPub) 设置属性：StatusesCanDoPub
boolean | setStatusIdAfterModify(int _nStatusIdAfterModify) 设置属性：StatusIdAfterModify
void | update() 更新修改。
void | update(User _user) 更新修改。
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, setCrUser, setCrUser, toString, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

WCMFolderPublishConfig

public WCMFolderPublishConfig()
构造函数：保留默认接口

WCMFolderPublishConfig

public WCMFolderPublishConfig(IPublishFolder _folder)
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getFolderType

public int getFolderType()
提取属性：FolderTypeConfig

返回：
FolderTypeConfig

setFolderType

public boolean setFolderType(int _nFolderType,
                             int _nFolderId)
                      throws WCMException
设置属性：FolderTypeConfig

参数：
_nFolderType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFolderId

public int getFolderId()
提取属性：FolderId

返回：
FolderId

getOutlineFileName

public java.lang.String getOutlineFileName()
                                    throws WCMException
提取属性：OutlineFileName

返回：
OutlineFileName
抛出：
WCMException

setOutlineFileName

public boolean setOutlineFileName(java.lang.String _sOutlineFileName)
                           throws WCMException
设置属性：OutlineFileName

参数：
_sOutlineFileName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDetailFileExt

public java.lang.String getDetailFileExt()
                                  throws WCMException
提取属性：DetailFileExt

返回：
DetailFileExt
抛出：
WCMException

setDetailFileExt

public boolean setDetailFileExt(java.lang.String _sDetailFileExt)
                         throws WCMException
设置属性：DetailFileExt

参数：
_sDetailFileExt - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDataPath

public java.lang.String getDataPath()
                             throws WCMException
提取属性：DataPath

返回：
DataPath
抛出：
WCMException

setDataPath

public boolean setDataPath(java.lang.String _sDataPath)
                    throws WCMException
设置属性：DataPath

参数：
_sDataPath - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRootDomain

public java.lang.String getRootDomain()
                               throws WCMException
提取属性：RootDomain

返回：
RootDomain
抛出：
WCMException

setRootDomain

public boolean setRootDomain(java.lang.String _sRootDomain)
                      throws WCMException
设置属性：RootDomain

参数：
_sRootDomain - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOutlineTemplateIds

public java.lang.String getOutlineTemplateIds()
                                       throws WCMException
提取属性：OutlineTemplateId

返回：
OutlineTemplateId
抛出：
WCMException

getDefaultOutlineTemplateId

public int getDefaultOutlineTemplateId()
                                throws WCMException
抛出：
WCMException

getOtherOutlineTemplateIds

public java.lang.String getOtherOutlineTemplateIds()
                                            throws WCMException
抛出：
WCMException

setOutlineTemplateId

public boolean setOutlineTemplateId(java.lang.String _sOutlineTemplateId)
                             throws WCMException
设置属性：OutlineTemplateId

参数：
_nOutlineTemplateId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDetailTemplateId

public int getDetailTemplateId()
                        throws WCMException
提取属性：DetailTemplateId

返回：
DetailTemplateId
抛出：
WCMException

setDetailTemplateId

public boolean setDetailTemplateId(int _nDetailTemplateId)
                            throws WCMException
设置属性：DetailTemplateId

参数：
_nDetailTemplateId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setInfoviewPrintTemplateId

public boolean setInfoviewPrintTemplateId(int _nInfoviewPrintTemplateId)
                                   throws WCMException
设置属性：_nInfoviewPrintTemplateId

参数：
_nInfoviewPrintTemplateId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getInfoviewPrintTemplateId

public int getInfoviewPrintTemplateId()
                               throws WCMException
提取属性：DetailTemplateId

返回：
DetailTemplateId
抛出：
WCMException

getStatusesCanDoPub

public java.lang.String getStatusesCanDoPub()
                                     throws WCMException
提取属性：StatusesCanDoPub

返回：
StatusesCanDoPub
抛出：
WCMException

setStatusesCanDoPub

public boolean setStatusesCanDoPub(java.lang.String _sStatusesCanDoPub)
                            throws WCMException
设置属性：StatusesCanDoPub

参数：
_sStatusesCanDoPub - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStatusIdAfterModify

public int getStatusIdAfterModify()
                           throws WCMException
提取属性：StatusIdAfterModify

返回：
StatusIdAfterModify
抛出：
WCMException

setStatusIdAfterModify

public boolean setStatusIdAfterModify(int _nStatusIdAfterModify)
                               throws WCMException
设置属性：StatusIdAfterModify

参数：
_nStatusIdAfterModify - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getScheduleMode

public int getScheduleMode()
                    throws WCMException
提取属性：ScheduleMode

返回：
ScheduleMode
抛出：
WCMException

getScheduleId

public int getScheduleId()
                  throws WCMException
抛出：
WCMException

setScheduleMode

public boolean setScheduleMode(int _nScheduleMode)
                        throws WCMException
设置属性：ScheduleMode

参数：
_nScheduleMode - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStartTime

public java.lang.String getStartTime()
                              throws WCMException
提取属性：StartTime

返回：
StartTime
抛出：
WCMException

setStartTime

public boolean setStartTime(java.lang.String _sStartTime)
                     throws WCMException
设置属性：StartTime

参数：
_sStartTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEndTime

public java.lang.String getEndTime()
                            throws WCMException
提取属性：EndTime

返回：
EndTime
抛出：
WCMException

setEndTime

public boolean setEndTime(java.lang.String _sEndTime)
                   throws WCMException
设置属性：EndTime

参数：
_sEndTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getInterval

public int getInterval()
                throws WCMException
提取属性：Interval

返回：
Interval
抛出：
WCMException

setInterval

public boolean setInterval(int _nInterval)
                    throws WCMException
设置属性：Interval

参数：
_nInterval - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getExecTime

public java.lang.String getExecTime()
                             throws WCMException
提取属性：ExecTime

返回：
ExecTime
抛出：
WCMException

setExecTime

public boolean setExecTime(java.lang.String _sExecTime)
                    throws WCMException
设置属性：ExecTime

参数：
_sExecTime - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isDefineFileRule

public boolean isDefineFileRule()
                         throws WCMException
提取属性：DefineFileRule

返回：
DefineFileRule
抛出：
WCMException

setDefineFileRule

public boolean setDefineFileRule(boolean _bDefineFileRule)
                          throws WCMException
设置属性：DefineFileRule

参数：
_bDefineFileRule - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isDefineSchedule

public boolean isDefineSchedule()
                         throws WCMException
提取属性：DefineSchedule

返回：
DefineSchedule
抛出：
WCMException

setDefineSchedule

public boolean setDefineSchedule(boolean _bDefineSchedule)
                          throws WCMException
设置属性：DefineSchedule

参数：
_bDefineSchedule - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isDefineStatus

public boolean isDefineStatus()
                       throws WCMException
提取属性：DefineStatus

返回：
DefineStatus
抛出：
WCMException

setDefineStatus

public boolean setDefineStatus(boolean _bDefineStatus)
                        throws WCMException
设置属性：DefineStatus

参数：
_bDefineStatus - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isResetChildrenTemplates

public boolean isResetChildrenTemplates()
提取属性:isResetChildrenTemplates

返回：

setIsResetChildrenTemplates

public boolean setIsResetChildrenTemplates(boolean _bReset)
                                    throws WCMException
设置属性:isResetChildrenTemplates

参数：
_bReset -
返回：
抛出：
WCMException

getSiteLanguage

public int getSiteLanguage()
                    throws WCMException
获取站点的语言选项
发布产生的静态页面使用的语言

返回：
抛出：
WCMException

setSiteLanguage

public boolean setSiteLanguage(int _nSiteLanguage)
                        throws WCMException
设置站点的语言选项

参数：
_nSiteLanguage - 发布产生的静态页面使用的语言
返回：
抛出：
WCMException

getPageEncoding

public java.lang.String getPageEncoding()
                                 throws WCMException
获取站点的页面编码
发布产生的静态页面使用的页面编码

返回：
抛出：
WCMException

setPageEncoding

public boolean setPageEncoding(java.lang.String _sPageEncoding)
                        throws WCMException
设置站点的页面编码

参数：
_sPageEncoding - 发布产生的静态页面使用的页面编码
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

save

public void save(User _currUser)
          throws WCMException
从类 CMSObj 复制的描述
对象保存自己

覆盖：
类 CMSObj 中的 save
参数：
_currUser - 当前操作用户
抛出：
WCMException

update

public void update(User _user)
            throws WCMException
从类 CMSObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 CMSObj 中的 update
参数：
_user - 操作用户
抛出：
WCMException

insert

public void insert()
            throws WCMException
从类 BaseObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 BaseObj 中的 insert
抛出：
WCMException

save

public void save()
          throws WCMException
从类 BaseObj 复制的描述
对象保存自己

覆盖：
类 CMSObj 中的 save
抛出：
WCMException

update

public void update()
            throws WCMException
从类 BaseObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 BaseObj 中的 update
抛出：
WCMException

findById

public static final WCMFolderPublishConfig findById(int _nId)
                                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final WCMFolderPublishConfig createNewInstance()
                                                      throws WCMException
产生当前对象[WCMFolderPublishConfig]的实例

返回：
当前对象的实例[WCMFolderPublishConfig]
抛出：
WCMException

findByKey

public static final WCMFolderPublishConfig findByKey(java.lang.Object _oKey)
                                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getURL

public java.lang.String getURL()
                        throws WCMException
返回：
抛出：
WCMException

getFolder

public IPublishFolder getFolder()
                         throws WCMException
抛出：
WCMException

findOf

public static final WCMFolderPublishConfig findOf(int _nFolderType,
                                                  int _nFolderId)
                                           throws WCMException
获取站点或频道的发布配置信息

参数：
_nFolderType - 类型（WCMTypes）
_nFolderId - Id
返回：
站点或频道的发布配置对象
抛出：
WCMException

canEdit

public boolean canEdit(User user)
覆盖：
类 CMSObj 中的 canEdit

isValidInstance

public boolean isValidInstance()
从类 BaseObj 复制的描述
检测当前对象是否是一个已经存在的实例对象

覆盖：
类 BaseObj 中的 isValidInstance
返回：

isSavePublishConfig

public boolean isSavePublishConfig()
返回：

setSavePublishConfig

public void setSavePublishConfig(boolean isSavePublishConfig)
参数：
isSavePublishConfig -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFolderPublishConfigLCListener

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 WCMFolderPublishConfigLCListener

java.lang.Object
    继承者  com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class WCMFolderPublishConfigLCListener
extends java.lang.Object
implements IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
Folder发布的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMFolderPublishConfigLCListener()
方法摘要
static void | main(java.lang.String[] args)
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMFolderPublishConfigLCListener

public WCMFolderPublishConfigLCListener()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMPublishHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 WCMPublishHelper

java.lang.Object
    继承者  com.trs.components.wcm.publish.WCMPublishHelper

public class WCMPublishHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMPublishHelper()
方法摘要
static java.lang.String getDataPath(BaseChannel _channel)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMPublishHelper

public WCMPublishHelper()
方法详细信息

getDataPath

public static java.lang.String getDataPath(BaseChannel _channel)
                                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMPubStatusConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 WCMPubStatusConfig

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.publish.WCMPubStatusConfig
所有已实现的接口：
java.lang.Cloneable
public class WCMPubStatusConfig
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
WCMPubStatusConfig()
构造函数：保留默认接口
方法摘要
static WCMPubStatusConfig | createNewInstance() 产生当前对象[WCMPubStatusConfig]的实例
static WCMPubStatusConfig | findById(int _nId) 提取指定ID的对象
static WCMPubStatusConfig | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static WCMPubStatusConfig | findOf(int _nFolderType, int _nFolderId)
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getFolderId() 提取属性：FolderId
int | getFolderType() 提取属性：FolderTypeConfig
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getStatusesCanDoPub() 提取属性：StatusesCanDoPub
int | getStatusIdAfterModify() 提取属性：StatusIdAfterModify
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
void | setFolderType(BaseChannel _currChannel)
void | setFolderType(int _nFolderType, int _nFolderId)
boolean | setStatusesCanDoPub(java.lang.String _sStatusesCanDoPub) 设置属性：StatusesCanDoPub
boolean | setStatusIdAfterModify(int _nStatusIdAfterModify) 设置属性：StatusIdAfterModify
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

WCMPubStatusConfig

public WCMPubStatusConfig()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

setFolderType

public void setFolderType(BaseChannel _currChannel)
                   throws WCMException
抛出：
WCMException

setFolderType

public void setFolderType(int _nFolderType,
                          int _nFolderId)
                   throws WCMException
抛出：
WCMException

getFolderType

public int getFolderType()
提取属性：FolderTypeConfig

返回：
FolderTypeConfig

getFolderId

public int getFolderId()
提取属性：FolderId

返回：
FolderId

getStatusesCanDoPub

public java.lang.String getStatusesCanDoPub()
提取属性：StatusesCanDoPub

返回：
StatusesCanDoPub

setStatusesCanDoPub

public boolean setStatusesCanDoPub(java.lang.String _sStatusesCanDoPub)
                            throws WCMException
设置属性：StatusesCanDoPub

参数：
_sStatusesCanDoPub - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStatusIdAfterModify

public int getStatusIdAfterModify()
提取属性：StatusIdAfterModify

返回：
StatusIdAfterModify

setStatusIdAfterModify

public boolean setStatusIdAfterModify(int _nStatusIdAfterModify)
                               throws WCMException
设置属性：StatusIdAfterModify

参数：
_nStatusIdAfterModify - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final WCMPubStatusConfig findById(int _nId)
                                         throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final WCMPubStatusConfig createNewInstance()
                                                  throws WCMException
产生当前对象[WCMPubStatusConfig]的实例

返回：
当前对象的实例[WCMPubStatusConfig]
抛出：
WCMException

findByKey

public static final WCMPubStatusConfig findByKey(java.lang.Object _oKey)
                                          throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findOf

public static final WCMPubStatusConfig findOf(int _nFolderType,
                                              int _nFolderId)
                                       throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMPubStatusConfigs

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish
类 WCMPubStatusConfigs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.publish.WCMPubStatusConfigs

public class WCMPubStatusConfigs
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WCMPubStatusConfigs(User _currUser)
构造函数
WCMPubStatusConfigs(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static WCMPubStatusConfigs | createNewInstance(User _currUser) 产生当前集合对象[WCMPubStatusConfigs]的实例
static WCMPubStatusConfigs | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static WCMPubStatusConfigs | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMPubStatusConfigs]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMPubStatusConfigs

public WCMPubStatusConfigs(User _currUser)
构造函数

另请参见：
WCMPubStatusConfigs( User _currUser, int _initCapacity, int _incCapacity );

WCMPubStatusConfigs

public WCMPubStatusConfigs(User _currUser,
                           int _initCapacity,
                           int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final WCMPubStatusConfigs findByIds(User _currUser,
                                                  java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（WCMPubStatusConfigs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final WCMPubStatusConfigs openWCMObjs(User _currUser,
                                                    WCMFilter _filter)
                                             throws WCMException
通过指定一个Filter获取当前集合[WCMPubStatusConfigs]

参数：
_filter - 指定的Filter
返回：
当前集合[WCMPubStatusConfigs]
抛出：
WCMException

createNewInstance

public static WCMPubStatusConfigs createNewInstance(User _currUser)
产生当前集合对象[WCMPubStatusConfigs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.publish.ChnlDocLCListnerForPublish 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.ChnlDocLCListnerForPublish
的使用

没有 com.trs.components.wcm.publish.ChnlDocLCListnerForPublish 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.DocumentLCListenerForPublish 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.DocumentLCListenerForPublish
的使用

没有 com.trs.components.wcm.publish.DocumentLCListenerForPublish 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl
的使用

没有 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.publish.IFolderPubStatusCacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.publish.IFolderPubStatusCacheMgr
的使用

使用 IFolderPubStatusCacheMgr 的软件包
com.trs.components.wcm.publish

com.trs.components.wcm.publish 中 IFolderPubStatusCacheMgr 的使用

实现 IFolderPubStatusCacheMgr 的 com.trs.components.wcm.publish 中的类
 class FolderPubStatusCacheMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.WCMContentPublishConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.WCMContentPublishConfig
的使用

没有 com.trs.components.wcm.publish.WCMContentPublishConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.WCMFolderLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.WCMFolderLCListener
的使用

没有 com.trs.components.wcm.publish.WCMFolderLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.WCMFolderPublishConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.WCMFolderPublishConfig
的使用

使用 WCMFolderPublishConfig 的软件包
com.trs.components.wcm.publish
com.trs.service
com.trs.service.impl

com.trs.components.wcm.publish 中 WCMFolderPublishConfig 的使用

返回 WCMFolderPublishConfig 的 com.trs.components.wcm.publish 中的方法
static WCMFolderPublishConfig | WCMFolderPublishConfig.createNewInstance() 产生当前对象[WCMFolderPublishConfig]的实例
static WCMFolderPublishConfig | WCMFolderPublishConfig.findById(int _nId) 提取指定ID的对象
static WCMFolderPublishConfig | WCMFolderPublishConfig.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static WCMFolderPublishConfig | WCMFolderPublishConfig.findOf(int _nFolderType, int _nFolderId) 获取站点或频道的发布配置信息

com.trs.service 中 WCMFolderPublishConfig 的使用

返回 WCMFolderPublishConfig 的 com.trs.service 中的方法
WCMFolderPublishConfig | IWCMPublishElementService.findFolderConfig(BaseChannel _currChannel) 获取当前站点或频道的发布配置信息
WCMFolderPublishConfig | IWCMPublishElementService.save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig) 保存当前站点或频道的发布配置信息

参数类型为 WCMFolderPublishConfig 的 com.trs.service 中的方法
 WCMFolderPublishConfig IWCMPublishElementService.save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig)
保存当前站点或频道的发布配置信息

com.trs.service.impl 中 WCMFolderPublishConfig 的使用

返回 WCMFolderPublishConfig 的 com.trs.service.impl 中的方法
WCMFolderPublishConfig | WCMPublishElementServiceImpl.findFolderConfig(BaseChannel _currChannel)
WCMFolderPublishConfig | WCMPublishElementServiceImpl.save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig)

参数类型为 WCMFolderPublishConfig 的 com.trs.service.impl 中的方法
 WCMFolderPublishConfig WCMPublishElementServiceImpl.save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener
的使用

没有 com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.WCMPublishHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.WCMPublishHelper
的使用

没有 com.trs.components.wcm.publish.WCMPublishHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.WCMPubStatusConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.WCMPubStatusConfig
的使用

使用 WCMPubStatusConfig 的软件包
com.trs.components.wcm.publish

com.trs.components.wcm.publish 中 WCMPubStatusConfig 的使用

返回 WCMPubStatusConfig 的 com.trs.components.wcm.publish 中的方法
static WCMPubStatusConfig | WCMPubStatusConfig.createNewInstance() 产生当前对象[WCMPubStatusConfig]的实例
static WCMPubStatusConfig | WCMPubStatusConfig.findById(int _nId) 提取指定ID的对象
static WCMPubStatusConfig | WCMPubStatusConfig.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static WCMPubStatusConfig | WCMPubStatusConfig.findOf(int _nFolderType, int _nFolderId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.WCMPubStatusConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.WCMPubStatusConfigs
的使用

使用 WCMPubStatusConfigs 的软件包
com.trs.components.wcm.publish

com.trs.components.wcm.publish 中 WCMPubStatusConfigs 的使用

返回 WCMPubStatusConfigs 的 com.trs.components.wcm.publish 中的方法
static WCMPubStatusConfigs | WCMPubStatusConfigs.createNewInstance(User _currUser) 产生当前集合对象[WCMPubStatusConfigs]的实例
static WCMPubStatusConfigs | WCMPubStatusConfigs.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WCMPubStatusConfigs | WCMPubStatusConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMPubStatusConfigs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IPreNextDocuments

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.domain
接口 IPreNextDocuments

所有已知实现类：
PreNextDocumentsImpl
public interface IPreNextDocuments

作者：
Administrator

方法摘要
 Documents[] getPreNextDocuments(Channel _channel, Document _currDocument, int _nNum)
获取前/后N篇文档集合

方法详细信息

getPreNextDocuments

Documents[] getPreNextDocuments(Channel _channel,
                                Document _currDocument,
                                int _nNum)
                                throws WCMException
获取前/后N篇文档集合

参数：
_channel - 文档所在的栏目（实体为DocChannel，镜像为镜像目标栏目）
_currDocument -
返回：
长度为2的Documents数组，如果一个栏目中存在文档集合为D1、D2、D3、D4、D5、D6、D7 获取D3的文档集合，Num指定为3，那么返回的结果为： Documens[[D2、D1], [D4、D5、D6]] 前N篇文档的顺序和栏目中的顺序刚好是相反
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.publish.domain
接口
IPreNextDocuments
类
PreNextDocumentsImpl
PreNextDocumentsImplTest


com.trs.components.wcm.publish.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.publish.domain

接口摘要
IPreNextDocuments

类摘要
PreNextDocumentsImpl
PreNextDocumentsImplTest


com.trs.components.wcm.publish.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.trs.TRSWCMBaseTest
          • com.trs.components.wcm.publish.domain.PreNextDocumentsImplTest
    • com.trs.components.wcm.publish.domain.PreNextDocumentsImpl (implements com.trs.components.wcm.publish.domain.IPreNextDocuments)

接口分层结构

  • com.trs.components.wcm.publish.domain.IPreNextDocuments


软件包 com.trs.components.wcm.publish.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.domain
的使用

使用 com.trs.components.wcm.publish.domain 的软件包
com.trs.components.wcm.publish.domain

com.trs.components.wcm.publish.domain 使用的 com.trs.components.wcm.publish.domain 中的类
IPreNextDocuments

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PreNextDocumentsImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.domain
类 PreNextDocumentsImpl

java.lang.Object
    继承者  com.trs.components.wcm.publish.domain.PreNextDocumentsImpl
所有已实现的接口：
IPreNextDocuments
public class PreNextDocumentsImpl
extends java.lang.Object
implements IPreNextDocuments

作者：
Administrator

字段摘要
static int MAX_READ_COUNT
构造方法摘要
PreNextDocumentsImpl()
方法摘要
 Documents[] getPreNextDocuments(Channel _channel, Document document, int num)
获取前/后N篇文档集合
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAX_READ_COUNT

public static int MAX_READ_COUNT
构造方法详细信息

PreNextDocumentsImpl

public PreNextDocumentsImpl()
方法详细信息

getPreNextDocuments

public Documents[] getPreNextDocuments(Channel _channel,
                                       Document document,
                                       int num)
                                throws WCMException
从接口 IPreNextDocuments 复制的描述
获取前/后N篇文档集合

指定者：
接口 IPreNextDocuments 中的 getPreNextDocuments
参数：
_channel - 文档所在的栏目（实体为DocChannel，镜像为镜像目标栏目）
返回：
长度为2的Documents数组，如果一个栏目中存在文档集合为D1、D2、D3、D4、D5、D6、D7 获取D3的文档集合，Num指定为3，那么返回的结果为： Documens[[D2、D1], [D4、D5、D6]] 前N篇文档的顺序和栏目中的顺序刚好是相反
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PreNextDocumentsImplTest

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.domain
类 PreNextDocumentsImplTest

java.lang.Object
    继承者  junit.framework.Assert
        继承者  junit.framework.TestCase
            继承者  com.trs.TRSWCMBaseTest
                继承者  com.trs.components.wcm.publish.domain.PreNextDocumentsImplTest
所有已实现的接口：
junit.framework.Test
public class PreNextDocumentsImplTest
extends com.trs.TRSWCMBaseTest

构造方法摘要
PreNextDocumentsImplTest()
方法摘要
 void testGetPreNextDocuments()
从类 junit.framework.TestCase 继承的方法
countTestCases, getName, run, run, runBare, setName, toString
从类 junit.framework.Assert 继承的方法
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PreNextDocumentsImplTest

public PreNextDocumentsImplTest()
方法详细信息

testGetPreNextDocuments

public void testGetPreNextDocuments()
                             throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.wcm.publish.domain.IPreNextDocuments 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.publish.domain.IPreNextDocuments
的使用

使用 IPreNextDocuments 的软件包
com.trs.components.wcm.publish.domain

com.trs.components.wcm.publish.domain 中 IPreNextDocuments 的使用

实现 IPreNextDocuments 的 com.trs.components.wcm.publish.domain 中的类
 class PreNextDocumentsImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.domain.PreNextDocumentsImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.domain.PreNextDocumentsImpl
的使用

没有 com.trs.components.wcm.publish.domain.PreNextDocumentsImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.domain.PreNextDocumentsImplTest 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.domain.PreNextDocumentsImplTest
的使用

没有 com.trs.components.wcm.publish.domain.PreNextDocumentsImplTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.wcm.publish.domain.job
类
PublishJobWorker
WithDrawJobWorker


com.trs.components.wcm.publish.domain.job

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.publish.domain.job

类摘要
PublishJobWorker | Title: TRS 内容协作平台（TRS WCM） Description: 计划发布执行者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WithDrawJobWorker | Title: TRS 内容协作平台（TRS WCM） Description: 定时撤稿 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)


com.trs.components.wcm.publish.domain.job 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.domain.job 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.components.common.job.BaseScheduleWorker
        • com.trs.components.common.job.BaseStatefulScheduleWorker (implements org.quartz.StatefulJob)
          • com.trs.components.wcm.publish.domain.job.PublishJobWorker
          • com.trs.components.wcm.publish.domain.job.WithDrawJobWorker


软件包 com.trs.components.wcm.publish.domain.job 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.domain.job
的使用

没有 com.trs.components.wcm.publish.domain.job 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishJobWorker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.domain.job
类 PublishJobWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.common.job.BaseStatefulScheduleWorker
                继承者  com.trs.components.wcm.publish.domain.job.PublishJobWorker
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
public class PublishJobWorker
extends BaseStatefulScheduleWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
计划发布执行者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishJobWorker()
构造函数，保留默认接口
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

PublishJobWorker

public PublishJobWorker()
构造函数，保留默认接口

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


WithDrawJobWorker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.domain.job
类 WithDrawJobWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.common.job.BaseStatefulScheduleWorker
                继承者  com.trs.components.wcm.publish.domain.job.WithDrawJobWorker
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
public class WithDrawJobWorker
extends BaseStatefulScheduleWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
定时撤稿
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
WithDrawJobWorker()
构造函数，保留默认接口
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

WithDrawJobWorker

public WithDrawJobWorker()
构造函数，保留默认接口

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.publish.domain.job.PublishJobWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.domain.job.PublishJobWorker
的使用

没有 com.trs.components.wcm.publish.domain.job.PublishJobWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.domain.job.WithDrawJobWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.domain.job.WithDrawJobWorker
的使用

没有 com.trs.components.wcm.publish.domain.job.WithDrawJobWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IRelateResource

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.element
接口 IRelateResource

所有已知实现类：
MetaViewDataRelateSource
public interface IRelateResource

Title: TRS 内容协作平台（TRS WCM）
Description:
相关文件
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

方法摘要
 java.util.List getResourceNames(IPublishContent content)
获取当前IPublishContent对象的相关文件(如正文中的图片等)
注意:实现时,即使没有相关的文件,也不能返回null.在没有相关文件的情况下,返回空集

方法详细信息

getResourceNames

java.util.List getResourceNames(IPublishContent content)
                                throws WCMException
获取当前IPublishContent对象的相关文件(如正文中的图片等)
注意:实现时,即使没有相关的文件,也不能返回null.在没有相关文件的情况下,返回空集

参数：
content -
返回：
返回文件名集合,文件名可以是全路径,也可以是WCMData管理的文件名集.
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.publish.element
接口
IRelateResource
类
PublishContentDocumentImpl
PublishElementsIteratorDocumentsImpl
PublishFolderChannelImpl
PublishFolderWebSiteImpl


com.trs.components.wcm.publish.element

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.publish.element

接口摘要
IRelateResource Title: TRS 内容协作平台（TRS WCM）
Description:
相关文件
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

类摘要
PublishContentDocumentImpl | Title: TRS 内容协作平台（TRS WCM） Description: publis content implementation with document.
PublishElementsIteratorDocumentsImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishFolderChannelImpl | Title: TRS 内容协作平台（TRS WCM） Description: channel implementation of IPublishFolder Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishFolderWebSiteImpl | Title: TRS 内容协作平台（TRS WCM） Description: website implementation of folder.


com.trs.components.wcm.publish.element 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.element 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.persistent.element.PublishContentImplBase (implements com.trs.components.common.publish.persistent.element.IPublishContent)
      • com.trs.components.wcm.publish.element.PublishContentDocumentImpl
    • com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl (implements com.trs.components.common.publish.domain.taskdispatch.IPublishElementsIterator)
    • com.trs.components.common.publish.persistent.element.PublishFolderImplBase (implements com.trs.components.common.publish.persistent.element.IPublishFolder)
      • com.trs.components.wcm.publish.element.PublishFolderChannelImpl
      • com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl

接口分层结构

  • com.trs.components.wcm.publish.element.IRelateResource


软件包 com.trs.components.wcm.publish.element 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.element
的使用

使用 com.trs.components.wcm.publish.element 的软件包
com.trs.components.metadata.publish
com.trs.components.wcm.epress

com.trs.components.metadata.publish 使用的 com.trs.components.wcm.publish.element 中的类
IRelateResource
Title: TRS 内容协作平台（TRS WCM）
Description:
相关文件
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.components.wcm.publish.element 中的类
PublishFolderChannelImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
channel implementation of IPublishFolder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishContentDocumentImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.element
类 PublishContentDocumentImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishContentImplBase
        继承者  com.trs.components.wcm.publish.element.PublishContentDocumentImpl
所有已实现的接口：
ICMSObjSubstanceContent, IPublishContent, IPublishElement
public class PublishContentDocumentImpl
extends PublishContentImplBase

Title: TRS 内容协作平台（TRS WCM）
Description:
publis content implementation with document.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishContentDocumentImpl()
constructor: default
PublishContentDocumentImpl(Document _doc)
constructor
方法摘要
boolean | canDoPreview() 判断发布元素是否可以预览
int | getBodyType() Returns the content body type
CMyDateTime | getCreatedTime() Returns the created time of this content.
java.lang.String | getFileName()
int | getId() Returns the publish content id.
java.lang.String | getLinkUrl()
int | getModal() Returns the content modal in the curernt folder
IPublishFolder | getOriginalHome() Returns the folder where this content originally lies.
java.util.Iterator | getRelatedResources() 获取Content相关的资源文件(如附件等)
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isFile()
boolean | isLink()
boolean | isPublishedInHome() Returns true if this content has been published in its home folder.
boolean | isValidElement() 判断是否为有效的发布元素
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setFolder(IPublishFolder _folder) Sets the folder where this content currently lies.
void | setPublishStatus(int _nStatus) Sets the publish status of this content in the specified folder
void | setPublishTime(CMyDateTime _dtTime) 设置当前内容的发布时间
void | setPublishTimeAndURL(CMyDateTime _time, java.lang.String _url) 设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
void | setSubstance(CMSObj _cmsObj) Sets the substantce
java.lang.String | toString()
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
boolean | validateCanDoPub() Returns true if the folder is can be published.
从类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 继承的方法
equals, getDetailTemplate, getDetailTemplateType, getEncoding, getFileNamedStyle, getFolder, getInfo, getRealHome, getTemplateArguments, isFolder, setDetailTemplateType
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PublishContentDocumentImpl

public PublishContentDocumentImpl()
constructor: default

PublishContentDocumentImpl

public PublishContentDocumentImpl(Document _doc)
constructor

参数：
_doc - the substance of this content
方法详细信息

setFolder

public void setFolder(IPublishFolder _folder)
从接口 IPublishContent 复制的描述
Sets the folder where this content currently lies.

指定者：
接口 IPublishContent 中的 setFolder
覆盖：
类 PublishContentImplBase 中的 setFolder
参数：
_folder - the current folder
另请参见：
IPublishContent.setFolder(IPublishFolder)

getModal

public int getModal()
             throws WCMException
从接口 IPublishContent 复制的描述
Returns the content modal in the curernt folder

指定者：
接口 IPublishContent 中的 getModal
覆盖：
类 PublishContentImplBase 中的 getModal
返回：
Returns the content modal type which is defined in CMSConstants like CONTENT_MODAL_ENTITY, CONTENT_MODAL_LINK, etc.
抛出：
WCMException - if failed to load this property.
另请参见：
IPublishContent.getModal()

isPublishedInHome

public boolean isPublishedInHome()
                          throws WCMException
从接口 IPublishContent 复制的描述
Returns true if this content has been published in its home folder.

返回：
true if this content has been published in its home folder.
抛出：
WCMException
另请参见：
IPublishContent.isPublishedInHome()

getBodyType

public int getBodyType()
从接口 IPublishContent 复制的描述
Returns the content body type

返回：
Returns the content body type which is defined in CMSConstants like CONTENT_BODY_NORMAL, CONTENT_BODY_HTML, etc.
另请参见：
IPublishContent.getBodyType()

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishContent 复制的描述
Sets the publish status of this content in the specified folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, etc.
抛出：
WCMException
另请参见：
IPublishContent.setPublishStatus(int)

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

返回：
the publish content type
另请参见：
ICMSObjSubstanceContent.getType()

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj
另请参见：
ICMSObjSubstanceContent.getSubstance()

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

参数：
_cmsObj - a CMS object
另请参见：
ICMSObjSubstanceContent.setSubstance(CMSObj)

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException
另请参见：
ICMSObjSubstanceContent.loadById(int)

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

指定者：
接口 ICMSObjSubstanceContent 中的 getId
覆盖：
类 PublishContentImplBase 中的 getId
返回：
the publish content id
另请参见：
ICMSObjSubstanceContent.getId()

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object
另请参见：
ICMSObjSubstanceContent.makeFrom(CMSObj)

getOriginalHome

public IPublishFolder getOriginalHome()
                               throws WCMException
从接口 IPublishContent 复制的描述
Returns the folder where this content originally lies.

返回：
the folder where this content originally lies.
抛出：
WCMException - if failed.
另请参见：
IPublishContent.getOriginalHome()

getCreatedTime

public CMyDateTime getCreatedTime()
从接口 IPublishContent 复制的描述
Returns the created time of this content.

指定者：
接口 IPublishContent 中的 getCreatedTime
覆盖：
类 PublishContentImplBase 中的 getCreatedTime
返回：
the created time of this content.
另请参见：
IPublishContent.getCreatedTime()

setPublishTime

public void setPublishTime(CMyDateTime _dtTime)
                    throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容的发布时间

参数：
_dtTime - CMyDateTime实例对象，如果为null表示页面被取消了
抛出：
WCMException - 如果发生错误

setPublishTimeAndURL

public void setPublishTimeAndURL(CMyDateTime _time,
                                 java.lang.String _url)
                          throws WCMException
从接口 IPublishContent 复制的描述
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消

参数：
_time - 发布的时间
_url - 发布后的URL
抛出：
WCMException - 如果发生错误

validateCanDoPub

public boolean validateCanDoPub()
                         throws WCMException
从接口 IPublishElement 复制的描述
Returns true if the folder is can be published.

指定者：
接口 IPublishElement 中的 validateCanDoPub
覆盖：
类 PublishContentImplBase 中的 validateCanDoPub
返回：
true if the folder is can be published.
抛出：
WCMException

isValidElement

public boolean isValidElement()
从接口 IPublishElement 复制的描述
判断是否为有效的发布元素

指定者：
接口 IPublishElement 中的 isValidElement
覆盖：
类 PublishContentImplBase 中的 isValidElement
返回：

isLink

public boolean isLink()
指定者：
接口 IPublishElement 中的 isLink
覆盖：
类 PublishContentImplBase 中的 isLink
返回：
true if the eliement is a link;
otherwise, returns false.

getLinkUrl

public java.lang.String getLinkUrl()
指定者：
接口 IPublishElement 中的 getLinkUrl
覆盖：
类 PublishContentImplBase 中的 getLinkUrl
返回：
the linked url if this eliement is a link;
otherwise, returns null.

isFile

public boolean isFile()
指定者：
接口 IPublishContent 中的 isFile
覆盖：
类 PublishContentImplBase 中的 isFile
返回：
true if the document is a link;
otherwise, returns false.

getFileName

public java.lang.String getFileName()
指定者：
接口 IPublishContent 中的 getFileName
覆盖：
类 PublishContentImplBase 中的 getFileName
返回：
the linked url if this document is a link;
otherwise, returns null.

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

抛出：
WCMException

canDoPreview

public boolean canDoPreview()
从接口 IPublishElement 复制的描述
判断发布元素是否可以预览

指定者：
接口 IPublishElement 中的 canDoPreview
覆盖：
类 PublishContentImplBase 中的 canDoPreview
返回：

getRelatedResources

public java.util.Iterator getRelatedResources()
                                       throws WCMException
从接口 IPublishContent 复制的描述
获取Content相关的资源文件(如附件等)

返回：
相关资源文件的文件名集合,可能返回null
抛出：
WCMException

isCanDoSave

public boolean isCanDoSave(User _loginUser)
                    throws WCMException
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

返回：
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishElementsIteratorDocumentsImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.element
类 PublishElementsIteratorDocumentsImpl

java.lang.Object
    继承者  com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl
所有已实现的接口：
IPublishElementsIterator, java.util.Iterator
public class PublishElementsIteratorDocumentsImpl
extends java.lang.Object
implements IPublishElementsIterator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static long | DEBUG_USE_TIME
static java.util.List | m_listExcludeFields
构造方法摘要
PublishElementsIteratorDocumentsImpl(WCMFilter _filter)
方法摘要
void | clear()
java.lang.String | getDbTableName()
java.lang.String | getIdFieldName()
boolean | hasNext()
java.lang.Object | next()
void | remove()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEBUG_USE_TIME

public static long DEBUG_USE_TIME

m_listExcludeFields

public static java.util.List m_listExcludeFields
构造方法详细信息

PublishElementsIteratorDocumentsImpl

public PublishElementsIteratorDocumentsImpl(WCMFilter _filter)
                                     throws WCMException
抛出：
WCMException
方法详细信息

clear

public void clear()
指定者：
接口 IPublishElementsIterator 中的 clear

remove

public void remove()
指定者：
接口 java.util.Iterator 中的 remove

hasNext

public boolean hasNext()
指定者：
接口 java.util.Iterator 中的 hasNext

next

public java.lang.Object next()
指定者：
接口 java.util.Iterator 中的 next

getDbTableName

public java.lang.String getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishFolderChannelImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.element
类 PublishFolderChannelImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishFolderImplBase
        继承者  com.trs.components.wcm.publish.element.PublishFolderChannelImpl
所有已实现的接口：
ICMSObjSubstanceContent, IPublishElement, IPublishFolder
直接已知子类：
EpressFolderWrapper
public class PublishFolderChannelImpl
extends PublishFolderImplBase

Title: TRS 内容协作平台（TRS WCM）
Description:
channel implementation of IPublishFolder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 继承的字段
INHERIT_ROOT_DETAIL_TEMPLATE
构造方法摘要
PublishFolderChannelImpl()
constructor: default
PublishFolderChannelImpl(Channel _channel)
constructor
方法摘要
boolean | canDoBatchDetailPageTask()
boolean | canDoDetailPageTask() check if can create detail page task
boolean | canDoOutlinePageTask() check if can create outline page task
boolean | canDoPreview() 判断发布元素是否可以预览
IPublishElements | getAllContents(WCMFilter _filter) Returns all the contents to publish
IPublishElementsIterator | getAllContentsIterator(WCMFilter _filter)
IPublishElements | getChildren() get the children folders
int | getId() Returns the publish content id.
IPublishElements | getIncreasedContents(WCMFilter _filter) Returns the increased contents to publish
IPublishElementsIterator | getIncreasedContentsIterator(WCMFilter _filter)
java.lang.String | getLinkUrl()
IPublishFolder | getParent()
IPublishElements | getPublishedContents(WCMFilter _filter) Returns the contents which have been published.
IPublishFolder | getRoot()
int | getSiblingIndex() Retuns index of this folder in its siblings.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isDeleted() 是否已经被假删除
boolean | isLink()
boolean | isRoot()
boolean | isValidElement() 判断是否为有效的发布元素
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setPublishStatus(int _nStatus) Sets the publish status of this folder
void | setSubstance(CMSObj _cmsObj) Sets the substantce
java.lang.String | toString()
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
boolean | validateCanDoPub() Returns true if the folder is can be published.
从类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 继承的方法
equals, getDataPath, getDetailTemplate, getEncoding, getFolder, getFoldersQuotingMe, getInfo, getOutlineTemplates, getPathKey, getRootDomain, getTemplateArguments, isFolder
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PublishFolderChannelImpl

public PublishFolderChannelImpl()
constructor: default

PublishFolderChannelImpl

public PublishFolderChannelImpl(Channel _channel)
constructor

参数：
_channel - the substance which is a channel.
方法详细信息

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

返回：
the publish content type
另请参见：
ICMSObjSubstanceContent.getType()

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj
另请参见：
ICMSObjSubstanceContent.getSubstance()

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

参数：
_cmsObj - a CMS object
另请参见：
ICMSObjSubstanceContent.setSubstance(CMSObj)

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException
另请参见：
ICMSObjSubstanceContent.loadById(int)

getIncreasedContents

public IPublishElements getIncreasedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the increased contents to publish

参数：
_filter - extra query filter for the collection
返回：
the contents collection, which are not published but can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getIncreasedContents(WCMFilter)

getPublishedContents

public IPublishElements getPublishedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the contents which have been published.

参数：
_filter - extra query filter for the collection
返回：
the contents which have been published
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getPublishedContents(WCMFilter)

getAllContents

public IPublishElements getAllContents(WCMFilter _filter)
                                throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns all the contents to publish

参数：
_filter - extra query filter for the collection
返回：
all the contents which have been published or can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getAllContents(WCMFilter)

isLink

public boolean isLink()
返回：
true if the eliement is a link;
otherwise, returns false.
另请参见：
IPublishElement.isLink()

getLinkUrl

public java.lang.String getLinkUrl()
返回：
the linked url if this eliement is a link;
otherwise, returns null.
另请参见：
IPublishElement.getLinkUrl()

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

返回：
the publish content id
另请参见：
ICMSObjSubstanceContent.getId()

isRoot

public boolean isRoot()
返回：
true if this folder is a root; otherwise, returns false.
另请参见：
IPublishFolder.isRoot()

getRoot

public IPublishFolder getRoot()
                       throws WCMException
返回：
the root of this folder.
抛出：
WCMException - if failed to find the folder root.
另请参见：
IPublishFolder.getRoot()

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object
另请参见：
ICMSObjSubstanceContent.makeFrom(CMSObj)

getParent

public IPublishFolder getParent()
                         throws WCMException
返回：
the parent of this folder.
抛出：
WCMException - if failed to fetch the parent folder.
另请参见：
IPublishFolder.getParent()

getChildren

public IPublishElements getChildren()
                             throws WCMException
从接口 IPublishFolder 复制的描述
get the children folders

返回：
the children folders collection.
抛出：
WCMException - if failed to fetch the children.
另请参见：
IPublishFolder.getChildren()

getSiblingIndex

public int getSiblingIndex()
                    throws WCMException
从接口 IPublishFolder 复制的描述
Retuns index of this folder in its siblings.

返回：
index of this folder in its siblings.
抛出：
WCMException - if failed to calculate the index.
另请参见：
IPublishFolder.getSiblingIndex()

validateCanDoPub

public boolean validateCanDoPub()
                         throws WCMException
从接口 IPublishElement 复制的描述
Returns true if the folder is can be published.

返回：
true if the folder is can be published.
抛出：
WCMException
另请参见：
IPublishElement.validateCanDoPub()

canDoOutlinePageTask

public boolean canDoOutlinePageTask()
从接口 IPublishFolder 复制的描述
check if can create outline page task

返回：

canDoDetailPageTask

public boolean canDoDetailPageTask()
从接口 IPublishFolder 复制的描述
check if can create detail page task

返回：

isValidElement

public boolean isValidElement()
从接口 IPublishElement 复制的描述
判断是否为有效的发布元素

返回：

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

抛出：
WCMException

canDoPreview

public boolean canDoPreview()
从接口 IPublishElement 复制的描述
判断发布元素是否可以预览

指定者：
接口 IPublishElement 中的 canDoPreview
覆盖：
类 PublishFolderImplBase 中的 canDoPreview
返回：

getIncreasedContentsIterator

public IPublishElementsIterator getIncreasedContentsIterator(WCMFilter _filter)
                                                      throws java.lang.Exception
抛出：
java.lang.Exception

getAllContentsIterator

public IPublishElementsIterator getAllContentsIterator(WCMFilter _filter)
                                                throws java.lang.Exception
抛出：
java.lang.Exception

canDoBatchDetailPageTask

public boolean canDoBatchDetailPageTask()

isCanDoSave

public boolean isCanDoSave(User _loginUser)
                    throws WCMException
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

返回：
抛出：
WCMException

isDeleted

public boolean isDeleted()
从接口 IPublishFolder 复制的描述
是否已经被假删除

返回：

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishFolder 复制的描述
Sets the publish status of this folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, STATUS_DELETEDetc.
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublishFolderWebSiteImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.element
类 PublishFolderWebSiteImpl

java.lang.Object
    继承者  com.trs.components.common.publish.persistent.element.PublishFolderImplBase
        继承者  com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl
所有已实现的接口：
ICMSObjSubstanceContent, IPublishElement, IPublishFolder
public class PublishFolderWebSiteImpl
extends PublishFolderImplBase

Title: TRS 内容协作平台（TRS WCM）
Description:
website implementation of folder.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 继承的字段
INHERIT_ROOT_DETAIL_TEMPLATE
构造方法摘要
PublishFolderWebSiteImpl()
constructor: default
PublishFolderWebSiteImpl(WebSite _site)
constructor
方法摘要
boolean | canDoBatchDetailPageTask()
boolean | canDoDetailPageTask() check if can create detail page task
boolean | canDoOutlinePageTask() check if can create outline page task
boolean | canDoPreview() 判断发布元素是否可以预览
IPublishElements | getAllContents(WCMFilter _filter) Returns all the contents to publish
IPublishElementsIterator | getAllContentsIterator(WCMFilter _filter)
IPublishElements | getChildren() get the children folders
java.util.Collection | getFoldersQuotingMe() Returns the content folders who are quoting this folder
int | getId() Returns the publish content id.
IPublishElements | getIncreasedContents(WCMFilter _filter) Returns the increased contents to publish
IPublishElementsIterator | getIncreasedContentsIterator(WCMFilter _filter)
java.lang.String | getLinkUrl()
IPublishFolder | getParent()
IPublishElements | getPublishedContents(WCMFilter _filter) Returns the contents which have been published.
IPublishFolder | getRoot()
int | getSiblingIndex() Retuns index of this folder in its siblings.
CMSObj | getSubstance() Returns the substance object which is an instance of CMSObj.
int | getType() Returns the publish content type.
boolean | isCanDoSave(User _loginUser) 指定用户是否可以保存当前对象
boolean | isDeleted() 是否已经被假删除
boolean | isLink()
boolean | isRoot()
boolean | isValidElement() 判断是否为有效的发布元素
boolean | loadById(int _nId) Loads the content data by the specified id.
void | makeFrom(CMSObj _cmsObj) Makes this content from a CMS object.
void | setPublishStatus(int _nStatus) Sets the publish status of this folder
void | setSubstance(CMSObj _cmsObj) Sets the substantce
void | validateCanDoPreview() 断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
boolean | validateCanDoPub() Returns true if the folder is can be published.
从类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 继承的方法
equals, getDataPath, getDetailTemplate, getEncoding, getFolder, getInfo, getOutlineTemplates, getPathKey, getRootDomain, getTemplateArguments, isFolder
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishFolderWebSiteImpl

public PublishFolderWebSiteImpl()
constructor: default

PublishFolderWebSiteImpl

public PublishFolderWebSiteImpl(WebSite _site)
constructor

参数：
_site - the substance which is a website.
方法详细信息

getType

public int getType()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content type.

返回：
the publish content type
另请参见：
ICMSObjSubstanceContent.getType()

getSubstance

public CMSObj getSubstance()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the substance object which is an instance of CMSObj.

返回：
the substance object which is an instance of CMSObj
另请参见：
ICMSObjSubstanceContent.getSubstance()

setSubstance

public void setSubstance(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Sets the substantce

参数：
_cmsObj - a CMS object
另请参见：
ICMSObjSubstanceContent.setSubstance(CMSObj)

loadById

public boolean loadById(int _nId)
                 throws WCMException
从接口 ICMSObjSubstanceContent 复制的描述
Loads the content data by the specified id.

参数：
_nId - the content id
返回：
Returns true if the content is found; otherwise, returns false.
抛出：
WCMException
另请参见：
ICMSObjSubstanceContent.loadById(int)

getIncreasedContents

public IPublishElements getIncreasedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the increased contents to publish

参数：
_filter - extra query filter for the collection
返回：
the contents collection, which are not published but can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getIncreasedContents(WCMFilter)

getPublishedContents

public IPublishElements getPublishedContents(WCMFilter _filter)
                                      throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns the contents which have been published.

参数：
_filter - extra query filter for the collection
返回：
the contents which have been published
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getPublishedContents(WCMFilter)

getAllContents

public IPublishElements getAllContents(WCMFilter _filter)
                                throws java.lang.Exception
从接口 IPublishFolder 复制的描述
Returns all the contents to publish

参数：
_filter - extra query filter for the collection
返回：
all the contents which have been published or can be published.
抛出：
java.lang.Exception - if failed to fetch the contents collection.
另请参见：
IPublishFolder.getAllContents(WCMFilter)

isLink

public boolean isLink()
返回：
true if the eliement is a link;
otherwise, returns false.
另请参见：
IPublishElement.isLink()

getLinkUrl

public java.lang.String getLinkUrl()
返回：
the linked url if this eliement is a link;
otherwise, returns null.
另请参见：
IPublishElement.getLinkUrl()

getId

public int getId()
从接口 ICMSObjSubstanceContent 复制的描述
Returns the publish content id.

返回：
the publish content id
另请参见：
ICMSObjSubstanceContent.getId()

isRoot

public boolean isRoot()
返回：
true if this folder is a root; otherwise, returns false.
另请参见：
IPublishFolder.isRoot()

getRoot

public IPublishFolder getRoot()
返回：
the root of this folder.
另请参见：
IPublishFolder.getRoot()

makeFrom

public void makeFrom(CMSObj _cmsObj)
从接口 ICMSObjSubstanceContent 复制的描述
Makes this content from a CMS object.

参数：
_cmsObj - a CMS object
另请参见：
ICMSObjSubstanceContent.makeFrom(com.trs.cms.content.CMSObj)

getParent

public IPublishFolder getParent()
返回：
the parent of this folder.
另请参见：
IPublishFolder.getParent()

getChildren

public IPublishElements getChildren()
                             throws WCMException
从接口 IPublishFolder 复制的描述
get the children folders

返回：
the children folders collection.
抛出：
WCMException - if failed to fetch the children.
另请参见：
IPublishFolder.getChildren()

getSiblingIndex

public int getSiblingIndex()
                    throws WCMException
从接口 IPublishFolder 复制的描述
Retuns index of this folder in its siblings.

返回：
index of this folder in its siblings.
抛出：
WCMException - if failed to calculate the index.
另请参见：
IPublishFolder.getSiblingIndex()

validateCanDoPub

public boolean validateCanDoPub()
                         throws WCMException
从接口 IPublishElement 复制的描述
Returns true if the folder is can be published.

返回：
true if the folder is can be published.
抛出：
WCMException
另请参见：
IPublishElement.validateCanDoPub()

canDoOutlinePageTask

public boolean canDoOutlinePageTask()
从接口 IPublishFolder 复制的描述
check if can create outline page task

返回：

canDoDetailPageTask

public boolean canDoDetailPageTask()
从接口 IPublishFolder 复制的描述
check if can create detail page task

返回：

isValidElement

public boolean isValidElement()
从接口 IPublishElement 复制的描述
判断是否为有效的发布元素

返回：

validateCanDoPreview

public void validateCanDoPreview()
                          throws WCMException
从接口 IPublishElement 复制的描述
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。 没有使用"assert"是为了和validateCanDoPub相兼容。

抛出：
WCMException

canDoPreview

public boolean canDoPreview()
从接口 IPublishElement 复制的描述
判断发布元素是否可以预览

指定者：
接口 IPublishElement 中的 canDoPreview
覆盖：
类 PublishFolderImplBase 中的 canDoPreview
返回：

getIncreasedContentsIterator

public IPublishElementsIterator getIncreasedContentsIterator(WCMFilter _filter)
                                                      throws java.lang.Exception
抛出：
java.lang.Exception

getAllContentsIterator

public IPublishElementsIterator getAllContentsIterator(WCMFilter _filter)
                                                throws java.lang.Exception
抛出：
java.lang.Exception

canDoBatchDetailPageTask

public boolean canDoBatchDetailPageTask()

isCanDoSave

public boolean isCanDoSave(User _loginUser)
                    throws WCMException
从接口 IPublishElement 复制的描述
指定用户是否可以保存当前对象

返回：
抛出：
WCMException

isDeleted

public boolean isDeleted()
从接口 IPublishFolder 复制的描述
是否已经被假删除

返回：

getFoldersQuotingMe

public java.util.Collection getFoldersQuotingMe()
从接口 IPublishFolder 复制的描述
Returns the content folders who are quoting this folder

指定者：
接口 IPublishFolder 中的 getFoldersQuotingMe
覆盖：
类 PublishFolderImplBase 中的 getFoldersQuotingMe
返回：
the folders collection who are quoting this folder
另请参见：
IPublishFolder.getFoldersQuotingMe()

setPublishStatus

public void setPublishStatus(int _nStatus)
                      throws WCMException
从接口 IPublishFolder 复制的描述
Sets the publish status of this folder

参数：
_nStatus - publish status which is defined in PublishConstants like STATUS_OPEN, STATUS_PUBLISHED, STATUS_DELETEDetc.
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.components.wcm.publish.element.IRelateResource 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.publish.element.IRelateResource
的使用

使用 IRelateResource 的软件包
com.trs.components.metadata.publish

com.trs.components.metadata.publish 中 IRelateResource 的使用

实现 IRelateResource 的 com.trs.components.metadata.publish 中的类
 class MetaViewDataRelateSource
Title: TRS 内容协作平台（TRS WCM）
Description:
获取相关文件
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl
的使用

没有 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl
的使用

没有 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl
的使用

使用 PublishFolderChannelImpl 的软件包
com.trs.components.wcm.epress

com.trs.components.wcm.epress 中 PublishFolderChannelImpl 的使用

com.trs.components.wcm.epress 中 PublishFolderChannelImpl 的子类
 class EpressFolderWrapper
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl
的使用

没有 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Logo

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.logo
类 Logo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.publish.logo.Logo
所有已实现的接口：
java.lang.Cloneable
public class Logo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Logo()
构造函数：保留默认接口
方法摘要
static Logo | createNewInstance() 产生当前对象[Logo]的实例
static Logo | findById(int _nId) 提取指定ID的对象
static Logo | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static Logo | findOf(int _nHostType, int _nHostId, int _nIndex) 获取指定对象的指定Logo
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getFileName() 提取属性：FileName
int | getHostId() 提取属性：HostId
int | getHostType() 提取属性：HostType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getLogoOrder() 提取属性：LogoOrder
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isUpdated() 提取属性：Updated
boolean | isValid() 检验对象数据有效性
boolean | setFileName(java.lang.String _sFileName) 设置属性：FileName
boolean | setHostId(int _nHostId) 设置属性：HostId
boolean | setHostType(int _nHostType) 设置属性：HostType
boolean | setLogoOrder(int _nLogoOrder) 设置属性：LogoOrder
boolean | setUpdated(boolean _bUpdated) 设置属性：Updated
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Logo

public Logo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

isUpdated

public boolean isUpdated()
提取属性：Updated

返回：
Updated

setUpdated

public boolean setUpdated(boolean _bUpdated)
                   throws WCMException
设置属性：Updated

参数：
_bUpdated - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostType

public int getHostType()
提取属性：HostType

返回：
HostType

setHostType

public boolean setHostType(int _nHostType)
                    throws WCMException
设置属性：HostType

参数：
_nHostType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostId

public int getHostId()
提取属性：HostId

返回：
HostId

setHostId

public boolean setHostId(int _nHostId)
                  throws WCMException
设置属性：HostId

参数：
_nHostId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFileName

public java.lang.String getFileName()
提取属性：FileName

返回：
FileName

setFileName

public boolean setFileName(java.lang.String _sFileName)
                    throws WCMException
设置属性：FileName

参数：
_sFileName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLogoOrder

public int getLogoOrder()
提取属性：LogoOrder

返回：
LogoOrder

setLogoOrder

public boolean setLogoOrder(int _nLogoOrder)
                     throws WCMException
设置属性：LogoOrder

参数：
_nLogoOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findOf

public static final Logo findOf(int _nHostType,
                                int _nHostId,
                                int _nIndex)
                         throws WCMException
获取指定对象的指定Logo

参数：
_nHostType -
_nHostId -
_nIndex -
返回：
抛出：
WCMException

findById

public static final Logo findById(int _nId)
                           throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Logo createNewInstance()
                                    throws WCMException
产生当前对象[Logo]的实例

返回：
当前对象的实例[Logo]
抛出：
WCMException

findByKey

public static final Logo findByKey(java.lang.Object _oKey)
                            throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Logos

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.logo
类 Logos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.publish.logo.Logos

public class Logos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Logos(User _currUser)
构造函数
Logos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Logos | createNewInstance(User _currUser) 产生当前集合对象[Logos]的实例
static Logos | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Logos | findOf(User _currUser, int _nHostType, int _nHostId, WCMFilter _filter) 获取指定对象的指定Logo集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Logos | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Logos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Logos

public Logos(User _currUser)
构造函数

另请参见：
Logos( User _currUser, int _initCapacity, int _incCapacity );

Logos

public Logos(User _currUser,
             int _initCapacity,
             int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findOf

public static final Logos findOf(User _currUser,
                                 int _nHostType,
                                 int _nHostId,
                                 WCMFilter _filter)
                          throws WCMException
获取指定对象的指定Logo集合

参数：
_currUser -
_nHostType -
_nHostId -
_filter -
返回：
抛出：
WCMException

findByIds

public static final Logos findByIds(User _currUser,
                                    java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Logos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Logos openWCMObjs(User _currUser,
                                      WCMFilter _filter)
                               throws WCMException
通过指定一个Filter获取当前集合[Logos]

参数：
_filter - 指定的Filter
返回：
当前集合[Logos]
抛出：
WCMException

createNewInstance

public static Logos createNewInstance(User _currUser)
产生当前集合对象[Logos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.publish.logo
类
Logo
Logos


com.trs.components.wcm.publish.logo

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.publish.logo

类摘要
Logo
Logos


com.trs.components.wcm.publish.logo 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.logo 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.publish.logo.Logo
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.publish.logo.Logos


软件包 com.trs.components.wcm.publish.logo 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.logo
的使用

使用 com.trs.components.wcm.publish.logo 的软件包
com.trs.components.wcm.publish.logo

com.trs.components.wcm.publish.logo 使用的 com.trs.components.wcm.publish.logo 中的类
Logo
Logos

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.logo.Logo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.logo.Logo
的使用

使用 Logo 的软件包
com.trs.components.wcm.publish.logo

com.trs.components.wcm.publish.logo 中 Logo 的使用

返回 Logo 的 com.trs.components.wcm.publish.logo 中的方法
static Logo | Logo.createNewInstance() 产生当前对象[Logo]的实例
static Logo | Logo.findById(int _nId) 提取指定ID的对象
static Logo | Logo.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static Logo | Logo.findOf(int _nHostType, int _nHostId, int _nIndex) 获取指定对象的指定Logo

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.logo.Logos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.logo.Logos
的使用

使用 Logos 的软件包
com.trs.components.wcm.publish.logo

com.trs.components.wcm.publish.logo 中 Logos 的使用

返回 Logos 的 com.trs.components.wcm.publish.logo 中的方法
static Logos | Logos.createNewInstance(User _currUser) 产生当前集合对象[Logos]的实例
static Logos | Logos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Logos | Logos.findOf(User _currUser, int _nHostType, int _nHostId, WCMFilter _filter) 获取指定对象的指定Logo集合
static Logos | Logos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Logos]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CellInfo

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 CellInfo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.publish.region.CellInfo
所有已实现的接口：
java.lang.Cloneable
public class CellInfo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
CellInfo()
构造函数：保留默认接口
方法摘要
static CellInfo | createNewInstance() 产生当前对象[CellInfo]的实例
static CellInfo | findById(int _nId) 提取指定ID的对象
static CellInfo | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
int | getAppendixId() 提取属性：APPENDIXID
int | getCellIndex() 提取属性：CellIndex
int | getChnlId() 提取属性：CHNLID
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getDocId() 提取属性：DocId
java.lang.String | getDocTitle() 提取属性：DocTitle
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getRegionInfoId() 提取属性：RegionInfoId
int | getRowIndex() 提取属性：RowIndex
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setAppendixId(int _nAppendixId) 设置属性：APPENDIXID
boolean | setCellIndex(int _nCellIndex) 设置属性：CellIndex
boolean | setChnlId(int _nChnlId) 设置属性：CHNLID
boolean | setDocId(int _nDocId) 设置属性：DocId
boolean | setDocTitle(java.lang.String _sDocTitle) 设置属性：DocTitle
boolean | setRegionInfoId(int _nRegionInfoId) 设置属性：RegionInfoId
boolean | setRowIndex(int _nRowIndex) 设置属性：RowIndex
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

CellInfo

public CellInfo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getDocId

public int getDocId()
提取属性：DocId

返回：
DocId

setDocId

public boolean setDocId(int _nDocId)
                 throws WCMException
设置属性：DocId

参数：
_nDocId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDocTitle

public java.lang.String getDocTitle()
提取属性：DocTitle

返回：
DocTitle

setDocTitle

public boolean setDocTitle(java.lang.String _sDocTitle)
                    throws WCMException
设置属性：DocTitle

参数：
_sDocTitle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAppendixId

public int getAppendixId()
提取属性：APPENDIXID

返回：
APPENDIXID

setAppendixId

public boolean setAppendixId(int _nAppendixId)
                      throws WCMException
设置属性：APPENDIXID

抛出：
WCMException

setChnlId

public boolean setChnlId(int _nChnlId)
                  throws WCMException
设置属性：CHNLID

抛出：
WCMException

getChnlId

public int getChnlId()
提取属性：CHNLID

返回：
CHNLID

getRegionInfoId

public int getRegionInfoId()
提取属性：RegionInfoId

返回：
RegionInfoId

setRegionInfoId

public boolean setRegionInfoId(int _nRegionInfoId)
                        throws WCMException
设置属性：RegionInfoId

参数：
_nRegionInfoId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRowIndex

public int getRowIndex()
提取属性：RowIndex

返回：
RowIndex

setRowIndex

public boolean setRowIndex(int _nRowIndex)
                    throws WCMException
设置属性：RowIndex

参数：
_nRowIndex - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCellIndex

public int getCellIndex()
提取属性：CellIndex

返回：
CellIndex

setCellIndex

public boolean setCellIndex(int _nCellIndex)
                     throws WCMException
设置属性：CellIndex

参数：
_nCellIndex - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final CellInfo findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final CellInfo createNewInstance()
                                        throws WCMException
产生当前对象[CellInfo]的实例

返回：
当前对象的实例[CellInfo]
抛出：
WCMException

findByKey

public static final CellInfo findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CellInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 CellInfos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.publish.region.CellInfos

public class CellInfos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
CellInfos(User _currUser)
构造函数
CellInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static CellInfos | createNewInstance(User _currUser) 产生当前集合对象[CellInfos]的实例
static CellInfos | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static CellInfos | findCellInfos(RegionInfo _regionInfo, WCMFilter _filter) 获取指定区域中所有的单元格，默认按照行、列排序
static CellInfos | findCellInfos(RegionInfo _regionInfo, WCMFilter _filter, User _currUser) 获取指定区域中所有的单元格，默认按照行、列排序.
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static CellInfos | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[CellInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CellInfos

public CellInfos(User _currUser)
构造函数

另请参见：
CellInfos( User _currUser, int _initCapacity, int _incCapacity );

CellInfos

public CellInfos(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final CellInfos findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（CellInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final CellInfos openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[CellInfos]

参数：
_filter - 指定的Filter
返回：
当前集合[CellInfos]
抛出：
WCMException

createNewInstance

public static CellInfos createNewInstance(User _currUser)
产生当前集合对象[CellInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findCellInfos

public static final CellInfos findCellInfos(RegionInfo _regionInfo,
                                            WCMFilter _filter)
                                     throws WCMException
获取指定区域中所有的单元格，默认按照行、列排序

参数：
_regionInfo -
_filter -
返回：
抛出：
WCMException

findCellInfos

public static final CellInfos findCellInfos(RegionInfo _regionInfo,
                                            WCMFilter _filter,
                                            User _currUser)
                                     throws WCMException
获取指定区域中所有的单元格，默认按照行、列排序. 之所以添加一个用户作为参数，是由于返回的集合对象，在服务器层可能执行删除

参数：
_regionInfo -
_filter -
_currUser -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CellServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 CellServiceProvider

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.CellServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class CellServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

作者：
Administrator

构造方法摘要
CellServiceProvider()
方法摘要
void | delete(MethodContext _oContext)
java.lang.Object | findById(MethodContext _oContext)
java.lang.Object | findByIds(MethodContext _oContext)
java.lang.Object | query(MethodContext _oContext)
int | save(MethodContext _oContext)
void | saveCells(MethodContext _oContext) 保存指定导读的所有单元格信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CellServiceProvider

public CellServiceProvider()
方法详细信息

delete

public void delete(MethodContext _oContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _oContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _oContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

saveCells

public void saveCells(MethodContext _oContext)
               throws java.lang.Throwable
保存指定导读的所有单元格信息

参数：
_oContext -
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _oContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _oContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CellsSaveListenerForPublish

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 CellsSaveListenerForPublish

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.CellsSaveListenerForPublish
所有已实现的接口：
IServiceListener
public class CellsSaveListenerForPublish
extends java.lang.Object
implements IServiceListener

构造方法摘要
CellsSaveListenerForPublish()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CellsSaveListenerForPublish

public CellsSaveListenerForPublish()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig listenerConfig,
                                 MethodContext methodContext,
                                 java.lang.Object serviceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
listenerConfig - 当前Lisntener的设置对象
methodContext - 执行服务的当前上下文参数
serviceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelDocListenerForPublish

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 ChannelDocListenerForPublish

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.ChannelDocListenerForPublish
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class ChannelDocListenerForPublish
extends java.lang.Object
implements IObjectLCListenerOnModify

构造方法摘要
ChannelDocListenerForPublish()
方法摘要
 void notifyOnModifyObj(BaseObj objModified, int eventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelDocListenerForPublish

public ChannelDocListenerForPublish()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelListenerForPublish

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 ChannelListenerForPublish

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.ChannelListenerForPublish
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ChannelListenerForPublish
extends java.lang.Object
implements IObjectLCListenerOnModify, IObjectLCListenerOnDel

构造方法摘要
ChannelListenerForPublish()
方法摘要
void | notifyOnDelObj(BaseObj objDeleted, int eventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj objModified, int eventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelListenerForPublish

public ChannelListenerForPublish()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj objDeleted,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
objDeleted - 被删除的对象
eventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentListenerForPublish

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 DocumentListenerForPublish

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.DocumentListenerForPublish
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class DocumentListenerForPublish
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

构造方法摘要
DocumentListenerForPublish()
方法摘要
void | notifyOnDelObj(BaseObj obj, int eventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj objModified, int eventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentListenerForPublish

public DocumentListenerForPublish()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj obj,
                           int eventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
obj - 被删除的对象
eventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj objModified,
                              int eventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
objModified - 被修改的对象
eventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.publish.region
类
CellInfo
CellInfos
CellServiceProvider
CellsSaveListenerForPublish
ChannelDocListenerForPublish
ChannelListenerForPublish
DocumentListenerForPublish
RegionEmploy
RegionEmployMgr
RegionEmploys
RegionEmployServiceProvider
RegionInfo
RegionInfos
RegionServiceProvider
TemplateSaveListenerForRegionEmploy
WCMTagParserRegion


com.trs.components.wcm.publish.region

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.publish.region

类摘要
CellInfo
CellInfos
CellServiceProvider
CellsSaveListenerForPublish
ChannelDocListenerForPublish
ChannelListenerForPublish
DocumentListenerForPublish
RegionEmploy
RegionEmployMgr
RegionEmploys
RegionEmployServiceProvider
RegionInfo
RegionInfos
RegionServiceProvider
TemplateSaveListenerForRegionEmploy
WCMTagParserRegion


com.trs.components.wcm.publish.region 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.region 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.publish.region.CellInfo
        • com.trs.components.wcm.publish.region.RegionEmploy
        • com.trs.components.wcm.publish.region.RegionInfo
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.publish.region.CellInfos
        • com.trs.components.wcm.publish.region.RegionEmploys
        • com.trs.components.wcm.publish.region.RegionInfos
    • com.trs.components.wcm.publish.region.CellServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.publish.region.CellsSaveListenerForPublish (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.wcm.publish.region.ChannelDocListenerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.region.ChannelListenerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.region.DocumentListenerForPublish (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.components.wcm.publish.region.RegionEmployMgr
    • com.trs.components.wcm.publish.region.RegionEmployServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.publish.region.RegionServiceProvider (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.components.wcm.publish.region.TemplateSaveListenerForRegionEmploy (implements com.trs.webframework.provider.IServiceListener)
    • com.trs.components.wcm.publish.region.WCMTagParserRegion (implements com.trs.components.common.publish.domain.tagparser.ITagParser)


软件包 com.trs.components.wcm.publish.region 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.region
的使用

使用 com.trs.components.wcm.publish.region 的软件包
com.trs.components.wcm.publish.region

com.trs.components.wcm.publish.region 使用的 com.trs.components.wcm.publish.region 中的类
CellInfo
CellInfos
RegionEmploy
RegionEmploys
RegionInfo
RegionInfos

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RegionEmploy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 RegionEmploy

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.publish.region.RegionEmploy
所有已实现的接口：
java.lang.Cloneable
public class RegionEmploy
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
RegionEmploy()
构造函数：保留默认接口
方法摘要
static RegionEmploy | createNewInstance() 产生当前对象[RegionEmploy]的实例
static RegionEmploy | findById(int _nId) 提取指定ID的对象
static RegionEmploy | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getEmployType() 提取属性：EmployType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getObjId() 提取属性：ObjId
int | getObjType() 提取属性：ObjType
int | getRegionEmployId() 提取属性：RegionEmployId
int | getRegionId() 提取属性：RegionId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setEmployType(int _nEmployType) 设置属性：EmployType
boolean | setObjId(int _nObjId) 设置属性：ObjId
boolean | setObjType(int _nObjType) 设置属性：ObjType
boolean | setRegionEmployId(int _nRegionEmployId) 设置属性：RegionEmployId
boolean | setRegionId(int _nRegionId) 设置属性：RegionId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

RegionEmploy

public RegionEmploy()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getRegionEmployId

public int getRegionEmployId()
提取属性：RegionEmployId

返回：
RegionEmployId

setRegionEmployId

public boolean setRegionEmployId(int _nRegionEmployId)
                          throws WCMException
设置属性：RegionEmployId

参数：
_nRegionEmployId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRegionId

public int getRegionId()
提取属性：RegionId

返回：
RegionId

setRegionId

public boolean setRegionId(int _nRegionId)
                    throws WCMException
设置属性：RegionId

参数：
_nRegionId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

public int getObjId()
提取属性：ObjId

返回：
ObjId

setObjId

public boolean setObjId(int _nObjId)
                 throws WCMException
设置属性：ObjId

参数：
_nObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjType

public int getObjType()
提取属性：ObjType

返回：
ObjType

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
设置属性：ObjType

参数：
_nObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEmployType

public int getEmployType()
提取属性：EmployType

返回：
EmployType

setEmployType

public boolean setEmployType(int _nEmployType)
                      throws WCMException
设置属性：EmployType

参数：
_nEmployType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final RegionEmploy findById(int _nId)
                                   throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final RegionEmploy createNewInstance()
                                            throws WCMException
产生当前对象[RegionEmploy]的实例

返回：
当前对象的实例[RegionEmploy]
抛出：
WCMException

findByKey

public static final RegionEmploy findByKey(java.lang.Object _oKey)
                                    throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegionEmployMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 RegionEmployMgr

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.RegionEmployMgr

public class RegionEmployMgr
extends java.lang.Object

作者：
lhm 导读配置使用关系业务逻辑

构造方法摘要
RegionEmployMgr()
方法摘要
RegionEmploy | findRegionEmployByInfo(int _regionId, int _objId, int _objType) 根据当前参数唯一返回一条记录信息
RegionEmploys | getRegionEmploysByObj(int _objId, int _objType) 根据配置对象返回配置关系
RegionEmploys | getRegionEmploysByRegion(RegionInfo _region) 根据导读返回导读配置信息
RegionEmploys | getRegionEmploysByRegionAndType(int _regionId, int[] _objTypes)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RegionEmployMgr

public RegionEmployMgr()
方法详细信息

findRegionEmployByInfo

public RegionEmploy findRegionEmployByInfo(int _regionId,
                                           int _objId,
                                           int _objType)
                                    throws WCMException
根据当前参数唯一返回一条记录信息

参数：
_regionId -
_objId -
_objType -
_employType -
返回：
RegionEmploy
抛出：
WCMException

getRegionEmploysByRegionAndType

public RegionEmploys getRegionEmploysByRegionAndType(int _regionId,
                                                     int[] _objTypes)
                                              throws WCMException
参数：
_regionId -
_objTypes -
返回：
抛出：
WCMException

getRegionEmploysByObj

public RegionEmploys getRegionEmploysByObj(int _objId,
                                           int _objType)
                                    throws WCMException
根据配置对象返回配置关系

参数：
_objId -
_objType -
_employType -
返回：
RegionEmploys
抛出：
WCMException

getRegionEmploysByRegion

public RegionEmploys getRegionEmploysByRegion(RegionInfo _region)
                                       throws WCMException
根据导读返回导读配置信息

参数：
_region -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegionEmploys

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 RegionEmploys

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.publish.region.RegionEmploys

public class RegionEmploys
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
RegionEmploys(User _currUser)
构造函数
RegionEmploys(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static RegionEmploys | createNewInstance(User _currUser) 产生当前集合对象[RegionEmploys]的实例
static RegionEmploys | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static RegionEmploys | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RegionEmploys]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RegionEmploys

public RegionEmploys(User _currUser)
构造函数

另请参见：
RegionEmploys( User _currUser, int _initCapacity, int _incCapacity );

RegionEmploys

public RegionEmploys(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final RegionEmploys findByIds(User _currUser,
                                            java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（RegionEmploys）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final RegionEmploys openWCMObjs(User _currUser,
                                              WCMFilter _filter)
                                       throws WCMException
通过指定一个Filter获取当前集合[RegionEmploys]

参数：
_filter - 指定的Filter
返回：
当前集合[RegionEmploys]
抛出：
WCMException

createNewInstance

public static RegionEmploys createNewInstance(User _currUser)
产生当前集合对象[RegionEmploys]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegionEmployServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 RegionEmployServiceProvider

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.RegionEmployServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class RegionEmployServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

构造方法摘要
RegionEmployServiceProvider()
方法摘要
void | delete(MethodContext context)
java.lang.Object | findById(MethodContext context)
java.lang.Object | findByIds(MethodContext context)
java.lang.Object | query(MethodContext context)
int | save(MethodContext context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RegionEmployServiceProvider

public RegionEmployServiceProvider()
方法详细信息

delete

public void delete(MethodContext context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegionInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 RegionInfo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.publish.region.RegionInfo
所有已实现的接口：
java.lang.Cloneable
public class RegionInfo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
RegionInfo()
构造函数：保留默认接口
方法摘要
static RegionInfo | createNewInstance() 产生当前对象[RegionInfo]的实例
static RegionInfo | findByChannelId(int _nChannelId, int _nIndex) 获取指定栏目指定位置的Region
static RegionInfo | findByChannelId(int _nChannelId, java.lang.String _sName) 获取指定栏目指定名称的Region
static RegionInfo | findById(int _nId) 提取指定ID的对象
static RegionInfo | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static RegionInfo | findByName(java.lang.String _sName) 获取指定名称的Region
static RegionInfo | findBySiteId(int _nSiteId, int _nIndex) 获取指定站点指定位置的Region
static RegionInfo | findBySiteId(int _nSiteId, java.lang.String _sName) 获取指定站点指定名称的Region
int | getCellNum() 提取属性：CellNum
int | getChannelId() 提取属性：ChannelId
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getName() 提取属性：Name
int | getRowNumber() 提取属性：ROWNUMBER
int | getWCMType() 取得该对象的类型编号
int | getWebSiteId() 提取属性：ChannelId
int | getWidth() 提取属性：Width
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setCellNum(int _nCellNum) 设置属性：CellNum
boolean | setChannelId(int _nChannelId) 设置属性：ChannelId
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setRowNumber(int _nRowNumber) 设置属性：ROWNUMBER
boolean | setWebSiteId(int _nWebSiteId) 设置属性：ChannelId
boolean | setWidth(int _nWidth) 设置属性：Width
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

RegionInfo

public RegionInfo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getChannelId

public int getChannelId()
提取属性：ChannelId

返回：
ChannelId

setWebSiteId

public boolean setWebSiteId(int _nWebSiteId)
                     throws WCMException
设置属性：ChannelId

参数：
_nChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWebSiteId

public int getWebSiteId()
提取属性：ChannelId

返回：
ChannelId

setChannelId

public boolean setChannelId(int _nChannelId)
                     throws WCMException
设置属性：ChannelId

参数：
_nChannelId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWidth

public int getWidth()
提取属性：Width

返回：
Width

setWidth

public boolean setWidth(int _nWidth)
                 throws WCMException
设置属性：Width

参数：
_nWidth - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRowNumber

public int getRowNumber()
提取属性：ROWNUMBER

返回：
ROWNUMBER

setRowNumber

public boolean setRowNumber(int _nRowNumber)
                     throws WCMException
设置属性：ROWNUMBER

参数：
_nRowNumber - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCellNum

public int getCellNum()
提取属性：CellNum

返回：
CellNum

setCellNum

public boolean setCellNum(int _nCellNum)
                   throws WCMException
设置属性：CellNum

参数：
_nCellNum - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final RegionInfo findById(int _nId)
                                 throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final RegionInfo createNewInstance()
                                          throws WCMException
产生当前对象[RegionInfo]的实例

返回：
当前对象的实例[RegionInfo]
抛出：
WCMException

findByKey

public static final RegionInfo findByKey(java.lang.Object _oKey)
                                  throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByChannelId

public static final RegionInfo findByChannelId(int _nChannelId,
                                               int _nIndex)
                                        throws WCMException
获取指定栏目指定位置的Region

参数：
_nId -
返回：
抛出：
WCMException

findByChannelId

public static final RegionInfo findByChannelId(int _nChannelId,
                                               java.lang.String _sName)
                                        throws WCMException
获取指定栏目指定名称的Region

参数：
_nChannelId -
_sName -
返回：
抛出：
WCMException

findBySiteId

public static final RegionInfo findBySiteId(int _nSiteId,
                                            int _nIndex)
                                     throws WCMException
获取指定站点指定位置的Region

参数：
_nId -
返回：
抛出：
WCMException

findBySiteId

public static final RegionInfo findBySiteId(int _nSiteId,
                                            java.lang.String _sName)
                                     throws WCMException
获取指定站点指定名称的Region

参数：
_nSiteId -
_sName -
返回：
抛出：
WCMException

findByName

public static final RegionInfo findByName(java.lang.String _sName)
                                   throws WCMException
获取指定名称的Region

参数：
_nSiteId -
_sName -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegionInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 RegionInfos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.publish.region.RegionInfos

public class RegionInfos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
RegionInfos(User _currUser)
构造函数
RegionInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static RegionInfos | createNewInstance(User _currUser) 产生当前集合对象[RegionInfos]的实例
static RegionInfos | findByChannelId(int _nChannelId) 查询指定栏目的导读
static RegionInfos | findByChannelId(int _nChannelId, WCMFilter _filter)
static RegionInfos | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static RegionInfos | findBySiteId(int _nWebSiteId, WCMFilter _filter)
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static RegionInfos | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RegionInfos]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RegionInfos

public RegionInfos(User _currUser)
构造函数

另请参见：
RegionInfos( User _currUser, int _initCapacity, int _incCapacity );

RegionInfos

public RegionInfos(User _currUser,
                   int _initCapacity,
                   int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final RegionInfos findByIds(User _currUser,
                                          java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（RegionInfos）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final RegionInfos openWCMObjs(User _currUser,
                                            WCMFilter _filter)
                                     throws WCMException
通过指定一个Filter获取当前集合[RegionInfos]

参数：
_filter - 指定的Filter
返回：
当前集合[RegionInfos]
抛出：
WCMException

createNewInstance

public static RegionInfos createNewInstance(User _currUser)
产生当前集合对象[RegionInfos]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByChannelId

public static final RegionInfos findByChannelId(int _nChannelId)
                                         throws WCMException
查询指定栏目的导读

参数：
_nChannelId -
返回：
抛出：
WCMException

findByChannelId

public static final RegionInfos findByChannelId(int _nChannelId,
                                                WCMFilter _filter)
                                         throws WCMException
抛出：
WCMException

findBySiteId

public static final RegionInfos findBySiteId(int _nWebSiteId,
                                             WCMFilter _filter)
                                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegionServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 RegionServiceProvider

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.RegionServiceProvider
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public class RegionServiceProvider
extends java.lang.Object
implements IGlueServiceProvider

作者：
Administrator

构造方法摘要
RegionServiceProvider()
方法摘要
void | delete(MethodContext _oContext)
boolean | existsSimilarName(MethodContext _oContext) 判断该名称的导读是否已经存在
java.lang.Object | findById(MethodContext _oContext)
java.lang.Object | findByIds(MethodContext _oContext)
java.lang.Object | query(MethodContext _oContext)
int | save(MethodContext _oContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RegionServiceProvider

public RegionServiceProvider()
方法详细信息

delete

public void delete(MethodContext _oContext)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _oContext)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

save

public int save(MethodContext _oContext)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

existsSimilarName

public boolean existsSimilarName(MethodContext _oContext)
                          throws java.lang.Throwable
判断该名称的导读是否已经存在

参数：
_oContext -
返回：
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _oContext)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _oContext)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateSaveListenerForRegionEmploy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 TemplateSaveListenerForRegionEmploy

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.TemplateSaveListenerForRegionEmploy
所有已实现的接口：
IServiceListener
public class TemplateSaveListenerForRegionEmploy
extends java.lang.Object
implements IServiceListener

构造方法摘要
TemplateSaveListenerForRegionEmploy()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateSaveListenerForRegionEmploy

public TemplateSaveListenerForRegionEmploy()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig listenerConfig,
                                 MethodContext methodContext,
                                 java.lang.Object serviceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
listenerConfig - 当前Lisntener的设置对象
methodContext - 执行服务的当前上下文参数
serviceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserRegion

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.region
类 WCMTagParserRegion

java.lang.Object
    继承者  com.trs.components.wcm.publish.region.WCMTagParserRegion
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserRegion
extends java.lang.Object
implements ITagParser

作者：
Administrator

构造方法摘要
WCMTagParserRegion()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _o_root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserRegion

public WCMTagParserRegion()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _o_root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_o_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.publish.region.CellInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.CellInfo
的使用

使用 CellInfo 的软件包
com.trs.components.wcm.publish.region

com.trs.components.wcm.publish.region 中 CellInfo 的使用

返回 CellInfo 的 com.trs.components.wcm.publish.region 中的方法
static CellInfo | CellInfo.createNewInstance() 产生当前对象[CellInfo]的实例
static CellInfo | CellInfo.findById(int _nId) 提取指定ID的对象
static CellInfo | CellInfo.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.CellInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.CellInfos
的使用

使用 CellInfos 的软件包
com.trs.components.wcm.publish.region

com.trs.components.wcm.publish.region 中 CellInfos 的使用

返回 CellInfos 的 com.trs.components.wcm.publish.region 中的方法
static CellInfos | CellInfos.createNewInstance(User _currUser) 产生当前集合对象[CellInfos]的实例
static CellInfos | CellInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static CellInfos | CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter) 获取指定区域中所有的单元格，默认按照行、列排序
static CellInfos | CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter, User _currUser) 获取指定区域中所有的单元格，默认按照行、列排序.
static CellInfos | CellInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[CellInfos]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.CellServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.CellServiceProvider
的使用

没有 com.trs.components.wcm.publish.region.CellServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.CellsSaveListenerForPublish 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.CellsSaveListenerForPublish
的使用

没有 com.trs.components.wcm.publish.region.CellsSaveListenerForPublish 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.ChannelDocListenerForPublish 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.ChannelDocListenerForPublish
的使用

没有 com.trs.components.wcm.publish.region.ChannelDocListenerForPublish 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.ChannelListenerForPublish 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.ChannelListenerForPublish
的使用

没有 com.trs.components.wcm.publish.region.ChannelListenerForPublish 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.DocumentListenerForPublish 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.DocumentListenerForPublish
的使用

没有 com.trs.components.wcm.publish.region.DocumentListenerForPublish 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.RegionEmploy 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.RegionEmploy
的使用

使用 RegionEmploy 的软件包
com.trs.components.wcm.publish.region

com.trs.components.wcm.publish.region 中 RegionEmploy 的使用

返回 RegionEmploy 的 com.trs.components.wcm.publish.region 中的方法
static RegionEmploy | RegionEmploy.createNewInstance() 产生当前对象[RegionEmploy]的实例
static RegionEmploy | RegionEmploy.findById(int _nId) 提取指定ID的对象
static RegionEmploy | RegionEmploy.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
RegionEmploy | RegionEmployMgr.findRegionEmployByInfo(int _regionId, int _objId, int _objType) 根据当前参数唯一返回一条记录信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.RegionEmployMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.RegionEmployMgr
的使用

没有 com.trs.components.wcm.publish.region.RegionEmployMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.RegionEmploys 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.RegionEmploys
的使用

使用 RegionEmploys 的软件包
com.trs.components.wcm.publish.region

com.trs.components.wcm.publish.region 中 RegionEmploys 的使用

返回 RegionEmploys 的 com.trs.components.wcm.publish.region 中的方法
static RegionEmploys | RegionEmploys.createNewInstance(User _currUser) 产生当前集合对象[RegionEmploys]的实例
static RegionEmploys | RegionEmploys.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
RegionEmploys | RegionEmployMgr.getRegionEmploysByObj(int _objId, int _objType) 根据配置对象返回配置关系
RegionEmploys | RegionEmployMgr.getRegionEmploysByRegion(RegionInfo _region) 根据导读返回导读配置信息
RegionEmploys | RegionEmployMgr.getRegionEmploysByRegionAndType(int _regionId, int[] _objTypes)
static RegionEmploys | RegionEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RegionEmploys]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.RegionEmployServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.RegionEmployServiceProvider
的使用

没有 com.trs.components.wcm.publish.region.RegionEmployServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.RegionInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.RegionInfo
的使用

使用 RegionInfo 的软件包
com.trs.components.wcm.publish.region

com.trs.components.wcm.publish.region 中 RegionInfo 的使用

返回 RegionInfo 的 com.trs.components.wcm.publish.region 中的方法
static RegionInfo | RegionInfo.createNewInstance() 产生当前对象[RegionInfo]的实例
static RegionInfo | RegionInfo.findByChannelId(int _nChannelId, int _nIndex) 获取指定栏目指定位置的Region
static RegionInfo | RegionInfo.findByChannelId(int _nChannelId, java.lang.String _sName) 获取指定栏目指定名称的Region
static RegionInfo | RegionInfo.findById(int _nId) 提取指定ID的对象
static RegionInfo | RegionInfo.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static RegionInfo | RegionInfo.findByName(java.lang.String _sName) 获取指定名称的Region
static RegionInfo | RegionInfo.findBySiteId(int _nSiteId, int _nIndex) 获取指定站点指定位置的Region
static RegionInfo | RegionInfo.findBySiteId(int _nSiteId, java.lang.String _sName) 获取指定站点指定名称的Region

参数类型为 RegionInfo 的 com.trs.components.wcm.publish.region 中的方法
static CellInfos | CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter) 获取指定区域中所有的单元格，默认按照行、列排序
static CellInfos | CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter, User _currUser) 获取指定区域中所有的单元格，默认按照行、列排序.
RegionEmploys | RegionEmployMgr.getRegionEmploysByRegion(RegionInfo _region) 根据导读返回导读配置信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.RegionInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.RegionInfos
的使用

使用 RegionInfos 的软件包
com.trs.components.wcm.publish.region

com.trs.components.wcm.publish.region 中 RegionInfos 的使用

返回 RegionInfos 的 com.trs.components.wcm.publish.region 中的方法
static RegionInfos | RegionInfos.createNewInstance(User _currUser) 产生当前集合对象[RegionInfos]的实例
static RegionInfos | RegionInfos.findByChannelId(int _nChannelId) 查询指定栏目的导读
static RegionInfos | RegionInfos.findByChannelId(int _nChannelId, WCMFilter _filter)
static RegionInfos | RegionInfos.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static RegionInfos | RegionInfos.findBySiteId(int _nWebSiteId, WCMFilter _filter)
static RegionInfos | RegionInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RegionInfos]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.RegionServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.RegionServiceProvider
的使用

没有 com.trs.components.wcm.publish.region.RegionServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.TemplateSaveListenerForRegionEmploy 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.TemplateSaveListenerForRegionEmploy
的使用

没有 com.trs.components.wcm.publish.region.TemplateSaveListenerForRegionEmploy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.region.WCMTagParserRegion 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.region.WCMTagParserRegion
的使用

没有 com.trs.components.wcm.publish.region.WCMTagParserRegion 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseWCMTagParserPreNextDocuments

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 BaseWCMTagParserPreNextDocuments

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
直接已知子类：
WCMTagParserNextDocuments, WCMTagParserPreDocuments
public abstract class BaseWCMTagParserPreNextDocuments
extends BaseTagParser4List

字段摘要
static java.util.ArrayList | FIELDS_DEFAULT_LIST
static java.util.HashMap | FIELDS_MAP
static int | MODE_NEXT
static int | MODE_PRE
构造方法摘要
BaseWCMTagParserPreNextDocuments()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FIELDS_DEFAULT_LIST

public static java.util.ArrayList FIELDS_DEFAULT_LIST

FIELDS_MAP

public static java.util.HashMap FIELDS_MAP

MODE_PRE

public static final int MODE_PRE
另请参见：
常量字段值

MODE_NEXT

public static final int MODE_NEXT
另请参见：
常量字段值
构造方法详细信息

BaseWCMTagParserPreNextDocuments

public BaseWCMTagParserPreNextDocuments()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentsTemp

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 DocumentsTemp

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.DocumentsTemp

public class DocumentsTemp
extends java.lang.Object

构造方法摘要
DocumentsTemp()
方法摘要
 void publishDocuments(javax.servlet.http.HttpSession session, javax.servlet.jsp.JspWriter out, int nYear, int nStartDocId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentsTemp

public DocumentsTemp()
方法详细信息

publishDocuments

public void publishDocuments(javax.servlet.http.HttpSession session,
                             javax.servlet.jsp.JspWriter out,
                             int nYear,
                             int nStartDocId)
                      throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishTaskDocumentsCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
接口 IPublishTaskDocumentsCacheMgr

所有已知实现类：
PublishTaskDocumentsCacheMgr
public interface IPublishTaskDocumentsCacheMgr

方法摘要
Documents | get(IPublishFolder _folder, WCMFilter _filter)
void | put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments) 将Folder根据Filter获取到的Documents缓存起来

方法详细信息

put

void put(IPublishFolder _folder,
         WCMFilter _filter,
         Documents _oDocuments)
         throws WCMException
将Folder根据Filter获取到的Documents缓存起来

参数：
_folder - 指定的Folder
_filter - 当前的Filter
_oDocuments - 返回的文档
抛出：
WCMException

get

Documents get(IPublishFolder _folder,
              WCMFilter _filter)
              throws WCMException
参数：
_folder -
_filter -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.publish.tagparser
接口
IPublishTaskDocumentsCacheMgr
类
BaseWCMTagParserPreNextDocuments
DocumentsTemp
PublishTaskDocumentsCacheMgr
RollDocumentsChannelsFinder
TagChannelChainParser
TagDocbakParser
TagParserCRUser
TagParserWmlImage
TagParserWmlImages
TagWmlContentParser
WCMAppendixGenerator
WCMTagParser4FolderHostBase
WCMTagParser4ObjsInChannelBase
WCMTagParserAppendix
WCMTagParserChannel
WCMTagParserChannelLogo
WCMTagParserChannels
WCMTagParserCurPage
WCMTagParserDefaultObjectsInChannel
WCMTagParserDefaultObjectsInChannelBase
WCMTagParserDocReply
WCMTagParserDocument
WCMTagParserDocumentChannels
WCMTagParserDocumentForBJGOV
WCMTagParserDocumentLogo
WCMTagParserDocuments
WCMTagParserEPressNews
WCMTagParserHelper
WCMTagParserIcon
WCMTagParserLogoBase
WCMTagParserMapArea
WCMTagParserNextDocuments
WCMTagParserPreDocuments
WCMTagParserPrev
WCMTagParserRelNews
WCMTagParserReplace
WCMTagParserRollDocuments
WCMTagparserTopIcon
WCMTagParserWebSite
WCMTagParserWebSites
WCMTagParserXDcouments
WCMTagParserXDocument
WCMTemplateChildIndexAnalyer
XTagParserObjsInChannelBase
XWCMContImgTagParser
XWCMFileAppendixTagParser
XWCMImageAppendixTagParser
XWCMTagParserPageGeneration


com.trs.components.wcm.publish.tagparser

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.publish.tagparser

接口摘要
IPublishTaskDocumentsCacheMgr

类摘要
BaseWCMTagParserPreNextDocuments |
DocumentsTemp |
PublishTaskDocumentsCacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: WCM指定Folder文档集合在一次发布任务中的缓冲对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RollDocumentsChannelsFinder |
TagChannelChainParser | Title: TRS 内容协作平台（TRS WCM） Description: 获取栏目父子链属性 Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagDocbakParser |
TagParserCRUser | Title: TRS 内容协作平台（TRS WCM） Description: 创建者属性发布置标 Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagParserWmlImage | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagParserWmlImages | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagWmlContentParser | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
WCMAppendixGenerator | Title: TRS 内容协作平台（TRS WCM） Description: helper for WCM tag parser Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParser4FolderHostBase | Title: TRS 内容协作平台（TRS WCM） Description: base implementation of tag parser for channel host in WCM Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParser4ObjsInChannelBase | Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_*** [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_***> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserAppendix | Title: TRS 内容协作平台（TRS WCM） Description: TRS_APPENDIX解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserChannel | Title: TRS 内容协作平台（TRS WCM） Description: The Parser For TRS_CHANNEL Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserChannelLogo |
WCMTagParserChannels | Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_ALLCATA Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserCurPage | Title: TRS 内容协作平台（TRS WCM） Description: tag parser for <_TRSCURPAGE>.
WCMTagParserDefaultObjectsInChannel |
WCMTagParserDefaultObjectsInChannelBase |
WCMTagParserDocReply | Title: TRS 内容协作平台（TRS WCM） Description: 文档回复的发布置标解释器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocument | Title: TRS 内容协作平台（TRS WCM） Description: parser for Grammer: <TRS_COLUMN ID="字段名" [[NUM="最大长度" [TRUNCATEDFLAG="长度裁减标记"]] [DATEFORMAT="日期格式"][AUTOFORMAT="自动格式化"] [AUTOLINK="是否自动产生链接 "][TARGET="窗口目标"][EXTRA="扩展HTML内容"] ]>通用细览 </TRS_COLUMN> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocumentChannels |
WCMTagParserDocumentForBJGOV | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocumentLogo |
WCMTagParserDocuments | Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_OUTLINE> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserEPressNews | Title: TRS 内容协作平台（TRS WCM） Description: 电子报版面图 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserHelper | Title: TRS 内容协作平台（TRS WCM） Description: WCMTagParser解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserIcon | Title: TRS 内容协作平台（TRS WCM） Description: WCMTagParser For TRS_ICON Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserLogoBase |
WCMTagParserMapArea | Title: TRS 内容协作平台（TRS WCM） Description: 生成电子报map area相关信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserNextDocuments |
WCMTagParserPreDocuments |
WCMTagParserPrev | Title: TRS 内容协作平台（TRS WCM） Description: WCM TagParser For TRS_PREV Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserRelNews | Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_RELNEWS Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserReplace | Title: TRS 内容协作平台（TRS WCM） Description: WCM Tag Parser For TRS_REPLACE Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserRollDocuments |
WCMTagparserTopIcon | Title: TRS 内容协作平台（TRS WCM） Description: 置顶文档标识 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
WCMTagParserWebSite |
WCMTagParserWebSites |
WCMTagParserXDcouments | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WCMTagParserXDocument |
WCMTemplateChildIndexAnalyer |
XTagParserObjsInChannelBase | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XWCMContImgTagParser |
XWCMFileAppendixTagParser | Title: TRS 内容协作平台（TRS WCM） Description: 解析文档包含的文件附件：支持自定义文件名 Copyright: Copyright (c) 2009-2010 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XWCMImageAppendixTagParser | Title: TRS 内容协作平台（TRS WCM） Description: 解析文档包含的图片附件：支持图片自动缩放 Copyright: Copyright (c) 2009-2010 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XWCMTagParserPageGeneration |


com.trs.components.wcm.publish.tagparser 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.tagparser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.tagparser.BaseTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.domain.tagparser.BaseTagParser4List (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
        • com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects
          • com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects
            • com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase
              • com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannel
        • com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments
          • com.trs.components.wcm.publish.tagparser.WCMTagParserNextDocuments
          • com.trs.components.wcm.publish.tagparser.WCMTagParserPreDocuments
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentChannels
        • com.trs.components.wcm.publish.tagparser.WCMTagParserWebSites
      • com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase
        • com.trs.components.wcm.publish.tagparser.WCMTagParserChannelLogo
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentLogo
      • com.trs.components.wcm.publish.tagparser.XWCMContImgTagParser
    • com.trs.components.wcm.publish.tagparser.DocumentsTemp
    • com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr (implements com.trs.components.wcm.publish.tagparser.IPublishTaskDocumentsCacheMgr)
    • com.trs.components.wcm.publish.tagparser.RollDocumentsChannelsFinder
    • com.trs.components.wcm.publish.tagparser.TagChannelChainParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.common.publish.domain.tagparser.TagParserContentBase
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocument
          • com.trs.components.wcm.publish.tagparser.TagDocbakParser
          • com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentForBJGOV
        • com.trs.components.wcm.publish.tagparser.WCMTagParserXDocument
      • com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
        • com.trs.components.wcm.publish.tagparser.WCMTagParserChannel
        • com.trs.components.wcm.publish.tagparser.WCMTagParserWebSite
      • com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply
    • com.trs.components.wcm.publish.tagparser.TagParserCRUser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.TagParserWmlImage (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.TagParserWmlImages (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.TagWmlContentParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator
    • com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
        • com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
          • com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews
          • com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments
          • com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments
        • com.trs.components.wcm.publish.tagparser.XTagParserObjsInChannelBase
      • com.trs.components.wcm.publish.tagparser.WCMTagParserChannels (implements com.trs.components.common.publish.domain.tagparser.ITagParser4List)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserHelper
    • com.trs.components.wcm.publish.tagparser.WCMTagParserIcon (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserPrev (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews (implements com.trs.components.common.publish.domain.tagparser.ITagParser, com.trs.components.common.publish.domain.tagparser.ITagParser4List)
    • com.trs.components.wcm.publish.tagparser.WCMTagParserReplace (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer
    • com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration (implements com.trs.components.common.publish.domain.tagparser.ITagParser)

接口分层结构

  • com.trs.components.wcm.publish.tagparser.IPublishTaskDocumentsCacheMgr


软件包 com.trs.components.wcm.publish.tagparser 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.tagparser
的使用

使用 com.trs.components.wcm.publish.tagparser 的软件包
com.trs.components.wcm.epress
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.epress 使用的 com.trs.components.wcm.publish.tagparser 中的类
WCMTagParser4FolderHostBase
Title: TRS 内容协作平台（TRS WCM）
Description:
base implementation of tag parser for channel host in WCM
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParser4ObjsInChannelBase
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_OUTLINE
Grammer:
<TRS_*** [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"]
[AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"]
[AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_***> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocuments
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_OUTLINE
Grammer:
<TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"]
[AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"]
[AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_OUTLINE> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser 使用的 com.trs.components.wcm.publish.tagparser 中的类
BaseWCMTagParserPreNextDocuments
IPublishTaskDocumentsCacheMgr
WCMTagParser4FolderHostBase
Title: TRS 内容协作平台（TRS WCM）
Description:
base implementation of tag parser for channel host in WCM
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParser4ObjsInChannelBase
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_OUTLINE
Grammer:
<TRS_*** [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"]
[AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"]
[AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_***> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDefaultObjectsInChannelBase
WCMTagParserDocument
Title: TRS 内容协作平台（TRS WCM）
Description:
parser for
Grammer:
<TRS_COLUMN ID="字段名" [[NUM="最大长度" [TRUNCATEDFLAG="长度裁减标记"]] [DATEFORMAT="日期格式"][AUTOFORMAT="自动格式化"] [AUTOLINK="是否自动产生链接 "][TARGET="窗口目标"][EXTRA="扩展HTML内容"] ]>通用细览 </TRS_COLUMN> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocuments
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_OUTLINE
Grammer:
<TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"]
[AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"]
[AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_OUTLINE> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserLogoBase

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishTaskDocumentsCacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 PublishTaskDocumentsCacheMgr

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr
所有已实现的接口：
IPublishTaskDocumentsCacheMgr
public class PublishTaskDocumentsCacheMgr
extends java.lang.Object
implements IPublishTaskDocumentsCacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
WCM指定Folder文档集合在一次发布任务中的缓冲对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishTaskDocumentsCacheMgr()
方法摘要
Documents | get(IPublishFolder _folder, WCMFilter _filter)
static void | main(java.lang.String[] args)
void | put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments) 将Folder根据Filter获取到的Documents缓存起来
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishTaskDocumentsCacheMgr

public PublishTaskDocumentsCacheMgr()
方法详细信息

get

public Documents get(IPublishFolder _folder,
                     WCMFilter _filter)
              throws WCMException
指定者：
接口 IPublishTaskDocumentsCacheMgr 中的 get
返回：
抛出：
WCMException

put

public void put(IPublishFolder _folder,
                WCMFilter _filter,
                Documents _oDocuments)
从接口 IPublishTaskDocumentsCacheMgr 复制的描述
将Folder根据Filter获取到的Documents缓存起来

指定者：
接口 IPublishTaskDocumentsCacheMgr 中的 put
参数：
_folder - 指定的Folder
_filter - 当前的Filter
_oDocuments - 返回的文档

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RollDocumentsChannelsFinder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 RollDocumentsChannelsFinder

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.RollDocumentsChannelsFinder

public class RollDocumentsChannelsFinder
extends java.lang.Object

构造方法摘要
RollDocumentsChannelsFinder(IPublishFolder _folder)
方法摘要
 java.lang.String find(TagItem _tagItem)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RollDocumentsChannelsFinder

public RollDocumentsChannelsFinder(IPublishFolder _folder)
                            throws WCMException
抛出：
WCMException
方法详细信息

find

public java.lang.String find(TagItem _tagItem)
                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagChannelChainParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 TagChannelChainParser

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.TagChannelChainParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagChannelChainParser
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
获取栏目父子链属性
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TagChannelChainParser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagChannelChainParser

public TagChannelChainParser()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagDocbakParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 TagDocbakParser

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserContentBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocument
                继承者  com.trs.components.wcm.publish.tagparser.TagDocbakParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagDocbakParser
extends WCMTagParserDocument

构造方法摘要
TagDocbakParser()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocument 继承的方法
getBeanInfo, getBytesLength
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagDocbakParser

public TagDocbakParser()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserCRUser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 TagParserCRUser

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.TagParserCRUser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserCRUser
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
创建者属性发布置标
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TagParserCRUser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserCRUser

public TagParserCRUser()
方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserWmlImage

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 TagParserWmlImage

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.TagParserWmlImage
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserWmlImage
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TagParserWmlImage()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserWmlImage

public TagParserWmlImage()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagParserWmlImages

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 TagParserWmlImages

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.TagParserWmlImages
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserWmlImages
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TagParserWmlImages()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserWmlImages

public TagParserWmlImages()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagWmlContentParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 TagWmlContentParser

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.TagWmlContentParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagWmlContentParser
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
TagWmlContentParser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagWmlContentParser

public TagWmlContentParser()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMAppendixGenerator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMAppendixGenerator

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator

public class WCMAppendixGenerator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
helper for WCM tag parser
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | RETURN_HTML
static int | RETURN_NAME
static int | RETURN_NONE
方法摘要
static java.lang.String | generateAppendix(Appendix _appendix, IPublishContent _apdOwner, PublishTagContext _context, int _nReturnMode) Generates a document appendix.
static java.lang.String | generateAppendixes(Document _doc, int _nApdType, PublishTagContext _context, int _nReturnMode) Generate the appendixes of a document.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RETURN_NONE

public static final int RETURN_NONE
另请参见：
常量字段值

RETURN_NAME

public static final int RETURN_NAME
另请参见：
常量字段值

RETURN_HTML

public static final int RETURN_HTML
另请参见：
常量字段值
方法详细信息

generateAppendixes

public static java.lang.String generateAppendixes(Document _doc,
                                                  int _nApdType,
                                                  PublishTagContext _context,
                                                  int _nReturnMode)
                                           throws WCMException
Generate the appendixes of a document.
NOTICE: we only copy the appendixes to the document orginal home folder in any case, no matter the content modal is link or mirror.

参数：
_doc - the specified document.
_nApdType - the appendix type
_context - current tag parse context
_nReturnMode - return mode, like RETURN_NONE, RETURN_NAME, RETURN_HTML etc.
返回：
the total appendixes count which have been generated
抛出：
WCMException - if failed to generate the appendix.

generateAppendix

public static java.lang.String generateAppendix(Appendix _appendix,
                                                IPublishContent _apdOwner,
                                                PublishTagContext _context,
                                                int _nReturnMode)
                                         throws WCMException
Generates a document appendix.

参数：
_appendix - a document appendix
_context - the current tag parse context
_apdFolder - the folder where the appendix lies
_sDocInfo - the information of the document belonging the appendix
_nReturnMode - return mode, like RETURN_NONE, RETURN_NAME, RETURN_HTML etc.
返回：
the appendix file name if return mode is RETURN_NAME;
the html text showing the appendix if return mode is RETURN_HTML;
other, null
抛出：
WCMException - if failed to publish the appendix.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParser4FolderHostBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParser4FolderHostBase

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
所有已实现的接口：
ITagParser, org.aton.container.IClearable
直接已知子类：
WCMTagParser4ObjsInChannelBase, WCMTagParserChannels
public abstract class WCMTagParser4FolderHostBase
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
base implementation of tag parser for channel host in WCM
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParser4FolderHostBase()
constructor: default
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.domain.tagparser.ITagParser 继承的方法
getBeanInfo, parse
从接口 org.aton.container.IClearable 继承的方法
clear

构造方法详细信息

WCMTagParser4FolderHostBase

public WCMTagParser4FolderHostBase()
constructor: default

方法详细信息

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.
另请参见：
ITagParser.setTagItem(TagItem)

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.analyzeQuotes(IPublishFolder)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParser4ObjsInChannelBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParser4ObjsInChannelBase

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
直接已知子类：
WCMTagParserDocuments, XTagParserObjsInChannelBase
public abstract class WCMTagParser4ObjsInChannelBase
extends WCMTagParser4FolderHostBase
implements ITagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_OUTLINE
Grammer:
<TRS_*** [[ID="频道名称"] [CHILDINDEX="子频道的序号"]
 [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"]
 [STARTPOS="开始位置"]
[AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"]
 [ALINK="链接字段"]
 [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"]
 [ICO="图标文件"]
[AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"]
 [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ]
 [MOREEXTRA="用于更多内容链接中的附加属性"]
 [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_***>

Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParser4ObjsInChannelBase()
方法摘要
void | clear()
PublishTagContext | getDelegatedContext() 返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
PublishTagContext | getNextRecordContext() Returns the tag parse context of the next record.
int | getRecordSize() Returns the records number in thes list.
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
java.lang.String | parseAutoMore(IPublishFolder _currFolder, PublishTagContext _context) Parses the auto more HTML text.
void | setStartPos(int _nPos) Sets the start position
PublishTagContext | substantiateContext(PublishTagContext _tagConext) 实体化指定的PublishTagContext对象
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
analyzeQuotes, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.domain.tagparser.ITagParser 继承的方法
getBeanInfo

构造方法详细信息

WCMTagParser4ObjsInChannelBase

public WCMTagParser4ObjsInChannelBase()
方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

getRecordSize

public int getRecordSize()
从接口 ITagParser4List 复制的描述
Returns the records number in thes list.

指定者：
接口 ITagParser4List 中的 getRecordSize
返回：
the records number in thes list.
另请参见：
ITagParser4List.getRecordSize()

setStartPos

public void setStartPos(int _nPos)
从接口 ITagParser4List 复制的描述
Sets the start position

指定者：
接口 ITagParser4List 中的 setStartPos
另请参见：
ITagParser4List.setStartPos(int)

getNextRecordContext

public PublishTagContext getNextRecordContext()
                                       throws WCMException
从接口 ITagParser4List 复制的描述
Returns the tag parse context of the next record.

指定者：
接口 ITagParser4List 中的 getNextRecordContext
返回：
the tag parse context of the next record.
抛出：
WCMException - if failed to get the next record or to construct the tag parse context.
另请参见：
ITagParser4List.getNextRecordContext()

getDelegatedContext

public PublishTagContext getDelegatedContext()
从接口 ITagParser4List 复制的描述
返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。 所谓被被托管（托管这种说法可能不太准确）的PublishTagContext对象， 是指被延迟实体化的对象，也即延迟设定实际的UpperHost的对象，因为被实体化， 所以相应 ITagParser4List对象中游标也就没有发生实际的移动。 注意（2006.02.08）
事实上该方法和substantiateContext(PublishTagContext)组合使用， 应该可以替代 getNextRecordContext方法，而且这两套方法不能混合使用， 之所以要保留 getNextRecordContext，是为了使改动可以回退。

指定者：
接口 ITagParser4List 中的 getDelegatedContext
返回：
被托管的PublishTagContext对象，或者null。
另请参见：
ITagParser4List.substantiateContext(PublishTagContext), ITagParser4List.getNextRecordContext()

substantiateContext

public PublishTagContext substantiateContext(PublishTagContext _tagConext)
                                      throws WCMException
从接口 ITagParser4List 复制的描述
实体化指定的PublishTagContext对象

指定者：
接口 ITagParser4List 中的 substantiateContext
参数：
_tagConext - 指定的PublishTagContext对象
返回：
实体化后的PublishTagContext对象
抛出：
WCMException - 如果发生错误

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

parseAutoMore

public java.lang.String parseAutoMore(IPublishFolder _currFolder,
                                      PublishTagContext _context)
                               throws java.lang.Exception
Parses the auto more HTML text.

参数：
_currFolder - the current folder
_context - the tag parse context
返回：
the auto more HTML text.
抛出：
java.lang.Exception - if failed.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserAppendix

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserAppendix

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserAppendix
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_APPENDIX解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserAppendix()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserAppendix

public WCMTagParserAppendix()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserChannel

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserChannel
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserChannel
extends TagParserFolderBase

Title: TRS 内容协作平台（TRS WCM）
Description:
The Parser For TRS_CHANNEL
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserChannel()
constructor: default
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserChannel

public WCMTagParserChannel()
constructor: default

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserChannelLogo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserChannelLogo

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserChannelLogo
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserChannelLogo
extends WCMTagParserLogoBase

构造方法摘要
WCMTagParserChannelLogo()
方法摘要
 IPublishElement findHost(PublishTagContext _context)
从类 com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase 继承的方法
parse
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserChannelLogo

public WCMTagParserChannelLogo()
方法详细信息

findHost

public IPublishElement findHost(PublishTagContext _context)
                         throws WCMException
指定者：
类 WCMTagParserLogoBase 中的 findHost
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserChannels

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserChannels

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserChannels
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserChannels
extends WCMTagParser4FolderHostBase
implements ITagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_ALLCATA
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserChannels()
constructor: default
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
PublishTagContext | getDelegatedContext() 返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
PublishTagContext | getNextRecordContext() Returns the tag parse context of the next record.
int | getRecordSize() Returns the records number in thes list.
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setStartPos(int _nPos) Sets the start position
PublishTagContext | substantiateContext(PublishTagContext _tagConext) 实体化指定的PublishTagContext对象
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserChannels

public WCMTagParserChannels()
constructor: default

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
覆盖：
类 WCMTagParser4FolderHostBase 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
另请参见：
ITagParser.analyzeQuotes(IPublishFolder)

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

setStartPos

public void setStartPos(int _nPos)
从接口 ITagParser4List 复制的描述
Sets the start position

指定者：
接口 ITagParser4List 中的 setStartPos
另请参见：
ITagParser4List.setStartPos(int)

getRecordSize

public int getRecordSize()
从接口 ITagParser4List 复制的描述
Returns the records number in thes list.

指定者：
接口 ITagParser4List 中的 getRecordSize
返回：
the records number in thes list.
另请参见：
ITagParser4List.getRecordSize()

getNextRecordContext

public PublishTagContext getNextRecordContext()
                                       throws WCMException
从接口 ITagParser4List 复制的描述
Returns the tag parse context of the next record.

指定者：
接口 ITagParser4List 中的 getNextRecordContext
返回：
the tag parse context of the next record.
抛出：
WCMException - if failed to get the next record or to construct the tag parse context.
另请参见：
ITagParser4List.getNextRecordContext()

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.parse(PublishTagContext)

getDelegatedContext

public PublishTagContext getDelegatedContext()
从接口 ITagParser4List 复制的描述
返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。 所谓被被托管（托管这种说法可能不太准确）的PublishTagContext对象， 是指被延迟实体化的对象，也即延迟设定实际的UpperHost的对象，因为被实体化， 所以相应 ITagParser4List对象中游标也就没有发生实际的移动。 注意（2006.02.08）
事实上该方法和substantiateContext(PublishTagContext)组合使用， 应该可以替代 getNextRecordContext方法，而且这两套方法不能混合使用， 之所以要保留 getNextRecordContext，是为了使改动可以回退。

指定者：
接口 ITagParser4List 中的 getDelegatedContext
返回：
被托管的PublishTagContext对象，或者null。
另请参见：
ITagParser4List.substantiateContext(PublishTagContext), ITagParser4List.getNextRecordContext()

substantiateContext

public PublishTagContext substantiateContext(PublishTagContext _tagConext)
                                      throws WCMException
从接口 ITagParser4List 复制的描述
实体化指定的PublishTagContext对象

指定者：
接口 ITagParser4List 中的 substantiateContext
参数：
_tagConext - 指定的PublishTagContext对象
返回：
实体化后的PublishTagContext对象
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserCurPage

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserCurPage

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserCurPage
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for <_TRSCURPAGE>.
Grammer:
<TRS_COLUMN ID="_TRSCURPAGE" [[ONLY="是否只是显示自己而不显示父频道路径"] [AUTOLINK="自动链接"] [VALUE="路径分割符"] [TARGET="窗口目标"] [EXTRA="额外的HTML内容"] ]>当前页面 </TRS_COLUMN>

Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserCurPage()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserCurPage

public WCMTagParserCurPage()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.
另请参见：
ITagParser.setTagItem(TagItem)

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.analyzeQuotes(IPublishFolder)

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.parse(PublishTagContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDefaultObjectsInChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserDefaultObjectsInChannel

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects
                继承者  com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects
                    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase
                        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannel
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserDefaultObjectsInChannel
extends WCMTagParserDefaultObjectsInChannelBase

构造方法摘要
WCMTagParserDefaultObjectsInChannel()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase 继承的方法
parse
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDefaultObjectsInChannel

public WCMTagParserDefaultObjectsInChannel()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDefaultObjectsInChannelBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserDefaultObjectsInChannelBase

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects
                继承者  com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects
                    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
直接已知子类：
WCMTagParserDefaultObjectsInChannel
public abstract class WCMTagParserDefaultObjectsInChannelBase
extends TagParserDefaultObjects

构造方法摘要
WCMTagParserDefaultObjectsInChannelBase()
方法摘要
 java.lang.String[] parse(PublishTagContext _context)
Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDefaultObjectsInChannelBase

public WCMTagParserDefaultObjectsInChannelBase()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
覆盖：
类 BaseTagParser4List 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDocReply

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserDocReply

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserDocReply
extends TagParserCMSObjBase

Title: TRS 内容协作平台（TRS WCM）
Description:
文档回复的发布置标解释器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserDocReply()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
static void | main(java.lang.String[] args)
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDocReply

public WCMTagParserDocReply()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDocument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserDocument

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserContentBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocument
所有已实现的接口：
ITagParser, org.aton.container.IClearable
直接已知子类：
TagDocbakParser, WCMTagParserDocumentForBJGOV
public class WCMTagParserDocument
extends TagParserContentBase

Title: TRS 内容协作平台（TRS WCM）
Description:
parser for
Grammer:
<TRS_COLUMN ID="字段名" [[NUM="最大长度" [TRUNCATEDFLAG="长度裁减标记"]] [DATEFORMAT="日期格式"][AUTOFORMAT="自动格式化"] [AUTOLINK="是否自动产生链接 "][TARGET="窗口目标"][EXTRA="扩展HTML内容"] ]>通用细览 </TRS_COLUMN>

Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserDocument()
constructor: default
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
static int | getBytesLength(java.lang.String _string)
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDocument

public WCMTagParserDocument()
constructor: default

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述

getBytesLength

public static int getBytesLength(java.lang.String _string)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDocumentChannels

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserDocumentChannels

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentChannels
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserDocumentChannels
extends BaseTagParser4List

构造方法摘要
WCMTagParserDocumentChannels()
方法摘要
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDocumentChannels

public WCMTagParserDocumentChannels()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDocumentForBJGOV

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserDocumentForBJGOV

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserContentBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocument
                继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentForBJGOV
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserDocumentForBJGOV
extends WCMTagParserDocument

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserDocumentForBJGOV()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocument 继承的方法
getBeanInfo, getBytesLength
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDocumentForBJGOV

public WCMTagParserDocumentForBJGOV()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDocumentLogo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserDocumentLogo

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentLogo
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserDocumentLogo
extends WCMTagParserLogoBase

构造方法摘要
WCMTagParserDocumentLogo()
方法摘要
 IPublishElement findHost(PublishTagContext _context)
从类 com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase 继承的方法
parse
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDocumentLogo

public WCMTagParserDocumentLogo()
方法详细信息

findHost

public IPublishElement findHost(PublishTagContext _context)
                         throws WCMException
指定者：
类 WCMTagParserLogoBase 中的 findHost
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserDocuments

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserDocuments

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
直接已知子类：
WCMTagParserEPressNews, WCMTagParserEPressNews, WCMTagParserExpertNews, WCMTagParserRollDocuments, WCMTagParserXDcouments
public class WCMTagParserDocuments
extends WCMTagParser4ObjsInChannelBase

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_OUTLINE
Grammer:
<TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"]
 [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"]
 [STARTPOS="开始位置"]
[AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"]
 [ALINK="链接字段"]
 [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"]
 [ICO="图标文件"]
[AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"]
 [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ]
 [MOREEXTRA="用于更多内容链接中的附加属性"]
 [MORETARGET="更多内容的链接目标类型"]>
 <column_block></TRS_OUTLINE>

Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserDocuments()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 继承的方法
clear, getDelegatedContext, getNextRecordContext, getRecordSize, parse, parseAutoMore, setStartPos, substantiateContext
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
analyzeQuotes, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserDocuments

public WCMTagParserDocuments()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserEPressNews

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserEPressNews

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
                继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserEPressNews
extends WCMTagParserDocuments

Title: TRS 内容协作平台（TRS WCM）
Description:
电子报版面图
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserEPressNews()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
static void | main(java.lang.String[] args)
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 继承的方法
clear, getDelegatedContext, getNextRecordContext, getRecordSize, parse, parseAutoMore, setStartPos, substantiateContext
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
analyzeQuotes, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserEPressNews

public WCMTagParserEPressNews()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 WCMTagParserDocuments 中的 getBeanInfo
返回：
置标解析器的自我描述

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserHelper

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserHelper

public class WCMTagParserHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
WCMTagParser解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserHelper()
方法摘要
static Document | findDocumentHost(PublishTagContext _context)
static BaseChannel | findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel) Returns the current host as a channel.
static BaseChannel | findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel, boolean _bIsFromAllCataTag)
static BaseChannel | findFolderHostByOldModal(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel)
static BaseChannel | findTopNewsOrPicChannel(BaseChannel _parent, int _nChannelType)
static int | getChildIndex(PublishTagContext _context) Returns the value of property ChildIndex in tag item.
static int | getChildIndex(TagItem _tagItem) Returns the value of property ChildIndex in tag item.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserHelper

public WCMTagParserHelper()
方法详细信息

getChildIndex

public static int getChildIndex(PublishTagContext _context)
                         throws WCMException
Returns the value of property ChildIndex in tag item.

返回：
the value of property ChildIndex in tag item.
抛出：
WCMException - if the property value is not integer or out of range.

getChildIndex

public static int getChildIndex(TagItem _tagItem)
                         throws WCMException
Returns the value of property ChildIndex in tag item.

返回：
the value of property ChildIndex in tag item.
抛出：
WCMException - if the property value is not integer or out of range.

findFolderHost

public static BaseChannel findFolderHost(TagItem _tagItem,
                                         PublishTagContext _context,
                                         boolean _bMustBeChannel)
                                  throws WCMException
Returns the current host as a channel.

参数：
_context - tag publish context
返回：
the current host as a channel
抛出：
java.lang.Exception - if failed to find the host.
WCMException

findFolderHost

public static BaseChannel findFolderHost(TagItem _tagItem,
                                         PublishTagContext _context,
                                         boolean _bMustBeChannel,
                                         boolean _bIsFromAllCataTag)
                                  throws WCMException
抛出：
WCMException

findFolderHostByOldModal

public static BaseChannel findFolderHostByOldModal(TagItem _tagItem,
                                                   PublishTagContext _context,
                                                   boolean _bMustBeChannel)
                                            throws WCMException
抛出：
WCMException

findTopNewsOrPicChannel

public static BaseChannel findTopNewsOrPicChannel(BaseChannel _parent,
                                                  int _nChannelType)
                                           throws WCMException
抛出：
WCMException

findDocumentHost

public static Document findDocumentHost(PublishTagContext _context)
                                 throws WCMException
参数：
_context -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserIcon

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserIcon

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserIcon
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserIcon
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
WCMTagParser For TRS_ICON
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserIcon()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserIcon

public WCMTagParserIcon()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserLogoBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserLogoBase

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase
所有已实现的接口：
ITagParser, org.aton.container.IClearable
直接已知子类：
WCMTagParserChannelLogo, WCMTagParserDocumentLogo
public abstract class WCMTagParserLogoBase
extends BaseTagParser

构造方法摘要
WCMTagParserLogoBase()
方法摘要
abstract IPublishElement | findHost(PublishTagContext _context)
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserLogoBase

public WCMTagParserLogoBase()
方法详细信息

findHost

public abstract IPublishElement findHost(PublishTagContext _context)
                                  throws WCMException
抛出：
WCMException

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserMapArea

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserMapArea

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserMapArea
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
生成电子报map area相关信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserMapArea()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
static void | main(java.lang.String[] args)
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserMapArea

public WCMTagParserMapArea()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserNextDocuments

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserNextDocuments

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments
                继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserNextDocuments
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserNextDocuments
extends BaseWCMTagParserPreNextDocuments

字段摘要
从类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 继承的字段
FIELDS_DEFAULT_LIST, FIELDS_MAP, MODE_NEXT, MODE_PRE
构造方法摘要
WCMTagParserNextDocuments()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 继承的方法
getBeanInfo
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserNextDocuments

public WCMTagParserNextDocuments()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserPreDocuments

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserPreDocuments

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments
                继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserPreDocuments
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserPreDocuments
extends BaseWCMTagParserPreNextDocuments

字段摘要
从类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 继承的字段
FIELDS_DEFAULT_LIST, FIELDS_MAP, MODE_NEXT, MODE_PRE
构造方法摘要
WCMTagParserPreDocuments()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 继承的方法
getBeanInfo
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserPreDocuments

public WCMTagParserPreDocuments()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserPrev

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserPrev

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserPrev
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserPrev
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
WCM TagParser For TRS_PREV
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserPrev()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserPrev

public WCMTagParserPrev()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserRelNews

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserRelNews

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserRelNews
extends java.lang.Object
implements ITagParser, ITagParser4List

Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_RELNEWS
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserRelNews()
constructor: default
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
PublishTagContext | getDelegatedContext() 返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
PublishTagContext | getNextRecordContext() Returns the tag parse context of the next record.
int | getRecordSize() Returns the records number in thes list.
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setStartPos(int _nPos) Sets the start position
void | setTagItem(TagItem _item) Sets the tag item to parser.
PublishTagContext | substantiateContext(PublishTagContext _tagConext) 实体化指定的PublishTagContext对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserRelNews

public WCMTagParserRelNews()
constructor: default

方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.
另请参见：
ITagParser.setTagItem(TagItem)

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
另请参见：
ITagParser.analyzeQuotes(IPublishFolder)

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.parse(PublishTagContext)

getRecordSize

public int getRecordSize()
从接口 ITagParser4List 复制的描述
Returns the records number in thes list.

指定者：
接口 ITagParser4List 中的 getRecordSize
返回：
the records number in thes list.
另请参见：
ITagParser4List.getRecordSize()

setStartPos

public void setStartPos(int _nPos)
从接口 ITagParser4List 复制的描述
Sets the start position

指定者：
接口 ITagParser4List 中的 setStartPos
另请参见：
ITagParser4List.setStartPos(int)

getNextRecordContext

public PublishTagContext getNextRecordContext()
                                       throws WCMException
从接口 ITagParser4List 复制的描述
Returns the tag parse context of the next record.

指定者：
接口 ITagParser4List 中的 getNextRecordContext
返回：
the tag parse context of the next record.
抛出：
WCMException - if failed to get the next record or to construct the tag parse context.
另请参见：
ITagParser4List.getNextRecordContext()

getDelegatedContext

public PublishTagContext getDelegatedContext()
从接口 ITagParser4List 复制的描述
返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。 所谓被被托管（托管这种说法可能不太准确）的PublishTagContext对象， 是指被延迟实体化的对象，也即延迟设定实际的UpperHost的对象，因为被实体化， 所以相应 ITagParser4List对象中游标也就没有发生实际的移动。 注意（2006.02.08）
事实上该方法和substantiateContext(PublishTagContext)组合使用， 应该可以替代 getNextRecordContext方法，而且这两套方法不能混合使用， 之所以要保留 getNextRecordContext，是为了使改动可以回退。

指定者：
接口 ITagParser4List 中的 getDelegatedContext
返回：
被托管的PublishTagContext对象，或者null。
另请参见：
ITagParser4List.substantiateContext(PublishTagContext), ITagParser4List.getNextRecordContext()

substantiateContext

public PublishTagContext substantiateContext(PublishTagContext _tagConext)
                                      throws WCMException
从接口 ITagParser4List 复制的描述
实体化指定的PublishTagContext对象

指定者：
接口 ITagParser4List 中的 substantiateContext
参数：
_tagConext - 指定的PublishTagContext对象
返回：
实体化后的PublishTagContext对象
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserReplace

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserReplace

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserReplace
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserReplace
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
WCM Tag Parser For TRS_REPLACE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserReplace()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserReplace

public WCMTagParserReplace()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserRollDocuments

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserRollDocuments

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
                继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserRollDocuments
extends WCMTagParserDocuments

字段摘要
static int TIME_EXEC_WARN
构造方法摘要
WCMTagParserRollDocuments()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String | parseAutoMore(IPublishFolder _currFolder, PublishTagContext _context) Parses the auto more HTML text.
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 继承的方法
clear, getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TIME_EXEC_WARN

public static int TIME_EXEC_WARN
构造方法详细信息

WCMTagParserRollDocuments

public WCMTagParserRollDocuments()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 WCMTagParserDocuments 中的 getBeanInfo
返回：
置标解析器的自我描述

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
覆盖：
类 WCMTagParser4FolderHostBase 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.
另请参见：
ITagParser.analyzeQuotes(IPublishFolder)

parseAutoMore

public java.lang.String parseAutoMore(IPublishFolder _currFolder,
                                      PublishTagContext _context)
                               throws java.lang.Exception
从类 WCMTagParser4ObjsInChannelBase 复制的描述
Parses the auto more HTML text.

覆盖：
类 WCMTagParser4ObjsInChannelBase 中的 parseAutoMore
参数：
_currFolder - the current folder
_context - the tag parse context
返回：
the auto more HTML text.
抛出：
java.lang.Exception - if failed.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagparserTopIcon

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagparserTopIcon

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagparserTopIcon
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
置顶文档标识
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
WCMTagparserTopIcon()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagparserTopIcon

public WCMTagparserTopIcon()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserWebSite

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserWebSite

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserFolderBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserWebSite
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserWebSite
extends TagParserFolderBase

构造方法摘要
WCMTagParserWebSite()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserWebSite

public WCMTagParserWebSite()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserWebSites

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserWebSites

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser4List
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserWebSites
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserWebSites
extends BaseTagParser4List

构造方法摘要
WCMTagParserWebSites()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 继承的方法
getDelegatedContext, getNextRecordContext, getRecordSize, parse, setStartPos, substantiateContext
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserWebSites

public WCMTagParserWebSites()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserXDcouments

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserXDcouments

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
                继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public class WCMTagParserXDcouments
extends WCMTagParserDocuments

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
WCMTagParserXDcouments()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
static void | main(java.lang.String[] args)
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 继承的方法
clear, getDelegatedContext, getNextRecordContext, getRecordSize, parse, parseAutoMore, setStartPos, substantiateContext
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
analyzeQuotes, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserXDcouments

public WCMTagParserXDcouments()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 WCMTagParserDocuments 中的 getBeanInfo
返回：
置标解析器的自我描述

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagParserXDocument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTagParserXDocument

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase
        继承者  com.trs.components.common.publish.domain.tagparser.TagParserContentBase
            继承者  com.trs.components.wcm.publish.tagparser.WCMTagParserXDocument
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserXDocument
extends TagParserContentBase

构造方法摘要
WCMTagParserXDocument()
方法摘要
 TagBeanInfo getBeanInfo()
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
从类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 继承的方法
analyzeQuotes, clear, parse, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserXDocument

public WCMTagParserXDocument()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

返回：
置标解析器的自我描述
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTemplateChildIndexAnalyer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 WCMTemplateChildIndexAnalyer

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer

public class WCMTemplateChildIndexAnalyer
extends java.lang.Object

字段摘要
static java.lang.String | INSERT_CHANNEL_CHILDINDEX_QUOTE
static java.lang.String | QUERY_CHANNEL_CHILDINDEX_QUOTE
构造方法摘要
WCMTemplateChildIndexAnalyer(IPublishFolder _root)
WCMTemplateChildIndexAnalyer(Template _template)
方法摘要
void | analyer()
static int | getAttribute(IPublishElement _element, TagItem _item, java.lang.String _sName, int _nDefault)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

INSERT_CHANNEL_CHILDINDEX_QUOTE

public static final java.lang.String INSERT_CHANNEL_CHILDINDEX_QUOTE
另请参见：
常量字段值

QUERY_CHANNEL_CHILDINDEX_QUOTE

public static final java.lang.String QUERY_CHANNEL_CHILDINDEX_QUOTE
另请参见：
常量字段值
构造方法详细信息

WCMTemplateChildIndexAnalyer

public WCMTemplateChildIndexAnalyer(Template _template)

WCMTemplateChildIndexAnalyer

public WCMTemplateChildIndexAnalyer(IPublishFolder _root)
方法详细信息

analyer

public void analyer()
             throws WCMException
抛出：
WCMException

getAttribute

public static int getAttribute(IPublishElement _element,
                               TagItem _item,
                               java.lang.String _sName,
                               int _nDefault)
                        throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XTagParserObjsInChannelBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 XTagParserObjsInChannelBase

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
        继承者  com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
            继承者  com.trs.components.wcm.publish.tagparser.XTagParserObjsInChannelBase
所有已实现的接口：
ITagParser, ITagParser4List, org.aton.container.IClearable
public abstract class XTagParserObjsInChannelBase
extends WCMTagParser4ObjsInChannelBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
XTagParserObjsInChannelBase()
方法摘要
 java.lang.String[] parse(PublishTagContext _tagContext)
Parses the specified tag item and returns the result.
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 继承的方法
clear, getDelegatedContext, getNextRecordContext, getRecordSize, parseAutoMore, setStartPos, substantiateContext
从类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 继承的方法
analyzeQuotes, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.components.common.publish.domain.tagparser.ITagParser 继承的方法
getBeanInfo

构造方法详细信息

XTagParserObjsInChannelBase

public XTagParserObjsInChannelBase()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _tagContext)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
覆盖：
类 WCMTagParser4ObjsInChannelBase 中的 parse
参数：
_tagContext - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XWCMContImgTagParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 XWCMContImgTagParser

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.components.wcm.publish.tagparser.XWCMContImgTagParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class XWCMContImgTagParser
extends BaseTagParser

作者：
CaiLun

构造方法摘要
XWCMContImgTagParser()
方法摘要
 java.lang.String[] parse(PublishTagContext _context)
Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, getBeanInfo, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XWCMContImgTagParser

public XWCMContImgTagParser()
方法详细信息

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XWCMFileAppendixTagParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 XWCMFileAppendixTagParser

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class XWCMFileAppendixTagParser
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
解析文档包含的文件附件：支持自定义文件名
Copyright: Copyright (c) 2009-2010 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.3
作者：
TRS信息技术有限公司

构造方法摘要
XWCMFileAppendixTagParser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder arg0) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XWCMFileAppendixTagParser

public XWCMFileAppendixTagParser()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder arg0)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
arg0 - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XWCMImageAppendixTagParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 XWCMImageAppendixTagParser

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class XWCMImageAppendixTagParser
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
解析文档包含的图片附件：支持图片自动缩放
Copyright: Copyright (c) 2009-2010 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.1
作者：
TRS信息技术有限公司

构造方法摘要
XWCMImageAppendixTagParser()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder arg0) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) 通过图片全路径找到图片名称（带后缀名）
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XWCMImageAppendixTagParser

public XWCMImageAppendixTagParser()
方法详细信息

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder arg0)
                              throws WCMException
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
arg0 - the root folder
返回：
the TemplateQuote list.
抛出：
WCMException - if failed to parse the tag item.

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
通过图片全路径找到图片名称（带后缀名）

指定者：
接口 ITagParser 中的 parse
参数：
_sZipImagePathName -
返回：
sImageName
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XWCMTagParserPageGeneration

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser
类 XWCMTagParserPageGeneration

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class XWCMTagParserPageGeneration
extends java.lang.Object
implements ITagParser

构造方法摘要
XWCMTagParserPageGeneration()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XWCMTagParserPageGeneration

public XWCMTagParserPageGeneration()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments
的使用

使用 BaseWCMTagParserPreNextDocuments 的软件包
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.publish.tagparser 中 BaseWCMTagParserPreNextDocuments 的使用

com.trs.components.wcm.publish.tagparser 中 BaseWCMTagParserPreNextDocuments 的子类
class | WCMTagParserNextDocuments
class | WCMTagParserPreDocuments

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.DocumentsTemp 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.DocumentsTemp
的使用

没有 com.trs.components.wcm.publish.tagparser.DocumentsTemp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.publish.tagparser.IPublishTaskDocumentsCacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.publish.tagparser.IPublishTaskDocumentsCacheMgr
的使用

使用 IPublishTaskDocumentsCacheMgr 的软件包
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.publish.tagparser 中 IPublishTaskDocumentsCacheMgr 的使用

实现 IPublishTaskDocumentsCacheMgr 的 com.trs.components.wcm.publish.tagparser 中的类
 class PublishTaskDocumentsCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM指定Folder文档集合在一次发布任务中的缓冲对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr
的使用

没有 com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.RollDocumentsChannelsFinder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.RollDocumentsChannelsFinder
的使用

没有 com.trs.components.wcm.publish.tagparser.RollDocumentsChannelsFinder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.TagChannelChainParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.TagChannelChainParser
的使用

没有 com.trs.components.wcm.publish.tagparser.TagChannelChainParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.TagDocbakParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.TagDocbakParser
的使用

没有 com.trs.components.wcm.publish.tagparser.TagDocbakParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.TagParserCRUser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.TagParserCRUser
的使用

没有 com.trs.components.wcm.publish.tagparser.TagParserCRUser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.TagParserWmlImage 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.TagParserWmlImage
的使用

没有 com.trs.components.wcm.publish.tagparser.TagParserWmlImage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.TagParserWmlImages 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.TagParserWmlImages
的使用

没有 com.trs.components.wcm.publish.tagparser.TagParserWmlImages 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.TagWmlContentParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.TagWmlContentParser
的使用

没有 com.trs.components.wcm.publish.tagparser.TagWmlContentParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase
的使用

使用 WCMTagParser4FolderHostBase 的软件包
com.trs.components.wcm.epress
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.epress 中 WCMTagParser4FolderHostBase 的使用

com.trs.components.wcm.epress 中 WCMTagParser4FolderHostBase 的子类
 class WCMTagParserExpertNews

com.trs.components.wcm.publish.tagparser 中 WCMTagParser4FolderHostBase 的使用

com.trs.components.wcm.publish.tagparser 中 WCMTagParser4FolderHostBase 的子类
class | WCMTagParser4ObjsInChannelBase Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_*** [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_***> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserChannels Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_ALLCATA Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserDocuments Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_OUTLINE> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserEPressNews Title: TRS 内容协作平台（TRS WCM） Description: 电子报版面图 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserRollDocuments
class | WCMTagParserXDcouments Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | XTagParserObjsInChannelBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase
的使用

使用 WCMTagParser4ObjsInChannelBase 的软件包
com.trs.components.wcm.epress
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.epress 中 WCMTagParser4ObjsInChannelBase 的使用

com.trs.components.wcm.epress 中 WCMTagParser4ObjsInChannelBase 的子类
 class WCMTagParserExpertNews

com.trs.components.wcm.publish.tagparser 中 WCMTagParser4ObjsInChannelBase 的使用

com.trs.components.wcm.publish.tagparser 中 WCMTagParser4ObjsInChannelBase 的子类
class | WCMTagParserDocuments Title: TRS 内容协作平台（TRS WCM） Description: tag parser for TRS_OUTLINE Grammer: <TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"] [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"] [STARTPOS="开始位置"] [AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"] [ALINK="链接字段"] [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"] [ICO="图标文件"] [AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"] [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ] [MOREEXTRA="用于更多内容链接中的附加属性"] [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_OUTLINE> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserEPressNews Title: TRS 内容协作平台（TRS WCM） Description: 电子报版面图 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserRollDocuments
class | WCMTagParserXDcouments Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | XTagParserObjsInChannelBase Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannel
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannelLogo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannelLogo
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserChannelLogo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannel
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase
的使用

使用 WCMTagParserDefaultObjectsInChannelBase 的软件包
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.publish.tagparser 中 WCMTagParserDefaultObjectsInChannelBase 的使用

com.trs.components.wcm.publish.tagparser 中 WCMTagParserDefaultObjectsInChannelBase 的子类
 class WCMTagParserDefaultObjectsInChannel

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocument 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocument
的使用

使用 WCMTagParserDocument 的软件包
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.publish.tagparser 中 WCMTagParserDocument 的使用

com.trs.components.wcm.publish.tagparser 中 WCMTagParserDocument 的子类
class | TagDocbakParser
class | WCMTagParserDocumentForBJGOV Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentChannels 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentChannels
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentChannels 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentForBJGOV 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentForBJGOV
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentForBJGOV 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentLogo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentLogo
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentLogo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments
的使用

使用 WCMTagParserDocuments 的软件包
com.trs.components.wcm.epress
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.epress 中 WCMTagParserDocuments 的使用

com.trs.components.wcm.epress 中 WCMTagParserDocuments 的子类
 class WCMTagParserExpertNews

com.trs.components.wcm.publish.tagparser 中 WCMTagParserDocuments 的使用

com.trs.components.wcm.publish.tagparser 中 WCMTagParserDocuments 的子类
class | WCMTagParserEPressNews Title: TRS 内容协作平台（TRS WCM） Description: 电子报版面图 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagParserRollDocuments
class | WCMTagParserXDcouments Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase
的使用

使用 WCMTagParserLogoBase 的软件包
com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.publish.tagparser 中 WCMTagParserLogoBase 的使用

com.trs.components.wcm.publish.tagparser 中 WCMTagParserLogoBase 的子类
class | WCMTagParserChannelLogo
class | WCMTagParserDocumentLogo

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserNextDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserNextDocuments
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserNextDocuments 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserPreDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserPreDocuments
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserPreDocuments 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSite 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSite
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSite 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSites 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSites
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSites 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDocument 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDocument
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTagParserXDocument 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer
的使用

没有 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.XTagParserObjsInChannelBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.XTagParserObjsInChannelBase
的使用

没有 com.trs.components.wcm.publish.tagparser.XTagParserObjsInChannelBase 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.XWCMContImgTagParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.XWCMContImgTagParser
的使用

没有 com.trs.components.wcm.publish.tagparser.XWCMContImgTagParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser
的使用

没有 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser
的使用

没有 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration
的使用

没有 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.wcm.publish.tagparser.formater
类
WCMTagFormatterAllCata
WCMTagFormatterBigNews
WCMTagFormatterChannel
WCMTagFormatterChnlName
WCMTagFormatterColumn
WCMTagFormatterDocumentsBase
WCMTagFormatterOutline
WCMTagFormatterPicNews
WCMTagFormatterPicture
WCMTagFormatterRecPath
WCMTagFormatterRelNews
WCMTagFormatterTemplate


com.trs.components.wcm.publish.tagparser.formater

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.publish.tagparser.formater

类摘要
WCMTagFormatterAllCata | Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSALLCATA Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterBigNews | Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSBigNews Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterChannel | Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterChnlName | Title: TRS 内容协作平台（TRS WCM） Description: tag formater for _TRSCHNLNAME Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterColumn | Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for PICCONTENT Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterDocumentsBase | Title: TRS 内容协作平台（TRS WCM） Description: WCM Tag格式化工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterOutline | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterPicNews | Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSPicNews Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterPicture | Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSPCITURE Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterRecPath | Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSRECPATH Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterRelNews | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterTemplate | 将name_of_template格式化为 的形式。


com.trs.components.wcm.publish.tagparser.formater 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.tagparser.formater 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterAllCata (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChannel (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChnlName (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterColumn (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
      • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterBigNews
      • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterOutline
      • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicNews
      • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRelNews
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicture (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRecPath (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)
    • com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterTemplate (implements com.trs.components.common.publish.domain.tagparser.ITagFormatter)


软件包 com.trs.components.wcm.publish.tagparser.formater 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.publish.tagparser.formater
的使用

使用 com.trs.components.wcm.publish.tagparser.formater 的软件包
com.trs.components.wcm.publish.tagparser.formater

com.trs.components.wcm.publish.tagparser.formater 使用的 com.trs.components.wcm.publish.tagparser.formater 中的类
WCMTagFormatterDocumentsBase
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM Tag格式化工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMTagFormatterAllCata

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterAllCata

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterAllCata
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterAllCata
extends java.lang.Object
implements ITagFormatter

Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSALLCATA
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterAllCata()
constructor: default
方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterAllCata

public WCMTagFormatterAllCata()
constructor: default

方法详细信息

standardize

public void standardize(TagItem _item)
                 throws WCMException
从接口 ITagFormatter 复制的描述
Converts the tag item to standard format.

指定者：
接口 ITagFormatter 中的 standardize
参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
另请参见：
ITagFormatter.standardize(TagItem)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterBigNews

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterBigNews

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase
        继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterBigNews
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterBigNews
extends WCMTagFormatterDocumentsBase

Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSBigNews
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterBigNews()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase 继承的方法
standardize
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterBigNews

public WCMTagFormatterBigNews()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterChannel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterChannel

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChannel
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterChannel
extends java.lang.Object
implements ITagFormatter

Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterChannel()
方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterChannel

public WCMTagFormatterChannel()
方法详细信息

standardize

public void standardize(TagItem _item)
                 throws WCMException
从接口 ITagFormatter 复制的描述
Converts the tag item to standard format.

指定者：
接口 ITagFormatter 中的 standardize
参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterChnlName

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterChnlName

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChnlName
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterChnlName
extends java.lang.Object
implements ITagFormatter

Title: TRS 内容协作平台（TRS WCM）
Description:
tag formater for _TRSCHNLNAME
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterChnlName()
constructor: default
方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterChnlName

public WCMTagFormatterChnlName()
constructor: default

方法详细信息

standardize

public void standardize(TagItem _item)
                 throws WCMException
从接口 ITagFormatter 复制的描述
Converts the tag item to standard format.

指定者：
接口 ITagFormatter 中的 standardize
参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
另请参见：
ITagFormatter.standardize(TagItem)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterColumn

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterColumn

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterColumn
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterColumn
extends java.lang.Object
implements ITagFormatter

Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for PICCONTENT
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterColumn()
constructor: default
方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterColumn

public WCMTagFormatterColumn()
constructor: default

方法详细信息

standardize

public void standardize(TagItem _item)
                 throws WCMException
从接口 ITagFormatter 复制的描述
Converts the tag item to standard format.

指定者：
接口 ITagFormatter 中的 standardize
参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
另请参见：
ITagFormatter.standardize(TagItem)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterDocumentsBase

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterDocumentsBase

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase
所有已实现的接口：
ITagFormatter
直接已知子类：
WCMTagFormatterBigNews, WCMTagFormatterOutline, WCMTagFormatterPicNews, WCMTagFormatterRelNews
public abstract class WCMTagFormatterDocumentsBase
extends java.lang.Object
implements ITagFormatter

Title: TRS 内容协作平台（TRS WCM）
Description:
WCM Tag格式化工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterDocumentsBase()
方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterDocumentsBase

public WCMTagFormatterDocumentsBase()
方法详细信息

standardize

public void standardize(TagItem _item)
                 throws WCMException
从接口 ITagFormatter 复制的描述
Converts the tag item to standard format.

指定者：
接口 ITagFormatter 中的 standardize
参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterOutline

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterOutline

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase
        继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterOutline
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterOutline
extends WCMTagFormatterDocumentsBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterOutline()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase 继承的方法
standardize
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterOutline

public WCMTagFormatterOutline()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterPicNews

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterPicNews

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase
        继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicNews
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterPicNews
extends WCMTagFormatterDocumentsBase

Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSPicNews
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterPicNews()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase 继承的方法
standardize
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterPicNews

public WCMTagFormatterPicNews()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterPicture

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterPicture

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicture
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterPicture
extends java.lang.Object
implements ITagFormatter

Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSPCITURE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterPicture()
constructor: default
方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterPicture

public WCMTagFormatterPicture()
constructor: default

方法详细信息

standardize

public void standardize(TagItem _item)
                 throws WCMException
从接口 ITagFormatter 复制的描述
Converts the tag item to standard format.

指定者：
接口 ITagFormatter 中的 standardize
参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
另请参见：
ITagFormatter.standardize(TagItem)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterRecPath

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterRecPath

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRecPath
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterRecPath
extends java.lang.Object
implements ITagFormatter

Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSRECPATH
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterRecPath()
constructor: default
方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterRecPath

public WCMTagFormatterRecPath()
constructor: default

方法详细信息

standardize

public void standardize(TagItem _item)
                 throws WCMException
从接口 ITagFormatter 复制的描述
Converts the tag item to standard format.

指定者：
接口 ITagFormatter 中的 standardize
参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
另请参见：
ITagFormatter.standardize(TagItem)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterRelNews

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterRelNews

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase
        继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRelNews
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterRelNews
extends WCMTagFormatterDocumentsBase

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagFormatterRelNews()
方法摘要
从类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase 继承的方法
standardize
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterRelNews

public WCMTagFormatterRelNews()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTagFormatterTemplate

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.publish.tagparser.formater
类 WCMTagFormatterTemplate

java.lang.Object
    继承者  com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterTemplate
所有已实现的接口：
ITagFormatter
public class WCMTagFormatterTemplate
extends java.lang.Object
implements ITagFormatter

将name_of_template格式化为 的形式。

作者：
Martin (付成睿)

构造方法摘要
WCMTagFormatterTemplate()
缺省构造方法
方法摘要
 void standardize(TagItem _item)
Converts the tag item to standard format.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagFormatterTemplate

public WCMTagFormatterTemplate()
缺省构造方法

方法详细信息

standardize

public void standardize(TagItem _item)
                 throws WCMException
从接口 ITagFormatter 复制的描述
Converts the tag item to standard format.

指定者：
接口 ITagFormatter 中的 standardize
参数：
_item - a tag item
抛出：
WCMException - if failed to convert the tag item format.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterAllCata 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterAllCata
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterAllCata 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterBigNews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterBigNews
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterBigNews 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChannel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChannel
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChannel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChnlName 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChnlName
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChnlName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterColumn 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterColumn
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterColumn 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase
的使用

使用 WCMTagFormatterDocumentsBase 的软件包
com.trs.components.wcm.publish.tagparser.formater

com.trs.components.wcm.publish.tagparser.formater 中 WCMTagFormatterDocumentsBase 的使用

com.trs.components.wcm.publish.tagparser.formater 中 WCMTagFormatterDocumentsBase 的子类
class | WCMTagFormatterBigNews Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSBigNews Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterOutline Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterPicNews Title: TRS 内容协作平台（TRS WCM） Description: tag formatter for _TRSPicNews Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMTagFormatterRelNews Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterOutline 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterOutline
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterOutline 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicNews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicNews
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicNews 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicture 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicture
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicture 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRecPath 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRecPath
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRecPath 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRelNews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRelNews
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRelNews 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterTemplate 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterTemplate
的使用

没有 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterTemplate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.wcm.recent
类
Recent
RecentMgr
Recents


com.trs.components.wcm.recent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.recent

类摘要
Recent |
RecentMgr | Title: TRS 内容协作平台（TRS WCM） Description: “我最近访问”的对象的平台管理层 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Recents |


com.trs.components.wcm.recent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.recent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.recent.Recent
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.recent.Recents
    • com.trs.components.wcm.recent.RecentMgr


软件包 com.trs.components.wcm.recent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.recent
的使用

使用 com.trs.components.wcm.recent 的软件包
com.trs.components.wcm.recent

com.trs.components.wcm.recent 使用的 com.trs.components.wcm.recent 中的类
Recent
Recents

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Recent

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.recent
类 Recent

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.recent.Recent
所有已实现的接口：
java.lang.Cloneable
public class Recent
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Recent()
构造函数：保留默认接口
方法摘要
static Recent | createNewInstance() 产生当前对象[Recent]的实例
static Recent | findById(int _nId) 提取指定ID的对象
static Recent | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
static int | getMaxNum() 从配置文件中查询当前类型对象所能保存的最大数目
int | getObjId() 提取属性：ObjId
int | getObjType() 提取属性：ObjType
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setObj(CMSObj _obj) 设置属性：ObjType
boolean | setObjId(int _nObjId) 设置属性：ObjId
boolean | setObjType(int _nObjType) 设置属性：ObjType
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Recent

public Recent()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getObjType

public int getObjType()
提取属性：ObjType

返回：
ObjType

setObjType

public boolean setObjType(int _nObjType)
                   throws WCMException
设置属性：ObjType

参数：
_nObjType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

public int getObjId()
提取属性：ObjId

返回：
ObjId

setObjId

public boolean setObjId(int _nObjId)
                 throws WCMException
设置属性：ObjId

参数：
_nObjId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final Recent findById(int _nId)
                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Recent createNewInstance()
                                      throws WCMException
产生当前对象[Recent]的实例

返回：
当前对象的实例[Recent]
抛出：
WCMException

findByKey

public static final Recent findByKey(java.lang.Object _oKey)
                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getMaxNum

public static int getMaxNum()
从配置文件中查询当前类型对象所能保存的最大数目

参数：
_nObjType -
返回：
@throws WCMException

setObj

public boolean setObj(CMSObj _obj)
               throws WCMException
设置属性：ObjType

参数：
_obj - 对象
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


RecentMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.recent
类 RecentMgr

java.lang.Object
    继承者  com.trs.components.wcm.recent.RecentMgr

public class RecentMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
“我最近访问”的对象的平台管理层
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RecentMgr()
方法摘要
boolean | add(int _nObjType, int _nObjId) 根据对象类型和ID，将当前对象添加到最近访问的对象中 如果没有超过每个对象的记录个数，则新增。
Channels | getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted) 获得用户最近访问的频道列表，按访问时间逆序排列
ChnlDocs | getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
Documents | getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted) 获得用户最近访问的文档列表，按访问时间逆序排列
java.lang.String | getIds(int _nObjTypeId) 取得当前用户对特定类型对象的最新访问列表Id序列
Templates | getTemplates(WCMFilter _aFilter) 获得用户最近访问的模板列表，按访问时间逆序排列
WebSites | getWebSites(WCMFilter _aFilter) 获得用户最近访问的模板列表，按访问时间逆序排列
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RecentMgr

public RecentMgr()
方法详细信息

add

public boolean add(int _nObjType,
                   int _nObjId)
            throws WCMException
根据对象类型和ID，将当前对象添加到最近访问的对象中
如果没有超过每个对象的记录个数，则新增。如果超过了，则更新最早的一个

参数：
_nObjType - 对象类型
_nObjId - 对象ID
返回：
true为操作成功，false为失败
抛出：
WCMException

getIds

public java.lang.String getIds(int _nObjTypeId)
                        throws WCMException
取得当前用户对特定类型对象的最新访问列表Id序列

参数：
_nObjTypeId -
返回：
特定类型的对象Id的序列，以逗号分隔
抛出：
WCMException

getDocuments

public Documents getDocuments(WCMFilter _aFilter,
                              boolean _bIncludeDeleted)
                       throws WCMException
获得用户最近访问的文档列表，按访问时间逆序排列

返回：
@throws WCMException
抛出：
WCMException

getChannels

public Channels getChannels(WCMFilter _aFilter,
                            boolean _bIncludeDeleted)
                     throws WCMException
获得用户最近访问的频道列表，按访问时间逆序排列

参数：
_aFilter -
_bIncludeDeleted - true为包含已删除的，false为不包含已删除的
返回：
@throws WCMException
抛出：
WCMException

getTemplates

public Templates getTemplates(WCMFilter _aFilter)
                       throws WCMException
获得用户最近访问的模板列表，按访问时间逆序排列

参数：
_aFilter -
返回：
@throws WCMException
抛出：
WCMException

getWebSites

public WebSites getWebSites(WCMFilter _aFilter)
                     throws WCMException
获得用户最近访问的模板列表，按访问时间逆序排列

参数：
_aFilter -
返回：
@throws WCMException
抛出：
WCMException

getChnlDocs

public ChnlDocs getChnlDocs(WCMFilter _aFilter,
                            boolean _bIncludeDeleted)
                     throws WCMException
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

参数：
_aFilter - 用户指定的查询条件
_bIncludeDeleted - true为包含已删除的，false为不包含已删除的
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Recents

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.recent
类 Recents

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.recent.Recents

public class Recents
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Recents(User _currUser)
构造函数
Recents(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Recents | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Recents | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Recents]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Recents

public Recents(User _currUser)
构造函数

另请参见：
Recents( User _currUser, int _initCapacity, int _incCapacity );

Recents

public Recents(User _currUser,
               int _initCapacity,
               int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final Recents findByIds(User _currUser,
                                      java.lang.String _sIds)
                               throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Recents openWCMObjs(User _currUser,
                                        WCMFilter _filter)
                                 throws WCMException
通过指定一个Filter获取当前集合[Recents]

参数：
_currUser - 当前操作的用户
_filter - 指定的Filter
返回：
当前集合[Recents]
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.recent.Recent 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.recent.Recent
的使用

使用 Recent 的软件包
com.trs.components.wcm.recent

com.trs.components.wcm.recent 中 Recent 的使用

返回 Recent 的 com.trs.components.wcm.recent 中的方法
static Recent | Recent.createNewInstance() 产生当前对象[Recent]的实例
static Recent | Recent.findById(int _nId) 提取指定ID的对象
static Recent | Recent.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.recent.RecentMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.recent.RecentMgr
的使用

没有 com.trs.components.wcm.recent.RecentMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.recent.Recents 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.recent.Recents
的使用

使用 Recents 的软件包
com.trs.components.wcm.recent

com.trs.components.wcm.recent 中 Recents 的使用

返回 Recents 的 com.trs.components.wcm.recent 中的方法
static Recents | Recents.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Recents | Recents.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Recents]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DocKind

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 DocKind

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.resource.DocKind
所有已实现的接口：
java.lang.Cloneable
public class DocKind
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
DocKind()
方法摘要
static DocKind | createNewInstance() 产生当前对象[DocKind]的实例
static DocKind | findById(int _nId) 提取指定ID的对象
static DocKind | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute()
DocKinds | getChildren(User _currUser)
java.lang.String | getCode()
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc()
int | getGrade()
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName()
DocKind | getParent()
int | getParentId()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setAttribute(java.lang.String _attribute) 共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
boolean | setCode(java.lang.String _code)
boolean | setDesc(java.lang.String _desc)
boolean | setName(java.lang.String _name)
boolean | setParent(DocKind _parent)
boolean | setParent(int _parentId)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

DocKind

public DocKind()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getParentId

public int getParentId()

getParent

public DocKind getParent()
                  throws WCMException
抛出：
WCMException

setParent

public boolean setParent(int _parentId)
                  throws WCMException
抛出：
WCMException

setParent

public boolean setParent(DocKind _parent)
                  throws WCMException
抛出：
WCMException

getGrade

public int getGrade()

getCode

public java.lang.String getCode()

setCode

public boolean setCode(java.lang.String _code)
                throws WCMException
抛出：
WCMException

getName

public java.lang.String getName()

setName

public boolean setName(java.lang.String _name)
                throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
覆盖：
类 BaseObj 中的 getAttribute

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
从类 BaseObj 复制的描述
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

getChildren

public DocKinds getChildren(User _currUser)
                     throws WCMException
抛出：
WCMException

findById

public static final DocKind findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final DocKind createNewInstance()
                                       throws WCMException
产生当前对象[DocKind]的实例

返回：
当前对象的实例[DocKind]
抛出：
WCMException

findByKey

public static final DocKind findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocKinds

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 DocKinds

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.resource.DocKinds

public class DocKinds
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
DocKinds(User _currUser)
DocKinds(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocKinds

public DocKinds(User _currUser)

DocKinds

public DocKinds(User _currUser,
                int initialCapacity,
                int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 FileType

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.resource.FileType
所有已实现的接口：
java.lang.Cloneable
public class FileType
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
构造方法摘要
FileType()
方法摘要
static FileType | createNewInstance() 产生当前对象[FileType]的实例
static FileType | findById(int _nId) 提取指定ID的对象
static FileType | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc()
java.lang.String | getExt()
java.lang.String | getForm()
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName()
java.lang.String | getOpenWith()
java.lang.String | getTag()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setDesc(java.lang.String _desc)
boolean | setExt(java.lang.String _ext)
boolean | setForm(java.lang.String _form)
boolean | setName(java.lang.String _name)
boolean | setOpenWith(java.lang.String _openWith)
boolean | setTag(java.lang.String _tag)
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

FileType

public FileType()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getName

public java.lang.String getName()

setName

public boolean setName(java.lang.String _name)
                throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
抛出：
WCMException

getForm

public java.lang.String getForm()

setForm

public boolean setForm(java.lang.String _form)
                throws WCMException
抛出：
WCMException

getTag

public java.lang.String getTag()

setTag

public boolean setTag(java.lang.String _tag)
               throws WCMException
抛出：
WCMException

getExt

public java.lang.String getExt()

setExt

public boolean setExt(java.lang.String _ext)
               throws WCMException
抛出：
WCMException

getOpenWith

public java.lang.String getOpenWith()

setOpenWith

public boolean setOpenWith(java.lang.String _openWith)
                    throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

findById

public static final FileType findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final FileType createNewInstance()
                                        throws WCMException
产生当前对象[FileType]的实例

返回：
当前对象的实例[FileType]
抛出：
WCMException

findByKey

public static final FileType findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 FileTypes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.resource.FileTypes

public class FileTypes
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
FileTypes(User _currUser)
FileTypes(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileTypes

public FileTypes(User _currUser)

FileTypes

public FileTypes(User _currUser,
                 int initialCapacity,
                 int capacityIncrement)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Keyword

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 Keyword

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.resource.Keyword
所有已实现的接口：
java.lang.Cloneable
public class Keyword
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Keyword()
构造函数：保留默认接口
方法摘要
static Keyword | createNewInstance() 产生当前对象[Keyword]的实例
static Keyword | findById(int _nId) 提取指定ID的对象
static Keyword | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getKFREQ() 提取属性：KFREQ
java.lang.String | getKNAME() 提取属性：KNAME
int | getSITEID() 提取属性：SITEID
int | getSITETYPE() 提取属性：SITETYPE
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setKFREQ(int _nKFREQ) 设置属性：KFREQ
boolean | setKNAME(java.lang.String _sKNAME) 设置属性：KNAME
boolean | setSITEID(int _nSITEID) 设置属性：SITEID
boolean | setSITETYPE(int _nSITETYPE) 设置属性：SITETYPE
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Keyword

public Keyword()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getKNAME

public java.lang.String getKNAME()
提取属性：KNAME

返回：
KNAME

setKNAME

public boolean setKNAME(java.lang.String _sKNAME)
                 throws WCMException
设置属性：KNAME

参数：
_sKNAME - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSITEID

public int getSITEID()
提取属性：SITEID

返回：
SITEID

setSITEID

public boolean setSITEID(int _nSITEID)
                  throws WCMException
设置属性：SITEID

参数：
_nSITEID - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSITETYPE

public int getSITETYPE()
提取属性：SITETYPE

返回：
SITETYPE

setSITETYPE

public boolean setSITETYPE(int _nSITETYPE)
                    throws WCMException
设置属性：SITETYPE

参数：
_nSITETYPE - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getKFREQ

public int getKFREQ()
提取属性：KFREQ

返回：
KFREQ

setKFREQ

public boolean setKFREQ(int _nKFREQ)
                 throws WCMException
设置属性：KFREQ

参数：
_nKFREQ - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final Keyword findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Keyword createNewInstance()
                                       throws WCMException
产生当前对象[Keyword]的实例

返回：
当前对象的实例[Keyword]
抛出：
WCMException

findByKey

public static final Keyword findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Keywords

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 Keywords

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.resource.Keywords

public class Keywords
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Keywords(User _currUser)
构造函数
Keywords(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Keywords | createNewInstance(User _currUser) 产生当前集合对象[Keywords]的实例
static Keywords | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Keywords | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Keywords]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Keywords

public Keywords(User _currUser)
构造函数

另请参见：
Keywords( User _currUser, int _initCapacity, int _incCapacity );

Keywords

public Keywords(User _currUser,
                int _initCapacity,
                int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final Keywords findByIds(User _currUser,
                                       java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Keywords）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Keywords openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[Keywords]

参数：
_filter - 指定的Filter
返回：
当前集合[Keywords]
抛出：
WCMException

createNewInstance

public static Keywords createNewInstance(User _currUser)
产生当前集合对象[Keywords]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.resource
类
DocKind
DocKinds
FileType
FileTypes
Keyword
Keywords
ResourceMgr
Securities
Security
Source
Sources
SourceTypeMgr
Status
Statuses


com.trs.components.wcm.resource

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.resource

类摘要
DocKind |
DocKinds |
FileType |
FileTypes |
Keyword |
Keywords |
ResourceMgr | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Securities |
Security |
Source |
Sources |
SourceTypeMgr |
Status |
Statuses |


com.trs.components.wcm.resource 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.resource 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.resource.DocKind
        • com.trs.components.wcm.resource.FileType
        • com.trs.components.wcm.resource.Keyword
        • com.trs.components.wcm.resource.Security
        • com.trs.components.wcm.resource.Source
        • com.trs.components.wcm.resource.Status
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.resource.DocKinds
        • com.trs.components.wcm.resource.FileTypes
        • com.trs.components.wcm.resource.Keywords
        • com.trs.components.wcm.resource.Securities
        • com.trs.components.wcm.resource.Sources
        • com.trs.components.wcm.resource.Statuses
    • com.trs.components.wcm.resource.ResourceMgr
    • com.trs.components.wcm.resource.SourceTypeMgr


软件包 com.trs.components.wcm.resource 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.resource
的使用

使用 com.trs.components.wcm.resource 的软件包
com.trs.ajaxservice
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.components.gkml.sqgk.persistent
com.trs.components.metadata.center
com.trs.components.wcm.content
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.resource
com.trs.components.wcm.wcmx.media
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 使用的 com.trs.components.wcm.resource 中的类
Statuses

com.trs.cms.process.definition 使用的 com.trs.components.wcm.resource 中的类
Status

com.trs.cms.process.engine 使用的 com.trs.components.wcm.resource 中的类
Status

com.trs.components.gkml.sqgk.persistent 使用的 com.trs.components.wcm.resource 中的类
Status

com.trs.components.metadata.center 使用的 com.trs.components.wcm.resource 中的类
Status

com.trs.components.wcm.content 使用的 com.trs.components.wcm.resource 中的类
Source
Status

com.trs.components.wcm.content.domain 使用的 com.trs.components.wcm.resource 中的类
Status

com.trs.components.wcm.content.persistent 使用的 com.trs.components.wcm.resource 中的类
DocKind
FileType
Security
Source
Status
Statuses

com.trs.components.wcm.resource 使用的 com.trs.components.wcm.resource 中的类
DocKind
DocKinds
FileType
Keyword
Keywords
Securities
Security
Source
Sources
Status
Statuses

com.trs.components.wcm.wcmx.media 使用的 com.trs.components.wcm.resource 中的类
Sources

com.trs.service 使用的 com.trs.components.wcm.resource 中的类
Status

com.trs.service.impl 使用的 com.trs.components.wcm.resource 中的类
Status

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ResourceMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 ResourceMgr

java.lang.Object
    继承者  com.trs.components.wcm.resource.ResourceMgr

public class ResourceMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ResourceMgr()
方法摘要
boolean | delete(User _currUser, CMSObj _currObj) 删除指定的配置资源对象
Schedules | getTempPathDeleteSchedules(WCMFilter _filter)
CMSObj | save(User _currUser, CMSObj _currObj) 保存指定的配置资源对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResourceMgr

public ResourceMgr()
方法详细信息

save

public CMSObj save(User _currUser,
                   CMSObj _currObj)
            throws WCMException
保存指定的配置资源对象

参数：
_currObj - 要保存的配置资源对象
返回：
抛出：
WCMException

delete

public boolean delete(User _currUser,
                      CMSObj _currObj)
               throws WCMException
删除指定的配置资源对象

参数：
_currObj - 要删除的配置资源对象
返回：
抛出：
WCMException

getTempPathDeleteSchedules

public Schedules getTempPathDeleteSchedules(WCMFilter _filter)
                                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Securities

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 Securities

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.resource.Securities

public class Securities
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Securities(User _currUser)
Securities(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Securities | createNewInstance(User _currUser) 产生当前集合对象[Securities]的实例
static Securities | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Securities | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Securities]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Securities

public Securities(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

Securities

public Securities(User _currUser,
                  int initialCapacity,
                  int capacityIncrement)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final Securities findByIds(User _currUser,
                                         java.lang.String _sIds)
                                  throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Securities openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[Securities]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[Securities]
抛出：
WCMException

createNewInstance

public static Securities createNewInstance(User _currUser)
                                    throws WCMException
产生当前集合对象[Securities]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Security

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 Security

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.resource.Security
所有已实现的接口：
java.lang.Cloneable
public class Security
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
Security()
方法摘要
static Security | createNewInstance() 产生当前对象[Security]的实例
static Security | findById(int _nId) 提取指定ID的对象
static Security | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取描述
java.lang.String | getDisp() 获取显示名称
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName() 获取名称
int | getValue() 获取安全级别的值
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isValid() 效验数据的有效性
boolean | setDesc(java.lang.String _desc) 设置描述
boolean | setDisp(java.lang.String _disp) 设置显示名称
boolean | setName(java.lang.String _name) 设置名称
boolean | setValue(int _value) 设置安全级别的值
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Security

public Security()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getName

public java.lang.String getName()
获取名称

返回：
名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置名称

参数：
_name - 名称
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取描述

返回：
描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置描述

参数：
_desc - 描述
返回：
抛出：
WCMException

getDisp

public java.lang.String getDisp()
获取显示名称

返回：
显示名称

setDisp

public boolean setDisp(java.lang.String _disp)
                throws WCMException
设置显示名称

参数：
_disp - 显示名称
返回：
抛出：
WCMException

getValue

public int getValue()
获取安全级别的值

返回：
安全级别的值

setValue

public boolean setValue(int _value)
                 throws WCMException
设置安全级别的值

参数：
_value - 安全级别的值
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
效验数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 新增模式下： 1、没有设置名称 2、没有设置安全级别值 3、名称重复
另请参见：
WCMObj.isValid()

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

findById

public static final Security findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Security createNewInstance()
                                        throws WCMException
产生当前对象[Security]的实例

返回：
当前对象的实例[Security]
抛出：
WCMException

findByKey

public static final Security findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Source

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 Source

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.resource.Source
所有已实现的接口：
java.lang.Cloneable
public class Source
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
Source()
方法摘要
static Source | createNewInstance() 产生当前对象[Source]的实例
static Source | findById(int _nId) 提取指定ID的对象
static Source | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 获取属性（用于扩展）
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取来源描述
static java.lang.String | getFirstLetter(java.lang.String _sFileName, java.lang.String _str)
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getLink() 获取来源链接
java.lang.String | getName() 获取来源名称
int | getOrder() 获取排序序号
int | getPrice() 获取来源的稿件单价
Security | getSecurity() 获取与来源有关的安全级别对象
int | getSecurityId() 获取与来源有关的安全级别对象ID
java.lang.String | getType() 获取来源类型
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isValid() 效验数据的有效性
static void | loadFirstLetter(java.lang.String _sFileName)
static void | main(java.lang.String[] args)
boolean | setAttribute(java.lang.String _attribute) 设置属性（用于扩展）
void | setCheckedSiteId(boolean _bCheckedSiteId) 设置校验来源重名时是否需要校验所属站点属性 默认为不校验
boolean | setDesc(java.lang.String _desc) 设置来源描述
boolean | setLink(java.lang.String _link) 设置来源链接
boolean | setName(java.lang.String _name) 设置来源名称
boolean | setOrder(int _nOrder) 设置的排序序号
boolean | setPrice(int _nPrice) 设置来源的稿件单价
boolean | setSecurity(int _nSecurityId) 设置与来源有关的安全级别
boolean | setSecurity(Security _security) 设置与来源有关的安全级别
boolean | setType(java.lang.String _type) 设置来源类型
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Source

public Source()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getName

public java.lang.String getName()
获取来源名称

返回：
来源名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置来源名称

参数：
_name - 来源名称
返回：
@throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取来源描述

返回：
来源描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置来源描述

参数：
_desc - 来源描述
返回：
@throws WCMException
抛出：
WCMException

getLink

public java.lang.String getLink()
获取来源链接

返回：
来源链接

setLink

public boolean setLink(java.lang.String _link)
                throws WCMException
设置来源链接

参数：
_link - 来源链接
返回：
@throws WCMException
抛出：
WCMException

getSecurityId

public int getSecurityId()
获取与来源有关的安全级别对象ID

返回：
与来源有关的安全级别对象ID

getSecurity

public Security getSecurity()
                     throws WCMException
获取与来源有关的安全级别对象

返回：
与来源有关的安全级别对象
抛出：
WCMException

setSecurity

public boolean setSecurity(int _nSecurityId)
                    throws WCMException
设置与来源有关的安全级别

参数：
_nSecurityId - 与来源有关的安全级别对象ID
返回：
@throws WCMException
抛出：
WCMException

setSecurity

public boolean setSecurity(Security _security)
                    throws WCMException
设置与来源有关的安全级别

参数：
_security - 与来源有关的安全级别对象ID
返回：
@throws WCMException
抛出：
WCMException

getPrice

public int getPrice()
获取来源的稿件单价

返回：
来源的稿件单价

setPrice

public boolean setPrice(int _nPrice)
                 throws WCMException
设置来源的稿件单价

参数：
_nPrice - 来源的稿件单价
返回：
@throws WCMException
抛出：
WCMException

getAttribute

public java.lang.String getAttribute()
获取属性（用于扩展）

覆盖：
类 BaseObj 中的 getAttribute
返回：
属性（用于扩展）

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
设置属性（用于扩展）

覆盖：
类 BaseObj 中的 setAttribute
参数：
_attribute - 属性（用于扩展）
返回：
@throws WCMException
抛出：
WCMException

getType

public java.lang.String getType()
获取来源类型

返回：
来源类型

setType

public boolean setType(java.lang.String _type)
                throws WCMException
设置来源类型

参数：
_type - 来源类型
返回：
@throws WCMException
抛出：
WCMException

setCheckedSiteId

public void setCheckedSiteId(boolean _bCheckedSiteId)
设置校验来源重名时是否需要校验所属站点属性 默认为不校验

参数：
_bCheckedSiteId -

isValid

public boolean isValid()
                throws WCMException
效验数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 新增模式下没有设置名称将会抛出异常
另请参见：
WCMObj.isValid()

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

loadFirstLetter

public static void loadFirstLetter(java.lang.String _sFileName)
                            throws WCMException
抛出：
WCMException

getFirstLetter

public static java.lang.String getFirstLetter(java.lang.String _sFileName,
                                              java.lang.String _str)
                                       throws WCMException
抛出：
WCMException

findById

public static final Source findById(int _nId)
                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Source createNewInstance()
                                      throws WCMException
产生当前对象[Source]的实例

返回：
当前对象的实例[Source]
抛出：
WCMException

findByKey

public static final Source findByKey(java.lang.Object _oKey)
                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getOrder

public int getOrder()
获取排序序号

返回：

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置的排序序号

参数：
_nOrder - 站点排序序号
返回：
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Sources

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 Sources

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.resource.Sources

public class Sources
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Sources(User _currUser)
Sources(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Sources | createNewInstance(User _currUser) 产生当前集合对象[Sources]的实例
static Sources | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Sources | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Sources]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Sources

public Sources(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

Sources

public Sources(User _currUser,
               int initialCapacity,
               int capacityIncrement)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final Sources findByIds(User _currUser,
                                      java.lang.String _sIds)
                               throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Sources openWCMObjs(User _currUser,
                                        WCMFilter _filter)
                                 throws WCMException
通过指定一个Filter获取当前集合[Sources]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[Sources]
抛出：
WCMException

createNewInstance

public static Sources createNewInstance(User _currUser)
                                 throws WCMException
产生当前集合对象[Sources]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SourceTypeMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 SourceTypeMgr

java.lang.Object
    继承者  com.trs.components.wcm.resource.SourceTypeMgr

public class SourceTypeMgr
extends java.lang.Object

字段摘要
static int[] | SOURCE_MGRER_ID_ARRAY
static boolean | SOURCE_SUPPORT_TYPE
static java.lang.String[] | SOURCE_TYPE_ARRAY
构造方法摘要
SourceTypeMgr()
方法摘要
static boolean | isSourceMgr(User _user)
static void | loadSourceConfig()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SOURCE_TYPE_ARRAY

public static java.lang.String[] SOURCE_TYPE_ARRAY

SOURCE_MGRER_ID_ARRAY

public static int[] SOURCE_MGRER_ID_ARRAY

SOURCE_SUPPORT_TYPE

public static boolean SOURCE_SUPPORT_TYPE
构造方法详细信息

SourceTypeMgr

public SourceTypeMgr()
方法详细信息

loadSourceConfig

public static void loadSourceConfig()

isSourceMgr

public static boolean isSourceMgr(User _user)

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Status

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 Status

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.resource.Status
所有已实现的接口：
java.lang.Cloneable
public class Status
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
static int | STATUS_ID_AGAIN 系统预先设定的状态对象ID：返工状态 3
static int | STATUS_ID_EDITED 系统预先设定的状态对象ID：已编状态 2
static int | STATUS_ID_NEW 系统预先设定的状态对象ID：新稿状态 1
static int | STATUS_ID_NO 系统预先设定的状态对象ID：已否状态 15
static int | STATUS_ID_PUBLISHED 系统预先设定的状态对象ID：已发状态 10
static int | STATUS_ID_SIGN 系统预先设定的状态对象ID：已签状态 16
static int | STATUS_ID_UNKNOWN 状态对象ID：未知
static int | STATUS_ID_USERDEF 用户定义的状态对象，ID起始值 30
static int | STATUS_ID_VERIFY 系统预先设定的状态对象ID：正审状态 18
构造方法摘要
Status()
方法摘要
static Status | createNewInstance() 产生当前对象[Status]的实例
static Status | findById(int _nId) 提取指定ID的对象
static Status | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc() 获取状态描述
java.lang.String | getDisp() 获取状态显示内容
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName() 获取状态名称
int | getRightIndex() 获取状态相关设置权限索引
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert(User _currUser) 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isUsed() 获取是否使用
boolean | isValid() 检查对象数据的有效性
boolean | setDesc(java.lang.String _desc) 设置状态描述
boolean | setDisp(java.lang.String _disp) 设置状态显示内容
boolean | setName(java.lang.String _name) 设置状态名称
boolean | setRightIndex(int _rightIndex) 设置状态相关权限值
boolean | setUsed(boolean _bUsed) 设置是否使用
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

STATUS_ID_UNKNOWN

public static final int STATUS_ID_UNKNOWN
状态对象ID：未知

另请参见：
常量字段值

STATUS_ID_NEW

public static final int STATUS_ID_NEW
系统预先设定的状态对象ID：新稿状态 1

另请参见：
常量字段值

STATUS_ID_EDITED

public static final int STATUS_ID_EDITED
系统预先设定的状态对象ID：已编状态 2

另请参见：
常量字段值

STATUS_ID_AGAIN

public static final int STATUS_ID_AGAIN
系统预先设定的状态对象ID：返工状态 3

另请参见：
常量字段值

STATUS_ID_PUBLISHED

public static final int STATUS_ID_PUBLISHED
系统预先设定的状态对象ID：已发状态 10

另请参见：
常量字段值

STATUS_ID_NO

public static final int STATUS_ID_NO
系统预先设定的状态对象ID：已否状态 15

另请参见：
常量字段值

STATUS_ID_SIGN

public static final int STATUS_ID_SIGN
系统预先设定的状态对象ID：已签状态 16

另请参见：
常量字段值

STATUS_ID_VERIFY

public static final int STATUS_ID_VERIFY
系统预先设定的状态对象ID：正审状态 18

另请参见：
常量字段值

STATUS_ID_USERDEF

public static final int STATUS_ID_USERDEF
用户定义的状态对象，ID起始值 30

另请参见：
常量字段值
构造方法详细信息

Status

public Status()
另请参见：
WCMObj.WCMObj()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getName

public java.lang.String getName()
获取状态名称

返回：
状态名称

setName

public boolean setName(java.lang.String _name)
                throws WCMException
设置状态名称

参数：
_name - 状态名称
返回：
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取状态描述

返回：
状态描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置状态描述

参数：
_desc - 状态描述
返回：
抛出：
WCMException

getDisp

public java.lang.String getDisp()
获取状态显示内容

返回：
状态显示内容

setDisp

public boolean setDisp(java.lang.String _disp)
                throws WCMException
设置状态显示内容

参数：
_disp - 状态显示内容
返回：
抛出：
WCMException

isUsed

public boolean isUsed()
获取是否使用

返回：
boolean：是否使用

setUsed

public boolean setUsed(boolean _bUsed)
                throws WCMException
设置是否使用

参数：
_bUsed -
返回：
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检查对象数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException - 如果在新增模式下没有设置名称将会抛出异常
另请参见：
WCMObj.isValid()

insert

public void insert(User _currUser)
            throws WCMException
从类 CMSObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 目前操作用户
抛出：
WCMException

getRightIndex

public int getRightIndex()
获取状态相关设置权限索引

返回：
权限索引(定义在com.trs.common.WCMRightTypes中)

setRightIndex

public boolean setRightIndex(int _rightIndex)
                      throws WCMException
设置状态相关权限值

参数：
_rightIndex - 权限索引(定义在com.trs.common.WCMRightTypes中)
返回：
抛出：
WCMException

findById

public static final Status findById(int _nId)
                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Status createNewInstance()
                                      throws WCMException
产生当前对象[Status]的实例

返回：
当前对象的实例[Status]
抛出：
WCMException

findByKey

public static final Status findByKey(java.lang.Object _oKey)
                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Statuses

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.resource
类 Statuses

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.resource.Statuses

public class Statuses
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Statuses(User _currUser)
Statuses(User _currUser, int initialCapacity, int capacityIncrement)
方法摘要
static Statuses | createNewInstance(User _currUser) 产生当前集合对象[Statuses]的实例
static Statuses | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Statuses | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Statuses]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Statuses

public Statuses(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

Statuses

public Statuses(User _currUser,
                int initialCapacity,
                int capacityIncrement)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
另请参见：
CMSBaseObjs.newInstance()

findByIds

public static final Statuses findByIds(User _currUser,
                                       java.lang.String _sIds)
                                throws WCMException
提取指定ID序列的对象集合

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_sIds - 指定的对象ID序列
返回：
指定对象集合（ObjectExamples）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Statuses openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[Statuses]

参数：
_currUser - 当前操作的拥护
_filter - 指定的Filter
返回：
当前集合[Statuses]
抛出：
WCMException

createNewInstance

public static Statuses createNewInstance(User _currUser)
                                  throws WCMException
产生当前集合对象[Statuses]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.resource.DocKind 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.DocKind
的使用

使用 DocKind 的软件包
com.trs.components.wcm.content.persistent
com.trs.components.wcm.resource

com.trs.components.wcm.content.persistent 中 DocKind 的使用

返回 DocKind 的 com.trs.components.wcm.content.persistent 中的方法
 DocKind Document.getKind()
获取文档分类对象

参数类型为 DocKind 的 com.trs.components.wcm.content.persistent 中的方法
 boolean Document.setKind(DocKind _docKind)
设置文档分类

com.trs.components.wcm.resource 中 DocKind 的使用

返回 DocKind 的 com.trs.components.wcm.resource 中的方法
static DocKind | DocKind.createNewInstance() 产生当前对象[DocKind]的实例
static DocKind | DocKind.findById(int _nId) 提取指定ID的对象
static DocKind | DocKind.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
DocKind | DocKind.getParent()

参数类型为 DocKind 的 com.trs.components.wcm.resource 中的方法
 boolean DocKind.setParent(DocKind _parent)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.DocKinds 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.DocKinds
的使用

使用 DocKinds 的软件包
com.trs.components.wcm.resource

com.trs.components.wcm.resource 中 DocKinds 的使用

返回 DocKinds 的 com.trs.components.wcm.resource 中的方法
 DocKinds DocKind.getChildren(User _currUser)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.FileType 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.FileType
的使用

使用 FileType 的软件包
com.trs.components.wcm.content.persistent
com.trs.components.wcm.resource

com.trs.components.wcm.content.persistent 中 FileType 的使用

返回 FileType 的 com.trs.components.wcm.content.persistent 中的方法
 FileType Appendix.getFileType()
获取附件文档类型对象

com.trs.components.wcm.resource 中 FileType 的使用

返回 FileType 的 com.trs.components.wcm.resource 中的方法
static FileType | FileType.createNewInstance() 产生当前对象[FileType]的实例
static FileType | FileType.findById(int _nId) 提取指定ID的对象
static FileType | FileType.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.FileTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.FileTypes
的使用

没有 com.trs.components.wcm.resource.FileTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.Keyword 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.Keyword
的使用

使用 Keyword 的软件包
com.trs.components.wcm.resource

com.trs.components.wcm.resource 中 Keyword 的使用

返回 Keyword 的 com.trs.components.wcm.resource 中的方法
static Keyword | Keyword.createNewInstance() 产生当前对象[Keyword]的实例
static Keyword | Keyword.findById(int _nId) 提取指定ID的对象
static Keyword | Keyword.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.Keywords 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.Keywords
的使用

使用 Keywords 的软件包
com.trs.components.wcm.resource

com.trs.components.wcm.resource 中 Keywords 的使用

返回 Keywords 的 com.trs.components.wcm.resource 中的方法
static Keywords | Keywords.createNewInstance(User _currUser) 产生当前集合对象[Keywords]的实例
static Keywords | Keywords.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Keywords | Keywords.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Keywords]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.ResourceMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.ResourceMgr
的使用

没有 com.trs.components.wcm.resource.ResourceMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.Securities 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.Securities
的使用

使用 Securities 的软件包
com.trs.components.wcm.resource

com.trs.components.wcm.resource 中 Securities 的使用

返回 Securities 的 com.trs.components.wcm.resource 中的方法
static Securities | Securities.createNewInstance(User _currUser) 产生当前集合对象[Securities]的实例
static Securities | Securities.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Securities | Securities.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Securities]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.Security 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.Security
的使用

使用 Security 的软件包
com.trs.components.wcm.content.persistent
com.trs.components.wcm.resource

com.trs.components.wcm.content.persistent 中 Security 的使用

返回 Security 的 com.trs.components.wcm.content.persistent 中的方法
 Security Document.getSecurity()
获取安全级别

参数类型为 Security 的 com.trs.components.wcm.content.persistent 中的方法
 boolean Document.setSecurity(Security _security)
设置安全级别

com.trs.components.wcm.resource 中 Security 的使用

返回 Security 的 com.trs.components.wcm.resource 中的方法
static Security | Security.createNewInstance() 产生当前对象[Security]的实例
static Security | Security.findById(int _nId) 提取指定ID的对象
static Security | Security.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Security | Source.getSecurity() 获取与来源有关的安全级别对象

参数类型为 Security 的 com.trs.components.wcm.resource 中的方法
 boolean Source.setSecurity(Security _security)
设置与来源有关的安全级别

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.Source 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.Source
的使用

使用 Source 的软件包
com.trs.components.wcm.content
com.trs.components.wcm.content.persistent
com.trs.components.wcm.resource

com.trs.components.wcm.content 中 Source 的使用

返回 Source 的 com.trs.components.wcm.content 中的方法
 Source ViewDocument.getSource()
获取文档来源

com.trs.components.wcm.content.persistent 中 Source 的使用

返回 Source 的 com.trs.components.wcm.content.persistent 中的方法
 Source Document.getSource()
获取文档来源

参数类型为 Source 的 com.trs.components.wcm.content.persistent 中的方法
 boolean Document.setSource(Source _source)
设置文档来源

com.trs.components.wcm.resource 中 Source 的使用

返回 Source 的 com.trs.components.wcm.resource 中的方法
static Source | Source.createNewInstance() 产生当前对象[Source]的实例
static Source | Source.findById(int _nId) 提取指定ID的对象
static Source | Source.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.Sources 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.Sources
的使用

使用 Sources 的软件包
com.trs.components.wcm.resource
com.trs.components.wcm.wcmx.media

com.trs.components.wcm.resource 中 Sources 的使用

返回 Sources 的 com.trs.components.wcm.resource 中的方法
static Sources | Sources.createNewInstance(User _currUser) 产生当前集合对象[Sources]的实例
static Sources | Sources.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Sources | Sources.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Sources]

com.trs.components.wcm.wcmx.media 中 Sources 的使用

返回 Sources 的 com.trs.components.wcm.wcmx.media 中的方法
 Sources MediaRemindedAgent.getSourcesRemided(User _currUser)
获取用户需要提醒的媒体集合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.SourceTypeMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.SourceTypeMgr
的使用

没有 com.trs.components.wcm.resource.SourceTypeMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.Status 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.Status
的使用

使用 Status 的软件包
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.components.gkml.sqgk.persistent
com.trs.components.metadata.center
com.trs.components.wcm.content
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.resource
com.trs.service
com.trs.service.impl

com.trs.cms.process.definition 中 Status 的使用

返回 Status 的 com.trs.cms.process.definition 中的方法
 Status FlowNodeBranch.getStatus()
获取文档经过此分支时自动改变后的状态

参数类型为 Status 的 com.trs.cms.process.definition 中的方法
 boolean FlowNodeBranch.setStatus(Status _status)
设置文档经过此分支时自动改变后的状态

com.trs.cms.process.engine 中 Status 的使用

返回 Status 的 com.trs.cms.process.engine 中的方法
 Status FlowNextBranchInfo.getChangeStatus()

参数类型为 Status 的 com.trs.cms.process.engine 中的方法
 void FlowNextBranchInfo.setChangeStatus(Status changeStatus)

com.trs.components.gkml.sqgk.persistent 中 Status 的使用

返回 Status 的 com.trs.components.gkml.sqgk.persistent 中的方法
 Status ApplyForm.getStatus()
获取文档状态

com.trs.components.metadata.center 中 Status 的使用

返回 Status 的 com.trs.components.metadata.center 中的方法
 Status MetaViewData.getStatus()

com.trs.components.wcm.content 中 Status 的使用

返回 Status 的 com.trs.components.wcm.content 中的方法
 Status ViewDocument.getStatus()

com.trs.components.wcm.content.domain 中 Status 的使用

返回 Status 的 com.trs.components.wcm.content.domain 中的方法
 Status DocumentMgr.getDocStatus(Document _currDocument, int _nChnlId)
获取当前文档在所有频道下的状态

参数类型为 Status 的 com.trs.components.wcm.content.domain 中的方法
 void DocumentMgr.changeStatus(Document _currDocument, Channel _currChannel, Status _newStatus)
修改ChnlDoc中对应的状态
如果是实体文档，则同步状态

com.trs.components.wcm.content.persistent 中 Status 的使用

返回 Status 的 com.trs.components.wcm.content.persistent 中的方法
Status | ChnlDoc.getStatus() 提取ChnlDoc的状态
Status | Document.getStatus() 获取文档状态

参数类型为 Status 的 com.trs.components.wcm.content.persistent 中的方法
boolean | WebSite.addPubStatus(Status _status) 添加站点的可发布文档状态
boolean | ChannelSyn.addStatus(Status _status)
boolean | Document.setStatus(Status _status) 设置文档状态
boolean | Document.setStatus(Status _status, boolean _bDeleted) 设置文档状态

com.trs.components.wcm.resource 中 Status 的使用

返回 Status 的 com.trs.components.wcm.resource 中的方法
static Status | Status.createNewInstance() 产生当前对象[Status]的实例
static Status | Status.findById(int _nId) 提取指定ID的对象
static Status | Status.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

com.trs.service 中 Status 的使用

参数类型为 Status 的 com.trs.service 中的方法
void | IDocumentService.changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
void | IDocumentService.changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)

com.trs.service.impl 中 Status 的使用

参数类型为 Status 的 com.trs.service.impl 中的方法
void | DocumentService.changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus)
void | DocumentService.changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.resource.Statuses 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.resource.Statuses
的使用

使用 Statuses 的软件包
com.trs.ajaxservice
com.trs.components.wcm.content.persistent
com.trs.components.wcm.resource

com.trs.ajaxservice 中 Statuses 的使用

返回 Statuses 的 com.trs.ajaxservice 中的方法
 Statuses StatusServiceProvider.queryDocumentStatuses(MethodContext _methContext)
获取当前用户在指定频道下可以改变状态

com.trs.components.wcm.content.persistent 中 Statuses 的使用

返回 Statuses 的 com.trs.components.wcm.content.persistent 中的方法
Statuses | AutoBakConfig.getCanSavedDocStatus(User _currUser) 获取可以进行自动保存的文档状态
Statuses | WebSite.getPubStatuses(User _currUser) 取所有允许发布的文档状态对象集合
Statuses | WebSite.getSaveStatuses(User _currUser) 获取站点上允许发布的文档状态
Statuses | ChannelSyn.getStatuses(User _currUser)

com.trs.components.wcm.resource 中 Statuses 的使用

返回 Statuses 的 com.trs.components.wcm.resource 中的方法
static Statuses | Statuses.createNewInstance(User _currUser) 产生当前集合对象[Statuses]的实例
static Statuses | Statuses.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Statuses | Statuses.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Statuses]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FileService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.soap
类 FileService

java.lang.Object
    继承者  com.trs.components.wcm.soap.FileService

public class FileService
extends java.lang.Object

构造方法摘要
FileService()
方法摘要
static java.lang.String sendFile(byte[] inBytes, java.lang.String Server, java.lang.String fileExt)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileService

public FileService()
方法详细信息

sendFile

public static java.lang.String sendFile(byte[] inBytes,
                                        java.lang.String Server,
                                        java.lang.String fileExt)
                                 throws java.io.IOException
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.soap
类
FileService
WordFileService


com.trs.components.wcm.soap

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.soap

类摘要
FileService
WordFileService


com.trs.components.wcm.soap 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.soap 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.soap.FileService
    • com.trs.components.wcm.soap.WordFileService


软件包 com.trs.components.wcm.soap 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.soap
的使用

没有 com.trs.components.wcm.soap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WordFileService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.soap
类 WordFileService

java.lang.Object
    继承者  com.trs.components.wcm.soap.WordFileService

public class WordFileService
extends java.lang.Object

构造方法摘要
WordFileService()
方法摘要
static java.lang.String | getValidFileExts() 返回允许导入的文件后缀名
static java.lang.String | receiveFileByBase64(java.lang.String strData, java.lang.String Server, java.lang.String fileExt) 通过Base64编码的方式接收数据
static java.lang.String | receiveFileByBytes(byte[] _pData, java.lang.String Server, java.lang.String fileExt) 通过Bytes方式接收数据
static java.lang.String | sendFileBase64(java.lang.String strData, java.lang.String Server, java.lang.String fileExt) 已过时。 表达的意思和执行的操作不一致,已经使用新的接口[receiveFileByBase64]替代
static void | setValidFileExts(java.lang.String _fileExts) 设置允许导入的文件后缀名
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WordFileService

public WordFileService()
方法详细信息

sendFileBase64

public static java.lang.String sendFileBase64(java.lang.String strData,
                                              java.lang.String Server,
                                              java.lang.String fileExt)
                                       throws java.io.IOException
已过时。 表达的意思和执行的操作不一致,已经使用新的接口[receiveFileByBase64]替代

通过Base64编码的方式接收数据

参数：
strData - 经过Base64编码的文件数据
Server - WCM服务器的地址
fileExt - 文件后缀名
返回：
抛出：
java.io.IOException

receiveFileByBase64

public static java.lang.String receiveFileByBase64(java.lang.String strData,
                                                   java.lang.String Server,
                                                   java.lang.String fileExt)
                                            throws java.io.IOException
通过Base64编码的方式接收数据

参数：
strData - 经过Base64编码的文件数据
Server - WCM服务器的地址
fileExt - 文件后缀名
返回：
抛出：
java.io.IOException

receiveFileByBytes

public static java.lang.String receiveFileByBytes(byte[] _pData,
                                                  java.lang.String Server,
                                                  java.lang.String fileExt)
                                           throws java.io.IOException
通过Bytes方式接收数据

参数：
_pData - bytes方式的文件数据
Server - WCM服务器的地址
fileExt - 文件后缀名
返回：
抛出：
java.io.IOException

getValidFileExts

public static java.lang.String getValidFileExts()
返回允许导入的文件后缀名

返回：
允许导入的文件后缀名，多个文件名使用";"分隔

setValidFileExts

public static void setValidFileExts(java.lang.String _fileExts)
设置允许导入的文件后缀名

参数：
_fileExts - 允许导入的文件后缀名，多个文件名使用";"分隔
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.soap.FileService 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.soap.FileService
的使用

没有 com.trs.components.wcm.soap.FileService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.soap.WordFileService 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.soap.WordFileService
的使用

没有 com.trs.components.wcm.soap.WordFileService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.wcm.stat
类
StatAutoRunWorker
StatFieldMap
StatFieldMaps
StatHost
StatHosts
StatMgr
StatResultHolder
StatView
StatViewRel
StatViewRels
StatViews


com.trs.components.wcm.stat

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.stat

类摘要
StatAutoRunWorker | Title: TRS 内容协作平台（TRS WCM） Description: 自动统计数据到临时表的Worker Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
StatFieldMap |
StatFieldMaps |
StatHost |
StatHosts |
StatMgr | Title: TRS 内容协作平台（TRS WCM） Description: 统计 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
StatResultHolder | Title: TRS 内容协作平台（TRS WCM） Description: Cached StatResult.
StatView |
StatViewRel |
StatViewRels |
StatViews |


com.trs.components.wcm.stat 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.stat 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.components.common.job.BaseScheduleWorker
        • com.trs.components.wcm.stat.StatAutoRunWorker
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.stat.StatFieldMap
        • com.trs.components.wcm.stat.StatHost
        • com.trs.components.wcm.stat.StatView
        • com.trs.components.wcm.stat.StatViewRel
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.stat.StatFieldMaps
        • com.trs.components.wcm.stat.StatHosts
        • com.trs.components.wcm.stat.StatViewRels
        • com.trs.components.wcm.stat.StatViews
    • com.trs.components.wcm.stat.StatMgr
    • com.trs.components.wcm.stat.StatResultHolder


软件包 com.trs.components.wcm.stat 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.stat
的使用

使用 com.trs.components.wcm.stat 的软件包
com.trs.components.wcm.stat
com.trs.components.wcm.stat.chart
com.trs.service
com.trs.service.impl

com.trs.components.wcm.stat 使用的 com.trs.components.wcm.stat 中的类
StatFieldMap
StatFieldMaps
StatHost
StatHosts
StatResultHolder
Title: TRS 内容协作平台（TRS WCM）
Description:
Cached StatResult.
StatView
StatViewRel
StatViewRels
StatViews

com.trs.components.wcm.stat.chart 使用的 com.trs.components.wcm.stat 中的类
StatFieldMaps

com.trs.service 使用的 com.trs.components.wcm.stat 中的类
StatFieldMaps
StatHost
StatHosts
StatView
StatViews

com.trs.service.impl 使用的 com.trs.components.wcm.stat 中的类
StatFieldMaps
StatHost
StatHosts
StatView
StatViews

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


StatAutoRunWorker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatAutoRunWorker

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.components.common.job.BaseScheduleWorker
            继承者  com.trs.components.wcm.stat.StatAutoRunWorker
所有已实现的接口：
org.quartz.Job
public class StatAutoRunWorker
extends BaseScheduleWorker

Title: TRS 内容协作平台（TRS WCM）
Description:
自动统计数据到临时表的Worker
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
StatAutoRunWorker()
方法摘要
从类 com.trs.components.common.job.BaseScheduleWorker 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatAutoRunWorker

public StatAutoRunWorker()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


StatFieldMap

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatFieldMap

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.stat.StatFieldMap
所有已实现的接口：
java.lang.Cloneable
public class StatFieldMap
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
StatFieldMap()
构造函数：保留默认接口
方法摘要
static StatFieldMap | createNewInstance() 产生当前对象[StatFieldsMap]的实例
static StatFieldMap | findById(int _nId) 提取指定ID的对象
static StatFieldMap | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getAttribute() 提取属性：Attribute
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getFieldDesc() 提取属性：FieldDesc
int | getFieldLength() 提取属性：FieldPos
java.lang.String | getFieldName() 提取属性：FieldName
int | getFieldPos() 提取属性：FieldPos
int | getFieldTop() 提取属性：IsTop
java.lang.String | getFieldType() 提取属性：FieldType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getStatTempId() 提取属性：StatTempId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setAttribute(java.lang.String _sAttribute) 设置属性：Attribute
boolean | setFieldDesc(java.lang.String _sFieldDesc) 设置属性：FieldDesc
boolean | setFieldLength(int _nFieldLength) 设置属性：FieldLength
boolean | setFieldName(java.lang.String _sFieldName) 设置属性：FieldName
boolean | setFieldPos(int _nFieldPos) 设置属性：FieldPos
boolean | setFieldTop(int _nFieldTop) 设置属性：FieldPos
boolean | setFieldType(java.lang.String _sFieldType) 设置属性：FieldType
boolean | setStatTempId(int _nStatTempId) 设置属性：StatTempId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

StatFieldMap

public StatFieldMap()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getStatTempId

public int getStatTempId()
提取属性：StatTempId

返回：
StatTempId

setStatTempId

public boolean setStatTempId(int _nStatTempId)
                      throws WCMException
设置属性：StatTempId

参数：
_nStatTempId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldPos

public int getFieldPos()
提取属性：FieldPos

返回：
FieldPos

setFieldTop

public boolean setFieldTop(int _nFieldTop)
                    throws WCMException
设置属性：FieldPos

参数：
_nFieldPos - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldTop

public int getFieldTop()
提取属性：IsTop

返回：
IsTop

setFieldPos

public boolean setFieldPos(int _nFieldPos)
                    throws WCMException
设置属性：FieldPos

参数：
_nFieldPos - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldName

public java.lang.String getFieldName()
提取属性：FieldName

返回：
FieldName

setFieldName

public boolean setFieldName(java.lang.String _sFieldName)
                     throws WCMException
设置属性：FieldName

参数：
_sFieldName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldDesc

public java.lang.String getFieldDesc()
提取属性：FieldDesc

返回：
FieldDesc

setFieldDesc

public boolean setFieldDesc(java.lang.String _sFieldDesc)
                     throws WCMException
设置属性：FieldDesc

参数：
_sFieldDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldType

public java.lang.String getFieldType()
提取属性：FieldType

返回：
FieldType

setFieldType

public boolean setFieldType(java.lang.String _sFieldType)
                     throws WCMException
设置属性：FieldType

参数：
_sFieldType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldLength

public int getFieldLength()
提取属性：FieldPos

返回：
FieldPos

setFieldLength

public boolean setFieldLength(int _nFieldLength)
                       throws WCMException
设置属性：FieldLength

参数：
_nFieldLength - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getAttribute

public java.lang.String getAttribute()
提取属性：Attribute

覆盖：
类 BaseObj 中的 getAttribute
返回：
Attribute

setAttribute

public boolean setAttribute(java.lang.String _sAttribute)
                     throws WCMException
设置属性：Attribute

覆盖：
类 BaseObj 中的 setAttribute
参数：
_sAttribute - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final StatFieldMap findById(int _nId)
                                   throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final StatFieldMap createNewInstance()
                                            throws WCMException
产生当前对象[StatFieldsMap]的实例

返回：
当前对象的实例[StatFieldsMap]
抛出：
WCMException

findByKey

public static final StatFieldMap findByKey(java.lang.Object _oKey)
                                    throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatFieldMaps

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatFieldMaps

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.stat.StatFieldMaps

public class StatFieldMaps
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
StatFieldMaps(User _currUser)
构造函数
StatFieldMaps(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static StatFieldMaps | createNewInstance(User _currUser) 产生当前集合对象[StatFieldsMaps]的实例
static StatFieldMaps | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static StatFieldMaps | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatFieldsMaps]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatFieldMaps

public StatFieldMaps(User _currUser)
构造函数

另请参见：
StatFieldsMaps( User _currUser, int _initCapacity, int _incCapacity );

StatFieldMaps

public StatFieldMaps(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final StatFieldMaps findByIds(User _currUser,
                                            java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（StatFieldsMaps）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final StatFieldMaps openWCMObjs(User _currUser,
                                              WCMFilter _filter)
                                       throws WCMException
通过指定一个Filter获取当前集合[StatFieldsMaps]

参数：
_filter - 指定的Filter
返回：
当前集合[StatFieldsMaps]
抛出：
WCMException

createNewInstance

public static StatFieldMaps createNewInstance(User _currUser)
产生当前集合对象[StatFieldsMaps]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatHost

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatHost

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.stat.StatHost
所有已实现的接口：
java.lang.Cloneable
public class StatHost
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
StatHost()
构造函数：保留默认接口
方法摘要
static StatHost | createNewInstance() 产生当前对象[StatHost]的实例
static StatHost | findById(int _nId) 提取指定ID的对象
static StatHost | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getHostDesc() 提取属性：HostDesc
java.lang.String | getHostName() 提取属性：HostName
int | getHostType() 提取属性：HostType
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getWCMTableId() 提取属性：WCMTableId
java.lang.String | getWCMTableName() 提取属性：WCMTableName
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setHostDesc(java.lang.String _sHostDesc) 设置属性：HostDesc
boolean | setHostName(java.lang.String _sHostName) 设置属性：HostName
boolean | setHostType(int _nHostType) 设置属性：HostType
boolean | setWCMTableId(java.lang.String _sWCMTableId) 设置属性：WCMTableId
boolean | setWCMTableName(java.lang.String _sWCMTableName) 设置属性：WCMTableName
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

StatHost

public StatHost()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getHostName

public java.lang.String getHostName()
提取属性：HostName

返回：
HostName

setHostName

public boolean setHostName(java.lang.String _sHostName)
                    throws WCMException
设置属性：HostName

参数：
_sHostName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostDesc

public java.lang.String getHostDesc()
提取属性：HostDesc

返回：
HostDesc

setHostDesc

public boolean setHostDesc(java.lang.String _sHostDesc)
                    throws WCMException
设置属性：HostDesc

参数：
_sHostDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWCMTableName

public java.lang.String getWCMTableName()
提取属性：WCMTableName

返回：
WCMTableName

setWCMTableName

public boolean setWCMTableName(java.lang.String _sWCMTableName)
                        throws WCMException
设置属性：WCMTableName

参数：
_sWCMTableName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHostType

public int getHostType()
提取属性：HostType

返回：
HostType

setHostType

public boolean setHostType(int _nHostType)
                    throws WCMException
设置属性：HostType

参数：
_nHostType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWCMTableId

public java.lang.String getWCMTableId()
提取属性：WCMTableId

返回：
WCMTableId

setWCMTableId

public boolean setWCMTableId(java.lang.String _sWCMTableId)
                      throws WCMException
设置属性：WCMTableId

参数：
_sWCMTableId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final StatHost findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final StatHost createNewInstance()
                                        throws WCMException
产生当前对象[StatHost]的实例

返回：
当前对象的实例[StatHost]
抛出：
WCMException

findByKey

public static final StatHost findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatHosts

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatHosts

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.stat.StatHosts

public class StatHosts
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
StatHosts(User _currUser)
构造函数
StatHosts(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static StatHosts | createNewInstance(User _currUser) 产生当前集合对象[StatHosts]的实例
static StatHosts | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static StatHosts | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatHosts]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatHosts

public StatHosts(User _currUser)
构造函数

另请参见：
StatHosts( User _currUser, int _initCapacity, int _incCapacity );

StatHosts

public StatHosts(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final StatHosts findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（StatHosts）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final StatHosts openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[StatHosts]

参数：
_filter - 指定的Filter
返回：
当前集合[StatHosts]
抛出：
WCMException

createNewInstance

public static StatHosts createNewInstance(User _currUser)
产生当前集合对象[StatHosts]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatMgr

java.lang.Object
    继承者  com.trs.components.wcm.stat.StatMgr

public class StatMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
统计
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String StatMgrName
构造方法摘要
StatMgr()
方法摘要
void | autorunStat() 自动执行统计数据的工作 每天早上2:00开始进行统计，对所有模板型概览模板进行统计数据的生成 以system的身份运行此任务
void | clearStatResult(int _nStatViewId) 删除统计视图对应的临时表中的数据 只有模板类视图才有临时表
Reports | deleteStatHost(StatHost _delStatHost) 删除统计主体
Reports | deleteStatView(StatView _delStatview) 删除一个统计视图
StatView | findStatViewByName(java.lang.String _sName) 根据统计视图的名称定位统计元素
void | generateTodayStat(int _nStatViewId) 产生特定统计视图模板当天的统计数据 统计数据记录在统计表中 可以由定时任务触发，也可以由初始化统计表格触发
CMyResultSets | getCurrentStatResult(int _nStatViewId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 做一个即时统计.模板统计视图不允许.
StatViews | getEmbeddedViews(StatView _mainView) 得到一个模板类视图的所有子视图（嵌入式）
StatFieldMaps | getStatFieldsByView(int _nStatViewId) 得到一个统计视图模板中的字段映射表（字段列表） 从统计映射表中获取，而不是从Select中自动识别
CMyResultSets | getStatResult(int _nStatViewId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy) 统计在一个时间段内，符合特定条件的某个统计的结果 从临时统计表中查询，所以时间条件都是以DEF_STATTIME为准 Id需要从表中构造 Notes: The view shoulb be a Template View.
CMyResultSets | getStatResult(java.lang.String _sqlStat, java.lang.String _sId) 进行用户定制的统计并返回统计结果
StatViews | getStatViews(java.lang.String _sStatHostName, int _nStatViewType, WCMFilter _filter) 获取指定统计主体下的统计视图.
StatFieldMaps | getViewFields(int _nStatViewId) 得到一个统计视图模板中的字段映射表（字段列表） 从统计映射表中获取，而不是从Select中自动识别
StatView | saveStatView(StatView _currStatView, java.util.List _fieldMapList) 保存统计视图模板 其中包括保存视图模板和字段列表
void | setStatViewRelation(StatView _mainView, StatViews _embeddedViews) 设置模板视图和嵌入视图的关联关系
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

StatMgrName

public static final java.lang.String StatMgrName
另请参见：
常量字段值
构造方法详细信息

StatMgr

public StatMgr()
方法详细信息

getStatResult

public CMyResultSets getStatResult(java.lang.String _sqlStat,
                                   java.lang.String _sId)
                            throws WCMException
进行用户定制的统计并返回统计结果

参数：
_sqlStat - 用户定制的统计语句，完整的SQL
返回：
统计结果集合
抛出：
WCMException

getStatResult

public CMyResultSets getStatResult(int _nStatViewId,
                                   CMyDateTime _fromDate,
                                   CMyDateTime _toDate,
                                   java.lang.String _sqlWhere,
                                   java.lang.String _sqlOrderBy)
                            throws WCMException
统计在一个时间段内，符合特定条件的某个统计的结果
从临时统计表中查询，所以时间条件都是以DEF_STATTIME为准
Id需要从表中构造
Notes:
The view shoulb be a Template View.
That means the view type is StatView.VIEW_TYPE_TEMPLATE

参数：
_nStatViewId - 统计视图Id
_fromDate - 统计开始时间，如果为null，则表示包括所有结束之前的统计数据
_toDate - 统计结束时间，如果为null，则表示包含所有开始之后的统计诗句
_sqlWhere - 附加的条件，比如名称为xx。或者数字小于多少的，等等。如果为null则表示没有附加查询条件
附件的条件不需要加AND
返回：
统计结果集合
抛出：
WCMException

getViewFields

public StatFieldMaps getViewFields(int _nStatViewId)
                            throws WCMException
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别

参数：
_nStatViewId - 统计模板Id
返回：
统计模板中的字段映射表
抛出：
WCMException

generateTodayStat

public void generateTodayStat(int _nStatViewId)
                       throws WCMException
产生特定统计视图模板当天的统计数据
统计数据记录在统计表中
可以由定时任务触发，也可以由初始化统计表格触发

参数：
_nStatViewId - 统计模板Id
抛出：
WCMException

getCurrentStatResult

public CMyResultSets getCurrentStatResult(int _nStatViewId,
                                          CMyDateTime _fromDate,
                                          CMyDateTime _toDate,
                                          java.lang.String _sqlWhere)
                                   throws WCMException
做一个即时统计.模板统计视图不允许.

参数：
_nStatViewId -
_fromDate -
_toDate -
_sqlWhere -
返回：
@throws WCMException
抛出：
WCMException

getStatViews

public StatViews getStatViews(java.lang.String _sStatHostName,
                              int _nStatViewType,
                              WCMFilter _filter)
                       throws WCMException
获取指定统计主体下的统计视图.

参数：
_sStatHostName - 统计主体名称
_nStatViewType - 统计视图类型(StateView.VIEW_TYPE_TEMPLATE等)
_filter - 过滤器,额外的查询条件.
返回：
@throws WCMException
抛出：
WCMException

findStatViewByName

public StatView findStatViewByName(java.lang.String _sName)
                            throws WCMException
根据统计视图的名称定位统计元素

参数：
_sName - 统计视图的名称
返回：
统计元素，如果没有找到则返回null
抛出：
WCMException

saveStatView

public StatView saveStatView(StatView _currStatView,
                             java.util.List _fieldMapList)
                      throws WCMException
保存统计视图模板
其中包括保存视图模板和字段列表

参数：
_currStatView - 统计视图模板
_fieldMapList - 视图字段映射表
返回：
@throws WCMException VIEWNAME、VIEWTYPE、STATHOST、TIMEFIELD、SELECT、FROM、字段列表不能为空，且必须有效否则抛出异常
抛出：
WCMException

autorunStat

public void autorunStat()
                 throws WCMException
自动执行统计数据的工作
每天早上2:00开始进行统计，对所有模板型概览模板进行统计数据的生成
以system的身份运行此任务

抛出：
WCMException

deleteStatView

public final Reports deleteStatView(StatView _delStatview)
                             throws WCMException
删除一个统计视图

参数：
_delStatview -
抛出：
WCMException

setStatViewRelation

public void setStatViewRelation(StatView _mainView,
                                StatViews _embeddedViews)
                         throws WCMException
设置模板视图和嵌入视图的关联关系

参数：
_nMainViewId -
_sEmbeddedViewIds -
抛出：
WCMException

getEmbeddedViews

public StatViews getEmbeddedViews(StatView _mainView)
                           throws WCMException
得到一个模板类视图的所有子视图（嵌入式）

参数：
_nMainView - 主视图，可以是模板类或者即时查询类的，应该也可以是嵌套类
返回：
嵌入视图集合
抛出：
WCMException

clearStatResult

public void clearStatResult(int _nStatViewId)
                     throws WCMException
删除统计视图对应的临时表中的数据
只有模板类视图才有临时表

参数：
_nStatViewId -
抛出：
WCMException

deleteStatHost

public Reports deleteStatHost(StatHost _delStatHost)
                       throws WCMException
删除统计主体

参数：
_delStatHost -
返回：
@throws WCMException
抛出：
WCMException

getStatFieldsByView

public StatFieldMaps getStatFieldsByView(int _nStatViewId)
                                  throws WCMException
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别

参数：
_nStatViewId - 统计模板Id
返回：
统计模板中的字段映射表
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatResultHolder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatResultHolder

java.lang.Object
    继承者  com.trs.components.wcm.stat.StatResultHolder

public class StatResultHolder
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Cached StatResult.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | cacheResults(int _nViewId, CMyResultSets _results)
java.util.List | getCachedResults(int _nViewId)
static StatResultHolder | getInstance()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

cacheResults

public void cacheResults(int _nViewId,
                         CMyResultSets _results)

getCachedResults

public java.util.List getCachedResults(int _nViewId)

getInstance

public static StatResultHolder getInstance()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatView

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatView

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.stat.StatView
所有已实现的接口：
java.lang.Cloneable
public class StatView
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
static int | VIEW_TYPE_ALL
static int | VIEW_TYPE_FIELD 统计视图——字段类，即可以被模板类嵌套，但是不能进行最终显示
static int | VIEW_TYPE_MAX 最大的有效统计视图类型
static int | VIEW_TYPE_MIN 最小的有效统计视图类型
static int | VIEW_TYPE_QUERY 统计视图——即时查询类，即可以直接生成统计结果，不通过临时表
static int | VIEW_TYPE_TEMPLATE 统计视图——模板类，即可以进行嵌套和最终显示
构造方法摘要
StatView()
构造函数：保留默认接口
方法摘要
static StatView | createNewInstance() 产生当前对象[StatView]的实例
static StatView | findById(int _nId) 提取指定ID的对象
static StatView | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getFiledNameFromSelect(int _nFieldPos) 从Select中获得字段名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getResultTable() 提取属性：ResultTable
java.lang.String | getStatHost() 提取属性：StatHost
java.lang.String | getViewAttribute() 提取属性：ViewAttribute
java.lang.String | getViewDesc() 提取属性：ViewDesc
java.lang.String | getViewFrom() 提取属性：ViewFrom
java.lang.String | getViewGroupBy() 提取属性：ViewGroupBy
java.lang.String | getViewName() 提取属性：ViewName
java.lang.String | getViewOrderBy() 提取属性：ViewOrderBy
java.lang.String | getViewSelect() 提取属性：ViewSelect
int | getViewType() 提取属性：ViewType
java.lang.String | getViewWhere() 提取属性：ViewWhere
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
static void | main(java.lang.String[] args)
boolean | setResultTable(java.lang.String _sResultTable) 设置属性：ResultTable
boolean | setStatHost(java.lang.String _sStatHost) 设置属性：StatHost
boolean | setViewAttribute(java.lang.String _sViewAttribute) 设置属性：ViewAttribute
boolean | setViewDesc(java.lang.String _sViewDesc) 设置属性：ViewDesc
boolean | setViewFrom(java.lang.String _sViewFrom) 设置属性：ViewFrom
boolean | setViewGroupBy(java.lang.String _sViewGroupBy) 设置属性：ViewGroupBy
boolean | setViewName(java.lang.String _sViewName) 设置属性：ViewName
boolean | setViewOrderBy(java.lang.String _sViewOrderBy) 设置属性：ViewOrderBy
boolean | setViewSelect(java.lang.String _sViewSelect) 设置属性：ViewSelect
boolean | setViewType(int _nViewType) 设置属性：ViewType
boolean | setViewWhere(java.lang.String _sViewWhere) 设置属性：ViewWhere
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

VIEW_TYPE_TEMPLATE

public static final int VIEW_TYPE_TEMPLATE
统计视图——模板类，即可以进行嵌套和最终显示

另请参见：
常量字段值

VIEW_TYPE_FIELD

public static final int VIEW_TYPE_FIELD
统计视图——字段类，即可以被模板类嵌套，但是不能进行最终显示

另请参见：
常量字段值

VIEW_TYPE_QUERY

public static final int VIEW_TYPE_QUERY
统计视图——即时查询类，即可以直接生成统计结果，不通过临时表

另请参见：
常量字段值

VIEW_TYPE_ALL

public static final int VIEW_TYPE_ALL
另请参见：
常量字段值

VIEW_TYPE_MIN

public static final int VIEW_TYPE_MIN
最小的有效统计视图类型

另请参见：
常量字段值

VIEW_TYPE_MAX

public static final int VIEW_TYPE_MAX
最大的有效统计视图类型

另请参见：
常量字段值
构造方法详细信息

StatView

public StatView()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getViewName

public java.lang.String getViewName()
提取属性：ViewName

返回：
ViewName

setViewName

public boolean setViewName(java.lang.String _sViewName)
                    throws WCMException
设置属性：ViewName

参数：
_sViewName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewDesc

public java.lang.String getViewDesc()
提取属性：ViewDesc

返回：
ViewDesc

setViewDesc

public boolean setViewDesc(java.lang.String _sViewDesc)
                    throws WCMException
设置属性：ViewDesc

参数：
_sViewDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewType

public int getViewType()
提取属性：ViewType

返回：
ViewType

setViewType

public boolean setViewType(int _nViewType)
                    throws WCMException
设置属性：ViewType

参数：
_nViewType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getStatHost

public java.lang.String getStatHost()
提取属性：StatHost

返回：
StatHost

setStatHost

public boolean setStatHost(java.lang.String _sStatHost)
                    throws WCMException
设置属性：StatHost

参数：
_sStatHost - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getResultTable

public java.lang.String getResultTable()
提取属性：ResultTable

返回：
ResultTable

setResultTable

public boolean setResultTable(java.lang.String _sResultTable)
                       throws WCMException
设置属性：ResultTable

参数：
_sResultTable - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewSelect

public java.lang.String getViewSelect()
提取属性：ViewSelect

返回：
ViewSelect

setViewSelect

public boolean setViewSelect(java.lang.String _sViewSelect)
                      throws WCMException
设置属性：ViewSelect

参数：
_sViewSelect - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewFrom

public java.lang.String getViewFrom()
提取属性：ViewFrom

返回：
ViewFrom

setViewFrom

public boolean setViewFrom(java.lang.String _sViewFrom)
                    throws WCMException
设置属性：ViewFrom

参数：
_sViewFrom - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewWhere

public java.lang.String getViewWhere()
提取属性：ViewWhere

返回：
ViewWhere

setViewWhere

public boolean setViewWhere(java.lang.String _sViewWhere)
                     throws WCMException
设置属性：ViewWhere

参数：
_sViewWhere - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewOrderBy

public java.lang.String getViewOrderBy()
提取属性：ViewOrderBy

返回：
ViewOrderBy

setViewOrderBy

public boolean setViewOrderBy(java.lang.String _sViewOrderBy)
                       throws WCMException
设置属性：ViewOrderBy

参数：
_sViewOrderBy - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewGroupBy

public java.lang.String getViewGroupBy()
提取属性：ViewGroupBy

返回：
ViewGroupBy

setViewGroupBy

public boolean setViewGroupBy(java.lang.String _sViewGroupBy)
                       throws WCMException
设置属性：ViewGroupBy

参数：
_sViewGroupBy - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getViewAttribute

public java.lang.String getViewAttribute()
提取属性：ViewAttribute

返回：
ViewAttribute

setViewAttribute

public boolean setViewAttribute(java.lang.String _sViewAttribute)
                         throws WCMException
设置属性：ViewAttribute

参数：
_sViewAttribute - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final StatView findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final StatView createNewInstance()
                                        throws WCMException
产生当前对象[StatView]的实例

返回：
当前对象的实例[StatView]
抛出：
WCMException

findByKey

public static final StatView findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

getFiledNameFromSelect

public java.lang.String getFiledNameFromSelect(int _nFieldPos)
                                        throws WCMException
从Select中获得字段名称

参数：
_nFieldPos - Select中所选字段的位置
返回：
自动产生的名称
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatViewRel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatViewRel

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.stat.StatViewRel
所有已实现的接口：
java.lang.Cloneable
public class StatViewRel
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
StatViewRel()
构造函数：保留默认接口
方法摘要
static StatViewRel | createNewInstance() 产生当前对象[StatViewRel]的实例
static StatViewRel | findById(int _nId) 提取指定ID的对象
static StatViewRel | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getEmbedViewId() 提取属性：EmbedViewId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getMainViewId() 提取属性：MainViewId
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setEmbedViewId(int _nEmbedViewId) 设置属性：EmbedViewId
boolean | setMainViewId(int _nMainViewId) 设置属性：MainViewId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

StatViewRel

public StatViewRel()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getMainViewId

public int getMainViewId()
提取属性：MainViewId

返回：
MainViewId

setMainViewId

public boolean setMainViewId(int _nMainViewId)
                      throws WCMException
设置属性：MainViewId

参数：
_nMainViewId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getEmbedViewId

public int getEmbedViewId()
提取属性：EmbedViewId

返回：
EmbedViewId

setEmbedViewId

public boolean setEmbedViewId(int _nEmbedViewId)
                       throws WCMException
设置属性：EmbedViewId

参数：
_nEmbedViewId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final StatViewRel findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final StatViewRel createNewInstance()
                                           throws WCMException
产生当前对象[StatViewRel]的实例

返回：
当前对象的实例[StatViewRel]
抛出：
WCMException

findByKey

public static final StatViewRel findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatViewRels

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatViewRels

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.stat.StatViewRels

public class StatViewRels
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
StatViewRels(User _currUser)
构造函数
StatViewRels(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static StatViewRels | createNewInstance(User _currUser) 产生当前集合对象[StatViewRels]的实例
static StatViewRels | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static StatViewRels | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatViewRels]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatViewRels

public StatViewRels(User _currUser)
构造函数

另请参见：
StatViewRels( User _currUser, int _initCapacity, int _incCapacity );

StatViewRels

public StatViewRels(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final StatViewRels findByIds(User _currUser,
                                           java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（StatViewRels）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final StatViewRels openWCMObjs(User _currUser,
                                             WCMFilter _filter)
                                      throws WCMException
通过指定一个Filter获取当前集合[StatViewRels]

参数：
_filter - 指定的Filter
返回：
当前集合[StatViewRels]
抛出：
WCMException

createNewInstance

public static StatViewRels createNewInstance(User _currUser)
产生当前集合对象[StatViewRels]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatViews

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat
类 StatViews

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.stat.StatViews

public class StatViews
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
StatViews(User _currUser)
构造函数
StatViews(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static StatViews | createNewInstance(User _currUser) 产生当前集合对象[StatViews]的实例
static StatViews | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static StatViews | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatViews]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatViews

public StatViews(User _currUser)
构造函数

另请参见：
StatViews( User _currUser, int _initCapacity, int _incCapacity );

StatViews

public StatViews(User _currUser,
                 int _initCapacity,
                 int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final StatViews findByIds(User _currUser,
                                        java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（StatViews）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final StatViews openWCMObjs(User _currUser,
                                          WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[StatViews]

参数：
_filter - 指定的Filter
返回：
当前集合[StatViews]
抛出：
WCMException

createNewInstance

public static StatViews createNewInstance(User _currUser)
产生当前集合对象[StatViews]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BarChartProducer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.chart
类 BarChartProducer

java.lang.Object
    继承者  com.trs.components.wcm.stat.chart.BarChartProducer
所有已实现的接口：
de.laures.cewolf.DatasetProducer, java.io.Serializable
public final class BarChartProducer
extends java.lang.Object
implements de.laures.cewolf.DatasetProducer

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

字段摘要
static java.lang.String | PARAM_COMPAREDFIELD
static java.lang.String | PARAM_UNIQUENAME
static java.lang.String | PARAM_VIEWID
从接口 de.laures.cewolf.DatasetProducer 继承的字段
PRODUCER_ATTRIBUTE_NAME
构造方法摘要
BarChartProducer()
方法摘要
java.lang.String | getProducerId()
StatFieldMaps | getStatFieldMaps()
CMyResultSets | getStatResults()
boolean | hasExpired(java.util.Map _params, java.util.Date _since)
java.lang.Object | produceDataset(java.util.Map _params)
void | setStatFieldMaps(StatFieldMaps statFieldMaps)
void | setStatResults(CMyResultSets results)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PARAM_UNIQUENAME

public static final java.lang.String PARAM_UNIQUENAME
另请参见：
常量字段值

PARAM_COMPAREDFIELD

public static final java.lang.String PARAM_COMPAREDFIELD
另请参见：
常量字段值

PARAM_VIEWID

public static final java.lang.String PARAM_VIEWID
另请参见：
常量字段值
构造方法详细信息

BarChartProducer

public BarChartProducer()
方法详细信息

produceDataset

public java.lang.Object produceDataset(java.util.Map _params)
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 produceDataset

hasExpired

public boolean hasExpired(java.util.Map _params,
                          java.util.Date _since)
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 hasExpired

getProducerId

public java.lang.String getProducerId()
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 getProducerId

getStatResults

public final CMyResultSets getStatResults()

setStatResults

public final void setStatResults(CMyResultSets results)

getStatFieldMaps

public final StatFieldMaps getStatFieldMaps()

setStatFieldMaps

public final void setStatFieldMaps(StatFieldMaps statFieldMaps)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.stat.chart
类
BarChartProducer
PieChartProducer


com.trs.components.wcm.stat.chart

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.stat.chart

类摘要
BarChartProducer | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PieChartProducer | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm.stat.chart 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.stat.chart 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.stat.chart.BarChartProducer (implements de.laures.cewolf.DatasetProducer)
    • com.trs.components.wcm.stat.chart.PieChartProducer (implements de.laures.cewolf.DatasetProducer)


软件包 com.trs.components.wcm.stat.chart 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.stat.chart
的使用

没有 com.trs.components.wcm.stat.chart 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PieChartProducer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.chart
类 PieChartProducer

java.lang.Object
    继承者  com.trs.components.wcm.stat.chart.PieChartProducer
所有已实现的接口：
de.laures.cewolf.DatasetProducer, java.io.Serializable
public final class PieChartProducer
extends java.lang.Object
implements de.laures.cewolf.DatasetProducer

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

字段摘要
static java.lang.String | PARAM_COMPAREDFIELD
static java.lang.String | PARAM_UNIQUENAME
static java.lang.String | PARAM_VIEWID
从接口 de.laures.cewolf.DatasetProducer 继承的字段
PRODUCER_ATTRIBUTE_NAME
构造方法摘要
PieChartProducer()
方法摘要
java.lang.String | getProducerId()
StatFieldMaps | getStatFieldMaps()
CMyResultSets | getStatResults()
boolean | hasExpired(java.util.Map _params, java.util.Date _since)
java.lang.Object | produceDataset(java.util.Map _params)
void | setStatFieldMaps(StatFieldMaps statFieldMaps)
void | setStatResults(CMyResultSets results)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PARAM_UNIQUENAME

public static final java.lang.String PARAM_UNIQUENAME
另请参见：
常量字段值

PARAM_COMPAREDFIELD

public static final java.lang.String PARAM_COMPAREDFIELD
另请参见：
常量字段值

PARAM_VIEWID

public static final java.lang.String PARAM_VIEWID
另请参见：
常量字段值
构造方法详细信息

PieChartProducer

public PieChartProducer()
方法详细信息

produceDataset

public java.lang.Object produceDataset(java.util.Map _params)
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 produceDataset

hasExpired

public boolean hasExpired(java.util.Map _params,
                          java.util.Date _since)
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 hasExpired

getProducerId

public java.lang.String getProducerId()
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 getProducerId

getStatResults

public final CMyResultSets getStatResults()

setStatResults

public final void setStatResults(CMyResultSets results)

getStatFieldMaps

public final StatFieldMaps getStatFieldMaps()

setStatFieldMaps

public final void setStatFieldMaps(StatFieldMaps statFieldMaps)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.stat.chart.BarChartProducer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.chart.BarChartProducer
的使用

没有 com.trs.components.wcm.stat.chart.BarChartProducer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.chart.PieChartProducer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.chart.PieChartProducer
的使用

没有 com.trs.components.wcm.stat.chart.PieChartProducer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatAutoRunWorker 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatAutoRunWorker
的使用

没有 com.trs.components.wcm.stat.StatAutoRunWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatFieldMap 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatFieldMap
的使用

使用 StatFieldMap 的软件包
com.trs.components.wcm.stat

com.trs.components.wcm.stat 中 StatFieldMap 的使用

返回 StatFieldMap 的 com.trs.components.wcm.stat 中的方法
static StatFieldMap | StatFieldMap.createNewInstance() 产生当前对象[StatFieldsMap]的实例
static StatFieldMap | StatFieldMap.findById(int _nId) 提取指定ID的对象
static StatFieldMap | StatFieldMap.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatFieldMaps 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatFieldMaps
的使用

使用 StatFieldMaps 的软件包
com.trs.components.wcm.stat
com.trs.components.wcm.stat.chart
com.trs.service
com.trs.service.impl

com.trs.components.wcm.stat 中 StatFieldMaps 的使用

返回 StatFieldMaps 的 com.trs.components.wcm.stat 中的方法
static StatFieldMaps | StatFieldMaps.createNewInstance(User _currUser) 产生当前集合对象[StatFieldsMaps]的实例
static StatFieldMaps | StatFieldMaps.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
StatFieldMaps | StatMgr.getStatFieldsByView(int _nStatViewId) 得到一个统计视图模板中的字段映射表（字段列表） 从统计映射表中获取，而不是从Select中自动识别
StatFieldMaps | StatMgr.getViewFields(int _nStatViewId) 得到一个统计视图模板中的字段映射表（字段列表） 从统计映射表中获取，而不是从Select中自动识别
static StatFieldMaps | StatFieldMaps.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatFieldsMaps]

com.trs.components.wcm.stat.chart 中 StatFieldMaps 的使用

返回 StatFieldMaps 的 com.trs.components.wcm.stat.chart 中的方法
StatFieldMaps | PieChartProducer.getStatFieldMaps()
StatFieldMaps | BarChartProducer.getStatFieldMaps()

参数类型为 StatFieldMaps 的 com.trs.components.wcm.stat.chart 中的方法
void | PieChartProducer.setStatFieldMaps(StatFieldMaps statFieldMaps)
void | BarChartProducer.setStatFieldMaps(StatFieldMaps statFieldMaps)

com.trs.service 中 StatFieldMaps 的使用

返回 StatFieldMaps 的 com.trs.service 中的方法
 StatFieldMaps IStatService.getStatFieldsByView(int _nStatViewId)
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别

com.trs.service.impl 中 StatFieldMaps 的使用

返回 StatFieldMaps 的 com.trs.service.impl 中的方法
 StatFieldMaps StatService.getStatFieldsByView(int _nStatTempId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatHost 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatHost
的使用

使用 StatHost 的软件包
com.trs.components.wcm.stat
com.trs.service
com.trs.service.impl

com.trs.components.wcm.stat 中 StatHost 的使用

返回 StatHost 的 com.trs.components.wcm.stat 中的方法
static StatHost | StatHost.createNewInstance() 产生当前对象[StatHost]的实例
static StatHost | StatHost.findById(int _nId) 提取指定ID的对象
static StatHost | StatHost.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

参数类型为 StatHost 的 com.trs.components.wcm.stat 中的方法
 Reports StatMgr.deleteStatHost(StatHost _delStatHost)
删除统计主体

com.trs.service 中 StatHost 的使用

返回 StatHost 的 com.trs.service 中的方法
 StatHost IStatService.saveStatHost(StatHost _currStatHost)
保存统计主体（即按xxx查询）

参数类型为 StatHost 的 com.trs.service 中的方法
 StatHost IStatService.saveStatHost(StatHost _currStatHost)
保存统计主体（即按xxx查询）

com.trs.service.impl 中 StatHost 的使用

返回 StatHost 的 com.trs.service.impl 中的方法
 StatHost StatService.saveStatHost(StatHost _currStatHost)

参数类型为 StatHost 的 com.trs.service.impl 中的方法
 StatHost StatService.saveStatHost(StatHost _currStatHost)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatHosts 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatHosts
的使用

使用 StatHosts 的软件包
com.trs.components.wcm.stat
com.trs.service
com.trs.service.impl

com.trs.components.wcm.stat 中 StatHosts 的使用

返回 StatHosts 的 com.trs.components.wcm.stat 中的方法
static StatHosts | StatHosts.createNewInstance(User _currUser) 产生当前集合对象[StatHosts]的实例
static StatHosts | StatHosts.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static StatHosts | StatHosts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatHosts]

com.trs.service 中 StatHosts 的使用

返回 StatHosts 的 com.trs.service 中的方法
 StatHosts IStatService.getStatHosts(WCMFilter _filter)
获得系统中提供的所有统计主体

com.trs.service.impl 中 StatHosts 的使用

返回 StatHosts 的 com.trs.service.impl 中的方法
 StatHosts StatService.getStatHosts(WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatMgr
的使用

没有 com.trs.components.wcm.stat.StatMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatResultHolder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatResultHolder
的使用

使用 StatResultHolder 的软件包
com.trs.components.wcm.stat

com.trs.components.wcm.stat 中 StatResultHolder 的使用

返回 StatResultHolder 的 com.trs.components.wcm.stat 中的方法
static StatResultHolder StatResultHolder.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatView 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatView
的使用

使用 StatView 的软件包
com.trs.components.wcm.stat
com.trs.service
com.trs.service.impl

com.trs.components.wcm.stat 中 StatView 的使用

返回 StatView 的 com.trs.components.wcm.stat 中的方法
static StatView | StatView.createNewInstance() 产生当前对象[StatView]的实例
static StatView | StatView.findById(int _nId) 提取指定ID的对象
static StatView | StatView.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
StatView | StatMgr.findStatViewByName(java.lang.String _sName) 根据统计视图的名称定位统计元素
StatView | StatMgr.saveStatView(StatView _currStatView, java.util.List _fieldMapList) 保存统计视图模板 其中包括保存视图模板和字段列表

参数类型为 StatView 的 com.trs.components.wcm.stat 中的方法
Reports | StatMgr.deleteStatView(StatView _delStatview) 删除一个统计视图
StatViews | StatMgr.getEmbeddedViews(StatView _mainView) 得到一个模板类视图的所有子视图（嵌入式）
StatView | StatMgr.saveStatView(StatView _currStatView, java.util.List _fieldMapList) 保存统计视图模板 其中包括保存视图模板和字段列表
void | StatMgr.setStatViewRelation(StatView _mainView, StatViews _embeddedViews) 设置模板视图和嵌入视图的关联关系

com.trs.service 中 StatView 的使用

返回 StatView 的 com.trs.service 中的方法
StatView | IStatService.findStatViewByName(java.lang.String _sName) 获取指定名称的统计视图.
StatView | IStatService.saveStatView(StatView _currStatView, java.util.List _fieldMapList) 保存统计视图模板 其中包括保存视图模板和字段列表

参数类型为 StatView 的 com.trs.service 中的方法
Reports | IStatService.deleteStatView(StatView _delStatView) 删除一个统计视图
StatView | IStatService.saveStatView(StatView _currStatView, java.util.List _fieldMapList) 保存统计视图模板 其中包括保存视图模板和字段列表
void | IStatService.setStatViewRelation(StatView _mainView, StatViews _embeddedViews) 设置模板视图和嵌入视图的关联关系

com.trs.service.impl 中 StatView 的使用

返回 StatView 的 com.trs.service.impl 中的方法
StatView | StatService.findStatViewByName(java.lang.String _sName)
StatView | StatService.saveStatView(StatView _currStatView, java.util.List _fieldMapList)

参数类型为 StatView 的 com.trs.service.impl 中的方法
Reports | StatService.deleteStatView(StatView _delStatView)
StatView | StatService.saveStatView(StatView _currStatView, java.util.List _fieldMapList)
void | StatService.setStatViewRelation(StatView _mainView, StatViews _embeddedViews)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatViewRel 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatViewRel
的使用

使用 StatViewRel 的软件包
com.trs.components.wcm.stat

com.trs.components.wcm.stat 中 StatViewRel 的使用

返回 StatViewRel 的 com.trs.components.wcm.stat 中的方法
static StatViewRel | StatViewRel.createNewInstance() 产生当前对象[StatViewRel]的实例
static StatViewRel | StatViewRel.findById(int _nId) 提取指定ID的对象
static StatViewRel | StatViewRel.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatViewRels 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatViewRels
的使用

使用 StatViewRels 的软件包
com.trs.components.wcm.stat

com.trs.components.wcm.stat 中 StatViewRels 的使用

返回 StatViewRels 的 com.trs.components.wcm.stat 中的方法
static StatViewRels | StatViewRels.createNewInstance(User _currUser) 产生当前集合对象[StatViewRels]的实例
static StatViewRels | StatViewRels.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static StatViewRels | StatViewRels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatViewRels]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.StatViews 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.StatViews
的使用

使用 StatViews 的软件包
com.trs.components.wcm.stat
com.trs.service
com.trs.service.impl

com.trs.components.wcm.stat 中 StatViews 的使用

返回 StatViews 的 com.trs.components.wcm.stat 中的方法
static StatViews | StatViews.createNewInstance(User _currUser) 产生当前集合对象[StatViews]的实例
static StatViews | StatViews.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
StatViews | StatMgr.getEmbeddedViews(StatView _mainView) 得到一个模板类视图的所有子视图（嵌入式）
StatViews | StatMgr.getStatViews(java.lang.String _sStatHostName, int _nStatViewType, WCMFilter _filter) 获取指定统计主体下的统计视图.
static StatViews | StatViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatViews]

参数类型为 StatViews 的 com.trs.components.wcm.stat 中的方法
 void StatMgr.setStatViewRelation(StatView _mainView, StatViews _embeddedViews)
设置模板视图和嵌入视图的关联关系

com.trs.service 中 StatViews 的使用

返回 StatViews 的 com.trs.service 中的方法
StatViews | IStatService.getEmbeddedViews(int _nMainViewId) 得到一个模板类视图的所有子视图（嵌入式）
StatViews | IStatService.getStatViews(java.lang.String _sStatHostName, int _StatViewType, WCMFilter _filter) 获得特定查询主体的统计视图模板

参数类型为 StatViews 的 com.trs.service 中的方法
 void IStatService.setStatViewRelation(StatView _mainView, StatViews _embeddedViews)
设置模板视图和嵌入视图的关联关系

com.trs.service.impl 中 StatViews 的使用

返回 StatViews 的 com.trs.service.impl 中的方法
StatViews | StatService.getEmbeddedViews(int _nMainViewId)
StatViews | StatService.getStatViews(java.lang.String _sStatHostName, int _nStatViewType, WCMFilter _filter)

参数类型为 StatViews 的 com.trs.service.impl 中的方法
 void StatService.setStatViewRelation(StatView _mainView, StatViews _embeddedViews)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChartBuildException

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 ChartBuildException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.components.wcm.stat.domain.ChartBuildException
所有已实现的接口：
java.io.Serializable
public class ChartBuildException
extends java.lang.RuntimeException

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)
另请参见：
序列化表格

构造方法摘要
ChartBuildException()
ChartBuildException(java.lang.String message)
ChartBuildException(java.lang.String message, java.lang.Throwable cause)
ChartBuildException(java.lang.Throwable cause)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ChartBuildException

public ChartBuildException()

ChartBuildException

public ChartBuildException(java.lang.String message)

ChartBuildException

public ChartBuildException(java.lang.Throwable cause)

ChartBuildException

public ChartBuildException(java.lang.String message,
                           java.lang.Throwable cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChartConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 ChartConstants

java.lang.Object
    继承者  com.trs.components.wcm.stat.domain.ChartConstants

public final class ChartConstants
extends java.lang.Object

字段摘要
static int | CATEGORY_BAR
static int | CATEGORY_PIE
static int | COUNTER_DIRCACHEFILES
static int | DEFAULT_TRUNCLENGTH
static java.lang.String | NAME_IMAGE_BOX
static java.lang.String | NAME_IMAGE_PREFIX
方法摘要
static java.util.Map | getChartCategoryNames()
static java.util.Map | getChartMineTypeNames()
static int | getSpecCategory(java.lang.String _sCategoryName)
static java.lang.String | getSpecFileExt(java.lang.String _sMineType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CATEGORY_PIE

public static final int CATEGORY_PIE
另请参见：
常量字段值

CATEGORY_BAR

public static final int CATEGORY_BAR
另请参见：
常量字段值

NAME_IMAGE_BOX

public static final java.lang.String NAME_IMAGE_BOX
另请参见：
常量字段值

NAME_IMAGE_PREFIX

public static final java.lang.String NAME_IMAGE_PREFIX
另请参见：
常量字段值

DEFAULT_TRUNCLENGTH

public static final int DEFAULT_TRUNCLENGTH
另请参见：
常量字段值

COUNTER_DIRCACHEFILES

public static final int COUNTER_DIRCACHEFILES
另请参见：
常量字段值
方法详细信息

getChartCategoryNames

public static java.util.Map getChartCategoryNames()

getChartMineTypeNames

public static java.util.Map getChartMineTypeNames()

getSpecCategory

public static int getSpecCategory(java.lang.String _sCategoryName)
                           throws CMyException
抛出：
CMyException

getSpecFileExt

public static java.lang.String getSpecFileExt(java.lang.String _sMineType)
                                       throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChartOption

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 ChartOption

java.lang.Object
    继承者  com.trs.components.wcm.stat.domain.ChartOption

public class ChartOption
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

字段摘要
static java.lang.String | DEF_DATE_FORMAT
static java.lang.String | GROUPBY_DEFAULT
static int | PERIOD_DAY
static int | PERIOD_MONTH
static int | PERIOD_WEEK
static int | PERIOD_YEAR
构造方法摘要
ChartOption(CMyDateTime _dtStart, CMyDateTime _dtEnd, int _nPeriodType, java.lang.String _sCurrStagField)
ChartOption(CMyDateTime _dtStart, CMyDateTime _dtEnd, int _nPeriodType, java.lang.String _sCurrStagField, java.lang.String _sGroupBy, java.lang.String _sStatTimeField)
方法摘要
java.lang.String | getCurrStageField()
CMyDateTime | getEndStatTime()
java.lang.String | getEndStatTimeAsString()
WCMFilter | getExtraFilter()
java.lang.String | getGroupBy()
int | getPeriodInterval()
int | getPeriodType()
CMyDateTime | getStartStatTime()
java.lang.String | getStartStatTimeAsString()
java.lang.String | getStatTimeField()
void | setCurrStageField(java.lang.String currStageField)
void | setEndStatTime(CMyDateTime endStatTime)
void | setExtraFilter(WCMFilter _filter)
void | setGroupBy(java.lang.String groupBy)
void | setPeriodInterval(int periodInterval)
void | setPeriodType(int periodType)
void | setStartStatTime(CMyDateTime startStatTime)
void | setStatTimeField(java.lang.String statTimeField)
void | validate()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PERIOD_DAY

public static final int PERIOD_DAY
另请参见：
常量字段值

PERIOD_WEEK

public static final int PERIOD_WEEK
另请参见：
常量字段值

PERIOD_MONTH

public static final int PERIOD_MONTH
另请参见：
常量字段值

PERIOD_YEAR

public static final int PERIOD_YEAR
另请参见：
常量字段值

GROUPBY_DEFAULT

public static final java.lang.String GROUPBY_DEFAULT
另请参见：
常量字段值

DEF_DATE_FORMAT

public static java.lang.String DEF_DATE_FORMAT
构造方法详细信息

ChartOption

public ChartOption(CMyDateTime _dtStart,
                   CMyDateTime _dtEnd,
                   int _nPeriodType,
                   java.lang.String _sCurrStagField)

ChartOption

public ChartOption(CMyDateTime _dtStart,
                   CMyDateTime _dtEnd,
                   int _nPeriodType,
                   java.lang.String _sCurrStagField,
                   java.lang.String _sGroupBy,
                   java.lang.String _sStatTimeField)
方法详细信息

validate

public void validate()

getStartStatTimeAsString

public java.lang.String getStartStatTimeAsString()

getEndStatTimeAsString

public java.lang.String getEndStatTimeAsString()

getStartStatTime

public CMyDateTime getStartStatTime()

getEndStatTime

public CMyDateTime getEndStatTime()

getGroupBy

public java.lang.String getGroupBy()

getStatTimeField

public java.lang.String getStatTimeField()

getCurrStageField

public java.lang.String getCurrStageField()

getPeriodType

public int getPeriodType()

getPeriodInterval

public int getPeriodInterval()

setPeriodInterval

public void setPeriodInterval(int periodInterval)

setStartStatTime

public void setStartStatTime(CMyDateTime startStatTime)

setEndStatTime

public void setEndStatTime(CMyDateTime endStatTime)

setGroupBy

public void setGroupBy(java.lang.String groupBy)

setStatTimeField

public void setStatTimeField(java.lang.String statTimeField)

setCurrStageField

public void setCurrStageField(java.lang.String currStageField)

setPeriodType

public void setPeriodType(int periodType)

getExtraFilter

public WCMFilter getExtraFilter()

setExtraFilter

public void setExtraFilter(WCMFilter _filter)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChartStyle

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 ChartStyle

java.lang.Object
    继承者  com.trs.components.wcm.stat.domain.ChartStyle

public class ChartStyle
extends java.lang.Object

字段摘要
static int | DEFAULT_CATEGORY
static int | DEFAULT_HEIGHT
static int | DEFAULT_WIDTH
构造方法摘要
ChartStyle()
方法摘要
int | getChartCategory()
java.lang.String | getChartFileExt()
int | getChartHeight()
java.util.List | getChartSubtitle()
java.lang.String | getChartTitle()
int | getChartWidth()
static ChartStyle | getDefaultStyle()
java.lang.String | getXDesc()
java.lang.String | getYDesc()
boolean | isShowLegend()
static ChartStyle | makeChartStyle(java.lang.String _sTitle, int _nWidth, int _nHeight, java.lang.String _sChartImgTyp, boolean _bShowLegend)
void | setChartCategory(int chartCategory)
void | setChartFileExt(java.lang.String chartFileExt)
void | setChartHeight(int chartHeight)
void | setChartSubtitle(java.lang.String _str)
void | setChartTitle(java.lang.String chartTitle)
void | setChartWidth(int chartWidth)
void | setShowLegend(boolean showLegend)
void | setXDesc(java.lang.String desc)
void | setXYAxisDescs(java.lang.String _sXDesc, java.lang.String _sYDesc)
void | setYDesc(java.lang.String desc)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_WIDTH

public static final int DEFAULT_WIDTH
另请参见：
常量字段值

DEFAULT_HEIGHT

public static final int DEFAULT_HEIGHT
另请参见：
常量字段值

DEFAULT_CATEGORY

public static final int DEFAULT_CATEGORY
另请参见：
常量字段值
构造方法详细信息

ChartStyle

public ChartStyle()
方法详细信息

getDefaultStyle

public static ChartStyle getDefaultStyle()

makeChartStyle

public static ChartStyle makeChartStyle(java.lang.String _sTitle,
                                        int _nWidth,
                                        int _nHeight,
                                        java.lang.String _sChartImgTyp,
                                        boolean _bShowLegend)

setXYAxisDescs

public void setXYAxisDescs(java.lang.String _sXDesc,
                           java.lang.String _sYDesc)

getChartWidth

public int getChartWidth()

getChartHeight

public int getChartHeight()

getChartTitle

public java.lang.String getChartTitle()

setChartHeight

public void setChartHeight(int chartHeight)

setChartTitle

public void setChartTitle(java.lang.String chartTitle)

setChartWidth

public void setChartWidth(int chartWidth)

getChartCategory

public int getChartCategory()

setChartCategory

public void setChartCategory(int chartCategory)

getChartFileExt

public java.lang.String getChartFileExt()

setChartFileExt

public void setChartFileExt(java.lang.String chartFileExt)

isShowLegend

public boolean isShowLegend()

setShowLegend

public void setShowLegend(boolean showLegend)

getXDesc

public java.lang.String getXDesc()

setXDesc

public void setXDesc(java.lang.String desc)

getYDesc

public java.lang.String getYDesc()

setYDesc

public void setYDesc(java.lang.String desc)

setChartSubtitle

public void setChartSubtitle(java.lang.String _str)

getChartSubtitle

public java.util.List getChartSubtitle()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChartWriter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 ChartWriter

java.lang.Object
    继承者  com.trs.components.wcm.stat.domain.ChartWriter

public class ChartWriter
extends java.lang.Object

作者：
gronlet trs.com.cn

构造方法摘要
ChartWriter()
方法摘要
static void | generateChart(java.io.OutputStream _os, org.jfree.chart.JFreeChart oChart)
static void | generateChart(java.io.OutputStream _os, org.jfree.chart.JFreeChart oChart, ChartStyle _oStyle)
static void | generateChart(java.lang.String _sFilepath, org.jfree.chart.JFreeChart oChart)
static void | generateChart(java.lang.String _sFilepath, org.jfree.chart.JFreeChart oChart, ChartStyle _oStyle)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChartWriter

public ChartWriter()
方法详细信息

generateChart

public static void generateChart(java.lang.String _sFilepath,
                                 org.jfree.chart.JFreeChart oChart)
                          throws CMyException
抛出：
CMyException

generateChart

public static void generateChart(java.lang.String _sFilepath,
                                 org.jfree.chart.JFreeChart oChart,
                                 ChartStyle _oStyle)
                          throws CMyException
抛出：
CMyException

generateChart

public static void generateChart(java.io.OutputStream _os,
                                 org.jfree.chart.JFreeChart oChart)
                          throws CMyException
抛出：
CMyException

generateChart

public static void generateChart(java.io.OutputStream _os,
                                 org.jfree.chart.JFreeChart oChart,
                                 ChartStyle _oStyle)
                          throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IChartBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
接口 IChartBuilder

所有已知实现类：
TimingChartBuilder
public interface IChartBuilder

方法摘要
 org.jfree.chart.JFreeChart buildChart(TimingChartData _oChartDataSet, ChartStyle _style, ChartOption _option)

方法详细信息

buildChart

org.jfree.chart.JFreeChart buildChart(TimingChartData _oChartDataSet,
                                      ChartStyle _style,
                                      ChartOption _option)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.stat.domain
接口
IChartBuilder
类
ChartConstants
ChartOption
ChartStyle
ChartWriter
StatDataItem
TimingChartBuilder
TimingChartData
TimingChartProducer
异常
ChartBuildException


com.trs.components.wcm.stat.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.stat.domain

接口摘要
IChartBuilder

类摘要
ChartConstants |
ChartOption | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChartStyle |
ChartWriter |
StatDataItem | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TimingChartBuilder |
TimingChartData |
TimingChartProducer | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
ChartBuildException Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm.stat.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.stat.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.stat.domain.ChartConstants
    • com.trs.components.wcm.stat.domain.ChartOption
    • com.trs.components.wcm.stat.domain.ChartStyle
    • com.trs.components.wcm.stat.domain.ChartWriter
    • com.trs.components.wcm.stat.domain.StatDataItem
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.trs.components.wcm.stat.domain.ChartBuildException
    • com.trs.components.wcm.stat.domain.TimingChartBuilder (implements com.trs.components.wcm.stat.domain.IChartBuilder)
    • com.trs.components.wcm.stat.domain.TimingChartData
    • com.trs.components.wcm.stat.domain.TimingChartProducer (implements de.laures.cewolf.DatasetProducer)

接口分层结构

  • com.trs.components.wcm.stat.domain.IChartBuilder


软件包 com.trs.components.wcm.stat.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.stat.domain
的使用

使用 com.trs.components.wcm.stat.domain 的软件包
com.trs.components.wcm.stat.domain

com.trs.components.wcm.stat.domain 使用的 com.trs.components.wcm.stat.domain 中的类
ChartOption
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChartStyle
IChartBuilder
TimingChartData

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


StatDataItem

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 StatDataItem

java.lang.Object
    继承者  com.trs.components.wcm.stat.domain.StatDataItem

public class StatDataItem
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

构造方法摘要
StatDataItem(CMyDateTime _sStatTime, java.util.Map _hData)
方法摘要
int | getData(java.lang.String _sKey)
java.util.Map | getDataMap()
static java.lang.String | getDataMapStr(java.util.Map _hData)
CMyDateTime | getStatTime()
java.lang.String | getStatTimeAsString()
java.lang.String | getStatTimeAsString(java.lang.String _sFormat)
void | setData(java.util.Map _hData)
void | setStatTime(CMyDateTime statTime)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatDataItem

public StatDataItem(CMyDateTime _sStatTime,
                    java.util.Map _hData)
方法详细信息

getStatTime

public CMyDateTime getStatTime()

getStatTimeAsString

public java.lang.String getStatTimeAsString()

getStatTimeAsString

public java.lang.String getStatTimeAsString(java.lang.String _sFormat)

setStatTime

public void setStatTime(CMyDateTime statTime)

getData

public int getData(java.lang.String _sKey)

getDataMap

public java.util.Map getDataMap()

setData

public void setData(java.util.Map _hData)

getDataMapStr

public static java.lang.String getDataMapStr(java.util.Map _hData)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimingChartBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 TimingChartBuilder

java.lang.Object
    继承者  com.trs.components.wcm.stat.domain.TimingChartBuilder
所有已实现的接口：
IChartBuilder
public class TimingChartBuilder
extends java.lang.Object
implements IChartBuilder

构造方法摘要
TimingChartBuilder()
方法摘要
org.jfree.chart.JFreeChart | buildChart(TimingChartData _oChartDataSet, ChartStyle _style, ChartOption _option)
org.jfree.data.xy.XYDataset | makeXYDataSet(java.lang.Object _dataset, ChartOption _option)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TimingChartBuilder

public TimingChartBuilder()
方法详细信息

buildChart

public org.jfree.chart.JFreeChart buildChart(TimingChartData _oChartDataSet,
                                             ChartStyle _style,
                                             ChartOption _option)
指定者：
接口 IChartBuilder 中的 buildChart

makeXYDataSet

public org.jfree.data.xy.XYDataset makeXYDataSet(java.lang.Object _dataset,
                                                 ChartOption _option)
                                          throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimingChartData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 TimingChartData

java.lang.Object
    继承者  com.trs.components.wcm.stat.domain.TimingChartData

public class TimingChartData
extends java.lang.Object

字段摘要
static boolean | IS_DEBUG
static java.lang.String | KEY_DATASET_HEADER
static java.lang.String | KEY_DATASET_VALUES
构造方法摘要
TimingChartData(int _nStatViewId, ChartOption _option)
方法摘要
java.lang.Object | fill()
java.lang.Object | fill(int _nPeriodType)
java.lang.Object | getDataSet()
static java.lang.String | getGroupNameById(java.lang.String _sGroupId)
static java.lang.String | getUserNameById(java.lang.String _sUserId)
static java.lang.String | makeDatasetJSON(int nStatviewId, ChartOption option)
static java.lang.String | makeDatasetJSON(TimingChartData data)
static java.lang.String | makeDatasetJSON(TimingChartData data, ChartOption option)
static java.lang.String | makeDatasetJSON(TimingChartData data, int _nPeriodType, java.lang.String _sGroupBy)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_DEBUG

public static boolean IS_DEBUG

KEY_DATASET_HEADER

public static final java.lang.String KEY_DATASET_HEADER
另请参见：
常量字段值

KEY_DATASET_VALUES

public static final java.lang.String KEY_DATASET_VALUES
另请参见：
常量字段值
构造方法详细信息

TimingChartData

public TimingChartData(int _nStatViewId,
                       ChartOption _option)
方法详细信息

getDataSet

public java.lang.Object getDataSet()

fill

public java.lang.Object fill()

fill

public java.lang.Object fill(int _nPeriodType)

makeDatasetJSON

public static java.lang.String makeDatasetJSON(int nStatviewId,
                                               ChartOption option)
                                        throws java.lang.Throwable
抛出：
java.lang.Throwable

makeDatasetJSON

public static java.lang.String makeDatasetJSON(TimingChartData data,
                                               ChartOption option)
                                        throws java.lang.Throwable
抛出：
java.lang.Throwable

makeDatasetJSON

public static java.lang.String makeDatasetJSON(TimingChartData data)
                                        throws java.lang.Throwable
抛出：
java.lang.Throwable

makeDatasetJSON

public static java.lang.String makeDatasetJSON(TimingChartData data,
                                               int _nPeriodType,
                                               java.lang.String _sGroupBy)
                                        throws java.lang.Throwable
抛出：
java.lang.Throwable

getUserNameById

public static java.lang.String getUserNameById(java.lang.String _sUserId)

getGroupNameById

public static java.lang.String getGroupNameById(java.lang.String _sGroupId)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimingChartProducer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.stat.domain
类 TimingChartProducer

java.lang.Object
    继承者  com.trs.components.wcm.stat.domain.TimingChartProducer
所有已实现的接口：
de.laures.cewolf.DatasetProducer, java.io.Serializable
public class TimingChartProducer
extends java.lang.Object
implements de.laures.cewolf.DatasetProducer

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)
另请参见：
序列化表格

字段摘要
从接口 de.laures.cewolf.DatasetProducer 继承的字段
PRODUCER_ATTRIBUTE_NAME
构造方法摘要
TimingChartProducer()
方法摘要
TimingChartData | getDataset()
ChartOption | getOption()
java.lang.String | getProducerId()
boolean | hasExpired(java.util.Map params, java.util.Date since)
java.lang.Object | produceDataset(java.util.Map params)
void | setDataset(TimingChartData _dataset)
void | setOption(ChartOption option)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TimingChartProducer

public TimingChartProducer()
方法详细信息

produceDataset

public java.lang.Object produceDataset(java.util.Map params)
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 produceDataset

getOption

public ChartOption getOption()

setOption

public void setOption(ChartOption option)

setDataset

public void setDataset(TimingChartData _dataset)

getProducerId

public java.lang.String getProducerId()
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 getProducerId

hasExpired

public boolean hasExpired(java.util.Map params,
                          java.util.Date since)
指定者：
接口 de.laures.cewolf.DatasetProducer 中的 hasExpired

getDataset

public TimingChartData getDataset()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.stat.domain.ChartBuildException 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.ChartBuildException
的使用

没有 com.trs.components.wcm.stat.domain.ChartBuildException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.domain.ChartConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.ChartConstants
的使用

没有 com.trs.components.wcm.stat.domain.ChartConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.domain.ChartOption 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.ChartOption
的使用

使用 ChartOption 的软件包
com.trs.components.wcm.stat.domain

com.trs.components.wcm.stat.domain 中 ChartOption 的使用

返回 ChartOption 的 com.trs.components.wcm.stat.domain 中的方法
 ChartOption TimingChartProducer.getOption()

参数类型为 ChartOption 的 com.trs.components.wcm.stat.domain 中的方法
org.jfree.chart.JFreeChart | TimingChartBuilder.buildChart(TimingChartData _oChartDataSet, ChartStyle _style, ChartOption _option)
org.jfree.chart.JFreeChart | IChartBuilder.buildChart(TimingChartData _oChartDataSet, ChartStyle _style, ChartOption _option)
static java.lang.String | TimingChartData.makeDatasetJSON(int nStatviewId, ChartOption option)
static java.lang.String | TimingChartData.makeDatasetJSON(TimingChartData data, ChartOption option)
org.jfree.data.xy.XYDataset | TimingChartBuilder.makeXYDataSet(java.lang.Object _dataset, ChartOption _option)
void | TimingChartProducer.setOption(ChartOption option)

参数类型为 ChartOption 的 com.trs.components.wcm.stat.domain 中的构造方法
TimingChartData(int _nStatViewId, ChartOption _option)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.domain.ChartStyle 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.ChartStyle
的使用

使用 ChartStyle 的软件包
com.trs.components.wcm.stat.domain

com.trs.components.wcm.stat.domain 中 ChartStyle 的使用

返回 ChartStyle 的 com.trs.components.wcm.stat.domain 中的方法
static ChartStyle | ChartStyle.getDefaultStyle()
static ChartStyle | ChartStyle.makeChartStyle(java.lang.String _sTitle, int _nWidth, int _nHeight, java.lang.String _sChartImgTyp, boolean _bShowLegend)

参数类型为 ChartStyle 的 com.trs.components.wcm.stat.domain 中的方法
org.jfree.chart.JFreeChart | TimingChartBuilder.buildChart(TimingChartData _oChartDataSet, ChartStyle _style, ChartOption _option)
org.jfree.chart.JFreeChart | IChartBuilder.buildChart(TimingChartData _oChartDataSet, ChartStyle _style, ChartOption _option)
static void | ChartWriter.generateChart(java.io.OutputStream _os, org.jfree.chart.JFreeChart oChart, ChartStyle _oStyle)
static void | ChartWriter.generateChart(java.lang.String _sFilepath, org.jfree.chart.JFreeChart oChart, ChartStyle _oStyle)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.domain.ChartWriter 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.ChartWriter
的使用

没有 com.trs.components.wcm.stat.domain.ChartWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.stat.domain.IChartBuilder 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.stat.domain.IChartBuilder
的使用

使用 IChartBuilder 的软件包
com.trs.components.wcm.stat.domain

com.trs.components.wcm.stat.domain 中 IChartBuilder 的使用

实现 IChartBuilder 的 com.trs.components.wcm.stat.domain 中的类
 class TimingChartBuilder

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.domain.StatDataItem 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.StatDataItem
的使用

没有 com.trs.components.wcm.stat.domain.StatDataItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.domain.TimingChartBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.TimingChartBuilder
的使用

没有 com.trs.components.wcm.stat.domain.TimingChartBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.domain.TimingChartData 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.TimingChartData
的使用

使用 TimingChartData 的软件包
com.trs.components.wcm.stat.domain

com.trs.components.wcm.stat.domain 中 TimingChartData 的使用

返回 TimingChartData 的 com.trs.components.wcm.stat.domain 中的方法
 TimingChartData TimingChartProducer.getDataset()

参数类型为 TimingChartData 的 com.trs.components.wcm.stat.domain 中的方法
org.jfree.chart.JFreeChart | TimingChartBuilder.buildChart(TimingChartData _oChartDataSet, ChartStyle _style, ChartOption _option)
org.jfree.chart.JFreeChart | IChartBuilder.buildChart(TimingChartData _oChartDataSet, ChartStyle _style, ChartOption _option)
static java.lang.String | TimingChartData.makeDatasetJSON(TimingChartData data)
static java.lang.String | TimingChartData.makeDatasetJSON(TimingChartData data, ChartOption option)
static java.lang.String | TimingChartData.makeDatasetJSON(TimingChartData data, int _nPeriodType, java.lang.String _sGroupBy)
void | TimingChartProducer.setDataset(TimingChartData _dataset)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.stat.domain.TimingChartProducer 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.stat.domain.TimingChartProducer
的使用

没有 com.trs.components.wcm.stat.domain.TimingChartProducer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CRightUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.util
类 CRightUtil

java.lang.Object
    继承者  com.trs.components.wcm.util.CRightUtil

public class CRightUtil
extends java.lang.Object

字段摘要
 java.lang.StringBuffer InitSetRightScript
构造方法摘要
CRightUtil()
CRightUtil(RightDefs _currRightDefs)
CRightUtil(RightDefs _currRightDefs, Rights _userRights, Rights _roleRights, Rights _groupRights)
方法摘要
java.lang.String | getSetRightTbl(RightDefs _currRightDefs, Rights _userRights, Rights _roleRights, Rights _groupRights, java.lang.String _sTblId)
java.lang.String | getSetRightTbl(RightDefs _currRightDefs, java.lang.String _sTblId)
java.lang.String | getSetRightTbl(java.lang.String _sTblId)
void | release()
void | setRightDefs(RightDefs _currRightDefs)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

InitSetRightScript

public java.lang.StringBuffer InitSetRightScript
构造方法详细信息

CRightUtil

public CRightUtil()

CRightUtil

public CRightUtil(RightDefs _currRightDefs)

CRightUtil

public CRightUtil(RightDefs _currRightDefs,
                  Rights _userRights,
                  Rights _roleRights,
                  Rights _groupRights)
方法详细信息

setRightDefs

public void setRightDefs(RightDefs _currRightDefs)

getSetRightTbl

public java.lang.String getSetRightTbl(RightDefs _currRightDefs,
                                       Rights _userRights,
                                       Rights _roleRights,
                                       Rights _groupRights,
                                       java.lang.String _sTblId)
                                throws WCMException
抛出：
WCMException

getSetRightTbl

public java.lang.String getSetRightTbl(RightDefs _currRightDefs,
                                       java.lang.String _sTblId)
                                throws WCMException
抛出：
WCMException

getSetRightTbl

public java.lang.String getSetRightTbl(java.lang.String _sTblId)
                                throws WCMException
抛出：
WCMException

release

public void release()
             throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ISystemWarner

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.util
接口 ISystemWarner

所有已知实现类：
SystemWarnerMsgImpl
public interface ISystemWarner

方法摘要
 void sendWarning(java.lang.String _sTitle, java.lang.String _sInfo, User _userTo, java.lang.Object _objOperated, java.lang.String _sObjName)
发送警告信息到指定用户

方法详细信息

sendWarning

void sendWarning(java.lang.String _sTitle,
                 java.lang.String _sInfo,
                 User _userTo,
                 java.lang.Object _objOperated,
                 java.lang.String _sObjName)
                 throws WCMException
发送警告信息到指定用户

参数：
_sTitle - 标题
_sInfo - 警告信息
_userTo - 目标用户
_objOperated - 操作的对象
_sObjName - 操作对象名称
抛出：
WCMException - 发送失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.util
接口
ISystemWarner
类
CRightUtil
SystemWarnerMsgImpl


com.trs.components.wcm.util

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.util

接口摘要
ISystemWarner

类摘要
CRightUtil
SystemWarnerMsgImpl


com.trs.components.wcm.util 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.util.CRightUtil
    • com.trs.components.wcm.util.SystemWarnerMsgImpl (implements com.trs.components.wcm.util.ISystemWarner)

接口分层结构

  • com.trs.components.wcm.util.ISystemWarner


软件包 com.trs.components.wcm.util 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.util
的使用

使用 com.trs.components.wcm.util 的软件包
com.trs.components.wcm.util

com.trs.components.wcm.util 使用的 com.trs.components.wcm.util 中的类
ISystemWarner

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SystemWarnerMsgImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.util
类 SystemWarnerMsgImpl

java.lang.Object
    继承者  com.trs.components.wcm.util.SystemWarnerMsgImpl
所有已实现的接口：
ISystemWarner
public class SystemWarnerMsgImpl
extends java.lang.Object
implements ISystemWarner

字段摘要
static java.lang.String CLASS_NAME
class full name
构造方法摘要
SystemWarnerMsgImpl()
构造函数
方法摘要
 void sendWarning(java.lang.String _sTitle, java.lang.String _sInfo, User _userTo, java.lang.Object _objOperated, java.lang.String _sObjName)
发送警告信息到指定用户
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CLASS_NAME

public static final java.lang.String CLASS_NAME
class full name

构造方法详细信息

SystemWarnerMsgImpl

public SystemWarnerMsgImpl()
构造函数

参数：
_app - 应用服务器
方法详细信息

sendWarning

public void sendWarning(java.lang.String _sTitle,
                        java.lang.String _sInfo,
                        User _userTo,
                        java.lang.Object _objOperated,
                        java.lang.String _sObjName)
                 throws WCMException
从接口 ISystemWarner 复制的描述
发送警告信息到指定用户

指定者：
接口 ISystemWarner 中的 sendWarning
参数：
_sTitle - 标题
_sInfo - 警告信息
_userTo - 目标用户
_objOperated - 操作的对象
_sObjName - 操作对象名称
抛出：
WCMException - 发送失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.util.CRightUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.util.CRightUtil
的使用

没有 com.trs.components.wcm.util.CRightUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.wcm.util.ISystemWarner 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.wcm.util.ISystemWarner
的使用

使用 ISystemWarner 的软件包
com.trs.components.wcm.util

com.trs.components.wcm.util 中 ISystemWarner 的使用

实现 ISystemWarner 的 com.trs.components.wcm.util 中的类
 class SystemWarnerMsgImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.util.SystemWarnerMsgImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.util.SystemWarnerMsgImpl
的使用

没有 com.trs.components.wcm.util.SystemWarnerMsgImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.wcm.wcmx.common
类
WCMTypesX


com.trs.components.wcm.wcmx.common

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.wcmx.common

类摘要
WCMTypesX


com.trs.components.wcm.wcmx.common 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.common 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.wcmx.common.WCMTypesX


软件包 com.trs.components.wcm.wcmx.common 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.common
的使用

没有 com.trs.components.wcm.wcmx.common 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMTypesX

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.common
类 WCMTypesX

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.common.WCMTypesX

public class WCMTypesX
extends java.lang.Object

字段摘要
static int | CHNL_TYPE_NEWS 频道类型：头条新闻
static int | CHNL_TYPE_PICS 频道类型：图片新闻
static int | CHNL_TYPE_TRSKEY
static int | CHNL_TYPE_X 频道类型：扩展类型频道
static int[] | CHNL_TYPES 系统中定义的所有的频道类型（不包括一般频道）
static int | OBJ_ADCOM 广告发放公司 *
static int | OBJ_ADFILE 广告文件管理 *
static int | OBJ_ADFILEPOS 广告文件和位置关系 *
static int | OBJ_ADPOS 广告位置管理 *
static int | OBJ_ADTYPE 广告类型 *
static int | OBJ_BOOKINFO
static int | OBJ_DEMO 演示 *
static int | OBJ_FORUMMSG 网上论坛帖子 *
static int | OBJ_FORUMTOPIC 网上论坛话题 *
static int | OBJ_HUMANSRC 对象类型：HumanSrc （用以演示）
static int | OBJ_INFOVIEW_DATA 自定义表单型文档
static int | OBJ_MYTEST 对象类型：MyTest
static int | OBJ_TRSDOC 对象类型：TRSDoc
static int | OBJ_TRSREGINFO TRS产品注册信息 *
static int | OBJ_USERSIGN 个人签名 *
static int | OBJ_WCMDICT 常用字典 *
static int | OPERTYPE_WCMTOTRS OperType类型：WCM 数据到TRS的同步（用以演示Schedule的处理）
static int | SPECIAL_CHNL_COUNT 记录非普通频道的数目
构造方法摘要
WCMTypesX()
方法摘要
static java.lang.String | getObjName(int _objType, boolean _bChineseName) 取指定类型的对象名称
static int | indexOfChnlTypes(int _chnlType) 定位频道类型的索引（编号）
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TRSDOC

public static final int OBJ_TRSDOC
对象类型：TRSDoc

另请参见：
常量字段值

OBJ_MYTEST

public static final int OBJ_MYTEST
对象类型：MyTest

另请参见：
常量字段值

OBJ_HUMANSRC

public static final int OBJ_HUMANSRC
对象类型：HumanSrc （用以演示）

另请参见：
常量字段值

OBJ_DEMO

public static final int OBJ_DEMO
演示 *

另请参见：
常量字段值

OBJ_WCMDICT

public static final int OBJ_WCMDICT
常用字典 *

另请参见：
常量字段值

OBJ_USERSIGN

public static final int OBJ_USERSIGN
个人签名 *

另请参见：
常量字段值

OBJ_TRSREGINFO

public static final int OBJ_TRSREGINFO
TRS产品注册信息 *

另请参见：
常量字段值

OBJ_FORUMTOPIC

public static final int OBJ_FORUMTOPIC
网上论坛话题 *

另请参见：
常量字段值

OBJ_FORUMMSG

public static final int OBJ_FORUMMSG
网上论坛帖子 *

另请参见：
常量字段值

OBJ_ADFILE

public static final int OBJ_ADFILE
广告文件管理 *

另请参见：
常量字段值

OBJ_ADCOM

public static final int OBJ_ADCOM
广告发放公司 *

另请参见：
常量字段值

OBJ_ADPOS

public static final int OBJ_ADPOS
广告位置管理 *

另请参见：
常量字段值

OBJ_ADFILEPOS

public static final int OBJ_ADFILEPOS
广告文件和位置关系 *

另请参见：
常量字段值

OBJ_ADTYPE

public static final int OBJ_ADTYPE
广告类型 *

另请参见：
常量字段值

OBJ_BOOKINFO

public static final int OBJ_BOOKINFO
另请参见：
常量字段值

OBJ_INFOVIEW_DATA

public static final int OBJ_INFOVIEW_DATA
自定义表单型文档

另请参见：
常量字段值

OPERTYPE_WCMTOTRS

public static final int OPERTYPE_WCMTOTRS
OperType类型：WCM 数据到TRS的同步（用以演示Schedule的处理）

另请参见：
常量字段值

CHNL_TYPE_PICS

public static final int CHNL_TYPE_PICS
频道类型：图片新闻

另请参见：
常量字段值

CHNL_TYPE_NEWS

public static final int CHNL_TYPE_NEWS
频道类型：头条新闻

另请参见：
常量字段值

CHNL_TYPE_X

public static final int CHNL_TYPE_X
频道类型：扩展类型频道

另请参见：
常量字段值

CHNL_TYPE_TRSKEY

public static final int CHNL_TYPE_TRSKEY
另请参见：
常量字段值

CHNL_TYPES

public static final int[] CHNL_TYPES
系统中定义的所有的频道类型（不包括一般频道）

SPECIAL_CHNL_COUNT

public static final int SPECIAL_CHNL_COUNT
记录非普通频道的数目

另请参见：
常量字段值
构造方法详细信息

WCMTypesX

public WCMTypesX()
方法详细信息

getObjName

public static java.lang.String getObjName(int _objType,
                                          boolean _bChineseName)
取指定类型的对象名称

参数：
_objType - 对象类型
_bChineseName - 是否返回对象的中文名称；若不是，则返回class名称
返回：

indexOfChnlTypes

public static final int indexOfChnlTypes(int _chnlType)
定位频道类型的索引（编号）

参数：
_chnlType - 频道类型
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.wcmx.common.WCMTypesX 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.common.WCMTypesX
的使用

没有 com.trs.components.wcm.wcmx.common.WCMTypesX 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.components.wcm.wcmx.help
类
WCMHelp
WCMHelps
WcmHelpUpdate


com.trs.components.wcm.wcmx.help

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.wcmx.help

类摘要
WCMHelp |
WCMHelps |
WcmHelpUpdate | Title: TRS 内容协作平台（TRS WCM） Description: Import wcmhelp data for WCM51-->WCM52 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.components.wcm.wcmx.help 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.help 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.wcmx.help.WCMHelp
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.wcmx.help.WCMHelps
    • com.trs.components.wcm.wcmx.help.WcmHelpUpdate (implements com.trs.infra.update.IUpdateCommander)


软件包 com.trs.components.wcm.wcmx.help 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.help
的使用

使用 com.trs.components.wcm.wcmx.help 的软件包
com.trs.components.wcm.wcmx.help

com.trs.components.wcm.wcmx.help 使用的 com.trs.components.wcm.wcmx.help 中的类
WCMHelp
WCMHelps

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMHelp

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.help
类 WCMHelp

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.wcmx.help.WCMHelp
所有已实现的接口：
java.lang.Cloneable
public class WCMHelp
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE TODO 需要定义 对象类型编号
构造方法摘要
WCMHelp()
方法摘要
static WCMHelp | createNewInstance() 产生当前对象[WCMHelp]的实例
static WCMHelp | findById(int _nId) 提取指定ID的对象
static WCMHelp | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getContent() 提取属性：Content
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getHtml() 提取属性：Html
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getJspUrl() 提取属性：JspUrl
java.lang.String | getKeywords() 提取属性：Keywords
java.lang.String | getTitle() 提取属性：Title
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setContent(java.lang.String _sContent) 设置属性：Content
boolean | setHtml(java.lang.String _sHtml) 设置属性：Html
boolean | setJspUrl(java.lang.String _sJspUrl) 设置属性：JspUrl
boolean | setKeywords(java.lang.String _sKeywords) 设置属性：Keywords
boolean | setTitle(java.lang.String _sTitle) 设置属性：Title
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
TODO 需要定义 对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

WCMHelp

public WCMHelp()
方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getJspUrl

public java.lang.String getJspUrl()
提取属性：JspUrl

返回：
JspUrl

setJspUrl

public boolean setJspUrl(java.lang.String _sJspUrl)
                  throws WCMException
设置属性：JspUrl

参数：
_sJspUrl - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getContent

public java.lang.String getContent()
提取属性：Content

返回：
Content

setContent

public boolean setContent(java.lang.String _sContent)
                   throws WCMException
设置属性：Content

参数：
_sContent - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getKeywords

public java.lang.String getKeywords()
提取属性：Keywords

返回：
Keywords

setKeywords

public boolean setKeywords(java.lang.String _sKeywords)
                    throws WCMException
设置属性：Keywords

参数：
_sKeywords - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTitle

public java.lang.String getTitle()
提取属性：Title

返回：
Title

setTitle

public boolean setTitle(java.lang.String _sTitle)
                 throws WCMException
设置属性：Title

参数：
_sTitle - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getHtml

public java.lang.String getHtml()
                         throws WCMException
提取属性：Html

返回：
Html
抛出：
WCMException

setHtml

public boolean setHtml(java.lang.String _sHtml)
                throws WCMException
设置属性：Html

参数：
_sHtml - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final WCMHelp findById(int _nId)
                              throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final WCMHelp createNewInstance()
                                       throws WCMException
产生当前对象[WCMHelp]的实例

返回：
当前对象的实例[WCMHelp]
抛出：
WCMException

findByKey

public static final WCMHelp findByKey(java.lang.Object _oKey)
                               throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


WCMHelps

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.help
类 WCMHelps

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.wcmx.help.WCMHelps

public class WCMHelps
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WCMHelps(User _currUser)
构造函数
WCMHelps(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static WCMHelps | createNewInstance(User _currUser) 产生当前集合对象[WCMHelps]的实例
static WCMHelps | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WCMHelp | findByUrl(User _currUser, java.lang.String _sUrl) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static WCMHelps | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMHelps]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMHelps

public WCMHelps(User _currUser)
构造函数

另请参见：
WCMHelps( User _currUser, int _initCapacity, int _incCapacity );

WCMHelps

public WCMHelps(User _currUser,
                int _initCapacity,
                int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final WCMHelps findByIds(User _currUser,
                                       java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（WCMHelps）
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByUrl

public static final WCMHelp findByUrl(User _currUser,
                                      java.lang.String _sUrl)
                               throws WCMException
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（WCMHelps）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final WCMHelps openWCMObjs(User _currUser,
                                         WCMFilter _filter)
                                  throws WCMException
通过指定一个Filter获取当前集合[WCMHelps]

参数：
_filter - 指定的Filter
返回：
当前集合[WCMHelps]
抛出：
WCMException

createNewInstance

public static WCMHelps createNewInstance(User _currUser)
产生当前集合对象[WCMHelps]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WcmHelpUpdate

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.help
类 WcmHelpUpdate

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.help.WcmHelpUpdate
所有已实现的接口：
IUpdateCommander
public class WcmHelpUpdate
extends java.lang.Object
implements IUpdateCommander

Title: TRS 内容协作平台（TRS WCM）
Description:
Import wcmhelp data for WCM51-->WCM52
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WcmHelpUpdate()
方法摘要
void | doUpdate()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WcmHelpUpdate

public WcmHelpUpdate()
方法详细信息

doUpdate

public void doUpdate()
指定者：
接口 IUpdateCommander 中的 doUpdate

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.wcmx.help.WCMHelp 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.help.WCMHelp
的使用

使用 WCMHelp 的软件包
com.trs.components.wcm.wcmx.help

com.trs.components.wcm.wcmx.help 中 WCMHelp 的使用

返回 WCMHelp 的 com.trs.components.wcm.wcmx.help 中的方法
static WCMHelp | WCMHelp.createNewInstance() 产生当前对象[WCMHelp]的实例
static WCMHelp | WCMHelp.findById(int _nId) 提取指定ID的对象
static WCMHelp | WCMHelp.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static WCMHelp | WCMHelps.findByUrl(User _currUser, java.lang.String _sUrl) 提取指定ID序列的对象集合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.help.WCMHelps 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.help.WCMHelps
的使用

使用 WCMHelps 的软件包
com.trs.components.wcm.wcmx.help

com.trs.components.wcm.wcmx.help 中 WCMHelps 的使用

返回 WCMHelps 的 com.trs.components.wcm.wcmx.help 中的方法
static WCMHelps | WCMHelps.createNewInstance(User _currUser) 产生当前集合对象[WCMHelps]的实例
static WCMHelps | WCMHelps.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static WCMHelps | WCMHelps.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMHelps]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.help.WcmHelpUpdate 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.help.WcmHelpUpdate
的使用

没有 com.trs.components.wcm.wcmx.help.WcmHelpUpdate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DataUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.jsp
类 DataUtil

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.jsp.DataUtil

public class DataUtil
extends java.lang.Object

构造方法摘要
DataUtil()
方法摘要
static java.lang.String getObjectAsString(java.lang.Object _obj, int _dataType)
将指定类型的数据转换为字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataUtil

public DataUtil()
方法详细信息

getObjectAsString

public static java.lang.String getObjectAsString(java.lang.Object _obj,
                                                 int _dataType)
将指定类型的数据转换为字符串

参数：
_obj - 数据对象
_dataType - 数据类型
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocOperDefine

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.jsp
类 DocOperDefine

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.jsp.DocOperDefine

public class DocOperDefine
extends java.lang.Object

构造方法摘要
DocOperDefine()
方法摘要
static java.lang.String | getDelFunc(Document _currDoc, Channel _currChnl) 获取删除文件的Javascript
static java.lang.String | getEditFunc(Document _currDoc, Channel _currChnl) 获取编辑文档的Javascript
static java.lang.String | getReplyFunc(Document _currDoc) 获取回复文档的Javascript
static java.lang.String | getSaveBakFunc(Document _currDoc, Channel _currChnl) 获取保存版本的Javascript
static java.lang.String | getShowBakFunc(Document _currDoc, Channel _currChnl) 获取管理版本的Javascript
static java.lang.String | getSubmitAgainFunc(Document _currDoc) 获取再次呈送文档的Javascript
static java.lang.String | getSubmitFunc(Document _currDoc) 获取呈送文档的Javascript
static java.lang.String | getTransmitFunc(Document _currDoc, Channel _currChnl) 获取转发文档的Javascript
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocOperDefine

public DocOperDefine()
方法详细信息

getEditFunc

public static java.lang.String getEditFunc(Document _currDoc,
                                           Channel _currChnl)
获取编辑文档的Javascript

参数：
_currDoc - 当前文档
_currChnl - 发出此操作所处的频道，如果不在频道内，传入null
返回：

getDelFunc

public static java.lang.String getDelFunc(Document _currDoc,
                                          Channel _currChnl)
获取删除文件的Javascript

参数：
_currDoc - 当前文档
_currChnl - 发出此操作所处的频道，如果不在频道内，传入null
返回：

getTransmitFunc

public static java.lang.String getTransmitFunc(Document _currDoc,
                                               Channel _currChnl)
获取转发文档的Javascript

参数：
_currDoc - 当前文档
_currChnl - 发出此操作所处的频道，如果不在频道内，传入null
返回：

getShowBakFunc

public static java.lang.String getShowBakFunc(Document _currDoc,
                                              Channel _currChnl)
获取管理版本的Javascript

参数：
_currDoc - 当前文档
_currChnl - 发出此操作所处的频道，如果不在频道内，传入null
返回：

getSaveBakFunc

public static java.lang.String getSaveBakFunc(Document _currDoc,
                                              Channel _currChnl)
获取保存版本的Javascript

参数：
_currDoc - 当前文档
_currChnl - 发出此操作所处的频道，如果不在频道内，传入null
返回：

getReplyFunc

public static java.lang.String getReplyFunc(Document _currDoc)
获取回复文档的Javascript

参数：
_currDoc - 当前文档
返回：

getSubmitFunc

public static java.lang.String getSubmitFunc(Document _currDoc)
获取呈送文档的Javascript

参数：
_currDoc - 当前文档
返回：

getSubmitAgainFunc

public static java.lang.String getSubmitAgainFunc(Document _currDoc)
获取再次呈送文档的Javascript

参数：
_currDoc - 当前文档
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.wcmx.jsp
类
DataUtil
DocOperDefine
PageUtil
UserUtil


com.trs.components.wcm.wcmx.jsp

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.wcmx.jsp

类摘要
DataUtil
DocOperDefine
PageUtil
UserUtil


com.trs.components.wcm.wcmx.jsp 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.jsp 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.wcmx.jsp.DataUtil
    • com.trs.components.wcm.wcmx.jsp.DocOperDefine
    • com.trs.components.wcm.wcmx.jsp.PageUtil
    • com.trs.components.wcm.wcmx.jsp.UserUtil


软件包 com.trs.components.wcm.wcmx.jsp 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.jsp
的使用

没有 com.trs.components.wcm.wcmx.jsp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.jsp
类 PageUtil

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.jsp.PageUtil

public class PageUtil
extends java.lang.Object

构造方法摘要
PageUtil()
方法摘要
static java.lang.String | getPageNextHtml(CPager _pager, java.lang.String _emptyDesc)
static java.lang.String | getPageNextHtml(CPager _pager, java.lang.String _emptyDesc, java.lang.String _pageClass, java.lang.String _firstImage, java.lang.String _nextImage, java.lang.String _prevImage, java.lang.String _endImage) 获取翻页的HTML代码
static java.lang.String | getPageNumHtml(CPager _pager)
static java.lang.String | getPageNumHtml(CPager _pager, java.lang.String _bgColor, java.lang.String _fontColor)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageUtil

public PageUtil()
方法详细信息

getPageNumHtml

public static java.lang.String getPageNumHtml(CPager _pager)
参数：
_pager -
返回：

getPageNumHtml

public static java.lang.String getPageNumHtml(CPager _pager,
                                              java.lang.String _bgColor,
                                              java.lang.String _fontColor)
参数：
_pager -
_bgColor -
_fontColor -
返回：

getPageNextHtml

public static java.lang.String getPageNextHtml(CPager _pager,
                                               java.lang.String _emptyDesc)

getPageNextHtml

public static java.lang.String getPageNextHtml(CPager _pager,
                                               java.lang.String _emptyDesc,
                                               java.lang.String _pageClass,
                                               java.lang.String _firstImage,
                                               java.lang.String _nextImage,
                                               java.lang.String _prevImage,
                                               java.lang.String _endImage)
获取翻页的HTML代码

参数：
_pager - 分页对象（由上层页面传入）
_emptyDesc - 如果没有数据页面显示的信息
_pageClass - 分页文字所用的class(例如 首页 )
可省略，默认为black
_firstImage - 表示“首页”的图片
可省略，默认为wcm/images/allow-first.gif
_nextImage - 表示“下一页”的图片
可省略，默认为wcm/images/allow-next.gif
_prevImage - 表示“上一页”的图片
可省略，默认为wcm/images/allow-prev.gif
_endImage - 表示“尾页”的图片
可省略，默认为wcm/images/allow-end.gif
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.jsp
类 UserUtil

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.jsp.UserUtil

public class UserUtil
extends java.lang.Object

构造方法摘要
UserUtil(User _currUser)
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserUtil

public UserUtil(User _currUser)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.components.wcm.wcmx.jsp.DataUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.jsp.DataUtil
的使用

没有 com.trs.components.wcm.wcmx.jsp.DataUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.jsp.DocOperDefine
的使用

没有 com.trs.components.wcm.wcmx.jsp.DocOperDefine 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.jsp.PageUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.jsp.PageUtil
的使用

没有 com.trs.components.wcm.wcmx.jsp.PageUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.jsp.UserUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.jsp.UserUtil
的使用

没有 com.trs.components.wcm.wcmx.jsp.UserUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


MediaRemindedAgent

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.media
类 MediaRemindedAgent

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.media.MediaRemindedAgent

public class MediaRemindedAgent
extends java.lang.Object

Created by IntelliJ IDEA. User: Administrator Date: 2004-3-17 Time: 14:10:11 To change this template use Options | File Templates.

构造方法摘要
MediaRemindedAgent()
方法摘要
void | addMediaReminded(int _nSourceId) 给指定的媒体增加更新
int | getCurrMediaCount(int _nSourceId, int _nUserId) 获取指定媒体指定用户累计的条数
int | getFreqReminded(int _nUserId) 获取用户设置的提醒频率
static MediaRemindedAgent | getInstance() 获取媒体提醒工具类的实例（一种Singlton的模式）
Sources | getSourcesRemided(User _currUser) 获取用户需要提醒的媒体集合
Users | getUsersByMediaReminded(int _nSourceId) 根据媒体ID获取设置了提醒的用户集合
void | init() 初始化缓冲信息
static void | main(java.lang.String[] arArgs)
void | putMediaRemindedInfoInCache(MediaRemindedInfo _currInfo) 将媒体提醒信息加入缓冲中
void | removeMediaRemindedInfoFromCache(int _nUserId, int _nSourceId) 将媒体提醒信息从缓冲中删除
void | sendRemindMessage(int _nSourceId, int _nUserId) 给指定的用户发送指定媒体的消息
void | setCurrMediaCount(int _nSourceId, int _nUserId, int _nCount) 给指定媒体指定用户累计的条数
void | setFreqReminded(int _nUserId, int _nFreq) 设置用户设置的提醒频率
void | updateMediaRemindedCache(MediaRemindedInfo _aInfo) 更新媒体提醒信息的缓冲
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MediaRemindedAgent

public MediaRemindedAgent()
方法详细信息

getInstance

public static MediaRemindedAgent getInstance()
获取媒体提醒工具类的实例（一种Singlton的模式）

参数：
_app - WCM的Application对象
返回：

getSourcesRemided

public Sources getSourcesRemided(User _currUser)
                          throws java.lang.Exception
获取用户需要提醒的媒体集合

参数：
_currUser -
返回：
@throws Exception
抛出：
java.lang.Exception

getFreqReminded

public int getFreqReminded(int _nUserId)
                    throws java.lang.Exception
获取用户设置的提醒频率

参数：
_nUserId - 指定的用户ID
返回：
@throws Exception
抛出：
java.lang.Exception

setFreqReminded

public void setFreqReminded(int _nUserId,
                            int _nFreq)
设置用户设置的提醒频率

参数：
_nUserId - 指定的用户ID
_nFreq - 指定的用户ID

init

public void init()
          throws java.lang.Exception
初始化缓冲信息

抛出：
java.lang.Exception

putMediaRemindedInfoInCache

public void putMediaRemindedInfoInCache(MediaRemindedInfo _currInfo)
将媒体提醒信息加入缓冲中

参数：
_currInfo - 媒体提醒对象

getUsersByMediaReminded

public Users getUsersByMediaReminded(int _nSourceId)
                              throws java.lang.Exception
根据媒体ID获取设置了提醒的用户集合

参数：
_nSourceId - 来源ID
返回：
@throws Exception
抛出：
java.lang.Exception

getCurrMediaCount

public int getCurrMediaCount(int _nSourceId,
                             int _nUserId)
                      throws java.lang.Exception
获取指定媒体指定用户累计的条数

参数：
_nSourceId - 媒体ID
_nUserId - 用户ID
返回：
@throws Exception
抛出：
java.lang.Exception

setCurrMediaCount

public void setCurrMediaCount(int _nSourceId,
                              int _nUserId,
                              int _nCount)
给指定媒体指定用户累计的条数

参数：
_nSourceId - 媒体ID
_nUserId - 用户ID

removeMediaRemindedInfoFromCache

public void removeMediaRemindedInfoFromCache(int _nUserId,
                                             int _nSourceId)
将媒体提醒信息从缓冲中删除

参数：
_nUserId - 用户ID
_nSourceId - 来源ID

updateMediaRemindedCache

public void updateMediaRemindedCache(MediaRemindedInfo _aInfo)
更新媒体提醒信息的缓冲

参数：
_aInfo - 媒体提醒记录对象

addMediaReminded

public void addMediaReminded(int _nSourceId)
                      throws java.lang.Exception
给指定的媒体增加更新

参数：
_nSourceId -
抛出：
java.lang.Exception

sendRemindMessage

public void sendRemindMessage(int _nSourceId,
                              int _nUserId)
                       throws java.lang.Exception
给指定的用户发送指定媒体的消息

参数：
_nSourceId - 媒体ID
_nUserId - 用户ID
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] arArgs)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MediaRemindedInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.media
类 MediaRemindedInfo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.wcmx.media.MediaRemindedInfo
所有已实现的接口：
java.lang.Cloneable
public class MediaRemindedInfo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
MediaRemindedInfo()
构造函数：保留默认接口
方法摘要
static MediaRemindedInfo | addRemindedSource(User _currUser, int _nUserId, int _nSourceId, int _nRemindedReq) 指定的用户设置指定媒体提醒的频率
static MediaRemindedInfo | createNewInstance() 产生当前对象[MediaRemindedInfo]的实例
int | delete(User _currUser) 从数据中删除对象信息
static MediaRemindedInfo | findById(int _nId) 提取指定ID的对象
static MediaRemindedInfo | findById(User _currUser, int _nId, java.lang.String _sSelect) 提取指定ID的对象
static MediaRemindedInfo | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static MediaRemindedInfo | findByUserAndSrc(User _currUser, int _nUserId, int _nSourceId) 提取指定ID的对象
int | getCurrMediaCount() 提取属性：CurrMediaCount
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
int | getFreqReminded() 提取属性：FreqReminded
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getSourceId() 提取属性：SourceId
int | getUserID() 提取属性：UserID
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setCurrMediaCount(int _nCurrMediaCount) 设置属性：CurrMediaCount
boolean | setFreqReminded(int _nFreqReminded) 设置属性：FreqReminded
boolean | setSourceId(int _nSourceId) 设置属性：SourceId
boolean | setUserID(int _nUserID) 设置属性：UserID
void | update(User _user) 重载父对象的update，执行缓冲区的更新操作
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

MediaRemindedInfo

public MediaRemindedInfo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getUserID

public int getUserID()
提取属性：UserID

返回：
UserID

setUserID

public boolean setUserID(int _nUserID)
                  throws WCMException
设置属性：UserID

参数：
_nUserID - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSourceId

public int getSourceId()
提取属性：SourceId

返回：
SourceId

setSourceId

public boolean setSourceId(int _nSourceId)
                    throws WCMException
设置属性：SourceId

参数：
_nSourceId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFreqReminded

public int getFreqReminded()
提取属性：FreqReminded

返回：
FreqReminded

setFreqReminded

public boolean setFreqReminded(int _nFreqReminded)
                        throws WCMException
设置属性：FreqReminded

参数：
_nFreqReminded - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getCurrMediaCount

public int getCurrMediaCount()
提取属性：CurrMediaCount

返回：
CurrMediaCount

setCurrMediaCount

public boolean setCurrMediaCount(int _nCurrMediaCount)
                          throws WCMException
设置属性：CurrMediaCount

参数：
_nCurrMediaCount - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

delete

public int delete(User _currUser)
           throws WCMException
从类 CMSObj 复制的描述
从数据中删除对象信息

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

update

public void update(User _user)
            throws WCMException
重载父对象的update，执行缓冲区的更新操作

覆盖：
类 CMSObj 中的 update
参数：
_user - 操作用户
抛出：
WCMException

findById

public static final MediaRemindedInfo findById(User _currUser,
                                               int _nId,
                                               java.lang.String _sSelect)
                                        throws WCMException
提取指定ID的对象

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_nId - 指定的对象ID
_sSelect - 对象提取的属性字段列表；可省略，缺省值为全部字段。
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByUserAndSrc

public static final MediaRemindedInfo findByUserAndSrc(User _currUser,
                                                       int _nUserId,
                                                       int _nSourceId)
                                                throws WCMException
提取指定ID的对象

参数：
_currUser - 当前操作用户
_app - 应用服务器对象
_nUserId - 指定的用户Id
_nSourceId - 指定媒体ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findById

public static final MediaRemindedInfo findById(int _nId)
                                        throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final MediaRemindedInfo createNewInstance()
                                                 throws WCMException
产生当前对象[MediaRemindedInfo]的实例

返回：
当前对象的实例[MediaRemindedInfo]
抛出：
WCMException

findByKey

public static final MediaRemindedInfo findByKey(java.lang.Object _oKey)
                                         throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

addRemindedSource

public static final MediaRemindedInfo addRemindedSource(User _currUser,
                                                        int _nUserId,
                                                        int _nSourceId,
                                                        int _nRemindedReq)
                                                 throws java.lang.Exception
指定的用户设置指定媒体提醒的频率

参数：
_currUser - 当前操作的用户
_app - WCM的Application
_nUserId - 用户ID
_nSourceId - 来源ID
_nRemindedReq - 提醒的频率
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaRemindedInfos

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.media
类 MediaRemindedInfos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.components.wcm.wcmx.media.MediaRemindedInfos

public class MediaRemindedInfos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MediaRemindedInfos(User _currUser)
构造函数
MediaRemindedInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MediaRemindedInfos

public MediaRemindedInfos(User _currUser)
构造函数

另请参见：
MediaRemindedInfos( User _currUser, int _initCapacity, int _incCapacity );

MediaRemindedInfos

public MediaRemindedInfos(User _currUser,
                          int _initCapacity,
                          int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.wcmx.media
类
MediaRemindedAgent
MediaRemindedInfo
MediaRemindedInfos


com.trs.components.wcm.wcmx.media

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.wcmx.media

类摘要
MediaRemindedAgent | Created by IntelliJ IDEA.
MediaRemindedInfo |
MediaRemindedInfos |


com.trs.components.wcm.wcmx.media 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.media 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.wcmx.media.MediaRemindedInfo
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.components.wcm.wcmx.media.MediaRemindedInfos
    • com.trs.components.wcm.wcmx.media.MediaRemindedAgent


软件包 com.trs.components.wcm.wcmx.media 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.media
的使用

使用 com.trs.components.wcm.wcmx.media 的软件包
com.trs.components.wcm.wcmx.media

com.trs.components.wcm.wcmx.media 使用的 com.trs.components.wcm.wcmx.media 中的类
MediaRemindedAgent
Created by IntelliJ IDEA.
MediaRemindedInfo

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent
的使用

使用 MediaRemindedAgent 的软件包
com.trs.components.wcm.wcmx.media

com.trs.components.wcm.wcmx.media 中 MediaRemindedAgent 的使用

返回 MediaRemindedAgent 的 com.trs.components.wcm.wcmx.media 中的方法
static MediaRemindedAgent MediaRemindedAgent.getInstance()
获取媒体提醒工具类的实例（一种Singlton的模式）

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo
的使用

使用 MediaRemindedInfo 的软件包
com.trs.components.wcm.wcmx.media

com.trs.components.wcm.wcmx.media 中 MediaRemindedInfo 的使用

返回 MediaRemindedInfo 的 com.trs.components.wcm.wcmx.media 中的方法
static MediaRemindedInfo | MediaRemindedInfo.addRemindedSource(User _currUser, int _nUserId, int _nSourceId, int _nRemindedReq) 指定的用户设置指定媒体提醒的频率
static MediaRemindedInfo | MediaRemindedInfo.createNewInstance() 产生当前对象[MediaRemindedInfo]的实例
static MediaRemindedInfo | MediaRemindedInfo.findById(int _nId) 提取指定ID的对象
static MediaRemindedInfo | MediaRemindedInfo.findById(User _currUser, int _nId, java.lang.String _sSelect) 提取指定ID的对象
static MediaRemindedInfo | MediaRemindedInfo.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static MediaRemindedInfo | MediaRemindedInfo.findByUserAndSrc(User _currUser, int _nUserId, int _nSourceId) 提取指定ID的对象

参数类型为 MediaRemindedInfo 的 com.trs.components.wcm.wcmx.media 中的方法
void | MediaRemindedAgent.putMediaRemindedInfoInCache(MediaRemindedInfo _currInfo) 将媒体提醒信息加入缓冲中
void | MediaRemindedAgent.updateMediaRemindedCache(MediaRemindedInfo _aInfo) 更新媒体提醒信息的缓冲

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.media.MediaRemindedInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.media.MediaRemindedInfos
的使用

没有 com.trs.components.wcm.wcmx.media.MediaRemindedInfos 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CWasTree

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.util
类 CWasTree

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.util.CWasTree

public class CWasTree
extends java.lang.Object

Title:

Description:

Copyright: Copyright (c) 2003

Company:

版本：
1.0
作者：
not attributable

字段摘要
static java.io.FileWriter fw
构造方法摘要
CWasTree()
方法摘要
void | CreatChnlTree(Channels aChnls)
void | CreatHeadPart()
void | CreatNavTree(Channels aChnls, int aNo)
void | CreatStylePart()
void | execute()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

fw

public static java.io.FileWriter fw
构造方法详细信息

CWasTree

public CWasTree()
方法详细信息

CreatHeadPart

public void CreatHeadPart()

CreatStylePart

public void CreatStylePart()

CreatNavTree

public void CreatNavTree(Channels aChnls,
                         int aNo)

CreatChnlTree

public void CreatChnlTree(Channels aChnls)

execute

public void execute()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.wcmx.util
类
CWasTree


com.trs.components.wcm.wcmx.util

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.wcmx.util

类摘要
CWasTree Title: Description: Copyright: Copyright (c) 2003 Company:


com.trs.components.wcm.wcmx.util 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.wcmx.util.CWasTree


软件包 com.trs.components.wcm.wcmx.util 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.util
的使用

没有 com.trs.components.wcm.wcmx.util 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.util.CWasTree 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.util.CWasTree
的使用

没有 com.trs.components.wcm.wcmx.util.CWasTree 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChannelRelated

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.wcm.wcmx.websites
类 ChannelRelated

java.lang.Object
    继承者  com.trs.components.wcm.wcmx.websites.ChannelRelated

public class ChannelRelated
extends java.lang.Object

构造方法摘要
ChannelRelated()
方法摘要
static java.lang.String | getChnlDefaultName(int _type) 获取指定的频道类型的默认名称
static java.lang.String | getChnlOrderHtml(Channel _currChnl, User _currUser) 获取设置频道顺序的HTML代码
static java.lang.String | getChnlType(int _type) 获取频道类型的描述
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelRelated

public ChannelRelated()
方法详细信息

getChnlType

public static java.lang.String getChnlType(int _type)
获取频道类型的描述

参数：
_type - 频道类型
返回：

getChnlDefaultName

public static java.lang.String getChnlDefaultName(int _type)
获取指定的频道类型的默认名称

参数：
_type - 指定的频道类型
返回：

getChnlOrderHtml

public static java.lang.String getChnlOrderHtml(Channel _currChnl,
                                                User _currUser)
                                         throws WCMException
获取设置频道顺序的HTML代码

参数：
_currChnl - 当前频道
_currUser - 当前操作用户
_app - WCM应用服务器
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.wcm.wcmx.websites
类
ChannelRelated


com.trs.components.wcm.wcmx.websites

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.wcm.wcmx.websites

类摘要
ChannelRelated


com.trs.components.wcm.wcmx.websites 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.websites 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.wcm.wcmx.websites.ChannelRelated


软件包 com.trs.components.wcm.wcmx.websites 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.wcm.wcmx.websites
的使用

没有 com.trs.components.wcm.wcmx.websites 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.wcm.wcmx.websites.ChannelRelated 的使用

上一个 下一个 框架 无框架

类 com.trs.components.wcm.wcmx.websites.ChannelRelated
的使用

没有 com.trs.components.wcm.wcmx.websites.ChannelRelated 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseFieldHTMLParser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.web
类 BaseFieldHTMLParser

java.lang.Object
    继承者  com.trs.components.web.BaseFieldHTMLParser
所有已实现的接口：
IFieldHTMLParser
直接已知子类：
DocumentFieldHTMLParser
public abstract class BaseFieldHTMLParser
extends java.lang.Object
implements IFieldHTMLParser

构造方法摘要
BaseFieldHTMLParser()
方法摘要
java.lang.String | getTemplate(java.lang.String sFieldName) 根据字段名称，返回该字段对应的HTML模板资源
java.lang.String | getTemplateEncoding(java.lang.String sFileName) 返回文件对应的编码信息
java.lang.String | getTemplateKey(java.lang.String sFileName) 返回文件对应的key信息
abstract java.lang.String | getTemplatePath() 返回模板存放的根路径
java.lang.String | parse(java.lang.String sFieldName, IPropertiesBuilder builder) 根据字段的内容，解析成相应的HTML代码
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseFieldHTMLParser

public BaseFieldHTMLParser()
方法详细信息

getTemplatePath

public abstract java.lang.String getTemplatePath()
                                          throws WCMException
返回模板存放的根路径

返回：
抛出：
WCMException

getTemplateEncoding

public java.lang.String getTemplateEncoding(java.lang.String sFileName)
返回文件对应的编码信息

参数：
sFileName -
返回：

getTemplateKey

public java.lang.String getTemplateKey(java.lang.String sFileName)
返回文件对应的key信息

参数：
sFileName -
返回：

getTemplate

public java.lang.String getTemplate(java.lang.String sFieldName)
                             throws CMyException
根据字段名称，返回该字段对应的HTML模板资源

参数：
sFieldName -
返回：
抛出：
CMyException

parse

public java.lang.String parse(java.lang.String sFieldName,
                              IPropertiesBuilder builder)
                       throws CMyException
从接口 IFieldHTMLParser 复制的描述
根据字段的内容，解析成相应的HTML代码

指定者：
接口 IFieldHTMLParser 中的 parse
返回：
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BasePropertiesBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.web
类 BasePropertiesBuilder

java.lang.Object
    继承者  com.trs.components.web.BasePropertiesBuilder
所有已实现的接口：
IPropertiesBuilder
直接已知子类：
DefaultPropertiesBuilder, DocumentPropertiesBuilder
public abstract class BasePropertiesBuilder
extends java.lang.Object
implements IPropertiesBuilder

构造方法摘要
BasePropertiesBuilder(BaseObj _obj)
方法摘要
void | append(java.util.Map _properties) 追加一些属性对
java.util.Map | build() 根据內部obj对象，返回想要的Properties
BaseObj | getObj()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasePropertiesBuilder

public BasePropertiesBuilder(BaseObj _obj)
方法详细信息

getObj

public BaseObj getObj()

build

public java.util.Map build()
                    throws WCMException
从接口 IPropertiesBuilder 复制的描述
根据內部obj对象，返回想要的Properties

指定者：
接口 IPropertiesBuilder 中的 build
返回：
抛出：
WCMException

append

public void append(java.util.Map _properties)
从接口 IPropertiesBuilder 复制的描述
追加一些属性对

指定者：
接口 IPropertiesBuilder 中的 append
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultPropertiesBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.web
类 DefaultPropertiesBuilder

java.lang.Object
    继承者  com.trs.components.web.BasePropertiesBuilder
        继承者  com.trs.components.web.DefaultPropertiesBuilder
所有已实现的接口：
IPropertiesBuilder
public class DefaultPropertiesBuilder
extends BasePropertiesBuilder

构造方法摘要
DefaultPropertiesBuilder(BaseObj _obj)
方法摘要
从类 com.trs.components.web.BasePropertiesBuilder 继承的方法
append, build, getObj
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultPropertiesBuilder

public DefaultPropertiesBuilder(BaseObj _obj)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFieldHTMLParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.components.web
接口 IFieldHTMLParser

所有已知实现类：
BaseFieldHTMLParser, DocumentFieldHTMLParser
public interface IFieldHTMLParser

方法摘要
 java.lang.String parse(java.lang.String sFieldName, IPropertiesBuilder builder)
根据字段的内容，解析成相应的HTML代码

方法详细信息

parse

java.lang.String parse(java.lang.String sFieldName,
                       IPropertiesBuilder builder)
                       throws CMyException
根据字段的内容，解析成相应的HTML代码

参数：
sFieldName -
builder -
返回：
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPropertiesBuilder

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.web
接口 IPropertiesBuilder

所有已知实现类：
BasePropertiesBuilder, DefaultPropertiesBuilder, DocumentPropertiesBuilder
public interface IPropertiesBuilder

方法摘要
void | append(java.util.Map properties) 追加一些属性对
java.util.Map | build() 根据內部obj对象，返回想要的Properties

方法详细信息

build

java.util.Map build()
                    throws WCMException
根据內部obj对象，返回想要的Properties

返回：
抛出：
WCMException

append

void append(java.util.Map properties)
追加一些属性对

参数：
properties -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.web
接口
IFieldHTMLParser
IPropertiesBuilder
类
BaseFieldHTMLParser
BasePropertiesBuilder
DefaultPropertiesBuilder


com.trs.components.web

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.web

接口摘要
IFieldHTMLParser
IPropertiesBuilder

类摘要
BaseFieldHTMLParser
BasePropertiesBuilder
DefaultPropertiesBuilder


com.trs.components.web 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.web 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.web.BaseFieldHTMLParser (implements com.trs.components.web.IFieldHTMLParser)
    • com.trs.components.web.BasePropertiesBuilder (implements com.trs.components.web.IPropertiesBuilder)
      • com.trs.components.web.DefaultPropertiesBuilder

接口分层结构

  • com.trs.components.web.IFieldHTMLParser
  • com.trs.components.web.IPropertiesBuilder


软件包 com.trs.components.web 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.web
的使用

使用 com.trs.components.web 的软件包
com.trs.components.web
com.trs.components.web.document

com.trs.components.web 使用的 com.trs.components.web 中的类
BasePropertiesBuilder
IFieldHTMLParser
IPropertiesBuilder

com.trs.components.web.document 使用的 com.trs.components.web 中的类
BaseFieldHTMLParser
BasePropertiesBuilder
IFieldHTMLParser
IPropertiesBuilder

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.web.BaseFieldHTMLParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.web.BaseFieldHTMLParser
的使用

使用 BaseFieldHTMLParser 的软件包
com.trs.components.web.document

com.trs.components.web.document 中 BaseFieldHTMLParser 的使用

com.trs.components.web.document 中 BaseFieldHTMLParser 的子类
 class DocumentFieldHTMLParser

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.web.BasePropertiesBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.web.BasePropertiesBuilder
的使用

使用 BasePropertiesBuilder 的软件包
com.trs.components.web
com.trs.components.web.document

com.trs.components.web 中 BasePropertiesBuilder 的使用

com.trs.components.web 中 BasePropertiesBuilder 的子类
 class DefaultPropertiesBuilder

com.trs.components.web.document 中 BasePropertiesBuilder 的使用

com.trs.components.web.document 中 BasePropertiesBuilder 的子类
 class DocumentPropertiesBuilder

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.web.DefaultPropertiesBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.web.DefaultPropertiesBuilder
的使用

没有 com.trs.components.web.DefaultPropertiesBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.web.IFieldHTMLParser 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.web.IFieldHTMLParser
的使用

使用 IFieldHTMLParser 的软件包
com.trs.components.web
com.trs.components.web.document

com.trs.components.web 中 IFieldHTMLParser 的使用

实现 IFieldHTMLParser 的 com.trs.components.web 中的类
 class BaseFieldHTMLParser

com.trs.components.web.document 中 IFieldHTMLParser 的使用

实现 IFieldHTMLParser 的 com.trs.components.web.document 中的类
 class DocumentFieldHTMLParser

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.components.web.IPropertiesBuilder 的使用

上一个 下一个 框架 无框架

接口 com.trs.components.web.IPropertiesBuilder
的使用

使用 IPropertiesBuilder 的软件包
com.trs.components.web
com.trs.components.web.document

com.trs.components.web 中 IPropertiesBuilder 的使用

实现 IPropertiesBuilder 的 com.trs.components.web 中的类
class | BasePropertiesBuilder
class | DefaultPropertiesBuilder

参数类型为 IPropertiesBuilder 的 com.trs.components.web 中的方法
java.lang.String | BaseFieldHTMLParser.parse(java.lang.String sFieldName, IPropertiesBuilder builder)
java.lang.String | IFieldHTMLParser.parse(java.lang.String sFieldName, IPropertiesBuilder builder) 根据字段的内容，解析成相应的HTML代码

com.trs.components.web.document 中 IPropertiesBuilder 的使用

实现 IPropertiesBuilder 的 com.trs.components.web.document 中的类
 class DocumentPropertiesBuilder

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DocumentFieldHTMLParser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.web.document
类 DocumentFieldHTMLParser

java.lang.Object
    继承者  com.trs.components.web.BaseFieldHTMLParser
        继承者  com.trs.components.web.document.DocumentFieldHTMLParser
所有已实现的接口：
IFieldHTMLParser
public class DocumentFieldHTMLParser
extends BaseFieldHTMLParser

方法摘要
static DocumentFieldHTMLParser | getInstance()
java.lang.String | getTemplatePath() 返回模板存放的根路径
从类 com.trs.components.web.BaseFieldHTMLParser 继承的方法
getTemplate, getTemplateEncoding, getTemplateKey, parse
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getInstance

public static DocumentFieldHTMLParser getInstance()

getTemplatePath

public java.lang.String getTemplatePath()
                                 throws WCMException
从类 BaseFieldHTMLParser 复制的描述
返回模板存放的根路径

指定者：
类 BaseFieldHTMLParser 中的 getTemplatePath
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentPropertiesBuilder

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.components.web.document
类 DocumentPropertiesBuilder

java.lang.Object
    继承者  com.trs.components.web.BasePropertiesBuilder
        继承者  com.trs.components.web.document.DocumentPropertiesBuilder
所有已实现的接口：
IPropertiesBuilder
public class DocumentPropertiesBuilder
extends BasePropertiesBuilder

构造方法摘要
DocumentPropertiesBuilder(Document obj)
方法摘要
 java.util.Map build()
根据內部obj对象，返回想要的Properties
从类 com.trs.components.web.BasePropertiesBuilder 继承的方法
append, getObj
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentPropertiesBuilder

public DocumentPropertiesBuilder(Document obj)
方法详细信息

build

public java.util.Map build()
                    throws WCMException
从接口 IPropertiesBuilder 复制的描述
根据內部obj对象，返回想要的Properties

指定者：
接口 IPropertiesBuilder 中的 build
覆盖：
类 BasePropertiesBuilder 中的 build
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.components.web.document
类
DocumentFieldHTMLParser
DocumentPropertiesBuilder


com.trs.components.web.document

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.components.web.document

类摘要
DocumentFieldHTMLParser
DocumentPropertiesBuilder


com.trs.components.web.document 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.components.web.document 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.web.BaseFieldHTMLParser (implements com.trs.components.web.IFieldHTMLParser)
      • com.trs.components.web.document.DocumentFieldHTMLParser
    • com.trs.components.web.BasePropertiesBuilder (implements com.trs.components.web.IPropertiesBuilder)
      • com.trs.components.web.document.DocumentPropertiesBuilder


软件包 com.trs.components.web.document 的使用

上一个 下一个 框架 无框架

软件包 com.trs.components.web.document
的使用

使用 com.trs.components.web.document 的软件包
com.trs.components.web.document

com.trs.components.web.document 使用的 com.trs.components.web.document 中的类
DocumentFieldHTMLParser

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.web.document.DocumentFieldHTMLParser 的使用

上一个 下一个 框架 无框架

类 com.trs.components.web.document.DocumentFieldHTMLParser
的使用

使用 DocumentFieldHTMLParser 的软件包
com.trs.components.web.document

com.trs.components.web.document 中 DocumentFieldHTMLParser 的使用

返回 DocumentFieldHTMLParser 的 com.trs.components.web.document 中的方法
static DocumentFieldHTMLParser DocumentFieldHTMLParser.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.components.web.document.DocumentPropertiesBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.components.web.document.DocumentPropertiesBuilder
的使用

没有 com.trs.components.web.document.DocumentPropertiesBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AllDDLMaker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 AllDDLMaker

java.lang.Object
    继承者  com.trs.database.util.AllDDLMaker

public class AllDDLMaker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
从sqserver数据库中得到其它数据库的ddl(包含建表/索引语句)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
AllDDLMaker(java.lang.String[] args)
方法摘要
static void | main(java.lang.String[] args)
void | make()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AllDDLMaker

public AllDDLMaker(java.lang.String[] args)
方法详细信息

make

public void make()
          throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DataDictionary

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 DataDictionary

java.lang.Object
    继承者  com.trs.database.util.DataDictionary

public class DataDictionary
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
数据字典
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
DataDictionary(java.lang.String url, java.lang.String user, java.lang.String passwd)
方法摘要
static void | main(java.lang.String[] args)
void | makeDic()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataDictionary

public DataDictionary(java.lang.String url,
                      java.lang.String user,
                      java.lang.String passwd)
               throws java.lang.Exception
参数：
url -
user -
passwd -
抛出：
java.lang.Exception
方法详细信息

makeDic

public void makeDic()
             throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DbDDLMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 DbDDLMaker

java.lang.Object
    继承者  com.trs.database.util.DbDDLMaker

public class DbDDLMaker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
从SQLServer中获取DDL
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
DbDDLMaker()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DbDDLMaker

public DbDDLMaker()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DDLMain

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 DDLMain

java.lang.Object
    继承者  com.trs.database.util.DDLMain

public class DDLMain
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
DDLMain()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DDLMain

public DDLMain()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndexDDLMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 IndexDDLMaker

java.lang.Object
    继承者  com.trs.database.util.IndexDDLMaker

public class IndexDDLMaker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
从MSSQL数据库中获取所有*WCM*表的索引
利用了sysobjects系统表及sp_helpindex系统存储过程
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
IndexDDLMaker()

方法摘要
static void main(java.lang.String[] args)

从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IndexDDLMaker

public IndexDDLMaker()
方法详细信息

main

public static void main(java.lang.String[] args)
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndexList4Ora

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 IndexList4Ora

java.lang.Object
    继承者  com.trs.database.util.IndexList4Ora

public class IndexList4Ora
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
通过user_ind_columns列出所有的索引
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
IndexList4Ora()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IndexList4Ora

public IndexList4Ora()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Ora2DB2Convertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 Ora2DB2Convertor

java.lang.Object
    继承者  com.trs.database.util.Ora2DB2Convertor

public class Ora2DB2Convertor
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
SQL脚本转换:Oracle --> DB2
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
Ora2DB2Convertor()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Ora2DB2Convertor

public Ora2DB2Convertor()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OraImpExtractDDL

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 OraImpExtractDDL

java.lang.Object
    继承者  com.trs.database.util.OraImpExtractDDL

public class OraImpExtractDDL
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
imp system/orasysadmin touser=sichuan indexfile=sichuan.ddl full=y
获取到的文件抽取
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
OraImpExtractDDL()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OraImpExtractDDL

public OraImpExtractDDL()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OTop

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.database.util
类 OTop

java.lang.Object
    继承者  com.trs.database.util.OTop

public class OTop
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Oracle Top Sql
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
OTop()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OTop

public OTop()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.database.util
类
AllDDLMaker
DataDictionary
DbDDLMaker
DDLMain
IndexDDLMaker
IndexList4Ora
Ora2DB2Convertor
OraImpExtractDDL
OTop


com.trs.database.util

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.database.util

类摘要
AllDDLMaker Title: TRS 内容协作平台（TRS WCM）
Description:
从sqserver数据库中得到其它数据库的ddl(包含建表/索引语句)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DataDictionary Title: TRS 内容协作平台（TRS WCM）
Description:
数据字典
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DbDDLMaker Title: TRS 内容协作平台（TRS WCM）
Description:
从SQLServer中获取DDL
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DDLMain Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
IndexDDLMaker Title: TRS 内容协作平台（TRS WCM）
Description:
从MSSQL数据库中获取所有*WCM*表的索引
利用了sysobjects系统表及sp_helpindex系统存储过程
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
IndexList4Ora Title: TRS 内容协作平台（TRS WCM）
Description:
通过user_ind_columns列出所有的索引
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
Ora2DB2Convertor Title: TRS 内容协作平台（TRS WCM）
Description:
SQL脚本转换:Oracle --> DB2
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OraImpExtractDDL Title: TRS 内容协作平台（TRS WCM）
Description:
imp system/orasysadmin touser=sichuan indexfile=sichuan.ddl full=y
获取到的文件抽取
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OTop Title: TRS 内容协作平台（TRS WCM）
Description:
Oracle Top Sql
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)


com.trs.database.util 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.database.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.database.util.AllDDLMaker
    • com.trs.database.util.DataDictionary
    • com.trs.database.util.DbDDLMaker
    • com.trs.database.util.DDLMain
    • com.trs.database.util.IndexDDLMaker
    • com.trs.database.util.IndexList4Ora
    • com.trs.database.util.Ora2DB2Convertor
    • com.trs.database.util.OraImpExtractDDL
    • com.trs.database.util.OTop


软件包 com.trs.database.util 的使用

上一个 下一个 框架 无框架

软件包 com.trs.database.util
的使用

没有 com.trs.database.util 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.AllDDLMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.AllDDLMaker
的使用

没有 com.trs.database.util.AllDDLMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.DataDictionary 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.DataDictionary
的使用

没有 com.trs.database.util.DataDictionary 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.DbDDLMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.DbDDLMaker
的使用

没有 com.trs.database.util.DbDDLMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.DDLMain 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.DDLMain
的使用

没有 com.trs.database.util.DDLMain 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.IndexDDLMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.IndexDDLMaker
的使用

没有 com.trs.database.util.IndexDDLMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.IndexList4Ora 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.IndexList4Ora
的使用

没有 com.trs.database.util.IndexList4Ora 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.Ora2DB2Convertor 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.Ora2DB2Convertor
的使用

没有 com.trs.database.util.Ora2DB2Convertor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.OraImpExtractDDL 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.OraImpExtractDDL
的使用

没有 com.trs.database.util.OraImpExtractDDL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.database.util.OTop 的使用

上一个 下一个 框架 无框架

类 com.trs.database.util.OTop
的使用

没有 com.trs.database.util.OTop 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.db.schema
类
TRSDBSchema
TRSDBSchemaTest


com.trs.db.schema

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.db.schema

类摘要
TRSDBSchema | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TRSDBSchemaTest | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.db.schema 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.db.schema 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.trs.TRSWCMBaseTest
          • com.trs.db.schema.TRSDBSchemaTest
    • com.trs.db.schema.TRSDBSchema


软件包 com.trs.db.schema 的使用

上一个 下一个 框架 无框架

软件包 com.trs.db.schema
的使用

没有 com.trs.db.schema 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TRSDBSchema

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.db.schema
类 TRSDBSchema

java.lang.Object
    继承者  com.trs.db.schema.TRSDBSchema

public class TRSDBSchema
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TRSDBSchema(int _nDBType)
方法摘要
 java.lang.String createDBDataInsertSQL(java.lang.String _sFileName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSDBSchema

public TRSDBSchema(int _nDBType)
方法详细信息

createDBDataInsertSQL

public java.lang.String createDBDataInsertSQL(java.lang.String _sFileName)
                                       throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


TRSDBSchemaTest

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.db.schema
类 TRSDBSchemaTest

java.lang.Object
    继承者  junit.framework.Assert
        继承者  junit.framework.TestCase
            继承者  com.trs.TRSWCMBaseTest
                继承者  com.trs.db.schema.TRSDBSchemaTest
所有已实现的接口：
junit.framework.Test
public class TRSDBSchemaTest
extends com.trs.TRSWCMBaseTest

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TRSDBSchemaTest()
方法摘要
 void testCreateDBDataInsertSQL()
从类 junit.framework.TestCase 继承的方法
countTestCases, getName, run, run, runBare, setName, toString
从类 junit.framework.Assert 继承的方法
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TRSDBSchemaTest

public TRSDBSchemaTest()
方法详细信息

testCreateDBDataInsertSQL

public void testCreateDBDataInsertSQL()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.db.schema.TRSDBSchema 的使用

上一个 下一个 框架 无框架

类 com.trs.db.schema.TRSDBSchema
的使用

没有 com.trs.db.schema.TRSDBSchema 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.db.schema.TRSDBSchemaTest 的使用

上一个 下一个 框架 无框架

类 com.trs.db.schema.TRSDBSchemaTest
的使用

没有 com.trs.db.schema.TRSDBSchemaTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DBUpdateLog

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.db.update
类 DBUpdateLog

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.db.update.DBUpdateLog
所有已实现的接口：
java.lang.Cloneable
public class DBUpdateLog
extends BaseObj

字段摘要
static java.lang.String[] | DB_AUTO_COMMIT
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | DB_TYPE_DB2
static int | DB_TYPE_MYSQL
static int | DB_TYPE_ORACLE
static int | DB_TYPE_SQL
static int | DB_TYPE_SYBASE
static int | OBJ_TYPE 对象类型编号
static int | TYPE_ADD
static int | TYPE_UPDATE
构造方法摘要
DBUpdateLog()
构造函数：保留默认接口
方法摘要
static DBUpdateLog | createNewInstance() 产生当前对象[DBUpdateLog]的实例
static DBUpdateLog | findById(int _nId) 提取指定ID的对象
static DBUpdateLog | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDB2SQL() 提取属性：DB2SQL
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getMemo() 提取属性：Memo
java.lang.String | getMysqlSQL() 提取属性：MysqlSQL
java.lang.String | getOracleSQL() 提取属性：OracleSQL
java.lang.String | getSQL(int _nDBType)
java.lang.String | getSQLServerSQL() 提取属性：SQLServerSQL
java.lang.String | getSubmitor() 提取属性：Submitor
java.lang.String | getSysbaseSQL() 提取属性：SysbaseSQL
java.lang.String | getTableName() 提取属性：TableName
java.lang.String | getTitle() 提取属性：Titile
int | getType() 提取属性：Type
java.lang.String | getTypeDesc()
int | getWCMType() 取得该对象的类型编号
boolean | isValid() 检验对象数据有效性
boolean | setDB2SQL(java.lang.String _sDB2SQL) 设置属性：DB2SQL
boolean | setMemo(java.lang.String _sMemo) 设置属性：Memo
boolean | setMysqlSQL(java.lang.String _sMysqlSQL) 设置属性：MysqlSQL
boolean | setOracleSQL(java.lang.String _sOracleSQL) 设置属性：OracleSQL
boolean | setSQLServerSQL(java.lang.String _sSQLServerSQL) 设置属性：SQLServerSQL
boolean | setSubmitor(java.lang.String _sSubmitor) 设置属性：Submitor
boolean | setSysbaseSQL(java.lang.String _sSysbaseSQL) 设置属性：SysbaseSQL
boolean | setTableName(java.lang.String _sTableName) 设置属性：TableName
boolean | setTitile(java.lang.String _sTitile) 设置属性：Titile
boolean | setType(int _nType) 设置属性：Type
java.lang.String | toString()
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

TYPE_UPDATE

public static final int TYPE_UPDATE
另请参见：
常量字段值

TYPE_ADD

public static final int TYPE_ADD
另请参见：
常量字段值

DB_TYPE_SQL

public static final int DB_TYPE_SQL
另请参见：
常量字段值

DB_TYPE_ORACLE

public static final int DB_TYPE_ORACLE
另请参见：
常量字段值

DB_TYPE_DB2

public static final int DB_TYPE_DB2
另请参见：
常量字段值

DB_TYPE_SYBASE

public static final int DB_TYPE_SYBASE
另请参见：
常量字段值

DB_TYPE_MYSQL

public static final int DB_TYPE_MYSQL
另请参见：
常量字段值

DB_AUTO_COMMIT

public static final java.lang.String[] DB_AUTO_COMMIT

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

DBUpdateLog

public DBUpdateLog()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getTitle

public java.lang.String getTitle()
提取属性：Titile

返回：
Titile

setTitile

public boolean setTitile(java.lang.String _sTitile)
                  throws WCMException
设置属性：Titile

参数：
_sTitile - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMemo

public java.lang.String getMemo()
提取属性：Memo

返回：
Memo

setMemo

public boolean setMemo(java.lang.String _sMemo)
                throws WCMException
设置属性：Memo

参数：
_sMemo - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSubmitor

public java.lang.String getSubmitor()
提取属性：Submitor

返回：
Submitor

setSubmitor

public boolean setSubmitor(java.lang.String _sSubmitor)
                    throws WCMException
设置属性：Submitor

参数：
_sSubmitor - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTableName

public java.lang.String getTableName()
提取属性：TableName

返回：
TableName

setTableName

public boolean setTableName(java.lang.String _sTableName)
                     throws WCMException
设置属性：TableName

参数：
_sTableName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getType

public int getType()
提取属性：Type

返回：
Type

getTypeDesc

public java.lang.String getTypeDesc()

setType

public boolean setType(int _nType)
                throws WCMException
设置属性：Type

参数：
_nType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSQL

public java.lang.String getSQL(int _nDBType)
                        throws WCMException
抛出：
WCMException

getSQLServerSQL

public java.lang.String getSQLServerSQL()
提取属性：SQLServerSQL

返回：
SQLServerSQL

setSQLServerSQL

public boolean setSQLServerSQL(java.lang.String _sSQLServerSQL)
                        throws WCMException
设置属性：SQLServerSQL

参数：
_sSQLServerSQL - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOracleSQL

public java.lang.String getOracleSQL()
提取属性：OracleSQL

返回：
OracleSQL

setOracleSQL

public boolean setOracleSQL(java.lang.String _sOracleSQL)
                     throws WCMException
设置属性：OracleSQL

参数：
_sOracleSQL - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDB2SQL

public java.lang.String getDB2SQL()
提取属性：DB2SQL

返回：
DB2SQL

setDB2SQL

public boolean setDB2SQL(java.lang.String _sDB2SQL)
                  throws WCMException
设置属性：DB2SQL

参数：
_sDB2SQL - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getSysbaseSQL

public java.lang.String getSysbaseSQL()
提取属性：SysbaseSQL

返回：
SysbaseSQL

setSysbaseSQL

public boolean setSysbaseSQL(java.lang.String _sSysbaseSQL)
                      throws WCMException
设置属性：SysbaseSQL

参数：
_sSysbaseSQL - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getMysqlSQL

public java.lang.String getMysqlSQL()
提取属性：MysqlSQL

返回：
MysqlSQL

setMysqlSQL

public boolean setMysqlSQL(java.lang.String _sMysqlSQL)
                    throws WCMException
设置属性：MysqlSQL

参数：
_sMysqlSQL - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

findById

public static final DBUpdateLog findById(int _nId)
                                  throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final DBUpdateLog createNewInstance()
                                           throws WCMException
产生当前对象[DBUpdateLog]的实例

返回：
当前对象的实例[DBUpdateLog]
抛出：
WCMException

findByKey

public static final DBUpdateLog findByKey(java.lang.Object _oKey)
                                   throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DBUpdateLogMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.db.update
类 DBUpdateLogMgr

java.lang.Object
    继承者  com.trs.db.update.DBUpdateLogMgr

public class DBUpdateLogMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
管理和数据库更新相关的行为s
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DBUpdateLogMgr()
方法摘要
 java.lang.String getUpdateSql(int _nDBType, java.lang.String _sOrderField, boolean _bAutoAddCommit, boolean _bAddTitle, boolean _bAuthor, CMyDateTime _dtStart)
获得完整的数据库更新脚本
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBUpdateLogMgr

public DBUpdateLogMgr()
方法详细信息

getUpdateSql

public java.lang.String getUpdateSql(int _nDBType,
                                     java.lang.String _sOrderField,
                                     boolean _bAutoAddCommit,
                                     boolean _bAddTitle,
                                     boolean _bAuthor,
                                     CMyDateTime _dtStart)
                              throws WCMException
获得完整的数据库更新脚本

参数：
_nDBType - 数据库类型，从DBUpdateLog中的常量找
_sOrderField - 返回的数据库更新脚本按什么字段进行排序。为null则默认为按照创建时间排序
_autoAddCommit - true为自动添加commit或者go之类的提交语句，在每个SQL语句后都添加一个
_bAddTitle - true为自动添加SQL语句的标题
返回：
完整的SQL语句
抛出：
WCMException - 如果没有找到数据库类型则抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBUpdateLogs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.db.update
类 DBUpdateLogs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.db.update.DBUpdateLogs

public class DBUpdateLogs
extends BaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
DBUpdateLogs()
构造函数
DBUpdateLogs(int _initCapacity, int _incCapacity)
构造函数
方法摘要
static DBUpdateLogs | createNewInstance() 产生当前集合对象[DBUpdateLogs]的实例
static DBUpdateLogs | findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static DBUpdateLogs | openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[DBUpdateLogs]
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBUpdateLogs

public DBUpdateLogs()
构造函数

另请参见：
DBUpdateLogs( User _currUser, Application _app, int _initCapacity, int _incCapacity );

DBUpdateLogs

public DBUpdateLogs(int _initCapacity,
                    int _incCapacity)
构造函数

参数：
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final DBUpdateLogs findByIds(java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（DBUpdateLogs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final DBUpdateLogs openWCMObjs(WCMFilter _filter)
                                      throws WCMException
通过指定一个Filter获取当前集合[DBUpdateLogs]

参数：
_filter - 指定的Filter
返回：
当前集合[DBUpdateLogs]
抛出：
WCMException

createNewInstance

public static DBUpdateLogs createNewInstance()
产生当前集合对象[DBUpdateLogs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.db.update
类
DBUpdateLog
DBUpdateLogMgr
DBUpdateLogs
SQLServerUpdateSQL
UpdateSQLGenerator


com.trs.db.update

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.db.update

类摘要
DBUpdateLog |
DBUpdateLogMgr | Title: TRS 内容协作平台（TRS WCM） Description: 管理和数据库更新相关的行为s Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DBUpdateLogs |
SQLServerUpdateSQL | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UpdateSQLGenerator | 自动生成SQL更新脚本的工具.


com.trs.db.update 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.db.update 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.db.update.DBUpdateLog
    • com.trs.infra.persistent.BaseObjs
      • com.trs.db.update.DBUpdateLogs
    • com.trs.db.update.DBUpdateLogMgr
    • com.trs.db.update.SQLServerUpdateSQL
    • com.trs.db.update.UpdateSQLGenerator


软件包 com.trs.db.update 的使用

上一个 下一个 框架 无框架

软件包 com.trs.db.update
的使用

使用 com.trs.db.update 的软件包
com.trs.db.update

com.trs.db.update 使用的 com.trs.db.update 中的类
DBUpdateLog
DBUpdateLogs

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SQLServerUpdateSQL

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.db.update
类 SQLServerUpdateSQL

java.lang.Object
    继承者  com.trs.db.update.SQLServerUpdateSQL

public class SQLServerUpdateSQL
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SQLServerUpdateSQL()
方法摘要
static void | createOracleUpateSQL(CMyDateTime _dtStart)
static void | createSQLServerUpateSQL(CMyDateTime _dtStart)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SQLServerUpdateSQL

public SQLServerUpdateSQL()
方法详细信息

createSQLServerUpateSQL

public static void createSQLServerUpateSQL(CMyDateTime _dtStart)

createOracleUpateSQL

public static void createOracleUpateSQL(CMyDateTime _dtStart)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UpdateSQLGenerator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.db.update
类 UpdateSQLGenerator

java.lang.Object
    继承者  com.trs.db.update.UpdateSQLGenerator

public class UpdateSQLGenerator
extends java.lang.Object

自动生成SQL更新脚本的工具.
在SQLServerUpdateSQL工具的基础上, 进一步提供以下功能:

  • 不再需要手工获取wcmdbupdate表的最后更新时间并在bat文件中替换此时间.
  • 可以通过命令行参数指定更新配置文件中定义的其他数据库.

    另请参见：
    SQLServerUpdateSQL

    构造方法摘要
    UpdateSQLGenerator()
    方法摘要
    static void main(java.lang.String[] args)
    自动比较数据库更新信息, 并生成SQL更新脚本.
    从类 java.lang.Object 继承的方法
    equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    构造方法详细信息

    UpdateSQLGenerator

    public UpdateSQLGenerator()
    方法详细信息

    main

    public static void main(java.lang.String[] args)
                 throws java.lang.Exception
    自动比较数据库更新信息, 并生成SQL更新脚本. 最新数据库以配置文件config.xml中定义的default为对比标准, 所以在该工具的运行环境下请将default设置为Developer数据源.
    bat文件中调用示例:
  • 本机数据库更新脚本: java -cp %CLASSPATH%;. com.trs.db.update.UpdateSQLGenerator
  • WCM6Demo更新脚本: java -cp %CLASSPATH%;. com.trs.db.update.UpdateSQLGenerator WCM6DemoDB

    参数：
    args - args[0]表示要更新的数据库的名称, 如果没有该参数则更新本机数据库("LocalSQLServer").
    抛出：
    java.lang.Exception
    • 概述 软件包 类 使用 树 已过时 索引 帮助
    上一个类 下一个类 | 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.db.update.DBUpdateLog 的使用

上一个 下一个 框架 无框架

类 com.trs.db.update.DBUpdateLog
的使用

使用 DBUpdateLog 的软件包
com.trs.db.update

com.trs.db.update 中 DBUpdateLog 的使用

返回 DBUpdateLog 的 com.trs.db.update 中的方法
static DBUpdateLog | DBUpdateLog.createNewInstance() 产生当前对象[DBUpdateLog]的实例
static DBUpdateLog | DBUpdateLog.findById(int _nId) 提取指定ID的对象
static DBUpdateLog | DBUpdateLog.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.db.update.DBUpdateLogMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.db.update.DBUpdateLogMgr
的使用

没有 com.trs.db.update.DBUpdateLogMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.db.update.DBUpdateLogs 的使用

上一个 下一个 框架 无框架

类 com.trs.db.update.DBUpdateLogs
的使用

使用 DBUpdateLogs 的软件包
com.trs.db.update

com.trs.db.update 中 DBUpdateLogs 的使用

返回 DBUpdateLogs 的 com.trs.db.update 中的方法
static DBUpdateLogs | DBUpdateLogs.createNewInstance() 产生当前集合对象[DBUpdateLogs]的实例
static DBUpdateLogs | DBUpdateLogs.findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
static DBUpdateLogs | DBUpdateLogs.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[DBUpdateLogs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.db.update.SQLServerUpdateSQL 的使用

上一个 下一个 框架 无框架

类 com.trs.db.update.SQLServerUpdateSQL
的使用

没有 com.trs.db.update.SQLServerUpdateSQL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.db.update.UpdateSQLGenerator 的使用

上一个 下一个 框架 无框架

类 com.trs.db.update.UpdateSQLGenerator
的使用

没有 com.trs.db.update.UpdateSQLGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


JsCombineFilter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.devhelper
类 JsCombineFilter

java.lang.Object
    继承者  com.trs.devhelper.JsCombineFilter
所有已实现的接口：
javax.servlet.Filter
public class JsCombineFilter
extends java.lang.Object
implements javax.servlet.Filter

构造方法摘要
JsCombineFilter()
方法摘要
void | destroy()
void | doFilter(javax.servlet.ServletRequest request, javax.servlet.ServletResponse response, javax.servlet.FilterChain chain)
void | init(javax.servlet.FilterConfig filterConfig)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JsCombineFilter

public JsCombineFilter()
方法详细信息

init

public void init(javax.servlet.FilterConfig filterConfig)
          throws javax.servlet.ServletException
指定者：
接口 javax.servlet.Filter 中的 init
抛出：
javax.servlet.ServletException

doFilter

public void doFilter(javax.servlet.ServletRequest request,
                     javax.servlet.ServletResponse response,
                     javax.servlet.FilterChain chain)
              throws java.io.IOException,
                     javax.servlet.ServletException
指定者：
接口 javax.servlet.Filter 中的 doFilter
抛出：
java.io.IOException
javax.servlet.ServletException

destroy

public void destroy()
指定者：
接口 javax.servlet.Filter 中的 destroy
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.devhelper
类
JsCombineFilter


com.trs.devhelper

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.devhelper

类摘要
JsCombineFilter


com.trs.devhelper 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.devhelper 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.devhelper.JsCombineFilter (implements javax.servlet.Filter)


软件包 com.trs.devhelper 的使用

上一个 下一个 框架 无框架

软件包 com.trs.devhelper
的使用

没有 com.trs.devhelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.devhelper.JsCombineFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.devhelper.JsCombineFilter
的使用

没有 com.trs.devhelper.JsCombineFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 BaseConfig

java.lang.Object
    继承者  com.trs.infra.BaseConfig
直接已知子类：
DBTableConfig, FileConfig, XMLConfig
public abstract class BaseConfig
extends java.lang.Object

版本：
1.0
作者：
wyw

构造方法摘要
BaseConfig()
方法摘要
void | refresh()
void | save()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseConfig

public BaseConfig()
方法详细信息

save

public void save()
          throws java.lang.Exception
抛出：
java.lang.Exception

refresh

public void refresh()
             throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BaseServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 BaseServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
所有已实现的接口：
IServer
直接已知子类：
BaseConfigServer, BeanConfigServer, CacheServer, ConfigServer, DBManager, FlowConfigServer, FlowRuleCacheServerImpl, FlowServer, FlowServerImpl, InfoViewDBStoreServer, JobScheduleServer, KMTRSServer, LocaleServer, NotificationServer, ObjectLCMonitorServer, ObjectTypeServer, OuterKMTRSServer, PublishServer, RightConfigServer, TRSCKMServer, TRSWCMClusterServer, UpdateServer, XMLConfigServer
public abstract class BaseServer
extends java.lang.Object
implements IServer

Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
java.lang.String | APP_BUILD 系统内部版本号
java.lang.String | APP_BUILD_TIME Build时间
static java.lang.String | APP_VERSION 版本信息
java.lang.String | DB_BUILD 当前连接的数据库版本信息
构造方法摘要
BaseServer()
方法摘要
java.lang.String | getBuildTime() build时间
java.lang.String | getDbBuild() 数据库版本号
CMyErrors | getErrors() 获取错误信息
java.lang.String | getServerBuild() 系统内部版本号
java.lang.String | getServerName() 获取服务名称
java.lang.String | getVersion() 当前系统版本号
boolean | isStarted() 判断Server是否已经启动
boolean | isStarting()
boolean | restart() 重新启动应用
void | setServerName(java.lang.String _sAppName) 设置服务名称
void | shutdown() 关闭应用
boolean | startup() 启动应用
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

APP_VERSION

public static final java.lang.String APP_VERSION
版本信息

另请参见：
常量字段值

APP_BUILD

public java.lang.String APP_BUILD
系统内部版本号

DB_BUILD

public java.lang.String DB_BUILD
当前连接的数据库版本信息

APP_BUILD_TIME

public java.lang.String APP_BUILD_TIME
Build时间

构造方法详细信息

BaseServer

public BaseServer()
方法详细信息

getErrors

public CMyErrors getErrors()
从接口 IServer 复制的描述
获取错误信息

指定者：
接口 IServer 中的 getErrors
返回：

isStarted

public boolean isStarted()
判断Server是否已经启动

返回：

isStarting

public boolean isStarting()
返回：
true :Server正在启动

false :Server不在启动过程中

startup

public boolean startup()
从接口 IServer 复制的描述
启动应用

指定者：
接口 IServer 中的 startup
返回：
如果启动成功,返回true
如果启动失败，返回false

shutdown

public void shutdown()
从接口 IServer 复制的描述
关闭应用

指定者：
接口 IServer 中的 shutdown

restart

public boolean restart()
从接口 IServer 复制的描述
重新启动应用

指定者：
接口 IServer 中的 restart
返回：
如果启动成功,返回true
如果启动失败，返回false

getServerName

public java.lang.String getServerName()
从接口 IServer 复制的描述
获取服务名称

指定者：
接口 IServer 中的 getServerName
返回：

setServerName

public void setServerName(java.lang.String _sAppName)
从接口 IServer 复制的描述
设置服务名称

指定者：
接口 IServer 中的 setServerName
参数：
_sAppName - 服务名称

getServerBuild

public java.lang.String getServerBuild()
从接口 IServer 复制的描述
系统内部版本号

指定者：
接口 IServer 中的 getServerBuild
返回：

getBuildTime

public java.lang.String getBuildTime()
从接口 IServer 复制的描述
build时间

指定者：
接口 IServer 中的 getBuildTime
返回：

getDbBuild

public java.lang.String getDbBuild()
从接口 IServer 复制的描述
数据库版本号

指定者：
接口 IServer 中的 getDbBuild
返回：

getVersion

public java.lang.String getVersion()
从接口 IServer 复制的描述
当前系统版本号

指定者：
接口 IServer 中的 getVersion
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClusterSessionFileter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 ClusterSessionFileter

java.lang.Object
    继承者  com.trs.infra.session.util.SessionFilterBase
        继承者  com.trs.infra.ClusterSessionFileter
所有已实现的接口：
javax.servlet.Filter
public class ClusterSessionFileter
extends com.trs.infra.session.util.SessionFilterBase

Title: TRS 内容协作平台（TRS WCM）
Description:
集群session管理
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ClusterSessionFileter()
方法摘要
从类 com.trs.infra.session.util.SessionFilterBase 继承的方法
destroy, doFilter, init
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClusterSessionFileter

public ClusterSessionFileter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


I18NMessage

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 I18NMessage

java.lang.Object
    继承者  com.trs.infra.I18NMessage

public final class I18NMessage
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
国际化消息处理
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
I18NMessage()
方法摘要
static java.lang.String | get(java.lang.Class objCls, java.lang.String key, java.lang.String defaultValue)
static java.lang.String | makeObjectNotFound(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

I18NMessage

public I18NMessage()
方法详细信息

makeObjectNotFound

public static java.lang.String makeObjectNotFound(java.lang.String[] args)

get

public static java.lang.String get(java.lang.Class objCls,
                                   java.lang.String key,
                                   java.lang.String defaultValue)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


I18NMessageStartUp

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 I18NMessageStartUp

java.lang.Object
    继承者  com.trs.infra.I18NMessageStartUp
所有已实现的接口：
java.util.EventListener, javax.servlet.ServletContextListener
public class I18NMessageStartUp
extends java.lang.Object
implements javax.servlet.ServletContextListener

构造方法摘要
I18NMessageStartUp()
方法摘要
void | contextDestroyed(javax.servlet.ServletContextEvent sce)
void | contextInitialized(javax.servlet.ServletContextEvent sce)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

I18NMessageStartUp

public I18NMessageStartUp()
方法详细信息

contextInitialized

public void contextInitialized(javax.servlet.ServletContextEvent sce)
指定者：
接口 javax.servlet.ServletContextListener 中的 contextInitialized

contextDestroyed

public void contextDestroyed(javax.servlet.ServletContextEvent sce)
指定者：
接口 javax.servlet.ServletContextListener 中的 contextDestroyed
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
接口 IServer

所有已知子接口：
ICKMServer, IFlowRuleCacheServer, IFlowServer
所有已知实现类：
BaseConfigServer, BaseServer, BeanConfigServer, CacheServer, ConfigServer, DBManager, DefaultChannelMakerCenter, FieldValueCreatorConfigStartServer, FlowConfigServer, FlowRuleCacheServerImpl, FlowServer, FlowServerImpl, InfoViewDBStoreServer, InfoViewFieldValueCreatorConfigStartServer, JobScheduleServer, KMTRSServer, LocaleServer, NotificationServer, ObjectLCMonitorServer, ObjectTypeServer, OuterKMTRSServer, PublishServer, RightConfigServer, ServiceConfigStartServer, TRSCKMServer, TRSWCMClusterServer, UpdateServer, XMLConfigServer, XMLConvertorConfigStartServer
public interface IServer

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String | getBuildTime() build时间
java.lang.String | getDbBuild() 数据库版本号
CMyErrors | getErrors() 获取错误信息
java.lang.String | getServerBuild() 系统内部版本号
java.lang.String | getServerName() 获取服务名称
java.lang.String | getVersion() 当前系统版本号
boolean | restart() 重新启动应用
void | setServerName(java.lang.String _sAppName) 设置服务名称
void | shutdown() 关闭应用
boolean | startup() 启动应用

方法详细信息

startup

boolean startup()
                throws WCMException
启动应用

返回：
如果启动成功,返回true
如果启动失败，返回false
抛出：
WCMException

restart

boolean restart()
重新启动应用

返回：
如果启动成功,返回true
如果启动失败，返回false

shutdown

void shutdown()
              throws WCMException
关闭应用

抛出：
WCMException

getErrors

CMyErrors getErrors()
获取错误信息

返回：

getVersion

java.lang.String getVersion()
当前系统版本号

返回：

getServerBuild

java.lang.String getServerBuild()
系统内部版本号

返回：

getDbBuild

java.lang.String getDbBuild()
数据库版本号

返回：

getBuildTime

java.lang.String getBuildTime()
build时间

返回：

getServerName

java.lang.String getServerName()
获取服务名称

返回：

setServerName

void setServerName(java.lang.String _sAppName)
设置服务名称

参数：
_sAppName - 服务名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MyTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 MyTypes

java.lang.Object
    继承者  com.trs.infra.MyTypes

public class MyTypes
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）

Description:

用以定义WCM中的对象类型编码常量、以及各个WCM系统中所用到的常量

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | NO WCM逻辑值常量，布尔假值
static int | YES WCM逻辑值常量，布尔真值
构造方法摘要
MyTypes()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

YES

public static final int YES
WCM逻辑值常量，布尔真值

另请参见：
常量字段值

NO

public static final int NO
WCM逻辑值常量，布尔假值

另请参见：
常量字段值
构造方法详细信息

MyTypes

public MyTypes()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra
接口
IServer
类
BaseConfig
BaseServer
ClusterSessionFileter
I18NMessage
I18NMessageStartUp
MyTypes
ServerConfig
ServerControl
StartupServlet


com.trs.infra

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra

接口摘要
IServer Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
BaseConfig |
BaseServer | Title: TRS 内容协作平台（TRS WCM） Description: Server基类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClusterSessionFileter | Title: TRS 内容协作平台（TRS WCM） Description: 集群session管理 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
I18NMessage | Title: TRS 内容协作平台（TRS WCM） Description: 国际化消息处理 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
I18NMessageStartUp |
MyTypes | Title: TRS 内容协作平台（TRS WCM） Description: 用以定义WCM中的对象类型编码常量、以及各个WCM系统中所用到的常量 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ServerConfig | Title: TRS 内容协作平台（TRS WCM） Description: 服务器对象的配置信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ServerControl | Title: TRS 内容协作平台（TRS WCM） Description: 服务器控制器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
StartupServlet | Title: TRS 内容协作平台（TRS WCM） Description: 系统服务器启动Servlet Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseConfig
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • com.trs.infra.StartupServlet
    • com.trs.infra.I18NMessage
    • com.trs.infra.I18NMessageStartUp (implements javax.servlet.ServletContextListener)
    • com.trs.infra.MyTypes
    • com.trs.infra.ServerConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.ServerControl
    • com.trs.infra.session.util.SessionFilterBase (implements javax.servlet.Filter)
      • com.trs.infra.ClusterSessionFileter

接口分层结构

  • com.trs.infra.IServer


软件包 com.trs.infra 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra
的使用

使用 com.trs.infra 的软件包
com.trs.cluster
com.trs.cms
com.trs.cms.auth.config
com.trs.cms.process
com.trs.cms.process.config
com.trs.cms.process.definition
com.trs.components.ckm
com.trs.components.common.job
com.trs.components.common.message.notify
com.trs.components.common.publish.domain
com.trs.components.infoview.db
com.trs.components.infoview.helper
com.trs.components.metadata.center
com.trs.components.metadata.service
com.trs.components.wcm.content.trsserver
com.trs.infra
com.trs.infra.config
com.trs.infra.persistent.db
com.trs.infra.persistent.listener
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.update
com.trs.presentation.locale
com.trs.webframework.config
com.trs.webframework.xmlserver

com.trs.cluster 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.config 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.config 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message.notify 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.db 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.helper 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.center 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.trsserver 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra 使用的 com.trs.infra 中的类
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServerControl
Title: TRS 内容协作平台（TRS WCM）
Description:
服务器控制器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config 使用的 com.trs.infra 中的类
BaseConfig
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.update 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.locale 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.config 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.xmlserver 使用的 com.trs.infra 中的类
BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ServerConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 ServerConfig

java.lang.Object
    继承者  com.trs.infra.ServerConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class ServerConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
服务器对象的配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ServerConfig()
方法摘要
IServer | getBean() 根据 beanId得到对应bean
java.lang.String | getBeanId()
java.lang.String | getName() 获取配置对象的名称
void | setBeanId(java.lang.String beanId)
void | setName(java.lang.String _sName) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServerConfig

public ServerConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getBeanId

public java.lang.String getBeanId()

setBeanId

public void setBeanId(java.lang.String beanId)

getBean

public IServer getBean()
根据 beanId得到对应bean

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerControl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 ServerControl

java.lang.Object
    继承者  com.trs.infra.ServerControl

public class ServerControl
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
服务器控制器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String APP_VERSION
构造方法摘要
ServerControl()
方法摘要
static ServerControl | createInstance()
int | getServerCount()
IServer[] | getServers()
static void | main(java.lang.String[] args)
boolean | restart()
void | shutdown()
void | startup()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

APP_VERSION

public static final java.lang.String APP_VERSION
另请参见：
常量字段值
构造方法详细信息

ServerControl

public ServerControl()
方法详细信息

createInstance

public static ServerControl createInstance()

getServerCount

public int getServerCount()

getServers

public IServer[] getServers()

restart

public boolean restart()

startup

public void startup()

main

public static void main(java.lang.String[] args)

shutdown

public void shutdown()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StartupServlet

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra
类 StartupServlet

java.lang.Object
    继承者  javax.servlet.GenericServlet
        继承者  javax.servlet.http.HttpServlet
            继承者  com.trs.infra.StartupServlet
所有已实现的接口：
java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig
public class StartupServlet
extends javax.servlet.http.HttpServlet

Title: TRS 内容协作平台（TRS WCM）
Description:
系统服务器启动Servlet
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
StartupServlet()
方法摘要
void | destroy()
void | init(javax.servlet.ServletConfig _servletConfig)
从类 javax.servlet.http.HttpServlet 继承的方法
service
从类 javax.servlet.GenericServlet 继承的方法
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StartupServlet

public StartupServlet()
方法详细信息

init

public void init(javax.servlet.ServletConfig _servletConfig)
          throws javax.servlet.ServletException
指定者：
接口 javax.servlet.Servlet 中的 init
覆盖：
类 javax.servlet.GenericServlet 中的 init
抛出：
javax.servlet.ServletException

destroy

public void destroy()
指定者：
接口 javax.servlet.Servlet 中的 destroy
覆盖：
类 javax.servlet.GenericServlet 中的 destroy
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.BaseConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.BaseConfig
的使用

使用 BaseConfig 的软件包
com.trs.infra.config

com.trs.infra.config 中 BaseConfig 的使用

com.trs.infra.config 中 BaseConfig 的子类
class | DBTableConfig
class | FileConfig
class | XMLConfig

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.BaseServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.BaseServer
的使用

使用 BaseServer 的软件包
com.trs.cluster
com.trs.cms
com.trs.cms.auth.config
com.trs.cms.process
com.trs.cms.process.config
com.trs.cms.process.definition
com.trs.components.ckm
com.trs.components.common.job
com.trs.components.common.message.notify
com.trs.components.common.publish.domain
com.trs.components.infoview.db
com.trs.components.infoview.helper
com.trs.components.metadata.center
com.trs.components.metadata.service
com.trs.components.wcm.content.trsserver
com.trs.infra.config
com.trs.infra.persistent.db
com.trs.infra.persistent.listener
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.update
com.trs.presentation.locale
com.trs.webframework.config
com.trs.webframework.xmlserver

com.trs.cluster 中 BaseServer 的使用

com.trs.cluster 中 BaseServer 的子类
 class TRSWCMClusterServer

com.trs.cms 中 BaseServer 的使用

com.trs.cms 中 BaseServer 的子类
 class ObjectTypeServer

com.trs.cms.auth.config 中 BaseServer 的使用

com.trs.cms.auth.config 中 BaseServer 的子类
 class RightConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:
权限配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process 中 BaseServer 的使用

com.trs.cms.process 中 BaseServer 的子类
class | FlowServer
class | FlowServerImpl Title: TRS 内容协作平台（TRS WCM） Description: FlowServer的默认实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.config 中 BaseServer 的使用

com.trs.cms.process.config 中 BaseServer 的子类
 class FlowConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流配置服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 中 BaseServer 的使用

com.trs.cms.process.definition 中 BaseServer 的子类
 class FlowRuleCacheServerImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流规则缓冲维护器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 中 BaseServer 的使用

com.trs.components.ckm 中 BaseServer 的子类
 class TRSCKMServer
Title: TRS 内容协作平台（TRS WCM）
Description:
智能信息处理服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 中 BaseServer 的使用

com.trs.components.common.job 中 BaseServer 的子类
 class JobScheduleServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message.notify 中 BaseServer 的使用

com.trs.components.common.message.notify 中 BaseServer 的子类
 class NotificationServer
Title: TRS 内容协作平台（TRS WCM）
Description:
notification server.

com.trs.components.common.publish.domain 中 BaseServer 的使用

com.trs.components.common.publish.domain 中 BaseServer 的子类
 class PublishServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.db 中 BaseServer 的使用

com.trs.components.infoview.db 中 BaseServer 的子类
 class InfoViewDBStoreServer
TODO Add javadoc for BigTableServer

com.trs.components.infoview.helper 中 BaseServer 的使用

com.trs.components.infoview.helper 中 BaseServer 的子类
 class InfoViewFieldValueCreatorConfigStartServer

com.trs.components.metadata.center 中 BaseServer 的使用

com.trs.components.metadata.center 中 BaseServer 的子类
 class FieldValueCreatorConfigStartServer
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 中 BaseServer 的使用

com.trs.components.metadata.service 中 BaseServer 的子类
 class DefaultChannelMakerCenter
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.trsserver 中 BaseServer 的使用

com.trs.components.wcm.content.trsserver 中 BaseServer 的子类
class | KMTRSServer
class | OuterKMTRSServer

com.trs.infra.config 中 BaseServer 的使用

com.trs.infra.config 中 BaseServer 的子类
class | BaseConfigServer
class | BeanConfigServer Title: TRS 内容协作平台（TRS WCM） Description: 为SpringBean的配置提供服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | XMLConfigServer Title: TRS 内容协作平台（TRS WCM） Description: 对可配置对象的顶层管理类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 中 BaseServer 的使用

com.trs.infra.persistent.db 中 BaseServer 的子类
 class DBManager
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 中 BaseServer 的使用

com.trs.infra.persistent.listener 中 BaseServer 的子类
 class ObjectLCMonitorServer
Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 中 BaseServer 的使用

com.trs.infra.support.cache 中 BaseServer 的子类
 class CacheServer
Title: TRS 内容协作平台（TRS WCM）
Description:
系统缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 中 BaseServer 的使用

com.trs.infra.support.config 中 BaseServer 的子类
 class ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.infra.update 中 BaseServer 的使用

com.trs.infra.update 中 BaseServer 的子类
 class UpdateServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Server
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.locale 中 BaseServer 的使用

com.trs.presentation.locale 中 BaseServer 的子类
 class LocaleServer
Title: TRS 内容协作平台（TRS WCM）
Description:
i18n
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.config 中 BaseServer 的使用

com.trs.webframework.config 中 BaseServer 的子类
 class ServiceConfigStartServer

com.trs.webframework.xmlserver 中 BaseServer 的使用

com.trs.webframework.xmlserver 中 BaseServer 的子类
 class XMLConvertorConfigStartServer
Title: TRS 内容协作平台（TRS WCM）
Description:
XML转换器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.ClusterSessionFileter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.ClusterSessionFileter
的使用

没有 com.trs.infra.ClusterSessionFileter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.I18NMessage 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.I18NMessage
的使用

没有 com.trs.infra.I18NMessage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.I18NMessageStartUp 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.I18NMessageStartUp
的使用

没有 com.trs.infra.I18NMessageStartUp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.IServer 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.IServer
的使用

使用 IServer 的软件包
com.trs.cluster
com.trs.cms
com.trs.cms.auth.config
com.trs.cms.process
com.trs.cms.process.config
com.trs.cms.process.definition
com.trs.components.ckm
com.trs.components.common.job
com.trs.components.common.message.notify
com.trs.components.common.publish.domain
com.trs.components.infoview.db
com.trs.components.infoview.helper
com.trs.components.metadata.center
com.trs.components.metadata.service
com.trs.components.wcm.content.trsserver
com.trs.infra
com.trs.infra.config
com.trs.infra.persistent.db
com.trs.infra.persistent.listener
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.update
com.trs.presentation.locale
com.trs.webframework.config
com.trs.webframework.xmlserver

com.trs.cluster 中 IServer 的使用

实现 IServer 的 com.trs.cluster 中的类
 class TRSWCMClusterServer

com.trs.cms 中 IServer 的使用

实现 IServer 的 com.trs.cms 中的类
 class ObjectTypeServer

com.trs.cms.auth.config 中 IServer 的使用

实现 IServer 的 com.trs.cms.auth.config 中的类
 class RightConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:
权限配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process 中 IServer 的使用

com.trs.cms.process 中 IServer 的子接口
 interface IFlowServer
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流流转驱动器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IServer 的 com.trs.cms.process 中的类
class | FlowServer
class | FlowServerImpl Title: TRS 内容协作平台（TRS WCM） Description: FlowServer的默认实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.config 中 IServer 的使用

实现 IServer 的 com.trs.cms.process.config 中的类
 class FlowConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流配置服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 中 IServer 的使用

com.trs.cms.process.definition 中 IServer 的子接口
 interface IFlowRuleCacheServer
Title: TRS 内容协作平台（TRS WCM）
Description:
规则缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IServer 的 com.trs.cms.process.definition 中的类
 class FlowRuleCacheServerImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流规则缓冲维护器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 中 IServer 的使用

com.trs.components.ckm 中 IServer 的子接口
 interface ICKMServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IServer 的 com.trs.components.ckm 中的类
 class TRSCKMServer
Title: TRS 内容协作平台（TRS WCM）
Description:
智能信息处理服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 中 IServer 的使用

实现 IServer 的 com.trs.components.common.job 中的类
 class JobScheduleServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message.notify 中 IServer 的使用

实现 IServer 的 com.trs.components.common.message.notify 中的类
 class NotificationServer
Title: TRS 内容协作平台（TRS WCM）
Description:
notification server.

com.trs.components.common.publish.domain 中 IServer 的使用

实现 IServer 的 com.trs.components.common.publish.domain 中的类
 class PublishServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.db 中 IServer 的使用

实现 IServer 的 com.trs.components.infoview.db 中的类
 class InfoViewDBStoreServer
TODO Add javadoc for BigTableServer

com.trs.components.infoview.helper 中 IServer 的使用

实现 IServer 的 com.trs.components.infoview.helper 中的类
 class InfoViewFieldValueCreatorConfigStartServer

com.trs.components.metadata.center 中 IServer 的使用

实现 IServer 的 com.trs.components.metadata.center 中的类
 class FieldValueCreatorConfigStartServer
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 中 IServer 的使用

实现 IServer 的 com.trs.components.metadata.service 中的类
 class DefaultChannelMakerCenter
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.trsserver 中 IServer 的使用

实现 IServer 的 com.trs.components.wcm.content.trsserver 中的类
class | KMTRSServer
class | OuterKMTRSServer

com.trs.infra 中 IServer 的使用

实现 IServer 的 com.trs.infra 中的类
 class BaseServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IServer 的 com.trs.infra 中的方法
IServer | ServerConfig.getBean() 根据 beanId得到对应bean
IServer[] | ServerControl.getServers()

com.trs.infra.config 中 IServer 的使用

实现 IServer 的 com.trs.infra.config 中的类
class | BaseConfigServer
class | BeanConfigServer Title: TRS 内容协作平台（TRS WCM） Description: 为SpringBean的配置提供服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | XMLConfigServer Title: TRS 内容协作平台（TRS WCM） Description: 对可配置对象的顶层管理类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 中 IServer 的使用

实现 IServer 的 com.trs.infra.persistent.db 中的类
 class DBManager
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 中 IServer 的使用

实现 IServer 的 com.trs.infra.persistent.listener 中的类
 class ObjectLCMonitorServer
Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 中 IServer 的使用

实现 IServer 的 com.trs.infra.support.cache 中的类
 class CacheServer
Title: TRS 内容协作平台（TRS WCM）
Description:
系统缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 中 IServer 的使用

实现 IServer 的 com.trs.infra.support.config 中的类
 class ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.infra.update 中 IServer 的使用

实现 IServer 的 com.trs.infra.update 中的类
 class UpdateServer
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Server
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.locale 中 IServer 的使用

实现 IServer 的 com.trs.presentation.locale 中的类
 class LocaleServer
Title: TRS 内容协作平台（TRS WCM）
Description:
i18n
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.config 中 IServer 的使用

实现 IServer 的 com.trs.webframework.config 中的类
 class ServiceConfigStartServer

com.trs.webframework.xmlserver 中 IServer 的使用

实现 IServer 的 com.trs.webframework.xmlserver 中的类
 class XMLConvertorConfigStartServer
Title: TRS 内容协作平台（TRS WCM）
Description:
XML转换器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.MyTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.MyTypes
的使用

没有 com.trs.infra.MyTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.ServerConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.ServerConfig
的使用

没有 com.trs.infra.ServerConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.ServerControl 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.ServerControl
的使用

使用 ServerControl 的软件包
com.trs.infra

com.trs.infra 中 ServerControl 的使用

返回 ServerControl 的 com.trs.infra 中的方法
static ServerControl ServerControl.createInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.StartupServlet 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.StartupServlet
的使用

没有 com.trs.infra.StartupServlet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseContextHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.common
类 BaseContextHelper

java.lang.Object
    继承者  com.trs.infra.common.BaseContextHelper

public class BaseContextHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
使用ThreadLocal方式在各个功能模块间传递参数的管理模块
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseContextHelper()
方法摘要
static void | clear()
static java.lang.Object | getArg(int _nIndex) 获得扩展参数列表中第_nIndex位置上的参数 处理策略： 1.
static int | getNextIndex()
static int | setArg(int _nIndex, java.lang.Object _currObj) 在扩展参数列表的第_nIndex个位置设置参数对象_currObj 处理策略： 1.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseContextHelper

public BaseContextHelper()
方法详细信息

getArg

public static java.lang.Object getArg(int _nIndex)
获得扩展参数列表中第_nIndex位置上的参数 处理策略：
1. 从ArrayList中定位到第_nIndex个位置 2. 取出来的对象使用前要做类型强制转换

参数：
_nIndex - ：扩展参数列表中参数的存放位置
返回：
如果指定位置上有对象，则返回该对象；如果没有则返回NULL（异常？）

setArg

public static int setArg(int _nIndex,
                         java.lang.Object _currObj)
在扩展参数列表的第_nIndex个位置设置参数对象_currObj 处理策略：
1. 如果该位置上已经存在参数，则替换原有参数

参数：
_nIndex - ：扩展参数列表中的位置
_currObj - ：设置的参数

getNextIndex

public static int getNextIndex()

clear

public static void clear()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BaseIdsMan

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.common
类 BaseIdsMan

java.lang.Object
    继承者  com.trs.infra.common.BaseIdsMan
直接已知子类：
CustomizedChannelIdsMan, EventShareIdsMan, GrpUserIdsMan, RoleUserIdsMan, SiteMemberIdsMan, TemplateEmployerIdsMan
public abstract class BaseIdsMan
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
关联对象的处理基本管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseIdsMan()
方法摘要
 void dowithIds(java.lang.String _sIds)
处理Ids
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseIdsMan

public BaseIdsMan()
方法详细信息

dowithIds

public void dowithIds(java.lang.String _sIds)
               throws WCMException
处理Ids

参数：
_sIds -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContextParameters

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.common
类 ContextParameters

java.lang.Object
    继承者  com.trs.infra.common.ContextParameters

public class ContextParameters
extends java.lang.Object

为了在不改变现有接口的情况下可以向下层函数传递新增加的参数 借助TLS实现，TLS:Thread Local Storage。

字段摘要
static int | FILE_ENCODING 预留索引 文件编码检测使用.
static int | NESTED_TEMPLATE 预留索引 嵌套模板环路检查使用.
static int | SAVED_OBJID 预留索引 保存日志使用
static int | SCHEDULE_PUBTASK 预留索引 计划发布任务使用
构造方法摘要
ContextParameters()
方法摘要
static java.lang.Object | get(int index) 返回指定索引序号的参数，返回后相关联位置的参数会被清除，以TLS节约内存
static java.lang.Object | get(int index, boolean keep) 返回指定索引序号的参数，并根据keep的值决定是否清楚该参数
static java.lang.Object | get0() 快速返回第一个参数，等价于get(0, false)。
static java.lang.Object | get1() 快速返回第二个参数，等价于get(1, false)。
static java.lang.Object | get2() 快速返回第三个参数，等价于get(2, false)。
static int | getMaxIndex() 返回所允许的最大的参数索引值
static java.lang.Object | set(int index, java.lang.Object parameter) 在指定的索引位置上设置参数
static void | set0(java.lang.Object parameter) 快速设置第一个参数，等价于set(0, parameter)。
static void | set1(java.lang.Object parameter) 快速设置第二个参数，等价于set(1, parameter)。
static void | set2(java.lang.Object parameter) 快速设置第三个参数，等价于set(2, parameter)。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SAVED_OBJID

public static final int SAVED_OBJID
预留索引
保存日志使用

另请参见：
常量字段值

SCHEDULE_PUBTASK

public static final int SCHEDULE_PUBTASK
预留索引
计划发布任务使用

另请参见：
常量字段值

NESTED_TEMPLATE

public static final int NESTED_TEMPLATE
预留索引
嵌套模板环路检查使用.

另请参见：
常量字段值

FILE_ENCODING

public static final int FILE_ENCODING
预留索引
文件编码检测使用.

另请参见：
常量字段值
构造方法详细信息

ContextParameters

public ContextParameters()
方法详细信息

getMaxIndex

public static final int getMaxIndex()
返回所允许的最大的参数索引值

返回：
允许的最大的参数索引值

get

public static final java.lang.Object get(int index)
返回指定索引序号的参数，返回后相关联位置的参数会被清除，以TLS节约内存

参数：
index - 指定的索引序号
返回：
该序号关联的参数
抛出：
java.lang.ArrayIndexOutOfBoundsException - 如果index超出了getMaxIndex()指定的范围

get

public static final java.lang.Object get(int index,
                                         boolean keep)
返回指定索引序号的参数，并根据keep的值决定是否清楚该参数

参数：
index - 指定的索引序号
keep - 是否继续持有相关参数
返回：
该序号关联的参数
抛出：
java.lang.ArrayIndexOutOfBoundsException - 如果index超出了getMaxIndex()指定的范围

set

public static final java.lang.Object set(int index,
                                         java.lang.Object parameter)
在指定的索引位置上设置参数

参数：
index - 指定的索引序号
parameter - 待设置的参数
返回：
在指定位置上原有参数
抛出：
java.lang.ArrayIndexOutOfBoundsException - 如果index超出了getMaxIndex()指定的范围

get0

public static final java.lang.Object get0()
快速返回第一个参数，等价于get(0, false)。

返回：
第一个上参数

set0

public static final void set0(java.lang.Object parameter)
快速设置第一个参数，等价于set(0, parameter)。

参数：
parameter - 待设置的参数

get1

public static final java.lang.Object get1()
快速返回第二个参数，等价于get(1, false)。

返回：
第一个上参数

set1

public static final void set1(java.lang.Object parameter)
快速设置第二个参数，等价于set(1, parameter)。

参数：
parameter - 待设置的参数

get2

public static final java.lang.Object get2()
快速返回第三个参数，等价于get(2, false)。

返回：
第一个上参数

set2

public static final void set2(java.lang.Object parameter)
快速设置第三个参数，等价于set(2, parameter)。

参数：
parameter - 待设置的参数
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContextTL

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.common
类 ContextTL

java.lang.Object
    继承者  java.lang.ThreadLocal
        继承者  com.trs.infra.common.ContextTL

public class ContextTL
extends java.lang.ThreadLocal

Title: TRS 内容协作平台（TRS WCM）
Description:
利用ThreadLocal传递参数的具体实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContextTL()
方法摘要
void | clear()
java.lang.Object | getArg(int _nIndex) 获取扩展参数列表中第_nIndex个位置上的参数
java.util.ArrayList | getArgs() 获得用户自定义的扩展参数列表 处理逻辑： 1.
int | setArg(int _nIndex, java.lang.Object _currObj) 在扩展参数列表的第_nIndex个位置设置参数 处理逻辑：
void | setArgs(java.util.ArrayList _currArgs) 设置用户自定义的扩展参数列表 处理逻辑： 1.
从类 java.lang.ThreadLocal 继承的方法
get, remove, set
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContextTL

public ContextTL()
方法详细信息

getArgs

public java.util.ArrayList getArgs()
获得用户自定义的扩展参数列表 处理逻辑：
1. 第2个ArrayList是用户自定义的扩展参数List

返回：
如果尚未初始化，则返回NUL；否则返回ArrayList

setArgs

public void setArgs(java.util.ArrayList _currArgs)
设置用户自定义的扩展参数列表 处理逻辑：
1. 用户构造一个ArrayList，并设置好参数，然后调用该接口设置参数 2. 第2个ArrayList是用户自定义的扩展参数List

参数：
_currArgList -

getArg

public java.lang.Object getArg(int _nIndex)
获取扩展参数列表中第_nIndex个位置上的参数

参数：
_nIndex - ：参数位置，从0开始
返回：
如果没有初始化，则返回NULL；否则返回_nIndex位置上的对象

setArg

public int setArg(int _nIndex,
                  java.lang.Object _currObj)
在扩展参数列表的第_nIndex个位置设置参数 处理逻辑：

参数：
_nIndex - ：扩展参数列表中的位置，为-1表示按顺序增加变量
_currObj - ：设置的参数

clear

public void clear()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.common
类
BaseContextHelper
BaseIdsMan
ContextParameters
ContextTL
WCMRightTypes
WCMTypes
异常
WCMDatainvalidException
WCMException


com.trs.infra.common

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.common

类摘要
BaseContextHelper | Title: TRS 内容协作平台（TRS WCM） Description: 使用ThreadLocal方式在各个功能模块间传递参数的管理模块 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseIdsMan | Title: TRS 内容协作平台（TRS WCM） Description: 关联对象的处理基本管理者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ContextParameters | 为了在不改变现有接口的情况下可以向下层函数传递新增加的参数 借助TLS实现，TLS:Thread Local Storage。
ContextTL | Title: TRS 内容协作平台（TRS WCM） Description: 利用ThreadLocal传递参数的具体实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMRightTypes | Title: TRS 内容协作平台（TRS WCM） Description: 定义权限认证中权限索引常量 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTypes | Title: TRS 内容协作平台（TRS WCM） Description: 用以定义WCM中的对象类型编码常量、以及各个WCM系统中所用到的常量 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
WCMDatainvalidException | Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMException | Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.common 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.common 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.common.BaseContextHelper
    • com.trs.infra.common.BaseIdsMan
    • com.trs.infra.common.ContextParameters
    • java.lang.ThreadLocal
      • com.trs.infra.common.ContextTL
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.infra.util.CMyException
          • com.trs.infra.common.WCMException
            • com.trs.infra.common.WCMDatainvalidException
    • com.trs.infra.common.WCMRightTypes
    • com.trs.infra.common.WCMTypes


软件包 com.trs.infra.common 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.common
的使用

使用 com.trs.infra.common 的软件包
com.trs.ajaxservice |
com.trs.ajaxservice.xmlconvertors |
com.trs.cluster.receiver |
com.trs.cms.auth |
com.trs.cms.auth.domain |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.process |
com.trs.cms.process.config |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.cms.process.engine.creators |
com.trs.cms.process.engine.handlers |
com.trs.cms.process.xml |
com.trs.components.ckm |
com.trs.components.comment.domain |
com.trs.components.comment.persistent |
com.trs.components.comment.publish.helper |
com.trs.components.comment.publish.tagparser |
com.trs.components.comment.service |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.conjection.service |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.message.notify |
com.trs.components.common.publish |
com.trs.components.common.publish.config |
com.trs.components.common.publish.domain |
com.trs.components.common.publish.domain.auth |
com.trs.components.common.publish.domain.distribute |
com.trs.components.common.publish.domain.element |
com.trs.components.common.publish.domain.publisher |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.publish.widget.tagparser |
com.trs.components.common.reminder |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.filter |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.gkml.sqgk.process.element |
com.trs.components.gkml.sqgk.process.engine.creators |
com.trs.components.gkml.sqgk.process.engine.handlers |
com.trs.components.govinfo |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.config |
com.trs.components.infoview.db |
com.trs.components.infoview.extract | 抽取 MS InfoPath 的 XSN 文件的内容。
com.trs.components.infoview.helper |
com.trs.components.infoview.mad |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.infoview.process |
com.trs.components.infoview.publish.tagparser | 结合 MS InfoPath 实现的自定义表单的发布置标。
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.definition |
com.trs.components.metadata.definition.xml |
com.trs.components.metadata.publish |
com.trs.components.metadata.right |
com.trs.components.metadata.service |
com.trs.components.metadata.web |
com.trs.components.metadata.web.impl |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.auth |
com.trs.components.wcm.channel |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.domain.auth |
com.trs.components.wcm.content.domain.intelligence |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.trsserver |
com.trs.components.wcm.contentlink |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.process |
com.trs.components.wcm.process.element |
com.trs.components.wcm.process.service.flowexporter |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.domain |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.publish.tagparser.formater |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.util |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.media |
com.trs.components.wcm.wcmx.websites |
com.trs.components.web |
com.trs.components.web.document |
com.trs.db.update |
com.trs.infra |
com.trs.infra.common |
com.trs.infra.config |
com.trs.infra.config.domain |
com.trs.infra.persistent |
com.trs.infra.persistent.cache |
com.trs.infra.persistent.db |
com.trs.infra.persistent.listener |
com.trs.infra.persistent.util |
com.trs.infra.support.cache |
com.trs.infra.support.config |
com.trs.infra.support.file |
com.trs.infra.support.log |
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.infra.util |
com.trs.infra.util.database |
com.trs.infra.util.job |
com.trs.km.auth |
com.trs.presentation.common |
com.trs.presentation.documetimport.xml |
com.trs.presentation.ids |
com.trs.presentation.locale |
com.trs.presentation.login |
com.trs.presentation.nav |
com.trs.presentation.navigation |
com.trs.presentation.portal |
com.trs.presentation.publish.template |
com.trs.presentation.right |
com.trs.presentation.util |
com.trs.presentation.valid |
com.trs.presentation.wcm.content |
com.trs.scene.parser |
com.trs.scene.tools |
com.trs.service |
com.trs.service.impl |
com.trs.template.domain |
com.trs.template.domain.setting |
com.trs.template.service.impl |
com.trs.upgrade |
com.trs.util |
com.trs.wcm.config |
com.trs.wcm.customize |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |
com.trs.wcm.photo.publish |
com.trs.wcmonline |
com.trs.webframework.config |
com.trs.webframework.controler |
com.trs.webframework.provider |
com.trsupdate |
com.wcm.pdf |

com.trs.ajaxservice 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.ajaxservice.xmlconvertors 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cluster.receiver 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.domain 使用的 com.trs.infra.common 中的类
BaseIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
关联对象的处理基本管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.content 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.config 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine.creators 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine.handlers 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.xml 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.comment.domain 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.comment.persistent 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.comment.publish.helper 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.comment.publish.tagparser 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.comment.service 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.address 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.bookmark 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.calendar 使用的 com.trs.infra.common 中的类
BaseIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
关联对象的处理基本管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.conjection.persistent 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.conjection.service 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message.notify 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.config 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.auth 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.element 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.publisher 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.tagparser 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.taskdispatch 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.template 使用的 com.trs.infra.common 中的类
BaseIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
关联对象的处理基本管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.distribute 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.element 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.publisher 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.taskdispatch 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.template 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget.tagparser 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.reminder 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.trsad 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.trsvote 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.filter 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.persistent 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.engine.creators 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.gkml.sqgk.process.engine.handlers 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.govinfo 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.config 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.db 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.extract 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.helper 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.mad 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.persistent 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.process 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.publish.tagparser 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.center 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.center.xml 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition.xml 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.publish 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.right 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.web 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.web.impl 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.special 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.auth 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.channel 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.infra.common 中的类
BaseIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
关联对象的处理基本管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain.auth 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain.intelligence 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.trsserver 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.contentlink 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.customize 使用的 com.trs.infra.common 中的类
BaseIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
关联对象的处理基本管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.individuation 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process.element 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process.service.flowexporter 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.domain 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.element 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.logo 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.tagparser.formater 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.recent 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.resource 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.stat 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.util 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.help 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.media 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.websites 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.web 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.web.document 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.db.update 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.common 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config.domain 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.util 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.file 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.log 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.security 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.database 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.job 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.km.auth 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.common 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.documetimport.xml 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.ids 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.locale 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.login 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.nav 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.navigation 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.portal 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.publish.template 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.right 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.util 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.valid 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.wcm.content 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.scene.parser 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.scene.tools 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service.impl 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.template.domain 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.template.domain.setting 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.template.service.impl 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.upgrade 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.util 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.config 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.customize 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.old 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo.impl 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo.publish 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcmonline 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.config 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.controler 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trsupdate 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.wcm.pdf 使用的 com.trs.infra.common 中的类
WCMException
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMDatainvalidException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.common
类 WCMDatainvalidException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.infra.util.CMyException
                继承者  com.trs.infra.common.WCMException
                    继承者  com.trs.infra.common.WCMDatainvalidException
所有已实现的接口：
java.io.Serializable
public class WCMDatainvalidException
extends WCMException

Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
WCMDatainvalidException(int _errNo)
WCMDatainvalidException(int _errNo, java.lang.String _sMsg)
WCMDatainvalidException(int _errNo, java.lang.String _sMsg, java.lang.Throwable _rootCause)
WCMDatainvalidException(java.lang.String _sMsg)
WCMDatainvalidException(java.lang.String _sMsg, java.lang.Throwable _rootCause)
方法摘要
从类 com.trs.infra.common.WCMException 继承的方法
catchException
从类 com.trs.infra.util.CMyException 继承的方法
getErrNo, getErrNoMsg, getLocalizedMessage, getMessage, getMyMessage, getRootCause, getStackTraceText, getStackTraceText, main, printStackTrace, printStackTrace, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getStackTrace, initCause, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

WCMDatainvalidException

public WCMDatainvalidException(int _errNo)
参数：
_errNo -

WCMDatainvalidException

public WCMDatainvalidException(int _errNo,
                               java.lang.String _sMsg)
参数：
_errNo -
_sMsg -

WCMDatainvalidException

public WCMDatainvalidException(java.lang.String _sMsg)
参数：
_sMsg -

WCMDatainvalidException

public WCMDatainvalidException(int _errNo,
                               java.lang.String _sMsg,
                               java.lang.Throwable _rootCause)
参数：
_errNo -
_sMsg -
_rootCause -

WCMDatainvalidException

public WCMDatainvalidException(java.lang.String _sMsg,
                               java.lang.Throwable _rootCause)
参数：
_sMsg -
_rootCause -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.common
类 WCMException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.infra.util.CMyException
                继承者  com.trs.infra.common.WCMException
所有已实现的接口：
java.io.Serializable
直接已知子类：
OrignHomePublishException, WCMDatainvalidException
public class WCMException
extends CMyException

Title: TRS 内容协作平台（TRS WCM）

Description:

WCM异常处理对象

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
WCMException(int _errNo)
WCMException(int _errNo, java.lang.String _sMsg)
WCMException(int _errNo, java.lang.String _sMsg, java.lang.Throwable _rootCause)
构造函数
WCMException(java.lang.String _sMsg)
WCMException(java.lang.String _sMsg, java.lang.Throwable _rootCause)
构造函数
方法摘要
static void catchException(java.lang.String _strDesc, java.lang.Exception _exCaught, boolean bSeverity)
从类 com.trs.infra.util.CMyException 继承的方法
getErrNo, getErrNoMsg, getLocalizedMessage, getMessage, getMyMessage, getRootCause, getStackTraceText, getStackTraceText, main, printStackTrace, printStackTrace, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getStackTrace, initCause, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

WCMException

public WCMException(int _errNo)

WCMException

public WCMException(int _errNo,
                    java.lang.String _sMsg)

WCMException

public WCMException(java.lang.String _sMsg)

WCMException

public WCMException(int _errNo,
                    java.lang.String _sMsg,
                    java.lang.Throwable _rootCause)
构造函数

参数：
_errNo - 错误编号（int）
_sMsg - 错误信息（String）可忽略
_rootCause - 错误根源（Throwable）可忽略

WCMException

public WCMException(java.lang.String _sMsg,
                    java.lang.Throwable _rootCause)
构造函数

参数：
_sMsg - 错误信息（String）可忽略
_rootCause - 错误根源（Throwable）可忽略
方法详细信息

catchException

public static void catchException(java.lang.String _strDesc,
                                  java.lang.Exception _exCaught,
                                  boolean bSeverity)
                           throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMRightTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.common
类 WCMRightTypes

java.lang.Object
    继承者  com.trs.infra.common.WCMRightTypes

public class WCMRightTypes
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）

Description:

定义权限认证中权限索引常量

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | ALL_BYPASS 不进行权限校验的索引值
static int | BT_DATA_EDIT 表单数据项的修改（包括删除）权限
static int | BT_DATA_FILL 表单数据项的填写权限
static int | BT_DATA_VIEW 表单数据项的查看权限
static int | CHNL_ADD 添加频道
static int | CHNL_BROWSE 浏览频道
static int | CHNL_DEL 删除频道
static int | CHNL_EDIT 修改频道
static int | CHNL_EXTEND 扩展字段
static int | CHNL_MAX_INDEX 频道权限index最大值
static int | CHNL_MIN_INDEX 频道权限Index最小值
static int | CHNL_MOVE 移动频道
static int | CHNL_PREVIEW 预览频道首页
static int | CHNL_PUB_ALL 完全发布频道
static int | CHNL_PUB_INC 增量发布频道 *
static int | CHNL_RECYCLE 废稿管理
static int | CHNL_SETRIGHT 设置频道的权限
static int | CHNL_SETTEMPLATE 设置频道的模板
static int | DOC_ADD 添加文档
static int | DOC_AGAIN 否定、要求返工文档
static int | DOC_BROWSE 查看细览
static int | DOC_COPY 复制文档
static int | DOC_COPY_ALL
static int | DOC_DEL 删除文档
static int | DOC_DELALL 删除全部文档
static int | DOC_EDIT 修改文档
static int | DOC_MAX_INDEX 文档权限index最大值
static int | DOC_MIN_INDEX 文档权限Index最小值
static int | DOC_MIRROR 镜像转发文档
static int | DOC_MOVE 移动文档
static int | DOC_NEWEDIT
static int | DOC_OUTLINE 浏览文档
static int | DOC_POSITIONSET 调整顺序
static int | DOC_PREVIEW 预览文档
static int | DOC_PUBLISH 发布文档
static int | DOC_QUOTE 引用转发文档
static int | DOC_RESTORE 恢复文档
static int | DOC_RIGTH_SET 设置文档权限
static int | DOC_SAVE 改变文档的状态为新稿、已编
static int | DOC_SIGN 签发文档
static int | EXT_ADMANAGE 广告管理
static int | EXT_APTITUDE 智能信息处理
static int | EXT_COMMENT 在线评论权限
static int | EXT_GOVREFER_DEPT 处理部门的咨询和信访
static int | EXT_GOVREFER_SITE 处理全站的咨询和信访
static int | EXT_INFOGATE 数据网关的权限
static int | EXT_INFOVIEW_MGR ge add by gfc @2008-4-10 下午08:38:06 表单管理 TODO 暂时没有空余的权限位，所以只能和信访重合，但基本上可以确定这两个东东不会放在一块使用
static int | EXT_INTERVIEW 嘉宾访谈的权限
static int | EXT_INVESTMENT 问卷调查管理
static int | EXT_MAX_INDEX 扩展功能最大权限值
static int | EXT_MIN_INDEX 扩展功能最小权限值
static int | EXT_SUBSCRIBE 邮件订阅的权限
static int | FLOW_ADD 添加工作流
static int | FLOW_DEL 删除工作流
static int | FLOW_EDIT 修改工作流
static int | FLOW_EXPORT 导出工作流
static int | FLOW_IMPORT 导入工作流
static int | FLOW_MAX_INDEX 工作流权限index最大值
static int | FLOW_MIN_INDEX 工作流权限Index最小值
static int | FLOW_MON 工作流监控
static int | FLOW_SETRIGHT
static int | FLOW_STAT 工作流统计
static int | GROUP_ADD_USER 添加用户的权限
static int | GROUP_DEL 删除组织的权限
static int | GROUP_DEL_USER 删除用户的权限
static int | GROUP_SAVE 保存组织的权限
static int[] | NOT_OPER_CHNL 记录非普通频道禁止的操作
static int | OBJ_ACCESS “访问”对象的权限
static int[] | RIGHT_INDEXS_WORKFLOW 工作流权限列表
static long | RIGHTVALUE_WHEN_NOT_EXISTS
static int | ROLE_ADD_USER 添加用户
static int | ROLE_DEL 删除角色的权限
static int | ROLE_DEL_USER 删除用户
static int | ROLE_SAVE 保存角色的权限
static int[] | SET_FLOW_EMPLOY_RIGHTS
static int | SITE_ADD 添加站点
static int | SITE_ADD_USER 设定站点用户
static int | SITE_DEL 删除站点
static int | SITE_EDIT 修改站点
static int | SITE_MAX_INDEX 站点权限index最大值
static int | SITE_MIN_INDEX 站点权限Index最小值
static int | SITE_PREVIEW 预览站点首页
static int | SITE_PUB_ALL 完全发布站点
static int | SITE_PUB_INC 增量发布站点
static int | Site_SETRIGHT 设置站点的权限
static int | SITE_SETTEMPLATE 设置站点的模板
static int | STATISTIC_MAX_INDEX 统计分析最大权限值
static int | STATISTIC_MIN_INDEX 统计分析最小权限值
static int | SYS_CONTENTLINK 管理热词和热词分类*
static int | SYS_DOCSOURCE 维护文档来源*
static int | SYS_DOCSTATUS 维护文档状态*
static int | SYS_EVENTTYPE 管理日程事件类型*
static int | SYS_MAX_INDEX 最大系统属性权限*
static int | SYS_MIN_INDEX 最小系统属性权限*
static int | SYS_OPERTYPE 管理操作类型*
static int | SYS_RIGHT_SET 给对象设置权限
static int | SYS_RIGHTDEF 管理权限定义*
static int | SYS_SECURITY 管理安全级别*
static int | SYS_STATISTIC 统计分析权限
static int | SYS_WCMBEAN 管理发布组件*
static int | TEMPLATE_ADD 添加模板
static int | TEMPLATE_BACKUP 备份模板
static int | TEMPLATE_CHECK 校验模板
static int | TEMPLATE_DEL 删除模板
static int | TEMPLATE_EDIT 修改模板
static int | TEMPLATE_EXPORT 导出模板
static int | TEMPLATE_IMPORT 导入模板
static int | TEMPLATE_MAX_INDEX 模板权限index最大值
static int | TEMPLATE_MIN_INDEX 模板权限Index最小值
static int | TEMPLATE_OUTLINE 查看模板列表
static int | TEMPLATE_PREVIEW 预览模板
static int | TEMPLATE_SAVE 模板保存
static int | TEMPLATE_SETARGS 管理模板变量
static int | TEMPLATE_SYN_APPENDIX 同步模板附件
static int | TEMPLATE_VIEW 查看模板
static int | USER_DEL 删除用户的权限
static int | USER_SAVE 保存用户的权限
static long | VALUE_ONLY_BROWSER 仅仅只是设置了浏览的权限
构造方法摘要
WCMRightTypes()
方法摘要
static int | getExtMaxIndex() 返回扩展功能最大权限值 为什么增加这个方法，而不是直接使用常量EXT_MAX_INDEX？
static int | getExtMinIndex() 返回扩展功能最小权限值 为什么增加这个方法，而不是直接使用常量EXT_MIN_INDEX？
static int[] | getRemoveRightIndexs()
static int | getStatisticMaxIndex() 返回统计分析最大权限值 为什么增加这个方法，而不是直接使用常量EXT_MAX_INDEX？
static int | getStatisticMinIndex() 返回统计分析最小权限值 为什么增加这个方法，而不是直接使用常量EXT_MIN_INDEX？
static int | getSysMaxIndex() 返回扩展功能最大权限值 为什么增加这个方法，而不是直接使用常量SYS_MAX_INDEX？
static int | getSysMinIndex() 返回扩展功能最小权限值 为什么增加这个方法，而不是直接使用常量SYS_MIN_INDEX？
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ALL_BYPASS

public static final int ALL_BYPASS
不进行权限校验的索引值

另请参见：
常量字段值

OBJ_ACCESS

public static final int OBJ_ACCESS
“访问”对象的权限

另请参见：
常量字段值

SITE_MAX_INDEX

public static final int SITE_MAX_INDEX
站点权限index最大值

另请参见：
常量字段值

SITE_MIN_INDEX

public static final int SITE_MIN_INDEX
站点权限Index最小值

另请参见：
常量字段值

SITE_ADD

public static final int SITE_ADD
添加站点

另请参见：
常量字段值

SITE_EDIT

public static final int SITE_EDIT
修改站点

另请参见：
常量字段值

SITE_DEL

public static final int SITE_DEL
删除站点

另请参见：
常量字段值

SITE_PREVIEW

public static final int SITE_PREVIEW
预览站点首页

另请参见：
常量字段值

SITE_PUB_ALL

public static final int SITE_PUB_ALL
完全发布站点

另请参见：
常量字段值

SITE_PUB_INC

public static final int SITE_PUB_INC
增量发布站点

另请参见：
常量字段值

SITE_ADD_USER

public static final int SITE_ADD_USER
设定站点用户

另请参见：
常量字段值

Site_SETRIGHT

public static final int Site_SETRIGHT
设置站点的权限

另请参见：
常量字段值

SITE_SETTEMPLATE

public static final int SITE_SETTEMPLATE
设置站点的模板

另请参见：
常量字段值

CHNL_MAX_INDEX

public static final int CHNL_MAX_INDEX
频道权限index最大值

另请参见：
常量字段值

CHNL_MIN_INDEX

public static final int CHNL_MIN_INDEX
频道权限Index最小值

另请参见：
常量字段值

CHNL_ADD

public static final int CHNL_ADD
添加频道

另请参见：
常量字段值

CHNL_DEL

public static final int CHNL_DEL
删除频道

另请参见：
常量字段值

CHNL_EDIT

public static final int CHNL_EDIT
修改频道

另请参见：
常量字段值

CHNL_BROWSE

public static final int CHNL_BROWSE
浏览频道

另请参见：
常量字段值

CHNL_PREVIEW

public static final int CHNL_PREVIEW
预览频道首页

另请参见：
常量字段值

CHNL_PUB_ALL

public static final int CHNL_PUB_ALL
完全发布频道

另请参见：
常量字段值

CHNL_PUB_INC

public static final int CHNL_PUB_INC
增量发布频道 *

另请参见：
常量字段值

CHNL_RECYCLE

public static final int CHNL_RECYCLE
废稿管理

另请参见：
常量字段值

CHNL_EXTEND

public static final int CHNL_EXTEND
扩展字段

另请参见：
常量字段值

CHNL_MOVE

public static final int CHNL_MOVE
移动频道

另请参见：
常量字段值

CHNL_SETRIGHT

public static final int CHNL_SETRIGHT
设置频道的权限

另请参见：
常量字段值

CHNL_SETTEMPLATE

public static final int CHNL_SETTEMPLATE
设置频道的模板

另请参见：
常量字段值

TEMPLATE_MAX_INDEX

public static final int TEMPLATE_MAX_INDEX
模板权限index最大值

另请参见：
常量字段值

TEMPLATE_MIN_INDEX

public static final int TEMPLATE_MIN_INDEX
模板权限Index最小值

另请参见：
常量字段值

TEMPLATE_OUTLINE

public static final int TEMPLATE_OUTLINE
查看模板列表

另请参见：
常量字段值

TEMPLATE_CHECK

public static final int TEMPLATE_CHECK
校验模板

另请参见：
常量字段值

TEMPLATE_SAVE

public static final int TEMPLATE_SAVE
模板保存

另请参见：
常量字段值

TEMPLATE_SETARGS

public static final int TEMPLATE_SETARGS
管理模板变量

另请参见：
常量字段值

TEMPLATE_ADD

public static final int TEMPLATE_ADD
添加模板

另请参见：
常量字段值

TEMPLATE_DEL

public static final int TEMPLATE_DEL
删除模板

另请参见：
常量字段值

TEMPLATE_EDIT

public static final int TEMPLATE_EDIT
修改模板

另请参见：
常量字段值

TEMPLATE_VIEW

public static final int TEMPLATE_VIEW
查看模板

另请参见：
常量字段值

TEMPLATE_IMPORT

public static final int TEMPLATE_IMPORT
导入模板

另请参见：
常量字段值

TEMPLATE_EXPORT

public static final int TEMPLATE_EXPORT
导出模板

另请参见：
常量字段值

TEMPLATE_BACKUP

public static final int TEMPLATE_BACKUP
备份模板

另请参见：
常量字段值

TEMPLATE_SYN_APPENDIX

public static final int TEMPLATE_SYN_APPENDIX
同步模板附件

另请参见：
常量字段值

TEMPLATE_PREVIEW

public static final int TEMPLATE_PREVIEW
预览模板

另请参见：
常量字段值

DOC_MAX_INDEX

public static final int DOC_MAX_INDEX
文档权限index最大值

另请参见：
常量字段值

DOC_MIN_INDEX

public static final int DOC_MIN_INDEX
文档权限Index最小值

另请参见：
常量字段值

DOC_OUTLINE

public static final int DOC_OUTLINE
浏览文档

另请参见：
常量字段值

DOC_ADD

public static final int DOC_ADD
添加文档

另请参见：
常量字段值

DOC_EDIT

public static final int DOC_EDIT
修改文档

另请参见：
常量字段值

DOC_DEL

public static final int DOC_DEL
删除文档

另请参见：
常量字段值

DOC_DELALL

public static final int DOC_DELALL
删除全部文档

另请参见：
常量字段值

DOC_POSITIONSET

public static final int DOC_POSITIONSET
调整顺序

另请参见：
常量字段值

DOC_BROWSE

public static final int DOC_BROWSE
查看细览

另请参见：
常量字段值

DOC_RIGTH_SET

public static final int DOC_RIGTH_SET
设置文档权限

另请参见：
常量字段值

DOC_SAVE

public static final int DOC_SAVE
改变文档的状态为新稿、已编

另请参见：
常量字段值

DOC_NEWEDIT

public static final int DOC_NEWEDIT
另请参见：
常量字段值

DOC_AGAIN

public static final int DOC_AGAIN
否定、要求返工文档

另请参见：
常量字段值

DOC_SIGN

public static final int DOC_SIGN
签发文档

另请参见：
常量字段值

DOC_PREVIEW

public static final int DOC_PREVIEW
预览文档

另请参见：
常量字段值

DOC_PUBLISH

public static final int DOC_PUBLISH
发布文档

另请参见：
常量字段值

DOC_COPY

public static final int DOC_COPY
复制文档

另请参见：
常量字段值

DOC_COPY_ALL

public static final int DOC_COPY_ALL
另请参见：
常量字段值

DOC_QUOTE

public static final int DOC_QUOTE
引用转发文档

另请参见：
常量字段值

DOC_MIRROR

public static final int DOC_MIRROR
镜像转发文档

另请参见：
常量字段值

DOC_RESTORE

public static final int DOC_RESTORE
恢复文档

另请参见：
常量字段值

FLOW_MAX_INDEX

public static final int FLOW_MAX_INDEX
工作流权限index最大值

另请参见：
常量字段值

FLOW_MIN_INDEX

public static final int FLOW_MIN_INDEX
工作流权限Index最小值

另请参见：
常量字段值

FLOW_ADD

public static final int FLOW_ADD
添加工作流

另请参见：
常量字段值

FLOW_EDIT

public static final int FLOW_EDIT
修改工作流

另请参见：
常量字段值

FLOW_DEL

public static final int FLOW_DEL
删除工作流

另请参见：
常量字段值

FLOW_EXPORT

public static final int FLOW_EXPORT
导出工作流

另请参见：
常量字段值

FLOW_IMPORT

public static final int FLOW_IMPORT
导入工作流

另请参见：
常量字段值

FLOW_MON

public static final int FLOW_MON
工作流监控

另请参见：
常量字段值

FLOW_STAT

public static final int FLOW_STAT
工作流统计

另请参见：
常量字段值

FLOW_SETRIGHT

public static final int FLOW_SETRIGHT
另请参见：
常量字段值

RIGHT_INDEXS_WORKFLOW

public static final int[] RIGHT_INDEXS_WORKFLOW
工作流权限列表

USER_SAVE

public static final int USER_SAVE
保存用户的权限

另请参见：
常量字段值

USER_DEL

public static final int USER_DEL
删除用户的权限

另请参见：
常量字段值

GROUP_SAVE

public static final int GROUP_SAVE
保存组织的权限

另请参见：
常量字段值

GROUP_DEL

public static final int GROUP_DEL
删除组织的权限

另请参见：
常量字段值

GROUP_ADD_USER

public static final int GROUP_ADD_USER
添加用户的权限

另请参见：
常量字段值

GROUP_DEL_USER

public static final int GROUP_DEL_USER
删除用户的权限

另请参见：
常量字段值

ROLE_SAVE

public static final int ROLE_SAVE
保存角色的权限

另请参见：
常量字段值

ROLE_DEL

public static final int ROLE_DEL
删除角色的权限

另请参见：
常量字段值

ROLE_ADD_USER

public static final int ROLE_ADD_USER
添加用户

另请参见：
常量字段值

ROLE_DEL_USER

public static final int ROLE_DEL_USER
删除用户

另请参见：
常量字段值

DOC_MOVE

public static final int DOC_MOVE
移动文档

另请参见：
常量字段值

SYS_DOCSOURCE

public static final int SYS_DOCSOURCE
维护文档来源*

另请参见：
常量字段值

SYS_DOCSTATUS

public static final int SYS_DOCSTATUS
维护文档状态*

另请参见：
常量字段值

SYS_WCMBEAN

public static final int SYS_WCMBEAN
管理发布组件*

另请参见：
常量字段值

SYS_EVENTTYPE

public static final int SYS_EVENTTYPE
管理日程事件类型*

另请参见：
常量字段值

SYS_SECURITY

public static final int SYS_SECURITY
管理安全级别*

另请参见：
常量字段值

SYS_RIGHTDEF

public static final int SYS_RIGHTDEF
管理权限定义*

另请参见：
常量字段值

SYS_OPERTYPE

public static final int SYS_OPERTYPE
管理操作类型*

另请参见：
常量字段值

SYS_CONTENTLINK

public static final int SYS_CONTENTLINK
管理热词和热词分类*

另请参见：
常量字段值

SYS_MIN_INDEX

public static final int SYS_MIN_INDEX
最小系统属性权限*

另请参见：
常量字段值

SYS_MAX_INDEX

public static final int SYS_MAX_INDEX
最大系统属性权限*

另请参见：
常量字段值

EXT_MIN_INDEX

public static final int EXT_MIN_INDEX
扩展功能最小权限值

另请参见：
常量字段值

EXT_COMMENT

public static final int EXT_COMMENT
在线评论权限

另请参见：
常量字段值

EXT_INVESTMENT

public static final int EXT_INVESTMENT
问卷调查管理

另请参见：
常量字段值

EXT_ADMANAGE

public static final int EXT_ADMANAGE
广告管理

另请参见：
常量字段值

EXT_APTITUDE

public static final int EXT_APTITUDE
智能信息处理

另请参见：
常量字段值

EXT_GOVREFER_SITE

public static final int EXT_GOVREFER_SITE
处理全站的咨询和信访

另请参见：
常量字段值

EXT_GOVREFER_DEPT

public static final int EXT_GOVREFER_DEPT
处理部门的咨询和信访

另请参见：
常量字段值

EXT_INFOGATE

public static final int EXT_INFOGATE
数据网关的权限

另请参见：
常量字段值

EXT_SUBSCRIBE

public static final int EXT_SUBSCRIBE
邮件订阅的权限

另请参见：
常量字段值

EXT_INTERVIEW

public static final int EXT_INTERVIEW
嘉宾访谈的权限

另请参见：
常量字段值

EXT_INFOVIEW_MGR

public static final int EXT_INFOVIEW_MGR
ge add by gfc @2008-4-10 下午08:38:06 表单管理 TODO 暂时没有空余的权限位，所以只能和信访重合，但基本上可以确定这两个东东不会放在一块使用

另请参见：
常量字段值

EXT_MAX_INDEX

public static final int EXT_MAX_INDEX
扩展功能最大权限值

另请参见：
常量字段值

SYS_RIGHT_SET

public static final int SYS_RIGHT_SET
给对象设置权限

另请参见：
常量字段值

STATISTIC_MIN_INDEX

public static final int STATISTIC_MIN_INDEX
统计分析最小权限值

另请参见：
常量字段值

SYS_STATISTIC

public static final int SYS_STATISTIC
统计分析权限

另请参见：
常量字段值

STATISTIC_MAX_INDEX

public static final int STATISTIC_MAX_INDEX
统计分析最大权限值

另请参见：
常量字段值

BT_DATA_VIEW

public static final int BT_DATA_VIEW
表单数据项的查看权限

另请参见：
常量字段值

BT_DATA_FILL

public static final int BT_DATA_FILL
表单数据项的填写权限

另请参见：
常量字段值

BT_DATA_EDIT

public static final int BT_DATA_EDIT
表单数据项的修改（包括删除）权限

另请参见：
常量字段值

VALUE_ONLY_BROWSER

public static final long VALUE_ONLY_BROWSER
仅仅只是设置了浏览的权限

RIGHTVALUE_WHEN_NOT_EXISTS

public static final long RIGHTVALUE_WHEN_NOT_EXISTS
另请参见：
常量字段值

NOT_OPER_CHNL

public static final int[] NOT_OPER_CHNL
记录非普通频道禁止的操作

SET_FLOW_EMPLOY_RIGHTS

public static int[] SET_FLOW_EMPLOY_RIGHTS
构造方法详细信息

WCMRightTypes

public WCMRightTypes()
方法详细信息

getExtMaxIndex

public static final int getExtMaxIndex()
返回扩展功能最大权限值 为什么增加这个方法，而不是直接使用常量EXT_MAX_INDEX？ 因为如果直接使用“final static”的常量，在编译jsp时会被inline化， 即便以后修改该常量的值，已经编译的jsp也不会看到这种变化。

返回：
扩展功能最大权限值

getExtMinIndex

public static final int getExtMinIndex()
返回扩展功能最小权限值 为什么增加这个方法，而不是直接使用常量EXT_MIN_INDEX？ 因为如果直接使用“final static”的常量，在编译jsp时会被inline化， 即便以后修改该常量的值，已经编译的jsp也不会看到这种变化。

返回：
扩展功能最小权限值

getStatisticMaxIndex

public static final int getStatisticMaxIndex()
返回统计分析最大权限值 为什么增加这个方法，而不是直接使用常量EXT_MAX_INDEX？ 因为如果直接使用“final static”的常量，在编译jsp时会被inline化， 即便以后修改该常量的值，已经编译的jsp也不会看到这种变化。

返回：
扩展功能最大权限值

getStatisticMinIndex

public static final int getStatisticMinIndex()
返回统计分析最小权限值 为什么增加这个方法，而不是直接使用常量EXT_MIN_INDEX？ 因为如果直接使用“final static”的常量，在编译jsp时会被inline化， 即便以后修改该常量的值，已经编译的jsp也不会看到这种变化。

返回：
扩展功能最小权限值

getSysMaxIndex

public static final int getSysMaxIndex()
返回扩展功能最大权限值 为什么增加这个方法，而不是直接使用常量SYS_MAX_INDEX？ 因为如果直接使用“final static”的常量，在编译jsp时会被inline化， 即便以后修改该常量的值，已经编译的jsp也不会看到这种变化。

返回：
扩展功能最大权限值

getSysMinIndex

public static final int getSysMinIndex()
返回扩展功能最小权限值 为什么增加这个方法，而不是直接使用常量SYS_MIN_INDEX？ 因为如果直接使用“final static”的常量，在编译jsp时会被inline化， 即便以后修改该常量的值，已经编译的jsp也不会看到这种变化。

返回：
扩展功能最小权限值

main

public static void main(java.lang.String[] args)

getRemoveRightIndexs

public static int[] getRemoveRightIndexs()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMTypes

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.common
类 WCMTypes

java.lang.Object
    继承者  com.trs.infra.common.WCMTypes

public class WCMTypes
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）

Description:

用以定义WCM中的对象类型编码常量、以及各个WCM系统中所用到的常量

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | LOG_EXCEPTION 操作异常日志
static int | LOG_FLOW 工作流日志
static int | LOG_JOB Jobserver日志
static int | LOG_OTHER 其他应用日志
static int | LOG_PUB 发布日志
static int | LOG_SCHEDULE_PUB
static int | LOG_SECURITY 安全日志
static int | LOG_SYSTEM 系统日志
static int | LOG_UNKOWN
static int | MESSAGE_RECEIVED 已接收短消息
static int | MESSAGE_SENT 已发送短消息
static int | MESSAGE_UNREAD 未读短消息
static int | NO WCM逻辑值常量，布尔假值
static int | OBJ_ADDRESS
static int | OBJ_ADDRESSGRP
static int | OBJ_APPENDIX
static int | OBJ_BIGTABLE WCM自定义的表单信息
static int | OBJ_BIGTABLEFIELD WCM自定义的表单中的字段信息
static int | OBJ_BIGTABLEMPLOY WCM自定义的表单中的使用信息
static int | OBJ_BOOKMARK
static int | OBJ_BULLETIN
static int | OBJ_CHANNEL
static int | OBJ_CHANNELSYN
static int | OBJ_CHNLDOC 记录文档逻辑信息对象*
static int | OBJ_CONDITIONBEAN 工作流条件系统配置对象
static int | OBJ_CONFIG
static int | OBJ_CONTACT
static int | OBJ_CONTACTGRP
static int | OBJ_CONTENTLINK
static int | OBJ_DOCBAK
static int | OBJ_DOCKIND
static int | OBJ_DOCREPLY
static int | OBJ_DOCUMENT
static int | OBJ_EVENT
static int | OBJ_EVENTTYPE
static int | OBJ_EXPIRATION
static int | OBJ_EXTENDEDFIELD
static int | OBJ_EXTFIELD
static int | OBJ_FIELDINFO
static int | OBJ_FILETYPE
static int | OBJ_FLOW
static int | OBJ_FLOWACTION
static int | OBJ_FLOWDOC 工作流流转情况对象
static int | OBJ_FLOWDOCBAK 工作流流转情况对象
static int | OBJ_FLOWEMPLOYBEAN 工作流配置关系
static int | OBJ_FLOWEVENTCONDITION 工作流节点事件条件对象
static int | OBJ_FLOWEVENTOPERATE 工作流节点事件执行对象
static int | OBJ_FLOWNODE
static int | OBJ_FLOWNODEBRANCH
static int | OBJ_FLOWNODEEVENT 工作流节点事件对象
static int | OBJ_GROUP
static int | OBJ_HITSCOUNT
static int | OBJ_INFOVIEW 结合 MS InfoPath 实现的自定义表单
static int | OBJ_INFOVIEWEMPLOY 结合 MS InfoPath 实现的自定义表单的雇佣关系（被频道使用）
static int | OBJ_INFOVIEWFIELD 结合 MS InfoPath 实现的自定义表单的数据项（字段）
static int | OBJ_INFOVIEWGROUP 结合 MS InfoPath 实现的自定义表单的数据区块（Section or Table）
static int | OBJ_INFOVIEWVIEW 结合 MS InfoPath 实现的自定义表单的视图
static int | OBJ_JOB
static int | OBJ_LOG
static int | OBJ_LOGTYPE
static int | OBJ_MARKKIND
static int | OBJ_MARKSHARE
static int | OBJ_MEETINGCONT
static int | OBJ_MEETINGROOM
static int | OBJ_MEETINGUSER
static int | OBJ_MESSAGE
static int | OBJ_MSGQUEUE
static int | OBJ_OPERATIONBEAN 工作流执行系统配置对象
static int | OBJ_OPERTYPE
static int | OBJ_OTHER 未定义的其他类型
static int | OBJ_PUBLISHDISTRIBUTION
static int | OBJ_RECENT
static int | OBJ_REGIONCELL
static int | OBJ_REGIONINFO
static int | OBJ_RELATION
static int | OBJ_REPLACE
static int | OBJ_RIGHT
static int | OBJ_RIGHTDEF
static int | OBJ_ROLE
static int | OBJ_SCHEDULE
static int | OBJ_SECURITY
static int | OBJ_SOURCE
static int | OBJ_STATUS
static int | OBJ_TABLEINFO
static int | OBJ_TASK
static int | OBJ_TASKPOOL
static int | OBJ_TRUSTEEINFO
static int | OBJ_UNKNOWN 未知类型
static int | OBJ_USER
static int | OBJ_USERDEF 用户自定义对象的起始值
static int | OBJ_USERSETTING
static int | OBJ_WCMEXCELDATA
static int | OBJ_WCMFORMFIELDS WCM自定义的表单中的字段信息 (old)
static int | OBJ_WCMFORMINFO WCM自定义的表单信息 (old)
static int | OBJ_WCMID
static int | OBJ_WCMOBJTRIGGER 管理WCMObj触发器的对象 *
static int | OBJ_WCMRESULTSET WCMRESULTSET对象类型
static int | OBJ_WEBSITE
static int | OPER_CHNL_ADD 添加频道
static int | OPER_CHNL_DEL 彻底删除频道
static int | OPER_CHNL_EDIT 修改频道
static int | OPER_CHNL_PUB 发布频道
static int | OPER_CHNL_RECYCLE 假删除频道
static int | OPER_CHNL_RESCOVER 恢复频道
static int | OPER_DOC_ADD 添加文档
static int | OPER_DOC_DEL 删除文档
static int | OPER_DOC_EDIT 修改文档
static int | OPER_DOC_PUB 发布文档
static int | OPER_FLOW_ADD 添加工作流
static int | OPER_FLOW_DEL 删除工作流
static int | OPER_FLOW_EDIT 修改工作流
static int | OPER_OTHER 未定义的其他操作类型
static int | OPER_SCHEDULE_PUB
static int | OPER_SITE_ADD 添加站点
static int | OPER_SITE_DEL 测定删除站点
static int | OPER_SITE_EDIT 修改站点
static int | OPER_SITE_PUB 发布站点
static int | OPER_SITE_RECYCLE 假删除站点
static int | OPER_SITE_RESCOVER 恢复站点
static int | OPER_SYSTEM_SET 修改系统配置
static int | OPER_SYSTEM_WARN Comment for OPER_SYSTEM_WARN 系统警告
static int | OPER_TEMPLATE_ADD 添加模板
static int | OPER_TEMPLATE_DEL 删除模板
static int | OPER_TEMPLATE_EDIT 修改模板
static int | OPER_UNKOWN 未知类型
static int | OPER_USER_DEFINE 用户指定义的操作类型起始值
static int | OPER_USER_LOGIN 用户登录
static int | OPER_USER_LOGOUT 用户退出
static int | PUBLISH_CHILD_NEED
static int | PUBLISH_NOT_NEED
static int | PUBLISH_SELF_NEED
static int | REMIND_BYEMAIL WCM提醒类别：Email提醒
static int | REMIND_BYMOBILE WCM提醒类别：手机提醒
static int | REMIND_DONE 有关提醒设置：已经完成提醒
static int | REMIND_NO 有关提醒设置：不提醒
static int | REMIND_ONLINE WCM提醒类别：在线提醒
static int | REMIND_YES 有关提醒设置：提醒
static int | TEMPLATE_COLUMN_TAG
static int | TEMPLATE_DEAL_MODE_CHANGE
static int | TEMPLATE_DEAL_MODE_IGNORE
static int | TEMPLATE_DEAL_MODE_QUIT
static int | TEMPLATE_DEAL_MODE_UPDATE
static int | TEMPLATE_OUTLINE_TAG
static int | TEMPLATE_RECORD_TAG
static int | TEMPLATEAPD_DEAL_MODE_CHANGE
static int | TEMPLATEAPD_DEAL_MODE_IGNORE
static int | TEMPLATEAPD_DEAL_MODE_QUIT
static int | TEMPLATEAPD_DEAL_MODE_UPDATE
static int | XML_IMPORT_NEW XML导入类型，从XML导入新的对象
static int | XML_IMPORT_RESTORE XML导入类型，从XML导入数据，恢复对象（若没有对象则创建，否则修改）
static int | XML_IMPORT_UPDATE XML导入类型，从XML导入数据，修改对象
static int | YES WCM逻辑值常量，布尔真值
构造方法摘要
WCMTypes()
方法摘要
static java.lang.String | getLowerObjName(int _objType)
static java.lang.String | getLowerSynName(boolean _sIsTarget)
static java.lang.String | getObjName(int _objType, boolean _bChineseName) 取指定类型的对象名称
static java.lang.String | getOperName(int _operType) 取指定操作类型的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

YES

public static final int YES
WCM逻辑值常量，布尔真值

另请参见：
常量字段值

NO

public static final int NO
WCM逻辑值常量，布尔假值

另请参见：
常量字段值

XML_IMPORT_NEW

public static final int XML_IMPORT_NEW
XML导入类型，从XML导入新的对象

另请参见：
常量字段值

XML_IMPORT_UPDATE

public static final int XML_IMPORT_UPDATE
XML导入类型，从XML导入数据，修改对象

另请参见：
常量字段值

XML_IMPORT_RESTORE

public static final int XML_IMPORT_RESTORE
XML导入类型，从XML导入数据，恢复对象（若没有对象则创建，否则修改）

另请参见：
常量字段值

REMIND_ONLINE

public static final int REMIND_ONLINE
WCM提醒类别：在线提醒

另请参见：
常量字段值

REMIND_BYEMAIL

public static final int REMIND_BYEMAIL
WCM提醒类别：Email提醒

另请参见：
常量字段值

REMIND_BYMOBILE

public static final int REMIND_BYMOBILE
WCM提醒类别：手机提醒

另请参见：
常量字段值

TEMPLATE_COLUMN_TAG

public static final int TEMPLATE_COLUMN_TAG
另请参见：
常量字段值

TEMPLATE_OUTLINE_TAG

public static final int TEMPLATE_OUTLINE_TAG
另请参见：
常量字段值

TEMPLATE_RECORD_TAG

public static final int TEMPLATE_RECORD_TAG
另请参见：
常量字段值

TEMPLATE_DEAL_MODE_UPDATE

public static final int TEMPLATE_DEAL_MODE_UPDATE
另请参见：
常量字段值

TEMPLATE_DEAL_MODE_IGNORE

public static final int TEMPLATE_DEAL_MODE_IGNORE
另请参见：
常量字段值

TEMPLATE_DEAL_MODE_CHANGE

public static final int TEMPLATE_DEAL_MODE_CHANGE
另请参见：
常量字段值

TEMPLATE_DEAL_MODE_QUIT

public static final int TEMPLATE_DEAL_MODE_QUIT
另请参见：
常量字段值

TEMPLATEAPD_DEAL_MODE_UPDATE

public static final int TEMPLATEAPD_DEAL_MODE_UPDATE
另请参见：
常量字段值

TEMPLATEAPD_DEAL_MODE_IGNORE

public static final int TEMPLATEAPD_DEAL_MODE_IGNORE
另请参见：
常量字段值

TEMPLATEAPD_DEAL_MODE_CHANGE

public static final int TEMPLATEAPD_DEAL_MODE_CHANGE
另请参见：
常量字段值

TEMPLATEAPD_DEAL_MODE_QUIT

public static final int TEMPLATEAPD_DEAL_MODE_QUIT
另请参见：
常量字段值

REMIND_NO

public static final int REMIND_NO
有关提醒设置：不提醒

另请参见：
常量字段值

REMIND_YES

public static final int REMIND_YES
有关提醒设置：提醒

另请参见：
常量字段值

REMIND_DONE

public static final int REMIND_DONE
有关提醒设置：已经完成提醒

另请参见：
常量字段值

OBJ_UNKNOWN

public static final int OBJ_UNKNOWN
未知类型

另请参见：
常量字段值

OBJ_OTHER

public static final int OBJ_OTHER
未定义的其他类型

另请参见：
常量字段值

OBJ_FIELDINFO

public static final int OBJ_FIELDINFO
另请参见：
常量字段值

OBJ_TABLEINFO

public static final int OBJ_TABLEINFO
另请参见：
常量字段值

OBJ_WCMID

public static final int OBJ_WCMID
另请参见：
常量字段值

OBJ_EXTENDEDFIELD

public static final int OBJ_EXTENDEDFIELD
另请参见：
常量字段值

OBJ_WCMOBJTRIGGER

public static final int OBJ_WCMOBJTRIGGER
管理WCMObj触发器的对象 *

另请参见：
常量字段值

OBJ_CHANNEL

public static final int OBJ_CHANNEL
另请参见：
常量字段值

OBJ_WEBSITE

public static final int OBJ_WEBSITE
另请参见：
常量字段值

OBJ_REPLACE

public static final int OBJ_REPLACE
另请参见：
常量字段值

OBJ_CONTENTLINK

public static final int OBJ_CONTENTLINK
另请参见：
常量字段值

OBJ_CHANNELSYN

public static final int OBJ_CHANNELSYN
另请参见：
常量字段值

OBJ_GROUP

public static final int OBJ_GROUP
另请参见：
常量字段值

OBJ_RIGHT

public static final int OBJ_RIGHT
另请参见：
常量字段值

OBJ_ROLE

public static final int OBJ_ROLE
另请参见：
常量字段值

OBJ_USER

public static final int OBJ_USER
另请参见：
常量字段值

OBJ_RIGHTDEF

public static final int OBJ_RIGHTDEF
另请参见：
常量字段值

OBJ_TRUSTEEINFO

public static final int OBJ_TRUSTEEINFO
另请参见：
常量字段值

OBJ_ADDRESS

public static final int OBJ_ADDRESS
另请参见：
常量字段值

OBJ_ADDRESSGRP

public static final int OBJ_ADDRESSGRP
另请参见：
常量字段值

OBJ_BOOKMARK

public static final int OBJ_BOOKMARK
另请参见：
常量字段值

OBJ_CONTACT

public static final int OBJ_CONTACT
另请参见：
常量字段值

OBJ_CONTACTGRP

public static final int OBJ_CONTACTGRP
另请参见：
常量字段值

OBJ_EVENT

public static final int OBJ_EVENT
另请参见：
常量字段值

OBJ_MARKKIND

public static final int OBJ_MARKKIND
另请参见：
常量字段值

OBJ_MARKSHARE

public static final int OBJ_MARKSHARE
另请参见：
常量字段值

OBJ_MESSAGE

public static final int OBJ_MESSAGE
另请参见：
常量字段值

OBJ_MSGQUEUE

public static final int OBJ_MSGQUEUE
另请参见：
常量字段值

OBJ_TASK

public static final int OBJ_TASK
另请参见：
常量字段值

OBJ_TASKPOOL

public static final int OBJ_TASKPOOL
另请参见：
常量字段值

OBJ_EVENTTYPE

public static final int OBJ_EVENTTYPE
另请参见：
常量字段值

OBJ_USERSETTING

public static final int OBJ_USERSETTING
另请参见：
常量字段值

OBJ_RECENT

public static final int OBJ_RECENT
另请参见：
常量字段值

OBJ_FLOW

public static final int OBJ_FLOW
另请参见：
常量字段值

OBJ_FLOWACTION

public static final int OBJ_FLOWACTION
另请参见：
常量字段值

OBJ_FLOWNODE

public static final int OBJ_FLOWNODE
另请参见：
常量字段值

OBJ_FLOWNODEBRANCH

public static final int OBJ_FLOWNODEBRANCH
另请参见：
常量字段值

OBJ_FLOWDOC

public static final int OBJ_FLOWDOC
工作流流转情况对象

另请参见：
常量字段值

OBJ_FLOWDOCBAK

public static final int OBJ_FLOWDOCBAK
工作流流转情况对象

另请参见：
常量字段值

OBJ_FLOWNODEEVENT

public static final int OBJ_FLOWNODEEVENT
工作流节点事件对象

另请参见：
常量字段值

OBJ_FLOWEVENTCONDITION

public static final int OBJ_FLOWEVENTCONDITION
工作流节点事件条件对象

另请参见：
常量字段值

OBJ_FLOWEVENTOPERATE

public static final int OBJ_FLOWEVENTOPERATE
工作流节点事件执行对象

另请参见：
常量字段值

OBJ_OPERATIONBEAN

public static final int OBJ_OPERATIONBEAN
工作流执行系统配置对象

另请参见：
常量字段值

OBJ_CONDITIONBEAN

public static final int OBJ_CONDITIONBEAN
工作流条件系统配置对象

另请参见：
常量字段值

OBJ_FLOWEMPLOYBEAN

public static final int OBJ_FLOWEMPLOYBEAN
工作流配置关系

另请参见：
常量字段值

OBJ_SCHEDULE

public static final int OBJ_SCHEDULE
另请参见：
常量字段值

OBJ_APPENDIX

public static final int OBJ_APPENDIX
另请参见：
常量字段值

OBJ_DOCKIND

public static final int OBJ_DOCKIND
另请参见：
常量字段值

OBJ_DOCREPLY

public static final int OBJ_DOCREPLY
另请参见：
常量字段值

OBJ_FILETYPE

public static final int OBJ_FILETYPE
另请参见：
常量字段值

OBJ_DOCUMENT

public static final int OBJ_DOCUMENT
另请参见：
常量字段值

OBJ_EXPIRATION

public static final int OBJ_EXPIRATION
另请参见：
常量字段值

OBJ_SECURITY

public static final int OBJ_SECURITY
另请参见：
常量字段值

OBJ_SOURCE

public static final int OBJ_SOURCE
另请参见：
常量字段值

OBJ_RELATION

public static final int OBJ_RELATION
另请参见：
常量字段值

OBJ_STATUS

public static final int OBJ_STATUS
另请参见：
常量字段值

OBJ_DOCBAK

public static final int OBJ_DOCBAK
另请参见：
常量字段值

OBJ_WCMEXCELDATA

public static final int OBJ_WCMEXCELDATA
另请参见：
常量字段值

OBJ_HITSCOUNT

public static final int OBJ_HITSCOUNT
另请参见：
常量字段值

OBJ_CHNLDOC

public static final int OBJ_CHNLDOC
记录文档逻辑信息对象*

另请参见：
常量字段值

OBJ_CONFIG

public static final int OBJ_CONFIG
另请参见：
常量字段值

OBJ_LOG

public static final int OBJ_LOG
另请参见：
常量字段值

OBJ_LOGTYPE

public static final int OBJ_LOGTYPE
另请参见：
常量字段值

OBJ_OPERTYPE

public static final int OBJ_OPERTYPE
另请参见：
常量字段值

OBJ_MEETINGROOM

public static final int OBJ_MEETINGROOM
另请参见：
常量字段值

OBJ_MEETINGCONT

public static final int OBJ_MEETINGCONT
另请参见：
常量字段值

OBJ_MEETINGUSER

public static final int OBJ_MEETINGUSER
另请参见：
常量字段值

OBJ_BULLETIN

public static final int OBJ_BULLETIN
另请参见：
常量字段值

OBJ_WCMRESULTSET

public static final int OBJ_WCMRESULTSET
WCMRESULTSET对象类型

另请参见：
常量字段值

OBJ_JOB

public static final int OBJ_JOB
另请参见：
常量字段值

OBJ_PUBLISHDISTRIBUTION

public static final int OBJ_PUBLISHDISTRIBUTION
另请参见：
常量字段值

OBJ_WCMFORMINFO

public static final int OBJ_WCMFORMINFO
WCM自定义的表单信息 (old)

另请参见：
常量字段值

OBJ_WCMFORMFIELDS

public static final int OBJ_WCMFORMFIELDS
WCM自定义的表单中的字段信息 (old)

另请参见：
常量字段值

OBJ_BIGTABLE

public static final int OBJ_BIGTABLE
WCM自定义的表单信息

另请参见：
常量字段值

OBJ_BIGTABLEFIELD

public static final int OBJ_BIGTABLEFIELD
WCM自定义的表单中的字段信息

另请参见：
常量字段值

OBJ_BIGTABLEMPLOY

public static final int OBJ_BIGTABLEMPLOY
WCM自定义的表单中的使用信息

另请参见：
常量字段值

OBJ_INFOVIEW

public static final int OBJ_INFOVIEW
结合 MS InfoPath 实现的自定义表单

另请参见：
常量字段值

OBJ_INFOVIEWFIELD

public static final int OBJ_INFOVIEWFIELD
结合 MS InfoPath 实现的自定义表单的数据项（字段）

另请参见：
常量字段值

OBJ_INFOVIEWEMPLOY

public static final int OBJ_INFOVIEWEMPLOY
结合 MS InfoPath 实现的自定义表单的雇佣关系（被频道使用）

另请参见：
常量字段值

OBJ_INFOVIEWGROUP

public static final int OBJ_INFOVIEWGROUP
结合 MS InfoPath 实现的自定义表单的数据区块（Section or Table）

另请参见：
常量字段值

OBJ_INFOVIEWVIEW

public static final int OBJ_INFOVIEWVIEW
结合 MS InfoPath 实现的自定义表单的视图

另请参见：
常量字段值

OBJ_USERDEF

public static final int OBJ_USERDEF
用户自定义对象的起始值

另请参见：
常量字段值

OBJ_EXTFIELD

public static final int OBJ_EXTFIELD
另请参见：
常量字段值

OBJ_REGIONINFO

public static final int OBJ_REGIONINFO
另请参见：
常量字段值

OBJ_REGIONCELL

public static final int OBJ_REGIONCELL
另请参见：
常量字段值

OPER_UNKOWN

public static final int OPER_UNKOWN
未知类型

另请参见：
常量字段值

OPER_OTHER

public static final int OPER_OTHER
未定义的其他操作类型

另请参见：
常量字段值

OPER_SYSTEM_SET

public static final int OPER_SYSTEM_SET
修改系统配置

另请参见：
常量字段值

OPER_SITE_ADD

public static final int OPER_SITE_ADD
添加站点

另请参见：
常量字段值

OPER_SITE_EDIT

public static final int OPER_SITE_EDIT
修改站点

另请参见：
常量字段值

OPER_SITE_DEL

public static final int OPER_SITE_DEL
测定删除站点

另请参见：
常量字段值

OPER_SITE_PUB

public static final int OPER_SITE_PUB
发布站点

另请参见：
常量字段值

OPER_SITE_RECYCLE

public static final int OPER_SITE_RECYCLE
假删除站点

另请参见：
常量字段值

OPER_SITE_RESCOVER

public static final int OPER_SITE_RESCOVER
恢复站点

另请参见：
常量字段值

OPER_SCHEDULE_PUB

public static final int OPER_SCHEDULE_PUB
另请参见：
常量字段值

OPER_CHNL_ADD

public static final int OPER_CHNL_ADD
添加频道

另请参见：
常量字段值

OPER_CHNL_EDIT

public static final int OPER_CHNL_EDIT
修改频道

另请参见：
常量字段值

OPER_CHNL_DEL

public static final int OPER_CHNL_DEL
彻底删除频道

另请参见：
常量字段值

OPER_CHNL_PUB

public static final int OPER_CHNL_PUB
发布频道

另请参见：
常量字段值

OPER_CHNL_RECYCLE

public static final int OPER_CHNL_RECYCLE
假删除频道

另请参见：
常量字段值

OPER_CHNL_RESCOVER

public static final int OPER_CHNL_RESCOVER
恢复频道

另请参见：
常量字段值

OPER_DOC_ADD

public static final int OPER_DOC_ADD
添加文档

另请参见：
常量字段值

OPER_DOC_EDIT

public static final int OPER_DOC_EDIT
修改文档

另请参见：
常量字段值

OPER_DOC_DEL

public static final int OPER_DOC_DEL
删除文档

另请参见：
常量字段值

OPER_DOC_PUB

public static final int OPER_DOC_PUB
发布文档

另请参见：
常量字段值

OPER_FLOW_ADD

public static final int OPER_FLOW_ADD
添加工作流

另请参见：
常量字段值

OPER_FLOW_EDIT

public static final int OPER_FLOW_EDIT
修改工作流

另请参见：
常量字段值

OPER_FLOW_DEL

public static final int OPER_FLOW_DEL
删除工作流

另请参见：
常量字段值

OPER_TEMPLATE_ADD

public static final int OPER_TEMPLATE_ADD
添加模板

另请参见：
常量字段值

OPER_TEMPLATE_EDIT

public static final int OPER_TEMPLATE_EDIT
修改模板

另请参见：
常量字段值

OPER_TEMPLATE_DEL

public static final int OPER_TEMPLATE_DEL
删除模板

另请参见：
常量字段值

OPER_USER_LOGIN

public static final int OPER_USER_LOGIN
用户登录

另请参见：
常量字段值

OPER_USER_LOGOUT

public static final int OPER_USER_LOGOUT
用户退出

另请参见：
常量字段值

OPER_SYSTEM_WARN

public static final int OPER_SYSTEM_WARN
Comment for OPER_SYSTEM_WARN 系统警告

另请参见：
常量字段值

OPER_USER_DEFINE

public static final int OPER_USER_DEFINE
用户指定义的操作类型起始值

另请参见：
常量字段值

LOG_UNKOWN

public static final int LOG_UNKOWN
另请参见：
常量字段值

LOG_SYSTEM

public static final int LOG_SYSTEM
系统日志

另请参见：
常量字段值

LOG_SECURITY

public static final int LOG_SECURITY
安全日志

另请参见：
常量字段值

LOG_FLOW

public static final int LOG_FLOW
工作流日志

另请参见：
常量字段值

LOG_PUB

public static final int LOG_PUB
发布日志

另请参见：
常量字段值

LOG_JOB

public static final int LOG_JOB
Jobserver日志

另请参见：
常量字段值

LOG_EXCEPTION

public static final int LOG_EXCEPTION
操作异常日志

另请参见：
常量字段值

LOG_OTHER

public static final int LOG_OTHER
其他应用日志

另请参见：
常量字段值

LOG_SCHEDULE_PUB

public static final int LOG_SCHEDULE_PUB
另请参见：
常量字段值

PUBLISH_NOT_NEED

public static final int PUBLISH_NOT_NEED
另请参见：
常量字段值

PUBLISH_SELF_NEED

public static final int PUBLISH_SELF_NEED
另请参见：
常量字段值

PUBLISH_CHILD_NEED

public static final int PUBLISH_CHILD_NEED
另请参见：
常量字段值

MESSAGE_UNREAD

public static final int MESSAGE_UNREAD
未读短消息

另请参见：
常量字段值

MESSAGE_SENT

public static final int MESSAGE_SENT
已发送短消息

另请参见：
常量字段值

MESSAGE_RECEIVED

public static final int MESSAGE_RECEIVED
已接收短消息

另请参见：
常量字段值
构造方法详细信息

WCMTypes

public WCMTypes()
方法详细信息

getLowerObjName

public static java.lang.String getLowerObjName(int _objType)

getLowerSynName

public static java.lang.String getLowerSynName(boolean _sIsTarget)

getObjName

public static java.lang.String getObjName(int _objType,
                                          boolean _bChineseName)
取指定类型的对象名称

参数：
_objType - 对象类型；
_bChineseName - 是否返回对象的中文名称；若不是，则返回class名称
返回：
String对象，指定类型的对象名称

getOperName

public static java.lang.String getOperName(int _operType)
取指定操作类型的名称

参数：
_operType - 操作类型
返回：
String对象，指定操作类型的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.common.BaseContextHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.common.BaseContextHelper
的使用

没有 com.trs.infra.common.BaseContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.common.BaseIdsMan 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.common.BaseIdsMan
的使用

使用 BaseIdsMan 的软件包
com.trs.cms.auth.domain
com.trs.components.common.calendar
com.trs.components.common.publish.domain.template
com.trs.components.wcm.content.domain
com.trs.components.wcm.customize

com.trs.cms.auth.domain 中 BaseIdsMan 的使用

com.trs.cms.auth.domain 中 BaseIdsMan 的子类
class | GrpUserIdsMan Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleUserIdsMan Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.calendar 中 BaseIdsMan 的使用

com.trs.components.common.calendar 中 BaseIdsMan 的子类
 class EventShareIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
日程共享管理:处理共享日程时,维护指定的日程安排与共享者的关联关系
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.template 中 BaseIdsMan 的使用

com.trs.components.common.publish.domain.template 中 BaseIdsMan 的子类
 class TemplateEmployerIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
Template Employee Ids manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 中 BaseIdsMan 的使用

com.trs.components.wcm.content.domain 中 BaseIdsMan 的子类
 class SiteMemberIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
站点用户关联处理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.customize 中 BaseIdsMan 的使用

com.trs.components.wcm.customize 中 BaseIdsMan 的子类
 class CustomizedChannelIdsMan
Title: TRS 内容协作平台（TRS WCM）
Description:
用户个性化定制频道的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.common.ContextParameters 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.common.ContextParameters
的使用

没有 com.trs.infra.common.ContextParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.common.ContextTL 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.common.ContextTL
的使用

没有 com.trs.infra.common.ContextTL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.common.WCMDatainvalidException 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.common.WCMDatainvalidException
的使用

没有 com.trs.infra.common.WCMDatainvalidException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.common.WCMException 的使用

概述

软件包

类

使用

树

已过时

索引

帮助

上一个 下一个

框架 无框架

类 com.trs.infra.common.WCMException
的使用

使用 WCMException 的软件包

com.trs.ajaxservice

com.trs.ajaxservice.xmlconvertors

com.trs.cluster.receiver

com.trs.cms.auth

com.trs.cms.auth.domain

com.trs.cms.auth.persistent

com.trs.cms.content

com.trs.cms.process

com.trs.cms.process.config

com.trs.cms.process.definition

com.trs.cms.process.engine

com.trs.cms.process.engine.creators

com.trs.cms.process.engine.handlers

com.trs.cms.process.xml

com.trs.components.ckm

com.trs.components.comment.domain

com.trs.components.comment.persistent

com.trs.components.comment.publish.helper

com.trs.components.comment.publish.tagparser

com.trs.components.comment.service

com.trs.components.common.address

com.trs.components.common.bookmark

com.trs.components.common.calendar

com.trs.components.common.conjection.persistent

com.trs.components.common.conjection.service

com.trs.components.common.job

com.trs.components.common.message

com.trs.components.common.message.notify

com.trs.components.common.publish

com.trs.components.common.publish.config

com.trs.components.common.publish.domain

com.trs.components.common.publish.domain.auth

com.trs.components.common.publish.domain.distribute

com.trs.components.common.publish.domain.element

com.trs.components.common.publish.domain.publisher

com.trs.components.common.publish.domain.tagparser

com.trs.components.common.publish.domain.taskdispatch

com.trs.components.common.publish.domain.template

com.trs.components.common.publish.persistent.distribute

com.trs.components.common.publish.persistent.element

com.trs.components.common.publish.persistent.publisher

com.trs.components.common.publish.persistent.taskdispatch

com.trs.components.common.publish.persistent.template

com.trs.components.common.publish.widget

com.trs.components.common.publish.widget.tagparser

com.trs.components.common.reminder

com.trs.components.common.trsad

com.trs.components.common.trsvote

com.trs.components.filter

com.trs.components.gkml.sqgk.persistent

com.trs.components.gkml.sqgk.process.element

com.trs.components.gkml.sqgk.process.engine.creators

com.trs.components.gkml.sqgk.process.engine.handlers

com.trs.components.govinfo

com.trs.components.infoview

结合 MS InfoPath 实现自定义表单。

com.trs.components.infoview.config

com.trs.components.infoview.db

com.trs.components.infoview.extract

抽取 MS InfoPath 的 XSN 文件的内容。

com.trs.components.infoview.helper

com.trs.components.infoview.mad

com.trs.components.infoview.persistent

结合 MS InfoPath 实现的自定义表单的持久化。

com.trs.components.infoview.process

com.trs.components.infoview.publish.tagparser

结合 MS InfoPath 实现的自定义表单的发布置标。

com.trs.components.metadata.center

com.trs.components.metadata.center.xml

com.trs.components.metadata.definition

com.trs.components.metadata.definition.xml

com.trs.components.metadata.publish

com.trs.components.metadata.right

com.trs.components.metadata.service

com.trs.components.metadata.web

com.trs.components.metadata.web.impl

com.trs.components.special

com.trs.components.stat

com.trs.components.wcm.auth

com.trs.components.wcm.channel

com.trs.components.wcm.content

com.trs.components.wcm.content.domain

com.trs.components.wcm.content.domain.auth

com.trs.components.wcm.content.domain.intelligence

com.trs.components.wcm.content.persistent

com.trs.components.wcm.content.trsserver

com.trs.components.wcm.contentlink

com.trs.components.wcm.customize

com.trs.components.wcm.epress

com.trs.components.wcm.individuation

com.trs.components.wcm.process

com.trs.components.wcm.process.element

com.trs.components.wcm.process.service.flowexporter

com.trs.components.wcm.publish

com.trs.components.wcm.publish.domain

com.trs.components.wcm.publish.element

com.trs.components.wcm.publish.logo

com.trs.components.wcm.publish.region

com.trs.components.wcm.publish.tagparser

com.trs.components.wcm.publish.tagparser.formater

com.trs.components.wcm.recent

com.trs.components.wcm.resource

com.trs.components.wcm.stat

com.trs.components.wcm.util

com.trs.components.wcm.wcmx.help

com.trs.components.wcm.wcmx.media

com.trs.components.wcm.wcmx.websites

com.trs.components.web

com.trs.components.web.document

com.trs.db.update

com.trs.infra

com.trs.infra.common

com.trs.infra.config

com.trs.infra.config.domain

com.trs.infra.persistent

com.trs.infra.persistent.cache

com.trs.infra.persistent.db

com.trs.infra.persistent.listener

com.trs.infra.persistent.util

com.trs.infra.support.cache

com.trs.infra.support.config

com.trs.infra.support.file

com.trs.infra.support.log

com.trs.infra.support.security

定义和安全相关的一些对象和操作，诸如密钥的存储和管理。

com.trs.infra.util

com.trs.infra.util.database

com.trs.infra.util.job

com.trs.km.auth

com.trs.presentation.common

com.trs.presentation.documetimport.xml

com.trs.presentation.ids

com.trs.presentation.locale

com.trs.presentation.login

com.trs.presentation.nav

com.trs.presentation.navigation

com.trs.presentation.portal

com.trs.presentation.publish.template

com.trs.presentation.right

com.trs.presentation.util

com.trs.presentation.valid

com.trs.presentation.wcm.content

com.trs.scene.parser

com.trs.scene.tools

com.trs.service

com.trs.service.impl

com.trs.template.domain

com.trs.template.domain.setting

com.trs.template.service.impl

com.trs.upgrade

com.trs.util

com.trs.wcm.config

com.trs.wcm.customize

com.trs.wcm.old

com.trs.wcm.photo

com.trs.wcm.photo.impl

com.trs.wcm.photo.publish

com.trs.wcmonline

com.trs.webframework.config

com.trs.webframework.controler

com.trs.webframework.provider

com.trsupdate

com.wcm.pdf

com.trs.ajaxservice 中 WCMException 的使用

抛出 WCMException 的 com.trs.ajaxservice 中的方法

void

InfoviewDataToolService.adapterHistory(MethodContext _context)
1.为系统所有视图创建表结构
2.替换视图的检索字段，概览字段，自动生成相应的DB字段
3.替换栏目的检索字段，自动生成相应的DB字段
4.同步文档的DocFlag到ChnlDoc表中

void

ContentExtendValues.addElement(int _nId, java.lang.String _sName, java.lang.String _sDBName, java.lang.String _sValue)

java.lang.Object

ContentLinkServiceProvider.addLinkInChannel(MethodContext _context)

void

InfoviewDataToolService.autoCreateHistoryDocs(MethodContext _context)
遍历docflag>0的文档列表，保存相关的字段，生成新的表单数据

java.lang.Object

ContentLinkServiceProvider.changeOrder(MethodContext _context)

java.lang.String

ChannelServiceProvider.checkSQLValid(MethodContext _context)

static int

TemplateEmployMgrHelper.clearEmploymentOfEmployer(IPublishElement _employer, Template _template)

void

MessageServiceProvider.clearInbox()
清空收件箱

void

MessageServiceProvider.clearOutbox()
清空发件箱

java.lang.String

ChannelServiceProvider.createChannelTreeHTMLOfIds(MethodContext _methodContext)
产生指定栏目ID的子栏目序列树HTML

void

ChannelServiceProvider.createFromFile(MethodContext _methodContext)

void

ContentLinkServiceProvider.createFromFile(MethodContext _context)
导入txt文件来批量创建热词

static void

ChannelServiceProviderHelper.createRelatedEmployes(Channel sourceChannel, Channel newChannel)

static void

DocumentPublishHelper.delete(Documents _documents, Channel _channel)

static void

DocumentPublishHelper.delete(Documents _documents, Channel _channel, boolean _bAll)

static void

DocumentPublishHelper.delete(java.lang.String _sDocIds, int _nChannelId)

void

ProcessService.disableFlowToChannel(MethodContext _methodContext)
取消给指定栏目启用的工作流

boolean

ProcessService.doAccept(MethodContext _MethodContext)

boolean

ProcessService.doReceive(MethodContext _MethodContext)

java.lang.Object

ContentLinkServiceProvider.editLinkInChannel(MethodContext _context)

void

ProcessService.enableFlowToChannel(MethodContext _methodContext)
给指定栏目启动启用指定的工作流

static ViewDocuments

WCMDocumentHelper.findViewDocumentsByIds(User _loginUser, java.lang.String _sChnlDocIds)

java.lang.String

InfoviewService.generaterContent(MethodContext _context)
_context 中参数 DocumentId InfoViewId/ChannelId TempIVType 缺省为detail Page 缺省为1

java.lang.String

InfoviewService.getAbsolutePath(InfoView _oInfoView, java.lang.String sFileName)

Channels

ProcessService.getChannelsUseingFlow(MethodContext _methodContext)
获取使用了指定工作流的栏目列表

static Channels

ChannelHelper.getChildren(User _loginUser, BaseChannel _parent, WCMFilter _extraFilter)

IFlowContent[]

ProcessService.getContentsInFlow(MethodContext _methodContext)
获取在指定的工作流中流转的内容列表

IFlowContent[]

ProcessService.getContentsOfUser(MethodContext _MethodContext)
获取需要用户处理的内容

static Flow

WCMApplyFormProcessServiceHelper.getFlow()

java.lang.String

ProcessService.getFlowOptionAuth(MethodContext _context)

Flow

ProcessService.getFlowUsedByChannel(MethodContext _methodContext)
获取指定栏目正在使用的工作流

InfoViews

InfoviewService.getInfoViews()

java.lang.String

ContentLinkServiceProvider.getParentChannelWhere(int _nChannelId, WCMFilter filter)

ContentProcessInfo

ProcessService.getProcessInfoOfContent(MethodContext _methodContext)
获取指定内容的流转信息（是否已经结束、发起人）

java.util.Map

RoleServiceProvider.getSiteRoleUsersInfo(MethodContext _context)
获取指定用户的站点角色用户信息，map格式为：

WebSites

WebSiteServiceProvider.getSitesForCurrUser(MethodContext _methodContext)
获取当前登录用户可以操作（默认为设置权限）的站点

java.lang.Object

PublishServiceProvider.getUnpubSchedule(MethodContext context)

Users

UserServiceProvider.getUsersByNames(MethodContext _context)

Users

UserServiceProvider.getUsersOfGroup(MethodContext _context)
获取指定组织下的用户集合,适用于角色的添加用户页面

Users

UserServiceProvider.getUsersOfRole(MethodContext _context)
获取指定角色和站点下的用户集合,兼容系统级角色和非系统级角色

Users

UserServiceProvider.getUsersOfSpecialRole(MethodContext _context)
获取指定特定角色下的用户集合

Users

UserServiceProvider.getUsersOfSystemRoleOnSite(MethodContext _context)
获取指定系统级角色和站点下的用户集合

static WebSites

WebSiteHelper.getWebSitesByRightIndex(User _loginUser, int _nRightIndex, WCMFilter extraFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual)
获取某个用户能操作的站点集合

static WebSites

WebSiteHelper.getWebSitesByType(User _loginUser, int _nSiteType, WCMFilter queryFilter)

static WebSites

WebSiteHelper.getWebSitesByTypeWithIndividual(User _loginUser, int _nSiteType, WCMFilter queryFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual)

static boolean

WCMProcessServiceHelper.hasFlowingActionRight(User _loginUser, int _nFlowdocId, int _nRightIndex)

Reports

ProcessService.importFlows(MethodContext _methodContext)

void

ContentLinkServiceProvider.importSysLinks(MethodContext _context)

void

InfoviewService.initInfoViewTemFileUrls()

boolean

SystemServiceProvider.isValidChannelId(MethodContext _oMethodContext)
判断指定的栏目Id是否有效

boolean

SystemServiceProvider.isValidSiteId(MethodContext _oMethodContext)
判断指定的站点Id是否有效

static boolean

WebSiteHelper.isVisible(User _loginUser, WebSite _site)
判断用户对于指定站点是否可见

java.lang.Object

PhotoServiceProvider.loadSysPicProps(MethodContext _context)

static PageOperators

PageOperatorsForServiceHelper.makeCMSBaseObjsOpertators(User _loginUser, java.lang.String _sObjectIds, CMSBaseObjs _objects)

static PageOperators

PageOperatorsForServiceHelper.makeCMSObjOpertators(User _loginUser, java.lang.String _sObjectKey, CMSObj channel)

static WCMFilter

DocumentAuthHelper.makeFilterWithRight(User _loginUser, BaseObjs _oSitesOrChannels)
构造当前用户在指定的栏目中带有权限的Filter

static java.lang.String

WCMProcessServiceHelper.makeFlowContextInfo(Flow _flow)

static RightValue

TemplateAuthHelper.makeHostRightValue(MethodContext _context, User _loginUser, IPublishFolder _host)

static java.lang.String

WCMDocumentHelper.makeRightValue(MethodContext _methodContext, User _loginUser, Channel _currChannel, Document _document)
构造指定文档在指定栏目中的权限

static RightValue

TemplateAuthHelper.makeTemplateRightValue(MethodContext _context, User _loginUser, Template _template, IPublishFolder _host)

void

InfoviewService.putInfoViewTemplateInfoOnePath(java.lang.String _infoviewids)

java.lang.Object

IndividuationServiceProvider.query(MethodContext _methContext)

java.lang.String

InfoviewService.queryChannelUsableInfoviews(MethodContext _context)

java.lang.Object

IndividuationServiceProvider.queryCustomSite(MethodContext _methContext)

InfoViews

InfoviewService.queryFlowInfoviews(MethodContext _context)

java.lang.Object

ContentLinkServiceProvider.queryLinkType(MethodContext _context)

java.lang.String

InfoviewService.querySearchFields(MethodContext _context)

java.lang.Object

ContentLinkServiceProvider.queryTypes(MethodContext _context)

void

InfoviewDataToolService.rebuildAllInfoViews(MethodContext _context)
为系统所有视图创建表结构

void

ProcessService.removeChannelEmployersOfFlow(MethodContext _methodContext)
批量取消工作流的配置情况

static void

ChannelHelper.removeNoRightChannel(User _loginUser, Channels _channels, int _nRightIndex)

void

InfoviewDataToolService.renderAllChannelOutlineFields(MethodContext _context)
替换栏目的检索字段，自动生成相应的DB字段

void

InfoviewDataToolService.renderAllInfoViewSearchOutlineFields(MethodContext _context)
替换视图的检索字段，概览字段，自动生成相应的DB字段

ChnlDocs

ChnlDocServiceProvider.search(MethodContext _methContext)
查询指定站点或者指定频道下的文档

void

ProcessService.setChannelEmployersOfFlow(MethodContext _methodContext)
批量维护工作流的配置情况

void

InfoviewService.setEmployedInfoView(MethodContext _context)

void

ContentLinkServiceProvider.setLinkType(MethodContext _context)

static void

TemplateEmployMgrHelper.setOtherOutlinesOfChannels(MethodContext _context, Template _template)

static void

TemplateEmployMgrHelper.setOtherOutlinesOfSite(IPublishElement siteFolder, Template template)

void

PublishServiceProvider.setUnpubSchedule(MethodContext context)

static CMSObj

WCMAJAXServiceHelper.setWCMObjectProperties(User _loginUser, MethodContext _methodContext, CMSObj _oCMSObj, java.lang.String[] _pLogicFields)
更新指定的对象

static void

WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, boolean _bUseDefaultFlowMode)

static void

WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, java.util.Map _hFlowContextInfo)

static void

WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, MethodContext _oMethodContext)

static void

WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, boolean _bUseDefaultFlowMode)

static void

WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, Flow _oFlow, MethodContext _oMethodContext)

static void

WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, java.util.Map _hFlowContextInfo)

static void

WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, MethodContext _oMethodContext)

void

InfoviewDataToolService.syncChnlDocFlag(MethodContext _context)
同步文档的DocFlag到ChnlDoc表中

static void

WCMAJAXServiceHelper.validateFile(java.lang.String _sImportFile)

static void

WCMApplyFormProcessServiceHelper.validateWorkFlowRight(User _loginUser, BaseObj _content, int _nFlowDocId, int _nActionIndex, java.lang.String _sOperDesc)

static void

WCMProcessServiceHelper.validateWorkFlowRight(User _loginUser, BaseObj _content, int _nFlowDocId, int _nActionIndex, java.lang.String _sOperDesc)

com.trs.ajaxservice.xmlconvertors 中 WCMException 的使用

抛出 WCMException 的 com.trs.ajaxservice.xmlconvertors 中的方法

void

XMLToCMSObj.parse(java.lang.String _sXMLText)

com.trs.cluster.receiver 中 WCMException 的使用

抛出 WCMException 的 com.trs.cluster.receiver 中的方法

void

TableInfosMsgReceiver.receive(java.lang.String _sContent, java.lang.String[] _pParameters)

void

RefreshPropertyMsgReceiver.receive(java.lang.String _sContent, java.lang.String[] _pParameters)

void

DBMsgReceiver.receive(java.lang.String _sContent, java.lang.String[] _pParameters)

com.trs.cms.auth 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.auth 中的方法

static boolean

AuthHelper.hasRightOnSelf(User _currUser, CMSObj _objCurrent, int[] _pRightIndex)

static boolean

AuthHelper.hasSuperRight(User _currUser, CMSObj _currObj)

com.trs.cms.auth.domain 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.auth.domain 中的方法

boolean

GroupRoleMgr.addGroup(Group _dstGroup, Role _theRole)

boolean

RoleMgr.addUser(Role _theRole, int _nSiteId, User _dstUser)
添加指定用户到指定的角色

boolean

GroupMgr.addUser(User _userToAdd, Group _theGroup)
将用户加到指定组织中去

boolean

RoleMgr.addUser(User _dstUser, Role _theRole)
已过时。 权限模型调整，需要引入站点id.

boolean

ObjectMemberMgr.canOperate(CMSObj _oOperator, int _nObjType, int _nObjId)

boolean

IObjectMemberMgr.canOperate(CMSObj _currOperator, int _nObjType, int _nObjId)
判断当前操作者对于指定对象是否可操作

boolean

ObjectMemberMgr.canOperate(Group _oGroup, int _nObjType, int _nObjId)

boolean

IObjectMemberMgr.canOperate(Group _currGroup, int _nObjType, int _nObjId)
判断当前组织对于指定对象是否可操作

boolean

ObjectMemberMgr.canOperate(Role _oRole, int _nObjType, int _nObjId)

boolean

IObjectMemberMgr.canOperate(Role _currRole, int _nObjType, int _nObjId)
判断当前角色对于指定对象是否可操作

boolean

ObjectMemberMgr.canOperate(User _oUser, int _nObjType, int _nObjId)

boolean

IObjectMemberMgr.canOperate(User _currUser, int _nObjType, int _nObjId)
判断当前用户对于指定对象是否可操作

boolean

UserMgr.changeUserRegStatus(User _dstUser, int _nNewStatusId)
更改用户的注册状态

boolean

GroupMgr.delete(Group _dstGroup)
删除组织

boolean

RoleMgr.delete(Role _roleToDelete, boolean _bDrop)
删除角色

boolean

UserMgr.delete(User _aUserToBeDeleted, boolean _bDrop)
删除一个用户

Right

IRightMgr.deleteRight(Right _delRight)
删除指定的权限

Right

RightMgr.deleteRight(Right _delRight)

Role

RoleMgr.findRoleByName(java.lang.String sRoleName)
根据角色名称，获取到第一个匹配的角色，优先获取id值更大的角色

Users

GroupMgr.getAdmins(Group _dstGroup)
获取指定组织的管理员集合

IRightHost[]

IRightHost.getChildren()
获取当前对象的一级子对象

Groups

GroupMgr.getChildren(Group _parentGroup)
获取子组织

Groups

GroupMgr.getChildren(Group _parentGroup, WCMFilter _filter)
获取子组织

Users

UserMgr.getConsignUsers(int _nModuleType)
获取当前用户的托管人

java.lang.String

IDepartmentMgr.getDepartmentInfo(User _user)
获取指定用户的所属部门描述信息，多级默认以/分隔

java.lang.String

DepartmentMgrImpl.getDepartmentInfo(User _user)

java.lang.String

IDepartmentMgr.getDepartmentInfo(User _user, java.lang.String _sDelimit)
获取指定用户的所属部门描述信息，多级以_sDelimit指定的分隔符分开，默认为\

java.lang.String

DepartmentMgrImpl.getDepartmentInfo(User _user, java.lang.String _sDelimit)

Groups

IDepartmentMgr.getDeptGroups(User _user)
获取指定用户所属的组织结构

Groups

DepartmentMgrImpl.getDeptGroups(User _user)

Groups

IDepartmentMgr.getDeptGroupTree(User _user)
获取指定用户的所属部门组织树，按照树形结构组织

Groups

DepartmentMgrImpl.getDeptGroupTree(User _user)

Groups

GroupRoleMgr.getGroups(Role _dstRole, WCMFilter _filter)
获取指定角色的关联的组织

Groups

UserMgr.getGroups(User _dstUser)
获取当前用户所在的所有组织

Groups

GroupMgr.getGroups(User _user, WCMFilter _filter)
根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织

GroupUsers

GroupMgr.getGroupUsers(Group _theGroup, WCMFilter _filter)
获取指定组织所有的用户(用户组织关联对象)

static java.lang.String

AuthServer.getLogicalRightValue(CMSObj _currObj, User _currOpUser, int[] _rightIndexes)
获取当前逻辑权限值，包含了继承关系

Rights

UserMgr.getMyRights(int _nOperatorType, int _nOperatorId, int _nObjType)
获取指定操作者在某类对象上的操作权限

RightValue

UserMgr.getMyRightValue(CMSObj _obj)
取用户在指定对象上的操作权限值

RightValue

UserMgr.getMyRightValue(int _objType, int _objId)
取用户在指定对象上的操作权限值

ObjectMember

ObjectMemberMgr.getObjectMember(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId)
获取ObjectMember

ObjectMember

IObjectMemberMgr.getObjectMember(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId)
获取可访问可操作对象

java.lang.String

GroupMgr.getOffspringGroupIds(java.lang.String _sGroupIds, boolean _bContainSelf)
返回所有的子孙组IDs,确定是否包含自身

Groups

GroupMgr.getOffspringGroups(Group _theGroup, boolean _bContainSelf, WCMFilter _filter)
返回所有的子孙组,确定是否包含自身

Groups

GroupMgr.getOffspringGroups(User _user, WCMFilter _filter)
根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织,同时包含子孙组织

IRightHost

IRightHost.getParent()
获取父对象

Right

IRightMgr.getRight(CMSObj _currObj, CMSObj _currOperator)
获取指定对象指定操作者的权限对象

Right

RightMgr.getRight(CMSObj _currObj, CMSObj _currOperator)

Right

IRightMgr.getRight(int _objType, int _objId, int _oprType, int _oprId)
获取指定对象指定操作者的权限对象

Right

RightMgr.getRight(int _objType, int _objId, int _oprType, int _oprId)

Rights

IRightMgr.getRights(CMSObj _currObj)

Rights

RightMgr.getRights(CMSObj _currObj)

Rights

IRightMgr.getRights(CMSObj _currObj, int _operatorType)

Rights

RightMgr.getRights(CMSObj _currObj, int _operatorType)

Rights

IRightMgr.getRights(CMSObj _currObj, java.lang.String _groupIds, java.lang.String _roleIds)
获取指定对象指定群和组织的权限对象

Rights

RightMgr.getRights(CMSObj _currObj, java.lang.String _groupIds, java.lang.String _roleIds)

Rights

IRightMgr.getRights(int objType, int objId)

Rights

RightMgr.getRights(int objType, int objId)

static RightValue

AuthServer.getRightValue(CMSObj _currObj, CMSObj _currOperator)
获取当前操作权限值

RightValue

IRightMgr.getRightValue(CMSObj _currObj, CMSObj _currOperator)

RightValue

RightMgr.getRightValue(CMSObj _currObj, CMSObj _currOperator)

static RightValue

AuthServer.getRightValue(CMSObj _currObj, User _currOpUser)
获取当前权限值

RightValue

RightCacheMgr.getRightValue(int _objType, int _objId, int _oprType, int _oprId)

long

RightCacheMgr.getRightValue(int _objType, int _objId, int _oprType, int _oprId, long _lDefaultValue)

Roles

RoleMgr.getRoles()
获取系统中的所有角色集合

Roles

GroupRoleMgr.getRoles(Group _dstGroup, WCMFilter _filter)
获取指定组织的所有角色

Roles

UserMgr.getRoles(User _dstUser)
获取当前用户担任的所有角色

Roles

RoleMgr.getRolesForUser(User _user, WCMFilter _filter)
获取指定用户可见的角色

RoleUsers

RoleMgr.getRoleUsers(Role _theRole, WCMFilter _filter)
获取指定角色下的角色用户信息

RoleUsers

RoleMgr.getRoleUsers(User _theUser, WCMFilter _filter)
获取指定用户下的角色用户信息

Group

IDepartmentMgr.getRootDepartmentGroup()
获取描述组织结构的根组织

Group

DepartmentMgrImpl.getRootDepartmentGroup()

Roles

RoleMgr.getSpecialRolesOfUser(User _user, WCMFilter _filter)
获取指定用户上设置的特定角色

Roles

RoleMgr.getSystemRolesOfUser(User _user, int nSiteId, WCMFilter _filter)
获取指定用户在指定站点上设置的角色信息

Rights

UserMgr.getUserRightsOnWCMObj(int _nObjType)
获取当前用户在指定类型的对象上的权限集合

Users

GroupMgr.getUsers(Group _theGroup, WCMFilter _filter)
获取属于某组织的所有用户集合

Users

GroupMgr.getUsers(Group _theGroup, WCMFilter _filter, boolean _bContainsChildGrp)
获取指定组织所有的用户(用户组织关联对象),包含所有的子组织的用户

Users

RoleMgr.getUsers(Role _dstRole, int _nSiteId, WCMFilter _filter)
获取某角色在某站点下的所有用户集合

Users

RoleMgr.getUsers(Role _dstRole, WCMFilter _filter)
获取担任某角色的所有用户集合

Users

RoleMgr.getUsersBySpecailForUser(Role _dstRole, WCMFilter _filter)
获取当前登录用户可以查看的某特定角色的所有用户集合

Users

RoleMgr.getUsersBySystemRoleForUser(Role _dstRole, int _nSiteId, WCMFilter _filter)
获取当前登录用户可以查看的某系统级角色的所有用户集合

static boolean

AuthServer.hasAttributeRight(User _currUser)
判断当前用户对于系统属性是否具有进入权限

static boolean

AuthServer.hasExtendedRight(User _currUser)

static boolean

AuthServer.hasExtendedRight(User _currUser, int _nRightIndex)

static boolean

AuthServer.hasMgrDocSourceRight(User _currUser)
添加一个判断是否有管理文档来源的权限判断方法

static boolean

AuthServer.hasRight(CMSObj _operator, CMSObj _currObj, int _nRightIndex)

static boolean

AuthServer.hasRight(RightValue aRightValue, int _index)

static boolean

AuthServer.hasRight(User _currUser, CMSObj _currObj)
判断用户对特定对象是否有“访问权限”

static boolean

AuthServer.hasRight(User _currUser, CMSObj _objCurrent, int _index)
判断当前用户对于指定的频道对象是否具有指定索引的权限

static boolean

GroupAuthServer.hasRight(User _loginUser, Group group, int _nRightIndex)

boolean

GroupRightObjImpl.hasRight(User _currUser, int _nRightIndex)

boolean

IRightObj.hasRight(User _currUser, int _nRightIndex)
判断用户对于指定的对象是否具有指定的权限

static boolean

RoleAuthServer.hasRight(User _loginUser, Role _role, int _nRightIndex)

static boolean

AuthServer.hasRightInObjects(User _currUser, CMSBaseObjs _objects, int _index)

static boolean

AuthServer.hasRightOnSelf(User _currUser, CMSObj _objCurrent, int _index)

static boolean

AuthServer.hasRightOnSelf(User _currUser, int _nObjType, int _nObjId, int _index)
判断当前用户对指定的对象是否具有指定权限

static boolean

AuthServer.hasStatisticRight(User _currUser)

static boolean

AuthServer.hasStatisticRight(User _currUser, int _nRightIndex)

static boolean

AuthServer.hasSuperRight(User _currUser, CMSObj _currObj)
Created: 2004-11-25 17:27:12 Last Modified: 2004-11-25/2004-11-25 Description: class AuthServer.java 判断当前用户是否有特权(用户是管理员,对象创建者等) wenyh

void

RightHostLCListenerForInherit.inheritObjectMembers(Channel _oChannel)

void

NewRightSet.inheritRights(User _loginUser, IRightHost _rightHost, boolean _bDropOldRights)
继承父对象的权限

void

RightSet.inheritRights(User _loginUser, IRightHost _rightHost, boolean _bDropOldRights)
继承父对象的权限

boolean

ObjectMemberMgr.init()

boolean

RightCacheMgr.init()

boolean

GroupMgr.isAdministrator(Group _group, User _user, boolean _bContainAncestor)
判断某个用户是否为某个组织的组管理员

boolean

UserMgr.isAdminOfGroup(User _user)
判断指定用户是否在系统中担任组管理员

boolean

IDepartmentMgr.isDepartmentAdmin(User _user)
判断用户是否是所在用户组的管理员

boolean

DepartmentMgrImpl.isDepartmentAdmin(User _user)

boolean

RightCacheMgr.isExistsRight(int _nObjType, int _nObjId)

boolean

UserMgr.isManagerOfRole(User _user)
判断指定用户是否在系统中担任角色维护员

boolean

UserMgr.isManagerOfUser(User _user)
判断当前登录用户是否能够管理指定的用户

static boolean

AuthServer.isManagerOfUser(User _loginUser, User _dstUser)
判断当前用户loginUser是否可以管理用户_dstUser

boolean

RoleMgr.isRoleManagers(User _user)
判断指定用户是否为角色管理员

boolean

ObjectMemberMgr.isVisible(CMSObj _oOperator, int _nObjType, int _nObjId)

boolean

IObjectMemberMgr.isVisible(CMSObj _currOperator, int _nObjType, int _nObjId)
判断当前操作者对于指定对象是否可见

boolean

ObjectMemberMgr.isVisible(Group _oGroup, int _nObjType, int _nObjId)

boolean

IObjectMemberMgr.isVisible(Group _currGroup, int _nObjType, int _nObjId)
判断当前组织对于指定对象是否可见

boolean

ObjectMemberMgr.isVisible(Role _oRole, int _nObjType, int _nObjId)

boolean

IObjectMemberMgr.isVisible(Role _currRole, int _nObjType, int _nObjId)
判断当前角色对于指定对象是否可见

boolean

ObjectMemberMgr.isVisible(User _oUser, int _nObjType, int _nObjId)

boolean

IObjectMemberMgr.isVisible(User _currUser, int _nObjType, int _nObjId)
判断当前用户对于指定对象是否可见

boolean

GroupRightObjImpl.loadById(int _nId)

static IRightHost

AuthServer.makeRightHost(int _nHostType, int _nHostId)
通过指定的HostType和HostId构造IRightHost的实现

static IRightHost

RightHostFactory.makeRightHostFrom(CMSObj _oCMSObj)

static IRightHost

RightHostFactory.makeRightHostFrom(int _nHostType, int _nHostId)

static IRightObj

RightObjectFactory.makeRightObjectFrom(CMSObj _oCMSObj)

static IRightObj

RightObjectFactory.makeRightObjectFrom(int _nObjectType, int _nObjectId)

boolean

GroupMgr.moveUser(User _dstUser, Group _srcGroup, Group _dstGroup)
更改指定用户的组织

void

ObjectMemberMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

RightHostLCListenerForInherit.notifyOnAddObj(BaseObj _oObjAdded)

void

RightCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

ObjectMemberMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

RightCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ObjectMemberMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

RightCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

boolean

ObjectMemberMgr.reinit()

boolean

RightCacheMgr.reinit()

void

IDepartmentMgr.reload()
重新加载相关信息

void

DepartmentMgrImpl.reload()

boolean

GroupRoleMgr.removeGroup(Group _dstGroup, Role _theRole)

boolean

RoleMgr.removeUser(Role _theRole, int _nSiteId, User _dstUser)
将指定的用户从指定的角色和站点中删除

boolean

GroupMgr.removeUser(User _dstUser, Group _theGroup)
删除组织中的某个用户

boolean

RoleMgr.removeUser(User _dstUser, Role _theRole)
已过时。

boolean

UserMgr.resetPassword(User _dstUser)
系统管理员重设指定用户的密码为默认密码,用于密码恢复

boolean

UserMgr.resetPassword(User _dstUser, java.lang.String _sNewPassword)
重置用户密码为新密码

boolean

UserMgr.resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword)
重设指定用户的密码

boolean

NewRightSet.save()

Group

GroupMgr.save(Group _dstGroup)
保存组织（新建、编辑）

Role

RoleMgr.save(Role _currRole)
保存指定的角色

User

UserMgr.save(User _dstUser)
保存用户

Right

IRightMgr.saveRight(Right _saveRight)
保存权限

Right

RightMgr.saveRight(Right _saveRight)

static void

UpdUserScheduleCreator.scheduleUpdUserRelatedInfo(User userToBeDeleted, User user)

boolean

GroupMgr.setGroupManager(User _dstUser, Group _theGroup, boolean _isAdministrator)
设置组管理员(设置或取消指定用户的组管理员身份)

void

GroupRoleMgr.setGroups(Role role, Groups groups)
绑定角色role和组织groups的关联，同时将清除原来的关联

boolean

RightSet.setRights(User loginUser, IRightHost _rightHost, java.util.List _currRightList, boolean _bSetChildrenRight)

void

RoleMgr.setRoleUsers(Role role, int _nSiteId, Users _users)
绑定角色,站点和用户的关联，同时将清除原来的关联

void

RoleMgr.setSpecailRolesOfUser(User _user, Roles _roles)
设置用户的特定角色，同时将清除原来的特定角色d关联

static boolean

AuthServer.setSystemMgrRights(int _nObjId, java.util.List _currRightList)

void

RoleMgr.setSystemRolesOfUser(User _user, int _nSiteId, Roles roles)
设置用户在指定站点上的系统级角色，同时将清除原来的关联

void

IRightHost.validateCanDoSetRight(User _user)
判断指定的用户是否有权给当前对象设置权限

抛出 WCMException 的 com.trs.cms.auth.domain 中的构造方法

GroupRightObjImpl(int _nId)

GrpUserIdsMan(int _nGroupId)

RoleUserIdsMan(int _nRoleId)

com.trs.cms.auth.persistent 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.auth.persistent 中的方法

boolean

Group.addUser(int _addedUserId, User _opUser)
添加新的用户到该组

boolean

Group.addUser(int _addedUserId, User _opUser, boolean _isAdministrator)

boolean

Group.addUser(User _userToAdd, User _opUser)

boolean

Group.addUser(User _userToAdd, User _opUser, boolean _isAdministrator)
添加新的用户到该组

static User

User.createNewInstance()
产生当前对象[User]的实例

static Group

Group.createNewInstance()
产生当前对象[Group]的实例

static Role

Role.createNewInstance()
产生当前对象[Role]的实例

static RoleUser

RoleUser.createNewInstance()
产生当前对象[RoleUser]的实例

static ObjectMember

ObjectMember.createNewInstance()
产生当前对象[ObjectMember]的实例

static RightDef

RightDef.createNewInstance()
产生当前对象[RightDef]的实例

static Right

Right.createNewInstance()
产生当前对象[Right]的实例

static GroupRole

GroupRole.createNewInstance()
产生当前对象[GroupRole]的实例

static GroupUser

GroupUser.createNewInstance()
产生当前对象[GroupUser]的实例

static RightDefs

RightDefs.createNewInstance(User _currUser)
产生一个当前集合对象[RightDefs]的实例

static Users

Users.createNewInstance(User _currUser)
产生当前集合对象[Users]的实例

static Rights

Rights.createNewInstance(User _currUser)
产生当前集合对象[Rights]的实例

static GroupUsers

GroupUsers.creatNewInstance(User _currUser)
产生一个当前集合对象[GroupUsers]的实例

static RoleUsers

RoleUsers.creatNewInstance(User _currUser)
产生一个当前集合对象[RoleUsers]的实例

static GroupRoles

GroupRoles.creatNewInstance(User _currUser)
产生一个当前集合对象[RoleUsers]的实例

static Users

Users.findAdministrators()

static Right

Right.findBy(int _nObjType, int _nObjId, int _nOprType, int _nOprId)

static User

User.findById(int _nId)
提取指定ID的对象

static Group

Group.findById(int _nId)
提取指定ID的对象

static Role

Role.findById(int _nId)
提取指定ID的对象

static RoleUser

RoleUser.findById(int _nId)
提取指定ID的对象

static ObjectMember

ObjectMember.findById(int _nId)
提取指定ID的对象

static RightDef

RightDef.findById(int _nId)
提取指定ID的对象

static Right

Right.findById(int _nId)
提取指定ID的对象

static GroupRole

GroupRole.findById(int _nId)
提取指定ID的对象

static GroupUser

GroupUser.findById(int _nId)
提取指定ID的对象

static RightDefs

RightDefs.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Users

Users.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Rights

Rights.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static GroupUsers

GroupUsers.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static RoleUsers

RoleUsers.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static GroupRoles

GroupRoles.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static User

User.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Group

Group.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Role

Role.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static RoleUser

RoleUser.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ObjectMember

ObjectMember.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static RightDef

RightDef.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Right

Right.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static GroupRole

GroupRole.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static GroupUser

GroupUser.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ObjectMember

ObjectMember.findByMemberObj(int _nMemberType, int _nMemberId, int _nObjType, int _nObjId)

Users

Group.getAdministrator(User _opUser)
取用户所属组对象集合

Users

GroupAdminsCacheMgr.getAdmins(Group _group)
获取指定用户组的管理员集合

Users

AdministratorCacheMgr.getAdminUsers()

Users

IAdministratorCacheMgr.getAdminUsers()

Groups

Group.getChildren(User _currUser)
取组的子组集合

Groups

Group.getChildren(User _currUser, java.lang.String _sOrder)
获取按照指定的排序方式排序的组的子组集合

User

TrusteeInfo.getCrUserById()

Groups

User.getGroups()
取用户所属组对象集合

static Groups

Right.getGroupsWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight)
获取在指定对象上设置了权限（/没有设置权限）的角色集合

Rights

User.getMyRights(int _objType)
取用户在指定类型的操作对象上的权限集合

Rights

Role.getMyRights(int _objType)
取角色在指定类型的操作对象上的权限集合

RightValue

User.getMyRightValue(CMSObj _obj)
取用户在指定对象上的操作权限值

RightValue

Role.getMyRightValue(CMSObj _obj)
取角色在指定对象上的操作权限值

RightValue

User.getMyRightValue(int _objType, int _objId)
取用户在指定对象上的操作权限值

RightValue

Role.getMyRightValue(int _objType, int _objId)

CMSObj

Right.getOperator()
获取权限操作者对象（用户/角色）

Group

Group.getParent()
获取组的父对象（Group）

Roles

User.getRoles()
获取用户所属的特定角色以及作用于所有站点的角色.

Roles

RoleUserCacheMgr.getRoles(User _currUser, WebSite _currSite)

static Roles

Right.getRolesWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight)
获取在指定对象上设置了权限（/没有设置权限）的角色集合

static WebSite

RightValue.getSite(int _nObjType, int _nObjId)
由于角色和站点绑定，所以这个地方需要获取站点的id，将RightValue和站点依赖不太好，目前没有找到相应的解决办法, 除非每一个对象实现一个getHost的方法

User

TrusteeInfo.getTrustee()

static IUserCacheMgr

User.getUserCacheMgr()

Users

Group.getUsers(User _currUser)
取组内所有用户集合（Users）

Users

Role.getUsers(User _currUser)
取属于该角色的所有用户

Users

Group.getUsers(User _currUser, java.lang.String _sOrder)
获取按照一定排序方式取组内所有用户集合（Users）

static Users

Right.getUsersWithRight(User _currUser, int _objType, int _objId, boolean _blHasRight)
获取在指定对象上设置了权限（/没有设置权限）的集合用户

boolean

GroupAdminsCacheMgr.init()

boolean

RoleUserCacheMgr.init()

boolean

AdministratorCacheMgr.init()

boolean

UserCacheMgr.init()

boolean

GroupUserCacheMgr.init()

void

User.insert(User _currUser)
添加用户记录到数据库

void

TrusteeInfo.insert(User _currUser)
将对象数据写入数据库

void

RoleUser.insert(User _currUser)
将对象数据写入数据库

void

ObjectMember.insert(User _currUser)
将对象数据写入数据库

void

RightDef.insert(User _currUser)

void

GroupRole.insert(User _currUser)
将对象数据写入数据库

void

GroupUser.insert(User _currUser)
将对象数据写入数据库

boolean

User.isAdministrator()
判断用户是否是系统管理员

boolean

Group.isAdministrator(User _currUser)
判断用户是否是本组的管理员

boolean

User.isValid()
检查对象数据的有效性

boolean

Group.isValid()
检查对象数据的有效性

boolean

TrusteeInfo.isValid()
检验对象数据有效性

boolean

Role.isValid()
更新前检验数据是否有效

boolean

RoleUser.isValid()
检验对象数据有效性

boolean

ObjectMember.isValid()
检验对象数据有效性

boolean

RightDef.isValid()

boolean

Right.isValid()
效验数据的有效性

boolean

GroupRole.isValid()
检验对象数据有效性

boolean

GroupUser.isValid()
检验对象数据有效性

void

RightValue.load(Group _group, int _objType, int _objId)
载入角色在指定对象的权限值

void

RightValue.load(int _operatorType, int _operatorId, int _objType, int _objId)
载入指定操作者在指定操作对象的权限值

void

RightValue.load(Role _role, int _objType, int _objId)
载入角色在指定对象的权限值

void

RightValue.load(User _user, int _objType, int _objId)
载入用户在指定对象的权限值（综合了用户所属角色的权限）

void

RightValue.load(User _user, int _objType, int _objId, boolean _bIncludeGrpAndRole)

int

User.login(java.lang.String _password, java.lang.String _sRemoteAddr)
用户登录处理

void

GroupAdminsCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

RoleUserCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

AdministratorCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

GroupUserCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

GroupAdminsCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

RoleUserCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

AdministratorCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

UserCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

GroupUserCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

GroupAdminsCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

UserCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

RightDefs.open(int _nObjType, boolean _bIndexDesc)

static ObjectMembers

ObjectMembers.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ObjectMembers]

static RightDefs

RightDefs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[RightDefs]

static Users

Users.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Users]

static Rights

Rights.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Rights]

static Groups

Groups.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Groups]

static Roles

Roles.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Roles]

static GroupUsers

GroupUsers.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[GroupUsers]

static RoleUsers

RoleUsers.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[RoleUsers]

static GroupRoles

GroupRoles.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[RoleUsers]

boolean

GroupAdminsCacheMgr.reinit()

boolean

RoleUserCacheMgr.reinit()

boolean

AdministratorCacheMgr.reinit()

boolean

UserCacheMgr.reinit()

boolean

GroupUserCacheMgr.reinit()

boolean

User.setAddress(java.lang.String _address)
设置联系地址

boolean

TrusteeInfo.setCancel(boolean _bCancel)

boolean

TrusteeInfo.setCrTime(CMyDateTime _dtCrTime)
设置属性：CrTime

boolean

TrusteeInfo.setCrUserId(int _nCrUserId)
设置属性：CrUserId

boolean

User.setDeleted(boolean _bDeleted)
设置属性:ISDELETED

boolean

Group.setDesc(java.lang.String _desc)
设置组的描述

boolean

Role.setDesc(java.lang.String _desc)
设置角色描述

boolean

RightDef.setDesc(java.lang.String _desc)

boolean

ObjectMember.setDoOperation(boolean _bDoOperation)
设置属性：DoOperation

boolean

User.setEmail(java.lang.String _email)
设置用户Email 邮件地址，若有多个，用";"分割

boolean

Group.setEmail(java.lang.String _email)
设置组的邮件地址 说明：若有多个邮件地址，则用";"分割

boolean

Role.setEmail(java.lang.String _email)
设置角色Email地址

boolean

TrusteeInfo.setEndTime(CMyDateTime _dtEndTime)
设置属性：EndTime

boolean

GroupRole.setGroupId(int _nGroupId)
设置属性：GroupId

boolean

GroupUser.setGroupId(int _nGroupId)
设置属性：GroupId

boolean

Group.setGroupOrder(int _nOrder)
设置属性：GroupOrder

boolean

RightDef.setIndex(int _index)

boolean

GroupUser.setIsAdministrator(int _nIsAdministrator)
设置属性：IsAdministrator

boolean

ObjectMember.setMember(int _nMemberType, int _nMemberId)

boolean

ObjectMember.setMemberId(int _nMemberId)
设置属性：MemberId

boolean

ObjectMember.setMemberType(int _nMemberType)
设置属性：MemberType

boolean

User.setMobile(java.lang.String _mobile)
设置移动通讯联系地址

boolean

TrusteeInfo.setModule(int _nModule)
设置属性：Module

boolean

User.setMsgInterval(int _msgInterval)
获取用户信息刷新时间

boolean

User.setName(java.lang.String _name)
设置用户名

boolean

Group.setName(java.lang.String _name)
设置组的名称 要求：名称不重复 处理：名称区分大小写。

boolean

Role.setName(java.lang.String _name)
设置角色名称

boolean

RightDef.setName(java.lang.String _name)

boolean

User.setNickName(java.lang.String _nickName)
设置昵称

boolean

ObjectMember.setObj(int _nObjType, int _nObjId)

boolean

Right.setObject(CMSObj _obj)
设置操作对象（WCMObj）

boolean

Right.setObject(int _nObjectType, int _nObjectId)

boolean

ObjectMember.setObjId(int _nObjId)
设置属性：ObjId

boolean

Right.setObjId(int _objId)
设置操作对象（WCMObj）ID

boolean

ObjectMember.setObjType(int _nObjType)
设置属性：ObjType

boolean

RightDef.setObjType(int _nObjType)

boolean

Right.setObjType(int _objType)
设置操作对象（WCMObj）类型（定义在WCMTypes中）

boolean

Right.setOperator(CMSObj _operator)
设置权限操作者对象（用户或角色） 说明：仅添加时可用

boolean

Right.setOperator(int _nOperType, int _nOperId)

boolean

Right.setOperatorId(int _operatorId)
设置权限操作者（用户/角色）ID

boolean

Right.setOperatorType(int _operatorType)
设置权限操作者（用户/角色）类型(定义在WCMTypes)

boolean

Group.setParent(Group _parent)
设置父对象：仅新增模式下有效

boolean

Group.setParent(int _parentId)
设置父对象：仅新增模式下有效

boolean

User.setPassword(java.lang.String _password)
设置密码 密码长度不少于8个字符

boolean

User.setPasswordLev(int _nPasswordLev)
保存用户密码的安全级别

boolean

User.setPrice(int _nPrice)
设置用户个人的稿件单价

boolean

User.setPubMyInfo(boolean _bPubMyInfo)
设置是否公开个人信息

boolean

User.setReminderAnswer(java.lang.String _reminderAnswer)
设置找回密码时的答案

boolean

User.setReminderQuestion(java.lang.String _reminderQuestion)
设置找回密码时的问题

boolean

Role.setRemoveable(boolean _bRemoveable)
设置角色是否可以删除

boolean

Role.setRightValue(long _lRightValue)
设置角色的权限（可以做的所有操作）

boolean

RoleUser.setRoleId(int _nRoleId)
设置属性：RoleId

boolean

GroupRole.setRoleId(int _nRoleId)
设置属性：RoleId

boolean

Role.setRoleOrder(int _nOrder)
设置属性：RoleOrder

boolean

Role.setRoleRange(int _nRoleRange)
设置角色所属范围，默认为0，

boolean

Role.setRoleType(int _nRoleType)
设置角色所属类型，默认为0，

boolean

RoleUser.setSiteId(int _nSiteId)
设置属性：SiteId

boolean

TrusteeInfo.setStartTime(CMyDateTime _dtStartTime)
设置属性：StartTime

boolean

User.setStatus(int _status)
设置用户当前状态

boolean

TrusteeInfo.setStatus(int _nStatus)
设置属性：Status

boolean

Role.setSysDefined(boolean _bSysDefined)
设置角色系统预定义的属性

boolean

RightDef.setSysDefined(boolean _bSysDefined)

boolean

User.setTel(java.lang.String _tel)
设置联系电话

boolean

User.setTrueName(java.lang.String _trueName)
设置真实姓名

boolean

TrusteeInfo.setTrustee(int _nTrustee)
设置属性：Trustee

boolean

RoleUser.setUserId(int _nUserId)
设置属性：UserId

boolean

GroupUser.setUserId(int _nUserId)
设置属性：UserId

boolean

Right.setValue(long _lValue)
使用长整型数设定权限值

boolean

Right.setValue(RightValue _rightValue)
使用RightValue对象定权限值

boolean

Role.setViewable(boolean _bVeiwable)
设置角色是否在应用可见

boolean

User.setViewInterval(int _viewInterval)
设置ViewInterval:视图刷新时间（秒）

boolean

ObjectMember.setVisible(boolean _bVisible)
设置属性：Visible

void

User.update(User _currUser)

com.trs.cms.content 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.content 中的方法

boolean

CMSBaseObjs.canEdit()
检查当前元素是否可以修改；若可以修改，则锁定该元素

boolean

CMSBaseObjs.canEdit(int _nLockTime)
检查当前元素是否可以修改；若可以修改，则锁定该元素

static CMSBaseObjs

CMSBaseObjs.createInstance(User _currUser, java.lang.Class _classObjs)
产生指定集合对象的实例

static CMSBaseObjs

CMSBaseObjs.createInstance(User _currUser, java.lang.String _sObjsClassName)
产生指定集合对象的实例

static ExtendedField

ExtendedField.createNewInstance()
产生当前对象[ExtendedField]的实例

int

CMSObj.delete()
建议使用delete(User)

int

CMSObj.delete(User _currUser)
从数据中删除对象信息

int

ExtendedField.delete(User _currUser)
删除扩展字段对象，重载父类接口：删除该对象之前，必须确保无任何频道使用该字段

static ExtendedField

ExtendedField.findById(int _nId)
提取指定ID的对象

static DefaultObj

DefaultObj.findById(int _nId, java.lang.String _sTableName, java.lang.String _sIdFieldName)
提取指定ID的对象

static ExtendedField

ExtendedField.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static CMSBaseObjs

CMSBaseObjs.findWCMObjsByIds(User _currUser, java.lang.Class _classObjs, java.lang.String _sObjIds)

static CMSBaseObjs

CMSBaseObjs.findWCMObjsByIds(User _currUser, java.lang.String _sObjsClassName, java.lang.String _sObjIds)
根据ID序列获取一个指定的集合

static java.lang.String

HTMLContent.getBodyContent(java.lang.String _sHTMLContent)

int

ExtendedField.getDefaultValueAsInt(int _default)
取整型默认值

java.util.List

HTMLContent.getFiles()
获取HTML内容中的所有文件

DataType

ExtendedField.getType()
获取扩展字段类型对象

java.lang.String

ExtendedField.getTypeDesc()

java.util.List

HTMLContent.getWCMFiles()
获取HTML内容中的WCM文件

void

CMSObj.insert(User _currUser)
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

void

ExtendedField.insert(User _currUser)
添加对象到数据库，重载WCMObj接口

boolean

ExtendedField.isValid()
检查数据的有效性

boolean

ICMSObjSubstanceContent.loadById(int _nId)
Loads the content data by the specified id.

void

ICMSObjSubstanceContent.makeFrom(CMSObj _cmsObj)
Makes this content from a CMS object.

static CMSBaseObjs

CMSBaseObjs.openWCMObjs(User _currUser, java.lang.Class _objsClass, WCMFilter _filter)
根据指定的Filter打开指定的集合

static CMSBaseObjs

CMSBaseObjs.openWCMObjs(User _currUser, java.lang.String _sObjsClassName, WCMFilter _filter)
根据指定的Filter打开指定的集合

static ExtendedFields

ExtendedFields.openWCMObjs(User _currUser, WCMFilter _filter)

static DefaultObjs

DefaultObjs.openWCMObjs(User _currUser, WCMFilter _filter, java.lang.String _sDbTableName, java.lang.String _sIdFieldName)
通过指定一个Filter获取当前集合[DefaultObjs]

java.lang.String

HTMLContent.parseHTMLContent(java.lang.String _sImgSrcPre)

java.lang.String

HTMLContent.parseHTMLContentWihtMultImgPre(java.lang.String[] _pImgSrcPre)

void

CMSObj.save()

void

CMSObj.save(User _currUser)
对象保存自己

static java.lang.String

HTMLContent.saveHtmlContent(java.lang.String _sHTMLContent)

static java.lang.String

HTMLContent.saveHtmlContent(java.lang.String _sHTMLContent, boolean _bRecopyAllPics, boolean _bDownloadA)

static java.lang.String

HTMLContent.saveHTMLContentFromOut(java.lang.String _sHTMLContent, java.util.HashMap _hmOutFile)
以外部资源为Src，保存HTMLContent中的资源

boolean

ExtendedField.setAttribute(java.lang.String _attribute)
设置扩展字段的扩展属性

boolean

CMSObj.setCrUser(java.lang.String _crUserName)
共用接口：属性创建用户CrUser写操作 说明：子类可以通过重载禁止使用

boolean

CMSObj.setCrUser(User _crUser)

boolean

ExtendedField.setDesc(java.lang.String _sDesc)
设置扩展字段描述信息

boolean

ExtendedField.setName(java.lang.String _sName)
设置扩展字段名称

boolean

ExtendedField.setTableName(java.lang.String _tableName)
设置扩展字段所属数据表名称

boolean

ExtendedField.setType(java.lang.String _typeName, int _maxLength)

boolean

ExtendedField.setType(java.lang.String _typeName, int _maxLength, boolean _bNullable, java.lang.String _sDefaultValue)
设置扩展字段数据类型

boolean

ExtendedField.setType(java.lang.String _typeName, int _maxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)

static CMSObj

WCMObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, CMSObj _oWCMObj)
解析传入的XML内容，生成传入WCMOBJ对象。

static CMSObj

WCMObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, User _loginUser, int _nObjId, java.lang.Class _oWCMObjClass)
解析传入的XML内容，生成传入WCMOBJ对象。

static void

WCMObjHelper.unlock(int _nObjType, int _nObjId, User _unlockerUser)
指定的用户给指定的对象解锁

void

CMSObj.update(User _user)
更新修改。

void

CMSObj.validCanDeleteAndLock(User _user)

void

CMSObj.validCanEditAndLock(User _user)

void

CMSObj.validCanEditAndLock(User _user, int _nLockTimeOut)

com.trs.cms.process 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.process 中的方法

FlowDoc

FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode)

FlowDoc

IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode)
自动将当前轨迹呈送到下一个节点

FlowDoc

FlowServerImpl.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers)

FlowDoc

IFlowServer.autoToNextNode(FlowContext _context, FlowNode _nextNode, Users _toUsers)
自动将当前轨迹呈送到下一个节点

boolean

FlowServerImpl.backTo(FlowContext _oFlowContext)

boolean

IFlowServer.backTo(FlowContext _oFlowContext)
要求返工

void

IFlowContent.cancelUpdate(User user)
取消本次更新

boolean

IFlowContent.canEdit(User _currUser)
判断当前操作用户是否可以对当前流转的内容进行修改

static FlowDoc

FlowServerImpl.convertToFlowDocNotFlags(FlowDoc _flowDoc, int[] _pFlags)

boolean

FlowServerImpl.doAccept(FlowContext _oFlowContext)

boolean

IFlowServer.doAccept(FlowContext _oFlowContext)
签收

boolean

FlowServerImpl.doReceive(FlowContext _oFlowContext)

boolean

IFlowServer.doReceive(FlowContext _oFlowContext)
接收

FlowNode

IFlowCacheMgr.findFlowNodeByName(int _nFlowId, java.lang.String _sNodeName)

boolean

FlowServerImpl.forceEnd(FlowContext _oFlowContext)

boolean

IFlowServer.forceEnd(FlowContext _oFlowContext)
强制结束

static Users

FlowServer.getConsignUsers(User _operator, int _nModule)
获得指定模块的所有的委托人，默认为公文管理(TrusteeInfo.MODULE_FLOW)

java.lang.String

IFlowContent.getContentAddEditPage()
获取内容的编辑页面

java.lang.String

IFlowContent.getContentShowPage()
获取内容的查看页面

User

IFlowContent.getCrUser()

int

FlowServer.getCurrFlowFlag(int contentType, int contentId)

java.lang.String

IFlowContent.getDeletePage()

java.lang.String

IFlowContent.getDesc()
获取当前流转内容的简要描述

IFlowContent[]

FlowServerImpl.getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext)

IFlowContent[]

IFlowServer.getFlowContentsDoneByUser(QueryFlowDocContext _oQueryFlowDocContext)
获取指定用户已经处理过的内容

IFlowContent[]

FlowServerImpl.getFlowContentsDoneByUser(User _currUser)

IFlowContent[]

IFlowServer.getFlowContentsDoneByUser(User _currUser)
获取指定用户已经处理过的内容

IFlowContent[]

FlowServerImpl.getFlowContentsDoneByUser(User _currUser, CPager _cpager)

IFlowContent[]

IFlowServer.getFlowContentsDoneByUser(User _currUser, CPager _cpager)
获取指定用户已经处理过的内容

IFlowContent[]

FlowServerImpl.getFlowContentsInFlow(Flow _flow)

IFlowContent[]

IFlowServer.getFlowContentsInFlow(Flow _flow)
获取在指定流程中正在流转的内容

IFlowContent[]

FlowServerImpl.getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext)

IFlowContent[]

IFlowServer.getFlowContentsOfUser(QueryFlowDocContext _oQueryFlowDocContext)
获取指定用户可以处理的内容

IFlowContent[]

FlowServerImpl.getFlowContentsOfUser(User _currUser)

IFlowContent[]

IFlowServer.getFlowContentsOfUser(User _currUser)
获取指定用户可以处理的内容

IFlowContent[]

FlowServerImpl.getFlowContentsOfUser(User _currUser, CPager _cpager)

IFlowContent[]

IFlowServer.getFlowContentsOfUser(User _currUser, CPager _cpager)
获取指定用户可以处理的内容

IFlowContent[]

FlowServerImpl.getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext)

IFlowContent[]

IFlowServer.getFlowContentsStartByUser(QueryFlowDocContext _oQueryFlowDocContext)
获取指定用户已经启动的内容

IFlowContent[]

FlowServerImpl.getFlowContentsStartByUser(User _currUser)

IFlowContent[]

IFlowServer.getFlowContentsStartByUser(User _currUser)
获取指定用户已经启动的内容

IFlowContent[]

FlowServerImpl.getFlowContentsStartByUser(User _currUser, CPager _cpager)

IFlowContent[]

IFlowServer.getFlowContentsStartByUser(User _currUser, CPager _cpager)
获取指定用户已经启动的内容

FlowDoc

FlowServer.getFlowDoc(IFlowContent _content)
取指定文档对应的FlowDoc对象

FlowDocs

FlowServerImpl.getFlowDocs(IFlowContent _content, WCMFilter _extrFilter)

FlowDocs

IFlowServer.getFlowDocs(IFlowContent _content, WCMFilter _extrFilter)
获取指定内容的流转轨迹

FlowDocs

FlowServer.getFlowDocs(User _operator, int _nFlag, WCMFilter _filter)

FlowDocs

FlowServer.getFlowDocsOfContent(int contentType, int contentId)

static FlowServer

FlowServer.getFlowServer()

FlowNodes

FlowServerImpl.getNextFlowNodes(FlowDoc _currFlowDoc, boolean _bIsResubmit)

FlowNodes

IFlowServer.getNextFlowNodes(FlowDoc _currFlowDoc, boolean _bIsResubmit)
获取当前轨迹的下一个处理节点

Flow

IFlowContent.getOwnerFlow()
获取当前所属对象的工作流对象

ContentProcessInfo

FlowServerImpl.getProcessInfoOfContent(IFlowContent _content)

ContentProcessInfo

IFlowServer.getProcessInfoOfContent(IFlowContent _content)
获取指定内容的流转情况

java.lang.String

IFlowContent.getProperty(java.lang.String _sName)
获取指定属性的名称

java.lang.String

IFlowContent.getPublishPage()

java.lang.String

IFlowContent.getStatusDesc()
获取状态的描述

int

IFlowContent.getStatusId()

CMSObj

IFlowContent.getSubinstance()
获取流转内容关联的对象

int

IFlowContent.getSubinstanceId()
获取当前流转内容的ID

FlowDocs

FlowServer.getSubmitFlowDocs(User _operator, WCMFilter _filter)

boolean

FlowServer.isCanInFlow(IFlowContent _content)

static FlowDoc

FlowServerImpl.lookupRealBackFlowDocAgain(FlowDoc _flowDoc)

static IFlowContent

FlowContentFactory.makeFlowContent(CMSObj _substance)

static IFlowContent

FlowContentFactory.makeFlowContent(int _nContentType, int _nContentId)

static java.lang.String

FlowEngineHelper.makeSeperateComments(FlowDoc _currFlowDoc)
产生并联审批结束时后合并的处理意见

static java.lang.String

FlowEngineHelper.makeTogetherComments(int _nParentFlowDocId)
产生合并后的处理意见

boolean

FlowServerImpl.refuse(FlowContext _oFlowContext)

boolean

IFlowServer.refuse(FlowContext _oFlowContext)
拒绝

FlowDoc

FlowServer.removeFlowDoc(IFlowContent _doc)

FlowDoc

FlowServer.removeFlowDoc(IFlowContent _doc, User _currUser)
从FlowServer移去指定的FlowDoc对象

FlowDoc

FlowServer.removeFlowDoc(int _nObjType, int _nObjId)

FlowDoc

FlowServer.removeFlowDoc(int _nObjType, int _nObjId, User _currUser)
从FlowServer移去指定的FlowDoc对象

boolean

FlowServerImpl.resubmitTo(FlowContext _oFlowContext)

boolean

IFlowServer.resubmitTo(FlowContext _oFlowContext)
重新指派

void

IFlowContent.setSubinstance(CMSObj _subinstance)

void

IFlowContent.setSubinstance(int _nSubinstanceId)
设置当前Content的关联ID

FlowDoc

FlowServer.startContentInFlow(User _currUser, IFlowContent _doc)

FlowDoc

FlowServer.startContentInFlow(User _currUser, IFlowContent _content, java.lang.String _sPostDesc)
为文档对象添加新的FlowDoc对象，使文档进入工作流流转

void

FlowServer.submitAgain(User user, int flowDocId, java.lang.String opinion)

FlowDoc

FlowServer.submitBack(User _currUser, IFlowContent _doc, java.lang.String _sPostDesc)

FlowDoc

FlowServer.submitBack(User _currUser, IFlowContent _content, java.lang.String _sOpinion, int _nStatusId)
将文档返回到上一个节点，并返回给指定的用户

boolean

FlowServerImpl.submitTo(FlowContext _context)

boolean

IFlowServer.submitTo(FlowContext _oFlowContext)
处理内容

FlowDoc

FlowServer.submitTo(FlowParamers _currParamers)
按照指定的方式处理文档

static void

FlowingDocOptMarkScouter.updateOperationMark(FlowContext _context)

static void

FlowingDocOptMarkScouter.updateOperationMark(FlowContext _context, java.lang.String _sPreOptValue)

static void

FlowingDocOptMarkScouter.updatePreOperationMark(FlowContext _context, java.lang.String _sPreOptValue)

void

IFlowContent.updateStatus(User user, int statusId)
更新当前内容的工作流状态

com.trs.cms.process.config 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.process.config 中的方法

Group

ToUsersCreatorConfig.getGroupRange(FlowContext _context)

Users

ToUsersCreatorConfig.getToUsers(FlowContext _context)
根据当前的配置获取处理者

void

ActionHandlerConfig.setClassName(java.lang.String className)

void

ToUsersCreatorConfig.setClassName(java.lang.String className)

void

ConditionHandlerConfig.setClassName(java.lang.String className)

void

FlowContentTypeConfig.setClassName(java.lang.String className)

com.trs.cms.process.definition 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.process.definition 中的方法

int

FlowEmployMgr.clearEmploysOfEmployer(BaseObj _employer)
clear all the employ records of the specified element

int

FlowEmployMgr.clearEmploysOfEmployer(int _nEmployerType, int _nEmployerId)
clear all the employ records of the specified element

int

FlowEmployMgr.clearEmploysOfFlow(Flow _flow)
clear all the employ records of the specified flow

int

FlowEmployMgr.clearEmploysOfFlow(int _nFlowId)
clear all the employ records of the specified flow

static FlowCondition

FlowCondition.createNewInstance()
产生当前对象[FlowCondition]的实例

static FlowAction

FlowAction.createNewInstance()
产生当前对象[FlowAction]的实例

static FlowEmploy

FlowEmploy.createNewInstance()
产生当前对象[FlowEmploy]的实例

static FlowNode

FlowNode.createNewInstance()
产生当前对象[FlowNode]的实例

static FlowdocLog

FlowdocLog.createNewInstance()
产生当前对象[FlowdocLog]的实例

static FlowNodeField

FlowNodeField.createNewInstance()
产生当前对象[FlowNodeField]的实例

static Flow

Flow.createNewInstance()
产生当前对象[Flow]的实例

static FlowRule

FlowRule.createNewInstance()
产生当前对象[FlowRule]的实例

void

FlowMgr.delete(Flow _currFlow)

int

FlowNode.delete(User _currUser)
重载父类delete函数，删除与工作流节点相关的信息（流转中的文档、节点操作者、分支等）

int

Flow.delete(User _currUser)
重载父类delete函数，删除与工作流相关的信息（流转中的文档、节点、频道中工作流的设置等）

static FlowCondition

FlowCondition.findById(int _nId)
提取指定ID的对象

static FlowAction

FlowAction.findById(int _nId)
提取指定ID的对象

static FlowEmploy

FlowEmploy.findById(int _nId)
提取指定ID的对象

static FlowNode

FlowNode.findById(int _nId)
提取指定ID的对象

static FlowdocLog

FlowdocLog.findById(int _nId)
提取指定ID的对象

static FlowNodeField

FlowNodeField.findById(int _nId)
提取指定ID的对象

static Flow

Flow.findById(int _nId)
提取指定ID的对象

static FlowRule

FlowRule.findById(int _nId)
提取指定ID的对象

static FlowCondition

FlowCondition.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowAction

FlowAction.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowEmploy

FlowEmploy.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowNode

FlowNode.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowdocLog

FlowdocLog.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowNodeField

FlowNodeField.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Flow

Flow.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowRule

FlowRule.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowNode

FlowNode.findByName(int _nFlowId, java.lang.String _sNodeName)

FlowNode

FlowCacheMgr.findFlowNodeByName(int _nFlowId, java.lang.String _sNodeName)

static FlowRules

FlowRules.findOf(User _currUser, CMSObj _host)
根据Host获取相关的规则

static FlowNodeFields

FlowNodeFields.findOf(User _currUser, FlowNode _node)

static FlowRules

FlowRules.findOf(User _currUser, int _nHostType, int _nHostId)
根据Host获取相关的规则

FlowActions

FlowRule.getActions(User _currUser)
获取规则中设定的所有操作

FlowNodeBranchs

FlowNode.getBranchs(User _currUser)
取得节点上的所有工作流分支集合

FlowNodeBranch

FlowNode.getBranchTo(User _currUser, FlowNode _nextNode)
获得当前节点到指定节点的分支

BaseObjs

FlowEmployMgr.getChannelsUseingFlow(Flow _flow, BaseObjs _baseObjects, int _nEmployerType, java.lang.String _sTableName, WCMFilter _extraFilter)
获取使用指定工作的指定类型的对象

FlowConditions

FlowRule.getConditions(User _currUser)
获取规则中设定的所有条件

Flows

FlowEmployMgr.getEmployedFlows(BaseObj _employer)
get the flows collection employed by the publish element.

FlowEmploys

FlowEmployMgr.getEmployers(Flow _flow, WCMFilter _filter)
get the employers who use the specified flow.

FlowEmploys

FlowEmployMgr.getEmploysOf(BaseObj _employer)
Returns the employ records of the specified employer, which may be a folder or a content.

FlowEmploys

FlowEmployMgr.getEmploysOfEmployer(int _nEmployerType, int _nEmployerId)
Returns the employ records of the specified employer, which may be a folder or a content.

FlowNode

Flow.getEndNode()
获取结束节点

Flow

FlowEmploy.getFlow()

Flow

FlowNode.getFlow()
节点所在工作流对象

Flow

FlowEmployMgr.getFlow(BaseObj _employer)
get the detail flow of the specified element.

FlowNodes

Flow.getFlowNodes(User _currUser)
取得工作流节点集合

static java.lang.String

FlowOptMarkEnumParser.getFlowOptMarkEnum(Flow _flow)

Groups

Flow.getMonitorGroups(User _currUser)
取工作流的监控用户组

Users

Flow.getMonitorUsers(User _currUser)
取工作流的监控用户

FlowNode

FlowNodeBranch.getNextNode(User _currUser)
取下一个节点对象

FlowNodes

FlowNode.getNextNodes(User _currUser)
获取下一个节点集合

FlowNodes

FlowNode.getNextNodes(User _currUser, WCMFilter _filter)

FlowNode

FlowNodeBranch.getNode()
获取第一个节点对象

Groups

FlowNode.getOperGroups(User _currUser)
取节点上的操作用户组

Users

FlowNode.getOperUsers(User _currUser)
取节点上的操作用户集合

Users

FlowNode.getOperUsers(User _currUser, boolean _bAll)

Users

FlowNode.getOperUsers(User _currUser, boolean _bAll, java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sOrder)
返回节点上定义的用户

BaseObj

Flow.getOwner()
获取工作流所属的对象

FlowRule[]

IFlowRuleCacheServer.getRules(FlowNode _currNode, int _nRuleType)
获取定义在指定节点上指定类型的规则

FlowRule[]

FlowRuleCacheServerImpl.getRules(int _nHostType, int _nHostId, int _nRuleType)

FlowRule[]

IFlowRuleCacheServer.getRules(int _nHostType, int _nHostId, int _nRuleType)
获取在指定对象上定义的指定类型的规则

FlowNode

Flow.getStartNode()
获取起始节点

Status

FlowNodeBranch.getStatus()
获取文档经过此分支时自动改变后的状态

boolean

FlowCacheMgr.init()

boolean

FlowEmployCacheMgr.init()

void

FlowCondition.insert(User _currUser)
将对象数据写入数据库

void

FlowAction.insert(User _currUser)
将对象数据写入数据库

void

FlowEmploy.insert(User _currUser)
将对象数据写入数据库

void

FlowNode.insert(User _currUser)
重载父类的insert函数，以便设置产生时间

void

FlowdocLog.insert(User _currUser)
将对象数据写入数据库

void

FlowNodeField.insert(User _currUser)
将对象数据写入数据库

void

FlowRule.insert(User _currUser)
将对象数据写入数据库

boolean

FlowNode.isEndNode()
判断该节点是否为所在工作流的结束节点

boolean

FlowNode.isStartNode()
判定该节点是否为所在工作流的起始节点

boolean

FlowNodeBranch.isValid()
实现父类的isValid函数，进行数据的效验

boolean

FlowCondition.isValid()
检验对象数据有效性

boolean

FlowAction.isValid()
检验对象数据有效性

boolean

FlowEmploy.isValid()
检验对象数据有效性

boolean

FlowNode.isValid()
实现父类的isValid函数，进行数据的效验

boolean

FlowdocLog.isValid()
检验对象数据有效性

boolean

FlowNodeField.isValid()
检验对象数据有效性

boolean

Flow.isValid()
检查对象数据是否有效

boolean

FlowRule.isValid()
检验对象数据有效性

void

FlowCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

FlowEmployCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

FlowEmployerLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

RuleHostLCListnerForCache.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

FlowCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

FlowEmployCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

FlowCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

FlowEmployCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

static FlowEmploys

FlowEmploys.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowEmploys]

static FlowActions

FlowActions.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowActions]

static FlowRules

FlowRules.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowRules]

static Flows

Flows.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Flows]

static FlowConditions

FlowConditions.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowConditions]

static FlowNodes

FlowNodes.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowNodes]

static FlowNodeFields

FlowNodeFields.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowNodeFields]

static FlowdocLogs

FlowdocLogs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowdocLogs]

static FlowNodeBranchs

FlowNodeBranchs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowNodeBranchs]

boolean

FlowCacheMgr.reinit()

boolean

FlowEmployCacheMgr.reinit()

void

FlowRuleCacheServerImpl.reloadRuleCache(BaseObj _host)

void

IFlowRuleCacheServer.reloadRuleCache(BaseObj _host)
重新装载指定对象(工作流/节点)的规则缓冲

void

IFlowRuleCacheServer.removeRuleCache(BaseObj _host)
删除指定对象(工作流/节点)的规则缓冲

boolean

FlowdocLog.setActionDesc(java.lang.String _sActionDesc)
设置属性：ActionDesc

boolean

FlowdocLog.setActionFlag(int _nActionFlag)
设置属性：ActionFlag

boolean

Flow.setAttribute(java.lang.String _sAttribute)

boolean

FlowdocLog.setBranchId(int _nBranchId)
设置属性：BranchId

boolean

FlowNode.setCeneterX(int _nCenterX)
设置X坐标（用于可视化编辑）

boolean

FlowNode.setCeneterY(int _nCenterY)
设置Y坐标（用于可视化编辑）

boolean

FlowdocLog.setChannelId(int _nChannelId)
设置属性：ChannelId

boolean

FlowNode.setDesc(java.lang.String _desc)
设置节点描述

boolean

Flow.setDesc(java.lang.String _desc)
设置工作流描述

boolean

FlowNode.setDocActions(int _actions)
使用整型值设置节点上允许的操作

boolean

FlowNode.setDocActions(int _actionType, boolean _bCanDo)
设定指定类型的文档操作许可

boolean

FlowEmploy.setEmployer(BaseObj _employer)
set the employer

boolean

FlowEmploy.setEmployer(int _nType, int _nId)
set the employer

void

FlowEmployMgr.setEmployersOfFlow(User _loginUser, int _nFlowId, int _nEmployerType, int[] _pEmployerIds)
批量维护指定工作流的配置关系

boolean

Flow.setEndNodeName(java.lang.String _sNodeName)
设置结束节点名称

boolean

FlowNodeField.setFieldDesc(java.lang.String _sFieldDesc)
设置属性：FieldDesc

boolean

FlowNodeField.setFieldName(java.lang.String _sFieldName)
设置属性：FieldName

boolean

FlowNodeField.setFieldType(int _nFieldType)
设置字段类型,Field/Group/View

void

FlowEmployMgr.setFlow(BaseObj _employer, int _nFlowId)
set the flow of the specified employer.

boolean

FlowEmploy.setFlow(Flow _flow)
set the flow used

boolean

FlowNode.setFlow(Flow _flow)
设置节点所在工作流

boolean

FlowEmploy.setFlow(int _nFlowId)
设置属性：FlowId

boolean

FlowNode.setFlow(int _flowId)
设置节点所在工作流

void

FlowEmployMgr.setFlow(int _nEmployType, int _nEmployId, int _nFlowId)

boolean

FlowdocLog.setFlowdocId(int _nFlowdocId)
设置属性：FlowdocId

boolean

FlowNodeField.setFlowId(int _nFlowId)
设置属性：FlowId

boolean

FlowCondition.setHandler(java.lang.Class _class)

boolean

FlowAction.setHandler(java.lang.Class _class)

boolean

FlowCondition.setHandler(java.lang.String _sHandler)
设置属性：Handler

boolean

FlowAction.setHandler(java.lang.String _sHandler)
设置属性：Handler

boolean

FlowRule.setHostId(int _nHostId)
设置属性：HostId

boolean

FlowRule.setHostType(int _nHostType)
设置属性：HostType

boolean

FlowCondition.setIsAndOperator(boolean _bIsAndOperator)
设置属性：LogicOperator

boolean

FlowNode.setName(java.lang.String _name)
设置节点名称

boolean

Flow.setName(java.lang.String _name)
设置工作流名称

boolean

FlowRule.setName(java.lang.String _sName)
设置属性：Name

boolean

FlowNode.setNeedPostTogether(boolean _bNeed)
设置是否需要会签属性

boolean

FlowNodeBranch.setNextNodeName(java.lang.String _NextName)
设置下一个节点名称

boolean

FlowNodeBranch.setNode(FlowNode _node)
设置第一个节点

boolean

FlowNodeBranch.setNode(int _nNodeId)
设置第一个节点

boolean

FlowNodeField.setNodeId(int _nNodeId)
设置属性：NodeId

boolean

FlowNodeBranch.setNotify(long _notify)
设置通知方式

boolean

FlowNodeBranch.setNotifyBy(int _notifyType, boolean _bValue)
设定指定的通知方式

boolean

FlowdocLog.setObjId(int _nObjId)
设置属性：ObjId

boolean

FlowdocLog.setObjType(int _nObjType)
设置属性：ObjType

boolean

FlowCondition.setOrder(int _nOrder)
设置属性：Order

boolean

FlowAction.setOrder(int _nOrder)
设置属性：Order

boolean

FlowRule.setOrder(int _nOrder)
设置属性：Order

boolean

Flow.setOwner(int _nOwnerType, int _nOwnerId)

boolean

Flow.setOwnerId(int _nOwnerId)

boolean

Flow.setOwnerType(int _nOwnerType)

boolean

FlowCondition.setParamName(java.lang.String _sParamName)
设置属性：ParamName

boolean

FlowAction.setParams(java.lang.String _sParams)
设置属性：Params

boolean

FlowCondition.setParamValue(java.lang.String _sParamValue)
设置属性：ParamValue

boolean

FlowdocLog.setPostUser(java.lang.String _sPostUser)
设置属性：PostUser

boolean

FlowNodeField.setReadField(boolean _bReadField)
设置字段为可读

boolean

FlowCondition.setRelationOperator(java.lang.String _sRelationOperator)
设置属性：RelationOperator

boolean

FlowCondition.setRuleId(int _nRuleId)
设置属性：RuleId

boolean

FlowAction.setRuleId(int _nRuleId)
设置属性：RuleId

boolean

FlowdocLog.setSiteId(int _nSiteId)
设置属性：SiteId

boolean

FlowdocLog.setStarting(boolean _bStarting)
设置属性：Starting

boolean

Flow.setStartNodeName(java.lang.String _sNodeName)
设置起始节点名称

boolean

FlowNodeBranch.setStatus(int _statusId)
设置文档经过此分支时自动改变后的状态

boolean

FlowNodeBranch.setStatus(Status _status)
设置文档经过此分支时自动改变后的状态

void

FlowNode.setToFirst(boolean _toFirst)

boolean

FlowRule.setType(int _nType)
设置属性：Type

boolean

FlowCondition.setUnitValue(java.lang.String _sUnitValue)
设置属性：UnitValue

boolean

FlowdocLog.setUserGroupId(int _nUserGroupId)
设置属性：UserGroupId

boolean

FlowNode.setWorkModal(int _nWorkModal)
设置节点上的流转模式

boolean

FlowNodeField.setWriteField(boolean _bWriteField)
设置字段为可写

void

FlowNodeBranch.update(User _user)
重载父类的update函数，实现下一个节点修改的同步

com.trs.cms.process.engine 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.process.engine 中的方法

boolean

FlowDoc.addToUser(int _userId)
添加呈送人员

boolean

FlowDoc.addToUser(User _user)
添加呈送人员

boolean

ContentProcessInfo.canInFlow()

boolean

ContentProcessInfo.canReInFlow()

static IFlowContent

FlowContentHelper.createFlowContent(CMSObj _subinstance)

static IFlowContent

FlowContentHelper.createFlowContent(int _nObjType, int _nObjId)

java.lang.String

IInitValueCreator.createInitValue(FlowContext _oFlowContext)
根据当前上下文信息产生初始值

static FlowContentConfig

FlowContentConfig.createNewInstance()
产生当前对象[FlowContentConfig]的实例

static FlowDoc

FlowDoc.createNewInstance()
产生当前对象[FlowDoc]的实例

Users

IToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)
根据当前上下文信息产生处理者信息

boolean

IActionHandler.execute(ExecuteContext _context, FlowAction _action)

static void

RuleExecuteHelper.executeRules(ExecuteContext _oExecContext, FlowRule[] _pRules)

static FlowContentConfig

FlowContentConfig.findById(int _nId)
提取指定ID的对象

static FlowDoc

FlowDoc.findById(int _nId)
提取指定ID的对象

static FlowDocs

FlowDocs.findByIdsOfDealer(User _currUser, java.lang.String _sIds, User _dealer)
根据处理者或者与其相关的FlowDocs

static FlowDocs

FlowDocs.findByIdsOfPoster(User _currUser, java.lang.String _sIds, User _poster)

static FlowContentConfig

FlowContentConfig.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowDoc

FlowDoc.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FlowDocs

FlowDocs.findOfContent(User _currUser, int _nContentType, int _nContentId, WCMFilter _extraFilter)
获取与指定内容相关的轨迹

FlowNodeBranch

FlowParamers.getBranch()

FlowNodeBranch

FlowContext.getBranch()
获取当前操作轨迹的分支

FlowNodeBranch

FlowDoc.getBranchComeFrom(User _currUser)
获取文档流转到当前状态经过的分支

long

FlowContext.getBranchSerialNum()

FlowDocs

FlowDoc.getChildren(User _currUser, WCMFilter _filter)
获取当前轨迹的子轨迹列表

Flow

ContentProcessInfo.getContentFlow()

FlowContext

FlowNextBranchInfo.getCurrFlowContext()

FlowNode

ExecuteContext.getCurrNode()
获取当前所处节点

FlowNode

FlowContext.getCurrNode()

static Users

FlowUserHelper.getDeptMgrsByGrpIds(java.lang.String _sGroupIds)
获取指定部门的部门经理(管理员)

static Users

FlowUserHelper.getDeptMgrsByGrpName(java.lang.String _sGroupName)
获取指定部门的部门经理(管理员)

static Users

FlowUserHelper.getDeptMgrsOfUserx(User _user)
获取用户所属部门的部门经理(管理员)

IFlowContent

FlowContentConfig.getFlowContent()

IFlowContent

ExecuteContext.getFlowContent()
获取当前正在处理的内容

IFlowContent

FlowContext.getFlowContent()

IFlowContent

FlowDoc.getFlowContent()

Group

AbstractToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)

Group

IToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)
限定了用户选择范围（在特定组内选择）

FlowNode

FlowDoc.getNode()
获取所在的节点对象

java.lang.String

FlowContext.getNotifyTypes()

java.lang.Class

FlowContentConfig.getObjClass()

FlowDoc

FlowDoc.getParent()
获取事务轨迹

FlowDoc

FlowDoc.getPreFlowDoc()
获取上一次事务轨迹

FlowNode

FlowDoc.getPreNode()
获取前一个节点

FlowDoc

FlowDocBak.getPrevious(User _currUser, boolean _bGoBack)
该方法与其父类中的同签名方法的行为定义有所不同。

FlowDoc

FlowDoc.getPrevious(User _currUser, boolean _bGoBack)
取前一个流转经过的FlowDoc对象 Sample: A->B->C，然后两次打回 C->B->A，在B处打回时需要将参数_bGoBack置为true

long

FlowContext.getSerialNum()

User

FlowDoc.getToUser()
获取接收者

java.lang.String

FlowDoc.getToUserNames()

Users

FlowDoc.getToUsers(User _currUser)
获取所有呈送人员集合

java.lang.String

FlowDoc.getToUserTrueNames()
添加了返回toUser的真实姓名的方法

void

FlowContentConfig.insert(User _currUser)
将对象数据写入数据库

void

FlowDoc.insert(User _currUser)
重载父类的insert函数，以便设置产生时间

boolean

IConditionHandler.isAccordWith(ExecuteContext _context, FlowCondition _condition)
是否与设定的条件相符合?

boolean

FlowContentConfig.isValid()
检验对象数据有效性

boolean

FlowDoc.isValid()
实现父类的isValid函数，进行数据的效验

void

FlowNodeLCListenerForForceEnd.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

FlowContentLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

static FlowContentConfigs

FlowContentConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowContentConfigs]

static FlowDocs

FlowDocs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FlowDocs]

static void

FlowContentHelper.registerContent(int _nObjType, java.lang.Class _currContentClass)

static void

FlowContentHelper.removeContent(int _nObjType)

boolean

FlowDoc.setAccepted()
设置签收

boolean

FlowDoc.setAcceptTime()
使用当前时间设置确认处理时间

boolean

FlowDoc.setBranchSerialNum(long _lSerialNum)

void

FlowDoc.setContent(IFlowContent flowContent)
设置相关内容

boolean

FlowDoc.setContent(int contentType, int contentId)
设置相关内容

boolean

FlowDoc.setContentId(int _nContentId)

boolean

FlowDoc.setContentType(int _nContentType)

boolean

FlowDoc.setFlag(int _flag)
设置文档流转状态

void

FlowParamers.setFlowContent(IFlowContent flowContent)

boolean

FlowDoc.setFlowContent(IFlowContent _content)
设置所属文档

void

FlowParamers.setFlowContent(int _nContentType, int _nContentId)

boolean

FlowDoc.setFlowContent(int _nObjType, int _nObjId)

void

FlowParamers.setNextNode(FlowNode nextNode)

void

FlowParamers.setNextNode(int _nNextNodeId)

boolean

FlowDoc.setNode(FlowNode _flowNode)
设置所在的节点

boolean

FlowDoc.setNode(int _nodeId)
设置所在的节点

boolean

FlowContentConfig.setObjClass(java.lang.String _sObjClass)
设置属性：ObjClass

boolean

FlowContentConfig.setObjDesc(java.lang.String _sObjDesc)
设置属性：ObjDesc

boolean

FlowContentConfig.setObjType(int _nObjType)
设置属性：ObjType

boolean

FlowDoc.setParent(int _nParentId)
设置所属事务轨迹

boolean

FlowDoc.setPostDesc(java.lang.String _desc)
设置递交说明

boolean

FlowDoc.setPostTime(CMyDateTime _postTime)
设置递交时间

boolean

FlowDoc.setPostUser(java.lang.String _userName)
设置递交用户

boolean

FlowDoc.setPostUser(User _postUser)
设置递交用户

boolean

FlowDoc.setPreFlowDoc(FlowDoc currFlowDoc)
设置前一个轨迹

boolean

FlowDoc.setPreFlowDoc(int _nPreFlowDocId)
设置上一次事务轨迹

void

FlowParamers.setPreNode(FlowNode preNode)

boolean

FlowDoc.setPreNode(FlowNode _flowNode)
设置前一个节点

void

FlowParamers.setPreNode(int _nPreNodeId)

boolean

FlowDoc.setPreNode(int _nodeId)
设置前一个节点

boolean

FlowDoc.setReceiveTime()
使用当前时间设置接收时间

boolean

FlowDoc.setSerialNum(long _lSerialNum)

boolean

FlowDoc.setToUser(int _nToUserId)
设置接收者

boolean

FlowDoc.setToUser(User _toUser)
设置接收者

void

FlowParamers.setToUsers(java.lang.String _sUserIds)

boolean

FlowDoc.setToUsers(java.lang.String _userIds)
设置呈送人员

boolean

FlowDoc.setWorked(boolean _bWorked)
设置流转轨迹是否处理过

boolean

FlowDoc.setWorkModal(int _nWorkModal)
设置事务处理模式

void

FlowContentConfig.update(User _user)

void

FlowParamers.validate()

void

FlowContext.validate()
校验上下文参数是否有效

抛出 WCMException 的 com.trs.cms.process.engine 中的构造方法

ContentProcessInfo(boolean _bEnd, IFlowContent _content, java.lang.String _sUserName)

FlowContentConfig(int _nObjType, java.lang.String _sClassName, java.lang.String _sDesc)

FlowContext(User _currUser, IFlowContent _oFlowContent)
内容开始流转时候的FlowContext构造函数

FlowContext(User _currUser, IFlowContent _oFlowContent, java.lang.String _sPostDesc, Users _toUsers, Flow _flow)
内容开始流转时候的FlowContext构造函数

FlowNextBranchInfo(User _currUser, FlowDoc _currFlowDoc, int _nNextNodeId, boolean _bResubmit)

com.trs.cms.process.engine.creators 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.process.engine.creators 中的方法

java.lang.String

CurrentDocStatusCreator.createInitValue(FlowContext flowContext)

Users

GroupAdminsFromChnlAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

Users

GroupAdminsFromFlowAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

Users

GroupAdminsAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

Users

RoleAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

Users

DeptMgrAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

Users

CrUserAsToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

Users

GroupAdminsFromSupportPartAsToUsersCreator.createToUsers(FlowContext flowContext, ToUsersCreatorConfig _oCreatorConfig)

Group

GroupMembersAsToUsersCreator.getGroupRange(FlowContext _context, ToUsersCreatorConfig _creatorConfig)

com.trs.cms.process.engine.handlers 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.process.engine.handlers 中的方法

java.lang.String

MsgSendHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context)
替换内容中的变量

void

DoingRuleHandler.execute()

boolean

MsgSendHandler.execute(ExecuteContext _context, FlowAction _action)

boolean

PublishContentActionHandler.execute(ExecuteContext _context, FlowAction _action)

boolean

ContentPropertyHandler.isAccordWith(ExecuteContext _context, FlowCondition _condition)

com.trs.cms.process.xml 中 WCMException 的使用

抛出 WCMException 的 com.trs.cms.process.xml 中的方法

Reports

FlowImporter.importFromFile(java.lang.String _sXmlFile, java.lang.String _sXslFile)

Reports

FlowImporter.importFromXMLContent(java.lang.String _sXmlContent)

Reports

FlowImporter.importFromXMLObj(XmlObject _sXmlObj)

com.trs.components.ckm 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.ckm 中的方法

com.trs.ckm.soap.CollErrorInfoDetail[]

TRSCKMServer.collateText(java.lang.String _sContent)

com.trs.ckm.soap.CollErrorInfoDetail[]

ICKMServer.collateText(java.lang.String _sContent)

java.lang.String[]

TRSCKMServer.extractAbstractAndKeywords(java.lang.String _sContent)

java.lang.String[]

ICKMServer.extractAbstractAndKeywords(java.lang.String _sContent)

com.trs.components.comment.domain 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.comment.domain 中的方法

void

DocumentTopicRelationMgr.deleteTopicDocRelation(int documentTopicId)

void

DocumentTopicRelationMgr.deleteTopicDocRelation(int documentTopicId, int delDocumentId)

DocumentTopic

DocumentTopicRelationMgr.getDocumentTopic(int _DocId, int _ChnlId)

boolean

DocumentTopicRelationMgr.isInRelatedTopic(java.lang.String _sRelatedDocIds, int _nDocId)

com.trs.components.comment.persistent 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.comment.persistent 中的方法

static TopicedDocRelation

TopicedDocRelation.createNewInstance()
产生当前对象[TopicedDocRelation]的实例

static DocumentTopic

DocumentTopic.createNewInstance()
产生当前对象[DocumentTopic]的实例

static TopicedDocRelation

TopicedDocRelation.findById(int _nId)
提取指定ID的对象

static DocumentTopic

DocumentTopic.findById(int _nId)
提取指定ID的对象

static TopicedDocRelation

TopicedDocRelation.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static DocumentTopic

DocumentTopic.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

void

TopicedDocRelation.insert(User _currUser)
将对象数据写入数据库

void

DocumentTopic.insert(User _currUser)
将对象数据写入数据库

boolean

TopicedDocRelation.isValid()
检验对象数据有效性

boolean

DocumentTopic.isValid()
检验对象数据有效性

static TopicedDocRelations

TopicedDocRelations.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[TopicedDocRelations]

static DocumentTopics

DocumentTopics.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[DocumentTopics]

boolean

DocumentTopic.setCategory(int _nCategory)
设置属性：Category

boolean

DocumentTopic.setChannelId(int _nChannelId)
设置属性：ChannelId

boolean

TopicedDocRelation.setDescription(java.lang.String _sDescription)
设置属性：Description

boolean

DocumentTopic.setDescription(java.lang.String _sDescription)
设置属性：Description

boolean

TopicedDocRelation.setDocChannelId(int _nDocChannelId)
设置属性：DocChannelId

boolean

TopicedDocRelation.setDocumentId(int _nDocumentId)
设置属性：DocumentId

boolean

DocumentTopic.setTitle(java.lang.String _sTitle)
设置属性：Title

boolean

TopicedDocRelation.setTopicId(int _nTopicId)
设置属性：TopicId

boolean

DocumentTopic.setUrl(java.lang.String _sUrl)
设置属性：Url

com.trs.components.comment.publish.helper 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.comment.publish.helper 中的方法

static CommentParserEntity

CommentParserUtil.getCommentParserEntity(Document doc, TagItem tagItem)

com.trs.components.comment.publish.tagparser 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.comment.publish.tagparser 中的方法

java.lang.String[]

XWCMTagParserComment.parse(PublishTagContext _context)

com.trs.components.comment.service 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.comment.service 中的方法

void

ICommentService.cancelDocTopicRelation(int _nDocumentTopicId, int _nDelDocumentId)

void

CommentService.cancelDocTopicRelation(int _nDocumentTopicId, int _nDelDocumentId)

DocumentTopic

ICommentService.getDocumentTopic(int _nDocId, int _nChnlId)

DocumentTopic

CommentService.getDocumentTopic(int _nDocId, int _nChnlId)

java.lang.String

ICommentService.getNoneRelatedDocIds(int _nTopicId, int _nDocChannelId)

java.lang.String

CommentService.getNoneRelatedDocIds(int _nTopicId, int _nDocChannelId)

java.lang.String

ICommentService.getRelatedDocIds(int _nTopicId)

java.lang.String

CommentService.getRelatedDocIds(int _nTopicId)

java.lang.String

ICommentService.getRelatedDocIds(int _nTopicId, int _nDocChannelId)

java.lang.String

CommentService.getRelatedDocIds(int _nTopicId, int _nDocChannelId)

Documents

ICommentService.getRelatedDocs(int _nTopicId, WCMFilter _oFilter)

Documents

CommentService.getRelatedDocs(int _nTopicId, WCMFilter _oFilter)

boolean

ICommentService.isInRelatedTopic(java.lang.String _sRelatedDocIds, int _nDocId)

void

ICommentService.saveDocTopicRelation(int _nTopicId, int _nDocChannelId, java.lang.String _sRelatedDocIds)

void

CommentService.saveDocTopicRelation(int _nTopicId, int _nDocChannelId, java.lang.String _sRelatedDocIds)

com.trs.components.common.address 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.address 中的方法

Contact

ContactMgr.addContact(Contact _contact, ContactGrp _contactGroup)
添加联系人到指定的组中

boolean

ContactGrp.addContact(Contact _Contact, User _opUser)
添加新的非系统用户到该组 参数：_Contact：要添加的非系统用户对象；_opUser：操作者（添加该用户的用户） 返回值：若参数_Contact无效，则抛出异常； 若已存在，则返回false; 若成功，则返回true

Contact

ContactMgr.addContactFromSystemUser(User _user)
导入系统用户为联系人

void

ContactMgr.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup)
更改联系人所在的分组

static Contact

Contact.createNewInstance()
产生当前对象[Contact]的实例

static ContactGrp

ContactGrp.createNewInstance()
产生当前对象[ContactGrp]的实例

static Contacts

Contacts.createNewInstance(User _currUser)
产生一个当前集合对象[Contacts]的实例

void

ContactMgr.deleteContact(Contact _contact)
删除指定的联系人

void

ContactMgr.deleteContactGroup(ContactGrp _contactGrp)
删除指定的联系人分组

static Contact

Contact.findById(int _nId)
提取指定ID的对象

static ContactGrp

ContactGrp.findById(int _nId)
提取指定ID的对象

static Contacts

Contacts.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Contact

Contact.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ContactGrp

ContactGrp.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

ContactGrps

ContactGrp.getChildren()
取组的子对象

ContactGrps

ContactMgr.getContactGroups(WCMFilter _filter)
获取当前用户的所有联系人分组

Contacts

ContactMgr.getContacts(WCMFilter _filter)
获取当前登录用户所有的联系人

Contacts

ContactMgr.getContacts(WCMFilter _filter, ContactGrp _contactGroup)
获取当前登录用户某个分组的联系人

ContactGrps

ContactMgr.getGroups(Contact _contact)
获取一个联系人所在的所有分组

ContactGrp

ContactGrp.getParent()
取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。

void

Contact.insert(User _currUser)
添加对象到数据库

void

ContactGrp.insert(User _currUser)
添加对象到数据库

boolean

Contact.isValid()
检查对象数据的有效性

boolean

ContactGrp.isValid()
验证对象数据的有效性

static ContactGrps

ContactGrps.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ContactGrps]

static Contacts

Contacts.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Contacts]

void

ContactMgr.removeContact(Contact _contact, ContactGrp _contactGroup)
将指定的联系人从指定的联系人分组中删除

boolean

ContactGrp.removeContact(Contact _Contact, User _opUser)
从非系统用户组中删除指定的非系统用户 参数：_Contact:要删除的非系统用户；_opUser:执行操作的用户

Contact

ContactMgr.saveContact(Contact _contact)
保存一个联系人

ContactGrp

ContactMgr.saveContactGroup(ContactGrp _contactGrp)
保存一个联系人分组

static void

ContactMsgSender.send(java.lang.String _sTitle, java.lang.String _sContent, java.lang.String _sSendType, Contact _toContact)
给联系人发送消息

boolean

Contact.setAddress(java.lang.String _address)

boolean

Contact.setAttribute(java.lang.String _attribute)

boolean

ContactGrp.setAttribute(java.lang.String _attribute)

boolean

Contact.setDesc(java.lang.String _desc)

boolean

ContactGrp.setDesc(java.lang.String _desc)

boolean

Contact.setEmail(java.lang.String _email)

boolean

ContactGrp.setEmail(java.lang.String _email)

boolean

Contact.setMobile(java.lang.String _mobile)

boolean

ContactGrp.setName(java.lang.String _name)

boolean

Contact.setNickName(java.lang.String _nickName)

boolean

ContactGrp.setParent(ContactGrp _parent)

boolean

ContactGrp.setParent(int _parentId)
设置父对象

boolean

Contact.setTel(java.lang.String _tel)

boolean

Contact.setUserName(java.lang.String _userName)

com.trs.components.common.bookmark 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.bookmark 中的方法

void

BookMarkMgr.cancelShares(int _nObjType, CMSBaseObjs _currObjs)

static MarkKind

MarkKind.createNewInstance()
产生当前对象[MarkKind]的实例

static BookMark

BookMark.createNewInstance()
产生当前对象[BookMark]的实例

static MarkShares

MarkShares.createNewInstance(User _currUser)
产生一个当前集合对象[MarkShares]的实例

static MarkKinds

MarkKinds.createNewInstance(User _currUser)
产生一个当前集合对象[MarkKinds]的实例

static BookMarks

BookMarks.createNewInstance(User _currUser)
产生一个当前集合对象[BookMarks]的实例

boolean

BookMarkMgr.deleteBookMark(BookMark _aBookMark)
删除一个书签

boolean

BookMarkMgr.deleteMarkKind(MarkKind _aMarkKind)
删除一个书签分类

static MarkKind

MarkKind.findById(int _nId)
提取指定ID的对象

static BookMark

BookMark.findById(int _nId)
提取指定ID的对象

static MarkShares

MarkShares.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static MarkKinds

MarkKinds.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static BookMarks

BookMarks.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static MarkKind

MarkKind.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static BookMark

BookMark.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

BookMarks

BookMarkMgr.getBookMarks(int _nMarkKindId, WCMFilter _filter)
获取当前登录用户的书签

BookMarks

BookMarkMgr.getBookMarks(MarkKind _markKind, WCMFilter _filter)

BookMarks

MarkKind.getBookMarks(User _currUser)
取所有该类别的书签集合

BookMarks

BookMarkMgr.getBookMarks(WCMFilter _filter)

MarkKinds

BookMarkMgr.getChildren(MarkKind _parentMarkKind, WCMFilter _filter)
获取当前书签分类的子分类

MarkKind

BookMark.getKind()
取标签类型对象

MarkKinds

BookMarkMgr.getMarkKinds(WCMFilter _filter)
获取当前登录用户的顶级书签分类

MarkShares

MarkKind.getMarkShares(User _currUser)
得到MarkShares

MarkShares

BookMark.getMarkShares(User _currUser)
得到MarkShares

CMSObj

MarkShare.getObject(User _currUser)
取共享的对象（ BookMark / MarkKind ）

MarkKind

MarkKind.getParent()
取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。

BookMarks

BookMarkMgr.getSharedBookMarks(User _aUser, WCMFilter _filter)
获取共享给当前登录用户的书签

Groups

BookMarkMgr.getSharedGroups(int _nTypeId, CMSObj _currObj)

MarkKinds

BookMarkMgr.getSharedMarkKinds(User _aUser, WCMFilter _filter)
获取共享给当前登录用户的书签分类

Users

BookMarkMgr.getSharedUsers(int _nTypeId, CMSObj _currObj)

MarkShares

BookMarkMgr.getShareMarks(WCMFilter _filter)
获取当前登录用户可访问的共享书签

CMSObj

MarkShare.getViewer(User _currUser)
取得Viewer对象(User,Group,Role,Contact,ContactGrp)

void

MarkKind.insert(User _currUser)
添加对象到数据库

void

BookMark.insert(User _currUser)
添加对象到数据库

void

MarkShare.insert(User _currUser)
添加对象到数据库

boolean

MarkKind.isShared(User _currUser)
是否被共享

boolean

BookMark.isShared(User _currUser)
是否被共享

boolean

MarkKind.isValid()
验证对象数据的有效性

boolean

BookMark.isValid()
验证对象数据的有效性

boolean

MarkShare.isValid()
有效性检验

void

BookMarkMgr.moveBookMark(BookMark _aBookMark, MarkKind _newParent)
将一个书签从移动新的分类中

void

BookMarkMgr.moveMarkKind(MarkKind _markKind, MarkKind _newParent)
移动一个书签类别

static MarkShares

MarkShares.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[MarkShares]

static MarkKinds

MarkKinds.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[MarkKinds]

static BookMarks

BookMarks.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[BookMarks]

BookMark

BookMarkMgr.saveBookMark(BookMark _bookMark)
保存一个书签

MarkKind

BookMarkMgr.saveMarkKind(MarkKind _markKind)
保存一个书类别

boolean

MarkKind.setAttribute(java.lang.String _attribute)

boolean

BookMark.setAttribute(java.lang.String _attribute)

boolean

MarkShare.setAttribute(java.lang.String _attribute)

boolean

MarkKind.setDesc(java.lang.String _desc)

boolean

BookMark.setIcon(java.lang.String _icon)

boolean

BookMark.setKind(int _nKindId)

boolean

BookMark.setKind(MarkKind _markKind)

boolean

BookMark.setLink(java.lang.String _link)

boolean

MarkKind.setName(java.lang.String _name)
名称要求不重复 处理：由函数isValid()检查，区分大小写

boolean

BookMark.setName(java.lang.String _name)
名称要求不重复 处理：由函数isValid()检查，并区分大小写

boolean

MarkShare.setObjId(int _objId)

boolean

MarkShare.setObjType(int _objType)
setObjType允许的对象类型为两类 OBJ_BOOKMARK OBJ_MARKKIND

boolean

MarkKind.setParent(int _parentId)
设置父对象

boolean

MarkKind.setParent(MarkKind _parent)

boolean

MarkKind.setParentId(int _parentId)
setParentId：设置父对象Id（为保证以前版本兼容而保留）

void

MarkShare.setViewer(CMSObj _viewer)
设置Viewer（User,Group,Role,Contact,ContactGrp）对象

boolean

MarkShare.setViewerId(int _viewerId)

boolean

MarkShare.setViewerType(int _viewerType)
setViewerType允许的对象类型常量为6种 OBJ_USER OBJ_GROUP OBJ_ROLE OBJ_CONTACT OBJ_CONTACTGRP MARKSHARE_STATE_ALLUSER

void

BookMarkMgr.shareTo(int _nObjType, CMSBaseObjs _currObjs, int _nViewerType, java.lang.String _sViewerIds)

com.trs.components.common.calendar 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.calendar 中的方法

void

EventMgr.cancelShare(Event _anEvent, CMSObj _cmsObj)
取消对象某用户/组织的一个日程安排

void

EventMgr.cancelShares(Event _anEvent)
取消指定的Event所有指派

static Event

Event.createNewInstance()
产生当前对象[Event]的实例

static EventShare

EventShare.createNewInstance()
产生当前对象[EventShare]的实例

static EventType

EventType.createNewInstance()
产生当前对象[EventType]的实例

static Events

Events.createNewInstance(User _currUser)
产生一个当前集合对象[Events]的实例

static EventShares

EventShares.creatNewInstance(User _currUser)
产生一个当前集合对象[EventShares]的实例

boolean

EventMgr.delete(Event _anEvent)
删除指定的Event

static Event

Event.findById(int _nId)
提取指定ID的对象

static EventShare

EventShare.findById(int _nId)
提取指定ID的对象

static EventType

EventType.findById(int _nId)
提取指定ID的对象

static Events

Events.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static EventShares

EventShares.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Event

Event.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static EventShare

EventShare.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static EventType

EventType.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

Events

EventMgr.getDailyEvents(CMyDateTime _date, WCMFilter _filter)
获取当前用户在指定日期的日程安排

Events

EventMgr.getEvents(User _currUser, CMyDateTime _date, boolean _bIncludingShared, WCMFilter _filter)

Events

EventMgr.getEvents(WCMFilter _filter)
获取系统中的日程安排

Groups

EventMgr.getGroups(Event _anEvent)
获取共享指定日程安排的所有组织

java.lang.String

Event.getSendTypes()

EventType

Event.getType()

Users

EventMgr.getUsers(Event _anEvent)
获取共享指定日程安排的所有用户

void

Event.insert(User _currUser)
添加对象到数据库

void

EventShare.insert(User _currUser)
将对象数据写入数据库

void

EventType.insert(User _currUser)

boolean

Event.isRemindBy(int _nRemindType)
是否按指定类型提醒 参数：_nRemindType 提醒类型（常量定义：WCMTypes.REMIND_ONLINE等）

boolean

Event.isRemindDone(int _nRemindType)
指定类型的提醒是否已经完成 参数：_nRemindType 提醒类型（常量定义：WCMTypes.REMIND_ONLINE等）

boolean

Event.isValid()
TITLE暂时定为可以重复

boolean

EventShare.isValid()
检验对象数据有效性

boolean

EventType.isValid()
检查对象数据的有效性

void

EventLCListenerForRemind.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

EventLCListenerForRemind.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

static Events

Events.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Events]

static EventShares

EventShares.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[EventShares]

Event

EventMgr.save(Event _anEvent)
保存日程安排

boolean

Event.setAheadRemindTime(int _nAheadRemindTime)

boolean

Event.setAttribute(java.lang.String _attribute)

boolean

Event.setDesc(java.lang.String _desc)

boolean

EventType.setDesc(java.lang.String _desc)

boolean

Event.setEmail(java.lang.String _email)

boolean

Event.setEndTime(CMyDateTime _time)

boolean

EventShare.setEventId(int _nEventId)
设置属性：EventId

boolean

EventType.setName(java.lang.String _name)
名称要求不重 处理：由函数isValid()检查，并区分大小写

boolean

EventShare.setObjId(int _nObjId)
设置属性：ObjId

boolean

EventShare.setObjType(int _nObjType)
设置属性：ObjType

boolean

Event.setOwner(java.lang.String _ownerName)

boolean

Event.setOwner(User _owner)

boolean

Event.setRemindBy(int _nRemindType, boolean _bIfRemind)

boolean

Event.setRemindDone(int _nRemindType)
置指定类型的提醒已经完成 说明：若当前提醒设置不是WCMTypes.YES，则抛出无效操作异常

boolean

Event.setShare(boolean _bShared)

boolean

Event.setStartTime(CMyDateTime _time)

boolean

Event.setTitle(java.lang.String _title)

boolean

Event.setType(EventType _type)

boolean

Event.setType(int _typeId)

void

EventMgr.shareTo(Event _anEvent, CMSObj _cmsObj)

void

Event.update(User _user)
重载父类接口，以处理提醒Job

抛出 WCMException 的 com.trs.components.common.calendar 中的构造方法

EventShareIdsMan(int _nEventId, int _nSharerType)

com.trs.components.common.conjection.persistent 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.conjection.persistent 中的方法

static EntryConfig

EntryConfig.createNewInstance()
产生当前对象[EntryConfig]的实例

static EntryConfig

EntryConfig.findById(int _nId)
提取指定ID的对象

static EntryConfig

EntryConfig.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

void

EntryConfig.insert(User _currUser)
将对象数据写入数据库

boolean

EntryConfig.isValid()
检验对象数据有效性

static EntryConfigs

EntryConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[EntryConfigs]

boolean

EntryConfig.setDescription(java.lang.String _sDescription)
设置属性：Description

boolean

EntryConfig.setEnable(boolean _bEnable)
设置属性：Enable

boolean

EntryConfig.setEnterDirectly(boolean _bEnterDirectly)
设置属性：EnterDirectly

boolean

EntryConfig.setLinkPath(java.lang.String _sLinkPath)
设置属性：LinkPath

boolean

EntryConfig.setType(int _nType)
设置属性：Type

com.trs.components.common.conjection.service 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.conjection.service 中的方法

java.lang.String

IAdmanageConfigService.getAdManagerLinkPath()

java.lang.String

AdmanageConfigServiceImpl.getAdManagerLinkPath()

EntryConfig

IComponentEntryConfigService.getEntryConfig(int _nEntryId)

EntryConfig

ComponentEntryConfigServiceImpl.getEntryConfig(int _nEntryId)

EntryConfig

IComponentEntryConfigService.getTypedEntryConfig(int _nEntryType)

EntryConfig

ComponentEntryConfigServiceImpl.getTypedEntryConfig(int _nEntryType)

boolean

IAdmanageConfigService.isAdManagerEnable()

boolean

AdmanageConfigServiceImpl.isAdManagerEnable()

void

IComponentEntryConfigService.saveComponentConfigInfo(EntryConfig _oEntry)

void

ComponentEntryConfigServiceImpl.saveComponentConfigInfo(EntryConfig _oEntry)

void

IAdmanageConfigService.updateAdManageService()

void

AdmanageConfigServiceImpl.updateAdManageService()

com.trs.components.common.job 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.job 中的方法

static Schedule

Schedule.createNewInstance()
产生当前对象[Schedule]的实例

static JobWorkerType

JobWorkerType.createNewInstance()
产生当前对象[JobWorker]的实例

static Schedules

Schedules.createNewInstance(User _currUser)
产生当前集合对象[Schedules]的实例

static Schedule

JobScheduleServer.deleteSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)

static JobWorkerType

JobWorkerType.findByClassName(java.lang.String _sClassName)

static Schedule

Schedule.findById(int _nId)
提取指定ID的对象

static JobWorkerType

JobWorkerType.findById(int _nId)
提取指定ID的对象

static Schedules

Schedules.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Schedule

Schedule.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static JobWorkerType

JobWorkerType.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Schedule

Schedule.findBySender(int _nWorkerId, BaseObj _currSender)
获取在指定对象上定义的指定类型的调度（Schedule）

static Schedule

JobScheduleServer.findSchedule(JobWorkerType _currWorkerType, CMSObj _currObj)

static Schedules

Schedules.findUnfinishedSchedules(User _currUser, CMyDateTime _dtTime)

java.lang.Object

JobWorkerType.getWorker()

java.lang.Class

JobWorkerType.getWorkerClass()

JobWorkerType

Schedule.getWorkerType()

void

Schedule.insert(User _currUser)
将对象数据写入数据库

boolean

Schedule.isValid()
检验对象数据有效性

boolean

JobWorkerType.isValid()

boolean

Schedule.logicalDelete(User _currUser)

boolean

Schedule.logicalUndelete(User _currUser)

void

ScheduleLCListenerForServer.notifyOnAddObj(BaseObj _oObjAdded)

void

ScheduleLCListenerForServer.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ScheduleLCListenerForFaieldResult.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

JobWorkerTypeLCListenerForSchedule.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ScheduleLCListenerForServer.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

static Schedules

Schedules.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Schedules]

static JobWorkerTypes

JobWorkerTypes.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[JobWorkers]

static Schedule

JobScheduleServer.saveSchedule(JobWorkerType _currWorkerType, Schedule _currSchedule, CMSObj _currObj)

boolean

Schedule.setDeleted(boolean _bDeleted)
逻辑接口：设置计划设是否为已删除状态 说明：对于正常状态下的计划，setDeleted( true )将计划改为已删除（逻辑删除）；
对于已删除的计划，setDeleted( false )将计划恢复为正常状态

boolean

Schedule.setDesc(java.lang.String _desc)
属性设置：描述

boolean

JobWorkerType.setDesc(java.lang.String _sDesc)

boolean

Schedule.setEndTime(CMyDateTime _endTime)

boolean

Schedule.setExeTime(CMyDateTime _exeTime)
属性设置：执行时间

boolean

Schedule.setLastExeResult(int _nResult)
属性设置：上次执行结果

boolean

Schedule.setLastExeTime()
设置上次执行时间为当前时间

boolean

Schedule.setLastExeTime(CMyDateTime _time)
设置上次执行时间为指定时间

boolean

Schedule.setLastTimeUsed(int _nTimeUsed)
属性设置：上次执行所用时间

boolean

Schedule.setMode(int _nMode)
属性设置：计划执行类型

boolean

Schedule.setName(java.lang.String _name)
属性设置：名称（要求名称不重复；区分大小写，由isValid处理）

boolean

Schedule.setOperArgs(java.lang.String _sOpArgs)
属性设置：操作参数

boolean

Schedule.setParam(int _nParam)
属性设置：参数

boolean

Schedule.setSender(CMSObj _sender)
属性设置：发送者

boolean

Schedule.setSender(int _senderType, int _senderId)
属性设置：发送者

boolean

Schedule.setStartTime(CMyDateTime _startTime)
属性设置：开始执行时间

boolean

Schedule.setStatus(int _status)
属性设置：计划状态

boolean

JobWorkerType.setWorkerClass(java.lang.Class _sClassName)

boolean

JobWorkerType.setWorkerClass(java.lang.String _sClassName)

boolean

JobWorkerType.setWorkerName(java.lang.String _sWorkerName)

boolean

Schedule.setWorkerType(int _nWorkerTypeId)

boolean

Schedule.setWorkerType(JobWorkerType _worker)

com.trs.components.common.message 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.message 中的方法

static MsgQueue

MsgQueue.createNewInstance()
产生当前对象[MsgQueue]的实例

static MsgReceiver

MsgReceiver.createNewInstance()
产生当前对象[MsgReceiver]的实例

static Message

Message.createNewInstance()
产生当前对象[Message]的实例

static Messages

Messages.createNewInstance(User _currUser)
产生一个当前集合对象[Messages]的实例

static MsgQueues

MsgQueues.createNewInstance(User _currUser)
产生一个当前集合对象[MsgQueues]的实例

boolean

IMessageService.delete(int _nMessageId)
根据短消息ID删除短消息

boolean

IMessageService.delete(Message _delMessage)
删除短消息

boolean

IMessageService.delete(Messages _delMessages)
删除短消息集合

boolean

IMessageService.delete(java.lang.String _sDelIds)
根据对象的ID列表删除短消息集合

int

Message.delete(User _currUser)
删除对象 重载父类接口：同时删除相关数据

static void

MessageServer.delete(User _currUser, java.lang.String _sDelMsgIds)
删除消息集合
删除消息时，如果用户为发件人，则在Message表中做逻辑删除的标志
如果用户为收件人，则从关联关系表中删除该记录
如果用户既是发件人，又是收件人，则两个操作都做
删除时，如果关联表中已没有和Message关联的记录，Message中也时逻辑删除，则从Message中彻底删除该消息。

static void

MessageServer.emptyInbox(User _currUser)
清空用户的收件箱
将用户接收到的消息都删除掉
参照delete的逻辑

static void

MessageServer.emptyOutbox(User _currUser)
清空用户的已发消息
将用户接发送的消息都删除掉
参照delete的逻辑

static MsgQueue

MsgQueue.findById(int _nId)
提取指定ID的对象

static MsgReceiver

MsgReceiver.findById(int _nId)
提取指定ID的对象

static Message

Message.findById(int _nId)
提取指定ID的对象

static Message

MessageServer.findById(User _currUser, int _nMsgId)

static Messages

Messages.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static MsgQueues

MsgQueues.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Messages

MessageServer.findByIds(User _currUser, java.lang.String _sMsgIds)

static MsgQueue

MsgQueue.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static MsgReceiver

MsgReceiver.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Message

Message.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

Message

MsgQueue.getMessage(User _currUser)
取得Message对象

static Messages

MessageServer.getMessages(int _nReadFlag, User _loginUser, WCMFilter _aFilter)
根据指定的类型(未读/已收/已发)获取消息集合

Messages

IMessageService.getMessages(int _nMessageType, WCMFilter _aFilter)
获取WCM中特定的类型的消息，如已读消息、已发消息

MsgQueues

Message.getMsgQueues(User _currUser)
得到消息队列

static Messages

MessageServer.getReceivedMsgs(User _currUser, WCMFilter _currFiilter)
获得某用户的所有接收到的消息
接收的判断是所有用户为接收者的消息

static java.lang.String

MessageServer.getReceiverNames(Message _currMsg, int _nReceiverType)
获取消息接收者名

Users

Message.getReceivers()
获取消息的接收者集合

static Messages

MessageServer.getSentMsgs(User _currUser, WCMFilter _currFiilter)
获得某用户的所有已发消息
已发的判断是从Message表中查询得到

static Messages

MessageServer.getUnreadMessages(User _currUser, WCMFilter _filter)
获得用户所有未读的消息
未读的定义即_currMsgUser为接收者，且消息的已读属性为false

static boolean

MessageServer.hasUnreadMessage(User _currUser)
判断用户是否有没有阅读的消息

static boolean

MessageServer.hasUnreadMessage(User _currUser, int[] _pMsgType)
判断用户是否有没有阅读指定类型的消息

void

MsgQueue.insert(User _currUser)

void

Message.insert(User _currUser)
添加对象到数据库

static boolean

MessageServer.isMessageReaded(Message _currMessage, User _currUser)
获得用户所接收消息的状态
状态包括已读和未读，通过状态标志来返回

boolean

Message.isQueue(User _currUser)
判断消息是否在队列中

boolean

MsgQueue.isValid()
验证有效性

boolean

MsgReceiver.isValid()

boolean

Message.isValid()
数据有效性检验

static Messages

Messages.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Messages]

static MsgQueues

MsgQueues.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[MsgQueues]

static MsgReceivers

MsgReceivers.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[MsgReceivers]

static void

MessageServer.send(Message _currMessage)
发送消息

boolean

IMessageService.send(java.lang.String _sMsgTitle, java.lang.String _sMsgBody, java.lang.String _sUserIds, boolean _bSendEmail, boolean _bSendMobile)
发送短消息给特定的用户集合

boolean

Message.setAttribute(java.lang.String _attribute)

boolean

Message.setBody(java.lang.String _body)

boolean

Message.setDeletedBySender()
删除已发送消息

boolean

Message.setFlag(int _flag)

boolean

MsgQueue.setMessage(int _messageId)

boolean

MsgQueue.setMessage(Message _message)

static void

MessageServer.setMessageReaded(Message _currMessage, User _currUser, boolean _bMessageReaded)
设置接收到的消息的已读状态

boolean

MsgReceiver.setMsgId(int _nMsgId)
设置对应的Message的ID

boolean

MsgQueue.setMsgType(int _type)

boolean

MsgQueue.setObj(CMSObj _obj)

boolean

MsgQueue.setObjId(int _objId)

boolean

MsgQueue.setObjType(int _objType)

boolean

MsgQueue.setReaded(boolean _bReaded)

boolean

MsgReceiver.setReceiverId(int _nReceiverId)
设置接收者ID

boolean

MsgReceiver.setReceiverName(java.lang.String _sReceiverName)
设置接收者的名称

boolean

MsgReceiver.setReceiverType(int _nReceiverType)
设置接收者的类型

boolean

Message.setSendTypes(java.lang.String _sSendType)
设置消息发送类型

boolean

Message.setSendTypes(java.lang.String[] _arSendTypes)
设置消息发送类型

boolean

Message.setTitle(java.lang.String _title)

boolean

Message.setValidTime(CMyDateTime _time)

com.trs.components.common.message.notify 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.message.notify 中的方法

void

Notifier.execute(NotificationSchemeConfig _scheme)
execute the specified notification scheme.

void

Notifier.executeOnEvent(java.lang.String _sEvent)
execute the notification on the specified event.

com.trs.components.common.publish 中 WCMException 的使用

com.trs.components.common.publish 中 WCMException 的子类

class

OrignHomePublishException

com.trs.components.common.publish.config 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.config 中的方法

IPublishElement

PublishElementType.createBean()
create a new bean instance

IFileDistristributor

PublishDistributionTargetType.createDistributor()
create a distributor instance

void

PublishElementType.fromConfigElement(PublishElementConfig _properties)
read properties from CMyBaseConfig, which may be imported from a XML file.

void

PublishDistributionTargetType.fromConfigElement(TargetTypeConfig _element)
read from a XML element

static java.lang.String

PublishServerConfigMapper.getDefaultEncoding()
Returns the default file encoding.

static java.lang.String

PublishServerConfigMapper.getDirDividedByDateFormat(boolean _bLocalFileSystemFormat)
Returns the format to divide publish directory.

static PublishDistributionConfig

PublishServerConfigMapper.getDistributionConfig()
Returns the distribution configuration.

static java.util.Map

PublishServerConfigMapper.getDistributionTargetTypes()
Returns the distribution target types mapping.

static PublishElementType

PublishServerConfigMapper.getElementType(int _nType)
lookup the folder type by type number

static PublishServerConfigMapper

PublishServerConfigMapper.getInstance()
get the instance

static LaborResourceConfig

PublishServerConfigMapper.getLaborResourceConfig()
get the labor resource configurator.

static int

PublishServerConfigMapper.getLoadBatchContentsModal()

static int

PublishServerConfigMapper.getLoadBatchContentsPageSize()

static java.util.List

PublishServerConfigMapper.getTagFormattersConfigs()
Returns the tag formatter config.

static TemplateParseConfig

PublishServerConfigMapper.getTemplateParseConfig()
get the template parse configuration.

static java.lang.String[]

PublishServerConfigMapper.getTemplateSupportedApdExts()
Returns the supported template appendix extends.

static java.lang.String[]

PublishServerConfigMapper.getTemplateSupportedExts()
Returns the supported template extends.

static java.lang.String[]

PublishServerConfigMapper.getTemplateTagsHavingSrc()
Returns the names list of those tags having src.

static java.lang.String[]

PublishServerConfigMapper.getTemplateTagSrcAttributeNames()
Returns the src attribute names of those tags having src.

static boolean

PublishServerConfigMapper.isAutoPublishDocInHomeWhenNeeded()
Returns true if to publish automatically the document who has not been published in its home folder when to publish the link of it.

static boolean

PublishServerConfigMapper.isDetailPageSeperateTo51Style()

static boolean

PublishServerConfigMapper.isDirDividedByDate()
Returns true if the publish directory is divided by date.

static boolean

PublishServerConfigMapper.isIgnoreIfHostNotFound()
Returns true if to ignore the error when the host is not found in tag item; false otherwise.

static boolean

PublishServerConfigMapper.isPublishInRootPath()
是否直接将文件发布到站点的根目录下

static boolean

PublishServerConfigMapper.isSendWarningIfFileNotFound()
Returns true if to send warning when file is not found.

static PublishDistributionTargetType

PublishServerConfigMapper.lookupDistributionTargetTypeByName(java.lang.String _sName)
lookup the distribution target type by name.

void

PublishServerConfigMapper.refresh()
load and refresh the configuration from XML file.

void

PublishDistributionTargetType.setDistributorClassName(java.lang.String _sClassName)

void

PublishDistributionTargetType.setName(java.lang.String _sName)

com.trs.components.common.publish.domain 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.domain 中的方法

void

PublishServer.cancelTask(PublishTask _task)
cancel the publish task if it has not been finished

int

PublishServer.distributeFile(java.lang.String _sLocalFilePathName, IPublishElement _fileOwner)
Distributes a specified file to the folder.

void

PublishServer.pauseTask(PublishTask _task)
暂停指定任务的执行

java.lang.String[]

PublishServer.previewFolder(IPublishFolder _folder, java.lang.String[] _warningsHolder)
Previews a content folder and returns the URLs of preview pages.

java.lang.String[]

PublishServer.previewFolder(IPublishFolder _folder, java.lang.String[] _warningsHolder, Template _template)

void

PublishServer.publishConfirm(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile)
确认（批准）发布，其内部行为： 1.删除备份文件 2.重名名正式文件为备份文件 3.重名名临时文件为备份文件

void

PublishServer.publishContent(IPublishContent _content, int _nPubType)
publish a content in the specified folder with specified PubType

void

PublishServer.publishContent(IPublishContent _content, IPublishElements folders)
忽略文档的状态，在指定的Folder下发布文档

void

PublishServer.publishFolder(IPublishFolder _folder, int _nPublishType)
publish the content folder

void

PublishServer.resumeTask(PublishTask _task)
暂停指定任务的执行

static void

PublishServer.validateElement(int _nElementType, int _nElementId)
校验指定的发布对象是否有效

static void

PublishServer.validateElement(IPublishElement _publishElement)
校验指定的发布对象是否有效

com.trs.components.common.publish.domain.auth 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.domain.auth 中的方法

boolean

TemplateRightObjImpl.hasRight(User _currUser, int _nRightIndex)

boolean

TemplateRightObjImpl.loadById(int _nId)

抛出 WCMException 的 com.trs.components.common.publish.domain.auth 中的构造方法

TemplateRightObjImpl(int _nId)

com.trs.components.common.publish.domain.distribute 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.domain.distribute 中的方法

void

PublishDistributionList.delDistribution(PublishDistribution _distribution)
从列表中删除指定的分发点设置

void

PublishDistributionMgr.delete(PublishDistribution _distribution)
Deletes a publish distribution.

void

UftpConnectionCacheManager.deleteDistribution(PublishDistribution _distribution)
删除和指定的PublishDistribution相关的FTP连接缓存管理器

int

FileDistributeShip.distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner)
Distributes a file to the specified folder.

int

FileDistributeShip.distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner, java.lang.String _sSubDir)
Distributes a file to the specified folder.

int

FileDistributeShip.distributeFile(java.lang.String _sLocalFile, IPublishElement _fileOwner, java.lang.String _sSubDir, boolean _bCheckDstFileExits)

FtpConnectionCache

UftpConnectionCacheManager.getConnectionCache(PublishDistribution dist)
返回和指定的PublishDistribution相关的FTP连接缓存管理器

PublishDistributions

PublishDistributionMgr.getDistributionsOf(IPublishFolder _folder, boolean _bExcludingDisabled, WCMFilter _filter)
get the publish distributions of the specified folder.

FileDistributorImpUnion

PublishDistributionList.getDistributorUnion()
返回有效分发点的聚合

FileDistributorImpUnion

PublishDistributionCacheMgr.getDistributorUnion(int iFolderType, int iFolderID)
返回指定目录上的分发点的聚合

FileDistributorImpUnion

PublishDistributionCacheMgr.getDistributorUnion(IPublishFolder _folder)
返回指定目录上的分发点的聚合

PublishDistributionList

PublishDistributionCacheMgr.getPublishDistributionList(int iFolderType, int iFolderID)
返回指定目录上的分发点的列表

PublishDistributionList

PublishDistributionCacheMgr.getPublishDistributionList(java.lang.String sKey)
返回和指定的缓存KEY绑定的分发点的列表

boolean

PublishDistributionCacheMgr.init()

static IFileDistristributor

PublishDistributionMgr.makeDistristributor(PublishDistribution _distribution)
根据指定的分发点配置信息构造 IFileDistristributor 对象实例

void

PublishDistributionLCListener.notifyOnAddObj(BaseObj objAdded)

void

PublishDistributionCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

PublishDistributionCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

PublishDistributionLCListener.notifyOnModifyObj(BaseObj objModified, int eventType)

void

PublishDistributionCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

PublishDistributionList.putDistribution(PublishDistribution _distribution)
向列表中增加或者替换列表中的分发点设置

boolean

PublishDistributionCacheMgr.reinit()

int

FileDistributeShip.renameFile(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile)

int

FileDistributeShip.renameFile(IPublishFolder _folder, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sFullDataPath)

void

PublishDistributionMgr.save(PublishDistribution _distribution)
Saves the distribution setting.

int

FileDistributeShip.withdrawFile(java.lang.String _sFileName, IPublishElement _fileOwner)
Withdraws a file.

int

FileDistributeShip.withdrawFile(java.lang.String _sFileName, IPublishElement _fileOwner, java.lang.String _sFullDataPath)

int

FileDistributeShip.withdrawFolder(IPublishFolder _folder)
Withdraws a folder.

int

FileDistributeShip.withdrawFolder(IPublishFolder _folder, java.util.List subdirs)
撤除指定folder的指定子目录

com.trs.components.common.publish.domain.element 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.domain.element 中的方法

void

PublishFolderLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

PublishContentLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

com.trs.components.common.publish.domain.publisher 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.domain.publisher 中的方法

void

PublishPageContext.addWarning(java.lang.String _sDesc)
add warning

void

PublishTagContext.addWarning(java.lang.String _sDesc)

void

PublishPageContext.addWarning(java.lang.String _sObjName, int _nObjId, java.lang.String _sDesc)
add warning

void

PublishTagContext.addWarning(java.lang.String _sObjName, int _nObjId, java.lang.String _sDesc)

static java.lang.String

PublishPathCompass.calFullDataPath(IPublishContent _content, boolean _bLocalFileSystemFormat)
Returns the full data path from the specified content to folder root.

static java.lang.String

PublishPathCompass.calFullDataPath(IPublishElement _element, boolean _bLocalFileSystemFormat)
Returns the full data path from the specified element to root.

static java.lang.String

PublishPathCompass.calFullDataPath(IPublishFolder _folder, boolean _bLocalFileSystemFormat)
Returns the full data path from the specified folder to root.

static java.lang.String

PublishPathCompass.calSubDirectory(IPublishContent _content, boolean _bLocalFileSystemFormat)
Calculates the sub directory of the specified content in its home.

static java.lang.String[]

PageGenerator.generateContent(PublishPageContext _pageContext, Template _template)

static java.lang.String[]

PageGenerator.generateOutlines(PublishPageContext _pageContext)
generate the content folder outline page file

static java.lang.String

PageGenerator.generatePage(PublishPageContext _pageContext, Template _template)
Generates page with the specified template in the specified page context.

static java.lang.String

PageGenerator.generatePage(PublishPageContext _pageContext, Template _template, boolean _bDiffContent)

java.lang.String

PublishPathCompass.getAbsoluteHttpPath(IPublishContent _content)
Returns the http path without file name of the specified content.

java.lang.String

PublishPathCompass.getAbsoluteHttpPath(IPublishElement _element)
Returns the http path of the specified element.

java.lang.String

PublishPathCompass.getAbsoluteHttpPath(IPublishFolder _folder)
Returns the http path of the specified folder.

int

PublishTagContext.getAttribute(java.lang.String _sName, int _nDefault)
get the integer attribute value

java.lang.String

PublishPathCompass.getFullDataPath(IPublishContent _content, boolean _bLocalFileSystemFormat)
Returns the full data path of the specified content.

java.lang.String

PublishPathCompass.getFullDataPath(IPublishElement _element, boolean _bLocalFileSystemFormat)
Returns the full data path of the specified element.

java.lang.String

PublishPathCompass.getFullDataPath(IPublishFolder _folder, boolean _bLocalFileSystemFormat)
Returns the full data path of the specified folder.

java.lang.String

PublishPathCompass.getHttpUrl(IPublishContent _content, int _nPageIndex)
Returns the http path including file name of the specified content.

java.lang.String

PublishPathCompass.getLocalPath(IPublishElement _element, boolean _bPreview)
Returns the element local path.

java.lang.String

PublishPageContext.getPageHttpPath()
Returns the http path of current page.

java.lang.String

PublishTagContext.getPageHttpPath()

java.lang.String

PublishPageContext.getPageHttpURL()
Returns the http URL of current page.

java.lang.String

PublishPathCompass.getPreviewHttpPath(IPublishElement _element)
Returns the http path for the previewed pages of the specified element.

java.lang.String

PublishPathCompass.getPreviewHttpUrl(IPublishContent _content, int _nPageIndex)
获取指定Content的预览地址

java.lang.String

PublishPathCompass.getPreviewLocalPath(IPublishContent _content)
Returns the local path for the previewed pages of the specified content.

java.lang.String

PublishPathCompass.getPreviewLocalPath(IPublishElement _element)
Returns the local path for the previewed pages of the specified element.

java.lang.String

PublishPathCompass.getPreviewLocalPath(IPublishFolder _folder)
Returns the local path for the previewed pages of the specified folder.

java.lang.String

PublishPathCompass.getPublishHttpPath(IPublishElement _element)

java.lang.String

PublishPathCompass.getPublishHttpUrl(IPublishContent _content, int _nPageIndex)

java.lang.String

PublishPathCompass.getPublishLocalPath(IPublishContent _content)
Returns the local path (without file name) for the published pages of the specified content in the folder.

java.lang.String

PublishPathCompass.getPublishLocalPath(IPublishElement _element)
Returns the local path for the published pages of the specified element.

java.lang.String

PublishPathCompass.getPublishLocalPath(IPublishFolder _folder)
Returns the local path for the published pages of the specified folder.

IPublishFolder

PublishTaskContext.getRoot()
Returns the root of the published folder.

IPublishFolder

PublishPageContext.getRoot()

IPublishFolder

PublishTagContext.getRoot()

java.lang.String

PublishPathCompass.getRootDomain(IPublishFolder _folder)
Returns the root domain of the specified folder.

java.lang.String

PublishPathCompass.getRootHttpPathFrom(IPublishElement _element)
Returns the root http path from the specified publish element.

java.lang.String

PublishPathCompass.getRootImageHttpPath(IPublishElement _element)
Returns the http path of the images in root.

int

PublishTagContext.getSequenceNumber()

static java.io.File

PublishSyncGlobalTuner.insureLocalPathExists(java.lang.String _sPath)
insure the specified path exists

java.lang.String

PublishTagContext.parsePageVariables(java.lang.String _sContent)

com.trs.components.common.publish.domain.tagparser 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.domain.tagparser 中的方法

TemplateQuote[]

BaseTagParser.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserPageNav4Detail.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserCondition.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

ITagParser.analyzeQuotes(IPublishFolder _root)
Analyzes the quote relations between this template and folders.

TemplateQuote[]

TagParserUnimpl.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserRepeat.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserOddOrEven.analyzeQuotes(IPublishFolder root)

TemplateQuote[]

TagParserSequenceNumber.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserEcho.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserVariableEnum.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserVariable.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserOnlyLogic.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserSystemConfig.analyzeQuotes(IPublishFolder _s_root)

TemplateQuote[]

TagParserVariableSet.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserNewIcon.analyzeQuotes(IPublishFolder _root)

TagParseResults

TagParseResults.append(java.lang.String[] _results)
Appends the product of the specified results and current results.

static ITagParser

TagParserFactory.createParserByName(java.lang.String _sTagName)
Creates a parser instance for the specified tag.

static void

TagParseHelper.distributionHTMLContentFiles(IPublishContent _content, PublishTagContext _context, java.util.List _listFiles)

static Template

TagParseHelper.findNestedTemplate(PublishTagContext _context)
Returns the template defined in the specified nested template tag item.

static Template

TagParseHelper.findNestedTemplate(java.lang.String sTempName, IPublishFolder _root)
Returns the template defined in the specified nested template tag item.

static Template

TagParseHelper.findNestedTemplate(TagItem _tagItem, IPublishFolder _root)
已过时。 Returns the template defined in the specified nested template tag item.

static ITagFormatter

TagFormatHelper.getFormatter(java.lang.String _sTagName)
Returns the tag formmater of the specified tag.

static TagFormatHelper

TagFormatHelper.getInstance()
Returns the tag formmater helper instance.

int

TagItem.getIntAttribute(java.lang.String _sName, int _nDefault)
get the integer attribute value

PublishTagContext

ITagParser4List.getNextRecordContext()
Returns the tag parse context of the next record.

PublishTagContext

BaseTagParser4List.getNextRecordContext()

java.lang.String

TagItem.getRequiredAttribute(java.lang.String _sName)
get a required attribute value

java.lang.String

TagItem.getRequiredAttributeTrim(java.lang.String _sName)
get the trimmed value of a required attribute.

Template

TemplateParameter.getTemplate()
返回形式参数所在的模板

void

TagBeanLCListener.notifyOnAddObj(BaseObj _oObjAdded)

void

TagBeanLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

TagBeanLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

static void

TagParserFactory.notifyOnTagBeanAdded(TagBean _newBean)
Updates cache when a new tag bean is created.

static void

TagParserFactory.notifyOnTagBeanDeleted(TagBean _bean)
Removes cache when a tag bean is deleted.

static void

TagParserFactory.notifyOnTagBeanModified(TagBean _bean)
Updates cache when a tag bean is modified.

java.lang.String[]

TagParserPageNav4Detail.parse(PublishTagContext _context)

java.lang.String[]

TagParserNestedTemplate.parse(PublishTagContext _context)

java.lang.String[]

TagParserCondition.parse(PublishTagContext _context)

java.lang.String[]

ITagParser.parse(PublishTagContext _context)
Parses the specified tag item and returns the result.

java.lang.String[]

TagParserUnimpl.parse(PublishTagContext _context)

java.lang.String[]

TagParserRepeat.parse(PublishTagContext _tagContext)

java.lang.String[]

TagParserOddOrEven.parse(PublishTagContext context)

java.lang.String[]

TagParserSequenceNumber.parse(PublishTagContext _context)

java.lang.String[]

TagParserEcho.parse(PublishTagContext _context)

java.lang.String[]

TagParserVariableEnum.parse(PublishTagContext _context)

java.lang.String[]

TagParserVariable.parse(PublishTagContext _context)

java.lang.String[]

TagParserOnlyLogic.parse(PublishTagContext _context)

java.lang.String[]

TagParserSystemConfig.parse(PublishTagContext _context)

java.lang.String[]

BaseTagParser4List.parse(PublishTagContext _context)

java.lang.String[]

TagParserVariableSet.parse(PublishTagContext _context)

java.lang.String[]

TagParserNewIcon.parse(PublishTagContext _context)

java.lang.String[]

TagParserCMSObjBase.parse(PublishTagContext _context)

static java.lang.String[]

TagParseHelper.parse4Children(TagItem _tagItem, PublishTagContext _tagContext)

static java.lang.String[]

TagParseHelper.parse4List(PublishTagContext _tagContext, ITagParser4List _parser4List)

static java.lang.String[]

TagParseHelper.parse4List(TagItem _tagItem, PublishTagContext _tagContext, ITagParser4List _parser4List)
Parses objects list tag, eg.

static java.lang.String[]

TagParseHelper.parseHtmlContent(java.lang.String _sHtmlContent, IPublishContent _content, PublishTagContext _context)

static java.lang.String[]

TagParseHelper.parseItem(TagItem _item, PublishTagContext _context)
Parses a tag item and returns the results which may be more than one.

static java.lang.String[]

TagParseHelper.parseItems(java.util.List _items, PublishTagContext _context)
Parses the tag items list and return the results which may be more than one.

void

TagFormatHelper.refresh()
Refreshs the tag formatters config.

void

TagParserFactory.refresh()
Refreshs the cache in factory.

void

TagItem.setAttribute(java.lang.String _sName, boolean _bValue)
Sets the value of a boolean property.

void

TagItem.setAttribute(java.lang.String _sName, int _nValue)
Sets the value of a attribute

void

TagItem.setAttribute(java.lang.String _sName, java.lang.String _sValue)
Sets the value of a attribute

static void

TagFormatHelper.standardize(TagItem _item)
Standardizes a specified tag item with the formatter configurated.

void

ITagFormatter.standardize(TagItem _item)
Converts the tag item to standard format.

PublishTagContext

ITagParser4List.substantiateContext(PublishTagContext _tagConext)
实体化指定的PublishTagContext对象

PublishTagContext

BaseTagParser4List.substantiateContext(PublishTagContext _tagConext)

static java.lang.String

TagParseHelper.truncateTextIfNeeded(PublishTagContext _context, java.lang.String _sText)
Truncates the text length if needed (when NUM>0).

static java.lang.String

TagParseHelper.truncateTextIfNeeded(TagItem _currItem, java.lang.String _sText)
已过时。 Truncates the text length if needed (when NUM>0).
Related properties in tag item: NUM, TRUNCATEDFLAG
if NUM>0, to truncate the text with the flag as tail.

com.trs.components.common.publish.domain.taskdispatch 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.domain.taskdispatch 中的方法

boolean

TaskDispatcher.cancelTask(int _nTaskId)

boolean

IPublishTaskDispatcher.cancelTask(int _nTaskId)
cancel a publish task by the specified id

boolean

PublishTaskDispatcherImpl.cancelTask(int _nTaskId)

PublishTask

IPublishTaskMgr.createContentPublishTask(IPublishContent _content, int _nPublishType)
create a content publish task

PublishTask

PublishTaskMgrImpl.createContentPublishTask(IPublishContent _content, int _nPublishType)

PublishTask

IPublishTaskMgr.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders)
创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）

PublishTask

PublishTaskMgrImpl.createContentPublishTask(IPublishContent _content, IPublishFolder _folder, IPublishElements _folders)
创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）

PublishTask

IPublishTaskMgr.createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType)
create a content publish task

PublishTask

PublishTaskMgrImpl.createContentPublishTask(IPublishElements _contents, IPublishFolder _folder, int _nPublishType)

PublishTask

IPublishTaskMgr.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)

PublishTask

PublishTaskMgrImpl.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishContent _content)

PublishTask

IPublishTaskMgr.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)

PublishTask

PublishTaskMgrImpl.createDeleteContentsSynPublishTask(IPublishFolder _folder, IPublishElements _contents)

PublishTask

IPublishTaskMgr.createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders)
创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）

PublishTask

PublishTaskMgrImpl.createDestroyPublishTask(IPublishElements _contents, IPublishFolder _folder, IPublishElements _folders)
创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）

PublishTask

IPublishTaskMgr.createFolderPublishTask(IPublishFolder _folder, int _nPublishType)
create a folder publish task

PublishTask

PublishTaskMgrImpl.createFolderPublishTask(IPublishFolder _folder, int _nPublishType)

boolean

IPublishTaskMgr.delete(PublishTask _task)
delete a publish task

boolean

PublishTaskMgrImpl.delete(PublishTask _task)

PublishTasks

IPublishTaskMgr.getMyTasks(WCMFilter _filter)
get the publish tasks created by the specified user

PublishTasks

PublishTaskMgrImpl.getMyTasks(WCMFilter _filter)

SinglePageTask

BatchDetailPageTask.getNext()
Returns the next page task to execute.

PublishTasks

IPublishTaskMgr.getTasks(WCMFilter _filter)
get the tasks collection with the specified filter

PublishTasks

PublishTaskMgrImpl.getTasks(WCMFilter _filter)

PublishTasks

IPublishTaskMgr.getUnfinishedTasks()
get the tasks collection who have not been finished.

PublishTasks

PublishTaskMgrImpl.getUnfinishedTasks()

void

PublishTaskDispatcherImpl.notifyOnAddObj(BaseObj objAdded)

void

PublishTaskDispatcherImpl.notifyOnDelObj(BaseObj objDeleted, int eventType)

boolean

TaskDispatcher.pauseTask(int iTaskID)

boolean

IPublishTaskDispatcher.pauseTask(int iTaskID)
暂停指定发布任务的执行,如果指定ID的发布任务还没有执行或者已经执行结束则什么都不作。

boolean

PublishTaskDispatcherImpl.pauseTask(int iTaskID)

void

TaskDispatcher.pushTask(PublishTask _task)

void

IPublishTaskDispatcher.pushTask(PublishTask _task)
push a publish task into the queue

boolean

TaskDispatcher.resumeTask(int iTaskID)

boolean

IPublishTaskDispatcher.resumeTask(int iTaskID)
恢复指定的已经暂停的发布任务的执行,如果指定的并不是处于暂停状态则什么都不作。

boolean

PublishTaskDispatcherImpl.resumeTask(int iTaskID)

PublishTask

IPublishTaskMgr.save(PublishTask _task)
save the publish task which is created or updated

PublishTask

PublishTaskMgrImpl.save(PublishTask _task)

void

TaskDispatcher.startup()

void

IPublishTaskDispatcher.startup()
startup the dispatcher

void

PublishTaskDispatcherImpl.startup()

com.trs.components.common.publish.domain.template 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.domain.template 中的方法

boolean

TemplateNestMgr.addNestRecord(int _nTemplateId, int _nNestedTemplateId)
add a template nest record

boolean

TemplateNestMgr.addNestRecord(int _nTemplateId, IPublishFolder _root, java.lang.String _sNestedTemplateName)
add a template nest record

int

TemplateEmployMgr.clearEmploysOfEmployer(int _nEmployerType, int _nEmployerId)
clear all the employ records of the specified element

int

TemplateEmployMgr.clearEmploysOfEmployer(IPublishElement _employer)
clear all the employ records of the specified element

int

TemplateEmployMgr.clearEmploysOfTemplate(int _nTemplateId)
clear all the employ records of the specified template

int

TemplateEmployMgr.clearEmploysOfTemplate(Template _template)
clear all the employ records of the specified template

int

TemplateNestMgr.clearNestRecordsOf(Template _template)
clear the nest records of the specified template

int

TemplateQuoteMgr0310.clearQuotesOfFolder(int _nFolderType, int _nFolderId)
Clears the quotes of the specified folder.

int

TemplateQuoteMgr.clearQuotesOfFolder(int _nFolderType, int _nFolderId)
Clears the quotes of the specified folder.

int

TemplateQuoteMgr0310.clearQuotesOfFolder(IPublishFolder _folder)
Clears the quotes of the specified folder.

int

TemplateQuoteMgr.clearQuotesOfFolder(IPublishFolder _folder)
Clears the quotes of the specified folder.

Reports

TemplateMgr.copyVisualTempToChnls(Channels _toChannels, Template _srcTemplate)
在指定栏目下，类似创建可视化模板

boolean

TemplateMgr.delete(Template _templateToDelete)
删除指定的模板

boolean

TemplateArgumentMgr.delete(TemplateArgument _aArgument)
删除指定的TemplateArgument对象

java.lang.String

TemplateExporter.export(Templates _currTemplates)
导出模板集合

java.lang.String

TemplateExporter.exportToXMLFile(Template _currTemplate)
将WCM的模板导出成为WCM XML标准格式的文件

java.lang.String

TemplateExporter.exportToXMLFile(Templates _currTemplates)
将WCM的模板集合导出成为WCM XML标准格式的文件

java.lang.String[]

TemplateImporter.extractTemplateNamesFromZip(java.lang.String _sZipFileName)
得到模板名称列表

java.lang.String

TemplateArgumentCacheMgr.getArgument(int _type, int _id, java.lang.String _name)

java.lang.String

TemplateArgumentCacheMgr.getArgument(IPublishElement _employer, java.lang.String _name)

java.util.HashMap

TemplateArgumentCacheMgr.getArguments(int _type, int _id)

java.util.HashMap

TemplateArgumentCacheMgr.getArguments(IPublishElement _employer)

TemplateArguments

TemplateArgumentMgr.getArguments(IPublishElement _element)
返回指定发布对象上的全部有效模板参数列表

Template

ITemplateEmployCacheMgr.getDefaultOutlineTemplate(IPublishFolder _folder)

Template

TemplateEmployCacheMgrImpl.getDefaultOutlineTemplate(IPublishFolder _folder)

Template

TemplateEmployMgr.getDefaultOutlineTemplate(IPublishFolder _folder)
Returns the default outline template of the specified folder.

Template

ITemplateEmployCacheMgr.getDetailTemplate(int _nPublishElementType, int _nPublishElementId)

Template

TemplateEmployCacheMgrImpl.getDetailTemplate(int _nPublishElementType, int _nPublishElementId)

Template

TemplateEmployMgr.getDetailTemplate(int _nEmployerType, int _nEmployerId)

Template

ITemplateEmployCacheMgr.getDetailTemplate(IPublishElement _employer)

Template

TemplateEmployCacheMgrImpl.getDetailTemplate(IPublishElement _employer)

Template

TemplateEmployMgr.getDetailTemplate(IPublishElement _employer)
Returns the detail template of the specified publish element.

Template

TemplateEmployMgr.getDetailTemplate(IPublishElement _employer, int _nTemplateType)

java.util.List

TemplateEmployMgr.getEmployers(Template _template, int _nEmployerType)
Returns the employers list of the specified type.

java.util.List

TemplateEmployMgr.getEmployers(Template _template, WCMFilter _filter)
get the employers who use the specified template.

TemplateEmploys

TemplateEmployMgr.getEmploysOf(IPublishElement _employer)

TemplateEmploys

TemplateEmployMgr.getEmploysOf(IPublishElement _employer, int _nTemplateType)
Returns the employ records of the specified employer, which may be a folder or a content.

TemplateEmploys

TemplateEmployMgr.getEmploysOfEmployer(int _nEmployerType, int _nEmployerId)

TemplateEmploys

TemplateEmployMgr.getEmploysOfEmployer(int _nEmployerType, int _nEmployerId, int _nTemplateType)
Returns the employ records of the specified employer, which may be a folder or a content.

java.util.List

TemplateQuoteMgr0310.getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder _quotedFolder)
find the folders whose outline quotes the contents of the specified folder.

java.util.List

TemplateQuoteMgr.getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder _quotedFolder)
find the folders whose outline quotes the contents of the specified folder.

Templates

TemplateMgr.getManagedTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren)
get the managed tempaltes in the specified folder

Templates

TemplateNestMgr.getNestedTemplates(Template _template)
get the nested templates

Templates

TemplateMgr.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent)
get the managed tempaltes in the specified folder

Templates

TemplateEmployMgr.getOtherOutlineTemplates(IPublishFolder _folder)
获取当前folder的其它概览模板集.

Templates

ITemplateEmployCacheMgr.getOutlineTemplates(IPublishFolder _folder)

Templates

TemplateEmployCacheMgrImpl.getOutlineTemplates(IPublishFolder _folder)

Templates

TemplateEmployMgr.getOutlineTemplates(IPublishFolder _folder)
get the outline templates of the specified folder.

static java.lang.String[]

TemplateImporter.getSupportedTemplateFileExt()
获取系统支持的模板文件类型.

TempAppendixes

TemplateMgr.getTempAppendixesInRoot(int _nRootType, int _nRootId, WCMFilter _filter)
get the template appendixes in the specified root

TemplateEmploys

TemplateEmployMgr.getTemplateEmployers(Template _template, WCMFilter _filter)

Templates

TemplateNestMgr.getTemplatesNested(Template _template)
返回获取嵌套了指定模板的所有模板

java.lang.String

TemplateMgr.getTextWithImgFilter(Template _template, java.lang.String sText, boolean _bRemoveExtraAttribute)

Reports

TemplateImporter.importFromHTML(IPublishFolder _folder, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName)
从html文件导入模板

Reports

TemplateImporter.importFromZip(IPublishFolder _folder, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected)
从zip文件中导入模板

boolean

TemplateEmployCacheMgrImpl.init()

boolean

TemplateArgumentCacheMgr.init()

Template

TemplateCacheMgr.lookupByName(IPublishFolder _root, java.lang.String _sName)
find the template by name

void

TemplateEmployCacheMgrImpl.notifyOnAddObj(BaseObj _oObjAdded)

void

TemplateArgumentCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

TemplateParseMgr.notifyOnAddObj(BaseObj objAdded)

void

TemplateEmployCacheMgrImpl.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

TemplateArgumentCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

TemplateParseMgr.notifyOnDelObj(BaseObj objDeleted, int eventType)

void

TemplateCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

TemplateArgumentLCListenerForEmployChanged.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

TemplateEmployCacheMgrImpl.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

TemplateArgumentCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

TemplateLCListenerForTypeChanged.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

TemplateLCListenerForNestedRename.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

TemplateParseMgr.notifyOnModifyObj(BaseObj objModified, int eventType)

void

TemplateCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

TemplateArgumentLCListenerForEmployChanged.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

TemplateParseMgr.notifyTemplateDeleted(Template _template)
Notifys template parse manager wehn a template is deleted.

void

TemplateParseMgr.notifyTemplateModified(Template _template)
Notifys template parse manager when a template is modified.

java.lang.String

CSSResourceProcessor.parseCSSFile(java.lang.String _sCSSFileName, java.util.HashMap _hExistsFileMap)

java.lang.String

TemplateMgr.preview(Template _currTemplate)
预览指定的模板

void

TemplateEmployDetail.putEmploy(TemplateEmploy _employ)

Reports

TemplateMgr.redistributeAppendixes(IPublishFolder _folder, boolean _zRecursive)
重新分发指定站点或者频道下的所有模板的附件，并且如果 _zRecursive 为 true ，则会进一步地重新分发子频道下的模板的附件。

boolean

TemplateEmployCacheMgrImpl.reinit()

boolean

TemplateArgumentCacheMgr.reinit()

void

TemplateEmployDetail.removeEmploy(TemplateEmploy _employ)

void

TemplateEmployMgr.resetChildern(IPublishFolder _folder)

void

TemplateEmployMgr.resetChildern(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bOutLine)

void

TemplateQuoteMgr0310.save(java.util.List _quotes)
saves the specified template quotes list.

void

TemplateQuoteMgr.save(java.util.List _quotes)
saves the specified template quotes list.

TemplateArgument

TemplateArgumentMgr.save(TemplateArgument _aArgument)
保存指定的TemplateArgument对象

Template

TemplateMgr.save(Template _currTemplate, java.util.HashMap _tempapds, boolean _bDowithAppendix, int _nPicMode, boolean _zParseIfNecessary)
保存模板

void

TemplateQuoteMgr0310.save(TemplateQuote _quote)
save a template quote

void

TemplateQuoteMgr.save(TemplateQuote _quote)
save a template quote

Template

TemplateMgr.save(Template _currTemplate, java.lang.String _sTempApdPath, boolean _bDowithAppendix, int _nPicMode)
保存模板

void

TemplateEmployMgr.setDefaultOutline(IPublishFolder _folder, int _nNewDefaultTemplateId)

void

TemplateEmployMgr.setDetailTemplate(IPublishElement _employer, int _nTemplateId, boolean _bResetChildren)

void

TemplateEmployMgr.setDetailTemplate(IPublishElement _employer, int _nTemplateId, boolean _bResetChildren, int _nDetailTemplateType)
set detail template of the specified element.

void

TemplateEmployMgr.setOtherOutlines(User loginUser, IPublishFolder _folder, java.lang.String _sTemplateIds)

void

TemplateEmployMgr.setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren)
set outline template of the specified folder

void

TemplateMgr.updateNestedTemplateName(Templates templates, java.lang.String sOldName, java.lang.String sNewName)

void

TemplateParseMgr.uploadAppendixes(Template _template, boolean _bForceAll)
Uploads the appendixes of the specified template.

抛出 WCMException 的 com.trs.components.common.publish.domain.template 中的构造方法

TemplateEmployDetail(TemplateEmploy _employ)

TemplateEmployerIdsMan(IPublishElement _element, TemplateEmployMgr _manager, int _nTemplateType)

com.trs.components.common.publish.persistent.distribute 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.persistent.distribute 中的方法

static PublishDistribution

PublishDistribution.createNewInstance()
产生当前对象[PublishDistributionConfig]的实例

static PublishDistribution

PublishDistribution.findById(int _nId)
提取指定ID的对象

static PublishDistribution

PublishDistribution.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

IPublishFolder

PublishDistribution.getFolder()

void

PublishDistribution.insert(User _currUser)
将对象数据写入数据库

boolean

PublishDistribution.isValid()
检验对象数据有效性

static PublishDistributions

PublishDistributions.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[PublishDistributions]

boolean

PublishDistribution.setAnonymous(boolean _zAnonymous)
设置属性：ANONYMFTP，是否在FTP登录中使用匿名方式 为了避免在某些数据库中可能存在的冲突，所以没有使用“Anonymous”作为字段名，而是使用了“ANONYMFTP”

boolean

PublishDistribution.setDataPath(java.lang.String _sDataPath)
设置属性：DataPath

boolean

PublishDistribution.setEnabled(boolean _bEnabled)
设置属性：Enabled

boolean

PublishDistribution.setFolder(int _nType, int _nId)
设置属性：FolderTypeConfig

boolean

PublishDistribution.setFolder(IPublishFolder _folder)

boolean

PublishDistribution.setLoginPassword(java.lang.String _sLoginPassword)
设置属性：LoginPassword

boolean

PublishDistribution.setLoginUser(java.lang.String _sLoginUser)
设置属性：LoginUser

boolean

PublishDistribution.setPassiveMode(boolean _bEnabled)
设置属性：PASSIVEMODE，禁用或者启用FTP协议中的Passive模式

boolean

PublishDistribution.setTargetPort(int _nServerPort)
设置属性：TargetPort，目标服务器的端口号

boolean

PublishDistribution.setTargetServer(java.lang.String _sServerAddress)
设置属性：TargetServer

boolean

PublishDistribution.setTargetType(java.lang.String _sName)
设置属性：TargetTypeConfig

com.trs.components.common.publish.persistent.element 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.persistent.element 中的方法

static IPublishElement

PublishElementFactory.createElementOfType(int _nType)
create an element instance for the specified type

IPublishElement

PublishElementsCMSObjsImpl.get(int _nIndex)

IPublishElement

IPublishElements.get(int _nIndex)
Returns the element at the specified position in this collection.

IPublishElement

PublishElementsCMSListImpl.get(int _nIndex)

IPublishElements

IPublishFolder.getChildren()
get the children folders

IPublishElements

PublishFolderWrapper.getChildren()

java.lang.String

PublishFolderImplBase.getDataPath()

java.lang.String

IPublishFolder.getDataPath()

java.lang.String

PublishFolderWrapper.getDataPath()

java.lang.String

PublishFolderImplBase.getEncoding()

java.lang.String

PublishContentImplBase.getEncoding()

java.lang.String

PublishElementWrapper.getEncoding()

java.lang.String

IPublishElement.getEncoding()
Returns the file encoding of this element.

java.util.Collection

PublishFolderImplBase.getFoldersQuotingMe()

java.util.Collection

IPublishFolder.getFoldersQuotingMe()
Returns the content folders who are quoting this folder

java.util.Collection

PublishFolderWrapper.getFoldersQuotingMe()

int

PublishContentImplBase.getModal()

int

IPublishContent.getModal()
Returns the content modal in the curernt folder

int

PublishContentWrapper.getModal()

IPublishFolder

IPublishContent.getOriginalHome()
Returns the folder where this content originally lies.

IPublishFolder

PublishContentWrapper.getOriginalHome()

IPublishFolder

IPublishFolder.getParent()

IPublishFolder

PublishFolderWrapper.getParent()

java.lang.String

IPublishFolder.getPathKey()
获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写

IPublishFolder

PublishContentImplBase.getRealHome()

IPublishFolder

IPublishContent.getRealHome()
Returns the folder where this content currently lies.

IPublishFolder

PublishContentWrapper.getRealHome()

java.util.Iterator

IPublishContent.getRelatedResources()
获取Content相关的资源文件(如附件等)

java.util.Iterator

PublishContentWrapper.getRelatedResources()

IPublishFolder

IPublishFolder.getRoot()

IPublishFolder

PublishFolderWrapper.getRoot()

java.lang.String

PublishFolderImplBase.getRootDomain()

java.lang.String

IPublishFolder.getRootDomain()
Returns the root domain of current folder.

java.lang.String

PublishFolderWrapper.getRootDomain()

int

IPublishFolder.getSiblingIndex()
Retuns index of this folder in its siblings.

int

PublishFolderWrapper.getSiblingIndex()

java.util.HashMap

PublishFolderImplBase.getTemplateArguments()

java.util.HashMap

PublishContentImplBase.getTemplateArguments()

java.util.HashMap

PublishElementWrapper.getTemplateArguments()

java.util.HashMap

IPublishElement.getTemplateArguments()
返回该发布对象已经进行了有效设置的全部模板参数列表

boolean

PublishElementWrapper.isCanDoSave(User _loginUser)

boolean

IPublishElement.isCanDoSave(User _loginUser)
指定用户是否可以保存当前对象

static boolean

PublishElementFactory.isContentType(int _nType)
Returns true if the specified type is a content.

static boolean

PublishElementFactory.isFolderType(int _nType)
Returns true if the specified type is a folder.

boolean

PublishElementWrapper.loadById(int _nId)

boolean

PublishContentDefaultObjImpl.loadById(int _nId)

static IPublishContent

PublishElementFactory.lookupContent(int _nType, int _iID, IPublishFolder _oFolder)
lookup a publish content object

static IPublishElement

PublishElementFactory.lookupElement(int _nType, int _nId)
lookup a publish element (folder/content)

static IPublishElements

PublishElementFactory.lookupElements(int _nType, java.lang.String _sIds)
lookup the contents collection by the specified type and ids.

static IPublishContent

PublishElementFactory.makeContentFrom(CMSObj _cmsObj, IPublishFolder _oFolder)
make a publish content from the specified CMS object.

static IPublishElement

PublishElementFactory.makeElementFrom(CMSObj _cmsObj)
make a publish element from the specified CMS object.

void

PublishElementWrapper.makeFrom(CMSObj _cmsObj)

void

PublishContentDefaultObjImpl.makeFrom(CMSObj _cmsObj)

void

PublishElementsCMSObjsImpl.remove(int _nIndex)

void

IPublishElements.remove(int _nIndex)

void

IPublishFolder.setPublishStatus(int _nStatus)
Sets the publish status of this folder

void

PublishFolderWrapper.setPublishStatus(int _nStatus)

void

IPublishContent.setPublishStatus(int _nStatus)
Sets the publish status of this content in the specified folder

void

PublishContentWrapper.setPublishStatus(int _nStatus)

void

PublishContentDefaultObjImpl.setPublishStatus(int _nStatus)

void

IPublishContent.setPublishTime(CMyDateTime _dtTime)
设置当前内容的发布时间

void

PublishContentWrapper.setPublishTime(CMyDateTime _dtTime)

void

PublishContentDefaultObjImpl.setPublishTime(CMyDateTime _dtTime)

void

IPublishContent.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消

void

PublishContentWrapper.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)

void

PublishContentDefaultObjImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)

IPublishElementsIterator

PublishElementsListImpl.toIterator()

IPublishElementsIterator

PublishElementsCMSObjsImpl.toIterator()

IPublishElementsIterator

PublishElementsCMSListImpl.toIterator()

void

PublishElementWrapper.validateCanDoPreview()

void

IPublishElement.validateCanDoPreview()
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。

void

PublishContentDefaultObjImpl.validateCanDoPreview()

boolean

PublishContentImplBase.validateCanDoPub()

boolean

PublishElementWrapper.validateCanDoPub()

boolean

IPublishElement.validateCanDoPub()
Returns true if the folder is can be published.

com.trs.components.common.publish.persistent.publisher 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.persistent.publisher 中的方法

static FolderPublishConfig

FolderPublishConfig.createNewInstance()
产生当前对象[FolderPublishConfig]的实例

int

FolderPublishConfig.delete(User _currUser)

static FolderPublishConfig

FolderPublishConfig.findById(int _nId)
提取指定ID的对象

static FolderPublishConfig

FolderPublishConfig.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FolderPublishConfig

FolderPublishConfig.findOf(int _nFolderType, int _nFolderId)
根据Folder的类型和Id获取配置信息

static FolderPublishConfig

FolderPublishConfig.findOf(IPublishFolder _folder)
find the publish config of the specified folder

void

FolderPublishConfig.insert(User _currUser)
将对象数据写入数据库

boolean

FolderPublishConfig.isValid()
检验对象数据有效性

static FolderPublishConfigs

FolderPublishConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FolderPublishConfigs]

boolean

FolderPublishConfig.setDataPath(java.lang.String _sDataPath)
设置属性：DataPath

boolean

FolderPublishConfig.setDetailFileExt(java.lang.String _sDetailFileExt)
设置属性：DetailFileName

boolean

FolderPublishConfig.setFolder(int _nType, int _nId)
设置属性：FolderId

boolean

FolderPublishConfig.setFolder(IPublishFolder _folder)
set the publish folder

boolean

FolderPublishConfig.setOutlineFileName(java.lang.String _sOutlineFileName)
设置属性：OutlineFileName

boolean

FolderPublishConfig.setPageEncoding(java.lang.String _sPageEncoding)
设置站点的页面编码

boolean

FolderPublishConfig.setRootDomain(java.lang.String _sRootMain)

boolean

FolderPublishConfig.setSiteLanguage(int _nSiteLanguage)
设置站点的语言选项

com.trs.components.common.publish.persistent.taskdispatch 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法

PublishErrorLog

PublishTask.addErrorLog(User _currUser, IPublishElement _publishElement, java.lang.String _sDesc, int _nResult, java.lang.String _sErrorDetail)
add error log for a folder publish page task

static PublishTask

PublishTask.createNewInstance()
产生当前对象[PublishTask]的实例

static PublishErrorLog

PublishErrorLog.createNewInstance()
产生当前对象[PublishLog]的实例

PublishTask

PublishTask.duplicate(User _currUser, boolean _bInsert2DB)
copy from this publish task and create a new one.

static PublishTask

PublishTask.findById(int _nId)
提取指定ID的对象

static PublishErrorLog

PublishErrorLog.findById(int _nId)
提取指定ID的对象

static PublishTasks

PublishTasks.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static PublishTask

PublishTask.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static PublishErrorLog

PublishErrorLog.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

IPublishElements

PublishTask.getContents()
获取Task所关联的内容集合

PublishErrorLogs

PublishTask.getErrorLogs(User _currUser, WCMFilter _filter)
get the error logs of this task

IPublishFolder

PublishTask.getFolder()

IPublishElements

PublishTask.getFolders()
get the property of ContentIds

void

PublishTask.insert(User _currUser)
将对象数据写入数据库

void

PublishErrorLog.insert(User _currUser)
将对象数据写入数据库

boolean

PublishTask.isValid()
检验对象数据有效性

boolean

PublishErrorLog.isValid()
检验对象数据有效性

boolean

PublishTask.setAnalyzeError(java.lang.String _sAnalyzeError)
设置属性：AnalyzeError

boolean

PublishErrorLog.setContent(int _nType, int _nId)
set the property of ContentTypeConfig

boolean

PublishTask.setContent(int _nType, java.lang.String _sIds)
set the property of ContentTypeConfig

boolean

PublishTask.setContent(IPublishContent _content)
set the property of ContentTypeConfig

boolean

PublishErrorLog.setContent(IPublishContent _content)
set the property of ContentTypeConfig

boolean

PublishTask.setDesc(java.lang.String _sDesc)
设置属性：Desc

boolean

PublishErrorLog.setDesc(java.lang.String _sDesc)
设置属性：Desc

boolean

PublishTask.setDetailPageCount(int _nCount)
设置共计发布了多少细览页面

boolean

PublishTask.setEndTime(CMyDateTime _endTime)
设置属性：EndTime

boolean

PublishErrorLog.setErrorDetail(java.lang.String _sDetail)
设置属性：ExeDetail

boolean

PublishTask.setFolder(int _nType, int _nId)
设置属性：FolderTypeConfig

boolean

PublishErrorLog.setFolder(int _nType, int _nId)
设置属性：FolderTypeConfig

boolean

PublishTask.setFolder(IPublishFolder _folder)
set the property of FolderTypeConfig

boolean

PublishErrorLog.setFolder(IPublishFolder _folder)
set the property of FolderTypeConfig

boolean

PublishTask.setFolders(IPublishElements folders)
get the property of ContentIds

boolean

PublishTask.setFolders(java.lang.String sFolders)
get the property of ContentIds

boolean

PublishTask.setHasWarnings(boolean _bHasWarnings)
设置属性：HasWarnings

boolean

PublishTask.setOutlinePageCount(int _nCount)
设置共计发布了多少概览页面

boolean

PublishTask.setPageTaskCount(int _nCount)
设置属性：PageTaskCount

void

PublishTask.setPriority(int _nPriority)
set the property of Priority

boolean

PublishErrorLog.setPublishTask(int _nPublishTaskId)
设置属性：PublishTaskId

boolean

PublishErrorLog.setPublishTask(PublishTask _task)
set the property of PublishTask

boolean

PublishTask.setPublishType(int _nPublishType)
设置属性：PublishType

boolean

PublishErrorLog.setResult(int _nResult)
设置属性：Result

boolean

PublishTask.setSchedulePublishTask(boolean _bSchedulePublishTask)
设置ISSCHEDULEDTASK属性,是否为计划发布

boolean

PublishTask.setStartTime(CMyDateTime _startTime)
设置属性：StartTime

boolean

PublishTask.setStatus(int _nStatus)
set the property of Status

boolean

PublishTask.setTimeUsed(int _nTimeUsed)
设置属性：TimeUsed

boolean

PublishTask.setTitle(java.lang.String _sTitle)
设置属性：Title

boolean

PublishTask.setURL(java.lang.String[] _sURL)
设置属性：URL

com.trs.components.common.publish.persistent.template 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.persistent.template 中的方法

TempAppendix

Template.addAppendix(User _currUser, java.lang.String _sFile, boolean _bAddRelation)
添加一个模板附件

boolean

TempAppendix.addRelation(int _templateId)
增加模板和附件的关联

boolean

TempAppendix.addRelation(Template _template)
增加模板和附件的关联

int

Template.clearAppendixes()
clear all appendxes of this template

static TemplateQuote

TemplateQuote.createNewInstance()
产生当前对象[TemplateQuote]的实例

static TemplateEmploy

TemplateEmploy.createNewInstance()
产生当前对象[TemplateEmploy]的实例

static TemplateArgument

TemplateArgument.createNewInstance()
产生当前对象[TemplateArgument]的实例

static Template

Template.createNewInstance()
产生当前对象[Template]的实例

static TempAppendix

TempAppendix.createNewInstance()
产生当前对象[TempAppendix]的实例

static TempApdRel

TempApdRel.createNewInstance()
产生当前对象[TempApdRel]的实例

static TagBean

TagBean.createNewInstance()
产生当前对象[TagBean]的实例

static Templates

Templates.createNewInstance(User _currUser)
产生当前集合对象[Templates]的实例

static TempAppendixes

TempAppendixes.createNewInstance(User _currUser)
产生一个当前集合对象[TempAppendixes]的实例

boolean

Template.deleteAppendix(int _appendixId)
删除一个模板附件，仅仅删除附件关联

boolean

Template.deleteAppendix(TempAppendix _appendix)
删除一个模板附件，仅仅删除附件关联

boolean

TempAppendix.deleteRelation(int _templateId)
删除模板和附件的关联

boolean

TempAppendix.deleteRelation(Template _template)
删除模板和附件的关联

static TemplateQuote

TemplateQuote.findById(int _nId)
提取指定ID的对象

static TemplateEmploy

TemplateEmploy.findById(int _nId)
提取指定ID的对象

static TemplateArgument

TemplateArgument.findById(int _nId)
提取指定ID的对象

static Template

Template.findById(int _nId)
提取指定ID的对象

static TempAppendix

TempAppendix.findById(int _nId)
提取指定ID的对象

static TempApdRel

TempApdRel.findById(int _nId)
提取指定ID的对象

static TagBean

TagBean.findById(int _nId)
提取指定ID的对象

static Templates

Templates.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static TempAppendixes

TempAppendixes.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static TempApdRels

TempApdRels.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static TemplateQuote

TemplateQuote.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static TemplateEmploy

TemplateEmploy.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static TemplateArgument

TemplateArgument.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Template

Template.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static TempAppendix

TempAppendix.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static TempApdRel

TempApdRel.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static TagBean

TagBean.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

Template

Templates.findByName(java.lang.String _sTempName)
根据模板名称从模板集合中查找模板

static TemplateArgument

TemplateArgument.findOf(java.lang.String _sArgName, java.lang.String _sPrexName)

TempApdRels

Template.getApdRels(WCMFilter _filter)
get the template appendix relations

TempAppendixes

Template.getAppendixes(User _currUser)
取模板的附件集合

TempAppendixes

Template.getAppendixes(User _currUser, int[] arrFlags)
取模板的附件集合

java.lang.String

Template.getCharSet()
获取模板的charset设置,如果模板本身没有设置,则返回从所属Folder所设置的发布语言.

IPublishFolder

Template.getFolder()
get the folder where the template is located.

java.lang.String

Template.getPubText()
取模板发布正文，用于模板解析

IPublishFolder

Template.getRoot()
get the root folder where the template is located.

Template

TemplateEmploy.getTemplate()

Template

TemplateArgument.getTemplate()
get the Template instance

java.lang.String

Template.getTextWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute)
模板文本图片过滤处理，用于模板正文的显示处理
处理过程：对模板正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于：
[1]模板正文显示，使用 getTextWithImgFilter( "show-pic.jsp?

void

TempAppendixXmlConverter.initConverter(int _nRootType, int _nRootId, java.lang.String _sExportPath)
使用converter时必须初始化一些参数，否则无法正常进行相关操作

void

TemplateQuote.insert(User _currUser)
将对象数据写入数据库

void

TemplateEmploy.insert(User _currUser)
将对象数据写入数据库

void

Template.insert(User _currUser)
添加模板对象到数据库

void

TempAppendix.insert(User _currUser)
添加模板附件对象到数据库

void

TagBean.insert(User _currUser)
将对象数据写入数据库

boolean

TemplateQuote.isValid()
检验对象数据有效性

boolean

TemplateEmploy.isValid()
检验对象数据有效性

boolean

TemplateArgument.isValid()

boolean

Template.isValid()
检查数据的有效性

boolean

TempAppendix.isValid()
检查模板附件对象数据的有效性

boolean

TempApdRel.isValid()
检验对象数据有效性

boolean

TagBean.isValid()
验证TRS置标解析组件是否有效

static Templates

Templates.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Templates]

static TemplateQuotes

TemplateQuotes.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[TemplateQuotes]

static TemplateEmploys

TemplateEmploys.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[TemplateEmploys]

static TemplateArguments

TemplateArguments.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[TemplateEmploys]

static TempAppendixes

TempAppendixes.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[TempAppendixes]

static TempApdRels

TempApdRels.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[TempApdRels]

void

Template.save(User _currUser)

boolean

Template.setApdModified(boolean _bModified)
设置模板附件是否被修改的标记

boolean

TemplateArgument.setArgumentName(java.lang.String _name)
设置属性：ArgumentName

boolean

TemplateArgument.setArgumentValue(boolean _value)
设置属性：ArgumentValue

boolean

TemplateArgument.setArgumentValue(int _value)
设置属性：ArgumentValue

boolean

TemplateArgument.setArgumentValue(java.lang.String _value)
设置属性：ArgumentValue

boolean

Template.setCharSet(java.lang.String charset)
设置模板的字符集属性,应该模板内容中的charset一致.

boolean

TemplateEmploy.setDefault(boolean _isDefault)
设置属性:IsDefault

boolean

Template.setDesc(java.lang.String _desc)
设置模板的描述

boolean

TemplateEmploy.setEmployer(int _nType, int _nId)
set the employer

boolean

TemplateArgument.setEmployer(int _nType, int _nId)
set the employer

boolean

TemplateEmploy.setEmployer(IPublishElement _employer)
set the employer

boolean

TemplateArgument.setEmployer(IPublishElement _employer)
set the employer

boolean

TagBean.setEnabled(boolean _bEnabled)
Sets the value of property Enabled.

boolean

TempAppendix.setFile(java.lang.String _sFile)
设置模板附件的文件名

boolean

TempAppendix.setFlag(int _nFlag)
设置模板附件的标记

boolean

Template.setFolder(int _nType, int _nId)
set the folder id

boolean

Template.setFolder(int _nFolderType, int _nFolderId, int _nRootType, int _nRootId)
set the folder where the template is located

boolean

Template.setFolder(IPublishFolder _folder)
set the folder where the template is located

boolean

Template.setFolder(IPublishFolder _folder, IPublishFolder _root)
set the folder where the template is located

boolean

Template.setName(java.lang.String _name)
设置模板的名称

boolean

Template.setOutputFileExt(java.lang.String _ext)
设置模板的扩展名

boolean

Template.setOutputFileName(java.lang.String _sFileName)
设置模板发布后的输出文件名

boolean

Template.setParsed(boolean _bParsed)
set the property of Parsed.

boolean

TemplateArgument.setPrefixOfName(java.lang.String _value)
设置属性：PrefixOfName

boolean

TemplateQuote.setQuotedFolder(int _nType, int _nId)
Sets the quoted folder with a specified folder.

boolean

TemplateQuote.setQuotedFolder(int _nType, int _nId, int _nFamilyIndex)
Sets the quoted folder property.

boolean

TemplateQuote.setQuotedFolderWithChild(int _nChildIndex)
Sets the quoted folder with the child of current folder who employs this template.

boolean

TemplateQuote.setQuotedFolderWithParent()
Set the quoted folder with the parent of current folder who employs this template.

boolean

TemplateQuote.setQuoteType(int _nQuoteType)
设置属性：QuoteType

boolean

Template.setRoot(int _nType, int _nId)
设置模板的所属文件夹根目录，仅添加模板时可用，不允许修改该属性。

boolean

TempAppendix.setRoot(int _nType, int _nId)
设置模板附件的所属文件夹根目录

boolean

TempAppendix.setRoot(IPublishFolder _root)
设置模板附件的所属文件夹根目录

boolean

TagBean.setTagBean(java.lang.String _sBean)
设置TRS置标解析组件的组件名

boolean

TagBean.setTagDesc(java.lang.String _sDesc)
设置TRS置标解析组件的描述

boolean

TagBean.setTagName(java.lang.String _sName)
设置TRS置标解析组件负责解析的置标名称

boolean

TempApdRel.setTempAppendixId(int _nTempAppendixId)
设置属性：TempAppendixId

boolean

TemplateQuote.setTemplate(int _nId, int _nTemplateType)
设置属性：TemplateId

boolean

TemplateEmploy.setTemplate(int _nTemplateType, int _nTemplateId)
设置属性：TemplateId

boolean

TemplateEmploy.setTemplate(Template _template)
set the template used

boolean

TemplateArgument.setTemplate(Template _template)
set the template

boolean

TemplateArgument.setTemplateId(int _nTemplateId)
设置属性：TemplateId

boolean

TempApdRel.setTemplateId(int _nTemplateId)
设置属性：TemplateId

boolean

Template.setText(java.lang.String _text)
设置模板正文

boolean

Template.setType(int _type)
设置模板的类型

void

Template.updateAppendixStatus()
设置模板Text属性（Html文本格式）

com.trs.components.common.publish.widget 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.widget 中的方法

WidgetInstParameters

IWidgetInstParameterMgr.addParameters(WidgetInstance oWidgetInstance, java.util.Map parameters)
给资源块实例对象设置相应的资源库实例变量,设置这些变量值之前，将清除该实例之前的所有变量

WidgetInstParameters

WidgetInstParameterMgr.addParameters(WidgetInstance oWidgetInstance, java.util.Map parameters)

boolean

IContentStyleMgr.checkCssFlag(PageStyle pageStyle, ContentStyle contentStyle, java.lang.String cssFlag)
在指定的页面风格下校验当前内容风格的风格标识（CssFlag）是否唯一

boolean

ContentStyleMgr.checkCssFlag(PageStyle _pageStyle, ContentStyle _currContentStyle, java.lang.String _cssFlag)
在指定的系统风格下校验CssFlag是否唯一

boolean

IResourceStyleMgr.checkCssFlag(PageStyle pageStyle, ResourceStyle resourceStyle, java.lang.String cssFlag)
在指定的系统风格下校验指定资源的风格标识（CssFlag）是否唯一

boolean

ResourceStyleMgr.checkCssFlag(PageStyle _pageStyle, ResourceStyle _currResourceStyle, java.lang.String _cssFlag)
在指定的系统风格下校验CssFlag是否唯一

boolean

ContentStyleServiceProvider.checkCssFlagOrNameCanUse(MethodContext _context)
判断指定的风格标识和风格名称是否在指定的页面风格下存在

boolean

ResourceStyleServiceProvider.checkCssFlagOrNameCanUse(MethodContext _context)
判断指定的风格标识和风格名称是否在指定的页面风格下存在

boolean

PageStyleServiceProvider.checkStyleDesc(MethodContext context)
检查风格中文（显示）名称是否唯一

boolean

PageStyleMgr.checkStyleDesc(PageStyle _oCurrPageStyle)
判断是否已经存在同名的风格

boolean

PageStyleServiceProvider.checkStyleName(MethodContext context)
检查风格英文名称是否唯一

boolean

PageStyleMgr.checkStyleName(PageStyle _oCurrPageStyle)
判断是否已经存在同名的风格

boolean

IContentStyleMgr.checkStyleName(PageStyle pageStyle, ContentStyle contentStyle, java.lang.String styleName)
在指定的页面风格下校验当前内容风格的风格名称（CssFlag）是否唯一

boolean

ContentStyleMgr.checkStyleName(PageStyle _pageStyle, ContentStyle _currContentStyle, java.lang.String _styleName)
在指定的系统风格下校验风格名称是否唯一

boolean

IResourceStyleMgr.checkStyleName(PageStyle pageStyle, ResourceStyle resourceStyle, java.lang.String styleName)
在指定的系统风格下校验指定资源的风格名称（StyleName）是否唯一

boolean

ResourceStyleMgr.checkStyleName(PageStyle _pageStyle, ResourceStyle _currResourceStyle, java.lang.String _styleName)
在指定的系统风格下校验风格名称是否唯一

ContentStyle

IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle)
仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle

ContentStyle

ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle)

ContentStyle

IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports)
仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle

ContentStyle

ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports)

PageStyle

IPageStyleMgr.copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle)
仿照指定的页面风格创建一份新的风格

PageStyle

PageStyleMgr.copy(User _currUser, PageStyle _sourcePageStyle, PageStyle _targetPageSytle)
仿照PageStyle创建一份新的风格

ResourceStyle

IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle)
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

ResourceStyle

ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle)
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

ResourceStyle

IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports)
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

ResourceStyle

ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports)
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

void

ISystemResourceStyleMgr.copyFor(User user, PageStyle pageStyle)
根据系统默认的资源可用风格为指定的系统风格创建

void

ISystemContentStyleMgr.copyFor(User user, PageStyle pageStyle)
根据系统默认的内容可用风格为指定的系统风格创建

void

SystemContentStyleMgr.copyFor(User _currUser, PageStyle _targetPageStyle)
根据系统默认的内容可用风格为指定的系统风格创建

void

SystemResourceStyleMgr.copyFor(User _currUser, PageStyle _targetPageStyle)
根据系统默认的资源可用风格为指定的系统风格创建

void

IStyleCenterMgr.copyToAllPageSylte(ContentStyle contentStyle)
给所有的风格下面都要建立当前这个内容风格

void

StyleCenterMgr.copyToAllPageSylte(ContentStyle _contentStyle)
给所有的风格下面都要建立当前这个内容风格

void

IStyleCenterMgr.copyToAllPageSylte(ResourceStyle resourceStyle)
给所有的页面风格下面都要建立当前这个资源风格

void

StyleCenterMgr.copyToAllPageSylte(ResourceStyle _resourceStyle)
给所有的风格下面都要建立当前这个资源风格

void

IStyleCenterMgr.createImgesDir(PageStyle pageStyle)
创建页面风格图片的存放目录

void

StyleCenterMgr.createImgesDir(PageStyle _pageStyle)
创建资源风格图片的存放目录

static WidgetInstance

WidgetInstance.createNewInstance()
产生当前对象[WidgetInstance]的实例

static PageStyle

PageStyle.createNewInstance()
产生当前对象[PageStyle]的实例

static WidgetInstParameter

WidgetInstParameter.createNewInstance()
产生当前对象[WidgetInstParameter]的实例

static Master

Master.createNewInstance()
产生当前对象[Master]的实例

static ContentStyle

ContentStyle.createNewInstance()
产生当前对象[ContentStyle]的实例

static Widget

Widget.createNewInstance()
产生当前对象[Widget]的实例

static StyleAndResource

StyleAndResource.createNewInstance()
产生当前对象[StyleAndResource]的实例

static WidgetParameter

WidgetParameter.createNewInstance()
产生当前对象[WidgetParameter]的实例

static Layout

Layout.createNewInstance()
产生当前对象[Layout]的实例

static ResourceStyle

ResourceStyle.createNewInstance()
产生当前对象[ResourceStyle]的实例

static StyleItem

StyleItem.createNewInstance()
产生当前对象[StyleItem]的实例

Template

IWidgetServer.createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType)
根据母版内容，创建新的模板

Template

WidgetServer.createTemplateFromMaster(IPublishFolder _oPageFolder, Master _oMaster, int _nMasterType)

void

ILayoutServiceProvider.delete(MethodContext context)

void

LayoutServiceProvider.delete(MethodContext context)
删除布局

void

IStyleItemMgr.delete(User loginUser, BaseStyle currBaseStyle)
删除指定风格对应的风格项（StyleItem）

void

StyleItemMgr.delete(User user, BaseStyle _baseStyle)
删除风格对应的风格项

void

IContentStyleMgr.delete(User _currUser, ContentStyle _contentStyle)
删除ContentStyle

void

ContentStyleMgr.delete(User _currUser, ContentStyle _contentStyle)

boolean

LayoutMgr.delete(User _oCurrUser, Layout _currLayout)
删除指定的布局

boolean

ILayoutMgr.delete(User _oCurrUser, Layouts _currLayouts)
删除布局

boolean

LayoutMgr.delete(User _oCurrUser, Layouts _oLayouts)
删除布局的集合

boolean

MasterMgr.delete(User _oCurrUser, Masters _oMasters)
删除母板

boolean

IMasterMgr.delete(User _oCurrUser, Masters _oMasters)
删除指定的母版

void

IPageStyleMgr.delete(User _currUser, PageStyle _pageStyle)
删除指定的页面风格

void

PageStyleMgr.delete(User _currUser, PageStyle pageStyle)
删除PageStyle

void

IResourceStyleMgr.delete(User _currUser, ResourceStyle _resourceStyle)
删除ResourceStyle

void

ResourceStyleMgr.delete(User _currUser, ResourceStyle _resourceStyle)

void

StyleAndResourceMgr.delete(User user, StyleAndResource _styleAndResource)

void

IStyleAndResourceMgr.delete(User _currUser, StyleAndResource _styleAndResource)
删除风格与资源的关联关系

void

IStyleItemMgr.delete(User _currUser, StyleItem _styleItem)
删除StyleItem

void

StyleItemMgr.delete(User _currUser, StyleItem styleItem)

boolean

IWidgetParameterMgr.delete(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)
删除资源变量

boolean

WidgetParameterMgr.delete(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)

void

IWidgetInstParameterMgr.delete(WidgetInstance oWidgetInstance)
清除某个资源实例下的所有资源实例的变量信息

void

WidgetInstanceMgr.delete(WidgetInstance widgetInstance)

void

IWidgetInstanceMgr.delete(WidgetInstance widgetInstance)
删除资源块实例和其下的所有变量

void

WidgetInstParameterMgr.delete(WidgetInstance oWidgetInstance)

void

ILayoutGenerator.deleteCss(Layout _currLayout)
删除当前布局对应的CSS样式内容

void

LayoutGenerator.deleteCss(Layout _currLayout)
删除当前布局对应的css样式

void

IPageStyleMgr.deletePageStyleInfos(User user, PageStyle pageStyle)
删除指定的页面风格的关联信息

void

PageStyleMgr.deletePageStyleInfos(User _currUser, PageStyle pageStyle)
删除页面风格的关联信息

void

StyleAndResourceMgr.deleteUnuseCSRItems(Widget systemResource, java.lang.String _sUseingIds)
删除资源与内容风格关联中没有使用的对象

void

IStyleAndResourceMgr.deleteUnuseCSRItems(Widget widget, java.lang.String objectIds)
删除资源与内容风格关联中没有使用的对象

void

IStyleItemMgr.deleteUnusePageOtherStyleItems(PageStyle pageStyle, java.lang.String objectIds)
删除页面style对应的没有使用的其他风格项

void

StyleItemMgr.deleteUnusePageOtherStyleItems(PageStyle _pageStyle, java.lang.String _sUseingIds)
删除页面style对应的没有使用的其他风格项

void

IStyleItemMgr.deleteUnuseStyleItems(BaseStyle baseStyle, java.lang.String objectIds)
删除指定风格没有使用的风格项

void

StyleItemMgr.deleteUnuseStyleItems(BaseStyle baseStyle, java.lang.String _sUseingIds)
删除指定风格没有使用的风格项

boolean

WidgetMgr.existSimilarWidget(Widget _oCurrWidget)
判断是否已经存在同名的资源

boolean

IWidgetParameterMgr.existWidgetParameter(Widget _oCurrWidget, WidgetParameter _oCurrWidgetParameter)
判断是否已经存在同名资源变量

boolean

WidgetParameterMgr.existWidgetParameter(Widget _oCurrWidget, WidgetParameter _oCurrWidgetParameter)

java.lang.String

MasterMgr.export(Masters _oMasters)
导出母板

java.lang.String

IMasterMgr.export(Masters _oMasters)
导出指定的母版

java.lang.String

WidgetMgr.export(Widgets _oWidgets)

ContentStyles

ContentStyleMgr.findByCssFlagAndPageStyle(java.lang.String _sCssFlag, PageStyle _oPageStyle)
根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 内容风格集合

ResourceStyles

ResourceStyleMgr.findByCssFlagAndPageStyle(java.lang.String _sCssFlag, PageStyle _oPageStyle)
根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 资源风格集合

static ContentStyle

ContentStyles.findByCssFlagAndPageStyle(User _currUser, java.lang.String _sCssFlag, int _nPageStyleId)
根据指定的风格标识和页面风格来获取内容风格

static ResourceStyle

ResourceStyles.findByCssFlagAndPageStyle(User _currUser, java.lang.String _sCssFlag, int _nPageStyleId)
根据指定的风格标识和页面风格来获取资源风格

static WidgetInstance

WidgetInstance.findById(int _nId)
提取指定ID的对象

static PageStyle

PageStyle.findById(int _nId)
提取指定ID的对象

static WidgetInstParameter

WidgetInstParameter.findById(int _nId)
提取指定ID的对象

static Master

Master.findById(int _nId)
提取指定ID的对象

static ContentStyle

ContentStyle.findById(int _nId)
提取指定ID的对象

static Widget

Widget.findById(int _nId)
提取指定ID的对象

static StyleAndResource

StyleAndResource.findById(int _nId)
提取指定ID的对象

static WidgetParameter

WidgetParameter.findById(int _nId)
提取指定ID的对象

static Layout

Layout.findById(int _nId)
提取指定ID的对象

static ResourceStyle

ResourceStyle.findById(int _nId)
提取指定ID的对象

static StyleItem

StyleItem.findById(int _nId)
提取指定ID的对象

java.lang.Object

ILayoutServiceProvider.findById(MethodContext context)

java.lang.Object

LayoutServiceProvider.findById(MethodContext context)
获取某个布局

java.lang.Object

ILayoutServiceProvider.findByIds(MethodContext context)

java.lang.Object

LayoutServiceProvider.findByIds(MethodContext context)
获取布局集合

static WidgetInstance

WidgetInstance.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static PageStyle

PageStyle.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static WidgetInstParameter

WidgetInstParameter.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Master

Master.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ContentStyle

ContentStyle.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Widget

Widget.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static StyleAndResource

StyleAndResource.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static WidgetParameter

WidgetParameter.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Layout

Layout.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ResourceStyle

ResourceStyle.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static StyleItem

StyleItem.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static PageStyle

PageStyle.findByName(java.lang.String _sName)
获取指定名称的风格

ContentStyles

ContentStyleMgr.findByStyleNameAndPageStyle(java.lang.String _sStyleName, PageStyle _oPageStyle)
根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 内容风格集合

ResourceStyles

ResourceStyleMgr.findByStyleNameAndPageStyle(java.lang.String _sStyleName, PageStyle _oPageStyle)
根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 资源风格集合

static ContentStyle

ContentStyles.findByStyleNameAndPageStyle(User _currUser, java.lang.String _sStyleName, int _nPageStyleId)
根据指定的风格名称和页面风格来获取内容风格

java.util.HashMap

IStyleCenterMgr.findCssFlagUsedStyles(PageStyle pageStyle, BaseStyle _oCurrBaseStyle, java.lang.String cssFlag)
当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。

java.util.HashMap

StyleCenterMgr.findCssFlagUsedStyles(PageStyle _oPageStyle, BaseStyle _oCurrBaseStyle, java.lang.String _sCssFlag)
当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。

Layout

ILayoutMgr.findLayoutByName(User _currUser, java.lang.String _sLayoutName)
根据传入的布局名称，返回找到的第一个布局对象，如果没有找到合适的布局对象，则返回null。

Layout

LayoutMgr.findLayoutByName(User _currUser, java.lang.String sLayoutName)

WidgetParameter

IWidgetParameterMgr.findParameter(WidgetInstParameter _oWidgetInstParameter)
根据资源变量实例获取到资源变量

WidgetParameter

WidgetParameterMgr.findParameter(WidgetInstParameter widgetInstParameter)

WidgetParameter

IWidgetParameterMgr.findParameterByName(Widget _oCurrWidget, java.lang.String sParameterName)
获取指定资源下，指定名称的资源变量

WidgetParameter

WidgetParameterMgr.findParameterByName(Widget _oCurrWidget, java.lang.String sParameterName)

static ContentStyles

ContentStyles.findSameCssFlagStyles(java.lang.String _sCssFlag)
根据指定的风格标识来获取内容风格集合

static ResourceStyles

ResourceStyles.findSameCssFlagStyles(java.lang.String _sCssFlag)
根据指定的风格标识来获取资源风格集合

static ContentStyles

ContentStyles.findSameNameStyles(java.lang.String _sStyleName)
根据指定的风格名称来获取资源风格集合

static ResourceStyles

ResourceStyles.findSameNameStyles(java.lang.String _sStyleName)
根据指定的风格名称来获取资源风格集合

java.lang.String

PageStyleServiceProvider.findStyleImageDir(MethodContext context)
获取风格中上传的图片路径(服务器端的物理地址)

java.lang.String

IStyleCenterMgr.findStyleImageDir(PageStyle pageStyle)
获取指定页面风格的图片所在目录

java.lang.String

StyleCenterMgr.findStyleImageDir(PageStyle _pageStyle)

java.util.HashMap

IStyleCenterMgr.findStyleNameUsedStyles(PageStyle _oPageStyle, BaseStyle _oBaseStyle, java.lang.String _sStyleName)
当前页面风格(_oPageStyle)下,除自己以外，名称为_sStyleName的资源风格以及内容风格。

java.util.HashMap

StyleCenterMgr.findStyleNameUsedStyles(PageStyle _oPageStyle, BaseStyle _oCurrBaseStyle, java.lang.String _sStyleName)
当前页面风格(_oPageStyle)下,除自己以外，名称为_sCssFlag的资源风格以及内容风格。

Widget

IWidgetMgr.findWidgetByName(User _oCurrUser, java.lang.String _sWidgetName)
根据传入的资源块名称，返回找到的第一个资源块对象，如果没有找到合适的资源块对象，则返回null。

Widget

WidgetMgr.findWidgetByName(User _oCurrUser, java.lang.String sWidgetName)

java.lang.String

ILayoutGenerator.generateHtml(Layout _currLayout, boolean _bCssInHtml)
生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可

java.lang.String

LayoutGenerator.generateHtml(Layout _currLayout, boolean _bCssInHtml)
产生布局的相关HTML代码

java.lang.String

ILayoutGenerator.generateHtml(Layout _currLayout, boolean _bCssInHtml, boolean _bColIndexAsText)
生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可

java.lang.String

LayoutGenerator.generateHtml(Layout _currLayout, boolean _bCssInHtml, boolean _bColIndexAsText)
产生布局的HTML代码和CSS代码

StyleAndResources

StyleAndResourceMgr.getContentStyleAndResource(Widget _systemResource, WCMFilter _filter)
获取内容风格和资源的关系

java.util.HashMap

StyleAndResourceMgr.getContentStyleAndResourceMap(Widget _systemResource, WCMFilter _filter)
获取内容风格和资源的关系

java.util.HashMap

IStyleAndResourceMgr.getContentStyleAndResourceMap(Widget systemResource, WCMFilter _filter)

ContentStyles

StyleAndResourceMgr.getContentStyles(Widget _resource, WCMFilter _filter)

ContentStyles

IStyleAndResourceMgr.getContentStyles(Widget _systemResource, WCMFilter _filter)
获取资源对应的内容可用风格

static java.lang.String

StylePathHelper.getCssTemplateFilePath()
获取风格样式文件的模板文件路径

static java.lang.String

StyleHelper.getCssTemplateFilePath()
获取样式模板所在路径

java.lang.String

Widget.getIdentityFlag(java.lang.String _sWidgetName)
提取唯一标识：IdentityFlag

java.lang.String

ILayoutServiceProvider.getLayoutHtml(MethodContext context)
通过获取比例类型和比例值来直接返回相应的HTML内容

java.lang.String

LayoutServiceProvider.getLayoutHtml(MethodContext context)
通过web页面发送布局比例类型和布局比例信息来获取到相应的HTML代码,该服务需要将布局的样式信息写到HTML代码中

java.lang.String

MasterMgr.getMasterFileContent(Master oMaster, int _nFileType)
获取指定母板中指定文件类型的文件内容

java.lang.String

IMasterMgr.getMasterFileContent(Master _oMaster, int _nFileType)
获取指定母板中指定文件类型的文件内容

java.util.Map

IWidgetInstParameterMgr.getParameters(WidgetInstance oWidgetInstance)
根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写 修改说明：先取资源默认的资源变量值，再用资源变量实例值覆盖，防止添加资源变量后 在解析资源代码时有些变量不能替换的问题

java.util.Map

WidgetInstParameterMgr.getParameters(WidgetInstance widgetInstance)

java.util.Map

IWidgetInstParameterMgr.getParameters(WidgetInstance oWidgetInstance, java.lang.String sSelectFields)
根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写

java.util.Map

WidgetInstParameterMgr.getParameters(WidgetInstance widgetInstance, java.lang.String selectFields)

static java.lang.String

WidgetPathHelper.getPath()

ResourceStyles

IResourceStyleMgr.getResourceStyles(PageStyle pageStyle)
获取指定页面风格下的资源可用风格集合

ResourceStyles

ResourceStyleMgr.getResourceStyles(PageStyle _pageStyle)
获取指定系统风格下的资源可用风格集合

static RightValue

SpecialAuthServer.getRightValue(CMSObj operator, java.lang.Class clazz)
获取指定用户在指定对象类型上的权限值，如是否能新建，导入等

static RightValue

SpecialAuthServer.getRightValue(CMSObj operator, CMSObj obj)
获取指定用户在指定对象上的权限值

static java.lang.String

SubjectDataInitHelper.getSpecialInitDataPath(javax.servlet.http.HttpServletRequest req)

static java.lang.String

StylePathHelper.getStyleCommonDir()
获取风格资源文件所在的路径

static java.lang.String

StylePathHelper.getStyleCommonDir(java.lang.String _sStyleName)
获取指定风格资源文件所在的路径

static java.lang.String

StylePathHelper.getStyleCssDir()
获取生成的风格样式文件路径

java.io.File

IStyleCenterMgr.getStyleFile(PageStyle _currPageStyle)
获取风格对应的样式文件

java.io.File

StyleCenterMgr.getStyleFile(PageStyle pageStyle)

ContentStyles

SystemContentStyleMgr.getSystemContentStyles()
获取系统级资源可用风格

ResourceStyles

SystemResourceStyleMgr.getSystemResourceStyles()
获取系统级资源可用风格

static java.lang.String

StylePathHelper.getWcmServerDir()
获取WCM应用所在的路径，通过WCM_PATH获取

Widget

WidgetInstance.getWidget()

WidgetInstParameter

IWidgetInstParameterMgr.getWidgetInstParameter(WidgetInstance widgetInstance, java.lang.String sParaName)
获取指定资源块实例下的资源块实例变量

WidgetInstParameter

WidgetInstParameterMgr.getWidgetInstParameter(WidgetInstance widgetInstance, java.lang.String paraName)

WidgetInstParameters

IWidgetInstParameterMgr.getWidgetInstParameters(WidgetInstance oWidgetInstance, WCMFilter oFilter)
获取资源块实例关联的资源块实例变量对象集合

WidgetInstParameters

WidgetInstParameterMgr.getWidgetInstParameters(WidgetInstance widgetInstance, WCMFilter filter)

static boolean

SpecialAuthServer.hasRight(CMSObj operator, CMSObj obj, int nRightIndex)
判断当前操作者operator在对象obj上是否有权限nRightIndex

Reports

MasterMgr.importMasters(User _oCurrUser, java.lang.String _sImportMastersFileName)
导入母板

Reports

IMasterMgr.importMasters(User _oCurrUser, java.lang.String _sImportMastersFileName)
导入母版

Reports

WidgetMgr.importWidgets(java.lang.String _sFile, int _nImportMode)

static void

SubjectDataInitHelper.initData(javax.servlet.http.HttpServletRequest req)

void

WidgetInstance.insert(User _currUser)
将对象数据写入数据库

void

PageStyle.insert(User _currUser)
将对象数据写入数据库

void

WidgetInstParameter.insert(User _currUser)
将对象数据写入数据库

void

Master.insert(User _currUser)
将对象数据写入数据库

void

ContentStyle.insert(User _currUser)
将对象数据写入数据库

void

Widget.insert(User _currUser)
将对象数据写入数据库

void

StyleAndResource.insert(User _currUser)
将对象数据写入数据库

void

WidgetParameter.insert(User _currUser)
将对象数据写入数据库

void

Layout.insert(User _currUser)
将对象数据写入数据库

void

ResourceStyle.insert(User _currUser)
将对象数据写入数据库

void

StyleItem.insert(User _currUser)
将对象数据写入数据库

void

IWidgetServer.insertStyleTag(Special special, Template template)
专题设置页面风格时所触发的逻辑，将专题所属的首页模板插入含当前页面风格标识的置标，发布时完成风格的切换

void

WidgetServer.insertStyleTag(Special special, Template template)

boolean

WidgetInstance.isValid()
检验对象数据有效性

boolean

PageStyle.isValid()
检验对象数据有效性

boolean

WidgetInstParameter.isValid()
检验对象数据有效性

boolean

Master.isValid()
检验对象数据有效性

boolean

ContentStyle.isValid()
检验对象数据有效性

boolean

Widget.isValid()
检验对象数据有效性

boolean

StyleAndResource.isValid()
检验对象数据有效性

boolean

WidgetParameter.isValid()
检验对象数据有效性

boolean

Layout.isValid()
检验对象数据有效性

boolean

ResourceStyle.isValid()
检验对象数据有效性

boolean

StyleItem.isValid()
检验对象数据有效性

java.lang.String

IPageStyleMgr.makeBaseStyleContent(PageStyle pageStyle)
生成页面风格基本特性样式

java.lang.String

PageStyleMgr.makeBaseStyleContent(PageStyle _pageStyle)
生成页面基本特性样式

java.lang.String

IContentStyleMgr.makeCssContent(ContentStyle _contentStyle)
生成指定PageStyle下可用的内容风格css文件

java.lang.String

ContentStyleMgr.makeCssContent(ContentStyle _contentStyle)

java.lang.String

IResourceStyleMgr.makeCssContent(ResourceStyle _currResourceStyle)
生成资源的可用风格内容

java.lang.String

ResourceStyleMgr.makeCssContent(ResourceStyle _resourceStyle)

static java.lang.String

StyleHelper.makeCSSContent(java.lang.String _sCssFlag, java.lang.String _sCSSTemplateContent, StyleItems _items)
根据风格模板替换其中的标记生成可以使用的风格内容

static java.lang.String

StyleHelper.makeCustomCssContent(java.lang.String _sCssFlag, java.lang.String _sCustomStyle)
产生自定义的风格内容

java.lang.String

IPageStyleMgr.makePageOtherStyleContent(PageStyle style)
生成页面其他样式

java.lang.String

PageStyleMgr.makePageOtherStyleContent(PageStyle _pageStyle)
生成页面其他样式

java.lang.String

IStyleCenterMgr.makePreviewCssContent(ContentStyle contentStyle)
获取内容可用风格预览时需要的样式内容

java.lang.String

StyleCenterMgr.makePreviewCssContent(ContentStyle _contentStyle)
获取内容可用风格预览时需要的样式内容

java.lang.String

IStyleCenterMgr.makePreviewCssContent(ResourceStyle resourceStyle)
获取资源可用风格预览时需要的样式内容

java.lang.String

StyleCenterMgr.makePreviewCssContent(ResourceStyle _resourceStyle)
获取资源可用风格预览时需要的样式内容

void

TemplateLCListenerVisualTemplate.notifyOnAddObj(BaseObj objAdded)

void

AdjustJsLCListenerWidget.notifyOnDelObj(BaseObj objDeleted, int eventType)

void

TemplateLCListenerVisualTemplate.notifyOnDelObj(BaseObj objDeleted, int eventType)

void

AdjustJsLCListenerWidget.notifyOnModifyObj(BaseObj objModified, int eventType)

void

TemplateLCListenerVisualTemplate.notifyOnModifyObj(BaseObj objModified, int eventType)

static WidgetParameters

WidgetParameters.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[WidgetParameters]

static PageStyles

PageStyles.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[PageStyles]

static ContentStyles

ContentStyles.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ContentStyles]

static WidgetInstParameters

WidgetInstParameters.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[WidgetInstParameters]

static ResourceStyles

ResourceStyles.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ResourceStyles]

static Widgets

Widgets.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Widgets]

static Masters

Masters.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Masters]

static StyleAndResources

StyleAndResources.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[StyleAndResources]

static Layouts

Layouts.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Layouts]

static StyleItems

StyleItems.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[StyleItems]

static WidgetInstances

WidgetInstances.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[WidgetInstances]

static java.util.List

StyleHelper.parseCssContent(java.lang.String _cssContent)
将模板中的CSS内容解析成多个List对象
过滤了模板中的样式和多余的回车换行

java.lang.String

IWidgetServer.parseToTemplate(java.lang.String sVisaulTemplate)
将可视化模板的内容，解析成相应的模板

java.lang.String

WidgetServer.parseToTemplate(java.lang.String sVisualHtml)

java.lang.String

IStyleCenterMgr.previewStyle(PageStyle pageStyle, java.lang.String cssFlag, java.lang.String templateName, StyleItems styleItems, java.lang.String customStyle)
预览时，获取风格的内容

java.lang.String

StyleCenterMgr.previewStyle(PageStyle _pageStyle, java.lang.String sCssFlag, java.lang.String sTemplateName, StyleItems _styleItems, java.lang.String _customStyle)
预览时，获取风格的内容

java.lang.String

IPageStyleMgr.previewStyle(PageStyle pageStyle, StyleItems styleItems)
获取预览时需要的样式内容

java.lang.String

PageStyleMgr.previewStyle(PageStyle _pageStyle, StyleItems _styleItems)
获取预览时需要的样式内容

static java.lang.String

StyleRepeatNameHelper.processCssFlag(java.lang.String _sRealCssFlag, int _nImportMode, int _nStyleType)
处理风格名称

static java.lang.String

StyleRepeatNameHelper.processStyleName(java.lang.String _sRealName, int _nImportMode, int _nStyleType)
处理风格名称

java.lang.Object

ILayoutServiceProvider.query(MethodContext context)

java.lang.Object

LayoutServiceProvider.query(MethodContext context)
查询布局

ContentStyles

IContentStyleMgr.query(PageStyle _currPageStyle, WCMFilter _filter)
在指定PageStyle下获取ContentStyle集合

ContentStyles

ContentStyleMgr.query(PageStyle pageStyle, WCMFilter _filter)

ResourceStyles

IResourceStyleMgr.query(PageStyle _currPageStyle, WCMFilter _filter)
获取指定页面风格下的ResourceStyle集合

ResourceStyles

ResourceStyleMgr.query(PageStyle pageStyle, WCMFilter _filter)

WidgetParameters

IWidgetParameterMgr.query(User _oCurrUser, WCMFilter _oFilter)
获取某资源所具有的资源变量

Masters

MasterMgr.query(User _oCurrUser, WCMFilter _oFilter)
查询系统指定的母板

Layouts

ILayoutMgr.query(User _currUser, WCMFilter _currFilter)
查询布局

WidgetParameters

WidgetParameterMgr.query(User _oCurrUser, WCMFilter _oFilter)

Layouts

LayoutMgr.query(User _currUser, WCMFilter _filter)
通过条件查询布局

Masters

IMasterMgr.query(User _oCurrUser, WCMFilter _currFilter)
查询系统指定母版

PageStyles

IPageStyleMgr.query(WCMFilter _filter)
获取页面风格集合

PageStyles

PageStyleMgr.query(WCMFilter _filter)
获取PageStyle集合

StyleItems

StyleItemMgr.query(WCMFilter _filter)
获取风格元素集合

WidgetParameters

IWidgetParameterMgr.query(Widget _oCurrWidget)
获取资源的所有资源变量

WidgetParameters

WidgetParameterMgr.query(Widget _oCurrWidget)

ContentStyles

IContentStyleMgr.queryContenetStyles(PageStyle pageStyle)
获取指定系统风格下的内容可用风格集合

ContentStyles

ContentStyleMgr.queryContenetStyles(PageStyle _pageStyle)
获取指定系统风格下的内容可用风格集合

java.util.HashMap

IStyleItemMgr.queryPageOtherStyleItemMap(PageStyle pageStyle, WCMFilter _filter)
获取页面其他风格样式项

java.util.HashMap

StyleItemMgr.queryPageOtherStyleItemMap(PageStyle pageStyle, WCMFilter _filter)
获取页面其他风格样式项

StyleItems

IStyleItemMgr.queryPageOtherStyleItems(PageStyle pageStyle, WCMFilter _filter)
获取页面其他风格样式项

StyleItems

StyleItemMgr.queryPageOtherStyleItems(PageStyle _pageStyle, WCMFilter _filter)
获取页面其他风格样式项

java.util.HashMap

IStyleItemMgr.queryStyleItemMap(BaseStyle baseStyle, WCMFilter _filter)
获取指定风格的风格项

java.util.HashMap

StyleItemMgr.queryStyleItemMap(BaseStyle _baseStyle, WCMFilter _filter)
获取指定风格的风格项

java.util.HashMap

StyleItemServiceProvider.queryStyleItemMap(MethodContext context)
获取指定风格对应的风格项集合

StyleItems

IStyleItemMgr.queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter)
获取某种（页面风格，资源可用风格，内容可用风格）风格下的StyleItem集合

StyleItems

StyleItemMgr.queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter)
获取指定风格的风格项

java.lang.Object

StyleItemServiceProvider.queryStyleItems(MethodContext context)
获取指定风格对应的风格项集合

java.lang.String

IWidgetServer.replaceWidgetInstParameters(WidgetInstance widgetInstance)
通过资源实例，获取资源实例的内容，并替换其中的资源实例变量

java.lang.String

WidgetServer.replaceWidgetInstParameters(WidgetInstance widgetInstance)

void

IStyleCenterMgr.resetStyle(BaseStyle baseStyle)
将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置

void

StyleCenterMgr.resetStyle(BaseStyle _oCurrBaseStyle)
将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置

int

ILayoutServiceProvider.save(MethodContext _context)

int

LayoutServiceProvider.save(MethodContext context)
保存布局

Master

IMasterServiceProvider.save(java.lang.String _sMasterName, java.lang.String _sFileName)
创建或者更新母板

Master

MasterServiceProvider.save(java.lang.String _sMasterName, java.lang.String _sFileName)
根据母板名称以及母板的文件名保存母板

StyleItem

IStyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem)
保存（新增、编辑）StyleItem

StyleItem

StyleItemMgr.save(User _currUser, BaseStyle _baseStyle, StyleItem _styleItem)

ContentStyle

IContentStyleMgr.save(User _currUser, ContentStyle _contentStyle)
保存（新增、编辑）ContentStyle

ContentStyle

ContentStyleMgr.save(User _currUser, ContentStyle _contentStyle)

Layout

ILayoutMgr.save(User _oCurrUser, Layout _currLayout)
新建或者保存布局

Layout

LayoutMgr.save(User _oCurrUser, Layout _currLayout)
保存当前布局，若ID为0则为创建布局,将样式文件写到文件上，不保存到HTML代码中

Master

MasterMgr.save(User _oUser, Master _oMaster)
保存当前母板

Master

IMasterMgr.save(User _oCurrUser, Master _oCurrMaster)

PageStyle

IPageStyleMgr.save(User _currUser, PageStyle _pageStyle)
保存（新增、编辑）页面风格

PageStyle

PageStyleMgr.save(User user, PageStyle pageStyle)
只保存风格的基本属性，不负责保存关联对象

ResourceStyle

IResourceStyleMgr.save(User _currUser, ResourceStyle _resourceStyle)
保存（新增、编辑）资源风格

ResourceStyle

ResourceStyleMgr.save(User _currUser, ResourceStyle _resourceStyle)
保存（新增、编辑）ResourceStyle

Master

MasterMgr.save(User _oUser, java.lang.String _sMasterName, java.lang.String _sFileName)
保存当前母板

Master

IMasterMgr.save(User _oCurrUser, java.lang.String _sMasterName, java.lang.String _sFileName)
保存当前母版

StyleAndResource

StyleAndResourceMgr.save(User user, StyleAndResource _styleAndResource)

StyleAndResource

IStyleAndResourceMgr.save(User _currUser, StyleAndResource _styleAndResource)
保存修改StyleAndResource

WidgetInstance

WidgetInstanceMgr.save(User _loginUser, WidgetInstance _WidgetInstance)

WidgetInstance

IWidgetInstanceMgr.save(User loginUser, WidgetInstance oWidgetInstance)
对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象

WidgetInstance

WidgetInstanceMgr.save(WidgetInstance widgetInstance, java.util.Map parameters)

WidgetInstance

IWidgetInstanceMgr.save(WidgetInstance oWidgetInstance, java.util.Map parameters)
修改指定的资源块实例的变量信息

StyleItem

IStyleItemMgr.savePageOtherStyleItem(User loginUser, PageStyle pageStyle, StyleItem styleItem)
保存页面风格对应的其他风格属性

StyleItem

StyleItemMgr.savePageOtherStyleItem(User _currUser, PageStyle pageStyle, StyleItem _styleItem)
保存页面风格对应的其他风格属性

WidgetInstParameters

IWidgetInstParameterMgr.saveParameters(WidgetInstance oWidgetInstance, java.util.Map parameters)
给资源块实例对象设置相应的资源库实例变量，仅仅只是设置这些传入了的变量的值

WidgetInstParameters

WidgetInstParameterMgr.saveParameters(WidgetInstance oWidgetInstance, java.util.Map parameters)

WidgetParameter

IWidgetParameterMgr.saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)
保存资源变量

WidgetParameter

WidgetParameterMgr.saveWidgetParameter(User _oCurrUser, WidgetParameter _oCurrWidgetParameter)

boolean

Widget.setCDefaultStyle(int _nCDefaultStyle)
设置属性：CDefaultStyle

boolean

WidgetParameter.setClassId(int _nClassId)
设置属性：CLASSID

boolean

StyleItem.setClassName(java.lang.String _sClassName)
设置属性：ClassName

boolean

StyleItem.setClassValue(java.lang.String _sClassValue)
设置属性：ClassValue

boolean

Layout.setColumns(int _nColumns)
设置属性：Columns

boolean

Widget.setContentStyle(java.lang.String _sContentStyle)
设置属性：ContentStyle

boolean

ContentStyle.setCssFlag(java.lang.String _sCssFlag)
设置属性：风格标识

boolean

StyleAndResource.setCssFlag(java.lang.String _sCssFlag)
设置属性：CssFlag

boolean

ResourceStyle.setCssFlag(java.lang.String _sCssFlag)
设置属性：风格标识

boolean

PageStyle.setCustomStyle(java.lang.String _sCustomStyle)
设置属性：自定义样式

boolean

ContentStyle.setCustomStyle(java.lang.String _sCustomStyle)
设置属性：自定义样式

boolean

ResourceStyle.setCustomStyle(java.lang.String _sCustomStyle)
设置属性：自定义的风格样式

boolean

WidgetParameter.setDefaultValue(java.lang.String _sDefaultValue)
设置属性：DefaultValue

boolean

WidgetParameter.setEnmvalue(java.lang.String _sEnmvalue)
设置属性：Enmvalue

boolean

Master.setFileName(java.lang.String _sFileName)
设置属性：FileName

boolean

Layout.setHtmlContent(java.lang.String _sHtmlContent)
设置属性：HtmlContent

boolean

PageStyle.setIsImport(int _nIsImport)
设置属性：是否是导入的对象

boolean

ContentStyle.setIsPrivate(int _nIsPrivate)
设置属性：是否是私有对象

boolean

ResourceStyle.setIsPrivate(int _nIsPrivate)
设置属性：是否是私有对象

boolean

PageStyle.setIsPublish(int _nIsPublish)
设置属性：是否发布

boolean

Master.setMDesc(java.lang.String _sMDesc)
设置属性：MDesc

boolean

Master.setMName(java.lang.String _sMName)
设置属性：MName

boolean

Layout.setName(java.lang.String _sName)
设置属性：Name

boolean

WidgetParameter.setNotEdit(int _nNotEdit)
设置属性：NotEdit

boolean

WidgetParameter.setNotnull(int _nNotnull)
设置属性：Notnull

boolean

WidgetParameter.setOrder(int _nOrder)
设置属性：Order

boolean

ContentStyle.setPageStyleId(int _nPageStyleId)
设置属性：页面风格ID

boolean

ResourceStyle.setPageStyleId(int _nPageStyleId)
设置属性：页面风格ID

boolean

WidgetInstParameter.setParamName(java.lang.String _sParamName)
设置属性：ParamName

boolean

WidgetInstParameter.setParamValue(java.lang.String _sParamValue)
设置属性：ParamValue

boolean

Master.setPicFileName(java.lang.String _sPicFileName)
设置属性：PicFileName

boolean

WidgetParameter.setRadorchk(int _nRadorchk)
设置属性：Radorchk

boolean

Layout.setRatio(java.lang.String _sRatio)
设置属性：Ratio

boolean

Layout.setRatioType(int _nRatioType)
设置属性：RatioType

void

IStyleCenterMgr.setResoruceStylePrivate(ContentStyle contentStyle)
设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。

void

StyleCenterMgr.setResoruceStylePrivate(ContentStyle _contentStyle)
设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。

boolean

StyleAndResource.setResourceId(int _nResourceId)
设置属性：ResourceId

void

IStyleCenterMgr.setResourceStylePrivate(ResourceStyle resourceStyle)
设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。

void

StyleCenterMgr.setResourceStylePrivate(ResourceStyle _resourceStyle)
设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。

boolean

ContentStyle.setSrcContentStyleId(int _nSrcContentStyleId)
设置属性：源内容风格ID

boolean

PageStyle.setSrcPageStyleId(int _sSrcPageStyleId)
设置属性：源页面风格

boolean

ResourceStyle.setSrcResourceStyleId(int _nSrcResourceStyleId)
设置属性：源资源风格ID

boolean

BaseStyle.setStyleDesc(java.lang.String _sStyleDesc)
设置属性：风格描述

boolean

BaseStyle.setStyleName(java.lang.String _sStyleName)
设置属性：风格名称

boolean

StyleAndResource.setStyleObjId(int _nStyleObjId)
设置属性：StyleObjId

boolean

StyleItem.setStyleObjId(int _nStyleObjId)
设置属性：StyleObjId

boolean

StyleAndResource.setStyleObjType(int _nStyleObjType)
设置属性：StyleObjType

boolean

StyleItem.setStyleObjType(int _nStyleObjType)
设置属性：StyleObjType

boolean

ContentStyle.setStyleThumb(java.lang.String _sStyleThumb)
设置属性：风格缩略图

boolean

ResourceStyle.setStyleThumb(java.lang.String _sStyleThumb)
设置属性：风格缩略图

boolean

BaseStyle.setStyleThumb(java.lang.String _sStyleThumb)
设置属性：风格缩略图

boolean

ContentStyle.setTemplate(java.lang.String _sTempalte)
设置属性：样式模板

boolean

ResourceStyle.setTemplate(java.lang.String _sTempalte)
设置属性：风格样式模板

boolean

BaseStyle.setTemplate(java.lang.String _sTemplate)
设置属性：风格样式模板

boolean

WidgetInstance.setTemplateId(int _nTemplateId)
设置属性：TemplateId

boolean

WidgetParameter.setValidator(java.lang.String _sValidator)
设置属性：Validator

boolean

Widget.setWDefaultStyle(java.lang.String _sWDefaultStyle)
设置属性：WDefaultStyle

boolean

Widget.setWdesc(java.lang.String _sWdesc)
设置属性：Wdesc

boolean

Widget.setWidgetAttrURL(java.lang.String _sWidgetAttrURL)
设置属性：WidgetAttrURL

boolean

Widget.setWidgetcontent(java.lang.String _sWidgetcontent)
设置属性：Widgetcontent

boolean

WidgetInstance.setWidgetId(int _nWidgetId)
设置属性：WidgetId

boolean

WidgetParameter.setWidgetId(int _nWidgetId)
设置属性：WidgetId

boolean

WidgetInstParameter.setWidgetInstId(int _nWidgetInstId)
设置属性：WidgetInstId

boolean

WidgetParameter.setWidgetParamDesc(java.lang.String _sWidgetParamDesc)
设置属性：WidgetParamDesc

boolean

WidgetParameter.setWidgetParamName(java.lang.String _sWidgetParamName)
设置属性：WidgetParamName

boolean

WidgetParameter.setWidgetParamType(int _nWidgetParamType)
设置属性：WidgetParamType

boolean

Widget.setWidgetpic(java.lang.String _sWidgetpic)
设置属性：Widgetpic

boolean

Widget.setWidgetType(int _nWidgetType)
设置属性：WidgetType

boolean

Widget.setWname(java.lang.String _sWname)
设置属性：Wname

void

IVisualTemplateServiceProvider.synchronizeWidgetInstances(MethodContext _methodContext)
将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。

void

VisualTemplateServiceProvider.synchronizeWidgetInstances(MethodContext methodContext)

void

IWidgetServer.synchronizeWidgetInstances(Template template)
将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。

void

WidgetServer.synchronizeWidgetInstances(Template template)

static void

SubjectDataInitHelper.updateDemoDataWidgetParamtersAndRegion()

boolean

ILayoutMgr.validate(Layout _currLayout)
验证布局的各属性是否符合规范，包括布局比例值和布局的HTML代码 注：布局HTML代码的验证斩不实现，为用户提交HTML内容代码提供验证功能

boolean

LayoutMgr.validate(Layout _currLayout)
验证布局属性信息，包括比例和HTML内容

boolean

ILayoutGenerator.validateHtml(Layout _currLayout)
对用户上传的HTML代码进行验证，查看是否符合相关规范，如果不允许用户上传，可以直接返回true

boolean

LayoutGenerator.validateHtml(Layout layout)
验证布局的HTML内容是否符合规范 （扩展用，暂不实现）

java.lang.String

MasterMgr.validateMasterFile(java.lang.String _sFileName)
校验母版文件的合法性

java.lang.String

IMasterMgr.validateMasterFile(java.lang.String _sFileName)
校验母版文件的合法性

java.lang.String

IMasterServiceProvider.validateMasterFile(java.lang.String _sFileName)
校验母版文件的合法性

java.lang.String

MasterServiceProvider.validateMasterFile(java.lang.String _sFileName)
校验母板文件的合法性

boolean

LayoutMgr.validateRatio(Layout _currLayout)
验证布局比例是否符合规范(包括比例类型和比例值)

com.trs.components.common.publish.widget.tagparser 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.publish.widget.tagparser 中的方法

RightValue

WCMTagParserBaseOperation.getChannelRightValue(User _currUser, BaseChannel _oBaseChannel)
获取栏目的权限

boolean

WCMTagParserDocInChnlOperation.hasSuperRight(BaseChannel host, CMSObj _aUser)
判断当前Operator对于指定结点是否有Super权限

java.lang.String[]

WCMTagParserPageStyle.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserSpecialAppendix.parse(PublishTagContext _context)
解析

java.lang.String[]

WCMTagParserWidget.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserBaseOperation.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserLayout.parse(PublishTagContext context)

java.lang.String[]

WCMTagParserTagCreator.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserLayoutCell.parse(PublishTagContext context)

java.lang.String[]

WCMTagParserPreWidget.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserSpecialLogo.parse(PublishTagContext _context)
解析

java.lang.String[]

WCMTagParserResources.parse(PublishTagContext _context)
发布产生指定的资源

com.trs.components.common.reminder 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.reminder 中的方法

static void

Reminder.createSchedule(Message _newMessage, CMyDateTime _dtRemind)
创建一个消息提醒

com.trs.components.common.trsad 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.trsad 中的方法

void

ADPos.ChnlInit(Channel _chnl, User _user)
初始化栏目

void

ADPos.ChnlInit(WebSite _website, User _user)
初始化站点

int

ADPos.delete(User _currUser)
重载父类方法删除属于广告位的所有广告记录

int

ADFile.delete(User _currUser)

int

ADCom.delete(User _currUser)
删除公司同时删除该公司的所有广告

ADCom

ADFile.getADCom()

ADFile

ADFilePos.getADFile()

ADFiles

ADType.getADFiles()

ADFiles

ADPos.getADFiles()
得到本广告位的广告的记录集

ADFiles

ADCom.getADFiles()
得到ADFiles集合对象

ADPos

ADFilePos.getADPos()

ADFiles

ADPos.getCurrADFiles()
得到本广告位的当前可用广告的记录集

java.lang.String

ADPoss.getLeaveNos(int _currChnlId, int _pClass)
getLeaveNos取得没有连续的广告位置；

int

ADPoss.getMaxPNo(int _pChnlId, int _pClass)

CMSObj

ADPos.getWebObj()
得到站点或频道对象

void

ADType.insert(User _currUser)
将对象数据写入数据库

void

ADPos.insert(User _currUser)
将对象数据写入数据库

void

ADFilePos.insert(User _currUser)
将对象数据写入数据库

void

ADFile.insert(User _currUser)
将对象数据写入数据库

void

ADCom.insert(User _currUser)
将对象数据写入数据库

boolean

ADType.isValid()
检验对象数据有效性

boolean

ADPos.isValid()
检验对象数据有效性

boolean

ADFilePos.isValid()
检验对象数据有效性

boolean

ADFile.isValid()
检验对象数据有效性

boolean

ADCom.isValid()
检验对象数据有效性

boolean

ADFile.setAdAction(java.lang.String _sAdAction)
设置属性：AdAction

boolean

ADFile.setAdAttribute(java.lang.String _sAdAttribute)
设置属性：AdAttribute

boolean

ADFilePos.setAdBegin(CMyDateTime _dtAdBegin)
设置属性：AdBegin

boolean

ADFile.setAdBegin(CMyDateTime _dtAdBegin)
设置属性：AdBegin

boolean

ADFile.setAdCompany(int _nAdCompany)
设置属性：AdCompany

boolean

ADFile.setAdCrTime(CMyDateTime _dtAdCrTime)
设置属性：AdCrTime

boolean

ADFile.setAdCrUser(java.lang.String _sAdCrUser)
设置属性：AdCrUser

boolean

ADFile.setAdDesc(java.lang.String _sAdDesc)
设置属性：AdDesc

boolean

ADFilePos.setAdEnd(CMyDateTime _dtAdEnd)
设置属性：AdEnd

boolean

ADFile.setAdEnd(CMyDateTime _dtAdEnd)
设置属性：AdEnd

boolean

ADFile.setAdExt(java.lang.String _sAdExt)
设置属性：AdExt

boolean

ADFilePos.setAdFileId(int _nAdFileId)
设置属性：AdFileId

boolean

ADType.setAdFileKind(int _nAdFileKind)
设置属性：AdFileKind

boolean

ADFile.setAdFileName(java.lang.String _sAdName)
设置属性：AdFileName广告文件名

boolean

ADFile.setAdFlag(int _nAdFlag)
设置属性：AdFlag

boolean

ADFile.setAdHeight(int _nAdHeight)
设置属性：AdHeight

boolean

ADFile.setAdHit(int _nAdHit)
设置属性：AdHit

boolean

ADFile.setAdIsWork(int _nAdIsWork)
设置属性：AdIsWork

boolean

ADFile.setAdName(java.lang.String _sAdName)
设置属性：AdName广告名称

boolean

ADFilePos.setAdPosId(int _nAdPosId)
设置属性：AdPosId

boolean

ADFile.setAdPrice(int _nAdPrice)
设置属性：AdPrice

boolean

ADFilePos.setAdTagHit(int _nAdTagHit)
设置属性：AdTagHit

boolean

ADFile.setAdType(int _nAdType)
设置属性：AdType

boolean

ADType.setAdTypeName(java.lang.String _sAdTypeName)
设置属性：AdTypeName

boolean

ADFile.setAdUrl(java.lang.String _sAdUrl)
设置属性：AdUrl

boolean

ADFile.setAdWidth(int _nAdWidth)
设置属性：AdWidth

boolean

ADCom.setComAddress(java.lang.String _sComAddress)
设置属性：ComAddress公司联系地址

boolean

ADCom.setComContact(java.lang.String _sComContact)
设置属性：ComContact联系人

boolean

ADCom.setComConTit(java.lang.String _sComConTit)
设置属性：ComConTit

boolean

ADCom.setComCrtime(CMyDateTime _dtComCrtime)
设置属性：ComCrtime记录创建时间

boolean

ADCom.setComCruser(java.lang.String _sComCruser)
设置属性：ComCruser记录创建人

boolean

ADCom.setComDesc(java.lang.String _sComDesc)
设置属性：ComDesc公司介绍信息

boolean

ADCom.setComEmail(java.lang.String _sComEmail)
设置属性：ComEmail公司Email

boolean

ADCom.setComMobile(java.lang.String _sComMobile)
设置属性：ComMobile 公司联系人移动电话

boolean

ADCom.setComName(java.lang.String _sComName)
设置属性：ComName公司名称

boolean

ADCom.setComPeople(int _nComPeople)
设置属性：ComPeople

boolean

ADCom.setComPubN(int _sComPubN)
设置属性：ComPubN 该公司发布广告的数量

boolean

ADCom.setComTel(java.lang.String _sComTel)
设置属性：ComTel公司联系电话

boolean

ADCom.setComUrl(java.lang.String _sComUrl)
设置属性：ComUrl公司网址

boolean

ADCom.setComZipcode(java.lang.String _sComZipcode)
设置属性：ComZipcode公司邮编

boolean

ADCom.setComZo(java.lang.String _sComZo)
设置属性：ComZo

boolean

ADCom.setComZone(java.lang.String _sComZone)
设置属性：ComZone公司区域

boolean

ADType.setOutString(java.lang.String _sOutString)
设置属性：OutString

boolean

ADPos.setPAttribute(java.lang.String _sPAttribute)
设置属性：PAttribute

boolean

ADPos.setPChnlId(int _nPChnlId)
设置属性：PChnlId

boolean

ADPos.setPChnlName(java.lang.String _sPChnlName)
设置属性：PChnlName

boolean

ADPos.setPClass(int _sPClass)
设置属性：PClass

boolean

ADPos.setPDesc(java.lang.String _sPDesc)
设置属性：PDesc

boolean

ADPos.setPHeight(int _nPHeight)
设置属性：PHeight

boolean

ADPos.setPNo(int _nPNo)
设置属性：PNo

boolean

ADPos.setPNum(int _sPNum)
设置属性：PNum

boolean

ADPos.setPPrice(int _iPPrice)
设置属性：PPrice

boolean

ADPos.setPStyle(java.lang.String _sPStyle)
设置属性：PStyle

boolean

ADPos.setPType(int _nPType)
设置属性：PType

boolean

ADPos.setPWidth(int _nPWidth)
设置属性：PWidth

boolean

ADType.setTypeCrTime(CMyDateTime _dtCrTime)
设置属性：CrTime

boolean

ADType.setTypeCrUser(java.lang.String _sCrUser)
设置属性：CrUser

boolean

ADType.setTypeDesc(java.lang.String _sTypeDesc)
设置属性：TypeDesc

com.trs.components.common.trsvote 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.common.trsvote 中的方法

VoteIPLogs

Vote.getIPLogs(User _currUser)
取得调查IP记录

Vote

VoteItem.getVote(User _currUser)
取得所属调查

VoteDatas

VoteOption.getVoteDatas(User _currUser)
取得调查选项的投票结果

VoteItem

VoteOption.getVoteItem(User _currUser)
取得调查选项所属的调查事项

VoteItems

Vote.getVoteItems(User _currUser)
取得调查事项

VoteOption

VoteData.getVoteOption(User _currUser)
取得调查数据所属的调查选项

VoteOptions

VoteItem.getVoteOptions(User _currUser)
取得调查选项

boolean

VoteOption.isValid()
检验对象数据有效性

boolean

VoteItem.isValid()
检验对象数据有效性

boolean

VoteIPLog.isValid()
检验对象数据有效性

boolean

VoteData.isValid()
检验对象数据有效性

boolean

Vote.isValid()
检验对象数据有效性

boolean

Vote.setCrTime(CMyDateTime _sCrTime)
设置属性：CrTime

boolean

Vote.setCrUserId(int _nCrUserId)
设置属性：CrUserId

boolean

Vote.setGroupId(int _nGroupId)
设置属性：GroupId

boolean

Vote.setInnerIPBegin(java.lang.String _sInnerIPBegin)
设置属性：InnerIPBegin

boolean

Vote.setInnerIPEnd(java.lang.String _sInnerIPEnd)
设置属性：InnerIPEnd

boolean

Vote.setInnerMulti(boolean _bInnerMulti)
设置属性：InnerMulti

boolean

Vote.setInnerMultiCount(int _nInnerMultiCount)
设置属性：InnerMultiCount

boolean

VoteIPLog.setIP(java.lang.String _sIP)
设置属性：IP

boolean

VoteOption.setItemId(int _nItemId)
设置属性：ItemId

boolean

VoteIPLog.setLogTime(CMyDateTime _dtLogTime)
设置属性：LogTime

boolean

VoteData.setOptionId(int _nOptionId)
设置属性：OptionId

boolean

Vote.setOuterMulti(boolean _bOuterMulti)
设置属性：OuterMulti

boolean

Vote.setOuterMultiCount(int _nOuterMultiCount)
设置属性：OuterMultiCount

boolean

Vote.setOuterPublic(boolean _bOuterPublic)
设置属性：OuterPublic

boolean

Vote.setSiteId(int _nSiteId)
设置属性：SITEID

boolean

Vote.setStartup(boolean _bStartup)
设置属性：Startup

boolean

VoteOption.setStyle(int _nStyle)
设置属性：Style

boolean

VoteItem.setStyle(int _nStyle)
设置属性：Style

boolean

Vote.setTimeBegin(CMyDateTime _sTimeBegin)
设置属性：TimeBegin

boolean

Vote.setTimeEnd(CMyDateTime _sTimeEnd)
设置属性：TimeEnd

boolean

VoteOption.setTitle(java.lang.String _sTitle)
设置属性：Title

boolean

VoteItem.setTitle(java.lang.String _sTitle)
设置属性：Title

boolean

Vote.setTitle(java.lang.String _sTitle)
设置属性：Title

boolean

VoteItem.setVoteId(int _nVoteId)
设置属性：VoteId

boolean

VoteIPLog.setVoteId(int _nVoteId)
设置属性：VoteId

boolean

Vote.setWCMDocId(int _nWCMDocId)
设置属性：WCMDocId

com.trs.components.filter 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.filter 中的方法

IQueryFilter

QueryFilterFactory.createQueryFilter(int nFilterType)

IQueryFilter

IQueryFilterFactory.createQueryFilter(int nFilterType)
通过类型构造查询过滤器

com.trs.components.gkml.sqgk.persistent 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.gkml.sqgk.persistent 中的方法

static MailConfig

MailConfig.createNewInstance()
产生当前对象[MailConfig]的实例

static ApplyFormDealLog

ApplyFormDealLog.createNewInstance()
产生当前对象[ApplyFormDealLog]的实例

static ApplyForm

ApplyForm.createNewInstance()
产生当前对象[ApplyForm]的实例

static MailConfig

MailConfig.findById(int _nId)
提取指定ID的对象

static ApplyFormDealLog

ApplyFormDealLog.findById(int _nId)
提取指定ID的对象

static ApplyForm

ApplyForm.findById(int _nId)
提取指定ID的对象

static MailConfig

MailConfig.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ApplyFormDealLog

ApplyFormDealLog.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ApplyForm

ApplyForm.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

Status

ApplyForm.getStatus()
获取文档状态

java.lang.String

ApplyForm.getStatusName()

void

MailConfig.insert(User _currUser)
将对象数据写入数据库

void

ApplyFormDealLog.insert(User _currUser)
将对象数据写入数据库

void

ApplyForm.insert(User _currUser)
将对象数据写入数据库

boolean

MailConfig.isValid()
检验对象数据有效性

boolean

ApplyFormDealLog.isValid()
检验对象数据有效性

boolean

ApplyForm.isValid()
检验对象数据有效性

static MailConfigs

MailConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[MailConfigs]

static ApplyForms

ApplyForms.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ApplyForms]

static ApplyFormDealLogs

ApplyFormDealLogs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ApplyFormDealLogs]

boolean

ApplyForm.setAddress(java.lang.String _sAddress)
设置属性：Address

boolean

ApplyFormDealLog.setApplyDesc(java.lang.String _sApplyDesc)
设置属性：APPLYDESC

boolean

ApplyForm.setApplyDesc(java.lang.String _sApplyDesc)
设置属性：ApplyDesc

boolean

ApplyFormDealLog.setApplyerName(java.lang.String _sApplyerName)
设置属性：ApplyerName

boolean

ApplyForm.setApplyerName(java.lang.String _sApplyerName)
设置属性：ApplyerName

boolean

ApplyForm.setApplyerType(int _nApplyerType)
设置属性：ApplyerType

boolean

ApplyForm.setApplyType(int _nApplyType)
设置属性：_nApplyType

boolean

ApplyForm.setAssociationPerson(java.lang.String _sAssociationPerson)
设置属性：AssociationPerson

boolean

ApplyForm.setCertificateCode(java.lang.String _sCertificateCode)
设置属性：CertificateCode

boolean

ApplyForm.setCertificateName(int _nCertificateName)
设置属性：CertificateName

boolean

ApplyFormDealLog.setDealContent(java.lang.String _sDealContent)
设置属性：DealContent

boolean

ApplyForm.setDealTime(CMyDateTime _dtDealTime)
设置属性：DEALTIME

boolean

ApplyForm.setDealType(int _nDealType)
设置属性：DealType

boolean

ApplyForm.setDepartment(java.lang.String _sDepartment)
设置属性：Department

boolean

ApplyForm.setEmail(java.lang.String _sEmail)
设置属性：Email

boolean

ApplyForm.setFax(java.lang.String _sFax)
设置属性：Fax

boolean

ApplyForm.setFlowStatus(int _nStatusId)
设置属性：_nStatusId

boolean

ApplyForm.setIndexCode(java.lang.String _sIndexCode)
设置属性：IndexCode

boolean

ApplyForm.setInfoGetType(long _lInfoGetType)
设置属性：InfoGetType

boolean

ApplyForm.setInfoProviderType(long _lInfoProviderType)
设置属性：InfoProviderType

boolean

ApplyForm.setLegalPerson(java.lang.String _sLegalPerson)
设置属性：LegalPerson

boolean

ApplyForm.setMailBody(java.lang.String _sMailBody)
设置属性：MailBody

boolean

ApplyForm.setMailTitle(java.lang.String _sMailTitle)
设置属性：MailTitle

boolean

ApplyForm.setOrganizeCode(java.lang.String _sOrganizeCode)
设置属性：OrganizeCode

boolean

MailConfig.setParamName(java.lang.String _sParamName)
设置属性：ParamName

boolean

MailConfig.setParamValue(java.lang.String _sParamValue)
设置属性：ParamValue

boolean

ApplyForm.setPostCode(java.lang.String _sPostCode)
设置属性：PostCode

boolean

ApplyForm.setPurpose(java.lang.String _sPurpose)
设置属性：Purpose

boolean

ApplyForm.setQueryCode(java.lang.String _sQueryCode)
设置属性：QueryCode

boolean

ApplyForm.setTelephone(java.lang.String _sTelephone)
设置属性：Telephone

com.trs.components.gkml.sqgk.process.element 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.gkml.sqgk.process.element 中的方法

void

FlowContentApplyFormImpl.cancelUpdate(User user)

boolean

FlowContentApplyFormImpl.canEdit(User _currUser)

java.lang.String

FlowContentApplyFormImpl.getContentAddEditPage()

java.lang.String

FlowContentApplyFormImpl.getContentShowPage()

User

FlowContentApplyFormImpl.getCrUser()

java.lang.String

FlowContentApplyFormImpl.getDeletePage()

java.lang.String

FlowContentApplyFormImpl.getDesc()

Flow

FlowContentApplyFormImpl.getOwnerFlow()

java.lang.String

FlowContentApplyFormImpl.getPublishPage()

java.lang.String

FlowContentApplyFormImpl.getStatusDesc()

int

FlowContentApplyFormImpl.getStatusId()

CMSObj

FlowContentApplyFormImpl.getSubinstance()

boolean

FlowContentApplyFormImpl.loadById(int _nId)

void

FlowContentApplyFormImpl.makeFrom(CMSObj _cmsObj)

void

FlowContentApplyFormImpl.setSubinstance(CMSObj _subinstance)

void

FlowContentApplyFormImpl.updateStatus(User user, int statusId)

com.trs.components.gkml.sqgk.process.engine.creators 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.gkml.sqgk.process.engine.creators 中的方法

Users

LawGovTousersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

Users

ApplyFormToUsersCreator.createToUsers(FlowContext _oFlowContext, ToUsersCreatorConfig _oCreatorConfig)

com.trs.components.gkml.sqgk.process.engine.handlers 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.gkml.sqgk.process.engine.handlers 中的方法

java.lang.String

ReplyNotifyHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context)
替换内容中的变量

java.lang.String

ReplyAppendixNotifyHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context)
替换内容中的变量

java.lang.String

ApplyFormTypeHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context)
替换内容中的变量

java.lang.String

ApplyFormReplyHandler.doPageVariablesParse(java.lang.String _sContent, ExecuteContext _context)
替换内容中的变量

boolean

ReplyNotifyHandler.execute(ExecuteContext _context, FlowAction _action)

boolean

ReplyAppendixNotifyHandler.execute(ExecuteContext _context, FlowAction _action)

boolean

AutoFillApplyFormHandler.execute(ExecuteContext _context, FlowAction _action)

boolean

ApplyFormTypeHandler.execute(ExecuteContext _context, FlowAction _action)

boolean

ApplyFormReplyHandler.execute(ExecuteContext _context, FlowAction _action)

static java.lang.String

ReplyNotifyHandler.getNotifyRootPath()

com.trs.components.govinfo 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.govinfo 中的方法

static MetaView

GovInfoViewFinder.findMetaViewOfChildGovInfo(User _loginUser)

static MetaView

GovInfoViewFinder.findMetaViewOfGovInfo(User _loginUser)

void

GovInfoLCListenerMetaView.notifyOnAddObj(BaseObj objAdded)

void

GovInfoLCListenerMetaView.notifyOnDelObj(BaseObj objDeleted, int eventType)

void

GovInfoLCListenerMetaView.notifyOnModifyObj(BaseObj objModified, int eventType)

com.trs.components.infoview 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview 中的方法

static void

InfoViewHelper.buildComplexFields(java.util.List _datas, int _nInfoviewDataId)
新建复合表单字段所对应的数据纪录

static void

InfoViewHelper.buildComplexFields(java.util.List _datas, int _nInfoviewDataId, boolean _bIsRestore)
建立复合表单字段所对应的数据纪录

static java.lang.String

InfoViewDataHelper.buildContent(InfoView _oInfoView, Document wcmDocument, org.dom4j.Document _oDom4jDocument)

static org.dom4j.Document

InfoViewHelper.buildDOM4JDocument(java.lang.String sFilePath)
构造指定XML文件的DOM4J的Document对象

boolean

RightHostInfoViewField.canDoSetRight(User _user)

boolean

RightHostInfoViewGroup.canDoSetRight(User _user)

boolean

RightHostInfoViewView.canDoSetRight(User _user)

int

InfoViewEmployMgr.clearByEmployer(CMSObj _oChnlOrSite)

int

InfoViewEmployMgr.clearByEmployer(int _nEmployerType, int _nEmployerId)

int

InfoViewEmployMgr.clearByInfoView(InfoView _oInfoView)

int

InfoViewEmployMgr.clearByInfoView(int nInfoViewId)

static void

InfoViewHelper.clearComplexFieldDatas(int _nInfoviewDataId)
清除指定表单纪录所属的所有复合表单字段记录

void

InfoViewMgr.delete(InfoView _oInfoView)

void

InfoViewMgr.delete(InfoViewField _oField)

void

InfoViewMgr.delete(InfoViewGroup _oGroup)

void

InfoViewMgr.delete(InfoViewView _oView)

java.lang.String

InfoViewMgr.filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int _nFlowDocId)
在工作流转中过滤文档中的不可读字段

java.lang.String

InfoViewMgr.forFillOut(InfoView _oInfoView, InfoViewView _oView)
为了在WCM内部填写表单而生成HTML页面

java.lang.String

InfoViewMgr.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int _nFlowDocId)
工作流转中xsl转化成html的过程

java.lang.String

InfoViewMgr.forFillOutInner(InfoView _oInfoView, InfoViewView _oView)
为了在WCM内部填写表单而生成HTML页面

java.lang.String

InfoViewMgr.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)
为了在WCM内部填写表单而生成HTML页面

java.lang.String

InfoViewMgr.forInfoGate(InfoView _oInfoView, FormProperty _oProperty)

java.lang.String

InfoViewMgr.forMultiView(InfoView _oInfoView, InfoViewView _oPubView, java.util.List fileList)

java.lang.String

InfoViewMgr.forPreview(InfoView _oInfoView, FormProperty _oProperty, java.util.List fileList)

java.lang.String

InfoViewMgr.forPreviewMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)

java.lang.String

InfoViewMgr.forPublish(InfoView _oInfoView, FormProperty _oProperty, java.util.List fileList)

java.lang.String

InfoViewMgr.forPublishMultiView(InfoView _oInfoView, InfoViewView _oPubView, FormProperty _oProperty, java.util.List fileList)

java.lang.String

InfoViewMgr.getAbsolutePath(InfoView _oInfoView, java.lang.String sFileName)

IRightHost[]

RightHostInfoViewField.getChildren()

IRightHost[]

RightHostInfoViewGroup.getChildren()

IRightHost[]

RightHostInfoViewView.getChildren()

java.lang.String

InfoViewMgr.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document _dom4jDocument)

java.lang.String

InfoViewMgr.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document _dom4jDocument, java.lang.String _sPostUserName)

java.lang.String

InfoViewMgr.getDocumentTitleForUserName(InfoView _oInfoView, org.dom4j.Document _dom4jDocument, java.lang.String _sPostUserName)

java.util.List

InfoViewEmployMgr.getEmployedInfoViews(CMSObj _employer)

java.util.List

InfoViewEmployMgr.getEmployedInfoViews(int _iEmployerType, int _iEmployerId)
TODO Add javadoc for field getEmployedInfoViews

java.util.List

InfoViewEmployMgr.getEmployedInfoViews(int _iEmployerType, int _iEmployerId, WCMFilter _filter)
TODO Add javadoc for field getEmployedInfoViews

EnumsConfig

InfoViewConfig.getEnumsConfig()

static java.lang.String

InfoViewDataHelper.getFieldValue(Document wcmDocument, java.lang.String field)

static InfoView

InfoViewHelper.getInfoView(Channel _oChannel)

java.util.List

InfoViewEmployMgr.getInfoViewEmployers(InfoView _employed)

java.util.List

InfoViewEmployMgr.getInfoViewEmployers(int _iInfoViewID)

java.util.List

InfoViewEmployMgr.getInfoViewEmployers(int _iInfoViewID, WCMFilter _filter)

InfoViews

InfoViewMgr.getInfoViews(WCMFilter _filter)

java.lang.String

InfoViewMgr.getInfoViewSerial(InfoView _oInfoView)

java.lang.String

InfoViewMgr.getInfoViewSerial(int _iInfoViewId)

IRightHost

RightHostInfoViewField.getParent()

IRightHost

RightHostInfoViewGroup.getParent()

IRightHost

RightHostInfoViewView.getParent()

static java.lang.String

InfoViewDataHelper.getProperty(Document wcmDocument, java.lang.String field)
返回指定表单文档的指定数据项的值 数据项的名称，可以只包括名称部分，也可以是完整的XPATH表述

java.lang.String

InfoViewMgr.getTemplateFileContent(InfoView _oInfoView)

java.lang.String

InfoViewMgr.initTemplateInFlow(InfoView _oInfoView, int _nFlowDocId)
在工作流转中初始化表单的模板数据

boolean

RightHostInfoViewField.loadById(int _nId)

boolean

RightHostInfoViewGroup.loadById(int _nId)

boolean

RightHostInfoViewView.loadById(int _nId)

void

RightHostInfoViewField.makeFrom(CMSObj _cmsObj)

void

RightHostInfoViewGroup.makeFrom(CMSObj _cmsObj)

void

RightHostInfoViewView.makeFrom(CMSObj _cmsObj)

static org.dom4j.Document

InfoViewHelper.parseToDocument(java.lang.String sXmlContent)

void

InfoViewMgr.rebuildXSLT(InfoView _oInfoView)

void

InfoViewMgr.rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)

void

InfoViewMgr.rebuildXSLTByGroups(InfoView _oInfoView, java.util.List _lstGroups)

static void

InfoViewHelper.restoreComplexFields(java.util.List _datas, int _nInfoviewDataId)
重建立复合表单字段所对应的数据纪录

void

InfoViewMgr.save(InfoView _oInfoView)

void

InfoViewMgr.save(InfoViewField _oField)

void

InfoViewMgr.save(InfoViewGroup _oGroup)

void

InfoViewMgr.save(InfoViewView _oView)

void

InfoViewMgr.saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)

void

InfoViewReplyNoticeSender.sendNotice()

void

InfoViewEmployMgr.setEmployedInfoView(CMSObj _employer, int _iInfoViewID)
TODO Add javadoc for field setEmployedInfoView

void

InfoViewEmployMgr.setEmployedInfoViews(CMSObj _employer, int[] _iInfoViewIDs)
注意： 在该函数执行后，参数数组_iInfoViewIDs的数据可能被破坏，因此如果需要，请调用该函数前备份

void

InfoViewConfig.setEnumsConfigFile(java.lang.String _enumsConfig)

void

InfoViewMgr.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadOnly)

static java.lang.String[]

InfoViewHelper.splitSelectFields(java.lang.String sOutlineDBFields, java.lang.String sTrueTableName)

void

RightHostInfoViewField.validateCanDoSetRight(User _user)

void

RightHostInfoViewGroup.validateCanDoSetRight(User _user)

void

RightHostInfoViewView.validateCanDoSetRight(User _user)

static void

InfoViewHelper.writeDOM4JDocument(org.dom4j.Document document, java.lang.String sFilePath)

抛出 WCMException 的 com.trs.components.infoview 中的构造方法

InfoViewReplyNoticeSender(InfoView _oInfoView, Document _oDocument, DocReply _oInfoViewReply)

com.trs.components.infoview.config 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview.config 中的方法

static java.lang.String

InfoViewEnumHelper.parseChains2Script(java.lang.String sContent)
转换级联菜单的xml内容为script内容

com.trs.components.infoview.db 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview.db 中的方法

void

InfoViewDBMgr.appendDefaultFields(User _currUser, int _nInfoViewId)

void

InfoViewDBStoreServer.changeChnnlOfInfoviewDatasaveInfoViewData(int _nInfoViewId, Document _oDocument, ChnlDoc _oChnDoc)

void

InfoViewDBMgr.createDBField(User user, InfoView _view, InfoViewField _viewField)

void

IInfoViewDBMgr.createDBField(User _currUser, InfoView _infoView, InfoViewField _infoViewField)
给当前表单的指定字段在数据库中创建对应物理字段

void

InfoViewDBMgr.createDBTable(User _currUser, int _nInfoViewId)

void

IInfoViewDBMgr.createDBTable(User _currUser, int _nInfoViewId)
新增或者修改系统表

java.lang.String

InfoViewDBMgr.createTableSQL(int _nInfoViewId)

void

InfoViewDBMgr.deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField)

void

IInfoViewDBMgr.deleteDBField(User _currUser, InfoView _view, InfoViewField _viewField)
删除指定字段

void

InfoViewDBMgr.deleteDBTable(User _currUser, int _nInfoViewId)

void

IInfoViewDBMgr.deleteDBTable(User _currUser, int _nInfoViewId)
删除指定表

void

InfoViewDBStoreServer.deleteInfoViewData(int _nInfoViewId, Document _oDocument)

java.util.List

InfoviewXMLDataUpdator.getFieldValue(java.lang.String _sNodeName)
获取某个节点的值

void

DocumentLCListenerForInfoViewDB.notifyOnAddObj(BaseObj _oObjAdded)

void

DocumentLCListenerForInfoViewDB.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

DocumentLCListenerForInfoViewDB.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

ChnlDocLCListenerForInfoViewDB.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

XMLContentRender.render(InfoViewData _oDocData, org.dom4j.Document xmlDocument, java.lang.String[] saNameSpaceURI)

void

XMLContentRender.render(InfoViewData _oDocData, java.lang.String sXMLContent, java.lang.String[] saNameSpaceURI)

void

InfoViewDBStoreServer.saveInfoViewData(int _nInfoViewId, Document _oDocument)

void

InfoviewXMLDataUpdator.setRepeatField(java.lang.String _sName, java.lang.String _sValue, int _nOrder)

java.lang.String

InfoviewXMLDataUpdator.update(java.lang.String[] saNameSpaceURI)

抛出 WCMException 的 com.trs.components.infoview.db 中的构造方法

InfoviewXMLDataUpdator(java.lang.String _sXMLContent)

com.trs.components.infoview.extract 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview.extract 中的方法

void

XSLTViewConstrainter.init(InfoView _oInfoView, InfoViewView _oInfoViewView)

void

XSLTViewConstrainter.init(InfoView _oInfoView, InfoViewView _oInfoViewView, java.util.List _lsGroups, java.util.List _lsFields)

boolean

XSLTViewConstrainter.rebuild(org.dom4j.Document _oXslDocument)

com.trs.components.infoview.helper 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview.helper 中的方法

void

BaseInfoViewFieldValueCreator.createInfoviewXMLDataUpdator()

static ComplexFieldData

ComplexFieldData.createNewInstance()
产生当前对象[ComplexFieldData]的实例

static ComplexFieldData

ComplexFieldData.findById(int _nId)
提取指定ID的对象

static ComplexFieldData

ComplexFieldData.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static java.lang.String

InfoViewTemplateHelper.generateContent(MethodContext _oContext, User _currUser)

static java.lang.String

InfoViewTemplateHelper.getContent(int nChannelId, java.lang.String sTemplateContent, java.lang.String sKey)

static Template

InfoViewTemplateHelper.getDetailTemplate(PublishPageContext _pageContext)

static int

InfoViewQueryHelper.getDocumentStatus(java.lang.String sLuceneId)

static java.lang.String[]

InfoViewNewQueryHelper.getFieldNames(InfoView infoview, java.lang.String sSelectedFields)

static java.lang.String

InfoViewNewQueryHelper.getFieldValue(InfoViewDocument _infoviewDoc, java.lang.String _sFieldName)

java.util.List

BaseInfoViewFieldValueCreator.getInfoViewFieldValue(java.lang.String sFieldName)
获取指定字段的值，因为可能是重复表字段，返回一个List

int

BaseInfoViewFieldValueCreator.getRepeatFieldIndex(java.lang.String _sFieldName, java.lang.String _sFieldValue)
获取指定字段和值的序号位置

static java.lang.String

InfoViewQueryHelper.getStatusName(int status)

void

ComplexFieldData.insert(User _currUser)
将对象数据写入数据库

boolean

ComplexFieldData.isValid()
检验对象数据有效性

WCMFilter

InfoViewChnlDocFilterHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)

WCMFilter

InfoViewChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)

WCMFilter

InfoViewChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)

static ComplexFieldDatas

ComplexFieldDatas.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ComplexFieldDatas]

boolean

ComplexFieldData.setFieldId(java.lang.String _sFieldId)
设置属性：FieldId

boolean

ComplexFieldData.setFieldName(java.lang.String _sFieldName)
设置属性：FieldName

boolean

ComplexFieldData.setFieldOrder(int fieldOrder)

boolean

ComplexFieldData.setFieldValue(java.lang.String _sFieldValue)
设置属性：FieldValue

boolean

ComplexFieldData.setInfoviewDataId(int _nInfoviewDataId)
设置属性：InfoviewDataId

void

BaseInfoViewFieldValueCreator.setInfoViewFieldValue(java.lang.String _sFieldName, java.lang.String _sValue)
给一个普通的字段设置值

abstract  void

BaseInfoViewFieldValueCreator.setInfoViewFieldValueBeforeSaveDoc()
给当前表单数据对象的相关属性设置上自动产生的值

boolean

ComplexFieldData.setInfoviewId(int _nInfoviewId)
设置属性：InfoviewId

void

BaseInfoViewFieldValueCreator.setInfoViewRepeatFieldValue(java.lang.String _sFieldName, java.lang.String _sValue, int index)
给指定位置的重复表字段设置值

boolean

ComplexFieldData.setParentFlag(java.lang.String _sParentFlag)
设置属性：ParentFlag

boolean

ComplexFieldData.setPostTime(CMyDateTime _postTime)

void

BaseInfoViewFieldValueCreator.updateDocument()
更新document内容

com.trs.components.infoview.mad 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview.mad 中的方法

java.lang.String

InfoViewDataHelper.buildContent(InfoView infoView, Document _document, org.dom4j.Document dom4jDocument)

java.lang.String

InfoViewDataHelperImpl.buildContent(InfoView infoView, Document _document, org.dom4j.Document dom4jDocument)

java.lang.String

InfoViewDataHelper.getFieldValue(Document doc, java.lang.String fieldName)

java.lang.String

InfoViewDataHelperImpl.getFieldValue(Document doc, java.lang.String fieldName)

java.lang.String

InfoViewDataHelper.getProperty(Document doc, java.lang.String groupName)

java.lang.String

InfoViewDataHelperImpl.getProperty(Document doc, java.lang.String groupName)

com.trs.components.infoview.persistent 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview.persistent 中的方法

java.util.List

InfoView.allFields()

java.util.List

InfoView.allGroups()

static InfoViewData

InfoViewData.createNewInstance()
产生当前对象[MetaViewData]的实例

static InfoView

InfoView.createNewInstance()
产生对象InfoView的实例

static InfoViewField

InfoViewField.createNewInstance()
产生对象InfoView的实例

static InfoViewData

InfoViewData.createNewInstance(int _nInfoViewId, int _nDocumentId)

static InfoViewDocuments

InfoViewDocuments.createNewInstance(User _currUser)
产生一个当前集合对象[ChnlDocs]的实例

static InfoViewViews

InfoViewViews.findBy(InfoView _iv)

static InfoViewFields

InfoViewFields.findBy(InfoView _iv)

static InfoViewGroups

InfoViewGroups.findBy(InfoView _iv)

static InfoViewDatas

InfoViewDatas.findByDocIds(User _currUser, int _nInfoViewId, java.lang.String _sDocumentIds)

static InfoViewData

InfoViewData.findByDocument(Document document)

static InfoViewDocument

InfoViewDocument.findByDocument(Document _oDocument, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument, java.lang.String _sSelectFieldsOfInfoView)

static InfoViewDocument

InfoViewDocument.findById(BaseChannel _host, int _nChnlDocRecId, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument, int _nInfoViewId, java.lang.String _sSelectFieldsOfInfoView)
获取指定Id的ViewDocument

static InfoViewData

InfoViewData.findById(InfoView _oInfoView, int _nId)
提取指定ID的对象

static InfoViewData

InfoViewData.findById(int _nDocumentId)

static InfoView

InfoView.findById(int id)
提取指定ID的对象

static InfoViewView

InfoViewView.findById(int id)
返回指定ID的表单视图对象

static InfoViewGroup

InfoViewGroup.findById(int id)
提取指定ID的对象

static InfoViewField

InfoViewField.findById(int id)
提取指定ID的对象

static InfoViewData

InfoViewData.findById2(int _nInfoViewId, int _nDocumentId)

static InfoViewDatas

InfoViewDatas.findByIds(User _currUser, int _nInfoViewId, java.lang.String _sInfoViewDataIds)

static InfoViewEmploys

InfoViewEmploys.findByIds(User _currUser, java.lang.String _sIds)

static InfoViews

InfoViews.findByIds(User _currUser, java.lang.String _sIds)
TODO Add javadoc for field findByIds

static InfoViewFields

InfoViewFields.findByIds(User _currUser, java.lang.String _sIds)

static InfoViewData

InfoViewData.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static InfoViewFields

InfoViewFields.findByName(java.lang.String _sName, int _nInfoViewId)

static InfoViewGroups

InfoViewGroups.findByName(java.lang.String _sGroupName, int _nInfoViewId)

static InfoViewViews

InfoViewViews.findDefaultBy(InfoView _iv)

static InfoViewDocument

InfoViewDocument.findSelfByDocument(Document _oDocument)

Channel

InfoViewData.getChannel()

ChnlDoc

InfoViewDocument.getChnlDoc()

Document

InfoViewData.getDocument()

Document

InfoViewDocument.getDocument()

CMSObj

InfoViewEmploy.getEmployer()

InfoView

InfoViewEmploy.getInfoView()

InfoView

InfoViewGroup.getInfoView()

InfoViewChnlDocFilterHelper

InfoViewDocuments.getInfoViewChnlDocFilterHelper()

InfoViewData

InfoViewDocument.getInfoViewData()

int

InfoViewEmploy.getInfoViewId()

java.lang.Integer

InfoViewSerial.getNextSerial()
获取下一个可用序号

java.lang.Object[]

InfoViewSerialGenerator.getNextSerial(int nInfoViewId, int nSerialPeriod, int nBaseSerial)
获取指定表单的下一个编号

static InfoViewFields

InfoViewFields.getOutlineFields(InfoView _iv)

static InfoViewFields

InfoViewFields.getSearchFields(InfoView _iv)

java.lang.String

InfoView.getTemplateFileContent()

java.lang.String

InfoViewField.getTrueFieldName()

InfoViewView

InfoViewGroup.getView()

boolean

InfoView.isValid()

boolean

InfoViewView.isValid()

boolean

InfoViewEmploy.isValid()

boolean

InfoViewGroup.isValid()

boolean

InfoViewField.isValid()

static InfoViewDatas

InfoViewDatas.openWCMObjs(int nInfoViewId, WCMFilter _filter)

boolean

InfoView.setAllFileList(java.lang.String _sAllFileList)

boolean

InfoViewField.setBackReadOnly(boolean _bBackReadOnly)

void

InfoViewData.setChannelId(int _nChannelId)

boolean

InfoViewField.setClassId(int _nClassId)

boolean

InfoViewField.setDataControl(java.lang.String _sDataControl)

boolean

InfoViewField.setDataPattern(java.lang.String _sDataPattern)

boolean

InfoViewField.setDataType(int _nDataType)

boolean

InfoViewField.setDefaultValue(java.lang.String _sDefaultValue)

boolean

InfoViewView.setDefaultView(boolean _zDefaultView)
设置该视图是否缺省视图

boolean

InfoView.setDesc(java.lang.String _sDesc)

boolean

InfoViewView.setDesc(java.lang.String _sDesc)
设置视图的描述

boolean

InfoViewGroup.setDesc(java.lang.String _sDesc)

boolean

InfoViewField.setDesc(java.lang.String _sDesc)

boolean

InfoView.setDocContentPattern(java.lang.String _sDocContentPattern)
设置正文构造器字段

boolean

InfoView.setDocSerial(boolean zDocSerial)

void

InfoViewData.setDocumentId(int _nDocId)

boolean

InfoViewEmploy.setEmployer(CMSObj _employer)

boolean

InfoViewEmploy.setEmployer(int _nType, int _nId)

boolean

InfoViewField.setEnumValue(java.lang.String _sEnumValue)

boolean

InfoViewField.setFieldType(java.lang.String _sFieldType)

boolean

InfoViewField.setFixLength(int _iFixLength)

boolean

InfoViewField.setGateWayBinding(java.lang.String _sGateWayBinding)

boolean

InfoView.setInfoPathFile(java.lang.String _sInfoPathFile)

boolean

InfoViewEmploy.setInfoView(InfoView _oInfoView)

boolean

InfoViewGroup.setInfoView(InfoView _oInfoView)

void

InfoViewData.setInfoViewId(int _nInfoViewId)

boolean

InfoViewEmploy.setInfoViewId(int _iInfoViewID)

boolean

InfoViewView.setInfoViewID(int _iInfoViewID)
设置视图所属表单的ID

boolean

InfoViewGroup.setInfoViewID(int _iInfoViewID)

boolean

InfoViewField.setInfoViewID(int _iInfoViewID)

boolean

InfoView.setInfoViewPath(java.lang.String _sInfoViewPath)

boolean

InfoViewField.setMaxLength(int _iMaxLength)

boolean

InfoViewField.setMinLength(int _iMinLength)

boolean

InfoView.setName(java.lang.String _sName)

boolean

InfoViewView.setName(java.lang.String _sName)
设置视图的名称

boolean

InfoViewGroup.setName(java.lang.String _sName)

boolean

InfoViewField.setName(java.lang.String _sName)

boolean

InfoViewView.setNewFile(java.lang.String _sFileName)
设置重整之后的XSL文件的文件名

boolean

InfoView.setNewXSLTFilet(java.lang.String _sXSLTFile)

boolean

InfoViewField.setNillable(boolean _zNillable)

boolean

InfoView.setNoticeContentPattern(java.lang.String _sContentPattern)
设置回复主题模板

boolean

InfoView.setNoticeRelatedField(java.lang.String _sRelatedField)
获取回复通知目标的相关表单项

boolean

InfoView.setNoticeSubjectPattern(java.lang.String _sSubPattern)
设置回复主题模板

boolean

InfoViewView.setOldFile(java.lang.String _sFileName)
设置该视图原始XSL文件的文件名

boolean

InfoView.setOutlineDBFields(java.lang.String _sOutlineFields)
设置概览DB字段

boolean

InfoViewField.setOutlineField(boolean _bInOutline)

boolean

InfoView.setOutlineFields(java.lang.String _sOutlineFields)
设置概览字段

boolean

InfoViewView.setPublicFill(boolean _zPublicFill)
设置该视图是否公共可填写，即是否发布到公网

boolean

InfoViewGroup.setPublicFill(boolean _zPublicFill)

boolean

InfoViewField.setPublicFill(boolean _zPublicFill)

boolean

InfoViewView.setPublicView(boolean _zPublicView)
设置该视图的数据是否任何人都可以查看 注意：到2006.07.13，尚未实现

boolean

InfoViewGroup.setPublicView(boolean _zPublicView)

boolean

InfoViewField.setPublicView(boolean _zPublicView)

boolean

InfoViewField.setReadOnly(boolean _bReadOnly)

boolean

InfoView.setReplyNoticeRequired(boolean _zRequired)
设置是否需要回复通知

boolean

InfoView.setSchemaFile(java.lang.String _sSchemaFile)

boolean

InfoView.setSearchDBFields(java.lang.String _sSearchFields)
设置检索DB字段

boolean

InfoViewField.setSearchField(boolean _bInSearch)

boolean

InfoView.setSearchFields(java.lang.String _sSearchFields)
设置检索字段

boolean

InfoView.setSerialField(java.lang.String _sTemplateFile)

boolean

InfoView.setSerialPattern(java.lang.String _sTemplateFile)

boolean

InfoView.setSerialPeriod(int _iSerialPeriod)

boolean

InfoView.setSiteID(int _iSiteID)

boolean

InfoViewView.setSpecialRight(boolean _zSpecialRight)
设置该视图是否单独设置过权限

boolean

InfoViewGroup.setSpecialRight(boolean _zSpecialRight)

boolean

InfoViewField.setSpecialRight(boolean _zSpecialRight)

boolean

InfoView.setTemplateFile(java.lang.String _sTemplateFile)

boolean

InfoView.setTitlePattern(java.lang.String _sTitlePattern)

boolean

InfoViewField.setTrueFieldName(java.lang.String _sTrueFieldName)

boolean

InfoViewGroup.setView(InfoViewView _oView)

boolean

InfoViewGroup.setViewID(int _iViewID)

boolean

InfoViewView.setViewWidth(java.lang.String _sViewWidth)
设置视图的宽度（HTML页面中有效区域的宽度）

boolean

InfoViewField.setXPath(java.lang.String _sXPath)

boolean

InfoViewView.setXSLPrefix(java.lang.String _sXSLPrefix)

boolean

InfoView.setXSLTFilet(java.lang.String _sXSLTFile)

com.trs.components.infoview.process 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview.process 中的方法

boolean

SendEmailForInfoViewHandler.execute(ExecuteContext _context, FlowAction _action)

java.lang.String

SendEmailForInfoViewHandler.parsePageVariables(java.lang.String _sContent, java.util.Map _variables)

com.trs.components.infoview.publish.tagparser 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.infoview.publish.tagparser 中的方法

TemplateQuote[]

TagParserInfoViewNavs.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserInfoViewHelper.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserInfoViewData.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserInfoViewNav.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserInfoViewPage.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserInfoView.analyzeQuotes(IPublishFolder _root)

InfoViewView[]

TagParserInfoViews.getPublishViews(InfoView _oInfoView, boolean _bPushlishAll, java.lang.String sPubViewNames)

java.lang.String[]

TagParserInfoViewNavs.parse(PublishTagContext _context)

java.lang.String[]

TagParserInfoViewHelper.parse(PublishTagContext _context)

java.lang.String[]

TagParserInfoViewData.parse(PublishTagContext _context)

java.lang.String[]

TagParserInfoViewNav.parse(PublishTagContext _context)

java.lang.String[]

TagParserInfoViewPage.parse(PublishTagContext _context)

java.lang.String[]

TagParserInfoViews.parse(PublishTagContext _context)

java.lang.String[]

TagParserInfoView.parse(PublishTagContext _context)

com.trs.components.metadata.center 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.center 中的方法

java.lang.String

MetaViewData.abstractPicSrc(java.lang.String _htmlContent)

void

MetaViewEmployerMgr.clearEmployer(User _currUser, Channel _channel)

void

IMetaViewEmployerMgr.clearEmployer(User _currUser, Channel _channel)
清除指定栏目所配置的视图关系

void

MetaViewEmployerMgr.clearEmployer(User _currUser, MetaView _view)

void

IMetaViewEmployerMgr.clearEmployer(User _currUser, MetaView _view)
清除指定视图所配置的使用关系

BaseObj

MetaViewData.cloneToNewObj()
由于视图字段的名称和元数据字段的名称可能不统一，在查看（findById)的时候，用 的是视图字段名称，而在保存（save）的时候用的是元数据字段名称，所以在此需要将视图字段的属性转化为元数据字段的属性

void

IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, ClassInfos oDestClassInfos, User oCurrUser)
将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos

void

ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, ClassInfos destClassInfos, User currUser)

void

IClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser)
将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos

void

ClassInfoViewMgr.copyViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos destClassInfos, User currUser)

void

IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oDestClassInfos, User oCurrUser)
将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos

void

ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos destClassInfos, User currUser)

void

IClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oDestClassInfos, User oCurrUser)
将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos

void

ClassInfoViewMgr.copyViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos destClassInfos, User currUser)

static ClassInfoView

ClassInfoView.createNewInstance()
产生当前对象[ClassInfoView]的实例

static MetaViewData

MetaViewData.createNewInstance()
产生当前对象[MetaViewData]的实例

void

MetaViewData.dealWithFieldsOfEnumValue()
处理新添加的枚举值

int

MetaViewData.delete(User _currUser)

void

IClassInfoViewMgr.delete(User user, ClassInfo _oClassInfo)
删除_oClassInfo下的文档关联

void

ClassInfoViewMgr.delete(User user, ClassInfo _oClassInfo)

void

IClassInfoViewMgr.delete(User _currUser, MetaViewData oMetaViewData)
删除ClassInfoView中满足MetaDataID的记录

void

ClassInfoViewMgr.delete(User _currUser, MetaViewData oMetaViewData)
删除ClassInfoView中满足MetaDataID的记录

int

MetaViewData.deleteViewDataAndDoc(User _currUser)

static MetaViewEmployer

MetaViewEmployer.findByChannelId(int _nChannelId)

static ClassInfoView

ClassInfoView.findById(int _nId)
提取指定ID的对象

static MetaViewData

MetaViewData.findById(int _nMetaViewDataId)

static MetaViewData

MetaViewData.findById(java.lang.String _sTableName, int _nId)
提取指定ID的对象

static MetaViewDatas

MetaViewDatas.findByIds(java.lang.String sIds)
返回一个MetaViewData的集合，注意sIds对应得视图必须相同

static ClassInfoView

ClassInfoView.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static MetaViewData

MetaViewData.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static MetaViews

MetaViewHelper.findViews(User _currUser)

java.lang.String

MetaViewData.getAppendixProperty(java.lang.String _sPropertyName, int _nPathType)

Channel

MetaViewData.getChannel()
获取文档当前所处的栏目

ChnlDoc

MetaViewData.getChnlDoc()

java.lang.String

MetaViewData.getContent()

Channel

MetaViewData.getDocChannel()

static java.util.List

DocumentFieldsSynFactory.getDocumentFieldSyn(java.lang.String sKey)
根据关键字获取IDocumentFieldsSyn对象

Document

MetaViewData.getDocumnent()

Channels

MetaViewEmployerMgr.getEmployers(MetaView _view, WCMFilter _extraFilter)

Channels

IMetaViewEmployerMgr.getEmployers(MetaView _view, WCMFilter _extraFilter)
获取使用了指定视图的所有栏目

java.lang.String

MetaViewData.getRealProperty(java.lang.String _sPropertyName)

RightValue

MetaViewData.getRightValue(User _currUser)
获取当前ViewDocument的RightValue

java.lang.String

MetaViewData.getSelectFields()

Status

MetaViewData.getStatus()

java.lang.String

MetaViewData.getTitle()

MetaView

MetaViewEmployerMgr.getViewOfEmployer(Channel _channel)

MetaView

IMetaViewEmployerMgr.getViewOfEmployer(Channel _channel)
获取指定栏目配置的视图

boolean

MetaViewData.hasRight(User _loginUser, int _nRightIndex)
判断当前用户对于ViewDocument是否具有指定的权限

void

MetaViewData.insert()

void

ClassInfoView.insert(User _currUser)
将对象数据写入数据库

void

MetaViewData.insert(User _currUser)

boolean

MetaViewData.isRightDefined()
判断当前文档是否自定义了权限

boolean

MetaViewEmployer.isValid()

boolean

ClassInfoView.isValid()
检验对象数据有效性

boolean

MetaViewData.isValid()

void

MetaViewDatas.loadViewDatas(WCMFilter _filter)

static WCMFilter

MetaDataCenterHelper.makeFilterWithClassInfos(java.lang.String sClassInfoIds, boolean _bContainsChildren)

void

IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser)
将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类

void

ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)

void

IClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData oViewData, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser)
将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类

void

ClassInfoViewMgr.moveViewDataByClassInfos(MetaViewData viewData, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)

void

IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser)
获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值

void

ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser)
获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值

void

IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser)
将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类

void

ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewData oViewData, MetaViewField oViewField, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User oCurrUser)
将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类

void

IClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser)
获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值

void

ClassInfoViewMgr.moveViewDatasByClassInfo(MetaViewDatas oViewDatas, ClassInfo oSrcClassInfo, ClassInfo oDestClassInfo, User currUser)
获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值

void

IClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo _oSrcClassInfo, int _nDestClassInfoId)
将记录的分类法由_oSrcClassInfo转换为_nDestClassInfoId 如果_nDestClassInfoId为0，则只删除记录的_oSrcClassInfo

void

ClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo srcClassInfo, int destClassInfoId)

void

IClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo _oSrcClassInfo, java.lang.String _destClassInfoId)
将记录的分类法由_oSrcClassInfo转换为_destClassInfoId 如果_destClassInfoId为null，则只删除记录的_oSrcClassInfo

void

ClassInfoViewMgr.moveViewDatasByClassInfo(User user, ClassInfo oClassInfo, java.lang.String _sDestClassInfoId)

void

IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser)
将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类

void

ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)

void

IClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas oViewDatas, MetaViewField oViewField, ClassInfos oSrcClassInfos, ClassInfo oDestClassInfo, User oCurrUser)
将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类

void

ClassInfoViewMgr.moveViewDatasByClassInfos(MetaViewDatas viewDatas, MetaViewField viewField, ClassInfos srcClassInfos, ClassInfo destClassInfo, User currUser)

void

DocumentListenerForMetaViewData.notifyOnAddObj(BaseObj _oObjAdded)

void

DocumentListenerForMetaViewData.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChnlDocLCListenerForSynToMetaData.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

DocumentListenerForMetaViewData.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

MetaViewDatas.open(Channels _channels, WCMFilter _filter)

void

MetaViewDatas.open(Channel _channel, WCMFilter _filter)

void

MetaViewDatas.open(CMSBaseObjs _oSitesOrChannels, WCMFilter _extraFilter)

void

MetaViewDatas.open(WCMFilter _filter)

void

MetaViewDatas.open(WCMFilter _filter, WCMFilter _countFilter)

void

MetaViewDatas.open(WebSites _sites, WCMFilter _filter)

void

MetaViewDatas.open(WebSite _site, WCMFilter _filter)

static MetaViewDatas

MetaViewDatas.openWCMObjs(MetaView oMetaView, WCMFilter _filter)

static MetaViewDatas

MetaViewDatas.openWCMObjs(java.lang.String _sTableName, WCMFilter _filter)
通过指定一个Filter获取当前集合[MetaViewDatas]

static ClassInfoViews

ClassInfoViews.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ClassInfoViews]

static MetaViewEmployers

MetaViewEmployers.openWCMObjs(WCMFilter _filter)

ClassInfos

IClassInfoViewMgr.queryClassInfos(User _currUser, Documents oDocuments, WCMFilter _filter)
根据文档对象集合获取获取分类法信息集合

ClassInfos

ClassInfoViewMgr.queryClassInfos(User user, Documents documents, WCMFilter _filter)

ClassInfos

IClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter)
根据文档对象获取获取分类法信息集合

ClassInfos

ClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter)
根据文档对象获取获取分类法信息集合

int

IClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo)
根据分类法对象返回相应的文档数目

int

ClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo)
根据分类法对象返回相应的文档数目

int

IClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)

int

ClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)

Documents

IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos _oClassInfos, WCMFilter _filter)
根据分类法集合对象得到相应的文档集合对象

Documents

ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos oClassInfos, WCMFilter _filter)
根据分类法集合对象得到相应的文档集合对象

Documents

IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter)
根据分类法对象得到相应的文档集合对象

Documents

ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter)
根据分类法对象得到相应的文档集合对象

static MetaViewDatas

ClassDocumentsHelper.queryMetaViewDatas(MetaView _view, ClassInfos _classInfos, boolean _bOnlyLeaf, WCMFilter _extraFilter)
获取指定视图中同时属于指定的多个分类（含下面的子分类）的文档 子分类仅仅只叶子节点

MetaViewDatas

IClassInfoViewMgr.queryViewDatas(User user, ClassInfo _oClassInfo, MetaView _oMetaView)
获取指定视图指定分类法下的数据集合

MetaViewDatas

ClassInfoViewMgr.queryViewDatas(User user, ClassInfo classInfo, MetaView metaView)

MetaViews

IClassInfoViewMgr.queryViews(User _currUser, ClassInfos _oClassInfo, WCMFilter _filter)
根据分类法ID序列返回视图对象集合

MetaViews

ClassInfoViewMgr.queryViews(User _currUser, ClassInfos oClassInfos, WCMFilter _filter)
根据分类法集合对象返回相应的视图对象集合

void

MetaViewData.readChnlDocPropertyFromRs(java.sql.ResultSet _rsData, java.sql.ResultSetMetaData _rsmdData)

static void

DocumentFieldsSynFactory.registerDocumentFieldsSyn(java.lang.String sKey, java.lang.Class clazz)
注册和元数据关联处理的IDocumentFieldsSyn对象

static void

DocumentFieldsSynFactory.registerDocumentFieldsSyn(java.lang.String sKey, java.lang.String sClassName)
注册和元数据关联处理的IDocumentFieldsSyn对象

static MetaViewData

MetaDataCenterClassInfoHelper.renderClassInfoFields(MetaViewData oViewData)
对元数据记录里面的分类法字段进行格式化处理，如：把分类法字段名称改成分类法id.

static void

MetaDataCenterHelper.rendHtmlFields(MetaViewData _oViewData)

void

IDocumentFieldsSyn.resetDocumentProperties(MetaView oMetaView)
给所有视图数据对象设置关联的document对象的值

void

IMetaDataFieldValueCreator.resetFieldValueOnMetaData()
给所有相关的元数据记录重新设置新的值

void

MetaViewData.save()

void

IClassInfoViewMgr.save(User _currUser, MetaViewData oMetaViewData)
保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录

void

ClassInfoViewMgr.save(User _currUser, MetaViewData _oMetaViewData)
保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录

boolean

ClassInfoView.setClassInfoId(int _nClassInfoId)
设置属性：ClassInfoId

void

IDocumentFieldsSyn.setDocumentProperties(Document _document, MetaViewData _viewData)
根据视图数据对象设置关联的document对象的值

void

MetaViewEmployerMgr.setEmployer(User _currUser, Channel _channel, MetaView _view)

void

IMetaViewEmployerMgr.setEmployer(User _currUser, Channel _channel, MetaView _view)
给指定的栏目配置指定的视图

void

IMetaDataFieldValueCreator.setFieldValueBeforeSaveMetaData(MetaViewData _viewData)
给当前元数据对象的相关属性设置上自动产生的值

boolean

ClassInfoView.setMetaDataID(int _nMetaDataID)
设置属性：MetaDataID

boolean

ClassInfoView.setViewID(int _nViewID)
设置属性：ViewID

void

MetaViewData.synDocumentFieldValueWithRule(Document _document)
按照栏目上设置的同步规则进行字段同步。

void

MetaViewData.translateFields()
由于视图字段的名称和元数据字段的名称可能不统一，在此方法中将视图字段的属性转化为元数据字段的属性, 在导入、复制视图数据的时候，可能需要用到这种功能

void

MetaViewData.update()

void

MetaViewData.update(User _user)

com.trs.components.metadata.center.xml 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.center.xml 中的方法

static java.lang.String

MetaViewDataImporter.converToAbsoluteFileName(java.lang.String _sFileName)

java.lang.String

MetaViewDataExporter.exportToExcelZip(MetaViewDatas _viewDatas)
将指定视图下的数据连同附件导出成ZIP文件

java.lang.String

MetaViewDataExporter.exportToExcelZip(MetaViewDatas _viewDatas, java.lang.String _sSelectFields, boolean _bExportAppendix)
将指定视图下的数据连同附件导出成ZIP文件

java.lang.String

MetaViewDataExporter.exportToZip(MetaViewDatas _viewDatas)
将指定视图下的数据连同附件导出成ZIP文件

java.lang.String

MetaViewDataExporter.exportToZip(MetaViewDatas _viewDatas, java.lang.String _sSelectFields, boolean _bExportAppendix)
将指定视图下的数据连同附件导出成ZIP文件

Reports

MetaViewDataImporter.importFromFile(int _nImportType, java.lang.String _sImportFile, java.lang.String _sXslFile)

org.dom4j.Element

MetaViewDataToExcel.toXmlElement(BaseObjs _baseObjs, java.lang.String _sFieldsList)
为什么要重载这个方法？

com.trs.components.metadata.definition 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.definition 中的方法

void

IMetaDataDefMgr.appendDefaultFields(User _curruser, MetaDBTable _oTable)
给自定的表追加默认的字段

void

MetaDataDefMgr.appendDefaultFields(User _currUser, MetaDBTable _oTable)

void

MetaDataDefMgr.clearTitleField(MetaView oView)
清除视图oView下的标题字段,即原来是标题字段的，将不再作为标题字段

java.lang.String

IMetaDataDefMgr.createDDLSQL(MetaDBTable _oTableInfo)
产生指定表的定义SQL

java.lang.String

MetaDataDefMgr.createDDLSQL(MetaDBTable _oTableInfo)

java.lang.String

IMetaDataDefMgr.createDDLSQL(MetaView _oViewInfo)
产生指定视图的定义SQL

java.lang.String

MetaDataDefMgr.createDDLSQL(MetaView _oViewInfo)

static MetaView

MetaView.createNewInstance()
产生当前对象[ViewInfo]的实例

static MetaDBTable

MetaDBTable.createNewInstance()
产生当前对象[TableInfo]的实例

static MetaViewField

MetaViewField.createNewInstance()
产生当前对象[ViewFieldInfo]的实例

static ClassInfo

ClassInfo.createNewInstance()
产生当前对象[ClassInfo]的实例

static MetaDBField

MetaDBField.createNewInstance()
产生当前对象[DBFieldInfo]的实例

boolean

IMetaDataDefMgr.createViewApplication(MetaView _oView, java.lang.String _sTemplatePath, java.lang.String _sApplicationPath)
视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8

boolean

MetaDataDefMgr.createViewApplication(MetaView _oView, java.lang.String _sTemplatePath, java.lang.String _sApplicationPath)
视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8

java.lang.String

IMetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView)
视图定义完成，产生视图相关的信息（DB视图、相关的JSP）

java.lang.String

MetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView)

java.lang.String

IMetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView, boolean generateApplication)
视图定义完成，产生视图相关的信息（DB视图、相关的JSP）

java.lang.String

MetaDataDefMgr.createViewRelations(User _currUser, MetaView _oView, boolean generateApplication)

void

IMetaDataDefMgr.delete(User _currUser, MetaDBField _oDBFieldInfo)
删除指定字段

void

MetaDataDefMgr.delete(User _currUser, MetaDBField _oDBFieldInfo)

void

IMetaDataDefMgr.delete(User _currUser, MetaDBTable _oTableInfo)
删除指定表

void

MetaDataDefMgr.delete(User _currUser, MetaDBTable _oTableInfo)
删除元数据的操作步骤如下：
删除元数据物理字段；
删除元数据对应物理表里的数据；
删除元数据物理表；
删除元数据；
删除所有以此元数据作为主表的视图；
获取所有以此元数据作为附表的视图；
删除附表视图和此元数据的关系；
删除附表视图中此元数据的字段；
如果此视图由多表变成单表，则删除此物理视图，并修改视图的viewName
重新生成视图；

void

IMetaDataDefMgr.delete(User _currUser, MetaView _oViewInfo)
删除指定表

void

MetaDataDefMgr.delete(User _currUser, MetaView _oView)

void

IMetaDataDefMgr.delete(User _currUser, MetaViewField _oViewField)
删除指定视图字段

void

MetaDataDefMgr.delete(User _currUser, MetaViewField _oViewField)

void

ClassInfoMgr.deleteClassInfo(User _currUser, ClassInfo _classInfo)

void

IClassInfoMgr.deleteClassInfo(User _currUser, ClassInfo _classInfo)
删除指定的分类

static MetaView

MetaView.findById(int _nId)
提取指定ID的对象

static MetaDBTable

MetaDBTable.findById(int _nId)
提取指定ID的对象

static MetaViewField

MetaViewField.findById(int _nId)
提取指定ID的对象

static ClassInfo

ClassInfo.findById(int _nId)
提取指定ID的对象

static MetaDBField

MetaDBField.findById(int _nId)
提取指定ID的对象

static MetaView

MetaView.findByIdentity(java.lang.String sIdentityName, java.lang.String sIdentityValue)
根据唯一标识属性，获取第一个视图对象，由于视图名称和视图描述是唯一的，所以一般情况下可以作为sIdentityName

static MetaView

MetaView.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static MetaDBTable

MetaDBTable.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static MetaViewField

MetaViewField.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ClassInfo

ClassInfo.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static MetaDBField

MetaDBField.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ClassInfo

ClassInfo.findByName(java.lang.String _sClassInfoName)
根据名称获取分类

ClassInfo

ClassInfoCacheMgr.findClassInfoByName(java.lang.String _sClassInfoName)
根据分类法名称获取分类法

ClassInfo

IClassInfoCacheMgr.findClassInfoByName(java.lang.String _sClassInfoName)

static ClassInfos

ClassInfo.findRootClassInfos()
获取所有根节点

static ClassInfos

ClassInfo.findRootClassInfos(boolean _bNotMakeNewObjs)

ClassInfos

ClassInfo.getChildren()
获取当前对象的一级子分类

ClassInfos

ClassInfo.getChildren(boolean _bNotMakeNewObjs)

ClassInfos

ClassInfoCacheMgr.getChildren(int _nParentId)
获取指定分类的所有一级子分类

ClassInfos

IClassInfoCacheMgr.getChildren(int _nParentId)

ClassInfos

ClassInfoCacheMgr.getChildren(int _nParentId, boolean _bNotMakeNewObjs)

ClassInfos

IClassInfoCacheMgr.getChildren(int _nParentId, boolean _bNotMakeNewObjs)

ClassInfo

ClassInfoMgr.getClassInfo(java.lang.String path)

ClassInfo

IClassInfoMgr.getClassInfo(java.lang.String _sPath)
根据分类法路径查找到指定的分类法

ClassInfo

ClassInfoMgr.getClassInfo(java.lang.String path, java.lang.String delim)

ClassInfo

IClassInfoMgr.getClassInfo(java.lang.String _sPath, java.lang.String _sDelim)
根据分类法路径查找到指定的分类法

ClassInfos

ClassInfoMgr.getClassInfosByName(int nClassInfoRootId, java.lang.String sClassInfoName)
通过名称获取分类法对象集合

ClassInfos

IClassInfoMgr.getClassInfosByName(int nClassInfoRootId, java.lang.String sClassInfoName)
通过名称获取分类法对象集合

ClassInfos

ClassInfoMgr.getClassInfosByName(java.lang.String sClassInfoName)
通过名称获取分类法对象集合

ClassInfos

IClassInfoMgr.getClassInfosByName(java.lang.String sClassInfoName)
通过名称获取分类法对象集合

ClassInfos

IMetaDataDefMgr.getClassInfosUsingMetaView(User _currUser, MetaView oMetaView)
查询视图oMetaView使用了的所有分类法集合

ClassInfos

MetaDataDefMgr.getClassInfosUsingMetaView(User _currUser, MetaView oMetaView)

MetaDBField

MetaViewField.getDBField()

MetaDBFields

IMetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter)
获取指定表的指定字段列表

MetaDBFields

MetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter)

MetaDBTable

MetaView.getMainDBTableInfo()

MetaDBTable

MetaView.getMainTable()

static int

ClassInfo.getMaxOrder(int _nParentId)

MetaDBTable

MetaDBField.getMetaDBTable()

MetaViewField

MetaDataDefCacheMgr.getMetaViewField(int _nViewId, java.lang.String _sViewFieldName)

MetaViewField

IMetaDataDefCacheMgr.getMetaViewField(int _nViewId, java.lang.String _sViewFieldName)

MetaViewField

IMetaDataDefMgr.getMetaViewField(MetaView _oView, int _iDbFieldId)

MetaViewField

MetaDataDefMgr.getMetaViewField(MetaView _oView, int _nDbFieldId)

java.util.HashMap

MetaDataDefCacheMgr.getMetaViewFields(int _nViewId)

java.util.HashMap

IMetaDataDefCacheMgr.getMetaViewFields(int _nViewId)
获得指定视图下的所有视图字段

java.util.Map

MetaDataDefCacheMgr.getMetaViewFields(int viewId, int fieldType)

java.util.Map

IMetaDataDefCacheMgr.getMetaViewFields(int _nViewId, int _nFieldType)
获取指定视图下，指定类型的视图字段

MetaViews

IMetaDataDefMgr.getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo)
查询使用了分类法oClassInfo的所有视图集合

MetaViews

MetaDataDefMgr.getMetaViewsUsingClassInfo(User _currUser, ClassInfo oClassInfo)

java.lang.String

ClassInfoMgr.getNamePath(ClassInfo _classInfo)
由指定的分类法得到从根节点到这个分类法节点的id序列

java.lang.String

IClassInfoMgr.getNamePath(ClassInfo _classInfo)

java.lang.String

ClassInfoMgr.getNamePath(ClassInfos _classInfos)
由指定的分类法得到从根节点到这个分类法节点的id序列

java.lang.String

IClassInfoMgr.getNamePath(ClassInfos _classInfos)

java.lang.String

MetaView.getOtherTableIds()
获取其它相关的表

MetaDBTables

MetaView.getOtherTables(User _currUser, WCMFilter _extraFilter)

CMSObj

MetaView.getOwner()
获取视图所属对象

CMSObj

MetaDBTable.getOwner()
获取视图所属对象

ClassInfo

ClassInfo.getParent()

java.lang.String

ClassInfoMgr.getPath(ClassInfo _classInfo)
由指定的分类法得到从根节点到这个分类法节点的id序列

java.lang.String

IClassInfoMgr.getPath(ClassInfo _classInfo)

java.lang.String

ClassInfoMgr.getPath(ClassInfos _classInfos)
由指定的分类法得到从根节点到这个分类法节点的id序列

java.lang.String

IClassInfoMgr.getPath(ClassInfos _classInfos)

java.util.List

MetaDataDefCacheMgr.getSortedMetaViewFields(int _nViewId)

java.util.List

IMetaDataDefCacheMgr.getSortedMetaViewFields(int _nViewId)

MetaViewField

MetaView.getTitleField()
返回视图的标题字段

static java.lang.String

MetaDataDefHelper.getViewApplicationPath(int _nViewId)

static java.lang.String

MetaDataDefHelper.getViewApplicationRootPath()

MetaViewFields

IMetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)

MetaViewFields

MetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)

MetaViewFields

MetaView.getViewFields(User _currUser, WCMFilter _extraFilter)

MetaViews

IMetaDataDefMgr.getViewsContainsTable(MetaDBTable _oTable)
获取使用指定表作为附表的视图

MetaViews

MetaDataDefMgr.getViewsContainsTable(MetaDBTable _oTable)

MetaViews

IMetaDataDefMgr.getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo)
获取使用了物理字段_oDBFieldInfo的所有视图

MetaViews

MetaDataDefMgr.getViewsUsingField(User _currUser, MetaDBField _oDBFieldInfo)

MetaViews

IMetaDataDefMgr.getViewsUsingTable(MetaDBTable _oTable)
获取正在使用指定表的视图

MetaViews

MetaDataDefMgr.getViewsUsingTable(MetaDBTable _oTable)

void

MetaViewField.inheritDBFieldInfo(MetaDBField _dbField)
设置物理字段的信息

boolean

ClassInfoCacheMgr.init()

boolean

MetaDataDefCacheMgr.init()

void

MetaView.insert(User _currUser)
将对象数据写入数据库

void

MetaDBTable.insert(User _currUser)
将对象数据写入数据库

void

MetaViewField.insert(User _currUser)
将对象数据写入数据库

void

ClassInfo.insert(User _currUser)
将对象数据写入数据库

boolean

ClassInfoMgr.isAncestor(int _nAncestorId, int _nDescendantId)

boolean

IClassInfoMgr.isAncestor(int nAncestorId, int nDescendantId)
判断nAncestorId是否为nDescendantId的祖先id

boolean

MetaDataDefCacheMgr.isEditorField(int _nViewId, java.lang.String _sViewFieldName)

boolean

IMetaDataDefCacheMgr.isEditorField(int _nViewId, java.lang.String _sViewFieldName)
判断是否为编辑器字段

boolean

MetaDataDefCacheMgr.isEditorField(MetaViewField _oViewField)

boolean

IMetaDataDefCacheMgr.isEditorField(MetaViewField oViewField)
判断是否为编辑器字段

boolean

MetaDataDefCacheMgr.isFieldWithType(int _nViewId, java.lang.String _sViewFieldName, int _nViewFieldType)

boolean

IMetaDataDefCacheMgr.isFieldWithType(int _nViewId, java.lang.String _sViewFieldName, int _nViewFieldType)
判断当前字段类型是否符合指定的类型

boolean

MetaViewField.isInMultiTable()

boolean

ClassInfo.isLeaf()
是否是叶子节点

boolean

MetaDataDefCacheMgr.isTitleFieldName(int _nViewId, java.lang.String _sViewFieldName)

boolean

IMetaDataDefCacheMgr.isTitleFieldName(int _nViewId, java.lang.String _sViewFieldName)

boolean

MetaView.isValid()
检验对象数据有效性

boolean

MetaDBTable.isValid()
检验对象数据有效性

boolean

MetaViewField.isValid()
检验对象数据有效性

boolean

ClassInfo.isValid()
检验对象数据有效性

boolean

MetaDBField.isValid()
检验对象数据有效性

static void

ClassInfoMgr.main(java.lang.String[] args)

void

ClassInfoCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

MetaDataDefCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

ClassInfoCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ClassInfoListenerForViewData.notifyOnDelObj(BaseObj objDeleted, int eventType)

void

ClassInfoCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

MetaDataDefCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

MetaDBFieldListenerForChannelSynRule.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

static ClassInfos

ClassInfos.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ClassInfos]

static MetaDBFields

MetaDBFields.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[DBFieldInfos]

static MetaViews

MetaViews.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ViewInfos]

static MetaDBTables

MetaDBTables.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[TableInfos]

static MetaViewFields

MetaViewFields.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ViewFieldInfos]

ClassInfos

ClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)

ClassInfos

IClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)

java.lang.String

ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列,以逗号分隔

java.lang.String

IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
得到满足条件的当前分类的所有子分类，包括子孙分类Ids

java.lang.String

ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列

java.lang.String

IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)

java.lang.String

ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, int _nClassInfoId, WCMFilter _extraFilter)

java.lang.String

IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, int _nClassInfoId, WCMFilter _extraFilter)

java.lang.String

ClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
得到满足条件的当前分类的一级子分类的Ids

java.lang.String

IClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
得到满足条件的当前分类的一级子分类的Ids

java.lang.String

ClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)

java.lang.String

IClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)

void

IMetaDataDefMgr.recreateAll(User _currUser, MetaDBTables _oMetaDBTables)
重新产生所有的表结构和相关视图的应用

void

MetaDataDefMgr.recreateAll(User _currUser, MetaDBTables _oMetaDBTables)

boolean

ClassInfoCacheMgr.reinit()

boolean

MetaDataDefCacheMgr.reinit()

void

MetaDataDefCacheMgr.reloadViewCache(int _nViewId)

void

IMetaDataDefCacheMgr.reloadViewCache(int _nViewId)

void

MetaDataDefMgr.resetTitleField(MetaViewField oMetaViewField)
根据oMetaViewField的TitleField状态决定是否重置该视图下的标题字段
如果是新建一个标题字段，则需要清除原来的标题字段；
如果是修改一个字段,并且它的TitleField属性由0变成1，即由非标题字段变成标题字段，
则也需求清除原来的标题字段

void

MetaView.save(User _currUser)

MetaDBTable

IMetaDataDefMgr.save(User _currUser, MetaDBTable _oTableInfo)
新增或者修改系统表

MetaDBTable

MetaDataDefMgr.save(User _currUser, MetaDBTable _oTableInfo)

MetaDBField

IMetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo)
在指定表上，新增或者修改指定字段信息

MetaDBField

MetaDataDefMgr.save(User _currUser, MetaDBTable _oOwnerTable, MetaDBField _oDBFieldInfo)

MetaView

IMetaDataDefMgr.save(User _currUser, MetaView _oViewInfo)
新增或修改视图信息

MetaView

MetaDataDefMgr.save(User _currUser, MetaView _oViewInfo)

MetaViewField

IMetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo)
在指定视图上，新增或者修改指定字段信息

MetaViewField

MetaDataDefMgr.save(User _currUser, MetaView _oOwnerView, MetaViewField _oViewFieldInfo)

boolean

MetaDBTable.setAnotherName(java.lang.String _sAnotherName)
设置属性：AnotherName

boolean

MetaViewField.setAnotherName(java.lang.String _sAnotherName)
设置属性：AnotherName

boolean

MetaDBField.setAnotherName(java.lang.String _sAnotherName)
设置属性：AnotherName

boolean

MetaViewField.setClassId(int _nClassId)
设置属性：ClassId

boolean

MetaDBField.setClassId(int _nClassId)
设置属性：ClassId

boolean

ClassInfo.setCode(java.lang.String _sCode)
设置属性：Code

boolean

MetaViewField.setDBField(int _nDBField)
设置属性：DBField

boolean

MetaViewField.setDBName(java.lang.String _sName)
设置属性：物理字段名称

boolean

MetaViewField.setDBType(int _nDBType)
设置属性：DBType

boolean

MetaDBField.setDBType(int _nDBType)
设置属性：DBType

boolean

MetaViewField.setDefaultValue(java.lang.String _sDefaultValue)
设置属性：DefaultValue

boolean

MetaDBField.setDefaultValue(java.lang.String _sDefaultValue)
设置属性：DefaultValue

boolean

MetaView.setDesc(java.lang.String _sDesc)
设置属性：Desc

boolean

MetaDBTable.setDesc(java.lang.String _sDesc)
设置属性：Desc

boolean

ClassInfo.setDesc(java.lang.String _sDesc)
设置属性：Desc

boolean

MetaViewField.setEditable(boolean _zEditable)

boolean

MetaViewField.setEnmValue(java.lang.String _sEnmValue)
设置属性：EnmValue

boolean

MetaDBField.setEnmValue(java.lang.String _sEnmValue)
设置属性：EnmValue

boolean

MetaViewField.setFromMainTable(boolean _bFromMainTable)
设置是否来自于主表

boolean

MetaViewField.setHidden(boolean _zHidden)

boolean

MetaView.setHiddenAppendix(boolean _zHide)

boolean

MetaViewField.setIdentityField(boolean _bIdentityField)
设置属性：IdentityField

boolean

MetaViewField.setInDetail(boolean _bInDetail)
设置属性：InDetail

boolean

MetaViewField.setInMultiTable(boolean _zInMultiTable)

boolean

MetaViewField.setInOutline(boolean _bInOutline)
设置属性：InOutline

boolean

MetaViewField.setLength(int _nLength)
设置属性：Length

boolean

MetaDBField.setLength(int _nLength)
设置属性：Length

boolean

MetaView.setMainTable(MetaDBTable _dbTableInfo)

boolean

MetaView.setMainTableId(int _nTableId, java.lang.String _sTableName)

boolean

MetaView.setName(java.lang.String _sName)
设置属性：Name

boolean

MetaDBTable.setName(java.lang.String _sName)
设置属性：Name

boolean

MetaViewField.setName(java.lang.String _sName)
设置属性：Name

boolean

ClassInfo.setName(java.lang.String _sName)
设置属性：Name

boolean

MetaDBField.setName(java.lang.String _sName)
设置属性：Name

boolean

MetaViewField.setNotNull(boolean _bNotNull)
设置属性：NotNull

boolean

MetaDBField.setNotNull(boolean _bNotNull)
设置属性：NotNull

boolean

MetaViewField.setOrder(int _nOrder)
设置属性：Order

boolean

ClassInfo.setOrder(int _nOrder)
设置分类顺序

boolean

MetaView.setOwner(int _nOwnerType, int _nOwnerId)
设置视图所属对象

boolean

MetaDBTable.setOwner(int _nOwnerType, int _nOwnerId)
设置视图所属对象

boolean

ClassInfo.setParentId(int _nParentId)
设置属性：ParentId

boolean

MetaViewField.setRadioOrCheck(boolean bRadioOrCheck)
设置属性：radioOrCheck

boolean

MetaDBField.setRadioOrCheck(boolean bRadioOrCheck)
设置属性：radioOrCheck

boolean

ClassInfo.setRootId(int _nRootId)
设置属性：RootId

boolean

MetaViewField.setScale(int _nScale)
设置属性：Scale

boolean

MetaDBField.setScale(int _nScale)
设置属性：Scale

boolean

MetaViewField.setSearchField(boolean _bSearchField)
设置属性：SearchField

boolean

MetaViewField.setTableId(int _nTableId)
设置属性：TableId

boolean

MetaDBField.setTableId(int _nTableId)
设置属性：TableId

boolean

MetaViewField.setTableName(java.lang.String _sTableName)
设置属性：TableName

boolean

MetaDBField.setTableName(java.lang.String _sTableName)
设置属性：TableName

boolean

MetaViewField.setTitleField(boolean _bTitleField)
设置属性：TitleField

boolean

MetaViewField.setType(int _nType)
设置属性：Type

boolean

MetaDBField.setType(int _nType)
设置属性：Type

boolean

MetaViewField.setValidator(java.lang.String _sValidatorExpress)
设置属性：Validator

boolean

MetaDBField.setValidator(java.lang.String _sValidatorExpress)
设置属性：Validator

boolean

MetaViewField.setView(int _nOwnerView)
设置属性：OwnerView

void

IMetaDataDefMgr.setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields)
设置

void

MetaDataDefMgr.setViewFields(User _currUser, MetaView _oOwnerView, MetaDBFields _dbFields)

com.trs.components.metadata.definition.xml 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.definition.xml 中的方法

java.lang.String

MetaViewExporter.export(MetaViews _views)
导出指定的视图

java.lang.String

MetaViewExporter.export(MetaViews _views, java.lang.String _sFileName)
导出指定的视图

void

ClassInfoImporter.importFromXML(java.lang.String _sXMLFile, int _nImportType)

void

MetaDataDDLImporter.importFromXML(java.lang.String _sXMLFile, int _nImportType, Reports _oReports)

com.trs.components.metadata.publish 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.publish 中的方法

TemplateQuote[]

WCMTagParserClassDocuments.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

WCMTagParserViewDatas.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

WCMTagParserExistDataOfClassInfo.analyzeQuotes(IPublishFolder _root)

IPublishElements

PublishFolderClassImpl.getChildren()

int

IClassInfoCountCacheForPublish.getClassInfoDataCountOfChannel(int _nChannelId, int _nClassInfoId)

int

ClassInfoCountCacheForPublishImpl.getClassInfoDataCountOfChannel(int _nChannelId, int _nClassInfoId)

int

IClassInfoCountCacheForPublish.getClassInfoDataCountOfSite(int _nSiteId, int _nClassInfoId)

int

ClassInfoCountCacheForPublishImpl.getClassInfoDataCountOfSite(int _nSiteId, int _nClassInfoId)

java.lang.String

PublishFolderClassImpl.getDataPath()

int

PublishContentViewDataImpl.getModal()

PublishTagContext

WCMTagParserRelNewsForViewData.getNextRecordContext()

PublishTagContext

WCMTagParserClassInfos.getNextRecordContext()

IPublishFolder

PublishContentViewFieldImpl.getOriginalHome()

IPublishFolder

PublishContentViewDataImpl.getOriginalHome()

IPublishFolder

PublishContentViewImpl.getOriginalHome()

IPublishFolder

PublishFolderClassImpl.getParent()

java.util.Iterator

PublishContentViewFieldImpl.getRelatedResources()

java.util.Iterator

PublishContentViewDataImpl.getRelatedResources()

java.util.Iterator

PublishContentViewImpl.getRelatedResources()

java.util.List

MetaViewDataRelateSource.getResourceNames(IPublishContent content)

IPublishFolder

PublishFolderClassImpl.getRoot()

boolean

PublishContentViewFieldImpl.isCanDoSave(User _loginUser)

boolean

PublishContentViewDataImpl.isCanDoSave(User _loginUser)

boolean

PublishContentViewImpl.isCanDoSave(User _loginUser)

boolean

PublishFolderClassImpl.loadById(int _nId)

boolean

PublishContentViewFieldImpl.loadById(int _nId)

boolean

PublishContentViewDataImpl.loadById(int _nId)

boolean

PublishContentViewImpl.loadById(int _nId)

void

PublishContentViewFieldImpl.makeFrom(CMSObj _cmsObj)

void

PublishContentViewDataImpl.makeFrom(CMSObj _cmsObj)

void

PublishContentViewImpl.makeFrom(CMSObj _cmsObj)

java.lang.String[]

WCMTagParserAppendix.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserClassIndexGener.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserRelNewsForViewData.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserClassInfos.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserViewDatas.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserViewData.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserExistDataOfClassInfo.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserViewData.parseSubItems(PublishTagContext _context)

void

PublishContentViewFieldImpl.setPublishStatus(int _nStatus)

void

PublishContentViewDataImpl.setPublishStatus(int _nStatus)

void

PublishContentViewImpl.setPublishStatus(int _nStatus)

void

PublishContentViewFieldImpl.setPublishTime(CMyDateTime _dtTime)

void

PublishContentViewDataImpl.setPublishTime(CMyDateTime _dtTime)

void

PublishContentViewImpl.setPublishTime(CMyDateTime _dtTime)

void

PublishContentViewFieldImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)

void

PublishContentViewDataImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)

void

PublishContentViewImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)

void

PublishFolderClassImpl.setRootId(int _nRootId)

PublishTagContext

WCMTagParserRelNewsForViewData.substantiateContext(PublishTagContext _tagConext)

PublishTagContext

WCMTagParserClassInfos.substantiateContext(PublishTagContext _tagConext)

void

PublishContentViewFieldImpl.validateCanDoPreview()

void

PublishContentViewDataImpl.validateCanDoPreview()

void

PublishContentViewImpl.validateCanDoPreview()

com.trs.components.metadata.right 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.right 中的方法

static boolean

AuthServerMgr.hasRight(User _loginUser, MetaDBTable _oDBTable)

static boolean

AuthServerMgr.hasRight(User _loginUser, MetaView _view)

com.trs.components.metadata.service 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.service 中的方法

static void

ClassInfoToChannelHelper.createChannels(ClassInfo _oParentClassInfo, BaseChannel _host, MetaView _oView, int _nMaxLevel)

java.lang.String

ClassInfoServiceProvider.createClassInfoTreeHTML(User _currUser, int _nParentId)
产生指定父节点的分类信息

java.lang.String

ClassInfoServiceProviderForGB.createClassInfoTreeHTML(User _currUser, int _nParentId)
产生指定父节点的分类信息

void

ClassInfoToGroupCreator.createGroups(ClassInfo _oDeptClassInfoRoot, Group _hostGroup, int _nMaxLevel)

static void

ClassInfoToChannelHelper.createSites(ClassInfo _oParentClassInfo, MetaView _oView, int _nMaxLevel, java.lang.String _sRootDomain)

void

ClassInfoServiceProvider.deleteClassInfo(User _currUser, int _nClassInfoId)

void

ClassInfoServiceProviderForGB.deleteClassInfo(User _currUser, int _nClassInfoId)

void

ClassInfoServiceProvider.deleteClassInfo(User _currUser, java.lang.String _sClassInfoIds)

void

ClassInfoServiceProviderForGB.deleteClassInfo(User _currUser, java.lang.String _sClassInfoIds)

java.lang.Object

ClassInfoServiceProvider.exists(MethodContext _methodContext)
是否存在指定条件的分类信息

java.lang.Object

ClassInfoServiceProviderForGB.exists(MethodContext _methodContext)
是否存在指定条件的分类信息

java.lang.String

ClassInfoServiceProvider.exportClassInfos(MethodContext _oMethodContext)
导出指定的分类法

java.lang.String

MetaDataDefServiceProvider.exportViews(MethodContext _oMethodContext)
导出指定的视图

MetaView

MetaDataDefServiceProvider.findViewByChannel(MethodContext _methodContext)

Channels

DefaultChannelMakerCenter.getAvailableChannels(User _loginUser, int _nViewId)
获取当前用户在指定视图下可用的栏目,根据视图，获取视图绑定的栏目，在过滤到没有权限的栏目

static java.lang.String

MailConfigsHelper.getConfig(java.lang.String sConfigName)

static java.util.Map

MailConfigsHelper.getConfigs()

java.lang.String

ClassInfoServiceProvider.getPath(MethodContext _methodContext)

java.lang.String

ClassInfoServiceProviderForGB.getPath(MethodContext _methodContext)

Reports

MetaDataDefServiceProvider.importViewsFromXML(MethodContext _oMethodContext)
从系统导出的XML创建视图（包括元数据表）

static void

MailConfigsHelper.loadConfigs()

Channel

DefaultChannelMakerCenter.makeDefaultChannel(User _loginUser, int _nViewId)
构造用户在指定视图上默认存储的栏目

Channel

IDefaultChannelMaker.makeDefaultChannel(User _loginUser, int _nViewId)
构造当前用户默认的栏目

Channel

UserRelateInfoMaker.makeDefaultChannel(User _loginUser, int _nViewId)

static ClassInfo

UserRelateInfoMaker.makeDefaultClassInfo(java.lang.String _sDeptClassInfoRootName, User _currUser)
构造指定用户对应的机构分类

void

ClassInfoPublishServiceProvider.publishClassInfo(MethodContext _oMethodContext)

ClassInfos

ClassInfoServiceProvider.queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)

ClassInfos

ClassInfoServiceProviderForGB.queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)

ClassInfos

ClassInfoViewService.queryClassInfos(User _currUser, java.lang.String _sDocumentIds, WCMFilter _filter)
根据分类法信息返回视图对象集合

MetaDBTables

MetaDataDefServiceProvider.queryDBTableInfos(MethodContext _oMethodContext)

Documents

ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfoIds, java.lang.String _sViewId, boolean _bContainChildClassInfo)
根据分类法的id序列和viewId得到文档集合对象

Documents

ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter)
根据传入的分类法对象获取文档集合对象

Documents

ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo)
根据传入的分类法对象获取文档集合对象

int

GovInfoServiceProvider.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)

int

MetaDataCenterServiceProviderForGB.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)

int

MetaDataCenterServiceProviderForAgri.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)

MetaViews

ClassInfoViewService.queryViews(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter)
根据分类法信息返回视图对象集合

MetaViews

ClassInfoViewService.queryViews(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo)
根据分类法信息返回视图对象集合

static void

ClassInfoChannelRightHelper.resetClassInfoChannelRight(WebSite _site, Group _rootGroup)

void

GovInfoIndexCreator.resetFieldValueOnMetaData()

ClassInfo

ClassInfoServiceProvider.saveClassInfo(MethodContext _context)

ClassInfo

ClassInfoServiceProviderForGB.saveClassInfo(MethodContext _context)

ClassInfo

ClassInfoServiceProvider.saveClassInfo(MethodContext _methodContext, User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode)
这个方法实现不太好，但只是为了兼容wcm6，因为wcm6的实现，字段都是写死的， 不能根据外界传入什么字段，向数据库中保存什么

ClassInfo

ClassInfoServiceProviderForGB.saveClassInfo(User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc)
保存分类法设置

ClassInfo

ClassInfoServiceProvider.saveClassInfo(User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode)
保存分类法设置

void

GovInfoIndexCreator.setFieldValueBeforeSaveMetaData(MetaViewData _oMetaViewData)

static MetaViewData

GovInfoServiceProvider.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)

static MetaViewData

MetaDataCenterServiceProviderForGB.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)

static MetaViewData

MetaDataCenterServiceProviderForZJH.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)

static MetaViewData

MetaDataCenterServiceProviderForAgri.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)

com.trs.components.metadata.web 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.web 中的方法

java.lang.String

FieldTemplate.getTemplateContent(MetaViewField oViewField)
获取该视图字段对应的模板内容

java.lang.String

HTMLMaker.makeHTML()
返回解析之后的视图字段资源片段

com.trs.components.metadata.web.impl 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.metadata.web.impl 中的方法

java.lang.String

DefaultHTMLMaker.makeHTML()

com.trs.components.special 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.special 中的方法

static Special

Special.createNewInstance()
产生当前对象[Special]的实例

void

SpecialMgr.delete(User _curruser, Special _special)

void

ISpecialMgr.delete(User _curruser, Special _oSpecial)
删除指定的专题

static Special

Special.findById(int _nId)
提取指定ID的对象

static Special

Special.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

Special

SpecialMgr.findSpecialByChnlId(User _oUser, int _nChnlId)

Special

ISpecialMgr.findSpecialByChnlId(User _oUser, int _nChnlId)
根据栏目的Id，获取栏目对应的专题对象

PageStyle

ISpecialMgr.getStyle(Special _oSpecial)
获取专题风格

void

Special.insert(User _currUser)
将对象数据写入数据库

boolean

Special.isValid()
检验对象数据有效性

static Specials

Specials.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Specials]

Specials

SpecialMgr.query(User _curruser, WCMFilter _filter)

Specials

ISpecialMgr.query(User _oCurrUser, WCMFilter _currFilter)
查询符合当前条件的专题

Special

ISpecialMgr.save(User _currUser, Special _currSpecial, java.lang.String _sSpecialSiteHttp)
保存当前专题

boolean

Special.setHostId(int _nHostId)
设置属性：HostId

boolean

Special.setHostType(int _nHostType)
设置属性：HostType

boolean

Special.setMasteId(int _nMasteId)
设置属性：MasteId

boolean

Special.setSpecialDesc(java.lang.String _sSpecialDesc)
设置属性：SpecialDesc

boolean

Special.setSpecialName(java.lang.String _sSpecialName)
设置属性：SpecialName

boolean

ISpecialMgr.setStyle(Special _oSpecial, PageStyle _oPageStyle)
设置专题风格

boolean

Special.setStyleName(java.lang.String _sStyleName)
设置属性：StyleName

boolean

Special.setViewThumb(java.lang.String _sViewThumb)
设置属性：ViewThumb

com.trs.components.stat 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.stat 中的方法

boolean

IStatResultsFilter.accept(java.lang.String sKey, IStatResults statResults)
过滤结果集集合中的数据

float

IBonusCalculator.caclulateHitsBonus(int _nHitsCount)
根据点击量，计算点击量所获奖金

float

BonusCalculator.caclulateHitsBonus(int _nHitsCount)
根据点击量，计算点击量所获奖金

float

IBonusCalculator.caclulateIssuedAmountBonus(int _nDocCount)
根据发稿量，计算发稿量所获奖金

float

BonusCalculator.caclulateIssuedAmountBonus(int _nDocCount)
根据发稿量，计算发稿量所获奖金

static BonusRule

BonusRule.createNewInstance()
产生当前对象[BonusRule]的实例

static HostObjHitsCount

HostObjHitsCount.createNewInstance()
产生当前对象[HostObjHitsCount]的实例

static HostObjDomain

HostObjDomain.createNewInstance()
产生当前对象[HostObjDomain]的实例

static UserLoginInfo

UserLoginInfo.createNewInstance()
产生当前对象[UserLoginInfo]的实例

static ChnlDept

ChnlDept.createNewInstance()
产生当前对象[ChnlDept]的实例

static DocumentHitsCount

DocumentHitsCount.createNewInstance()
产生当前对象[DocumentHitsCount]的实例

boolean

BonusRuleMgr.delete(User _oCurrUser, BonusRules _oBonusRules)
删除指定的奖励规则

boolean

IBonusRuleMgr.delete(User _oCurrUser, BonusRules _oBonusRules)
删除指定的奖励规则

IStatResults

IStatResults.filter(IStatResultsFilter resultsFilter)
使用过滤规则resultFilter对结果集集合进行过滤，返回过滤之后的新的结果集集合

IStatResults

StatResults.filter(IStatResultsFilter resultsFilter)

static BonusRule

BonusRule.findById(int _nId)
提取指定ID的对象

static HostObjHitsCount

HostObjHitsCount.findById(int _nId)
提取指定ID的对象

static HostObjDomain

HostObjDomain.findById(int _nId)
提取指定ID的对象

static UserLoginInfo

UserLoginInfo.findById(int _nId)
提取指定ID的对象

static ChnlDept

ChnlDept.findById(int _nId)
提取指定ID的对象

static DocumentHitsCount

DocumentHitsCount.findById(int _nId)
提取指定ID的对象

static BonusRule

BonusRule.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static HostObjHitsCount

HostObjHitsCount.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static HostObjDomain

HostObjDomain.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static UserLoginInfo

UserLoginInfo.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ChnlDept

ChnlDept.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static DocumentHitsCount

DocumentHitsCount.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

float

StatBonusResultForUser.getBonus(java.lang.String _sUserName, int _nBonusType)
获取指定用户所获得的指定类型的奖金

java.util.List

IChnlDeptMgr.getChnlIdsByDep(Group group)
根据组织返回栏目的id数组

java.util.List

ChnlDeptMgr.getChnlIdsByDep(Group _group)
根据组织获取组织相关的栏目ID列表

java.lang.String

IChnlDeptMgr.getChnlIdsByDepts(Groups groups)
根据组织返回栏目的id数组

java.lang.String

ChnlDeptMgr.getChnlIdsByDepts(Groups groups)
通过组织集合查找所有组织相关的栏目

java.lang.String

IUserLoginInfoMgr.getCurrUser(User _oUser)
获取普通用户自己的条件构造

java.lang.String

UserLoginInfoMgr.getCurrUser(User _oUser)
获取用户自己的构造条件，返回用户名的userId

java.util.List

IChnlDeptMgr.getDepIdsByChannel(Channel channel)
根据栏目返回组织的id数组

java.util.List

ChnlDeptMgr.getDepIdsByChannel(Channel _channel)
通过栏目获取组织的ID序列

java.lang.String

IChnlDeptMgr.getDepNamesByChannel(Channel channel, User user)
根据栏目获取组织名称或者用户获取组织

java.lang.String

ChnlDeptMgr.getDepNamesByChannel(Channel _channel, User _user)
通过栏目或用户获取组织名称

java.lang.String

IUserLoginInfoMgr.getSearchGroupName(java.lang.String _groupName)
获取部门名称检索的条件构造

java.lang.String

IUserLoginInfoMgr.getSearchUserName(java.lang.String _userName)
获取用户名称检索的条件构造

float

StatBonusResultForUser.getTotalBonus(java.lang.String _sUserName)
获取指定用户所获得的总奖金

java.lang.String

IUserLoginInfoMgr.getUsersForGrpAdmin(User _oUser)
获取组管理员所在组的所有用户的条件构造

void

IHitsCountHandler.handle(BaseObj obj, java.util.Map properties)
更新指定对象obj的点击量

void

SiteHitsCountHandler.handle(BaseObj obj, java.util.Map properties)

void

ChannelHitsCountHandler.handle(BaseObj obj, java.util.Map properties)

boolean

ChnlDeptMgr.init()

void

BonusRule.insert(User _currUser)
将对象数据写入数据库

void

HostObjHitsCount.insert(User _currUser)
将对象数据写入数据库

void

HostObjDomain.insert(User _currUser)
将对象数据写入数据库

void

UserLoginInfo.insert(User _currUser)
将对象数据写入数据库

void

ChnlDept.insert(User _currUser)
将对象数据写入数据库

void

DocumentHitsCount.insert(User _currUser)
将对象数据写入数据库

boolean

BonusRule.isValid()
检验对象数据有效性

boolean

HostObjHitsCount.isValid()
检验对象数据有效性

boolean

HostObjDomain.isValid()
检验对象数据有效性

boolean

UserLoginInfo.isValid()
检验对象数据有效性

boolean

ChnlDept.isValid()
检验对象数据有效性

boolean

DocumentHitsCount.isValid()
检验对象数据有效性

void

IHitsCountHandler.notifyComplete()
在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。

void

ChnlDeptMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

ChnlDeptMgr.notifyOnDelObj(BaseObj _oObjDeleted, int eventType)

void

ChnlDeptMgr.notifyOnModifyObj(BaseObj _oObjModified, int eventType)

static DocumentHitsCounts

DocumentHitsCounts.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[DocumentHitsCounts]

static HostObjDomains

HostObjDomains.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[HostObjDomains]

static ChnlDepts

ChnlDepts.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ChnlDepts]

static HostObjHitsCounts

HostObjHitsCounts.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[HostObjHitsCounts]

static UserLoginInfos

UserLoginInfos.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[UserLoginInfos]

static BonusRules

BonusRules.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[BonusRules]

BaseObj

IURLParser.parse(java.lang.String sUrl)
根据Url信息，返回该Url对应的BaseObj对象。

BaseObj

URLParser.parse(java.lang.String sUrl)

UserLoginInfos

IUserLoginInfoMgr.query(User _oCurrUser, WCMFilter _filter)

BonusRules

BonusRuleMgr.query(User _oCurrUser, WCMFilter _oFilter)
查询系统指定奖励规则

BonusRules

IBonusRuleMgr.query(User _oCurrUser, WCMFilter _currFilter)
查询系统指定奖励规则

UserLoginInfos

UserLoginInfoMgr.query(User _oCurrUser, WCMFilter _filter)
查询指定条件下的用户登录信息

boolean

ChnlDeptMgr.reinit()

BonusRule

BonusRuleMgr.save(User _oCurrUser, BonusRule _oBonusRule)

BonusRule

IBonusRuleMgr.save(User _oCurrUser, BonusRule _oBonusRule)

BonusRule

BonusRuleMgr.save(User _oCurrUser, int _nBonusType, java.lang.String _sRange, float _fPricePerUnit)
保存当前奖励规则

BonusRule

IBonusRuleMgr.save(User _oCurrUser, int _nBonusType, java.lang.String _sRange, float _fPricePerUnit)
保存当前奖励规则

UserLoginInfo

IUserLoginInfoMgr.save(UserLoginInfo _oUserLoginInfo, User _oCurrUser)

UserLoginInfo

UserLoginInfoMgr.save(UserLoginInfo _oUserLoginInfo, User _oCurrUser)
保存当前用户登录信息

boolean

BonusRule.setBonusType(int _nBonusType)
设置属性：BonusType。

boolean

ChnlDept.setChannelId(int _nChannelId)
设置属性：ChannelId

boolean

DocumentHitsCount.setChnlId(int _nChnlId)
设置属性：ChnlId 栏目ID

boolean

DocumentHitsCount.setChnlName(java.lang.String _sChnlName)
设置属性：ChnlName 栏目名称

boolean

ChnlDept.setContainsChildrenChnl(boolean _bContainsChildrenChnl)
设置属性：ContainsChildrenChnl

boolean

DocumentHitsCount.setDocCrTime(CMyDateTime _dtDocCrTime)
设置属性：DocCrTime 文档创建时间

boolean

DocumentHitsCount.setDocCrUser(java.lang.String _sDocCrUser)
设置属性：DocCrUser 文档创建者

boolean

DocumentHitsCount.setDocId(int _nDocId)
设置属性：DocId 文档ID

boolean

DocumentHitsCount.setDocTitle(java.lang.String _sDocTitle)
设置属性：DocTitle 文档标题

boolean

ChnlDept.setGroupId(int _nGroupId)
设置属性：GroupId

boolean

HostObjHitsCount.setHitsCount(int _nHitsCount)
设置属性：HitsCount

boolean

DocumentHitsCount.setHitsCount(int _nHitsCount)
设置属性：HitsCount 点击量

boolean

HostObjHitsCount.setHitsTime(CMyDateTime _dtHitsTime)
设置属性：HitsTime

boolean

DocumentHitsCount.setHitsTime(CMyDateTime _dtHitsTime)
设置属性：HitsTime 点击时间

boolean

HostObjHitsCount.setHostId(int _nHostId)
设置属性：HostId

boolean

HostObjDomain.setHostId(int _nHostId)
设置属性：HostId

boolean

HostObjHitsCount.setHostType(int _nHostType)
设置属性：HostType

boolean

HostObjDomain.setHostType(int _nHostType)
设置属性：HostType

boolean

UserLoginInfo.setIpAddress(java.lang.String _sIpAddress)
设置属性：IpAddress，登陆的IP地址

boolean

UserLoginInfo.setLoginTime(CMyDateTime _dtLoginTime)
设置属性：LoginTime，用户登录时间

boolean

HostObjHitsCount.setObjCrTime(CMyDateTime _dtObjCrTime)
设置属性：ObjCrTime

boolean

HostObjHitsCount.setObjCrUser(java.lang.String _sObjCrUser)
设置属性：ObjCrUser

boolean

HostObjHitsCount.setObjName(java.lang.String _sObjName)
设置属性：ObjName

boolean

BonusRule.setPricePerUnit(float _fPricePerUnit)
设置属性：PricePerUnit

boolean

BonusRule.setRange(java.lang.String _sRange)
设置属性：Range

boolean

HostObjHitsCount.setSpecial(boolean _bIsSpecial)
设置属性：IsSpecial

boolean

HostObjDomain.setUrl(java.lang.String _sUrl)
设置属性：Url

boolean

UserLoginInfo.setUserId(int _nUserId)
设置属性：UserId，用户ID

java.util.List

IStatResult.sort(boolean bSortDesc)
对第1条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序

java.util.List

StatResult.sort(boolean sortDesc)

java.util.List

IStatResult.sort(int nSQLIndex, int nKeyIndex, java.lang.String sKeyValue, boolean bSortDesc)
对第nSQLIndex条统计结果集中的，第nKeyIndex位key的sKeyValue值进行排序

java.util.List

StatResult.sort(int index, int keyIndex, java.lang.String keyValue, boolean sortDesc)

java.util.List

IStatResult.sort(int nSQLIndex, java.lang.String sKeyValue, boolean bSortDesc)
对第nSQLIndex条统计结果集中的，第3位key的sKeyValue值进行排序

java.util.List

StatResult.sort(int index, java.lang.String keyValue, boolean sortDesc)

java.util.List

IStatResult.sortWithSQLIndex(int nSQLIndex, boolean bSortDesc)
对第nSQLIndex条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序
一般仅对select包含两个字段有效

java.util.List

StatResult.sortWithSQLIndex(int index, boolean sortDesc)

IStatResult

StatAnalysisTool.stat(CMyDateTime startDate, CMyDateTime endDate)
对指定的开始时间startDate与结束时间endDate进行统计，返回统计的结果集对象

IStatResults

StatAnalysisTool.stat(CMyDateTime startDate, CMyDateTime endDate, int nStepType)
对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。

IStatResult

StatAnalysisTool.stat(java.lang.String sStartDate, java.lang.String sEndDate)
对指定的开始时间sStartDate与结束时间sEndDate进行统计，返回统计的结果集对象

IStatResults

StatAnalysisTool.stat(java.lang.String sStartDate, java.lang.String sEndDate, int nStepType)
对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。

void

IStatHandler.visitEnd(int nSQLIndex)
在遍历完所有统计结果之后，需要执行的处理

void

DocStatHandler4SiteOfGroup.visitStart(java.sql.ResultSet resultSet, int nSQLIndex)

void

BaseStatHandler.visitStart(java.sql.ResultSet resultSet, int nSQLIndex)

void

IStatHandler.visitStart(java.sql.ResultSet resultSet, int nSQLIndex)
在遍历每一条统计处理之前，需要执行的处理

void

DocstatHandler4ChannelOfUser.visitStart(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocstatHandler4SiteOfUser.visitStart(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocStatHandler4ChannelOfGroup.visitStart(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocStatHandler4ChnlDeptChannel.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocStatHandler4UserDeptSite.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocStatHandler4Channel.visitStatItem(java.sql.ResultSet resultSet, int index)

void

DocStatHandler4SiteOfGroup.visitStatItem(java.sql.ResultSet resultSet, int index)

void

IStatHandler.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。

void

DocStatHandler4UserDeptChannel.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocStatHandler4UserChannel.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocstatHandler4ChannelOfUser.visitStatItem(java.sql.ResultSet resultSet, int index)

void

DocStatHandler4UserSite.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocStatHandler4ChnlDept.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

HitsStatHandler4Channel.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocstatHandler4SiteOfUser.visitStatItem(java.sql.ResultSet resultSet, int index)

void

DocStatHandler4ChnlDeptSite.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

HitsStatHandler4UserDept.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DefaultStatHandler.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

HitsStatHandler4User.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

HitsStatHandler4ChnlDept.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocStatHandler4UserDept.visitStatItem(java.sql.ResultSet resultSet, int nSQLIndex)

void

DocStatHandler4ChannelOfGroup.visitStatItem(java.sql.ResultSet resultSet, int index)

com.trs.components.wcm.auth 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.auth 中的方法

static boolean

ChannelAuthHelper.hasRight(User _currUser, Channel _channel, int _nRightIndex)

boolean

WebSiteRightObjImpl.hasRight(User _currUser, int _nRightIndex)

boolean

ChannelRightObjImpl.hasRight(User _currUser, int _nRightIndex)

boolean

WebSiteRightObjImpl.loadById(int _nId)

boolean

ChannelRightObjImpl.loadById(int _nId)

void

WebSiteRightObjImpl.makeFrom(CMSObj _oObj)

void

ChannelRightObjImpl.makeFrom(CMSObj _oObj)

com.trs.components.wcm.channel 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.channel 中的方法

VChannel

TxtFileParser.parse(java.lang.String filename)

VChannel

IVChannelParser.parse(java.lang.String filename)
从文件内容中解释得到需要创建的对象.

void

VChannelManager.save(Channel _parent, VChannel _oVChannel)

void

VChannelManager.save(WCMSystemObject _parent, VChannel _oVChannel)

void

VChannelManager.save(WebSite _parent, VChannel _oVChannel)

com.trs.components.wcm.content 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.content 中的方法

static ViewDocument

ViewDocument.findById(BaseChannel _host, int _nChnlDocRecId, java.lang.String _sSelectFieldsOfChnlDoc, java.lang.String _sSelectFieldsOfDocument)
获取指定Id的ViewDocument

Channel

ViewDocument.getChannel()
获取文档当前所处的栏目

Channel

ViewDocument.getDocChannel()

java.lang.String

ViewDocument.getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute)
文档HTML内容过滤处理，用于文档HTML正文的显示处理
处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于：
[1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?

java.lang.String

ViewDocument.getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute, boolean _bFromPubHTMLContent)

RightValue

ViewDocument.getRightValue(User _currUser)
获取当前ViewDocument的RightValue

Source

ViewDocument.getSource()
获取文档来源

Status

ViewDocument.getStatus()

boolean

ViewDocument.hasRight(User _loginUser, int _nRightIndex)
判断当前用户对于ViewDocument是否具有指定的权限

boolean

ViewDocument.isRightDefined()
判断当前文档是否自定义了权限

void

ViewDocuments.open(Channels _channels, WCMFilter _filter)

void

ViewDocuments.open(Channel _channel, WCMFilter _filter)

void

ViewDocuments.open(CMSBaseObjs _oSitesOrChannels, WCMFilter _extraFilter)

void

ViewDocuments.open(WebSites _sites, WCMFilter _filter)

void

ViewDocuments.open(WebSite _site, WCMFilter _filter)

void

ViewDocuments.openViewDocuments(WCMFilter _filter)

static Documents

QueryDocumentCenter.queryDocumentsForUser(User _currUser, BaseChannel _oChannelOrSite, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize, boolean _bContainsChildren, WCMFilter _filter)

static Documents

QueryDocumentCenter.queryDocumentsForUser(User _currUser, int _nChannelId, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize)

static Documents

QueryDocumentCenter.queryDocumentsOfCurrPage(WCMFilter _filter, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize)

void

ViewDocument.readChnlDocPropertyFromRs(java.sql.ResultSet _rsData, java.sql.ResultSetMetaData _rsmdData)

com.trs.components.wcm.content.domain 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.content.domain 中的方法

void

AppendixMgr.addAppendix(Document _currDocument, Appendix _currAppendix)
新增附件

void

ContentExtFieldMgr.addExtField(CMSObj _host, ContentExtField _extfield, int i)

void

ContentExtFieldMgr.addExtFieldToChildren(CMSObj _host, ContentExtField _extfield)

void

ContentExtFieldMgr.addExtFieldToSpeicficChildren(java.lang.String _sSiteids, java.lang.String _sChannelids, ContentExtField _extfield)

void

DocKeywordMgrImpl.addNewDocKeywords(Document _document)

void

IDocKeywordMgr.addNewDocKeywords(Document _document)
增加指定文档的相关新闻记录

void

SiteMemberMgr.addSiteGroup(WebSite _site, Group _group)
添加站点用户组
将指定的用户组添加到指定的站点

void

SiteMemberMgr.addSiteMember(int _nSiteId, int _nObjType, int _nObjId)

void

SiteMemberMgr.addSiteUser(WebSite _site, User _user)
添加站点用户
将指定的用户添加到指定的站点

void

AutoDocBakMgr.autoBakDocument(Document _document)

void

AutoDocBakMgr.autoBakDocument(Document _document, int _nOperType)

DocBak

DocBakMgr.bakupDocument(Document _currDocument)
备份当前文档

void

DocumentMgr.changeStatus(Document _currDocument, Channel _currChannel, int _newStatusId)

void

DocumentMgr.changeStatus(Document _currDocument, Channel _currChannel, Status _newStatus)
修改ChnlDoc中对应的状态
如果是实体文档，则同步状态

void

DocumentMgr.changeStatus(int _newStatusId, ChnlDoc _currChnlDoc)
改变文档在指定频道下的状态

void

DocumentMgr.clearAll(User _currUser, BaseChannel _oSiteOrChannel)
清空回收站

void

AppendixMgr.copyAppendixes(Document _fromDocument, Document _newDocument)
复制某个特定文档的所有附件到一个新文档中

void

DocReplyMgr.copyDocReplys(Document _fromDocument, Document _newDocument)
复制文档回复

Document

DocumentMgr.copyDocument(Document _fromDocument, Channel _fromChannel, Channel _toChannel)
复制文档到另一个频道上
不负责非依赖型关联对象的复制，如附件和相关文档
不能将一个文档从草稿箱或者复制到草稿箱
复制引用转发的文档相当于创建一个新的引用转发
复制实体文档，则需要在目标频道下创建一个新的实体文档

java.util.List

RelationMgr.copyRelationListByObj(BaseObj _currObj)
以List方式获得文档所属关联文档集合
在处理文档时是个有用的接口
该接口应该是获得对象的关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用
以后扩展应该也比较方便，增加一个对象类型ID即可

void

RelationMgr.copyRelations(Document _fromDocument, Document _newDocument)
复制某个特定文档的所有相关文档到一个新文档中

void

ChannelMgr.delete(BaseChannel _oChannel, boolean _bDrop)

void

AutoTransmitMgr.delete(ChannelSyn _currChnlSyn)

void

ContentExtFieldMgr.delete(CMSObj _siteOrChannel, ContentExtField _extfield, boolean _bDoWithChildren)

void

ContentLinkMgr.delete(ContentLink _contentLink)
删除内容超链接

void

ContentLinkMgr.delete(ContentLinks _contentLinks)
删除内容超链接集合

void

DocumentMgr.delete(Document _currDocument, Channel _currChannel, boolean _bDrop)
从某个频道下删除一篇文档
频道为一个真实频道，暂时不支持从回收站、草稿箱或其它特殊频道中删除。

boolean

ReplaceMgr.delete(Replace _aReplace)
删除指定的Replace对象

void

ContentLinkMgr.deleteContentLinks(WebSite _site)

void

DocBakMgr.deleteDocBak(DocBak _currDocBak)
删除一个文档备份(版本)

void

DocumentMgr.deleteDocQuotes(Document _currDocument, java.lang.String _sExcludeChannelIds)
根据频道排除Id，删除所有特定类型的文档转发关系

void

AutoTransmitMgr.deleteDocumentSyn(DocumentSyn _currTransmittedDoc)

void

RelationMgr.deleteRelations(Document _document)

void

AppendixMgr.deleteUnuseAppendixes(Document _currDocument, java.lang.String _sUseingIds, int _nAppendixType)
删除指定文档指定类型没有使用的附件

void

RelationMgr.deleteUnuseRelations(java.lang.String _sUseingIds, Document _document)

void

AppendixMgr.editAppendix(Document _currDocument, Appendix _currAppendix)
修改附件

java.lang.String

ChannelExporter.export(BaseChannel _siteOrChnl, boolean _bWithChildren, boolean _bWithRelate)

java.lang.String

ChannelExporter.export(Channels _channels, boolean _bWithChildren, boolean _bWithRelate)

java.lang.String

DocumentExporter.export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes)
导出文档集合

java.lang.String

DocumentExporter.export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes)
导出指定的文档

java.lang.String

DocumentExporter.export(int _nDocId, java.lang.String _sFieldsList, boolean _bWithAppendixes)
导出指定的文档

java.lang.String

ChannelExporter.export(java.lang.Object _object, boolean _bWithChildren, boolean _bWithRelate)

java.lang.String

ChannelExporter.export(java.lang.Object _object, boolean _bWithChildren, boolean _bWithRelate, boolean _bReturnXMLContent)

java.lang.String

ChannelExporter.export(java.lang.Object _object, boolean _bWithChildren, boolean _bWithRelate, boolean _bReturnXMLContent, boolean _bForcedExportTempInfo)

java.lang.String

DocumentExporter.export(java.lang.String _sDocIds, java.lang.String _sFieldsList, boolean _bWithAppendixes)
根据指定的ID序列导出文档

java.lang.String

ChannelExporter.export(WebSites _sites, boolean _bWithChildren, boolean _bWithRelate)

java.lang.String

ChannelExporter.exportToXMLContent(java.lang.Object _object, boolean _bWithChildren, boolean _bWithRelate)

ChnlDoc

DocumentMgr.findChnlDoc(Document _currDocument, Channel _currChannel)
根据文档和频道，找到对应的ChnlDoc

DocBaks

DocBakMgr.findDocBaks(Document _currDocument)
取文档的备份集合

DocBaks

DocBakMgr.findDocBaks(Document _currDocument, WCMFilter _filter)
取当前文档的备份集合

Schedule

DocumentPriMgr.findSchedule(ChnlDoc _currChnlDoc)
查找文档置顶计划中，当前ChnlDoc对应的计划发布任务

Documents

DocumentMgr.getAllDocuments(BaseChannel _oChannel, WCMFilter _filter)
获取当前站点/频道下的所有文档

Documents

DocKeywordMgrImpl.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)

Documents

IDocKeywordMgr.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
获取指定文档的所有相关文档

Documents

DocKeywordMgrImpl.getAllRelatedDocumentsByKeywordsFromTRSServer(java.lang.String _sKeywords, WCMFilter _filter, int _nPageIndex)

Appendix

AppendixMgr.getAppendixById(int _nId)

Appendixes

AppendixMgr.getAppendixes(Document _currDocument, int _nAppendixType)
获取当前文档某种类型的附件

Appendixes

AppendixMgr.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter)
获取当前文档某种类型的附件

Appendixes

AppendixMgr.getAppendixes(Document _currDocument, WCMFilter _filter)
获取当前文档的附件(符合筛选条件)

Appendixes

AppendixMgr.getAppendixes(WCMFilter _aWCMFilter)
根据条件获得当前附件

AutoBakConfig

AutoDocBakMgr.getAutoSaveConfig(WebSite _currSite)

Channels

DocumentMgr.getChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere)
获取所有与文档相关的频道

Channels

ChannelMgr.getChannels(int _nSiteId, int _nChannelType, boolean _bIncludingDeletedChannel)
取当前站点下某类型的栏目集合

Channels

ChannelMgr.getChannels(int _nSiteId, WCMFilter _filter)
取符合一定条件的栏目集合

ChannelSyns

AutoTransmitMgr.getChannelSyns(Channel _currChannel, WCMFilter _filter)

ChannelSyns

AutoTransmitMgr.getChannelSyns(Channel _currChannel, WCMFilter _filter, boolean _bChannelAsTarget)

CMSBaseObjs

ChannelMgr.getChildren(BaseChannel _oChannel, int _nChannelType, boolean _bIncludingDeletedChannel, WCMFilter _filter)

ContentLinks

ContentLinkMgr.getContentLinks(int _nSiteId, WCMFilter _filter)
获取指定站点下的内容超链接

ContentLinks

ContentLinkMgr.getContentLinks(WebSite _currSite, WCMFilter _filter)
获取当前站点的所有内容超链接

DocBak

DocBakMgr.getDocBak(Document _currDocument, int _nVersion)
取文档某个版本的备份

Status

DocumentMgr.getDocStatus(Document _currDocument, int _nChnlId)
获取当前文档在所有频道下的状态

Documents

DocumentMgr.getDocuments(BaseChannel _oChannel, WCMFilter _filter)
取站点/频道的(除了回收站外的)文档集合

static Documents

DocumentsGetHelper.getDocuments(Channel _channel, WCMFilter _filter)

static Documents

DocumentsGetHelper.getDocuments(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder)

Documents

UserDocumentMgr.getDocuments(WCMFilter _filter)
获取个人的所有有效文档

CMyDateTime

DocumentMgr.getDocumentTopTime(Document _currDocument, Channel _currChannel)
获得文档置顶的截止时间
如果文档没有置顶，则直接返回null
如果置顶文档没有设置截止时间则返回null

Documents

UserDocumentMgr.getDraft(WCMFilter _filter)
获取个人草稿

static java.io.File[]

DocumentImporter.getExistedMapingFiles(User _currUser)

static java.io.File[]

DocumentImporter.getExistedXslFiles(User _currUser)

ContentExtFields

ContentExtFieldMgr.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)

ContentExtFields

ContentExtFieldMgr.getExtFields(CMSObj _host, WCMFilter _filter, boolean _bContainsChildren)

WCMFilter

DocumentMgr.getFilterForDocuments(BaseChannel _oChannel, WCMFilter _docFitler)

ChnlDoc

DocumentMgr.getFirstChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop)
得到频道内的第一个频道文档。

BaseChannel

ChannelMgr.getHost(BaseChannel _oChannel)
获取栏目的父栏目,如果栏目是一级栏目,则返回该栏目所在的站点

ChnlDoc

DocumentMgr.getLastChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop)
得到频道内的最后一个频道文档。

int

ContentExtFieldMgr.getMaxOrder(CMSObj host)

static java.lang.String

DocumentImporter.getMyDocumentImportSourceFilePath(User _currUser)

ChnlDoc

DocumentMgr.getNextChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop)
得到频道内，当前频道文档的后一个频道文档。

ChnlDoc

DocumentMgr.getPreviousChnlDoc(ChnlDoc _currChnlDoc, boolean _bIncludeTop)
得到频道内，当前频道文档的前一个频道文档。

Channels

DocumentMgr.getQutoedChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere)
获得实体文档对应的特定类型的频道集合
包括所有转发的频道、镜像的频道、实体频道和所有频道

Channels

DocumentMgr.getQutoedChannels(Document _currDocument, int _nDocModal, java.lang.String _sExtraChnlDocWhere, boolean _bIsIncludeTrashed)

Channels

ChannelMgr.getRecycleChannels(BaseChannel _oChannel, WCMFilter _chnlFilter)
获取符合一定条件的被删除的栏目

Documents

DocumentMgr.getRecycleDocuments(BaseChannel _currChnl, WCMFilter _filter)
取频道的废稿

Documents

UserDocumentMgr.getRecycleDocuments(WCMFilter _filter)
获取个人回收站里的文档

WebSites

ChannelMgr.getRecycleSites(WCMFilter _filter)

ChannelSyns

AutoTransmitMgr.getRelatedChannelSyns(Channel _currChannel, WCMFilter _filter)

Documents

DocumentMgr.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter)
相关文档的相关方法

Documents

DocumentMgr.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites)
获取与当前文档相关的文档集合(指定获取的方式:相关表/关键词/相关词等)

Documents

DocKeywordMgrImpl.getRelatedDocumentsByKeywords(Document _document, int _nMaxSize, java.lang.String _sSelectFields, int[] _pFilterStatusId, boolean _bMultiSite, java.util.ArrayList _arExistDocumentTitles)
根据标题排重 add by ly

Documents

IDocKeywordMgr.getRelatedDocumentsByKeywords(Document _document, int _nMaxSize, java.lang.String _sSelectFields, int[] _pFilterStatusId, boolean _bMultiSite, java.util.ArrayList _arExistDocumentTitles)
获取指定文档的相关文档

Relations

RelationMgr.getRelations(Document _currDocument)

Relations

RelationMgr.getRelations(Document _currDocument, WCMFilter _extraFilter)

Relations

RelationMgr.getRelations(WCMFilter _aWCMFilter)
根据条件获得相关文档

Replaces

ReplaceMgr.getReplaces(Channel _oChannel, WCMFilter _filter)
获取当前频道下的替换内容

DocReplys

DocReplyMgr.getReplys(Document _currDocument)
获取文档的所有回复

DocReplys

DocReplyMgr.getReplys(Document _currDocument, int _nReplyType)
获取当前文档某种类型的回复

Groups

SiteMemberMgr.getSiteGroups(WebSite _site, WCMFilter _filter)
获取站点中的用户组集合

Roles

SiteMemberMgr.getSiteRoles(WebSite _site, WCMFilter _fitler)

Users

SiteMemberMgr.getSiteUsers(WebSite _site, WCMFilter _filter)
获取站点中的用户集合

Channels

AutoTransmitMgr.getSynSrcChannels(Channel _currChannel)
获取给当前频道分发文档的频道集合

Channels

AutoTransmitMgr.getSynToChannels(Channel _currChannel)
获取当前频分发文档的目标频道集合

Documents

DocumentMgr.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter)
获得特定频道下已设置为置顶的所有文档

int

DocumentMgr.getTopPosition(Channel _currChannel, Document _currDocument)
得到频道下文档的置顶位置

WebSites

SiteMemberMgr.getUserSites(User _currUser, WCMFilter _filter)
获取当前用户所在站点集合

WebSites

SiteMemberMgr.getWebSites(int _objType, int _objId, java.lang.String _sOrder)
获取某个对象（用户、组织、角色）可以管理的站点

WebSites

ChannelMgr.getWebSites(WCMFilter _filter, boolean _bIncludeDel)
获取系统中的所有站点

Reports

DocumentImporter.importFromFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel)
从文件中导入文档
支持从zip,xml,html,htm文件导入

Reports

DocumentImporter.importFromFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel, boolean bImportbyName)

Reports

ChannelImporter.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl)

Reports

DocumentImporter.importFromFileByName(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel, boolean bImportbyName)

Reports

DocumentImporter.importFromTRSFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sDefineXmlForTRServer, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel)
从TRS文件中导入文档
支持从zip,xml,html,htm文件导入

boolean

SiteMemberMgr.isBelongToSite(CMSObj _operator, WebSite _site)
判断指定的对象是否属于指定的站点

boolean

SiteMemberMgr.isBelongToSite(Group _group, WebSite _site)
判断指定的用户组是否属于指定的站点

boolean

SiteMemberMgr.isBelongToSite(Role _role, WebSite _site)
判断指定的角色是否属于指定的站点

boolean

SiteMemberMgr.isBelongToSite(User _user, WebSite _site)
判断指定的用户是否属于指定的站点

boolean

DocumentMgr.isDocumentTopped(Document _currDocument, Channel _currChannel)
判断一个频道下的文档是否是处于置顶状态

boolean

SiteMemberMgr.isVisible(CMSObj _operator, WebSite _site)

boolean

SiteMemberMgr.isVisible(User _user, WebSite _site)

static WCMFilter

DocumentsGetHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)

WCMFilter

DatasWithChnlDocFilterHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)

static WCMFilter

DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)

WCMFilter

DatasWithChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)

static WCMFilter

DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)

WCMFilter

DatasWithChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)

static WCMFilter

DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle, int _nTrueChannelId)

Report

DocumentMgr.mirrorTo(Document _fromDocument, Channel _toChannel)
将实体文档镜像转发到另一个频道
草稿箱中的文档无法转发
目标频道为空无法转发

Reports

DocumentMgr.moveAllDocumentsToChannel(Channel _fromChannel, Channel _toChannel)
移动当前栏目下现有文档到指定的频道

void

DocumentMgr.moveDocumentInChannel(Document _fromDocument, Document _toDocument, Channel _currChannel)
在频道中移动文档的顺序
如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档

void

DocumentMgr.moveDocumentInChannel(Document _fromDocument, Document _toDocument, Channel _currChannel, int _nPosition)
在频道中移动文档的顺序
如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档

Reports

DocumentMgr.moveDocumentsToChannel(ViewDocuments _sViewDocuments, Channel _fromChannel, Channel _toChannel)

void

ChannelMgr.moveTo(Channel _fromChannel, BaseChannel _toSiteOrChannel, int _nMoveToType)

void

ChannelMgr.moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType)
将栏目移动到栏目，作为兄弟或者子栏目

void

ChannelMgr.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType)
将栏目移动到站点，作为兄弟或者子栏目

Report

DocumentMgr.moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel)
将文档从一个频道移动到另一个频道
支持引用和镜像的移动
如果是草稿箱中的，则不支持移动；也不支持移动到草稿箱 如果目标频道下已经存在，则无法移动

Report

DocumentMgr.moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel, java.lang.String _sIsPhoto)

void

InfoViewEmployLCListenerForChannel.notifyOnAddObj(BaseObj _objAdded)

void

ExtendedFieldLCListenerForDocBak.notifyOnAddObj(BaseObj _oObjAdded)

void

ChnlDocLCListenerForRecordNotEntity.notifyOnAddObj(BaseObj _oObjAdded)

void

ChnlDocLCListenerForPri.notifyOnAddObj(BaseObj _oObjAdded)

void

ChnlDocLCListener4ClassInfo.notifyOnAddObj(BaseObj _oObjAdded)

void

RightLCListenerForSynSiteMember.notifyOnAddObj(BaseObj _oObjAdded)

void

DocumentLCListenerForRelDocs.notifyOnAddObj(BaseObj _oObjAdded)

void

DocumentLCListenerForKeyword.notifyOnAddObj(BaseObj _oObjAdded)

void

DocBakLCListenerForApd.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

WebSiteLCListenerForSiteUser.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ApdHostLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ExtendedFieldLCListenerForDocBak.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

SiteMemberLCListner.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChnlDocLCListenerForRecordNotEntity.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

WebSiteLCListenerForAutoDocBak.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

DocumentLCListenerForExternalFile.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChannelLCListenerForDocument.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChnlDocLCListenerForPri.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

WebSiteLCListenerForContentLink.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChannelLCListenerForSpeical.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

DocumentLCListenerForDocBak.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChnlDocLCListener4ClassInfo.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChannelLCListenerForChannelSyn.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

RightLCListenerForSynSiteMember.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

DocumentLCListenerForRelDocs.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

DocumentLCListenerForKeyword.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChannelLCListenerForExtField.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

DocumentLCListenerForRelation.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

DocumentLCListenerForDocReply.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ContentExtFieldCListenerForDocProps.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ContentExtFieldLCListenerForDocFields.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ApdHostLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

ExtendedFieldLCListenerForDocBak.notifyOnModifyObj(BaseObj _oObjEdited, int _nEventType)

void

ChnlDocLCListenerForAutoDocBak.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

DocumentLCListenerForExternalFile.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

ChannelLCListenerForDocument.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

ChnlDocLCListenerForPri.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

DocumentLCListenerForAutoDocBak.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

RightLCListenerForSynSiteMember.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

DocumentLCListenerForRelDocs.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

DocumentLCListenerForKeyword.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

Report

DocumentMgr.quoteTo(Document _fromDocument, Channel _toChannel)
将实体文档引用转发到另一个频道
草稿箱中的文档无法转发
目标频道为空无法转发

Report

DocumentMgr.quoteTo(Document _fromDocument, Channel _toChannel, java.lang.String _sIsPhoto)

Document

DocBakMgr.recoverDocument(DocBak _aDocBak, Document _currDocument)
恢复当前文档的数据到某个(备份)版本

void

AutoDocBakMgr.removeConfig(WebSite _currSite)

void

DocKeywordMgrImpl.removeDocKeywords(Document _document)

void

IDocKeywordMgr.removeDocKeywords(Document _document)
删除指定文档的相关新闻记录

void

SiteMemberMgr.removeSiteGroup(WebSite _site, Group _group)
删除站点用户组
将指定的用户组从指定的站点删除

void

SiteMemberMgr.removeSiteMember(int _nSiteId, int _nObjType, int _nObjId)

void

SiteMemberMgr.removeSiteUser(WebSite _site, User _user)
删除站点用户
将指定的用户从指定的站点删除

void

DocumentMgr.removeToppedDocument(Channel _currChannel, Document _currDocument)
取消特定频道下某文档的置顶标志
该文档将成为普通文档
注意，不是删除文档！

void

ChannelMgr.restore(BaseChannel _oChannel)
恢复回收站中的站点/栏目

void

ChannelMgr.restore(BaseChannel _oChannel, boolean _bSystemNotifyRestore)

void

DocumentMgr.restore(ChnlDoc _oChnlDocDeleted)
恢复指定的ChnlDoc

void

DocumentMgr.restore(Document _delDocument, Channel _currChannel)
还原频道回收站中的一篇频道文档

void

DocumentMgr.restoreAll(User _currUser, BaseChannel _oSiteOrChannel)

AutoBakConfig

AutoDocBakMgr.save(AutoBakConfig _currConfig)

BaseChannel

ChannelMgr.save(BaseChannel _oChannel)
保存（新增、编辑）栏目或者站点

ChannelSyn

AutoTransmitMgr.save(ChannelSyn _currChnlSyn)

ContentExtField

ContentExtFieldMgr.save(CMSObj _host, ContentExtField _extfield, boolean _bDoWithChildren)

ContentLink

ContentLinkMgr.save(ContentLink _contentLink)
保存一个内容超链接

Document

DocumentMgr.save(Document _currDocument)
在频道下保存/修改一篇文档
文档的频道属性不能在此被修改，而应该通过移动操作进行修改
文档的假删除、恢复 都需要调用相关接口，而不该通过修改接口
修改文档状态时，需要同步修改ChnlDoc的状态

Replace

ReplaceMgr.save(Replace _aReplace)
保存指定的Replace对象

void

AppendixMgr.saveAppendixes(Document _currDocument, java.util.List _currAppendixList)
保存特定的附件列表，包括添加、删除或者更新其中的具体附件
从private方法变成public方法，要小心
注意：保存文档相关的附件时，需要删除已经不再属于该文档的附件
050321，OO调整时进行的

void

DocReplyMgr.saveDocReply(Document _currDocument, DocReply _docReply)
保存文档的一个回复

DocumentSyn

AutoTransmitMgr.saveDocumentSyn(DocumentSyn _currTransmittedDoc)

void

RelationMgr.saveRelations(Document _currDocument, java.util.List _currRelationList)
保存相关文档的信息，可能是添加或者修改时调用

void

DocumentMgr.setTopDocument(Channel _currChannel, Document _fromDocument, Document _toDocument, int _nPosition, CMyDateTime dtValid)

void

DocumentMgr.setTopDocument(Channel _currChannel, Document _currDocument, int _nToppedOrder, CMyDateTime _dtValidUntil)
将特定频道下的一篇文档设置为置顶
如果特定的位置已经存在文档，则需要将该位置及其后的所有置顶向后移动一位
如果最后一个置顶项目也有占用，则自动将置顶位置扩展一位！

void

DocumentMgr.setTopedDocument(Document _document, Channel _channel, int _nTopOrder, CMyDateTime _dtTopedValid)

void

DocKeywordMgrImpl.updateDocKeywords(Document _document, java.lang.String _sOldKeywords, java.lang.String _sNewKeywords)

void

IDocKeywordMgr.updateDocKeywords(Document _document, java.lang.String _sOldKeywords, java.lang.String _sNewKeywords)
更新指定文档的相关文档记录信息

抛出 WCMException 的 com.trs.components.wcm.content.domain 中的构造方法

SiteMemberIdsMan(WebSite _site, int _nMemberType)

com.trs.components.wcm.content.domain.auth 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.content.domain.auth 中的方法

IRightHost[]

WebSiteRightHostImpl.getChildren()

IRightHost[]

ChannelRightHostImpl.getChildren()

IRightHost

ChannelRightHostImpl.getParent()

IRightHost

DocumentRightHostImpl.getParent()

static boolean

DocumentAuthServer.hasFlowDocRight(User _currUser, Document _document, int _nRightIndex)

static boolean

DocumentAuthServer.hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Document _document, int _nRightIndex)
判断指定用户在指定频道中对于指定的文档是否具有指定的权限

static boolean

DocumentAuthServer.hasRight(User _loginUser, BaseChannel _oSiteOrChannel, Documents _documents, int _nRightIndex)

static boolean

DocumentAuthServer.hasRight(User _loginUser, ChnlDoc _chnlDoc, int _nRightIndex)

static boolean

DocumentAuthServer.isDefineRightOnDocument(Document _document)
判断当前文档是否自定义了权限

static boolean

DocumentAuthServer.isDefineRightOnDocument(int _nDocId)

static java.lang.String

DocumentAuthServer.makeLogicRightValue(User _loginUser, Channel _currChannel, Document _currDocument)
构造用户对于指定栏目的指定文档的权限值

void

WebSiteRightHostImpl.validateCanDoSetRight(User _user)

void

ChannelRightHostImpl.validateCanDoSetRight(User _user)

void

DocumentRightHostImpl.validateCanDoSetRight(User _user)

抛出 WCMException 的 com.trs.components.wcm.content.domain.auth 中的构造方法

ChannelRightHostImpl(int _nId)

DocumentRightHostImpl(int _nId)

WebSiteRightHostImpl(int _nId)

com.trs.components.wcm.content.domain.intelligence 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.content.domain.intelligence 中的方法

Reports

IntelMgrImpl.createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName)

Reports

IIntellMgr.createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName)
从指定站点指定样式中创建新的站点

Reports

IntelMgrImpl.createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName, java.lang.String _sSiteDesc)

Reports

IIntellMgr.createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName, java.lang.String _sNewSiteDesc)

java.lang.String[]

IntellResLocatorImpl.findSiteKinds(java.lang.String _sSrcPath)

java.lang.String[]

IIntellResLocator.findSiteKinds(java.lang.String _sSrcPath)
从指定的路径中获取站点的类型

java.lang.String[]

IntellResLocatorImpl.findSiteStylesOfKind(java.lang.String _sSrcPath, java.lang.String _sKindName)

java.lang.String[]

IIntellResLocator.findSiteStylesOfKind(java.lang.String _sSrcPath, java.lang.String _sKindName)
从指定路径中获取指定类型的样式

java.lang.String

IntelMgrImpl.getSiteDataFile(java.lang.String _sKind, java.lang.String _sStyle)

java.lang.String

IIntellMgr.getSiteDataFile(java.lang.String _sKind, java.lang.String _sStyle)
获取指定站点指定样式的数据文件

java.lang.String

IntelMgrImpl.getSiteDemoLink(java.lang.String _sKind, java.lang.String _sStyle)

java.lang.String

IIntellMgr.getSiteDemoLink(java.lang.String _sKind, java.lang.String _sStyle)
获取指定站点指定样式的演示地址

java.lang.String

IntelMgrImpl.getSiteIntroduceContent(java.lang.String _sKind, java.lang.String _sStyle)

java.lang.String

IIntellMgr.getSiteIntroduceContent(java.lang.String _sKind, java.lang.String _sStyle)
获取指定站点指定样式的介绍内容

java.lang.String

IIntellMgr.getSiteIntroduceImgFilePath(java.lang.String _sKind, java.lang.String _sStyle)
获取指定站点指定样式的介绍图片

java.lang.String

IntellResLocatorImpl.getSiteKindPath(java.lang.String _sSrcPath, java.lang.String _sKindName)

java.lang.String

IIntellResLocator.getSiteKindPath(java.lang.String _sSrcPath, java.lang.String _sKindName)
根据给定路径下的类型得到真实的路径

java.lang.String[]

IntelMgrImpl.getSiteKinds()

java.lang.String[]

IIntellMgr.getSiteKinds()
获取所有站点类型

java.lang.String

IntellResLocatorImpl.getSiteKindStylePath(java.lang.String _sSrcPath, java.lang.String _sKindName, java.lang.String _sStyle)

java.lang.String

IIntellResLocator.getSiteKindStylePath(java.lang.String _sSrcPath, java.lang.String _sKindName, java.lang.String _sStyle)
根据给定路径下的类型和样式得到真实的路径

java.lang.String[]

IntelMgrImpl.getSiteStyles(java.lang.String _sKindName)

java.lang.String[]

IIntellMgr.getSiteStyles(java.lang.String _sKindName)
获取指定类型的所有样式

com.trs.components.wcm.content.persistent 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.content.persistent 中的方法

boolean

WebSite.addPubStatus(int _nStatusId)
添加站点的可发布文档状态

boolean

WebSite.addPubStatus(Status _status)
添加站点的可发布文档状态

boolean

ChannelSyn.addStatus(int _statusId)

boolean

ChannelSyn.addStatus(Status _status)

BaseObj

Document.cloneToNewWCMObj()

BaseObj

Appendix.cloneToNewWCMObj()
由对象复制成一个新对象

static SiteMember

SiteMember.createNewInstance()
产生当前对象[SiteUser]的实例

static ChnlDoc

ChnlDoc.createNewInstance()
产生当前对象[ChnlDoc]的实例

static ContentLink

ContentLink.createNewInstance()
产生当前对象[ContentLink]的实例

static Replace

Replace.createNewInstance()
产生当前对象[Replace]的实例

static Document

DocBak.createNewInstance()
产生当前对象[DocBak]的实例

static Relation

Relation.createNewInstance()
产生当前对象[Relation]的实例

static DocumentSyn

DocumentSyn.createNewInstance()
产生当前对象[TransmittedDoc]的实例

static ChannelContentLink

ChannelContentLink.createNewInstance()
产生当前对象[ChannelContentLink]的实例

static AutoBakConfig

AutoBakConfig.createNewInstance()
产生当前对象[AutoBakConfig]的实例

static Document

Document.createNewInstance()
产生当前对象[Document]的实例

static ChannelSyn

ChannelSyn.createNewInstance()
产生当前对象[ChannelSyn]的实例

static Channel

Channel.createNewInstance()
产生当前对象[Channel]的实例

static DocReply

DocReply.createNewInstance()
产生当前对象[DocReply]的实例

static Appendix

Appendix.createNewInstance()
产生当前对象[Appendix]的实例

static WebSite

WebSite.createNewInstance()
产生当前对象[WebSite]的实例

static DocReplys

DocReplys.createNewInstance(User _currUser)
产生一个当前集合对象[DocReplys]的实例

static DocBaks

DocBaks.createNewInstance(User _currUser)
产生一个当前集合对象[DocBaks]的实例

static Appendixes

Appendixes.createNewInstance(User _currUser)
产生一个当前集合对象[Appendixes]的实例

static SiteMembers

SiteMembers.createNewInstance(User _currUser)
产生一个当前集合对象[SiteUsers]的实例

static WebSites

WebSites.createNewInstance(User _currUser)
产生当前集合对象[WebSites]的实例

static ChnlDocs

ChnlDocs.createNewInstance(User _currUser)
产生一个当前集合对象[ChnlDocs]的实例

static Channels

Channels.createNewInstance(User _currUser)
产生一个当前集合对象[Channels]的实例

int

Document.delete()

int

DocBak.delete(User _currUser)
重载父类delete函数 删除该版本的备份，同时需要删除该版本在相关附件上的引用关系

int

Document.delete(User _currUser)

int

Channel.delete(User _currUser)

int

Appendix.delete(User _currUser)

static Appendixes

Appendixes.findAppendixesByObj(BaseObj _currObj)
获得文档所属附件集合
该接口应该是获得对象所属附件集合，由于Appendix对象目前只和Document对象耦合，所以先暂时这样使用
以后扩展应该也比较方便，增加一个对象类型ID即可

static ChnlDoc

ChnlDoc.findByDocAndChnl(Document _currDocument, Channel _currChannel)
根据文档和频道，找到对应的ChnlDoc

static ChnlDoc

ChnlDoc.findByDocAndChnl(int _nDocumentId, int _nChannelId)

static ChnlDoc

ChnlDoc.findByDocument(Document _currDocument)
根据文档，找到对应的ChnlDoc，只找实体文档本身对应的频道

static SiteMember

SiteMember.findById(int _nId)
提取指定ID的对象

static ChnlDoc

ChnlDoc.findById(int _nId)
提取指定ID的对象

static ContentLink

ContentLink.findById(int _nId)
提取指定ID的对象

static Replace

Replace.findById(int _nId)
提取指定ID的对象

static Document

DocBak.findById(int _nId)
提取指定ID的对象

static Relation

Relation.findById(int _nId)
提取指定ID的对象

static DocumentSyn

DocumentSyn.findById(int _nId)
提取指定ID的对象

static ChannelContentLink

ChannelContentLink.findById(int _nId)
提取指定ID的对象

static ContentExtField

ContentExtField.findById(int _nId)
提取指定ID的对象

static AutoBakConfig

AutoBakConfig.findById(int _nId)
提取指定ID的对象

static Document

Document.findById(int _nId)
提取指定ID的对象

static ChannelSyn

ChannelSyn.findById(int _nId)
提取指定ID的对象

static Channel

Channel.findById(int _nId)
提取指定ID的对象

static DocReply

DocReply.findById(int _nId)
提取指定ID的对象

static Appendix

Appendix.findById(int _nId)
提取指定ID的对象

static WebSite

WebSite.findById(int _nId)
提取指定ID的对象

static ContentLinkType

ContentLinkType.findById(int _nId)
提取指定ID的对象

static Document

Document.findById(int _nId, java.lang.String _sSelectFields)

static Document

Document.findById(int _nId, java.lang.String _sSelectFields, java.lang.String _sTableName)

static DocReplys

DocReplys.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static DocBaks

DocBaks.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Appendixes

Appendixes.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static SiteMembers

SiteMembers.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static WebSites

WebSites.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static ChnlDocs

ChnlDocs.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Channels

Channels.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static SiteMember

SiteMember.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ChnlDoc

ChnlDoc.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ContentLink

ContentLink.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Replace

Replace.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Document

DocBak.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Relation

Relation.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static DocumentSyn

DocumentSyn.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ChannelContentLink

ChannelContentLink.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ContentExtField

ContentExtField.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static AutoBakConfig

AutoBakConfig.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Document

Document.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ChannelSyn

ChannelSyn.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Channel

Channel.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static DocReply

DocReply.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Appendix

Appendix.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static WebSite

WebSite.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static ContentLinkType

ContentLinkType.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

Channel

IChannelNameMgr.findByName(int p_nSiteId, java.lang.String p_sName)
提取指定站点、指定名称的频道

Channel

ChannelNameMgr.findByName(int p_nSiteId, java.lang.String p_sName)
提取指定站点、指定名称的频道

static Relations

Relations.findRelationsByObj(BaseObj _currObj)
获得文档所属关联文档集合
该接口应该是获得对象所属关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用
以后扩展应该也比较方便，增加一个对象类型ID即可

java.util.List

BaseChannel.getAllChildren(User _currUser)

org.aton.cache.LRUCacheContainer

ChannelNameMgr.getCache()

Statuses

AutoBakConfig.getCanSavedDocStatus(User _currUser)
获取可以进行自动保存的文档状态

Channel

ChnlDoc.getChannel()
取文档所属频道对象

Channel

Replace.getChannel()
获取所属频道

Channel

ChannelContentLink.getChannel()
获取所属栏目

Channel

Document.getChannel()
取文档所属频道对象

java.lang.String

Document.getChannelName()
获取所属栏目

Channel

IChildrenMgr.getChildAt(BaseChannel _parent, int _nIndex)

Channel

ChildrenCacheMgr.getChildAt(BaseChannel _parent, int _nIndex)

Channel

BaseChannel.getChildAt(int _nIndex)

java.util.List

BaseChannel.getChildren(User _currUser)

java.util.List

BaseChannel.getChildren(User _currUser, int _nType)
获取当前对象某种类型的子频道

java.util.List

BaseChannel.getChildren(User _currUser, int[] _nArrayTypes)
获取当前对象某几种类型的子频道

Channels

Channels.getChildrenOf(int _parentId)
取当前集合ParentId为指定值的子集

int

BaseChannel.getChildrenSize(User _currUser)

int

IChildrenMgr.getChildrenSize(User _currUser, BaseChannel _parent)
获取当前站点/频道的子频道数目

int

ChildrenCacheMgr.getChildrenSize(User _currUser, BaseChannel _parent)

int

ContentExtField.getDefaultValueAsInt(int _nDefault)
取整型默认值

Document

ChnlDoc.getDocument()
取文档所属频道对象

Document

DocBak.getDocument()

java.lang.String

ContentExtField.getExtFieldProperty(java.lang.String _sName)

FileType

Appendix.getFileType()
获取附件文档类型对象

abstract  BaseChannel

BaseChannel.getHost()
得到当前频道的父频道，在Channel和Site中分别定义

CMSObj

ContentExtField.getHost()

BaseChannel

Channel.getHost()

java.lang.String

Document.getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute)
文档HTML内容过滤处理，用于文档HTML正文的显示处理
处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于：
[1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?

java.lang.String

Document.getHtmlContentWithImgFilter(java.lang.String _sImgSrcPre, boolean _bRemoveExtraAttribute, boolean _bFromPubHTMLContent)

java.util.List

Document.getHTMLFiles()
获取当前文档所包含的HTML文件列表

java.util.List

Document.getHTMLWCMFiles()

java.util.List

Document.getHTMLWCMFiles(boolean _bFromPubHTMLContent)

DocKind

Document.getKind()
获取文档分类对象

java.lang.String

ContentLink.getLinkTypeName()

java.lang.String

WebSite.getLocalFtpPath()
获取应用服务器上站点的FTP路径

java.lang.String

WebSite.getLocalHttpPath()
获取应用服务器上站点的HTTP路径

java.lang.String

WebSite.getLocalPath()
获取应用服务器上存放站点页面的绝对物理路径

Channel

Channel.getParent()
获取父频道对象

WebSite

WebSite.getParent()

Statuses

WebSite.getPubStatuses(User _currUser)
取所有允许发布的文档状态对象集合

java.util.Map

ReplaceCacheMgr.getRepalceCache()

Replaces

Channel.getReplaces(User _currUser)
获取频道上所有的替换内容对象

Statuses

WebSite.getSaveStatuses(User _currUser)
获取站点上允许发布的文档状态

Security

Document.getSecurity()
获取安全级别

int

BaseChannel.getSiblingIndex()
获取当前频道或站点的位置

int

IChildrenMgr.getSiblingIndex(BaseChannel _channel)
获取指定频道/站点在其同级目录中的位置

int

ChildrenCacheMgr.getSiblingIndex(BaseChannel _channel)

WebSite

ContentLink.getSite()
获取所属站点对象

abstract  WebSite

BaseChannel.getSite()

WebSite

AutoBakConfig.getSite()
获取站点对象

WebSite

Channel.getSite()
频道所属的站点对象

Source

Document.getSource()
获取文档来源

Channel

ChannelSyn.getSrcChannel()
获取源频道

Status

ChnlDoc.getStatus()
提取ChnlDoc的状态

Status

Document.getStatus()
获取文档状态

Statuses

ChannelSyn.getStatuses(User _currUser)

java.lang.String

ChnlDoc.getStatusName()
获取状态名称

java.lang.String

Document.getStatusName()
获取状态名称

Channels

Channels.getSubChannelsByParentId(int _parentId)
取当前集合ParentId为指定值的子集

Channel

ChannelSyn.getToChannel()
获取目标频道

DataType

ContentExtField.getType()
获取扩展字段类型对象

java.lang.String

ContentExtField.getTypeDesc()
获取类型的描述

boolean

ChannelNameMgr.init()

boolean

ReplaceCacheMgr.init()

boolean

ChildrenCacheMgr.init()

void

SiteMember.insert(User _currUser)
将对象数据写入数据库

void

DocBak.insert(User _currUser)

void

Relation.insert(User _currUser)

void

ContentExtField.insert(User _currUser)
将对象数据写入数据库

void

DocReply.insert(User _currUser)
添加记录到数据库 为了设置产生时间特重载

void

HitsCount.insert(User _currUser)
将对象数据写入数据库

void

Appendix.insert(User _currUser)

void

ContentLinkType.insert(User _currUser)
将对象数据写入数据库

void

Documents.insertOtherTable(User _currUser, java.lang.String _sTableName)

void

Document.insertOtherTable(User _currUser, java.lang.String _sTableName)

boolean

SiteMember.isValid()
检验对象数据有效性

boolean

ChnlDoc.isValid()
检验对象数据有效性

boolean

ContentLink.isValid()
效验数据的有效性

boolean

Replace.isValid()
效验数据的有效性

boolean

Relation.isValid()
检查数据的有效性

boolean

XDocument.isValid()

boolean

DocumentSyn.isValid()

boolean

ChannelContentLink.isValid()

boolean

ContentExtField.isValid()
检验对象数据有效性

boolean

AutoBakConfig.isValid()

boolean

Document.isValid()
检查对象数据的有效性

boolean

ChannelSyn.isValid()
检验对象数据有效性

boolean

Channel.isValid()
对象的有效性校验

boolean

DocReply.isValid()
检查对象数据的有效性

boolean

HitsCount.isValid()
检验对象数据有效性

boolean

Appendix.isValid()
检查对象数据的有效性

boolean

WebSite.isValid()

boolean

ContentLinkType.isValid()
检验对象数据有效性

static boolean

ChannelSyn.isValid(int _nSrcChannelId, int _nDstChannelId)
校验当前分发是否有效

java.util.List

IChildrenMgr.listChildren(User _currUser, BaseChannel _parent, int _nType)
获取子频道列表

java.util.List

ChildrenCacheMgr.listChildren(User _currUser, BaseChannel _parent, int _nType)

java.util.List

IChildrenMgr.listChildren(User _currUser, BaseChannel _parent, int[] _arrayTypes)
获取子频道列表

java.util.List

ChildrenCacheMgr.listChildren(User _currUser, BaseChannel _parent, int[] _arrayNeedType)

boolean

ChannelSubstanceImplBase.loadById(int _nId)

boolean

WebSiteSubstanceImplBase.loadById(int _nId)

boolean

DocumentSubstanceImplBase.loadById(int _nId)

boolean

Document.logicalDelete(User _currUser)
逻辑删除

boolean

Document.logicalUndelete(User _currUser)
恢复文档

void

ChannelNameMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

ReplaceCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

ChildrenCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)

void

ChannelNameMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ReplaceCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChildrenCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

ChannelNameMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

ReplaceCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

ChildrenCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

XDocuments.open(java.lang.String _sTableName, int _nDocId, WCMFilter _extraFilter, java.lang.String _sIdFieldName)

static DocReplys

DocReplys.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[DocReplys]

static Documents

Documents.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Documents]

static ChannelContentLinks

ChannelContentLinks.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ChannelContentLinks]

static ChannelSyns

ChannelSyns.openWCMObjs(User _currUser, WCMFilter _filter)
Created: 2004-12-12 17:12:53 Last Modified: 2004-12-12/2004-12-12 Description:获取频道分发设置集合

static DocBaks

DocBaks.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[DocBaks]

static Appendixes

Appendixes.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Appendixes]

static Relations

Relations.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Relations]

static ContentLinks

ContentLinks.openWCMObjs(User _currUser, WCMFilter _filter)
Created: 2004-12-12 17:19:37 Last Modified: 2004-12-12/2004-12-12 Description: 获取内容超链接对象集合

static DocumentSyns

DocumentSyns.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[TransmittedDocs]

static Replaces

Replaces.openWCMObjs(User _currUser, WCMFilter _fitler)
Created: 2004-12-12 17:23:52 Last Modified: 2004-12-12/2004-12-12 Description:获取内容替换对象集合

static SiteMembers

SiteMembers.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[SiteUsers]

static ContentExtFields

ContentExtFields.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ContentExtFields]

static AutoBakConfigs

AutoBakConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[AutoBakConfigs]

static WebSites

WebSites.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[WebSites]

static ChnlDocs

ChnlDocs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ChnlDocs]

static ContentLinkTypes

ContentLinkTypes.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[ContentLinkTypes]

static Channels

Channels.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Channels]

boolean

ChannelNameMgr.reinit()

boolean

ReplaceCacheMgr.reinit()

boolean

ChildrenCacheMgr.reinit()

static java.lang.String

Replace.replace(int _nChannelId, java.lang.String _sName)
替换指定的内容

boolean

BaseChannel.restore(boolean _bSystemNotifyRestore)
恢复站点/频道到正常状态(STATUS_NORM)

boolean

Document.setAbstract(java.lang.String _abstract)
设置摘要

boolean

Appendix.setAlt(java.lang.String _alt)
设置附件显示的ALT

boolean

Appendix.setApdProperty(int _nProperty)
设置附件的属性

boolean

Document.setAttachPic(boolean _bAttachPic)

boolean

ContentExtField.setAttribute(java.lang.String _attribute)
设置扩展字段的扩展属性

boolean

Appendix.setAttribute(java.lang.String _attribute)
设置附件的属性

boolean

Document.setAuditor(java.lang.String _auditorName)
设置审稿者(可能有多个)

boolean

Document.setAuditor(User _auditor)
设置审稿者(可能有多个)

boolean

Document.setAuthor(java.lang.String _authorName)
设置作者

boolean

Appendix.setAuthor(java.lang.String _author)
设置附件的作者

boolean

DocBak.setBakUser(java.lang.String _bakUserName)
设置备份用户

boolean

DocBak.setBakUser(User _bakUser)
设置备份用户

boolean

Channel.setCanPub(boolean _bCanPub)
设置是否允许发布

boolean

AutoBakConfig.setCanSavedDocStatus(java.lang.String _sStatusIds)
设置可以自动保存的文档状态

boolean

Document.setChannel(Channel _channel)
设置文档所属频道

boolean

Document.setChannel(int _channelId)
设置文档所属频道

boolean

ChnlDoc.setChannelId(int _nChannelId)
设置属性：ChannelId

boolean

DocumentSyn.setChannelId(int _nChannelId)

boolean

Replace.setChnlId(int _chnlid)
设置所属频道

boolean

ChannelContentLink.setChnlId(int _nChannelid)
设置所属栏目

boolean

Channel.setChnlProperty(int _nProperty)
设置频道属性

boolean

Channel.setClickPreview(boolean _bClickPreview)
设置点击文档时是否直接预览页面

boolean

Channel.setCluster(boolean _bCluster)

boolean

Channel.setContainsChildren(boolean _bContainsChildren)

boolean

Replace.setContent(java.lang.String _content)
设置替换内容

boolean

Document.setContent(java.lang.String _content)
设置文档的文本正文

boolean

DocReply.setContent(java.lang.String _content)
设置回复内容

boolean

WebSite.setDataPath(java.lang.String _dataPath)
设置数据存放的本地路径（相对路径）

boolean

ChnlDoc.setDeleted(boolean _bDeleted)
将文档设为已删除状态 说明：对于正常状态下的文档，setDeleted( true )将ChnlDoc改为已删除（逻辑删除）； 对于已删除的文档，setDeleted( false )将文档恢复为正常状态

boolean

BaseChannel.setDeleted(boolean _bSystemNotifyDelete)
设置站点/频道为已删除状态

boolean

Document.setDeleted(boolean _bDeleted)
将文档设为已删除状态 说明：对于正常状态下的文档，setDeleted( true )将文档改为已删除（逻辑删除）； 对于已删除的文档，setDeleted( false )将文档恢复为正常状态

boolean

ContentExtField.setDesc(java.lang.String _sLogicFieldDesc)
设置属性：LogicFieldDesc

boolean

Channel.setDesc(java.lang.String _desc)
设置频道描述

boolean

DocReply.setDesc(java.lang.String _desc)
设置描述

boolean

Appendix.setDesc(java.lang.String _desc)
设置附件描述

boolean

WebSite.setDesc(java.lang.String _desc)
设置站点的描述

boolean

WebSite.setDetailExt(java.lang.String _sExt)
设置细览页面的扩展名

boolean

Channel.setDetailFile(java.lang.String _sFile)
设置频道细览文件名

boolean

ChannelSyn.setDocEndTime(CMyDateTime _endTime)

boolean

DocBak.setDocId(Document _doc)
设置备份的文档

boolean

ChnlDoc.setDocId(int _nDocId)
设置属性：DocId

boolean

DocBak.setDocId(int _docId)
设置备份文档的ID

boolean

Relation.setDocId(int _nDocId)
设置相关文档对象所属文档的ID

boolean

DocReply.setDocId(int _docId)
设置回复所属的文档ID

boolean

Appendix.setDocId(int _docId)
设置附件所属文档编号

boolean

ChnlDoc.setDocOrder(int _nDocOrder)
设置属性：DocOrder

boolean

ChnlDoc.setDocOrderPri(int _nDocOrderPri)
设置文档的置顶顺序，不判断是否大于系统允许最大的有效范围

void

Document.setDocPro(int _nIndex, boolean _bValue)

boolean

ChnlDoc.setDocPubTime(CMyDateTime _dtDocPubTime)
设置属性：DocPubTime

boolean

ChnlDoc.setDocPubURL(java.lang.String _sDocPubURL)
设置属性：DocPubURL

boolean

ChannelSyn.setDocStartTime(CMyDateTime _startTime)
属性设置：文档执行时间

boolean

ChnlDoc.setDocTopPriOrder(int _nOrder)
设置文档的置顶位置.

boolean

ChnlDoc.setDocument(Document _document, boolean _bOnlyCache)

boolean

DocumentSyn.setDocumentId(int _nDocumentId)

boolean

Channel.setDoDeptFilter(boolean _bIsDoDeptFilter)
栏目文档列表是否做所属部门的过滤

boolean

Channel.setEditFile(java.lang.String _sFile)
设置编辑文件名

boolean

Document.setEditor(java.lang.String _editorName)
设置修改者

boolean

Appendix.setEditor(java.lang.String _editor)
设置附件的修改人

boolean

Document.setEditor(User _editor)
设置修改者

boolean

ChannelSyn.setEndTime(CMyDateTime _endTime)

boolean

ContentExtField.setExtFieldProperty(java.lang.String _sName, java.lang.String _attribute)

boolean

Appendix.setFile(java.lang.String _file)
设置附件文件名

boolean

Appendix.setFileExt(java.lang.String _fileExt)
设置附件的源文件名后缀名

boolean

Document.setFlag(int _flag)
设置文档标志 目前系统只支持一种风格（对外发布的文档），其余风格的文档可在二次开发中定义

boolean

Appendix.setFlag(int _flag)
设置附件类型

boolean

Document.setFromVersion(int _nFromVersion)
设置文档是从哪个版本恢复回来的

boolean

WebSite.setFtpFolder(java.lang.String _ftpFolder)
设置ftp目录

boolean

WebSite.setFtpPassword(java.lang.String _password)
设置ftp用户密码

boolean

WebSite.setFtpServer(java.lang.String _ftpServer)
设置站点对应的ftp服务器地址

boolean

WebSite.setFtpUpload(boolean _isUpload)
设置站点是否需要上传文件

boolean

WebSite.setFtpUser(java.lang.String _ftpUser)
设置站点对应的ftp服务器用户

boolean

Document.setHitsCount(int _hitsCount)
设置文档的点击数

boolean

Document.setHtmlContent(java.lang.String _sHtmlContent)

boolean

Channel.setInheritDetail(boolean _bInheritDetail)
设置是否继承父频道的细览模板

boolean

Channel.setInheritExtend(boolean _bInheritExtend)
设置是否继承父系的扩展字段

boolean

Channel.setInheritOutline(boolean _bInheritOutline)
设置是否继承父频道的概览模板

boolean

Channel.setInputFile(java.lang.String _sFile)
设置输入文件名

boolean

ChnlDoc.setInvalidTime(CMyDateTime _dtInvalidTime)
设置文档置顶的有效时间（截止时间）

boolean

Document.setKeywords(java.lang.String _keywords)
设置关键词

boolean

Document.setKind(DocKind _docKind)
设置文档分类

boolean

Document.setKind(int _kindId)
设置文档分类

boolean

ContentLink.setLinkTitle(java.lang.String _linkTitle)
设置链接中的标题

boolean

ChannelContentLink.setLinkTitle(java.lang.String _linkTitle)
设置链接中的标题

boolean

ContentLink.setLinkType(int _nType)

boolean

ContentLink.setLinkUrl(java.lang.String _linkUrl)
获取链接

boolean

ChannelContentLink.setLinkUrl(java.lang.String _linkUrl)
获取链接

boolean

Channel.setLinkUrl(java.lang.String _sUrl)
Sets the link url of this folder.

boolean

WebSite.setMainFileExt(java.lang.String _sExt)
设置主页面的扩展名

boolean

WebSite.setMainFileName(java.lang.String _sName)
设置主页面的文件名

boolean

Channel.setMetaSynFields(java.lang.String _metaSynFieldValue)

boolean

ChnlDoc.setModal(int _nModal)
设置ChnlDoc的类型

boolean

ContentLink.setName(java.lang.String _name)
设置名称

boolean

Replace.setName(java.lang.String _name)
设置替换名称

abstract  boolean

BaseChannel.setName(java.lang.String _sName)
设置对象的名称

boolean

ChannelContentLink.setName(java.lang.String _name)
设置名称

boolean

ContentExtField.setName(java.lang.String _sName)
设置扩展字段名称

boolean

Channel.setName(java.lang.String _name)
设置频道的名称 名称要求：同一级（即相同父频道）的频道，名称不重复 处理：由函数isValid()检查，区分大小写

boolean

WebSite.setName(java.lang.String _name)
设置站点名称

void

Appendix.setNextId()

boolean

SiteMember.setObjId(int _nObjId)

boolean

ContentExtField.setObjId(int _nObjId)
设置属性：ObjId

boolean

HitsCount.setObjId(int _nObjId)
设置属性：ObjId

boolean

SiteMember.setObjType(int _nObjType)

boolean

ContentExtField.setObjType(int _nObjType)
设置属性：ObjType

boolean

HitsCount.setObjType(int _nObjType)
设置属性：ObjType

boolean

Channel.setOnlyManager(boolean _bOnlyManager)
设置是否只作为管理节点

boolean

Channel.setOnlySearch(boolean _bOnlySearch)
设置是否只使用检索条件

boolean

ChnlDoc.setOperTime()
设置操作时间

boolean

BaseChannel.setOperTime()
记录站点/频道删除(恢复)操作的执行时间

boolean

AutoBakConfig.setOperType(java.lang.String _sOperTypes)
设置可以触发自动保存的操作类型

boolean

ChnlDoc.setOperUser(java.lang.String _sUserName)
设置删除操作的用户名

boolean

BaseChannel.setOperUser(java.lang.String _sUserName)
记录站点/频道删除(恢复)的操作者

boolean

ChnlDoc.setOperUser(User _currUser)
设置删除操作的用户

boolean

BaseChannel.setOperUser(User _opUser)
记录站点/频道删除(恢复)的操作者

boolean

ChannelContentLink.setOrder(int _order)
设置排序

boolean

Channel.setOrder(int _order)
设置频道排序序号

boolean

WebSite.setOrder(int _nOrder)
设置站点的排序序号

boolean

Channel.setOrderBy(java.lang.String _sOrderBy)
设置频道默认的排序方式

boolean

WebSite.setOrderBy(java.lang.String _sOrderBy)
设置站点的默认的排序方式 说明：目前没有体现

boolean

Document.setOtherTableName(java.lang.String _sOtherTableName)

boolean

WebSite.setOutlineExt(java.lang.String _sExt)
设置概览页面的扩展名

boolean

Channel.setOutlineFields(java.lang.String _sOutlineFields)
设置取该在频道概览页面需要显示的字段列表，以逗号分隔

boolean

Channel.setOutlineFile(java.lang.String _sFile)
设置频道概览文件名

boolean

WebSite.setOutlineName(java.lang.String _sName)
设置概览页面的文件名

boolean

Document.setOutUpId(int _outUpId)
设置外部上传ID

boolean

Channel.setParent(BaseChannel _parent)
Sets the parent of this channel.

abstract  boolean

BaseChannel.setParent(int _nParentId)

boolean

Channel.setParent(int _parentId)
设置父频道

boolean

WebSite.setParent(int _parentId)

boolean

WebSite.setParent(WebSite _parent)

boolean

Document.setPeople(java.lang.String _people)
设置人物

boolean

Document.setPlace(java.lang.String _place)
设置地点

boolean

DocBak.setProperty(java.lang.String _sName, java.lang.Object _oValue)

boolean

XDocument.setProperty(java.lang.String _sName, java.lang.Object _oValue)

boolean

Appendix.setPropertyWithString(java.lang.String name, java.lang.String value)

boolean

Document.setPubHtmlContent(java.lang.String _htmlContent)
设置文档的Html文本

boolean

WebSite.setPubStatus(java.lang.String _statusIds)
设置站点的可发布文档状态

boolean

Document.setPubTime(CMyDateTime _pubTime)
设置发布时间

boolean

Document.setPubURL(java.lang.String _pubUrl)
设置文档发布后的地址

boolean

Channel.setQuery(java.lang.String _query)
设置频道的查询条件

boolean

Document.setRandomSerial(java.lang.String randomSerial)

boolean

Appendix.setRelatedColumn(java.lang.String _relatedColumn)

boolean

Document.setRelateWords(java.lang.String _relateWords)
设置相关词（用于相关文档搜索）

boolean

Relation.setRelDocId(int _nRelDocId)
设置相关文档的ID

boolean

Document.setReleaseTime(CMyDateTime _releaseTime)
设置撰写时间

boolean

Document.setRightDefined(boolean _bSysDefined)
设置是否单独定义了用户的权限属性

boolean

Document.setSecurity(int _securityId)
设置安全级别

boolean

Document.setSecurity(Security _security)
设置安全级别

void

Appendix.setSerialNo(int _nNextSerialNo)

boolean

Channel.setSite(int _nSiteId)
设置所属站点：仅添加频道时可用，不允许修改该属性

boolean

Channel.setSite(WebSite _website)
设置所属站点：仅添加频道时可用，不允许修改该属性

boolean

SiteMember.setSiteId(int _nSiteId)
设置属性：SiteId

boolean

ChnlDoc.setSiteId(int _nSiteId)
设置属性：SiteId

boolean

ContentLink.setSiteId(int _siteId)
设置所属站点

boolean

ChannelContentLink.setSiteId(int _nSiteid)
设置所属站点

boolean

AutoBakConfig.setSiteId(int _nSiteId)
设置站点ID

boolean

WebSite.setSiteProp(int _index, boolean _value)
设置站点指定索引的属性

boolean

Document.setSource(int _sourceId)
设置文档来源

boolean

Document.setSource(Source _source)
设置文档来源

boolean

ChannelSyn.setSrcChannelId(int _nSrcChannelId)
设置属性：SrcChannelId

boolean

Appendix.setSrcFile(java.lang.String _srcFile)
设置附件的源文件名

boolean

ChannelSyn.setStartTime(CMyDateTime _startTime)
属性设置：开始执行时间

boolean

BaseChannel.setStatus(int _nStatus)
设置站点/频道的状态值(STATUS_NORM等)

boolean

Document.setStatus(int _statusId)
设置文档状态

boolean

Channel.setStatus(int _status)
设置频道状态（Channel.STATUS_NORM等）

boolean

Document.setStatus(Status _status)
设置文档状态

boolean

Document.setStatus(Status _status, boolean _bDeleted)
设置文档状态

boolean

ChannelSyn.setStatus(java.lang.String _statusIds)

boolean

ChnlDoc.setStatusId(int _nStatusId)
设置属性：StatusId

boolean

Document.setSubTitle(java.lang.String _title)
设置文档副标题

boolean

Channel.setSureFormFile(java.lang.String _sSureFormFileName)
设置书生表单文件名称

boolean

ChannelContentLink.setSysContentLinkId(int _nSysId)

boolean

Channel.setTable(java.lang.String _table)
设置存储频道中文档的数据表的名称

boolean

ContentExtField.setTableName(java.lang.String _tableName)
设置扩展字段所属数据表名称

boolean

Appendix.setTime(CMyDateTime _time)
设置附件的时间

boolean

Document.setTitle(java.lang.String _title)
设置文档标题

boolean

DocReply.setTitle(java.lang.String _title)
设置回复标题

boolean

Document.setTitleColor(java.lang.String _titleColor)
设置标题颜色

boolean

ChannelSyn.setToChannelId(int _nToChannelId)
设置属性：ToChannelId

boolean

Channel.setToChnlUser(boolean _bToChnlUser)
判断文档流转时是否考虑频道的权限

void

ChannelSyn.setTransmitType(int _nTransmitType)

boolean

Document.setType(int _type)
设置文档类型

boolean

Channel.setType(int _type)
设置频道类型(Channel.TYPE_NORM等)

boolean

DocReply.setType(int _type)

boolean

WebSite.setType(int siteType)

boolean

ContentExtField.setType(java.lang.String _typeName, int _maxLength)

boolean

ContentExtField.setType(java.lang.String _typeName, int _maxLength, boolean _bNullable, java.lang.String _sDefaultValue)
设置扩展字段数据类型

boolean

ContentExtField.setType(java.lang.String _typeName, int _maxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)

boolean

ContentLinkType.setTypeDesc(java.lang.String _sTypeDesc)
设置属性：TYPEDESC

boolean

ContentLinkType.setTypeName(java.lang.String _sTypeName)
设置属性：TYPENAME

boolean

Appendix.setUsedByVersion(int _nVersion, boolean _bUsed)
设置指定的版本是否使用此附件

boolean

ChannelContentLink.setUsedInChildren(boolean _bUsedInChildren)

boolean

Appendix.setUsedVersions(long _lUsedVersions)
设置使用该附件的文档的版本号

boolean

Document.setValidTime(CMyDateTime _valid)
设置文档的有效时间

boolean

Document.setVersion(int _nVersion)
设置文档的版本号

boolean

WebSite.setWebHttp(java.lang.String _webHttp)
设置Web站点Http地址

boolean

ChannelSyn.setWhereSql(java.lang.String _sWhereSql)
设置属性：WhereSql

void

ChannelXmlConverter.setWithTemp(boolean _bWithTemp, java.lang.String _sTempApdPath)
设置是否导出模板
因为导出模板的同时,会导出模板所使用的文件(JS,CSS等)
因此,需要指定文件的导出位置
默认为不导出

void

DocBak.update(User _user)

void

Channel.update(User _currUser)

void

ChannelLoopValidator.validEditModeChannel(Channel _currChannel)

void

ChannelLoopValidator.validHasExistsChannel(Channel _channel)

void

Channel.validLoop()

抛出 WCMException 的 com.trs.components.wcm.content.persistent 中的构造方法

ChannelSubstanceImplBase(int _nId)

DocumentSubstanceImplBase(int _nId)

WebSiteSubstanceImplBase(int _nId)

com.trs.components.wcm.content.trsserver 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.content.trsserver 中的方法

void

TRSSearcher.buildSearcher()
构造当前TRS检索器的检索环境

static TRSSearcher

TRSSearcherFactory.buildSearcher(RequestHelper _currRequestHelper, User _loginUser)
构造TRS检索条件Searcher

java.lang.String

ChannelsWithRightMaker.getChannelIdsWithRight()

java.lang.String

ChannelsWithRightMaker.getChannelIdsWithRight(java.lang.String _sChannelIds)

com.eprobiti.trs.TRSConnection

KMTRSServer.getConnection()
返回默认的TRSWCM数据库链接

com.eprobiti.trs.TRSConnection

OuterKMTRSServer.getConnection()
返回默认的TRSWCM数据库链接

java.lang.Object

DatasFromTRSServer.getDatasFromTRSServer(int _nCurrPage, int _nPageSize)

java.lang.Object

DatasFromTRSServer.getDatasFromTRSServer(java.lang.String _sWhere, int _nCurrPage, int _nPageSize)

com.eprobiti.trs.TRSConnection

DatasFromTRSServer.getValidConnection(java.lang.String host, java.lang.String port, java.lang.String username, java.lang.String password)

static void

DatasFromTRSServer.main(java.lang.String[] args)

Documents

DocsFromTRSServer.openDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize)
通过TRS构造一个Document集合

Documents

DocsFromTRSServer.openDocs(User _currUser, WCMFilter _filter, int _nCurrPage, int _nPageSize)

Documents

DocsFromTRSServer.openDocsByLocal(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize)
通过TRS构造一个Document集合

java.lang.Object

DocsFromTRSServer.openViewDocs(User _currUser, TRSToWCMFilter _filter, int _nCurrPage, int _nPageSize)

void

TRSToWCMFilter.setSelect(java.lang.String _sWCMSelect, java.lang.String _sTRSSelect)

TRSToWCMFilter

DocsFromTRSServer.toTRSFilter(WCMFilter _filter)

com.trs.components.wcm.contentlink 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.contentlink 中的方法

java.util.Map

TxtFileParserForContentLink.parse(java.lang.String filename)

java.util.Map

IVContentLinkParser.parse(java.lang.String filename)
从文件内容中解释得到需要创建的对象.

com.trs.components.wcm.customize 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.customize 中的方法

static UserSetting

UserSetting.createNewInstance()
产生当前对象[UserSetting]的实例

static UserSettings

UserSettings.createNewInstance(User _currUser)
产生一个当前集合对象[UserSettings]的实例

boolean

CustomizeMgr.delete(int _nMoudelType)
删除定制的模块

boolean

CustomizeMgr.deleteChannels(int[] _nArgChannelId)
删除定制的频道

UserSetting

CustomizeMgr.find(User _currUser, int _nRegionNumber)

static UserSetting

UserSetting.findById(int _nId)
提取指定ID的对象

static UserSettings

UserSettings.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static UserSetting

UserSetting.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static UserSetting

UserSetting.findOf(User _currUser, int _nObjType, int _nObjId)
获取指定类型指定ID的个性化配置

static UserSettings

UserSettings.findOf(User _currUser, int _nObjType, WCMFilter _filter)

Channels

CustomizeMgr.getChannels()
获取当前登录用户定制的频道集合

int[]

CustomizeMgr.getMoudels()
获取定制的模块(不包定制的频道/站点)

Channel

UserSetting.getObjAsChannel(User _currUser)
若定制对象为频道，则取其对应的频道对象 //why: 2002-04-02 扩展接口 说明：若不是频道对象，则返回null.

User

UserSetting.getOwner()

void

UserSetting.insert(User _currUser)
添加对象到数据库

boolean

UserSetting.isValid()
验证对象数据的有效性

static UserSettings

UserSettings.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[UserSettings]

boolean

CustomizeMgr.save(int _nMoudelType)
保存定制的功能模块

boolean

CustomizeMgr.saveChannels(int[] _nArgChannelId)
保存定制的频道

void

CustomizeMgr.saveSetting(BaseObj _baseObj, int _nOrder, int _nRegionNumber)
保存一个定制

void

CustomizeMgr.saveSetting(BaseObj _baseObj, int _nOrder, int _nRegionNumber, java.lang.String _sValue)
保存一个定制

boolean

UserSetting.setAttribute(java.lang.String _attribute)

boolean

UserSetting.setObjId(int _objId)
设置对象ID号，允许为空

boolean

UserSetting.setObjType(int _objType)
设置对象类型

boolean

UserSetting.setOrder(int _rangeIndex)
设置排列顺序

boolean

UserSetting.setRegion(int _nRegionNumber)
设置定制的布局区域号

boolean

UserSetting.setUser(int _userId)
设置登录用户ID号

boolean

UserSetting.setUser(User _user)
设置登录用户

boolean

UserSetting.setValue(java.lang.String _sValue)
设置定制的值

com.trs.components.wcm.epress 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.epress 中的方法

void

EPressConf.add(java.lang.String key, int parentid)

void

EPressHistoryIndexWorker.execute()

void

EPressHistoryGenerator.generate()

void

EPressHistoryGenerator.generate(CMyDateTime _history)

IPublishElements

EpressFolderWrapper.getChildren()

java.lang.String

EpressFolderWrapper.getDataPath()

java.lang.String

EpressFolderWrapper.getEncoding()

java.util.Collection

EpressFolderWrapper.getFoldersQuotingMe()

IPublishFolder

EpressFolderWrapper.getParent()

IPublishFolder

EpressFolderWrapper.getRoot()

java.lang.String

EpressFolderWrapper.getRootDomain()

int

EpressFolderWrapper.getSiblingIndex()

java.util.HashMap

EpressFolderWrapper.getTemplateArguments()

void

EPressImporter.importDocuments(java.lang.String _dataZipFile)

void

EPressImporter.importDocuments(java.lang.String _dataZipFile, Channel _channel)

void

EPressImporter.importDocuments(java.lang.String _dataZipFile, java.lang.String _epressKey)

boolean

EpressFolderWrapper.isCanDoSave(User _loginUser)

boolean

EpressFolderWrapper.loadById(int _nId)

void

ChannelLCListener4EPress.notifyOnAddObj(BaseObj objAdded)

void

DocumentLCListener4EPress.notifyOnDelObj(BaseObj objDeleted, int eventType)

void

ChannelLCListener4EPress.notifyOnDelObj(BaseObj objDeleted, int eventType)

void

DocumentLCListener4EPress.notifyOnModifyObj(BaseObj objModified, int eventType)

java.lang.String[]

TagPreNextParser.parse(PublishTagContext _context)

java.lang.String[]

TagParserPageNav.parse(PublishTagContext _context)

java.lang.String[]

TagMapAreaParser.parse(PublishTagContext _context)

java.lang.String[]

TagEBookDirParser.parse(PublishTagContext _context)

void

EpressFolderWrapper.setPublishStatus(int _nStatus)

void

EpressFolderWrapper.validateCanDoPreview()

boolean

EpressFolderWrapper.validateCanDoPub()

com.trs.components.wcm.individuation 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.individuation 中的方法

static Individuation

Individuation.createNewInstance()
产生当前对象[Individuation]的实例

static Individuation

Individuation.findById(int _nId)
提取指定ID的对象

static CustomSiteCheckedInfo

CustomSiteCheckedInfo.findById(int _nId)
提取指定ID的对象

static Individuation

Individuation.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static CustomSiteCheckedInfo

CustomSiteCheckedInfo.getCustomSiteCheckInfo(int individuationId, User loginUser)

static CustomSiteCheckedInfos

CustomSiteCheckedInfo.getCustomSiteCheckInfoByIndividuationId(int individuationId, User loginUser)

Individuations

IndividuationMgr.getLoginUserIndividuationConfigs(java.lang.String[] paramNames, boolean isInclude)

void

Individuation.insert(User _currUser)
将对象数据写入数据库

void

CustomSiteCheckedInfo.insert(User _currUser)
将对象数据写入数据库

boolean

Individuation.isValid()
检验对象数据有效性

boolean

CustomSiteCheckedInfo.isValid()

static Individuations

Individuations.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Individuations]

static CustomSiteCheckedInfos

CustomSiteCheckedInfos.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[CustomSiteCheckedInfos]

boolean

Individuation.setAttribute(java.lang.String _sAttribute)
设置属性：Attribute

boolean

CustomSiteCheckedInfo.setCheckedUser(int _nCheckedUserId)
设置属性：CheckedUser

boolean

CustomSiteCheckedInfo.setIndividuationId(int _nIndividuationId)
设置属性：IndividuationId

boolean

Individuation.setIsChecked(boolean _bIsChecked)
设置属性：IsChecked

boolean

Individuation.setIsShared(boolean _bIsShared)
设置属性：IsChecked

boolean

Individuation.setObjectIdsValue(java.lang.String _sObjectIdsValue)
设置属性：ObjectIdsValue

boolean

Individuation.setParamName(java.lang.String _sParamName)
设置属性：ParamName

boolean

Individuation.setParamValue(java.lang.String _sParamValue)
设置属性：ParamValue

boolean

Individuation.setUserId(int _nUserId)
设置属性：UserId

com.trs.components.wcm.process 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.process 中的方法

void

ChnlDocLCListenerForFlow.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

ChannelLCListenerForFlow.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

FlowEmployLCListenerForChange.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.wcm.process.element 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.process.element 中的方法

void

FlowContentDocumentImpl.cancelUpdate(User user)

boolean

FlowContentDocumentImpl.canEdit(User _currUser)

java.lang.String

FlowContentDocumentImpl.getContentAddEditPage()

java.lang.String

FlowContentDocumentImpl.getContentShowPage()

User

FlowContentDocumentImpl.getCrUser()

java.lang.String

FlowContentDocumentImpl.getDeletePage()

java.lang.String

MyFlowContentDocumentImpl.getDesc()

java.lang.String

FlowContentDocumentImpl.getDesc()

Document

FlowContentDocumentImpl.getDocument()

Flow

FlowContentDocumentImpl.getOwnerFlow()

java.lang.String

FlowContentDocumentImpl.getPublishPage()

java.lang.String

FlowContentDocumentImpl.getStatusDesc()

int

FlowContentDocumentImpl.getStatusId()

CMSObj

FlowContentDocumentImpl.getSubinstance()

boolean

FlowContentDocumentImpl.loadById(int _nId)

void

FlowContentDocumentImpl.makeFrom(CMSObj _cmsObj)

void

FlowContentDocumentImpl.updateStatus(User user, int statusId)

com.trs.components.wcm.process.service.flowexporter 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.process.service.flowexporter 中的方法

void

SiteExporterForFlow.exportFlowsOfSite(WebSite oWebSite, java.lang.Object _args)

com.trs.components.wcm.publish 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.publish 中的方法

static WCMFolderPublishConfig

WCMFolderPublishConfig.createNewInstance()
产生当前对象[WCMFolderPublishConfig]的实例

static WCMPubStatusConfig

WCMPubStatusConfig.createNewInstance()
产生当前对象[WCMPubStatusConfig]的实例

static WCMFolderPublishConfig

WCMFolderPublishConfig.findById(int _nId)
提取指定ID的对象

static WCMPubStatusConfig

WCMPubStatusConfig.findById(int _nId)
提取指定ID的对象

static WCMFolderPublishConfig

WCMFolderPublishConfig.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static WCMPubStatusConfig

WCMPubStatusConfig.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static WCMFolderPublishConfig

WCMFolderPublishConfig.findOf(int _nFolderType, int _nFolderId)
获取站点或频道的发布配置信息

static WCMPubStatusConfig

WCMPubStatusConfig.findOf(int _nFolderType, int _nFolderId)

int[]

IFolderPubStatusCacheMgr.findStatusesCanDoIncreasePub(int _nFolderType, int _nFolderId)
获取指定Folder的可增量发布的状态

int[]

FolderPubStatusCacheMgrImpl.findStatusesCanDoIncreasePub(int _nFolderType, int _nFolderId)

int[]

IFolderPubStatusCacheMgr.findStatusesCanDoPub(int _nFolderType, int _nFolderId)
获取指定Folder的可完全发布的状态

int[]

FolderPubStatusCacheMgrImpl.findStatusesCanDoPub(int _nFolderType, int _nFolderId)

java.lang.String

WCMFolderPublishConfig.getDataPath()
提取属性：DataPath

static java.lang.String

WCMPublishHelper.getDataPath(BaseChannel _channel)

int

WCMFolderPublishConfig.getDefaultOutlineTemplateId()

java.lang.String

WCMFolderPublishConfig.getDetailFileExt()
提取属性：DetailFileExt

Template

WCMContentPublishConfig.getDetailTemplate()

int

WCMContentPublishConfig.getDetailTemplateId()

int

WCMFolderPublishConfig.getDetailTemplateId()
提取属性：DetailTemplateId

java.lang.String

WCMFolderPublishConfig.getEndTime()
提取属性：EndTime

java.lang.String

WCMFolderPublishConfig.getExecTime()
提取属性：ExecTime

IPublishFolder

WCMFolderPublishConfig.getFolder()

int

WCMFolderPublishConfig.getInfoviewPrintTemplateId()
提取属性：DetailTemplateId

int

WCMFolderPublishConfig.getInterval()
提取属性：Interval

java.lang.String

WCMFolderPublishConfig.getOtherOutlineTemplateIds()

java.lang.String

WCMFolderPublishConfig.getOutlineFileName()
提取属性：OutlineFileName

java.lang.String

WCMFolderPublishConfig.getOutlineTemplateIds()
提取属性：OutlineTemplateId

java.lang.String

WCMFolderPublishConfig.getPageEncoding()
获取站点的页面编码
发布产生的静态页面使用的页面编码

java.lang.String

WCMFolderPublishConfig.getRootDomain()
提取属性：RootDomain

Schedule

WCMContentPublishConfig.getSchedule()

int

WCMFolderPublishConfig.getScheduleId()

int

WCMFolderPublishConfig.getScheduleMode()
提取属性：ScheduleMode

java.lang.String

WCMContentPublishConfig.getScheduleTime()

int

WCMFolderPublishConfig.getSiteLanguage()
获取站点的语言选项
发布产生的静态页面使用的语言

java.lang.String

WCMFolderPublishConfig.getStartTime()
提取属性：StartTime

java.lang.String

WCMFolderPublishConfig.getStatusesCanDoPub()
提取属性：StatusesCanDoPub

int

WCMFolderPublishConfig.getStatusIdAfterModify()
提取属性：StatusIdAfterModify

java.lang.String

WCMContentPublishConfig.getURL()

java.lang.String

WCMFolderPublishConfig.getURL()

boolean

FolderPubStatusCacheMgrImpl.init()

void

WCMFolderPublishConfig.insert()

void

WCMFolderPublishConfig.insert(User _currUser)

void

WCMPubStatusConfig.insert(User _currUser)
将对象数据写入数据库

boolean

WCMFolderPublishConfig.isDefineFileRule()
提取属性：DefineFileRule

boolean

WCMFolderPublishConfig.isDefineSchedule()
提取属性：DefineSchedule

boolean

WCMFolderPublishConfig.isDefineStatus()
提取属性：DefineStatus

boolean

WCMContentPublishConfig.isScheduled()

boolean

WCMFolderPublishConfig.isValid()
检验对象数据有效性

boolean

WCMPubStatusConfig.isValid()
检验对象数据有效性

void

FolderPubStatusCacheMgrImpl.notifyOnAddObj(BaseObj _oObjAdded)

void

ChnlDocLCListnerForPublish.notifyOnAddObj(BaseObj _oObjAdded)

void

FolderPubStatusCacheMgrImpl.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

WCMFolderPublishConfigLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

FolderPubStatusCacheMgrImpl.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

DocumentLCListenerForPublish.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

static WCMPubStatusConfigs

WCMPubStatusConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[WCMPubStatusConfigs]

boolean

FolderPubStatusCacheMgrImpl.reinit()

void

WCMFolderPublishConfig.save()

void

WCMFolderPublishConfig.save(User _currUser)

boolean

WCMFolderPublishConfig.setDataPath(java.lang.String _sDataPath)
设置属性：DataPath

boolean

WCMFolderPublishConfig.setDefineFileRule(boolean _bDefineFileRule)
设置属性：DefineFileRule

boolean

WCMFolderPublishConfig.setDefineSchedule(boolean _bDefineSchedule)
设置属性：DefineSchedule

boolean

WCMFolderPublishConfig.setDefineStatus(boolean _bDefineStatus)
设置属性：DefineStatus

boolean

WCMFolderPublishConfig.setDetailFileExt(java.lang.String _sDetailFileExt)
设置属性：DetailFileExt

boolean

WCMFolderPublishConfig.setDetailTemplateId(int _nDetailTemplateId)
设置属性：DetailTemplateId

void

WCMContentPublishConfig.setDetialTemplate(int _nTemplateId)

boolean

WCMFolderPublishConfig.setEndTime(java.lang.String _sEndTime)
设置属性：EndTime

boolean

WCMFolderPublishConfig.setExecTime(java.lang.String _sExecTime)
设置属性：ExecTime

void

WCMPubStatusConfig.setFolderType(BaseChannel _currChannel)

boolean

WCMFolderPublishConfig.setFolderType(int _nFolderType, int _nFolderId)
设置属性：FolderTypeConfig

void

WCMPubStatusConfig.setFolderType(int _nFolderType, int _nFolderId)

boolean

WCMFolderPublishConfig.setInfoviewPrintTemplateId(int _nInfoviewPrintTemplateId)
设置属性：_nInfoviewPrintTemplateId

boolean

WCMFolderPublishConfig.setInterval(int _nInterval)
设置属性：Interval

boolean

WCMFolderPublishConfig.setIsResetChildrenTemplates(boolean _bReset)
设置属性:isResetChildrenTemplates

boolean

WCMFolderPublishConfig.setOutlineFileName(java.lang.String _sOutlineFileName)
设置属性：OutlineFileName

boolean

WCMFolderPublishConfig.setOutlineTemplateId(java.lang.String _sOutlineTemplateId)
设置属性：OutlineTemplateId

boolean

WCMFolderPublishConfig.setPageEncoding(java.lang.String _sPageEncoding)
设置站点的页面编码

boolean

WCMFolderPublishConfig.setRootDomain(java.lang.String _sRootDomain)
设置属性：RootDomain

boolean

WCMFolderPublishConfig.setScheduleMode(int _nScheduleMode)
设置属性：ScheduleMode

void

WCMContentPublishConfig.setSchedulePublish(CMyDateTime _dtSchedulePublishTime)

boolean

WCMFolderPublishConfig.setSiteLanguage(int _nSiteLanguage)
设置站点的语言选项

boolean

WCMFolderPublishConfig.setStartTime(java.lang.String _sStartTime)
设置属性：StartTime

boolean

WCMFolderPublishConfig.setStatusesCanDoPub(java.lang.String _sStatusesCanDoPub)
设置属性：StatusesCanDoPub

boolean

WCMPubStatusConfig.setStatusesCanDoPub(java.lang.String _sStatusesCanDoPub)
设置属性：StatusesCanDoPub

boolean

WCMFolderPublishConfig.setStatusIdAfterModify(int _nStatusIdAfterModify)
设置属性：StatusIdAfterModify

boolean

WCMPubStatusConfig.setStatusIdAfterModify(int _nStatusIdAfterModify)
设置属性：StatusIdAfterModify

void

WCMFolderPublishConfig.update()

void

WCMFolderPublishConfig.update(User _user)

com.trs.components.wcm.publish.domain 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.publish.domain 中的方法

Documents[]

PreNextDocumentsImpl.getPreNextDocuments(Channel _channel, Document document, int num)

Documents[]

IPreNextDocuments.getPreNextDocuments(Channel _channel, Document _currDocument, int _nNum)
获取前/后N篇文档集合

void

PreNextDocumentsImplTest.testGetPreNextDocuments()

com.trs.components.wcm.publish.element 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.publish.element 中的方法

IPublishElements

PublishFolderChannelImpl.getChildren()

IPublishElements

PublishFolderWebSiteImpl.getChildren()

int

PublishContentDocumentImpl.getModal()

IPublishFolder

PublishContentDocumentImpl.getOriginalHome()

IPublishFolder

PublishFolderChannelImpl.getParent()

java.util.Iterator

PublishContentDocumentImpl.getRelatedResources()

java.util.List

IRelateResource.getResourceNames(IPublishContent content)
获取当前IPublishContent对象的相关文件(如正文中的图片等)
注意:实现时,即使没有相关的文件,也不能返回null.在没有相关文件的情况下,返回空集

IPublishFolder

PublishFolderChannelImpl.getRoot()

int

PublishFolderChannelImpl.getSiblingIndex()

int

PublishFolderWebSiteImpl.getSiblingIndex()

boolean

PublishFolderChannelImpl.isCanDoSave(User _loginUser)

boolean

PublishContentDocumentImpl.isCanDoSave(User _loginUser)

boolean

PublishFolderWebSiteImpl.isCanDoSave(User _loginUser)

boolean

PublishContentDocumentImpl.isPublishedInHome()

boolean

PublishFolderChannelImpl.loadById(int _nId)

boolean

PublishContentDocumentImpl.loadById(int _nId)

boolean

PublishFolderWebSiteImpl.loadById(int _nId)

void

PublishFolderChannelImpl.setPublishStatus(int _nStatus)

void

PublishContentDocumentImpl.setPublishStatus(int _nStatus)

void

PublishFolderWebSiteImpl.setPublishStatus(int _nStatus)

void

PublishContentDocumentImpl.setPublishTime(CMyDateTime _dtTime)

void

PublishContentDocumentImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String _url)

void

PublishFolderChannelImpl.validateCanDoPreview()

void

PublishContentDocumentImpl.validateCanDoPreview()

void

PublishFolderWebSiteImpl.validateCanDoPreview()

boolean

PublishFolderChannelImpl.validateCanDoPub()

boolean

PublishContentDocumentImpl.validateCanDoPub()

boolean

PublishFolderWebSiteImpl.validateCanDoPub()

抛出 WCMException 的 com.trs.components.wcm.publish.element 中的构造方法

PublishElementsIteratorDocumentsImpl(WCMFilter _filter)

com.trs.components.wcm.publish.logo 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.publish.logo 中的方法

static Logo

Logo.createNewInstance()
产生当前对象[Logo]的实例

static Logo

Logo.findById(int _nId)
提取指定ID的对象

static Logo

Logo.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Logo

Logo.findOf(int _nHostType, int _nHostId, int _nIndex)
获取指定对象的指定Logo

static Logos

Logos.findOf(User _currUser, int _nHostType, int _nHostId, WCMFilter _filter)
获取指定对象的指定Logo集合

void

Logo.insert(User _currUser)
将对象数据写入数据库

boolean

Logo.isValid()
检验对象数据有效性

static Logos

Logos.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Logos]

boolean

Logo.setFileName(java.lang.String _sFileName)
设置属性：FileName

boolean

Logo.setHostId(int _nHostId)
设置属性：HostId

boolean

Logo.setHostType(int _nHostType)
设置属性：HostType

boolean

Logo.setLogoOrder(int _nLogoOrder)
设置属性：LogoOrder

boolean

Logo.setUpdated(boolean _bUpdated)
设置属性：Updated

com.trs.components.wcm.publish.region 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.publish.region 中的方法

TemplateQuote[]

WCMTagParserRegion.analyzeQuotes(IPublishFolder _o_root)

static RegionInfo

RegionInfo.createNewInstance()
产生当前对象[RegionInfo]的实例

static RegionEmploy

RegionEmploy.createNewInstance()
产生当前对象[RegionEmploy]的实例

static CellInfo

CellInfo.createNewInstance()
产生当前对象[CellInfo]的实例

static RegionInfos

RegionInfos.findByChannelId(int _nChannelId)
查询指定栏目的导读

static RegionInfo

RegionInfo.findByChannelId(int _nChannelId, int _nIndex)
获取指定栏目指定位置的Region

static RegionInfo

RegionInfo.findByChannelId(int _nChannelId, java.lang.String _sName)
获取指定栏目指定名称的Region

static RegionInfos

RegionInfos.findByChannelId(int _nChannelId, WCMFilter _filter)

static RegionInfo

RegionInfo.findById(int _nId)
提取指定ID的对象

static RegionEmploy

RegionEmploy.findById(int _nId)
提取指定ID的对象

static CellInfo

CellInfo.findById(int _nId)
提取指定ID的对象

static RegionInfo

RegionInfo.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static RegionEmploy

RegionEmploy.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static CellInfo

CellInfo.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static RegionInfo

RegionInfo.findByName(java.lang.String _sName)
获取指定名称的Region

static RegionInfo

RegionInfo.findBySiteId(int _nSiteId, int _nIndex)
获取指定站点指定位置的Region

static RegionInfo

RegionInfo.findBySiteId(int _nSiteId, java.lang.String _sName)
获取指定站点指定名称的Region

static RegionInfos

RegionInfos.findBySiteId(int _nWebSiteId, WCMFilter _filter)

static CellInfos

CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter)
获取指定区域中所有的单元格，默认按照行、列排序

static CellInfos

CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter, User _currUser)
获取指定区域中所有的单元格，默认按照行、列排序.

RegionEmploy

RegionEmployMgr.findRegionEmployByInfo(int _regionId, int _objId, int _objType)
根据当前参数唯一返回一条记录信息

RegionEmploys

RegionEmployMgr.getRegionEmploysByObj(int _objId, int _objType)
根据配置对象返回配置关系

RegionEmploys

RegionEmployMgr.getRegionEmploysByRegion(RegionInfo _region)
根据导读返回导读配置信息

RegionEmploys

RegionEmployMgr.getRegionEmploysByRegionAndType(int _regionId, int[] _objTypes)

void

RegionInfo.insert(User _currUser)
将对象数据写入数据库

void

RegionEmploy.insert(User _currUser)
将对象数据写入数据库

void

CellInfo.insert(User _currUser)
将对象数据写入数据库

boolean

RegionInfo.isValid()
检验对象数据有效性

boolean

RegionEmploy.isValid()
检验对象数据有效性

boolean

CellInfo.isValid()
检验对象数据有效性

void

DocumentListenerForPublish.notifyOnDelObj(BaseObj obj, int eventType)

void

ChannelListenerForPublish.notifyOnDelObj(BaseObj objDeleted, int eventType)

void

DocumentListenerForPublish.notifyOnModifyObj(BaseObj objModified, int eventType)

void

ChannelListenerForPublish.notifyOnModifyObj(BaseObj objModified, int eventType)

void

ChannelDocListenerForPublish.notifyOnModifyObj(BaseObj objModified, int eventType)

static RegionInfos

RegionInfos.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[RegionInfos]

static RegionEmploys

RegionEmploys.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[RegionEmploys]

static CellInfos

CellInfos.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[CellInfos]

java.lang.String[]

WCMTagParserRegion.parse(PublishTagContext _context)

boolean

CellInfo.setAppendixId(int _nAppendixId)
设置属性：APPENDIXID

boolean

CellInfo.setCellIndex(int _nCellIndex)
设置属性：CellIndex

boolean

RegionInfo.setCellNum(int _nCellNum)
设置属性：CellNum

boolean

RegionInfo.setChannelId(int _nChannelId)
设置属性：ChannelId

boolean

CellInfo.setChnlId(int _nChnlId)
设置属性：CHNLID

boolean

CellInfo.setDocId(int _nDocId)
设置属性：DocId

boolean

CellInfo.setDocTitle(java.lang.String _sDocTitle)
设置属性：DocTitle

boolean

RegionEmploy.setEmployType(int _nEmployType)
设置属性：EmployType

boolean

RegionInfo.setName(java.lang.String _sName)
设置属性：Name

boolean

RegionEmploy.setObjId(int _nObjId)
设置属性：ObjId

boolean

RegionEmploy.setObjType(int _nObjType)
设置属性：ObjType

boolean

RegionEmploy.setRegionEmployId(int _nRegionEmployId)
设置属性：RegionEmployId

boolean

RegionEmploy.setRegionId(int _nRegionId)
设置属性：RegionId

boolean

CellInfo.setRegionInfoId(int _nRegionInfoId)
设置属性：RegionInfoId

boolean

CellInfo.setRowIndex(int _nRowIndex)
设置属性：RowIndex

boolean

RegionInfo.setRowNumber(int _nRowNumber)
设置属性：ROWNUMBER

boolean

RegionInfo.setWebSiteId(int _nWebSiteId)
设置属性：ChannelId

boolean

RegionInfo.setWidth(int _nWidth)
设置属性：Width

com.trs.components.wcm.publish.tagparser 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.publish.tagparser 中的方法

void

WCMTemplateChildIndexAnalyer.analyer()

TemplateQuote[]

TagWmlContentParser.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagChannelChainParser.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserWmlImage.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

WCMTagParserCurPage.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserCRUser.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

WCMTagParserRollDocuments.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

WCMTagParser4FolderHostBase.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

XWCMFileAppendixTagParser.analyzeQuotes(IPublishFolder arg0)

TemplateQuote[]

XWCMImageAppendixTagParser.analyzeQuotes(IPublishFolder arg0)

TemplateQuote[]

WCMTagparserTopIcon.analyzeQuotes(IPublishFolder _root)

TemplateQuote[]

TagParserWmlImages.analyzeQuotes(IPublishFolder _root)

java.lang.String

RollDocumentsChannelsFinder.find(TagItem _tagItem)

static Document

WCMTagParserHelper.findDocumentHost(PublishTagContext _context)

static BaseChannel

WCMTagParserHelper.findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel)
Returns the current host as a channel.

static BaseChannel

WCMTagParserHelper.findFolderHost(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel, boolean _bIsFromAllCataTag)

static BaseChannel

WCMTagParserHelper.findFolderHostByOldModal(TagItem _tagItem, PublishTagContext _context, boolean _bMustBeChannel)

abstract  IPublishElement

WCMTagParserLogoBase.findHost(PublishTagContext _context)

IPublishElement

WCMTagParserDocumentLogo.findHost(PublishTagContext _context)

IPublishElement

WCMTagParserChannelLogo.findHost(PublishTagContext _context)

static BaseChannel

WCMTagParserHelper.findTopNewsOrPicChannel(BaseChannel _parent, int _nChannelType)

static java.lang.String

WCMAppendixGenerator.generateAppendix(Appendix _appendix, IPublishContent _apdOwner, PublishTagContext _context, int _nReturnMode)
Generates a document appendix.

static java.lang.String

WCMAppendixGenerator.generateAppendixes(Document _doc, int _nApdType, PublishTagContext _context, int _nReturnMode)
Generate the appendixes of a document.

Documents

PublishTaskDocumentsCacheMgr.get(IPublishFolder _folder, WCMFilter _filter)

Documents

IPublishTaskDocumentsCacheMgr.get(IPublishFolder _folder, WCMFilter _filter)

static int

WCMTemplateChildIndexAnalyer.getAttribute(IPublishElement _element, TagItem _item, java.lang.String _sName, int _nDefault)

static int

WCMTagParserHelper.getChildIndex(PublishTagContext _context)
Returns the value of property ChildIndex in tag item.

static int

WCMTagParserHelper.getChildIndex(TagItem _tagItem)
Returns the value of property ChildIndex in tag item.

PublishTagContext

WCMTagParser4ObjsInChannelBase.getNextRecordContext()

PublishTagContext

WCMTagParserChannels.getNextRecordContext()

PublishTagContext

WCMTagParserRelNews.getNextRecordContext()

java.lang.String[]

TagWmlContentParser.parse(PublishTagContext _context)

java.lang.String[]

TagChannelChainParser.parse(PublishTagContext _context)

java.lang.String[]

TagParserWmlImage.parse(PublishTagContext _context)

java.lang.String[]

XWCMContImgTagParser.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserLogoBase.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserCurPage.parse(PublishTagContext _context)

java.lang.String[]

TagParserCRUser.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserDefaultObjectsInChannelBase.parse(PublishTagContext _context)

java.lang.String[]

XTagParserObjsInChannelBase.parse(PublishTagContext _tagContext)

java.lang.String[]

WCMTagParserMapArea.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserAppendix.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserIcon.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParser4ObjsInChannelBase.parse(PublishTagContext _context)

java.lang.String[]

XWCMFileAppendixTagParser.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserChannels.parse(PublishTagContext _context)

java.lang.String[]

XWCMImageAppendixTagParser.parse(PublishTagContext _context)
通过图片全路径找到图片名称（带后缀名）

java.lang.String[]

WCMTagparserTopIcon.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserReplace.parse(PublishTagContext _context)

java.lang.String[]

TagParserWmlImages.parse(PublishTagContext _context)

java.lang.String[]

WCMTagParserRelNews.parse(PublishTagContext _context)

void

IPublishTaskDocumentsCacheMgr.put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments)
将Folder根据Filter获取到的Documents缓存起来

PublishTagContext

WCMTagParser4ObjsInChannelBase.substantiateContext(PublishTagContext _tagConext)

PublishTagContext

WCMTagParserChannels.substantiateContext(PublishTagContext _tagConext)

PublishTagContext

WCMTagParserRelNews.substantiateContext(PublishTagContext _tagConext)

抛出 WCMException 的 com.trs.components.wcm.publish.tagparser 中的构造方法

RollDocumentsChannelsFinder(IPublishFolder _folder)

com.trs.components.wcm.publish.tagparser.formater 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.publish.tagparser.formater 中的方法

void

WCMTagFormatterTemplate.standardize(TagItem _item)

void

WCMTagFormatterRecPath.standardize(TagItem _item)

void

WCMTagFormatterPicture.standardize(TagItem _item)

void

WCMTagFormatterDocumentsBase.standardize(TagItem _item)

void

WCMTagFormatterColumn.standardize(TagItem _item)

void

WCMTagFormatterChnlName.standardize(TagItem _item)

void

WCMTagFormatterChannel.standardize(TagItem _item)

void

WCMTagFormatterAllCata.standardize(TagItem _item)

com.trs.components.wcm.recent 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.recent 中的方法

boolean

RecentMgr.add(int _nObjType, int _nObjId)
根据对象类型和ID，将当前对象添加到最近访问的对象中
如果没有超过每个对象的记录个数，则新增。

static Recent

Recent.createNewInstance()
产生当前对象[Recent]的实例

static Recent

Recent.findById(int _nId)
提取指定ID的对象

static Recents

Recents.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Recent

Recent.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

Channels

RecentMgr.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted)
获得用户最近访问的频道列表，按访问时间逆序排列

ChnlDocs

RecentMgr.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted)
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

Documents

RecentMgr.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted)
获得用户最近访问的文档列表，按访问时间逆序排列

java.lang.String

RecentMgr.getIds(int _nObjTypeId)
取得当前用户对特定类型对象的最新访问列表Id序列

Templates

RecentMgr.getTemplates(WCMFilter _aFilter)
获得用户最近访问的模板列表，按访问时间逆序排列

WebSites

RecentMgr.getWebSites(WCMFilter _aFilter)
获得用户最近访问的模板列表，按访问时间逆序排列

void

Recent.insert(User _currUser)
将对象数据写入数据库

boolean

Recent.isValid()
检验对象数据有效性

static Recents

Recents.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Recents]

boolean

Recent.setObj(CMSObj _obj)
设置属性：ObjType

boolean

Recent.setObjId(int _nObjId)
设置属性：ObjId

boolean

Recent.setObjType(int _nObjType)
设置属性：ObjType

com.trs.components.wcm.resource 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.resource 中的方法

static Security

Security.createNewInstance()
产生当前对象[Security]的实例

static Source

Source.createNewInstance()
产生当前对象[Source]的实例

static Keyword

Keyword.createNewInstance()
产生当前对象[Keyword]的实例

static FileType

FileType.createNewInstance()
产生当前对象[FileType]的实例

static Status

Status.createNewInstance()
产生当前对象[Status]的实例

static DocKind

DocKind.createNewInstance()
产生当前对象[DocKind]的实例

static Securities

Securities.createNewInstance(User _currUser)
产生当前集合对象[Securities]的实例

static Sources

Sources.createNewInstance(User _currUser)
产生当前集合对象[Sources]的实例

static Statuses

Statuses.createNewInstance(User _currUser)
产生当前集合对象[Statuses]的实例

boolean

ResourceMgr.delete(User _currUser, CMSObj _currObj)
删除指定的配置资源对象

static Security

Security.findById(int _nId)
提取指定ID的对象

static Source

Source.findById(int _nId)
提取指定ID的对象

static Keyword

Keyword.findById(int _nId)
提取指定ID的对象

static FileType

FileType.findById(int _nId)
提取指定ID的对象

static Status

Status.findById(int _nId)
提取指定ID的对象

static DocKind

DocKind.findById(int _nId)
提取指定ID的对象

static Securities

Securities.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Sources

Sources.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Statuses

Statuses.findByIds(User _currUser, java.lang.String _sIds)
提取指定ID序列的对象集合

static Security

Security.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Source

Source.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Keyword

Keyword.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static FileType

FileType.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Status

Status.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static DocKind

DocKind.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

DocKinds

DocKind.getChildren(User _currUser)

static java.lang.String

Source.getFirstLetter(java.lang.String _sFileName, java.lang.String _str)

DocKind

DocKind.getParent()

Security

Source.getSecurity()
获取与来源有关的安全级别对象

Schedules

ResourceMgr.getTempPathDeleteSchedules(WCMFilter _filter)

void

Security.insert(User _currUser)

void

Source.insert(User _currUser)

void

Keyword.insert(User _currUser)
将对象数据写入数据库

void

FileType.insert(User _currUser)

void

Status.insert(User _currUser)

void

DocKind.insert(User _currUser)

boolean

Security.isValid()
效验数据的有效性

boolean

Source.isValid()
效验数据的有效性

boolean

Keyword.isValid()
检验对象数据有效性

boolean

FileType.isValid()

boolean

Status.isValid()
检查对象数据的有效性

boolean

DocKind.isValid()

static void

Source.loadFirstLetter(java.lang.String _sFileName)

static Keywords

Keywords.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Keywords]

static Securities

Securities.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Securities]

static Sources

Sources.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Sources]

static Statuses

Statuses.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Statuses]

CMSObj

ResourceMgr.save(User _currUser, CMSObj _currObj)
保存指定的配置资源对象

boolean

Source.setAttribute(java.lang.String _attribute)
设置属性（用于扩展）

boolean

DocKind.setAttribute(java.lang.String _attribute)

boolean

DocKind.setCode(java.lang.String _code)

boolean

Security.setDesc(java.lang.String _desc)
设置描述

boolean

Source.setDesc(java.lang.String _desc)
设置来源描述

boolean

FileType.setDesc(java.lang.String _desc)

boolean

Status.setDesc(java.lang.String _desc)
设置状态描述

boolean

DocKind.setDesc(java.lang.String _desc)

boolean

Security.setDisp(java.lang.String _disp)
设置显示名称

boolean

Status.setDisp(java.lang.String _disp)
设置状态显示内容

boolean

FileType.setExt(java.lang.String _ext)

boolean

FileType.setForm(java.lang.String _form)

boolean

Keyword.setKFREQ(int _nKFREQ)
设置属性：KFREQ

boolean

Keyword.setKNAME(java.lang.String _sKNAME)
设置属性：KNAME

boolean

Source.setLink(java.lang.String _link)
设置来源链接

boolean

Security.setName(java.lang.String _name)
设置名称

boolean

Source.setName(java.lang.String _name)
设置来源名称

boolean

FileType.setName(java.lang.String _name)

boolean

Status.setName(java.lang.String _name)
设置状态名称

boolean

DocKind.setName(java.lang.String _name)

boolean

FileType.setOpenWith(java.lang.String _openWith)

boolean

Source.setOrder(int _nOrder)
设置的排序序号

boolean

DocKind.setParent(DocKind _parent)

boolean

DocKind.setParent(int _parentId)

boolean

Source.setPrice(int _nPrice)
设置来源的稿件单价

boolean

Status.setRightIndex(int _rightIndex)
设置状态相关权限值

boolean

Source.setSecurity(int _nSecurityId)
设置与来源有关的安全级别

boolean

Source.setSecurity(Security _security)
设置与来源有关的安全级别

boolean

Keyword.setSITEID(int _nSITEID)
设置属性：SITEID

boolean

Keyword.setSITETYPE(int _nSITETYPE)
设置属性：SITETYPE

boolean

FileType.setTag(java.lang.String _tag)

boolean

Source.setType(java.lang.String _type)
设置来源类型

boolean

Status.setUsed(boolean _bUsed)
设置是否使用

boolean

Security.setValue(int _value)
设置安全级别的值

com.trs.components.wcm.stat 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.stat 中的方法

void

StatMgr.autorunStat()
自动执行统计数据的工作
每天早上2:00开始进行统计，对所有模板型概览模板进行统计数据的生成
以system的身份运行此任务

void

StatMgr.clearStatResult(int _nStatViewId)
删除统计视图对应的临时表中的数据
只有模板类视图才有临时表

static StatViewRel

StatViewRel.createNewInstance()
产生当前对象[StatViewRel]的实例

static StatView

StatView.createNewInstance()
产生当前对象[StatView]的实例

static StatHost

StatHost.createNewInstance()
产生当前对象[StatHost]的实例

static StatFieldMap

StatFieldMap.createNewInstance()
产生当前对象[StatFieldsMap]的实例

Reports

StatMgr.deleteStatHost(StatHost _delStatHost)
删除统计主体

Reports

StatMgr.deleteStatView(StatView _delStatview)
删除一个统计视图

static StatViewRel

StatViewRel.findById(int _nId)
提取指定ID的对象

static StatView

StatView.findById(int _nId)
提取指定ID的对象

static StatHost

StatHost.findById(int _nId)
提取指定ID的对象

static StatFieldMap

StatFieldMap.findById(int _nId)
提取指定ID的对象

static StatViewRel

StatViewRel.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static StatView

StatView.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static StatHost

StatHost.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static StatFieldMap

StatFieldMap.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

StatView

StatMgr.findStatViewByName(java.lang.String _sName)
根据统计视图的名称定位统计元素

void

StatMgr.generateTodayStat(int _nStatViewId)
产生特定统计视图模板当天的统计数据
统计数据记录在统计表中
可以由定时任务触发，也可以由初始化统计表格触发

CMyResultSets

StatMgr.getCurrentStatResult(int _nStatViewId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)
做一个即时统计.模板统计视图不允许.

StatViews

StatMgr.getEmbeddedViews(StatView _mainView)
得到一个模板类视图的所有子视图（嵌入式）

java.lang.String

StatView.getFiledNameFromSelect(int _nFieldPos)
从Select中获得字段名称

StatFieldMaps

StatMgr.getStatFieldsByView(int _nStatViewId)
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别

CMyResultSets

StatMgr.getStatResult(int _nStatViewId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)
统计在一个时间段内，符合特定条件的某个统计的结果
从临时统计表中查询，所以时间条件都是以DEF_STATTIME为准
Id需要从表中构造
Notes:
The view shoulb be a Template View.

CMyResultSets

StatMgr.getStatResult(java.lang.String _sqlStat, java.lang.String _sId)
进行用户定制的统计并返回统计结果

StatViews

StatMgr.getStatViews(java.lang.String _sStatHostName, int _nStatViewType, WCMFilter _filter)
获取指定统计主体下的统计视图.

StatFieldMaps

StatMgr.getViewFields(int _nStatViewId)
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别

void

StatViewRel.insert(User _currUser)
将对象数据写入数据库

void

StatView.insert(User _currUser)
将对象数据写入数据库

void

StatHost.insert(User _currUser)
将对象数据写入数据库

void

StatFieldMap.insert(User _currUser)
将对象数据写入数据库

boolean

StatViewRel.isValid()
检验对象数据有效性

boolean

StatView.isValid()
检验对象数据有效性

boolean

StatHost.isValid()
检验对象数据有效性

boolean

StatFieldMap.isValid()
检验对象数据有效性

static StatViews

StatViews.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[StatViews]

static StatViewRels

StatViewRels.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[StatViewRels]

static StatHosts

StatHosts.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[StatHosts]

static StatFieldMaps

StatFieldMaps.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[StatFieldsMaps]

StatView

StatMgr.saveStatView(StatView _currStatView, java.util.List _fieldMapList)
保存统计视图模板
其中包括保存视图模板和字段列表

boolean

StatFieldMap.setAttribute(java.lang.String _sAttribute)
设置属性：Attribute

boolean

StatViewRel.setEmbedViewId(int _nEmbedViewId)
设置属性：EmbedViewId

boolean

StatFieldMap.setFieldDesc(java.lang.String _sFieldDesc)
设置属性：FieldDesc

boolean

StatFieldMap.setFieldLength(int _nFieldLength)
设置属性：FieldLength

boolean

StatFieldMap.setFieldName(java.lang.String _sFieldName)
设置属性：FieldName

boolean

StatFieldMap.setFieldPos(int _nFieldPos)
设置属性：FieldPos

boolean

StatFieldMap.setFieldTop(int _nFieldTop)
设置属性：FieldPos

boolean

StatFieldMap.setFieldType(java.lang.String _sFieldType)
设置属性：FieldType

boolean

StatHost.setHostDesc(java.lang.String _sHostDesc)
设置属性：HostDesc

boolean

StatHost.setHostName(java.lang.String _sHostName)
设置属性：HostName

boolean

StatHost.setHostType(int _nHostType)
设置属性：HostType

boolean

StatViewRel.setMainViewId(int _nMainViewId)
设置属性：MainViewId

boolean

StatView.setResultTable(java.lang.String _sResultTable)
设置属性：ResultTable

boolean

StatView.setStatHost(java.lang.String _sStatHost)
设置属性：StatHost

boolean

StatFieldMap.setStatTempId(int _nStatTempId)
设置属性：StatTempId

void

StatMgr.setStatViewRelation(StatView _mainView, StatViews _embeddedViews)
设置模板视图和嵌入视图的关联关系

boolean

StatView.setViewAttribute(java.lang.String _sViewAttribute)
设置属性：ViewAttribute

boolean

StatView.setViewDesc(java.lang.String _sViewDesc)
设置属性：ViewDesc

boolean

StatView.setViewFrom(java.lang.String _sViewFrom)
设置属性：ViewFrom

boolean

StatView.setViewGroupBy(java.lang.String _sViewGroupBy)
设置属性：ViewGroupBy

boolean

StatView.setViewName(java.lang.String _sViewName)
设置属性：ViewName

boolean

StatView.setViewOrderBy(java.lang.String _sViewOrderBy)
设置属性：ViewOrderBy

boolean

StatView.setViewSelect(java.lang.String _sViewSelect)
设置属性：ViewSelect

boolean

StatView.setViewType(int _nViewType)
设置属性：ViewType

boolean

StatView.setViewWhere(java.lang.String _sViewWhere)
设置属性：ViewWhere

boolean

StatHost.setWCMTableId(java.lang.String _sWCMTableId)
设置属性：WCMTableId

boolean

StatHost.setWCMTableName(java.lang.String _sWCMTableName)
设置属性：WCMTableName

com.trs.components.wcm.util 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.util 中的方法

java.lang.String

CRightUtil.getSetRightTbl(RightDefs _currRightDefs, Rights _userRights, Rights _roleRights, Rights _groupRights, java.lang.String _sTblId)

java.lang.String

CRightUtil.getSetRightTbl(RightDefs _currRightDefs, java.lang.String _sTblId)

java.lang.String

CRightUtil.getSetRightTbl(java.lang.String _sTblId)

void

SystemWarnerMsgImpl.sendWarning(java.lang.String _sTitle, java.lang.String _sInfo, User _userTo, java.lang.Object _objOperated, java.lang.String _sObjName)

void

ISystemWarner.sendWarning(java.lang.String _sTitle, java.lang.String _sInfo, User _userTo, java.lang.Object _objOperated, java.lang.String _sObjName)
发送警告信息到指定用户

com.trs.components.wcm.wcmx.help 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.wcmx.help 中的方法

static WCMHelp

WCMHelp.createNewInstance()
产生当前对象[WCMHelp]的实例

static WCMHelp

WCMHelp.findById(int _nId)
提取指定ID的对象

static WCMHelp

WCMHelp.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static WCMHelp

WCMHelps.findByUrl(User _currUser, java.lang.String _sUrl)
提取指定ID序列的对象集合

java.lang.String

WCMHelp.getHtml()
提取属性：Html

void

WCMHelp.insert(User _currUser)
将对象数据写入数据库

boolean

WCMHelp.isValid()
检验对象数据有效性

static WCMHelps

WCMHelps.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[WCMHelps]

boolean

WCMHelp.setContent(java.lang.String _sContent)
设置属性：Content

boolean

WCMHelp.setHtml(java.lang.String _sHtml)
设置属性：Html

boolean

WCMHelp.setJspUrl(java.lang.String _sJspUrl)
设置属性：JspUrl

boolean

WCMHelp.setKeywords(java.lang.String _sKeywords)
设置属性：Keywords

boolean

WCMHelp.setTitle(java.lang.String _sTitle)
设置属性：Title

com.trs.components.wcm.wcmx.media 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.wcmx.media 中的方法

static MediaRemindedInfo

MediaRemindedInfo.createNewInstance()
产生当前对象[MediaRemindedInfo]的实例

int

MediaRemindedInfo.delete(User _currUser)

static MediaRemindedInfo

MediaRemindedInfo.findById(int _nId)
提取指定ID的对象

static MediaRemindedInfo

MediaRemindedInfo.findById(User _currUser, int _nId, java.lang.String _sSelect)
提取指定ID的对象

static MediaRemindedInfo

MediaRemindedInfo.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static MediaRemindedInfo

MediaRemindedInfo.findByUserAndSrc(User _currUser, int _nUserId, int _nSourceId)
提取指定ID的对象

void

MediaRemindedInfo.insert(User _currUser)
将对象数据写入数据库

boolean

MediaRemindedInfo.isValid()
检验对象数据有效性

boolean

MediaRemindedInfo.setCurrMediaCount(int _nCurrMediaCount)
设置属性：CurrMediaCount

boolean

MediaRemindedInfo.setFreqReminded(int _nFreqReminded)
设置属性：FreqReminded

boolean

MediaRemindedInfo.setSourceId(int _nSourceId)
设置属性：SourceId

boolean

MediaRemindedInfo.setUserID(int _nUserID)
设置属性：UserID

void

MediaRemindedInfo.update(User _user)
重载父对象的update，执行缓冲区的更新操作

com.trs.components.wcm.wcmx.websites 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.wcm.wcmx.websites 中的方法

static java.lang.String

ChannelRelated.getChnlOrderHtml(Channel _currChnl, User _currUser)
获取设置频道顺序的HTML代码

com.trs.components.web 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.web 中的方法

java.util.Map

IPropertiesBuilder.build()
根据內部obj对象，返回想要的Properties

java.util.Map

BasePropertiesBuilder.build()

abstract  java.lang.String

BaseFieldHTMLParser.getTemplatePath()
返回模板存放的根路径

com.trs.components.web.document 中 WCMException 的使用

抛出 WCMException 的 com.trs.components.web.document 中的方法

java.util.Map

DocumentPropertiesBuilder.build()

java.lang.String

DocumentFieldHTMLParser.getTemplatePath()

com.trs.db.update 中 WCMException 的使用

抛出 WCMException 的 com.trs.db.update 中的方法

static DBUpdateLog

DBUpdateLog.createNewInstance()
产生当前对象[DBUpdateLog]的实例

static DBUpdateLog

DBUpdateLog.findById(int _nId)
提取指定ID的对象

static DBUpdateLog

DBUpdateLog.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

java.lang.String

DBUpdateLog.getSQL(int _nDBType)

java.lang.String

DBUpdateLogMgr.getUpdateSql(int _nDBType, java.lang.String _sOrderField, boolean _bAutoAddCommit, boolean _bAddTitle, boolean _bAuthor, CMyDateTime _dtStart)
获得完整的数据库更新脚本

boolean

DBUpdateLog.isValid()
检验对象数据有效性

static DBUpdateLogs

DBUpdateLogs.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[DBUpdateLogs]

boolean

DBUpdateLog.setDB2SQL(java.lang.String _sDB2SQL)
设置属性：DB2SQL

boolean

DBUpdateLog.setMemo(java.lang.String _sMemo)
设置属性：Memo

boolean

DBUpdateLog.setMysqlSQL(java.lang.String _sMysqlSQL)
设置属性：MysqlSQL

boolean

DBUpdateLog.setOracleSQL(java.lang.String _sOracleSQL)
设置属性：OracleSQL

boolean

DBUpdateLog.setSQLServerSQL(java.lang.String _sSQLServerSQL)
设置属性：SQLServerSQL

boolean

DBUpdateLog.setSubmitor(java.lang.String _sSubmitor)
设置属性：Submitor

boolean

DBUpdateLog.setSysbaseSQL(java.lang.String _sSysbaseSQL)
设置属性：SysbaseSQL

boolean

DBUpdateLog.setTableName(java.lang.String _sTableName)
设置属性：TableName

boolean

DBUpdateLog.setTitile(java.lang.String _sTitile)
设置属性：Titile

boolean

DBUpdateLog.setType(int _nType)
设置属性：Type

com.trs.infra 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra 中的方法

void

IServer.shutdown()
关闭应用

boolean

IServer.startup()
启动应用

com.trs.infra.common 中 WCMException 的使用

com.trs.infra.common 中 WCMException 的子类

class

WCMDatainvalidException
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

抛出 WCMException 的 com.trs.infra.common 中的方法

static void

WCMException.catchException(java.lang.String _strDesc, java.lang.Exception _exCaught, boolean bSeverity)

void

BaseIdsMan.dowithIds(java.lang.String _sIds)
处理Ids

com.trs.infra.config 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.config 中的方法

static void

FileConfig.main(java.lang.String[] args)

static void

DBTableConfig.main(java.lang.String[] args)

void

DBTableConfig.save()

com.trs.infra.config.domain 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.config.domain 中的方法

ConfigFiles

ConfigFilesFinder.getConfigFiles()
得到已经组织好的配置文件集合

com.trs.infra.persistent 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.persistent 中的方法

boolean

BaseObjs.addElement(BaseObj _aObj)
添加一个元素

boolean

BaseObjs.addElement(BaseObj _aObj, int _nIndex)

BaseObj

BaseObjs.addNew()
新建一个对象元素

void

BaseObjs.addWith(BaseObjs _anotherObjs)
与指定集合做加法运算

boolean

BaseObj.checkExists(java.lang.String _sCondition)
在数据库中检查对象是否已经存在

BaseObj

BaseObj.cloneToNewObj()
由对象复制成一个新对象

BaseObj

BaseObj.cloneToNewWCMObj()
已过时。

XmlObject[]

XmlToObjConverter.convertXml(java.lang.String _sXMLContent, java.lang.String _sFieldsList)

XmlObject[]

XmlToObjConverterByDOM4j.convertXml(java.lang.String _sXMLContent, java.lang.String _sFieldsList)

XmlObject[]

AbstractXmlToObjConverter.convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList)
parse the xml file

XmlObject[]

XmlToObjConverter.convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList)
parse the xml file

XmlObject[]

XmlToObjConverterByDOM4j.convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList)
parse the xml file

static BaseObjs

BaseObjs.createInstance(java.lang.Class _classObjs)
产生指定集合对象的实例

static BaseObjs

BaseObjs.createInstance(java.lang.String _sObjsClassName)
产生指定集合对象的实例

static BaseObj

BaseObj.createNewInstance(java.lang.Class _classWCMObj)
产生指定的WCM元素对象的实例

static BaseObj

BaseObj.createNewInstance(java.lang.String _sClassName)
产生指定的WCM元素对象的实例

int

BaseObj.delete()
从数据中删除对象信息

BaseObjs

BaseObjs.filter(WCMFilter _filter)
使用指定的过滤器筛选子集

static BaseObj

BaseObj.findById(java.lang.Class _objClass, int _nId)

static BaseObj

BaseObj.findById(int _nObjType, int _nId)

static BaseObj

BaseObj.findByKey(java.lang.Class _objClass, java.lang.Object _oKey)

int

BaseObjs.getQueryCount()
获取本次查询的记录数

int

BaseObjs.getSelectCount()
根据获取集合的Filter指定的条件,得到这一次查询的所有行数 select count(*)

void

BaseObj.insert()
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

abstract  boolean

BaseObj.isValid()
检测对象属性是否有效 注意：子类必须重载！！

void

BaseObjs.isValidSQL()
效验SQL语句的合法性

boolean

BaseObj.loadById(int _nId, java.lang.String _sSelectFields)
指定ID装载数据

boolean

BaseObj.loadById(int _nId, java.lang.String _sSelectFields, boolean _bLoadNewProperty)

void

BaseObjs.loadObjsOfCurrPage(int _nPageIndex, int _nPageSize, WCMFilter _filterForLoadID, java.lang.String _sSelectFieldsOfLoadObj)

void

BaseObjs.minusWith(BaseObjs _anotherObjs)
与指定集合做减法运算

void

CMyResultObjs.open(java.lang.String _strSQL, java.util.List _listParameters, java.lang.String _sIdName)

void

CMyResultObjs.open(java.lang.String _strSQL, java.lang.String _sIdName)
打开集合

void

BaseObjs.open(WCMFilter _filter)
打开集合

void

CMyResultSets.open(WCMFilter _filter)
打开集合

void

BaseObj.readFromRs(java.sql.ResultSet _rsData, java.sql.ResultSetMetaData _rsmdData)
从记录集当前行读取对象信息 注意：（1）ResultSet的列序号从1开始 （2）Hashtable.put(key,value)函数中，要求value!

void

BaseObj.readFromRs(java.sql.ResultSet _rsData, java.sql.ResultSetMetaData _rsmdData, java.lang.String _sIdName)

void

CMyResultObjs.refresh()
刷新函数：用以重新执行过滤函数，刷新对象集 由于处理机制与缓冲集合不一样需重载父类的接口

void

BaseObjs.refresh()
刷新函数：用以重新执行过滤函数，刷新对象集

boolean

BaseObj.refreshProperty(java.lang.String _sName, boolean _bValue)

boolean

BaseObj.refreshProperty(java.lang.String _sName, long _lValue)

boolean

BaseObj.refreshProperty(java.lang.String _sName, java.lang.Object _oValue)
刷新对象指定属性值 //why:2002-04-01 为保持对象和数据库一致性 注意：不同类型的属性，必须使用相应匹配的对象作为属性值 说明：刷新是指更新对象在数据库中的存储值，与更改对象属性值不同 说明：不检测锁定；要求非新增模式使用（暂未检测）

boolean

BaseObj.refreshProperty(java.lang.String _sName, java.lang.Object _oValue, boolean _bSendMsgOfCluster)

void

BaseObj.releaseProperty(java.lang.String _sName)

boolean

BaseObj.reload()
从数据库中重新装载对象数据

boolean

BaseObjs.reloadSpecailData(java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sSelect)
从数据库中重新装载指定的数据

boolean

BaseObjs.remove()

boolean

BaseObjs.remove(BaseObj _aObj)

boolean

BaseObjs.remove(BaseObj _aObj, boolean _bDrop)
从集合中删除指定元素 说明：若指定元素不在集合中，则返回false

boolean

BaseObjs.remove(boolean _bDrop)
从集合中删除当前元素

boolean

BaseObjs.remove(int _id)

boolean

BaseObjs.remove(int _id, boolean _bDrop)
从集合中删除ID为指定值的元素

void

BaseObjs.removeAll()

void

BaseObjs.removeAll(boolean _bDrop)
删除集合中的所有元素

boolean

BaseObjs.removeAt(int _index)

boolean

BaseObjs.removeAt(int _index, boolean _bDrop)
从集合中删除指定位置的元素

void

BaseObj.save()
对象保存自己

boolean

BaseObjs.set(java.lang.String _sName, java.lang.Object _oValue)
设置集合当前元素的属性

boolean

BaseObj.setAttribute(AttributesString _attribute)

boolean

BaseObj.setAttribute(java.lang.String _attribute)
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

boolean

BaseObj.setAttribute(java.lang.String _sName, java.lang.String _sValue)
设置扩展属性

void

BaseObj.setNextId()
Created: 2004-12-22 11:48:34 Last Modified: 2004-12-22/2004-12-22 Description: 设置对象的ID值

boolean

BaseObj.setProperty(java.lang.String _sName, boolean _bValue)

boolean

BaseObj.setProperty(java.lang.String _sName, double _dValue)
导出数据到XML文件

boolean

BaseObj.setProperty(java.lang.String _sName, long _lValue)
设置属性值 注意：不同类型的属性，必须使用相应匹配的对象作为属性值

boolean

CMyResultSet.setProperty(java.lang.String _sName, java.lang.Object _oValue)

boolean

BaseObj.setProperty(java.lang.String _sName, java.lang.Object _oValue)

boolean

BaseObj.setProperty(java.lang.String _sName, java.lang.Object _oValue, boolean _bCheckPropValid)

boolean

BaseObj.setPropertyWithString(java.lang.String _sName, java.lang.String _sValue)
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象

boolean

BaseObj.setTextProperty(java.lang.String _sName, java.lang.String _sText)
set the value of the property whose type is text.

static BaseObj

BaseObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, BaseObj _oWCMObj)
解析传入的XML内容，生成传入WCMOBJ对象。

static BaseObj

BaseObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, int _nObjId, java.lang.Class _oWCMObjClass)
解析传入的XML内容，生成传入WCMOBJ对象。

org.dom4j.Element

BaseObjToXmlConverter.toXmlElement(BaseObj _baseObj)

org.dom4j.Element

BaseObjToXmlConverter.toXmlElement(BaseObjs _baseObjs, java.lang.String _sFieldsList)

org.dom4j.Element

BaseObjToXmlConverter.toXmlElement(java.util.List _listObjs, java.lang.String _sFieldsList)

void

BaseObjToXmlConverter.toXMLFile(java.lang.Object _currObj, java.lang.String _sXmlFile)

void

BaseObjToXmlConverter.toXMLFile(java.lang.Object _currObj, java.lang.String _sXmlFile, java.lang.String _sXslFile)

void

BaseObjToXmlConverter.toXMLFile(java.lang.Object _currObj, java.lang.String _sXMLFile, java.lang.String _XSLFileName, java.lang.String _sFieldsList)
将对象输出为XML文件

java.lang.String

BaseObjToXmlConverter.toXMLString(java.lang.Object _currObj)

java.lang.String

BaseObjToXmlConverter.toXMLString(java.lang.Object _currObj, java.lang.String _sXslFile)

java.lang.String

BaseObjToXmlConverter.toXMLString(java.lang.Object _currObj, java.lang.String _XSLFileName, java.lang.String _sFieldsList)
将对象输出为XML字串

void

BaseObjs.update()
更新集合中当前的对象

void

BaseObj.update()
更新修改。

com.trs.infra.persistent.cache 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.persistent.cache 中的方法

java.util.Hashtable

ICachedPOMgr.getBuffer(java.lang.Class _objClass)

java.util.Hashtable

CachedPOMgr.getBuffer(java.lang.Class _objClass)

java.util.Hashtable

ICachedPOMgr.getBuffer(int _nBufferIndex)

java.util.Hashtable

CachedPOMgr.getBuffer(int _nBufferIndex)
取指定缓冲区

int

ICachedPOMgr.getCacheIndex(java.lang.Class _objClass)

int

ICachedPOMgr.getCacheIndex(java.lang.String _sClassName)

BaseObj

ICachedPOMgr.getObjFromBuffer(java.lang.Class _objClass, int _objId)

BaseObj

CachedPOMgr.getObjFromBuffer(java.lang.Class _objClass, int _objId)

BaseObj

ICachedPOMgr.getObjFromBuffer(java.lang.Class _objClass, java.lang.Object _key)

BaseObj

CachedPOMgr.getObjFromBuffer(java.lang.Class _objClass, java.lang.Object _key)

BaseObj

ICachedPOMgr.getObjFromBuffer(java.lang.String _sClassName, int _objId)

BaseObj

CachedPOMgr.getObjFromBuffer(java.lang.String _sClassName, int _objId)

boolean

CachedPOMgr.init()

boolean

ICachedPOMgr.isCached(java.lang.Class _objClass)

boolean

ICachedPOMgr.isCached(java.lang.String _sClassName)

boolean

CachedPOMgr.reinit()

com.trs.infra.persistent.db 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.persistent.db 中的方法

java.sql.Connection

DBManager.getConnection()
获取有效的数据库连接

com.trs.util.dbcp.ConnectionCache

DBManager.getConnectionCache()
返回实际的连接缓冲池对象，便于监控连接缓冲池的状态

DBIdManager

DBManager.getDBIdManager()
获取数据表ID管理器

FieldInfo

DBManager.getFieldInfo(java.lang.String _tableName, java.lang.String _fieldName)
取得值定数据表中指定字段信息

TableInfo

DBManager.getTableInfo(java.lang.String _tableName)
取指定数据表的信息

TableInfos

DBManager.getTableInfos()

void

DBManager.notifyAddTable(java.lang.String _sTableName)
添加数据表

void

DBManager.notifyRemoveTable(java.lang.String _sTableName)
删除数据表

void

DBManager.reloadTableInfo(java.lang.String _sTableName)
重新装载指定的表信息

void

DBManager.reloadTableInfo(java.lang.String _sTableName, boolean _bSendMsgOfCluster)

static void

DBManager.setParameters(java.sql.PreparedStatement _oPreStmt, java.util.List listSearchValues)

static void

DBManager.setParameters(java.sql.PreparedStatement _oPreStmt, WCMFilter filter)

boolean

DBManager.sqlExecUpdateProcedure(java.lang.String _strProc)
执行指定的存储过程语句

int

DBManager.sqlExecuteCountQuery(WCMFilter _filter)

int

DBManager.sqlExecuteIntQuery(java.lang.String _strSQL)
caohui@2003.09.27 新增 获取指定SQL语句的第一行第一个整型数据

int

DBManager.sqlExecuteIntQuery(java.lang.String _sQuerySQL, int[] _pParamerters)

int

DBManager.sqlExecuteIntQuery(java.lang.String _sSQL, java.util.List _lParameters)

int

DBManager.sqlExecuteIntQuery(WCMFilter _filter)

int[]

DBManager.sqlExecuteIntsQuery(WCMFilter _filter)

java.sql.ResultSet

DBManager.sqlExecuteQuery(java.lang.String _strSQL)
已过时。 错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。

java.sql.ResultSet

DBManager.sqlExecuteQuery(java.lang.String _strSQL, int _nMaxSize)
已过时。 错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。 获取指定SQL语句的字符集

int

DBManager.sqlExecuteQuery(java.lang.String _sSQL, java.util.List _lParameters, int _lDefault)

long

DBManager.sqlExecuteQuery(java.lang.String _sSQL, java.util.List _lParameters, long _lDefault)

java.lang.String

DBManager.sqlExecuteStringQuery(java.lang.String _sQuerySQL, int[] _pParamerters)

int

DBManager.sqlExecuteUpdate(java.lang.String _strSQL)
执行指定的SQL Update语句

int

DBManager.sqlExecuteUpdate(java.lang.String[] _strSQLs)
执行指定的SQL Update语句

void

DBManager.sqlExecuteUpdate(java.lang.String[] _pUpdateSQL, int[] _pParamerters)

void

DBManager.sqlExecuteUpdate(java.lang.String[] _pUpdateSQL, java.lang.Object[] _pParamerters)

java.lang.String

DBManager.toDBInfo()
返回数据库信息

com.trs.infra.persistent.listener 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.persistent.listener 中的方法

void

ObjectLCMonitorServer.notifyOnAddObj(BaseObj _oObjAdded)

void

IObjectLCListenerOnAdd.notifyOnAddObj(BaseObj _oObjAdded)
新增一个对象后通知所有的Cache

void

ObjectLCMonitorServer.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

IObjectLCListenerOnDel.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache

void

ObjectLCMonitorServer.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

void

IObjectLCListenerOnModify.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache

com.trs.infra.persistent.util 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.persistent.util 中的方法

void

SynChildrenExecutorBase.execute(User _currUser)

com.trs.infra.support.cache 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.support.cache 中的方法

void

ICacheServer.clear()
清除系统所有的Cache

boolean

ICacheServer.init()
初始化系统所有的Cache

boolean

ICacheMgr.init()
初始化当前的Cache

void

ICacheServer.notify(int _nEventType, java.lang.Object _oCacheObj, java.lang.Object[] _data)
缓冲同步通知

boolean

ICacheMgr.reinit()

com.trs.infra.support.config 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.support.config 中的方法

static Config

Config.createNewInstance()
产生当前对象[Config]的实例

int

Config.delete()

static Config

Config.findById(int _nId)
提取指定ID的对象

static Config

Config.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

Config

ConfigServer.getSysConfig(java.lang.String _sConfigName)
取指定的系统配置信息

java.lang.String

ConfigServer.getSysConfigValue(java.lang.String _key, java.lang.String _default)

void

Config.insert()

boolean

Config.isValid()
效验数据是否有效

void

ConfigServer.notifyOnAddObj(BaseObj _currObj)

void

ConfigServer.notifyOnDelObj(BaseObj _currObj, int _nEventType)

void

ConfigServer.notifyOnModifyObj(BaseObj _currObj, int _nEventType)

static Configs

Configs.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[Configs]

void

PathConfig.set(java.lang.String _sValues)
使用组合字符串设置属性值 字符串格式：Flag;LocalPath;HttpPath;FtpPath

boolean

Config.setConfigKey(java.lang.String _key)
设置配置主键 要求：相同Type的配置记录不重名； 处理：区分大小写，由isValid函数检查

boolean

Config.setDesc(java.lang.String _desc)
设置配置描述信息

void

ConfigServer.setInitProperties(java.util.Map properties)

void

ConfigServer.setInitProperties(java.lang.String sKey, java.lang.String sValue)

void

PathConfig.setLocalPath(java.lang.String _sLocalPath)
设置本地路径

boolean

Config.setType(int _nType)
获取配置类别（定义在Config中）

boolean

Config.setValue(java.lang.String _value)
设置配置值

boolean

Config.setValue(java.lang.String _value, boolean _bEncrypted)
设置配置值

void

Config.update()

void

ConfigServer.updateConfigValue(java.lang.String _sConfigName, java.lang.String _sValue)
更新系统的配置信息

抛出 WCMException 的 com.trs.infra.support.config 中的构造方法

PathConfig(java.lang.String _sValues)
使用组合字符串构造对象 字符串格式：Flag;LocalPath;HttpPath;FtpPath

com.trs.infra.support.file 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.support.file 中的方法

java.lang.String

FilesMan.copyFile(java.lang.String _srcFilePathName, java.lang.String _dstPathFlag, boolean _bReturnPath)
将指定文件复制到指定的目录

java.lang.String

FilesMan.copyWCMFile(java.lang.String _srcFileName, java.lang.String _dstPathFlag)
将指定WCM文件复制到目标目录

boolean

FilesMan.deleteFile(java.lang.String _sFileName)
删除指定的文件

static CMyDateTime

FilesMan.extractFileCrDate(java.lang.String _sFileName)
提取创建日期值

static CMyDateTime

FilesMan.extractFileCrDateTime(java.lang.String _sFileName)
提取文件创建的日期时间值

static java.lang.String

FilesMan.extractFileCrDateValue(java.lang.String _sFileName)
提取日期值

static long

FilesMan.extractFileCrTimeValue(java.lang.String _sFileName)
从文件名中提取创建时间值

java.lang.String

FilesMan.getNextFileName(java.lang.String _sPathFlag, java.lang.String _sFileExt)
获取下一个可用的文件名称

java.lang.String

FilesMan.getNextFileName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime)
获取下一个可用的文件名称

java.lang.String

FilesMan.getNextFileName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime, boolean _bIncludePath)
获取下一个可用的文件名称 构造说明： [1]构造文件名时，自动检测文件名是否重复。

java.lang.String

FilesMan.getNextFilePathName(java.lang.String _sPathFlag, java.lang.String _sFileExt)
获取下一个可用的文件名称

java.lang.String

FilesMan.getNextFilePathName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime)
获取下一个可用的文件名称

java.lang.String

FilesMan.getTempAppendixFilePath(int _nSiteId, int _nPathType, boolean _bCreateWhenNotExists)
已过时。 to use getTemplateAppendixPath(WebSite.OBJ_TYPE, _nSiteId, _nPathType, _bCreateWhenNotExists) instead please.

java.lang.String

FilesMan.getTemplateAppendixPath(int _nRootType, int _nRootId, int _nPathType, boolean _bCreateWhenNotExists)
Returns the template appendix file path of the sepcified root.

java.lang.String

FilesMan.mapFilePath(java.lang.String _sFileName, int _nPathType)
目录映射：根据文件名映射文件所在的路径 文件所在路径 说明：不检查文件路径是否真正存在

java.lang.String

FilesMan.moveFile(java.lang.String _srcFilePathName, java.lang.String _dstPathFlag, boolean _bReturnPath)
将指定文件移动到指定的目录

java.lang.String

FilesMan.moveWCMFile(java.lang.String _srcFileName, java.lang.String _dstPathFlag, boolean _bReturnPath)
将指定文件移动到指定的目录

void

PathConfigLCListener.notifyOnAddObj(BaseObj _oObjAdded)

void

PathConfigLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

boolean

FilesMan.putPathConfig(Config _config, boolean _bMakeDirIfNotExists)
装载指定目录配置信息 //why@2002-04-24

boolean

FilesMan.putPathConfig(java.lang.String sKey, java.lang.String sPath, boolean _bMakeDirIfNotExists)

com.trs.infra.support.log 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.support.log 中的方法

static void

LogServer.archiveLogs(CMyDateTime _arciveDate)
对特定时间之前的所有日志进行归档

void

LogMgr.bakupLogs(BaseObjs _logs)

void

ILogMgr.bakupLogs(BaseObjs _logs)

boolean

LogMgr.clearLogBaks()

static boolean

LogServer.clearLogBaks()
清空归档日志
警告:请慎重进行此操作,确定需要删除所有的归档日志

boolean

ILogMgr.clearLogBaks()

boolean

LogMgr.clearLogs()

static boolean

LogServer.clearLogs()
清空所有日志
警告:请慎重进行此操作,确定需要删除所有的日志

boolean

ILogMgr.clearLogs()

static OperType

OperType.createNewInstance()
产生当前对象[OperType]的实例

static Log

Log.createNewInstance()
产生当前对象[WCMLog]的实例

static LogBak

LogBak.createNewInstance()
产生当前对象[LogBak]的实例

static boolean

LogServer.delete(BaseObjs _currLogs)
删除日志集合

static boolean

LogServer.delete(CMyDateTime _currDate)
删除特定日期之前的所有日志

static boolean

LogServer.delete(CMyDateTime _startDate, CMyDateTime _endDate)
删除特定时间段的所有日志

static boolean

LogServer.delete(ILog _currLog)
删除一个日志记录

void

LogMgr.delete(int _nLogId)

static boolean

LogServer.delete(int _nLogId)
根据日志ID删除一个日志记录

void

ILogMgr.delete(int _nLogId)

void

LogMgr.delete(java.lang.String _sLogIds)

static boolean

LogServer.delete(java.lang.String _sLogIds)
根据日志ID序列，删除日志集合

void

ILogMgr.delete(java.lang.String _sLogIds)

void

LogMgr.delete(WCMFilter _filter)

void

ILogMgr.delete(WCMFilter _filter)

boolean

BaseDBLog.deleteLog()

boolean

ILog.deleteLog()

static boolean

LogServer.deleteLogBaks(CMyDateTime _currDate)
删除特定日期前的所有归档日志

static boolean

LogServer.deleteLogBaks(CMyDateTime _startDate, CMyDateTime _endDate)
删除特定时间段的所有归档日志

void

LogMgr.deleteLogBaks(WCMFilter _filter)

void

ILogMgr.deleteLogBaks(WCMFilter _filter)

static java.lang.String

LogServer.export(BaseObjs _currLogs)
根据日志对象集合导出日志

static java.lang.String

LogServer.export(java.lang.String _sLogIds)
根据日志ID序列导出日志

static java.lang.String

LogServer.exportToXMLString(ILog _currLog)
根据日志对象导出日志
导出的格式，符合WCMXML格式

static java.lang.String

LogServer.exportToXMLString(int _nLogId)
根据日志ID导出日志
导出的格式，符合WCMXML格式

ILog

LogMgr.find(int _nLogId)

ILog

ILogMgr.find(int _nLogId)

BaseObjs

ILogMgr.find(java.lang.String _sLogIds)

static OperType

OperType.findById(int _nId)
提取指定ID的对象

static LogType

LogType.findById(int _nId)
根据ID获取日志类型

static Log

Log.findById(int _nId)
提取指定ID的对象

static LogBak

LogBak.findById(int _nId)
提取指定ID的对象

static OperType

OperType.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static Log

Log.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static LogBak

LogBak.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

long

ILog.getExecTime()

static BaseObjs

LogServer.getLogBaks(int _nLogType, WCMFilter _filter)
获取所有符合条件的归档日志，可直接指定日志类型ID

BaseObjs

LogMgr.getLogBaks(WCMFilter _filter)

static BaseObjs

LogServer.getLogBaks(WCMFilter _currFilter)
获取所有符合条件的归档日志

BaseObjs

ILogMgr.getLogBaks(WCMFilter _filter)

BaseObjs

LogMgr.getLogBaks(WCMFilter _filter, int _nLogType)

BaseObjs

ILogMgr.getLogBaks(WCMFilter _filter, int _nLogType)

static BaseObjs

LogServer.getLogs(int _nLogType, WCMFilter _filter)
获取所有符合条件的日志，可直接指定日志类型ID

BaseObjs

LogMgr.getLogs(WCMFilter _filter)

static BaseObjs

LogServer.getLogs(WCMFilter _filter)
获取所有符合条件的日志

BaseObjs

ILogMgr.getLogs(WCMFilter _filter)

BaseObjs

LogMgr.getLogs(WCMFilter _filter, int _nLogType)

BaseObjs

ILogMgr.getLogs(WCMFilter _filter, int _nLogType)

static BaseObjs

LogServer.getLogsByTopId(int _nLogTopId, WCMFilter _filter)
获取属于一个逻辑操作（TopId）的日志集合
TopId标识日志的起始触发操作，相同TopId的操作都是一个操作触发的。

BaseObjs

LogMgr.getLogsByTopId(WCMFilter _filter, int _nTopId)

BaseObjs

ILogMgr.getLogsByTopId(WCMFilter _filter, int _nTopId)

LogType

BaseDBLog.getLogType()
获取日志类型对象

LogType

ILog.getLogType()
获取日志类型对象

static java.lang.String

LogServer.getLogTypeName(java.lang.String _sLogTypeConst)
根据日志类型常量获得日志类型名称

java.lang.String

BaseDBLog.getOperTypeDesc()

java.lang.String

ILog.getOperTypeDesc()
获取日志操作类型的具体描述

void

Log.insert()
将记录添加到数据库中

void

LogBak.insert()

boolean

BaseDBLog.isValid()
效验数据的有效性

boolean

OperType.isValid()

void

BaseDBLog.loadByStartId(long _lStartId)

void

ILog.loadByStartId(long _lStartId)

static OperTypes

OperTypes.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[OperTypes]

static LogBaks

LogBaks.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[WCMLogBaks]

static Logs

Logs.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[WCMLogs]

void

BaseDBLog.saveLog()

void

ILog.saveLog()

boolean

LogBak.setBakUser(java.lang.String _sUserName)
设置备份用户

boolean

BaseDBLog.setDesc(java.lang.String _desc)
设置日志描述

boolean

OperType.setDesc(java.lang.String _sDesc)

boolean

ILog.setDesc(java.lang.String _desc)
设置日志描述

boolean

BaseDBLog.setEndTimeMillis(long _lEndTime)

boolean

ILog.setEndTimeMillis(long _lEndTime)

boolean

BaseDBLog.setExecTime(long _lExecTime)

boolean

ILog.setExecTime(long _lExecTime)

boolean

LogBak.setLogId(int _nLogId)

boolean

BaseDBLog.setLogType(int _typeId)
设置日志类型

boolean

ILog.setLogType(int _nLogTypeId)

boolean

BaseDBLog.setLogType(LogType _logType)
设置日志类型

boolean

ILog.setLogType(LogType _logType)
设置日志类型

boolean

BaseDBLog.setLogUserIP(java.lang.String _sLogUserIP)

boolean

ILog.setLogUserIP(java.lang.String _sLogUserIP)
设置触发日志记录的用户的登录IP

boolean

OperType.setName(java.lang.String _sOperName)

boolean

BaseDBLog.setObj(BaseObj _baseObj)

boolean

ILog.setObj(BaseObj _baseObj)

boolean

BaseDBLog.setObjId(int _objId)
设置日志操作对象编号

boolean

ILog.setObjId(int _objId)
设置日志操作对象编号

boolean

BaseDBLog.setObjName(java.lang.String _objName)
设置日志操作对象名称

boolean

ILog.setObjName(java.lang.String _objName)
设置日志操作对象名称

boolean

BaseDBLog.setObjType(int _objType)
设置日志操作对象类型

boolean

ILog.setObjType(int _objType)
设置日志操作对象类型

boolean

BaseDBLog.setObjTypeId(int _objTypeId)
设置日志操作类型

boolean

ILog.setObjTypeId(int _objTypeId)
设置日志操作类型

boolean

BaseDBLog.setOpArgs(java.lang.String _opArgs)
设置日志操作参数

boolean

ILog.setOpArgs(java.lang.String _opArgs)
设置日志操作参数

boolean

BaseDBLog.setOpTime()
设置操作时间

boolean

ILog.setOpTime()
设置操作时间

boolean

BaseDBLog.setOpTime(CMyDateTime _opTime)
设置操作时间

boolean

ILog.setOpTime(CMyDateTime _opTime)
设置操作时间

boolean

BaseDBLog.setOpType(int _opType)
设置日志操作类型

boolean

ILog.setOpType(int _opType)
设置日志操作类型

boolean

LogBak.setProperty(java.lang.String _sName, java.lang.Object _oValue)

boolean

BaseDBLog.setResult(int _result)
设置操作结果

boolean

ILog.setResult(int _result)
设置操作结果

boolean

BaseDBLog.setStartTimeMillis(long _lStartTime)

boolean

ILog.setStartTimeMillis(long _lStartTime)

boolean

BaseDBLog.setTopLogId(int _nTopLogId)

boolean

ILog.setTopLogId(int _nTopLogId)
设置触发日志记录操作所记录的第一条日志的ID
如果当前日志是第一条记录(或独立的一条日志)则TopId为0

boolean

BaseDBLog.setUser(java.lang.String _userName)
设置用户

boolean

ILog.setUser(java.lang.String _userName)
设置用户

void

LogBak.update()

com.trs.infra.support.security 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.support.security 中的方法

static SecureKey

SecureKey.createNewInstance()
产生当前对象[SecureKey]的实例

byte[]

SecureKeyMgr.decrypt(java.lang.String _sKeyName, byte[] _bytes)
使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。

byte[]

SecureKeyMgr.encrypt(java.lang.String _sKeyName, byte[] _data)
使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。

java.lang.String

SecureKeyMgr.exportKey(int _nKeyId, boolean _zIsPrivate)

java.lang.String

SecureKeyMgr.exportKey(java.lang.String _sKeyName, boolean _zIsPrivate)

static SecureKey

SecureKey.findById(int _nId)
提取指定ID的对象

static SecureKey

SecureKey.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

static SecureKey

SecureKey.findByName(java.lang.String _sKeyName)

SecureKeys

SecureKeyMgr.getKeys(WCMFilter _filter)
获取当前系统中符合条件的密钥的集合

boolean

SecureKey.isValid()

static SecureKeys

SecureKeys.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[SecureKeys]

SecureKey

SecureKeyMgr.save(SecureKey _secureKey)
保存指定的密钥

boolean

SecureKey.setAlgorithm(java.lang.String _alg)
设定密钥算法

boolean

SecureKey.setKeyName(java.lang.String _sKeyName)
设定密钥名

boolean

SecureKey.setKeySize(int _nKeySize)
设定密钥长度

byte[]

SecureKeyMgr.sign(java.lang.String _keyName, byte[] _data)
使用指定名称的密钥计算指定的数据的签名

void

SecureKey.update()

boolean

SecureKeyMgr.verify(java.lang.String _sKeyName, byte[] _data, byte[] _sign)
使用指定名称的密钥，验证指定数据和签名是否相符

com.trs.infra.util 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.util 中的方法

static java.lang.String

CMyFileX.autoToAbsoluteFilePath(java.lang.String _sSrcFileName)

static org.dom4j.Element

CMyDOM4jHelper.buildXmlFile(java.lang.String _sXmlFile, java.lang.String _sXslFile)

static CMyXMLElement

CMyXMLParser.fileToElement(java.lang.String _sResourceFileName)

static CMyXMLElement

CMyXMLParser.fileToElement(java.lang.String _sResourceFileName, java.lang.Class _class)

static CMyXMLElement

CMyXMLParser.filtToElement(java.lang.String _sResourceFileName, java.lang.Class _class, java.lang.String _sEncoding)

static CMyClassConfig[]

CMyClassConfig.fromXMLFile(java.lang.String _sXMLFile)

static CMyBeanConfig[]

CMyBeanConfig.fromXMLFile(java.lang.String _sXMLFile)

java.lang.Object

CMyClassConfig.getBean()

java.lang.Object

CMyBeanConfig.getBean()

static int

PropertiesUtil.getIntProperty(java.util.Map _properties, java.lang.String _sName, int _nDefault)
get the integer property value

static java.lang.String

PropertiesUtil.getRequiredProperty(java.util.Map _properties, java.lang.String _sName)
get a required property value

static java.lang.String

PropertiesUtil.getRequiredPropertyTrim(java.util.Map _properties, java.lang.String _sName)
get the trimmed value of a required property.

java.lang.String

CMyXMLElement.getRequiredPropertyTrim(java.lang.String _sName)
get the trimed value of a required property

static org.dom4j.Document

CMyDOM4jHelper.makeXMLDocument(org.dom4j.Element _element, java.lang.String _XSLFileName)

static java.lang.String

CMyFile.mapResouceFullPath(java.lang.String _resource)
map the resource related path to full real path

static java.lang.String

CMyFile.mapResouceFullPath(java.lang.String _resource, java.lang.Class _currClass)

static java.lang.String

CMyString.parsePageVariables(java.lang.String _sContent, java.util.Map _variables)
替换内容中的变量

static java.lang.String

CMyString.parsePageVariables(java.lang.String _sContent, java.util.Map _variables, char[] _aSep)
替换内容中的变量

static java.lang.String

CMyString.parsePageVariables(java.lang.String _sContent, java.util.Map _variables, char[] _aSep, int _nPgvarnameMaxLength)
替换内容中的变量

static java.lang.String

CMyString.parsePageVariables(java.lang.String _sContent, java.util.Map _variables, int _nPgvarnameMaxLength)
替换内容中的变量

static void

CMyDOM4jHelper.toXMLFile(org.dom4j.Element _element, java.lang.String _sXMLEncoding, java.lang.String _sXMLFile, java.lang.String _XSLFileName)

com.trs.infra.util.database 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.util.database 中的方法

java.lang.String

TypeNames.get(int typecode)
get default type name for specified type

java.lang.String

TypeNames.get(int typecode, int size, int precision, int scale)
get type name for specified type and size

java.lang.String

DBType.getCastTypeName(int code)
Get the name of the database type appropriate for casting operations (via the CAST() SQL function) for the given Types typecode.

int

DBIdManager.getNextId(BaseObj _obj, java.sql.Connection _oConn, boolean _bAddIfNotExist)

static int

ClusterDBIdManager.getNextId(java.lang.String tablename, java.lang.String idFieldName)
获取指定表的下一个可用ID.

int

DBIdManager.getNextId(java.lang.String _sTableName, java.lang.String _sIdFieldName, java.sql.Connection _oConn, boolean _bAddIfNotExist)

java.lang.String

DBType.getTypeName(int code)
Get the name of the database type associated with the given Types typecode.

java.lang.String

DB2UDB2.getTypeName(int code, int length, int precision, int scale)

java.lang.String

DBType.getTypeName(int code, int length, int precision, int scale)
Get the name of the database type associated with the given Types typecode with the given storage specification parameters.

java.lang.String

DB2AS400DB.getTypeName(int code, int length, int precision, int scale)

static boolean

CDBKeyWords.isDBKeyWords(java.lang.String _sWord)

DBIdManager

DBIdManager.load(java.sql.Connection _oConn, java.lang.String _sGetNextIdSQL)
从数据库中装载ID信息

static void

CDBKeyWords.reloadProperties()

void

TableInfos.removeTableInfo(java.lang.String _sTableName)

void

TableInfos.removeTableInfo(java.lang.String _sTableName, boolean _bSendMsgOfCluster)
删除指定表

static void

DB2ReorgUtil.reorgTable(java.lang.String tabname)
执行DB2 reorg table tabname命令.

java.lang.String

DB2UDB2.sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _sNullable, java.lang.String _sDefaultValue, int _nScale)

java.lang.String

DBType.sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。

java.lang.String

DB2AS400DB.sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _sNullable, java.lang.String _sDefaultValue, int _nScale)

java.lang.String

KingBaseDB.sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _sNullable, java.lang.String _sDefaultValue, int _nScale)

java.lang.String

DB2UDB2.sqlCreateTableWithPrimary(java.lang.String tableName, java.lang.String primaryFieldName)

java.lang.String

DBType.sqlCreateTableWithPrimary(java.lang.String _sTableName, java.lang.String _sPrimaryFieldName)
构造一个带有PrimaryKey字段的表的SQL

java.lang.String

DB2UDB2.sqlModifyField(java.lang.String tableName, java.lang.String fieldName, int fieldType, int lengthOrPrecision, boolean nullable, int scale)

java.lang.String

DB2UDBV9.sqlModifyField(java.lang.String tableName, java.lang.String fieldName, int fieldType, int lengthOrPrecision, boolean nullable, int scale)

java.lang.String

DBType.sqlModifyField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _bNullable, int _nScale)
修改指定表指定字段的属性

java.lang.String

XuguDB.sqlModifyField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _bNullable, int _nScale)

java.lang.String

KingBaseDB.sqlModifyField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _bNullable, int _nScale)

java.lang.String

DB2UDB2.sqlRenameField(java.lang.String tableName, java.lang.String oldFieldName, java.lang.String newFieldName)

java.lang.String

DB2UDBV9.sqlRenameField(java.lang.String tableName, java.lang.String oldFieldName, java.lang.String newFieldName)

java.lang.String

DBType.sqlRenameField(java.lang.String _sTableName, java.lang.String _sOldFieldName, java.lang.String _sNewFieldName)
重命名指定表的指定字段

java.lang.String

DB2UDB2.sqlRenameTable(java.lang.String oldTableName, java.lang.String newTableName)

java.lang.String

DB2UDBV9.sqlRenameTable(java.lang.String oldTableName, java.lang.String newTableName)

java.lang.String

DBType.sqlRenameTable(java.lang.String _sOldTableName, java.lang.String _sNewTableName)
重命名指定的表

com.trs.infra.util.job 中 WCMException 的使用

抛出 WCMException 的 com.trs.infra.util.job 中的方法

void

JobScheduler.addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, CMyDateTime _dtExecute)

void

JobScheduler.addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, CMyDateTime _dtStart, CMyDateTime _dtEnd, long _nInterval)

void

JobScheduler.addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, long _nInterval)

void

JobScheduler.addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, java.lang.String _sCronExpression)

void

JobScheduler.addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, java.lang.String[] _arCronExpression)

void

JobScheduler.addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, org.quartz.Trigger _trigger)

static JobFailedResult

JobFailedResult.createNewInstance()
产生当前对象[JobFailedResult]的实例

void

JobScheduler.deleteJob(java.lang.String _sJobName)

static JobFailedResult

JobFailedResult.findById(int _nId)
提取指定ID的对象

static JobFailedResult

JobFailedResult.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

void

JobFailedResult.insert()

static JobFailedResults

JobFailedResults.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[JobFailedResults]

void

JobScheduler.registerCalendar(java.lang.String _calendarName, org.quartz.Calendar _calendar)

void

JobScheduler.restart()

boolean

JobScheduler.start()

void

JobFailedResult.update()

com.trs.km.auth 中 WCMException 的使用

抛出 WCMException 的 com.trs.km.auth 中的方法

void

UserListenerForRecordLogin.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.presentation.common 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.common 中的方法

static java.lang.String

PageViewConstants.getOperNodeURL(int _nOperationType)

static java.lang.String

PageViewConstants.getOperRootURL(int _nOperationType)

static java.util.Enumeration

PageViewConstants.getPropertyNames()

static java.lang.String

PageViewConstants.getViewConfigValue(java.lang.String _sKey)

static void

PageViewConstants.reloadProperties()

com.trs.presentation.documetimport.xml 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.documetimport.xml 中的方法

static void

DocumentImportXmlHelper.addImportSource(java.lang.String _strAddFilePath)
新建一个文档导入的映射文件 just for document/document_xml_add_dowith.jsp

static void

DocumentImportXmlHelper.editImportSource(java.lang.String _strDefaultXslPath, java.lang.String _strXMLField, java.lang.String _strTRSField, java.lang.String _strSQLField)
编辑一个文档导入所需的xml映射文件 just for document/document_xml_edit_dowith.jsp

static java.lang.String[][]

DocumentImportXmlHelper.getImportSources(java.lang.String _strDefaultXslPath)
取得一个文档导入需要的xml文件信息 just for document/document_xml_edit.jsp

com.trs.presentation.ids 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.ids 中的方法

static Group

ActorHelper.saveGroup(com.trs.idm.client.actor.SSOGroup _group, Group currGroup, int parentId)
本地应用的保存组织操作

com.trs.presentation.locale 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.locale 中的方法

static void

LocaleServer.setFavorLanguage(User _currUser, java.lang.String _sLanguageKey)
设置个人偏好

static void

LocaleServer.setFavorLocale(User _currUser, java.util.Locale _locale)
设置用户选用的Locale

com.trs.presentation.login 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.login 中的方法

void

UserLCListenerForLogin.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

void

UserLCListenerForLogin.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.presentation.nav 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.nav 中的方法

static INavHandler

NavHandlerFactory.getNavHandler(java.lang.String _sItemKey)

WebSites

TreeCreator.getWebSites(int _nSiteType)

boolean

TreeCreator.hasRight(Channel _channel)

boolean

TreeCreator.hasSuperRight(BaseChannel host, CMSObj _aUser)
判断当前Operator对于指定结点是否有Super权限

java.lang.String

INavHandler.makeDefaultMainURL()
构造主窗口的地址

java.lang.String

ClassInfoNavHandler.makeDefaultMainURL()

java.lang.String

INavHandler.toHandlerkey()
产生指定Handler的Key

java.lang.String

INavHandler.toNavInfoJSON(java.util.Map oArguments)
返回一个可能包含navMode,mainFirstLink的HashMap对象

java.lang.String

ClassInfoNavHandler.toNavInfoJSON(java.util.Map _oArguments)

抛出 WCMException 的 com.trs.presentation.nav 中的构造方法

TreeCreator(User _loginUser, RequestHelper _requestHelper, javax.servlet.jsp.JspWriter _out)

com.trs.presentation.navigation 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.navigation 中的方法

static java.lang.String

TreeItem.getNodeHref(int _nChannelId, int _nOperType)

static java.lang.String

TreeItem.getRootHref(int _nSiteId, int _nOperType)

com.trs.presentation.portal 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.portal 中的方法

static java.lang.String

PortalHelper.getDocumentsByChannelId(int _nChannelId, int _nMaxSize, int _nMaxLength)
得到频道的文档 for portal/portal_documents_of_channel.jsp

static java.lang.String

PortalHelper.getMyFlowDocs(int _nMaxSize, int _nMaxLength)
得到需要我处理的文档 for portal/portal_mywork_flowdoc.jsp

static java.lang.String

PortalHelper.getRecentChannels(int _nMaxSize)
得到我最近访问的频道 for portal/portal_recent_channel.jsp

static java.lang.String

PortalHelper.getRecentDocs(int _nMaxSize, int _nMaxLength)
我最近处理的文档信息 for portal/portal_recent_doc.jsp

com.trs.presentation.publish.template 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.publish.template 中的方法

static java.lang.String

CMyTemplateWizard.toTemplateCode(int _nTempId, java.lang.String _sXMLString)
根据指定置标模板ID及传入的参数数据XML构造一份置标代码

static java.lang.String

CMyTemplateWizard.toTemplateCode(java.lang.String _sTemplateContent, java.lang.String _sXMLString)
根据指定置标代码样例及传入的参数数据XML构造一份置标代码

com.trs.presentation.right 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.right 中的方法

static boolean

RightHelper.hasRight(User _loginUser, CMSObj _currObj, int[] _rightIndexes)
判断用户对某个对象是否具有具有一系列权限中的一个

com.trs.presentation.util 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.util 中的方法

static PageParameter

PageParameter.createPageParameterFromXML(org.dom4j.Element _elParameter)
通过一个XML数据产生一个PageParameter对象

void

RequestHelper.doValid()

void

RequestHelper.doValid(boolean _bCheckFileExists)
根据当前页面的配置文件,解析当前传入页面的参数

static CMSObj

CmsObjUnlockTools.findLockedObj(int _nObjType, int _nObjId)

static boolean

CmsObjUnlockTools.forceUnLocke(User _opUser, CMSObj _lockedobj)

boolean

Parameter.fromXML(org.dom4j.Element _element)
从指定的XML Element导入参数数据 fromXMLElement(_element)

boolean

PageParameter.fromXML(org.dom4j.Element _element)

static AppAutoParameters

AppAutoParameters.getAppAutoParameters(java.lang.String _sConfigXMLFileName)
根据页面文件获取页面配置参数信息

boolean

RequestHelper.getBoolean(java.lang.String _sName, boolean _bDefault)
取布尔型属性值 说明：0值为false，非0值为true

CMyDateTime

RequestHelper.getDateTime(java.lang.String _sName)
取日期时间型属性值

CMyDateTime

RequestHelper.getDateTime(java.lang.String _sName, java.lang.String _sDateFormate)
取日期时间型属性值

boolean

PageParameter.getDefaultAsBoolean(boolean _bDefaultValue)
将默认值转换为布尔型

CMyDateTime

PageParameter.getDefaultAsDateTime()
将默认值转换为日期类型

double

PageParameter.getDefaultAsDouble(double _dDefaultValue)
将默认值转换为双精度

float

PageParameter.getDefaultAsFloat(float _fDefaultValue)
将默认值转换为浮点数

int

PageParameter.getDefaultAsInt(int _nDefaultValue)
将默认值转换为整型数

long

PageParameter.getDefaultAsLong(long _lDefaultValue)
将默认值转换为长整型

CMSObj

AppAutoParameter.getElementInstance()

int

RequestHelper.getInt(java.lang.String _sName, int _nDefault)
取长整型属性值

long

RequestHelper.getLong(java.lang.String _sName, long _lDefault)
取长整型属性值

java.lang.String

RequestHelper.getOrderField()

java.lang.String

RequestHelper.getOrderSQL()
获取当前条件下的排序语句

java.lang.String

RequestHelper.getOrderType()

WCMFilter

RequestHelper.getPageFilter(WCMFilter _extraFilter)

static PageParameters

PageParameters.getParametersOfPage(java.lang.String _sPageName, java.lang.String _sAbsolutePagePath)
根据页面文件获取页面配置参数信息

boolean

Parameter.getPropertyAsBoolean(java.lang.String _sName, boolean _bDefault)
取布尔型属性值 说明：0值为false，非0值为true

CMyDateTime

Parameter.getPropertyAsDateTime(java.lang.String _sName)
取日期时间型属性值

int

Parameter.getPropertyAsInt(java.lang.String _sName, int _nDefault)
取长整型属性值

long

Parameter.getPropertyAsLong(java.lang.String _sName, long _lDefault)
取长整型属性值

java.lang.String

RequestHelper.getSearchKey()

java.lang.String

RequestHelper.getSearchTableName()

java.lang.String

RequestHelper.getSearchValue()

java.lang.String

RequestHelper.getString(java.lang.String _sName)
取字符串型属性值

static CMSObj

AppAutoParameter.getWCMObj(java.lang.String _sClassName)

java.lang.String

RequestHelper.getWhereSQL()
获取当前条件下的检索语句

void

ResponseHelper.initCurrentPage(javax.servlet.http.HttpServletRequest _request)

void

ResponseHelper.initCurrentPage(javax.servlet.http.HttpServletRequest _request, java.lang.String _sCache, int _nExpires, int _nMaxage)

boolean

LoginHelper.isOverMaxErrNum(int _errNum)
判断用户有登录错误次数是否超过系统配置的最大次数 系统配置小于等于0，则不限制错误次数

static void

LoginHelper.kickUser(User _operUser, User user)

static CMSBaseObjs

CmsObjUnlockTools.listLockedObjs(User _opUser, int _nObjType)

void

Parameters.loadParametersFromXML(java.lang.String _sXMLFileName)

int

LoginHelper.login(java.lang.String _sUserName, java.lang.String _sPassword)
用户登录处理

int

LoginHelper.loginByIDS(java.lang.String _sUserName)

void

DefaultWhereSQLMaker.makeWhereSQL()

void

WhereSQLMaker.makeWhereSQL(RequestHelper _currRequestHelper)

java.lang.String

RequestHelper.realParameters2QueryString()
将参数以URL参数信息方式输出

static AppAutoParameters

AppAutoParameters.reloadAppAutoParameters(java.lang.String _sConfigXMLFileName)
再次装载指定页面文件的页面配置参数信息

void

RequestHelper.reloadPageConfig()
重新装载页面配置信息

static PageParameters

PageParameters.reloadParametersOfPageName(java.lang.String _sPageName, java.lang.String _sAbsolutePagePath)
再次装载指定页面文件的页面配置参数信息

void

PageParameter.setType(java.lang.String _sType)
设置当前参数的类型，类型定义为：PageParameter.TYPE_STRING等

java.lang.String

RequestHelper.toHTMLHidden()
将参数以Hidden元素的形式输出

java.lang.String

RequestHelper.toInitSearchJavaScript()

java.lang.String

RequestHelper.toTRSRequestParam()
以TRS Page 参数形式输出

java.lang.String

RequestHelper.toURL()
将参数以URL参数信息方式输出

java.lang.String

RequestHelper.toURLParameters()
将参数以URL参数信息方式输出

org.dom4j.Element

Parameters.toXMLElement()

org.dom4j.Element

Parameters.toXMLElement(java.lang.String _sTagName)

org.dom4j.Element

Parameter.toXMLElment()

org.dom4j.Element

Parameter.toXMLElment(java.lang.String _sTagName)

void

AppAutoParameters.toXMLFile(java.lang.String _XMLFileName)

boolean

Parameters.toXMLFile(java.lang.String _XMLFileName, java.lang.String _sTagName, java.lang.String _XSLFileName)

static void

AppAutoParameter.validWCMObjClass(java.lang.String _sClassName)

com.trs.presentation.valid 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.valid 中的方法

void

IValidator.validParameterValue(PageParameter _currPageParameter, java.lang.String _sValue)

com.trs.presentation.wcm.content 中 WCMException 的使用

抛出 WCMException 的 com.trs.presentation.wcm.content 中的方法

boolean

DocumentsPageHelper.canDoAddDoc()

boolean

DocumentsPageHelper.canDoOperteOnNotEmpty(int _nRightIndex)

boolean

DocumentsPageHelper.canDoPreview(Document _document)

boolean

DocumentsPageHelper.canDoPub()

Channel

DocumentsPageHelper.getDocChannel(Document _document)

Documents

DocumentsPageHelper.getDocuments(java.lang.String _sOrderFields, java.lang.String _sSelectFields)

java.lang.String

DocumentsPageHelper.getLogicRightValue()

java.lang.String

DocumentsPageHelper.getLogicRightValue(Document _currDocument)

boolean

DocumentsPageHelper.hasRight(int _nRightIndex)

boolean

DocumentsPageHelper.hasRight(int _nRightIndex, Document _document)

抛出 WCMException 的 com.trs.presentation.wcm.content 中的构造方法

DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper)

DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, BaseChannel _baseChannel)

DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, Channel _channel)

DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, WebSite _site)

com.trs.scene.parser 中 WCMException 的使用

抛出 WCMException 的 com.trs.scene.parser 中的方法

SceneNode

SceneXMLParser.parse()

SceneConnector[][]

ScenePathsParser.parse()

com.trs.scene.tools 中 WCMException 的使用

抛出 WCMException 的 com.trs.scene.tools 中的方法

SceneNode

SceneNode.addChildNode(java.lang.String _sName, int _nTabCount)
添加一个子节点

void

SceneAutoCreator.deleteAll()

com.trs.service 中 WCMException 的使用

抛出 WCMException 的 com.trs.service 中的方法

boolean

IRecentService.add(int _nObjType, int _nObjId)
添加最近访问的WCM对象

boolean

IRecentService.add(int _nObjType, java.lang.String _sObjIds)
添加最近访问的WCM对象

boolean

IRecentService.addChnlDoc(int _nChannelId, int _nDocumentId)
添加最近访问的ChnlDoc

Contact

IContactService.addContact(Contact _contact, ContactGrp _contactGroup)
添加联系人到指定的组中

Contact

IContactService.addContact(int _nContactId, int _nContactGrpId)
添加联系人到指定的组中

void

IContactService.addContact(java.lang.String _sContactIds, int _nContactGrpId)
添加联系人到指定的组中

Contact

IContactService.addContactFromSystemUser(int _nUserId)
导入系统用户为联系人

Contact

IContactService.addContactFromSystemUser(User _user)
导入系统用户为联系人

void

IChannelService.addGroupsToSite(java.lang.String _sGroupIds, WebSite _site)
给指定的站点添加指定的用户组

boolean

IGroupService.addManager(User _adminToAdd, Group _dstGroup)
将指定用户设置为某个组的管理员
注意: 指定的用户必须在指定组中

void

IChannelService.addRolesToSite(java.lang.String _sRoleIds, WebSite _site)
给指定的站点添加指定的角色

void

IChannelService.addSitesToGroup(java.lang.String _sSiteIds, Group _group)
给指定的用户组添加指定的站点

void

IChannelService.addSitesToUser(java.lang.String _sSiteIds, User _currUser)
给指定的用户添加指定的站点

boolean

IGroupService.addUser(User _userToAdd, Group _dstGroup)
将指定用户添加个指定的组中

User

IRoleService.addUser(User _dstUser, Role _toRole)
添加指定的用户到指定的角色

void

IChannelService.addUsersToSite(java.lang.String _sUserIds, WebSite _currSite)
给指定的站点添加指定的用户

DocBak

IDocumentService.backup(Document _currDocument)
备份当前文档,产生当前文档的一个版本
备份只针对实体文档，不针对引用转发或者镜像文档，所以只提供一个Document参数

void

IEventService.cancelShare(Event _aEvent, Group _assignToGroup)
取消指派给另外一个组织的Event

void

IEventService.cancelShare(Event _aEvent, User _assignToUser)
取消指派给另外一个用户的Event

void

IEventService.cancelShare(Event _aEvent, Users _assignToUsers)
取消指派给一个用户集合的Event

void

IEventService.cancelShares(Event _aEvent)
取消所有共享

void

IBookMarkService.cancelShares(int _nObjType, java.lang.String _sObjIds)
取消共享

void

IPublishService.cancelTasks(java.lang.String _sTaskIds)
取消指定的发布任务集合

void

IDocumentService.changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus)
修改指定文档的文档状态(新稿、已发等)

void

IDocumentService.changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus)
修改指定文档的文档状态(新稿、已发等)

void

IContactService.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup)
更改联系人所在的分组

void

IContactService.changeGroup(int _nContactId, int _nSrcGroupId, int _nDestGroupId)
更改联系人所在的分组

void

IStatService.clearStatResult(int _nStatViewId)
清除特定统计视图对应临时表中的数据
只有模板类视图才有临时表

Reports

IDocumentService.copyTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)
将一组文档从指定的频道复制到多个目标频道下
一般这样的操作是在文档列表页面执行的

Reports

IDocumentService.copyTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)
复制文档集合 将一堆文档复制到某个频道 一堆文档可以是一个检索的结果

static IAutoDocBakService

ServiceHelper.createAutoDocBakService()
产生IAutoDocBakService的实例

static IBookMarkService

ServiceHelper.createBookMarkService()
产生IBookMarkService的实例

static IChannelService

ServiceHelper.createChannelService()
产生IChannelService的实例

static IContactService

ServiceHelper.createContactService()
产生IContactService的实例

static ICustomizeService

ServiceHelper.createCustomizeService()
产生ICustomizeService的实例

static IDocumentService

ServiceHelper.createDocumentService()
产生IDocumentService的实例

static IEventService

ServiceHelper.createEventService()
产生IEventService的实例

Reports

IChannelService.createFrom(Channel _srcChannel, BaseChannel _parent)
频道的类似创建的实现
从指定的频道获取频道的相关属性,创建一个新的频道
新频道与源频道有基本相同的属性.

Reports

IChannelService.createFrom(int _nChannelId, BaseChannel _parent)
频道的类似创建的实现

Reports

IChannelService.createFrom(int _nSiteId, boolean _bWithRelated)
站点的类似创建的实现

Reports

IChannelService.createFrom(WebSite _srcSite, boolean _bWithRelated)
站点的类似创建的实现
从指定的站点获取站点的相关属性,创建一个新的站点.

static IGroupService

ServiceHelper.createGroupService()
产生IGroupService的实例

static IInfoViewService

ServiceHelper.createInfoViewService()

static IOfficeDocumentService

ServiceHelper.createOfficeDocumentService()

static IRecentService

ServiceHelper.createRecentService()
产生IRecentService的实例

static IResourceService

ServiceHelper.createResourceService()
产生IResourceService的实例

static IRoleService

ServiceHelper.createRoleService()
产生IRoleService的实例

static IScheduleService

ServiceHelper.createScheduleService()
产生IScheduleService的实例

static IStatService

ServiceHelper.createStatService()
产生IStatService的实例

static ISureformService

ServiceHelper.createSureformService()
产生ISureformService的实例

static IUserService

ServiceHelper.createUserService()
产生IUserService的实例

static IWCMProcessService

ServiceHelper.createWCMProcessService()
产生IWCMProcessService的实例

static IWCMPublishElementService

ServiceHelper.createWCMPublishElementService()
产生IWCMPublishElementSetting的实例

byte[]

ISecurityService.decrypt(java.lang.String sKeyName, byte[] bytes)
使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。

boolean

IChannelService.delete(BaseChannel _oChannel, boolean _bDrop)
删除站点/频道

boolean

IChannelService.delete(Channels _currChannels, boolean _bDrop)
删除频道集合

boolean

IDocumentService.delete(ChnlDocs _delChnlDocs, boolean _bDrop)
批量删除当前频道下的文档

boolean

IResourceService.delete(CMSObj _currObjToDelete)
删除资源配置

void

IPublishService.delete(Document _document)
删除指定文档已发布的页面

void

IPublishService.delete(Document _document, Channel _channel)
从指定频道上删除指定文档已发布的页面

boolean

IDocumentService.delete(Document _currDocument, Channel _currChannel, boolean _bDrop)
删除当前频道的一个文档

void

IPublishService.delete(Documents _documents)
删除指定文档集合已发布的页面

void

IPublishService.delete(Documents _documents, Channel _channel)
从指定频道上删除指定文档集合已发布的页面

boolean

IDocumentService.delete(Documents _aDocuments, Channel _currChannel, boolean _bDrop)
批量删除当前频道下的文档

boolean

IEventService.delete(Event _aEvent)
根据指定的Event对象进行删除操作

boolean

IEventService.delete(Events _aEvents)
根据指定的Events对象进行删除操作

boolean

IGroupService.delete(Group _groupToDelete)
删除某个特定的组织

boolean

IGroupService.delete(Groups _groupsToDelete)
删除一批组织（在组织列表页面中用到）

void

IInfoViewService.delete(InfoView _oInfoView)
彻底删除指定的自定义表单

void

IInfoViewService.delete(InfoViews _oInfoViews)
彻底删除指定的自定义表单集合 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。

boolean

IEventService.delete(int _nEventId)
根据提供的Event ID进行删除操作, 直接进行彻底删除操作

boolean

IGroupService.delete(int _nGroupId)
根据组ID，删除一个组织

boolean

ICustomizeService.delete(int _nMoudelType)
删除个人定制模块

void

IInfoViewService.delete(int _iInfoViewID)
根据自定义表单的ID彻底删除自定义表单

boolean

ITemplateService.delete(int _nDelTemplateId)
根据模板ID彻底删除模板

boolean

IRoleService.delete(int _nDelRoleId)
根据Id删除指定的角色

boolean

IUserService.delete(int _nUserId, boolean _bDrop)
删除指定的用户

boolean

IDocumentService.delete(int _nDocumentId, Channel _currChannel, boolean _bDrop)
删除当前频道下的一个文档

boolean

IRoleService.delete(Role _roleToDelete)
删除指定的角色

boolean

IRoleService.delete(Roles _rolesToDelete)
删除指定的角色集合

boolean

IEventService.delete(java.lang.String _sIds)
根据制定的ID序列，进行删除操作

boolean

IGroupService.delete(java.lang.String _sGroupIds)
根据组织Id，删除一批组织（在组织列表页面中用到）

void

IInfoViewService.delete(java.lang.String _sInfoViewIDs)
根据自定义表单的ID列表彻底删除自定义表单， 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。

boolean

ITemplateService.delete(java.lang.String _sDelTemplateIds)
根据模板Id列表彻底删除模板

boolean

IRoleService.delete(java.lang.String _sDelRoleIds)
根据Id序列删除多个角色

boolean

IChannelService.delete(java.lang.String _sChannelIds, boolean _bDrop)
根据频道id列表，删除频道集合

boolean

IUserService.delete(java.lang.String _sUserIds, boolean _bDrop)
根据用户id序列,批量删除指定的用户

boolean

IDocumentService.delete(java.lang.String _sDocumentIds, Channel _currChannel, boolean _bDrop)
根据文档id序列批量删除当前频道下的文档

boolean

ITemplateService.delete(Template _currTemplateToDelete)
彻底删除模板

boolean

ITemplateService.delete(Templates _currTemplatesToDelete)
彻底删除模板集合

boolean

IUserService.delete(User _userToDelete, boolean _bDrop)
删除指定的用户

boolean

IUserService.delete(Users _usersToDelete, boolean _bDrop)
批量删除指定的用户

boolean

IBookMarkService.deleteBookMark(int _nBookMarkId)
删除指定的书签

boolean

IBookMarkService.deleteBookMark(java.lang.String _sBookMarkIds)
删除指定的书签集合

boolean

ICustomizeService.deleteChannels(int[] _nArgChannelId)
删除个人定制的频道

void

IChannelService.deleteChannelSyn(int _nChnlSynId)

void

IChannelService.deleteChannelSyns(java.lang.String _sChnlSynIds)

void

IContactService.deleteContact(Contact _contact)
删除指定的联系人

void

IContactService.deleteContact(int _nContactId)
删除指定的联系人

void

IContactService.deleteContactGroup(ContactGrp _contactGrp)
删除指定的联系人分组

void

IContactService.deleteContactGroup(int _nContactGroupId)
删除指定的联系人分组

void

IContactService.deleteContactGroups(ContactGrps _contactGroups)
删除指定的联系人分组

void

IContactService.deleteContactGroups(java.lang.String _sContactGroupIds)
删除指定的联系人分组

void

IContactService.deleteContacts(Contacts _contacts)
删除指定的联系人集合

void

IContactService.deleteContacts(java.lang.String _sContactIds)
删除指定的联系人

void

IChannelService.deleteContentLink(ContentLink _contentLink)

void

IChannelService.deleteContentLinks(ContentLinks _contentLinks)

void

IDocumentService.deleteDocBak(DocBak _docbak)
删除指定的文档版本

void

IDocumentService.deleteDocBak(int _nDocBakId)
删除指定的文档版本

void

IDocumentService.deleteDocBaks(DocBaks _docbaks)
删除指定的文档版本集合

void

IDocumentService.deleteDocBaks(java.lang.String _sDocBakIds)
删除指定的文档版本

void

IChannelService.deleteExtFields(BaseChannel _siteOrChannel, java.lang.String _extFieldIds, boolean _bDeleteInherited)
删除指定站点/频道下的指定扩展字段

void

IChannelService.deleteExtFiled(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bDeleteInherited)
删除指定站点/频道下的指定扩展字段

void

IWCMProcessService.deleteFlows(java.lang.String _sFlowIds)

void

ISecurityService.deleteKey(int _toDeleteId)
删除指定ID的密钥

void

ISecurityService.deleteKey(java.lang.String _toDeleteIds)
删除指定ID的密钥 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经被删除的密钥不会回滚。

void

ISecurityService.deleteKeyByName(java.lang.String _toDeleteName)
删除指定名称（名称：一般是密钥的用途）的密钥

boolean

IBookMarkService.deleteMarkKind(int _nMarkKindId)
删除指定的书签文件夹

boolean

IBookMarkService.deleteMarkKind(java.lang.String _sMarkKindIds)
删除指定的书签文件夹集合

void

IWCMPublishElementService.deletePublishDistributions(WebSite _currSite, java.lang.String _sPublishDistributionIds)
将当前站点的指定分发信息设置删除

Schedule

IScheduleService.deletePublishSchedule(BaseChannel _currChannel)
删除指定站点或频道的计划发布

Schedule

IScheduleService.deletePublishSchedule(Document _currDocument)
删除指定文档的计划发布

boolean

IChannelService.deleteReplace(Replace _aReplace)
删除替换内容对象

boolean

IChannelService.deleteReplace(Replaces _aReplaces)
删除替换内容对象集合

boolean

ICustomizeService.deleteSites(int[] _nArgSiteId)
删除个人定制的站点集合

Reports

IStatService.deleteStatHosts(java.lang.String _sDelStatHostIds)
删除统计类型

Reports

IStatService.deleteStatView(int _nStatViewId)
删除一个统计视图

Reports

IStatService.deleteStatView(StatView _delStatView)
删除一个统计视图

Reports

IStatService.deleteStatViews(java.lang.String _sStatViewIds)
删除一个统计视图

void

IPublishService.deleteTasks(java.lang.String _sTaskIds)

boolean

ITemplateService.deleteTemplateArgument(TemplateArgument _argument)
删除指定的TemplateArgument对象

void

ITemplateService.deleteTemplateArguments(TemplateArguments _arguments)
删除指定的TemplateArguments对象集合

byte[]

ISecurityService.digest(java.lang.String sAlgorithm, byte[] data)
使用指定的算法计算指定数据的摘要

boolean

IUserService.disable(int _nUserId)
根据Id来禁用用户

boolean

IUserService.disable(User _userToDisable)
设置一个用户为禁用状态

void

ISureformService.distributeSureformFile(int _nChannelId)
将频道配置的书生表单发布到Web服务器上

void

ISecurityService.doDecrypt(java.lang.String sKeyName, java.io.InputStream is, java.io.OutputStream os)
使用指定名称的密钥，解密指定的输入流中的数据，并将明文写入指定的输出流。

byte[]

ISecurityService.doDigest(java.lang.String sAlgorithm, java.io.InputStream is)
使用指定的算法计算指定数据源（输入流）的摘要

void

ISecurityService.doEncrypt(java.lang.String sKeyName, java.io.InputStream is, java.io.OutputStream os)
使用指定名称的密钥，加密指定的输入流中的数据，并将密文写入指定的输出流。

byte[]

ISecurityService.doSign(java.lang.String sKeyName, java.io.InputStream is)
使用指定名称的密钥计算指定的数据源的签名

boolean

ISecurityService.doVerify(java.lang.String sKeyName, java.io.InputStream is, byte[] sign)
使用指定名称的密钥，验证指定数据源和签名是否相符

void

IChannelService.emptyRecycleBin(int _nChannelId)
清空指定频道的文档回收站
删除指定频道回收站中的所有文档.

boolean

IUserService.enable(int _nUserId)
根据ID恢复用户

boolean

IUserService.enable(User _userToEnable)
开通一个用户

byte[]

ISecurityService.encrypt(java.lang.String sKeyName, byte[] bytes)
使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。

java.lang.Object

IInfoViewEnumCreator.enumScript(InfoViewContext _oContext)

java.lang.String

IChannelService.export(BaseChannel _fromChannel, boolean _bWithChildren, boolean _bWithRelated)
将WCM的站点、频道导出成为WCM XML标准格式的字符串

java.lang.String

IChannelService.export(Channels _fromChannels, boolean _bWithChildren, boolean _bWithRelated)

java.lang.String

IDocumentService.export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes)
导出文档集合

java.lang.String

IDocumentService.export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes)
导出指定的文档

java.lang.String

ITemplateService.export(int _nTemplateId)
根据Id导出模板到临时目录的文件中

java.lang.String

IDocumentService.export(int _nDocId, java.lang.String _sFieldsList, boolean _bWithAppendixes)
导出指定的文档

java.lang.String

ITemplateService.export(java.lang.String _sTemplateIds)
根据模板的Id列表导出模板集合到临时目录的文件中

java.lang.String

IDocumentService.export(java.lang.String _sDocIds, java.lang.String _sFieldsList, boolean _bWithAppendixes)
根据指定的ID序列导出文档

java.lang.String

ITemplateService.export(Template _currTemplate)
导出模板到固定的文件中

java.lang.String

ITemplateService.export(Templates _currTemplates)
导出模板集合到临时目录的文件中

java.lang.String

IChannelService.export(WebSites _fromWebSites, boolean _bWithChildren, boolean _bWithRelated)

java.lang.String

IChannelService.exportChannels(java.lang.String _sChnlIds, boolean _bWithChildren, boolean _bWithRelated)

java.lang.String

IWCMProcessService.exportFlow(int _nFlowId)
导出指定的工作流对象.

java.lang.String

IWCMProcessService.exportFlows(java.lang.String _sFlowIds)
导出指定的工作流为XML文件格式的数据.

java.lang.String

ISecurityService.exportKey(boolean _zIsPrivate, int iKeyId)
导出指定的密钥

java.lang.String

ISecurityService.exportKey(boolean _zIsPrivate, java.lang.String sKeyName)
导出指定的密钥

byte[]

ISecurityService.exportKey(int _toExportId, boolean _zIsPrivate)
导出指定ID的密钥的原始数据

byte[]

ISecurityService.exportKey(java.lang.String _toExportName, boolean _zIsPrivate)
导出指定名称的密钥的原始数据

void

ISecurityService.exportKey(java.lang.String _toExportIds, java.io.Writer _writer)
以XML文件的形式导出指定的密钥

void

ISecurityService.exportKey(java.io.Writer _writer)
以XML文件的形式导出系统内的全部密钥

java.lang.String

IChannelService.exportSites(java.lang.String _sSiteIds, boolean _bWithChildren, boolean _bWithRelated)

java.util.List

ISecurityService.extractKey(java.io.File _oXMLFile, java.lang.String _encoding)
从指定的XML文件中抽取全部可用的密钥

java.util.List

ISecurityService.extractKey(java.io.Reader _oXMLReader)
从指定的XML文件输出流中抽取全部可用的密钥

java.lang.String[]

ITemplateService.extractTemplateNamesFromZip(java.lang.String _sZipFileName)
得到导入文件中可能的模板文件名列表

java.lang.String

IInfoViewService.filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int nFlowDocId)

InfoView

IInfoViewService.findById(int _iInfoViewID)
在指定的站点下查找指定ID的自定义表单

Template

ITemplateService.findByName(int _nSiteId, java.lang.String _sTempName)
根据指定的SiteId，找到指定名称的模板

ChnlDoc

IDocumentService.findChnldoc(int _currDocumentId, int _currChannelId)
根据频道和文档，找到对应的ChnlDoc

WCMFolderPublishConfig

IWCMPublishElementService.findFolderConfig(BaseChannel _currChannel)
获取当前站点或频道的发布配置信息

SecureKey

ISecurityService.findKey(int _iKeyId)
在系统内查找指定ID的密钥

SecureKey

ISecurityService.findKey(java.lang.String _iKeyName)
在系统内查找指定名称的密钥

PublishDistributions

IWCMPublishElementService.findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter)
获取当前站点所设置的分发目录集合

Schedule

IScheduleService.findPublishSchedule(BaseChannel _currChannel)
获取指定站点或频道的计划发布信息

Schedule

IScheduleService.findPublishSchedule(Document _currDocument)
获取指定文档的计划发布信息

StatView

IStatService.findStatViewByName(java.lang.String _sName)
获取指定名称的统计视图.

InfoViewView

IInfoViewService.findViewById(int _iViewID)
查找指定ID的自定义表单视图

void

IWCMProcessService.forceContentEndInFlow(int _nContentType, int _nContentId)

java.lang.String

IInfoViewService.forFillOut(InfoView _oInfoView, InfoViewView _oView)
为了在WCM内部填写表单而生成HTML页面 事实上生成的HTML页面不仅用于内部填写表单、还用在表单预览、表单数据察看。

java.lang.String

IInfoViewService.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int nFlowDocId)

java.lang.String

IInfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView)

java.lang.String

IInfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)

void

IStatService.generateTodayStat(int _nStatTempId)
产生特定统计模板当天的统计数据
统计数据记录在统计表中

Users

IGroupService.getAdmins(Group _dstGroup)
获取指定组的管理员集合

java.lang.String

ICDSService.getAllChannelsXML(boolean _bIncludeChildren)
获取系统树状结构信息

Documents

IDocumentService.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)

PublishTasks

IPublishService.getAllTasks(WCMFilter _filter)
提取所有的发布任务；要求当前用户必须具有管理权限

Appendixes

IDocumentService.getAppendixes(Document _currDocument)
获取当前文档的所有附件

Appendixes

IDocumentService.getAppendixes(Document _currDocument, int _nAppendixType)
获取当前文档的某种类型的附件

Appendixes

IDocumentService.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter)
获取当前文档的某种类型的附件

Appendixes

IDocumentService.getAppendixes(Document _currDocument, WCMFilter _filter)
获取当前文档的某种类型的附件

java.util.List

IInfoViewService.getAppendixList(org.dom4j.Document dom4jDocument)
从org.dom4j.Document对象中抽取附件信息 作为输入的org.dom4j.Document对象，在抽取附件信息，其中的附件标示信息已经被删除。

java.util.List

IInfoViewService.getAppendixList(java.lang.String xmlContent)
从XML文件中抽取附件信息

AutoBakConfig

IAutoDocBakService.getAutoSaveConfig(int _nSiteId)
获取指定站点上所有关于文档版本自动保存的配置信息

BookMarks

IBookMarkService.getBookMarks(int _nMarkKindId)
根据传入的MarkKind ID，获取它所包含的BookMarks

BookMarks

IBookMarkService.getBookMarks(int _nMarkKindId, WCMFilter _filter)
根据传入的MarkKind ID，获取它所包含的BookMarks

BookMarks

IBookMarkService.getBookMarks(WCMFilter _filter)
获取BookMarks集合

Users

IUserService.getCanMgrUsers(int _nUserRegStatus, WCMFilter _filter)
获取我可管理的用户

Channel

InfoViewContext.getChannel()

Channels

ICustomizeService.getChannels()
获取当前用户定制的频道集合

Channels

IDocumentService.getChannels(Document _currDocument)
获得实体文档相关的引用、镜像等对应的所有频道

Channels

ICustomizeService.getChannels(int _nRightIndex)
获取当前用户定制的并且有指定操作权限的频道集合

Channels

IRecentService.getChannels(WCMFilter _aFilter)
返回用户最近访问的频道列表
按照访问的时间顺序排序

Channels

IRecentService.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted)
返回用户最近访问的频道列表
按照访问的时间顺序排序

Channels

IRecentService.getChannels(WCMFilter _filter, boolean _bIncludeDeleted, int _nRightIndex)
获取用户最近访问的频道集合,并校验访问指定权限.

Channels

IRecentService.getChannelsWithRight(WCMFilter _filter)
获取用户最近访问的频道集合,并校验访问权限.

java.lang.String

ICDSService.getChannelsXML(BaseChannel _oBaseChannel, boolean _bIncludeChildren)
获取指定站点或频道的树状结构信息

ChannelSyns

IChannelService.getChannelSyns(int _nChannelId, WCMFilter _filter)

java.util.List

IChannelService.getChildren(BaseChannel _oChannel)
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限

java.util.List

IChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex)
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)

java.util.List

IChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex, int _nChannelType)
获取当前站点/频道的子频道集合(不包含已删除的子频道)

java.util.List

IChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex, int[] _nArrayChannelType)
获取当前站点/频道的子频道集合(不包含已删除的子频道)

java.util.List

IChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex, int[] _nArrayChannelType, java.lang.StringBuffer _sbNoRightIds)
获取当前站点/频道的子频道集合(不包含已删除的子频道)

Groups

IGroupService.getChildren(Group _parentGroup)
获取某个组的子组集合

Groups

IGroupService.getChildren(Group _parentGroup, boolean _bContainsChildren)

Groups

IGroupService.getChildren(Group _parentGroup, boolean _bContainsChildren, WCMFilter _filter)

MarkKinds

IBookMarkService.getChildren(int _nMarkKindId, WCMFilter _filter)
根据传入的MarkKind ID，获取它的子MarkKinds

ChnlDocs

IRecentService.getChnlDocs(WCMFilter _aFilter)
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

ChnlDocs

IRecentService.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted)
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

ContactGrps

IContactService.getContactGroups(WCMFilter _filter)
获取当前用户的所有联系人分组

Contacts

IContactService.getContacts(WCMFilter _filter)
获取当前登录用户所有的联系人

Contacts

IContactService.getContacts(WCMFilter _filter, ContactGrp _contactGroup)
获取当前登录用户某个分组的联系人

ContentLinks

IChannelService.getContentLinks(WebSite _site, WCMFilter _filter)

FlowDoc

IWCMProcessService.getCurrentFlowDoc(int _nContentType, int _nContentId)

CMyResultSets

IStatService.getCurrentStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)
统计在一个时间段内，符合特定条件的某个统计的结果
对数据库进行实时统计，而不是从统计临时表中取

int

IWCMProcessService.getCurrFlowFlag(int _nContentType, int _nContentId)

java.lang.String

IWCMProcessService.getCurrFlowFlagDesc(int _nContentType, int _nContentId)

Template

ITemplateService.getDetailTemplate(IPublishElement _publishElement)
获得指定频道的细览模板

DocBak

IDocumentService.getDocBak(Document _currDocument, int _nVersion)
获取当前文档指定版本的备份

DocBaks

IDocumentService.getDocBaks(Document _currDocument)
获取当前文档的备份

DocBaks

IDocumentService.getDocBaks(Document _currDocument, WCMFilter _filter)
获取当前文档的备份

Document

InfoViewContext.getDocument()

Documents

IUserService.getDocuments()
获取当前登录用户创建的有效文档集合

Documents

IChannelService.getDocuments(BaseChannel _oChannel)
获取当前站点/频道下的有效文档

Documents

IChannelService.getDocuments(BaseChannel _oChannel, WCMFilter _docFilter)
获取当前站点/频道下的有效文档

Documents

IChannelService.getDocuments(int _nChnlId)
获取当前频道下的有效文档

Documents

IChannelService.getDocuments(int _nChnlId, WCMFilter _filter)
获取当前频道下的有效文档

Documents

IUserService.getDocuments(WCMFilter _filter)
获取当前登录用户创建的有效文档集合,设定查询条件

Documents

IRecentService.getDocuments(WCMFilter _aFilter)
返回用户最近访问的文档列表
由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询

Documents

IRecentService.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted)
返回用户最近访问的文档列表
由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询

java.lang.String

IInfoViewService.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument)
按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题

java.lang.String

IInfoViewService.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument, java.lang.String _oPostUserNmae)
按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题

java.lang.String

IInfoViewService.getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent)
按照相关表单的设定从XML文件抽取文档的标题

org.dom4j.Document

IInfoViewService.getDOM4JDocument(java.lang.String xmlContent)
将XML文件的内容转化为org.dom4j.Document对象

Documents

IUserService.getDraft()
获取当前登录用户创建的草稿集合

Documents

IUserService.getDraft(WCMFilter _filter)
获取当前登录用户创建的草稿集合,设定查询条件

StatViews

IStatService.getEmbeddedViews(int _nMainViewId)
得到一个模板类视图的所有子视图（嵌入式）

java.util.List

IInfoViewService.getEmployedInfoViews(CMSObj _employer)
获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合

java.util.List

IInfoViewService.getEmployedInfoViews(int _iEmployerType, int _iEmployerId)
获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合

Events

IEventService.getEvents(WCMFilter _filter)
根据指定的filter获取Events

java.io.File[]

IDocumentService.getExitedMappingFiles()
获取当前用户已定义的XML映射文件

java.io.File[]

IDocumentService.getExitedXslFiles()
获取当前用户已上传的xsl文件

ContentExtFields

IChannelService.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)
获取指定站点/频道下的扩展字段.

java.lang.Object

IInfoViewInitorValue.getFieldValue(InfoViewContext _oContext, BindingBean _oBindingBean)

FlowDocs

IWCMProcessService.getFlowDocs(int _nFlag, WCMFilter _filter)

FlowDocs

IWCMProcessService.getFlowDocsOfContent(int _nContentType, int _nContentId)
获取当前内容的所有流转情况

Flow

IWCMProcessService.getFlowOfEmployer(BaseObj _employer)

Flows

IWCMProcessService.getFlows(WCMFilter _filter)

Groups

IUserService.getGroups()
获取当前登录用户所在的组织.

ContactGrps

IContactService.getGroups(Contact _contact)
获取指定联系人所属的所有联系人分组

Groups

IUserService.getGroups(User _currUser)
获取指定用户所在的组织集合

java.lang.String

IRecentService.getIds(int _nObjTypeId)
根据对象的类型，得到最近访问的该对象的集合Ids

InfoView

InfoViewContext.getInfoView()

java.util.List

IInfoViewService.getInfoViewEmployers(InfoView _employed)
获取指定自定义表单的所有雇主（频道对象）的集合

java.util.List

IInfoViewService.getInfoViewEmployers(int _iInfoViewID)
获取指定自定义表单的所有雇主（频道对象）的集合

InfoViews

IInfoViewService.getInfoViews(WCMFilter _filter)
获取所有符合条件的自定义表单

java.lang.String

IInfoViewService.getInfoViewSerial(InfoView _oInfoView)
获取指定表单的编号

java.lang.String

IInfoViewService.getInfoViewSerial(int _iInfoViewId)
获取指定表单的编号

SecureKeys

ISecurityService.getKeys(WCMFilter _filter)
获取当前系统中符合条件的密钥的集合

Templates

ITemplateService.getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren)
获取站点/频道下管理的模板集合

int

IDocumentService.getMaxToppedNum()
获得允许置顶的文档的总数
是从系统配置中获取，整个系统中有一个数值记录

Channels

IDocumentService.getMirrorChannels(Document _currDocument)
获得源文档所有存在同源异现镜像的频道

int[]

ICustomizeService.getMoudels()
获取当前用户定制的模块集合

java.lang.String

IDocumentService.getMyDocumentImportSourceFilePath()
获取当前登录用户导入文档时,XSL文件的存放位置

PublishTasks

IPublishService.getMyTasks(WCMFilter _filter)
提取我的发布任务

Users

IUserService.getMyUsers(int _nUserRegStatus, WCMFilter _filter)
获取我所创建的用户列表

Templates

ITemplateService.getNestedTemplates(Template _currTemplate)
获取当前模板中使用到的嵌套模板

Templates

ITemplateService.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseParent)
获取指定Folder中可选的模板集合

Templates

ITemplateService.getOutlineTemplates(IPublishFolder _folder)
获得指定频道的概览模板

Channels

IDocumentService.getQuoteChannels(Document _currDocument)
获取引用了当前指定文档的所有频道

Channels

IDocumentService.getQuoteChannels(int _nDocumentId)
获取引用了当前指定文档的所有频道

Channels

IChannelService.getRecycleChannels(BaseChannel _oChannel)
获取当前站点/频道下的废弃频道集合

Channels

IChannelService.getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter)
获取当前站点/频道下的废弃频道集合

Documents

IUserService.getRecycleDocuments()
获取当前登录用户创建的废稿集合

Documents

IChannelService.getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter)
获取当前站点/频道下的废稿

Documents

IDocumentService.getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter)
获取当前站点或频道的回收站的文档

Documents

IChannelService.getRecycleDocuments(int _nChnlId)
获取当前频道下的废稿

Documents

IChannelService.getRecycleDocuments(int _nChnlId, WCMFilter _filter)
获取当前频道下的废稿

Documents

IUserService.getRecycleDocuments(WCMFilter _filter)
获取当前登录用户创建的废稿集合,设定查询条件

WebSites

IChannelService.getRecycleSites(WCMFilter _filter)
获取系统回收站中的站点集合

Documents

IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich)
指定检索条件获取与当前文档相关的文档

Documents

IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter)
指定检索条件获取与当前文档相关的文档

Documents

IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSite)
指定检索条件获取与当前文档相关的文档

Relations

IDocumentService.getRelations(Document _currDocument)
获取当前文档的Relations集合，即手工设定的相关文档

Replaces

IChannelService.getReplaces(Channel _oChannel, WCMFilter _filter)
获取指定频道下的替换内容对象集合

Roles

IUserService.getRoles()
获取当前登录用户所担任的角色.

Roles

IUserService.getRoles(User _currUser)
获取指定用户所属的角色集合

BookMarks

IBookMarkService.getSharedBookMarks(User _currUser, WCMFilter _fliter)
获取所有共享的书签

Events

IEventService.getSharedEvents(User _user, CMyDateTime _date)
获取用户在指定日期内被Assign的所有Events

Events

IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll)
获取用户在指定日期内私有的或公有的Events

Events

IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter)
获取用户在指定filter限制下被Assign的Events

Groups

IEventService.getSharedGroups(Event _aEvent)
获取一个Event被AssignTo的Group

Groups

IBookMarkService.getSharedGroups(int _nObjType, int _nObjId)
获取共享组织

MarkKinds

IBookMarkService.getSharedMarkKinds(User _currUser, WCMFilter _filter)
获取所有共享的书签文件夹

Users

IEventService.getSharedUsers(Event _aEvent)
获取一个Event被AssignTo的Users

Users

IBookMarkService.getSharedUsers(int _nObjType, int _nObjId)
获取共享用户

Groups

IChannelService.getSiteGroups(WebSite _site, WCMFilter _filter)
获取指定站点的所属用户组集合

Roles

IChannelService.getSiteRoles(WebSite _site, WCMFilter _filter)
获取指定站点的所属角色集合

Users

IChannelService.getSiteUsers(WebSite _currSite, WCMFilter _currFilter)
获取指定站点的所属用户集合

StatFieldMaps

IStatService.getStatFieldsByView(int _nStatViewId)
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别

StatHosts

IStatService.getStatHosts(WCMFilter _filter)
获得系统中提供的所有统计主体

CMyResultSets

IStatService.getStatResult(int _nStatTempId)
获得一个统计模板对应的所有结果

CMyResultSets

IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate)
统计在一个时间段内，某个统计的结果

CMyResultSets

IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)
统计在一个时间段内，符合特定条件的某个统计的结果

CMyResultSets

IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)

CMyResultSets

IStatService.getStatResult(java.lang.String _sqlStat, java.lang.String _sId)
进行用户定制的统计并返回统计结果

StatViews

IStatService.getStatViews(java.lang.String _sStatHostName, int _StatViewType, WCMFilter _filter)
获得特定查询主体的统计视图模板

FlowDocs

IWCMProcessService.getSubmitFlowDocs(User _operator, WCMFilter _filter)
获取用户[_operator]已经呈送的信息

DataType[]

IDBService.getSupportedDataTypes()

Channels

IChannelService.getSynSrcChannel(Channel _currChannel)
获取给当前频道分发文档的频道集合

Channels

IChannelService.getSynToChannel(Channel _currChannel)
获取当前频道分发文档的目标频道集合

java.lang.String

ICDSService.getSystemInfo(java.lang.String _sCDSType, int _nParentSiteId, int _nParentChannelId)
根据CDS传入的参数，获取指定的系统信息

java.lang.String

ICDSService.getSystemInfo(java.lang.String _sCDSType, int _nParentSiteId, int _nParentChannelId, java.lang.String _sSiteFields, java.lang.String _sChannelFields)
根据CDS传入的参数，获取指定的系统信息

TemplateArguments

ITemplateService.getTemplateArguments(IPublishElement _element)
返回指定发布对象上的全部有效模板参数列表

java.util.List

ITemplateService.getTemplateEmployers(Template _currTemplate)
获取使用到当前模板的所有对象集合

java.util.List

ITemplateService.getTemplateEmployers(Template _currTemplate, int _nEmployerType)
获取使用到当前模板的指定类型的对象集合

TemplateParameterList

ITemplateService.getTemplateParameters(IPublishElement _element)
返回指定发布对象使用的所有模板中的全部形式参数列表

TemplateParameterList

ITemplateService.getTemplateParameters(IPublishElement _element, boolean zRecursion)
返回指定发布对象使用的所有模板中的全部形式参数列表

Templates

IRecentService.getTemplates(WCMFilter _aFilter)
返回用户最近访问的模板列表
按照访问的时间顺序排序

Templates

ITemplateService.getTemplatesNested(Template _currTemplate)
获取嵌套了当前模板的所有模板

Documents

IDocumentService.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter)
获得特定频道下已设置为置顶的所有文档

int

IDocumentService.getTopPosition(Document _currDocument, Channel _currChannel)
得到当前频道下的特定文档的置顶位置

CMyDateTime

IDocumentService.getTopTime(Document _currDocument, Channel _currChannel)
获得文档置顶的截止时间
如果文档没有置顶，则直接返回null
如果置顶文档没有设置截止时间则返回null

Users

IGroupService.getUsers(Group _dstGroup, WCMFilter _filter)
获取指定组中的所有用户

Users

IGroupService.getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildren)

Users

IUserService.getUsers(int _nUserRegStatus, WCMFilter _filter)
获取系统中的某个注册状态的所有用户

Users

IRoleService.getUsers(Role _dstRole, WCMFilter _filter)
获取指定角色的所有用户

WebSites

IChannelService.getUserSites(User _currUser, WCMFilter _currFilter)
获取指定用户所属的站点集合

WebSites

ICustomizeService.getWebSites()
获取个人定制的站点集合

WebSites

IChannelService.getWebSites(WCMFilter _filter)
获取当前用户可以看见的站点

WebSites

IRecentService.getWebSites(WCMFilter _aFilter)
返回用户最近访问的站点列表
按照访问的时间顺序排序

boolean

ICustomizeService.hasCustomized()
当前用户是否有个性化定制

Reports

IDocumentService.importDocuments(java.lang.String _sImportFile, int _nDstChnlId, java.lang.String _sXSLFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel)
从文件中导入文档
支持从zip,xml,html,htm文件导入

Reports

IWCMProcessService.importFlows(java.lang.String _sImportFile)
从XML文件中导入工作流配置.

Reports

IWCMProcessService.importFlows(java.lang.String _sImportFile, java.lang.String _sXslFile)
从XML文件中导入工作流配置.

Reports

IChannelService.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl)
从zip/xml文件中导入站点/频道

Reports

ITemplateService.importFromHTML(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName)
从html文件导入模板

Reports

ITemplateService.importFromZip(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected)
从zip文件中导入模板

Reports

IDocumentService.importTRSDocuments(java.lang.String _sImportFile, int _nDestChannelId, java.lang.String _sDefineXmlFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel)
从TRS文件中导入文档
支持从zip,xml,html,htm文件导入

java.lang.Object

IInfoViewInitor.init(InfoViewContext _oContext)

boolean

IUserService.isAdminOfGroup(User _user)
判断指定用户是否在系统中担任组管理员

boolean

IWCMProcessService.isCanInFlow(int _nContentType, int _nContentId)

boolean

IDocumentService.isDocumentTopped(Document _currDocument, Channel _currChannel)
判断一个频道下的文档是否是处于置顶状态
应用层可以利用这个接口，在文档列表前加上图片标识

boolean

IDocumentService.isDocumentTopScheduled(Document _currDocument, Channel _currChannel)
判断频道下的文档如果置顶的话，是否已经加入了计划调度

boolean

IUserService.isManagerOfRole(User _user)
判断指定用户是否在系统中担任角色维护员

boolean

IChannelService.isVisible(User _currUser, BaseChannel _currChannel)
判断指定的频道对象对于用户是否可见

boolean

IChannelService.isVisible(User _currUser, BaseChannel _currChannel, int _nRightIndex)
判断在指定的权限值下，指定的频道对象对于用户是否可见

Appendix

ISureformService.makeAppendix(java.lang.String _sFormFile)
根据书生表单数据，构造一个文档附件
规则是先将数据打包成为一个在WebPic下的文件，然后做成附件并构造List返回
注意返回后，需要将DocId设置上，否则保存附件时会报错

void

IDocumentService.mirrorTo(Document _currDocument, Channel _toChannel)
将文档在另一个频道中建立一个同源异现的镜像

Reports

IDocumentService.mirrorTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)
将一组文档镜像转发到多个目标频道下
一般这样的操作是在文档列表页面执行的

Reports

IDocumentService.mirrorTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)
镜像转发频道文档集合
将一堆文档镜像转发到某个频道 一堆文档可以是一个检索的结果

void

IDocumentService.moveBackward(int _currDocumentId, int _currChannelId)
将文档向后移动一位
需要将两篇文档对换顺序
如果文档已经是最后一篇，则不移动
置顶区域中的文档不能移动

void

IBookMarkService.moveBookMark(int _nBookMarkId, int _nMarkKindId)
移动指定书签到目标书签文件夹下

void

IBookMarkService.moveBookMark(java.lang.String _sBookMarkIds, int _nMarkKindId)
移动指定书签集合到目标书签文件夹下

Reports

IBookMarkService.moveBookMarks(java.lang.String _sMarkIds, int _nMarkKindId)
移动指定的书签集合到目标书签夹下.

void

IDocumentService.moveDocumentInChannel(int _fromDocumentId, int _toDocumentId, int _currChannelId)
在频道中移动文档的顺序
如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档

void

IDocumentService.moveDocumentInChannel(int _fromDocumentId, int _toDocumentId, int _currChannelId, int _nPostionCode)

void

IDocumentService.moveFirst(int _currDocumentId, int _currChannelInt)
将文档移动到频道内第一的位置
需要将该移动文档前面的所有文档后移一位
如果文档已经是第一篇，则不移动
移动后的文档不进入置顶区域，是置顶区后的第一篇
置顶区域中的文档也不能移动

void

IDocumentService.moveForward(int _currDocumentId, int _currChannelId)
将文档向前移动一位
需要将两篇文档对换顺序
如果文档已经是第一篇，则不移动
移动后的文档不进入置顶区域，是置顶区后的第一篇
置顶区域中的文档也不能移动

void

IDocumentService.moveLast(int _currDocumentId, int _currChannelId)
将文档移动到最后的位置
需要将该移动文档后面的所有文档向前移一位
如果文档已经是最后一篇，则不移动
置顶区域中的文档也不能移动

void

IBookMarkService.moveMarkKind(int _nMarkKindId, int _nNewParentId)
移动指定书签文件夹到一个新的书签文件夹下

void

IBookMarkService.moveMarkKind(java.lang.String _sMarkKindIds, int _nNewParentId)
移动指定书签文件夹集合到一个新的书签文件夹下

void

IChannelService.moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType)
将频道移动到另一个频道下，作为该频道的子频道或者兄弟

void

IChannelService.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType)
将频道移动到站点下，作为站点的一级子频道

Group

IGroupService.moveTo(Group _fromGroup, Group _toGroup)
移动组织，将一个组织移动到另一个组织下

Reports

IDocumentService.moveTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)
将文档从指定的频道移动到多个目标频道下
一般这样的操作是在文档列表页面执行的

Reports

IDocumentService.moveTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)
移动文档集合
将一堆文档移动到某个频道 一堆文档可以是一个检索的结果

void

IChannelService.moveTo(WebSite _fromWebSite, WebSite _toWebSite, int _nMoveToType)
将站点移动到另一个站点下，作为该站点的子站点或者兄弟

boolean

IGroupService.moveUser(User _userToMove, Group _srcGroup, Group _dstGroup)
将指定用户从某个组移动到指定的另外一个组中

boolean

IGroupService.moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups)
将指定的用户从某个组移动到指定的多个组中

void

IPublishService.pauseTask(java.lang.String _sTaskIds)
暂停指定的发布任务集合，对其中不处于执行状态的任务不会产生影响

java.lang.String[]

IPublishService.preview(BaseChannel _siteOrChannel, java.lang.String[] _warningsHolder)
预览指定的站点/频道，并返回预览页面的URL列表（若配置了多个概览模板，则可能有多个）。

java.lang.String

IPublishService.preview(Document _document, Channel _channel, java.lang.String[] _warningsHolder)
在指定的频道上预览文档，并返回预览页面的URL。

java.lang.String

IPublishService.preview(Document _document, java.lang.String[] _warningsHolder)
在文档的存放点上预览文档，并返回预览页面的URL。

java.lang.String

ITemplateService.preview(int _nTemplateId)
预览指定id的模板

java.lang.String

ITemplateService.preview(Template _currTemplate)
预览指定的模板

java.lang.String

IPublishService.previewInfoviewPrint(Document _document, Channel _channel, java.lang.String[] _waringsHolder, int _templateId)

void

IPublishService.publishConfirm(BaseChannel _oSiteOrChnl, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile)
确认（批准）发布 用于先将站点或频道的首页发布到一个临时文件，在确认没有错误后，再把临时文件重名为正式的站点或频道首页。

void

IPublishService.publishForcibly(int _nDocumentId, java.lang.String _sChannelIds)
强制在指定的频道中发布文档， 如果文档在指定的频道中状态为不允许发布状态，将会自动改为可发布的状态，然后再发不

Reports

IDocumentService.quoteTo(Document _currDocument, java.lang.String _sToChannelIds)
维护单篇文档的引用转发关系
将单篇文档引用转发到目标频道列表中
一般用于在文档采编页面中，设置一篇文档的引用转发
这里的维护中包括删除所有无用的引用转发关系

Reports

IDocumentService.quoteTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String sToChannelIds)
将一组文档转发（引用转发）到多个目标频道下
一般这样的操作是在文档列表页面执行的

Reports

IDocumentService.quoteTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)
引用转发频道文档集合
将一堆频道文档移动到某个频道 一堆文档可以是一个检索的结果

void

IInfoViewService.rebuildXSLT(InfoView _oInfoView)

void

IInfoViewService.rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)

Document

IDocumentService.recoverDocument(DocBak _aDocBak, Document _currDocument)
从文档备份版本中恢复文档

Reports

ITemplateService.redistributeAppendixes(CMSObj _chnlOrSite, boolean _zRecursive)
重新分发指定站点或者频道下的所有模板的附件，并且如果_zRecursive 为true ，则会进一步地重新分发子频道下的模板的附件。

void

IPublishService.redoTasks(java.lang.String _sTaskIds)
重新执行指定的发布任务集合

void

IAutoDocBakService.removeConfig(int _nSiteId)
删除指定站点上所有关于文档版本自动保存的配置信息

void

IContactService.removeContact(Contact _contact, ContactGrp _contactGroup)
将指定的联系人从指定的联系人分组中删除

void

IContactService.removeContact(int _nContactId, int _nContactGrpId)
将指定的联系人从指定的联系人分组中删除

void

IContactService.removeContacts(java.lang.String _sContactIds, int _nContactGrpId)
将指定的联系人从指定的联系人分组中删除

void

IChannelService.removeGroupsFromSite(java.lang.String _sGroupIds, WebSite _site)
删除指定的站点中的指定用户组

boolean

IGroupService.removeManager(User _adminToCancel, Group _dstGroup)
取消指定用户在某个组的管理员身份
注意: 指定的用户必须在指定组中

void

IChannelService.removeRolesFromSite(java.lang.String _sRoleIds, WebSite _site)

void

IChannelService.removeSitesFromGroup(java.lang.String _sSiteIds, Group _group)
删除指定的用户组上指定的站点

void

IChannelService.removeSitesFromUser(java.lang.String _sSiteIds, User _currUser)
删除指定的用户上指定的站点

void

IDocumentService.removeToppedDocument(Document _currDocument, Channel _currChannel)
取消特定频道下某文档的置顶标志
该文档将成为普通文档
注意，不是删除文档！

boolean

IGroupService.removeUser(User _userToRemove, Group _dstGroup)
将指定组从指定的组中删除

boolean

IGroupService.removeUser(User _userToRemove, Group _dstGroup, boolean _bRemoveOffspring)

boolean

IRoleService.removeUser(User _dstUser, Role _fromRole)
从指定的角色中删除指定的用户

void

IChannelService.removeUsersFromSite(java.lang.String _sUserIds, WebSite _currSite)
删除指定的站点中的指定用户

boolean

IUserService.resetPassword(User _dstUser)
重设指定用户的密码为缺省值(只能由系统管理员操作)

boolean

IUserService.resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword)
重设指定用户的登录密码

void

IChannelService.restore(BaseChannel _oChannel)
恢复站点/频道

void

IChannelService.restore(Channels _currChannels)
恢复频道集合

void

IDocumentService.restore(Document _currDocument, Channel _currChannel)
恢复回收站中的文档

void

IDocumentService.restore(Documents _documents)
批量恢复回收站中的文档

Reports

IDocumentService.restore(java.lang.String _sDelDocIds, int _nChannelId)
批量恢复回收站中的文档

boolean

IUserService.restore(User _userToRestore)
恢复已删除的用户

boolean

IUserService.restore(Users _usersToRestore)
恢复已删除的用户集合

void

IChannelService.restore(WebSites _currSites)
恢复站点集合

void

IChannelService.restoreAllInRecycleBin(int _nChannelId)
还原指定频道回收站中的所有文档

void

IPublishService.resumeTask(java.lang.String _sTaskIds)
恢复指定的发布任务集合，对其中不处于暂停状态的任务不会产生影响

AutoBakConfig

IAutoDocBakService.save(AutoBakConfig _currConfig)
保存站点上关于文档版本自动保存的配置信息

BaseChannel

IChannelService.save(BaseChannel _currBaseChannel)
保存指定的站点/频道

WCMFolderPublishConfig

IWCMPublishElementService.save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig)
保存当前站点或频道的发布配置信息

BookMark

IBookMarkService.save(BookMark _aBookMark)
保存一个BookMark

CMSObj

IResourceService.save(CMSObj _currObjToSave)
保存资源配置

Document

IDocumentService.save(Document _aDocument, java.util.List _aAppendixList, java.util.List _aRelationList)
添加文档、修改文档时的保存操作 由于对对象进行了重新划分，将AppendixList等从Document对象中提取出来
保持了Document对象和各个对象的独立性

Document

IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, int _nFlowdocId)

Document

IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo)

Document

IDocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.lang.String _sFlowContextInfo)

Event

IEventService.save(Event _aEvent)
保存一个Event

Group

IGroupService.save(Group _dstGroup)
保存指定的组织

void

IInfoViewService.save(InfoView _oInfoView)
保存指定的自定义表单

void

IInfoViewService.save(InfoViewField _oField)
保存指定的自定义表单字段

void

IInfoViewService.save(InfoViewGroup _oGroup)
保存指定的自定义表单数据节

void

IInfoViewService.save(InfoViewView _oView)
保存指定的自定义表单视图

boolean

ICustomizeService.save(int _nMoudelType)
保存当前登录用户定制的模块

MarkKind

IBookMarkService.save(MarkKind _aMarkKind)
保存一个MarkKind

Role

IRoleService.save(Role _roleToSave)
保存指定的角色

Template

ITemplateService.save(Template _currTemplateToSave)
保存模板，包括新增和修改，此接口一般用于从源代码方式下保存模板

Template

ITemplateService.save(Template _currTemplateToSave, boolean _bDowithAppendix, int _nPicMode)
保存模板，包括新增和修改

User

IUserService.save(User _userToSave)
保存一个用户

User

IUserService.save(User _userToSave, Group _currGrp)

PublishDistribution

IWCMPublishElementService.save(WebSite _currSite, PublishDistribution _currPublishDistribution)
保存当前站点所设置的分发目录

boolean

ICustomizeService.saveChannels(java.lang.String _sChannelIds)
保存个人定制的频道

ChannelSyn

IChannelService.saveChannelSyn(ChannelSyn _currChnlSyn)

ChannelSyns

IChannelService.saveChannelSyns(ChannelSyn _currChnlSyn, java.lang.String _sToChannelIds)

Contact

IContactService.saveContact(Contact _contact)
保存一个联系人

ContactGrp

IContactService.saveContactGroup(ContactGrp _contactGrp)
保存一个联系人分组

ContentLink

IChannelService.saveContentLink(ContentLink _contentLink)

ContentExtField

IChannelService.saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited)
保存指定的扩展字段

Reports

IWCMProcessService.saveFlow(java.lang.String _sFlowXML)

Document

IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc)

Document

IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.util.Map _hFlowContextInfo)

Document

IDocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.lang.String _sFlowContextInfo)

Document

IDocumentService.saveInfoViewDocument(Document _document, InfoView _infoView, java.util.Map _infoViewData)

void

ISecurityService.saveKey(SecureKey _oKey)
保存指定的密钥

Schedule

IScheduleService.savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel)
给指定的站点或频道设置计划发布属性

Schedule

IScheduleService.savePublishSchedule(Schedule _currSchedule, Document _currDocument)
给指定的文档设置计划发布属性

Replace

IChannelService.saveReplace(Replace _aReplace)
保存替换内容对象

boolean

ICustomizeService.saveSites(int[] _nArgSiteId)
保存个人定制的站点集合

StatHost

IStatService.saveStatHost(StatHost _currStatHost)
保存统计主体（即按xxx查询）

StatView

IStatService.saveStatView(StatView _currStatView, java.util.List _fieldMapList)
保存统计视图模板
其中包括保存视图模板和字段列表

TemplateArgument

ITemplateService.saveTemplateArgument(TemplateArgument _argument)
保存指定的TemplateArgument对象

void

IInfoViewService.saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)

void

IInfoViewService.sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage)
发送表单文档的回复通知
优先使用表单上的设置

void

IInfoViewService.sendReplyNotice(int _iInfoViewId, int _iDocumentId, int _iDocReplyId, boolean _zSendEmail, boolean _zSendMessage)
发送表单文档的回复通知
优先使用表单上的设置

void

ICustomizeService.setCustomizedChannels(java.lang.String _sChannelIds)
设置定制的频道

void

ITemplateService.setDetailTemplate(IPublishContent _content, int _nTemplateId)

void

ITemplateService.setDetailTemplate(IPublishContent _content, int _nTemplateId, int _nDetailTemplateType)
为指定文档设定模板

void

ITemplateService.setDetailTemplate(IPublishFolder _folder, int _nTemplateId, boolean _bResetChildren)
为指定频道设定细览模板

void

IInfoViewService.setEmployedInfoView(CMSObj _employer, InfoView _oInfoView)
设置雇主（通常是频道）雇佣的自定义表单的ID列表

void

IInfoViewService.setEmployedInfoViews(CMSObj _employer, java.lang.String _sInfoViewIDs)
设置雇主（通常是频道）雇佣的自定义表单的ID列表

void

IInfoViewService.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadonly)

void

IWCMProcessService.setFlowEmploy(BaseObj _employer, int _nFlowId)

boolean

IGroupService.setGroupUsers(int _nDstGroupId, java.lang.String _sUserIdsToAdd)
维护指定用户组的用户列表

void

ITemplateService.setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren)
为指定频道设定概览模板

void

IWCMPublishElementService.setPubDistributionsEnable(WebSite _currSite, java.lang.String _sPublishDistributionIds, boolean _bEnable)
将当前站点的指定分发信息设置为无效

void

IRoleService.setRoleUsers(int _nDstRoleId, java.lang.String _sUserIdsToAdd)

void

IChannelService.setSiteMembers(int _nSiteId, int _nMemberType, java.lang.String _sMemberIds)
设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

void

IChannelService.setSiteMembers(WebSite _site, int _nMemberType, java.lang.String _sMemberIds)
设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

void

IStatService.setStatViewRelation(int _nMainViewId, java.lang.String _sEmbeddedViewIds)
设置模板视图和嵌入视图的关联关系

void

IStatService.setStatViewRelation(StatView _mainView, StatViews _embeddedViews)
设置模板视图和嵌入视图的关联关系

void

IDocumentService.setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil)
将特定频道下的一篇文档设置为置顶

void

IEventService.shareTo(Event _aEvent, Group _assignToGroup)
当前用户把一个Event指派给一个组织

void

IEventService.shareTo(Event _aEvent, Groups _assignToGroups)

void

IEventService.shareTo(Event _aEvent, java.lang.String _sUserIds)

void

IEventService.shareTo(Event _aEvent, User _assignToUser)
当前用户把一个Event指派给另外一个用户

void

IEventService.shareTo(Event _aEvent, Users _assignToUsers)
把一个Event指派给一个用户集合

void

IBookMarkService.shareTo(int _nObjType, java.lang.String _sObjIds, int _nShareObjType, java.lang.String _sShareObjIds)
设置共享

byte[]

ISecurityService.sign(java.lang.String sKeyName, byte[] data)
使用指定名称的密钥计算指定的数据的签名

FlowDoc

IWCMProcessService.startContentInFlow(int _nContentType, int _nContentId)

void

IWCMProcessService.submitAgain(User _postUser, int _nFlowDocId, java.lang.String _sOpinion)

void

IWCMProcessService.submitBack(User _postUser, java.lang.String _sFromFlowDocId, java.lang.String _sOpinion)
指定的用户将指定的工作事项打回

void

IWCMProcessService.submitTo(FlowParamers _currParamerts)
将内容按照指定的方式呈送

boolean

IStatService.testStatView(int _nStatViewId)
测试特定的统计模板是否能够运行通过

java.lang.String

IWCMProcessService.toFlowsXMLString(java.lang.String _sFlowIds)

java.lang.String

IWCMProcessService.toFlowXMLString(Flow _currFlow)

boolean

ISecurityService.verify(java.lang.String sKeyName, byte[] data, byte[] sign)
使用指定名称的密钥，验证指定数据和签名是否相符

void

IDocumentService.withdraw(Document _currDocument)
撤稿 ?

com.trs.service.impl 中 WCMException 的使用

抛出 WCMException 的 com.trs.service.impl 中的方法

boolean

RecentService.add(int _nObjType, int _nObjId)

boolean

RecentService.add(int _nObjType, java.lang.String _sObjIds)

boolean

RecentService.addChnlDoc(int _nChannelId, int _nDocumentId)

Contact

ContactService.addContact(Contact _contact, ContactGrp _contactGroup)

Contact

ContactService.addContact(int _nContactId, int _nContactGrpId)

void

ContactService.addContact(java.lang.String _sContactIds, int _nContactGrpId)

Contact

ContactService.addContactFromSystemUser(int _nUserId)

Contact

ContactService.addContactFromSystemUser(User _user)

void

ChannelService.addGroupsToSite(java.lang.String _sGroupIds, WebSite _site)

boolean

GroupService.addManager(User _adminToAdd, Group _dstGroup)

void

ChannelService.addRolesToSite(java.lang.String _sRoleIds, WebSite _site)

void

ChannelService.addSitesToGroup(java.lang.String _sSiteIds, Group _group)

void

ChannelService.addSitesToUser(java.lang.String _sSiteIds, User _currUser)

boolean

GroupService.addUser(User _userToAdd, Group _dstGroup)

User

RoleService.addUser(User _dstUser, Role _toRole)

void

ChannelService.addUsersToSite(java.lang.String _sUserIds, WebSite _currSite)

DocBak

DocumentService.backup(Document _currDocument)

void

EventService.cancelShare(Event _aEvent, Group _assignToGroup)

void

EventService.cancelShare(Event _aEvent, User _assignToUser)

void

EventService.cancelShare(Event _aEvent, Users _assignToUsers)

void

EventService.cancelShares(Event _aEvent)

void

BookMarkService.cancelShares(int _nObjType, java.lang.String _sObjIds)

void

PublishService.cancelTasks(java.lang.String _sTaskIds)

void

DocumentService.changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus)

void

DocumentService.changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus)

void

ContactService.changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup)

void

ContactService.changeGroup(int _nContactId, int _nSrcGroupId, int _nDestGroupId)

void

StatService.clearStatResult(int _nStatViewId)

Reports

DocumentService.copyTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)

Reports

DocumentService.copyTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)

Reports

ChannelService.createFrom(Channel _srcChannel, BaseChannel _parent)

Reports

ChannelService.createFrom(int _nChannelId, BaseChannel _parent)

Reports

ChannelService.createFrom(int _nSiteId, boolean _bWithRelated)

Reports

ChannelService.createFrom(WebSite _srcSite, boolean _bWithRelated)

byte[]

SecurityService.decrypt(java.lang.String sKeyName, byte[] bytes)

void

PublishService.delete(BaseChannel _siteOrChannel)
已过时。 根本就没有没有使用，声明为废弃的，以标识

boolean

ChannelService.delete(BaseChannel _oChannel, boolean _bDrop)
删除站点/频道

boolean

ChannelService.delete(Channels _currChannels, boolean _bDrop)
删除频道集合

boolean

DocumentService.delete(ChnlDocs _delChnlDocs, boolean _bDrop)

boolean

ResouceService.delete(CMSObj _currObjToDelete)

void

PublishService.delete(Document _document)
已过时。 根本就没有没有使用，声明为废弃的，以标识

void

PublishService.delete(Document _document, Channel _channel)
已过时。 根本就没有没有使用，声明为废弃的，以标识

boolean

DocumentService.delete(Document _currDocument, Channel _currChannel, boolean _bDrop)

void

PublishService.delete(Documents _documents)
已过时。 根本就没有没有使用，声明为废弃的，以标识

void

PublishService.delete(Documents _documents, Channel _channel)

boolean

DocumentService.delete(Documents _currDocuments, Channel _currChannel, boolean _bDrop)

boolean

EventService.delete(Event _aEvent)

boolean

EventService.delete(Events _anEvents)

boolean

GroupService.delete(Group _groupToDelete)

boolean

GroupService.delete(Groups _groupsToDelete)

void

InfoViewService.delete(InfoView _oInfoView)

void

InfoViewService.delete(InfoViews _oInfoViews)

void

InfoViewService.delete(int _iInfoViewID)

boolean

EventService.delete(int _nEventId)

boolean

GroupService.delete(int _nGroupId)

boolean

CustomizeService.delete(int _nMoudelType)

boolean

RoleService.delete(int _nDelRoleId)

boolean

TemplateService.delete(int _nDelTemplateId)

boolean

UserService.delete(int _nUserId, boolean _bDrop)

boolean

DocumentService.delete(int _nDocumentId, Channel _currChannel, boolean _bDrop)

boolean

RoleService.delete(Role _roleToDelete)

boolean

RoleService.delete(Roles _rolesToDelete)

void

InfoViewService.delete(java.lang.String _sInfoViewIDs)

boolean

EventService.delete(java.lang.String _sIds)

boolean

GroupService.delete(java.lang.String _sGroupIds)

boolean

RoleService.delete(java.lang.String _sDelRoleIds)

boolean

TemplateService.delete(java.lang.String _sDelTemplateIds)

boolean

ChannelService.delete(java.lang.String _sChannelIds, boolean _bDrop)
根据频道id列表，删除频道集合

boolean

UserService.delete(java.lang.String _sUserIds, boolean _bDrop)

boolean

DocumentService.delete(java.lang.String _sDocumentIds, Channel _currChannel, boolean _bDrop)

boolean

TemplateService.delete(Template _template)

boolean

TemplateService.delete(Templates _currTemplatesToDelete)

boolean

UserService.delete(User _userToDelete, boolean _bDrop)

boolean

UserService.delete(Users _usersToDelete, boolean _bDrop)

boolean

BookMarkService.deleteBookMark(int _nBookMarkId)

boolean

BookMarkService.deleteBookMark(java.lang.String _sBookMarkIds)

boolean

CustomizeService.deleteChannels(int[] _nArgChannelId)

void

ChannelService.deleteChannelSyn(int _nChnlSynId)

void

ChannelService.deleteChannelSyns(java.lang.String _sChnlSynIds)

void

ContactService.deleteContact(Contact _contact)

void

ContactService.deleteContact(int _nContactId)

void

ContactService.deleteContactGroup(ContactGrp _contactGroup)

void

ContactService.deleteContactGroup(int _nContactGroupId)

void

ContactService.deleteContactGroups(ContactGrps _contactGroups)

void

ContactService.deleteContactGroups(java.lang.String _sContactGroupIds)

void

ContactService.deleteContacts(Contacts _contacts)

void

ContactService.deleteContacts(java.lang.String _sContactIds)

void

ChannelService.deleteContentLink(ContentLink _contentLink)

void

ChannelService.deleteContentLinks(ContentLinks _contentLinks)

void

DocumentService.deleteDocBak(DocBak _docbak)

void

DocumentService.deleteDocBak(int _nDocBakId)

void

DocumentService.deleteDocBaks(DocBaks _docbaks)

void

DocumentService.deleteDocBaks(java.lang.String _sDocBakIds)

void

ChannelService.deleteExtFields(BaseChannel _siteOrChannel, java.lang.String _extFieldIds, boolean _bDeleteInherited)
删除指定站点/频道下的指定扩展字段

void

ChannelService.deleteExtFiled(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bDeleteInherited)
删除指定站点/频道下的指定扩展字段

void

WCMProcessServiceImpl.deleteFlows(java.lang.String _sFlowIds)

void

SecurityService.deleteKey(int _toDeleteId)

void

SecurityService.deleteKey(java.lang.String _toDeleteIds)

void

SecurityService.deleteKeyByName(java.lang.String _toDeleteName)

boolean

BookMarkService.deleteMarkKind(int _nMarkKindId)

boolean

BookMarkService.deleteMarkKind(java.lang.String _sBookMarkIds)

void

WCMPublishElementServiceImpl.deletePublishDistributions(WebSite _currSite, java.lang.String _sPublishDistributionIds)

Schedule

ScheduleService.deletePublishSchedule(BaseChannel _currChannel)

Schedule

ScheduleService.deletePublishSchedule(Document _currDocument)

boolean

ChannelService.deleteReplace(Replace _aReplace)

boolean

ChannelService.deleteReplace(Replaces _aReplaces)

boolean

CustomizeService.deleteSites(int[] _nArgSiteId)

Reports

StatService.deleteStatHosts(java.lang.String _sDelStatHostIds)

Reports

StatService.deleteStatView(int _nStatViewId)

Reports

StatService.deleteStatView(StatView _delStatView)

Reports

StatService.deleteStatViews(java.lang.String _sStatViewIds)

void

PublishService.deleteTasks(java.lang.String _sTaskIds)

boolean

TemplateService.deleteTemplateArgument(TemplateArgument _argument)

void

TemplateService.deleteTemplateArguments(TemplateArguments _arguments)

byte[]

SecurityService.digest(java.lang.String sAlgorithm, byte[] data)

boolean

UserService.disable(int _nUserId)

boolean

UserService.disable(User _userToDisable)

void

SureformService.distributeSureformFile(int _nChannelId)

void

SecurityService.doDecrypt(java.lang.String sKeyName, java.io.InputStream is, java.io.OutputStream os)

byte[]

SecurityService.doDigest(java.lang.String sAlgorithm, java.io.InputStream is)

void

SecurityService.doEncrypt(java.lang.String sKeyName, java.io.InputStream is, java.io.OutputStream os)

byte[]

SecurityService.doSign(java.lang.String sKeyName, java.io.InputStream is)

boolean

SecurityService.doVerify(java.lang.String sKeyName, java.io.InputStream is, byte[] sign)

void

ChannelService.emptyRecycleBin(int _nChannelId)
清空指定频道的文档回收站
删除指定频道回收站中的所有文档.

boolean

UserService.enable(int _nUserId)

boolean

UserService.enable(User _userToEnable)

byte[]

SecurityService.encrypt(java.lang.String sKeyName, byte[] bytes)

java.lang.Object

InfoViewEnumCreatorImpl.enumScript(InfoViewContext _oContext)

java.lang.String

ChannelService.export(BaseChannel _fromChannel, boolean _bWithChildren, boolean _bWithRelated)

java.lang.String

ChannelService.export(Channels _fromChannels, boolean _bWithChildren, boolean _bWithRelated)

java.lang.String

DocumentService.export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes)

java.lang.String

DocumentService.export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes)

java.lang.String

TemplateService.export(int _nTemplateId)

java.lang.String

DocumentService.export(int _nDocId, java.lang.String _sFieldsList, boolean _bWithAppendixes)

java.lang.String

TemplateService.export(java.lang.String _sTemplateIds)

java.lang.String

DocumentService.export(java.lang.String _sDocIds, java.lang.String _sFieldsList, boolean _bWithAppendixes)

java.lang.String

DocumentService.export(java.lang.String _sDocIds, java.lang.String _sFieldsList, boolean _bWithAppendixes, boolean _bWithExtFields)

java.lang.String

TemplateService.export(Template _currTemplate)

java.lang.String

TemplateService.export(Templates _currTemplates)

java.lang.String

ChannelService.export(WebSites _fromWebSites, boolean _bWithChildren, boolean _bWithRelated)

java.lang.String

ChannelService.exportChannels(java.lang.String _sChnlIds, boolean _bWithChildren, boolean _bWithRelated)

java.lang.String

WCMProcessServiceImpl.exportFlow(int _nFlowId)

java.lang.String

WCMProcessServiceImpl.exportFlows(java.lang.String _sFlowIds)

java.lang.String

SecurityService.exportKey(boolean _zIsPrivate, int iKeyId)

java.lang.String

SecurityService.exportKey(boolean _zIsPrivate, java.lang.String sKeyName)

byte[]

SecurityService.exportKey(int _toExportId, boolean _zIsPrivate)

byte[]

SecurityService.exportKey(java.lang.String _toExportName, boolean _zIsPrivate)

void

SecurityService.exportKey(java.lang.String _toExportIds, java.io.Writer _writer)

void

SecurityService.exportKey(java.io.Writer _writer)

java.lang.String

ChannelService.exportSites(java.lang.String _sSiteIds, boolean _bWithChildren, boolean _bWithRelated)

java.util.List

SecurityService.extractKey(java.io.File _oXMLFile, java.lang.String _encoding)

java.util.List

SecurityService.extractKey(java.io.Reader _oXMLReader)

java.lang.String[]

TemplateService.extractTemplateNamesFromZip(java.lang.String _sZipFileName)

java.lang.String

InfoViewService.filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int nFlowDocId)

InfoView

InfoViewService.findById(int _iInfoViewID)

Template

TemplateService.findByName(int _nSiteId, java.lang.String _sTempName)

ChnlDoc

DocumentService.findChnldoc(int _currDocumentId, int _currChannelId)

WCMFolderPublishConfig

WCMPublishElementServiceImpl.findFolderConfig(BaseChannel _currChannel)

SecureKey

SecurityService.findKey(int _iKeyId)

SecureKey

SecurityService.findKey(java.lang.String _iKeyName)

PublishDistributions

WCMPublishElementServiceImpl.findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter)

Schedule

ScheduleService.findPublishSchedule(BaseChannel _currChannel)

Schedule

ScheduleService.findPublishSchedule(Document _currDocument)

StatView

StatService.findStatViewByName(java.lang.String _sName)

InfoViewView

InfoViewService.findViewById(int _iViewID)

void

WCMProcessServiceImpl.forceContentEndInFlow(int _nContentType, int _nContentId)

java.lang.String

InfoViewService.forFillOut(InfoView _oInfoView, InfoViewView _oView)

java.lang.String

InfoViewService.forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int _flowDocId)

java.lang.String

InfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView)

java.lang.String

InfoViewService.forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)

void

StatService.generateTodayStat(int _nStatTempId)

Users

GroupService.getAdmins(Group _dstGroup)

java.lang.String

CDSServiceImpl.getAllChannelsXML(boolean _bIncludeChildren)

Documents

DocumentService.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)

PublishTasks

PublishService.getAllTasks(WCMFilter _filter)

Appendixes

DocumentService.getAppendixes(Document _currDocument)

Appendixes

DocumentService.getAppendixes(Document _currDocument, int _nAppendixType)

Appendixes

DocumentService.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter)

Appendixes

DocumentService.getAppendixes(Document _currDocument, WCMFilter _apdFilter)

java.util.List

InfoViewService.getAppendixList(org.dom4j.Document dom4jDocument)

java.util.List

InfoViewService.getAppendixList(java.lang.String xmlContent)

AutoBakConfig

AutoDocBakService.getAutoSaveConfig(int _nSiteId)

BookMarks

BookMarkService.getBookMarks(int _nMarkKindId)

BookMarks

BookMarkService.getBookMarks(int _nMarkKindId, WCMFilter _filter)

BookMarks

BookMarkService.getBookMarks(WCMFilter _filter)

Users

UserService.getCanMgrUsers(int _nUserRegStatus, WCMFilter _filter)
获取我所能管理的用户

Channels

CustomizeService.getChannels()

Channels

DocumentService.getChannels(Document _currDocument)

Channels

CustomizeService.getChannels(int _nRightIndex)

Channels

RecentService.getChannels(WCMFilter _aFilter)

Channels

RecentService.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted)

Channels

RecentService.getChannels(WCMFilter _filter, boolean _bIncludeDeleted, int _nRightIndex)

Channels

RecentService.getChannelsWithRight(WCMFilter _filter)

java.lang.String

CDSServiceImpl.getChannelsXML(BaseChannel _oBaseChannel, boolean _bIncludeChildren)

ChannelSyns

ChannelService.getChannelSyns(int _nChannelId, WCMFilter _filter)

java.util.List

ChannelService.getChildren(BaseChannel _oChannel)
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限

java.util.List

ChannelService.getChildren(BaseChannel _oChannel, int _nRightIndex)
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)

java.util.List

ChannelService.getChildren(BaseChannel _parentChannel, int _nRightIndex, int _nChannelType)
获取当前站点/频道的子频道集合(不包含已删除的子频道)

java.util.List

ChannelService.getChildren(BaseChannel _parentChannel, int _nRightIndex, int[] _nArrayChannelType)
获取当前站点/频道的子频道集合(不包含已删除的子频道)

java.util.List

ChannelService.getChildren(BaseChannel _parentChannel, int _nRightIndex, int[] _nArrayChannelType, java.lang.StringBuffer _sbNoRightIds)
获取当前站点/频道的子频道集合(不包含已删除的子频道)

Groups

GroupService.getChildren(Group _parentGroup)

Groups

GroupService.getChildren(Group _parentGroup, boolean _bContainsChild)

Groups

GroupService.getChildren(Group _parentGroup, boolean _bContainsChild, WCMFilter _filter)

MarkKinds

BookMarkService.getChildren(int _nMarkKindId, WCMFilter _filter)

ChnlDocs

RecentService.getChnlDocs(WCMFilter _aFilter)

ChnlDocs

RecentService.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted)

ContactGrps

ContactService.getContactGroups(WCMFilter _filter)

Contacts

ContactService.getContacts(WCMFilter _filter)

Contacts

ContactService.getContacts(WCMFilter _filter, ContactGrp _contactGroup)

ContentLinks

ChannelService.getContentLinks(WebSite _site, WCMFilter _filter)

CMyResultSets

StatService.getCurrentStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)

int

WCMProcessServiceImpl.getCurrFlowFlag(int _nContentType, int _nContentId)

java.lang.String

WCMProcessServiceImpl.getCurrFlowFlagDesc(int _nContentType, int _nContentId)

Template

TemplateService.getDetailTemplate(IPublishElement _publishElement)

DocBak

DocumentService.getDocBak(Document _currDocument, int _nVersion)

DocBaks

DocumentService.getDocBaks(Document _currDocument)

DocBaks

DocumentService.getDocBaks(Document _currDocument, WCMFilter _filter)

Documents

UserService.getDocuments()

Documents

ChannelService.getDocuments(BaseChannel _oChannel)
获取当前站点/频道下的有效文档

Documents

ChannelService.getDocuments(BaseChannel _oChannel, WCMFilter _docFilter)
获取当前站点/频道下的有效文档

Documents

ChannelService.getDocuments(int _nChnlId)
获取当前频道下的有效文档

Documents

ChannelService.getDocuments(int _nChnlId, WCMFilter _filter)
获取当前频道下的有效文档

Documents

RecentService.getDocuments(WCMFilter _aFilter)

Documents

UserService.getDocuments(WCMFilter _filter)

Documents

RecentService.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted)

java.lang.String

InfoViewService.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument)

java.lang.String

InfoViewService.getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument, java.lang.String sPostUserName)

java.lang.String

InfoViewService.getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent)

java.lang.String

InfoViewService.getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent, java.lang.String sPostUserName)

org.dom4j.Document

InfoViewService.getDOM4JDocument(java.lang.String xmlContent)

Documents

UserService.getDraft()

Documents

UserService.getDraft(WCMFilter _filter)

StatViews

StatService.getEmbeddedViews(int _nMainViewId)

java.util.List

InfoViewService.getEmployedInfoViews(CMSObj _employer)

java.util.List

InfoViewService.getEmployedInfoViews(int _iEmployerType, int _iEmployerId)

Events

EventService.getEvents(WCMFilter _filter)

java.io.File[]

DocumentService.getExitedMappingFiles()

java.io.File[]

DocumentService.getExitedXslFiles()

ContentExtFields

ChannelService.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)
获取指定站点/频道下的扩展字段.

java.lang.Object

InfoViewInitorImpl.getFieldValue(InfoViewContext _oContext, BindingBean _oBean)

java.lang.Object

SiteNameCreator.getFieldValue(InfoViewContext _context, BindingBean _bindingBean)

FlowDocs

WCMProcessServiceImpl.getFlowDocs(int _nFlag, WCMFilter _filter)

FlowDocs

WCMProcessServiceImpl.getFlowDocsOfContent(int _nContentType, int _nContentId)

Flow

WCMProcessServiceImpl.getFlowOfEmployer(BaseObj _employer)

Flows

WCMProcessServiceImpl.getFlows(WCMFilter _filter)

Groups

UserService.getGroups()

ContactGrps

ContactService.getGroups(Contact _contact)

Groups

UserService.getGroups(User _currUser)

java.lang.String

RecentService.getIds(int _nObjTypeId)

java.util.List

InfoViewService.getInfoViewEmployers(InfoView _employed)

java.util.List

InfoViewService.getInfoViewEmployers(int _iInfoViewID)

InfoViews

InfoViewService.getInfoViews(WCMFilter _filter)

java.lang.String

InfoViewService.getInfoViewSerial(InfoView _oInfoView)

java.lang.String

InfoViewService.getInfoViewSerial(int _iInfoViewId)

SecureKeys

SecurityService.getKeys(WCMFilter _filter)

Templates

TemplateService.getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren)

Channels

DocumentService.getMirrorChannels(Document _currDocument)

int[]

CustomizeService.getMoudels()

java.lang.String

DocumentService.getMyDocumentImportSourceFilePath()

PublishTasks

PublishService.getMyTasks(WCMFilter _filter)

Users

UserService.getMyUsers(int _nUserRegStatus, WCMFilter _filter)
获取我所创建的用户列表

Templates

TemplateService.getNestedTemplates(Template _template)

Templates

TemplateService.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent)

Templates

TemplateService.getOutlineTemplates(IPublishFolder _folder)

Channels

DocumentService.getQuoteChannels(Document _currDocument)

Channels

DocumentService.getQuoteChannels(int _nDocumentId)

Channels

ChannelService.getRecycleChannels(BaseChannel _oChannel)
获取当前站点/频道下的废弃频道集合

Channels

ChannelService.getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter)
获取当前站点/频道下的废弃频道集合

Documents

UserService.getRecycleDocuments()

Documents

DocumentService.getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter)

Documents

ChannelService.getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter)
获取当前站点/频道下的废稿

Documents

ChannelService.getRecycleDocuments(int _nChnlId)
获取当前频道下的废稿

Documents

ChannelService.getRecycleDocuments(int _nChnlId, WCMFilter _filter)
获取当前频道下的废稿

Documents

UserService.getRecycleDocuments(WCMFilter _filter)

WebSites

ChannelService.getRecycleSites(WCMFilter _filter)

Documents

DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich)

Documents

DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter)

Documents

DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites)

Relations

DocumentService.getRelations(Document _currDocument)

Replaces

ChannelService.getReplaces(Channel _oChannel, WCMFilter _filter)

Roles

UserService.getRoles()

Roles

UserService.getRoles(User _currUser)

BookMarks

BookMarkService.getSharedBookMarks(User _currUser, WCMFilter _fliter)

Events

EventService.getSharedEvents(User _user, CMyDateTime _date)

Events

EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll)

Events

EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter)

Groups

EventService.getSharedGroups(Event _aEvent)

Groups

BookMarkService.getSharedGroups(int _nObjType, int _nObjId)

MarkKinds

BookMarkService.getSharedMarkKinds(User _currUser, WCMFilter _filter)

Users

EventService.getSharedUsers(Event _aEvent)

Users

BookMarkService.getSharedUsers(int _nObjType, int _nObjId)

Groups

ChannelService.getSiteGroups(WebSite _site, WCMFilter _filter)

Roles

ChannelService.getSiteRoles(WebSite _site, WCMFilter _filter)

Users

ChannelService.getSiteUsers(WebSite _currSite, WCMFilter _currFilter)

StatFieldMaps

StatService.getStatFieldsByView(int _nStatTempId)

StatHosts

StatService.getStatHosts(WCMFilter _filter)

CMyResultSets

StatService.getStatResult(int _nStatTempId)

CMyResultSets

StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate)

CMyResultSets

StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)

CMyResultSets

StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)

CMyResultSets

StatService.getStatResult(java.lang.String _sqlStat, java.lang.String _sId)

StatViews

StatService.getStatViews(java.lang.String _sStatHostName, int _nStatViewType, WCMFilter _filter)

FlowDocs

WCMProcessServiceImpl.getSubmitFlowDocs(User _operator, WCMFilter _filter)

Channels

ChannelService.getSynSrcChannel(Channel _currChannel)
获取给当前频道分发文档的频道集合

Channels

ChannelService.getSynToChannel(Channel _currChannel)
获取当前频道分发文档的目标频道集合

java.lang.String

CDSServiceImpl.getSystemInfo(java.lang.String _sCDSType, int _nParentSiteId, int _nParentChannelId)

java.lang.String

CDSServiceImpl.getSystemInfo(java.lang.String _sCDSType, int _nParentSiteId, int _nParentChannelId, java.lang.String _sSiteFields, java.lang.String _sChannelFields)

TemplateArguments

TemplateService.getTemplateArguments(IPublishElement _element)

java.util.List

TemplateService.getTemplateEmployers(Template _template)

java.util.List

TemplateService.getTemplateEmployers(Template _template, int _nEmployerType)

TemplateParameterList

TemplateService.getTemplateParameters(IPublishElement _element)

TemplateParameterList

TemplateService.getTemplateParameters(IPublishElement _element, boolean zRecursion)

Templates

RecentService.getTemplates(WCMFilter _aFilter)

Templates

TemplateService.getTemplatesNested(Template _template)

Documents

DocumentService.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter)

int

DocumentService.getTopPosition(Document _currDocument, Channel _currChannel)

CMyDateTime

DocumentService.getTopTime(Document _currDocument, Channel _currChannel)

Users

GroupService.getUsers(Group _dstGroup, WCMFilter _filter)

Users

GroupService.getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildGrp)

Users

UserService.getUsers(int _nUserRegStatus, WCMFilter _filter)

Users

RoleService.getUsers(Role _dstRole, WCMFilter _filter)

WebSites

ChannelService.getUserSites(User _currUser, WCMFilter _currFilter)

WebSites

CustomizeService.getWebSites()

WebSites

ChannelService.getWebSites(WCMFilter _filter)
获取当前用户可以看见的站点

WebSites

RecentService.getWebSites(WCMFilter _aFilter)

boolean

CustomizeService.hasCustomized()

Reports

DocumentService.importDocuments(java.lang.String _sImportFile, int _nDstChnlId, java.lang.String _sXSLFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel)

Reports

WCMProcessServiceImpl.importFlows(java.lang.String _sImportFile)

Reports

WCMProcessServiceImpl.importFlows(java.lang.String _sImportFile, java.lang.String _sXslFile)

Reports

ChannelService.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl)
站点、频道导出、类似创建相关的方法

Reports

TemplateService.importFromHTML(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName)

Reports

TemplateService.importFromZip(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected)

Reports

DocumentService.importTRSDocuments(java.lang.String _sImportFile, int _nDestChannelId, java.lang.String _sDefineXmlFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel)

java.lang.Object

InfoViewInitorImpl.init(InfoViewContext _oContext)

boolean

UserService.isAdminOfGroup(User _user)
判断指定用户是否在系统中担任组管理员

boolean

WCMProcessServiceImpl.isCanInFlow(int _nContentType, int _nContentId)

boolean

DocumentService.isDocumentTopped(Document _currDocument, Channel _currChannel)

boolean

DocumentService.isDocumentTopScheduled(Document _currDocument, Channel _currChannel)

boolean

UserService.isManagerOfRole(User _user)
判断指定用户是否在系统中担任角色维护员

boolean

ChannelService.isVisible(User _currUser, BaseChannel _currChannel)

boolean

ChannelService.isVisible(User _currUser, BaseChannel _currChannel, int _nRightIndex)

Appendix

SureformService.makeAppendix(java.lang.String _sFormFile)

void

DocumentService.mirrorTo(Document _currDocument, Channel _toChannel)

Reports

DocumentService.mirrorTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)

Reports

DocumentService.mirrorTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)

void

DocumentService.moveBackward(int _currDocumentId, int _currChannelId)

void

BookMarkService.moveBookMark(int _aBookMark, int _aMarkKind)

void

BookMarkService.moveBookMark(java.lang.String _sBookMarkIds, int _nMarkKindId)

Reports

BookMarkService.moveBookMarks(java.lang.String _sMarkIds, int _nMarkKindId)

void

DocumentService.moveDocumentInChannel(int _fromDocumentId, int _toDocumentId, int _currChannelId)

void

DocumentService.moveDocumentInChannel(int _fromDocumentId, int _toDocumentId, int _currChannelId, int _nPostionCode)

void

DocumentService.moveFirst(int _currDocumentId, int _currChannelId)

void

DocumentService.moveForward(int _currDocumentId, int _currChannelId)
---- ==== ---- Begin 文档拖动相关的操作 ---- vvvv ----

void

DocumentService.moveLast(int _currDocumentId, int _currChannelId)

void

BookMarkService.moveMarkKind(int _nMarkKindId, int _nNewParentId)

void

BookMarkService.moveMarkKind(java.lang.String _sMarkKindIds, int _nNewParentId)

void

ChannelService.moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType)

void

ChannelService.moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType)

Reports

DocumentService.moveTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)

Reports

DocumentService.moveTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)

void

ChannelService.moveTo(WebSite _fromWebSite, WebSite _toWebSite, int _nMoveToType)

boolean

GroupService.moveUser(User _userToMove, Group _srcGroup, Group _dstGroup)

boolean

GroupService.moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups)

void

PublishService.pauseTask(java.lang.String _sTaskIds)

java.lang.String[]

PublishService.preview(BaseChannel _siteOrChannel, java.lang.String[] _warningsToReturn)

java.lang.String

PublishService.preview(Document _document, Channel _channel, java.lang.String[] _warningsHolder)

java.lang.String

PublishService.preview(Document _document, Channel _channel, java.lang.String[] holder, Template _template)

java.lang.String

PublishService.preview(Document _document, java.lang.String[] _warningsHolder)

java.lang.String

TemplateService.preview(int _nTemplateId)

java.lang.String

TemplateService.preview(Template _template)

java.lang.String

PublishService.previewInfoviewPrint(Document _document, Channel _channel, java.lang.String[] _warningsHolder, int _templateId)

java.util.List

DocumentService.processAppendix(java.util.List nodes, int nFlag)

void

PublishService.publish(BaseChannel _siteOrChannel, int _nPublishType)

void

PublishService.publishConfirm(BaseChannel _oSiteOrChnl, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile)

void

PublishService.publishForcibly(int _nDocumentId, java.lang.String _sChannelIds)

Reports

DocumentService.quoteTo(Document _currDocument, java.lang.String _sToChannelIds)

Reports

DocumentService.quoteTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)

Reports

DocumentService.quoteTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)

void

InfoViewService.rebuildXSLT(InfoView _oInfoView)

void

InfoViewService.rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)

Document

DocumentService.recoverDocument(DocBak _aDocBak, Document _currDocument)

Reports

TemplateService.redistributeAppendixes(CMSObj _chnlOrSite, boolean _zRecursive)

void

PublishService.redoTasks(java.lang.String _sTaskIds)

void

AutoDocBakService.removeConfig(int _nSiteId)

void

ContactService.removeContact(Contact _contact, ContactGrp _contactGroup)

void

ContactService.removeContact(int _nContactId, int _nContactGrpId)

void

ContactService.removeContacts(java.lang.String _sContactIds, int _nContactGrpId)

void

ChannelService.removeGroupsFromSite(java.lang.String _sGroupIds, WebSite _site)

boolean

GroupService.removeManager(User _adminToCancel, Group _dstGroup)

void

ChannelService.removeRolesFromSite(java.lang.String _sRoleIds, WebSite _site)

void

ChannelService.removeSitesFromGroup(java.lang.String _sSiteIds, Group _group)

void

ChannelService.removeSitesFromUser(java.lang.String _sSiteIds, User _currUser)

void

DocumentService.removeToppedDocument(Document _currDocument, Channel _currChannel)

boolean

GroupService.removeUser(User _userToRemove, Group _dstGroup)

boolean

GroupService.removeUser(User _userToRemove, Group _dstGroup, boolean _bContainsChildren)

boolean

RoleService.removeUser(User _dstUser, Role _fromRole)

void

ChannelService.removeUsersFromSite(java.lang.String _sUserIds, WebSite _currSite)

boolean

UserService.resetPassword(User _dstUser)

boolean

UserService.resetPassword(User _dstUser, java.lang.String _sNewPassword)
重置用户密码为新密码

boolean

UserService.resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword)

void

ChannelService.restore(BaseChannel _oChannel)
恢复站点/频道

void

ChannelService.restore(Channels _currChannels)

void

DocumentService.restore(Document _currDocument, Channel _currChannel)

void

DocumentService.restore(Documents _documents)

Reports

DocumentService.restore(java.lang.String _sDelDocIds, int _nChannelId)

boolean

UserService.restore(User _userToRestore)

boolean

UserService.restore(Users _usersToRestore)

void

ChannelService.restore(WebSites _currSites)

void

ChannelService.restoreAllInRecycleBin(int _nChannelId)
还原指定频道回收站中的所有文档

void

PublishService.resumeTask(java.lang.String _sTaskIds)

AutoBakConfig

AutoDocBakService.save(AutoBakConfig _currConfig)

BaseChannel

ChannelService.save(BaseChannel _currBaseChannel)
保存指定的站点/频道

WCMFolderPublishConfig

WCMPublishElementServiceImpl.save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig)

BookMark

BookMarkService.save(BookMark _aBookMark)

CMSObj

ResouceService.save(CMSObj _currObjToSave)

Document

DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList)

Document

DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, int _nFlowDocId)

Document

DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo)

Document

DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo, boolean _bNeedValidateRight)

Document

DocumentService.save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.lang.String _sFlowContextInfo)

Event

EventService.save(Event _aEvent)

Group

GroupService.save(Group _dstGroup)

void

InfoViewService.save(InfoView _oInfoView)

void

InfoViewService.save(InfoViewField _oField)

void

InfoViewService.save(InfoViewGroup _oGroup)

void

InfoViewService.save(InfoViewView _oView)

boolean

CustomizeService.save(int _nMoudelType)

MarkKind

BookMarkService.save(MarkKind _aMarkKind)

Role

RoleService.save(Role _roleToSave)

Template

TemplateService.save(Template _currTemplateToSave)

Template

TemplateService.save(Template _currTemplateToSave, boolean _bDowithAppendix, int _nPicMode)

User

UserService.save(User _userToSave)

User

UserService.save(User _userToSave, Group _currGrp)

PublishDistribution

WCMPublishElementServiceImpl.save(WebSite _currSite, PublishDistribution _currPublishDistribution)

boolean

CustomizeService.saveChannels(java.lang.String _sChannelIds)

ChannelSyn

ChannelService.saveChannelSyn(ChannelSyn _currChnlSyn)

ChannelSyns

ChannelService.saveChannelSyns(ChannelSyn _currChnlSyn, java.lang.String _sToChannelIds)

Contact

ContactService.saveContact(Contact _contact)

ContactGrp

ContactService.saveContactGroup(ContactGrp _contactGrp)

ContentLink

ChannelService.saveContentLink(ContentLink _contentLink)

ContentExtField

ChannelService.saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited)
保存指定的扩展字段

Reports

WCMProcessServiceImpl.saveFlow(java.lang.String _sFlowXML)

Document

DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc)

Document

DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.util.Map _hFlowContextInfo)

Document

DocumentService.saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.lang.String _sFlowContextInfo)

Document

DocumentService.saveInfoViewDocument(Document _document, InfoView _oInfoView, java.util.Map _oInfoViewData)

void

SecurityService.saveKey(SecureKey _oKey)

Schedule

ScheduleService.savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel)

Schedule

ScheduleService.savePublishSchedule(Schedule _currSchedule, Document _currDocument)

Replace

ChannelService.saveReplace(Replace _aReplace)

boolean

CustomizeService.saveSites(int[] _nArgSiteId)

StatHost

StatService.saveStatHost(StatHost _currStatHost)

StatView

StatService.saveStatView(StatView _currStatView, java.util.List _fieldMapList)

TemplateArgument

TemplateService.saveTemplateArgument(TemplateArgument _argument)

void

InfoViewService.saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)

void

InfoViewService.sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage)

void

InfoViewService.sendReplyNotice(int _iInfoViewId, int _iDocumentId, int _iDocReplyId, boolean _zSendEmail, boolean _zSendMessage)

void

CustomizeService.setCustomizedChannels(java.lang.String _sChannelIds)

void

TemplateService.setDetailTemplate(IPublishContent _content, int _nTemplateId)

void

TemplateService.setDetailTemplate(IPublishContent _content, int _nTemplateId, int _nDetailTemplateType)

void

TemplateService.setDetailTemplate(IPublishFolder _folder, int _nTemplateId, boolean _bResetChildren)

void

InfoViewService.setEmployedInfoView(CMSObj _employer, InfoView _oInfoView)

void

InfoViewService.setEmployedInfoViews(CMSObj _employer, java.lang.String _sInfoViewIDs)

void

InfoViewService.setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadonly)

void

WCMProcessServiceImpl.setFlowEmploy(BaseObj _employer, int _nFlowId)

boolean

GroupService.setGroupUsers(int _nDstGroupId, java.lang.String _sUserIdsToAdd)

void

TemplateService.setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren)

void

WCMPublishElementServiceImpl.setPubDistributionsEnable(WebSite _currSite, java.lang.String _sPublishDistributionIds, boolean _bEnable)

void

RoleService.setRoleUsers(int _nDstRoleId, java.lang.String _sUserIdsToAdd)

void

ChannelService.setSiteMembers(int _nSiteId, int _nMemberType, java.lang.String _sMemberIds)
设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

void

ChannelService.setSiteMembers(WebSite _site, int _nMemberType, java.lang.String _sMemberIds)
设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

void

StatService.setStatViewRelation(int _nMainViewId, java.lang.String _sEmbeddedViewIds)

void

StatService.setStatViewRelation(StatView _mainView, StatViews _embeddedViews)

void

DocumentService.setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil)

void

EventService.shareEventTo(Event _eventToShare, java.lang.String _sSharerIds, int _nSharerType)
共享日程给指定的共享者

void

EventService.shareTo(Event _aEvent, Group _assignToGroup)

void

EventService.shareTo(Event _aEvent, Groups _assignToGroups)

void

EventService.shareTo(Event _aEvent, java.lang.String _sUserIds)

void

EventService.shareTo(Event _aEvent, User _assignToUser)

void

EventService.shareTo(Event _aEvent, Users _assignToUsers)

void

BookMarkService.shareTo(int _nObjType, java.lang.String _sObjIds, int _nShareObjType, java.lang.String _sShareObjIds)

byte[]

SecurityService.sign(java.lang.String sKeyName, byte[] data)

FlowDoc

WCMProcessServiceImpl.startContentInFlow(int _nContentType, int _nContentId)

void

WCMProcessServiceImpl.submitAgain(User _postUser, int _nFlowDocId, java.lang.String _sOpinion)

void

WCMProcessServiceImpl.submitBack(User _postUser, java.lang.String _sFromFlowDocId, java.lang.String _sOpinion)

void

WCMProcessServiceImpl.submitTo(FlowParamers _currParamerts)

java.lang.String

WCMProcessServiceImpl.toFlowsXMLString(java.lang.String _sFlowIds)

java.lang.String

WCMProcessServiceImpl.toFlowXMLString(Flow _currFlow)

boolean

SecurityService.verify(java.lang.String sKeyName, byte[] data, byte[] sign)

抛出 WCMException 的 com.trs.service.impl 中的构造方法

InfoViewEnumCreatorImpl()

com.trs.template.domain 中 WCMException 的使用

抛出 WCMException 的 com.trs.template.domain 中的方法

java.lang.String

XTemplateExporter.export(Templates _currTemplates)
导出模板集合

InfoEntities

InfoEntityFinder.getBaseChannelEntities(int _nSiteId)

InfoEntities

InfoEntityFinder.getFieldEntities()

InfoEntities

InfoEntityFinder.getSiteEntities()

InfoEntities

InfoEntityFinder.getTemplateEntities()

XTemplateExporter.HierarchyEntity

XTemplateExporter.makeHierarchicalDir4Template(Template _oTemplate)

com.trs.template.domain.setting 中 WCMException 的使用

抛出 WCMException 的 com.trs.template.domain.setting 中的方法

byte[]

ITemplateSetting.getContent()

byte[]

AbstractTemplateSetting.getContent()

java.util.List

ITemplateSetting.getContentFiles()

ITemplateSetting[]

TemplateSettingFactory.makeAllSettings()

ITemplateSetting

TemplateSettingFactory.makeSettingByType(java.lang.String _sSettingType)

com.trs.template.service.impl 中 WCMException 的使用

抛出 WCMException 的 com.trs.template.service.impl 中的方法

IPublishFolder

TemplateServiceImpl.makeTemplateFolder(java.lang.String _sFormattedTempName, WebSite _oRootSite)

com.trs.upgrade 中 WCMException 的使用

抛出 WCMException 的 com.trs.upgrade 中的方法

java.lang.String

UpgradeObjectMember4SiteMember.execute()
将系统中的站点成员（用户、组织或角色）转换成对象的访问控制; 因为对于wcm60，如果是站点成员，那么对该站点可以访问， 所以在wcm65中，需要将其转换成可访问

com.trs.util 中 WCMException 的使用

抛出 WCMException 的 com.trs.util 中的方法

void

ResetClassInfoOfViewData.execute()

int

ResetClassInfoOfViewData.getCountOfViewDatas()

void

ResetClassInfoOfViewData.handleViewDatas()

com.trs.wcm.config 中 WCMException 的使用

抛出 WCMException 的 com.trs.wcm.config 中的方法

static PageOperator

PageOperator.createNewInstance()
产生当前对象[PageOperator]的实例

static PageOperator

PageOperator.findById(int _nId)
提取指定ID的对象

static PageOperator

PageOperator.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

void

PageOperator.insert(User _currUser)
将对象数据写入数据库

boolean

PageOperator.isValid()
检验对象数据有效性

static PageOperators

PageOperators.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[PageOperators]

boolean

PageOperator.setDesc(java.lang.String _sDesc)
设置属性：Desc

boolean

PageOperator.setIsDisplay(int _nIsDisplay)
设置属性：IsDisplay

boolean

PageOperator.setName(java.lang.String _sName)
设置属性：Name

boolean

PageOperator.setOprKey(java.lang.String _sOprKey)
设置属性：OprKey

boolean

PageOperator.setOrder(int _nOrder)
设置属性：Order

boolean

PageOperator.setRightIndex(int _nRightIndex)
设置属性：Order

boolean

PageOperator.setType(java.lang.String _sType)
设置属性：Type

com.trs.wcm.customize 中 WCMException 的使用

抛出 WCMException 的 com.trs.wcm.customize 中的方法

PageOperators

ICustomizeMgr.getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter)
获取指定用户指定类型的操作

PageOperators

CustomizeMgrImpl.getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter)

com.trs.wcm.old 中 WCMException 的使用

抛出 WCMException 的 com.trs.wcm.old 中的方法

int

WCMFormInfo.delete(User _currUser)
重载父类删除接口，同步删除其字段列表

Channel

WCMFormInfo.getChannel()
获取表单的所属频道对象

Channel

WCMExcelData.getChannel()
取所属频道对象

int

WCMFormInfo.getChannelId()
获取表单所属的频道ID

Document

WCMExcelData.getDocument()
获取所属的文档对象

WCMFormFieldses

WCMFormInfo.getFields()
获取表单字段列表集合

WCMFormFieldses

WCMFormInfo.getFields(java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sOrder)

WCMFormInfo

WCMExcelData.getForm()
获得扩展数据所属表单对象

WCMFormInfos

WCMFormMgr.getForms(BaseChannel _oChannel, boolean _bChildren, WCMFilter _filter)
获取站点/频道的自定义表单
从ChannelMgr中移动过来的 hx@050328

WebSite

WCMFormInfo.getSite()
设置表单所属的站点

WCMFormInfo

WCMFormFields.getWCMForm()
获取所属WCMForm对象

void

WCMFormInfo.insert(User _currUser)
将对象数据写入数据库

boolean

WCMFormInfo.isValid()
检验对象数据有效性

boolean

WCMFormFields.isValid()
检验对象数据有效性

boolean

WCMExcelData.isValid()

static WCMFormInfos

WCMFormInfos.openWCMObjs(User _currUser, WCMFilter _filter)
Created: 2004-12-12 16:42:24 Last Modified: 2004-12-12/2004-12-12 Description:获取表单集合

boolean

WCMExcelData.setChannel(Channel _channel)
设置所属频道

boolean

WCMExcelData.setChannel(int _channelId)
设置所属频道

boolean

WCMFormInfo.setChannelId(int _channelId)
设置表单所属的频道ID

boolean

WCMFormFields.setDBName(java.lang.String _sDBName)
设置属性：DBName

boolean

WCMFormInfo.setDesc(java.lang.String _sDesc)
设置属性：Desc

boolean

WCMFormFields.setFieldDesc(java.lang.String _sFieldDesc)
设置属性：FieldDesc

boolean

WCMFormFields.setFieldName(java.lang.String _sFieldName)
设置属性：FieldName

boolean

WCMExcelData.setForm(int _formId)
设置扩展数据所属表单

boolean

WCMFormFields.setFormId(int _nFormId)
设置属性：FormId

boolean

WCMFormInfo.setName(java.lang.String _sName)
设置属性：Name

boolean

WCMFormInfo.setObjName(java.lang.String _sObjName)
设置属性：ObjName

boolean

WCMFormInfo.setObjPath(java.lang.String _sObjPath)
设置属性：ObjPath

boolean

WCMFormInfo.setObjsName(java.lang.String _sObjsName)
设置属性：ObjsName

boolean

WCMFormInfo.setObjsPath(java.lang.String _sObjsPath)
设置属性：ObjsPath

void

WCMExcelData.setPropertyByDocument(Document _doc)
使用文档对象给新的对象设置属性

boolean

WCMFormInfo.setSite(int _siteId)
设置表单的所属站点，仅添加表单时可用，不允许修改该属性。

boolean

WCMFormInfo.setSite(WebSite _website)
设置表单的所属站点，仅添加表单时有效，不允许修改

boolean

WCMFormInfo.setType(int _nType)
设置属性：Type

com.trs.wcm.photo 中 WCMException 的使用

抛出 WCMException 的 com.trs.wcm.photo 中的方法

void

IImageLibService.clearQuotedImages(int _nDocId)

static Watermark

Watermark.createNewInstance()
产生当前对象[Watermark]的实例

int

Watermark.delete(User _currUser)

void

Watermarks.deleteAll(boolean _bDrop)

void

IImageLibMgr.deleteDocumentQuoteImage(int _nDocumentId)
删除指定文档的所有引用关系

void

IImageLibMgr.deleteDocumentQuoteImage(int _nDocumentId, int _nImageId)
删除文档和指定图片引用关系

void

IImageLibMgr.deleteDocumentQuoteImage(int _nDocumentId, java.lang.String _sExcludeImageIds)
删除指定文档的图片引用关系，不包括指定的图片ID

void

IImageLibService.deleteImage(java.lang.String _sDocIds)
从图片库中删除指定的图片

void

IImageLibService.deleteImage(java.lang.String _sDocIds, int _nChannelId)
从指定的分类中删除图片

static Watermark

Watermark.findById(int _nId)
提取指定ID的对象

static ImageKind

ImageKind.findById(int _nImageKindId)

static Watermark

Watermark.findByKey(java.lang.Object _oKey)
提取指定缓冲区Key的对象

java.util.List

IImageLibService.getChannels(User _user, int _nRightIndex)
获取指定用户可见的图片库的一级分类

java.util.List

IImageLibService.getChannels(User _user, int _nRightIndex, Channel _channel)
获取指定用户在指定分类可见的子分类列表

java.util.List

IImageLibService.getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter)
获取指定用户在指定分类可见的子分类列表

java.lang.String

IImageLibConfig.getDefaultConvertImageFileExt()
获取默认转换的图片格式

Template

IImageLibConfig.getDefaultDetailTemplate()
获取图片库分类默认的细览模板

int

IImageLibConfig.getDefaultDetailTemplateId()
获取图片库分类默认的细览模板ID

Template

IImageLibConfig.getDefaultOutlineTemplate()
获取图片库分类默认的概览模板

int

IImageLibConfig.getDefaultOutlineTemplateId()
获取图片库分类默认的概览模板ID

Documents

IImageLibService.getDocuments(BaseChannel _oChannel, WCMFilter _filter)
获取当前分类下所有的图片

Documents

IImageLibService.getDocumentsQuoteImage(int _nImageId)
获取使用指定图片的所有文档

Documents

IImageLibMgr.getDocumentsQuoteImage(int _nImageId)
获取使用指定图片的所有文档

Appendixes

IImageLibService.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)
获取系统中已经存在的图片

Appendixes

IImageLibMgr.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)
获取系统中已经存在的图片

static java.lang.String

ImageLibHelper.getImageFileNameByScale(Document _document, int _nScale)

static java.lang.String

ImageLibHelper.getImageFileNameByScale(Document _document, int _nScale, boolean _bOnlyFileName)

static java.lang.String

ImageLibHelper.getImageFileNameByScaleIndex(Document _document, int _nScaleIndex)

static java.lang.String

ImageLibHelper.getImageFileNameByScaleIndex(Document _document, int _nScaleIndex, boolean _bOnlyFileName)

static java.lang.String

ImageLibHelper.getOrigImageFileName(Document _document, boolean _bOnlyFileName)

static java.lang.String

ImageLibHelper.getOrigImageFilePath(Document _document, boolean _bOnlyFileName)
返回图片的原图的图径，若文档已发布，则返回该图的发布路径

int[]

IImageLibConfig.getOtherRelatedKindIds()
获取其它的默认分类

Channel

ImageKind.getRelatedChannel()

java.lang.String

IImageLibConfig.getRelatedConvertType()
获取bmp文件转换格式

int

IImageLibConfig.getRelatedKindId()
获取默认主分类

int

IImageLibConfig.getRelatedWaterMarkId()
获取水印

int[]

IImageLibConfig.getRelatedWaterMarkPos()
获取水印位置

WebSite

IImageLibConfig.getRelateSite()
获取与图片库相关的站点

int

IImageLibConfig.getRelateSiteId()
获取与图片库相关的站点ID

java.lang.String

IImageLibConfig.getScaleDescAt(int _nScaleIndex)
获取指定尺寸索引的描述

int[]

IImageLibConfig.getScaleSizes()
获取图片库默认定义的各种缩放尺寸

java.lang.String

IImageLibConfig.getScaleStyle()

java.lang.String[]

IImageLibConfig.getSupportImageFileExt()
获取系统支持的各种图片文件格式

int

IImageLibConfig.getWaterMarkSize(int _nImageWidth)
获取指定图片宽度设置的水印大小

ImageInfo

IImageLibService.importImageAppendix(int _nAppendixId, ImageInfo _imageInfo)
导入单个的图片到指定的分类中

ImageInfo[]

IImageLibService.importImageAppendix(java.lang.String _sAppendixIds, ImageInfo _imageInfo)
导入指定的图片到指定的分类中

ImageInfo

IImageLibMgr.importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo)
导入指定的图片到图片库指定的分类中

void

Watermark.insert(User _currUser)
将对象数据写入数据库

boolean

IImageLibConfig.isAutoEnable()
是否启动文档中的图片自动保存到图片库中

boolean

IImageLibConfig.isCmdUsed()

boolean

IImageLibConfig.isInstalled()

boolean

IImageLibConfig.isOriginalMarked()

boolean

IImageLibConfig.isSupportImageFileExt(java.lang.String _sImageFileExt)
判断当前图片文件格式是否在系统支持系列中

boolean

Watermark.isValid()
检验对象数据有效性

static Watermarks

Watermarks.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[Watermarks]

void

IImageLibService.quoteImages(int _nDocId, java.lang.String _sQuoteImageIds)
保存指定文档引用图片的关系

void

IImageLibMgr.recordDocumentQuoteImage(int _nDocumentId, int _nImageId)
记录文档和指定图片的引用关系

boolean

IImageLibConfig.reloadConfig()
重新装载图片库配置信息

void

Watermark.save(User _currUser)

boolean

IImageLibConfig.saveConfig()
保存图片库的设置

Document

IImageLibService.saveImageDetail(Document _document)
保存图片的标注信息(标题、作者、地点、人物、时间)

ImageInfo

IImageLibService.saveImageInfo(ImageInfo _imageInfo)
保存图片信息到图片库中

ImageInfo

IImageLibMgr.saveImageInfo(ImageInfo _imageInfo)

void

IImageLibConfig.setAtuoEnable(boolean _enable)
设置是否启动文档中的图片自动保存到图片库中

void

IImageLibConfig.setDefaultTemplateId(int _nOutlineTemplateId, int _nDetailTemplateId)
设置默认的模板信息

void

IImageLibConfig.setImageFileExt(java.lang.String[] _pSupportFileExt, java.lang.String _sDefaultConvertFileExt)
设置支持的图片格式和默认的转换图片

void

IImageLibConfig.setInstalled()

boolean

Watermark.setLibId(int _nLibId)

void

IImageLibConfig.setOtherRelatedKindIds(java.lang.String _ids)
设置其它的默认分类

void

IImageLibConfig.setRealtedKindId(int _id)
设置默认主分类

void

IImageLibConfig.setRelatedConvertType(java.lang.String _type)
设置bmp文件转换格式

void

IImageLibConfig.setRelatedWaterMarkId(int _id)
设置水印

void

IImageLibConfig.setRelatedWaterMarkPos(java.lang.String _pos)
设置水印位置

void

IImageLibConfig.setRelateSiteId(int _nRelateId)
设置相关站点

void

IImageLibConfig.setScaleSizes(int[] _pScaleSize, java.lang.String[] _pScaleSizeDesc, int[] _pWaterMarkSize)
设置图片库自动缩放的图片尺寸、描述以及添加的水印大小

boolean

Watermark.setWMName(java.lang.String _sWMName)
设置属性：WMName

boolean

Watermark.setWMPicture(java.lang.String _sWMPicture)
设置属性：WMPicture

com.trs.wcm.photo.impl 中 WCMException 的使用

抛出 WCMException 的 com.trs.wcm.photo.impl 中的方法

void

ImageLibServiceImpl.clearQuotedImages(int _nDocId)

void

ImageLibMgrImpl.deleteDocumentQuoteImage(int _nDocumentId)

void

ImageLibMgrImpl.deleteDocumentQuoteImage(int _nDocumentId, int _nImageId)

void

ImageLibMgrImpl.deleteDocumentQuoteImage(int _nDocumentId, java.lang.String _sExcludeImageIds)

void

ImageLibServiceImpl.deleteImage(java.lang.String _sDocIds)

void

ImageLibServiceImpl.deleteImage(java.lang.String _sDocIds, int _nChannelId)

java.util.List

ImageLibServiceImpl.getChannels(User _user, int _nRightIndex)

java.util.List

ImageLibServiceImpl.getChannels(User _user, int _nRightIndex, Channel _channel)

java.util.List

ImageLibServiceImpl.getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter)

java.lang.String

ImageLibConfigImpl.getDefaultConvertImageFileExt()

Template

ImageLibConfigImpl.getDefaultDetailTemplate()

int

ImageLibConfigImpl.getDefaultDetailTemplateId()

Template

ImageLibConfigImpl.getDefaultOutlineTemplate()

int

ImageLibConfigImpl.getDefaultOutlineTemplateId()

Documents

ImageLibServiceImpl.getDocuments(BaseChannel _oChannel, WCMFilter _filter)

Documents

ImageLibServiceImpl.getDocumentsQuoteImage(int _nImageId)

Documents

ImageLibMgrImpl.getDocumentsQuoteImage(int _nImageId)

Appendixes

ImageLibServiceImpl.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)

Appendixes

ImageLibMgrImpl.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)

int[]

ImageLibConfigImpl.getOtherRelatedKindIds()

java.lang.String

ImageLibConfigImpl.getRelatedConvertType()

int

ImageLibConfigImpl.getRelatedKindId()

int

ImageLibConfigImpl.getRelatedWaterMarkId()

int[]

ImageLibConfigImpl.getRelatedWaterMarkPos()

WebSite

ImageLibConfigImpl.getRelateSite()

int

ImageLibConfigImpl.getRelateSiteId()

java.lang.String

ImageLibConfigImpl.getScaleDescAt(int _nScaleIndex)

int[]

ImageLibConfigImpl.getScaleSizes()

java.lang.String

ImageLibConfigImpl.getScaleStyle()

java.lang.String[]

ImageLibConfigImpl.getSupportImageFileExt()

int

ImageLibConfigImpl.getWaterMarkSize(int _nImageWidth)

ImageInfo

ImageLibServiceImpl.importImageAppendix(int _nAppendixId, ImageInfo _imageInfo)

ImageInfo[]

ImageLibServiceImpl.importImageAppendix(java.lang.String _sAppendixIds, ImageInfo _imageInfo)

ImageInfo

ImageLibMgrImpl.importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo)

void

PhotoImporter.importViaZipFile(java.lang.String fn, Channel channel)

boolean

ImageLibConfigImpl.isAutoEnable()

boolean

ImageLibConfigImpl.isCmdUsed()

boolean

ImageLibConfigImpl.isInstalled()

boolean

ImageLibConfigImpl.isOriginalMarked()

boolean

ImageLibConfigImpl.isSupportImageFileExt(java.lang.String _sImageFileExt)

void

ImageLibServiceImpl.quoteImages(int _nDocId, java.lang.String _sQuoteImageIds)

void

ImageLibMgrImpl.recordDocumentQuoteImage(int _nDocumentId, int _nImageId)

boolean

ImageLibConfigImpl.reloadConfig()

boolean

ImageLibConfigImpl.saveConfig()

Document

ImageLibServiceImpl.saveImageDetail(Document _document)

ImageInfo

ImageLibServiceImpl.saveImageInfo(ImageInfo _imageInfo)

ImageInfo

ImageLibMgrImpl.saveImageInfo(ImageInfo _imageInfo)

void

ImageLibConfigImpl.setAtuoEnable(boolean _enable)

void

ImageLibConfigImpl.setDefaultTemplateId(int _nOutlineTemplateId, int _nDetailTemplateId)

void

ImageLibConfigImpl.setImageFileExt(java.lang.String[] _pSupportFileExt, java.lang.String _sDefaultConvertFileExt)

void

ImageLibConfigImpl.setInstalled()

void

ImageLibConfigImpl.setOtherRelatedKindIds(java.lang.String _ids)

void

ImageLibConfigImpl.setRealtedKindId(int _id)

void

ImageLibConfigImpl.setRelatedConvertType(java.lang.String _type)

void

ImageLibConfigImpl.setRelatedWaterMarkId(int _id)

void

ImageLibConfigImpl.setRelatedWaterMarkPos(java.lang.String _pos)

void

ImageLibConfigImpl.setRelateSiteId(int _nRelateId)

void

ImageLibConfigImpl.setScaleSizes(int[] _pScaleSize, java.lang.String[] _pScaleSizeDesc, int[] _pWaterMarkSize)

抛出 WCMException 的 com.trs.wcm.photo.impl 中的构造方法

ImageMagickCmd.ImageObj(java.lang.String fn)

com.trs.wcm.photo.publish 中 WCMException 的使用

抛出 WCMException 的 com.trs.wcm.photo.publish 中的方法

java.lang.String[]

WCMTagParserImage.parse(PublishTagContext _context)

com.trs.wcmonline 中 WCMException 的使用

抛出 WCMException 的 com.trs.wcmonline 中的方法

java.lang.String[]

TagParserVipMetaData.parse(PublishTagContext _context)

com.trs.webframework.config 中 WCMException 的使用

抛出 WCMException 的 com.trs.webframework.config 中的方法

void

ServiceFilterConfig.setClassName(java.lang.String _className)

void

ServiceListenerConfig.setClassName(java.lang.String _className)

抛出 WCMException 的 com.trs.webframework.config 中的构造方法

ServiceFilterConfig(java.lang.String _sServiceId, java.lang.String _sMethodName, java.lang.String _sClassName)

ServiceListenerConfig(java.lang.String _sServiceId, java.lang.String _sMethodName, java.lang.String _sClassName)

com.trs.webframework.controler 中 WCMException 的使用

抛出 WCMException 的 com.trs.webframework.controler 中的方法

java.lang.Object

JSPRequestProcessor.excute(java.lang.String _sServiceId, java.lang.String _sMethodName)
使用Request中的参数执行指定的服务

java.lang.Object

JSPRequestProcessor.excute(java.lang.String _sServiceId, java.lang.String _sMethodName, java.util.HashMap _parameters)
使用指定的参数执行指定的服务

java.lang.Object[]

JSPRequestProcessor.excuteArrayMult(java.lang.String _sServiceId, java.lang.String _sMethodName)
执行一组中多个同名方法，并返回多个返回值

java.lang.Object

JSPRequestProcessor.excuteMult(int _nServiceIndex)
指定MultCall中的指定顺序的服务，从0开始

java.lang.Object

JSPRequestProcessor.excuteMult(java.lang.String _sServiceId, java.lang.String _sMethodName)
指定MultCall中的指定服务

void

PostDataParser.parse(org.xml.sax.InputSource _ins)

void

PostDataParser.parse(java.lang.String _sXMLFile)

void

JSPRequestProcessor.setAppendParameters(java.lang.String[] _appendParameters)
设置追加的参数

void

JSPRequestProcessor.setEscapeParameters(java.lang.String[] _escapeParameters)
指定Request转义的参数

com.trs.webframework.provider 中 WCMException 的使用

抛出 WCMException 的 com.trs.webframework.provider 中的方法

boolean

IServiceFilter.doFilter(ServiceFilterConfig _oFilterConfig, MethodContext _oMethodContext)
* 在执行服务之前，在这个方法中可以： 1、根据当前上下文参数，判断操作是否可以继续 2、如果不能继续，也可以通过MethodContext获取当前Servlet上下文参数，做重定向 3、也能够修改MethodContext

com.trsupdate 中 WCMException 的使用

抛出 WCMException 的 com.trsupdate 中的方法

int

RightUpdaterForUser.doResetRight()

com.wcm.pdf 中 WCMException 的使用

抛出 WCMException 的 com.wcm.pdf 中的构造方法

CreateThreadForPDF(java.lang.String xmlfile, java.lang.String wordfile, java.lang.String pdffile, java.lang.String year)

概述

软件包

类

使用

树

已过时

索引

帮助

上一个   下一个

框架    无框架


类 com.trs.infra.common.WCMRightTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.common.WCMRightTypes
的使用

没有 com.trs.infra.common.WCMRightTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.common.WCMTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.common.WCMTypes
的使用

没有 com.trs.infra.common.WCMTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseConfigServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 BaseConfigServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.config.BaseConfigServer
所有已实现的接口：
IServer
直接已知子类：
DefaultChannelMakerCenter, FieldValueCreatorConfigStartServer, InfoViewFieldValueCreatorConfigStartServer, ServiceConfigStartServer, XMLConvertorConfigStartServer
public abstract class BaseConfigServer
extends BaseServer

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
BaseConfigServer()
方法摘要
java.lang.String | getConfigPath()
void | setConfigPath(java.lang.String configPath)
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseConfigServer

public BaseConfigServer()
方法详细信息

getConfigPath

public java.lang.String getConfigPath()
返回：

setConfigPath

public void setConfigPath(java.lang.String configPath)
参数：
configPath -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BeanConfigServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 BeanConfigServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.config.BeanConfigServer
所有已实现的接口：
IServer
public class BeanConfigServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
为SpringBean的配置提供服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
方法摘要
boolean | containsBean(java.lang.String _beanId) 检验指定id标识的Bean配置对象是否存在
java.util.List | getBeanConfigCollection() 得到所有Bean的集合[BeanConfig]
java.util.List | getBeanConfigCollection(java.lang.String _sPluginId) 得到指定Id的Plugin下的Bean的集合[BeanConfig]
static BeanConfigServer | getInstance()
static boolean | started() 判断BeanConfigServer是否已经启动，即所有的Bean配置文件都已经被加载了
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getInstance

public static BeanConfigServer getInstance()
返回：
单体引用器
抛出：
CMyException

getBeanConfigCollection

public java.util.List getBeanConfigCollection()
得到所有Bean的集合[BeanConfig]

返回：
所有Bean的集合[BeanConfig]

getBeanConfigCollection

public java.util.List getBeanConfigCollection(java.lang.String _sPluginId)
得到指定Id的Plugin下的Bean的集合[BeanConfig]

参数：
_sPluginId - 指定Plugin的id标识
返回：

containsBean

public boolean containsBean(java.lang.String _beanId)
检验指定id标识的Bean配置对象是否存在

参数：
id - bean的id标识
返回：

started

public static boolean started()
判断BeanConfigServer是否已经启动，即所有的Bean配置文件都已经被加载了

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 ConfigConstants

java.lang.Object
    继承者  com.trs.infra.config.ConfigConstants

public final class ConfigConstants
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Config 的常量定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DIR_APPROOT
static java.lang.String | DIR_CLASSROOT
static int | ERR_FORMAT_INVALID
static java.lang.String | EXT_FILE_CONFIG
static java.lang.String | NAME_FILE_BEAN
static java.lang.String | NAME_FILE_CONFIG
static java.lang.String | NAME_FILE_MAPPING
static java.lang.String | TAG_ATTRIBUTE_BEANCLASSNAME
static java.lang.String | TAG_ATTRIBUTE_BEANID
static java.lang.String | TAG_ATTRIBUTE_BEANISSINGLETON
static java.lang.String | TAG_ELEMENT_BEAN
static java.lang.String | TAG_ELEMENT_BEANS
构造方法摘要
ConfigConstants()
方法摘要
static java.lang.String | getAbsoluteFileNameOfCoreBeansXML()
static java.lang.String | getAbsoluteFileNameOfCoreConfigXML()
static java.lang.String | getAbsoluteFileNameOfCoreMapping()
static java.lang.String | getConfigRootPath()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DIR_APPROOT

public static java.lang.String DIR_APPROOT

DIR_CLASSROOT

public static java.lang.String DIR_CLASSROOT

EXT_FILE_CONFIG

public static final java.lang.String EXT_FILE_CONFIG
另请参见：
常量字段值

NAME_FILE_CONFIG

public static final java.lang.String NAME_FILE_CONFIG
另请参见：
常量字段值

NAME_FILE_BEAN

public static final java.lang.String NAME_FILE_BEAN
另请参见：
常量字段值

TAG_ELEMENT_BEANS

public static final java.lang.String TAG_ELEMENT_BEANS
另请参见：
常量字段值

TAG_ELEMENT_BEAN

public static final java.lang.String TAG_ELEMENT_BEAN
另请参见：
常量字段值

TAG_ATTRIBUTE_BEANID

public static final java.lang.String TAG_ATTRIBUTE_BEANID
另请参见：
常量字段值

TAG_ATTRIBUTE_BEANCLASSNAME

public static final java.lang.String TAG_ATTRIBUTE_BEANCLASSNAME
另请参见：
常量字段值

NAME_FILE_MAPPING

public static final java.lang.String NAME_FILE_MAPPING
另请参见：
常量字段值

TAG_ATTRIBUTE_BEANISSINGLETON

public static final java.lang.String TAG_ATTRIBUTE_BEANISSINGLETON
另请参见：
常量字段值

ERR_FORMAT_INVALID

public static final int ERR_FORMAT_INVALID
另请参见：
常量字段值
构造方法详细信息

ConfigConstants

public ConfigConstants()
方法详细信息

getAbsoluteFileNameOfCoreMapping

public static java.lang.String getAbsoluteFileNameOfCoreMapping()

getAbsoluteFileNameOfCoreConfigXML

public static java.lang.String getAbsoluteFileNameOfCoreConfigXML()

getAbsoluteFileNameOfCoreBeansXML

public static java.lang.String getAbsoluteFileNameOfCoreBeansXML()

getConfigRootPath

public static java.lang.String getConfigRootPath()

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigController

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 ConfigController

java.lang.Object
    继承者  com.trs.infra.config.ConfigController

public class ConfigController
extends java.lang.Object

构造方法摘要
ConfigController()
方法摘要
static void | main(java.lang.String[] args)
void | save(javax.servlet.ServletRequest request)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConfigController

public ConfigController()
方法详细信息

save

public void save(javax.servlet.ServletRequest request)
          throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBTableConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 DBTableConfig

java.lang.Object
    继承者  com.trs.infra.BaseConfig
        继承者  com.trs.infra.config.DBTableConfig

public class DBTableConfig
extends BaseConfig

版本：
1.0
作者：
wyw

构造方法摘要
DBTableConfig(java.lang.String _sConfig, java.lang.String _sValue)
方法摘要
static void | main(java.lang.String[] args)
void | save()
从类 com.trs.infra.BaseConfig 继承的方法
refresh
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBTableConfig

public DBTableConfig(java.lang.String _sConfig,
                     java.lang.String _sValue)
方法详细信息

save

public void save()
          throws WCMException
覆盖：
类 BaseConfig 中的 save
抛出：
WCMException

main

public static void main(java.lang.String[] args)
                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 FileConfig

java.lang.Object
    继承者  com.trs.infra.BaseConfig
        继承者  com.trs.infra.config.FileConfig

public class FileConfig
extends BaseConfig

版本：
1.0
作者：
wyw

构造方法摘要
FileConfig(java.lang.String _sConfig, java.lang.String _sValue)
方法摘要
void | finalize()
static void | main(java.lang.String[] args)
void | save()
从类 com.trs.infra.BaseConfig 继承的方法
refresh
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileConfig

public FileConfig(java.lang.String _sConfig,
                  java.lang.String _sValue)
方法详细信息

finalize

public void finalize()
              throws java.lang.Throwable
覆盖：
类 java.lang.Object 中的 finalize
抛出：
java.lang.Throwable

save

public void save()
          throws java.lang.Exception
覆盖：
类 BaseConfig 中的 save
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.config
类
BaseConfigServer
BeanConfigServer
ConfigConstants
ConfigController
DBTableConfig
FileConfig
TRSConfigServer
XMLConfig
XMLConfigServer


com.trs.infra.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.config

类摘要
BaseConfigServer |
BeanConfigServer | Title: TRS 内容协作平台（TRS WCM） Description: 为SpringBean的配置提供服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigConstants | Title: TRS 内容协作平台（TRS WCM） Description: Config 的常量定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigController |
DBTableConfig |
FileConfig |
TRSConfigServer |
XMLConfig |
XMLConfigServer | Title: TRS 内容协作平台（TRS WCM） Description: 对可配置对象的顶层管理类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseConfig
      • com.trs.infra.config.DBTableConfig
      • com.trs.infra.config.FileConfig
      • com.trs.infra.config.XMLConfig
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.config.BaseConfigServer
      • com.trs.infra.config.BeanConfigServer
      • com.trs.infra.config.XMLConfigServer
    • com.trs.infra.config.ConfigConstants
    • com.trs.infra.config.ConfigController
    • com.trs.infra.config.TRSConfigServer


软件包 com.trs.infra.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.config
的使用

使用 com.trs.infra.config 的软件包
com.trs.components.infoview.helper
com.trs.components.metadata.center
com.trs.components.metadata.service
com.trs.infra.config
com.trs.webframework.config
com.trs.webframework.xmlserver

com.trs.components.infoview.helper 使用的 com.trs.infra.config 中的类
BaseConfigServer

com.trs.components.metadata.center 使用的 com.trs.infra.config 中的类
BaseConfigServer

com.trs.components.metadata.service 使用的 com.trs.infra.config 中的类
BaseConfigServer

com.trs.infra.config 使用的 com.trs.infra.config 中的类
BaseConfigServer
BeanConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:
为SpringBean的配置提供服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:
对可配置对象的顶层管理类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.config 使用的 com.trs.infra.config 中的类
BaseConfigServer

com.trs.webframework.xmlserver 使用的 com.trs.infra.config 中的类
BaseConfigServer

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TRSConfigServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 TRSConfigServer

java.lang.Object
    继承者  com.trs.infra.config.TRSConfigServer

public class TRSConfigServer
extends java.lang.Object

字段摘要
static java.lang.String FILENAME_APP_PROPERTIES
构造方法摘要
TRSConfigServer()
方法摘要
static BaseConfigServer | findConfigServerById(java.lang.String _sConfigServerId)
static java.lang.String | getAppRootPath()
static java.lang.String | getConfigRootPath() 获取配置服务器的根路径
static void | main(java.lang.String[] args)
static void | start() 启动配置服务器
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FILENAME_APP_PROPERTIES

public static java.lang.String FILENAME_APP_PROPERTIES
构造方法详细信息

TRSConfigServer

public TRSConfigServer()
方法详细信息

findConfigServerById

public static BaseConfigServer findConfigServerById(java.lang.String _sConfigServerId)

getConfigRootPath

public static java.lang.String getConfigRootPath()
获取配置服务器的根路径

返回：
抛出：
WCMException

start

public static void start()
启动配置服务器

getAppRootPath

public static java.lang.String getAppRootPath()

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 XMLConfig

java.lang.Object
    继承者  com.trs.infra.BaseConfig
        继承者  com.trs.infra.config.XMLConfig

public class XMLConfig
extends BaseConfig

版本：
1.0
作者：
wyw

构造方法摘要
XMLConfig(java.lang.String _sConfig, java.lang.String _sValue)
方法摘要
static void | main(java.lang.String[] args)
void | save()
从类 com.trs.infra.BaseConfig 继承的方法
refresh
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLConfig

public XMLConfig(java.lang.String _sConfig,
                 java.lang.String _sValue)
方法详细信息

save

public void save()
          throws java.lang.Exception
覆盖：
类 BaseConfig 中的 save
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws CMyException,
                        org.dom4j.DocumentException,
                        java.io.IOException
抛出：
CMyException
org.dom4j.DocumentException
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLConfigServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config
类 XMLConfigServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.config.XMLConfigServer
所有已实现的接口：
IServer
public class XMLConfigServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
对可配置对象的顶层管理类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
方法摘要
java.util.List | getConfigObjects(java.lang.Class _cfgObjType) 依据可配置对象类型，得到对应的配置信息
java.util.List | getConfigObjects(java.lang.String _sExtCfgId) 依据可配置对象在配置文件中的ID，得到对应的配置信息
static XMLConfigServer | getInstance()
java.util.Map | getPluginMap()
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getInstance

public static XMLConfigServer getInstance()
返回：
单体引用器

getConfigObjects

public java.util.List getConfigObjects(java.lang.Class _cfgObjType)
依据可配置对象类型，得到对应的配置信息

参数：
_cfgObjType - 可配置对象的类型
返回：
一个ICfgEntity的数组，可以通过类型转换得到具体的可配置对象

getConfigObjects

public java.util.List getConfigObjects(java.lang.String _sExtCfgId)
依据可配置对象在配置文件中的ID，得到对应的配置信息

参数：
_sExtCfgId - 可配置对象在配置文件中的ID
返回：
一个IConfigElement的数组，可以通过类型转换得到具体的可配置对象

getPluginMap

public java.util.Map getPluginMap()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.config.BaseConfigServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.BaseConfigServer
的使用

使用 BaseConfigServer 的软件包
com.trs.components.infoview.helper
com.trs.components.metadata.center
com.trs.components.metadata.service
com.trs.infra.config
com.trs.webframework.config
com.trs.webframework.xmlserver

com.trs.components.infoview.helper 中 BaseConfigServer 的使用

com.trs.components.infoview.helper 中 BaseConfigServer 的子类
 class InfoViewFieldValueCreatorConfigStartServer

com.trs.components.metadata.center 中 BaseConfigServer 的使用

com.trs.components.metadata.center 中 BaseConfigServer 的子类
 class FieldValueCreatorConfigStartServer
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 中 BaseConfigServer 的使用

com.trs.components.metadata.service 中 BaseConfigServer 的子类
 class DefaultChannelMakerCenter
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config 中 BaseConfigServer 的使用

返回 BaseConfigServer 的 com.trs.infra.config 中的方法
static BaseConfigServer TRSConfigServer.findConfigServerById(java.lang.String _sConfigServerId)

com.trs.webframework.config 中 BaseConfigServer 的使用

com.trs.webframework.config 中 BaseConfigServer 的子类
 class ServiceConfigStartServer

com.trs.webframework.xmlserver 中 BaseConfigServer 的使用

com.trs.webframework.xmlserver 中 BaseConfigServer 的子类
 class XMLConvertorConfigStartServer
Title: TRS 内容协作平台（TRS WCM）
Description:
XML转换器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.BeanConfigServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.BeanConfigServer
的使用

使用 BeanConfigServer 的软件包
com.trs.infra.config

com.trs.infra.config 中 BeanConfigServer 的使用

返回 BeanConfigServer 的 com.trs.infra.config 中的方法
static BeanConfigServer BeanConfigServer.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.ConfigConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.ConfigConstants
的使用

没有 com.trs.infra.config.ConfigConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.ConfigController 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.ConfigController
的使用

没有 com.trs.infra.config.ConfigController 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.DBTableConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.DBTableConfig
的使用

没有 com.trs.infra.config.DBTableConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.FileConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.FileConfig
的使用

没有 com.trs.infra.config.FileConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.TRSConfigServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.TRSConfigServer
的使用

没有 com.trs.infra.config.TRSConfigServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.XMLConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.XMLConfig
的使用

没有 com.trs.infra.config.XMLConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.XMLConfigServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.XMLConfigServer
的使用

使用 XMLConfigServer 的软件包
com.trs.infra.config

com.trs.infra.config 中 XMLConfigServer 的使用

返回 XMLConfigServer 的 com.trs.infra.config 中的方法
static XMLConfigServer XMLConfigServer.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BeanConfigHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.domain
类 BeanConfigHelper

java.lang.Object
    继承者  com.trs.infra.config.domain.BeanConfigHelper

public class BeanConfigHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
SpringBean对象配置信息的管理类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BeanConfigHelper(java.util.List _listBeanConfig)
方法摘要
static void | checkIsBeanValid(java.lang.String _beanId) 校验指定的beanId对应的SpringBean是否存在， 通常在设置和某一SpringBean相关联的配置对象属性时进行
static void | checkIsBeanValid(java.lang.String _beanId, java.lang.String _sName) 校验指定的beanId对应的SpringBean是否存在， 通常在设置和某一SpringBean相关联的配置对象属性时进行
java.io.InputStream | getBeanConfigXmlInputStream() 得到所有SpringBeand的inputStream，特用于SpringBean的创建
void | unload() 回收
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BeanConfigHelper

public BeanConfigHelper(java.util.List _listBeanConfig)
方法详细信息

getBeanConfigXmlInputStream

public java.io.InputStream getBeanConfigXmlInputStream()
                                                throws CMyException
得到所有SpringBeand的inputStream，特用于SpringBean的创建

返回：
所有SpringBeand的inputStream
抛出：
WCMException
CMyException

unload

public void unload()
回收

checkIsBeanValid

public static void checkIsBeanValid(java.lang.String _beanId,
                                    java.lang.String _sName)
校验指定的beanId对应的SpringBean是否存在，
通常在设置和某一SpringBean相关联的配置对象属性时进行

参数：
_beanId - 指定关联的SpringBean的id标识
_sName - 在证该SpringBean不存在时，
显示详细信息时打印出配置对像给的名称

checkIsBeanValid

public static void checkIsBeanValid(java.lang.String _beanId)
校验指定的beanId对应的SpringBean是否存在，
通常在设置和某一SpringBean相关联的配置对象属性时进行

参数：
_beanId - 指定关联的SpringBean的id标识
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ConfigFilesFinder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.domain
类 ConfigFilesFinder

java.lang.Object
    继承者  com.trs.infra.config.domain.ConfigFilesFinder

public class ConfigFilesFinder
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
按照指定方式读写文件的工具类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConfigFilesFinder(java.util.ArrayList _arConfigFileRootPaths, java.lang.String _sConfigXmlFile)
ConfigFilesFinder(java.lang.String _sConfigFileRootPath, java.lang.String _sConfigXmlFile)
方法摘要
ConfigFiles | getConfigFiles() 得到已经组织好的配置文件集合
ConfigFiles | refresh() 刷新
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConfigFilesFinder

public ConfigFilesFinder(java.lang.String _sConfigFileRootPath,
                         java.lang.String _sConfigXmlFile)

ConfigFilesFinder

public ConfigFilesFinder(java.util.ArrayList _arConfigFileRootPaths,
                         java.lang.String _sConfigXmlFile)
方法详细信息

getConfigFiles

public ConfigFiles getConfigFiles()
                           throws WCMException
得到已经组织好的配置文件集合

返回：
包含config.xml - mapping.xml的CfgFiles对象
抛出：
WCMException - 可能的文件读取错误

refresh

public ConfigFiles refresh()
                    throws CMyException
刷新

抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.domain
类 ConfigHelper

java.lang.Object
    继承者  com.trs.infra.config.domain.ConfigHelper

public class ConfigHelper
extends java.lang.Object

字段摘要
static boolean RUN_IN_ECLISPE
构造方法摘要
ConfigHelper()
方法摘要
static java.util.ArrayList | getClassPaths()
static java.util.ArrayList | getDomainConfigPaths()
static org.xml.sax.InputSource | getMappingSource(ConfigFiles _configFiles) 组织所有的映射文件，形成一个文件流，用于Mapping对象的创建
static org.xml.sax.InputSource | getMappingSource(java.lang.String _sMappingFile) 通过文件名得到 Mapping 的输入流
static java.util.ArrayList | getServiceConfigPaths()
static org.dom4j.Document | toXMLDocument(java.io.File _file) 将指定的xml文件流转化文档模型
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RUN_IN_ECLISPE

public static boolean RUN_IN_ECLISPE
构造方法详细信息

ConfigHelper

public ConfigHelper()
方法详细信息

getDomainConfigPaths

public static java.util.ArrayList getDomainConfigPaths()

getClassPaths

public static java.util.ArrayList getClassPaths()

getServiceConfigPaths

public static java.util.ArrayList getServiceConfigPaths()

toXMLDocument

public static org.dom4j.Document toXMLDocument(java.io.File _file)
                                        throws CMyException
将指定的xml文件流转化文档模型

参数：
_file - 指定要转换的文件流
返回：
转化后的文档对象
抛出：
CMyException

getMappingSource

public static org.xml.sax.InputSource getMappingSource(ConfigFiles _configFiles)
                                                throws CMyException
组织所有的映射文件，形成一个文件流，用于Mapping对象的创建

参数：
_configFiles -
返回：
所有的映射文件的文件流
抛出：
CMyException

getMappingSource

public static org.xml.sax.InputSource getMappingSource(java.lang.String _sMappingFile)
                                                throws CMyException
通过文件名得到 Mapping 的输入流

参数：
_sMappingFile - Mapping 文件路径+文件名
返回：
转换后的输入流对象
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigObjectLoader

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.domain
类 ConfigObjectLoader

java.lang.Object
    继承者  com.trs.infra.config.domain.ConfigObjectLoader

public final class ConfigObjectLoader
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
配置文件的编组与解组工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConfigObjectLoader()
方法摘要
void | clear() 回收
java.util.List | getExtensionalObjects(java.lang.Class _cElementType) 依据可配置对象类型，得到所有该类型的配置信息
java.util.List | getExtensionalObjects(java.lang.String _sExtId) 依据可配置对象ID标示，得到所有该类型的配置信息
java.util.Map | getPluginMap() 得到所有的配置文件的格式为 散列集
void | load() 加载
static PluginConfig | loadUnmarshallerRoot(java.io.File _fCfgXml, org.exolab.castor.mapping.Mapping _map) 依据一个配置文件，解组得到一个可配置根对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConfigObjectLoader

public ConfigObjectLoader()
方法详细信息

clear

public void clear()
回收

load

public void load()
加载

loadUnmarshallerRoot

public static PluginConfig loadUnmarshallerRoot(java.io.File _fCfgXml,
                                                org.exolab.castor.mapping.Mapping _map)
                                         throws org.exolab.castor.mapping.MappingException,
                                                java.lang.Exception
依据一个配置文件，解组得到一个可配置根对象

参数：
_fCfgXml - 配置文件的路径
_map -
返回：
@throws Exception
抛出：
org.exolab.castor.mapping.MappingException
java.lang.Exception

getExtensionalObjects

public java.util.List getExtensionalObjects(java.lang.Class _cElementType)
依据可配置对象类型，得到所有该类型的配置信息

参数：
_cElementType - 可配置对象的类型
返回：
一个ICfgEntity的数组

getExtensionalObjects

public java.util.List getExtensionalObjects(java.lang.String _sExtId)
依据可配置对象ID标示，得到所有该类型的配置信息

参数：
_sExtId - 可配置对象ID标示
返回：
一个ICfgEntity的数组

getPluginMap

public java.util.Map getPluginMap()
得到所有的配置文件的格式为 散列集

返回：
配置文件的格式为 散列集
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.config.domain
类
BeanConfigHelper
ConfigFilesFinder
ConfigHelper
ConfigObjectLoader


com.trs.infra.config.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.config.domain

类摘要
BeanConfigHelper | Title: TRS 内容协作平台（TRS WCM） Description: SpringBean对象配置信息的管理类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigFilesFinder | Title: TRS 内容协作平台（TRS WCM） Description: 按照指定方式读写文件的工具类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigHelper |
ConfigObjectLoader | Title: TRS 内容协作平台（TRS WCM） Description: 配置文件的编组与解组工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.config.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.config.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.config.domain.BeanConfigHelper
    • com.trs.infra.config.domain.ConfigFilesFinder
    • com.trs.infra.config.domain.ConfigHelper
    • com.trs.infra.config.domain.ConfigObjectLoader


软件包 com.trs.infra.config.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.config.domain
的使用

没有 com.trs.infra.config.domain 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.domain.BeanConfigHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.domain.BeanConfigHelper
的使用

没有 com.trs.infra.config.domain.BeanConfigHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.domain.ConfigFilesFinder 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.domain.ConfigFilesFinder
的使用

没有 com.trs.infra.config.domain.ConfigFilesFinder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.domain.ConfigHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.domain.ConfigHelper
的使用

没有 com.trs.infra.config.domain.ConfigHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.domain.ConfigObjectLoader 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.domain.ConfigObjectLoader
的使用

没有 com.trs.infra.config.domain.ConfigObjectLoader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BeanConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.persistent
类 BeanConfig

java.lang.Object
    继承者  com.trs.infra.config.persistent.BeanConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class BeanConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BeanConfig()
方法摘要
java.lang.String | getClassName()
java.lang.String | getId()
java.lang.String | getName() 获取配置对象的名称
boolean | isSingleton()
void | setClassName(java.lang.String className)
void | setId(java.lang.String id)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setSingleton(boolean isSingleton)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BeanConfig

public BeanConfig()
方法详细信息

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String className)
参数：
className -

getId

public java.lang.String getId()
返回：

setId

public void setId(java.lang.String id)
参数：
id -

isSingleton

public boolean isSingleton()
返回：

setSingleton

public void setSingleton(boolean isSingleton)
参数：
isSingleton -

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ConfigFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.persistent
类 ConfigFile

java.lang.Object
    继承者  com.trs.infra.config.persistent.ConfigFile

public class ConfigFile
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConfigFile(java.io.File _plugin, java.io.File _mapping)
方法摘要
java.io.File | getMapping()
java.io.File | getPlugin()
void | setMapping(java.io.File mapping)
void | setPlugin(java.io.File plugin)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConfigFile

public ConfigFile(java.io.File _plugin,
                  java.io.File _mapping)
参数：
_file -
mapping2 -
方法详细信息

getMapping

public java.io.File getMapping()
返回：

setMapping

public void setMapping(java.io.File mapping)
参数：
mapping -

getPlugin

public java.io.File getPlugin()
返回：

setPlugin

public void setPlugin(java.io.File plugin)
参数：
plugin -

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigFiles

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.persistent
类 ConfigFiles

java.lang.Object
    继承者  com.trs.infra.config.persistent.ConfigFiles

public class ConfigFiles
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConfigFiles()
方法摘要
void | add(ConfigFile _file)
ConfigFile | get(int i)
int | size()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConfigFiles

public ConfigFiles()
方法详细信息

add

public void add(ConfigFile _file)

get

public ConfigFile get(int i)

size

public int size()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExtensionConfigs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.persistent
类 ExtensionConfigs

java.lang.Object
    继承者  com.trs.infra.config.persistent.ExtensionConfigs
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class ExtensionConfigs
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ExtensionConfigs()
方法摘要
void | addConfigElements(IConfigElement element)
java.lang.String | getClassName()
java.util.ArrayList | getConfigElements()
java.lang.String | getId()
java.lang.String | getName() 获取配置对象的名称
void | setClassName(java.lang.String className)
void | setConfigElements(java.util.ArrayList configElements)
void | setId(java.lang.String id)
void | setName(java.lang.String _sName) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExtensionConfigs

public ExtensionConfigs()
方法详细信息

getId

public java.lang.String getId()
返回：

setId

public void setId(java.lang.String id)
参数：
id -

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String className)
参数：
className -

getConfigElements

public java.util.ArrayList getConfigElements()
返回：
IConfigElement List

setConfigElements

public void setConfigElements(java.util.ArrayList configElements)
参数：
configElements -

addConfigElements

public void addConfigElements(IConfigElement element)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IConfigElement

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.persistent
接口 IConfigElement

所有超级接口：
IXmlPersistentObject
所有已知实现类：
BeanConfig, CachedObjectConfig, CacheMgrConfig, ContentTypeConfig, DBConnectionConfig, DBConnectionConfigs, DocumentFieldConfig, DocumentShowFieldConfig, ExtensionConfigs, FileNamedStyle, FolderTypeConfig, InfoViewConfig, LaborResourceConfig, MessageSendingConfig, MonitorHostConfig, NotificationSchemeConfig, ObjectLCListenerConfig, ObjectTypeConfig, OperationConfig, OperationDefineOnCurrChannelConfig, OperationRelatedConfig, PublishDistributionConfig, PublishElementConfig, PublishServerConfig, RegFromConfig, RightHostConfig, RightHostIndexsConfig, RightObjectConfig, ServerConfig, SMTPServerConfig, SMTPServerConfigs, SystemCollocationConfig, TagFormatterConfig, TargetTypeConfig, TemplateParseConfig, UpdateCommanderConfig, WCMAppConfig
public interface IConfigElement
extends IXmlPersistentObject

Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String | getName() 获取配置对象的名称
void | setName(java.lang.String _sName) 设置配置对象的名称

方法详细信息

setName

void setName(java.lang.String _sName)
设置配置对象的名称

参数：
_sName - 配置对象的名称

getName

java.lang.String getName()
获取配置对象的名称

返回：
配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.config.persistent
接口
IConfigElement
类
BeanConfig
ConfigFile
ConfigFiles
ExtensionConfigs
PluginConfig


com.trs.infra.config.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.config.persistent

接口摘要
IConfigElement Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
BeanConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigFile | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigFiles | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ExtensionConfigs | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PluginConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.config.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.config.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.config.persistent.BeanConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.config.persistent.ConfigFile
    • com.trs.infra.config.persistent.ConfigFiles
    • com.trs.infra.config.persistent.ExtensionConfigs (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.config.persistent.PluginConfig

接口分层结构

  • com.trs.infra.util.xml.IXmlPersistentObject
    • com.trs.infra.config.persistent.IConfigElement


软件包 com.trs.infra.config.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.config.persistent
的使用

使用 com.trs.infra.config.persistent 的软件包
com.trs.cms.auth.config |
com.trs.components.common.message |
com.trs.components.common.message.notify |
com.trs.components.common.publish.config.persistent |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.wcm |
com.trs.components.wcm.content.persistent |
com.trs.infra |
com.trs.infra.config.domain |
com.trs.infra.config.persistent |
com.trs.infra.persistent |
com.trs.infra.persistent.cache |
com.trs.infra.persistent.db |
com.trs.infra.persistent.listener |
com.trs.infra.support.cache |
com.trs.infra.support.config |
com.trs.infra.update |
com.trs.infra.util.email |
com.trs.presentation.ids |

com.trs.cms.auth.config 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message.notify 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.config.persistent 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.taskdispatch 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config.domain 使用的 com.trs.infra.config.persistent 中的类
ConfigFiles
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PluginConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config.persistent 使用的 com.trs.infra.config.persistent 中的类
BeanConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigFile
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ExtensionConfigs
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.update 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.email 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.ids 使用的 com.trs.infra.config.persistent 中的类
IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PluginConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.config.persistent
类 PluginConfig

java.lang.Object
    继承者  com.trs.infra.config.persistent.PluginConfig

public class PluginConfig
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PluginConfig()
方法摘要
void | addBeans(BeanConfig _bean)
void | addExtensions(ExtensionConfigs _cfg)
java.util.ArrayList | getBeans()
java.util.ArrayList | getExtensions()
java.lang.String | getHostFilePath()
java.lang.String | getId()
java.lang.String | getName()
java.lang.String | getVersion()
void | setBeans(java.util.ArrayList beans)
void | setExtensions(java.util.ArrayList cfgEntities)
void | setHostFilePath(java.lang.String cofingFilePath)
void | setId(java.lang.String id)
void | setName(java.lang.String name)
void | setVersion(java.lang.String version)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PluginConfig

public PluginConfig()
方法详细信息

getId

public java.lang.String getId()
返回：

setId

public void setId(java.lang.String id)
参数：
id -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

getVersion

public java.lang.String getVersion()
返回：

setVersion

public void setVersion(java.lang.String version)
参数：
version -

getExtensions

public java.util.ArrayList getExtensions()
返回：

setExtensions

public void setExtensions(java.util.ArrayList cfgEntities)
参数：
cfgEntities -

addExtensions

public void addExtensions(ExtensionConfigs _cfg)

getBeans

public java.util.ArrayList getBeans()
返回：

setBeans

public void setBeans(java.util.ArrayList beans)
参数：
beans -

addBeans

public void addBeans(BeanConfig _bean)

getHostFilePath

public java.lang.String getHostFilePath()
返回：

setHostFilePath

public void setHostFilePath(java.lang.String cofingFilePath)
参数：
cofingFilePath -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.config.persistent.BeanConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.persistent.BeanConfig
的使用

使用 BeanConfig 的软件包
com.trs.infra.config.persistent

com.trs.infra.config.persistent 中 BeanConfig 的使用

参数类型为 BeanConfig 的 com.trs.infra.config.persistent 中的方法
 void PluginConfig.addBeans(BeanConfig _bean)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.persistent.ConfigFile 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.persistent.ConfigFile
的使用

使用 ConfigFile 的软件包
com.trs.infra.config.persistent

com.trs.infra.config.persistent 中 ConfigFile 的使用

返回 ConfigFile 的 com.trs.infra.config.persistent 中的方法
 ConfigFile ConfigFiles.get(int i)

参数类型为 ConfigFile 的 com.trs.infra.config.persistent 中的方法
 void ConfigFiles.add(ConfigFile _file)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.persistent.ConfigFiles 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.persistent.ConfigFiles
的使用

使用 ConfigFiles 的软件包
com.trs.infra.config.domain

com.trs.infra.config.domain 中 ConfigFiles 的使用

返回 ConfigFiles 的 com.trs.infra.config.domain 中的方法
ConfigFiles | ConfigFilesFinder.getConfigFiles() 得到已经组织好的配置文件集合
ConfigFiles | ConfigFilesFinder.refresh() 刷新

参数类型为 ConfigFiles 的 com.trs.infra.config.domain 中的方法
static org.xml.sax.InputSource ConfigHelper.getMappingSource(ConfigFiles _configFiles)
组织所有的映射文件，形成一个文件流，用于Mapping对象的创建

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.persistent.ExtensionConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.persistent.ExtensionConfigs
的使用

使用 ExtensionConfigs 的软件包
com.trs.infra.config.persistent

com.trs.infra.config.persistent 中 ExtensionConfigs 的使用

参数类型为 ExtensionConfigs 的 com.trs.infra.config.persistent 中的方法
 void PluginConfig.addExtensions(ExtensionConfigs _cfg)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.config.persistent.IConfigElement 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.config.persistent.IConfigElement
的使用

使用 IConfigElement 的软件包
com.trs.cms.auth.config |
com.trs.components.common.message |
com.trs.components.common.message.notify |
com.trs.components.common.publish.config.persistent |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.wcm |
com.trs.components.wcm.content.persistent |
com.trs.infra |
com.trs.infra.config.persistent |
com.trs.infra.persistent |
com.trs.infra.persistent.cache |
com.trs.infra.persistent.db |
com.trs.infra.persistent.listener |
com.trs.infra.support.cache |
com.trs.infra.support.config |
com.trs.infra.update |
com.trs.infra.util.email |
com.trs.presentation.ids |

com.trs.cms.auth.config 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.cms.auth.config 中的类
class | OperationConfig
class | OperationDefineOnCurrChannelConfig
class | OperationRelatedConfig
class | RightHostConfig Title: TRS 内容协作平台（TRS WCM） Description: Right Object实现配置信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RightHostIndexsConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RightObjectConfig Title: TRS 内容协作平台（TRS WCM） Description: Right Object实现配置信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.components.common.message 中的类
 class MessageSendingConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message.notify 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.components.common.message.notify 中的类
 class NotificationSchemeConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.config.persistent 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.components.common.publish.config.persistent 中的类
class | ContentTypeConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FileNamedStyle Title: TRS 内容协作平台（TRS WCM） Description: 表征文件的命名规则，采用“三段式” ：前缀 + 标示体 + 附加字段 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FolderTypeConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | LaborResourceConfig Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishDistributionConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishElementConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishServerConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagFormatterConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TargetTypeConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateParseConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.taskdispatch 中 IConfigElement 的使用

参数类型为 IConfigElement 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
void | LaborResourceMgrImpl.configure(IConfigElement _config)
void | ILaborResourceMgr.configure(IConfigElement _config) configure the manager

com.trs.components.infoview 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.components.infoview 中的类
 class InfoViewConfig

com.trs.components.wcm 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.components.wcm 中的类
 class WCMAppConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.components.wcm.content.persistent 中的类
class | DocumentFieldConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentShowFieldConfig

com.trs.infra 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra 中的类
 class ServerConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
服务器对象的配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config.persistent 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.config.persistent 中的类
class | BeanConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtensionConfigs Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 IConfigElement 的 com.trs.infra.config.persistent 中的方法
 void ExtensionConfigs.addConfigElements(IConfigElement element)

com.trs.infra.persistent 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.persistent 中的类
 class ObjectTypeConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.persistent.cache 中的类
 class CachedObjectConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.persistent.db 中的类
class | DBConnectionConfig Title: TRS 内容协作平台（TRS WCM） Description: 数据库连接特性的配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DBConnectionConfigs Title: TRS 内容协作平台（TRS WCM） Description: 数据库连接配置对象的集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.persistent.listener 中的类
class | MonitorHostConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectLCListenerConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.support.cache 中的类
 class CacheMgrConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.support.config 中的类
 class SystemCollocationConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.update 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.update 中的类
 class UpdateCommanderConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commander
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.email 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.infra.util.email 中的类
class | SMTPServerConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | SMTPServerConfigs Title: TRS 内容协作平台（TRS WCM） Description: SMTPServer config 的集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.ids 中 IConfigElement 的使用

实现 IConfigElement 的 com.trs.presentation.ids 中的类
 class RegFromConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.config.persistent.PluginConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.config.persistent.PluginConfig
的使用

使用 PluginConfig 的软件包
com.trs.infra.config.domain

com.trs.infra.config.domain 中 PluginConfig 的使用

返回 PluginConfig 的 com.trs.infra.config.domain 中的方法
static PluginConfig ConfigObjectLoader.loadUnmarshallerRoot(java.io.File _fCfgXml, org.exolab.castor.mapping.Mapping _map)
依据一个配置文件，解组得到一个可配置根对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.infra.db
类
QueryFilter


com.trs.infra.db

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.db

类摘要
QueryFilter


com.trs.infra.db 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.db 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.db.QueryFilter (implements java.lang.Cloneable)


软件包 com.trs.infra.db 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.db
的使用

使用 com.trs.infra.db 的软件包
com.trs.infra.db
com.trs.infra.persistent
com.trs.webframework.context

com.trs.infra.db 使用的 com.trs.infra.db 中的类
QueryFilter

com.trs.infra.persistent 使用的 com.trs.infra.db 中的类
QueryFilter

com.trs.webframework.context 使用的 com.trs.infra.db 中的类
QueryFilter

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


QueryFilter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.db
类 QueryFilter

java.lang.Object
    继承者  com.trs.infra.db.QueryFilter
所有已实现的接口：
java.lang.Cloneable
public class QueryFilter
extends java.lang.Object
implements java.lang.Cloneable

字段摘要
static int | DEFAULT_OPEN_RECORD_COUNT Comment for MAX_OPEN_RECORD_COUNT ：打开的最大记录数
static int | NOTLIMITED_OPEN_OPEN_RECORD_COUNT Comment for NOTLIMITED_OPEN_OPEN_RECORD_COUNT ：不限制集合的记录数
构造方法摘要
QueryFilter()
QueryFilter(QueryFilter _filter)
QueryFilter(java.lang.String _from, java.lang.String _where, java.lang.String _order)
QueryFilter(java.lang.String _from, java.lang.String _where, java.lang.String _order, java.lang.String _select)
过滤器构造函数
QueryFilter(java.lang.String _from, java.lang.String _where, java.lang.String _order, java.lang.String _select, int _nMaxSize)
QueryFilter(java.lang.String _from, java.lang.String _where, java.lang.String _order, java.lang.String _select, java.lang.String _orderSelect)
方法摘要
void | addSearchValues(CMyDateTime _value)
void | addSearchValues(double _value)
void | addSearchValues(float _value)
void | addSearchValues(int _nSearchValue)
void | addSearchValues(int _nIndex, CMyDateTime _dtTime)
void | addSearchValues(int _nIndex, double _dSearchValue)
void | addSearchValues(int _nIndex, float _fSearchValue)
void | addSearchValues(int _nIndex, int _nSearchValue)
void | addSearchValues(int _nIndex, java.lang.String _sSearchValue)
void | addSearchValues(java.lang.String _value)
void | clear() 清除过滤器的所有参数
java.lang.Object | clone() 过滤器的克隆
void | copy(QueryFilter _filterSrc) 过滤器复制函数
java.lang.String | findSelectField(java.lang.String _fieldName) 在Select子句中查找指定的字段。
java.lang.String | getFrom() 获取表名称列表，多个表用","分割
int | getMaxRowNumber() 获取查询的最大行数
java.lang.String | getOderSelect()
java.lang.String | getOrder() 获取排序条件
int | getPageSize()
java.util.List | getSearchValues()
java.lang.String | getSelect() 获取抽取的字段名列表
java.lang.String | getWhere() 获取查询条件
boolean | isForceFirstLoadIds()
boolean | isToGetAll() 判断是否为全集，即没有设定任何筛选条件
static void | main(java.lang.String[] args)
QueryFilter | mergeWith(QueryFilter _filter) 过滤器的合并
void | setForceFirstLoadIds(boolean forceFirstLoadIds)
void | setFrom(java.lang.String _from) 设置表名称列表，多个表用","分割
void | setMaxRowNumber(int _maxRowNumber) 设置查询的最大行数
void | setOrder(java.lang.String _order) 设置排序条件
void | setOrderSelect(java.lang.String _orderSelect)
void | setPageSize(int pageSize)
void | setSearchValues(java.util.List searchValues)
void | setSelect(java.lang.String _select) 设置抽取的字段名列表
void | setWhere(java.lang.String _where) 设置查询条件
java.lang.String | toSQL() 创建SQL语句
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_OPEN_RECORD_COUNT

public static int DEFAULT_OPEN_RECORD_COUNT
Comment for MAX_OPEN_RECORD_COUNT ：打开的最大记录数

NOTLIMITED_OPEN_OPEN_RECORD_COUNT

public static int NOTLIMITED_OPEN_OPEN_RECORD_COUNT
Comment for NOTLIMITED_OPEN_OPEN_RECORD_COUNT ：不限制集合的记录数

构造方法详细信息

QueryFilter

public QueryFilter()

QueryFilter

public QueryFilter(QueryFilter _filter)

QueryFilter

public QueryFilter(java.lang.String _from,
                   java.lang.String _where,
                   java.lang.String _order)

QueryFilter

public QueryFilter(java.lang.String _from,
                   java.lang.String _where,
                   java.lang.String _order,
                   java.lang.String _select)
过滤器构造函数

参数：
_from - String对象SQL语句中From部分，不包含From关键字
_where - String对象SQL语句中Where部分，不包含Where关键字
_order - String对象SQL语句中Order by部分，不包含Order by关键字
_select - String对象SQL语句中Select部分，不包含Select关键字

QueryFilter

public QueryFilter(java.lang.String _from,
                   java.lang.String _where,
                   java.lang.String _order,
                   java.lang.String _select,
                   java.lang.String _orderSelect)

QueryFilter

public QueryFilter(java.lang.String _from,
                   java.lang.String _where,
                   java.lang.String _order,
                   java.lang.String _select,
                   int _nMaxSize)
方法详细信息

clear

public void clear()
清除过滤器的所有参数

copy

public void copy(QueryFilter _filterSrc)
过滤器复制函数

参数：
_filterSrc - WCMFilter对象，被复制的过滤器

clone

public java.lang.Object clone()
过滤器的克隆

覆盖：
类 java.lang.Object 中的 clone
返回：
Object过滤器对象(可以强制转换成WCMFilter)

getFrom

public java.lang.String getFrom()
获取表名称列表，多个表用","分割

返回：
String对象SQL语句中From部分，不包含From关键字

setFrom

public void setFrom(java.lang.String _from)
设置表名称列表，多个表用","分割

参数：
_from - String对象SQL语句中From部分，不包含From关键字

getWhere

public java.lang.String getWhere()
获取查询条件

返回：

setWhere

public void setWhere(java.lang.String _where)
设置查询条件

参数：
_where - String对象SQL语句中Where部分，不包含Where关键字

getOrder

public java.lang.String getOrder()
获取排序条件

返回：
String对象SQL语句中Order by部分，不包含Order by关键字

setOrder

public void setOrder(java.lang.String _order)
设置排序条件

参数：
_order - String对象SQL语句中Order by部分，不包含Order by关键字

getSelect

public java.lang.String getSelect()
获取抽取的字段名列表

返回：
String对象SQL语句中Select部分，不包含Select关键字

setSelect

public void setSelect(java.lang.String _select)
设置抽取的字段名列表

参数：
_select - String对象SQL语句中Select部分，不包含Select关键字

getOderSelect

public java.lang.String getOderSelect()

setOrderSelect

public void setOrderSelect(java.lang.String _orderSelect)

getMaxRowNumber

public int getMaxRowNumber()
获取查询的最大行数

返回：
int数.SQL语句中,SQL server 的top部分/Orcal 的rownum,不含关键字

setMaxRowNumber

public void setMaxRowNumber(int _maxRowNumber)
设置查询的最大行数

参数：
_maxRowNumber - int数,对应SQL Server中的top/Orcal中的rownum

mergeWith

public QueryFilter mergeWith(QueryFilter _filter)
过滤器的合并

参数：
_filter - WCMFilter需要和当前过滤器对象合并的过滤器
返回：
boolean合并成功返回true;否则返回false

toSQL

public java.lang.String toSQL()
创建SQL语句

返回：
String根据设定的条件以及作用对象后组合的SQL语句

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

isToGetAll

public boolean isToGetAll()
判断是否为全集，即没有设定任何筛选条件

返回：

findSelectField

public java.lang.String findSelectField(java.lang.String _fieldName)
在Select子句中查找指定的字段。若有As语句，则一同提取。

参数：
_fieldName - 指定字段名称
返回：
返回有关指定字段的筛选字段

main

public static void main(java.lang.String[] args)

getSearchValues

public java.util.List getSearchValues()
返回：

setSearchValues

public void setSearchValues(java.util.List searchValues)
参数：
searchValues -

addSearchValues

public void addSearchValues(int _nIndex,
                            int _nSearchValue)

addSearchValues

public void addSearchValues(int _nSearchValue)

addSearchValues

public void addSearchValues(int _nIndex,
                            float _fSearchValue)

addSearchValues

public void addSearchValues(float _value)

addSearchValues

public void addSearchValues(int _nIndex,
                            double _dSearchValue)

addSearchValues

public void addSearchValues(double _value)

addSearchValues

public void addSearchValues(int _nIndex,
                            java.lang.String _sSearchValue)

addSearchValues

public void addSearchValues(java.lang.String _value)

addSearchValues

public void addSearchValues(int _nIndex,
                            CMyDateTime _dtTime)

addSearchValues

public void addSearchValues(CMyDateTime _value)

isForceFirstLoadIds

public boolean isForceFirstLoadIds()
返回：

setForceFirstLoadIds

public void setForceFirstLoadIds(boolean forceFirstLoadIds)
参数：
forceFirstLoadIds -

getPageSize

public int getPageSize()
返回：

setPageSize

public void setPageSize(int pageSize)
参数：
pageSize -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.db.QueryFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.db.QueryFilter
的使用

使用 QueryFilter 的软件包
com.trs.infra.db
com.trs.infra.persistent
com.trs.webframework.context

com.trs.infra.db 中 QueryFilter 的使用

返回 QueryFilter 的 com.trs.infra.db 中的方法
 QueryFilter QueryFilter.mergeWith(QueryFilter _filter)
过滤器的合并

参数类型为 QueryFilter 的 com.trs.infra.db 中的方法
void | QueryFilter.copy(QueryFilter _filterSrc) 过滤器复制函数
QueryFilter | QueryFilter.mergeWith(QueryFilter _filter) 过滤器的合并

参数类型为 QueryFilter 的 com.trs.infra.db 中的构造方法
QueryFilter(QueryFilter _filter)

com.trs.infra.persistent 中 QueryFilter 的使用

参数类型为 QueryFilter 的 com.trs.infra.persistent 中的构造方法
WCMFilter(QueryFilter _queryFilter)

com.trs.webframework.context 中 QueryFilter 的使用

返回 QueryFilter 的 com.trs.webframework.context 中的方法
 QueryFilter MethodContext.getQueryFilter()

参数类型为 QueryFilter 的 com.trs.webframework.context 中的方法
 void MethodContext.setQueryFilter(QueryFilter filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AbstractXmlToObjConverter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 AbstractXmlToObjConverter

java.lang.Object
    继承者  com.trs.infra.persistent.AbstractXmlToObjConverter
直接已知子类：
XmlToDocumentConverter, XMLToMetaDBTablesConvertor, XMLToMetaViewData
public abstract class AbstractXmlToObjConverter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AbstractXmlToObjConverter(int _nImportType)
方法摘要
XmlObject[] | convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList) parse the xml file
java.lang.String | getXmlEncoding() 获取XML的输出字符编码设置
void | registPersistentObj(java.lang.String _sTagName, java.lang.Class _releatClazz) 注册TagName 与相应对象的映射
void | setXmlEncoding(java.lang.String _sXmlEncoding) 设置XML的输出字符编码
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractXmlToObjConverter

public AbstractXmlToObjConverter(int _nImportType)
方法详细信息

registPersistentObj

public void registPersistentObj(java.lang.String _sTagName,
                                java.lang.Class _releatClazz)
注册TagName 与相应对象的映射

参数：
_sTagName -
_releatClazz -

convertXml

public XmlObject[] convertXml(java.lang.String _sXmlFile,
                              java.lang.String _sXslFile,
                              java.lang.String _sFieldsList)
                       throws WCMException
parse the xml file

参数：
_sXmlFile -
_sXslFile -
_sFieldsList -
返回：
抛出：
WCMException

getXmlEncoding

public java.lang.String getXmlEncoding()
获取XML的输出字符编码设置

返回：

setXmlEncoding

public void setXmlEncoding(java.lang.String _sXmlEncoding)
设置XML的输出字符编码

参数：
_sXmlEncoding - 指定的字符编码,默认为"UTF-8"
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BaseObj

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 BaseObj

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
BaseDBLog, CMSObj, CMyResultSet, Config, DBUpdateLog, JobFailedResult, MetaViewEmployer, MsgReceiver, MyBaseObj, OperType, SecureKey
public abstract class BaseObj
extends java.lang.Object
implements java.lang.Cloneable

构造方法摘要
BaseObj()
方法摘要
 void cancelUpdate()
撤销更新操作，清除更新缓冲区
 boolean checkExists(java.lang.String _sCondition)
在数据库中检查对象是否已经存在
 java.lang.Object clone()
对象复制
 java.util.Hashtable cloneProperties()
复制对象所有的属性
 BaseObj cloneToNewObj()
由对象复制成一个新对象
 BaseObj cloneToNewWCMObj()
已过时。
 boolean containsNewProperty(java.lang.String _sName)
 boolean containsProperty(java.lang.String _sName)
static BaseObj createNewInstance(java.lang.Class _classWCMObj)
产生指定的WCM元素对象的实例
static BaseObj createNewInstance(java.lang.String _sClassName)
产生指定的WCM元素对象的实例
 int delete()
从数据中删除对象信息
 boolean equals(int _id)
在id标识对象的条件下，判断对象是否为指定id标识的对象
 boolean equals(java.lang.Object _another)
判定本对象是否与指定对象相同
static BaseObj findById(java.lang.Class _objClass, int _nId)
static BaseObj findById(int _nObjType, int _nId)
static BaseObj findByKey(java.lang.Class _objClass, java.lang.Object _oKey)
 java.util.Hashtable getAllProperty()
获取对象的属性表
 java.lang.String getAttribute()
 AttributesString getAttributesString()
共用接口：属性创建扩展属性Attribute读操作 说明：子类可以通过重载禁止使用
 java.lang.String getAttributeValue(java.lang.String _sName)
获取扩展属性的值
 int getCacheIndex()
返回当前对象的CacheIndex
 java.lang.String getClassName(boolean _bIncludePackage)
取该对象的类别名称
 CMyDateTime getCrTime()
共有接口：获取创建时间crtime 说明：子类可以通过重载禁止使用
abstract  java.lang.String getDbTableName()
获得数据库中存储该对象的数据表名称。
 java.lang.String getFinalPropertyAsString(java.lang.String _sName)
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取
 java.lang.String getFinalPropertyAsString(java.lang.String _sName, java.lang.String _sDefaultValue)
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取
 int getId()
获取对象的ID
abstract  java.lang.String getIdFieldName()
获得Id字段名。
 java.lang.Object getKey()
获得对象的标示关键字，用在Hashtable中索引对象
 java.lang.String getNewAttribute()
 AttributesString getNewAttributesString()
共用接口：属性创建扩展属性Attribute读操作 说明：子类可以通过重载禁止使用
 java.lang.String getNewAttributeValue(java.lang.String _sName)
获取扩展属性的值（编辑模式下的新值）
 java.util.Hashtable getNewProperties()
 java.lang.Object getNewProperty(java.lang.String _sName)
 int getNewPropertyAsInt(java.lang.String _sPropertyName, int _nDefault)
 java.lang.String getNewPropertyAsString(java.lang.String _sPropertyName)
 java.util.Hashtable getProperties()
 java.lang.Object getProperty(java.lang.String _sName)
取对象属性值
 boolean getPropertyAsBoolean(java.lang.String _sName, boolean _bDefault)
取布尔型属性值 说明：0值为false，非0值为true
 CMyDateTime getPropertyAsDateTime(java.lang.String _sName)
取日期时间型属性值
 double getPropertyAsDouble(java.lang.String _sName, double _dDefault)
取浮点型数据属性值
 int getPropertyAsInt(java.lang.String _sName, int _nDefault)
取长整型属性值
 long getPropertyAsLong(java.lang.String _sName, long _lDefault)
取长整型属性值
 java.lang.String getPropertyAsString(java.lang.String _sName)
取字符串型属性值
 java.lang.String getPropertyAsString(java.lang.String _sName, java.lang.String _sDefaultValue)
abstract  int getWCMType()
取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
 void insert()
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
 boolean isAddMode()
检测当前对象是否处于新增模式。
 boolean isCached()
是否为缓冲对象
 boolean isChangeProperty(java.lang.String _sName)
Returns true if the value of the specified property is changed.
 boolean isGetPropertyFromNew()
 boolean isModified()
 boolean isModified(boolean zDeep)
abstract  boolean isValid()
检测对象属性是否有效 注意：子类必须重载！！
 boolean isValidInstance()
检测当前对象是否是一个已经存在的实例对象
 boolean loadById(int _nId, java.lang.String _sSelectFields)
指定ID装载数据
 boolean loadById(int _nId, java.lang.String _sSelectFields, boolean _bLoadNewProperty)
 void readFromRs(java.sql.ResultSet _rsData, java.sql.ResultSetMetaData _rsmdData)
从记录集当前行读取对象信息 注意：（1）ResultSet的列序号从1开始 （2）Hashtable.put(key,value)函数中，要求value!
 void readFromRs(java.sql.ResultSet _rsData, java.sql.ResultSetMetaData _rsmdData, java.lang.String _sIdName)
 void refreshProperty(BaseObj _newObj)
 boolean refreshProperty(java.lang.String _sName, boolean _bValue)
 boolean refreshProperty(java.lang.String _sName, long _lValue)
 boolean refreshProperty(java.lang.String _sName, java.lang.Object _oValue)
刷新对象指定属性值 //why:2002-04-01 为保持对象和数据库一致性 注意：不同类型的属性，必须使用相应匹配的对象作为属性值 说明：刷新是指更新对象在数据库中的存储值，与更改对象属性值不同 说明：不检测锁定；要求非新增模式使用（暂未检测）
 boolean refreshProperty(java.lang.String _sName, java.lang.Object _oValue, boolean _bSendMsgOfCluster)
 void releaseProperty(java.lang.String _sName)
 boolean reload()
从数据库中重新装载对象数据
 java.lang.Object removeProperty(java.lang.String _sName)
 void save()
对象保存自己
 boolean setAttribute(AttributesString _attribute)
 boolean setAttribute(java.lang.String _attribute)
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
 boolean setAttribute(java.lang.String _sName, java.lang.String _sValue)
设置扩展属性
 void setGetPropertyFromNew(boolean _bGetPropertyFromNew)
 void setId(int _nId)
设置对象ID
 void setLoadText(boolean _isLoadText)
设置是否在第一次的时候载入元素的大字段信息
 void setNewProperties(java.util.Hashtable newProperties)
 void setNextId()
Created: 2004-12-22 11:48:34 Last Modified: 2004-12-22/2004-12-22 Description: 设置对象的ID值
 boolean setProperties(java.util.Hashtable _properties)
将指定的属性列表数据拷贝到本对象中
 boolean setProperty(java.lang.String _sName, boolean _bValue)
 boolean setProperty(java.lang.String _sName, double _dValue)
导出数据到XML文件
 boolean setProperty(java.lang.String _sName, long _lValue)
设置属性值 注意：不同类型的属性，必须使用相应匹配的对象作为属性值
 boolean setProperty(java.lang.String _sName, java.lang.Object _oValue)
 boolean setProperty(java.lang.String _sName, java.lang.Object _oValue, boolean _bCheckPropValid)
 boolean setPropertyWithString(java.lang.String _sName, java.lang.String _sValue)
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象
 boolean setTextProperty(java.lang.String _sName, java.lang.String _sText)
set the value of the property whose type is text.
 void update()
更新修改。
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseObj

public BaseObj()
方法详细信息

getWCMType

public abstract int getWCMType()
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

返回：
整型类型数

getDbTableName

public abstract java.lang.String getDbTableName()
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

返回：

getIdFieldName

public abstract java.lang.String getIdFieldName()
获得Id字段名。如：wcmUser表中的UserId

返回：
Id字段名

getKey

public java.lang.Object getKey()
获得对象的标示关键字，用在Hashtable中索引对象

返回：

isCached

public final boolean isCached()
是否为缓冲对象

返回：
缓冲对象返回true 非缓冲对象返回false

getCacheIndex

public final int getCacheIndex()
返回当前对象的CacheIndex

返回：

getClassName

public java.lang.String getClassName(boolean _bIncludePackage)
取该对象的类别名称

参数：
_bIncludePackage - 是否包含package名称
返回：

getId

public int getId()
获取对象的ID

返回：

getAllProperty

public java.util.Hashtable getAllProperty()
获取对象的属性表

返回：
属性表
抛出：
WCMException - 从数据库中载入属性表时可能抛出异常

getNewProperties

public java.util.Hashtable getNewProperties()

isModified

public boolean isModified()

isModified

public boolean isModified(boolean zDeep)

setProperties

public boolean setProperties(java.util.Hashtable _properties)
将指定的属性列表数据拷贝到本对象中

参数：
_properties - 属性列表
返回：
拷贝成功返回true
抛出：
WCMException

isGetPropertyFromNew

public boolean isGetPropertyFromNew()

setGetPropertyFromNew

public void setGetPropertyFromNew(boolean _bGetPropertyFromNew)

getProperty

public java.lang.Object getProperty(java.lang.String _sName)
取对象属性值

参数：
_sName - 属性字段名称
返回：
返回Object对象

getNewProperty

public java.lang.Object getNewProperty(java.lang.String _sName)

getPropertyAsString

public java.lang.String getPropertyAsString(java.lang.String _sName)
取字符串型属性值

参数：
_sName - 属性字段名称
返回：
String对象

getFinalPropertyAsString

public java.lang.String getFinalPropertyAsString(java.lang.String _sName)
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取

参数：
_sName -
_sDefaultValue -
返回：

getFinalPropertyAsString

public java.lang.String getFinalPropertyAsString(java.lang.String _sName,
                                                 java.lang.String _sDefaultValue)
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取

参数：
_sName -
_sDefaultValue -
返回：

getPropertyAsString

public java.lang.String getPropertyAsString(java.lang.String _sName,
                                            java.lang.String _sDefaultValue)

containsProperty

public boolean containsProperty(java.lang.String _sName)

containsNewProperty

public boolean containsNewProperty(java.lang.String _sName)

getPropertyAsDateTime

public CMyDateTime getPropertyAsDateTime(java.lang.String _sName)
取日期时间型属性值

参数：
_sName - 属性字段名称
返回：
CMyDateTime对象

getPropertyAsLong

public long getPropertyAsLong(java.lang.String _sName,
                              long _lDefault)
取长整型属性值

参数：
_sName - 属性字段名称
_lDefault - 默认值
返回：
long类型的属性值

getPropertyAsInt

public int getPropertyAsInt(java.lang.String _sName,
                            int _nDefault)
取长整型属性值

参数：
_sName - 属性字段名称
_nDefault - 默认值
返回：
int类型的属性值

getPropertyAsBoolean

public boolean getPropertyAsBoolean(java.lang.String _sName,
                                    boolean _bDefault)
取布尔型属性值 说明：0值为false，非0值为true

参数：
_sName - 属性名
_bDefault - 默认值
返回：
boolean类型的属性值

refreshProperty

public boolean refreshProperty(java.lang.String _sName,
                               java.lang.Object _oValue)
                        throws WCMException
刷新对象指定属性值 //why:2002-04-01 为保持对象和数据库一致性 注意：不同类型的属性，必须使用相应匹配的对象作为属性值 说明：刷新是指更新对象在数据库中的存储值，与更改对象属性值不同 说明：不检测锁定；要求非新增模式使用（暂未检测）

参数：
_sName - 属性名
_oValue - 属性值
返回：
更新成功返回true,否则返回false
抛出：
WCMException

refreshProperty

public boolean refreshProperty(java.lang.String _sName,
                               java.lang.Object _oValue,
                               boolean _bSendMsgOfCluster)
                        throws WCMException
抛出：
WCMException

refreshProperty

public boolean refreshProperty(java.lang.String _sName,
                               long _lValue)
                        throws WCMException
抛出：
WCMException

refreshProperty

public boolean refreshProperty(java.lang.String _sName,
                               boolean _bValue)
                        throws WCMException
抛出：
WCMException

refreshProperty

public void refreshProperty(BaseObj _newObj)

setProperty

public boolean setProperty(java.lang.String _sName,
                           long _lValue)
                    throws WCMException
设置属性值 注意：不同类型的属性，必须使用相应匹配的对象作为属性值

参数：
_sName - 属性名
_lValue - 属性值
返回：
设置成功返回true,否则返回false
抛出：
WCMException

setProperty

public boolean setProperty(java.lang.String _sName,
                           boolean _bValue)
                    throws WCMException
抛出：
WCMException

setProperty

public boolean setProperty(java.lang.String _sName,
                           java.lang.Object _oValue,
                           boolean _bCheckPropValid)
                    throws WCMException
抛出：
WCMException

setProperty

public boolean setProperty(java.lang.String _sName,
                           java.lang.Object _oValue)
                    throws WCMException
抛出：
WCMException

removeProperty

public java.lang.Object removeProperty(java.lang.String _sName)

setTextProperty

public boolean setTextProperty(java.lang.String _sName,
                               java.lang.String _sText)
                        throws WCMException
set the value of the property whose type is text.

参数：
_sName - the property name.
_sText - the property value.
返回：
Returns true if the property is set successfully.
抛出：
WCMException - if failed.

setPropertyWithString

public boolean setPropertyWithString(java.lang.String _sName,
                                     java.lang.String _sValue)
                              throws WCMException
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象

参数：
_sName - 属性名
_sValue - 属性值
返回：
抛出：
WCMException

getAttributesString

public AttributesString getAttributesString()
共用接口：属性创建扩展属性Attribute读操作 说明：子类可以通过重载禁止使用

返回：

getNewAttributesString

public AttributesString getNewAttributesString()
共用接口：属性创建扩展属性Attribute读操作 说明：子类可以通过重载禁止使用

返回：

getAttribute

public java.lang.String getAttribute()

getNewAttribute

public java.lang.String getNewAttribute()

getAttributeValue

public java.lang.String getAttributeValue(java.lang.String _sName)
获取扩展属性的值

参数：
_sName - 属性名称
返回：

getNewAttributeValue

public java.lang.String getNewAttributeValue(java.lang.String _sName)
获取扩展属性的值（编辑模式下的新值）

参数：
_sName - 属性名称
返回：

setAttribute

public boolean setAttribute(java.lang.String _attribute)
                     throws WCMException
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用

参数：
_attribute - 扩展属性
返回：
抛出：
WCMException

setAttribute

public boolean setAttribute(AttributesString _attribute)
                     throws WCMException
抛出：
WCMException

setAttribute

public boolean setAttribute(java.lang.String _sName,
                            java.lang.String _sValue)
                     throws WCMException
设置扩展属性

参数：
_sName - 属性名称
_sValue - 属性值
返回：
抛出：
WCMException

getCrTime

public CMyDateTime getCrTime()
共有接口：获取创建时间crtime 说明：子类可以通过重载禁止使用

返回：

isValidInstance

public boolean isValidInstance()
检测当前对象是否是一个已经存在的实例对象

返回：

isAddMode

public boolean isAddMode()
检测当前对象是否处于新增模式。

返回：

readFromRs

public final void readFromRs(java.sql.ResultSet _rsData,
                             java.sql.ResultSetMetaData _rsmdData)
                      throws WCMException
从记录集当前行读取对象信息 注意：（1）ResultSet的列序号从1开始 （2）Hashtable.put(key,value)函数中，要求value!=null

参数：
_rsData -
_rsmdData -
抛出：
WCMException

readFromRs

public final void readFromRs(java.sql.ResultSet _rsData,
                             java.sql.ResultSetMetaData _rsmdData,
                             java.lang.String _sIdName)
                      throws WCMException
抛出：
WCMException

equals

public boolean equals(int _id)
在id标识对象的条件下，判断对象是否为指定id标识的对象

参数：
_id - 指定ID
返回：

equals

public boolean equals(java.lang.Object _another)
判定本对象是否与指定对象相同

覆盖：
类 java.lang.Object 中的 equals
参数：
_another - 指定对象
返回：

cloneProperties

public java.util.Hashtable cloneProperties()
复制对象所有的属性

返回：
哈希表对象(Hashtable)
抛出：
WCMException

clone

public java.lang.Object clone()
对象复制

覆盖：
类 java.lang.Object 中的 clone
返回：
返回Object对象

cloneToNewObj

public BaseObj cloneToNewObj()
                      throws WCMException
由对象复制成一个新对象

返回：
返回Object对象
抛出：
WCMException

cloneToNewWCMObj

public BaseObj cloneToNewWCMObj()
                         throws WCMException
已过时。

返回：
抛出：
WCMException

isValid

public abstract boolean isValid()
                         throws WCMException
检测对象属性是否有效 注意：子类必须重载！！

返回：
抛出：
WCMException

checkExists

public boolean checkExists(java.lang.String _sCondition)
                    throws WCMException
在数据库中检查对象是否已经存在

参数：
_sCondition -
返回：
抛出：
WCMException

insert

public void insert()
            throws WCMException
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

参数：
_currUser - 目前操作用户
抛出：
WCMException

update

public void update()
            throws WCMException
更新修改。修改的属性值保存在hPropertyNew中

参数：
_user - 操作用户
抛出：
WCMException

cancelUpdate

public void cancelUpdate()
撤销更新操作，清除更新缓冲区

参数：
_user - 当前操作的用户

reload

public boolean reload()
               throws WCMException
从数据库中重新装载对象数据

返回：
若装载成功，则返回true；否则，返回false.
抛出：
WCMException - 从数据库中提取数据时可能抛出异常

delete

public int delete()
           throws WCMException
从数据中删除对象信息

参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException

setProperty

public boolean setProperty(java.lang.String _sName,
                           double _dValue)
                    throws WCMException
导出数据到XML文件

参数：
_XMLFileName - 导出的XML文件名
_XSLFileName - 用于XML转换的XSL文件名；可省略，缺省时由数据库字段名构成元素名
_sFieldsList - 导出数据的字段列表；可省略，缺省时导出所有字段
返回：
抛出：
WCMException

getPropertyAsDouble

public double getPropertyAsDouble(java.lang.String _sName,
                                  double _dDefault)
取浮点型数据属性值

参数：
_sName - 属性字段名称
_dDefault - 默认值
返回：
double类型的属性值

isChangeProperty

public boolean isChangeProperty(java.lang.String _sName)
Returns true if the value of the specified property is changed.

参数：
_sName - property name
返回：
true if the value of the specified property is changed.

setLoadText

public void setLoadText(boolean _isLoadText)
设置是否在第一次的时候载入元素的大字段信息

参数：
_isLoadText - true/false

save

public void save()
          throws WCMException
对象保存自己

抛出：
WCMException

createNewInstance

public static BaseObj createNewInstance(java.lang.Class _classWCMObj)
                                 throws WCMException
产生指定的WCM元素对象的实例

参数：
_classWCMObj - WCM元素对象的class
返回：
指定的WCM元素对象的实例(WCMObj)
抛出：
WCMException

createNewInstance

public static BaseObj createNewInstance(java.lang.String _sClassName)
                                 throws WCMException
产生指定的WCM元素对象的实例

参数：
_sClassName - WCM元素对象的class
返回：
指定的WCM元素对象的实例
抛出：
WCMException

setNextId

public void setNextId()
               throws WCMException
Created: 2004-12-22 11:48:34 Last Modified: 2004-12-22/2004-12-22 Description: 设置对象的ID值

抛出：
WCMException

releaseProperty

public void releaseProperty(java.lang.String _sName)
                     throws WCMException
抛出：
WCMException

getNewPropertyAsInt

public int getNewPropertyAsInt(java.lang.String _sPropertyName,
                               int _nDefault)

getNewPropertyAsString

public java.lang.String getNewPropertyAsString(java.lang.String _sPropertyName)

getProperties

public java.util.Hashtable getProperties()
返回：

setNewProperties

public void setNewProperties(java.util.Hashtable newProperties)
参数：
newProperties -

setId

public void setId(int _nId)
设置对象ID

参数：
_nId -

loadById

public boolean loadById(int _nId,
                        java.lang.String _sSelectFields)
                 throws WCMException
指定ID装载数据

参数：
_nId - 指定的ID
_sSelectFields - 指定装载的字段列表
返回：
抛出：
WCMException

loadById

public boolean loadById(int _nId,
                        java.lang.String _sSelectFields,
                        boolean _bLoadNewProperty)
                 throws WCMException
抛出：
WCMException

findById

public static BaseObj findById(int _nObjType,
                               int _nId)
                        throws WCMException
抛出：
WCMException

findById

public static BaseObj findById(java.lang.Class _objClass,
                               int _nId)
                        throws WCMException
抛出：
WCMException

findByKey

public static BaseObj findByKey(java.lang.Class _objClass,
                                java.lang.Object _oKey)
                         throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseObjHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 BaseObjHandler

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
        继承者  com.trs.infra.persistent.BaseObjHandler
所有已实现的接口：
org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class BaseObjHandler
extends org.xml.sax.helpers.DefaultHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseObjHandler(BaseObj _obj)
方法摘要
void | characters(char[] ch, int start, int length)
void | endElement(java.lang.String uri, java.lang.String localName, java.lang.String qName)
BaseObj | getWCMObj()
void | startElement(java.lang.String uri, java.lang.String localName, java.lang.String qName, org.xml.sax.Attributes attributes)
从类 org.xml.sax.helpers.DefaultHandler 继承的方法
endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseObjHandler

public BaseObjHandler(BaseObj _obj)
方法详细信息

startElement

public void startElement(java.lang.String uri,
                         java.lang.String localName,
                         java.lang.String qName,
                         org.xml.sax.Attributes attributes)
指定者：
接口 org.xml.sax.ContentHandler 中的 startElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 startElement

characters

public void characters(char[] ch,
                       int start,
                       int length)
指定者：
接口 org.xml.sax.ContentHandler 中的 characters
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 characters

endElement

public void endElement(java.lang.String uri,
                       java.lang.String localName,
                       java.lang.String qName)
                throws org.xml.sax.SAXException
指定者：
接口 org.xml.sax.ContentHandler 中的 endElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 endElement
抛出：
org.xml.sax.SAXException

getWCMObj

public BaseObj getWCMObj()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseObjHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 BaseObjHelper

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjHelper

public class BaseObjHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseObjHelper()
方法摘要
static java.lang.String | toIdsString(java.util.List _arWCMObj) 将WCMObj数组转换为以逗号隔开的Id序列
static java.lang.String | toIdsString(java.util.List _arWCMObj, java.lang.String _sDelim) 将WCMObj数组转换为Id序列
static BaseObj | toWCMObj(java.lang.String _sWCMObjXMLContent, BaseObj _oWCMObj) 解析传入的XML内容，生成传入WCMOBJ对象。
static BaseObj | toWCMObj(java.lang.String _sWCMObjXMLContent, int _nObjId, java.lang.Class _oWCMObjClass) 解析传入的XML内容，生成传入WCMOBJ对象。
static java.util.List | toWCMObjList(java.lang.String _sWCMObjsXMLContent, BaseObj _obj) 解析传入的XML内容，生成包含指定类型WCMObj的List。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseObjHelper

public BaseObjHelper()
方法详细信息

toWCMObj

public static BaseObj toWCMObj(java.lang.String _sWCMObjXMLContent,
                               BaseObj _oWCMObj)
                        throws WCMException
解析传入的XML内容，生成传入WCMOBJ对象。

参数：
_sWCMObjXMLContent - 指定的XML内容，如这样的格式，XML中的属性必须和数据表保持一致
_oWCMObj - 指定的WCMObj对象
返回：
根据XML构造的WCMOBJ
样本：
<WCMOBJ>
    <PROPERTIES>
        <DOCID>0</DOCID>
        <DOCCHANNEL>62</DOCCHANNEL>
        <DOCTITLE><![CDATA[fdfsda]]></DOCTITLE>
        <DOCRELTIME><![CDATA[2004-12-21]]></DOCRELTIME>
        <DOCKEYWORDS><![CDATA[dfa]]></DOCKEYWORDS>
        <DOCRELWORDS><![CDATA[dffasd]]></DOCRELWORDS>
        <DOCABSTRACT><![CDATA[dsasfdasf]]></DOCABSTRACT>
        <DOCCONTENT><![CDATA[dfasd]]></DOCCONTENT>
    </PROPERTIES>
</WCMOBJ>
抛出：
WCMException

toWCMObj

public static BaseObj toWCMObj(java.lang.String _sWCMObjXMLContent,
                               int _nObjId,
                               java.lang.Class _oWCMObjClass)
                        throws WCMException
解析传入的XML内容，生成传入WCMOBJ对象。

参数：
_sWCMObjXMLContent - 指定的XML内容，如这样的格式，XML中的属性必须和数据表保持一致
_loginUser - 当前操作的用户
_nObjId - 对象ID， <=0表示为新增的对象，>0表示修改对象
_oWCMObjClass - 对象Class
返回：
设置完属性的WCMObj
抛出：
WCMException - XML数据格式不对或者对象已经被锁定会抛出异常
用例[保存文档]：
int nAppendixId = 1;
aAppendix = (Appendix)WCMObjHelper.toWCMObj(sXML, loginUser, nAppendixId, Appendix.class);
XML的格式：
<?xml version="1.0" encoding="GBK"?>
<WCMAPPENDIX Version="5.1">
<PROPERTIES>
<APPSERN>-1</APPSERN>
<APPENDIXID>1</APPENDIXID>
<APPFILETYPE>-1</APPFILETYPE>
<APPFLAG>30</APPFLAG>
<CRTIME>2002-08-12 22:39:37</CRTIME>
<CRUSER><![CDATA[system]]></CRUSER>
<USEDVERSIONS>1</USEDVERSIONS>
<APPDOCID>618</APPDOCID>
<APPFILE><![CDATA[W020020812815778615145.jpg]]></APPFILE>
<APPTIME>
</APPTIME>
</PROPERTIES>
</WCMAPPENDIX>

toWCMObjList

public static java.util.List toWCMObjList(java.lang.String _sWCMObjsXMLContent,
                                          BaseObj _obj)
                                   throws java.lang.Exception
解析传入的XML内容，生成包含指定类型WCMObj的List。

参数：
_sWCMObjsXMLContent - 传入的XML内容
_obj - 指定的WCMObj
返回：
包含指定类型WCMObj的List。
抛出：
java.lang.Exception - XML数据格式不对或者对象已经被锁定会抛出异常
用例[产生一个附件List]：
List arResult = WCMObjHelper.toWCMObjList(sXML, Appendix.createNewInstance(), "WCMAPPENDIX", loginUser);

//3.查看结果
for(int i=0; i<arResult.size(); i++){
WCMObj currObj = (WCMObj)arResult.get(i);
System.out.println("第["+(i+1)+"]条记录" + currObj.getProperties());
}

toIdsString

public static java.lang.String toIdsString(java.util.List _arWCMObj)
将WCMObj数组转换为以逗号隔开的Id序列

参数：
_arWCMObj - WCMObj数组
返回：
以逗号隔开的Id序列

toIdsString

public static java.lang.String toIdsString(java.util.List _arWCMObj,
                                           java.lang.String _sDelim)
将WCMObj数组转换为Id序列

参数：
_arWCMObj - WCMObj数组
_sDelim - ID序列分隔符
返回：
以指定分隔符隔开的ID序列
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseObjs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 BaseObjs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
直接已知子类：
CMSBaseObjs, CMyResultObjs, Configs, DBUpdateLogs, JobFailedResults, LogBaks, Logs, MetaViewEmployers, MsgReceivers, MyBaseObjs, OperTypes, SecureKeys
public abstract class BaseObjs
extends java.lang.Object

字段摘要
static int | BOOKMARK_CURRENT
static int | BOOKMARK_FIRST
static int | BOOKMARK_LAST
static long | DEBUG_USE_TIME
static java.lang.Integer | ID_NOT_LOAD
static boolean | IS_DEBUG 调试模式开关
构造方法摘要
BaseObjs()
构造函数
BaseObjs(int _initCapacity, int _incCapacity)
构造函数（默认不指定容量，建立指定）
方法摘要
boolean | addElement(BaseObj _aObj) 添加一个元素
boolean | addElement(BaseObj _aObj, int _nIndex)
void | addElement(int _nId)
void | addElement(java.lang.Integer _iKey)
void | addElement(int _nId, int _nIndex)
void | addElement(java.lang.String _sIds)
void | addElements(BaseObjs _objs)
BaseObj | addNew() 新建一个对象元素
void | addWith(BaseObjs _anotherObjs) 与指定集合做加法运算
void | cancelUpdate() 取消当前元素的修改操作
void | cancelUpdateAll()
void | cancelUpdateAll(int _end) 取消集合中指定数量的元素的修改记录
void | clear() 清空集合
static BaseObjs | createInstance(java.lang.Class _classObjs) 产生指定集合对象的实例
static BaseObjs | createInstance(java.lang.String _sObjsClassName) 产生指定集合对象的实例
BaseObjs | filter(WCMFilter _filter) 使用指定的过滤器筛选子集
BaseObj | getAt(int _index) 通过指定索引获取对象
BaseObj | getById(int _nId) 通过指定Id获取对象
int | getCacheIndex()
java.lang.String | getClassName(boolean _bIncludePackage) 取该对象的类别名称
BaseObj | getCurrent() 获得当前元素对象
int | getCurrPage() 属性提取：当前页码
abstract java.lang.Class | getElementClass() 取集合元素类
WCMFilter | getFilter() 获得集合的过滤器
int | getIdAt(int _index) 取指定索引位置的元素ID
abstract java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
java.lang.String | getIdListAsString()
java.lang.String | getIdListAsString(char _chrDelim) 将集合中的所有元素的Id，链接构成字符串； 不同Id之间，以分割符 _chrDelim 分割。
int | getMaxBufferSize() 提取属性：缓冲区最大容量
int | getMaxSize() 获取最大允许集合大小（元素个数） select top筛选
int | getPageCount() 取集合的总页数
int | getPageSize() 属性提取：分页大小
BaseObjs | getParent() 获得父集合
int | getQueryCount() 获取本次查询的记录数
int | getRecCount() 获取本次查询的记录个数
int | getSelectCount() 根据获取集合的Filter指定的条件,得到这一次查询的所有行数 select count(*)
int | indexOf(BaseObj _aObj) 获取指定对象所在的序号 注意：索引对象并不改变集合的当前指针位置，故需要在检索后恢复旧的指针位置
int | indexOf(int _nId) 通过整型标识id索引对象
int | indexOf(java.lang.Integer _iId) 通过整型标识id索引对象
int | indexOf(int _nId, int _nStartPos)
boolean | isBOF() 判断当前位置是否为POS_BOF
boolean | isCached() 是否为缓冲对象
boolean | isEmpty() 判断集合是否存在元素
boolean | isEOF() 判断当前位置是否为POS_EOF
void | isValidSQL() 效验SQL语句的合法性
void | loadObjsOfCurrPage(int _nPageIndex, int _nPageSize, WCMFilter _filterForLoadID, java.lang.String _sSelectFieldsOfLoadObj)
void | minusWith(BaseObjs _anotherObjs) 与指定集合做减法运算
int | move(int _nStep) 移动指针：从当前位置移动指定的步数
int | move(int _nStep, int _nStart) 移动指针：从指定起始位置移动指定步数
int | moveFirst() 移动指针到第一个元素,若集合为空，置当前指针为POS_BOF
int | moveLast() 移动指针到最后一个元素,若集合为空，置当前指针为POS_EOF
int | moveNext() 移动指针到下一个元素
int | movePrevious() 移动指针到前一个元素
int | moveTo(int _nIndex) 移动指针到指定位置
abstract BaseObjs | newInstance() 生成新的集合对象实例
void | open(WCMFilter _filter) 打开集合
int | position() 取当前指针位置
void | refresh() 刷新函数：用以重新执行过滤函数，刷新对象集
boolean | reloadSpecailData(java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sSelect) 从数据库中重新装载指定的数据
boolean | remove()
boolean | remove(BaseObj _aObj)
boolean | remove(BaseObj _aObj, boolean _bDrop) 从集合中删除指定元素 说明：若指定元素不在集合中，则返回false
boolean | remove(boolean _bDrop) 从集合中删除当前元素
boolean | remove(int _id)
boolean | remove(int _id, boolean _bDrop) 从集合中删除ID为指定值的元素
void | removeAll()
void | removeAll(boolean _bDrop) 删除集合中的所有元素
boolean | removeAt(int _index)
boolean | removeAt(int _index, boolean _bDrop) 从集合中删除指定位置的元素
boolean | set(java.lang.String _sName, java.lang.Object _oValue) 设置集合当前元素的属性
void | setCurrPage(int _pageIndex) 属性设置：当前页码
void | setFilter(WCMFilter _filter)
void | setLoadText(boolean _isLoadText) 设置是否在第一次的时候载入元素的大字段信息
boolean | setMaxBufferSize(int _maxSize) 属性设置：缓冲区最大容量
void | setMaxSize(int _nMaxSize) 设置集合载入的最大数
void | setOrder(java.lang.String _sOrder)
boolean | setPageSize(int _pageSize) 属性设置：分页大小
void | setRecCount(int _nRecCount) 设置本次查询的记录个数
void | setSelect(java.lang.String _sSelect)
int | size() 获取集合的大小
void | update() 更新集合中当前的对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ID_NOT_LOAD

public static final java.lang.Integer ID_NOT_LOAD

IS_DEBUG

public static boolean IS_DEBUG
调试模式开关

BOOKMARK_CURRENT

public static final int BOOKMARK_CURRENT
另请参见：
常量字段值

BOOKMARK_FIRST

public static final int BOOKMARK_FIRST
另请参见：
常量字段值

BOOKMARK_LAST

public static final int BOOKMARK_LAST
另请参见：
常量字段值

DEBUG_USE_TIME

public static long DEBUG_USE_TIME
构造方法详细信息

BaseObjs

public BaseObjs()
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象

BaseObjs

public BaseObjs(int _initCapacity,
                int _incCapacity)
构造函数（默认不指定容量，建立指定）

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

isCached

public boolean isCached()
是否为缓冲对象

返回：
缓冲对象返回true 非缓冲对象返回false

getCacheIndex

public int getCacheIndex()

getIdFieldName

public abstract java.lang.String getIdFieldName()
取对象数据存储的ID字段名。

返回：
ID字段名

getElementClass

public abstract java.lang.Class getElementClass()
取集合元素类

返回：
集合元素类

newInstance

public abstract BaseObjs newInstance()
                              throws java.lang.Exception
生成新的集合对象实例

返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

getClassName

public java.lang.String getClassName(boolean _bIncludePackage)
取该对象的类别名称

参数：
_bIncludePackage - 是否包含package名称
返回：

getParent

public BaseObjs getParent()
获得父集合

返回：
WCMBaseObjs对象

getFilter

public WCMFilter getFilter()
获得集合的过滤器

返回：
数据库过滤器对象WCMFilter

getMaxSize

public int getMaxSize()
获取最大允许集合大小（元素个数） select top筛选

返回：

setMaxSize

public void setMaxSize(int _nMaxSize)
设置集合载入的最大数

参数：
_nMaxSize -

getMaxBufferSize

public int getMaxBufferSize()
提取属性：缓冲区最大容量

返回：
缓冲区最大容量（0表示不限制）

setMaxBufferSize

public boolean setMaxBufferSize(int _maxSize)
属性设置：缓冲区最大容量

参数：
_maxSize - 缓冲区最大容量（0表示不限制）
返回：
若限制大小改变了，则返回true；否则返回false.

size

public int size()
获取集合的大小

返回：

isEmpty

public boolean isEmpty()
判断集合是否存在元素

返回：

clear

public void clear()
清空集合

getPageSize

public int getPageSize()
属性提取：分页大小

返回：
每页元素个数

setPageSize

public boolean setPageSize(int _pageSize)
属性设置：分页大小

参数：
_pageSize - 每页元素个数
返回：
若页面大小改变了，则返回true；否则返回false.

getPageCount

public int getPageCount()
取集合的总页数

返回：
总页数

getCurrPage

public int getCurrPage()
属性提取：当前页码

返回：
当前页码（从0开始）

setCurrPage

public void setCurrPage(int _pageIndex)
属性设置：当前页码

参数：
_pageIndex - 页号（从0开始）
抛出：
WCMException - 装载指定页可能会抛出异常

isValidSQL

public void isValidSQL()
                throws WCMException
效验SQL语句的合法性

抛出：
WCMException - 1、SQL语句非法将抛出异常

refresh

public void refresh()
             throws WCMException
刷新函数：用以重新执行过滤函数，刷新对象集

抛出：
WCMException - 提取数据时可能会抛出异常

getSelectCount

public int getSelectCount()
                   throws WCMException
根据获取集合的Filter指定的条件,得到这一次查询的所有行数 select count(*)

返回：
行数
抛出：
WCMException

open

public void open(WCMFilter _filter)
          throws WCMException
打开集合

参数：
_filter - 筛选对象
抛出：
WCMException - 若集合打开失败，会抛出异常。

filter

public BaseObjs filter(WCMFilter _filter)
                throws WCMException
使用指定的过滤器筛选子集

参数：
_filter - 子集过滤器
返回：
使用指定过滤器筛选的子集
抛出：
WCMException - 筛选子集中可能会抛出异常

getIdAt

public int getIdAt(int _index)
取指定索引位置的元素ID

参数：
_index - 元素索引位置（从0开始）
返回：
指定位置的元素ID；若没有找到，则返回0；若下标越界，会抛出异常。

getAt

public BaseObj getAt(int _index)
通过指定索引获取对象

参数：
_index - 指定索引
返回：
WCMObj 元素对象

indexOf

public int indexOf(int _nId)
通过整型标识id索引对象

参数：
_nId - 指定ID编号
返回：

indexOf

public int indexOf(int _nId,
                   int _nStartPos)

indexOf

public int indexOf(java.lang.Integer _iId)
通过整型标识id索引对象

参数：
_iId - 指定ID编号
返回：

indexOf

public int indexOf(BaseObj _aObj)
获取指定对象所在的序号 注意：索引对象并不改变集合的当前指针位置，故需要在检索后恢复旧的指针位置

参数：
_aObj -
返回：

getById

public BaseObj getById(int _nId)
通过指定Id获取对象

参数：
_nId - 指定ID
返回：
WCMObj元素对象

isBOF

public boolean isBOF()
判断当前位置是否为POS_BOF

返回：

isEOF

public boolean isEOF()
判断当前位置是否为POS_EOF

返回：

position

public int position()
取当前指针位置

返回：

moveNext

public int moveNext()
移动指针到下一个元素

返回：
返回值：指针移动后的当前位置 返回 POS_BOF的情况： (1)currIndex==POS_EOF (2)size()==0 (3)size()>0 && currIndex>=size()-1

movePrevious

public int movePrevious()
移动指针到前一个元素

返回：
返回值：指针移动后的当前位置 返回 POS_BOF的情况： (1)currIndex==POS_BOF (2)size()==0 (3)size()>0 && currIndex==0

moveFirst

public int moveFirst()
移动指针到第一个元素,若集合为空，置当前指针为POS_BOF

返回：
返回移动后的当前指针

moveLast

public int moveLast()
移动指针到最后一个元素,若集合为空，置当前指针为POS_EOF

返回：
返回移动后的当前指针

moveTo

public int moveTo(int _nIndex)
移动指针到指定位置

参数：
_nIndex - 返回移动后的当前指针位置
返回：

move

public int move(int _nStep)
移动指针：从当前位置移动指定的步数

参数：
_nStep - =0不变, >0向后移， <0向前移，
返回：

move

public int move(int _nStep,
                int _nStart)
移动指针：从指定起始位置移动指定步数

参数：
_nStep - 指定步数=0不变, >0向后移， <0向前移，
_nStart - 起始位置
返回：

getCurrent

public BaseObj getCurrent()
获得当前元素对象

返回：
WCMObj

addNew

public final BaseObj addNew()
                     throws WCMException
新建一个对象元素

返回：
新建的对象
抛出：
WCMException

addElement

public boolean addElement(BaseObj _aObj)
                   throws WCMException
添加一个元素

参数：
_aObj - WCMObj元素对象
返回：
返回值：布尔型（若集合中不存在该元素，则返回true；否则，返回false)
抛出：
WCMException

addElement

public boolean addElement(BaseObj _aObj,
                          int _nIndex)
                   throws WCMException
抛出：
WCMException

set

public boolean set(java.lang.String _sName,
                   java.lang.Object _oValue)
            throws WCMException
设置集合当前元素的属性

参数：
_sName - 属性名称
_oValue - 属性值
返回：
boolean,设置成功返回true;否则返回false
抛出：
WCMException

update

public void update()
            throws WCMException
更新集合中当前的对象

抛出：
WCMException

remove

public boolean remove(BaseObj _aObj,
                      boolean _bDrop)
               throws WCMException
从集合中删除指定元素 说明：若指定元素不在集合中，则返回false

参数：
_aObj - 指定对象
_bDrop - 将元素从集合中移去时是否同时删除数据库中的元素
返回：
boolean 删除成功返回true;否则返回false
抛出：
WCMException - 如果当前模式不是普通模式下或删除失败时

remove

public boolean remove(BaseObj _aObj)
               throws WCMException
抛出：
WCMException

remove

public boolean remove(int _id,
                      boolean _bDrop)
               throws WCMException
从集合中删除ID为指定值的元素

参数：
_id - 指定ID号
_bDrop - 将元素从集合中移去时是否同时删除数据库中的元素
返回：
boolean 删除成功返回true;否则返回false
抛出：
WCMException - 如果当前模式不是普通模式下或删除失败时

remove

public boolean remove(int _id)
               throws WCMException
抛出：
WCMException

remove

public boolean remove(boolean _bDrop)
               throws WCMException
从集合中删除当前元素

参数：
_bDrop - 将元素从集合中移去时是否同时删除数据库中的元素
返回：
boolean 删除成功返回true;否则返回false
抛出：
WCMException - 如果当前模式不是普通模式下或删除失败时

remove

public boolean remove()
               throws WCMException
抛出：
WCMException

removeAt

public boolean removeAt(int _index,
                        boolean _bDrop)
                 throws WCMException
从集合中删除指定位置的元素

参数：
_index - 指定位置
_bDrop - 将元素从集合中移去时是否同时删除数据库中的元素
返回：
boolean 删除成功返回true;否则返回false
抛出：
WCMException - 如果当前模式不是普通模式下或删除失败时

removeAt

public boolean removeAt(int _index)
                 throws WCMException
抛出：
WCMException

removeAll

public void removeAll(boolean _bDrop)
               throws WCMException
删除集合中的所有元素

参数：
_bDrop - 将元素从集合中移去时是否同时删除数据库中的元素
抛出：
WCMException - 如果当前模式不是普通模式下或删除失败时

removeAll

public void removeAll()
               throws WCMException
抛出：
WCMException

addWith

public void addWith(BaseObjs _anotherObjs)
             throws WCMException
与指定集合做加法运算

参数：
_anotherObjs - 需要添加的集合
抛出：
WCMException - 如果不是同一类型的集合或添加元素时

minusWith

public void minusWith(BaseObjs _anotherObjs)
               throws WCMException
与指定集合做减法运算

参数：
_anotherObjs - 需要减去的集合对象
抛出：
WCMException - 如果不是同一类型的集合或删除元素时

getIdListAsString

public java.lang.String getIdListAsString(char _chrDelim)

将集合中的所有元素的Id，链接构成字符串；

不同Id之间，以分割符 _chrDelim 分割。

参数：
_chrDelim - 分割符，可省略，默认值","
返回：
集合中所有元素的Id列表；若集合为空，则返回null.

getIdListAsString

public java.lang.String getIdListAsString()

setFilter

public void setFilter(WCMFilter _filter)

setSelect

public void setSelect(java.lang.String _sSelect)

setOrder

public void setOrder(java.lang.String _sOrder)

createInstance

public static BaseObjs createInstance(java.lang.String _sObjsClassName)
                               throws WCMException
产生指定集合对象的实例

参数：
_currUser - 当前操作用户
_sObjsClassName - 指定集合对象的Class Name
返回：
抛出：
WCMException

createInstance

public static BaseObjs createInstance(java.lang.Class _classObjs)
                               throws WCMException
产生指定集合对象的实例

参数：
_currUser - 当前操作用户
_classObjs - 指定集合对象的Class
返回：
抛出：
WCMException

getQueryCount

public int getQueryCount()
                  throws WCMException
获取本次查询的记录数

返回：
抛出：
WCMException

cancelUpdateAll

public void cancelUpdateAll(int _end)
取消集合中指定数量的元素的修改记录

参数：
_end - 元素结束位置，默认为所有

cancelUpdateAll

public void cancelUpdateAll()

cancelUpdate

public void cancelUpdate()
取消当前元素的修改操作

setLoadText

public void setLoadText(boolean _isLoadText)
设置是否在第一次的时候载入元素的大字段信息

参数：
_isLoadText - true/false

reloadSpecailData

public boolean reloadSpecailData(java.lang.String _sFrom,
                                 java.lang.String _sWhere,
                                 java.lang.String _sSelect)
                          throws WCMException
从数据库中重新装载指定的数据

参数：
_sFrom - 指定的From条件
_sWhere - 指定的Where条件
_sSelect - 指定的Select语句
返回：
抛出：
WCMException

addElement

public void addElement(java.lang.String _sIds)

addElements

public void addElements(BaseObjs _objs)

addElement

public void addElement(int _nId)

addElement

public void addElement(java.lang.Integer _iKey)

addElement

public void addElement(int _nId,
                       int _nIndex)

loadObjsOfCurrPage

public void loadObjsOfCurrPage(int _nPageIndex,
                               int _nPageSize,
                               WCMFilter _filterForLoadID,
                               java.lang.String _sSelectFieldsOfLoadObj)
                        throws WCMException
抛出：
WCMException

setRecCount

public void setRecCount(int _nRecCount)
设置本次查询的记录个数

参数：
_nRecCount - 记录个数

getRecCount

public int getRecCount()
获取本次查询的记录个数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseObjsHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 BaseObjsHandler

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
        继承者  com.trs.infra.persistent.BaseObjsHandler
所有已实现的接口：
org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class BaseObjsHandler
extends org.xml.sax.helpers.DefaultHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseObjsHandler(BaseObj _obj)
BaseObjsHandler(BaseObj _obj, java.lang.String _sTagName)
方法摘要
void | characters(char[] ch, int start, int length)
void | endElement(java.lang.String uri, java.lang.String localName, java.lang.String qName)
java.util.List | getWCMObjList()
void | startElement(java.lang.String uri, java.lang.String localName, java.lang.String qName, org.xml.sax.Attributes attributes)
从类 org.xml.sax.helpers.DefaultHandler 继承的方法
endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseObjsHandler

public BaseObjsHandler(BaseObj _obj,
                       java.lang.String _sTagName)

BaseObjsHandler

public BaseObjsHandler(BaseObj _obj)
方法详细信息

startElement

public void startElement(java.lang.String uri,
                         java.lang.String localName,
                         java.lang.String qName,
                         org.xml.sax.Attributes attributes)
指定者：
接口 org.xml.sax.ContentHandler 中的 startElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 startElement

characters

public void characters(char[] ch,
                       int start,
                       int length)
指定者：
接口 org.xml.sax.ContentHandler 中的 characters
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 characters

endElement

public void endElement(java.lang.String uri,
                       java.lang.String localName,
                       java.lang.String qName)
                throws org.xml.sax.SAXException
指定者：
接口 org.xml.sax.ContentHandler 中的 endElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 endElement
抛出：
org.xml.sax.SAXException

getWCMObjList

public java.util.List getWCMObjList()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseObjToXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 BaseObjToXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
直接已知子类：
BaseObjToXmlConverterForSpecialProperty, ChannelXmlConverter, ClassInfoXMLConvertor, ContentExtFieldXmlConverter, ContentStyleXmlConverter, DocumentXmlConverter, FlowNodeXmlConverter, FlowRuleXMLConvertor, FlowXmlConverter, GroupXmlConverter, LogXmlConverter, MetaTableXMLConvertor, MetaViewXMLConvertor, ObjToXmlConverter, ObjToXmlConverterByDOM4j, PageStyleXmlConverter, ResourceStyleXmlConverter, RoleXmlConverter, TempAppendixXmlConverter, TemplateXmlConverter, WidgetXmlConverter
public abstract class BaseObjToXmlConverter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseObjToXmlConverter()
方法摘要
void | addChildElements(org.dom4j.Element currElement, org.dom4j.Element[] childElements)
java.lang.String | getElementTag(BaseObj _baseObj)
java.lang.String | getElementTag(BaseObjs _baseObjs)
java.lang.String | getXmlEncoding() 获取XML的输出字符编码设置
boolean | isAddVersion()
void | setAddVersion(boolean _bAddVersion)
void | setXmlEncoding(java.lang.String _sXmlEncoding) 设置XML的输出字符编码
org.dom4j.Element | toXmlElement(BaseObj _baseObj)
org.dom4j.Element | toXmlElement(BaseObjs _baseObjs, java.lang.String _sFieldsList)
org.dom4j.Element | toXmlElement(java.util.List _listObjs, java.lang.String _sFieldsList)
void | toXMLFile(java.lang.Object _currObj, java.lang.String _sXmlFile)
void | toXMLFile(java.lang.Object _currObj, java.lang.String _sXmlFile, java.lang.String _sXslFile)
void | toXMLFile(java.lang.Object _currObj, java.lang.String _sXMLFile, java.lang.String _XSLFileName, java.lang.String _sFieldsList) 将对象输出为XML文件
java.lang.String | toXMLString(java.lang.Object _currObj)
java.lang.String | toXMLString(java.lang.Object _currObj, java.lang.String _sXslFile)
java.lang.String | toXMLString(java.lang.Object _currObj, java.lang.String _XSLFileName, java.lang.String _sFieldsList) 将对象输出为XML字串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseObjToXmlConverter

public BaseObjToXmlConverter()
方法详细信息

toXMLString

public java.lang.String toXMLString(java.lang.Object _currObj)
                             throws WCMException
抛出：
WCMException

toXMLString

public java.lang.String toXMLString(java.lang.Object _currObj,
                                    java.lang.String _sXslFile)
                             throws WCMException
抛出：
WCMException

toXMLString

public java.lang.String toXMLString(java.lang.Object _currObj,
                                    java.lang.String _XSLFileName,
                                    java.lang.String _sFieldsList)
                             throws WCMException
将对象输出为XML字串

参数：
_currObj -
_XSLFileName -
_sFieldsList -
返回：
抛出：
WCMException

toXMLFile

public void toXMLFile(java.lang.Object _currObj,
                      java.lang.String _sXmlFile)
               throws WCMException
抛出：
WCMException

toXMLFile

public void toXMLFile(java.lang.Object _currObj,
                      java.lang.String _sXmlFile,
                      java.lang.String _sXslFile)
               throws WCMException
抛出：
WCMException

toXMLFile

public void toXMLFile(java.lang.Object _currObj,
                      java.lang.String _sXMLFile,
                      java.lang.String _XSLFileName,
                      java.lang.String _sFieldsList)
               throws WCMException
将对象输出为XML文件

参数：
_currObj -
_sXMLFile -
_XSLFileName -
_sFieldsList -
抛出：
WCMException

toXmlElement

public org.dom4j.Element toXmlElement(BaseObjs _baseObjs,
                                      java.lang.String _sFieldsList)
                               throws WCMException
抛出：
WCMException

toXmlElement

public org.dom4j.Element toXmlElement(java.util.List _listObjs,
                                      java.lang.String _sFieldsList)
                               throws WCMException
抛出：
WCMException

toXmlElement

public org.dom4j.Element toXmlElement(BaseObj _baseObj)
                               throws WCMException
抛出：
WCMException

addChildElements

public void addChildElements(org.dom4j.Element currElement,
                             org.dom4j.Element[] childElements)

getXmlEncoding

public java.lang.String getXmlEncoding()
获取XML的输出字符编码设置

返回：

setXmlEncoding

public void setXmlEncoding(java.lang.String _sXmlEncoding)
设置XML的输出字符编码

参数：
_sXmlEncoding - 指定的字符编码,默认为"UTF-8"

getElementTag

public java.lang.String getElementTag(BaseObjs _baseObjs)

getElementTag

public java.lang.String getElementTag(BaseObj _baseObj)

isAddVersion

public boolean isAddVersion()

setAddVersion

public void setAddVersion(boolean _bAddVersion)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BaseObjToXmlConverterForSpecialProperty

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 BaseObjToXmlConverterForSpecialProperty

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
直接已知子类：
MetaDBFieldXMLConvertor, MetaViewDataToExcel, MetaViewDataToXML, MetaViewFieldXMLConvertor
public abstract class BaseObjToXmlConverterForSpecialProperty
extends BaseObjToXmlConverter

构造方法摘要
BaseObjToXmlConverterForSpecialProperty()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseObjToXmlConverterForSpecialProperty

public BaseObjToXmlConverterForSpecialProperty()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyParameter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 CMyParameter

java.lang.Object
    继承者  com.trs.infra.persistent.CMyParameter

public class CMyParameter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
参数对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyParameter()
CMyParameter(java.lang.String _sName, java.lang.String _sDesc)
方法摘要
java.lang.String | getDesc()
java.lang.String | getName()
java.lang.String | getValue()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyParameter

public CMyParameter()

CMyParameter

public CMyParameter(java.lang.String _sName,
                    java.lang.String _sDesc)
方法详细信息

getName

public java.lang.String getName()
返回：

getValue

public java.lang.String getValue()
返回：

getDesc

public java.lang.String getDesc()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyResultObjs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 CMyResultObjs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.persistent.CMyResultObjs
直接已知子类：
CMyResultSets, XDocuments
public abstract class CMyResultObjs
extends BaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
WCMResult基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
CMyResultObjs()
CMyResultObjs(int _initCapacity, int _incCapacity)
方法摘要
void | open(java.lang.String _strSQL, java.util.List _listParameters, java.lang.String _sIdName)
void | open(java.lang.String _strSQL, java.lang.String _sIdName) 打开集合
void | refresh() 刷新函数：用以重新执行过滤函数，刷新对象集 由于处理机制与缓冲集合不一样需重载父类的接口
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getElementClass, getFilter, getIdAt, getIdFieldName, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, newInstance, open, position, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyResultObjs

public CMyResultObjs()

CMyResultObjs

public CMyResultObjs(int _initCapacity,
                     int _incCapacity)
方法详细信息

open

public void open(java.lang.String _strSQL,
                 java.lang.String _sIdName)
          throws WCMException
打开集合

参数：
_filter - 筛选对象
抛出：
WCMException - 若集合打开失败，会抛出异常。

open

public void open(java.lang.String _strSQL,
                 java.util.List _listParameters,
                 java.lang.String _sIdName)
          throws WCMException
抛出：
WCMException

refresh

public void refresh()
             throws WCMException
刷新函数：用以重新执行过滤函数，刷新对象集 由于处理机制与缓冲集合不一样需重载父类的接口

覆盖：
类 BaseObjs 中的 refresh
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyResultSet

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 CMyResultSet

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.persistent.CMyResultSet
所有已实现的接口：
java.lang.Cloneable
public class CMyResultSet
extends BaseObj

Title: TRS 内容协作平台（TRS WCM）
Description:
WCMResultSet
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
CMyResultSet()
构造函数：保留默认接口
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | setId(int _id) 设置对象ID
boolean | setProperty(java.lang.String _sName, java.lang.Object _oValue)
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

CMyResultSet

public CMyResultSet()
构造函数：保留默认接口

方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：

setProperty

public boolean setProperty(java.lang.String _sName,
                           java.lang.Object _oValue)
                    throws WCMException
覆盖：
类 BaseObj 中的 setProperty
抛出：
WCMException

setId

public void setId(int _id)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyResultSets

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 CMyResultSets

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.persistent.CMyResultObjs
            继承者  com.trs.infra.persistent.CMyResultSets

public class CMyResultSets
extends CMyResultObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
CMyResultSets()
CMyResultSets(int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
void | open(WCMFilter _filter) 打开集合
从类 com.trs.infra.persistent.CMyResultObjs 继承的方法
open, open, refresh
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, position, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyResultSets

public CMyResultSets()

CMyResultSets

public CMyResultSets(int _initCapacity,
                     int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

open

public void open(WCMFilter _filter)
          throws WCMException
打开集合

覆盖：
类 BaseObjs 中的 open
参数：
_filter - 筛选对象
抛出：
WCMException - 若集合打开失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IObjTypeLookup

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
接口 IObjTypeLookup

所有已知实现类：
ObjTypeLookupImpl
public interface IObjTypeLookup

方法摘要
 int lookupByClassName(java.lang.String _sClassName)
lookup the object type by class name

方法详细信息

lookupByClassName

int lookupByClassName(java.lang.String _sClassName)
lookup the object type by class name

参数：
_sClassName - name of the object class
返回：
Returns the object type
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MyBaseObj

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 MyBaseObj

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.persistent.MyBaseObj
所有已实现的接口：
java.lang.Cloneable
public class MyBaseObj
extends BaseObj

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MyBaseObj()
方法摘要
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | setAddMode(boolean _bAddMode)
void | setDbTableName(java.lang.String dbTableName)
void | setId(int _nId) 设置对象ID
void | setIdFieldName(java.lang.String idFieldName)
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MyBaseObj

public MyBaseObj()
方法详细信息

setAddMode

public void setAddMode(boolean _bAddMode)

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

setDbTableName

public void setDbTableName(java.lang.String dbTableName)
参数：
dbTableName -

setIdFieldName

public void setIdFieldName(java.lang.String idFieldName)
参数：
idFieldName -

setId

public void setId(int _nId)
从类 BaseObj 复制的描述
设置对象ID

覆盖：
类 BaseObj 中的 setId

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MyBaseObjs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 MyBaseObjs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.persistent.MyBaseObjs

public class MyBaseObjs
extends BaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
MyBaseObjs()
MyBaseObjs(int _initCapacity, int _incCapacity)
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
void | setDbTableName(java.lang.String dbTableName)
void | setIdFieldName(java.lang.String idFieldName)
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MyBaseObjs

public MyBaseObjs()

MyBaseObjs

public MyBaseObjs(int _initCapacity,
                  int _incCapacity)
参数：
_initCapacity -
_incCapacity -
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

setDbTableName

public void setDbTableName(java.lang.String dbTableName)
参数：
dbTableName -

setIdFieldName

public void setIdFieldName(java.lang.String idFieldName)
参数：
idFieldName -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NullValue

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 NullValue

java.lang.Object
    继承者  com.trs.infra.persistent.NullValue

public class NullValue
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
NullValue(int _nDataType)
方法摘要
int | getDataType()
void | setDataType(int dataType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NullValue

public NullValue(int _nDataType)
方法详细信息

getDataType

public int getDataType()
返回：

setDataType

public void setDataType(int dataType)
参数：
dataType -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectTypeConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 ObjectTypeConfig

java.lang.Object
    继承者  com.trs.infra.persistent.ObjectTypeConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class ObjectTypeConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ObjectTypeConfig()
方法摘要
java.lang.String | getName() 获取配置对象的名称
java.lang.Class | getObjectClass()
java.lang.String | getObjectClassName()
int | getObjectType()
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setObjectClass(java.lang.Class objectClass)
void | setObjectClassName(java.lang.String objectClassName)
void | setObjectType(int objectType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectTypeConfig

public ObjectTypeConfig()
方法详细信息

getObjectType

public int getObjectType()
返回：

setObjectType

public void setObjectType(int objectType)
参数：
objectType -

getObjectClassName

public java.lang.String getObjectClassName()
返回：

setObjectClassName

public void setObjectClassName(java.lang.String objectClassName)
参数：
objectClassName -

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getObjectClass

public java.lang.Class getObjectClass()
返回：

setObjectClass

public void setObjectClass(java.lang.Class objectClass)
参数：
objectClass -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectTypesFinder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 ObjectTypesFinder

java.lang.Object
    继承者  com.trs.infra.persistent.ObjectTypesFinder

public class ObjectTypesFinder
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ObjectTypesFinder()
方法摘要
static java.lang.Class findObjectClassByType(int _nObjType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectTypesFinder

public ObjectTypesFinder()
方法详细信息

findObjectClassByType

public static java.lang.Class findObjectClassByType(int _nObjType)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjToXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 ObjToXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.infra.persistent.ObjToXmlConverter

public class ObjToXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
BaseObj数据转换为XML格式的转换者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ObjToXmlConverter()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjToXmlConverter

public ObjToXmlConverter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjToXmlConverterByDOM4j

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 ObjToXmlConverterByDOM4j

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.infra.persistent.ObjToXmlConverterByDOM4j

public class ObjToXmlConverterByDOM4j
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
BaseObj数据转换为XML格式的转换者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ObjToXmlConverterByDOM4j()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjToXmlConverterByDOM4j

public ObjToXmlConverterByDOM4j()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjTypeLookupHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 ObjTypeLookupHelper

java.lang.Object
    继承者  com.trs.infra.persistent.ObjTypeLookupHelper

public class ObjTypeLookupHelper
extends java.lang.Object

方法摘要
static int | lookupByClassName(java.lang.String _sClassName) lookup the object type by class name
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

lookupByClassName

public static int lookupByClassName(java.lang.String _sClassName)
lookup the object type by class name

参数：
_sClassName - name of the object class
返回：
Returns the object type

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjTypeLookupImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 ObjTypeLookupImpl

java.lang.Object
    继承者  com.trs.infra.persistent.ObjTypeLookupImpl
所有已实现的接口：
IObjTypeLookup
public class ObjTypeLookupImpl
extends java.lang.Object
implements IObjTypeLookup

字段摘要
static java.lang.String CONFIG_FILE
config file
构造方法摘要
ObjTypeLookupImpl()
constructor: default
方法摘要
 int lookupByClassName(java.lang.String _sClassName)
lookup the object type by class name
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CONFIG_FILE

public static java.lang.String CONFIG_FILE
config file

构造方法详细信息

ObjTypeLookupImpl

public ObjTypeLookupImpl()
constructor: default

方法详细信息

lookupByClassName

public int lookupByClassName(java.lang.String _sClassName)
从接口 IObjTypeLookup 复制的描述
lookup the object type by class name

指定者：
接口 IObjTypeLookup 中的 lookupByClassName
参数：
_sClassName - name of the object class
返回：
Returns the object type
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.persistent
接口
IObjTypeLookup
类
AbstractXmlToObjConverter
BaseObj
BaseObjHandler
BaseObjHelper
BaseObjs
BaseObjsHandler
BaseObjToXmlConverter
BaseObjToXmlConverterForSpecialProperty
CMyParameter
CMyResultObjs
CMyResultSet
CMyResultSets
MyBaseObj
MyBaseObjs
NullValue
ObjectTypeConfig
ObjectTypesFinder
ObjToXmlConverter
ObjToXmlConverterByDOM4j
ObjTypeLookupHelper
ObjTypeLookupImpl
WCMFilter
XmlObject
XmlToObjConverter
XmlToObjConverterByDOM4j


com.trs.infra.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.persistent

接口摘要
IObjTypeLookup

类摘要
AbstractXmlToObjConverter | Title: TRS 内容协作平台（TRS WCM） Description: XML文件到BaseObj的转换 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObj |
BaseObjHandler | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjs |
BaseObjsHandler | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjToXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: 对象到XML文件(WCM格式)转换实现 只能转换BaseObj/BaseObjs及其子类的对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjToXmlConverterForSpecialProperty |
CMyParameter | Title: TRS 内容协作平台（TRS WCM） Description: 参数对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyResultObjs | Title: TRS 内容协作平台（TRS WCM） Description: WCMResult基类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyResultSet | Title: TRS 内容协作平台（TRS WCM） Description: WCMResultSet Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyResultSets | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MyBaseObj | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MyBaseObjs | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
NullValue | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectTypeConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectTypesFinder | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjToXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: BaseObj数据转换为XML格式的转换者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjToXmlConverterByDOM4j | Title: TRS 内容协作平台（TRS WCM） Description: BaseObj数据转换为XML格式的转换者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjTypeLookupHelper |
ObjTypeLookupImpl |
WCMFilter |
XmlObject | Title: TRS 内容协作平台（TRS WCM） Description: XML节点对应对象的定义和实现: 当前节点对应的对象及其子节点所对应的对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XmlToObjConverter | Title: TRS 内容协作平台（TRS WCM） Description: XML文件到BaseObj的转换 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XmlToObjConverterByDOM4j | Title: TRS 内容协作平台（TRS WCM） Description: XML文件到BaseObj的转换 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.AbstractXmlToObjConverter
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.infra.persistent.CMyResultSet
      • com.trs.infra.persistent.MyBaseObj
    • com.trs.infra.persistent.BaseObjHelper
    • com.trs.infra.persistent.BaseObjs
      • com.trs.infra.persistent.CMyResultObjs
        • com.trs.infra.persistent.CMyResultSets
      • com.trs.infra.persistent.MyBaseObjs
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
      • com.trs.infra.persistent.ObjToXmlConverter
      • com.trs.infra.persistent.ObjToXmlConverterByDOM4j
    • com.trs.infra.persistent.CMyParameter
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.trs.infra.persistent.BaseObjHandler
      • com.trs.infra.persistent.BaseObjsHandler
    • com.trs.infra.persistent.NullValue
    • com.trs.infra.persistent.ObjectTypeConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.ObjectTypesFinder
    • com.trs.infra.persistent.ObjTypeLookupHelper
    • com.trs.infra.persistent.ObjTypeLookupImpl (implements com.trs.infra.persistent.IObjTypeLookup)
    • com.trs.infra.persistent.WCMFilter (implements java.lang.Cloneable)
    • com.trs.infra.persistent.XmlObject
    • com.trs.infra.persistent.XmlToObjConverter
    • com.trs.infra.persistent.XmlToObjConverterByDOM4j

接口分层结构

  • com.trs.infra.persistent.IObjTypeLookup


软件包 com.trs.infra.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent
的使用

使用 com.trs.infra.persistent 的软件包
com.trs.ajaxservice |
com.trs.cluster |
com.trs.cluster.receiver |
com.trs.cms.auth.domain |
com.trs.cms.auth.logger |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.logger |
com.trs.cms.process |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.cms.process.xml |
com.trs.components.ckm |
com.trs.components.comment.persistent |
com.trs.components.comment.service |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.domain |
com.trs.components.common.publish.domain.distribute |
com.trs.components.common.publish.domain.element |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.filter |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.govinfo |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.db |
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.definition |
com.trs.components.metadata.definition.xml |
com.trs.components.metadata.publish |
com.trs.components.metadata.service |
com.trs.components.metadata.service.portervisitors |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.service.portervisitors |
com.trs.components.wcm.content.trsserver |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.logger |
com.trs.components.wcm.process |
com.trs.components.wcm.process.service.flowexporter |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.stat.chart |
com.trs.components.wcm.stat.domain |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.media |
com.trs.components.web |
com.trs.db.update |
com.trs.infra.persistent |
com.trs.infra.persistent.cache |
com.trs.infra.persistent.db |
com.trs.infra.persistent.listener |
com.trs.infra.persistent.util |
com.trs.infra.support.config |
com.trs.infra.support.file |
com.trs.infra.support.log |
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.infra.util.database |
com.trs.infra.util.job |
com.trs.km.auth |
com.trs.presentation.login |
com.trs.presentation.util |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.config |
com.trs.wcm.customize |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |
com.trs.webframework.context |
com.trs.webframework.controler |

com.trs.ajaxservice 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter
XmlToObjConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cluster 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.cluster.receiver 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.cms.auth.domain 使用的 com.trs.infra.persistent 中的类
BaseObj
WCMFilter

com.trs.cms.auth.logger 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.cms.auth.persistent 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilter

com.trs.cms.content 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.cms.logger 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.cms.process 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.cms.process.definition 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.cms.process.engine 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.cms.process.xml 使用的 com.trs.infra.persistent 中的类
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XmlObject
Title: TRS 内容协作平台（TRS WCM）
Description:
XML节点对应对象的定义和实现:
当前节点对应的对象及其子节点所对应的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.components.comment.persistent 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.comment.service 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.common.address 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.bookmark 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.calendar 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.conjection.persistent 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.job 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.message 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.publish.domain 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.common.publish.domain.distribute 使用的 com.trs.infra.persistent 中的类
BaseObj
WCMFilter

com.trs.components.common.publish.domain.element 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.components.common.publish.domain.tagparser 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.components.common.publish.domain.taskdispatch 使用的 com.trs.infra.persistent 中的类
BaseObj
WCMFilter

com.trs.components.common.publish.domain.template 使用的 com.trs.infra.persistent 中的类
BaseObj
WCMFilter

com.trs.components.common.publish.persistent.distribute 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.publish.persistent.element 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.common.publish.persistent.publisher 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.publish.persistent.taskdispatch 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.common.publish.persistent.template 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilter

com.trs.components.common.publish.widget 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilter

com.trs.components.common.trsad 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs

com.trs.components.common.trsvote 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs

com.trs.components.filter 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.gkml.sqgk.persistent 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.govinfo 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.components.infoview 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.infoview.db 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.components.infoview.helper 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.infoview.persistent 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.metadata.center 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.metadata.center.xml 使用的 com.trs.infra.persistent 中的类
AbstractXmlToObjConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObj
BaseObjs
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjToXmlConverterForSpecialProperty

com.trs.components.metadata.definition 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.metadata.definition.xml 使用的 com.trs.infra.persistent 中的类
AbstractXmlToObjConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjToXmlConverterForSpecialProperty

com.trs.components.metadata.publish 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.metadata.service 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.metadata.service.portervisitors 使用的 com.trs.infra.persistent 中的类
BaseObj
XmlObject
Title: TRS 内容协作平台（TRS WCM）
Description:
XML节点对应对象的定义和实现:
当前节点对应的对象及其子节点所对应的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.special 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.stat 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.content 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.content.domain 使用的 com.trs.infra.persistent 中的类
AbstractXmlToObjConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObj
WCMFilter

com.trs.components.wcm.content.persistent 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyResultObjs
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMResult基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilter

com.trs.components.wcm.content.service.portervisitors 使用的 com.trs.infra.persistent 中的类
BaseObj
XmlObject
Title: TRS 内容协作平台（TRS WCM）
Description:
XML节点对应对象的定义和实现:
当前节点对应的对象及其子节点所对应的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.trsserver 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.wcm.customize 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.epress 使用的 com.trs.infra.persistent 中的类
BaseObj
WCMFilter

com.trs.components.wcm.individuation 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.logger 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.components.wcm.process 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.components.wcm.process.service.flowexporter 使用的 com.trs.infra.persistent 中的类
BaseObj
XmlObject
Title: TRS 内容协作平台（TRS WCM）
Description:
XML节点对应对象的定义和实现:
当前节点对应的对象及其子节点所对应的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.publish.element 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.wcm.publish.logo 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.publish.region 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.publish.tagparser 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.wcm.recent 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.resource 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.stat 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
CMyResultSets
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilter

com.trs.components.wcm.stat.chart 使用的 com.trs.infra.persistent 中的类
CMyResultSets
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.stat.domain 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.components.wcm.wcmx.help 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.components.wcm.wcmx.media 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs

com.trs.components.web 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.db.update 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.infra.persistent 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyResultObjs
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMResult基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjTypeLookup
WCMFilter
XmlObject
Title: TRS 内容协作平台（TRS WCM）
Description:
XML节点对应对象的定义和实现:
当前节点对应的对象及其子节点所对应的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.infra.persistent.db 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.infra.persistent.listener 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.infra.persistent.util 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.infra.support.config 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.infra.support.file 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.infra.support.log 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
BaseObjToXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilter

com.trs.infra.support.security 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.infra.util.database 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.infra.util.job 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.km.auth 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.presentation.login 使用的 com.trs.infra.persistent 中的类
BaseObj

com.trs.presentation.util 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.service 使用的 com.trs.infra.persistent 中的类
BaseObj
CMyResultSets
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilter

com.trs.service.impl 使用的 com.trs.infra.persistent 中的类
BaseObj
CMyResultSets
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilter

com.trs.wcm.config 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.wcm.customize 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.wcm.old 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.wcm.photo 使用的 com.trs.infra.persistent 中的类
BaseObj
BaseObjs
WCMFilter

com.trs.wcm.photo.impl 使用的 com.trs.infra.persistent 中的类
WCMFilter

com.trs.webframework.context 使用的 com.trs.infra.persistent 中的类
BaseObj
WCMFilter

com.trs.webframework.controler 使用的 com.trs.infra.persistent 中的类
BaseObj

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMFilter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 WCMFilter

java.lang.Object
    继承者  com.trs.infra.persistent.WCMFilter
所有已实现的接口：
java.lang.Cloneable
public class WCMFilter
extends java.lang.Object
implements java.lang.Cloneable

字段摘要
static int | DEFAULT_OPEN_RECORD_COUNT Comment for MAX_OPEN_RECORD_COUNT ：打开的最大记录数
static int | NOTLIMITED_OPEN_OPEN_RECORD_COUNT Comment for NOTLIMITED_OPEN_OPEN_RECORD_COUNT ：不限制集合的记录数
构造方法摘要
WCMFilter()
WCMFilter(QueryFilter _queryFilter)
WCMFilter(java.lang.String _from, java.lang.String _where, java.lang.String _order)
WCMFilter(java.lang.String _from, java.lang.String _where, java.lang.String _order, java.lang.String _select)
过滤器构造函数
WCMFilter(java.lang.String _from, java.lang.String _where, java.lang.String _order, java.lang.String _select, int _nMaxSize)
WCMFilter(java.lang.String _from, java.lang.String _where, java.lang.String _order, java.lang.String _select, java.lang.String _orderSelect)
WCMFilter(WCMFilter _filter)
方法摘要
void | addSearchValues(CMyDateTime _value)
void | addSearchValues(double _value)
void | addSearchValues(float _value)
void | addSearchValues(int _nSearchValue)
void | addSearchValues(int _nIndex, CMyDateTime _dtTime)
void | addSearchValues(int _nIndex, double _dSearchValue)
void | addSearchValues(int _nIndex, float _fSearchValue)
void | addSearchValues(int _nIndex, int _nSearchValue)
void | addSearchValues(int _nIndex, java.lang.String _sSearchValue)
void | addSearchValues(long _lSearchValue)
void | addSearchValues(java.lang.String _value)
void | clear() 清除过滤器的所有参数
java.lang.Object | clone() 过滤器的克隆
boolean | containsSelectFields(java.lang.String _sFieldName)
void | copy(WCMFilter _filterSrc) 过滤器复制函数
java.lang.String | findSelectField(java.lang.String _fieldName) 在Select子句中查找指定的字段。
java.lang.String | getFrom() 获取表名称列表，多个表用","分割
int | getMaxRowNumber() 获取查询的最大行数
java.lang.String | getOderSelect()
java.lang.String | getOrder() 获取排序条件
int | getPageSize()
java.util.List | getSearchValues()
java.lang.String | getSelect() 获取抽取的字段名列表
java.lang.String | getWhere() 获取查询条件
boolean | isForceFirstLoadIds()
boolean | isFromMultiTable()
boolean | isToGetAll() 判断是否为全集，即没有设定任何筛选条件
static void | main(java.lang.String[] args)
WCMFilter | mergeWith(WCMFilter _filter) 过滤器的合并
void | setForceFirstLoadIds(boolean forceFirstLoadIds)
void | setFrom(java.lang.String _from) 设置表名称列表，多个表用","分割
void | setMaxRowNumber(int _maxRowNumber) 设置查询的最大行数
void | setOrder(java.lang.String _order) 设置排序条件
void | setOrderSelect(java.lang.String _orderSelect)
void | setPageSize(int pageSize)
void | setSearchValues(java.util.List searchValues)
void | setSelect(java.lang.String _select) 设置抽取的字段名列表
void | setWhere(java.lang.String _where) 设置查询条件
java.lang.String | toCountQueryInfo()
java.lang.String | toCountSQL()
java.lang.String | toSQL() 创建SQL语句
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_OPEN_RECORD_COUNT

public static int DEFAULT_OPEN_RECORD_COUNT
Comment for MAX_OPEN_RECORD_COUNT ：打开的最大记录数

NOTLIMITED_OPEN_OPEN_RECORD_COUNT

public static int NOTLIMITED_OPEN_OPEN_RECORD_COUNT
Comment for NOTLIMITED_OPEN_OPEN_RECORD_COUNT ：不限制集合的记录数

构造方法详细信息

WCMFilter

public WCMFilter()

WCMFilter

public WCMFilter(WCMFilter _filter)

WCMFilter

public WCMFilter(java.lang.String _from,
                 java.lang.String _where,
                 java.lang.String _order)

WCMFilter

public WCMFilter(java.lang.String _from,
                 java.lang.String _where,
                 java.lang.String _order,
                 java.lang.String _select)
过滤器构造函数

参数：
_from - String对象SQL语句中From部分，不包含From关键字
_where - String对象SQL语句中Where部分，不包含Where关键字
_order - String对象SQL语句中Order by部分，不包含Order by关键字
_select - String对象SQL语句中Select部分，不包含Select关键字

WCMFilter

public WCMFilter(java.lang.String _from,
                 java.lang.String _where,
                 java.lang.String _order,
                 java.lang.String _select,
                 java.lang.String _orderSelect)

WCMFilter

public WCMFilter(java.lang.String _from,
                 java.lang.String _where,
                 java.lang.String _order,
                 java.lang.String _select,
                 int _nMaxSize)

WCMFilter

public WCMFilter(QueryFilter _queryFilter)
方法详细信息

clear

public void clear()
清除过滤器的所有参数

copy

public void copy(WCMFilter _filterSrc)
过滤器复制函数

参数：
_filterSrc - WCMFilter对象，被复制的过滤器

clone

public java.lang.Object clone()
过滤器的克隆

覆盖：
类 java.lang.Object 中的 clone
返回：
Object过滤器对象(可以强制转换成WCMFilter)

getFrom

public java.lang.String getFrom()
获取表名称列表，多个表用","分割

返回：
String对象SQL语句中From部分，不包含From关键字

setFrom

public void setFrom(java.lang.String _from)
设置表名称列表，多个表用","分割

参数：
_from - String对象SQL语句中From部分，不包含From关键字

getWhere

public java.lang.String getWhere()
获取查询条件

返回：

setWhere

public void setWhere(java.lang.String _where)
设置查询条件

参数：
_where - String对象SQL语句中Where部分，不包含Where关键字

getOrder

public java.lang.String getOrder()
获取排序条件

返回：
String对象SQL语句中Order by部分，不包含Order by关键字

setOrder

public void setOrder(java.lang.String _order)
设置排序条件

参数：
_order - String对象SQL语句中Order by部分，不包含Order by关键字

getSelect

public java.lang.String getSelect()
获取抽取的字段名列表

返回：
String对象SQL语句中Select部分，不包含Select关键字

setSelect

public void setSelect(java.lang.String _select)
设置抽取的字段名列表

参数：
_select - String对象SQL语句中Select部分，不包含Select关键字

getOderSelect

public java.lang.String getOderSelect()

setOrderSelect

public void setOrderSelect(java.lang.String _orderSelect)

getMaxRowNumber

public int getMaxRowNumber()
获取查询的最大行数

返回：
int数.SQL语句中,SQL server 的top部分/Orcal 的rownum,不含关键字

setMaxRowNumber

public void setMaxRowNumber(int _maxRowNumber)
设置查询的最大行数

参数：
_maxRowNumber - int数,对应SQL Server中的top/Orcal中的rownum

mergeWith

public WCMFilter mergeWith(WCMFilter _filter)
过滤器的合并

参数：
_filter - WCMFilter需要和当前过滤器对象合并的过滤器
返回：
boolean合并成功返回true;否则返回false

toSQL

public java.lang.String toSQL()
创建SQL语句

返回：
String根据设定的条件以及作用对象后组合的SQL语句

toCountSQL

public java.lang.String toCountSQL()

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

toCountQueryInfo

public java.lang.String toCountQueryInfo()

isToGetAll

public boolean isToGetAll()
判断是否为全集，即没有设定任何筛选条件

返回：

findSelectField

public java.lang.String findSelectField(java.lang.String _fieldName)
在Select子句中查找指定的字段。若有As语句，则一同提取。

参数：
_fieldName - 指定字段名称
返回：
返回有关指定字段的筛选字段

main

public static void main(java.lang.String[] args)

getSearchValues

public java.util.List getSearchValues()
返回：

setSearchValues

public void setSearchValues(java.util.List searchValues)
参数：
searchValues -

addSearchValues

public void addSearchValues(int _nIndex,
                            int _nSearchValue)

addSearchValues

public void addSearchValues(int _nSearchValue)

addSearchValues

public void addSearchValues(long _lSearchValue)

addSearchValues

public void addSearchValues(int _nIndex,
                            float _fSearchValue)

addSearchValues

public void addSearchValues(float _value)

addSearchValues

public void addSearchValues(int _nIndex,
                            double _dSearchValue)

addSearchValues

public void addSearchValues(double _value)

addSearchValues

public void addSearchValues(int _nIndex,
                            java.lang.String _sSearchValue)

addSearchValues

public void addSearchValues(java.lang.String _value)

addSearchValues

public void addSearchValues(int _nIndex,
                            CMyDateTime _dtTime)

addSearchValues

public void addSearchValues(CMyDateTime _value)

isForceFirstLoadIds

public boolean isForceFirstLoadIds()
返回：

setForceFirstLoadIds

public void setForceFirstLoadIds(boolean forceFirstLoadIds)
参数：
forceFirstLoadIds -

getPageSize

public int getPageSize()
返回：

setPageSize

public void setPageSize(int pageSize)
参数：
pageSize -

containsSelectFields

public boolean containsSelectFields(java.lang.String _sFieldName)

isFromMultiTable

public boolean isFromMultiTable()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlObject

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 XmlObject

java.lang.Object
    继承者  com.trs.infra.persistent.XmlObject

public class XmlObject
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
XML节点对应对象的定义和实现:
当前节点对应的对象及其子节点所对应的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
XmlObject()
方法摘要
void | addChild(java.lang.String _sTagName, XmlObject[] _currChildren)
XmlObject[] | getChild(java.lang.String _sTagName)
int | getChildrenSize()
java.lang.String[] | getChildTagNames()
BaseObj | getCurrentObj()
boolean | hasChild(java.lang.String _sTagName)
boolean | hasChildren()
void | setCurrentObj(BaseObj _currObj)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlObject

public XmlObject()
方法详细信息

addChild

public void addChild(java.lang.String _sTagName,
                     XmlObject[] _currChildren)

setCurrentObj

public void setCurrentObj(BaseObj _currObj)

getChild

public XmlObject[] getChild(java.lang.String _sTagName)

getCurrentObj

public BaseObj getCurrentObj()

getChildTagNames

public java.lang.String[] getChildTagNames()

hasChild

public boolean hasChild(java.lang.String _sTagName)

getChildrenSize

public int getChildrenSize()

hasChildren

public boolean hasChildren()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlToObjConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 XmlToObjConverter

java.lang.Object
    继承者  com.trs.infra.persistent.XmlToObjConverter
直接已知子类：
XmlToRightConvertor
public class XmlToObjConverter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
XmlToObjConverter(int _nImportType)
方法摘要
XmlObject[] | convertXml(java.lang.String _sXMLContent, java.lang.String _sFieldsList)
XmlObject[] | convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList) parse the xml file
java.lang.String | getXmlEncoding() 获取XML的输出字符编码设置
void | registPersistentObj(java.lang.String _sTagName, java.lang.Class _releatClazz) 注册TagName 与相应对象的映射
void | setXmlEncoding(java.lang.String _sXmlEncoding) 设置XML的输出字符编码
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlToObjConverter

public XmlToObjConverter(int _nImportType)
方法详细信息

registPersistentObj

public void registPersistentObj(java.lang.String _sTagName,
                                java.lang.Class _releatClazz)
注册TagName 与相应对象的映射

参数：
_sTagName -
_releatClazz -

convertXml

public XmlObject[] convertXml(java.lang.String _sXmlFile,
                              java.lang.String _sXslFile,
                              java.lang.String _sFieldsList)
                       throws WCMException
parse the xml file

参数：
_sXmlFile -
_sXslFile -
_sFieldsList -
返回：
抛出：
WCMException

convertXml

public XmlObject[] convertXml(java.lang.String _sXMLContent,
                              java.lang.String _sFieldsList)
                       throws WCMException
抛出：
WCMException

getXmlEncoding

public java.lang.String getXmlEncoding()
获取XML的输出字符编码设置

返回：

setXmlEncoding

public void setXmlEncoding(java.lang.String _sXmlEncoding)
设置XML的输出字符编码

参数：
_sXmlEncoding - 指定的字符编码,默认为"UTF-8"
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlToObjConverterByDOM4j

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent
类 XmlToObjConverterByDOM4j

java.lang.Object
    继承者  com.trs.infra.persistent.XmlToObjConverterByDOM4j

public class XmlToObjConverterByDOM4j
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
XmlToObjConverterByDOM4j(int _nImportType)
方法摘要
XmlObject[] | convertXml(java.lang.String _sXMLContent, java.lang.String _sFieldsList)
XmlObject[] | convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList) parse the xml file
java.lang.String | getXmlEncoding() 获取XML的输出字符编码设置
void | registPersistentObj(java.lang.String _sTagName, java.lang.Class _releatClazz) 注册TagName 与相应对象的映射
void | setXmlEncoding(java.lang.String _sXmlEncoding) 设置XML的输出字符编码
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlToObjConverterByDOM4j

public XmlToObjConverterByDOM4j(int _nImportType)
方法详细信息

registPersistentObj

public void registPersistentObj(java.lang.String _sTagName,
                                java.lang.Class _releatClazz)
注册TagName 与相应对象的映射

参数：
_sTagName -
_releatClazz -

convertXml

public XmlObject[] convertXml(java.lang.String _sXmlFile,
                              java.lang.String _sXslFile,
                              java.lang.String _sFieldsList)
                       throws WCMException
parse the xml file

参数：
_sXmlFile -
_sXslFile -
_sFieldsList -
返回：
抛出：
WCMException

convertXml

public XmlObject[] convertXml(java.lang.String _sXMLContent,
                              java.lang.String _sFieldsList)
                       throws WCMException
抛出：
WCMException

getXmlEncoding

public java.lang.String getXmlEncoding()
获取XML的输出字符编码设置

返回：

setXmlEncoding

public void setXmlEncoding(java.lang.String _sXmlEncoding)
设置XML的输出字符编码

参数：
_sXmlEncoding - 指定的字符编码,默认为"UTF-8"
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CachedObjectConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.cache
类 CachedObjectConfig

java.lang.Object
    继承者  com.trs.infra.persistent.cache.CachedObjectConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class CachedObjectConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CachedObjectConfig()
方法摘要
java.lang.Class | getCachedObjectClass()
java.lang.String | getClassName()
java.lang.String | getName() 获取配置对象的名称
void | setClassName(java.lang.String className)
void | setName(java.lang.String name) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CachedObjectConfig

public CachedObjectConfig()
方法详细信息

getClassName

public java.lang.String getClassName()
返回：

getCachedObjectClass

public java.lang.Class getCachedObjectClass()

setClassName

public void setClassName(java.lang.String className)
参数：
className -

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：

setName

public void setName(java.lang.String name)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
name -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CachedPOMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.cache
类 CachedPOMgr

java.lang.Object
    继承者  com.trs.infra.persistent.cache.CachedPOMgr
所有已实现的接口：
ICachedPOMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, ICacheMgr
public class CachedPOMgr
extends java.lang.Object
implements ICachedPOMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
被缓冲的持久化对象的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CachedPOMgr()
方法摘要
void | clear() 清除系统所有的Cache
java.util.Hashtable | getBuffer(java.lang.Class _objClass)
java.util.Hashtable | getBuffer(int _nBufferIndex) 取指定缓冲区
int | getCacheIndex(java.lang.Class _objClass)
int | getCacheIndex(java.lang.String _sClassName)
CachedObjectConfig[] | getConfigs()
BaseObj | getObjFromBuffer(java.lang.Class _objClass, int _objId)
BaseObj | getObjFromBuffer(java.lang.Class _objClass, java.lang.Object _key)
BaseObj | getObjFromBuffer(java.lang.String _sClassName, int _objId)
boolean | init() 初始化当前的Cache
boolean | isCached(java.lang.Class _objClass)
boolean | isCached(java.lang.String _sClassName)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
boolean | reinit()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CachedPOMgr

public CachedPOMgr()
方法详细信息

init

public boolean init()
             throws WCMException
从接口 ICacheMgr 复制的描述
初始化当前的Cache

指定者：
接口 ICacheMgr 中的 init
返回：
抛出：
WCMException

getBuffer

public java.util.Hashtable getBuffer(int _nBufferIndex)
                              throws WCMException
取指定缓冲区

指定者：
接口 ICachedPOMgr 中的 getBuffer
参数：
_nBufferIndex - 指定缓冲对象类别索引
返回：
抛出：
WCMException

clear

public void clear()
从接口 ICacheMgr 复制的描述
清除系统所有的Cache

指定者：
接口 ICacheMgr 中的 clear

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO

isCached

public boolean isCached(java.lang.Class _objClass)
指定者：
接口 ICachedPOMgr 中的 isCached

isCached

public boolean isCached(java.lang.String _sClassName)
指定者：
接口 ICachedPOMgr 中的 isCached

getCacheIndex

public int getCacheIndex(java.lang.Class _objClass)
指定者：
接口 ICachedPOMgr 中的 getCacheIndex

getCacheIndex

public int getCacheIndex(java.lang.String _sClassName)
指定者：
接口 ICachedPOMgr 中的 getCacheIndex

getObjFromBuffer

public BaseObj getObjFromBuffer(java.lang.String _sClassName,
                                int _objId)
                         throws WCMException
指定者：
接口 ICachedPOMgr 中的 getObjFromBuffer
抛出：
WCMException

getObjFromBuffer

public BaseObj getObjFromBuffer(java.lang.Class _objClass,
                                int _objId)
                         throws WCMException
指定者：
接口 ICachedPOMgr 中的 getObjFromBuffer
抛出：
WCMException

getObjFromBuffer

public BaseObj getObjFromBuffer(java.lang.Class _objClass,
                                java.lang.Object _key)
                         throws WCMException
指定者：
接口 ICachedPOMgr 中的 getObjFromBuffer
抛出：
WCMException

getConfigs

public CachedObjectConfig[] getConfigs()
返回：

getBuffer

public java.util.Hashtable getBuffer(java.lang.Class _objClass)
                              throws WCMException
指定者：
接口 ICachedPOMgr 中的 getBuffer
抛出：
WCMException

reinit

public boolean reinit()
               throws WCMException
指定者：
接口 ICacheMgr 中的 reinit
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICachedPOMgr

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.cache
接口 ICachedPOMgr

所有超级接口：
ICacheMgr, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知实现类：
CachedPOMgr
public interface ICachedPOMgr
extends ICacheMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.util.Hashtable | getBuffer(java.lang.Class _objClass)
java.util.Hashtable | getBuffer(int _nBufferIndex)
int | getCacheIndex(java.lang.Class _objClass)
int | getCacheIndex(java.lang.String _sClassName)
BaseObj | getObjFromBuffer(java.lang.Class _objClass, int _objId)
BaseObj | getObjFromBuffer(java.lang.Class _objClass, java.lang.Object _key)
BaseObj | getObjFromBuffer(java.lang.String _sClassName, int _objId)
boolean | isCached(java.lang.Class _objClass)
boolean | isCached(java.lang.String _sClassName)
从接口 com.trs.infra.support.cache.ICacheMgr 继承的方法
clear, init, reinit
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

getObjFromBuffer

BaseObj getObjFromBuffer(java.lang.String _sClassName,
                         int _objId)
                         throws WCMException
抛出：
WCMException

getObjFromBuffer

BaseObj getObjFromBuffer(java.lang.Class _objClass,
                         int _objId)
                         throws WCMException
抛出：
WCMException

getObjFromBuffer

BaseObj getObjFromBuffer(java.lang.Class _objClass,
                         java.lang.Object _key)
                         throws WCMException
抛出：
WCMException

getBuffer

java.util.Hashtable getBuffer(java.lang.Class _objClass)
                              throws WCMException
抛出：
WCMException

getBuffer

java.util.Hashtable getBuffer(int _nBufferIndex)
                              throws WCMException
抛出：
WCMException

isCached

boolean isCached(java.lang.Class _objClass)
                 throws WCMException
抛出：
WCMException

isCached

boolean isCached(java.lang.String _sClassName)
                 throws WCMException
抛出：
WCMException

getCacheIndex

int getCacheIndex(java.lang.Class _objClass)
                  throws WCMException
抛出：
WCMException

getCacheIndex

int getCacheIndex(java.lang.String _sClassName)
                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.persistent.cache
接口
ICachedPOMgr
类
CachedObjectConfig
CachedPOMgr


com.trs.infra.persistent.cache

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.persistent.cache

接口摘要
ICachedPOMgr Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
CachedObjectConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CachedPOMgr | Title: TRS 内容协作平台（TRS WCM） Description: 被缓冲的持久化对象的管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.persistent.cache 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent.cache 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.cache.CachedObjectConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.cache.CachedPOMgr (implements com.trs.infra.persistent.cache.ICachedPOMgr)

接口分层结构

  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.infra.persistent.cache.ICachedPOMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
        • com.trs.infra.persistent.cache.ICachedPOMgr
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
        • com.trs.infra.persistent.cache.ICachedPOMgr


软件包 com.trs.infra.persistent.cache 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent.cache
的使用

使用 com.trs.infra.persistent.cache 的软件包
com.trs.infra.persistent.cache

com.trs.infra.persistent.cache 使用的 com.trs.infra.persistent.cache 中的类
CachedObjectConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.cache.CachedObjectConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.cache.CachedObjectConfig
的使用

使用 CachedObjectConfig 的软件包
com.trs.infra.persistent.cache

com.trs.infra.persistent.cache 中 CachedObjectConfig 的使用

返回 CachedObjectConfig 的 com.trs.infra.persistent.cache 中的方法
 CachedObjectConfig[] CachedPOMgr.getConfigs()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.cache.CachedPOMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.cache.CachedPOMgr
的使用

没有 com.trs.infra.persistent.cache.CachedPOMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.persistent.cache.ICachedPOMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.persistent.cache.ICachedPOMgr
的使用

使用 ICachedPOMgr 的软件包
com.trs.infra.persistent.cache

com.trs.infra.persistent.cache 中 ICachedPOMgr 的使用

实现 ICachedPOMgr 的 com.trs.infra.persistent.cache 中的类
 class CachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
被缓冲的持久化对象的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.AbstractXmlToObjConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.AbstractXmlToObjConverter
的使用

使用 AbstractXmlToObjConverter 的软件包
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition.xml
com.trs.components.wcm.content.domain

com.trs.components.metadata.center.xml 中 AbstractXmlToObjConverter 的使用

com.trs.components.metadata.center.xml 中 AbstractXmlToObjConverter 的子类
 class XMLToMetaViewData
Title: TRS 内容协作平台（TRS WCM）
Description:
XML to MetaViewData转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition.xml 中 AbstractXmlToObjConverter 的使用

com.trs.components.metadata.definition.xml 中 AbstractXmlToObjConverter 的子类
 class XMLToMetaDBTablesConvertor

com.trs.components.wcm.content.domain 中 AbstractXmlToObjConverter 的使用

com.trs.components.wcm.content.domain 中 AbstractXmlToObjConverter 的子类
 class XmlToDocumentConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
Xml-->Document(WCM)对象的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.BaseObj 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.BaseObj
的使用

使用 BaseObj 的软件包
com.trs.ajaxservice |
com.trs.cluster |
com.trs.cluster.receiver |
com.trs.cms.auth.domain |
com.trs.cms.auth.logger |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.logger |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.components.ckm |
com.trs.components.comment.persistent |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.domain.distribute |
com.trs.components.common.publish.domain.element |
com.trs.components.common.publish.domain.tagparser |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.govinfo |
com.trs.components.infoview.db |
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.definition |
com.trs.components.metadata.service.portervisitors |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.service.portervisitors |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.logger |
com.trs.components.wcm.process |
com.trs.components.wcm.process.service.flowexporter |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.media |
com.trs.components.web |
com.trs.db.update |
com.trs.infra.persistent |
com.trs.infra.persistent.cache |
com.trs.infra.persistent.listener |
com.trs.infra.persistent.util |
com.trs.infra.support.config |
com.trs.infra.support.file |
com.trs.infra.support.log |
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.infra.util.database |
com.trs.infra.util.job |
com.trs.km.auth |
com.trs.presentation.login |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.config |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.webframework.context |
com.trs.webframework.controler |

com.trs.ajaxservice 中 BaseObj 的使用

com.trs.ajaxservice 中 BaseObj 的子类
 class ContentExtendValue
Title: TRS 内容协作平台（TRS WCM）
Description:
虚对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 BaseObj 的 com.trs.ajaxservice 中的方法
static void | WCMApplyFormProcessServiceHelper.validateWorkFlowRight(User _loginUser, BaseObj _content, int _nFlowDocId, int _nActionIndex, java.lang.String _sOperDesc)
static void | WCMProcessServiceHelper.validateWorkFlowRight(User _loginUser, BaseObj _content, int _nFlowDocId, int _nActionIndex, java.lang.String _sOperDesc)

com.trs.cluster 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.cluster 中的方法
void | IClusterMsgReceiver.receive(BaseObj _oEventObject, int _nEventType) 响应基于持久化对象拟定的消息
void | IClusterMsgCenter.send(BaseObj _obj, int _nEventType)
void | ClusterMsgCenterImpl.send(BaseObj _obj, int _nEventType)

com.trs.cluster.receiver 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.cluster.receiver 中的方法
void | TableInfosMsgReceiver.receive(BaseObj _oEventObject, int _nEventType)
void | RefreshPropertyMsgReceiver.receive(BaseObj _oEventObject, int _nEventType)
void | ObjectLCMsgReceiver.receive(BaseObj _oEventObject, int _nEventType)
void | MetaAppCreateMsgReceiver.receive(BaseObj eventObject, int eventType)
void | FileWithdrawMsgReceiver.receive(BaseObj eventObject, int eventType)
void | DBMsgReceiver.receive(BaseObj _oEventObject, int _nEventType)

com.trs.cms.auth.domain 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.cms.auth.domain 中的方法
void | ObjectMemberMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | RightHostLCListenerForInherit.notifyOnAddObj(BaseObj _oObjAdded)
void | RightCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | ObjectMemberMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | RightCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ObjectMemberMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | RightCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ObjectMemberMgrForCluster.receive(BaseObj _oEventObject, int _nEventType)

com.trs.cms.auth.logger 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.cms.auth.logger 中的方法
LogInfo | RoleUserLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | RoleUserLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | RoleUserLogger.makeLogOnModify(BaseObj objmodified)

com.trs.cms.auth.persistent 中 BaseObj 的使用

com.trs.cms.auth.persistent 中 BaseObj 的子类
class | Group
class | GroupRole
class | GroupUser
class | ObjectMember
class | Right
class | RightDef
class | Role
class | RoleUser Title: TRS 内容协作平台（TRS WCM） Description: 角色/用户关联对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TrusteeInfo
class | User Title: TRS 内容协作平台（TRS WCM） Description: 用户对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 BaseObj 的 com.trs.cms.auth.persistent 中的方法
void | GroupAdminsCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | RoleUserCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | AdministratorCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | UserCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | GroupUserCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | GroupAdminsCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | RoleUserCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | AdministratorCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | UserCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | GroupUserCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | GroupAdminsCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | RoleUserCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | AdministratorCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | UserCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | GroupUserCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.cms.content 中 BaseObj 的使用

com.trs.cms.content 中 BaseObj 的子类
class | CMSObj
class | CMSObjDefaultImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DefaultObj
class | ExtendedField
class | WCMSystemObject Title: TRS 内容协作平台（TRS WCM） Description: 系统级虚对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.logger 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.cms.logger 中的方法
static int | OperTypeHelper.getAddOp(BaseObj object)
static int | OperTypeHelper.getDeleteOp(BaseObj object)
static int | OperTypeHelper.getModifyOp(BaseObj object)
LogInfo | ObjLoggerBase.makeLogOnAdd(BaseObj newobj)
LogInfo | IObjLogger.makeLogOnAdd(BaseObj newobj) 根据指定的对象构造新增日志说明记录
LogInfo | ObjLoggerBase.makeLogOnDel(BaseObj objdeleted)
LogInfo | IObjLogger.makeLogOnDel(BaseObj objdeleted) 根据指定的对象构造删除日志说明记录
LogInfo | ObjLoggerBase.makeLogOnModify(BaseObj objmodified)
LogInfo | IObjLogger.makeLogOnModify(BaseObj objmodified) 根据指定的对象构造修改日志说明记录
int | ObjSysLogger.startLogDeleting(User curruser, BaseObj object) 开始记录一个删除记录的日志
int | ObjSysLogger.startLogInserting(User curruser, BaseObj object) 开始记录一个新增记录的日志
int | ObjSysLogger.startLogModifying(User curruser, BaseObj object) 开始记录一个修改记录的日志

com.trs.cms.process.definition 中 BaseObj 的使用

com.trs.cms.process.definition 中 BaseObj 的子类
class | Flow
class | FlowAction
class | FlowCondition
class | FlowdocLog
class | FlowEmploy
class | FlowNode
class | FlowNodeBranch
class | FlowNodeField
class | FlowRule

返回 BaseObj 的 com.trs.cms.process.definition 中的方法
BaseObj | FlowEmploy.getEmployer() get the employer instance
BaseObj | Flow.getOwner() 获取工作流所属的对象

参数类型为 BaseObj 的 com.trs.cms.process.definition 中的方法
int | FlowEmployMgr.clearEmploysOfEmployer(BaseObj _employer) clear all the employ records of the specified element
Flows | FlowEmployMgr.getEmployedFlows(BaseObj _employer) get the flows collection employed by the publish element.
FlowEmploys | FlowEmployMgr.getEmploysOf(BaseObj _employer) Returns the employ records of the specified employer, which may be a folder or a content.
Flow | FlowEmployMgr.getFlow(BaseObj _employer) get the detail flow of the specified element.
void | FlowCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | FlowEmployCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | FlowEmployerLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | RuleHostLCListnerForCache.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | FlowCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | FlowEmployCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | FlowCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | FlowEmployCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | FlowRuleCacheServerImpl.reloadRuleCache(BaseObj _host)
void | IFlowRuleCacheServer.reloadRuleCache(BaseObj _host) 重新装载指定对象(工作流/节点)的规则缓冲
void | FlowRuleCacheServerImpl.removeRuleCache(BaseObj _host)
void | IFlowRuleCacheServer.removeRuleCache(BaseObj _host) 删除指定对象(工作流/节点)的规则缓冲
boolean | FlowEmploy.setEmployer(BaseObj _employer) set the employer
void | FlowEmployMgr.setFlow(BaseObj _employer, int _nFlowId) set the flow of the specified employer.

com.trs.cms.process.engine 中 BaseObj 的使用

com.trs.cms.process.engine 中 BaseObj 的子类
class | FlowContentConfig
class | FlowDoc
class | FlowDocBak Title: TRS 内容协作平台（TRS WCM） Description: 文档流转对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 BaseObj 的 com.trs.cms.process.engine 中的方法
void | FlowNodeLCListenerForForceEnd.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | FlowContentLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

com.trs.components.ckm 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.ckm 中的方法
void | DocumentLCListenerForSIMSearch.notifyOnAddObj(BaseObj _oObjAdded)
void | DocumentLCListenerForSIMSearch.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | DocumentLCListenerForSIMSearch.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.comment.persistent 中 BaseObj 的使用

com.trs.components.comment.persistent 中 BaseObj 的子类
class | DocumentTopic
class | TopicedDocRelation

com.trs.components.common.address 中 BaseObj 的使用

com.trs.components.common.address 中 BaseObj 的子类
class | Contact Title: TRS 内容协作平台（TRS WCM） Description: 联系人对象的定义及实现,用于通讯录 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContactGrp Title: TRS 内容协作平台（TRS WCM） Description: 联系入组对象的定义及实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.bookmark 中 BaseObj 的使用

com.trs.components.common.bookmark 中 BaseObj 的子类
class | BookMark
class | MarkKind
class | MarkShare

com.trs.components.common.calendar 中 BaseObj 的使用

com.trs.components.common.calendar 中 BaseObj 的子类
class | Event
class | EventShare
class | EventType

参数类型为 BaseObj 的 com.trs.components.common.calendar 中的方法
void | EventLCListenerForRemind.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | EventLCListenerForRemind.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.common.conjection.persistent 中 BaseObj 的使用

com.trs.components.common.conjection.persistent 中 BaseObj 的子类
 class EntryConfig

com.trs.components.common.job 中 BaseObj 的使用

com.trs.components.common.job 中 BaseObj 的子类
class | JobWorkerType Title: TRS 内容协作平台（TRS WCM） Description: 系统Job的定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Schedule

参数类型为 BaseObj 的 com.trs.components.common.job 中的方法
static Schedule | Schedule.findBySender(int _nWorkerId, BaseObj _currSender) 获取在指定对象上定义的指定类型的调度（Schedule）
void | ScheduleLCListenerForServer.notifyOnAddObj(BaseObj _oObjAdded)
void | ScheduleLCListenerForServer.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ScheduleLCListenerForFaieldResult.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | JobWorkerTypeLCListenerForSchedule.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ScheduleLCListenerForServer.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.common.message 中 BaseObj 的使用

com.trs.components.common.message 中 BaseObj 的子类
class | Message
class | MsgQueue
class | MsgReceiver Title: TRS 内容协作平台（TRS WCM） Description: 消息接收者对象,记录消息与消息接收者的联系 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.common.publish.domain.distribute 中的方法
void | PublishDistributionLCListener.notifyOnAddObj(BaseObj objAdded)
void | PublishDistributionCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | FileDistributorFtpCacheMgr.notifyOnAddObj(BaseObj _oObjAdded) 已过时。
void | PublishDistributionCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | FileDistributorFtpCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 已过时。
void | PublishDistributionLCListener.notifyOnModifyObj(BaseObj objModified, int eventType)
void | PublishDistributionCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | FileDistributorFtpCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 已过时。

com.trs.components.common.publish.domain.element 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.common.publish.domain.element 中的方法
void | PublishFolderLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | PublishContentLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

com.trs.components.common.publish.domain.tagparser 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.common.publish.domain.tagparser 中的方法
void | TagBeanLCListener.notifyOnAddObj(BaseObj _oObjAdded)
void | TagBeanLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | TagBeanLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.common.publish.domain.taskdispatch 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
void | PublishTaskDispatcherImpl.notifyOnAddObj(BaseObj objAdded)
void | PublishTaskDispatcherImpl.notifyOnDelObj(BaseObj objDeleted, int eventType)

com.trs.components.common.publish.domain.template 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.common.publish.domain.template 中的方法
void | TemplateEmployCacheMgrImpl.notifyOnAddObj(BaseObj _oObjAdded)
void | TemplateArgumentCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | TemplateParseMgr.notifyOnAddObj(BaseObj objAdded)
void | TemplateCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | TemplateEmployCacheMgrImpl.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | TemplateArgumentCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | TemplateParseMgr.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | TemplateCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | TemplateArgumentLCListenerForEmployChanged.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | TemplateEmployCacheMgrImpl.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | TemplateArgumentCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | TemplateLCListenerForTypeChanged.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | TemplateLCListenerForNestedRename.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | TemplateParseMgr.notifyOnModifyObj(BaseObj objModified, int eventType)
void | TemplateCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | TemplateArgumentLCListenerForEmployChanged.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.common.publish.persistent.distribute 中 BaseObj 的使用

com.trs.components.common.publish.persistent.distribute 中 BaseObj 的子类
 class PublishDistribution

com.trs.components.common.publish.persistent.publisher 中 BaseObj 的使用

com.trs.components.common.publish.persistent.publisher 中 BaseObj 的子类
 class FolderPublishConfig

com.trs.components.common.publish.persistent.taskdispatch 中 BaseObj 的使用

com.trs.components.common.publish.persistent.taskdispatch 中 BaseObj 的子类
class | PublishErrorLog
class | PublishTask

com.trs.components.common.publish.persistent.template 中 BaseObj 的使用

com.trs.components.common.publish.persistent.template 中 BaseObj 的子类
class | TagBean
class | TempApdRel
class | TempAppendix
class | Template Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateArgument 模板中的形式参数的实际值
class | TemplateEmploy
class | TemplateQuote

com.trs.components.common.publish.widget 中 BaseObj 的使用

com.trs.components.common.publish.widget 中 BaseObj 的子类
class | BaseStyle 风格抽象类
class | ContentStyle
class | Layout
class | Master
class | PageStyle
class | ResourceStyle
class | StyleAndResource
class | StyleItem
class | Widget
class | WidgetInstance
class | WidgetInstParameter
class | WidgetParameter

参数类型为 BaseObj 的 com.trs.components.common.publish.widget 中的方法
void | TemplateLCListenerVisualTemplate.notifyOnAddObj(BaseObj objAdded)
void | AdjustJsLCListenerWidget.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | TemplateLCListenerVisualTemplate.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | AdjustJsLCListenerWidget.notifyOnModifyObj(BaseObj objModified, int eventType)
void | TemplateLCListenerVisualTemplate.notifyOnModifyObj(BaseObj objModified, int eventType)

com.trs.components.common.trsad 中 BaseObj 的使用

com.trs.components.common.trsad 中 BaseObj 的子类
class | ADCom
class | ADFile
class | ADFilePos
class | ADPos
class | ADType

com.trs.components.common.trsvote 中 BaseObj 的使用

com.trs.components.common.trsvote 中 BaseObj 的子类
class | Vote
class | VoteData
class | VoteIPLog
class | VoteItem
class | VoteOption

com.trs.components.gkml.sqgk.persistent 中 BaseObj 的使用

com.trs.components.gkml.sqgk.persistent 中 BaseObj 的子类
class | ApplyForm
class | ApplyFormDealLog
class | MailConfig

com.trs.components.govinfo 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.govinfo 中的方法
void | GovInfoLCListenerMetaView.notifyOnAddObj(BaseObj objAdded)
void | GovInfoLCListenerMetaView.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | GovInfoLCListenerMetaView.notifyOnModifyObj(BaseObj objModified, int eventType)

com.trs.components.infoview.db 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.infoview.db 中的方法
void | DocumentLCListenerForInfoViewDB.notifyOnAddObj(BaseObj _oObjAdded)
void | DocumentLCListenerForInfoViewDB.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | DocumentLCListenerForInfoViewDB.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ChnlDocLCListenerForInfoViewDB.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.infoview.helper 中 BaseObj 的使用

com.trs.components.infoview.helper 中 BaseObj 的子类
 class ComplexFieldData

com.trs.components.infoview.persistent 中 BaseObj 的使用

com.trs.components.infoview.persistent 中 BaseObj 的子类
class | InfoView TODO Add javadoc for InfoView
class | InfoViewData
class | InfoViewDocument
class | InfoViewEmploy TODO Add javadoc for InfoViewEmploy
class | InfoViewField
class | InfoViewGroup 描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table
class | InfoViewView 描述自定义表单的一个视图

com.trs.components.metadata.center 中 BaseObj 的使用

com.trs.components.metadata.center 中 BaseObj 的子类
class | ClassInfoView
class | MetaViewData
class | MetaViewEmployer

返回 BaseObj 的 com.trs.components.metadata.center 中的方法
 BaseObj MetaViewData.cloneToNewObj()
由于视图字段的名称和元数据字段的名称可能不统一，在查看（findById)的时候，用 的是视图字段名称，而在保存（save）的时候用的是元数据字段名称，所以在此需要将视图字段的属性转化为元数据字段的属性

参数类型为 BaseObj 的 com.trs.components.metadata.center 中的方法
void | DocumentListenerForMetaViewData.notifyOnAddObj(BaseObj _oObjAdded)
void | DocumentListenerForMetaViewData.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChnlDocLCListenerForSynToMetaData.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | DocumentListenerForMetaViewData.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.metadata.center.xml 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.metadata.center.xml 中的方法
java.lang.String | MetaViewDataToExcel.getElementTag(BaseObj _baseObj)
java.lang.String | MetaViewDataToXML.getElementTag(BaseObj _baseObj)

com.trs.components.metadata.definition 中 BaseObj 的使用

com.trs.components.metadata.definition 中 BaseObj 的子类
class | ClassInfo
class | MetaDBField
class | MetaDBTable
class | MetaView
class | MetaViewField

参数类型为 BaseObj 的 com.trs.components.metadata.definition 中的方法
void | ClassInfoCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | MetaDataDefCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | ClassInfoCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | MetaDataDefCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ClassInfoListenerForViewData.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | ClassInfoCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | MetaDataDefCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | MetaDBFieldListenerForChannelSynRule.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.metadata.service.portervisitors 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.metadata.service.portervisitors 中的方法
void | ChannelPorterVisitorForMetaView.doExport(BaseObj _baseObj, java.lang.Object _extraArgs)
void | ChannelPorterVisitorForMetaView.doImport(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs)

com.trs.components.special 中 BaseObj 的使用

com.trs.components.special 中 BaseObj 的子类
 class Special

com.trs.components.stat 中 BaseObj 的使用

com.trs.components.stat 中 BaseObj 的子类
class | BonusRule
class | ChnlDept
class | DocumentHitsCount
class | HostObjDomain
class | HostObjHitsCount
class | UserLoginInfo

返回 BaseObj 的 com.trs.components.stat 中的方法
BaseObj | IURLParser.parse(java.lang.String sUrl) 根据Url信息，返回该Url对应的BaseObj对象。
BaseObj | URLParser.parse(java.lang.String sUrl)

参数类型为 BaseObj 的 com.trs.components.stat 中的方法
void | IHitsCountHandler.handle(BaseObj obj, java.util.Map properties) 更新指定对象obj的点击量
void | SiteHitsCountHandler.handle(BaseObj obj, java.util.Map properties)
void | DocumentHitsCountHandler.handle(BaseObj obj, java.util.Map properties)
void | ChannelHitsCountHandler.handle(BaseObj obj, java.util.Map properties)
void | ChnlDeptMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | ChnlDeptMgr.notifyOnDelObj(BaseObj _oObjDeleted, int eventType)
void | ChnlDeptMgr.notifyOnModifyObj(BaseObj _oObjModified, int eventType)
void | ChnlDeptMgrForCluster.receive(BaseObj _oEventObject, int _nEventType)

com.trs.components.wcm.content 中 BaseObj 的使用

com.trs.components.wcm.content 中 BaseObj 的子类
 class ViewDocument
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档元素对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.wcm.content.domain 中的方法
java.util.List | RelationMgr.copyRelationListByObj(BaseObj _currObj) 以List方式获得文档所属关联文档集合 在处理文档时是个有用的接口 该接口应该是获得对象的关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用 以后扩展应该也比较方便，增加一个对象类型ID即可
void | InfoViewEmployLCListenerForChannel.notifyOnAddObj(BaseObj _objAdded)
void | ExtendedFieldLCListenerForDocBak.notifyOnAddObj(BaseObj _oObjAdded)
void | ChnlDocLCListenerForRecordNotEntity.notifyOnAddObj(BaseObj _oObjAdded)
void | ChnlDocLCListenerForPri.notifyOnAddObj(BaseObj _oObjAdded)
void | ChnlDocLCListener4ClassInfo.notifyOnAddObj(BaseObj _oObjAdded)
void | RightLCListenerForSynSiteMember.notifyOnAddObj(BaseObj _oObjAdded)
void | DocumentLCListenerForRelDocs.notifyOnAddObj(BaseObj _oObjAdded)
void | DocumentLCListenerForKeyword.notifyOnAddObj(BaseObj _oObjAdded)
void | DocBakLCListenerForApd.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | WebSiteLCListenerForSiteUser.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ApdHostLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ExtendedFieldLCListenerForDocBak.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | BaseChannelLCListener4Region.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | SiteMemberLCListner.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChnlDocLCListenerForRecordNotEntity.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | WebSiteLCListenerForAutoDocBak.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | DocumentLCListenerForExternalFile.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChannelLCListenerForDocument.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChnlDocLCListenerForPri.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | WebSiteLCListenerForContentLink.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | BaseChannelLCListener4ExtField.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChannelLCListenerForSpeical.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | DocumentLCListenerForDocBak.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChnlDocLCListener4ClassInfo.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChannelLCListenerForChannelSyn.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | RightLCListenerForSynSiteMember.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | DocumentLCListenerForRelDocs.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | DocumentLCListenerForKeyword.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChannelLCListenerForExtField.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | DocumentLCListenerForRelation.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | DocumentLCListenerForDocReply.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ContentExtFieldCListenerForDocProps.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ContentExtFieldLCListenerForDocFields.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ApdHostLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ExtendedFieldLCListenerForDocBak.notifyOnModifyObj(BaseObj _oObjEdited, int _nEventType)
void | ChnlDocLCListenerForAutoDocBak.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | DocumentLCListenerForExternalFile.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ChannelLCListenerForDocument.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ChnlDocLCListenerForPri.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | DocumentLCListenerForAutoDocBak.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | RightLCListenerForSynSiteMember.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | DocumentLCListenerForRelDocs.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | DocumentLCListenerForKeyword.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.wcm.content.persistent 中 BaseObj 的使用

com.trs.components.wcm.content.persistent 中 BaseObj 的子类
class | Appendix
class | AutoBakConfig Title: TRS 内容协作平台（TRS WCM） Description: 自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseChannel Title: TRS 内容协作平台（TRS WCM） Description:
class | Channel
class | ChannelContentLink Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ChannelSyn
class | ChnlDoc
class | ContentExtField
class | ContentLink
class | ContentLinkType
class | DocBak
class | DocReply
class | Document
class | DocumentSyn Title: TRS 内容协作平台（TRS WCM） Description: 已经自动转发过的文档的记录 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | HitsCount
class | Relation
class | Replace
class | SiteMember
class | WebSite
class | XDocument

返回 BaseObj 的 com.trs.components.wcm.content.persistent 中的方法
BaseObj | Document.cloneToNewWCMObj()
BaseObj | Appendix.cloneToNewWCMObj() 由对象复制成一个新对象
BaseObj | Documents.getAt(int _index)

参数类型为 BaseObj 的 com.trs.components.wcm.content.persistent 中的方法
static Appendixes | Appendixes.findAppendixesByObj(BaseObj _currObj) 获得文档所属附件集合 该接口应该是获得对象所属附件集合，由于Appendix对象目前只和Document对象耦合，所以先暂时这样使用 以后扩展应该也比较方便，增加一个对象类型ID即可
static Relations | Relations.findRelationsByObj(BaseObj _currObj) 获得文档所属关联文档集合 该接口应该是获得对象所属关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用 以后扩展应该也比较方便，增加一个对象类型ID即可
boolean | ChannelNameMgr.isDoNotify(BaseObj _currObj)
void | ChannelNameMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | ReplaceCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | ChildrenCacheMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | ChannelNameMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ReplaceCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChildrenCacheMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChannelNameMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ReplaceCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ChildrenCacheMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.wcm.content.service.portervisitors 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.wcm.content.service.portervisitors 中的方法
void | IPorterVisitor.doExport(BaseObj _baseObj, java.lang.Object _extraArgs) 在导出_baseObj对象时,根据_baseObj对象做一些额外处理
static void | PorterUtil.doExports(BaseObj _baseObj, java.lang.Object _extraArgs) 根据注册的导入/导出访问器类,在导出_baseObj时,执行所有已注册的访问器的导出定制操作
void | IPorterVisitor.doImport(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs) 在导入_baseObj对象时,根据当前xml串做一些额外处理
static void | PorterUtil.doImports(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs) 根据注册的导入/导出访问器类,在导入_baseObj时,执行所有已注册的访问器的导入定制操作

com.trs.components.wcm.customize 中 BaseObj 的使用

com.trs.components.wcm.customize 中 BaseObj 的子类
 class UserSetting

参数类型为 BaseObj 的 com.trs.components.wcm.customize 中的方法
void | CustomizeMgr.saveSetting(BaseObj _baseObj, int _nOrder, int _nRegionNumber) 保存一个定制
void | CustomizeMgr.saveSetting(BaseObj _baseObj, int _nOrder, int _nRegionNumber, java.lang.String _sValue) 保存一个定制

com.trs.components.wcm.epress 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.wcm.epress 中的方法
void | ChannelLCListener4EPress.notifyOnAddObj(BaseObj objAdded)
void | EPressConf.notifyOnDelObj(BaseObj objDeleted)
void | DocumentLCListener4EPress.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | ChannelLCListener4EPress.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | DocumentLCListener4EPress.notifyOnModifyObj(BaseObj objModified, int eventType)

com.trs.components.wcm.individuation 中 BaseObj 的使用

com.trs.components.wcm.individuation 中 BaseObj 的子类
class | CustomSiteCheckedInfo
class | Individuation

com.trs.components.wcm.logger 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.wcm.logger 中的方法
LogInfo | TemplateEmployLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | RegionCellInfoLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | FlowEmployLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | ConfigLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | ChnlDocLogger.makeLogOnAdd(BaseObj newobj)
LogInfo | TemplateEmployLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | RegionCellInfoLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | FlowEmployLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | ConfigLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | ChnlDocLogger.makeLogOnDel(BaseObj objdeleted)
LogInfo | TemplateEmployLogger.makeLogOnModify(BaseObj objmodified)
LogInfo | RegionCellInfoLogger.makeLogOnModify(BaseObj objmodified)
LogInfo | FlowEmployLogger.makeLogOnModify(BaseObj objmodified)
LogInfo | ConfigLogger.makeLogOnModify(BaseObj objmodified)
LogInfo | ChnlDocLogger.makeLogOnModify(BaseObj objmodified)

com.trs.components.wcm.process 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.wcm.process 中的方法
void | ChnlDocLCListenerForFlow.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ChannelLCListenerForFlow.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | FlowEmployLCListenerForChange.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.wcm.process.service.flowexporter 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.components.wcm.process.service.flowexporter 中的方法
void | SiteExporterForFlow.doExport(BaseObj _baseObj, java.lang.Object _args)
void | SiteExporterForFlow.doImport(BaseObj _baseObj, XmlObject _obj, java.lang.Object args)

com.trs.components.wcm.publish 中 BaseObj 的使用

com.trs.components.wcm.publish 中 BaseObj 的子类
class | WCMFolderPublishConfig
class | WCMPubStatusConfig

参数类型为 BaseObj 的 com.trs.components.wcm.publish 中的方法
void | FolderPubStatusCacheMgrImpl.notifyOnAddObj(BaseObj _oObjAdded)
void | ChnlDocLCListnerForPublish.notifyOnAddObj(BaseObj _oObjAdded)
void | FolderPubStatusCacheMgrImpl.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | WCMFolderLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | ChnlDocLCListnerForPublish.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | WCMFolderPublishConfigLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | FolderPubStatusCacheMgrImpl.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | WCMFolderLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | ChnlDocLCListnerForPublish.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | DocumentLCListenerForPublish.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.components.wcm.publish.logo 中 BaseObj 的使用

com.trs.components.wcm.publish.logo 中 BaseObj 的子类
 class Logo

com.trs.components.wcm.publish.region 中 BaseObj 的使用

com.trs.components.wcm.publish.region 中 BaseObj 的子类
class | CellInfo
class | RegionEmploy
class | RegionInfo

参数类型为 BaseObj 的 com.trs.components.wcm.publish.region 中的方法
void | DocumentListenerForPublish.notifyOnDelObj(BaseObj obj, int eventType)
void | ChannelListenerForPublish.notifyOnDelObj(BaseObj objDeleted, int eventType)
void | DocumentListenerForPublish.notifyOnModifyObj(BaseObj objModified, int eventType)
void | ChannelListenerForPublish.notifyOnModifyObj(BaseObj objModified, int eventType)
void | ChannelDocListenerForPublish.notifyOnModifyObj(BaseObj objModified, int eventType)

com.trs.components.wcm.recent 中 BaseObj 的使用

com.trs.components.wcm.recent 中 BaseObj 的子类
 class Recent

com.trs.components.wcm.resource 中 BaseObj 的使用

com.trs.components.wcm.resource 中 BaseObj 的子类
class | DocKind
class | FileType
class | Keyword
class | Security
class | Source
class | Status

com.trs.components.wcm.stat 中 BaseObj 的使用

com.trs.components.wcm.stat 中 BaseObj 的子类
class | StatFieldMap
class | StatHost
class | StatView
class | StatViewRel

com.trs.components.wcm.wcmx.help 中 BaseObj 的使用

com.trs.components.wcm.wcmx.help 中 BaseObj 的子类
 class WCMHelp

com.trs.components.wcm.wcmx.media 中 BaseObj 的使用

com.trs.components.wcm.wcmx.media 中 BaseObj 的子类
 class MediaRemindedInfo

com.trs.components.web 中 BaseObj 的使用

返回 BaseObj 的 com.trs.components.web 中的方法
 BaseObj BasePropertiesBuilder.getObj()

参数类型为 BaseObj 的 com.trs.components.web 中的构造方法
BasePropertiesBuilder(BaseObj _obj)
DefaultPropertiesBuilder(BaseObj _obj)

com.trs.db.update 中 BaseObj 的使用

com.trs.db.update 中 BaseObj 的子类
 class DBUpdateLog

com.trs.infra.persistent 中 BaseObj 的使用

com.trs.infra.persistent 中 BaseObj 的子类
class | CMyResultSet Title: TRS 内容协作平台（TRS WCM） Description: WCMResultSet Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MyBaseObj Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 BaseObj 的 com.trs.infra.persistent 中的方法
BaseObj | BaseObjs.addNew() 新建一个对象元素
BaseObj | BaseObj.cloneToNewObj() 由对象复制成一个新对象
BaseObj | BaseObj.cloneToNewWCMObj() 已过时。
static BaseObj | BaseObj.createNewInstance(java.lang.Class _classWCMObj) 产生指定的WCM元素对象的实例
static BaseObj | BaseObj.createNewInstance(java.lang.String _sClassName) 产生指定的WCM元素对象的实例
static BaseObj | BaseObj.findById(java.lang.Class _objClass, int _nId)
static BaseObj | BaseObj.findById(int _nObjType, int _nId)
static BaseObj | BaseObj.findByKey(java.lang.Class _objClass, java.lang.Object _oKey)
BaseObj | BaseObjs.getAt(int _index) 通过指定索引获取对象
BaseObj | BaseObjs.getById(int _nId) 通过指定Id获取对象
BaseObj | BaseObjs.getCurrent() 获得当前元素对象
BaseObj | XmlObject.getCurrentObj()
BaseObj | BaseObjHandler.getWCMObj()
static BaseObj | BaseObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, BaseObj _oWCMObj) 解析传入的XML内容，生成传入WCMOBJ对象。
static BaseObj | BaseObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, int _nObjId, java.lang.Class _oWCMObjClass) 解析传入的XML内容，生成传入WCMOBJ对象。

参数类型为 BaseObj 的 com.trs.infra.persistent 中的方法
boolean | BaseObjs.addElement(BaseObj _aObj) 添加一个元素
boolean | BaseObjs.addElement(BaseObj _aObj, int _nIndex)
java.lang.String | BaseObjToXmlConverter.getElementTag(BaseObj _baseObj)
int | BaseObjs.indexOf(BaseObj _aObj) 获取指定对象所在的序号 注意：索引对象并不改变集合的当前指针位置，故需要在检索后恢复旧的指针位置
void | BaseObj.refreshProperty(BaseObj _newObj)
boolean | BaseObjs.remove(BaseObj _aObj)
boolean | BaseObjs.remove(BaseObj _aObj, boolean _bDrop) 从集合中删除指定元素 说明：若指定元素不在集合中，则返回false
void | XmlObject.setCurrentObj(BaseObj _currObj)
static BaseObj | BaseObjHelper.toWCMObj(java.lang.String _sWCMObjXMLContent, BaseObj _oWCMObj) 解析传入的XML内容，生成传入WCMOBJ对象。
static java.util.List | BaseObjHelper.toWCMObjList(java.lang.String _sWCMObjsXMLContent, BaseObj _obj) 解析传入的XML内容，生成包含指定类型WCMObj的List。
org.dom4j.Element | BaseObjToXmlConverter.toXmlElement(BaseObj _baseObj)

参数类型为 BaseObj 的 com.trs.infra.persistent 中的构造方法
BaseObjHandler(BaseObj _obj)
BaseObjsHandler(BaseObj _obj)
BaseObjsHandler(BaseObj _obj, java.lang.String _sTagName)

com.trs.infra.persistent.cache 中 BaseObj 的使用

返回 BaseObj 的 com.trs.infra.persistent.cache 中的方法
BaseObj | ICachedPOMgr.getObjFromBuffer(java.lang.Class _objClass, int _objId)
BaseObj | CachedPOMgr.getObjFromBuffer(java.lang.Class _objClass, int _objId)
BaseObj | ICachedPOMgr.getObjFromBuffer(java.lang.Class _objClass, java.lang.Object _key)
BaseObj | CachedPOMgr.getObjFromBuffer(java.lang.Class _objClass, java.lang.Object _key)
BaseObj | ICachedPOMgr.getObjFromBuffer(java.lang.String _sClassName, int _objId)
BaseObj | CachedPOMgr.getObjFromBuffer(java.lang.String _sClassName, int _objId)

参数类型为 BaseObj 的 com.trs.infra.persistent.cache 中的方法
void | CachedPOMgr.notifyOnAddObj(BaseObj _oObjAdded)
void | CachedPOMgr.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | CachedPOMgr.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.infra.persistent.listener 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.infra.persistent.listener 中的方法
IObjectLCListener[] | ObjectLCMonitorServer.getListeners(int _nEventType, BaseObj _currObj)
boolean | ObjectLCMonitorServer.isDoNotify(int _nEventType, BaseObj _currObj)
void | ObjectLCMonitorServer.notifyOnAddObj(BaseObj _oObjAdded)
void | IObjectLCListenerOnAdd.notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | ObjectLCMonitorServer.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | IObjectLCListenerOnDel.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | ObjectLCMonitorServer.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
void | IObjectLCListenerOnModify.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache

com.trs.infra.persistent.util 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.infra.persistent.util 中的构造方法
SynChildrenExecutorBase(BaseObj _oStartObj)
SynChildrenExecutorBase(BaseObj _oStartObj, boolean _bDoOnStartObj)

com.trs.infra.support.config 中 BaseObj 的使用

com.trs.infra.support.config 中 BaseObj 的子类
 class Config

参数类型为 BaseObj 的 com.trs.infra.support.config 中的方法
void | ConfigServer.notifyOnAddObj(BaseObj _currObj)
void | ConfigServer.notifyOnDelObj(BaseObj _currObj, int _nEventType)
void | ConfigServer.notifyOnModifyObj(BaseObj _currObj, int _nEventType)

com.trs.infra.support.file 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.infra.support.file 中的方法
void | PathConfigLCListener.notifyOnAddObj(BaseObj _oObjAdded)
void | PathConfigLCListener.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | PathConfigLCListener.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.infra.support.log 中 BaseObj 的使用

com.trs.infra.support.log 中 BaseObj 的子类
class | BaseDBLog Title: TRS 内容协作平台（TRS WCM） Description: WCMLog,ILog的一个具体实现.日志对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Log Title: TRS 内容协作平台（TRS WCM） Description: 日志对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | LogBak Title: TRS 内容协作平台（TRS WCM） Description: WCMLog的备份对象定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | OperType Title: TRS 内容协作平台（TRS WCM） Description: 日志记录的操作类型对象定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 BaseObj 的 com.trs.infra.support.log 中的方法
static boolean | LogServer.isRecordNeeded(BaseObj _currObj)
boolean | BaseDBLog.setObj(BaseObj _baseObj)
boolean | ILog.setObj(BaseObj _baseObj)
static long | LogServer.startRecord(java.lang.String _sUserName, java.lang.String _sOperType, java.lang.String _sLogDesc, BaseObj _baseObj)
static long | LogServer.startRecord(java.lang.String _sUserName, java.lang.String _sOperType, java.lang.String _sLogDesc, BaseObj _baseObj, int _nLogType) 开始记录日志

com.trs.infra.support.security 中 BaseObj 的使用

com.trs.infra.support.security 中 BaseObj 的子类
 class SecureKey
TODO Add javadoc for SecureKeys 描述系统中的密钥对象， 属性有：密钥算法、密钥长度、公钥数据、私钥数据等 关于名称：SecureKey，因为“SecretKey”是一个通用名称，在很多系统API中被采用，虽然在不同的包中使用相同的类名是可以的， 但是为了避免不必要的歧义，故意选择了这个错误的类型名称“SecureKey”。

com.trs.infra.util.database 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.infra.util.database 中的方法
 int DBIdManager.getNextId(BaseObj _obj, java.sql.Connection _oConn, boolean _bAddIfNotExist)

com.trs.infra.util.job 中 BaseObj 的使用

com.trs.infra.util.job 中 BaseObj 的子类
 class JobFailedResult
Title: TRS 内容协作平台（TRS WCM）
Description:
计划任务执行失败记录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.km.auth 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.km.auth 中的方法
 void UserListenerForRecordLogin.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.presentation.login 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.presentation.login 中的方法
void | UserLCListenerForLogin.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
void | UserLCListenerForLogin.notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)

com.trs.service 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.service 中的方法
Flow | IWCMProcessService.getFlowOfEmployer(BaseObj _employer)
void | IWCMProcessService.setFlowEmploy(BaseObj _employer, int _nFlowId)

com.trs.service.impl 中 BaseObj 的使用

参数类型为 BaseObj 的 com.trs.service.impl 中的方法
Flow | WCMProcessServiceImpl.getFlowOfEmployer(BaseObj _employer)
void | WCMProcessServiceImpl.setFlowEmploy(BaseObj _employer, int _nFlowId)

com.trs.wcm.config 中 BaseObj 的使用

com.trs.wcm.config 中 BaseObj 的子类
 class PageOperator

com.trs.wcm.old 中 BaseObj 的使用

com.trs.wcm.old 中 BaseObj 的子类
class | WCMExcelData Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
class | WCMFormFields
class | WCMFormInfo

com.trs.wcm.photo 中 BaseObj 的使用

com.trs.wcm.photo 中 BaseObj 的子类
 class Watermark

参数类型为 BaseObj 的 com.trs.wcm.photo 中的方法
 void DocumentLCLisenterForPhoto.notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)

com.trs.webframework.context 中 BaseObj 的使用

返回 BaseObj 的 com.trs.webframework.context 中的方法
 BaseObj MethodContext.getCurrHost()

参数类型为 BaseObj 的 com.trs.webframework.context 中的方法
 void MethodContext.setCurrHost(BaseObj _oCurrHost)
设置当前方法时候关联的主要对象

com.trs.webframework.controler 中 BaseObj 的使用

返回 BaseObj 的 com.trs.webframework.controler 中的方法
 BaseObj JSPRequestProcessor.getCurrHost()

参数类型为 BaseObj 的 com.trs.webframework.controler 中的方法
 void JSPRequestProcessor.setCurrHost(BaseObj _oCurrHost)
设置当前方法时候关联的主要对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.BaseObjHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.BaseObjHandler
的使用

没有 com.trs.infra.persistent.BaseObjHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.BaseObjHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.BaseObjHelper
的使用

没有 com.trs.infra.persistent.BaseObjHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.BaseObjs 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.BaseObjs
的使用

使用 BaseObjs 的软件包
com.trs.ajaxservice |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.components.comment.persistent |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.common.trsad |
com.trs.components.common.trsvote |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.center.xml |
com.trs.components.metadata.definition |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.content |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.customize |
com.trs.components.wcm.individuation |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.wcmx.help |
com.trs.components.wcm.wcmx.media |
com.trs.db.update |
com.trs.infra.persistent |
com.trs.infra.support.config |
com.trs.infra.support.log |
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.infra.util.job |
com.trs.wcm.config |
com.trs.wcm.old |
com.trs.wcm.photo |

com.trs.ajaxservice 中 BaseObjs 的使用

com.trs.ajaxservice 中 BaseObjs 的子类
 class ContentExtendValues
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 BaseObjs 的 com.trs.ajaxservice 中的方法
 BaseObjs ContentExtendValues.newInstance()

参数类型为 BaseObjs 的 com.trs.ajaxservice 中的方法
static WCMFilter DocumentAuthHelper.makeFilterWithRight(User _loginUser, BaseObjs _oSitesOrChannels)
构造当前用户在指定的栏目中带有权限的Filter

com.trs.cms.auth.persistent 中 BaseObjs 的使用

com.trs.cms.auth.persistent 中 BaseObjs 的子类
class | GroupRoles
class | Groups
class | GroupUsers Title: TRS 内容协作平台（TRS WCM） Description: 组织用户关联对象集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectMembers
class | RightDefs
class | Rights
class | Roles
class | RoleUsers Title: TRS 内容协作平台（TRS WCM） Description: 角色/用户关联对象集合的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TrusteeInfos
class | Users

返回 BaseObjs 的 com.trs.cms.auth.persistent 中的方法
BaseObjs | ObjectMembers.newInstance()
BaseObjs | RightDefs.newInstance()
BaseObjs | Users.newInstance() 生成新的集合对象实例
BaseObjs | Rights.newInstance()
BaseObjs | Groups.newInstance() 生成新的集合对象实例
BaseObjs | Roles.newInstance() 生成新的集合对象实例
BaseObjs | GroupUsers.newInstance() 生成新的集合对象实例
BaseObjs | TrusteeInfos.newInstance() 生成新的集合对象实例
BaseObjs | RoleUsers.newInstance() 生成新的集合对象实例
BaseObjs | GroupRoles.newInstance() 生成新的集合对象实例

com.trs.cms.content 中 BaseObjs 的使用

com.trs.cms.content 中 BaseObjs 的子类
class | CMSBaseObjs
class | DefaultObjs
class | ExtendedFields

返回 BaseObjs 的 com.trs.cms.content 中的方法
BaseObjs | DefaultObjs.newInstance()
BaseObjs | ExtendedFields.newInstance() 生成新的集合对象实例

参数类型为 BaseObjs 的 com.trs.cms.content 中的方法
static java.lang.String | WCMObjHelper.concatProperties(BaseObjs _oCurrBaseObjs, java.lang.String _sPropertyName) 将WCMObjects中的指定属性转换为以逗号隔开的字符串序列
static java.lang.String | WCMObjHelper.concatProperties(BaseObjs _oCurrBaseObjs, java.lang.String _sPropertyName, java.lang.String _sDelim) 将WCMObjects中的指定属性转换为以逗号隔开的字符串序列

com.trs.cms.process.definition 中 BaseObjs 的使用

com.trs.cms.process.definition 中 BaseObjs 的子类
class | FlowActions
class | FlowConditions
class | FlowdocLogs
class | FlowEmploys
class | FlowNodeBranchs
class | FlowNodeFields
class | FlowNodes
class | FlowRules
class | Flows

返回 BaseObjs 的 com.trs.cms.process.definition 中的方法
BaseObjs | FlowEmployMgr.getChannelsUseingFlow(Flow _flow, BaseObjs _baseObjects, int _nEmployerType, java.lang.String _sTableName, WCMFilter _extraFilter) 获取使用指定工作的指定类型的对象
BaseObjs | FlowEmploys.newInstance()
BaseObjs | FlowActions.newInstance()
BaseObjs | FlowRules.newInstance()
BaseObjs | Flows.newInstance()
BaseObjs | FlowConditions.newInstance()
BaseObjs | FlowNodes.newInstance()
BaseObjs | FlowNodeFields.newInstance()
BaseObjs | FlowdocLogs.newInstance()
BaseObjs | FlowNodeBranchs.newInstance()

参数类型为 BaseObjs 的 com.trs.cms.process.definition 中的方法
 BaseObjs FlowEmployMgr.getChannelsUseingFlow(Flow _flow, BaseObjs _baseObjects, int _nEmployerType, java.lang.String _sTableName, WCMFilter _extraFilter)
获取使用指定工作的指定类型的对象

com.trs.cms.process.engine 中 BaseObjs 的使用

com.trs.cms.process.engine 中 BaseObjs 的子类
class | FlowContentConfigs
class | FlowDocBaks
class | FlowDocs

返回 BaseObjs 的 com.trs.cms.process.engine 中的方法
BaseObjs | FlowContentConfigs.newInstance()
BaseObjs | FlowDocBaks.newInstance()
BaseObjs | FlowDocs.newInstance()

com.trs.components.comment.persistent 中 BaseObjs 的使用

com.trs.components.comment.persistent 中 BaseObjs 的子类
class | DocumentTopics
class | TopicedDocRelations

返回 BaseObjs 的 com.trs.components.comment.persistent 中的方法
BaseObjs | TopicedDocRelations.newInstance()
BaseObjs | DocumentTopics.newInstance()

com.trs.components.common.address 中 BaseObjs 的使用

com.trs.components.common.address 中 BaseObjs 的子类
class | ContactGrps Title: TRS 内容协作平台（TRS WCM） Description: 联系人组集合对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Contacts Title: TRS 内容协作平台（TRS WCM） Description: 联系人集合对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 BaseObjs 的 com.trs.components.common.address 中的方法
BaseObjs | ContactGrps.newInstance() 生成新的集合对象实例
BaseObjs | Contacts.newInstance() 生成新的集合对象实例

com.trs.components.common.bookmark 中 BaseObjs 的使用

com.trs.components.common.bookmark 中 BaseObjs 的子类
class | BookMarks
class | MarkKinds
class | MarkShares

返回 BaseObjs 的 com.trs.components.common.bookmark 中的方法
BaseObjs | MarkShares.newInstance() 生成新的集合对象实例
BaseObjs | MarkKinds.newInstance() 生成新的集合对象实例
BaseObjs | BookMarks.newInstance()

com.trs.components.common.calendar 中 BaseObjs 的使用

com.trs.components.common.calendar 中 BaseObjs 的子类
class | Events
class | EventShares
class | EventTypes

返回 BaseObjs 的 com.trs.components.common.calendar 中的方法
BaseObjs | Events.newInstance() 生成新的集合对象实例
BaseObjs | EventTypes.newInstance() 生成新的集合对象实例
BaseObjs | EventShares.newInstance() 生成新的集合对象实例

com.trs.components.common.conjection.persistent 中 BaseObjs 的使用

com.trs.components.common.conjection.persistent 中 BaseObjs 的子类
 class EntryConfigs

返回 BaseObjs 的 com.trs.components.common.conjection.persistent 中的方法
 BaseObjs EntryConfigs.newInstance()

com.trs.components.common.job 中 BaseObjs 的使用

com.trs.components.common.job 中 BaseObjs 的子类
class | JobWorkerTypes Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Schedules

返回 BaseObjs 的 com.trs.components.common.job 中的方法
BaseObjs | Schedules.newInstance()
BaseObjs | JobWorkerTypes.newInstance()

com.trs.components.common.message 中 BaseObjs 的使用

com.trs.components.common.message 中 BaseObjs 的子类
class | Messages
class | MsgQueues
class | MsgReceivers Title: TRS 内容协作平台（TRS WCM） Description: 消息接收者集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 BaseObjs 的 com.trs.components.common.message 中的方法
BaseObjs | Messages.newInstance() 生成新的集合对象实例
BaseObjs | MsgQueues.newInstance() 生成新的集合对象实例
BaseObjs | MsgReceivers.newInstance()

com.trs.components.common.publish.persistent.distribute 中 BaseObjs 的使用

com.trs.components.common.publish.persistent.distribute 中 BaseObjs 的子类
 class PublishDistributions

返回 BaseObjs 的 com.trs.components.common.publish.persistent.distribute 中的方法
 BaseObjs PublishDistributions.newInstance()

com.trs.components.common.publish.persistent.publisher 中 BaseObjs 的使用

com.trs.components.common.publish.persistent.publisher 中 BaseObjs 的子类
 class FolderPublishConfigs

返回 BaseObjs 的 com.trs.components.common.publish.persistent.publisher 中的方法
 BaseObjs FolderPublishConfigs.newInstance()

com.trs.components.common.publish.persistent.taskdispatch 中 BaseObjs 的使用

com.trs.components.common.publish.persistent.taskdispatch 中 BaseObjs 的子类
class | PublishErrorLogs
class | PublishTasks

返回 BaseObjs 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
BaseObjs | PublishTasks.newInstance() 生成新的集合对象实例
BaseObjs | PublishErrorLogs.newInstance() 生成新的集合对象实例

com.trs.components.common.publish.persistent.template 中 BaseObjs 的使用

com.trs.components.common.publish.persistent.template 中 BaseObjs 的子类
class | TagBeans
class | TempApdRels
class | TempAppendixes
class | TemplateArguments TemplateArgument对象的集合
class | TemplateEmploys
class | TemplateQuotes
class | Templates

返回 BaseObjs 的 com.trs.components.common.publish.persistent.template 中的方法
BaseObjs | Templates.newInstance()
BaseObjs | TemplateQuotes.newInstance()
BaseObjs | TemplateEmploys.newInstance()
BaseObjs | TemplateArguments.newInstance()
BaseObjs | TempAppendixes.newInstance() 生成新的集合对象实例
BaseObjs | TempApdRels.newInstance() 生成新的集合对象实例
BaseObjs | TagBeans.newInstance() 生成新的集合对象实例

com.trs.components.common.publish.widget 中 BaseObjs 的使用

com.trs.components.common.publish.widget 中 BaseObjs 的子类
class | ContentStyles
class | Layouts
class | Masters
class | PageStyles
class | ResourceStyles
class | StyleAndResources
class | StyleItems
class | WidgetInstances
class | WidgetInstParameters
class | WidgetParameters
class | Widgets

返回 BaseObjs 的 com.trs.components.common.publish.widget 中的方法
BaseObjs | WidgetParameters.newInstance()
BaseObjs | PageStyles.newInstance()
BaseObjs | ContentStyles.newInstance()
BaseObjs | WidgetInstParameters.newInstance()
BaseObjs | ResourceStyles.newInstance()
BaseObjs | Widgets.newInstance()
BaseObjs | Masters.newInstance()
BaseObjs | StyleAndResources.newInstance()
BaseObjs | Layouts.newInstance()
BaseObjs | StyleItems.newInstance()
BaseObjs | WidgetInstances.newInstance()

com.trs.components.common.trsad 中 BaseObjs 的使用

com.trs.components.common.trsad 中 BaseObjs 的子类
class | ADComs
class | ADFilePoss
class | ADFiles
class | ADPoss
class | ADTypes

返回 BaseObjs 的 com.trs.components.common.trsad 中的方法
BaseObjs | ADTypes.newInstance() 生成新的集合对象实例
BaseObjs | ADPoss.newInstance() 生成新的集合对象实例
BaseObjs | ADFiles.newInstance() 生成新的集合对象实例
BaseObjs | ADFilePoss.newInstance() 生成新的集合对象实例
BaseObjs | ADComs.newInstance() 生成新的集合对象实例

com.trs.components.common.trsvote 中 BaseObjs 的使用

com.trs.components.common.trsvote 中 BaseObjs 的子类
class | VoteDatas
class | VoteIPLogs
class | VoteItems
class | VoteOptions
class | Votes

返回 BaseObjs 的 com.trs.components.common.trsvote 中的方法
BaseObjs | Votes.newInstance() 生成新的集合对象实例
BaseObjs | VoteOptions.newInstance() 生成新的集合对象实例
BaseObjs | VoteItems.newInstance() 生成新的集合对象实例
BaseObjs | VoteIPLogs.newInstance() 生成新的集合对象实例
BaseObjs | VoteDatas.newInstance() 生成新的集合对象实例

com.trs.components.gkml.sqgk.persistent 中 BaseObjs 的使用

com.trs.components.gkml.sqgk.persistent 中 BaseObjs 的子类
class | ApplyFormDealLogs
class | ApplyForms
class | MailConfigs

返回 BaseObjs 的 com.trs.components.gkml.sqgk.persistent 中的方法
BaseObjs | MailConfigs.newInstance()
BaseObjs | ApplyForms.newInstance()
BaseObjs | ApplyFormDealLogs.newInstance()

com.trs.components.infoview.helper 中 BaseObjs 的使用

com.trs.components.infoview.helper 中 BaseObjs 的子类
 class ComplexFieldDatas

返回 BaseObjs 的 com.trs.components.infoview.helper 中的方法
 BaseObjs ComplexFieldDatas.newInstance()

com.trs.components.infoview.persistent 中 BaseObjs 的使用

com.trs.components.infoview.persistent 中 BaseObjs 的子类
class | InfoViewDatas Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoViewDocuments
class | InfoViewEmploys TODO Add javadoc for InfoViewEmploys
class | InfoViewFields
class | InfoViewGroups
class | InfoViews TODO Add javadoc for InfoViews
class | InfoViewViews

返回 BaseObjs 的 com.trs.components.infoview.persistent 中的方法
BaseObjs | InfoViewDatas.newInstance()
BaseObjs | InfoViewViews.newInstance()
BaseObjs | InfoViewEmploys.newInstance()
BaseObjs | InfoViewDocuments.newInstance() 生成新的集合对象实例
BaseObjs | InfoViews.newInstance()
BaseObjs | InfoViewFields.newInstance()
BaseObjs | InfoViewGroups.newInstance()

com.trs.components.metadata.center 中 BaseObjs 的使用

com.trs.components.metadata.center 中 BaseObjs 的子类
class | ClassInfoViews
class | MetaViewDatas Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaViewEmployers

返回 BaseObjs 的 com.trs.components.metadata.center 中的方法
BaseObjs | ClassInfoViews.newInstance()
BaseObjs | MetaViewDatas.newInstance()
BaseObjs | MetaViewEmployers.newInstance()

com.trs.components.metadata.center.xml 中 BaseObjs 的使用

参数类型为 BaseObjs 的 com.trs.components.metadata.center.xml 中的方法
java.lang.String | MetaViewDataToExcel.getElementTag(BaseObjs _baseObjs)
java.lang.String | MetaViewDataToXML.getElementTag(BaseObjs _baseObjs)
org.dom4j.Element | MetaViewDataToExcel.toXmlElement(BaseObjs _baseObjs, java.lang.String _sFieldsList) 为什么要重载这个方法？

com.trs.components.metadata.definition 中 BaseObjs 的使用

com.trs.components.metadata.definition 中 BaseObjs 的子类
class | ClassInfos
class | MetaDBFields
class | MetaDBTables
class | MetaViewFields
class | MetaViews

返回 BaseObjs 的 com.trs.components.metadata.definition 中的方法
BaseObjs | ClassInfos.newInstance()
BaseObjs | MetaDBFields.newInstance()
BaseObjs | MetaViews.newInstance()
BaseObjs | MetaDBTables.newInstance()
BaseObjs | MetaViewFields.newInstance()

com.trs.components.special 中 BaseObjs 的使用

com.trs.components.special 中 BaseObjs 的子类
 class Specials

返回 BaseObjs 的 com.trs.components.special 中的方法
 BaseObjs Specials.newInstance()

com.trs.components.stat 中 BaseObjs 的使用

com.trs.components.stat 中 BaseObjs 的子类
class | BonusRules
class | ChnlDepts
class | DocumentHitsCounts
class | HostObjDomains
class | HostObjHitsCounts
class | UserLoginInfos

返回 BaseObjs 的 com.trs.components.stat 中的方法
BaseObjs | DocumentHitsCounts.newInstance()
BaseObjs | HostObjDomains.newInstance()
BaseObjs | ChnlDepts.newInstance()
BaseObjs | HostObjHitsCounts.newInstance()
BaseObjs | UserLoginInfos.newInstance()
BaseObjs | BonusRules.newInstance()

com.trs.components.wcm.content 中 BaseObjs 的使用

com.trs.components.wcm.content 中 BaseObjs 的子类
 class ViewDocuments
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档集合对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 BaseObjs 的 com.trs.components.wcm.content 中的方法
 BaseObjs ViewDocuments.newInstance()

com.trs.components.wcm.content.persistent 中 BaseObjs 的使用

com.trs.components.wcm.content.persistent 中 BaseObjs 的子类
class | Appendixes
class | AutoBakConfigs Title: TRS 内容协作平台（TRS WCM） Description: 版本自动保存配置信息集合对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelContentLinks Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | Channels
class | ChannelSyns
class | ChnlDocs
class | ContentExtFields
class | ContentLinks
class | ContentLinkTypes
class | DocBaks
class | DocReplys
class | Documents
class | DocumentSyns Title: TRS 内容协作平台（TRS WCM） Description: 已经转发过的文档记录集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | HitsCounts
class | Relations
class | Replaces Title: TRS 内容协作平台（TRS WCM） Description: 替换内容对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | SiteMembers
class | WebSites
class | XDocuments

返回 BaseObjs 的 com.trs.components.wcm.content.persistent 中的方法
BaseObjs | DocReplys.newInstance()
BaseObjs | Documents.newInstance()
BaseObjs | ChannelContentLinks.newInstance()
BaseObjs | ChannelSyns.newInstance() 生成新的集合对象实例
BaseObjs | HitsCounts.newInstance() 生成新的集合对象实例
BaseObjs | DocBaks.newInstance()
BaseObjs | Appendixes.newInstance()
BaseObjs | Relations.newInstance()
BaseObjs | XDocuments.newInstance()
BaseObjs | ContentLinks.newInstance()
BaseObjs | DocumentSyns.newInstance()
BaseObjs | Replaces.newInstance()
BaseObjs | SiteMembers.newInstance() 生成新的集合对象实例
BaseObjs | ContentExtFields.newInstance()
BaseObjs | AutoBakConfigs.newInstance()
BaseObjs | WebSites.newInstance()
BaseObjs | ChnlDocs.newInstance() 生成新的集合对象实例
BaseObjs | ContentLinkTypes.newInstance()
BaseObjs | Channels.newInstance()

com.trs.components.wcm.customize 中 BaseObjs 的使用

com.trs.components.wcm.customize 中 BaseObjs 的子类
 class UserSettings

返回 BaseObjs 的 com.trs.components.wcm.customize 中的方法
 BaseObjs UserSettings.newInstance()
生成新的集合对象实例

com.trs.components.wcm.individuation 中 BaseObjs 的使用

com.trs.components.wcm.individuation 中 BaseObjs 的子类
class | CustomSiteCheckedInfos
class | Individuations

返回 BaseObjs 的 com.trs.components.wcm.individuation 中的方法
BaseObjs | Individuations.newInstance()
BaseObjs | CustomSiteCheckedInfos.newInstance()

com.trs.components.wcm.publish 中 BaseObjs 的使用

com.trs.components.wcm.publish 中 BaseObjs 的子类
 class WCMPubStatusConfigs

返回 BaseObjs 的 com.trs.components.wcm.publish 中的方法
 BaseObjs WCMPubStatusConfigs.newInstance()

com.trs.components.wcm.publish.logo 中 BaseObjs 的使用

com.trs.components.wcm.publish.logo 中 BaseObjs 的子类
 class Logos

返回 BaseObjs 的 com.trs.components.wcm.publish.logo 中的方法
 BaseObjs Logos.newInstance()

com.trs.components.wcm.publish.region 中 BaseObjs 的使用

com.trs.components.wcm.publish.region 中 BaseObjs 的子类
class | CellInfos
class | RegionEmploys
class | RegionInfos

返回 BaseObjs 的 com.trs.components.wcm.publish.region 中的方法
BaseObjs | RegionInfos.newInstance()
BaseObjs | RegionEmploys.newInstance()
BaseObjs | CellInfos.newInstance()

com.trs.components.wcm.recent 中 BaseObjs 的使用

com.trs.components.wcm.recent 中 BaseObjs 的子类
 class Recents

返回 BaseObjs 的 com.trs.components.wcm.recent 中的方法
 BaseObjs Recents.newInstance()
生成新的集合对象实例

com.trs.components.wcm.resource 中 BaseObjs 的使用

com.trs.components.wcm.resource 中 BaseObjs 的子类
class | DocKinds
class | FileTypes
class | Keywords
class | Securities
class | Sources
class | Statuses

返回 BaseObjs 的 com.trs.components.wcm.resource 中的方法
BaseObjs | Keywords.newInstance()
BaseObjs | FileTypes.newInstance()
BaseObjs | DocKinds.newInstance()
BaseObjs | Securities.newInstance()
BaseObjs | Sources.newInstance()
BaseObjs | Statuses.newInstance()

com.trs.components.wcm.stat 中 BaseObjs 的使用

com.trs.components.wcm.stat 中 BaseObjs 的子类
class | StatFieldMaps
class | StatHosts
class | StatViewRels
class | StatViews

返回 BaseObjs 的 com.trs.components.wcm.stat 中的方法
BaseObjs | StatViews.newInstance()
BaseObjs | StatViewRels.newInstance()
BaseObjs | StatHosts.newInstance()
BaseObjs | StatFieldMaps.newInstance()

com.trs.components.wcm.wcmx.help 中 BaseObjs 的使用

com.trs.components.wcm.wcmx.help 中 BaseObjs 的子类
 class WCMHelps

返回 BaseObjs 的 com.trs.components.wcm.wcmx.help 中的方法
 BaseObjs WCMHelps.newInstance()

com.trs.components.wcm.wcmx.media 中 BaseObjs 的使用

com.trs.components.wcm.wcmx.media 中 BaseObjs 的子类
 class MediaRemindedInfos

返回 BaseObjs 的 com.trs.components.wcm.wcmx.media 中的方法
 BaseObjs MediaRemindedInfos.newInstance()
生成新的集合对象实例

com.trs.db.update 中 BaseObjs 的使用

com.trs.db.update 中 BaseObjs 的子类
 class DBUpdateLogs

返回 BaseObjs 的 com.trs.db.update 中的方法
 BaseObjs DBUpdateLogs.newInstance()

com.trs.infra.persistent 中 BaseObjs 的使用

com.trs.infra.persistent 中 BaseObjs 的子类
class | CMyResultObjs Title: TRS 内容协作平台（TRS WCM） Description: WCMResult基类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | CMyResultSets Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MyBaseObjs Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 BaseObjs 的 com.trs.infra.persistent 中的方法
static BaseObjs | BaseObjs.createInstance(java.lang.Class _classObjs) 产生指定集合对象的实例
static BaseObjs | BaseObjs.createInstance(java.lang.String _sObjsClassName) 产生指定集合对象的实例
BaseObjs | BaseObjs.filter(WCMFilter _filter) 使用指定的过滤器筛选子集
BaseObjs | BaseObjs.getParent() 获得父集合
abstract BaseObjs | BaseObjs.newInstance() 生成新的集合对象实例
BaseObjs | CMyResultSets.newInstance()
BaseObjs | MyBaseObjs.newInstance()

参数类型为 BaseObjs 的 com.trs.infra.persistent 中的方法
void | BaseObjs.addElements(BaseObjs _objs)
void | BaseObjs.addWith(BaseObjs _anotherObjs) 与指定集合做加法运算
java.lang.String | BaseObjToXmlConverter.getElementTag(BaseObjs _baseObjs)
void | BaseObjs.minusWith(BaseObjs _anotherObjs) 与指定集合做减法运算
org.dom4j.Element | BaseObjToXmlConverter.toXmlElement(BaseObjs _baseObjs, java.lang.String _sFieldsList)

com.trs.infra.support.config 中 BaseObjs 的使用

com.trs.infra.support.config 中 BaseObjs 的子类
 class Configs

返回 BaseObjs 的 com.trs.infra.support.config 中的方法
 BaseObjs Configs.newInstance()
生成新的集合对象实例

com.trs.infra.support.log 中 BaseObjs 的使用

com.trs.infra.support.log 中 BaseObjs 的子类
class | LogBaks Title: TRS 内容协作平台（TRS WCM） Description: 日志备份对象集合的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Logs Title: TRS 内容协作平台（TRS WCM） Description: 日志对象(WCMLog)集合对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | OperTypes Title: TRS 内容协作平台（TRS WCM） Description: 日志记录的操作类型集合对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 BaseObjs 的 com.trs.infra.support.log 中的方法
BaseObjs | LogMgr.find(java.lang.String _sLogIds)
BaseObjs | ILogMgr.find(java.lang.String _sLogIds)
static BaseObjs | LogServer.getLogBaks(int _nLogType, WCMFilter _filter) 获取所有符合条件的归档日志，可直接指定日志类型ID
BaseObjs | LogMgr.getLogBaks(WCMFilter _filter)
static BaseObjs | LogServer.getLogBaks(WCMFilter _currFilter) 获取所有符合条件的归档日志
BaseObjs | ILogMgr.getLogBaks(WCMFilter _filter)
BaseObjs | LogMgr.getLogBaks(WCMFilter _filter, int _nLogType)
BaseObjs | ILogMgr.getLogBaks(WCMFilter _filter, int _nLogType)
static BaseObjs | LogServer.getLogs(int _nLogType, WCMFilter _filter) 获取所有符合条件的日志，可直接指定日志类型ID
BaseObjs | LogMgr.getLogs(WCMFilter _filter)
static BaseObjs | LogServer.getLogs(WCMFilter _filter) 获取所有符合条件的日志
BaseObjs | ILogMgr.getLogs(WCMFilter _filter)
BaseObjs | LogMgr.getLogs(WCMFilter _filter, int _nLogType)
BaseObjs | ILogMgr.getLogs(WCMFilter _filter, int _nLogType)
static BaseObjs | LogServer.getLogsByTopId(int _nLogTopId, WCMFilter _filter) 获取属于一个逻辑操作（TopId）的日志集合 TopId标识日志的起始触发操作，相同TopId的操作都是一个操作触发的。
BaseObjs | LogMgr.getLogsByTopId(WCMFilter _filter, int _nTopId)
BaseObjs | ILogMgr.getLogsByTopId(WCMFilter _filter, int _nTopId)
BaseObjs | OperTypes.newInstance()
BaseObjs | LogBaks.newInstance()
BaseObjs | Logs.newInstance()

参数类型为 BaseObjs 的 com.trs.infra.support.log 中的方法
void | LogMgr.bakupLogs(BaseObjs _logs)
void | ILogMgr.bakupLogs(BaseObjs _logs)
static boolean | LogServer.delete(BaseObjs _currLogs) 删除日志集合
static java.lang.String | LogServer.export(BaseObjs _currLogs) 根据日志对象集合导出日志

com.trs.infra.support.security 中 BaseObjs 的使用

com.trs.infra.support.security 中 BaseObjs 的子类
 class SecureKeys
TODO Add javadoc for SecureKeys 密钥对 SecureKey 象的集合

返回 BaseObjs 的 com.trs.infra.support.security 中的方法
 BaseObjs SecureKeys.newInstance()

com.trs.infra.util.job 中 BaseObjs 的使用

com.trs.infra.util.job 中 BaseObjs 的子类
 class JobFailedResults
Title: TRS 内容协作平台（TRS WCM）
Description:
计划任务执行失败记录集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 BaseObjs 的 com.trs.infra.util.job 中的方法
 BaseObjs JobFailedResults.newInstance()

com.trs.wcm.config 中 BaseObjs 的使用

com.trs.wcm.config 中 BaseObjs 的子类
 class PageOperators

返回 BaseObjs 的 com.trs.wcm.config 中的方法
 BaseObjs PageOperators.newInstance()

com.trs.wcm.old 中 BaseObjs 的使用

com.trs.wcm.old 中 BaseObjs 的子类
class | WCMExcelDatas Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
class | WCMFormFieldses
class | WCMFormInfos

返回 BaseObjs 的 com.trs.wcm.old 中的方法
BaseObjs | WCMFormInfos.newInstance() 生成新的集合对象实例
BaseObjs | WCMFormFieldses.newInstance() 生成新的集合对象实例
BaseObjs | WCMExcelDatas.newInstance()

com.trs.wcm.photo 中 BaseObjs 的使用

com.trs.wcm.photo 中 BaseObjs 的子类
 class Watermarks

返回 BaseObjs 的 com.trs.wcm.photo 中的方法
 BaseObjs Watermarks.newInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.BaseObjsHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.BaseObjsHandler
的使用

没有 com.trs.infra.persistent.BaseObjsHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.BaseObjToXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.BaseObjToXmlConverter
的使用

使用 BaseObjToXmlConverter 的软件包
com.trs.cms.auth.persistent
com.trs.cms.process.xml
com.trs.components.common.publish.persistent.template
com.trs.components.common.publish.widget
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition.xml
com.trs.components.wcm.content.persistent
com.trs.infra.persistent
com.trs.infra.support.log

com.trs.cms.auth.persistent 中 BaseObjToXmlConverter 的使用

com.trs.cms.auth.persistent 中 BaseObjToXmlConverter 的子类
class | GroupXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: 组织对象到XML转换对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: 角色对象转换为XML数据格式对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.xml 中 BaseObjToXmlConverter 的使用

com.trs.cms.process.xml 中 BaseObjToXmlConverter 的子类
class | FlowNodeXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: 工作流节点对象到XML转换的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowRuleXMLConvertor
class | FlowXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: 工作流对象到XML转换对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.template 中 BaseObjToXmlConverter 的使用

com.trs.components.common.publish.persistent.template 中 BaseObjToXmlConverter 的子类
class | TempAppendixXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: 模板附件导出成为WCM的XML格式的转换管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: 将模板导入、导出成为WCM的XML对象 目前模板的导入只支持随着站点的导入一起进行，不支持单独的模板导入 目前提供的独立的模板导入、导出是通过独立的处理逻辑进行的，和XML的导入、导出没有关系 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 BaseObjToXmlConverter 的使用

com.trs.components.common.publish.widget 中 BaseObjToXmlConverter 的子类
class | ContentStyleXmlConverter 内容风格导出xml转换器
class | PageStyleXmlConverter
class | ResourceStyleXmlConverter
class | WidgetXmlConverter

com.trs.components.metadata.center.xml 中 BaseObjToXmlConverter 的使用

com.trs.components.metadata.center.xml 中 BaseObjToXmlConverter 的子类
class | MetaViewDataToExcel
class | MetaViewDataToXML Title: TRS 内容协作平台（TRS WCM） Description: 将元数据转换成XML Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition.xml 中 BaseObjToXmlConverter 的使用

com.trs.components.metadata.definition.xml 中 BaseObjToXmlConverter 的子类
class | ClassInfoXMLConvertor
class | MetaDBFieldXMLConvertor
class | MetaTableXMLConvertor
class | MetaViewFieldXMLConvertor
class | MetaViewXMLConvertor

com.trs.components.wcm.content.persistent 中 BaseObjToXmlConverter 的使用

com.trs.components.wcm.content.persistent 中 BaseObjToXmlConverter 的子类
class | ChannelXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: 站点/频道到XML转换的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContentExtFieldXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: 负责和Document以XML方式导入、导出的方法 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent 中 BaseObjToXmlConverter 的使用

com.trs.infra.persistent 中 BaseObjToXmlConverter 的子类
class | BaseObjToXmlConverterForSpecialProperty
class | ObjToXmlConverter Title: TRS 内容协作平台（TRS WCM） Description: BaseObj数据转换为XML格式的转换者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjToXmlConverterByDOM4j Title: TRS 内容协作平台（TRS WCM） Description: BaseObj数据转换为XML格式的转换者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.log 中 BaseObjToXmlConverter 的使用

com.trs.infra.support.log 中 BaseObjToXmlConverter 的子类
 class LogXmlConverter
Title: TRS 内容协作平台（TRS WCM）
Description:
Log --> XML 转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty
的使用

使用 BaseObjToXmlConverterForSpecialProperty 的软件包
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition.xml

com.trs.components.metadata.center.xml 中 BaseObjToXmlConverterForSpecialProperty 的使用

com.trs.components.metadata.center.xml 中 BaseObjToXmlConverterForSpecialProperty 的子类
class | MetaViewDataToExcel
class | MetaViewDataToXML Title: TRS 内容协作平台（TRS WCM） Description: 将元数据转换成XML Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition.xml 中 BaseObjToXmlConverterForSpecialProperty 的使用

com.trs.components.metadata.definition.xml 中 BaseObjToXmlConverterForSpecialProperty 的子类
class | MetaDBFieldXMLConvertor
class | MetaViewFieldXMLConvertor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.CMyParameter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.CMyParameter
的使用

没有 com.trs.infra.persistent.CMyParameter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.CMyResultObjs 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.CMyResultObjs
的使用

使用 CMyResultObjs 的软件包
com.trs.components.wcm.content.persistent
com.trs.infra.persistent

com.trs.components.wcm.content.persistent 中 CMyResultObjs 的使用

com.trs.components.wcm.content.persistent 中 CMyResultObjs 的子类
 class XDocuments

com.trs.infra.persistent 中 CMyResultObjs 的使用

com.trs.infra.persistent 中 CMyResultObjs 的子类
 class CMyResultSets
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.CMyResultSet 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.CMyResultSet
的使用

没有 com.trs.infra.persistent.CMyResultSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.CMyResultSets 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.CMyResultSets
的使用

使用 CMyResultSets 的软件包
com.trs.components.wcm.stat
com.trs.components.wcm.stat.chart
com.trs.service
com.trs.service.impl

com.trs.components.wcm.stat 中 CMyResultSets 的使用

返回 CMyResultSets 的 com.trs.components.wcm.stat 中的方法
CMyResultSets | StatMgr.getCurrentStatResult(int _nStatViewId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 做一个即时统计.模板统计视图不允许.
CMyResultSets | StatMgr.getStatResult(int _nStatViewId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy) 统计在一个时间段内，符合特定条件的某个统计的结果 从临时统计表中查询，所以时间条件都是以DEF_STATTIME为准 Id需要从表中构造 Notes: The view shoulb be a Template View.
CMyResultSets | StatMgr.getStatResult(java.lang.String _sqlStat, java.lang.String _sId) 进行用户定制的统计并返回统计结果

参数类型为 CMyResultSets 的 com.trs.components.wcm.stat 中的方法
 void StatResultHolder.cacheResults(int _nViewId, CMyResultSets _results)

com.trs.components.wcm.stat.chart 中 CMyResultSets 的使用

返回 CMyResultSets 的 com.trs.components.wcm.stat.chart 中的方法
CMyResultSets | PieChartProducer.getStatResults()
CMyResultSets | BarChartProducer.getStatResults()

参数类型为 CMyResultSets 的 com.trs.components.wcm.stat.chart 中的方法
void | PieChartProducer.setStatResults(CMyResultSets results)
void | BarChartProducer.setStatResults(CMyResultSets results)

com.trs.service 中 CMyResultSets 的使用

返回 CMyResultSets 的 com.trs.service 中的方法
CMyResultSets | IStatService.getCurrentStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 统计在一个时间段内，符合特定条件的某个统计的结果 对数据库进行实时统计，而不是从统计临时表中取
CMyResultSets | IStatService.getStatResult(int _nStatTempId) 获得一个统计模板对应的所有结果
CMyResultSets | IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate) 统计在一个时间段内，某个统计的结果
CMyResultSets | IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 统计在一个时间段内，符合特定条件的某个统计的结果
CMyResultSets | IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)
CMyResultSets | IStatService.getStatResult(java.lang.String _sqlStat, java.lang.String _sId) 进行用户定制的统计并返回统计结果

com.trs.service.impl 中 CMyResultSets 的使用

返回 CMyResultSets 的 com.trs.service.impl 中的方法
CMyResultSets | StatService.getCurrentStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)
CMyResultSets | StatService.getStatResult(int _nStatTempId)
CMyResultSets | StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate)
CMyResultSets | StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)
CMyResultSets | StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)
CMyResultSets | StatService.getStatResult(java.lang.String _sqlStat, java.lang.String _sId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.persistent.IObjTypeLookup 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.persistent.IObjTypeLookup
的使用

使用 IObjTypeLookup 的软件包
com.trs.infra.persistent

com.trs.infra.persistent 中 IObjTypeLookup 的使用

实现 IObjTypeLookup 的 com.trs.infra.persistent 中的类
 class ObjTypeLookupImpl

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.MyBaseObj 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.MyBaseObj
的使用

没有 com.trs.infra.persistent.MyBaseObj 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.MyBaseObjs 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.MyBaseObjs
的使用

没有 com.trs.infra.persistent.MyBaseObjs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.NullValue 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.NullValue
的使用

没有 com.trs.infra.persistent.NullValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.ObjectTypeConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.ObjectTypeConfig
的使用

没有 com.trs.infra.persistent.ObjectTypeConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.ObjectTypesFinder 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.ObjectTypesFinder
的使用

没有 com.trs.infra.persistent.ObjectTypesFinder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.ObjToXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.ObjToXmlConverter
的使用

没有 com.trs.infra.persistent.ObjToXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.ObjToXmlConverterByDOM4j 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.ObjToXmlConverterByDOM4j
的使用

没有 com.trs.infra.persistent.ObjToXmlConverterByDOM4j 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.ObjTypeLookupHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.ObjTypeLookupHelper
的使用

没有 com.trs.infra.persistent.ObjTypeLookupHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.ObjTypeLookupImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.ObjTypeLookupImpl
的使用

没有 com.trs.infra.persistent.ObjTypeLookupImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.WCMFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.WCMFilter
的使用

使用 WCMFilter 的软件包
com.trs.ajaxservice |
com.trs.cms.auth.domain |
com.trs.cms.auth.persistent |
com.trs.cms.content |
com.trs.cms.process |
com.trs.cms.process.definition |
com.trs.cms.process.engine |
com.trs.components.comment.persistent |
com.trs.components.comment.service |
com.trs.components.common.address |
com.trs.components.common.bookmark |
com.trs.components.common.calendar |
com.trs.components.common.conjection.persistent |
com.trs.components.common.job |
com.trs.components.common.message |
com.trs.components.common.publish.domain |
com.trs.components.common.publish.domain.distribute |
com.trs.components.common.publish.domain.taskdispatch |
com.trs.components.common.publish.domain.template |
com.trs.components.common.publish.persistent.distribute |
com.trs.components.common.publish.persistent.element |
com.trs.components.common.publish.persistent.publisher |
com.trs.components.common.publish.persistent.taskdispatch |
com.trs.components.common.publish.persistent.template |
com.trs.components.common.publish.widget |
com.trs.components.filter |
com.trs.components.gkml.sqgk.persistent |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.infoview.helper |
com.trs.components.infoview.persistent | 结合 MS InfoPath 实现的自定义表单的持久化。
com.trs.components.metadata.center |
com.trs.components.metadata.definition |
com.trs.components.metadata.publish |
com.trs.components.metadata.service |
com.trs.components.special |
com.trs.components.stat |
com.trs.components.wcm.content |
com.trs.components.wcm.content.domain |
com.trs.components.wcm.content.persistent |
com.trs.components.wcm.content.trsserver |
com.trs.components.wcm.customize |
com.trs.components.wcm.epress |
com.trs.components.wcm.individuation |
com.trs.components.wcm.publish |
com.trs.components.wcm.publish.element |
com.trs.components.wcm.publish.logo |
com.trs.components.wcm.publish.region |
com.trs.components.wcm.publish.tagparser |
com.trs.components.wcm.recent |
com.trs.components.wcm.resource |
com.trs.components.wcm.stat |
com.trs.components.wcm.stat.domain |
com.trs.components.wcm.wcmx.help |
com.trs.db.update |
com.trs.infra.persistent |
com.trs.infra.persistent.db |
com.trs.infra.support.config |
com.trs.infra.support.log |
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.infra.util.job |
com.trs.presentation.util |
com.trs.service |
com.trs.service.impl |
com.trs.wcm.config |
com.trs.wcm.customize |
com.trs.wcm.old |
com.trs.wcm.photo |
com.trs.wcm.photo.impl |
com.trs.webframework.context |

com.trs.ajaxservice 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.ajaxservice 中的方法
static WCMFilter DocumentAuthHelper.makeFilterWithRight(User _loginUser, BaseObjs _oSitesOrChannels)
构造当前用户在指定的栏目中带有权限的Filter

参数类型为 WCMFilter 的 com.trs.ajaxservice 中的方法
static Channels | ChannelHelper.getChildren(User _loginUser, BaseChannel _parent, WCMFilter _extraFilter)
java.lang.String | ContentLinkServiceProvider.getParentChannelWhere(int _nChannelId, WCMFilter filter)
static WebSites | WebSiteHelper.getWebSitesByRightIndex(User _loginUser, int _nRightIndex, WCMFilter extraFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual) 获取某个用户能操作的站点集合
static WebSites | WebSiteHelper.getWebSitesByType(User _loginUser, int _nSiteType, WCMFilter queryFilter)
static WebSites | WebSiteHelper.getWebSitesByTypeWithIndividual(User _loginUser, int _nSiteType, WCMFilter queryFilter, java.util.Hashtable customSiteIdHt, boolean _bForIndividual)

com.trs.cms.auth.domain 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.cms.auth.domain 中的方法
Groups | GroupMgr.getChildren(Group _parentGroup, WCMFilter _filter) 获取子组织
Groups | GroupRoleMgr.getGroups(Role _dstRole, WCMFilter _filter) 获取指定角色的关联的组织
Groups | GroupMgr.getGroups(User _user, WCMFilter _filter) 根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织
GroupUsers | GroupMgr.getGroupUsers(Group _theGroup, WCMFilter _filter) 获取指定组织所有的用户(用户组织关联对象)
Groups | GroupMgr.getOffspringGroups(Group _theGroup, boolean _bContainSelf, WCMFilter _filter) 返回所有的子孙组,确定是否包含自身
Groups | GroupMgr.getOffspringGroups(User _user, WCMFilter _filter) 根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织,同时包含子孙组织
Roles | GroupRoleMgr.getRoles(Group _dstGroup, WCMFilter _filter) 获取指定组织的所有角色
Roles | RoleMgr.getRolesForUser(User _user, WCMFilter _filter) 获取指定用户可见的角色
RoleUsers | RoleMgr.getRoleUsers(Role _theRole, WCMFilter _filter) 获取指定角色下的角色用户信息
RoleUsers | RoleMgr.getRoleUsers(User _theUser, WCMFilter _filter) 获取指定用户下的角色用户信息
Roles | RoleMgr.getSpecialRolesOfUser(User _user, WCMFilter _filter) 获取指定用户上设置的特定角色
Roles | RoleMgr.getSystemRolesOfUser(User _user, int nSiteId, WCMFilter _filter) 获取指定用户在指定站点上设置的角色信息
Users | GroupMgr.getUsers(Group _theGroup, WCMFilter _filter) 获取属于某组织的所有用户集合
Users | GroupMgr.getUsers(Group _theGroup, WCMFilter _filter, boolean _bContainsChildGrp) 获取指定组织所有的用户(用户组织关联对象),包含所有的子组织的用户
Users | RoleMgr.getUsers(Role _dstRole, int _nSiteId, WCMFilter _filter) 获取某角色在某站点下的所有用户集合
Users | RoleMgr.getUsers(Role _dstRole, WCMFilter _filter) 获取担任某角色的所有用户集合
Users | RoleMgr.getUsersBySpecailForUser(Role _dstRole, WCMFilter _filter) 获取当前登录用户可以查看的某特定角色的所有用户集合
Users | RoleMgr.getUsersBySystemRoleForUser(Role _dstRole, int _nSiteId, WCMFilter _filter) 获取当前登录用户可以查看的某系统级角色的所有用户集合

com.trs.cms.auth.persistent 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.cms.auth.persistent 中的方法
static ObjectMembers | ObjectMembers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ObjectMembers]
static RightDefs | RightDefs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RightDefs]
static Users | Users.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Users]
static Rights | Rights.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Rights]
static Groups | Groups.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Groups]
static Roles | Roles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Roles]
static GroupUsers | GroupUsers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[GroupUsers]
static RoleUsers | RoleUsers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RoleUsers]
static GroupRoles | GroupRoles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RoleUsers]

com.trs.cms.content 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.cms.content 中的方法
static CMSBaseObjs | CMSBaseObjs.openWCMObjs(User _currUser, java.lang.Class _objsClass, WCMFilter _filter) 根据指定的Filter打开指定的集合
static CMSBaseObjs | CMSBaseObjs.openWCMObjs(User _currUser, java.lang.String _sObjsClassName, WCMFilter _filter) 根据指定的Filter打开指定的集合
static ExtendedFields | ExtendedFields.openWCMObjs(User _currUser, WCMFilter _filter)
static DefaultObjs | DefaultObjs.openWCMObjs(User _currUser, WCMFilter _filter, java.lang.String _sDbTableName, java.lang.String _sIdFieldName) 通过指定一个Filter获取当前集合[DefaultObjs]

com.trs.cms.process 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.cms.process 中的方法
FlowDocs | FlowServerImpl.getFlowDocs(IFlowContent _content, WCMFilter _extrFilter)
FlowDocs | IFlowServer.getFlowDocs(IFlowContent _content, WCMFilter _extrFilter) 获取指定内容的流转轨迹
FlowDocs | FlowServer.getFlowDocs(User _operator, int _nFlag, WCMFilter _filter)
FlowDocs | FlowServer.getSubmitFlowDocs(User _operator, WCMFilter _filter)

com.trs.cms.process.definition 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.cms.process.definition 中的方法
BaseObjs | FlowEmployMgr.getChannelsUseingFlow(Flow _flow, BaseObjs _baseObjects, int _nEmployerType, java.lang.String _sTableName, WCMFilter _extraFilter) 获取使用指定工作的指定类型的对象
FlowEmploys | FlowEmployMgr.getEmployers(Flow _flow, WCMFilter _filter) get the employers who use the specified flow.
FlowNodes | FlowNode.getNextNodes(User _currUser, WCMFilter _filter)
static FlowEmploys | FlowEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowEmploys]
static FlowActions | FlowActions.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowActions]
static FlowRules | FlowRules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowRules]
static Flows | Flows.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Flows]
static FlowConditions | FlowConditions.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowConditions]
static FlowNodes | FlowNodes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodes]
static FlowNodeFields | FlowNodeFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodeFields]
static FlowdocLogs | FlowdocLogs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowdocLogs]
static FlowNodeBranchs | FlowNodeBranchs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowNodeBranchs]

com.trs.cms.process.engine 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.cms.process.engine 中的方法
static FlowDocs | FlowDocs.findOfContent(User _currUser, int _nContentType, int _nContentId, WCMFilter _extraFilter) 获取与指定内容相关的轨迹
FlowDocs | FlowDoc.getChildren(User _currUser, WCMFilter _filter) 获取当前轨迹的子轨迹列表
static FlowContentConfigs | FlowContentConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowContentConfigs]
static FlowDocs | FlowDocs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[FlowDocs]

com.trs.components.comment.persistent 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.comment.persistent 中的方法
static TopicedDocRelations | TopicedDocRelations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TopicedDocRelations]
static DocumentTopics | DocumentTopics.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocumentTopics]

com.trs.components.comment.service 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.comment.service 中的方法
Documents | ICommentService.getRelatedDocs(int _nTopicId, WCMFilter _oFilter)
Documents | CommentService.getRelatedDocs(int _nTopicId, WCMFilter _oFilter)

com.trs.components.common.address 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.address 中的方法
ContactGrps | ContactMgr.getContactGroups(WCMFilter _filter) 获取当前用户的所有联系人分组
Contacts | ContactMgr.getContacts(WCMFilter _filter) 获取当前登录用户所有的联系人
Contacts | ContactMgr.getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人
static ContactGrps | ContactGrps.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContactGrps]
static Contacts | Contacts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Contacts]

com.trs.components.common.bookmark 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.bookmark 中的方法
BookMarks | BookMarkMgr.getBookMarks(int _nMarkKindId, WCMFilter _filter) 获取当前登录用户的书签
BookMarks | BookMarkMgr.getBookMarks(MarkKind _markKind, WCMFilter _filter)
BookMarks | BookMarkMgr.getBookMarks(WCMFilter _filter)
MarkKinds | BookMarkMgr.getChildren(MarkKind _parentMarkKind, WCMFilter _filter) 获取当前书签分类的子分类
MarkKinds | BookMarkMgr.getMarkKinds(WCMFilter _filter) 获取当前登录用户的顶级书签分类
BookMarks | BookMarkMgr.getSharedBookMarks(User _aUser, WCMFilter _filter) 获取共享给当前登录用户的书签
MarkKinds | BookMarkMgr.getSharedMarkKinds(User _aUser, WCMFilter _filter) 获取共享给当前登录用户的书签分类
MarkShares | BookMarkMgr.getShareMarks(WCMFilter _filter) 获取当前登录用户可访问的共享书签
static MarkShares | MarkShares.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MarkShares]
static MarkKinds | MarkKinds.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MarkKinds]
static BookMarks | BookMarks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[BookMarks]

com.trs.components.common.calendar 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.calendar 中的方法
Events | EventMgr.getDailyEvents(CMyDateTime _date, WCMFilter _filter) 获取当前用户在指定日期的日程安排
Events | EventMgr.getEvents(User _currUser, CMyDateTime _date, boolean _bIncludingShared, WCMFilter _filter)
Events | EventMgr.getEvents(WCMFilter _filter) 获取系统中的日程安排
static Events | Events.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Events]
static EventShares | EventShares.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[EventShares]

com.trs.components.common.conjection.persistent 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.conjection.persistent 中的方法
static EntryConfigs EntryConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[EntryConfigs]

com.trs.components.common.job 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.job 中的方法
static Schedules | Schedules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Schedules]
static JobWorkerTypes | JobWorkerTypes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[JobWorkers]

com.trs.components.common.message 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.message 中的方法
static Messages | MessageServer.getMessages(int _nReadFlag, User _loginUser, WCMFilter _aFilter) 根据指定的类型(未读/已收/已发)获取消息集合
Messages | IMessageService.getMessages(int _nMessageType, WCMFilter _aFilter) 获取WCM中特定的类型的消息，如已读消息、已发消息
static Messages | MessageServer.getReceivedMsgs(User _currUser, WCMFilter _currFiilter) 获得某用户的所有接收到的消息 接收的判断是所有用户为接收者的消息
static Messages | MessageServer.getSentMsgs(User _currUser, WCMFilter _currFiilter) 获得某用户的所有已发消息 已发的判断是从Message表中查询得到
static Messages | MessageServer.getUnreadMessages(User _currUser, WCMFilter _filter) 获得用户所有未读的消息 未读的定义即_currMsgUser为接收者，且消息的已读属性为false
static Messages | Messages.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Messages]
static MsgQueues | MsgQueues.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MsgQueues]
static MsgReceivers | MsgReceivers.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[MsgReceivers]

com.trs.components.common.publish.domain 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.domain 中的方法
PublishTasks | PublishServer.getAllTasks(WCMFilter _filter) get all the publish tasks in the system
PublishTasks | PublishServer.getMyTasks(WCMFilter _filter) get the publish tasks of the specified user

com.trs.components.common.publish.domain.distribute 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.domain.distribute 中的方法
 PublishDistributions PublishDistributionMgr.getDistributionsOf(IPublishFolder _folder, boolean _bExcludingDisabled, WCMFilter _filter)
get the publish distributions of the specified folder.

com.trs.components.common.publish.domain.taskdispatch 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.domain.taskdispatch 中的方法
PublishTasks | IPublishTaskMgr.getMyTasks(WCMFilter _filter) get the publish tasks created by the specified user
PublishTasks | PublishTaskMgrImpl.getMyTasks(WCMFilter _filter)
PublishTasks | IPublishTaskMgr.getTasks(WCMFilter _filter) get the tasks collection with the specified filter
PublishTasks | PublishTaskMgrImpl.getTasks(WCMFilter _filter)

com.trs.components.common.publish.domain.template 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.domain.template 中的方法
java.util.List | TemplateEmployMgr.getEmployers(Template _template, WCMFilter _filter) get the employers who use the specified template.
Templates | TemplateMgr.getManagedTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) get the managed tempaltes in the specified folder
Templates | TemplateMgr.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent) get the managed tempaltes in the specified folder
TempAppendixes | TemplateMgr.getTempAppendixesInRoot(int _nRootType, int _nRootId, WCMFilter _filter) get the template appendixes in the specified root
TemplateEmploys | TemplateEmployMgr.getTemplateEmployers(Template _template, WCMFilter _filter)

com.trs.components.common.publish.persistent.distribute 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.persistent.distribute 中的方法
static PublishDistributions PublishDistributions.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[PublishDistributions]

com.trs.components.common.publish.persistent.element 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.persistent.element 中的方法
IPublishElements | IPublishFolder.getAllContents(WCMFilter _filter) Returns all the contents to publish
IPublishElements | PublishFolderWrapper.getAllContents(WCMFilter _filter)
IPublishElementsIterator | IPublishFolder.getAllContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderWrapper.getAllContentsIterator(WCMFilter _filter)
IPublishElements | IPublishFolder.getIncreasedContents(WCMFilter _filter) Returns the increased contents to publish
IPublishElements | PublishFolderWrapper.getIncreasedContents(WCMFilter _filter)
IPublishElementsIterator | IPublishFolder.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderWrapper.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElements | IPublishFolder.getPublishedContents(WCMFilter _filter) Returns the contents which have been published.
IPublishElements | PublishFolderWrapper.getPublishedContents(WCMFilter _filter)

com.trs.components.common.publish.persistent.publisher 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.persistent.publisher 中的方法
static FolderPublishConfigs FolderPublishConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[FolderPublishConfigs]

com.trs.components.common.publish.persistent.taskdispatch 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
 PublishErrorLogs PublishTask.getErrorLogs(User _currUser, WCMFilter _filter)
get the error logs of this task

com.trs.components.common.publish.persistent.template 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.persistent.template 中的方法
TempApdRels | Template.getApdRels(WCMFilter _filter) get the template appendix relations
static Templates | Templates.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Templates]
static TemplateQuotes | TemplateQuotes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateQuotes]
static TemplateEmploys | TemplateEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateEmploys]
static TemplateArguments | TemplateArguments.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TemplateEmploys]
static TempAppendixes | TempAppendixes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TempAppendixes]
static TempApdRels | TempApdRels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TempApdRels]

com.trs.components.common.publish.widget 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.common.publish.widget 中的方法
StyleAndResources | StyleAndResourceMgr.getContentStyleAndResource(Widget _systemResource, WCMFilter _filter) 获取内容风格和资源的关系
java.util.HashMap | StyleAndResourceMgr.getContentStyleAndResourceMap(Widget _systemResource, WCMFilter _filter) 获取内容风格和资源的关系
java.util.HashMap | IStyleAndResourceMgr.getContentStyleAndResourceMap(Widget systemResource, WCMFilter _filter)
ContentStyles | StyleAndResourceMgr.getContentStyles(Widget _resource, WCMFilter _filter)
ContentStyles | IStyleAndResourceMgr.getContentStyles(Widget _systemResource, WCMFilter _filter) 获取资源对应的内容可用风格
WidgetInstParameters | IWidgetInstParameterMgr.getWidgetInstParameters(WidgetInstance oWidgetInstance, WCMFilter oFilter) 获取资源块实例关联的资源块实例变量对象集合
WidgetInstParameters | WidgetInstParameterMgr.getWidgetInstParameters(WidgetInstance widgetInstance, WCMFilter filter)
static WidgetParameters | WidgetParameters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetParameters]
static PageStyles | PageStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PageStyles]
static ContentStyles | ContentStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentStyles]
static WidgetInstParameters | WidgetInstParameters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetInstParameters]
static ResourceStyles | ResourceStyles.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ResourceStyles]
static Widgets | Widgets.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Widgets]
static Masters | Masters.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Masters]
static StyleAndResources | StyleAndResources.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StyleAndResources]
static Layouts | Layouts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Layouts]
static StyleItems | StyleItems.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StyleItems]
static WidgetInstances | WidgetInstances.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WidgetInstances]
ContentStyles | IContentStyleMgr.query(PageStyle _currPageStyle, WCMFilter _filter) 在指定PageStyle下获取ContentStyle集合
ContentStyles | ContentStyleMgr.query(PageStyle pageStyle, WCMFilter _filter)
ResourceStyles | IResourceStyleMgr.query(PageStyle _currPageStyle, WCMFilter _filter) 获取指定页面风格下的ResourceStyle集合
ResourceStyles | ResourceStyleMgr.query(PageStyle pageStyle, WCMFilter _filter)
Widgets | IWidgetMgr.query(User _oCurrUser, WCMFilter _oFilter) 获取资源
WidgetParameters | IWidgetParameterMgr.query(User _oCurrUser, WCMFilter _oFilter) 获取某资源所具有的资源变量
Widgets | WidgetMgr.query(User _oCurrUser, WCMFilter _oFilter)
Masters | MasterMgr.query(User _oCurrUser, WCMFilter _oFilter) 查询系统指定的母板
Layouts | ILayoutMgr.query(User _currUser, WCMFilter _currFilter) 查询布局
WidgetParameters | WidgetParameterMgr.query(User _oCurrUser, WCMFilter _oFilter)
Layouts | LayoutMgr.query(User _currUser, WCMFilter _filter) 通过条件查询布局
Masters | IMasterMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询系统指定母版
PageStyles | IPageStyleMgr.query(WCMFilter _filter) 获取页面风格集合
PageStyles | PageStyleMgr.query(WCMFilter _filter) 获取PageStyle集合
StyleItems | StyleItemMgr.query(WCMFilter _filter) 获取风格元素集合
java.util.HashMap | IStyleItemMgr.queryPageOtherStyleItemMap(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
java.util.HashMap | StyleItemMgr.queryPageOtherStyleItemMap(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
StyleItems | IStyleItemMgr.queryPageOtherStyleItems(PageStyle pageStyle, WCMFilter _filter) 获取页面其他风格样式项
StyleItems | StyleItemMgr.queryPageOtherStyleItems(PageStyle _pageStyle, WCMFilter _filter) 获取页面其他风格样式项
java.util.HashMap | IStyleItemMgr.queryStyleItemMap(BaseStyle baseStyle, WCMFilter _filter) 获取指定风格的风格项
java.util.HashMap | StyleItemMgr.queryStyleItemMap(BaseStyle _baseStyle, WCMFilter _filter) 获取指定风格的风格项
StyleItems | IStyleItemMgr.queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter) 获取某种（页面风格，资源可用风格，内容可用风格）风格下的StyleItem集合
StyleItems | StyleItemMgr.queryStyleItems(BaseStyle _baseStyle, WCMFilter _filter) 获取指定风格的风格项

com.trs.components.filter 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.components.filter 中的方法
 WCMFilter IQueryFilter.getFilter(MethodContext _mc)

com.trs.components.gkml.sqgk.persistent 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.gkml.sqgk.persistent 中的方法
static MailConfigs | MailConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[MailConfigs]
static ApplyForms | ApplyForms.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ApplyForms]
static ApplyFormDealLogs | ApplyFormDealLogs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ApplyFormDealLogs]

com.trs.components.infoview 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.infoview 中的方法
java.util.List | InfoViewEmployMgr.getEmployedInfoViews(int _iEmployerType, int _iEmployerId, WCMFilter _filter) TODO Add javadoc for field getEmployedInfoViews
java.util.List | InfoViewEmployMgr.getInfoViewEmployers(int _iInfoViewID, WCMFilter _filter)
InfoViews | InfoViewMgr.getInfoViews(WCMFilter _filter)

com.trs.components.infoview.helper 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.components.infoview.helper 中的方法
WCMFilter | InfoViewChnlDocFilterHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
WCMFilter | InfoViewChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
WCMFilter | InfoViewChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | InfoViewChnlDocFilterHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | InfoViewChnlDocFilterHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)

参数类型为 WCMFilter 的 com.trs.components.infoview.helper 中的方法
WCMFilter | InfoViewChnlDocFilterHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
WCMFilter | InfoViewChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
WCMFilter | InfoViewChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | InfoViewChnlDocFilterHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | InfoViewChnlDocFilterHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
static ComplexFieldDatas | ComplexFieldDatas.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ComplexFieldDatas]

com.trs.components.infoview.persistent 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.infoview.persistent 中的方法
static InfoViewDatas InfoViewDatas.openWCMObjs(int nInfoViewId, WCMFilter _filter)

com.trs.components.metadata.center 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.components.metadata.center 中的方法
static WCMFilter MetaDataCenterHelper.makeFilterWithClassInfos(java.lang.String sClassInfoIds, boolean _bContainsChildren)

参数类型为 WCMFilter 的 com.trs.components.metadata.center 中的方法
Channels | MetaViewEmployerMgr.getEmployers(MetaView _view, WCMFilter _extraFilter)
Channels | IMetaViewEmployerMgr.getEmployers(MetaView _view, WCMFilter _extraFilter) 获取使用了指定视图的所有栏目
void | MetaViewDatas.loadViewDatas(WCMFilter _filter)
void | MetaViewDatas.open(Channels _channels, WCMFilter _filter)
void | MetaViewDatas.open(Channel _channel, WCMFilter _filter)
void | MetaViewDatas.open(CMSBaseObjs _oSitesOrChannels, WCMFilter _extraFilter)
void | MetaViewDatas.open(WCMFilter _filter)
void | MetaViewDatas.open(WCMFilter _filter, WCMFilter _countFilter)
void | MetaViewDatas.open(WebSites _sites, WCMFilter _filter)
void | MetaViewDatas.open(WebSite _site, WCMFilter _filter)
static MetaViewDatas | MetaViewDatas.openWCMObjs(MetaView oMetaView, WCMFilter _filter)
static MetaViewDatas | MetaViewDatas.openWCMObjs(java.lang.String _sTableName, WCMFilter _filter) 通过指定一个Filter获取当前集合[MetaViewDatas]
static ClassInfoViews | ClassInfoViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ClassInfoViews]
static MetaViewEmployers | MetaViewEmployers.openWCMObjs(WCMFilter _filter)
ClassInfos | IClassInfoViewMgr.queryClassInfos(User _currUser, Documents oDocuments, WCMFilter _filter) 根据文档对象集合获取获取分类法信息集合
ClassInfos | ClassInfoViewMgr.queryClassInfos(User user, Documents documents, WCMFilter _filter)
ClassInfos | IClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
ClassInfos | ClassInfoViewMgr.queryClassInfos(User _currUser, Document oDocument, WCMFilter _filter) 根据文档对象获取获取分类法信息集合
int | IClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)
int | ClassInfoViewMgr.queryDocumentNum(User _currUser, ClassInfo _classInfo, WCMFilter _filter)
Documents | IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos _oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象得到相应的文档集合对象
Documents | IClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
Documents | ClassInfoViewMgr.queryDocuments(User _currUser, ClassInfo _oClassInfo, WCMFilter _filter) 根据分类法对象得到相应的文档集合对象
static MetaViewDatas | ClassDocumentsHelper.queryMetaViewDatas(MetaView _view, ClassInfos _classInfos, boolean _bOnlyLeaf, WCMFilter _extraFilter) 获取指定视图中同时属于指定的多个分类（含下面的子分类）的文档 子分类仅仅只叶子节点
MetaViews | IClassInfoViewMgr.queryViews(User _currUser, ClassInfos _oClassInfo, WCMFilter _filter) 根据分类法ID序列返回视图对象集合
MetaViews | ClassInfoViewMgr.queryViews(User _currUser, ClassInfos oClassInfos, WCMFilter _filter) 根据分类法集合对象返回相应的视图对象集合

com.trs.components.metadata.definition 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.metadata.definition 中的方法
MetaDBFields | IMetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter) 获取指定表的指定字段列表
MetaDBFields | MetaDataDefMgr.getDFieldInfos(User _currUser, MetaDBTable _oDBTableInfo, WCMFilter _extraFilter)
MetaDBTables | MetaView.getOtherTables(User _currUser, WCMFilter _extraFilter)
MetaViewFields | IMetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViewFields | MetaDataDefMgr.getViewFields(User _currUser, MetaView _oView, WCMFilter _extraFilter)
MetaViewFields | MetaView.getViewFields(User _currUser, WCMFilter _extraFilter)
static ClassInfos | ClassInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ClassInfos]
static MetaDBFields | MetaDBFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DBFieldInfos]
static MetaViews | MetaViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ViewInfos]
static MetaDBTables | MetaDBTables.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TableInfos]
static MetaViewFields | MetaViewFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ViewFieldInfos]
ClassInfos | ClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
ClassInfos | IClassInfoMgr.queryChildren(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter)
java.lang.String | ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列,以逗号分隔
java.lang.String | IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的所有子分类，包括子孙分类Ids
java.lang.String | ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim) 得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列
java.lang.String | IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
java.lang.String | ClassInfoMgr.queryChildrenWithAllLevel(User _currUser, int _nClassInfoId, WCMFilter _extraFilter)
java.lang.String | IClassInfoMgr.queryChildrenWithAllLevel(User _currUser, int _nClassInfoId, WCMFilter _extraFilter)
java.lang.String | ClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的一级子分类的Ids
java.lang.String | IClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter) 得到满足条件的当前分类的一级子分类的Ids
java.lang.String | ClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)
java.lang.String | IClassInfoMgr.queryChildrenWithFirstLevel(User _currUser, ClassInfo _classInfo, WCMFilter _extraFilter, char _cDelim)

com.trs.components.metadata.publish 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.metadata.publish 中的方法
IPublishElements | PublishFolderClassImpl.getAllContents(WCMFilter _filter)
IPublishElementsIterator | PublishFolderClassImpl.getAllContentsIterator(WCMFilter _filter)
IPublishElements | PublishFolderClassImpl.getIncreasedContents(WCMFilter _filter)
IPublishElementsIterator | PublishFolderClassImpl.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElements | PublishFolderClassImpl.getPublishedContents(WCMFilter _filter)

com.trs.components.metadata.service 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.components.metadata.service 中的方法
WCMFilter | WCMFilterMakerForContainsChildren.getCurrFilter()
static WCMFilter | GovInfoToXML.getMetaDatasFilter(ClassInfo _oClassInfo)

参数类型为 WCMFilter 的 com.trs.components.metadata.service 中的方法
ClassInfos | ClassInfoServiceProvider.queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)
ClassInfos | ClassInfoServiceProviderForGB.queryClassInfos(User _currUser, int _nParentId, WCMFilter _extraFilter)
ClassInfos | ClassInfoViewService.queryClassInfos(User _currUser, java.lang.String _sDocumentIds, WCMFilter _filter) 根据分类法信息返回视图对象集合
Documents | ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter) 根据传入的分类法对象获取文档集合对象
Documents | ClassInfoViewService.queryDocuments(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo) 根据传入的分类法对象获取文档集合对象
int | GovInfoServiceProvider.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
int | MetaDataCenterServiceProviderForGB.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
int | MetaDataCenterServiceProviderForAgri.queryObjectsCountOfClassInfo(MetaView _metaView, ClassInfo _classInfo, WCMFilter _filter)
MetaViews | ClassInfoViewService.queryViews(User _currUser, java.lang.String _sClassInfo, WCMFilter _filter) 根据分类法信息返回视图对象集合
MetaViews | ClassInfoViewService.queryViews(User _currUser, java.lang.String _sClassInfoId, WCMFilter _filter, boolean _bContainChildClassInfo) 根据分类法信息返回视图对象集合

com.trs.components.special 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.special 中的方法
static Specials | Specials.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Specials]
Specials | SpecialMgr.query(User _curruser, WCMFilter _filter)
Specials | ISpecialMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询符合当前条件的专题

com.trs.components.stat 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.stat 中的方法
static DocumentHitsCounts | DocumentHitsCounts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocumentHitsCounts]
static HostObjDomains | HostObjDomains.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[HostObjDomains]
static ChnlDepts | ChnlDepts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChnlDepts]
static HostObjHitsCounts | HostObjHitsCounts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[HostObjHitsCounts]
static UserLoginInfos | UserLoginInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[UserLoginInfos]
static BonusRules | BonusRules.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[BonusRules]
UserLoginInfos | IUserLoginInfoMgr.query(User _oCurrUser, WCMFilter _filter)
BonusRules | BonusRuleMgr.query(User _oCurrUser, WCMFilter _oFilter) 查询系统指定奖励规则
BonusRules | IBonusRuleMgr.query(User _oCurrUser, WCMFilter _currFilter) 查询系统指定奖励规则
UserLoginInfos | UserLoginInfoMgr.query(User _oCurrUser, WCMFilter _filter) 查询指定条件下的用户登录信息

com.trs.components.wcm.content 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.content 中的方法
void | ViewDocuments.open(Channels _channels, WCMFilter _filter)
void | ViewDocuments.open(Channel _channel, WCMFilter _filter)
void | ViewDocuments.open(CMSBaseObjs _oSitesOrChannels, WCMFilter _extraFilter)
void | ViewDocuments.open(WebSites _sites, WCMFilter _filter)
void | ViewDocuments.open(WebSite _site, WCMFilter _filter)
void | ViewDocuments.openViewDocuments(WCMFilter _filter)
static Documents | QueryDocumentCenter.queryDocumentsForUser(User _currUser, BaseChannel _oChannelOrSite, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize, boolean _bContainsChildren, WCMFilter _filter)
static Documents | QueryDocumentCenter.queryDocumentsOfCurrPage(WCMFilter _filter, java.lang.String _sSelectFieldsOfDocument, int _nPageIndex, int _nPageSize)

com.trs.components.wcm.content.domain 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.components.wcm.content.domain 中的方法
WCMFilter | DocumentMgr.getFilterForDocuments(BaseChannel _oChannel, WCMFilter _docFitler)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle, int _nTrueChannelId)
static WCMFilter | DocumentsGetHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
static WCMFilter | DocumentsGetHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)

参数类型为 WCMFilter 的 com.trs.components.wcm.content.domain 中的方法
DocBaks | DocBakMgr.findDocBaks(Document _currDocument, WCMFilter _filter) 取当前文档的备份集合
Documents | DocumentMgr.getAllDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的所有文档
Documents | DocKeywordMgrImpl.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
Documents | IDocKeywordMgr.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter) 获取指定文档的所有相关文档
Documents | DocKeywordMgrImpl.getAllRelatedDocumentsByKeywordsFromTRSServer(java.lang.String _sKeywords, WCMFilter _filter, int _nPageIndex)
Appendixes | AppendixMgr.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档某种类型的附件
Appendixes | AppendixMgr.getAppendixes(Document _currDocument, WCMFilter _filter) 获取当前文档的附件(符合筛选条件)
Appendixes | AppendixMgr.getAppendixes(WCMFilter _aWCMFilter) 根据条件获得当前附件
Channels | ChannelMgr.getChannels(int _nSiteId, WCMFilter _filter) 取符合一定条件的栏目集合
ChannelSyns | AutoTransmitMgr.getChannelSyns(Channel _currChannel, WCMFilter _filter)
ChannelSyns | AutoTransmitMgr.getChannelSyns(Channel _currChannel, WCMFilter _filter, boolean _bChannelAsTarget)
CMSBaseObjs | ChannelMgr.getChildren(BaseChannel _oChannel, int _nChannelType, boolean _bIncludingDeletedChannel, WCMFilter _filter)
ContentLinks | ContentLinkMgr.getContentLinks(int _nSiteId, WCMFilter _filter) 获取指定站点下的内容超链接
ContentLinks | ContentLinkMgr.getContentLinks(WebSite _currSite, WCMFilter _filter) 获取当前站点的所有内容超链接
Documents | DocumentMgr.getDocuments(BaseChannel _oChannel, WCMFilter _filter) 取站点/频道的(除了回收站外的)文档集合
static Documents | DocumentsGetHelper.getDocuments(Channel _channel, WCMFilter _filter)
static Documents | DocumentsGetHelper.getDocuments(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder)
Documents | UserDocumentMgr.getDocuments(WCMFilter _filter) 获取个人的所有有效文档
Documents | UserDocumentMgr.getDraft(WCMFilter _filter) 获取个人草稿
ContentExtFields | ContentExtFieldMgr.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter)
ContentExtFields | ContentExtFieldMgr.getExtFields(CMSObj _host, WCMFilter _filter, boolean _bContainsChildren)
WCMFilter | DocumentMgr.getFilterForDocuments(BaseChannel _oChannel, WCMFilter _docFitler)
Channels | ChannelMgr.getRecycleChannels(BaseChannel _oChannel, WCMFilter _chnlFilter) 获取符合一定条件的被删除的栏目
Documents | DocumentMgr.getRecycleDocuments(BaseChannel _currChnl, WCMFilter _filter) 取频道的废稿
Documents | UserDocumentMgr.getRecycleDocuments(WCMFilter _filter) 获取个人回收站里的文档
WebSites | ChannelMgr.getRecycleSites(WCMFilter _filter)
ChannelSyns | AutoTransmitMgr.getRelatedChannelSyns(Channel _currChannel, WCMFilter _filter)
Documents | DocumentMgr.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 相关文档的相关方法
Documents | DocumentMgr.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites) 获取与当前文档相关的文档集合(指定获取的方式:相关表/关键词/相关词等)
Relations | RelationMgr.getRelations(Document _currDocument, WCMFilter _extraFilter)
Relations | RelationMgr.getRelations(WCMFilter _aWCMFilter) 根据条件获得相关文档
Replaces | ReplaceMgr.getReplaces(Channel _oChannel, WCMFilter _filter) 获取当前频道下的替换内容
Groups | SiteMemberMgr.getSiteGroups(WebSite _site, WCMFilter _filter) 获取站点中的用户组集合
Roles | SiteMemberMgr.getSiteRoles(WebSite _site, WCMFilter _fitler)
Users | SiteMemberMgr.getSiteUsers(WebSite _site, WCMFilter _filter) 获取站点中的用户集合
Documents | DocumentMgr.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档
WebSites | SiteMemberMgr.getUserSites(User _currUser, WCMFilter _filter) 获取当前用户所在站点集合
WebSites | ChannelMgr.getWebSites(WCMFilter _filter, boolean _bIncludeDel) 获取系统中的所有站点
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channels _channels, WCMFilter _filter, boolean _bFromRecycle)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle)
static WCMFilter | DocumentsGetHelper.makeChannelFilter(Channel _channel, WCMFilter _filter, boolean _bIncludeOrder, boolean _bFromRecycle, int _nTrueChannelId)
static WCMFilter | DocumentsGetHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeFilter(WebSites _sites, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
static WCMFilter | DocumentsGetHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)
WCMFilter | DatasWithChnlDocFilterHelper.makeFilter(WebSite _site, WCMFilter _extraFilter, boolean _bIncludeOrder, boolean _bFromRecycle)

com.trs.components.wcm.content.persistent 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.content.persistent 中的方法
void | XDocuments.open(java.lang.String _sTableName, int _nDocId, WCMFilter _extraFilter, java.lang.String _sIdFieldName)
static DocReplys | DocReplys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocReplys]
static Documents | Documents.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Documents]
static ChannelContentLinks | ChannelContentLinks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChannelContentLinks]
static ChannelSyns | ChannelSyns.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 17:12:53 Last Modified: 2004-12-12/2004-12-12 Description:获取频道分发设置集合
static DocBaks | DocBaks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[DocBaks]
static Appendixes | Appendixes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Appendixes]
static Relations | Relations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Relations]
static ContentLinks | ContentLinks.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 17:19:37 Last Modified: 2004-12-12/2004-12-12 Description: 获取内容超链接对象集合
static DocumentSyns | DocumentSyns.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[TransmittedDocs]
static Replaces | Replaces.openWCMObjs(User _currUser, WCMFilter _fitler) Created: 2004-12-12 17:23:52 Last Modified: 2004-12-12/2004-12-12 Description:获取内容替换对象集合
static SiteMembers | SiteMembers.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[SiteUsers]
static ContentExtFields | ContentExtFields.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentExtFields]
static AutoBakConfigs | AutoBakConfigs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[AutoBakConfigs]
static WebSites | WebSites.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[WebSites]
static ChnlDocs | ChnlDocs.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ChnlDocs]
static ContentLinkTypes | ContentLinkTypes.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[ContentLinkTypes]
static Channels | Channels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Channels]
void | Documents.setIdList(java.util.Vector _vIdList, WCMFilter _filter, boolean _bNotClear)

com.trs.components.wcm.content.trsserver 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.content.trsserver 中的方法
Documents | DocsFromTRSServer.openDocs(User _currUser, WCMFilter _filter, int _nCurrPage, int _nPageSize)
TRSToWCMFilter | DocsFromTRSServer.toTRSFilter(WCMFilter _filter)

com.trs.components.wcm.customize 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.customize 中的方法
static UserSettings | UserSettings.findOf(User _currUser, int _nObjType, WCMFilter _filter)
static UserSettings | UserSettings.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[UserSettings]

com.trs.components.wcm.epress 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.epress 中的方法
IPublishElements | EpressFolderWrapper.getAllContents(WCMFilter _filter)
IPublishElementsIterator | EpressFolderWrapper.getAllContentsIterator(WCMFilter _filter)
IPublishElements | EpressFolderWrapper.getIncreasedContents(WCMFilter _filter)
IPublishElementsIterator | EpressFolderWrapper.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElements | EpressFolderWrapper.getPublishedContents(WCMFilter _filter)

com.trs.components.wcm.individuation 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.individuation 中的方法
static Individuations | Individuations.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Individuations]
static CustomSiteCheckedInfos | CustomSiteCheckedInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[CustomSiteCheckedInfos]

com.trs.components.wcm.publish 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.publish 中的方法
static WCMPubStatusConfigs WCMPubStatusConfigs.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[WCMPubStatusConfigs]

com.trs.components.wcm.publish.element 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.publish.element 中的方法
IPublishElements | PublishFolderChannelImpl.getAllContents(WCMFilter _filter)
IPublishElements | PublishFolderWebSiteImpl.getAllContents(WCMFilter _filter)
IPublishElementsIterator | PublishFolderChannelImpl.getAllContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderWebSiteImpl.getAllContentsIterator(WCMFilter _filter)
IPublishElements | PublishFolderChannelImpl.getIncreasedContents(WCMFilter _filter)
IPublishElements | PublishFolderWebSiteImpl.getIncreasedContents(WCMFilter _filter)
IPublishElementsIterator | PublishFolderChannelImpl.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElementsIterator | PublishFolderWebSiteImpl.getIncreasedContentsIterator(WCMFilter _filter)
IPublishElements | PublishFolderChannelImpl.getPublishedContents(WCMFilter _filter)
IPublishElements | PublishFolderWebSiteImpl.getPublishedContents(WCMFilter _filter)

参数类型为 WCMFilter 的 com.trs.components.wcm.publish.element 中的构造方法
PublishElementsIteratorDocumentsImpl(WCMFilter _filter)

com.trs.components.wcm.publish.logo 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.publish.logo 中的方法
static Logos | Logos.findOf(User _currUser, int _nHostType, int _nHostId, WCMFilter _filter) 获取指定对象的指定Logo集合
static Logos | Logos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Logos]

com.trs.components.wcm.publish.region 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.publish.region 中的方法
static RegionInfos | RegionInfos.findByChannelId(int _nChannelId, WCMFilter _filter)
static RegionInfos | RegionInfos.findBySiteId(int _nWebSiteId, WCMFilter _filter)
static CellInfos | CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter) 获取指定区域中所有的单元格，默认按照行、列排序
static CellInfos | CellInfos.findCellInfos(RegionInfo _regionInfo, WCMFilter _filter, User _currUser) 获取指定区域中所有的单元格，默认按照行、列排序.
static RegionInfos | RegionInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RegionInfos]
static RegionEmploys | RegionEmploys.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[RegionEmploys]
static CellInfos | CellInfos.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[CellInfos]

com.trs.components.wcm.publish.tagparser 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.publish.tagparser 中的方法
Documents | PublishTaskDocumentsCacheMgr.get(IPublishFolder _folder, WCMFilter _filter)
Documents | IPublishTaskDocumentsCacheMgr.get(IPublishFolder _folder, WCMFilter _filter)
void | PublishTaskDocumentsCacheMgr.put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments)
void | IPublishTaskDocumentsCacheMgr.put(IPublishFolder _folder, WCMFilter _filter, Documents _oDocuments) 将Folder根据Filter获取到的Documents缓存起来

com.trs.components.wcm.recent 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.recent 中的方法
Channels | RecentMgr.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted) 获得用户最近访问的频道列表，按访问时间逆序排列
ChnlDocs | RecentMgr.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
Documents | RecentMgr.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted) 获得用户最近访问的文档列表，按访问时间逆序排列
Templates | RecentMgr.getTemplates(WCMFilter _aFilter) 获得用户最近访问的模板列表，按访问时间逆序排列
WebSites | RecentMgr.getWebSites(WCMFilter _aFilter) 获得用户最近访问的模板列表，按访问时间逆序排列
static Recents | Recents.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Recents]

com.trs.components.wcm.resource 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.resource 中的方法
Schedules | ResourceMgr.getTempPathDeleteSchedules(WCMFilter _filter)
static Keywords | Keywords.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Keywords]
static Securities | Securities.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Securities]
static Sources | Sources.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Sources]
static Statuses | Statuses.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Statuses]

com.trs.components.wcm.stat 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.stat 中的方法
StatViews | StatMgr.getStatViews(java.lang.String _sStatHostName, int _nStatViewType, WCMFilter _filter) 获取指定统计主体下的统计视图.
static StatViews | StatViews.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatViews]
static StatViewRels | StatViewRels.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatViewRels]
static StatHosts | StatHosts.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatHosts]
static StatFieldMaps | StatFieldMaps.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[StatFieldsMaps]

com.trs.components.wcm.stat.domain 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.components.wcm.stat.domain 中的方法
 WCMFilter ChartOption.getExtraFilter()

参数类型为 WCMFilter 的 com.trs.components.wcm.stat.domain 中的方法
 void ChartOption.setExtraFilter(WCMFilter _filter)

com.trs.components.wcm.wcmx.help 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.components.wcm.wcmx.help 中的方法
static WCMHelps WCMHelps.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[WCMHelps]

com.trs.db.update 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.db.update 中的方法
static DBUpdateLogs DBUpdateLogs.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[DBUpdateLogs]

com.trs.infra.persistent 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.infra.persistent 中的方法
WCMFilter | BaseObjs.getFilter() 获得集合的过滤器
WCMFilter | WCMFilter.mergeWith(WCMFilter _filter) 过滤器的合并

参数类型为 WCMFilter 的 com.trs.infra.persistent 中的方法
void | WCMFilter.copy(WCMFilter _filterSrc) 过滤器复制函数
BaseObjs | BaseObjs.filter(WCMFilter _filter) 使用指定的过滤器筛选子集
void | BaseObjs.loadObjsOfCurrPage(int _nPageIndex, int _nPageSize, WCMFilter _filterForLoadID, java.lang.String _sSelectFieldsOfLoadObj)
WCMFilter | WCMFilter.mergeWith(WCMFilter _filter) 过滤器的合并
void | BaseObjs.open(WCMFilter _filter) 打开集合
void | CMyResultSets.open(WCMFilter _filter) 打开集合
void | BaseObjs.setFilter(WCMFilter _filter)

参数类型为 WCMFilter 的 com.trs.infra.persistent 中的构造方法
WCMFilter(WCMFilter _filter)

com.trs.infra.persistent.db 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.infra.persistent.db 中的方法
static void | DBManager.setParameters(java.sql.PreparedStatement _oPreStmt, WCMFilter filter)
int | DBManager.sqlExecuteCountQuery(WCMFilter _filter)
int | DBManager.sqlExecuteIntQuery(WCMFilter _filter)
int[] | DBManager.sqlExecuteIntsQuery(WCMFilter _filter)

com.trs.infra.support.config 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.infra.support.config 中的方法
static Configs Configs.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[Configs]

com.trs.infra.support.log 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.infra.support.log 中的方法
void | LogMgr.delete(WCMFilter _filter)
void | ILogMgr.delete(WCMFilter _filter)
void | LogMgr.deleteLogBaks(WCMFilter _filter)
void | ILogMgr.deleteLogBaks(WCMFilter _filter)
static BaseObjs | LogServer.getLogBaks(int _nLogType, WCMFilter _filter) 获取所有符合条件的归档日志，可直接指定日志类型ID
BaseObjs | LogMgr.getLogBaks(WCMFilter _filter)
static BaseObjs | LogServer.getLogBaks(WCMFilter _currFilter) 获取所有符合条件的归档日志
BaseObjs | ILogMgr.getLogBaks(WCMFilter _filter)
BaseObjs | LogMgr.getLogBaks(WCMFilter _filter, int _nLogType)
BaseObjs | ILogMgr.getLogBaks(WCMFilter _filter, int _nLogType)
static BaseObjs | LogServer.getLogs(int _nLogType, WCMFilter _filter) 获取所有符合条件的日志，可直接指定日志类型ID
BaseObjs | LogMgr.getLogs(WCMFilter _filter)
static BaseObjs | LogServer.getLogs(WCMFilter _filter) 获取所有符合条件的日志
BaseObjs | ILogMgr.getLogs(WCMFilter _filter)
BaseObjs | LogMgr.getLogs(WCMFilter _filter, int _nLogType)
BaseObjs | ILogMgr.getLogs(WCMFilter _filter, int _nLogType)
static BaseObjs | LogServer.getLogsByTopId(int _nLogTopId, WCMFilter _filter) 获取属于一个逻辑操作（TopId）的日志集合 TopId标识日志的起始触发操作，相同TopId的操作都是一个操作触发的。
BaseObjs | LogMgr.getLogsByTopId(WCMFilter _filter, int _nTopId)
BaseObjs | ILogMgr.getLogsByTopId(WCMFilter _filter, int _nTopId)
static OperTypes | OperTypes.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[OperTypes]
static LogBaks | LogBaks.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMLogBaks]
static Logs | Logs.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMLogs]

com.trs.infra.support.security 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.infra.support.security 中的方法
SecureKeys | SecureKeyMgr.getKeys(WCMFilter _filter) 获取当前系统中符合条件的密钥的集合
static SecureKeys | SecureKeys.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[SecureKeys]

com.trs.infra.util.job 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.infra.util.job 中的方法
static JobFailedResults JobFailedResults.openWCMObjs(WCMFilter _filter)
通过指定一个Filter获取当前集合[JobFailedResults]

com.trs.presentation.util 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.presentation.util 中的方法
 WCMFilter RequestHelper.getPageFilter(WCMFilter _extraFilter)

参数类型为 WCMFilter 的 com.trs.presentation.util 中的方法
 WCMFilter RequestHelper.getPageFilter(WCMFilter _extraFilter)

com.trs.service 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.service 中的方法
PublishDistributions | IWCMPublishElementService.findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter) 获取当前站点所设置的分发目录集合
Documents | IDocumentService.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
PublishTasks | IPublishService.getAllTasks(WCMFilter _filter) 提取所有的发布任务；要求当前用户必须具有管理权限
Appendixes | IDocumentService.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档的某种类型的附件
Appendixes | IDocumentService.getAppendixes(Document _currDocument, WCMFilter _filter) 获取当前文档的某种类型的附件
BookMarks | IBookMarkService.getBookMarks(int _nMarkKindId, WCMFilter _filter) 根据传入的MarkKind ID，获取它所包含的BookMarks
BookMarks | IBookMarkService.getBookMarks(WCMFilter _filter) 获取BookMarks集合
Users | IUserService.getCanMgrUsers(int _nUserRegStatus, WCMFilter _filter) 获取我可管理的用户
Channels | IRecentService.getChannels(WCMFilter _aFilter) 返回用户最近访问的频道列表 按照访问的时间顺序排序
Channels | IRecentService.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道列表 按照访问的时间顺序排序
Channels | IRecentService.getChannels(WCMFilter _filter, boolean _bIncludeDeleted, int _nRightIndex) 获取用户最近访问的频道集合,并校验访问指定权限.
Channels | IRecentService.getChannelsWithRight(WCMFilter _filter) 获取用户最近访问的频道集合,并校验访问权限.
ChannelSyns | IChannelService.getChannelSyns(int _nChannelId, WCMFilter _filter)
Groups | IGroupService.getChildren(Group _parentGroup, boolean _bContainsChildren, WCMFilter _filter)
MarkKinds | IBookMarkService.getChildren(int _nMarkKindId, WCMFilter _filter) 根据传入的MarkKind ID，获取它的子MarkKinds
ChnlDocs | IRecentService.getChnlDocs(WCMFilter _aFilter) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
ChnlDocs | IRecentService.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
ContactGrps | IContactService.getContactGroups(WCMFilter _filter) 获取当前用户的所有联系人分组
Contacts | IContactService.getContacts(WCMFilter _filter) 获取当前登录用户所有的联系人
Contacts | IContactService.getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人
ContentLinks | IChannelService.getContentLinks(WebSite _site, WCMFilter _filter)
DocBaks | IDocumentService.getDocBaks(Document _currDocument, WCMFilter _filter) 获取当前文档的备份
Documents | IChannelService.getDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的有效文档
Documents | IChannelService.getDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的有效文档
Documents | IUserService.getDocuments(WCMFilter _filter) 获取当前登录用户创建的有效文档集合,设定查询条件
Documents | IRecentService.getDocuments(WCMFilter _aFilter) 返回用户最近访问的文档列表 由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
Documents | IRecentService.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的文档列表 由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
Documents | IUserService.getDraft(WCMFilter _filter) 获取当前登录用户创建的草稿集合,设定查询条件
Events | IEventService.getEvents(WCMFilter _filter) 根据指定的filter获取Events
ContentExtFields | IChannelService.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter) 获取指定站点/频道下的扩展字段.
FlowDocs | IWCMProcessService.getFlowDocs(int _nFlag, WCMFilter _filter)
Flows | IWCMProcessService.getFlows(WCMFilter _filter)
InfoViews | IInfoViewService.getInfoViews(WCMFilter _filter) 获取所有符合条件的自定义表单
SecureKeys | ISecurityService.getKeys(WCMFilter _filter) 获取当前系统中符合条件的密钥的集合
Templates | ITemplateService.getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) 获取站点/频道下管理的模板集合
PublishTasks | IPublishService.getMyTasks(WCMFilter _filter) 提取我的发布任务
Users | IUserService.getMyUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所创建的用户列表
Templates | ITemplateService.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseParent) 获取指定Folder中可选的模板集合
Channels | IChannelService.getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的废弃频道集合
Documents | IChannelService.getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的废稿
Documents | IDocumentService.getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter) 获取当前站点或频道的回收站的文档
Documents | IChannelService.getRecycleDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的废稿
Documents | IUserService.getRecycleDocuments(WCMFilter _filter) 获取当前登录用户创建的废稿集合,设定查询条件
WebSites | IChannelService.getRecycleSites(WCMFilter _filter) 获取系统回收站中的站点集合
Documents | IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 指定检索条件获取与当前文档相关的文档
Documents | IDocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSite) 指定检索条件获取与当前文档相关的文档
Replaces | IChannelService.getReplaces(Channel _oChannel, WCMFilter _filter) 获取指定频道下的替换内容对象集合
BookMarks | IBookMarkService.getSharedBookMarks(User _currUser, WCMFilter _fliter) 获取所有共享的书签
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter) 获取用户在指定filter限制下被Assign的Events
MarkKinds | IBookMarkService.getSharedMarkKinds(User _currUser, WCMFilter _filter) 获取所有共享的书签文件夹
Groups | IChannelService.getSiteGroups(WebSite _site, WCMFilter _filter) 获取指定站点的所属用户组集合
Roles | IChannelService.getSiteRoles(WebSite _site, WCMFilter _filter) 获取指定站点的所属角色集合
Users | IChannelService.getSiteUsers(WebSite _currSite, WCMFilter _currFilter) 获取指定站点的所属用户集合
StatHosts | IStatService.getStatHosts(WCMFilter _filter) 获得系统中提供的所有统计主体
StatViews | IStatService.getStatViews(java.lang.String _sStatHostName, int _StatViewType, WCMFilter _filter) 获得特定查询主体的统计视图模板
FlowDocs | IWCMProcessService.getSubmitFlowDocs(User _operator, WCMFilter _filter) 获取用户[_operator]已经呈送的信息
Templates | IRecentService.getTemplates(WCMFilter _aFilter) 返回用户最近访问的模板列表 按照访问的时间顺序排序
Documents | IDocumentService.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档
Users | IGroupService.getUsers(Group _dstGroup, WCMFilter _filter) 获取指定组中的所有用户
Users | IGroupService.getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildren)
Users | IUserService.getUsers(int _nUserRegStatus, WCMFilter _filter) 获取系统中的某个注册状态的所有用户
Users | IRoleService.getUsers(Role _dstRole, WCMFilter _filter) 获取指定角色的所有用户
WebSites | IChannelService.getUserSites(User _currUser, WCMFilter _currFilter) 获取指定用户所属的站点集合
WebSites | IChannelService.getWebSites(WCMFilter _filter) 获取当前用户可以看见的站点
WebSites | IRecentService.getWebSites(WCMFilter _aFilter) 返回用户最近访问的站点列表 按照访问的时间顺序排序

com.trs.service.impl 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.service.impl 中的方法
PublishDistributions | WCMPublishElementServiceImpl.findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter)
Documents | DocumentService.getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
PublishTasks | PublishService.getAllTasks(WCMFilter _filter)
Appendixes | DocumentService.getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter)
Appendixes | DocumentService.getAppendixes(Document _currDocument, WCMFilter _apdFilter)
BookMarks | BookMarkService.getBookMarks(int _nMarkKindId, WCMFilter _filter)
BookMarks | BookMarkService.getBookMarks(WCMFilter _filter)
Users | UserService.getCanMgrUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所能管理的用户
Channels | RecentService.getChannels(WCMFilter _aFilter)
Channels | RecentService.getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted)
Channels | RecentService.getChannels(WCMFilter _filter, boolean _bIncludeDeleted, int _nRightIndex)
Channels | RecentService.getChannelsWithRight(WCMFilter _filter)
ChannelSyns | ChannelService.getChannelSyns(int _nChannelId, WCMFilter _filter)
Groups | GroupService.getChildren(Group _parentGroup, boolean _bContainsChild, WCMFilter _filter)
MarkKinds | BookMarkService.getChildren(int _nMarkKindId, WCMFilter _filter)
ChnlDocs | RecentService.getChnlDocs(WCMFilter _aFilter)
ChnlDocs | RecentService.getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted)
ContactGrps | ContactService.getContactGroups(WCMFilter _filter)
Contacts | ContactService.getContacts(WCMFilter _filter)
Contacts | ContactService.getContacts(WCMFilter _filter, ContactGrp _contactGroup)
ContentLinks | ChannelService.getContentLinks(WebSite _site, WCMFilter _filter)
DocBaks | DocumentService.getDocBaks(Document _currDocument, WCMFilter _filter)
Documents | ChannelService.getDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的有效文档
Documents | ChannelService.getDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的有效文档
Documents | RecentService.getDocuments(WCMFilter _aFilter)
Documents | UserService.getDocuments(WCMFilter _filter)
Documents | RecentService.getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted)
Documents | UserService.getDraft(WCMFilter _filter)
Events | EventService.getEvents(WCMFilter _filter)
ContentExtFields | ChannelService.getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter) 获取指定站点/频道下的扩展字段.
FlowDocs | WCMProcessServiceImpl.getFlowDocs(int _nFlag, WCMFilter _filter)
Flows | WCMProcessServiceImpl.getFlows(WCMFilter _filter)
InfoViews | InfoViewService.getInfoViews(WCMFilter _filter)
SecureKeys | SecurityService.getKeys(WCMFilter _filter)
Templates | TemplateService.getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren)
PublishTasks | PublishService.getMyTasks(WCMFilter _filter)
Users | UserService.getMyUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所创建的用户列表
Templates | TemplateService.getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent)
Channels | ChannelService.getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的废弃频道集合
Documents | DocumentService.getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter)
Documents | ChannelService.getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的废稿
Documents | ChannelService.getRecycleDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的废稿
Documents | UserService.getRecycleDocuments(WCMFilter _filter)
WebSites | ChannelService.getRecycleSites(WCMFilter _filter)
Documents | DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter)
Documents | DocumentService.getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites)
Replaces | ChannelService.getReplaces(Channel _oChannel, WCMFilter _filter)
BookMarks | BookMarkService.getSharedBookMarks(User _currUser, WCMFilter _fliter)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter)
MarkKinds | BookMarkService.getSharedMarkKinds(User _currUser, WCMFilter _filter)
Groups | ChannelService.getSiteGroups(WebSite _site, WCMFilter _filter)
Roles | ChannelService.getSiteRoles(WebSite _site, WCMFilter _filter)
Users | ChannelService.getSiteUsers(WebSite _currSite, WCMFilter _currFilter)
StatHosts | StatService.getStatHosts(WCMFilter _filter)
StatViews | StatService.getStatViews(java.lang.String _sStatHostName, int _nStatViewType, WCMFilter _filter)
FlowDocs | WCMProcessServiceImpl.getSubmitFlowDocs(User _operator, WCMFilter _filter)
Templates | RecentService.getTemplates(WCMFilter _aFilter)
Documents | DocumentService.getToppedDocuments(Channel _currChannel, WCMFilter _docFilter)
Users | GroupService.getUsers(Group _dstGroup, WCMFilter _filter)
Users | GroupService.getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildGrp)
Users | UserService.getUsers(int _nUserRegStatus, WCMFilter _filter)
Users | RoleService.getUsers(Role _dstRole, WCMFilter _filter)
WebSites | ChannelService.getUserSites(User _currUser, WCMFilter _currFilter)
WebSites | ChannelService.getWebSites(WCMFilter _filter) 获取当前用户可以看见的站点
WebSites | RecentService.getWebSites(WCMFilter _aFilter)

com.trs.wcm.config 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.wcm.config 中的方法
static PageOperators PageOperators.openWCMObjs(User _currUser, WCMFilter _filter)
通过指定一个Filter获取当前集合[PageOperators]

com.trs.wcm.customize 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.wcm.customize 中的方法
PageOperators | ICustomizeMgr.getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter) 获取指定用户指定类型的操作
PageOperators | CustomizeMgrImpl.getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter)

com.trs.wcm.old 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.wcm.old 中的方法
WCMFormInfos | WCMFormMgr.getForms(BaseChannel _oChannel, boolean _bChildren, WCMFilter _filter) 获取站点/频道的自定义表单 从ChannelMgr中移动过来的 hx@050328
static WCMFormInfos | WCMFormInfos.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 16:42:24 Last Modified: 2004-12-12/2004-12-12 Description:获取表单集合

com.trs.wcm.photo 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.wcm.photo 中的方法
java.util.List | IImageLibService.getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter) 获取指定用户在指定分类可见的子分类列表
Documents | IImageLibService.getDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前分类下所有的图片
Appendixes | IImageLibService.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片
Appendixes | IImageLibMgr.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片
static Watermarks | Watermarks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Watermarks]

com.trs.wcm.photo.impl 中 WCMFilter 的使用

参数类型为 WCMFilter 的 com.trs.wcm.photo.impl 中的方法
java.util.List | ImageLibServiceImpl.getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter)
Documents | ImageLibServiceImpl.getDocuments(BaseChannel _oChannel, WCMFilter _filter)
Appendixes | ImageLibServiceImpl.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)
Appendixes | ImageLibMgrImpl.getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported)

com.trs.webframework.context 中 WCMFilter 的使用

返回 WCMFilter 的 com.trs.webframework.context 中的方法
WCMFilter | MethodContext.getExtraWCMFilter()
static WCMFilter | MethodContextHelper.mergeMoreFilter(MethodContext _context, WCMFilter _filter)

参数类型为 WCMFilter 的 com.trs.webframework.context 中的方法
static WCMFilter MethodContextHelper.mergeMoreFilter(MethodContext _context, WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.XmlObject 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.XmlObject
的使用

使用 XmlObject 的软件包
com.trs.cms.process.xml
com.trs.components.metadata.service.portervisitors
com.trs.components.wcm.content.service.portervisitors
com.trs.components.wcm.process.service.flowexporter
com.trs.infra.persistent

com.trs.cms.process.xml 中 XmlObject 的使用

参数类型为 XmlObject 的 com.trs.cms.process.xml 中的方法
 Reports FlowImporter.importFromXMLObj(XmlObject _sXmlObj)

com.trs.components.metadata.service.portervisitors 中 XmlObject 的使用

参数类型为 XmlObject 的 com.trs.components.metadata.service.portervisitors 中的方法
 void ChannelPorterVisitorForMetaView.doImport(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs)

com.trs.components.wcm.content.service.portervisitors 中 XmlObject 的使用

参数类型为 XmlObject 的 com.trs.components.wcm.content.service.portervisitors 中的方法
void | IPorterVisitor.doImport(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs) 在导入_baseObj对象时,根据当前xml串做一些额外处理
static void | PorterUtil.doImports(BaseObj _baseObj, XmlObject _xmlObj, java.lang.Object _extraArgs) 根据注册的导入/导出访问器类,在导入_baseObj时,执行所有已注册的访问器的导入定制操作

com.trs.components.wcm.process.service.flowexporter 中 XmlObject 的使用

参数类型为 XmlObject 的 com.trs.components.wcm.process.service.flowexporter 中的方法
 void SiteExporterForFlow.doImport(BaseObj _baseObj, XmlObject _obj, java.lang.Object args)

com.trs.infra.persistent 中 XmlObject 的使用

返回 XmlObject 的 com.trs.infra.persistent 中的方法
XmlObject[] | XmlToObjConverter.convertXml(java.lang.String _sXMLContent, java.lang.String _sFieldsList)
XmlObject[] | XmlToObjConverterByDOM4j.convertXml(java.lang.String _sXMLContent, java.lang.String _sFieldsList)
XmlObject[] | AbstractXmlToObjConverter.convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList) parse the xml file
XmlObject[] | XmlToObjConverter.convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList) parse the xml file
XmlObject[] | XmlToObjConverterByDOM4j.convertXml(java.lang.String _sXmlFile, java.lang.String _sXslFile, java.lang.String _sFieldsList) parse the xml file
XmlObject[] | XmlObject.getChild(java.lang.String _sTagName)

参数类型为 XmlObject 的 com.trs.infra.persistent 中的方法
 void XmlObject.addChild(java.lang.String _sTagName, XmlObject[] _currChildren)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.XmlToObjConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.XmlToObjConverter
的使用

使用 XmlToObjConverter 的软件包
com.trs.ajaxservice

com.trs.ajaxservice 中 XmlToObjConverter 的使用

com.trs.ajaxservice 中 XmlToObjConverter 的子类
 class XmlToRightConvertor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.XmlToObjConverterByDOM4j 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.XmlToObjConverterByDOM4j
的使用

没有 com.trs.infra.persistent.XmlToObjConverterByDOM4j 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ConnectPasswordEncrypter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.db
类 ConnectPasswordEncrypter

java.lang.Object
    继承者  com.trs.infra.persistent.db.ConnectPasswordEncrypter

public final class ConnectPasswordEncrypter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
数据库连接密码加密/解密.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConnectPasswordEncrypter()
方法摘要
static java.lang.String | deEncrypt(java.lang.String _encrypted)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConnectPasswordEncrypter

public ConnectPasswordEncrypter()
方法详细信息

deEncrypt

public static java.lang.String deEncrypt(java.lang.String _encrypted)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DBConnectionConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.db
类 DBConnectionConfig

java.lang.Object
    继承者  com.trs.infra.persistent.db.DBConnectionConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class DBConnectionConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
数据库连接特性的配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DBConnectionConfig()
方法摘要
java.lang.String | getCacheScheme()
java.lang.String | getClassName()
java.lang.String | getConnectionPassword()
java.lang.String | getConnectionURL()
java.lang.String | getConnectionUser()
DBType | getDBType() 依据当前连接配置对象的className属性，获取DBType对象实例
int | getInitConnects()
int | getMaxConnects()
int | getMaxIdleTime()
int | getMaxOrphanTime()
int | getMonitorInterval()
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getTestSQL()
int | getTimeToLiveOverUse()
boolean | isDowithClob()
boolean | isTestOnAssign()
boolean | isTestOnIdle()
boolean | isTraceAssign()
boolean | isWaitIfBusy()
void | setCacheScheme(java.lang.String cacheScheme)
void | setClassName(java.lang.String className)
void | setConnectionPassword(java.lang.String connectionPassword)
void | setConnectionURL(java.lang.String connectionURL)
void | setConnectionUser(java.lang.String connectionUser)
void | setDowithClob(boolean dowithClob)
void | setInitConnects(int initConnects)
void | setMaxConnects(int maxConnects)
void | setMaxIdleTime(int maxIdleTime)
void | setMaxOrphanTime(int maxOrphanTime)
void | setMonitorInterval(int monitorInterval)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setTestOnAssign(boolean testOnAssign)
void | setTestOnIdle(boolean testOnIdle)
void | setTestSQL(java.lang.String testSQL)
void | setTimeToLiveOverUse(int timeToLiveOverUse)
void | setTraceAssign(boolean traceAssign)
void | setWaitIfBusy(boolean waitIfBusy)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBConnectionConfig

public DBConnectionConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

isWaitIfBusy

public boolean isWaitIfBusy()

setWaitIfBusy

public void setWaitIfBusy(boolean waitIfBusy)

getInitConnects

public int getInitConnects()

setInitConnects

public void setInitConnects(int initConnects)

getMaxConnects

public int getMaxConnects()

setMaxConnects

public void setMaxConnects(int maxConnects)

getClassName

public java.lang.String getClassName()

setClassName

public void setClassName(java.lang.String className)

getConnectionPassword

public java.lang.String getConnectionPassword()

setConnectionPassword

public void setConnectionPassword(java.lang.String connectionPassword)

getConnectionURL

public java.lang.String getConnectionURL()

setConnectionURL

public void setConnectionURL(java.lang.String connectionURL)

getConnectionUser

public java.lang.String getConnectionUser()

setConnectionUser

public void setConnectionUser(java.lang.String connectionUser)

isDowithClob

public boolean isDowithClob()

setDowithClob

public void setDowithClob(boolean dowithClob)

getDBType

public DBType getDBType()
依据当前连接配置对象的className属性，获取DBType对象实例

返回：
当前连接配置对象的className属性对应的DBType对象实例

isTraceAssign

public boolean isTraceAssign()
返回：
Returns the traceAssign.

setTraceAssign

public void setTraceAssign(boolean traceAssign)
参数：
traceAssign - The traceAssign to set.

getTimeToLiveOverUse

public int getTimeToLiveOverUse()
返回：
Returns the timeToLiveOverUse.

setTimeToLiveOverUse

public void setTimeToLiveOverUse(int timeToLiveOverUse)
参数：
timeToLiveOverUse - The timeToLiveOverUse to set.

getCacheScheme

public java.lang.String getCacheScheme()
返回：
Returns the cacheScheme.

setCacheScheme

public void setCacheScheme(java.lang.String cacheScheme)
参数：
cacheScheme - The cacheScheme to set.

getTestSQL

public java.lang.String getTestSQL()

setTestSQL

public void setTestSQL(java.lang.String testSQL)

isTestOnAssign

public boolean isTestOnAssign()

setTestOnAssign

public void setTestOnAssign(boolean testOnAssign)

getMaxIdleTime

public int getMaxIdleTime()

setMaxIdleTime

public void setMaxIdleTime(int maxIdleTime)

getMonitorInterval

public int getMonitorInterval()

setMonitorInterval

public void setMonitorInterval(int monitorInterval)

isTestOnIdle

public boolean isTestOnIdle()

setTestOnIdle

public void setTestOnIdle(boolean testOnIdle)

getMaxOrphanTime

public int getMaxOrphanTime()

setMaxOrphanTime

public void setMaxOrphanTime(int maxOrphanTime)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBConnectionConfigs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.db
类 DBConnectionConfigs

java.lang.Object
    继承者  com.trs.infra.persistent.db.DBConnectionConfigs
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class DBConnectionConfigs
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
数据库连接配置对象的集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DBConnectionConfigs()
方法摘要
DBConnectionConfig | get(int _nIndex)
java.util.ArrayList | getDBConnectionConfigColl()
java.lang.String | getDefaultConnection()
java.lang.String | getName() 获取配置对象的名称
void | setDBConnectionConfigColl(java.util.ArrayList connectionConfig)
void | setDefaultConnection(java.lang.String defaultConnection)
void | setName(java.lang.String _sName) 设置配置对象的名称
int | size() logic for Collection Options
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBConnectionConfigs

public DBConnectionConfigs()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getDBConnectionConfigColl

public java.util.ArrayList getDBConnectionConfigColl()

setDBConnectionConfigColl

public void setDBConnectionConfigColl(java.util.ArrayList connectionConfig)

getDefaultConnection

public java.lang.String getDefaultConnection()

setDefaultConnection

public void setDefaultConnection(java.lang.String defaultConnection)

size

public int size()
logic for Collection Options

get

public DBConnectionConfig get(int _nIndex)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBConnectionMapper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.db
类 DBConnectionMapper

java.lang.Object
    继承者  com.trs.infra.persistent.db.DBConnectionMapper
所有已实现的接口：
org.aton.container.IClearable
public class DBConnectionMapper
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
DBConnectionConfig 的散列查找表
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DBConnectionMapper()
Constructor
方法摘要
void | clear()
DBConnectionConfig | getDBConnectionConfigByName(java.lang.String _dbConnName) 依据连接名获取指定的配置信息
DBConnectionConfig | getDefaultDBConnectionConfig() 获取当前选择的连接的配置信息
static DBConnectionMapper | getInstance()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBConnectionMapper

public DBConnectionMapper()
Constructor

方法详细信息

getInstance

public static DBConnectionMapper getInstance()

getDBConnectionConfigByName

public DBConnectionConfig getDBConnectionConfigByName(java.lang.String _dbConnName)
依据连接名获取指定的配置信息

参数：
_dbConnName - 数据库连接名
返回：
指定的连接信息的配置对象

getDefaultDBConnectionConfig

public DBConnectionConfig getDefaultDBConnectionConfig()
获取当前选择的连接的配置信息

返回：
当前选中的连接配置对象

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBManager

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.db
类 DBManager

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.persistent.db.DBManager
所有已实现的接口：
IServer
public class DBManager
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
数据库管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
DBManager()
方法摘要
void | freeConnection(java.sql.Connection _oConn) 释放数据库连接
java.sql.Connection | getConnection() 获取有效的数据库连接
com.trs.util.dbcp.ConnectionCache | getConnectionCache() 返回实际的连接缓冲池对象，便于监控连接缓冲池的状态
DBConnectionConfig | getDBConnConfig() 获取当前所使用的数据库配置
DBIdManager | getDBIdManager() 获取数据表ID管理器
java.util.Set | getDBKeywords()
static DBManager | getDBManager()
DBType | getDBType() 获取当前的数据库类型对象的实现（对象的路径由配置文件中定义）
int | getDBTypeAsInt()
FieldInfo | getFieldInfo(java.lang.String _tableName, java.lang.String _fieldName) 取得值定数据表中指定字段信息
TableInfo | getTableInfo(java.lang.String _tableName) 取指定数据表的信息
TableInfos | getTableInfos()
boolean | isKeywords(java.lang.String _sFieldName) 校验当前字段名是否为数据库关键字
java.util.Iterator | iteratorKeywords()
static void | main(java.lang.String[] args)
void | notifyAddTable(java.lang.String _sTableName) 添加数据表
void | notifyRemoveTable(java.lang.String _sTableName) 删除数据表
void | reloadTableInfo(java.lang.String _sTableName) 重新装载指定的表信息
void | reloadTableInfo(java.lang.String _sTableName, boolean _bSendMsgOfCluster)
void | setDBConfig(DBConnectionConfig config) 设置当前所使用的数据库配置
static void | setParameters(java.sql.PreparedStatement _oPreStmt, java.util.List listSearchValues)
static void | setParameters(java.sql.PreparedStatement _oPreStmt, WCMFilter filter)
boolean | sqlExecUpdateProcedure(java.lang.String _strProc) 执行指定的存储过程语句
int | sqlExecuteCountQuery(WCMFilter _filter)
int | sqlExecuteIntQuery(java.lang.String _strSQL) caohui@2003.09.27 新增 获取指定SQL语句的第一行第一个整型数据
int | sqlExecuteIntQuery(java.lang.String _sQuerySQL, int[] _pParamerters)
int | sqlExecuteIntQuery(java.lang.String _sSQL, java.util.List _lParameters)
int | sqlExecuteIntQuery(WCMFilter _filter)
int[] | sqlExecuteIntsQuery(WCMFilter _filter)
java.sql.ResultSet | sqlExecuteQuery(java.lang.String _strSQL) 已过时。 错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。
java.sql.ResultSet | sqlExecuteQuery(java.lang.String _strSQL, int _nMaxSize) 已过时。 错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。 获取指定SQL语句的字符集
int | sqlExecuteQuery(java.lang.String _sSQL, java.util.List _lParameters, int _lDefault)
long | sqlExecuteQuery(java.lang.String _sSQL, java.util.List _lParameters, long _lDefault)
java.lang.String | sqlExecuteStringQuery(java.lang.String _sQuerySQL, int[] _pParamerters)
int | sqlExecuteUpdate(java.lang.String _strSQL) 执行指定的SQL Update语句
int | sqlExecuteUpdate(java.lang.String[] _strSQLs) 执行指定的SQL Update语句
void | sqlExecuteUpdate(java.lang.String[] _pUpdateSQL, int[] _pParamerters)
void | sqlExecuteUpdate(java.lang.String[] _pUpdateSQL, java.lang.Object[] _pParamerters)
java.lang.String | toDBInfo() 返回数据库信息
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBManager

public DBManager()
方法详细信息

isKeywords

public boolean isKeywords(java.lang.String _sFieldName)
校验当前字段名是否为数据库关键字

参数：
_sFieldName -
返回：
如果_sFieldName为空字符串,则总是返回true

getDBManager

public static DBManager getDBManager()

getDBKeywords

public java.util.Set getDBKeywords()

iteratorKeywords

public java.util.Iterator iteratorKeywords()

getDBConnConfig

public DBConnectionConfig getDBConnConfig()
获取当前所使用的数据库配置

返回：
数据库配置对象（DBConfig）

setDBConfig

public void setDBConfig(DBConnectionConfig config)
设置当前所使用的数据库配置

参数：
config - 当前所使用的数据库配置(DBConfig)

getConnection

public java.sql.Connection getConnection()
                                  throws WCMException
获取有效的数据库连接

返回：
数据库连接（Connection）
抛出：
WCMException - 如果数据库管理器没有正确启动，将会抛出异常
如果缓冲池中的连接对象无效，将会抛出异常

getFieldInfo

public FieldInfo getFieldInfo(java.lang.String _tableName,
                              java.lang.String _fieldName)
                       throws WCMException
取得值定数据表中指定字段信息

参数：
_tableName - 表名称
_fieldName - 字段名（列名）
返回：
抛出：
WCMException

getTableInfo

public TableInfo getTableInfo(java.lang.String _tableName)
                       throws WCMException
取指定数据表的信息

参数：
_tableName - 数据表名称
返回：
抛出：
WCMException

getDBType

public DBType getDBType()
获取当前的数据库类型对象的实现（对象的路径由配置文件中定义）

返回：
数据库类型对象的实现(DBType)

getDBTypeAsInt

public int getDBTypeAsInt()

notifyAddTable

public void notifyAddTable(java.lang.String _sTableName)
                    throws WCMException
添加数据表

参数：
_sTableName -
抛出：
WCMException

notifyRemoveTable

public void notifyRemoveTable(java.lang.String _sTableName)
                       throws WCMException
删除数据表

参数：
_sTableName -
抛出：
WCMException

freeConnection

public void freeConnection(java.sql.Connection _oConn)
释放数据库连接

参数：
_oConn - 数据库连接对象

toDBInfo

public java.lang.String toDBInfo()
                          throws WCMException
返回数据库信息

返回：
数据库连接以及缓冲池配置信息
抛出：
WCMException - 如果当前服务器没有正确启动会抛出异常

getConnectionCache

public com.trs.util.dbcp.ConnectionCache getConnectionCache()
                                                     throws WCMException
返回实际的连接缓冲池对象，便于监控连接缓冲池的状态

返回：
实际的连接缓冲池对象
抛出：
WCMException

getDBIdManager

public DBIdManager getDBIdManager()
                           throws WCMException
获取数据表ID管理器

返回：
数据表ID管理器(DBIdManager)
抛出：
WCMException

getTableInfos

public TableInfos getTableInfos()
                         throws WCMException
返回：
抛出：
WCMException

sqlExecUpdateProcedure

public boolean sqlExecUpdateProcedure(java.lang.String _strProc)
                               throws WCMException
执行指定的存储过程语句

参数：
_strProc - 指定的SQL Update语句
返回：
抛出：
WCMException

sqlExecuteQuery

public java.sql.ResultSet sqlExecuteQuery(java.lang.String _strSQL)
                                   throws WCMException
已过时。 错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。

抛出：
WCMException
另请参见：
ResultSet _sqlExecuteQuery(String _strSQL, int _nMaxSize) throws WCMException

sqlExecuteQuery

public java.sql.ResultSet sqlExecuteQuery(java.lang.String _strSQL,
                                          int _nMaxSize)
                                   throws WCMException
已过时。 错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。 获取指定SQL语句的字符集

参数：
_strSQL - 指定SQL语句
_nMaxSize - 数据集的最大数（可省略，默认值为0）
返回：
数据集对象ResultSet
抛出：
WCMException

sqlExecuteIntQuery

public int sqlExecuteIntQuery(java.lang.String _strSQL)
                       throws WCMException
caohui@2003.09.27 新增 获取指定SQL语句的第一行第一个整型数据

参数：
_strSQL - 指定SQL语句
返回：
整型数据(如果发生异常或查询不到将会返回-999)
抛出：
WCMException

sqlExecuteIntQuery

public int sqlExecuteIntQuery(WCMFilter _filter)
                       throws WCMException
抛出：
WCMException

sqlExecuteIntQuery

public int sqlExecuteIntQuery(java.lang.String _sSQL,
                              java.util.List _lParameters)
                       throws WCMException
参数：
_sSQL -
_lParameters -
返回：
抛出：
WCMException

sqlExecuteQuery

public long sqlExecuteQuery(java.lang.String _sSQL,
                            java.util.List _lParameters,
                            long _lDefault)
                     throws WCMException
抛出：
WCMException

sqlExecuteQuery

public int sqlExecuteQuery(java.lang.String _sSQL,
                           java.util.List _lParameters,
                           int _lDefault)
                    throws WCMException
抛出：
WCMException

sqlExecuteIntsQuery

public int[] sqlExecuteIntsQuery(WCMFilter _filter)
                          throws WCMException
抛出：
WCMException

sqlExecuteCountQuery

public int sqlExecuteCountQuery(WCMFilter _filter)
                         throws WCMException
抛出：
WCMException

sqlExecuteUpdate

public int sqlExecuteUpdate(java.lang.String[] _strSQLs)
                     throws WCMException
执行指定的SQL Update语句

参数：
_strSQLs - 指定的SQL Update语句
返回：
抛出：
WCMException

sqlExecuteUpdate

public int sqlExecuteUpdate(java.lang.String _strSQL)
                     throws WCMException
执行指定的SQL Update语句

参数：
_strSQL - 指定的SQL Update语句
返回：
抛出：
WCMException

sqlExecuteUpdate

public void sqlExecuteUpdate(java.lang.String[] _pUpdateSQL,
                             int[] _pParamerters)
                      throws WCMException
参数：
_pUpdateSQL -
_pParamerters -
抛出：
WCMException

sqlExecuteUpdate

public void sqlExecuteUpdate(java.lang.String[] _pUpdateSQL,
                             java.lang.Object[] _pParamerters)
                      throws WCMException
抛出：
WCMException

setParameters

public static void setParameters(java.sql.PreparedStatement _oPreStmt,
                                 java.util.List listSearchValues)
                          throws WCMException
抛出：
WCMException

sqlExecuteIntQuery

public int sqlExecuteIntQuery(java.lang.String _sQuerySQL,
                              int[] _pParamerters)
                       throws WCMException
参数：
_sQuerySQL -
_pParamerters -
返回：
抛出：
WCMException

sqlExecuteStringQuery

public java.lang.String sqlExecuteStringQuery(java.lang.String _sQuerySQL,
                                              int[] _pParamerters)
                                       throws WCMException
抛出：
WCMException

setParameters

public static void setParameters(java.sql.PreparedStatement _oPreStmt,
                                 WCMFilter filter)
                          throws WCMException
抛出：
WCMException

reloadTableInfo

public void reloadTableInfo(java.lang.String _sTableName)
                     throws WCMException
重新装载指定的表信息

参数：
_sTableName -
抛出：
WCMException

reloadTableInfo

public void reloadTableInfo(java.lang.String _sTableName,
                            boolean _bSendMsgOfCluster)
                     throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LicenseMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.db
类 LicenseMgr

java.lang.Object
    继承者  com.trs.infra.persistent.db.LicenseMgr

public class LicenseMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LicenseMgr()
方法摘要
static LicenseMgr getInstance()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LicenseMgr

public LicenseMgr()
方法详细信息

getInstance

public static LicenseMgr getInstance()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MyDate

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.db
类 MyDate

java.lang.Object
    继承者  com.trs.infra.persistent.db.MyDate
所有已实现的接口：
License
public class MyDate
extends java.lang.Object
implements License

Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MyDate()
方法摘要
int | getMaxSiteNum() 获取最大站点数
int | getMaxUserNum() 获取最大用户数
int | getPluginCode() 获取选件的注册码
java.lang.String | validate() 校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MyDate

public MyDate()
方法详细信息

getMaxSiteNum

public int getMaxSiteNum()
从接口 License 复制的描述
获取最大站点数

指定者：
接口 License 中的 getMaxSiteNum
返回：

getMaxUserNum

public int getMaxUserNum()
从接口 License 复制的描述
获取最大用户数

指定者：
接口 License 中的 getMaxUserNum
返回：

getPluginCode

public int getPluginCode()
从接口 License 复制的描述
获取选件的注册码

指定者：
接口 License 中的 getPluginCode
返回：

validate

public java.lang.String validate()
从接口 License 复制的描述
校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息

指定者：
接口 License 中的 validate
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.persistent.db
类
ConnectPasswordEncrypter
DBConnectionConfig
DBConnectionConfigs
DBConnectionMapper
DBManager
LicenseMgr
MyDate


com.trs.infra.persistent.db

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.persistent.db

类摘要
ConnectPasswordEncrypter | Title: TRS 内容协作平台（TRS WCM） Description: 数据库连接密码加密/解密.
DBConnectionConfig | Title: TRS 内容协作平台（TRS WCM） Description: 数据库连接特性的配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DBConnectionConfigs | Title: TRS 内容协作平台（TRS WCM） Description: 数据库连接配置对象的集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DBConnectionMapper | Title: TRS 内容协作平台（TRS WCM） Description: DBConnectionConfig 的散列查找表 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DBManager | Title: TRS 内容协作平台（TRS WCM） Description: 数据库管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LicenseMgr | Title: TRS 内容协作平台（TRS WCM） Description: License protected validator Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MyDate | Title: TRS 内容协作平台（TRS WCM） Description: 时间处理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.persistent.db 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent.db 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.persistent.db.DBManager
    • com.trs.infra.persistent.db.ConnectPasswordEncrypter
    • com.trs.infra.persistent.db.DBConnectionConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.db.DBConnectionConfigs (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.db.DBConnectionMapper (implements org.aton.container.IClearable)
    • com.trs.infra.persistent.db.LicenseMgr
    • com.trs.infra.persistent.db.MyDate (implements com.trs.license.License)


软件包 com.trs.infra.persistent.db 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent.db
的使用

使用 com.trs.infra.persistent.db 的软件包
com.trs.infra.persistent.db
com.trs.infra.util.database

com.trs.infra.persistent.db 使用的 com.trs.infra.persistent.db 中的类
DBConnectionConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库连接特性的配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DBConnectionMapper
Title: TRS 内容协作平台（TRS WCM）
Description:
DBConnectionConfig 的散列查找表
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DBManager
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LicenseMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.database 使用的 com.trs.infra.persistent.db 中的类
DBConnectionConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库连接特性的配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.db.ConnectPasswordEncrypter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.db.ConnectPasswordEncrypter
的使用

没有 com.trs.infra.persistent.db.ConnectPasswordEncrypter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.db.DBConnectionConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.db.DBConnectionConfig
的使用

使用 DBConnectionConfig 的软件包
com.trs.infra.persistent.db
com.trs.infra.util.database

com.trs.infra.persistent.db 中 DBConnectionConfig 的使用

返回 DBConnectionConfig 的 com.trs.infra.persistent.db 中的方法
DBConnectionConfig | DBConnectionConfigs.get(int _nIndex)
DBConnectionConfig | DBManager.getDBConnConfig() 获取当前所使用的数据库配置
DBConnectionConfig | DBConnectionMapper.getDBConnectionConfigByName(java.lang.String _dbConnName) 依据连接名获取指定的配置信息
DBConnectionConfig | DBConnectionMapper.getDefaultDBConnectionConfig() 获取当前选择的连接的配置信息

参数类型为 DBConnectionConfig 的 com.trs.infra.persistent.db 中的方法
 void DBManager.setDBConfig(DBConnectionConfig config)
设置当前所使用的数据库配置

com.trs.infra.util.database 中 DBConnectionConfig 的使用

参数类型为 DBConnectionConfig 的 com.trs.infra.util.database 中的构造方法
ConnectionPool(DBConnectionConfig config)
构造方法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.db.DBConnectionConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.db.DBConnectionConfigs
的使用

没有 com.trs.infra.persistent.db.DBConnectionConfigs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.db.DBConnectionMapper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.db.DBConnectionMapper
的使用

使用 DBConnectionMapper 的软件包
com.trs.infra.persistent.db

com.trs.infra.persistent.db 中 DBConnectionMapper 的使用

返回 DBConnectionMapper 的 com.trs.infra.persistent.db 中的方法
static DBConnectionMapper DBConnectionMapper.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.db.DBManager 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.db.DBManager
的使用

使用 DBManager 的软件包
com.trs.infra.persistent.db

com.trs.infra.persistent.db 中 DBManager 的使用

返回 DBManager 的 com.trs.infra.persistent.db 中的方法
static DBManager DBManager.getDBManager()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.db.LicenseMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.db.LicenseMgr
的使用

使用 LicenseMgr 的软件包
com.trs.infra.persistent.db

com.trs.infra.persistent.db 中 LicenseMgr 的使用

返回 LicenseMgr 的 com.trs.infra.persistent.db 中的方法
static LicenseMgr LicenseMgr.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.db.MyDate 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.db.MyDate
的使用

没有 com.trs.infra.persistent.db.MyDate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IObjectLCListener

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.listener
接口 IObjectLCListener

所有已知子接口：
IAdministratorCacheMgr, ICachedPOMgr, ICacheMgr, ICacheServer, IChannelNameMgr, IChildrenMgr, IChnlDeptMgr, IClassInfoCacheMgr, IFolderPubStatusCacheMgr, IMetaDataDefCacheMgr, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify, IObjectMemberMgr, ITemplateEmployCacheMgr, IUserCacheMgr
所有已知实现类：
AdjustJsLCListenerWidget, AdministratorCacheMgr, ApdHostLCListener, BaseChannelLCListener4ExtField, BaseChannelLCListener4Region, CachedPOMgr, ChannelDocListenerForPublish, ChannelLCListener4EPress, ChannelLCListenerForChannelSyn, ChannelLCListenerForDocument, ChannelLCListenerForExtField, ChannelLCListenerForFlow, ChannelLCListenerForSpeical, ChannelListenerForPublish, ChannelNameMgr, ChildrenCacheMgr, ChnlDeptMgr, ChnlDocLCListener4ClassInfo, ChnlDocLCListenerForAutoDocBak, ChnlDocLCListenerForFlow, ChnlDocLCListenerForInfoViewDB, ChnlDocLCListenerForPri, ChnlDocLCListenerForRecordNotEntity, ChnlDocLCListenerForSynToMetaData, ChnlDocLCListnerForPublish, ClassInfoCacheMgr, ClassInfoListenerForViewData, ConfigServer, ContentExtFieldCListenerForDocProps, ContentExtFieldLCListenerForDocFields, DocBakLCListenerForApd, DocumentLCLisenterForPhoto, DocumentLCListener4EPress, DocumentLCListenerForAutoDocBak, DocumentLCListenerForDocBak, DocumentLCListenerForDocReply, DocumentLCListenerForExternalFile, DocumentLCListenerForInfoViewDB, DocumentLCListenerForKeyword, DocumentLCListenerForPublish, DocumentLCListenerForRelation, DocumentLCListenerForRelDocs, DocumentLCListenerForSIMSearch, DocumentListenerForMetaViewData, DocumentListenerForPublish, EventLCListenerForRemind, ExtendedFieldLCListenerForDocBak, FileDistributorFtpCacheMgr, FlowCacheMgr, FlowContentLCListener, FlowEmployCacheMgr, FlowEmployerLCListener, FlowEmployLCListenerForChange, FlowNodeLCListenerForForceEnd, FolderPubStatusCacheMgrImpl, GovInfoLCListenerMetaView, GroupAdminsCacheMgr, GroupUserCacheMgr, InfoViewEmployLCListenerForChannel, JobWorkerTypeLCListenerForSchedule, MetaDataDefCacheMgr, MetaDBFieldListenerForChannelSynRule, ObjectLCMonitorServer, ObjectMemberMgr, PathConfigLCListener, PublishContentLCListener, PublishDistributionCacheMgr, PublishDistributionLCListener, PublishFolderLCListener, PublishTaskDispatcherImpl, ReplaceCacheMgr, RightCacheMgr, RightHostLCListenerForInherit, RightLCListenerForSynSiteMember, RoleUserCacheMgr, RuleHostLCListnerForCache, ScheduleLCListenerForFaieldResult, ScheduleLCListenerForServer, SiteMemberLCListner, TagBeanLCListener, TemplateArgumentCacheMgr, TemplateArgumentLCListenerForEmployChanged, TemplateCacheMgr, TemplateEmployCacheMgrImpl, TemplateLCListenerForNestedRename, TemplateLCListenerForTypeChanged, TemplateLCListenerVisualTemplate, TemplateParseMgr, UserCacheMgr, UserLCListenerForLogin, UserListenerForRecordLogin, WCMFolderLCListener, WCMFolderPublishConfigLCListener, WebSiteLCListenerForAutoDocBak, WebSiteLCListenerForContentLink, WebSiteLCListenerForSiteUser
public interface IObjectLCListener

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IObjectLCListenerOnAdd

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.listener
接口 IObjectLCListenerOnAdd

所有超级接口：
IObjectLCListener
所有已知子接口：
IAdministratorCacheMgr, ICachedPOMgr, ICacheMgr, ICacheServer, IChannelNameMgr, IChildrenMgr, IChnlDeptMgr, IClassInfoCacheMgr, IFolderPubStatusCacheMgr, IMetaDataDefCacheMgr, IObjectMemberMgr, ITemplateEmployCacheMgr, IUserCacheMgr
所有已知实现类：
AdministratorCacheMgr, CachedPOMgr, ChannelLCListener4EPress, ChannelNameMgr, ChildrenCacheMgr, ChnlDeptMgr, ChnlDocLCListener4ClassInfo, ChnlDocLCListenerForPri, ChnlDocLCListenerForRecordNotEntity, ChnlDocLCListnerForPublish, ClassInfoCacheMgr, ConfigServer, DocumentLCListenerForInfoViewDB, DocumentLCListenerForRelDocs, DocumentLCListenerForSIMSearch, DocumentListenerForMetaViewData, ExtendedFieldLCListenerForDocBak, FileDistributorFtpCacheMgr, FlowCacheMgr, FlowEmployCacheMgr, FolderPubStatusCacheMgrImpl, GovInfoLCListenerMetaView, GroupAdminsCacheMgr, GroupUserCacheMgr, InfoViewEmployLCListenerForChannel, MetaDataDefCacheMgr, ObjectLCMonitorServer, ObjectMemberMgr, PathConfigLCListener, PublishDistributionCacheMgr, PublishDistributionLCListener, PublishTaskDispatcherImpl, ReplaceCacheMgr, RightCacheMgr, RightHostLCListenerForInherit, RightLCListenerForSynSiteMember, RoleUserCacheMgr, ScheduleLCListenerForServer, TagBeanLCListener, TemplateArgumentCacheMgr, TemplateCacheMgr, TemplateEmployCacheMgrImpl, TemplateLCListenerVisualTemplate, TemplateParseMgr, UserCacheMgr
public interface IObjectLCListenerOnAdd
extends IObjectLCListener

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 void notifyOnAddObj(BaseObj _oObjAdded)
新增一个对象后通知所有的Cache

方法详细信息

notifyOnAddObj

void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
新增一个对象后通知所有的Cache

参数：
_oObjAdded - 新增的对象
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IObjectLCListenerOnDel

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.listener
接口 IObjectLCListenerOnDel

所有超级接口：
IObjectLCListener
所有已知子接口：
IAdministratorCacheMgr, ICachedPOMgr, ICacheMgr, ICacheServer, IChannelNameMgr, IChildrenMgr, IChnlDeptMgr, IClassInfoCacheMgr, IFolderPubStatusCacheMgr, IMetaDataDefCacheMgr, IObjectMemberMgr, ITemplateEmployCacheMgr, IUserCacheMgr
所有已知实现类：
AdjustJsLCListenerWidget, AdministratorCacheMgr, ApdHostLCListener, BaseChannelLCListener4ExtField, BaseChannelLCListener4Region, CachedPOMgr, ChannelLCListener4EPress, ChannelLCListenerForChannelSyn, ChannelLCListenerForDocument, ChannelLCListenerForExtField, ChannelLCListenerForSpeical, ChannelListenerForPublish, ChannelNameMgr, ChildrenCacheMgr, ChnlDeptMgr, ChnlDocLCListener4ClassInfo, ChnlDocLCListenerForPri, ChnlDocLCListenerForRecordNotEntity, ChnlDocLCListnerForPublish, ClassInfoCacheMgr, ClassInfoListenerForViewData, ConfigServer, ContentExtFieldCListenerForDocProps, ContentExtFieldLCListenerForDocFields, DocBakLCListenerForApd, DocumentLCLisenterForPhoto, DocumentLCListener4EPress, DocumentLCListenerForDocBak, DocumentLCListenerForDocReply, DocumentLCListenerForExternalFile, DocumentLCListenerForInfoViewDB, DocumentLCListenerForKeyword, DocumentLCListenerForRelation, DocumentLCListenerForRelDocs, DocumentLCListenerForSIMSearch, DocumentListenerForMetaViewData, DocumentListenerForPublish, EventLCListenerForRemind, ExtendedFieldLCListenerForDocBak, FileDistributorFtpCacheMgr, FlowCacheMgr, FlowContentLCListener, FlowEmployCacheMgr, FlowEmployerLCListener, FlowNodeLCListenerForForceEnd, FolderPubStatusCacheMgrImpl, GovInfoLCListenerMetaView, GroupAdminsCacheMgr, GroupUserCacheMgr, JobWorkerTypeLCListenerForSchedule, MetaDataDefCacheMgr, ObjectLCMonitorServer, ObjectMemberMgr, PathConfigLCListener, PublishContentLCListener, PublishDistributionCacheMgr, PublishFolderLCListener, PublishTaskDispatcherImpl, ReplaceCacheMgr, RightCacheMgr, RightLCListenerForSynSiteMember, RoleUserCacheMgr, RuleHostLCListnerForCache, ScheduleLCListenerForFaieldResult, ScheduleLCListenerForServer, SiteMemberLCListner, TagBeanLCListener, TemplateArgumentCacheMgr, TemplateArgumentLCListenerForEmployChanged, TemplateCacheMgr, TemplateEmployCacheMgrImpl, TemplateLCListenerVisualTemplate, TemplateParseMgr, UserCacheMgr, UserLCListenerForLogin, WCMFolderLCListener, WebSiteLCListenerForAutoDocBak, WebSiteLCListenerForContentLink, WebSiteLCListenerForSiteUser
public interface IObjectLCListenerOnDel
extends IObjectLCListener

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache

方法详细信息

notifyOnDelObj

void notifyOnDelObj(BaseObj _oObjDeleted,
                    int _nEventType)
                    throws WCMException
删除一个对象后通知所有的Cache

参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IObjectLCListenerOnModify

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.listener
接口 IObjectLCListenerOnModify

所有超级接口：
IObjectLCListener
所有已知子接口：
IAdministratorCacheMgr, ICachedPOMgr, ICacheMgr, ICacheServer, IChannelNameMgr, IChildrenMgr, IChnlDeptMgr, IClassInfoCacheMgr, IFolderPubStatusCacheMgr, IMetaDataDefCacheMgr, IObjectMemberMgr, ITemplateEmployCacheMgr, IUserCacheMgr
所有已知实现类：
AdjustJsLCListenerWidget, AdministratorCacheMgr, ApdHostLCListener, CachedPOMgr, ChannelDocListenerForPublish, ChannelLCListenerForDocument, ChannelLCListenerForFlow, ChannelListenerForPublish, ChannelNameMgr, ChildrenCacheMgr, ChnlDeptMgr, ChnlDocLCListenerForAutoDocBak, ChnlDocLCListenerForFlow, ChnlDocLCListenerForInfoViewDB, ChnlDocLCListenerForPri, ChnlDocLCListenerForSynToMetaData, ChnlDocLCListnerForPublish, ClassInfoCacheMgr, ConfigServer, DocumentLCListener4EPress, DocumentLCListenerForAutoDocBak, DocumentLCListenerForExternalFile, DocumentLCListenerForInfoViewDB, DocumentLCListenerForKeyword, DocumentLCListenerForPublish, DocumentLCListenerForRelDocs, DocumentLCListenerForSIMSearch, DocumentListenerForMetaViewData, DocumentListenerForPublish, EventLCListenerForRemind, ExtendedFieldLCListenerForDocBak, FileDistributorFtpCacheMgr, FlowCacheMgr, FlowEmployCacheMgr, FlowEmployLCListenerForChange, FolderPubStatusCacheMgrImpl, GovInfoLCListenerMetaView, GroupAdminsCacheMgr, GroupUserCacheMgr, MetaDataDefCacheMgr, MetaDBFieldListenerForChannelSynRule, ObjectLCMonitorServer, ObjectMemberMgr, PathConfigLCListener, PublishDistributionCacheMgr, PublishDistributionLCListener, ReplaceCacheMgr, RightCacheMgr, RightLCListenerForSynSiteMember, RoleUserCacheMgr, ScheduleLCListenerForServer, TagBeanLCListener, TemplateArgumentCacheMgr, TemplateArgumentLCListenerForEmployChanged, TemplateCacheMgr, TemplateEmployCacheMgrImpl, TemplateLCListenerForNestedRename, TemplateLCListenerForTypeChanged, TemplateLCListenerVisualTemplate, TemplateParseMgr, UserCacheMgr, UserLCListenerForLogin, UserListenerForRecordLogin, WCMFolderLCListener, WCMFolderPublishConfigLCListener
public interface IObjectLCListenerOnModify
extends IObjectLCListener

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache

方法详细信息

notifyOnModifyObj

void notifyOnModifyObj(BaseObj _oObjModified,
                       int _nEventType)
                       throws WCMException
修改一个对象后通知所有的Cache

参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MonitorHostConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.listener
类 MonitorHostConfig

java.lang.Object
    继承者  com.trs.infra.persistent.listener.MonitorHostConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class MonitorHostConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MonitorHostConfig()
方法摘要
java.lang.String | getClassName()
java.util.ArrayList | getListeners()
java.lang.String | getName() 获取配置对象的名称
void | setClassName(java.lang.String className)
void | setListeners(java.util.ArrayList listeners)
void | setName(java.lang.String _sName) 设置配置对象的名称
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MonitorHostConfig

public MonitorHostConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getListeners

public java.util.ArrayList getListeners()

setListeners

public void setListeners(java.util.ArrayList listeners)

getClassName

public java.lang.String getClassName()

setClassName

public void setClassName(java.lang.String className)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectLCListenerConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.listener
类 ObjectLCListenerConfig

java.lang.Object
    继承者  com.trs.infra.persistent.listener.ObjectLCListenerConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class ObjectLCListenerConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ObjectLCListenerConfig()
方法摘要
IObjectLCListener | getBean()
java.lang.String | getBeanId()
java.lang.String | getEventType()
java.lang.String | getName() 获取配置对象的名称
void | setBeanId(java.lang.String beanId)
void | setEventType(java.lang.String eventType)
void | setName(java.lang.String _sName) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectLCListenerConfig

public ObjectLCListenerConfig()
方法详细信息

getBeanId

public java.lang.String getBeanId()

setBeanId

public void setBeanId(java.lang.String beanId)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getEventType

public java.lang.String getEventType()

setEventType

public void setEventType(java.lang.String eventType)

getBean

public IObjectLCListener getBean()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectLCMonitorServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.listener
类 ObjectLCMonitorServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.persistent.listener.ObjectLCMonitorServer
所有已实现的接口：
IServer, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ObjectLCMonitorServer
extends BaseServer
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | EVENT_TYPE_ADD
static int | EVENT_TYPE_DELETE_AFTER
static int | EVENT_TYPE_DELETE_BEFORE
static int | EVENT_TYPE_EDIT_AFTER
static int | EVENT_TYPE_EDIT_BEFORE
static int[] | EVENT_TYPES
static int[] | EVENT_TYPES_DEFAULT
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
ObjectLCMonitorServer()
方法摘要
IObjectLCListener[] | getListeners(int _nEventType, BaseObj _currObj)
IObjectLCListener[] | getListeners(int _nEventType, java.lang.Class _objClass)
java.util.Map | getListenersMap()
static ObjectLCMonitorServer | getMonitorServer()
boolean | isDoNotify(int _nEventType, BaseObj _currObj)
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

EVENT_TYPE_ADD

public static final int EVENT_TYPE_ADD
另请参见：
常量字段值

EVENT_TYPE_EDIT_AFTER

public static final int EVENT_TYPE_EDIT_AFTER
另请参见：
常量字段值

EVENT_TYPE_DELETE_BEFORE

public static final int EVENT_TYPE_DELETE_BEFORE
另请参见：
常量字段值

EVENT_TYPE_DELETE_AFTER

public static final int EVENT_TYPE_DELETE_AFTER
另请参见：
常量字段值

EVENT_TYPE_EDIT_BEFORE

public static final int EVENT_TYPE_EDIT_BEFORE
另请参见：
常量字段值

EVENT_TYPES

public static final int[] EVENT_TYPES

EVENT_TYPES_DEFAULT

public static final int[] EVENT_TYPES_DEFAULT
构造方法详细信息

ObjectLCMonitorServer

public ObjectLCMonitorServer()
方法详细信息

getMonitorServer

public static ObjectLCMonitorServer getMonitorServer()

getListeners

public IObjectLCListener[] getListeners(int _nEventType,
                                        BaseObj _currObj)

getListeners

public IObjectLCListener[] getListeners(int _nEventType,
                                        java.lang.Class _objClass)

isDoNotify

public boolean isDoNotify(int _nEventType,
                          BaseObj _currObj)
参数：
_nEventType -
_currObj -
返回：
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException

getListenersMap

public java.util.Map getListenersMap()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectMonitored

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.listener
类 ObjectMonitored

java.lang.Object
    继承者  com.trs.infra.persistent.listener.ObjectMonitored

public class ObjectMonitored
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ObjectMonitored()
ObjectMonitored(java.lang.String _sName, java.lang.String _sClassName)
方法摘要
java.lang.String | getClassNsme()
java.lang.String | getName()
void | setClassNsme(java.lang.String classNsme)
void | setName(java.lang.String name)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ObjectMonitored

public ObjectMonitored()

ObjectMonitored

public ObjectMonitored(java.lang.String _sName,
                       java.lang.String _sClassName)
方法详细信息

getClassNsme

public java.lang.String getClassNsme()
返回：

setClassNsme

public void setClassNsme(java.lang.String classNsme)
参数：
classNsme -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.persistent.listener
接口
IObjectLCListener
IObjectLCListenerOnAdd
IObjectLCListenerOnDel
IObjectLCListenerOnModify
类
MonitorHostConfig
ObjectLCListenerConfig
ObjectLCMonitorServer
ObjectMonitored


com.trs.infra.persistent.listener

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.persistent.listener

接口摘要
IObjectLCListener | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
MonitorHostConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectLCListenerConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectLCMonitorServer | Title: TRS 内容协作平台（TRS WCM） Description: 生命周期管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectMonitored | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.persistent.listener 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent.listener 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.persistent.listener.ObjectLCMonitorServer (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.infra.persistent.listener.MonitorHostConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.listener.ObjectLCListenerConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.persistent.listener.ObjectMonitored

接口分层结构

  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify


软件包 com.trs.infra.persistent.listener 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent.listener
的使用

使用 com.trs.infra.persistent.listener 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.components.ckm
com.trs.components.common.calendar
com.trs.components.common.job
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.element
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.widget
com.trs.components.govinfo
com.trs.components.infoview.db
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.epress
com.trs.components.wcm.process
com.trs.components.wcm.publish
com.trs.components.wcm.publish.region
com.trs.infra.persistent.cache
com.trs.infra.persistent.listener
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.support.file
com.trs.km.auth
com.trs.presentation.login
com.trs.wcm.photo

com.trs.cms.auth.domain 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.calendar 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.element 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.tagparser 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.taskdispatch 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.template 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.govinfo 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.db 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.center 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.process 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectLCMonitorServer
Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.file 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.km.auth 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.login 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo 使用的 com.trs.infra.persistent.listener 中的类
IObjectLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.persistent.listener.IObjectLCListener 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.persistent.listener.IObjectLCListener
的使用

使用 IObjectLCListener 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.components.ckm
com.trs.components.common.calendar
com.trs.components.common.job
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.element
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.widget
com.trs.components.govinfo
com.trs.components.infoview.db
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.epress
com.trs.components.wcm.process
com.trs.components.wcm.publish
com.trs.components.wcm.publish.region
com.trs.infra.persistent.cache
com.trs.infra.persistent.listener
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.support.file
com.trs.km.auth
com.trs.presentation.login
com.trs.wcm.photo

com.trs.cms.auth.domain 中 IObjectLCListener 的使用

com.trs.cms.auth.domain 中 IObjectLCListener 的子接口
 interface IObjectMemberMgr

实现 IObjectLCListener 的 com.trs.cms.auth.domain 中的类
class | ObjectMemberMgr 可见可操作对象的缓冲管理.
class | RightCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RightHostLCListenerForInherit Title: TRS 内容协作平台（TRS WCM） Description: 权限对象新增创建监听器，为了继承父对象的权限权限 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 中 IObjectLCListener 的使用

com.trs.cms.auth.persistent 中 IObjectLCListener 的子接口
interface | IAdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: IAdministratorCacheMgr,接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户缓冲管理接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListener 的 com.trs.cms.auth.persistent 中的类
class | AdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 管理员角色用户缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户组织管理员缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | RoleUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | UserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户名缓冲器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.cms.process.definition 中的类
class | FlowCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 工作流缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Template Employ缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployerLCListener Title: TRS 内容协作平台（TRS WCM） Description: Flow Employer监听器,只监听删除前 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RuleHostLCListnerForCache Title: TRS 内容协作平台（TRS WCM） Description: 工作流规则所属对象监听器，为了删除对象时候同步规则缓冲 由于修改和新增的时候规则可能还没有建立起来，所以需要在创建的逻辑中使用硬代码 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.cms.process.engine 中的类
class | FlowContentLCListener Title: TRS 内容协作平台（TRS WCM） Description: Flow Content生命周期监听器,只监听删除前 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowNodeLCListenerForForceEnd 监听工作流节点的删除

com.trs.components.ckm 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.ckm 中的类
 class DocumentLCListenerForSIMSearch
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.calendar 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.common.calendar 中的类
 class EventLCListenerForRemind
Title: TRS 内容协作平台（TRS WCM）
Description:
日程提醒消息的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.common.job 中的类
class | JobWorkerTypeLCListenerForSchedule Title: TRS 内容协作平台（TRS WCM） Description: 计划同步删除 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ScheduleLCListenerForFaieldResult Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ScheduleLCListenerForServer Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.common.publish.domain.distribute 中的类
class | FileDistributorFtpCacheMgr 已过时。 使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM） Description: ftp cache manager for file distribution. Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishDistributionCacheMgr FolderType,FolderId 到 PublishDistributionList 的缓存，加速给定目录分发点的查找
class | PublishDistributionLCListener Title: TRS 内容协作平台（TRS WCM） Description: 分发的新增/修改监听,需要的话,做一次同步模板附件操作.

com.trs.components.common.publish.domain.element 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.common.publish.domain.element 中的类
class | PublishContentLCListener Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishFolderLCListener Title: TRS 内容协作平台（TRS WCM） Description: 模板需要监控的其他相关对象的操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.tagparser 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.common.publish.domain.tagparser 中的类
 class TagBeanLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
life cycel listener for TagBean.

com.trs.components.common.publish.domain.taskdispatch 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.common.publish.domain.taskdispatch 中的类
 class PublishTaskDispatcherImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
the publish task dispatcher implementation.

com.trs.components.common.publish.domain.template 中 IObjectLCListener 的使用

com.trs.components.common.publish.domain.template 中 IObjectLCListener 的子接口
 interface ITemplateEmployCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListener 的 com.trs.components.common.publish.domain.template 中的类
class | TemplateArgumentCacheMgr 缓存TemplateArguments对象，并监听TemplateArgument的增删改
class | TemplateArgumentLCListenerForEmployChanged 在模板和频道的雇佣关系发生变化时，清除已经设置的模板变量
class | TemplateCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: template cache manaager implementation.
class | TemplateEmployCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: 模板和发布元素的配置缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateLCListenerForNestedRename 如果修改了模板的名称，则要检查模板是否被嵌套，如果模板被嵌套使用，则要同步修改所有的引用。
class | TemplateLCListenerForTypeChanged Title: TRS 内容协作平台（TRS WCM） Description: 监听模板类型的变化,更新模板的使用情况 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateParseMgr Title: TRS 内容协作平台（TRS WCM） Description: template parse manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.common.publish.widget 中的类
class | AdjustJsLCListenerWidget Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | TemplateLCListenerVisualTemplate 当可视化模板进行保存或修改的时候，需要将模板和资源实例建立去关联关系。

com.trs.components.govinfo 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.govinfo 中的类
 class GovInfoLCListenerMetaView
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.infoview.db 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.infoview.db 中的类
class | ChnlDocLCListenerForInfoViewDB
class | DocumentLCListenerForInfoViewDB

com.trs.components.metadata.center 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.metadata.center 中的类
class | ChnlDocLCListenerForSynToMetaData Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentListenerForMetaViewData

com.trs.components.metadata.definition 中 IObjectLCListener 的使用

com.trs.components.metadata.definition 中 IObjectLCListener 的子接口
interface | IClassInfoCacheMgr
interface | IMetaDataDefCacheMgr

实现 IObjectLCListener 的 com.trs.components.metadata.definition 中的类
class | ClassInfoCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ClassInfoListenerForViewData
class | MetaDataDefCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDBFieldListenerForChannelSynRule

com.trs.components.stat 中 IObjectLCListener 的使用

com.trs.components.stat 中 IObjectLCListener 的子接口
 interface IChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

实现 IObjectLCListener 的 com.trs.components.stat 中的类
 class ChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.wcm.content.domain 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.wcm.content.domain 中的类
class | ApdHostLCListener Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseChannelLCListener4ExtField Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | BaseChannelLCListener4Region Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | ChannelLCListenerForChannelSyn Title: TRS 内容协作平台（TRS WCM） Description: 监控频道被删除时，同步删除与该频道相关的频道分发设置 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelLCListenerForDocument Title: TRS 内容协作平台（TRS WCM） Description: 与文档相关的栏目生命周期监听处理.
class | ChannelLCListenerForExtField Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelLCListenerForSpeical Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | ChnlDocLCListener4ClassInfo Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ChnlDocLCListenerForAutoDocBak Title: TRS 内容协作平台（TRS WCM） Description: 监听ChnlDoc状态的修改,在满足一定条件时保存一个文档版本 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChnlDocLCListenerForPri Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc LC Listener For Document Pri Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChnlDocLCListenerForRecordNotEntity
class | ContentExtFieldCListenerForDocProps
class | ContentExtFieldLCListenerForDocFields
class | DocBakLCListenerForApd Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForAutoDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForDocReply Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForExternalFile Title: TRS 内容协作平台（TRS WCM） Description: 外部文档的文件处理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForKeyword
class | DocumentLCListenerForRelation Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForRelDocs
class | ExtendedFieldLCListenerForDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoViewEmployLCListenerForChannel
class | RightLCListenerForSynSiteMember Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | SiteMemberLCListner Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteLCListenerForAutoDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteLCListenerForContentLink Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteLCListenerForSiteUser Title: TRS 内容协作平台（TRS WCM） Description: 站点用户/用户组监听 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 中 IObjectLCListener 的使用

com.trs.components.wcm.content.persistent 中 IObjectLCListener 的子接口
interface | IChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IChildrenMgr Title: TRS 内容协作平台（TRS WCM） Description: 子频道获取管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListener 的 com.trs.components.wcm.content.persistent 中的类
class | ChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理(LRU缓冲算法) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChildrenCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 替换内容的缓冲 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.wcm.epress 中的类
class | ChannelLCListener4EPress Title: TRS 内容协作平台（TRS WCM） Description: 栏目删除监听 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DocumentLCListener4EPress Title: TRS 内容协作平台（TRS WCM） Description: 修改重发相应的历史索引 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.process 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.wcm.process 中的类
class | ChannelLCListenerForFlow 在频道假删除（频道即如回收站）时，删除所有正在流转和已经流转结束的文档
class | ChnlDocLCListenerForFlow Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployLCListenerForChange 监听频道工作流设置的改变

com.trs.components.wcm.publish 中 IObjectLCListener 的使用

com.trs.components.wcm.publish 中 IObjectLCListener 的子接口
 interface IFolderPubStatusCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListener 的 com.trs.components.wcm.publish 中的类
class | ChnlDocLCListnerForPublish Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc发布内容同步删除监控器，监控ChnlDoc修改前、修改后和删除后 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForPublish Title: TRS 内容协作平台（TRS WCM） Description: 为发布的相关同步监听文档的修改 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FolderPubStatusCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMFolderLCListener Title: TRS 内容协作平台（TRS WCM） Description: 站点或频道的删除同步撤除发布目录监听器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMFolderPublishConfigLCListener Title: TRS 内容协作平台（TRS WCM） Description: Folder发布的监听 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.components.wcm.publish.region 中的类
class | ChannelDocListenerForPublish
class | ChannelListenerForPublish
class | DocumentListenerForPublish

com.trs.infra.persistent.cache 中 IObjectLCListener 的使用

com.trs.infra.persistent.cache 中 IObjectLCListener 的子接口
 interface ICachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListener 的 com.trs.infra.persistent.cache 中的类
 class CachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
被缓冲的持久化对象的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 中 IObjectLCListener 的使用

com.trs.infra.persistent.listener 中 IObjectLCListener 的子接口
interface | IObjectLCListenerOnAdd Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IObjectLCListenerOnDel Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IObjectLCListenerOnModify Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListener 的 com.trs.infra.persistent.listener 中的类
 class ObjectLCMonitorServer
Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

返回 IObjectLCListener 的 com.trs.infra.persistent.listener 中的方法
IObjectLCListener | ObjectLCListenerConfig.getBean()
IObjectLCListener[] | ObjectLCMonitorServer.getListeners(int _nEventType, BaseObj _currObj)
IObjectLCListener[] | ObjectLCMonitorServer.getListeners(int _nEventType, java.lang.Class _objClass)

com.trs.infra.support.cache 中 IObjectLCListener 的使用

com.trs.infra.support.cache 中 IObjectLCListener 的子接口
interface | ICacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Cache管理者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | ICacheServer Title: TRS 内容协作平台（TRS WCM） Description: Cache调度者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.infra.support.config 中的类
 class ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.infra.support.file 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.infra.support.file 中的类
 class PathConfigLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
目录配置更新的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.km.auth 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.km.auth 中的类
 class UserListenerForRecordLogin

com.trs.presentation.login 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.presentation.login 中的类
 class UserLCListenerForLogin
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo 中 IObjectLCListener 的使用

实现 IObjectLCListener 的 com.trs.wcm.photo 中的类
 class DocumentLCLisenterForPhoto
Title: TRS 内容协作平台（TRS WCM）
Description:
图片删除监听器
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
的使用

使用 IObjectLCListenerOnAdd 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.components.ckm
com.trs.components.common.job
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.widget
com.trs.components.govinfo
com.trs.components.infoview.db
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.epress
com.trs.components.wcm.publish
com.trs.infra.persistent.cache
com.trs.infra.persistent.listener
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.support.file

com.trs.cms.auth.domain 中 IObjectLCListenerOnAdd 的使用

com.trs.cms.auth.domain 中 IObjectLCListenerOnAdd 的子接口
 interface IObjectMemberMgr

实现 IObjectLCListenerOnAdd 的 com.trs.cms.auth.domain 中的类
class | ObjectMemberMgr 可见可操作对象的缓冲管理.
class | RightCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RightHostLCListenerForInherit Title: TRS 内容协作平台（TRS WCM） Description: 权限对象新增创建监听器，为了继承父对象的权限权限 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 中 IObjectLCListenerOnAdd 的使用

com.trs.cms.auth.persistent 中 IObjectLCListenerOnAdd 的子接口
interface | IAdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: IAdministratorCacheMgr,接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户缓冲管理接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnAdd 的 com.trs.cms.auth.persistent 中的类
class | AdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 管理员角色用户缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户组织管理员缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | RoleUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | UserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户名缓冲器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.cms.process.definition 中的类
class | FlowCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 工作流缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Template Employ缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.ckm 中的类
 class DocumentLCListenerForSIMSearch
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.common.job 中的类
 class ScheduleLCListenerForServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.common.publish.domain.distribute 中的类
class | FileDistributorFtpCacheMgr 已过时。 使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM） Description: ftp cache manager for file distribution. Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishDistributionCacheMgr FolderType,FolderId 到 PublishDistributionList 的缓存，加速给定目录分发点的查找
class | PublishDistributionLCListener Title: TRS 内容协作平台（TRS WCM） Description: 分发的新增/修改监听,需要的话,做一次同步模板附件操作.

com.trs.components.common.publish.domain.tagparser 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.common.publish.domain.tagparser 中的类
 class TagBeanLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
life cycel listener for TagBean.

com.trs.components.common.publish.domain.taskdispatch 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.common.publish.domain.taskdispatch 中的类
 class PublishTaskDispatcherImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
the publish task dispatcher implementation.

com.trs.components.common.publish.domain.template 中 IObjectLCListenerOnAdd 的使用

com.trs.components.common.publish.domain.template 中 IObjectLCListenerOnAdd 的子接口
 interface ITemplateEmployCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnAdd 的 com.trs.components.common.publish.domain.template 中的类
class | TemplateArgumentCacheMgr 缓存TemplateArguments对象，并监听TemplateArgument的增删改
class | TemplateCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: template cache manaager implementation.
class | TemplateEmployCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: 模板和发布元素的配置缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateParseMgr Title: TRS 内容协作平台（TRS WCM） Description: template parse manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.common.publish.widget 中的类
 class TemplateLCListenerVisualTemplate
当可视化模板进行保存或修改的时候，需要将模板和资源实例建立去关联关系。

com.trs.components.govinfo 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.govinfo 中的类
 class GovInfoLCListenerMetaView
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.infoview.db 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.infoview.db 中的类
 class DocumentLCListenerForInfoViewDB

com.trs.components.metadata.center 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.metadata.center 中的类
 class DocumentListenerForMetaViewData

com.trs.components.metadata.definition 中 IObjectLCListenerOnAdd 的使用

com.trs.components.metadata.definition 中 IObjectLCListenerOnAdd 的子接口
interface | IClassInfoCacheMgr
interface | IMetaDataDefCacheMgr

实现 IObjectLCListenerOnAdd 的 com.trs.components.metadata.definition 中的类
class | ClassInfoCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataDefCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 中 IObjectLCListenerOnAdd 的使用

com.trs.components.stat 中 IObjectLCListenerOnAdd 的子接口
 interface IChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

实现 IObjectLCListenerOnAdd 的 com.trs.components.stat 中的类
 class ChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.wcm.content.domain 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.wcm.content.domain 中的类
class | ChnlDocLCListener4ClassInfo Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ChnlDocLCListenerForPri Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc LC Listener For Document Pri Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChnlDocLCListenerForRecordNotEntity
class | DocumentLCListenerForRelDocs
class | ExtendedFieldLCListenerForDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoViewEmployLCListenerForChannel
class | RightLCListenerForSynSiteMember Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 中 IObjectLCListenerOnAdd 的使用

com.trs.components.wcm.content.persistent 中 IObjectLCListenerOnAdd 的子接口
interface | IChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IChildrenMgr Title: TRS 内容协作平台（TRS WCM） Description: 子频道获取管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnAdd 的 com.trs.components.wcm.content.persistent 中的类
class | ChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理(LRU缓冲算法) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChildrenCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 替换内容的缓冲 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.components.wcm.epress 中的类
 class ChannelLCListener4EPress
Title: TRS 内容协作平台（TRS WCM）
Description:
栏目删除监听
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 中 IObjectLCListenerOnAdd 的使用

com.trs.components.wcm.publish 中 IObjectLCListenerOnAdd 的子接口
 interface IFolderPubStatusCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnAdd 的 com.trs.components.wcm.publish 中的类
class | ChnlDocLCListnerForPublish Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc发布内容同步删除监控器，监控ChnlDoc修改前、修改后和删除后 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FolderPubStatusCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 中 IObjectLCListenerOnAdd 的使用

com.trs.infra.persistent.cache 中 IObjectLCListenerOnAdd 的子接口
 interface ICachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnAdd 的 com.trs.infra.persistent.cache 中的类
 class CachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
被缓冲的持久化对象的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.infra.persistent.listener 中的类
 class ObjectLCMonitorServer
Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 中 IObjectLCListenerOnAdd 的使用

com.trs.infra.support.cache 中 IObjectLCListenerOnAdd 的子接口
interface | ICacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Cache管理者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | ICacheServer Title: TRS 内容协作平台（TRS WCM） Description: Cache调度者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.infra.support.config 中的类
 class ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.infra.support.file 中 IObjectLCListenerOnAdd 的使用

实现 IObjectLCListenerOnAdd 的 com.trs.infra.support.file 中的类
 class PathConfigLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
目录配置更新的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel
的使用

使用 IObjectLCListenerOnDel 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.components.ckm
com.trs.components.common.calendar
com.trs.components.common.job
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.element
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.taskdispatch
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.widget
com.trs.components.govinfo
com.trs.components.infoview.db
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.epress
com.trs.components.wcm.publish
com.trs.components.wcm.publish.region
com.trs.infra.persistent.cache
com.trs.infra.persistent.listener
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.support.file
com.trs.presentation.login
com.trs.wcm.photo

com.trs.cms.auth.domain 中 IObjectLCListenerOnDel 的使用

com.trs.cms.auth.domain 中 IObjectLCListenerOnDel 的子接口
 interface IObjectMemberMgr

实现 IObjectLCListenerOnDel 的 com.trs.cms.auth.domain 中的类
class | ObjectMemberMgr 可见可操作对象的缓冲管理.
class | RightCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 中 IObjectLCListenerOnDel 的使用

com.trs.cms.auth.persistent 中 IObjectLCListenerOnDel 的子接口
interface | IAdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: IAdministratorCacheMgr,接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户缓冲管理接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnDel 的 com.trs.cms.auth.persistent 中的类
class | AdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 管理员角色用户缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户组织管理员缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | RoleUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | UserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户名缓冲器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.cms.process.definition 中的类
class | FlowCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 工作流缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Template Employ缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployerLCListener Title: TRS 内容协作平台（TRS WCM） Description: Flow Employer监听器,只监听删除前 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RuleHostLCListnerForCache Title: TRS 内容协作平台（TRS WCM） Description: 工作流规则所属对象监听器，为了删除对象时候同步规则缓冲 由于修改和新增的时候规则可能还没有建立起来，所以需要在创建的逻辑中使用硬代码 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.cms.process.engine 中的类
class | FlowContentLCListener Title: TRS 内容协作平台（TRS WCM） Description: Flow Content生命周期监听器,只监听删除前 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowNodeLCListenerForForceEnd 监听工作流节点的删除

com.trs.components.ckm 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.ckm 中的类
 class DocumentLCListenerForSIMSearch
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.calendar 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.common.calendar 中的类
 class EventLCListenerForRemind
Title: TRS 内容协作平台（TRS WCM）
Description:
日程提醒消息的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.common.job 中的类
class | JobWorkerTypeLCListenerForSchedule Title: TRS 内容协作平台（TRS WCM） Description: 计划同步删除 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ScheduleLCListenerForFaieldResult Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ScheduleLCListenerForServer Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.common.publish.domain.distribute 中的类
class | FileDistributorFtpCacheMgr 已过时。 使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM） Description: ftp cache manager for file distribution. Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishDistributionCacheMgr FolderType,FolderId 到 PublishDistributionList 的缓存，加速给定目录分发点的查找

com.trs.components.common.publish.domain.element 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.common.publish.domain.element 中的类
class | PublishContentLCListener Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishFolderLCListener Title: TRS 内容协作平台（TRS WCM） Description: 模板需要监控的其他相关对象的操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.tagparser 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.common.publish.domain.tagparser 中的类
 class TagBeanLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
life cycel listener for TagBean.

com.trs.components.common.publish.domain.taskdispatch 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.common.publish.domain.taskdispatch 中的类
 class PublishTaskDispatcherImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
the publish task dispatcher implementation.

com.trs.components.common.publish.domain.template 中 IObjectLCListenerOnDel 的使用

com.trs.components.common.publish.domain.template 中 IObjectLCListenerOnDel 的子接口
 interface ITemplateEmployCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnDel 的 com.trs.components.common.publish.domain.template 中的类
class | TemplateArgumentCacheMgr 缓存TemplateArguments对象，并监听TemplateArgument的增删改
class | TemplateArgumentLCListenerForEmployChanged 在模板和频道的雇佣关系发生变化时，清除已经设置的模板变量
class | TemplateCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: template cache manaager implementation.
class | TemplateEmployCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: 模板和发布元素的配置缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateParseMgr Title: TRS 内容协作平台（TRS WCM） Description: template parse manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.common.publish.widget 中的类
class | AdjustJsLCListenerWidget Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | TemplateLCListenerVisualTemplate 当可视化模板进行保存或修改的时候，需要将模板和资源实例建立去关联关系。

com.trs.components.govinfo 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.govinfo 中的类
 class GovInfoLCListenerMetaView
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.infoview.db 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.infoview.db 中的类
 class DocumentLCListenerForInfoViewDB

com.trs.components.metadata.center 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.metadata.center 中的类
 class DocumentListenerForMetaViewData

com.trs.components.metadata.definition 中 IObjectLCListenerOnDel 的使用

com.trs.components.metadata.definition 中 IObjectLCListenerOnDel 的子接口
interface | IClassInfoCacheMgr
interface | IMetaDataDefCacheMgr

实现 IObjectLCListenerOnDel 的 com.trs.components.metadata.definition 中的类
class | ClassInfoCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ClassInfoListenerForViewData
class | MetaDataDefCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 中 IObjectLCListenerOnDel 的使用

com.trs.components.stat 中 IObjectLCListenerOnDel 的子接口
 interface IChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

实现 IObjectLCListenerOnDel 的 com.trs.components.stat 中的类
 class ChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.wcm.content.domain 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.wcm.content.domain 中的类
class | ApdHostLCListener Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseChannelLCListener4ExtField Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | BaseChannelLCListener4Region Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | ChannelLCListenerForChannelSyn Title: TRS 内容协作平台（TRS WCM） Description: 监控频道被删除时，同步删除与该频道相关的频道分发设置 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelLCListenerForDocument Title: TRS 内容协作平台（TRS WCM） Description: 与文档相关的栏目生命周期监听处理.
class | ChannelLCListenerForExtField Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelLCListenerForSpeical Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | ChnlDocLCListener4ClassInfo Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ChnlDocLCListenerForPri Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc LC Listener For Document Pri Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChnlDocLCListenerForRecordNotEntity
class | ContentExtFieldCListenerForDocProps
class | ContentExtFieldLCListenerForDocFields
class | DocBakLCListenerForApd Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForDocReply Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForExternalFile Title: TRS 内容协作平台（TRS WCM） Description: 外部文档的文件处理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForKeyword
class | DocumentLCListenerForRelation Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForRelDocs
class | ExtendedFieldLCListenerForDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RightLCListenerForSynSiteMember Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | SiteMemberLCListner Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteLCListenerForAutoDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteLCListenerForContentLink Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteLCListenerForSiteUser Title: TRS 内容协作平台（TRS WCM） Description: 站点用户/用户组监听 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 中 IObjectLCListenerOnDel 的使用

com.trs.components.wcm.content.persistent 中 IObjectLCListenerOnDel 的子接口
interface | IChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IChildrenMgr Title: TRS 内容协作平台（TRS WCM） Description: 子频道获取管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnDel 的 com.trs.components.wcm.content.persistent 中的类
class | ChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理(LRU缓冲算法) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChildrenCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 替换内容的缓冲 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.wcm.epress 中的类
class | ChannelLCListener4EPress Title: TRS 内容协作平台（TRS WCM） Description: 栏目删除监听 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DocumentLCListener4EPress Title: TRS 内容协作平台（TRS WCM） Description: 修改重发相应的历史索引 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 中 IObjectLCListenerOnDel 的使用

com.trs.components.wcm.publish 中 IObjectLCListenerOnDel 的子接口
 interface IFolderPubStatusCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnDel 的 com.trs.components.wcm.publish 中的类
class | ChnlDocLCListnerForPublish Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc发布内容同步删除监控器，监控ChnlDoc修改前、修改后和删除后 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FolderPubStatusCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMFolderLCListener Title: TRS 内容协作平台（TRS WCM） Description: 站点或频道的删除同步撤除发布目录监听器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.components.wcm.publish.region 中的类
class | ChannelListenerForPublish
class | DocumentListenerForPublish

com.trs.infra.persistent.cache 中 IObjectLCListenerOnDel 的使用

com.trs.infra.persistent.cache 中 IObjectLCListenerOnDel 的子接口
 interface ICachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnDel 的 com.trs.infra.persistent.cache 中的类
 class CachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
被缓冲的持久化对象的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.infra.persistent.listener 中的类
 class ObjectLCMonitorServer
Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 中 IObjectLCListenerOnDel 的使用

com.trs.infra.support.cache 中 IObjectLCListenerOnDel 的子接口
interface | ICacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Cache管理者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | ICacheServer Title: TRS 内容协作平台（TRS WCM） Description: Cache调度者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.infra.support.config 中的类
 class ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.infra.support.file 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.infra.support.file 中的类
 class PathConfigLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
目录配置更新的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.login 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.presentation.login 中的类
 class UserLCListenerForLogin
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.wcm.photo 中 IObjectLCListenerOnDel 的使用

实现 IObjectLCListenerOnDel 的 com.trs.wcm.photo 中的类
 class DocumentLCLisenterForPhoto
Title: TRS 内容协作平台（TRS WCM）
Description:
图片删除监听器
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify
的使用

使用 IObjectLCListenerOnModify 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.components.ckm
com.trs.components.common.calendar
com.trs.components.common.job
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.tagparser
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.widget
com.trs.components.govinfo
com.trs.components.infoview.db
com.trs.components.metadata.center
com.trs.components.metadata.definition
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.epress
com.trs.components.wcm.process
com.trs.components.wcm.publish
com.trs.components.wcm.publish.region
com.trs.infra.persistent.cache
com.trs.infra.persistent.listener
com.trs.infra.support.cache
com.trs.infra.support.config
com.trs.infra.support.file
com.trs.km.auth
com.trs.presentation.login

com.trs.cms.auth.domain 中 IObjectLCListenerOnModify 的使用

com.trs.cms.auth.domain 中 IObjectLCListenerOnModify 的子接口
 interface IObjectMemberMgr

实现 IObjectLCListenerOnModify 的 com.trs.cms.auth.domain 中的类
class | ObjectMemberMgr 可见可操作对象的缓冲管理.
class | RightCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 中 IObjectLCListenerOnModify 的使用

com.trs.cms.auth.persistent 中 IObjectLCListenerOnModify 的子接口
interface | IAdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: IAdministratorCacheMgr,接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户缓冲管理接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnModify 的 com.trs.cms.auth.persistent 中的类
class | AdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 管理员角色用户缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户组织管理员缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | RoleUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | UserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户名缓冲器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.cms.process.definition 中的类
class | FlowCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 工作流缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Template Employ缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.ckm 中的类
 class DocumentLCListenerForSIMSearch
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.calendar 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.common.calendar 中的类
 class EventLCListenerForRemind
Title: TRS 内容协作平台（TRS WCM）
Description:
日程提醒消息的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.common.job 中的类
 class ScheduleLCListenerForServer
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.common.publish.domain.distribute 中的类
class | FileDistributorFtpCacheMgr 已过时。 使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM） Description: ftp cache manager for file distribution. Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishDistributionCacheMgr FolderType,FolderId 到 PublishDistributionList 的缓存，加速给定目录分发点的查找
class | PublishDistributionLCListener Title: TRS 内容协作平台（TRS WCM） Description: 分发的新增/修改监听,需要的话,做一次同步模板附件操作.

com.trs.components.common.publish.domain.tagparser 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.common.publish.domain.tagparser 中的类
 class TagBeanLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
life cycel listener for TagBean.

com.trs.components.common.publish.domain.template 中 IObjectLCListenerOnModify 的使用

com.trs.components.common.publish.domain.template 中 IObjectLCListenerOnModify 的子接口
 interface ITemplateEmployCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnModify 的 com.trs.components.common.publish.domain.template 中的类
class | TemplateArgumentCacheMgr 缓存TemplateArguments对象，并监听TemplateArgument的增删改
class | TemplateArgumentLCListenerForEmployChanged 在模板和频道的雇佣关系发生变化时，清除已经设置的模板变量
class | TemplateCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: template cache manaager implementation.
class | TemplateEmployCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: 模板和发布元素的配置缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateLCListenerForNestedRename 如果修改了模板的名称，则要检查模板是否被嵌套，如果模板被嵌套使用，则要同步修改所有的引用。
class | TemplateLCListenerForTypeChanged Title: TRS 内容协作平台（TRS WCM） Description: 监听模板类型的变化,更新模板的使用情况 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateParseMgr Title: TRS 内容协作平台（TRS WCM） Description: template parse manager Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.common.publish.widget 中的类
class | AdjustJsLCListenerWidget Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | TemplateLCListenerVisualTemplate 当可视化模板进行保存或修改的时候，需要将模板和资源实例建立去关联关系。

com.trs.components.govinfo 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.govinfo 中的类
 class GovInfoLCListenerMetaView
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.infoview.db 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.infoview.db 中的类
class | ChnlDocLCListenerForInfoViewDB
class | DocumentLCListenerForInfoViewDB

com.trs.components.metadata.center 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.metadata.center 中的类
class | ChnlDocLCListenerForSynToMetaData Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentListenerForMetaViewData

com.trs.components.metadata.definition 中 IObjectLCListenerOnModify 的使用

com.trs.components.metadata.definition 中 IObjectLCListenerOnModify 的子接口
interface | IClassInfoCacheMgr
interface | IMetaDataDefCacheMgr

实现 IObjectLCListenerOnModify 的 com.trs.components.metadata.definition 中的类
class | ClassInfoCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataDefCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDBFieldListenerForChannelSynRule

com.trs.components.stat 中 IObjectLCListenerOnModify 的使用

com.trs.components.stat 中 IObjectLCListenerOnModify 的子接口
 interface IChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

实现 IObjectLCListenerOnModify 的 com.trs.components.stat 中的类
 class ChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.wcm.content.domain 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.wcm.content.domain 中的类
class | ApdHostLCListener Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelLCListenerForDocument Title: TRS 内容协作平台（TRS WCM） Description: 与文档相关的栏目生命周期监听处理.
class | ChnlDocLCListenerForAutoDocBak Title: TRS 内容协作平台（TRS WCM） Description: 监听ChnlDoc状态的修改,在满足一定条件时保存一个文档版本 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChnlDocLCListenerForPri Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc LC Listener For Document Pri Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForAutoDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForExternalFile Title: TRS 内容协作平台（TRS WCM） Description: 外部文档的文件处理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForKeyword
class | DocumentLCListenerForRelDocs
class | ExtendedFieldLCListenerForDocBak Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RightLCListenerForSynSiteMember Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 中 IObjectLCListenerOnModify 的使用

com.trs.components.wcm.content.persistent 中 IObjectLCListenerOnModify 的子接口
interface | IChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IChildrenMgr Title: TRS 内容协作平台（TRS WCM） Description: 子频道获取管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnModify 的 com.trs.components.wcm.content.persistent 中的类
class | ChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理(LRU缓冲算法) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChildrenCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 替换内容的缓冲 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.wcm.epress 中的类
 class DocumentLCListener4EPress
Title: TRS 内容协作平台（TRS WCM）
Description:
修改重发相应的历史索引
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.process 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.wcm.process 中的类
class | ChannelLCListenerForFlow 在频道假删除（频道即如回收站）时，删除所有正在流转和已经流转结束的文档
class | ChnlDocLCListenerForFlow Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployLCListenerForChange 监听频道工作流设置的改变

com.trs.components.wcm.publish 中 IObjectLCListenerOnModify 的使用

com.trs.components.wcm.publish 中 IObjectLCListenerOnModify 的子接口
 interface IFolderPubStatusCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnModify 的 com.trs.components.wcm.publish 中的类
class | ChnlDocLCListnerForPublish Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc发布内容同步删除监控器，监控ChnlDoc修改前、修改后和删除后 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentLCListenerForPublish Title: TRS 内容协作平台（TRS WCM） Description: 为发布的相关同步监听文档的修改 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FolderPubStatusCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMFolderLCListener Title: TRS 内容协作平台（TRS WCM） Description: 站点或频道的删除同步撤除发布目录监听器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMFolderPublishConfigLCListener Title: TRS 内容协作平台（TRS WCM） Description: Folder发布的监听 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.components.wcm.publish.region 中的类
class | ChannelDocListenerForPublish
class | ChannelListenerForPublish
class | DocumentListenerForPublish

com.trs.infra.persistent.cache 中 IObjectLCListenerOnModify 的使用

com.trs.infra.persistent.cache 中 IObjectLCListenerOnModify 的子接口
 interface ICachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IObjectLCListenerOnModify 的 com.trs.infra.persistent.cache 中的类
 class CachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
被缓冲的持久化对象的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.infra.persistent.listener 中的类
 class ObjectLCMonitorServer
Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 中 IObjectLCListenerOnModify 的使用

com.trs.infra.support.cache 中 IObjectLCListenerOnModify 的子接口
interface | ICacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Cache管理者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | ICacheServer Title: TRS 内容协作平台（TRS WCM） Description: Cache调度者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.infra.support.config 中的类
 class ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.infra.support.file 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.infra.support.file 中的类
 class PathConfigLCListener
Title: TRS 内容协作平台（TRS WCM）
Description:
目录配置更新的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.km.auth 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.km.auth 中的类
 class UserListenerForRecordLogin

com.trs.presentation.login 中 IObjectLCListenerOnModify 的使用

实现 IObjectLCListenerOnModify 的 com.trs.presentation.login 中的类
 class UserLCListenerForLogin
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.listener.MonitorHostConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.listener.MonitorHostConfig
的使用

没有 com.trs.infra.persistent.listener.MonitorHostConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.listener.ObjectLCListenerConfig
的使用

没有 com.trs.infra.persistent.listener.ObjectLCListenerConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.listener.ObjectLCMonitorServer
的使用

使用 ObjectLCMonitorServer 的软件包
com.trs.infra.persistent.listener

com.trs.infra.persistent.listener 中 ObjectLCMonitorServer 的使用

返回 ObjectLCMonitorServer 的 com.trs.infra.persistent.listener 中的方法
static ObjectLCMonitorServer ObjectLCMonitorServer.getMonitorServer()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.persistent.listener.ObjectMonitored 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.listener.ObjectMonitored
的使用

没有 com.trs.infra.persistent.listener.ObjectMonitored 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.infra.persistent.util
类
SynChildrenExecutorBase


com.trs.infra.persistent.util

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.persistent.util

类摘要
SynChildrenExecutorBase Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.persistent.util 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.util.SynChildrenExecutorBase


软件包 com.trs.infra.persistent.util 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.persistent.util
的使用

使用 com.trs.infra.persistent.util 的软件包
com.trs.components.metadata.service
com.trs.components.wcm.content

com.trs.components.metadata.service 使用的 com.trs.infra.persistent.util 中的类
SynChildrenExecutorBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 使用的 com.trs.infra.persistent.util 中的类
SynChildrenExecutorBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SynChildrenExecutorBase

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.persistent.util
类 SynChildrenExecutorBase

java.lang.Object
    继承者  com.trs.infra.persistent.util.SynChildrenExecutorBase
直接已知子类：
SynChildrenOfChannelExecutorBase
public abstract class SynChildrenExecutorBase
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SynChildrenExecutorBase(BaseObj _oStartObj)
SynChildrenExecutorBase(BaseObj _oStartObj, boolean _bDoOnStartObj)
方法摘要
 void execute(User _currUser)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SynChildrenExecutorBase

public SynChildrenExecutorBase(BaseObj _oStartObj)

SynChildrenExecutorBase

public SynChildrenExecutorBase(BaseObj _oStartObj,
                               boolean _bDoOnStartObj)
方法详细信息

execute

public void execute(User _currUser)
             throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.persistent.util.SynChildrenExecutorBase 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.persistent.util.SynChildrenExecutorBase
的使用

使用 SynChildrenExecutorBase 的软件包
com.trs.components.metadata.service
com.trs.components.wcm.content

com.trs.components.metadata.service 中 SynChildrenExecutorBase 的使用

com.trs.components.metadata.service 中 SynChildrenExecutorBase 的子类
class | SynChildrenExecutorForViewEmploy Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMFilterMakerForContainsChildren Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 中 SynChildrenExecutorBase 的使用

com.trs.components.wcm.content 中 SynChildrenExecutorBase 的子类
 class SynChildrenOfChannelExecutorBase
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CacheMgrConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.cache
类 CacheMgrConfig

java.lang.Object
    继承者  com.trs.infra.support.cache.CacheMgrConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class CacheMgrConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CacheMgrConfig()
方法摘要
java.lang.String | getBeanId()
java.lang.String | getName() 获取配置对象的名称
void | setBeanId(java.lang.String beanId)
void | setName(java.lang.String name) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CacheMgrConfig

public CacheMgrConfig()
方法详细信息

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

setName

public void setName(java.lang.String name)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
name - 配置对象的名称

getBeanId

public java.lang.String getBeanId()

setBeanId

public void setBeanId(java.lang.String beanId)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CacheServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.cache
类 CacheServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.support.cache.CacheServer
所有已实现的接口：
IServer
public class CacheServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
系统缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
CacheServer()
方法摘要
CacheMgrConfig[] | getConfigs()
void | setConfig(CacheMgrConfig[] _configs)
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CacheServer

public CacheServer()
方法详细信息

getConfigs

public CacheMgrConfig[] getConfigs()
返回：

setConfig

public void setConfig(CacheMgrConfig[] _configs)
参数：
_configs -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICacheMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.cache
接口 ICacheMgr

所有超级接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
所有已知子接口：
IAdministratorCacheMgr, ICachedPOMgr, IChannelNameMgr, IChildrenMgr, IChnlDeptMgr, IClassInfoCacheMgr, IFolderPubStatusCacheMgr, IMetaDataDefCacheMgr, IObjectMemberMgr, ITemplateEmployCacheMgr, IUserCacheMgr
所有已知实现类：
AdministratorCacheMgr, CachedPOMgr, ChannelNameMgr, ChildrenCacheMgr, ChnlDeptMgr, ClassInfoCacheMgr, FileDistributorFtpCacheMgr, FlowCacheMgr, FlowEmployCacheMgr, FolderPubStatusCacheMgrImpl, GroupAdminsCacheMgr, GroupUserCacheMgr, MetaDataDefCacheMgr, ObjectMemberMgr, PublishDistributionCacheMgr, ReplaceCacheMgr, RightCacheMgr, RoleUserCacheMgr, TemplateArgumentCacheMgr, TemplateCacheMgr, TemplateEmployCacheMgrImpl, UserCacheMgr
public interface ICacheMgr
extends IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | clear() 清除系统所有的Cache
boolean | init() 初始化当前的Cache
boolean | reinit()
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

init

boolean init()
             throws WCMException
初始化当前的Cache

返回：
抛出：
WCMException

reinit

boolean reinit()
               throws WCMException
返回：
抛出：
WCMException

clear

void clear()
清除系统所有的Cache

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICacheServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.cache
接口 ICacheServer

所有超级接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public interface ICacheServer
extends IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
Cache调度者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | clear() 清除系统所有的Cache
boolean | init() 初始化系统所有的Cache
void | notify(int _nEventType, java.lang.Object _oCacheObj, java.lang.Object[] _data) 缓冲同步通知
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 继承的方法
notifyOnAddObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 继承的方法
notifyOnDelObj
从接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 继承的方法
notifyOnModifyObj

方法详细信息

notify

void notify(int _nEventType,
            java.lang.Object _oCacheObj,
            java.lang.Object[] _data)
            throws WCMException
缓冲同步通知

参数：
_nEventType - 同步事件类型
_oCacheObj - 同步的缓冲对象
_data - 缓冲源数据
抛出：
WCMException

init

boolean init()
             throws WCMException
初始化系统所有的Cache

返回：
抛出：
WCMException

clear

void clear()
           throws WCMException
清除系统所有的Cache

抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.support.cache
接口
ICacheMgr
ICacheServer
类
CacheMgrConfig
CacheServer


com.trs.infra.support.cache

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.support.cache

接口摘要
ICacheMgr | Title: TRS 内容协作平台（TRS WCM） Description: Cache管理者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ICacheServer | Title: TRS 内容协作平台（TRS WCM） Description: Cache调度者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
CacheMgrConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CacheServer | Title: TRS 内容协作平台（TRS WCM） Description: 系统缓冲服务器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.support.cache 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.cache 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.support.cache.CacheServer
    • com.trs.infra.support.cache.CacheMgrConfig (implements com.trs.infra.config.persistent.IConfigElement)

接口分层结构

  • com.trs.infra.persistent.listener.IObjectLCListener
    • com.trs.infra.persistent.listener.IObjectLCListenerOnAdd
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
      • com.trs.infra.support.cache.ICacheServer (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.infra.persistent.listener.IObjectLCListenerOnDel
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
      • com.trs.infra.support.cache.ICacheServer (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.infra.persistent.listener.IObjectLCListenerOnModify
      • com.trs.infra.support.cache.ICacheMgr (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
      • com.trs.infra.support.cache.ICacheServer (并 extends com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel)


软件包 com.trs.infra.support.cache 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.cache
的使用

使用 com.trs.infra.support.cache 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.template
com.trs.components.metadata.definition
com.trs.components.stat
com.trs.components.wcm.content.persistent
com.trs.components.wcm.publish
com.trs.infra.persistent.cache
com.trs.infra.support.cache

com.trs.cms.auth.domain 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.template 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 使用的 com.trs.infra.support.cache 中的类
ICacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 使用的 com.trs.infra.support.cache 中的类
CacheMgrConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.cache.CacheMgrConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.cache.CacheMgrConfig
的使用

使用 CacheMgrConfig 的软件包
com.trs.infra.support.cache

com.trs.infra.support.cache 中 CacheMgrConfig 的使用

返回 CacheMgrConfig 的 com.trs.infra.support.cache 中的方法
 CacheMgrConfig[] CacheServer.getConfigs()

参数类型为 CacheMgrConfig 的 com.trs.infra.support.cache 中的方法
 void CacheServer.setConfig(CacheMgrConfig[] _configs)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.cache.CacheServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.cache.CacheServer
的使用

没有 com.trs.infra.support.cache.CacheServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.support.cache.ICacheMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.support.cache.ICacheMgr
的使用

使用 ICacheMgr 的软件包
com.trs.cms.auth.domain
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.components.common.publish.domain.distribute
com.trs.components.common.publish.domain.template
com.trs.components.metadata.definition
com.trs.components.stat
com.trs.components.wcm.content.persistent
com.trs.components.wcm.publish
com.trs.infra.persistent.cache

com.trs.cms.auth.domain 中 ICacheMgr 的使用

com.trs.cms.auth.domain 中 ICacheMgr 的子接口
 interface IObjectMemberMgr

实现 ICacheMgr 的 com.trs.cms.auth.domain 中的类
class | ObjectMemberMgr 可见可操作对象的缓冲管理.
class | RightCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 中 ICacheMgr 的使用

com.trs.cms.auth.persistent 中 ICacheMgr 的子接口
interface | IAdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: IAdministratorCacheMgr,接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户缓冲管理接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 ICacheMgr 的 com.trs.cms.auth.persistent 中的类
class | AdministratorCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 管理员角色用户缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupAdminsCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户组织管理员缓冲管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | RoleUserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 组织用户的缓冲.
class | UserCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 用户名缓冲器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 中 ICacheMgr 的使用

实现 ICacheMgr 的 com.trs.cms.process.definition 中的类
class | FlowCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 工作流缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowEmployCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: Template Employ缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.domain.distribute 中 ICacheMgr 的使用

实现 ICacheMgr 的 com.trs.components.common.publish.domain.distribute 中的类
class | FileDistributorFtpCacheMgr 已过时。 使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM） Description: ftp cache manager for file distribution. Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishDistributionCacheMgr FolderType,FolderId 到 PublishDistributionList 的缓存，加速给定目录分发点的查找

com.trs.components.common.publish.domain.template 中 ICacheMgr 的使用

com.trs.components.common.publish.domain.template 中 ICacheMgr 的子接口
 interface ITemplateEmployCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 ICacheMgr 的 com.trs.components.common.publish.domain.template 中的类
class | TemplateArgumentCacheMgr 缓存TemplateArguments对象，并监听TemplateArgument的增删改
class | TemplateCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: template cache manaager implementation.
class | TemplateEmployCacheMgrImpl Title: TRS 内容协作平台（TRS WCM） Description: 模板和发布元素的配置缓冲管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition 中 ICacheMgr 的使用

com.trs.components.metadata.definition 中 ICacheMgr 的子接口
interface | IClassInfoCacheMgr
interface | IMetaDataDefCacheMgr

实现 ICacheMgr 的 com.trs.components.metadata.definition 中的类
class | ClassInfoCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataDefCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 中 ICacheMgr 的使用

com.trs.components.stat 中 ICacheMgr 的子接口
 interface IChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

实现 ICacheMgr 的 com.trs.components.stat 中的类
 class ChnlDeptMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.wcm.content.persistent 中 ICacheMgr 的使用

com.trs.components.wcm.content.persistent 中 ICacheMgr 的子接口
interface | IChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IChildrenMgr Title: TRS 内容协作平台（TRS WCM） Description: 子频道获取管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

实现 ICacheMgr 的 com.trs.components.wcm.content.persistent 中的类
class | ChannelNameMgr Title: TRS 内容协作平台（TRS WCM） Description: 频道名称缓冲管理(LRU缓冲算法) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChildrenCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 子栏目管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceCacheMgr Title: TRS 内容协作平台（TRS WCM） Description: 替换内容的缓冲 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish 中 ICacheMgr 的使用

com.trs.components.wcm.publish 中 ICacheMgr 的子接口
 interface IFolderPubStatusCacheMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 ICacheMgr 的 com.trs.components.wcm.publish 中的类
 class FolderPubStatusCacheMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 中 ICacheMgr 的使用

com.trs.infra.persistent.cache 中 ICacheMgr 的子接口
 interface ICachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 ICacheMgr 的 com.trs.infra.persistent.cache 中的类
 class CachedPOMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
被缓冲的持久化对象的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.support.cache.ICacheServer 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.support.cache.ICacheServer
的使用

没有 com.trs.infra.support.cache.ICacheServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Config

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.config
类 Config

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.support.config.Config
所有已实现的接口：
java.lang.Cloneable
public class Config
extends BaseObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
static int | TYPE_CLUSTER_META 配置信息类别：集群相关配置
static int | TYPE_CUSTOM_ADD 配置信息类别：用户新增的配置(非系统自带的配置)
static int | TYPE_FILE_PATH 配置信息类别：文件目录配置
static int | TYPE_JOB_SERVER 配置信息类别：Job Server中的Worker配置
static int | TYPE_NORM 配置信息类别：系统配置
static int | TYPE_SCHEDULE_SERVER 配置信息类别：Schedule Server中的Worker配置
构造方法摘要
Config()
构造函数：保留默认接口
方法摘要
static Config | createNewInstance() 产生当前对象[Config]的实例
int | delete() 从数据中删除对象信息
static Config | findById(int _nId) 提取指定ID的对象
static Config | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getConfigKey() 获取配置主键
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 获取配置描述信息
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getType() 获取配置类别
java.lang.String | getTypeName()
java.lang.String | getValue() 获取配置值
int | getWCMType() 取得该对象的类型编号（定义在WCMTypes中）
void | insert() 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isEncrypted() 判断配置是否加密
boolean | isValid() 效验数据是否有效
boolean | setConfigKey(java.lang.String _key) 设置配置主键 要求：相同Type的配置记录不重名； 处理：区分大小写，由isValid函数检查
boolean | setDesc(java.lang.String _desc) 设置配置描述信息
boolean | setType(int _nType) 获取配置类别（定义在Config中）
boolean | setValue(java.lang.String _value) 设置配置值
boolean | setValue(java.lang.String _value, boolean _bEncrypted) 设置配置值
void | update() 更新修改。
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值

TYPE_NORM

public static final int TYPE_NORM
配置信息类别：系统配置

另请参见：
常量字段值

TYPE_FILE_PATH

public static final int TYPE_FILE_PATH
配置信息类别：文件目录配置

另请参见：
常量字段值

TYPE_JOB_SERVER

public static final int TYPE_JOB_SERVER
配置信息类别：Job Server中的Worker配置

另请参见：
常量字段值

TYPE_SCHEDULE_SERVER

public static final int TYPE_SCHEDULE_SERVER
配置信息类别：Schedule Server中的Worker配置

另请参见：
常量字段值

TYPE_CLUSTER_META

public static final int TYPE_CLUSTER_META
配置信息类别：集群相关配置

另请参见：
常量字段值

TYPE_CUSTOM_ADD

public static final int TYPE_CUSTOM_ADD
配置信息类别：用户新增的配置(非系统自带的配置)

另请参见：
常量字段值
构造方法详细信息

Config

public Config()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getType

public int getType()
获取配置类别

返回：
配置类别

getTypeName

public java.lang.String getTypeName()

setType

public boolean setType(int _nType)
                throws WCMException
获取配置类别（定义在Config中）

参数：
_nType - 配置类别（定义在Config中）
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getConfigKey

public java.lang.String getConfigKey()
获取配置主键

返回：
配置主键

setConfigKey

public boolean setConfigKey(java.lang.String _key)
                     throws WCMException
设置配置主键 要求：相同Type的配置记录不重名； 处理：区分大小写，由isValid函数检查

参数：
_key - 配置主键
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isEncrypted

public boolean isEncrypted()
判断配置是否加密

返回：
如果配置加密了返回true；否则返回false

getDesc

public java.lang.String getDesc()
获取配置描述信息

返回：
配置描述信息

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置配置描述信息

参数：
_desc - 配置描述信息
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getValue

public java.lang.String getValue()
获取配置值

返回：

setValue

public boolean setValue(java.lang.String _value)
                 throws WCMException
设置配置值

参数：
_value - 配置值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setValue

public boolean setValue(java.lang.String _value,
                        boolean _bEncrypted)
                 throws WCMException
设置配置值

参数：
_value - 配置值
_bEncrypted - 是否加密。可缺省（默认值：新建对象为false,修改对象为原来的设置值）
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
效验数据是否有效

指定者：
类 BaseObj 中的 isValid
返回：
如果有效返回true；否则返回false
抛出：
WCMException - 如果无效将会抛出异常

findById

public static final Config findById(int _nId)
                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Config createNewInstance()
                                      throws WCMException
产生当前对象[Config]的实例

返回：
当前对象的实例[Config]
抛出：
WCMException

findByKey

public static final Config findByKey(java.lang.Object _oKey)
                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

insert

public void insert()
            throws WCMException
从类 BaseObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 BaseObj 中的 insert
抛出：
WCMException

update

public void update()
            throws WCMException
从类 BaseObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 BaseObj 中的 update
抛出：
WCMException

delete

public int delete()
           throws WCMException
从类 BaseObj 复制的描述
从数据中删除对象信息

覆盖：
类 BaseObj 中的 delete
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Configs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.config
类 Configs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.support.config.Configs

public class Configs
extends BaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Configs()
构造函数
Configs(int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Configs | createNewInstance() 产生当前集合对象[Configs]的实例
static Configs | findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Configs | openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[Configs]
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Configs

public Configs()
构造函数

另请参见：
Users( User _currUser, int _initCapacity, int _incCapacity );

Configs

public Configs(int _initCapacity,
               int _incCapacity)
构造函数

参数：
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

findByIds

public static final Configs findByIds(java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Configs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Configs openWCMObjs(WCMFilter _filter)
                                 throws WCMException
通过指定一个Filter获取当前集合[Configs]

参数：
_filter - 指定的Filter
返回：
当前集合[Configs]
抛出：
WCMException

createNewInstance

public static Configs createNewInstance()
产生当前集合对象[Configs]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.config
类 ConfigServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.support.config.ConfigServer
所有已实现的接口：
IServer, IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class ConfigServer
extends BaseServer
implements IObjectLCListenerOnAdd, IObjectLCListenerOnModify, IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String INI_FILENAME
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
ConfigServer()
方法摘要
void | clear()
static ConfigServer | createInstance()
java.lang.String | getInitProperty(java.lang.String _sKey)
static ConfigServer | getServer()
Config | getSysConfig(java.lang.String _sConfigName) 取指定的系统配置信息
java.lang.String | getSysConfigValue(java.lang.String _key, java.lang.String _default)
int[] | getTypeIds()
java.lang.String | getTypeName(int _nTypeId)
java.lang.String[] | getTypeNames()
static void | main(java.lang.String[] args)
void | notifyOnAddObj(BaseObj _currObj) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _currObj, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _currObj, int _nEventType) 修改一个对象后通知所有的Cache
void | setInitProperties(java.util.Map properties)
void | setInitProperties(java.lang.String sKey, java.lang.String sValue)
void | updateConfigValue(java.lang.String _sConfigName, java.lang.String _sValue) 更新系统的配置信息
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

INI_FILENAME

public static final java.lang.String INI_FILENAME
另请参见：
常量字段值
构造方法详细信息

ConfigServer

public ConfigServer()
方法详细信息

getTypeIds

public int[] getTypeIds()
返回：

getTypeNames

public java.lang.String[] getTypeNames()
返回：

createInstance

public static ConfigServer createInstance()

updateConfigValue

public void updateConfigValue(java.lang.String _sConfigName,
                              java.lang.String _sValue)
                       throws WCMException
更新系统的配置信息

参数：
_sConfigName - 配置项
_sValue - 配置信息
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _currObj,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_currObj - 被修改的对象
_nEventType - TODO
抛出：
WCMException

notifyOnAddObj

public void notifyOnAddObj(BaseObj _currObj)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_currObj - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _currObj,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_currObj - 被删除的对象
_nEventType - TODO
抛出：
WCMException

getSysConfig

public Config getSysConfig(java.lang.String _sConfigName)
                    throws WCMException
取指定的系统配置信息

参数：
_sConfigName - 配置项名称
返回：
@throws WCMException
抛出：
WCMException

getSysConfigValue

public java.lang.String getSysConfigValue(java.lang.String _key,
                                          java.lang.String _default)
                                   throws WCMException
参数：
_key -
_default -
返回：
抛出：
WCMException

clear

public void clear()

getServer

public static ConfigServer getServer()

getInitProperty

public java.lang.String getInitProperty(java.lang.String _sKey)

setInitProperties

public void setInitProperties(java.lang.String sKey,
                              java.lang.String sValue)
                       throws WCMException
抛出：
WCMException

setInitProperties

public void setInitProperties(java.util.Map properties)
                       throws WCMException
抛出：
WCMException

getTypeName

public java.lang.String getTypeName(int _nTypeId)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.support.config
类
Config
Configs
ConfigServer
PathConfig
SystemCollocationConfig


com.trs.infra.support.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.support.config

类摘要
Config |
Configs |
ConfigServer | Title: TRS 内容协作平台（TRS WCM） Description:
PathConfig |
SystemCollocationConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.support.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.infra.support.config.Config
    • com.trs.infra.persistent.BaseObjs
      • com.trs.infra.support.config.Configs
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.support.config.ConfigServer (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)
    • com.trs.infra.support.config.PathConfig (implements java.lang.Cloneable)
    • com.trs.infra.support.config.SystemCollocationConfig (implements com.trs.infra.config.persistent.IConfigElement)


软件包 com.trs.infra.support.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.config
的使用

使用 com.trs.infra.support.config 的软件包
com.trs.ajaxservice
com.trs.components.gkml.sqgk.process.element
com.trs.infra.support.config
com.trs.infra.support.file

com.trs.ajaxservice 使用的 com.trs.infra.support.config 中的类
ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.infra.support.config 中的类
ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:

com.trs.infra.support.config 使用的 com.trs.infra.support.config 中的类
Config
Configs
ConfigServer
Title: TRS 内容协作平台（TRS WCM）
Description:
PathConfig

com.trs.infra.support.file 使用的 com.trs.infra.support.config 中的类
Config
PathConfig

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PathConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.config
类 PathConfig

java.lang.Object
    继承者  com.trs.infra.support.config.PathConfig
所有已实现的接口：
java.lang.Cloneable
public class PathConfig
extends java.lang.Object
implements java.lang.Cloneable

字段摘要
static java.lang.String DELIM
属性分割符
构造方法摘要
PathConfig()
默认构造函数
PathConfig(PathConfig _pathConfig)
使用目录配置对象构造对象
PathConfig(java.lang.String _sValues)
使用组合字符串构造对象 字符串格式：Flag;LocalPath;HttpPath;FtpPath
方法摘要
void | clear() 清除所有属性值
java.lang.Object | clone() 对象克隆
java.lang.String | getFtpPath() 获取Ftp路径
java.lang.String | getHttpPath() 获取Http路径
java.lang.String | getLocalPath() 获取本地路径
void | set(java.lang.String _sValues) 使用组合字符串设置属性值 字符串格式：Flag;LocalPath;HttpPath;FtpPath
void | setFtpPath(java.lang.String _sFtpPath) 设置Ftp路径
void | setHttpPath(java.lang.String _sHttpPath) 设置Http路径
void | setLocalPath(java.lang.String _sLocalPath) 设置本地路径
java.lang.String | toString() 将属性值输出为格式化的字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DELIM

public static final java.lang.String DELIM
属性分割符

另请参见：
常量字段值
构造方法详细信息

PathConfig

public PathConfig()
默认构造函数

PathConfig

public PathConfig(PathConfig _pathConfig)
使用目录配置对象构造对象

参数：
_pathConfig - 目录配置对象

PathConfig

public PathConfig(java.lang.String _sValues)
           throws WCMException
使用组合字符串构造对象 字符串格式：Flag;LocalPath;HttpPath;FtpPath

参数：
_sValues - 属性字符串
抛出：
WCMException
方法详细信息

getLocalPath

public java.lang.String getLocalPath()
获取本地路径

返回：
本地路径

setLocalPath

public void setLocalPath(java.lang.String _sLocalPath)
                  throws WCMException
设置本地路径

参数：
_sLocalPath - 本地路径
抛出：
WCMException

getHttpPath

public java.lang.String getHttpPath()
获取Http路径

返回：
Http路径

setHttpPath

public void setHttpPath(java.lang.String _sHttpPath)
设置Http路径

参数：
_sHttpPath - Http路径

getFtpPath

public java.lang.String getFtpPath()
获取Ftp路径

返回：
Ftp路径

setFtpPath

public void setFtpPath(java.lang.String _sFtpPath)
设置Ftp路径

参数：
_sFtpPath - Ftp路径

set

public void set(java.lang.String _sValues)
         throws WCMException
使用组合字符串设置属性值 字符串格式：Flag;LocalPath;HttpPath;FtpPath

参数：
_sValues - 属性字符串
抛出：
WCMException

toString

public java.lang.String toString()
将属性值输出为格式化的字符串

覆盖：
类 java.lang.Object 中的 toString
返回：
格式化的属性值

clear

public void clear()
清除所有属性值

clone

public java.lang.Object clone()
对象克隆

覆盖：
类 java.lang.Object 中的 clone
返回：
Object对象
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SystemCollocationConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.config
类 SystemCollocationConfig

java.lang.Object
    继承者  com.trs.infra.support.config.SystemCollocationConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class SystemCollocationConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SystemCollocationConfig()
方法摘要
java.lang.String | getName() 获取配置对象的名称
int | getTypeId()
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setTypeId(int typeId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SystemCollocationConfig

public SystemCollocationConfig()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getTypeId

public int getTypeId()

setTypeId

public void setTypeId(int typeId)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.support.config.Config 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.config.Config
的使用

使用 Config 的软件包
com.trs.infra.support.config
com.trs.infra.support.file

com.trs.infra.support.config 中 Config 的使用

返回 Config 的 com.trs.infra.support.config 中的方法
static Config | Config.createNewInstance() 产生当前对象[Config]的实例
static Config | Config.findById(int _nId) 提取指定ID的对象
static Config | Config.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
Config | ConfigServer.getSysConfig(java.lang.String _sConfigName) 取指定的系统配置信息

com.trs.infra.support.file 中 Config 的使用

参数类型为 Config 的 com.trs.infra.support.file 中的方法
boolean | FilesMan.putPathConfig(Config _config, boolean _bMakeDirIfNotExists) 装载指定目录配置信息 //why@2002-04-24
boolean | FilesMan.refreshPathConfig(Config _config) 刷新目录配置缓冲

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.config.Configs 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.config.Configs
的使用

使用 Configs 的软件包
com.trs.infra.support.config

com.trs.infra.support.config 中 Configs 的使用

返回 Configs 的 com.trs.infra.support.config 中的方法
static Configs | Configs.createNewInstance() 产生当前集合对象[Configs]的实例
static Configs | Configs.findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
static Configs | Configs.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[Configs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.config.ConfigServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.config.ConfigServer
的使用

使用 ConfigServer 的软件包
com.trs.ajaxservice
com.trs.components.gkml.sqgk.process.element
com.trs.infra.support.config

com.trs.ajaxservice 中 ConfigServer 的使用

声明为 ConfigServer 的 com.trs.ajaxservice 中的字段
static ConfigServer WCMApplyFormProcessServiceHelper.m_oConfigServer

返回 ConfigServer 的 com.trs.ajaxservice 中的方法
static ConfigServer WCMApplyFormProcessServiceHelper.getConfigServer()

com.trs.components.gkml.sqgk.process.element 中 ConfigServer 的使用

返回 ConfigServer 的 com.trs.components.gkml.sqgk.process.element 中的方法
static ConfigServer FlowContentApplyFormImpl.getConfigServer()

com.trs.infra.support.config 中 ConfigServer 的使用

返回 ConfigServer 的 com.trs.infra.support.config 中的方法
static ConfigServer | ConfigServer.createInstance()
static ConfigServer | ConfigServer.getServer()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.config.PathConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.config.PathConfig
的使用

使用 PathConfig 的软件包
com.trs.infra.support.config
com.trs.infra.support.file

com.trs.infra.support.config 中 PathConfig 的使用

参数类型为 PathConfig 的 com.trs.infra.support.config 中的构造方法
PathConfig(PathConfig _pathConfig)
使用目录配置对象构造对象

com.trs.infra.support.file 中 PathConfig 的使用

返回 PathConfig 的 com.trs.infra.support.file 中的方法
PathConfig | FilesMan.getPathConfig(java.lang.String _sPathFlag) 取指定目录标识的配置信息
PathConfig | FilesMan.removePathConfig(java.lang.String _sPathFlag) 从目录配置项中删除指定配置项

参数类型为 PathConfig 的 com.trs.infra.support.file 中的方法
 boolean FilesMan.putPathConfig(java.lang.String _sPathFlag, PathConfig _pathConfig, boolean _bMakeDirIfNotExists)
载入指定目录配置信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.config.SystemCollocationConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.config.SystemCollocationConfig
的使用

没有 com.trs.infra.support.config.SystemCollocationConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FilesMan

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.file
类 FilesMan

java.lang.Object
    继承者  com.trs.infra.support.file.FilesMan

public class FilesMan
extends java.lang.Object

字段摘要
static int | FILENAME_DATE_LENGTH 日期长度
static int | FILENAME_FLAG_LENGTH 目录标识长度
static int | FILENAME_MIN_LENGTH 文件名称最小值
static int | FILENAME_RANDOM_LENGTH 随机数长度
static int | FILENAME_TIME_LENGTH 时间值长度
static java.lang.String | FLAG_BIGTABLE 文件标识类型：BigTable（稀疏数据）的存储路径
static java.lang.String | FLAG_DOCUMENTSOURCE 文件标识类型：文档导出导入相关资源文件的存放路径
static java.lang.String | FLAG_HELPSEARCH 文件标识类型：HelpSearchIndex（帮助文件索引）的存储路径
static java.lang.String | FLAG_INFOVIEW 文件标识类型：InfoView（自定义表单，借助MS InfoPath实现）的存储路径
static java.lang.String | FLAG_LOCALPREVIEW 文件标识类型：本地存放预览文件的路径
static java.lang.String | FLAG_LOCALPUB 文件标识类型：本地存放发布文件的路径
static java.lang.String | FLAG_NORMAL 文件标识类型：普通文件目录
static java.lang.String | FLAG_PROTECTED 文件标识类型：受保护文件目录
static java.lang.String | FLAG_SITEFROM 文件标识类型：智能建站预设路径
static java.lang.String | FLAG_SYSTEMTEMP 文件标识类型：系统用临时文件目录
static java.lang.String | FLAG_TEMPLATE 文件标识类型：模板文件目录
static java.lang.String | FLAG_TRANSFORMER 系统中XSL文件的存放路径
static java.lang.String | FLAG_UPLOAD 文件标识类型：上传的临时文件目录
static java.lang.String | FLAG_USERTEMP 文件标识类型：用户用临时文件目录
static java.lang.String | FLAG_WEBFILE 文件标识类型：可通过http协议访问的文件的路径
static int | PATH_FTP 目录类型：Ftp目录，用于Ftp( for Client )
static int | PATH_HTTP 目录类型：Http目录，用于Web( for Client )
static int | PATH_LOCAL 目录类型：本地目录，用于Server( for Server )
方法摘要
 java.lang.String copyFile(java.lang.String _srcFilePathName, java.lang.String _dstPathFlag, boolean _bReturnPath)
将指定文件复制到指定的目录
 java.lang.String copyWCMFile(java.lang.String _srcFileName, java.lang.String _dstPathFlag)
将指定WCM文件复制到目标目录
 boolean deleteFile(java.lang.String _sFileName)
删除指定的文件
static CMyDateTime extractFileCrDate(java.lang.String _sFileName)
提取创建日期值
static CMyDateTime extractFileCrDateTime(java.lang.String _sFileName)
提取文件创建的日期时间值
static java.lang.String extractFileCrDateValue(java.lang.String _sFileName)
提取日期值
static long extractFileCrTimeValue(java.lang.String _sFileName)
从文件名中提取创建时间值
 boolean fileExists(java.lang.String _sFileName)
根据FilesMan的规则，判断文件对应的实际文件物理是否存在
不抛出异常，只返回true/false
 java.lang.String getFileFlag(java.lang.String _sFileName)
根据文件名，返回文件所在路径的Flag标识，如FilesMan.Flag_Protected
static FilesMan getFilesMan()
 java.lang.String getNextFileName(java.lang.String _sPathFlag, java.lang.String _sFileExt)
获取下一个可用的文件名称
 java.lang.String getNextFileName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime)
获取下一个可用的文件名称
 java.lang.String getNextFileName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime, boolean _bIncludePath)
获取下一个可用的文件名称 构造说明： [1]构造文件名时，自动检测文件名是否重复。
 java.lang.String getNextFilePathName(java.lang.String _sPathFlag, java.lang.String _sFileExt)
获取下一个可用的文件名称
 java.lang.String getNextFilePathName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime)
获取下一个可用的文件名称
 PathConfig getPathConfig(java.lang.String _sPathFlag)
取指定目录标识的配置信息
 java.lang.String getPathConfigValue(java.lang.String _sPathFlag, int _nPathType)
获取指定目录标识的配置信息值
 java.lang.String getTempAppendixFilePath(int _nSiteId, int _nPathType, boolean _bCreateWhenNotExists)
已过时。 to use getTemplateAppendixPath(WebSite.OBJ_TYPE, _nSiteId, _nPathType, _bCreateWhenNotExists) instead please.
 java.lang.String getTemplateAppendixPath(int _nRootType, int _nRootId, int _nPathType, boolean _bCreateWhenNotExists)
Returns the template appendix file path of the sepcified root.
static boolean isValidFile(java.lang.String _sFileName, java.lang.String _sPathFlag)
 java.lang.String mapFilePath(java.lang.String _sFileName, int _nPathType)
目录映射：根据文件名映射文件所在的路径 文件所在路径 说明：不检查文件路径是否真正存在
 java.lang.String moveFile(java.lang.String _srcFilePathName, java.lang.String _dstPathFlag, boolean _bReturnPath)
将指定文件移动到指定的目录
 java.lang.String moveWCMFile(java.lang.String _srcFileName, java.lang.String _dstPathFlag, boolean _bReturnPath)
将指定文件移动到指定的目录
 boolean putPathConfig(Config _config, boolean _bMakeDirIfNotExists)
装载指定目录配置信息 //why@2002-04-24
 boolean putPathConfig(java.lang.String _sPathFlag, PathConfig _pathConfig, boolean _bMakeDirIfNotExists)
载入指定目录配置信息
 boolean putPathConfig(java.lang.String sKey, java.lang.String sPath, boolean _bMakeDirIfNotExists)
 boolean refreshPathConfig(Config _config)
刷新目录配置缓冲
 PathConfig removePathConfig(java.lang.String _sPathFlag)
从目录配置项中删除指定配置项
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FILENAME_MIN_LENGTH

public static final int FILENAME_MIN_LENGTH
文件名称最小值

另请参见：
常量字段值

FILENAME_FLAG_LENGTH

public static final int FILENAME_FLAG_LENGTH
目录标识长度

另请参见：
常量字段值

FILENAME_DATE_LENGTH

public static final int FILENAME_DATE_LENGTH
日期长度

另请参见：
常量字段值

FILENAME_TIME_LENGTH

public static final int FILENAME_TIME_LENGTH
时间值长度

另请参见：
常量字段值

FILENAME_RANDOM_LENGTH

public static final int FILENAME_RANDOM_LENGTH
随机数长度

另请参见：
常量字段值

FLAG_NORMAL

public static final java.lang.String FLAG_NORMAL
文件标识类型：普通文件目录

另请参见：
常量字段值

FLAG_PROTECTED

public static final java.lang.String FLAG_PROTECTED
文件标识类型：受保护文件目录

另请参见：
常量字段值

FLAG_UPLOAD

public static final java.lang.String FLAG_UPLOAD
文件标识类型：上传的临时文件目录

另请参见：
常量字段值

FLAG_SYSTEMTEMP

public static final java.lang.String FLAG_SYSTEMTEMP
文件标识类型：系统用临时文件目录

另请参见：
常量字段值

FLAG_USERTEMP

public static final java.lang.String FLAG_USERTEMP
文件标识类型：用户用临时文件目录

另请参见：
常量字段值

FLAG_TEMPLATE

public static final java.lang.String FLAG_TEMPLATE
文件标识类型：模板文件目录

另请参见：
常量字段值

FLAG_LOCALPUB

public static final java.lang.String FLAG_LOCALPUB
文件标识类型：本地存放发布文件的路径

另请参见：
常量字段值

FLAG_LOCALPREVIEW

public static final java.lang.String FLAG_LOCALPREVIEW
文件标识类型：本地存放预览文件的路径

另请参见：
常量字段值

FLAG_WEBFILE

public static final java.lang.String FLAG_WEBFILE
文件标识类型：可通过http协议访问的文件的路径

另请参见：
常量字段值

FLAG_DOCUMENTSOURCE

public static final java.lang.String FLAG_DOCUMENTSOURCE
文件标识类型：文档导出导入相关资源文件的存放路径

另请参见：
常量字段值

FLAG_SITEFROM

public static final java.lang.String FLAG_SITEFROM
文件标识类型：智能建站预设路径

另请参见：
常量字段值

FLAG_BIGTABLE

public static final java.lang.String FLAG_BIGTABLE
文件标识类型：BigTable（稀疏数据）的存储路径

另请参见：
常量字段值

FLAG_INFOVIEW

public static final java.lang.String FLAG_INFOVIEW
文件标识类型：InfoView（自定义表单，借助MS InfoPath实现）的存储路径

另请参见：
常量字段值

FLAG_TRANSFORMER

public static final java.lang.String FLAG_TRANSFORMER
系统中XSL文件的存放路径

另请参见：
常量字段值

FLAG_HELPSEARCH

public static final java.lang.String FLAG_HELPSEARCH
文件标识类型：HelpSearchIndex（帮助文件索引）的存储路径

另请参见：
常量字段值

PATH_LOCAL

public static final int PATH_LOCAL
目录类型：本地目录，用于Server( for Server )

另请参见：
常量字段值

PATH_HTTP

public static final int PATH_HTTP
目录类型：Http目录，用于Web( for Client )

另请参见：
常量字段值

PATH_FTP

public static final int PATH_FTP
目录类型：Ftp目录，用于Ftp( for Client )

另请参见：
常量字段值
方法详细信息

getFilesMan

public static FilesMan getFilesMan()

putPathConfig

public boolean putPathConfig(Config _config,
                             boolean _bMakeDirIfNotExists)
                      throws WCMException
装载指定目录配置信息 //why@2002-04-24

参数：
_config - 配置对象
返回：
若装在成功，则返回true；否则，返回false
抛出：
WBEException
WCMException

putPathConfig

public boolean putPathConfig(java.lang.String sKey,
                             java.lang.String sPath,
                             boolean _bMakeDirIfNotExists)
                      throws WCMException
抛出：
WCMException

putPathConfig

public boolean putPathConfig(java.lang.String _sPathFlag,
                             PathConfig _pathConfig,
                             boolean _bMakeDirIfNotExists)
                      throws java.lang.Exception
载入指定目录配置信息

参数：
_sPathFlag - 目录标志（和文件标志为同一标志，FLAG_NORMAL等常量）
_pathConfig - 目录配置对象
_bMakeDirIfNotExists - 目录不存在是否自动创建
返回：
抛出：
java.lang.Exception

removePathConfig

public PathConfig removePathConfig(java.lang.String _sPathFlag)
从目录配置项中删除指定配置项

参数：
_sPathFlag - 目录标志（和文件标志为同一标志，FLAG_NORMAL等常量）
返回：

getPathConfig

public PathConfig getPathConfig(java.lang.String _sPathFlag)
取指定目录标识的配置信息

参数：
_sPathFlag - 目录标志（和文件标志为同一标志，FLAG_NORMAL等常量）
返回：
指定目录标识的配置信息

getPathConfigValue

public java.lang.String getPathConfigValue(java.lang.String _sPathFlag,
                                           int _nPathType)
获取指定目录标识的配置信息值

参数：
_sPathFlag - 目录标志（和文件标志为同一标志，FLAG_NORMAL等常量）
_nPathType - 目录类型（定义在FilesMan中，PATH_LOCAL等常量）
返回：
指定目录标识的配置信息值

mapFilePath

public java.lang.String mapFilePath(java.lang.String _sFileName,
                                    int _nPathType)
                             throws WCMException
目录映射：根据文件名映射文件所在的路径

文件所在路径

说明：不检查文件路径是否真正存在

参数：
_sFileName - 文件名
_nPathType - 目录类型
返回：
根据文件名映射文件所在的路径
抛出：
WCMException

getNextFileName

public java.lang.String getNextFileName(java.lang.String _sPathFlag,
                                        java.lang.String _sFileExt,
                                        CMyDateTime _crTime,
                                        boolean _bIncludePath)
                                 throws WCMException
获取下一个可用的文件名称

构造说明：

[1]构造文件名时，自动检测文件名是否重复。

[2]若重复，则在重复的文件名后再追加2位随机数。

说明：为减少系统负担，一旦两次获取文件名失败，返回null.

参数：
_sPathFlag - 文件类型标识（值由FLAG_NORMAL等常量定义）
_sFileExt - 文件扩展名（".ext"或"ext"形式）
_crTime - 创建时间（可省，默认值null，表示当前时间）
_bIncludePath - 返回值中是否包含路径（可省，默认值包含）
返回：
若成功，返回得到的文件名；否则，返回null.
抛出：
WCMException

getNextFileName

public java.lang.String getNextFileName(java.lang.String _sPathFlag,
                                        java.lang.String _sFileExt)
                                 throws WCMException
获取下一个可用的文件名称

抛出：
WCMException
另请参见：
getNextFileName( String _sPathFlag, String _sFileExt, CMyDateTime _crTime, boolean _bIncludePath )

getNextFileName

public java.lang.String getNextFileName(java.lang.String _sPathFlag,
                                        java.lang.String _sFileExt,
                                        CMyDateTime _crTime)
                                 throws WCMException
获取下一个可用的文件名称

抛出：
WCMException
另请参见：
getNextFileName( String _sPathFlag, String _sFileExt, CMyDateTime _crTime, boolean _bIncludePath )

getNextFilePathName

public java.lang.String getNextFilePathName(java.lang.String _sPathFlag,
                                            java.lang.String _sFileExt)
                                     throws WCMException
获取下一个可用的文件名称

抛出：
WCMException
另请参见：
getNextFileName( String _sPathFlag, String _sFileExt, CMyDateTime _crTime, boolean _bIncludePath )

getNextFilePathName

public java.lang.String getNextFilePathName(java.lang.String _sPathFlag,
                                            java.lang.String _sFileExt,
                                            CMyDateTime _crTime)
                                     throws WCMException
获取下一个可用的文件名称

抛出：
WCMException
另请参见：
getNextFileName( String _sPathFlag, String _sFileExt, CMyDateTime _crTime, boolean _bIncludePath )

extractFileCrDateValue

public static java.lang.String extractFileCrDateValue(java.lang.String _sFileName)
                                               throws WCMException
提取日期值

参数：
_sFileName - 文件名
返回：
字符串，格式：yyyy-MM-dd
抛出：
WCMException - 若文件名格式不符，抛出异常

extractFileCrTimeValue

public static long extractFileCrTimeValue(java.lang.String _sFileName)
                                   throws WCMException
从文件名中提取创建时间值

参数：
_sFileName - 文件名
返回：
long型
抛出：
WCMException - 若文件名格式不符，抛出异常

extractFileCrDate

public static CMyDateTime extractFileCrDate(java.lang.String _sFileName)
                                     throws WCMException
提取创建日期值

参数：
_sFileName -
返回：
返回值：CMyDateTime
抛出：
WCMException - 异常：若文件名格式不符，抛出异常

extractFileCrDateTime

public static CMyDateTime extractFileCrDateTime(java.lang.String _sFileName)
                                         throws WCMException
提取文件创建的日期时间值

参数：
_sFileName - 文件名
返回：
CMyDateTime 日期时间值
抛出：
WCMException - 异常：若文件名格式不符，抛出异常

copyFile

public java.lang.String copyFile(java.lang.String _srcFilePathName,
                                 java.lang.String _dstPathFlag,
                                 boolean _bReturnPath)
                          throws WCMException
将指定文件复制到指定的目录

参数：
_srcFilePathName - 原文件名（包含路径）
_dstPathFlag - 目标目录标识（必须是有效的目录标识）
_bReturnPath - 是否返回保存后的文件名
返回：
抛出：
WCMException

moveFile

public java.lang.String moveFile(java.lang.String _srcFilePathName,
                                 java.lang.String _dstPathFlag,
                                 boolean _bReturnPath)
                          throws WCMException
将指定文件移动到指定的目录

参数：
_srcFilePathName - 原文件名（包含路径）
_dstPathFlag - 目标目录标识（必须是有效的目录标识）
_bReturnPath - 是否返回保存后的文件名
返回：
抛出：
WCMException

deleteFile

public boolean deleteFile(java.lang.String _sFileName)
                   throws WCMException
删除指定的文件

参数：
_sFileName - 按照WCM文件命名规则构造的文件名
返回：
删除成功时返回true；否则返回false
抛出：
WCMException

getTempAppendixFilePath

public java.lang.String getTempAppendixFilePath(int _nSiteId,
                                                int _nPathType,
                                                boolean _bCreateWhenNotExists)
                                         throws WCMException
已过时。 to use getTemplateAppendixPath(WebSite.OBJ_TYPE, _nSiteId, _nPathType, _bCreateWhenNotExists) instead please.

模板附件文件所在目录映射

目录组织：文件保存在Template目录下，并按站点划分子目录

命名规则：


 com.trs.infra.support.file
类
FilesMan
PathConfigLCListener


com.trs.infra.support.file

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.support.file

类摘要
FilesMan |
PathConfigLCListener | Title: TRS 内容协作平台（TRS WCM） Description: 目录配置更新的监听 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.support.file 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.file 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.support.file.FilesMan
    • com.trs.infra.support.file.PathConfigLCListener (implements com.trs.infra.persistent.listener.IObjectLCListenerOnAdd, com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)


软件包 com.trs.infra.support.file 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.file
的使用

使用 com.trs.infra.support.file 的软件包
com.trs.infra.support.file

com.trs.infra.support.file 使用的 com.trs.infra.support.file 中的类
FilesMan

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PathConfigLCListener

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.file
类 PathConfigLCListener

java.lang.Object
    继承者  com.trs.infra.support.file.PathConfigLCListener
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class PathConfigLCListener
extends java.lang.Object
implements IObjectLCListenerOnAdd, IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
目录配置更新的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PathConfigLCListener()
方法摘要
void | notifyOnAddObj(BaseObj _oObjAdded) 新增一个对象后通知所有的Cache
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PathConfigLCListener

public PathConfigLCListener()
方法详细信息

notifyOnAddObj

public void notifyOnAddObj(BaseObj _oObjAdded)
                    throws WCMException
从接口 IObjectLCListenerOnAdd 复制的描述
新增一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnAdd 中的 notifyOnAddObj
参数：
_oObjAdded - 新增的对象
抛出：
WCMException

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.support.file.FilesMan 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.file.FilesMan
的使用

使用 FilesMan 的软件包
com.trs.infra.support.file

com.trs.infra.support.file 中 FilesMan 的使用

返回 FilesMan 的 com.trs.infra.support.file 中的方法
static FilesMan FilesMan.getFilesMan()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.file.PathConfigLCListener 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.file.PathConfigLCListener
的使用

没有 com.trs.infra.support.file.PathConfigLCListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseDBLog

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 BaseDBLog

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.support.log.BaseDBLog
所有已实现的接口：
ILog, java.lang.Cloneable
直接已知子类：
Log, LogBak
public abstract class BaseDBLog
extends BaseObj
implements ILog

Title: TRS 内容协作平台（TRS WCM）
Description:
WCMLog,ILog的一个具体实现.日志对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseDBLog()
构造函数：保留默认接口
方法摘要
boolean | deleteLog()
java.lang.String | getDesc() 获取日志描述
long | getExecTime()
LogType | getLogType() 获取日志类型对象
java.lang.String | getLogUserIP() 获取触发日志记录的用户登录IP
int | getObjId() 获取日志操作对象编号
java.lang.String | getObjName() 获取日志操作对象名称
int | getObjType() 获取日志操作对象类型
java.lang.String | getOpArgs() 获取日志操作参数
java.lang.String | getOperTypeDesc() 获取日志操作类型的具体描述
CMyDateTime | getOpTime() 获取操作时间
int | getOpType() 获取日志操作类型
int | getOpTypeId() 获取日志操作类型
int | getResult() 获取操作结果
long | getStartId()
long | getStartTimeMillis()
int | getTopLogId() 获取触发日志记录操作所记录的第一条日志的ID 如果当前日志是第一条记录(或独立的一条日志)则TopId为0
java.lang.String | getUserName() 获得日志用户名
boolean | isValid() 效验数据的有效性
void | loadByStartId(long _lStartId)
void | saveLog()
boolean | setDesc(java.lang.String _desc) 设置日志描述
boolean | setEndTimeMillis(long _lEndTime)
boolean | setExecTime(long _lExecTime)
boolean | setLogType(int _typeId) 设置日志类型
boolean | setLogType(LogType _logType) 设置日志类型
boolean | setLogUserIP(java.lang.String _sLogUserIP) 设置触发日志记录的用户的登录IP
boolean | setObj(BaseObj _baseObj)
boolean | setObjId(int _objId) 设置日志操作对象编号
boolean | setObjName(java.lang.String _objName) 设置日志操作对象名称
boolean | setObjType(int _objType) 设置日志操作对象类型
boolean | setObjTypeId(int _objTypeId) 设置日志操作类型
boolean | setOpArgs(java.lang.String _opArgs) 设置日志操作参数
boolean | setOpTime() 设置操作时间
boolean | setOpTime(CMyDateTime _opTime) 设置操作时间
boolean | setOpType(int _opType) 设置日志操作类型
boolean | setResult(int _result) 设置操作结果
boolean | setStartTimeMillis(long _lStartTime)
boolean | setTopLogId(int _nTopLogId) 设置触发日志记录操作所记录的第一条日志的ID 如果当前日志是第一条记录(或独立的一条日志)则TopId为0
boolean | setUser(java.lang.String _userName) 设置用户
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getDbTableName, getFinalPropertyAsString, getFinalPropertyAsString, getId, getIdFieldName, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, getWCMType, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseDBLog

public BaseDBLog()
构造函数：保留默认接口

方法详细信息

isValid

public boolean isValid()
                throws WCMException
效验数据的有效性

指定者：
类 BaseObj 中的 isValid
返回：
如果有效返回true；否则返回false
抛出：
WCMException

getLogType

public LogType getLogType()
                   throws WCMException
获取日志类型对象

指定者：
接口 ILog 中的 getLogType
返回：
@throws WCMException
抛出：
WCMException

setLogType

public boolean setLogType(int _typeId)
                   throws WCMException
设置日志类型

指定者：
接口 ILog 中的 setLogType
参数：
_typeId - 日志类型ID
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setLogType

public boolean setLogType(LogType _logType)
                   throws WCMException
设置日志类型

指定者：
接口 ILog 中的 setLogType
参数：
_logType - 日志类型
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOpType

public int getOpType()
获取日志操作类型

指定者：
接口 ILog 中的 getOpType
返回：
日志操作类型

setOpType

public boolean setOpType(int _opType)
                  throws WCMException
设置日志操作类型

指定者：
接口 ILog 中的 setOpType
参数：
_opType - 日志操作类型
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
获取日志描述

指定者：
接口 ILog 中的 getDesc
返回：
日志描述

setDesc

public boolean setDesc(java.lang.String _desc)
                throws WCMException
设置日志描述

指定者：
接口 ILog 中的 setDesc
参数：
_desc - 日志描述
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getUserName

public java.lang.String getUserName()
获得日志用户名

指定者：
接口 ILog 中的 getUserName
返回：
日志用户名

setUser

public boolean setUser(java.lang.String _userName)
                throws WCMException
设置用户

指定者：
接口 ILog 中的 setUser
参数：
_userName - 用户名
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjType

public int getObjType()
获取日志操作对象类型

指定者：
接口 ILog 中的 getObjType
返回：
日志操作对象类型

setObjType

public boolean setObjType(int _objType)
                   throws WCMException
设置日志操作对象类型

指定者：
接口 ILog 中的 setObjType
参数：
_objType - 日志操作对象类型
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

public int getObjId()
获取日志操作对象编号

指定者：
接口 ILog 中的 getObjId
返回：

setObj

public boolean setObj(BaseObj _baseObj)
               throws WCMException
指定者：
接口 ILog 中的 setObj
抛出：
WCMException

setObjId

public boolean setObjId(int _objId)
                 throws WCMException
设置日志操作对象编号

指定者：
接口 ILog 中的 setObjId
参数：
_objId -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjName

public java.lang.String getObjName()
获取日志操作对象名称

指定者：
接口 ILog 中的 getObjName
返回：

setObjName

public boolean setObjName(java.lang.String _objName)
                   throws WCMException
设置日志操作对象名称

指定者：
接口 ILog 中的 setObjName
参数：
_objName -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOpTypeId

public int getOpTypeId()
获取日志操作类型

指定者：
接口 ILog 中的 getOpTypeId
返回：

setObjTypeId

public boolean setObjTypeId(int _objTypeId)
                     throws WCMException
设置日志操作类型

指定者：
接口 ILog 中的 setObjTypeId
参数：
_objTypeId -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOpArgs

public java.lang.String getOpArgs()
获取日志操作参数

指定者：
接口 ILog 中的 getOpArgs
返回：

setOpArgs

public boolean setOpArgs(java.lang.String _opArgs)
                  throws WCMException
设置日志操作参数

指定者：
接口 ILog 中的 setOpArgs
参数：
_opArgs -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getResult

public int getResult()
获取操作结果

指定者：
接口 ILog 中的 getResult
返回：
操作结果

setResult

public boolean setResult(int _result)
                  throws WCMException
设置操作结果

指定者：
接口 ILog 中的 setResult
参数：
_result - 操作结果
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOpTime

public CMyDateTime getOpTime()
获取操作时间

指定者：
接口 ILog 中的 getOpTime
返回：

setOpTime

public boolean setOpTime(CMyDateTime _opTime)
                  throws WCMException
设置操作时间

指定者：
接口 ILog 中的 setOpTime
参数：
_opTime - 操作时间，如果省略参数 _opTime，则取当前时间作为操作时间
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setOpTime

public boolean setOpTime()
                  throws WCMException
设置操作时间

指定者：
接口 ILog 中的 setOpTime
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTopLogId

public int getTopLogId()
从接口 ILog 复制的描述
获取触发日志记录操作所记录的第一条日志的ID
如果当前日志是第一条记录(或独立的一条日志)则TopId为0

指定者：
接口 ILog 中的 getTopLogId
返回：

setTopLogId

public boolean setTopLogId(int _nTopLogId)
                    throws WCMException
从接口 ILog 复制的描述
设置触发日志记录操作所记录的第一条日志的ID
如果当前日志是第一条记录(或独立的一条日志)则TopId为0

指定者：
接口 ILog 中的 setTopLogId
参数：
_nTopLogId - 第一条日志的ID
返回：
@throws WCMException
抛出：
WCMException

getLogUserIP

public java.lang.String getLogUserIP()
从接口 ILog 复制的描述
获取触发日志记录的用户登录IP

指定者：
接口 ILog 中的 getLogUserIP
返回：

setLogUserIP

public boolean setLogUserIP(java.lang.String _sLogUserIP)
                     throws WCMException
从接口 ILog 复制的描述
设置触发日志记录的用户的登录IP

指定者：
接口 ILog 中的 setLogUserIP
参数：
_sLogUserIP - 用户登录IP
返回：
@throws WCMException
抛出：
WCMException

saveLog

public void saveLog()
             throws WCMException
指定者：
接口 ILog 中的 saveLog
抛出：
WCMException

deleteLog

public boolean deleteLog()
                  throws WCMException
指定者：
接口 ILog 中的 deleteLog
抛出：
WCMException

setStartTimeMillis

public boolean setStartTimeMillis(long _lStartTime)
                           throws WCMException
指定者：
接口 ILog 中的 setStartTimeMillis
抛出：
WCMException

getStartTimeMillis

public long getStartTimeMillis()
指定者：
接口 ILog 中的 getStartTimeMillis

setEndTimeMillis

public boolean setEndTimeMillis(long _lEndTime)
                         throws WCMException
指定者：
接口 ILog 中的 setEndTimeMillis
抛出：
WCMException

setExecTime

public boolean setExecTime(long _lExecTime)
                    throws WCMException
指定者：
接口 ILog 中的 setExecTime
抛出：
WCMException

getExecTime

public long getExecTime()
指定者：
接口 ILog 中的 getExecTime

loadByStartId

public void loadByStartId(long _lStartId)
                   throws WCMException
指定者：
接口 ILog 中的 loadByStartId
抛出：
WCMException

getOperTypeDesc

public java.lang.String getOperTypeDesc()
                                 throws WCMException
从接口 ILog 复制的描述
获取日志操作类型的具体描述

指定者：
接口 ILog 中的 getOperTypeDesc
返回：
@throws WCMException
抛出：
WCMException

getStartId

public long getStartId()
指定者：
接口 ILog 中的 getStartId
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ILog

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
接口 ILog

所有已知实现类：
BaseDBLog, Log, LogBak
public interface ILog

Title: TRS 内容协作平台（TRS WCM）
Description:
日志相关接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | deleteLog()
java.lang.String | getDesc() 获取日志描述
long | getExecTime()
LogType | getLogType() 获取日志类型对象
java.lang.String | getLogUserIP() 获取触发日志记录的用户登录IP
int | getObjId() 获取日志操作对象编号
java.lang.String | getObjName() 获取日志操作对象名称
int | getObjType() 获取日志操作对象类型
java.lang.String | getOpArgs() 获取日志操作参数
java.lang.String | getOperTypeDesc() 获取日志操作类型的具体描述
CMyDateTime | getOpTime() 获取操作时间
int | getOpType() 获取日志操作类型
int | getOpTypeId() 获取日志操作类型
int | getResult() 获取操作结果
long | getStartId()
long | getStartTimeMillis()
int | getTopLogId() 获取触发日志记录操作所记录的第一条日志的ID 如果当前日志是第一条记录(或独立的一条日志)则TopId为0
java.lang.String | getUserName() 获得日志用户名
void | loadByStartId(long _lStartId)
void | saveLog()
boolean | setDesc(java.lang.String _desc) 设置日志描述
boolean | setEndTimeMillis(long _lEndTime)
boolean | setExecTime(long _lExecTime)
boolean | setLogType(int _nLogTypeId)
boolean | setLogType(LogType _logType) 设置日志类型
boolean | setLogUserIP(java.lang.String _sLogUserIP) 设置触发日志记录的用户的登录IP
boolean | setObj(BaseObj _baseObj)
boolean | setObjId(int _objId) 设置日志操作对象编号
boolean | setObjName(java.lang.String _objName) 设置日志操作对象名称
boolean | setObjType(int _objType) 设置日志操作对象类型
boolean | setObjTypeId(int _objTypeId) 设置日志操作类型
boolean | setOpArgs(java.lang.String _opArgs) 设置日志操作参数
boolean | setOpTime() 设置操作时间
boolean | setOpTime(CMyDateTime _opTime) 设置操作时间
boolean | setOpType(int _opType) 设置日志操作类型
boolean | setResult(int _result) 设置操作结果
boolean | setStartTimeMillis(long _lStartTime)
boolean | setTopLogId(int _nTopLogId) 设置触发日志记录操作所记录的第一条日志的ID 如果当前日志是第一条记录(或独立的一条日志)则TopId为0
boolean | setUser(java.lang.String _userName) 设置用户

方法详细信息

getLogType

LogType getLogType()
                   throws WCMException
获取日志类型对象

返回：
@throws WCMException
抛出：
WCMException

setLogType

boolean setLogType(LogType _logType)
                   throws WCMException
设置日志类型

参数：
_logType - 日志类型
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setLogType

boolean setLogType(int _nLogTypeId)
                   throws WCMException
抛出：
WCMException

getOpType

int getOpType()
获取日志操作类型

返回：
日志操作类型

setOpType

boolean setOpType(int _opType)
                  throws WCMException
设置日志操作类型

参数：
_opType - 日志操作类型
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

java.lang.String getDesc()
获取日志描述

返回：
日志描述

setDesc

boolean setDesc(java.lang.String _desc)
                throws WCMException
设置日志描述

参数：
_desc - 日志描述
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getUserName

java.lang.String getUserName()
获得日志用户名

返回：
日志用户名

setUser

boolean setUser(java.lang.String _userName)
                throws WCMException
设置用户

参数：
_userName - 用户名
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjType

int getObjType()
获取日志操作对象类型

返回：
日志操作对象类型

setObjType

boolean setObjType(int _objType)
                   throws WCMException
设置日志操作对象类型

参数：
_objType - 日志操作对象类型
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjId

int getObjId()
获取日志操作对象编号

返回：

setObjId

boolean setObjId(int _objId)
                 throws WCMException
设置日志操作对象编号

参数：
_objId -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjName

java.lang.String getObjName()
获取日志操作对象名称

返回：

setObjName

boolean setObjName(java.lang.String _objName)
                   throws WCMException
设置日志操作对象名称

参数：
_objName -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOpTypeId

int getOpTypeId()
获取日志操作类型

返回：

setObjTypeId

boolean setObjTypeId(int _objTypeId)
                     throws WCMException
设置日志操作类型

参数：
_objTypeId -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOpArgs

java.lang.String getOpArgs()
获取日志操作参数

返回：

setOpArgs

boolean setOpArgs(java.lang.String _opArgs)
                  throws WCMException
设置日志操作参数

参数：
_opArgs -
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getResult

int getResult()
获取操作结果

返回：
操作结果

setResult

boolean setResult(int _result)
                  throws WCMException
设置操作结果

参数：
_result - 操作结果
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOpTime

CMyDateTime getOpTime()
获取操作时间

返回：

setOpTime

boolean setOpTime(CMyDateTime _opTime)
                  throws WCMException
设置操作时间

参数：
_opTime - 操作时间，如果省略参数 _opTime，则取当前时间作为操作时间
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

setOpTime

boolean setOpTime()
                  throws WCMException
设置操作时间

返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getTopLogId

int getTopLogId()
获取触发日志记录操作所记录的第一条日志的ID
如果当前日志是第一条记录(或独立的一条日志)则TopId为0

返回：

setTopLogId

boolean setTopLogId(int _nTopLogId)
                    throws WCMException
设置触发日志记录操作所记录的第一条日志的ID
如果当前日志是第一条记录(或独立的一条日志)则TopId为0

参数：
_nTopLogId - 第一条日志的ID
返回：
@throws WCMException
抛出：
WCMException

getLogUserIP

java.lang.String getLogUserIP()
获取触发日志记录的用户登录IP

返回：

setLogUserIP

boolean setLogUserIP(java.lang.String _sLogUserIP)
                     throws WCMException
设置触发日志记录的用户的登录IP

参数：
_sLogUserIP - 用户登录IP
返回：
@throws WCMException
抛出：
WCMException

setObj

boolean setObj(BaseObj _baseObj)
               throws WCMException
抛出：
WCMException

setStartTimeMillis

boolean setStartTimeMillis(long _lStartTime)
                           throws WCMException
抛出：
WCMException

setEndTimeMillis

boolean setEndTimeMillis(long _lEndTime)
                         throws WCMException
抛出：
WCMException

getStartTimeMillis

long getStartTimeMillis()

setExecTime

boolean setExecTime(long _lExecTime)
                    throws WCMException
抛出：
WCMException

getExecTime

long getExecTime()
                 throws WCMException
抛出：
WCMException

loadByStartId

void loadByStartId(long _lStartId)
                   throws WCMException
抛出：
WCMException

saveLog

void saveLog()
             throws WCMException
抛出：
WCMException

getStartId

long getStartId()

deleteLog

boolean deleteLog()
                  throws WCMException
抛出：
WCMException

getOperTypeDesc

java.lang.String getOperTypeDesc()
                                 throws WCMException
获取日志操作类型的具体描述

返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ILogMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
接口 ILogMgr

所有已知实现类：
LogMgr
public interface ILogMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
日志管理相关接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | bakupLogs(BaseObjs _logs)
boolean | clearLogBaks()
boolean | clearLogs()
void | delete(int _nLogId)
void | delete(java.lang.String _sLogIds)
void | delete(WCMFilter _filter)
void | deleteLogBaks(WCMFilter _filter)
ILog | find(int _nLogId)
BaseObjs | find(java.lang.String _sLogIds)
BaseObjs | getLogBaks(WCMFilter _filter)
BaseObjs | getLogBaks(WCMFilter _filter, int _nLogType)
BaseObjs | getLogs(WCMFilter _filter)
BaseObjs | getLogs(WCMFilter _filter, int _nLogType)
BaseObjs | getLogsByTopId(WCMFilter _filter, int _nTopId)

方法详细信息

delete

void delete(int _nLogId)
            throws WCMException
抛出：
WCMException

delete

void delete(java.lang.String _sLogIds)
            throws WCMException
抛出：
WCMException

delete

void delete(WCMFilter _filter)
            throws WCMException
抛出：
WCMException

getLogs

BaseObjs getLogs(WCMFilter _filter)
                 throws WCMException
抛出：
WCMException

getLogs

BaseObjs getLogs(WCMFilter _filter,
                 int _nLogType)
                 throws WCMException
抛出：
WCMException

getLogsByTopId

BaseObjs getLogsByTopId(WCMFilter _filter,
                        int _nTopId)
                        throws WCMException
抛出：
WCMException

deleteLogBaks

void deleteLogBaks(WCMFilter _filter)
                   throws WCMException
抛出：
WCMException

getLogBaks

BaseObjs getLogBaks(WCMFilter _filter)
                    throws WCMException
抛出：
WCMException

getLogBaks

BaseObjs getLogBaks(WCMFilter _filter,
                    int _nLogType)
                    throws WCMException
抛出：
WCMException

bakupLogs

void bakupLogs(BaseObjs _logs)
               throws WCMException
抛出：
WCMException

find

ILog find(int _nLogId)
          throws WCMException
抛出：
WCMException

find

BaseObjs find(java.lang.String _sLogIds)
              throws WCMException
抛出：
WCMException

clearLogs

boolean clearLogs()
                  throws WCMException
返回：
抛出：
WCMException

clearLogBaks

boolean clearLogBaks()
                     throws WCMException
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Log

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 Log

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.support.log.BaseDBLog
            继承者  com.trs.infra.support.log.Log
所有已实现的接口：
ILog, java.lang.Cloneable
public class Log
extends BaseDBLog

Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
Log()
构造函数：保留默认接口
方法摘要
static Log | createNewInstance() 产生当前对象[WCMLog]的实例
static Log | findById(int _nId) 提取指定ID的对象
static Log | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getValidSignResult() 获取校验日志签名的结果
int | getWCMType() 取得该对象的类型编号（定义在WCMTypes中）
void | insert() 将记录添加到数据库中
boolean | isValidSignLog() 是否为合法的签名日志
从类 com.trs.infra.support.log.BaseDBLog 继承的方法
deleteLog, getDesc, getExecTime, getLogType, getLogUserIP, getObjId, getObjName, getObjType, getOpArgs, getOperTypeDesc, getOpTime, getOpType, getOpTypeId, getResult, getStartId, getStartTimeMillis, getTopLogId, getUserName, isValid, loadByStartId, saveLog, setDesc, setEndTimeMillis, setExecTime, setLogType, setLogType, setLogUserIP, setObj, setObjId, setObjName, setObjType, setObjTypeId, setOpArgs, setOpTime, setOpTime, setOpType, setResult, setStartTimeMillis, setTopLogId, setUser
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Log

public Log()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号（定义在WCMTypes中）

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

insert

public void insert()
            throws WCMException
将记录添加到数据库中

覆盖：
类 BaseObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException

findById

public static final Log findById(int _nId)
                          throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Log createNewInstance()
                                   throws WCMException
产生当前对象[WCMLog]的实例

返回：
当前对象的实例[WCMLog]
抛出：
WCMException

findByKey

public static final Log findByKey(java.lang.Object _oKey)
                           throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

isValidSignLog

public boolean isValidSignLog()
是否为合法的签名日志

返回：

getValidSignResult

public java.lang.String getValidSignResult()
获取校验日志签名的结果

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogBak

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 LogBak

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.support.log.BaseDBLog
            继承者  com.trs.infra.support.log.LogBak
所有已实现的接口：
ILog, java.lang.Cloneable
public class LogBak
extends BaseDBLog

Title: TRS 内容协作平台（TRS WCM）
Description:
WCMLog的备份对象定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
构造方法摘要
LogBak()
方法摘要
static LogBak | createNewInstance() 产生当前对象[LogBak]的实例
static LogBak | findById(int _nId) 提取指定ID的对象
static LogBak | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
CMyDateTime | getBakTime() 获取备份时间
java.lang.String | getBakUserName() 获取备份用户
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getLogId()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert() 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | setBakUser(java.lang.String _sUserName) 设置备份用户
boolean | setLogId(int _nLogId)
boolean | setProperty(java.lang.String _sName, java.lang.Object _oValue)
void | update() 更新修改。
从类 com.trs.infra.support.log.BaseDBLog 继承的方法
deleteLog, getDesc, getExecTime, getLogType, getLogUserIP, getObjId, getObjName, getObjType, getOpArgs, getOperTypeDesc, getOpTime, getOpType, getOpTypeId, getResult, getStartId, getStartTimeMillis, getTopLogId, getUserName, isValid, loadByStartId, saveLog, setDesc, setEndTimeMillis, setExecTime, setLogType, setLogType, setLogUserIP, setObj, setObjId, setObjName, setObjType, setObjTypeId, setOpArgs, setOpTime, setOpTime, setOpType, setResult, setStartTimeMillis, setTopLogId, setUser
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

LogBak

public LogBak()
方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

getLogId

public int getLogId()

setLogId

public boolean setLogId(int _nLogId)
                 throws WCMException
抛出：
WCMException

getBakUserName

public java.lang.String getBakUserName()
获取备份用户

返回：
备份用户

setBakUser

public boolean setBakUser(java.lang.String _sUserName)
                   throws WCMException
设置备份用户

参数：
_bakUser - 备份用户对象
返回：
抛出：
WCMException

getBakTime

public CMyDateTime getBakTime()
获取备份时间

返回：
备份时间

setProperty

public boolean setProperty(java.lang.String _sName,
                           java.lang.Object _oValue)
                    throws WCMException
覆盖：
类 BaseObj 中的 setProperty
抛出：
WCMException - 如果修改文档备份对象将会抛出异常
另请参见：
( String _sName, Object _oValue ) throws WCMException

update

public void update()
            throws WCMException
从类 BaseObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 BaseObj 中的 update
抛出：
WCMException - 如果修改文档备份对象将会抛出异常
另请参见：
throws WCMException{

insert

public void insert()
            throws WCMException
从类 BaseObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 BaseObj 中的 insert
抛出：
WCMException - 如果修改文档备份对象将不执行任何操作
另请参见：
throws WCMException{

findById

public static final LogBak findById(int _nId)
                             throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final LogBak createNewInstance()
                                      throws WCMException
产生当前对象[LogBak]的实例

返回：
当前对象的实例[LogBak]
抛出：
WCMException

findByKey

public static final LogBak findByKey(java.lang.Object _oKey)
                              throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogBaks

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 LogBaks

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.support.log.LogBaks

public class LogBaks
extends BaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
日志备份对象集合的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
LogBaks()
方法摘要
static LogBaks | createNewInstance() 产生当前集合对象[WCMLogBaks]的实例
static LogBaks | findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static LogBaks | openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMLogBaks]
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LogBaks

public LogBaks()
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final LogBaks findByIds(java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（WCMLogBaks）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final LogBaks openWCMObjs(WCMFilter _filter)
                                 throws WCMException
通过指定一个Filter获取当前集合[WCMLogBaks]

参数：
_filter - 指定的Filter
返回：
当前集合[WCMLogBaks]
抛出：
WCMException

createNewInstance

public static LogBaks createNewInstance()
产生当前集合对象[WCMLogBaks]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogListUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 LogListUtil

java.lang.Object
    继承者  com.trs.infra.support.log.LogListUtil

public class LogListUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
日志列表工具,方便文档列页调用,其它地方很少使用这个接口
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
LogListUtil()
方法摘要
static java.util.Map | getLogObjs(boolean forceLoad)
static java.util.Map | getLogOpTypes(boolean forceLoad)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LogListUtil

public LogListUtil()
方法详细信息

getLogObjs

public static java.util.Map getLogObjs(boolean forceLoad)

getLogOpTypes

public static java.util.Map getLogOpTypes(boolean forceLoad)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 LogMgr

java.lang.Object
    继承者  com.trs.infra.support.log.LogMgr
所有已实现的接口：
ILogMgr
public class LogMgr
extends java.lang.Object
implements ILogMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象(WCMLog)的管理对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LogMgr()
方法摘要
void | bakupLogs(BaseObjs _logs)
boolean | clearLogBaks()
boolean | clearLogs()
void | delete(int _nLogId)
void | delete(java.lang.String _sLogIds)
void | delete(WCMFilter _filter)
void | deleteLogBaks(WCMFilter _filter)
ILog | find(int _nLogId)
BaseObjs | find(java.lang.String _sLogIds)
BaseObjs | getLogBaks(WCMFilter _filter)
BaseObjs | getLogBaks(WCMFilter _filter, int _nLogType)
BaseObjs | getLogs(WCMFilter _filter)
BaseObjs | getLogs(WCMFilter _filter, int _nLogType)
BaseObjs | getLogsByTopId(WCMFilter _filter, int _nTopId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LogMgr

public LogMgr()
方法详细信息

delete

public void delete(int _nLogId)
            throws WCMException
指定者：
接口 ILogMgr 中的 delete
抛出：
WCMException

delete

public void delete(java.lang.String _sLogIds)
            throws WCMException
指定者：
接口 ILogMgr 中的 delete
抛出：
WCMException

delete

public void delete(WCMFilter _filter)
            throws WCMException
指定者：
接口 ILogMgr 中的 delete
抛出：
WCMException

getLogs

public BaseObjs getLogs(WCMFilter _filter)
                 throws WCMException
指定者：
接口 ILogMgr 中的 getLogs
抛出：
WCMException

getLogs

public BaseObjs getLogs(WCMFilter _filter,
                        int _nLogType)
                 throws WCMException
指定者：
接口 ILogMgr 中的 getLogs
抛出：
WCMException

getLogsByTopId

public BaseObjs getLogsByTopId(WCMFilter _filter,
                               int _nTopId)
                        throws WCMException
指定者：
接口 ILogMgr 中的 getLogsByTopId
抛出：
WCMException

deleteLogBaks

public void deleteLogBaks(WCMFilter _filter)
                   throws WCMException
指定者：
接口 ILogMgr 中的 deleteLogBaks
抛出：
WCMException

getLogBaks

public BaseObjs getLogBaks(WCMFilter _filter)
                    throws WCMException
指定者：
接口 ILogMgr 中的 getLogBaks
抛出：
WCMException

getLogBaks

public BaseObjs getLogBaks(WCMFilter _filter,
                           int _nLogType)
                    throws WCMException
指定者：
接口 ILogMgr 中的 getLogBaks
抛出：
WCMException

bakupLogs

public void bakupLogs(BaseObjs _logs)
               throws WCMException
指定者：
接口 ILogMgr 中的 bakupLogs
抛出：
WCMException

find

public ILog find(int _nLogId)
          throws WCMException
指定者：
接口 ILogMgr 中的 find
抛出：
WCMException

find

public BaseObjs find(java.lang.String _sLogIds)
指定者：
接口 ILogMgr 中的 find

clearLogs

public boolean clearLogs()
                  throws WCMException
指定者：
接口 ILogMgr 中的 clearLogs
返回：
抛出：
WCMException

clearLogBaks

public boolean clearLogBaks()
                     throws WCMException
指定者：
接口 ILogMgr 中的 clearLogBaks
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Logs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 Logs

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.support.log.Logs

public class Logs
extends BaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象(WCMLog)集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Logs()
方法摘要
static Logs | createNewInstance() 产生当前集合对象[WCMLogs]的实例
static Logs | findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static Logs | openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMLogs]
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Logs

public Logs()
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final Logs findByIds(java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（WCMLogs）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Logs openWCMObjs(WCMFilter _filter)
                              throws WCMException
通过指定一个Filter获取当前集合[WCMLogs]

参数：
_filter - 指定的Filter
返回：
当前集合[WCMLogs]
抛出：
WCMException

createNewInstance

public static Logs createNewInstance()
产生当前集合对象[WCMLogs]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 LogServer

java.lang.Object
    继承者  com.trs.infra.support.log.LogServer

public class LogServer
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
日志服务提供者,提供系统日志的记录/查询/删除等操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | CONTEXT_INDEX_IP
static int | CONTEXT_INDEX_TOPID
构造方法摘要
LogServer()
方法摘要
static void | archiveLogs(CMyDateTime _arciveDate) 对特定时间之前的所有日志进行归档
static void | cachedLogtype(OperType _type)
static boolean | clearLogBaks() 清空归档日志 警告:请慎重进行此操作,确定需要删除所有的归档日志
static boolean | clearLogs() 清空所有日志 警告:请慎重进行此操作,确定需要删除所有的日志
static boolean | delete(BaseObjs _currLogs) 删除日志集合
static boolean | delete(CMyDateTime _currDate) 删除特定日期之前的所有日志
static boolean | delete(CMyDateTime _startDate, CMyDateTime _endDate) 删除特定时间段的所有日志
static boolean | delete(ILog _currLog) 删除一个日志记录
static boolean | delete(int _nLogId) 根据日志ID删除一个日志记录
static boolean | delete(java.lang.String _sLogIds) 根据日志ID序列，删除日志集合
static boolean | deleteLogBaks(CMyDateTime _currDate) 删除特定日期前的所有归档日志
static boolean | deleteLogBaks(CMyDateTime _startDate, CMyDateTime _endDate) 删除特定时间段的所有归档日志
static void | endRecordFailedOperation(long _lStartId, java.lang.Throwable _throwable)
static void | endRecordSucceedOperation(long _lStartId)
static void | endRecordSucceedOperation(long _lStartId, int _nLogObjId) 记录一个成功的操作日志 同时更新该记录的logobjid属性.
static boolean | existsLogType(java.lang.String _sLogType)
static java.lang.String | export(BaseObjs _currLogs) 根据日志对象集合导出日志
static java.lang.String | export(java.lang.String _sLogIds) 根据日志ID序列导出日志
static java.lang.String | exportToXMLString(ILog _currLog) 根据日志对象导出日志 导出的格式，符合WCMXML格式
static java.lang.String | exportToXMLString(int _nLogId) 根据日志ID导出日志 导出的格式，符合WCMXML格式
static BaseObjs | getLogBaks(int _nLogType, WCMFilter _filter) 获取所有符合条件的归档日志，可直接指定日志类型ID
static BaseObjs | getLogBaks(WCMFilter _currFilter) 获取所有符合条件的归档日志
static BaseObjs | getLogs(int _nLogType, WCMFilter _filter) 获取所有符合条件的日志，可直接指定日志类型ID
static BaseObjs | getLogs(WCMFilter _filter) 获取所有符合条件的日志
static BaseObjs | getLogsByTopId(int _nLogTopId, WCMFilter _filter) 获取属于一个逻辑操作（TopId）的日志集合 TopId标识日志的起始触发操作，相同TopId的操作都是一个操作触发的。
static java.lang.String | getLogTypeName(java.lang.String _sLogTypeConst) 根据日志类型常量获得日志类型名称
static LogType[] | getLogTypes() 获取系统定义的所有日志类型
static boolean | isRecordNeeded(BaseObj _currObj)
static long | startRecord(java.lang.String _sUserName, java.lang.String _sOperType, java.lang.String _sLogDesc, BaseObj _baseObj)
static long | startRecord(java.lang.String _sUserName, java.lang.String _sOperType, java.lang.String _sLogDesc, BaseObj _baseObj, int _nLogType) 开始记录日志
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CONTEXT_INDEX_IP

public static int CONTEXT_INDEX_IP

CONTEXT_INDEX_TOPID

public static int CONTEXT_INDEX_TOPID
构造方法详细信息

LogServer

public LogServer()
方法详细信息

delete

public static boolean delete(ILog _currLog)
                      throws WCMException
删除一个日志记录

参数：
_currLog -
返回：
抛出：
WCMException

delete

public static boolean delete(int _nLogId)
                      throws WCMException
根据日志ID删除一个日志记录

参数：
_nLogId -
返回：
抛出：
WCMException

delete

public static boolean delete(BaseObjs _currLogs)
                      throws WCMException
删除日志集合

参数：
_currLogs -
返回：
抛出：
WCMException

delete

public static boolean delete(java.lang.String _sLogIds)
                      throws WCMException
根据日志ID序列，删除日志集合

参数：
_sLogIds -
返回：
抛出：
WCMException

delete

public static boolean delete(CMyDateTime _currDate)
                      throws WCMException
删除特定日期之前的所有日志

参数：
_currDate -
返回：
抛出：
WCMException

delete

public static boolean delete(CMyDateTime _startDate,
                             CMyDateTime _endDate)
                      throws WCMException
删除特定时间段的所有日志

参数：
_startDate -
_endDate -
返回：
抛出：
WCMException

clearLogs

public static boolean clearLogs()
                         throws WCMException
清空所有日志
警告:请慎重进行此操作,确定需要删除所有的日志

返回：
抛出：
WCMException

getLogs

public static BaseObjs getLogs(WCMFilter _filter)
                        throws WCMException
获取所有符合条件的日志

参数：
_filter -
返回：
抛出：
WCMException

getLogs

public static BaseObjs getLogs(int _nLogType,
                               WCMFilter _filter)
                        throws WCMException
获取所有符合条件的日志，可直接指定日志类型ID

参数：
_nLogType -
_filter -
返回：
抛出：
WCMException

getLogsByTopId

public static BaseObjs getLogsByTopId(int _nLogTopId,
                                      WCMFilter _filter)
                               throws WCMException
获取属于一个逻辑操作（TopId）的日志集合
TopId标识日志的起始触发操作，相同TopId的操作都是一个操作触发的。

参数：
_nLogTopId -
_filter -
返回：
抛出：
WCMException

archiveLogs

public static void archiveLogs(CMyDateTime _arciveDate)
                        throws WCMException
对特定时间之前的所有日志进行归档

参数：
_arciveDate - 进行归档的时间点
抛出：
WCMException

exportToXMLString

public static java.lang.String exportToXMLString(int _nLogId)
                                          throws WCMException
根据日志ID导出日志
导出的格式，符合WCMXML格式

参数：
_nLogId -
返回：
抛出：
WCMException

exportToXMLString

public static java.lang.String exportToXMLString(ILog _currLog)
                                          throws WCMException
根据日志对象导出日志
导出的格式，符合WCMXML格式

参数：
_currLog -
返回：
抛出：
WCMException

export

public static java.lang.String export(java.lang.String _sLogIds)
                               throws WCMException
根据日志ID序列导出日志

参数：
_sLogIds -
返回：
抛出：
WCMException

export

public static java.lang.String export(BaseObjs _currLogs)
                               throws WCMException
根据日志对象集合导出日志

参数：
_currLogs -
返回：
抛出：
WCMException

getLogBaks

public static BaseObjs getLogBaks(WCMFilter _currFilter)
                           throws WCMException
获取所有符合条件的归档日志

参数：
_filter -
返回：
抛出：
WCMException

getLogBaks

public static BaseObjs getLogBaks(int _nLogType,
                                  WCMFilter _filter)
                           throws WCMException
获取所有符合条件的归档日志，可直接指定日志类型ID

参数：
_nLogType -
_filter -
返回：
抛出：
WCMException

deleteLogBaks

public static boolean deleteLogBaks(CMyDateTime _currDate)
                             throws WCMException
删除特定日期前的所有归档日志

参数：
_currTime -
抛出：
WCMException

deleteLogBaks

public static boolean deleteLogBaks(CMyDateTime _startDate,
                                    CMyDateTime _endDate)
                             throws WCMException
删除特定时间段的所有归档日志

参数：
_startDate -
_endDate -
抛出：
WCMException

clearLogBaks

public static boolean clearLogBaks()
                            throws WCMException
清空归档日志
警告:请慎重进行此操作,确定需要删除所有的归档日志

抛出：
WCMException

getLogTypeName

public static java.lang.String getLogTypeName(java.lang.String _sLogTypeConst)
                                       throws WCMException
根据日志类型常量获得日志类型名称

参数：
_sLogTypeConst -
返回：
抛出：
WCMException

getLogTypes

public static LogType[] getLogTypes()
获取系统定义的所有日志类型

返回：

startRecord

public static long startRecord(java.lang.String _sUserName,
                               java.lang.String _sOperType,
                               java.lang.String _sLogDesc,
                               BaseObj _baseObj,
                               int _nLogType)
开始记录日志

参数：
_sUserName - 操作的用户
_sOperType - 操作类型（定义在OpersType.xml中）
_sLogDesc - 日志描述
_nLogType - 日志类型(定义在LogType中ID_ERR...)
_baseObj - 操作对象
返回：
操作成功，返回当前日志的Id

startRecord

public static long startRecord(java.lang.String _sUserName,
                               java.lang.String _sOperType,
                               java.lang.String _sLogDesc,
                               BaseObj _baseObj)
另请参见：
startRecord(String, String, String, BaseObj, int)

endRecordSucceedOperation

public static void endRecordSucceedOperation(long _lStartId)

endRecordSucceedOperation

public static void endRecordSucceedOperation(long _lStartId,
                                             int _nLogObjId)
记录一个成功的操作日志
同时更新该记录的logobjid属性.

参数：
_lStartId -
_nLogObjId -

endRecordFailedOperation

public static void endRecordFailedOperation(long _lStartId,
                                            java.lang.Throwable _throwable)

isRecordNeeded

public static final boolean isRecordNeeded(BaseObj _currObj)

existsLogType

public static boolean existsLogType(java.lang.String _sLogType)
参数：
_sLogType -
返回：

cachedLogtype

public static void cachedLogtype(OperType _type)
参数：
_type -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 LogType

java.lang.Object
    继承者  com.trs.infra.support.log.LogType

public final class LogType
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
日志类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static LogType | DEBUG 日志类型:调试
static LogType | ERROR 日志类型:错误
static LogType | FATAL 日志类型:致命
static int | ID_DEBUG
static int | ID_ERROR
static int | ID_FATAL
static int | ID_INFO
static int | ID_WARN
static LogType | INFO 日志类型:信息
static LogType | WARN 日志类型:警告
方法摘要
static LogType | findById(int _nId) 根据ID获取日志类型
java.lang.String | getDesc() 获取描述
int | getId() 获取ID
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ID_FATAL

public static final int ID_FATAL
另请参见：
常量字段值

ID_ERROR

public static final int ID_ERROR
另请参见：
常量字段值

ID_WARN

public static final int ID_WARN
另请参见：
常量字段值

ID_INFO

public static final int ID_INFO
另请参见：
常量字段值

ID_DEBUG

public static final int ID_DEBUG
另请参见：
常量字段值

FATAL

public static final LogType FATAL
日志类型:致命

ERROR

public static final LogType ERROR
日志类型:错误

WARN

public static final LogType WARN
日志类型:警告

INFO

public static final LogType INFO
日志类型:信息

DEBUG

public static final LogType DEBUG
日志类型:调试

方法详细信息

getDesc

public java.lang.String getDesc()
获取描述

返回：

getId

public int getId()
获取ID

返回：

findById

public static LogType findById(int _nId)
                        throws WCMException
根据ID获取日志类型

参数：
_nId -
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogXmlConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 LogXmlConverter

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjToXmlConverter
        继承者  com.trs.infra.support.log.LogXmlConverter

public final class LogXmlConverter
extends BaseObjToXmlConverter

Title: TRS 内容协作平台（TRS WCM）
Description:
Log --> XML 转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LogXmlConverter()
方法摘要
从类 com.trs.infra.persistent.BaseObjToXmlConverter 继承的方法
addChildElements, getElementTag, getElementTag, getXmlEncoding, isAddVersion, setAddVersion, setXmlEncoding, toXmlElement, toXmlElement, toXmlElement, toXMLFile, toXMLFile, toXMLFile, toXMLString, toXMLString, toXMLString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LogXmlConverter

public LogXmlConverter()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OperType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 OperType

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.support.log.OperType
所有已实现的接口：
java.lang.Cloneable
public class OperType
extends BaseObj

Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录的操作类型对象定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
static int | OBJ_TYPE
static int | UNKNOWN_OPERTYPE_ID
构造方法摘要
OperType()
方法摘要
static OperType | createNewInstance() 产生当前对象[OperType]的实例
static OperType | findById(int _nId) 提取指定ID的对象
static OperType | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getDesc()
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getName()
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
boolean | setDesc(java.lang.String _sDesc)
boolean | setName(java.lang.String _sOperName)
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值

UNKNOWN_OPERTYPE_ID

public static final int UNKNOWN_OPERTYPE_ID
另请参见：
常量字段值
构造方法详细信息

OperType

public OperType()
方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

getName

public java.lang.String getName()

setName

public boolean setName(java.lang.String _sOperName)
                throws WCMException
抛出：
WCMException

getDesc

public java.lang.String getDesc()

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
抛出：
WCMException

findById

public static final OperType findById(int _nId)
                               throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final OperType createNewInstance()
                                        throws WCMException
产生当前对象[OperType]的实例

返回：
当前对象的实例[OperType]
抛出：
WCMException

findByKey

public static final OperType findByKey(java.lang.Object _oKey)
                                throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OperTypes

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.log
类 OperTypes

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.support.log.OperTypes

public class OperTypes
extends BaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录的操作类型集合对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
OperTypes()
方法摘要
static OperTypes | createNewInstance() 产生当前集合对象[OperTypes]的实例
static OperTypes | findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static OperTypes | openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[OperTypes]
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OperTypes

public OperTypes()
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final OperTypes findByIds(java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（OperTypes）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final OperTypes openWCMObjs(WCMFilter _filter)
                                   throws WCMException
通过指定一个Filter获取当前集合[OperTypes]

参数：
_filter - 指定的Filter
返回：
当前集合[OperTypes]
抛出：
WCMException

createNewInstance

public static OperTypes createNewInstance()
产生当前集合对象[OperTypes]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.support.log
接口
ILog
ILogMgr
类
BaseDBLog
Log
LogBak
LogBaks
LogListUtil
LogMgr
Logs
LogServer
LogType
LogXmlConverter
OperType
OperTypes


com.trs.infra.support.log

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.support.log

接口摘要
ILog | Title: TRS 内容协作平台（TRS WCM） Description: 日志相关接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ILogMgr | Title: TRS 内容协作平台（TRS WCM） Description: 日志管理相关接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
BaseDBLog | Title: TRS 内容协作平台（TRS WCM） Description: WCMLog,ILog的一个具体实现.日志对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Log | Title: TRS 内容协作平台（TRS WCM） Description: 日志对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LogBak | Title: TRS 内容协作平台（TRS WCM） Description: WCMLog的备份对象定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LogBaks | Title: TRS 内容协作平台（TRS WCM） Description: 日志备份对象集合的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LogListUtil | Title: TRS 内容协作平台（TRS WCM） Description: 日志列表工具,方便文档列页调用,其它地方很少使用这个接口 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
LogMgr | Title: TRS 内容协作平台（TRS WCM） Description: 日志对象(WCMLog)的管理对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Logs | Title: TRS 内容协作平台（TRS WCM） Description: 日志对象(WCMLog)集合对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LogServer | Title: TRS 内容协作平台（TRS WCM） Description: 日志服务提供者,提供系统日志的记录/查询/删除等操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LogType | Title: TRS 内容协作平台（TRS WCM） Description: 日志类型 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LogXmlConverter | Title: TRS 内容协作平台（TRS WCM） Description: Log --> XML 转换 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
OperType | Title: TRS 内容协作平台（TRS WCM） Description: 日志记录的操作类型对象定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
OperTypes | Title: TRS 内容协作平台（TRS WCM） Description: 日志记录的操作类型集合对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.support.log 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.log 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.infra.support.log.BaseDBLog (implements com.trs.infra.support.log.ILog)
        • com.trs.infra.support.log.Log
        • com.trs.infra.support.log.LogBak
      • com.trs.infra.support.log.OperType
    • com.trs.infra.persistent.BaseObjs
      • com.trs.infra.support.log.LogBaks
      • com.trs.infra.support.log.Logs
      • com.trs.infra.support.log.OperTypes
    • com.trs.infra.persistent.BaseObjToXmlConverter
      • com.trs.infra.support.log.LogXmlConverter
    • com.trs.infra.support.log.LogListUtil
    • com.trs.infra.support.log.LogMgr (implements com.trs.infra.support.log.ILogMgr)
    • com.trs.infra.support.log.LogServer
    • com.trs.infra.support.log.LogType

接口分层结构

  • com.trs.infra.support.log.ILog
  • com.trs.infra.support.log.ILogMgr


软件包 com.trs.infra.support.log 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.log
的使用

使用 com.trs.infra.support.log 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 使用的 com.trs.infra.support.log 中的类
BaseDBLog
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMLog,ILog的一个具体实现.日志对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ILog
Title: TRS 内容协作平台（TRS WCM）
Description:
日志相关接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ILogMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
日志管理相关接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Log
Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogBak
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMLog的备份对象定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogBaks
Title: TRS 内容协作平台（TRS WCM）
Description:
日志备份对象集合的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Logs
Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象(WCMLog)集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogType
Title: TRS 内容协作平台（TRS WCM）
Description:
日志类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OperType
Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录的操作类型对象定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OperTypes
Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录的操作类型集合对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.BaseDBLog 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.BaseDBLog
的使用

使用 BaseDBLog 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 BaseDBLog 的使用

com.trs.infra.support.log 中 BaseDBLog 的子类
class | Log Title: TRS 内容协作平台（TRS WCM） Description: 日志对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | LogBak Title: TRS 内容协作平台（TRS WCM） Description: WCMLog的备份对象定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.support.log.ILog 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.support.log.ILog
的使用

使用 ILog 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 ILog 的使用

实现 ILog 的 com.trs.infra.support.log 中的类
class | BaseDBLog Title: TRS 内容协作平台（TRS WCM） Description: WCMLog,ILog的一个具体实现.日志对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Log Title: TRS 内容协作平台（TRS WCM） Description: 日志对象的定义与实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | LogBak Title: TRS 内容协作平台（TRS WCM） Description: WCMLog的备份对象定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 ILog 的 com.trs.infra.support.log 中的方法
ILog | LogMgr.find(int _nLogId)
ILog | ILogMgr.find(int _nLogId)

参数类型为 ILog 的 com.trs.infra.support.log 中的方法
static boolean | LogServer.delete(ILog _currLog) 删除一个日志记录
static java.lang.String | LogServer.exportToXMLString(ILog _currLog) 根据日志对象导出日志 导出的格式，符合WCMXML格式

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.support.log.ILogMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.support.log.ILogMgr
的使用

使用 ILogMgr 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 ILogMgr 的使用

实现 ILogMgr 的 com.trs.infra.support.log 中的类
 class LogMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象(WCMLog)的管理对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.Log 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.Log
的使用

使用 Log 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 Log 的使用

返回 Log 的 com.trs.infra.support.log 中的方法
static Log | Log.createNewInstance() 产生当前对象[WCMLog]的实例
static Log | Log.findById(int _nId) 提取指定ID的对象
static Log | Log.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.LogBak 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.LogBak
的使用

使用 LogBak 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 LogBak 的使用

返回 LogBak 的 com.trs.infra.support.log 中的方法
static LogBak | LogBak.createNewInstance() 产生当前对象[LogBak]的实例
static LogBak | LogBak.findById(int _nId) 提取指定ID的对象
static LogBak | LogBak.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.LogBaks 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.LogBaks
的使用

使用 LogBaks 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 LogBaks 的使用

返回 LogBaks 的 com.trs.infra.support.log 中的方法
static LogBaks | LogBaks.createNewInstance() 产生当前集合对象[WCMLogBaks]的实例
static LogBaks | LogBaks.findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
static LogBaks | LogBaks.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMLogBaks]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.LogListUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.LogListUtil
的使用

没有 com.trs.infra.support.log.LogListUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.LogMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.LogMgr
的使用

没有 com.trs.infra.support.log.LogMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.Logs 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.Logs
的使用

使用 Logs 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 Logs 的使用

返回 Logs 的 com.trs.infra.support.log 中的方法
static Logs | Logs.createNewInstance() 产生当前集合对象[WCMLogs]的实例
static Logs | Logs.findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
static Logs | Logs.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[WCMLogs]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.LogServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.LogServer
的使用

没有 com.trs.infra.support.log.LogServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.LogType 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.LogType
的使用

使用 LogType 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 LogType 的使用

声明为 LogType 的 com.trs.infra.support.log 中的字段
static LogType | LogType.DEBUG 日志类型:调试
static LogType | LogType.ERROR 日志类型:错误
static LogType | LogType.FATAL 日志类型:致命
static LogType | LogType.INFO 日志类型:信息
static LogType | LogType.WARN 日志类型:警告

返回 LogType 的 com.trs.infra.support.log 中的方法
static LogType | LogType.findById(int _nId) 根据ID获取日志类型
LogType | BaseDBLog.getLogType() 获取日志类型对象
LogType | ILog.getLogType() 获取日志类型对象
static LogType[] | LogServer.getLogTypes() 获取系统定义的所有日志类型

参数类型为 LogType 的 com.trs.infra.support.log 中的方法
boolean | BaseDBLog.setLogType(LogType _logType) 设置日志类型
boolean | ILog.setLogType(LogType _logType) 设置日志类型

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.LogXmlConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.LogXmlConverter
的使用

没有 com.trs.infra.support.log.LogXmlConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.OperType 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.OperType
的使用

使用 OperType 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 OperType 的使用

返回 OperType 的 com.trs.infra.support.log 中的方法
static OperType | OperType.createNewInstance() 产生当前对象[OperType]的实例
static OperType | OperType.findById(int _nId) 提取指定ID的对象
static OperType | OperType.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

参数类型为 OperType 的 com.trs.infra.support.log 中的方法
static void LogServer.cachedLogtype(OperType _type)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.log.OperTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.log.OperTypes
的使用

使用 OperTypes 的软件包
com.trs.infra.support.log

com.trs.infra.support.log 中 OperTypes 的使用

返回 OperTypes 的 com.trs.infra.support.log 中的方法
static OperTypes | OperTypes.createNewInstance() 产生当前集合对象[OperTypes]的实例
static OperTypes | OperTypes.findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
static OperTypes | OperTypes.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[OperTypes]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.infra.support.security
类
SecureKey
SecureKeyMgr
SecureKeys
SecureKeyUtil


com.trs.infra.support.security

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.support.security

定义和安全相关的一些对象和操作，诸如密钥的存储和管理。

请参见：
描述

类摘要
SecureKey | TODO Add javadoc for SecureKeys 描述系统中的密钥对象， 属性有：密钥算法、密钥长度、公钥数据、私钥数据等 关于名称：SecureKey，因为“SecretKey”是一个通用名称，在很多系统API中被采用，虽然在不同的包中使用相同的类名是可以的， 但是为了避免不必要的歧义，故意选择了这个错误的类型名称“SecureKey”。
SecureKeyMgr | Title: TRS 内容协作平台（TRS WCM） Description: SecureKey管理者对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SecureKeys | TODO Add javadoc for SecureKeys 密钥对 SecureKey 象的集合
SecureKeyUtil | Title: TRS 内容协作平台（TRS WCM） Description: SecureKeyUtil:工具函数 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

软件包 com.trs.infra.support.security 的描述

定义和安全相关的一些对象和操作，诸如密钥的存储和管理。


com.trs.infra.support.security 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.security 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.infra.support.security.SecureKey
    • com.trs.infra.persistent.BaseObjs
      • com.trs.infra.support.security.SecureKeys
    • com.trs.infra.support.security.SecureKeyMgr
    • com.trs.infra.support.security.SecureKeyUtil


软件包 com.trs.infra.support.security 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.support.security
的使用

使用 com.trs.infra.support.security 的软件包
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.service |
com.trs.service.impl |

com.trs.infra.support.security 使用的 com.trs.infra.support.security 中的类
SecureKey
TODO Add javadoc for SecureKeys 描述系统中的密钥对象， 属性有：密钥算法、密钥长度、公钥数据、私钥数据等 关于名称：SecureKey，因为“SecretKey”是一个通用名称，在很多系统API中被采用，虽然在不同的包中使用相同的类名是可以的， 但是为了避免不必要的歧义，故意选择了这个错误的类型名称“SecureKey”。
SecureKeys
TODO Add javadoc for SecureKeys 密钥对 SecureKey 象的集合

com.trs.service 使用的 com.trs.infra.support.security 中的类
SecureKey
TODO Add javadoc for SecureKeys 描述系统中的密钥对象， 属性有：密钥算法、密钥长度、公钥数据、私钥数据等 关于名称：SecureKey，因为“SecretKey”是一个通用名称，在很多系统API中被采用，虽然在不同的包中使用相同的类名是可以的， 但是为了避免不必要的歧义，故意选择了这个错误的类型名称“SecureKey”。
SecureKeys
TODO Add javadoc for SecureKeys 密钥对 SecureKey 象的集合

com.trs.service.impl 使用的 com.trs.infra.support.security 中的类
SecureKey
TODO Add javadoc for SecureKeys 描述系统中的密钥对象， 属性有：密钥算法、密钥长度、公钥数据、私钥数据等 关于名称：SecureKey，因为“SecretKey”是一个通用名称，在很多系统API中被采用，虽然在不同的包中使用相同的类名是可以的， 但是为了避免不必要的歧义，故意选择了这个错误的类型名称“SecureKey”。
SecureKeys
TODO Add javadoc for SecureKeys 密钥对 SecureKey 象的集合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SecureKey

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.security
类 SecureKey

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.support.security.SecureKey
所有已实现的接口：
java.lang.Cloneable
public class SecureKey
extends BaseObj

TODO Add javadoc for SecureKeys 描述系统中的密钥对象， 属性有：密钥算法、密钥长度、公钥数据、私钥数据等 关于名称：SecureKey，因为“SecretKey”是一个通用名称，在很多系统API中被采用，虽然在不同的包中使用相同的类名是可以的， 但是为了避免不必要的歧义，故意选择了这个错误的类型名称“SecureKey”。

字段摘要
static java.lang.String | DB_ID_NAME 对象表的主键列
static java.lang.String | DB_TABLE_NAME 对象在WCM中对应的数据表名
static int | OBJ_TYPE
构造方法摘要
SecureKey()
方法摘要
static SecureKey | createNewInstance() 产生当前对象[SecureKey]的实例
static SecureKey | findById(int _nId) 提取指定ID的对象
static SecureKey | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static SecureKey | findByName(java.lang.String _sKeyName)
java.lang.String | getAlgorithm() 获取密钥算法
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
java.lang.String | getKeyName() 获取密钥名
int | getKeySize() 获取密钥长度
java.security.Key | getPrivateKey() 获取密钥的私钥
java.security.Key | getPublicKey() 获取密钥的公钥
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
static void | main(java.lang.String[] args)
boolean | setAlgorithm(java.lang.String _alg) 设定密钥算法
boolean | setKeyName(java.lang.String _sKeyName) 设定密钥名
boolean | setKeySize(int _nKeySize) 设定密钥长度
java.lang.String | toString()
void | update() 更新修改。
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象在WCM中对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象表的主键列

另请参见：
常量字段值
构造方法详细信息

SecureKey

public SecureKey()
方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

isValid

public boolean isValid()
                throws WCMException
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：
抛出：
WCMException

findById

public static final SecureKey findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final SecureKey createNewInstance()
                                         throws WCMException
产生当前对象[SecureKey]的实例

返回：
当前对象的实例[SecureKey]
抛出：
WCMException

findByKey

public static final SecureKey findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

findByName

public static final SecureKey findByName(java.lang.String _sKeyName)
                                  throws WCMException
抛出：
WCMException

update

public void update()
            throws WCMException
从类 BaseObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 BaseObj 中的 update
抛出：
WCMException

getKeyName

public java.lang.String getKeyName()
获取密钥名

返回：
密钥名

setKeyName

public boolean setKeyName(java.lang.String _sKeyName)
                   throws WCMException
设定密钥名

参数：
_sKeyName - 指定的密钥名
返回：
如果操作成功 true
抛出：
WCMException - 如果操作过程中出现异常

getAlgorithm

public java.lang.String getAlgorithm()
获取密钥算法

返回：
密钥算法

setAlgorithm

public boolean setAlgorithm(java.lang.String _alg)
                     throws WCMException
设定密钥算法

参数：
_alg - 指定的密钥算法
返回：
如果操作成功 true
抛出：
WCMException - 如果操作过程中出现异常

getKeySize

public int getKeySize()
获取密钥长度

返回：
密钥长度

setKeySize

public boolean setKeySize(int _nKeySize)
                   throws WCMException
设定密钥长度

参数：
_nKeySize - 指定的密钥长度
返回：
@throws WCMException
抛出：
WCMException

getPrivateKey

public java.security.Key getPrivateKey()
获取密钥的私钥

返回：
私钥

getPublicKey

public java.security.Key getPublicKey()
获取密钥的公钥

返回：
公钥

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SecureKeyMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.security
类 SecureKeyMgr

java.lang.Object
    继承者  com.trs.infra.support.security.SecureKeyMgr

public class SecureKeyMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
SecureKey管理者对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SecureKeyMgr()
方法摘要
byte[] | decrypt(java.lang.String _sKeyName, byte[] _bytes) 使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。
byte[] | encrypt(java.lang.String _sKeyName, byte[] _data) 使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。
java.lang.String | exportKey(int _nKeyId, boolean _zIsPrivate)
java.lang.String | exportKey(java.lang.String _sKeyName, boolean _zIsPrivate)
SecureKeys | getKeys(WCMFilter _filter) 获取当前系统中符合条件的密钥的集合
SecureKey | save(SecureKey _secureKey) 保存指定的密钥
byte[] | sign(java.lang.String _keyName, byte[] _data) 使用指定名称的密钥计算指定的数据的签名
boolean | verify(java.lang.String _sKeyName, byte[] _data, byte[] _sign) 使用指定名称的密钥，验证指定数据和签名是否相符
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecureKeyMgr

public SecureKeyMgr()
方法详细信息

encrypt

public byte[] encrypt(java.lang.String _sKeyName,
                      byte[] _data)
               throws WCMException
使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。

参数：
sKeyName - 密钥的名称
bytes - 待加密的数据
返回：
密文数据
抛出：
WCMException - 如果发生错误

decrypt

public byte[] decrypt(java.lang.String _sKeyName,
                      byte[] _bytes)
               throws WCMException
使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。

参数：
_sKeyName - 密钥的名称
_bytes - 待解密的密文数据
返回：
明文数据
抛出：
WCMException - 如果发生错误

sign

public byte[] sign(java.lang.String _keyName,
                   byte[] _data)
            throws WCMException
使用指定名称的密钥计算指定的数据的签名

参数：
_sKeyName - 密钥的名称
_data - 待签名数据
返回：
签名数据
抛出：
WCMException - 如果发生错误

verify

public boolean verify(java.lang.String _sKeyName,
                      byte[] _data,
                      byte[] _sign)
               throws WCMException
使用指定名称的密钥，验证指定数据和签名是否相符

参数：
_sKeyName - 密钥的名称
_data - 待验证的数据
_sign - 签名数据
返回：
如果签名相符，返回 true ，否则返回 false
抛出：
WCMException - 如果发生错误

save

public SecureKey save(SecureKey _secureKey)
               throws WCMException
保存指定的密钥

参数：
_secureKey - 待保存的密钥
抛出：
WCMException - 如果操作失败

getKeys

public SecureKeys getKeys(WCMFilter _filter)
                   throws WCMException
获取当前系统中符合条件的密钥的集合

参数：
_filter -
返回：
过滤器，可选的查询条件，可以为 null
抛出：
WCMException - 如果操作失败

exportKey

public java.lang.String exportKey(java.lang.String _sKeyName,
                                  boolean _zIsPrivate)
                           throws WCMException
参数：
_zIsPrivate - 是否导出私钥。 如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
keyName -
返回：
抛出：
WCMException

exportKey

public java.lang.String exportKey(int _nKeyId,
                                  boolean _zIsPrivate)
                           throws WCMException
参数：
_nKeyId -
_zIsPrivate - 是否导出私钥。 如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecureKeys

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.security
类 SecureKeys

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.support.security.SecureKeys

public class SecureKeys
extends BaseObjs

TODO Add javadoc for SecureKeys 密钥对 SecureKey 象的集合

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
SecureKeys()
SecureKeys(int _initCapacity, int _incCapacity)
方法摘要
static SecureKeys | createNewInstance() 产生当前集合对象[SecureKeys]的实例
static SecureKeys | findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static SecureKeys | openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[SecureKeys]
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecureKeys

public SecureKeys()

SecureKeys

public SecureKeys(int _initCapacity,
                  int _incCapacity)
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final SecureKeys findByIds(java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（SecureKeys）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final SecureKeys openWCMObjs(WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[SecureKeys]

参数：
_filter - 指定的Filter
返回：
当前集合[SecureKeys]
抛出：
WCMException

createNewInstance

public static SecureKeys createNewInstance()
产生当前集合对象[SecureKeys]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecureKeyUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.support.security
类 SecureKeyUtil

java.lang.Object
    继承者  com.trs.infra.support.security.SecureKeyUtil

public class SecureKeyUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
SecureKeyUtil:工具函数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static java.lang.String[] | getCryptoImpls(java.lang.String serviceType)
static java.lang.String[] | getCryptoImplsBy(java.lang.String provName, java.lang.String serviceType)
static java.lang.String[] | getServiceTypes()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getServiceTypes

public static java.lang.String[] getServiceTypes()

getCryptoImpls

public static java.lang.String[] getCryptoImpls(java.lang.String serviceType)

getCryptoImplsBy

public static java.lang.String[] getCryptoImplsBy(java.lang.String provName,
                                                  java.lang.String serviceType)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.support.security.SecureKey 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.security.SecureKey
的使用

使用 SecureKey 的软件包
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.service |
com.trs.service.impl |

com.trs.infra.support.security 中 SecureKey 的使用

返回 SecureKey 的 com.trs.infra.support.security 中的方法
static SecureKey | SecureKey.createNewInstance() 产生当前对象[SecureKey]的实例
static SecureKey | SecureKey.findById(int _nId) 提取指定ID的对象
static SecureKey | SecureKey.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
static SecureKey | SecureKey.findByName(java.lang.String _sKeyName)
SecureKey | SecureKeyMgr.save(SecureKey _secureKey) 保存指定的密钥

参数类型为 SecureKey 的 com.trs.infra.support.security 中的方法
 SecureKey SecureKeyMgr.save(SecureKey _secureKey)
保存指定的密钥

com.trs.service 中 SecureKey 的使用

返回 SecureKey 的 com.trs.service 中的方法
SecureKey | ISecurityService.findKey(int _iKeyId) 在系统内查找指定ID的密钥
SecureKey | ISecurityService.findKey(java.lang.String _iKeyName) 在系统内查找指定名称的密钥

参数类型为 SecureKey 的 com.trs.service 中的方法
 void ISecurityService.saveKey(SecureKey _oKey)
保存指定的密钥

com.trs.service.impl 中 SecureKey 的使用

返回 SecureKey 的 com.trs.service.impl 中的方法
SecureKey | SecurityService.findKey(int _iKeyId)
SecureKey | SecurityService.findKey(java.lang.String _iKeyName)

参数类型为 SecureKey 的 com.trs.service.impl 中的方法
 void SecurityService.saveKey(SecureKey _oKey)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.security.SecureKeyMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.security.SecureKeyMgr
的使用

没有 com.trs.infra.support.security.SecureKeyMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.security.SecureKeys 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.security.SecureKeys
的使用

使用 SecureKeys 的软件包
com.trs.infra.support.security | 定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.service |
com.trs.service.impl |

com.trs.infra.support.security 中 SecureKeys 的使用

返回 SecureKeys 的 com.trs.infra.support.security 中的方法
static SecureKeys | SecureKeys.createNewInstance() 产生当前集合对象[SecureKeys]的实例
static SecureKeys | SecureKeys.findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
SecureKeys | SecureKeyMgr.getKeys(WCMFilter _filter) 获取当前系统中符合条件的密钥的集合
static SecureKeys | SecureKeys.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[SecureKeys]

com.trs.service 中 SecureKeys 的使用

返回 SecureKeys 的 com.trs.service 中的方法
 SecureKeys ISecurityService.getKeys(WCMFilter _filter)
获取当前系统中符合条件的密钥的集合

com.trs.service.impl 中 SecureKeys 的使用

返回 SecureKeys 的 com.trs.service.impl 中的方法
 SecureKeys SecurityService.getKeys(WCMFilter _filter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.support.security.SecureKeyUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.support.security.SecureKeyUtil
的使用

没有 com.trs.infra.support.security.SecureKeyUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IUpdateCommander

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.update
接口 IUpdateCommander

所有已知实现类：
ContentUpdateCommanderImpl, PublishUpdateCommderImpl, WcmHelpUpdate
public interface IUpdateCommander

Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commonder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 void doUpdate()

方法详细信息

doUpdate

void doUpdate()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.update
接口
IUpdateCommander
类
UpdateCommanderConfig
UpdateServer


com.trs.infra.update

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.update

接口摘要
IUpdateCommander Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commonder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
UpdateCommanderConfig | Title: TRS 内容协作平台（TRS WCM） Description: Update Commander Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UpdateServer | Title: TRS 内容协作平台（TRS WCM） Description: Update Server Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.update 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.update 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.update.UpdateServer
    • com.trs.infra.update.UpdateCommanderConfig (implements com.trs.infra.config.persistent.IConfigElement)

接口分层结构

  • com.trs.infra.update.IUpdateCommander


软件包 com.trs.infra.update 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.update
的使用

使用 com.trs.infra.update 的软件包
com.trs.components.common.publish
com.trs.components.wcm.content
com.trs.components.wcm.wcmx.help
com.trs.infra.update

com.trs.components.common.publish 使用的 com.trs.infra.update 中的类
IUpdateCommander
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commonder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 使用的 com.trs.infra.update 中的类
IUpdateCommander
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commonder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.help 使用的 com.trs.infra.update 中的类
IUpdateCommander
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commonder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.update 使用的 com.trs.infra.update 中的类
IUpdateCommander
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commonder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


UpdateCommanderConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.update
类 UpdateCommanderConfig

java.lang.Object
    继承者  com.trs.infra.update.UpdateCommanderConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class UpdateCommanderConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commander
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
UpdateCommanderConfig()
方法摘要
IUpdateCommander | getCommander()
java.lang.String | getCommanderClassName()
java.lang.String | getName() 获取配置对象的名称
void | setCommanderClassName(java.lang.String commanderClassName)
void | setName(java.lang.String _sName) 设置配置对象的名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UpdateCommanderConfig

public UpdateCommanderConfig()
方法详细信息

getCommanderClassName

public java.lang.String getCommanderClassName()
返回：

setCommanderClassName

public void setCommanderClassName(java.lang.String commanderClassName)
参数：
commanderClassName -

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getCommander

public IUpdateCommander getCommander()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UpdateServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.update
类 UpdateServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.update.UpdateServer
所有已实现的接口：
IServer
public class UpdateServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
Update Server
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
UpdateServer()
方法摘要
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UpdateServer

public UpdateServer()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.infra.update.IUpdateCommander 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.update.IUpdateCommander
的使用

使用 IUpdateCommander 的软件包
com.trs.components.common.publish
com.trs.components.wcm.content
com.trs.components.wcm.wcmx.help
com.trs.infra.update

com.trs.components.common.publish 中 IUpdateCommander 的使用

实现 IUpdateCommander 的 com.trs.components.common.publish 中的类
 class PublishUpdateCommderImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 中 IUpdateCommander 的使用

实现 IUpdateCommander 的 com.trs.components.wcm.content 中的类
 class ContentUpdateCommanderImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.help 中 IUpdateCommander 的使用

实现 IUpdateCommander 的 com.trs.components.wcm.wcmx.help 中的类
 class WcmHelpUpdate
Title: TRS 内容协作平台（TRS WCM）
Description:
Import wcmhelp data for WCM51-->WCM52
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.update 中 IUpdateCommander 的使用

返回 IUpdateCommander 的 com.trs.infra.update 中的方法
 IUpdateCommander UpdateCommanderConfig.getCommander()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.update.UpdateCommanderConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.update.UpdateCommanderConfig
的使用

没有 com.trs.infra.update.UpdateCommanderConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.update.UpdateServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.update.UpdateServer
的使用

没有 com.trs.infra.update.UpdateServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AttributesString

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 AttributesString

java.lang.Object
    继承者  com.trs.infra.util.AttributesString

public class AttributesString
extends java.lang.Object

字段摘要
static java.lang.String ATTRIBUTE_DELIM
属性之间的分割符
构造方法摘要
AttributesString()
AttributesString(java.lang.String _attributes)
直接使用属性字符串构造对象
方法摘要
boolean | containsName(java.lang.String _sName)
java.lang.String | getAttributes() 获得属性字符串
java.util.HashMap | getAttributesMap()
java.lang.String | getAttributeValue(java.lang.String _sName) 取指定名称的属性值 若没有找到该属性，则返回null.
java.lang.String[] | getAttributeValues(java.lang.String _sName)
java.lang.String | getDelim()
java.lang.String | getNameAt(int _nIndex)
java.util.List | getNameList()
static void | main(java.lang.String[] args)
void | putAttributeValue(java.lang.String _name, java.lang.String _value) 设置指定名称的属性值
void | putAttributeValue(java.lang.String _sName, java.lang.String _sValue, boolean _bAllowMultValue)
void | setAttributes(java.lang.String _attributes) 直接用属性字符串设置属性
void | setDelim(java.lang.String delim)
int | size()
java.lang.String | toString() 获得属性字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ATTRIBUTE_DELIM

public static final java.lang.String ATTRIBUTE_DELIM
属性之间的分割符

另请参见：
常量字段值
构造方法详细信息

AttributesString

public AttributesString()

AttributesString

public AttributesString(java.lang.String _attributes)
直接使用属性字符串构造对象

参数：
_attributes - 属性字符串（可忽略）
方法详细信息

toString

public java.lang.String toString()
获得属性字符串

覆盖：
类 java.lang.Object 中的 toString
返回：
属性字符串（String对象）

getAttributes

public java.lang.String getAttributes()
获得属性字符串

返回：
属性字符串（String对象）

setAttributes

public void setAttributes(java.lang.String _attributes)
直接用属性字符串设置属性

参数：
_attributes - 属性字符串

getAttributeValue

public java.lang.String getAttributeValue(java.lang.String _sName)
取指定名称的属性值 若没有找到该属性，则返回null.

参数：
_sName - 属性名称
返回：
属性值

getAttributeValues

public java.lang.String[] getAttributeValues(java.lang.String _sName)

putAttributeValue

public void putAttributeValue(java.lang.String _name,
                              java.lang.String _value)
设置指定名称的属性值

参数：
_name - 属性名（不区分大小写）；
_value - 属性值（字符串）

getAttributesMap

public java.util.HashMap getAttributesMap()
返回：

putAttributeValue

public void putAttributeValue(java.lang.String _sName,
                              java.lang.String _sValue,
                              boolean _bAllowMultValue)

getNameList

public java.util.List getNameList()
返回：

getDelim

public java.lang.String getDelim()
返回：

setDelim

public void setDelim(java.lang.String delim)
参数：
delim -

size

public int size()

containsName

public boolean containsName(java.lang.String _sName)

getNameAt

public java.lang.String getNameAt(int _nIndex)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BASE64DecoderStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 BASE64DecoderStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  com.trs.infra.util.BASE64DecoderStream
所有已实现的接口：
java.io.Closeable
public class BASE64DecoderStream
extends java.io.FilterInputStream

BASE64 解码输入流。 线程不安全。

作者：
最初反编译自 JavaMail,原始作者不祥.

构造方法摘要
BASE64DecoderStream(java.io.InputStream in)
使用指定的输入流创建BASE64DecoderStream对象， 即对输入流in进行解码。
方法摘要
int | available()
static byte[] | decode(byte[] inbuff) 解码BASE64数组，输入的字节数组中不能含有BASE64字符以外的字符。
static byte[] | decode(java.lang.String encoded) 解码BASE64编码的字符串，输入的字符串中不能含有BASE64字符以外的字符。
boolean | markSupported()
int | read()
int | read(byte[] b, int off, int len)
从类 java.io.FilterInputStream 继承的方法
close, mark, read, reset, skip
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BASE64DecoderStream

public BASE64DecoderStream(java.io.InputStream in)
使用指定的输入流创建BASE64DecoderStream对象， 即对输入流in进行解码。

参数：
in - 待解码的输入流
方法详细信息

decode

public static final byte[] decode(byte[] inbuff)
解码BASE64数组，输入的字节数组中不能含有BASE64字符以外的字符。该方法适用于解码少量数据。

参数：
inbuff - 待解码的字节数组
返回：
解码结果数组

decode

public static final byte[] decode(java.lang.String encoded)
解码BASE64编码的字符串，输入的字符串中不能含有BASE64字符以外的字符。该方法适用于解码少量数据。

参数：
encoded - BASE64编码的字符串
返回：
解码结果数组

available

public int available()
              throws java.io.IOException
覆盖：
类 java.io.FilterInputStream 中的 available
抛出：
java.io.IOException

markSupported

public boolean markSupported()
覆盖：
类 java.io.FilterInputStream 中的 markSupported

read

public int read()
         throws java.io.IOException
覆盖：
类 java.io.FilterInputStream 中的 read
抛出：
java.io.IOException

read

public int read(byte[] b,
                int off,
                int len)
         throws java.io.IOException
覆盖：
类 java.io.FilterInputStream 中的 read
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BASE64EncoderStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 BASE64EncoderStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  com.trs.infra.util.BASE64EncoderStream
所有已实现的接口：
java.io.Closeable, java.io.Flushable
public class BASE64EncoderStream
extends java.io.FilterOutputStream

BASE64 编码输入流。 线程不安全。

作者：
最初反编译自 JavaMail,原始作者不祥.

构造方法摘要
BASE64EncoderStream(java.io.OutputStream out)
使用指定的输出流和缺省的最大行长（76字符换行）创建BASE64编码流对象
BASE64EncoderStream(java.io.OutputStream out, int lin)
使用指定的输出流和指定的最大行长创建BASE64编码流对象
方法摘要
void | close()
static byte[] | encode(byte[] inbuff) 使用BASE64编码一个字节数组，输出数组中不会加入非BASE64字符。
void | flush()
void | write(byte[] b)
void | write(byte[] b, int off, int len)
void | write(int b)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BASE64EncoderStream

public BASE64EncoderStream(java.io.OutputStream out)
使用指定的输出流和缺省的最大行长（76字符换行）创建BASE64编码流对象

参数：
out - 指定的输出流

BASE64EncoderStream

public BASE64EncoderStream(java.io.OutputStream out,
                           int lin)
使用指定的输出流和指定的最大行长创建BASE64编码流对象

参数：
out - 指定的输出流
lin - 指定的最大行长
方法详细信息

encode

public static final byte[] encode(byte[] inbuff)
使用BASE64编码一个字节数组，输出数组中不会加入非BASE64字符。该方法适用于编码少量数据。

参数：
inbuff - 待编码的字节数组
返回：
编码结果数组

close

public void close()
           throws java.io.IOException
指定者：
接口 java.io.Closeable 中的 close
覆盖：
类 java.io.FilterOutputStream 中的 close
抛出：
java.io.IOException

flush

public void flush()
           throws java.io.IOException
指定者：
接口 java.io.Flushable 中的 flush
覆盖：
类 java.io.FilterOutputStream 中的 flush
抛出：
java.io.IOException

write

public void write(byte[] b,
                  int off,
                  int len)
           throws java.io.IOException
覆盖：
类 java.io.FilterOutputStream 中的 write
抛出：
java.io.IOException

write

public void write(byte[] b)
           throws java.io.IOException
覆盖：
类 java.io.FilterOutputStream 中的 write
抛出：
java.io.IOException

write

public void write(int b)
           throws java.io.IOException
覆盖：
类 java.io.FilterOutputStream 中的 write
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Base64Util

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 Base64Util

java.lang.Object
    继承者  com.trs.infra.util.Base64Util

public class Base64Util
extends java.lang.Object

Base64编码/解码工具类,编码后会加上特征前缀__encoded__;

作者：
wenyh

构造方法摘要
Base64Util()
方法摘要
static java.lang.String | decode(java.lang.String string) 解码指定的字符串
static java.lang.String | encode(java.lang.String string) 编码指定的字符串 注意:如果字符串以__encoded__开头,则认为是已编码的
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Base64Util

public Base64Util()
方法详细信息

encode

public static java.lang.String encode(java.lang.String string)
编码指定的字符串

注意:如果字符串以__encoded__开头,则认为是已编码的

参数：
string - 要编码的字符串
返回：
编码后的字符串
编码后的字符串会以__encoded开头作为编码的特征.如果编码过程出现异常,则是返回原内容

decode

public static java.lang.String decode(java.lang.String string)
解码指定的字符串

参数：
string - 指定要解码的字符串
返回：
解码后的字符串
如果字符串不是以__encoded__ 开头,则认为是没有编码过的字符.如果解码过程出现异常,则是返回原内容
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharsetDetector

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CharsetDetector

java.lang.Object
    继承者  com.trs.infra.util.CharsetDetector

public class CharsetDetector
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文件编码探测工具依赖于(chardet.jar)Mozzila的算法实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CharsetDetector()
方法摘要
static java.lang.String | detect(java.lang.String fn)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CharsetDetector

public CharsetDetector()
方法详细信息

detect

public static final java.lang.String detect(java.lang.String fn)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CImage

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CImage

java.lang.Object
    继承者  com.trs.infra.util.CImage

public class CImage
extends java.lang.Object

Title: photo manager Description: Your description Copyright: Copyright (c) 1998 Company: trs

版本：
作者：
yale

构造方法摘要
CImage()
方法摘要
 void createSmallImage(java.lang.String p_sSrcPicName, java.lang.String p_sDestPicName, int p_nSmallPicWidth)
 void drawWatermark(java.awt.Image p_Image, java.awt.Color p_Color, java.lang.String p_sWatermark, java.lang.String p_sDestFileName)
public int getSize(Image p_Image){ }
 void drawWatermark(java.awt.Image p_Image, java.awt.Color p_Color, java.lang.String p_sWatermark, java.lang.String p_sDestFileName, java.lang.String _sFont, int _nFontSize)
给图片加上水印
 int getHeight(java.awt.Image p_Image)
 int getWidth(java.awt.Image p_Image)
 java.awt.Image loadImage(java.lang.String p_PicFile)
static void main(java.lang.String[] args)
 void moveFile(java.lang.String p_srcFileName, java.lang.String p_destFileName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CImage

public CImage()
方法详细信息

loadImage

public java.awt.Image loadImage(java.lang.String p_PicFile)
                         throws java.io.IOException
抛出：
java.io.IOException

getWidth

public int getWidth(java.awt.Image p_Image)

getHeight

public int getHeight(java.awt.Image p_Image)

drawWatermark

public void drawWatermark(java.awt.Image p_Image,
                          java.awt.Color p_Color,
                          java.lang.String p_sWatermark,
                          java.lang.String p_sDestFileName)
                   throws java.io.IOException
public int getSize(Image p_Image){ }

抛出：
java.io.IOException

drawWatermark

public void drawWatermark(java.awt.Image p_Image,
                          java.awt.Color p_Color,
                          java.lang.String p_sWatermark,
                          java.lang.String p_sDestFileName,
                          java.lang.String _sFont,
                          int _nFontSize)
                   throws java.io.IOException
给图片加上水印

参数：
p_Image - 图片对象
p_Color - 颜色
p_sWatermark - 水印
p_sDestFileName - 目标文件
_sFont - 字体（可省略，默认为宋体）
_nFontSize - 字大小（可省略，默认为30）
抛出：
java.awt.AWTException
java.io.IOException

createSmallImage

public void createSmallImage(java.lang.String p_sSrcPicName,
                             java.lang.String p_sDestPicName,
                             int p_nSmallPicWidth)
                      throws java.io.IOException
抛出：
java.io.IOException

moveFile

public void moveFile(java.lang.String p_srcFileName,
                     java.lang.String p_destFileName)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMy3WLib

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMy3WLib

java.lang.Object
    继承者  com.trs.infra.util.CMy3WLib

public class CMy3WLib
extends java.lang.Object

构造方法摘要
CMy3WLib()
方法摘要
static ResponseBuddy | doGet(java.lang.String sURL, java.util.Map mContent) 向指定的sURL发送一个get请求
static ResponseBuddy | doGet(java.lang.String sURL, java.lang.String sContent) 向指定的sURL发送一个get请求
static ResponseBuddy | doPost(java.lang.String sURL, java.util.Map mContent) 向指定的sURL发送一个post请求
static ResponseBuddy | doPost(java.lang.String sURL, java.util.Map mContent, java.lang.String sEncoding)
static ResponseBuddy | doPost(java.lang.String sURL, java.lang.String sContent)
static ResponseBuddy | doPost(java.lang.String sURL, java.lang.String sContent, java.lang.String sEncoding)
static boolean | getFile(java.lang.String p_sSrcFileUrl) 访WEB链接
static boolean | getFile(java.lang.String p_sSrcFileUrl, java.lang.String p_sDstPathFileName) 获取WEB上文件
static boolean | getFile(java.lang.String p_sProtocol, java.lang.String p_sHost, int p_nPort, java.lang.String p_sFile, java.lang.String p_sDstPathFileName) 获取WEB上文件
static boolean | getFile(java.lang.String p_sProtocol, java.lang.String p_sHost, java.lang.String p_sFile, java.lang.String p_sDstPathFileName) 获取WEB上文件
static boolean | getFile(java.net.URL p_urlSrcFile) 访问指定的URL
static boolean | getFile(java.net.URL p_urlSrcFile, java.lang.String p_sDstPathFileName) 获取指定URL的源文件，并保存到本地目标文件 说明：若不指定目标文件，则抛弃获取结果
static java.net.URL | getURL(java.lang.String p_sSrcFileUrl) 获取URL对象
static java.lang.String | getURLContent(java.lang.String p_sSrcFileUrl) 获取指定URL的源文件，并保存到本地目标文件 说明：若不指定目标文件，则抛弃获取结果
static void | main(java.lang.String[] args)
static void | setProxyInfo(java.lang.String _sKey, java.lang.String _sValue) 设置代理服务器信息
static void | setTimeout(int timeout)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMy3WLib

public CMy3WLib()
方法详细信息

setProxyInfo

public static void setProxyInfo(java.lang.String _sKey,
                                java.lang.String _sValue)
设置代理服务器信息

参数：
_host - 代理服务器地址
_port - 代理服务器端口号
_user - 代理服务器用户名
_password - 代理服务器密码

getFile

public static boolean getFile(java.net.URL p_urlSrcFile)
                       throws CMyException
访问指定的URL

参数：
p_urlSrcFile - WEB源文件的URL对象
返回：
操作成功返回true；否则返回false
抛出：
CMyException

getFile

public static boolean getFile(java.net.URL p_urlSrcFile,
                              java.lang.String p_sDstPathFileName)
                       throws CMyException
获取指定URL的源文件，并保存到本地目标文件

说明：若不指定目标文件，则抛弃获取结果

参数：
p_urlSrcFile - WEB源文件的URL对象
p_sDstPathFileName - 保存到本地的文件名称（含路径）
返回：
操作成功返回true；否则返回false
抛出：
CMyException

getURLContent

public static java.lang.String getURLContent(java.lang.String p_sSrcFileUrl)
                                      throws java.lang.Exception
获取指定URL的源文件，并保存到本地目标文件

说明：若不指定目标文件，则抛弃获取结果

参数：
p_sSrcFileUrl - WEB源文件的URL对象
返回：
操作成功返回true；否则返回false
抛出：
CMyException
java.lang.Exception

getFile

public static boolean getFile(java.lang.String p_sSrcFileUrl)
                       throws CMyException
访WEB链接

参数：
p_sSrcFileUrl - WEB源文件名

如：http://images.sohu.com/foxanimal.gif

ftp://ftpserver/filename.ext

返回：
操作成功返回true；否则返回false
抛出：
CMyException

getURL

public static java.net.URL getURL(java.lang.String p_sSrcFileUrl)
                           throws java.lang.Exception
获取URL对象

参数：
p_sSrcFileUrl - WEB源文件名

如：http://images.sohu.com/foxanimal.gif

ftp://ftpserver/filename.ext

返回：
链接对象URL
抛出：
java.lang.Exception

getFile

public static boolean getFile(java.lang.String p_sSrcFileUrl,
                              java.lang.String p_sDstPathFileName)
                       throws CMyException
获取WEB上文件

参数：
p_sSrcFileUrl - WEB源文件名
p_sDstPathFileName - 目标文件名（包含路径）
返回：
操作成功返回true；否则返回false
抛出：
CMyException

getFile

public static boolean getFile(java.lang.String p_sProtocol,
                              java.lang.String p_sHost,
                              java.lang.String p_sFile,
                              java.lang.String p_sDstPathFileName)
                       throws CMyException
获取WEB上文件

参数：
p_sProtocol - 网络传输协议。如："http"
p_sHost - 主机地址
p_sFile - WEB源文件
p_sDstPathFileName - 目标文件名（包含路径）
返回：
操作成功返回true；否则返回false
抛出：
CMyException

getFile

public static boolean getFile(java.lang.String p_sProtocol,
                              java.lang.String p_sHost,
                              int p_nPort,
                              java.lang.String p_sFile,
                              java.lang.String p_sDstPathFileName)
                       throws CMyException
获取WEB上文件

参数：
p_sProtocol - 网络传输协议。如："http"
p_sHost - 主机地址
p_nPort - 端口号
p_sFile - 源文件名
p_sDstPathFileName - 目标文件名（包含路径）
返回：
操作成功返回true；否则返回false
抛出：
CMyException

doGet

public static ResponseBuddy doGet(java.lang.String sURL,
                                  java.util.Map mContent)
                           throws CMyException
向指定的sURL发送一个get请求

参数：
sURL - 发送的目标地址
mContent - 向目标地址发送的参数
抛出：
CMyException

doGet

public static ResponseBuddy doGet(java.lang.String sURL,
                                  java.lang.String sContent)
                           throws CMyException
向指定的sURL发送一个get请求

参数：
sURL - 发送的目标地址
sContent - 发送的内容
抛出：
CMyException

doPost

public static ResponseBuddy doPost(java.lang.String sURL,
                                   java.util.Map mContent)
                            throws CMyException
向指定的sURL发送一个post请求

参数：
sURL - 发送的目标地址
mParams - 向目标地址发送的参数
抛出：
CMyException

doPost

public static ResponseBuddy doPost(java.lang.String sURL,
                                   java.lang.String sContent)
                            throws CMyException
抛出：
CMyException

doPost

public static ResponseBuddy doPost(java.lang.String sURL,
                                   java.util.Map mContent,
                                   java.lang.String sEncoding)
                            throws CMyException
参数：
sURL -
mContent -
sEncoding -
抛出：
CMyException

doPost

public static ResponseBuddy doPost(java.lang.String sURL,
                                   java.lang.String sContent,
                                   java.lang.String sEncoding)
                            throws CMyException
参数：
sURL -
sContent -
sEncoding -
抛出：
CMyException

setTimeout

public static void setTimeout(int timeout)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyBeanConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyBeanConfig

java.lang.Object
    继承者  com.trs.infra.util.CMyXMLElement
        继承者  com.trs.infra.util.CMyBeanConfig

public class CMyBeanConfig
extends CMyXMLElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyBeanConfig()
方法摘要
static CMyBeanConfig[] | fromXMLFile(java.lang.String _sXMLFile)
java.lang.Object | getBean()
java.lang.String | getBeanId()
java.lang.String | getName()
java.lang.String | toString()
从类 com.trs.infra.util.CMyXMLElement 继承的方法
addChild, clear, getChild, getChildren, getChildren, getProperties, getPropertiesList, getProperty, getPropertyAsBoolean, getPropertyAsInt, getPropertyNames, getPropertyTrim, getPropertyTrim, getRequiredPropertyTrim, setName, setProperties, setProperty
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMyBeanConfig

public CMyBeanConfig()
方法详细信息

getBeanId

public java.lang.String getBeanId()

getName

public java.lang.String getName()
覆盖：
类 CMyXMLElement 中的 getName

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getBean

public java.lang.Object getBean()
                         throws WCMException
抛出：
WCMException

fromXMLFile

public static CMyBeanConfig[] fromXMLFile(java.lang.String _sXMLFile)
                                   throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyBitsValue

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyBitsValue

java.lang.Object
    继承者  com.trs.infra.util.CMyBitsValue
所有已实现的接口：
java.lang.Cloneable
直接已知子类：
RightValue
public class CMyBitsValue
extends java.lang.Object
implements java.lang.Cloneable

构造方法摘要
CMyBitsValue()
默认构造函数，用0初始化
CMyBitsValue(CMyBitsValue _myBitsValue)
使用CMyBitsValue初始化的构造函数
CMyBitsValue(long _lValue)
使用长整型数初始化的构造函数
CMyBitsValue(java.lang.String _sValue)
使用字符串初始化的构造函数
方法摘要
void | and(CMyBitsValue _myBitsValue) 按位进行“与”运算
void | and(long _value) 按位进行“与”运算
java.lang.Object | clone() 对象克隆
void | copy(CMyBitsValue _myBitsValue) 对象复制
boolean | getBit(int _index) 取指定位置的二进制值
static boolean | getBit(long _value, int _index) 取指定整型值（int/long）的指定bit位的值
static boolean | getBitOfInt(int _value, int _index) 取指定整型值（int/long）的指定bit位的值
int | getRealLength() 取二进制位的实际长度
long | getValue() 取二进制序列对应的长整型值
int | getValueAsInt() 取二进制序列对应的int值
static void | main(java.lang.String[] args)
void | or(CMyBitsValue _myBitsValue) 按位进行或运算
void | or(long _value) 按位进行或运算
CMyBitsValue | setBit(int _index, boolean _bValue) 设置指定bit位置的值
static long | setBit(long _value, int _index, boolean _bValue) 设置长整型数据中指定位置的bit值
void | setValue(long _nValue) 用整型值指定权限
void | setValue(java.lang.String _sValue) 用0/1字符串序列指定权限值 每位字符代表一种权限，'1'为1，其他为0
java.lang.String | toString() 将权限值按实际位数以二进制序列字符串输出
java.lang.String | toString(int _nLength) 将权限值按实际位数以二进制序列字符串输出
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMyBitsValue

public CMyBitsValue()
默认构造函数，用0初始化

CMyBitsValue

public CMyBitsValue(long _lValue)
使用长整型数初始化的构造函数

参数：
_lValue - 初始化值

CMyBitsValue

public CMyBitsValue(java.lang.String _sValue)
使用字符串初始化的构造函数

参数：
_sValue - 二进制字符串

CMyBitsValue

public CMyBitsValue(CMyBitsValue _myBitsValue)
使用CMyBitsValue初始化的构造函数

参数：
_myBitsValue -
方法详细信息

copy

public void copy(CMyBitsValue _myBitsValue)
对象复制

参数：
_myBitsValue -

clone

public java.lang.Object clone()
对象克隆

覆盖：
类 java.lang.Object 中的 clone
返回：

getBitOfInt

public static boolean getBitOfInt(int _value,
                                  int _index)
取指定整型值（int/long）的指定bit位的值

参数：
_value - 指定的整型值
_index - 指定的bit位
返回：

getBit

public static boolean getBit(long _value,
                             int _index)
取指定整型值（int/long）的指定bit位的值

参数：
_value - 指定的长整型值
_index - 指定的bit位
返回：

setBit

public static long setBit(long _value,
                          int _index,
                          boolean _bValue)
设置长整型数据中指定位置的bit值

参数：
_value - 长整型数据
_index - 指定位置
_bValue - true - 1;false - 0
返回：
设置值以后的长整型数

getValue

public long getValue()
取二进制序列对应的长整型值

返回：
二进制序列对应的长整型值

getValueAsInt

public int getValueAsInt()
取二进制序列对应的int值

返回：
二进制序列对应的int值

setValue

public void setValue(long _nValue)
用整型值指定权限

参数：
_nValue -

setValue

public void setValue(java.lang.String _sValue)
用0/1字符串序列指定权限值 每位字符代表一种权限，'1'为1，其他为0

参数：
_sValue - 二进制序列（字符串）。

getBit

public boolean getBit(int _index)
取指定位置的二进制值

参数：
_index - bit索引
返回：
1 - true ;0 - false

setBit

public CMyBitsValue setBit(int _index,
                           boolean _bValue)
设置指定bit位置的值

参数：
_index - bit索引
_bValue - true - 1;false - 0
返回：

and

public void and(CMyBitsValue _myBitsValue)
按位进行“与”运算

参数：
_myBitsValue - 运算对象（CMyBitsValue）

and

public void and(long _value)
按位进行“与”运算

参数：
_value - 运算对象（long）

or

public void or(CMyBitsValue _myBitsValue)
按位进行或运算

参数：
_myBitsValue - 运算对象（CMyBitsValue）

or

public void or(long _value)
按位进行或运算

参数：
_value - 运算对象（long）

getRealLength

public int getRealLength()
取二进制位的实际长度

返回：
二进制位的实际长度

toString

public java.lang.String toString()
将权限值按实际位数以二进制序列字符串输出

覆盖：
类 java.lang.Object 中的 toString
返回：

toString

public java.lang.String toString(int _nLength)
将权限值按实际位数以二进制序列字符串输出

参数：
_nLength -
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyClassConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyClassConfig

java.lang.Object
    继承者  com.trs.infra.util.CMyXMLElement
        继承者  com.trs.infra.util.CMyClassConfig
直接已知子类：
CMySMTPServer
public class CMyClassConfig
extends CMyXMLElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyClassConfig()
方法摘要
static CMyClassConfig[] | fromXMLFile(java.lang.String _sXMLFile)
java.lang.Object | getBean()
java.lang.String | getClassName()
java.lang.String | getName()
java.lang.String | toString()
从类 com.trs.infra.util.CMyXMLElement 继承的方法
addChild, clear, getChild, getChildren, getChildren, getProperties, getPropertiesList, getProperty, getPropertyAsBoolean, getPropertyAsInt, getPropertyNames, getPropertyTrim, getPropertyTrim, getRequiredPropertyTrim, setName, setProperties, setProperty
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMyClassConfig

public CMyClassConfig()
方法详细信息

getClassName

public java.lang.String getClassName()

getName

public java.lang.String getName()
覆盖：
类 CMyXMLElement 中的 getName

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getBean

public java.lang.Object getBean()
                         throws WCMException
抛出：
WCMException

fromXMLFile

public static CMyClassConfig[] fromXMLFile(java.lang.String _sXMLFile)
                                    throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyDateTime

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyDateTime

java.lang.Object
    继承者  com.trs.infra.util.CMyDateTime
所有已实现的接口：
java.io.Serializable, java.lang.Cloneable
public class CMyDateTime
extends java.lang.Object
implements java.lang.Cloneable, java.io.Serializable

另请参见：
序列化表格

字段摘要
static long | ADAY_MILLIS 1 天的时间数（毫秒数）
static int | DAY 日期/时间的各个部分标识：日（3）
static int | DAY_OF_MONTH 当月天数（13）
static int | DAY_OF_YEAR 当年天数（15）
static java.lang.String | DEF_DATE_FORMAT_PRG 默认日期字符串格式 "yyyy-MM-dd" （用于java程序）
static java.lang.String | DEF_DATETIME_FORMAT_DB 默认日时字符串格式 "YYYY-MM-DD HH24:MI:SS" （用于Oracle DB）
static java.lang.String | DEF_DATETIME_FORMAT_PRG 默认日时字符串格式 "yyyy-MM-dd HH:mm:ss" （用于java程序）
static java.lang.String | DEF_TIME_FORMAT_PRG 默认时间字符串格式 "HH:mm:ss" （用于java程序）
static int | FORMAT_DEFAULT 日时字符串格式：默认格式
static int | FORMAT_LONG 日时字符串格式：长格式（如：年份用4位表示）
static int | FORMAT_SHORT 日时字符串格式：短格式（如：年份用2位表示）
static int | HOUR 日期/时间的各个部分标识：时（4）
static int | MINUTE 日期/时间的各个部分标识：分（5）
static int | MONTH 日期/时间的各个部分标识：月（2）
static java.lang.String[] | MONTHS
static int | QUATER 日期/时间的各个部分标识：一刻钟（11）
static int | SECOND 日期/时间的各个部分标识：秒（6）
static int | WEEK 日期/时间的各个部分标识：一周（12）
static int | WEEK_OF_MONTH 当月周数（14）
static int | WEEK_OF_YEAR 当月周数（16）
static java.lang.String[] | WEEKS
static int | YEAR 日期/时间的各个部分标识：年（1）
构造方法摘要
CMyDateTime()
默认构造函数
CMyDateTime(long p_lDate)
使用长整型的数构造日期对象
方法摘要
 java.lang.Object clone()
对象克隆
 long compareTo(CMyDateTime p_mydtAnother)
时间比较
 long compareTo(java.util.Date p_dtAnother)
时间比较
 CMyDateTime dateAdd(int p_nField, int p_nAdd)
日期时间增/减函数
 long dateDiff_month(java.util.Date p_dtAnother)
计算当前时间对象与指定时间的【月】差
 long dateDiff(int p_nPart, CMyDateTime p_mydtAnother)
取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差
 long dateDiff(int p_nPart, java.util.Date p_dtAnother)
取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差
 boolean equals(java.lang.Object _another)
Returns true if this datetime equals with the specified one.
static java.lang.String extractDateFormat(java.lang.String _sValue)
提取 日期 字符串数据的格式
static java.lang.String extractDateTimeFormat(java.lang.String _sValue)
提取 日期时间 字符串数据的格式
static java.lang.String extractTimeFormat(java.lang.String _sValue)
提取 时间 字符串数据的格式
static java.lang.String formatTimeUsed(long iMillis)
把以毫秒计算的使用时间格式化为“xxx分xx秒”的格式
 int get(int p_nField)
日期/时间的分解
 java.util.Date getDateTime()
将当前对象转换为java.util.Date对象
 java.lang.String getDateTimeAsString()
输出格式化的日期时间字符串
格式：由setDateTimeFormat指定
 java.lang.String getDateTimeAsString(java.lang.String p_sFormat)
获取格式化的日期时间字符串
 int getDay()
获取当前对象中的【日】的部分
 int getDayOfWeek()
取当前日期是所在week的第几天
说明：一个礼拜的第一天为Monday(0)，最后一天为Sunday(6)
 int getHour()
获取当前对象中的【小时】的部分
 int getMinute()
获取当前对象中的【分】的部分
 int getMonth()
获取当前对象中的【月】的部分
 int getSecond()
获取当前对象中的【秒】的部分
static java.lang.String getStr(java.lang.Object _dtTime, java.lang.String _sFormat)
 long getTimeInMillis()
获取时间值（毫秒数）
static int getTimeZoneRawOffset()
取当前时区差值(单位：毫秒)
如：东8区，getTimeZoneRawOffset()=1000*60*60*8=28800000
 int getWeekCountsOfMonth(boolean _bSundayStart)
 int getYear()
获取当前对象中的【年】的部分
 boolean isLeapYear()
 boolean isNull()
判断时间对象是否为空
 boolean isToday()
static void main(java.lang.String[] args)
static CMyDateTime now()
获取值为系统当前时间的CMyDateTime对象
 boolean setDate(java.sql.Date p_dDate)
设置日期值
说明：若当前日期时间非空，则仅改变日期值，时间值保持不变
 void setDateTime(java.util.Date p_dtDate)
使用 java.util.Date 对象设置日期和时间
 void setDateTimeFormat(java.lang.String p_sFormat)
设置日期时间字符串格式
 void setDateTimeWithCurrentTime()
设置日期和时间为系统当前日期时间
 void setDateTimeWithRs(java.sql.ResultSet p_rsData, int p_nFieldIndex)
从记录集当前行读取指定日期/时间字段的值
 void setDateTimeWithRs(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName)
从记录集当前行读取指定日期/时间字段的值
 boolean setDateTimeWithString(java.lang.String _sValue)
使用未知格式的字符串值设置日期时间
 boolean setDateTimeWithString(java.lang.String p_sValue, java.lang.String p_sFormat)
使用字符串设置日期和时间
 void setDateTimeWithTimestamp(java.sql.Timestamp p_tsDateTime)
使用Timestamp对象设置日期和时间
 boolean setDateWithString(java.lang.String p_sDateValue, int p_nFormatType)
使用字符串设置日期值
 boolean setTime(java.sql.Time p_tTime)
设置时间值
说明：若当前日期时间非空，则仅改变时间值，日期值保持不变
 boolean setTimeWithString(java.lang.String p_sTimeValue, int p_nFormatType)
使用字符串设置时间值
 boolean testDateFormat(java.lang.String _sFieldValue)
测试日期格式是否合法
 java.sql.Date toDate()
转化为java.sq.Date型数据
 java.lang.String toString()
 java.lang.String toString(java.lang.String p_sFormat)
将日期数据转化为指定格式的字符串
 java.lang.String toString(java.lang.String sFormat, java.lang.String sLocaleId, java.lang.String sTimezoneId)
 java.sql.Time toTime()
转化为java.sql.Time型数据
 java.sql.Timestamp toTimestamp()
转化为java.sql.Timestamp型数据
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

FORMAT_DEFAULT

public static final int FORMAT_DEFAULT
日时字符串格式：默认格式

另请参见：
常量字段值

FORMAT_LONG

public static final int FORMAT_LONG
日时字符串格式：长格式（如：年份用4位表示）

另请参见：
常量字段值

FORMAT_SHORT

public static final int FORMAT_SHORT
日时字符串格式：短格式（如：年份用2位表示）

另请参见：
常量字段值

DEF_DATE_FORMAT_PRG

public static final java.lang.String DEF_DATE_FORMAT_PRG
默认日期字符串格式 "yyyy-MM-dd" （用于java程序）

另请参见：
常量字段值

DEF_TIME_FORMAT_PRG

public static final java.lang.String DEF_TIME_FORMAT_PRG
默认时间字符串格式 "HH:mm:ss" （用于java程序）

另请参见：
常量字段值

DEF_DATETIME_FORMAT_PRG

public static final java.lang.String DEF_DATETIME_FORMAT_PRG
默认日时字符串格式 "yyyy-MM-dd HH:mm:ss" （用于java程序）

另请参见：
常量字段值

DEF_DATETIME_FORMAT_DB

public static final java.lang.String DEF_DATETIME_FORMAT_DB
默认日时字符串格式 "YYYY-MM-DD HH24:MI:SS" （用于Oracle DB）

另请参见：
常量字段值

YEAR

public static final int YEAR
日期/时间的各个部分标识：年（1）

另请参见：
常量字段值

MONTH

public static final int MONTH
日期/时间的各个部分标识：月（2）

另请参见：
常量字段值

DAY

public static final int DAY
日期/时间的各个部分标识：日（3）

另请参见：
常量字段值

HOUR

public static final int HOUR
日期/时间的各个部分标识：时（4）

另请参见：
常量字段值

MINUTE

public static final int MINUTE
日期/时间的各个部分标识：分（5）

另请参见：
常量字段值

SECOND

public static final int SECOND
日期/时间的各个部分标识：秒（6）

另请参见：
常量字段值

QUATER

public static final int QUATER
日期/时间的各个部分标识：一刻钟（11）

另请参见：
常量字段值

WEEK

public static final int WEEK
日期/时间的各个部分标识：一周（12）

另请参见：
常量字段值

DAY_OF_MONTH

public static final int DAY_OF_MONTH
当月天数（13）

另请参见：
常量字段值

WEEK_OF_MONTH

public static final int WEEK_OF_MONTH
当月周数（14）

另请参见：
常量字段值

DAY_OF_YEAR

public static final int DAY_OF_YEAR
当年天数（15）

另请参见：
常量字段值

WEEK_OF_YEAR

public static final int WEEK_OF_YEAR
当月周数（16）

另请参见：
常量字段值

ADAY_MILLIS

public static final long ADAY_MILLIS
1 天的时间数（毫秒数）

另请参见：
常量字段值

MONTHS

public static final java.lang.String[] MONTHS

WEEKS

public static final java.lang.String[] WEEKS
构造方法详细信息

CMyDateTime

public CMyDateTime()
默认构造函数

CMyDateTime

public CMyDateTime(long p_lDate)
使用长整型的数构造日期对象

参数：
p_lDate -
方法详细信息

now

public static CMyDateTime now()
获取值为系统当前时间的CMyDateTime对象

返回：

isNull

public boolean isNull()
判断时间对象是否为空

返回：

getTimeInMillis

public long getTimeInMillis()
获取时间值（毫秒数）

返回：

getTimeZoneRawOffset

public static int getTimeZoneRawOffset()
取当前时区差值(单位：毫秒)
如：东8区，getTimeZoneRawOffset()=1000*60*60*8=28800000

返回：

compareTo

public long compareTo(java.util.Date p_dtAnother)
时间比较

参数：
p_dtAnother - 待比较的时间对象：java.util.Date对象
返回：
两者之间的时间差（毫秒数）。

compareTo

public long compareTo(CMyDateTime p_mydtAnother)
时间比较

参数：
p_mydtAnother - 待比较的时间对象：CMyDateTime对象
返回：
两者之间的时间差（毫秒数）。

dateDiff

public long dateDiff(int p_nPart,
                     CMyDateTime p_mydtAnother)
              throws CMyException
取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差

参数：
p_nPart - 定义返回值的类型（CMyDateTime.YEAR等）
p_mydtAnother - 指定的时间对象：CMyDateTime
返回：
@throws CMyException
抛出：
CMyException

dateDiff

public long dateDiff(int p_nPart,
                     java.util.Date p_dtAnother)
              throws CMyException
取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差

参数：
p_nPart - 定义返回值的类型（CMyDateTime.YEAR等）
p_dtAnother - 指定的时间对象：java.util.Date
返回：
@throws CMyException
抛出：
CMyException

dateDiff_month

public long dateDiff_month(java.util.Date p_dtAnother)
计算当前时间对象与指定时间的【月】差

参数：
p_dtAnother - 指定的时间对象：
返回：

get

public int get(int p_nField)
        throws CMyException
日期/时间的分解

参数：
p_nField - 指定域（年/月/日/小时/分/秒/星期）编号（定义在CMyDateTime.YEAR）
返回：
@throws CMyException
抛出：
CMyException

getYear

public int getYear()
            throws CMyException
获取当前对象中的【年】的部分

返回：
@throws CMyException
抛出：
CMyException

getMonth

public int getMonth()
             throws CMyException
获取当前对象中的【月】的部分

返回：
@throws CMyException
抛出：
CMyException

getDay

public int getDay()
           throws CMyException
获取当前对象中的【日】的部分

返回：
@throws CMyException
抛出：
CMyException

getHour

public int getHour()
            throws CMyException
获取当前对象中的【小时】的部分

返回：
@throws CMyException
抛出：
CMyException

getMinute

public int getMinute()
              throws CMyException
获取当前对象中的【分】的部分

返回：
@throws CMyException
抛出：
CMyException

getSecond

public int getSecond()
              throws CMyException
获取当前对象中的【秒】的部分

返回：
@throws CMyException
抛出：
CMyException

getDayOfWeek

public int getDayOfWeek()
                 throws CMyException
取当前日期是所在week的第几天
说明：一个礼拜的第一天为Monday(0)，最后一天为Sunday(6)

返回：
@throws CMyException
抛出：
CMyException

dateAdd

public CMyDateTime dateAdd(int p_nField,
                           int p_nAdd)
                    throws CMyException
日期时间增/减函数

参数：
p_nField - 指定域（例如CMyDateTime.YEAR等）
p_nAdd - 增加数目（负值为减）
返回：
返回当前对象本身
抛出：
CMyException

clone

public java.lang.Object clone()
对象克隆

覆盖：
类 java.lang.Object 中的 clone
返回：

getDateTime

public java.util.Date getDateTime()
将当前对象转换为java.util.Date对象

返回：

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
另请参见：
String toString( String p_sFormat )

toString

public java.lang.String toString(java.lang.String p_sFormat)
将日期数据转化为指定格式的字符串

参数：
p_sFormat - 指定的格式（例如"yyyy-MM-dd HH:mm:ss"）可省略，默认为"yyyy-MM-dd HH:mm:ss"
返回：

toString

public java.lang.String toString(java.lang.String sFormat,
                                 java.lang.String sLocaleId,
                                 java.lang.String sTimezoneId)

toDate

public java.sql.Date toDate()
转化为java.sq.Date型数据

返回：

toTime

public java.sql.Time toTime()
转化为java.sql.Time型数据

返回：

toTimestamp

public java.sql.Timestamp toTimestamp()
转化为java.sql.Timestamp型数据

返回：

setDateTime

public void setDateTime(java.util.Date p_dtDate)
使用 java.util.Date 对象设置日期和时间

参数：
p_dtDate - java.util.Date 对象

setDateTimeWithString

public boolean setDateTimeWithString(java.lang.String p_sValue,
                                     java.lang.String p_sFormat)
                              throws CMyException
使用字符串设置日期和时间

参数：
p_sValue - 日期和时间字符串
p_sFormat - 日期和时间字符串格式
返回：
@throws CMyException
抛出：
CMyException

setDateTimeWithCurrentTime

public void setDateTimeWithCurrentTime()
设置日期和时间为系统当前日期时间

setDateTimeWithTimestamp

public void setDateTimeWithTimestamp(java.sql.Timestamp p_tsDateTime)
                              throws CMyException
使用Timestamp对象设置日期和时间

参数：
p_tsDateTime - java.sql.Timestamp对象
抛出：
CMyException

setDateTimeWithRs

public void setDateTimeWithRs(java.sql.ResultSet p_rsData,
                              int p_nFieldIndex)
                       throws CMyException
从记录集当前行读取指定日期/时间字段的值

参数：
p_rsData - java.sql.ResultSet对象
p_nFieldIndex - 指定Date字段的位置
抛出：
CMyException

setDateTimeWithRs

public void setDateTimeWithRs(java.sql.ResultSet p_rsData,
                              java.lang.String p_sFieldName)
                       throws CMyException
从记录集当前行读取指定日期/时间字段的值

参数：
p_rsData - java.sql.ResultSet对象
p_sFieldName - 指定Date字段名称
抛出：
CMyException

setDate

public boolean setDate(java.sql.Date p_dDate)
                throws CMyException
设置日期值
说明：若当前日期时间非空，则仅改变日期值，时间值保持不变

参数：
p_dDate -
返回：
@throws CMyException
抛出：
CMyException

setTime

public boolean setTime(java.sql.Time p_tTime)
                throws CMyException
设置时间值
说明：若当前日期时间非空，则仅改变时间值，日期值保持不变

参数：
p_tTime -
返回：
@throws CMyException
抛出：
CMyException

setDateWithString

public boolean setDateWithString(java.lang.String p_sDateValue,
                                 int p_nFormatType)
                          throws CMyException
使用字符串设置日期值

参数：
p_sDateValue - 日期值字符串
p_nFormatType - 日期格式类型
返回：
@throws CMyException 若格式不正确，则抛出异常
抛出：
CMyException

setTimeWithString

public boolean setTimeWithString(java.lang.String p_sTimeValue,
                                 int p_nFormatType)
                          throws CMyException
使用字符串设置时间值

参数：
p_sTimeValue - 时间值字符串
p_nFormatType - 时间格式类型（例如CMyDateTime.FORMAT_LONG等）
返回：
@throws CMyException 若格式不正确，则抛出异常
抛出：
CMyException

setDateTimeFormat

public void setDateTimeFormat(java.lang.String p_sFormat)
设置日期时间字符串格式

参数：
p_sFormat - 指定格式（例如："yyyy-MM-dd HH:mm:ss"）

getDateTimeAsString

public java.lang.String getDateTimeAsString(java.lang.String p_sFormat)
                                     throws CMyException
获取格式化的日期时间字符串

参数：
p_sFormat - 指定日期时间字符串格式（例如："yyyy-MM-dd HH:mm:ss"）
返回：
@throws CMyException
抛出：
CMyException

getDateTimeAsString

public java.lang.String getDateTimeAsString()
                                     throws CMyException
输出格式化的日期时间字符串
格式：由setDateTimeFormat指定

返回：
若日期时间为空，或者格式化对象m_dtFormater为空，返回null.
抛出：
CMyException

extractDateTimeFormat

public static java.lang.String extractDateTimeFormat(java.lang.String _sValue)
提取 日期时间 字符串数据的格式

参数：
_sValue - 指定的日期时间字符串
返回：
若正确解析，则返回日时字符串的格式字符串；否则返回null。

extractDateFormat

public static java.lang.String extractDateFormat(java.lang.String _sValue)
提取 日期 字符串数据的格式

参数：
_sValue - 指定的日期字符串
返回：
若正确解析，则返回日期字符串的格式字符串；否则返回null。

extractTimeFormat

public static java.lang.String extractTimeFormat(java.lang.String _sValue)
提取 时间 字符串数据的格式

参数：
_sValue - 指定的时间字符串
返回：
若正确解析，则返回时间字符串的格式字符串；否则返回null。

setDateTimeWithString

public boolean setDateTimeWithString(java.lang.String _sValue)
                              throws CMyException
使用未知格式的字符串值设置日期时间

参数：
_sValue - 指定的日期时间值（字符串）
返回：
若设置成功，则返回true；否则返回false.
抛出：
CMyException - 解析日期时间值（字符串）可能抛出异常

formatTimeUsed

public static final java.lang.String formatTimeUsed(long iMillis)
把以毫秒计算的使用时间格式化为“xxx分xx秒”的格式

参数：
iTimeMillis - 毫秒数
返回：
格式化的时间

getStr

public static java.lang.String getStr(java.lang.Object _dtTime,
                                      java.lang.String _sFormat)

main

public static void main(java.lang.String[] args)

isLeapYear

public boolean isLeapYear()
                   throws CMyException
抛出：
CMyException

isToday

public boolean isToday()

getWeekCountsOfMonth

public int getWeekCountsOfMonth(boolean _bSundayStart)
                         throws CMyException
抛出：
CMyException

equals

public boolean equals(java.lang.Object _another)
Returns true if this datetime equals with the specified one.

覆盖：
类 java.lang.Object 中的 equals
参数：
_another - another object to compare
返回：
true if this datetime equals with the specified one.

testDateFormat

public boolean testDateFormat(java.lang.String _sFieldValue)
测试日期格式是否合法

参数：
_sFieldValue -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyDecimalBuddy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyDecimalBuddy

java.lang.Object
    继承者  com.trs.infra.util.CMyDecimalBuddy

public final class CMyDecimalBuddy
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
提供浮点数的四则运算
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static double | add(double augend, double addend) 加法运算。
static double | div(double devidend, double divisor) 除法运算，以默认的精度（小数点后六位）进行四舍五入
static double | div(double diviend, double divisor, int precision) 除法运算，以指定的精度进行四舍五入
static double | mul(double feciend, double multiplier) 乘法运算。
static double | round(double digit, int precision) 小数位四舍五入
static double | sub(double minuend, double subtrahend) 减法运算。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

add

public static double add(double augend,
                         double addend)
加法运算。

参数：
augend - 被加数
addend - 加数
返回：
和

sub

public static double sub(double minuend,
                         double subtrahend)
减法运算。

参数：
minuend - 被减数
subtrahend - 减数
返回：
差

mul

public static double mul(double feciend,
                         double multiplier)
乘法运算。

参数：
feciend - 被乘数
multiplier - 乘数
返回：
积

div

public static double div(double devidend,
                         double divisor)
除法运算，以默认的精度（小数点后六位）进行四舍五入

参数：
devidend - 被除数
divisor - 除数
返回：
商

div

public static double div(double diviend,
                         double divisor,
                         int precision)
除法运算，以指定的精度进行四舍五入

参数：
diviend - 被除数
divisor - 除数
precision - 精度，即精确到小数点以后几位
返回：
商

round

public static double round(double digit,
                           int precision)
小数位四舍五入

参数：
digit - 需要四舍五入的数字
precision - 小数点后保留几位
返回：
四舍五入后的结果
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyDOM4jHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyDOM4jHelper

java.lang.Object
    继承者  com.trs.infra.util.CMyDOM4jHelper

public class CMyDOM4jHelper
extends java.lang.Object

构造方法摘要
CMyDOM4jHelper()
方法摘要
static org.dom4j.Element | buildXmlFile(java.lang.String _sXmlFile, java.lang.String _sXslFile)
static org.dom4j.Document | makeXMLDocument(org.dom4j.Element _element, java.lang.String _XSLFileName)
static void | toXMLFile(org.dom4j.Element _element, java.lang.String _sXMLEncoding, java.lang.String _sXMLFile, java.lang.String _XSLFileName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyDOM4jHelper

public CMyDOM4jHelper()
方法详细信息

buildXmlFile

public static org.dom4j.Element buildXmlFile(java.lang.String _sXmlFile,
                                             java.lang.String _sXslFile)
                                      throws WCMException
抛出：
WCMException

toXMLFile

public static void toXMLFile(org.dom4j.Element _element,
                             java.lang.String _sXMLEncoding,
                             java.lang.String _sXMLFile,
                             java.lang.String _XSLFileName)
                      throws WCMException
抛出：
WCMException

makeXMLDocument

public static org.dom4j.Document makeXMLDocument(org.dom4j.Element _element,
                                                 java.lang.String _XSLFileName)
                                          throws javax.xml.transform.TransformerFactoryConfigurationError,
                                                 WCMException
抛出：
javax.xml.transform.TransformerFactoryConfigurationError
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyEncrypt

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyEncrypt

java.lang.Object
    继承者  com.trs.infra.util.CMyEncrypt

public class CMyEncrypt
extends java.lang.Object

字段摘要
 java.lang.String digestHexStr
构造方法摘要
CMyEncrypt()
默认的构造函数
方法摘要
static long | b2iu(byte b) 把byte值按照不考虑正负号的原则的＂升位＂
static java.lang.String | byteHEX(byte ib) 用来把一个byte类型的数转换成十六进制的ASCII表示，
java.lang.String | getMD5OfStr(java.lang.String inbuf) 获取经过MD5加密后的结果
static void | main(java.lang.String[] args)
static java.lang.String | RASDecrypt(java.lang.String _sSrc)
static java.lang.String | RASEncrypt(java.lang.String _sSrc)
static java.lang.String | setAnotherChar(java.lang.String _sSecret) 设置另一种加密算法
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

digestHexStr

public java.lang.String digestHexStr
构造方法详细信息

CMyEncrypt

public CMyEncrypt()
默认的构造函数

方法详细信息

getMD5OfStr

public java.lang.String getMD5OfStr(java.lang.String inbuf)
获取经过MD5加密后的结果

参数：
inbuf - 需要进行加密的字符串
返回：

b2iu

public static long b2iu(byte b)
把byte值按照不考虑正负号的原则的＂升位＂

参数：
b - byte值
返回：

byteHEX

public static java.lang.String byteHEX(byte ib)
用来把一个byte类型的数转换成十六进制的ASCII表示，

参数：
ib - byte值
返回：

setAnotherChar

public static java.lang.String setAnotherChar(java.lang.String _sSecret)
设置另一种加密算法

参数：
_sSecret - 加密算法字符串
返回：

RASEncrypt

public static java.lang.String RASEncrypt(java.lang.String _sSrc)

RASDecrypt

public static java.lang.String RASDecrypt(java.lang.String _sSrc)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyErrors

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyErrors

java.lang.Object
    继承者  com.trs.infra.util.CMyErrors

public class CMyErrors
extends java.lang.Object

构造方法摘要
CMyErrors()
默认构造函数
方法摘要
CMyErrors | add(CMyErrors _errors) 添加错误
CMyErrors | add(java.lang.Exception _ex) 添加错误
CMyErrors | add(java.lang.String _sError) 添加错误
CMyErrors | add(java.lang.String _sInfo, java.lang.Exception _ex)
CMyErrors | clear() 清除错误列表
java.lang.Object | getAt(int _index) 取指定位置的错误信息对象
java.util.Vector | getErrors() 取所有错误列表
boolean | isEmpty() 判断是否为空
static void | main(java.lang.String[] args)
int | size() 取错误总数
java.lang.String | toString()
java.lang.String | toString(boolean _bIncludingNo) 输出错误信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMyErrors

public CMyErrors()
默认构造函数

方法详细信息

add

public CMyErrors add(java.lang.String _sError)
添加错误

参数：
_sError - 错误描述字符串
返回：

add

public CMyErrors add(java.lang.Exception _ex)
添加错误

参数：
_ex - 异常对象
返回：

add

public CMyErrors add(java.lang.String _sInfo,
                     java.lang.Exception _ex)

add

public CMyErrors add(CMyErrors _errors)
添加错误

参数：
_errors - 错误对象
返回：

size

public int size()
取错误总数

返回：

isEmpty

public boolean isEmpty()
判断是否为空

返回：

getErrors

public java.util.Vector getErrors()
取所有错误列表

返回：
所有错误列表(Vector)

getAt

public java.lang.Object getAt(int _index)
取指定位置的错误信息对象

参数：
_index - 指定位置
返回：

clear

public CMyErrors clear()
清除错误列表

返回：
对象本身

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
另请参见：
String toString( boolean _bIncludingNo )

toString

public java.lang.String toString(boolean _bIncludingNo)
输出错误信息

参数：
_bIncludingNo - 输出字符串时，每个错误是否输出序号，可省略，默认输出
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.infra.util.CMyException
所有已实现的接口：
java.io.Serializable
直接已知子类：
CMyMailException, ConvertException, WCMException
public class CMyException
extends java.lang.Exception

Title: TRS 内容协作平台（TRS WCM）

Description:

class CMyException —— 异常对象的定义和实现

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
CMyException(int _errNo)
构造函数
CMyException(int _errNo, java.lang.String _sMsg)
构造函数
CMyException(int _errNo, java.lang.String _sMsg, java.lang.Throwable _rootCause)
构造函数
CMyException(java.lang.String _sMsg)
构造函数
CMyException(java.lang.String _sMsg, java.lang.Throwable _rootCause)
构造函数
方法摘要
int | getErrNo() 获取错误编号
java.lang.String | getErrNoMsg()
java.lang.String | getLocalizedMessage() 取错误消息，若rootCause非空，则同时输出rootCause的错误消息
java.lang.String | getMessage() 取错误消息，若rootCause非空，则同时输出rootCause的错误消息
java.lang.String | getMyMessage() 仅仅取该异常自身的消息
java.lang.Throwable | getRootCause() 获取异常对象
java.lang.String | getStackTraceText()
static java.lang.String | getStackTraceText(java.lang.Throwable _ex) 取异常堆栈信息
static void | main(java.lang.String[] args)
void | printStackTrace(java.io.PrintStream _ps)
void | printStackTrace(java.io.PrintWriter _pw) 向指定设备打印错误信息
java.lang.String | toString() 将异常信息输出为字符串
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getStackTrace, initCause, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMyException

public CMyException(int _errNo)
构造函数

参数：
_errNo - 错误编号

CMyException

public CMyException(int _errNo,
                    java.lang.String _sMsg)
构造函数

参数：
_errNo - 错误编号
_sMsg - 错误描述

CMyException

public CMyException(java.lang.String _sMsg)
构造函数

参数：
_sMsg - 错误描述

CMyException

public CMyException(int _errNo,
                    java.lang.String _sMsg,
                    java.lang.Throwable _rootCause)
构造函数

参数：
_errNo - 错误编号
_sMsg - 错误描述
_rootCause - 异常对象

CMyException

public CMyException(java.lang.String _sMsg,
                    java.lang.Throwable _rootCause)
构造函数

参数：
_sMsg - 错误描述
_rootCause - 异常对象
方法详细信息

getErrNo

public int getErrNo()
获取错误编号

返回：

getRootCause

public java.lang.Throwable getRootCause()
获取异常对象

返回：

getErrNoMsg

public java.lang.String getErrNoMsg()

getMyMessage

public java.lang.String getMyMessage()
仅仅取该异常自身的消息

返回：
String 当前异常的信息

toString

public java.lang.String toString()
将异常信息输出为字符串

覆盖：
类 java.lang.Throwable 中的 toString
返回：
字符串表示的异常信息

getMessage

public java.lang.String getMessage()
取错误消息，若rootCause非空，则同时输出rootCause的错误消息

覆盖：
类 java.lang.Throwable 中的 getMessage
返回：
String 错误信息

getLocalizedMessage

public java.lang.String getLocalizedMessage()
取错误消息，若rootCause非空，则同时输出rootCause的错误消息

覆盖：
类 java.lang.Throwable 中的 getLocalizedMessage
返回：
String 错误信息

printStackTrace

public void printStackTrace(java.io.PrintStream _ps)
覆盖：
类 java.lang.Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(java.io.PrintWriter _pw)
向指定设备打印错误信息

覆盖：
类 java.lang.Throwable 中的 printStackTrace
参数：
_pw - 指定设备java.io.PrintWriter对象

getStackTraceText

public java.lang.String getStackTraceText()

getStackTraceText

public static java.lang.String getStackTraceText(java.lang.Throwable _ex)
取异常堆栈信息

返回：
异常堆栈信息

main

public static final void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyFile

java.lang.Object
    继承者  com.trs.infra.util.CMyFile

public class CMyFile
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM） Description: class CMyFile —— 文件操作通用函数的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyFile()
构造函数
方法摘要
static boolean | appendFile(java.lang.String _sFileName, java.lang.String _sAddContent) 把指定的内容_sAddContent追加到文件_sFileName中
static boolean | copyFile(java.lang.String _sSrcFile, java.lang.String _sDstFile) 复制文件
static boolean | copyFile(java.lang.String _sSrcFile, java.lang.String _sDstFile, boolean _bMakeDirIfNotExists)
static boolean | copyFile(java.lang.String _sSrcFile, java.lang.String _sDstFile, boolean _bMakeDirIfNotExists, boolean preserveFileDate)
static void | copyFileDir(java.lang.String _fromFileDir, java.lang.String _toFileDir, boolean _bIncludeCurrDir) 拷贝文件夹到指定的文件夹
static boolean | deleteDir(java.io.File _path) Deletes a file path, and all the files and subdirectories in this path will also be deleted.
static boolean | deleteDir(java.lang.String _sPath) Deletes a file path, and all the files and subdirectories in this path will also be deleted.
static boolean | deleteDir(java.lang.String _sDir, boolean _bDeleteChildren) 已过时。 to use deleteDir(String _sPath) or deleteDir(File _path) instead.
static boolean | deleteFile(java.lang.String _sFilePathName) 删除指定的文件
static java.lang.String | excludeFileExt(java.lang.String sFileMame) 排除文件的扩展名,只保留路径(如果存在)和主文件名
static java.lang.String | extractFileDrive(java.lang.String _sFilePathName) 从文件的完整路径名（路径+文件名）中提取文件所在驱动器 注意：区分两种类型的文件名表示 [1] d:\path\filename.ext --> return "d:" [2] \\host\shareDrive\shareDir\filename.ext --> return "\\host\shareDrive"
static java.lang.String | extractFileExt(java.lang.String _sFilePathName) 从文件的完整路径名（路径+文件名）中提取: 文件扩展名
static java.lang.String | extractFileName(java.lang.String _sFilePathName) 从文件的完整路径名（路径+文件名）中提取文件名(包含扩展名) 如：d:\path\file.ext --> file.ext
static java.lang.String | extractFileName(java.lang.String _sFilePathName, java.lang.String _sFileSeparator) 从文件的完整路径名（路径+文件名）中提取文件名(包含扩展名) 如：d:\path\file.ext --> file.ext
static java.lang.String | extractFilePath(java.lang.String _sFilePathName) 从文件的完整路径名（路径+文件名）中提取 路径（包括：Drive+Directroy )
static java.lang.String | extractHttpFileName(java.lang.String _sFilePathName) 从EB路径地址中提取: 文件名
static java.lang.String | extractMainFileName(java.lang.String _sFilePathName) 从文件的完整路径名（路径+文件名）中提取:主文件名（不包括路径和扩展名）
static boolean | fileExists(java.lang.String _sPathFileName) 检查指定文件是否存在
static java.lang.String | getTempFileName() 返回一个临时的文件名(通常用作目录)
static java.io.File[] | listFiles(java.lang.String _dir, java.lang.String _extendName) 获取某一路径下的特殊文件
static java.io.File[] | listSubDirectories(java.lang.String _dir) 获取某一路径下的子文件夹
static void | main(java.lang.String[] args)
static boolean | makeDir(java.lang.String _sDir, boolean _bCreateParentDir) 创建目录
static java.lang.String | mapResouceFullPath(java.lang.String _resource) map the resource related path to full real path
static java.lang.String | mapResouceFullPath(java.lang.String _resource, java.lang.Class _currClass)
static boolean | moveFile(java.lang.String _sSrcFile, java.lang.String _sDstFile) 移动文件
static boolean | moveFile(java.lang.String _sSrcFile, java.lang.String _sDstFile, boolean _bMakeDirIfNotExists) 移动文件
static boolean | pathExists(java.lang.String _sPathFileName) 检查指定文件的路径是否存在
static byte[] | readBytesFromFile(java.lang.String _sFileName)
static java.lang.String | readFile(java.lang.String _sFileName) 读取文件的内容，返回字符串类型的文件内容
static java.lang.String | readFile(java.lang.String _sFileName, java.lang.String _sEncoding) 读取文件的内容，返回字符串类型的文件内容
static java.lang.String | toAbsolutePathName(java.lang.String _sFilePathName) 将文件/路径名称转化为绝对路径名
static boolean | writeFile(java.lang.String _sFileName, java.lang.String _sFileContent) 以指定内容_sFileContent生成新的文件_sFileName
static boolean | writeFile(java.lang.String _sFileName, java.lang.String _sFileContent, java.lang.String _encoding) 以指定内容_sFileContent生成新的文件_sFileName
static boolean | writeFile(java.lang.String _sFileName, java.lang.String _sFileContent, java.lang.String _sFileEncoding, boolean _bWriteUnicodeFlag)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyFile

public CMyFile()
构造函数

方法详细信息

fileExists

public static boolean fileExists(java.lang.String _sPathFileName)
检查指定文件是否存在

参数：
_sPathFileName - 文件名称(含路径）
返回：
若存在，则返回true；否则，返回false

pathExists

public static boolean pathExists(java.lang.String _sPathFileName)
检查指定文件的路径是否存在

参数：
_sPathFileName - 文件名称(含路径）
返回：
若存在，则返回true；否则，返回false

extractFileName

public static java.lang.String extractFileName(java.lang.String _sFilePathName)
从文件的完整路径名（路径+文件名）中提取文件名(包含扩展名)
如：d:\path\file.ext --> file.ext

参数：
_sFilePathName -
返回：

extractFileName

public static java.lang.String extractFileName(java.lang.String _sFilePathName,
                                               java.lang.String _sFileSeparator)
从文件的完整路径名（路径+文件名）中提取文件名(包含扩展名)
如：d:\path\file.ext --> file.ext

参数：
_sFilePathName - 全文件路径名
_sFileSeparator - 文件分隔符
返回：

extractHttpFileName

public static java.lang.String extractHttpFileName(java.lang.String _sFilePathName)
从EB路径地址中提取: 文件名

参数：
_sFilePathName -
返回：

extractMainFileName

public static java.lang.String extractMainFileName(java.lang.String _sFilePathName)
从文件的完整路径名（路径+文件名）中提取:主文件名（不包括路径和扩展名）

参数：
_sFilePathName -
返回：

excludeFileExt

public static java.lang.String excludeFileExt(java.lang.String sFileMame)
排除文件的扩展名,只保留路径(如果存在)和主文件名

参数：
sFileMame -
返回：

extractFileExt

public static java.lang.String extractFileExt(java.lang.String _sFilePathName)
从文件的完整路径名（路径+文件名）中提取: 文件扩展名

参数：
_sFilePathName -
返回：

extractFilePath

public static java.lang.String extractFilePath(java.lang.String _sFilePathName)
从文件的完整路径名（路径+文件名）中提取 路径（包括：Drive+Directroy )

参数：
_sFilePathName -
返回：

toAbsolutePathName

public static java.lang.String toAbsolutePathName(java.lang.String _sFilePathName)
将文件/路径名称转化为绝对路径名

参数：
_sFilePathName - 文件名或路径名
返回：

extractFileDrive

public static java.lang.String extractFileDrive(java.lang.String _sFilePathName)
从文件的完整路径名（路径+文件名）中提取文件所在驱动器
注意：区分两种类型的文件名表示
[1] d:\path\filename.ext --> return "d:"
[2] \\host\shareDrive\shareDir\filename.ext --> return "\\host\shareDrive"

参数：
_sFilePathName -
返回：

deleteFile

public static boolean deleteFile(java.lang.String _sFilePathName)
删除指定的文件

参数：
_sFilePathName - 指定的文件名
返回：

makeDir

public static boolean makeDir(java.lang.String _sDir,
                              boolean _bCreateParentDir)
创建目录

参数：
_sDir - 目录名称
_bCreateParentDir - 如果父目录不存在，是否创建父目录
返回：

deleteDir

public static boolean deleteDir(java.lang.String _sDir,
                                boolean _bDeleteChildren)
已过时。 to use deleteDir(String _sPath) or deleteDir(File _path) instead.

删除指定的目录下所有的文件 注意：若文件或目录正在使用，删除操作将失败。

参数：
_sDir - 目录名
_bDeleteChildren - 是否删除其子目录或子文件（可省略，默认不删除）
返回：
true if the directory exists and has been deleted successfully.

deleteDir

public static boolean deleteDir(java.lang.String _sPath)
Deletes a file path, and all the files and subdirectories in this path will also be deleted.

参数：
_sPath - the specified path.
返回：
true if the path exists and has been deleted successfully; false othewise.

deleteDir

public static boolean deleteDir(java.io.File _path)
Deletes a file path, and all the files and subdirectories in this path will also be deleted.

参数：
_path - the specified path.
返回：
true if the path exists and has been deleted successfully; false othewise.

listFiles

public static java.io.File[] listFiles(java.lang.String _dir,
                                       java.lang.String _extendName)
获取某一路径下的特殊文件

参数：
dir - 路径名称
extendName - 文件扩展名，"."可以包含也可以不包含
返回：

listSubDirectories

public static java.io.File[] listSubDirectories(java.lang.String _dir)
获取某一路径下的子文件夹

参数：
_dir - 路径名称
返回：
子文件夹对象数组

readFile

public static java.lang.String readFile(java.lang.String _sFileName)
                                 throws CMyException
读取文件的内容，返回字符串类型的文件内容

参数：
_sFileName - 文件名
返回：
抛出：
CMyException

readFile

public static java.lang.String readFile(java.lang.String _sFileName,
                                        java.lang.String _sEncoding)
                                 throws CMyException
读取文件的内容，返回字符串类型的文件内容

参数：
_sFileName - 文件名
_sEncoding - 以指定的字符编码读取文件内容,默认为"UTF-8"
返回：
抛出：
CMyException

readBytesFromFile

public static byte[] readBytesFromFile(java.lang.String _sFileName)
                                throws CMyException
抛出：
CMyException

writeFile

public static boolean writeFile(java.lang.String _sFileName,
                                java.lang.String _sFileContent)
                         throws CMyException
以指定内容_sFileContent生成新的文件_sFileName

参数：
_sFileName - 文件名
_sFileContent - 指定的内容
返回：
抛出：
CMyException

writeFile

public static boolean writeFile(java.lang.String _sFileName,
                                java.lang.String _sFileContent,
                                java.lang.String _encoding)
                         throws CMyException
以指定内容_sFileContent生成新的文件_sFileName

参数：
_sFileName - 文件名
_sFileContent - 指定的内容
返回：
抛出：
CMyException

writeFile

public static boolean writeFile(java.lang.String _sFileName,
                                java.lang.String _sFileContent,
                                java.lang.String _sFileEncoding,
                                boolean _bWriteUnicodeFlag)
                         throws CMyException
抛出：
CMyException

appendFile

public static boolean appendFile(java.lang.String _sFileName,
                                 java.lang.String _sAddContent)
                          throws CMyException
把指定的内容_sAddContent追加到文件_sFileName中

参数：
_sFileName - 文件名
_sAddContent - 追加的内容
返回：
抛出：
CMyException

moveFile

public static boolean moveFile(java.lang.String _sSrcFile,
                               java.lang.String _sDstFile)
                        throws CMyException
移动文件

参数：
_sSrcFile - 待移动的文件
_sDstFile - 目标文件
返回：
抛出：
CMyException

moveFile

public static boolean moveFile(java.lang.String _sSrcFile,
                               java.lang.String _sDstFile,
                               boolean _bMakeDirIfNotExists)
                        throws CMyException
移动文件

参数：
_sSrcFile - 待移动的文件
_sDstFile - 目标文件
_bMakeDirIfNotExists - 若目标路径不存在，是否创建;可缺省,默认值为true.
返回：
抛出：
CMyException

copyFile

public static boolean copyFile(java.lang.String _sSrcFile,
                               java.lang.String _sDstFile)
                        throws CMyException
复制文件

参数：
_sSrcFile - 源文件（必须包含路径）
_sDstFile - 目标文件（必须包含路径）
_bMakeDirIfNotExists - 若目标路径不存在，是否创建;可缺省,默认值为true.
返回：
若文件复制成功，则返回true；否则，返回false.
抛出：
CMyException - 源文件不存在,或目标文件所在目录不存在,或文件复制失败,会抛出异常.

copyFile

public static boolean copyFile(java.lang.String _sSrcFile,
                               java.lang.String _sDstFile,
                               boolean _bMakeDirIfNotExists)
                        throws CMyException
抛出：
CMyException

copyFile

public static boolean copyFile(java.lang.String _sSrcFile,
                               java.lang.String _sDstFile,
                               boolean _bMakeDirIfNotExists,
                               boolean preserveFileDate)
                        throws CMyException
抛出：
CMyException

copyFileDir

public static void copyFileDir(java.lang.String _fromFileDir,
                               java.lang.String _toFileDir,
                               boolean _bIncludeCurrDir)
                        throws CMyException
拷贝文件夹到指定的文件夹

参数：
_fromFileDir - 源目录
_toFileDir - 目标目录
_bIncludeCurrDir - 是否包含源目录的自身目录
抛出：
CMyException

mapResouceFullPath

public static java.lang.String mapResouceFullPath(java.lang.String _resource)
                                           throws WCMException
map the resource related path to full real path

参数：
_resource - related path of resource
返回：
the full real path
抛出：
java.lang.Exception - if encounter errors
WCMException

mapResouceFullPath

public static java.lang.String mapResouceFullPath(java.lang.String _resource,
                                                  java.lang.Class _currClass)
                                           throws WCMException
抛出：
WCMException

getTempFileName

public static java.lang.String getTempFileName()
返回一个临时的文件名(通常用作目录)

返回：
临时文件名

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyFilenameFilter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyFilenameFilter

java.lang.Object
    继承者  com.trs.infra.util.CMyFilenameFilter
所有已实现的接口：
java.io.FilenameFilter
public class CMyFilenameFilter
extends java.lang.Object
implements java.io.FilenameFilter

构造方法摘要
CMyFilenameFilter(java.lang.String _extendName)
方法摘要
 boolean accept(java.io.File _dir, java.lang.String _name)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyFilenameFilter

public CMyFilenameFilter(java.lang.String _extendName)
方法详细信息

accept

public boolean accept(java.io.File _dir,
                      java.lang.String _name)
指定者：
接口 java.io.FilenameFilter 中的 accept
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyFileX

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyFileX

java.lang.Object
    继承者  com.trs.infra.util.CMyFileX

public class CMyFileX
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyFileX()
方法摘要
static java.lang.String | autoToAbsoluteFilePath(java.lang.String _sSrcFileName)
static void | writeFile(java.lang.String _sFileName, byte[] _btContent)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyFileX

public CMyFileX()
方法详细信息

writeFile

public static void writeFile(java.lang.String _sFileName,
                             byte[] _btContent)
                      throws java.lang.Exception
抛出：
java.lang.Exception

autoToAbsoluteFilePath

public static java.lang.String autoToAbsoluteFilePath(java.lang.String _sSrcFileName)
                                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyKeyGenerator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyKeyGenerator

java.lang.Object
    继承者  com.trs.infra.util.CMyKeyGenerator

public class CMyKeyGenerator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
密钥生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyKeyGenerator()
方法摘要
static boolean | generatorKey(java.lang.String _sPrivateKeyFile, java.lang.String _sPublicKeyFile)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyKeyGenerator

public CMyKeyGenerator()
方法详细信息

generatorKey

public static boolean generatorKey(java.lang.String _sPrivateKeyFile,
                                   java.lang.String _sPublicKeyFile)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyMemory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyMemory

java.lang.Object
    继承者  com.trs.infra.util.CMyMemory

public class CMyMemory
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyMemory()
方法摘要
static int | freeMemory()
static void | main(java.lang.String[] args)
static java.lang.String | toMemoryInfo()
static int | totalMemory()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyMemory

public CMyMemory()
方法详细信息

freeMemory

public static int freeMemory()

totalMemory

public static int totalMemory()

toMemoryInfo

public static java.lang.String toMemoryInfo()

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMySign

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMySign

java.lang.Object
    继承者  com.trs.infra.util.CMySign

public class CMySign
extends java.lang.Object

签名和编码，仅供包内使用

方法摘要
byte[] | decodeRadix64(byte[] inbuf)
java.lang.String | encodeRadix64(byte[] inbuf) 进行Base64编码，但是与标准的Base64不同，'-'代替'+'，'_'代替'/'进行转换，用'.'
static CMySign | getSign(java.lang.String _sPrivateKey) 返回唯一的实例
static CMySign | getVerify(java.lang.String _sPublicKey) 此处插入方法说明。
static void | main(java.lang.String[] args)
byte[] | sign(byte[] buff) 进行数字签名。
boolean | verify(byte[] data, int iLength) 此处插入方法说明。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

decodeRadix64

public byte[] decodeRadix64(byte[] inbuf)

encodeRadix64

public java.lang.String encodeRadix64(byte[] inbuf)
进行Base64编码，但是与标准的Base64不同，'-'代替'+'，'_'代替'/'进行转换，用'.'代替'='进行填充。

getSign

public static CMySign getSign(java.lang.String _sPrivateKey)
                       throws java.lang.Exception
返回唯一的实例

抛出：
java.lang.Exception

getVerify

public static CMySign getVerify(java.lang.String _sPublicKey)
                         throws java.lang.Exception
此处插入方法说明。

抛出：
java.lang.Exception

sign

public byte[] sign(byte[] buff)
            throws java.lang.Exception
进行数字签名。

抛出：
java.lang.Exception

verify

public boolean verify(byte[] data,
                      int iLength)
               throws java.lang.Exception
此处插入方法说明。

抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMySMS

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMySMS

java.lang.Object
    继承者  com.trs.infra.util.CMySMS

public class CMySMS
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）

Description:

class CMySMS —— 用于手机发送短信息

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
java.lang.String | sContent 短信息内容
java.lang.String | sFrom 发信人
java.lang.String | sTo 收信人
构造方法摘要
CMySMS()
默认的构造函数
方法摘要
java.lang.String | getContent() 获取短信息内容
java.lang.String | getFrom() 获取发信人
java.lang.String | getTo() 获取收信人
static boolean | isValidMobile(java.lang.String _sMobile) 判断指定的手机号是否有效 有效手机号：11位，且不是130/133型
static void | main(java.lang.String[] args)
boolean | send() 发送短消息
void | setContent(java.lang.String _sContent) 设置短信息内容
void | setFrom(java.lang.String _sFrom) 设置发信人
static void | setParamNameContent(java.lang.String _paramNameContent) 设置参数Content的名称
static void | setParamNameTo(java.lang.String _paramNameTo) 设置参数To的名称
static void | setSendUrlPre(java.lang.String _urlPre) 设置用于发送短信息的Url前半部分 eg."
void | setTo(java.lang.String _sTo) 设置收信人
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

sFrom

public java.lang.String sFrom
发信人

sTo

public java.lang.String sTo
收信人

sContent

public java.lang.String sContent
短信息内容

构造方法详细信息

CMySMS

public CMySMS()
默认的构造函数

方法详细信息

setSendUrlPre

public static void setSendUrlPre(java.lang.String _urlPre)
设置用于发送短信息的Url前半部分
eg."http://210.83.137.173/services/instantcall/sendCall_client.asp?UID=128640&PASSWORD=020201&MSGTYPE=SMS" ;

参数：
_urlPre - 用于发送短信息的Url前半部分

setParamNameTo

public static void setParamNameTo(java.lang.String _paramNameTo)
设置参数To的名称

参数：
_paramNameTo - 参数To的名称

setParamNameContent

public static void setParamNameContent(java.lang.String _paramNameContent)
设置参数Content的名称

参数：
_paramNameContent - 参数Content的名称

isValidMobile

public static boolean isValidMobile(java.lang.String _sMobile)
判断指定的手机号是否有效
有效手机号：11位，且不是130/133型

参数：
_sMobile -
返回：

getFrom

public java.lang.String getFrom()
获取发信人

返回：

setFrom

public void setFrom(java.lang.String _sFrom)
设置发信人

参数：
_sFrom -

getTo

public java.lang.String getTo()
获取收信人

返回：

setTo

public void setTo(java.lang.String _sTo)
           throws CMyException
设置收信人

参数：
_sTo - 收信人
抛出：
CMyException

getContent

public java.lang.String getContent()
获取短信息内容

返回：

setContent

public void setContent(java.lang.String _sContent)
                throws CMyException
设置短信息内容

参数：
_sContent - 短信息内容
抛出：
CMyException

send

public boolean send()
             throws CMyException
发送短消息

返回：
返回值：若参数设定错误，则返回false；若发送成功，返回true；
抛出：
CMyException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyString

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyString

java.lang.Object
    继承者  com.trs.infra.util.CMyString

public class CMyString
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）

Description:

class CMyString —— 字符串处理对象

Copyright: Copyright (c) 2001

Company: www.trs.com.cn

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | ENCODING_DEFAULT 默认字符编码集
static java.lang.String | FILE_WRITING_ENCODING
static java.lang.String | GET_ENCODING_DEFAULT
构造方法摘要
CMyString()
方法摘要
static java.lang.String byteToHexString(byte[] _bytes)
将字节数据输出为16进制数表示的字符串
static java.lang.String byteToHexString(byte[] _bytes, char _delim)
将字节数据输出为16进制无符号数表示的字符串
static java.lang.String byteToString(byte[] _bytes, char _delim, int _radix)
将字节数据输出为指定进制数表示的字符串（注意：负数带有负号）
static java.lang.String capitalize(java.lang.String _strValue)
static java.lang.String circleStr(java.lang.String _strSrc)
字符串翻转：对于给定的字符串，按相反的顺序输出
static boolean containsCDATAStr(java.lang.String _sValue)
static int countTokens(java.lang.String _str, java.lang.String _sDelim)
获取按照指定的分隔符截取到的字符个数
static java.lang.String cutStr(java.lang.String _string, int _length)
已过时。 已经由函数truncateStr替代
static java.lang.String decodeForCDATA(java.lang.String _str)
处理XML内容
如果有经过@see #encodeForCDATA(String)替换的CDATA嵌套则还原
static java.lang.String encodeForCDATA(java.lang.String _str)
处理XML内容时
如果有CDATA嵌套则替换
static java.lang.String encodeForRegExp(java.lang.String sSource)
对输入字符串中的正则表达式特殊字符进行转义，转成普通字符
static java.lang.String expandStr(java.lang.String _string, int _length, char _chrFill, boolean _bFillOnLeft)
扩展字符串长度；若长度不足，则是用指定的字符串填充
static java.lang.String filterForHTMLValue(java.lang.String _sContent)
HTML元素value值过滤处理函数：将 & < >\ 等特殊字符作转化处理
static java.lang.String filterForJava(java.lang.String _sContent)
可能有置标内容输出到java代码中作为参数。
static java.lang.String filterForJDOM(java.lang.String _string)
过滤掉XML不接受的字符
static java.lang.String filterForJs(java.lang.String _sContent)
JavaScript过滤处理函数：将指定文本中的 " \ \r \n 等特殊字符做转化处理
static java.lang.String filterForSQL(java.lang.String _sContent)
SQL语句特殊字符过滤处理函数 用于：构造SQL语句时，填充字符串参数时使用 如： String strSQL = "select * from tbName where Name='"+CMyString.filterForSQL("a'bc")+"'" 说明：需要处理的特殊字符及对应转化规则：如： ' --->'' 不允许使用的特殊字符： !
static java.lang.String filterForSQL2(java.lang.String _sContent)
static java.lang.String filterForUrl(java.lang.String _sContent)
URL过滤处理函数：将 # & 等特殊字符作转化处理
static java.lang.String filterForXML(java.lang.String _sContent)
XML文本过滤处理函数：将 & < >\ 等特殊字符做转化处理
static java.lang.String filterForXsltValue(java.lang.String _sAttrValue)
static java.lang.String format(java.lang.String _sFormat, int[] _args)
用数组_args里面的第i个变量替换掉_sFormat中的{i}
static java.lang.String format(java.lang.String _sFormat, java.lang.Object[] _args)
用数组_args里面的第i个变量替换掉_sFormat中的{i}
static java.lang.String format(java.lang.String _sFormat, java.lang.String[] _args)
用数组_args里面的第i个变量替换掉_sFormat中的{i}
static int getBytesLength(java.lang.String _string)
计算字符串所占的字节数； 说明：英文和数字字符长度记1；中文字符长度记2。
static int getCharViewWidth(int c)
返回指定字符的显示宽度，在目前的实现中，认为一个英文字符的显示宽度是1，一个汉字的显示宽度是2。
static java.lang.String getFirstLetter(java.lang.String _str)
static int[] getIdListAsIntArr(java.util.List vIdList)
static java.lang.String getIdListAsString(java.util.List vIdList, char _separate)
static java.lang.String getStr(java.lang.String _strSrc)
字符串编码转换函数，用于将指定编码的字符串转换为标准（Unicode）字符串
static java.lang.String getStr(java.lang.String _strSrc, boolean _bPostMethod)
字符转换函数，处理中文问题
static java.lang.String getStr(java.lang.String _strSrc, java.lang.String _encoding)
字符串编码转换函数，用于将指定编码的字符串转换为标准（Unicode）字符串 Purpose: 转换字符串内码，用于解决中文显示问题 Usage： 在页面切换时，获取并显示中文字符串参数时可用。
static int getStringViewWidth(java.lang.String s)
返回指定字符串的显示宽度
static byte[] getUTF8Bytes(java.lang.String _string)
提取字符串UTF8编码的字节流 说明：等价于 _string.getBytes("UTF8")
static java.lang.String getUTF8String(byte[] b)
static java.lang.String getUTF8String(byte[] b, int off, int len)
从指定的字节数组中提取UTF8编码的字符串 说明：函数等价于 new String(b,"UTF8")
static java.lang.String innerText(java.lang.String _strValue)
static boolean isChineseChar(int c)
判断指定的字符是不是汉字，目前是通过判断其值是否大于7FH实现的。
static boolean isContainChineseChar(java.lang.String _str)
判断字符串中是否包含中文字符
如果包含,则返回 true
static boolean isEmpty(java.lang.String _string)
判断指定字符串是否为空
static boolean isEmptyStr(java.lang.String _string)
已过时。 由函数 isEmpty 替换
static boolean isValidCharOfXML(char _char)
校验当前字符是否是合法的XML字符
static java.lang.String join(java.util.ArrayList _arColl, java.lang.String _sSeparator)
将一个数组按照给定的连接符联结起来
static java.lang.String join(int[] _intColl, java.lang.String _sSeparator)
static java.lang.String join(java.lang.Object[] _arColl, java.lang.String _sSeparator)
将一个数组按照给定的连接符联结起来
static void main(java.lang.String[] args)
简单测试用例
static java.lang.String makeBlanks(int _length)
构造指定长度的空格字符串
static java.lang.String numberToStr(int _nValue)
将指定整型值转化为字符串
static java.lang.String numberToStr(int _nValue, int _length)
将指定整型值转化为字符串
static java.lang.String numberToStr(int _nValue, int _length, char _chrFill)
将指定整型值转化为字符串
static java.lang.String numberToStr(long _lValue)
将指定长整数转化为字符串
static java.lang.String numberToStr(long _lValue, int _length)
将指定长整数转化为字符串
static java.lang.String numberToStr(long _lValue, int _length, char _chrFill)
将指定长整数转化为字符串
static java.lang.String parsePageVariables(java.lang.String _sContent, java.util.Map _variables)
替换内容中的变量
static java.lang.String parsePageVariables(java.lang.String _sContent, java.util.Map _variables, char[] _aSep)
替换内容中的变量
static java.lang.String parsePageVariables(java.lang.String _sContent, java.util.Map _variables, char[] _aSep, int _nPgvarnameMaxLength)
替换内容中的变量
static java.lang.String parsePageVariables(java.lang.String _sContent, java.util.Map _variables, int _nPgvarnameMaxLength)
替换内容中的变量
static java.lang.String replaceParasStartEndSpaces(java.lang.String _strValue)
先拆分成段，再分别替换各段段首和段尾的空格
static java.lang.String replaceStartEndSpaces(java.lang.String _strValue)
替换段首和段尾的空格
static java.lang.String replaceStr(java.lang.StringBuffer _strSrc, java.lang.String _strOld, java.lang.String _strNew)
字符串替换函数：用于将指定字符串中指定的字符串替换为新的字符串。
static java.lang.String replaceStr(java.lang.String _strSrc, java.lang.String _strOld, java.lang.String _strNew)
字符串替换函数：用于将指定字符串中指定的字符串替换为新的字符串。
static java.lang.String setStrEndWith(java.lang.String _string, char _chrEnd)
设置字符串最后一位为指定的字符
static java.lang.String showEmpty(java.lang.String p_sValue)
字符串显示处理函数：若为空对象，则返回指定的字符串
static java.lang.String showEmpty(java.lang.String _sValue, java.lang.String _sReplaceIfEmpty)
字符串显示处理函数：若为空对象或者空串，则返回指定的字符串
static java.lang.String showNull(java.lang.String p_sValue)
字符串显示处理函数：若为空对象，则返回指定的字符串
static java.lang.String showNull(java.lang.String _sValue, java.lang.String _sReplaceIfNull)
字符串显示处理函数：若为空对象，则返回指定的字符串
static java.lang.String showObjNull(java.lang.Object p_sValue)
字符串显示处理函数：若为空对象，则返回指定的字符串
static java.lang.String showObjNull(java.lang.Object _sValue, java.lang.String _sReplaceIfNull)
字符串显示处理函数：若为空对象，则返回指定的字符串
static java.lang.String[] split(java.lang.String _str, java.lang.String _sDelim)
static java.util.Map split2AttrMap(java.lang.String _sAttrStr)
static int[] splitToInt(java.lang.String _str, java.lang.String _sDelim)
static java.lang.String toISO_8859(java.lang.String _strSrc)
将指定的字符串转化为ISO-8859-1编码的字符串
static java.lang.String toUnicode(java.lang.String _strSrc)
已过时。 含义模糊，已经使用toISO_8859替换
static java.lang.String transDisplay_bbs(java.lang.String _sContent, java.lang.String p_sQuoteColor)
static java.lang.String transDisplay_bbs(java.lang.String _sContent, java.lang.String p_sQuoteColor, boolean _bChangeBlank)
将指定文本内容，格式化为bbs风格的Html文本字符串。
static java.lang.String transDisplay(java.lang.String _sContent)
用于在Html中显示文本内容
static java.lang.String transDisplay(java.lang.String _sContent, boolean _bChangeBlank)
用于在Html中显示文本内容。
static java.lang.String transDisplayMark(java.lang.String _strSrc, char p_chrMark)
字符串的掩码显示：用指定的掩码构造与指定字符串相同长度的字符串 用于：密码显示等需要掩码处理的场合
static java.lang.String transJsDisplay(java.lang.String _sContent)
javascript显示处理，用于处理javascript中的文本字符串显示
static java.lang.String transPrettyUrl(java.lang.String _sUrl, int _nMaxLen)
static java.lang.String transPrettyUrl(java.lang.String _sUrl, int _nMaxLen, java.lang.String _sSkimWord)
static java.lang.String truncateStr(java.lang.String _string, int _maxLength)
字符串截断函数：取指定字符串前部指定长度的字符串； 说明：英文和数字字符长度记1；中文字符长度记2。
static java.lang.String truncateStr(java.lang.String _string, int _maxLength, java.lang.String _sExt)
字符串截断函数：取指定字符串前部指定长度的字符串； 说明：英文和数字字符长度记1；中文字符长度记2。
static java.lang.String unfilterForHTMLValue(java.lang.String _sContent)
将_sContent做filterForHTMLValue的逆处理
static java.lang.String URLEncode(java.lang.String s)
处理Get方式的字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ENCODING_DEFAULT

public static java.lang.String ENCODING_DEFAULT
默认字符编码集

GET_ENCODING_DEFAULT

public static java.lang.String GET_ENCODING_DEFAULT

FILE_WRITING_ENCODING

public static java.lang.String FILE_WRITING_ENCODING
构造方法详细信息

CMyString

public CMyString()
方法详细信息

isEmpty

public static boolean isEmpty(java.lang.String _string)
判断指定字符串是否为空

参数：
_string - 指定的字符串
返回：
若字符串为空对象（_string==null）或空串（长度为0），则返回true；否则，返回false.

isEmptyStr

public static boolean isEmptyStr(java.lang.String _string)
已过时。 由函数 isEmpty 替换

判断指定字符串是否为空

参数：
_string - 指定的字符串
返回：
若字符串为空对象（_string==null）或空串（长度为0），则返回true；否则，返回false.
另请参见：
isEmpty( String _string )

showObjNull

public static java.lang.String showObjNull(java.lang.Object p_sValue)
字符串显示处理函数：若为空对象，则返回指定的字符串

另请参见：
showNull( String _sValue, String _sReplaceIfNull )

showObjNull

public static java.lang.String showObjNull(java.lang.Object _sValue,
                                           java.lang.String _sReplaceIfNull)
字符串显示处理函数：若为空对象，则返回指定的字符串

参数：
_sValue - 指定的字符串
_sReplaceIfNull - 当_sValue==null时的替换显示字符串；可选参数，缺省值为空字符串（""）
返回：
处理后的字符串

showNull

public static java.lang.String showNull(java.lang.String p_sValue)
字符串显示处理函数：若为空对象，则返回指定的字符串

另请参见：
showNull( String _sValue, String _sReplaceIfNull )

showNull

public static java.lang.String showNull(java.lang.String _sValue,
                                        java.lang.String _sReplaceIfNull)
字符串显示处理函数：若为空对象，则返回指定的字符串

参数：
_sValue - 指定的字符串
_sReplaceIfNull - 当_sValue==null时的替换显示字符串；可选参数，缺省值为空字符串（""）
返回：
处理后的字符串

showEmpty

public static java.lang.String showEmpty(java.lang.String p_sValue)
字符串显示处理函数：若为空对象，则返回指定的字符串

另请参见：
showNull( String _sValue, String _sReplaceIfNull )

showEmpty

public static java.lang.String showEmpty(java.lang.String _sValue,
                                         java.lang.String _sReplaceIfEmpty)
字符串显示处理函数：若为空对象或者空串，则返回指定的字符串

参数：
_sValue - 指定的字符串
_sReplaceIfEmpty - 当CMyStirng.isEmpty(_sValue)时的替换显示字符串；可选参数，缺省值为空字符串（""）
返回：
处理后的字符串

expandStr

public static java.lang.String expandStr(java.lang.String _string,
                                         int _length,
                                         char _chrFill,
                                         boolean _bFillOnLeft)
扩展字符串长度；若长度不足，则是用指定的字符串填充

参数：
_string - 要扩展的字符串
_length - 扩展后的字符串长度。
_chrFill - 扩展时，用于填充的字符。
_bFillOnLeft - 扩展时，是否为左填充（扩展）；否则，为右填充
返回：
长度扩展后的字符串

setStrEndWith

public static java.lang.String setStrEndWith(java.lang.String _string,
                                             char _chrEnd)
设置字符串最后一位为指定的字符

参数：
_string - 指定的字符串
_chrEnd - 指定字符，若字符串最后一位不是该字符，则在字符串尾部追加该字符
返回：
处理后的字符串 如果isEmpty(_string)返回true,则原样返回
另请参见：
isEmpty(String)

makeBlanks

public static java.lang.String makeBlanks(int _length)
构造指定长度的空格字符串

参数：
_length - 指定长度
返回：
指定长度的空格字符串

replaceStr

public static java.lang.String replaceStr(java.lang.String _strSrc,
                                          java.lang.String _strOld,
                                          java.lang.String _strNew)
字符串替换函数：用于将指定字符串中指定的字符串替换为新的字符串。

参数：
_strSrc - 源字符串。
_strOld - 被替换的旧字符串
_strNew - 用来替换旧字符串的新字符串
返回：
替换处理后的字符串

replaceStr

public static java.lang.String replaceStr(java.lang.StringBuffer _strSrc,
                                          java.lang.String _strOld,
                                          java.lang.String _strNew)
字符串替换函数：用于将指定字符串中指定的字符串替换为新的字符串。

参数：
_strSrc - 源字符串。
_strOld - 被替换的旧字符串
_strNew - 用来替换旧字符串的新字符串
返回：
替换处理后的字符串

getStr

public static java.lang.String getStr(java.lang.String _strSrc)
字符串编码转换函数，用于将指定编码的字符串转换为标准（Unicode）字符串

另请参见：
getStr( String _strSrc, String _encoding )

getStr

public static java.lang.String getStr(java.lang.String _strSrc,
                                      boolean _bPostMethod)
字符转换函数，处理中文问题

参数：
_strSrc - 源字符串
_bPostMethod - 提交数据的方式（Get方式采用GET_ENCODING_DEFAULT字符集，Post方式采用ENCODING_DEFAULT字符集 ）
返回：

getStr

public static java.lang.String getStr(java.lang.String _strSrc,
                                      java.lang.String _encoding)
字符串编码转换函数，用于将指定编码的字符串转换为标准（Unicode）字符串

Purpose: 转换字符串内码，用于解决中文显示问题

Usage： 在页面切换时，获取并显示中文字符串参数时可用。

参数：
_strSrc - 需要转换的字符串
_encoding - 指定字符串（_strSrc）的编码方式；可选参数，缺省值为ENCODING_DEFAULT
返回：

toISO_8859

public static java.lang.String toISO_8859(java.lang.String _strSrc)
将指定的字符串转化为ISO-8859-1编码的字符串

参数：
_strSrc - 指定的源字符串
返回：
转化后的字符串

toUnicode

public static java.lang.String toUnicode(java.lang.String _strSrc)
已过时。 含义模糊，已经使用toISO_8859替换

将指定的字符串转化为ISO-8859-1编码的字符串

参数：
_strSrc - 指定的源字符串
返回：
转化后的字符串

getUTF8Bytes

public static byte[] getUTF8Bytes(java.lang.String _string)
提取字符串UTF8编码的字节流

说明：等价于 _string.getBytes("UTF8")

参数：
_string - 源字符串
返回：
UTF8编码的字节数组

getUTF8String

public static java.lang.String getUTF8String(byte[] b)

getUTF8String

public static java.lang.String getUTF8String(byte[] b,
                                             int off,
                                             int len)
从指定的字节数组中提取UTF8编码的字符串

说明：函数等价于 new String(b,"UTF8")

参数：
b - 指定的字节数组（UTF8编码）
off - 开始提取的字节起始位置；可选参数，缺省值为0；
len - 提取的字节数；可选择书，缺省值为全部。
返回：
提取后得到的字符串。

byteToHexString

public static java.lang.String byteToHexString(byte[] _bytes)
将字节数据输出为16进制数表示的字符串

另请参见：
byteToHexString( byte[] _bytes, char _delim )

byteToHexString

public static java.lang.String byteToHexString(byte[] _bytes,
                                               char _delim)
将字节数据输出为16进制无符号数表示的字符串

参数：
_bytes - 字节数组
_delim - 字节数据显示时，字节之间的分隔符；可选参数，缺省值为','
返回：
16进制无符号数表示的字节数据

byteToString

public static java.lang.String byteToString(byte[] _bytes,
                                            char _delim,
                                            int _radix)
将字节数据输出为指定进制数表示的字符串（注意：负数带有负号）

参数：
_bytes - 字节数组
_delim - 字节数据显示时，字节之间的分隔符；可选参数，缺省值为','
_radix - 进制数（如16进制）
返回：
指定进制数表示的字节数据（负数带由负号）

transDisplay

public static java.lang.String transDisplay(java.lang.String _sContent)
用于在Html中显示文本内容

另请参见：
transDisplay( String _sContent, boolean _bChangeBlank )

transDisplay

public static java.lang.String transDisplay(java.lang.String _sContent,
                                            boolean _bChangeBlank)
用于在Html中显示文本内容。将空格等转化为html标记。

说明：处理折行时，若使用 style="WORD_WRAP:keepall" ，则不能将空格转换为 &nbsp;

参数：
_sContent - 要显示的内容
_bChangeBlank - 是否转换空格符；可选参数，默认值为true.
返回：
转化后的Html文本

transDisplay_bbs

public static java.lang.String transDisplay_bbs(java.lang.String _sContent,
                                                java.lang.String p_sQuoteColor)

transDisplay_bbs

public static java.lang.String transDisplay_bbs(java.lang.String _sContent,
                                                java.lang.String p_sQuoteColor,
                                                boolean _bChangeBlank)
将指定文本内容，格式化为bbs风格的Html文本字符串。

说明：[1]处理折行时，若使用 style="WORD_WRAP:keepall"，则不能将空格转换为 &nbsp;

[2]该函数格式化时，如果遇到某一行以":"开始，则认为是引用语(quote)，

参数：
_sContent - 文本内容；
p_sQuoteColor - 引用语的显示颜色。
_bChangeBlank - 是否转换空格符，可省略，默认值为true
返回：
转化后的Html文本

transJsDisplay

public static java.lang.String transJsDisplay(java.lang.String _sContent)
javascript显示处理，用于处理javascript中的文本字符串显示

参数：
_sContent - javascript文本
返回：
处理后的javascript文本

transDisplayMark

public static java.lang.String transDisplayMark(java.lang.String _strSrc,
                                                char p_chrMark)
字符串的掩码显示：用指定的掩码构造与指定字符串相同长度的字符串

用于：密码显示等需要掩码处理的场合

参数：
_strSrc - 源字符串
p_chrMark - 指定的掩码
返回：
用掩码处理后的字符串

filterForSQL

public static java.lang.String filterForSQL(java.lang.String _sContent)
SQL语句特殊字符过滤处理函数

用于：构造SQL语句时，填充字符串参数时使用

如： String strSQL = "select * from tbName where Name='"+CMyString.filterForSQL("a'bc")+"'"

说明：需要处理的特殊字符及对应转化规则：如： ' --->''

不允许使用的特殊字符： !@#$%^&*()+|-=\\;:\",./<>?

参数：
_sContent - 需要处理的字符串
返回：
过滤处理后的字符串

filterForSQL2

public static java.lang.String filterForSQL2(java.lang.String _sContent)

filterForXsltValue

public static java.lang.String filterForXsltValue(java.lang.String _sAttrValue)

filterForXML

public static java.lang.String filterForXML(java.lang.String _sContent)
XML文本过滤处理函数：将 & < >\ 等特殊字符做转化处理

参数：
_sContent - 指定的XML文本内容
返回：
处理后的文本内容

filterForHTMLValue

public static java.lang.String filterForHTMLValue(java.lang.String _sContent)
HTML元素value值过滤处理函数：将 & < >\ 等特殊字符作转化处理

参数：
_sContent - 指定的文本内容
返回：
处理后的文本内容

unfilterForHTMLValue

public static java.lang.String unfilterForHTMLValue(java.lang.String _sContent)
将_sContent做filterForHTMLValue的逆处理

参数：
_sContent -
返回：

filterForUrl

public static java.lang.String filterForUrl(java.lang.String _sContent)
URL过滤处理函数：将 # & 等特殊字符作转化处理

参数：
_sContent - 指定的URL内容
返回：
处理后的字符串

filterForJs

public static java.lang.String filterForJs(java.lang.String _sContent)
JavaScript过滤处理函数：将指定文本中的 " \ \r \n 等特殊字符做转化处理

参数：
_sContent - 指定的javascript文本
返回：
转化处理后的字符串

filterForJava

public static java.lang.String filterForJava(java.lang.String _sContent)
可能有置标内容输出到java代码中作为参数。在输出之前需要排除特殊字符。

参数：
_sContent置标输出之前的内容 -
返回：
转化处理后的字符串

numberToStr

public static java.lang.String numberToStr(int _nValue)
将指定整型值转化为字符串

另请参见：
numberToStr( int _nValue, int _length, char _chrFill )

numberToStr

public static java.lang.String numberToStr(int _nValue,
                                           int _length)
将指定整型值转化为字符串

另请参见：
numberToStr( int _nValue, int _length, char _chrFill )

numberToStr

public static java.lang.String numberToStr(int _nValue,
                                           int _length,
                                           char _chrFill)
将指定整型值转化为字符串

参数：
_nValue - 指定整数
_length - 转化后字符串长度；若实际长度小于该长度，则使用_chrFill左填充; 可选参数，缺省值0，表示按照实际长度，不扩展。
_chrFill - 当整数的实际位数小于指定长度时的填充字符；可选参数，缺省值'0'
返回：
转化后的字符串

numberToStr

public static java.lang.String numberToStr(long _lValue)
将指定长整数转化为字符串

另请参见：
numberToStr( long _lValue, int _length, char _chrFill )

numberToStr

public static java.lang.String numberToStr(long _lValue,
                                           int _length)
将指定长整数转化为字符串

另请参见：
numberToStr( long _lValue, int _length, char _chrFill )

numberToStr

public static java.lang.String numberToStr(long _lValue,
                                           int _length,
                                           char _chrFill)
将指定长整数转化为字符串

参数：
_lValue - 指定长整数
_length - 转化后字符串长度；若实际长度小于该长度，则使用_chrFill左填充; 可选参数，缺省值0，表示按照实际长度，不扩展。
_chrFill - 当整数的实际位数小于指定长度时的填充字符；可选参数，缺省值'0'
返回：
转化后的字符串

circleStr

public static java.lang.String circleStr(java.lang.String _strSrc)
字符串翻转：对于给定的字符串，按相反的顺序输出

参数：
_strSrc - 指定的字符串
返回：
翻转后的字符串

isChineseChar

public static final boolean isChineseChar(int c)
判断指定的字符是不是汉字，目前是通过判断其值是否大于7FH实现的。

参数：
c - 指定的字符
返回：
是否汉字

getCharViewWidth

public static final int getCharViewWidth(int c)
返回指定字符的显示宽度，在目前的实现中，认为一个英文字符的显示宽度是1，一个汉字的显示宽度是2。

参数：
c - 指定的字符
返回：
指定字符的显示宽度

getStringViewWidth

public static final int getStringViewWidth(java.lang.String s)
返回指定字符串的显示宽度

参数：
s - 指定的字符串
返回：
指定字符串的显示宽度

truncateStr

public static java.lang.String truncateStr(java.lang.String _string,
                                           int _maxLength)
字符串截断函数：取指定字符串前部指定长度的字符串； 说明：英文和数字字符长度记1；中文字符长度记2。

参数：
_string - 要截断的字符串。
_maxLength - 截断长度。
返回：
截断后的字符串。若指定长度小于字符串实际长度，则在返回的字符串后补“...”

truncateStr

public static java.lang.String truncateStr(java.lang.String _string,
                                           int _maxLength,
                                           java.lang.String _sExt)
字符串截断函数：取指定字符串前部指定长度的字符串； 说明：英文和数字字符长度记1；中文字符长度记2。

参数：
_string - 要截断的字符串。
_maxLength - 截断长度。
_sExt - 在截断后的字符串上的附加的字符串
返回：
截断后的字符串

filterForJDOM

public static java.lang.String filterForJDOM(java.lang.String _string)
过滤掉XML不接受的字符

参数：
_string - 源字符串
返回：

isValidCharOfXML

public static boolean isValidCharOfXML(char _char)
校验当前字符是否是合法的XML字符

参数：
_char - 需要校验的字符
返回：

getBytesLength

public static int getBytesLength(java.lang.String _string)
计算字符串所占的字节数；

说明：英文和数字字符长度记1；中文字符长度记2。

参数：
_string - 要截断的字符串。
返回：
截断后的字符串。若指定长度小于字符串实际长度，则在返回的字符串后补“...”

cutStr

public static java.lang.String cutStr(java.lang.String _string,
                                      int _length)
已过时。 已经由函数truncateStr替代

字符串截断函数：取指定字符串前部指定长度的字符串；

说明：英文和数字字符长度记1；中文字符长度记2。

参数：
_string - 要截断的字符串。
_length - 截断长度。
返回：
截断后的字符串。若指定长度小于字符串实际长度，则在返回的字符串后补“...”

URLEncode

public static java.lang.String URLEncode(java.lang.String s)
处理Get方式的字符串

参数：
s - 待处理的字符串
返回：
返回经过处理的字符串

split

public static java.lang.String[] split(java.lang.String _str,
                                       java.lang.String _sDelim)

countTokens

public static int countTokens(java.lang.String _str,
                              java.lang.String _sDelim)
获取按照指定的分隔符截取到的字符个数

参数：
_str - 指定的字符数
_sDelim - 指定的分隔符
返回：
分隔的字符个数（int）

splitToInt

public static int[] splitToInt(java.lang.String _str,
                               java.lang.String _sDelim)
参数：
_str - if null or empty string return an array with zero length.
_sDelim - if null or empty string then this will set to ,
返回：

getIdListAsString

public static java.lang.String getIdListAsString(java.util.List vIdList,
                                                 char _separate)
参数：
vIdList - list数组
_chrDelim - 分隔符
返回：
带分割符字符串

getIdListAsIntArr

public static int[] getIdListAsIntArr(java.util.List vIdList)

getFirstLetter

public static java.lang.String getFirstLetter(java.lang.String _str)
                                       throws java.lang.Exception
抛出：
java.lang.Exception

encodeForCDATA

public static final java.lang.String encodeForCDATA(java.lang.String _str)
处理XML内容时
如果有CDATA嵌套则替换

参数：
_str -
返回：

decodeForCDATA

public static final java.lang.String decodeForCDATA(java.lang.String _str)
处理XML内容
如果有经过@see #encodeForCDATA(String)替换的CDATA嵌套则还原

参数：
_str -
返回：

isContainChineseChar

public static final boolean isContainChineseChar(java.lang.String _str)
判断字符串中是否包含中文字符
如果包含,则返回 true

参数：
_str - 指定的字符串
返回：

join

public static java.lang.String join(java.util.ArrayList _arColl,
                                    java.lang.String _sSeparator)
将一个数组按照给定的连接符联结起来

参数：
_arColl - 进行操作的数组
_sSeparator - 连接符
返回：
连接后的字符串

join

public static java.lang.String join(java.lang.Object[] _arColl,
                                    java.lang.String _sSeparator)
将一个数组按照给定的连接符联结起来

参数：
_arColl - 进行操作的数组
_sSeparator - 连接符
返回：
连接后的字符串

join

public static java.lang.String join(int[] _intColl,
                                    java.lang.String _sSeparator)

containsCDATAStr

public static boolean containsCDATAStr(java.lang.String _sValue)

parsePageVariables

public static java.lang.String parsePageVariables(java.lang.String _sContent,
                                                  java.util.Map _variables)
                                           throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_variables - 变量表
返回：
抛出：
WCMException

parsePageVariables

public static java.lang.String parsePageVariables(java.lang.String _sContent,
                                                  java.util.Map _variables,
                                                  char[] _aSep)
                                           throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_variables - 变量表
_aSep - 变量前缀和后缀分隔符
返回：
抛出：
WCMException

parsePageVariables

public static java.lang.String parsePageVariables(java.lang.String _sContent,
                                                  java.util.Map _variables,
                                                  int _nPgvarnameMaxLength)
                                           throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_variables - 变量表
_nPgvarnameMaxLength - 变量最大匹配长度
返回：
抛出：
WCMException

parsePageVariables

public static java.lang.String parsePageVariables(java.lang.String _sContent,
                                                  java.util.Map _variables,
                                                  char[] _aSep,
                                                  int _nPgvarnameMaxLength)
                                           throws WCMException
替换内容中的变量

参数：
_sContent - 正文内容
_variables - 变量表
_aSep - 变量前缀和后缀分隔符
_nPgvarnameMaxLength - 变量最大匹配长度
返回：
抛出：
WCMException

transPrettyUrl

public static java.lang.String transPrettyUrl(java.lang.String _sUrl,
                                              int _nMaxLen)

transPrettyUrl

public static java.lang.String transPrettyUrl(java.lang.String _sUrl,
                                              int _nMaxLen,
                                              java.lang.String _sSkimWord)

replaceStartEndSpaces

public static java.lang.String replaceStartEndSpaces(java.lang.String _strValue)
替换段首和段尾的空格

参数：
_strValue -
返回：

replaceParasStartEndSpaces

public static java.lang.String replaceParasStartEndSpaces(java.lang.String _strValue)
先拆分成段，再分别替换各段段首和段尾的空格

参数：
_strValue -
返回：

split2AttrMap

public static java.util.Map split2AttrMap(java.lang.String _sAttrStr)

format

public static java.lang.String format(java.lang.String _sFormat,
                                      java.lang.String[] _args)
用数组_args里面的第i个变量替换掉_sFormat中的{i}

参数：
_sFromat -
_args -
返回：

format

public static java.lang.String format(java.lang.String _sFormat,
                                      java.lang.Object[] _args)
用数组_args里面的第i个变量替换掉_sFormat中的{i}

参数：
_sFromat -
_args -
返回：

format

public static java.lang.String format(java.lang.String _sFormat,
                                      int[] _args)
用数组_args里面的第i个变量替换掉_sFormat中的{i}

参数：
_sFromat -
_args -
返回：

innerText

public static java.lang.String innerText(java.lang.String _strValue)

encodeForRegExp

public static java.lang.String encodeForRegExp(java.lang.String sSource)
对输入字符串中的正则表达式特殊字符进行转义，转成普通字符

参数：
sSource -
返回：

capitalize

public static java.lang.String capitalize(java.lang.String _strValue)

main

public static void main(java.lang.String[] args)
简单测试用例

参数：
args -
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyTimer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyTimer

java.lang.Object
    继承者  java.lang.Thread
        继承者  com.trs.infra.util.CMyTimer
所有已实现的接口：
java.lang.Runnable
public class CMyTimer
extends java.lang.Thread

Title: TRS 内容协作平台（TRS WCM）

Description:

class CMyFile —— 定时器对象的定义和实现

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

嵌套类摘要
从类 java.lang.Thread 继承的嵌套类/接口
java.lang.Thread.State, java.lang.Thread.UncaughtExceptionHandler
字段摘要
从类 java.lang.Thread 继承的字段
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
构造方法摘要
CMyTimer(java.lang.Runnable _target)
构造函数
方法摘要
int | getInerval() 获取间隔运行时间
boolean | isEnabled() 判断是否允许使用
boolean | isStopped() 判断是否已经停止
void | run() 运行
void | setEnabled(boolean _bEnabled) 设置是否允许使用
void | setInterval(int _interval) 设置间隔运行时间
void | toStop() 中止线程
从类 java.lang.Thread 继承的方法
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getAllStackTraces, getContextClassLoader, getDefaultUncaughtExceptionHandler, getId, getName, getPriority, getStackTrace, getState, getThreadGroup, getUncaughtExceptionHandler, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setDefaultUncaughtExceptionHandler, setName, setPriority, setUncaughtExceptionHandler, sleep, sleep, start, stop, stop, suspend, toString, yield
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMyTimer

public CMyTimer(java.lang.Runnable _target)
构造函数

参数：
_target - Runnable对象
方法详细信息

getInerval

public int getInerval()
获取间隔运行时间

返回：
间隔运行时间

setInterval

public void setInterval(int _interval)
设置间隔运行时间

参数：
_interval - 间隔运行时间

isEnabled

public boolean isEnabled()
判断是否允许使用

返回：

setEnabled

public void setEnabled(boolean _bEnabled)
设置是否允许使用

参数：
_bEnabled -

isStopped

public boolean isStopped()
判断是否已经停止

返回：

toStop

public void toStop()
中止线程

run

public final void run()
运行

指定者：
接口 java.lang.Runnable 中的 run
覆盖：
类 java.lang.Thread 中的 run
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyTransformCoding

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyTransformCoding

java.lang.Object
    继承者  com.trs.infra.util.CMyTransformCoding

public class CMyTransformCoding
extends java.lang.Object

Title: 网站内容管理（TRSWCM）

Description:

Copyright: Copyright (c) 2001

Company: www.trs.com.cn

版本：
1.0
作者：
com.trs.wcm

构造方法摘要
CMyTransformCoding()
方法摘要
 java.lang.String TransformCoding(java.lang.String strInput)
转换汉字内码：GB <=>BIG5.输入字符串的内码自动识别
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyTransformCoding

public CMyTransformCoding()
方法详细信息

TransformCoding

public java.lang.String TransformCoding(java.lang.String strInput)
转换汉字内码：GB <=>BIG5.输入字符串的内码自动识别

参数：
strInput - 转换前的字符串
strOutput - 内码转换后的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyUnzip

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyUnzip

java.lang.Object
    继承者  com.trs.infra.util.CMyUnzip

public class CMyUnzip
extends java.lang.Object

字段摘要
static boolean IS_DEBUG
调试开关
构造方法摘要
CMyUnzip()
方法摘要
java.lang.String | getEncoding() 取当前字符编码集
ZipEntry | getItem(java.lang.String _sItemName) 提取指定压缩项信息
java.util.Enumeration | getItems() 提取zip文件中的压缩项
static void | main(java.lang.String[] args)
void | setEncoding(java.lang.String _encoding) 设置字符编码集
void | setZipFile(java.lang.String _zipFileName) 设置zip文件
void | unzip(java.lang.String _sDstPath, boolean _bCreateDstPathIfNotExists) 解压缩操作
static void | unzip(java.lang.String _zipFileName, java.lang.String _dstPath, boolean _bCreateDstPathIfNotExists) 将指定的压缩文件解压缩到指定目录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_DEBUG

public static boolean IS_DEBUG
调试开关

构造方法详细信息

CMyUnzip

public CMyUnzip()
方法详细信息

getEncoding

public java.lang.String getEncoding()
取当前字符编码集

返回：
当前字符编码集

setEncoding

public void setEncoding(java.lang.String _encoding)
设置字符编码集

参数：
_encoding - 字符编码集；若为null，则表示为默认字符编码集

setZipFile

public void setZipFile(java.lang.String _zipFileName)
                throws CMyException
设置zip文件

参数：
_zipFileName - 压缩文件名
抛出：
CMyException - 若文件名无效，会抛出异常

getItems

public java.util.Enumeration getItems()
                               throws CMyException
提取zip文件中的压缩项

返回：
压缩文件中的压缩项枚举
抛出：
CMyException - 解析zip文件压缩项失败会抛出异常

getItem

public ZipEntry getItem(java.lang.String _sItemName)
                 throws CMyException
提取指定压缩项信息

参数：
_sItemName - 压缩项名称
返回：
压缩项信息
抛出：
CMyException - 解析zip文件压缩项失败会抛出异常

unzip

public void unzip(java.lang.String _sDstPath,
                  boolean _bCreateDstPathIfNotExists)
           throws CMyException
解压缩操作

参数：
_sDstPath - 解压缩后文件的存储路径
_bCreateDstPathIfNotExists - 指定若目标目录不存在是否创建
抛出：
CMyException - 解压缩失败会抛出异常

unzip

public static void unzip(java.lang.String _zipFileName,
                         java.lang.String _dstPath,
                         boolean _bCreateDstPathIfNotExists)
                  throws CMyException
将指定的压缩文件解压缩到指定目录

参数：
_zipFileName - 指定压缩文件
_dstPath - 解压缩后文件的存储路径
_bCreateDstPathIfNotExists - 指定若目标目录不存在是否创建
抛出：
CMyException - 解压缩失败会抛出异常

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyUnZipFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyUnZipFile

java.lang.Object
    继承者  com.trs.infra.util.CMyUnZipFile

public class CMyUnZipFile
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Zip文件解压对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyUnZipFile(java.lang.String _sZipFile, java.lang.String _sUnZipPath)
方法摘要
void | addFileExtFilters(java.lang.String _sFileExt) 添加需要过滤的文件扩展名
void | doUnZipAnd()
java.util.Hashtable | getAllFileNameIndex() 获取ZIP中所有文件的文件名索引
java.util.ArrayList | getFileExtFilters() 获取需要过滤的文件扩展名列表
java.lang.String | getFileNameEncoding()
java.util.ArrayList | getFilteredFiles() 获取按照后缀名过滤器的设置过滤后的文件列表
java.lang.String | getUnZipPath() 返回解压路径
java.lang.String | getZipFile() 获取需要解压的文件
static void | main(java.lang.String[] args)
void | setFileNameEncoding(java.lang.String fileNameEncoding)
void | setUnZipPath(java.lang.String unZipPath) 设置解压路径
void | setZipFile(java.lang.String zipFile) 设置需要解压的文件
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyUnZipFile

public CMyUnZipFile(java.lang.String _sZipFile,
                    java.lang.String _sUnZipPath)
方法详细信息

doUnZipAnd

public void doUnZipAnd()
                throws CMyException
抛出：
CMyException

getZipFile

public java.lang.String getZipFile()
获取需要解压的文件

返回：

setZipFile

public void setZipFile(java.lang.String zipFile)
设置需要解压的文件

参数：
zipFile - 需要解压的文件（绝对路径）

getAllFileNameIndex

public java.util.Hashtable getAllFileNameIndex()
获取ZIP中所有文件的文件名索引

返回：
ZIP中所有文件的文件名索引（Hashtable Key：大写的文件名）

getFileExtFilters

public java.util.ArrayList getFileExtFilters()
获取需要过滤的文件扩展名列表

返回：

addFileExtFilters

public void addFileExtFilters(java.lang.String _sFileExt)
添加需要过滤的文件扩展名

参数：
_sFileExt - 需要过滤的文件扩展名

getFileNameEncoding

public java.lang.String getFileNameEncoding()
返回：
Returns the fileNameEncoding.

setFileNameEncoding

public void setFileNameEncoding(java.lang.String fileNameEncoding)
参数：
fileNameEncoding - The fileNameEncoding to set.

getUnZipPath

public java.lang.String getUnZipPath()
返回解压路径

返回：
解压路径（绝对路径）

setUnZipPath

public void setUnZipPath(java.lang.String unZipPath)
设置解压路径

参数：
unZipPath -

getFilteredFiles

public java.util.ArrayList getFilteredFiles()
获取按照后缀名过滤器的设置过滤后的文件列表

返回：
按照后缀名过滤器的设置过滤后的文件列表（List）

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyURLEncoder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyURLEncoder

java.lang.Object
    继承者  com.trs.infra.util.CMyURLEncoder

public class CMyURLEncoder
extends java.lang.Object

Utility class for HTML form encoding. This class contains static methods for converting a String to the application/x-www-form-urlencoded MIME format. For more information about HTML form encoding, consult the HTML specification .

When encoding a String, the following rules apply:

  • The alphanumeric characters " a " through " z ", " A " through " Z " and " 0 " through " 9 " remain the same.
  • The special characters " . ", " - ", " * ", and " _ " remain the same.
  • The space character "   " is converted into a plus sign " + ".
  • All other characters are unsafe and are first converted into one or more bytes using some encoding scheme. Then each byte is represented by the 3-character string " %xy ", where xy is the two-digit hexadecimal representation of the byte. The recommended encoding scheme to use is UTF-8. However, for compatibility reasons, if an encoding is not specified, then the default encoding of the platform is used.

For example using UTF-8 as the encoding scheme the string "The string ü@foo-bar" would get converted to "The+string+%C3%BC%40foo-bar" because in UTF-8 the character ü is encoded as two bytes C3 (hex) and BC (hex), and the character @ is encoded as one byte 40 (hex).

从以下版本开始：
JDK1.0
版本：
1.25, 12/03/01
作者：
Herb Jellinek

方法摘要
static java.lang.String encode(java.lang.String s)
已过时。 The resulting string may vary depending on the platform's default encoding. Instead, use the encode(String,String) method to specify the encoding.
static java.lang.String encode(java.lang.String s, java.lang.String enc)
Translates a string into application/x-www-form-urlencoded format using a specific encoding scheme.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

encode

public static java.lang.String encode(java.lang.String s)
已过时。 The resulting string may vary depending on the platform's default encoding. Instead, use the encode(String,String) method to specify the encoding.

Translates a string into x-www-form-urlencoded format. This method uses the platform's default encoding as the encoding scheme to obtain the bytes for unsafe characters.

参数：
s - String to be translated.
返回：
the translated String.

encode

public static java.lang.String encode(java.lang.String s,
                                      java.lang.String enc)
                               throws java.io.UnsupportedEncodingException
Translates a string into application/x-www-form-urlencoded format using a specific encoding scheme. This method uses the supplied encoding scheme to obtain the bytes for unsafe characters.

Note: The World Wide Web Consortium Recommendation states that UTF-8 should be used. Not doing so may introduce incompatibilites.

参数：
s - String to be translated.
enc - The name of a supported character encoding .
返回：
the translated String.
抛出：
java.io.UnsupportedEncodingException - If the named encoding is not supported
另请参见：
URLDecoder.decode(java.lang.String, java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyXMLDoc

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyXMLDoc

java.lang.Object
    继承者  com.trs.infra.util.CMyXMLDoc

public class CMyXMLDoc
extends java.lang.Object

构造方法摘要
CMyXMLDoc()
方法摘要
static void | main(java.lang.String[] args)
static void | toFile(org.jdom.Document _XMLDoc, java.lang.String _XMLFileName)
static void | toFile(org.jdom.Document _XMLDoc, java.lang.String _XMLFileName, java.lang.String _XSLFileName)
static java.lang.String | toString(org.jdom.Document _XMLDoc) 根据DOM树，生成字符串
static java.lang.String | toString(org.jdom.Document _XMLDoc, java.lang.String _sXMLEncoding) 根据DOM树，生成字符串
static java.lang.String | toString(org.jdom.Element _xmlElement) 根据DOM树，生成字符串
static java.lang.String | toString(org.jdom.Element _XMLElement, java.lang.String _sXMLEncoding) 根据DOM树，生成字符串
static org.jdom.Document | toXMLDocument(java.lang.String _sXMLFile) 将XML文件解析成DOM结构，返回XML Document对象
static org.jdom.Document | toXMLDocument(java.lang.String _sXMLFile, java.lang.String _sXSLFile) 将XML文件解析成DOM结构，返回XML Document对象
static void | toXMLFile(org.jdom.Document _XMLDoc, java.lang.String _sXMLFileName, java.lang.String _sXMLEncoding) 根据DOM 树生成XML文件
static void | toXMLFile(org.jdom.Document _XMLDoc, java.lang.String _XMLFileName, java.lang.String _XSLFileName, java.lang.String _XMLEncoding) 根据DOM 树生成XML文件
static boolean | transformXML(java.lang.String _XMLSource, java.lang.String _XSLSource, java.lang.String _XMLTarget) 根据XSL模板文件生成XML文件
static boolean | transformXML(java.lang.String _XMLSource, java.lang.String _XSLSource, java.lang.String _XMLTarget, java.lang.String _XMLEncoding) 根据XSL模板文件生成XML文件
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyXMLDoc

public CMyXMLDoc()
方法详细信息

toXMLDocument

public static org.jdom.Document toXMLDocument(java.lang.String _sXMLFile)
                                       throws CMyException
将XML文件解析成DOM结构，返回XML Document对象

参数：
_sXMLFile - 待转换的XML文件，必须设置
返回：
XML Document对象
抛出：
CMyException - 如果指定的XML文件不存在，抛出
如果解析失败，抛出XML解析异常

toXMLDocument

public static org.jdom.Document toXMLDocument(java.lang.String _sXMLFile,
                                              java.lang.String _sXSLFile)
                                       throws CMyException
将XML文件解析成DOM结构，返回XML Document对象

参数：
_sXMLFile - 待转换的XML文件，必须设置
_sXSLFile - XSLT文件，可以不设置
返回：
XML Document对象
抛出：
CMyException - 如果指定的XML文件不存在，抛出
如果解析失败，抛出XML解析异常

transformXML

public static boolean transformXML(java.lang.String _XMLSource,
                                   java.lang.String _XSLSource,
                                   java.lang.String _XMLTarget)
                            throws CMyException
根据XSL模板文件生成XML文件

参数：
_XMLSource - XML源文件
_XSLSource - XSL文件名
_XMLTarget - 目标文件
返回：
@throws CMyException
抛出：
CMyException

toFile

public static void toFile(org.jdom.Document _XMLDoc,
                          java.lang.String _XMLFileName)
                   throws CMyException
抛出：
CMyException
另请参见：
toXMLFile(Document, String, String)

toFile

public static void toFile(org.jdom.Document _XMLDoc,
                          java.lang.String _XMLFileName,
                          java.lang.String _XSLFileName)
                   throws CMyException
抛出：
CMyException

toString

public static java.lang.String toString(org.jdom.Document _XMLDoc)
根据DOM树，生成字符串

参数：
_XMLDoc - XML Document对象，org.jdom.Document对象
返回：

toString

public static java.lang.String toString(org.jdom.Element _xmlElement)
根据DOM树，生成字符串

参数：
_XMLDoc - XML Document对象，org.jdom.Document对象
返回：

main

public static void main(java.lang.String[] args)

toXMLFile

public static void toXMLFile(org.jdom.Document _XMLDoc,
                             java.lang.String _sXMLFileName,
                             java.lang.String _sXMLEncoding)
                      throws CMyException
根据DOM 树生成XML文件

参数：
_XMLDoc - XML Document对象，org.jdom.Document对象
_XMLFileName - 输出的XML文件名
_sXMLEncoding - XML文件的字符编码集
抛出：
CMyException

toXMLFile

public static void toXMLFile(org.jdom.Document _XMLDoc,
                             java.lang.String _XMLFileName,
                             java.lang.String _XSLFileName,
                             java.lang.String _XMLEncoding)
                      throws CMyException
根据DOM 树生成XML文件

参数：
_XMLDoc - XML Document对象，org.jdom.Document对象
_XMLFileName - 输出的XML文件名
_XSLFileName - XSL文件名，用于XML转换；可缺省，默认值为不转换。
_XMLEncoding - XML文件的字符编码集
抛出：
CMyException

toString

public static java.lang.String toString(org.jdom.Document _XMLDoc,
                                        java.lang.String _sXMLEncoding)
根据DOM树，生成字符串

参数：
_XMLDoc - XML Document对象，org.jdom.Document对象
_sXMLEncoding - 字符编码集
返回：

toString

public static java.lang.String toString(org.jdom.Element _XMLElement,
                                        java.lang.String _sXMLEncoding)
根据DOM树，生成字符串

参数：
_XMLDoc - XML Document对象，org.jdom.Document对象
_sXMLEncoding - 字符编码集
返回：

transformXML

public static boolean transformXML(java.lang.String _XMLSource,
                                   java.lang.String _XSLSource,
                                   java.lang.String _XMLTarget,
                                   java.lang.String _XMLEncoding)
                            throws CMyException
根据XSL模板文件生成XML文件

参数：
_XMLSource - XML源文件
_XSLSource - XSL文件名
_XMLTarget - 目标文件
_XMLEncoding - XML文件的字符编码集
返回：
@throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyXMLElement

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyXMLElement

java.lang.Object
    继承者  com.trs.infra.util.CMyXMLElement
直接已知子类：
CMyBeanConfig, CMyClassConfig
public class CMyXMLElement
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
定义解析XML格式的配置文件后，各配置属性的存储数据结构 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyXMLElement()
方法摘要
boolean | addChild(CMyXMLElement _config)
void | clear()
CMyXMLElement | getChild(java.lang.String _sChildName)
java.util.List | getChildren()
java.util.List | getChildren(java.lang.String _sChildName)
java.lang.String | getName()
java.util.Map | getProperties()
java.util.List | getPropertiesList()
java.lang.String | getProperty(java.lang.String _sPropertyName) get the value of the specified property.
boolean | getPropertyAsBoolean(java.lang.String _sName, boolean _bDefault) get the boolean property value
int | getPropertyAsInt(java.lang.String _sName, int _nDefault)
java.util.Iterator | getPropertyNames()
java.lang.String | getPropertyTrim(java.lang.String _sName) get the trimed value of the specified property.
java.lang.String | getPropertyTrim(java.lang.String _sName, java.lang.String _sDefault) get the trimed value of the specified property.
java.lang.String | getRequiredPropertyTrim(java.lang.String _sName) get the trimed value of a required property
boolean | setName(java.lang.String _sName)
boolean | setProperties(java.util.HashMap _properties)
boolean | setProperty(java.lang.String _sPropertyName, java.lang.String _sValue)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyXMLElement

public CMyXMLElement()
方法详细信息

clear

public void clear()

getChildren

public java.util.List getChildren()

addChild

public boolean addChild(CMyXMLElement _config)

getPropertyNames

public java.util.Iterator getPropertyNames()

getProperty

public java.lang.String getProperty(java.lang.String _sPropertyName)
get the value of the specified property.

参数：
_sPropertyName - the property name.
返回：
Returns null if the property name is null/empty or the property is not found; otherwise, returns the property value.

getPropertyTrim

public java.lang.String getPropertyTrim(java.lang.String _sName)
get the trimed value of the specified property.

参数：
_sName - the property name
返回：
Returns the trimed value of the property if found; otherwise, returns null.

getPropertyTrim

public java.lang.String getPropertyTrim(java.lang.String _sName,
                                        java.lang.String _sDefault)
get the trimed value of the specified property.

参数：
_sName - the property name
_sDefault - default value if the property value is not set.
返回：
Returns the trimed value of the property if found; otherwise, returns the default value.

getRequiredPropertyTrim

public java.lang.String getRequiredPropertyTrim(java.lang.String _sName)
                                         throws WCMException
get the trimed value of a required property

参数：
_sName - the property name.
返回：
Returns the trimed value of the property.
抛出：
WCMException - if the property does not exist or its value is empty.

setProperty

public boolean setProperty(java.lang.String _sPropertyName,
                           java.lang.String _sValue)

getName

public java.lang.String getName()

setName

public boolean setName(java.lang.String _sName)

setProperties

public boolean setProperties(java.util.HashMap _properties)

getChildren

public java.util.List getChildren(java.lang.String _sChildName)

getChild

public CMyXMLElement getChild(java.lang.String _sChildName)

getProperties

public java.util.Map getProperties()

getPropertiesList

public java.util.List getPropertiesList()

getPropertyAsInt

public int getPropertyAsInt(java.lang.String _sName,
                            int _nDefault)

getPropertyAsBoolean

public boolean getPropertyAsBoolean(java.lang.String _sName,
                                    boolean _bDefault)
get the boolean property value

参数：
_sName - the property name
_bDefault - the default value if the property does not exist or is empty.
返回：
Returns the default value if property does not exist or is empty; otherwise, returns the booloean value.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyXMLHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyXMLHandler

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
        继承者  com.trs.infra.util.CMyXMLHandler
所有已实现的接口：
org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class CMyXMLHandler
extends org.xml.sax.helpers.DefaultHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
处理XML配置文件，解析成为CMyXMLConfig Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyXMLHandler()
CMyXMLHandler(java.lang.Class _class)
方法摘要
void | characters(char[] ch, int start, int length)
void | endElement(java.lang.String uri, java.lang.String localName, java.lang.String qName)
java.lang.Class | getConfigClass()
CMyXMLElement | getRootConfig()
void | setConfigClass(java.lang.Class configClass)
void | setRootConfig(CMyXMLElement rootConfig)
void | startElement(java.lang.String uri, java.lang.String localName, java.lang.String qName, org.xml.sax.Attributes attributes)
从类 org.xml.sax.helpers.DefaultHandler 继承的方法
endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyXMLHandler

public CMyXMLHandler()

CMyXMLHandler

public CMyXMLHandler(java.lang.Class _class)
              throws java.lang.Exception
抛出：
java.lang.Exception
方法详细信息

characters

public void characters(char[] ch,
                       int start,
                       int length)
指定者：
接口 org.xml.sax.ContentHandler 中的 characters
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 characters

endElement

public void endElement(java.lang.String uri,
                       java.lang.String localName,
                       java.lang.String qName)
指定者：
接口 org.xml.sax.ContentHandler 中的 endElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 endElement

startElement

public void startElement(java.lang.String uri,
                         java.lang.String localName,
                         java.lang.String qName,
                         org.xml.sax.Attributes attributes)
                  throws org.xml.sax.SAXException
指定者：
接口 org.xml.sax.ContentHandler 中的 startElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 startElement
抛出：
org.xml.sax.SAXException

getRootConfig

public CMyXMLElement getRootConfig()

getConfigClass

public java.lang.Class getConfigClass()
返回：

setConfigClass

public void setConfigClass(java.lang.Class configClass)
参数：
configClass -

setRootConfig

public void setRootConfig(CMyXMLElement rootConfig)
参数：
rootConfig -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyXMLParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyXMLParser

java.lang.Object
    继承者  com.trs.infra.util.CMyXMLParser

public class CMyXMLParser
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
根据XML配置文件解析成为CMyXMLConfig Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMyXMLParser()
方法摘要
static CMyXMLElement | fileToElement(java.lang.String _sResourceFileName)
static CMyXMLElement | fileToElement(java.lang.String _sResourceFileName, java.lang.Class _class)
static CMyXMLElement | filtToElement(java.lang.String _sResourceFileName, java.lang.Class _class, java.lang.String _sEncoding)
static CMyXMLElement | streamToElement(java.io.InputStream _isContent, java.lang.Class _class, java.lang.String _sEncoding)
static CMyXMLElement | strToElement(java.lang.String _sContent)
static CMyXMLElement | strToElement(java.lang.String _sContent, java.lang.Class _class)
static CMyXMLElement | strToElement(java.lang.String _sContent, java.lang.Class _class, java.lang.String _sEncoding)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMyXMLParser

public CMyXMLParser()
方法详细信息

strToElement

public static CMyXMLElement strToElement(java.lang.String _sContent)
                                  throws java.lang.Exception
抛出：
java.lang.Exception

strToElement

public static CMyXMLElement strToElement(java.lang.String _sContent,
                                         java.lang.Class _class)
                                  throws java.lang.Exception
抛出：
java.lang.Exception

strToElement

public static CMyXMLElement strToElement(java.lang.String _sContent,
                                         java.lang.Class _class,
                                         java.lang.String _sEncoding)
                                  throws java.lang.Exception
抛出：
java.lang.Exception

fileToElement

public static CMyXMLElement fileToElement(java.lang.String _sResourceFileName)
                                   throws WCMException
抛出：
WCMException

fileToElement

public static CMyXMLElement fileToElement(java.lang.String _sResourceFileName,
                                          java.lang.Class _class)
                                   throws WCMException
抛出：
WCMException

filtToElement

public static CMyXMLElement filtToElement(java.lang.String _sResourceFileName,
                                          java.lang.Class _class,
                                          java.lang.String _sEncoding)
                                   throws WCMException
抛出：
WCMException

streamToElement

public static CMyXMLElement streamToElement(java.io.InputStream _isContent,
                                            java.lang.Class _class,
                                            java.lang.String _sEncoding)
                                     throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyZip

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CMyZip

java.lang.Object
    继承者  com.trs.infra.util.CMyZip

public class CMyZip
extends java.lang.Object

字段摘要
static boolean IS_DEBUG
Debug 模式开关
构造方法摘要
CMyZip()
方法摘要
void | addToZip(java.lang.String p_srcToZip)
void | addToZip(java.lang.String p_srcToZip, boolean p_bAddPathToEntryName) 将指定文件或目录，添加到压缩包
void | addToZip(java.lang.String p_srcToZip, java.lang.String _sEntryName)
boolean | done()
java.lang.String | getEncoding() 取当前字符编码集
static void | main(java.lang.String[] args)
void | setEncoding(java.lang.String _encoding) 设置字符编码集
void | setZipFileName(java.lang.String p_sZipFileName) 设置压缩后的目标Zip文件名
void | setZipWithChildDirPath(boolean _bZipWithChildDirPath) 设置在不包含路径压缩时是否包含子目录的路径,默认为不包含 例如:要压缩目录src目录下的文件,src下包含images目录和1.txt文件 如果设置为 true 则把images目录包含.
void | zip(java.lang.String p_srcToZip, java.lang.String p_sZipFile)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_DEBUG

public static boolean IS_DEBUG
Debug 模式开关

构造方法详细信息

CMyZip

public CMyZip()
方法详细信息

getEncoding

public java.lang.String getEncoding()
取当前字符编码集

返回：
当前字符编码集

setEncoding

public void setEncoding(java.lang.String _encoding)
设置字符编码集

参数：
_encoding - 字符编码集；若为null，则表示为默认字符编码集

setZipFileName

public void setZipFileName(java.lang.String p_sZipFileName)
                    throws CMyException
设置压缩后的目标Zip文件名

参数：
p_sZipFileName - 目标zip文件名
抛出：
CMyException - 若上次压缩操作未完成，则抛出异常

addToZip

public void addToZip(java.lang.String p_srcToZip)
              throws CMyException
抛出：
CMyException

addToZip

public void addToZip(java.lang.String p_srcToZip,
                     java.lang.String _sEntryName)
              throws CMyException
抛出：
CMyException

addToZip

public void addToZip(java.lang.String p_srcToZip,
                     boolean p_bAddPathToEntryName)
              throws CMyException
将指定文件或目录，添加到压缩包

参数：
p_srcToZip - 要压缩的源文件或目录
p_bAddPathToEntryName - 是否在zip条目名称中加入目录信息。可选，默认值为true
注意：若参数p_bAddPathToEntryName=true，则不判断重复（由调用者处理）。
抛出：
CMyException - 若压缩失败，则抛出异常

done

public boolean done()
             throws CMyException
抛出：
CMyException

zip

public void zip(java.lang.String p_srcToZip,
                java.lang.String p_sZipFile)
         throws CMyException
抛出：
CMyException

main

public static void main(java.lang.String[] args)

setZipWithChildDirPath

public void setZipWithChildDirPath(boolean _bZipWithChildDirPath)
设置在不包含路径压缩时是否包含子目录的路径,默认为不包含
例如:要压缩目录src目录下的文件,src下包含images目录和1.txt文件
如果设置为 true 则把images目录包含.

参数：
_bZipWithChildDirPath -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigElementContentTester

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 ConfigElementContentTester

java.lang.Object
    继承者  com.trs.infra.util.ConfigElementContentTester

public final class ConfigElementContentTester
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
帮助类，为了更方便地对配置文件进行初步检验
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ConfigElementContentTester()
方法摘要
static java.util.List | checkConfigCounter(java.lang.Class clzConfig) 检查指定Class的配置类的数目（即extension的直接子节点个数）
static boolean | isRecursive()
static void | printDetail(java.lang.Object _oConfig) 打印出配置对象的所有公开的"get"属性
static void | printDetail(java.lang.Object _oConfig, java.lang.String _sName) 打印出配置对象的所有公开的"get"属性
static void | setRecursive(boolean recursive)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConfigElementContentTester

public ConfigElementContentTester()
方法详细信息

checkConfigCounter

public static java.util.List checkConfigCounter(java.lang.Class clzConfig)
检查指定Class的配置类的数目（即extension的直接子节点个数）

参数：
clzConfig -
返回：

printDetail

public static void printDetail(java.lang.Object _oConfig,
                               java.lang.String _sName)
打印出配置对象的所有公开的"get"属性

参数：
_oConfig -
_sName -

printDetail

public static void printDetail(java.lang.Object _oConfig)
打印出配置对象的所有公开的"get"属性

参数：
_oConfig -

isRecursive

public static boolean isRecursive()

setRecursive

public static void setRecursive(boolean recursive)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CopyOfTRSImportsOrgnize

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CopyOfTRSImportsOrgnize

java.lang.Object
    继承者  com.trs.infra.util.CopyOfTRSImportsOrgnize

public class CopyOfTRSImportsOrgnize
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.util.ArrayList | arExcludeClass
static java.lang.String | CLASSES_PATH_FLAG
static java.lang.String[] | EXCLUDE_PATH
static java.lang.String | FLAG_PAGE_START
static java.util.Hashtable | hTRSClasses
static java.lang.String[] | OPERATION_STR
static int | TYPE_CODE_END
static int | TYPE_CODE_START
static int | TYPE_COMMENT
static int | TYPE_HTML_VALUE
static int | TYPE_INCLUDE
static int | TYPE_NOFLAG
static int | TYPE_PAGE_START
构造方法摘要
CopyOfTRSImportsOrgnize()
方法摘要
static java.lang.String | dowithFile(java.lang.String _sFileName)
static java.util.ArrayList | dowithLine(java.lang.String _sLine)
static void | dowithPath(java.lang.String _sPath)
static java.util.Hashtable | getFileHashtable(java.lang.String _sPath)
static void | initExcludeClass()
static boolean | isExcludeClass(java.lang.String _sClassName)
static void | main(java.lang.String[] args)
static java.lang.String | mapClassFullPath(java.lang.String _sClassName)
static java.lang.String | transformPathToClassPath(java.lang.String _sAbsoluteFile)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CLASSES_PATH_FLAG

public static final java.lang.String CLASSES_PATH_FLAG

FLAG_PAGE_START

public static final java.lang.String FLAG_PAGE_START
另请参见：
常量字段值

TYPE_NOFLAG

public static final int TYPE_NOFLAG
另请参见：
常量字段值

TYPE_PAGE_START

public static final int TYPE_PAGE_START
另请参见：
常量字段值

TYPE_INCLUDE

public static final int TYPE_INCLUDE
另请参见：
常量字段值

TYPE_HTML_VALUE

public static final int TYPE_HTML_VALUE
另请参见：
常量字段值

TYPE_CODE_START

public static final int TYPE_CODE_START
另请参见：
常量字段值

TYPE_CODE_END

public static final int TYPE_CODE_END
另请参见：
常量字段值

TYPE_COMMENT

public static final int TYPE_COMMENT
另请参见：
常量字段值

OPERATION_STR

public static final java.lang.String[] OPERATION_STR

EXCLUDE_PATH

public static final java.lang.String[] EXCLUDE_PATH

arExcludeClass

public static java.util.ArrayList arExcludeClass

hTRSClasses

public static java.util.Hashtable hTRSClasses
构造方法详细信息

CopyOfTRSImportsOrgnize

public CopyOfTRSImportsOrgnize()
方法详细信息

initExcludeClass

public static void initExcludeClass()

isExcludeClass

public static boolean isExcludeClass(java.lang.String _sClassName)

transformPathToClassPath

public static java.lang.String transformPathToClassPath(java.lang.String _sAbsoluteFile)

getFileHashtable

public static java.util.Hashtable getFileHashtable(java.lang.String _sPath)

mapClassFullPath

public static java.lang.String mapClassFullPath(java.lang.String _sClassName)

dowithPath

public static void dowithPath(java.lang.String _sPath)
                       throws java.lang.Exception
抛出：
java.lang.Exception

dowithFile

public static java.lang.String dowithFile(java.lang.String _sFileName)
                                   throws CMyException
抛出：
CMyException

dowithLine

public static java.util.ArrayList dowithLine(java.lang.String _sLine)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CPager

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 CPager

java.lang.Object
    继承者  com.trs.infra.util.CPager

public class CPager
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）

Description:

class CPager —— 分页对象，为解决Web中集合的分页显示而设

* 支持两种方式下的分页问题：
（1）java.sql.ResultSet的分页；
（2）列表集合的分页（如：Vector list）
* 注意：页面、记录的序号均从1开始

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int DEFAULT_PAGE_SIZE
构造方法摘要
CPager()
构造函数
CPager(int p_nPageSize)
构造函数
方法摘要
boolean | atFirstPage() 判断是否是在第一页
boolean | atLastPage() 判断是否是在最后一页
int | getCurrentPageIndex() 获取目前所在的页
int | getCurrentPageSize() 获取目前页面的记录数
int | getFirstItemIndex() 取第一个元素的索引号
int | getItemCount() 获取记录数
int | getLastItemIndex() 取最后一个元素的索引号
int | getNextPageIndex() 取下一页的页号
int | getPageCount() 获取页数
java.lang.String | getPageHref(int p_PageIndex) 取页面链接
int | getPageSize() 获取页面大小
int | getPrePageIndex() 取前一页的页号
static void | main(java.lang.String[] args)
void | moveToCurrentPageInRs(java.sql.ResultSet p_rsData) 在记录集中定位到当前页
void | setCurrentPageIndex(int newCurrentPageIndex) 设置目前的所在的页面
void | setItemCount(int p_nItemCount) 设定元素总数：直接指定
void | setItemCount(java.sql.Statement p_oStmt, java.lang.String p_sCountSQL) 设定元素总数：通过指定查询SQL语句，在数据库中检索
void | setPageHrefPre(java.lang.String p_sPageHrefPre) 设置页面链接的前面部分 如：".
void | setPageSize(int newPageSize) 设置页面大小
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_PAGE_SIZE

public static final int DEFAULT_PAGE_SIZE
另请参见：
常量字段值
构造方法详细信息

CPager

public CPager()
构造函数

CPager

public CPager(int p_nPageSize)
构造函数

参数：
p_nPageSize - 页面大小
方法详细信息

setItemCount

public void setItemCount(int p_nItemCount)
设定元素总数：直接指定

参数：
p_nItemCount -

setItemCount

public void setItemCount(java.sql.Statement p_oStmt,
                         java.lang.String p_sCountSQL)
                  throws CMyException
设定元素总数：通过指定查询SQL语句，在数据库中检索

参数：
p_oStmt - java.sql.Statement对象
p_sCountSQL - SQL语句
抛出：
CMyException

moveToCurrentPageInRs

public void moveToCurrentPageInRs(java.sql.ResultSet p_rsData)
                           throws CMyException
在记录集中定位到当前页

参数：
p_rsData - 记录集对象java.sql.ResultSet
抛出：
CMyException

atFirstPage

public boolean atFirstPage()
判断是否是在第一页

返回：

atLastPage

public boolean atLastPage()
判断是否是在最后一页

返回：

getFirstItemIndex

public int getFirstItemIndex()
取第一个元素的索引号

返回：

getLastItemIndex

public int getLastItemIndex()
取最后一个元素的索引号

返回：

getPrePageIndex

public int getPrePageIndex()
取前一页的页号

返回：

getNextPageIndex

public int getNextPageIndex()
取下一页的页号

返回：

setPageHrefPre

public void setPageHrefPre(java.lang.String p_sPageHrefPre)
设置页面链接的前面部分
如："./myjsp.jsp?Pg="

参数：
p_sPageHrefPre -

getPageHref

public java.lang.String getPageHref(int p_PageIndex)
取页面链接

参数：
p_PageIndex - 页面位置
返回：

getPageSize

public int getPageSize()
获取页面大小

返回：

setPageSize

public void setPageSize(int newPageSize)
设置页面大小

参数：
newPageSize - 页面大小

getItemCount

public int getItemCount()
获取记录数

返回：

getPageCount

public int getPageCount()
获取页数

返回：

setCurrentPageIndex

public void setCurrentPageIndex(int newCurrentPageIndex)
设置目前的所在的页面

参数：
newCurrentPageIndex - 页码

getCurrentPageIndex

public int getCurrentPageIndex()
获取目前所在的页

返回：

getCurrentPageSize

public int getCurrentPageSize()
获取目前页面的记录数

返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DebugTimer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 DebugTimer

java.lang.Object
    继承者  com.trs.infra.util.DebugTimer

public class DebugTimer
extends java.lang.Object

构造方法摘要
DebugTimer()
方法摘要
long | getTime()
void | start()
void | stop()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DebugTimer

public DebugTimer()
方法详细信息

start

public void start()

stop

public void stop()

getTime

public long getTime()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DiscoveryFactoryBuddy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 DiscoveryFactoryBuddy

java.lang.Object
    继承者  com.trs.infra.util.DiscoveryFactoryBuddy

public class DiscoveryFactoryBuddy
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

构造方法摘要
DiscoveryFactoryBuddy()
方法摘要
static java.lang.Object getImplementor(java.lang.Class _clz)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DiscoveryFactoryBuddy

public DiscoveryFactoryBuddy()
方法详细信息

getImplementor

public static java.lang.Object getImplementor(java.lang.Class _clz)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExceptionMessages

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 ExceptionMessages

java.lang.Object
    继承者  com.trs.infra.util.ExceptionMessages

public class ExceptionMessages
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static java.lang.String getString(int _nErrorNumber)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getString

public static java.lang.String getString(int _nErrorNumber)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExceptionNumber

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 ExceptionNumber

java.lang.Object
    继承者  com.trs.infra.util.ExceptionNumber

public class ExceptionNumber
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
异常编号及描述汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | ERR_CLASS_CONFIG 错误编号：类配置错误
static int | ERR_CLASS_NOTFOUND 错误编号：class未找到
static int | ERR_CONFIG_MISSING 错误编号：缺少配置
static int | ERR_CONNECTION_GETFAIL 错误编号常量:取数据库连接失败
static int | ERR_DATACONVERT 错误编号常量:数据转化错误
static int | ERR_DBOP_FAIL 错误编号常量:数据库操作失败
static int | ERR_DOC_DUPLICATED 文档无法移动或转发到自身所在频道
static int | ERR_FACTORY_CONFIG 工厂文件配置错误
static int | ERR_FILE_NOTFOUND 错误编号常量:文件未找到
static int | ERR_FILEOP_CLOSE 错误编号常量:关闭文件失败
static int | ERR_FILEOP_FAIL 错误编号常量:文件操作失败
static int | ERR_FILEOP_MOVE 错误编号常量:移动文件失败
static int | ERR_FILEOP_OPEN 错误编号常量:打开文件失败
static int | ERR_FILEOP_READ 错误编号常量:读文件失败
static int | ERR_FILEOP_WRITE 错误编号常量:写文件失败
static int | ERR_HOST_NOT_FOUND
static int | ERR_IMPORTFILE_INVALID 导入的文件格式不支持
static int | ERR_INSTANCE_INVALID 通过Class.newInstance,创建BaseObj对象实例失败
static int | ERR_MESSAGE 消息
static int | ERR_MESSAGE_UNKNOWN_SENDTYPE unknown message send type
static int | ERR_MYEXCEPTION 错误编号常量:数据转化错误
static int | ERR_NET_OPENSTREAM 错误编号常量:打开网络数据流失败
static int | ERR_NEW_INSTANCE 错误编号常量：实例话对象失败
static int | ERR_NEWOBJ_INVALID 新建对象无效
static int | ERR_NUMOP_FAIL 错误编号常量:数学运算错误
static int | ERR_OBJ_LOCKED 对象已被其他用户锁定
static int | ERR_OBJ_NOTFOUND
static int | ERR_OBJ_NOTLOCKED 对象未锁定
static int | ERR_OBJ_NULL 错误编号常量: 空指针
static int | ERR_PARAM_INVALID 错误编号常量:无效参数
static int | ERR_PROPERTY_NOT_EXIST 不存在该属性
static int | ERR_PROPERTY_NOT_MODIFIED 对象属性没有修改
static int | ERR_PROPERTY_NOT_SET 对象属性没有设置
static int | ERR_PROPERTY_NOTALLOW_EDIT 属性不允许修改
static int | ERR_PROPERTY_TYPE_INVALID 属性类型不匹配
static int | ERR_PROPERTY_VALUE_DUPLICATED 属性值重复
static int | ERR_PROPERTY_VALUE_INVALID 属性值无效
static int | ERR_PUBLISH publish error
static int | ERR_PUBLISH_ANALYZE_DETAIL_PAGE_TASK publish error: failed to analyze the detail page tasks
static int | ERR_PUBLISH_CANCEL_TASK publish error: failed to cancel the publish task
static int | ERR_PUBLISH_CREATE_TASK publish error: failed to create publish task
static int | ERR_PUBLISH_DETAIL_TEMPLATE_REQUIRED publish error: detail template required
static int | ERR_PUBLISH_FIlE_DISTRIBUTE publish error: failed to distribute the file
static int | ERR_PUBLISH_OUTLINE_TEMPLATE_REQUIRED publish error: outline template required
static int | ERR_PUBLISH_PAGE_GENERATE publish error: failed to generate page
static int | ERR_PUBLISH_SERVER_NOTSTARTED publish error: the publish server has not been started
static int | ERR_PUBLISH_TAG_PARSE publish error: failed to parse the specified tag
static int | ERR_PUBLISH_TAG_PROPERTY_VALUE_INVALID publish error: invalid tag property value
static int | ERR_PUBLISH_TAGDOC_GRAMMAR_ILLEGAL publish error: tag document grammar is illegal
static int | ERR_PUBLISH_TASK_STILLOPEN publish error: the publish task is still open (has not been executed)
static int | ERR_PUBLISH_TEMPLATE_SEMANTIC_ANALYSE publish error: failed to analyze the semantic relations in template
static int | ERR_PUBLISH_UNKNOWN_CONTENT_TYPE publish error: unknown publish content type
static int | ERR_PUBLISH_UNKNOWN_FOLDER_TYPE publish error: unknown publish folder type
static int | ERR_PUBLISH_UNKNOWN_PUBLISH_TYPE publish error: unknown publish type
static int | ERR_PUBLISH_UPDATE_QUOTING_FOLDERS publish error: fails to update the quoting folders
static int | ERR_REFRESH_NOTIFICATION_SERVER failed to refresh the notification server
static int | ERR_RUNTIME_CONFIG 错误编号：运行时配置错误
static int | ERR_SEND_NOTIFICATION failed to send notification
static int | ERR_SYS_OBJECT_NOT_FOUND
static int | ERR_SYS_PARAM_INVALID
static int | ERR_SYS_PARAM_NOT_SET
static int | ERR_SYS_RUNTIME
static int | ERR_TEMPLATE_HOST_NOT_FOUND
static int | ERR_TEMPLATE_NOT_FOUND
static int | ERR_UNKNOWN 错误编号常量:不明错误
static int | ERR_URL_MALFORMED 错误编号常量:无效URL
static int | ERR_USER_NORIGHT 用户没有操作权限
static int | ERR_USER_NOTLOGIN 用户未登录或超时
static int | ERR_WCMEXCEPTION WCM Exception
static int | ERR_XML_PROPERTY_REQUIRED xml error: the specified property is requried
static int | ERR_XMLELEMENT_NOTFOUND XML解析错误：指定XML元素没有找到
static int | ERR_XMLFILE_PARSE Comment for ERR_XMLFILE_PARSE XML文件解析的异常，错误编号：150
static int | ERR_XMLSTRING_PARSE XML字符串解析异常
static int | ERR_XMLSTRUCTURE_NOTROOT Comment for ERR_XMLSTRUCTURE_NOTROOT XML结构错误，没有定义根元素，错误编号：151
static int | ERR_ZIP_UNZIP Comment for ERR_ZIP_UNZIP 解压文件异常，错误编号：200
static int | INFO_ERROR_MSG 使用该错误号以告知应用代码,信息提示需要特殊处理.
static int | MSG_NOT_SET_DETAIL_TEMPLATE
static int | MSG_NOT_SET_OUTLINE_TEMPLATE
static int | MSG_NOT_SET_PUBLISH_PROPERTIES
static int | MSG_SET_TO_CANNOT_PUBLISH 设置成不能发布
static int | MSG_STATUS_CANNOT_PUBLISH 为成不能发布状态
构造方法摘要
ExceptionNumber()
方法摘要
static java.lang.String getErrNoMsg(int _nExceptionNum)
取错误编号对应的错误信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ERR_UNKNOWN

public static final int ERR_UNKNOWN
错误编号常量:不明错误

另请参见：
常量字段值

ERR_MYEXCEPTION

public static final int ERR_MYEXCEPTION
错误编号常量:数据转化错误

另请参见：
常量字段值

ERR_DATACONVERT

public static final int ERR_DATACONVERT
错误编号常量:数据转化错误

另请参见：
常量字段值

ERR_PARAM_INVALID

public static final int ERR_PARAM_INVALID
错误编号常量:无效参数

另请参见：
常量字段值

ERR_CLASS_CONFIG

public static final int ERR_CLASS_CONFIG
错误编号：类配置错误

另请参见：
常量字段值

ERR_RUNTIME_CONFIG

public static final int ERR_RUNTIME_CONFIG
错误编号：运行时配置错误

另请参见：
常量字段值

ERR_CLASS_NOTFOUND

public static final int ERR_CLASS_NOTFOUND
错误编号：class未找到

另请参见：
常量字段值

ERR_CONFIG_MISSING

public static final int ERR_CONFIG_MISSING
错误编号：缺少配置

另请参见：
常量字段值

ERR_OBJ_NULL

public static final int ERR_OBJ_NULL
错误编号常量: 空指针

另请参见：
常量字段值

ERR_NEW_INSTANCE

public static final int ERR_NEW_INSTANCE
错误编号常量：实例话对象失败

另请参见：
常量字段值

ERR_NUMOP_FAIL

public static final int ERR_NUMOP_FAIL
错误编号常量:数学运算错误

另请参见：
常量字段值

ERR_DBOP_FAIL

public static final int ERR_DBOP_FAIL
错误编号常量:数据库操作失败

另请参见：
常量字段值

ERR_CONNECTION_GETFAIL

public static final int ERR_CONNECTION_GETFAIL
错误编号常量:取数据库连接失败

另请参见：
常量字段值

ERR_FILEOP_FAIL

public static final int ERR_FILEOP_FAIL
错误编号常量:文件操作失败

另请参见：
常量字段值

ERR_FILEOP_OPEN

public static final int ERR_FILEOP_OPEN
错误编号常量:打开文件失败

另请参见：
常量字段值

ERR_FILEOP_CLOSE

public static final int ERR_FILEOP_CLOSE
错误编号常量:关闭文件失败

另请参见：
常量字段值

ERR_FILEOP_READ

public static final int ERR_FILEOP_READ
错误编号常量:读文件失败

另请参见：
常量字段值

ERR_FILEOP_WRITE

public static final int ERR_FILEOP_WRITE
错误编号常量:写文件失败

另请参见：
常量字段值

ERR_FILE_NOTFOUND

public static final int ERR_FILE_NOTFOUND
错误编号常量:文件未找到

另请参见：
常量字段值

ERR_FILEOP_MOVE

public static final int ERR_FILEOP_MOVE
错误编号常量:移动文件失败

另请参见：
常量字段值

ERR_URL_MALFORMED

public static final int ERR_URL_MALFORMED
错误编号常量:无效URL

另请参见：
常量字段值

ERR_NET_OPENSTREAM

public static final int ERR_NET_OPENSTREAM
错误编号常量:打开网络数据流失败

另请参见：
常量字段值

ERR_XMLFILE_PARSE

public static final int ERR_XMLFILE_PARSE
Comment for ERR_XMLFILE_PARSE
XML文件解析的异常，错误编号：150

另请参见：
常量字段值

ERR_XMLSTRUCTURE_NOTROOT

public static final int ERR_XMLSTRUCTURE_NOTROOT
Comment for ERR_XMLSTRUCTURE_NOTROOT
XML结构错误，没有定义根元素，错误编号：151

另请参见：
常量字段值

ERR_XMLELEMENT_NOTFOUND

public static final int ERR_XMLELEMENT_NOTFOUND
XML解析错误：指定XML元素没有找到

另请参见：
常量字段值

ERR_XML_PROPERTY_REQUIRED

public static final int ERR_XML_PROPERTY_REQUIRED
xml error: the specified property is requried

另请参见：
常量字段值

ERR_XMLSTRING_PARSE

public static final int ERR_XMLSTRING_PARSE
XML字符串解析异常

另请参见：
常量字段值

ERR_ZIP_UNZIP

public static final int ERR_ZIP_UNZIP
Comment for ERR_ZIP_UNZIP
解压文件异常，错误编号：200

另请参见：
常量字段值

ERR_PUBLISH

public static final int ERR_PUBLISH
publish error

另请参见：
常量字段值

ERR_PUBLISH_SERVER_NOTSTARTED

public static final int ERR_PUBLISH_SERVER_NOTSTARTED
publish error: the publish server has not been started

另请参见：
常量字段值

ERR_PUBLISH_UPDATE_QUOTING_FOLDERS

public static final int ERR_PUBLISH_UPDATE_QUOTING_FOLDERS
publish error: fails to update the quoting folders

另请参见：
常量字段值

ERR_PUBLISH_TASK_STILLOPEN

public static final int ERR_PUBLISH_TASK_STILLOPEN
publish error: the publish task is still open (has not been executed)

另请参见：
常量字段值

ERR_PUBLISH_CREATE_TASK

public static final int ERR_PUBLISH_CREATE_TASK
publish error: failed to create publish task

另请参见：
常量字段值

ERR_PUBLISH_CANCEL_TASK

public static final int ERR_PUBLISH_CANCEL_TASK
publish error: failed to cancel the publish task

另请参见：
常量字段值

ERR_PUBLISH_UNKNOWN_FOLDER_TYPE

public static final int ERR_PUBLISH_UNKNOWN_FOLDER_TYPE
publish error: unknown publish folder type

另请参见：
常量字段值

ERR_PUBLISH_UNKNOWN_CONTENT_TYPE

public static final int ERR_PUBLISH_UNKNOWN_CONTENT_TYPE
publish error: unknown publish content type

另请参见：
常量字段值

ERR_PUBLISH_UNKNOWN_PUBLISH_TYPE

public static final int ERR_PUBLISH_UNKNOWN_PUBLISH_TYPE
publish error: unknown publish type

另请参见：
常量字段值

ERR_PUBLISH_ANALYZE_DETAIL_PAGE_TASK

public static final int ERR_PUBLISH_ANALYZE_DETAIL_PAGE_TASK
publish error: failed to analyze the detail page tasks

另请参见：
常量字段值

ERR_PUBLISH_OUTLINE_TEMPLATE_REQUIRED

public static final int ERR_PUBLISH_OUTLINE_TEMPLATE_REQUIRED
publish error: outline template required

另请参见：
常量字段值

ERR_PUBLISH_DETAIL_TEMPLATE_REQUIRED

public static final int ERR_PUBLISH_DETAIL_TEMPLATE_REQUIRED
publish error: detail template required

另请参见：
常量字段值

ERR_PUBLISH_TAGDOC_GRAMMAR_ILLEGAL

public static final int ERR_PUBLISH_TAGDOC_GRAMMAR_ILLEGAL
publish error: tag document grammar is illegal

另请参见：
常量字段值

ERR_PUBLISH_TEMPLATE_SEMANTIC_ANALYSE

public static final int ERR_PUBLISH_TEMPLATE_SEMANTIC_ANALYSE
publish error: failed to analyze the semantic relations in template

另请参见：
常量字段值

ERR_PUBLISH_TAG_PARSE

public static final int ERR_PUBLISH_TAG_PARSE
publish error: failed to parse the specified tag

另请参见：
常量字段值

ERR_PUBLISH_TAG_PROPERTY_VALUE_INVALID

public static final int ERR_PUBLISH_TAG_PROPERTY_VALUE_INVALID
publish error: invalid tag property value

另请参见：
常量字段值

ERR_PUBLISH_FIlE_DISTRIBUTE

public static final int ERR_PUBLISH_FIlE_DISTRIBUTE
publish error: failed to distribute the file

另请参见：
常量字段值

ERR_PUBLISH_PAGE_GENERATE

public static final int ERR_PUBLISH_PAGE_GENERATE
publish error: failed to generate page

另请参见：
常量字段值

ERR_WCMEXCEPTION

public static final int ERR_WCMEXCEPTION
WCM Exception

另请参见：
常量字段值

ERR_MESSAGE

public static final int ERR_MESSAGE
消息

另请参见：
常量字段值

ERR_USER_NOTLOGIN

public static final int ERR_USER_NOTLOGIN
用户未登录或超时

另请参见：
常量字段值

ERR_USER_NORIGHT

public static final int ERR_USER_NORIGHT
用户没有操作权限

另请参见：
常量字段值

ERR_OBJ_NOTLOCKED

public static final int ERR_OBJ_NOTLOCKED
对象未锁定

另请参见：
常量字段值

ERR_OBJ_LOCKED

public static final int ERR_OBJ_LOCKED
对象已被其他用户锁定

另请参见：
常量字段值

ERR_PROPERTY_NOT_EXIST

public static final int ERR_PROPERTY_NOT_EXIST
不存在该属性

另请参见：
常量字段值

ERR_PROPERTY_NOTALLOW_EDIT

public static final int ERR_PROPERTY_NOTALLOW_EDIT
属性不允许修改

另请参见：
常量字段值

ERR_PROPERTY_TYPE_INVALID

public static final int ERR_PROPERTY_TYPE_INVALID
属性类型不匹配

另请参见：
常量字段值

ERR_PROPERTY_VALUE_INVALID

public static final int ERR_PROPERTY_VALUE_INVALID
属性值无效

另请参见：
常量字段值

ERR_NEWOBJ_INVALID

public static final int ERR_NEWOBJ_INVALID
新建对象无效

另请参见：
常量字段值

ERR_PROPERTY_NOT_SET

public static final int ERR_PROPERTY_NOT_SET
对象属性没有设置

另请参见：
常量字段值

ERR_PROPERTY_NOT_MODIFIED

public static final int ERR_PROPERTY_NOT_MODIFIED
对象属性没有修改

另请参见：
常量字段值

ERR_PROPERTY_VALUE_DUPLICATED

public static final int ERR_PROPERTY_VALUE_DUPLICATED
属性值重复

另请参见：
常量字段值

ERR_IMPORTFILE_INVALID

public static final int ERR_IMPORTFILE_INVALID
导入的文件格式不支持

另请参见：
常量字段值

ERR_DOC_DUPLICATED

public static final int ERR_DOC_DUPLICATED
文档无法移动或转发到自身所在频道

另请参见：
常量字段值

ERR_INSTANCE_INVALID

public static final int ERR_INSTANCE_INVALID
通过Class.newInstance,创建BaseObj对象实例失败

另请参见：
常量字段值

ERR_SEND_NOTIFICATION

public static final int ERR_SEND_NOTIFICATION
failed to send notification

另请参见：
常量字段值

ERR_REFRESH_NOTIFICATION_SERVER

public static final int ERR_REFRESH_NOTIFICATION_SERVER
failed to refresh the notification server

另请参见：
常量字段值

ERR_MESSAGE_UNKNOWN_SENDTYPE

public static final int ERR_MESSAGE_UNKNOWN_SENDTYPE
unknown message send type

另请参见：
常量字段值

ERR_SYS_OBJECT_NOT_FOUND

public static final int ERR_SYS_OBJECT_NOT_FOUND
另请参见：
常量字段值

ERR_SYS_PARAM_NOT_SET

public static final int ERR_SYS_PARAM_NOT_SET
另请参见：
常量字段值

ERR_SYS_PARAM_INVALID

public static final int ERR_SYS_PARAM_INVALID
另请参见：
常量字段值

ERR_SYS_RUNTIME

public static final int ERR_SYS_RUNTIME
另请参见：
常量字段值

ERR_HOST_NOT_FOUND

public static final int ERR_HOST_NOT_FOUND
另请参见：
常量字段值

ERR_TEMPLATE_NOT_FOUND

public static final int ERR_TEMPLATE_NOT_FOUND
另请参见：
常量字段值

ERR_TEMPLATE_HOST_NOT_FOUND

public static final int ERR_TEMPLATE_HOST_NOT_FOUND
另请参见：
常量字段值

ERR_FACTORY_CONFIG

public static final int ERR_FACTORY_CONFIG
工厂文件配置错误

另请参见：
常量字段值

MSG_NOT_SET_PUBLISH_PROPERTIES

public static final int MSG_NOT_SET_PUBLISH_PROPERTIES
另请参见：
常量字段值

MSG_NOT_SET_OUTLINE_TEMPLATE

public static final int MSG_NOT_SET_OUTLINE_TEMPLATE
另请参见：
常量字段值

MSG_NOT_SET_DETAIL_TEMPLATE

public static final int MSG_NOT_SET_DETAIL_TEMPLATE
另请参见：
常量字段值

MSG_SET_TO_CANNOT_PUBLISH

public static final int MSG_SET_TO_CANNOT_PUBLISH
设置成不能发布

另请参见：
常量字段值

MSG_STATUS_CANNOT_PUBLISH

public static final int MSG_STATUS_CANNOT_PUBLISH
为成不能发布状态

另请参见：
常量字段值

ERR_OBJ_NOTFOUND

public static final int ERR_OBJ_NOTFOUND
另请参见：
常量字段值

INFO_ERROR_MSG

public static final int INFO_ERROR_MSG
使用该错误号以告知应用代码,信息提示需要特殊处理.

另请参见：
常量字段值
构造方法详细信息

ExceptionNumber

public ExceptionNumber()
方法详细信息

getErrNoMsg

public static java.lang.String getErrNoMsg(int _nExceptionNum)
取错误编号对应的错误信息

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileNameExtFilter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 FileNameExtFilter

java.lang.Object
    继承者  com.trs.infra.util.FileNameExtFilter
所有已实现的接口：
java.io.FilenameFilter
public class FileNameExtFilter
extends java.lang.Object
implements java.io.FilenameFilter

Title: TRS 内容协作平台（TRS WCM）
Description:
文档扩展名过滤器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FileNameExtFilter(java.lang.String _sFileExt)
方法摘要
boolean | accept(java.io.File arg0, java.lang.String _sFileName)
java.lang.String | getFileExt()
void | setFileExt(java.lang.String fileExt)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileNameExtFilter

public FileNameExtFilter(java.lang.String _sFileExt)
方法详细信息

accept

public boolean accept(java.io.File arg0,
                      java.lang.String _sFileName)
指定者：
接口 java.io.FilenameFilter 中的 accept

getFileExt

public java.lang.String getFileExt()

setFileExt

public void setFileExt(java.lang.String fileExt)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HttpClientBuddy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 HttpClientBuddy

java.lang.Object
    继承者  com.trs.infra.util.HttpClientBuddy

public class HttpClientBuddy
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DEFAULT_CONTENT_ENCODING
static java.lang.String | SERVICE_REQEUST_ENCODING 向wcm发送数据时的流写编码
构造方法摘要
HttpClientBuddy()
HttpClientBuddy(java.lang.String encoding)
HttpClientBuddy(java.lang.String encoding, java.lang.String[][] _arrRequestHeaders)
方法摘要
ResponseBuddy | doGet(java.lang.String _sPostUri, java.util.Map mContent)
ResponseBuddy | doGet(java.lang.String _sPostUri, java.lang.String _sQueryString) 以GET方式发送请求，获取返回对象
ResponseBuddy | doPost(java.lang.String _sPostUri, byte[] _btContent) 以POST方式发送请求，获取返回对象
ResponseBuddy | doPost(java.lang.String _sPostUri, byte[] _btContent, boolean _bChunked) 以POST方式发送请求，获取返回对象
ResponseBuddy | doPost(java.lang.String _sPostUri, java.util.Map mContent, boolean _bChunked)
ResponseBuddy | doPost(java.lang.String _sPostUri, java.lang.String sContent) 以POST方式发送请求，获取返回对象
ResponseBuddy | doPost(java.lang.String _sPostUri, java.lang.String sContent, boolean _bChunked) 以POST方式发送请求，获取返回对象
ResponseBuddy | updateFile(java.lang.String _sPostUri, byte[] _fileContent)
ResponseBuddy | updateFile(java.lang.String _sPostUri, java.io.File _oUpdateFile) 上传文件，获取返回对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_CONTENT_ENCODING

public static final java.lang.String DEFAULT_CONTENT_ENCODING
另请参见：
常量字段值

SERVICE_REQEUST_ENCODING

public static final java.lang.String SERVICE_REQEUST_ENCODING
向wcm发送数据时的流写编码

另请参见：
常量字段值
构造方法详细信息

HttpClientBuddy

public HttpClientBuddy()

HttpClientBuddy

public HttpClientBuddy(java.lang.String encoding)

HttpClientBuddy

public HttpClientBuddy(java.lang.String encoding,
                       java.lang.String[][] _arrRequestHeaders)
方法详细信息

doPost

public ResponseBuddy doPost(java.lang.String _sPostUri,
                            java.lang.String sContent)
                     throws CMyException
以POST方式发送请求，获取返回对象

参数：
_sPostUri -
sContent -
返回：
抛出：
HttpClientRenderException
CMyException

updateFile

public ResponseBuddy updateFile(java.lang.String _sPostUri,
                                byte[] _fileContent)
                         throws CMyException
抛出：
CMyException

updateFile

public ResponseBuddy updateFile(java.lang.String _sPostUri,
                                java.io.File _oUpdateFile)
                         throws CMyException
上传文件，获取返回对象

参数：
_sPostUri -
_oUpdateFile -
返回：
抛出：
java.io.FileNotFoundException
HttpClientExcuteException
java.io.UnsupportedEncodingException
org.apache.commons.httpclient.URIException
HttpClientRenderException
java.io.FileNotFoundException
CMyException

doPost

public ResponseBuddy doPost(java.lang.String _sPostUri,
                            byte[] _btContent)
                     throws CMyException
以POST方式发送请求，获取返回对象

参数：
_sPostUri -
_btContent -
返回：
抛出：
HttpClientExcuteException
org.apache.commons.httpclient.URIException
HttpClientRenderException
CMyException

doPost

public ResponseBuddy doPost(java.lang.String _sPostUri,
                            java.lang.String sContent,
                            boolean _bChunked)
                     throws CMyException
以POST方式发送请求，获取返回对象

参数：
_sPostUri -
sContent -
_bChunked -
返回：
抛出：
java.io.UnsupportedEncodingException
HttpClientExcuteException
org.apache.commons.httpclient.URIException
CMyException

doPost

public ResponseBuddy doPost(java.lang.String _sPostUri,
                            java.util.Map mContent,
                            boolean _bChunked)
                     throws CMyException
参数：
_sPostUri -
mContent -
_bChunked -
返回：
抛出：
CMyException

doPost

public ResponseBuddy doPost(java.lang.String _sPostUri,
                            byte[] _btContent,
                            boolean _bChunked)
                     throws CMyException
以POST方式发送请求，获取返回对象

参数：
_sPostUri -
_btContent -
_bChunked -
返回：
抛出：
HttpClientExcuteException
org.apache.commons.httpclient.URIException
HttpClientRenderException
CMyException

doGet

public ResponseBuddy doGet(java.lang.String _sPostUri,
                           java.lang.String _sQueryString)
                    throws CMyException
以GET方式发送请求，获取返回对象

参数：
_sPostUri -
_sQueryString -
返回：
抛出：
org.apache.commons.httpclient.URIException
HttpClientExcuteException
HttpClientRenderException
CMyException

doGet

public ResponseBuddy doGet(java.lang.String _sPostUri,
                           java.util.Map mContent)
                    throws CMyException
参数：
_sPostUri -
mContent -
返回：
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HttpGet

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 HttpGet

java.lang.Object
    继承者  com.trs.infra.util.HttpGet

public class HttpGet
extends java.lang.Object

字段摘要
static int TRY_INTERVAL
重试间隔时间，单位：毫秒
构造方法摘要
HttpGet()
方法摘要
static java.lang.String | get(java.lang.String _sUrl)
static java.lang.String | get(java.lang.String _sUrl, int _nTryCount)
static java.lang.String | get(java.lang.String _sUrl, int _nTryCount, boolean _bRetContent)
static boolean | isStarted(java.lang.String _sFileName)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TRY_INTERVAL

public static final int TRY_INTERVAL
重试间隔时间，单位：毫秒

另请参见：
常量字段值
构造方法详细信息

HttpGet

public HttpGet()
方法详细信息

isStarted

public static boolean isStarted(java.lang.String _sFileName)

get

public static java.lang.String get(java.lang.String _sUrl)

get

public static java.lang.String get(java.lang.String _sUrl,
                                   int _nTryCount)

get

public static java.lang.String get(java.lang.String _sUrl,
                                   int _nTryCount,
                                   boolean _bRetContent)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JavaScriptVARProcessor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 JavaScriptVARProcessor

java.lang.Object
    继承者  com.trs.infra.util.JavaScriptVARProcessor

public class JavaScriptVARProcessor
extends java.lang.Object

作者：
Administrator

构造方法摘要
JavaScriptVARProcessor(java.lang.String _sSrcPath, java.lang.String _sComparePath, java.lang.String _sDstPath, java.lang.String _sStartPath)
方法摘要
static void | main(java.lang.String[] args)
java.lang.String | process() 开始逐个处理文件
java.lang.String | process(java.lang.String sAbsoluteFileName, java.lang.String sCompareFileName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JavaScriptVARProcessor

public JavaScriptVARProcessor(java.lang.String _sSrcPath,
                              java.lang.String _sComparePath,
                              java.lang.String _sDstPath,
                              java.lang.String _sStartPath)
方法详细信息

process

public java.lang.String process()
                         throws java.lang.Exception
开始逐个处理文件

抛出：
java.lang.Exception

process

public java.lang.String process(java.lang.String sAbsoluteFileName,
                                java.lang.String sCompareFileName)
                         throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 ListUtil

java.lang.Object
    继承者  com.trs.infra.util.ListUtil

public class ListUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
utilities for value list.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static int indexOf(int _value, int[] _array)
find the index of a value in the specified array
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

indexOf

public static int indexOf(int _value,
                          int[] _array)
find the index of a value in the specified array

参数：
_value - the value to find
_array - the array to seek
返回：
Returns the index position (from 0) in the array if the value is found; otherwise, returns -1.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Loader

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 Loader

java.lang.Object
    继承者  com.trs.infra.util.Loader

public class Loader
extends java.lang.Object

Load resources (or images) from various sources.

作者：
Ceki Gülcü

构造方法摘要
Loader()
方法摘要
static java.net.URL | getResource(java.lang.String resource) This method will search for resource in different places.
static boolean | isJava1() Are we running under JDK 1.x?
static java.lang.Class | loadClass(java.lang.String clazz) If running under JDK 1.2 load the specified class using the Thread contextClassLoader if that fails try Class.forname.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Loader

public Loader()
方法详细信息

getResource

public static java.net.URL getResource(java.lang.String resource)
This method will search for resource in different places. The rearch order is as follows:

  1. Search for resource using the thread context class loader under Java2. If that fails, search for resource using the class loader that loaded this class (Loader). Under JDK 1.1, only the the class loader that loaded this class ( Loader) is used.

  2. Try one last time with ClassLoader.getSystemResource(resource), that is is using the system class loader in JDK 1.2 and virtual machine's built-in class loader in JDK 1.1.

isJava1

public static boolean isJava1()
Are we running under JDK 1.x?

loadClass

public static java.lang.Class loadClass(java.lang.String clazz)
                                 throws java.lang.ClassNotFoundException
If running under JDK 1.2 load the specified class using the Thread contextClassLoader if that fails try Class.forname. Under JDK 1.1 only Class.forName is used.

抛出：
java.lang.ClassNotFoundException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MD5

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 MD5

java.lang.Object
    继承者  com.trs.infra.util.MD5

public class MD5
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
 java.lang.String digestHexStr
构造方法摘要
MD5()
方法摘要
static long | b2iu(byte b) 把byte值按照不考虑正负号的原则的＂升位＂
static java.lang.String | byteHEX(byte ib) 用来把一个byte类型的数转换成十六进制的ASCII表示，
java.lang.String | getMD5OfStr(java.lang.String inbuf) 获取经过MD5加密后的结果
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

digestHexStr

public java.lang.String digestHexStr
构造方法详细信息

MD5

public MD5()
方法详细信息

getMD5OfStr

public java.lang.String getMD5OfStr(java.lang.String inbuf)
获取经过MD5加密后的结果

参数：
inbuf - 需要进行加密的字符串
返回：

b2iu

public static long b2iu(byte b)
把byte值按照不考虑正负号的原则的＂升位＂

参数：
b - byte值
返回：

byteHEX

public static java.lang.String byteHEX(byte ib)
用来把一个byte类型的数转换成十六进制的ASCII表示，

参数：
ib - byte值
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MySSLSocketFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 MySSLSocketFactory

java.lang.Object
    继承者  com.trs.infra.util.MySSLSocketFactory
所有已实现的接口：
org.apache.commons.httpclient.protocol.ProtocolSocketFactory
public class MySSLSocketFactory
extends java.lang.Object
implements org.apache.commons.httpclient.protocol.ProtocolSocketFactory

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

嵌套类摘要
static class MySSLSocketFactory.MyX509TrustManager
构造方法摘要
MySSLSocketFactory()
方法摘要
java.net.Socket | createSocket(java.lang.String host, int port)
java.net.Socket | createSocket(java.lang.String host, int port, java.net.InetAddress clientHost, int clientPort)
java.net.Socket | createSocket(java.lang.String host, int port, java.net.InetAddress localAddress, int localPort, org.apache.commons.httpclient.params.HttpConnectionParams params)
boolean | equals(java.lang.Object obj)
int | hashCode()
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MySSLSocketFactory

public MySSLSocketFactory()
方法详细信息

createSocket

public java.net.Socket createSocket(java.lang.String host,
                                    int port,
                                    java.net.InetAddress clientHost,
                                    int clientPort)
                             throws java.io.IOException,
                                    java.rmi.UnknownHostException
指定者：
接口 org.apache.commons.httpclient.protocol.ProtocolSocketFactory 中的 createSocket
抛出：
java.io.IOException
java.rmi.UnknownHostException

createSocket

public java.net.Socket createSocket(java.lang.String host,
                                    int port,
                                    java.net.InetAddress localAddress,
                                    int localPort,
                                    org.apache.commons.httpclient.params.HttpConnectionParams params)
                             throws java.io.IOException,
                                    java.rmi.UnknownHostException
指定者：
接口 org.apache.commons.httpclient.protocol.ProtocolSocketFactory 中的 createSocket
抛出：
java.io.IOException
java.rmi.UnknownHostException

createSocket

public java.net.Socket createSocket(java.lang.String host,
                                    int port)
                             throws java.io.IOException,
                                    java.rmi.UnknownHostException
指定者：
接口 org.apache.commons.httpclient.protocol.ProtocolSocketFactory 中的 createSocket
抛出：
java.io.IOException
java.rmi.UnknownHostException

equals

public boolean equals(java.lang.Object obj)
覆盖：
类 java.lang.Object 中的 equals

hashCode

public int hashCode()
覆盖：
类 java.lang.Object 中的 hashCode
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MySSLSocketFactory.MyX509TrustManager

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 MySSLSocketFactory.MyX509TrustManager

java.lang.Object
    继承者  com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager
所有已实现的接口：
javax.net.ssl.TrustManager, javax.net.ssl.X509TrustManager
包容类：
MySSLSocketFactory
public static class MySSLSocketFactory.MyX509TrustManager
extends java.lang.Object
implements javax.net.ssl.X509TrustManager

构造方法摘要
MySSLSocketFactory.MyX509TrustManager()
方法摘要
void | checkClientTrusted(java.security.cert.X509Certificate[] chain, java.lang.String authType)
void | checkServerTrusted(java.security.cert.X509Certificate[] chain, java.lang.String authType)
java.security.cert.X509Certificate[] | getAcceptedIssuers()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MySSLSocketFactory.MyX509TrustManager

public MySSLSocketFactory.MyX509TrustManager()
方法详细信息

getAcceptedIssuers

public java.security.cert.X509Certificate[] getAcceptedIssuers()
指定者：
接口 javax.net.ssl.X509TrustManager 中的 getAcceptedIssuers

checkClientTrusted

public void checkClientTrusted(java.security.cert.X509Certificate[] chain,
                               java.lang.String authType)
指定者：
接口 javax.net.ssl.X509TrustManager 中的 checkClientTrusted

checkServerTrusted

public void checkServerTrusted(java.security.cert.X509Certificate[] chain,
                               java.lang.String authType)
指定者：
接口 javax.net.ssl.X509TrustManager 中的 checkServerTrusted
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamesRegister

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 NamesRegister

java.lang.Object
    继承者  com.trs.infra.util.NamesRegister
所有已实现的接口：
org.aton.container.IClearable
public class NamesRegister
extends java.lang.Object
implements org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
names register.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
NamesRegister()
constructor: default
方法摘要
 void clear()
 boolean contains(java.lang.String _sName)
Returns true if this register contains the specified name.
 int lookup(java.lang.String _sName, int _nDefault)
Returns the identity of the specified name if found in register;
other, returns the default value given.
 void register(java.lang.String _sName, int _nId)
Registers a name with the specified id
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NamesRegister

public NamesRegister()
constructor: default

方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

register

public void register(java.lang.String _sName,
                     int _nId)
Registers a name with the specified id

参数：
_sName - name to register
_nId - integer identity for this name

contains

public boolean contains(java.lang.String _sName)
Returns true if this register contains the specified name.

参数：
_sName - name to find
返回：
true if this register contains the specified name.

lookup

public int lookup(java.lang.String _sName,
                  int _nDefault)
Returns the identity of the specified name if found in register;
other, returns the default value given.

参数：
_sName - name to find
_nDefault - default value to return if the name is not found.
返回：
the identity of the specified name if found in register;
other, returns the default value given.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OptionConverter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 OptionConverter

java.lang.Object
    继承者  com.trs.infra.util.OptionConverter

public class OptionConverter
extends java.lang.Object

A convenience class to convert property values to specific types.

作者：
Ceki Gülcü, Simon Kitching;, Anders Kristensen

方法摘要
static java.lang.String[] | concatanateArrays(java.lang.String[] l, java.lang.String[] r)
static java.lang.String | convertSpecialChars(java.lang.String s)
static java.lang.String | findAndSubst(java.lang.String key, java.util.Properties props) Find the value corresponding to key in props.
static java.lang.String | getSystemProperty(java.lang.String key, java.lang.String def) Very similar to System.getProperty except that the SecurityException is hidden.
static java.lang.Object | instantiateByClassName(java.lang.String className, java.lang.Class superClass, java.lang.Object defaultValue) Instantiate an object given a class name.
static java.lang.Object | instantiateByKey(java.util.Properties props, java.lang.String key, java.lang.Class superClass, java.lang.Object defaultValue)
static void | selectAndConfigure(java.net.URL url, java.lang.String clazz, org.apache.log4j.spi.LoggerRepository hierarchy) Configure log4j given a URL.
static java.lang.String | substVars(java.lang.String val, java.util.Properties props) Perform variable substitution in string val from the values of keys found in the system propeties.
static boolean | toBoolean(java.lang.String value, boolean dEfault) If value is "true", then true is returned.
static long | toFileSize(java.lang.String value, long dEfault)
static int | toInt(java.lang.String value, int dEfault)
static org.apache.log4j.Level | toLevel(java.lang.String value, org.apache.log4j.Level defaultValue) Converts a standard or custom priority level to a Level object.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

concatanateArrays

public static java.lang.String[] concatanateArrays(java.lang.String[] l,
                                                   java.lang.String[] r)

convertSpecialChars

public static java.lang.String convertSpecialChars(java.lang.String s)

getSystemProperty

public static java.lang.String getSystemProperty(java.lang.String key,
                                                 java.lang.String def)
Very similar to System.getProperty except that the SecurityException is hidden.

参数：
key - The key to search for.
def - The default value to return.
返回：
the string value of the system property, or the default value if there is no property with that key.
从以下版本开始：
1.1

instantiateByKey

public static java.lang.Object instantiateByKey(java.util.Properties props,
                                                java.lang.String key,
                                                java.lang.Class superClass,
                                                java.lang.Object defaultValue)

toBoolean

public static boolean toBoolean(java.lang.String value,
                                boolean dEfault)
If value is "true", then true is returned. If value is "false", then true is returned. Otherwise, default is returned.

Case of value is unimportant.

toInt

public static int toInt(java.lang.String value,
                        int dEfault)

toLevel

public static org.apache.log4j.Level toLevel(java.lang.String value,
                                             org.apache.log4j.Level defaultValue)
Converts a standard or custom priority level to a Level object.

If value is of form "level#classname", then the specified class' toLevel method is called to process the specified level string; if no '#' character is present, then the default Level class is used to process the level value.

As a special case, if the value parameter is equal to the string "NULL", then the value null will be returned.

If any error occurs while converting the value to a level, the defaultValue parameter, which may be null, is returned.

Case of value is insignificant for the level level, but is significant for the class name part, if present.

从以下版本开始：
1.1

toFileSize

public static long toFileSize(java.lang.String value,
                              long dEfault)

findAndSubst

public static java.lang.String findAndSubst(java.lang.String key,
                                            java.util.Properties props)
Find the value corresponding to key in props. Then perform variable substitution on the found value.

instantiateByClassName

public static java.lang.Object instantiateByClassName(java.lang.String className,
                                                      java.lang.Class superClass,
                                                      java.lang.Object defaultValue)
Instantiate an object given a class name. Check that the className is a subclass of superClass. If that test fails or the object could not be instantiated, then defaultValue is returned.

参数：
className - The fully qualified class name of the object to instantiate.
superClass - The class to which the new object should belong.
defaultValue - The object to return in case of non-fulfillment

substVars

public static java.lang.String substVars(java.lang.String val,
                                         java.util.Properties props)
                                  throws java.lang.IllegalArgumentException
Perform variable substitution in string val from the values of keys found in the system propeties.

The variable substitution delimeters are ${ and }.

For example, if the System properties contains "key=value", then the call

 String s = OptionConverter.substituteVars("Value of key is ${key}.");
will set the variable s to "Value of key is value.".

If no value could be found for the specified key, then the props parameter is searched, if the value could not be found there, then substitution defaults to the empty string.

For example, if system propeties contains no value for the key "inexistentKey", then the call

 String s = OptionConverter
         .subsVars("Value of inexistentKey is [${inexistentKey}]");
will set s to "Value of inexistentKey is []"

An IllegalArgumentException is thrown if val contains a start delimeter "${" which is not balanced by a stop delimeter "}".

Author Avy Sharell

参数：
val - The string on which variable substitution is performed.
抛出：
java.lang.IllegalArgumentException - if val is malformed.

selectAndConfigure

public static void selectAndConfigure(java.net.URL url,
                                      java.lang.String clazz,
                                      org.apache.log4j.spi.LoggerRepository hierarchy)
Configure log4j given a URL.

The url must point to a file or resource which will be interpreted by a new instance of a log4j configurator.

All configurations steps are taken on the hierarchy passed as a parameter.

参数：
url - The location of the configuration file or resource.
clazz - The classname, of the log4j configurator which will parse the file or resource at url. This must be a subclass of Configurator, or null. If this value is null then a default configurator of PropertyConfigurator is used, unless the filename pointed to by url ends in '.xml', in which case org.apache.log4j.xml.DOMConfigurator is used.
hierarchy - The Hierarchy to act on.
从以下版本开始：
1.1.4
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OrgnizeContextImports

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 OrgnizeContextImports

java.lang.Object
    继承者  com.trs.infra.util.OrgnizeContextImports

public class OrgnizeContextImports
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
OrgnizeContextImports()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OrgnizeContextImports

public OrgnizeContextImports()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util
类
AttributesString
BASE64DecoderStream
BASE64EncoderStream
Base64Util
CharsetDetector
CImage
CMy3WLib
CMyBeanConfig
CMyBitsValue
CMyClassConfig
CMyDateTime
CMyDecimalBuddy
CMyDOM4jHelper
CMyEncrypt
CMyErrors
CMyFile
CMyFilenameFilter
CMyFileX
CMyKeyGenerator
CMyMemory
CMySign
CMySMS
CMyString
CMyTimer
CMyTransformCoding
CMyUnzip
CMyUnZipFile
CMyURLEncoder
CMyXMLDoc
CMyXMLElement
CMyXMLHandler
CMyXMLParser
CMyZip
ConfigElementContentTester
CopyOfTRSImportsOrgnize
CPager
DebugTimer
DiscoveryFactoryBuddy
ExceptionMessages
ExceptionNumber
FileNameExtFilter
HttpClientBuddy
HttpGet
JavaScriptVARProcessor
ListUtil
Loader
MD5
MySSLSocketFactory
MySSLSocketFactory.MyX509TrustManager
NamesRegister
OptionConverter
OrgnizeContextImports
PinyinHelper
PropertiesUtil
PropertiesVARProcessor
RemoteAddrUtil
Report
Reports
ResponseBuddy
TRSImportsOrgnize
TRSJspAutoTool
TRSLocaleAuto
URLCoder
WCMDiscoveryFactory
XmlCharCheckedInputStream
XmlDocWithDom4j
异常
CMyException


com.trs.infra.util

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util

类摘要
AttributesString |
BASE64DecoderStream | BASE64 解码输入流。
BASE64EncoderStream | BASE64 编码输入流。
Base64Util | Base64编码/解码工具类,编码后会加上特征前缀__encoded__;
CharsetDetector | Title: TRS 内容协作平台（TRS WCM） Description: 文件编码探测工具依赖于(chardet.jar)Mozzila的算法实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CImage | Title: photo manager Description: Your description Copyright: Copyright (c) 1998 Company: trs
CMy3WLib |
CMyBeanConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyBitsValue |
CMyClassConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyDateTime |
CMyDecimalBuddy | Title: TRS 内容协作平台（TRS WCM） Description: 提供浮点数的四则运算 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyDOM4jHelper |
CMyEncrypt |
CMyErrors |
CMyFile | Title: TRS 内容协作平台（TRS WCM） Description: class CMyFile —— 文件操作通用函数的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyFilenameFilter |
CMyFileX | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyKeyGenerator | Title: TRS 内容协作平台（TRS WCM） Description: 密钥生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyMemory | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMySign | 签名和编码，仅供包内使用
CMySMS | Title: TRS 内容协作平台（TRS WCM） Description: class CMySMS —— 用于手机发送短信息 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyString | Title: TRS 内容协作平台（TRS WCM） Description: class CMyString —— 字符串处理对象 Copyright: Copyright (c) 2001 Company: www.trs.com.cn
CMyTimer | Title: TRS 内容协作平台（TRS WCM） Description: class CMyFile —— 定时器对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyTransformCoding | Title: 网站内容管理（TRSWCM） Description: Copyright: Copyright (c) 2001 Company: www.trs.com.cn
CMyUnzip |
CMyUnZipFile | Title: TRS 内容协作平台（TRS WCM） Description: Zip文件解压对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyURLEncoder | Utility class for HTML form encoding.
CMyXMLDoc |
CMyXMLElement | Title: TRS 内容协作平台（TRS WCM） Description: 定义解析XML格式的配置文件后，各配置属性的存储数据结构 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyXMLHandler | Title: TRS 内容协作平台（TRS WCM） Description: 处理XML配置文件，解析成为CMyXMLConfig Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyXMLParser | Title: TRS 内容协作平台（TRS WCM） Description: 根据XML配置文件解析成为CMyXMLConfig Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyZip |
ConfigElementContentTester | Title: TRS 内容协作平台（TRS WCM） Description: 帮助类，为了更方便地对配置文件进行初步检验 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CopyOfTRSImportsOrgnize | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CPager | Title: TRS 内容协作平台（TRS WCM） Description: class CPager —— 分页对象，为解决Web中集合的分页显示而设 * 支持两种方式下的分页问题： （1）java.sql.ResultSet的分页； （2）列表集合的分页（如：Vector list） * 注意：页面、记录的序号均从1开始 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DebugTimer |
DiscoveryFactoryBuddy | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ExceptionMessages | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ExceptionNumber | Title: TRS 内容协作平台（TRS WCM） Description: 异常编号及描述汇总 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FileNameExtFilter | Title: TRS 内容协作平台（TRS WCM） Description: 文档扩展名过滤器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
HttpClientBuddy | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
HttpGet |
JavaScriptVARProcessor |
ListUtil | Title: TRS 内容协作平台（TRS WCM） Description: utilities for value list.
Loader | Load resources (or images) from various sources.
MD5 | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MySSLSocketFactory | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MySSLSocketFactory.MyX509TrustManager |
NamesRegister | Title: TRS 内容协作平台（TRS WCM） Description: names register.
OptionConverter | A convenience class to convert property values to specific types.
OrgnizeContextImports | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PinyinHelper | Title: TRS 内容协作平台（TRS WCM） Description: 汉字转拼音 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
PropertiesUtil | Title: TRS 内容协作平台（TRS WCM） Description: utilities for properties.
PropertiesVARProcessor |
RemoteAddrUtil | Title: TRS 内容协作平台（TRS WCM） Description: 获取IP地址工具类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
Report | Title: TRS 内容协作平台（TRS WCM） Description: 给一个逻辑操作的产生操作报告 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Reports | Title: TRS 内容协作平台（TRS WCM） Description: 报告汇总 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ResponseBuddy | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TRSImportsOrgnize | Title: TRS 内容协作平台（TRS WCM） Description: JSP Import自动产生工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TRSJspAutoTool | Title: TRS 内容协作平台（TRS WCM） Description: 应用层自动化工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TRSLocaleAuto | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
URLCoder | URL的编码和解码 是从“com.trs.util.net”中移植过来的一个类，因为目前还不太方便直接使用“com.trs.util.net” 中的工具类。
WCMDiscoveryFactory |
XmlCharCheckedInputStream | Title: TRS 内容协作平台（TRS WCM） Description: Xml有效字符检查输入流 java.io.InputStream的一个简单封装,read方法检查每一个byte.
XmlDocWithDom4j | Title: TRS 内容协作平台（TRS WCM） Description: Test dom4j Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
CMyException Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.util 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.AttributesString
    • com.trs.infra.util.Base64Util
    • com.trs.infra.util.CharsetDetector
    • com.trs.infra.util.CImage
    • com.trs.infra.util.CMy3WLib
    • com.trs.infra.util.CMyBitsValue (implements java.lang.Cloneable)
    • com.trs.infra.util.CMyDateTime (implements java.lang.Cloneable, java.io.Serializable)
    • com.trs.infra.util.CMyDecimalBuddy
    • com.trs.infra.util.CMyDOM4jHelper
    • com.trs.infra.util.CMyEncrypt
    • com.trs.infra.util.CMyErrors
    • com.trs.infra.util.CMyFile
    • com.trs.infra.util.CMyFilenameFilter (implements java.io.FilenameFilter)
    • com.trs.infra.util.CMyFileX
    • com.trs.infra.util.CMyKeyGenerator
    • com.trs.infra.util.CMyMemory
    • com.trs.infra.util.CMySign
    • com.trs.infra.util.CMySMS
    • com.trs.infra.util.CMyString
    • com.trs.infra.util.CMyTransformCoding
    • com.trs.infra.util.CMyUnzip
    • com.trs.infra.util.CMyUnZipFile
    • com.trs.infra.util.CMyURLEncoder
    • com.trs.infra.util.CMyXMLDoc
    • com.trs.infra.util.CMyXMLElement
      • com.trs.infra.util.CMyBeanConfig
      • com.trs.infra.util.CMyClassConfig
    • com.trs.infra.util.CMyXMLParser
    • com.trs.infra.util.CMyZip
    • com.trs.infra.util.ConfigElementContentTester
    • com.trs.infra.util.CopyOfTRSImportsOrgnize
    • com.trs.infra.util.CPager
    • com.trs.infra.util.DebugTimer
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.trs.infra.util.CMyXMLHandler
    • com.trs.infra.util.DiscoveryFactoryBuddy
    • com.trs.infra.util.ExceptionMessages
    • com.trs.infra.util.ExceptionNumber
    • com.trs.infra.util.FileNameExtFilter (implements java.io.FilenameFilter)
    • com.trs.infra.util.HttpClientBuddy
    • com.trs.infra.util.HttpGet
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • com.trs.infra.util.BASE64DecoderStream
      • com.trs.infra.util.XmlCharCheckedInputStream
    • com.trs.infra.util.JavaScriptVARProcessor
    • com.trs.infra.util.ListUtil
    • com.trs.infra.util.Loader
    • com.trs.infra.util.MD5
    • com.trs.infra.util.MySSLSocketFactory (implements org.apache.commons.httpclient.protocol.ProtocolSocketFactory)
    • com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager (implements javax.net.ssl.X509TrustManager)
    • com.trs.infra.util.NamesRegister (implements org.aton.container.IClearable)
    • com.trs.infra.util.OptionConverter
    • com.trs.infra.util.OrgnizeContextImports
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • com.trs.infra.util.BASE64EncoderStream
    • com.trs.infra.util.PinyinHelper
    • com.trs.infra.util.PropertiesUtil
    • com.trs.infra.util.PropertiesVARProcessor
    • com.trs.infra.util.RemoteAddrUtil
    • com.trs.infra.util.Report
    • com.trs.infra.util.Reports
    • com.trs.infra.util.ResponseBuddy
    • java.lang.Thread (implements java.lang.Runnable)
      • com.trs.infra.util.CMyTimer
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.infra.util.CMyException
    • com.trs.infra.util.TRSImportsOrgnize
    • com.trs.infra.util.TRSJspAutoTool
    • com.trs.infra.util.TRSLocaleAuto
    • com.trs.infra.util.URLCoder
    • com.trs.infra.util.WCMDiscoveryFactory
    • com.trs.infra.util.XmlDocWithDom4j


软件包 com.trs.infra.util 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util
的使用

使用 com.trs.infra.util 的软件包
com.trs
com.trs.ajaxservice
com.trs.cms.auth.persistent
com.trs.cms.content
com.trs.cms.process
com.trs.cms.process.definition
com.trs.cms.process.engine
com.trs.cms.process.xml
com.trs.components.ckm
com.trs.components.comment.domain
com.trs.components.common.calendar
com.trs.components.common.job
com.trs.components.common.message
com.trs.components.common.publish
com.trs.components.common.publish.config
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.persistent.element
com.trs.components.common.publish.persistent.taskdispatch
com.trs.components.common.publish.widget
com.trs.components.common.reminder
com.trs.components.common.trsad
com.trs.components.common.trsvote
com.trs.components.gkml.sqgk.persistent
com.trs.components.gkml.sqgk.process.element
com.trs.components.infoview.helper
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition.xml
com.trs.components.metadata.publish
com.trs.components.metadata.service
com.trs.components.stat
com.trs.components.wcm.content
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.domain.intelligence
com.trs.components.wcm.content.persistent
com.trs.components.wcm.epress
com.trs.components.wcm.process.element
com.trs.components.wcm.publish
com.trs.components.wcm.publish.element
com.trs.components.wcm.stat
com.trs.components.wcm.stat.domain
com.trs.components.wcm.wcmx.jsp
com.trs.components.web
com.trs.db.update
com.trs.infra
com.trs.infra.common
com.trs.infra.config
com.trs.infra.config.domain
com.trs.infra.db
com.trs.infra.persistent
com.trs.infra.support.file
com.trs.infra.support.log
com.trs.infra.util
com.trs.infra.util.database
com.trs.infra.util.email
com.trs.infra.util.ftp
com.trs.infra.util.html
com.trs.infra.util.job
com.trs.infra.util.xml
com.trs.presentation.locale
com.trs.presentation.util
com.trs.scene.tools
com.trs.service
com.trs.service.impl
com.trs.template.domain
com.trs.tools
com.trs.webframework.config
com.trs.webframework.context
com.trs.webframework.controler
com.trs.webframework.xmlserver

com.trs 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.ajaxservice 使用的 com.trs.infra.util 中的类
CMyDateTime
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.auth.persistent 使用的 com.trs.infra.util 中的类
CMyBitsValue
CMyDateTime

com.trs.cms.content 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process 使用的 com.trs.infra.util 中的类
CMyDateTime
CPager
Title: TRS 内容协作平台（TRS WCM） Description: class CPager —— 分页对象，为解决Web中集合的分页显示而设
* 支持两种方式下的分页问题：
（1）java.sql.ResultSet的分页；
（2）列表集合的分页（如：Vector list）
* 注意：页面、记录的序号均从1开始 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.definition 使用的 com.trs.infra.util 中的类
CMyBitsValue

com.trs.cms.process.engine 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.cms.process.xml 使用的 com.trs.infra.util 中的类
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.ckm 使用的 com.trs.infra.util 中的类
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.comment.domain 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.calendar 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.common.job 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.common.message 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.common.publish 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.config 使用的 com.trs.infra.util 中的类
AttributesString

com.trs.components.common.publish.domain.template 使用的 com.trs.infra.util 中的类
Report
Title: TRS 内容协作平台（TRS WCM）
Description:
给一个逻辑操作的产生操作报告
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.persistent.element 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.common.publish.persistent.taskdispatch 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.common.publish.widget 使用的 com.trs.infra.util 中的类
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.reminder 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.common.trsad 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.common.trsvote 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.gkml.sqgk.persistent 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.gkml.sqgk.process.element 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.infoview.helper 使用的 com.trs.infra.util 中的类
CMyDateTime
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.center.xml 使用的 com.trs.infra.util 中的类
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.definition.xml 使用的 com.trs.infra.util 中的类
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.publish 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.metadata.service 使用的 com.trs.infra.util 中的类
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.infra.util 中的类
CMyDateTime
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 使用的 com.trs.infra.util 中的类
CPager
Title: TRS 内容协作平台（TRS WCM） Description: class CPager —— 分页对象，为解决Web中集合的分页显示而设
* 支持两种方式下的分页问题：
（1）java.sql.ResultSet的分页；
（2）列表集合的分页（如：Vector list）
* 注意：页面、记录的序号均从1开始 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.infra.util 中的类
CMyDateTime
Report
Title: TRS 内容协作平台（TRS WCM）
Description:
给一个逻辑操作的产生操作报告
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain.intelligence 使用的 com.trs.infra.util 中的类
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 使用的 com.trs.infra.util 中的类
CMyBitsValue
CMyDateTime

com.trs.components.wcm.epress 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.wcm.process.element 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.wcm.publish 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.wcm.publish.element 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.components.wcm.stat 使用的 com.trs.infra.util 中的类
CMyDateTime
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.stat.domain 使用的 com.trs.infra.util 中的类
CMyDateTime
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.wcmx.jsp 使用的 com.trs.infra.util 中的类
CPager
Title: TRS 内容协作平台（TRS WCM） Description: class CPager —— 分页对象，为解决Web中集合的分页显示而设
* 支持两种方式下的分页问题：
（1）java.sql.ResultSet的分页；
（2）列表集合的分页（如：Vector list）
* 注意：页面、记录的序号均从1开始 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.web 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.db.update 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.infra 使用的 com.trs.infra.util 中的类
CMyErrors

com.trs.infra.common 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config.domain 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.db 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.infra.persistent 使用的 com.trs.infra.util 中的类
AttributesString
CMyDateTime

com.trs.infra.support.file 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.infra.support.log 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.infra.util 使用的 com.trs.infra.util 中的类
CMyBeanConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyBitsValue
CMyClassConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyDateTime
CMyErrors
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMySign
签名和编码，仅供包内使用
CMyXMLElement
Title: TRS 内容协作平台（TRS WCM）
Description:
定义解析XML格式的配置文件后，各配置属性的存储数据结构 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Report
Title: TRS 内容协作平台（TRS WCM）
Description:
给一个逻辑操作的产生操作报告
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ResponseBuddy
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.database 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.email 使用的 com.trs.infra.util 中的类
CMyClassConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyXMLElement
Title: TRS 内容协作平台（TRS WCM）
Description:
定义解析XML格式的配置文件后，各配置属性的存储数据结构 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.ftp 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.html 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.job 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.infra.util.xml 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.locale 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.presentation.util 使用的 com.trs.infra.util 中的类
CMyDateTime
CPager
Title: TRS 内容协作平台（TRS WCM） Description: class CPager —— 分页对象，为解决Web中集合的分页显示而设
* 支持两种方式下的分页问题：
（1）java.sql.ResultSet的分页；
（2）列表集合的分页（如：Vector list）
* 注意：页面、记录的序号均从1开始 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.scene.tools 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service 使用的 com.trs.infra.util 中的类
CMyDateTime
Report
Title: TRS 内容协作平台（TRS WCM）
Description:
给一个逻辑操作的产生操作报告
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.service.impl 使用的 com.trs.infra.util 中的类
CMyDateTime
Report
Title: TRS 内容协作平台（TRS WCM）
Description:
给一个逻辑操作的产生操作报告
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Reports
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.template.domain 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.tools 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.config 使用的 com.trs.infra.util 中的类
CMyDateTime
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.context 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.webframework.controler 使用的 com.trs.infra.util 中的类
CMyDateTime

com.trs.webframework.xmlserver 使用的 com.trs.infra.util 中的类
CMyException
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PinyinHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 PinyinHelper

java.lang.Object
    继承者  com.trs.infra.util.PinyinHelper

public final class PinyinHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
汉字转拼音
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
PinyinHelper()
方法摘要
static java.lang.String | convert(java.lang.String string) 转换
static java.lang.String | convert(java.lang.String string, java.lang.String delimiter) 转换
static java.lang.String | getFirstLetter(java.lang.String string, boolean lowercase) 获取首字母
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PinyinHelper

public PinyinHelper()
方法详细信息

convert

public static java.lang.String convert(java.lang.String string)
转换

参数：
string - 源字符串
返回：

convert

public static java.lang.String convert(java.lang.String string,
                                       java.lang.String delimiter)
转换

参数：
string - 源字符串
delimiter - 转换后的连接字符
返回：

getFirstLetter

public static java.lang.String getFirstLetter(java.lang.String string,
                                              boolean lowercase)
获取首字母

参数：
string - 源字符串
lowercase - 是否为小写
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertiesUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 PropertiesUtil

java.lang.Object
    继承者  com.trs.infra.util.PropertiesUtil

public class PropertiesUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
utilities for properties.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static boolean | getBooleanProperty(java.util.Map _properties, java.lang.String _sName, boolean _bDefault) get the boolean property value
static int | getIntProperty(java.util.Map _properties, java.lang.String _sName, int _nDefault) get the integer property value
static java.lang.String | getProperty(java.util.Map _properties, java.lang.String _sName) get a property value
static java.lang.String | getPropertyTrim(java.util.Map _properties, java.lang.String _sName) get the timmed value of a property
static java.lang.String | getRequiredProperty(java.util.Map _properties, java.lang.String _sName) get a required property value
static java.lang.String | getRequiredPropertyTrim(java.util.Map _properties, java.lang.String _sName) get the trimmed value of a required property.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getProperty

public static java.lang.String getProperty(java.util.Map _properties,
                                           java.lang.String _sName)
get a property value

参数：
_properties - the property name and value map
_sName - the property name
返回：
Returns the property value if found;
otherwise, returns null.

getPropertyTrim

public static java.lang.String getPropertyTrim(java.util.Map _properties,
                                               java.lang.String _sName)
get the timmed value of a property

参数：
_properties - the property name and value map
_sName - the property name.
返回：
Returns the trimmed value of the property if found;
otherwise, returns null.

getRequiredProperty

public static java.lang.String getRequiredProperty(java.util.Map _properties,
                                                   java.lang.String _sName)
                                            throws WCMException
get a required property value

参数：
_properties - the property name and value map
_sName - the property name
返回：
Returns the property value.
抛出：
WCMException - if the property is not found.

getRequiredPropertyTrim

public static java.lang.String getRequiredPropertyTrim(java.util.Map _properties,
                                                       java.lang.String _sName)
                                                throws WCMException
get the trimmed value of a required property.

参数：
_properties - the property name and value map
_sName - the property name.
返回：
Returns the trimmed value of the property if found.
抛出：
WCMException - if the property is not found or empty.

getIntProperty

public static int getIntProperty(java.util.Map _properties,
                                 java.lang.String _sName,
                                 int _nDefault)
                          throws WCMException
get the integer property value

参数：
_properties - the property name and value map
_sName - the property name.
_nDefault - default value if the property value is not set.
返回：
Returns the integer value of the property.
抛出：
WCMException - if the property value is not integer.

getBooleanProperty

public static boolean getBooleanProperty(java.util.Map _properties,
                                         java.lang.String _sName,
                                         boolean _bDefault)
get the boolean property value

参数：
_properties - the property name and value map
_sName - the property name
_bDefault - the default value if the property is not found.
返回：
Returns the boolean value of the property if found;
otherwise, returns the default value.
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertiesVARProcessor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 PropertiesVARProcessor

java.lang.Object
    继承者  com.trs.infra.util.PropertiesVARProcessor

public class PropertiesVARProcessor
extends java.lang.Object

作者：
Administrator

构造方法摘要
PropertiesVARProcessor(java.lang.String _sSrcPath, java.lang.String _sComparePath, java.lang.String _sDstPath, java.lang.String _sStartPath)
方法摘要
static void | main(java.lang.String[] args)
java.lang.String | process() 开始逐个处理文件
java.lang.String | process(java.lang.String sAbsoluteFileName, java.lang.String sCompareFileName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PropertiesVARProcessor

public PropertiesVARProcessor(java.lang.String _sSrcPath,
                              java.lang.String _sComparePath,
                              java.lang.String _sDstPath,
                              java.lang.String _sStartPath)
方法详细信息

process

public java.lang.String process()
                         throws java.lang.Exception
开始逐个处理文件

抛出：
java.lang.Exception

process

public java.lang.String process(java.lang.String sAbsoluteFileName,
                                java.lang.String sCompareFileName)
                         throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemoteAddrUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 RemoteAddrUtil

java.lang.Object
    继承者  com.trs.infra.util.RemoteAddrUtil

public class RemoteAddrUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
获取IP地址工具类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
RemoteAddrUtil()
方法摘要
static java.lang.String | getRemoteAddr(javax.servlet.http.HttpServletRequest req)
static boolean | isIPAddress(java.lang.String s)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RemoteAddrUtil

public RemoteAddrUtil()
方法详细信息

getRemoteAddr

public static java.lang.String getRemoteAddr(javax.servlet.http.HttpServletRequest req)

isIPAddress

public static final boolean isIPAddress(java.lang.String s)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Report

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 Report

java.lang.Object
    继承者  com.trs.infra.util.Report

public final class Report
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
给一个逻辑操作的产生操作报告
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | TYPE_DEBUG
static int | TYPE_ERROR
static int | TYPE_INFO
static int | TYPE_WARN
构造方法摘要
Report(java.lang.String _sReportTitle)
构造函数
Report(java.lang.String _sReportTitle, java.lang.Throwable _throwable)
构造函数
方法摘要
java.lang.Object | getRelateObject()
java.lang.String | getRportDetail() 获取详细内容
java.lang.String | getRportTitle() 获取标题
int | getType() 获取Report类型（定义在Report.TYPE_INFO...）
void | setRelateObject(java.lang.Object relateObject)
void | setRportDetail(java.lang.String rportDetail) 设置详细内容
void | setRportTitle(java.lang.String rportTitle) 设置标题
void | setType(int type) 设置Report类型
java.lang.String | toJSONXML()
java.lang.String | toString()
java.lang.String | toXML()
org.dom4j.Element | toXMLElement(boolean _bReturnJSONXML)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

TYPE_ERROR

public static final int TYPE_ERROR
另请参见：
常量字段值

TYPE_WARN

public static final int TYPE_WARN
另请参见：
常量字段值

TYPE_INFO

public static final int TYPE_INFO
另请参见：
常量字段值

TYPE_DEBUG

public static final int TYPE_DEBUG
另请参见：
常量字段值
构造方法详细信息

Report

public Report(java.lang.String _sReportTitle,
              java.lang.Throwable _throwable)
构造函数

参数：
_sReportTitle - 标题
_throwable - 异常对象

Report

public Report(java.lang.String _sReportTitle)
构造函数

参数：
_sReportTitle - 标题
方法详细信息

getRportDetail

public java.lang.String getRportDetail()
获取详细内容

返回：
详细内容

getRportTitle

public java.lang.String getRportTitle()
获取标题

返回：
标题信息

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

toXMLElement

public org.dom4j.Element toXMLElement(boolean _bReturnJSONXML)

toXML

public java.lang.String toXML()

toJSONXML

public java.lang.String toJSONXML()

getType

public int getType()
获取Report类型（定义在Report.TYPE_INFO...）

返回：

setType

public void setType(int type)
设置Report类型

参数：
type - Report类型（定义在Report.TYPE_INFO...）

setRportDetail

public void setRportDetail(java.lang.String rportDetail)
设置详细内容

参数：
rportDetail - 详细内容

setRportTitle

public void setRportTitle(java.lang.String rportTitle)
设置标题

参数：
rportTitle - 标题

getRelateObject

public java.lang.Object getRelateObject()
返回：

setRelateObject

public void setRelateObject(java.lang.Object relateObject)
参数：
relateObject -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Reports

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 Reports

java.lang.Object
    继承者  com.trs.infra.util.Reports

public class Reports
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
Reports(java.lang.String _sTitle)
方法摘要
void | add(Reports _reports)
Report | addFailedReport(java.lang.String _sMessage, java.lang.Throwable _cause) 添加操作失败报告 当操作失败时使用
void | addReport(Report report) 增加一个Report
void | addSucessedReport(java.lang.String _sMessage) 添加操作成功报告 当一个操作成功时使用
Report | addWarnedReport(java.lang.String _sMessage, java.lang.Throwable _cause) 添加操作警告报告 当操作不会导致失败,但需要告知操作者时使用
java.util.ArrayList | getExtraData()
java.util.List | getFailedReporter() 获取报告中的所有失败报告
Report | getFailedReporterAt(int _nIndex) 获取一个失败报告
int | getReportsNum()
int[] | getResultIds() 获取Reports记录的处理对象Id数组
java.util.List | getSucessedReporter() 获取所有成功的报告
Report | getSucessedReporterAt(int _nIndex) 获取一个成功的报告
java.lang.String | getTitle()
java.util.List | getWarnedReporter() 获取所有警告报告
Report | getWarnedReporterAt(int _nIndex) 获取一个警告报告
void | merge(Reports _reports)
void | setExtraData(java.util.ArrayList arEextraData)
void | setResultIds(int[] _ids) 设置Reports记录的处理对象的Id数组
void | setTitle(java.lang.String _sTitle)
java.lang.String | toJSONXML()
java.lang.String | toString()
java.lang.String | toXML()
java.lang.String | toXML(boolean _bReturnJSONXML)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Reports

public Reports(java.lang.String _sTitle)
参数：
_sTitle - 操作报告的标题
方法详细信息

getExtraData

public java.util.ArrayList getExtraData()

setExtraData

public void setExtraData(java.util.ArrayList arEextraData)

add

public void add(Reports _reports)

addFailedReport

public Report addFailedReport(java.lang.String _sMessage,
                              java.lang.Throwable _cause)
添加操作失败报告
当操作失败时使用

参数：
_sMessage - 报告信息
_cause - 导致操作失败的原因

addWarnedReport

public Report addWarnedReport(java.lang.String _sMessage,
                              java.lang.Throwable _cause)
添加操作警告报告
当操作不会导致失败,但需要告知操作者时使用

参数：
_sMessage - 报告信息
_cause - 导致警告的原因

addSucessedReport

public void addSucessedReport(java.lang.String _sMessage)
添加操作成功报告
当一个操作成功时使用

参数：
_sMessage - 操作成功的信息

getFailedReporter

public java.util.List getFailedReporter()
获取报告中的所有失败报告

返回：

getFailedReporterAt

public Report getFailedReporterAt(int _nIndex)
获取一个失败报告

参数：
_nIndex -
返回：

getWarnedReporter

public java.util.List getWarnedReporter()
获取所有警告报告

返回：

getWarnedReporterAt

public Report getWarnedReporterAt(int _nIndex)
获取一个警告报告

参数：
_nIndex -
返回：

getSucessedReporter

public java.util.List getSucessedReporter()
获取所有成功的报告

返回：

getSucessedReporterAt

public Report getSucessedReporterAt(int _nIndex)
获取一个成功的报告

参数：
_nIndex -
返回：

getReportsNum

public int getReportsNum()

getTitle

public java.lang.String getTitle()

setTitle

public void setTitle(java.lang.String _sTitle)

merge

public void merge(Reports _reports)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

toXML

public java.lang.String toXML()

toXML

public java.lang.String toXML(boolean _bReturnJSONXML)

toJSONXML

public java.lang.String toJSONXML()

addReport

public void addReport(Report report)
增加一个Report

参数：
report -

setResultIds

public void setResultIds(int[] _ids)
设置Reports记录的处理对象的Id数组

参数：
_ids -

getResultIds

public int[] getResultIds()
获取Reports记录的处理对象Id数组

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResponseBuddy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 ResponseBuddy

java.lang.Object
    继承者  com.trs.infra.util.ResponseBuddy

public class ResponseBuddy
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
ResponseBuddy(org.apache.commons.httpclient.HttpMethod oHttpMethod)
方法摘要
java.io.InputStream | getBodyAsStream()
java.lang.String | getBodyAsString()
java.lang.String | getCharset()
int | getContentLength()
java.lang.String | getContentType()
java.lang.String | getHeader(java.lang.String _sName)
java.util.Map | getHeaders()
int | getStatusCode()
void | init()
void | setBody(byte[] pContent)
void | setContentType(java.lang.String pContentType)
void | setHeaders(org.apache.commons.httpclient.Header[] headers)
void | setStatusCode(int pResponseCode)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResponseBuddy

public ResponseBuddy(org.apache.commons.httpclient.HttpMethod oHttpMethod)
              throws java.io.IOException
抛出：
java.io.IOException
方法详细信息

init

public void init()

getBodyAsStream

public java.io.InputStream getBodyAsStream()

getBodyAsString

public java.lang.String getBodyAsString()

setBody

public void setBody(byte[] pContent)

getContentLength

public int getContentLength()

getContentType

public java.lang.String getContentType()

setContentType

public void setContentType(java.lang.String pContentType)

getStatusCode

public int getStatusCode()

setStatusCode

public void setStatusCode(int pResponseCode)

getCharset

public java.lang.String getCharset()

getHeaders

public java.util.Map getHeaders()

setHeaders

public void setHeaders(org.apache.commons.httpclient.Header[] headers)

getHeader

public java.lang.String getHeader(java.lang.String _sName)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSImportsOrgnize

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 TRSImportsOrgnize

java.lang.Object
    继承者  com.trs.infra.util.TRSImportsOrgnize

public class TRSImportsOrgnize
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
JSP Import自动产生工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.util.ArrayList | arExcludeClass
static java.lang.String | CLASSES_PATH_FLAG
static java.lang.String[] | EXCLUDE_PATH
static java.lang.String | FLAG_PAGE_START
static java.util.Hashtable | hTRSClasses
static java.lang.String[] | OPERATION_STR
static int | TYPE_CODE_END
static int | TYPE_CODE_START
static int | TYPE_COMMENT
static int | TYPE_HTML_VALUE
static int | TYPE_INCLUDE
static int | TYPE_NOFLAG
static int | TYPE_PAGE_START
构造方法摘要
TRSImportsOrgnize()
方法摘要
static java.lang.String | dowithFile(java.lang.String _sFileName)
static void | dowithPath(java.lang.String _sPath)
static java.util.Hashtable | getFileHashtable(java.lang.String _sPath)
static boolean | isExcludeClass(java.lang.String _sClassName)
static void | main(java.lang.String[] args)
static java.lang.String | mapClassFullPath(java.lang.String _sClassName)
static java.lang.String | transformPathToClassPath(java.lang.String _sAbsoluteFile)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CLASSES_PATH_FLAG

public static final java.lang.String CLASSES_PATH_FLAG

FLAG_PAGE_START

public static final java.lang.String FLAG_PAGE_START
另请参见：
常量字段值

TYPE_NOFLAG

public static final int TYPE_NOFLAG
另请参见：
常量字段值

TYPE_PAGE_START

public static final int TYPE_PAGE_START
另请参见：
常量字段值

TYPE_INCLUDE

public static final int TYPE_INCLUDE
另请参见：
常量字段值

TYPE_HTML_VALUE

public static final int TYPE_HTML_VALUE
另请参见：
常量字段值

TYPE_CODE_START

public static final int TYPE_CODE_START
另请参见：
常量字段值

TYPE_CODE_END

public static final int TYPE_CODE_END
另请参见：
常量字段值

TYPE_COMMENT

public static final int TYPE_COMMENT
另请参见：
常量字段值

OPERATION_STR

public static final java.lang.String[] OPERATION_STR

EXCLUDE_PATH

public static final java.lang.String[] EXCLUDE_PATH

arExcludeClass

public static java.util.ArrayList arExcludeClass

hTRSClasses

public static java.util.Hashtable hTRSClasses
构造方法详细信息

TRSImportsOrgnize

public TRSImportsOrgnize()
方法详细信息

isExcludeClass

public static boolean isExcludeClass(java.lang.String _sClassName)

transformPathToClassPath

public static java.lang.String transformPathToClassPath(java.lang.String _sAbsoluteFile)

getFileHashtable

public static java.util.Hashtable getFileHashtable(java.lang.String _sPath)

mapClassFullPath

public static java.lang.String mapClassFullPath(java.lang.String _sClassName)

dowithPath

public static void dowithPath(java.lang.String _sPath)
                       throws java.lang.Exception
抛出：
java.lang.Exception

dowithFile

public static java.lang.String dowithFile(java.lang.String _sFileName)
                                   throws CMyException
抛出：
CMyException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSJspAutoTool

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 TRSJspAutoTool

java.lang.Object
    继承者  com.trs.infra.util.TRSJspAutoTool

public class TRSJspAutoTool
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
应用层自动化工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TRSJspAutoTool(java.lang.String _sAuthor, java.lang.String _sClassPath, java.lang.String _sFileName, java.lang.String _sBaseObj, java.lang.String _sDescription)
方法摘要
void | createFile()
java.lang.String | getDowithTemplateFile()
java.lang.String | getSearchFields()
java.lang.String | getTemplateFile()
void | init(java.lang.String _sTemplateFile, boolean _bMergeFile, java.lang.String _sSearchFields)
boolean | isFileNameByBaseObj()
boolean | isMergeFile()
static void | main(java.lang.String[] args)
void | setDowithTemplateFile(java.lang.String dowithTemplateFile)
void | setFileNameByBaseObj(boolean fileNameByBaseObj)
void | setMergeFile(boolean mergeFile)
void | setSearchFields(java.lang.String searchFields)
void | setTemplateFile(java.lang.String templateFile)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSJspAutoTool

public TRSJspAutoTool(java.lang.String _sAuthor,
                      java.lang.String _sClassPath,
                      java.lang.String _sFileName,
                      java.lang.String _sBaseObj,
                      java.lang.String _sDescription)
方法详细信息

createFile

public void createFile()
                throws CMyException
抛出：
CMyException

isMergeFile

public boolean isMergeFile()

setMergeFile

public void setMergeFile(boolean mergeFile)

init

public void init(java.lang.String _sTemplateFile,
                 boolean _bMergeFile,
                 java.lang.String _sSearchFields)
          throws CMyException
抛出：
CMyException

getDowithTemplateFile

public java.lang.String getDowithTemplateFile()

setDowithTemplateFile

public void setDowithTemplateFile(java.lang.String dowithTemplateFile)

getSearchFields

public java.lang.String getSearchFields()

setSearchFields

public void setSearchFields(java.lang.String searchFields)

isFileNameByBaseObj

public boolean isFileNameByBaseObj()

setFileNameByBaseObj

public void setFileNameByBaseObj(boolean fileNameByBaseObj)

getTemplateFile

public java.lang.String getTemplateFile()

setTemplateFile

public void setTemplateFile(java.lang.String templateFile)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSLocaleAuto

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 TRSLocaleAuto

java.lang.Object
    继承者  com.trs.infra.util.TRSLocaleAuto

public class TRSLocaleAuto
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TRSLocaleAuto()
方法摘要
static java.lang.String | createJSPLocal(java.lang.String _sName, java.lang.String _sComponentName, java.lang.String _sElementName, java.lang.String _sOperName, java.lang.String _sPropFile)
static java.lang.String | createLocal(java.lang.String _sName, java.lang.String _sComponentName)
static java.lang.String | createLocal(java.lang.String _sName, java.lang.String _sComponentName, java.lang.String _sElementName)
static java.lang.String | createLocal(java.lang.String _sName, java.lang.String _sComponentName, java.lang.String _sElementName, java.lang.String _sOperName, java.lang.String _sPropFile)
static java.util.ArrayList | getElements()
static java.util.ArrayList | getOpers()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSLocaleAuto

public TRSLocaleAuto()
方法详细信息

createLocal

public static java.lang.String createLocal(java.lang.String _sName,
                                           java.lang.String _sComponentName)
                                    throws CMyException
抛出：
CMyException

createLocal

public static java.lang.String createLocal(java.lang.String _sName,
                                           java.lang.String _sComponentName,
                                           java.lang.String _sElementName)
                                    throws CMyException
抛出：
CMyException

createLocal

public static java.lang.String createLocal(java.lang.String _sName,
                                           java.lang.String _sComponentName,
                                           java.lang.String _sElementName,
                                           java.lang.String _sOperName,
                                           java.lang.String _sPropFile)

createJSPLocal

public static java.lang.String createJSPLocal(java.lang.String _sName,
                                              java.lang.String _sComponentName,
                                              java.lang.String _sElementName,
                                              java.lang.String _sOperName,
                                              java.lang.String _sPropFile)

getElements

public static java.util.ArrayList getElements()
                                       throws CMyException
返回：
抛出：
CMyException

getOpers

public static java.util.ArrayList getOpers()
                                    throws CMyException
返回：
抛出：
CMyException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLCoder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 URLCoder

java.lang.Object
    继承者  com.trs.infra.util.URLCoder

public final class URLCoder
extends java.lang.Object

URL的编码和解码 是从“com.trs.util.net”中移植过来的一个类，因为目前还不太方便直接使用“com.trs.util.net” 中的工具类。所以把其中的类型“URLCoder”移植到“com.trs.infra.util”中。

作者：
Martin (Fu Chengrui)

方法摘要
static java.lang.String | decode(java.lang.String s) 使用缺省字符集解码URL字符串
static java.lang.String | decode(java.lang.String str, java.lang.String enc) 使用指定的字符集解码URL
static java.lang.String | encode(java.lang.String s) 使用缺省字符集编码URL
static java.lang.String | encode(java.lang.String str, java.lang.String enc) 使用指定的字符集编码URL
static void | main(java.lang.String[] args) 仅供测试使用
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

decode

public static final java.lang.String decode(java.lang.String s)
使用缺省字符集解码URL字符串

参数：
s - 待解码的URL字符串

decode

public static final java.lang.String decode(java.lang.String str,
                                            java.lang.String enc)
                                     throws java.io.UnsupportedEncodingException
使用指定的字符集解码URL

参数：
str - 待解码的URL字符串
enc - 指定的字符集
返回：
解码后的字串
抛出：
java.io.UnsupportedEncodingException

encode

public static final java.lang.String encode(java.lang.String s)
使用缺省字符集编码URL

参数：
s - 待编码的字符串
返回：
编码后的URL

encode

public static final java.lang.String encode(java.lang.String str,
                                            java.lang.String enc)
                                     throws java.io.UnsupportedEncodingException
使用指定的字符集编码URL

参数：
str - 待编码的字符串
enc - 指定的字符集
返回：
编码后的URL
抛出：
java.io.UnsupportedEncodingException

main

public static void main(java.lang.String[] args)
仅供测试使用

参数：
args - 命令行参数
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMDiscoveryFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 WCMDiscoveryFactory

java.lang.Object
    继承者  com.trs.infra.util.WCMDiscoveryFactory

public class WCMDiscoveryFactory
extends java.lang.Object

构造方法摘要
WCMDiscoveryFactory()
方法摘要
static java.io.File | getClassRootFilePath() 获取Class文件的根路径
static java.io.File | getConfigRootFilePath() 获取配置文件的根路径
static com.trs.infra.discover.IDiscovery | getDiscovery() 获取当前系统的Discovery
static com.trs.infra.discover.IDiscovery | initDiscovery(java.io.File[] _pLibDirs, java.io.File[] _pClassesDirs)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMDiscoveryFactory

public WCMDiscoveryFactory()
方法详细信息

initDiscovery

public static com.trs.infra.discover.IDiscovery initDiscovery(java.io.File[] _pLibDirs,
                                                              java.io.File[] _pClassesDirs)
参数：
_pLibDirs -
_pClassesDirs -
返回：

getDiscovery

public static com.trs.infra.discover.IDiscovery getDiscovery()
获取当前系统的Discovery

返回：

getConfigRootFilePath

public static java.io.File getConfigRootFilePath()
获取配置文件的根路径

返回：
抛出：
java.lang.Exception

getClassRootFilePath

public static java.io.File getClassRootFilePath()
获取Class文件的根路径

返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlCharCheckedInputStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 XmlCharCheckedInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  com.trs.infra.util.XmlCharCheckedInputStream
所有已实现的接口：
java.io.Closeable
public class XmlCharCheckedInputStream
extends java.io.InputStream

Title: TRS 内容协作平台（TRS WCM）
Description:
Xml有效字符检查输入流
java.io.InputStream的一个简单封装,read方法检查每一个byte. 忽略0x20以下,除0x9(\t),0xA(\n),0xD(\r)字符 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
XmlCharCheckedInputStream(java.io.InputStream ins)
方法摘要
void | close()
int | read()
从类 java.io.InputStream 继承的方法
available, mark, markSupported, read, read, reset, skip
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlCharCheckedInputStream

public XmlCharCheckedInputStream(java.io.InputStream ins)
参数：
ins -
方法详细信息

read

public int read()
         throws java.io.IOException
指定者：
类 java.io.InputStream 中的 read
抛出：
java.io.IOException

close

public void close()
           throws java.io.IOException
指定者：
接口 java.io.Closeable 中的 close
覆盖：
类 java.io.InputStream 中的 close
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlDocWithDom4j

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util
类 XmlDocWithDom4j

java.lang.Object
    继承者  com.trs.infra.util.XmlDocWithDom4j

public class XmlDocWithDom4j
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Test dom4j
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
XmlDocWithDom4j()
方法摘要
static void | main(java.lang.String[] args)
static org.dom4j.Document | parse(java.lang.String _sXmlFile)
static org.dom4j.Document | parse(java.lang.String _sXmlFile, java.lang.String _sXslFile)
static org.dom4j.Document | styleDocument(org.dom4j.Document _document, java.lang.String _stylesheet)
static void | transform(java.lang.String _sSourceXml, java.lang.String _sSourceXsl, java.lang.String _sTarget)
static void | transform(java.lang.String _sSourceXml, java.lang.String _sSourceXsl, java.lang.String _encoding, java.lang.String _sTarget)
static void | write(org.dom4j.Document _document, java.lang.String _sTargetFile)
static void | write(org.dom4j.Document _document, java.lang.String _encoding, java.lang.String _sTargetFile)
static void | write(org.dom4j.Document _document, java.lang.String _xslFile, java.lang.String _encoding, java.lang.String _result)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlDocWithDom4j

public XmlDocWithDom4j()
方法详细信息

parse

public static org.dom4j.Document parse(java.lang.String _sXmlFile)
                                throws org.dom4j.DocumentException
抛出：
org.dom4j.DocumentException

parse

public static org.dom4j.Document parse(java.lang.String _sXmlFile,
                                       java.lang.String _sXslFile)
                                throws org.dom4j.DocumentException,
                                       javax.xml.transform.TransformerException
抛出：
org.dom4j.DocumentException
javax.xml.transform.TransformerException

write

public static void write(org.dom4j.Document _document,
                         java.lang.String _sTargetFile)
                  throws java.io.FileNotFoundException
抛出：
java.io.FileNotFoundException

write

public static void write(org.dom4j.Document _document,
                         java.lang.String _encoding,
                         java.lang.String _sTargetFile)
                  throws java.io.UnsupportedEncodingException,
                         java.io.FileNotFoundException
抛出：
java.io.UnsupportedEncodingException
java.io.FileNotFoundException

write

public static void write(org.dom4j.Document _document,
                         java.lang.String _xslFile,
                         java.lang.String _encoding,
                         java.lang.String _result)
                  throws javax.xml.transform.TransformerException,
                         java.io.UnsupportedEncodingException,
                         java.io.FileNotFoundException
抛出：
javax.xml.transform.TransformerException
java.io.UnsupportedEncodingException
java.io.FileNotFoundException

styleDocument

public static org.dom4j.Document styleDocument(org.dom4j.Document _document,
                                               java.lang.String _stylesheet)
                                        throws javax.xml.transform.TransformerException
抛出：
javax.xml.transform.TransformerException

transform

public static void transform(java.lang.String _sSourceXml,
                             java.lang.String _sSourceXsl,
                             java.lang.String _sTarget)
                      throws javax.xml.transform.TransformerException,
                             java.io.FileNotFoundException,
                             org.dom4j.DocumentException
抛出：
javax.xml.transform.TransformerException
java.io.FileNotFoundException
org.dom4j.DocumentException

transform

public static void transform(java.lang.String _sSourceXml,
                             java.lang.String _sSourceXsl,
                             java.lang.String _encoding,
                             java.lang.String _sTarget)
                      throws java.io.FileNotFoundException,
                             org.dom4j.DocumentException,
                             javax.xml.transform.TransformerException,
                             java.io.UnsupportedEncodingException
抛出：
java.io.FileNotFoundException
org.dom4j.DocumentException
javax.xml.transform.TransformerException
java.io.UnsupportedEncodingException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CabConstants

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.cabfile
接口 CabConstants

所有已知实现类：
CabEntry, CabFile
public interface CabConstants

字段摘要
static int | _A_ARCH
static int | _A_EXEC
static int | _A_HIDDEN
static int | _A_NAME_IS_UTF
static int | _A_RDONLY
static int | _A_SYSTEM
static int | cfhdrNEXT_CABINET
static int | cfhdrPREV_CABINET
static int | cfhdrRESERVE_PRESENT
static int | tcompBAD
static int | tcompMASK_TYPE
static int | tcompTYPE_LZX
static int | tcompTYPE_MSZIP
static int | tcompTYPE_NONE
static int | tcompTYPE_QUANTUM

字段详细信息

cfhdrPREV_CABINET

static final int cfhdrPREV_CABINET
另请参见：
常量字段值

cfhdrNEXT_CABINET

static final int cfhdrNEXT_CABINET
另请参见：
常量字段值

cfhdrRESERVE_PRESENT

static final int cfhdrRESERVE_PRESENT
另请参见：
常量字段值

_A_RDONLY

static final int _A_RDONLY
另请参见：
常量字段值

_A_HIDDEN

static final int _A_HIDDEN
另请参见：
常量字段值

_A_SYSTEM

static final int _A_SYSTEM
另请参见：
常量字段值

_A_ARCH

static final int _A_ARCH
另请参见：
常量字段值

_A_EXEC

static final int _A_EXEC
另请参见：
常量字段值

_A_NAME_IS_UTF

static final int _A_NAME_IS_UTF
另请参见：
常量字段值

tcompMASK_TYPE

static final int tcompMASK_TYPE
另请参见：
常量字段值

tcompTYPE_NONE

static final int tcompTYPE_NONE
另请参见：
常量字段值

tcompTYPE_MSZIP

static final int tcompTYPE_MSZIP
另请参见：
常量字段值

tcompTYPE_QUANTUM

static final int tcompTYPE_QUANTUM
另请参见：
常量字段值

tcompTYPE_LZX

static final int tcompTYPE_LZX
另请参见：
常量字段值

tcompBAD

static final int tcompBAD
另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CabEntry

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.cabfile
类 CabEntry

java.lang.Object
    继承者  com.trs.infra.util.cabfile.CabEntry
所有已实现的接口：
CabConstants
public class CabEntry
extends java.lang.Object
implements CabConstants

字段摘要
从接口 com.trs.infra.util.cabfile.CabConstants 继承的字段
_A_ARCH, _A_EXEC, _A_HIDDEN, _A_NAME_IS_UTF, _A_RDONLY, _A_SYSTEM, cfhdrNEXT_CABINET, cfhdrPREV_CABINET, cfhdrRESERVE_PRESENT, tcompBAD, tcompMASK_TYPE, tcompTYPE_LZX, tcompTYPE_MSZIP, tcompTYPE_NONE, tcompTYPE_QUANTUM
方法摘要
int | getAttribute()
java.lang.String | getName()
long | getSize()
long | getTime()
boolean | isHidden()
boolean | isReadonly()
boolean | isSystem()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getName

public java.lang.String getName()

getSize

public long getSize()

getTime

public long getTime()

getAttribute

public int getAttribute()

isReadonly

public boolean isReadonly()

isHidden

public boolean isHidden()

isSystem

public boolean isSystem()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CabFile

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.cabfile
类 CabFile

java.lang.Object
    继承者  com.trs.infra.util.cabfile.CabFile
所有已实现的接口：
CabConstants
public class CabFile
extends java.lang.Object
implements CabConstants

字段摘要
从接口 com.trs.infra.util.cabfile.CabConstants 继承的字段
_A_ARCH, _A_EXEC, _A_HIDDEN, _A_NAME_IS_UTF, _A_RDONLY, _A_SYSTEM, cfhdrNEXT_CABINET, cfhdrPREV_CABINET, cfhdrRESERVE_PRESENT, tcompBAD, tcompMASK_TYPE, tcompTYPE_LZX, tcompTYPE_MSZIP, tcompTYPE_NONE, tcompTYPE_QUANTUM
构造方法摘要
CabFile(java.io.File file)
CabFile(java.lang.String file)
方法摘要
void | close()
java.util.Iterator | entries()
int | extract(java.io.File diretory)
CabEntry | getEntry(java.lang.String name)
java.io.InputStream | getInputStream(CabEntry entry)
java.lang.String | getName()
int | size()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CabFile

public CabFile(java.io.File file)
        throws java.io.IOException
抛出：
java.io.IOException

CabFile

public CabFile(java.lang.String file)
        throws java.io.IOException
抛出：
java.io.IOException
方法详细信息

close

public void close()

entries

public java.util.Iterator entries()

extract

public int extract(java.io.File diretory)
            throws java.io.IOException
抛出：
java.io.IOException

getEntry

public CabEntry getEntry(java.lang.String name)

getInputStream

public java.io.InputStream getInputStream(CabEntry entry)
                                   throws java.io.IOException
抛出：
java.io.IOException

getName

public java.lang.String getName()

size

public int size()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.cabfile
接口
CabConstants
类
CabEntry
CabFile


com.trs.infra.util.cabfile

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.cabfile

接口摘要
CabConstants

类摘要
CabEntry
CabFile


com.trs.infra.util.cabfile 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.cabfile 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.cabfile.CabEntry (implements com.trs.infra.util.cabfile.CabConstants)
    • com.trs.infra.util.cabfile.CabFile (implements com.trs.infra.util.cabfile.CabConstants)

接口分层结构

  • com.trs.infra.util.cabfile.CabConstants


软件包 com.trs.infra.util.cabfile 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.cabfile
的使用

使用 com.trs.infra.util.cabfile 的软件包
com.trs.infra.util.cabfile

com.trs.infra.util.cabfile 使用的 com.trs.infra.util.cabfile 中的类
CabConstants
CabEntry

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.util.cabfile.CabConstants 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.util.cabfile.CabConstants
的使用

使用 CabConstants 的软件包
com.trs.infra.util.cabfile

com.trs.infra.util.cabfile 中 CabConstants 的使用

实现 CabConstants 的 com.trs.infra.util.cabfile 中的类
class | CabEntry
class | CabFile

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.cabfile.CabEntry 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.cabfile.CabEntry
的使用

使用 CabEntry 的软件包
com.trs.infra.util.cabfile

com.trs.infra.util.cabfile 中 CabEntry 的使用

返回 CabEntry 的 com.trs.infra.util.cabfile 中的方法
 CabEntry CabFile.getEntry(java.lang.String name)

参数类型为 CabEntry 的 com.trs.infra.util.cabfile 中的方法
 java.io.InputStream CabFile.getInputStream(CabEntry entry)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.cabfile.CabFile 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.cabfile.CabFile
的使用

没有 com.trs.infra.util.cabfile.CabFile 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.AttributesString 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.AttributesString
的使用

使用 AttributesString 的软件包
com.trs.components.common.publish.config
com.trs.infra.persistent

com.trs.components.common.publish.config 中 AttributesString 的使用

返回 AttributesString 的 com.trs.components.common.publish.config 中的方法
 AttributesString PublishDistributionTargetType.getParameters()
Returns the parameters config.

com.trs.infra.persistent 中 AttributesString 的使用

返回 AttributesString 的 com.trs.infra.persistent 中的方法
AttributesString | BaseObj.getAttributesString() 共用接口：属性创建扩展属性Attribute读操作 说明：子类可以通过重载禁止使用
AttributesString | BaseObj.getNewAttributesString() 共用接口：属性创建扩展属性Attribute读操作 说明：子类可以通过重载禁止使用

参数类型为 AttributesString 的 com.trs.infra.persistent 中的方法
 boolean BaseObj.setAttribute(AttributesString _attribute)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.BASE64DecoderStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.BASE64DecoderStream
的使用

没有 com.trs.infra.util.BASE64DecoderStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.BASE64EncoderStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.BASE64EncoderStream
的使用

没有 com.trs.infra.util.BASE64EncoderStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.Base64Util 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.Base64Util
的使用

没有 com.trs.infra.util.Base64Util 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CharsetDetector 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CharsetDetector
的使用

没有 com.trs.infra.util.CharsetDetector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CImage 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CImage
的使用

没有 com.trs.infra.util.CImage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMy3WLib 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMy3WLib
的使用

没有 com.trs.infra.util.CMy3WLib 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyBeanConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyBeanConfig
的使用

使用 CMyBeanConfig 的软件包
com.trs.infra.util

com.trs.infra.util 中 CMyBeanConfig 的使用

返回 CMyBeanConfig 的 com.trs.infra.util 中的方法
static CMyBeanConfig[] CMyBeanConfig.fromXMLFile(java.lang.String _sXMLFile)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyBitsValue 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyBitsValue
的使用

使用 CMyBitsValue 的软件包
com.trs.cms.auth.persistent
com.trs.cms.process.definition
com.trs.components.wcm.content.persistent
com.trs.infra.util

com.trs.cms.auth.persistent 中 CMyBitsValue 的使用

com.trs.cms.auth.persistent 中 CMyBitsValue 的子类
 class RightValue

返回 CMyBitsValue 的 com.trs.cms.auth.persistent 中的方法
 CMyBitsValue Rights.orAll()
将所有权限对象的权限值，做位或操作

com.trs.cms.process.definition 中 CMyBitsValue 的使用

返回 CMyBitsValue 的 com.trs.cms.process.definition 中的方法
 CMyBitsValue FlowNode.getDocActions()
获取在节点上定义的能够进行的文档操作（CMyBitsValue）

com.trs.components.wcm.content.persistent 中 CMyBitsValue 的使用

返回 CMyBitsValue 的 com.trs.components.wcm.content.persistent 中的方法
 CMyBitsValue Appendix.getUsedVersions()
获取使用该附件的文档的版本号列表

com.trs.infra.util 中 CMyBitsValue 的使用

返回 CMyBitsValue 的 com.trs.infra.util 中的方法
 CMyBitsValue CMyBitsValue.setBit(int _index, boolean _bValue)
设置指定bit位置的值

参数类型为 CMyBitsValue 的 com.trs.infra.util 中的方法
void | CMyBitsValue.and(CMyBitsValue _myBitsValue) 按位进行“与”运算
void | CMyBitsValue.copy(CMyBitsValue _myBitsValue) 对象复制
void | CMyBitsValue.or(CMyBitsValue _myBitsValue) 按位进行或运算

参数类型为 CMyBitsValue 的 com.trs.infra.util 中的构造方法
CMyBitsValue(CMyBitsValue _myBitsValue)
使用CMyBitsValue初始化的构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyClassConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyClassConfig
的使用

使用 CMyClassConfig 的软件包
com.trs.infra.util
com.trs.infra.util.email

com.trs.infra.util 中 CMyClassConfig 的使用

返回 CMyClassConfig 的 com.trs.infra.util 中的方法
static CMyClassConfig[] CMyClassConfig.fromXMLFile(java.lang.String _sXMLFile)

com.trs.infra.util.email 中 CMyClassConfig 的使用

com.trs.infra.util.email 中 CMyClassConfig 的子类
 class CMySMTPServer
Title: TRS 内容协作平台（TRS WCM）
Description:
SMTP服务器及其的相关属性设置管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyDateTime 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyDateTime
的使用

使用 CMyDateTime 的软件包
com.trs.ajaxservice
com.trs.cms.auth.persistent
com.trs.cms.process
com.trs.cms.process.engine
com.trs.components.common.calendar
com.trs.components.common.job
com.trs.components.common.message
com.trs.components.common.publish.persistent.element
com.trs.components.common.publish.persistent.taskdispatch
com.trs.components.common.reminder
com.trs.components.common.trsad
com.trs.components.common.trsvote
com.trs.components.gkml.sqgk.persistent
com.trs.components.gkml.sqgk.process.element
com.trs.components.infoview.helper
com.trs.components.metadata.publish
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.persistent
com.trs.components.wcm.epress
com.trs.components.wcm.process.element
com.trs.components.wcm.publish
com.trs.components.wcm.publish.element
com.trs.components.wcm.stat
com.trs.components.wcm.stat.domain
com.trs.db.update
com.trs.infra.db
com.trs.infra.persistent
com.trs.infra.support.file
com.trs.infra.support.log
com.trs.infra.util
com.trs.infra.util.job
com.trs.presentation.locale
com.trs.presentation.util
com.trs.service
com.trs.service.impl
com.trs.webframework.config
com.trs.webframework.context
com.trs.webframework.controler

com.trs.ajaxservice 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.ajaxservice 中的方法
static CMyDateTime ServiceConstants.makeDateTime(int _nFilterType)

com.trs.cms.auth.persistent 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.cms.auth.persistent 中的方法
CMyDateTime | TrusteeInfo.getCrTime() 提取属性：CrTime
CMyDateTime | TrusteeInfo.getEndTime() 提取属性：EndTime
CMyDateTime | User.getLastLoginTime() 取上次登录时间
CMyDateTime | User.getLoginTime() 获取当前登录时间
CMyDateTime | User.getRegTime() 获取注册时间
CMyDateTime | TrusteeInfo.getStartTime() 提取属性：StartTime

参数类型为 CMyDateTime 的 com.trs.cms.auth.persistent 中的方法
boolean | TrusteeInfo.setCrTime(CMyDateTime _dtCrTime) 设置属性：CrTime
boolean | TrusteeInfo.setEndTime(CMyDateTime _dtEndTime) 设置属性：EndTime
boolean | TrusteeInfo.setStartTime(CMyDateTime _dtStartTime) 设置属性：StartTime

com.trs.cms.process 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.cms.process 中的方法
CMyDateTime | QueryFlowDocContext.getParameter(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
CMyDateTime | IFlowContent.getStartTime() 获取内容被发起的时间

参数类型为 CMyDateTime 的 com.trs.cms.process 中的方法
CMyDateTime | QueryFlowDocContext.getParameter(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
void | QueryFlowDocContext.setParameter(java.lang.String _sParameterName, CMyDateTime _sValue)
void | IFlowContent.setStartTime(CMyDateTime _dtStartTime) 设置内容被发起的时间

com.trs.cms.process.engine 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.cms.process.engine 中的方法
CMyDateTime | FlowDoc.getAcceptTime()
CMyDateTime | FlowDoc.getPostTime() 获取递交时间
CMyDateTime | FlowDoc.getReceiveTime()

参数类型为 CMyDateTime 的 com.trs.cms.process.engine 中的方法
 boolean FlowDoc.setPostTime(CMyDateTime _postTime)
设置递交时间

com.trs.components.common.calendar 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.common.calendar 中的方法
CMyDateTime | Event.getEndTime() property: EndTime 结束时间
CMyDateTime | Event.getStartTime() property: StartTime 开始时间

参数类型为 CMyDateTime 的 com.trs.components.common.calendar 中的方法
Events | EventMgr.getDailyEvents(CMyDateTime _date, WCMFilter _filter) 获取当前用户在指定日期的日程安排
Events | EventMgr.getEvents(User _currUser, CMyDateTime _date, boolean _bIncludingShared, WCMFilter _filter)
boolean | Event.setEndTime(CMyDateTime _time)
boolean | Event.setStartTime(CMyDateTime _time)

com.trs.components.common.job 中 CMyDateTime 的使用

声明为 CMyDateTime 的 com.trs.components.common.job 中的字段
 CMyDateTime Schedule.dtAddList

返回 CMyDateTime 的 com.trs.components.common.job 中的方法
CMyDateTime | Schedule.getEndTime() 属性提取：执行结束时间，与开始时间共同指定计划执行所在的时间段。
CMyDateTime | Schedule.getExeTime() 属性提取：执行时间
CMyDateTime | Schedule.getLastExeTime() 取上次执行时间
CMyDateTime | Schedule.getStartTime() 属性提取：开始执行时间，与结束时间共同指定计划执行所在的时间段。

参数类型为 CMyDateTime 的 com.trs.components.common.job 中的方法
static Schedules | Schedules.findUnfinishedSchedules(User _currUser, CMyDateTime _dtTime)
boolean | Schedule.setEndTime(CMyDateTime _endTime)
boolean | Schedule.setExeTime(CMyDateTime _exeTime) 属性设置：执行时间
boolean | Schedule.setLastExeTime(CMyDateTime _time) 设置上次执行时间为指定时间
boolean | Schedule.setStartTime(CMyDateTime _startTime) 属性设置：开始执行时间

com.trs.components.common.message 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.common.message 中的方法
 CMyDateTime Message.getValidTime()
property: ValidTime 有效期

参数类型为 CMyDateTime 的 com.trs.components.common.message 中的方法
 boolean Message.setValidTime(CMyDateTime _time)

com.trs.components.common.publish.persistent.element 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.common.publish.persistent.element 中的方法
CMyDateTime | PublishContentImplBase.getCreatedTime()
CMyDateTime | IPublishContent.getCreatedTime() Returns the created time of this content.
CMyDateTime | PublishContentWrapper.getCreatedTime()

参数类型为 CMyDateTime 的 com.trs.components.common.publish.persistent.element 中的方法
void | IPublishContent.setPublishTime(CMyDateTime _dtTime) 设置当前内容的发布时间
void | PublishContentWrapper.setPublishTime(CMyDateTime _dtTime)
void | PublishContentDefaultObjImpl.setPublishTime(CMyDateTime _dtTime)
void | IPublishContent.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url) 设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
void | PublishContentWrapper.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)
void | PublishContentDefaultObjImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)

com.trs.components.common.publish.persistent.taskdispatch 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
CMyDateTime | PublishTask.getEndTime() 提取属性：EndTime
CMyDateTime | PublishTask.getStartTime() 提取属性：StartTime

参数类型为 CMyDateTime 的 com.trs.components.common.publish.persistent.taskdispatch 中的方法
boolean | PublishTask.setEndTime(CMyDateTime _endTime) 设置属性：EndTime
boolean | PublishTask.setStartTime(CMyDateTime _startTime) 设置属性：StartTime

com.trs.components.common.reminder 中 CMyDateTime 的使用

参数类型为 CMyDateTime 的 com.trs.components.common.reminder 中的方法
static void Reminder.createSchedule(Message _newMessage, CMyDateTime _dtRemind)
创建一个消息提醒

com.trs.components.common.trsad 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.common.trsad 中的方法
CMyDateTime | ADFilePos.getAdBegin() 提取属性：AdBegin
CMyDateTime | ADFile.getAdBegin() 提取属性：AdBegin
CMyDateTime | ADFile.getAdCrTime() 提取属性：AdCrTime
CMyDateTime | ADFilePos.getAdEnd() 提取属性：AdEnd
CMyDateTime | ADFile.getAdEnd() 提取属性：AdEnd
CMyDateTime | ADCom.getComCrtime() 提取属性：ComCrtime记录创建时间
CMyDateTime | ADType.getTypeCrTime() 提取属性：CrTime

参数类型为 CMyDateTime 的 com.trs.components.common.trsad 中的方法
boolean | ADFilePos.setAdBegin(CMyDateTime _dtAdBegin) 设置属性：AdBegin
boolean | ADFile.setAdBegin(CMyDateTime _dtAdBegin) 设置属性：AdBegin
boolean | ADFile.setAdCrTime(CMyDateTime _dtAdCrTime) 设置属性：AdCrTime
boolean | ADFilePos.setAdEnd(CMyDateTime _dtAdEnd) 设置属性：AdEnd
boolean | ADFile.setAdEnd(CMyDateTime _dtAdEnd) 设置属性：AdEnd
boolean | ADCom.setComCrtime(CMyDateTime _dtComCrtime) 设置属性：ComCrtime记录创建时间
boolean | ADType.setTypeCrTime(CMyDateTime _dtCrTime) 设置属性：CrTime

com.trs.components.common.trsvote 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.common.trsvote 中的方法
CMyDateTime | Vote.getCrTime() 提取属性：CrTime
CMyDateTime | VoteIPLog.getLogTime() 提取属性：LogTime
CMyDateTime | Vote.getTimeBegin() 提取属性：TimeBegin
CMyDateTime | Vote.getTimeEnd() 提取属性：TimeEnd

参数类型为 CMyDateTime 的 com.trs.components.common.trsvote 中的方法
boolean | Vote.setCrTime(CMyDateTime _sCrTime) 设置属性：CrTime
boolean | VoteIPLog.setLogTime(CMyDateTime _dtLogTime) 设置属性：LogTime
boolean | Vote.setTimeBegin(CMyDateTime _sTimeBegin) 设置属性：TimeBegin
boolean | Vote.setTimeEnd(CMyDateTime _sTimeEnd) 设置属性：TimeEnd

com.trs.components.gkml.sqgk.persistent 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.gkml.sqgk.persistent 中的方法
 CMyDateTime ApplyForm.getDealTime()
提取属性：DEALTIME

参数类型为 CMyDateTime 的 com.trs.components.gkml.sqgk.persistent 中的方法
 boolean ApplyForm.setDealTime(CMyDateTime _dtDealTime)
设置属性：DEALTIME

com.trs.components.gkml.sqgk.process.element 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.gkml.sqgk.process.element 中的方法
 CMyDateTime FlowContentApplyFormImpl.getStartTime()

参数类型为 CMyDateTime 的 com.trs.components.gkml.sqgk.process.element 中的方法
 void FlowContentApplyFormImpl.setStartTime(CMyDateTime _dtStartTime)

com.trs.components.infoview.helper 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.infoview.helper 中的方法
 CMyDateTime ComplexFieldData.getPostTime()

参数类型为 CMyDateTime 的 com.trs.components.infoview.helper 中的方法
 boolean ComplexFieldData.setPostTime(CMyDateTime _postTime)

com.trs.components.metadata.publish 中 CMyDateTime 的使用

参数类型为 CMyDateTime 的 com.trs.components.metadata.publish 中的方法
void | PublishContentViewFieldImpl.setPublishTime(CMyDateTime _dtTime)
void | PublishContentViewDataImpl.setPublishTime(CMyDateTime _dtTime)
void | PublishContentViewImpl.setPublishTime(CMyDateTime _dtTime)
void | PublishContentViewFieldImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)
void | PublishContentViewDataImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)
void | PublishContentViewImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String url)

com.trs.components.stat 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.stat 中的方法
CMyDateTime | StatDocCountOfGroupByMetaClass.createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
CMyDateTime | StatDocCountOfUserByMetaClass.createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
CMyDateTime | StatDocCountOfGroupByChannel.createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
CMyDateTime | StatDocCountByChannel.createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
CMyDateTime | DocumentHitsCount.getDocCrTime() 提取属性：DocCrTime 文档创建时间
CMyDateTime | HostObjHitsCount.getHitsTime() 提取属性：HitsTime
CMyDateTime | DocumentHitsCount.getHitsTime() 提取属性：HitsTime 点击时间
CMyDateTime | UserLoginInfo.getLoginTime() 提取属性：LoginTime，用户登录时间
CMyDateTime | HostObjHitsCount.getObjCrTime() 提取属性：ObjCrTime
CMyDateTime | TimeRange.getRangeEnd() 获取当前位置下，指定步长之内，跨度的结束时间
CMyDateTime | TimeRange.getRangeStart() 获取当前位置下，指定步长之内，跨度的开始时间

参数类型为 CMyDateTime 的 com.trs.components.stat 中的方法
CMyDateTime | StatDocCountOfGroupByMetaClass.createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
CMyDateTime | StatDocCountOfUserByMetaClass.createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
CMyDateTime | StatDocCountOfGroupByChannel.createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
CMyDateTime | StatDocCountByChannel.createStatDataInTempTableByDay(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime)
float | StatBonusResultForUser.getHitsBonusOfMonth(java.lang.String _sUserName, int _nDocId, CMyDateTime _dateTime) 获取指定用户所发的指定文档，在指定月份的点击量奖金
int | StatBonusResultForUser.getHitsCountOfMonth(java.lang.String _sUserName, int _nDocId, CMyDateTime _dateTime) 获取指定用户所发的指定文档，在指定月份的点击量
int | StatBonusResultForUser.getIssuedAmountOfMonth(java.lang.String _sUserName, CMyDateTime _dateTime) 获取指定用户在指定月份的发稿量 (该方法用在按月份统计的时候，奖金的类型已经确定)
float | StatBonusResultForUser.getIssuesAmountBonusOfMonth(java.lang.String _sUserName, CMyDateTime _dateTime) 获取指定用户在指定月份所获的奖金 (该方法在按月份统计的时候使用，这时奖金的类型已经确定)
boolean | DocumentHitsCount.setDocCrTime(CMyDateTime _dtDocCrTime) 设置属性：DocCrTime 文档创建时间
boolean | HostObjHitsCount.setHitsTime(CMyDateTime _dtHitsTime) 设置属性：HitsTime
boolean | DocumentHitsCount.setHitsTime(CMyDateTime _dtHitsTime) 设置属性：HitsTime 点击时间
boolean | UserLoginInfo.setLoginTime(CMyDateTime _dtLoginTime) 设置属性：LoginTime，用户登录时间
boolean | HostObjHitsCount.setObjCrTime(CMyDateTime _dtObjCrTime) 设置属性：ObjCrTime
StatBonusResultForUser | StatBonusDataForUser.stat(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
IStatResult | StatAnalysisTool.stat(CMyDateTime startDate, CMyDateTime endDate) 对指定的开始时间startDate与结束时间endDate进行统计，返回统计的结果集对象
IStatResults | StatAnalysisTool.stat(CMyDateTime startDate, CMyDateTime endDate, int nStepType) 对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。
StatBonusResultForUser | StatBonusDataForUser.stat(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, int _nSortBy, boolean _bSortDesc) 产生指定时间段的统计结果
java.util.HashMap | StatDocCountOfGroupByMetaClass.stat(int _nRootClassInfoId, CMyDateTime _dtStartTime) 产生指定时间指定站点的统计结果
java.util.HashMap | StatDocCountOfUserByMetaClass.stat(int _nRootClassInfoId, CMyDateTime _dtStartTime) 产生指定时间指定分类下的统计结果
java.util.HashMap | StatDocCountOfGroupByChannel.stat(int _nSiteId, CMyDateTime _dtStartTime) 产生指定时间指定站点的统计结果
java.util.HashMap | StatDocCountByChannel.stat(int _nSiteId, CMyDateTime _dtStartTime) 产生指定时间指定站点的统计结果
java.util.HashMap | StatDocCountOfGroupByMetaClass.stat(int _nRootClassInfoId, CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
java.util.HashMap | StatDocCountOfUserByMetaClass.stat(int _nRootClassInfoId, CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
java.util.HashMap | StatDocCountOfGroupByChannel.stat(int _nSiteId, CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
java.util.HashMap | StatDocCountByChannel.stat(int _nSiteId, CMyDateTime _dtStartTime, CMyDateTime _dtEndTime) 产生指定时间段的统计结果
StatBonusResultForUser | StatBonusDataForUser.statHitsBonusByMonth(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, boolean _bSortDesc) 获取指定时间段的点击量奖金的统计结果
StatBonusResultForUser | StatBonusDataForUser.statIssuedAmountBonusByMonth(CMyDateTime _dtStartTime, CMyDateTime _dtEndTime, boolean _bSortDesc) 获取发稿量奖金按月统计的结果

参数类型为 CMyDateTime 的 com.trs.components.stat 中的构造方法
TimeRange(CMyDateTime startDate, CMyDateTime endDate, int nStepType)

com.trs.components.wcm.content.domain 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.wcm.content.domain 中的方法
CMyDateTime | DocumentMgr.getDocumentTopTime(Document _currDocument, Channel _currChannel) 获得文档置顶的截止时间 如果文档没有置顶，则直接返回null 如果置顶文档没有设置截止时间则返回null
CMyDateTime | IDocumentsTimeRangeMgr.getStartDateTime(int _nChannelId) 获取指定频道提取文档的开始时间
CMyDateTime | DocumentsTimeRangeMgrImpl.getStartDateTime(int _nChannelId)
CMyDateTime | IDocumentsTimeRangeMgr.getStartDateTime(int _nObjectId, int _nObjectType) 获取指定对象提取文档的开始时间
CMyDateTime | DocumentsTimeRangeMgrImpl.getStartDateTime(int _nObjectId, int _nObjectType)

参数类型为 CMyDateTime 的 com.trs.components.wcm.content.domain 中的方法
void | DocumentMgr.setTopDocument(Channel _currChannel, Document _fromDocument, Document _toDocument, int _nPosition, CMyDateTime dtValid)
void | DocumentMgr.setTopDocument(Channel _currChannel, Document _currDocument, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶 如果特定的位置已经存在文档，则需要将该位置及其后的所有置顶向后移动一位 如果最后一个置顶项目也有占用，则自动将置顶位置扩展一位！
void | DocumentMgr.setTopedDocument(Document _document, Channel _channel, int _nTopOrder, CMyDateTime _dtTopedValid)

com.trs.components.wcm.content.persistent 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.wcm.content.persistent 中的方法
CMyDateTime | DocBak.getBakTime() 获取备份时间
CMyDateTime | ChannelSyn.getDocEndTime() 属性提取：文档结束时间
CMyDateTime | ChnlDoc.getDocPubTime() 提取属性：DocPubTime
CMyDateTime | ChannelSyn.getDocStartTime() 属性提取：文档执行时间
CMyDateTime | ChannelSyn.getEndTime() 属性提取：执行结束时间
CMyDateTime | ChnlDoc.getInvalidTime() 获取文档置顶的有效时间（截止时间）
CMyDateTime | ChnlDoc.getOperTime() 获得操作时间
static CMyDateTime | Document.getPubPathStartTime() 获取发布文件按照日期存放的起始时间
CMyDateTime | Document.getPubTime() 获取发布时间
CMyDateTime | Document.getReleaseTime() 获取撰写时间
CMyDateTime | ChannelSyn.getStartTime() 属性提取：开始执行时间
CMyDateTime | Appendix.getTime() 获取附件的时间
CMyDateTime | Document.getValidTime() 获取文档的有效时间

参数类型为 CMyDateTime 的 com.trs.components.wcm.content.persistent 中的方法
boolean | ChannelSyn.setDocEndTime(CMyDateTime _endTime)
boolean | ChnlDoc.setDocPubTime(CMyDateTime _dtDocPubTime) 设置属性：DocPubTime
boolean | ChannelSyn.setDocStartTime(CMyDateTime _startTime) 属性设置：文档执行时间
boolean | ChannelSyn.setEndTime(CMyDateTime _endTime)
void | Channel.setEndTime(CMyDateTime _dtEnd) 设置频道文档列表的结束时间
boolean | ChnlDoc.setInvalidTime(CMyDateTime _dtInvalidTime) 设置文档置顶的有效时间（截止时间）
static void | Document.setPubPathStartTime(CMyDateTime _dtStart) 设置发布文件按照日期存放的起始时间
boolean | Document.setPubTime(CMyDateTime _pubTime) 设置发布时间
boolean | Document.setReleaseTime(CMyDateTime _releaseTime) 设置撰写时间
boolean | ChannelSyn.setStartTime(CMyDateTime _startTime) 属性设置：开始执行时间
void | Channel.setStartTime(CMyDateTime _dtStart) 设置频道文档列表的开始时间
boolean | Appendix.setTime(CMyDateTime _time) 设置附件的时间
boolean | Document.setValidTime(CMyDateTime _valid) 设置文档的有效时间

com.trs.components.wcm.epress 中 CMyDateTime 的使用

参数类型为 CMyDateTime 的 com.trs.components.wcm.epress 中的方法
 void EPressHistoryGenerator.generate(CMyDateTime _history)

参数类型为 CMyDateTime 的 com.trs.components.wcm.epress 中的构造方法
EpressFolderWrapper(IPublishFolder _folder, CMyDateTime _history)

com.trs.components.wcm.process.element 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.wcm.process.element 中的方法
 CMyDateTime FlowContentDocumentImpl.getStartTime()

参数类型为 CMyDateTime 的 com.trs.components.wcm.process.element 中的方法
 void FlowContentDocumentImpl.setStartTime(CMyDateTime _dtStartTime)

com.trs.components.wcm.publish 中 CMyDateTime 的使用

参数类型为 CMyDateTime 的 com.trs.components.wcm.publish 中的方法
 void WCMContentPublishConfig.setSchedulePublish(CMyDateTime _dtSchedulePublishTime)

com.trs.components.wcm.publish.element 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.wcm.publish.element 中的方法
 CMyDateTime PublishContentDocumentImpl.getCreatedTime()

参数类型为 CMyDateTime 的 com.trs.components.wcm.publish.element 中的方法
void | PublishContentDocumentImpl.setPublishTime(CMyDateTime _dtTime)
void | PublishContentDocumentImpl.setPublishTimeAndURL(CMyDateTime _time, java.lang.String _url)

com.trs.components.wcm.stat 中 CMyDateTime 的使用

参数类型为 CMyDateTime 的 com.trs.components.wcm.stat 中的方法
CMyResultSets | StatMgr.getCurrentStatResult(int _nStatViewId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 做一个即时统计.模板统计视图不允许.
CMyResultSets | StatMgr.getStatResult(int _nStatViewId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy) 统计在一个时间段内，符合特定条件的某个统计的结果 从临时统计表中查询，所以时间条件都是以DEF_STATTIME为准 Id需要从表中构造 Notes: The view shoulb be a Template View.

com.trs.components.wcm.stat.domain 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.components.wcm.stat.domain 中的方法
CMyDateTime | ChartOption.getEndStatTime()
CMyDateTime | ChartOption.getStartStatTime()
CMyDateTime | StatDataItem.getStatTime()

参数类型为 CMyDateTime 的 com.trs.components.wcm.stat.domain 中的方法
void | ChartOption.setEndStatTime(CMyDateTime endStatTime)
void | ChartOption.setStartStatTime(CMyDateTime startStatTime)
void | StatDataItem.setStatTime(CMyDateTime statTime)

参数类型为 CMyDateTime 的 com.trs.components.wcm.stat.domain 中的构造方法
ChartOption(CMyDateTime _dtStart, CMyDateTime _dtEnd, int _nPeriodType, java.lang.String _sCurrStagField)
ChartOption(CMyDateTime _dtStart, CMyDateTime _dtEnd, int _nPeriodType, java.lang.String _sCurrStagField, java.lang.String _sGroupBy, java.lang.String _sStatTimeField)
StatDataItem(CMyDateTime _sStatTime, java.util.Map _hData)

com.trs.db.update 中 CMyDateTime 的使用

参数类型为 CMyDateTime 的 com.trs.db.update 中的方法
static void | SQLServerUpdateSQL.createOracleUpateSQL(CMyDateTime _dtStart)
static void | SQLServerUpdateSQL.createSQLServerUpateSQL(CMyDateTime _dtStart)
java.lang.String | DBUpdateLogMgr.getUpdateSql(int _nDBType, java.lang.String _sOrderField, boolean _bAutoAddCommit, boolean _bAddTitle, boolean _bAuthor, CMyDateTime _dtStart) 获得完整的数据库更新脚本

com.trs.infra.db 中 CMyDateTime 的使用

参数类型为 CMyDateTime 的 com.trs.infra.db 中的方法
void | QueryFilter.addSearchValues(CMyDateTime _value)
void | QueryFilter.addSearchValues(int _nIndex, CMyDateTime _dtTime)

com.trs.infra.persistent 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.infra.persistent 中的方法
CMyDateTime | BaseObj.getCrTime() 共有接口：获取创建时间crtime 说明：子类可以通过重载禁止使用
CMyDateTime | BaseObj.getPropertyAsDateTime(java.lang.String _sName) 取日期时间型属性值

参数类型为 CMyDateTime 的 com.trs.infra.persistent 中的方法
void | WCMFilter.addSearchValues(CMyDateTime _value)
void | WCMFilter.addSearchValues(int _nIndex, CMyDateTime _dtTime)

com.trs.infra.support.file 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.infra.support.file 中的方法
static CMyDateTime | FilesMan.extractFileCrDate(java.lang.String _sFileName) 提取创建日期值
static CMyDateTime | FilesMan.extractFileCrDateTime(java.lang.String _sFileName) 提取文件创建的日期时间值

参数类型为 CMyDateTime 的 com.trs.infra.support.file 中的方法
java.lang.String | FilesMan.getNextFileName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime) 获取下一个可用的文件名称
java.lang.String | FilesMan.getNextFileName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime, boolean _bIncludePath) 获取下一个可用的文件名称 构造说明： [1]构造文件名时，自动检测文件名是否重复。
java.lang.String | FilesMan.getNextFilePathName(java.lang.String _sPathFlag, java.lang.String _sFileExt, CMyDateTime _crTime) 获取下一个可用的文件名称

com.trs.infra.support.log 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.infra.support.log 中的方法
CMyDateTime | LogBak.getBakTime() 获取备份时间
CMyDateTime | BaseDBLog.getOpTime() 获取操作时间
CMyDateTime | ILog.getOpTime() 获取操作时间

参数类型为 CMyDateTime 的 com.trs.infra.support.log 中的方法
static void | LogServer.archiveLogs(CMyDateTime _arciveDate) 对特定时间之前的所有日志进行归档
static boolean | LogServer.delete(CMyDateTime _currDate) 删除特定日期之前的所有日志
static boolean | LogServer.delete(CMyDateTime _startDate, CMyDateTime _endDate) 删除特定时间段的所有日志
static boolean | LogServer.deleteLogBaks(CMyDateTime _currDate) 删除特定日期前的所有归档日志
static boolean | LogServer.deleteLogBaks(CMyDateTime _startDate, CMyDateTime _endDate) 删除特定时间段的所有归档日志
boolean | BaseDBLog.setOpTime(CMyDateTime _opTime) 设置操作时间
boolean | ILog.setOpTime(CMyDateTime _opTime) 设置操作时间

com.trs.infra.util 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.infra.util 中的方法
CMyDateTime | CMyDateTime.dateAdd(int p_nField, int p_nAdd) 日期时间增/减函数
static CMyDateTime | CMyDateTime.now() 获取值为系统当前时间的CMyDateTime对象

参数类型为 CMyDateTime 的 com.trs.infra.util 中的方法
long | CMyDateTime.compareTo(CMyDateTime p_mydtAnother) 时间比较
long | CMyDateTime.dateDiff(int p_nPart, CMyDateTime p_mydtAnother) 取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差

com.trs.infra.util.job 中 CMyDateTime 的使用

参数类型为 CMyDateTime 的 com.trs.infra.util.job 中的方法
void | JobScheduler.addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, CMyDateTime _dtExecute)
void | JobScheduler.addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, CMyDateTime _dtStart, CMyDateTime _dtEnd, long _nInterval)

com.trs.presentation.locale 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.presentation.locale 中的方法
static CMyDateTime LocaleServer.getDateTime(java.lang.String _sKey)
已过时。 no need?

com.trs.presentation.util 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.presentation.util 中的方法
CMyDateTime | RequestHelper.getDateTime(java.lang.String _sName) 取日期时间型属性值
CMyDateTime | RequestHelper.getDateTime(java.lang.String _sName, java.lang.String _sDateFormate) 取日期时间型属性值
CMyDateTime | PageParameter.getDefaultAsDateTime() 将默认值转换为日期类型
CMyDateTime | Parameter.getPropertyAsDateTime(java.lang.String _sName) 取日期时间型属性值

参数类型为 CMyDateTime 的 com.trs.presentation.util 中的方法
static java.lang.String | PageViewUtil.toHtml(CMyDateTime _date)
static java.lang.String | PageViewUtil.toHtml(CMyDateTime _date, java.lang.String _dateFormat)

com.trs.service 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.service 中的方法
 CMyDateTime IDocumentService.getTopTime(Document _currDocument, Channel _currChannel)
获得文档置顶的截止时间
如果文档没有置顶，则直接返回null
如果置顶文档没有设置截止时间则返回null

参数类型为 CMyDateTime 的 com.trs.service 中的方法
CMyResultSets | IStatService.getCurrentStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 统计在一个时间段内，符合特定条件的某个统计的结果 对数据库进行实时统计，而不是从统计临时表中取
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date) 获取用户在指定日期内被Assign的所有Events
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll) 获取用户在指定日期内私有的或公有的Events
Events | IEventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter) 获取用户在指定filter限制下被Assign的Events
CMyResultSets | IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate) 统计在一个时间段内，某个统计的结果
CMyResultSets | IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 统计在一个时间段内，符合特定条件的某个统计的结果
CMyResultSets | IStatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)
void | IDocumentService.setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶

com.trs.service.impl 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.service.impl 中的方法
 CMyDateTime DocumentService.getTopTime(Document _currDocument, Channel _currChannel)

参数类型为 CMyDateTime 的 com.trs.service.impl 中的方法
CMyResultSets | StatService.getCurrentStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll)
Events | EventService.getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter)
CMyResultSets | StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate)
CMyResultSets | StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere)
CMyResultSets | StatService.getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)
void | DocumentService.setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil)

com.trs.webframework.config 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.webframework.config 中的方法
CMyDateTime | TRSPageParameter.getDefaultAsDateTime() 将默认值转换为日期类型
CMyDateTime | TRSParameter.getPropertyAsDateTime(java.lang.String _sName) 取日期时间型属性值

com.trs.webframework.context 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.webframework.context 中的方法
 CMyDateTime MethodContext.getValue(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)

参数类型为 CMyDateTime 的 com.trs.webframework.context 中的方法
CMyDateTime | MethodContext.getValue(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
void | MethodContext.setValue(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)

com.trs.webframework.controler 中 CMyDateTime 的使用

返回 CMyDateTime 的 com.trs.webframework.controler 中的方法
CMyDateTime | JSPServiceContext.getParam(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
CMyDateTime | JSPRequestProcessor.getParam(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)

参数类型为 CMyDateTime 的 com.trs.webframework.controler 中的方法
CMyDateTime | JSPServiceContext.getParam(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
CMyDateTime | JSPRequestProcessor.getParam(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyDecimalBuddy 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyDecimalBuddy
的使用

没有 com.trs.infra.util.CMyDecimalBuddy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyDOM4jHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyDOM4jHelper
的使用

没有 com.trs.infra.util.CMyDOM4jHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyEncrypt 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyEncrypt
的使用

没有 com.trs.infra.util.CMyEncrypt 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyErrors 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyErrors
的使用

使用 CMyErrors 的软件包
com.trs.infra
com.trs.infra.util

com.trs.infra 中 CMyErrors 的使用

返回 CMyErrors 的 com.trs.infra 中的方法
CMyErrors | IServer.getErrors() 获取错误信息
CMyErrors | BaseServer.getErrors()

com.trs.infra.util 中 CMyErrors 的使用

返回 CMyErrors 的 com.trs.infra.util 中的方法
CMyErrors | CMyErrors.add(CMyErrors _errors) 添加错误
CMyErrors | CMyErrors.add(java.lang.Exception _ex) 添加错误
CMyErrors | CMyErrors.add(java.lang.String _sError) 添加错误
CMyErrors | CMyErrors.add(java.lang.String _sInfo, java.lang.Exception _ex)
CMyErrors | CMyErrors.clear() 清除错误列表

参数类型为 CMyErrors 的 com.trs.infra.util 中的方法
 CMyErrors CMyErrors.add(CMyErrors _errors)
添加错误

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyException 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyException
的使用

使用 CMyException 的软件包
com.trs
com.trs.ajaxservice
com.trs.cms.content
com.trs.components.comment.domain
com.trs.components.common.publish
com.trs.components.infoview.helper
com.trs.components.stat
com.trs.components.wcm.stat.domain
com.trs.components.web
com.trs.infra.common
com.trs.infra.config
com.trs.infra.config.domain
com.trs.infra.util
com.trs.infra.util.database
com.trs.infra.util.email
com.trs.infra.util.ftp
com.trs.infra.util.html
com.trs.infra.util.xml
com.trs.scene.tools
com.trs.template.domain
com.trs.tools
com.trs.webframework.config
com.trs.webframework.xmlserver

com.trs 中 CMyException 的使用

抛出 CMyException 的 com.trs 中的方法
java.lang.Object | SpringBean.getBean(java.lang.String _sResourceId)
java.lang.Class | SpringBean.getBeanClass(java.lang.String _sResourceId)
java.lang.String | SpringBean.getBeanClassName(java.lang.String _sResourceId)
static java.lang.String[] | DreamFactory.getBeanDefinitionNames()
java.lang.String[] | SpringBean.getBeanDefinitionNames()
boolean | SpringBean.isSinglton(java.lang.String _sResourceid)

com.trs.ajaxservice 中 CMyException 的使用

抛出 CMyException 的 com.trs.ajaxservice 中的方法
static CMyDateTime | ServiceConstants.makeDateTime(int _nFilterType)
java.io.File | InfoviewService.makeTemplatesToZip(MethodContext _context)

com.trs.cms.content 中 CMyException 的使用

抛出 CMyException 的 com.trs.cms.content 中的方法
static void WCMObjHelper.unlock(int _nObjType, int _nObjId, User _unlockerUser)
指定的用户给指定的对象解锁

com.trs.components.comment.domain 中 CMyException 的使用

抛出 CMyException 的 com.trs.components.comment.domain 中的方法
java.lang.String | DocumentTopicRelationMgr.getNoneRelatedDocIds(int _nTopicId, int _nDocChannelId)
java.lang.String | DocumentTopicRelationMgr.getRelatedDocIds(int _nTopicId)
java.lang.String | DocumentTopicRelationMgr.getRelatedDocIds(int _nTopicId, int _nDocChannelId)
boolean | DocumentTopicRelationMgr.isInRelatedTopic(int _nDocId, int _nDocChannelId)
void | DocumentTopicRelationMgr.saveDocTopicRelation(int _nTopicId, int _nDocChannelId, int[] _arRelatedDocIds)

com.trs.components.common.publish 中 CMyException 的使用

com.trs.components.common.publish 中 CMyException 的子类
 class OrignHomePublishException

com.trs.components.infoview.helper 中 CMyException 的使用

抛出 CMyException 的 com.trs.components.infoview.helper 中的方法
static InfoViewDocuments | InfoViewNewQueryHelper.queryData(MethodContext _methodContext)
static InfoViewDocuments | InfoViewNewQueryHelper.queryData(RequestHelper requestHelper)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML(MethodContext _context)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML(RequestHelper _requestHelper)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML2(MethodContext _context)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML2(RequestHelper _requestHelper)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML3(MethodContext _context)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML3(RequestHelper _requestHelper)
static Documents | InfoViewNewQueryHelper.queryDocuments(MethodContext _methodContext)
static Documents | InfoViewNewQueryHelper.queryDocuments(RequestHelper requestHelper)

com.trs.components.stat 中 CMyException 的使用

抛出 CMyException 的 com.trs.components.stat 中的方法
java.lang.String | TimeRange.getXlabel() 根据当前的开始时间和结束时间获取X的坐标内容
static java.lang.String[] | HitsCountHelper.makeQueryComparedHitsTimeRands(int _nType) 构造比较的时间段
static java.lang.String[] | HitsCountHelper.makeQueryHitsTimeRands(int _nType) 构造原时间段
boolean | TimeRange.next() 判断当前是否还能获取到下一步长的时间

com.trs.components.wcm.stat.domain 中 CMyException 的使用

抛出 CMyException 的 com.trs.components.wcm.stat.domain 中的方法
static void | ChartWriter.generateChart(java.io.OutputStream _os, org.jfree.chart.JFreeChart oChart)
static void | ChartWriter.generateChart(java.io.OutputStream _os, org.jfree.chart.JFreeChart oChart, ChartStyle _oStyle)
static void | ChartWriter.generateChart(java.lang.String _sFilepath, org.jfree.chart.JFreeChart oChart)
static void | ChartWriter.generateChart(java.lang.String _sFilepath, org.jfree.chart.JFreeChart oChart, ChartStyle _oStyle)
static int | ChartConstants.getSpecCategory(java.lang.String _sCategoryName)
static java.lang.String | ChartConstants.getSpecFileExt(java.lang.String _sMineType)
org.jfree.data.xy.XYDataset | TimingChartBuilder.makeXYDataSet(java.lang.Object _dataset, ChartOption _option)

com.trs.components.web 中 CMyException 的使用

抛出 CMyException 的 com.trs.components.web 中的方法
java.lang.String | BaseFieldHTMLParser.getTemplate(java.lang.String sFieldName) 根据字段名称，返回该字段对应的HTML模板资源
java.lang.String | BaseFieldHTMLParser.parse(java.lang.String sFieldName, IPropertiesBuilder builder)
java.lang.String | IFieldHTMLParser.parse(java.lang.String sFieldName, IPropertiesBuilder builder) 根据字段的内容，解析成相应的HTML代码

com.trs.infra.common 中 CMyException 的使用

com.trs.infra.common 中 CMyException 的子类
class | WCMDatainvalidException Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMException Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config 中 CMyException 的使用

抛出 CMyException 的 com.trs.infra.config 中的方法
static void XMLConfig.main(java.lang.String[] args)

com.trs.infra.config.domain 中 CMyException 的使用

抛出 CMyException 的 com.trs.infra.config.domain 中的方法
java.io.InputStream | BeanConfigHelper.getBeanConfigXmlInputStream() 得到所有SpringBeand的inputStream，特用于SpringBean的创建
static org.xml.sax.InputSource | ConfigHelper.getMappingSource(ConfigFiles _configFiles) 组织所有的映射文件，形成一个文件流，用于Mapping对象的创建
static org.xml.sax.InputSource | ConfigHelper.getMappingSource(java.lang.String _sMappingFile) 通过文件名得到 Mapping 的输入流
ConfigFiles | ConfigFilesFinder.refresh() 刷新
static org.dom4j.Document | ConfigHelper.toXMLDocument(java.io.File _file) 将指定的xml文件流转化文档模型

com.trs.infra.util 中 CMyException 的使用

抛出 CMyException 的 com.trs.infra.util 中的方法
void | CMyZip.addToZip(java.lang.String p_srcToZip)
void | CMyZip.addToZip(java.lang.String p_srcToZip, boolean p_bAddPathToEntryName) 将指定文件或目录，添加到压缩包
void | CMyZip.addToZip(java.lang.String p_srcToZip, java.lang.String _sEntryName)
static boolean | CMyFile.appendFile(java.lang.String _sFileName, java.lang.String _sAddContent) 把指定的内容_sAddContent追加到文件_sFileName中
static boolean | CMyFile.copyFile(java.lang.String _sSrcFile, java.lang.String _sDstFile) 复制文件
static boolean | CMyFile.copyFile(java.lang.String _sSrcFile, java.lang.String _sDstFile, boolean _bMakeDirIfNotExists)
static boolean | CMyFile.copyFile(java.lang.String _sSrcFile, java.lang.String _sDstFile, boolean _bMakeDirIfNotExists, boolean preserveFileDate)
static void | CMyFile.copyFileDir(java.lang.String _fromFileDir, java.lang.String _toFileDir, boolean _bIncludeCurrDir) 拷贝文件夹到指定的文件夹
void | TRSJspAutoTool.createFile()
static java.lang.String | TRSLocaleAuto.createLocal(java.lang.String _sName, java.lang.String _sComponentName)
static java.lang.String | TRSLocaleAuto.createLocal(java.lang.String _sName, java.lang.String _sComponentName, java.lang.String _sElementName)
CMyDateTime | CMyDateTime.dateAdd(int p_nField, int p_nAdd) 日期时间增/减函数
long | CMyDateTime.dateDiff(int p_nPart, CMyDateTime p_mydtAnother) 取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差
long | CMyDateTime.dateDiff(int p_nPart, java.util.Date p_dtAnother) 取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差
static ResponseBuddy | CMy3WLib.doGet(java.lang.String sURL, java.util.Map mContent) 向指定的sURL发送一个get请求
ResponseBuddy | HttpClientBuddy.doGet(java.lang.String _sPostUri, java.util.Map mContent)
static ResponseBuddy | CMy3WLib.doGet(java.lang.String sURL, java.lang.String sContent) 向指定的sURL发送一个get请求
ResponseBuddy | HttpClientBuddy.doGet(java.lang.String _sPostUri, java.lang.String _sQueryString) 以GET方式发送请求，获取返回对象
boolean | CMyZip.done()
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, byte[] _btContent) 以POST方式发送请求，获取返回对象
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, byte[] _btContent, boolean _bChunked) 以POST方式发送请求，获取返回对象
static ResponseBuddy | CMy3WLib.doPost(java.lang.String sURL, java.util.Map mContent) 向指定的sURL发送一个post请求
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, java.util.Map mContent, boolean _bChunked)
static ResponseBuddy | CMy3WLib.doPost(java.lang.String sURL, java.util.Map mContent, java.lang.String sEncoding)
static ResponseBuddy | CMy3WLib.doPost(java.lang.String sURL, java.lang.String sContent)
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, java.lang.String sContent) 以POST方式发送请求，获取返回对象
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, java.lang.String sContent, boolean _bChunked) 以POST方式发送请求，获取返回对象
static ResponseBuddy | CMy3WLib.doPost(java.lang.String sURL, java.lang.String sContent, java.lang.String sEncoding)
void | CMyUnZipFile.doUnZipAnd()
static java.lang.String | CopyOfTRSImportsOrgnize.dowithFile(java.lang.String _sFileName)
static java.lang.String | TRSImportsOrgnize.dowithFile(java.lang.String _sFileName)
int | CMyDateTime.get(int p_nField) 日期/时间的分解
java.lang.String | CMyDateTime.getDateTimeAsString() 输出格式化的日期时间字符串 格式：由setDateTimeFormat指定
java.lang.String | CMyDateTime.getDateTimeAsString(java.lang.String p_sFormat) 获取格式化的日期时间字符串
int | CMyDateTime.getDay() 获取当前对象中的【日】的部分
int | CMyDateTime.getDayOfWeek() 取当前日期是所在week的第几天 说明：一个礼拜的第一天为Monday(0)，最后一天为Sunday(6)
static java.util.ArrayList | TRSLocaleAuto.getElements()
static boolean | CMy3WLib.getFile(java.lang.String p_sSrcFileUrl) 访WEB链接
static boolean | CMy3WLib.getFile(java.lang.String p_sSrcFileUrl, java.lang.String p_sDstPathFileName) 获取WEB上文件
static boolean | CMy3WLib.getFile(java.lang.String p_sProtocol, java.lang.String p_sHost, int p_nPort, java.lang.String p_sFile, java.lang.String p_sDstPathFileName) 获取WEB上文件
static boolean | CMy3WLib.getFile(java.lang.String p_sProtocol, java.lang.String p_sHost, java.lang.String p_sFile, java.lang.String p_sDstPathFileName) 获取WEB上文件
static boolean | CMy3WLib.getFile(java.net.URL p_urlSrcFile) 访问指定的URL
static boolean | CMy3WLib.getFile(java.net.URL p_urlSrcFile, java.lang.String p_sDstPathFileName) 获取指定URL的源文件，并保存到本地目标文件 说明：若不指定目标文件，则抛弃获取结果
int | CMyDateTime.getHour() 获取当前对象中的【小时】的部分
ZipEntry | CMyUnzip.getItem(java.lang.String _sItemName) 提取指定压缩项信息
java.util.Enumeration | CMyUnzip.getItems() 提取zip文件中的压缩项
int | CMyDateTime.getMinute() 获取当前对象中的【分】的部分
int | CMyDateTime.getMonth() 获取当前对象中的【月】的部分
static java.util.ArrayList | TRSLocaleAuto.getOpers()
int | CMyDateTime.getSecond() 获取当前对象中的【秒】的部分
int | CMyDateTime.getWeekCountsOfMonth(boolean _bSundayStart)
int | CMyDateTime.getYear() 获取当前对象中的【年】的部分
void | TRSJspAutoTool.init(java.lang.String _sTemplateFile, boolean _bMergeFile, java.lang.String _sSearchFields)
boolean | CMyDateTime.isLeapYear()
static boolean | CMyFile.moveFile(java.lang.String _sSrcFile, java.lang.String _sDstFile) 移动文件
static boolean | CMyFile.moveFile(java.lang.String _sSrcFile, java.lang.String _sDstFile, boolean _bMakeDirIfNotExists) 移动文件
void | CPager.moveToCurrentPageInRs(java.sql.ResultSet p_rsData) 在记录集中定位到当前页
static byte[] | CMyFile.readBytesFromFile(java.lang.String _sFileName)
static java.lang.String | CMyFile.readFile(java.lang.String _sFileName) 读取文件的内容，返回字符串类型的文件内容
static java.lang.String | CMyFile.readFile(java.lang.String _sFileName, java.lang.String _sEncoding) 读取文件的内容，返回字符串类型的文件内容
boolean | CMySMS.send() 发送短消息
void | CMySMS.setContent(java.lang.String _sContent) 设置短信息内容
boolean | CMyDateTime.setDate(java.sql.Date p_dDate) 设置日期值 说明：若当前日期时间非空，则仅改变日期值，时间值保持不变
void | CMyDateTime.setDateTimeWithRs(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从记录集当前行读取指定日期/时间字段的值
void | CMyDateTime.setDateTimeWithRs(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从记录集当前行读取指定日期/时间字段的值
boolean | CMyDateTime.setDateTimeWithString(java.lang.String _sValue) 使用未知格式的字符串值设置日期时间
boolean | CMyDateTime.setDateTimeWithString(java.lang.String p_sValue, java.lang.String p_sFormat) 使用字符串设置日期和时间
void | CMyDateTime.setDateTimeWithTimestamp(java.sql.Timestamp p_tsDateTime) 使用Timestamp对象设置日期和时间
boolean | CMyDateTime.setDateWithString(java.lang.String p_sDateValue, int p_nFormatType) 使用字符串设置日期值
void | CPager.setItemCount(java.sql.Statement p_oStmt, java.lang.String p_sCountSQL) 设定元素总数：通过指定查询SQL语句，在数据库中检索
boolean | CMyDateTime.setTime(java.sql.Time p_tTime) 设置时间值 说明：若当前日期时间非空，则仅改变时间值，日期值保持不变
boolean | CMyDateTime.setTimeWithString(java.lang.String p_sTimeValue, int p_nFormatType) 使用字符串设置时间值
void | CMySMS.setTo(java.lang.String _sTo) 设置收信人
void | CMyUnzip.setZipFile(java.lang.String _zipFileName) 设置zip文件
void | CMyZip.setZipFileName(java.lang.String p_sZipFileName) 设置压缩后的目标Zip文件名
static void | CMyXMLDoc.toFile(org.jdom.Document _XMLDoc, java.lang.String _XMLFileName)
static void | CMyXMLDoc.toFile(org.jdom.Document _XMLDoc, java.lang.String _XMLFileName, java.lang.String _XSLFileName)
static org.jdom.Document | CMyXMLDoc.toXMLDocument(java.lang.String _sXMLFile) 将XML文件解析成DOM结构，返回XML Document对象
static org.jdom.Document | CMyXMLDoc.toXMLDocument(java.lang.String _sXMLFile, java.lang.String _sXSLFile) 将XML文件解析成DOM结构，返回XML Document对象
static void | CMyXMLDoc.toXMLFile(org.jdom.Document _XMLDoc, java.lang.String _sXMLFileName, java.lang.String _sXMLEncoding) 根据DOM 树生成XML文件
static void | CMyXMLDoc.toXMLFile(org.jdom.Document _XMLDoc, java.lang.String _XMLFileName, java.lang.String _XSLFileName, java.lang.String _XMLEncoding) 根据DOM 树生成XML文件
static boolean | CMyXMLDoc.transformXML(java.lang.String _XMLSource, java.lang.String _XSLSource, java.lang.String _XMLTarget) 根据XSL模板文件生成XML文件
static boolean | CMyXMLDoc.transformXML(java.lang.String _XMLSource, java.lang.String _XSLSource, java.lang.String _XMLTarget, java.lang.String _XMLEncoding) 根据XSL模板文件生成XML文件
void | CMyUnzip.unzip(java.lang.String _sDstPath, boolean _bCreateDstPathIfNotExists) 解压缩操作
static void | CMyUnzip.unzip(java.lang.String _zipFileName, java.lang.String _dstPath, boolean _bCreateDstPathIfNotExists) 将指定的压缩文件解压缩到指定目录
ResponseBuddy | HttpClientBuddy.updateFile(java.lang.String _sPostUri, byte[] _fileContent)
ResponseBuddy | HttpClientBuddy.updateFile(java.lang.String _sPostUri, java.io.File _oUpdateFile) 上传文件，获取返回对象
static boolean | CMyFile.writeFile(java.lang.String _sFileName, java.lang.String _sFileContent) 以指定内容_sFileContent生成新的文件_sFileName
static boolean | CMyFile.writeFile(java.lang.String _sFileName, java.lang.String _sFileContent, java.lang.String _encoding) 以指定内容_sFileContent生成新的文件_sFileName
static boolean | CMyFile.writeFile(java.lang.String _sFileName, java.lang.String _sFileContent, java.lang.String _sFileEncoding, boolean _bWriteUnicodeFlag)
void | CMyZip.zip(java.lang.String p_srcToZip, java.lang.String p_sZipFile)

com.trs.infra.util.database 中 CMyException 的使用

抛出 CMyException 的 com.trs.infra.util.database 中的方法
java.lang.String | DB2UDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
java.lang.String | DB2UDB2.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
static java.lang.String | SybaseASEText.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex) 根据字段序号提取Clob/text字段内容
java.lang.String | SQLServerDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
java.lang.String | SybaseASEWithJtds.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
abstract java.lang.String | DBType.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
java.lang.String | MysqlDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
java.lang.String | SybaseASE.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
java.lang.String | XuguDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
java.lang.String | OracleDB11G.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
java.lang.String | DB2AS400DB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
static java.lang.String | COracleCLOB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
java.lang.String | OracleDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
java.lang.String | DB2UDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
java.lang.String | DB2UDB2.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
static java.lang.String | SybaseASEText.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName) 根据字段名称提取Clob/text字段内容
java.lang.String | SQLServerDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
java.lang.String | SybaseASEWithJtds.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
abstract java.lang.String | DBType.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
java.lang.String | MysqlDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
java.lang.String | SybaseASE.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
java.lang.String | XuguDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
java.lang.String | OracleDB11G.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
java.lang.String | DB2AS400DB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
static java.lang.String | COracleCLOB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
java.lang.String | OracleDB.getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
static java.lang.String | CMysqlText.getClob(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Text型字段的值
static java.lang.String | CAS400CLOB.getClob(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
static java.lang.String | CDB2DBCLOB.getClob(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
static java.lang.String | CDB2DBCLOB2.getClob(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
static java.lang.String | CMysqlText.getClob(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Text型字段的值
static java.lang.String | CAS400CLOB.getClob(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
static java.lang.String | CDB2DBCLOB.getClob(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
static java.lang.String | CDB2DBCLOB2.getClob(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
static java.lang.String | CSQLText.getText(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Text型字段的值
static java.lang.String | CSQLText.getText(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Text型字段的值
void | TableInfos.load(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner) 从指定的数据库中读取所有字段的字段信息，构成字段信息列表
void | TableInfos.load(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner, java.lang.String _sTableName)
void | TableInfos.notifyAddTable(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner, java.lang.String _sTableName)
void | CDBText.readFromRs(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
void | CDBText.readFromRs(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
boolean | DBType.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sIdFieldName, int nObjId, java.lang.String[] p_asFieldsAndValues)
boolean | OracleDB11G.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sIdFieldName, int nObjId, java.lang.String[] p_asFieldsAndValues)
boolean | OracleDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sIdFieldName, int nObjId, java.lang.String[] p_asFieldsAndValues)
boolean | DBType.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String sIdFieldName, int nObjId, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
boolean | OracleDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String sIdFieldName, int nObjId, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
static boolean | SybaseASEText.setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 根据更新语句设置Clob/text字段内容
static boolean | CMysqlText.setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 根据更新语句设置Clob/text字段内容
static boolean | CAS400CLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 将Clob/Text型字段值写入数据库
static boolean | CDB2DBCLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 将Clob/Text型字段值写入数据库
static boolean | CDB2DBCLOB2.setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 将Clob/Text型字段值写入数据库
static boolean | COracleCLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 将Clob/Text型字段值写入数据库
boolean | DB2UDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
boolean | DB2UDB2.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
static boolean | SybaseASEText.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 根据条件同时写入多个Clob/text内容
boolean | SQLServerDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
boolean | SybaseASEWithJtds.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
static boolean | CMysqlText.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 根据条件同时写入多个Clob/text内容
abstract boolean | DBType.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
boolean | MysqlDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
static boolean | CAS400CLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
boolean | SybaseASE.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
static boolean | CDB2DBCLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
boolean | OracleDB11G.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
static boolean | CDB2DBCLOB2.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
boolean | DB2AS400DB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
static boolean | COracleCLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
boolean | OracleDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
boolean | DB2UDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
boolean | DB2UDB2.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
static boolean | SybaseASEText.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 根据条件写入Clob/text内容
boolean | SQLServerDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
boolean | SybaseASEWithJtds.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
static boolean | CMysqlText.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 根据条件写入Clob/text内容
abstract boolean | DBType.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
boolean | MysqlDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
static boolean | CAS400CLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
boolean | SybaseASE.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
static boolean | CDB2DBCLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
boolean | OracleDB11G.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
static boolean | CDB2DBCLOB2.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
boolean | DB2AS400DB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
static boolean | COracleCLOB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
boolean | OracleDB.setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
void | TableInfos.toHtml(java.sql.Connection _oConn, int _dbType, java.lang.String _sFileName) 将数据库信息，输出到Html文本中
boolean | CDBText.updateToDB(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sTextFieldName) 将Clob/Text型字段值写入数据库

com.trs.infra.util.email 中 CMyException 的使用

com.trs.infra.util.email 中 CMyException 的子类
 class CMyMailException
Title: TRS 内容协作平台（TRS WCM）
Description:
邮件相关的异常信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.ftp 中 CMyException 的使用

抛出 CMyException 的 com.trs.infra.util.ftp 中的方法
void | CMyFtp.changeDirs(java.lang.String _sPath) 更改FTP服务器的当前目录，如果包含的子目录不存在，则自动创建子目录
boolean | CMyFtp.Connect() 根据设置的配置信息，连接到FTP服务器
boolean | CMyFtp.Connect(boolean bPassiveMode)
CMyFtp | FtpConnectionPool.getConnection()
void | IFtpMgr.init(java.lang.String _sServer, java.lang.String _sLoginUser, java.lang.String _sPassword, java.lang.String _sRootDir, boolean _bPassiveMode, int _nMaxConnections) Initiates this ftp manager.
void | FtpMgr.init(java.lang.String _sServer, java.lang.String _sLoginUser, java.lang.String _sPassword, java.lang.String _sRootDir, boolean _bPassiveMode, int _nMaxConnections)
boolean | CMyFtp.isConnected() 判断当前的连接是否存在或有效
boolean | CMyFtp.makeDirectory(java.lang.String _sDir) 根据指定的路径创建FTP目录
boolean | CMyFtp.removeDirectory(java.lang.String _sDir) 删除FTP服务器上指定的目录
boolean | CMyFtp.renameFile(java.lang.String _sDstFile, java.lang.String _sNewFile) 根据指定的路径创建FTP目录
boolean | IFtpMgr.upload(java.lang.String _sLocalFile, java.lang.String _sRemoteFile) Uploads a local file to the ftp server.
boolean | FtpMgr.upload(java.lang.String _sLocalFtpFile, java.lang.String _sRemoteFile)
void | CMyFtp.uploadDirectory(java.lang.String _localDir, java.lang.String _remoteDir) 上传指定目录下的所有文件到FTP服务器的指定目录
boolean | CMyFtp.uploadFile(java.lang.String _localFile, java.lang.String _remoteFile) 上传指定的本地文件到FTP服务器 首先检查FTP链接是否正常，如果已经断开则自动重新链接一次。

抛出 CMyException 的 com.trs.infra.util.ftp 中的构造方法
FtpConnectionPool(java.lang.String _sServer, java.lang.String _sLoginUser, java.lang.String _sPassword, java.lang.String _sRootDir, boolean _bPassiveMode, int _nMaxConnections)
Constructor

com.trs.infra.util.html 中 CMyException 的使用

抛出 CMyException 的 com.trs.infra.util.html 中的方法
HtmlElement | HtmlElement.addContent(HtmlComment _comment) 添加一个注释对象
HtmlDocument | HtmlDocument.addContent(HtmlComment _comment) 在文档内容列表中，添加一个注释对象
HtmlElement | HtmlElement.addContent(HtmlElement _element) 添加一个HtmlElement
int | HtmlElement.fromString(char[] _srcBuffer, int _nStart)
int | HtmlElement.fromString(char[] _srcBuffer, int _nStart, java.lang.String _sTagsToSkip) 从指定的字符串中导入元素信息
int | HtmlElement.fromString(java.lang.String _strSrc)
boolean | HtmlDocument.fromString(java.lang.String _strSrc) 从字符串导入 处理方式：构造虚拟的HtmlElement元素，由其解释
int | HtmlElement.fromString(java.lang.String _strSrc, java.lang.String _sTagsToSkip) 字符串导入,字符串格式：<名称 属性列表> 内容|子元素列表 </名称>
boolean | HtmlAttribute.getBooleanValue() 将属性值转化为boolean值
double | HtmlAttribute.getDoubleValue() 将属性值转化为双精度数
float | HtmlAttribute.getFloatValue() 将属性值转化为浮点数
int | HtmlAttribute.getIntValue() 将属性值转化为整型
long | HtmlAttribute.getLongValue() 将属性值转化为长整型
boolean | HtmlDocument.loadFromFile(java.lang.String _sFilePathName) 从文件中装载
boolean | ContentLinkReplacer.loadLinkMap(java.lang.String _linkMapFile) 装载链接映射表
java.lang.String | ContentLinkReplacer.replaceLink(java.lang.String _srcContent) 使用指定的链接映射表，替换指定内容中的字符串
java.lang.String | ContentLinkReplacer.replaceLink(java.lang.String _srcContent, java.lang.String _extraLinkAttributes) 使用指定的链接映射表，替换指定内容中的字符串
void | HtmlDocument.saveToFile(java.lang.String _sFilePathName) 将Html文档内容保存到文件
HtmlDocument | HtmlDocument.setContent(java.util.List _newContent) 设置Html文档内容,要求：有且仅有一个根元素

com.trs.infra.util.xml 中 CMyException 的使用

抛出 CMyException 的 com.trs.infra.util.xml 中的方法
IXmlPersistentObject | XmlObjectPersistentor.getParsedInstance(java.lang.String _sXmlFile)
IXmlPersistentObject | XmlObjectPersistentor.getParsedInstance(java.lang.String _sXmlFile, java.lang.String _sEncodingStyle) get the Parsed Instance from a certain xml file
void | XmlObjectPersistentor.updateInstance(IXmlPersistentObject _xmlObj, java.lang.String _sXmlFile)
void | XmlObjectPersistentor.updateInstance(IXmlPersistentObject _xmlObj, java.lang.String _sXmlFile, java.lang.String _sEncodingStyle) update the persistent object

com.trs.scene.tools 中 CMyException 的使用

抛出 CMyException 的 com.trs.scene.tools 中的方法
void | SceneAutoCreator.changeTempName()
void | SceneAutoCreator.copyImage() 将模板中所用到的图片和部分flash文件拷贝到preview/pub中，防止zip上传时造成的文件丢失，预览效果差。

com.trs.template.domain 中 CMyException 的使用

抛出 CMyException 的 com.trs.template.domain 中的方法
static byte[] TemplateXmlGenerator.zipFiles(java.util.List arFiles)

com.trs.tools 中 CMyException 的使用

抛出 CMyException 的 com.trs.tools 中的方法
void | LocalServerAuto.analyze()
void | LocalServerAuto.analyzeFile(java.io.File oFile)
void | LocalServerAuto.analyzePath(java.io.File oPath)
static void | ChineseFinder.handleFile(java.lang.String sSrcFileName, java.lang.String sDestFileName)
static void | ChineseFinder.handleFolder(java.lang.String sSrcPath, java.lang.String sDestPath)
static void | ChineseFinder.handleFolder(java.lang.String sSrcPath, java.lang.String sDestPath, java.lang.String sFileExt)
void | Localizer.localize()
void | Localizer2.localize()
void | Localizer.localize1()
void | Localizer2.localize1()
void | Localizer.localizeFile(java.io.File oFile, java.lang.String _toFileName)
void | Localizer2.localizeFile(java.io.File oFile, java.lang.String _toFileName)
void | Localizer.localizeNew(java.util.Date date)
void | Localizer2.localizeNew(java.util.Date date)
void | Localizer.localizeNew1(java.util.Date date)
void | Localizer2.localizeNew1(java.util.Date date)
void | Localizer.localizePath(java.io.File oPath)
void | Localizer2.localizePath(java.io.File oPath)
static void | ChineseFinder.main(java.lang.String[] args)

com.trs.webframework.config 中 CMyException 的使用

抛出 CMyException 的 com.trs.webframework.config 中的方法
static TRSPageParameter | TRSPageParameter.createPageParameterFromXML(org.dom4j.Element _elParameter) 通过一个XML数据产生一个PageParameter对象
boolean | TRSParameter.fromXML(org.dom4j.Element _element) 从指定的XML Element导入参数数据 fromXMLElement(_element)
boolean | TRSPageParameter.fromXML(org.dom4j.Element _element)
CMyDateTime | TRSPageParameter.getDefaultAsDateTime() 将默认值转换为日期类型
boolean | TRSParameter.getPropertyAsBoolean(java.lang.String _sName, boolean _bDefault) 取布尔型属性值 说明：0值为false，非0值为true
CMyDateTime | TRSParameter.getPropertyAsDateTime(java.lang.String _sName) 取日期时间型属性值
int | TRSParameter.getPropertyAsInt(java.lang.String _sName, int _nDefault) 取长整型属性值
long | TRSParameter.getPropertyAsLong(java.lang.String _sName, long _lDefault) 取长整型属性值
void | MethodConfig.initFrom(org.dom4j.Element _elMethod, IServiceProvider _oDefaultProvider)
void | TRSPageParameter.setType(java.lang.String _sType) 设置当前参数的类型，类型定义为：PageParameter.TYPE_STRING等

com.trs.webframework.xmlserver 中 CMyException 的使用

com.trs.webframework.xmlserver 中 CMyException 的子类
 class ConvertException
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyFile 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyFile
的使用

没有 com.trs.infra.util.CMyFile 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyFilenameFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyFilenameFilter
的使用

没有 com.trs.infra.util.CMyFilenameFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyFileX 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyFileX
的使用

没有 com.trs.infra.util.CMyFileX 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyKeyGenerator 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyKeyGenerator
的使用

没有 com.trs.infra.util.CMyKeyGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyMemory 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyMemory
的使用

没有 com.trs.infra.util.CMyMemory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMySign 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMySign
的使用

使用 CMySign 的软件包
com.trs.infra.util

com.trs.infra.util 中 CMySign 的使用

返回 CMySign 的 com.trs.infra.util 中的方法
static CMySign | CMySign.getSign(java.lang.String _sPrivateKey) 返回唯一的实例
static CMySign | CMySign.getVerify(java.lang.String _sPublicKey) 此处插入方法说明。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMySMS 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMySMS
的使用

没有 com.trs.infra.util.CMySMS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyString 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyString
的使用

没有 com.trs.infra.util.CMyString 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyTimer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyTimer
的使用

没有 com.trs.infra.util.CMyTimer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyTransformCoding 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyTransformCoding
的使用

没有 com.trs.infra.util.CMyTransformCoding 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyUnzip 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyUnzip
的使用

没有 com.trs.infra.util.CMyUnzip 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyUnZipFile 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyUnZipFile
的使用

没有 com.trs.infra.util.CMyUnZipFile 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyURLEncoder 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyURLEncoder
的使用

没有 com.trs.infra.util.CMyURLEncoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyXMLDoc 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyXMLDoc
的使用

没有 com.trs.infra.util.CMyXMLDoc 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyXMLElement 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyXMLElement
的使用

使用 CMyXMLElement 的软件包
com.trs.infra.util
com.trs.infra.util.email

com.trs.infra.util 中 CMyXMLElement 的使用

com.trs.infra.util 中 CMyXMLElement 的子类
class | CMyBeanConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | CMyClassConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 CMyXMLElement 的 com.trs.infra.util 中的方法
static CMyXMLElement | CMyXMLParser.fileToElement(java.lang.String _sResourceFileName)
static CMyXMLElement | CMyXMLParser.fileToElement(java.lang.String _sResourceFileName, java.lang.Class _class)
static CMyXMLElement | CMyXMLParser.filtToElement(java.lang.String _sResourceFileName, java.lang.Class _class, java.lang.String _sEncoding)
CMyXMLElement | CMyXMLElement.getChild(java.lang.String _sChildName)
CMyXMLElement | CMyXMLHandler.getRootConfig()
static CMyXMLElement | CMyXMLParser.streamToElement(java.io.InputStream _isContent, java.lang.Class _class, java.lang.String _sEncoding)
static CMyXMLElement | CMyXMLParser.strToElement(java.lang.String _sContent)
static CMyXMLElement | CMyXMLParser.strToElement(java.lang.String _sContent, java.lang.Class _class)
static CMyXMLElement | CMyXMLParser.strToElement(java.lang.String _sContent, java.lang.Class _class, java.lang.String _sEncoding)

参数类型为 CMyXMLElement 的 com.trs.infra.util 中的方法
boolean | CMyXMLElement.addChild(CMyXMLElement _config)
void | CMyXMLHandler.setRootConfig(CMyXMLElement rootConfig)

com.trs.infra.util.email 中 CMyXMLElement 的使用

com.trs.infra.util.email 中 CMyXMLElement 的子类
 class CMySMTPServer
Title: TRS 内容协作平台（TRS WCM）
Description:
SMTP服务器及其的相关属性设置管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyXMLHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyXMLHandler
的使用

没有 com.trs.infra.util.CMyXMLHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyXMLParser 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyXMLParser
的使用

没有 com.trs.infra.util.CMyXMLParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CMyZip 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CMyZip
的使用

没有 com.trs.infra.util.CMyZip 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ConfigElementContentTester 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ConfigElementContentTester
的使用

没有 com.trs.infra.util.ConfigElementContentTester 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CopyOfTRSImportsOrgnize 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CopyOfTRSImportsOrgnize
的使用

没有 com.trs.infra.util.CopyOfTRSImportsOrgnize 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.CPager 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.CPager
的使用

使用 CPager 的软件包
com.trs.cms.process
com.trs.components.wcm.content
com.trs.components.wcm.wcmx.jsp
com.trs.presentation.util

com.trs.cms.process 中 CPager 的使用

返回 CPager 的 com.trs.cms.process 中的方法
 CPager QueryFlowDocContext.getPager()

参数类型为 CPager 的 com.trs.cms.process 中的方法
IFlowContent[] | FlowServerImpl.getFlowContentsDoneByUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsDoneByUser(User _currUser, CPager _cpager) 获取指定用户已经处理过的内容
IFlowContent[] | FlowServerImpl.getFlowContentsOfUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsOfUser(User _currUser, CPager _cpager) 获取指定用户可以处理的内容
IFlowContent[] | FlowServerImpl.getFlowContentsStartByUser(User _currUser, CPager _cpager)
IFlowContent[] | IFlowServer.getFlowContentsStartByUser(User _currUser, CPager _cpager) 获取指定用户已经启动的内容
void | QueryFlowDocContext.setPager(CPager _sPager)

com.trs.components.wcm.content 中 CPager 的使用

参数类型为 CPager 的 com.trs.components.wcm.content 中的方法
 void ViewDocuments.openTRSServerViewDocuments(com.eprobiti.trs.TRSResultSet _sTrsRs, TRSToWCMFilter _filter, CPager _sCurrPager)

com.trs.components.wcm.wcmx.jsp 中 CPager 的使用

参数类型为 CPager 的 com.trs.components.wcm.wcmx.jsp 中的方法
static java.lang.String | PageUtil.getPageNextHtml(CPager _pager, java.lang.String _emptyDesc)
static java.lang.String | PageUtil.getPageNextHtml(CPager _pager, java.lang.String _emptyDesc, java.lang.String _pageClass, java.lang.String _firstImage, java.lang.String _nextImage, java.lang.String _prevImage, java.lang.String _endImage) 获取翻页的HTML代码
static java.lang.String | PageUtil.getPageNumHtml(CPager _pager)
static java.lang.String | PageUtil.getPageNumHtml(CPager _pager, java.lang.String _bgColor, java.lang.String _fontColor)

com.trs.presentation.util 中 CPager 的使用

参数类型为 CPager 的 com.trs.presentation.util 中的方法
static java.lang.String | PageHelper.PagerHtmlGenerator(CPager _pager, int _nPageItemCount)
static java.lang.String | PageHelper.PagerHtmlGenerator(CPager _pager, int _nPageItemCount, int _nPageMaxCount)
static java.lang.String | PageHelper.PagerHtmlGenerator(CPager _pager, int _nPageItemCount, int _nPageMaxCount, java.lang.String _sItemName, java.lang.String _sUnitName)
static java.lang.String | PageHelper.PagerHtmlGenerator(CPager _pager, int _nPageItemCount, int _nPageMaxCount, java.lang.String _sItemName, java.lang.String _sUnitName, java.lang.String _sBackColor, java.lang.String _sFontColor)
static java.lang.String | PageHelper.PagerHtmlGenerator(CPager _pager, int _nPageItemCount, java.lang.String _sItemName, java.lang.String _sUnitName)
static java.lang.String | PageHelper.PagerHtmlGenerator(CPager _pager, int _nPageItemCount, java.lang.String _sItemName, java.lang.String _sUnitName, java.lang.String _sBackColor, java.lang.String _sFontColor)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.DebugTimer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.DebugTimer
的使用

没有 com.trs.infra.util.DebugTimer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.DiscoveryFactoryBuddy 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.DiscoveryFactoryBuddy
的使用

没有 com.trs.infra.util.DiscoveryFactoryBuddy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ExceptionMessages 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ExceptionMessages
的使用

没有 com.trs.infra.util.ExceptionMessages 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ExceptionNumber 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ExceptionNumber
的使用

没有 com.trs.infra.util.ExceptionNumber 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.FileNameExtFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.FileNameExtFilter
的使用

没有 com.trs.infra.util.FileNameExtFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.HttpClientBuddy 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.HttpClientBuddy
的使用

没有 com.trs.infra.util.HttpClientBuddy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.HttpGet 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.HttpGet
的使用

没有 com.trs.infra.util.HttpGet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.JavaScriptVARProcessor 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.JavaScriptVARProcessor
的使用

没有 com.trs.infra.util.JavaScriptVARProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ListUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ListUtil
的使用

没有 com.trs.infra.util.ListUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.Loader 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.Loader
的使用

没有 com.trs.infra.util.Loader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.MD5 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.MD5
的使用

没有 com.trs.infra.util.MD5 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.MySSLSocketFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.MySSLSocketFactory
的使用

没有 com.trs.infra.util.MySSLSocketFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager
的使用

没有 com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.NamesRegister 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.NamesRegister
的使用

没有 com.trs.infra.util.NamesRegister 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.OptionConverter 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.OptionConverter
的使用

没有 com.trs.infra.util.OptionConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.OrgnizeContextImports 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.OrgnizeContextImports
的使用

没有 com.trs.infra.util.OrgnizeContextImports 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.PinyinHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.PinyinHelper
的使用

没有 com.trs.infra.util.PinyinHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.PropertiesUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.PropertiesUtil
的使用

没有 com.trs.infra.util.PropertiesUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.PropertiesVARProcessor 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.PropertiesVARProcessor
的使用

没有 com.trs.infra.util.PropertiesVARProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.RemoteAddrUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.RemoteAddrUtil
的使用

没有 com.trs.infra.util.RemoteAddrUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.Report 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.Report
的使用

使用 Report 的软件包
com.trs.components.common.publish.domain.template
com.trs.components.wcm.content.domain
com.trs.infra.util
com.trs.service
com.trs.service.impl

com.trs.components.common.publish.domain.template 中 Report 的使用

返回 Report 的 com.trs.components.common.publish.domain.template 中的方法
Report | TemplateParseMgr.checkTemplate(Template _template) 检查模板语法正确性
Report | TemplateParseMgr.checkTemplate(Template _template, boolean bCanEdit)

参数类型为 Report 的 com.trs.components.common.publish.domain.template 中的方法
boolean | TemplateParseMgr.checkGrammar(TagDocument _tagDoc, Report _report) 检查模板置标树的语法
TagDocument | TemplateParseMgr.checkLexical(Template _template, Report _report) 对模板的正文进行文法检查，如果没有文法错误，则返回模板置标树，如果存在文法错误， 则通过传入参数 _report 报告错误信息。

com.trs.components.wcm.content.domain 中 Report 的使用

返回 Report 的 com.trs.components.wcm.content.domain 中的方法
Report | DocumentMgr.mirrorTo(Document _fromDocument, Channel _toChannel) 将实体文档镜像转发到另一个频道 草稿箱中的文档无法转发 目标频道为空无法转发
Report | DocumentMgr.moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel) 将文档从一个频道移动到另一个频道 支持引用和镜像的移动 如果是草稿箱中的，则不支持移动；也不支持移动到草稿箱 如果目标频道下已经存在，则无法移动
Report | DocumentMgr.moveTo(Document _fromDocument, Channel _fromChannel, Channel _toChannel, java.lang.String _sIsPhoto)
Report | DocumentMgr.quoteTo(Document _fromDocument, Channel _toChannel) 将实体文档引用转发到另一个频道 草稿箱中的文档无法转发 目标频道为空无法转发
Report | DocumentMgr.quoteTo(Document _fromDocument, Channel _toChannel, java.lang.String _sIsPhoto)

com.trs.infra.util 中 Report 的使用

返回 Report 的 com.trs.infra.util 中的方法
Report | Reports.addFailedReport(java.lang.String _sMessage, java.lang.Throwable _cause) 添加操作失败报告 当操作失败时使用
Report | Reports.addWarnedReport(java.lang.String _sMessage, java.lang.Throwable _cause) 添加操作警告报告 当操作不会导致失败,但需要告知操作者时使用
Report | Reports.getFailedReporterAt(int _nIndex) 获取一个失败报告
Report | Reports.getSucessedReporterAt(int _nIndex) 获取一个成功的报告
Report | Reports.getWarnedReporterAt(int _nIndex) 获取一个警告报告

参数类型为 Report 的 com.trs.infra.util 中的方法
 void Reports.addReport(Report report)
增加一个Report

com.trs.service 中 Report 的使用

返回 Report 的 com.trs.service 中的方法
 Report ITemplateParseService.checkTemplate(Template _aTemplate)
解析模板语法

com.trs.service.impl 中 Report 的使用

返回 Report 的 com.trs.service.impl 中的方法
 Report TemplateParseService.checkTemplate(Template _aTemplate)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.Reports 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.Reports
的使用

使用 Reports 的软件包
com.trs.ajaxservice
com.trs.cms.process.xml
com.trs.components.ckm
com.trs.components.common.publish.domain.template
com.trs.components.common.publish.widget
com.trs.components.metadata.center.xml
com.trs.components.metadata.definition.xml
com.trs.components.metadata.service
com.trs.components.wcm.content.domain
com.trs.components.wcm.content.domain.intelligence
com.trs.components.wcm.stat
com.trs.infra.util
com.trs.presentation.util
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 Reports 的使用

返回 Reports 的 com.trs.ajaxservice 中的方法
Reports | ChnlDocServiceProvider.copy(MethodContext _methodContext) 拷贝文档
Reports | ViewDocumentServiceProvider.copy(MethodContext _methodContext) 拷贝文档
Reports | DocumentServiceProvider.copy(MethodContext _methodContext) 拷贝文档
Reports | DocumentServiceProvider.copyAll(MethodContext _methodContext) 复制全部文档到
Reports | ProcessService.fromXML(MethodContext _methodContext) 使用XML的方式保存工作流
Reports | ProcessService.importFlows(MethodContext _methodContext)
Reports | ChnlDocServiceProvider.mirror(MethodContext _methodContext) 镜像文档
Reports | ViewDocumentServiceProvider.mirror(MethodContext _methodContext) 镜像文档
Reports | ChnlDocServiceProvider.move(MethodContext _methodContext) 移动文档
Reports | ViewDocumentServiceProvider.move(MethodContext _methodContext) 移动文档
Reports | DocumentServiceProvider.move(MethodContext _methodContext) 移动文档
Reports | ViewDocumentServiceProvider.moveAll(MethodContext _methodContext) 移动全部文档
Reports | ViewDocumentServiceProvider.publish(MethodContext _methodContext)
Reports | ChnlDocServiceProvider.quote(MethodContext _methodContext) 引用文档
Reports | ViewDocumentServiceProvider.quote(MethodContext _methodContext) 引用文档
Reports | DocumentServiceProvider.quote(MethodContext _methodContext) 引用文档到...
Reports | ViewDocumentServiceProvider.replaceContentLink(MethodContext _methContext)
Reports | DocumentServiceProvider.setQuote(MethodContext _methodContext) 为文档指定引用,用于编辑器中维护文档的所有引用关系
Reports | DocumentServiceProvider.transmit(MethodContext _methodContext) 转发文档

com.trs.cms.process.xml 中 Reports 的使用

返回 Reports 的 com.trs.cms.process.xml 中的方法
Reports | FlowImporter.importFromFile(java.lang.String _sXmlFile, java.lang.String _sXslFile)
Reports | FlowImporter.importFromXMLContent(java.lang.String _sXmlContent)
Reports | FlowImporter.importFromXMLObj(XmlObject _sXmlObj)

com.trs.components.ckm 中 Reports 的使用

返回 Reports 的 com.trs.components.ckm 中的方法
Reports | TRSCKMServer.validateCKMServer()
Reports | ICKMServer.validateCKMServer() 校验系统配置的CKMServer是否有效
Reports | TRSCKMServer.validateCKMServer(java.lang.String _sServerIP, java.lang.String _sServerPort, java.lang.String _sUserName, java.lang.String _sPassword)
Reports | ICKMServer.validateCKMServer(java.lang.String _sServerIP, java.lang.String _sServerPort, java.lang.String _sUserName, java.lang.String _sPassword) 校验CKM Service是否有效

com.trs.components.common.publish.domain.template 中 Reports 的使用

返回 Reports 的 com.trs.components.common.publish.domain.template 中的方法
Reports | TemplateMgr.copyVisualTempToChnls(Channels _toChannels, Template _srcTemplate) 在指定栏目下，类似创建可视化模板
Reports | TemplateImporter.importFromHTML(IPublishFolder _folder, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName) 从html文件导入模板
Reports | TemplateImporter.importFromZip(IPublishFolder _folder, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected) 从zip文件中导入模板
Reports | TemplateMgr.redistributeAppendixes(IPublishFolder _folder, boolean _zRecursive) 重新分发指定站点或者频道下的所有模板的附件，并且如果 _zRecursive 为 true ，则会进一步地重新分发子频道下的模板的附件。
Reports | TemplateMgr.redistributeAppendixes(Templates _templates) 重新分发模板的所有附件

com.trs.components.common.publish.widget 中 Reports 的使用

返回 Reports 的 com.trs.components.common.publish.widget 中的方法
Reports | VisualTemplateServiceProvider.copyVisualTemplate(MethodContext _context) 类似创建功能，在指定栏目下创建新的可视化模板
Reports | PageStyleImporter.importFromFile(java.lang.String _sFile) 从zip文件中导入PageStyle的信息。
Reports | ContentStyleImporter.importFromFile(java.lang.String _sFile, int _nImportMode) 从zip文件中导入PageStyle的信息。
Reports | ResourceStyleImporter.importFromFile(java.lang.String _sFile, int _nImportMode) 从zip文件中导入PageStyle的信息。
Reports | MasterMgr.importMasters(User _oCurrUser, java.lang.String _sImportMastersFileName) 导入母板
Reports | IMasterMgr.importMasters(User _oCurrUser, java.lang.String _sImportMastersFileName) 导入母版
Reports | IWidgetMgr.importWidgets(java.lang.String _sFile, int _nImportMode) 导入资源
Reports | WidgetMgr.importWidgets(java.lang.String _sFile, int _nImportMode)

参数类型为 Reports 的 com.trs.components.common.publish.widget 中的方法
ContentStyle | IContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
ContentStyle | ContentStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ContentStyle _sourceContentStyle, int _nCopyMode, Reports oCopyReports)
ResourceStyle | IResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
ResourceStyle | ResourceStyleMgr.copy(User _currUser, PageStyle _targetPageStyle, ResourceStyle _sourceResourceStyle, int _nCopyMode, Reports oCopyReports) 仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle

com.trs.components.metadata.center.xml 中 Reports 的使用

返回 Reports 的 com.trs.components.metadata.center.xml 中的方法
 Reports MetaViewDataImporter.importFromFile(int _nImportType, java.lang.String _sImportFile, java.lang.String _sXslFile)

com.trs.components.metadata.definition.xml 中 Reports 的使用

返回 Reports 的 com.trs.components.metadata.definition.xml 中的方法
 Reports ClassInfoImporter.getReports()

参数类型为 Reports 的 com.trs.components.metadata.definition.xml 中的方法
 void MetaDataDDLImporter.importFromXML(java.lang.String _sXMLFile, int _nImportType, Reports _oReports)

com.trs.components.metadata.service 中 Reports 的使用

返回 Reports 的 com.trs.components.metadata.service 中的方法
Reports | MetaDataCenterServiceProvider.copy(MethodContext _methodContext) 复制记录到...
Reports | GovInfoServiceProvider.copy(MethodContext _methodContext) 复制记录到...
Reports | MetaDataCenterServiceProviderForGB.copy(MethodContext _methodContext) 复制记录到...
Reports | MetaDataCenterServiceProviderForAgri.copy(MethodContext _methodContext) 复制记录到...
Reports | MetaDataDefServiceProvider.createViewRelation(MethodContext _methodContext) 重新产生所有视图或者指定视图的应用
Reports | MetaDataDefServiceProvider.deleteDBFieldInfo(MethodContext _methodContext) 删除元数据字段信息
Reports | MetaDataDefServiceProvider.deleteDBTableInfo(MethodContext _methodContext) 删除元数据结构信息
Reports | MetaDataDefServiceProvider.deleteView(MethodContext _methodContext) 删除多个视图信息
Reports | MetaDataCenterServiceProvider.deleteViewDatas(MethodContext _methodContext) 已过时。 改成Document的监听机制，转向调用ViewDocument.delete方法
Reports | GovInfoServiceProvider.deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
Reports | MetaDataCenterServiceProviderForGB.deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
Reports | MetaDataCenterServiceProviderForAgri.deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
Reports | MetaDataDefServiceProvider.deleteViewField(MethodContext _methodContext) 删除视图字段信息信息
Reports | ClassInfoServiceProvider.importClassInfos(MethodContext _methodContext) 从文件中导入分类法
Reports | ClassInfoServiceProviderForGB.importClassInfos(MethodContext _methodContext) 从文件中导入分类法
Reports | MetaDataCenterServiceProvider.importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
Reports | GovInfoServiceProvider.importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
Reports | MetaDataCenterServiceProviderForGB.importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
Reports | MetaDataCenterServiceProviderForAgri.importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
Reports | MetaDataDefServiceProvider.importViewsFromXML(MethodContext _oMethodContext) 从系统导出的XML创建视图（包括元数据表）

com.trs.components.wcm.content.domain 中 Reports 的使用

返回 Reports 的 com.trs.components.wcm.content.domain 中的方法
Reports | DocumentImporter.getImportReports()
Reports | DocumentImporter.importFromFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从文件中导入文档 支持从zip,xml,html,htm文件导入
Reports | DocumentImporter.importFromFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel, boolean bImportbyName)
Reports | ChannelImporter.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl)
Reports | DocumentImporter.importFromFileByName(java.lang.String _sImportFile, Channel _channel, java.lang.String _sXslFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel, boolean bImportbyName)
Reports | DocumentImporter.importFromTRSFile(java.lang.String _sImportFile, Channel _channel, java.lang.String _sDefineXmlForTRServer, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从TRS文件中导入文档 支持从zip,xml,html,htm文件导入
Reports | DocumentMgr.moveAllDocumentsToChannel(Channel _fromChannel, Channel _toChannel) 移动当前栏目下现有文档到指定的频道
Reports | DocumentMgr.moveDocumentsToChannel(ViewDocuments _sViewDocuments, Channel _fromChannel, Channel _toChannel)

com.trs.components.wcm.content.domain.intelligence 中 Reports 的使用

返回 Reports 的 com.trs.components.wcm.content.domain.intelligence 中的方法
Reports | IntelMgrImpl.createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName)
Reports | IIntellMgr.createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName) 从指定站点指定样式中创建新的站点
Reports | IntelMgrImpl.createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName, java.lang.String _sSiteDesc)
Reports | IIntellMgr.createNewSiteFrom(java.lang.String _sKind, java.lang.String _sStyle, java.lang.String _sNewSiteName, java.lang.String _sNewSiteDesc)

com.trs.components.wcm.stat 中 Reports 的使用

返回 Reports 的 com.trs.components.wcm.stat 中的方法
Reports | StatMgr.deleteStatHost(StatHost _delStatHost) 删除统计主体
Reports | StatMgr.deleteStatView(StatView _delStatview) 删除一个统计视图

com.trs.infra.util 中 Reports 的使用

参数类型为 Reports 的 com.trs.infra.util 中的方法
void | Reports.add(Reports _reports)
void | Reports.merge(Reports _reports)

com.trs.presentation.util 中 Reports 的使用

返回 Reports 的 com.trs.presentation.util 中的方法
 Reports RequestHelper.getReports()

参数类型为 Reports 的 com.trs.presentation.util 中的方法
 void RequestHelper.handleOpReports(java.lang.String _sResponseUrl, Reports _currReports)

com.trs.service 中 Reports 的使用

返回 Reports 的 com.trs.service 中的方法
Reports | IDocumentService.copyTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将一组文档从指定的频道复制到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | IDocumentService.copyTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 复制文档集合 将一堆文档复制到某个频道 一堆文档可以是一个检索的结果
Reports | IChannelService.createFrom(Channel _srcChannel, BaseChannel _parent) 频道的类似创建的实现 从指定的频道获取频道的相关属性,创建一个新的频道 新频道与源频道有基本相同的属性.
Reports | IChannelService.createFrom(int _nChannelId, BaseChannel _parent) 频道的类似创建的实现
Reports | IChannelService.createFrom(int _nSiteId, boolean _bWithRelated) 站点的类似创建的实现
Reports | IChannelService.createFrom(WebSite _srcSite, boolean _bWithRelated) 站点的类似创建的实现 从指定的站点获取站点的相关属性,创建一个新的站点.
Reports | IStatService.deleteStatHosts(java.lang.String _sDelStatHostIds) 删除统计类型
Reports | IStatService.deleteStatView(int _nStatViewId) 删除一个统计视图
Reports | IStatService.deleteStatView(StatView _delStatView) 删除一个统计视图
Reports | IStatService.deleteStatViews(java.lang.String _sStatViewIds) 删除一个统计视图
Reports | IDocumentService.importDocuments(java.lang.String _sImportFile, int _nDstChnlId, java.lang.String _sXSLFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从文件中导入文档 支持从zip,xml,html,htm文件导入
Reports | IWCMProcessService.importFlows(java.lang.String _sImportFile) 从XML文件中导入工作流配置.
Reports | IWCMProcessService.importFlows(java.lang.String _sImportFile, java.lang.String _sXslFile) 从XML文件中导入工作流配置.
Reports | IChannelService.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl) 从zip/xml文件中导入站点/频道
Reports | ITemplateService.importFromHTML(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName) 从html文件导入模板
Reports | ITemplateService.importFromZip(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected) 从zip文件中导入模板
Reports | IDocumentService.importTRSDocuments(java.lang.String _sImportFile, int _nDestChannelId, java.lang.String _sDefineXmlFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从TRS文件中导入文档 支持从zip,xml,html,htm文件导入
Reports | IDocumentService.mirrorTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将一组文档镜像转发到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | IDocumentService.mirrorTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 镜像转发频道文档集合 将一堆文档镜像转发到某个频道 一堆文档可以是一个检索的结果
Reports | IBookMarkService.moveBookMarks(java.lang.String _sMarkIds, int _nMarkKindId) 移动指定的书签集合到目标书签夹下.
Reports | IDocumentService.moveTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将文档从指定的频道移动到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | IDocumentService.moveTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 移动文档集合 将一堆文档移动到某个频道 一堆文档可以是一个检索的结果
Reports | IDocumentService.quoteTo(Document _currDocument, java.lang.String _sToChannelIds) 维护单篇文档的引用转发关系 将单篇文档引用转发到目标频道列表中 一般用于在文档采编页面中，设置一篇文档的引用转发 这里的维护中包括删除所有无用的引用转发关系
Reports | IDocumentService.quoteTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String sToChannelIds) 将一组文档转发（引用转发）到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | IDocumentService.quoteTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 引用转发频道文档集合 将一堆频道文档移动到某个频道 一堆文档可以是一个检索的结果
Reports | ITemplateService.redistributeAppendixes(CMSObj _chnlOrSite, boolean _zRecursive) 重新分发指定站点或者频道下的所有模板的附件，并且如果_zRecursive 为true ，则会进一步地重新分发子频道下的模板的附件。
Reports | IDocumentService.restore(java.lang.String _sDelDocIds, int _nChannelId) 批量恢复回收站中的文档
Reports | IWCMProcessService.saveFlow(java.lang.String _sFlowXML)

com.trs.service.impl 中 Reports 的使用

返回 Reports 的 com.trs.service.impl 中的方法
Reports | DocumentService.copyTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)
Reports | DocumentService.copyTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)
Reports | ChannelService.createFrom(Channel _srcChannel, BaseChannel _parent)
Reports | ChannelService.createFrom(int _nChannelId, BaseChannel _parent)
Reports | ChannelService.createFrom(int _nSiteId, boolean _bWithRelated)
Reports | ChannelService.createFrom(WebSite _srcSite, boolean _bWithRelated)
Reports | StatService.deleteStatHosts(java.lang.String _sDelStatHostIds)
Reports | StatService.deleteStatView(int _nStatViewId)
Reports | StatService.deleteStatView(StatView _delStatView)
Reports | StatService.deleteStatViews(java.lang.String _sStatViewIds)
Reports | DocumentService.importDocuments(java.lang.String _sImportFile, int _nDstChnlId, java.lang.String _sXSLFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel)
Reports | WCMProcessServiceImpl.importFlows(java.lang.String _sImportFile)
Reports | WCMProcessServiceImpl.importFlows(java.lang.String _sImportFile, java.lang.String _sXslFile)
Reports | ChannelService.importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl) 站点、频道导出、类似创建相关的方法
Reports | TemplateService.importFromHTML(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName)
Reports | TemplateService.importFromZip(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected)
Reports | DocumentService.importTRSDocuments(java.lang.String _sImportFile, int _nDestChannelId, java.lang.String _sDefineXmlFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel)
Reports | DocumentService.mirrorTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)
Reports | DocumentService.mirrorTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)
Reports | BookMarkService.moveBookMarks(java.lang.String _sMarkIds, int _nMarkKindId)
Reports | DocumentService.moveTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)
Reports | DocumentService.moveTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)
Reports | DocumentService.quoteTo(Document _currDocument, java.lang.String _sToChannelIds)
Reports | DocumentService.quoteTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds)
Reports | DocumentService.quoteTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds)
Reports | TemplateService.redistributeAppendixes(CMSObj _chnlOrSite, boolean _zRecursive)
Reports | DocumentService.restore(java.lang.String _sDelDocIds, int _nChannelId)
Reports | WCMProcessServiceImpl.saveFlow(java.lang.String _sFlowXML)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ResponseBuddy 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ResponseBuddy
的使用

使用 ResponseBuddy 的软件包
com.trs.infra.util

com.trs.infra.util 中 ResponseBuddy 的使用

返回 ResponseBuddy 的 com.trs.infra.util 中的方法
static ResponseBuddy | CMy3WLib.doGet(java.lang.String sURL, java.util.Map mContent) 向指定的sURL发送一个get请求
ResponseBuddy | HttpClientBuddy.doGet(java.lang.String _sPostUri, java.util.Map mContent)
static ResponseBuddy | CMy3WLib.doGet(java.lang.String sURL, java.lang.String sContent) 向指定的sURL发送一个get请求
ResponseBuddy | HttpClientBuddy.doGet(java.lang.String _sPostUri, java.lang.String _sQueryString) 以GET方式发送请求，获取返回对象
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, byte[] _btContent) 以POST方式发送请求，获取返回对象
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, byte[] _btContent, boolean _bChunked) 以POST方式发送请求，获取返回对象
static ResponseBuddy | CMy3WLib.doPost(java.lang.String sURL, java.util.Map mContent) 向指定的sURL发送一个post请求
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, java.util.Map mContent, boolean _bChunked)
static ResponseBuddy | CMy3WLib.doPost(java.lang.String sURL, java.util.Map mContent, java.lang.String sEncoding)
static ResponseBuddy | CMy3WLib.doPost(java.lang.String sURL, java.lang.String sContent)
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, java.lang.String sContent) 以POST方式发送请求，获取返回对象
ResponseBuddy | HttpClientBuddy.doPost(java.lang.String _sPostUri, java.lang.String sContent, boolean _bChunked) 以POST方式发送请求，获取返回对象
static ResponseBuddy | CMy3WLib.doPost(java.lang.String sURL, java.lang.String sContent, java.lang.String sEncoding)
ResponseBuddy | HttpClientBuddy.updateFile(java.lang.String _sPostUri, byte[] _fileContent)
ResponseBuddy | HttpClientBuddy.updateFile(java.lang.String _sPostUri, java.io.File _oUpdateFile) 上传文件，获取返回对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.TRSImportsOrgnize 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.TRSImportsOrgnize
的使用

没有 com.trs.infra.util.TRSImportsOrgnize 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.TRSJspAutoTool 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.TRSJspAutoTool
的使用

没有 com.trs.infra.util.TRSJspAutoTool 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.TRSLocaleAuto 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.TRSLocaleAuto
的使用

没有 com.trs.infra.util.TRSLocaleAuto 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.URLCoder 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.URLCoder
的使用

没有 com.trs.infra.util.URLCoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.WCMDiscoveryFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.WCMDiscoveryFactory
的使用

没有 com.trs.infra.util.WCMDiscoveryFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.XmlCharCheckedInputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.XmlCharCheckedInputStream
的使用

没有 com.trs.infra.util.XmlCharCheckedInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.XmlDocWithDom4j 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.XmlDocWithDom4j
的使用

没有 com.trs.infra.util.XmlDocWithDom4j 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AndinOraDB

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 AndinOraDB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.OracleDB
            继承者  com.trs.infra.util.database.AndinOraDB

public class AndinOraDB
extends OracleDB

Title: TRS 内容协作平台（TRS WCM）
Description:
Andin加密处理,Oracle数据库.
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

字段摘要
从类 com.trs.infra.util.database.OracleDB 继承的字段
BFILE, BLOB, CHAR, CLOB, DATE, DATETIME, FLOAT, INT, LONG, LONGRAW, NCLOB, NUMBER, NVARCHAR, RAW, ROWID, SMALLINT, VARCHAR2
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
AndinOraDB()
AndinOraDB(java.lang.String _sName, java.lang.String _sDriverClass)
构造函数
注：支持存储过程
方法摘要
从类 com.trs.infra.util.database.OracleDB 继承的方法
canDropField, canWriteTextDirectly, encodeStrToWrite, getAllDataTypes, getClob, getClob, getSupportedDataTypes, getType, initQuerySQL, setClob, setClob, setClob, setClob, setStringFieldValue, sqlAddField, sqlConcatStr, sqlConcatStr, sqlConcatStr, sqlDate, sqlDateField, sqlDateTime, sqlFilterForClob, sqlFilterOneDay, sqlGetNextId, sqlGetSysDate, sqlQueryTableInfo, sqlQueryTableInfos, sqlRenameField, sqlRenameTable
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setDriverClass, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropField, sqlDropTable, sqlEscapeString, sqlModifyField
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AndinOraDB

public AndinOraDB()

AndinOraDB

public AndinOraDB(java.lang.String _sName,
                  java.lang.String _sDriverClass)
构造函数
注：支持存储过程

参数：
_sName - 名称，可省略，默认为"Oracle"
_sDriverClass - JDBC Driver Class Name，可省略，默认为"oracle.jdbc.driver.OracleDriver"
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CAS400CLOB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 CAS400CLOB

java.lang.Object
    继承者  com.trs.infra.util.database.CAS400CLOB

public class CAS400CLOB
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CAS400CLOB()
默认构造函数
方法摘要
static java.lang.String | getClob(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
static java.lang.String | getClob(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 将Clob/Text型字段值写入数据库
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CAS400CLOB

public CAS400CLOB()
默认构造函数

方法详细信息

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       java.lang.String p_sFieldName)
                                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_sFieldName - 字段名称
返回：
@throws CMyException
抛出：
CMyException

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       int p_nFieldIndex)
                                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_nFieldIndex - 字段索引
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String p_sClobFieldName,
                              java.lang.String p_sValue)
                       throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sValue,
                              java.lang.String p_sUpdateSQL,
                              java.lang.String p_sFieldName)
                       throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sValue - 字段值
p_sUpdateSQL - 定位检索SQL语句，注意必须包含" for update "子句
p_sFieldName - CLOB字段名
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String[] p_asFieldsAndValues)
                       throws CMyException
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
@throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CDB2DBCLOB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 CDB2DBCLOB

java.lang.Object
    继承者  com.trs.infra.util.database.CDB2DBCLOB

public class CDB2DBCLOB
extends java.lang.Object

构造方法摘要
CDB2DBCLOB()
默认构造函数
方法摘要
static java.lang.String | getClob(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
static java.lang.String | getClob(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 将Clob/Text型字段值写入数据库
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CDB2DBCLOB

public CDB2DBCLOB()
默认构造函数

方法详细信息

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       java.lang.String p_sFieldName)
                                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_sFieldName - 字段名称
返回：
@throws CMyException
抛出：
CMyException

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       int p_nFieldIndex)
                                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_nFieldIndex - 字段索引
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String p_sClobFieldName,
                              java.lang.String p_sValue)
                       throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sValue,
                              java.lang.String p_sUpdateSQL,
                              java.lang.String p_sFieldName)
                       throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sValue - 字段值
p_sUpdateSQL - 定位检索SQL语句，注意必须包含" for update "子句
p_sFieldName - CLOB字段名
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String[] p_asFieldsAndValues)
                       throws CMyException
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
@throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CDB2DBCLOB2

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 CDB2DBCLOB2

java.lang.Object
    继承者  com.trs.infra.util.database.CDB2DBCLOB2

public class CDB2DBCLOB2
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CDB2DBCLOB2()
默认构造函数
方法摘要
static java.lang.String | getClob(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
static java.lang.String | getClob(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 将Clob/Text型字段值写入数据库
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CDB2DBCLOB2

public CDB2DBCLOB2()
默认构造函数

方法详细信息

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       java.lang.String p_sFieldName)
                                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_sFieldName - 字段名称
返回：
@throws CMyException
抛出：
CMyException

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       int p_nFieldIndex)
                                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_nFieldIndex - 字段索引
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String p_sClobFieldName,
                              java.lang.String p_sValue)
                       throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sValue,
                              java.lang.String p_sUpdateSQL,
                              java.lang.String p_sFieldName)
                       throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sValue - 字段值
p_sUpdateSQL - 定位检索SQL语句，注意必须包含" for update "子句
p_sFieldName - CLOB字段名
返回：
@throws CMyException
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String[] p_asFieldsAndValues)
                       throws CMyException
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
@throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CDBKeyWords

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 CDBKeyWords

java.lang.Object
    继承者  com.trs.infra.util.database.CDBKeyWords

public class CDBKeyWords
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
从配置文件中读取数据库关键字，提供相关的有效性检验等操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String DB_KEYWORDS_RESOURCE
构造方法摘要
CDBKeyWords()
方法摘要
static boolean | isDBKeyWords(java.lang.String _sWord)
static void | reloadProperties()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DB_KEYWORDS_RESOURCE

public static final java.lang.String DB_KEYWORDS_RESOURCE
另请参见：
常量字段值
构造方法详细信息

CDBKeyWords

public CDBKeyWords()
方法详细信息

reloadProperties

public static final void reloadProperties()
                                   throws WCMException
抛出：
WCMException

isDBKeyWords

public static final boolean isDBKeyWords(java.lang.String _sWord)
                                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CDBText

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 CDBText

java.lang.Object
    继承者  com.trs.infra.util.database.CDBText

public class CDBText
extends java.lang.Object

字段摘要
static boolean JDBC_IS2
构造方法摘要
CDBText(DBType _dBType)
CDBText(DBType _dBType, java.lang.String _sText)
CDBText(int _nDBType)
构造函数
CDBText(int _nDBType, java.lang.String _sText)
构造函数
方法摘要
boolean | equals(java.lang.Object _another)
DBType | getDBType() 获取数据库类型对象
int | getLength() 取文本长度
java.lang.String | getText() 获取文本内容
boolean | isLoaded() 判断是否装载了数据
boolean | isNull() 判断文本内容是否为空
void | readFromRs(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
void | readFromRs(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
void | setDBType(DBType type)
void | setText(java.lang.String p_sText) 设置文本内容
java.lang.String | toString() 字符串输出
boolean | updateToDB(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sTextFieldName) 将Clob/Text型字段值写入数据库
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

JDBC_IS2

public static final boolean JDBC_IS2
另请参见：
常量字段值
构造方法详细信息

CDBText

public CDBText(int _nDBType)
构造函数

参数：
_nDBType - 数据库类型（例如DBTypes.ORACLE等）

CDBText

public CDBText(int _nDBType,
               java.lang.String _sText)
构造函数

参数：
_nDBType - 数据库类型（例如DBTypes.ORACLE等）
_sText - 大文本数据

CDBText

public CDBText(DBType _dBType,
               java.lang.String _sText)

CDBText

public CDBText(DBType _dBType)
方法详细信息

getDBType

public DBType getDBType()
获取数据库类型对象

返回：
数据库类型对象

isLoaded

public boolean isLoaded()
判断是否装载了数据

返回：

getText

public java.lang.String getText()
获取文本内容

返回：

setText

public void setText(java.lang.String p_sText)
设置文本内容

参数：
p_sText -

isNull

public boolean isNull()
判断文本内容是否为空

返回：

getLength

public int getLength()
取文本长度

返回：

toString

public java.lang.String toString()
字符串输出

覆盖：
类 java.lang.Object 中的 toString
返回：

readFromRs

public void readFromRs(java.sql.ResultSet p_rsData,
                       java.lang.String p_sFieldName)
                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_sFieldName - 字段名称
抛出：
CMyException

readFromRs

public void readFromRs(java.sql.ResultSet p_rsData,
                       int p_nFieldIndex)
                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_nFieldIndex - 字段索引
抛出：
CMyException

updateToDB

public boolean updateToDB(java.sql.Connection p_oConn,
                          java.lang.String p_sTableName,
                          java.lang.String p_sWhere,
                          java.lang.String p_sIdFieldName,
                          java.lang.String p_sTextFieldName)
                   throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接对象
p_sTableName - 数据表名
p_sWhere - where语句
p_sIdFieldName - ID字段名称
p_sTextFieldName - 大字段名称
返回：
@throws CMyException
抛出：
CMyException

setDBType

public void setDBType(DBType type)
参数：
type -

equals

public boolean equals(java.lang.Object _another)
覆盖：
类 java.lang.Object 中的 equals
另请参见：
Object.equals(java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClusterDBIdManager

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 ClusterDBIdManager

java.lang.Object
    继承者  com.trs.infra.util.database.ClusterDBIdManager

public class ClusterDBIdManager
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
集群对象ID获取(Compare and Write)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
ClusterDBIdManager()
方法摘要
static int getNextId(java.lang.String tablename, java.lang.String idFieldName)
获取指定表的下一个可用ID.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClusterDBIdManager

public ClusterDBIdManager()
方法详细信息

getNextId

public static int getNextId(java.lang.String tablename,
                            java.lang.String idFieldName)
                     throws WCMException
获取指定表的下一个可用ID.
这些表都中BaseObj的实例.

参数：
tablename - 指定的表名
idFieldName - 该表的ID列名
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMysqlText

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 CMysqlText

java.lang.Object
    继承者  com.trs.infra.util.database.CMysqlText

public class CMysqlText
extends java.lang.Object

作者：
huxuanlai

构造方法摘要
CMysqlText()
方法摘要
static java.lang.String | getClob(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Text型字段的值
static java.lang.String | getClob(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Text型字段的值
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 根据更新语句设置Clob/text字段内容
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 根据条件同时写入多个Clob/text内容
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 根据条件写入Clob/text内容
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMysqlText

public CMysqlText()
方法详细信息

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       java.lang.String p_sFieldName)
                                throws CMyException
从数据库中读取Text型字段的值

参数：
p_rsData - 数据集
p_sFieldName - 字段名称
返回：
抛出：
CMyException

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       int p_nFieldIndex)
                                throws CMyException
从数据库中读取Text型字段的值

参数：
p_rsData - 数据集
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sValue,
                              java.lang.String p_sUpdateSQL,
                              java.lang.String p_sFieldName)
                       throws CMyException
根据更新语句设置Clob/text字段内容

参数：
p_oConn - 数据库连接
p_sValue - 字段内容
p_sUpdateSQL - 更新字段使用的SQL语句
p_sFieldName - 字段名称
返回：
更新操作是否成功
抛出：
CMyException - 如果更新过程发生错误

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String p_sClobFieldName,
                              java.lang.String p_sValue)
                       throws CMyException
根据条件写入Clob/text内容

参数：
p_oConn - 数据库连接
p_sTableName - 执行数据写入的表名
p_sWhere - 执行写入的检索条件
p_sIdFieldName - 写入表的标示字段
p_sClobFieldName - Clob/text字段名
p_sValue - 字段内容
返回：
字段写入操作是否成功
抛出：
CMyException - 如果写入过程发生错误

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String[] p_asFieldsAndValues)
                       throws CMyException
根据条件同时写入多个Clob/text内容

参数：
p_oConn - 数据库连接
p_sTableName - 表名
p_sWhere - 检索条件
p_sIdFieldName - 表的标示字段
p_asFieldsAndValues - 表的字段名和字段内容集合
返回：
字段写入操作是否成功
抛出：
CMyException - 如果写入过程发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConnectionPool

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 ConnectionPool

java.lang.Object
    继承者  com.trs.infra.util.database.ConnectionPool

public class ConnectionPool
extends java.lang.Object

com.trs.util.dbcp.ConnectionCache的一个代理

构造方法摘要
ConnectionPool(DBConnectionConfig config)
构造方法
方法摘要
void | close() 关闭所有连接
void | free(java.sql.Connection conn) 释放连接
java.sql.Connection | getConnection() 取得有效的数据库连接
com.trs.util.dbcp.ConnectionCache | getConnectionCache() 返回实际的连接缓冲池对象，便于监控连接缓冲池的状态
java.lang.String | toString() 获取数据库连接的信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConnectionPool

public ConnectionPool(DBConnectionConfig config)
               throws java.sql.SQLException
构造方法

参数：
config - 数据库连接配置
抛出：
java.sql.SQLException - 如果发生错误
方法详细信息

close

public void close()
关闭所有连接

free

public void free(java.sql.Connection conn)
释放连接

参数：
conn - 数据库连接对象(Connection)

getConnection

public java.sql.Connection getConnection()
                                  throws java.sql.SQLException
取得有效的数据库连接

返回：
数据库连接对象
抛出：
java.sql.SQLException

toString

public java.lang.String toString()
获取数据库连接的信息

覆盖：
类 java.lang.Object 中的 toString
返回：
数据库连接的信息（String）

getConnectionCache

public com.trs.util.dbcp.ConnectionCache getConnectionCache()
返回实际的连接缓冲池对象，便于监控连接缓冲池的状态

返回：
实际的连接缓冲池对象
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


COracleCLOB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 COracleCLOB

java.lang.Object
    继承者  com.trs.infra.util.database.COracleCLOB

public class COracleCLOB
extends java.lang.Object

构造方法摘要
COracleCLOB()
方法摘要
static java.lang.String | getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
static java.lang.String | getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 将Clob/Text型字段值写入数据库
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

COracleCLOB

public COracleCLOB()
方法详细信息

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       boolean p_bJdbcIs2,
                                       java.lang.String p_sFieldName)
                                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       boolean p_bJdbcIs2,
                                       int p_nFieldIndex)
                                throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String p_sClobFieldName,
                              java.lang.String p_sValue)
                       throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sValue,
                              java.lang.String p_sUpdateSQL,
                              java.lang.String p_sFieldName)
                       throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sValue - 字段值
p_sUpdateSQL - 定位检索SQL语句，注意必须包含" for update "子句
p_sFieldName - CLOB字段名
返回：
抛出：
CMyException

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String[] p_asFieldsAndValues)
                       throws CMyException
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CSQLText

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 CSQLText

java.lang.Object
    继承者  com.trs.infra.util.database.CSQLText

public class CSQLText
extends java.lang.Object

构造方法摘要
CSQLText()
默认构造函数
方法摘要
static java.lang.String | getText(java.sql.ResultSet p_rsData, int p_nFieldIndex) 从数据库中读取Text型字段的值
static java.lang.String | getText(java.sql.ResultSet p_rsData, java.lang.String p_sFieldName) 从数据库中读取Text型字段的值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CSQLText

public CSQLText()
默认构造函数

方法详细信息

getText

public static java.lang.String getText(java.sql.ResultSet p_rsData,
                                       java.lang.String p_sFieldName)
                                throws CMyException
从数据库中读取Text型字段的值

参数：
p_rsData - 数据集
p_sFieldName - 字段名称
返回：
抛出：
CMyException

getText

public static java.lang.String getText(java.sql.ResultSet p_rsData,
                                       int p_nFieldIndex)
                                throws CMyException
从数据库中读取Text型字段的值

参数：
p_rsData - 数据集
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DamengDB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DamengDB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.SQLServerDB
            继承者  com.trs.infra.util.database.DamengDB

public class DamengDB
extends SQLServerDB

Title: TRS 内容协作平台（TRS WCM）
Description:
达梦
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

字段摘要
static DataType | NCHAR
static DataType | NTEXT
static DataType | NVARCHAR
从类 com.trs.infra.util.database.SQLServerDB 继承的字段
BIGINT, BINARY, BIT, CHAR, DATE, DATETIME, DECIMAL, FLOAT, IMAGE, INT, MONEY, NUMBER, NUMERIC, REAL, SMALLDATETIME, SMALLINT, SMALLMONEY, SQL_VARIRANT, TEXT, TIMESTAMP, TINYINT, UNIQUEIDENTIFIER, VARBINARY, VARCHAR, VARCHAR2, WRITE_STR_ENCODING
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
DamengDB()
DamengDB(java.lang.String _sName, java.lang.String _sDriverClass)
方法摘要
java.lang.String | sqlAddField(java.lang.String tableName, java.lang.String fieldName, java.lang.String fieldType, int maxLength, boolean _bNullable, java.lang.String defaultValue, int scale) 构造添加字段的SQL语句 特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
java.lang.String | sqlGetNextId()
java.lang.String | sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sDBTableName)
java.lang.String | sqlQueryTableInfos(java.lang.String _sOwnerUser)
从类 com.trs.infra.util.database.SQLServerDB 继承的方法
canDropField, canWriteTextDirectly, encodeStrToWrite, getAllDataTypes, getClob, getClob, getSupportedDataTypes, getType, initQuerySQL, setClob, setClob, sqlConcatStr, sqlConcatStr, sqlConcatStr, sqlDate, sqlDateField, sqlDateTime, sqlFilterForClob, sqlFilterOneDay, sqlGetSysDate, sqlRenameField, sqlRenameTable
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropField, sqlDropTable, sqlEscapeString, sqlModifyField
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NVARCHAR

public static final DataType NVARCHAR

NCHAR

public static final DataType NCHAR

NTEXT

public static final DataType NTEXT
构造方法详细信息

DamengDB

public DamengDB()

DamengDB

public DamengDB(java.lang.String _sName,
                java.lang.String _sDriverClass)
方法详细信息

sqlGetNextId

public java.lang.String sqlGetNextId()
覆盖：
类 SQLServerDB 中的 sqlGetNextId

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
覆盖：
类 SQLServerDB 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sDBTableName)
覆盖：
类 SQLServerDB 中的 sqlQueryTableInfo

sqlAddField

public java.lang.String sqlAddField(java.lang.String tableName,
                                    java.lang.String fieldName,
                                    java.lang.String fieldType,
                                    int maxLength,
                                    boolean _bNullable,
                                    java.lang.String defaultValue,
                                    int scale)
从类 SQLServerDB 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

覆盖：
类 SQLServerDB 中的 sqlAddField
参数：
tableName - 表名称
fieldName - 字段名称
fieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
maxLength - 最大长度
_bNullable - 是否允许为空
defaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DataType

java.lang.Object
    继承者  com.trs.infra.util.database.DataType

public class DataType
extends java.lang.Object

字段摘要
static int LENGTH_UNKOWN
未知长度的
构造方法摘要
DataType(java.lang.String _name, int _type)
构造函数
DataType(java.lang.String _name, int _type, int _maxLength)
构造函数
方法摘要
boolean | equals(java.lang.Object _obj) 对象比较判断
int | getMaxLength() 获取最大长度
java.lang.String | getName() 获取类型名称
int | getType() 获取类型，由java.sql.Types.INTEGER等定义
boolean | isCharData() 判定是否为字符类型
boolean | isLengthDefinedByUser() 判定长度是否由用户定义
java.lang.String | toString() 字符串输出
static java.lang.String | toTypeDescription(DataType _currDataType)
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

LENGTH_UNKOWN

public static final int LENGTH_UNKOWN
未知长度的

另请参见：
常量字段值
构造方法详细信息

DataType

public DataType(java.lang.String _name,
                int _type)
构造函数

参数：
_name - 类型名称
_type - 类型

DataType

public DataType(java.lang.String _name,
                int _type,
                int _maxLength)
构造函数

参数：
_name - 类型名称
_type - 类型，由java.sql.Types.INTEGER等定义
_maxLength - 最大长度
方法详细信息

getName

public java.lang.String getName()
获取类型名称

返回：

getType

public int getType()
获取类型，由java.sql.Types.INTEGER等定义

返回：

getMaxLength

public int getMaxLength()
获取最大长度

返回：

isCharData

public boolean isCharData()
判定是否为字符类型

返回：

isLengthDefinedByUser

public boolean isLengthDefinedByUser()
判定长度是否由用户定义

返回：

toString

public java.lang.String toString()
字符串输出

覆盖：
类 java.lang.Object 中的 toString
返回：

equals

public boolean equals(java.lang.Object _obj)
对象比较判断

覆盖：
类 java.lang.Object 中的 equals
参数：
_obj -
返回：

toTypeDescription

public static java.lang.String toTypeDescription(DataType _currDataType)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DB2AS400DB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DB2AS400DB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.DB2AS400DB

public class DB2AS400DB
extends DBType

字段摘要
static DataType | BIGINT 定义SQL Server中的字段类型：BIGINT
static DataType | BLOB 定义SQL Server中的字段类型：BLOB
static DataType | CHAR 定义SQL Server中的字段类型：CHAR
static DataType | CLOB 定义SQL Server中的字段类型：CLOB
static DataType | DATE 定义SQL Server中的字段类型：DATE
static DataType | DATETIME
static DataType | DBCLOB 定义SQL Server中的字段类型：DBCLOB
static DataType | DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | INT 定义SQL Server中的字段类型：INT
static DataType | NINT
static DataType | NUMERIC 定义ASS400中的字段类型：NUMERIC
static DataType | NVARCHAR
static DataType | REAL 定义SQL Server中的字段类型：REAL
static DataType | SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | SQL_VARIRANT 定义SQL Server中的字段类型：SQL_VARIRANT
static DataType | TIME 定义SQL Server中的字段类型：TIME
static DataType | TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | UNIQUEIDENTIFIER 定义SQL Server中的字段类型：UNIQUEIDENTIFIER
static DataType | VARCHAR 定义SQL Server中的字段类型：VARCHAR
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
DB2AS400DB()
DB2AS400DB(java.lang.String _sName, java.lang.String _sDriverClass, boolean _bSupportStoredProc)
构造函数
注：支持存储过程
方法摘要
 boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
 boolean canWriteTextDirectly()
判断是否可以直接写入大文本
 java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 int getType()
获取当前的类型
 java.lang.String getTypeName(int code, int length, int precision, int scale)
Get the name of the database type associated with the given Types typecode with the given storage specification parameters.
 java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
生成查询一页数据的sql语句
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _sNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlDate(java.lang.String _sDateTime)
 java.lang.String sqlDateField(java.lang.String _sDateField)
 java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlDropField(java.lang.String _sTableName, java.lang.String _sFieldNames)
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
 java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sDBTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, setStringFieldValue, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropTable, sqlEscapeString, sqlModifyField, sqlRenameField, sqlRenameTable
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SMALLINT

public static final DataType SMALLINT
定义SQL Server中的字段类型：SMALLINT

INT

public static final DataType INT
定义SQL Server中的字段类型：INT

BIGINT

public static final DataType BIGINT
定义SQL Server中的字段类型：BIGINT

NUMERIC

public static final DataType NUMERIC
定义ASS400中的字段类型：NUMERIC

DECIMAL

public static final DataType DECIMAL
定义SQL Server中的字段类型：DECIMAL

REAL

public static final DataType REAL
定义SQL Server中的字段类型：REAL

FLOAT

public static final DataType FLOAT
定义SQL Server中的字段类型：FLOAT

CHAR

public static final DataType CHAR
定义SQL Server中的字段类型：CHAR

VARCHAR

public static final DataType VARCHAR
定义SQL Server中的字段类型：VARCHAR

CLOB

public static final DataType CLOB
定义SQL Server中的字段类型：CLOB

DBCLOB

public static final DataType DBCLOB
定义SQL Server中的字段类型：DBCLOB

BLOB

public static final DataType BLOB
定义SQL Server中的字段类型：BLOB

DATE

public static final DataType DATE
定义SQL Server中的字段类型：DATE

TIME

public static final DataType TIME
定义SQL Server中的字段类型：TIME

TIMESTAMP

public static final DataType TIMESTAMP
定义SQL Server中的字段类型：TIMESTAMP

UNIQUEIDENTIFIER

public static final DataType UNIQUEIDENTIFIER
定义SQL Server中的字段类型：UNIQUEIDENTIFIER

SQL_VARIRANT

public static final DataType SQL_VARIRANT
定义SQL Server中的字段类型：SQL_VARIRANT

NVARCHAR

public static final DataType NVARCHAR

NINT

public static final DataType NINT

DATETIME

public static final DataType DATETIME
构造方法详细信息

DB2AS400DB

public DB2AS400DB()
另请参见：
DB2UDB( String _sName, String _sDriverClass ){

DB2AS400DB

public DB2AS400DB(java.lang.String _sName,
                  java.lang.String _sDriverClass,
                  boolean _bSupportStoredProc)
构造函数
注：支持存储过程

参数：
_sName - 名称，可省略，默认为"DB2UDB"
_sDriverClass - JDBC Driver Class Name，可省略，默认为"COM.ibm.db2.jdbc.app.DB2Driver"
方法详细信息

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                         java.lang.String _sValue)
从类 DBType 复制的描述
大字段检索函数

指定者：
类 DBType 中的 sqlFilterForClob
参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
从类 DBType 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

指定者：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    int _nFieldType,
                                    int _nLengthOrPrecision,
                                    boolean _sNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
                             throws WCMException
从类 DBType 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

覆盖：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_nFieldType - 字段类型（java.sql.Types.*）
_nLengthOrPrecision - 字符串长度或者数字精度
_sNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句
抛出：
WCMException

getTypeName

public java.lang.String getTypeName(int code,
                                    int length,
                                    int precision,
                                    int scale)
                             throws WCMException
从类 DBType 复制的描述
Get the name of the database type associated with the given Types typecode with the given storage specification parameters.

覆盖：
类 DBType 中的 getTypeName
参数：
code - The Types typecode
length - The datatype length
precision - The datatype precision
scale - The datatype scale
返回：
the database type name
抛出：
WCMException

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
从类 DBType 复制的描述
字符串连接函数

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

canWriteTextDirectly

public boolean canWriteTextDirectly()
判断是否可以直接写入大文本

指定者：
类 DBType 中的 canWriteTextDirectly
返回：
AS400可以直接写入，返回true

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

指定者：
类 DBType 中的 getAllDataTypes
返回：

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

指定者：
类 DBType 中的 getSupportedDataTypes
返回：

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以筛选指定日期

指定者：
类 DBType 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                    java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以表示日期时间值

指定者：
类 DBType 中的 sqlDateTime
参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String _sDateTime)
指定者：
类 DBType 中的 sqlDate

sqlDateField

public java.lang.String sqlDateField(java.lang.String _sDateField)
指定者：
类 DBType 中的 sqlDateField

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2,
                                     java.lang.String _strSQL3)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlGetSysDate

public java.lang.String sqlGetSysDate()
取系统时间的内部函数

指定者：
类 DBType 中的 sqlGetSysDate
返回：

sqlDropField

public java.lang.String sqlDropField(java.lang.String _sTableName,
                                     java.lang.String _sFieldNames)
                              throws java.lang.Exception
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2

覆盖：
类 DBType 中的 sqlDropField
参数：
_sTableName - 数据表名称
_sFieldNames - 字段名称（可以有多个，不同字段之间以","分割）
返回：
构造的SQL语句
抛出：
java.lang.Exception

encodeStrToWrite

public java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串

指定者：
类 DBType 中的 encodeStrToWrite
参数：
_strSrc - 指定的字符串
返回：

initQuerySQL

public java.lang.String initQuerySQL(java.lang.String _strSql,
                                     int _nStartIndex,
                                     int _nSize)
生成查询一页数据的sql语句

指定者：
类 DBType 中的 initQuerySQL
参数：
_strSql - 原查询语句
_nStartIndex - 开始记录位置
_nSize - 需要获取的记录数
返回：

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
指定者：
类 DBType 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sDBTableName)
指定者：
类 DBType 中的 sqlQueryTableInfo

sqlGetNextId

public java.lang.String sqlGetNextId()
指定者：
类 DBType 中的 sqlGetNextId

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

getType

public int getType()
从类 DBType 复制的描述
获取当前的类型

指定者：
类 DBType 中的 getType
返回：

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

指定者：
类 DBType 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DB2ReorgUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DB2ReorgUtil

java.lang.Object
    继承者  com.trs.infra.util.database.DB2ReorgUtil

public class DB2ReorgUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
执行db2 reorg table 命令的工具类.
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
DB2ReorgUtil()
方法摘要
static void reorgTable(java.lang.String tabname)
执行DB2 reorg table tabname命令.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DB2ReorgUtil

public DB2ReorgUtil()
方法详细信息

reorgTable

public static void reorgTable(java.lang.String tabname)
                       throws WCMException
执行DB2 reorg table tabname命令.

参数：
tabname - 要reorg的表名.
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DB2UDB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DB2UDB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.DB2UDB

public class DB2UDB
extends DBType

字段摘要
static DataType | BIGINT 定义SQL Server中的字段类型：BIGINT
static DataType | BLOB 定义SQL Server中的字段类型：BLOB
static DataType | CHAR 定义SQL Server中的字段类型：CHAR
static DataType | CLOB 定义SQL Server中的字段类型：CLOB
static DataType | DATE 定义SQL Server中的字段类型：DATE
static DataType | DBCLOB 定义SQL Server中的字段类型：DBCLOB
static DataType | DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | INT 定义SQL Server中的字段类型：INT
static DataType | REAL 定义SQL Server中的字段类型：REAL
static DataType | SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | SQL_VARIRANT 定义SQL Server中的字段类型：SQL_VARIRANT
static DataType | TIME 定义SQL Server中的字段类型：TIME
static DataType | TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | UNIQUEIDENTIFIER 定义SQL Server中的字段类型：UNIQUEIDENTIFIER
static DataType | VARCHAR 定义SQL Server中的字段类型：VARCHAR
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
DB2UDB()
DB2UDB(java.lang.String _sName, java.lang.String _sDriverClass, boolean _bSupportStoredProc)
构造函数
注：支持存储过程
方法摘要
 boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
 boolean canWriteTextDirectly()
判断是否可以直接写入大文本
 java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 int getType()
获取当前的类型
 java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
生成查询一页数据的sql语句
static void main(java.lang.String[] args)
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlDate(java.lang.String _sDateTime)
 java.lang.String sqlDateField(java.lang.String _sDateField)
 java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlDropField(java.lang.String _sTableName, java.lang.String _sFieldNames)
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
 java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropTable, sqlEscapeString, sqlModifyField, sqlRenameField, sqlRenameTable
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SMALLINT

public static final DataType SMALLINT
定义SQL Server中的字段类型：SMALLINT

INT

public static final DataType INT
定义SQL Server中的字段类型：INT

BIGINT

public static final DataType BIGINT
定义SQL Server中的字段类型：BIGINT

DECIMAL

public static final DataType DECIMAL
定义SQL Server中的字段类型：DECIMAL

REAL

public static final DataType REAL
定义SQL Server中的字段类型：REAL

FLOAT

public static final DataType FLOAT
定义SQL Server中的字段类型：FLOAT

CHAR

public static final DataType CHAR
定义SQL Server中的字段类型：CHAR

VARCHAR

public static final DataType VARCHAR
定义SQL Server中的字段类型：VARCHAR

CLOB

public static final DataType CLOB
定义SQL Server中的字段类型：CLOB

DBCLOB

public static final DataType DBCLOB
定义SQL Server中的字段类型：DBCLOB

BLOB

public static final DataType BLOB
定义SQL Server中的字段类型：BLOB

DATE

public static final DataType DATE
定义SQL Server中的字段类型：DATE

TIME

public static final DataType TIME
定义SQL Server中的字段类型：TIME

TIMESTAMP

public static final DataType TIMESTAMP
定义SQL Server中的字段类型：TIMESTAMP

UNIQUEIDENTIFIER

public static final DataType UNIQUEIDENTIFIER
定义SQL Server中的字段类型：UNIQUEIDENTIFIER

SQL_VARIRANT

public static final DataType SQL_VARIRANT
定义SQL Server中的字段类型：SQL_VARIRANT

构造方法详细信息

DB2UDB

public DB2UDB()
另请参见：
DB2UDB( String _sName, String _sDriverClass ){

DB2UDB

public DB2UDB(java.lang.String _sName,
              java.lang.String _sDriverClass,
              boolean _bSupportStoredProc)
构造函数
注：支持存储过程

参数：
_sName - 名称，可省略，默认为"DB2UDB"
_sDriverClass - JDBC Driver Class Name，可省略，默认为"COM.ibm.db2.jdbc.app.DB2Driver"
方法详细信息

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                         java.lang.String _sValue)
从类 DBType 复制的描述
大字段检索函数

指定者：
类 DBType 中的 sqlFilterForClob
参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
从类 DBType 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

指定者：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
从类 DBType 复制的描述
字符串连接函数

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

canWriteTextDirectly

public boolean canWriteTextDirectly()
判断是否可以直接写入大文本

指定者：
类 DBType 中的 canWriteTextDirectly
返回：
DB2中不能直接写入，返回false

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

指定者：
类 DBType 中的 getAllDataTypes
返回：

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

指定者：
类 DBType 中的 getSupportedDataTypes
返回：

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以筛选指定日期

指定者：
类 DBType 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                    java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以表示日期时间值

指定者：
类 DBType 中的 sqlDateTime
参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String _sDateTime)
指定者：
类 DBType 中的 sqlDate

sqlDateField

public java.lang.String sqlDateField(java.lang.String _sDateField)
指定者：
类 DBType 中的 sqlDateField

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2,
                                     java.lang.String _strSQL3)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlGetSysDate

public java.lang.String sqlGetSysDate()
取系统时间的内部函数

指定者：
类 DBType 中的 sqlGetSysDate
返回：

sqlDropField

public java.lang.String sqlDropField(java.lang.String _sTableName,
                                     java.lang.String _sFieldNames)
                              throws java.lang.Exception
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2

覆盖：
类 DBType 中的 sqlDropField
参数：
_sTableName - 数据表名称
_sFieldNames - 字段名称（可以有多个，不同字段之间以","分割）
返回：
构造的SQL语句
抛出：
java.lang.Exception

encodeStrToWrite

public java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串

指定者：
类 DBType 中的 encodeStrToWrite
参数：
_strSrc - 指定的字符串
返回：

main

public static void main(java.lang.String[] args)

initQuerySQL

public java.lang.String initQuerySQL(java.lang.String _strSql,
                                     int _nStartIndex,
                                     int _nSize)
生成查询一页数据的sql语句

指定者：
类 DBType 中的 initQuerySQL
参数：
_strSql - 原查询语句
_nStartIndex - 开始记录位置
_nSize - 需要获取的记录数
返回：

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
指定者：
类 DBType 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sTableName)
指定者：
类 DBType 中的 sqlQueryTableInfo

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

sqlGetNextId

public java.lang.String sqlGetNextId()
指定者：
类 DBType 中的 sqlGetNextId

getType

public int getType()
从类 DBType 复制的描述
获取当前的类型

指定者：
类 DBType 中的 getType
返回：

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

指定者：
类 DBType 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DB2UDB2

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DB2UDB2

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.DB2UDB2
直接已知子类：
DB2UDBV9
public class DB2UDB2
extends DBType

字段摘要
static DataType | BIGINT 定义SQL Server中的字段类型：BIGINT
static DataType | BLOB 定义SQL Server中的字段类型：BLOB
static DataType | CHAR 定义SQL Server中的字段类型：CHAR
static DataType | CLOB 定义SQL Server中的字段类型：CLOB
static DataType | DATE 定义SQL Server中的字段类型：DATE
static DataType | DATETIME
static DataType | DBCLOB 定义SQL Server中的字段类型：DBCLOB
static DataType | DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | INT 定义SQL Server中的字段类型：INT
static DataType | NINT
static DataType | NUMERIC
static DataType | NVARCHAR
static DataType | REAL 定义SQL Server中的字段类型：REAL
static DataType | SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | SQL_VARIRANT 定义SQL Server中的字段类型：SQL_VARIRANT
static DataType | TIME 定义SQL Server中的字段类型：TIME
static DataType | TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | UNIQUEIDENTIFIER 定义SQL Server中的字段类型：UNIQUEIDENTIFIER
static DataType | VARCHAR 定义SQL Server中的字段类型：VARCHAR
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
DB2UDB2()
DB2UDB2(java.lang.String _sName, java.lang.String _sDriverClass, boolean _bSupportStoredProc)
构造函数
注：支持存储过程
方法摘要
 boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
 boolean canWriteTextDirectly()
判断是否可以直接写入大文本
 java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 int getType()
获取当前的类型
 java.lang.String getTypeName(int code, int length, int precision, int scale)
Get the name of the database type associated with the given Types typecode with the given storage specification parameters.
 java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
生成查询一页数据的sql语句
static void main(java.lang.String[] args)
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _sNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlCreateTableWithPrimary(java.lang.String tableName, java.lang.String primaryFieldName)
构造一个带有PrimaryKey字段的表的SQL
 java.lang.String sqlDate(java.lang.String _sDateTime)
 java.lang.String sqlDateField(java.lang.String _sDateField)
 java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlDropField(java.lang.String tableName, java.lang.String fieldNames)
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
 java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlModifyField(java.lang.String tableName, java.lang.String fieldName, int fieldType, int lengthOrPrecision, boolean nullable, int scale)
修改指定表指定字段的属性
 java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
 java.lang.String sqlRenameField(java.lang.String tableName, java.lang.String oldFieldName, java.lang.String newFieldName)
重命名指定表的指定字段
 java.lang.String sqlRenameTable(java.lang.String oldTableName, java.lang.String newTableName)
重命名指定的表
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, setStringFieldValue, sqlAddField, sqlCreateTable, sqlDropTable, sqlEscapeString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SMALLINT

public static final DataType SMALLINT
定义SQL Server中的字段类型：SMALLINT

INT

public static final DataType INT
定义SQL Server中的字段类型：INT

BIGINT

public static final DataType BIGINT
定义SQL Server中的字段类型：BIGINT

DECIMAL

public static final DataType DECIMAL
定义SQL Server中的字段类型：DECIMAL

REAL

public static final DataType REAL
定义SQL Server中的字段类型：REAL

FLOAT

public static final DataType FLOAT
定义SQL Server中的字段类型：FLOAT

CHAR

public static final DataType CHAR
定义SQL Server中的字段类型：CHAR

VARCHAR

public static final DataType VARCHAR
定义SQL Server中的字段类型：VARCHAR

CLOB

public static final DataType CLOB
定义SQL Server中的字段类型：CLOB

DBCLOB

public static final DataType DBCLOB
定义SQL Server中的字段类型：DBCLOB

BLOB

public static final DataType BLOB
定义SQL Server中的字段类型：BLOB

DATE

public static final DataType DATE
定义SQL Server中的字段类型：DATE

TIME

public static final DataType TIME
定义SQL Server中的字段类型：TIME

TIMESTAMP

public static final DataType TIMESTAMP
定义SQL Server中的字段类型：TIMESTAMP

UNIQUEIDENTIFIER

public static final DataType UNIQUEIDENTIFIER
定义SQL Server中的字段类型：UNIQUEIDENTIFIER

SQL_VARIRANT

public static final DataType SQL_VARIRANT
定义SQL Server中的字段类型：SQL_VARIRANT

NVARCHAR

public static final DataType NVARCHAR

NINT

public static final DataType NINT

DATETIME

public static final DataType DATETIME

NUMERIC

public static final DataType NUMERIC
构造方法详细信息

DB2UDB2

public DB2UDB2()
另请参见：
DB2UDB( String _sName, String _sDriverClass ){

DB2UDB2

public DB2UDB2(java.lang.String _sName,
               java.lang.String _sDriverClass,
               boolean _bSupportStoredProc)
构造函数
注：支持存储过程

参数：
_sName - 名称，可省略，默认为"DB2UDB"
_sDriverClass - JDBC Driver Class Name，可省略，默认为"COM.ibm.db2.jdbc.app.DB2Driver"
方法详细信息

sqlCreateTableWithPrimary

public java.lang.String sqlCreateTableWithPrimary(java.lang.String tableName,
                                                  java.lang.String primaryFieldName)
                                           throws WCMException
从类 DBType 复制的描述
构造一个带有PrimaryKey字段的表的SQL

覆盖：
类 DBType 中的 sqlCreateTableWithPrimary
返回：
抛出：
WCMException

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                         java.lang.String _sValue)
从类 DBType 复制的描述
大字段检索函数

指定者：
类 DBType 中的 sqlFilterForClob
参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
从类 DBType 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

指定者：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    int _nFieldType,
                                    int _nLengthOrPrecision,
                                    boolean _sNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
                             throws WCMException
从类 DBType 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

覆盖：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_nFieldType - 字段类型（java.sql.Types.*）
_nLengthOrPrecision - 字符串长度或者数字精度
_sNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句
抛出：
WCMException

getTypeName

public java.lang.String getTypeName(int code,
                                    int length,
                                    int precision,
                                    int scale)
                             throws WCMException
从类 DBType 复制的描述
Get the name of the database type associated with the given Types typecode with the given storage specification parameters.

覆盖：
类 DBType 中的 getTypeName
参数：
code - The Types typecode
length - The datatype length
precision - The datatype precision
scale - The datatype scale
返回：
the database type name
抛出：
WCMException

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
从类 DBType 复制的描述
字符串连接函数

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

canWriteTextDirectly

public boolean canWriteTextDirectly()
判断是否可以直接写入大文本

指定者：
类 DBType 中的 canWriteTextDirectly
返回：
DB2中不能直接写入，返回false

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

指定者：
类 DBType 中的 getAllDataTypes
返回：

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

指定者：
类 DBType 中的 getSupportedDataTypes
返回：

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以筛选指定日期

指定者：
类 DBType 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                    java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以表示日期时间值

指定者：
类 DBType 中的 sqlDateTime
参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String _sDateTime)
指定者：
类 DBType 中的 sqlDate

sqlDateField

public java.lang.String sqlDateField(java.lang.String _sDateField)
指定者：
类 DBType 中的 sqlDateField

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2,
                                     java.lang.String _strSQL3)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlGetSysDate

public java.lang.String sqlGetSysDate()
取系统时间的内部函数

指定者：
类 DBType 中的 sqlGetSysDate
返回：

encodeStrToWrite

public java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串

指定者：
类 DBType 中的 encodeStrToWrite
参数：
_strSrc - 指定的字符串
返回：

main

public static void main(java.lang.String[] args)

initQuerySQL

public java.lang.String initQuerySQL(java.lang.String _strSql,
                                     int _nStartIndex,
                                     int _nSize)
生成查询一页数据的sql语句

指定者：
类 DBType 中的 initQuerySQL
参数：
_strSql - 原查询语句
_nStartIndex - 开始记录位置
_nSize - 需要获取的记录数
返回：

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
指定者：
类 DBType 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sTableName)
指定者：
类 DBType 中的 sqlQueryTableInfo

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

sqlGetNextId

public java.lang.String sqlGetNextId()
指定者：
类 DBType 中的 sqlGetNextId

getType

public int getType()
从类 DBType 复制的描述
获取当前的类型

指定者：
类 DBType 中的 getType
返回：

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

指定者：
类 DBType 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false

sqlDropField

public java.lang.String sqlDropField(java.lang.String tableName,
                                     java.lang.String fieldNames)
                              throws java.lang.Exception
从类 DBType 复制的描述
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2

覆盖：
类 DBType 中的 sqlDropField
参数：
tableName - 数据表名称
fieldNames - 字段名称（可以有多个，不同字段之间以","分割）
返回：
构造的SQL语句
抛出：
java.lang.Exception

sqlModifyField

public java.lang.String sqlModifyField(java.lang.String tableName,
                                       java.lang.String fieldName,
                                       int fieldType,
                                       int lengthOrPrecision,
                                       boolean nullable,
                                       int scale)
                                throws WCMException
从类 DBType 复制的描述
修改指定表指定字段的属性

覆盖：
类 DBType 中的 sqlModifyField
返回：
抛出：
WCMException

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String tableName,
                                       java.lang.String oldFieldName,
                                       java.lang.String newFieldName)
                                throws WCMException
从类 DBType 复制的描述
重命名指定表的指定字段

覆盖：
类 DBType 中的 sqlRenameField
返回：
抛出：
WCMException

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String oldTableName,
                                       java.lang.String newTableName)
                                throws WCMException
从类 DBType 复制的描述
重命名指定的表

覆盖：
类 DBType 中的 sqlRenameTable
参数：
oldTableName - 以前的表名
newTableName - 新的表名
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DB2UDBV9

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DB2UDBV9

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.DB2UDB2
            继承者  com.trs.infra.util.database.DB2UDBV9

public class DB2UDBV9
extends DB2UDB2

Title: TRS 内容协作平台（TRS WCM）
Description:
DB2 UDB V9+
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

字段摘要
从类 com.trs.infra.util.database.DB2UDB2 继承的字段
BIGINT, BLOB, CHAR, CLOB, DATE, DATETIME, DBCLOB, DECIMAL, FLOAT, INT, NINT, NUMERIC, NVARCHAR, REAL, SMALLINT, SQL_VARIRANT, TIME, TIMESTAMP, UNIQUEIDENTIFIER, VARCHAR
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
DB2UDBV9()
DB2UDBV9(java.lang.String _sName, java.lang.String _sDriverClass, boolean _bSupportStoredProc)
方法摘要
boolean | canDropField() 使用的数据数据库是否可以删除某个表中的列.
java.lang.String | sqlDropField(java.lang.String tableName, java.lang.String fieldNames) 构造删除字段的SQL语句 实例：ALTER TABLE _table DROP COLUMN _column1,_column2
java.lang.String | sqlModifyField(java.lang.String tableName, java.lang.String fieldName, int fieldType, int lengthOrPrecision, boolean nullable, int scale) 修改指定表指定字段的属性
java.lang.String | sqlRenameField(java.lang.String tableName, java.lang.String oldFieldName, java.lang.String newFieldName) 重命名指定表的指定字段
java.lang.String | sqlRenameTable(java.lang.String oldTableName, java.lang.String newTableName) 重命名指定的表
从类 com.trs.infra.util.database.DB2UDB2 继承的方法
canWriteTextDirectly, encodeStrToWrite, getAllDataTypes, getClob, getClob, getSupportedDataTypes, getType, getTypeName, initQuerySQL, main, setClob, setClob, sqlAddField, sqlAddField, sqlConcatStr, sqlConcatStr, sqlConcatStr, sqlCreateTableWithPrimary, sqlDate, sqlDateField, sqlDateTime, sqlFilterForClob, sqlFilterOneDay, sqlGetNextId, sqlGetSysDate, sqlQueryTableInfo, sqlQueryTableInfos
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, setStringFieldValue, sqlAddField, sqlCreateTable, sqlDropTable, sqlEscapeString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DB2UDBV9

public DB2UDBV9()

DB2UDBV9

public DB2UDBV9(java.lang.String _sName,
                java.lang.String _sDriverClass,
                boolean _bSupportStoredProc)
方法详细信息

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

覆盖：
类 DB2UDB2 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false

sqlDropField

public java.lang.String sqlDropField(java.lang.String tableName,
                                     java.lang.String fieldNames)
                              throws java.lang.Exception
从类 DBType 复制的描述
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2

覆盖：
类 DB2UDB2 中的 sqlDropField
参数：
tableName - 数据表名称
fieldNames - 字段名称（可以有多个，不同字段之间以","分割）
返回：
构造的SQL语句
抛出：
java.lang.Exception

sqlModifyField

public java.lang.String sqlModifyField(java.lang.String tableName,
                                       java.lang.String fieldName,
                                       int fieldType,
                                       int lengthOrPrecision,
                                       boolean nullable,
                                       int scale)
                                throws WCMException
从类 DBType 复制的描述
修改指定表指定字段的属性

覆盖：
类 DB2UDB2 中的 sqlModifyField
返回：
抛出：
WCMException

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String tableName,
                                       java.lang.String oldFieldName,
                                       java.lang.String newFieldName)
                                throws WCMException
从类 DBType 复制的描述
重命名指定表的指定字段

覆盖：
类 DB2UDB2 中的 sqlRenameField
返回：
抛出：
WCMException

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String oldTableName,
                                       java.lang.String newTableName)
                                throws WCMException
从类 DBType 复制的描述
重命名指定的表

覆盖：
类 DB2UDB2 中的 sqlRenameTable
参数：
oldTableName - 以前的表名
newTableName - 新的表名
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBIdManager

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DBIdManager

java.lang.Object
    继承者  com.trs.infra.util.database.DBIdManager

public class DBIdManager
extends java.lang.Object

嵌套类摘要
 class DBIdManager.IdSeq
Title: 网站内容管理（TRSWCM） Description: 单个对象的ID管理者 Copyright: Copyright (c) 2001 Company: www.trs.com.cn
字段摘要
static boolean ISDEBUG
构造方法摘要
DBIdManager()
方法摘要
int | getNextId(BaseObj _obj, java.sql.Connection _oConn, boolean _bAddIfNotExist)
int | getNextId(java.lang.String _sTableName, java.lang.String _sIdFieldName, java.sql.Connection _oConn, boolean _bAddIfNotExist)
DBIdManager | load(java.sql.Connection _oConn, java.lang.String _sGetNextIdSQL) 从数据库中装载ID信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ISDEBUG

public static boolean ISDEBUG
构造方法详细信息

DBIdManager

public DBIdManager()
方法详细信息

load

public DBIdManager load(java.sql.Connection _oConn,
                        java.lang.String _sGetNextIdSQL)
                 throws WCMException
从数据库中装载ID信息

参数：
_oConn - 数据库连接对象
返回：
装载成功返回（DBIdManager）
抛出：
WCMException

getNextId

public int getNextId(BaseObj _obj,
                     java.sql.Connection _oConn,
                     boolean _bAddIfNotExist)
              throws WCMException
参数：
_obj -
_oConn -
_bAddIfNotExist -
返回：
抛出：
WCMException

getNextId

public int getNextId(java.lang.String _sTableName,
                     java.lang.String _sIdFieldName,
                     java.sql.Connection _oConn,
                     boolean _bAddIfNotExist)
              throws WCMException
参数：
_obj -
sTableName -
_oConn -
_bAddIfNotExist -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBIdManager.IdSeq

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DBIdManager.IdSeq

java.lang.Object
    继承者  com.trs.infra.util.database.DBIdManager.IdSeq
包容类：
DBIdManager
public class DBIdManager.IdSeq
extends java.lang.Object

Title: 网站内容管理（TRSWCM）

Description:

单个对象的ID管理者

Copyright: Copyright (c) 2001

Company: www.trs.com.cn

版本：
1.0
作者：
EPROBITI

字段摘要
static int CACHESIZE_DEFAULT
构造方法摘要
DBIdManager.IdSeq()
DBIdManager.IdSeq(int _nextId)
DBIdManager.IdSeq(int _nextId, int _cacheSize)
构造函数
方法摘要
int | getCacheSize() 获得缓冲区大小
int | getMaxId() 属性：MaxId 最大ID值
int | getNextId() 取下一个有效的Id值 若已经达到最大值，则返回-1； 若为0，则表示需要从对应数据表中获取最大ID值
DBIdManager.IdSeq | setCacheSize(int _cacheSize) 设置缓冲池大小
DBIdManager.IdSeq | setNextId(int _nextId) 设置下一个有效的ID值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CACHESIZE_DEFAULT

public static final int CACHESIZE_DEFAULT
另请参见：
常量字段值
构造方法详细信息

DBIdManager.IdSeq

public DBIdManager.IdSeq()

DBIdManager.IdSeq

public DBIdManager.IdSeq(int _nextId)

DBIdManager.IdSeq

public DBIdManager.IdSeq(int _nextId,
                         int _cacheSize)
构造函数

参数：
_nextId - 下一个ID号
_cacheSize - 缓冲区大小
方法详细信息

getCacheSize

public int getCacheSize()
获得缓冲区大小

返回：
缓冲区大小（int）

setCacheSize

public DBIdManager.IdSeq setCacheSize(int _cacheSize)
设置缓冲池大小

参数：
_cacheSize - 缓冲池大小（int）
返回：

getMaxId

public int getMaxId()
属性：MaxId 最大ID值

返回：

getNextId

public int getNextId()
取下一个有效的Id值 若已经达到最大值，则返回-1； 若为0，则表示需要从对应数据表中获取最大ID值

返回：
下一个有效的Id值（int）

setNextId

public DBIdManager.IdSeq setNextId(int _nextId)
设置下一个有效的ID值

参数：
_nextId - 下一个有效的ID值
返回：
IdSeq对象
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBType

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DBType

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
直接已知子类：
DB2AS400DB, DB2UDB, DB2UDB2, MysqlDB, OracleDB, SQLServerDB, SybaseASE, SybaseASEWithJtds
public abstract class DBType
extends java.lang.Object

字段摘要
static int | DEFAULT_LENGTH
static int | DEFAULT_PRECISION
static int | DEFAULT_SCALE
static int | MAX_PAGE_SIZE
static DataType | OTHER 其他数据类型
构造方法摘要
DBType(java.lang.String _sName, java.lang.String _sDriverClass, boolean _bSupportStoredProc)
构造函数
方法摘要
abstract  boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
abstract  boolean canWriteTextDirectly()
判断是否可以直接写入大文本
abstract  java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
abstract  DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getCastTypeName(int code)
Get the name of the database type appropriate for casting operations (via the CAST() SQL function) for the given Types typecode.
abstract  java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
abstract  java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType getDataType(java.lang.String _name)
取指定名字的字段数据类型
 java.lang.String getDriverClass()
取数据库默认的驱动程序库
 java.lang.String getName()
取数据库类型名称
abstract  DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
abstract  int getType()
获取当前的类型
 java.lang.String getTypeName(int code)
Get the name of the database type associated with the given Types typecode.
 java.lang.String getTypeName(int code, int length, int precision, int scale)
Get the name of the database type associated with the given Types typecode with the given storage specification parameters.
abstract  java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
 boolean isSupportStoredProc()
判断是否支持存储过程
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sIdFieldName, int nObjId, java.lang.String[] p_asFieldsAndValues)
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String sIdFieldName, int nObjId, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
abstract  boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
abstract  boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 DBType setDriverClass(java.lang.String _sDriverClass)
设置数据库默认的驱动程序库
 void setStringFieldValue(java.sql.PreparedStatement _oPreStmt, int _nIndex, java.lang.String _sValue)
 void setStringFieldValue(java.sql.PreparedStatement _oPreStmt, int _nIndex, java.lang.String _sValue, boolean _bNullable)
设置字符类型的列值 Important Notes:添加此方法,主要是为了兼容Sybase的情况.
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable)
abstract  java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
abstract  java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
abstract  java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
abstract  java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlCreateTable()
产生Create Table的SQL
 java.lang.String sqlCreateTableWithPrimary(java.lang.String _sTableName, java.lang.String _sPrimaryFieldName)
构造一个带有PrimaryKey字段的表的SQL
abstract  java.lang.String sqlDate(java.lang.String _sDate)
abstract  java.lang.String sqlDateField(java.lang.String _sDateField)
abstract  java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlDropField(java.lang.String _sTableName, java.lang.String _sFieldNames)
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
 java.lang.String sqlDropTable(java.lang.String _sTableName)
删除指定的物理表
 java.lang.String sqlEscapeString(java.lang.String s)
字符串转义函数，把字符串转义为可以直接用于SQL语句中的形式。
abstract  java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
abstract  java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
abstract  java.lang.String sqlGetNextId()
abstract  java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlModifyField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _bNullable, int _nScale)
修改指定表指定字段的属性
abstract  java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sDBTableName)
abstract  java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
 java.lang.String sqlRenameField(java.lang.String _sTableName, java.lang.String _sOldFieldName, java.lang.String _sNewFieldName)
重命名指定表的指定字段
 java.lang.String sqlRenameTable(java.lang.String _sOldTableName, java.lang.String _sNewTableName)
重命名指定的表
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_LENGTH

public static final int DEFAULT_LENGTH
另请参见：
常量字段值

DEFAULT_PRECISION

public static final int DEFAULT_PRECISION
另请参见：
常量字段值

DEFAULT_SCALE

public static final int DEFAULT_SCALE
另请参见：
常量字段值

MAX_PAGE_SIZE

public static final int MAX_PAGE_SIZE
另请参见：
常量字段值

OTHER

public static final DataType OTHER
其他数据类型

构造方法详细信息

DBType

public DBType(java.lang.String _sName,
              java.lang.String _sDriverClass,
              boolean _bSupportStoredProc)
构造函数

参数：
_sName - 名称
_sDriverClass - JDBC Driver Class Name
_bSupportStoredProc - 是否支持存储过程
方法详细信息

getName

public java.lang.String getName()
取数据库类型名称

返回：

getDriverClass

public java.lang.String getDriverClass()
取数据库默认的驱动程序库

返回：

setDriverClass

public DBType setDriverClass(java.lang.String _sDriverClass)
设置数据库默认的驱动程序库

参数：
_sDriverClass -
返回：

isSupportStoredProc

public boolean isSupportStoredProc()
判断是否支持存储过程

返回：

encodeStrToWrite

public abstract java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串

参数：
_strSrc - 指定的字符串
返回：

canWriteTextDirectly

public abstract boolean canWriteTextDirectly()
判断是否可以直接写入大文本

返回：

getAllDataTypes

public abstract DataType[] getAllDataTypes()
取所有的字段数据类型

返回：

getSupportedDataTypes

public abstract DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

返回：

getDataType

public DataType getDataType(java.lang.String _name)
取指定名字的字段数据类型

参数：
_name - 指定的字段名称
返回：

getTypeName

public java.lang.String getTypeName(int code)
                             throws WCMException
Get the name of the database type associated with the given Types typecode.

参数：
code - The Types typecode
返回：
the database type name
抛出：
HibernateException - If no mapping was specified for that type.
WCMException

getTypeName

public java.lang.String getTypeName(int code,
                                    int length,
                                    int precision,
                                    int scale)
                             throws WCMException
Get the name of the database type associated with the given Types typecode with the given storage specification parameters.

参数：
code - The Types typecode
length - The datatype length
precision - The datatype precision
scale - The datatype scale
返回：
the database type name
抛出：
HibernateException - If no mapping was specified for that type.
WCMException

getCastTypeName

public java.lang.String getCastTypeName(int code)
                                 throws WCMException
Get the name of the database type appropriate for casting operations (via the CAST() SQL function) for the given Types typecode.

参数：
code - The Types typecode
返回：
The database type name
抛出：
WCMException

sqlCreateTable

public java.lang.String sqlCreateTable()
产生Create Table的SQL

返回：

sqlConcatStr

public abstract java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                              java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public abstract java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                              java.lang.String _strSQL2,
                                              java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public abstract java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数

参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

sqlEscapeString

public java.lang.String sqlEscapeString(java.lang.String s)
字符串转义函数，把字符串转义为可以直接用于SQL语句中的形式。 即在字符串的两端，加上单引号，并将字符串中的单引号转义，目前的实现是 把一个单引号替换为连续的两个单引号，如果某种数据库的单引号转义的语法 有所不同，需要覆盖这个函数。 如果输入的字符串为 null ，则返回“NULL”，同样的如果某种 数据库的空值语法不同，也需要覆盖这个函数。

参数：
s - 需要转义的字符串
返回：
转义结果，或者“NULL”

sqlFilterForClob

public abstract java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                                  java.lang.String _sValue)
大字段检索函数

参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable)
另请参见：
abstract String sqlAddField( String _sTableName, String _sFieldName, String _sFieldType, int _nMaxLength, boolean _bNullable, String _sDefaultValue )

sqlAddField

public abstract java.lang.String sqlAddField(java.lang.String _sTableName,
                                             java.lang.String _sFieldName,
                                             java.lang.String _sFieldType,
                                             int _nMaxLength,
                                             boolean _bNullable,
                                             java.lang.String _sDefaultValue,
                                             int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    int _nFieldType,
                                    int _nLengthOrPrecision,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
                             throws WCMException
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

参数：
_sTableName - 表名称
_sFieldName - 字段名称
_nFieldType - 字段类型（java.sql.Types.*）
_nLengthOrPrecision - 字符串长度或者数字精度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句
抛出：
WCMException

sqlModifyField

public java.lang.String sqlModifyField(java.lang.String _sTableName,
                                       java.lang.String _sFieldName,
                                       int _nFieldType,
                                       int _nLengthOrPrecision,
                                       boolean _bNullable,
                                       int _nScale)
                                throws WCMException
修改指定表指定字段的属性

参数：
_sTableName -
_sFieldName -
_nFieldType -
_nLengthOrPrecision -
_bNullable -
_nScale -
返回：
抛出：
WCMException

sqlCreateTableWithPrimary

public java.lang.String sqlCreateTableWithPrimary(java.lang.String _sTableName,
                                                  java.lang.String _sPrimaryFieldName)
                                           throws WCMException
构造一个带有PrimaryKey字段的表的SQL

参数：
_sTableName -
_sPrimaryFieldName -
返回：
抛出：
WCMException

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String _sOldTableName,
                                       java.lang.String _sNewTableName)
                                throws WCMException
重命名指定的表

参数：
_sOldTableName - 以前的表名
_sNewTableName - 新的表名
返回：
抛出：
WCMException

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String _sTableName,
                                       java.lang.String _sOldFieldName,
                                       java.lang.String _sNewFieldName)
                                throws WCMException
重命名指定表的指定字段

参数：
_sTableName -
_sOldFieldName -
_sNewFieldName -
返回：
抛出：
WCMException

sqlDropField

public java.lang.String sqlDropField(java.lang.String _sTableName,
                                     java.lang.String _sFieldNames)
                              throws java.lang.Exception
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2

参数：
_sTableName - 数据表名称
_sFieldNames - 字段名称（可以有多个，不同字段之间以","分割）
返回：
构造的SQL语句
抛出：
java.lang.Exception

sqlDropTable

public java.lang.String sqlDropTable(java.lang.String _sTableName)
                              throws java.lang.Exception
删除指定的物理表

参数：
_sTableName -
返回：
抛出：
java.lang.Exception

sqlGetSysDate

public abstract java.lang.String sqlGetSysDate()
取系统时间的内部函数

返回：

sqlFilterOneDay

public abstract java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                                 java.lang.String _sDateTime,
                                                 java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期

参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public abstract java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                             java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值

参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDate

public abstract java.lang.String sqlDate(java.lang.String _sDate)

sqlDateField

public abstract java.lang.String sqlDateField(java.lang.String _sDateField)

initQuerySQL

public abstract java.lang.String initQuerySQL(java.lang.String _strSql,
                                              int _nStartIndex,
                                              int _nSize)

sqlQueryTableInfos

public abstract java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)

sqlQueryTableInfo

public abstract java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                                   java.lang.String _sDBTableName)

sqlGetNextId

public abstract java.lang.String sqlGetNextId()

getClob

public abstract java.lang.String getClob(java.sql.ResultSet p_rsData,
                                         boolean p_bJdbcIs2,
                                         int p_nFieldIndex)
                                  throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public abstract java.lang.String getClob(java.sql.ResultSet p_rsData,
                                         boolean p_bJdbcIs2,
                                         java.lang.String p_sFieldName)
                                  throws CMyException
从数据库中读取Clob/Text型字段的值

参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public abstract boolean setClob(java.sql.Connection p_oConn,
                                java.lang.String p_sTableName,
                                java.lang.String p_sWhere,
                                java.lang.String p_sIdFieldName,
                                java.lang.String p_sClobFieldName,
                                java.lang.String p_sValue)
                         throws CMyException
将Clob/Text型字段值写入数据库

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public abstract boolean setClob(java.sql.Connection p_oConn,
                                java.lang.String p_sTableName,
                                java.lang.String p_sWhere,
                                java.lang.String p_sIdFieldName,
                                java.lang.String[] p_asFieldsAndValues)
                         throws CMyException
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

getType

public abstract int getType()
获取当前的类型

返回：

setStringFieldValue

public void setStringFieldValue(java.sql.PreparedStatement _oPreStmt,
                                int _nIndex,
                                java.lang.String _sValue)
                         throws java.lang.Exception
抛出：
java.lang.Exception

setStringFieldValue

public void setStringFieldValue(java.sql.PreparedStatement _oPreStmt,
                                int _nIndex,
                                java.lang.String _sValue,
                                boolean _bNullable)
                         throws java.lang.Exception
设置字符类型的列值

Important Notes:添加此方法,主要是为了兼容Sybase的情况. 在Sybase中,varchar列设置的空串会被当做一个空格处理.但又不能简单的setNull.(考虑列不能为空的情况)

参数：
_oPreStmt - 要设值的statment句柄
_nIndex - 要设值的列索引自
_sValue - 要设置的值
_bNullable - 要设置的列是否允许空
抛出：
java.lang.Exception

canDropField

public abstract boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.

返回：
如果可以则返回 true ,否则返回 false

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String sIdFieldName,
                       int nObjId,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sIdFieldName,
                       int nObjId,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 DBTypes

java.lang.Object
    继承者  com.trs.infra.util.database.DBTypes

public class DBTypes
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）

Description:

class DBTypes —— 支持的数据类型对象

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static DB2AS400DB | db2AS400 数据库类型对象：DB2AS400DB(DB2 Type4)
static int | DB2AS400 定义数据库类型：DB2 UDB AS400
static DB2UDB | db2Instance 数据库类型对象：DB2UDB
static DB2UDB2 | db2Instance2 数据库类型对象：DB2UDB2(DB2 Type4)
static int | DB2UDB 定义数据库类型：DB2 UDB
static int | DB2UDB2
static SybaseASE | dbSybaseASE 数据库类型对象：SybaseASE
static int | MYSQL 定义数据库类型：Mysql
static MysqlDB | MYSQLDB 数据库类型对象：Mysql
static int | ORACLE 定义数据库类型：ORACLE
static OracleDB | ORACLEDB 数据库类型对象：OracleDB
static int | SQLSERVER 定义数据库类型：SQL Server
static SQLServerDB | SQLSERVERDB 数据库类型对象：SQLServerDB
static int | SybaseASE 定义数据库类型：Sybase ASE
static int | UNKOWN 定义数据库类型：未知
构造方法摘要
DBTypes()
方法摘要
static DBType | getDBType(int _nDBType) 通过指定数据库类型获取数据库类型对象
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

UNKOWN

public static final int UNKOWN
定义数据库类型：未知

另请参见：
常量字段值

ORACLE

public static final int ORACLE
定义数据库类型：ORACLE

另请参见：
常量字段值

SQLSERVER

public static final int SQLSERVER
定义数据库类型：SQL Server

另请参见：
常量字段值

DB2UDB

public static final int DB2UDB
定义数据库类型：DB2 UDB

另请参见：
常量字段值

DB2UDB2

public static final int DB2UDB2
另请参见：
常量字段值

DB2AS400

public static final int DB2AS400
定义数据库类型：DB2 UDB AS400

另请参见：
常量字段值

SybaseASE

public static final int SybaseASE
定义数据库类型：Sybase ASE

另请参见：
常量字段值

MYSQL

public static final int MYSQL
定义数据库类型：Mysql

另请参见：
常量字段值

ORACLEDB

public static final OracleDB ORACLEDB
数据库类型对象：OracleDB

SQLSERVERDB

public static final SQLServerDB SQLSERVERDB
数据库类型对象：SQLServerDB

db2Instance

public static final DB2UDB db2Instance
数据库类型对象：DB2UDB

db2Instance2

public static final DB2UDB2 db2Instance2
数据库类型对象：DB2UDB2(DB2 Type4)

db2AS400

public static final DB2AS400DB db2AS400
数据库类型对象：DB2AS400DB(DB2 Type4)

dbSybaseASE

public static final SybaseASE dbSybaseASE
数据库类型对象：SybaseASE

MYSQLDB

public static final MysqlDB MYSQLDB
数据库类型对象：Mysql

构造方法详细信息

DBTypes

public DBTypes()
方法详细信息

getDBType

public static DBType getDBType(int _nDBType)
通过指定数据库类型获取数据库类型对象

参数：
_nDBType - 数据库类型
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 FieldInfo

java.lang.Object
    继承者  com.trs.infra.util.database.FieldInfo

public class FieldInfo
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）

Description:

class FieldInfo —— 数据库字段信息对象

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FieldInfo(DBType _dbType, java.lang.String _dataTypeName, int _dataLength, boolean _nullable, int _columnID, java.lang.String _dataDefault, int _dataScale)
构造函数
方法摘要
int | getColumnID() 获取字段的编号
java.lang.String | getDataDefault() 取默认值，注意：默认值用字符串型表示
int | getDataLength() 取数据长度 说明：字符串类型的数据有效
int | getDataScale()
DataType | getDataType() 取数据类型编号
java.lang.String | getDataTypeName() 取数据类型名称
boolean | isNullable() 判断是否允许空
java.lang.String | toString() 获取字段信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FieldInfo

public FieldInfo(DBType _dbType,
                 java.lang.String _dataTypeName,
                 int _dataLength,
                 boolean _nullable,
                 int _columnID,
                 java.lang.String _dataDefault,
                 int _dataScale)
构造函数

参数：
_dbType - 数据库类型对象
_dataTypeName - 字段类型名称
_dataLength - 字段的最大有效长度，例如255等
_nullable - 字段是否允许为空
_columnID - 字段的编号
_dataDefault - 字段的默认值，例如sysdate等
方法详细信息

getDataTypeName

public java.lang.String getDataTypeName()
取数据类型名称

返回：

getDataType

public DataType getDataType()
取数据类型编号

返回：

getDataLength

public int getDataLength()
取数据长度
说明：字符串类型的数据有效

返回：

isNullable

public boolean isNullable()
判断是否允许空

返回：

getColumnID

public int getColumnID()
获取字段的编号

返回：

getDataDefault

public java.lang.String getDataDefault()
取默认值，注意：默认值用字符串型表示

返回：

toString

public java.lang.String toString()
获取字段信息

覆盖：
类 java.lang.Object 中的 toString
返回：

getDataScale

public int getDataScale()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KingBaseDB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 KingBaseDB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.SQLServerDB
            继承者  com.trs.infra.util.database.KingBaseDB

public class KingBaseDB
extends SQLServerDB

Title: TRS 内容协作平台（TRS WCM）
Description:
人大金仓数据库
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

字段摘要
static DataType | DATE 定义SQL Server中的字段类型：DATE
static DataType | INTEGER 定义SQL Server中的字段类型：INT
static DataType | NVARCHAR 定义SQL Server中的字段类型：NVARCHAR
static DataType | TIME 定义SQL Server中的字段类型：TIME
static DataType | TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | TINYINT
static DataType | VARCHAR 定义SQL Server中的字段类型：VARCHAR
从类 com.trs.infra.util.database.SQLServerDB 继承的字段
BIGINT, BINARY, BIT, CHAR, DATETIME, DECIMAL, FLOAT, IMAGE, INT, MONEY, NCHAR, NTEXT, NUMBER, NUMERIC, REAL, SMALLDATETIME, SMALLINT, SMALLMONEY, SQL_VARIRANT, TEXT, UNIQUEIDENTIFIER, VARBINARY, VARCHAR2, WRITE_STR_ENCODING
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
KingBaseDB()
KingBaseDB(java.lang.String _sName, java.lang.String _sDriverClass)
方法摘要
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _sNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlAddField(java.lang.String tableName, java.lang.String fieldName, java.lang.String fieldType, int maxLength, boolean nullable, java.lang.String defaultValue, int scale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] ls)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String str1, java.lang.String str2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String str1, java.lang.String str2, java.lang.String str3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlDate(java.lang.String dateTime)
 java.lang.String sqlDateField(java.lang.String dateField)
 java.lang.String sqlDateTime(java.lang.String dateTime, java.lang.String format)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlFilterForClob(java.lang.String fieldName, java.lang.String value)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String fieldName, java.lang.String dateTime, java.lang.String format)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlModifyField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _bNullable, int _nScale)
修改指定表指定字段的属性
 java.lang.String sqlQueryTableInfo(java.lang.String ownerUser, java.lang.String tableName)
 java.lang.String sqlQueryTableInfos(java.lang.String ownerUser)
 java.lang.String sqlRenameField(java.lang.String tableName, java.lang.String oldFieldName, java.lang.String newFieldName)
重命名指定表的指定字段
 java.lang.String sqlRenameTable(java.lang.String oldTableName, java.lang.String newTableName)
重命名指定的表
从类 com.trs.infra.util.database.SQLServerDB 继承的方法
canDropField, canWriteTextDirectly, encodeStrToWrite, getClob, getClob, getSupportedDataTypes, getType, initQuerySQL, setClob, setClob
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, setStringFieldValue, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropField, sqlDropTable, sqlEscapeString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TINYINT

public static final DataType TINYINT

DATE

public static final DataType DATE
定义SQL Server中的字段类型：DATE

TIME

public static final DataType TIME
定义SQL Server中的字段类型：TIME

TIMESTAMP

public static final DataType TIMESTAMP
定义SQL Server中的字段类型：TIMESTAMP

INTEGER

public static final DataType INTEGER
定义SQL Server中的字段类型：INT

VARCHAR

public static final DataType VARCHAR
定义SQL Server中的字段类型：VARCHAR

NVARCHAR

public static final DataType NVARCHAR
定义SQL Server中的字段类型：NVARCHAR

构造方法详细信息

KingBaseDB

public KingBaseDB()

KingBaseDB

public KingBaseDB(java.lang.String _sName,
                  java.lang.String _sDriverClass)
方法详细信息

sqlGetNextId

public java.lang.String sqlGetNextId()
覆盖：
类 SQLServerDB 中的 sqlGetNextId

sqlAddField

public java.lang.String sqlAddField(java.lang.String tableName,
                                    java.lang.String fieldName,
                                    java.lang.String fieldType,
                                    int maxLength,
                                    boolean nullable,
                                    java.lang.String defaultValue,
                                    int scale)
从类 SQLServerDB 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

覆盖：
类 SQLServerDB 中的 sqlAddField
参数：
tableName - 表名称
fieldName - 字段名称
fieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
maxLength - 最大长度
nullable - 是否允许为空
defaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    int _nFieldType,
                                    int _nLengthOrPrecision,
                                    boolean _sNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
                             throws WCMException
从类 DBType 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

覆盖：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_nFieldType - 字段类型（java.sql.Types.*）
_nLengthOrPrecision - 字符串长度或者数字精度
_sNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句
抛出：
WCMException

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String str1,
                                     java.lang.String str2,
                                     java.lang.String str3)
从类 SQLServerDB 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

覆盖：
类 SQLServerDB 中的 sqlConcatStr
参数：
str1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
str2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
str3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String str1,
                                     java.lang.String str2)
从类 SQLServerDB 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

覆盖：
类 SQLServerDB 中的 sqlConcatStr
参数：
str1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
str2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] ls)
从类 SQLServerDB 复制的描述
字符串连接函数

覆盖：
类 SQLServerDB 中的 sqlConcatStr
参数：
ls - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String dateTime)
覆盖：
类 SQLServerDB 中的 sqlDate

sqlDateField

public java.lang.String sqlDateField(java.lang.String dateField)
覆盖：
类 SQLServerDB 中的 sqlDateField

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String dateTime,
                                    java.lang.String format)
从类 SQLServerDB 复制的描述
构造SQL语句，用以表示日期时间值

覆盖：
类 SQLServerDB 中的 sqlDateTime
参数：
dateTime - 指定日期值
format - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String fieldName,
                                         java.lang.String value)
从类 SQLServerDB 复制的描述
大字段检索函数

覆盖：
类 SQLServerDB 中的 sqlFilterForClob
参数：
fieldName - 大字段名称
value - 需要检索的值
返回：

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String fieldName,
                                        java.lang.String dateTime,
                                        java.lang.String format)
从类 SQLServerDB 复制的描述
构造SQL语句，用以筛选指定日期

覆盖：
类 SQLServerDB 中的 sqlFilterOneDay
参数：
fieldName - 日期字段名
dateTime - 指定日期值
format - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlGetSysDate

public java.lang.String sqlGetSysDate()
从类 SQLServerDB 复制的描述
取系统时间的内部函数

覆盖：
类 SQLServerDB 中的 sqlGetSysDate
返回：

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String tableName,
                                       java.lang.String oldFieldName,
                                       java.lang.String newFieldName)
从类 DBType 复制的描述
重命名指定表的指定字段

覆盖：
类 SQLServerDB 中的 sqlRenameField
返回：

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String oldTableName,
                                       java.lang.String newTableName)
从类 DBType 复制的描述
重命名指定的表

覆盖：
类 SQLServerDB 中的 sqlRenameTable
参数：
oldTableName - 以前的表名
newTableName - 新的表名
返回：

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String ownerUser,
                                          java.lang.String tableName)
覆盖：
类 SQLServerDB 中的 sqlQueryTableInfo

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String ownerUser)
覆盖：
类 SQLServerDB 中的 sqlQueryTableInfos

sqlModifyField

public java.lang.String sqlModifyField(java.lang.String _sTableName,
                                       java.lang.String _sFieldName,
                                       int _nFieldType,
                                       int _nLengthOrPrecision,
                                       boolean _bNullable,
                                       int _nScale)
                                throws WCMException
从类 DBType 复制的描述
修改指定表指定字段的属性

覆盖：
类 DBType 中的 sqlModifyField
返回：
抛出：
WCMException

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

覆盖：
类 SQLServerDB 中的 getAllDataTypes
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MysqlDB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 MysqlDB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.MysqlDB

public class MysqlDB
extends DBType

Title: TRS 内容协作平台（TRS WCM）
Description:
msql 数据库,使用mysql-connector-java-5.0.4-bin.jar驱动
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
huxuanlai

字段摘要
static DataType | BIGINT
static DataType | BIT
static DataType | BLOB
static DataType | BOOLEAN
static DataType | CHAR
static DataType | DATE
static DataType | DATETIME
static DataType | DECIMAL
static DataType | FLOAT
static DataType | INTEGER
static DataType | LONGBLOB
static DataType | LONGTEXT
static DataType | MEDIUBLOB
static DataType | MEDIUMTEXT
static DataType | NUMERIC
static DataType | NVARCHAR
static DataType | SMALLINT
static DataType | TEXT
static DataType | TIME
static DataType | TIMESTAMP
static DataType | TINYBLOB
static DataType | TINYINT
static DataType | TINYTEXT
static DataType | VARBINARY
static DataType | VARCHAR
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
MysqlDB()
MysqlDB(java.lang.String _sName, java.lang.String _sDriverClass)
构造函数
注：支持存储过程
方法摘要
 boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
 boolean canWriteTextDirectly()
判断是否可以直接写入大文本
 java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
Oracle不需额外处理
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 int getType()
获取当前的类型
 java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
生成查询一页数据的sql语句
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 void setStringFieldValue(java.sql.PreparedStatement _preStat, int _nIndex, java.lang.String _sValue)
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlDate(java.lang.String _sDateTime)
 java.lang.String sqlDateField(java.lang.String _sDateField)
 java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sDBTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
 java.lang.String sqlRenameField(java.lang.String _sTableName, java.lang.String _sOldFieldName, java.lang.String _sNewFieldName)
重命名指定表的指定字段
 java.lang.String sqlRenameTable(java.lang.String _sOldTableName, java.lang.String _sNewTableName)
重命名指定的表
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropField, sqlDropTable, sqlEscapeString, sqlModifyField
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

BIT

public static final DataType BIT

BOOLEAN

public static final DataType BOOLEAN

TINYINT

public static final DataType TINYINT

SMALLINT

public static final DataType SMALLINT

INTEGER

public static final DataType INTEGER

BIGINT

public static final DataType BIGINT

FLOAT

public static final DataType FLOAT

DECIMAL

public static final DataType DECIMAL

NUMERIC

public static final DataType NUMERIC

CHAR

public static final DataType CHAR

VARCHAR

public static final DataType VARCHAR

TINYTEXT

public static final DataType TINYTEXT

TEXT

public static final DataType TEXT

MEDIUMTEXT

public static final DataType MEDIUMTEXT

LONGTEXT

public static final DataType LONGTEXT

VARBINARY

public static final DataType VARBINARY

TINYBLOB

public static final DataType TINYBLOB

BLOB

public static final DataType BLOB

MEDIUBLOB

public static final DataType MEDIUBLOB

LONGBLOB

public static final DataType LONGBLOB

DATE

public static final DataType DATE

TIME

public static final DataType TIME

DATETIME

public static final DataType DATETIME

TIMESTAMP

public static final DataType TIMESTAMP

NVARCHAR

public static final DataType NVARCHAR
构造方法详细信息

MysqlDB

public MysqlDB()
另请参见：
MysqlDB( String _sName, String _sDriverClass ){

MysqlDB

public MysqlDB(java.lang.String _sName,
               java.lang.String _sDriverClass)
构造函数
注：支持存储过程

参数：
_sName - 名称，可省略，默认为"Mysql"
_sDriverClass - JDBC Driver Class Name，可省略，默认为"com.mysql.jdbc.Driver"
方法详细信息

encodeStrToWrite

public java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
Oracle不需额外处理

指定者：
类 DBType 中的 encodeStrToWrite
参数：
_strSrc - 指定的字符串
返回：

canWriteTextDirectly

public boolean canWriteTextDirectly()
判断是否可以直接写入大文本

指定者：
类 DBType 中的 canWriteTextDirectly
返回：
Oracle中不能直接写入，返回false

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

指定者：
类 DBType 中的 getAllDataTypes
返回：

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

指定者：
类 DBType 中的 getSupportedDataTypes
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 -
_strSQL2 -
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2,
                                     java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                         java.lang.String _sValue)
大字段检索函数

指定者：
类 DBType 中的 sqlFilterForClob
参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

指定者：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String _sOldTableName,
                                       java.lang.String _sNewTableName)
从类 DBType 复制的描述
重命名指定的表

覆盖：
类 DBType 中的 sqlRenameTable
参数：
_sOldTableName - 以前的表名
_sNewTableName - 新的表名
返回：

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String _sTableName,
                                       java.lang.String _sOldFieldName,
                                       java.lang.String _sNewFieldName)
从类 DBType 复制的描述
重命名指定表的指定字段

覆盖：
类 DBType 中的 sqlRenameField
返回：

sqlGetSysDate

public java.lang.String sqlGetSysDate()
取系统时间的内部函数

指定者：
类 DBType 中的 sqlGetSysDate
返回：

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期

指定者：
类 DBType 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                    java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值

指定者：
类 DBType 中的 sqlDateTime
参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String _sDateTime)
指定者：
类 DBType 中的 sqlDate

sqlDateField

public java.lang.String sqlDateField(java.lang.String _sDateField)
指定者：
类 DBType 中的 sqlDateField

initQuerySQL

public java.lang.String initQuerySQL(java.lang.String _strSql,
                                     int _nStartIndex,
                                     int _nSize)
生成查询一页数据的sql语句

指定者：
类 DBType 中的 initQuerySQL
参数：
_strSql - 原查询语句
_nStartIndex - 开始记录位置
_nSize - 需要获取的记录数
返回：

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
指定者：
类 DBType 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sDBTableName)
指定者：
类 DBType 中的 sqlQueryTableInfo

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

sqlGetNextId

public java.lang.String sqlGetNextId()
指定者：
类 DBType 中的 sqlGetNextId

getType

public int getType()
从类 DBType 复制的描述
获取当前的类型

指定者：
类 DBType 中的 getType
返回：

setStringFieldValue

public void setStringFieldValue(java.sql.PreparedStatement _preStat,
                                int _nIndex,
                                java.lang.String _sValue)
                         throws java.lang.Exception
覆盖：
类 DBType 中的 setStringFieldValue
抛出：
java.lang.Exception

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

指定者：
类 DBType 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OracleDB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 OracleDB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.OracleDB
直接已知子类：
AndinOraDB, OracleDB11G
public class OracleDB
extends DBType

字段摘要
static DataType | BFILE 定义Oracle中的字段类型：BFILE
static DataType | BLOB 定义Oracle中的字段类型：BLOB
static DataType | CHAR 定义Oracle中的字段类型：CHAR
static DataType | CLOB 定义Oracle中的字段类型：CLOB
static DataType | DATE 定义Oracle中的字段类型：DATE
static DataType | DATETIME 定义Oracle中的字段类型：DATE
static DataType | FLOAT 定义Oracle中的字段类型：INT 和SQLServer
static DataType | INT 定义Oracle中的字段类型：INT 和SQLServer
static DataType | LONG 定义Oracle中的字段类型：LONG
static DataType | LONGRAW 定义Oracle中的字段类型：LONGRAW
static DataType | NCLOB 定义Oracle中的字段类型：NCLOB
static DataType | NUMBER 定义Oracle中的字段类型：NUMBER
static DataType | NVARCHAR 定义Oracle中的字段类型：NVARCHAR 和SQLServer
static DataType | RAW 定义Oracle中的字段类型：RAW
static DataType | ROWID 定义Oracle中的字段类型：ROWID
static DataType | SMALLINT 定义Oracle中的字段类型：SMALLINT
static DataType | VARCHAR2 定义Oracle中的字段类型：VARCHAR2
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
OracleDB()
OracleDB(java.lang.String _sName, java.lang.String _sDriverClass)
构造函数
注：支持存储过程
方法摘要
 boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
 boolean canWriteTextDirectly()
判断是否可以直接写入大文本
 java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
Oracle不需额外处理
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 int getType()
获取当前的类型
 java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
生成查询一页数据的sql语句
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sIdFieldName, int nObjId, java.lang.String[] p_asFieldsAndValues)
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String sIdFieldName, int nObjId, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 void setStringFieldValue(java.sql.PreparedStatement _preStat, int _nIndex, java.lang.String _sValue)
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlDate(java.lang.String _sDateTime)
 java.lang.String sqlDateField(java.lang.String _sDateField)
 java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlQueryTableInfo(java.lang.String _sUserOwner, java.lang.String _sTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sUserOwner)
 java.lang.String sqlRenameField(java.lang.String _sTableName, java.lang.String _sOldFieldName, java.lang.String _sNewFieldName)
重命名指定表的指定字段
 java.lang.String sqlRenameTable(java.lang.String _sOldTableName, java.lang.String _sNewTableName)
重命名指定的表
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setDriverClass, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropField, sqlDropTable, sqlEscapeString, sqlModifyField
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CHAR

public static final DataType CHAR
定义Oracle中的字段类型：CHAR

VARCHAR2

public static final DataType VARCHAR2
定义Oracle中的字段类型：VARCHAR2

NUMBER

public static final DataType NUMBER
定义Oracle中的字段类型：NUMBER

INT

public static final DataType INT
定义Oracle中的字段类型：INT 和SQLServer

SMALLINT

public static final DataType SMALLINT
定义Oracle中的字段类型：SMALLINT

FLOAT

public static final DataType FLOAT
定义Oracle中的字段类型：INT 和SQLServer

NVARCHAR

public static final DataType NVARCHAR
定义Oracle中的字段类型：NVARCHAR 和SQLServer

LONG

public static final DataType LONG
定义Oracle中的字段类型：LONG

ROWID

public static final DataType ROWID
定义Oracle中的字段类型：ROWID

DATE

public static final DataType DATE
定义Oracle中的字段类型：DATE

DATETIME

public static final DataType DATETIME
定义Oracle中的字段类型：DATE

RAW

public static final DataType RAW
定义Oracle中的字段类型：RAW

LONGRAW

public static final DataType LONGRAW
定义Oracle中的字段类型：LONGRAW

CLOB

public static final DataType CLOB
定义Oracle中的字段类型：CLOB

BLOB

public static final DataType BLOB
定义Oracle中的字段类型：BLOB

NCLOB

public static final DataType NCLOB
定义Oracle中的字段类型：NCLOB

BFILE

public static final DataType BFILE
定义Oracle中的字段类型：BFILE

构造方法详细信息

OracleDB

public OracleDB()
另请参见：
OracleDB( String _sName, String _sDriverClass ){

OracleDB

public OracleDB(java.lang.String _sName,
                java.lang.String _sDriverClass)
构造函数
注：支持存储过程

参数：
_sName - 名称，可省略，默认为"Oracle"
_sDriverClass - JDBC Driver Class Name，可省略，默认为"oracle.jdbc.driver.OracleDriver"
方法详细信息

encodeStrToWrite

public java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
Oracle不需额外处理

指定者：
类 DBType 中的 encodeStrToWrite
参数：
_strSrc - 指定的字符串
返回：

canWriteTextDirectly

public boolean canWriteTextDirectly()
判断是否可以直接写入大文本

指定者：
类 DBType 中的 canWriteTextDirectly
返回：
Oracle中不能直接写入，返回false

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

指定者：
类 DBType 中的 getAllDataTypes
返回：

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

指定者：
类 DBType 中的 getSupportedDataTypes
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 -
_strSQL2 -
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2,
                                     java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                         java.lang.String _sValue)
大字段检索函数

指定者：
类 DBType 中的 sqlFilterForClob
参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

指定者：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String _sOldTableName,
                                       java.lang.String _sNewTableName)
从类 DBType 复制的描述
重命名指定的表

覆盖：
类 DBType 中的 sqlRenameTable
参数：
_sOldTableName - 以前的表名
_sNewTableName - 新的表名
返回：

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String _sTableName,
                                       java.lang.String _sOldFieldName,
                                       java.lang.String _sNewFieldName)
从类 DBType 复制的描述
重命名指定表的指定字段

覆盖：
类 DBType 中的 sqlRenameField
返回：

sqlGetSysDate

public java.lang.String sqlGetSysDate()
取系统时间的内部函数

指定者：
类 DBType 中的 sqlGetSysDate
返回：

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期

指定者：
类 DBType 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                    java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值

指定者：
类 DBType 中的 sqlDateTime
参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String _sDateTime)
指定者：
类 DBType 中的 sqlDate

sqlDateField

public java.lang.String sqlDateField(java.lang.String _sDateField)
指定者：
类 DBType 中的 sqlDateField

initQuerySQL

public java.lang.String initQuerySQL(java.lang.String _strSql,
                                     int _nStartIndex,
                                     int _nSize)
生成查询一页数据的sql语句

指定者：
类 DBType 中的 initQuerySQL
参数：
_strSql - 原查询语句
_nStartIndex - 开始记录位置
_nSize - 需要获取的记录数
返回：

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sUserOwner)
指定者：
类 DBType 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sUserOwner,
                                          java.lang.String _sTableName)
指定者：
类 DBType 中的 sqlQueryTableInfo

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

sqlGetNextId

public java.lang.String sqlGetNextId()
指定者：
类 DBType 中的 sqlGetNextId

getType

public int getType()
从类 DBType 复制的描述
获取当前的类型

指定者：
类 DBType 中的 getType
返回：

setStringFieldValue

public void setStringFieldValue(java.sql.PreparedStatement _preStat,
                                int _nIndex,
                                java.lang.String _sValue)
                         throws java.lang.Exception
覆盖：
类 DBType 中的 setStringFieldValue
抛出：
java.lang.Exception

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

指定者：
类 DBType 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String sIdFieldName,
                       int nObjId,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
覆盖：
类 DBType 中的 setClob
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sIdFieldName,
                       int nObjId,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
覆盖：
类 DBType 中的 setClob
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OracleDB11G

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 OracleDB11G

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.OracleDB
            继承者  com.trs.infra.util.database.OracleDB11G

public class OracleDB11G
extends OracleDB

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

字段摘要
从类 com.trs.infra.util.database.OracleDB 继承的字段
BFILE, BLOB, CHAR, CLOB, DATE, DATETIME, FLOAT, INT, LONG, LONGRAW, NCLOB, NUMBER, NVARCHAR, RAW, ROWID, SMALLINT, VARCHAR2
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
OracleDB11G()
方法摘要
java.lang.String | getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex) 从数据库中读取Clob/Text型字段的值
java.lang.String | getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName) 从数据库中读取Clob/Text型字段的值
boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sIdFieldName, int nObjId, java.lang.String[] p_asFieldsAndValues)
boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 将Clob/Text型字段值写入数据库
从类 com.trs.infra.util.database.OracleDB 继承的方法
canDropField, canWriteTextDirectly, encodeStrToWrite, getAllDataTypes, getSupportedDataTypes, getType, initQuerySQL, setClob, setStringFieldValue, sqlAddField, sqlConcatStr, sqlConcatStr, sqlConcatStr, sqlDate, sqlDateField, sqlDateTime, sqlFilterForClob, sqlFilterOneDay, sqlGetNextId, sqlGetSysDate, sqlQueryTableInfo, sqlQueryTableInfos, sqlRenameField, sqlRenameTable
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setDriverClass, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropField, sqlDropTable, sqlEscapeString, sqlModifyField
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OracleDB11G

public OracleDB11G()
方法详细信息

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

覆盖：
类 OracleDB 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

覆盖：
类 OracleDB 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

覆盖：
类 OracleDB 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

覆盖：
类 OracleDB 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sIdFieldName,
                       int nObjId,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
覆盖：
类 OracleDB 中的 setClob
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.database
类
AndinOraDB
CAS400CLOB
CDB2DBCLOB
CDB2DBCLOB2
CDBKeyWords
CDBText
ClusterDBIdManager
CMysqlText
ConnectionPool
COracleCLOB
CSQLText
DamengDB
DataType
DB2AS400DB
DB2ReorgUtil
DB2UDB
DB2UDB2
DB2UDBV9
DBIdManager
DBType
DBTypes
FieldInfo
KingBaseDB
MysqlDB
OracleDB
OracleDB11G
SQLServerDB
SybaseASE
SybaseASEText
SybaseASEWithJtds
TableInfo
TableInfos
TypeNames
XuguDB


com.trs.infra.util.database

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.database

类摘要
AndinOraDB | Title: TRS 内容协作平台（TRS WCM） Description: Andin加密处理,Oracle数据库.
CAS400CLOB | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CDB2DBCLOB |
CDB2DBCLOB2 | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CDBKeyWords | Title: TRS 内容协作平台（TRS WCM） Description: 从配置文件中读取数据库关键字，提供相关的有效性检验等操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CDBText |
ClusterDBIdManager | Title: TRS 内容协作平台（TRS WCM） Description: 集群对象ID获取(Compare and Write) Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
CMysqlText |
ConnectionPool | com.trs.util.dbcp.ConnectionCache的一个代理
COracleCLOB |
CSQLText |
DamengDB | Title: TRS 内容协作平台（TRS WCM） Description: 达梦 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DataType |
DB2AS400DB |
DB2ReorgUtil | Title: TRS 内容协作平台（TRS WCM） Description: 执行db2 reorg table 命令的工具类.
DB2UDB |
DB2UDB2 |
DB2UDBV9 | Title: TRS 内容协作平台（TRS WCM） Description: DB2 UDB V9+ Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DBIdManager |
DBType |
DBTypes | Title: TRS 内容协作平台（TRS WCM） Description: class DBTypes —— 支持的数据类型对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FieldInfo | Title: TRS 内容协作平台（TRS WCM） Description: class FieldInfo —— 数据库字段信息对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
KingBaseDB | Title: TRS 内容协作平台（TRS WCM） Description: 人大金仓数据库 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
MysqlDB | Title: TRS 内容协作平台（TRS WCM） Description: msql 数据库,使用mysql-connector-java-5.0.4-bin.jar驱动 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OracleDB |
OracleDB11G | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
SQLServerDB |
SybaseASE |
SybaseASEText |
SybaseASEWithJtds | Title: TRS 内容协作平台（TRS WCM） Description: SybaseASE 数据库,使用jtds驱动 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TableInfo |
TableInfos |
TypeNames | This class maps a type to names.
XuguDB | Title: TRS 内容协作平台（TRS WCM） Description: 虚谷数据库 Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)


com.trs.infra.util.database 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.database 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.database.CAS400CLOB
    • com.trs.infra.util.database.CDB2DBCLOB
    • com.trs.infra.util.database.CDB2DBCLOB2
    • com.trs.infra.util.database.CDBKeyWords
    • com.trs.infra.util.database.CDBText
    • com.trs.infra.util.database.ClusterDBIdManager
    • com.trs.infra.util.database.CMysqlText
    • com.trs.infra.util.database.ConnectionPool
    • com.trs.infra.util.database.COracleCLOB
    • com.trs.infra.util.database.CSQLText
    • com.trs.infra.util.database.DataType
    • com.trs.infra.util.database.DB2ReorgUtil
    • com.trs.infra.util.database.DBIdManager
    • com.trs.infra.util.database.DBIdManager.IdSeq
    • com.trs.infra.util.database.DBType
      • com.trs.infra.util.database.DB2AS400DB
      • com.trs.infra.util.database.DB2UDB
      • com.trs.infra.util.database.DB2UDB2
        • com.trs.infra.util.database.DB2UDBV9
      • com.trs.infra.util.database.MysqlDB
      • com.trs.infra.util.database.OracleDB
        • com.trs.infra.util.database.AndinOraDB
        • com.trs.infra.util.database.OracleDB11G
      • com.trs.infra.util.database.SQLServerDB
        • com.trs.infra.util.database.DamengDB
        • com.trs.infra.util.database.KingBaseDB
        • com.trs.infra.util.database.XuguDB
      • com.trs.infra.util.database.SybaseASE
      • com.trs.infra.util.database.SybaseASEWithJtds
    • com.trs.infra.util.database.DBTypes
    • com.trs.infra.util.database.FieldInfo
    • com.trs.infra.util.database.SybaseASEText
    • com.trs.infra.util.database.TableInfo
    • com.trs.infra.util.database.TableInfos
    • com.trs.infra.util.database.TypeNames


软件包 com.trs.infra.util.database 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.database
的使用

使用 com.trs.infra.util.database 的软件包
com.trs.ajaxservice
com.trs.cms.content
com.trs.components.wcm.content.persistent
com.trs.infra.persistent.db
com.trs.infra.util.database
com.trs.service
com.trs.service.impl
com.trs.wcm.old

com.trs.ajaxservice 使用的 com.trs.infra.util.database 中的类
DataType

com.trs.cms.content 使用的 com.trs.infra.util.database 中的类
DataType

com.trs.components.wcm.content.persistent 使用的 com.trs.infra.util.database 中的类
DataType

com.trs.infra.persistent.db 使用的 com.trs.infra.util.database 中的类
DBIdManager
DBType
FieldInfo
Title: TRS 内容协作平台（TRS WCM） Description: class FieldInfo —— 数据库字段信息对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TableInfo
TableInfos

com.trs.infra.util.database 使用的 com.trs.infra.util.database 中的类
DataType
DB2AS400DB
DB2UDB
DB2UDB2
DBIdManager
DBIdManager.IdSeq
Title: 网站内容管理（TRSWCM） Description: 单个对象的ID管理者 Copyright: Copyright (c) 2001 Company: www.trs.com.cn
DBType
FieldInfo
Title: TRS 内容协作平台（TRS WCM） Description: class FieldInfo —— 数据库字段信息对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MysqlDB
Title: TRS 内容协作平台（TRS WCM）
Description:
msql 数据库,使用mysql-connector-java-5.0.4-bin.jar驱动
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OracleDB
SQLServerDB
SybaseASE
TableInfo

com.trs.service 使用的 com.trs.infra.util.database 中的类
DataType

com.trs.service.impl 使用的 com.trs.infra.util.database 中的类
DataType

com.trs.wcm.old 使用的 com.trs.infra.util.database 中的类
FieldInfo
Title: TRS 内容协作平台（TRS WCM） Description: class FieldInfo —— 数据库字段信息对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SQLServerDB

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 SQLServerDB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.SQLServerDB
直接已知子类：
DamengDB, KingBaseDB, XuguDB
public class SQLServerDB
extends DBType

字段摘要
static DataType | BIGINT 定义SQL Server中的字段类型：BIGINT
static DataType | BINARY 定义SQL Server中的字段类型：BINARY
static DataType | BIT 定义SQL Server中的字段类型：BIT
static DataType | CHAR 定义SQL Server中的字段类型：CHAR
static DataType | DATE
static DataType | DATETIME 定义SQL Server中的字段类型：DATETIME
static DataType | DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | IMAGE 定义SQL Server中的字段类型：IMAGE
static DataType | INT 定义SQL Server中的字段类型：INT
static DataType | MONEY 定义SQL Server中的字段类型：MONEY
static DataType | NCHAR 定义SQL Server中的字段类型：NCHAR
static DataType | NTEXT 定义SQL Server中的字段类型：NTEXT
static DataType | NUMBER
static DataType | NUMERIC 定义SQL Server中的字段类型：NUMERIC
static DataType | NVARCHAR 定义SQL Server中的字段类型：NVARCHAR
static DataType | REAL 定义SQL Server中的字段类型：REAL
static DataType | SMALLDATETIME 定义SQL Server中的字段类型：SMALLDATETIME
static DataType | SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | SMALLMONEY 定义SQL Server中的字段类型：SMALLMONEY
static DataType | SQL_VARIRANT 定义SQL Server中的字段类型：SQL_VARIRANT
static DataType | TEXT 定义SQL Server中的字段类型：TEXT
static DataType | TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | TINYINT 定义SQL Server中的字段类型：TINYINT
static DataType | UNIQUEIDENTIFIER 定义SQL Server中的字段类型：UNIQUEIDENTIFIER
static DataType | VARBINARY 定义SQL Server中的字段类型：VARBINARY
static DataType | VARCHAR 定义SQL Server中的字段类型：VARCHAR
static DataType | VARCHAR2
static java.lang.String | WRITE_STR_ENCODING
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
SQLServerDB()
SQLServerDB(java.lang.String _sName, java.lang.String _sDriverClass)
方法摘要
 boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
 boolean canWriteTextDirectly()
判断是否可以直接写入大文本
 java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
使用SQLServerDB.WRITE_STR_ENCODING进行编码，默认为(ISO-8859-1)
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 int getType()
获取当前的类型
 java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
生成查询一页数据的sql语句
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlDate(java.lang.String _sDateTime)
 java.lang.String sqlDateField(java.lang.String _sDateField)
 java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sDBTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
 java.lang.String sqlRenameField(java.lang.String _sTableName, java.lang.String _sOldFieldName, java.lang.String _sNewFieldName)
重命名指定表的指定字段
 java.lang.String sqlRenameTable(java.lang.String _sOldTableName, java.lang.String _sNewTableName)
重命名指定的表
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropField, sqlDropTable, sqlEscapeString, sqlModifyField
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

WRITE_STR_ENCODING

public static java.lang.String WRITE_STR_ENCODING

BIT

public static final DataType BIT
定义SQL Server中的字段类型：BIT

TINYINT

public static final DataType TINYINT
定义SQL Server中的字段类型：TINYINT

SMALLINT

public static final DataType SMALLINT
定义SQL Server中的字段类型：SMALLINT

INT

public static final DataType INT
定义SQL Server中的字段类型：INT

BIGINT

public static final DataType BIGINT
定义SQL Server中的字段类型：BIGINT

NUMERIC

public static final DataType NUMERIC
定义SQL Server中的字段类型：NUMERIC

REAL

public static final DataType REAL
定义SQL Server中的字段类型：REAL

FLOAT

public static final DataType FLOAT
定义SQL Server中的字段类型：FLOAT

DECIMAL

public static final DataType DECIMAL
定义SQL Server中的字段类型：DECIMAL

MONEY

public static final DataType MONEY
定义SQL Server中的字段类型：MONEY

SMALLMONEY

public static final DataType SMALLMONEY
定义SQL Server中的字段类型：SMALLMONEY

BINARY

public static final DataType BINARY
定义SQL Server中的字段类型：BINARY

VARBINARY

public static final DataType VARBINARY
定义SQL Server中的字段类型：VARBINARY

IMAGE

public static final DataType IMAGE
定义SQL Server中的字段类型：IMAGE

CHAR

public static final DataType CHAR
定义SQL Server中的字段类型：CHAR

NCHAR

public static final DataType NCHAR
定义SQL Server中的字段类型：NCHAR

VARCHAR

public static final DataType VARCHAR
定义SQL Server中的字段类型：VARCHAR

NVARCHAR

public static final DataType NVARCHAR
定义SQL Server中的字段类型：NVARCHAR

TEXT

public static final DataType TEXT
定义SQL Server中的字段类型：TEXT

NTEXT

public static final DataType NTEXT
定义SQL Server中的字段类型：NTEXT

TIMESTAMP

public static final DataType TIMESTAMP
定义SQL Server中的字段类型：TIMESTAMP

DATETIME

public static final DataType DATETIME
定义SQL Server中的字段类型：DATETIME

SMALLDATETIME

public static final DataType SMALLDATETIME
定义SQL Server中的字段类型：SMALLDATETIME

UNIQUEIDENTIFIER

public static final DataType UNIQUEIDENTIFIER
定义SQL Server中的字段类型：UNIQUEIDENTIFIER

SQL_VARIRANT

public static final DataType SQL_VARIRANT
定义SQL Server中的字段类型：SQL_VARIRANT

VARCHAR2

public static final DataType VARCHAR2

NUMBER

public static final DataType NUMBER

DATE

public static final DataType DATE
构造方法详细信息

SQLServerDB

public SQLServerDB()

SQLServerDB

public SQLServerDB(java.lang.String _sName,
                   java.lang.String _sDriverClass)
方法详细信息

encodeStrToWrite

public java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
使用SQLServerDB.WRITE_STR_ENCODING进行编码，默认为(ISO-8859-1)

指定者：
类 DBType 中的 encodeStrToWrite
参数：
_strSrc - 指定的字符串
返回：

canWriteTextDirectly

public boolean canWriteTextDirectly()
判断是否可以直接写入大文本

指定者：
类 DBType 中的 canWriteTextDirectly
返回：
Sql Server中能直接写入，返回true

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

指定者：
类 DBType 中的 getAllDataTypes
返回：

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

指定者：
类 DBType 中的 getSupportedDataTypes
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2,
                                     java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                         java.lang.String _sValue)
大字段检索函数

指定者：
类 DBType 中的 sqlFilterForClob
参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

指定者：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlGetSysDate

public java.lang.String sqlGetSysDate()
取系统时间的内部函数

指定者：
类 DBType 中的 sqlGetSysDate
返回：

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期

指定者：
类 DBType 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                    java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值

指定者：
类 DBType 中的 sqlDateTime
参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String _sDateTime)
指定者：
类 DBType 中的 sqlDate

sqlDateField

public java.lang.String sqlDateField(java.lang.String _sDateField)
指定者：
类 DBType 中的 sqlDateField

initQuerySQL

public java.lang.String initQuerySQL(java.lang.String _strSql,
                                     int _nStartIndex,
                                     int _nSize)
生成查询一页数据的sql语句

指定者：
类 DBType 中的 initQuerySQL
参数：
_strSql - 原查询语句
_nStartIndex - 开始记录位置
_nSize - 需要获取的记录数
返回：

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
指定者：
类 DBType 中的 sqlQueryTableInfos

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

sqlGetNextId

public java.lang.String sqlGetNextId()
指定者：
类 DBType 中的 sqlGetNextId

getType

public int getType()
从类 DBType 复制的描述
获取当前的类型

指定者：
类 DBType 中的 getType
返回：

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sDBTableName)
指定者：
类 DBType 中的 sqlQueryTableInfo

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

指定者：
类 DBType 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String _sOldTableName,
                                       java.lang.String _sNewTableName)
从类 DBType 复制的描述
重命名指定的表

覆盖：
类 DBType 中的 sqlRenameTable
参数：
_sOldTableName - 以前的表名
_sNewTableName - 新的表名
返回：

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String _sTableName,
                                       java.lang.String _sOldFieldName,
                                       java.lang.String _sNewFieldName)
从类 DBType 复制的描述
重命名指定表的指定字段

覆盖：
类 DBType 中的 sqlRenameField
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SybaseASE

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 SybaseASE

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.SybaseASE

public class SybaseASE
extends DBType

字段摘要
static DataType | BINARY 定义SQL Server中的字段类型：BINARY
static DataType | BIT 定义SQL Server中的字段类型：BIT
static DataType | CHAR 定义SQL Server中的字段类型：CHAR
static DataType | DATETIME 定义SQL Server中的字段类型：DATETIME
static DataType | DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | IMAGE 定义SQL Server中的字段类型：IMAGE
static DataType | INT 定义SQL Server中的字段类型：INT
static DataType | MONEY 定义SQL Server中的字段类型：MONEY
static DataType | NCHAR 定义SQL Server中的字段类型：NCHAR
static DataType | NUMERIC 定义SQL Server中的字段类型：NUMERIC
static DataType | NVARCHAR 定义SQL Server中的字段类型：NVARCHAR
static DataType | REAL 定义SQL Server中的字段类型：REAL
static DataType | SMALLDATETIME 定义SQL Server中的字段类型：SMALLDATETIME
static DataType | SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | SMALLMONEY 定义SQL Server中的字段类型：SMALLMONEY
static DataType | TEXT 定义SQL Server中的字段类型：TEXT
static DataType | TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | TINYINT 定义SQL Server中的字段类型：TINYINT
static DataType | VARBINARY 定义SQL Server中的字段类型：VARBINARY
static DataType | VARCHAR 定义SQL Server中的字段类型：VARCHAR
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
SybaseASE()
SybaseASE(java.lang.String _sName, java.lang.String _sDriverClass, boolean _bSupportStoredProc)
方法摘要
 boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
 boolean canWriteTextDirectly()
判断是否可以直接写入大文本
 java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 int getType()
获取当前的类型
 java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
生成查询一页数据的sql语句
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 void setStringFieldValue(java.sql.PreparedStatement _oPreStmt, int _nIndex, java.lang.String _sValue)
覆写:在Sybase中,设置一个空串会默认插入一个空格.
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlDate(java.lang.String _sDate)
 java.lang.String sqlDateField(java.lang.String _sDateField)
 java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlDropField(java.lang.String _sTableName, java.lang.String _sFieldNames)
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
 java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropTable, sqlEscapeString, sqlModifyField, sqlRenameField, sqlRenameTable
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

BIT

public static final DataType BIT
定义SQL Server中的字段类型：BIT

TINYINT

public static final DataType TINYINT
定义SQL Server中的字段类型：TINYINT

SMALLINT

public static final DataType SMALLINT
定义SQL Server中的字段类型：SMALLINT

INT

public static final DataType INT
定义SQL Server中的字段类型：INT

NUMERIC

public static final DataType NUMERIC
定义SQL Server中的字段类型：NUMERIC

REAL

public static final DataType REAL
定义SQL Server中的字段类型：REAL

FLOAT

public static final DataType FLOAT
定义SQL Server中的字段类型：FLOAT

DECIMAL

public static final DataType DECIMAL
定义SQL Server中的字段类型：DECIMAL

MONEY

public static final DataType MONEY
定义SQL Server中的字段类型：MONEY

SMALLMONEY

public static final DataType SMALLMONEY
定义SQL Server中的字段类型：SMALLMONEY

BINARY

public static final DataType BINARY
定义SQL Server中的字段类型：BINARY

VARBINARY

public static final DataType VARBINARY
定义SQL Server中的字段类型：VARBINARY

IMAGE

public static final DataType IMAGE
定义SQL Server中的字段类型：IMAGE

CHAR

public static final DataType CHAR
定义SQL Server中的字段类型：CHAR

NCHAR

public static final DataType NCHAR
定义SQL Server中的字段类型：NCHAR

VARCHAR

public static final DataType VARCHAR
定义SQL Server中的字段类型：VARCHAR

NVARCHAR

public static final DataType NVARCHAR
定义SQL Server中的字段类型：NVARCHAR

TEXT

public static final DataType TEXT
定义SQL Server中的字段类型：TEXT

TIMESTAMP

public static final DataType TIMESTAMP
定义SQL Server中的字段类型：TIMESTAMP

DATETIME

public static final DataType DATETIME
定义SQL Server中的字段类型：DATETIME

SMALLDATETIME

public static final DataType SMALLDATETIME
定义SQL Server中的字段类型：SMALLDATETIME

构造方法详细信息

SybaseASE

public SybaseASE()

SybaseASE

public SybaseASE(java.lang.String _sName,
                 java.lang.String _sDriverClass,
                 boolean _bSupportStoredProc)
方法详细信息

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                         java.lang.String _sValue)
从类 DBType 复制的描述
大字段检索函数

指定者：
类 DBType 中的 sqlFilterForClob
参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
从类 DBType 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

指定者：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
从类 DBType 复制的描述
字符串连接函数

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

canWriteTextDirectly

public boolean canWriteTextDirectly()
从类 DBType 复制的描述
判断是否可以直接写入大文本

指定者：
类 DBType 中的 canWriteTextDirectly
返回：

sqlDateField

public java.lang.String sqlDateField(java.lang.String _sDateField)
指定者：
类 DBType 中的 sqlDateField

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以筛选指定日期

指定者：
类 DBType 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                    java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以表示日期时间值

指定者：
类 DBType 中的 sqlDateTime
参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2,
                                     java.lang.String _strSQL3)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String _sDate)
指定者：
类 DBType 中的 sqlDate

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

指定者：
类 DBType 中的 getAllDataTypes
返回：

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

指定者：
类 DBType 中的 getSupportedDataTypes
返回：

sqlGetSysDate

public java.lang.String sqlGetSysDate()
从类 DBType 复制的描述
取系统时间的内部函数

指定者：
类 DBType 中的 sqlGetSysDate
返回：

sqlDropField

public java.lang.String sqlDropField(java.lang.String _sTableName,
                                     java.lang.String _sFieldNames)
                              throws java.lang.Exception
从类 DBType 复制的描述
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2

覆盖：
类 DBType 中的 sqlDropField
参数：
_sTableName - 数据表名称
_sFieldNames - 字段名称（可以有多个，不同字段之间以","分割）
返回：
构造的SQL语句
抛出：
java.lang.Exception

encodeStrToWrite

public java.lang.String encodeStrToWrite(java.lang.String _strSrc)
从类 DBType 复制的描述
将指定字符串编码为数据库能够正确接受的字符串

指定者：
类 DBType 中的 encodeStrToWrite
参数：
_strSrc - 指定的字符串
返回：

initQuerySQL

public java.lang.String initQuerySQL(java.lang.String _strSql,
                                     int _nStartIndex,
                                     int _nSize)
生成查询一页数据的sql语句

指定者：
类 DBType 中的 initQuerySQL
参数：
_strSql - 原查询语句
_nStartIndex - 开始记录位置
_nSize - 需要获取的记录数
返回：

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
指定者：
类 DBType 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sTableName)
指定者：
类 DBType 中的 sqlQueryTableInfo

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

sqlGetNextId

public java.lang.String sqlGetNextId()
指定者：
类 DBType 中的 sqlGetNextId

getType

public int getType()
从类 DBType 复制的描述
获取当前的类型

指定者：
类 DBType 中的 getType
返回：

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

指定者：
类 DBType 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false

setStringFieldValue

public void setStringFieldValue(java.sql.PreparedStatement _oPreStmt,
                                int _nIndex,
                                java.lang.String _sValue)
                         throws java.lang.Exception
覆写:在Sybase中,设置一个空串会默认插入一个空格.
判断:如果是空串的话,直接设置为null

覆盖：
类 DBType 中的 setStringFieldValue
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SybaseASEText

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 SybaseASEText

java.lang.Object
    继承者  com.trs.infra.util.database.SybaseASEText

public class SybaseASEText
extends java.lang.Object

构造方法摘要
SybaseASEText()
方法摘要
static java.lang.String | getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex) 根据字段序号提取Clob/text字段内容
static java.lang.String | getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName) 根据字段名称提取Clob/text字段内容
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sValue, java.lang.String p_sUpdateSQL, java.lang.String p_sFieldName) 根据更新语句设置Clob/text字段内容
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues) 根据条件同时写入多个Clob/text内容
static boolean | setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue) 根据条件写入Clob/text内容
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SybaseASEText

public SybaseASEText()
方法详细信息

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       boolean p_bJdbcIs2,
                                       int p_nFieldIndex)
                                throws CMyException
根据字段序号提取Clob/text字段内容

参数：
p_rsData - 记录集
p_bJdbcIs2 - 是否支持JDBC 2.0 API，支持
p_nFieldIndex - 字段序号
返回：
p_nFieldIndex指定的字段内容
抛出：
CMyException - 如果提取内容过程发生错误

getClob

public static java.lang.String getClob(java.sql.ResultSet p_rsData,
                                       boolean p_bJdbcIs2,
                                       java.lang.String p_sFieldName)
                                throws CMyException
根据字段名称提取Clob/text字段内容

参数：
p_rsData - 记录集
p_bJdbcIs2 - 是否支持JDBC 2.0 API，支持
p_sFieldName - 字段名称
返回：
p_sFieldName指定的字段内容
抛出：
CMyException - 如果提取过程发生错误

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sValue,
                              java.lang.String p_sUpdateSQL,
                              java.lang.String p_sFieldName)
                       throws CMyException
根据更新语句设置Clob/text字段内容

参数：
p_oConn - 数据库连接
p_sValue - 字段内容
p_sUpdateSQL - 更新字段使用的SQL语句
p_sFieldName - 字段名称
返回：
更新操作是否成功
抛出：
CMyException - 如果更新过程发生错误

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String p_sClobFieldName,
                              java.lang.String p_sValue)
                       throws CMyException
根据条件写入Clob/text内容

参数：
p_oConn - 数据库连接
p_sTableName - 执行数据写入的表名
p_sWhere - 执行写入的检索条件
p_sIdFieldName - 写入表的标示字段
p_sClobFieldName - Clob/text字段名
p_sValue - 字段内容
返回：
字段写入操作是否成功
抛出：
CMyException - 如果写入过程发生错误

setClob

public static boolean setClob(java.sql.Connection p_oConn,
                              java.lang.String p_sTableName,
                              java.lang.String p_sWhere,
                              java.lang.String p_sIdFieldName,
                              java.lang.String[] p_asFieldsAndValues)
                       throws CMyException
根据条件同时写入多个Clob/text内容

参数：
p_oConn - 数据库连接
p_sTableName - 表名
p_sWhere - 检索条件
p_sIdFieldName - 表的标示字段
p_asFieldsAndValues - 表的字段名和字段内容集合
返回：
字段写入操作是否成功
抛出：
CMyException - 如果写入过程发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SybaseASEWithJtds

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 SybaseASEWithJtds

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.SybaseASEWithJtds

public class SybaseASEWithJtds
extends DBType

Title: TRS 内容协作平台（TRS WCM）
Description:
SybaseASE 数据库,使用jtds驱动
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

字段摘要
static DataType | BINARY 定义SQL Server中的字段类型：BINARY
static DataType | BIT 定义SQL Server中的字段类型：BIT
static DataType | CHAR 定义SQL Server中的字段类型：CHAR
static DataType | DATETIME 定义SQL Server中的字段类型：DATETIME
static DataType | DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | IMAGE 定义SQL Server中的字段类型：IMAGE
static DataType | INT 定义SQL Server中的字段类型：INT
static DataType | MONEY 定义SQL Server中的字段类型：MONEY
static DataType | NCHAR 定义SQL Server中的字段类型：NCHAR
static DataType | NUMERIC 定义SQL Server中的字段类型：NUMERIC
static DataType | NVARCHAR 定义SQL Server中的字段类型：NVARCHAR
static DataType | REAL 定义SQL Server中的字段类型：REAL
static DataType | SMALLDATETIME 定义SQL Server中的字段类型：SMALLDATETIME
static DataType | SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | SMALLMONEY 定义SQL Server中的字段类型：SMALLMONEY
static DataType | TEXT 定义SQL Server中的字段类型：TEXT
static DataType | TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | TINYINT 定义SQL Server中的字段类型：TINYINT
static DataType | VARBINARY 定义SQL Server中的字段类型：VARBINARY
static DataType | VARCHAR 定义SQL Server中的字段类型：VARCHAR
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
SybaseASEWithJtds()
SybaseASEWithJtds(java.lang.String _sName, java.lang.String _sDriverClass, boolean _bSupportStoredProc)
方法摘要
 boolean canDropField()
使用的数据数据库是否可以删除某个表中的列.
 boolean canWriteTextDirectly()
判断是否可以直接写入大文本
 java.lang.String encodeStrToWrite(java.lang.String _strSrc)
将指定字符串编码为数据库能够正确接受的字符串
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 int getType()
获取当前的类型
 java.lang.String initQuerySQL(java.lang.String _strSql, int _nStartIndex, int _nSize)
生成查询一页数据的sql语句
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String[] p_asFieldsAndValues)
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
 boolean setClob(java.sql.Connection p_oConn, java.lang.String p_sTableName, java.lang.String p_sWhere, java.lang.String p_sIdFieldName, java.lang.String p_sClobFieldName, java.lang.String p_sValue)
将Clob/Text型字段值写入数据库
 void setStringFieldValue(java.sql.PreparedStatement _oPreStmt, int _nIndex, java.lang.String _sValue, boolean _bNullable)
覆写:在Sybase中,设置一个空串会默认插入一个空格.
 java.lang.String sqlAddField(java.lang.String _sTableName, java.lang.String _sFieldName, java.lang.String _sFieldType, int _nMaxLength, boolean _bNullable, java.lang.String _sDefaultValue, int _nScale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String _strSQL1, java.lang.String _strSQL2, java.lang.String _strSQL3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlCreateTableWithPrimary(java.lang.String _sTableName, java.lang.String _sPrimaryFieldName)
构造一个带有PrimaryKey字段的表的SQL
 java.lang.String sqlDate(java.lang.String _sDate)
 java.lang.String sqlDateField(java.lang.String _sDateField)
 java.lang.String sqlDateTime(java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlDropField(java.lang.String _sTableName, java.lang.String _sFieldNames)
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
 java.lang.String sqlFilterForClob(java.lang.String _sFieldName, java.lang.String _sValue)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
 java.lang.String sqlRenameField(java.lang.String _sTableName, java.lang.String _sOldFieldName, java.lang.String _sNewFieldName)
重命名指定表的指定字段
 java.lang.String sqlRenameTable(java.lang.String _sOldTableName, java.lang.String _sNewTableName)
重命名指定的表
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlDropTable, sqlEscapeString, sqlModifyField
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

BIT

public static final DataType BIT
定义SQL Server中的字段类型：BIT

TINYINT

public static final DataType TINYINT
定义SQL Server中的字段类型：TINYINT

SMALLINT

public static final DataType SMALLINT
定义SQL Server中的字段类型：SMALLINT

INT

public static final DataType INT
定义SQL Server中的字段类型：INT

NUMERIC

public static final DataType NUMERIC
定义SQL Server中的字段类型：NUMERIC

REAL

public static final DataType REAL
定义SQL Server中的字段类型：REAL

FLOAT

public static final DataType FLOAT
定义SQL Server中的字段类型：FLOAT

DECIMAL

public static final DataType DECIMAL
定义SQL Server中的字段类型：DECIMAL

MONEY

public static final DataType MONEY
定义SQL Server中的字段类型：MONEY

SMALLMONEY

public static final DataType SMALLMONEY
定义SQL Server中的字段类型：SMALLMONEY

BINARY

public static final DataType BINARY
定义SQL Server中的字段类型：BINARY

VARBINARY

public static final DataType VARBINARY
定义SQL Server中的字段类型：VARBINARY

IMAGE

public static final DataType IMAGE
定义SQL Server中的字段类型：IMAGE

CHAR

public static final DataType CHAR
定义SQL Server中的字段类型：CHAR

NCHAR

public static final DataType NCHAR
定义SQL Server中的字段类型：NCHAR

VARCHAR

public static final DataType VARCHAR
定义SQL Server中的字段类型：VARCHAR

NVARCHAR

public static final DataType NVARCHAR
定义SQL Server中的字段类型：NVARCHAR

TEXT

public static final DataType TEXT
定义SQL Server中的字段类型：TEXT

TIMESTAMP

public static final DataType TIMESTAMP
定义SQL Server中的字段类型：TIMESTAMP

DATETIME

public static final DataType DATETIME
定义SQL Server中的字段类型：DATETIME

SMALLDATETIME

public static final DataType SMALLDATETIME
定义SQL Server中的字段类型：SMALLDATETIME

构造方法详细信息

SybaseASEWithJtds

public SybaseASEWithJtds()

SybaseASEWithJtds

public SybaseASEWithJtds(java.lang.String _sName,
                         java.lang.String _sDriverClass,
                         boolean _bSupportStoredProc)
方法详细信息

getAllDataTypes

public DataType[] getAllDataTypes()
取所有的字段数据类型

指定者：
类 DBType 中的 getAllDataTypes
返回：

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String _sFieldName,
                                         java.lang.String _sValue)
从类 DBType 复制的描述
大字段检索函数

指定者：
类 DBType 中的 sqlFilterForClob
参数：
_sFieldName - 大字段名称
_sValue - 需要检索的值
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String _sTableName,
                                    java.lang.String _sFieldName,
                                    java.lang.String _sFieldType,
                                    int _nMaxLength,
                                    boolean _bNullable,
                                    java.lang.String _sDefaultValue,
                                    int _nScale)
从类 DBType 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

指定者：
类 DBType 中的 sqlAddField
参数：
_sTableName - 表名称
_sFieldName - 字段名称
_sFieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
_nMaxLength - 最大长度
_bNullable - 是否允许为空
_sDefaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] _strSQLs)
从类 DBType 复制的描述
字符串连接函数

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQLs - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

canWriteTextDirectly

public boolean canWriteTextDirectly()
从类 DBType 复制的描述
判断是否可以直接写入大文本

指定者：
类 DBType 中的 canWriteTextDirectly
返回：

sqlDateField

public java.lang.String sqlDateField(java.lang.String _sDateField)
指定者：
类 DBType 中的 sqlDateField

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以筛选指定日期

指定者：
类 DBType 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String _sDateTime,
                                    java.lang.String _sFormat)
从类 DBType 复制的描述
构造SQL语句，用以表示日期时间值

指定者：
类 DBType 中的 sqlDateTime
参数：
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String _strSQL1,
                                     java.lang.String _strSQL2,
                                     java.lang.String _strSQL3)
从类 DBType 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

指定者：
类 DBType 中的 sqlConcatStr
参数：
_strSQL1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
_strSQL3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String _sDate)
指定者：
类 DBType 中的 sqlDate

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型

指定者：
类 DBType 中的 getSupportedDataTypes
返回：

sqlGetSysDate

public java.lang.String sqlGetSysDate()
从类 DBType 复制的描述
取系统时间的内部函数

指定者：
类 DBType 中的 sqlGetSysDate
返回：

sqlDropField

public java.lang.String sqlDropField(java.lang.String _sTableName,
                                     java.lang.String _sFieldNames)
                              throws java.lang.Exception
从类 DBType 复制的描述
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2

覆盖：
类 DBType 中的 sqlDropField
参数：
_sTableName - 数据表名称
_sFieldNames - 字段名称（可以有多个，不同字段之间以","分割）
返回：
构造的SQL语句
抛出：
java.lang.Exception

encodeStrToWrite

public java.lang.String encodeStrToWrite(java.lang.String _strSrc)
从类 DBType 复制的描述
将指定字符串编码为数据库能够正确接受的字符串

指定者：
类 DBType 中的 encodeStrToWrite
参数：
_strSrc - 指定的字符串
返回：

initQuerySQL

public java.lang.String initQuerySQL(java.lang.String _strSql,
                                     int _nStartIndex,
                                     int _nSize)
生成查询一页数据的sql语句

指定者：
类 DBType 中的 initQuerySQL
参数：
_strSql - 原查询语句
_nStartIndex - 开始记录位置
_nSize - 需要获取的记录数
返回：

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
指定者：
类 DBType 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sTableName)
指定者：
类 DBType 中的 sqlQueryTableInfo

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

指定者：
类 DBType 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String p_sClobFieldName,
                       java.lang.String p_sValue)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_sClobFieldName - CLOB字段名
p_sValue - 字段值
返回：
抛出：
CMyException

setClob

public boolean setClob(java.sql.Connection p_oConn,
                       java.lang.String p_sTableName,
                       java.lang.String p_sWhere,
                       java.lang.String p_sIdFieldName,
                       java.lang.String[] p_asFieldsAndValues)
                throws CMyException
从类 DBType 复制的描述
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况

指定者：
类 DBType 中的 setClob
参数：
p_oConn - 数据库连接表名
p_sTableName - 数据表名
p_sWhere - 额外条件
p_sIdFieldName - 记录ID值
p_asFieldsAndValues - （数组）CLOB字段名和值数组。
要求：[1]必须是按照 （CLOB字段1,CLOB字段1的值，CLOB字段2,CLOB字段2的值，...）的顺序排列
[2]CLOB字段名和字段值，必须成对出现，且至少出现一对。
返回：
抛出：
CMyException

sqlGetNextId

public java.lang.String sqlGetNextId()
指定者：
类 DBType 中的 sqlGetNextId

getType

public int getType()
从类 DBType 复制的描述
获取当前的类型

指定者：
类 DBType 中的 getType
返回：

canDropField

public boolean canDropField()
从类 DBType 复制的描述
使用的数据数据库是否可以删除某个表中的列.

指定者：
类 DBType 中的 canDropField
返回：
如果可以则返回 true ,否则返回 false

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String _sOldTableName,
                                       java.lang.String _sNewTableName)
从类 DBType 复制的描述
重命名指定的表

覆盖：
类 DBType 中的 sqlRenameTable
参数：
_sOldTableName - 以前的表名
_sNewTableName - 新的表名
返回：

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String _sTableName,
                                       java.lang.String _sOldFieldName,
                                       java.lang.String _sNewFieldName)
从类 DBType 复制的描述
重命名指定表的指定字段

覆盖：
类 DBType 中的 sqlRenameField
返回：

sqlCreateTableWithPrimary

public java.lang.String sqlCreateTableWithPrimary(java.lang.String _sTableName,
                                                  java.lang.String _sPrimaryFieldName)
从类 DBType 复制的描述
构造一个带有PrimaryKey字段的表的SQL

覆盖：
类 DBType 中的 sqlCreateTableWithPrimary
返回：

setStringFieldValue

public void setStringFieldValue(java.sql.PreparedStatement _oPreStmt,
                                int _nIndex,
                                java.lang.String _sValue,
                                boolean _bNullable)
                         throws java.lang.Exception
覆写:在Sybase中,设置一个空串会默认插入一个空格.
判断:如果是空串且列允许空值的话,直接设置为null.如果不允许空值,则仍设置为空格

覆盖：
类 DBType 中的 setStringFieldValue
参数：
_oPreStmt - 要设值的statment句柄
_nIndex - 要设值的列索引自
_sValue - 要设置的值
_bNullable - 要设置的列是否允许空
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 TableInfo

java.lang.Object
    继承者  com.trs.infra.util.database.TableInfo

public class TableInfo
extends java.lang.Object

构造方法摘要
TableInfo()
构造函数
方法摘要
void | clear() 清除所有数据
int | getFieldCount() 取字段总数
FieldInfo | getFieldInfo(java.lang.String _sFieldName) 根据字段名，提取字段信息对象
java.util.Enumeration | getFieldNames() 取所有的字段名称
java.lang.String | getTableName() 获取数据表名称
boolean | isField(java.lang.String _sFieldName) 检测某个字段是否存在于指定的表
void | putFieldInfo(java.lang.String _sFieldName, FieldInfo _fieldInfo) 在数据表字段信息集合中存入字段信息
void | removeFieldInfo(java.lang.String _sFieldName) 在数据表字段信息集合中清除字段信息
void | setTableName(java.lang.String _sTableName) 设置数据表名称
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableInfo

public TableInfo()
构造函数

方法详细信息

getTableName

public java.lang.String getTableName()
获取数据表名称

返回：

setTableName

public void setTableName(java.lang.String _sTableName)
设置数据表名称

参数：
_sTableName -

clear

public void clear()
清除所有数据

removeFieldInfo

public void removeFieldInfo(java.lang.String _sFieldName)
在数据表字段信息集合中清除字段信息

参数：
_sFieldName - 字段名称

putFieldInfo

public void putFieldInfo(java.lang.String _sFieldName,
                         FieldInfo _fieldInfo)
在数据表字段信息集合中存入字段信息

参数：
_sFieldName - 字段名称
_fieldInfo - 字段信息

getFieldInfo

public FieldInfo getFieldInfo(java.lang.String _sFieldName)
根据字段名，提取字段信息对象

参数：
_sFieldName - 字段名称
返回：

isField

public boolean isField(java.lang.String _sFieldName)
检测某个字段是否存在于指定的表

参数：
_sFieldName - 字段名称
返回：

getFieldCount

public int getFieldCount()
取字段总数

返回：

getFieldNames

public java.util.Enumeration getFieldNames()
取所有的字段名称

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 TableInfos

java.lang.Object
    继承者  com.trs.infra.util.database.TableInfos

public class TableInfos
extends java.lang.Object

构造方法摘要
TableInfos()
构造函数
方法摘要
void | clear() 清除所有数据
FieldInfo | getFieldInfo(java.lang.String _sTableName, java.lang.String _sFieldName) 取指定数据表中指定字段信息
int | getTableCount() 取数据表的总数
TableInfo | getTableInfo(java.lang.String _sTableName) 取指定数据表的字段信息
java.util.Enumeration | getTableNames() 取所有的数据表名称列表
boolean | isField(java.lang.String _sTableName, java.lang.String _sFieldName) 检测某个字段是否存在于指定的表
void | load(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner) 从指定的数据库中读取所有字段的字段信息，构成字段信息列表
void | load(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner, java.lang.String _sTableName)
static void | main(java.lang.String[] args)
void | notifyAddTable(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner, java.lang.String _sTableName)
void | notifyRemoveTable(java.lang.String _sTableName)
void | removeTableInfo(java.lang.String _sTableName)
void | removeTableInfo(java.lang.String _sTableName, boolean _bSendMsgOfCluster) 删除指定表
void | toHtml(java.sql.Connection _oConn, int _dbType, java.lang.String _sFileName) 将数据库信息，输出到Html文本中
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableInfos

public TableInfos()
构造函数

方法详细信息

clear

public void clear()
清除所有数据

getTableCount

public int getTableCount()
取数据表的总数

返回：

getTableNames

public java.util.Enumeration getTableNames()
取所有的数据表名称列表

返回：

getTableInfo

public TableInfo getTableInfo(java.lang.String _sTableName)
取指定数据表的字段信息

参数：
_sTableName - 表名称
返回：

getFieldInfo

public FieldInfo getFieldInfo(java.lang.String _sTableName,
                              java.lang.String _sFieldName)
取指定数据表中指定字段信息

参数：
_sTableName - 表名称
_sFieldName - 字段名称
返回：

isField

public boolean isField(java.lang.String _sTableName,
                       java.lang.String _sFieldName)
检测某个字段是否存在于指定的表

参数：
_sTableName - 表名称
_sFieldName - 字段名称
返回：

load

public void load(java.sql.Connection _oConn,
                 DBType _dbType,
                 java.lang.String _sDBOwner)
          throws CMyException
从指定的数据库中读取所有字段的字段信息，构成字段信息列表

参数：
_oConn - 数据库连接对象
_dbType - 数据库类型
抛出：
CMyException

load

public void load(java.sql.Connection _oConn,
                 DBType _dbType,
                 java.lang.String _sDBOwner,
                 java.lang.String _sTableName)
          throws CMyException
参数：
_oConn -
_dbType -
_sDBOwner -
_sTableName -
抛出：
CMyException

toHtml

public void toHtml(java.sql.Connection _oConn,
                   int _dbType,
                   java.lang.String _sFileName)
            throws CMyException
将数据库信息，输出到Html文本中

参数：
_oConn - 数据库连接对象
_dbType - 数据库类型
_sFileName - 输出文件名
抛出：
CMyException

notifyAddTable

public void notifyAddTable(java.sql.Connection _oConn,
                           DBType _dbType,
                           java.lang.String _sDBOwner,
                           java.lang.String _sTableName)
                    throws CMyException
抛出：
CMyException

notifyRemoveTable

public void notifyRemoveTable(java.lang.String _sTableName)

main

public static void main(java.lang.String[] args)

removeTableInfo

public void removeTableInfo(java.lang.String _sTableName)
                     throws WCMException
抛出：
WCMException

removeTableInfo

public void removeTableInfo(java.lang.String _sTableName,
                            boolean _bSendMsgOfCluster)
                     throws WCMException
删除指定表

参数：
_sTableName -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeNames

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 TypeNames

java.lang.Object
    继承者  com.trs.infra.util.database.TypeNames

public class TypeNames
extends java.lang.Object

This class maps a type to names. Associations may be marked with a capacity. Calling the get() method with a type and actual size n will return the associated name with smallest capacity >= n, if available and an unmarked default type otherwise. Eg, setting

 names.put(type, "TEXT");
 names.put(type, 255, "VARCHAR($l)");
 names.put(type, 65534, "LONGVARCHAR($l)");
will give you back the following:
  names.get(type)         // --> "TEXT" (default)
  names.get(type,    100) // --> "VARCHAR(100)" (100 is in [0:255])
  names.get(type,   1000) // --> "LONGVARCHAR(1000)" (1000 is in [256:65534])
  names.get(type, 100000) // --> "TEXT" (default)
On the other hand, simply putting
 names.put(type, "VARCHAR($l)");
would result in
  names.get(type)        // --> "VARCHAR($l)" (will cause trouble)
  names.get(type, 100)   // --> "VARCHAR(100)"
  names.get(type, 10000) // --> "VARCHAR(10000)"

作者：
Christoph Beck

构造方法摘要
TypeNames()
方法摘要
java.lang.String | get(int typecode) get default type name for specified type
java.lang.String | get(int typecode, int size, int precision, int scale) get type name for specified type and size
void | put(int typecode, int capacity, java.lang.String value) set a type name for specified type key and capacity
void | put(int typecode, java.lang.String value) set a default type name for specified type key
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TypeNames

public TypeNames()
方法详细信息

get

public java.lang.String get(int typecode)
                     throws WCMException
get default type name for specified type

参数：
typecode - the type key
返回：
the default type name associated with specified key
抛出：
WCMException

get

public java.lang.String get(int typecode,
                            int size,
                            int precision,
                            int scale)
                     throws WCMException
get type name for specified type and size

参数：
typecode - the type key
size - the SQL length
scale - the SQL scale
precision - the SQL precision
返回：
the associated name with smallest capacity >= size, if available and the default type name otherwise
抛出：
WCMException

put

public void put(int typecode,
                int capacity,
                java.lang.String value)
set a type name for specified type key and capacity

参数：
typecode - the type key

put

public void put(int typecode,
                java.lang.String value)
set a default type name for specified type key

参数：
typecode - the type key
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XuguDB

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.database
类 XuguDB

java.lang.Object
    继承者  com.trs.infra.util.database.DBType
        继承者  com.trs.infra.util.database.SQLServerDB
            继承者  com.trs.infra.util.database.XuguDB

public class XuguDB
extends SQLServerDB

Title: TRS 内容协作平台（TRS WCM）
Description:
虚谷数据库
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

字段摘要
static DataType | CLOB
static DataType | INT
static DataType | INTEGER
从类 com.trs.infra.util.database.SQLServerDB 继承的字段
BIGINT, BINARY, BIT, CHAR, DATE, DATETIME, DECIMAL, FLOAT, IMAGE, MONEY, NCHAR, NTEXT, NUMBER, NUMERIC, NVARCHAR, REAL, SMALLDATETIME, SMALLINT, SMALLMONEY, SQL_VARIRANT, TEXT, TIMESTAMP, TINYINT, UNIQUEIDENTIFIER, VARBINARY, VARCHAR, VARCHAR2, WRITE_STR_ENCODING
从类 com.trs.infra.util.database.DBType 继承的字段
DEFAULT_LENGTH, DEFAULT_PRECISION, DEFAULT_SCALE, MAX_PAGE_SIZE, OTHER
构造方法摘要
XuguDB()
XuguDB(java.lang.String name, java.lang.String driver)
方法摘要
 DataType[] getAllDataTypes()
取所有的字段数据类型
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, int p_nFieldIndex)
从数据库中读取Clob/Text型字段的值
 java.lang.String getClob(java.sql.ResultSet p_rsData, boolean p_bJdbcIs2, java.lang.String p_sFieldName)
从数据库中读取Clob/Text型字段的值
 DataType[] getSupportedDataTypes()
取系统处理可以支持的数据类型
 java.lang.String sqlAddField(java.lang.String tableName, java.lang.String fieldName, java.lang.String fieldType, int maxLength, boolean nullable, java.lang.String defaultValue, int scale)
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
 java.lang.String sqlConcatStr(java.lang.String[] ls)
字符串连接函数
 java.lang.String sqlConcatStr(java.lang.String str1, java.lang.String str2)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlConcatStr(java.lang.String str1, java.lang.String str2, java.lang.String str3)
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
 java.lang.String sqlDate(java.lang.String dateTime)
 java.lang.String sqlDateField(java.lang.String dateField)
 java.lang.String sqlDateTime(java.lang.String dateTime, java.lang.String format)
构造SQL语句，用以表示日期时间值
 java.lang.String sqlFilterForClob(java.lang.String fieldName, java.lang.String value)
大字段检索函数
 java.lang.String sqlFilterOneDay(java.lang.String _sFieldName, java.lang.String _sDateTime, java.lang.String _sFormat)
构造SQL语句，用以筛选指定日期
 java.lang.String sqlGetNextId()
 java.lang.String sqlGetSysDate()
取系统时间的内部函数
 java.lang.String sqlModifyField(java.lang.String _sTableName, java.lang.String _sFieldName, int _nFieldType, int _nLengthOrPrecision, boolean _bNullable, int _nScale)
修改指定表指定字段的属性
 java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser, java.lang.String _sDBTableName)
 java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
 java.lang.String sqlRenameField(java.lang.String tableName, java.lang.String oldFieldName, java.lang.String newFieldName)
重命名指定表的指定字段
 java.lang.String sqlRenameTable(java.lang.String oldTableName, java.lang.String newTableName)
重命名指定的表
从类 com.trs.infra.util.database.SQLServerDB 继承的方法
canDropField, canWriteTextDirectly, encodeStrToWrite, getType, initQuerySQL, setClob, setClob
从类 com.trs.infra.util.database.DBType 继承的方法
getCastTypeName, getDataType, getDriverClass, getName, getTypeName, getTypeName, isSupportStoredProc, setClob, setClob, setDriverClass, setStringFieldValue, setStringFieldValue, sqlAddField, sqlAddField, sqlCreateTable, sqlCreateTableWithPrimary, sqlDropField, sqlDropTable, sqlEscapeString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

INT

public static final DataType INT

INTEGER

public static final DataType INTEGER

CLOB

public static final DataType CLOB
构造方法详细信息

XuguDB

public XuguDB()

XuguDB

public XuguDB(java.lang.String name,
              java.lang.String driver)
方法详细信息

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                int p_nFieldIndex)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

覆盖：
类 SQLServerDB 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_nFieldIndex - 字段索引
返回：
抛出：
CMyException

getClob

public java.lang.String getClob(java.sql.ResultSet p_rsData,
                                boolean p_bJdbcIs2,
                                java.lang.String p_sFieldName)
                         throws CMyException
从类 DBType 复制的描述
从数据库中读取Clob/Text型字段的值

覆盖：
类 SQLServerDB 中的 getClob
参数：
p_rsData - 记录集
p_bJdbcIs2 - oracle.jdbc的版本号是否为2.0
若为2.0，则取得CLOB字段值对象时可以使用函数oracle.driver.OracleResult.getClob
否则，使用函数 getCLOB
[参见]Oracle 文档，Oracle8i JDBC Developer's Guide and Reference Release 8.1.5 部分
p_sFieldName - 字段名称
返回：
抛出：
CMyException

sqlGetSysDate

public java.lang.String sqlGetSysDate()
从类 SQLServerDB 复制的描述
取系统时间的内部函数

覆盖：
类 SQLServerDB 中的 sqlGetSysDate
返回：

sqlGetNextId

public java.lang.String sqlGetNextId()
覆盖：
类 SQLServerDB 中的 sqlGetNextId

sqlQueryTableInfos

public java.lang.String sqlQueryTableInfos(java.lang.String _sOwnerUser)
覆盖：
类 SQLServerDB 中的 sqlQueryTableInfos

sqlQueryTableInfo

public java.lang.String sqlQueryTableInfo(java.lang.String _sOwnerUser,
                                          java.lang.String _sDBTableName)
覆盖：
类 SQLServerDB 中的 sqlQueryTableInfo

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String str1,
                                     java.lang.String str2,
                                     java.lang.String str3)
从类 SQLServerDB 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

覆盖：
类 SQLServerDB 中的 sqlConcatStr
参数：
str1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
str2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
str3 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String str1,
                                     java.lang.String str2)
从类 SQLServerDB 复制的描述
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";

覆盖：
类 SQLServerDB 中的 sqlConcatStr
参数：
str1 - 用于连接的SQL语句。必须是字符串常数或者字段名称
str2 - 用于连接的SQL语句。必须是字符串常数或者字段名称
返回：

sqlConcatStr

public java.lang.String sqlConcatStr(java.lang.String[] ls)
从类 SQLServerDB 复制的描述
字符串连接函数

覆盖：
类 SQLServerDB 中的 sqlConcatStr
参数：
ls - 用于连接的SQL语句数组。必须是字符串常数或者字段名称
返回：

sqlDate

public java.lang.String sqlDate(java.lang.String dateTime)
覆盖：
类 SQLServerDB 中的 sqlDate

sqlDateField

public java.lang.String sqlDateField(java.lang.String dateField)
覆盖：
类 SQLServerDB 中的 sqlDateField

sqlDateTime

public java.lang.String sqlDateTime(java.lang.String dateTime,
                                    java.lang.String format)
从类 SQLServerDB 复制的描述
构造SQL语句，用以表示日期时间值

覆盖：
类 SQLServerDB 中的 sqlDateTime
参数：
dateTime - 指定日期值
format - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

sqlFilterForClob

public java.lang.String sqlFilterForClob(java.lang.String fieldName,
                                         java.lang.String value)
从类 SQLServerDB 复制的描述
大字段检索函数

覆盖：
类 SQLServerDB 中的 sqlFilterForClob
参数：
fieldName - 大字段名称
value - 需要检索的值
返回：

sqlAddField

public java.lang.String sqlAddField(java.lang.String tableName,
                                    java.lang.String fieldName,
                                    java.lang.String fieldType,
                                    int maxLength,
                                    boolean nullable,
                                    java.lang.String defaultValue,
                                    int scale)
从类 SQLServerDB 复制的描述
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。如："'abc'"
举例：ALTER TABLE WCMDOCBAK ADD RIGHTDEFINED int DEFAULT 0 NOT NULL

覆盖：
类 SQLServerDB 中的 sqlAddField
参数：
tableName - 表名称
fieldName - 字段名称
fieldType - 字段类型（特别注意：若是字符串等，则需要指定长度，如：nvarchar(10) ）
maxLength - 最大长度
nullable - 是否允许为空
defaultValue - 字段默认值，可缺省（缺省值为null，表示没有指定）
返回：
构造的SQL语句

sqlRenameField

public java.lang.String sqlRenameField(java.lang.String tableName,
                                       java.lang.String oldFieldName,
                                       java.lang.String newFieldName)
从类 DBType 复制的描述
重命名指定表的指定字段

覆盖：
类 SQLServerDB 中的 sqlRenameField
返回：

sqlRenameTable

public java.lang.String sqlRenameTable(java.lang.String oldTableName,
                                       java.lang.String newTableName)
从类 DBType 复制的描述
重命名指定的表

覆盖：
类 SQLServerDB 中的 sqlRenameTable
参数：
oldTableName - 以前的表名
newTableName - 新的表名
返回：

sqlModifyField

public java.lang.String sqlModifyField(java.lang.String _sTableName,
                                       java.lang.String _sFieldName,
                                       int _nFieldType,
                                       int _nLengthOrPrecision,
                                       boolean _bNullable,
                                       int _nScale)
                                throws WCMException
从类 DBType 复制的描述
修改指定表指定字段的属性

覆盖：
类 DBType 中的 sqlModifyField
返回：
抛出：
WCMException

sqlFilterOneDay

public java.lang.String sqlFilterOneDay(java.lang.String _sFieldName,
                                        java.lang.String _sDateTime,
                                        java.lang.String _sFormat)
从类 SQLServerDB 复制的描述
构造SQL语句，用以筛选指定日期

覆盖：
类 SQLServerDB 中的 sqlFilterOneDay
参数：
_sFieldName - 日期字段名
_sDateTime - 指定日期值
_sFormat - 日期值（字符串）格式（仅Oracle等数据库有用）
返回：

getAllDataTypes

public DataType[] getAllDataTypes()
从类 SQLServerDB 复制的描述
取所有的字段数据类型

覆盖：
类 SQLServerDB 中的 getAllDataTypes
返回：

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
从类 SQLServerDB 复制的描述
取系统处理可以支持的数据类型

覆盖：
类 SQLServerDB 中的 getSupportedDataTypes
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.util.database.AndinOraDB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.AndinOraDB
的使用

没有 com.trs.infra.util.database.AndinOraDB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.CAS400CLOB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.CAS400CLOB
的使用

没有 com.trs.infra.util.database.CAS400CLOB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.CDB2DBCLOB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.CDB2DBCLOB
的使用

没有 com.trs.infra.util.database.CDB2DBCLOB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.CDB2DBCLOB2 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.CDB2DBCLOB2
的使用

没有 com.trs.infra.util.database.CDB2DBCLOB2 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.CDBKeyWords 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.CDBKeyWords
的使用

没有 com.trs.infra.util.database.CDBKeyWords 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.CDBText 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.CDBText
的使用

没有 com.trs.infra.util.database.CDBText 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.ClusterDBIdManager 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.ClusterDBIdManager
的使用

没有 com.trs.infra.util.database.ClusterDBIdManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.CMysqlText 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.CMysqlText
的使用

没有 com.trs.infra.util.database.CMysqlText 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.ConnectionPool 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.ConnectionPool
的使用

没有 com.trs.infra.util.database.ConnectionPool 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.COracleCLOB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.COracleCLOB
的使用

没有 com.trs.infra.util.database.COracleCLOB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.CSQLText 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.CSQLText
的使用

没有 com.trs.infra.util.database.CSQLText 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DamengDB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DamengDB
的使用

没有 com.trs.infra.util.database.DamengDB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DataType 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DataType
的使用

使用 DataType 的软件包
com.trs.ajaxservice
com.trs.cms.content
com.trs.components.wcm.content.persistent
com.trs.infra.util.database
com.trs.service
com.trs.service.impl

com.trs.ajaxservice 中 DataType 的使用

返回 DataType 的 com.trs.ajaxservice 中的方法
 DataType[] ExtendFieldServiceProvider.getSupportedDataTypes()
获取系统支持的数据类型

com.trs.cms.content 中 DataType 的使用

返回 DataType 的 com.trs.cms.content 中的方法
 DataType ExtendedField.getType()
获取扩展字段类型对象

com.trs.components.wcm.content.persistent 中 DataType 的使用

返回 DataType 的 com.trs.components.wcm.content.persistent 中的方法
 DataType ContentExtField.getType()
获取扩展字段类型对象

com.trs.infra.util.database 中 DataType 的使用

声明为 DataType 的 com.trs.infra.util.database 中的字段
static DataType | OracleDB.BFILE 定义Oracle中的字段类型：BFILE
static DataType | DB2UDB.BIGINT 定义SQL Server中的字段类型：BIGINT
static DataType | DB2UDB2.BIGINT 定义SQL Server中的字段类型：BIGINT
static DataType | SQLServerDB.BIGINT 定义SQL Server中的字段类型：BIGINT
static DataType | MysqlDB.BIGINT
static DataType | DB2AS400DB.BIGINT 定义SQL Server中的字段类型：BIGINT
static DataType | SQLServerDB.BINARY 定义SQL Server中的字段类型：BINARY
static DataType | SybaseASEWithJtds.BINARY 定义SQL Server中的字段类型：BINARY
static DataType | SybaseASE.BINARY 定义SQL Server中的字段类型：BINARY
static DataType | SQLServerDB.BIT 定义SQL Server中的字段类型：BIT
static DataType | SybaseASEWithJtds.BIT 定义SQL Server中的字段类型：BIT
static DataType | MysqlDB.BIT
static DataType | SybaseASE.BIT 定义SQL Server中的字段类型：BIT
static DataType | DB2UDB.BLOB 定义SQL Server中的字段类型：BLOB
static DataType | DB2UDB2.BLOB 定义SQL Server中的字段类型：BLOB
static DataType | MysqlDB.BLOB
static DataType | DB2AS400DB.BLOB 定义SQL Server中的字段类型：BLOB
static DataType | OracleDB.BLOB 定义Oracle中的字段类型：BLOB
static DataType | MysqlDB.BOOLEAN
static DataType | DB2UDB.CHAR 定义SQL Server中的字段类型：CHAR
static DataType | DB2UDB2.CHAR 定义SQL Server中的字段类型：CHAR
static DataType | SQLServerDB.CHAR 定义SQL Server中的字段类型：CHAR
static DataType | SybaseASEWithJtds.CHAR 定义SQL Server中的字段类型：CHAR
static DataType | MysqlDB.CHAR
static DataType | SybaseASE.CHAR 定义SQL Server中的字段类型：CHAR
static DataType | DB2AS400DB.CHAR 定义SQL Server中的字段类型：CHAR
static DataType | OracleDB.CHAR 定义Oracle中的字段类型：CHAR
static DataType | DB2UDB.CLOB 定义SQL Server中的字段类型：CLOB
static DataType | DB2UDB2.CLOB 定义SQL Server中的字段类型：CLOB
static DataType | XuguDB.CLOB
static DataType | DB2AS400DB.CLOB 定义SQL Server中的字段类型：CLOB
static DataType | OracleDB.CLOB 定义Oracle中的字段类型：CLOB
static DataType | DB2UDB.DATE 定义SQL Server中的字段类型：DATE
static DataType | DB2UDB2.DATE 定义SQL Server中的字段类型：DATE
static DataType | SQLServerDB.DATE
static DataType | MysqlDB.DATE
static DataType | DB2AS400DB.DATE 定义SQL Server中的字段类型：DATE
static DataType | KingBaseDB.DATE 定义SQL Server中的字段类型：DATE
static DataType | OracleDB.DATE 定义Oracle中的字段类型：DATE
static DataType | DB2UDB2.DATETIME
static DataType | SQLServerDB.DATETIME 定义SQL Server中的字段类型：DATETIME
static DataType | SybaseASEWithJtds.DATETIME 定义SQL Server中的字段类型：DATETIME
static DataType | MysqlDB.DATETIME
static DataType | SybaseASE.DATETIME 定义SQL Server中的字段类型：DATETIME
static DataType | DB2AS400DB.DATETIME
static DataType | OracleDB.DATETIME 定义Oracle中的字段类型：DATE
static DataType | DB2UDB.DBCLOB 定义SQL Server中的字段类型：DBCLOB
static DataType | DB2UDB2.DBCLOB 定义SQL Server中的字段类型：DBCLOB
static DataType | DB2AS400DB.DBCLOB 定义SQL Server中的字段类型：DBCLOB
static DataType | DB2UDB.DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | DB2UDB2.DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | SQLServerDB.DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | SybaseASEWithJtds.DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | MysqlDB.DECIMAL
static DataType | SybaseASE.DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | DB2AS400DB.DECIMAL 定义SQL Server中的字段类型：DECIMAL
static DataType | DB2UDB.FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | DB2UDB2.FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | SQLServerDB.FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | SybaseASEWithJtds.FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | MysqlDB.FLOAT
static DataType | SybaseASE.FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | DB2AS400DB.FLOAT 定义SQL Server中的字段类型：FLOAT
static DataType | OracleDB.FLOAT 定义Oracle中的字段类型：INT 和SQLServer
static DataType | SQLServerDB.IMAGE 定义SQL Server中的字段类型：IMAGE
static DataType | SybaseASEWithJtds.IMAGE 定义SQL Server中的字段类型：IMAGE
static DataType | SybaseASE.IMAGE 定义SQL Server中的字段类型：IMAGE
static DataType | DB2UDB.INT 定义SQL Server中的字段类型：INT
static DataType | DB2UDB2.INT 定义SQL Server中的字段类型：INT
static DataType | SQLServerDB.INT 定义SQL Server中的字段类型：INT
static DataType | SybaseASEWithJtds.INT 定义SQL Server中的字段类型：INT
static DataType | SybaseASE.INT 定义SQL Server中的字段类型：INT
static DataType | XuguDB.INT
static DataType | DB2AS400DB.INT 定义SQL Server中的字段类型：INT
static DataType | OracleDB.INT 定义Oracle中的字段类型：INT 和SQLServer
static DataType | MysqlDB.INTEGER
static DataType | XuguDB.INTEGER
static DataType | KingBaseDB.INTEGER 定义SQL Server中的字段类型：INT
static DataType | OracleDB.LONG 定义Oracle中的字段类型：LONG
static DataType | MysqlDB.LONGBLOB
static DataType | OracleDB.LONGRAW 定义Oracle中的字段类型：LONGRAW
static DataType | MysqlDB.LONGTEXT
static DataType | MysqlDB.MEDIUBLOB
static DataType | MysqlDB.MEDIUMTEXT
static DataType | SQLServerDB.MONEY 定义SQL Server中的字段类型：MONEY
static DataType | SybaseASEWithJtds.MONEY 定义SQL Server中的字段类型：MONEY
static DataType | SybaseASE.MONEY 定义SQL Server中的字段类型：MONEY
static DataType | DamengDB.NCHAR
static DataType | SQLServerDB.NCHAR 定义SQL Server中的字段类型：NCHAR
static DataType | SybaseASEWithJtds.NCHAR 定义SQL Server中的字段类型：NCHAR
static DataType | SybaseASE.NCHAR 定义SQL Server中的字段类型：NCHAR
static DataType | OracleDB.NCLOB 定义Oracle中的字段类型：NCLOB
static DataType | DB2UDB2.NINT
static DataType | DB2AS400DB.NINT
static DataType | DamengDB.NTEXT
static DataType | SQLServerDB.NTEXT 定义SQL Server中的字段类型：NTEXT
static DataType | SQLServerDB.NUMBER
static DataType | OracleDB.NUMBER 定义Oracle中的字段类型：NUMBER
static DataType | DB2UDB2.NUMERIC
static DataType | SQLServerDB.NUMERIC 定义SQL Server中的字段类型：NUMERIC
static DataType | SybaseASEWithJtds.NUMERIC 定义SQL Server中的字段类型：NUMERIC
static DataType | MysqlDB.NUMERIC
static DataType | SybaseASE.NUMERIC 定义SQL Server中的字段类型：NUMERIC
static DataType | DB2AS400DB.NUMERIC 定义ASS400中的字段类型：NUMERIC
static DataType | DamengDB.NVARCHAR
static DataType | DB2UDB2.NVARCHAR
static DataType | SQLServerDB.NVARCHAR 定义SQL Server中的字段类型：NVARCHAR
static DataType | SybaseASEWithJtds.NVARCHAR 定义SQL Server中的字段类型：NVARCHAR
static DataType | MysqlDB.NVARCHAR
static DataType | SybaseASE.NVARCHAR 定义SQL Server中的字段类型：NVARCHAR
static DataType | DB2AS400DB.NVARCHAR
static DataType | KingBaseDB.NVARCHAR 定义SQL Server中的字段类型：NVARCHAR
static DataType | OracleDB.NVARCHAR 定义Oracle中的字段类型：NVARCHAR 和SQLServer
static DataType | DBType.OTHER 其他数据类型
static DataType | OracleDB.RAW 定义Oracle中的字段类型：RAW
static DataType | DB2UDB.REAL 定义SQL Server中的字段类型：REAL
static DataType | DB2UDB2.REAL 定义SQL Server中的字段类型：REAL
static DataType | SQLServerDB.REAL 定义SQL Server中的字段类型：REAL
static DataType | SybaseASEWithJtds.REAL 定义SQL Server中的字段类型：REAL
static DataType | SybaseASE.REAL 定义SQL Server中的字段类型：REAL
static DataType | DB2AS400DB.REAL 定义SQL Server中的字段类型：REAL
static DataType | OracleDB.ROWID 定义Oracle中的字段类型：ROWID
static DataType | SQLServerDB.SMALLDATETIME 定义SQL Server中的字段类型：SMALLDATETIME
static DataType | SybaseASEWithJtds.SMALLDATETIME 定义SQL Server中的字段类型：SMALLDATETIME
static DataType | SybaseASE.SMALLDATETIME 定义SQL Server中的字段类型：SMALLDATETIME
static DataType | DB2UDB.SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | DB2UDB2.SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | SQLServerDB.SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | SybaseASEWithJtds.SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | MysqlDB.SMALLINT
static DataType | SybaseASE.SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | DB2AS400DB.SMALLINT 定义SQL Server中的字段类型：SMALLINT
static DataType | OracleDB.SMALLINT 定义Oracle中的字段类型：SMALLINT
static DataType | SQLServerDB.SMALLMONEY 定义SQL Server中的字段类型：SMALLMONEY
static DataType | SybaseASEWithJtds.SMALLMONEY 定义SQL Server中的字段类型：SMALLMONEY
static DataType | SybaseASE.SMALLMONEY 定义SQL Server中的字段类型：SMALLMONEY
static DataType | DB2UDB.SQL_VARIRANT 定义SQL Server中的字段类型：SQL_VARIRANT
static DataType | DB2UDB2.SQL_VARIRANT 定义SQL Server中的字段类型：SQL_VARIRANT
static DataType | SQLServerDB.SQL_VARIRANT 定义SQL Server中的字段类型：SQL_VARIRANT
static DataType | DB2AS400DB.SQL_VARIRANT 定义SQL Server中的字段类型：SQL_VARIRANT
static DataType | SQLServerDB.TEXT 定义SQL Server中的字段类型：TEXT
static DataType | SybaseASEWithJtds.TEXT 定义SQL Server中的字段类型：TEXT
static DataType | MysqlDB.TEXT
static DataType | SybaseASE.TEXT 定义SQL Server中的字段类型：TEXT
static DataType | DB2UDB.TIME 定义SQL Server中的字段类型：TIME
static DataType | DB2UDB2.TIME 定义SQL Server中的字段类型：TIME
static DataType | MysqlDB.TIME
static DataType | DB2AS400DB.TIME 定义SQL Server中的字段类型：TIME
static DataType | KingBaseDB.TIME 定义SQL Server中的字段类型：TIME
static DataType | DB2UDB.TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | DB2UDB2.TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | SQLServerDB.TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | SybaseASEWithJtds.TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | MysqlDB.TIMESTAMP
static DataType | SybaseASE.TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | DB2AS400DB.TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | KingBaseDB.TIMESTAMP 定义SQL Server中的字段类型：TIMESTAMP
static DataType | MysqlDB.TINYBLOB
static DataType | SQLServerDB.TINYINT 定义SQL Server中的字段类型：TINYINT
static DataType | SybaseASEWithJtds.TINYINT 定义SQL Server中的字段类型：TINYINT
static DataType | MysqlDB.TINYINT
static DataType | SybaseASE.TINYINT 定义SQL Server中的字段类型：TINYINT
static DataType | KingBaseDB.TINYINT
static DataType | MysqlDB.TINYTEXT
static DataType | DB2UDB.UNIQUEIDENTIFIER 定义SQL Server中的字段类型：UNIQUEIDENTIFIER
static DataType | DB2UDB2.UNIQUEIDENTIFIER 定义SQL Server中的字段类型：UNIQUEIDENTIFIER
static DataType | SQLServerDB.UNIQUEIDENTIFIER 定义SQL Server中的字段类型：UNIQUEIDENTIFIER
static DataType | DB2AS400DB.UNIQUEIDENTIFIER 定义SQL Server中的字段类型：UNIQUEIDENTIFIER
static DataType | SQLServerDB.VARBINARY 定义SQL Server中的字段类型：VARBINARY
static DataType | SybaseASEWithJtds.VARBINARY 定义SQL Server中的字段类型：VARBINARY
static DataType | MysqlDB.VARBINARY
static DataType | SybaseASE.VARBINARY 定义SQL Server中的字段类型：VARBINARY
static DataType | DB2UDB.VARCHAR 定义SQL Server中的字段类型：VARCHAR
static DataType | DB2UDB2.VARCHAR 定义SQL Server中的字段类型：VARCHAR
static DataType | SQLServerDB.VARCHAR 定义SQL Server中的字段类型：VARCHAR
static DataType | SybaseASEWithJtds.VARCHAR 定义SQL Server中的字段类型：VARCHAR
static DataType | MysqlDB.VARCHAR
static DataType | SybaseASE.VARCHAR 定义SQL Server中的字段类型：VARCHAR
static DataType | DB2AS400DB.VARCHAR 定义SQL Server中的字段类型：VARCHAR
static DataType | KingBaseDB.VARCHAR 定义SQL Server中的字段类型：VARCHAR
static DataType | SQLServerDB.VARCHAR2
static DataType | OracleDB.VARCHAR2 定义Oracle中的字段类型：VARCHAR2

返回 DataType 的 com.trs.infra.util.database 中的方法
DataType[] | DB2UDB.getAllDataTypes() 取所有的字段数据类型
DataType[] | DB2UDB2.getAllDataTypes() 取所有的字段数据类型
DataType[] | SQLServerDB.getAllDataTypes() 取所有的字段数据类型
DataType[] | SybaseASEWithJtds.getAllDataTypes() 取所有的字段数据类型
abstract DataType[] | DBType.getAllDataTypes() 取所有的字段数据类型
DataType[] | MysqlDB.getAllDataTypes() 取所有的字段数据类型
DataType[] | SybaseASE.getAllDataTypes() 取所有的字段数据类型
DataType[] | XuguDB.getAllDataTypes()
DataType[] | DB2AS400DB.getAllDataTypes() 取所有的字段数据类型
DataType[] | KingBaseDB.getAllDataTypes() 取所有的字段数据类型
DataType[] | OracleDB.getAllDataTypes() 取所有的字段数据类型
DataType | FieldInfo.getDataType() 取数据类型编号
DataType | DBType.getDataType(java.lang.String _name) 取指定名字的字段数据类型
DataType[] | DB2UDB.getSupportedDataTypes() 取系统处理可以支持的数据类型
DataType[] | DB2UDB2.getSupportedDataTypes() 取系统处理可以支持的数据类型
DataType[] | SQLServerDB.getSupportedDataTypes() 取系统处理可以支持的数据类型
DataType[] | SybaseASEWithJtds.getSupportedDataTypes() 取系统处理可以支持的数据类型
abstract DataType[] | DBType.getSupportedDataTypes() 取系统处理可以支持的数据类型
DataType[] | MysqlDB.getSupportedDataTypes() 取系统处理可以支持的数据类型
DataType[] | SybaseASE.getSupportedDataTypes() 取系统处理可以支持的数据类型
DataType[] | XuguDB.getSupportedDataTypes()
DataType[] | DB2AS400DB.getSupportedDataTypes() 取系统处理可以支持的数据类型
DataType[] | OracleDB.getSupportedDataTypes() 取系统处理可以支持的数据类型

参数类型为 DataType 的 com.trs.infra.util.database 中的方法
static java.lang.String DataType.toTypeDescription(DataType _currDataType)

com.trs.service 中 DataType 的使用

返回 DataType 的 com.trs.service 中的方法
 DataType[] IDBService.getSupportedDataTypes()

com.trs.service.impl 中 DataType 的使用

返回 DataType 的 com.trs.service.impl 中的方法
 DataType[] DBService.getSupportedDataTypes()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DB2AS400DB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DB2AS400DB
的使用

使用 DB2AS400DB 的软件包
com.trs.infra.util.database

com.trs.infra.util.database 中 DB2AS400DB 的使用

声明为 DB2AS400DB 的 com.trs.infra.util.database 中的字段
static DB2AS400DB DBTypes.db2AS400
数据库类型对象：DB2AS400DB(DB2 Type4)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DB2ReorgUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DB2ReorgUtil
的使用

没有 com.trs.infra.util.database.DB2ReorgUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DB2UDB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DB2UDB
的使用

使用 DB2UDB 的软件包
com.trs.infra.util.database

com.trs.infra.util.database 中 DB2UDB 的使用

声明为 DB2UDB 的 com.trs.infra.util.database 中的字段
static DB2UDB DBTypes.db2Instance
数据库类型对象：DB2UDB

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DB2UDB2 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DB2UDB2
的使用

使用 DB2UDB2 的软件包
com.trs.infra.util.database

com.trs.infra.util.database 中 DB2UDB2 的使用

com.trs.infra.util.database 中 DB2UDB2 的子类
 class DB2UDBV9
Title: TRS 内容协作平台（TRS WCM）
Description:
DB2 UDB V9+
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

声明为 DB2UDB2 的 com.trs.infra.util.database 中的字段
static DB2UDB2 DBTypes.db2Instance2
数据库类型对象：DB2UDB2(DB2 Type4)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DB2UDBV9 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DB2UDBV9
的使用

没有 com.trs.infra.util.database.DB2UDBV9 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DBIdManager 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DBIdManager
的使用

使用 DBIdManager 的软件包
com.trs.infra.persistent.db
com.trs.infra.util.database

com.trs.infra.persistent.db 中 DBIdManager 的使用

返回 DBIdManager 的 com.trs.infra.persistent.db 中的方法
 DBIdManager DBManager.getDBIdManager()
获取数据表ID管理器

com.trs.infra.util.database 中 DBIdManager 的使用

返回 DBIdManager 的 com.trs.infra.util.database 中的方法
 DBIdManager DBIdManager.load(java.sql.Connection _oConn, java.lang.String _sGetNextIdSQL)
从数据库中装载ID信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DBIdManager.IdSeq 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DBIdManager.IdSeq
的使用

使用 DBIdManager.IdSeq 的软件包
com.trs.infra.util.database

com.trs.infra.util.database 中 DBIdManager.IdSeq 的使用

返回 DBIdManager.IdSeq 的 com.trs.infra.util.database 中的方法
DBIdManager.IdSeq | DBIdManager.IdSeq.setCacheSize(int _cacheSize) 设置缓冲池大小
DBIdManager.IdSeq | DBIdManager.IdSeq.setNextId(int _nextId) 设置下一个有效的ID值

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DBType 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DBType
的使用

使用 DBType 的软件包
com.trs.infra.persistent.db
com.trs.infra.util.database

com.trs.infra.persistent.db 中 DBType 的使用

返回 DBType 的 com.trs.infra.persistent.db 中的方法
DBType | DBManager.getDBType() 获取当前的数据库类型对象的实现（对象的路径由配置文件中定义）
DBType | DBConnectionConfig.getDBType() 依据当前连接配置对象的className属性，获取DBType对象实例

com.trs.infra.util.database 中 DBType 的使用

com.trs.infra.util.database 中 DBType 的子类
class | AndinOraDB Title: TRS 内容协作平台（TRS WCM） Description: Andin加密处理,Oracle数据库.
class | DamengDB Title: TRS 内容协作平台（TRS WCM） Description: 达梦 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DB2AS400DB
class | DB2UDB
class | DB2UDB2
class | DB2UDBV9 Title: TRS 内容协作平台（TRS WCM） Description: DB2 UDB V9+ Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | KingBaseDB Title: TRS 内容协作平台（TRS WCM） Description: 人大金仓数据库 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | MysqlDB Title: TRS 内容协作平台（TRS WCM） Description: msql 数据库,使用mysql-connector-java-5.0.4-bin.jar驱动 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | OracleDB
class | OracleDB11G Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | SQLServerDB
class | SybaseASE
class | SybaseASEWithJtds Title: TRS 内容协作平台（TRS WCM） Description: SybaseASE 数据库,使用jtds驱动 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | XuguDB Title: TRS 内容协作平台（TRS WCM） Description: 虚谷数据库 Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

返回 DBType 的 com.trs.infra.util.database 中的方法
DBType | CDBText.getDBType() 获取数据库类型对象
static DBType | DBTypes.getDBType(int _nDBType) 通过指定数据库类型获取数据库类型对象
DBType | DBType.setDriverClass(java.lang.String _sDriverClass) 设置数据库默认的驱动程序库

参数类型为 DBType 的 com.trs.infra.util.database 中的方法
void | TableInfos.load(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner) 从指定的数据库中读取所有字段的字段信息，构成字段信息列表
void | TableInfos.load(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner, java.lang.String _sTableName)
void | TableInfos.notifyAddTable(java.sql.Connection _oConn, DBType _dbType, java.lang.String _sDBOwner, java.lang.String _sTableName)
void | CDBText.setDBType(DBType type)

参数类型为 DBType 的 com.trs.infra.util.database 中的构造方法
CDBText(DBType _dBType)
CDBText(DBType _dBType, java.lang.String _sText)
FieldInfo(DBType _dbType, java.lang.String _dataTypeName, int _dataLength, boolean _nullable, int _columnID, java.lang.String _dataDefault, int _dataScale)
构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.DBTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.DBTypes
的使用

没有 com.trs.infra.util.database.DBTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.FieldInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.FieldInfo
的使用

使用 FieldInfo 的软件包
com.trs.infra.persistent.db
com.trs.infra.util.database
com.trs.wcm.old

com.trs.infra.persistent.db 中 FieldInfo 的使用

返回 FieldInfo 的 com.trs.infra.persistent.db 中的方法
 FieldInfo DBManager.getFieldInfo(java.lang.String _tableName, java.lang.String _fieldName)
取得值定数据表中指定字段信息

com.trs.infra.util.database 中 FieldInfo 的使用

返回 FieldInfo 的 com.trs.infra.util.database 中的方法
FieldInfo | TableInfo.getFieldInfo(java.lang.String _sFieldName) 根据字段名，提取字段信息对象
FieldInfo | TableInfos.getFieldInfo(java.lang.String _sTableName, java.lang.String _sFieldName) 取指定数据表中指定字段信息

参数类型为 FieldInfo 的 com.trs.infra.util.database 中的方法
 void TableInfo.putFieldInfo(java.lang.String _sFieldName, FieldInfo _fieldInfo)
在数据表字段信息集合中存入字段信息

com.trs.wcm.old 中 FieldInfo 的使用

返回 FieldInfo 的 com.trs.wcm.old 中的方法
 FieldInfo WCMFormFields.getFieldInfo()
获取表单元素所对应的数据库字段类型对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.KingBaseDB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.KingBaseDB
的使用

没有 com.trs.infra.util.database.KingBaseDB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.MysqlDB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.MysqlDB
的使用

使用 MysqlDB 的软件包
com.trs.infra.util.database

com.trs.infra.util.database 中 MysqlDB 的使用

声明为 MysqlDB 的 com.trs.infra.util.database 中的字段
static MysqlDB DBTypes.MYSQLDB
数据库类型对象：Mysql

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.OracleDB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.OracleDB
的使用

使用 OracleDB 的软件包
com.trs.infra.util.database

com.trs.infra.util.database 中 OracleDB 的使用

com.trs.infra.util.database 中 OracleDB 的子类
class | AndinOraDB Title: TRS 内容协作平台（TRS WCM） Description: Andin加密处理,Oracle数据库.
class | OracleDB11G Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

声明为 OracleDB 的 com.trs.infra.util.database 中的字段
static OracleDB DBTypes.ORACLEDB
数据库类型对象：OracleDB

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.OracleDB11G 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.OracleDB11G
的使用

没有 com.trs.infra.util.database.OracleDB11G 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.SQLServerDB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.SQLServerDB
的使用

使用 SQLServerDB 的软件包
com.trs.infra.util.database

com.trs.infra.util.database 中 SQLServerDB 的使用

com.trs.infra.util.database 中 SQLServerDB 的子类
class | DamengDB Title: TRS 内容协作平台（TRS WCM） Description: 达梦 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | KingBaseDB Title: TRS 内容协作平台（TRS WCM） Description: 人大金仓数据库 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | XuguDB Title: TRS 内容协作平台（TRS WCM） Description: 虚谷数据库 Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

声明为 SQLServerDB 的 com.trs.infra.util.database 中的字段
static SQLServerDB DBTypes.SQLSERVERDB
数据库类型对象：SQLServerDB

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.SybaseASE 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.SybaseASE
的使用

使用 SybaseASE 的软件包
com.trs.infra.util.database

com.trs.infra.util.database 中 SybaseASE 的使用

声明为 SybaseASE 的 com.trs.infra.util.database 中的字段
static SybaseASE DBTypes.dbSybaseASE
数据库类型对象：SybaseASE

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.SybaseASEText 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.SybaseASEText
的使用

没有 com.trs.infra.util.database.SybaseASEText 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.SybaseASEWithJtds 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.SybaseASEWithJtds
的使用

没有 com.trs.infra.util.database.SybaseASEWithJtds 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.TableInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.TableInfo
的使用

使用 TableInfo 的软件包
com.trs.infra.persistent.db
com.trs.infra.util.database

com.trs.infra.persistent.db 中 TableInfo 的使用

返回 TableInfo 的 com.trs.infra.persistent.db 中的方法
 TableInfo DBManager.getTableInfo(java.lang.String _tableName)
取指定数据表的信息

com.trs.infra.util.database 中 TableInfo 的使用

返回 TableInfo 的 com.trs.infra.util.database 中的方法
 TableInfo TableInfos.getTableInfo(java.lang.String _sTableName)
取指定数据表的字段信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.TableInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.TableInfos
的使用

使用 TableInfos 的软件包
com.trs.infra.persistent.db

com.trs.infra.persistent.db 中 TableInfos 的使用

返回 TableInfos 的 com.trs.infra.persistent.db 中的方法
 TableInfos DBManager.getTableInfos()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.TypeNames 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.TypeNames
的使用

没有 com.trs.infra.util.database.TypeNames 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.database.XuguDB 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.database.XuguDB
的使用

没有 com.trs.infra.util.database.XuguDB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CMyEmail

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 CMyEmail

java.lang.Object
    继承者  com.trs.infra.util.email.CMyEmail

public class CMyEmail
extends java.lang.Object

字段摘要
static int | FORMAT_HTML
static int | FORMAT_TEXT
static java.lang.String | MAIL_HTML_SEPARATOR
static java.lang.String | MAIL_SEPARATOR
构造方法摘要
CMyEmail()
默认构造函数
方法摘要
void | addAttachedFile(java.lang.String _sAbsoluteFileName)
void | addAttachedFile(java.lang.String _sAbsoluteFileName, java.lang.String _sFileName)
java.lang.String | composeMail() 通过邮件已经设置的信息，构造邮件头和邮件正文
java.lang.String | getAttachedFile()
java.util.HashMap | getAttatchedFileList()
java.lang.String | getBcc()
java.lang.String | getBody()
java.lang.String | getCc()
java.lang.String | getFrom()
java.lang.String | getFromUser() 获取发件人的显示名称
int | getMailFormat()
boolean | getMimeMail()
java.lang.String | getReplyTo()
java.lang.String | getSubject()
java.lang.String | getTo()
java.lang.String | makeMailData()
void | setAttachedFile(java.lang.String _sAbsoluteFileName) 添加附件
void | setAttachedFile(java.lang.String _sAbsoluteFileName, java.lang.String _sSrcFileName)
void | setBcc(java.lang.String _sBcc) 设置密送地址
void | setBody(java.lang.String _sBody) 设置邮件内容
void | setCc(java.lang.String _sCc) 设置抄送地址
void | setFrom(java.lang.String _sFrom) 设置发邮件人地址
void | setFromUser(java.lang.String _sUserName) 设置发件人的显示名称
void | setMailFormat(int _iMailFormat) 设置邮件格式
void | setMimeMail(boolean _bMimeMail) 设置是否对邮件进行MIME编码
void | setReplyTo(java.lang.String _sReplyTo) 设置回复地址
void | setSubject(java.lang.String _sSubject) 设置邮件主题
void | setTo(java.lang.String _sTo) 设置收信人地址
void | validate() 验证邮件是否合法
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FORMAT_HTML

public static final int FORMAT_HTML
另请参见：
常量字段值

FORMAT_TEXT

public static final int FORMAT_TEXT
另请参见：
常量字段值

MAIL_SEPARATOR

public static final java.lang.String MAIL_SEPARATOR
另请参见：
常量字段值

MAIL_HTML_SEPARATOR

public static final java.lang.String MAIL_HTML_SEPARATOR
另请参见：
常量字段值
构造方法详细信息

CMyEmail

public CMyEmail()
默认构造函数

方法详细信息

setFrom

public void setFrom(java.lang.String _sFrom)
设置发邮件人地址

参数：
_sFrom - 发邮件人地址

getFrom

public java.lang.String getFrom()

setFromUser

public void setFromUser(java.lang.String _sUserName)
设置发件人的显示名称

参数：
_sUserName -

getFromUser

public java.lang.String getFromUser()
获取发件人的显示名称

返回：

setReplyTo

public void setReplyTo(java.lang.String _sReplyTo)
设置回复地址

参数：
_sReplyTo - 回复地址

getReplyTo

public java.lang.String getReplyTo()

setTo

public void setTo(java.lang.String _sTo)
设置收信人地址

参数：
_sTo - 收信人地址

getTo

public java.lang.String getTo()

setCc

public void setCc(java.lang.String _sCc)
设置抄送地址

参数：
_sCc - 抄送地址

getCc

public java.lang.String getCc()

setBcc

public void setBcc(java.lang.String _sBcc)
设置密送地址

参数：
_sBcc - 密送地址

getBcc

public java.lang.String getBcc()

setSubject

public void setSubject(java.lang.String _sSubject)
设置邮件主题

参数：
_sSubject - 邮件主题

getSubject

public java.lang.String getSubject()

setBody

public void setBody(java.lang.String _sBody)
设置邮件内容

参数：
_sBody - 邮件内容

getBody

public java.lang.String getBody()

setAttachedFile

public void setAttachedFile(java.lang.String _sAbsoluteFileName)
添加附件

参数：
_sAbsoluteFileName - 文件名
抛出：
CMyException

setAttachedFile

public void setAttachedFile(java.lang.String _sAbsoluteFileName,
                            java.lang.String _sSrcFileName)

getAttachedFile

public java.lang.String getAttachedFile()

addAttachedFile

public void addAttachedFile(java.lang.String _sAbsoluteFileName)

addAttachedFile

public void addAttachedFile(java.lang.String _sAbsoluteFileName,
                            java.lang.String _sFileName)

getAttatchedFileList

public java.util.HashMap getAttatchedFileList()

setMailFormat

public void setMailFormat(int _iMailFormat)
设置邮件格式

参数：
_iMailFormat - 邮件格式： 1: plain text; 0: MIME format

getMailFormat

public int getMailFormat()

setMimeMail

public void setMimeMail(boolean _bMimeMail)
设置是否对邮件进行MIME编码

参数：
_bMimeMail -

getMimeMail

public boolean getMimeMail()

composeMail

public java.lang.String composeMail()
通过邮件已经设置的信息，构造邮件头和邮件正文

返回：
邮件头和邮件正文
抛出：
CMyMailException

makeMailData

public java.lang.String makeMailData()

validate

public void validate()
              throws CMyMailException
验证邮件是否合法

抛出：
CMyMailException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CMyMailException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 CMyMailException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.infra.util.CMyException
                继承者  com.trs.infra.util.email.CMyMailException
所有已实现的接口：
java.io.Serializable
public class CMyMailException
extends CMyException

Title: TRS 内容协作平台（TRS WCM）
Description:
邮件相关的异常信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
CMyMailException()
CMyMailException(java.lang.String _sMsg)
方法摘要
从类 com.trs.infra.util.CMyException 继承的方法
getErrNo, getErrNoMsg, getLocalizedMessage, getMessage, getMyMessage, getRootCause, getStackTraceText, getStackTraceText, main, printStackTrace, printStackTrace, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getStackTrace, initCause, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMyMailException

public CMyMailException()

CMyMailException

public CMyMailException(java.lang.String _sMsg)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMyMailLog

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 CMyMailLog

java.lang.Object
    继承者  com.trs.infra.util.email.CMyMailLog

public class CMyMailLog
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
邮件相关的日志信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | TYPE_RECEIVE_LOG 接收日志类型
static int | TYPE_SEND_LOG 发送日志类型
构造方法摘要
CMyMailLog()
方法摘要
void | appendSendLogs(java.lang.String _sLog) 在日志中添加一行，自动加上回车换行标志
java.lang.String | getLog()
void | recordSendLogs(java.lang.String _sLog, int _nType) 根据类型，记录邮件日志
void | setLog(java.lang.String sLog)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_SEND_LOG

public static final int TYPE_SEND_LOG
发送日志类型

另请参见：
常量字段值

TYPE_RECEIVE_LOG

public static final int TYPE_RECEIVE_LOG
接收日志类型

另请参见：
常量字段值
构造方法详细信息

CMyMailLog

public CMyMailLog()
方法详细信息

setLog

public void setLog(java.lang.String sLog)
参数：
authLog -

getLog

public java.lang.String getLog()
返回：

appendSendLogs

public void appendSendLogs(java.lang.String _sLog)
在日志中添加一行，自动加上回车换行标志

参数：
_sLog -

recordSendLogs

public void recordSendLogs(java.lang.String _sLog,
                           int _nType)
根据类型，记录邮件日志

参数：
_sLog -
_nType -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CMySMTPServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 CMySMTPServer

java.lang.Object
    继承者  com.trs.infra.util.CMyXMLElement
        继承者  com.trs.infra.util.CMyClassConfig
            继承者  com.trs.infra.util.email.CMySMTPServer

public class CMySMTPServer
extends CMyClassConfig

Title: TRS 内容协作平台（TRS WCM）
Description:
SMTP服务器及其的相关属性设置管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CMySMTPServer()
方法摘要
boolean | canAuth() 判断SMTP服务器的设置，是否能够进行身份验证
java.net.Socket | createSocket()
static CMySMTPServer | getDefaultSMTPServer() 从配置文件中，得到默认的SMTP服务器的配置
java.lang.String | getPassword()
java.lang.String | getServerName()
int | getServerPort()
static CMySMTPServer | getSMTPServerByName(java.lang.String _sServerName) 从配置文件中，根据邮件服务器的名称，得到邮件服务器的配置
java.lang.String | getUserName()
boolean | isSSLServer()
boolean | needAuth()
void | setAuth(boolean auth)
void | setPassword(java.lang.String password)
void | setServerName(java.lang.String serverName)
void | setServerPort(int serverPort)
void | setSMTPConfig(SMTPServerConfig _mySMTPConfig)
void | setSSLServer(boolean _bIsSSLServer)
void | setUserName(java.lang.String userName)
java.lang.String | toString()
void | validate() 判断当前配置的服务器参数是否正确 只判断参数，不进行实际的服务器尝试
从类 com.trs.infra.util.CMyClassConfig 继承的方法
fromXMLFile, getBean, getClassName, getName
从类 com.trs.infra.util.CMyXMLElement 继承的方法
addChild, clear, getChild, getChildren, getChildren, getProperties, getPropertiesList, getProperty, getPropertyAsBoolean, getPropertyAsInt, getPropertyNames, getPropertyTrim, getPropertyTrim, getRequiredPropertyTrim, setName, setProperties, setProperty
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMySMTPServer

public CMySMTPServer()
方法详细信息

setServerName

public void setServerName(java.lang.String serverName)
参数：
serverName -

getServerName

public java.lang.String getServerName()
返回：

setServerPort

public void setServerPort(int serverPort)
参数：
serverPort -

getServerPort

public int getServerPort()
返回：

setAuth

public void setAuth(boolean auth)
参数：
auth -

needAuth

public boolean needAuth()

setUserName

public void setUserName(java.lang.String userName)
参数：
userName -

getUserName

public java.lang.String getUserName()
返回：

setPassword

public void setPassword(java.lang.String password)
参数：
password -

getPassword

public java.lang.String getPassword()
返回：

setSMTPConfig

public void setSMTPConfig(SMTPServerConfig _mySMTPConfig)
参数：
mySMTPConfig -

getDefaultSMTPServer

public static CMySMTPServer getDefaultSMTPServer()
从配置文件中，得到默认的SMTP服务器的配置

返回：
默认的SMTP服务器的配置。
如果没有找到，则返回NULL。

getSMTPServerByName

public static CMySMTPServer getSMTPServerByName(java.lang.String _sServerName)
从配置文件中，根据邮件服务器的名称，得到邮件服务器的配置

参数：
_sServerName - 邮件服务器的名称（即在配置中配置的邮件服务器地址或者IP）
返回：
SMTP服务器的配置
如果找不到，则返回NULL。

validate

public void validate()
              throws CMyMailException
判断当前配置的服务器参数是否正确
只判断参数，不进行实际的服务器尝试

抛出：
CMyMailException

canAuth

public boolean canAuth()
判断SMTP服务器的设置，是否能够进行身份验证

返回：
如果用户名和密码都不为空，则返回true，否则false

isSSLServer

public boolean isSSLServer()

setSSLServer

public void setSSLServer(boolean _bIsSSLServer)

createSocket

public java.net.Socket createSocket()
                             throws java.io.IOException
抛出：
java.io.IOException

toString

public java.lang.String toString()
覆盖：
类 CMyClassConfig 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MIMEBase64

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 MIMEBase64

java.lang.Object
    继承者  com.trs.infra.util.email.MIMEBase64

public class MIMEBase64
extends java.lang.Object

构造方法摘要
MIMEBase64()
方法摘要
static void | encode(java.lang.String filename, java.io.BufferedWriter out)
static void | send(java.io.BufferedWriter out, java.lang.String s)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MIMEBase64

public MIMEBase64()
方法详细信息

encode

public static void encode(java.lang.String filename,
                          java.io.BufferedWriter out)

send

public static void send(java.io.BufferedWriter out,
                        java.lang.String s)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.email
类
CMyEmail
CMyMailLog
CMySMTPServer
MIMEBase64
SMTPServerConfig
SMTPServerConfigMapper
SMTPServerConfigs
TRSMailer
异常
CMyMailException


com.trs.infra.util.email

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.email

类摘要
CMyEmail |
CMyMailLog | Title: TRS 内容协作平台（TRS WCM） Description: 邮件相关的日志信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMySMTPServer | Title: TRS 内容协作平台（TRS WCM） Description: SMTP服务器及其的相关属性设置管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MIMEBase64 |
SMTPServerConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SMTPServerConfigMapper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SMTPServerConfigs | Title: TRS 内容协作平台（TRS WCM） Description: SMTPServer config 的集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TRSMailer | Title: TRS 内容协作平台（TRS WCM） Description: 模拟邮件客户端工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
CMyMailException Title: TRS 内容协作平台（TRS WCM）
Description:
邮件相关的异常信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.util.email 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.email 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.email.CMyEmail
    • com.trs.infra.util.email.CMyMailLog
    • com.trs.infra.util.CMyXMLElement
      • com.trs.infra.util.CMyClassConfig
        • com.trs.infra.util.email.CMySMTPServer
    • com.trs.infra.util.email.MIMEBase64
    • com.trs.infra.util.email.SMTPServerConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.infra.util.email.SMTPServerConfigMapper
    • com.trs.infra.util.email.SMTPServerConfigs (implements com.trs.infra.config.persistent.IConfigElement)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.infra.util.CMyException
          • com.trs.infra.util.email.CMyMailException
    • com.trs.infra.util.email.TRSMailer


软件包 com.trs.infra.util.email 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.email
的使用

使用 com.trs.infra.util.email 的软件包
com.trs.infra.util.email

com.trs.infra.util.email 使用的 com.trs.infra.util.email 中的类
CMyEmail
CMyMailException
Title: TRS 内容协作平台（TRS WCM）
Description:
邮件相关的异常信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyMailLog
Title: TRS 内容协作平台（TRS WCM）
Description:
邮件相关的日志信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMySMTPServer
Title: TRS 内容协作平台（TRS WCM）
Description:
SMTP服务器及其的相关属性设置管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SMTPServerConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SMTPServerConfigMapper
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SMTPServerConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 SMTPServerConfig

java.lang.Object
    继承者  com.trs.infra.util.email.SMTPServerConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class SMTPServerConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SMTPServerConfig()
方法摘要
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getPassword()
int | getPort()
java.lang.String | getUserName()
boolean | isAuth()
void | setAuth(boolean auth)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setPassword(java.lang.String password)
void | setPort(int port)
void | setUserName(java.lang.String userName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SMTPServerConfig

public SMTPServerConfig()
方法详细信息

isAuth

public boolean isAuth()

setAuth

public void setAuth(boolean auth)

getPassword

public java.lang.String getPassword()

setPassword

public void setPassword(java.lang.String password)

getUserName

public java.lang.String getUserName()

setUserName

public void setUserName(java.lang.String userName)

getPort

public int getPort()

setPort

public void setPort(int port)

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SMTPServerConfigMapper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 SMTPServerConfigMapper

java.lang.Object
    继承者  com.trs.infra.util.email.SMTPServerConfigMapper

public class SMTPServerConfigMapper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SMTPServerConfigMapper()
Constructor
方法摘要
void | clear()
SMTPServerConfig | getDefaultSMTPServerConfig() 获取当前选择的SMTP服务器配置信息
static SMTPServerConfigMapper | getInstance()
SMTPServerConfig | getSMTPServerConfigByName(java.lang.String _sSMTPServerName) 依据SMTP服务器名获取指定的配置信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SMTPServerConfigMapper

public SMTPServerConfigMapper()
Constructor

方法详细信息

getInstance

public static SMTPServerConfigMapper getInstance()

getSMTPServerConfigByName

public SMTPServerConfig getSMTPServerConfigByName(java.lang.String _sSMTPServerName)
依据SMTP服务器名获取指定的配置信息

参数：
_sSMTPServerName - SMTP服务器名
返回：
指定的SMTP服务器配置对象

getDefaultSMTPServerConfig

public SMTPServerConfig getDefaultSMTPServerConfig()
获取当前选择的SMTP服务器配置信息

返回：
当前选中的SMTP服务器配置对象

clear

public void clear()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SMTPServerConfigs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 SMTPServerConfigs

java.lang.Object
    继承者  com.trs.infra.util.email.SMTPServerConfigs
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class SMTPServerConfigs
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
SMTPServer config 的集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SMTPServerConfigs()
方法摘要
SMTPServerConfig | get(int _nIndex)
java.lang.String | getDefaultSMTPServer()
java.lang.String | getName() 获取配置对象的名称
java.util.ArrayList | getSMTPServerConfigColl()
void | setDefaultSMTPServer(java.lang.String _sDefaultSMTPServer)
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setSMTPServerConfigColl(java.util.ArrayList _oSMTPServerConfig)
int | size() logic for Collection Options
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SMTPServerConfigs

public SMTPServerConfigs()
方法详细信息

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称

getSMTPServerConfigColl

public java.util.ArrayList getSMTPServerConfigColl()

setSMTPServerConfigColl

public void setSMTPServerConfigColl(java.util.ArrayList _oSMTPServerConfig)

getDefaultSMTPServer

public java.lang.String getDefaultSMTPServer()

setDefaultSMTPServer

public void setDefaultSMTPServer(java.lang.String _sDefaultSMTPServer)

size

public int size()
logic for Collection Options

get

public SMTPServerConfig get(int _nIndex)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSMailer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.email
类 TRSMailer

java.lang.Object
    继承者  com.trs.infra.util.email.TRSMailer

public class TRSMailer
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
模拟邮件客户端工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TRSMailer()
方法摘要
void | disableSocketTimeOut() 禁用服务器超时设置：设置超时为-1
CMyMailLog | getMailLog()
java.lang.String | getMailLogString()
int | getSocketTimeOut()
boolean | send(CMyEmail _currMail) 通过默认的邮件服务器发送邮件
boolean | send(CMyEmail _currMail, CMySMTPServer _currSmtpServer) 通过线程去发送邮件
boolean | send0(CMyEmail _currMail, CMySMTPServer _currSmtpServer) 通过邮件服务器发送邮件
void | setSocketTimeOut(int socketTimeOut)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSMailer

public TRSMailer()
方法详细信息

setSocketTimeOut

public void setSocketTimeOut(int socketTimeOut)
参数：
socketTimeOut -

disableSocketTimeOut

public void disableSocketTimeOut()
禁用服务器超时设置：设置超时为-1

getSocketTimeOut

public int getSocketTimeOut()
返回：

getMailLog

public CMyMailLog getMailLog()
返回：
邮件发送的日志记录信息

getMailLogString

public java.lang.String getMailLogString()
返回：
邮件发送的日志记录信息

send

public boolean send(CMyEmail _currMail)
             throws CMyMailException
通过默认的邮件服务器发送邮件

参数：
_currMail - 已经构造好的邮件
返回：
抛出：
CMyMailException

send

public boolean send(CMyEmail _currMail,
                    CMySMTPServer _currSmtpServer)
通过线程去发送邮件

参数：
_currMail -
_currSmtpServer -
返回：

send0

public boolean send0(CMyEmail _currMail,
                     CMySMTPServer _currSmtpServer)
              throws CMyMailException
通过邮件服务器发送邮件

参数：
_currMail - 已经构造好的邮件
_currSmtpServer - 已经获得的邮件服务器
返回：
发送是否成功
抛出：
CMyMailException - 参数无效、身份验证失败或者发送过程中发生其他问题则发生问题
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.util.email.CMyEmail 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.CMyEmail
的使用

使用 CMyEmail 的软件包
com.trs.infra.util.email

com.trs.infra.util.email 中 CMyEmail 的使用

参数类型为 CMyEmail 的 com.trs.infra.util.email 中的方法
boolean | TRSMailer.send(CMyEmail _currMail) 通过默认的邮件服务器发送邮件
boolean | TRSMailer.send(CMyEmail _currMail, CMySMTPServer _currSmtpServer) 通过线程去发送邮件
boolean | TRSMailer.send0(CMyEmail _currMail, CMySMTPServer _currSmtpServer) 通过邮件服务器发送邮件

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.email.CMyMailException 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.CMyMailException
的使用

使用 CMyMailException 的软件包
com.trs.infra.util.email

com.trs.infra.util.email 中 CMyMailException 的使用

抛出 CMyMailException 的 com.trs.infra.util.email 中的方法
boolean | TRSMailer.send(CMyEmail _currMail) 通过默认的邮件服务器发送邮件
boolean | TRSMailer.send0(CMyEmail _currMail, CMySMTPServer _currSmtpServer) 通过邮件服务器发送邮件
void | CMyEmail.validate() 验证邮件是否合法
void | CMySMTPServer.validate() 判断当前配置的服务器参数是否正确 只判断参数，不进行实际的服务器尝试

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.email.CMyMailLog 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.CMyMailLog
的使用

使用 CMyMailLog 的软件包
com.trs.infra.util.email

com.trs.infra.util.email 中 CMyMailLog 的使用

返回 CMyMailLog 的 com.trs.infra.util.email 中的方法
 CMyMailLog TRSMailer.getMailLog()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.email.CMySMTPServer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.CMySMTPServer
的使用

使用 CMySMTPServer 的软件包
com.trs.infra.util.email

com.trs.infra.util.email 中 CMySMTPServer 的使用

返回 CMySMTPServer 的 com.trs.infra.util.email 中的方法
static CMySMTPServer | CMySMTPServer.getDefaultSMTPServer() 从配置文件中，得到默认的SMTP服务器的配置
static CMySMTPServer | CMySMTPServer.getSMTPServerByName(java.lang.String _sServerName) 从配置文件中，根据邮件服务器的名称，得到邮件服务器的配置

参数类型为 CMySMTPServer 的 com.trs.infra.util.email 中的方法
boolean | TRSMailer.send(CMyEmail _currMail, CMySMTPServer _currSmtpServer) 通过线程去发送邮件
boolean | TRSMailer.send0(CMyEmail _currMail, CMySMTPServer _currSmtpServer) 通过邮件服务器发送邮件

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.email.MIMEBase64 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.MIMEBase64
的使用

没有 com.trs.infra.util.email.MIMEBase64 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.email.SMTPServerConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.SMTPServerConfig
的使用

使用 SMTPServerConfig 的软件包
com.trs.infra.util.email

com.trs.infra.util.email 中 SMTPServerConfig 的使用

返回 SMTPServerConfig 的 com.trs.infra.util.email 中的方法
SMTPServerConfig | SMTPServerConfigs.get(int _nIndex)
SMTPServerConfig | SMTPServerConfigMapper.getDefaultSMTPServerConfig() 获取当前选择的SMTP服务器配置信息
SMTPServerConfig | SMTPServerConfigMapper.getSMTPServerConfigByName(java.lang.String _sSMTPServerName) 依据SMTP服务器名获取指定的配置信息

参数类型为 SMTPServerConfig 的 com.trs.infra.util.email 中的方法
 void CMySMTPServer.setSMTPConfig(SMTPServerConfig _mySMTPConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.email.SMTPServerConfigMapper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.SMTPServerConfigMapper
的使用

使用 SMTPServerConfigMapper 的软件包
com.trs.infra.util.email

com.trs.infra.util.email 中 SMTPServerConfigMapper 的使用

返回 SMTPServerConfigMapper 的 com.trs.infra.util.email 中的方法
static SMTPServerConfigMapper SMTPServerConfigMapper.getInstance()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.email.SMTPServerConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.SMTPServerConfigs
的使用

没有 com.trs.infra.util.email.SMTPServerConfigs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.email.TRSMailer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.email.TRSMailer
的使用

没有 com.trs.infra.util.email.TRSMailer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


JavaScriptEscape

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.file
类 JavaScriptEscape

java.lang.Object
    继承者  com.trs.infra.util.file.JavaScriptEscape

public class JavaScriptEscape
extends java.lang.Object

TODO javadoc for com.trs.tools.file.JavaScriptEscape 已知的限制

  1. 注释中的汉字也会被转义
  2. 没有为转义后的字符串生成必要的注释，以便于该js以后的查看

作者：
Martin (付成睿)

构造方法摘要
JavaScriptEscape()
方法摘要
static java.lang.String | char2hex(int j)
static void | log(java.lang.String s) 记录信息到日志,只是输出的标准输出
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JavaScriptEscape

public JavaScriptEscape()
方法详细信息

main

public static void main(java.lang.String[] args)

char2hex

public static java.lang.String char2hex(int j)

log

public static final void log(java.lang.String s)
记录信息到日志,只是输出的标准输出

参数：
s - 待记录的信息
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.file
类
JavaScriptEscape


com.trs.infra.util.file

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.file

类摘要
JavaScriptEscape TODO javadoc for com.trs.tools.file.JavaScriptEscape 已知的限制 注释中的汉字也会被转义 没有为转义后的字符串生成必要的注释，以便于该js以后的查看


com.trs.infra.util.file 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.file 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.file.JavaScriptEscape


软件包 com.trs.infra.util.file 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.file
的使用

没有 com.trs.infra.util.file 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.file.JavaScriptEscape 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.file.JavaScriptEscape
的使用

没有 com.trs.infra.util.file.JavaScriptEscape 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CMyFtp

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.ftp
类 CMyFtp

java.lang.Object
    继承者  com.trs.infra.util.ftp.CMyFtp
所有已实现的接口：
java.lang.Runnable
public class CMyFtp
extends java.lang.Object
implements java.lang.Runnable

字段摘要
java.lang.String | ERR_NO_LOCAL_FILE
static int | LIST_ALL
static int | LIST_DIRS
static int | LIST_FILES
static int | UPLOAD_RETRY_TIMES
构造方法摘要
CMyFtp()
默认构造函数
方法摘要
boolean | changeDir(java.lang.String _localDir, boolean bRemote) 更改本地或FTP服务器上的当前默认目录
void | changeDirs(java.lang.String _sPath) 更改FTP服务器的当前目录，如果包含的子目录不存在，则自动创建子目录
boolean | Connect() 根据设置的配置信息，连接到FTP服务器
boolean | Connect(boolean bPassiveMode)
boolean | Disconnect() 断开和FTP服务器的连接
boolean | downloadFile(java.lang.String _remoteFile, java.lang.String _localFile) 从远程FTP服务器上下载指定的文件到本地
java.lang.String | getDateTime(java.lang.String _name, boolean bRemote)
int | getFileSize(java.lang.String _fileName, boolean bRemote) 获得指定文件名文件的大小
static CMyFtp | getFtpConnection()
boolean | isConnected() 判断当前的连接是否存在或有效
java.lang.String | listAll(java.lang.String _ftpPath) 获得FTP服务器上指定目录下的所有文件和文件夹，用","分割
java.lang.String | listDirectory(java.lang.String _ftpPath, int _listType) 列出FTP服务器上指定目录下的第一层子目录或所有文件，用","分割
java.lang.String | listDirs(java.lang.String _ftpPath) 列出FTP服务器上指定目录下的所有第一层子目录，用","分割目录
java.lang.String | listFiles(java.lang.String _ftpPath) 获得FTP服务器上指定目录下哦的所有文件，用“,”分割
static void | main(java.lang.String[] args)
boolean | makeDirectory(java.lang.String _sDir) 根据指定的路径创建FTP目录
boolean | removeDirectory(java.lang.String _sDir) 删除FTP服务器上指定的目录
boolean | removeFile(java.lang.String _fileName, boolean bRemote) 删除当前目录下的文件
boolean | renameFile(java.lang.String _sDstFile, java.lang.String _sNewFile) 根据指定的路径创建FTP目录
void | run()
void | setConnectionInfo(java.lang.String _sServer, java.lang.String _sPort, java.lang.String _sLogin, java.lang.String _sPassword) 设置FTP服务器的连接信息
void | setConnectionInfo(java.lang.String _sServer, java.lang.String _sPort, java.lang.String _sLogin, java.lang.String _sPassword, boolean _bPassive)
void | setLocalPath(java.lang.String _sLocalPath) 设置本地的默认路径
void | setLocalPubPath(java.lang.String _sLocalPubPath) 设置FTP登录的本地路径信息
void | setRemotePath(java.lang.String _sRemotePath) 设置FTP服务器的默认路径
void | setStopNoop(boolean stopNoop)
boolean | testFtpServer(java.lang.String _ftpServer, java.lang.String _ftpUser, java.lang.String _ftpPwd) 使用默认端口"21"测试FTP服务器连接正常
boolean | testFtpServer(java.lang.String _ftpServer, java.lang.String _ftpUser, java.lang.String _ftpPwd, java.lang.String _ftpFolder, boolean _bWrite) 测试默认端口"21"测试FTP服务器连接正常以及指定的目录是否具有可写权限
void | uploadDirectory(java.lang.String _localDir, java.lang.String _remoteDir) 上传指定目录下的所有文件到FTP服务器的指定目录
boolean | uploadFile(java.lang.String _localFile, java.lang.String _remoteFile) 上传指定的本地文件到FTP服务器 首先检查FTP链接是否正常，如果已经断开则自动重新链接一次。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ERR_NO_LOCAL_FILE

public final java.lang.String ERR_NO_LOCAL_FILE

UPLOAD_RETRY_TIMES

public static int UPLOAD_RETRY_TIMES

LIST_ALL

public static final int LIST_ALL
另请参见：
常量字段值

LIST_FILES

public static final int LIST_FILES
另请参见：
常量字段值

LIST_DIRS

public static final int LIST_DIRS
另请参见：
常量字段值
构造方法详细信息

CMyFtp

public CMyFtp()
默认构造函数

方法详细信息

Connect

public boolean Connect()
                throws CMyException
根据设置的配置信息，连接到FTP服务器

返回：
连接是否成功
抛出：
CMyException

Connect

public boolean Connect(boolean bPassiveMode)
                throws CMyException
抛出：
CMyException

Disconnect

public boolean Disconnect()
                   throws java.lang.Exception
断开和FTP服务器的连接

返回：
断开操作是否成功
抛出：
java.lang.Exception

renameFile

public boolean renameFile(java.lang.String _sDstFile,
                          java.lang.String _sNewFile)
                   throws CMyException
根据指定的路径创建FTP目录

参数：
_sDstFile - 需要修改的文件名
_sNewFile - 新的文件名
返回：
创建操作是否成功
抛出：
CMyException

makeDirectory

public boolean makeDirectory(java.lang.String _sDir)
                      throws CMyException
根据指定的路径创建FTP目录

参数：
_sDir - 指定的FTP目录
返回：
创建操作是否成功
抛出：
CMyException

removeDirectory

public boolean removeDirectory(java.lang.String _sDir)
                        throws CMyException
删除FTP服务器上指定的目录

参数：
_sDir - 指定的FTP目录
返回：
删除操作是否成功
抛出：
CMyException

setLocalPubPath

public void setLocalPubPath(java.lang.String _sLocalPubPath)
设置FTP登录的本地路径信息

参数：
_sLocalPubPath - 本地路径信息

uploadFile

public boolean uploadFile(java.lang.String _localFile,
                          java.lang.String _remoteFile)
                   throws CMyException
上传指定的本地文件到FTP服务器 首先检查FTP链接是否正常，如果已经断开则自动重新链接一次。 在FTP链接正常的情况下，进行文件的上传操作。 如果上传错误不成功，则自动重复上传一次。再次上传前自动检查链接是否正常。

参数：
_localFile - 本地文件路径
_remoteFile - FTP文件路径
返回：
上传操作是否成功
抛出：
CMyException

changeDirs

public void changeDirs(java.lang.String _sPath)
                throws CMyException
更改FTP服务器的当前目录，如果包含的子目录不存在，则自动创建子目录

参数：
_sPath - 当前的FTP目录
抛出：
CMyException

uploadDirectory

public void uploadDirectory(java.lang.String _localDir,
                            java.lang.String _remoteDir)
                     throws CMyException
上传指定目录下的所有文件到FTP服务器的指定目录

参数：
_localDir - 本地目录
_remoteDir - FTP目录
抛出：
CMyException

changeDir

public boolean changeDir(java.lang.String _localDir,
                         boolean bRemote)
                  throws java.lang.Exception
更改本地或FTP服务器上的当前默认目录

参数：
_localDir - 文件夹
bRemote - 远程或本地
返回：
更改操作的结果
抛出：
java.lang.Exception

setConnectionInfo

public void setConnectionInfo(java.lang.String _sServer,
                              java.lang.String _sPort,
                              java.lang.String _sLogin,
                              java.lang.String _sPassword)
设置FTP服务器的连接信息

参数：
_sServer - FTP服务器
_sPort - FTP端口
_sLogin - FTP登录用户
_sPassword - FTP登录口令

setConnectionInfo

public void setConnectionInfo(java.lang.String _sServer,
                              java.lang.String _sPort,
                              java.lang.String _sLogin,
                              java.lang.String _sPassword,
                              boolean _bPassive)

setRemotePath

public void setRemotePath(java.lang.String _sRemotePath)
设置FTP服务器的默认路径

参数：
_sRemotePath - 远程路径

setLocalPath

public void setLocalPath(java.lang.String _sLocalPath)
设置本地的默认路径

参数：
_sLocalPath - 本地路径

downloadFile

public boolean downloadFile(java.lang.String _remoteFile,
                            java.lang.String _localFile)
                     throws java.lang.Exception
从远程FTP服务器上下载指定的文件到本地

参数：
_remoteFile - 远程文件名
_localFile - 本地文件名
返回：
文件是否下载成功
抛出：
java.lang.Exception

getDateTime

public java.lang.String getDateTime(java.lang.String _name,
                                    boolean bRemote)
                             throws java.lang.Exception
抛出：
java.lang.Exception

getFileSize

public int getFileSize(java.lang.String _fileName,
                       boolean bRemote)
                throws java.lang.Exception
获得指定文件名文件的大小

参数：
_fileName - 文件名
bRemote - 是本地文件还是远程文件
返回：
文件大小
抛出：
java.lang.Exception

removeFile

public boolean removeFile(java.lang.String _fileName,
                          boolean bRemote)
                   throws java.lang.Exception
删除当前目录下的文件

参数：
_fileName - 删除的文件名
bRemote - 是本地还是远程
返回：
删除操作是否成功
抛出：
java.lang.Exception

testFtpServer

public boolean testFtpServer(java.lang.String _ftpServer,
                             java.lang.String _ftpUser,
                             java.lang.String _ftpPwd)
                      throws java.lang.Exception
使用默认端口"21"测试FTP服务器连接正常

参数：
_ftpServer - FTP服务器
_ftpUser - FTP登录用户
_ftpPwd - FTP登录口令
返回：
服务器连接是否成功
抛出：
java.lang.Exception

testFtpServer

public boolean testFtpServer(java.lang.String _ftpServer,
                             java.lang.String _ftpUser,
                             java.lang.String _ftpPwd,
                             java.lang.String _ftpFolder,
                             boolean _bWrite)
                      throws java.lang.Exception
测试默认端口"21"测试FTP服务器连接正常以及指定的目录是否具有可写权限

参数：
_ftpServer - 测试的FTP服务器
_ftpUser - 测试的登录用户
_ftpPwd - 测试的登录口令
_ftpFolder - 测试的FTP文件夹
_bWrite - 是否需要测试可写权限
返回：
测试结果是否正确
抛出：
java.lang.Exception - 测试结果不正确是抛出异常

isConnected

public boolean isConnected()
                    throws CMyException
判断当前的连接是否存在或有效

返回：
连接是否存在
抛出：
CMyException

listDirs

public java.lang.String listDirs(java.lang.String _ftpPath)
                          throws java.lang.Exception
列出FTP服务器上指定目录下的所有第一层子目录，用","分割目录

参数：
_ftpPath - 指定的FTP目录
返回：
指定目录下的第一级子目录
抛出：
java.lang.Exception

listDirectory

public java.lang.String listDirectory(java.lang.String _ftpPath,
                                      int _listType)
                               throws java.lang.Exception
列出FTP服务器上指定目录下的第一层子目录或所有文件，用","分割

参数：
_ftpPath - 指定的FTP目录
_listType - 获得的结果类型：目录（LIST_DIRS）或文件（LIST_ALL）
返回：
获得需要的目录或文件集合
抛出：
java.lang.Exception

listAll

public java.lang.String listAll(java.lang.String _ftpPath)
                         throws java.lang.Exception
获得FTP服务器上指定目录下的所有文件和文件夹，用","分割

参数：
_ftpPath - 指定的FTP目录
返回：
指定FTP目录下的所有文件和文件夹列表
抛出：
java.lang.Exception

listFiles

public java.lang.String listFiles(java.lang.String _ftpPath)
                           throws java.lang.Exception
获得FTP服务器上指定目录下哦的所有文件，用“,”分割

参数：
_ftpPath - 指定的FTP目录
返回：
指定FTP目录下的所有文件列表
抛出：
java.lang.Exception

getFtpConnection

public static CMyFtp getFtpConnection()
                               throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)

run

public void run()
指定者：
接口 java.lang.Runnable 中的 run

setStopNoop

public void setStopNoop(boolean stopNoop)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FtpConnectionPool

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.ftp
类 FtpConnectionPool

java.lang.Object
    继承者  com.trs.infra.util.ftp.FtpConnectionPool
所有已实现的接口：
java.lang.Runnable, org.aton.container.IClearable
public class FtpConnectionPool
extends java.lang.Object
implements java.lang.Runnable, org.aton.container.IClearable

构造方法摘要
FtpConnectionPool(java.lang.String _sServer, java.lang.String _sLoginUser, java.lang.String _sPassword, java.lang.String _sRootDir, boolean _bPassiveMode, int _nMaxConnections)
Constructor
方法摘要
void | clear()
void | free(CMyFtp _connection)
CMyFtp | getConnection()
void | run() 初始化FTP连接缓冲池
java.lang.String | toString() 获取FTP连接的信息
int | totalConnections() 获取缓冲池中连接总数
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FtpConnectionPool

public FtpConnectionPool(java.lang.String _sServer,
                         java.lang.String _sLoginUser,
                         java.lang.String _sPassword,
                         java.lang.String _sRootDir,
                         boolean _bPassiveMode,
                         int _nMaxConnections)
                  throws CMyException
Constructor

参数：
_sServer -
_sLoginUser -
_sPassword -
_sRootDir -
_bPassiveMode -
_nMaxConnections -
抛出：
CMyException
方法详细信息

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

free

public void free(CMyFtp _connection)

getConnection

public CMyFtp getConnection()
                     throws CMyException
抛出：
CMyException

run

public void run()
初始化FTP连接缓冲池

指定者：
接口 java.lang.Runnable 中的 run

toString

public java.lang.String toString()
获取FTP连接的信息

覆盖：
类 java.lang.Object 中的 toString
返回：
FTP连接的信息（String）

totalConnections

public int totalConnections()
获取缓冲池中连接总数

返回：
缓冲池中连接总数（int）
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FtpMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.ftp
类 FtpMgr

java.lang.Object
    继承者  com.trs.infra.util.ftp.FtpMgr
所有已实现的接口：
IFtpMgr, org.aton.container.IClearable
public class FtpMgr
extends java.lang.Object
implements IFtpMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
ftp manager implementation for IFtpMgr
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FtpMgr()
方法摘要
void | clear()
java.lang.String | getServerHost() Returns the server host addres.
void | init(java.lang.String _sServer, java.lang.String _sLoginUser, java.lang.String _sPassword, java.lang.String _sRootDir, boolean _bPassiveMode, int _nMaxConnections) Initiates this ftp manager.
boolean | isCheckWriteAuth() 获取初始化的时候是否需要校验写权限
boolean | removeFile(java.lang.String _sRemoteFile) Removes a file from the ftp server.
boolean | removePath(java.lang.String _sRemotePath) Removes a path from the ftp server.
void | setCheckWriteAuth(boolean checkWriteAuth) 设置初始化的时候是否需要校验写权限
boolean | upload(java.lang.String _sLocalFtpFile, java.lang.String _sRemoteFile) Uploads a local file to the ftp server.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FtpMgr

public FtpMgr()
方法详细信息

init

public void init(java.lang.String _sServer,
                 java.lang.String _sLoginUser,
                 java.lang.String _sPassword,
                 java.lang.String _sRootDir,
                 boolean _bPassiveMode,
                 int _nMaxConnections)
          throws CMyException
从接口 IFtpMgr 复制的描述
Initiates this ftp manager.

指定者：
接口 IFtpMgr 中的 init
参数：
_sServer - the ftp server host
_sLoginUser - login user name
_sPassword - login password
_sRootDir - the root directory
_bPassiveMode - true, the passive mode.
_nMaxConnections - the maximum number of ftp connection
抛出：
CMyException - if failed to initiate the ftp manager.

getServerHost

public java.lang.String getServerHost()
从接口 IFtpMgr 复制的描述
Returns the server host addres.

指定者：
接口 IFtpMgr 中的 getServerHost
返回：
the server host address.
另请参见：
IFtpMgr.getServerHost()

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
另请参见：
IClearable.clear()

upload

public boolean upload(java.lang.String _sLocalFtpFile,
                      java.lang.String _sRemoteFile)
               throws CMyException
从接口 IFtpMgr 复制的描述
Uploads a local file to the ftp server.

指定者：
接口 IFtpMgr 中的 upload
参数：
_sLocalFtpFile - local file path name.
_sRemoteFile - the remote file to upload.
返回：
true if the file is uploaded successfully; false otherwise.
抛出：
CMyException - if failed to upload the file.

removePath

public boolean removePath(java.lang.String _sRemotePath)
                   throws java.lang.Exception
从接口 IFtpMgr 复制的描述
Removes a path from the ftp server.

指定者：
接口 IFtpMgr 中的 removePath
参数：
_sRemotePath - the remote path to remove.
返回：
true if the path exists and has been removed successfully; false otherwise.
抛出：
java.lang.Exception - if failed to withdraw the path.

removeFile

public boolean removeFile(java.lang.String _sRemoteFile)
                   throws java.lang.Exception
从接口 IFtpMgr 复制的描述
Removes a file from the ftp server.

指定者：
接口 IFtpMgr 中的 removeFile
参数：
_sRemoteFile - the remote file to removes.
返回：
true if the file exists and has been removed successfully; false otherwise.
抛出：
java.lang.Exception - if failed to withdraw the file.

isCheckWriteAuth

public boolean isCheckWriteAuth()
获取初始化的时候是否需要校验写权限

返回：
true：需要 false：不需要

setCheckWriteAuth

public void setCheckWriteAuth(boolean checkWriteAuth)
设置初始化的时候是否需要校验写权限

参数：
checkWriteAuth - 是否需要校验写权限（true：需要 false：不需要）
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FtpMgrTest

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.ftp
类 FtpMgrTest

java.lang.Object
    继承者  com.trs.infra.util.ftp.FtpMgrTest
所有已实现的接口：
java.lang.Runnable
public class FtpMgrTest
extends java.lang.Object
implements java.lang.Runnable

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
FtpMgrTest(IFtpMgr _currFtpMgr, int _nThreadIndex)
方法摘要
static void | main(java.lang.String[] args)
void | run()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FtpMgrTest

public FtpMgrTest(IFtpMgr _currFtpMgr,
                  int _nThreadIndex)
方法详细信息

run

public void run()
指定者：
接口 java.lang.Runnable 中的 run

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFtpMgr

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.ftp
接口 IFtpMgr

所有超级接口：
org.aton.container.IClearable
所有已知实现类：
FtpMgr
public interface IFtpMgr
extends org.aton.container.IClearable

Title: TRS 内容协作平台（TRS WCM）
Description:
interface of ftp manager.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String | getServerHost() Returns the server host addres.
void | init(java.lang.String _sServer, java.lang.String _sLoginUser, java.lang.String _sPassword, java.lang.String _sRootDir, boolean _bPassiveMode, int _nMaxConnections) Initiates this ftp manager.
boolean | removeFile(java.lang.String _sRemoteFile) Removes a file from the ftp server.
boolean | removePath(java.lang.String _sRemotePath) Removes a path from the ftp server.
boolean | upload(java.lang.String _sLocalFile, java.lang.String _sRemoteFile) Uploads a local file to the ftp server.
从接口 org.aton.container.IClearable 继承的方法
clear

方法详细信息

init

void init(java.lang.String _sServer,
          java.lang.String _sLoginUser,
          java.lang.String _sPassword,
          java.lang.String _sRootDir,
          boolean _bPassiveMode,
          int _nMaxConnections)
          throws CMyException
Initiates this ftp manager.

参数：
_sServer - the ftp server host
_sLoginUser - login user name
_sPassword - login password
_sRootDir - the root directory
_bPassiveMode - true, the passive mode.
_nMaxConnections - the maximum number of ftp connection
抛出：
CMyException - if failed to initiate the ftp manager.

getServerHost

java.lang.String getServerHost()
Returns the server host addres.

返回：
the server host address.

upload

boolean upload(java.lang.String _sLocalFile,
               java.lang.String _sRemoteFile)
               throws CMyException
Uploads a local file to the ftp server.

参数：
_sLocalFile - local file path name.
_sRemoteFile - the remote file to upload.
返回：
true if the file is uploaded successfully; false otherwise.
抛出：
CMyException - if failed to upload the file.

removePath

boolean removePath(java.lang.String _sRemotePath)
                   throws java.lang.Exception
Removes a path from the ftp server.

参数：
_sRemotePath - the remote path to remove.
返回：
true if the path exists and has been removed successfully; false otherwise.
抛出：
java.lang.Exception - if failed to withdraw the path.

removeFile

boolean removeFile(java.lang.String _sRemoteFile)
                   throws java.lang.Exception
Removes a file from the ftp server.

参数：
_sRemoteFile - the remote file to removes.
返回：
true if the file exists and has been removed successfully; false otherwise.
抛出：
java.lang.Exception - if failed to withdraw the file.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.ftp
接口
IFtpMgr
类
CMyFtp
FtpConnectionPool
FtpMgr
FtpMgrTest


com.trs.infra.util.ftp

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.ftp

接口摘要
IFtpMgr Title: TRS 内容协作平台（TRS WCM）
Description:
interface of ftp manager.

类摘要
CMyFtp |
FtpConnectionPool |
FtpMgr | Title: TRS 内容协作平台（TRS WCM） Description: ftp manager implementation for IFtpMgr Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FtpMgrTest | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.util.ftp 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.ftp 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.ftp.CMyFtp (implements java.lang.Runnable)
    • com.trs.infra.util.ftp.FtpConnectionPool (implements org.aton.container.IClearable, java.lang.Runnable)
    • com.trs.infra.util.ftp.FtpMgr (implements com.trs.infra.util.ftp.IFtpMgr)
    • com.trs.infra.util.ftp.FtpMgrTest (implements java.lang.Runnable)

接口分层结构

  • org.aton.container.IClearable
    • com.trs.infra.util.ftp.IFtpMgr


软件包 com.trs.infra.util.ftp 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.ftp
的使用

使用 com.trs.infra.util.ftp 的软件包
com.trs.components.common.publish.domain.distribute
com.trs.infra.util.ftp

com.trs.components.common.publish.domain.distribute 使用的 com.trs.infra.util.ftp 中的类
FtpMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
ftp manager implementation for IFtpMgr
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.ftp 使用的 com.trs.infra.util.ftp 中的类
CMyFtp
IFtpMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
interface of ftp manager.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ftp.CMyFtp 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ftp.CMyFtp
的使用

使用 CMyFtp 的软件包
com.trs.infra.util.ftp

com.trs.infra.util.ftp 中 CMyFtp 的使用

返回 CMyFtp 的 com.trs.infra.util.ftp 中的方法
CMyFtp | FtpConnectionPool.getConnection()
static CMyFtp | CMyFtp.getFtpConnection()

参数类型为 CMyFtp 的 com.trs.infra.util.ftp 中的方法
 void FtpConnectionPool.free(CMyFtp _connection)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ftp.FtpConnectionPool 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ftp.FtpConnectionPool
的使用

没有 com.trs.infra.util.ftp.FtpConnectionPool 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ftp.FtpMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ftp.FtpMgr
的使用

使用 FtpMgr 的软件包
com.trs.components.common.publish.domain.distribute

com.trs.components.common.publish.domain.distribute 中 FtpMgr 的使用

返回 FtpMgr 的 com.trs.components.common.publish.domain.distribute 中的方法
 FtpMgr FileDistributorFtpCacheMgr.lookupFtpMgr(PublishDistribution _distribution)
已过时。 Returns the ftp manager of the specified distribution.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.ftp.FtpMgrTest 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.ftp.FtpMgrTest
的使用

没有 com.trs.infra.util.ftp.FtpMgrTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.util.ftp.IFtpMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.util.ftp.IFtpMgr
的使用

使用 IFtpMgr 的软件包
com.trs.infra.util.ftp

com.trs.infra.util.ftp 中 IFtpMgr 的使用

实现 IFtpMgr 的 com.trs.infra.util.ftp 中的类
 class FtpMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
ftp manager implementation for IFtpMgr
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 IFtpMgr 的 com.trs.infra.util.ftp 中的构造方法
FtpMgrTest(IFtpMgr _currFtpMgr, int _nThreadIndex)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ContentLinkReplacer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 ContentLinkReplacer

java.lang.Object
    继承者  com.trs.infra.util.html.ContentLinkReplacer

public class ContentLinkReplacer
extends java.lang.Object

字段摘要
static int KEY_LEN_LIMIT
构造方法摘要
ContentLinkReplacer()
构造函数
方法摘要
void | clear() 清除所有的链接映射项
java.lang.String | getMappedLink(java.lang.String _sKey) 取指定字符串映射链接
static java.lang.String[] | getTagsToSkip() 取处理时可以跳过的元素标记
boolean | loadLinkMap(java.lang.String _linkMapFile) 装载链接映射表
static void | main(java.lang.String[] args)
boolean | putLinkMap(java.lang.String _sKey, java.lang.String _sLink)
boolean | putLinkMap(java.lang.String _sKey, java.lang.String _sLink, java.lang.String _sTitle) 装入一个链接的映射项 备注：如果要考虑大小写的区分/不区分，请在装入时统一转化为大写/小写
java.lang.String | removeLinkMap(java.lang.String _sKey) 从链接映射表中删除一个链接项
java.lang.String | replaceLink(java.lang.String _srcContent) 使用指定的链接映射表，替换指定内容中的字符串
java.lang.String | replaceLink(java.lang.String _srcContent, java.lang.String _extraLinkAttributes) 使用指定的链接映射表，替换指定内容中的字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

KEY_LEN_LIMIT

public static int KEY_LEN_LIMIT
构造方法详细信息

ContentLinkReplacer

public ContentLinkReplacer()
构造函数

方法详细信息

getTagsToSkip

public static final java.lang.String[] getTagsToSkip()
取处理时可以跳过的元素标记

返回：
元素标记数组

clear

public void clear()
清除所有的链接映射项

putLinkMap

public boolean putLinkMap(java.lang.String _sKey,
                          java.lang.String _sLink)
另请参见：
boolean putLinkMap( String _sKey, String _sLink, String _sTitle )

putLinkMap

public boolean putLinkMap(java.lang.String _sKey,
                          java.lang.String _sLink,
                          java.lang.String _sTitle)
装入一个链接的映射项
备注：如果要考虑大小写的区分/不区分，请在装入时统一转化为大写/小写

参数：
_sKey - 关键字
_sLink - 对应链接
_sTitle - 链接的Title属性，可省略，默认为""
返回：
若参数有效并装入成功，则返回true；否则返回false.

removeLinkMap

public java.lang.String removeLinkMap(java.lang.String _sKey)
从链接映射表中删除一个链接项

参数：
_sKey - 关键字
返回：
若找到，则返回被删除映射项中的链接内容；否则，返回null

getMappedLink

public java.lang.String getMappedLink(java.lang.String _sKey)
取指定字符串映射链接

参数：
_sKey - 关键字
返回：
若找到，则返回映射项中的链接内容；否则，返回null

replaceLink

public java.lang.String replaceLink(java.lang.String _srcContent)
                             throws CMyException
使用指定的链接映射表，替换指定内容中的字符串

参数：
_srcContent - 指定的源文本内容
返回：
替换后的Html文本内容
抛出：
CMyException - 替换操作异常
另请参见：
String replaceLink( String _srcContent, String _extraLinkAttributes )

replaceLink

public java.lang.String replaceLink(java.lang.String _srcContent,
                                    java.lang.String _extraLinkAttributes)
                             throws CMyException
使用指定的链接映射表，替换指定内容中的字符串

参数：
_srcContent - 指定的源文本内容
_extraLinkAttributes - 用户指定的额外链接属性，如： "class=\"white\" target=\"_blank\"" ； 可选参数，缺省值为null（不指定）
返回：
替换后的Html文本内容
抛出：
CMyException - 替换操作异常

loadLinkMap

public boolean loadLinkMap(java.lang.String _linkMapFile)
                    throws CMyException
装载链接映射表

参数：
_linkMapFile - 记录链接映射的文件
返回：
装载成功返回true;否则返回false
抛出：
CMyException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


HTML.Attribute

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HTML.Attribute

java.lang.Object
    继承者  com.trs.infra.util.html.HTML.Attribute
包容类：
HTML
public static final class HTML.Attribute
extends java.lang.Object

Title: TRS内容协作平台（TRS WCM）

Description:

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: www.trs.com.cn

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static HTML.Attribute | ACTION
static HTML.Attribute | ALIGN
static HTML.Attribute | ALINK
static HTML.Attribute | ALT
static HTML.Attribute | ARCHIVE
static HTML.Attribute | BACKGROUND
static HTML.Attribute | BGCOLOR
static HTML.Attribute | BORDER
static HTML.Attribute | CELLPADDING
static HTML.Attribute | CELLSPACING
static HTML.Attribute | CHECKED
static HTML.Attribute | CLASS
static HTML.Attribute | CLASSID
static HTML.Attribute | CLEAR
static HTML.Attribute | CODE
static HTML.Attribute | CODEBASE
static HTML.Attribute | CODETYPE
static HTML.Attribute | COLOR
static HTML.Attribute | COLS
static HTML.Attribute | COLSPAN
static HTML.Attribute | COMMENT
static HTML.Attribute | COMPACT
static HTML.Attribute | CONTENT
static HTML.Attribute | COORDS
static HTML.Attribute | DATA
static HTML.Attribute | DECLARE
static HTML.Attribute | DIR
static HTML.Attribute | DUMMY
static HTML.Attribute | ENCTYPE
static HTML.Attribute | ENDTAG
static HTML.Attribute | FACE
static HTML.Attribute | FRAMEBORDER
static HTML.Attribute | HALIGN
static HTML.Attribute | HEIGHT
static HTML.Attribute | HREF
static HTML.Attribute | HSPACE
static HTML.Attribute | HTTPEQUIV
static HTML.Attribute | ID
static HTML.Attribute | ISMAP
static HTML.Attribute | LANG
static HTML.Attribute | LANGUAGE
static HTML.Attribute | LINK
static HTML.Attribute | LOWSRC
static HTML.Attribute | MARGINHEIGHT
static HTML.Attribute | MARGINWIDTH
static HTML.Attribute | MAXLENGTH
static HTML.Attribute | METHOD
static HTML.Attribute | MULTIPLE
static HTML.Attribute | N
static HTML.Attribute | NAME
static HTML.Attribute | NOHREF
static HTML.Attribute | NORESIZE
static HTML.Attribute | NOSHADE
static HTML.Attribute | NOWRAP
static HTML.Attribute | PROMPT
static HTML.Attribute | REL
static HTML.Attribute | REV
static HTML.Attribute | ROWS
static HTML.Attribute | ROWSPAN
static HTML.Attribute | SCROLLING
static HTML.Attribute | SELECTED
static HTML.Attribute | SHAPE
static HTML.Attribute | SHAPES
static HTML.Attribute | SIZE
static HTML.Attribute | SRC
static HTML.Attribute | STANDBY
static HTML.Attribute | START
static HTML.Attribute | STYLE
static HTML.Attribute | TARGET
static HTML.Attribute | TEXT
static HTML.Attribute | TITLE
static HTML.Attribute | TYPE
static HTML.Attribute | USEMAP
static HTML.Attribute | VALIGN
static HTML.Attribute | VALUE
static HTML.Attribute | VALUETYPE
static HTML.Attribute | VERSION
static HTML.Attribute | VLINK
static HTML.Attribute | VSPACE
static HTML.Attribute | WIDTH
方法摘要
 java.lang.String toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SIZE

public static final HTML.Attribute SIZE

COLOR

public static final HTML.Attribute COLOR

CLEAR

public static final HTML.Attribute CLEAR

BACKGROUND

public static final HTML.Attribute BACKGROUND

BGCOLOR

public static final HTML.Attribute BGCOLOR

TEXT

public static final HTML.Attribute TEXT

LINK

public static final HTML.Attribute LINK

VLINK

public static final HTML.Attribute VLINK

ALINK

public static final HTML.Attribute ALINK

WIDTH

public static final HTML.Attribute WIDTH

HEIGHT

public static final HTML.Attribute HEIGHT

ALIGN

public static final HTML.Attribute ALIGN

NAME

public static final HTML.Attribute NAME

HREF

public static final HTML.Attribute HREF

REL

public static final HTML.Attribute REL

REV

public static final HTML.Attribute REV

TITLE

public static final HTML.Attribute TITLE

TARGET

public static final HTML.Attribute TARGET

SHAPE

public static final HTML.Attribute SHAPE

COORDS

public static final HTML.Attribute COORDS

ISMAP

public static final HTML.Attribute ISMAP

NOHREF

public static final HTML.Attribute NOHREF

ALT

public static final HTML.Attribute ALT

ID

public static final HTML.Attribute ID

SRC

public static final HTML.Attribute SRC

HSPACE

public static final HTML.Attribute HSPACE

VSPACE

public static final HTML.Attribute VSPACE

USEMAP

public static final HTML.Attribute USEMAP

LOWSRC

public static final HTML.Attribute LOWSRC

CODEBASE

public static final HTML.Attribute CODEBASE

CODE

public static final HTML.Attribute CODE

ARCHIVE

public static final HTML.Attribute ARCHIVE

VALUE

public static final HTML.Attribute VALUE

VALUETYPE

public static final HTML.Attribute VALUETYPE

TYPE

public static final HTML.Attribute TYPE

CLASS

public static final HTML.Attribute CLASS

STYLE

public static final HTML.Attribute STYLE

LANG

public static final HTML.Attribute LANG

FACE

public static final HTML.Attribute FACE

DIR

public static final HTML.Attribute DIR

DECLARE

public static final HTML.Attribute DECLARE

CLASSID

public static final HTML.Attribute CLASSID

DATA

public static final HTML.Attribute DATA

CODETYPE

public static final HTML.Attribute CODETYPE

STANDBY

public static final HTML.Attribute STANDBY

BORDER

public static final HTML.Attribute BORDER

SHAPES

public static final HTML.Attribute SHAPES

NOSHADE

public static final HTML.Attribute NOSHADE

COMPACT

public static final HTML.Attribute COMPACT

START

public static final HTML.Attribute START

ACTION

public static final HTML.Attribute ACTION

METHOD

public static final HTML.Attribute METHOD

ENCTYPE

public static final HTML.Attribute ENCTYPE

CHECKED

public static final HTML.Attribute CHECKED

MAXLENGTH

public static final HTML.Attribute MAXLENGTH

MULTIPLE

public static final HTML.Attribute MULTIPLE

SELECTED

public static final HTML.Attribute SELECTED

ROWS

public static final HTML.Attribute ROWS

COLS

public static final HTML.Attribute COLS

DUMMY

public static final HTML.Attribute DUMMY

CELLSPACING

public static final HTML.Attribute CELLSPACING

CELLPADDING

public static final HTML.Attribute CELLPADDING

VALIGN

public static final HTML.Attribute VALIGN

HALIGN

public static final HTML.Attribute HALIGN

NOWRAP

public static final HTML.Attribute NOWRAP

ROWSPAN

public static final HTML.Attribute ROWSPAN

COLSPAN

public static final HTML.Attribute COLSPAN

PROMPT

public static final HTML.Attribute PROMPT

HTTPEQUIV

public static final HTML.Attribute HTTPEQUIV

CONTENT

public static final HTML.Attribute CONTENT

LANGUAGE

public static final HTML.Attribute LANGUAGE

VERSION

public static final HTML.Attribute VERSION

N

public static final HTML.Attribute N

FRAMEBORDER

public static final HTML.Attribute FRAMEBORDER

MARGINWIDTH

public static final HTML.Attribute MARGINWIDTH

MARGINHEIGHT

public static final HTML.Attribute MARGINHEIGHT

SCROLLING

public static final HTML.Attribute SCROLLING

NORESIZE

public static final HTML.Attribute NORESIZE

ENDTAG

public static final HTML.Attribute ENDTAG

COMMENT

public static final HTML.Attribute COMMENT
方法详细信息

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTML

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HTML

java.lang.Object
    继承者  com.trs.infra.util.html.HTML

public class HTML
extends java.lang.Object

嵌套类摘要
static class | HTML.Attribute Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
static class | HTML.Tag Typesafe enumeration for an html tag.
static class | HTML.UnknownTag
字段摘要
static java.lang.String NULL_ATTRIBUTE_VALUE
Fetch an integer attribute value.
构造方法摘要
HTML()
方法摘要
static HTML.Attribute[] | getAllAttributeKeys() This is the set of html attributes recognized.
static HTML.Tag[] | getAllTags() This is the set of actual html tags that are known about the the default html reader.
static HTML.Attribute | getAttributeKey(java.lang.String attName) Fetch an attribute constant for a well-known attribute name (i.e. one of the attributes in the set allAttributes).
static HTML.Tag | getTag(java.lang.String tagName) Fetch a tag constant for a well-known tag name (i.e. one of the tags in the set allTags).
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NULL_ATTRIBUTE_VALUE

public static final java.lang.String NULL_ATTRIBUTE_VALUE
Fetch an integer attribute value. Attribute values are stored as a string, and this is a convenience method to convert to an actual integer.

另请参见：
常量字段值
构造方法详细信息

HTML

public HTML()
方法详细信息

getAllTags

public static HTML.Tag[] getAllTags()
This is the set of actual html tags that are known about the the default html reader. This set does not include tags that are manufactured by the reader.

getTag

public static HTML.Tag getTag(java.lang.String tagName)
Fetch a tag constant for a well-known tag name (i.e. one of the tags in the set allTags). If the given name does not represent one of the well-known tags, then null will be returned.

getAllAttributeKeys

public static HTML.Attribute[] getAllAttributeKeys()
This is the set of html attributes recognized.

getAttributeKey

public static HTML.Attribute getAttributeKey(java.lang.String attName)
Fetch an attribute constant for a well-known attribute name (i.e. one of the attributes in the set allAttributes). If the given name does not represent one of the well-known attributes, then null will be returned.

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTML.Tag

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HTML.Tag

java.lang.Object
    继承者  com.trs.infra.util.html.HTML.Tag
直接已知子类：
HTML.UnknownTag
包容类：
HTML
public static class HTML.Tag
extends java.lang.Object

Typesafe enumeration for an html tag. Although the set of html tags is a closed set, we have let the set open so that people can add their own tag types to their custom parser and still communicate to the reader.

字段摘要
static HTML.Tag | A
static HTML.Tag | ADDRESS
static HTML.Tag | APPLET
static HTML.Tag | AREA
static HTML.Tag | B
static HTML.Tag | BASE
static HTML.Tag | BASEFONT
static HTML.Tag | BIG
static HTML.Tag | BLOCKQUOTE
static HTML.Tag | BODY
static HTML.Tag | BR
static HTML.Tag | CAPTION
static HTML.Tag | CENTER
static HTML.Tag | CITE
static HTML.Tag | CODE
static HTML.Tag | COMMENT All comments are labeled with this tag.
static HTML.Tag | CONTENT All text content is labeled with this tag.
static HTML.Tag | DD
static HTML.Tag | DFN
static HTML.Tag | DIR
static HTML.Tag | DIV
static HTML.Tag | DL
static HTML.Tag | DT
static HTML.Tag | EM
static HTML.Tag | FONT
static HTML.Tag | FORM
static HTML.Tag | FRAME
static HTML.Tag | FRAMESET
static HTML.Tag | H1
static HTML.Tag | H2
static HTML.Tag | H3
static HTML.Tag | H4
static HTML.Tag | H5
static HTML.Tag | H6
static HTML.Tag | HEAD
static HTML.Tag | HR
static HTML.Tag | HTML
static HTML.Tag | I
static HTML.Tag | IMG
static HTML.Tag | IMPLIED All text content must be in a paragraph element.
static HTML.Tag | INPUT
static HTML.Tag | ISINDEX
static HTML.Tag | KBD
static HTML.Tag | LI
static HTML.Tag | LINK
static HTML.Tag | MAP
static HTML.Tag | MENU
static HTML.Tag | META
static HTML.Tag | NOFRAMES
static HTML.Tag | OBJECT
static HTML.Tag | OL
static HTML.Tag | OPTION
static HTML.Tag | P
static HTML.Tag | PARAM
static HTML.Tag | PRE
static HTML.Tag | S
static HTML.Tag | SAMP
static HTML.Tag | SCRIPT
static HTML.Tag | SELECT
static HTML.Tag | SMALL
static HTML.Tag | SPAN
static HTML.Tag | STRIKE
static HTML.Tag | STRONG
static HTML.Tag | STYLE
static HTML.Tag | SUB
static HTML.Tag | SUP
static HTML.Tag | TABLE
static HTML.Tag | TBODY
static HTML.Tag | TD
static HTML.Tag | TEXTAREA
static HTML.Tag | TH
static HTML.Tag | TITLE
static HTML.Tag | TR
static HTML.Tag | TT
static HTML.Tag | U
static HTML.Tag | UL
static HTML.Tag | VAR
构造方法摘要
HTML.Tag()
方法摘要
boolean | breakBeforeBegin()
boolean | breakBeforeEnd()
boolean | breaksFlow() If the tag causes a line break, to the flow of data, then this method will return true.
boolean | isBlock() Block tags are tags that add structure to a document.
boolean | isPreformatted()
java.lang.String | toString() Return the string representation of the tag.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

A

public static final HTML.Tag A

ADDRESS

public static final HTML.Tag ADDRESS

APPLET

public static final HTML.Tag APPLET

AREA

public static final HTML.Tag AREA

B

public static final HTML.Tag B

BASE

public static final HTML.Tag BASE

BASEFONT

public static final HTML.Tag BASEFONT

BIG

public static final HTML.Tag BIG

BLOCKQUOTE

public static final HTML.Tag BLOCKQUOTE

BODY

public static final HTML.Tag BODY

BR

public static final HTML.Tag BR

CAPTION

public static final HTML.Tag CAPTION

CENTER

public static final HTML.Tag CENTER

CITE

public static final HTML.Tag CITE

CODE

public static final HTML.Tag CODE

DD

public static final HTML.Tag DD

DFN

public static final HTML.Tag DFN

DIR

public static final HTML.Tag DIR

DIV

public static final HTML.Tag DIV

DL

public static final HTML.Tag DL

DT

public static final HTML.Tag DT

EM

public static final HTML.Tag EM

FONT

public static final HTML.Tag FONT

FORM

public static final HTML.Tag FORM

FRAME

public static final HTML.Tag FRAME

FRAMESET

public static final HTML.Tag FRAMESET

H1

public static final HTML.Tag H1

H2

public static final HTML.Tag H2

H3

public static final HTML.Tag H3

H4

public static final HTML.Tag H4

H5

public static final HTML.Tag H5

H6

public static final HTML.Tag H6

HEAD

public static final HTML.Tag HEAD

HR

public static final HTML.Tag HR

HTML

public static final HTML.Tag HTML

I

public static final HTML.Tag I

IMG

public static final HTML.Tag IMG

INPUT

public static final HTML.Tag INPUT

ISINDEX

public static final HTML.Tag ISINDEX

KBD

public static final HTML.Tag KBD

LI

public static final HTML.Tag LI

LINK

public static final HTML.Tag LINK

MAP

public static final HTML.Tag MAP

MENU

public static final HTML.Tag MENU

META

public static final HTML.Tag META

NOFRAMES

public static final HTML.Tag NOFRAMES

OBJECT

public static final HTML.Tag OBJECT

OL

public static final HTML.Tag OL

OPTION

public static final HTML.Tag OPTION

P

public static final HTML.Tag P

PARAM

public static final HTML.Tag PARAM

PRE

public static final HTML.Tag PRE

SAMP

public static final HTML.Tag SAMP

SCRIPT

public static final HTML.Tag SCRIPT

SELECT

public static final HTML.Tag SELECT

SMALL

public static final HTML.Tag SMALL

SPAN

public static final HTML.Tag SPAN

STRIKE

public static final HTML.Tag STRIKE

S

public static final HTML.Tag S

STRONG

public static final HTML.Tag STRONG

STYLE

public static final HTML.Tag STYLE

SUB

public static final HTML.Tag SUB

SUP

public static final HTML.Tag SUP

TABLE

public static final HTML.Tag TABLE

TBODY

public static final HTML.Tag TBODY

TR

public static final HTML.Tag TR

TD

public static final HTML.Tag TD

TEXTAREA

public static final HTML.Tag TEXTAREA

TH

public static final HTML.Tag TH

TITLE

public static final HTML.Tag TITLE

TT

public static final HTML.Tag TT

U

public static final HTML.Tag U

UL

public static final HTML.Tag UL

VAR

public static final HTML.Tag VAR

IMPLIED

public static final HTML.Tag IMPLIED
All text content must be in a paragraph element. If a paragraph didn't exist when content was encountered, a paragraph is manufactured.

This is a tag synthesized by the html reader. Since elements are identified by their tag type, we create a some fake tag types to mark the elements that were manufactured.

CONTENT

public static final HTML.Tag CONTENT
All text content is labeled with this tag.

This is a tag synthesized by the html reader. Since elements are identified by their tag type, we create a some fake tag types to mark the elements that were manufactured.

COMMENT

public static final HTML.Tag COMMENT
All comments are labeled with this tag.

This is a tag synthesized by the html reader. Since elements are identified by their tag type, we create a some fake tag types to mark the elements that were manufactured.

构造方法详细信息

HTML.Tag

public HTML.Tag()
方法详细信息

isBlock

public boolean isBlock()
Block tags are tags that add structure to a document.

breaksFlow

public boolean breaksFlow()
If the tag causes a line break, to the flow of data, then this method will return true.

isPreformatted

public boolean isPreformatted()

breakBeforeBegin

public boolean breakBeforeBegin()

breakBeforeEnd

public boolean breakBeforeEnd()

toString

public java.lang.String toString()
Return the string representation of the tag.

覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTML.UnknownTag

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HTML.UnknownTag

java.lang.Object
    继承者  com.trs.infra.util.html.HTML.Tag
        继承者  com.trs.infra.util.html.HTML.UnknownTag
所有已实现的接口：
java.io.Serializable
包容类：
HTML
public static class HTML.UnknownTag
extends HTML.Tag
implements java.io.Serializable

另请参见：
序列化表格

字段摘要
从类 com.trs.infra.util.html.HTML.Tag 继承的字段
A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, COMMENT, CONTENT, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, IMPLIED, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, S, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, STRONG, STYLE, SUB, SUP, TABLE, TBODY, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR
构造方法摘要
HTML.UnknownTag(java.lang.String id)
方法摘要
boolean | equals(java.lang.Object obj) Compares this object to the specifed object.
int | hashCode()
从类 com.trs.infra.util.html.HTML.Tag 继承的方法
breakBeforeBegin, breakBeforeEnd, breaksFlow, isBlock, isPreformatted, toString
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

HTML.UnknownTag

public HTML.UnknownTag(java.lang.String id)
方法详细信息

hashCode

public int hashCode()
覆盖：
类 java.lang.Object 中的 hashCode

equals

public boolean equals(java.lang.Object obj)
Compares this object to the specifed object. The result is true if and only if the argument is not null and is a UnknownTag object with the same name.

覆盖：
类 java.lang.Object 中的 equals
参数：
obj - the object to compare this tag with.
返回：
true if the objects are equal; false otherwise.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlAttribute

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HtmlAttribute

java.lang.Object
    继承者  com.trs.infra.util.html.HtmlAttribute
所有已实现的接口：
java.lang.Cloneable
public class HtmlAttribute
extends java.lang.Object
implements java.lang.Cloneable

构造方法摘要
HtmlAttribute(java.lang.String _strSrc)
构造函数
HtmlAttribute(java.lang.String _name, java.lang.String _value)
构造函数
HtmlAttribute(java.lang.String _name, java.lang.String _value, char _quote)
构造函数
方法摘要
java.lang.Object | clone() 对象克隆
boolean | fromString(java.lang.String _strSrc) 字符串导入 字符串格式：属性名=属性值
boolean | getBooleanValue() 将属性值转化为boolean值
HtmlDocument | getDocument() 取属性所属文档对象
double | getDoubleValue() 将属性值转化为双精度数
float | getFloatValue() 将属性值转化为浮点数
int | getIntValue() 将属性值转化为整型
long | getLongValue() 将属性值转化为长整型
java.lang.String | getName() 获取名称
HtmlElement | getParent() 获取所属元素对象
java.lang.String | getValue() 获取属性值
static void | main(java.lang.String[] args)
boolean | nameIs(java.lang.String _name) 判断名称是否为指定的名字
HtmlAttribute | setName(java.lang.String _name) 设置属性名称
HtmlAttribute | setParent(HtmlElement _parent) 设置
HtmlAttribute | setValue(java.lang.String _value) 设置属性值
java.lang.String | toString() 字符串导出
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HtmlAttribute

public HtmlAttribute(java.lang.String _name,
                     java.lang.String _value)
构造函数

参数：
_name - 属性名称
_value - 属性值

HtmlAttribute

public HtmlAttribute(java.lang.String _name,
                     java.lang.String _value,
                     char _quote)
构造函数

参数：
_name - 属性名称
_value - 属性值

HtmlAttribute

public HtmlAttribute(java.lang.String _strSrc)
构造函数

参数：
_strSrc - 属性字符串，字符串格式：属性名=属性值
方法详细信息

getParent

public HtmlElement getParent()
获取所属元素对象

返回：

setParent

public HtmlAttribute setParent(HtmlElement _parent)
设置

参数：
_parent -
返回：

getName

public java.lang.String getName()
获取名称

返回：

setName

public HtmlAttribute setName(java.lang.String _name)
设置属性名称

参数：
_name -
返回：

nameIs

public boolean nameIs(java.lang.String _name)
判断名称是否为指定的名字

参数：
_name - 属性名称
返回：

getValue

public java.lang.String getValue()
获取属性值

返回：

setValue

public HtmlAttribute setValue(java.lang.String _value)
设置属性值

参数：
_value -
返回：

getIntValue

public int getIntValue()
                throws CMyException
将属性值转化为整型

返回：
抛出：
CMyException

getLongValue

public long getLongValue()
                  throws CMyException
将属性值转化为长整型

返回：
抛出：
CMyException

getFloatValue

public float getFloatValue()
                    throws CMyException
将属性值转化为浮点数

返回：
抛出：
CMyException

getDoubleValue

public double getDoubleValue()
                      throws CMyException
将属性值转化为双精度数

返回：
抛出：
CMyException

getBooleanValue

public boolean getBooleanValue()
                        throws CMyException
将属性值转化为boolean值

返回：
抛出：
CMyException

getDocument

public HtmlDocument getDocument()
取属性所属文档对象

返回：

clone

public java.lang.Object clone()
对象克隆

覆盖：
类 java.lang.Object 中的 clone
返回：

toString

public final java.lang.String toString()
字符串导出

覆盖：
类 java.lang.Object 中的 toString
返回：

fromString

public boolean fromString(java.lang.String _strSrc)
字符串导入 字符串格式：属性名=属性值

参数：
_strSrc -
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlComment

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HtmlComment

java.lang.Object
    继承者  com.trs.infra.util.html.HtmlComment
所有已实现的接口：
java.lang.Cloneable
public class HtmlComment
extends java.lang.Object
implements java.lang.Cloneable

Title: TRS 内容协作平台（TRS WCM）

Description:

class HtmlComment —— 解析HTML中注释部分

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | TAG_END
static java.lang.String | TAG_START
构造方法摘要
HtmlComment(java.lang.String _text)
构造函数
方法摘要
java.lang.Object | clone() 对象克隆
boolean | fromString(java.lang.String _strSrc) 字符串导入，字符串格式：
HtmlDocument | getDocument() 获取所在的HtmlDocument
HtmlElement | getParent() 获取父元素对象
java.lang.String | getText() 获取注释内容
boolean | isRootComment() 判断是否为根元素
static void | main(java.lang.String[] args)
HtmlComment | setDocument(HtmlDocument _document) 直接设定了Document对象，表示为根元素
HtmlComment | setParent(HtmlElement _parent) 设置父元素对象
HtmlComment | setText(java.lang.String _text) 设置注释内容
java.lang.String | toString() 字符串导出
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

TAG_START

public static final java.lang.String TAG_START
另请参见：
常量字段值

TAG_END

public static final java.lang.String TAG_END
另请参见：
常量字段值
构造方法详细信息

HtmlComment

public HtmlComment(java.lang.String _text)
构造函数

参数：
_text - 注释内容
方法详细信息

getDocument

public HtmlDocument getDocument()
获取所在的HtmlDocument

返回：

setDocument

public HtmlComment setDocument(HtmlDocument _document)
直接设定了Document对象，表示为根元素

参数：
_document -
返回：

getParent

public HtmlElement getParent()
获取父元素对象

返回：

setParent

public HtmlComment setParent(HtmlElement _parent)
设置父元素对象

参数：
_parent -
返回：

getText

public java.lang.String getText()
获取注释内容

返回：

setText

public HtmlComment setText(java.lang.String _text)
设置注释内容

参数：
_text - 注释内容
返回：

isRootComment

public boolean isRootComment()
判断是否为根元素

返回：

clone

public java.lang.Object clone()
对象克隆

覆盖：
类 java.lang.Object 中的 clone
返回：

toString

public java.lang.String toString()
字符串导出

覆盖：
类 java.lang.Object 中的 toString
返回：

fromString

public boolean fromString(java.lang.String _strSrc)
字符串导入，字符串格式：

参数：
_strSrc -
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlDocument

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HtmlDocument

java.lang.Object
    继承者  com.trs.infra.util.html.HtmlDocument

public class HtmlDocument
extends java.lang.Object

构造方法摘要
HtmlDocument()
构造函数
HtmlDocument(HtmlElement _rootElement)
构造函数
方法摘要
HtmlDocument | addContent(HtmlComment _comment) 在文档内容列表中，添加一个注释对象
boolean | fromString(java.lang.String _strSrc) 从字符串导入 处理方式：构造虚拟的HtmlElement元素，由其解释
java.util.List | getContent() 获取内容
java.util.List | getElementsByName(java.lang.String _name) 取文档中指定名字的所有元素
HtmlElement | getRootElement() 取根元素 操作：从content中查找第一个HtmlElement元素，即看作根元素
boolean | loadFromFile(java.lang.String _sFilePathName) 从文件中装载
static void | main(java.lang.String[] args)
void | saveToFile(java.lang.String _sFilePathName) 将Html文档内容保存到文件
HtmlDocument | setContent(java.util.List _newContent) 设置Html文档内容,要求：有且仅有一个根元素
HtmlDocument | setRootElement(HtmlElement _rootElement) 设置根元素 操作：检查是否已经存在根元素。
java.lang.String | toString() 将文档内容输出为字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HtmlDocument

public HtmlDocument()
构造函数

HtmlDocument

public HtmlDocument(HtmlElement _rootElement)
构造函数

参数：
_rootElement - 根元素
方法详细信息

getContent

public java.util.List getContent()
获取内容

返回：

setContent

public HtmlDocument setContent(java.util.List _newContent)
                        throws CMyException
设置Html文档内容,要求：有且仅有一个根元素

参数：
_newContent -
返回：
抛出：
CMyException

getRootElement

public HtmlElement getRootElement()
取根元素 操作：从content中查找第一个HtmlElement元素，即看作根元素

返回：

setRootElement

public HtmlDocument setRootElement(HtmlElement _rootElement)
设置根元素 操作：检查是否已经存在根元素。若已经存在，则替换；否则，添加到content中。

参数：
_rootElement - 根元素
返回：

addContent

public HtmlDocument addContent(HtmlComment _comment)
                        throws CMyException
在文档内容列表中，添加一个注释对象

参数：
_comment - 注释对象
返回：
抛出：
CMyException

getElementsByName

public java.util.List getElementsByName(java.lang.String _name)
取文档中指定名字的所有元素

参数：
_name -
返回：

toString

public java.lang.String toString()
将文档内容输出为字符串

覆盖：
类 java.lang.Object 中的 toString
返回：

fromString

public boolean fromString(java.lang.String _strSrc)
                   throws CMyException
从字符串导入 处理方式：构造虚拟的HtmlElement元素，由其解释

参数：
_strSrc -
返回：
抛出：
CMyException

loadFromFile

public boolean loadFromFile(java.lang.String _sFilePathName)
                     throws CMyException
从文件中装载

参数：
_sFilePathName - 文件名
返回：
抛出：
CMyException

saveToFile

public void saveToFile(java.lang.String _sFilePathName)
                throws CMyException
将Html文档内容保存到文件

参数：
_sFilePathName - 目标文件名
抛出：
CMyException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlElement

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HtmlElement

java.lang.Object
    继承者  com.trs.infra.util.html.HtmlElement
所有已实现的接口：
java.lang.Cloneable
public class HtmlElement
extends java.lang.Object
implements java.lang.Cloneable

字段摘要
static int | CON_COMMENT 内容类型：HtmlComment(注释)
static int | CON_ELEMENT 内容类型：HtmlElement(HTML元素)
static int | CON_TEXT 内容类型：Text(纯文本)
static boolean | ISDEBUG 调试模式开关
boolean | ONLY_SEARCH_SELF
static java.lang.String | TAG_ALONE
static java.lang.String | TAG_SHORT
static java.lang.String | TAGS_TOSKIP 可以跳过的标记列表
构造方法摘要
HtmlElement()
构造函数
HtmlElement(java.lang.String _name)
构造函数
方法摘要
HtmlElement | addContent(HtmlComment _comment) 添加一个注释对象
HtmlElement | addContent(HtmlElement _element) 添加一个HtmlElement
HtmlElement | addContent(java.lang.String _text) 添加内容
static boolean | checkTagIn(java.lang.String _sTagName, java.lang.String _sNameList) 判断指定的元素标记，是否在指定的标记列表中
int | fromString(char[] _srcBuffer, int _nStart)
int | fromString(char[] _srcBuffer, int _nStart, java.lang.String _sTagsToSkip) 从指定的字符串中导入元素信息
int | fromString(java.lang.String _strSrc)
int | fromString(java.lang.String _strSrc, java.lang.String _sTagsToSkip) 字符串导入,字符串格式：<名称 属性列表> 内容|子元素列表 </名称>
HtmlAttribute | getAttribute(java.lang.String _name) 获取指定名称的属性对象
java.util.List | getAttributes() 获取元素中所有的属性对象列表
java.lang.String | getAttributeValue(java.lang.String _name) 获取元素中指定属性的值
HtmlElement | getChild(java.lang.String _name) 获取第一个指定名称的子元素
java.util.List | getChildren() 获取所有的子元素
java.util.List | getChildren(java.lang.String _name) 获取指定名称的子元素列表
java.util.List | getContent() 获取元素中所有内容列表
HtmlDocument | getDocument() 获取所在的文档对象
java.util.List | getElementsByName(java.lang.String _name) 获取所有指定名字的元素（包括多级子元素）
int | getLevel() 获得该元素的层次（根元素层次为0）
java.lang.String | getName() 获取Html元素标记
HtmlElement | getParent() 获取父元素对象
HTML.Tag | getTag() 获取Tag对象
java.lang.String | getText() 取元素内容中的文本部分 说明：文本部分，仅仅包括String对象；不包括HtmlComment和HtmlElement部分
boolean | hasChildren() 判断是否含有子元素
static boolean | isAloneTag(java.lang.String _name) 判断指定的Html元素标记，是否为独立（即自封闭）标记
boolean | isAncestorOf(HtmlElement _element) 判断当前元素是否为指定元素的祖先
boolean | isRootElement() 判断该元素是否为根元素
static void | main(java.lang.String[] args)
boolean | nameIs(java.lang.String _name) 判断当前对象是否是指定的Html元素标记
boolean | removeAttribute(java.lang.String _name) 删除指定的属性
boolean | removeContent(HtmlComment _comment) 删除注释对象
boolean | removeContent(HtmlElement _element) 删除一个HTMLElement对象
HtmlElement | setAttribute(HtmlAttribute _attribute) 设置属性
HtmlElement | setAttribute(java.lang.String _name, java.lang.String _value) 设置指定属性的值
HtmlElement | setAttribute(java.lang.String _name, java.lang.String _value, char _quote)
HtmlElement | setAttributes(java.util.List _attributes) 设置元素的属性
HtmlElement | setDocument(HtmlDocument _document) 设定所在的文档对象
HtmlElement | setName(java.lang.String _name) 设置Html元素标记
HtmlElement | setParent(HtmlElement _parent) 设置父元素对象
java.lang.String | toString()
java.lang.String | toString(boolean _bIncludingTag, boolean _bFormat)
java.lang.String | toString(boolean _bIncludingTag, boolean _bFormat, java.lang.String _sTagNamesSkipped) 字符串导出
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

CON_COMMENT

public static final int CON_COMMENT
内容类型：HtmlComment(注释)

另请参见：
常量字段值

CON_ELEMENT

public static final int CON_ELEMENT
内容类型：HtmlElement(HTML元素)

另请参见：
常量字段值

CON_TEXT

public static final int CON_TEXT
内容类型：Text(纯文本)

另请参见：
常量字段值

TAGS_TOSKIP

public static final java.lang.String TAGS_TOSKIP
可以跳过的标记列表

另请参见：
常量字段值

ISDEBUG

public static boolean ISDEBUG
调试模式开关

TAG_ALONE

public static final java.lang.String TAG_ALONE
另请参见：
常量字段值

TAG_SHORT

public static final java.lang.String TAG_SHORT
另请参见：
常量字段值

ONLY_SEARCH_SELF

public boolean ONLY_SEARCH_SELF
构造方法详细信息

HtmlElement

public HtmlElement()
构造函数

HtmlElement

public HtmlElement(java.lang.String _name)
构造函数

参数：
_name - 元素名称
方法详细信息

isAloneTag

public static boolean isAloneTag(java.lang.String _name)
判断指定的Html元素标记，是否为独立（即自封闭）标记

参数：
_name - Html元素标记
返回：

checkTagIn

public static boolean checkTagIn(java.lang.String _sTagName,
                                 java.lang.String _sNameList)
判断指定的元素标记，是否在指定的标记列表中

参数：
_sTagName - 元素标记名称
_sNameList - 标记名称列表
返回：
若指定的元素标记在名称列表中，则返回true；否则返回false.

getName

public java.lang.String getName()
获取Html元素标记

返回：

nameIs

public boolean nameIs(java.lang.String _name)
判断当前对象是否是指定的Html元素标记

参数：
_name -
返回：

setName

public HtmlElement setName(java.lang.String _name)
设置Html元素标记

参数：
_name -
返回：

getTag

public HTML.Tag getTag()
获取Tag对象

返回：

getDocument

public HtmlDocument getDocument()
获取所在的文档对象

返回：

setDocument

public HtmlElement setDocument(HtmlDocument _document)
设定所在的文档对象

参数：
_document -
返回：

getParent

public HtmlElement getParent()
获取父元素对象

返回：

setParent

public HtmlElement setParent(HtmlElement _parent)
设置父元素对象

参数：
_parent -
返回：

getAttributes

public java.util.List getAttributes()
获取元素中所有的属性对象列表

返回：

getContent

public java.util.List getContent()
获取元素中所有内容列表

返回：

getAttribute

public HtmlAttribute getAttribute(java.lang.String _name)
获取指定名称的属性对象

参数：
_name - 属性名称
返回：

getAttributeValue

public java.lang.String getAttributeValue(java.lang.String _name)
获取元素中指定属性的值

参数：
_name - 属性名称
返回：

setAttributes

public HtmlElement setAttributes(java.util.List _attributes)
设置元素的属性

参数：
_attributes - 属性对象列表
返回：

setAttribute

public HtmlElement setAttribute(java.lang.String _name,
                                java.lang.String _value)
设置指定属性的值

参数：
_name - 属性名称
_value - 属性值
返回：

setAttribute

public HtmlElement setAttribute(java.lang.String _name,
                                java.lang.String _value,
                                char _quote)

setAttribute

public HtmlElement setAttribute(HtmlAttribute _attribute)
设置属性

参数：
_attribute - 属性对象
返回：

removeAttribute

public boolean removeAttribute(java.lang.String _name)
删除指定的属性

参数：
_name - 属性名称
返回：

addContent

public HtmlElement addContent(java.lang.String _text)
添加内容

参数：
_text -
返回：

addContent

public HtmlElement addContent(HtmlElement _element)
                       throws CMyException
添加一个HtmlElement

参数：
_element - HtmlElement对象
返回：
@throws CMyException
抛出：
CMyException

addContent

public HtmlElement addContent(HtmlComment _comment)
                       throws CMyException
添加一个注释对象

参数：
_comment - 注释对象
返回：
@throws CMyException
抛出：
CMyException

removeContent

public boolean removeContent(HtmlComment _comment)
删除注释对象

参数：
_comment - 注释对象
返回：

removeContent

public boolean removeContent(HtmlElement _element)
删除一个HTMLElement对象

参数：
_element - HTMLElement对象
返回：

hasChildren

public boolean hasChildren()
判断是否含有子元素

返回：

getChildren

public java.util.List getChildren()
获取所有的子元素

返回：

getChildren

public java.util.List getChildren(java.lang.String _name)
获取指定名称的子元素列表

参数：
_name - 元素名称
返回：

getChild

public HtmlElement getChild(java.lang.String _name)
获取第一个指定名称的子元素

参数：
_name - 元素名称
返回：

getText

public java.lang.String getText()
取元素内容中的文本部分
说明：文本部分，仅仅包括String对象；不包括HtmlComment和HtmlElement部分

返回：

isRootElement

public boolean isRootElement()
判断该元素是否为根元素

返回：

getLevel

public int getLevel()
获得该元素的层次（根元素层次为0）

返回：

isAncestorOf

public boolean isAncestorOf(HtmlElement _element)
判断当前元素是否为指定元素的祖先

参数：
_element - 指定的HTMLElement
返回：

getElementsByName

public java.util.List getElementsByName(java.lang.String _name)
获取所有指定名字的元素（包括多级子元素）

参数：
_name -
返回：

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
另请参见：
String toString( boolean _bIncludingTag, boolean _bFormat )

toString

public java.lang.String toString(boolean _bIncludingTag,
                                 boolean _bFormat,
                                 java.lang.String _sTagNamesSkipped)
字符串导出

参数：
_bIncludingTag - 是否包含Tag;若为false则，仅仅输出内容，默认为true
_bFormat - 是否格式化（为true时，元素的输出，将按照其所在的层次关系输出前导空格），默认为false
返回：

toString

public java.lang.String toString(boolean _bIncludingTag,
                                 boolean _bFormat)

fromString

public int fromString(java.lang.String _strSrc,
                      java.lang.String _sTagsToSkip)
               throws CMyException
字符串导入,字符串格式：<名称 属性列表> 内容|子元素列表 </名称>

参数：
_strSrc - 源字符串
_sTagsToSkip - 需要跳过处理的标记名称列表
返回：
@throws CMyException
抛出：
CMyException

fromString

public int fromString(java.lang.String _strSrc)
               throws CMyException
抛出：
CMyException

fromString

public int fromString(char[] _srcBuffer,
                      int _nStart,
                      java.lang.String _sTagsToSkip)
               throws CMyException
从指定的字符串中导入元素信息

参数：
_srcBuffer - 字符串缓冲区
_nStart - 起始位置
_sTagsToSkip - 需要跳过的标记名称，如"P,FORM"。
返回：
下一个元素的起始位置；若失败，则返回0；若非法，则返回-1。
抛出：
CMyException

fromString

public int fromString(char[] _srcBuffer,
                      int _nStart)
               throws CMyException
抛出：
CMyException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlElementFinder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HtmlElementFinder

java.lang.Object
    继承者  com.trs.infra.util.html.HtmlElementFinder

public class HtmlElementFinder
extends java.lang.Object

字段摘要
 java.lang.StringBuffer conBuffer
内容缓冲区
构造方法摘要
HtmlElementFinder()
构造函数
HtmlElementFinder(char[] _src)
构造函数
HtmlElementFinder(java.lang.String _src)
构造函数
方法摘要
HtmlElement | findNextElement(java.lang.String _sName) 找到下一个指定名称的元素
HtmlElement | findNextElement(java.lang.String _sName, boolean _bOnlySearchSelf)
HtmlElement | findNextElement(java.lang.String _sName, boolean _bOnlySearchSelf, java.lang.String _sTagsToSkip) 找到下一个指定名称的元素
java.lang.String | getContent() 取Html内容
static void | main(java.lang.String[] args)
HtmlElementFinder | putElement(HtmlElement _element) 在Html文本内容的当前位置，插入元素的内容
HtmlElementFinder | putHTML(java.lang.String _sHTML) 在Html文本内容的当前位置，插入HTML内容
HtmlElementFinder | setHtmlSrc(char[] _src) 设置Html文本源
HtmlElementFinder | setHtmlSrc(java.lang.String _src) 设置Html文本源
void | setPosition(int _nPos) 设置Html检索的起始位置
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

conBuffer

public java.lang.StringBuffer conBuffer
内容缓冲区

构造方法详细信息

HtmlElementFinder

public HtmlElementFinder()
构造函数

HtmlElementFinder

public HtmlElementFinder(java.lang.String _src)
构造函数

参数：
_src - Html文本源

HtmlElementFinder

public HtmlElementFinder(char[] _src)
构造函数

参数：
_src - Html文本源
方法详细信息

setPosition

public void setPosition(int _nPos)
设置Html检索的起始位置

参数：
_nPos -

setHtmlSrc

public HtmlElementFinder setHtmlSrc(java.lang.String _src)
设置Html文本源

参数：
_src - Html文本源
返回：

setHtmlSrc

public HtmlElementFinder setHtmlSrc(char[] _src)
设置Html文本源

参数：
_src - Html文本源
返回：

getContent

public java.lang.String getContent()
取Html内容

返回：
Html内容

findNextElement

public HtmlElement findNextElement(java.lang.String _sName)
找到下一个指定名称的元素

参数：
_sName - 元素名称
返回：
若找到，则返回找到的元素；否则，返回null

findNextElement

public HtmlElement findNextElement(java.lang.String _sName,
                                   boolean _bOnlySearchSelf,
                                   java.lang.String _sTagsToSkip)
找到下一个指定名称的元素

参数：
_sName - 元素名称
返回：
若找到，则返回找到的元素；否则，返回null

findNextElement

public HtmlElement findNextElement(java.lang.String _sName,
                                   boolean _bOnlySearchSelf)

putElement

public HtmlElementFinder putElement(HtmlElement _element)
在Html文本内容的当前位置，插入元素的内容

参数：
_element - HTML元素
返回：

putHTML

public HtmlElementFinder putHTML(java.lang.String _sHTML)
在Html文本内容的当前位置，插入HTML内容

参数：
_sHTML - HTML元素
返回：

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.html
类 HtmlUtil

java.lang.Object
    继承者  com.trs.infra.util.html.HtmlUtil

public class HtmlUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
HTML text render utilities.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
static java.lang.String calParentRelativePath(java.lang.String _sChildDataPath)
Calculates the parent relative path of current child.
static java.lang.String calRelativePath(java.lang.String _sUrl1, java.lang.String _sUrl2)
Calculates the relative path between two urls.
static java.lang.String extractProtocolInURL(java.lang.String _sUrl, java.lang.String _sDefault)
Retuns protocol name in the specified URL if it includes protocol part;
other, returns the default protocol given.
static boolean isAbsoluteURL(java.lang.String url)
判断指定的URL是不是站内地址，即是不是“http://www.abc.com/abc/abc.htm”的形式
static boolean isAbsoluteURLinSite(java.lang.String url)
判断指定的URL是不是站内绝对地址，即是不是“/abc/abc.htm”的形式
static java.lang.String newRelativeURL(java.lang.String sReference, java.lang.String sRelative)
static java.lang.String renderImage(java.lang.String _sSrc, java.lang.String _sAlt, java.lang.String _sExtra)
组合生成HTML [image] 元素
static java.lang.String renderImage(java.lang.String _sSrc, java.lang.String _sAlt, java.lang.String _sExtra, java.lang.String _sWidth, java.lang.String _sHeight)
组合生成HTML [image] 元素
static java.lang.String renderLink(java.lang.String _sHref, java.lang.String _sTarget, java.lang.String _sAlt, java.lang.String _sExtra, java.lang.String _sDesc)
组合生成HTML 元素
static java.lang.String renderLink(java.lang.String _sHref, java.lang.String _sTarget, java.lang.String _sAlt, java.lang.String _sExtra, java.lang.String _sDesc, java.lang.String _sLinkText)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

renderLink

public static java.lang.String renderLink(java.lang.String _sHref,
                                          java.lang.String _sTarget,
                                          java.lang.String _sAlt,
                                          java.lang.String _sExtra,
                                          java.lang.String _sDesc)
组合生成HTML 元素

参数：
_sHref - 链接地址
_sTarget - 目标框架
_sAlt - 提示信息
_sExtra - 附加属性
_sDesc - 描述

renderLink

public static java.lang.String renderLink(java.lang.String _sHref,
                                          java.lang.String _sTarget,
                                          java.lang.String _sAlt,
                                          java.lang.String _sExtra,
                                          java.lang.String _sDesc,
                                          java.lang.String _sLinkText)

renderImage

public static java.lang.String renderImage(java.lang.String _sSrc,
                                           java.lang.String _sAlt,
                                           java.lang.String _sExtra)
组合生成HTML [image] 元素

参数：
_sSrc - 源地址
_sAlt - 提示信息
_sExtra - 附加属性
返回：
元素HTML文本
抛出：
java.lang.Exception - 构造失败，会抛出异常。

renderImage

public static java.lang.String renderImage(java.lang.String _sSrc,
                                           java.lang.String _sAlt,
                                           java.lang.String _sExtra,
                                           java.lang.String _sWidth,
                                           java.lang.String _sHeight)
组合生成HTML [image] 元素

参数：
_sSrc - 源地址
_sAlt - 提示信息
_sExtra - 附加属性
_sWidth - 图片宽度
_sHeight - 图片高度
返回：
元素HTML文本
抛出：
java.lang.Exception - 构造失败，会抛出异常。

extractProtocolInURL

public static java.lang.String extractProtocolInURL(java.lang.String _sUrl,
                                                    java.lang.String _sDefault)
Retuns protocol name in the specified URL if it includes protocol part;
other, returns the default protocol given.

参数：
_sUrl - the specified URL
_sDefault - default protocol if the URL does not include protocol part.
返回：
protocol name in the specified URL if it includes protocol part;
other, returns the default protocol given.

calRelativePath

public static java.lang.String calRelativePath(java.lang.String _sUrl1,
                                               java.lang.String _sUrl2)
Calculates the relative path between two urls.

参数：
_sUrl1 - url to calculate relative path
_sUrl2 - url to compare with
返回：
the relative path of url1 compared with url2.

calParentRelativePath

public static java.lang.String calParentRelativePath(java.lang.String _sChildDataPath)
Calculates the parent relative path of current child.

参数：
_sChildDataPath - the child data path.
返回：
the parent relative path of current child

isAbsoluteURL

public static boolean isAbsoluteURL(java.lang.String url)
判断指定的URL是不是站内地址，即是不是“http://www.abc.com/abc/abc.htm”的形式

参数：
url - 指定的URL
返回：
是绝对地址返回true，否则返回false

isAbsoluteURLinSite

public static boolean isAbsoluteURLinSite(java.lang.String url)
判断指定的URL是不是站内绝对地址，即是不是“/abc/abc.htm”的形式

参数：
url - 指定的URL
返回：
是站内绝对地址返回true，否则返回false

newRelativeURL

public static java.lang.String newRelativeURL(java.lang.String sReference,
                                              java.lang.String sRelative)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.html
类
ContentLinkReplacer
HTML
HTML.Attribute
HTML.Tag
HTML.UnknownTag
HtmlAttribute
HtmlComment
HtmlDocument
HtmlElement
HtmlElementFinder
HtmlUtil


com.trs.infra.util.html

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.html

类摘要
ContentLinkReplacer |
HTML |
HTML.Attribute | Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
HTML.Tag | Typesafe enumeration for an html tag.
HTML.UnknownTag |
HtmlAttribute |
HtmlComment | Title: TRS 内容协作平台（TRS WCM） Description: class HtmlComment —— 解析HTML中注释部分 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
HtmlDocument |
HtmlElement |
HtmlElementFinder |
HtmlUtil | Title: TRS 内容协作平台（TRS WCM） Description: HTML text render utilities.


com.trs.infra.util.html 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.html 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.html.ContentLinkReplacer
    • com.trs.infra.util.html.HTML
    • com.trs.infra.util.html.HTML.Attribute
    • com.trs.infra.util.html.HTML.Tag
      • com.trs.infra.util.html.HTML.UnknownTag (implements java.io.Serializable)
    • com.trs.infra.util.html.HtmlAttribute (implements java.lang.Cloneable)
    • com.trs.infra.util.html.HtmlComment (implements java.lang.Cloneable)
    • com.trs.infra.util.html.HtmlDocument
    • com.trs.infra.util.html.HtmlElement (implements java.lang.Cloneable)
    • com.trs.infra.util.html.HtmlElementFinder
    • com.trs.infra.util.html.HtmlUtil


软件包 com.trs.infra.util.html 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.html
的使用

使用 com.trs.infra.util.html 的软件包
com.trs.infra.util.html

com.trs.infra.util.html 使用的 com.trs.infra.util.html 中的类
HTML.Attribute
Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
HTML.Tag
Typesafe enumeration for an html tag.
HtmlAttribute
HtmlComment
Title: TRS 内容协作平台（TRS WCM） Description: class HtmlComment —— 解析HTML中注释部分 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
HtmlDocument
HtmlElement
HtmlElementFinder

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.ContentLinkReplacer 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.ContentLinkReplacer
的使用

没有 com.trs.infra.util.html.ContentLinkReplacer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HTML.Attribute 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HTML.Attribute
的使用

使用 HTML.Attribute 的软件包
com.trs.infra.util.html

com.trs.infra.util.html 中 HTML.Attribute 的使用

声明为 HTML.Attribute 的 com.trs.infra.util.html 中的字段
static HTML.Attribute | HTML.Attribute.ACTION
static HTML.Attribute | HTML.Attribute.ALIGN
static HTML.Attribute | HTML.Attribute.ALINK
static HTML.Attribute | HTML.Attribute.ALT
static HTML.Attribute | HTML.Attribute.ARCHIVE
static HTML.Attribute | HTML.Attribute.BACKGROUND
static HTML.Attribute | HTML.Attribute.BGCOLOR
static HTML.Attribute | HTML.Attribute.BORDER
static HTML.Attribute | HTML.Attribute.CELLPADDING
static HTML.Attribute | HTML.Attribute.CELLSPACING
static HTML.Attribute | HTML.Attribute.CHECKED
static HTML.Attribute | HTML.Attribute.CLASS
static HTML.Attribute | HTML.Attribute.CLASSID
static HTML.Attribute | HTML.Attribute.CLEAR
static HTML.Attribute | HTML.Attribute.CODE
static HTML.Attribute | HTML.Attribute.CODEBASE
static HTML.Attribute | HTML.Attribute.CODETYPE
static HTML.Attribute | HTML.Attribute.COLOR
static HTML.Attribute | HTML.Attribute.COLS
static HTML.Attribute | HTML.Attribute.COLSPAN
static HTML.Attribute | HTML.Attribute.COMMENT
static HTML.Attribute | HTML.Attribute.COMPACT
static HTML.Attribute | HTML.Attribute.CONTENT
static HTML.Attribute | HTML.Attribute.COORDS
static HTML.Attribute | HTML.Attribute.DATA
static HTML.Attribute | HTML.Attribute.DECLARE
static HTML.Attribute | HTML.Attribute.DIR
static HTML.Attribute | HTML.Attribute.DUMMY
static HTML.Attribute | HTML.Attribute.ENCTYPE
static HTML.Attribute | HTML.Attribute.ENDTAG
static HTML.Attribute | HTML.Attribute.FACE
static HTML.Attribute | HTML.Attribute.FRAMEBORDER
static HTML.Attribute | HTML.Attribute.HALIGN
static HTML.Attribute | HTML.Attribute.HEIGHT
static HTML.Attribute | HTML.Attribute.HREF
static HTML.Attribute | HTML.Attribute.HSPACE
static HTML.Attribute | HTML.Attribute.HTTPEQUIV
static HTML.Attribute | HTML.Attribute.ID
static HTML.Attribute | HTML.Attribute.ISMAP
static HTML.Attribute | HTML.Attribute.LANG
static HTML.Attribute | HTML.Attribute.LANGUAGE
static HTML.Attribute | HTML.Attribute.LINK
static HTML.Attribute | HTML.Attribute.LOWSRC
static HTML.Attribute | HTML.Attribute.MARGINHEIGHT
static HTML.Attribute | HTML.Attribute.MARGINWIDTH
static HTML.Attribute | HTML.Attribute.MAXLENGTH
static HTML.Attribute | HTML.Attribute.METHOD
static HTML.Attribute | HTML.Attribute.MULTIPLE
static HTML.Attribute | HTML.Attribute.N
static HTML.Attribute | HTML.Attribute.NAME
static HTML.Attribute | HTML.Attribute.NOHREF
static HTML.Attribute | HTML.Attribute.NORESIZE
static HTML.Attribute | HTML.Attribute.NOSHADE
static HTML.Attribute | HTML.Attribute.NOWRAP
static HTML.Attribute | HTML.Attribute.PROMPT
static HTML.Attribute | HTML.Attribute.REL
static HTML.Attribute | HTML.Attribute.REV
static HTML.Attribute | HTML.Attribute.ROWS
static HTML.Attribute | HTML.Attribute.ROWSPAN
static HTML.Attribute | HTML.Attribute.SCROLLING
static HTML.Attribute | HTML.Attribute.SELECTED
static HTML.Attribute | HTML.Attribute.SHAPE
static HTML.Attribute | HTML.Attribute.SHAPES
static HTML.Attribute | HTML.Attribute.SIZE
static HTML.Attribute | HTML.Attribute.SRC
static HTML.Attribute | HTML.Attribute.STANDBY
static HTML.Attribute | HTML.Attribute.START
static HTML.Attribute | HTML.Attribute.STYLE
static HTML.Attribute | HTML.Attribute.TARGET
static HTML.Attribute | HTML.Attribute.TEXT
static HTML.Attribute | HTML.Attribute.TITLE
static HTML.Attribute | HTML.Attribute.TYPE
static HTML.Attribute | HTML.Attribute.USEMAP
static HTML.Attribute | HTML.Attribute.VALIGN
static HTML.Attribute | HTML.Attribute.VALUE
static HTML.Attribute | HTML.Attribute.VALUETYPE
static HTML.Attribute | HTML.Attribute.VERSION
static HTML.Attribute | HTML.Attribute.VLINK
static HTML.Attribute | HTML.Attribute.VSPACE
static HTML.Attribute | HTML.Attribute.WIDTH

返回 HTML.Attribute 的 com.trs.infra.util.html 中的方法
static HTML.Attribute[] | HTML.getAllAttributeKeys() This is the set of html attributes recognized.
static HTML.Attribute | HTML.getAttributeKey(java.lang.String attName) Fetch an attribute constant for a well-known attribute name (i.e. one of the attributes in the set allAttributes).

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HTML 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HTML
的使用

没有 com.trs.infra.util.html.HTML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HTML.Tag 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HTML.Tag
的使用

使用 HTML.Tag 的软件包
com.trs.infra.util.html

com.trs.infra.util.html 中 HTML.Tag 的使用

com.trs.infra.util.html 中 HTML.Tag 的子类
static class HTML.UnknownTag

声明为 HTML.Tag 的 com.trs.infra.util.html 中的字段
static HTML.Tag | HTML.Tag.A
static HTML.Tag | HTML.Tag.ADDRESS
static HTML.Tag | HTML.Tag.APPLET
static HTML.Tag | HTML.Tag.AREA
static HTML.Tag | HTML.Tag.B
static HTML.Tag | HTML.Tag.BASE
static HTML.Tag | HTML.Tag.BASEFONT
static HTML.Tag | HTML.Tag.BIG
static HTML.Tag | HTML.Tag.BLOCKQUOTE
static HTML.Tag | HTML.Tag.BODY
static HTML.Tag | HTML.Tag.BR
static HTML.Tag | HTML.Tag.CAPTION
static HTML.Tag | HTML.Tag.CENTER
static HTML.Tag | HTML.Tag.CITE
static HTML.Tag | HTML.Tag.CODE
static HTML.Tag | HTML.Tag.COMMENT All comments are labeled with this tag.
static HTML.Tag | HTML.Tag.CONTENT All text content is labeled with this tag.
static HTML.Tag | HTML.Tag.DD
static HTML.Tag | HTML.Tag.DFN
static HTML.Tag | HTML.Tag.DIR
static HTML.Tag | HTML.Tag.DIV
static HTML.Tag | HTML.Tag.DL
static HTML.Tag | HTML.Tag.DT
static HTML.Tag | HTML.Tag.EM
static HTML.Tag | HTML.Tag.FONT
static HTML.Tag | HTML.Tag.FORM
static HTML.Tag | HTML.Tag.FRAME
static HTML.Tag | HTML.Tag.FRAMESET
static HTML.Tag | HTML.Tag.H1
static HTML.Tag | HTML.Tag.H2
static HTML.Tag | HTML.Tag.H3
static HTML.Tag | HTML.Tag.H4
static HTML.Tag | HTML.Tag.H5
static HTML.Tag | HTML.Tag.H6
static HTML.Tag | HTML.Tag.HEAD
static HTML.Tag | HTML.Tag.HR
static HTML.Tag | HTML.Tag.HTML
static HTML.Tag | HTML.Tag.I
static HTML.Tag | HTML.Tag.IMG
static HTML.Tag | HTML.Tag.IMPLIED All text content must be in a paragraph element.
static HTML.Tag | HTML.Tag.INPUT
static HTML.Tag | HTML.Tag.ISINDEX
static HTML.Tag | HTML.Tag.KBD
static HTML.Tag | HTML.Tag.LI
static HTML.Tag | HTML.Tag.LINK
static HTML.Tag | HTML.Tag.MAP
static HTML.Tag | HTML.Tag.MENU
static HTML.Tag | HTML.Tag.META
static HTML.Tag | HTML.Tag.NOFRAMES
static HTML.Tag | HTML.Tag.OBJECT
static HTML.Tag | HTML.Tag.OL
static HTML.Tag | HTML.Tag.OPTION
static HTML.Tag | HTML.Tag.P
static HTML.Tag | HTML.Tag.PARAM
static HTML.Tag | HTML.Tag.PRE
static HTML.Tag | HTML.Tag.S
static HTML.Tag | HTML.Tag.SAMP
static HTML.Tag | HTML.Tag.SCRIPT
static HTML.Tag | HTML.Tag.SELECT
static HTML.Tag | HTML.Tag.SMALL
static HTML.Tag | HTML.Tag.SPAN
static HTML.Tag | HTML.Tag.STRIKE
static HTML.Tag | HTML.Tag.STRONG
static HTML.Tag | HTML.Tag.STYLE
static HTML.Tag | HTML.Tag.SUB
static HTML.Tag | HTML.Tag.SUP
static HTML.Tag | HTML.Tag.TABLE
static HTML.Tag | HTML.Tag.TBODY
static HTML.Tag | HTML.Tag.TD
static HTML.Tag | HTML.Tag.TEXTAREA
static HTML.Tag | HTML.Tag.TH
static HTML.Tag | HTML.Tag.TITLE
static HTML.Tag | HTML.Tag.TR
static HTML.Tag | HTML.Tag.TT
static HTML.Tag | HTML.Tag.U
static HTML.Tag | HTML.Tag.UL
static HTML.Tag | HTML.Tag.VAR

返回 HTML.Tag 的 com.trs.infra.util.html 中的方法
static HTML.Tag[] | HTML.getAllTags() This is the set of actual html tags that are known about the the default html reader.
HTML.Tag | HtmlElement.getTag() 获取Tag对象
static HTML.Tag | HTML.getTag(java.lang.String tagName) Fetch a tag constant for a well-known tag name (i.e. one of the tags in the set allTags).

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HTML.UnknownTag 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HTML.UnknownTag
的使用

没有 com.trs.infra.util.html.HTML.UnknownTag 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HtmlAttribute 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HtmlAttribute
的使用

使用 HtmlAttribute 的软件包
com.trs.infra.util.html

com.trs.infra.util.html 中 HtmlAttribute 的使用

返回 HtmlAttribute 的 com.trs.infra.util.html 中的方法
HtmlAttribute | HtmlElement.getAttribute(java.lang.String _name) 获取指定名称的属性对象
HtmlAttribute | HtmlAttribute.setName(java.lang.String _name) 设置属性名称
HtmlAttribute | HtmlAttribute.setParent(HtmlElement _parent) 设置
HtmlAttribute | HtmlAttribute.setValue(java.lang.String _value) 设置属性值

参数类型为 HtmlAttribute 的 com.trs.infra.util.html 中的方法
 HtmlElement HtmlElement.setAttribute(HtmlAttribute _attribute)
设置属性

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HtmlComment 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HtmlComment
的使用

使用 HtmlComment 的软件包
com.trs.infra.util.html

com.trs.infra.util.html 中 HtmlComment 的使用

返回 HtmlComment 的 com.trs.infra.util.html 中的方法
HtmlComment | HtmlComment.setDocument(HtmlDocument _document) 直接设定了Document对象，表示为根元素
HtmlComment | HtmlComment.setParent(HtmlElement _parent) 设置父元素对象
HtmlComment | HtmlComment.setText(java.lang.String _text) 设置注释内容

参数类型为 HtmlComment 的 com.trs.infra.util.html 中的方法
HtmlElement | HtmlElement.addContent(HtmlComment _comment) 添加一个注释对象
HtmlDocument | HtmlDocument.addContent(HtmlComment _comment) 在文档内容列表中，添加一个注释对象
boolean | HtmlElement.removeContent(HtmlComment _comment) 删除注释对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HtmlDocument 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HtmlDocument
的使用

使用 HtmlDocument 的软件包
com.trs.infra.util.html

com.trs.infra.util.html 中 HtmlDocument 的使用

返回 HtmlDocument 的 com.trs.infra.util.html 中的方法
HtmlDocument | HtmlDocument.addContent(HtmlComment _comment) 在文档内容列表中，添加一个注释对象
HtmlDocument | HtmlAttribute.getDocument() 取属性所属文档对象
HtmlDocument | HtmlElement.getDocument() 获取所在的文档对象
HtmlDocument | HtmlComment.getDocument() 获取所在的HtmlDocument
HtmlDocument | HtmlDocument.setContent(java.util.List _newContent) 设置Html文档内容,要求：有且仅有一个根元素
HtmlDocument | HtmlDocument.setRootElement(HtmlElement _rootElement) 设置根元素 操作：检查是否已经存在根元素。

参数类型为 HtmlDocument 的 com.trs.infra.util.html 中的方法
HtmlElement | HtmlElement.setDocument(HtmlDocument _document) 设定所在的文档对象
HtmlComment | HtmlComment.setDocument(HtmlDocument _document) 直接设定了Document对象，表示为根元素

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HtmlElement 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HtmlElement
的使用

使用 HtmlElement 的软件包
com.trs.infra.util.html

com.trs.infra.util.html 中 HtmlElement 的使用

返回 HtmlElement 的 com.trs.infra.util.html 中的方法
HtmlElement | HtmlElement.addContent(HtmlComment _comment) 添加一个注释对象
HtmlElement | HtmlElement.addContent(HtmlElement _element) 添加一个HtmlElement
HtmlElement | HtmlElement.addContent(java.lang.String _text) 添加内容
HtmlElement | HtmlElementFinder.findNextElement(java.lang.String _sName) 找到下一个指定名称的元素
HtmlElement | HtmlElementFinder.findNextElement(java.lang.String _sName, boolean _bOnlySearchSelf)
HtmlElement | HtmlElementFinder.findNextElement(java.lang.String _sName, boolean _bOnlySearchSelf, java.lang.String _sTagsToSkip) 找到下一个指定名称的元素
HtmlElement | HtmlElement.getChild(java.lang.String _name) 获取第一个指定名称的子元素
HtmlElement | HtmlAttribute.getParent() 获取所属元素对象
HtmlElement | HtmlElement.getParent() 获取父元素对象
HtmlElement | HtmlComment.getParent() 获取父元素对象
HtmlElement | HtmlDocument.getRootElement() 取根元素 操作：从content中查找第一个HtmlElement元素，即看作根元素
HtmlElement | HtmlElement.setAttribute(HtmlAttribute _attribute) 设置属性
HtmlElement | HtmlElement.setAttribute(java.lang.String _name, java.lang.String _value) 设置指定属性的值
HtmlElement | HtmlElement.setAttribute(java.lang.String _name, java.lang.String _value, char _quote)
HtmlElement | HtmlElement.setAttributes(java.util.List _attributes) 设置元素的属性
HtmlElement | HtmlElement.setDocument(HtmlDocument _document) 设定所在的文档对象
HtmlElement | HtmlElement.setName(java.lang.String _name) 设置Html元素标记
HtmlElement | HtmlElement.setParent(HtmlElement _parent) 设置父元素对象

参数类型为 HtmlElement 的 com.trs.infra.util.html 中的方法
HtmlElement | HtmlElement.addContent(HtmlElement _element) 添加一个HtmlElement
boolean | HtmlElement.isAncestorOf(HtmlElement _element) 判断当前元素是否为指定元素的祖先
HtmlElementFinder | HtmlElementFinder.putElement(HtmlElement _element) 在Html文本内容的当前位置，插入元素的内容
boolean | HtmlElement.removeContent(HtmlElement _element) 删除一个HTMLElement对象
HtmlAttribute | HtmlAttribute.setParent(HtmlElement _parent) 设置
HtmlElement | HtmlElement.setParent(HtmlElement _parent) 设置父元素对象
HtmlComment | HtmlComment.setParent(HtmlElement _parent) 设置父元素对象
HtmlDocument | HtmlDocument.setRootElement(HtmlElement _rootElement) 设置根元素 操作：检查是否已经存在根元素。

参数类型为 HtmlElement 的 com.trs.infra.util.html 中的构造方法
HtmlDocument(HtmlElement _rootElement)
构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HtmlElementFinder 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HtmlElementFinder
的使用

使用 HtmlElementFinder 的软件包
com.trs.infra.util.html

com.trs.infra.util.html 中 HtmlElementFinder 的使用

返回 HtmlElementFinder 的 com.trs.infra.util.html 中的方法
HtmlElementFinder | HtmlElementFinder.putElement(HtmlElement _element) 在Html文本内容的当前位置，插入元素的内容
HtmlElementFinder | HtmlElementFinder.putHTML(java.lang.String _sHTML) 在Html文本内容的当前位置，插入HTML内容
HtmlElementFinder | HtmlElementFinder.setHtmlSrc(char[] _src) 设置Html文本源
HtmlElementFinder | HtmlElementFinder.setHtmlSrc(java.lang.String _src) 设置Html文本源

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.html.HtmlUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.html.HtmlUtil
的使用

没有 com.trs.infra.util.html.HtmlUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Adler32

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 Adler32

java.lang.Object
    继承者  com.trs.infra.util.jazzlib.Adler32
所有已实现的接口：
Checksum
public class Adler32
extends java.lang.Object
implements Checksum

Computes Adler32 checksum for a stream of data. An Adler32 checksum is not as reliable as a CRC32 checksum, but a lot faster to compute.

The specification for Adler32 may be found in RFC 1950. (ZLIB Compressed Data Format Specification version 3.3)

From that document:

"ADLER32 (Adler-32 checksum) This contains a checksum value of the uncompressed data (excluding any dictionary data) computed according to Adler-32 algorithm. This algorithm is a 32-bit extension and improvement of the Fletcher algorithm, used in the ITU-T X.224 / ISO 8073 standard.

Adler-32 is composed of two sums accumulated per byte: s1 is the sum of all bytes, s2 is the sum of all s1 values. Both sums are done modulo 65521. s1 is initialized to 1, s2 to zero. The Adler-32 checksum is stored as s2*65536 + s1 in most- significant-byte first (network) order."

"8.2. The Adler-32 algorithm

The Adler-32 algorithm is much faster than the CRC32 algorithm yet still provides an extremely low probability of undetected errors.

The modulo on unsigned long accumulators can be delayed for 5552 bytes, so the modulo operation time is negligible. If the bytes are a, b, c, the second sum is 3a + 2b + c + 3, and so is position and order sensitive, unlike the first sum, which is just a checksum. That 65521 is prime is important to avoid a possible large class of two-byte errors that leave the check unchanged. (The Fletcher checksum uses 255, which is not prime and which also makes the Fletcher check insensitive to single byte changes 0 <->255.)

The sum s1 is initialized to 1 instead of zero to make the length of the sequence part of s2, so that the length does not have to be checked separately. (Any sequence of zeroes has a Fletcher checksum of zero.)"

从以下版本开始：
JDK 1.1
作者：
John Leuner, Per Bothner
另请参见：
InflaterInputStream, DeflaterOutputStream

构造方法摘要
Adler32()
Creates a new instance of the Adler32 class.
方法摘要
long | getValue() Returns the Adler32 data checksum computed so far.
void | reset() Resets the Adler32 checksum to the initial value.
void | update(byte[] buffer) Updates the checksum with the bytes taken from the array.
void | update(byte[] buf, int off, int len) Updates the checksum with the bytes taken from the array.
void | update(int bval) Updates the checksum with the byte b.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Adler32

public Adler32()
Creates a new instance of the Adler32 class. The checksum starts off with a value of 1.

方法详细信息

reset

public void reset()
Resets the Adler32 checksum to the initial value.

指定者：
接口 Checksum 中的 reset

update

public void update(int bval)
Updates the checksum with the byte b.

指定者：
接口 Checksum 中的 update
参数：
bval - the data value to add. The high byte of the int is ignored.

update

public void update(byte[] buffer)
Updates the checksum with the bytes taken from the array.

参数：
buffer - an array of bytes

update

public void update(byte[] buf,
                   int off,
                   int len)
Updates the checksum with the bytes taken from the array.

指定者：
接口 Checksum 中的 update
参数：
buf - an array of bytes
off - the start of the data used for this update
len - the number of bytes to use for this update

getValue

public long getValue()
Returns the Adler32 data checksum computed so far.

指定者：
接口 Checksum 中的 getValue
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CheckedInputStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 CheckedInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  com.trs.infra.util.jazzlib.CheckedInputStream
所有已实现的接口：
java.io.Closeable
public class CheckedInputStream
extends java.io.FilterInputStream

InputStream that computes a checksum of the data being read using a supplied Checksum object.

作者：
Tom Tromey
另请参见：
Checksum

构造方法摘要
CheckedInputStream(java.io.InputStream in, Checksum sum)
Creates a new CheckInputStream on top of the supplied OutputStream using the supplied Checksum.
方法摘要
Checksum | getChecksum() Returns the Checksum object used.
int | read() Reads one byte, updates the checksum and returns the read byte (or -1 when the end of file was reached).
int | read(byte[] buf, int off, int len) Reads at most len bytes in the supplied buffer and updates the checksum with it.
long | skip(long n) Skips n bytes by reading them in a temporary buffer and updating the the checksum with that buffer.
从类 java.io.FilterInputStream 继承的方法
available, close, mark, markSupported, read, reset
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CheckedInputStream

public CheckedInputStream(java.io.InputStream in,
                          Checksum sum)
Creates a new CheckInputStream on top of the supplied OutputStream using the supplied Checksum.

方法详细信息

getChecksum

public Checksum getChecksum()
Returns the Checksum object used. To get the data checksum computed so far call getChecksum.getValue().

read

public int read()
         throws java.io.IOException
Reads one byte, updates the checksum and returns the read byte (or -1 when the end of file was reached).

覆盖：
类 java.io.FilterInputStream 中的 read
抛出：
java.io.IOException

read

public int read(byte[] buf,
                int off,
                int len)
         throws java.io.IOException
Reads at most len bytes in the supplied buffer and updates the checksum with it. Returns the number of bytes actually read or -1 when the end of file was reached.

覆盖：
类 java.io.FilterInputStream 中的 read
抛出：
java.io.IOException

skip

public long skip(long n)
          throws java.io.IOException
Skips n bytes by reading them in a temporary buffer and updating the the checksum with that buffer. Returns the actual number of bytes skiped which can be less then requested when the end of file is reached.

覆盖：
类 java.io.FilterInputStream 中的 skip
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CheckedOutputStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 CheckedOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  com.trs.infra.util.jazzlib.CheckedOutputStream
所有已实现的接口：
java.io.Closeable, java.io.Flushable
public class CheckedOutputStream
extends java.io.FilterOutputStream

OutputStream that computes a checksum of data being written using a supplied Checksum object.

作者：
Tom Tromey
另请参见：
Checksum

构造方法摘要
CheckedOutputStream(java.io.OutputStream out, Checksum cksum)
Creates a new CheckInputStream on top of the supplied OutputStream using the supplied Checksum.
方法摘要
Checksum | getChecksum() Returns the Checksum object used.
void | write(byte[] buf, int off, int len) Writes the byte array to the OutputStream and updates the Checksum.
void | write(int bval) Writes one byte to the OutputStream and updates the Checksum.
从类 java.io.FilterOutputStream 继承的方法
close, flush, write
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CheckedOutputStream

public CheckedOutputStream(java.io.OutputStream out,
                           Checksum cksum)
Creates a new CheckInputStream on top of the supplied OutputStream using the supplied Checksum.

方法详细信息

getChecksum

public Checksum getChecksum()
Returns the Checksum object used. To get the data checksum computed so far call getChecksum.getValue().

write

public void write(int bval)
           throws java.io.IOException
Writes one byte to the OutputStream and updates the Checksum.

覆盖：
类 java.io.FilterOutputStream 中的 write
抛出：
java.io.IOException

write

public void write(byte[] buf,
                  int off,
                  int len)
           throws java.io.IOException
Writes the byte array to the OutputStream and updates the Checksum.

覆盖：
类 java.io.FilterOutputStream 中的 write
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Checksum

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
接口 Checksum

所有已知实现类：
Adler32, CRC32
public interface Checksum

Interface to compute a data checksum used by checked input/output streams. A data checksum can be updated by one byte or with a byte array. After each update the value of the current checksum can be returned by calling getValue. The complete checksum object can also be reset so it can be used again with new data.

作者：
Per Bothner, Jochen Hoenicke
另请参见：
CheckedInputStream, CheckedOutputStream

方法摘要
long | getValue() Returns the data checksum computed so far.
void | reset() Resets the data checksum as if no update was ever called.
void | update(byte[] buf, int off, int len) Adds the byte array to the data checksum.
void | update(int bval) Adds one byte to the data checksum.

方法详细信息

getValue

long getValue()
Returns the data checksum computed so far.

reset

void reset()
Resets the data checksum as if no update was ever called.

update

void update(int bval)
Adds one byte to the data checksum.

参数：
bval - the data value to add. The high byte of the int is ignored.

update

void update(byte[] buf,
            int off,
            int len)
Adds the byte array to the data checksum.

参数：
buf - the buffer which contains the data
off - the offset in the buffer where the data starts
len - the length of the data
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CRC32

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 CRC32

java.lang.Object
    继承者  com.trs.infra.util.jazzlib.CRC32
所有已实现的接口：
Checksum
public class CRC32
extends java.lang.Object
implements Checksum

Computes CRC32 data checksum of a data stream. The actual CRC32 algorithm is described in RFC 1952 (GZIP file format specification version 4.3). Can be used to get the CRC32 over a stream if used with checked input/output streams.

作者：
Per Bothner
另请参见：
InflaterInputStream, DeflaterOutputStream

构造方法摘要
CRC32()
方法摘要
long | getValue() Returns the CRC32 data checksum computed so far.
void | reset() Resets the CRC32 data checksum as if no update was ever called.
void | update(byte[] buf) Adds the complete byte array to the data checksum.
void | update(byte[] buf, int off, int len) Adds the byte array to the data checksum.
void | update(int bval) Updates the checksum with the int bval.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CRC32

public CRC32()
方法详细信息

getValue

public long getValue()
Returns the CRC32 data checksum computed so far.

指定者：
接口 Checksum 中的 getValue

reset

public void reset()
Resets the CRC32 data checksum as if no update was ever called.

指定者：
接口 Checksum 中的 reset

update

public void update(int bval)
Updates the checksum with the int bval.

指定者：
接口 Checksum 中的 update
参数：
bval - (the byte is taken as the lower 8 bits of bval)

update

public void update(byte[] buf,
                   int off,
                   int len)
Adds the byte array to the data checksum.

指定者：
接口 Checksum 中的 update
参数：
buf - the buffer which contains the data
off - the offset in the buffer where the data starts
len - the length of the data

update

public void update(byte[] buf)
Adds the complete byte array to the data checksum.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataFormatException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 DataFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.infra.util.jazzlib.DataFormatException
所有已实现的接口：
java.io.Serializable
public class DataFormatException
extends java.lang.Exception

Exception thrown when compressed data is corrupt.

从以下版本开始：
JDK 1.1
作者：
Tom Tromey, John Leuner
另请参见：
序列化表格

构造方法摘要
DataFormatException()
DataFormatException(java.lang.String msg)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DataFormatException

public DataFormatException()

DataFormatException

public DataFormatException(java.lang.String msg)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Deflater

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 Deflater

java.lang.Object
    继承者  com.trs.infra.util.jazzlib.Deflater

public class Deflater
extends java.lang.Object

This is the Deflater class. The deflater class compresses input with the deflate algorithm described in RFC 1951. It has several compression levels and three different strategies described below. This class is not thread safe. This is inherent in the API, due to the split of deflate and setInput.

作者：
Jochen Hoenicke

字段摘要
static int | BEST_COMPRESSION The best and slowest compression level.
static int | BEST_SPEED The worst but fastest compression level.
static int | DEFAULT_COMPRESSION The default compression level.
static int | DEFAULT_STRATEGY The default strategy.
static int | DEFLATED The compression method.
static int | FILTERED This strategy will only allow longer string repetitions.
static int | HUFFMAN_ONLY This strategy will not look for string repetitions at all.
static int | NO_COMPRESSION This level won't compress at all but output uncompressed blocks.
构造方法摘要
Deflater()
Creates a new deflater with default compression level.
Deflater(int lvl)
Creates a new deflater with given compression level.
Deflater(int lvl, boolean nowrap)
Creates a new deflater with given compression level.
方法摘要
int | deflate(byte[] output) Deflates the current input block to the given array.
int | deflate(byte[] output, int offset, int length) Deflates the current input block to the given array.
void | end() 已过时。 Just clear all references to deflater instead.
void | finish() Finishes the deflater with the current input block.
boolean | finished() Returns true iff the stream was finished and no more output bytes are available.
int | getAdler() Gets the current adler checksum of the data that was processed so far.
int | getTotalIn() Gets the number of input bytes processed so far.
int | getTotalOut() Gets the number of output bytes so far.
boolean | needsInput() Returns true, if the input buffer is empty.
void | reset() Resets the deflater.
void | setDictionary(byte[] dict) Sets the dictionary which should be used in the deflate process.
void | setDictionary(byte[] dict, int offset, int length) Sets the dictionary which should be used in the deflate process.
void | setInput(byte[] input) Sets the data which should be compressed next.
void | setInput(byte[] input, int off, int len) Sets the data which should be compressed next.
void | setLevel(int lvl) Sets the compression level.
void | setStrategy(int stgy) Sets the compression strategy.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

BEST_COMPRESSION

public static final int BEST_COMPRESSION
The best and slowest compression level. This tries to find very long and distant string repetitions.

另请参见：
常量字段值

BEST_SPEED

public static final int BEST_SPEED
The worst but fastest compression level.

另请参见：
常量字段值

DEFAULT_COMPRESSION

public static final int DEFAULT_COMPRESSION
The default compression level.

另请参见：
常量字段值

NO_COMPRESSION

public static final int NO_COMPRESSION
This level won't compress at all but output uncompressed blocks.

另请参见：
常量字段值

DEFAULT_STRATEGY

public static final int DEFAULT_STRATEGY
The default strategy.

另请参见：
常量字段值

FILTERED

public static final int FILTERED
This strategy will only allow longer string repetitions. It is useful for random data with a small character set.

另请参见：
常量字段值

HUFFMAN_ONLY

public static final int HUFFMAN_ONLY
This strategy will not look for string repetitions at all. It only encodes with Huffman trees (which means, that more common characters get a smaller encoding.

另请参见：
常量字段值

DEFLATED

public static final int DEFLATED
The compression method. This is the only method supported so far. There is no need to use this constant at all.

另请参见：
常量字段值
构造方法详细信息

Deflater

public Deflater()
Creates a new deflater with default compression level.

Deflater

public Deflater(int lvl)
Creates a new deflater with given compression level.

参数：
lvl - the compression level, a value between NO_COMPRESSION and BEST_COMPRESSION, or DEFAULT_COMPRESSION.
抛出：
java.lang.IllegalArgumentException - if lvl is out of range.

Deflater

public Deflater(int lvl,
                boolean nowrap)
Creates a new deflater with given compression level.

参数：
lvl - the compression level, a value between NO_COMPRESSION and BEST_COMPRESSION.
nowrap - true, iff we should suppress the deflate header at the beginning and the adler checksum at the end of the output. This is useful for the GZIP format.
抛出：
java.lang.IllegalArgumentException - if lvl is out of range.
方法详细信息

reset

public void reset()
Resets the deflater. The deflater acts afterwards as if it was just created with the same compression level and strategy as it had before.

end

public void end()
已过时。 Just clear all references to deflater instead.

Frees all objects allocated by the compressor. There's no reason to call this, since you can just rely on garbage collection. Exists only for compatibility against Sun's JDK, where the compressor allocates native memory. If you call any method (even reset) afterwards the behaviour is undefined .

getAdler

public int getAdler()
Gets the current adler checksum of the data that was processed so far.

getTotalIn

public int getTotalIn()
Gets the number of input bytes processed so far.

getTotalOut

public int getTotalOut()
Gets the number of output bytes so far.

finish

public void finish()
Finishes the deflater with the current input block. It is an error to give more input after this method was called. This method must be called to force all bytes to be flushed.

finished

public boolean finished()
Returns true iff the stream was finished and no more output bytes are available.

needsInput

public boolean needsInput()
Returns true, if the input buffer is empty. You should then call setInput().
NOTE: This method can also return true when the stream was finished.

setInput

public void setInput(byte[] input)
Sets the data which should be compressed next. This should be only called when needsInput indicates that more input is needed. If you call setInput when needsInput() returns false, the previous input that is still pending will be thrown away. The given byte array should not be changed, before needsInput() returns true again. This call is equivalent to setInput(input, 0, input.length).

参数：
input - the buffer containing the input data.
抛出：
java.lang.IllegalStateException - if the buffer was finished() or ended().

setInput

public void setInput(byte[] input,
                     int off,
                     int len)
Sets the data which should be compressed next. This should be only called when needsInput indicates that more input is needed. The given byte array should not be changed, before needsInput() returns true again.

参数：
input - the buffer containing the input data.
off - the start of the data.
len - the length of the data.
抛出：
java.lang.IllegalStateException - if the buffer was finished() or ended() or if previous input is still pending.

setLevel

public void setLevel(int lvl)
Sets the compression level. There is no guarantee of the exact position of the change, but if you call this when needsInput is true the change of compression level will occur somewhere near before the end of the so far given input.

参数：
lvl - the new compression level.

setStrategy

public void setStrategy(int stgy)
Sets the compression strategy. Strategy is one of DEFAULT_STRATEGY, HUFFMAN_ONLY and FILTERED. For the exact position where the strategy is changed, the same as for setLevel() applies.

参数：
stgy - the new compression strategy.

deflate

public int deflate(byte[] output)
Deflates the current input block to the given array. It returns the number of bytes compressed, or 0 if either needsInput() or finished() returns true or length is zero.

参数：
output - the buffer where to write the compressed data.

deflate

public int deflate(byte[] output,
                   int offset,
                   int length)
Deflates the current input block to the given array. It returns the number of bytes compressed, or 0 if either needsInput() or finished() returns true or length is zero.

参数：
output - the buffer where to write the compressed data.
offset - the offset into the output array.
length - the maximum number of bytes that may be written.
抛出：
java.lang.IllegalStateException - if end() was called.
java.lang.IndexOutOfBoundsException - if offset and/or length don't match the array length.

setDictionary

public void setDictionary(byte[] dict)
Sets the dictionary which should be used in the deflate process. This call is equivalent to setDictionary(dict, 0, dict.length).

参数：
dict - the dictionary.
抛出：
java.lang.IllegalStateException - if setInput () or deflate () were already called or another dictionary was already set.

setDictionary

public void setDictionary(byte[] dict,
                          int offset,
                          int length)
Sets the dictionary which should be used in the deflate process. The dictionary should be a byte array containing strings that are likely to occur in the data which should be compressed. The dictionary is not stored in the compressed output, only a checksum. To decompress the output you need to supply the same dictionary again.

参数：
dict - the dictionary.
offset - an offset into the dictionary.
length - the length of the dictionary.
抛出：
java.lang.IllegalStateException - if setInput () or deflate () were already called or another dictionary was already set.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DeflaterOutputStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 DeflaterOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  com.trs.infra.util.jazzlib.DeflaterOutputStream
所有已实现的接口：
java.io.Closeable, java.io.Flushable
直接已知子类：
GZIPOutputStream, ZipOutputStream
public class DeflaterOutputStream
extends java.io.FilterOutputStream

This is a special FilterOutputStream deflating the bytes that are written through it. It uses the Deflater for deflating. A special thing to be noted is that flush() doesn't flush everything in Sun's JDK, but it does so in jazzlib. This is because Sun's Deflater doesn't have a way to flush() everything, without finishing the stream.

作者：
Tom Tromey, Jochen Hoenicke

构造方法摘要
DeflaterOutputStream(java.io.OutputStream out)
Creates a new DeflaterOutputStream with a default Deflater and default buffer size.
DeflaterOutputStream(java.io.OutputStream out, Deflater defl)
Creates a new DeflaterOutputStream with the given Deflater and default buffer size.
DeflaterOutputStream(java.io.OutputStream out, Deflater defl, int bufsize)
Creates a new DeflaterOutputStream with the given Deflater and buffer size.
方法摘要
 void close()
Calls finish () and closes the stream.
 void finish()
Finishes the stream by calling finish() on the deflater.
 void flush()
Flushes the stream by calling flush() on the deflater and then on the underlying stream.
 void write(byte[] buf, int off, int len)
Writes a len bytes from an array to the compressed stream.
 void write(int bval)
Writes a single byte to the compressed output stream.
从类 java.io.FilterOutputStream 继承的方法
write
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DeflaterOutputStream

public DeflaterOutputStream(java.io.OutputStream out)
Creates a new DeflaterOutputStream with a default Deflater and default buffer size.

参数：
out - the output stream where deflated output should be written.

DeflaterOutputStream

public DeflaterOutputStream(java.io.OutputStream out,
                            Deflater defl)
Creates a new DeflaterOutputStream with the given Deflater and default buffer size.

参数：
out - the output stream where deflated output should be written.
defl - the underlying deflater.

DeflaterOutputStream

public DeflaterOutputStream(java.io.OutputStream out,
                            Deflater defl,
                            int bufsize)
Creates a new DeflaterOutputStream with the given Deflater and buffer size.

参数：
out - the output stream where deflated output should be written.
defl - the underlying deflater.
bufsize - the buffer size.
抛出：
java.lang.IllegalArgumentException - if bufsize isn't positive.
方法详细信息

flush

public void flush()
           throws java.io.IOException
Flushes the stream by calling flush() on the deflater and then on the underlying stream. This ensures that all bytes are flushed. This function doesn't work in Sun's JDK, but only in jazzlib.

指定者：
接口 java.io.Flushable 中的 flush
覆盖：
类 java.io.FilterOutputStream 中的 flush
抛出：
java.io.IOException

finish

public void finish()
            throws java.io.IOException
Finishes the stream by calling finish() on the deflater. This was the only way to ensure that all bytes are flushed in Sun's JDK.

抛出：
java.io.IOException

close

public void close()
           throws java.io.IOException
Calls finish () and closes the stream.

指定者：
接口 java.io.Closeable 中的 close
覆盖：
类 java.io.FilterOutputStream 中的 close
抛出：
java.io.IOException

write

public void write(int bval)
           throws java.io.IOException
Writes a single byte to the compressed output stream.

覆盖：
类 java.io.FilterOutputStream 中的 write
参数：
bval - the byte value.
抛出：
java.io.IOException

write

public void write(byte[] buf,
                  int off,
                  int len)
           throws java.io.IOException
Writes a len bytes from an array to the compressed stream.

覆盖：
类 java.io.FilterOutputStream 中的 write
参数：
buf - the byte array.
off - the offset into the byte array where to start.
len - the number of bytes to write.
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GZIPInputStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 GZIPInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  com.trs.infra.util.jazzlib.InflaterInputStream
                继承者  com.trs.infra.util.jazzlib.GZIPInputStream
所有已实现的接口：
java.io.Closeable
public class GZIPInputStream
extends InflaterInputStream

This filter stream is used to decompress a "GZIP" format stream. The "GZIP" format is described in RFC 1952.

从以下版本开始：
JDK 1.1
作者：
John Leuner

字段摘要
static int | FCOMMENT
static int | FEXTRA
static int | FHCRC
static int | FNAME
static int | FTEXT
static int | GZIP_MAGIC
构造方法摘要
GZIPInputStream(java.io.InputStream in)
Creates a GZIPInputStream with the default buffer size
GZIPInputStream(java.io.InputStream in, int size)
Creates a GZIPInputStream with the specified buffer size
方法摘要
void | close() Closes the input stream
int | read(byte[] buf, int offset, int len) Reads uncompressed data into an array of bytes
从类 com.trs.infra.util.jazzlib.InflaterInputStream 继承的方法
available, read, skip
从类 java.io.FilterInputStream 继承的方法
mark, markSupported, read, reset
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

GZIP_MAGIC

public static final int GZIP_MAGIC
另请参见：
常量字段值

FTEXT

public static final int FTEXT
另请参见：
常量字段值

FHCRC

public static final int FHCRC
另请参见：
常量字段值

FEXTRA

public static final int FEXTRA
另请参见：
常量字段值

FNAME

public static final int FNAME
另请参见：
常量字段值

FCOMMENT

public static final int FCOMMENT
另请参见：
常量字段值
构造方法详细信息

GZIPInputStream

public GZIPInputStream(java.io.InputStream in)
                throws java.io.IOException
Creates a GZIPInputStream with the default buffer size

参数：
in - The stream to read compressed data from (in GZIP format)
抛出：
java.io.IOException

GZIPInputStream

public GZIPInputStream(java.io.InputStream in,
                       int size)
                throws java.io.IOException
Creates a GZIPInputStream with the specified buffer size

参数：
in - The stream to read compressed data from (in GZIP format)
size - Size of the buffer to use
抛出：
java.io.IOException
方法详细信息

close

public void close()
           throws java.io.IOException
Closes the input stream

指定者：
接口 java.io.Closeable 中的 close
覆盖：
类 InflaterInputStream 中的 close
抛出：
java.io.IOException

read

public int read(byte[] buf,
                int offset,
                int len)
         throws java.io.IOException
Reads uncompressed data into an array of bytes

覆盖：
类 InflaterInputStream 中的 read
参数：
buf - the buffer to read uncompressed data into
offset - the offset indicating where the data should be placed
len - the number of uncompressed bytes to be read
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GZIPOutputStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 GZIPOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  com.trs.infra.util.jazzlib.DeflaterOutputStream
                继承者  com.trs.infra.util.jazzlib.GZIPOutputStream
所有已实现的接口：
java.io.Closeable, java.io.Flushable
public class GZIPOutputStream
extends DeflaterOutputStream

This filter stream is used to compress a stream into a "GZIP" stream. The "GZIP" format is described in RFC 1952.

从以下版本开始：
JDK 1.1
作者：
John Leuner

字段摘要
static int | FCOMMENT
static int | FEXTRA
static int | FHCRC
static int | FNAME
static int | FTEXT
static int | GZIP_MAGIC
构造方法摘要
GZIPOutputStream(java.io.OutputStream out)
GZIPOutputStream(java.io.OutputStream out, int size)
方法摘要
 void close()
Writes remaining compressed output data to the output stream and closes it.
 void finish()
Finishes the stream by calling finish() on the deflater.
 void write(byte[] buf, int off, int len)
Writes a len bytes from an array to the compressed stream.
从类 com.trs.infra.util.jazzlib.DeflaterOutputStream 继承的方法
flush, write
从类 java.io.FilterOutputStream 继承的方法
write
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

GZIP_MAGIC

public static final int GZIP_MAGIC
另请参见：
常量字段值

FTEXT

public static final int FTEXT
另请参见：
常量字段值

FHCRC

public static final int FHCRC
另请参见：
常量字段值

FEXTRA

public static final int FEXTRA
另请参见：
常量字段值

FNAME

public static final int FNAME
另请参见：
常量字段值

FCOMMENT

public static final int FCOMMENT
另请参见：
常量字段值
构造方法详细信息

GZIPOutputStream

public GZIPOutputStream(java.io.OutputStream out)
                 throws java.io.IOException
抛出：
java.io.IOException

GZIPOutputStream

public GZIPOutputStream(java.io.OutputStream out,
                        int size)
                 throws java.io.IOException
抛出：
java.io.IOException
方法详细信息

write

public void write(byte[] buf,
                  int off,
                  int len)
           throws java.io.IOException
从类 DeflaterOutputStream 复制的描述
Writes a len bytes from an array to the compressed stream.

覆盖：
类 DeflaterOutputStream 中的 write
参数：
buf - the byte array.
off - the offset into the byte array where to start.
len - the number of bytes to write.
抛出：
java.io.IOException

close

public void close()
           throws java.io.IOException
Writes remaining compressed output data to the output stream and closes it.

指定者：
接口 java.io.Closeable 中的 close
覆盖：
类 DeflaterOutputStream 中的 close
抛出：
java.io.IOException

finish

public void finish()
            throws java.io.IOException
从类 DeflaterOutputStream 复制的描述
Finishes the stream by calling finish() on the deflater. This was the only way to ensure that all bytes are flushed in Sun's JDK.

覆盖：
类 DeflaterOutputStream 中的 finish
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Inflater

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 Inflater

java.lang.Object
    继承者  com.trs.infra.util.jazzlib.Inflater

public class Inflater
extends java.lang.Object

Inflater is used to decompress data that has been compressed according to the "deflate" standard described in rfc1950. The usage is as following. First you have to set some input with setInput(), then inflate() it. If inflate doesn't inflate any bytes there may be three reasons:

  • needsInput() returns true because the input buffer is empty. You have to provide more input with setInput(). NOTE: needsInput() also returns true when, the stream is finished.
  • needsDictionary() returns true, you have to provide a preset dictionary with setDictionary().
  • finished() returns true, the inflater has finished.
Once the first output byte is produced, a dictionary will not be needed at a later stage.

从以下版本开始：
JDK 1.1
作者：
John Leuner, Jochen Hoenicke

构造方法摘要
Inflater()
Creates a new inflater.
Inflater(boolean nowrap)
Creates a new inflater.
方法摘要
 void end()
已过时。 Just clear all references to inflater instead.
 boolean finished()
Returns true, if the inflater has finished.
 int getAdler()
Gets the adler checksum.
 int getRemaining()
Gets the number of unprocessed input.
 int getTotalIn()
Gets the total number of processed compressed input bytes.
 int getTotalOut()
Gets the total number of output bytes returned by inflate().
 int inflate(byte[] buf)
Inflates the compressed stream to the output buffer.
 int inflate(byte[] buf, int off, int len)
Inflates the compressed stream to the output buffer.
 boolean needsDictionary()
Returns true, if a preset dictionary is needed to inflate the input.
 boolean needsInput()
Returns true, if the input buffer is empty.
 void reset()
Resets the inflater so that a new stream can be decompressed.
 void setDictionary(byte[] buffer)
Sets the preset dictionary.
 void setDictionary(byte[] buffer, int off, int len)
Sets the preset dictionary.
 void setInput(byte[] buf)
Sets the input.
 void setInput(byte[] buf, int off, int len)
Sets the input.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Inflater

public Inflater()
Creates a new inflater.

Inflater

public Inflater(boolean nowrap)
Creates a new inflater.

参数：
nowrap - true if no header and checksum field appears in the stream. This is used for GZIPed input. For compatibility with Sun JDK you should provide one byte of input more than needed in this case.
方法详细信息

reset

public void reset()
Resets the inflater so that a new stream can be decompressed. All pending input and output will be discarded.

setDictionary

public void setDictionary(byte[] buffer)
Sets the preset dictionary. This should only be called, if needsDictionary() returns true and it should set the same dictionary, that was used for deflating. The getAdler() function returns the checksum of the dictionary needed.

参数：
buffer - the dictionary.
抛出：
java.lang.IllegalStateException - if no dictionary is needed.
java.lang.IllegalArgumentException - if the dictionary checksum is wrong.

setDictionary

public void setDictionary(byte[] buffer,
                          int off,
                          int len)
Sets the preset dictionary. This should only be called, if needsDictionary() returns true and it should set the same dictionary, that was used for deflating. The getAdler() function returns the checksum of the dictionary needed.

参数：
buffer - the dictionary.
off - the offset into buffer where the dictionary starts.
len - the length of the dictionary.
抛出：
java.lang.IllegalStateException - if no dictionary is needed.
java.lang.IllegalArgumentException - if the dictionary checksum is wrong.
java.lang.IndexOutOfBoundsException - if the off and/or len are wrong.

setInput

public void setInput(byte[] buf)
Sets the input. This should only be called, if needsInput() returns true.

参数：
buffer - the input.
抛出：
java.lang.IllegalStateException - if no input is needed.

setInput

public void setInput(byte[] buf,
                     int off,
                     int len)
Sets the input. This should only be called, if needsInput() returns true.

参数：
buffer - the input.
off - the offset into buffer where the input starts.
len - the length of the input.
抛出：
java.lang.IllegalStateException - if no input is needed.
java.lang.IndexOutOfBoundsException - if the off and/or len are wrong.

inflate

public int inflate(byte[] buf)
            throws DataFormatException
Inflates the compressed stream to the output buffer. If this returns 0, you should check, whether needsDictionary(), needsInput() or finished() returns true, to determine why no further output is produced.

参数：
buffer - the output buffer.
返回：
the number of bytes written to the buffer, 0 if no further output can be produced.
抛出：
DataFormatException - , if deflated stream is invalid.
java.lang.IllegalArgumentException - , if buf has length 0.

inflate

public int inflate(byte[] buf,
                   int off,
                   int len)
            throws DataFormatException
Inflates the compressed stream to the output buffer. If this returns 0, you should check, whether needsDictionary(), needsInput() or finished() returns true, to determine why no further output is produced.

参数：
buffer - the output buffer.
off - the offset into buffer where the output should start.
len - the maximum length of the output.
返回：
the number of bytes written to the buffer, 0 if no further output can be produced.
抛出：
DataFormatException - , if deflated stream is invalid.
java.lang.IllegalArgumentException - , if len is <= 0.
java.lang.IndexOutOfBoundsException - if the off and/or len are wrong.

needsInput

public boolean needsInput()
Returns true, if the input buffer is empty. You should then call setInput().
NOTE: This method also returns true when the stream is finished.

needsDictionary

public boolean needsDictionary()
Returns true, if a preset dictionary is needed to inflate the input.

finished

public boolean finished()
Returns true, if the inflater has finished. This means, that no input is needed and no output can be produced.

getAdler

public int getAdler()
Gets the adler checksum. This is either the checksum of all uncompressed bytes returned by inflate(), or if needsDictionary() returns true (and thus no output was yet produced) this is the adler checksum of the expected dictionary.

getTotalOut

public int getTotalOut()
Gets the total number of output bytes returned by inflate().

返回：
the total number of output bytes.

getTotalIn

public int getTotalIn()
Gets the total number of processed compressed input bytes.

返回：
the total number of bytes of processed input bytes.

getRemaining

public int getRemaining()
Gets the number of unprocessed input. Useful, if the end of the stream is reached and you want to further process the bytes after the deflate stream.

返回：
the number of bytes of the input which were not processed.

end

public void end()
已过时。 Just clear all references to inflater instead.

Frees all objects allocated by the inflater. There's no reason to call this, since you can just rely on garbage collection (even for the Sun implementation). Exists only for compatibility with Sun's JDK, where the compressor allocates native memory. If you call any method (even reset) afterwards the behaviour is undefined .

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InflaterHuffmanTree

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 InflaterHuffmanTree

java.lang.Object
    继承者  com.trs.infra.util.jazzlib.InflaterHuffmanTree

public class InflaterHuffmanTree
extends java.lang.Object

字段摘要
static InflaterHuffmanTree | defDistTree
static InflaterHuffmanTree | defLitLenTree
构造方法摘要
InflaterHuffmanTree(byte[] codeLengths)
Constructs a Huffman tree from the array of code lengths.
方法摘要
 int getSymbol(com.trs.infra.util.jazzlib.StreamManipulator input)
Reads the next symbol from input.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

defLitLenTree

public static InflaterHuffmanTree defLitLenTree

defDistTree

public static InflaterHuffmanTree defDistTree
构造方法详细信息

InflaterHuffmanTree

public InflaterHuffmanTree(byte[] codeLengths)
                    throws DataFormatException
Constructs a Huffman tree from the array of code lengths.

参数：
codeLengths - the array of code lengths
抛出：
DataFormatException
方法详细信息

getSymbol

public int getSymbol(com.trs.infra.util.jazzlib.StreamManipulator input)
              throws DataFormatException
Reads the next symbol from input. The symbol is encoded using the huffman tree.

参数：
input - the input source.
返回：
the next symbol, or -1 if not enough input is available.
抛出：
DataFormatException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InflaterInputStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 InflaterInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  com.trs.infra.util.jazzlib.InflaterInputStream
所有已实现的接口：
java.io.Closeable
直接已知子类：
GZIPInputStream, ZipInputStream
public class InflaterInputStream
extends java.io.FilterInputStream

This filter stream is used to decompress data compressed in the "deflate" format. The "deflate" format is described in RFC 1951. This stream may form the basis for other decompression filters, such as the GZIPInputStream.

从以下版本开始：
JDK 1.1
作者：
John Leuner

构造方法摘要
InflaterInputStream(java.io.InputStream in)
Create an InflaterInputStream with the default decompresseor and a default buffer size.
InflaterInputStream(java.io.InputStream in, Inflater inf)
Create an InflaterInputStream with the specified decompresseor and a default buffer size.
InflaterInputStream(java.io.InputStream in, Inflater inf, int size)
Create an InflaterInputStream with the specified decompresseor and a specified buffer size.
方法摘要
int | available() Returns 0 once the end of the stream (EOF) has been reached.
void | close() Closes the input stream
int | read() Reads one byte of decompressed data.
int | read(byte[] b, int off, int len) Decompresses data into the byte array
long | skip(long n) Skip specified number of bytes of uncompressed data
从类 java.io.FilterInputStream 继承的方法
mark, markSupported, read, reset
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InflaterInputStream

public InflaterInputStream(java.io.InputStream in)
Create an InflaterInputStream with the default decompresseor and a default buffer size.

参数：
in - the InputStream to read bytes from

InflaterInputStream

public InflaterInputStream(java.io.InputStream in,
                           Inflater inf)
Create an InflaterInputStream with the specified decompresseor and a default buffer size.

参数：
in - the InputStream to read bytes from
inf - the decompressor used to decompress data read from in

InflaterInputStream

public InflaterInputStream(java.io.InputStream in,
                           Inflater inf,
                           int size)
Create an InflaterInputStream with the specified decompresseor and a specified buffer size.

参数：
in - the InputStream to read bytes from
inf - the decompressor used to decompress data read from in
size - size of the buffer to use
方法详细信息

available

public int available()
              throws java.io.IOException
Returns 0 once the end of the stream (EOF) has been reached. Otherwise returns 1.

覆盖：
类 java.io.FilterInputStream 中的 available
抛出：
java.io.IOException

close

public void close()
           throws java.io.IOException
Closes the input stream

指定者：
接口 java.io.Closeable 中的 close
覆盖：
类 java.io.FilterInputStream 中的 close
抛出：
java.io.IOException

read

public int read()
         throws java.io.IOException
Reads one byte of decompressed data. The byte is in the lower 8 bits of the int.

覆盖：
类 java.io.FilterInputStream 中的 read
抛出：
java.io.IOException

read

public int read(byte[] b,
                int off,
                int len)
         throws java.io.IOException
Decompresses data into the byte array

覆盖：
类 java.io.FilterInputStream 中的 read
参数：
b - the array to read and decompress data into
off - the offset indicating where the data should be placed
len - the number of bytes to decompress
抛出：
java.io.IOException

skip

public long skip(long n)
          throws java.io.IOException
Skip specified number of bytes of uncompressed data

覆盖：
类 java.io.FilterInputStream 中的 skip
参数：
n - number of bytes to skip
抛出：
java.io.IOException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.jazzlib
接口
Checksum
类
Adler32
CheckedInputStream
CheckedOutputStream
CRC32
Deflater
DeflaterOutputStream
GZIPInputStream
GZIPOutputStream
Inflater
InflaterHuffmanTree
InflaterInputStream
ZipEntry
ZipFile
ZipInputStream
ZipOutputStream
异常
DataFormatException
ZipException


com.trs.infra.util.jazzlib

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.jazzlib

接口摘要
Checksum Interface to compute a data checksum used by checked input/output streams.

类摘要
Adler32 | Computes Adler32 checksum for a stream of data.
CheckedInputStream | InputStream that computes a checksum of the data being read using a supplied Checksum object.
CheckedOutputStream | OutputStream that computes a checksum of data being written using a supplied Checksum object.
CRC32 | Computes CRC32 data checksum of a data stream.
Deflater | This is the Deflater class.
DeflaterOutputStream | This is a special FilterOutputStream deflating the bytes that are written through it.
GZIPInputStream | This filter stream is used to decompress a "GZIP" format stream.
GZIPOutputStream | This filter stream is used to compress a stream into a "GZIP" stream.
Inflater | Inflater is used to decompress data that has been compressed according to the "deflate" standard described in rfc1950.
InflaterHuffmanTree |
InflaterInputStream | This filter stream is used to decompress data compressed in the "deflate" format.
ZipEntry | This class represents a member of a zip archive.
ZipFile | This class represents a Zip archive.
ZipInputStream | This is a FilterInputStream that reads the files in an zip archive one after another.
ZipOutputStream | This is a FilterOutputStream that writes the files into a zip archive one after another.

异常摘要
DataFormatException | Exception thrown when compressed data is corrupt.
ZipException | Is thrown during the creation or input of a zip file.


com.trs.infra.util.jazzlib 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.jazzlib 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.jazzlib.Adler32 (implements com.trs.infra.util.jazzlib.Checksum)
    • com.trs.infra.util.jazzlib.CRC32 (implements com.trs.infra.util.jazzlib.Checksum)
    • com.trs.infra.util.jazzlib.Deflater
    • com.trs.infra.util.jazzlib.Inflater
    • com.trs.infra.util.jazzlib.InflaterHuffmanTree
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • com.trs.infra.util.jazzlib.CheckedInputStream
        • com.trs.infra.util.jazzlib.InflaterInputStream
          • com.trs.infra.util.jazzlib.GZIPInputStream
          • com.trs.infra.util.jazzlib.ZipInputStream
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • com.trs.infra.util.jazzlib.CheckedOutputStream
        • com.trs.infra.util.jazzlib.DeflaterOutputStream
          • com.trs.infra.util.jazzlib.GZIPOutputStream
          • com.trs.infra.util.jazzlib.ZipOutputStream
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.infra.util.jazzlib.DataFormatException
        • java.io.IOException
          • com.trs.infra.util.jazzlib.ZipException
    • com.trs.infra.util.jazzlib.ZipEntry (implements java.lang.Cloneable)
    • com.trs.infra.util.jazzlib.ZipFile

接口分层结构

  • com.trs.infra.util.jazzlib.Checksum


软件包 com.trs.infra.util.jazzlib 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.jazzlib
的使用

使用 com.trs.infra.util.jazzlib 的软件包
com.trs.infra.util
com.trs.infra.util.jazzlib

com.trs.infra.util 使用的 com.trs.infra.util.jazzlib 中的类
ZipEntry
This class represents a member of a zip archive.

com.trs.infra.util.jazzlib 使用的 com.trs.infra.util.jazzlib 中的类
Checksum
Interface to compute a data checksum used by checked input/output streams.
DataFormatException
Exception thrown when compressed data is corrupt.
Deflater
This is the Deflater class.
DeflaterOutputStream
This is a special FilterOutputStream deflating the bytes that are written through it.
Inflater
Inflater is used to decompress data that has been compressed according to the "deflate" standard described in rfc1950.
InflaterHuffmanTree
InflaterInputStream
This filter stream is used to decompress data compressed in the "deflate" format.
ZipEntry
This class represents a member of a zip archive.
ZipException
Is thrown during the creation or input of a zip file.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ZipEntry

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 ZipEntry

java.lang.Object
    继承者  com.trs.infra.util.jazzlib.ZipEntry
所有已实现的接口：
java.lang.Cloneable
public class ZipEntry
extends java.lang.Object
implements java.lang.Cloneable

This class represents a member of a zip archive. ZipFile and ZipInputStream will give you instances of this class as information about the members in an archive. On the other hand ZipOutputStream needs an instance of this class to create a new member.

作者：
Jochen Hoenicke

字段摘要
static int | DEFLATED Compression method.
static int | STORED Compression method.
构造方法摘要
ZipEntry(java.lang.String name)
Creates a zip entry with the given name.
ZipEntry(ZipEntry e)
Creates a copy of the given zip entry.
方法摘要
java.lang.Object | clone() Clones the entry.
java.lang.String | getComment() Gets the comment.
long | getCompressedSize() Gets the size of the compressed data.
long | getCrc() Gets the crc of the uncompressed data.
byte[] | getExtra() Gets the extra data.
int | getMethod() Gets the compression method.
java.lang.String | getName() Returns the entry name.
long | getSize() Gets the size of the uncompressed data.
long | getTime() Gets the time of last modification of the entry.
int | hashCode() Gets the hashCode of this ZipEntry.
boolean | isDirectory() Gets true, if the entry is a directory.
void | setComment(java.lang.String comment) Sets the entry comment.
void | setCompressedSize(long csize) Sets the size of the compressed data.
void | setCrc(long crc) Sets the crc of the uncompressed data.
void | setExtra(byte[] extra) Sets the extra data.
void | setMethod(int method) Sets the compression method.
void | setSize(long size) Sets the size of the uncompressed data.
void | setTime(long time) Sets the time of last modification of the entry.
java.lang.String | toString() Gets the string representation of this ZipEntry.
从类 java.lang.Object 继承的方法
equals, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

STORED

public static final int STORED
Compression method. This method doesn't compress at all.

另请参见：
常量字段值

DEFLATED

public static final int DEFLATED
Compression method. This method uses the Deflater.

另请参见：
常量字段值
构造方法详细信息

ZipEntry

public ZipEntry(java.lang.String name)
Creates a zip entry with the given name.

参数：
name - the name. May include directory components separated by '/'.

ZipEntry

public ZipEntry(ZipEntry e)
Creates a copy of the given zip entry.

参数：
e - the entry to copy.
方法详细信息

clone

public java.lang.Object clone()
Clones the entry.

覆盖：
类 java.lang.Object 中的 clone

getName

public java.lang.String getName()
Returns the entry name. The path components in the entry are always separated by slashes ('/').

setTime

public void setTime(long time)
Sets the time of last modification of the entry.

getTime

public long getTime()
Gets the time of last modification of the entry.

返回：
the time of last modification of the entry, or -1 if unknown.

setSize

public void setSize(long size)
Sets the size of the uncompressed data.

抛出：
java.lang.IllegalArgumentException - if size is not in 0..0xffffffffL

getSize

public long getSize()
Gets the size of the uncompressed data.

返回：
the size or -1 if unknown.

setCompressedSize

public void setCompressedSize(long csize)
Sets the size of the compressed data.

抛出：
java.lang.IllegalArgumentException - if size is not in 0..0xffffffffL

getCompressedSize

public long getCompressedSize()
Gets the size of the compressed data.

返回：
the size or -1 if unknown.

setCrc

public void setCrc(long crc)
Sets the crc of the uncompressed data.

抛出：
java.lang.IllegalArgumentException - if crc is not in 0..0xffffffffL

getCrc

public long getCrc()
Gets the crc of the uncompressed data.

返回：
the crc or -1 if unknown.

setMethod

public void setMethod(int method)
Sets the compression method. Only DEFLATED and STORED are supported.

抛出：
java.lang.IllegalArgumentException - if method is not supported.
另请参见：
ZipOutputStream.DEFLATED, ZipOutputStream.STORED

getMethod

public int getMethod()
Gets the compression method.

返回：
the compression method or -1 if unknown.

setExtra

public void setExtra(byte[] extra)
Sets the extra data.

抛出：
java.lang.IllegalArgumentException - if extra is longer than 0xffff bytes.

getExtra

public byte[] getExtra()
Gets the extra data.

返回：
the extra data or null if not set.

setComment

public void setComment(java.lang.String comment)
Sets the entry comment.

抛出：
java.lang.IllegalArgumentException - if comment is longer than 0xffff.

getComment

public java.lang.String getComment()
Gets the comment.

返回：
the comment or null if not set.

isDirectory

public boolean isDirectory()
Gets true, if the entry is a directory. This is solely determined by the name, a trailing slash '/' marks a directory.

toString

public java.lang.String toString()
Gets the string representation of this ZipEntry. This is just the name as returned by getName().

覆盖：
类 java.lang.Object 中的 toString

hashCode

public int hashCode()
Gets the hashCode of this ZipEntry. This is just the hashCode of the name. Note that the equals method isn't changed, though.

覆盖：
类 java.lang.Object 中的 hashCode
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 ZipException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  com.trs.infra.util.jazzlib.ZipException
所有已实现的接口：
java.io.Serializable
public class ZipException
extends java.io.IOException

Is thrown during the creation or input of a zip file.

从以下版本开始：
JDK 1.1
作者：
Jochen Hoenicke, Per Bothner
另请参见：
序列化表格

构造方法摘要
ZipException()
ZipException(java.lang.String msg)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ZipException

public ZipException()

ZipException

public ZipException(java.lang.String msg)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 ZipFile

java.lang.Object
    继承者  com.trs.infra.util.jazzlib.ZipFile

public class ZipFile
extends java.lang.Object

This class represents a Zip archive. You can ask for the contained entries, or get an input stream for a file entry. The entry is automatically decompressed. This class is thread safe: You can open input streams for arbitrary entries in different threads.

作者：
Jochen Hoenicke

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static int | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDDCD
static int | ENDHDR
static int | ENDNRD
static int | ENDOFF
static int | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static int | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static int | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
static int | OPEN_DELETE Mode flag to delete a zip file after reading
static int | OPEN_READ Mode flag to open a zip file for reading
构造方法摘要
ZipFile(java.io.File file)
Opens a Zip file reading the given File.
ZipFile(java.io.File file, int mode)
Opens a Zip file reading the given File in the given mode.
ZipFile(java.lang.String name)
Opens a Zip file with the given name for reading.
ZipFile(java.lang.String name, java.lang.String enc)
Opens a Zip file with the given name for reading.
方法摘要
void | close() Closes the ZipFile.
java.util.Enumeration | entries() Returns an enumeration of all Zip entries in this Zip file.
java.lang.String | getEncoding() 取当前字符编码集
ZipEntry | getEntry(java.lang.String name) Searches for a zip entry in this archive with the given name.
java.io.InputStream | getInputStream(ZipEntry entry) Creates an input stream reading the given zip entry as uncompressed data.
java.lang.String | getName() Returns the name of this zip file.
void | setEncoding(java.lang.String _encoding) 设置字符编码集
int | size() Returns the number of entries in this zip file.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OPEN_READ

public static final int OPEN_READ
Mode flag to open a zip file for reading

另请参见：
常量字段值

OPEN_DELETE

public static final int OPEN_DELETE
Mode flag to delete a zip file after reading

另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

LOCSIG

public static final int LOCSIG
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTSIG

public static final int EXTSIG
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENSIG

public static final int CENSIG
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSIG

public static final int ENDSIG
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

ENDNRD

public static final int ENDNRD
另请参见：
常量字段值

ENDDCD

public static final int ENDDCD
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

ZipFile

public ZipFile(java.lang.String name)
        throws ZipException,
               java.io.IOException
Opens a Zip file with the given name for reading.

抛出：
java.io.IOException - if a i/o error occured.
ZipException - if the file doesn't contain a valid zip archive.

ZipFile

public ZipFile(java.lang.String name,
               java.lang.String enc)
        throws ZipException,
               java.io.IOException
Opens a Zip file with the given name for reading.

抛出：
java.io.IOException - if a i/o error occured.
ZipException - if the file doesn't contain a valid zip archive.

ZipFile

public ZipFile(java.io.File file)
        throws ZipException,
               java.io.IOException
Opens a Zip file reading the given File.

抛出：
java.io.IOException - if a i/o error occured.
ZipException - if the file doesn't contain a valid zip archive.

ZipFile

public ZipFile(java.io.File file,
               int mode)
        throws ZipException,
               java.io.IOException
Opens a Zip file reading the given File in the given mode. If the OPEN_DELETE mode is specified, the zip file will be deleted at some time moment after it is opened. It will be deleted before the zip file is closed or the Virtual Machine exits. The contents of the zip file will be accessible until it is closed. The OPEN_DELETE mode is currently unimplemented in this library

参数：
mode - Must be one of OPEN_READ or OPEN_READ | OPEN_DELETE
抛出：
java.io.IOException - if a i/o error occured.
ZipException - if the file doesn't contain a valid zip archive.
从以下版本开始：
JDK1.3
方法详细信息

getEncoding

public java.lang.String getEncoding()
取当前字符编码集

返回：
当前字符编码集

setEncoding

public void setEncoding(java.lang.String _encoding)
设置字符编码集

参数：
_encoding - 字符编码集；若为null，则表示为默认字符编码集

close

public void close()
           throws java.io.IOException
Closes the ZipFile. This also closes all input streams given by this class. After this is called, no further method should be called.

抛出：
java.io.IOException - if a i/o error occured.

entries

public java.util.Enumeration entries()
Returns an enumeration of all Zip entries in this Zip file.

getEntry

public ZipEntry getEntry(java.lang.String name)
Searches for a zip entry in this archive with the given name.

参数：
the - name. May contain directory components separated by slashes ('/').
返回：
the zip entry, or null if no entry with that name exists.
另请参见：
entries

getInputStream

public java.io.InputStream getInputStream(ZipEntry entry)
                                   throws java.io.IOException
Creates an input stream reading the given zip entry as uncompressed data. Normally zip entry should be an entry returned by getEntry() or entries().

返回：
the input stream.
抛出：
java.io.IOException - if a i/o error occured.
ZipException - if the Zip archive is malformed.

getName

public java.lang.String getName()
Returns the name of this zip file.

size

public int size()
Returns the number of entries in this zip file.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipInputStream

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 ZipInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  com.trs.infra.util.jazzlib.InflaterInputStream
                继承者  com.trs.infra.util.jazzlib.ZipInputStream
所有已实现的接口：
java.io.Closeable
public class ZipInputStream
extends InflaterInputStream

This is a FilterInputStream that reads the files in an zip archive one after another. It has a special method to get the zip entry of the next file. The zip entry contains information about the file name size, compressed size, CRC, etc. It includes support for STORED and DEFLATED entries.

作者：
Jochen Hoenicke

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static int | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDDCD
static int | ENDHDR
static int | ENDNRD
static int | ENDOFF
static int | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static int | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static int | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
构造方法摘要
ZipInputStream(java.io.InputStream in)
Creates a new Zip input stream, reading a zip archive.
方法摘要
int | available() Returns 0 once the end of the stream (EOF) has been reached.
void | close() Closes the zip file.
void | closeEntry() Closes the current zip entry and moves to the next one.
ZipEntry | getNextEntry() Open the next entry from the zip archive, and return its description.
ZipEntry | getNextEntry(java.lang.String _encoding)
int | read() Reads a byte from the current zip entry.
int | read(byte[] b, int off, int len) Reads a block of bytes from the current zip entry.
从类 com.trs.infra.util.jazzlib.InflaterInputStream 继承的方法
skip
从类 java.io.FilterInputStream 继承的方法
mark, markSupported, read, reset
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

LOCSIG

public static final int LOCSIG
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTSIG

public static final int EXTSIG
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENSIG

public static final int CENSIG
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSIG

public static final int ENDSIG
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

ENDNRD

public static final int ENDNRD
另请参见：
常量字段值

ENDDCD

public static final int ENDDCD
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

ZipInputStream

public ZipInputStream(java.io.InputStream in)
Creates a new Zip input stream, reading a zip archive.

方法详细信息

getNextEntry

public ZipEntry getNextEntry()
                      throws java.io.IOException
Open the next entry from the zip archive, and return its description. If the previous entry wasn't closed, this method will close it.

抛出：
java.io.IOException

getNextEntry

public ZipEntry getNextEntry(java.lang.String _encoding)
                      throws java.io.IOException
抛出：
java.io.IOException

closeEntry

public void closeEntry()
                throws java.io.IOException
Closes the current zip entry and moves to the next one.

抛出：
java.io.IOException

available

public int available()
              throws java.io.IOException
从类 InflaterInputStream 复制的描述
Returns 0 once the end of the stream (EOF) has been reached. Otherwise returns 1.

覆盖：
类 InflaterInputStream 中的 available
抛出：
java.io.IOException

read

public int read()
         throws java.io.IOException
Reads a byte from the current zip entry.

覆盖：
类 InflaterInputStream 中的 read
返回：
the byte or -1 on EOF.
抛出：
java.io.IOException - if a i/o error occured.
ZipException - if the deflated stream is corrupted.

read

public int read(byte[] b,
                int off,
                int len)
         throws java.io.IOException
Reads a block of bytes from the current zip entry.

覆盖：
类 InflaterInputStream 中的 read
参数：
b - the array to read and decompress data into
off - the offset indicating where the data should be placed
len - the number of bytes to decompress
返回：
the number of bytes read (may be smaller, even before EOF), or -1 on EOF.
抛出：
java.io.IOException - if a i/o error occured.
ZipException - if the deflated stream is corrupted.

close

public void close()
           throws java.io.IOException
Closes the zip file.

指定者：
接口 java.io.Closeable 中的 close
覆盖：
类 InflaterInputStream 中的 close
抛出：
java.io.IOException - if a i/o error occured.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipOutputStream

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.jazzlib
类 ZipOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  com.trs.infra.util.jazzlib.DeflaterOutputStream
                继承者  com.trs.infra.util.jazzlib.ZipOutputStream
所有已实现的接口：
java.io.Closeable, java.io.Flushable
public class ZipOutputStream
extends DeflaterOutputStream

This is a FilterOutputStream that writes the files into a zip archive one after another. It has a special method to start a new zip entry. The zip entries contains information about the file name size, compressed size, CRC, etc. It includes support for STORED and DEFLATED entries. This class is not thread safe.

作者：
Jochen Hoenicke

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static int | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | DEFLATED Compression method.
static int | ENDCOM
static int | ENDDCD
static int | ENDHDR
static int | ENDNRD
static int | ENDOFF
static int | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static int | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static int | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
static int | STORED Compression method.
构造方法摘要
ZipOutputStream(java.io.OutputStream out)
Creates a new Zip output stream, writing a zip archive.
方法摘要
void | closeEntry() Closes the current entry.
void | finish() Finishes the stream.
java.lang.String | getEncoding() 取当前字符编码集
void | putNextEntry(ZipEntry entry) Starts a new Zip entry.
void | setComment(java.lang.String comment) Set the zip file comment.
void | setEncoding(java.lang.String _encoding) 设置字符编码集
void | setLevel(int level) Sets default compression level.
void | setMethod(int method) Sets default compression method.
void | write(byte[] b, int off, int len) Writes the given buffer to the current entry.
从类 com.trs.infra.util.jazzlib.DeflaterOutputStream 继承的方法
close, flush, write
从类 java.io.FilterOutputStream 继承的方法
write
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STORED

public static final int STORED
Compression method. This method doesn't compress at all.

另请参见：
常量字段值

DEFLATED

public static final int DEFLATED
Compression method. This method uses the Deflater.

另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

LOCSIG

public static final int LOCSIG
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTSIG

public static final int EXTSIG
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENSIG

public static final int CENSIG
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSIG

public static final int ENDSIG
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

ENDNRD

public static final int ENDNRD
另请参见：
常量字段值

ENDDCD

public static final int ENDDCD
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

ZipOutputStream

public ZipOutputStream(java.io.OutputStream out)
Creates a new Zip output stream, writing a zip archive.

参数：
out - the output stream to which the zip archive is written.
方法详细信息

getEncoding

public java.lang.String getEncoding()
取当前字符编码集

返回：
当前字符编码集

setEncoding

public void setEncoding(java.lang.String _encoding)
设置字符编码集

参数：
_encoding - 字符编码集；若为null，则表示为默认字符编码集

setComment

public void setComment(java.lang.String comment)
Set the zip file comment.

参数：
comment - the comment.
抛出：
java.lang.IllegalArgumentException - if UTF8 encoding of comment is longer than 0xffff bytes.

setMethod

public void setMethod(int method)
Sets default compression method. If the Zip entry specifies another method its method takes precedence.

参数：
method - the method.
抛出：
java.lang.IllegalArgumentException - if method is not supported.
另请参见：
STORED, DEFLATED

setLevel

public void setLevel(int level)
Sets default compression level. The new level will be activated immediately.

抛出：
java.lang.IllegalArgumentException - if level is not supported.
另请参见：
Deflater

putNextEntry

public void putNextEntry(ZipEntry entry)
                  throws java.io.IOException
Starts a new Zip entry. It automatically closes the previous entry if present. If the compression method is stored, the entry must have a valid size and crc, otherwise all elements (except name) are optional, but must be correct if present. If the time is not set in the entry, the current time is used.

参数：
entry - the entry.
抛出：
java.io.IOException - if an I/O error occured.
java.lang.IllegalStateException - if stream was finished

closeEntry

public void closeEntry()
                throws java.io.IOException
Closes the current entry.

抛出：
java.io.IOException - if an I/O error occured.
java.lang.IllegalStateException - if no entry is active.

write

public void write(byte[] b,
                  int off,
                  int len)
           throws java.io.IOException
Writes the given buffer to the current entry.

覆盖：
类 DeflaterOutputStream 中的 write
参数：
b - the byte array.
off - the offset into the byte array where to start.
len - the number of bytes to write.
抛出：
java.io.IOException - if an I/O error occured.
java.lang.IllegalStateException - if no entry is active.

finish

public void finish()
            throws java.io.IOException
Finishes the stream. This will write the central directory at the end of the zip file and flush the stream.

覆盖：
类 DeflaterOutputStream 中的 finish
抛出：
java.io.IOException - if an I/O error occured.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.util.jazzlib.Adler32 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.Adler32
的使用

没有 com.trs.infra.util.jazzlib.Adler32 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.CheckedInputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.CheckedInputStream
的使用

没有 com.trs.infra.util.jazzlib.CheckedInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.CheckedOutputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.CheckedOutputStream
的使用

没有 com.trs.infra.util.jazzlib.CheckedOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.infra.util.jazzlib.Checksum 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.util.jazzlib.Checksum
的使用

使用 Checksum 的软件包
com.trs.infra.util.jazzlib

com.trs.infra.util.jazzlib 中 Checksum 的使用

实现 Checksum 的 com.trs.infra.util.jazzlib 中的类
class | Adler32 Computes Adler32 checksum for a stream of data.
class | CRC32 Computes CRC32 data checksum of a data stream.

返回 Checksum 的 com.trs.infra.util.jazzlib 中的方法
Checksum | CheckedOutputStream.getChecksum() Returns the Checksum object used.
Checksum | CheckedInputStream.getChecksum() Returns the Checksum object used.

参数类型为 Checksum 的 com.trs.infra.util.jazzlib 中的构造方法
CheckedInputStream(java.io.InputStream in, Checksum sum)
Creates a new CheckInputStream on top of the supplied OutputStream using the supplied Checksum.
CheckedOutputStream(java.io.OutputStream out, Checksum cksum)
Creates a new CheckInputStream on top of the supplied OutputStream using the supplied Checksum.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.CRC32 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.CRC32
的使用

没有 com.trs.infra.util.jazzlib.CRC32 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.DataFormatException 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.DataFormatException
的使用

使用 DataFormatException 的软件包
com.trs.infra.util.jazzlib

com.trs.infra.util.jazzlib 中 DataFormatException 的使用

抛出 DataFormatException 的 com.trs.infra.util.jazzlib 中的方法
int | InflaterHuffmanTree.getSymbol(com.trs.infra.util.jazzlib.StreamManipulator input) Reads the next symbol from input.
int | Inflater.inflate(byte[] buf) Inflates the compressed stream to the output buffer.
int | Inflater.inflate(byte[] buf, int off, int len) Inflates the compressed stream to the output buffer.

抛出 DataFormatException 的 com.trs.infra.util.jazzlib 中的构造方法
InflaterHuffmanTree(byte[] codeLengths)
Constructs a Huffman tree from the array of code lengths.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.Deflater 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.Deflater
的使用

使用 Deflater 的软件包
com.trs.infra.util.jazzlib

com.trs.infra.util.jazzlib 中 Deflater 的使用

参数类型为 Deflater 的 com.trs.infra.util.jazzlib 中的构造方法
DeflaterOutputStream(java.io.OutputStream out, Deflater defl)
Creates a new DeflaterOutputStream with the given Deflater and default buffer size.
DeflaterOutputStream(java.io.OutputStream out, Deflater defl, int bufsize)
Creates a new DeflaterOutputStream with the given Deflater and buffer size.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.DeflaterOutputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.DeflaterOutputStream
的使用

使用 DeflaterOutputStream 的软件包
com.trs.infra.util.jazzlib

com.trs.infra.util.jazzlib 中 DeflaterOutputStream 的使用

com.trs.infra.util.jazzlib 中 DeflaterOutputStream 的子类
class | GZIPOutputStream This filter stream is used to compress a stream into a "GZIP" stream.
class | ZipOutputStream This is a FilterOutputStream that writes the files into a zip archive one after another.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.GZIPInputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.GZIPInputStream
的使用

没有 com.trs.infra.util.jazzlib.GZIPInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.GZIPOutputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.GZIPOutputStream
的使用

没有 com.trs.infra.util.jazzlib.GZIPOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.Inflater 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.Inflater
的使用

使用 Inflater 的软件包
com.trs.infra.util.jazzlib

com.trs.infra.util.jazzlib 中 Inflater 的使用

参数类型为 Inflater 的 com.trs.infra.util.jazzlib 中的构造方法
InflaterInputStream(java.io.InputStream in, Inflater inf)
Create an InflaterInputStream with the specified decompresseor and a default buffer size.
InflaterInputStream(java.io.InputStream in, Inflater inf, int size)
Create an InflaterInputStream with the specified decompresseor and a specified buffer size.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.InflaterHuffmanTree 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.InflaterHuffmanTree
的使用

使用 InflaterHuffmanTree 的软件包
com.trs.infra.util.jazzlib

com.trs.infra.util.jazzlib 中 InflaterHuffmanTree 的使用

声明为 InflaterHuffmanTree 的 com.trs.infra.util.jazzlib 中的字段
static InflaterHuffmanTree | InflaterHuffmanTree.defDistTree
static InflaterHuffmanTree | InflaterHuffmanTree.defLitLenTree

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.InflaterInputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.InflaterInputStream
的使用

使用 InflaterInputStream 的软件包
com.trs.infra.util.jazzlib

com.trs.infra.util.jazzlib 中 InflaterInputStream 的使用

com.trs.infra.util.jazzlib 中 InflaterInputStream 的子类
class | GZIPInputStream This filter stream is used to decompress a "GZIP" format stream.
class | ZipInputStream This is a FilterInputStream that reads the files in an zip archive one after another.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.ZipEntry 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.ZipEntry
的使用

使用 ZipEntry 的软件包
com.trs.infra.util
com.trs.infra.util.jazzlib

com.trs.infra.util 中 ZipEntry 的使用

返回 ZipEntry 的 com.trs.infra.util 中的方法
 ZipEntry CMyUnzip.getItem(java.lang.String _sItemName)
提取指定压缩项信息

com.trs.infra.util.jazzlib 中 ZipEntry 的使用

返回 ZipEntry 的 com.trs.infra.util.jazzlib 中的方法
ZipEntry | ZipFile.getEntry(java.lang.String name) Searches for a zip entry in this archive with the given name.
ZipEntry | ZipInputStream.getNextEntry() Open the next entry from the zip archive, and return its description.
ZipEntry | ZipInputStream.getNextEntry(java.lang.String _encoding)

参数类型为 ZipEntry 的 com.trs.infra.util.jazzlib 中的方法
java.io.InputStream | ZipFile.getInputStream(ZipEntry entry) Creates an input stream reading the given zip entry as uncompressed data.
void | ZipOutputStream.putNextEntry(ZipEntry entry) Starts a new Zip entry.

参数类型为 ZipEntry 的 com.trs.infra.util.jazzlib 中的构造方法
ZipEntry(ZipEntry e)
Creates a copy of the given zip entry.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.ZipException 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.ZipException
的使用

使用 ZipException 的软件包
com.trs.infra.util.jazzlib

com.trs.infra.util.jazzlib 中 ZipException 的使用

抛出 ZipException 的 com.trs.infra.util.jazzlib 中的构造方法
ZipFile(java.io.File file)
Opens a Zip file reading the given File.
ZipFile(java.io.File file, int mode)
Opens a Zip file reading the given File in the given mode.
ZipFile(java.lang.String name)
Opens a Zip file with the given name for reading.
ZipFile(java.lang.String name, java.lang.String enc)
Opens a Zip file with the given name for reading.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.ZipFile 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.ZipFile
的使用

没有 com.trs.infra.util.jazzlib.ZipFile 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.ZipInputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.ZipInputStream
的使用

没有 com.trs.infra.util.jazzlib.ZipInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.jazzlib.ZipOutputStream 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.jazzlib.ZipOutputStream
的使用

没有 com.trs.infra.util.jazzlib.ZipOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseJob

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.job
类 BaseJob

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
所有已实现的接口：
org.quartz.Job
直接已知子类：
BaseScheduleWorker, BaseStatefulJob, UserInfoSyncUpdater
public abstract class BaseJob
extends java.lang.Object
implements org.quartz.Job

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseJob()
方法摘要
 void execute(org.quartz.JobExecutionContext _currContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseJob

public BaseJob()
方法详细信息

execute

public void execute(org.quartz.JobExecutionContext _currContext)
指定者：
接口 org.quartz.Job 中的 execute
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BaseStatefulJob

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.job
类 BaseStatefulJob

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.infra.util.job.BaseStatefulJob
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
直接已知子类：
DoingRuleHandler, StatefulJobTest
public abstract class BaseStatefulJob
extends BaseJob
implements org.quartz.StatefulJob

Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseStatefulJob()
方法摘要
从类 com.trs.infra.util.job.BaseJob 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

BaseStatefulJob

public BaseStatefulJob()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobFailedResult

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.job
类 JobFailedResult

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.infra.util.job.JobFailedResult
所有已实现的接口：
java.lang.Cloneable
public class JobFailedResult
extends BaseObj

Title: TRS 内容协作平台（TRS WCM）
Description:
计划任务执行失败记录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME
static java.lang.String | DB_TABLE_NAME
构造方法摘要
JobFailedResult()
JobFailedResult(int _nJobId, java.lang.Exception _rootCause)
方法摘要
static JobFailedResult | createNewInstance() 产生当前对象[JobFailedResult]的实例
static JobFailedResult | findById(int _nId) 提取指定ID的对象
static JobFailedResult | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
void | insert() 添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
boolean | isValid() 检测对象属性是否有效 注意：子类必须重载！！
void | update() 更新修改。
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, delete, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, save, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
另请参见：
常量字段值
构造方法详细信息

JobFailedResult

public JobFailedResult()

JobFailedResult

public JobFailedResult(int _nJobId,
                       java.lang.Exception _rootCause)
方法详细信息

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

指定者：
类 BaseObj 中的 getWCMType
返回：
整型类型数

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

指定者：
类 BaseObj 中的 getDbTableName
返回：

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

指定者：
类 BaseObj 中的 getIdFieldName
返回：
Id字段名

insert

public void insert()
            throws WCMException
从类 BaseObj 复制的描述
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理

覆盖：
类 BaseObj 中的 insert
抛出：
WCMException

update

public void update()
            throws WCMException
从类 BaseObj 复制的描述
更新修改。修改的属性值保存在hPropertyNew中

覆盖：
类 BaseObj 中的 update
抛出：
WCMException

isValid

public boolean isValid()
从类 BaseObj 复制的描述
检测对象属性是否有效 注意：子类必须重载！！

指定者：
类 BaseObj 中的 isValid
返回：

findById

public static final JobFailedResult findById(int _nId)
                                      throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final JobFailedResult createNewInstance()
                                               throws WCMException
产生当前对象[JobFailedResult]的实例

返回：
当前对象的实例[JobFailedResult]
抛出：
WCMException

findByKey

public static final JobFailedResult findByKey(java.lang.Object _oKey)
                                       throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobFailedResults

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.job
类 JobFailedResults

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.infra.util.job.JobFailedResults

public class JobFailedResults
extends BaseObjs

Title: TRS 内容协作平台（TRS WCM）
Description:
计划任务执行失败记录集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
JobFailedResults()
方法摘要
static JobFailedResults | createNewInstance() 产生当前集合对象[JobFailedResults]的实例
static JobFailedResults | findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
static JobFailedResults | openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[JobFailedResults]
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, cancelUpdate, cancelUpdateAll, cancelUpdateAll, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JobFailedResults

public JobFailedResults()
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

findByIds

public static final JobFailedResults findByIds(java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（JobFailedResults）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final JobFailedResults openWCMObjs(WCMFilter _filter)
                                          throws WCMException
通过指定一个Filter获取当前集合[JobFailedResults]

参数：
_filter - 指定的Filter
返回：
当前集合[JobFailedResults]
抛出：
WCMException

createNewInstance

public static JobFailedResults createNewInstance()
产生当前集合对象[JobFailedResults]的实例

参数：
_currUser - 当前操作用户
返回：
@throws WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobScheduler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.job
类 JobScheduler

java.lang.Object
    继承者  com.trs.infra.util.job.JobScheduler

public class JobScheduler
extends java.lang.Object

A "Cron-Expression" is a string comprised of 6 or 7 fields separated by white space. The 6 mandatory and 1 optional fields are as follows:

Field Name | Allowed Values | Allowed Special Characters
Seconds | 0-59 | , - * /
Minutes | 0-59 | , - * /
Hours | 0-23 | , - * /
Day-of-month | 1-31 | , - * ? / L W C
Month | 1-12 or JAN-DEC | , - * /
Day-of-Week | 1-7 or SUN-SAT | , - * ? / L C #
Year (Optional) | empty, 1970-2099 | , - * /

The '*' character is used to specify all values. For example, "*" in the minute field means "every minute".

The '?' character is allowed for the day-of-month and day-of-week fields. It is used to specify 'no specific value'. This is useful when you need to specify something in one of the two fileds, but not the other. See the examples below for clarification.

The '-' character is used to specify ranges For example "10-12" in the hour field means "the hours 10, 11 and 12".

The ',' character is used to specify additional values. For example "MON,WED,FRI" in the day-of-week field means "the days Monday, Wednesday, and Friday".

The '/' character is used to specify increments. For example "0/15" in the seconds field means "the seconds 0, 15, 30, and 45". And "5/15" in the seconds field means "the seconds 5, 20, 35, and 50". You can also specify '/' after the '*' character - in this case '*' is equivalent to having '0' before the '/'.

The 'L' character is allowed for the day-of-month and day-of-week fields. This character is short-hand for "last", but it has different meaning in each of the two fields. For example, the value "L" in the day-of-month field means "the last day of the month" - day 31 for January, day 28 for February on non-leap years. If used in the day-of-week field by itself, it simply means "7" or "SAT". But if used in the day-of-week field after another value, it means "the last xxx day of the month" - for example "6L" means "the last friday of the month". When using the 'L' option, it is important not to specify lists, or ranges of values, as you'll get confusing results.

The 'W' character is allowed for the day-of-month field. This character is used to specify the weekday (Monday-Friday) nearest the given day. As an example, if you were to specify "15W" as the value for the day-of-month field, the meaning is: "the nearest weekday to the 15th of the month". So if the 15th is a Saturday, the trigger will fire on Friday the 14th. If the 15th is a Sunday, the trigger will fire on Monday the 16th. If the 15th is a Tuesday, then it will fire on Tuesday the 15th. However if you specify "1W" as the value for day-of-month, and the 1st is a Saturday, the trigger will fire on Monday the 3rd, as it will not 'jump' over the boundary of a month's days. The 'W' character can only be specified when the day-of-month is a single day, not a range or list of days.

The 'L' and 'W' characters can also be combined for the day-of-month expression to yield 'LW', which translates to "last weekday of the month".

The '#' character is allowed for the day-of-week field. This character is used to specify "the nth" XXX day of the month. For example, the value of "6#3" in the day-of-week field means the third Friday of the month (day 6 = Friday and "#3" = the 3rd one in the month). Other examples: "2#1" = the first Monday of the month and "4#5" = the fifth Wednesday of the month. Note that if you specify "#5" and there is not 5 of the given day-of-week in the month, then no firing will occur that month.

The 'C' character is allowed for the day-of-month and day-of-week fields. This character is short-hand for "calendar". This means values are calculated against the associated calendar, if any. If no calendar is associated, then it is equivalent to having an all-inclusive calendar. A value of "5C" in the day-of-month field means "the first day included by the calendar on or after the 5th". A value of "1C" in the day-of-week field means "the first day included by the calendar on or after sunday".

The legal characters and the names of months and days of the week are not case sensitive.

Here are some full examples:

Expression | Meaning
"0 0 12 * * ?" | Fire at 12pm (noon) every day
"0 15 10 ? * *" | Fire at 10:15am every day
"0 15 10 * * ?" | Fire at 10:15am every day
"0 15 10 * * ? *" | Fire at 10:15am every day
"0 15 10 * * ? 2005" | Fire at 10:15am every day during the year 2005
"0 * 14 * * ?" | Fire every minute starting at 2pm and ending at 2:59pm, every day
"0 0/5 14 * * ?" | Fire every 5 minutes starting at 2pm and ending at 2:55pm, every day
"0 0/5 14,18 * * ?" | Fire every 5 minutes starting at 2pm and ending at 2:55pm, AND fire every 5 minutes starting at 6pm and ending at 6:55pm, every day
"0 0-5 14 * * ?" | Fire every minute starting at 2pm and ending at 2:05pm, every day
"0 10,44 14 ? 3 WED" | Fire at 2:10pm and at 2:44pm every Wednesday in the month of March.
"0 15 10 ? * MON-FRI" | Fire at 10:15am every Monday, Tuesday, Wednesday, Thursday and Friday
"0 15 10 15 * ?" | Fire at 10:15am on the 15th day of every month
"0 15 10 L * ?" | Fire at 10:15am on the last day of every month
"0 15 10 ? * 6L" | Fire at 10:15am on the last Friday of every month
"0 15 10 ? * 6L" | Fire at 10:15am on the last Friday of every month
"0 15 10 ? * 6L 2002-2005" | Fire at 10:15am on every last friday of every month during the years 2002, 2003, 2004 and 2005
"0 15 10 ? * 6#3" | Fire at 10:15am on the third Friday of every month

Pay attention to the effects of '?' and '*' in the day-of-week and day-of-month fields!

NOTES:

  • Support for the features described for the 'C' character is not complete.
  • Support for specifying both a day-of-week and a day-of-month value is not complete (you'll need to use the '?' character in on of these fields).
  • Be careful when setting fire times between mid-night and 1:00 AM - "daylight savings" can cause a skip or a repeat depending on whether the time moves back or jumps forward.

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
JobScheduler()
方法摘要
void | addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, CMyDateTime _dtExecute)
void | addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, CMyDateTime _dtStart, CMyDateTime _dtEnd, long _nInterval)
void | addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, long _nInterval)
void | addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, java.lang.String _sCronExpression)
void | addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, java.lang.String[] _arCronExpression)
void | addJob(java.lang.String _sJobName, java.lang.Class _jobWorkerClass, java.lang.String _sArgs, org.quartz.Trigger _trigger)
void | deleteJob(java.lang.String _sJobName)
java.util.Iterator | listTirggers() 列出当前所有的调度任务,以方便查看计划执行的情况
void | registerCalendar(java.lang.String _calendarName, org.quartz.Calendar _calendar)
void | restart()
void | shutDown()
boolean | start()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JobScheduler

public JobScheduler()
方法详细信息

restart

public void restart()
             throws WCMException
抛出：
WCMException

shutDown

public void shutDown()

start

public boolean start()
              throws WCMException
抛出：
WCMException

addJob

public void addJob(java.lang.String _sJobName,
                   java.lang.Class _jobWorkerClass,
                   java.lang.String _sArgs,
                   CMyDateTime _dtExecute)
            throws WCMException
抛出：
WCMException

addJob

public void addJob(java.lang.String _sJobName,
                   java.lang.Class _jobWorkerClass,
                   java.lang.String _sArgs,
                   CMyDateTime _dtStart,
                   CMyDateTime _dtEnd,
                   long _nInterval)
            throws WCMException
抛出：
WCMException

addJob

public void addJob(java.lang.String _sJobName,
                   java.lang.Class _jobWorkerClass,
                   java.lang.String _sArgs,
                   long _nInterval)
            throws WCMException
抛出：
WCMException

addJob

public void addJob(java.lang.String _sJobName,
                   java.lang.Class _jobWorkerClass,
                   java.lang.String _sArgs,
                   java.lang.String _sCronExpression)
            throws WCMException
抛出：
WCMException

addJob

public void addJob(java.lang.String _sJobName,
                   java.lang.Class _jobWorkerClass,
                   java.lang.String _sArgs,
                   java.lang.String[] _arCronExpression)
            throws WCMException
抛出：
WCMException

deleteJob

public void deleteJob(java.lang.String _sJobName)
               throws WCMException
抛出：
WCMException

addJob

public void addJob(java.lang.String _sJobName,
                   java.lang.Class _jobWorkerClass,
                   java.lang.String _sArgs,
                   org.quartz.Trigger _trigger)
            throws WCMException
抛出：
WCMException

registerCalendar

public void registerCalendar(java.lang.String _calendarName,
                             org.quartz.Calendar _calendar)
                      throws WCMException
参数：
dailyCal -
dailyCalendar -
抛出：
WCMException

listTirggers

public java.util.Iterator listTirggers()
                                throws java.lang.Exception
列出当前所有的调度任务,以方便查看计划执行的情况

返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.job
类
BaseJob
BaseStatefulJob
JobFailedResult
JobFailedResults
JobScheduler
StatefulJobTest


com.trs.infra.util.job

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.job

类摘要
BaseJob | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulJob | Title: TRS 内容协作平台（TRS WCM） Description: 线程安全的Job Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JobFailedResult | Title: TRS 内容协作平台（TRS WCM） Description: 计划任务执行失败记录 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JobFailedResults | Title: TRS 内容协作平台（TRS WCM） Description: 计划任务执行失败记录集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JobScheduler | A "Cron-Expression" is a string comprised of 6 or 7 fields separated by white space.
StatefulJobTest | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.util.job 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.job 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.job.BaseJob (implements org.quartz.Job)
      • com.trs.infra.util.job.BaseStatefulJob (implements org.quartz.StatefulJob)
        • com.trs.infra.util.job.StatefulJobTest
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.infra.util.job.JobFailedResult
    • com.trs.infra.persistent.BaseObjs
      • com.trs.infra.util.job.JobFailedResults
    • com.trs.infra.util.job.JobScheduler


软件包 com.trs.infra.util.job 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.job
的使用

使用 com.trs.infra.util.job 的软件包
com.trs.cms.auth.domain
com.trs.cms.process.engine.handlers
com.trs.components.common.job
com.trs.components.common.reminder
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.epress
com.trs.components.wcm.publish.domain.job
com.trs.components.wcm.stat
com.trs.infra.util.job

com.trs.cms.auth.domain 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.cms.process.engine.handlers 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulJob
Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.job 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.reminder 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.domain.job 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.stat 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.job 使用的 com.trs.infra.util.job 中的类
BaseJob
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulJob
Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobFailedResult
Title: TRS 内容协作平台（TRS WCM）
Description:
计划任务执行失败记录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobFailedResults
Title: TRS 内容协作平台（TRS WCM）
Description:
计划任务执行失败记录集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


StatefulJobTest

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.job
类 StatefulJobTest

java.lang.Object
    继承者  com.trs.infra.util.job.BaseJob
        继承者  com.trs.infra.util.job.BaseStatefulJob
            继承者  com.trs.infra.util.job.StatefulJobTest
所有已实现的接口：
org.quartz.Job, org.quartz.StatefulJob
public class StatefulJobTest
extends BaseStatefulJob

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
StatefulJobTest()
方法摘要
static void main(java.lang.String[] args)
从类 com.trs.infra.util.job.BaseJob 继承的方法
execute
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.quartz.Job 继承的方法
execute

构造方法详细信息

StatefulJobTest

public StatefulJobTest()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.util.job.BaseJob 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.job.BaseJob
的使用

使用 BaseJob 的软件包
com.trs.cms.auth.domain
com.trs.cms.process.engine.handlers
com.trs.components.common.job
com.trs.components.common.reminder
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.epress
com.trs.components.wcm.publish.domain.job
com.trs.components.wcm.stat
com.trs.infra.util.job

com.trs.cms.auth.domain 中 BaseJob 的使用

com.trs.cms.auth.domain 中 BaseJob 的子类
 class UserInfoSyncUpdater
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.cms.process.engine.handlers 中 BaseJob 的使用

com.trs.cms.process.engine.handlers 中 BaseJob 的子类
 class DoingRuleHandler

com.trs.components.common.job 中 BaseJob 的使用

com.trs.components.common.job 中 BaseJob 的子类
class | BaseScheduleWorker Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseStatefulScheduleWorker Title: TRS 内容协作平台（TRS WCM） Description: 线程安全的Job Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | OptimizeSystemWorker
class | TempPathCleaner

com.trs.components.common.reminder 中 BaseJob 的使用

com.trs.components.common.reminder 中 BaseJob 的子类
 class Reminder

com.trs.components.stat 中 BaseJob 的使用

com.trs.components.stat 中 BaseJob 的子类
 class HitsCountParserSchedule

com.trs.components.wcm.content.domain 中 BaseJob 的使用

com.trs.components.wcm.content.domain 中 BaseJob 的子类
class | ChnlSynWorker
class | DocPriDisableWorker Title: TRS 内容协作平台（TRS WCM） Description: 根据文档置顶的截止时间撤销文档置顶的计划任务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 BaseJob 的使用

com.trs.components.wcm.epress 中 BaseJob 的子类
 class EPressHistoryIndexWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
计划发布产生概览索引(当天的数据)
Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.domain.job 中 BaseJob 的使用

com.trs.components.wcm.publish.domain.job 中 BaseJob 的子类
class | PublishJobWorker Title: TRS 内容协作平台（TRS WCM） Description: 计划发布执行者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WithDrawJobWorker Title: TRS 内容协作平台（TRS WCM） Description: 定时撤稿 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.components.wcm.stat 中 BaseJob 的使用

com.trs.components.wcm.stat 中 BaseJob 的子类
 class StatAutoRunWorker
Title: TRS 内容协作平台（TRS WCM）
Description:
自动统计数据到临时表的Worker
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.job 中 BaseJob 的使用

com.trs.infra.util.job 中 BaseJob 的子类
class | BaseStatefulJob Title: TRS 内容协作平台（TRS WCM） Description: 线程安全的Job Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | StatefulJobTest Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.job.BaseStatefulJob 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.job.BaseStatefulJob
的使用

使用 BaseStatefulJob 的软件包
com.trs.cms.process.engine.handlers
com.trs.infra.util.job

com.trs.cms.process.engine.handlers 中 BaseStatefulJob 的使用

com.trs.cms.process.engine.handlers 中 BaseStatefulJob 的子类
 class DoingRuleHandler

com.trs.infra.util.job 中 BaseStatefulJob 的使用

com.trs.infra.util.job 中 BaseStatefulJob 的子类
 class StatefulJobTest
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.job.JobFailedResult 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.job.JobFailedResult
的使用

使用 JobFailedResult 的软件包
com.trs.infra.util.job

com.trs.infra.util.job 中 JobFailedResult 的使用

返回 JobFailedResult 的 com.trs.infra.util.job 中的方法
static JobFailedResult | JobFailedResult.createNewInstance() 产生当前对象[JobFailedResult]的实例
static JobFailedResult | JobFailedResult.findById(int _nId) 提取指定ID的对象
static JobFailedResult | JobFailedResult.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.job.JobFailedResults 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.job.JobFailedResults
的使用

使用 JobFailedResults 的软件包
com.trs.infra.util.job

com.trs.infra.util.job 中 JobFailedResults 的使用

返回 JobFailedResults 的 com.trs.infra.util.job 中的方法
static JobFailedResults | JobFailedResults.createNewInstance() 产生当前集合对象[JobFailedResults]的实例
static JobFailedResults | JobFailedResults.findByIds(java.lang.String _sIds) 提取指定ID序列的对象集合
static JobFailedResults | JobFailedResults.openWCMObjs(WCMFilter _filter) 通过指定一个Filter获取当前集合[JobFailedResults]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.job.JobScheduler 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.job.JobScheduler
的使用

没有 com.trs.infra.util.job.JobScheduler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.job.StatefulJobTest 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.job.StatefulJobTest
的使用

没有 com.trs.infra.util.job.StatefulJobTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CKeyUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.key
类 CKeyUtil

java.lang.Object
    继承者  com.trs.infra.util.key.CKeyUtil

public class CKeyUtil
extends java.lang.Object

Title: 网站内容管理（TRSWCM）

Description:

Copyright: Copyright (c) 2001

Company: www.trs.com.cn

版本：
1.0
作者：
EPROBITI

构造方法摘要
CKeyUtil()
方法摘要
static java.lang.String | DecodeKey(java.lang.String _sCode)
static int | getKeyNum(java.lang.String _sNum)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CKeyUtil

public CKeyUtil()
方法详细信息

getKeyNum

public static int getKeyNum(java.lang.String _sNum)

DecodeKey

public static java.lang.String DecodeKey(java.lang.String _sCode)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CRegister

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.key
类 CRegister

java.lang.Object
    继承者  com.trs.infra.util.key.CRegister

public class CRegister
extends java.lang.Object

构造方法摘要
CRegister()
方法摘要
static void RegisterDemo()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CRegister

public CRegister()
方法详细信息

RegisterDemo

public static void RegisterDemo()
                         throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MacAddressHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.key
类 MacAddressHelper

java.lang.Object
    继承者  com.trs.infra.util.key.MacAddressHelper

public class MacAddressHelper
extends java.lang.Object

字段摘要
static boolean IS_DEBUG
构造方法摘要
MacAddressHelper()
方法摘要
static java.lang.String | getMyMac(int _nIndex)
static long | getMyMacAsLong()
static long | getMyMacAsLong(int _nIndex)
static long | getMyMacAsLong(java.lang.String _sMac)
static boolean | isValidMac(long _lMac)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_DEBUG

public static final boolean IS_DEBUG
另请参见：
常量字段值
构造方法详细信息

MacAddressHelper

public MacAddressHelper()
方法详细信息

isValidMac

public static boolean isValidMac(long _lMac)

getMyMacAsLong

public static long getMyMacAsLong(int _nIndex)

getMyMacAsLong

public static long getMyMacAsLong()

getMyMacAsLong

public static long getMyMacAsLong(java.lang.String _sMac)

getMyMac

public static java.lang.String getMyMac(int _nIndex)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MachineCodeDetector

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.key
类 MachineCodeDetector

java.lang.Object
    继承者  com.trs.infra.util.key.MachineCodeDetector

public class MachineCodeDetector
extends java.lang.Object

构造方法摘要
MachineCodeDetector()
方法摘要
static java.lang.String | identifyHost() 获取机器码.
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MachineCodeDetector

public MachineCodeDetector()
方法详细信息

main

public static void main(java.lang.String[] args)

identifyHost

public static java.lang.String identifyHost()
获取机器码.(jni依赖)

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.key
类
CKeyUtil
CRegister
MacAddressHelper
MachineCodeDetector


com.trs.infra.util.key

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.key

类摘要
CKeyUtil | Title: 网站内容管理（TRSWCM） Description: Copyright: Copyright (c) 2001 Company: www.trs.com.cn
CRegister |
MacAddressHelper |
MachineCodeDetector |


com.trs.infra.util.key 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.key 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.key.CKeyUtil
    • com.trs.infra.util.key.CRegister
    • com.trs.infra.util.key.MacAddressHelper
    • com.trs.infra.util.key.MachineCodeDetector


软件包 com.trs.infra.util.key 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.key
的使用

没有 com.trs.infra.util.key 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.key.CKeyUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.key.CKeyUtil
的使用

没有 com.trs.infra.util.key.CKeyUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.key.CRegister 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.key.CRegister
的使用

没有 com.trs.infra.util.key.CRegister 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.key.MacAddressHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.key.MacAddressHelper
的使用

没有 com.trs.infra.util.key.MacAddressHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.key.MachineCodeDetector 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.key.MachineCodeDetector
的使用

没有 com.trs.infra.util.key.MachineCodeDetector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CMySoapClient

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.soap
类 CMySoapClient

java.lang.Object
    继承者  com.trs.infra.util.soap.CMySoapClient
直接已知子类：
OcrSoapClient
public class CMySoapClient
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
简易Soap请求
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
CMySoapClient()
方法摘要
java.lang.String | getHost()
java.lang.String | getPassWord()
int | getPort()
java.lang.String | getUrn()
java.lang.String | getUserName()
void | setKeepAlive(boolean _bKeepAlive)
void | setServer(java.lang.String _sHost, java.lang.String _sUserName, java.lang.String _sPassword)
void | setUrn(java.lang.String _sUrn)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CMySoapClient

public CMySoapClient()
方法详细信息

setServer

public void setServer(java.lang.String _sHost,
                      java.lang.String _sUserName,
                      java.lang.String _sPassword)

setKeepAlive

public void setKeepAlive(boolean _bKeepAlive)

setUrn

public void setUrn(java.lang.String _sUrn)

getHost

public java.lang.String getHost()

getPort

public int getPort()

getUserName

public java.lang.String getUserName()

getPassWord

public java.lang.String getPassWord()

getUrn

public java.lang.String getUrn()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


OcrSoapClient

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.soap
类 OcrSoapClient

java.lang.Object
    继承者  com.trs.infra.util.soap.CMySoapClient
        继承者  com.trs.infra.util.soap.OcrSoapClient

public class OcrSoapClient
extends CMySoapClient

Title: TRS 内容协作平台（TRS WCM）
Description:
智能创建文档的ConvertOfficeFile远程调用接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
OcrSoapClient()
方法摘要
 java.lang.String ConvertOfficeFile(java.lang.String _sFileName)
从类 com.trs.infra.util.soap.CMySoapClient 继承的方法
getHost, getPassWord, getPort, getUrn, getUserName, setKeepAlive, setServer, setUrn
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OcrSoapClient

public OcrSoapClient()
方法详细信息

ConvertOfficeFile

public java.lang.String ConvertOfficeFile(java.lang.String _sFileName)
                                   throws javax.xml.rpc.ServiceException,
                                          java.rmi.RemoteException
抛出：
javax.xml.rpc.ServiceException
java.rmi.RemoteException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.soap
类
CMySoapClient
OcrSoapClient


com.trs.infra.util.soap

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.soap

类摘要
CMySoapClient | Title: TRS 内容协作平台（TRS WCM） Description: 简易Soap请求 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
OcrSoapClient | Title: TRS 内容协作平台（TRS WCM） Description: 智能创建文档的ConvertOfficeFile远程调用接口实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.util.soap 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.soap 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.soap.CMySoapClient
      • com.trs.infra.util.soap.OcrSoapClient


软件包 com.trs.infra.util.soap 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.soap
的使用

使用 com.trs.infra.util.soap 的软件包
com.trs.infra.util.soap

com.trs.infra.util.soap 使用的 com.trs.infra.util.soap 中的类
CMySoapClient
Title: TRS 内容协作平台（TRS WCM）
Description:
简易Soap请求
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.soap.CMySoapClient 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.soap.CMySoapClient
的使用

使用 CMySoapClient 的软件包
com.trs.infra.util.soap

com.trs.infra.util.soap 中 CMySoapClient 的使用

com.trs.infra.util.soap 中 CMySoapClient 的子类
 class OcrSoapClient
Title: TRS 内容协作平台（TRS WCM）
Description:
智能创建文档的ConvertOfficeFile远程调用接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.soap.OcrSoapClient 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.soap.OcrSoapClient
的使用

没有 com.trs.infra.util.soap.OcrSoapClient 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


FtpConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.uftp
类 FtpConfig

java.lang.Object
    继承者  com.trs.infra.util.uftp.FtpConfig

public class FtpConfig
extends java.lang.Object

集中存放FTP相关的配置信息

作者：
Martin (付成睿)

构造方法摘要
FtpConfig()
缺省构造方法
方法摘要
boolean | getAnonymous() 返回在FTP登录中是否使用匿名方式
java.lang.String | getHost() 返回FTP服务器的主机名或者IP地址
int | getMaxClient() 返回所允许的最大客户端连接数
long | getMaxIdleMills()
boolean | getPassive() 返回是否使用Passve模式
java.lang.String | getPassWord() 返回登陆FTP服务器的用户口令
int | getPort() 返回FTP服务器的端口号
java.lang.String | getProtocol() 返回协议名称，恒定返回“ftp”
java.lang.String | getRootPath() 返回远端文件所在的路径，或者零长度的字符串。
java.lang.String | getUserName() 返回登陆FTP服务器的用户名
void | setAnonymous(boolean zAnonymous) 设置在FTP登录中是否使用匿名方式
void | setHost(java.lang.String host) 设置FTP服务器的主机名或者IP地址
void | setMaxClient(int maxClient) 设置所允许的最大客户端连接数
void | setMaxIdleTime(int maxTime) 设置连接有效的最大空闲时间
void | setPassive(boolean passive) 设置是否使用Passve模式
void | setPassWord(java.lang.String passWord) 设置登陆FTP服务器的用户口令
void | setPort(int port) 设置FTP服务器的端口号
void | setProtocol(java.lang.String protocol) 设置协议名称，在目前实现中为空方法，什么都不做。
void | setRootPath(java.lang.String path) 设置远端文件所在的路径
void | setUserName(java.lang.String userName) 设置登陆FTP服务器的用户名
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FtpConfig

public FtpConfig()
缺省构造方法

方法详细信息

getProtocol

public java.lang.String getProtocol()
返回协议名称，恒定返回“ftp”

返回：
协议名称，恒定为“ftp”

setProtocol

public void setProtocol(java.lang.String protocol)
设置协议名称，在目前实现中为空方法，什么都不做。

参数：
protocol - 协议名称

getAnonymous

public boolean getAnonymous()
返回在FTP登录中是否使用匿名方式

返回：
如果使用匿名登录，则返回true，否则返回false。

setAnonymous

public void setAnonymous(boolean zAnonymous)
设置在FTP登录中是否使用匿名方式

参数：
zAnonymous - true则使用匿名登录，false则不使用。

getUserName

public java.lang.String getUserName()
返回登陆FTP服务器的用户名

返回：
登陆FTP服务器的用户名

setUserName

public void setUserName(java.lang.String userName)
设置登陆FTP服务器的用户名

参数：
userName - 登陆FTP服务器的用户名

getPassWord

public java.lang.String getPassWord()
返回登陆FTP服务器的用户口令

返回：
登陆FTP服务器的用户口令

setPassWord

public void setPassWord(java.lang.String passWord)
设置登陆FTP服务器的用户口令

参数：
passWord - 登陆FTP服务器的用户口令

getHost

public java.lang.String getHost()
返回FTP服务器的主机名或者IP地址

返回：
FTP服务器的主机名或者IP地址

setHost

public void setHost(java.lang.String host)
设置FTP服务器的主机名或者IP地址

参数：
host - FTP服务器的主机名或者IP地址

getPort

public int getPort()
返回FTP服务器的端口号

返回：
FTP服务器的端口号

setPort

public void setPort(int port)
设置FTP服务器的端口号

参数：
port - FTP服务器的端口号，小于等于0的值将被忽略

getRootPath

public java.lang.String getRootPath()
返回远端文件所在的路径，或者零长度的字符串。

返回：
远端文件所在的路径，或者零长度的字符串。

setRootPath

public void setRootPath(java.lang.String path)
设置远端文件所在的路径

参数：
path - 远端文件所在的路径

getPassive

public boolean getPassive()
返回是否使用Passve模式

返回：
是否使用Passve模式

setPassive

public void setPassive(boolean passive)
设置是否使用Passve模式

参数：
passive - 是否使用Passve模式

getMaxClient

public int getMaxClient()
返回所允许的最大客户端连接数

返回：
所允许的最大客户端连接数

setMaxClient

public void setMaxClient(int maxClient)
设置所允许的最大客户端连接数

参数：
maxClient - 所允许的最大客户端连接数

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

setMaxIdleTime

public void setMaxIdleTime(int maxTime)
设置连接有效的最大空闲时间

参数：
maxTime - 最大空闲时间,以秒为单位设置.

getMaxIdleMills

public long getMaxIdleMills()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FtpConnection

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.uftp
类 FtpConnection

java.lang.Object
    继承者  com.trs.infra.util.uftp.FtpConnection
直接已知子类：
FtpConnectionImpFtp, FtpConnectionImpSSH
public abstract class FtpConnection
extends java.lang.Object

抽象类，所有FTP和FTP类似协议实现的封装接口。

作者：
Martin (付成睿)

构造方法摘要
FtpConnection()
缺省构造方法
方法摘要
boolean | cutFromList() 从链表中删除该节点
abstract boolean | deleteDirectory(java.lang.String sPath) 删除远程服务器上的目录
abstract boolean | deleteFile(java.lang.String sPath) 删除远程服务器上的文件
FtpConfig | getFtpConfig() 返回当前连接的配置信息
java.lang.String | getHomePath() 返回登陆远程服务器后的初始目录
long | getIdleimestamp() 获取空闲时间戳
long | getIdleTimemills() 获取连接的空闲时间(ms)
abstract boolean | hasTheFile(java.lang.String sPath) 判断远程服务器上是否存在指定的文件
abstract boolean | isReadOnly() 判断当前连接是不是只读的，即是否可以上传文件
abstract void | onIdle() 在连接处于空闲状态时，会定时的访问服务器，以防止服务器端超时。
abstract boolean | renameFile(java.lang.String sSourcePath, java.lang.String sTargetFile) 重命名远程服务器上的文件
void | setIdleTimestamp() 设置空闲时间戳
abstract java.lang.String | toAbsolutePath(java.lang.String sRelativePath) 把指定的相对路径转换为绝对路径，
abstract boolean | uploadFile(java.lang.String sLocal, java.lang.String sRemote) 上传文件到远程服务器
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FtpConnection

public FtpConnection()
缺省构造方法

方法详细信息

getHomePath

public java.lang.String getHomePath()
返回登陆远程服务器后的初始目录

返回：
登陆远程服务器后的初始目录

getFtpConfig

public FtpConfig getFtpConfig()
返回当前连接的配置信息

返回：
当前连接的配置信息

onIdle

public abstract void onIdle()
                     throws java.lang.Exception
在连接处于空闲状态时，会定时的访问服务器，以防止服务器端超时。

抛出：
java.lang.Exception - 如果发生IO异常

isReadOnly

public abstract boolean isReadOnly()
                            throws java.lang.Exception
判断当前连接是不是只读的，即是否可以上传文件

返回：
当前连接是否只读
抛出：
java.lang.Exception - 如果发生IO异常

toAbsolutePath

public abstract java.lang.String toAbsolutePath(java.lang.String sRelativePath)
                                         throws java.lang.Exception
把指定的相对路径转换为绝对路径，

参数：
sRelativePath - 相对路径，相对于当前路径，但是一般指相对登录用户的根目录
返回：
绝对路径
抛出：
java.lang.Exception - 如果发生IO异常

uploadFile

public abstract boolean uploadFile(java.lang.String sLocal,
                                   java.lang.String sRemote)
                            throws java.lang.Exception
上传文件到远程服务器

参数：
sLocal - 本地文件名
sRemote - 远程文件名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

hasTheFile

public abstract boolean hasTheFile(java.lang.String sPath)
                            throws java.lang.Exception
判断远程服务器上是否存在指定的文件

参数：
sPath - 远程文件名
返回：
如果存在返回true，否则返回false
抛出：
java.lang.Exception - 如果发生IO异常

deleteFile

public abstract boolean deleteFile(java.lang.String sPath)
                            throws java.lang.Exception
删除远程服务器上的文件

参数：
sPath - 待删除文件的文件名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

deleteDirectory

public abstract boolean deleteDirectory(java.lang.String sPath)
                                 throws java.lang.Exception
删除远程服务器上的目录

参数：
sPath - 待删除目录的目录名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

renameFile

public abstract boolean renameFile(java.lang.String sSourcePath,
                                   java.lang.String sTargetFile)
                            throws java.lang.Exception
重命名远程服务器上的文件

参数：
sSourcePath - 原文件名，使用全限定文件名，包括完整的路径
sTargetFile - 目标文件名，只能是文件名，不能包含路径
返回：
如果存在返回true，否则返回false
抛出：
java.lang.Exception - 如果发生IO异常

setIdleTimestamp

public void setIdleTimestamp()
设置空闲时间戳

getIdleimestamp

public long getIdleimestamp()
获取空闲时间戳

返回：

getIdleTimemills

public long getIdleTimemills()
获取连接的空闲时间(ms)

返回：
与当前时间间的毫秒数

cutFromList

public boolean cutFromList()
从链表中删除该节点

返回：
是否成功删除
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FtpConnectionCache

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.uftp
类 FtpConnectionCache

java.lang.Object
    继承者  com.trs.infra.util.uftp.FtpConnectionCache
所有已实现的接口：
org.aton.container.IClearable
public class FtpConnectionCache
extends java.lang.Object
implements org.aton.container.IClearable

FTP客户端连接的缓冲池，除了维护连接以外，还会后台的线程定期地检查连接的有效性

作者：
Martin (付成睿)

构造方法摘要
FtpConnectionCache(FtpConfig config)
缺省构造方法
方法摘要
void | clear()
int | getBusyCount()
FtpConnection | getConnectionWrapper() 返回FTP连接的封装，使用该封装，不需要考虑向缓冲池还回的问题
FtpConfig | getFtpConfig() 返回FTP连接的配置信息
int | getIdleCount()
int | getLimitCount()
int | getTotalCount()
void | initialize() 执行初始化操作
java.lang.String | toString()
static boolean | verifyConfig(FtpConfig ftpConfig, java.lang.String[] forReturn) 测试指定的FTP配置是否可用，测试的项目包括：连接、登录、建立临时目录、建立数据通道四项。
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FtpConnectionCache

public FtpConnectionCache(FtpConfig config)
缺省构造方法

方法详细信息

verifyConfig

public static final boolean verifyConfig(FtpConfig ftpConfig,
                                         java.lang.String[] forReturn)
测试指定的FTP配置是否可用，测试的项目包括：连接、登录、建立临时目录、建立数据通道四项。 如果测试成功，则返回true ，失败则返回false， 并设置失败的原因于传入的字符串数组的第一个元素。因此，如果该数组为空， 或者长度为零的话，会抛出异常 IllegalArgumentException。如果在测试的最后， 删除临时目录的时候出错，则不会认为测试失败。

参数：
ftpConfig - 待测试的FTP配置
forReturn - 用于返回错误信息，如果出错的话
返回：
指定的FTP配置是否可用
抛出：
java.lang.IllegalArgumentException - 如果输入的参数无效，为空或者数组的长度为零

getFtpConfig

public FtpConfig getFtpConfig()
返回FTP连接的配置信息

返回：
FTP连接的配置信息

initialize

public void initialize()
执行初始化操作

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear

getConnectionWrapper

public FtpConnection getConnectionWrapper()
返回FTP连接的封装，使用该封装，不需要考虑向缓冲池还回的问题

返回：

getBusyCount

public int getBusyCount()
返回：

getIdleCount

public int getIdleCount()
返回：

getLimitCount

public int getLimitCount()
返回：

getTotalCount

public int getTotalCount()
返回：

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FtpConnectionImpFtp

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.uftp
类 FtpConnectionImpFtp

java.lang.Object
    继承者  com.trs.infra.util.uftp.FtpConnection
        继承者  com.trs.infra.util.uftp.FtpConnectionImpFtp

public class FtpConnectionImpFtp
extends FtpConnection

使用普通的FTP协议实现 FtpConnection 抽象类， 其中FTP协议部分的实现采用TRS公司的实现。

作者：
Martin (付成睿)

构造方法摘要
FtpConnectionImpFtp()
缺省构造方法
方法摘要
boolean | cutFromList() 从链表中删除该节点
boolean | deleteDirectory(java.lang.String sPath) 删除远程服务器上的目录
boolean | deleteFile(java.lang.String sPath) 删除远程服务器上的文件
boolean | hasTheFile(java.lang.String sPath) 判断远程服务器上是否存在指定的文件
boolean | isReadOnly() 判断当前连接是不是只读的，即是否可以上传文件
static void | main(java.lang.String[] args) 仅供内部测试使用
void | onIdle() 在连接处于空闲状态时，会定时的访问服务器，以防止服务器端超时。
boolean | renameFile(java.lang.String sSourcePath, java.lang.String sTargetFile) 重命名远程服务器上的文件
java.lang.String | toAbsolutePath(java.lang.String sPath) 把指定的相对路径转换为绝对路径，
boolean | uploadFile(java.lang.String sLocal, java.lang.String sRemote) 上传文件到远程服务器
从类 com.trs.infra.util.uftp.FtpConnection 继承的方法
getFtpConfig, getHomePath, getIdleimestamp, getIdleTimemills, setIdleTimestamp
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FtpConnectionImpFtp

public FtpConnectionImpFtp()
缺省构造方法

方法详细信息

onIdle

public void onIdle()
            throws java.lang.Exception
从类 FtpConnection 复制的描述
在连接处于空闲状态时，会定时的访问服务器，以防止服务器端超时。

指定者：
类 FtpConnection 中的 onIdle
抛出：
java.lang.Exception - 如果发生IO异常

isReadOnly

public boolean isReadOnly()
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
判断当前连接是不是只读的，即是否可以上传文件

指定者：
类 FtpConnection 中的 isReadOnly
返回：
当前连接是否只读
抛出：
java.lang.Exception - 如果发生IO异常

toAbsolutePath

public java.lang.String toAbsolutePath(java.lang.String sPath)
                                throws java.lang.Exception
从类 FtpConnection 复制的描述
把指定的相对路径转换为绝对路径，

指定者：
类 FtpConnection 中的 toAbsolutePath
参数：
sPath - 相对路径，相对于当前路径，但是一般指相对登录用户的根目录
返回：
绝对路径
抛出：
java.lang.Exception - 如果发生IO异常

uploadFile

public boolean uploadFile(java.lang.String sLocal,
                          java.lang.String sRemote)
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
上传文件到远程服务器

指定者：
类 FtpConnection 中的 uploadFile
参数：
sLocal - 本地文件名
sRemote - 远程文件名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

hasTheFile

public boolean hasTheFile(java.lang.String sPath)
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
判断远程服务器上是否存在指定的文件

指定者：
类 FtpConnection 中的 hasTheFile
参数：
sPath - 远程文件名
返回：
如果存在返回true，否则返回false
抛出：
java.lang.Exception - 如果发生IO异常

deleteFile

public boolean deleteFile(java.lang.String sPath)
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
删除远程服务器上的文件

指定者：
类 FtpConnection 中的 deleteFile
参数：
sPath - 待删除文件的文件名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

deleteDirectory

public boolean deleteDirectory(java.lang.String sPath)
                        throws java.lang.Exception
从类 FtpConnection 复制的描述
删除远程服务器上的目录

指定者：
类 FtpConnection 中的 deleteDirectory
参数：
sPath - 待删除目录的目录名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

renameFile

public boolean renameFile(java.lang.String sSourcePath,
                          java.lang.String sTargetFile)
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
重命名远程服务器上的文件

指定者：
类 FtpConnection 中的 renameFile
参数：
sSourcePath - 原文件名，使用全限定文件名，包括完整的路径
sTargetFile - 目标文件名，只能是文件名，不能包含路径
返回：
如果存在返回true，否则返回false
抛出：
java.lang.Exception - 如果发生IO异常

main

public static void main(java.lang.String[] args)
仅供内部测试使用

cutFromList

public boolean cutFromList()
从链表中删除该节点

返回：
是否成功删除
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FtpConnectionImpSSH

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.uftp
类 FtpConnectionImpSSH

java.lang.Object
    继承者  com.trs.infra.util.uftp.FtpConnection
        继承者  com.trs.infra.util.uftp.FtpConnectionImpSSH

public class FtpConnectionImpSSH
extends FtpConnection

使用SSH的SFTP协议实现FtpConnection抽象类， 其中SFTP协议部分的实现采用www.jcraft.com的实现。

作者：
Martin (付成睿)

构造方法摘要
FtpConnectionImpSSH()
缺省构造方法
方法摘要
boolean | cutFromList() 从链表中删除该节点
boolean | deleteDirectory(java.lang.String sPath) 删除远程服务器上的目录
boolean | deleteFile(java.lang.String sPath) 删除远程服务器上的文件
boolean | hasTheFile(java.lang.String sPath) 判断远程服务器上是否存在指定的文件
boolean | isReadOnly() 判断当前连接是不是只读的，即是否可以上传文件
static void | main(java.lang.String[] args) 仅供内部测试使用
void | onIdle() 在连接处于空闲状态时，会定时的访问服务器，以防止服务器端超时。
boolean | renameFile(java.lang.String sSourcePath, java.lang.String sTargetFile) 重命名远程服务器上的文件
java.lang.String | toAbsolutePath(java.lang.String sRelativePath) 把指定的相对路径转换为绝对路径，
boolean | uploadFile(java.lang.String sLocal, java.lang.String sRemote) 上传文件到远程服务器
从类 com.trs.infra.util.uftp.FtpConnection 继承的方法
getFtpConfig, getHomePath, getIdleimestamp, getIdleTimemills, setIdleTimestamp
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FtpConnectionImpSSH

public FtpConnectionImpSSH()
缺省构造方法

方法详细信息

onIdle

public void onIdle()
            throws java.lang.Exception
从类 FtpConnection 复制的描述
在连接处于空闲状态时，会定时的访问服务器，以防止服务器端超时。

指定者：
类 FtpConnection 中的 onIdle
抛出：
java.lang.Exception - 如果发生IO异常

isReadOnly

public boolean isReadOnly()
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
判断当前连接是不是只读的，即是否可以上传文件

指定者：
类 FtpConnection 中的 isReadOnly
返回：
当前连接是否只读
抛出：
java.lang.Exception - 如果发生IO异常

toAbsolutePath

public java.lang.String toAbsolutePath(java.lang.String sRelativePath)
                                throws java.lang.Exception
从类 FtpConnection 复制的描述
把指定的相对路径转换为绝对路径，

指定者：
类 FtpConnection 中的 toAbsolutePath
参数：
sRelativePath - 相对路径，相对于当前路径，但是一般指相对登录用户的根目录
返回：
绝对路径
抛出：
java.lang.Exception - 如果发生IO异常

uploadFile

public boolean uploadFile(java.lang.String sLocal,
                          java.lang.String sRemote)
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
上传文件到远程服务器

指定者：
类 FtpConnection 中的 uploadFile
参数：
sLocal - 本地文件名
sRemote - 远程文件名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

hasTheFile

public boolean hasTheFile(java.lang.String sPath)
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
判断远程服务器上是否存在指定的文件

指定者：
类 FtpConnection 中的 hasTheFile
参数：
sPath - 远程文件名
返回：
如果存在返回true，否则返回false
抛出：
java.lang.Exception - 如果发生IO异常

deleteFile

public boolean deleteFile(java.lang.String sPath)
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
删除远程服务器上的文件

指定者：
类 FtpConnection 中的 deleteFile
参数：
sPath - 待删除文件的文件名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

deleteDirectory

public boolean deleteDirectory(java.lang.String sPath)
                        throws java.lang.Exception
从类 FtpConnection 复制的描述
删除远程服务器上的目录

指定者：
类 FtpConnection 中的 deleteDirectory
参数：
sPath - 待删除目录的目录名
返回：
如果成功返回true
抛出：
java.lang.Exception - 如果发生IO异常

renameFile

public boolean renameFile(java.lang.String sSourcePath,
                          java.lang.String sTargetFile)
                   throws java.lang.Exception
从类 FtpConnection 复制的描述
重命名远程服务器上的文件

指定者：
类 FtpConnection 中的 renameFile
参数：
sSourcePath - 原文件名，使用全限定文件名，包括完整的路径
sTargetFile - 目标文件名，只能是文件名，不能包含路径
返回：
如果存在返回true，否则返回false
抛出：
java.lang.Exception - 如果发生IO异常

main

public static void main(java.lang.String[] args)
仅供内部测试使用

cutFromList

public boolean cutFromList()
从链表中删除该节点

返回：
是否成功删除
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.uftp
类
FtpConfig
FtpConnection
FtpConnectionCache
FtpConnectionImpFtp
FtpConnectionImpSSH


com.trs.infra.util.uftp

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.uftp

提供一个使用FTP、及FTP类似协议进行远程发布的统一接口.

请参见：
描述

类摘要
FtpConfig | 集中存放FTP相关的配置信息
FtpConnection | 抽象类，所有FTP和FTP类似协议实现的封装接口。
FtpConnectionCache | FTP客户端连接的缓冲池，除了维护连接以外，还会后台的线程定期地检查连接的有效性
FtpConnectionImpFtp | 使用普通的FTP协议实现 FtpConnection 抽象类， 其中FTP协议部分的实现采用TRS公司的实现。
FtpConnectionImpSSH | 使用SSH的SFTP协议实现FtpConnection抽象类， 其中SFTP协议部分的实现采用www.jcraft.com的实现。

软件包 com.trs.infra.util.uftp 的描述

提供一个使用FTP、及FTP类似协议进行远程发布的统一接口. FTP类似协议包括FTPS、SFTP和GFTP等。虽然这些协议的复杂程度各不相同， 但是在发布系统当中会使用到的功能相对单一，主要是上传文件和删除文件等。 所以为这一类的协议设计了一个统一的接口提供给上层的发布系统使用。这里， 包名uftp意味着Universal FTP，即统一的FTP。


com.trs.infra.util.uftp 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.uftp 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.uftp.FtpConfig
    • com.trs.infra.util.uftp.FtpConnection
      • com.trs.infra.util.uftp.FtpConnectionImpFtp
      • com.trs.infra.util.uftp.FtpConnectionImpSSH
    • com.trs.infra.util.uftp.FtpConnectionCache (implements org.aton.container.IClearable)


软件包 com.trs.infra.util.uftp 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.uftp
的使用

使用 com.trs.infra.util.uftp 的软件包
com.trs.components.common.publish.domain.distribute |
com.trs.infra.util.uftp | 提供一个使用FTP、及FTP类似协议进行远程发布的统一接口.

com.trs.components.common.publish.domain.distribute 使用的 com.trs.infra.util.uftp 中的类
FtpConnectionCache
FTP客户端连接的缓冲池，除了维护连接以外，还会后台的线程定期地检查连接的有效性

com.trs.infra.util.uftp 使用的 com.trs.infra.util.uftp 中的类
FtpConfig
集中存放FTP相关的配置信息
FtpConnection
抽象类，所有FTP和FTP类似协议实现的封装接口。

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.uftp.FtpConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.uftp.FtpConfig
的使用

使用 FtpConfig 的软件包
com.trs.infra.util.uftp 提供一个使用FTP、及FTP类似协议进行远程发布的统一接口.

com.trs.infra.util.uftp 中 FtpConfig 的使用

返回 FtpConfig 的 com.trs.infra.util.uftp 中的方法
FtpConfig | FtpConnectionCache.getFtpConfig() 返回FTP连接的配置信息
FtpConfig | FtpConnection.getFtpConfig() 返回当前连接的配置信息

参数类型为 FtpConfig 的 com.trs.infra.util.uftp 中的方法
static boolean FtpConnectionCache.verifyConfig(FtpConfig ftpConfig, java.lang.String[] forReturn)
测试指定的FTP配置是否可用，测试的项目包括：连接、登录、建立临时目录、建立数据通道四项。

参数类型为 FtpConfig 的 com.trs.infra.util.uftp 中的构造方法
FtpConnectionCache(FtpConfig config)
缺省构造方法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.uftp.FtpConnection 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.uftp.FtpConnection
的使用

使用 FtpConnection 的软件包
com.trs.infra.util.uftp 提供一个使用FTP、及FTP类似协议进行远程发布的统一接口.

com.trs.infra.util.uftp 中 FtpConnection 的使用

com.trs.infra.util.uftp 中 FtpConnection 的子类
class | FtpConnectionImpFtp 使用普通的FTP协议实现 FtpConnection 抽象类， 其中FTP协议部分的实现采用TRS公司的实现。
class | FtpConnectionImpSSH 使用SSH的SFTP协议实现FtpConnection抽象类， 其中SFTP协议部分的实现采用www.jcraft.com的实现。

返回 FtpConnection 的 com.trs.infra.util.uftp 中的方法
 FtpConnection FtpConnectionCache.getConnectionWrapper()
返回FTP连接的封装，使用该封装，不需要考虑向缓冲池还回的问题

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.uftp.FtpConnectionCache 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.uftp.FtpConnectionCache
的使用

使用 FtpConnectionCache 的软件包
com.trs.components.common.publish.domain.distribute

com.trs.components.common.publish.domain.distribute 中 FtpConnectionCache 的使用

返回 FtpConnectionCache 的 com.trs.components.common.publish.domain.distribute 中的方法
 FtpConnectionCache UftpConnectionCacheManager.getConnectionCache(PublishDistribution dist)
返回和指定的PublishDistribution相关的FTP连接缓存管理器

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.uftp.FtpConnectionImpFtp 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.uftp.FtpConnectionImpFtp
的使用

没有 com.trs.infra.util.uftp.FtpConnectionImpFtp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.uftp.FtpConnectionImpSSH 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.uftp.FtpConnectionImpSSH
的使用

没有 com.trs.infra.util.uftp.FtpConnectionImpSSH 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Constants

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade
类 Constants

java.lang.Object
    继承者  com.trs.infra.util.upgrade.Constants

public class Constants
extends java.lang.Object

字段摘要
static java.lang.String | SQL_ESCAPE
static java.lang.String | SQL_SEPCHAR
构造方法摘要
Constants()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SQL_ESCAPE

public static final java.lang.String SQL_ESCAPE
另请参见：
常量字段值

SQL_SEPCHAR

public static java.lang.String SQL_SEPCHAR
构造方法详细信息

Constants

public Constants()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DbConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade
类 DbConfig

java.lang.Object
    继承者  com.trs.infra.util.upgrade.DbConfig

public class DbConfig
extends java.lang.Object

数据库配置信息对象

作者：
wenyh

构造方法摘要
DbConfig()
方法摘要
java.lang.String | getBakTable4WcmRight()
java.lang.String | getDbtype()
java.lang.String | getJdbcDriver()
java.lang.String | getNewPasswd() 获取新的数据库用户密码
java.lang.String | getNewSchema()
java.lang.String | getNewUrl() 获取新的数据库连接URL
java.lang.String | getNewUser() 获取新的数据库用户
java.lang.String | getOldPasswd() 获取旧的数据库用户密码
java.lang.String | getOldSchema()
java.lang.String | getOldUrl() 获取旧的数据库连接URL
java.lang.String | getOldUser() 获取旧的数据库用户
void | load(java.io.InputStream ins) 从指定输入流中读取配置
void | load(java.lang.String fn) 从指定文件中读取配置
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DbConfig

public DbConfig()
方法详细信息

load

public void load(java.lang.String fn)
从指定文件中读取配置

参数：
fn -

load

public void load(java.io.InputStream ins)
从指定输入流中读取配置

参数：
ins -

getDbtype

public java.lang.String getDbtype()
返回：
the dbtype

getJdbcDriver

public java.lang.String getJdbcDriver()
返回：
the jdbcDriver

getOldUser

public java.lang.String getOldUser()
获取旧的数据库用户

返回：
the oldUser

getOldPasswd

public java.lang.String getOldPasswd()
获取旧的数据库用户密码

返回：
the oldPasswd

getOldUrl

public java.lang.String getOldUrl()
获取旧的数据库连接URL

返回：
the oldUrl

getNewUser

public java.lang.String getNewUser()
获取新的数据库用户

返回：
the newUser

getNewPasswd

public java.lang.String getNewPasswd()
获取新的数据库用户密码

返回：
the newPasswd

getNewUrl

public java.lang.String getNewUrl()
获取新的数据库连接URL

返回：
the newUrl

getOldSchema

public java.lang.String getOldSchema()

getNewSchema

public java.lang.String getNewSchema()

getBakTable4WcmRight

public java.lang.String getBakTable4WcmRight()
返回：
the bakTable4WcmRight
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Main

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade
类 Main

java.lang.Object
    继承者  com.trs.infra.util.upgrade.Main

public class Main
extends java.lang.Object

构造方法摘要
Main()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Main

public Main()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.upgrade
类
Constants
DbConfig
Main
WcmIdFieldInit


com.trs.infra.util.upgrade

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.upgrade

类摘要
Constants |
DbConfig | 数据库配置信息对象
Main |
WcmIdFieldInit | WCMID.IDFIELDNAME


com.trs.infra.util.upgrade 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.upgrade 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.upgrade.Constants
    • com.trs.infra.util.upgrade.DbConfig
    • com.trs.infra.util.upgrade.Main
    • com.trs.infra.util.upgrade.WcmIdFieldInit


软件包 com.trs.infra.util.upgrade 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.upgrade
的使用

没有 com.trs.infra.util.upgrade 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WcmIdFieldInit

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade
类 WcmIdFieldInit

java.lang.Object
    继承者  com.trs.infra.util.upgrade.WcmIdFieldInit

public class WcmIdFieldInit
extends java.lang.Object

WCMID.IDFIELDNAME

作者：
wenyh

构造方法摘要
WcmIdFieldInit()
方法摘要
void | doAction(java.sql.Connection conn)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WcmIdFieldInit

public WcmIdFieldInit()
方法详细信息

doAction

public void doAction(java.sql.Connection conn)
              throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.util.upgrade.Constants 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.Constants
的使用

没有 com.trs.infra.util.upgrade.Constants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.DbConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.DbConfig
的使用

没有 com.trs.infra.util.upgrade.DbConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.Main 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.Main
的使用

没有 com.trs.infra.util.upgrade.Main 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.WcmIdFieldInit 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.WcmIdFieldInit
的使用

没有 com.trs.infra.util.upgrade.WcmIdFieldInit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DocRightSetRightIndex

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dataprocess
类 DocRightSetRightIndex

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex

public class DocRightSetRightIndex
extends java.lang.Object

设置文档权限的权限值变化

原有值为54,更改为61.原值用作问券调查的管理权限.

注意:需要手工执行一下WCMRIGHT表的备份,更新从备份表获取数据

作者：
wenyh

构造方法摘要
DocRightSetRightIndex(java.lang.String dbconf)
方法摘要
void | doAction()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocRightSetRightIndex

public DocRightSetRightIndex(java.lang.String dbconf)
方法详细信息

doAction

public void doAction()
              throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


OrderGroupAndRole

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dataprocess
类 OrderGroupAndRole

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole

public class OrderGroupAndRole
extends java.lang.Object

用户组/角色的排序

作者：
wenyh

构造方法摘要
OrderGroupAndRole(java.lang.String dbconf)
方法摘要
void | doAction()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OrderGroupAndRole

public OrderGroupAndRole(java.lang.String dbconf)
方法详细信息

doAction

public void doAction()
              throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.upgrade.dataprocess
类
DocRightSetRightIndex
OrderGroupAndRole
PhotoLibConfig
ScheduleOper
WcmIdFieldInit


com.trs.infra.util.upgrade.dataprocess

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.upgrade.dataprocess

类摘要
DocRightSetRightIndex | 设置文档权限的权限值变化 原有值为54,更改为61.原值用作问券调查的管理权限.
OrderGroupAndRole | 用户组/角色的排序
PhotoLibConfig | 处理图片库配置(将一些配置添加到wcmconfig表
ScheduleOper | 新添加的计划任务
WcmIdFieldInit | 处理wcmid表的IDFIELDNAME


com.trs.infra.util.upgrade.dataprocess 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.upgrade.dataprocess 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex
    • com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole
    • com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig
    • com.trs.infra.util.upgrade.dataprocess.ScheduleOper
    • com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit


软件包 com.trs.infra.util.upgrade.dataprocess 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.upgrade.dataprocess
的使用

没有 com.trs.infra.util.upgrade.dataprocess 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PhotoLibConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dataprocess
类 PhotoLibConfig

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig

public class PhotoLibConfig
extends java.lang.Object

处理图片库配置(将一些配置添加到wcmconfig表

作者：
wenyh

构造方法摘要
PhotoLibConfig(java.lang.String dbconf, java.lang.String srcconf)
构造函数
方法摘要
void | doAction() 处理相应数据
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PhotoLibConfig

public PhotoLibConfig(java.lang.String dbconf,
                      java.lang.String srcconf)
构造函数

参数：
dbconf - 数据库配置文件
srcconf - TRSWCMPhoto.properties完整路径
如/home/trs/TRSWCMV6/Tomcat/webapps/wcm /WEB-INF/classes/TRSWCMPhoto.properties
方法详细信息

doAction

public void doAction()
              throws java.lang.Exception
处理相应数据

抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScheduleOper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dataprocess
类 ScheduleOper

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dataprocess.ScheduleOper

public class ScheduleOper
extends java.lang.Object

新添加的计划任务

作者：
wenyh

构造方法摘要
ScheduleOper(java.lang.String dbconf)
构造函数
方法摘要
void | doAction() 处理相应数据
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScheduleOper

public ScheduleOper(java.lang.String dbconf)
构造函数

参数：
dbconf - 数据库配置文件
方法详细信息

doAction

public void doAction()
              throws java.lang.Exception
处理相应数据

抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WcmIdFieldInit

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dataprocess
类 WcmIdFieldInit

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit

public class WcmIdFieldInit
extends java.lang.Object

处理wcmid表的IDFIELDNAME

作者：
wenyh

构造方法摘要
WcmIdFieldInit(java.lang.String dbconf)
方法摘要
void | doAction()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WcmIdFieldInit

public WcmIdFieldInit(java.lang.String dbconf)
方法详细信息

doAction

public void doAction()
              throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex
的使用

没有 com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole
的使用

没有 com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig
的使用

没有 com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dataprocess.ScheduleOper 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dataprocess.ScheduleOper
的使用

没有 com.trs.infra.util.upgrade.dataprocess.ScheduleOper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit
的使用

没有 com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Column

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dbcompare
类 Column

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dbcompare.Column

public class Column
extends java.lang.Object

数据库表列描述对象

作者：
WenYehui

字段摘要
java.lang.String | defaultValue 列默认值
int | length 列的长度
java.lang.String | name 列名
boolean | nullAble 列是否允许空值
int | order 列序号
int | scale 列的精度
int | type 列类型值:java.sql.Types
java.lang.String | typeName 列类型名
boolean | useNull
构造方法摘要
Column(java.lang.String name, int type, java.lang.String typeName)
构造函数
方法摘要
boolean | equals(java.lang.Object another)
int | hashCode()
java.lang.String | toString()
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

字段详细信息

name

public java.lang.String name
列名

type

public int type
列类型值:java.sql.Types

typeName

public java.lang.String typeName
列类型名

nullAble

public boolean nullAble
列是否允许空值

defaultValue

public java.lang.String defaultValue
列默认值

length

public int length
列的长度

scale

public int scale
列的精度

order

public int order
列序号

useNull

public boolean useNull
构造方法详细信息

Column

public Column(java.lang.String name,
              int type,
              java.lang.String typeName)
构造函数

参数：
name - 列名
type - 列类型值
typeName - 列类型名
方法详细信息

hashCode

public int hashCode()
覆盖：
类 java.lang.Object 中的 hashCode

equals

public boolean equals(java.lang.Object another)
覆盖：
类 java.lang.Object 中的 equals

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


JdbcTypeMap

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dbcompare
类 JdbcTypeMap

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dbcompare.JdbcTypeMap

public class JdbcTypeMap
extends java.lang.Object

java.sql.Types的映射.通过反射从值反向获取值.

作者：
wenyh

构造方法摘要
JdbcTypeMap()
方法摘要
static java.lang.String get(int jdbcType)
根据jdbcType获取得到jdbcTypeName.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JdbcTypeMap

public JdbcTypeMap()
方法详细信息

get

public static java.lang.String get(int jdbcType)
根据jdbcType获取得到jdbcTypeName.

参数：
jdbcType -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaDataLoader

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dbcompare
类 MetaDataLoader

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dbcompare.MetaDataLoader

public class MetaDataLoader
extends java.lang.Object

数据库表描述对象

作者：
WenYehui

构造方法摘要
MetaDataLoader(java.sql.Connection conn, java.lang.String schema)
构造函数
方法摘要
java.util.List | getIndexes() 获取索引
java.util.Map | getTables() 获取所有表对象
void | load() 从连接中获取所有meta信息
void | setIndexes(java.util.List indexes) 设置索引
void | setTables(java.util.Map tables) 设置表对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetaDataLoader

public MetaDataLoader(java.sql.Connection conn,
                      java.lang.String schema)
构造函数

参数：
conn - 数据库连接
schema - 数据库schema,可以为null.Oracle数据库通常是用户名大写
方法详细信息

getTables

public java.util.Map getTables()
获取所有表对象

返回：

setTables

public void setTables(java.util.Map tables)
设置表对象

参数：
tables -

getIndexes

public java.util.List getIndexes()
获取索引

返回：

setIndexes

public void setIndexes(java.util.List indexes)
设置索引

参数：
indexes -

load

public void load()
          throws java.sql.SQLException
从连接中获取所有meta信息

参数：
conn -
schema -
抛出：
java.sql.SQLException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.upgrade.dbcompare
类
Column
JdbcTypeMap
MetaDataLoader
SchemaCompare
Table
TableDiff
TypeInfo
TypeInfoMap


com.trs.infra.util.upgrade.dbcompare

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.upgrade.dbcompare

类摘要
Column | 数据库表列描述对象
JdbcTypeMap | java.sql.Types的映射.通过反射从值反向获取值.
MetaDataLoader | 数据库表描述对象
SchemaCompare | 数据库比较对象
Table | 数据库表描述对象
TableDiff | 两个同名表比较后的差异
TypeInfo |
TypeInfoMap | 类型映射.


com.trs.infra.util.upgrade.dbcompare 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.upgrade.dbcompare 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.upgrade.dbcompare.Column
    • com.trs.infra.util.upgrade.dbcompare.JdbcTypeMap
    • com.trs.infra.util.upgrade.dbcompare.MetaDataLoader
    • com.trs.infra.util.upgrade.dbcompare.SchemaCompare
    • com.trs.infra.util.upgrade.dbcompare.Table
    • com.trs.infra.util.upgrade.dbcompare.TableDiff
    • com.trs.infra.util.upgrade.dbcompare.TypeInfo
    • com.trs.infra.util.upgrade.dbcompare.TypeInfoMap


软件包 com.trs.infra.util.upgrade.dbcompare 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.upgrade.dbcompare
的使用

使用 com.trs.infra.util.upgrade.dbcompare 的软件包
com.trs.infra.util.upgrade.dbcompare
com.trs.infra.util.upgrade.sql

com.trs.infra.util.upgrade.dbcompare 使用的 com.trs.infra.util.upgrade.dbcompare 中的类
Column
数据库表列描述对象
MetaDataLoader
数据库表描述对象
Table
数据库表描述对象
TypeInfo

com.trs.infra.util.upgrade.sql 使用的 com.trs.infra.util.upgrade.dbcompare 中的类
TableDiff
两个同名表比较后的差异

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SchemaCompare

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dbcompare
类 SchemaCompare

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dbcompare.SchemaCompare

public class SchemaCompare
extends java.lang.Object

数据库比较对象

作者：
wenyh

构造方法摘要
SchemaCompare(MetaDataLoader source, MetaDataLoader dest)
构造函数
方法摘要
java.util.List | compare(boolean reverse) 进行比较运算
java.util.List | getDiff4Dest() 获取目标库相对于源库的差异 只会计算一次,缓存比较结果.
java.util.List | getDiff4Source() 获取源库相对于目标库的差异 只会计算一次,缓存比较结果.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SchemaCompare

public SchemaCompare(MetaDataLoader source,
                     MetaDataLoader dest)
构造函数

参数：
source - 源库
dest - 目标库
方法详细信息

getDiff4Source

public java.util.List getDiff4Source()
                              throws java.sql.SQLException
获取源库相对于目标库的差异
只会计算一次,缓存比较结果.

返回：
抛出：
java.sql.SQLException

getDiff4Dest

public java.util.List getDiff4Dest()
                            throws java.sql.SQLException
获取目标库相对于源库的差异
只会计算一次,缓存比较结果.

返回：
抛出：
java.sql.SQLException

compare

public java.util.List compare(boolean reverse)
                       throws java.sql.SQLException
进行比较运算

参数：
reverse -
抛出：
java.sql.SQLException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Table

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dbcompare
类 Table

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dbcompare.Table

public class Table
extends java.lang.Object

数据库表描述对象

作者：
WenYehui

字段摘要
static char ESCAPE_CHAR
构造方法摘要
Table(java.lang.String tableName)
Table(java.lang.String tableName, java.lang.String[] primaryKey)
方法摘要
void | addColumn(Column column)
java.util.Map | getColumns()
java.lang.String[] | getPrimaryKey()
java.lang.String | getTableName()
void | removeColumn(Column column)
void | setColumns(java.util.SortedMap columns)
void | setPrimaryKey(java.lang.String[] primaryKey)
void | setTableName(java.lang.String tableName)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ESCAPE_CHAR

public static final char ESCAPE_CHAR
另请参见：
常量字段值
构造方法详细信息

Table

public Table(java.lang.String tableName)

Table

public Table(java.lang.String tableName,
             java.lang.String[] primaryKey)
方法详细信息

getTableName

public java.lang.String getTableName()

setTableName

public void setTableName(java.lang.String tableName)

getPrimaryKey

public java.lang.String[] getPrimaryKey()

setPrimaryKey

public void setPrimaryKey(java.lang.String[] primaryKey)

getColumns

public java.util.Map getColumns()

setColumns

public void setColumns(java.util.SortedMap columns)

addColumn

public void addColumn(Column column)

removeColumn

public void removeColumn(Column column)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableDiff

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dbcompare
类 TableDiff

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dbcompare.TableDiff

public class TableDiff
extends java.lang.Object

两个同名表比较后的差异

作者：
wenyh

字段摘要
static int | TYPE_COLDEL 删除的列的标识
static int | TYPE_COLNEW 新添加列的标识
static int | TYPE_COLUPD 更新的列的标识
构造方法摘要
TableDiff(java.lang.String tableName)
构造函数
TableDiff(Table table)
构造函数
方法摘要
void | addColumn(Column column, int type) 添加比较结果的列
java.util.List | getDelcols() 获取被删除的列
java.util.List | getNewcols() 获取新增加的列
Table | getTable() 获取表对象
java.lang.String | getTableName() 获取表名
java.util.List | getUpdcols() 获取更新的列
boolean | isNewtable() 是否是新建的表
void | setDelcols(java.util.List delcols) 设置被删除的列
void | setNewcols(java.util.List newcols) 设置新添加的列
void | setUpdcols(java.util.List updcols) 设置更新的列
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

TYPE_COLNEW

public static final int TYPE_COLNEW
新添加列的标识

另请参见：
常量字段值

TYPE_COLUPD

public static final int TYPE_COLUPD
更新的列的标识

另请参见：
常量字段值

TYPE_COLDEL

public static final int TYPE_COLDEL
删除的列的标识

另请参见：
常量字段值
构造方法详细信息

TableDiff

public TableDiff(java.lang.String tableName)
构造函数

参数：
tableName - 表名

TableDiff

public TableDiff(Table table)
构造函数

参数：
tableName - 表名
newtable - 是否为新建表,true表示新建
方法详细信息

getNewcols

public java.util.List getNewcols()
获取新增加的列

返回：
the newcols

setNewcols

public void setNewcols(java.util.List newcols)
设置新添加的列

参数：
newcols - the newcols to set

getUpdcols

public java.util.List getUpdcols()
获取更新的列

返回：
the updcols

setUpdcols

public void setUpdcols(java.util.List updcols)
设置更新的列

参数：
updcols - the updcols to set

getDelcols

public java.util.List getDelcols()
获取被删除的列

返回：
the delcols

setDelcols

public void setDelcols(java.util.List delcols)
设置被删除的列

参数：
delcols - the delcols to set

getTableName

public java.lang.String getTableName()
获取表名

返回：
the tableName

addColumn

public void addColumn(Column column,
                      int type)
添加比较结果的列

参数：
column - 要添加的列
type - 列的标识:TableDiff.TYPE_NEWCOL, TableDiff.TYPE_UPDCOL TableDiff.TYPE_DELCOL

isNewtable

public boolean isNewtable()
是否是新建的表

返回：
the newtable 如果是则返回true,否则,返回false

getTable

public Table getTable()
获取表对象

返回：
如果不是新表,则返回null

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dbcompare
类 TypeInfo

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dbcompare.TypeInfo

public class TypeInfo
extends java.lang.Object

字段摘要
static int | CRT_PARAMS_COUNT_NONE
static int | CRT_PARAMS_COUNT_ONE
static int | CRT_PARAMS_COUNT_TWO
构造方法摘要
TypeInfo()
方法摘要
int | getCrtParamsCount()
int | getJdbcType()
java.lang.String | getJdbcTypeName()
java.lang.String | getLiteralPrefix()
java.lang.String | getLiteralSuffix()
java.lang.String | getTypeName()
void | setCrtParamsCount(int crtParamsCount)
void | setJdbcType(int jdbcType)
void | setJdbcTypeName(java.lang.String jdbcTypeName)
void | setLiteralPrefix(java.lang.String literalPrefix)
void | setLiteralSuffix(java.lang.String literalSuffix)
void | setTypeName(java.lang.String typeName)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

CRT_PARAMS_COUNT_NONE

public static final int CRT_PARAMS_COUNT_NONE
另请参见：
常量字段值

CRT_PARAMS_COUNT_ONE

public static final int CRT_PARAMS_COUNT_ONE
另请参见：
常量字段值

CRT_PARAMS_COUNT_TWO

public static final int CRT_PARAMS_COUNT_TWO
另请参见：
常量字段值
构造方法详细信息

TypeInfo

public TypeInfo()
方法详细信息

getJdbcType

public int getJdbcType()

setJdbcType

public void setJdbcType(int jdbcType)

getTypeName

public java.lang.String getTypeName()

setTypeName

public void setTypeName(java.lang.String typeName)

getJdbcTypeName

public java.lang.String getJdbcTypeName()

setJdbcTypeName

public void setJdbcTypeName(java.lang.String jdbcTypeName)

getCrtParamsCount

public int getCrtParamsCount()

setCrtParamsCount

public void setCrtParamsCount(int crtParamsCount)

getLiteralPrefix

public java.lang.String getLiteralPrefix()

setLiteralPrefix

public void setLiteralPrefix(java.lang.String literalPrefix)

getLiteralSuffix

public java.lang.String getLiteralSuffix()

setLiteralSuffix

public void setLiteralSuffix(java.lang.String literalSuffix)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeInfoMap

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.dbcompare
类 TypeInfoMap

java.lang.Object
    继承者  com.trs.infra.util.upgrade.dbcompare.TypeInfoMap

public class TypeInfoMap
extends java.lang.Object

类型映射.

作者：
wenyh

构造方法摘要
TypeInfoMap()
方法摘要
static java.lang.String | display()
static TypeInfo | get(java.lang.String typeName)
static void | load(java.lang.String dbtype)
static void | put(java.lang.String typeName, TypeInfo typeInfo)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TypeInfoMap

public TypeInfoMap()
方法详细信息

load

public static void load(java.lang.String dbtype)

put

public static void put(java.lang.String typeName,
                       TypeInfo typeInfo)

get

public static TypeInfo get(java.lang.String typeName)

display

public static java.lang.String display()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.util.upgrade.dbcompare.Column 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dbcompare.Column
的使用

使用 Column 的软件包
com.trs.infra.util.upgrade.dbcompare

com.trs.infra.util.upgrade.dbcompare 中 Column 的使用

参数类型为 Column 的 com.trs.infra.util.upgrade.dbcompare 中的方法
void | Table.addColumn(Column column)
void | TableDiff.addColumn(Column column, int type) 添加比较结果的列
void | Table.removeColumn(Column column)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dbcompare.JdbcTypeMap 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dbcompare.JdbcTypeMap
的使用

没有 com.trs.infra.util.upgrade.dbcompare.JdbcTypeMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dbcompare.MetaDataLoader 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dbcompare.MetaDataLoader
的使用

使用 MetaDataLoader 的软件包
com.trs.infra.util.upgrade.dbcompare

com.trs.infra.util.upgrade.dbcompare 中 MetaDataLoader 的使用

参数类型为 MetaDataLoader 的 com.trs.infra.util.upgrade.dbcompare 中的构造方法
SchemaCompare(MetaDataLoader source, MetaDataLoader dest)
构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dbcompare.SchemaCompare 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dbcompare.SchemaCompare
的使用

没有 com.trs.infra.util.upgrade.dbcompare.SchemaCompare 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dbcompare.Table 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dbcompare.Table
的使用

使用 Table 的软件包
com.trs.infra.util.upgrade.dbcompare

com.trs.infra.util.upgrade.dbcompare 中 Table 的使用

返回 Table 的 com.trs.infra.util.upgrade.dbcompare 中的方法
 Table TableDiff.getTable()
获取表对象

参数类型为 Table 的 com.trs.infra.util.upgrade.dbcompare 中的构造方法
TableDiff(Table table)
构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dbcompare.TableDiff 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dbcompare.TableDiff
的使用

使用 TableDiff 的软件包
com.trs.infra.util.upgrade.sql

com.trs.infra.util.upgrade.sql 中 TableDiff 的使用

参数类型为 TableDiff 的 com.trs.infra.util.upgrade.sql 中的方法
 java.lang.String[] SchemaUpdSqlMaker.getSql(TableDiff diff)
获取SQL

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dbcompare.TypeInfo
的使用

使用 TypeInfo 的软件包
com.trs.infra.util.upgrade.dbcompare

com.trs.infra.util.upgrade.dbcompare 中 TypeInfo 的使用

返回 TypeInfo 的 com.trs.infra.util.upgrade.dbcompare 中的方法
static TypeInfo TypeInfoMap.get(java.lang.String typeName)

参数类型为 TypeInfo 的 com.trs.infra.util.upgrade.dbcompare 中的方法
static void TypeInfoMap.put(java.lang.String typeName, TypeInfo typeInfo)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.dbcompare.TypeInfoMap 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.dbcompare.TypeInfoMap
的使用

没有 com.trs.infra.util.upgrade.dbcompare.TypeInfoMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DB2UpdSqlMaker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.sql
类 DB2UpdSqlMaker

java.lang.Object
    继承者  com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker
        继承者  com.trs.infra.util.upgrade.sql.DB2UpdSqlMaker

public class DB2UpdSqlMaker
extends SchemaUpdSqlMaker

构造方法摘要
DB2UpdSqlMaker()
方法摘要
从类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker 继承的方法
getSql
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DB2UpdSqlMaker

public DB2UpdSqlMaker()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DbUpdSqlLogMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.sql
类 DbUpdSqlLogMaker

java.lang.Object
    继承者  com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker

public class DbUpdSqlLogMaker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
产生更新SQL语句.
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

方法摘要
void | end(int version, java.lang.String info)
static void | main(java.lang.String[] args)
void | write(java.lang.String title, java.lang.String ora, java.lang.String mssql, java.lang.String sybase, java.lang.String db2)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

main

public static void main(java.lang.String[] args)

write

public void write(java.lang.String title,
                  java.lang.String ora,
                  java.lang.String mssql,
                  java.lang.String sybase,
                  java.lang.String db2)
           throws java.lang.Exception
抛出：
java.lang.Exception

end

public void end(int version,
                java.lang.String info)
         throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DiffSqlMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.sql
类 DiffSqlMaker

java.lang.Object
    继承者  com.trs.infra.util.upgrade.sql.DiffSqlMaker

public class DiffSqlMaker
extends java.lang.Object

构造方法摘要
DiffSqlMaker(java.lang.String dbconf, java.lang.String output)
方法摘要
static void | main(java.lang.String[] args)
void | make()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DiffSqlMaker

public DiffSqlMaker(java.lang.String dbconf,
                    java.lang.String output)
参数：
dbconf - 数据库配置
output - 输出文件
方法详细信息

make

public void make()
          throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MssqlUpdSqlMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.sql
类 MssqlUpdSqlMaker

java.lang.Object
    继承者  com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker
        继承者  com.trs.infra.util.upgrade.sql.MssqlUpdSqlMaker

public class MssqlUpdSqlMaker
extends SchemaUpdSqlMaker

构造方法摘要
MssqlUpdSqlMaker()
方法摘要
从类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker 继承的方法
getSql
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MssqlUpdSqlMaker

public MssqlUpdSqlMaker()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OracleUpdSqlMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.sql
类 OracleUpdSqlMaker

java.lang.Object
    继承者  com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker
        继承者  com.trs.infra.util.upgrade.sql.OracleUpdSqlMaker

public class OracleUpdSqlMaker
extends SchemaUpdSqlMaker

构造方法摘要
OracleUpdSqlMaker()
方法摘要
从类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker 继承的方法
getSql
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OracleUpdSqlMaker

public OracleUpdSqlMaker()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.upgrade.sql
类
DB2UpdSqlMaker
DbUpdSqlLogMaker
DiffSqlMaker
MssqlUpdSqlMaker
OracleUpdSqlMaker
SchemaUpdSqlMaker
SchemaUpdSqlMakerFactory
UpdSqlMaker


com.trs.infra.util.upgrade.sql

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.upgrade.sql

类摘要
DB2UpdSqlMaker |
DbUpdSqlLogMaker | Title: TRS 内容协作平台（TRS WCM） Description: 产生更新SQL语句.
DiffSqlMaker |
MssqlUpdSqlMaker |
OracleUpdSqlMaker |
SchemaUpdSqlMaker | 根据比较的差异结果产生更新SQL
SchemaUpdSqlMakerFactory | sql产生者的工厂类
UpdSqlMaker |


com.trs.infra.util.upgrade.sql 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.upgrade.sql 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker
    • com.trs.infra.util.upgrade.sql.DiffSqlMaker
    • com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker
      • com.trs.infra.util.upgrade.sql.DB2UpdSqlMaker
      • com.trs.infra.util.upgrade.sql.MssqlUpdSqlMaker
      • com.trs.infra.util.upgrade.sql.OracleUpdSqlMaker
    • com.trs.infra.util.upgrade.sql.SchemaUpdSqlMakerFactory
    • com.trs.infra.util.upgrade.sql.UpdSqlMaker


软件包 com.trs.infra.util.upgrade.sql 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.upgrade.sql
的使用

使用 com.trs.infra.util.upgrade.sql 的软件包
com.trs.infra.util.upgrade.sql

com.trs.infra.util.upgrade.sql 使用的 com.trs.infra.util.upgrade.sql 中的类
SchemaUpdSqlMaker
根据比较的差异结果产生更新SQL

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SchemaUpdSqlMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.sql
类 SchemaUpdSqlMaker

java.lang.Object
    继承者  com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker
直接已知子类：
DB2UpdSqlMaker, MssqlUpdSqlMaker, OracleUpdSqlMaker
public abstract class SchemaUpdSqlMaker
extends java.lang.Object

根据比较的差异结果产生更新SQL

作者：
wenyh

构造方法摘要
SchemaUpdSqlMaker()
方法摘要
 java.lang.String[] getSql(TableDiff diff)
获取SQL
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SchemaUpdSqlMaker

public SchemaUpdSqlMaker()
方法详细信息

getSql

public java.lang.String[] getSql(TableDiff diff)
获取SQL

参数：
diff -
返回：
SQL
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SchemaUpdSqlMakerFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.sql
类 SchemaUpdSqlMakerFactory

java.lang.Object
    继承者  com.trs.infra.util.upgrade.sql.SchemaUpdSqlMakerFactory

public class SchemaUpdSqlMakerFactory
extends java.lang.Object

sql产生者的工厂类

作者：
wenyh

构造方法摘要
SchemaUpdSqlMakerFactory()
方法摘要
static SchemaUpdSqlMaker makeSqlMaker(java.lang.String dbtype)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SchemaUpdSqlMakerFactory

public SchemaUpdSqlMakerFactory()
方法详细信息

makeSqlMaker

public static final SchemaUpdSqlMaker makeSqlMaker(java.lang.String dbtype)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UpdSqlMaker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.upgrade.sql
类 UpdSqlMaker

java.lang.Object
    继承者  com.trs.infra.util.upgrade.sql.UpdSqlMaker

public class UpdSqlMaker
extends java.lang.Object

构造方法摘要
UpdSqlMaker()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UpdSqlMaker

public UpdSqlMaker()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.infra.util.upgrade.sql.DB2UpdSqlMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.sql.DB2UpdSqlMaker
的使用

没有 com.trs.infra.util.upgrade.sql.DB2UpdSqlMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker
的使用

没有 com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.sql.DiffSqlMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.sql.DiffSqlMaker
的使用

没有 com.trs.infra.util.upgrade.sql.DiffSqlMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.sql.MssqlUpdSqlMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.sql.MssqlUpdSqlMaker
的使用

没有 com.trs.infra.util.upgrade.sql.MssqlUpdSqlMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.sql.OracleUpdSqlMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.sql.OracleUpdSqlMaker
的使用

没有 com.trs.infra.util.upgrade.sql.OracleUpdSqlMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker
的使用

使用 SchemaUpdSqlMaker 的软件包
com.trs.infra.util.upgrade.sql

com.trs.infra.util.upgrade.sql 中 SchemaUpdSqlMaker 的使用

com.trs.infra.util.upgrade.sql 中 SchemaUpdSqlMaker 的子类
class | DB2UpdSqlMaker
class | MssqlUpdSqlMaker
class | OracleUpdSqlMaker

返回 SchemaUpdSqlMaker 的 com.trs.infra.util.upgrade.sql 中的方法
static SchemaUpdSqlMaker SchemaUpdSqlMakerFactory.makeSqlMaker(java.lang.String dbtype)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMakerFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMakerFactory
的使用

没有 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMakerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.upgrade.sql.UpdSqlMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.upgrade.sql.UpdSqlMaker
的使用

没有 com.trs.infra.util.upgrade.sql.UpdSqlMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IXmlPersistentObject

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.xml
接口 IXmlPersistentObject

所有已知子接口：
IConfigElement, IInfoEntity
所有已知实现类：
BaseChannelInfoEntity, BeanConfig, CachedObjectConfig, CacheMgrConfig, ContentTypeConfig, DBConnectionConfig, DBConnectionConfigs, DocumentFieldConfig, DocumentShowFieldConfig, ExtensionConfigs, FileNamedStyle, FolderTypeConfig, InfoEntities, InfoViewConfig, LaborResourceConfig, MessageSendingConfig, MonitorHostConfig, NotificationSchemeConfig, ObjectLCListenerConfig, ObjectTypeConfig, OperationConfig, OperationDefineOnCurrChannelConfig, OperationRelatedConfig, PublishDistributionConfig, PublishElementConfig, PublishServerConfig, RegFromConfig, RightHostConfig, RightHostIndexsConfig, RightObjectConfig, ServerConfig, SMTPServerConfig, SMTPServerConfigs, SystemCollocationConfig, TagFieldInfoEntity, TagFormatterConfig, TargetTypeConfig, TemplateInfoEntity, TemplateParseConfig, UpdateCommanderConfig, WCMAppConfig, WebSiteInfoEntity
public interface IXmlPersistentObject

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.infra.util.xml
接口
IXmlPersistentObject
类
XmlObjectPersistentor


com.trs.infra.util.xml

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.infra.util.xml

接口摘要
IXmlPersistentObject

类摘要
XmlObjectPersistentor Title: TRS 内容协作平台（TRS WCM）
Description:
The tool for getting or serializing a xml object
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.infra.util.xml 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.xml 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.util.xml.XmlObjectPersistentor

接口分层结构

  • com.trs.infra.util.xml.IXmlPersistentObject


软件包 com.trs.infra.util.xml 的使用

上一个 下一个 框架 无框架

软件包 com.trs.infra.util.xml
的使用

使用 com.trs.infra.util.xml 的软件包
com.trs.cms.auth.config |
com.trs.components.common.message |
com.trs.components.common.message.notify |
com.trs.components.common.publish.config.persistent |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.wcm |
com.trs.components.wcm.content.persistent |
com.trs.infra |
com.trs.infra.config.persistent |
com.trs.infra.persistent |
com.trs.infra.persistent.cache |
com.trs.infra.persistent.db |
com.trs.infra.persistent.listener |
com.trs.infra.support.cache |
com.trs.infra.support.config |
com.trs.infra.update |
com.trs.infra.util.email |
com.trs.infra.util.xml |
com.trs.presentation.ids |
com.trs.template.persistent |

com.trs.cms.auth.config 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.components.common.message 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.components.common.message.notify 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.components.common.publish.config.persistent 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.components.infoview 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.components.wcm 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.components.wcm.content.persistent 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.config.persistent 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.persistent 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.persistent.cache 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.persistent.db 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.persistent.listener 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.support.cache 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.support.config 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.update 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.util.email 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.infra.util.xml 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.presentation.ids 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

com.trs.template.persistent 使用的 com.trs.infra.util.xml 中的类
IXmlPersistentObject

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


XmlObjectPersistentor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.infra.util.xml
类 XmlObjectPersistentor

java.lang.Object
    继承者  com.trs.infra.util.xml.XmlObjectPersistentor

public class XmlObjectPersistentor
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
The tool for getting or serializing a xml object
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DEFAULT_ENCODING
static java.lang.String | MAPPINGPATH
构造方法摘要
XmlObjectPersistentor()
方法摘要
java.lang.String | getMappingSrc() get the mapping src
IXmlPersistentObject | getParsedInstance(java.lang.String _sXmlFile)
IXmlPersistentObject | getParsedInstance(java.lang.String _sXmlFile, java.lang.String _sEncodingStyle) get the Parsed Instance from a certain xml file
boolean | isHasMapping() mack it known that if the mashall/unmarshall has mapping src
void | setHasMapping(boolean hasMapping) determine if the mashall/unmarshall has mapping src
void | setMappingSrc(java.lang.String mappingSrc) set the mapping file src
void | updateInstance(IXmlPersistentObject _xmlObj, java.lang.String _sXmlFile)
void | updateInstance(IXmlPersistentObject _xmlObj, java.lang.String _sXmlFile, java.lang.String _sEncodingStyle) update the persistent object
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MAPPINGPATH

public static final java.lang.String MAPPINGPATH
另请参见：
常量字段值

DEFAULT_ENCODING

public static final java.lang.String DEFAULT_ENCODING
另请参见：
常量字段值
构造方法详细信息

XmlObjectPersistentor

public XmlObjectPersistentor()
方法详细信息

getParsedInstance

public IXmlPersistentObject getParsedInstance(java.lang.String _sXmlFile,
                                              java.lang.String _sEncodingStyle)
                                       throws CMyException
get the Parsed Instance from a certain xml file

参数：
_sXmlFile - the path of the xml file (must be invalid)
返回：
抛出：
java.lang.Exception
CMyException

getParsedInstance

public IXmlPersistentObject getParsedInstance(java.lang.String _sXmlFile)
                                       throws CMyException
抛出：
CMyException

updateInstance

public void updateInstance(IXmlPersistentObject _xmlObj,
                           java.lang.String _sXmlFile,
                           java.lang.String _sEncodingStyle)
                    throws CMyException
update the persistent object

参数：
_xmlObj - the xml object to be persistented
_sXmlFile - the path of the xml file (must be invalid) which the object persistented at
抛出：
java.lang.Exception
CMyException

updateInstance

public void updateInstance(IXmlPersistentObject _xmlObj,
                           java.lang.String _sXmlFile)
                    throws CMyException
抛出：
CMyException

isHasMapping

public boolean isHasMapping()
mack it known that if the mashall/unmarshall has mapping src

返回：

setHasMapping

public void setHasMapping(boolean hasMapping)
determine if the mashall/unmarshall has mapping src

参数：
hasMapping -

getMappingSrc

public java.lang.String getMappingSrc()
get the mapping src

返回：
the file path of the mapping src

setMappingSrc

public void setMappingSrc(java.lang.String mappingSrc)
set the mapping file src

参数：
mappingSrc - the path of the mapping file
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.infra.util.xml.IXmlPersistentObject 的使用

上一个 下一个 框架 无框架

接口 com.trs.infra.util.xml.IXmlPersistentObject
的使用

使用 IXmlPersistentObject 的软件包
com.trs.cms.auth.config |
com.trs.components.common.message |
com.trs.components.common.message.notify |
com.trs.components.common.publish.config.persistent |
com.trs.components.infoview | 结合 MS InfoPath 实现自定义表单。
com.trs.components.wcm |
com.trs.components.wcm.content.persistent |
com.trs.infra |
com.trs.infra.config.persistent |
com.trs.infra.persistent |
com.trs.infra.persistent.cache |
com.trs.infra.persistent.db |
com.trs.infra.persistent.listener |
com.trs.infra.support.cache |
com.trs.infra.support.config |
com.trs.infra.update |
com.trs.infra.util.email |
com.trs.infra.util.xml |
com.trs.presentation.ids |
com.trs.template.persistent |

com.trs.cms.auth.config 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.cms.auth.config 中的类
class | OperationConfig
class | OperationDefineOnCurrChannelConfig
class | OperationRelatedConfig
class | RightHostConfig Title: TRS 内容协作平台（TRS WCM） Description: Right Object实现配置信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RightHostIndexsConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RightObjectConfig Title: TRS 内容协作平台（TRS WCM） Description: Right Object实现配置信息 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.components.common.message 中的类
 class MessageSendingConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.message.notify 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.components.common.message.notify 中的类
 class NotificationSchemeConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.config.persistent 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.components.common.publish.config.persistent 中的类
class | ContentTypeConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FileNamedStyle Title: TRS 内容协作平台（TRS WCM） Description: 表征文件的命名规则，采用“三段式” ：前缀 + 标示体 + 附加字段 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FolderTypeConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | LaborResourceConfig Title: TRS 内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishDistributionConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishElementConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishServerConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TagFormatterConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TargetTypeConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateParseConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.components.infoview 中的类
 class InfoViewConfig

com.trs.components.wcm 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.components.wcm 中的类
 class WCMAppConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.persistent 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.components.wcm.content.persistent 中的类
class | DocumentFieldConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentShowFieldConfig

com.trs.infra 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra 中的类
 class ServerConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
服务器对象的配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.config.persistent 中 IXmlPersistentObject 的使用

com.trs.infra.config.persistent 中 IXmlPersistentObject 的子接口
 interface IConfigElement
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

实现 IXmlPersistentObject 的 com.trs.infra.config.persistent 中的类
class | BeanConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtensionConfigs Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra.persistent 中的类
 class ObjectTypeConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.cache 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra.persistent.cache 中的类
 class CachedObjectConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra.persistent.db 中的类
class | DBConnectionConfig Title: TRS 内容协作平台（TRS WCM） Description: 数据库连接特性的配置对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DBConnectionConfigs Title: TRS 内容协作平台（TRS WCM） Description: 数据库连接配置对象的集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.listener 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra.persistent.listener 中的类
class | MonitorHostConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectLCListenerConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.cache 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra.support.cache 中的类
 class CacheMgrConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.support.config 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra.support.config 中的类
 class SystemCollocationConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.update 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra.update 中的类
 class UpdateCommanderConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commander
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.email 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.infra.util.email 中的类
class | SMTPServerConfig Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | SMTPServerConfigs Title: TRS 内容协作平台（TRS WCM） Description: SMTPServer config 的集合 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.util.xml 中 IXmlPersistentObject 的使用

返回 IXmlPersistentObject 的 com.trs.infra.util.xml 中的方法
IXmlPersistentObject | XmlObjectPersistentor.getParsedInstance(java.lang.String _sXmlFile)
IXmlPersistentObject | XmlObjectPersistentor.getParsedInstance(java.lang.String _sXmlFile, java.lang.String _sEncodingStyle) get the Parsed Instance from a certain xml file

参数类型为 IXmlPersistentObject 的 com.trs.infra.util.xml 中的方法
void | XmlObjectPersistentor.updateInstance(IXmlPersistentObject _xmlObj, java.lang.String _sXmlFile)
void | XmlObjectPersistentor.updateInstance(IXmlPersistentObject _xmlObj, java.lang.String _sXmlFile, java.lang.String _sEncodingStyle) update the persistent object

com.trs.presentation.ids 中 IXmlPersistentObject 的使用

实现 IXmlPersistentObject 的 com.trs.presentation.ids 中的类
 class RegFromConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.template.persistent 中 IXmlPersistentObject 的使用

com.trs.template.persistent 中 IXmlPersistentObject 的子接口
 interface IInfoEntity

实现 IXmlPersistentObject 的 com.trs.template.persistent 中的类
class | BaseChannelInfoEntity
class | InfoEntities
class | TagFieldInfoEntity
class | TemplateInfoEntity
class | WebSiteInfoEntity

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.infra.util.xml.XmlObjectPersistentor 的使用

上一个 下一个 框架 无框架

类 com.trs.infra.util.xml.XmlObjectPersistentor
的使用

没有 com.trs.infra.util.xml.XmlObjectPersistentor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.km.auth
类
UserListenerForRecordLogin


com.trs.km.auth

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.km.auth

类摘要
UserListenerForRecordLogin


com.trs.km.auth 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.km.auth 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.km.auth.UserListenerForRecordLogin (implements com.trs.infra.persistent.listener.IObjectLCListenerOnModify)


软件包 com.trs.km.auth 的使用

上一个 下一个 框架 无框架

软件包 com.trs.km.auth
的使用

没有 com.trs.km.auth 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


UserListenerForRecordLogin

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.km.auth
类 UserListenerForRecordLogin

java.lang.Object
    继承者  com.trs.km.auth.UserListenerForRecordLogin
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnModify
public class UserListenerForRecordLogin
extends java.lang.Object
implements IObjectLCListenerOnModify

构造方法摘要
UserListenerForRecordLogin()
方法摘要
 void notifyOnModifyObj(BaseObj _oObjModified, int _nEventType)
修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserListenerForRecordLogin

public UserListenerForRecordLogin()
方法详细信息

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.km.auth.UserListenerForRecordLogin 的使用

上一个 下一个 框架 无框架

类 com.trs.km.auth.UserListenerForRecordLogin
的使用

没有 com.trs.km.auth.UserListenerForRecordLogin 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


License

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.license
接口 License

所有已知实现类：
MyDate, MyDB, MySite
public interface License

Title: TRS 内容协作平台（TRS WCM）
Description:
License
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
int | getMaxSiteNum() 获取最大站点数
int | getMaxUserNum() 获取最大用户数
int | getPluginCode() 获取选件的注册码
java.lang.String | validate() 校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息

方法详细信息

getMaxSiteNum

int getMaxSiteNum()
获取最大站点数

返回：

getMaxUserNum

int getMaxUserNum()
获取最大用户数

返回：

getPluginCode

int getPluginCode()
获取选件的注册码

返回：

validate

java.lang.String validate()
校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


LicenseException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.license
类 LicenseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.license.LicenseException
所有已实现的接口：
java.io.Serializable
public class LicenseException
extends java.lang.RuntimeException

Title: TRS 内容协作平台（TRS WCM）
Description:
Top Exception of License validate
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
LicenseException()
LicenseException(java.lang.String _sMessage)
LicenseException(java.lang.String _sMessage, java.lang.Throwable _cause)
LicenseException(java.lang.Throwable _cause)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LicenseException

public LicenseException()

LicenseException

public LicenseException(java.lang.String _sMessage)

LicenseException

public LicenseException(java.lang.String _sMessage,
                        java.lang.Throwable _cause)

LicenseException

public LicenseException(java.lang.Throwable _cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LicenseUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.license
类 LicenseUtil

java.lang.Object
    继承者  com.trs.license.LicenseUtil

public class LicenseUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Encoder:Base64
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LicenseUtil()
方法摘要
static java.lang.String decodeRadix64(java.lang.String _srcStr)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LicenseUtil

public LicenseUtil()
方法详细信息

decodeRadix64

public static java.lang.String decodeRadix64(java.lang.String _srcStr)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.license
接口
License
类
LicenseUtil
异常
LicenseException


com.trs.license

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.license

接口摘要
License Title: TRS 内容协作平台（TRS WCM）
Description:
License
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
LicenseUtil Title: TRS 内容协作平台（TRS WCM）
Description:
Encoder:Base64
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
LicenseException Title: TRS 内容协作平台（TRS WCM）
Description:
Top Exception of License validate
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.license 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.license 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.license.LicenseUtil
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.trs.license.LicenseException

接口分层结构

  • com.trs.license.License


软件包 com.trs.license 的使用

上一个 下一个 框架 无框架

软件包 com.trs.license
的使用

使用 com.trs.license 的软件包
com.trs.components.wcm
com.trs.components.wcm.content
com.trs.infra.persistent.db

com.trs.components.wcm 使用的 com.trs.license 中的类
License
Title: TRS 内容协作平台（TRS WCM）
Description:
License
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 使用的 com.trs.license 中的类
License
Title: TRS 内容协作平台（TRS WCM）
Description:
License
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 使用的 com.trs.license 中的类
License
Title: TRS 内容协作平台（TRS WCM）
Description:
License
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.license.License 的使用

上一个 下一个 框架 无框架

接口 com.trs.license.License
的使用

使用 License 的软件包
com.trs.components.wcm
com.trs.components.wcm.content
com.trs.infra.persistent.db

com.trs.components.wcm 中 License 的使用

实现 License 的 com.trs.components.wcm 中的类
 class MyDB
Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content 中 License 的使用

实现 License 的 com.trs.components.wcm.content 中的类
 class MySite
Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.infra.persistent.db 中 License 的使用

实现 License 的 com.trs.infra.persistent.db 中的类
 class MyDate
Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.license.LicenseException 的使用

上一个 下一个 框架 无框架

类 com.trs.license.LicenseException
的使用

没有 com.trs.license.LicenseException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.license.LicenseUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.license.LicenseUtil
的使用

没有 com.trs.license.LicenseUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.presentation.common
类
PageViewConstants


com.trs.presentation.common

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.common

类摘要
PageViewConstants Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.common 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.common 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.common.PageViewConstants


软件包 com.trs.presentation.common 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.common
的使用

没有 com.trs.presentation.common 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageViewConstants

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.common
类 PageViewConstants

java.lang.Object
    继承者  com.trs.presentation.common.PageViewConstants

public class PageViewConstants
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | FILE_VIEW_CONFIG
static int | OPER_DOCUMENT_COPY Comment for OPER_DOCUMENT_COPY 操作类型：移动文档[20]
static int | OPER_DOCUMENT_MIRROR Comment for OPER_DOCUMENT_MIRROR 操作类型：镜像文档[40]
static int | OPER_DOCUMENT_MOVE Comment for OPER_DOCUMENT_MOVE 操作类型：移动文档[10]
static int | OPER_DOCUMENT_QUOTE Comment for OPER_DOCUMENT_QUOTE 操作类型：移动文档[30]
static java.lang.String | OPER_NODE_URL_KEY
static java.lang.String | OPER_ROOT_URL_KEY
static int | TREE_OPERATION_DOCUMENT Comment for TREE_OPERATION_DOCUMENT 树形结构操作类型：文档管理 1
static int | TREE_OPERATION_GROUP_SEL Comment for TREE_OPERATION_GROUP_SEL 树形结构操作类型：组织选择
static int | TREE_OPERATION_GRPUSER_MGR Comment for TREE_OPERATION_GRPUSER_MGR 树形结构操作类型：组织内用户管理 12
static int | TREE_OPERATION_GRPUSER_SEL Comment for TREE_OPERATION_GRPUSER_SEL 树形结构操作类型：组织内用户选择 11
static int | TREE_OPERATION_GRPUSER_SEL_SPECIAL Comment for TREE_OPERATION_GRPUSER_SEL_SPECIAL 树形结构操作类型：组织内用户选择 23
static int | TREE_OPERATION_OTHER Comment for TREE_OPERATION_OTHER 树形结构操作类型：其它 0
static int | TREE_OPERATION_PORTAL Comment for TREE_OPERATION_TEMPLATE 树形结构操作类型：门户导航 4
static int | TREE_OPERATION_ROLEUSER_MGR Comment for TREE_OPERATION_ROLEUSER_MGR 树形结构操作类型：组织内用户管理 14
static int | TREE_OPERATION_ROLEUSER_SEL Comment for TREE_OPERATION_ROLEUSER_SEL 树形结构操作类型：角色内用户选择 13
static int | TREE_OPERATION_SITE Comment for TREE_OPERATION_SITE 树形结构操作类型：站点管理 2
static int | TREE_OPERATION_SYSUSER_MGR Comment for TREE_OPERATION_SYSUSER_MGR 树形结构操作类型：系统所有用户管理 10
static int | TREE_OPERATION_TEMPLATE Comment for TREE_OPERATION_TEMPLATE 树形结构操作类型：模板管理 3
static int | TREE_TYPE_CHECKBOX Comment for TREE_TYPE_CHECKBOX 树形结构类型：多选[1]
static int | TREE_TYPE_NORMAL Comment for TREE_TYPE_NORMAL 栏目树类型：普通[0]
static int | TREE_TYPE_RADIOBOX Comment for TREE_TYPE_RADIOBOX 树形结构类型：单选[2]
构造方法摘要
PageViewConstants()
方法摘要
static java.lang.String | getOperNodeURL(int _nOperationType)
static java.lang.String | getOperRootURL(int _nOperationType)
static java.util.Enumeration | getPropertyNames()
static java.lang.String | getViewConfigValue(java.lang.String _sKey)
static void | main(java.lang.String[] args)
static void | reloadProperties()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TREE_TYPE_NORMAL

public static final int TREE_TYPE_NORMAL
Comment for TREE_TYPE_NORMAL 栏目树类型：普通[0]

另请参见：
常量字段值

TREE_TYPE_CHECKBOX

public static final int TREE_TYPE_CHECKBOX
Comment for TREE_TYPE_CHECKBOX 树形结构类型：多选[1]

另请参见：
常量字段值

TREE_TYPE_RADIOBOX

public static final int TREE_TYPE_RADIOBOX
Comment for TREE_TYPE_RADIOBOX 树形结构类型：单选[2]

另请参见：
常量字段值

TREE_OPERATION_OTHER

public static final int TREE_OPERATION_OTHER
Comment for TREE_OPERATION_OTHER 树形结构操作类型：其它 0

另请参见：
常量字段值

TREE_OPERATION_DOCUMENT

public static final int TREE_OPERATION_DOCUMENT
Comment for TREE_OPERATION_DOCUMENT 树形结构操作类型：文档管理 1

另请参见：
常量字段值

TREE_OPERATION_SITE

public static final int TREE_OPERATION_SITE
Comment for TREE_OPERATION_SITE 树形结构操作类型：站点管理 2

另请参见：
常量字段值

TREE_OPERATION_TEMPLATE

public static final int TREE_OPERATION_TEMPLATE
Comment for TREE_OPERATION_TEMPLATE 树形结构操作类型：模板管理 3

另请参见：
常量字段值

TREE_OPERATION_PORTAL

public static final int TREE_OPERATION_PORTAL
Comment for TREE_OPERATION_TEMPLATE 树形结构操作类型：门户导航 4

另请参见：
常量字段值

TREE_OPERATION_SYSUSER_MGR

public static final int TREE_OPERATION_SYSUSER_MGR
Comment for TREE_OPERATION_SYSUSER_MGR 树形结构操作类型：系统所有用户管理 10

另请参见：
常量字段值

TREE_OPERATION_GRPUSER_SEL

public static final int TREE_OPERATION_GRPUSER_SEL
Comment for TREE_OPERATION_GRPUSER_SEL 树形结构操作类型：组织内用户选择 11

另请参见：
常量字段值

TREE_OPERATION_GRPUSER_SEL_SPECIAL

public static final int TREE_OPERATION_GRPUSER_SEL_SPECIAL
Comment for TREE_OPERATION_GRPUSER_SEL_SPECIAL 树形结构操作类型：组织内用户选择 23

另请参见：
常量字段值

TREE_OPERATION_GRPUSER_MGR

public static final int TREE_OPERATION_GRPUSER_MGR
Comment for TREE_OPERATION_GRPUSER_MGR 树形结构操作类型：组织内用户管理 12

另请参见：
常量字段值

TREE_OPERATION_ROLEUSER_SEL

public static final int TREE_OPERATION_ROLEUSER_SEL
Comment for TREE_OPERATION_ROLEUSER_SEL 树形结构操作类型：角色内用户选择 13

另请参见：
常量字段值

TREE_OPERATION_ROLEUSER_MGR

public static final int TREE_OPERATION_ROLEUSER_MGR
Comment for TREE_OPERATION_ROLEUSER_MGR 树形结构操作类型：组织内用户管理 14

另请参见：
常量字段值

TREE_OPERATION_GROUP_SEL

public static final int TREE_OPERATION_GROUP_SEL
Comment for TREE_OPERATION_GROUP_SEL 树形结构操作类型：组织选择

另请参见：
常量字段值

OPER_DOCUMENT_MOVE

public static final int OPER_DOCUMENT_MOVE
Comment for OPER_DOCUMENT_MOVE 操作类型：移动文档[10]

另请参见：
常量字段值

OPER_DOCUMENT_COPY

public static final int OPER_DOCUMENT_COPY
Comment for OPER_DOCUMENT_COPY 操作类型：移动文档[20]

另请参见：
常量字段值

OPER_DOCUMENT_QUOTE

public static final int OPER_DOCUMENT_QUOTE
Comment for OPER_DOCUMENT_QUOTE 操作类型：移动文档[30]

另请参见：
常量字段值

OPER_DOCUMENT_MIRROR

public static final int OPER_DOCUMENT_MIRROR
Comment for OPER_DOCUMENT_MIRROR 操作类型：镜像文档[40]

另请参见：
常量字段值

OPER_ROOT_URL_KEY

public static final java.lang.String OPER_ROOT_URL_KEY
另请参见：
常量字段值

OPER_NODE_URL_KEY

public static final java.lang.String OPER_NODE_URL_KEY
另请参见：
常量字段值

FILE_VIEW_CONFIG

public static final java.lang.String FILE_VIEW_CONFIG
另请参见：
常量字段值
构造方法详细信息

PageViewConstants

public PageViewConstants()
方法详细信息

getOperRootURL

public static final java.lang.String getOperRootURL(int _nOperationType)
                                             throws WCMException
抛出：
WCMException

getOperNodeURL

public static final java.lang.String getOperNodeURL(int _nOperationType)
                                             throws WCMException
抛出：
WCMException

getViewConfigValue

public static final java.lang.String getViewConfigValue(java.lang.String _sKey)
                                                 throws WCMException
抛出：
WCMException

reloadProperties

public static final void reloadProperties()
                                   throws WCMException
抛出：
WCMException

getPropertyNames

public static final java.util.Enumeration getPropertyNames()
                                                    throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.common.PageViewConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.common.PageViewConstants
的使用

没有 com.trs.presentation.common.PageViewConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DocumentImportXmlHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.documetimport.xml
类 DocumentImportXmlHelper

java.lang.Object
    继承者  com.trs.presentation.documetimport.xml.DocumentImportXmlHelper

public class DocumentImportXmlHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentImportXmlHelper()
方法摘要
static void | addImportSource(java.lang.String _strAddFilePath) 新建一个文档导入的映射文件 just for document/document_xml_add_dowith.jsp
static void | editImportSource(java.lang.String _strDefaultXslPath, java.lang.String _strXMLField, java.lang.String _strTRSField, java.lang.String _strSQLField) 编辑一个文档导入所需的xml映射文件 just for document/document_xml_edit_dowith.jsp
static java.lang.String[][] | getImportSources(java.lang.String _strDefaultXslPath) 取得一个文档导入需要的xml文件信息 just for document/document_xml_edit.jsp
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentImportXmlHelper

public DocumentImportXmlHelper()
方法详细信息

getImportSources

public static java.lang.String[][] getImportSources(java.lang.String _strDefaultXslPath)
                                             throws WCMException
取得一个文档导入需要的xml文件信息 just for document/document_xml_edit.jsp

参数：
_strDefaultXslPath -
返回：
抛出：
WCMException

addImportSource

public static void addImportSource(java.lang.String _strAddFilePath)
                            throws WCMException
新建一个文档导入的映射文件 just for document/document_xml_add_dowith.jsp

参数：
_strAddFilePath -
抛出：
WCMException

editImportSource

public static void editImportSource(java.lang.String _strDefaultXslPath,
                                    java.lang.String _strXMLField,
                                    java.lang.String _strTRSField,
                                    java.lang.String _strSQLField)
                             throws WCMException
编辑一个文档导入所需的xml映射文件 just for document/document_xml_edit_dowith.jsp

参数：
_strDefaultXslPath -
_strXMLField -
_strTRSField -
_strSQLField -
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.documetimport.xml
类
DocumentImportXmlHelper


com.trs.presentation.documetimport.xml

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.documetimport.xml

类摘要
DocumentImportXmlHelper Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.documetimport.xml 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.documetimport.xml 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.documetimport.xml.DocumentImportXmlHelper


软件包 com.trs.presentation.documetimport.xml 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.documetimport.xml
的使用

没有 com.trs.presentation.documetimport.xml 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.documetimport.xml.DocumentImportXmlHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.documetimport.xml.DocumentImportXmlHelper
的使用

没有 com.trs.presentation.documetimport.xml.DocumentImportXmlHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ActorHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.ids
类 ActorHelper

java.lang.Object
    继承者  com.trs.presentation.ids.ActorHelper

public class ActorHelper
extends java.lang.Object

构造方法摘要
ActorHelper()
方法摘要
static Group | getGroupFromSSOGroup(com.trs.idm.client.actor.SSOGroup _group) 从IDS的组织中获取当前应用的组织
static java.lang.String[][] | getGroupInfos(java.lang.String groupPath) 从grouppath中获取组织的信息，包括ID和组织名
static GroupMgr | getGroupMgr() 获取GroupMgr
static User | getUserFromSSOUser(com.trs.idm.client.actor.SSOUser _user) 从IDS的用户中获取当前应用的用户
static UserMgr | getUserMgr() 获取UserMgr
static Group | saveGroup(com.trs.idm.client.actor.SSOGroup _group, Group currGroup, int parentId) 本地应用的保存组织操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActorHelper

public ActorHelper()
方法详细信息

getUserMgr

public static UserMgr getUserMgr()
获取UserMgr

返回：

getGroupMgr

public static GroupMgr getGroupMgr()
获取GroupMgr

返回：

getGroupInfos

public static java.lang.String[][] getGroupInfos(java.lang.String groupPath)
从grouppath中获取组织的信息，包括ID和组织名

参数：
groupPath -
返回：

saveGroup

public static Group saveGroup(com.trs.idm.client.actor.SSOGroup _group,
                              Group currGroup,
                              int parentId)
                       throws WCMException
本地应用的保存组织操作

参数：
_group -
currGroup -
parentId -
返回：
抛出：
WCMException

getGroupFromSSOGroup

public static Group getGroupFromSSOGroup(com.trs.idm.client.actor.SSOGroup _group)
从IDS的组织中获取当前应用的组织

参数：
groupNames -
返回：

getUserFromSSOUser

public static User getUserFromSSOUser(com.trs.idm.client.actor.SSOUser _user)
从IDS的用户中获取当前应用的用户

参数：
_user -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CAUserSync

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.ids
类 CAUserSync

java.lang.Object
    继承者  com.trs.presentation.ids.CAUserSync

public class CAUserSync
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
园林局项目定制:CA用户信息同步实现
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

嵌套类摘要
static class CAUserSync.UserInfo
用户的相关信息.
构造方法摘要
CAUserSync()
方法摘要
boolean | doUserAdd(CAUserSync.UserInfo userInfo) 同步用户添加
boolean | doUserDel(CAUserSync.UserInfo userInfo) 同步用户删除
boolean | doUserModify(CAUserSync.UserInfo userInfo) 同步用户修改
java.lang.String | getCaSvrURL() 从系统设置中获取CA服务回调的URL设置.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CAUserSync

public CAUserSync()
方法详细信息

doUserAdd

public boolean doUserAdd(CAUserSync.UserInfo userInfo)
同步用户添加

参数：
userInfo -
返回：

doUserModify

public boolean doUserModify(CAUserSync.UserInfo userInfo)
同步用户修改

参数：
userInfo -
返回：

doUserDel

public boolean doUserDel(CAUserSync.UserInfo userInfo)
同步用户删除

参数：
userInfo -
返回：

getCaSvrURL

public java.lang.String getCaSvrURL()
从系统设置中获取CA服务回调的URL设置.

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CAUserSync.UserInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.ids
类 CAUserSync.UserInfo

java.lang.Object
    继承者  com.trs.presentation.ids.CAUserSync.UserInfo
包容类：
CAUserSync
public static class CAUserSync.UserInfo
extends java.lang.Object

用户的相关信息.

构造方法摘要
CAUserSync.UserInfo(java.lang.String name)
方法摘要
java.lang.String | getName()
java.lang.String | getTrueName()
java.lang.String | getUserAddress()
java.lang.String | getUserEmail()
java.lang.String | getUserIdcardNum()
java.lang.String | getUserIdcode()
java.lang.String | getUserMobile()
java.lang.String | getUserPhone()
java.lang.String | getUserTitle()
void | setName(java.lang.String name)
void | setTrueName(java.lang.String trueName)
void | setUserAddress(java.lang.String userAddress)
void | setUserEmail(java.lang.String userEmail)
void | setUserIdcardNum(java.lang.String userIdcardNum)
void | setUserIdcode(java.lang.String userIdcode)
void | setUserMobile(java.lang.String userMobile)
void | setUserPhone(java.lang.String userPhone)
void | setUserTitle(java.lang.String userTitle)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CAUserSync.UserInfo

public CAUserSync.UserInfo(java.lang.String name)
方法详细信息

getUserAddress

public final java.lang.String getUserAddress()

setUserAddress

public final void setUserAddress(java.lang.String userAddress)

getUserEmail

public final java.lang.String getUserEmail()

setUserEmail

public final void setUserEmail(java.lang.String userEmail)

getUserIdcardNum

public final java.lang.String getUserIdcardNum()

setUserIdcardNum

public final void setUserIdcardNum(java.lang.String userIdcardNum)

getUserMobile

public final java.lang.String getUserMobile()

setUserMobile

public final void setUserMobile(java.lang.String userMobile)

getUserPhone

public final java.lang.String getUserPhone()

setUserPhone

public final void setUserPhone(java.lang.String userPhone)

getUserTitle

public final java.lang.String getUserTitle()

setUserTitle

public final void setUserTitle(java.lang.String userTitle)

getUserIdcode

public final java.lang.String getUserIdcode()

setUserIdcode

public final void setUserIdcode(java.lang.String userIdcode)

getName

public final java.lang.String getName()

setName

public final void setName(java.lang.String name)

getTrueName

public final java.lang.String getTrueName()

setTrueName

public final void setTrueName(java.lang.String trueName)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.ids
类
ActorHelper
CAUserSync
CAUserSync.UserInfo
RegFromConfig
WCM52Actor


com.trs.presentation.ids

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.ids

类摘要
ActorHelper |
CAUserSync | Title: TRS 内容协作平台（TRS WCM） Description: 园林局项目定制:CA用户信息同步实现 Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
CAUserSync.UserInfo | 用户的相关信息.
RegFromConfig | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCM52Actor | Title: TRS 内容协作平台（TRS WCM） Description: 用于同步IDS的用户和组织到WCM中 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.ids 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.ids 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.ids.ActorHelper
    • com.trs.presentation.ids.CAUserSync
    • com.trs.presentation.ids.CAUserSync.UserInfo
    • com.trs.presentation.ids.RegFromConfig (implements com.trs.infra.config.persistent.IConfigElement)
    • com.trs.idm.client.actor.StdHttpSessionBasedActor (implements com.trs.idm.client.actor.IServletAppActor)
      • com.trs.presentation.ids.WCM52Actor


软件包 com.trs.presentation.ids 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.ids
的使用

使用 com.trs.presentation.ids 的软件包
com.trs.presentation.ids

com.trs.presentation.ids 使用的 com.trs.presentation.ids 中的类
CAUserSync.UserInfo
用户的相关信息.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RegFromConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.ids
类 RegFromConfig

java.lang.Object
    继承者  com.trs.presentation.ids.RegFromConfig
所有已实现的接口：
IConfigElement, IXmlPersistentObject
public class RegFromConfig
extends java.lang.Object
implements IConfigElement

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RegFromConfig()
方法摘要
int | getGroupId() 获取所属组织ID
java.lang.String | getName() 获取配置对象的名称
java.lang.String | getRegFrom() 获取注册来源
void | setGroupId(int groupId) 设置所属组织ID
void | setName(java.lang.String _sName) 设置配置对象的名称
void | setRegFrom(java.lang.String regFrom) 设置注册来源
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RegFromConfig

public RegFromConfig()
方法详细信息

getGroupId

public int getGroupId()
获取所属组织ID

返回：

setGroupId

public void setGroupId(int groupId)
设置所属组织ID

参数：
groupId - 组织ID

getRegFrom

public java.lang.String getRegFrom()
获取注册来源

返回：
注册来源

setRegFrom

public void setRegFrom(java.lang.String regFrom)
设置注册来源

参数：
regFrom - 注册来源

setName

public void setName(java.lang.String _sName)
从接口 IConfigElement 复制的描述
设置配置对象的名称

指定者：
接口 IConfigElement 中的 setName
参数：
_sName - 配置对象的名称

getName

public java.lang.String getName()
从接口 IConfigElement 复制的描述
获取配置对象的名称

指定者：
接口 IConfigElement 中的 getName
返回：
配置对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCM52Actor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.ids
类 WCM52Actor

java.lang.Object
    继承者  com.trs.idm.client.actor.StdHttpSessionBasedActor
        继承者  com.trs.presentation.ids.WCM52Actor
所有已实现的接口：
com.trs.idm.client.actor.IServletAppActor
public class WCM52Actor
extends com.trs.idm.client.actor.StdHttpSessionBasedActor

Title: TRS 内容协作平台（TRS WCM）
Description:
用于同步IDS的用户和组织到WCM中
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCM52Actor()
方法摘要
boolean | addGroup(com.trs.idm.client.actor.SSOGroup _group, javax.servlet.http.HttpServletRequest req) 添加组织
boolean | addUser(com.trs.idm.client.actor.SSOUser _user, javax.servlet.http.HttpServletRequest arg1) 添加用户
boolean | checkLocalLogin(javax.servlet.http.HttpSession session)
boolean | delGroup(com.trs.idm.client.actor.SSOGroup _group, javax.servlet.http.HttpServletRequest req) 删除组织
boolean | disableUser(com.trs.idm.client.actor.SSOUser _user) 禁用用户
boolean | enableUser(com.trs.idm.client.actor.SSOUser _user) 开通用户
java.lang.String | extractUserName(javax.servlet.http.HttpServletRequest req)
java.lang.String | extractUserPwd(javax.servlet.http.HttpServletRequest req)
Group | getGroupByPath(java.lang.String[] groupNames) 从路径中获取组织
void | loadLoginUser(javax.servlet.http.HttpServletRequest _req, com.trs.idm.client.actor.SSOUser _user) 用户登录
void | logout(javax.servlet.http.HttpSession session) 登出
boolean | moveToGroup(com.trs.idm.client.actor.SSOUser _user, com.trs.idm.client.actor.SSOGroup _group) 将用户添加到组织中去
boolean | removeFromGroup(com.trs.idm.client.actor.SSOUser _user, com.trs.idm.client.actor.SSOGroup _group) 将用户添加到组织中去
boolean | removeUser(com.trs.idm.client.actor.SSOUser _user, javax.servlet.http.HttpServletRequest _req)
boolean | updateGroup(com.trs.idm.client.actor.SSOGroup _group, javax.servlet.http.HttpServletRequest req) 更新组织
boolean | updateUser(com.trs.idm.client.actor.SSOUser _user, javax.servlet.http.HttpServletRequest req)
boolean | userExist(com.trs.idm.client.actor.SSOUser _user)
从类 com.trs.idm.client.actor.StdHttpSessionBasedActor 继承的方法
checkLocalLogin, extractExtraInput, getSessionId, loadAnonymous, loadLoginUser, logout, start, stop, unremoveUser, useStandardHttpSession
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCM52Actor

public WCM52Actor()
方法详细信息

checkLocalLogin

public boolean checkLocalLogin(javax.servlet.http.HttpSession session)
指定者：
类 com.trs.idm.client.actor.StdHttpSessionBasedActor 中的 checkLocalLogin

loadLoginUser

public void loadLoginUser(javax.servlet.http.HttpServletRequest _req,
                          com.trs.idm.client.actor.SSOUser _user)
                   throws com.trs.idm.client.actor.ActorException
用户登录

指定者：
类 com.trs.idm.client.actor.StdHttpSessionBasedActor 中的 loadLoginUser
抛出：
com.trs.idm.client.actor.ActorException

logout

public void logout(javax.servlet.http.HttpSession session)
            throws com.trs.idm.client.actor.ActorException
登出

指定者：
类 com.trs.idm.client.actor.StdHttpSessionBasedActor 中的 logout
抛出：
com.trs.idm.client.actor.ActorException

addUser

public boolean addUser(com.trs.idm.client.actor.SSOUser _user,
                       javax.servlet.http.HttpServletRequest arg1)
                throws com.trs.idm.client.actor.ActorException
添加用户

抛出：
com.trs.idm.client.actor.ActorException

disableUser

public boolean disableUser(com.trs.idm.client.actor.SSOUser _user)
                    throws com.trs.idm.client.actor.ActorException
禁用用户

抛出：
com.trs.idm.client.actor.ActorException

enableUser

public boolean enableUser(com.trs.idm.client.actor.SSOUser _user)
                   throws com.trs.idm.client.actor.ActorException
开通用户

抛出：
com.trs.idm.client.actor.ActorException

extractUserName

public java.lang.String extractUserName(javax.servlet.http.HttpServletRequest req)
                                 throws com.trs.idm.client.actor.ActorException
抛出：
com.trs.idm.client.actor.ActorException

extractUserPwd

public java.lang.String extractUserPwd(javax.servlet.http.HttpServletRequest req)
                                throws com.trs.idm.client.actor.ActorException
抛出：
com.trs.idm.client.actor.ActorException

removeUser

public boolean removeUser(com.trs.idm.client.actor.SSOUser _user,
                          javax.servlet.http.HttpServletRequest _req)
                   throws com.trs.idm.client.actor.ActorException
抛出：
com.trs.idm.client.actor.ActorException

updateUser

public boolean updateUser(com.trs.idm.client.actor.SSOUser _user,
                          javax.servlet.http.HttpServletRequest req)
                   throws com.trs.idm.client.actor.ActorException
抛出：
com.trs.idm.client.actor.ActorException

userExist

public boolean userExist(com.trs.idm.client.actor.SSOUser _user)
                  throws com.trs.idm.client.actor.ActorException
抛出：
com.trs.idm.client.actor.ActorException

addGroup

public boolean addGroup(com.trs.idm.client.actor.SSOGroup _group,
                        javax.servlet.http.HttpServletRequest req)
添加组织

指定者：
接口 com.trs.idm.client.actor.IServletAppActor 中的 addGroup
覆盖：
类 com.trs.idm.client.actor.StdHttpSessionBasedActor 中的 addGroup

updateGroup

public boolean updateGroup(com.trs.idm.client.actor.SSOGroup _group,
                           javax.servlet.http.HttpServletRequest req)
更新组织

指定者：
接口 com.trs.idm.client.actor.IServletAppActor 中的 updateGroup
覆盖：
类 com.trs.idm.client.actor.StdHttpSessionBasedActor 中的 updateGroup

delGroup

public boolean delGroup(com.trs.idm.client.actor.SSOGroup _group,
                        javax.servlet.http.HttpServletRequest req)
删除组织

指定者：
接口 com.trs.idm.client.actor.IServletAppActor 中的 delGroup
覆盖：
类 com.trs.idm.client.actor.StdHttpSessionBasedActor 中的 delGroup

getGroupByPath

public Group getGroupByPath(java.lang.String[] groupNames)
从路径中获取组织

参数：
_sGroupPath -
返回：

moveToGroup

public boolean moveToGroup(com.trs.idm.client.actor.SSOUser _user,
                           com.trs.idm.client.actor.SSOGroup _group)
将用户添加到组织中去

指定者：
接口 com.trs.idm.client.actor.IServletAppActor 中的 moveToGroup
覆盖：
类 com.trs.idm.client.actor.StdHttpSessionBasedActor 中的 moveToGroup
参数：
_user - IDS中的用户对象
_group - IDS中的组织对象

removeFromGroup

public boolean removeFromGroup(com.trs.idm.client.actor.SSOUser _user,
                               com.trs.idm.client.actor.SSOGroup _group)
将用户添加到组织中去

指定者：
接口 com.trs.idm.client.actor.IServletAppActor 中的 removeFromGroup
覆盖：
类 com.trs.idm.client.actor.StdHttpSessionBasedActor 中的 removeFromGroup
参数：
_user - IDS中的用户对象
_group - IDS中的组织对象
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.ids.ActorHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.ids.ActorHelper
的使用

没有 com.trs.presentation.ids.ActorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.ids.CAUserSync 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.ids.CAUserSync
的使用

没有 com.trs.presentation.ids.CAUserSync 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.ids.CAUserSync.UserInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.ids.CAUserSync.UserInfo
的使用

使用 CAUserSync.UserInfo 的软件包
com.trs.presentation.ids

com.trs.presentation.ids 中 CAUserSync.UserInfo 的使用

参数类型为 CAUserSync.UserInfo 的 com.trs.presentation.ids 中的方法
boolean | CAUserSync.doUserAdd(CAUserSync.UserInfo userInfo) 同步用户添加
boolean | CAUserSync.doUserDel(CAUserSync.UserInfo userInfo) 同步用户删除
boolean | CAUserSync.doUserModify(CAUserSync.UserInfo userInfo) 同步用户修改

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.ids.RegFromConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.ids.RegFromConfig
的使用

没有 com.trs.presentation.ids.RegFromConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.ids.WCM52Actor 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.ids.WCM52Actor
的使用

没有 com.trs.presentation.ids.WCM52Actor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


JspChecker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.jsputil
类 JspChecker

java.lang.Object
    继承者  com.trs.presentation.jsputil.JspChecker

public class JspChecker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
JSP正确性验证对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
JspChecker(java.lang.String _sJSPRootPath, java.lang.String _sAppName)
JspChecker(java.lang.String _sJSPRootPath, java.lang.String _sAppName, java.lang.String host, int port)
方法摘要
void | run()
void | setAuthDetail(java.lang.String username, java.lang.String password, java.lang.String authPage)
void | setResult(boolean needStore)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JspChecker

public JspChecker(java.lang.String _sJSPRootPath,
                  java.lang.String _sAppName)

JspChecker

public JspChecker(java.lang.String _sJSPRootPath,
                  java.lang.String _sAppName,
                  java.lang.String host,
                  int port)
方法详细信息

setAuthDetail

public void setAuthDetail(java.lang.String username,
                          java.lang.String password,
                          java.lang.String authPage)

setResult

public void setResult(boolean needStore)

run

public void run()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.jsputil
类
JspChecker


com.trs.presentation.jsputil

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.jsputil

类摘要
JspChecker Title: TRS 内容协作平台（TRS WCM）
Description:
JSP正确性验证对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.jsputil 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.jsputil 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.jsputil.JspChecker


软件包 com.trs.presentation.jsputil 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.jsputil
的使用

没有 com.trs.presentation.jsputil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.jsputil.JspChecker 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.jsputil.JspChecker
的使用

没有 com.trs.presentation.jsputil.JspChecker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


LocaleServer

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.locale
类 LocaleServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.presentation.locale.LocaleServer
所有已实现的接口：
IServer
public final class LocaleServer
extends BaseServer

Title: TRS 内容协作平台（TRS WCM）
Description:
i18n
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
LocaleServer()
方法摘要
static java.util.Locale | getCurrentLocale()
static CMyDateTime | getDateTime(java.lang.String _sKey) 已过时。 no need?
static java.lang.String | getFavorLanguageKey()
static java.lang.String[] | getLanguageKeys() 获取系统所有支持语种对应的Key
static java.lang.String | getString(java.lang.String _sKey, java.lang.String _sDefaultValue) 获取特定语种资源配置中的资源值（数值型）
static void | setFavorLanguage(User _currUser, java.lang.String _sLanguageKey) 设置个人偏好
static void | setFavorLocale(User _currUser, java.util.Locale _locale) 设置用户选用的Locale
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LocaleServer

public LocaleServer()
方法详细信息

getString

public static java.lang.String getString(java.lang.String _sKey,
                                         java.lang.String _sDefaultValue)
获取特定语种资源配置中的资源值（数值型）

参数：
_sKey - 资源名称
_sDefaultValue - 默认的返回值
返回：
资源的具体值
抛出：
java.lang.Exception - 如果类型不匹配、没有找到该键值或者资源文件不存在，则返回默认值，为空串("")

getDateTime

public static CMyDateTime getDateTime(java.lang.String _sKey)
已过时。 no need?

获取特定语种资源配置中的资源值（日期型）

参数：
_sKey - 资源名称
返回：
资源的具体值
抛出：
java.lang.Exception - 如果类型不匹配、没有找到该键值或者资源文件不存在，则返回默认值，为当前日期

getCurrentLocale

public static java.util.Locale getCurrentLocale()

setFavorLanguage

public static void setFavorLanguage(User _currUser,
                                    java.lang.String _sLanguageKey)
                             throws WCMException
设置个人偏好

参数：
_currUser -
_sLanguageKey -
抛出：
WCMException

setFavorLocale

public static void setFavorLocale(User _currUser,
                                  java.util.Locale _locale)
                           throws WCMException
设置用户选用的Locale

参数：
_currUser - 当前用户
_locale - 用户使用的Locale
抛出：
WCMException

getFavorLanguageKey

public static java.lang.String getFavorLanguageKey()

getLanguageKeys

public static java.lang.String[] getLanguageKeys()
获取系统所有支持语种对应的Key

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.locale
类
LocaleServer


com.trs.presentation.locale

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.locale

类摘要
LocaleServer Title: TRS 内容协作平台（TRS WCM）
Description:
i18n
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.locale 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.locale 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.presentation.locale.LocaleServer


软件包 com.trs.presentation.locale 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.locale
的使用

没有 com.trs.presentation.locale 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.locale.LocaleServer 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.locale.LocaleServer
的使用

没有 com.trs.presentation.locale.LocaleServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.presentation.login
类
SessionListener
UserLCListenerForLogin


com.trs.presentation.login

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.login

类摘要
SessionListener | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UserLCListenerForLogin | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.login 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.login 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.login.SessionListener (implements com.trs.infra.cluster.session.Acknowledged, javax.servlet.http.HttpSessionBindingListener, java.io.Serializable)
    • com.trs.presentation.login.UserLCListenerForLogin (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel, com.trs.infra.persistent.listener.IObjectLCListenerOnModify)


软件包 com.trs.presentation.login 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.login
的使用

没有 com.trs.presentation.login 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SessionListener

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.login
类 SessionListener

java.lang.Object
    继承者  com.trs.presentation.login.SessionListener
所有已实现的接口：
com.trs.infra.cluster.session.Acknowledged, java.io.Serializable, java.util.EventListener, javax.servlet.http.HttpSessionBindingListener
public class SessionListener
extends java.lang.Object
implements javax.servlet.http.HttpSessionBindingListener, java.io.Serializable, com.trs.infra.cluster.session.Acknowledged

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
SessionListener(java.lang.Integer _oUserKey)
方法摘要
static int | getCount()
static java.util.Vector | getOnlineUsers()
static int | getVersion()
void | valueBound(javax.servlet.http.HttpSessionBindingEvent event)
void | valueUnbound(javax.servlet.http.HttpSessionBindingEvent event)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SessionListener

public SessionListener(java.lang.Integer _oUserKey)
方法详细信息

getCount

public static int getCount()

getOnlineUsers

public static java.util.Vector getOnlineUsers()

valueBound

public void valueBound(javax.servlet.http.HttpSessionBindingEvent event)
指定者：
接口 javax.servlet.http.HttpSessionBindingListener 中的 valueBound

valueUnbound

public void valueUnbound(javax.servlet.http.HttpSessionBindingEvent event)
指定者：
接口 javax.servlet.http.HttpSessionBindingListener 中的 valueUnbound

getVersion

public static int getVersion()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


UserLCListenerForLogin

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.login
类 UserLCListenerForLogin

java.lang.Object
    继承者  com.trs.presentation.login.UserLCListenerForLogin
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel, IObjectLCListenerOnModify
public class UserLCListenerForLogin
extends java.lang.Object
implements IObjectLCListenerOnDel, IObjectLCListenerOnModify

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
UserLCListenerForLogin()
方法摘要
void | notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType) 删除一个对象后通知所有的Cache
void | notifyOnModifyObj(BaseObj _oObjModified, int _nEventType) 修改一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserLCListenerForLogin

public UserLCListenerForLogin()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
                    throws WCMException
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
抛出：
WCMException

notifyOnModifyObj

public void notifyOnModifyObj(BaseObj _oObjModified,
                              int _nEventType)
                       throws WCMException
从接口 IObjectLCListenerOnModify 复制的描述
修改一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnModify 中的 notifyOnModifyObj
参数：
_oObjModified - 被修改的对象
_nEventType - TODO
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.login.SessionListener 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.login.SessionListener
的使用

没有 com.trs.presentation.login.SessionListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.login.UserLCListenerForLogin 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.login.UserLCListenerForLogin
的使用

没有 com.trs.presentation.login.UserLCListenerForLogin 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AdvSearchNavHandler

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 AdvSearchNavHandler

java.lang.Object
    继承者  com.trs.presentation.nav.AdvSearchNavHandler
所有已实现的接口：
INavHandler
public class AdvSearchNavHandler
extends java.lang.Object
implements INavHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AdvSearchNavHandler()
方法摘要
java.lang.String | makeDefaultMainURL() 构造主窗口的地址
java.lang.String | toHandlerkey() 产生指定Handler的Key
java.lang.String | toNavInfoJSON(java.util.Map oArguments) 返回一个可能包含navMode,mainFirstLink的HashMap对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdvSearchNavHandler

public AdvSearchNavHandler()
方法详细信息

makeDefaultMainURL

public java.lang.String makeDefaultMainURL()
从接口 INavHandler 复制的描述
构造主窗口的地址

指定者：
接口 INavHandler 中的 makeDefaultMainURL
返回：

toHandlerkey

public java.lang.String toHandlerkey()
从接口 INavHandler 复制的描述
产生指定Handler的Key

指定者：
接口 INavHandler 中的 toHandlerkey
返回：

toNavInfoJSON

public java.lang.String toNavInfoJSON(java.util.Map oArguments)
从接口 INavHandler 复制的描述
返回一个可能包含navMode,mainFirstLink的HashMap对象

指定者：
接口 INavHandler 中的 toNavInfoJSON
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChannelNavHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 ChannelNavHandler

java.lang.Object
    继承者  com.trs.presentation.nav.ChannelNavHandler
所有已实现的接口：
INavHandler
public class ChannelNavHandler
extends java.lang.Object
implements INavHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelNavHandler()
方法摘要
java.lang.String | makeDefaultMainURL() 构造主窗口的地址
java.lang.String | toHandlerkey() 产生指定Handler的Key
java.lang.String | toNavInfoJSON(java.util.Map oArguments) 返回一个可能包含navMode,mainFirstLink的HashMap对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelNavHandler

public ChannelNavHandler()
方法详细信息

makeDefaultMainURL

public java.lang.String makeDefaultMainURL()
从接口 INavHandler 复制的描述
构造主窗口的地址

指定者：
接口 INavHandler 中的 makeDefaultMainURL
返回：

toHandlerkey

public java.lang.String toHandlerkey()
从接口 INavHandler 复制的描述
产生指定Handler的Key

指定者：
接口 INavHandler 中的 toHandlerkey
返回：

toNavInfoJSON

public java.lang.String toNavInfoJSON(java.util.Map oArguments)
从接口 INavHandler 复制的描述
返回一个可能包含navMode,mainFirstLink的HashMap对象

指定者：
接口 INavHandler 中的 toNavInfoJSON
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassInfoNavHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 ClassInfoNavHandler

java.lang.Object
    继承者  com.trs.presentation.nav.ClassInfoNavHandler
所有已实现的接口：
INavHandler
public class ClassInfoNavHandler
extends java.lang.Object
implements INavHandler

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ClassInfoNavHandler()
方法摘要
java.lang.String | makeDefaultMainURL() 构造主窗口的地址
java.lang.String | toHandlerkey() 产生指定Handler的Key
java.lang.String | toNavInfoJSON(java.util.Map _oArguments) 返回一个可能包含navMode,mainFirstLink的HashMap对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassInfoNavHandler

public ClassInfoNavHandler()
方法详细信息

makeDefaultMainURL

public java.lang.String makeDefaultMainURL()
                                    throws WCMException
从接口 INavHandler 复制的描述
构造主窗口的地址

指定者：
接口 INavHandler 中的 makeDefaultMainURL
返回：
抛出：
WCMException

toHandlerkey

public java.lang.String toHandlerkey()
从接口 INavHandler 复制的描述
产生指定Handler的Key

指定者：
接口 INavHandler 中的 toHandlerkey
返回：

toNavInfoJSON

public java.lang.String toNavInfoJSON(java.util.Map _oArguments)
                               throws WCMException
从接口 INavHandler 复制的描述
返回一个可能包含navMode,mainFirstLink的HashMap对象

指定者：
接口 INavHandler 中的 toNavInfoJSON
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INavHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
接口 INavHandler

所有已知实现类：
AdvSearchNavHandler, ChannelNavHandler, ClassInfoNavHandler
public interface INavHandler

方法摘要
java.lang.String | makeDefaultMainURL() 构造主窗口的地址
java.lang.String | toHandlerkey() 产生指定Handler的Key
java.lang.String | toNavInfoJSON(java.util.Map oArguments) 返回一个可能包含navMode,mainFirstLink的HashMap对象

方法详细信息

toNavInfoJSON

java.lang.String toNavInfoJSON(java.util.Map oArguments)
                               throws WCMException
返回一个可能包含navMode,mainFirstLink的HashMap对象

抛出：
WCMException

makeDefaultMainURL

java.lang.String makeDefaultMainURL()
                                    throws WCMException
构造主窗口的地址

返回：
抛出：
WCMException

toHandlerkey

java.lang.String toHandlerkey()
                              throws WCMException
产生指定Handler的Key

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NavConstatns

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 NavConstatns

java.lang.Object
    继承者  com.trs.presentation.nav.NavConstatns

public class NavConstatns
extends java.lang.Object

字段摘要
static int | MULTI_MODE 包含分类法在内的导航模式
static int | SIMPLE_MODE 仅有高级检索和栏目树构成的导航模式
构造方法摘要
NavConstatns()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SIMPLE_MODE

public static final int SIMPLE_MODE
仅有高级检索和栏目树构成的导航模式

另请参见：
常量字段值

MULTI_MODE

public static final int MULTI_MODE
包含分类法在内的导航模式

另请参见：
常量字段值
构造方法详细信息

NavConstatns

public NavConstatns()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NavHandlerFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 NavHandlerFactory

java.lang.Object
    继承者  com.trs.presentation.nav.NavHandlerFactory

public class NavHandlerFactory
extends java.lang.Object

构造方法摘要
NavHandlerFactory()
方法摘要
static INavHandler getNavHandler(java.lang.String _sItemKey)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NavHandlerFactory

public NavHandlerFactory()
方法详细信息

getNavHandler

public static INavHandler getNavHandler(java.lang.String _sItemKey)
                                 throws WCMException
参数：
_sItemKey -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.nav
接口
INavHandler
类
AdvSearchNavHandler
ChannelNavHandler
ClassInfoNavHandler
NavConstatns
NavHandlerFactory
RadarTreeCreator
TreeCreator
TreeCreatorTest
TreeNodeCalctor


com.trs.presentation.nav

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.nav

接口摘要
INavHandler

类摘要
AdvSearchNavHandler | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelNavHandler | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoNavHandler | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
NavConstatns |
NavHandlerFactory |
RadarTreeCreator | Title: TRS 内容协作平台（TRS WCM） Description: 为雷达/NetSnap提供站点/栏目树.
TreeCreator | Title: TRS 内容协作平台（TRS WCM） Description: 导航树的产生器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TreeCreatorTest |
TreeNodeCalctor |


com.trs.presentation.nav 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.nav 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.nav.AdvSearchNavHandler (implements com.trs.presentation.nav.INavHandler)
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.trs.presentation.nav.TreeCreatorTest
    • com.trs.presentation.nav.ChannelNavHandler (implements com.trs.presentation.nav.INavHandler)
    • com.trs.presentation.nav.ClassInfoNavHandler (implements com.trs.presentation.nav.INavHandler)
    • com.trs.presentation.nav.NavConstatns
    • com.trs.presentation.nav.NavHandlerFactory
    • com.trs.presentation.nav.RadarTreeCreator
    • com.trs.presentation.nav.TreeCreator
    • com.trs.presentation.nav.TreeNodeCalctor

接口分层结构

  • com.trs.presentation.nav.INavHandler


软件包 com.trs.presentation.nav 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.nav
的使用

使用 com.trs.presentation.nav 的软件包
com.trs.presentation.nav

com.trs.presentation.nav 使用的 com.trs.presentation.nav 中的类
INavHandler
TreeNodeCalctor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RadarTreeCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 RadarTreeCreator

java.lang.Object
    继承者  com.trs.presentation.nav.RadarTreeCreator

public class RadarTreeCreator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
为雷达/NetSnap提供站点/栏目树.
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
RadarTreeCreator(java.lang.String userName, int rightIndex, java.lang.String type, int parentId)
方法摘要
java.lang.String | getTreeInfo()
void | setAddRoot(boolean addRoot)
void | setEncoding(java.lang.String encoding)
void | setSiteType(int siteType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RadarTreeCreator

public RadarTreeCreator(java.lang.String userName,
                        int rightIndex,
                        java.lang.String type,
                        int parentId)
方法详细信息

setAddRoot

public void setAddRoot(boolean addRoot)

setEncoding

public void setEncoding(java.lang.String encoding)

setSiteType

public void setSiteType(int siteType)

getTreeInfo

public java.lang.String getTreeInfo()
                             throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 TreeCreator

java.lang.Object
    继承者  com.trs.presentation.nav.TreeCreator

public class TreeCreator
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
导航树的产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | VIEW_TYPE_CHECKBOX
static int | VIEW_TYPE_NORMAL
static int | VIEW_TYPE_RADIO
构造方法摘要
TreeCreator(User _loginUser, RequestHelper _requestHelper, javax.servlet.jsp.JspWriter _out)
方法摘要
WebSites | getWebSites(int _nSiteType)
boolean | hasRight(Channel _channel)
boolean | hasSuperRight(BaseChannel host, CMSObj _aUser) 判断当前Operator对于指定结点是否有Super权限
static void | main(java.lang.String[] args)
void | writeHTMLContainsChannels() 产生包含指定栏目的HTML
void | writeHTMLOfAPath() 输出当前节点路径的HTML 节点路径有逗号(,)分割的节点ID组成 通过NodeIds参数传入
void | writeTopChildrenHTML() 根据父结点的载入子对象的HTML信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

VIEW_TYPE_NORMAL

public static final int VIEW_TYPE_NORMAL
另请参见：
常量字段值

VIEW_TYPE_RADIO

public static final int VIEW_TYPE_RADIO
另请参见：
常量字段值

VIEW_TYPE_CHECKBOX

public static final int VIEW_TYPE_CHECKBOX
另请参见：
常量字段值
构造方法详细信息

TreeCreator

public TreeCreator(User _loginUser,
                   RequestHelper _requestHelper,
                   javax.servlet.jsp.JspWriter _out)
            throws WCMException
抛出：
WCMException
方法详细信息

writeTopChildrenHTML

public void writeTopChildrenHTML()
                          throws java.lang.Exception
根据父结点的载入子对象的HTML信息

参数：
_sParentType -
_nParentId -
抛出：
java.lang.Exception

writeHTMLOfAPath

public void writeHTMLOfAPath()
                      throws java.lang.Exception
输出当前节点路径的HTML 节点路径有逗号(,)分割的节点ID组成 通过NodeIds参数传入

抛出：
WCMException
java.lang.Exception

writeHTMLContainsChannels

public void writeHTMLContainsChannels()
                               throws java.lang.Exception
产生包含指定栏目的HTML

抛出：
java.lang.Exception

getWebSites

public WebSites getWebSites(int _nSiteType)
                     throws WCMException
抛出：
WCMException

hasSuperRight

public boolean hasSuperRight(BaseChannel host,
                             CMSObj _aUser)
                      throws WCMException
判断当前Operator对于指定结点是否有Super权限

参数：
host -
_aUser - TODO
返回：
抛出：
WCMException

hasRight

public boolean hasRight(Channel _channel)
                 throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeCreatorTest

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 TreeCreatorTest

java.lang.Object
    继承者  junit.framework.Assert
        继承者  junit.framework.TestCase
            继承者  com.trs.presentation.nav.TreeCreatorTest
所有已实现的接口：
junit.framework.Test
public class TreeCreatorTest
extends junit.framework.TestCase

构造方法摘要
TreeCreatorTest()
方法摘要
void | testWriteHTMLOfAPath()
void | testWriteTreeHTML()
从类 junit.framework.TestCase 继承的方法
countTestCases, getName, run, run, runBare, setName, toString
从类 junit.framework.Assert 继承的方法
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TreeCreatorTest

public TreeCreatorTest()
方法详细信息

testWriteTreeHTML

public void testWriteTreeHTML()
                       throws java.lang.Exception
抛出：
java.lang.Exception

testWriteHTMLOfAPath

public void testWriteHTMLOfAPath()
                          throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeNodeCalctor

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.nav
类 TreeNodeCalctor

java.lang.Object
    继承者  com.trs.presentation.nav.TreeNodeCalctor

public class TreeNodeCalctor
extends java.lang.Object

构造方法摘要
TreeNodeCalctor(int _nChannelId, int _nChildMaxCount)
TreeNodeCalctor(java.lang.String _sChannelIds, User _loginUser)
TreeNodeCalctor(WebSite _site, Channels _srcChannels)
方法摘要
int | getChannelId()
TreeNodeCalctor | getExpandNodeById(int _nChannelId)
TreeNodeCalctor[] | getNeedExpandTreeNodes()
WebSite | getRoot()
WebSites | getSites()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TreeNodeCalctor

public TreeNodeCalctor(java.lang.String _sChannelIds,
                       User _loginUser)

TreeNodeCalctor

public TreeNodeCalctor(WebSite _site,
                       Channels _srcChannels)

TreeNodeCalctor

public TreeNodeCalctor(int _nChannelId,
                       int _nChildMaxCount)
方法详细信息

getChannelId

public int getChannelId()
返回：

getSites

public WebSites getSites()
返回：

getNeedExpandTreeNodes

public TreeNodeCalctor[] getNeedExpandTreeNodes()
返回：

getRoot

public WebSite getRoot()
返回：

getExpandNodeById

public TreeNodeCalctor getExpandNodeById(int _nChannelId)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.nav.AdvSearchNavHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.AdvSearchNavHandler
的使用

没有 com.trs.presentation.nav.AdvSearchNavHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.nav.ChannelNavHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.ChannelNavHandler
的使用

没有 com.trs.presentation.nav.ChannelNavHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.nav.ClassInfoNavHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.ClassInfoNavHandler
的使用

没有 com.trs.presentation.nav.ClassInfoNavHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.presentation.nav.INavHandler 的使用

上一个 下一个 框架 无框架

接口 com.trs.presentation.nav.INavHandler
的使用

使用 INavHandler 的软件包
com.trs.presentation.nav

com.trs.presentation.nav 中 INavHandler 的使用

实现 INavHandler 的 com.trs.presentation.nav 中的类
class | AdvSearchNavHandler Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelNavHandler Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ClassInfoNavHandler Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 INavHandler 的 com.trs.presentation.nav 中的方法
static INavHandler NavHandlerFactory.getNavHandler(java.lang.String _sItemKey)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.nav.NavConstatns 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.NavConstatns
的使用

没有 com.trs.presentation.nav.NavConstatns 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.nav.NavHandlerFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.NavHandlerFactory
的使用

没有 com.trs.presentation.nav.NavHandlerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.nav.RadarTreeCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.RadarTreeCreator
的使用

没有 com.trs.presentation.nav.RadarTreeCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.nav.TreeCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.TreeCreator
的使用

没有 com.trs.presentation.nav.TreeCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.nav.TreeCreatorTest 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.TreeCreatorTest
的使用

没有 com.trs.presentation.nav.TreeCreatorTest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.nav.TreeNodeCalctor 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.nav.TreeNodeCalctor
的使用

使用 TreeNodeCalctor 的软件包
com.trs.presentation.nav

com.trs.presentation.nav 中 TreeNodeCalctor 的使用

返回 TreeNodeCalctor 的 com.trs.presentation.nav 中的方法
TreeNodeCalctor | TreeNodeCalctor.getExpandNodeById(int _nChannelId)
TreeNodeCalctor[] | TreeNodeCalctor.getNeedExpandTreeNodes()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.presentation.navigation
类
TreeItem


com.trs.presentation.navigation

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.navigation

类摘要
TreeItem Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.navigation 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.navigation 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.navigation.TreeItem


软件包 com.trs.presentation.navigation 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.navigation
的使用

使用 com.trs.presentation.navigation 的软件包
com.trs.presentation.navigation

com.trs.presentation.navigation 使用的 com.trs.presentation.navigation 中的类
TreeItem
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TreeItem

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.navigation
类 TreeItem

java.lang.Object
    继承者  com.trs.presentation.navigation.TreeItem

public class TreeItem
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
boolean | m_bChecked
boolean | m_bOpened
static java.util.Hashtable | m_hTreeRes
int | m_nType
构造方法摘要
TreeItem(int _nTreeId, java.lang.String _sName, java.lang.String _sId, java.lang.String _sToolTip, java.lang.String _sHref, TreeItem _oParentItem, boolean _bHasChildren)
方法摘要
void | addChild(TreeItem _oChildItem)
void | clear()
static java.lang.String | getNodeHref(int _nChannelId, int _nOperType)
static java.lang.String | getRootHref(int _nSiteId, int _nOperType)
boolean | isLast()
static void | main(java.lang.String[] args)
java.lang.String | toHTML()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

m_bOpened

public boolean m_bOpened

m_nType

public int m_nType

m_bChecked

public boolean m_bChecked

m_hTreeRes

public static java.util.Hashtable m_hTreeRes
构造方法详细信息

TreeItem

public TreeItem(int _nTreeId,
                java.lang.String _sName,
                java.lang.String _sId,
                java.lang.String _sToolTip,
                java.lang.String _sHref,
                TreeItem _oParentItem,
                boolean _bHasChildren)
方法详细信息

addChild

public void addChild(TreeItem _oChildItem)

clear

public void clear()

isLast

public boolean isLast()

toHTML

public java.lang.String toHTML()

getRootHref

public static java.lang.String getRootHref(int _nSiteId,
                                           int _nOperType)
                                    throws WCMException
抛出：
WCMException

getNodeHref

public static java.lang.String getNodeHref(int _nChannelId,
                                           int _nOperType)
                                    throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.navigation.TreeItem 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.navigation.TreeItem
的使用

使用 TreeItem 的软件包
com.trs.presentation.navigation

com.trs.presentation.navigation 中 TreeItem 的使用

参数类型为 TreeItem 的 com.trs.presentation.navigation 中的方法
 void TreeItem.addChild(TreeItem _oChildItem)

参数类型为 TreeItem 的 com.trs.presentation.navigation 中的构造方法
TreeItem(int _nTreeId, java.lang.String _sName, java.lang.String _sId, java.lang.String _sToolTip, java.lang.String _sHref, TreeItem _oParentItem, boolean _bHasChildren)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.presentation.plugin
类
PluginConfig


com.trs.presentation.plugin

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.plugin

类摘要
PluginConfig


com.trs.presentation.plugin 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.plugin 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.plugin.PluginConfig


软件包 com.trs.presentation.plugin 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.plugin
的使用

没有 com.trs.presentation.plugin 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PluginConfig

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.plugin
类 PluginConfig

java.lang.Object
    继承者  com.trs.presentation.plugin.PluginConfig

public class PluginConfig
extends java.lang.Object

构造方法摘要
PluginConfig()
方法摘要
static boolean | isStartPhoto()
static boolean | isStartVideo()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PluginConfig

public PluginConfig()
方法详细信息

isStartPhoto

public static boolean isStartPhoto()
返回：

isStartVideo

public static boolean isStartVideo()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.plugin.PluginConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.plugin.PluginConfig
的使用

没有 com.trs.presentation.plugin.PluginConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.presentation.portal
类
PortalHelper


com.trs.presentation.portal

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.portal

类摘要
PortalHelper Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.portal 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.portal 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.portal.PortalHelper


软件包 com.trs.presentation.portal 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.portal
的使用

没有 com.trs.presentation.portal 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PortalHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.portal
类 PortalHelper

java.lang.Object
    继承者  com.trs.presentation.portal.PortalHelper

public class PortalHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PortalHelper()
方法摘要
static java.lang.String | getDocumentsByChannelId(int _nChannelId, int _nMaxSize, int _nMaxLength) 得到频道的文档 for portal/portal_documents_of_channel.jsp
static java.lang.String | getMyFlowDocs(int _nMaxSize, int _nMaxLength) 得到需要我处理的文档 for portal/portal_mywork_flowdoc.jsp
static java.lang.String | getRecentChannels(int _nMaxSize) 得到我最近访问的频道 for portal/portal_recent_channel.jsp
static java.lang.String | getRecentDocs(int _nMaxSize, int _nMaxLength) 我最近处理的文档信息 for portal/portal_recent_doc.jsp
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PortalHelper

public PortalHelper()
方法详细信息

getRecentDocs

public static java.lang.String getRecentDocs(int _nMaxSize,
                                             int _nMaxLength)
                                      throws WCMException
我最近处理的文档信息 for portal/portal_recent_doc.jsp

参数：
_nMaxSize -
返回：
@throws WCMException
抛出：
WCMException

getRecentChannels

public static java.lang.String getRecentChannels(int _nMaxSize)
                                          throws WCMException
得到我最近访问的频道 for portal/portal_recent_channel.jsp

参数：
_nMaxSize -
返回：
@throws WCMException
抛出：
WCMException

getMyFlowDocs

public static java.lang.String getMyFlowDocs(int _nMaxSize,
                                             int _nMaxLength)
                                      throws WCMException
得到需要我处理的文档 for portal/portal_mywork_flowdoc.jsp

参数：
_nMaxSize -
返回：
@throws WCMException
抛出：
WCMException

getDocumentsByChannelId

public static java.lang.String getDocumentsByChannelId(int _nChannelId,
                                                       int _nMaxSize,
                                                       int _nMaxLength)
                                                throws WCMException
得到频道的文档 for portal/portal_documents_of_channel.jsp

参数：
_nChannelId -
_nMaxSize -
返回：
@throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.portal.PortalHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.portal.PortalHelper
的使用

没有 com.trs.presentation.portal.PortalHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CMyTemplateWizard

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.publish.template
类 CMyTemplateWizard

java.lang.Object
    继承者  com.trs.presentation.publish.template.CMyTemplateWizard

public class CMyTemplateWizard
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
模板置标添加向导
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | PARAM_TYPE_BOOLEAN
static int | PARAM_TYPE_ENUMER
static int | PARAM_TYPE_ENUMER_EXT
static int | PARAM_TYPE_INT
static int | PARAM_TYPE_LONGTEXT
static int | PARAM_TYPE_TEXT
构造方法摘要
CMyTemplateWizard()
方法摘要
static java.util.List | getParameters(int _nTempId) 获取指定置标代码样例中的参数列表
static java.lang.String | toTemplateCode(int _nTempId, java.lang.String _sXMLString) 根据指定置标模板ID及传入的参数数据XML构造一份置标代码
static java.lang.String | toTemplateCode(java.lang.String _sTemplateContent, java.lang.String _sXMLString) 根据指定置标代码样例及传入的参数数据XML构造一份置标代码
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PARAM_TYPE_ENUMER

public static final int PARAM_TYPE_ENUMER
另请参见：
常量字段值

PARAM_TYPE_ENUMER_EXT

public static final int PARAM_TYPE_ENUMER_EXT
另请参见：
常量字段值

PARAM_TYPE_BOOLEAN

public static final int PARAM_TYPE_BOOLEAN
另请参见：
常量字段值

PARAM_TYPE_INT

public static final int PARAM_TYPE_INT
另请参见：
常量字段值

PARAM_TYPE_TEXT

public static final int PARAM_TYPE_TEXT
另请参见：
常量字段值

PARAM_TYPE_LONGTEXT

public static final int PARAM_TYPE_LONGTEXT
另请参见：
常量字段值
构造方法详细信息

CMyTemplateWizard

public CMyTemplateWizard()
方法详细信息

toTemplateCode

public static java.lang.String toTemplateCode(int _nTempId,
                                              java.lang.String _sXMLString)
                                       throws WCMException
根据指定置标模板ID及传入的参数数据XML构造一份置标代码

参数：
_nTempId -
_sXMLString -
返回：
抛出：
WCMException

toTemplateCode

public static java.lang.String toTemplateCode(java.lang.String _sTemplateContent,
                                              java.lang.String _sXMLString)
                                       throws WCMException
根据指定置标代码样例及传入的参数数据XML构造一份置标代码

参数：
_sTemplateContent -
_sXMLString -
返回：
抛出：
WCMException

getParameters

public static java.util.List getParameters(int _nTempId)
                                    throws java.lang.Exception
获取指定置标代码样例中的参数列表

参数：
_nTempId -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.publish.template
类
CMyTemplateWizard


com.trs.presentation.publish.template

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.publish.template

类摘要
CMyTemplateWizard Title: TRS 内容协作平台（TRS WCM）
Description:
模板置标添加向导
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.publish.template 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.publish.template 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.publish.template.CMyTemplateWizard


软件包 com.trs.presentation.publish.template 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.publish.template
的使用

没有 com.trs.presentation.publish.template 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.publish.template.CMyTemplateWizard 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.publish.template.CMyTemplateWizard
的使用

没有 com.trs.presentation.publish.template.CMyTemplateWizard 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.presentation.right
类
RightHelper


com.trs.presentation.right

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.right

类摘要
RightHelper Title: TRS 内容协作平台（TRS WCM）
Description:
用于表现层权限构造相关的管理方法
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.right 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.right 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.right.RightHelper


软件包 com.trs.presentation.right 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.right
的使用

没有 com.trs.presentation.right 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RightHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.right
类 RightHelper

java.lang.Object
    继承者  com.trs.presentation.right.RightHelper

public class RightHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
用于表现层权限构造相关的管理方法
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RightHelper()
方法摘要
static boolean hasRight(User _loginUser, CMSObj _currObj, int[] _rightIndexes)
判断用户对某个对象是否具有具有一系列权限中的一个
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightHelper

public RightHelper()
方法详细信息

hasRight

public static boolean hasRight(User _loginUser,
                               CMSObj _currObj,
                               int[] _rightIndexes)
                        throws WCMException
判断用户对某个对象是否具有具有一系列权限中的一个

参数：
_loginUser - 登录用户
_currObj - 操作对象
_rightIndexes - 权限值数组
返回：
如果具有任何一个权限，则为有权限
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.right.RightHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.right.RightHelper
的使用

没有 com.trs.presentation.right.RightHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AppAutoParameter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 AppAutoParameter

java.lang.Object
    继承者  com.trs.presentation.util.Parameter
        继承者  com.trs.presentation.util.AppAutoParameter

public class AppAutoParameter
extends Parameter

Title: TRS 内容协作平台（TRS WCM）
Description:
代码自动生工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AppAutoParameter()
方法摘要
java.lang.String | getAddEditFields() 编辑页面字段列表
java.lang.String | getAuthor() 获取作者信息
java.lang.String | getDetailFields() 细览页面字段列表
java.lang.String | getElement() 元素名称
CMSObj | getElementInstance()
java.lang.String | getElements() 集合名称
java.lang.String | getName() 模块名称
java.lang.String | getOutlineFields() 概览页面字段列表
java.lang.String | getPackage() 元素和集合存放的Package路径
java.lang.String | getSearchKeys() 概览页面检索字段列表
static CMSObj | getWCMObj(java.lang.String _sClassName)
boolean | setAddEditFields(java.lang.String _sAddEditFields)
boolean | setAuthor(java.lang.String _sAuthor) 设置作者信息
boolean | setDetailFields(java.lang.String _sDetailFields)
boolean | setElement(java.lang.String _sElement)
boolean | setElements(java.lang.String _sElements)
boolean | setName(java.lang.String _sName)
boolean | setOutlineFields(java.lang.String _sOutlineFields)
boolean | setPackage(java.lang.String _sPackage)
boolean | setSearchKeys(java.lang.String _sSearchKeys)
static void | validWCMObjClass(java.lang.String _sClassName)
从类 com.trs.presentation.util.Parameter 继承的方法
fromXML, getKeys, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, main, setPropertyWithString, toXMLElment, toXMLElment
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AppAutoParameter

public AppAutoParameter()
方法详细信息

getName

public java.lang.String getName()
模块名称

返回：
模块名称（String）

setName

public boolean setName(java.lang.String _sName)
参数：
_sName -
返回：

getElement

public java.lang.String getElement()
元素名称

返回：
元素名称(String)

setElement

public boolean setElement(java.lang.String _sElement)

getElementInstance

public CMSObj getElementInstance()
                          throws WCMException
抛出：
WCMException

getElements

public java.lang.String getElements()
集合名称

返回：
集合名称（String）

setElements

public boolean setElements(java.lang.String _sElements)

getAuthor

public java.lang.String getAuthor()
获取作者信息

返回：

setAuthor

public boolean setAuthor(java.lang.String _sAuthor)
设置作者信息

参数：
_sAuthor - 作者信息
返回：

getPackage

public java.lang.String getPackage()
元素和集合存放的Package路径

返回：
元素和集合存放的Package路径(String)

setPackage

public boolean setPackage(java.lang.String _sPackage)

getOutlineFields

public java.lang.String getOutlineFields()
概览页面字段列表

返回：
概览页面字段列表（String）

setOutlineFields

public boolean setOutlineFields(java.lang.String _sOutlineFields)

getDetailFields

public java.lang.String getDetailFields()
细览页面字段列表

返回：
细览页面字段列表（String）

setDetailFields

public boolean setDetailFields(java.lang.String _sDetailFields)

getSearchKeys

public java.lang.String getSearchKeys()
概览页面检索字段列表

返回：
概览页面检索字段列表（String）

setSearchKeys

public boolean setSearchKeys(java.lang.String _sSearchKeys)

getAddEditFields

public java.lang.String getAddEditFields()
编辑页面字段列表

返回：
编辑页面字段列表（String）

setAddEditFields

public boolean setAddEditFields(java.lang.String _sAddEditFields)

getWCMObj

public static CMSObj getWCMObj(java.lang.String _sClassName)
                        throws WCMException
抛出：
WCMException

validWCMObjClass

public static void validWCMObjClass(java.lang.String _sClassName)
                             throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AppAutoParameters

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 AppAutoParameters

java.lang.Object
    继承者  com.trs.presentation.util.Parameters
        继承者  com.trs.presentation.util.AppAutoParameters

public class AppAutoParameters
extends Parameters

Title: TRS 内容协作平台（TRS WCM）
Description:
管理应用程序自动化
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AppAutoParameters()
AppAutoParameters(int _nParameterSize)
方法摘要
boolean | add(Parameter _oPageParameter) 添加参数对象
Parameter | createParameterInstance() 产生当前参数对象的实例
AppAutoParameter | getAppAutoParameterByName(java.lang.String _sName) 根据配置名称获取指定的配置
static AppAutoParameters | getAppAutoParameters(java.lang.String _sConfigXMLFileName) 根据页面文件获取页面配置参数信息
static void | main(java.lang.String[] args)
static AppAutoParameters | reloadAppAutoParameters(java.lang.String _sConfigXMLFileName) 再次装载指定页面文件的页面配置参数信息
void | toXMLFile(java.lang.String _XMLFileName)
从类 com.trs.presentation.util.Parameters 继承的方法
get, loadParametersFromXML, remove, remove, size, toString, toXMLElement, toXMLElement, toXMLFile
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AppAutoParameters

public AppAutoParameters()

AppAutoParameters

public AppAutoParameters(int _nParameterSize)
参数：
_nParameterSize -
方法详细信息

createParameterInstance

public Parameter createParameterInstance()
从类 Parameters 复制的描述
产生当前参数对象的实例

覆盖：
类 Parameters 中的 createParameterInstance
返回：

getAppAutoParameters

public static AppAutoParameters getAppAutoParameters(java.lang.String _sConfigXMLFileName)
                                              throws WCMException
根据页面文件获取页面配置参数信息

参数：
_sPageName - 页面名称
_sConfigXMLFileName - 页面的存放位置
返回：
页面配置参数信息(PageParameters)
抛出：
WCMException - 参数无效抛出编号为
另请参见：

目录不存在抛出编号为,

reloadAppAutoParameters

public static AppAutoParameters reloadAppAutoParameters(java.lang.String _sConfigXMLFileName)
                                                 throws WCMException
再次装载指定页面文件的页面配置参数信息

参数：
_sConfigXMLFileName - 页面的存放位置
返回：
页面配置参数信息(PageParameters)
抛出：
WCMException - 参数无效抛出编号为
另请参见：

目录不存在抛出编号为,

add

public boolean add(Parameter _oPageParameter)
从类 Parameters 复制的描述
添加参数对象

覆盖：
类 Parameters 中的 add
参数：
_oPageParameter - 参数对象
返回：
添加成功,返回 true

getAppAutoParameterByName

public AppAutoParameter getAppAutoParameterByName(java.lang.String _sName)
根据配置名称获取指定的配置

参数：
_sName - 配置名称
返回：
配置对象（AppAutoParameter）

toXMLFile

public void toXMLFile(java.lang.String _XMLFileName)
               throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CmsObjUnlockTools

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 CmsObjUnlockTools

java.lang.Object
    继承者  com.trs.presentation.util.CmsObjUnlockTools

public final class CmsObjUnlockTools
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
unlock tools .
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CmsObjUnlockTools()
方法摘要
static CMSObj | findLockedObj(int _nObjType, int _nObjId)
static boolean | forceUnLocke(User _opUser, CMSObj _lockedobj)
static CMSBaseObjs | listLockedObjs(User _opUser, int _nObjType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CmsObjUnlockTools

public CmsObjUnlockTools()
方法详细信息

findLockedObj

public static CMSObj findLockedObj(int _nObjType,
                                   int _nObjId)
                            throws WCMException
抛出：
WCMException

forceUnLocke

public static boolean forceUnLocke(User _opUser,
                                   CMSObj _lockedobj)
                            throws WCMException
抛出：
WCMException

listLockedObjs

public static CMSBaseObjs listLockedObjs(User _opUser,
                                         int _nObjType)
                                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultWhereSQLMaker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 DefaultWhereSQLMaker

java.lang.Object
    继承者  com.trs.presentation.util.DefaultWhereSQLMaker

public class DefaultWhereSQLMaker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DefaultWhereSQLMaker(java.lang.String _sSearchTable, java.lang.String _sSearchKey, java.lang.String _sSearchValue)
方法摘要
java.util.List | getSearchValues()
java.lang.String | getWhereSQL()
void | makeWhereSQL()
void | setSearchValues(java.util.List searchValues)
void | setWhereSQL(java.lang.String whereSQL)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultWhereSQLMaker

public DefaultWhereSQLMaker(java.lang.String _sSearchTable,
                            java.lang.String _sSearchKey,
                            java.lang.String _sSearchValue)
方法详细信息

getSearchValues

public java.util.List getSearchValues()
返回：

setSearchValues

public void setSearchValues(java.util.List searchValues)
参数：
searchValues -

getWhereSQL

public java.lang.String getWhereSQL()
返回：

setWhereSQL

public void setWhereSQL(java.lang.String whereSQL)
参数：
whereSQL -

makeWhereSQL

public void makeWhereSQL()
                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoginHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 LoginHelper

java.lang.Object
    继承者  com.trs.presentation.util.LoginHelper

public class LoginHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
WCM登录管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | ERR_PWD_WRONG 密码错误
static int | ERR_USER_DELETED 用户已删除
static int | ERR_USER_FORBID 用户已禁止
static int | ERR_USER_LOCKED 用户已锁定
static int | ERR_USER_LOGINED 用户已经登录
static int | ERR_USER_NOREG 用户未批准
static int | ERR_USER_NOTEXIST 用户不存在
static int | ERR_USERDEF_FROM 用户自定义错误起始编号（负数，递减1）
static int | ERRNUM_MAX 最多允许密码错误次数；默认10次。
static java.lang.String | KEY_PRIVATE_LOGIN
static java.lang.String | KEY_PRIVATE_PLATFORM_LOGIN
static java.lang.String | KEY_PUBLIC_LOGIN
static java.lang.String | KEY_PUBLIC_PLATFORM_LOGIN
static java.lang.String | ONLINE_USER_VERSION
static int | RESULT_OK 登录成功
static java.lang.String | SESSION_NAME_USER 当前登录用户在Session中存放的名称
构造方法摘要
LoginHelper()
LoginHelper(javax.servlet.http.HttpServletRequest _request, javax.servlet.ServletContext _servletContext)
方法摘要
boolean | canReLogin(User _loginUser, java.lang.String _sPassword, java.lang.String _sRemoteAddr)
boolean | checkEncodeInfo(java.lang.String sPublicKey, java.lang.String sEncodeInfo)
boolean | checkEncodeInfoFromKey(java.lang.String sPublicKey)
boolean | checkLogin()
boolean | checkLogin(boolean _bCheckEncodeInfo)
boolean | checkOnlineUserUpdate()
boolean | checkPluginLogin()
static void | clearLoginErrNum(User _user) 将指定用户的登录失败次数清零
java.lang.String | createEncodeUserInfo()
java.lang.String | createEncodeUserInfo(User _loginUser, java.lang.String _sPrivateKeyFile)
java.lang.String | createEncodeUserInfo(User _loginUser, java.lang.String _sPrivateKeyFile, java.lang.String _sParam)
java.lang.String | createPluginEncodeUserInfo()
java.lang.String | createPluginEncodeUserInfo(java.lang.String parameters)
static java.lang.String | getErrorMsg(int _nError) 提取错误信息
static java.lang.String | getErrorMsg(int _nError, java.lang.String _sDefault) 提取错误信息
int | getLoginErrNum(User _user) 提取指定用户登录失败的次数
User | getLoginUser()
static int | getOnlineUserCount()
static Users | getOnlineUsers()
java.lang.String | getPluginParams()
static javax.servlet.http.HttpSession | getSessionById(java.lang.String _sessionId)
static javax.servlet.http.HttpSession | getSessionByUser(User _oUser)
boolean | isForceKick()
boolean | isOverMaxErrNum(int _errNum) 判断用户有登录错误次数是否超过系统配置的最大次数 系统配置小于等于0，则不限制错误次数
boolean | isRecordUsedTime() 属性提取：是否记录操作所用时间
static void | kickUser(User _operUser, User user)
int | login(java.lang.String _sUserName, java.lang.String _sPassword) 用户登录处理
int | loginByIDS(java.lang.String _sUserName)
void | logout()
static void | putSession(java.lang.Integer _oUserKey, javax.servlet.http.HttpSession _session) 保存Session
static void | removeSession(javax.servlet.http.HttpSession _session, java.lang.Integer _oUserKey)
void | setForceKick(boolean forceKick)
void | setRecordUsedTime(boolean _bRecord) 属性设置：是否记录操作所用时间
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ERRNUM_MAX

public static int ERRNUM_MAX
最多允许密码错误次数；默认10次。

ERR_USER_NOTEXIST

public static final int ERR_USER_NOTEXIST
用户不存在

另请参见：
常量字段值

ERR_USER_LOCKED

public static final int ERR_USER_LOCKED
用户已锁定

另请参见：
常量字段值

ERR_PWD_WRONG

public static final int ERR_PWD_WRONG
密码错误

另请参见：
常量字段值

ERR_USER_LOGINED

public static final int ERR_USER_LOGINED
用户已经登录

另请参见：
常量字段值

ERR_USER_NOREG

public static final int ERR_USER_NOREG
用户未批准

另请参见：
常量字段值

ERR_USER_FORBID

public static final int ERR_USER_FORBID
用户已禁止

另请参见：
常量字段值

ERR_USER_DELETED

public static final int ERR_USER_DELETED
用户已删除

另请参见：
常量字段值

RESULT_OK

public static final int RESULT_OK
登录成功

另请参见：
常量字段值

ERR_USERDEF_FROM

public static final int ERR_USERDEF_FROM
用户自定义错误起始编号（负数，递减1）

另请参见：
常量字段值

SESSION_NAME_USER

public static final java.lang.String SESSION_NAME_USER
当前登录用户在Session中存放的名称

另请参见：
常量字段值

ONLINE_USER_VERSION

public static final java.lang.String ONLINE_USER_VERSION
另请参见：
常量字段值

KEY_PRIVATE_LOGIN

public static final java.lang.String KEY_PRIVATE_LOGIN
另请参见：
常量字段值

KEY_PUBLIC_LOGIN

public static final java.lang.String KEY_PUBLIC_LOGIN
另请参见：
常量字段值

KEY_PRIVATE_PLATFORM_LOGIN

public static final java.lang.String KEY_PRIVATE_PLATFORM_LOGIN

KEY_PUBLIC_PLATFORM_LOGIN

public static final java.lang.String KEY_PUBLIC_PLATFORM_LOGIN
构造方法详细信息

LoginHelper

public LoginHelper()

LoginHelper

public LoginHelper(javax.servlet.http.HttpServletRequest _request,
                   javax.servlet.ServletContext _servletContext)
方法详细信息

checkLogin

public boolean checkLogin()

checkPluginLogin

public boolean checkPluginLogin()

checkLogin

public boolean checkLogin(boolean _bCheckEncodeInfo)

getLoginUser

public User getLoginUser()
返回：
Returns the m_oUser.

getErrorMsg

public static final java.lang.String getErrorMsg(int _nError)
提取错误信息

参数：
_nError - 错误编号
返回：
错误信息

getErrorMsg

public static final java.lang.String getErrorMsg(int _nError,
                                                 java.lang.String _sDefault)
提取错误信息

参数：
_nError - 错误编号
_sDefault - 默认错误信息;可缺省,缺省值为"未知错误"。
返回：
错误信息

isRecordUsedTime

public boolean isRecordUsedTime()
属性提取：是否记录操作所用时间

返回：
若记录，则返回true；否则，返回false.

setRecordUsedTime

public void setRecordUsedTime(boolean _bRecord)
属性设置：是否记录操作所用时间

参数：
_bRecord - true=记录；false=不记录。

login

public int login(java.lang.String _sUserName,
                 java.lang.String _sPassword)
          throws WCMException
用户登录处理

参数：
_sUserName - 登录用户名
_sPassword - 密码
_sIp - 登录IP
返回：
登录结果
抛出：
WCMException - 登录过程可能抛出异常

loginByIDS

public int loginByIDS(java.lang.String _sUserName)
               throws WCMException
抛出：
WCMException

logout

public void logout()

getLoginErrNum

public int getLoginErrNum(User _user)
提取指定用户登录失败的次数

参数：
_user - 用户对象
返回：
指定用户登录失败的次数

clearLoginErrNum

public static final void clearLoginErrNum(User _user)
将指定用户的登录失败次数清零

参数：
_user - 用户对象

isOverMaxErrNum

public boolean isOverMaxErrNum(int _errNum)
                        throws WCMException
判断用户有登录错误次数是否超过系统配置的最大次数 系统配置小于等于0，则不限制错误次数

参数：
_errNum -
返回：
抛出：
WCMException

checkOnlineUserUpdate

public boolean checkOnlineUserUpdate()

getOnlineUsers

public static Users getOnlineUsers()

getOnlineUserCount

public static int getOnlineUserCount()

createEncodeUserInfo

public java.lang.String createEncodeUserInfo()

createPluginEncodeUserInfo

public java.lang.String createPluginEncodeUserInfo()

createPluginEncodeUserInfo

public java.lang.String createPluginEncodeUserInfo(java.lang.String parameters)

createEncodeUserInfo

public java.lang.String createEncodeUserInfo(User _loginUser,
                                             java.lang.String _sPrivateKeyFile)
参数：
_sPrivateKeyFile -
返回：

createEncodeUserInfo

public java.lang.String createEncodeUserInfo(User _loginUser,
                                             java.lang.String _sPrivateKeyFile,
                                             java.lang.String _sParam)

getPluginParams

public java.lang.String getPluginParams()

checkEncodeInfoFromKey

public boolean checkEncodeInfoFromKey(java.lang.String sPublicKey)
参数：
sPublicKey -
返回：

checkEncodeInfo

public boolean checkEncodeInfo(java.lang.String sPublicKey,
                               java.lang.String sEncodeInfo)
参数：
sPublicKey -
sEncodeInfo -
返回：

putSession

public static void putSession(java.lang.Integer _oUserKey,
                              javax.servlet.http.HttpSession _session)
保存Session

参数：
_oUserKey -
_sRemoteAddr -

getSessionByUser

public static javax.servlet.http.HttpSession getSessionByUser(User _oUser)

getSessionById

public static javax.servlet.http.HttpSession getSessionById(java.lang.String _sessionId)

removeSession

public static void removeSession(javax.servlet.http.HttpSession _session,
                                 java.lang.Integer _oUserKey)

kickUser

public static void kickUser(User _operUser,
                            User user)
                     throws WCMException
抛出：
WCMException

canReLogin

public boolean canReLogin(User _loginUser,
                          java.lang.String _sPassword,
                          java.lang.String _sRemoteAddr)

isForceKick

public final boolean isForceKick()

setForceKick

public final void setForceKick(boolean forceKick)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.util
类
AppAutoParameter
AppAutoParameters
CmsObjUnlockTools
DefaultWhereSQLMaker
LoginHelper
PageHelper
PageParameter
PageParameters
PageViewUtil
Parameter
Parameters
RequestHelper
ResponseHelper
WhereSQLMaker


com.trs.presentation.util

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.util

类摘要
AppAutoParameter | Title: TRS 内容协作平台（TRS WCM） Description: 代码自动生工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
AppAutoParameters | Title: TRS 内容协作平台（TRS WCM） Description: 管理应用程序自动化 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CmsObjUnlockTools | Title: TRS 内容协作平台（TRS WCM） Description: unlock tools .
DefaultWhereSQLMaker | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
LoginHelper | Title: TRS 内容协作平台（TRS WCM） Description: WCM登录管理 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PageHelper | Title: TRS 内容协作平台（TRS WCM） Description: JSP列表页面的分页工具类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PageParameter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PageParameters | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PageViewUtil | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Parameter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Parameters | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RequestHelper | Title: TRS 内容协作平台（TRS WCM） Description: 解析Web交互的参数，构造Where条件 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ResponseHelper | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WhereSQLMaker | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.util 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.util.CmsObjUnlockTools
    • com.trs.presentation.util.DefaultWhereSQLMaker
    • com.trs.presentation.util.LoginHelper
    • com.trs.presentation.util.PageHelper
    • com.trs.presentation.util.PageViewUtil
    • com.trs.presentation.util.Parameter
      • com.trs.presentation.util.AppAutoParameter
      • com.trs.presentation.util.PageParameter
    • com.trs.presentation.util.Parameters
      • com.trs.presentation.util.AppAutoParameters
      • com.trs.presentation.util.PageParameters
    • com.trs.presentation.util.RequestHelper
    • com.trs.presentation.util.ResponseHelper
    • com.trs.presentation.util.WhereSQLMaker


软件包 com.trs.presentation.util 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.util
的使用

使用 com.trs.presentation.util 的软件包
com.trs.components.infoview.helper
com.trs.components.wcm.content.trsserver
com.trs.presentation.nav
com.trs.presentation.util
com.trs.presentation.valid
com.trs.presentation.wcm.content

com.trs.components.infoview.helper 使用的 com.trs.presentation.util 中的类
RequestHelper
Title: TRS 内容协作平台（TRS WCM）
Description:
解析Web交互的参数，构造Where条件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.trsserver 使用的 com.trs.presentation.util 中的类
RequestHelper
Title: TRS 内容协作平台（TRS WCM）
Description:
解析Web交互的参数，构造Where条件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.nav 使用的 com.trs.presentation.util 中的类
RequestHelper
Title: TRS 内容协作平台（TRS WCM）
Description:
解析Web交互的参数，构造Where条件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.util 使用的 com.trs.presentation.util 中的类
AppAutoParameter
Title: TRS 内容协作平台（TRS WCM）
Description:
代码自动生工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AppAutoParameters
Title: TRS 内容协作平台（TRS WCM）
Description:
管理应用程序自动化
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PageParameter
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PageParameters
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Parameter
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Parameters
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RequestHelper
Title: TRS 内容协作平台（TRS WCM）
Description:
解析Web交互的参数，构造Where条件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.valid 使用的 com.trs.presentation.util 中的类
PageParameter
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.presentation.wcm.content 使用的 com.trs.presentation.util 中的类
RequestHelper
Title: TRS 内容协作平台（TRS WCM）
Description:
解析Web交互的参数，构造Where条件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 PageHelper

java.lang.Object
    继承者  com.trs.presentation.util.PageHelper

public class PageHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
JSP列表页面的分页工具类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PageHelper()
方法摘要
static java.lang.String | PagerHtmlGenerator(CPager _pager, int _nPageItemCount)
static java.lang.String | PagerHtmlGenerator(CPager _pager, int _nPageItemCount, int _nPageMaxCount)
static java.lang.String | PagerHtmlGenerator(CPager _pager, int _nPageItemCount, int _nPageMaxCount, java.lang.String _sItemName, java.lang.String _sUnitName)
static java.lang.String | PagerHtmlGenerator(CPager _pager, int _nPageItemCount, int _nPageMaxCount, java.lang.String _sItemName, java.lang.String _sUnitName, java.lang.String _sBackColor, java.lang.String _sFontColor)
static java.lang.String | PagerHtmlGenerator(CPager _pager, int _nPageItemCount, java.lang.String _sItemName, java.lang.String _sUnitName)
static java.lang.String | PagerHtmlGenerator(CPager _pager, int _nPageItemCount, java.lang.String _sItemName, java.lang.String _sUnitName, java.lang.String _sBackColor, java.lang.String _sFontColor)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageHelper

public PageHelper()
方法详细信息

PagerHtmlGenerator

public static java.lang.String PagerHtmlGenerator(CPager _pager,
                                                  int _nPageItemCount)

PagerHtmlGenerator

public static java.lang.String PagerHtmlGenerator(CPager _pager,
                                                  int _nPageItemCount,
                                                  java.lang.String _sItemName,
                                                  java.lang.String _sUnitName)

PagerHtmlGenerator

public static java.lang.String PagerHtmlGenerator(CPager _pager,
                                                  int _nPageItemCount,
                                                  java.lang.String _sItemName,
                                                  java.lang.String _sUnitName,
                                                  java.lang.String _sBackColor,
                                                  java.lang.String _sFontColor)

PagerHtmlGenerator

public static java.lang.String PagerHtmlGenerator(CPager _pager,
                                                  int _nPageItemCount,
                                                  int _nPageMaxCount)

PagerHtmlGenerator

public static java.lang.String PagerHtmlGenerator(CPager _pager,
                                                  int _nPageItemCount,
                                                  int _nPageMaxCount,
                                                  java.lang.String _sItemName,
                                                  java.lang.String _sUnitName)

PagerHtmlGenerator

public static java.lang.String PagerHtmlGenerator(CPager _pager,
                                                  int _nPageItemCount,
                                                  int _nPageMaxCount,
                                                  java.lang.String _sItemName,
                                                  java.lang.String _sUnitName,
                                                  java.lang.String _sBackColor,
                                                  java.lang.String _sFontColor)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageParameter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 PageParameter

java.lang.Object
    继承者  com.trs.presentation.util.Parameter
        继承者  com.trs.presentation.util.PageParameter

public class PageParameter
extends Parameter

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | TYPE_BOOLEAN Comment for TYPE_BOOLEAN 布尔型
static int | TYPE_BOOLEAN_HASHCODE Comment for TYPE_BOOLEAN 布尔型
static java.lang.String | TYPE_DATE Comment for TYPE_DATE 日期型
static int | TYPE_DATE_HASHCODE Comment for TYPE_DATE 日期型
static java.lang.String | TYPE_DATETIME Comment for TYPE_DATETIME 日期时间型
static int | TYPE_DATETIME_HASHCODE Comment for TYPE_DATETIME 日期时间型
static java.lang.String | TYPE_DOUBLE Comment for TYPE_DOUBLE 双精度
static int | TYPE_DOUBLE_HASHCODE Comment for TYPE_DOUBLE 双精度
static java.lang.String | TYPE_FLOAT Comment for TYPE_FLOAT 浮点型
static int | TYPE_FLOAT_HASHCODE Comment for TYPE_FLOAT 浮点型
static java.lang.String | TYPE_INT Comment for TYPE_INT 整型
static int | TYPE_INT_HASHCODE Comment for TYPE_INT 整型
static java.lang.String | TYPE_LONG Comment for TYPE_LONG 长整型
static int | TYPE_LONG_HASHCODE Comment for TYPE_LONG 长整型
static java.lang.String | TYPE_STRING Comment for TYPE_STRING 字符型
static int | TYPE_STRING_HASHCODE Comment for TYPE_STRING 字符型
static java.lang.String | TYPE_TIME Comment for TYPE_TIME 时间型
static int | TYPE_TIME_HASHCODE Comment for TYPE_TIME 时间型
static java.lang.String[] | TYPES_SUPPORTED Comment for TYPES_SUPPORTED
构造方法摘要
PageParameter()
方法摘要
static PageParameter | createPageParameterFromXML(org.dom4j.Element _elParameter) 通过一个XML数据产生一个PageParameter对象
boolean | fromXML(org.dom4j.Element _element) 从指定的XML Element导入参数数据 fromXMLElement(_element)
java.lang.String | getDefault() 获取默认值
boolean | getDefaultAsBoolean(boolean _bDefaultValue) 将默认值转换为布尔型
CMyDateTime | getDefaultAsDateTime() 将默认值转换为日期类型
double | getDefaultAsDouble(double _dDefaultValue) 将默认值转换为双精度
float | getDefaultAsFloat(float _fDefaultValue) 将默认值转换为浮点数
int | getDefaultAsInt(int _nDefaultValue) 将默认值转换为整型数
long | getDefaultAsLong(long _lDefaultValue) 将默认值转换为长整型
java.lang.String | getDesc() 获取参数描述
java.lang.String | getExcludeValue()
int | getMaxLength() 获取参数允许的最大长度，仅仅对字符类型数据有效
java.lang.String | getMaxValue() 获取允许的最大值，对非字符类型数据有效
int | getMinLength() 获取参数允许的最小长度，仅仅对字符类型数据有效
java.lang.String | getMinValue() 获取允许的最小值，对非字符类型数据有效
java.lang.String | getName() 获取名称
java.lang.String | getSearchField()
java.lang.String | getSearchOperator()
java.lang.String | getSearchType()
java.lang.String | getType() 获取当前的参数类型
boolean | isRequired() 参数是否需要传入
boolean | isSearch()
static void | main(java.lang.String[] args)
void | setDefault(java.lang.String default1) 设置默认值
void | setDesc(java.lang.String desc) 设置参数描述
void | setExcludeValue(java.lang.String excludeValue)
void | setMaxLength(int maxLength) 设置参数允许的最大长度，仅仅对字符类型数据有效
void | setMaxValue(java.lang.String maxValue) 设置允许的最大值，对非字符类型数据有效
void | setMinLength(int minLength) 设置参数允许的最小长度
void | setMinValue(java.lang.String minValue) 设置允许的最小值，对非字符类型数据有效
void | setName(java.lang.String name) 设置名称(必须为英文)
void | setRequired(boolean required) 设置参数是否需要传入
void | setSearch(boolean search)
void | setSearchField(java.lang.String searchField)
void | setSearchOperator(java.lang.String searchOperator)
void | setSearchType(java.lang.String searchType)
void | setType(java.lang.String _sType) 设置当前参数的类型，类型定义为：PageParameter.TYPE_STRING等
从类 com.trs.presentation.util.Parameter 继承的方法
getKeys, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, setPropertyWithString, toXMLElment, toXMLElment
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_STRING

public static final java.lang.String TYPE_STRING
Comment for TYPE_STRING 字符型

另请参见：
常量字段值

TYPE_INT

public static final java.lang.String TYPE_INT
Comment for TYPE_INT 整型

另请参见：
常量字段值

TYPE_LONG

public static final java.lang.String TYPE_LONG
Comment for TYPE_LONG 长整型

另请参见：
常量字段值

TYPE_FLOAT

public static final java.lang.String TYPE_FLOAT
Comment for TYPE_FLOAT 浮点型

另请参见：
常量字段值

TYPE_DOUBLE

public static final java.lang.String TYPE_DOUBLE
Comment for TYPE_DOUBLE 双精度

另请参见：
常量字段值

TYPE_DATE

public static final java.lang.String TYPE_DATE
Comment for TYPE_DATE 日期型

另请参见：
常量字段值

TYPE_TIME

public static final java.lang.String TYPE_TIME
Comment for TYPE_TIME 时间型

另请参见：
常量字段值

TYPE_DATETIME

public static final java.lang.String TYPE_DATETIME
Comment for TYPE_DATETIME 日期时间型

另请参见：
常量字段值

TYPE_BOOLEAN

public static final java.lang.String TYPE_BOOLEAN
Comment for TYPE_BOOLEAN 布尔型

另请参见：
常量字段值

TYPE_STRING_HASHCODE

public static final int TYPE_STRING_HASHCODE
Comment for TYPE_STRING 字符型

另请参见：
常量字段值

TYPE_INT_HASHCODE

public static final int TYPE_INT_HASHCODE
Comment for TYPE_INT 整型

另请参见：
常量字段值

TYPE_LONG_HASHCODE

public static final int TYPE_LONG_HASHCODE
Comment for TYPE_LONG 长整型

另请参见：
常量字段值

TYPE_FLOAT_HASHCODE

public static final int TYPE_FLOAT_HASHCODE
Comment for TYPE_FLOAT 浮点型

另请参见：
常量字段值

TYPE_DOUBLE_HASHCODE

public static final int TYPE_DOUBLE_HASHCODE
Comment for TYPE_DOUBLE 双精度

另请参见：
常量字段值

TYPE_DATE_HASHCODE

public static final int TYPE_DATE_HASHCODE
Comment for TYPE_DATE 日期型

另请参见：
常量字段值

TYPE_TIME_HASHCODE

public static final int TYPE_TIME_HASHCODE
Comment for TYPE_TIME 时间型

另请参见：
常量字段值

TYPE_DATETIME_HASHCODE

public static final int TYPE_DATETIME_HASHCODE
Comment for TYPE_DATETIME 日期时间型

另请参见：
常量字段值

TYPE_BOOLEAN_HASHCODE

public static final int TYPE_BOOLEAN_HASHCODE
Comment for TYPE_BOOLEAN 布尔型

另请参见：
常量字段值

TYPES_SUPPORTED

public static final java.lang.String[] TYPES_SUPPORTED
Comment for TYPES_SUPPORTED

构造方法详细信息

PageParameter

public PageParameter()
方法详细信息

isRequired

public boolean isRequired()
参数是否需要传入

返回：
如果需要传入,返回true

setRequired

public void setRequired(boolean required)
设置参数是否需要传入

参数：
required - 如果需要传入:true

getType

public java.lang.String getType()
获取当前的参数类型

返回：

setType

public void setType(java.lang.String _sType)
             throws WCMException
设置当前参数的类型，类型定义为：PageParameter.TYPE_STRING等

参数：
_sType - 参数类型，整型数,类型定义为：PageParameter.TYPE_STRING等
抛出：
WCMException

getDesc

public java.lang.String getDesc()
获取参数描述

返回：
参数描述(String)

setDesc

public void setDesc(java.lang.String desc)
设置参数描述

参数：
desc - 参数描述(String)

getName

public java.lang.String getName()
获取名称

返回：
名称(String)

setName

public void setName(java.lang.String name)
设置名称(必须为英文)

参数：
name -

getMaxLength

public int getMaxLength()
获取参数允许的最大长度，仅仅对字符类型数据有效

返回：
参数允许的最大长度

setMaxLength

public void setMaxLength(int maxLength)
设置参数允许的最大长度，仅仅对字符类型数据有效

参数：
maxLength - 参数允许的最大长度

getMinLength

public int getMinLength()
获取参数允许的最小长度，仅仅对字符类型数据有效

返回：
参数允许的最小长度

setMinLength

public void setMinLength(int minLength)
设置参数允许的最小长度

参数：
minLength - 参数允许的最小长度

getDefault

public java.lang.String getDefault()
获取默认值

返回：
默认值

getDefaultAsInt

public int getDefaultAsInt(int _nDefaultValue)
                    throws WCMException
将默认值转换为整型数

参数：
_nDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
WCMException

getDefaultAsLong

public long getDefaultAsLong(long _lDefaultValue)
                      throws WCMException
将默认值转换为长整型

参数：
_lDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
WCMException

getDefaultAsFloat

public float getDefaultAsFloat(float _fDefaultValue)
                        throws WCMException
将默认值转换为浮点数

参数：
_fDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
WCMException

getDefaultAsBoolean

public boolean getDefaultAsBoolean(boolean _bDefaultValue)
                            throws WCMException
将默认值转换为布尔型

参数：
_bDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
WCMException

getDefaultAsDouble

public double getDefaultAsDouble(double _dDefaultValue)
                          throws WCMException
将默认值转换为双精度

参数：
_dDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
WCMException

getDefaultAsDateTime

public CMyDateTime getDefaultAsDateTime()
                                 throws WCMException
将默认值转换为日期类型

返回：
抛出：
WCMException

setDefault

public void setDefault(java.lang.String default1)
设置默认值

参数：
default1 - 默认值

getMaxValue

public java.lang.String getMaxValue()
获取允许的最大值，对非字符类型数据有效

返回：
允许的最大值 *

setMaxValue

public void setMaxValue(java.lang.String maxValue)
设置允许的最大值，对非字符类型数据有效

参数：
maxValue - 允许的最大值

getMinValue

public java.lang.String getMinValue()
获取允许的最小值，对非字符类型数据有效

返回：
允许的最小值

setMinValue

public void setMinValue(java.lang.String minValue)
设置允许的最小值，对非字符类型数据有效

参数：
minValue - 允许的最小值

fromXML

public boolean fromXML(org.dom4j.Element _element)
                throws WCMException
从类 Parameter 复制的描述
从指定的XML Element导入参数数据 fromXMLElement(_element)

覆盖：
类 Parameter 中的 fromXML
参数：
_element - 要导入数据的XML Element 元素；
返回：
boolean，若有数据导入，返回true;否则，返回false
抛出：
WCMException

createPageParameterFromXML

public static PageParameter createPageParameterFromXML(org.dom4j.Element _elParameter)
                                                throws WCMException
通过一个XML数据产生一个PageParameter对象

参数：
_elParameter - XML数据对象
返回：
页面参数对象(PageParameter)
抛出：
WCMException - 数据非法抛出异常

isSearch

public boolean isSearch()
返回：

setSearch

public void setSearch(boolean search)
参数：
search -

getSearchOperator

public java.lang.String getSearchOperator()
返回：

setSearchOperator

public void setSearchOperator(java.lang.String searchOperator)
参数：
searchOperator -

main

public static void main(java.lang.String[] args)

getSearchField

public java.lang.String getSearchField()
返回：

setSearchField

public void setSearchField(java.lang.String searchField)
参数：
searchField -

getSearchType

public java.lang.String getSearchType()
返回：

setSearchType

public void setSearchType(java.lang.String searchType)
参数：
searchType -

getExcludeValue

public java.lang.String getExcludeValue()
返回：

setExcludeValue

public void setExcludeValue(java.lang.String excludeValue)
参数：
excludeValue -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageParameters

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 PageParameters

java.lang.Object
    继承者  com.trs.presentation.util.Parameters
        继承者  com.trs.presentation.util.PageParameters

public class PageParameters
extends Parameters

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PageParameters()
PageParameters(int _nParameterSize)
方法摘要
Parameter | createParameterInstance() 产生当前参数对象的实例
static java.util.Enumeration | getPages()
static PageParameters | getParametersOfPage(java.lang.String _sPageName, java.lang.String _sAbsolutePagePath) 根据页面文件获取页面配置参数信息
static void | main(java.lang.String[] args)
static PageParameters | reloadParametersOfPageName(java.lang.String _sPageName, java.lang.String _sAbsolutePagePath) 再次装载指定页面文件的页面配置参数信息
static void | removeParametersOfPageName(java.lang.String _sKey) 删除指定Page的配置，以便重新载入
从类 com.trs.presentation.util.Parameters 继承的方法
add, get, loadParametersFromXML, remove, remove, size, toString, toXMLElement, toXMLElement, toXMLFile
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PageParameters

public PageParameters()

PageParameters

public PageParameters(int _nParameterSize)
参数：
_nParameterSize -
方法详细信息

createParameterInstance

public Parameter createParameterInstance()
从类 Parameters 复制的描述
产生当前参数对象的实例

覆盖：
类 Parameters 中的 createParameterInstance
返回：

getParametersOfPage

public static PageParameters getParametersOfPage(java.lang.String _sPageName,
                                                 java.lang.String _sAbsolutePagePath)
                                          throws WCMException
根据页面文件获取页面配置参数信息

参数：
_sPageName - 页面名称
_sAbsolutePagePath - 页面的存放位置
返回：
页面配置参数信息(PageParameters)
抛出：
WCMException - 参数无效抛出编号为
另请参见：

目录不存在抛出编号为,

reloadParametersOfPageName

public static PageParameters reloadParametersOfPageName(java.lang.String _sPageName,
                                                        java.lang.String _sAbsolutePagePath)
                                                 throws WCMException
再次装载指定页面文件的页面配置参数信息

参数：
_sPageName - 页面名称
_sAbsolutePagePath - 页面的存放位置
返回：
页面配置参数信息(PageParameters)
抛出：
WCMException - 参数无效抛出编号为
另请参见：

目录不存在抛出编号为,

removeParametersOfPageName

public static void removeParametersOfPageName(java.lang.String _sKey)
删除指定Page的配置，以便重新载入

参数：
_sKey - 指定的Page Name

getPages

public static java.util.Enumeration getPages()

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageViewUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 PageViewUtil

java.lang.Object
    继承者  com.trs.presentation.util.PageViewUtil

public class PageViewUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | ORDERBY_TYPE_ASC
static java.lang.String | ORDERBY_TYPE_DESC
构造方法摘要
PageViewUtil()
方法摘要
static java.lang.String | getHeadTitle(java.lang.String _sField, java.lang.String _sFieldDesc, java.lang.String _sCurrOrderField, java.lang.String _sCurrOrderType)
static java.lang.String | ObjectToHtml(java.lang.Object _obj)
static java.lang.String | ObjectToHtmlValue(java.lang.Object _obj)
static java.lang.String | showOrdImg(java.lang.String _sCurrOrderType)
static java.lang.String | toHtml(CMyDateTime _date)
static java.lang.String | toHtml(CMyDateTime _date, java.lang.String _dateFormat)
static java.lang.String | toHtml(java.lang.String _sValue)
static java.lang.String | toHtml(java.lang.String _sValue, boolean _bDisplay, boolean _bMultiLanguage)
static java.lang.String | toHtmlValue(java.lang.String _sValue)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ORDERBY_TYPE_DESC

public static java.lang.String ORDERBY_TYPE_DESC

ORDERBY_TYPE_ASC

public static java.lang.String ORDERBY_TYPE_ASC
构造方法详细信息

PageViewUtil

public PageViewUtil()
方法详细信息

ObjectToHtml

public static java.lang.String ObjectToHtml(java.lang.Object _obj)

ObjectToHtmlValue

public static java.lang.String ObjectToHtmlValue(java.lang.Object _obj)

toHtmlValue

public static java.lang.String toHtmlValue(java.lang.String _sValue)

toHtml

public static java.lang.String toHtml(java.lang.String _sValue)

toHtml

public static java.lang.String toHtml(java.lang.String _sValue,
                                      boolean _bDisplay,
                                      boolean _bMultiLanguage)

toHtml

public static java.lang.String toHtml(CMyDateTime _date)

toHtml

public static java.lang.String toHtml(CMyDateTime _date,
                                      java.lang.String _dateFormat)

showOrdImg

public static java.lang.String showOrdImg(java.lang.String _sCurrOrderType)

getHeadTitle

public static java.lang.String getHeadTitle(java.lang.String _sField,
                                            java.lang.String _sFieldDesc,
                                            java.lang.String _sCurrOrderField,
                                            java.lang.String _sCurrOrderType)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Parameter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 Parameter

java.lang.Object
    继承者  com.trs.presentation.util.Parameter
直接已知子类：
AppAutoParameter, PageParameter
public class Parameter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
Parameter()
方法摘要
boolean | fromXML(org.dom4j.Element _element) 从指定的XML Element导入参数数据 fromXMLElement(_element)
java.util.Enumeration | getKeys()
java.lang.Object | getProperty(java.lang.String _sName) 取对象属性值
boolean | getPropertyAsBoolean(java.lang.String _sName, boolean _bDefault) 取布尔型属性值 说明：0值为false，非0值为true
CMyDateTime | getPropertyAsDateTime(java.lang.String _sName) 取日期时间型属性值
int | getPropertyAsInt(java.lang.String _sName, int _nDefault) 取长整型属性值
long | getPropertyAsLong(java.lang.String _sName, long _lDefault) 取长整型属性值
java.lang.String | getPropertyAsString(java.lang.String _sName) 取字符串型属性值
static void | main(java.lang.String[] args)
boolean | setPropertyWithString(java.lang.String _sName, java.lang.String _sValue) 用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象
org.dom4j.Element | toXMLElment()
org.dom4j.Element | toXMLElment(java.lang.String _sTagName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Parameter

public Parameter()
方法详细信息

getKeys

public java.util.Enumeration getKeys()

fromXML

public boolean fromXML(org.dom4j.Element _element)
                throws WCMException
从指定的XML Element导入参数数据 fromXMLElement(_element)

参数：
_element - 要导入数据的XML Element 元素；
返回：
boolean，若有数据导入，返回true;否则，返回false
抛出：
WCMException

toXMLElment

public org.dom4j.Element toXMLElment(java.lang.String _sTagName)
                              throws WCMException
抛出：
WCMException

toXMLElment

public org.dom4j.Element toXMLElment()
                              throws WCMException
抛出：
WCMException

setPropertyWithString

public boolean setPropertyWithString(java.lang.String _sName,
                                     java.lang.String _sValue)
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象

参数：
_sName - 属性名
_sValue - 属性值
返回：
抛出：
WCMException

getProperty

public java.lang.Object getProperty(java.lang.String _sName)
取对象属性值

参数：
_sName - 属性字段名称
返回：
返回属性对象(Object)，目前为String

getPropertyAsString

public java.lang.String getPropertyAsString(java.lang.String _sName)
取字符串型属性值

参数：
_sName - 属性字段名称
返回：
String对象

getPropertyAsDateTime

public CMyDateTime getPropertyAsDateTime(java.lang.String _sName)
                                  throws WCMException
取日期时间型属性值

参数：
_sName - 属性字段名称
返回：
CMyDateTime对象
抛出：
WCMException

getPropertyAsLong

public long getPropertyAsLong(java.lang.String _sName,
                              long _lDefault)
                       throws WCMException
取长整型属性值

参数：
_sName - 属性字段名称
_lDefault - 默认值
返回：
long类型的属性值
抛出：
WCMException

getPropertyAsInt

public int getPropertyAsInt(java.lang.String _sName,
                            int _nDefault)
                     throws WCMException
取长整型属性值

参数：
_sName - 属性字段名称
_nDefault - 默认值
返回：
int类型的属性值
抛出：
WCMException

getPropertyAsBoolean

public boolean getPropertyAsBoolean(java.lang.String _sName,
                                    boolean _bDefault)
                             throws WCMException
取布尔型属性值 说明：0值为false，非0值为true

参数：
_sName - 属性名
_bDefault - 默认值
返回：
boolean类型的属性值
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Parameters

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 Parameters

java.lang.Object
    继承者  com.trs.presentation.util.Parameters
直接已知子类：
AppAutoParameters, PageParameters
public class Parameters
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
Parameters()
Parameters(int _nParameterSize)
方法摘要
boolean | add(Parameter _oPageParameter) 添加参数对象
Parameter | createParameterInstance() 产生当前参数对象的实例
Parameter | get(int _nIndex) 获取指定位置的参数对象
void | loadParametersFromXML(java.lang.String _sXMLFileName)
static void | main(java.lang.String[] args)
Parameter | remove(int _nIndex) 删除指定位置的参数对象
boolean | remove(Parameter _oPageParameter) 删除指定的参数对象
int | size() 获取参数的个数
java.lang.String | toString()
org.dom4j.Element | toXMLElement()
org.dom4j.Element | toXMLElement(java.lang.String _sTagName)
boolean | toXMLFile(java.lang.String _XMLFileName, java.lang.String _sTagName, java.lang.String _XSLFileName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Parameters

public Parameters()

Parameters

public Parameters(int _nParameterSize)
方法详细信息

size

public int size()
获取参数的个数

返回：
参数的个数

get

public Parameter get(int _nIndex)
获取指定位置的参数对象

参数：
_nIndex - 指定位置
返回：
指定位置的参数对象 PageParameter

add

public boolean add(Parameter _oPageParameter)
添加参数对象

参数：
_oPageParameter - 参数对象
返回：
添加成功,返回 true

remove

public Parameter remove(int _nIndex)
删除指定位置的参数对象

参数：
_nIndex - 指定位置
返回：
如果删除成功，返回删除后的对象

remove

public boolean remove(Parameter _oPageParameter)
删除指定的参数对象

参数：
_oPageParameter - 指定的参数对象
返回：
如果删除成功，返回 true

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

createParameterInstance

public Parameter createParameterInstance()
产生当前参数对象的实例

返回：

loadParametersFromXML

public void loadParametersFromXML(java.lang.String _sXMLFileName)
                           throws WCMException
参数：
_sXMLFileName -
抛出：
WCMException

toXMLElement

public org.dom4j.Element toXMLElement(java.lang.String _sTagName)
                               throws WCMException
抛出：
WCMException

toXMLElement

public org.dom4j.Element toXMLElement()
                               throws WCMException
抛出：
WCMException

toXMLFile

public boolean toXMLFile(java.lang.String _XMLFileName,
                         java.lang.String _sTagName,
                         java.lang.String _XSLFileName)
                  throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 RequestHelper

java.lang.Object
    继承者  com.trs.presentation.util.RequestHelper

public class RequestHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
解析Web交互的参数，构造Where条件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | PARAM_NAME_ORDER_FIELD
static java.lang.String | PARAM_NAME_ORDER_TYPE
static java.lang.String | PARAM_NAME_SEARCH_KEY
static java.lang.String | PARAM_NAME_SEARCH_TABLE
static java.lang.String | PARAM_NAME_SEARCH_VALUE
构造方法摘要
RequestHelper()
RequestHelper(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response, javax.servlet.ServletContext _servletContext)
RequestHelper(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response, javax.servlet.ServletContext _servletContext, boolean _bPostMehthod)
方法摘要
void | doValid()
void | doValid(boolean _bCheckFileExists) 根据当前页面的配置文件,解析当前传入页面的参数
void | forward(java.lang.String _sURL) 页面带参数跳转到_sURL
boolean | getBoolean(java.lang.String _sName, boolean _bDefault) 取布尔型属性值 说明：0值为false，非0值为true
CMyDateTime | getDateTime(java.lang.String _sName) 取日期时间型属性值
CMyDateTime | getDateTime(java.lang.String _sName, java.lang.String _sDateFormate) 取日期时间型属性值
int | getInt(java.lang.String _sName, int _nDefault) 取长整型属性值
long | getLong(java.lang.String _sName, long _lDefault) 取长整型属性值
java.lang.String | getOrderField()
java.lang.String | getOrderSQL() 获取当前条件下的排序语句
java.lang.String | getOrderType()
WCMFilter | getPageFilter(WCMFilter _extraFilter)
Reports | getReports()
javax.servlet.http.HttpServletRequest | getRequest()
javax.servlet.http.HttpServletResponse | getResponse()
java.lang.String | getSearchKey()
java.lang.String | getSearchTableName()
java.lang.String | getSearchValue()
java.lang.String | getServerName() 获取服务器名
int | getServerPort() 获取服务器端口
java.lang.String | getString(java.lang.String _sName) 取字符串型属性值
java.lang.String | getWhereSQL() 获取当前条件下的检索语句
void | handleOpReports(java.lang.String _sResponseUrl, Reports _currReports)
java.lang.String | realParameters2QueryString() 将参数以URL参数信息方式输出
void | reloadPageConfig() 重新装载页面配置信息
void | removePageConfig(java.lang.String _sPageName) 删除指定Page的配置，以便重新载入
void | sendRedirect(java.lang.String url) 借助“..
void | setOrderField(java.lang.String orderField)
void | setOrderType(java.lang.String orderType)
void | setRequest(javax.servlet.http.HttpServletRequest request) 获取当前J2EE容器中的Request对象
void | setResponse(javax.servlet.http.HttpServletResponse response)
void | setSearchKey(java.lang.String searchKey)
void | setSearchTableName(java.lang.String searchTableName)
void | setSearchValue(java.lang.String searchValue)
java.lang.Object | setValue(java.lang.String _sName, java.lang.String _sValue)
java.lang.String | toHTMLHidden() 将参数以Hidden元素的形式输出
java.lang.String | toInitSearchJavaScript()
java.lang.String | toString()
java.lang.String | toTRSRequestParam() 以TRS Page 参数形式输出
java.lang.String | toURL() 将参数以URL参数信息方式输出
java.lang.String | toURLParameters() 将参数以URL参数信息方式输出
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

PARAM_NAME_SEARCH_KEY

public static final java.lang.String PARAM_NAME_SEARCH_KEY
另请参见：
常量字段值

PARAM_NAME_SEARCH_TABLE

public static final java.lang.String PARAM_NAME_SEARCH_TABLE
另请参见：
常量字段值

PARAM_NAME_SEARCH_VALUE

public static final java.lang.String PARAM_NAME_SEARCH_VALUE
另请参见：
常量字段值

PARAM_NAME_ORDER_FIELD

public static final java.lang.String PARAM_NAME_ORDER_FIELD
另请参见：
常量字段值

PARAM_NAME_ORDER_TYPE

public static final java.lang.String PARAM_NAME_ORDER_TYPE
另请参见：
常量字段值
构造方法详细信息

RequestHelper

public RequestHelper()

RequestHelper

public RequestHelper(javax.servlet.http.HttpServletRequest _request,
                     javax.servlet.http.HttpServletResponse _response,
                     javax.servlet.ServletContext _servletContext)

RequestHelper

public RequestHelper(javax.servlet.http.HttpServletRequest _request,
                     javax.servlet.http.HttpServletResponse _response,
                     javax.servlet.ServletContext _servletContext,
                     boolean _bPostMehthod)
方法详细信息

getRequest

public javax.servlet.http.HttpServletRequest getRequest()
返回：

setRequest

public void setRequest(javax.servlet.http.HttpServletRequest request)
获取当前J2EE容器中的Request对象

参数：
request - 当前J2EE容器中的Request对象（HttpServletRequest）

getResponse

public javax.servlet.http.HttpServletResponse getResponse()
返回：

setResponse

public void setResponse(javax.servlet.http.HttpServletResponse response)
参数：
response -

doValid

public void doValid()
             throws WCMException
抛出：
WCMException

doValid

public void doValid(boolean _bCheckFileExists)
             throws WCMException
根据当前页面的配置文件,解析当前传入页面的参数

抛出：
WCMException

getString

public java.lang.String getString(java.lang.String _sName)
                           throws WCMException
取字符串型属性值

参数：
_sName - 属性字段名称
返回：
String对象
抛出：
WCMException

getDateTime

public CMyDateTime getDateTime(java.lang.String _sName)
                        throws WCMException
取日期时间型属性值

参数：
_sName - 属性字段名称
返回：
CMyDateTime对象
抛出：
WCMException

getDateTime

public CMyDateTime getDateTime(java.lang.String _sName,
                               java.lang.String _sDateFormate)
                        throws WCMException
取日期时间型属性值

参数：
_sName - 属性字段名称
_sDateFormate - 日期类型
返回：
CMyDateTime对象
抛出：
WCMException

getLong

public long getLong(java.lang.String _sName,
                    long _lDefault)
             throws WCMException
取长整型属性值

参数：
_sName - 属性字段名称
_lDefault - 默认值
返回：
long类型的属性值
抛出：
WCMException

getInt

public int getInt(java.lang.String _sName,
                  int _nDefault)
           throws WCMException
取长整型属性值

参数：
_sName - 属性字段名称
_nDefault - 默认值
返回：
int类型的属性值
抛出：
WCMException

getBoolean

public boolean getBoolean(java.lang.String _sName,
                          boolean _bDefault)
                   throws WCMException
取布尔型属性值 说明：0值为false，非0值为true

参数：
_sName - 属性名
_bDefault - 默认值
返回：
boolean类型的属性值
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

toURL

public java.lang.String toURL()
                       throws WCMException
将参数以URL参数信息方式输出

返回：
URL参数字符串
抛出：
WCMException

toURLParameters

public java.lang.String toURLParameters()
                                 throws WCMException
将参数以URL参数信息方式输出

返回：
URL参数字符串
抛出：
WCMException

toHTMLHidden

public java.lang.String toHTMLHidden()
                              throws WCMException
将参数以Hidden元素的形式输出

返回：
Hidden元素字符串
抛出：
WCMException

toTRSRequestParam

public java.lang.String toTRSRequestParam()
                                   throws WCMException
以TRS Page 参数形式输出

返回：
一段初始化TRSPage的JavaScript
抛出：
WCMException

toInitSearchJavaScript

public java.lang.String toInitSearchJavaScript()
                                        throws WCMException
抛出：
WCMException

reloadPageConfig

public void reloadPageConfig()
                      throws WCMException
重新装载页面配置信息

抛出：
WCMException - 如果配置文件无效，抛出

removePageConfig

public void removePageConfig(java.lang.String _sPageName)
删除指定Page的配置，以便重新载入

参数：
_sPageName - 指定的Page Name

getSearchKey

public java.lang.String getSearchKey()
                              throws WCMException
返回：
抛出：
WCMException

setSearchKey

public void setSearchKey(java.lang.String searchKey)
参数：
searchKey -

getSearchValue

public java.lang.String getSearchValue()
                                throws WCMException
返回：
抛出：
WCMException

setSearchValue

public void setSearchValue(java.lang.String searchValue)
参数：
searchValue -

setValue

public java.lang.Object setValue(java.lang.String _sName,
                                 java.lang.String _sValue)

getSearchTableName

public java.lang.String getSearchTableName()
                                    throws WCMException
返回：
抛出：
WCMException

setSearchTableName

public void setSearchTableName(java.lang.String searchTableName)
参数：
searchTableName -

getOrderField

public java.lang.String getOrderField()
                               throws WCMException
返回：
抛出：
WCMException

setOrderField

public void setOrderField(java.lang.String orderField)
参数：
orderField -

getOrderType

public java.lang.String getOrderType()
                              throws WCMException
返回：
抛出：
WCMException

setOrderType

public void setOrderType(java.lang.String orderType)
参数：
orderType -

getPageFilter

public WCMFilter getPageFilter(WCMFilter _extraFilter)
                        throws WCMException
抛出：
WCMException

getWhereSQL

public java.lang.String getWhereSQL()
                             throws WCMException
获取当前条件下的检索语句

返回：
当前条件下的检索语句
抛出：
WCMException

getOrderSQL

public java.lang.String getOrderSQL()
                             throws WCMException
获取当前条件下的排序语句

返回：
当前条件下的排序语句
抛出：
WCMException

handleOpReports

public void handleOpReports(java.lang.String _sResponseUrl,
                            Reports _currReports)
                     throws java.lang.Exception
抛出：
java.lang.Exception

getReports

public Reports getReports()

forward

public void forward(java.lang.String _sURL)
             throws java.lang.Exception
页面带参数跳转到_sURL

参数：
_sURL - 可以传入相对地址，只支持本应用内的页面程序
抛出：
java.lang.Exception

getServerName

public java.lang.String getServerName()
获取服务器名

返回：

getServerPort

public int getServerPort()
获取服务器端口

返回：

sendRedirect

public void sendRedirect(java.lang.String url)
                  throws java.lang.Exception
借助“../tools/custom_page_redirect.jsp”实现保留现有参数的重定向 之所以不直接使用HttpServletResponse的sendRedirect()函数， 是为了屏蔽不同应用服务在进行重定向对相对路径计算的差异。

参数：
url - 目标URL
抛出：
java.lang.Exception - 如果发生错误

realParameters2QueryString

public java.lang.String realParameters2QueryString()
                                            throws WCMException
将参数以URL参数信息方式输出

返回：
URL参数字符串
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResponseHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 ResponseHelper

java.lang.Object
    继承者  com.trs.presentation.util.ResponseHelper

public class ResponseHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ResponseHelper(javax.servlet.http.HttpServletResponse _response)
方法摘要
void | initCurrentPage(javax.servlet.http.HttpServletRequest _request)
void | initCurrentPage(javax.servlet.http.HttpServletRequest _request, java.lang.String _sCache, int _nExpires, int _nMaxage)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResponseHelper

public ResponseHelper(javax.servlet.http.HttpServletResponse _response)
方法详细信息

initCurrentPage

public void initCurrentPage(javax.servlet.http.HttpServletRequest _request)
                     throws WCMException
抛出：
WCMException

initCurrentPage

public void initCurrentPage(javax.servlet.http.HttpServletRequest _request,
                            java.lang.String _sCache,
                            int _nExpires,
                            int _nMaxage)
                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WhereSQLMaker

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.util
类 WhereSQLMaker

java.lang.Object
    继承者  com.trs.presentation.util.WhereSQLMaker

public class WhereSQLMaker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | TYPE_BOOLEAN_HASHCODE Comment for TYPE_BOOLEAN 布尔型
static int | TYPE_DATE_HASHCODE Comment for TYPE_DATE 日期型
static int | TYPE_DATETIME_HASHCODE Comment for TYPE_DATETIME 日期时间型
static int | TYPE_DOUBLE_HASHCODE Comment for TYPE_DOUBLE 双精度
static int | TYPE_FLOAT_HASHCODE Comment for TYPE_FLOAT 浮点型
static int | TYPE_INT_HASHCODE Comment for TYPE_INT 整型
static int | TYPE_LONG_HASHCODE Comment for TYPE_LONG 长整型
static int | TYPE_STRING_HASHCODE Comment for TYPE_STRING 字符型
static int | TYPE_TIME_HASHCODE Comment for TYPE_TIME 时间型
构造方法摘要
WhereSQLMaker(PageParameters parameters)
方法摘要
java.util.List | getSearchValues()
java.lang.String | getWhereSQL()
void | makeWhereSQL(RequestHelper _currRequestHelper)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_STRING_HASHCODE

public static final int TYPE_STRING_HASHCODE
Comment for TYPE_STRING 字符型

另请参见：
常量字段值

TYPE_INT_HASHCODE

public static final int TYPE_INT_HASHCODE
Comment for TYPE_INT 整型

另请参见：
常量字段值

TYPE_LONG_HASHCODE

public static final int TYPE_LONG_HASHCODE
Comment for TYPE_LONG 长整型

另请参见：
常量字段值

TYPE_FLOAT_HASHCODE

public static final int TYPE_FLOAT_HASHCODE
Comment for TYPE_FLOAT 浮点型

另请参见：
常量字段值

TYPE_DOUBLE_HASHCODE

public static final int TYPE_DOUBLE_HASHCODE
Comment for TYPE_DOUBLE 双精度

另请参见：
常量字段值

TYPE_DATE_HASHCODE

public static final int TYPE_DATE_HASHCODE
Comment for TYPE_DATE 日期型

另请参见：
常量字段值

TYPE_TIME_HASHCODE

public static final int TYPE_TIME_HASHCODE
Comment for TYPE_TIME 时间型

另请参见：
常量字段值

TYPE_DATETIME_HASHCODE

public static final int TYPE_DATETIME_HASHCODE
Comment for TYPE_DATETIME 日期时间型

另请参见：
常量字段值

TYPE_BOOLEAN_HASHCODE

public static final int TYPE_BOOLEAN_HASHCODE
Comment for TYPE_BOOLEAN 布尔型

另请参见：
常量字段值
构造方法详细信息

WhereSQLMaker

public WhereSQLMaker(PageParameters parameters)
参数：
parameters -
方法详细信息

makeWhereSQL

public void makeWhereSQL(RequestHelper _currRequestHelper)
                  throws WCMException
抛出：
WCMException

getSearchValues

public java.util.List getSearchValues()
返回：

getWhereSQL

public java.lang.String getWhereSQL()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.presentation.util.AppAutoParameter 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.AppAutoParameter
的使用

使用 AppAutoParameter 的软件包
com.trs.presentation.util

com.trs.presentation.util 中 AppAutoParameter 的使用

返回 AppAutoParameter 的 com.trs.presentation.util 中的方法
 AppAutoParameter AppAutoParameters.getAppAutoParameterByName(java.lang.String _sName)
根据配置名称获取指定的配置

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.AppAutoParameters 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.AppAutoParameters
的使用

使用 AppAutoParameters 的软件包
com.trs.presentation.util

com.trs.presentation.util 中 AppAutoParameters 的使用

返回 AppAutoParameters 的 com.trs.presentation.util 中的方法
static AppAutoParameters | AppAutoParameters.getAppAutoParameters(java.lang.String _sConfigXMLFileName) 根据页面文件获取页面配置参数信息
static AppAutoParameters | AppAutoParameters.reloadAppAutoParameters(java.lang.String _sConfigXMLFileName) 再次装载指定页面文件的页面配置参数信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.CmsObjUnlockTools 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.CmsObjUnlockTools
的使用

没有 com.trs.presentation.util.CmsObjUnlockTools 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.DefaultWhereSQLMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.DefaultWhereSQLMaker
的使用

没有 com.trs.presentation.util.DefaultWhereSQLMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.LoginHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.LoginHelper
的使用

没有 com.trs.presentation.util.LoginHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.PageHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.PageHelper
的使用

没有 com.trs.presentation.util.PageHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.PageParameter 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.PageParameter
的使用

使用 PageParameter 的软件包
com.trs.presentation.util
com.trs.presentation.valid

com.trs.presentation.util 中 PageParameter 的使用

返回 PageParameter 的 com.trs.presentation.util 中的方法
static PageParameter PageParameter.createPageParameterFromXML(org.dom4j.Element _elParameter)
通过一个XML数据产生一个PageParameter对象

com.trs.presentation.valid 中 PageParameter 的使用

参数类型为 PageParameter 的 com.trs.presentation.valid 中的方法
 void IValidator.validParameterValue(PageParameter _currPageParameter, java.lang.String _sValue)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.PageParameters 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.PageParameters
的使用

使用 PageParameters 的软件包
com.trs.presentation.util

com.trs.presentation.util 中 PageParameters 的使用

返回 PageParameters 的 com.trs.presentation.util 中的方法
static PageParameters | PageParameters.getParametersOfPage(java.lang.String _sPageName, java.lang.String _sAbsolutePagePath) 根据页面文件获取页面配置参数信息
static PageParameters | PageParameters.reloadParametersOfPageName(java.lang.String _sPageName, java.lang.String _sAbsolutePagePath) 再次装载指定页面文件的页面配置参数信息

参数类型为 PageParameters 的 com.trs.presentation.util 中的构造方法
WhereSQLMaker(PageParameters parameters)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.PageViewUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.PageViewUtil
的使用

没有 com.trs.presentation.util.PageViewUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.Parameter 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.Parameter
的使用

使用 Parameter 的软件包
com.trs.presentation.util

com.trs.presentation.util 中 Parameter 的使用

com.trs.presentation.util 中 Parameter 的子类
class | AppAutoParameter Title: TRS 内容协作平台（TRS WCM） Description: 代码自动生工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PageParameter Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

返回 Parameter 的 com.trs.presentation.util 中的方法
Parameter | Parameters.createParameterInstance() 产生当前参数对象的实例
Parameter | PageParameters.createParameterInstance()
Parameter | AppAutoParameters.createParameterInstance()
Parameter | Parameters.get(int _nIndex) 获取指定位置的参数对象
Parameter | Parameters.remove(int _nIndex) 删除指定位置的参数对象

参数类型为 Parameter 的 com.trs.presentation.util 中的方法
boolean | Parameters.add(Parameter _oPageParameter) 添加参数对象
boolean | AppAutoParameters.add(Parameter _oPageParameter)
boolean | Parameters.remove(Parameter _oPageParameter) 删除指定的参数对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.Parameters 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.Parameters
的使用

使用 Parameters 的软件包
com.trs.presentation.util

com.trs.presentation.util 中 Parameters 的使用

com.trs.presentation.util 中 Parameters 的子类
class | AppAutoParameters Title: TRS 内容协作平台（TRS WCM） Description: 管理应用程序自动化 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PageParameters Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.RequestHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.RequestHelper
的使用

使用 RequestHelper 的软件包
com.trs.components.infoview.helper
com.trs.components.wcm.content.trsserver
com.trs.presentation.nav
com.trs.presentation.util
com.trs.presentation.wcm.content

com.trs.components.infoview.helper 中 RequestHelper 的使用

参数类型为 RequestHelper 的 com.trs.components.infoview.helper 中的方法
static InfoViewDocuments | InfoViewNewQueryHelper.queryData(RequestHelper requestHelper)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML(RequestHelper _requestHelper)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML2(RequestHelper _requestHelper)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML3(RequestHelper _requestHelper)
static Documents | InfoViewNewQueryHelper.queryDocuments(RequestHelper requestHelper)

com.trs.components.wcm.content.trsserver 中 RequestHelper 的使用

参数类型为 RequestHelper 的 com.trs.components.wcm.content.trsserver 中的方法
static TRSSearcher | TRSSearcherFactory.buildSearcher(RequestHelper _currRequestHelper, User _loginUser) 构造TRS检索条件Searcher
static TRSSearcher | TRSSearcher.getTRSSearcher(RequestHelper _currRequestHelper, User _loginUser) 从当前请求中获取TRS检索对象

com.trs.presentation.nav 中 RequestHelper 的使用

参数类型为 RequestHelper 的 com.trs.presentation.nav 中的构造方法
TreeCreator(User _loginUser, RequestHelper _requestHelper, javax.servlet.jsp.JspWriter _out)

com.trs.presentation.util 中 RequestHelper 的使用

参数类型为 RequestHelper 的 com.trs.presentation.util 中的方法
 void WhereSQLMaker.makeWhereSQL(RequestHelper _currRequestHelper)

com.trs.presentation.wcm.content 中 RequestHelper 的使用

参数类型为 RequestHelper 的 com.trs.presentation.wcm.content 中的构造方法
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, BaseChannel _baseChannel)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, Channel _channel)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, WebSite _site)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.ResponseHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.ResponseHelper
的使用

没有 com.trs.presentation.util.ResponseHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.util.WhereSQLMaker 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.util.WhereSQLMaker
的使用

没有 com.trs.presentation.util.WhereSQLMaker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IValidator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.valid
接口 IValidator

public interface IValidator

An object that works with an IFormComponentto format output (convert object values to strings values) and to process input (convert strings to object values and validate them).

从以下版本开始：
1.0.1
版本：
$Id: IValidator.java,v 1.2 2009/10/12 09:59:48 wenyehui Exp $
作者：
CH

方法摘要
boolean | isRequired() All validators must implement a required property.
void | validParameterValue(PageParameter _currPageParameter, java.lang.String _sValue)

方法详细信息

isRequired

boolean isRequired()
All validators must implement a required property. If true, the client must supply a non-null value.

validParameterValue

void validParameterValue(PageParameter _currPageParameter,
                         java.lang.String _sValue)
                         throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.valid
接口
IValidator


com.trs.presentation.valid

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.valid

接口摘要
IValidator An object that works with an IFormComponentto format output (convert object values to strings values) and to process input (convert strings to object values and validate them).


com.trs.presentation.valid 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.valid 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • com.trs.presentation.valid.IValidator


软件包 com.trs.presentation.valid 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.valid
的使用

没有 com.trs.presentation.valid 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.presentation.valid.IValidator 的使用

上一个 下一个 框架 无框架

接口 com.trs.presentation.valid.IValidator
的使用

没有 com.trs.presentation.valid.IValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DocumentsPageHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.presentation.wcm.content
类 DocumentsPageHelper

java.lang.Object
    继承者  com.trs.presentation.wcm.content.DocumentsPageHelper

public class DocumentsPageHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
文档列表页面业务逻辑管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, BaseChannel _baseChannel)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, Channel _channel)
DocumentsPageHelper(User _loginUser, RequestHelper _requestHelper, WebSite _site)
方法摘要
boolean | canDoAddDoc()
boolean | canDoOperteOnNotEmpty(int _nRightIndex)
boolean | canDoPreview(Document _document)
boolean | canDoPub()
void | doForwardIfNeed()
Channel | getDocChannel(Document _document)
Documents | getDocuments(java.lang.String _sOrderFields, java.lang.String _sSelectFields)
java.lang.String | getLogicRightValue()
java.lang.String | getLogicRightValue(Document _currDocument)
boolean | hasRight(int _nRightIndex)
boolean | hasRight(int _nRightIndex, Document _document)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentsPageHelper

public DocumentsPageHelper(User _loginUser,
                           RequestHelper _requestHelper,
                           Channel _channel)
                    throws WCMException
抛出：
WCMException

DocumentsPageHelper

public DocumentsPageHelper(User _loginUser,
                           RequestHelper _requestHelper,
                           WebSite _site)
                    throws WCMException
抛出：
WCMException

DocumentsPageHelper

public DocumentsPageHelper(User _loginUser,
                           RequestHelper _requestHelper)
                    throws WCMException
抛出：
WCMException

DocumentsPageHelper

public DocumentsPageHelper(User _loginUser,
                           RequestHelper _requestHelper,
                           BaseChannel _baseChannel)
                    throws WCMException
抛出：
WCMException
方法详细信息

doForwardIfNeed

public void doForwardIfNeed()
                     throws java.lang.Exception
抛出：
java.lang.Exception

getDocuments

public Documents getDocuments(java.lang.String _sOrderFields,
                              java.lang.String _sSelectFields)
                       throws WCMException
参数：
_sOrderFields -
_sSelectFields -
返回：
抛出：
WCMException

getLogicRightValue

public java.lang.String getLogicRightValue()
                                    throws WCMException
返回：
抛出：
WCMException

getLogicRightValue

public java.lang.String getLogicRightValue(Document _currDocument)
                                    throws WCMException
参数：
_currDocument -
返回：
抛出：
WCMException

canDoAddDoc

public boolean canDoAddDoc()
                    throws WCMException
返回：
抛出：
WCMException

canDoPub

public boolean canDoPub()
                 throws WCMException
返回：
抛出：
WCMException

canDoOperteOnNotEmpty

public boolean canDoOperteOnNotEmpty(int _nRightIndex)
                              throws WCMException
抛出：
WCMException

hasRight

public boolean hasRight(int _nRightIndex)
                 throws WCMException
抛出：
WCMException

getDocChannel

public Channel getDocChannel(Document _document)
                      throws WCMException
抛出：
WCMException

hasRight

public boolean hasRight(int _nRightIndex,
                        Document _document)
                 throws WCMException
抛出：
WCMException

canDoPreview

public boolean canDoPreview(Document _document)
                     throws WCMException
抛出：
WCMException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.presentation.wcm.content
类
DocumentsPageHelper


com.trs.presentation.wcm.content

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.presentation.wcm.content

类摘要
DocumentsPageHelper Title: TRS 内容协作平台（TRS WCM）
Description:
文档列表页面业务逻辑管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.presentation.wcm.content 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.presentation.wcm.content 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.presentation.wcm.content.DocumentsPageHelper


软件包 com.trs.presentation.wcm.content 的使用

上一个 下一个 框架 无框架

软件包 com.trs.presentation.wcm.content
的使用

没有 com.trs.presentation.wcm.content 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.presentation.wcm.content.DocumentsPageHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.presentation.wcm.content.DocumentsPageHelper
的使用

没有 com.trs.presentation.wcm.content.DocumentsPageHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.scene.parser
类
SceneConnector
SceneNode
ScenePathsParser
SceneXMLParser


com.trs.scene.parser

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.scene.parser

类摘要
SceneConnector
SceneNode
ScenePathsParser
SceneXMLParser


com.trs.scene.parser 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.scene.parser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.scene.parser.SceneConnector
    • com.trs.scene.parser.SceneNode
    • com.trs.scene.parser.ScenePathsParser
    • com.trs.scene.parser.SceneXMLParser


软件包 com.trs.scene.parser 的使用

上一个 下一个 框架 无框架

软件包 com.trs.scene.parser
的使用

使用 com.trs.scene.parser 的软件包
com.trs.scene.parser

com.trs.scene.parser 使用的 com.trs.scene.parser 中的类
SceneConnector
SceneNode

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SceneConnector

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.parser
类 SceneConnector

java.lang.Object
    继承者  com.trs.scene.parser.SceneConnector

public class SceneConnector
extends java.lang.Object

作者：
曹辉

构造方法摘要
SceneConnector(int _nId, java.lang.String _sName)
方法摘要
int | getId()
java.lang.String | getName()
SceneNode | getNextNode()
SceneNode | getPreNode()
void | setId(int _sId)
void | setName(java.lang.String _sName)
void | setNextNode(SceneNode _sNextNode)
void | setPreNode(SceneNode _sPreNode)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SceneConnector

public SceneConnector(int _nId,
                      java.lang.String _sName)
方法详细信息

getName

public java.lang.String getName()

setName

public void setName(java.lang.String _sName)

getId

public int getId()

setId

public void setId(int _sId)

getPreNode

public SceneNode getPreNode()

setPreNode

public void setPreNode(SceneNode _sPreNode)

getNextNode

public SceneNode getNextNode()

setNextNode

public void setNextNode(SceneNode _sNextNode)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SceneNode

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.parser
类 SceneNode

java.lang.Object
    继承者  com.trs.scene.parser.SceneNode

public class SceneNode
extends java.lang.Object

构造方法摘要
SceneNode(int _nId, java.lang.String _sName)
方法摘要
void | addNextConnector(SceneConnector _nextConnector)
int | getId()
java.lang.Integer | getKey()
java.lang.String | getName()
java.util.ArrayList | getNextConnectors()
void | setId(int _id)
void | setName(java.lang.String _name)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SceneNode

public SceneNode(int _nId,
                 java.lang.String _sName)
方法详细信息

getName

public java.lang.String getName()

setName

public void setName(java.lang.String _name)

getId

public int getId()

setId

public void setId(int _id)

getNextConnectors

public java.util.ArrayList getNextConnectors()

addNextConnector

public void addNextConnector(SceneConnector _nextConnector)

getKey

public java.lang.Integer getKey()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScenePathsParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.parser
类 ScenePathsParser

java.lang.Object
    继承者  com.trs.scene.parser.ScenePathsParser

public class ScenePathsParser
extends java.lang.Object

作者：
曹辉

构造方法摘要
ScenePathsParser(SceneNode _oFirstNode)
方法摘要
 SceneConnector[][] parse()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScenePathsParser

public ScenePathsParser(SceneNode _oFirstNode)
方法详细信息

parse

public SceneConnector[][] parse()
                         throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SceneXMLParser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.parser
类 SceneXMLParser

java.lang.Object
    继承者  com.trs.scene.parser.SceneXMLParser

public class SceneXMLParser
extends java.lang.Object

作者：
曹辉

构造方法摘要
SceneXMLParser(java.lang.String _sXMLContent)
方法摘要
 SceneNode parse()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SceneXMLParser

public SceneXMLParser(java.lang.String _sXMLContent)
方法详细信息

parse

public SceneNode parse()
                throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.scene.parser.SceneConnector 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.parser.SceneConnector
的使用

使用 SceneConnector 的软件包
com.trs.scene.parser

com.trs.scene.parser 中 SceneConnector 的使用

返回 SceneConnector 的 com.trs.scene.parser 中的方法
 SceneConnector[][] ScenePathsParser.parse()

参数类型为 SceneConnector 的 com.trs.scene.parser 中的方法
 void SceneNode.addNextConnector(SceneConnector _nextConnector)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.scene.parser.SceneNode 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.parser.SceneNode
的使用

使用 SceneNode 的软件包
com.trs.scene.parser

com.trs.scene.parser 中 SceneNode 的使用

返回 SceneNode 的 com.trs.scene.parser 中的方法
SceneNode | SceneConnector.getNextNode()
SceneNode | SceneConnector.getPreNode()
SceneNode | SceneXMLParser.parse()

参数类型为 SceneNode 的 com.trs.scene.parser 中的方法
void | SceneConnector.setNextNode(SceneNode _sNextNode)
void | SceneConnector.setPreNode(SceneNode _sPreNode)

参数类型为 SceneNode 的 com.trs.scene.parser 中的构造方法
ScenePathsParser(SceneNode _oFirstNode)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.scene.parser.ScenePathsParser 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.parser.ScenePathsParser
的使用

没有 com.trs.scene.parser.ScenePathsParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.scene.parser.SceneXMLParser 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.parser.SceneXMLParser
的使用

没有 com.trs.scene.parser.SceneXMLParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.scene.tools
类
SceneAutoCreator
SceneNode
SceneNodeAction
SceneNodeParser
SceneNodeToXML


com.trs.scene.tools

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.scene.tools

类摘要
SceneAutoCreator |
SceneNode |
SceneNodeAction |
SceneNodeParser | Title: TRS 内容协作平台（TRS WCM） Description: 分类法定义工具 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SceneNodeToXML |


com.trs.scene.tools 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.scene.tools 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.scene.tools.SceneAutoCreator
    • com.trs.scene.tools.SceneNode
    • com.trs.scene.tools.SceneNodeAction
    • com.trs.scene.tools.SceneNodeParser
    • com.trs.scene.tools.SceneNodeToXML


软件包 com.trs.scene.tools 的使用

上一个 下一个 框架 无框架

软件包 com.trs.scene.tools
的使用

使用 com.trs.scene.tools 的软件包
com.trs.scene.tools

com.trs.scene.tools 使用的 com.trs.scene.tools 中的类
SceneNode

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SceneAutoCreator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.tools
类 SceneAutoCreator

java.lang.Object
    继承者  com.trs.scene.tools.SceneAutoCreator

public class SceneAutoCreator
extends java.lang.Object

作者：
micah

构造方法摘要
SceneAutoCreator()
方法摘要
void | changeTempName()
static void | copy(java.io.File source, java.io.File target) 拷贝一个目录或者文件到指定路径下
void | copyImage() 将模板中所用到的图片和部分flash文件拷贝到preview/pub中，防止zip上传时造成的文件丢失，预览效果差。
int | Create()
void | deleteAll()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SceneAutoCreator

public SceneAutoCreator()
方法详细信息

Create

public int Create()
           throws java.lang.Exception
抛出：
java.lang.Exception

changeTempName

public void changeTempName()
                    throws CMyException
抛出：
CMyException

copyImage

public void copyImage()
               throws CMyException
将模板中所用到的图片和部分flash文件拷贝到preview/pub中，防止zip上传时造成的文件丢失，预览效果差。

抛出：
CMyException

deleteAll

public void deleteAll()
               throws WCMException
抛出：
WCMException

copy

public static void copy(java.io.File source,
                        java.io.File target)
拷贝一个目录或者文件到指定路径下

参数：
source -
target -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SceneNode

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.tools
类 SceneNode

java.lang.Object
    继承者  com.trs.scene.tools.SceneNode

public class SceneNode
extends java.lang.Object

作者：
Administrator

字段摘要
static int | HEIGHT 节点高度
int | m_nX
int | m_nY
SceneNode | m_oParentNode
SceneNode | m_oRootNode
static int | TYPE_LINE
static int | TYPE_NORM
static int | TYPE_START 开始节点
static int | WIDTH 节点长度
static int | X_DISTANCE 水平距离
static int | Y_DISTANCE 垂直距离
构造方法摘要
SceneNode(java.lang.String _sName, int _nType)
方法摘要
SceneNode | addChildNode(java.lang.String _sName, int _nTabCount) 添加一个子节点
java.util.ArrayList | getChildren() 获取子节点
int | getFirstChildId()
int | getId()
int | getLevel()
java.lang.String | getName()
int | getNextId()
int | getParentId()
SceneNode | getParentNode()
int | getPositionX() 获取X坐标
int | getPositionY() 获取Y坐标
int | getTabCount()
int | getType()
void | setPositionX(int _positionX) 设置X坐标
void | setPositionY(int _positionY) 设置Y坐标
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

WIDTH

public static final int WIDTH
节点长度

另请参见：
常量字段值

HEIGHT

public static final int HEIGHT
节点高度

另请参见：
常量字段值

X_DISTANCE

public static final int X_DISTANCE
水平距离

另请参见：
常量字段值

Y_DISTANCE

public static final int Y_DISTANCE
垂直距离

另请参见：
常量字段值

TYPE_START

public static final int TYPE_START
开始节点

另请参见：
常量字段值

TYPE_NORM

public static final int TYPE_NORM
另请参见：
常量字段值

TYPE_LINE

public static final int TYPE_LINE
另请参见：
常量字段值

m_oParentNode

public SceneNode m_oParentNode

m_oRootNode

public SceneNode m_oRootNode

m_nX

public int m_nX

m_nY

public int m_nY
构造方法详细信息

SceneNode

public SceneNode(java.lang.String _sName,
                 int _nType)
方法详细信息

addChildNode

public SceneNode addChildNode(java.lang.String _sName,
                              int _nTabCount)
                       throws WCMException
添加一个子节点

参数：
_sName -
返回：
抛出：
WCMException

getTabCount

public int getTabCount()

getType

public int getType()

getChildren

public java.util.ArrayList getChildren()
获取子节点

返回：

setPositionY

public void setPositionY(int _positionY)
设置Y坐标

参数：
_positionY -

setPositionX

public void setPositionX(int _positionX)
设置X坐标

参数：
_positionX -

getPositionX

public int getPositionX()
获取X坐标

返回：

getPositionY

public int getPositionY()
获取Y坐标

返回：

getLevel

public int getLevel()

getParentNode

public SceneNode getParentNode()

getName

public java.lang.String getName()

getId

public int getId()

getParentId

public int getParentId()

getFirstChildId

public int getFirstChildId()

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getNextId

public int getNextId()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SceneNodeAction

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.tools
类 SceneNodeAction

java.lang.Object
    继承者  com.trs.scene.tools.SceneNodeAction

public class SceneNodeAction
extends java.lang.Object

构造方法摘要
SceneNodeAction(SceneNode _root)
构造函数
方法摘要
void | confirmPosition(SceneNode _root) 确定该树中所有节点的位置
void | confirmPositionX(SceneNode _root) 通过先确定叶子节点的X位置，然后从下往上依次计算出非叶子节点X位置
void | confirmPositionY(SceneNode _root) 通过每一层节点的深度，确定每个节点的Y坐标
java.util.ArrayList | getAllNodes() 获取所有node
java.util.ArrayList | getChilrenNodes(java.util.ArrayList _arrLevelNodes) 获取当前层节点的所有子节点
void | getNodes(SceneNode _root) 获取所有的节点ArrayList 所有保存在一个大ArrayList中,每一层又保存在一个ArrayList中
int | getParentX(SceneNode _parentNode) 通过该节点的子节点获得其x坐标
void | getTraverseNodes(SceneNode _root) 获取所有的叶子节点，叶子节点按从左到右的顺序加入到ArrayList中 算法：后续遍历，只保存叶子节点
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SceneNodeAction

public SceneNodeAction(SceneNode _root)
构造函数

参数：
_root -
方法详细信息

getAllNodes

public java.util.ArrayList getAllNodes()
获取所有node

返回：

confirmPosition

public void confirmPosition(SceneNode _root)
确定该树中所有节点的位置

参数：
_root -

confirmPositionX

public void confirmPositionX(SceneNode _root)
通过先确定叶子节点的X位置，然后从下往上依次计算出非叶子节点X位置

参数：
_root -

getParentX

public int getParentX(SceneNode _parentNode)
通过该节点的子节点获得其x坐标

参数：
_parentNode -
返回：

confirmPositionY

public void confirmPositionY(SceneNode _root)
通过每一层节点的深度，确定每个节点的Y坐标

参数：
_root -

getTraverseNodes

public void getTraverseNodes(SceneNode _root)
获取所有的叶子节点，叶子节点按从左到右的顺序加入到ArrayList中 算法：后续遍历，只保存叶子节点

参数：
_root -

getNodes

public void getNodes(SceneNode _root)
获取所有的节点ArrayList 所有保存在一个大ArrayList中,每一层又保存在一个ArrayList中

参数：
_root -

getChilrenNodes

public java.util.ArrayList getChilrenNodes(java.util.ArrayList _arrLevelNodes)
获取当前层节点的所有子节点

参数：
_arrLevelNodes -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SceneNodeParser

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.tools
类 SceneNodeParser

java.lang.Object
    继承者  com.trs.scene.tools.SceneNodeParser

public class SceneNodeParser
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
分类法定义工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SceneNodeParser()
方法摘要
SceneNode | importFormFileByName(java.lang.String _sFileName)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SceneNodeParser

public SceneNodeParser()
方法详细信息

importFormFileByName

public SceneNode importFormFileByName(java.lang.String _sFileName)
                               throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SceneNodeToXML

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.scene.tools
类 SceneNodeToXML

java.lang.Object
    继承者  com.trs.scene.tools.SceneNodeToXML

public class SceneNodeToXML
extends java.lang.Object

作者：
Administrator

构造方法摘要
SceneNodeToXML()
方法摘要
static java.lang.String | format(org.dom4j.Element element)
static void | main(java.lang.String[] args)
static java.lang.String | toXML(SceneNode _rootSceneNode)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SceneNodeToXML

public SceneNodeToXML()
方法详细信息

toXML

public static java.lang.String toXML(SceneNode _rootSceneNode)
                              throws java.lang.Exception
抛出：
java.lang.Exception

format

public static java.lang.String format(org.dom4j.Element element)

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.scene.tools.SceneAutoCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.tools.SceneAutoCreator
的使用

没有 com.trs.scene.tools.SceneAutoCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.scene.tools.SceneNode 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.tools.SceneNode
的使用

使用 SceneNode 的软件包
com.trs.scene.tools

com.trs.scene.tools 中 SceneNode 的使用

声明为 SceneNode 的 com.trs.scene.tools 中的字段
SceneNode | SceneNode.m_oParentNode
SceneNode | SceneNode.m_oRootNode

返回 SceneNode 的 com.trs.scene.tools 中的方法
SceneNode | SceneNode.addChildNode(java.lang.String _sName, int _nTabCount) 添加一个子节点
SceneNode | SceneNode.getParentNode()
SceneNode | SceneNodeParser.importFormFileByName(java.lang.String _sFileName)

参数类型为 SceneNode 的 com.trs.scene.tools 中的方法
void | SceneNodeAction.confirmPosition(SceneNode _root) 确定该树中所有节点的位置
void | SceneNodeAction.confirmPositionX(SceneNode _root) 通过先确定叶子节点的X位置，然后从下往上依次计算出非叶子节点X位置
void | SceneNodeAction.confirmPositionY(SceneNode _root) 通过每一层节点的深度，确定每个节点的Y坐标
void | SceneNodeAction.getNodes(SceneNode _root) 获取所有的节点ArrayList 所有保存在一个大ArrayList中,每一层又保存在一个ArrayList中
int | SceneNodeAction.getParentX(SceneNode _parentNode) 通过该节点的子节点获得其x坐标
void | SceneNodeAction.getTraverseNodes(SceneNode _root) 获取所有的叶子节点，叶子节点按从左到右的顺序加入到ArrayList中 算法：后续遍历，只保存叶子节点
static java.lang.String | SceneNodeToXML.toXML(SceneNode _rootSceneNode)

参数类型为 SceneNode 的 com.trs.scene.tools 中的构造方法
SceneNodeAction(SceneNode _root)
构造函数

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.scene.tools.SceneNodeAction 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.tools.SceneNodeAction
的使用

没有 com.trs.scene.tools.SceneNodeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.scene.tools.SceneNodeParser 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.tools.SceneNodeParser
的使用

没有 com.trs.scene.tools.SceneNodeParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.scene.tools.SceneNodeToXML 的使用

上一个 下一个 框架 无框架

类 com.trs.scene.tools.SceneNodeToXML
的使用

没有 com.trs.scene.tools.SceneNodeToXML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


IAutoDocBakService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IAutoDocBakService

所有已知实现类：
AutoDocBakService
public interface IAutoDocBakService

Title: TRS 内容协作平台（TRS WCM）
Description:
文档版本自动保存接口设计
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
AutoBakConfig | getAutoSaveConfig(int _nSiteId) 获取指定站点上所有关于文档版本自动保存的配置信息
void | removeConfig(int _nSiteId) 删除指定站点上所有关于文档版本自动保存的配置信息
AutoBakConfig | save(AutoBakConfig _currConfig) 保存站点上关于文档版本自动保存的配置信息

方法详细信息

save

AutoBakConfig save(AutoBakConfig _currConfig)
                   throws WCMException
保存站点上关于文档版本自动保存的配置信息

参数：
_currConfig -
返回：
TODO
抛出：
WCMException

removeConfig

void removeConfig(int _nSiteId)
                  throws WCMException
删除指定站点上所有关于文档版本自动保存的配置信息

参数：
_nSiteId -
抛出：
WCMException

getAutoSaveConfig

AutoBakConfig getAutoSaveConfig(int _nSiteId)
                                throws WCMException
获取指定站点上所有关于文档版本自动保存的配置信息

参数：
_nSiteId -
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IBookMarkService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IBookMarkService

所有已知实现类：
BookMarkService
public interface IBookMarkService

Title: TRS 内容协作平台（TRS WCM）
Description:
IBookMarkServic接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | cancelShares(int _nObjType, java.lang.String _sObjIds) 取消共享
boolean | deleteBookMark(int _nBookMarkId) 删除指定的书签
boolean | deleteBookMark(java.lang.String _sBookMarkIds) 删除指定的书签集合
boolean | deleteMarkKind(int _nMarkKindId) 删除指定的书签文件夹
boolean | deleteMarkKind(java.lang.String _sMarkKindIds) 删除指定的书签文件夹集合
BookMarks | getBookMarks(int _nMarkKindId) 根据传入的MarkKind ID，获取它所包含的BookMarks
BookMarks | getBookMarks(int _nMarkKindId, WCMFilter _filter) 根据传入的MarkKind ID，获取它所包含的BookMarks
BookMarks | getBookMarks(WCMFilter _filter) 获取BookMarks集合
MarkKinds | getChildren(int _nMarkKindId, WCMFilter _filter) 根据传入的MarkKind ID，获取它的子MarkKinds
BookMarks | getSharedBookMarks(User _currUser, WCMFilter _fliter) 获取所有共享的书签
Groups | getSharedGroups(int _nObjType, int _nObjId) 获取共享组织
MarkKinds | getSharedMarkKinds(User _currUser, WCMFilter _filter) 获取所有共享的书签文件夹
Users | getSharedUsers(int _nObjType, int _nObjId) 获取共享用户
void | moveBookMark(int _nBookMarkId, int _nMarkKindId) 移动指定书签到目标书签文件夹下
void | moveBookMark(java.lang.String _sBookMarkIds, int _nMarkKindId) 移动指定书签集合到目标书签文件夹下
Reports | moveBookMarks(java.lang.String _sMarkIds, int _nMarkKindId) 移动指定的书签集合到目标书签夹下.
void | moveMarkKind(int _nMarkKindId, int _nNewParentId) 移动指定书签文件夹到一个新的书签文件夹下
void | moveMarkKind(java.lang.String _sMarkKindIds, int _nNewParentId) 移动指定书签文件夹集合到一个新的书签文件夹下
BookMark | save(BookMark _aBookMark) 保存一个BookMark
MarkKind | save(MarkKind _aMarkKind) 保存一个MarkKind
void | shareTo(int _nObjType, java.lang.String _sObjIds, int _nShareObjType, java.lang.String _sShareObjIds) 设置共享

方法详细信息

save

BookMark save(BookMark _aBookMark)
              throws WCMException
保存一个BookMark

参数：
_aBookMark -
返回：
@throws WCMException
抛出：
WCMException

deleteBookMark

boolean deleteBookMark(int _nBookMarkId)
                       throws WCMException
删除指定的书签

参数：
_nBookMarkId -
返回：
@throws WCMException
抛出：
WCMException

deleteBookMark

boolean deleteBookMark(java.lang.String _sBookMarkIds)
                       throws WCMException
删除指定的书签集合

参数：
_sBookMarkIds -
返回：
@throws WCMException
抛出：
WCMException

deleteMarkKind

boolean deleteMarkKind(int _nMarkKindId)
                       throws WCMException
删除指定的书签文件夹

参数：
_nMarkKindId -
返回：
@throws WCMException
抛出：
WCMException

deleteMarkKind

boolean deleteMarkKind(java.lang.String _sMarkKindIds)
                       throws WCMException
删除指定的书签文件夹集合

参数：
_sMarkKindIds -
返回：
@throws WCMException
抛出：
WCMException

getBookMarks

BookMarks getBookMarks(int _nMarkKindId,
                       WCMFilter _filter)
                       throws WCMException
根据传入的MarkKind ID，获取它所包含的BookMarks

参数：
_nMarkKindId -
_filter -
返回：
@throws WCMException
抛出：
WCMException

getBookMarks

BookMarks getBookMarks(WCMFilter _filter)
                       throws WCMException
获取BookMarks集合

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getBookMarks

BookMarks getBookMarks(int _nMarkKindId)
                       throws WCMException
根据传入的MarkKind ID，获取它所包含的BookMarks

参数：
_nMarkKindId -
_filter -
返回：
@throws WCMException
抛出：
WCMException

getChildren

MarkKinds getChildren(int _nMarkKindId,
                      WCMFilter _filter)
                      throws WCMException
根据传入的MarkKind ID，获取它的子MarkKinds

参数：
_nMarkKindId -
_filter -
返回：
@throws WCMException
抛出：
WCMException

getSharedBookMarks

BookMarks getSharedBookMarks(User _currUser,
                             WCMFilter _fliter)
                             throws WCMException
获取所有共享的书签

参数：
_currUser -
_fliter -
返回：
@throws WCMException
抛出：
WCMException

getSharedMarkKinds

MarkKinds getSharedMarkKinds(User _currUser,
                             WCMFilter _filter)
                             throws WCMException
获取所有共享的书签文件夹

参数：
_currUser -
_filter -
返回：
@throws WCMException
抛出：
WCMException

save

MarkKind save(MarkKind _aMarkKind)
              throws WCMException
保存一个MarkKind

参数：
_aMarkKind -
返回：
@throws WCMException 如果保存失败，则抛出异常。如果成功则返回这个MarkKind
抛出：
WCMException

getSharedUsers

Users getSharedUsers(int _nObjType,
                     int _nObjId)
                     throws WCMException
获取共享用户

参数：
_nObjType -
_nObjId -
返回：
@throws WCMException
抛出：
WCMException

getSharedGroups

Groups getSharedGroups(int _nObjType,
                       int _nObjId)
                       throws WCMException
获取共享组织

参数：
_nObjId -
_ObjType -
返回：
@throws WCMException
抛出：
WCMException

shareTo

void shareTo(int _nObjType,
             java.lang.String _sObjIds,
             int _nShareObjType,
             java.lang.String _sShareObjIds)
             throws WCMException
设置共享

参数：
_nObjType -
_sObjIds -
_sViewerIds -
_nViewerType -
抛出：
WCMException

moveBookMark

void moveBookMark(int _nBookMarkId,
                  int _nMarkKindId)
                  throws WCMException
移动指定书签到目标书签文件夹下

参数：
_nBookMarkId -
_nMarkKindId -
抛出：
WCMException

moveBookMark

void moveBookMark(java.lang.String _sBookMarkIds,
                  int _nMarkKindId)
                  throws WCMException
移动指定书签集合到目标书签文件夹下

参数：
_sBookMarkIds -
_nMarkKindId -
抛出：
WCMException

moveBookMarks

Reports moveBookMarks(java.lang.String _sMarkIds,
                      int _nMarkKindId)
                      throws WCMException
移动指定的书签集合到目标书签夹下.

参数：
_sMarkIds - 要移动的书签ID序列,以字符','分隔.
_nMarkKindId - 目标书签夹id.
返回：
处理结果.
抛出：
WCMException

moveMarkKind

void moveMarkKind(int _nMarkKindId,
                  int _nNewParentId)
                  throws WCMException
移动指定书签文件夹到一个新的书签文件夹下

参数：
_nMarkKindId -
_nNewParentId -
抛出：
WCMException

moveMarkKind

void moveMarkKind(java.lang.String _sMarkKindIds,
                  int _nNewParentId)
                  throws WCMException
移动指定书签文件夹集合到一个新的书签文件夹下

参数：
_sMarkKindIds -
_nNewParentId -
抛出：
WCMException

cancelShares

void cancelShares(int _nObjType,
                  java.lang.String _sObjIds)
                  throws WCMException
取消共享

参数：
_nObjType -
_sObjIds -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICDSService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 ICDSService

所有已知实现类：
CDSServiceImpl
public interface ICDSService

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String | getAllChannelsXML(boolean _bIncludeChildren) 获取系统树状结构信息
java.lang.String | getChannelsXML(BaseChannel _oBaseChannel, boolean _bIncludeChildren) 获取指定站点或频道的树状结构信息
java.lang.String | getSystemInfo(java.lang.String _sCDSType, int _nParentSiteId, int _nParentChannelId) 根据CDS传入的参数，获取指定的系统信息
java.lang.String | getSystemInfo(java.lang.String _sCDSType, int _nParentSiteId, int _nParentChannelId, java.lang.String _sSiteFields, java.lang.String _sChannelFields) 根据CDS传入的参数，获取指定的系统信息

方法详细信息

getSystemInfo

java.lang.String getSystemInfo(java.lang.String _sCDSType,
                               int _nParentSiteId,
                               int _nParentChannelId,
                               java.lang.String _sSiteFields,
                               java.lang.String _sChannelFields)
                               throws WCMException
根据CDS传入的参数，获取指定的系统信息

参数：
_sCDSType - CDS获取数据的模式
_nParentSiteId - 父站点ID
_nParentChannelId - 父频道ID
_sSiteFields - 站点字段列表
_sChannelFields - 显示的频道字段列表
返回：
抛出：
WCMException

getSystemInfo

java.lang.String getSystemInfo(java.lang.String _sCDSType,
                               int _nParentSiteId,
                               int _nParentChannelId)
                               throws WCMException
根据CDS传入的参数，获取指定的系统信息

参数：
_sCDSType - CDS获取数据的模式
_nParentSiteId - 父站点ID
_nParentChannelId - 父频道ID
返回：
以XML方式组织的系统信息
抛出：
WCMException - TODO

getChannelsXML

java.lang.String getChannelsXML(BaseChannel _oBaseChannel,
                                boolean _bIncludeChildren)
                                throws WCMException
获取指定站点或频道的树状结构信息

参数：
_oBaseChannel - 指定站点或频道
_bIncludeChildren - 是否包括子节点
返回：
以XML方式组织的系统信息
抛出：
WCMException - TODO

getAllChannelsXML

java.lang.String getAllChannelsXML(boolean _bIncludeChildren)
                                   throws WCMException
获取系统树状结构信息

参数：
_bIncludeChildren - TODO
返回：
以XML方式组织的系统信息
抛出：
WCMException - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IChannelService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IChannelService

所有已知实现类：
ChannelService
public interface IChannelService

Title: TRS 内容协作平台（TRS WCM）
Description:
站点/频道服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | addGroupsToSite(java.lang.String _sGroupIds, WebSite _site) 给指定的站点添加指定的用户组
void | addRolesToSite(java.lang.String _sRoleIds, WebSite _site) 给指定的站点添加指定的角色
void | addSitesToGroup(java.lang.String _sSiteIds, Group _group) 给指定的用户组添加指定的站点
void | addSitesToUser(java.lang.String _sSiteIds, User _currUser) 给指定的用户添加指定的站点
void | addUsersToSite(java.lang.String _sUserIds, WebSite _currSite) 给指定的站点添加指定的用户
Reports | createFrom(Channel _srcChannel, BaseChannel _parent) 频道的类似创建的实现 从指定的频道获取频道的相关属性,创建一个新的频道 新频道与源频道有基本相同的属性.
Reports | createFrom(int _nChannelId, BaseChannel _parent) 频道的类似创建的实现
Reports | createFrom(int _nSiteId, boolean _bWithRelated) 站点的类似创建的实现
Reports | createFrom(WebSite _srcSite, boolean _bWithRelated) 站点的类似创建的实现 从指定的站点获取站点的相关属性,创建一个新的站点.
boolean | delete(BaseChannel _oChannel, boolean _bDrop) 删除站点/频道
boolean | delete(Channels _currChannels, boolean _bDrop) 删除频道集合
boolean | delete(java.lang.String _sChannelIds, boolean _bDrop) 根据频道id列表，删除频道集合
void | deleteChannelSyn(int _nChnlSynId)
void | deleteChannelSyns(java.lang.String _sChnlSynIds)
void | deleteContentLink(ContentLink _contentLink)
void | deleteContentLinks(ContentLinks _contentLinks)
void | deleteExtFields(BaseChannel _siteOrChannel, java.lang.String _extFieldIds, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
void | deleteExtFiled(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
boolean | deleteReplace(Replace _aReplace) 删除替换内容对象
boolean | deleteReplace(Replaces _aReplaces) 删除替换内容对象集合
void | emptyRecycleBin(int _nChannelId) 清空指定频道的文档回收站 删除指定频道回收站中的所有文档.
java.lang.String | export(BaseChannel _fromChannel, boolean _bWithChildren, boolean _bWithRelated) 将WCM的站点、频道导出成为WCM XML标准格式的字符串
java.lang.String | export(Channels _fromChannels, boolean _bWithChildren, boolean _bWithRelated)
java.lang.String | export(WebSites _fromWebSites, boolean _bWithChildren, boolean _bWithRelated)
java.lang.String | exportChannels(java.lang.String _sChnlIds, boolean _bWithChildren, boolean _bWithRelated)
java.lang.String | exportSites(java.lang.String _sSiteIds, boolean _bWithChildren, boolean _bWithRelated)
ChannelSyns | getChannelSyns(int _nChannelId, WCMFilter _filter)
java.util.List | getChildren(BaseChannel _oChannel) 获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限
java.util.List | getChildren(BaseChannel _oChannel, int _nRightIndex) 获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)
java.util.List | getChildren(BaseChannel _oChannel, int _nRightIndex, int _nChannelType) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
java.util.List | getChildren(BaseChannel _oChannel, int _nRightIndex, int[] _nArrayChannelType) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
java.util.List | getChildren(BaseChannel _oChannel, int _nRightIndex, int[] _nArrayChannelType, java.lang.StringBuffer _sbNoRightIds) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
ContentLinks | getContentLinks(WebSite _site, WCMFilter _filter)
Documents | getDocuments(BaseChannel _oChannel) 获取当前站点/频道下的有效文档
Documents | getDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的有效文档
Documents | getDocuments(int _nChnlId) 获取当前频道下的有效文档
Documents | getDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的有效文档
ContentExtFields | getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter) 获取指定站点/频道下的扩展字段.
Channels | getRecycleChannels(BaseChannel _oChannel) 获取当前站点/频道下的废弃频道集合
Channels | getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的废弃频道集合
Documents | getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的废稿
Documents | getRecycleDocuments(int _nChnlId) 获取当前频道下的废稿
Documents | getRecycleDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的废稿
WebSites | getRecycleSites(WCMFilter _filter) 获取系统回收站中的站点集合
Replaces | getReplaces(Channel _oChannel, WCMFilter _filter) 获取指定频道下的替换内容对象集合
Groups | getSiteGroups(WebSite _site, WCMFilter _filter) 获取指定站点的所属用户组集合
Roles | getSiteRoles(WebSite _site, WCMFilter _filter) 获取指定站点的所属角色集合
Users | getSiteUsers(WebSite _currSite, WCMFilter _currFilter) 获取指定站点的所属用户集合
Channels | getSynSrcChannel(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | getSynToChannel(Channel _currChannel) 获取当前频道分发文档的目标频道集合
WebSites | getUserSites(User _currUser, WCMFilter _currFilter) 获取指定用户所属的站点集合
WebSites | getWebSites(WCMFilter _filter) 获取当前用户可以看见的站点
Reports | importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl) 从zip/xml文件中导入站点/频道
boolean | isVisible(User _currUser, BaseChannel _currChannel) 判断指定的频道对象对于用户是否可见
boolean | isVisible(User _currUser, BaseChannel _currChannel, int _nRightIndex) 判断在指定的权限值下，指定的频道对象对于用户是否可见
void | moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType) 将频道移动到另一个频道下，作为该频道的子频道或者兄弟
void | moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType) 将频道移动到站点下，作为站点的一级子频道
void | moveTo(WebSite _fromWebSite, WebSite _toWebSite, int _nMoveToType) 将站点移动到另一个站点下，作为该站点的子站点或者兄弟
void | removeGroupsFromSite(java.lang.String _sGroupIds, WebSite _site) 删除指定的站点中的指定用户组
void | removeRolesFromSite(java.lang.String _sRoleIds, WebSite _site)
void | removeSitesFromGroup(java.lang.String _sSiteIds, Group _group) 删除指定的用户组上指定的站点
void | removeSitesFromUser(java.lang.String _sSiteIds, User _currUser) 删除指定的用户上指定的站点
void | removeUsersFromSite(java.lang.String _sUserIds, WebSite _currSite) 删除指定的站点中的指定用户
void | restore(BaseChannel _oChannel) 恢复站点/频道
void | restore(Channels _currChannels) 恢复频道集合
void | restore(WebSites _currSites) 恢复站点集合
void | restoreAllInRecycleBin(int _nChannelId) 还原指定频道回收站中的所有文档
BaseChannel | save(BaseChannel _currBaseChannel) 保存指定的站点/频道
ChannelSyn | saveChannelSyn(ChannelSyn _currChnlSyn)
ChannelSyns | saveChannelSyns(ChannelSyn _currChnlSyn, java.lang.String _sToChannelIds)
ContentLink | saveContentLink(ContentLink _contentLink)
ContentExtField | saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited) 保存指定的扩展字段
Replace | saveReplace(Replace _aReplace) 保存替换内容对象
void | setSiteMembers(int _nSiteId, int _nMemberType, java.lang.String _sMemberIds) 设置站点成员,一个站点成员可以是系统中的一个用户或一个组织
void | setSiteMembers(WebSite _site, int _nMemberType, java.lang.String _sMemberIds) 设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

方法详细信息

getChildren

java.util.List getChildren(BaseChannel _oChannel,
                           int _nRightIndex,
                           int _nChannelType)
                           throws WCMException
获取当前站点/频道的子频道集合(不包含已删除的子频道)

参数：
_oIChannel - 当前站点/频道对象
_nRightIndex - 权限值索引
_nChannelType - 频道类型(指定只取该类型的频道Channel.TYPE_NORM等)
返回：
子频道集合
抛出：
WCMException

getChildren

java.util.List getChildren(BaseChannel _oChannel,
                           int _nRightIndex,
                           int[] _nArrayChannelType)
                           throws WCMException
获取当前站点/频道的子频道集合(不包含已删除的子频道)

参数：
_oIChannel - 当前站点/频道对象
_nRightIndex - 权限值索引
_nArrayChannelType - 频道类型(指定只取该类型的频道Channel.TYPE_NORM等组成的数组)
返回：
子频道集合
抛出：
WCMException

getChildren

java.util.List getChildren(BaseChannel _oChannel,
                           int _nRightIndex,
                           int[] _nArrayChannelType,
                           java.lang.StringBuffer _sbNoRightIds)
                           throws WCMException
获取当前站点/频道的子频道集合(不包含已删除的子频道)

参数：
_oIChannel - 当前站点/频道对象
_nRightIndex - 权限值索引
_nChannelType - 频道类型(指定只取该类型的频道Channel.TYPE_NORM等)
_sbNoRightIds - 可见但无指定操作权限的频道ID
返回：
子频道集合
抛出：
WCMException

getChildren

java.util.List getChildren(BaseChannel _oChannel,
                           int _nRightIndex)
                           throws WCMException
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)

参数：
_oIChannel - 当前站点/频道对象
_nRightIndex - 权限值索引
返回：
子频道集合
抛出：
WCMException

getChildren

java.util.List getChildren(BaseChannel _oChannel)
                           throws WCMException
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限

参数：
_oChannel - 当前站点/频道
抛出：
WCMException

getRecycleChannels

Channels getRecycleChannels(BaseChannel _oChannel)
                            throws WCMException
获取当前站点/频道下的废弃频道集合

参数：
_oChannel - 当前站点/频道
抛出：
WCMException

getRecycleChannels

Channels getRecycleChannels(BaseChannel _oChannel,
                            WCMFilter _filter)
                            throws WCMException
获取当前站点/频道下的废弃频道集合

参数：
_oChannel - 当前站点/频道
_filter - 过滤器
返回：
频道集合
抛出：
WCMException

getDocuments

Documents getDocuments(int _nChnlId)
                       throws WCMException
获取当前频道下的有效文档

参数：
_nChnlId - 当前频道的id
抛出：
WCMException

getDocuments

Documents getDocuments(int _nChnlId,
                       WCMFilter _filter)
                       throws WCMException
获取当前频道下的有效文档

参数：
_nChnlId - 当前频道的id
_filter - 过滤器,额外的查询条件
抛出：
WCMException

getDocuments

Documents getDocuments(BaseChannel _oChannel)
                       throws WCMException
获取当前站点/频道下的有效文档

参数：
_oChannel - 当前站点/频道
抛出：
WCMException

getDocuments

Documents getDocuments(BaseChannel _oChannel,
                       WCMFilter _docFilter)
                       throws WCMException
获取当前站点/频道下的有效文档

参数：
_oChannel - 当前站点/频道
_filter - 过滤器,额外的查询条件
抛出：
WCMException

getRecycleDocuments

Documents getRecycleDocuments(int _nChnlId)
                              throws WCMException
获取当前频道下的废稿

参数：
_nChnlId - 当前频道的id
抛出：
WCMException

getRecycleDocuments

Documents getRecycleDocuments(int _nChnlId,
                              WCMFilter _filter)
                              throws WCMException
获取当前频道下的废稿

参数：
_nChnlId - 当前频道的id
_filter - 过滤器,额外的查询条件
抛出：
WCMException

getRecycleDocuments

Documents getRecycleDocuments(BaseChannel _oChannel,
                              WCMFilter _docFilter)
                              throws WCMException
获取当前站点/频道下的废稿

参数：
_oChannel - 当前站点/频道
_docFilter - 过滤器,额外的查询条件
抛出：
WCMException

delete

boolean delete(java.lang.String _sChannelIds,
               boolean _bDrop)
               throws WCMException
根据频道id列表，删除频道集合

参数：
_sChannelIds - 要删除的频道id序列
_bDrop - 是否删除数据库中的数据,true为删除,不可恢复
返回：
操作成功返回true
抛出：
WCMException

delete

boolean delete(Channels _currChannels,
               boolean _bDrop)
               throws WCMException
删除频道集合

参数：
_currChannels - 要删除的集合数据
_bDrop - 是否删除数据库数据,true为删除,不可恢复
抛出：
WCMException

delete

boolean delete(BaseChannel _oChannel,
               boolean _bDrop)
               throws WCMException
删除站点/频道

参数：
_oChannel - 将删除的站点/频道
_bDrop - 是否删除数据库中的数据,true为删除,不可恢复
抛出：
WCMException

save

BaseChannel save(BaseChannel _currBaseChannel)
                 throws WCMException
保存指定的站点/频道

参数：
_currBaseChannel - 要保存的站点/频道
抛出：
WCMException

getSynSrcChannel

Channels getSynSrcChannel(Channel _currChannel)
                          throws WCMException
获取给当前频道分发文档的频道集合

参数：
_currChannel - 当前频道
返回：
给当前频道分发文档的频道集合
抛出：
WCMException

getSynToChannel

Channels getSynToChannel(Channel _currChannel)
                         throws WCMException
获取当前频道分发文档的目标频道集合

参数：
_currChannel - 当前频道
返回：
@throws WCMException
抛出：
WCMException

saveReplace

Replace saveReplace(Replace _aReplace)
                    throws WCMException
保存替换内容对象

参数：
_aReplace - 要保存的替换内容对象
返回：
@throws WCMException
抛出：
WCMException

deleteReplace

boolean deleteReplace(Replace _aReplace)
                      throws WCMException
删除替换内容对象

参数：
_aReplace - 要删除的对象
返回：
@throws WCMException
抛出：
WCMException

deleteReplace

boolean deleteReplace(Replaces _aReplaces)
                      throws WCMException
删除替换内容对象集合

参数：
_aReplaces - 要删除的集合
返回：
@throws WCMException
抛出：
WCMException

getReplaces

Replaces getReplaces(Channel _oChannel,
                     WCMFilter _filter)
                     throws WCMException
获取指定频道下的替换内容对象集合

参数：
_oChannel - 指定频道
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

restore

void restore(BaseChannel _oChannel)
             throws WCMException
恢复站点/频道

参数：
_oChannel - 要恢复的站点/频道
抛出：
WCMException

restore

void restore(Channels _currChannels)
             throws WCMException
恢复频道集合

参数：
_aChannels - 要恢复的站点/频道集合
抛出：
WCMException

restore

void restore(WebSites _currSites)
             throws WCMException
恢复站点集合

参数：
_aChannels - 要恢复的站点/频道集合
抛出：
WCMException

moveTo

void moveTo(Channel _fromChannel,
            WebSite _toWebSite,
            int _nMoveToType)
            throws WCMException
将频道移动到站点下，作为站点的一级子频道

参数：
__fromChannel - 要移动的频道
__toWebSite - 接收该频道的站点（也就是移动后的父站点）
_nMoveType - 移动类型，1为作为目标频道的兄弟频道，2为作为目标频道的子频道
目前不支持将频道移动成为一个站点，所以有一个分支是空的
抛出：
WCMException

moveTo

void moveTo(Channel _fromChannel,
            Channel _toChannel,
            int _nMoveToType)
            throws WCMException
将频道移动到另一个频道下，作为该频道的子频道或者兄弟

参数：
_fromChannel - 要移动的频道
_toChannel - 要移动到的目标频道
_nMoveToType - 移动类型，通过Channel中的常量表示，MOVE_AS_BROTHER为作为目标频道的兄弟频道， MOVE_AS_CHILD为作为目标频道的子频道
抛出：
WCMException

moveTo

void moveTo(WebSite _fromWebSite,
            WebSite _toWebSite,
            int _nMoveToType)
            throws WCMException
将站点移动到另一个站点下，作为该站点的子站点或者兄弟

参数：
_fromWebSite - 要移动的站点
_toWebSite - 要移动到的目标站点
_nMoveToType - 移动类型，1为作为目标站点的兄弟站点，2为作为目标站点的子站点
目前暂时不支持站点的移动
抛出：
WCMException

getWebSites

WebSites getWebSites(WCMFilter _filter)
                     throws WCMException
获取当前用户可以看见的站点

参数：
_filter - 额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getUserSites

WebSites getUserSites(User _currUser,
                      WCMFilter _currFilter)
                      throws WCMException
获取指定用户所属的站点集合

参数：
_currUser - 指定用户对象（User）
_currFilter - 过滤器,额外的查询条件
返回：
站点集合(WebSites)
抛出：
WCMException - 如果指定的用户无效，抛出参数异常

getSiteUsers

Users getSiteUsers(WebSite _currSite,
                   WCMFilter _currFilter)
                   throws WCMException
获取指定站点的所属用户集合

参数：
_currSite - 指定站点对象
_currFilter - 过滤器,额外的查询条件
返回：
用户集合（Users）
抛出：
WCMException - 如果指定的站点无效，抛出参数异常

addUsersToSite

void addUsersToSite(java.lang.String _sUserIds,
                    WebSite _currSite)
                    throws WCMException
给指定的站点添加指定的用户

参数：
_sUserIds - 指定的用户ID序列
_currSite - 指定的站点对象（WebSite）
抛出：
WCMException - 如果指定的站点无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

addSitesToUser

void addSitesToUser(java.lang.String _sSiteIds,
                    User _currUser)
                    throws WCMException
给指定的用户添加指定的站点

参数：
_sSiteIds - 指定站点ID序列
_currUser - 指定的用户
抛出：
WCMException - 如果指定的用户无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

removeUsersFromSite

void removeUsersFromSite(java.lang.String _sUserIds,
                         WebSite _currSite)
                         throws WCMException
删除指定的站点中的指定用户

参数：
_sUserIds - 指定的用户ID序列
_currSite - 指定的站点对象（WebSite）
抛出：
WCMException - 如果指定的站点无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

removeSitesFromUser

void removeSitesFromUser(java.lang.String _sSiteIds,
                         User _currUser)
                         throws WCMException
删除指定的用户上指定的站点

参数：
_sSiteIds - 指定站点ID序列
_currUser - 指定的用户
抛出：
WCMException - 如果指定的用户无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

isVisible

boolean isVisible(User _currUser,
                  BaseChannel _currChannel)
                  throws WCMException
判断指定的频道对象对于用户是否可见

参数：
_currUser - 指定的用户
_currChannel - 指定的频道（可以是WebSite也可以是Channel）
返回：
如果可见，返回true;否则返回false
抛出：
WCMException

isVisible

boolean isVisible(User _currUser,
                  BaseChannel _currChannel,
                  int _nRightIndex)
                  throws WCMException
判断在指定的权限值下，指定的频道对象对于用户是否可见

参数：
_currUser - 指定的用户
_currChannel - 指定的频道（可以是WebSite也可以是Channel）
_nRightIndex - 指定的权限值（定义在WCMRightTypes中）
返回：
如果可见，返回true;否则返回false
抛出：
WCMException

importFromFile

Reports importFromFile(java.lang.String _sFile,
                       java.lang.String _sXslFile,
                       BaseChannel _destSiteOrChnl)
                       throws WCMException
从zip/xml文件中导入站点/频道

参数：
_sFile - 导入的数据源文件
_sXslFile - 如果要转换的XML文件,需要提供相应的XSL文件
_destSiteOrChnl - 导入的父节点(可以是站点/频道)
返回：
@throws WCMException
抛出：
WCMException

export

java.lang.String export(BaseChannel _fromChannel,
                        boolean _bWithChildren,
                        boolean _bWithRelated)
                        throws WCMException
将WCM的站点、频道导出成为WCM XML标准格式的字符串

参数：
_fromChannel - 要导出的根频道，可能是站点，也可能是频道
_bWithChildren - 是否导出子节点，true为导出，false为不导出
_bWithRelated -
  • 是否导入相关对象，true为导出，false为不导出
  • 相关对象包括模板和扩展字段，频道导出时不导出模板
    返回：
    WCM XML标准格式的文件名，为temp目录下的文件
    抛出：
    WCMException

    • export

    java.lang.String export(WebSites _fromWebSites,
                        boolean _bWithChildren,
                        boolean _bWithRelated)
                        throws WCMException
    抛出：
    WCMException

    export

    java.lang.String export(Channels _fromChannels,
                        boolean _bWithChildren,
                        boolean _bWithRelated)
                        throws WCMException
    抛出：
    WCMException

    exportChannels

    java.lang.String exportChannels(java.lang.String _sChnlIds,
                                boolean _bWithChildren,
                                boolean _bWithRelated)
                                throws WCMException
    抛出：
    WCMException

    exportSites

    java.lang.String exportSites(java.lang.String _sSiteIds,
                             boolean _bWithChildren,
                             boolean _bWithRelated)
                             throws WCMException
    抛出：
    WCMException

    getContentLinks

    ContentLinks getContentLinks(WebSite _site,
                             WCMFilter _filter)
                             throws WCMException
    抛出：
    WCMException

    saveContentLink

    ContentLink saveContentLink(ContentLink _contentLink)
                            throws WCMException
    抛出：
    WCMException

    deleteContentLink

    void deleteContentLink(ContentLink _contentLink)
                       throws WCMException
    抛出：
    WCMException

    deleteContentLinks

    void deleteContentLinks(ContentLinks _contentLinks)
                        throws WCMException
    抛出：
    WCMException

    saveChannelSyn

    ChannelSyn saveChannelSyn(ChannelSyn _currChnlSyn)
                          throws WCMException
    抛出：
    WCMException

    saveChannelSyns

    ChannelSyns saveChannelSyns(ChannelSyn _currChnlSyn,
                            java.lang.String _sToChannelIds)
                            throws WCMException
    抛出：
    WCMException

    deleteChannelSyn

    void deleteChannelSyn(int _nChnlSynId)
                      throws WCMException
    抛出：
    WCMException

    deleteChannelSyns

    void deleteChannelSyns(java.lang.String _sChnlSynIds)
                       throws WCMException
    抛出：
    WCMException

    getChannelSyns

    ChannelSyns getChannelSyns(int _nChannelId,
                           WCMFilter _filter)
                           throws WCMException
    抛出：
    WCMException

    getRecycleSites

    WebSites getRecycleSites(WCMFilter _filter)
                         throws WCMException
    获取系统回收站中的站点集合

    参数：
    _filter - 过滤器,额外的查询条件
    返回：
    @throws WCMException
    抛出：
    WCMException

    createFrom

    Reports createFrom(int _nSiteId,
                   boolean _bWithRelated)
                   throws WCMException
    站点的类似创建的实现

    参数：
    _nSiteId - 指定的源站点ID
    _bWithRelated - 是否创建相关的对象
    返回：
    @throws WCMException
    抛出：
    WCMException
    另请参见：
    createFrom(WebSite, boolean)

    createFrom

    Reports createFrom(WebSite _srcSite,
                   boolean _bWithRelated)
                   throws WCMException
    站点的类似创建的实现
    从指定的站点获取站点的相关属性,创建一个新的站点.
    新站点与源站点有基本相同的属性.

    参数：
    _srcSite - 源站点
    _bWithRelated - 是否创建相关的对象(模板,扩展字段等)
    返回：
    @throws WCMException
    抛出：
    WCMException

    createFrom

    Reports createFrom(int _nChannelId,
                   BaseChannel _parent)
                   throws WCMException
    频道的类似创建的实现

    参数：
    _nChannelId - 指定的源频道ID
    _parent - 新频道的父节点,可以是一个站点,也可以是一个频道
    返回：
    @throws WCMException
    抛出：
    WCMException
    另请参见：
    createFrom(Channel, BaseChannel)

    createFrom

    Reports createFrom(Channel _srcChannel,
                   BaseChannel _parent)
                   throws WCMException
    频道的类似创建的实现
    从指定的频道获取频道的相关属性,创建一个新的频道
    新频道与源频道有基本相同的属性.

    参数：
    _srcChannel - 源频道
    _parent - 新频道的父节点,可以是一个站点,也可以是一个频道
    返回：
    @throws WCMException
    抛出：
    WCMException

    addGroupsToSite

    void addGroupsToSite(java.lang.String _sGroupIds,
                     WebSite _site)
                     throws WCMException
    给指定的站点添加指定的用户组

    参数：
    _sGroupIds - 指定的用户组ID序列,以字符','隔开
    _site - 指定的站点对象（WebSite）
    抛出：
    WCMException - 如果指定的站点无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

    addRolesToSite

    void addRolesToSite(java.lang.String _sRoleIds,
                    WebSite _site)
                    throws WCMException
    给指定的站点添加指定的角色

    参数：
    _sRoleIds - 指定的角色ID序列，以字符 , >隔开
    _site - 指定的站点对象
    抛出：
    WCMException

    removeRolesFromSite

    void removeRolesFromSite(java.lang.String _sRoleIds,
                         WebSite _site)
                         throws WCMException
    抛出：
    WCMException

    addSitesToGroup

    void addSitesToGroup(java.lang.String _sSiteIds,
                     Group _group)
                     throws WCMException
    给指定的用户组添加指定的站点

    参数：
    _sSiteIds - 指定站点ID序列,以字符','隔开
    _group - 指定的用户组
    抛出：
    WCMException - 如果指定的用户无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

    removeGroupsFromSite

    void removeGroupsFromSite(java.lang.String _sGroupIds,
                          WebSite _site)
                          throws WCMException
    删除指定的站点中的指定用户组

    参数：
    _sGroupIds - 指定的用户ID序列,以字符','隔开
    _site - 指定的站点对象（WebSite）
    抛出：
    WCMException - 如果指定的站点无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

    removeSitesFromGroup

    void removeSitesFromGroup(java.lang.String _sSiteIds,
                          Group _group)
                          throws WCMException
    删除指定的用户组上指定的站点

    参数：
    _sSiteIds - 指定站点ID序列,以字符','隔开
    _group - 指定的用户组
    抛出：
    WCMException - 如果指定的用户无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

    getSiteGroups

    Groups getSiteGroups(WebSite _site,
                     WCMFilter _filter)
                     throws WCMException
    获取指定站点的所属用户组集合

    参数：
    _site - 指定站点对象
    _filter - 过滤器,额外的查询条件
    返回：
    用户组集合（Groups）
    抛出：
    WCMException - 如果指定的站点无效，抛出参数异常

    getSiteRoles

    Roles getSiteRoles(WebSite _site,
                   WCMFilter _filter)
                   throws WCMException
    获取指定站点的所属角色集合

    参数：
    _site - 指定站点对象
    _filter - 过滤器,额外的查询条件
    返回：
    角色集合
    抛出：
    WCMException如果指定的站点无效 - ，抛出参数异常
    WCMException
    另请参见：
    Roles

    saveExtField

    ContentExtField saveExtField(BaseChannel _siteOrChannel,
                             ContentExtField _extfield,
                             boolean _bInherited)
                             throws WCMException
    保存指定的扩展字段

    参数：
    _siteOrChannel - 指定的站点/频道
    _extfield - 要保存的扩展字段
    _bInherited - 是否让子频道继承该字段,如果 true 则继承
    返回：
    @throws WCMException
    抛出：
    WCMException

    deleteExtFields

    void deleteExtFields(BaseChannel _siteOrChannel,
                     java.lang.String _extFieldIds,
                     boolean _bDeleteInherited)
                     throws WCMException
    删除指定站点/频道下的指定扩展字段

    参数：
    _siteOrChannel - 指定的站点/频道
    _extFieldIds - 指定的扩展字段的id序列,以字符','分隔
    _bDeleteInherited - 是否同时删除子频道下相同的扩展字段,如果 true 则删除
    抛出：
    WCMException

    deleteExtFiled

    void deleteExtFiled(BaseChannel _siteOrChannel,
                    ContentExtField _extfield,
                    boolean _bDeleteInherited)
                    throws WCMException
    删除指定站点/频道下的指定扩展字段

    参数：
    _siteOrChannel - 指定的站点/频道
    _extfield - 指定的扩展字段
    _bDeleteInherited - 是否同时删除子频道下相同的扩展字段,如果 true 则删除
    抛出：
    WCMException

    getExtFields

    ContentExtFields getExtFields(BaseChannel _siteOrChannel,
                              WCMFilter _filter)
                              throws WCMException
    获取指定站点/频道下的扩展字段.

    参数：
    _siteOrChannel -
    _filter -
    返回：
    @throws WCMException
    抛出：
    WCMException

    setSiteMembers

    void setSiteMembers(int _nSiteId,
                    int _nMemberType,
                    java.lang.String _sMemberIds)
                    throws WCMException
    设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

    参数：
    _nSiteId - 指定的站点id
    _nMemberType - 站点成员的类型(User.OBJ_TYPE/Group.OBJ_TYPE)
    _sMemberIds - 成员的Id序列,以字符','分隔
    抛出：
    WCMException

    setSiteMembers

    void setSiteMembers(WebSite _site,
                    int _nMemberType,
                    java.lang.String _sMemberIds)
                    throws WCMException
    设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

    参数：
    _site - 指定的站点
    _nMemberType - 站点成员的类型(User.OBJ_TYPE/Group.OBJ_TYPE)
    _sMemberIds - 成员的Id序列,以字符','分隔
    抛出：
    WCMException

    emptyRecycleBin

    void emptyRecycleBin(int _nChannelId)
                     throws WCMException
    清空指定频道的文档回收站
    删除指定频道回收站中的所有文档.

    参数：
    _nChannelId - 指定的频道Id
    抛出：
    WCMException

    restoreAllInRecycleBin

    void restoreAllInRecycleBin(int _nChannelId)
                            throws WCMException
    还原指定频道回收站中的所有文档

    参数：
    _nChannelId - 指定的频道Id
    抛出：
    WCMException
    概述 软件包 类 使用 树 已过时 索引 帮助
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IContactService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IContactService

所有已知实现类：
ContactService
public interface IContactService

Title: TRS 内容协作平台（TRS WCM）
Description:
联系人服务接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
Contact | addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
Contact | addContact(int _nContactId, int _nContactGrpId) 添加联系人到指定的组中
void | addContact(java.lang.String _sContactIds, int _nContactGrpId) 添加联系人到指定的组中
Contact | addContactFromSystemUser(int _nUserId) 导入系统用户为联系人
Contact | addContactFromSystemUser(User _user) 导入系统用户为联系人
void | changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup) 更改联系人所在的分组
void | changeGroup(int _nContactId, int _nSrcGroupId, int _nDestGroupId) 更改联系人所在的分组
void | deleteContact(Contact _contact) 删除指定的联系人
void | deleteContact(int _nContactId) 删除指定的联系人
void | deleteContactGroup(ContactGrp _contactGrp) 删除指定的联系人分组
void | deleteContactGroup(int _nContactGroupId) 删除指定的联系人分组
void | deleteContactGroups(ContactGrps _contactGroups) 删除指定的联系人分组
void | deleteContactGroups(java.lang.String _sContactGroupIds) 删除指定的联系人分组
void | deleteContacts(Contacts _contacts) 删除指定的联系人集合
void | deleteContacts(java.lang.String _sContactIds) 删除指定的联系人
ContactGrps | getContactGroups(WCMFilter _filter) 获取当前用户的所有联系人分组
Contacts | getContacts(WCMFilter _filter) 获取当前登录用户所有的联系人
Contacts | getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人
ContactGrps | getGroups(Contact _contact) 获取指定联系人所属的所有联系人分组
void | removeContact(Contact _contact, ContactGrp _contactGroup) 将指定的联系人从指定的联系人分组中删除
void | removeContact(int _nContactId, int _nContactGrpId) 将指定的联系人从指定的联系人分组中删除
void | removeContacts(java.lang.String _sContactIds, int _nContactGrpId) 将指定的联系人从指定的联系人分组中删除
Contact | saveContact(Contact _contact) 保存一个联系人
ContactGrp | saveContactGroup(ContactGrp _contactGrp) 保存一个联系人分组

方法详细信息

addContactFromSystemUser

Contact addContactFromSystemUser(int _nUserId)
                                 throws WCMException
导入系统用户为联系人

参数：
_nUserId - 要导入的用户Id
返回：
@throws WCMException
抛出：
WCMException

addContactFromSystemUser

Contact addContactFromSystemUser(User _user)
                                 throws WCMException
导入系统用户为联系人

参数：
_user - 要导入的用户
返回：
@throws WCMException
抛出：
WCMException

addContact

void addContact(java.lang.String _sContactIds,
                int _nContactGrpId)
                throws WCMException
添加联系人到指定的组中

参数：
_nContactId - 要添加的联系人ID序列,以字符','分隔
_nContactGrpId - 指定的联系人分组ID
抛出：
WCMException

addContact

Contact addContact(int _nContactId,
                   int _nContactGrpId)
                   throws WCMException
添加联系人到指定的组中

参数：
_nContactId - 要添加的联系人ID
_nContactGrpId - 指定的联系人分组ID
返回：
@throws WCMException
抛出：
WCMException

addContact

Contact addContact(Contact _contact,
                   ContactGrp _contactGroup)
                   throws WCMException
添加联系人到指定的组中

参数：
_contact - 要添加的联系人
_contactGroup - 指定的联系人分组
返回：
@throws WCMException
抛出：
WCMException

saveContact

Contact saveContact(Contact _contact)
                    throws WCMException
保存一个联系人

参数：
_contact - 要保存的联系人
返回：
@throws WCMException
抛出：
WCMException

deleteContacts

void deleteContacts(java.lang.String _sContactIds)
                    throws WCMException
删除指定的联系人

参数：
_sContactIds - 指定的联系人对象ID序列,以字符','隔开
抛出：
WCMException

deleteContacts

void deleteContacts(Contacts _contacts)
                    throws WCMException
删除指定的联系人集合

参数：
_contacts - 指定的联系人集合
抛出：
WCMException

deleteContact

void deleteContact(int _nContactId)
                   throws WCMException
删除指定的联系人

参数：
_nContactId - 指定的联系人ID
抛出：
WCMException

deleteContact

void deleteContact(Contact _contact)
                   throws WCMException
删除指定的联系人

参数：
_contact - 指定的联系人
抛出：
WCMException

saveContactGroup

ContactGrp saveContactGroup(ContactGrp _contactGrp)
                            throws WCMException
保存一个联系人分组

参数：
_contactGrp -
返回：
@throws WCMException
抛出：
WCMException

deleteContactGroups

void deleteContactGroups(java.lang.String _sContactGroupIds)
                         throws WCMException
删除指定的联系人分组

参数：
_sContactGroupIds - 指定的联系人分组对象ID序列,以字符','隔开
抛出：
WCMException

deleteContactGroups

void deleteContactGroups(ContactGrps _contactGroups)
                         throws WCMException
删除指定的联系人分组

参数：
_contactGroups - 指定的联系人分组
抛出：
WCMException

deleteContactGroup

void deleteContactGroup(int _nContactGroupId)
                        throws WCMException
删除指定的联系人分组

参数：
_nContactGroupId - 指定的联系人分组ID
抛出：
WCMException

deleteContactGroup

void deleteContactGroup(ContactGrp _contactGrp)
                        throws WCMException
删除指定的联系人分组

参数：
_contactGrp - 要删除的联系人分组
抛出：
WCMException

getGroups

ContactGrps getGroups(Contact _contact)
                      throws WCMException
获取指定联系人所属的所有联系人分组

参数：
_contact -
返回：
@throws WCMException
抛出：
WCMException

getContactGroups

ContactGrps getContactGroups(WCMFilter _filter)
                             throws WCMException
获取当前用户的所有联系人分组

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getContacts

Contacts getContacts(WCMFilter _filter,
                     ContactGrp _contactGroup)
                     throws WCMException
获取当前登录用户某个分组的联系人

参数：
_filter - 过滤器,额外的查询条件
_contactGroup - 指定的联系人分组
返回：
@throws WCMException
抛出：
WCMException
另请参见：
ContactMgr.getContacts(WCMFilter)

getContacts

Contacts getContacts(WCMFilter _filter)
                     throws WCMException
获取当前登录用户所有的联系人

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

removeContact

void removeContact(int _nContactId,
                   int _nContactGrpId)
                   throws WCMException
将指定的联系人从指定的联系人分组中删除

参数：
_nContactId - 指定的联系人ID
_nContactGrpId - 联系人分组ID
抛出：
WCMException

removeContacts

void removeContacts(java.lang.String _sContactIds,
                    int _nContactGrpId)
                    throws WCMException
将指定的联系人从指定的联系人分组中删除

参数：
_nContactId - 指定的联系人ID序列,以字符','分隔
_nContactGrpId - 联系人分组ID
抛出：
WCMException

removeContact

void removeContact(Contact _contact,
                   ContactGrp _contactGroup)
                   throws WCMException
将指定的联系人从指定的联系人分组中删除

参数：
_contact - 指定的联系人
_contactGroup - 联系人分组
抛出：
WCMException

changeGroup

void changeGroup(int _nContactId,
                 int _nSrcGroupId,
                 int _nDestGroupId)
                 throws WCMException
更改联系人所在的分组

参数：
_nContactId - 指定的联系人ID
_nSrcGroupId - 联系人所在的分组ID
_nDestGroupId - 更改后所在的分组ID
抛出：
WCMException

changeGroup

void changeGroup(Contact _contact,
                 ContactGrp _srcGroup,
                 ContactGrp _destGroup)
                 throws WCMException
更改联系人所在的分组

参数：
_contact - 指定的联系人
_srcGroup - 联系人所在的分组
_destGroup - 更改后所在的分组
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICustomizeService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 ICustomizeService

所有已知实现类：
CustomizeService
public interface ICustomizeService

Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | delete(int _nMoudelType) 删除个人定制模块
boolean | deleteChannels(int[] _nArgChannelId) 删除个人定制的频道
boolean | deleteSites(int[] _nArgSiteId) 删除个人定制的站点集合
Channels | getChannels() 获取当前用户定制的频道集合
Channels | getChannels(int _nRightIndex) 获取当前用户定制的并且有指定操作权限的频道集合
User | getLoginUser() 获取使用service的当前用户
int[] | getMoudels() 获取当前用户定制的模块集合
WebSites | getWebSites() 获取个人定制的站点集合
boolean | hasCustomized() 当前用户是否有个性化定制
boolean | save(int _nMoudelType) 保存当前登录用户定制的模块
boolean | saveChannels(java.lang.String _sChannelIds) 保存个人定制的频道
boolean | saveSites(int[] _nArgSiteId) 保存个人定制的站点集合
void | setCustomizedChannels(java.lang.String _sChannelIds) 设置定制的频道

方法详细信息

getLoginUser

User getLoginUser()
获取使用service的当前用户

返回：
当前登录用户

hasCustomized

boolean hasCustomized()
                      throws WCMException
当前用户是否有个性化定制

参数：
_currUser - 当前用户
返回：
如果有定制,返回true
抛出：
WCMException

save

boolean save(int _nMoudelType)
             throws WCMException
保存当前登录用户定制的模块

参数：
_nMoudelType - 定制的模块类型
返回：
保存成功返回true
抛出：
WCMException

delete

boolean delete(int _nMoudelType)
               throws WCMException
删除个人定制模块

参数：
_nMoudelType - 定制模块类型
返回：
删除成功返回true
抛出：
WCMException

getMoudels

int[] getMoudels()
                 throws WCMException
获取当前用户定制的模块集合

参数：
_currUser - 当前用户
返回：
用户定制了的模块类型
抛出：
WCMException

saveChannels

boolean saveChannels(java.lang.String _sChannelIds)
                     throws WCMException
保存个人定制的频道

参数：
_sChannelIds - 定制的频道id序列,以字符','分隔,可以是空串 "";
返回：
保存成功返回true
抛出：
WCMException

deleteChannels

boolean deleteChannels(int[] _nArgChannelId)
                       throws WCMException
删除个人定制的频道

参数：
_nArgChannelId - 要删除的定制频道id数组
返回：
删除成功返回true
抛出：
WCMException

getChannels

Channels getChannels()
                     throws WCMException
获取当前用户定制的频道集合

参数：
_currUser - 当前用户
返回：
返回当前用户定制的频道集合
抛出：
WCMException

getChannels

Channels getChannels(int _nRightIndex)
                     throws WCMException
获取当前用户定制的并且有指定操作权限的频道集合

参数：
_nRightIndex - 指定的权限索引值
返回：
@throws WCMException
抛出：
WCMException

saveSites

boolean saveSites(int[] _nArgSiteId)
                  throws WCMException
保存个人定制的站点集合

参数：
_nArgSiteId - 要保存的站点id数组
返回：
保存成功返回true
抛出：
WCMException

deleteSites

boolean deleteSites(int[] _nArgSiteId)
                    throws WCMException
删除个人定制的站点集合

参数：
_nArgSiteId - 要删除的站点Id数组
返回：
删除成功返回true
抛出：
WCMException

getWebSites

WebSites getWebSites()
                     throws WCMException
获取个人定制的站点集合

返回：
返回当前用户个人定制的站点集合
抛出：
WCMException

setCustomizedChannels

void setCustomizedChannels(java.lang.String _sChannelIds)
                           throws WCMException
设置定制的频道

参数：
_sChannelIds - 定制的频道id序列,以字符','分隔,可以是空串 "";
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDBService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IDBService

所有已知实现类：
DBService
public interface IDBService

Title: TRS 内容协作平台（TRS WCM）
Description:
数据库相关操作服务层接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 DataType[] getSupportedDataTypes()

方法详细信息

getSupportedDataTypes

DataType[] getSupportedDataTypes()
                                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDocumentService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IDocumentService

所有已知实现类：
DocumentService
public interface IDocumentService

作者：
Han Xiao WCM52服务层，被表示层调用并调用其下的层 文档操作相关的接口

方法摘要
DocBak | backup(Document _currDocument) 备份当前文档,产生当前文档的一个版本 备份只针对实体文档，不针对引用转发或者镜像文档，所以只提供一个Document参数
void | changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
void | changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
Reports | copyTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将一组文档从指定的频道复制到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | copyTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 复制文档集合 将一堆文档复制到某个频道 一堆文档可以是一个检索的结果
boolean | delete(ChnlDocs _delChnlDocs, boolean _bDrop) 批量删除当前频道下的文档
boolean | delete(Document _currDocument, Channel _currChannel, boolean _bDrop) 删除当前频道的一个文档
boolean | delete(Documents _aDocuments, Channel _currChannel, boolean _bDrop) 批量删除当前频道下的文档
boolean | delete(int _nDocumentId, Channel _currChannel, boolean _bDrop) 删除当前频道下的一个文档
boolean | delete(java.lang.String _sDocumentIds, Channel _currChannel, boolean _bDrop) 根据文档id序列批量删除当前频道下的文档
void | deleteDocBak(DocBak _docbak) 删除指定的文档版本
void | deleteDocBak(int _nDocBakId) 删除指定的文档版本
void | deleteDocBaks(DocBaks _docbaks) 删除指定的文档版本集合
void | deleteDocBaks(java.lang.String _sDocBakIds) 删除指定的文档版本
java.lang.String | export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出文档集合
java.lang.String | export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出指定的文档
java.lang.String | export(int _nDocId, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出指定的文档
java.lang.String | export(java.lang.String _sDocIds, java.lang.String _sFieldsList, boolean _bWithAppendixes) 根据指定的ID序列导出文档
ChnlDoc | findChnldoc(int _currDocumentId, int _currChannelId) 根据频道和文档，找到对应的ChnlDoc
Documents | getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
Appendixes | getAppendixes(Document _currDocument) 获取当前文档的所有附件
Appendixes | getAppendixes(Document _currDocument, int _nAppendixType) 获取当前文档的某种类型的附件
Appendixes | getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档的某种类型的附件
Appendixes | getAppendixes(Document _currDocument, WCMFilter _filter) 获取当前文档的某种类型的附件
Channels | getChannels(Document _currDocument) 获得实体文档相关的引用、镜像等对应的所有频道
DocBak | getDocBak(Document _currDocument, int _nVersion) 获取当前文档指定版本的备份
DocBaks | getDocBaks(Document _currDocument) 获取当前文档的备份
DocBaks | getDocBaks(Document _currDocument, WCMFilter _filter) 获取当前文档的备份
java.io.File[] | getExitedMappingFiles() 获取当前用户已定义的XML映射文件
java.io.File[] | getExitedXslFiles() 获取当前用户已上传的xsl文件
User | getLoginUser() 返回当前登录用户
int | getMaxToppedNum() 获得允许置顶的文档的总数 是从系统配置中获取，整个系统中有一个数值记录
Channels | getMirrorChannels(Document _currDocument) 获得源文档所有存在同源异现镜像的频道
java.lang.String | getMyDocumentImportSourceFilePath() 获取当前登录用户导入文档时,XSL文件的存放位置
Channels | getQuoteChannels(Document _currDocument) 获取引用了当前指定文档的所有频道
Channels | getQuoteChannels(int _nDocumentId) 获取引用了当前指定文档的所有频道
Documents | getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter) 获取当前站点或频道的回收站的文档
Documents | getRelatedDocuments(Document _currDocument, int _nGetByWhich) 指定检索条件获取与当前文档相关的文档
Documents | getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 指定检索条件获取与当前文档相关的文档
Documents | getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSite) 指定检索条件获取与当前文档相关的文档
Relations | getRelations(Document _currDocument) 获取当前文档的Relations集合，即手工设定的相关文档
Documents | getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档
int | getTopPosition(Document _currDocument, Channel _currChannel) 得到当前频道下的特定文档的置顶位置
CMyDateTime | getTopTime(Document _currDocument, Channel _currChannel) 获得文档置顶的截止时间 如果文档没有置顶，则直接返回null 如果置顶文档没有设置截止时间则返回null
Reports | importDocuments(java.lang.String _sImportFile, int _nDstChnlId, java.lang.String _sXSLFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从文件中导入文档 支持从zip,xml,html,htm文件导入
Reports | importTRSDocuments(java.lang.String _sImportFile, int _nDestChannelId, java.lang.String _sDefineXmlFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从TRS文件中导入文档 支持从zip,xml,html,htm文件导入
boolean | isDocumentTopped(Document _currDocument, Channel _currChannel) 判断一个频道下的文档是否是处于置顶状态 应用层可以利用这个接口，在文档列表前加上图片标识
boolean | isDocumentTopScheduled(Document _currDocument, Channel _currChannel) 判断频道下的文档如果置顶的话，是否已经加入了计划调度
void | mirrorTo(Document _currDocument, Channel _toChannel) 将文档在另一个频道中建立一个同源异现的镜像
Reports | mirrorTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将一组文档镜像转发到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | mirrorTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 镜像转发频道文档集合 将一堆文档镜像转发到某个频道 一堆文档可以是一个检索的结果
void | moveBackward(int _currDocumentId, int _currChannelId) 将文档向后移动一位 需要将两篇文档对换顺序 如果文档已经是最后一篇，则不移动 置顶区域中的文档不能移动
void | moveDocumentInChannel(int _fromDocumentId, int _toDocumentId, int _currChannelId) 在频道中移动文档的顺序 如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后 通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作 置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
void | moveDocumentInChannel(int _fromDocumentId, int _toDocumentId, int _currChannelId, int _nPostionCode)
void | moveFirst(int _currDocumentId, int _currChannelInt) 将文档移动到频道内第一的位置 需要将该移动文档前面的所有文档后移一位 如果文档已经是第一篇，则不移动 移动后的文档不进入置顶区域，是置顶区后的第一篇 置顶区域中的文档也不能移动
void | moveForward(int _currDocumentId, int _currChannelId) 将文档向前移动一位 需要将两篇文档对换顺序 如果文档已经是第一篇，则不移动 移动后的文档不进入置顶区域，是置顶区后的第一篇 置顶区域中的文档也不能移动
void | moveLast(int _currDocumentId, int _currChannelId) 将文档移动到最后的位置 需要将该移动文档后面的所有文档向前移一位 如果文档已经是最后一篇，则不移动 置顶区域中的文档也不能移动
Reports | moveTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将文档从指定的频道移动到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | moveTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 移动文档集合 将一堆文档移动到某个频道 一堆文档可以是一个检索的结果
Reports | quoteTo(Document _currDocument, java.lang.String _sToChannelIds) 维护单篇文档的引用转发关系 将单篇文档引用转发到目标频道列表中 一般用于在文档采编页面中，设置一篇文档的引用转发 这里的维护中包括删除所有无用的引用转发关系
Reports | quoteTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String sToChannelIds) 将一组文档转发（引用转发）到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | quoteTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 引用转发频道文档集合 将一堆频道文档移动到某个频道 一堆文档可以是一个检索的结果
Document | recoverDocument(DocBak _aDocBak, Document _currDocument) 从文档备份版本中恢复文档
void | removeToppedDocument(Document _currDocument, Channel _currChannel) 取消特定频道下某文档的置顶标志 该文档将成为普通文档 注意，不是删除文档！
void | restore(Document _currDocument, Channel _currChannel) 恢复回收站中的文档
void | restore(Documents _documents) 批量恢复回收站中的文档
Reports | restore(java.lang.String _sDelDocIds, int _nChannelId) 批量恢复回收站中的文档
Document | save(Document _aDocument, java.util.List _aAppendixList, java.util.List _aRelationList) 添加文档、修改文档时的保存操作 由于对对象进行了重新划分，将AppendixList等从Document对象中提取出来 保持了Document对象和各个对象的独立性
Document | save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, int _nFlowdocId)
Document | save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo)
Document | save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.lang.String _sFlowContextInfo)
Document | saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc)
Document | saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.util.Map _hFlowContextInfo)
Document | saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.lang.String _sFlowContextInfo)
Document | saveInfoViewDocument(Document _document, InfoView _infoView, java.util.Map _infoViewData)
void | setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶
void | withdraw(Document _currDocument) 撤稿 ?

方法详细信息

getLoginUser

User getLoginUser()
返回当前登录用户

返回：

save

Document save(Document _aDocument,
              java.util.List _aAppendixList,
              java.util.List _aRelationList)
              throws WCMException
添加文档、修改文档时的保存操作 由于对对象进行了重新划分，将AppendixList等从Document对象中提取出来
保持了Document对象和各个对象的独立性

参数：
_aDocument - 文档对象
_aAppendixList - 附件列表，如果为null则表示不需要处理附件
添加时，由系统自动添加附件和文档关联的ID
如果List isEmpty也要执行附件的处理（删除已有附件）
_aRelationList - 相关文档列表，如果为null则表示不需要处理相关文档
添加时，由系统自动添加附件和文档关联的ID
_aRightList - 权限列表，为文档单独设置的权限，如果如果为null则表示不需要处理
返回：
抛出：
WCMException

delete

boolean delete(java.lang.String _sDocumentIds,
               Channel _currChannel,
               boolean _bDrop)
               throws WCMException
根据文档id序列批量删除当前频道下的文档

参数：
_sDocumentIds - 指定的文档id序列
_currChannel - 当前频道
_bDrop - 是否删除数据库中的数据,true为删除,不可恢复
返回：
操作成功返回true
抛出：
WCMException

delete

boolean delete(Documents _aDocuments,
               Channel _currChannel,
               boolean _bDrop)
               throws WCMException
批量删除当前频道下的文档

参数：
_aDocuments - 需要删除的文档集合
_currChannel - 当前频道
_bDrop - 是否删除数据库中的数据,true为删除,不可恢复
返回：
操作成功返回true
抛出：
WCMException

delete

boolean delete(int _nDocumentId,
               Channel _currChannel,
               boolean _bDrop)
               throws WCMException
删除当前频道下的一个文档

参数：
_nDocumentId - 要删除的文档
_currChannel - 当前频道
_bDrop - 是否删除数据库中的数据,true为删除,false为删除到回收站
返回：
抛出：
WCMException

delete

boolean delete(Document _currDocument,
               Channel _currChannel,
               boolean _bDrop)
               throws WCMException
删除当前频道的一个文档

参数：
_currDocument - 要删除的文档
_currChannel - 当前频道
_bDrop - 是否删除数据库中的数据,true为删除,false为删除到回收站
返回：
抛出：
WCMException

withdraw

void withdraw(Document _currDocument)
              throws WCMException
撤稿 ?提供一种撤稿状态，可以通过操作直接修改，同时可能还要进行一次频道的增量发布 ?在站点发布属性中，撤稿是不允许选为可发布的 ?已撤的稿件应该还可以重新恢复成为可发布的其他状态，具体操作方式待定 ?撤稿后，引用转发的文档是否也撤还有待商榷

参数：
_currDocument - 要撤的文档
抛出：
WCMException

importDocuments

Reports importDocuments(java.lang.String _sImportFile,
                        int _nDstChnlId,
                        java.lang.String _sXSLFile,
                        boolean _bExitWhenDocumentExisted,
                        boolean _bOmitOriginalChannel)
                        throws WCMException
从文件中导入文档
支持从zip,xml,html,htm文件导入

参数：
_sImportFile - 导入的源文件
_channel - 要导入的目标频道
_sXslFile - xml文件对应的转换文件
_bExitWhenDocumentExisted - 当出现重复文档时,是继续导入还是忽略该篇文档的导入
如果 true 则忽略
_bOmitOriginalChannel - 是否忽略文档原来的所属频道属性 (如果导入的源数据中包含相关的信息)
如果 true 则忽略,将文档导入到指定的目标频道
抛出：
WCMException

importTRSDocuments

Reports importTRSDocuments(java.lang.String _sImportFile,
                           int _nDestChannelId,
                           java.lang.String _sDefineXmlFile,
                           boolean _bExitWhenDocumentExisted,
                           boolean _bOmitOriginalChannel)
                           throws WCMException
从TRS文件中导入文档
支持从zip,xml,html,htm文件导入

参数：
_sImportFile - 导入的源文件
_channel - 要导入的目标频道
_sDefineXmlFile - 指定的TRS映射文件
_bExitWhenDocumentExisted - 当出现重复文档时,是继续导入还是忽略该篇文档的导入
如果 true 则忽略
_bOmitOriginalChannel - 是否忽略文档原来的所属频道属性 (如果导入的源数据中包含相关的信息)
如果 true 则忽略,将文档导入到指定的目标频道
返回：
Reports
抛出：
WCMException

getExitedXslFiles

java.io.File[] getExitedXslFiles()
                                 throws WCMException
获取当前用户已上传的xsl文件

返回：
抛出：
WCMException

getExitedMappingFiles

java.io.File[] getExitedMappingFiles()
                                     throws WCMException
获取当前用户已定义的XML映射文件

返回：
抛出：
WCMException

getMyDocumentImportSourceFilePath

java.lang.String getMyDocumentImportSourceFilePath()
                                                   throws WCMException
获取当前登录用户导入文档时,XSL文件的存放位置

返回：
抛出：
WCMException

export

java.lang.String export(Document _document,
                        java.lang.String _sFieldsList,
                        boolean _bWithAppendixes)
                        throws WCMException
导出指定的文档

参数：
_document - 需要导出的文档
_sFieldsList - 需要导出的字段列表
_bWithAppendixes - 是否一同导出文档的附件
返回：
抛出：
WCMException

export

java.lang.String export(int _nDocId,
                        java.lang.String _sFieldsList,
                        boolean _bWithAppendixes)
                        throws WCMException
导出指定的文档

参数：
_nDocId - 指定的文档ID
_sFieldsList - 要导出的字段列表
_bWithAppendixes - 是否一同导出文档的附件
返回：
抛出：
WCMException

export

java.lang.String export(java.lang.String _sDocIds,
                        java.lang.String _sFieldsList,
                        boolean _bWithAppendixes)
                        throws WCMException
根据指定的ID序列导出文档

参数：
_sDocIds - 指定的ID序列
_sFieldsList - 需要导出的字段列表
_bWithAppendixes - 是否一同导出文档的附件
返回：
抛出：
WCMException

export

java.lang.String export(Documents _documents,
                        java.lang.String _sFieldsList,
                        boolean _bWithAppendixes)
                        throws WCMException
导出文档集合

参数：
_documents - 要导出的文档集合
_sFieldsList - 需要导出的字段列表
_bWithAppendixes - 是否一同导出文档的附件
返回：
返回systemtemp目录下的一个文件名
抛出：
WCMException

changeDocumentsStatus

void changeDocumentsStatus(Documents _currDocuments,
                           Channel _currChannel,
                           Status _currStatus)
                           throws WCMException
修改指定文档的文档状态(新稿、已发等)

参数：
_currDocument - 指定的文档
_currChannel - 当前频道
_nStatudId - 要指定的状态Id
抛出：
WCMException

changeDocumentStatus

void changeDocumentStatus(Document _currDocument,
                          Channel _currChannel,
                          Status _currStatus)
                          throws WCMException
修改指定文档的文档状态(新稿、已发等)

参数：
_currDocument - 指定的文档
_currChannel - 当前频道
_currStatus - 要指定的状态
抛出：
WCMException

getDocBaks

DocBaks getDocBaks(Document _currDocument)
                   throws WCMException
获取当前文档的备份

参数：
_currDocument - 当前文档
返回：
抛出：
WCMException

getDocBaks

DocBaks getDocBaks(Document _currDocument,
                   WCMFilter _filter)
                   throws WCMException
获取当前文档的备份

参数：
_currDocument - 当前文档
_filter - 过滤器
返回：
抛出：
WCMException

getDocBak

DocBak getDocBak(Document _currDocument,
                 int _nVersion)
                 throws WCMException
获取当前文档指定版本的备份

参数：
_currDocument - 当前文档
_nVersion - 指定版本
返回：
抛出：
WCMException

deleteDocBak

void deleteDocBak(int _nDocBakId)
                  throws WCMException
删除指定的文档版本

参数：
_nDocBakId - 指定的文档版本Id
抛出：
WCMException

deleteDocBaks

void deleteDocBaks(java.lang.String _sDocBakIds)
                   throws WCMException
删除指定的文档版本

参数：
_sDocBakIds - 指定的文档版本Id序列,以字符','分隔
抛出：
WCMException

deleteDocBaks

void deleteDocBaks(DocBaks _docbaks)
                   throws WCMException
删除指定的文档版本集合

参数：
_docbaks - 指定的文档版本集合
抛出：
WCMException

deleteDocBak

void deleteDocBak(DocBak _docbak)
                  throws WCMException
删除指定的文档版本

参数：
_docbak - 指定的文档版本
抛出：
WCMException

getAppendixes

Appendixes getAppendixes(Document _currDocument)
                         throws WCMException
获取当前文档的所有附件

参数：
_currDocument - 当前文档
返回：
抛出：
WCMException

getAppendixes

Appendixes getAppendixes(Document _currDocument,
                         int _nAppendixType)
                         throws WCMException
获取当前文档的某种类型的附件

参数：
_currDocument - 当前文档
_nAppendixType - 附件的类型
返回：
抛出：
WCMException

getAppendixes

Appendixes getAppendixes(Document _document,
                         int _nAppendixType,
                         WCMFilter _filter)
                         throws WCMException
获取当前文档的某种类型的附件

参数：
_currDocument - 当前文档
_nAppendixType - 附件的类型
_filter - 过滤器,额外的查询条件
返回：
抛出：
WCMException

getAppendixes

Appendixes getAppendixes(Document _currDocument,
                         WCMFilter _filter)
                         throws WCMException
获取当前文档的某种类型的附件

参数：
_currDocument - 当前文档
_filter - 过滤器
返回：
抛出：
WCMException

recoverDocument

Document recoverDocument(DocBak _aDocBak,
                         Document _currDocument)
                         throws WCMException
从文档备份版本中恢复文档

参数：
_aDocBak - 恢复的目的版本
_currDocument - 当前需要恢复的文档
返回：
恢复操作后的文档
抛出：
WCMException

getRelatedDocuments

Documents getRelatedDocuments(Document _currDocument,
                              int _nGetByWhich)
                              throws WCMException
指定检索条件获取与当前文档相关的文档

参数：
_currDocument - 当前文档
_nGetByWhich - 获取方式(Document.GET_BY_ALL等)
_nMaxSize - 获取的篇数
_filter - 过滤器(额外的检索条件)
_bExactMatch - 是否精确匹配
_bMultiSite - 是否跨站上查询
返回：
与当前文档相关的文档集合
抛出：
WCMException

getRelatedDocuments

Documents getRelatedDocuments(Document _currDocument,
                              int _nGetByWhich,
                              WCMFilter _filter)
                              throws WCMException
指定检索条件获取与当前文档相关的文档

参数：
_currDocument - 当前文档
_nGetByWhich - 获取方式(Document.GET_BY_ALL等)
_nMaxSize - 获取的篇数
_filter - 过滤器(额外的检索条件)
返回：
与当前文档相关的文档集合
抛出：
WCMException

getRelatedDocuments

Documents getRelatedDocuments(Document _currDocument,
                              int _nGetByWhich,
                              WCMFilter _filter,
                              boolean _bExactMatch,
                              boolean _bMultiSite)
                              throws WCMException
指定检索条件获取与当前文档相关的文档

参数：
_currDocument - 当前文档
_nGetByWhich - 获取方式(Document.GET_BY_ALL等)
_filter - 过滤器(额外的检索条件)
_bExactMatch - 是否精确匹配
_bMultiSite - 是否跨站上查询
返回：
与当前文档相关的文档集合
抛出：
WCMException

backup

DocBak backup(Document _currDocument)
              throws WCMException
备份当前文档,产生当前文档的一个版本
备份只针对实体文档，不针对引用转发或者镜像文档，所以只提供一个Document参数

参数：
_currDocument - 当前文档
返回：
新的文档备份
抛出：
WCMException

getQuoteChannels

Channels getQuoteChannels(Document _currDocument)
                          throws WCMException
获取引用了当前指定文档的所有频道

参数：
_currDocument - 指定的当前文档
返回：
引用了该文档的所有频道集合,如果文档为草稿,则返回空集
抛出：
WCMException

getQuoteChannels

Channels getQuoteChannels(int _nDocumentId)
                          throws WCMException
获取引用了当前指定文档的所有频道

参数：
_nDocumentId - 当前文档的id
返回：
引用了该文档的所有频道集合,如果文档为草稿,则返回空集
抛出：
WCMException

restore

void restore(Document _currDocument,
             Channel _currChannel)
             throws WCMException
恢复回收站中的文档

参数：
_document - 要恢复的文档
抛出：
WCMException

restore

void restore(Documents _documents)
             throws WCMException
批量恢复回收站中的文档

参数：
_document - 要恢复的文档集合
抛出：
WCMException

restore

Reports restore(java.lang.String _sDelDocIds,
                int _nChannelId)
                throws WCMException
批量恢复回收站中的文档

参数：
_sDelDocIds - 要恢复的文档集合
_nChannelId - 频道Id
返回：
操作成功返回true
抛出：
WCMException

getRelations

Relations getRelations(Document _currDocument)
                       throws WCMException
获取当前文档的Relations集合，即手工设定的相关文档

参数：
_currDocument -
返回：
抛出：
WCMException

mirrorTo

void mirrorTo(Document _currDocument,
              Channel _toChannel)
              throws WCMException
将文档在另一个频道中建立一个同源异现的镜像

参数：
_currDocument - 源文档
_toChannel - 目标频道
抛出：
WCMException

getMirrorChannels

Channels getMirrorChannels(Document _currDocument)
                           throws WCMException
获得源文档所有存在同源异现镜像的频道

参数：
_currDocument - 源文档
返回：
存在镜像的频道
抛出：
WCMException

getMaxToppedNum

int getMaxToppedNum()
                    throws WCMException
获得允许置顶的文档的总数
是从系统配置中获取，整个系统中有一个数值记录

返回：
允许置顶的文档的总数，找不到配置则返回0
抛出：
WCMException

getToppedDocuments

Documents getToppedDocuments(Channel _currChannel,
                             WCMFilter _docFilter)
                             throws WCMException
获得特定频道下已设置为置顶的所有文档

参数：
_currChannel - 特定的频道
_docFilter - 文档的条件
返回：
该频道下置顶的文档集合，没有则返回空的Documents集合
抛出：
WCMException

isDocumentTopped

boolean isDocumentTopped(Document _currDocument,
                         Channel _currChannel)
                         throws WCMException
判断一个频道下的文档是否是处于置顶状态
应用层可以利用这个接口，在文档列表前加上图片标识

参数：
_currChannel - 文档所在频道
_currDocument - 文档
返回：
true为是置顶文档，false为不是置顶文档
抛出：
WCMException

setTopDocument

void setTopDocument(Document _currDocument,
                    Channel _currChannel,
                    int _nToppedOrder,
                    CMyDateTime _dtValidUntil)
                    throws WCMException
将特定频道下的一篇文档设置为置顶

参数：
_currChannel - 文档所在频道
_currDocument - 文档
_nToppedOrder - 该文档在当前频道下置顶的顺序
_dtValidUntil - 置顶的有效期（截止日期）
抛出：
WCMException - 如果置顶顺序大于最大顺序，则抛出异常
如果置顶位置上已存在文档，则抛出异常

removeToppedDocument

void removeToppedDocument(Document _currDocument,
                          Channel _currChannel)
                          throws WCMException
取消特定频道下某文档的置顶标志
该文档将成为普通文档
注意，不是删除文档！

参数：
_currChannel - 特定频道
_currDocument - 文档
抛出：
WCMException - 如果该文档不是置顶的，也不抛出异常

getTopPosition

int getTopPosition(Document _currDocument,
                   Channel _currChannel)
                   throws WCMException
得到当前频道下的特定文档的置顶位置

参数：
_currChannel -
_currDocument -
返回：
置顶位置，如果不是置顶的文档，则返回0
抛出：
WCMException

isDocumentTopScheduled

boolean isDocumentTopScheduled(Document _currDocument,
                               Channel _currChannel)
                               throws WCMException
判断频道下的文档如果置顶的话，是否已经加入了计划调度

参数：
_currChannel -
_currDocument -
返回：
如果置顶有截止日期，则返回true，表示加入了计划调度；否则返回false
抛出：
WCMException

getTopTime

CMyDateTime getTopTime(Document _currDocument,
                       Channel _currChannel)
                       throws WCMException
获得文档置顶的截止时间
  • 如果文档没有置顶，则直接返回null
  • 如果置顶文档没有设置截止时间则返回null

    参数：
    _currDocument - 置顶的文档
    _currChannel - 文档所在频道
    返回：
    返回置顶文档的截止时间（包含日期）
    抛出：
    WCMException

    • moveForward

    void moveForward(int _currDocumentId,
                 int _currChannelId)
                 throws WCMException
    将文档向前移动一位
    需要将两篇文档对换顺序
    如果文档已经是第一篇，则不移动
    移动后的文档不进入置顶区域，是置顶区后的第一篇
    置顶区域中的文档也不能移动

    参数：
    _currChannelId - 文档所在频道
    _currDocumentId - 文档
    抛出：
    WCMException - 如果文档已经是第一篇文档，则不做处理，不抛异常

    moveBackward

    void moveBackward(int _currDocumentId,
                  int _currChannelId)
                  throws WCMException
    将文档向后移动一位
    需要将两篇文档对换顺序
    如果文档已经是最后一篇，则不移动
    置顶区域中的文档不能移动

    参数：
    _currChannelId - 文档所在频道
    _currDocumentId - 文档
    抛出：
    WCMException - 如果文档已经是最后一篇文档，则不做处理，不抛异常

    moveFirst

    void moveFirst(int _currDocumentId,
               int _currChannelInt)
               throws WCMException
    将文档移动到频道内第一的位置
    需要将该移动文档前面的所有文档后移一位
    如果文档已经是第一篇，则不移动
    移动后的文档不进入置顶区域，是置顶区后的第一篇
    置顶区域中的文档也不能移动

    参数：
    _currChannelId - 文档所在频道
    _currDocumentId - 文档
    抛出：
    WCMException - 如果文档已经是第一篇，则不做处理，不抛异常

    moveLast

    void moveLast(int _currDocumentId,
              int _currChannelId)
              throws WCMException
    将文档移动到最后的位置
    需要将该移动文档后面的所有文档向前移一位
    如果文档已经是最后一篇，则不移动
    置顶区域中的文档也不能移动

    参数：
    _currChannel - 文档所在频道
    _currDocument - 文档
    抛出：
    WCMException - 如果文档已经是最后一篇，则不做处理，不抛异常

    moveDocumentInChannel

    void moveDocumentInChannel(int _fromDocumentId,
                           int _toDocumentId,
                           int _currChannelId)
                           throws WCMException
    在频道中移动文档的顺序
    如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
    通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
    置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档

    参数：
    _fromDocumentId - 要移动的文档Id
    _toDocumentId - 移动的目标文档Id
    _currChannelId - 文档所在频道Id
    抛出：
    WCMException

    moveDocumentInChannel

    void moveDocumentInChannel(int _fromDocumentId,
                           int _toDocumentId,
                           int _currChannelId,
                           int _nPostionCode)
                           throws WCMException
    抛出：
    WCMException

    getChannels

    Channels getChannels(Document _currDocument)
                     throws WCMException
    获得实体文档相关的引用、镜像等对应的所有频道

    参数：
    _currDocument -
    返回：
    抛出：
    WCMException

    delete

    boolean delete(ChnlDocs _delChnlDocs,
               boolean _bDrop)
               throws WCMException
    批量删除当前频道下的文档

    参数：
    _delChnlDocs - 需要删除的频道文档集合
    _bDrop - 是否删除数据库中的数据,true为删除,不可恢复
    返回：
    操作成功返回true
    抛出：
    WCMException

    quoteTo

    Reports quoteTo(Document _currDocument,
                java.lang.String _sToChannelIds)
                throws WCMException
    维护单篇文档的引用转发关系
    将单篇文档引用转发到目标频道列表中
    一般用于在文档采编页面中，设置一篇文档的引用转发
    这里的维护中包括删除所有无用的引用转发关系

    参数：
    _currDocument - 实体文档本身，原始频道即文档的频道
    _sToChannelIds - 目标频道Id列表
    抛出：
    WCMException

    quoteTo

    Reports quoteTo(java.lang.String _sDocumentIds,
                int _nFromChannelId,
                java.lang.String sToChannelIds)
                throws WCMException
    将一组文档转发（引用转发）到多个目标频道下
    一般这样的操作是在文档列表页面执行的

    参数：
    _sDocumentIds - 源文档Id列表
    _nFromChannelId - 源频道Id
    sToChannelIds - 目标频道Id列表
    返回：
    引用转发的结果报告
    抛出：
    WCMException

    copyTo

    Reports copyTo(java.lang.String _sDocumentIds,
               int _nFromChannelId,
               java.lang.String _sToChannelIds)
               throws WCMException
    将一组文档从指定的频道复制到多个目标频道下
    一般这样的操作是在文档列表页面执行的

    参数：
    _sDocumentIds - 文档Id列表
    _nFromChannelId - 指定的频道Id(>0表示从当前指定频道操作;0表示从文档所属频道操作)
    sToChannelIds - 目标频道Id列表
    返回：
    复制的结果报告
    抛出：
    WCMException

    moveTo

    Reports moveTo(java.lang.String _sDocumentIds,
               int _nFromChannelId,
               java.lang.String _sToChannelIds)
               throws WCMException
    将文档从指定的频道移动到多个目标频道下
    一般这样的操作是在文档列表页面执行的

    参数：
    _sDocumentIds - 文档Id列表
    _nFromChannelId - 指定的频道Id（=0表示从文档的所属频道操作）
    sToChannelIds - 目标频道Id列表
    返回：
    移动的结果报告
    抛出：
    WCMException

    copyTo

    Reports copyTo(java.lang.String _fromChnlDocIds,
               java.lang.String _toChannelIds)
               throws WCMException
    复制文档集合 将一堆文档复制到某个频道 一堆文档可以是一个检索的结果

    参数：
    _fromChnlDocIds - 要复制的频道文档集合Id序列
    _toChannelIds - 目标频道Id序列
    返回：
    抛出：
    WCMException

    moveTo

    Reports moveTo(java.lang.String _fromChnlDocIds,
               java.lang.String _toChannelIds)
               throws WCMException
    移动文档集合
    将一堆文档移动到某个频道 一堆文档可以是一个检索的结果

    参数：
    _fromChnlDocIds - 要移动的频道文档集合Id序列
    _toChannelIds - 目标频道Id序列
    返回：
    抛出：
    WCMException

    quoteTo

    Reports quoteTo(java.lang.String _fromChnlDocIds,
                java.lang.String _toChannelIds)
                throws WCMException
    引用转发频道文档集合
    将一堆频道文档移动到某个频道 一堆文档可以是一个检索的结果

    参数：
    _fromChnlDocIds - 要引用哈钻发的频道文档集合Id序列
    _toChannelIds - 目标频道Id序列
    返回：
    抛出：
    WCMException

    mirrorTo

    Reports mirrorTo(java.lang.String _fromChnlDocIds,
                 java.lang.String _toChannelIds)
                 throws WCMException
    镜像转发频道文档集合
    将一堆文档镜像转发到某个频道 一堆文档可以是一个检索的结果

    参数：
    _fromChnlDocIds - 要镜像转发的频道文档集合Id序列
    _toChannelIds - 目标频道Id序列
    返回：
    抛出：
    WCMException

    mirrorTo

    Reports mirrorTo(java.lang.String _sDocumentIds,
                 int _nFromChannelId,
                 java.lang.String _sToChannelIds)
                 throws WCMException
    将一组文档镜像转发到多个目标频道下
    一般这样的操作是在文档列表页面执行的

    参数：
    _sDocumentIds - 源文档Id列表
    _nFromChannelId - 源频道Id
    sToChannelIds - 目标频道Id列表
    返回：
    镜像转发的结果报告
    抛出：
    WCMException

    findChnldoc

    ChnlDoc findChnldoc(int _currDocumentId,
                    int _currChannelId)
                    throws WCMException
    根据频道和文档，找到对应的ChnlDoc

    参数：
    _currChannel -
    _currDocument -
    返回：
    抛出：
    WCMException

    getRecycleDocuments

    Documents getRecycleDocuments(BaseChannel _channelOrSite,
                              WCMFilter _filter)
                              throws WCMException
    获取当前站点或频道的回收站的文档

    参数：
    _channelOrSite - 站点或频道对象
    _filter - 额外的检索条件
    返回：
    文档集合
    抛出：
    WCMException

    getAllRelatedDocumentsByKeywords

    Documents getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords,
                                           int _nExcludeDocId,
                                           WCMFilter _filter)
                                           throws WCMException
    抛出：
    WCMException

    saveInfoViewDocument

    Document saveInfoViewDocument(Document _document,
                              org.dom4j.Document _contentXmlDoc)
                              throws WCMException
    抛出：
    WCMException

    save

    Document save(Document newDocument,
              java.util.List _aAppendixList,
              java.util.List _aRelationList,
              java.util.Map _hFlowContextInfo)
              throws WCMException
    抛出：
    WCMException

    save

    Document save(Document newDocument,
              java.util.List _aAppendixList,
              java.util.List _aRelationList,
              java.lang.String _sFlowContextInfo)
              throws WCMException
    抛出：
    WCMException

    save

    Document save(Document newDocument,
              java.util.List _aAppendixList,
              java.util.List _aRelationList,
              int _nFlowdocId)
              throws WCMException
    抛出：
    WCMException

    saveInfoViewDocument

    Document saveInfoViewDocument(Document _document,
                              org.dom4j.Document _contentXmlDoc,
                              java.util.Map _hFlowContextInfo)
                              throws WCMException
    抛出：
    WCMException

    saveInfoViewDocument

    Document saveInfoViewDocument(Document _document,
                              org.dom4j.Document _contentXmlDoc,
                              java.lang.String _sFlowContextInfo)
                              throws WCMException
    抛出：
    WCMException

    saveInfoViewDocument

    Document saveInfoViewDocument(Document _document,
                              InfoView _infoView,
                              java.util.Map _infoViewData)
                              throws WCMException
    参数：
    _document -
    _infoView -
    _infoViewData -
    抛出：
    WCMException
    概述 软件包 类 使用 树 已过时 索引 帮助
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IEventService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IEventService

所有已知实现类：
EventService
public interface IEventService

Title: TRS 内容协作平台（TRS WCM）
Description:
Event Service Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | cancelShare(Event _aEvent, Group _assignToGroup) 取消指派给另外一个组织的Event
void | cancelShare(Event _aEvent, User _assignToUser) 取消指派给另外一个用户的Event
void | cancelShare(Event _aEvent, Users _assignToUsers) 取消指派给一个用户集合的Event
void | cancelShares(Event _aEvent) 取消所有共享
boolean | delete(Event _aEvent) 根据指定的Event对象进行删除操作
boolean | delete(Events _aEvents) 根据指定的Events对象进行删除操作
boolean | delete(int _nEventId) 根据提供的Event ID进行删除操作, 直接进行彻底删除操作
boolean | delete(java.lang.String _sIds) 根据制定的ID序列，进行删除操作
Events | getEvents(WCMFilter _filter) 根据指定的filter获取Events
User | getLoginUser() 获取当前登录用户
Events | getSharedEvents(User _user, CMyDateTime _date) 获取用户在指定日期内被Assign的所有Events
Events | getSharedEvents(User _user, CMyDateTime _date, boolean _bAll) 获取用户在指定日期内私有的或公有的Events
Events | getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter) 获取用户在指定filter限制下被Assign的Events
Groups | getSharedGroups(Event _aEvent) 获取一个Event被AssignTo的Group
Users | getSharedUsers(Event _aEvent) 获取一个Event被AssignTo的Users
Event | save(Event _aEvent) 保存一个Event
void | shareTo(Event _aEvent, Group _assignToGroup) 当前用户把一个Event指派给一个组织
void | shareTo(Event _aEvent, Groups _assignToGroups)
void | shareTo(Event _aEvent, java.lang.String _sUserIds)
void | shareTo(Event _aEvent, User _assignToUser) 当前用户把一个Event指派给另外一个用户
void | shareTo(Event _aEvent, Users _assignToUsers) 把一个Event指派给一个用户集合

方法详细信息

save

Event save(Event _aEvent)
           throws WCMException
保存一个Event

参数：
_aEvent -
返回：
如果成功则返回这个Event
抛出：
WCMException - 如果保存失败，则抛出异常

delete

boolean delete(int _nEventId)
               throws WCMException
根据提供的Event ID进行删除操作, 直接进行彻底删除操作

参数：
_nEventId -
返回：
如果成功，则返回true
抛出：
WCMException - 如果没有找到指定ID的Event对象，则抛出异常，中止操作 如果删除失败则抛出异常

delete

boolean delete(Event _aEvent)
               throws WCMException
根据指定的Event对象进行删除操作

参数：
_aEvent -
返回：
抛出：
WCMException - 如果传入空对象，则抛出异常

delete

boolean delete(java.lang.String _sIds)
               throws WCMException
根据制定的ID序列，进行删除操作

参数：
_sIds -
返回：
抛出：
WCMException

delete

boolean delete(Events _aEvents)
               throws WCMException
根据指定的Events对象进行删除操作

参数：
_aEvents -
返回：
抛出：
WCMException - 如果传入空对象，则抛出异常

getEvents

Events getEvents(WCMFilter _filter)
                 throws WCMException
根据指定的filter获取Events

参数：
_filter -
返回：
抛出：
WCMException

shareTo

void shareTo(Event _aEvent,
             User _assignToUser)
             throws WCMException
当前用户把一个Event指派给另外一个用户

参数：
_aEvent -
_assignToUser -
抛出：
WCMException

shareTo

void shareTo(Event _aEvent,
             Users _assignToUsers)
             throws WCMException
把一个Event指派给一个用户集合

参数：
_aEvent -
_assignToUsers -
抛出：
WCMException

shareTo

void shareTo(Event _aEvent,
             java.lang.String _sUserIds)
             throws WCMException
参数：
_aEvent -
_sUserIds -
抛出：
WCMException

shareTo

void shareTo(Event _aEvent,
             Group _assignToGroup)
             throws WCMException
当前用户把一个Event指派给一个组织

参数：
_aEvent -
_assignToGroup -
抛出：
WCMException

shareTo

void shareTo(Event _aEvent,
             Groups _assignToGroups)
             throws WCMException
参数：
_aEvent -
_assignToGroups -
抛出：
WCMException

cancelShare

void cancelShare(Event _aEvent,
                 User _assignToUser)
                 throws WCMException
取消指派给另外一个用户的Event

参数：
_aEvent -
_assignToUser -
抛出：
WCMException

cancelShare

void cancelShare(Event _aEvent,
                 Users _assignToUsers)
                 throws WCMException
取消指派给一个用户集合的Event

参数：
_aEvent -
_assignToUsers -
抛出：
WCMException

cancelShare

void cancelShare(Event _aEvent,
                 Group _assignToGroup)
                 throws WCMException
取消指派给另外一个组织的Event

参数：
_aEvent -
_assignToGroup -
抛出：
WCMException

getLoginUser

User getLoginUser()
获取当前登录用户

返回：

getSharedEvents

Events getSharedEvents(User _user,
                       CMyDateTime _date)
                       throws WCMException
获取用户在指定日期内被Assign的所有Events

参数：
_user -
_date -
返回：
抛出：
WCMException

getSharedEvents

Events getSharedEvents(User _user,
                       CMyDateTime _date,
                       boolean _bAll)
                       throws WCMException
获取用户在指定日期内私有的或公有的Events

参数：
_user -
_date -
_bAll -
返回：
抛出：
WCMException

getSharedEvents

Events getSharedEvents(User _user,
                       CMyDateTime _date,
                       boolean _bAll,
                       WCMFilter _filter)
                       throws WCMException
获取用户在指定filter限制下被Assign的Events

参数：
_user -
_filter -
返回：
抛出：
WCMException

getSharedUsers

Users getSharedUsers(Event _aEvent)
                     throws WCMException
获取一个Event被AssignTo的Users

参数：
_aEvent -
返回：
抛出：
WCMException

getSharedGroups

Groups getSharedGroups(Event _aEvent)
                       throws WCMException
获取一个Event被AssignTo的Group

参数：
_aEvent -
返回：
抛出：
WCMException

cancelShares

void cancelShares(Event _aEvent)
                  throws WCMException
取消所有共享

参数：
_aEvent -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IGroupService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IGroupService

所有已知实现类：
GroupService
public interface IGroupService

Title: TRS 内容协作平台（TRS WCM）
Description:
组织服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | addManager(User _adminToAdd, Group _dstGroup) 将指定用户设置为某个组的管理员 注意: 指定的用户必须在指定组中
boolean | addUser(User _userToAdd, Group _dstGroup) 将指定用户添加个指定的组中
boolean | delete(Group _groupToDelete) 删除某个特定的组织
boolean | delete(Groups _groupsToDelete) 删除一批组织（在组织列表页面中用到）
boolean | delete(int _nGroupId) 根据组ID，删除一个组织
boolean | delete(java.lang.String _sGroupIds) 根据组织Id，删除一批组织（在组织列表页面中用到）
Users | getAdmins(Group _dstGroup) 获取指定组的管理员集合
Groups | getChildren(Group _parentGroup) 获取某个组的子组集合
Groups | getChildren(Group _parentGroup, boolean _bContainsChildren)
Groups | getChildren(Group _parentGroup, boolean _bContainsChildren, WCMFilter _filter)
Users | getUsers(Group _dstGroup, WCMFilter _filter) 获取指定组中的所有用户
Users | getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildren)
Group | moveTo(Group _fromGroup, Group _toGroup) 移动组织，将一个组织移动到另一个组织下
boolean | moveUser(User _userToMove, Group _srcGroup, Group _dstGroup) 将指定用户从某个组移动到指定的另外一个组中
boolean | moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups) 将指定的用户从某个组移动到指定的多个组中
boolean | removeManager(User _adminToCancel, Group _dstGroup) 取消指定用户在某个组的管理员身份 注意: 指定的用户必须在指定组中
boolean | removeUser(User _userToRemove, Group _dstGroup) 将指定组从指定的组中删除
boolean | removeUser(User _userToRemove, Group _dstGroup, boolean _bRemoveOffspring)
Group | save(Group _dstGroup) 保存指定的组织
boolean | setGroupUsers(int _nDstGroupId, java.lang.String _sUserIdsToAdd) 维护指定用户组的用户列表

方法详细信息

addUser

boolean addUser(User _userToAdd,
                Group _dstGroup)
                throws WCMException
将指定用户添加个指定的组中

参数：
_userToAdd - 要添加的指定用户
_dstGroup - 指定的目标组
返回：
添加成功返回true
抛出：
WCMException

setGroupUsers

boolean setGroupUsers(int _nDstGroupId,
                      java.lang.String _sUserIdsToAdd)
                      throws WCMException
维护指定用户组的用户列表

参数：
_nDstGroupId - 指定的用户组
_sUserIdsToAdd - 用户列表的ID序列
返回：
@throws WCMException
抛出：
WCMException

removeUser

boolean removeUser(User _userToRemove,
                   Group _dstGroup)
                   throws WCMException
将指定组从指定的组中删除

参数：
_userToRemove - 要删除的指定用户
_dstGroup - 指定的目标组
返回：
删除成功返回true
抛出：
WCMException

removeUser

boolean removeUser(User _userToRemove,
                   Group _dstGroup,
                   boolean _bRemoveOffspring)
                   throws WCMException
抛出：
WCMException

getUsers

Users getUsers(Group _dstGroup,
               WCMFilter _filter)
               throws WCMException
获取指定组中的所有用户

参数：
_dstGroup - 指定的目标组
_filter - 过滤器,额外的查询条件
返回：
组中所有的用户集合
抛出：
WCMException

getUsers

Users getUsers(Group _dstGroup,
               WCMFilter _filter,
               boolean _bContainsChildren)
               throws WCMException
抛出：
WCMException

moveUser

boolean moveUser(User _userToMove,
                 Group _srcGroup,
                 Group _dstGroup)
                 throws WCMException
将指定用户从某个组移动到指定的另外一个组中

参数：
_userToMove -
_srcGroup - 用户原来所在的组
_dstGroup - 用户所属的新组
返回：
移动成功返回true
抛出：
WCMException

moveUser

boolean moveUser(User _userToMove,
                 Group _srcGroup,
                 Groups _dstGroups)
                 throws WCMException
将指定的用户从某个组移动到指定的多个组中

参数：
_userToMove - 要移动的指定用户
_srcGroup - 用户所在的原组
_dstGroups - 目标组集合
返回：
移动成功返回true
抛出：
WCMException

addManager

boolean addManager(User _adminToAdd,
                   Group _dstGroup)
                   throws WCMException
将指定用户设置为某个组的管理员
注意: 指定的用户必须在指定组中

参数：
_adminToAdd - 指定的用户
_dstGroup - 目标组
返回：
设置成功,返回true
抛出：
WCMException

removeManager

boolean removeManager(User _adminToCancel,
                      Group _dstGroup)
                      throws WCMException
取消指定用户在某个组的管理员身份
注意: 指定的用户必须在指定组中

参数：
_adminToCancel - 指定的组管理员
_dstGroup - 目标组
返回：
操作成功返回true
抛出：
WCMException

getChildren

Groups getChildren(Group _parentGroup)
                   throws WCMException
获取某个组的子组集合

参数：
_parentGroup - 指定的父组(如果没有指定,则返回系统中的一级组织)
返回：
该组的子组集合
抛出：
WCMException

getChildren

Groups getChildren(Group _parentGroup,
                   boolean _bContainsChildren,
                   WCMFilter _filter)
                   throws WCMException
抛出：
WCMException

getChildren

Groups getChildren(Group _parentGroup,
                   boolean _bContainsChildren)
                   throws WCMException
抛出：
WCMException

delete

boolean delete(Group _groupToDelete)
               throws WCMException
删除某个特定的组织

参数：
_groupToDelete - ：要删除的组织
返回：
true为删除成功，false为删除失败
抛出：
WCMException

delete

boolean delete(int _nGroupId)
               throws WCMException
根据组ID，删除一个组织

参数：
_nGroupId - ：要删除组织的Id
返回：
true为删除成功，false为删除失败
抛出：
WCMException

delete

boolean delete(Groups _groupsToDelete)
               throws WCMException
删除一批组织（在组织列表页面中用到）

参数：
_groupsToDelete - 要删除的组织集合
返回：
true为删除成功，false为删除失败
抛出：
WCMException

delete

boolean delete(java.lang.String _sGroupIds)
               throws WCMException
根据组织Id，删除一批组织（在组织列表页面中用到）

参数：
_sGroupIds - 要删除的组织集合的Id列表，形如1,2,3,5
返回：
true为删除成功，false为删除失败
抛出：
WCMException

save

Group save(Group _dstGroup)
           throws WCMException
保存指定的组织

参数：
_dstGroup - 要保存的组织
返回：
@throws WCMException
抛出：
WCMException

moveTo

Group moveTo(Group _fromGroup,
             Group _toGroup)
             throws WCMException
移动组织，将一个组织移动到另一个组织下

参数：
_fromGroup - 需要移动的组织
_toGroup - 目标组织，fromGroup移动后作为目标组织的一个子组织；目标组织为0表示在根下建立
返回：
移动后的组织
抛出：
WCMException

getAdmins

Users getAdmins(Group _dstGroup)
                throws WCMException
获取指定组的管理员集合

参数：
_dstGroup - 指定的目标组
返回：
指定组的管理员集合
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IInfoViewEnumCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IInfoViewEnumCreator

所有已知实现类：
InfoViewEnumCreatorImpl
public interface IInfoViewEnumCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

方法摘要
 java.lang.Object enumScript(InfoViewContext _oContext)

方法详细信息

enumScript

java.lang.Object enumScript(InfoViewContext _oContext)
                            throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IInfoViewInitor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IInfoViewInitor

所有已知实现类：
InfoViewInitorImpl
public interface IInfoViewInitor

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

方法摘要
 java.lang.Object init(InfoViewContext _oContext)

方法详细信息

init

java.lang.Object init(InfoViewContext _oContext)
                      throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IInfoViewInitorValue

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IInfoViewInitorValue

所有已知实现类：
SiteNameCreator
public interface IInfoViewInitorValue

方法摘要
 java.lang.Object getFieldValue(InfoViewContext _oContext, BindingBean _oBindingBean)

方法详细信息

getFieldValue

java.lang.Object getFieldValue(InfoViewContext _oContext,
                               BindingBean _oBindingBean)
                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IInfoViewService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IInfoViewService

所有已知实现类：
InfoViewService
public interface IInfoViewService

自定义表单管理的公共接口定义

作者：
Martin (Fu Chengrui)

方法摘要
void | delete(InfoView _oInfoView) 彻底删除指定的自定义表单
void | delete(InfoViews _oInfoViews) 彻底删除指定的自定义表单集合 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。
void | delete(int _iInfoViewID) 根据自定义表单的ID彻底删除自定义表单
void | delete(java.lang.String _sInfoViewIDs) 根据自定义表单的ID列表彻底删除自定义表单， 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。
java.lang.String | filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int nFlowDocId)
InfoView | findById(int _iInfoViewID) 在指定的站点下查找指定ID的自定义表单
InfoViewView | findViewById(int _iViewID) 查找指定ID的自定义表单视图
java.lang.String | forFillOut(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面 事实上生成的HTML页面不仅用于内部填写表单、还用在表单预览、表单数据察看。
java.lang.String | forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int nFlowDocId)
java.lang.String | forFillOutInner(InfoView _oInfoView, InfoViewView _oView)
java.lang.String | forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)
java.util.List | getAppendixList(org.dom4j.Document dom4jDocument) 从org.dom4j.Document对象中抽取附件信息 作为输入的org.dom4j.Document对象，在抽取附件信息，其中的附件标示信息已经被删除。
java.util.List | getAppendixList(java.lang.String xmlContent) 从XML文件中抽取附件信息
java.lang.String | getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument) 按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题
java.lang.String | getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument, java.lang.String _oPostUserNmae) 按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题
java.lang.String | getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent) 按照相关表单的设定从XML文件抽取文档的标题
org.dom4j.Document | getDOM4JDocument(java.lang.String xmlContent) 将XML文件的内容转化为org.dom4j.Document对象
java.util.List | getEmployedInfoViews(CMSObj _employer) 获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合
java.util.List | getEmployedInfoViews(int _iEmployerType, int _iEmployerId) 获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合
java.util.List | getInfoViewEmployers(InfoView _employed) 获取指定自定义表单的所有雇主（频道对象）的集合
java.util.List | getInfoViewEmployers(int _iInfoViewID) 获取指定自定义表单的所有雇主（频道对象）的集合
InfoViews | getInfoViews(WCMFilter _filter) 获取所有符合条件的自定义表单
java.lang.String | getInfoViewSerial(InfoView _oInfoView) 获取指定表单的编号
java.lang.String | getInfoViewSerial(int _iInfoViewId) 获取指定表单的编号
void | rebuildXSLT(InfoView _oInfoView)
void | rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)
void | save(InfoView _oInfoView) 保存指定的自定义表单
void | save(InfoViewField _oField) 保存指定的自定义表单字段
void | save(InfoViewGroup _oGroup) 保存指定的自定义表单数据节
void | save(InfoViewView _oView) 保存指定的自定义表单视图
void | saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)
void | sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage) 发送表单文档的回复通知 优先使用表单上的设置
void | sendReplyNotice(int _iInfoViewId, int _iDocumentId, int _iDocReplyId, boolean _zSendEmail, boolean _zSendMessage) 发送表单文档的回复通知 优先使用表单上的设置
void | setEmployedInfoView(CMSObj _employer, InfoView _oInfoView) 设置雇主（通常是频道）雇佣的自定义表单的ID列表
void | setEmployedInfoViews(CMSObj _employer, java.lang.String _sInfoViewIDs) 设置雇主（通常是频道）雇佣的自定义表单的ID列表
void | setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadonly)

方法详细信息

delete

void delete(InfoView _oInfoView)
            throws WCMException
彻底删除指定的自定义表单

参数：
_oInfoView - 待删除的自定义表单
抛出：
WCMException - 如果操作失败

delete

void delete(InfoViews _oInfoViews)
            throws WCMException
彻底删除指定的自定义表单集合 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。

参数：
_oInfoViews - 待删除的自定义表单集合
抛出：
WCMException - 如果操作失败

delete

void delete(int _iInfoViewID)
            throws WCMException
根据自定义表单的ID彻底删除自定义表单

参数：
_iInfoViewID - 待删除的自定义表单的ID
抛出：
WCMException - 如果操作失败

delete

void delete(java.lang.String _sInfoViewIDs)
            throws WCMException
根据自定义表单的ID列表彻底删除自定义表单， 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。

参数：
_sInfoViewIDs - 待删除的自定义表单的ID列表，形如2,3,5,13
抛出：
WCMException - 如果操作失败

findById

InfoView findById(int _iInfoViewID)
                  throws WCMException
在指定的站点下查找指定ID的自定义表单

参数：
_iInfoViewID - 指定的表单ID
返回：
符合条件的自定义表单或者null
抛出：
WCMException - 如果操作失败

findViewById

InfoViewView findViewById(int _iViewID)
                          throws WCMException
查找指定ID的自定义表单视图

参数：
_iViewID - 视图的ID
返回：
符合条件的视图对象或者null
抛出：
WCMException - 如果操作失败

forFillOut

java.lang.String forFillOut(InfoView _oInfoView,
                            InfoViewView _oView)
                            throws WCMException
为了在WCM内部填写表单而生成HTML页面 事实上生成的HTML页面不仅用于内部填写表单、还用在表单预览、表单数据察看。

参数：
_oInfoView - 指定的表单
_oView - 指定的视图
返回：
生成HTML页面的内容
抛出：
WCMException - 如果发生错误

forFillOutInner

java.lang.String forFillOutInner(InfoView _oInfoView,
                                 InfoViewView _oView)
                                 throws WCMException
抛出：
WCMException

forFillOutInner

java.lang.String forFillOutInner(InfoView _oInfoView,
                                 InfoViewView _oView,
                                 boolean _bNewDocInFlow)
                                 throws WCMException
抛出：
WCMException

forFillOutInFlow

java.lang.String forFillOutInFlow(InfoView _oInfoView,
                                  InfoViewView _oView,
                                  int nFlowDocId)
                                  throws WCMException,
                                         java.lang.Throwable
抛出：
WCMException
java.lang.Throwable

filterContentInFlow

java.lang.String filterContentInFlow(InfoView _oInfoView,
                                     java.lang.String _sXmlContent,
                                     int nFlowDocId)
                                     throws WCMException,
                                            java.lang.Throwable
抛出：
WCMException
java.lang.Throwable

getInfoViews

InfoViews getInfoViews(WCMFilter _filter)
                       throws WCMException
获取所有符合条件的自定义表单

参数：
_filter - 条件
返回：
符合条件的自定义表单集合
抛出：
WCMException - 如果发生错误

getInfoViewEmployers

java.util.List getInfoViewEmployers(InfoView _employed)
                                    throws WCMException
获取指定自定义表单的所有雇主（频道对象）的集合

参数：
_employed - 指定的自定义表单
返回：
指定自定义表单的所有雇主的集合
抛出：
WCMException - 如果操作失败

getInfoViewEmployers

java.util.List getInfoViewEmployers(int _iInfoViewID)
                                    throws WCMException
获取指定自定义表单的所有雇主（频道对象）的集合

参数：
_iInfoViewID - 指定的自定义表单的ID
返回：
指定自定义表单的所有雇主的集合
抛出：
WCMException - 如果操作失败

getEmployedInfoViews

java.util.List getEmployedInfoViews(CMSObj _employer)
                                    throws WCMException
获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合

参数：
_employer - 指定的雇主
返回：
全部受雇表单的集合
抛出：
WCMException - 如果操作失败

getEmployedInfoViews

java.util.List getEmployedInfoViews(int _iEmployerType,
                                    int _iEmployerId)
                                    throws WCMException
获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合

参数：
_iEmployerType - 指定的雇主的类型
_iEmployerId - 指定的雇主的ID
返回：
全部受雇表单的集合
抛出：
WCMException - 如果操作失败

save

void save(InfoView _oInfoView)
          throws WCMException
保存指定的自定义表单

参数：
_oInfoView - 指定的表单
抛出：
WCMException - 如果操作失败

rebuildXSLT

void rebuildXSLT(InfoView _oInfoView)
                 throws WCMException
抛出：
WCMException

rebuildXSLTByFields

void rebuildXSLTByFields(InfoView _oInfoView,
                         java.util.List _lstFields)
                         throws WCMException
抛出：
WCMException

saveViewByFields

void saveViewByFields(InfoView _oInfoView,
                      java.util.List _lstFields)
                      throws WCMException
抛出：
WCMException

save

void save(InfoViewField _oField)
          throws WCMException
保存指定的自定义表单字段

参数：
_oField - 指定的字段对象
抛出：
WCMException - 如果操作失败

save

void save(InfoViewGroup _oGroup)
          throws WCMException
保存指定的自定义表单数据节

参数：
_oGroup - 指定的数据节对象
抛出：
WCMException - 如果操作失败

save

void save(InfoViewView _oView)
          throws WCMException
保存指定的自定义表单视图

参数：
_oView - 指定的视图对象
抛出：
WCMException - 如果操作失败

setEmployedInfoView

void setEmployedInfoView(CMSObj _employer,
                         InfoView _oInfoView)
                         throws WCMException
设置雇主（通常是频道）雇佣的自定义表单的ID列表

参数：
_employer - 雇主对象
_oInfoView - 表单对象
抛出：
WCMException - 如果操作失败

setEmployedInfoViews

void setEmployedInfoViews(CMSObj _employer,
                          java.lang.String _sInfoViewIDs)
                          throws WCMException
设置雇主（通常是频道）雇佣的自定义表单的ID列表

参数：
_employer - 雇主对象
_sInfoViewIDs - 受雇的表单ID列表
抛出：
WCMException - 如果操作失败

getAppendixList

java.util.List getAppendixList(org.dom4j.Document dom4jDocument)
                               throws WCMException
从org.dom4j.Document对象中抽取附件信息 作为输入的org.dom4j.Document对象，在抽取附件信息，其中的附件标示信息已经被删除。

参数：
dom4jDocument - 传入的org.dom4j.Document对象
返回：
附件列表，可以为null
抛出：
WCMException - 如果操作失败

getAppendixList

java.util.List getAppendixList(java.lang.String xmlContent)
                               throws WCMException
从XML文件中抽取附件信息

参数：
xmlContent - XML文件的内容
返回：
附件列表，可以为null
抛出：
WCMException - 如果操作失败

getDocumentTitle

java.lang.String getDocumentTitle(InfoView _oInfoView,
                                  org.dom4j.Document dom4jDocument)
                                  throws WCMException
按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题

参数：
_oInfoView - 相关的表单对象
dom4jDocument - 传入的org.dom4j.Document对象
返回：
从XML中获得的文档标题
抛出：
WCMException - 如果操作失败

getDocumentTitle

java.lang.String getDocumentTitle(InfoView _oInfoView,
                                  java.lang.String xmlContent)
                                  throws WCMException
按照相关表单的设定从XML文件抽取文档的标题

参数：
_oInfoView - 相关的表单对象
xmlContent - XML文件的内容
返回：
从XML中获得的文档标题
抛出：
WCMException - 如果操作失败

getDocumentTitle

java.lang.String getDocumentTitle(InfoView _oInfoView,
                                  org.dom4j.Document dom4jDocument,
                                  java.lang.String _oPostUserNmae)
                                  throws WCMException
按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题

参数：
_oInfoView - 相关的表单对象
dom4jDocument - 传入的org.dom4j.Document对象
返回：
从XML中获得的文档标题
抛出：
WCMException - 如果操作失败

getDOM4JDocument

org.dom4j.Document getDOM4JDocument(java.lang.String xmlContent)
                                    throws WCMException
将XML文件的内容转化为org.dom4j.Document对象

参数：
xmlContent - XML文件的内容
返回：
org.dom4j.Document对象
抛出：
WCMException - 如果操作失败

getInfoViewSerial

java.lang.String getInfoViewSerial(int _iInfoViewId)
                                   throws WCMException
获取指定表单的编号

参数：
_iInfoViewId - 指定的表单Id
返回：
抛出：
WCMException

getInfoViewSerial

java.lang.String getInfoViewSerial(InfoView _oInfoView)
                                   throws WCMException
获取指定表单的编号

参数：
_oInfoView - 指定的表单
返回：
抛出：
WCMException

sendReplyNotice

void sendReplyNotice(int _iInfoViewId,
                     int _iDocumentId,
                     int _iDocReplyId,
                     boolean _zSendEmail,
                     boolean _zSendMessage)
                     throws WCMException
发送表单文档的回复通知
优先使用表单上的设置

参数：
_iInfoViewId - 表单Id
_iDocumentId - 表单文档Id
_iDocReplyId - 表单文档回复Id
_zSendEmail - 是否发送Email
_zSendMessage - 是否发送系统短消息
抛出：
WCMException

sendReplyNotice

void sendReplyNotice(InfoView _oInfoView,
                     Document _document,
                     DocReply _docReply,
                     boolean _zSendEmail,
                     boolean _zSendMessage)
                     throws WCMException
发送表单文档的回复通知
优先使用表单上的设置

参数：
_oInfoView - 表单对象
_document - 表单文档对象
_docReply - 表单回复对象
_zSendEmail - 是否发送Email
_zSendMessage - 是否发送系统短消息
抛出：
WCMException

setFieldsReadOnly

void setFieldsReadOnly(InfoView _oInfoView,
                       InfoViewFields _oInfoViewFields,
                       boolean _bReadonly)
                       throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewContext

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
类 InfoViewContext

java.lang.Object
    继承者  com.trs.service.InfoViewContext

public class InfoViewContext
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
InfoViewContext(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response)
方法摘要
static InfoViewContext | create(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response)
Channel | getChannel()
int | getChannelId()
static InfoViewContext | getCurrentInfoViewContext()
Document | getDocument()
int | getDocumentId()
int | getFlowId()
InfoView | getInfoView()
int | getInfoViewId()
javax.servlet.http.HttpServletRequest | getRequest()
javax.servlet.http.HttpServletResponse | getResponse()
User | getUser()
static void | main(java.lang.String[] args)
void | setChannelId(int _channelId)
void | setDocumentId(int _documentId)
void | setFlowId(int _flowId)
void | setInfoViewId(int _infoViewId)
void | setUser(User _oUser)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewContext

public InfoViewContext(javax.servlet.http.HttpServletRequest _request,
                       javax.servlet.http.HttpServletResponse _response)
方法详细信息

create

public static InfoViewContext create(javax.servlet.http.HttpServletRequest _request,
                                     javax.servlet.http.HttpServletResponse _response)

getCurrentInfoViewContext

public static InfoViewContext getCurrentInfoViewContext()

getRequest

public javax.servlet.http.HttpServletRequest getRequest()
返回：
the request

getResponse

public javax.servlet.http.HttpServletResponse getResponse()
返回：
the response

getChannelId

public int getChannelId()
返回：
the m_nChannelId

getChannel

public Channel getChannel()
                   throws WCMException
抛出：
WCMException

setChannelId

public void setChannelId(int _channelId)
参数：
_channelId - the m_nChannelId to set

getDocumentId

public int getDocumentId()
返回：
the m_nDocumentId

getDocument

public Document getDocument()
                     throws WCMException
抛出：
WCMException

setDocumentId

public void setDocumentId(int _documentId)
参数：
_documentId - the m_nDocumentId to set

getFlowId

public int getFlowId()
返回：
the m_nFlowId

setFlowId

public void setFlowId(int _flowId)
参数：
_flowId - the m_nFlowId to set

getInfoViewId

public int getInfoViewId()
返回：
the m_nInfoViewId

getInfoView

public InfoView getInfoView()
                     throws WCMException
抛出：
WCMException

setInfoViewId

public void setInfoViewId(int _infoViewId)
参数：
_infoViewId - the m_nInfoViewId to set

getUser

public User getUser()
返回：
the m_sUserName

setUser

public void setUser(User _oUser)
参数：
_userName - the m_sUserName to set

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IOfficeDocumentService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IOfficeDocumentService

所有已知实现类：
OfficeDocumentService
public interface IOfficeDocumentService

Title: TRS 内容协作平台（TRS WCM）
Description:
Office文档的相关服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

方法摘要
 java.lang.String convert2Html(java.lang.String _sFileName)
Soap调用OfficeConverter处理文件，转换成HTML文件的zip包

方法详细信息

convert2Html

java.lang.String convert2Html(java.lang.String _sFileName)
                              throws java.lang.Exception
Soap调用OfficeConverter处理文件，转换成HTML文件的zip包

参数：
_sFileName -
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IPublishService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IPublishService

所有已知实现类：
PublishService
public interface IPublishService

方法摘要
void | cancelTasks(java.lang.String _sTaskIds) 取消指定的发布任务集合
void | delete(BaseChannel _siteOrChannel) 删除指定站点/频道的发布页面
void | delete(Document _document) 删除指定文档已发布的页面
void | delete(Document _document, Channel _channel) 从指定频道上删除指定文档已发布的页面
void | delete(Documents _documents) 删除指定文档集合已发布的页面
void | delete(Documents _documents, Channel _channel) 从指定频道上删除指定文档集合已发布的页面
void | deleteTasks(java.lang.String _sTaskIds)
PublishTasks | getAllTasks(WCMFilter _filter) 提取所有的发布任务；要求当前用户必须具有管理权限
User | getLoginUser()
PublishTasks | getMyTasks(WCMFilter _filter) 提取我的发布任务
PublishTask | getRunningTask(int iTaskID) 返回指定ID的正在执行的发布任务对象
java.util.Iterator | getRunningTasks() 返回所有的正在执行的任务
PublishTaskRuntime | getTaskRuntime(int iTaskID) 返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
void | pauseTask(java.lang.String _sTaskIds) 暂停指定的发布任务集合，对其中不处于执行状态的任务不会产生影响
java.lang.String[] | preview(BaseChannel _siteOrChannel, java.lang.String[] _warningsHolder) 预览指定的站点/频道，并返回预览页面的URL列表（若配置了多个概览模板，则可能有多个）。
java.lang.String | preview(Document _document, Channel _channel, java.lang.String[] _warningsHolder) 在指定的频道上预览文档，并返回预览页面的URL。
java.lang.String | preview(Document _document, java.lang.String[] _warningsHolder) 在文档的存放点上预览文档，并返回预览页面的URL。
java.lang.String | previewInfoviewPrint(Document _document, Channel _channel, java.lang.String[] _waringsHolder, int _templateId)
void | publish(BaseChannel _siteOrChannel, int _nPublishType) 完全发布站点/频道
void | publish(ChnlDocs _chnlDocs, int _nPubType) 发布指定的ChnlDoc集合，用于“最近访问文档”的直接发布
void | publish(Document _document, Channel _channel, int _nPubType) 发布文档
void | publish(Document _document, int _nPubType) 发布文档
void | publish(Documents _documents, Channel _channel, int _nPubType) 发布指定文档集合
void | publish(Documents _documents, int _nPubType) 发布指定文档集合
void | publishConfirm(BaseChannel _oSiteOrChnl, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile) 确认（批准）发布 用于先将站点或频道的首页发布到一个临时文件，在确认没有错误后，再把临时文件重名为正式的站点或频道首页。
void | publishForcibly(int _nDocumentId, java.lang.String _sChannelIds) 强制在指定的频道中发布文档， 如果文档在指定的频道中状态为不允许发布状态，将会自动改为可发布的状态，然后再发不
void | redoTasks(java.lang.String _sTaskIds) 重新执行指定的发布任务集合
void | resumeTask(java.lang.String _sTaskIds) 恢复指定的发布任务集合，对其中不处于暂停状态的任务不会产生影响

方法详细信息

getLoginUser

User getLoginUser()
返回：
返回当前登录用户

preview

java.lang.String[] preview(BaseChannel _siteOrChannel,
                           java.lang.String[] _warningsHolder)
                           throws WCMException
预览指定的站点/频道，并返回预览页面的URL列表（若配置了多个概览模板，则可能有多个）。
若在预览过程中存在一些警告信息，且指定了存储容器（_warningsHolder），这些警告信息会被存储在容器的第一个元素位置。

参数：
_siteOrChannel - 要预览的站点/频道
_warningsHolder - 用以接纳警告信息的存储容器
返回：
返回预览页面的URL地址列表（可能有多个概览模板）
抛出：
WCMException - 若当前用户无预览权限，或预览失败，会抛出异常。

preview

java.lang.String preview(Document _document,
                         java.lang.String[] _warningsHolder)
                         throws WCMException
在文档的存放点上预览文档，并返回预览页面的URL。
若在预览过程中存在一些警告信息，且指定了存储容器（_warningsHolder），这些警告信息会被存储在容器的第一个元素位置。

参数：
_document - 要预览的文档
_warningsHolder - 用以接纳警告信息的存储容器
返回：
返回预览页面的URL地址
抛出：
WCMException - 若当前用户无文档发布权限，或预览失败，会抛出异常。

preview

java.lang.String preview(Document _document,
                         Channel _channel,
                         java.lang.String[] _warningsHolder)
                         throws WCMException
在指定的频道上预览文档，并返回预览页面的URL。
若在预览过程中存在一些警告信息，且指定了存储容器（_warningsHolder），这些警告信息会被存储在容器的第一个元素位置。

参数：
_document - 要预览的文档
_channel - 文档所在频道
_warningsHolder - 用以接纳警告信息的存储容器
返回：
返回预览页面的URL地址
抛出：
WCMException - 若当前用户无文档发布权限，或预览失败，会抛出异常。

previewInfoviewPrint

java.lang.String previewInfoviewPrint(Document _document,
                                      Channel _channel,
                                      java.lang.String[] _waringsHolder,
                                      int _templateId)
                                      throws WCMException
抛出：
WCMException

publish

void publish(BaseChannel _siteOrChannel,
             int _nPublishType)
             throws java.lang.Exception
完全发布站点/频道

参数：
_siteOrChannel - 待发布的站点/频道
_nPublishType - 发布类型（如完全发布、增量发布等，定义在WCMPublisher中）
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

delete

void delete(BaseChannel _siteOrChannel)
            throws java.lang.Exception
删除指定站点/频道的发布页面

参数：
_siteOrChannel - 删除的站点/频道
抛出：
java.lang.Exception - 若当前用户无发布权限,或更新发布失败，会抛出异常

publish

void publish(Document _document,
             int _nPubType)
             throws java.lang.Exception
发布文档

参数：
_document - 待发布的文档
_nPubType - TODO
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

publish

void publish(Document _document,
             Channel _channel,
             int _nPubType)
             throws java.lang.Exception
发布文档

参数：
_document - 待发布的文档
_channel - 文档所在频道
_nPubType - TODO
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

publish

void publish(Documents _documents,
             int _nPubType)
             throws java.lang.Exception
发布指定文档集合

参数：
_documents - 待发布的文档集合
_nPubType - TODO
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

publish

void publish(Documents _documents,
             Channel _channel,
             int _nPubType)
             throws java.lang.Exception
发布指定文档集合

参数：
_documents - 待发布的文档集合
_channel - 文档所在频道
_nPubType - TODO
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

publish

void publish(ChnlDocs _chnlDocs,
             int _nPubType)
             throws java.lang.Exception
发布指定的ChnlDoc集合，用于“最近访问文档”的直接发布

参数：
_chnlDocs -
_nPubType - TODO
抛出：
java.lang.Exception

delete

void delete(Document _document)
            throws WCMException
删除指定文档已发布的页面

参数：
_document - 待删除的文档
抛出：
WCMException - 若更新发布失败，会抛出异常

delete

void delete(Document _document,
            Channel _channel)
            throws WCMException
从指定频道上删除指定文档已发布的页面

参数：
_document - 待删除的文档
_channel - 文档所在频道
抛出：
WCMException - 若更新发布失败，会抛出异常

delete

void delete(Documents _documents)
            throws WCMException
删除指定文档集合已发布的页面

参数：
_documents - 待删除的文档
抛出：
WCMException - 若当前用户无发布权限,或更新发布失败，会抛出异常

delete

void delete(Documents _documents,
            Channel _channel)
            throws WCMException
从指定频道上删除指定文档集合已发布的页面

参数：
_documents - 待删除的文档
_documents - 待删除的文档
抛出：
WCMException - 若当前用户无发布权限,或更新发布失败，会抛出异常

getMyTasks

PublishTasks getMyTasks(WCMFilter _filter)
                        throws WCMException
提取我的发布任务

参数：
_filter - 附加筛选条件
返回：
返回当前用户的发布任务集合
抛出：
WCMException - 若提取发布任务集合失败，会抛出异常

getAllTasks

PublishTasks getAllTasks(WCMFilter _filter)
                         throws WCMException
提取所有的发布任务；要求当前用户必须具有管理权限

参数：
_filter - 附加筛选条件
返回：
返回发布任务集合
抛出：
WCMException - 若用户没有管理权限，或提取发布任务集合失败，会抛出异常。

deleteTasks

void deleteTasks(java.lang.String _sTaskIds)
                 throws WCMException
抛出：
WCMException

redoTasks

void redoTasks(java.lang.String _sTaskIds)
               throws WCMException
重新执行指定的发布任务集合

参数：
_sTaskIds - TODO
_task - 待执行的发布任务集合
抛出：
WCMException - 若用户没有指定任务的管理权限，或重新执行发布任务失败，会抛出异常。

cancelTasks

void cancelTasks(java.lang.String _sTaskIds)
                 throws WCMException
取消指定的发布任务集合

参数：
_sTaskIds - 待取消的发布任务集合
抛出：
java.lang.Exception - 若用户没有指定任务的管理权限，或取消发布任务失败，会抛出异常。
WCMException

pauseTask

void pauseTask(java.lang.String _sTaskIds)
               throws WCMException
暂停指定的发布任务集合，对其中不处于执行状态的任务不会产生影响

参数：
_sTaskIds - 待暂停的发布任务集合
抛出：
java.lang.Exception - 若用户没有指定任务的管理权限，或暂停发布任务失败，会抛出异常。
WCMException

resumeTask

void resumeTask(java.lang.String _sTaskIds)
                throws WCMException
恢复指定的发布任务集合，对其中不处于暂停状态的任务不会产生影响

参数：
_sTaskIds - 待恢复的发布任务集合
抛出：
java.lang.Exception - 若用户没有指定任务的管理权限，或恢复发布任务失败，会抛出异常。
WCMException

getTaskRuntime

PublishTaskRuntime getTaskRuntime(int iTaskID)
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。

参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回其运行时对象PublishTaskRuntime， 否则返回 null。

getRunningTask

PublishTask getRunningTask(int iTaskID)
返回指定ID的正在执行的发布任务对象

参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回发布任务对象PublishTask， 否则返回 null。

getRunningTasks

java.util.Iterator getRunningTasks()
返回所有的正在执行的任务

返回：
所有的正在执行的任务

publishForcibly

void publishForcibly(int _nDocumentId,
                     java.lang.String _sChannelIds)
                     throws WCMException
强制在指定的频道中发布文档， 如果文档在指定的频道中状态为不允许发布状态，将会自动改为可发布的状态，然后再发不

参数：
_nDocumentId - 指定的文档ID
_sChannelIds - 指定的频道序列（如果不指定，那么将会触发所有引用文档的频道进行发布）
抛出：
WCMException

publishConfirm

void publishConfirm(BaseChannel _oSiteOrChnl,
                    java.lang.String _sSourceFile,
                    java.lang.String _sTargetFile,
                    java.lang.String _sBackupFile)
                    throws WCMException
确认（批准）发布 用于先将站点或频道的首页发布到一个临时文件，在确认没有错误后，再把临时文件重名为正式的站点或频道首页。 并把原来的正式的站点或频道首页（如果存在）重命名为备份文件名。

参数：
_oSiteOrChnl - 站点或者频道对象，不能为空。
_sSourceFile - 源文件名，即上面的临时文件名，不能为空。
_sTargetFile - 目标文件名，即站点或频道的正式首页。如果为空，则取系统配置的缺省值，一般是“index.html”。
_sBackupFile - 备份文件名。如果为空，则取系统配置的缺省值，一般是“index.html.bak”。
抛出：
WCMException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IRecentService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IRecentService

所有已知实现类：
RecentService
public interface IRecentService

Title: TRS 内容协作平台（TRS WCM）
Description:
为“最近处理的对象” 提供的服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | add(int _nObjType, int _nObjId) 添加最近访问的WCM对象
boolean | add(int _nObjType, java.lang.String _sObjIds) 添加最近访问的WCM对象
boolean | addChnlDoc(int _nChannelId, int _nDocumentId) 添加最近访问的ChnlDoc
Channels | getChannels(WCMFilter _aFilter) 返回用户最近访问的频道列表 按照访问的时间顺序排序
Channels | getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道列表 按照访问的时间顺序排序
Channels | getChannels(WCMFilter _filter, boolean _bIncludeDeleted, int _nRightIndex) 获取用户最近访问的频道集合,并校验访问指定权限.
Channels | getChannelsWithRight(WCMFilter _filter) 获取用户最近访问的频道集合,并校验访问权限.
ChnlDocs | getChnlDocs(WCMFilter _aFilter) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
ChnlDocs | getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
Documents | getDocuments(WCMFilter _aFilter) 返回用户最近访问的文档列表 由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
Documents | getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的文档列表 由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
java.lang.String | getIds(int _nObjTypeId) 根据对象的类型，得到最近访问的该对象的集合Ids
User | getLoginUser() 获得当前登录用户
Templates | getTemplates(WCMFilter _aFilter) 返回用户最近访问的模板列表 按照访问的时间顺序排序
WebSites | getWebSites(WCMFilter _aFilter) 返回用户最近访问的站点列表 按照访问的时间顺序排序

方法详细信息

getLoginUser

User getLoginUser()
获得当前登录用户

返回：
当前登录用户

add

boolean add(int _nObjType,
            java.lang.String _sObjIds)
            throws WCMException
添加最近访问的WCM对象

参数：
_nObjType - WCM对象TypeID
_sObjIds - 对象的具体ID序列，以逗号分隔，形如1,2,3,4
返回：
是否添加成功
抛出：
WCMException

add

boolean add(int _nObjType,
            int _nObjId)
            throws WCMException
添加最近访问的WCM对象

参数：
_nObjType - WCM对象TypeID
_nObjId - 该对象的具体ID
返回：
是否添加成功
抛出：
WCMException

addChnlDoc

boolean addChnlDoc(int _nChannelId,
                   int _nDocumentId)
                   throws WCMException
添加最近访问的ChnlDoc

参数：
_nChannelId - 频道Id
_nDocumentId - 文档Id
返回：
@throws WCMException 如果ChnlDoc没有找到或者频道、文档无效，则抛出异常
抛出：
WCMException

getIds

java.lang.String getIds(int _nObjTypeId)
                        throws WCMException
根据对象的类型，得到最近访问的该对象的集合Ids

参数：
_nObjTypeId - 欲查询的对象Id
返回：
“我”最近访问的对象Id列表，如果没有访问过这种对象，则返回NULL
抛出：
WCMException

getDocuments

Documents getDocuments(WCMFilter _aFilter)
                       throws WCMException
返回用户最近访问的文档列表
由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询

参数：
_aFilter - 用户指定的查询条件
返回：
按照访问时间降序排列的文档集合
抛出：
WCMException

getDocuments

Documents getDocuments(WCMFilter _aFilter,
                       boolean _bIncludeDeleted)
                       throws WCMException
返回用户最近访问的文档列表
由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询

参数：
_aFilter - 用户指定的查询条件
_bIncludeDeleted - true为包含已经删除的，false为不包含已经删除的
返回：
@throws WCMException
抛出：
WCMException

getChannels

Channels getChannels(WCMFilter _aFilter)
                     throws WCMException
返回用户最近访问的频道列表
按照访问的时间顺序排序

参数：
_aFilter - 用户指定的查询条件
返回：
按照访问时间降序排列的频道集合
抛出：
WCMException

getChannels

Channels getChannels(WCMFilter _aFilter,
                     boolean _bIncludeDeleted)
                     throws WCMException
返回用户最近访问的频道列表
按照访问的时间顺序排序

参数：
_aFilter - 用户指定的查询条件
_bIncludeDeleted - true为包含已删除的，false为不包含已删除的
返回：
按照访问时间降序排列的频道集合
抛出：
WCMException

getChannelsWithRight

Channels getChannelsWithRight(WCMFilter _filter)
                              throws WCMException
获取用户最近访问的频道集合,并校验访问权限.

参数：
_filter - 过滤器,额外的查询条件件
返回：
@throws WCMException
抛出：
WCMException

getChannels

Channels getChannels(WCMFilter _filter,
                     boolean _bIncludeDeleted,
                     int _nRightIndex)
                     throws WCMException
获取用户最近访问的频道集合,并校验访问指定权限.

参数：
_filter - 过滤器,额外的查询条件件
_bIncludeDeleted - 是否包含已删除的频道.
_nRightIndex - 指定的权限索引值.
返回：
@throws WCMException
抛出：
WCMException

getTemplates

Templates getTemplates(WCMFilter _aFilter)
                       throws WCMException
返回用户最近访问的模板列表
按照访问的时间顺序排序

参数：
_aFilter - 用户指定的查询条件
返回：
按照访问时间降序排列的模板集合
抛出：
WCMException

getWebSites

WebSites getWebSites(WCMFilter _aFilter)
                     throws WCMException
返回用户最近访问的站点列表
按照访问的时间顺序排序

参数：
_aFilter - 用户指定的查询条件
返回：
按照访问时间降序排列的站点集合
抛出：
WCMException

getChnlDocs

ChnlDocs getChnlDocs(WCMFilter _aFilter)
                     throws WCMException
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

参数：
_aFilter - 用户指定的查询条件
返回：
@throws WCMException
抛出：
WCMException

getChnlDocs

ChnlDocs getChnlDocs(WCMFilter _aFilter,
                     boolean _bIncludeDeleted)
                     throws WCMException
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

参数：
_aFilter - 用户指定的查询条件
_bIncludeDeleted - true为包括已删除的，false为不包括已删除的
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IResourceService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IResourceService

所有已知实现类：
ResouceService
public interface IResourceService

Title: TRS 内容协作平台（TRS WCM）
Description:
配置资源服务提供对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | delete(CMSObj _currObjToDelete) 删除资源配置
User | getLoginUser() 返回当前登录用户
CMSObj | save(CMSObj _currObjToSave) 保存资源配置

方法详细信息

getLoginUser

User getLoginUser()
返回当前登录用户

返回：

save

CMSObj save(CMSObj _currObjToSave)
            throws WCMException
保存资源配置

参数：
_currObjToSave - 要保存的对象
支持的对象: Source,Sercurity,Status,RightDef,EventType,OperType,Config ,TagBean
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(CMSObj _currObjToDelete)
               throws WCMException
删除资源配置

参数：
_currObjToDelete - 要删除的对象
支持的对象: Source,Sercurity,Status,RightDef,EventType,OperType,Config ,TagBean
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IRoleService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IRoleService

所有已知实现类：
RoleService
public interface IRoleService

Title: TRS 内容协作平台（TRS WCM）
Description:
角色相关服务提供对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
User | addUser(User _dstUser, Role _toRole) 添加指定的用户到指定的角色
boolean | delete(int _nDelRoleId) 根据Id删除指定的角色
boolean | delete(Role _roleToDelete) 删除指定的角色
boolean | delete(Roles _rolesToDelete) 删除指定的角色集合
boolean | delete(java.lang.String _sDelRoleIds) 根据Id序列删除多个角色
Users | getUsers(Role _dstRole, WCMFilter _filter) 获取指定角色的所有用户
boolean | removeUser(User _dstUser, Role _fromRole) 从指定的角色中删除指定的用户
Role | save(Role _roleToSave) 保存指定的角色
void | setRoleUsers(int _nDstRoleId, java.lang.String _sUserIdsToAdd)

方法详细信息

save

Role save(Role _roleToSave)
          throws WCMException
保存指定的角色

参数：
_roleToSave - 要保存的角色
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(Role _roleToDelete)
               throws WCMException
删除指定的角色

参数：
_roleToDelete - 需要删除的角色
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(int _nDelRoleId)
               throws WCMException
根据Id删除指定的角色

参数：
_nDelRoleId - 需要删除的角色Id
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(Roles _rolesToDelete)
               throws WCMException
删除指定的角色集合

参数：
_rolesToDelete - 要删除的角色集合
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(java.lang.String _sDelRoleIds)
               throws WCMException
根据Id序列删除多个角色

参数：
_sDelRoleIds - 指定的Id序列
返回：
@throws WCMException
抛出：
WCMException

addUser

User addUser(User _dstUser,
             Role _toRole)
             throws WCMException
添加指定的用户到指定的角色

参数：
_dstUser - 指定的要添加的用户
_toRole - 指定的角色
返回：
@throws WCMException
抛出：
WCMException

setRoleUsers

void setRoleUsers(int _nDstRoleId,
                  java.lang.String _sUserIdsToAdd)
                  throws WCMException
抛出：
WCMException

removeUser

boolean removeUser(User _dstUser,
                   Role _fromRole)
                   throws WCMException
从指定的角色中删除指定的用户

参数：
_dstUser - 指定要删除的用户
_toRole - 指定的角色
返回：
@throws WCMException
抛出：
WCMException

getUsers

Users getUsers(Role _dstRole,
               WCMFilter _filter)
               throws WCMException
获取指定角色的所有用户

参数：
_dstRole - 指定的角色
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IScheduleService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IScheduleService

所有已知实现类：
ScheduleService
public interface IScheduleService

Title: TRS 内容协作平台（TRS WCM）
Description:
计划调度服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
Schedule | deletePublishSchedule(BaseChannel _currChannel) 删除指定站点或频道的计划发布
Schedule | deletePublishSchedule(Document _currDocument) 删除指定文档的计划发布
Schedule | findPublishSchedule(BaseChannel _currChannel) 获取指定站点或频道的计划发布信息
Schedule | findPublishSchedule(Document _currDocument) 获取指定文档的计划发布信息
Schedule | savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel) 给指定的站点或频道设置计划发布属性
Schedule | savePublishSchedule(Schedule _currSchedule, Document _currDocument) 给指定的文档设置计划发布属性

方法详细信息

savePublishSchedule

Schedule savePublishSchedule(Schedule _currSchedule,
                             BaseChannel _currChannel)
                             throws WCMException
给指定的站点或频道设置计划发布属性

参数：
_currSchedule - 设置的计划内容（Schedule）
_currChannel - 设置的站点或频道对象（BaseChannel）
返回：
返回保存后的Schedule对象
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
保存信息时可能抛出异常

deletePublishSchedule

Schedule deletePublishSchedule(BaseChannel _currChannel)
                               throws WCMException
删除指定站点或频道的计划发布

参数：
_currChannel - 被删除计划发布的站点或发布
返回：
被删除后的计划发布对象
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
保存信息时可能抛出异常

findPublishSchedule

Schedule findPublishSchedule(BaseChannel _currChannel)
                             throws WCMException
获取指定站点或频道的计划发布信息

参数：
_currChannel - 指定的站点或频道对象（BaseChannel）
返回：
如果设置了计划发布，返回计划对象；否则返回null
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
获取信息时可能抛出异常

savePublishSchedule

Schedule savePublishSchedule(Schedule _currSchedule,
                             Document _currDocument)
                             throws WCMException
给指定的文档设置计划发布属性

参数：
_currSchedule - 设置的计划内容（Schedule）
_currDocument - 设置的文档对象（Document）
返回：
返回保存后的Schedule对象
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
保存信息时可能抛出异常

deletePublishSchedule

Schedule deletePublishSchedule(Document _currDocument)
                               throws WCMException
删除指定文档的计划发布

参数：
_currDocument - 被删除计划发布的站点或发布
返回：
被删除后的计划发布对象
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
保存信息时可能抛出异常

findPublishSchedule

Schedule findPublishSchedule(Document _currDocument)
                             throws WCMException
获取指定文档的计划发布信息

参数：
_currDocument - 指定的文档对象（Document）
返回：
如果设置了计划发布，返回计划对象；否则返回null
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
获取信息时可能抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ISecurityService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 ISecurityService

所有已知实现类：
SecurityService
public interface ISecurityService

作者：
Martin (Fu Chengrui) 密钥管理，以及加密、解密、签名、验证、摘要等操作的公共接口定义 函数返回值和异常的说明，所有的操作类型的函数（指不返回计算结果，只是执行某个动作的函数）都声明为要么操作成功，不返回任何内容，要么操作失败抛出异常 ， 而不是返回 boolean 类型的结果。所有可能抛出的异常，都使用 WCMException 进行封装，但是原始异常信息不应该被丢失。 先期必须要实现的有：getKeys()、saveKey()、sign()和verify()四个函数，其他可以暂时不实现。

方法摘要
byte[] | decrypt(java.lang.String sKeyName, byte[] bytes) 使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。
void | deleteKey(int _toDeleteId) 删除指定ID的密钥
void | deleteKey(java.lang.String _toDeleteIds) 删除指定ID的密钥 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经被删除的密钥不会回滚。
void | deleteKeyByName(java.lang.String _toDeleteName) 删除指定名称（名称：一般是密钥的用途）的密钥
byte[] | digest(java.lang.String sAlgorithm, byte[] data) 使用指定的算法计算指定数据的摘要
void | doDecrypt(java.lang.String sKeyName, java.io.InputStream is, java.io.OutputStream os) 使用指定名称的密钥，解密指定的输入流中的数据，并将明文写入指定的输出流。
byte[] | doDigest(java.lang.String sAlgorithm, java.io.InputStream is) 使用指定的算法计算指定数据源（输入流）的摘要
void | doEncrypt(java.lang.String sKeyName, java.io.InputStream is, java.io.OutputStream os) 使用指定名称的密钥，加密指定的输入流中的数据，并将密文写入指定的输出流。
byte[] | doSign(java.lang.String sKeyName, java.io.InputStream is) 使用指定名称的密钥计算指定的数据源的签名
boolean | doVerify(java.lang.String sKeyName, java.io.InputStream is, byte[] sign) 使用指定名称的密钥，验证指定数据源和签名是否相符
byte[] | encrypt(java.lang.String sKeyName, byte[] bytes) 使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。
java.lang.String | exportKey(boolean _zIsPrivate, int iKeyId) 导出指定的密钥
java.lang.String | exportKey(boolean _zIsPrivate, java.lang.String sKeyName) 导出指定的密钥
byte[] | exportKey(int _toExportId, boolean _zIsPrivate) 导出指定ID的密钥的原始数据
byte[] | exportKey(java.lang.String _toExportName, boolean _zIsPrivate) 导出指定名称的密钥的原始数据
void | exportKey(java.lang.String _toExportIds, java.io.Writer _writer) 以XML文件的形式导出指定的密钥
void | exportKey(java.io.Writer _writer) 以XML文件的形式导出系统内的全部密钥
java.util.List | extractKey(java.io.File _oXMLFile, java.lang.String _encoding) 从指定的XML文件中抽取全部可用的密钥
java.util.List | extractKey(java.io.Reader _oXMLReader) 从指定的XML文件输出流中抽取全部可用的密钥
SecureKey | findKey(int _iKeyId) 在系统内查找指定ID的密钥
SecureKey | findKey(java.lang.String _iKeyName) 在系统内查找指定名称的密钥
SecureKeys | getKeys(WCMFilter _filter) 获取当前系统中符合条件的密钥的集合
void | saveKey(SecureKey _oKey) 保存指定的密钥
byte[] | sign(java.lang.String sKeyName, byte[] data) 使用指定名称的密钥计算指定的数据的签名
boolean | verify(java.lang.String sKeyName, byte[] data, byte[] sign) 使用指定名称的密钥，验证指定数据和签名是否相符

方法详细信息

deleteKey

void deleteKey(int _toDeleteId)
               throws WCMException
删除指定ID的密钥

参数：
_toDeleteId - 待删除密钥的ID
抛出：
WCMException - 如果操作失败

deleteKey

void deleteKey(java.lang.String _toDeleteIds)
               throws WCMException
删除指定ID的密钥 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经被删除的密钥不会回滚。

参数：
_toDeleteIds - 待删除密钥的ID列表，形如2,3,5,13
抛出：
WCMException - 如果操作失败

deleteKeyByName

void deleteKeyByName(java.lang.String _toDeleteName)
                     throws WCMException
删除指定名称（名称：一般是密钥的用途）的密钥

参数：
_toDeleteName - 待删除密钥的名称
抛出：
WCMException - 如果操作失败

exportKey

byte[] exportKey(int _toExportId,
                 boolean _zIsPrivate)
                 throws WCMException
导出指定ID的密钥的原始数据

参数：
_toExportId - 待导出密钥的ID
_zIsPrivate - 是否导出私钥。如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
返回：
密钥的原始数据
抛出：
WCMException - 如果操作失败

exportKey

byte[] exportKey(java.lang.String _toExportName,
                 boolean _zIsPrivate)
                 throws WCMException
导出指定名称的密钥的原始数据

参数：
_toExportName - 待导出密钥的名称
_zIsPrivate - 是否导出私钥。如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
返回：
密钥的原始数据
抛出：
WCMException - 如果操作失败

exportKey

void exportKey(java.lang.String _toExportIds,
               java.io.Writer _writer)
               throws WCMException
以XML文件的形式导出指定的密钥

参数：
_toExportIds - 需要导出的密钥ID列表，形如2,3,5,13
_writer - 目标XML文件输出流
抛出：
WCMException - 如果操作失败

exportKey

void exportKey(java.io.Writer _writer)
               throws WCMException
以XML文件的形式导出系统内的全部密钥

参数：
_writer - 目标XML文件输出流
抛出：
WCMException - 如果操作失败

extractKey

java.util.List extractKey(java.io.Reader _oXMLReader)
                          throws WCMException
从指定的XML文件输出流中抽取全部可用的密钥

参数：
_oXMLReader - 指定的输入流
返回：
输入流中有效密钥的集合
抛出：
WCMException

extractKey

java.util.List extractKey(java.io.File _oXMLFile,
                          java.lang.String _encoding)
                          throws WCMException
从指定的XML文件中抽取全部可用的密钥

参数：
_oXMLFile - 指定的XML文件
_encoding - 指定的XML文件的编码方式
返回：
XML文件中有效密钥的集合
抛出：
WCMException

findKey

SecureKey findKey(int _iKeyId)
                  throws WCMException
在系统内查找指定ID的密钥

参数：
_iKeyId - 密钥的ID
返回：
指定ID的密钥
抛出：
WCMException - 如果操作失败

findKey

SecureKey findKey(java.lang.String _iKeyName)
                  throws WCMException
在系统内查找指定名称的密钥

参数：
_iKeyName - 密钥的名称
返回：
指定名称的密钥
抛出：
WCMException - 如果操作失败

getKeys

SecureKeys getKeys(WCMFilter _filter)
                   throws WCMException
获取当前系统中符合条件的密钥的集合

参数：
_filter -
返回：
过滤器，可选的查询条件，可以为 null
抛出：
WCMException - 如果操作失败

saveKey

void saveKey(SecureKey _oKey)
             throws WCMException
保存指定的密钥

参数：
_oKey - 待保存的密钥
抛出：
WCMException - 如果操作失败

encrypt

byte[] encrypt(java.lang.String sKeyName,
               byte[] bytes)
               throws WCMException
使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。

参数：
sKeyName - 密钥的名称
bytes - 待加密的数据
返回：
密文数据
抛出：
WCMException - 如果发生错误

doEncrypt

void doEncrypt(java.lang.String sKeyName,
               java.io.InputStream is,
               java.io.OutputStream os)
               throws WCMException
使用指定名称的密钥，加密指定的输入流中的数据，并将密文写入指定的输出流。 如果指定的密钥是对称密钥，则一定使用公钥进行加密。

参数：
sKeyName - 密钥的名称
is - 待加密的数据源
os - 密文输出流
抛出：
WCMException - 如果发生错误

decrypt

byte[] decrypt(java.lang.String sKeyName,
               byte[] bytes)
               throws WCMException
使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。

参数：
sKeyName - 密钥的名称
bytes - 待解密的密文数据
返回：
明文数据
抛出：
WCMException - 如果发生错误

doDecrypt

void doDecrypt(java.lang.String sKeyName,
               java.io.InputStream is,
               java.io.OutputStream os)
               throws WCMException
使用指定名称的密钥，解密指定的输入流中的数据，并将明文写入指定的输出流。 如果指定的密钥是对称密钥，则一定使用私钥进行解密。

参数：
sKeyName - 密钥的名称
is - 待解密的数据源
os - 明文输出流
抛出：
WCMException - 如果发生错误

sign

byte[] sign(java.lang.String sKeyName,
            byte[] data)
            throws WCMException
使用指定名称的密钥计算指定的数据的签名

参数：
sKeyName - 密钥的名称
data - 待签名数据
返回：
签名数据
抛出：
WCMException - 如果发生错误

doSign

byte[] doSign(java.lang.String sKeyName,
              java.io.InputStream is)
              throws WCMException
使用指定名称的密钥计算指定的数据源的签名

参数：
sKeyName - 密钥的名称
is - 待签名的数据源
返回：
签名数据
抛出：
WCMException - 如果发生错误

verify

boolean verify(java.lang.String sKeyName,
               byte[] data,
               byte[] sign)
               throws WCMException
使用指定名称的密钥，验证指定数据和签名是否相符

参数：
sKeyName - 密钥的名称
data - 待验证的数据
sign - 签名数据
返回：
如果签名相符，返回 true ，否则返回 false
抛出：
WCMException - 如果发生错误

doVerify

boolean doVerify(java.lang.String sKeyName,
                 java.io.InputStream is,
                 byte[] sign)
                 throws WCMException
使用指定名称的密钥，验证指定数据源和签名是否相符

参数：
sKeyName - 密钥的名称
is - 待验证的数据源
sign - 签名数据
返回：
如果签名相符，返回 true ，否则返回 false
抛出：
WCMException - 如果发生错误

digest

byte[] digest(java.lang.String sAlgorithm,
              byte[] data)
              throws WCMException
使用指定的算法计算指定数据的摘要

参数：
sAlgorithm - 摘要算法的名称，如果为 null ，则默认使用MD5
data - 原始数据
返回：
摘要计算结果
抛出：
WCMException - 如果发生错误

doDigest

byte[] doDigest(java.lang.String sAlgorithm,
                java.io.InputStream is)
                throws WCMException
使用指定的算法计算指定数据源（输入流）的摘要

参数：
sAlgorithm - 摘要算法的名称，如果为 null ，则默认使用MD5
is - 数据源
返回：
摘要计算结果
抛出：
WCMException - 如果发生错误

exportKey

java.lang.String exportKey(boolean _zIsPrivate,
                           java.lang.String sKeyName)
                           throws WCMException
导出指定的密钥

参数：
_zIsPrivate - 是否导出私钥。 如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
sKeyName - 指定的密钥名称
返回：
导出的文件名(符合WCM规范)
抛出：
WCMException

exportKey

java.lang.String exportKey(boolean _zIsPrivate,
                           int iKeyId)
                           throws WCMException
导出指定的密钥

参数：
_zIsPrivate - 是否导出私钥。 如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
sKeyName - 指定的密钥Id
返回：
导出的文件名(符合WCM规范)
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ISOAPService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 ISOAPService

所有已知实现类：
SOAPServiceImpl
public interface ISOAPService

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String | getAllChannelXML() 返回系统的站点和频道的所有信息
java.lang.String | getChannelChildrenXML(int _nSiteId, int _nChannelId, boolean _bAllChildren) 获取指定站点指定频道的配置信息
java.lang.String | getChannelXML(int _nChannelId) 获取指定频道的信息
int | getMajorVersion() 获取当前SOAP服务的版本
java.lang.String | getSiteXML(int _nSiteId) 获取指定站点的信息
java.lang.String | importDocuments(byte[] _pImportFileContent, java.lang.String _sFileExt) 从指定文件中导入文档集合
java.lang.String | sendFileBase64(java.lang.String strData, java.lang.String Server, java.lang.String fileExt) 上传指定的文件
java.lang.String | uploadFile(byte[] _pUploadFileContent, java.lang.String _sFileExt, boolean _bOnlyReturnFileName) 上传指定的文件

方法详细信息

getAllChannelXML

java.lang.String getAllChannelXML()
返回系统的站点和频道的所有信息

返回：
标准WCM XML字符串

getChannelChildrenXML

java.lang.String getChannelChildrenXML(int _nSiteId,
                                       int _nChannelId,
                                       boolean _bAllChildren)
获取指定站点指定频道的配置信息

参数：
_nSiteId - 指定站点ID
_nChannelId - 指定频道ID
_bAllChildren - 是否获取所有的子频道（false:表示只获取当前一级子频道列表 true:表示获取所有子频道列表）
返回：
标准的WCM XML字符串

getChannelXML

java.lang.String getChannelXML(int _nChannelId)
获取指定频道的信息

参数：
_nChannelId - 指定的频道ID
返回：
标准的WCM XML字符串

getSiteXML

java.lang.String getSiteXML(int _nSiteId)
获取指定站点的信息

参数：
_nSiteId - 指定的站点ID
返回：
标准的WCM XML字符串

importDocuments

java.lang.String importDocuments(byte[] _pImportFileContent,
                                 java.lang.String _sFileExt)
从指定文件中导入文档集合

参数：
_pImportFileContent - 需要导入的文件内容，为byte数组（不需要编码）
_sFileExt - 文件后缀名（默认为ZIP）
返回：
以XML形式组织的返回信息，如果失败也返回相同结构的信息，只是内容不一样

uploadFile

java.lang.String uploadFile(byte[] _pUploadFileContent,
                            java.lang.String _sFileExt,
                            boolean _bOnlyReturnFileName)
上传指定的文件

参数：
_pUploadFileContent - 文件内容
_sFileExt - 文件后缀
_bOnlyReturnFileName - TODO
返回：

sendFileBase64

java.lang.String sendFileBase64(java.lang.String strData,
                                java.lang.String Server,
                                java.lang.String fileExt)
上传指定的文件

参数：
strData - Base64编码的文件内容
Server - 服务器地址
fileExt - 文件后缀名
返回：

getMajorVersion

int getMajorVersion()
获取当前SOAP服务的版本

返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IStatService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IStatService

所有已知实现类：
StatService
public interface IStatService

Title: TRS 内容协作平台（TRS WCM）
Description:
统计应用相关的服务接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | clearStatResult(int _nStatViewId) 清除特定统计视图对应临时表中的数据 只有模板类视图才有临时表
Reports | deleteStatHosts(java.lang.String _sDelStatHostIds) 删除统计类型
Reports | deleteStatView(int _nStatViewId) 删除一个统计视图
Reports | deleteStatView(StatView _delStatView) 删除一个统计视图
Reports | deleteStatViews(java.lang.String _sStatViewIds) 删除一个统计视图
StatView | findStatViewByName(java.lang.String _sName) 获取指定名称的统计视图.
void | generateTodayStat(int _nStatTempId) 产生特定统计模板当天的统计数据 统计数据记录在统计表中
CMyResultSets | getCurrentStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 统计在一个时间段内，符合特定条件的某个统计的结果 对数据库进行实时统计，而不是从统计临时表中取
StatViews | getEmbeddedViews(int _nMainViewId) 得到一个模板类视图的所有子视图（嵌入式）
StatFieldMaps | getStatFieldsByView(int _nStatViewId) 得到一个统计视图模板中的字段映射表（字段列表） 从统计映射表中获取，而不是从Select中自动识别
StatHosts | getStatHosts(WCMFilter _filter) 获得系统中提供的所有统计主体
CMyResultSets | getStatResult(int _nStatTempId) 获得一个统计模板对应的所有结果
CMyResultSets | getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate) 统计在一个时间段内，某个统计的结果
CMyResultSets | getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 统计在一个时间段内，符合特定条件的某个统计的结果
CMyResultSets | getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)
CMyResultSets | getStatResult(java.lang.String _sqlStat, java.lang.String _sId) 进行用户定制的统计并返回统计结果
StatViews | getStatViews(java.lang.String _sStatHostName, int _StatViewType, WCMFilter _filter) 获得特定查询主体的统计视图模板
StatHost | saveStatHost(StatHost _currStatHost) 保存统计主体（即按xxx查询）
StatView | saveStatView(StatView _currStatView, java.util.List _fieldMapList) 保存统计视图模板 其中包括保存视图模板和字段列表
void | setStatViewRelation(int _nMainViewId, java.lang.String _sEmbeddedViewIds) 设置模板视图和嵌入视图的关联关系
void | setStatViewRelation(StatView _mainView, StatViews _embeddedViews) 设置模板视图和嵌入视图的关联关系
boolean | testStatView(int _nStatViewId) 测试特定的统计模板是否能够运行通过

方法详细信息

getStatViews

StatViews getStatViews(java.lang.String _sStatHostName,
                       int _StatViewType,
                       WCMFilter _filter)
                       throws WCMException
获得特定查询主体的统计视图模板

参数：
_sStatHostName - 统计主体的名称，如CHANNEL
_StatViewType - 统计视图模板类型，由常量维护，在StatView中，Type_All表示所有类型
_filter -
返回：
@throws WCMException
抛出：
WCMException

getStatHosts

StatHosts getStatHosts(WCMFilter _filter)
                       throws WCMException
获得系统中提供的所有统计主体

参数：
_filter - 查询条件
返回：
统计主体集合
抛出：
WCMException

getStatFieldsByView

StatFieldMaps getStatFieldsByView(int _nStatViewId)
                                  throws WCMException
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别

参数：
_nStatViewId - 统计视图模板Id
返回：
统计模板中的字段映射表
抛出：
WCMException

getStatResult

CMyResultSets getStatResult(int _nStatTempId)
                            throws WCMException
获得一个统计模板对应的所有结果

参数：
_nStatTempId - 统计模板Id
返回：
统计结果集合
抛出：
WCMException

getStatResult

CMyResultSets getStatResult(int _nStatTempId,
                            CMyDateTime _fromDate,
                            CMyDateTime _toDate)
                            throws WCMException
统计在一个时间段内，某个统计的结果

参数：
_nStatTempId - 统计模板Id
_fromDate - 统计开始时间，如果为null，则表示包括所有结束之前的统计数据
_toDate - 统计结束时间，如果为null，则表示包含所有开始之后的统计诗句
返回：
统计结果集合
抛出：
WCMException

getStatResult

CMyResultSets getStatResult(int _nStatTempId,
                            CMyDateTime _fromDate,
                            CMyDateTime _toDate,
                            java.lang.String _sqlWhere)
                            throws WCMException
统计在一个时间段内，符合特定条件的某个统计的结果

参数：
_nStatTempId - 统计模板Id
_fromDate - 统计开始时间，如果为null，则表示包括所有结束之前的统计数据
_toDate - 统计结束时间，如果为null，则表示包含所有开始之后的统计诗句
_sqlWhere - 附加的条件，比如名称为xx。或者数字小于多少的，等等。如果为null则表示没有附加查询条件
附件的条件不需要加AND
返回：
统计结果集合
抛出：
WCMException

getStatResult

CMyResultSets getStatResult(int _nStatTempId,
                            CMyDateTime _fromDate,
                            CMyDateTime _toDate,
                            java.lang.String _sqlWhere,
                            java.lang.String _sqlOrderBy)
                            throws WCMException
抛出：
WCMException

getCurrentStatResult

CMyResultSets getCurrentStatResult(int _nStatTempId,
                                   CMyDateTime _fromDate,
                                   CMyDateTime _toDate,
                                   java.lang.String _sqlWhere)
                                   throws WCMException
统计在一个时间段内，符合特定条件的某个统计的结果
对数据库进行实时统计，而不是从统计临时表中取

参数：
_nStatTempId - 统计模板Id
_fromDate - 统计开始时间，如果为null，则表示包括所有结束之前的统计数据
_toDate - 统计结束时间，如果为null，则表示包含所有开始之后的统计诗句
_sqlWhere - 附加的条件，比如名称为xx。或者数字小于多少的，等等。如果为null则表示没有附加查询条件
附件的条件不需要加AND
返回：
统计结果集合
抛出：
WCMException

getStatResult

CMyResultSets getStatResult(java.lang.String _sqlStat,
                            java.lang.String _sId)
                            throws WCMException
进行用户定制的统计并返回统计结果

参数：
_sqlStat - 用户定制的统计语句，完整的SQL
返回：
统计结果集合
抛出：
WCMException

testStatView

boolean testStatView(int _nStatViewId)
                     throws WCMException
测试特定的统计模板是否能够运行通过

参数：
_nStatViewId - 统计模板Id
返回：
true为测试通过，否则抛出异常
抛出：
WCMException - 测试不通过

generateTodayStat

void generateTodayStat(int _nStatTempId)
                       throws WCMException
产生特定统计模板当天的统计数据
统计数据记录在统计表中

参数：
_nStatTempId - 统计模板Id
抛出：
WCMException

saveStatView

StatView saveStatView(StatView _currStatView,
                      java.util.List _fieldMapList)
                      throws WCMException
保存统计视图模板
其中包括保存视图模板和字段列表

参数：
_currStatView - 统计视图模板
_fieldMapList - 视图字段映射表
返回：
@throws WCMException VIEWNAME、VIEWTYPE、STATHOST、TIMEFIELD、SELECT、FROM 、字段列表不能为空，且必须有效否则抛出异常
只有管理员有权限
抛出：
WCMException

saveStatHost

StatHost saveStatHost(StatHost _currStatHost)
                      throws WCMException
保存统计主体（即按xxx查询）

参数：
_currStatHost - 统计主体
返回：
@throws WCMException
抛出：
WCMException

deleteStatView

Reports deleteStatView(int _nStatViewId)
                       throws WCMException
删除一个统计视图

参数：
_nStatViewId - 欲删除的统计视图Id
返回：
TODO
抛出：
WCMException

deleteStatViews

Reports deleteStatViews(java.lang.String _sStatViewIds)
                        throws WCMException
删除一个统计视图

参数：
_nStatViewId - 欲删除的统计视图Id
返回：
TODO
抛出：
WCMException

deleteStatView

Reports deleteStatView(StatView _delStatView)
                       throws WCMException
删除一个统计视图

参数：
_delStatView - 欲删除的统计视图
返回：
TODO
抛出：
WCMException

setStatViewRelation

void setStatViewRelation(int _nMainViewId,
                         java.lang.String _sEmbeddedViewIds)
                         throws WCMException
设置模板视图和嵌入视图的关联关系

参数：
_nMainViewId - 模板视图Id
_sEmbeddedViewIds - 嵌入视图Ids
抛出：
WCMException

setStatViewRelation

void setStatViewRelation(StatView _mainView,
                         StatViews _embeddedViews)
                         throws WCMException
设置模板视图和嵌入视图的关联关系

参数：
_mainView - 模板视图
_embeddedViews - 嵌入视图集合
抛出：
WCMException

getEmbeddedViews

StatViews getEmbeddedViews(int _nMainViewId)
                           throws WCMException
得到一个模板类视图的所有子视图（嵌入式）

参数：
_nMainViewId - 主视图Id
返回：
嵌入视图集合
抛出：
WCMException

clearStatResult

void clearStatResult(int _nStatViewId)
                     throws WCMException
清除特定统计视图对应临时表中的数据
只有模板类视图才有临时表

参数：
_nStatViewId - 统计视图
抛出：
WCMException

deleteStatHosts

Reports deleteStatHosts(java.lang.String _sDelStatHostIds)
                        throws WCMException
删除统计类型

参数：
_sDelStatHostIds - 被删除的统计主体的Id
抛出：
WCMException

findStatViewByName

StatView findStatViewByName(java.lang.String _sName)
                            throws WCMException
获取指定名称的统计视图.

参数：
_sName - 指定的视图名称.
返回：
如果没有找到则返回 null.
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ISureformService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 ISureformService

所有已知实现类：
SureformService
public interface ISureformService

Title: TRS 内容协作平台（TRS WCM）
Description:
书生表单服务层
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | distributeSureformFile(int _nChannelId) 将频道配置的书生表单发布到Web服务器上
Appendix | makeAppendix(java.lang.String _sFormFile) 根据书生表单数据，构造一个文档附件 规则是先将数据打包成为一个在WebPic下的文件，然后做成附件并构造List返回 注意返回后，需要将DocId设置上，否则保存附件时会报错

方法详细信息

makeAppendix

Appendix makeAppendix(java.lang.String _sFormFile)
                      throws WCMException
根据书生表单数据，构造一个文档附件
规则是先将数据打包成为一个在WebPic下的文件，然后做成附件并构造List返回
注意返回后，需要将DocId设置上，否则保存附件时会报错

参数：
_sFormFile - 本地可以访问的书生文件
返回：
构造的新建附件
抛出：
WCMException - 无法构造书生表单数据则抛错

distributeSureformFile

void distributeSureformFile(int _nChannelId)
                            throws WCMException
将频道配置的书生表单发布到Web服务器上

参数：
_nChannelId - 频道Id
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ITemplateParseService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 ITemplateParseService

所有已知实现类：
TemplateParseService
public interface ITemplateParseService

Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板解析接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 Report checkTemplate(Template _aTemplate)
解析模板语法

方法详细信息

checkTemplate

Report checkTemplate(Template _aTemplate)
解析模板语法

参数：
_aTemplate -
返回：
模板语法解析结果
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ITemplateService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 ITemplateService

所有已知实现类：
TemplateService
public interface ITemplateService

Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板管理的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | delete(int _nDelTemplateId) 根据模板ID彻底删除模板
boolean | delete(java.lang.String _sDelTemplateIds) 根据模板Id列表彻底删除模板
boolean | delete(Template _currTemplateToDelete) 彻底删除模板
boolean | delete(Templates _currTemplatesToDelete) 彻底删除模板集合
boolean | deleteTemplateArgument(TemplateArgument _argument) 删除指定的TemplateArgument对象
void | deleteTemplateArguments(TemplateArguments _arguments) 删除指定的TemplateArguments对象集合
java.lang.String | export(int _nTemplateId) 根据Id导出模板到临时目录的文件中
java.lang.String | export(java.lang.String _sTemplateIds) 根据模板的Id列表导出模板集合到临时目录的文件中
java.lang.String | export(Template _currTemplate) 导出模板到固定的文件中
java.lang.String | export(Templates _currTemplates) 导出模板集合到临时目录的文件中
java.lang.String[] | extractTemplateNamesFromZip(java.lang.String _sZipFileName) 得到导入文件中可能的模板文件名列表
Template | findByName(int _nSiteId, java.lang.String _sTempName) 根据指定的SiteId，找到指定名称的模板
Template | getDetailTemplate(IPublishElement _publishElement) 获得指定频道的细览模板
Templates | getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) 获取站点/频道下管理的模板集合
Templates | getNestedTemplates(Template _currTemplate) 获取当前模板中使用到的嵌套模板
Templates | getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseParent) 获取指定Folder中可选的模板集合
Templates | getOutlineTemplates(IPublishFolder _folder) 获得指定频道的概览模板
TemplateArguments | getTemplateArguments(IPublishElement _element) 返回指定发布对象上的全部有效模板参数列表
java.util.List | getTemplateEmployers(Template _currTemplate) 获取使用到当前模板的所有对象集合
java.util.List | getTemplateEmployers(Template _currTemplate, int _nEmployerType) 获取使用到当前模板的指定类型的对象集合
TemplateParameterList | getTemplateParameters(IPublishElement _element) 返回指定发布对象使用的所有模板中的全部形式参数列表
TemplateParameterList | getTemplateParameters(IPublishElement _element, boolean zRecursion) 返回指定发布对象使用的所有模板中的全部形式参数列表
Templates | getTemplatesNested(Template _currTemplate) 获取嵌套了当前模板的所有模板
Reports | importFromHTML(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName) 从html文件导入模板
Reports | importFromZip(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected) 从zip文件中导入模板
java.lang.String | preview(int _nTemplateId) 预览指定id的模板
java.lang.String | preview(Template _currTemplate) 预览指定的模板
Reports | redistributeAppendixes(CMSObj _chnlOrSite, boolean _zRecursive) 重新分发指定站点或者频道下的所有模板的附件，并且如果_zRecursive 为true ，则会进一步地重新分发子频道下的模板的附件。
Template | save(Template _currTemplateToSave) 保存模板，包括新增和修改，此接口一般用于从源代码方式下保存模板
Template | save(Template _currTemplateToSave, boolean _bDowithAppendix, int _nPicMode) 保存模板，包括新增和修改
TemplateArgument | saveTemplateArgument(TemplateArgument _argument) 保存指定的TemplateArgument对象
void | setDetailTemplate(IPublishContent _content, int _nTemplateId)
void | setDetailTemplate(IPublishContent _content, int _nTemplateId, int _nDetailTemplateType) 为指定文档设定模板
void | setDetailTemplate(IPublishFolder _folder, int _nTemplateId, boolean _bResetChildren) 为指定频道设定细览模板
void | setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren) 为指定频道设定概览模板

方法详细信息

save

Template save(Template _currTemplateToSave,
              boolean _bDowithAppendix,
              int _nPicMode)
              throws WCMException
保存模板，包括新增和修改

参数：
_currTemplateToSave - 待保存的模板
_bDowithAppendix - 是否处理附件，不处理表示不分析模板中可能的资源文件的地址（图片、CSS、js）
_nPicMode - 模板中图片重名后的处理方法，4种，参见WCMTypes.TEMPLATEAPD_xxxx
返回：
保存后的模板
抛出：
WCMException

save

Template save(Template _currTemplateToSave)
              throws WCMException
保存模板，包括新增和修改，此接口一般用于从源代码方式下保存模板

参数：
_currTemplateToSave - 待保存的模板
返回：
保存后的模板
抛出：
WCMException

delete

boolean delete(java.lang.String _sDelTemplateIds)
               throws WCMException
根据模板Id列表彻底删除模板

参数：
_sDelTemplateIds - 待删除的模板Id列表，形如2,3,5,13
返回：
操作是否成功
抛出：
WCMException

delete

boolean delete(Templates _currTemplatesToDelete)
               throws WCMException
彻底删除模板集合

参数：
_currTemplatesToDelete - 待删除的模板集合
返回：
操作是否成功，如果中间有一个模板没有删除成功，则立刻抛出异常，中止删除
抛出：
WCMException

delete

boolean delete(int _nDelTemplateId)
               throws WCMException
根据模板ID彻底删除模板

参数：
_nDelTemplateId - 待删除的模板Id
返回：
操作是否成功
抛出：
WCMException

delete

boolean delete(Template _currTemplateToDelete)
               throws WCMException
彻底删除模板

参数：
_currTemplateToDelete - 待删除的模板
返回：
操作是否成功
抛出：
WCMException

export

java.lang.String export(java.lang.String _sTemplateIds)
                        throws WCMException
根据模板的Id列表导出模板集合到临时目录的文件中

参数：
_sTemplateIds - 模板的Id列表
返回：
导出的文件名（不含路径，应是一个临时目录）
抛出：
WCMException

export

java.lang.String export(Templates _currTemplates)
                        throws WCMException
导出模板集合到临时目录的文件中

参数：
_currTemplates - 待导出的模板集合
返回：
导出的文件名（不含路径，应是一个临时目录）
抛出：
WCMException
WCMException

export

java.lang.String export(int _nTemplateId)
                        throws WCMException
根据Id导出模板到临时目录的文件中

参数：
_nTemplateId - 待导出的模板Id
返回：
导出的文件名（不含路径，应是一个临时目录）
抛出：
WCMException
WCMException

export

java.lang.String export(Template _currTemplate)
                        throws WCMException
导出模板到固定的文件中

参数：
_currTemplate - 待导出的模板
返回：
导出的文件名（不含路径，应是一个临时目录）
抛出：
WCMException
WCMException

importFromZip

Reports importFromZip(CMSObj _siteOrChannel,
                      java.lang.String _sFileName,
                      int _nImportMode,
                      int _nPicMode,
                      java.lang.String[] _arSelected)
                      throws WCMException
从zip文件中导入模板

参数：
_siteOrChannel - 站点/频道对象
_sFileName - 文件名(规则的WCM文件名)
_nImportMode - 模板导入模式,模板重名的处理方式(WCMTypes.TEMPLATE_DEAL_MODE_UPDATE等)
_nPicMode - 模板附件导入模式,附件重名的处理方式(WCMTypes.TEMPLATEAPD_DEAL_MODE_UPDATE等)
_arSelected - 用户已经选择的是模板的文件的列表
返回：
导入成功的模板名
抛出：
WCMException

importFromHTML

Reports importFromHTML(CMSObj _siteOrChannel,
                       java.lang.String _sFileName,
                       int _nImportMode,
                       java.lang.String _sSrcName)
                       throws WCMException
从html文件导入模板

参数：
_siteOrChannel - 站点/频道对象
_sFileName - 文件名(WCM规则的文件名)
_nImportMode - 模板导入模式,模板重名的处理方式(WCMTypes.TEMPLATE_DEAL_MODE_UPDATE等)
_sSrcName - 模板原文件名(模板的入库文件名)
返回：
抛出：
WCMException

extractTemplateNamesFromZip

java.lang.String[] extractTemplateNamesFromZip(java.lang.String _sZipFileName)
                                               throws WCMException
得到导入文件中可能的模板文件名列表

参数：
_sZipFileName - 待导入的模板文件，为ZIP格式
返回：
可能存在的模板名称列表
抛出：
WCMException

redistributeAppendixes

Reports redistributeAppendixes(CMSObj _chnlOrSite,
                               boolean _zRecursive)
                               throws WCMException
重新分发指定站点或者频道下的所有模板的附件，并且如果_zRecursive 为true ，则会进一步地重新分发子频道下的模板的附件。

参数：
_chnlOrSite - 站点或者频道
_zRecursive - 是否递归子频道
返回：
执行结果
抛出：
WCMException - 如果发生异常

preview

java.lang.String preview(int _nTemplateId)
                         throws WCMException
预览指定id的模板

参数：
_nTemplateId - 指定的模板Id
返回：
模板的内容
抛出：
WCMException

preview

java.lang.String preview(Template _currTemplate)
                         throws WCMException
预览指定的模板

参数：
_currTemplate - 指定的模板
返回：
模板的内容
抛出：
WCMException

getDetailTemplate

Template getDetailTemplate(IPublishElement _publishElement)
                           throws WCMException
获得指定频道的细览模板

参数：
_publishElement - a channel
返回：
细览模板，如果没有细览模板则返回null
抛出：
WCMException

getOutlineTemplates

Templates getOutlineTemplates(IPublishFolder _folder)
                              throws WCMException
获得指定频道的概览模板

参数：
_folder - channel or site
返回：
概览模板，如果没有概览模板则返回null
抛出：
WCMException

setDetailTemplate

void setDetailTemplate(IPublishFolder _folder,
                       int _nTemplateId,
                       boolean _bResetChildren)
                       throws WCMException
为指定频道设定细览模板

参数：
_folder -
_nTemplateId -
_bResetChildren - 是否重设子频道的细览模板
如果为 true,则重设
抛出：
WCMException

setOutlineTemplates

void setOutlineTemplates(IPublishFolder _folder,
                         java.lang.String _sTemplateIds,
                         boolean _bResetChildren)
                         throws WCMException
为指定频道设定概览模板

参数：
_folder -
_sTemplateIds - 模板ID列表；其中第一个为默认的概览模板。
_bResetChildren - 是否重设子频道的概览模板
如果为 true,则重设
抛出：
WCMException

setDetailTemplate

void setDetailTemplate(IPublishContent _content,
                       int _nTemplateId,
                       int _nDetailTemplateType)
                       throws WCMException
为指定文档设定模板

参数：
_content -
_nTemplateId -
_nDetailTemplateType -
抛出：
WCMException

setDetailTemplate

void setDetailTemplate(IPublishContent _content,
                       int _nTemplateId)
                       throws WCMException
抛出：
WCMException

getManagedTemplates

Templates getManagedTemplates(CMSObj _channelOrSite,
                              int _nTemplateType,
                              WCMFilter _filter,
                              boolean _bIncludingThoseInChildren)
                              throws WCMException
获取站点/频道下管理的模板集合

参数：
_oIChannel - 当前站点/频道
_filter - 过滤器,额外的查询条件
_nTemplateType - 模板类型(Template.ALL_TEMPLATE等)
_bIncludingThoseInChildren - 是否包括子频道的模板
返回：
模板集合
抛出：
WCMException

getOptionalTemplates

Templates getOptionalTemplates(IPublishFolder _folder,
                               int _nTemplateType,
                               WCMFilter _filter,
                               boolean _bIncludingThoseParent)
                               throws WCMException
获取指定Folder中可选的模板集合

参数：
_folder - 当前站点/频道
_nTemplateType - 模板类型
_filter - 过滤器,额外的查询条件
_bIncludingThoseParent - 是否包含父频道的模板
返回：
模板集合
抛出：
WCMException

getNestedTemplates

Templates getNestedTemplates(Template _currTemplate)
                             throws WCMException
获取当前模板中使用到的嵌套模板

参数：
_currTemplate - 当前模板
返回：
抛出：
WCMException

getTemplatesNested

Templates getTemplatesNested(Template _currTemplate)
                             throws WCMException
获取嵌套了当前模板的所有模板

参数：
_currTemplate - 当前模板
返回：
抛出：
WCMException

getTemplateEmployers

java.util.List getTemplateEmployers(Template _currTemplate)
                                    throws WCMException
获取使用到当前模板的所有对象集合

参数：
_currTemplate - 当前模板
返回：
抛出：
WCMException

getTemplateEmployers

java.util.List getTemplateEmployers(Template _currTemplate,
                                    int _nEmployerType)
                                    throws WCMException
获取使用到当前模板的指定类型的对象集合

参数：
_currTemplate - 当前模板
_nEmployerType - 指定对象类型
返回：
抛出：
WCMException

findByName

Template findByName(int _nSiteId,
                    java.lang.String _sTempName)
                    throws WCMException
根据指定的SiteId，找到指定名称的模板

参数：
_nSiteIdId -
_sTempName -
返回：
抛出：
WCMException

getTemplateArguments

TemplateArguments getTemplateArguments(IPublishElement _element)
                                       throws WCMException
返回指定发布对象上的全部有效模板参数列表

返回：
有效的模板参数列表
抛出：
WCMException

deleteTemplateArgument

boolean deleteTemplateArgument(TemplateArgument _argument)
                               throws WCMException
删除指定的TemplateArgument对象

参数：
_argument - 待删除的TemplateArgument对象
返回：
是否删除成功
抛出：
WCMException - 如果发生错误

deleteTemplateArguments

void deleteTemplateArguments(TemplateArguments _arguments)
                             throws WCMException
删除指定的TemplateArguments对象集合

参数：
_arguments - 待删除的TemplateArguments对象集合
抛出：
WCMException - 如果发生错误

saveTemplateArgument

TemplateArgument saveTemplateArgument(TemplateArgument _argument)
                                      throws WCMException
保存指定的TemplateArgument对象

参数：
_argument - 待保存的TemplateArgument对象
返回：
保存后的TemplateArgument对象
抛出：
WCMException - 如果发生错误

getTemplateParameters

TemplateParameterList getTemplateParameters(IPublishElement _element)
                                            throws WCMException
返回指定发布对象使用的所有模板中的全部形式参数列表

返回：
指定发布对象使用的所有模板中的全部形式参数列表
抛出：
WCMException

getTemplateParameters

TemplateParameterList getTemplateParameters(IPublishElement _element,
                                            boolean zRecursion)
                                            throws WCMException
返回指定发布对象使用的所有模板中的全部形式参数列表

参数：
_element - 指定的发布对象
zRecursion - 是否递归被嵌套的模板中变量
返回：
指定发布对象使用的所有模板中的全部形式参数列表
抛出：
WCMException - 如果发生错误
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IUserService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IUserService

所有已知实现类：
UserService
public interface IUserService

Title: TRS 内容协作平台（TRS WCM）
Description:
用户管理的各种接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | delete(int _nUserId, boolean _bDrop) 删除指定的用户
boolean | delete(java.lang.String _sUserIds, boolean _bDrop) 根据用户id序列,批量删除指定的用户
boolean | delete(User _userToDelete, boolean _bDrop) 删除指定的用户
boolean | delete(Users _usersToDelete, boolean _bDrop) 批量删除指定的用户
boolean | disable(int _nUserId) 根据Id来禁用用户
boolean | disable(User _userToDisable) 设置一个用户为禁用状态
boolean | enable(int _nUserId) 根据ID恢复用户
boolean | enable(User _userToEnable) 开通一个用户
Users | getCanMgrUsers(int _nUserRegStatus, WCMFilter _filter) 获取我可管理的用户
Documents | getDocuments() 获取当前登录用户创建的有效文档集合
Documents | getDocuments(WCMFilter _filter) 获取当前登录用户创建的有效文档集合,设定查询条件
Documents | getDraft() 获取当前登录用户创建的草稿集合
Documents | getDraft(WCMFilter _filter) 获取当前登录用户创建的草稿集合,设定查询条件
Groups | getGroups() 获取当前登录用户所在的组织.
Groups | getGroups(User _currUser) 获取指定用户所在的组织集合
Users | getMyUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所创建的用户列表
Documents | getRecycleDocuments() 获取当前登录用户创建的废稿集合
Documents | getRecycleDocuments(WCMFilter _filter) 获取当前登录用户创建的废稿集合,设定查询条件
Roles | getRoles() 获取当前登录用户所担任的角色.
Roles | getRoles(User _currUser) 获取指定用户所属的角色集合
Users | getUsers(int _nUserRegStatus, WCMFilter _filter) 获取系统中的某个注册状态的所有用户
boolean | isAdminOfGroup(User _user) 判断指定用户是否在系统中担任组管理员
boolean | isManagerOfRole(User _user) 判断指定用户是否在系统中担任角色维护员
boolean | resetPassword(User _dstUser) 重设指定用户的密码为缺省值(只能由系统管理员操作)
boolean | resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword) 重设指定用户的登录密码
boolean | restore(User _userToRestore) 恢复已删除的用户
boolean | restore(Users _usersToRestore) 恢复已删除的用户集合
User | save(User _userToSave) 保存一个用户
User | save(User _userToSave, Group _currGrp)

方法详细信息

getDocuments

Documents getDocuments()
                       throws WCMException
获取当前登录用户创建的有效文档集合

返回：
@throws WCMException
抛出：
WCMException

getDocuments

Documents getDocuments(WCMFilter _filter)
                       throws WCMException
获取当前登录用户创建的有效文档集合,设定查询条件

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getDraft

Documents getDraft()
                   throws WCMException
获取当前登录用户创建的草稿集合

返回：
@throws WCMException
抛出：
WCMException

getDraft

Documents getDraft(WCMFilter _filter)
                   throws WCMException
获取当前登录用户创建的草稿集合,设定查询条件

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getRecycleDocuments

Documents getRecycleDocuments()
                              throws WCMException
获取当前登录用户创建的废稿集合

返回：
@throws WCMException
抛出：
WCMException

getRecycleDocuments

Documents getRecycleDocuments(WCMFilter _filter)
                              throws WCMException
获取当前登录用户创建的废稿集合,设定查询条件

参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getGroups

Groups getGroups(User _currUser)
                 throws WCMException
获取指定用户所在的组织集合

参数：
_currUser - 指定的用户.
返回：
@throws WCMException
抛出：
WCMException

getGroups

Groups getGroups()
                 throws WCMException
获取当前登录用户所在的组织.

返回：
@throws WCMException
抛出：
WCMException

getRoles

Roles getRoles(User _currUser)
               throws WCMException
获取指定用户所属的角色集合

参数：
_currUser - 指定用户.
返回：
@throws WCMException
抛出：
WCMException

getRoles

Roles getRoles()
               throws WCMException
获取当前登录用户所担任的角色.

返回：
@throws WCMException
抛出：
WCMException

save

User save(User _userToSave)
          throws WCMException
保存一个用户

参数：
_userToSave - 要保存的用户
返回：
@throws WCMException
抛出：
WCMException

save

User save(User _userToSave,
          Group _currGrp)
          throws WCMException
抛出：
WCMException

enable

boolean enable(User _userToEnable)
               throws WCMException
开通一个用户

参数：
_userToEnable - 要开通的用户帐号
返回：
@throws WCMException
抛出：
WCMException

disable

boolean disable(User _userToDisable)
                throws WCMException
设置一个用户为禁用状态

参数：
_userToDisable - 要禁用的用户
返回：
@throws WCMException
抛出：
WCMException

restore

boolean restore(User _userToRestore)
                throws WCMException
恢复已删除的用户

参数：
_userToRestore - 要恢复的用户
返回：
@throws WCMException
抛出：
WCMException

restore

boolean restore(Users _usersToRestore)
                throws WCMException
恢复已删除的用户集合

参数：
_usersToRestore -
返回：
@throws WCMException
抛出：
WCMException

resetPassword

boolean resetPassword(User _dstUser,
                      java.lang.String _sOldPassword,
                      java.lang.String _sNewPassword)
                      throws WCMException
重设指定用户的登录密码

参数：
_dstUser - 指定的用户
_sOldPassword - 旧密码
_sNewPassword - 新密码
返回：
@throws WCMException
抛出：
WCMException

resetPassword

boolean resetPassword(User _dstUser)
                      throws WCMException
重设指定用户的密码为缺省值(只能由系统管理员操作)

参数：
_dstUser指定的用户 -
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(java.lang.String _sUserIds,
               boolean _bDrop)
               throws WCMException
根据用户id序列,批量删除指定的用户

参数：
_userToDelete - 要删除的用户id序列
_bDrop - 是否删除数据库中的数据,true为删除,false为设置指定用户的注册状态为(User.USER_STATUS_DEL)
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(Users _usersToDelete,
               boolean _bDrop)
               throws WCMException
批量删除指定的用户

参数：
_usersToDelete - 要删除的用户集合
_bDrop - 是否删除数据库中的数据,true为删除,false为设置指定用户的注册状态为(User.USER_STATUS_DEL)
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(int _nUserId,
               boolean _bDrop)
               throws WCMException
删除指定的用户

参数：
_nUserId - 要删除的用户id
_bDrop - 是否删除数据库中的数据,true为删除,false为设置指定用户的注册状态为(User.USER_STATUS_DEL)
返回：
@throws WCMException
抛出：
WCMException

delete

boolean delete(User _userToDelete,
               boolean _bDrop)
               throws WCMException
删除指定的用户

参数：
_userToDelete - 要删除的用户
_bDrop - 是否删除数据库中的数据,true为删除,false为设置指定用户的注册状态为(User.USER_STATUS_DEL)
返回：
@throws WCMException
抛出：
WCMException

disable

boolean disable(int _nUserId)
                throws WCMException
根据Id来禁用用户

参数：
_nUserId指定的用户id -
抛出：
WCMException

enable

boolean enable(int _nUserId)
               throws WCMException
根据ID恢复用户

参数：
_nUserId - 指定的用户id
抛出：
WCMException

getUsers

Users getUsers(int _nUserRegStatus,
               WCMFilter _filter)
               throws WCMException
获取系统中的某个注册状态的所有用户

参数：
_nUserRegStatus - 用户的注册状态(User.USER_STATUS_APPLY等)
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getMyUsers

Users getMyUsers(int _nUserRegStatus,
                 WCMFilter _filter)
                 throws WCMException
获取我所创建的用户列表

参数：
_nUserRegStatus -
_filter -
返回：
抛出：
WCMException

getCanMgrUsers

Users getCanMgrUsers(int _nUserRegStatus,
                     WCMFilter _filter)
                     throws WCMException
获取我可管理的用户

参数：
__nUserRegStatus -
_filter -
返回：
抛出：
WCMException

isAdminOfGroup

boolean isAdminOfGroup(User _user)
                       throws WCMException
判断指定用户是否在系统中担任组管理员

参数：
_user - 指定用户
返回：
如果有则返回 true
抛出：
WCMException

isManagerOfRole

boolean isManagerOfRole(User _user)
                        throws WCMException
判断指定用户是否在系统中担任角色维护员

参数：
_user - 指定用户
返回：
如果有则返回 true
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWCMProcessService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IWCMProcessService

所有已知实现类：
WCMProcessServiceImpl
public interface IWCMProcessService

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | deleteFlows(java.lang.String _sFlowIds)
java.lang.String | exportFlow(int _nFlowId) 导出指定的工作流对象.
java.lang.String | exportFlows(java.lang.String _sFlowIds) 导出指定的工作流为XML文件格式的数据.
void | forceContentEndInFlow(int _nContentType, int _nContentId)
FlowDoc | getCurrentFlowDoc(int _nContentType, int _nContentId)
int | getCurrFlowFlag(int _nContentType, int _nContentId)
java.lang.String | getCurrFlowFlagDesc(int _nContentType, int _nContentId)
FlowDocs | getFlowDocs(int _nFlag, WCMFilter _filter)
FlowDocs | getFlowDocsOfContent(int _nContentType, int _nContentId) 获取当前内容的所有流转情况
Flow | getFlowOfEmployer(BaseObj _employer)
Flows | getFlows(WCMFilter _filter)
FlowDocs | getSubmitFlowDocs(User _operator, WCMFilter _filter) 获取用户[_operator]已经呈送的信息
Reports | importFlows(java.lang.String _sImportFile) 从XML文件中导入工作流配置.
Reports | importFlows(java.lang.String _sImportFile, java.lang.String _sXslFile) 从XML文件中导入工作流配置.
boolean | isCanInFlow(int _nContentType, int _nContentId)
Reports | saveFlow(java.lang.String _sFlowXML)
void | setFlowEmploy(BaseObj _employer, int _nFlowId)
FlowDoc | startContentInFlow(int _nContentType, int _nContentId)
void | submitAgain(User _postUser, int _nFlowDocId, java.lang.String _sOpinion)
void | submitBack(User _postUser, java.lang.String _sFromFlowDocId, java.lang.String _sOpinion) 指定的用户将指定的工作事项打回
void | submitTo(FlowParamers _currParamerts) 将内容按照指定的方式呈送
java.lang.String | toFlowsXMLString(java.lang.String _sFlowIds)
java.lang.String | toFlowXMLString(Flow _currFlow)

方法详细信息

toFlowsXMLString

java.lang.String toFlowsXMLString(java.lang.String _sFlowIds)
                                  throws WCMException
抛出：
WCMException

toFlowXMLString

java.lang.String toFlowXMLString(Flow _currFlow)
                                 throws WCMException
抛出：
WCMException

getFlows

Flows getFlows(WCMFilter _filter)
               throws WCMException
抛出：
WCMException

deleteFlows

void deleteFlows(java.lang.String _sFlowIds)
                 throws WCMException
抛出：
WCMException

saveFlow

Reports saveFlow(java.lang.String _sFlowXML)
                 throws WCMException
抛出：
WCMException

getFlowDocs

FlowDocs getFlowDocs(int _nFlag,
                     WCMFilter _filter)
                     throws WCMException
抛出：
WCMException

startContentInFlow

FlowDoc startContentInFlow(int _nContentType,
                           int _nContentId)
                           throws WCMException
抛出：
WCMException

forceContentEndInFlow

void forceContentEndInFlow(int _nContentType,
                           int _nContentId)
                           throws WCMException
抛出：
WCMException

isCanInFlow

boolean isCanInFlow(int _nContentType,
                    int _nContentId)
                    throws WCMException
抛出：
WCMException

submitTo

void submitTo(FlowParamers _currParamerts)
              throws WCMException
将内容按照指定的方式呈送

参数：
_currParamerts - 指定的方式(FlowParamers)
抛出：
WCMException

submitBack

void submitBack(User _postUser,
                java.lang.String _sFromFlowDocId,
                java.lang.String _sOpinion)
                throws WCMException
指定的用户将指定的工作事项打回

参数：
_postUser - 指定的用户
_sFromFlowDocId - 指定的工作事项ID序列
_sOpinion - 意见
抛出：
WCMException

submitAgain

void submitAgain(User _postUser,
                 int _nFlowDocId,
                 java.lang.String _sOpinion)
                 throws WCMException
抛出：
WCMException

setFlowEmploy

void setFlowEmploy(BaseObj _employer,
                   int _nFlowId)
                   throws WCMException
抛出：
WCMException

getFlowOfEmployer

Flow getFlowOfEmployer(BaseObj _employer)
                       throws WCMException
抛出：
WCMException

getCurrentFlowDoc

FlowDoc getCurrentFlowDoc(int _nContentType,
                          int _nContentId)
                          throws WCMException
抛出：
WCMException

getCurrFlowFlagDesc

java.lang.String getCurrFlowFlagDesc(int _nContentType,
                                     int _nContentId)
                                     throws WCMException
抛出：
WCMException

getCurrFlowFlag

int getCurrFlowFlag(int _nContentType,
                    int _nContentId)
                    throws WCMException
抛出：
WCMException

getFlowDocsOfContent

FlowDocs getFlowDocsOfContent(int _nContentType,
                              int _nContentId)
                              throws WCMException
获取当前内容的所有流转情况

参数：
_nContentType - 当前内容的类型
_nContentId - 当前内容的ID
返回：
FlowDocs
抛出：
WCMException

getSubmitFlowDocs

FlowDocs getSubmitFlowDocs(User _operator,
                           WCMFilter _filter)
                           throws WCMException
获取用户[_operator]已经呈送的信息

参数：
_operator - 操作用户
_filter - 检索条件
返回：
流转信息集合（FlowDoc）
抛出：
WCMException

importFlows

Reports importFlows(java.lang.String _sImportFile)
                    throws WCMException
从XML文件中导入工作流配置.

参数：
_sImportFile - 工作流的配置文件.
返回：
@throws WCMException
抛出：
WCMException

importFlows

Reports importFlows(java.lang.String _sImportFile,
                    java.lang.String _sXslFile)
                    throws WCMException
从XML文件中导入工作流配置.

参数：
_sImportFile - 工作流配置文件.
_sXslFile - XML转换所需要的XSL文件.
返回：
@throws WCMException
抛出：
WCMException

exportFlow

java.lang.String exportFlow(int _nFlowId)
                            throws WCMException
导出指定的工作流对象.

参数：
_nFlowId - 指定的工作流对象ID.
返回：
@throws WCMException
抛出：
WCMException

exportFlows

java.lang.String exportFlows(java.lang.String _sFlowIds)
                             throws WCMException
导出指定的工作流为XML文件格式的数据.

参数：
_sFlowIds - 指定要导出的工作流对象的ID序列,必须以字符','分隔.
返回：
返回XML文件名,不包含路径.
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IWCMPublishElementService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service
接口 IWCMPublishElementService

所有已知实现类：
WCMPublishElementServiceImpl
public interface IWCMPublishElementService

Title: TRS 内容协作平台（TRS WCM）
Description:
service interface for publish element settings in WCM.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | deletePublishDistributions(WebSite _currSite, java.lang.String _sPublishDistributionIds) 将当前站点的指定分发信息设置删除
WCMFolderPublishConfig | findFolderConfig(BaseChannel _currChannel) 获取当前站点或频道的发布配置信息
PublishDistributions | findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter) 获取当前站点所设置的分发目录集合
java.util.Iterator | getDistributionTargetTypes() Returns the distribution target type name collection iterator.
PublishDistributionTargetType | lookupDistributionTargetTypeByName(java.lang.String _sName) lookup the distribution target type by name.
WCMFolderPublishConfig | save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig) 保存当前站点或频道的发布配置信息
PublishDistribution | save(WebSite _currSite, PublishDistribution _currPublishDistribution) 保存当前站点所设置的分发目录
void | setPubDistributionsEnable(WebSite _currSite, java.lang.String _sPublishDistributionIds, boolean _bEnable) 将当前站点的指定分发信息设置为无效

方法详细信息

findFolderConfig

WCMFolderPublishConfig findFolderConfig(BaseChannel _currChannel)
                                        throws WCMException
获取当前站点或频道的发布配置信息

参数：
_currChannel - 当前站点或频道
返回：
站点或频道的发布配置信息（WCMFolderPublishConfig）
抛出：
WCMException

save

WCMFolderPublishConfig save(BaseChannel _currChannel,
                            WCMFolderPublishConfig _currFolderConfig)
                            throws WCMException
保存当前站点或频道的发布配置信息

参数：
_currChannel - 当前站点或频道
_currFolderConfig - 站点或频道的发布配置信息
返回：
站点或频道的发布配置信息
抛出：
WCMException

findPublishDistributions

PublishDistributions findPublishDistributions(WebSite _currSite,
                                              boolean _bExcludingDisabled,
                                              WCMFilter _filter)
                                              throws WCMException
获取当前站点所设置的分发目录集合

参数：
_currSite - 当前站点
_bExcludingDisabled - 是否只获取enable的
_filter - 过滤器,额外的查询条件
返回：
分发目录集合(PublishDistributions)
抛出：
WCMException

save

PublishDistribution save(WebSite _currSite,
                         PublishDistribution _currPublishDistribution)
                         throws WCMException
保存当前站点所设置的分发目录

参数：
_currSite - 当前站点
_currPublishDistribution - 需要保存的分发目录信息
返回：
成功保存的分发目录信息（PublishDistributionConfig）
抛出：
WCMException

setPubDistributionsEnable

void setPubDistributionsEnable(WebSite _currSite,
                               java.lang.String _sPublishDistributionIds,
                               boolean _bEnable)
                               throws WCMException
将当前站点的指定分发信息设置为无效

参数：
_currSite - 当前站点
_sPublishDistributionIds - 分发信息的ID序列
抛出：
WCMException

deletePublishDistributions

void deletePublishDistributions(WebSite _currSite,
                                java.lang.String _sPublishDistributionIds)
                                throws WCMException
将当前站点的指定分发信息设置删除

参数：
_currSite - 当前站点
_sPublishDistributionIds - 需要删除的分发信息ID序列
抛出：
WCMException

getDistributionTargetTypes

java.util.Iterator getDistributionTargetTypes()
                                              throws java.lang.Exception
Returns the distribution target type name collection iterator.

返回：
the distribution target type name collection iterator.
抛出：
java.lang.Exception - if failed.

lookupDistributionTargetTypeByName

PublishDistributionTargetType lookupDistributionTargetTypeByName(java.lang.String _sName)
                                                                 throws java.lang.Exception
lookup the distribution target type by name.

参数：
_sName - the target type name.
返回：
the distribution target type if found, other null.
抛出：
java.lang.Exception - if the failed to load the configuration.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.service
接口
IAutoDocBakService
IBookMarkService
ICDSService
IChannelService
IContactService
ICustomizeService
IDBService
IDocumentService
IEventService
IGroupService
IInfoViewEnumCreator
IInfoViewInitor
IInfoViewInitorValue
IInfoViewService
IOfficeDocumentService
IPublishService
IRecentService
IResourceService
IRoleService
IScheduleService
ISecurityService
ISOAPService
IStatService
ISureformService
ITemplateParseService
ITemplateService
IUserService
IWCMProcessService
IWCMPublishElementService
类
InfoViewContext
ServiceHelper


com.trs.service

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.service

接口摘要
IAutoDocBakService | Title: TRS 内容协作平台（TRS WCM） Description: 文档版本自动保存接口设计 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IBookMarkService | Title: TRS 内容协作平台（TRS WCM） Description: IBookMarkServic接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ICDSService | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IChannelService | Title: TRS 内容协作平台（TRS WCM） Description: 站点/频道服务提供对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IContactService | Title: TRS 内容协作平台（TRS WCM） Description: 联系人服务接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ICustomizeService | Title: TRS 内容协作平台（TRS WCM） Description: 个性化定制服务提供对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IDBService | Title: TRS 内容协作平台（TRS WCM） Description: 数据库相关操作服务层接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IDocumentService |
IEventService | Title: TRS 内容协作平台（TRS WCM） Description: Event Service Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IGroupService | Title: TRS 内容协作平台（TRS WCM） Description: 组织服务提供对象接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewEnumCreator | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewInitor | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewInitorValue |
IInfoViewService | 自定义表单管理的公共接口定义
IOfficeDocumentService | Title: TRS 内容协作平台（TRS WCM） Description: Office文档的相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IPublishService |
IRecentService | Title: TRS 内容协作平台（TRS WCM） Description: 为“最近处理的对象” 提供的服务层接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IResourceService | Title: TRS 内容协作平台（TRS WCM） Description: 配置资源服务提供对象的接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IRoleService | Title: TRS 内容协作平台（TRS WCM） Description: 角色相关服务提供对象的接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IScheduleService | Title: TRS 内容协作平台（TRS WCM） Description: 计划调度服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ISecurityService |
ISOAPService | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IStatService | Title: TRS 内容协作平台（TRS WCM） Description: 统计应用相关的服务接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ISureformService | Title: TRS 内容协作平台（TRS WCM） Description: 书生表单服务层 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateParseService | Title: TRS 内容协作平台（TRS WCM） Description: 提供模板解析接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateService | Title: TRS 内容协作平台（TRS WCM） Description: 提供模板管理的接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IUserService | Title: TRS 内容协作平台（TRS WCM） Description: 用户管理的各种接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IWCMProcessService | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IWCMPublishElementService | Title: TRS 内容协作平台（TRS WCM） Description: service interface for publish element settings in WCM.

类摘要
InfoViewContext | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceHelper | Title: TRS 内容协作平台（TRS WCM） Description: Service解析器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.service 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.service 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.service.InfoViewContext
    • com.trs.service.ServiceHelper

接口分层结构

  • com.trs.service.IAutoDocBakService
  • com.trs.service.IBookMarkService
  • com.trs.service.ICDSService
  • com.trs.service.IChannelService
  • com.trs.service.IContactService
  • com.trs.service.ICustomizeService
  • com.trs.service.IDBService
  • com.trs.service.IDocumentService
  • com.trs.service.IEventService
  • com.trs.service.IGroupService
  • com.trs.service.IInfoViewEnumCreator
  • com.trs.service.IInfoViewInitor
  • com.trs.service.IInfoViewInitorValue
  • com.trs.service.IInfoViewService
  • com.trs.service.IOfficeDocumentService
  • com.trs.service.IPublishService
  • com.trs.service.IRecentService
  • com.trs.service.IResourceService
  • com.trs.service.IRoleService
  • com.trs.service.IScheduleService
  • com.trs.service.ISecurityService
  • com.trs.service.ISOAPService
  • com.trs.service.IStatService
  • com.trs.service.ISureformService
  • com.trs.service.ITemplateParseService
  • com.trs.service.ITemplateService
  • com.trs.service.IUserService
  • com.trs.service.IWCMProcessService
  • com.trs.service.IWCMPublishElementService


软件包 com.trs.service 的使用

上一个 下一个 框架 无框架

软件包 com.trs.service
的使用

使用 com.trs.service 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 使用的 com.trs.service 中的类
IAutoDocBakService
Title: TRS 内容协作平台（TRS WCM）
Description:
文档版本自动保存接口设计
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IBookMarkService
Title: TRS 内容协作平台（TRS WCM）
Description:
IBookMarkServic接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICDSService
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IChannelService
Title: TRS 内容协作平台（TRS WCM）
Description:
站点/频道服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IContactService
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人服务接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICustomizeService
Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IDocumentService
IEventService
Title: TRS 内容协作平台（TRS WCM）
Description:
Event Service Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IGroupService
Title: TRS 内容协作平台（TRS WCM）
Description:
组织服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewService
自定义表单管理的公共接口定义
InfoViewContext
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IOfficeDocumentService
Title: TRS 内容协作平台（TRS WCM）
Description:
Office文档的相关服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRecentService
Title: TRS 内容协作平台（TRS WCM）
Description:
为“最近处理的对象” 提供的服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IResourceService
Title: TRS 内容协作平台（TRS WCM）
Description:
配置资源服务提供对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRoleService
Title: TRS 内容协作平台（TRS WCM）
Description:
角色相关服务提供对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IScheduleService
Title: TRS 内容协作平台（TRS WCM）
Description:
计划调度服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IStatService
Title: TRS 内容协作平台（TRS WCM）
Description:
统计应用相关的服务接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ISureformService
Title: TRS 内容协作平台（TRS WCM）
Description:
书生表单服务层
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateParseService
Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板解析接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateService
Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板管理的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IUserService
Title: TRS 内容协作平台（TRS WCM）
Description:
用户管理的各种接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IWCMProcessService
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IWCMPublishElementService
Title: TRS 内容协作平台（TRS WCM）
Description:
service interface for publish element settings in WCM.

com.trs.service.impl 使用的 com.trs.service 中的类
IAutoDocBakService
Title: TRS 内容协作平台（TRS WCM）
Description:
文档版本自动保存接口设计
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IBookMarkService
Title: TRS 内容协作平台（TRS WCM）
Description:
IBookMarkServic接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICDSService
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IChannelService
Title: TRS 内容协作平台（TRS WCM）
Description:
站点/频道服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IContactService
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人服务接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICustomizeService
Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IDBService
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库相关操作服务层接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IDocumentService
IEventService
Title: TRS 内容协作平台（TRS WCM）
Description:
Event Service Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IGroupService
Title: TRS 内容协作平台（TRS WCM）
Description:
组织服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewEnumCreator
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewInitor
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewInitorValue
IInfoViewService
自定义表单管理的公共接口定义
InfoViewContext
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IOfficeDocumentService
Title: TRS 内容协作平台（TRS WCM）
Description:
Office文档的相关服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IPublishService
IRecentService
Title: TRS 内容协作平台（TRS WCM）
Description:
为“最近处理的对象” 提供的服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IResourceService
Title: TRS 内容协作平台（TRS WCM）
Description:
配置资源服务提供对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRoleService
Title: TRS 内容协作平台（TRS WCM）
Description:
角色相关服务提供对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IScheduleService
Title: TRS 内容协作平台（TRS WCM）
Description:
计划调度服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ISecurityService
ISOAPService
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IStatService
Title: TRS 内容协作平台（TRS WCM）
Description:
统计应用相关的服务接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ISureformService
Title: TRS 内容协作平台（TRS WCM）
Description:
书生表单服务层
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateParseService
Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板解析接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateService
Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板管理的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IUserService
Title: TRS 内容协作平台（TRS WCM）
Description:
用户管理的各种接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IWCMProcessService
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IWCMPublishElementService
Title: TRS 内容协作平台（TRS WCM）
Description:
service interface for publish element settings in WCM.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ServiceHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.service
类 ServiceHelper

java.lang.Object
    继承者  com.trs.service.ServiceHelper

public class ServiceHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Service解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ServiceHelper()
方法摘要
static IAutoDocBakService | createAutoDocBakService() 产生IAutoDocBakService的实例
static IBookMarkService | createBookMarkService() 产生IBookMarkService的实例
static ICDSService | createCDSService()
static IChannelService | createChannelService() 产生IChannelService的实例
static IContactService | createContactService() 产生IContactService的实例
static ICustomizeService | createCustomizeService() 产生ICustomizeService的实例
static IDocumentService | createDocumentService() 产生IDocumentService的实例
static IEventService | createEventService() 产生IEventService的实例
static IGroupService | createGroupService() 产生IGroupService的实例
static IInfoViewService | createInfoViewService()
static IOfficeDocumentService | createOfficeDocumentService()
static IRecentService | createRecentService() 产生IRecentService的实例
static IResourceService | createResourceService() 产生IResourceService的实例
static IRoleService | createRoleService() 产生IRoleService的实例
static IScheduleService | createScheduleService() 产生IScheduleService的实例
static IStatService | createStatService() 产生IStatService的实例
static ISureformService | createSureformService() 产生ISureformService的实例
static ITemplateParseService | createTemplateParseService()
static ITemplateService | createTemplateService()
static IUserService | createUserService() 产生IUserService的实例
static IWCMProcessService | createWCMProcessService() 产生IWCMProcessService的实例
static IWCMPublishElementService | createWCMPublishElementService() 产生IWCMPublishElementSetting的实例
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceHelper

public ServiceHelper()
方法详细信息

createContactService

public static IContactService createContactService()
                                            throws WCMException
产生IContactService的实例

返回：
IContactService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createAutoDocBakService

public static IAutoDocBakService createAutoDocBakService()
                                                  throws WCMException
产生IAutoDocBakService的实例

返回：
IAutoDocBakService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createBookMarkService

public static IBookMarkService createBookMarkService()
                                              throws WCMException
产生IBookMarkService的实例

返回：
IBookMarkService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createChannelService

public static IChannelService createChannelService()
                                            throws WCMException
产生IChannelService的实例

返回：
IChannelService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createCustomizeService

public static ICustomizeService createCustomizeService()
                                                throws WCMException
产生ICustomizeService的实例

返回：
ICustomizeService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createDocumentService

public static IDocumentService createDocumentService()
                                              throws WCMException
产生IDocumentService的实例

返回：
IDocumentService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createEventService

public static IEventService createEventService()
                                        throws WCMException
产生IEventService的实例

返回：
IEventService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createGroupService

public static IGroupService createGroupService()
                                        throws WCMException
产生IGroupService的实例

返回：
IGroupService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createRecentService

public static IRecentService createRecentService()
                                          throws WCMException
产生IRecentService的实例

返回：
IRecentService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createResourceService

public static IResourceService createResourceService()
                                              throws WCMException
产生IResourceService的实例

返回：
IResourceService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createRoleService

public static IRoleService createRoleService()
                                      throws WCMException
产生IRoleService的实例

返回：
IRoleService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createScheduleService

public static IScheduleService createScheduleService()
                                              throws WCMException
产生IScheduleService的实例

返回：
IScheduleService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createUserService

public static IUserService createUserService()
                                      throws WCMException
产生IUserService的实例

返回：
IUserService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createStatService

public static IStatService createStatService()
                                      throws WCMException
产生IStatService的实例

返回：
IStatService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createWCMPublishElementService

public static IWCMPublishElementService createWCMPublishElementService()
                                                                throws WCMException
产生IWCMPublishElementSetting的实例

返回：
IWCMPublishElementSetting的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createWCMProcessService

public static IWCMProcessService createWCMProcessService()
                                                  throws WCMException
产生IWCMProcessService的实例

返回：
IWCMProcessService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createSureformService

public static ISureformService createSureformService()
                                              throws WCMException
产生ISureformService的实例

返回：
ISureformService的实例
抛出：
WCMException - 如果Service配置错误，抛出异常

createTemplateService

public static ITemplateService createTemplateService()

createTemplateParseService

public static ITemplateParseService createTemplateParseService()

createCDSService

public static ICDSService createCDSService()

createInfoViewService

public static IInfoViewService createInfoViewService()
                                              throws WCMException
抛出：
WCMException

createOfficeDocumentService

public static IOfficeDocumentService createOfficeDocumentService()
                                                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


接口 com.trs.service.IAutoDocBakService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IAutoDocBakService
的使用

使用 IAutoDocBakService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IAutoDocBakService 的使用

返回 IAutoDocBakService 的 com.trs.service 中的方法
static IAutoDocBakService ServiceHelper.createAutoDocBakService()
产生IAutoDocBakService的实例

com.trs.service.impl 中 IAutoDocBakService 的使用

实现 IAutoDocBakService 的 com.trs.service.impl 中的类
 class AutoDocBakService
Title: TRS 内容协作平台（TRS WCM）
Description:
实现IAutoDocBakService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IBookMarkService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IBookMarkService
的使用

使用 IBookMarkService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IBookMarkService 的使用

返回 IBookMarkService 的 com.trs.service 中的方法
static IBookMarkService ServiceHelper.createBookMarkService()
产生IBookMarkService的实例

com.trs.service.impl 中 IBookMarkService 的使用

实现 IBookMarkService 的 com.trs.service.impl 中的类
 class BookMarkService
Title: TRS 内容协作平台（TRS WCM）
Description:
实现IBookMarkService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.ICDSService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.ICDSService
的使用

使用 ICDSService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 ICDSService 的使用

返回 ICDSService 的 com.trs.service 中的方法
static ICDSService ServiceHelper.createCDSService()

com.trs.service.impl 中 ICDSService 的使用

实现 ICDSService 的 com.trs.service.impl 中的类
 class CDSServiceImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
CDS Service
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IChannelService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IChannelService
的使用

使用 IChannelService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IChannelService 的使用

返回 IChannelService 的 com.trs.service 中的方法
static IChannelService ServiceHelper.createChannelService()
产生IChannelService的实例

com.trs.service.impl 中 IChannelService 的使用

实现 IChannelService 的 com.trs.service.impl 中的类
 class ChannelService
Title: TRS 内容协作平台（TRS WCM）
Description:

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IContactService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IContactService
的使用

使用 IContactService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IContactService 的使用

返回 IContactService 的 com.trs.service 中的方法
static IContactService ServiceHelper.createContactService()
产生IContactService的实例

com.trs.service.impl 中 IContactService 的使用

实现 IContactService 的 com.trs.service.impl 中的类
 class ContactService
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人服务接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.ICustomizeService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.ICustomizeService
的使用

使用 ICustomizeService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 ICustomizeService 的使用

返回 ICustomizeService 的 com.trs.service 中的方法
static ICustomizeService ServiceHelper.createCustomizeService()
产生ICustomizeService的实例

com.trs.service.impl 中 ICustomizeService 的使用

实现 ICustomizeService 的 com.trs.service.impl 中的类
 class CustomizeService
Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制服务提供对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IDBService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IDBService
的使用

使用 IDBService 的软件包
com.trs.service.impl

com.trs.service.impl 中 IDBService 的使用

实现 IDBService 的 com.trs.service.impl 中的类
 class DBService
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库相关操作服务层接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IDocumentService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IDocumentService
的使用

使用 IDocumentService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IDocumentService 的使用

返回 IDocumentService 的 com.trs.service 中的方法
static IDocumentService ServiceHelper.createDocumentService()
产生IDocumentService的实例

com.trs.service.impl 中 IDocumentService 的使用

实现 IDocumentService 的 com.trs.service.impl 中的类
 class DocumentService

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IEventService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IEventService
的使用

使用 IEventService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IEventService 的使用

返回 IEventService 的 com.trs.service 中的方法
static IEventService ServiceHelper.createEventService()
产生IEventService的实例

com.trs.service.impl 中 IEventService 的使用

实现 IEventService 的 com.trs.service.impl 中的类
 class EventService
Title: TRS 内容协作平台（TRS WCM）
Description:
日程服务提供对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IGroupService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IGroupService
的使用

使用 IGroupService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IGroupService 的使用

返回 IGroupService 的 com.trs.service 中的方法
static IGroupService ServiceHelper.createGroupService()
产生IGroupService的实例

com.trs.service.impl 中 IGroupService 的使用

实现 IGroupService 的 com.trs.service.impl 中的类
 class GroupService
Title: TRS 内容协作平台（TRS WCM）
Description:
组织管理的服务接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IInfoViewEnumCreator 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IInfoViewEnumCreator
的使用

使用 IInfoViewEnumCreator 的软件包
com.trs.service.impl

com.trs.service.impl 中 IInfoViewEnumCreator 的使用

实现 IInfoViewEnumCreator 的 com.trs.service.impl 中的类
 class InfoViewEnumCreatorImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IInfoViewInitor 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IInfoViewInitor
的使用

使用 IInfoViewInitor 的软件包
com.trs.service.impl

com.trs.service.impl 中 IInfoViewInitor 的使用

实现 IInfoViewInitor 的 com.trs.service.impl 中的类
 class InfoViewInitorImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IInfoViewInitorValue 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IInfoViewInitorValue
的使用

使用 IInfoViewInitorValue 的软件包
com.trs.service.impl

com.trs.service.impl 中 IInfoViewInitorValue 的使用

实现 IInfoViewInitorValue 的 com.trs.service.impl 中的类
 class SiteNameCreator

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IInfoViewService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IInfoViewService
的使用

使用 IInfoViewService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IInfoViewService 的使用

返回 IInfoViewService 的 com.trs.service 中的方法
static IInfoViewService ServiceHelper.createInfoViewService()

com.trs.service.impl 中 IInfoViewService 的使用

实现 IInfoViewService 的 com.trs.service.impl 中的类
 class InfoViewService
自定义表单管理的公共接口定义IInfoViewService的实现

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.InfoViewContext 的使用

上一个 下一个 框架 无框架

类 com.trs.service.InfoViewContext
的使用

使用 InfoViewContext 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 InfoViewContext 的使用

返回 InfoViewContext 的 com.trs.service 中的方法
static InfoViewContext | InfoViewContext.create(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response)
static InfoViewContext | InfoViewContext.getCurrentInfoViewContext()

参数类型为 InfoViewContext 的 com.trs.service 中的方法
java.lang.Object | IInfoViewEnumCreator.enumScript(InfoViewContext _oContext)
java.lang.Object | IInfoViewInitorValue.getFieldValue(InfoViewContext _oContext, BindingBean _oBindingBean)
java.lang.Object | IInfoViewInitor.init(InfoViewContext _oContext)

com.trs.service.impl 中 InfoViewContext 的使用

参数类型为 InfoViewContext 的 com.trs.service.impl 中的方法
java.lang.Object | InfoViewEnumCreatorImpl.enumScript(InfoViewContext _oContext)
java.lang.Object | InfoViewInitorImpl.getFieldValue(InfoViewContext _oContext, BindingBean _oBean)
java.lang.Object | SiteNameCreator.getFieldValue(InfoViewContext _context, BindingBean _bindingBean)
java.lang.Object | InfoViewInitorImpl.init(InfoViewContext _oContext)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IOfficeDocumentService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IOfficeDocumentService
的使用

使用 IOfficeDocumentService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IOfficeDocumentService 的使用

返回 IOfficeDocumentService 的 com.trs.service 中的方法
static IOfficeDocumentService ServiceHelper.createOfficeDocumentService()

com.trs.service.impl 中 IOfficeDocumentService 的使用

实现 IOfficeDocumentService 的 com.trs.service.impl 中的类
 class OfficeDocumentService
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IPublishService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IPublishService
的使用

使用 IPublishService 的软件包
com.trs.service.impl

com.trs.service.impl 中 IPublishService 的使用

实现 IPublishService 的 com.trs.service.impl 中的类
 class PublishService
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IPublishService.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IRecentService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IRecentService
的使用

使用 IRecentService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IRecentService 的使用

返回 IRecentService 的 com.trs.service 中的方法
static IRecentService ServiceHelper.createRecentService()
产生IRecentService的实例

com.trs.service.impl 中 IRecentService 的使用

实现 IRecentService 的 com.trs.service.impl 中的类
 class RecentService
Title: TRS 内容协作平台（TRS WCM）
Description:
为“最近处理的对象” 提供的服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IResourceService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IResourceService
的使用

使用 IResourceService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IResourceService 的使用

返回 IResourceService 的 com.trs.service 中的方法
static IResourceService ServiceHelper.createResourceService()
产生IResourceService的实例

com.trs.service.impl 中 IResourceService 的使用

实现 IResourceService 的 com.trs.service.impl 中的类
 class ResouceService
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IRoleService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IRoleService
的使用

使用 IRoleService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IRoleService 的使用

返回 IRoleService 的 com.trs.service 中的方法
static IRoleService ServiceHelper.createRoleService()
产生IRoleService的实例

com.trs.service.impl 中 IRoleService 的使用

实现 IRoleService 的 com.trs.service.impl 中的类
 class RoleService
Title: TRS 内容协作平台（TRS WCM）
Description:
角色相关服务接口的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IScheduleService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IScheduleService
的使用

使用 IScheduleService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IScheduleService 的使用

返回 IScheduleService 的 com.trs.service 中的方法
static IScheduleService ServiceHelper.createScheduleService()
产生IScheduleService的实例

com.trs.service.impl 中 IScheduleService 的使用

实现 IScheduleService 的 com.trs.service.impl 中的类
 class ScheduleService
Title: TRS 内容协作平台（TRS WCM）
Description:
计划服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.ISecurityService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.ISecurityService
的使用

使用 ISecurityService 的软件包
com.trs.service.impl

com.trs.service.impl 中 ISecurityService 的使用

实现 ISecurityService 的 com.trs.service.impl 中的类
 class SecurityService

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.ISOAPService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.ISOAPService
的使用

使用 ISOAPService 的软件包
com.trs.service.impl

com.trs.service.impl 中 ISOAPService 的使用

实现 ISOAPService 的 com.trs.service.impl 中的类
 class SOAPServiceImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
对外的SOAP接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IStatService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IStatService
的使用

使用 IStatService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IStatService 的使用

返回 IStatService 的 com.trs.service 中的方法
static IStatService ServiceHelper.createStatService()
产生IStatService的实例

com.trs.service.impl 中 IStatService 的使用

实现 IStatService 的 com.trs.service.impl 中的类
 class StatService
Title: TRS 内容协作平台（TRS WCM）
Description:
实现统计服务接口提供的功能
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.ISureformService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.ISureformService
的使用

使用 ISureformService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 ISureformService 的使用

返回 ISureformService 的 com.trs.service 中的方法
static ISureformService ServiceHelper.createSureformService()
产生ISureformService的实例

com.trs.service.impl 中 ISureformService 的使用

实现 ISureformService 的 com.trs.service.impl 中的类
 class SureformService
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM为书生表单定制的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.ITemplateParseService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.ITemplateParseService
的使用

使用 ITemplateParseService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 ITemplateParseService 的使用

返回 ITemplateParseService 的 com.trs.service 中的方法
static ITemplateParseService ServiceHelper.createTemplateParseService()

com.trs.service.impl 中 ITemplateParseService 的使用

实现 ITemplateParseService 的 com.trs.service.impl 中的类
 class TemplateParseService
Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板解析接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.ITemplateService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.ITemplateService
的使用

使用 ITemplateService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 ITemplateService 的使用

返回 ITemplateService 的 com.trs.service 中的方法
static ITemplateService ServiceHelper.createTemplateService()

com.trs.service.impl 中 ITemplateService 的使用

实现 ITemplateService 的 com.trs.service.impl 中的类
 class TemplateService
Title: TRS 内容协作平台（TRS WCM）
Description:
模板服务提供对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IUserService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IUserService
的使用

使用 IUserService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IUserService 的使用

返回 IUserService 的 com.trs.service 中的方法
static IUserService ServiceHelper.createUserService()
产生IUserService的实例

com.trs.service.impl 中 IUserService 的使用

实现 IUserService 的 com.trs.service.impl 中的类
 class UserService
Title: TRS 内容协作平台（TRS WCM）
Description:

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IWCMProcessService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IWCMProcessService
的使用

使用 IWCMProcessService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IWCMProcessService 的使用

返回 IWCMProcessService 的 com.trs.service 中的方法
static IWCMProcessService ServiceHelper.createWCMProcessService()
产生IWCMProcessService的实例

com.trs.service.impl 中 IWCMProcessService 的使用

实现 IWCMProcessService 的 com.trs.service.impl 中的类
 class WCMProcessServiceImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
IWCMProcessService的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.service.IWCMPublishElementService 的使用

上一个 下一个 框架 无框架

接口 com.trs.service.IWCMPublishElementService
的使用

使用 IWCMPublishElementService 的软件包
com.trs.service
com.trs.service.impl

com.trs.service 中 IWCMPublishElementService 的使用

返回 IWCMPublishElementService 的 com.trs.service 中的方法
static IWCMPublishElementService ServiceHelper.createWCMPublishElementService()
产生IWCMPublishElementSetting的实例

com.trs.service.impl 中 IWCMPublishElementService 的使用

实现 IWCMPublishElementService 的 com.trs.service.impl 中的类
 class WCMPublishElementServiceImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IWCMPublishElementService
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.ServiceHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.service.ServiceHelper
的使用

没有 com.trs.service.ServiceHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AutoDocBakService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 AutoDocBakService

java.lang.Object
    继承者  com.trs.service.impl.AutoDocBakService
所有已实现的接口：
IAutoDocBakService
public class AutoDocBakService
extends java.lang.Object
implements IAutoDocBakService

Title: TRS 内容协作平台（TRS WCM）
Description:
实现IAutoDocBakService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
AutoDocBakService()
方法摘要
AutoBakConfig | getAutoSaveConfig(int _nSiteId) 获取指定站点上所有关于文档版本自动保存的配置信息
void | removeConfig(int _nSiteId) 删除指定站点上所有关于文档版本自动保存的配置信息
AutoBakConfig | save(AutoBakConfig _currConfig) 保存站点上关于文档版本自动保存的配置信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AutoDocBakService

public AutoDocBakService()
方法详细信息

save

public AutoBakConfig save(AutoBakConfig _currConfig)
                   throws WCMException
从接口 IAutoDocBakService 复制的描述
保存站点上关于文档版本自动保存的配置信息

指定者：
接口 IAutoDocBakService 中的 save
返回：
TODO
抛出：
WCMException

removeConfig

public void removeConfig(int _nSiteId)
                  throws WCMException
从接口 IAutoDocBakService 复制的描述
删除指定站点上所有关于文档版本自动保存的配置信息

指定者：
接口 IAutoDocBakService 中的 removeConfig
抛出：
WCMException

getAutoSaveConfig

public AutoBakConfig getAutoSaveConfig(int _nSiteId)
                                throws WCMException
从接口 IAutoDocBakService 复制的描述
获取指定站点上所有关于文档版本自动保存的配置信息

指定者：
接口 IAutoDocBakService 中的 getAutoSaveConfig
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BookMarkService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 BookMarkService

java.lang.Object
    继承者  com.trs.service.impl.BookMarkService
所有已实现的接口：
IBookMarkService
public class BookMarkService
extends java.lang.Object
implements IBookMarkService

Title: TRS 内容协作平台（TRS WCM）
Description:
实现IBookMarkService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BookMarkService()
方法摘要
void | cancelShares(int _nObjType, java.lang.String _sObjIds) 取消共享
boolean | deleteBookMark(int _nBookMarkId) 删除指定的书签
boolean | deleteBookMark(java.lang.String _sBookMarkIds) 删除指定的书签集合
boolean | deleteMarkKind(int _nMarkKindId) 删除指定的书签文件夹
boolean | deleteMarkKind(java.lang.String _sBookMarkIds) 删除指定的书签文件夹集合
BookMarks | getBookMarks(int _nMarkKindId) 根据传入的MarkKind ID，获取它所包含的BookMarks
BookMarks | getBookMarks(int _nMarkKindId, WCMFilter _filter) 根据传入的MarkKind ID，获取它所包含的BookMarks
BookMarks | getBookMarks(WCMFilter _filter) 获取BookMarks集合
MarkKinds | getChildren(int _nMarkKindId, WCMFilter _filter) 根据传入的MarkKind ID，获取它的子MarkKinds
BookMarks | getSharedBookMarks(User _currUser, WCMFilter _fliter) 获取所有共享的书签
Groups | getSharedGroups(int _nObjType, int _nObjId) 获取共享组织
MarkKinds | getSharedMarkKinds(User _currUser, WCMFilter _filter) 获取所有共享的书签文件夹
Users | getSharedUsers(int _nObjType, int _nObjId) 获取共享用户
void | moveBookMark(int _aBookMark, int _aMarkKind) 移动指定书签到目标书签文件夹下
void | moveBookMark(java.lang.String _sBookMarkIds, int _nMarkKindId) 移动指定书签集合到目标书签文件夹下
Reports | moveBookMarks(java.lang.String _sMarkIds, int _nMarkKindId) 移动指定的书签集合到目标书签夹下.
void | moveMarkKind(int _nMarkKindId, int _nNewParentId) 移动指定书签文件夹到一个新的书签文件夹下
void | moveMarkKind(java.lang.String _sMarkKindIds, int _nNewParentId) 移动指定书签文件夹集合到一个新的书签文件夹下
BookMark | save(BookMark _aBookMark) 保存一个BookMark
MarkKind | save(MarkKind _aMarkKind) 保存一个MarkKind
void | shareTo(int _nObjType, java.lang.String _sObjIds, int _nShareObjType, java.lang.String _sShareObjIds) 设置共享
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BookMarkService

public BookMarkService()
方法详细信息

save

public BookMark save(BookMark _aBookMark)
              throws WCMException
从接口 IBookMarkService 复制的描述
保存一个BookMark

指定者：
接口 IBookMarkService 中的 save
返回：
@throws WCMException
抛出：
WCMException

deleteBookMark

public boolean deleteBookMark(int _nBookMarkId)
                       throws WCMException
从接口 IBookMarkService 复制的描述
删除指定的书签

指定者：
接口 IBookMarkService 中的 deleteBookMark
返回：
@throws WCMException
抛出：
WCMException

deleteBookMark

public boolean deleteBookMark(java.lang.String _sBookMarkIds)
                       throws WCMException
从接口 IBookMarkService 复制的描述
删除指定的书签集合

指定者：
接口 IBookMarkService 中的 deleteBookMark
返回：
@throws WCMException
抛出：
WCMException

deleteMarkKind

public boolean deleteMarkKind(int _nMarkKindId)
                       throws WCMException
从接口 IBookMarkService 复制的描述
删除指定的书签文件夹

指定者：
接口 IBookMarkService 中的 deleteMarkKind
返回：
@throws WCMException
抛出：
WCMException

deleteMarkKind

public boolean deleteMarkKind(java.lang.String _sBookMarkIds)
                       throws WCMException
从接口 IBookMarkService 复制的描述
删除指定的书签文件夹集合

指定者：
接口 IBookMarkService 中的 deleteMarkKind
返回：
@throws WCMException
抛出：
WCMException

moveBookMark

public void moveBookMark(int _aBookMark,
                         int _aMarkKind)
                  throws WCMException
从接口 IBookMarkService 复制的描述
移动指定书签到目标书签文件夹下

指定者：
接口 IBookMarkService 中的 moveBookMark
抛出：
WCMException

moveBookMark

public void moveBookMark(java.lang.String _sBookMarkIds,
                         int _nMarkKindId)
                  throws WCMException
从接口 IBookMarkService 复制的描述
移动指定书签集合到目标书签文件夹下

指定者：
接口 IBookMarkService 中的 moveBookMark
抛出：
WCMException

moveBookMarks

public Reports moveBookMarks(java.lang.String _sMarkIds,
                             int _nMarkKindId)
                      throws WCMException
从接口 IBookMarkService 复制的描述
移动指定的书签集合到目标书签夹下.

指定者：
接口 IBookMarkService 中的 moveBookMarks
参数：
_sMarkIds - 要移动的书签ID序列,以字符','分隔.
_nMarkKindId - 目标书签夹id.
返回：
处理结果.
抛出：
WCMException

getBookMarks

public BookMarks getBookMarks(int _nMarkKindId)
                       throws WCMException
从接口 IBookMarkService 复制的描述
根据传入的MarkKind ID，获取它所包含的BookMarks

指定者：
接口 IBookMarkService 中的 getBookMarks
返回：
@throws WCMException
抛出：
WCMException

getBookMarks

public BookMarks getBookMarks(int _nMarkKindId,
                              WCMFilter _filter)
                       throws WCMException
从接口 IBookMarkService 复制的描述
根据传入的MarkKind ID，获取它所包含的BookMarks

指定者：
接口 IBookMarkService 中的 getBookMarks
返回：
@throws WCMException
抛出：
WCMException

getBookMarks

public BookMarks getBookMarks(WCMFilter _filter)
                       throws WCMException
从接口 IBookMarkService 复制的描述
获取BookMarks集合

指定者：
接口 IBookMarkService 中的 getBookMarks
参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getChildren

public MarkKinds getChildren(int _nMarkKindId,
                             WCMFilter _filter)
                      throws WCMException
从接口 IBookMarkService 复制的描述
根据传入的MarkKind ID，获取它的子MarkKinds

指定者：
接口 IBookMarkService 中的 getChildren
返回：
@throws WCMException
抛出：
WCMException

getSharedBookMarks

public BookMarks getSharedBookMarks(User _currUser,
                                    WCMFilter _fliter)
                             throws WCMException
从接口 IBookMarkService 复制的描述
获取所有共享的书签

指定者：
接口 IBookMarkService 中的 getSharedBookMarks
返回：
@throws WCMException
抛出：
WCMException

getSharedMarkKinds

public MarkKinds getSharedMarkKinds(User _currUser,
                                    WCMFilter _filter)
                             throws WCMException
从接口 IBookMarkService 复制的描述
获取所有共享的书签文件夹

指定者：
接口 IBookMarkService 中的 getSharedMarkKinds
返回：
@throws WCMException
抛出：
WCMException

moveMarkKind

public void moveMarkKind(int _nMarkKindId,
                         int _nNewParentId)
                  throws WCMException
从接口 IBookMarkService 复制的描述
移动指定书签文件夹到一个新的书签文件夹下

指定者：
接口 IBookMarkService 中的 moveMarkKind
抛出：
WCMException

save

public MarkKind save(MarkKind _aMarkKind)
              throws WCMException
从接口 IBookMarkService 复制的描述
保存一个MarkKind

指定者：
接口 IBookMarkService 中的 save
返回：
@throws WCMException 如果保存失败，则抛出异常。如果成功则返回这个MarkKind
抛出：
WCMException

getSharedGroups

public Groups getSharedGroups(int _nObjType,
                              int _nObjId)
                       throws WCMException
从接口 IBookMarkService 复制的描述
获取共享组织

指定者：
接口 IBookMarkService 中的 getSharedGroups
返回：
@throws WCMException
抛出：
WCMException

getSharedUsers

public Users getSharedUsers(int _nObjType,
                            int _nObjId)
                     throws WCMException
从接口 IBookMarkService 复制的描述
获取共享用户

指定者：
接口 IBookMarkService 中的 getSharedUsers
返回：
@throws WCMException
抛出：
WCMException

cancelShares

public void cancelShares(int _nObjType,
                         java.lang.String _sObjIds)
                  throws WCMException
从接口 IBookMarkService 复制的描述
取消共享

指定者：
接口 IBookMarkService 中的 cancelShares
抛出：
WCMException

moveMarkKind

public void moveMarkKind(java.lang.String _sMarkKindIds,
                         int _nNewParentId)
                  throws WCMException
从接口 IBookMarkService 复制的描述
移动指定书签文件夹集合到一个新的书签文件夹下

指定者：
接口 IBookMarkService 中的 moveMarkKind
抛出：
WCMException

shareTo

public void shareTo(int _nObjType,
                    java.lang.String _sObjIds,
                    int _nShareObjType,
                    java.lang.String _sShareObjIds)
             throws WCMException
从接口 IBookMarkService 复制的描述
设置共享

指定者：
接口 IBookMarkService 中的 shareTo
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CDSServiceImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 CDSServiceImpl

java.lang.Object
    继承者  com.trs.service.impl.CDSServiceImpl
所有已实现的接口：
ICDSService
public class CDSServiceImpl
extends java.lang.Object
implements ICDSService

Title: TRS 内容协作平台（TRS WCM）
Description:
CDS Service
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CDSServiceImpl()
方法摘要
java.lang.String | getAllChannelsXML(boolean _bIncludeChildren) 获取系统树状结构信息
java.lang.String | getChannelsXML(BaseChannel _oBaseChannel, boolean _bIncludeChildren) 获取指定站点或频道的树状结构信息
java.lang.String | getSystemInfo(java.lang.String _sCDSType, int _nParentSiteId, int _nParentChannelId) 根据CDS传入的参数，获取指定的系统信息
java.lang.String | getSystemInfo(java.lang.String _sCDSType, int _nParentSiteId, int _nParentChannelId, java.lang.String _sSiteFields, java.lang.String _sChannelFields) 根据CDS传入的参数，获取指定的系统信息
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CDSServiceImpl

public CDSServiceImpl()
方法详细信息

getSystemInfo

public java.lang.String getSystemInfo(java.lang.String _sCDSType,
                                      int _nParentSiteId,
                                      int _nParentChannelId)
                               throws WCMException
从接口 ICDSService 复制的描述
根据CDS传入的参数，获取指定的系统信息

指定者：
接口 ICDSService 中的 getSystemInfo
参数：
_sCDSType - CDS获取数据的模式
_nParentSiteId - 父站点ID
_nParentChannelId - 父频道ID
返回：
以XML方式组织的系统信息
抛出：
WCMException - TODO

getSystemInfo

public java.lang.String getSystemInfo(java.lang.String _sCDSType,
                                      int _nParentSiteId,
                                      int _nParentChannelId,
                                      java.lang.String _sSiteFields,
                                      java.lang.String _sChannelFields)
                               throws WCMException
从接口 ICDSService 复制的描述
根据CDS传入的参数，获取指定的系统信息

指定者：
接口 ICDSService 中的 getSystemInfo
参数：
_sCDSType - CDS获取数据的模式
_nParentSiteId - 父站点ID
_nParentChannelId - 父频道ID
_sSiteFields - 站点字段列表
_sChannelFields - 显示的频道字段列表
返回：
抛出：
WCMException

getChannelsXML

public java.lang.String getChannelsXML(BaseChannel _oBaseChannel,
                                       boolean _bIncludeChildren)
                                throws WCMException
从接口 ICDSService 复制的描述
获取指定站点或频道的树状结构信息

指定者：
接口 ICDSService 中的 getChannelsXML
参数：
_oBaseChannel - 指定站点或频道
_bIncludeChildren - 是否包括子节点
返回：
以XML方式组织的系统信息
抛出：
WCMException - TODO

getAllChannelsXML

public java.lang.String getAllChannelsXML(boolean _bIncludeChildren)
                                   throws WCMException
从接口 ICDSService 复制的描述
获取系统树状结构信息

指定者：
接口 ICDSService 中的 getAllChannelsXML
参数：
_bIncludeChildren - TODO
返回：
以XML方式组织的系统信息
抛出：
WCMException - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChannelService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 ChannelService

java.lang.Object
    继承者  com.trs.service.impl.ChannelService
所有已实现的接口：
IChannelService
public class ChannelService
extends java.lang.Object
implements IChannelService

Title: TRS 内容协作平台（TRS WCM）
Description:

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ChannelService()
方法摘要
void | addGroupsToSite(java.lang.String _sGroupIds, WebSite _site) 给指定的站点添加指定的用户组
void | addRolesToSite(java.lang.String _sRoleIds, WebSite _site) 给指定的站点添加指定的角色
void | addSitesToGroup(java.lang.String _sSiteIds, Group _group) 给指定的用户组添加指定的站点
void | addSitesToUser(java.lang.String _sSiteIds, User _currUser) 给指定的用户添加指定的站点
void | addUsersToSite(java.lang.String _sUserIds, WebSite _currSite) 给指定的站点添加指定的用户
Reports | createFrom(Channel _srcChannel, BaseChannel _parent) 频道的类似创建的实现 从指定的频道获取频道的相关属性,创建一个新的频道 新频道与源频道有基本相同的属性.
Reports | createFrom(int _nChannelId, BaseChannel _parent) 频道的类似创建的实现
Reports | createFrom(int _nSiteId, boolean _bWithRelated) 站点的类似创建的实现
Reports | createFrom(WebSite _srcSite, boolean _bWithRelated) 站点的类似创建的实现 从指定的站点获取站点的相关属性,创建一个新的站点.
boolean | delete(BaseChannel _oChannel, boolean _bDrop) 删除站点/频道
boolean | delete(Channels _currChannels, boolean _bDrop) 删除频道集合
boolean | delete(java.lang.String _sChannelIds, boolean _bDrop) 根据频道id列表，删除频道集合
void | deleteChannelSyn(int _nChnlSynId)
void | deleteChannelSyns(java.lang.String _sChnlSynIds)
void | deleteContentLink(ContentLink _contentLink)
void | deleteContentLinks(ContentLinks _contentLinks)
void | deleteExtFields(BaseChannel _siteOrChannel, java.lang.String _extFieldIds, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
void | deleteExtFiled(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bDeleteInherited) 删除指定站点/频道下的指定扩展字段
boolean | deleteReplace(Replace _aReplace) 删除替换内容对象
boolean | deleteReplace(Replaces _aReplaces) 删除替换内容对象集合
void | emptyRecycleBin(int _nChannelId) 清空指定频道的文档回收站 删除指定频道回收站中的所有文档.
java.lang.String | export(BaseChannel _fromChannel, boolean _bWithChildren, boolean _bWithRelated) 将WCM的站点、频道导出成为WCM XML标准格式的字符串
java.lang.String | export(Channels _fromChannels, boolean _bWithChildren, boolean _bWithRelated)
java.lang.String | export(WebSites _fromWebSites, boolean _bWithChildren, boolean _bWithRelated)
java.lang.String | exportChannels(java.lang.String _sChnlIds, boolean _bWithChildren, boolean _bWithRelated)
java.lang.String | exportSites(java.lang.String _sSiteIds, boolean _bWithChildren, boolean _bWithRelated)
ChannelSyns | getChannelSyns(int _nChannelId, WCMFilter _filter)
java.util.List | getChildren(BaseChannel _oChannel) 获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限
java.util.List | getChildren(BaseChannel _oChannel, int _nRightIndex) 获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)
java.util.List | getChildren(BaseChannel _parentChannel, int _nRightIndex, int _nChannelType) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
java.util.List | getChildren(BaseChannel _parentChannel, int _nRightIndex, int[] _nArrayChannelType) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
java.util.List | getChildren(BaseChannel _parentChannel, int _nRightIndex, int[] _nArrayChannelType, java.lang.StringBuffer _sbNoRightIds) 获取当前站点/频道的子频道集合(不包含已删除的子频道)
ContentLinks | getContentLinks(WebSite _site, WCMFilter _filter)
Documents | getDocuments(BaseChannel _oChannel) 获取当前站点/频道下的有效文档
Documents | getDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的有效文档
Documents | getDocuments(int _nChnlId) 获取当前频道下的有效文档
Documents | getDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的有效文档
ContentExtFields | getExtFields(BaseChannel _siteOrChannel, WCMFilter _filter) 获取指定站点/频道下的扩展字段.
Channels | getRecycleChannels(BaseChannel _oChannel) 获取当前站点/频道下的废弃频道集合
Channels | getRecycleChannels(BaseChannel _oChannel, WCMFilter _filter) 获取当前站点/频道下的废弃频道集合
Documents | getRecycleDocuments(BaseChannel _oChannel, WCMFilter _docFilter) 获取当前站点/频道下的废稿
Documents | getRecycleDocuments(int _nChnlId) 获取当前频道下的废稿
Documents | getRecycleDocuments(int _nChnlId, WCMFilter _filter) 获取当前频道下的废稿
WebSites | getRecycleSites(WCMFilter _filter) 获取系统回收站中的站点集合
Replaces | getReplaces(Channel _oChannel, WCMFilter _filter) 获取指定频道下的替换内容对象集合
Groups | getSiteGroups(WebSite _site, WCMFilter _filter) 获取指定站点的所属用户组集合
Roles | getSiteRoles(WebSite _site, WCMFilter _filter) 获取指定站点的所属角色集合
Users | getSiteUsers(WebSite _currSite, WCMFilter _currFilter) 获取指定站点的所属用户集合
Channels | getSynSrcChannel(Channel _currChannel) 获取给当前频道分发文档的频道集合
Channels | getSynToChannel(Channel _currChannel) 获取当前频道分发文档的目标频道集合
WebSites | getUserSites(User _currUser, WCMFilter _currFilter) 获取指定用户所属的站点集合
WebSites | getWebSites(WCMFilter _filter) 获取当前用户可以看见的站点
Reports | importFromFile(java.lang.String _sFile, java.lang.String _sXslFile, BaseChannel _destSiteOrChnl) 站点、频道导出、类似创建相关的方法
boolean | isVisible(User _currUser, BaseChannel _currChannel) 判断指定的频道对象对于用户是否可见
boolean | isVisible(User _currUser, BaseChannel _currChannel, int _nRightIndex) 判断在指定的权限值下，指定的频道对象对于用户是否可见
void | moveTo(Channel _fromChannel, Channel _toChannel, int _nMoveToType) 将频道移动到另一个频道下，作为该频道的子频道或者兄弟
void | moveTo(Channel _fromChannel, WebSite _toWebSite, int _nMoveToType) 将频道移动到站点下，作为站点的一级子频道
void | moveTo(WebSite _fromWebSite, WebSite _toWebSite, int _nMoveToType) 将站点移动到另一个站点下，作为该站点的子站点或者兄弟
void | removeGroupsFromSite(java.lang.String _sGroupIds, WebSite _site) 删除指定的站点中的指定用户组
void | removeRolesFromSite(java.lang.String _sRoleIds, WebSite _site)
void | removeSitesFromGroup(java.lang.String _sSiteIds, Group _group) 删除指定的用户组上指定的站点
void | removeSitesFromUser(java.lang.String _sSiteIds, User _currUser) 删除指定的用户上指定的站点
void | removeUsersFromSite(java.lang.String _sUserIds, WebSite _currSite) 删除指定的站点中的指定用户
void | restore(BaseChannel _oChannel) 恢复站点/频道
void | restore(Channels _currChannels) 恢复频道集合
void | restore(WebSites _currSites) 恢复站点集合
void | restoreAllInRecycleBin(int _nChannelId) 还原指定频道回收站中的所有文档
BaseChannel | save(BaseChannel _currBaseChannel) 保存指定的站点/频道
ChannelSyn | saveChannelSyn(ChannelSyn _currChnlSyn)
ChannelSyns | saveChannelSyns(ChannelSyn _currChnlSyn, java.lang.String _sToChannelIds)
ContentLink | saveContentLink(ContentLink _contentLink)
ContentExtField | saveExtField(BaseChannel _siteOrChannel, ContentExtField _extfield, boolean _bInherited) 保存指定的扩展字段
Replace | saveReplace(Replace _aReplace) 保存替换内容对象
void | setSiteMembers(int _nSiteId, int _nMemberType, java.lang.String _sMemberIds) 设置站点成员,一个站点成员可以是系统中的一个用户或一个组织
void | setSiteMembers(WebSite _site, int _nMemberType, java.lang.String _sMemberIds) 设置站点成员,一个站点成员可以是系统中的一个用户或一个组织
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelService

public ChannelService()
方法详细信息

getChildren

public java.util.List getChildren(BaseChannel _parentChannel,
                                  int _nRightIndex,
                                  int _nChannelType)
                           throws WCMException
获取当前站点/频道的子频道集合(不包含已删除的子频道)

指定者：
接口 IChannelService 中的 getChildren
参数：
_oIChannel - 当前站点/频道对象
_nRightIndex - 权限值索引
_nChannelType - 频道类型(指定只取该类型的频道Channel.TYPE_NORM等)
返回：
子频道集合
抛出：
WCMException

getChildren

public java.util.List getChildren(BaseChannel _parentChannel,
                                  int _nRightIndex,
                                  int[] _nArrayChannelType)
                           throws WCMException
获取当前站点/频道的子频道集合(不包含已删除的子频道)

指定者：
接口 IChannelService 中的 getChildren
参数：
_oIChannel - 当前站点/频道对象
_nRightIndex - 权限值索引
_nChannelType - 频道类型(指定只取该类型的频道Channel.TYPE_NORM等)
返回：
子频道集合
抛出：
WCMException

getChildren

public java.util.List getChildren(BaseChannel _parentChannel,
                                  int _nRightIndex,
                                  int[] _nArrayChannelType,
                                  java.lang.StringBuffer _sbNoRightIds)
                           throws WCMException
获取当前站点/频道的子频道集合(不包含已删除的子频道)

指定者：
接口 IChannelService 中的 getChildren
参数：
_oIChannel - 当前站点/频道对象
_nRightIndex - 权限值索引
_nChannelType - 频道类型(指定只取该类型的频道Channel.TYPE_NORM等)
_sbNoRightIds - 可见但无指定操作权限的频道ID
返回：
子频道集合
抛出：
WCMException

getChildren

public java.util.List getChildren(BaseChannel _oChannel,
                                  int _nRightIndex)
                           throws WCMException
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)

指定者：
接口 IChannelService 中的 getChildren
参数：
_oIChannel - 当前站点/频道对象
_nRightIndex - 权限值索引
返回：
子频道集合
抛出：
WCMException

getChildren

public java.util.List getChildren(BaseChannel _oChannel)
                           throws WCMException
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限

指定者：
接口 IChannelService 中的 getChildren
参数：
_oChannel - 当前站点/频道
抛出：
WCMException

getRecycleChannels

public Channels getRecycleChannels(BaseChannel _oChannel)
                            throws WCMException
获取当前站点/频道下的废弃频道集合

指定者：
接口 IChannelService 中的 getRecycleChannels
参数：
_oChannel - 当前站点/频道
抛出：
WCMException

getRecycleChannels

public Channels getRecycleChannels(BaseChannel _oChannel,
                                   WCMFilter _filter)
                            throws WCMException
获取当前站点/频道下的废弃频道集合

指定者：
接口 IChannelService 中的 getRecycleChannels
参数：
_oChannel - 当前站点/频道
_filter - 过滤器
返回：
频道集合
抛出：
WCMException

getDocuments

public Documents getDocuments(int _nChnlId)
                       throws WCMException
获取当前频道下的有效文档

指定者：
接口 IChannelService 中的 getDocuments
参数：
_nChnlId - 当前频道的id
抛出：
WCMException

getDocuments

public Documents getDocuments(int _nChnlId,
                              WCMFilter _filter)
                       throws WCMException
获取当前频道下的有效文档

指定者：
接口 IChannelService 中的 getDocuments
参数：
_nChnlId - 当前频道的id
_filter - 过滤器,额外的查询条件
抛出：
WCMException

getDocuments

public Documents getDocuments(BaseChannel _oChannel)
                       throws WCMException
获取当前站点/频道下的有效文档

指定者：
接口 IChannelService 中的 getDocuments
参数：
_oChannel - 当前站点/频道
抛出：
WCMException

getDocuments

public Documents getDocuments(BaseChannel _oChannel,
                              WCMFilter _docFilter)
                       throws WCMException
获取当前站点/频道下的有效文档

指定者：
接口 IChannelService 中的 getDocuments
参数：
_oChannel - 当前站点/频道
_filter - 过滤器,额外的查询条件
抛出：
WCMException

getRecycleDocuments

public Documents getRecycleDocuments(int _nChnlId)
                              throws WCMException
获取当前频道下的废稿

指定者：
接口 IChannelService 中的 getRecycleDocuments
参数：
_nChnlId - 当前频道的id
抛出：
WCMException

getRecycleDocuments

public Documents getRecycleDocuments(int _nChnlId,
                                     WCMFilter _filter)
                              throws WCMException
获取当前频道下的废稿

指定者：
接口 IChannelService 中的 getRecycleDocuments
参数：
_nChnlId - 当前频道的id
_filter - 过滤器,额外的查询条件
抛出：
WCMException

getRecycleDocuments

public Documents getRecycleDocuments(BaseChannel _oChannel,
                                     WCMFilter _docFilter)
                              throws WCMException
获取当前站点/频道下的废稿

指定者：
接口 IChannelService 中的 getRecycleDocuments
参数：
_oChannel - 当前站点/频道
_docFilter - 过滤器,额外的查询条件
抛出：
WCMException

delete

public boolean delete(java.lang.String _sChannelIds,
                      boolean _bDrop)
               throws WCMException
根据频道id列表，删除频道集合

指定者：
接口 IChannelService 中的 delete
参数：
_sChannelIds - 要删除的频道id序列
_bDrop - 是否删除数据库中的数据,true为删除,不可恢复
返回：
操作成功返回true
抛出：
WCMException

delete

public boolean delete(Channels _currChannels,
                      boolean _bDrop)
               throws WCMException
删除频道集合

指定者：
接口 IChannelService 中的 delete
参数：
_currChannels - 要删除的集合数据
_bDrop - 是否删除数据库数据,true为删除,不可恢复
抛出：
WCMException

delete

public boolean delete(BaseChannel _oChannel,
                      boolean _bDrop)
               throws WCMException
删除站点/频道

指定者：
接口 IChannelService 中的 delete
参数：
_oChannel - 将删除的站点/频道
_bDrop - 是否删除数据库中的数据,true为删除,不可恢复
抛出：
WCMException

save

public BaseChannel save(BaseChannel _currBaseChannel)
                 throws WCMException
保存指定的站点/频道

指定者：
接口 IChannelService 中的 save
参数：
_currBaseChannel - 要保存的站点/频道
抛出：
WCMException

getSynSrcChannel

public Channels getSynSrcChannel(Channel _currChannel)
                          throws WCMException
获取给当前频道分发文档的频道集合

指定者：
接口 IChannelService 中的 getSynSrcChannel
参数：
_currChannel - 当前频道
返回：
给当前频道分发文档的频道集合
抛出：
WCMException

getSynToChannel

public Channels getSynToChannel(Channel _currChannel)
                         throws WCMException
获取当前频道分发文档的目标频道集合

指定者：
接口 IChannelService 中的 getSynToChannel
参数：
_currChannel - 当前频道
返回：
抛出：
WCMException

saveReplace

public Replace saveReplace(Replace _aReplace)
                    throws WCMException
从接口 IChannelService 复制的描述
保存替换内容对象

指定者：
接口 IChannelService 中的 saveReplace
参数：
_aReplace - 要保存的替换内容对象
返回：
@throws WCMException
抛出：
WCMException

deleteReplace

public boolean deleteReplace(Replace _aReplace)
                      throws WCMException
从接口 IChannelService 复制的描述
删除替换内容对象

指定者：
接口 IChannelService 中的 deleteReplace
参数：
_aReplace - 要删除的对象
返回：
@throws WCMException
抛出：
WCMException

deleteReplace

public boolean deleteReplace(Replaces _aReplaces)
                      throws WCMException
从接口 IChannelService 复制的描述
删除替换内容对象集合

指定者：
接口 IChannelService 中的 deleteReplace
参数：
_aReplaces - 要删除的集合
返回：
@throws WCMException
抛出：
WCMException

getReplaces

public Replaces getReplaces(Channel _oChannel,
                            WCMFilter _filter)
                     throws WCMException
从接口 IChannelService 复制的描述
获取指定频道下的替换内容对象集合

指定者：
接口 IChannelService 中的 getReplaces
参数：
_oChannel - 指定频道
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

restore

public void restore(BaseChannel _oChannel)
             throws WCMException
恢复站点/频道

指定者：
接口 IChannelService 中的 restore
参数：
_oChannel - 要恢复的站点/频道
抛出：
WCMException

restore

public void restore(Channels _currChannels)
             throws WCMException
从接口 IChannelService 复制的描述
恢复频道集合

指定者：
接口 IChannelService 中的 restore
抛出：
WCMException

restore

public void restore(WebSites _currSites)
             throws WCMException
从接口 IChannelService 复制的描述
恢复站点集合

指定者：
接口 IChannelService 中的 restore
抛出：
WCMException

getWebSites

public WebSites getWebSites(WCMFilter _filter)
                     throws WCMException
获取当前用户可以看见的站点

指定者：
接口 IChannelService 中的 getWebSites
参数：
_filter - 额外的查询条件
返回：
抛出：
WCMException

moveTo

public void moveTo(Channel _fromChannel,
                   WebSite _toWebSite,
                   int _nMoveToType)
            throws WCMException
从接口 IChannelService 复制的描述
将频道移动到站点下，作为站点的一级子频道

指定者：
接口 IChannelService 中的 moveTo
抛出：
WCMException

moveTo

public void moveTo(Channel _fromChannel,
                   Channel _toChannel,
                   int _nMoveToType)
            throws WCMException
从接口 IChannelService 复制的描述
将频道移动到另一个频道下，作为该频道的子频道或者兄弟

指定者：
接口 IChannelService 中的 moveTo
参数：
_fromChannel - 要移动的频道
_toChannel - 要移动到的目标频道
_nMoveToType - 移动类型，通过Channel中的常量表示，MOVE_AS_BROTHER为作为目标频道的兄弟频道， MOVE_AS_CHILD为作为目标频道的子频道
抛出：
WCMException

moveTo

public void moveTo(WebSite _fromWebSite,
                   WebSite _toWebSite,
                   int _nMoveToType)
            throws WCMException
从接口 IChannelService 复制的描述
将站点移动到另一个站点下，作为该站点的子站点或者兄弟

指定者：
接口 IChannelService 中的 moveTo
参数：
_fromWebSite - 要移动的站点
_toWebSite - 要移动到的目标站点
_nMoveToType - 移动类型，1为作为目标站点的兄弟站点，2为作为目标站点的子站点
目前暂时不支持站点的移动
抛出：
WCMException

getUserSites

public WebSites getUserSites(User _currUser,
                             WCMFilter _currFilter)
                      throws WCMException
从接口 IChannelService 复制的描述
获取指定用户所属的站点集合

指定者：
接口 IChannelService 中的 getUserSites
参数：
_currUser - 指定用户对象（User）
_currFilter - 过滤器,额外的查询条件
返回：
站点集合(WebSites)
抛出：
WCMException - 如果指定的用户无效，抛出参数异常

getSiteUsers

public Users getSiteUsers(WebSite _currSite,
                          WCMFilter _currFilter)
                   throws WCMException
从接口 IChannelService 复制的描述
获取指定站点的所属用户集合

指定者：
接口 IChannelService 中的 getSiteUsers
参数：
_currSite - 指定站点对象
_currFilter - 过滤器,额外的查询条件
返回：
用户集合（Users）
抛出：
WCMException - 如果指定的站点无效，抛出参数异常

addUsersToSite

public void addUsersToSite(java.lang.String _sUserIds,
                           WebSite _currSite)
                    throws WCMException
从接口 IChannelService 复制的描述
给指定的站点添加指定的用户

指定者：
接口 IChannelService 中的 addUsersToSite
参数：
_sUserIds - 指定的用户ID序列
_currSite - 指定的站点对象（WebSite）
抛出：
WCMException - 如果指定的站点无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

addSitesToUser

public void addSitesToUser(java.lang.String _sSiteIds,
                           User _currUser)
                    throws WCMException
从接口 IChannelService 复制的描述
给指定的用户添加指定的站点

指定者：
接口 IChannelService 中的 addSitesToUser
参数：
_sSiteIds - 指定站点ID序列
_currUser - 指定的用户
抛出：
WCMException - 如果指定的用户无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

removeUsersFromSite

public void removeUsersFromSite(java.lang.String _sUserIds,
                                WebSite _currSite)
                         throws WCMException
从接口 IChannelService 复制的描述
删除指定的站点中的指定用户

指定者：
接口 IChannelService 中的 removeUsersFromSite
参数：
_sUserIds - 指定的用户ID序列
_currSite - 指定的站点对象（WebSite）
抛出：
WCMException - 如果指定的站点无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

removeSitesFromUser

public void removeSitesFromUser(java.lang.String _sSiteIds,
                                User _currUser)
                         throws WCMException
从接口 IChannelService 复制的描述
删除指定的用户上指定的站点

指定者：
接口 IChannelService 中的 removeSitesFromUser
参数：
_sSiteIds - 指定站点ID序列
_currUser - 指定的用户
抛出：
WCMException - 如果指定的用户无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

isVisible

public boolean isVisible(User _currUser,
                         BaseChannel _currChannel)
                  throws WCMException
从接口 IChannelService 复制的描述
判断指定的频道对象对于用户是否可见

指定者：
接口 IChannelService 中的 isVisible
参数：
_currUser - 指定的用户
_currChannel - 指定的频道（可以是WebSite也可以是Channel）
返回：
如果可见，返回true;否则返回false
抛出：
WCMException

isVisible

public boolean isVisible(User _currUser,
                         BaseChannel _currChannel,
                         int _nRightIndex)
                  throws WCMException
从接口 IChannelService 复制的描述
判断在指定的权限值下，指定的频道对象对于用户是否可见

指定者：
接口 IChannelService 中的 isVisible
参数：
_currUser - 指定的用户
_currChannel - 指定的频道（可以是WebSite也可以是Channel）
_nRightIndex - 指定的权限值（定义在WCMRightTypes中）
返回：
如果可见，返回true;否则返回false
抛出：
WCMException

importFromFile

public Reports importFromFile(java.lang.String _sFile,
                              java.lang.String _sXslFile,
                              BaseChannel _destSiteOrChnl)
                       throws WCMException
站点、频道导出、类似创建相关的方法

指定者：
接口 IChannelService 中的 importFromFile
参数：
_sFile - 导入的数据源文件
_sXslFile - 如果要转换的XML文件,需要提供相应的XSL文件
_destSiteOrChnl - 导入的父节点(可以是站点/频道)
返回：
@throws WCMException
抛出：
WCMException

export

public java.lang.String export(BaseChannel _fromChannel,
                               boolean _bWithChildren,
                               boolean _bWithRelated)
                        throws WCMException
从接口 IChannelService 复制的描述
将WCM的站点、频道导出成为WCM XML标准格式的字符串

指定者：
接口 IChannelService 中的 export
参数：
_fromChannel - 要导出的根频道，可能是站点，也可能是频道
_bWithChildren - 是否导出子节点，true为导出，false为不导出
_bWithRelated -
  • 是否导入相关对象，true为导出，false为不导出
  • 相关对象包括模板和扩展字段，频道导出时不导出模板
    返回：
    WCM XML标准格式的文件名，为temp目录下的文件
    抛出：
    WCMException

    • export

    public java.lang.String export(WebSites _fromWebSites,
                               boolean _bWithChildren,
                               boolean _bWithRelated)
                        throws WCMException
    指定者：
    接口 IChannelService 中的 export
    抛出：
    WCMException

    export

    public java.lang.String export(Channels _fromChannels,
                               boolean _bWithChildren,
                               boolean _bWithRelated)
                        throws WCMException
    指定者：
    接口 IChannelService 中的 export
    抛出：
    WCMException

    exportChannels

    public java.lang.String exportChannels(java.lang.String _sChnlIds,
                                       boolean _bWithChildren,
                                       boolean _bWithRelated)
                                throws WCMException
    指定者：
    接口 IChannelService 中的 exportChannels
    抛出：
    WCMException

    exportSites

    public java.lang.String exportSites(java.lang.String _sSiteIds,
                                    boolean _bWithChildren,
                                    boolean _bWithRelated)
                             throws WCMException
    指定者：
    接口 IChannelService 中的 exportSites
    抛出：
    WCMException

    getContentLinks

    public ContentLinks getContentLinks(WebSite _site,
                                    WCMFilter _filter)
                             throws WCMException
    指定者：
    接口 IChannelService 中的 getContentLinks
    抛出：
    WCMException

    saveContentLink

    public ContentLink saveContentLink(ContentLink _contentLink)
                            throws WCMException
    指定者：
    接口 IChannelService 中的 saveContentLink
    抛出：
    WCMException

    deleteContentLink

    public void deleteContentLink(ContentLink _contentLink)
                       throws WCMException
    指定者：
    接口 IChannelService 中的 deleteContentLink
    抛出：
    WCMException

    deleteContentLinks

    public void deleteContentLinks(ContentLinks _contentLinks)
                        throws WCMException
    指定者：
    接口 IChannelService 中的 deleteContentLinks
    抛出：
    WCMException

    deleteChannelSyn

    public void deleteChannelSyn(int _nChnlSynId)
                      throws WCMException
    指定者：
    接口 IChannelService 中的 deleteChannelSyn
    抛出：
    WCMException

    deleteChannelSyns

    public void deleteChannelSyns(java.lang.String _sChnlSynIds)
                       throws WCMException
    指定者：
    接口 IChannelService 中的 deleteChannelSyns
    抛出：
    WCMException

    getChannelSyns

    public ChannelSyns getChannelSyns(int _nChannelId,
                                  WCMFilter _filter)
                           throws WCMException
    指定者：
    接口 IChannelService 中的 getChannelSyns
    抛出：
    WCMException

    saveChannelSyns

    public ChannelSyns saveChannelSyns(ChannelSyn _currChnlSyn,
                                   java.lang.String _sToChannelIds)
                            throws WCMException
    指定者：
    接口 IChannelService 中的 saveChannelSyns
    抛出：
    WCMException

    saveChannelSyn

    public ChannelSyn saveChannelSyn(ChannelSyn _currChnlSyn)
                          throws WCMException
    指定者：
    接口 IChannelService 中的 saveChannelSyn
    抛出：
    WCMException

    getRecycleSites

    public WebSites getRecycleSites(WCMFilter _filter)
                         throws WCMException
    从接口 IChannelService 复制的描述
    获取系统回收站中的站点集合

    指定者：
    接口 IChannelService 中的 getRecycleSites
    参数：
    _filter - 过滤器,额外的查询条件
    返回：
    @throws WCMException
    抛出：
    WCMException

    createFrom

    public Reports createFrom(int _nSiteId,
                          boolean _bWithRelated)
                   throws WCMException
    从接口 IChannelService 复制的描述
    站点的类似创建的实现

    指定者：
    接口 IChannelService 中的 createFrom
    参数：
    _nSiteId - 指定的源站点ID
    _bWithRelated - 是否创建相关的对象
    返回：
    @throws WCMException
    抛出：
    WCMException
    另请参见：
    IChannelService.createFrom(WebSite, boolean)

    createFrom

    public Reports createFrom(WebSite _srcSite,
                          boolean _bWithRelated)
                   throws WCMException
    从接口 IChannelService 复制的描述
    站点的类似创建的实现
    从指定的站点获取站点的相关属性,创建一个新的站点.
    新站点与源站点有基本相同的属性.

    指定者：
    接口 IChannelService 中的 createFrom
    参数：
    _srcSite - 源站点
    _bWithRelated - 是否创建相关的对象(模板,扩展字段等)
    返回：
    @throws WCMException
    抛出：
    WCMException

    createFrom

    public Reports createFrom(int _nChannelId,
                          BaseChannel _parent)
                   throws WCMException
    从接口 IChannelService 复制的描述
    频道的类似创建的实现

    指定者：
    接口 IChannelService 中的 createFrom
    参数：
    _nChannelId - 指定的源频道ID
    _parent - 新频道的父节点,可以是一个站点,也可以是一个频道
    返回：
    @throws WCMException
    抛出：
    WCMException
    另请参见：
    IChannelService.createFrom(Channel, BaseChannel)

    createFrom

    public Reports createFrom(Channel _srcChannel,
                          BaseChannel _parent)
                   throws WCMException
    从接口 IChannelService 复制的描述
    频道的类似创建的实现
    从指定的频道获取频道的相关属性,创建一个新的频道
    新频道与源频道有基本相同的属性.

    指定者：
    接口 IChannelService 中的 createFrom
    参数：
    _srcChannel - 源频道
    _parent - 新频道的父节点,可以是一个站点,也可以是一个频道
    返回：
    @throws WCMException
    抛出：
    WCMException

    addGroupsToSite

    public void addGroupsToSite(java.lang.String _sGroupIds,
                            WebSite _site)
                     throws WCMException
    从接口 IChannelService 复制的描述
    给指定的站点添加指定的用户组

    指定者：
    接口 IChannelService 中的 addGroupsToSite
    参数：
    _sGroupIds - 指定的用户组ID序列,以字符','隔开
    _site - 指定的站点对象（WebSite）
    抛出：
    WCMException - 如果指定的站点无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

    addSitesToGroup

    public void addSitesToGroup(java.lang.String _sSiteIds,
                            Group _group)
                     throws WCMException
    从接口 IChannelService 复制的描述
    给指定的用户组添加指定的站点

    指定者：
    接口 IChannelService 中的 addSitesToGroup
    参数：
    _sSiteIds - 指定站点ID序列,以字符','隔开
    _group - 指定的用户组
    抛出：
    WCMException - 如果指定的用户无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

    removeGroupsFromSite

    public void removeGroupsFromSite(java.lang.String _sGroupIds,
                                 WebSite _site)
                          throws WCMException
    从接口 IChannelService 复制的描述
    删除指定的站点中的指定用户组

    指定者：
    接口 IChannelService 中的 removeGroupsFromSite
    参数：
    _sGroupIds - 指定的用户ID序列,以字符','隔开
    _site - 指定的站点对象（WebSite）
    抛出：
    WCMException - 如果指定的站点无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

    removeSitesFromGroup

    public void removeSitesFromGroup(java.lang.String _sSiteIds,
                                 Group _group)
                          throws WCMException
    从接口 IChannelService 复制的描述
    删除指定的用户组上指定的站点

    指定者：
    接口 IChannelService 中的 removeSitesFromGroup
    参数：
    _sSiteIds - 指定站点ID序列,以字符','隔开
    _group - 指定的用户组
    抛出：
    WCMException - 如果指定的用户无效，抛出参数异常 如果指定的ID序列无效，抛出参数异常 如果当前操作的用户不是管理员，抛出权限异常

    getSiteGroups

    public Groups getSiteGroups(WebSite _site,
                            WCMFilter _filter)
                     throws WCMException
    从接口 IChannelService 复制的描述
    获取指定站点的所属用户组集合

    指定者：
    接口 IChannelService 中的 getSiteGroups
    参数：
    _site - 指定站点对象
    _filter - 过滤器,额外的查询条件
    返回：
    用户组集合（Groups）
    抛出：
    WCMException - 如果指定的站点无效，抛出参数异常

    getSiteRoles

    public Roles getSiteRoles(WebSite _site,
                          WCMFilter _filter)
                   throws WCMException
    从接口 IChannelService 复制的描述
    获取指定站点的所属角色集合

    指定者：
    接口 IChannelService 中的 getSiteRoles
    参数：
    _site - 指定站点对象
    _filter - 过滤器,额外的查询条件
    返回：
    角色集合
    抛出：
    WCMException
    另请参见：
    Roles

    saveExtField

    public ContentExtField saveExtField(BaseChannel _siteOrChannel,
                                    ContentExtField _extfield,
                                    boolean _bInherited)
                             throws WCMException
    保存指定的扩展字段

    指定者：
    接口 IChannelService 中的 saveExtField
    参数：
    _siteOrChannel - 指定的站点/频道
    _extfield - 要保存的扩展字段
    _bInherited - 是否让子频道继承该字段,如果 true 则继承
    返回：
    抛出：
    WCMException

    deleteExtFields

    public void deleteExtFields(BaseChannel _siteOrChannel,
                            java.lang.String _extFieldIds,
                            boolean _bDeleteInherited)
                     throws WCMException
    删除指定站点/频道下的指定扩展字段

    指定者：
    接口 IChannelService 中的 deleteExtFields
    参数：
    _siteOrChannel - 指定的站点/频道
    _extFieldIds - 指定的扩展字段的id序列,以字符','分隔
    _bDeleteInherited - 是否同时删除子频道下相同的扩展字段,如果 true 则删除
    抛出：
    WCMException

    deleteExtFiled

    public void deleteExtFiled(BaseChannel _siteOrChannel,
                           ContentExtField _extfield,
                           boolean _bDeleteInherited)
                    throws WCMException
    删除指定站点/频道下的指定扩展字段

    指定者：
    接口 IChannelService 中的 deleteExtFiled
    参数：
    _siteOrChannel - 指定的站点/频道
    _extfield - 指定的扩展字段
    _bDeleteInherited - 是否同时删除子频道下相同的扩展字段,如果 true 则删除
    抛出：
    WCMException

    getExtFields

    public ContentExtFields getExtFields(BaseChannel _siteOrChannel,
                                     WCMFilter _filter)
                              throws WCMException
    获取指定站点/频道下的扩展字段.

    指定者：
    接口 IChannelService 中的 getExtFields
    参数：
    _siteOrChannel -
    _filter -
    返回：
    抛出：
    WCMException

    setSiteMembers

    public void setSiteMembers(int _nSiteId,
                           int _nMemberType,
                           java.lang.String _sMemberIds)
                    throws WCMException
    设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

    指定者：
    接口 IChannelService 中的 setSiteMembers
    参数：
    _nSiteId - 指定的站点id
    _nMemberType - 站点成员的类型(User.OBJ_TYPE/Group.OBJ_TYPE)
    _sMemberIds - 成员的Id序列,以字符','分隔
    抛出：
    WCMException

    setSiteMembers

    public void setSiteMembers(WebSite _site,
                           int _nMemberType,
                           java.lang.String _sMemberIds)
                    throws WCMException
    设置站点成员,一个站点成员可以是系统中的一个用户或一个组织

    指定者：
    接口 IChannelService 中的 setSiteMembers
    参数：
    _site - 指定的站点
    _nMemberType - 站点成员的类型(User.OBJ_TYPE/Group.OBJ_TYPE)
    _sMemberIds - 成员的Id序列,以字符','分隔
    抛出：
    WCMException

    addRolesToSite

    public void addRolesToSite(java.lang.String _sRoleIds,
                           WebSite _site)
                    throws WCMException
    从接口 IChannelService 复制的描述
    给指定的站点添加指定的角色

    指定者：
    接口 IChannelService 中的 addRolesToSite
    参数：
    _sRoleIds - 指定的角色ID序列，以字符 , >隔开
    _site - 指定的站点对象
    抛出：
    WCMException

    removeRolesFromSite

    public void removeRolesFromSite(java.lang.String _sRoleIds,
                                WebSite _site)
                         throws WCMException
    指定者：
    接口 IChannelService 中的 removeRolesFromSite
    抛出：
    WCMException

    emptyRecycleBin

    public void emptyRecycleBin(int _nChannelId)
                     throws WCMException
    清空指定频道的文档回收站
    删除指定频道回收站中的所有文档.

    指定者：
    接口 IChannelService 中的 emptyRecycleBin
    参数：
    _nChannelId - 指定的频道Id
    抛出：
    WCMException

    restoreAllInRecycleBin

    public void restoreAllInRecycleBin(int _nChannelId)
                            throws WCMException
    还原指定频道回收站中的所有文档

    指定者：
    接口 IChannelService 中的 restoreAllInRecycleBin
    参数：
    _nChannelId - 指定的频道Id
    抛出：
    WCMException
    概述 软件包 类 使用 树 已过时 索引 帮助
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContactService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 ContactService

java.lang.Object
    继承者  com.trs.service.impl.ContactService
所有已实现的接口：
IContactService
public class ContactService
extends java.lang.Object
implements IContactService

Title: TRS 内容协作平台（TRS WCM）
Description:
联系人服务接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ContactService()
方法摘要
Contact | addContact(Contact _contact, ContactGrp _contactGroup) 添加联系人到指定的组中
Contact | addContact(int _nContactId, int _nContactGrpId) 添加联系人到指定的组中
void | addContact(java.lang.String _sContactIds, int _nContactGrpId) 添加联系人到指定的组中
Contact | addContactFromSystemUser(int _nUserId) 导入系统用户为联系人
Contact | addContactFromSystemUser(User _user) 导入系统用户为联系人
void | changeGroup(Contact _contact, ContactGrp _srcGroup, ContactGrp _destGroup) 更改联系人所在的分组
void | changeGroup(int _nContactId, int _nSrcGroupId, int _nDestGroupId) 更改联系人所在的分组
void | deleteContact(Contact _contact) 删除指定的联系人
void | deleteContact(int _nContactId) 删除指定的联系人
void | deleteContactGroup(ContactGrp _contactGroup) 删除指定的联系人分组
void | deleteContactGroup(int _nContactGroupId) 删除指定的联系人分组
void | deleteContactGroups(ContactGrps _contactGroups) 删除指定的联系人分组
void | deleteContactGroups(java.lang.String _sContactGroupIds) 删除指定的联系人分组
void | deleteContacts(Contacts _contacts) 删除指定的联系人集合
void | deleteContacts(java.lang.String _sContactIds) 删除指定的联系人
ContactGrps | getContactGroups(WCMFilter _filter) 获取当前用户的所有联系人分组
Contacts | getContacts(WCMFilter _filter) 获取当前登录用户所有的联系人
Contacts | getContacts(WCMFilter _filter, ContactGrp _contactGroup) 获取当前登录用户某个分组的联系人
ContactGrps | getGroups(Contact _contact) 获取指定联系人所属的所有联系人分组
void | removeContact(Contact _contact, ContactGrp _contactGroup) 将指定的联系人从指定的联系人分组中删除
void | removeContact(int _nContactId, int _nContactGrpId) 将指定的联系人从指定的联系人分组中删除
void | removeContacts(java.lang.String _sContactIds, int _nContactGrpId) 将指定的联系人从指定的联系人分组中删除
Contact | saveContact(Contact _contact) 保存一个联系人
ContactGrp | saveContactGroup(ContactGrp _contactGrp) 保存一个联系人分组
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContactService

public ContactService()
方法详细信息

addContactFromSystemUser

public Contact addContactFromSystemUser(int _nUserId)
                                 throws WCMException
从接口 IContactService 复制的描述
导入系统用户为联系人

指定者：
接口 IContactService 中的 addContactFromSystemUser
参数：
_nUserId - 要导入的用户Id
返回：
@throws WCMException
抛出：
WCMException

addContactFromSystemUser

public Contact addContactFromSystemUser(User _user)
                                 throws WCMException
从接口 IContactService 复制的描述
导入系统用户为联系人

指定者：
接口 IContactService 中的 addContactFromSystemUser
参数：
_user - 要导入的用户
返回：
@throws WCMException
抛出：
WCMException

addContact

public void addContact(java.lang.String _sContactIds,
                       int _nContactGrpId)
                throws WCMException
从接口 IContactService 复制的描述
添加联系人到指定的组中

指定者：
接口 IContactService 中的 addContact
_nContactGrpId - 指定的联系人分组ID
抛出：
WCMException

addContact

public Contact addContact(int _nContactId,
                          int _nContactGrpId)
                   throws WCMException
从接口 IContactService 复制的描述
添加联系人到指定的组中

指定者：
接口 IContactService 中的 addContact
参数：
_nContactId - 要添加的联系人ID
_nContactGrpId - 指定的联系人分组ID
返回：
@throws WCMException
抛出：
WCMException

addContact

public Contact addContact(Contact _contact,
                          ContactGrp _contactGroup)
                   throws WCMException
从接口 IContactService 复制的描述
添加联系人到指定的组中

指定者：
接口 IContactService 中的 addContact
参数：
_contact - 要添加的联系人
_contactGroup - 指定的联系人分组
返回：
@throws WCMException
抛出：
WCMException

saveContact

public Contact saveContact(Contact _contact)
                    throws WCMException
从接口 IContactService 复制的描述
保存一个联系人

指定者：
接口 IContactService 中的 saveContact
参数：
_contact - 要保存的联系人
返回：
@throws WCMException
抛出：
WCMException

deleteContacts

public void deleteContacts(java.lang.String _sContactIds)
                    throws WCMException
从接口 IContactService 复制的描述
删除指定的联系人

指定者：
接口 IContactService 中的 deleteContacts
参数：
_sContactIds - 指定的联系人对象ID序列,以字符','隔开
抛出：
WCMException

deleteContacts

public void deleteContacts(Contacts _contacts)
                    throws WCMException
从接口 IContactService 复制的描述
删除指定的联系人集合

指定者：
接口 IContactService 中的 deleteContacts
参数：
_contacts - 指定的联系人集合
抛出：
WCMException

deleteContact

public void deleteContact(int _nContactId)
                   throws WCMException
从接口 IContactService 复制的描述
删除指定的联系人

指定者：
接口 IContactService 中的 deleteContact
参数：
_nContactId - 指定的联系人ID
抛出：
WCMException

deleteContact

public void deleteContact(Contact _contact)
                   throws WCMException
从接口 IContactService 复制的描述
删除指定的联系人

指定者：
接口 IContactService 中的 deleteContact
参数：
_contact - 指定的联系人
抛出：
WCMException

saveContactGroup

public ContactGrp saveContactGroup(ContactGrp _contactGrp)
                            throws WCMException
从接口 IContactService 复制的描述
保存一个联系人分组

指定者：
接口 IContactService 中的 saveContactGroup
返回：
@throws WCMException
抛出：
WCMException

deleteContactGroups

public void deleteContactGroups(java.lang.String _sContactGroupIds)
                         throws WCMException
从接口 IContactService 复制的描述
删除指定的联系人分组

指定者：
接口 IContactService 中的 deleteContactGroups
参数：
_sContactGroupIds - 指定的联系人分组对象ID序列,以字符','隔开
抛出：
WCMException

deleteContactGroups

public void deleteContactGroups(ContactGrps _contactGroups)
                         throws WCMException
从接口 IContactService 复制的描述
删除指定的联系人分组

指定者：
接口 IContactService 中的 deleteContactGroups
参数：
_contactGroups - 指定的联系人分组
抛出：
WCMException

deleteContactGroup

public void deleteContactGroup(int _nContactGroupId)
                        throws WCMException
从接口 IContactService 复制的描述
删除指定的联系人分组

指定者：
接口 IContactService 中的 deleteContactGroup
参数：
_nContactGroupId - 指定的联系人分组ID
抛出：
WCMException

deleteContactGroup

public void deleteContactGroup(ContactGrp _contactGroup)
                        throws WCMException
从接口 IContactService 复制的描述
删除指定的联系人分组

指定者：
接口 IContactService 中的 deleteContactGroup
参数：
_contactGroup - 要删除的联系人分组
抛出：
WCMException

getGroups

public ContactGrps getGroups(Contact _contact)
                      throws WCMException
从接口 IContactService 复制的描述
获取指定联系人所属的所有联系人分组

指定者：
接口 IContactService 中的 getGroups
返回：
@throws WCMException
抛出：
WCMException

getContactGroups

public ContactGrps getContactGroups(WCMFilter _filter)
                             throws WCMException
从接口 IContactService 复制的描述
获取当前用户的所有联系人分组

指定者：
接口 IContactService 中的 getContactGroups
参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getContacts

public Contacts getContacts(WCMFilter _filter,
                            ContactGrp _contactGroup)
                     throws WCMException
从接口 IContactService 复制的描述
获取当前登录用户某个分组的联系人

指定者：
接口 IContactService 中的 getContacts
参数：
_filter - 过滤器,额外的查询条件
_contactGroup - 指定的联系人分组
返回：
@throws WCMException
抛出：
WCMException
另请参见：
ContactMgr.getContacts(WCMFilter)

getContacts

public Contacts getContacts(WCMFilter _filter)
                     throws WCMException
从接口 IContactService 复制的描述
获取当前登录用户所有的联系人

指定者：
接口 IContactService 中的 getContacts
参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

removeContacts

public void removeContacts(java.lang.String _sContactIds,
                           int _nContactGrpId)
                    throws WCMException
从接口 IContactService 复制的描述
将指定的联系人从指定的联系人分组中删除

指定者：
接口 IContactService 中的 removeContacts
_nContactGrpId - 联系人分组ID
抛出：
WCMException

removeContact

public void removeContact(int _nContactId,
                          int _nContactGrpId)
                   throws WCMException
从接口 IContactService 复制的描述
将指定的联系人从指定的联系人分组中删除

指定者：
接口 IContactService 中的 removeContact
参数：
_nContactId - 指定的联系人ID
_nContactGrpId - 联系人分组ID
抛出：
WCMException

removeContact

public void removeContact(Contact _contact,
                          ContactGrp _contactGroup)
                   throws WCMException
从接口 IContactService 复制的描述
将指定的联系人从指定的联系人分组中删除

指定者：
接口 IContactService 中的 removeContact
参数：
_contact - 指定的联系人
_contactGroup - 联系人分组
抛出：
WCMException

changeGroup

public void changeGroup(int _nContactId,
                        int _nSrcGroupId,
                        int _nDestGroupId)
                 throws WCMException
从接口 IContactService 复制的描述
更改联系人所在的分组

指定者：
接口 IContactService 中的 changeGroup
参数：
_nContactId - 指定的联系人ID
_nSrcGroupId - 联系人所在的分组ID
_nDestGroupId - 更改后所在的分组ID
抛出：
WCMException

changeGroup

public void changeGroup(Contact _contact,
                        ContactGrp _srcGroup,
                        ContactGrp _destGroup)
                 throws WCMException
从接口 IContactService 复制的描述
更改联系人所在的分组

指定者：
接口 IContactService 中的 changeGroup
参数：
_contact - 指定的联系人
_srcGroup - 联系人所在的分组
_destGroup - 更改后所在的分组
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CustomizeService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 CustomizeService

java.lang.Object
    继承者  com.trs.service.impl.CustomizeService
所有已实现的接口：
ICustomizeService
public class CustomizeService
extends java.lang.Object
implements ICustomizeService

Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制服务提供对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CustomizeService()
方法摘要
boolean | delete(int _nMoudelType) 删除个人定制模块
boolean | deleteChannels(int[] _nArgChannelId) 删除个人定制的频道
boolean | deleteSites(int[] _nArgSiteId) 删除个人定制的站点集合
Channels | getChannels() 获取当前用户定制的频道集合
Channels | getChannels(int _nRightIndex) 获取当前用户定制的并且有指定操作权限的频道集合
User | getLoginUser() 获取使用service的当前用户
int[] | getMoudels() 获取当前用户定制的模块集合
WebSites | getWebSites() 获取个人定制的站点集合
boolean | hasCustomized() 当前用户是否有个性化定制
boolean | save(int _nMoudelType) 保存当前登录用户定制的模块
boolean | saveChannels(java.lang.String _sChannelIds) 保存个人定制的频道
boolean | saveSites(int[] _nArgSiteId) 保存个人定制的站点集合
void | setCustomizedChannels(java.lang.String _sChannelIds) 设置定制的频道
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CustomizeService

public CustomizeService()
方法详细信息

getLoginUser

public User getLoginUser()
从接口 ICustomizeService 复制的描述
获取使用service的当前用户

指定者：
接口 ICustomizeService 中的 getLoginUser
返回：
当前登录用户

hasCustomized

public boolean hasCustomized()
                      throws WCMException
从接口 ICustomizeService 复制的描述
当前用户是否有个性化定制

指定者：
接口 ICustomizeService 中的 hasCustomized
返回：
如果有定制,返回true
抛出：
WCMException

save

public boolean save(int _nMoudelType)
             throws WCMException
从接口 ICustomizeService 复制的描述
保存当前登录用户定制的模块

指定者：
接口 ICustomizeService 中的 save
参数：
_nMoudelType - 定制的模块类型
返回：
保存成功返回true
抛出：
WCMException

delete

public boolean delete(int _nMoudelType)
               throws WCMException
从接口 ICustomizeService 复制的描述
删除个人定制模块

指定者：
接口 ICustomizeService 中的 delete
参数：
_nMoudelType - 定制模块类型
返回：
删除成功返回true
抛出：
WCMException

getMoudels

public int[] getMoudels()
                 throws WCMException
从接口 ICustomizeService 复制的描述
获取当前用户定制的模块集合

指定者：
接口 ICustomizeService 中的 getMoudels
返回：
用户定制了的模块类型
抛出：
WCMException

saveChannels

public boolean saveChannels(java.lang.String _sChannelIds)
                     throws WCMException
从接口 ICustomizeService 复制的描述
保存个人定制的频道

指定者：
接口 ICustomizeService 中的 saveChannels
参数：
_sChannelIds - 定制的频道id序列,以字符','分隔,可以是空串 "";
返回：
保存成功返回true
抛出：
WCMException

deleteChannels

public boolean deleteChannels(int[] _nArgChannelId)
                       throws WCMException
从接口 ICustomizeService 复制的描述
删除个人定制的频道

指定者：
接口 ICustomizeService 中的 deleteChannels
参数：
_nArgChannelId - 要删除的定制频道id数组
返回：
删除成功返回true
抛出：
WCMException

getChannels

public Channels getChannels()
                     throws WCMException
从接口 ICustomizeService 复制的描述
获取当前用户定制的频道集合

指定者：
接口 ICustomizeService 中的 getChannels
返回：
返回当前用户定制的频道集合
抛出：
WCMException

getChannels

public Channels getChannels(int _nRightIndex)
                     throws WCMException
从接口 ICustomizeService 复制的描述
获取当前用户定制的并且有指定操作权限的频道集合

指定者：
接口 ICustomizeService 中的 getChannels
参数：
_nRightIndex - 指定的权限索引值
返回：
@throws WCMException
抛出：
WCMException

saveSites

public boolean saveSites(int[] _nArgSiteId)
                  throws WCMException
从接口 ICustomizeService 复制的描述
保存个人定制的站点集合

指定者：
接口 ICustomizeService 中的 saveSites
参数：
_nArgSiteId - 要保存的站点id数组
返回：
保存成功返回true
抛出：
WCMException

deleteSites

public boolean deleteSites(int[] _nArgSiteId)
                    throws WCMException
从接口 ICustomizeService 复制的描述
删除个人定制的站点集合

指定者：
接口 ICustomizeService 中的 deleteSites
参数：
_nArgSiteId - 要删除的站点Id数组
返回：
删除成功返回true
抛出：
WCMException

getWebSites

public WebSites getWebSites()
                     throws WCMException
从接口 ICustomizeService 复制的描述
获取个人定制的站点集合

指定者：
接口 ICustomizeService 中的 getWebSites
返回：
返回当前用户个人定制的站点集合
抛出：
WCMException

setCustomizedChannels

public void setCustomizedChannels(java.lang.String _sChannelIds)
                           throws WCMException
从接口 ICustomizeService 复制的描述
设置定制的频道

指定者：
接口 ICustomizeService 中的 setCustomizedChannels
参数：
_sChannelIds - 定制的频道id序列,以字符','分隔,可以是空串 "";
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DBService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 DBService

java.lang.Object
    继承者  com.trs.service.impl.DBService
所有已实现的接口：
IDBService
public class DBService
extends java.lang.Object
implements IDBService

Title: TRS 内容协作平台（TRS WCM）
Description:
数据库相关操作服务层接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DBService()
方法摘要
 DataType[] getSupportedDataTypes()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DBService

public DBService()
方法详细信息

getSupportedDataTypes

public DataType[] getSupportedDataTypes()
指定者：
接口 IDBService 中的 getSupportedDataTypes
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 DocumentService

java.lang.Object
    继承者  com.trs.service.impl.DocumentService
所有已实现的接口：
IDocumentService
public class DocumentService
extends java.lang.Object
implements IDocumentService

作者：
admin DocumentService接口对应的实现 应该是动态注入的，这里先暂时直接实现

字段摘要
AppendixMgr | m_oAppendixMgr
DocumentMgr | m_oDocumentMgr
RelationMgr | m_oRelationMgr
构造方法摘要
DocumentService()
构造函数：保留默认接口
方法摘要
DocBak | backup(Document _currDocument) 备份当前文档,产生当前文档的一个版本 备份只针对实体文档，不针对引用转发或者镜像文档，所以只提供一个Document参数
void | changeDocumentsStatus(Documents _currDocuments, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
void | changeDocumentStatus(Document _currDocument, Channel _currChannel, Status _currStatus) 修改指定文档的文档状态(新稿、已发等)
Reports | copyTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将一组文档从指定的频道复制到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | copyTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 复制文档集合 将一堆文档复制到某个频道 一堆文档可以是一个检索的结果
boolean | delete(ChnlDocs _delChnlDocs, boolean _bDrop) 批量删除当前频道下的文档
boolean | delete(Document _currDocument, Channel _currChannel, boolean _bDrop) 删除当前频道的一个文档
boolean | delete(Documents _currDocuments, Channel _currChannel, boolean _bDrop) 批量删除当前频道下的文档
boolean | delete(int _nDocumentId, Channel _currChannel, boolean _bDrop) 删除当前频道下的一个文档
boolean | delete(java.lang.String _sDocumentIds, Channel _currChannel, boolean _bDrop) 根据文档id序列批量删除当前频道下的文档
void | deleteDocBak(DocBak _docbak) 删除指定的文档版本
void | deleteDocBak(int _nDocBakId) 删除指定的文档版本
void | deleteDocBaks(DocBaks _docbaks) 删除指定的文档版本集合
void | deleteDocBaks(java.lang.String _sDocBakIds) 删除指定的文档版本
java.lang.String | export(Documents _documents, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出文档集合
java.lang.String | export(Document _document, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出指定的文档
java.lang.String | export(int _nDocId, java.lang.String _sFieldsList, boolean _bWithAppendixes) 导出指定的文档
java.lang.String | export(java.lang.String _sDocIds, java.lang.String _sFieldsList, boolean _bWithAppendixes) 根据指定的ID序列导出文档
java.lang.String | export(java.lang.String _sDocIds, java.lang.String _sFieldsList, boolean _bWithAppendixes, boolean _bWithExtFields)
ChnlDoc | findChnldoc(int _currDocumentId, int _currChannelId) 根据频道和文档，找到对应的ChnlDoc
Documents | getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords, int _nExcludeDocId, WCMFilter _filter)
Appendixes | getAppendixes(Document _currDocument) 获取当前文档的所有附件
Appendixes | getAppendixes(Document _currDocument, int _nAppendixType) 获取当前文档的某种类型的附件
Appendixes | getAppendixes(Document _document, int _nAppendixType, WCMFilter _filter) 获取当前文档的某种类型的附件
Appendixes | getAppendixes(Document _currDocument, WCMFilter _apdFilter) 获取当前文档的某种类型的附件
Channels | getChannels(Document _currDocument) 获得实体文档相关的引用、镜像等对应的所有频道
DocBak | getDocBak(Document _currDocument, int _nVersion) 获取当前文档指定版本的备份
DocBaks | getDocBaks(Document _currDocument) 获取当前文档的备份
DocBaks | getDocBaks(Document _currDocument, WCMFilter _filter) 获取当前文档的备份
java.io.File[] | getExitedMappingFiles() 获取当前用户已定义的XML映射文件
java.io.File[] | getExitedXslFiles() 获取当前用户已上传的xsl文件
User | getLoginUser() 返回当前登录用户
java.lang.String | getLoginUserName()
int | getMaxToppedNum() ---- ==== ---- Begin 置顶相关的操作 ---- ==== ----
Channels | getMirrorChannels(Document _currDocument) 获得源文档所有存在同源异现镜像的频道
java.lang.String | getMyDocumentImportSourceFilePath() 获取当前登录用户导入文档时,XSL文件的存放位置
Channels | getQuoteChannels(Document _currDocument) 获取引用了当前指定文档的所有频道
Channels | getQuoteChannels(int _nDocumentId) 获取引用了当前指定文档的所有频道
Documents | getRecycleDocuments(BaseChannel _channelOrSite, WCMFilter _filter) 获取当前站点或频道的回收站的文档
Documents | getRelatedDocuments(Document _currDocument, int _nGetByWhich) 指定检索条件获取与当前文档相关的文档
Documents | getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter) 指定检索条件获取与当前文档相关的文档
Documents | getRelatedDocuments(Document _currDocument, int _nGetByWhich, WCMFilter _filter, boolean _bExactMatch, boolean _bMultiSites) 指定检索条件获取与当前文档相关的文档
Relations | getRelations(Document _currDocument) 获取当前文档的Relations集合，即手工设定的相关文档
Documents | getToppedDocuments(Channel _currChannel, WCMFilter _docFilter) 获得特定频道下已设置为置顶的所有文档
int | getTopPosition(Document _currDocument, Channel _currChannel) 得到当前频道下的特定文档的置顶位置
CMyDateTime | getTopTime(Document _currDocument, Channel _currChannel) 获得文档置顶的截止时间 如果文档没有置顶，则直接返回null 如果置顶文档没有设置截止时间则返回null
Reports | importDocuments(java.lang.String _sImportFile, int _nDstChnlId, java.lang.String _sXSLFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从文件中导入文档 支持从zip,xml,html,htm文件导入
Reports | importTRSDocuments(java.lang.String _sImportFile, int _nDestChannelId, java.lang.String _sDefineXmlFile, boolean _bExitWhenDocumentExisted, boolean _bOmitOriginalChannel) 从TRS文件中导入文档 支持从zip,xml,html,htm文件导入
boolean | isDocumentTopped(Document _currDocument, Channel _currChannel) 判断一个频道下的文档是否是处于置顶状态 应用层可以利用这个接口，在文档列表前加上图片标识
boolean | isDocumentTopScheduled(Document _currDocument, Channel _currChannel) 判断频道下的文档如果置顶的话，是否已经加入了计划调度
void | mirrorTo(Document _currDocument, Channel _toChannel) 将文档在另一个频道中建立一个同源异现的镜像
Reports | mirrorTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将一组文档镜像转发到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | mirrorTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 镜像转发频道文档集合 将一堆文档镜像转发到某个频道 一堆文档可以是一个检索的结果
void | moveBackward(int _currDocumentId, int _currChannelId) 将文档向后移动一位 需要将两篇文档对换顺序 如果文档已经是最后一篇，则不移动 置顶区域中的文档不能移动
void | moveDocumentInChannel(int _fromDocumentId, int _toDocumentId, int _currChannelId) 在频道中移动文档的顺序 如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后 通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作 置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
void | moveDocumentInChannel(int _fromDocumentId, int _toDocumentId, int _currChannelId, int _nPostionCode)
void | moveFirst(int _currDocumentId, int _currChannelId) 将文档移动到频道内第一的位置 需要将该移动文档前面的所有文档后移一位 如果文档已经是第一篇，则不移动 移动后的文档不进入置顶区域，是置顶区后的第一篇 置顶区域中的文档也不能移动
void | moveForward(int _currDocumentId, int _currChannelId) ---- ==== ---- Begin 文档拖动相关的操作 ---- vvvv ----
void | moveLast(int _currDocumentId, int _currChannelId) 将文档移动到最后的位置 需要将该移动文档后面的所有文档向前移一位 如果文档已经是最后一篇，则不移动 置顶区域中的文档也不能移动
Reports | moveTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将文档从指定的频道移动到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | moveTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 移动文档集合 将一堆文档移动到某个频道 一堆文档可以是一个检索的结果
java.util.List | processAppendix(java.util.List nodes, int nFlag)
Reports | quoteTo(Document _currDocument, java.lang.String _sToChannelIds) 维护单篇文档的引用转发关系 将单篇文档引用转发到目标频道列表中 一般用于在文档采编页面中，设置一篇文档的引用转发 这里的维护中包括删除所有无用的引用转发关系
Reports | quoteTo(java.lang.String _sDocumentIds, int _nFromChannelId, java.lang.String _sToChannelIds) 将一组文档转发（引用转发）到多个目标频道下 一般这样的操作是在文档列表页面执行的
Reports | quoteTo(java.lang.String _fromChnlDocIds, java.lang.String _toChannelIds) 引用转发频道文档集合 将一堆频道文档移动到某个频道 一堆文档可以是一个检索的结果
Document | recoverDocument(DocBak _aDocBak, Document _currDocument) 从文档备份版本中恢复文档
void | removeToppedDocument(Document _currDocument, Channel _currChannel) 取消特定频道下某文档的置顶标志 该文档将成为普通文档 注意，不是删除文档！
void | restore(Document _currDocument, Channel _currChannel) 恢复回收站中的文档
void | restore(Documents _documents) 批量恢复回收站中的文档
Reports | restore(java.lang.String _sDelDocIds, int _nChannelId) 批量恢复回收站中的文档
Document | save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList) 添加文档、修改文档时的保存操作 由于对对象进行了重新划分，将AppendixList等从Document对象中提取出来 保持了Document对象和各个对象的独立性
Document | save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, int _nFlowDocId)
Document | save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo)
Document | save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.util.Map _hFlowContextInfo, boolean _bNeedValidateRight)
Document | save(Document newDocument, java.util.List _aAppendixList, java.util.List _aRelationList, java.lang.String _sFlowContextInfo)
Document | saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc)
Document | saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.util.Map _hFlowContextInfo)
Document | saveInfoViewDocument(Document _document, org.dom4j.Document _contentXmlDoc, java.lang.String _sFlowContextInfo)
Document | saveInfoViewDocument(Document _document, InfoView _oInfoView, java.util.Map _oInfoViewData)
void | setTopDocument(Document _currDocument, Channel _currChannel, int _nToppedOrder, CMyDateTime _dtValidUntil) 将特定频道下的一篇文档设置为置顶
void | withdraw(Document _currDocument) 撤稿 ?
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

m_oAppendixMgr

public AppendixMgr m_oAppendixMgr

m_oDocumentMgr

public DocumentMgr m_oDocumentMgr

m_oRelationMgr

public RelationMgr m_oRelationMgr
构造方法详细信息

DocumentService

public DocumentService()
构造函数：保留默认接口

方法详细信息

getDocBaks

public DocBaks getDocBaks(Document _currDocument)
                   throws WCMException
从接口 IDocumentService 复制的描述
获取当前文档的备份

指定者：
接口 IDocumentService 中的 getDocBaks
参数：
_currDocument - 当前文档
返回：
抛出：
WCMException

getDocBaks

public DocBaks getDocBaks(Document _currDocument,
                          WCMFilter _filter)
                   throws WCMException
从接口 IDocumentService 复制的描述
获取当前文档的备份

指定者：
接口 IDocumentService 中的 getDocBaks
参数：
_currDocument - 当前文档
_filter - 过滤器
返回：
抛出：
WCMException

getDocBak

public DocBak getDocBak(Document _currDocument,
                        int _nVersion)
                 throws WCMException
从接口 IDocumentService 复制的描述
获取当前文档指定版本的备份

指定者：
接口 IDocumentService 中的 getDocBak
参数：
_currDocument - 当前文档
_nVersion - 指定版本
返回：
抛出：
WCMException

save

public Document save(Document newDocument,
                     java.util.List _aAppendixList,
                     java.util.List _aRelationList)
              throws WCMException
从接口 IDocumentService 复制的描述
添加文档、修改文档时的保存操作 由于对对象进行了重新划分，将AppendixList等从Document对象中提取出来
保持了Document对象和各个对象的独立性

指定者：
接口 IDocumentService 中的 save
参数：
newDocument - 文档对象
_aAppendixList - 附件列表，如果为null则表示不需要处理附件
添加时，由系统自动添加附件和文档关联的ID
如果List isEmpty也要执行附件的处理（删除已有附件）
_aRelationList - 相关文档列表，如果为null则表示不需要处理相关文档
添加时，由系统自动添加附件和文档关联的ID
返回：
抛出：
WCMException

save

public Document save(Document newDocument,
                     java.util.List _aAppendixList,
                     java.util.List _aRelationList,
                     java.lang.String _sFlowContextInfo)
              throws WCMException
指定者：
接口 IDocumentService 中的 save
抛出：
WCMException

save

public Document save(Document newDocument,
                     java.util.List _aAppendixList,
                     java.util.List _aRelationList,
                     int _nFlowDocId)
              throws WCMException
指定者：
接口 IDocumentService 中的 save
抛出：
WCMException

save

public Document save(Document newDocument,
                     java.util.List _aAppendixList,
                     java.util.List _aRelationList,
                     java.util.Map _hFlowContextInfo)
              throws WCMException
指定者：
接口 IDocumentService 中的 save
抛出：
WCMException

save

public Document save(Document newDocument,
                     java.util.List _aAppendixList,
                     java.util.List _aRelationList,
                     java.util.Map _hFlowContextInfo,
                     boolean _bNeedValidateRight)
              throws WCMException
抛出：
WCMException

delete

public boolean delete(java.lang.String _sDocumentIds,
                      Channel _currChannel,
                      boolean _bDrop)
               throws WCMException
从接口 IDocumentService 复制的描述
根据文档id序列批量删除当前频道下的文档

指定者：
接口 IDocumentService 中的 delete
参数：
_sDocumentIds - 指定的文档id序列
_currChannel - 当前频道
_bDrop - 是否删除数据库中的数据,true为删除,不可恢复
返回：
操作成功返回true
抛出：
WCMException

delete

public boolean delete(Documents _currDocuments,
                      Channel _currChannel,
                      boolean _bDrop)
               throws WCMException
从接口 IDocumentService 复制的描述
批量删除当前频道下的文档

指定者：
接口 IDocumentService 中的 delete
参数：
_currDocuments - 需要删除的文档集合
_currChannel - 当前频道
_bDrop - 是否删除数据库中的数据,true为删除,不可恢复
返回：
操作成功返回true
抛出：
WCMException

delete

public boolean delete(int _nDocumentId,
                      Channel _currChannel,
                      boolean _bDrop)
               throws WCMException
从接口 IDocumentService 复制的描述
删除当前频道下的一个文档

指定者：
接口 IDocumentService 中的 delete
参数：
_nDocumentId - 要删除的文档
_currChannel - 当前频道
_bDrop - 是否删除数据库中的数据,true为删除,false为删除到回收站
返回：
抛出：
WCMException

delete

public boolean delete(Document _currDocument,
                      Channel _currChannel,
                      boolean _bDrop)
               throws WCMException
从接口 IDocumentService 复制的描述
删除当前频道的一个文档

指定者：
接口 IDocumentService 中的 delete
参数：
_currDocument - 要删除的文档
_currChannel - 当前频道
_bDrop - 是否删除数据库中的数据,true为删除,false为删除到回收站
返回：
抛出：
WCMException

withdraw

public void withdraw(Document _currDocument)
从接口 IDocumentService 复制的描述
撤稿 ?提供一种撤稿状态，可以通过操作直接修改，同时可能还要进行一次频道的增量发布 ?在站点发布属性中，撤稿是不允许选为可发布的 ?已撤的稿件应该还可以重新恢复成为可发布的其他状态，具体操作方式待定 ?撤稿后，引用转发的文档是否也撤还有待商榷

指定者：
接口 IDocumentService 中的 withdraw
参数：
_currDocument - 要撤的文档

importDocuments

public Reports importDocuments(java.lang.String _sImportFile,
                               int _nDstChnlId,
                               java.lang.String _sXSLFile,
                               boolean _bExitWhenDocumentExisted,
                               boolean _bOmitOriginalChannel)
                        throws WCMException
从接口 IDocumentService 复制的描述
从文件中导入文档
支持从zip,xml,html,htm文件导入

指定者：
接口 IDocumentService 中的 importDocuments
参数：
_sImportFile - 导入的源文件
_bExitWhenDocumentExisted - 当出现重复文档时,是继续导入还是忽略该篇文档的导入
如果 true 则忽略
_bOmitOriginalChannel - 是否忽略文档原来的所属频道属性 (如果导入的源数据中包含相关的信息)
如果 true 则忽略,将文档导入到指定的目标频道
抛出：
WCMException

importTRSDocuments

public Reports importTRSDocuments(java.lang.String _sImportFile,
                                  int _nDestChannelId,
                                  java.lang.String _sDefineXmlFile,
                                  boolean _bExitWhenDocumentExisted,
                                  boolean _bOmitOriginalChannel)
                           throws WCMException
从接口 IDocumentService 复制的描述
从TRS文件中导入文档
支持从zip,xml,html,htm文件导入

指定者：
接口 IDocumentService 中的 importTRSDocuments
参数：
_sImportFile - 导入的源文件
_sDefineXmlFile - 指定的TRS映射文件
_bExitWhenDocumentExisted - 当出现重复文档时,是继续导入还是忽略该篇文档的导入
如果 true 则忽略
_bOmitOriginalChannel - 是否忽略文档原来的所属频道属性 (如果导入的源数据中包含相关的信息)
如果 true 则忽略,将文档导入到指定的目标频道
返回：
Reports
抛出：
WCMException

getExitedXslFiles

public java.io.File[] getExitedXslFiles()
                                 throws WCMException
从接口 IDocumentService 复制的描述
获取当前用户已上传的xsl文件

指定者：
接口 IDocumentService 中的 getExitedXslFiles
返回：
抛出：
WCMException

getExitedMappingFiles

public java.io.File[] getExitedMappingFiles()
                                     throws WCMException
从接口 IDocumentService 复制的描述
获取当前用户已定义的XML映射文件

指定者：
接口 IDocumentService 中的 getExitedMappingFiles
返回：
抛出：
WCMException

getMyDocumentImportSourceFilePath

public java.lang.String getMyDocumentImportSourceFilePath()
                                                   throws WCMException
从接口 IDocumentService 复制的描述
获取当前登录用户导入文档时,XSL文件的存放位置

指定者：
接口 IDocumentService 中的 getMyDocumentImportSourceFilePath
返回：
抛出：
WCMException

changeDocumentsStatus

public void changeDocumentsStatus(Documents _currDocuments,
                                  Channel _currChannel,
                                  Status _currStatus)
                           throws WCMException
从接口 IDocumentService 复制的描述
修改指定文档的文档状态(新稿、已发等)

指定者：
接口 IDocumentService 中的 changeDocumentsStatus
_currChannel - 当前频道
抛出：
WCMException

changeDocumentStatus

public void changeDocumentStatus(Document _currDocument,
                                 Channel _currChannel,
                                 Status _currStatus)
                          throws WCMException
从接口 IDocumentService 复制的描述
修改指定文档的文档状态(新稿、已发等)

指定者：
接口 IDocumentService 中的 changeDocumentStatus
参数：
_currDocument - 指定的文档
_currChannel - 当前频道
_currStatus - 要指定的状态
抛出：
WCMException

getAppendixes

public Appendixes getAppendixes(Document _currDocument)
                         throws WCMException
从接口 IDocumentService 复制的描述
获取当前文档的所有附件

指定者：
接口 IDocumentService 中的 getAppendixes
参数：
_currDocument - 当前文档
返回：
抛出：
WCMException

getAppendixes

public Appendixes getAppendixes(Document _currDocument,
                                int _nAppendixType)
                         throws WCMException
从接口 IDocumentService 复制的描述
获取当前文档的某种类型的附件

指定者：
接口 IDocumentService 中的 getAppendixes
参数：
_currDocument - 当前文档
_nAppendixType - 附件的类型
返回：
抛出：
WCMException

getAppendixes

public Appendixes getAppendixes(Document _document,
                                int _nAppendixType,
                                WCMFilter _filter)
                         throws WCMException
从接口 IDocumentService 复制的描述
获取当前文档的某种类型的附件

指定者：
接口 IDocumentService 中的 getAppendixes
_nAppendixType - 附件的类型
_filter - 过滤器,额外的查询条件
返回：
抛出：
WCMException

getAppendixes

public Appendixes getAppendixes(Document _currDocument,
                                WCMFilter _apdFilter)
                         throws WCMException
从接口 IDocumentService 复制的描述
获取当前文档的某种类型的附件

指定者：
接口 IDocumentService 中的 getAppendixes
参数：
_currDocument - 当前文档
_apdFilter - 过滤器
返回：
抛出：
WCMException

getRelatedDocuments

public Documents getRelatedDocuments(Document _currDocument,
                                     int _nGetByWhich,
                                     WCMFilter _filter,
                                     boolean _bExactMatch,
                                     boolean _bMultiSites)
                              throws WCMException
从接口 IDocumentService 复制的描述
指定检索条件获取与当前文档相关的文档

指定者：
接口 IDocumentService 中的 getRelatedDocuments
参数：
_currDocument - 当前文档
_nGetByWhich - 获取方式(Document.GET_BY_ALL等)
_filter - 过滤器(额外的检索条件)
_bExactMatch - 是否精确匹配
_bMultiSites - 是否跨站上查询
返回：
与当前文档相关的文档集合
抛出：
WCMException

getRelatedDocuments

public Documents getRelatedDocuments(Document _currDocument,
                                     int _nGetByWhich)
                              throws WCMException
从接口 IDocumentService 复制的描述
指定检索条件获取与当前文档相关的文档

指定者：
接口 IDocumentService 中的 getRelatedDocuments
参数：
_currDocument - 当前文档
_nGetByWhich - 获取方式(Document.GET_BY_ALL等)
返回：
与当前文档相关的文档集合
抛出：
WCMException

getRelatedDocuments

public Documents getRelatedDocuments(Document _currDocument,
                                     int _nGetByWhich,
                                     WCMFilter _filter)
                              throws WCMException
从接口 IDocumentService 复制的描述
指定检索条件获取与当前文档相关的文档

指定者：
接口 IDocumentService 中的 getRelatedDocuments
参数：
_currDocument - 当前文档
_nGetByWhich - 获取方式(Document.GET_BY_ALL等)
_filter - 过滤器(额外的检索条件)
返回：
与当前文档相关的文档集合
抛出：
WCMException

recoverDocument

public Document recoverDocument(DocBak _aDocBak,
                                Document _currDocument)
                         throws WCMException
从接口 IDocumentService 复制的描述
从文档备份版本中恢复文档

指定者：
接口 IDocumentService 中的 recoverDocument
参数：
_aDocBak - 恢复的目的版本
_currDocument - 当前需要恢复的文档
返回：
恢复操作后的文档
抛出：
WCMException

backup

public DocBak backup(Document _currDocument)
              throws WCMException
从接口 IDocumentService 复制的描述
备份当前文档,产生当前文档的一个版本
备份只针对实体文档，不针对引用转发或者镜像文档，所以只提供一个Document参数

指定者：
接口 IDocumentService 中的 backup
参数：
_currDocument - 当前文档
返回：
新的文档备份
抛出：
WCMException

deleteDocBak

public void deleteDocBak(int _nDocBakId)
                  throws WCMException
从接口 IDocumentService 复制的描述
删除指定的文档版本

指定者：
接口 IDocumentService 中的 deleteDocBak
参数：
_nDocBakId - 指定的文档版本Id
抛出：
WCMException

deleteDocBaks

public void deleteDocBaks(java.lang.String _sDocBakIds)
                   throws WCMException
从接口 IDocumentService 复制的描述
删除指定的文档版本

指定者：
接口 IDocumentService 中的 deleteDocBaks
参数：
_sDocBakIds - 指定的文档版本Id序列,以字符','分隔
抛出：
WCMException

deleteDocBaks

public void deleteDocBaks(DocBaks _docbaks)
                   throws WCMException
从接口 IDocumentService 复制的描述
删除指定的文档版本集合

指定者：
接口 IDocumentService 中的 deleteDocBaks
参数：
_docbaks - 指定的文档版本集合
抛出：
WCMException

deleteDocBak

public void deleteDocBak(DocBak _docbak)
                  throws WCMException
从接口 IDocumentService 复制的描述
删除指定的文档版本

指定者：
接口 IDocumentService 中的 deleteDocBak
参数：
_docbak - 指定的文档版本
抛出：
WCMException

getLoginUser

public User getLoginUser()
从接口 IDocumentService 复制的描述
返回当前登录用户

指定者：
接口 IDocumentService 中的 getLoginUser
返回：

getQuoteChannels

public Channels getQuoteChannels(Document _currDocument)
                          throws WCMException
从接口 IDocumentService 复制的描述
获取引用了当前指定文档的所有频道

指定者：
接口 IDocumentService 中的 getQuoteChannels
参数：
_currDocument - 指定的当前文档
返回：
引用了该文档的所有频道集合,如果文档为草稿,则返回空集
抛出：
WCMException

getQuoteChannels

public Channels getQuoteChannels(int _nDocumentId)
                          throws WCMException
从接口 IDocumentService 复制的描述
获取引用了当前指定文档的所有频道

指定者：
接口 IDocumentService 中的 getQuoteChannels
参数：
_nDocumentId - 当前文档的id
返回：
引用了该文档的所有频道集合,如果文档为草稿,则返回空集
抛出：
WCMException

restore

public void restore(Document _currDocument,
                    Channel _currChannel)
             throws WCMException
从接口 IDocumentService 复制的描述
恢复回收站中的文档

指定者：
接口 IDocumentService 中的 restore
抛出：
WCMException

restore

public void restore(Documents _documents)
             throws WCMException
从接口 IDocumentService 复制的描述
批量恢复回收站中的文档

指定者：
接口 IDocumentService 中的 restore
抛出：
WCMException

restore

public Reports restore(java.lang.String _sDelDocIds,
                       int _nChannelId)
                throws WCMException
从接口 IDocumentService 复制的描述
批量恢复回收站中的文档

指定者：
接口 IDocumentService 中的 restore
参数：
_sDelDocIds - 要恢复的文档集合
_nChannelId - 频道Id
返回：
操作成功返回true
抛出：
WCMException

getRelations

public Relations getRelations(Document _currDocument)
                       throws WCMException
从接口 IDocumentService 复制的描述
获取当前文档的Relations集合，即手工设定的相关文档

指定者：
接口 IDocumentService 中的 getRelations
返回：
抛出：
WCMException

getMaxToppedNum

public int getMaxToppedNum()
---- ==== ---- Begin 置顶相关的操作 ---- ==== ----

指定者：
接口 IDocumentService 中的 getMaxToppedNum
返回：
允许置顶的文档的总数，找不到配置则返回0

getToppedDocuments

public Documents getToppedDocuments(Channel _currChannel,
                                    WCMFilter _docFilter)
                             throws WCMException
从接口 IDocumentService 复制的描述
获得特定频道下已设置为置顶的所有文档

指定者：
接口 IDocumentService 中的 getToppedDocuments
参数：
_currChannel - 特定的频道
_docFilter - 文档的条件
返回：
该频道下置顶的文档集合，没有则返回空的Documents集合
抛出：
WCMException

isDocumentTopped

public boolean isDocumentTopped(Document _currDocument,
                                Channel _currChannel)
                         throws WCMException
从接口 IDocumentService 复制的描述
判断一个频道下的文档是否是处于置顶状态
应用层可以利用这个接口，在文档列表前加上图片标识

指定者：
接口 IDocumentService 中的 isDocumentTopped
参数：
_currDocument - 文档
_currChannel - 文档所在频道
返回：
true为是置顶文档，false为不是置顶文档
抛出：
WCMException

setTopDocument

public void setTopDocument(Document _currDocument,
                           Channel _currChannel,
                           int _nToppedOrder,
                           CMyDateTime _dtValidUntil)
                    throws WCMException
从接口 IDocumentService 复制的描述
将特定频道下的一篇文档设置为置顶

指定者：
接口 IDocumentService 中的 setTopDocument
参数：
_currDocument - 文档
_currChannel - 文档所在频道
_nToppedOrder - 该文档在当前频道下置顶的顺序
_dtValidUntil - 置顶的有效期（截止日期）
抛出：
WCMException - 如果置顶顺序大于最大顺序，则抛出异常
如果置顶位置上已存在文档，则抛出异常

removeToppedDocument

public void removeToppedDocument(Document _currDocument,
                                 Channel _currChannel)
                          throws WCMException
从接口 IDocumentService 复制的描述
取消特定频道下某文档的置顶标志
该文档将成为普通文档
注意，不是删除文档！

指定者：
接口 IDocumentService 中的 removeToppedDocument
参数：
_currDocument - 文档
_currChannel - 特定频道
抛出：
WCMException - 如果该文档不是置顶的，也不抛出异常

getTopPosition

public int getTopPosition(Document _currDocument,
                          Channel _currChannel)
                   throws WCMException
从接口 IDocumentService 复制的描述
得到当前频道下的特定文档的置顶位置

指定者：
接口 IDocumentService 中的 getTopPosition
返回：
置顶位置，如果不是置顶的文档，则返回0
抛出：
WCMException

isDocumentTopScheduled

public boolean isDocumentTopScheduled(Document _currDocument,
                                      Channel _currChannel)
                               throws WCMException
从接口 IDocumentService 复制的描述
判断频道下的文档如果置顶的话，是否已经加入了计划调度

指定者：
接口 IDocumentService 中的 isDocumentTopScheduled
返回：
如果置顶有截止日期，则返回true，表示加入了计划调度；否则返回false
抛出：
WCMException

getTopTime

public CMyDateTime getTopTime(Document _currDocument,
                              Channel _currChannel)
                       throws WCMException
从接口 IDocumentService 复制的描述
获得文档置顶的截止时间
  • 如果文档没有置顶，则直接返回null
  • 如果置顶文档没有设置截止时间则返回null

    指定者：
    接口 IDocumentService 中的 getTopTime
    参数：
    _currDocument - 置顶的文档
    _currChannel - 文档所在频道
    返回：
    返回置顶文档的截止时间（包含日期）
    抛出：
    WCMException

    • moveForward

    public void moveForward(int _currDocumentId,
                        int _currChannelId)
                 throws WCMException
    ---- ==== ---- Begin 文档拖动相关的操作 ---- vvvv ----

    指定者：
    接口 IDocumentService 中的 moveForward
    参数：
    _currDocumentId - 文档
    _currChannelId - 文档所在频道
    抛出：
    WCMException - 如果文档已经是第一篇文档，则不做处理，不抛异常

    moveBackward

    public void moveBackward(int _currDocumentId,
                         int _currChannelId)
                  throws WCMException
    从接口 IDocumentService 复制的描述
    将文档向后移动一位
    需要将两篇文档对换顺序
    如果文档已经是最后一篇，则不移动
    置顶区域中的文档不能移动

    指定者：
    接口 IDocumentService 中的 moveBackward
    参数：
    _currDocumentId - 文档
    _currChannelId - 文档所在频道
    抛出：
    WCMException - 如果文档已经是最后一篇文档，则不做处理，不抛异常

    moveFirst

    public void moveFirst(int _currDocumentId,
                      int _currChannelId)
               throws WCMException
    从接口 IDocumentService 复制的描述
    将文档移动到频道内第一的位置
    需要将该移动文档前面的所有文档后移一位
    如果文档已经是第一篇，则不移动
    移动后的文档不进入置顶区域，是置顶区后的第一篇
    置顶区域中的文档也不能移动

    指定者：
    接口 IDocumentService 中的 moveFirst
    参数：
    _currDocumentId - 文档
    抛出：
    WCMException - 如果文档已经是第一篇，则不做处理，不抛异常

    moveLast

    public void moveLast(int _currDocumentId,
                     int _currChannelId)
              throws WCMException
    从接口 IDocumentService 复制的描述
    将文档移动到最后的位置
    需要将该移动文档后面的所有文档向前移一位
    如果文档已经是最后一篇，则不移动
    置顶区域中的文档也不能移动

    指定者：
    接口 IDocumentService 中的 moveLast
    抛出：
    WCMException - 如果文档已经是最后一篇，则不做处理，不抛异常

    moveDocumentInChannel

    public void moveDocumentInChannel(int _fromDocumentId,
                                  int _toDocumentId,
                                  int _currChannelId)
                           throws WCMException
    从接口 IDocumentService 复制的描述
    在频道中移动文档的顺序
    如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
    通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
    置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档

    指定者：
    接口 IDocumentService 中的 moveDocumentInChannel
    参数：
    _fromDocumentId - 要移动的文档Id
    _toDocumentId - 移动的目标文档Id
    _currChannelId - 文档所在频道Id
    抛出：
    WCMException

    moveDocumentInChannel

    public void moveDocumentInChannel(int _fromDocumentId,
                                  int _toDocumentId,
                                  int _currChannelId,
                                  int _nPostionCode)
                           throws WCMException
    指定者：
    接口 IDocumentService 中的 moveDocumentInChannel
    抛出：
    WCMException

    mirrorTo

    public void mirrorTo(Document _currDocument,
                     Channel _toChannel)
              throws WCMException
    从接口 IDocumentService 复制的描述
    将文档在另一个频道中建立一个同源异现的镜像

    指定者：
    接口 IDocumentService 中的 mirrorTo
    参数：
    _currDocument - 源文档
    _toChannel - 目标频道
    抛出：
    WCMException

    getMirrorChannels

    public Channels getMirrorChannels(Document _currDocument)
                           throws WCMException
    从接口 IDocumentService 复制的描述
    获得源文档所有存在同源异现镜像的频道

    指定者：
    接口 IDocumentService 中的 getMirrorChannels
    参数：
    _currDocument - 源文档
    返回：
    存在镜像的频道
    抛出：
    WCMException

    getChannels

    public Channels getChannels(Document _currDocument)
                     throws WCMException
    从接口 IDocumentService 复制的描述
    获得实体文档相关的引用、镜像等对应的所有频道

    指定者：
    接口 IDocumentService 中的 getChannels
    返回：
    抛出：
    WCMException

    delete

    public boolean delete(ChnlDocs _delChnlDocs,
                      boolean _bDrop)
               throws WCMException
    从接口 IDocumentService 复制的描述
    批量删除当前频道下的文档

    指定者：
    接口 IDocumentService 中的 delete
    参数：
    _delChnlDocs - 需要删除的频道文档集合
    _bDrop - 是否删除数据库中的数据,true为删除,不可恢复
    返回：
    操作成功返回true
    抛出：
    WCMException

    getLoginUserName

    public java.lang.String getLoginUserName()

    export

    public java.lang.String export(Document _document,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes)
                        throws WCMException
    从接口 IDocumentService 复制的描述
    导出指定的文档

    指定者：
    接口 IDocumentService 中的 export
    参数：
    _document - 需要导出的文档
    _sFieldsList - 需要导出的字段列表
    _bWithAppendixes - 是否一同导出文档的附件
    返回：
    抛出：
    WCMException

    export

    public java.lang.String export(int _nDocId,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes)
                        throws WCMException
    从接口 IDocumentService 复制的描述
    导出指定的文档

    指定者：
    接口 IDocumentService 中的 export
    参数：
    _nDocId - 指定的文档ID
    _sFieldsList - 要导出的字段列表
    _bWithAppendixes - 是否一同导出文档的附件
    返回：
    抛出：
    WCMException

    export

    public java.lang.String export(java.lang.String _sDocIds,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes)
                        throws WCMException
    从接口 IDocumentService 复制的描述
    根据指定的ID序列导出文档

    指定者：
    接口 IDocumentService 中的 export
    参数：
    _sDocIds - 指定的ID序列
    _sFieldsList - 需要导出的字段列表
    _bWithAppendixes - 是否一同导出文档的附件
    返回：
    抛出：
    WCMException

    export

    public java.lang.String export(Documents _documents,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes)
                        throws WCMException
    从接口 IDocumentService 复制的描述
    导出文档集合

    指定者：
    接口 IDocumentService 中的 export
    参数：
    _documents - 要导出的文档集合
    _sFieldsList - 需要导出的字段列表
    _bWithAppendixes - 是否一同导出文档的附件
    返回：
    返回systemtemp目录下的一个文件名
    抛出：
    WCMException

    export

    public java.lang.String export(java.lang.String _sDocIds,
                               java.lang.String _sFieldsList,
                               boolean _bWithAppendixes,
                               boolean _bWithExtFields)
                        throws WCMException
    抛出：
    WCMException

    quoteTo

    public Reports quoteTo(Document _currDocument,
                       java.lang.String _sToChannelIds)
                throws WCMException
    从接口 IDocumentService 复制的描述
    维护单篇文档的引用转发关系
    将单篇文档引用转发到目标频道列表中
    一般用于在文档采编页面中，设置一篇文档的引用转发
    这里的维护中包括删除所有无用的引用转发关系

    指定者：
    接口 IDocumentService 中的 quoteTo
    参数：
    _currDocument - 实体文档本身，原始频道即文档的频道
    _sToChannelIds - 目标频道Id列表
    抛出：
    WCMException

    quoteTo

    public Reports quoteTo(java.lang.String _sDocumentIds,
                       int _nFromChannelId,
                       java.lang.String _sToChannelIds)
                throws WCMException
    从接口 IDocumentService 复制的描述
    将一组文档转发（引用转发）到多个目标频道下
    一般这样的操作是在文档列表页面执行的

    指定者：
    接口 IDocumentService 中的 quoteTo
    参数：
    _sDocumentIds - 源文档Id列表
    _nFromChannelId - 源频道Id
    _sToChannelIds - 目标频道Id列表
    返回：
    引用转发的结果报告
    抛出：
    WCMException

    copyTo

    public Reports copyTo(java.lang.String _sDocumentIds,
                      int _nFromChannelId,
                      java.lang.String _sToChannelIds)
               throws WCMException
    从接口 IDocumentService 复制的描述
    将一组文档从指定的频道复制到多个目标频道下
    一般这样的操作是在文档列表页面执行的

    指定者：
    接口 IDocumentService 中的 copyTo
    参数：
    _sDocumentIds - 文档Id列表
    _nFromChannelId - 指定的频道Id(>0表示从当前指定频道操作;0表示从文档所属频道操作)
    返回：
    复制的结果报告
    抛出：
    WCMException

    moveTo

    public Reports moveTo(java.lang.String _sDocumentIds,
                      int _nFromChannelId,
                      java.lang.String _sToChannelIds)
               throws WCMException
    从接口 IDocumentService 复制的描述
    将文档从指定的频道移动到多个目标频道下
    一般这样的操作是在文档列表页面执行的

    指定者：
    接口 IDocumentService 中的 moveTo
    参数：
    _sDocumentIds - 文档Id列表
    _nFromChannelId - 指定的频道Id（=0表示从文档的所属频道操作）
    返回：
    移动的结果报告
    抛出：
    WCMException

    copyTo

    public Reports copyTo(java.lang.String _fromChnlDocIds,
                      java.lang.String _toChannelIds)
               throws WCMException
    从接口 IDocumentService 复制的描述
    复制文档集合 将一堆文档复制到某个频道 一堆文档可以是一个检索的结果

    指定者：
    接口 IDocumentService 中的 copyTo
    参数：
    _fromChnlDocIds - 要复制的频道文档集合Id序列
    _toChannelIds - 目标频道Id序列
    返回：
    抛出：
    WCMException

    moveTo

    public Reports moveTo(java.lang.String _fromChnlDocIds,
                      java.lang.String _toChannelIds)
               throws WCMException
    从接口 IDocumentService 复制的描述
    移动文档集合
    将一堆文档移动到某个频道 一堆文档可以是一个检索的结果

    指定者：
    接口 IDocumentService 中的 moveTo
    参数：
    _fromChnlDocIds - 要移动的频道文档集合Id序列
    _toChannelIds - 目标频道Id序列
    返回：
    抛出：
    WCMException

    quoteTo

    public Reports quoteTo(java.lang.String _fromChnlDocIds,
                       java.lang.String _toChannelIds)
                throws WCMException
    从接口 IDocumentService 复制的描述
    引用转发频道文档集合
    将一堆频道文档移动到某个频道 一堆文档可以是一个检索的结果

    指定者：
    接口 IDocumentService 中的 quoteTo
    参数：
    _fromChnlDocIds - 要引用哈钻发的频道文档集合Id序列
    _toChannelIds - 目标频道Id序列
    返回：
    抛出：
    WCMException

    mirrorTo

    public Reports mirrorTo(java.lang.String _fromChnlDocIds,
                        java.lang.String _toChannelIds)
                 throws WCMException
    从接口 IDocumentService 复制的描述
    镜像转发频道文档集合
    将一堆文档镜像转发到某个频道 一堆文档可以是一个检索的结果

    指定者：
    接口 IDocumentService 中的 mirrorTo
    参数：
    _fromChnlDocIds - 要镜像转发的频道文档集合Id序列
    _toChannelIds - 目标频道Id序列
    返回：
    抛出：
    WCMException

    mirrorTo

    public Reports mirrorTo(java.lang.String _sDocumentIds,
                        int _nFromChannelId,
                        java.lang.String _sToChannelIds)
                 throws WCMException
    从接口 IDocumentService 复制的描述
    将一组文档镜像转发到多个目标频道下
    一般这样的操作是在文档列表页面执行的

    指定者：
    接口 IDocumentService 中的 mirrorTo
    参数：
    _sDocumentIds - 源文档Id列表
    _nFromChannelId - 源频道Id
    返回：
    镜像转发的结果报告
    抛出：
    WCMException

    findChnldoc

    public ChnlDoc findChnldoc(int _currDocumentId,
                           int _currChannelId)
                    throws WCMException
    从接口 IDocumentService 复制的描述
    根据频道和文档，找到对应的ChnlDoc

    指定者：
    接口 IDocumentService 中的 findChnldoc
    返回：
    抛出：
    WCMException

    getRecycleDocuments

    public Documents getRecycleDocuments(BaseChannel _channelOrSite,
                                     WCMFilter _filter)
                              throws WCMException
    从接口 IDocumentService 复制的描述
    获取当前站点或频道的回收站的文档

    指定者：
    接口 IDocumentService 中的 getRecycleDocuments
    参数：
    _channelOrSite - 站点或频道对象
    _filter - 额外的检索条件
    返回：
    文档集合
    抛出：
    WCMException

    getAllRelatedDocumentsByKeywords

    public Documents getAllRelatedDocumentsByKeywords(java.lang.String _sKeywords,
                                                  int _nExcludeDocId,
                                                  WCMFilter _filter)
                                           throws WCMException
    指定者：
    接口 IDocumentService 中的 getAllRelatedDocumentsByKeywords
    抛出：
    WCMException

    saveInfoViewDocument

    public Document saveInfoViewDocument(Document _document,
                                     org.dom4j.Document _contentXmlDoc)
                              throws WCMException
    指定者：
    接口 IDocumentService 中的 saveInfoViewDocument
    抛出：
    WCMException

    saveInfoViewDocument

    public Document saveInfoViewDocument(Document _document,
                                     org.dom4j.Document _contentXmlDoc,
                                     java.lang.String _sFlowContextInfo)
                              throws WCMException
    指定者：
    接口 IDocumentService 中的 saveInfoViewDocument
    抛出：
    WCMException

    saveInfoViewDocument

    public Document saveInfoViewDocument(Document _document,
                                     InfoView _oInfoView,
                                     java.util.Map _oInfoViewData)
                              throws WCMException
    指定者：
    接口 IDocumentService 中的 saveInfoViewDocument
    抛出：
    WCMException

    saveInfoViewDocument

    public Document saveInfoViewDocument(Document _document,
                                     org.dom4j.Document _contentXmlDoc,
                                     java.util.Map _hFlowContextInfo)
                              throws WCMException
    指定者：
    接口 IDocumentService 中的 saveInfoViewDocument
    抛出：
    WCMException

    processAppendix

    public java.util.List processAppendix(java.util.List nodes,
                                      int nFlag)
                               throws WCMException
    抛出：
    WCMException
    概述 软件包 类 使用 树 已过时 索引 帮助
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 EventService

java.lang.Object
    继承者  com.trs.service.impl.EventService
所有已实现的接口：
IEventService
public class EventService
extends java.lang.Object
implements IEventService

Title: TRS 内容协作平台（TRS WCM）
Description:
日程服务提供对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
EventService()
方法摘要
void | cancelShare(Event _aEvent, Group _assignToGroup) 取消指派给另外一个组织的Event
void | cancelShare(Event _aEvent, User _assignToUser) 取消指派给另外一个用户的Event
void | cancelShare(Event _aEvent, Users _assignToUsers) 取消指派给一个用户集合的Event
void | cancelShares(Event _aEvent) 取消所有共享
boolean | delete(Event _aEvent) 根据指定的Event对象进行删除操作
boolean | delete(Events _anEvents) 根据指定的Events对象进行删除操作
boolean | delete(int _nEventId) 根据提供的Event ID进行删除操作, 直接进行彻底删除操作
boolean | delete(java.lang.String _sIds) 根据制定的ID序列，进行删除操作
Events | getEvents(WCMFilter _filter) 根据指定的filter获取Events
User | getLoginUser() 获取当前登录用户
Events | getSharedEvents(User _user, CMyDateTime _date) 获取用户在指定日期内被Assign的所有Events
Events | getSharedEvents(User _user, CMyDateTime _date, boolean _bAll) 获取用户在指定日期内私有的或公有的Events
Events | getSharedEvents(User _user, CMyDateTime _date, boolean _bAll, WCMFilter _filter) 获取用户在指定filter限制下被Assign的Events
Groups | getSharedGroups(Event _aEvent) 获取一个Event被AssignTo的Group
Users | getSharedUsers(Event _aEvent) 获取一个Event被AssignTo的Users
Event | save(Event _aEvent) 保存一个Event
void | shareEventTo(Event _eventToShare, java.lang.String _sSharerIds, int _nSharerType) 共享日程给指定的共享者
void | shareTo(Event _aEvent, Group _assignToGroup) 当前用户把一个Event指派给一个组织
void | shareTo(Event _aEvent, Groups _assignToGroups)
void | shareTo(Event _aEvent, java.lang.String _sUserIds)
void | shareTo(Event _aEvent, User _assignToUser) 当前用户把一个Event指派给另外一个用户
void | shareTo(Event _aEvent, Users _assignToUsers) 把一个Event指派给一个用户集合
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventService

public EventService()
方法详细信息

getSharedEvents

public Events getSharedEvents(User _user,
                              CMyDateTime _date,
                              boolean _bAll)
                       throws WCMException
从接口 IEventService 复制的描述
获取用户在指定日期内私有的或公有的Events

指定者：
接口 IEventService 中的 getSharedEvents
返回：
抛出：
WCMException

getSharedEvents

public Events getSharedEvents(User _user,
                              CMyDateTime _date)
                       throws WCMException
从接口 IEventService 复制的描述
获取用户在指定日期内被Assign的所有Events

指定者：
接口 IEventService 中的 getSharedEvents
返回：
抛出：
WCMException

getSharedEvents

public Events getSharedEvents(User _user,
                              CMyDateTime _date,
                              boolean _bAll,
                              WCMFilter _filter)
                       throws WCMException
从接口 IEventService 复制的描述
获取用户在指定filter限制下被Assign的Events

指定者：
接口 IEventService 中的 getSharedEvents
返回：
抛出：
WCMException

getSharedGroups

public Groups getSharedGroups(Event _aEvent)
                       throws WCMException
从接口 IEventService 复制的描述
获取一个Event被AssignTo的Group

指定者：
接口 IEventService 中的 getSharedGroups
返回：
抛出：
WCMException

getSharedUsers

public Users getSharedUsers(Event _aEvent)
                     throws WCMException
从接口 IEventService 复制的描述
获取一个Event被AssignTo的Users

指定者：
接口 IEventService 中的 getSharedUsers
返回：
抛出：
WCMException

save

public Event save(Event _aEvent)
           throws WCMException
从接口 IEventService 复制的描述
保存一个Event

指定者：
接口 IEventService 中的 save
返回：
如果成功则返回这个Event
抛出：
WCMException - 如果保存失败，则抛出异常

delete

public boolean delete(int _nEventId)
               throws WCMException
从接口 IEventService 复制的描述
根据提供的Event ID进行删除操作, 直接进行彻底删除操作

指定者：
接口 IEventService 中的 delete
返回：
如果成功，则返回true
抛出：
WCMException - 如果没有找到指定ID的Event对象，则抛出异常，中止操作 如果删除失败则抛出异常

delete

public boolean delete(Event _aEvent)
               throws WCMException
从接口 IEventService 复制的描述
根据指定的Event对象进行删除操作

指定者：
接口 IEventService 中的 delete
返回：
抛出：
WCMException - 如果传入空对象，则抛出异常

delete

public boolean delete(java.lang.String _sIds)
               throws WCMException
从接口 IEventService 复制的描述
根据制定的ID序列，进行删除操作

指定者：
接口 IEventService 中的 delete
返回：
抛出：
WCMException

delete

public boolean delete(Events _anEvents)
               throws WCMException
从接口 IEventService 复制的描述
根据指定的Events对象进行删除操作

指定者：
接口 IEventService 中的 delete
返回：
抛出：
WCMException - 如果传入空对象，则抛出异常

getEvents

public Events getEvents(WCMFilter _filter)
                 throws WCMException
从接口 IEventService 复制的描述
根据指定的filter获取Events

指定者：
接口 IEventService 中的 getEvents
返回：
抛出：
WCMException

shareTo

public void shareTo(Event _aEvent,
                    User _assignToUser)
             throws WCMException
从接口 IEventService 复制的描述
当前用户把一个Event指派给另外一个用户

指定者：
接口 IEventService 中的 shareTo
抛出：
WCMException

shareTo

public void shareTo(Event _aEvent,
                    Groups _assignToGroups)
             throws WCMException
指定者：
接口 IEventService 中的 shareTo
抛出：
WCMException

cancelShare

public void cancelShare(Event _aEvent,
                        User _assignToUser)
                 throws WCMException
从接口 IEventService 复制的描述
取消指派给另外一个用户的Event

指定者：
接口 IEventService 中的 cancelShare
抛出：
WCMException

getLoginUser

public User getLoginUser()
从接口 IEventService 复制的描述
获取当前登录用户

指定者：
接口 IEventService 中的 getLoginUser
返回：

shareTo

public void shareTo(Event _aEvent,
                    Group _assignToGroup)
             throws WCMException
从接口 IEventService 复制的描述
当前用户把一个Event指派给一个组织

指定者：
接口 IEventService 中的 shareTo
抛出：
WCMException

shareTo

public void shareTo(Event _aEvent,
                    Users _assignToUsers)
             throws WCMException
从接口 IEventService 复制的描述
把一个Event指派给一个用户集合

指定者：
接口 IEventService 中的 shareTo
抛出：
WCMException

shareTo

public void shareTo(Event _aEvent,
                    java.lang.String _sUserIds)
             throws WCMException
指定者：
接口 IEventService 中的 shareTo
抛出：
WCMException

cancelShare

public void cancelShare(Event _aEvent,
                        Users _assignToUsers)
                 throws WCMException
从接口 IEventService 复制的描述
取消指派给一个用户集合的Event

指定者：
接口 IEventService 中的 cancelShare
抛出：
WCMException

cancelShare

public void cancelShare(Event _aEvent,
                        Group _assignToGroup)
                 throws WCMException
从接口 IEventService 复制的描述
取消指派给另外一个组织的Event

指定者：
接口 IEventService 中的 cancelShare
抛出：
WCMException

cancelShares

public void cancelShares(Event _aEvent)
                  throws WCMException
从接口 IEventService 复制的描述
取消所有共享

指定者：
接口 IEventService 中的 cancelShares
抛出：
WCMException

shareEventTo

public void shareEventTo(Event _eventToShare,
                         java.lang.String _sSharerIds,
                         int _nSharerType)
                  throws WCMException
共享日程给指定的共享者

参数：
_eventToShare - 要共享的日程安排
_sSharerIds - 共享者的Id序列,必须以字符','分隔
_nSharerType - 共享者的对象类型(User.OBJ_TYPE/Group.OBJ_TYPE);
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FtpSoap4Radar

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 FtpSoap4Radar

java.lang.Object
    继承者  com.trs.service.impl.FtpSoap4Radar

public class FtpSoap4Radar
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
通过FTP配合接收雷达的数据(SOAP),需要配置类路径中的ftpsoap4radar.properties
Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
FtpSoap4Radar()
方法摘要
 java.lang.String importViaFtp(java.lang.String fn)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FtpSoap4Radar

public FtpSoap4Radar()
方法详细信息

importViaFtp

public java.lang.String importViaFtp(java.lang.String fn)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 GroupService

java.lang.Object
    继承者  com.trs.service.impl.GroupService
所有已实现的接口：
IGroupService
public class GroupService
extends java.lang.Object
implements IGroupService

Title: TRS 内容协作平台（TRS WCM）
Description:
组织管理的服务接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
GroupService()
方法摘要
boolean | addManager(User _adminToAdd, Group _dstGroup) 将指定用户设置为某个组的管理员 注意: 指定的用户必须在指定组中
boolean | addUser(User _userToAdd, Group _dstGroup) 将指定用户添加个指定的组中
boolean | delete(Group _groupToDelete) 删除某个特定的组织
boolean | delete(Groups _groupsToDelete) 删除一批组织（在组织列表页面中用到）
boolean | delete(int _nGroupId) 根据组ID，删除一个组织
boolean | delete(java.lang.String _sGroupIds) 根据组织Id，删除一批组织（在组织列表页面中用到）
Users | getAdmins(Group _dstGroup) 获取指定组的管理员集合
Groups | getChildren(Group _parentGroup) 获取某个组的子组集合
Groups | getChildren(Group _parentGroup, boolean _bContainsChild)
Groups | getChildren(Group _parentGroup, boolean _bContainsChild, WCMFilter _filter)
Users | getUsers(Group _dstGroup, WCMFilter _filter) 获取指定组中的所有用户
Users | getUsers(Group _dstGroup, WCMFilter _filter, boolean _bContainsChildGrp)
Group | moveTo(Group _fromGroup, Group _toGroup) 移动组织，将一个组织移动到另一个组织下
boolean | moveUser(User _userToMove, Group _srcGroup, Group _dstGroup) 将指定用户从某个组移动到指定的另外一个组中
boolean | moveUser(User _userToMove, Group _srcGroup, Groups _dstGroups) 将指定的用户从某个组移动到指定的多个组中
boolean | removeManager(User _adminToCancel, Group _dstGroup) 取消指定用户在某个组的管理员身份 注意: 指定的用户必须在指定组中
boolean | removeUser(User _userToRemove, Group _dstGroup) 将指定组从指定的组中删除
boolean | removeUser(User _userToRemove, Group _dstGroup, boolean _bContainsChildren)
Group | save(Group _dstGroup) 保存指定的组织
boolean | setGroupUsers(int _nDstGroupId, java.lang.String _sUserIdsToAdd) 维护指定用户组的用户列表
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GroupService

public GroupService()
方法详细信息

addUser

public boolean addUser(User _userToAdd,
                       Group _dstGroup)
                throws WCMException
从接口 IGroupService 复制的描述
将指定用户添加个指定的组中

指定者：
接口 IGroupService 中的 addUser
参数：
_userToAdd - 要添加的指定用户
_dstGroup - 指定的目标组
返回：
添加成功返回true
抛出：
WCMException

removeUser

public boolean removeUser(User _userToRemove,
                          Group _dstGroup)
                   throws WCMException
从接口 IGroupService 复制的描述
将指定组从指定的组中删除

指定者：
接口 IGroupService 中的 removeUser
参数：
_userToRemove - 要删除的指定用户
_dstGroup - 指定的目标组
返回：
删除成功返回true
抛出：
WCMException

removeUser

public boolean removeUser(User _userToRemove,
                          Group _dstGroup,
                          boolean _bContainsChildren)
                   throws WCMException
指定者：
接口 IGroupService 中的 removeUser
抛出：
WCMException

getUsers

public Users getUsers(Group _dstGroup,
                      WCMFilter _filter)
               throws WCMException
从接口 IGroupService 复制的描述
获取指定组中的所有用户

指定者：
接口 IGroupService 中的 getUsers
参数：
_dstGroup - 指定的目标组
_filter - 过滤器,额外的查询条件
返回：
组中所有的用户集合
抛出：
WCMException

getUsers

public Users getUsers(Group _dstGroup,
                      WCMFilter _filter,
                      boolean _bContainsChildGrp)
               throws WCMException
指定者：
接口 IGroupService 中的 getUsers
抛出：
WCMException

moveUser

public boolean moveUser(User _userToMove,
                        Group _srcGroup,
                        Group _dstGroup)
                 throws WCMException
从接口 IGroupService 复制的描述
将指定用户从某个组移动到指定的另外一个组中

指定者：
接口 IGroupService 中的 moveUser
_srcGroup - 用户原来所在的组
_dstGroup - 用户所属的新组
返回：
移动成功返回true
抛出：
WCMException

moveUser

public boolean moveUser(User _userToMove,
                        Group _srcGroup,
                        Groups _dstGroups)
                 throws WCMException
从接口 IGroupService 复制的描述
将指定的用户从某个组移动到指定的多个组中

指定者：
接口 IGroupService 中的 moveUser
参数：
_userToMove - 要移动的指定用户
_srcGroup - 用户所在的原组
_dstGroups - 目标组集合
返回：
移动成功返回true
抛出：
WCMException

addManager

public boolean addManager(User _adminToAdd,
                          Group _dstGroup)
                   throws WCMException
从接口 IGroupService 复制的描述
将指定用户设置为某个组的管理员
注意: 指定的用户必须在指定组中

指定者：
接口 IGroupService 中的 addManager
参数：
_adminToAdd - 指定的用户
_dstGroup - 目标组
返回：
设置成功,返回true
抛出：
WCMException

removeManager

public boolean removeManager(User _adminToCancel,
                             Group _dstGroup)
                      throws WCMException
从接口 IGroupService 复制的描述
取消指定用户在某个组的管理员身份
注意: 指定的用户必须在指定组中

指定者：
接口 IGroupService 中的 removeManager
参数：
_adminToCancel - 指定的组管理员
_dstGroup - 目标组
返回：
操作成功返回true
抛出：
WCMException

getChildren

public Groups getChildren(Group _parentGroup)
                   throws WCMException
从接口 IGroupService 复制的描述
获取某个组的子组集合

指定者：
接口 IGroupService 中的 getChildren
参数：
_parentGroup - 指定的父组(如果没有指定,则返回系统中的一级组织)
返回：
该组的子组集合
抛出：
WCMException

getChildren

public Groups getChildren(Group _parentGroup,
                          boolean _bContainsChild)
                   throws WCMException
指定者：
接口 IGroupService 中的 getChildren
抛出：
WCMException

getChildren

public Groups getChildren(Group _parentGroup,
                          boolean _bContainsChild,
                          WCMFilter _filter)
                   throws WCMException
指定者：
接口 IGroupService 中的 getChildren
抛出：
WCMException

delete

public boolean delete(int _nGroupId)
               throws WCMException
从接口 IGroupService 复制的描述
根据组ID，删除一个组织

指定者：
接口 IGroupService 中的 delete
参数：
_nGroupId - ：要删除组织的Id
返回：
true为删除成功，false为删除失败
抛出：
WCMException

delete

public boolean delete(java.lang.String _sGroupIds)
               throws WCMException
从接口 IGroupService 复制的描述
根据组织Id，删除一批组织（在组织列表页面中用到）

指定者：
接口 IGroupService 中的 delete
参数：
_sGroupIds - 要删除的组织集合的Id列表，形如1,2,3,5
返回：
true为删除成功，false为删除失败
抛出：
WCMException

delete

public boolean delete(Groups _groupsToDelete)
               throws WCMException
从接口 IGroupService 复制的描述
删除一批组织（在组织列表页面中用到）

指定者：
接口 IGroupService 中的 delete
参数：
_groupsToDelete - 要删除的组织集合
返回：
true为删除成功，false为删除失败
抛出：
WCMException

delete

public boolean delete(Group _groupToDelete)
               throws WCMException
从接口 IGroupService 复制的描述
删除某个特定的组织

指定者：
接口 IGroupService 中的 delete
参数：
_groupToDelete - ：要删除的组织
返回：
true为删除成功，false为删除失败
抛出：
WCMException

save

public Group save(Group _dstGroup)
           throws WCMException
从接口 IGroupService 复制的描述
保存指定的组织

指定者：
接口 IGroupService 中的 save
参数：
_dstGroup - 要保存的组织
返回：
@throws WCMException
抛出：
WCMException

moveTo

public Group moveTo(Group _fromGroup,
                    Group _toGroup)
从接口 IGroupService 复制的描述
移动组织，将一个组织移动到另一个组织下

指定者：
接口 IGroupService 中的 moveTo
参数：
_fromGroup - 需要移动的组织
_toGroup - 目标组织，fromGroup移动后作为目标组织的一个子组织；目标组织为0表示在根下建立
返回：
移动后的组织
抛出：
java.lang.UnsupportedOperationException - 方法未实现

getAdmins

public Users getAdmins(Group _dstGroup)
                throws WCMException
从接口 IGroupService 复制的描述
获取指定组的管理员集合

指定者：
接口 IGroupService 中的 getAdmins
参数：
_dstGroup - 指定的目标组
返回：
指定组的管理员集合
抛出：
WCMException

setGroupUsers

public boolean setGroupUsers(int _nDstGroupId,
                             java.lang.String _sUserIdsToAdd)
                      throws WCMException
从接口 IGroupService 复制的描述
维护指定用户组的用户列表

指定者：
接口 IGroupService 中的 setGroupUsers
参数：
_nDstGroupId - 指定的用户组
_sUserIdsToAdd - 用户列表的ID序列
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewDocImportService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 InfoViewDocImportService

java.lang.Object
    继承者  com.trs.service.impl.InfoViewDocImportService

public class InfoViewDocImportService
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
从网关中转过来的数据导入
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InfoViewDocImportService()
方法摘要
void | checkSysInfos(java.lang.String _sChannelId, java.lang.String _sInfoViewId)
DocumentMgr | getDocumentMgr()
java.lang.String | importInfoViewData(byte[] _importData, byte[] _signData, java.lang.String _sChannelId, java.lang.String _sInfoViewId)
java.lang.String | importInfoViewData(byte[] _importData, byte[] _signData, java.lang.String _sChannelId, java.lang.String _sInfoViewId, java.lang.String _sPostUser, java.lang.String _sAttributeStr)
java.lang.String | importInfoViewDataForCustom(org.dom4j.Document xmlDoc, java.lang.String _sChannelId, java.lang.String _sInfoViewId, java.lang.String _sPostUser, java.util.HashMap _map)
static void | main(java.lang.String[] args)
java.lang.String | retriveChannelInfo(java.lang.String siteId, java.lang.String channelName, java.lang.String infoViewId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewDocImportService

public InfoViewDocImportService()
方法详细信息

getDocumentMgr

public DocumentMgr getDocumentMgr()

checkSysInfos

public void checkSysInfos(java.lang.String _sChannelId,
                          java.lang.String _sInfoViewId)
                   throws java.lang.Exception
抛出：
java.lang.Exception

retriveChannelInfo

public java.lang.String retriveChannelInfo(java.lang.String siteId,
                                           java.lang.String channelName,
                                           java.lang.String infoViewId)
                                    throws java.lang.Exception
抛出：
java.lang.Exception

importInfoViewData

public java.lang.String importInfoViewData(byte[] _importData,
                                           byte[] _signData,
                                           java.lang.String _sChannelId,
                                           java.lang.String _sInfoViewId)
                                    throws java.lang.Exception
抛出：
java.lang.Exception

importInfoViewData

public java.lang.String importInfoViewData(byte[] _importData,
                                           byte[] _signData,
                                           java.lang.String _sChannelId,
                                           java.lang.String _sInfoViewId,
                                           java.lang.String _sPostUser,
                                           java.lang.String _sAttributeStr)
                                    throws java.lang.Exception
抛出：
java.lang.Exception

importInfoViewDataForCustom

public java.lang.String importInfoViewDataForCustom(org.dom4j.Document xmlDoc,
                                                    java.lang.String _sChannelId,
                                                    java.lang.String _sInfoViewId,
                                                    java.lang.String _sPostUser,
                                                    java.util.HashMap _map)
                                             throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewEnumCreatorImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 InfoViewEnumCreatorImpl

java.lang.Object
    继承者  com.trs.service.impl.InfoViewEnumCreatorImpl
所有已实现的接口：
IInfoViewEnumCreator
public class InfoViewEnumCreatorImpl
extends java.lang.Object
implements IInfoViewEnumCreator

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
InfoViewEnumCreatorImpl()
方法摘要
 java.lang.Object enumScript(InfoViewContext _oContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewEnumCreatorImpl

public InfoViewEnumCreatorImpl()
                        throws WCMException
抛出：
WCMException
方法详细信息

enumScript

public java.lang.Object enumScript(InfoViewContext _oContext)
                            throws WCMException
指定者：
接口 IInfoViewEnumCreator 中的 enumScript
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewInitorImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 InfoViewInitorImpl

java.lang.Object
    继承者  com.trs.service.impl.InfoViewInitorImpl
所有已实现的接口：
IInfoViewInitor
public class InfoViewInitorImpl
extends java.lang.Object
implements IInfoViewInitor

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
InfoViewInitorImpl()
方法摘要
java.lang.Object | getFieldValue(InfoViewContext _oContext, BindingBean _oBean)
java.lang.Object | init(InfoViewContext _oContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewInitorImpl

public InfoViewInitorImpl()
方法详细信息

init

public java.lang.Object init(InfoViewContext _oContext)
                      throws WCMException
指定者：
接口 IInfoViewInitor 中的 init
抛出：
WCMException

getFieldValue

public java.lang.Object getFieldValue(InfoViewContext _oContext,
                                      BindingBean _oBean)
                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoViewService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 InfoViewService

java.lang.Object
    继承者  com.trs.service.impl.InfoViewService
所有已实现的接口：
IInfoViewService
public class InfoViewService
extends java.lang.Object
implements IInfoViewService

自定义表单管理的公共接口定义IInfoViewService的实现

作者：
Martin (Fu Chengrui)

构造方法摘要
InfoViewService()
缺省构造方法
方法摘要
void | delete(InfoView _oInfoView) 彻底删除指定的自定义表单
void | delete(InfoViews _oInfoViews) 彻底删除指定的自定义表单集合 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。
void | delete(int _iInfoViewID) 根据自定义表单的ID彻底删除自定义表单
void | delete(java.lang.String _sInfoViewIDs) 根据自定义表单的ID列表彻底删除自定义表单， 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。
java.lang.String | filterContentInFlow(InfoView _oInfoView, java.lang.String _sXmlContent, int nFlowDocId)
InfoView | findById(int _iInfoViewID) 在指定的站点下查找指定ID的自定义表单
InfoViewView | findViewById(int _iViewID) 查找指定ID的自定义表单视图
java.lang.String | forFillOut(InfoView _oInfoView, InfoViewView _oView) 为了在WCM内部填写表单而生成HTML页面 事实上生成的HTML页面不仅用于内部填写表单、还用在表单预览、表单数据察看。
java.lang.String | forFillOutInFlow(InfoView _oInfoView, InfoViewView _oView, int _flowDocId)
java.lang.String | forFillOutInner(InfoView _oInfoView, InfoViewView _oView)
java.lang.String | forFillOutInner(InfoView _oInfoView, InfoViewView _oView, boolean _bNewDocInFlow)
java.util.List | getAppendixList(org.dom4j.Document dom4jDocument) 从org.dom4j.Document对象中抽取附件信息 作为输入的org.dom4j.Document对象，在抽取附件信息，其中的附件标示信息已经被删除。
java.util.List | getAppendixList(java.lang.String xmlContent) 从XML文件中抽取附件信息
java.lang.String | getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument) 按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题
java.lang.String | getDocumentTitle(InfoView _oInfoView, org.dom4j.Document dom4jDocument, java.lang.String sPostUserName) 按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题
java.lang.String | getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent) 按照相关表单的设定从XML文件抽取文档的标题
java.lang.String | getDocumentTitle(InfoView _oInfoView, java.lang.String xmlContent, java.lang.String sPostUserName)
org.dom4j.Document | getDOM4JDocument(java.lang.String xmlContent) 将XML文件的内容转化为org.dom4j.Document对象
java.util.List | getEmployedInfoViews(CMSObj _employer) 获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合
java.util.List | getEmployedInfoViews(int _iEmployerType, int _iEmployerId) 获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合
java.util.List | getInfoViewEmployers(InfoView _employed) 获取指定自定义表单的所有雇主（频道对象）的集合
java.util.List | getInfoViewEmployers(int _iInfoViewID) 获取指定自定义表单的所有雇主（频道对象）的集合
InfoViews | getInfoViews(WCMFilter _filter) 获取所有符合条件的自定义表单
java.lang.String | getInfoViewSerial(InfoView _oInfoView) 获取指定表单的编号
java.lang.String | getInfoViewSerial(int _iInfoViewId) 获取指定表单的编号
void | rebuildXSLT(InfoView _oInfoView)
void | rebuildXSLTByFields(InfoView _oInfoView, java.util.List _lstFields)
void | save(InfoView _oInfoView) 保存指定的自定义表单
void | save(InfoViewField _oField) 保存指定的自定义表单字段
void | save(InfoViewGroup _oGroup) 保存指定的自定义表单数据节
void | save(InfoViewView _oView) 保存指定的自定义表单视图
void | saveViewByFields(InfoView _oInfoView, java.util.List _lstFields)
void | sendReplyNotice(InfoView _oInfoView, Document _document, DocReply _docReply, boolean _zSendEmail, boolean _zSendMessage) 发送表单文档的回复通知 优先使用表单上的设置
void | sendReplyNotice(int _iInfoViewId, int _iDocumentId, int _iDocReplyId, boolean _zSendEmail, boolean _zSendMessage) 发送表单文档的回复通知 优先使用表单上的设置
void | setEmployedInfoView(CMSObj _employer, InfoView _oInfoView) 设置雇主（通常是频道）雇佣的自定义表单的ID列表
void | setEmployedInfoViews(CMSObj _employer, java.lang.String _sInfoViewIDs) 设置雇主（通常是频道）雇佣的自定义表单的ID列表
void | setFieldsReadOnly(InfoView _oInfoView, InfoViewFields _oInfoViewFields, boolean _bReadonly)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoViewService

public InfoViewService()
缺省构造方法

方法详细信息

delete

public void delete(InfoView _oInfoView)
            throws WCMException
从接口 IInfoViewService 复制的描述
彻底删除指定的自定义表单

指定者：
接口 IInfoViewService 中的 delete
参数：
_oInfoView - 待删除的自定义表单
抛出：
WCMException - 如果操作失败

delete

public void delete(InfoViews _oInfoViews)
            throws WCMException
从接口 IInfoViewService 复制的描述
彻底删除指定的自定义表单集合 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。

指定者：
接口 IInfoViewService 中的 delete
参数：
_oInfoViews - 待删除的自定义表单集合
抛出：
WCMException - 如果操作失败

delete

public void delete(int _iInfoViewID)
            throws WCMException
从接口 IInfoViewService 复制的描述
根据自定义表单的ID彻底删除自定义表单

指定者：
接口 IInfoViewService 中的 delete
参数：
_iInfoViewID - 待删除的自定义表单的ID
抛出：
WCMException - 如果操作失败

delete

public void delete(java.lang.String _sInfoViewIDs)
            throws WCMException
从接口 IInfoViewService 复制的描述
根据自定义表单的ID列表彻底删除自定义表单， 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。

指定者：
接口 IInfoViewService 中的 delete
参数：
_sInfoViewIDs - 待删除的自定义表单的ID列表，形如2,3,5,13
抛出：
WCMException - 如果操作失败

findById

public InfoView findById(int _iInfoViewID)
                  throws WCMException
从接口 IInfoViewService 复制的描述
在指定的站点下查找指定ID的自定义表单

指定者：
接口 IInfoViewService 中的 findById
参数：
_iInfoViewID - 指定的表单ID
返回：
符合条件的自定义表单或者null
抛出：
WCMException - 如果操作失败

findViewById

public InfoViewView findViewById(int _iViewID)
                          throws WCMException
从接口 IInfoViewService 复制的描述
查找指定ID的自定义表单视图

指定者：
接口 IInfoViewService 中的 findViewById
参数：
_iViewID - 视图的ID
返回：
符合条件的视图对象或者null
抛出：
WCMException - 如果操作失败

forFillOut

public java.lang.String forFillOut(InfoView _oInfoView,
                                   InfoViewView _oView)
                            throws WCMException
从接口 IInfoViewService 复制的描述
为了在WCM内部填写表单而生成HTML页面 事实上生成的HTML页面不仅用于内部填写表单、还用在表单预览、表单数据察看。

指定者：
接口 IInfoViewService 中的 forFillOut
参数：
_oInfoView - 指定的表单
_oView - 指定的视图
返回：
生成HTML页面的内容
抛出：
WCMException - 如果发生错误

forFillOutInner

public java.lang.String forFillOutInner(InfoView _oInfoView,
                                        InfoViewView _oView)
                                 throws WCMException
指定者：
接口 IInfoViewService 中的 forFillOutInner
抛出：
WCMException

forFillOutInner

public java.lang.String forFillOutInner(InfoView _oInfoView,
                                        InfoViewView _oView,
                                        boolean _bNewDocInFlow)
                                 throws WCMException
指定者：
接口 IInfoViewService 中的 forFillOutInner
抛出：
WCMException

forFillOutInFlow

public java.lang.String forFillOutInFlow(InfoView _oInfoView,
                                         InfoViewView _oView,
                                         int _flowDocId)
                                  throws WCMException,
                                         java.lang.Throwable
指定者：
接口 IInfoViewService 中的 forFillOutInFlow
抛出：
WCMException
java.lang.Throwable

filterContentInFlow

public java.lang.String filterContentInFlow(InfoView _oInfoView,
                                            java.lang.String _sXmlContent,
                                            int nFlowDocId)
                                     throws WCMException,
                                            java.lang.Throwable
指定者：
接口 IInfoViewService 中的 filterContentInFlow
抛出：
WCMException
java.lang.Throwable

getInfoViews

public InfoViews getInfoViews(WCMFilter _filter)
                       throws WCMException
从接口 IInfoViewService 复制的描述
获取所有符合条件的自定义表单

指定者：
接口 IInfoViewService 中的 getInfoViews
参数：
_filter - 条件
返回：
符合条件的自定义表单集合
抛出：
WCMException - 如果发生错误

getInfoViewEmployers

public java.util.List getInfoViewEmployers(InfoView _employed)
                                    throws WCMException
从接口 IInfoViewService 复制的描述
获取指定自定义表单的所有雇主（频道对象）的集合

指定者：
接口 IInfoViewService 中的 getInfoViewEmployers
参数：
_employed - 指定的自定义表单
返回：
指定自定义表单的所有雇主的集合
抛出：
WCMException - 如果操作失败

getInfoViewEmployers

public java.util.List getInfoViewEmployers(int _iInfoViewID)
                                    throws WCMException
从接口 IInfoViewService 复制的描述
获取指定自定义表单的所有雇主（频道对象）的集合

指定者：
接口 IInfoViewService 中的 getInfoViewEmployers
参数：
_iInfoViewID - 指定的自定义表单的ID
返回：
指定自定义表单的所有雇主的集合
抛出：
WCMException - 如果操作失败

getEmployedInfoViews

public java.util.List getEmployedInfoViews(CMSObj _employer)
                                    throws WCMException
从接口 IInfoViewService 复制的描述
获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合

指定者：
接口 IInfoViewService 中的 getEmployedInfoViews
参数：
_employer - 指定的雇主
返回：
全部受雇表单的集合
抛出：
WCMException - 如果操作失败

getEmployedInfoViews

public java.util.List getEmployedInfoViews(int _iEmployerType,
                                           int _iEmployerId)
                                    throws WCMException
从接口 IInfoViewService 复制的描述
获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合

指定者：
接口 IInfoViewService 中的 getEmployedInfoViews
参数：
_iEmployerType - 指定的雇主的类型
_iEmployerId - 指定的雇主的ID
返回：
全部受雇表单的集合
抛出：
WCMException - 如果操作失败

save

public void save(InfoView _oInfoView)
          throws WCMException
从接口 IInfoViewService 复制的描述
保存指定的自定义表单

指定者：
接口 IInfoViewService 中的 save
参数：
_oInfoView - 指定的表单
抛出：
WCMException - 如果操作失败

rebuildXSLT

public void rebuildXSLT(InfoView _oInfoView)
                 throws WCMException
指定者：
接口 IInfoViewService 中的 rebuildXSLT
抛出：
WCMException

rebuildXSLTByFields

public void rebuildXSLTByFields(InfoView _oInfoView,
                                java.util.List _lstFields)
                         throws WCMException
指定者：
接口 IInfoViewService 中的 rebuildXSLTByFields
抛出：
WCMException

saveViewByFields

public void saveViewByFields(InfoView _oInfoView,
                             java.util.List _lstFields)
                      throws WCMException
指定者：
接口 IInfoViewService 中的 saveViewByFields
抛出：
WCMException

save

public void save(InfoViewField _oField)
          throws WCMException
从接口 IInfoViewService 复制的描述
保存指定的自定义表单字段

指定者：
接口 IInfoViewService 中的 save
参数：
_oField - 指定的字段对象
抛出：
WCMException - 如果操作失败

save

public void save(InfoViewGroup _oGroup)
          throws WCMException
从接口 IInfoViewService 复制的描述
保存指定的自定义表单数据节

指定者：
接口 IInfoViewService 中的 save
参数：
_oGroup - 指定的数据节对象
抛出：
WCMException - 如果操作失败

save

public void save(InfoViewView _oView)
          throws WCMException
从接口 IInfoViewService 复制的描述
保存指定的自定义表单视图

指定者：
接口 IInfoViewService 中的 save
参数：
_oView - 指定的视图对象
抛出：
WCMException - 如果操作失败

setEmployedInfoView

public void setEmployedInfoView(CMSObj _employer,
                                InfoView _oInfoView)
                         throws WCMException
从接口 IInfoViewService 复制的描述
设置雇主（通常是频道）雇佣的自定义表单的ID列表

指定者：
接口 IInfoViewService 中的 setEmployedInfoView
参数：
_employer - 雇主对象
_oInfoView - 表单对象
抛出：
WCMException - 如果操作失败

setEmployedInfoViews

public void setEmployedInfoViews(CMSObj _employer,
                                 java.lang.String _sInfoViewIDs)
                          throws WCMException
从接口 IInfoViewService 复制的描述
设置雇主（通常是频道）雇佣的自定义表单的ID列表

指定者：
接口 IInfoViewService 中的 setEmployedInfoViews
参数：
_employer - 雇主对象
_sInfoViewIDs - 受雇的表单ID列表
抛出：
WCMException - 如果操作失败

getAppendixList

public java.util.List getAppendixList(org.dom4j.Document dom4jDocument)
                               throws WCMException
从接口 IInfoViewService 复制的描述
从org.dom4j.Document对象中抽取附件信息 作为输入的org.dom4j.Document对象，在抽取附件信息，其中的附件标示信息已经被删除。

指定者：
接口 IInfoViewService 中的 getAppendixList
参数：
dom4jDocument - 传入的org.dom4j.Document对象
返回：
附件列表，可以为null
抛出：
WCMException - 如果操作失败

getAppendixList

public java.util.List getAppendixList(java.lang.String xmlContent)
                               throws WCMException
从接口 IInfoViewService 复制的描述
从XML文件中抽取附件信息

指定者：
接口 IInfoViewService 中的 getAppendixList
参数：
xmlContent - XML文件的内容
返回：
附件列表，可以为null
抛出：
WCMException - 如果操作失败

getDocumentTitle

public java.lang.String getDocumentTitle(InfoView _oInfoView,
                                         org.dom4j.Document dom4jDocument)
                                  throws WCMException
从接口 IInfoViewService 复制的描述
按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题

指定者：
接口 IInfoViewService 中的 getDocumentTitle
参数：
_oInfoView - 相关的表单对象
dom4jDocument - 传入的org.dom4j.Document对象
返回：
从XML中获得的文档标题
抛出：
WCMException - 如果操作失败

getDocumentTitle

public java.lang.String getDocumentTitle(InfoView _oInfoView,
                                         java.lang.String xmlContent)
                                  throws WCMException
从接口 IInfoViewService 复制的描述
按照相关表单的设定从XML文件抽取文档的标题

指定者：
接口 IInfoViewService 中的 getDocumentTitle
参数：
_oInfoView - 相关的表单对象
xmlContent - XML文件的内容
返回：
从XML中获得的文档标题
抛出：
WCMException - 如果操作失败

getDocumentTitle

public java.lang.String getDocumentTitle(InfoView _oInfoView,
                                         org.dom4j.Document dom4jDocument,
                                         java.lang.String sPostUserName)
                                  throws WCMException
从接口 IInfoViewService 复制的描述
按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题

指定者：
接口 IInfoViewService 中的 getDocumentTitle
参数：
_oInfoView - 相关的表单对象
dom4jDocument - 传入的org.dom4j.Document对象
返回：
从XML中获得的文档标题
抛出：
WCMException - 如果操作失败

getDocumentTitle

public java.lang.String getDocumentTitle(InfoView _oInfoView,
                                         java.lang.String xmlContent,
                                         java.lang.String sPostUserName)
                                  throws WCMException
抛出：
WCMException

getDOM4JDocument

public org.dom4j.Document getDOM4JDocument(java.lang.String xmlContent)
                                    throws WCMException
从接口 IInfoViewService 复制的描述
将XML文件的内容转化为org.dom4j.Document对象

指定者：
接口 IInfoViewService 中的 getDOM4JDocument
参数：
xmlContent - XML文件的内容
返回：
org.dom4j.Document对象
抛出：
WCMException - 如果操作失败

getInfoViewSerial

public java.lang.String getInfoViewSerial(int _iInfoViewId)
                                   throws WCMException
从接口 IInfoViewService 复制的描述
获取指定表单的编号

指定者：
接口 IInfoViewService 中的 getInfoViewSerial
参数：
_iInfoViewId - 指定的表单Id
返回：
抛出：
WCMException

getInfoViewSerial

public java.lang.String getInfoViewSerial(InfoView _oInfoView)
                                   throws WCMException
从接口 IInfoViewService 复制的描述
获取指定表单的编号

指定者：
接口 IInfoViewService 中的 getInfoViewSerial
参数：
_oInfoView - 指定的表单
返回：
抛出：
WCMException

sendReplyNotice

public void sendReplyNotice(int _iInfoViewId,
                            int _iDocumentId,
                            int _iDocReplyId,
                            boolean _zSendEmail,
                            boolean _zSendMessage)
                     throws WCMException
从接口 IInfoViewService 复制的描述
发送表单文档的回复通知
优先使用表单上的设置

指定者：
接口 IInfoViewService 中的 sendReplyNotice
参数：
_iInfoViewId - 表单Id
_iDocumentId - 表单文档Id
_iDocReplyId - 表单文档回复Id
_zSendEmail - 是否发送Email
_zSendMessage - 是否发送系统短消息
抛出：
WCMException

sendReplyNotice

public void sendReplyNotice(InfoView _oInfoView,
                            Document _document,
                            DocReply _docReply,
                            boolean _zSendEmail,
                            boolean _zSendMessage)
                     throws WCMException
从接口 IInfoViewService 复制的描述
发送表单文档的回复通知
优先使用表单上的设置

指定者：
接口 IInfoViewService 中的 sendReplyNotice
参数：
_oInfoView - 表单对象
_document - 表单文档对象
_docReply - 表单回复对象
_zSendEmail - 是否发送Email
_zSendMessage - 是否发送系统短消息
抛出：
WCMException

setFieldsReadOnly

public void setFieldsReadOnly(InfoView _oInfoView,
                              InfoViewFields _oInfoViewFields,
                              boolean _bReadonly)
                       throws WCMException
指定者：
接口 IInfoViewService 中的 setFieldsReadOnly
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NetSnapTool

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 NetSnapTool

java.lang.Object
    继承者  com.trs.service.impl.NetSnapTool

public class NetSnapTool
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
NetSnapTool工具辅助
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
NetSnapTool()
方法摘要
static java.lang.String | getTreeInfo(java.lang.String name, int rightIndex, int siteType, boolean addRoot)
static java.lang.String | getTreeInfo2(java.lang.String name, int rightIndex, int siteType, boolean addRoot)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NetSnapTool

public NetSnapTool()
方法详细信息

getTreeInfo2

public static java.lang.String getTreeInfo2(java.lang.String name,
                                            int rightIndex,
                                            int siteType,
                                            boolean addRoot)
                                     throws java.lang.Exception
抛出：
java.lang.Exception

getTreeInfo

public static java.lang.String getTreeInfo(java.lang.String name,
                                           int rightIndex,
                                           int siteType,
                                           boolean addRoot)
                                    throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OfficeDocumentService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 OfficeDocumentService

java.lang.Object
    继承者  com.trs.service.impl.OfficeDocumentService
所有已实现的接口：
IOfficeDocumentService
public class OfficeDocumentService
extends java.lang.Object
implements IOfficeDocumentService

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 LY

构造方法摘要
OfficeDocumentService()
方法摘要
 java.lang.String convert2Html(java.lang.String _sFileName)
Soap调用OfficeConverter处理文件，转换成HTML文件的zip包
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OfficeDocumentService

public OfficeDocumentService()
方法详细信息

convert2Html

public java.lang.String convert2Html(java.lang.String _sFileName)
                              throws java.lang.Exception
从接口 IOfficeDocumentService 复制的描述
Soap调用OfficeConverter处理文件，转换成HTML文件的zip包

指定者：
接口 IOfficeDocumentService 中的 convert2Html
返回：
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.service.impl
类
AutoDocBakService
BookMarkService
CDSServiceImpl
ChannelService
ContactService
CustomizeService
DBService
DocumentService
EventService
FtpSoap4Radar
GroupService
InfoViewDocImportService
InfoViewEnumCreatorImpl
InfoViewInitorImpl
InfoViewService
NetSnapTool
OfficeDocumentService
PublishService
RecentService
ResouceService
RoleService
ScheduleService
SecurityService
SiteNameCreator
SOAPServiceImpl
StatService
SureformService
TemplateParseService
TemplateService
UserService
WCMProcessServiceImpl
WCMPublishElementServiceImpl


com.trs.service.impl

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.service.impl

类摘要
AutoDocBakService | Title: TRS 内容协作平台（TRS WCM） Description: 实现IAutoDocBakService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
BookMarkService | Title: TRS 内容协作平台（TRS WCM） Description: 实现IBookMarkService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CDSServiceImpl | Title: TRS 内容协作平台（TRS WCM） Description: CDS Service Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelService | Title: TRS 内容协作平台（TRS WCM） Description:
ContactService | Title: TRS 内容协作平台（TRS WCM） Description: 联系人服务接口实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CustomizeService | Title: TRS 内容协作平台（TRS WCM） Description: 个性化定制服务提供对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DBService | Title: TRS 内容协作平台（TRS WCM） Description: 数据库相关操作服务层接口实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentService |
EventService | Title: TRS 内容协作平台（TRS WCM） Description: 日程服务提供对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FtpSoap4Radar | Title: TRS 内容协作平台（TRS WCM） Description: 通过FTP配合接收雷达的数据(SOAP),需要配置类路径中的ftpsoap4radar.properties Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
GroupService | Title: TRS 内容协作平台（TRS WCM） Description: 组织管理的服务接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDocImportService | Title: TRS 内容协作平台（TRS WCM） Description: 从网关中转过来的数据导入 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewEnumCreatorImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewInitorImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewService | 自定义表单管理的公共接口定义IInfoViewService的实现
NetSnapTool | Title: TRS 内容协作平台（TRS WCM） Description: NetSnapTool工具辅助 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OfficeDocumentService | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PublishService | Title: TRS 内容协作平台（TRS WCM） Description: implementation for IPublishService.
RecentService | Title: TRS 内容协作平台（TRS WCM） Description: 为“最近处理的对象” 提供的服务层接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ResouceService | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RoleService | Title: TRS 内容协作平台（TRS WCM） Description: 角色相关服务接口的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ScheduleService | Title: TRS 内容协作平台（TRS WCM） Description: 计划服务器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SecurityService |
SiteNameCreator |
SOAPServiceImpl | Title: TRS 内容协作平台（TRS WCM） Description: 对外的SOAP接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
StatService | Title: TRS 内容协作平台（TRS WCM） Description: 实现统计服务接口提供的功能 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
SureformService | Title: TRS 内容协作平台（TRS WCM） Description: WCM为书生表单定制的接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseService | Title: TRS 内容协作平台（TRS WCM） Description: 提供模板解析接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateService | Title: TRS 内容协作平台（TRS WCM） Description: 模板服务提供对象的定义和实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
UserService | Title: TRS 内容协作平台（TRS WCM） Description:
WCMProcessServiceImpl | Title: TRS 内容协作平台（TRS WCM） Description: IWCMProcessService的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMPublishElementServiceImpl | Title: TRS 内容协作平台（TRS WCM） Description: implementation for IWCMPublishElementService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.service.impl 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.service.impl 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.service.impl.AutoDocBakService (implements com.trs.service.IAutoDocBakService)
    • com.trs.service.impl.BookMarkService (implements com.trs.service.IBookMarkService)
    • com.trs.service.impl.CDSServiceImpl (implements com.trs.service.ICDSService)
    • com.trs.service.impl.ChannelService (implements com.trs.service.IChannelService)
    • com.trs.service.impl.ContactService (implements com.trs.service.IContactService)
    • com.trs.service.impl.CustomizeService (implements com.trs.service.ICustomizeService)
    • com.trs.service.impl.DBService (implements com.trs.service.IDBService)
    • com.trs.service.impl.DocumentService (implements com.trs.service.IDocumentService)
    • com.trs.service.impl.EventService (implements com.trs.service.IEventService)
    • com.trs.service.impl.FtpSoap4Radar
    • com.trs.service.impl.GroupService (implements com.trs.service.IGroupService)
    • com.trs.service.impl.InfoViewDocImportService
    • com.trs.service.impl.InfoViewEnumCreatorImpl (implements com.trs.service.IInfoViewEnumCreator)
    • com.trs.service.impl.InfoViewInitorImpl (implements com.trs.service.IInfoViewInitor)
    • com.trs.service.impl.InfoViewService (implements com.trs.service.IInfoViewService)
    • com.trs.service.impl.NetSnapTool
    • com.trs.service.impl.OfficeDocumentService (implements com.trs.service.IOfficeDocumentService)
    • com.trs.service.impl.PublishService (implements com.trs.service.IPublishService)
    • com.trs.service.impl.RecentService (implements com.trs.service.IRecentService)
    • com.trs.service.impl.ResouceService (implements com.trs.service.IResourceService)
    • com.trs.service.impl.RoleService (implements com.trs.service.IRoleService)
    • com.trs.service.impl.ScheduleService (implements com.trs.service.IScheduleService)
    • com.trs.service.impl.SecurityService (implements com.trs.service.ISecurityService)
    • com.trs.service.impl.SiteNameCreator (implements com.trs.service.IInfoViewInitorValue)
    • com.trs.service.impl.SOAPServiceImpl (implements com.trs.service.ISOAPService)
    • com.trs.service.impl.StatService (implements com.trs.service.IStatService)
    • com.trs.service.impl.SureformService (implements com.trs.service.ISureformService)
    • com.trs.service.impl.TemplateParseService (implements com.trs.service.ITemplateParseService)
    • com.trs.service.impl.TemplateService (implements com.trs.service.ITemplateService)
    • com.trs.service.impl.UserService (implements com.trs.service.IUserService)
    • com.trs.service.impl.WCMProcessServiceImpl (implements com.trs.service.IWCMProcessService)
    • com.trs.service.impl.WCMPublishElementServiceImpl (implements com.trs.service.IWCMPublishElementService)


软件包 com.trs.service.impl 的使用

上一个 下一个 框架 无框架

软件包 com.trs.service.impl
的使用

没有 com.trs.service.impl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PublishService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 PublishService

java.lang.Object
    继承者  com.trs.service.impl.PublishService
所有已实现的接口：
IPublishService
public class PublishService
extends java.lang.Object
implements IPublishService

Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IPublishService.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
PublishService()
constructor: default
方法摘要
void | cancelTasks(java.lang.String _sTaskIds) 取消指定的发布任务集合
void | delete(BaseChannel _siteOrChannel) 已过时。 根本就没有没有使用，声明为废弃的，以标识
void | delete(Document _document) 已过时。 根本就没有没有使用，声明为废弃的，以标识
void | delete(Document _document, Channel _channel) 已过时。 根本就没有没有使用，声明为废弃的，以标识
void | delete(Documents _documents) 已过时。 根本就没有没有使用，声明为废弃的，以标识
void | delete(Documents _documents, Channel _channel) 从指定频道上删除指定文档集合已发布的页面
void | deleteTasks(java.lang.String _sTaskIds)
PublishTasks | getAllTasks(WCMFilter _filter) 提取所有的发布任务；要求当前用户必须具有管理权限
User | getLoginUser()
PublishTasks | getMyTasks(WCMFilter _filter) 提取我的发布任务
PublishTask | getRunningTask(int iTaskID) 返回指定ID的正在执行的发布任务对象
java.util.Iterator | getRunningTasks() 返回所有的正在执行的任务
PublishTaskRuntime | getTaskRuntime(int iTaskID) 返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
void | pauseTask(java.lang.String _sTaskIds) 暂停指定的发布任务集合，对其中不处于执行状态的任务不会产生影响
java.lang.String[] | preview(BaseChannel _siteOrChannel, java.lang.String[] _warningsToReturn) 预览指定的站点/频道，并返回预览页面的URL列表（若配置了多个概览模板，则可能有多个）。
java.lang.String | preview(Document _document, Channel _channel, java.lang.String[] _warningsHolder) 在指定的频道上预览文档，并返回预览页面的URL。
java.lang.String | preview(Document _document, Channel _channel, java.lang.String[] holder, Template _template)
java.lang.String | preview(Document _document, java.lang.String[] _warningsHolder) 在文档的存放点上预览文档，并返回预览页面的URL。
java.lang.String | previewInfoviewPrint(Document _document, Channel _channel, java.lang.String[] _warningsHolder, int _templateId)
void | publish(BaseChannel _siteOrChannel, int _nPublishType) 完全发布站点/频道
void | publish(ChnlDocs _chnlDocs, int _nPubType) 发布指定的ChnlDoc集合，用于“最近访问文档”的直接发布
void | publish(Document _document, Channel _channel, int _nPubType) 发布文档
void | publish(Document _document, int _nPubType) 发布文档
void | publish(Documents _documents, Channel _channel, int _nPubType) 发布指定文档集合
void | publish(Documents _documents, int _nPubType) 发布指定文档集合
void | publishConfirm(BaseChannel _oSiteOrChnl, java.lang.String _sSourceFile, java.lang.String _sTargetFile, java.lang.String _sBackupFile) 确认（批准）发布 用于先将站点或频道的首页发布到一个临时文件，在确认没有错误后，再把临时文件重名为正式的站点或频道首页。
void | publishForcibly(int _nDocumentId, java.lang.String _sChannelIds) 强制在指定的频道中发布文档， 如果文档在指定的频道中状态为不允许发布状态，将会自动改为可发布的状态，然后再发不
void | redoTasks(java.lang.String _sTaskIds) 重新执行指定的发布任务集合
void | resumeTask(java.lang.String _sTaskIds) 恢复指定的发布任务集合，对其中不处于暂停状态的任务不会产生影响
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PublishService

public PublishService()
constructor: default

方法详细信息

getLoginUser

public User getLoginUser()
指定者：
接口 IPublishService 中的 getLoginUser
返回：
返回当前登录用户
另请参见：
IPublishService.getLoginUser()

preview

public java.lang.String[] preview(BaseChannel _siteOrChannel,
                                  java.lang.String[] _warningsToReturn)
                           throws WCMException
从接口 IPublishService 复制的描述
预览指定的站点/频道，并返回预览页面的URL列表（若配置了多个概览模板，则可能有多个）。
若在预览过程中存在一些警告信息，且指定了存储容器（_warningsHolder），这些警告信息会被存储在容器的第一个元素位置。

指定者：
接口 IPublishService 中的 preview
参数：
_siteOrChannel - 要预览的站点/频道
_warningsToReturn - 用以接纳警告信息的存储容器
返回：
返回预览页面的URL地址列表（可能有多个概览模板）
抛出：
WCMException - 若当前用户无预览权限，或预览失败，会抛出异常。

preview

public java.lang.String preview(Document _document,
                                java.lang.String[] _warningsHolder)
                         throws WCMException
从接口 IPublishService 复制的描述
在文档的存放点上预览文档，并返回预览页面的URL。
若在预览过程中存在一些警告信息，且指定了存储容器（_warningsHolder），这些警告信息会被存储在容器的第一个元素位置。

指定者：
接口 IPublishService 中的 preview
参数：
_document - 要预览的文档
_warningsHolder - 用以接纳警告信息的存储容器
返回：
返回预览页面的URL地址
抛出：
WCMException - 若当前用户无文档发布权限，或预览失败，会抛出异常。

preview

public java.lang.String preview(Document _document,
                                Channel _channel,
                                java.lang.String[] _warningsHolder)
                         throws WCMException
从接口 IPublishService 复制的描述
在指定的频道上预览文档，并返回预览页面的URL。
若在预览过程中存在一些警告信息，且指定了存储容器（_warningsHolder），这些警告信息会被存储在容器的第一个元素位置。

指定者：
接口 IPublishService 中的 preview
参数：
_document - 要预览的文档
_channel - 文档所在频道
_warningsHolder - 用以接纳警告信息的存储容器
返回：
返回预览页面的URL地址
抛出：
WCMException - 若当前用户无文档发布权限，或预览失败，会抛出异常。

previewInfoviewPrint

public java.lang.String previewInfoviewPrint(Document _document,
                                             Channel _channel,
                                             java.lang.String[] _warningsHolder,
                                             int _templateId)
                                      throws WCMException
指定者：
接口 IPublishService 中的 previewInfoviewPrint
抛出：
WCMException

publish

public void publish(BaseChannel _siteOrChannel,
                    int _nPublishType)
             throws WCMException
从接口 IPublishService 复制的描述
完全发布站点/频道

指定者：
接口 IPublishService 中的 publish
参数：
_siteOrChannel - 待发布的站点/频道
_nPublishType - 发布类型（如完全发布、增量发布等，定义在WCMPublisher中）
抛出：
WCMException

delete

public void delete(BaseChannel _siteOrChannel)
            throws WCMException
已过时。 根本就没有没有使用，声明为废弃的，以标识

从接口 IPublishService 复制的描述
删除指定站点/频道的发布页面

指定者：
接口 IPublishService 中的 delete
参数：
_siteOrChannel - 删除的站点/频道
抛出：
WCMException
另请参见：
com.trs.wcm.service.IPublishService#delete(com.trs.wcm.infra.channel.BaseChannel)

publish

public void publish(Document _document,
                    int _nPubType)
             throws java.lang.Exception
从接口 IPublishService 复制的描述
发布文档

指定者：
接口 IPublishService 中的 publish
参数：
_document - 待发布的文档
_nPubType - TODO
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

publish

public void publish(Document _document,
                    Channel _channel,
                    int _nPubType)
             throws java.lang.Exception
从接口 IPublishService 复制的描述
发布文档

指定者：
接口 IPublishService 中的 publish
参数：
_document - 待发布的文档
_channel - 文档所在频道
_nPubType - TODO
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

publish

public void publish(Documents _documents,
                    int _nPubType)
             throws java.lang.Exception
从接口 IPublishService 复制的描述
发布指定文档集合

指定者：
接口 IPublishService 中的 publish
参数：
_documents - 待发布的文档集合
_nPubType - TODO
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

publish

public void publish(Documents _documents,
                    Channel _channel,
                    int _nPubType)
             throws java.lang.Exception
从接口 IPublishService 复制的描述
发布指定文档集合

指定者：
接口 IPublishService 中的 publish
参数：
_documents - 待发布的文档集合
_channel - 文档所在频道
_nPubType - TODO
抛出：
java.lang.Exception - 若当前用户无发布权限,或发布失败，会抛出异常

delete

public void delete(Document _document)
            throws WCMException
已过时。 根本就没有没有使用，声明为废弃的，以标识

从接口 IPublishService 复制的描述
删除指定文档已发布的页面

指定者：
接口 IPublishService 中的 delete
参数：
_document - 待删除的文档
抛出：
WCMException - 若更新发布失败，会抛出异常
另请参见：
com.trs.wcm.service.IPublishService#delete(com.trs.wcm.infra.content.Document)

delete

public void delete(Document _document,
                   Channel _channel)
            throws WCMException
已过时。 根本就没有没有使用，声明为废弃的，以标识

从接口 IPublishService 复制的描述
从指定频道上删除指定文档已发布的页面

指定者：
接口 IPublishService 中的 delete
参数：
_document - 待删除的文档
_channel - 文档所在频道
抛出：
WCMException - 若更新发布失败，会抛出异常
另请参见：
com.trs.wcm.service.IPublishService#delete(com.trs.wcm.infra.content.Document, com.trs.wcm.infra.channel.Channel)

delete

public void delete(Documents _documents)
            throws WCMException
已过时。 根本就没有没有使用，声明为废弃的，以标识

从接口 IPublishService 复制的描述
删除指定文档集合已发布的页面

指定者：
接口 IPublishService 中的 delete
参数：
_documents - 待删除的文档
抛出：
WCMException - 若当前用户无发布权限,或更新发布失败，会抛出异常
另请参见：
com.trs.wcm.service.IPublishService#delete(com.trs.wcm.infra.content.Documents)

delete

public void delete(Documents _documents,
                   Channel _channel)
            throws WCMException
从接口 IPublishService 复制的描述
从指定频道上删除指定文档集合已发布的页面

指定者：
接口 IPublishService 中的 delete
参数：
_documents - 待删除的文档
抛出：
WCMException - 若当前用户无发布权限,或更新发布失败，会抛出异常

getMyTasks

public PublishTasks getMyTasks(WCMFilter _filter)
                        throws WCMException
从接口 IPublishService 复制的描述
提取我的发布任务

指定者：
接口 IPublishService 中的 getMyTasks
参数：
_filter - 附加筛选条件
返回：
返回当前用户的发布任务集合
抛出：
WCMException - 若提取发布任务集合失败，会抛出异常

getAllTasks

public PublishTasks getAllTasks(WCMFilter _filter)
                         throws WCMException
从接口 IPublishService 复制的描述
提取所有的发布任务；要求当前用户必须具有管理权限

指定者：
接口 IPublishService 中的 getAllTasks
参数：
_filter - 附加筛选条件
返回：
返回发布任务集合
抛出：
WCMException - 若用户没有管理权限，或提取发布任务集合失败，会抛出异常。

deleteTasks

public void deleteTasks(java.lang.String _sTaskIds)
                 throws WCMException
指定者：
接口 IPublishService 中的 deleteTasks
抛出：
WCMException

redoTasks

public void redoTasks(java.lang.String _sTaskIds)
               throws WCMException
从接口 IPublishService 复制的描述
重新执行指定的发布任务集合

指定者：
接口 IPublishService 中的 redoTasks
参数：
_sTaskIds - TODO
抛出：
WCMException - 若用户没有指定任务的管理权限，或重新执行发布任务失败，会抛出异常。

publish

public void publish(ChnlDocs _chnlDocs,
                    int _nPubType)
             throws java.lang.Exception
从接口 IPublishService 复制的描述
发布指定的ChnlDoc集合，用于“最近访问文档”的直接发布

指定者：
接口 IPublishService 中的 publish
_nPubType - TODO
抛出：
java.lang.Exception

cancelTasks

public void cancelTasks(java.lang.String _sTaskIds)
                 throws WCMException
从接口 IPublishService 复制的描述
取消指定的发布任务集合

指定者：
接口 IPublishService 中的 cancelTasks
参数：
_sTaskIds - 待取消的发布任务集合
抛出：
WCMException

pauseTask

public void pauseTask(java.lang.String _sTaskIds)
               throws WCMException
从接口 IPublishService 复制的描述
暂停指定的发布任务集合，对其中不处于执行状态的任务不会产生影响

指定者：
接口 IPublishService 中的 pauseTask
参数：
_sTaskIds - 待暂停的发布任务集合
抛出：
WCMException

resumeTask

public void resumeTask(java.lang.String _sTaskIds)
                throws WCMException
从接口 IPublishService 复制的描述
恢复指定的发布任务集合，对其中不处于暂停状态的任务不会产生影响

指定者：
接口 IPublishService 中的 resumeTask
参数：
_sTaskIds - 待恢复的发布任务集合
抛出：
WCMException

getTaskRuntime

public PublishTaskRuntime getTaskRuntime(int iTaskID)
从接口 IPublishService 复制的描述
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。

指定者：
接口 IPublishService 中的 getTaskRuntime
参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回其运行时对象PublishTaskRuntime， 否则返回 null。

getRunningTask

public PublishTask getRunningTask(int iTaskID)
从接口 IPublishService 复制的描述
返回指定ID的正在执行的发布任务对象

指定者：
接口 IPublishService 中的 getRunningTask
参数：
iTaskID - 指定的任务ID
返回：
如果指定ID的任务正在执行，则返回发布任务对象PublishTask， 否则返回 null。

getRunningTasks

public java.util.Iterator getRunningTasks()
从接口 IPublishService 复制的描述
返回所有的正在执行的任务

指定者：
接口 IPublishService 中的 getRunningTasks
返回：
所有的正在执行的任务

publishForcibly

public void publishForcibly(int _nDocumentId,
                            java.lang.String _sChannelIds)
                     throws WCMException
从接口 IPublishService 复制的描述
强制在指定的频道中发布文档， 如果文档在指定的频道中状态为不允许发布状态，将会自动改为可发布的状态，然后再发不

指定者：
接口 IPublishService 中的 publishForcibly
参数：
_nDocumentId - 指定的文档ID
_sChannelIds - 指定的频道序列（如果不指定，那么将会触发所有引用文档的频道进行发布）
抛出：
WCMException

publishConfirm

public void publishConfirm(BaseChannel _oSiteOrChnl,
                           java.lang.String _sSourceFile,
                           java.lang.String _sTargetFile,
                           java.lang.String _sBackupFile)
                    throws WCMException
从接口 IPublishService 复制的描述
确认（批准）发布 用于先将站点或频道的首页发布到一个临时文件，在确认没有错误后，再把临时文件重名为正式的站点或频道首页。 并把原来的正式的站点或频道首页（如果存在）重命名为备份文件名。

指定者：
接口 IPublishService 中的 publishConfirm
参数：
_oSiteOrChnl - 站点或者频道对象，不能为空。
_sSourceFile - 源文件名，即上面的临时文件名，不能为空。
_sTargetFile - 目标文件名，即站点或频道的正式首页。如果为空，则取系统配置的缺省值，一般是“index.html”。
_sBackupFile - 备份文件名。如果为空，则取系统配置的缺省值，一般是“index.html.bak”。
抛出：
WCMException - 如果发生错误

preview

public java.lang.String preview(Document _document,
                                Channel _channel,
                                java.lang.String[] holder,
                                Template _template)
                         throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RecentService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 RecentService

java.lang.Object
    继承者  com.trs.service.impl.RecentService
所有已实现的接口：
IRecentService
public class RecentService
extends java.lang.Object
implements IRecentService

Title: TRS 内容协作平台（TRS WCM）
Description:
为“最近处理的对象” 提供的服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RecentService()
方法摘要
boolean | add(int _nObjType, int _nObjId) 添加最近访问的WCM对象
boolean | add(int _nObjType, java.lang.String _sObjIds) 添加最近访问的WCM对象
boolean | addChnlDoc(int _nChannelId, int _nDocumentId) 添加最近访问的ChnlDoc
Channels | getChannels(WCMFilter _aFilter) 返回用户最近访问的频道列表 按照访问的时间顺序排序
Channels | getChannels(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道列表 按照访问的时间顺序排序
Channels | getChannels(WCMFilter _filter, boolean _bIncludeDeleted, int _nRightIndex) 获取用户最近访问的频道集合,并校验访问指定权限.
Channels | getChannelsWithRight(WCMFilter _filter) 获取用户最近访问的频道集合,并校验访问权限.
ChnlDocs | getChnlDocs(WCMFilter _aFilter) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
ChnlDocs | getChnlDocs(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的频道文档列表 按照访问的时间顺序排序
Documents | getDocuments(WCMFilter _aFilter) 返回用户最近访问的文档列表 由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
Documents | getDocuments(WCMFilter _aFilter, boolean _bIncludeDeleted) 返回用户最近访问的文档列表 由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
java.lang.String | getIds(int _nObjTypeId) 根据对象的类型，得到最近访问的该对象的集合Ids
User | getLoginUser() 获得当前登录用户
Templates | getTemplates(WCMFilter _aFilter) 返回用户最近访问的模板列表 按照访问的时间顺序排序
WebSites | getWebSites(WCMFilter _aFilter) 返回用户最近访问的站点列表 按照访问的时间顺序排序
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RecentService

public RecentService()
方法详细信息

getLoginUser

public User getLoginUser()
从接口 IRecentService 复制的描述
获得当前登录用户

指定者：
接口 IRecentService 中的 getLoginUser
返回：
当前登录用户

add

public boolean add(int _nObjType,
                   int _nObjId)
            throws WCMException
从接口 IRecentService 复制的描述
添加最近访问的WCM对象

指定者：
接口 IRecentService 中的 add
参数：
_nObjType - WCM对象TypeID
_nObjId - 该对象的具体ID
返回：
是否添加成功
抛出：
WCMException

getIds

public java.lang.String getIds(int _nObjTypeId)
                        throws WCMException
从接口 IRecentService 复制的描述
根据对象的类型，得到最近访问的该对象的集合Ids

指定者：
接口 IRecentService 中的 getIds
参数：
_nObjTypeId - 欲查询的对象Id
返回：
“我”最近访问的对象Id列表，如果没有访问过这种对象，则返回NULL
抛出：
WCMException

getDocuments

public Documents getDocuments(WCMFilter _aFilter)
                       throws WCMException
从接口 IRecentService 复制的描述
返回用户最近访问的文档列表
由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询

指定者：
接口 IRecentService 中的 getDocuments
参数：
_aFilter - 用户指定的查询条件
返回：
按照访问时间降序排列的文档集合
抛出：
WCMException

getDocuments

public Documents getDocuments(WCMFilter _aFilter,
                              boolean _bIncludeDeleted)
                       throws WCMException
从接口 IRecentService 复制的描述
返回用户最近访问的文档列表
由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询

指定者：
接口 IRecentService 中的 getDocuments
参数：
_aFilter - 用户指定的查询条件
_bIncludeDeleted - true为包含已经删除的，false为不包含已经删除的
返回：
@throws WCMException
抛出：
WCMException

getChannels

public Channels getChannels(WCMFilter _aFilter)
                     throws WCMException
从接口 IRecentService 复制的描述
返回用户最近访问的频道列表
按照访问的时间顺序排序

指定者：
接口 IRecentService 中的 getChannels
参数：
_aFilter - 用户指定的查询条件
返回：
按照访问时间降序排列的频道集合
抛出：
WCMException

getChannels

public Channels getChannels(WCMFilter _aFilter,
                            boolean _bIncludeDeleted)
                     throws WCMException
从接口 IRecentService 复制的描述
返回用户最近访问的频道列表
按照访问的时间顺序排序

指定者：
接口 IRecentService 中的 getChannels
参数：
_aFilter - 用户指定的查询条件
_bIncludeDeleted - true为包含已删除的，false为不包含已删除的
返回：
按照访问时间降序排列的频道集合
抛出：
WCMException

getChannelsWithRight

public Channels getChannelsWithRight(WCMFilter _filter)
                              throws WCMException
从接口 IRecentService 复制的描述
获取用户最近访问的频道集合,并校验访问权限.

指定者：
接口 IRecentService 中的 getChannelsWithRight
参数：
_filter - 过滤器,额外的查询条件件
返回：
@throws WCMException
抛出：
WCMException

getChannels

public Channels getChannels(WCMFilter _filter,
                            boolean _bIncludeDeleted,
                            int _nRightIndex)
                     throws WCMException
从接口 IRecentService 复制的描述
获取用户最近访问的频道集合,并校验访问指定权限.

指定者：
接口 IRecentService 中的 getChannels
参数：
_filter - 过滤器,额外的查询条件件
_bIncludeDeleted - 是否包含已删除的频道.
_nRightIndex - 指定的权限索引值.
返回：
@throws WCMException
抛出：
WCMException

getTemplates

public Templates getTemplates(WCMFilter _aFilter)
                       throws WCMException
从接口 IRecentService 复制的描述
返回用户最近访问的模板列表
按照访问的时间顺序排序

指定者：
接口 IRecentService 中的 getTemplates
参数：
_aFilter - 用户指定的查询条件
返回：
按照访问时间降序排列的模板集合
抛出：
WCMException

getWebSites

public WebSites getWebSites(WCMFilter _aFilter)
                     throws WCMException
从接口 IRecentService 复制的描述
返回用户最近访问的站点列表
按照访问的时间顺序排序

指定者：
接口 IRecentService 中的 getWebSites
参数：
_aFilter - 用户指定的查询条件
返回：
按照访问时间降序排列的站点集合
抛出：
WCMException

add

public boolean add(int _nObjType,
                   java.lang.String _sObjIds)
            throws WCMException
从接口 IRecentService 复制的描述
添加最近访问的WCM对象

指定者：
接口 IRecentService 中的 add
参数：
_nObjType - WCM对象TypeID
_sObjIds - 对象的具体ID序列，以逗号分隔，形如1,2,3,4
返回：
是否添加成功
抛出：
WCMException

addChnlDoc

public boolean addChnlDoc(int _nChannelId,
                          int _nDocumentId)
                   throws WCMException
从接口 IRecentService 复制的描述
添加最近访问的ChnlDoc

指定者：
接口 IRecentService 中的 addChnlDoc
参数：
_nChannelId - 频道Id
_nDocumentId - 文档Id
返回：
@throws WCMException 如果ChnlDoc没有找到或者频道、文档无效，则抛出异常
抛出：
WCMException

getChnlDocs

public ChnlDocs getChnlDocs(WCMFilter _aFilter)
                     throws WCMException
从接口 IRecentService 复制的描述
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

指定者：
接口 IRecentService 中的 getChnlDocs
参数：
_aFilter - 用户指定的查询条件
返回：
@throws WCMException
抛出：
WCMException

getChnlDocs

public ChnlDocs getChnlDocs(WCMFilter _aFilter,
                            boolean _bIncludeDeleted)
                     throws WCMException
从接口 IRecentService 复制的描述
返回用户最近访问的频道文档列表
按照访问的时间顺序排序

指定者：
接口 IRecentService 中的 getChnlDocs
参数：
_aFilter - 用户指定的查询条件
_bIncludeDeleted - true为包括已删除的，false为不包括已删除的
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResouceService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 ResouceService

java.lang.Object
    继承者  com.trs.service.impl.ResouceService
所有已实现的接口：
IResourceService
public class ResouceService
extends java.lang.Object
implements IResourceService

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ResouceService()
方法摘要
boolean | delete(CMSObj _currObjToDelete) 删除资源配置
User | getLoginUser() 返回当前登录用户
CMSObj | save(CMSObj _currObjToSave) 保存资源配置
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResouceService

public ResouceService()
方法详细信息

getLoginUser

public User getLoginUser()
从接口 IResourceService 复制的描述
返回当前登录用户

指定者：
接口 IResourceService 中的 getLoginUser
返回：

save

public CMSObj save(CMSObj _currObjToSave)
            throws WCMException
从接口 IResourceService 复制的描述
保存资源配置

指定者：
接口 IResourceService 中的 save
参数：
_currObjToSave - 要保存的对象
支持的对象: Source,Sercurity,Status,RightDef,EventType,OperType,Config ,TagBean
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(CMSObj _currObjToDelete)
               throws WCMException
从接口 IResourceService 复制的描述
删除资源配置

指定者：
接口 IResourceService 中的 delete
参数：
_currObjToDelete - 要删除的对象
支持的对象: Source,Sercurity,Status,RightDef,EventType,OperType,Config ,TagBean
返回：
@throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 RoleService

java.lang.Object
    继承者  com.trs.service.impl.RoleService
所有已实现的接口：
IRoleService
public class RoleService
extends java.lang.Object
implements IRoleService

Title: TRS 内容协作平台（TRS WCM）
Description:
角色相关服务接口的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RoleService()
方法摘要
User | addUser(User _dstUser, Role _toRole) 添加指定的用户到指定的角色
boolean | delete(int _nDelRoleId) 根据Id删除指定的角色
boolean | delete(Role _roleToDelete) 删除指定的角色
boolean | delete(Roles _rolesToDelete) 删除指定的角色集合
boolean | delete(java.lang.String _sDelRoleIds) 根据Id序列删除多个角色
Users | getUsers(Role _dstRole, WCMFilter _filter) 获取指定角色的所有用户
boolean | removeUser(User _dstUser, Role _fromRole) 从指定的角色中删除指定的用户
Role | save(Role _roleToSave) 保存指定的角色
void | setRoleUsers(int _nDstRoleId, java.lang.String _sUserIdsToAdd)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleService

public RoleService()
方法详细信息

save

public Role save(Role _roleToSave)
          throws WCMException
从接口 IRoleService 复制的描述
保存指定的角色

指定者：
接口 IRoleService 中的 save
参数：
_roleToSave - 要保存的角色
返回：
@throws WCMException
抛出：
WCMException

getUsers

public Users getUsers(Role _dstRole,
                      WCMFilter _filter)
               throws WCMException
从接口 IRoleService 复制的描述
获取指定角色的所有用户

指定者：
接口 IRoleService 中的 getUsers
参数：
_dstRole - 指定的角色
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(int _nDelRoleId)
               throws WCMException
从接口 IRoleService 复制的描述
根据Id删除指定的角色

指定者：
接口 IRoleService 中的 delete
参数：
_nDelRoleId - 需要删除的角色Id
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(java.lang.String _sDelRoleIds)
               throws WCMException
从接口 IRoleService 复制的描述
根据Id序列删除多个角色

指定者：
接口 IRoleService 中的 delete
参数：
_sDelRoleIds - 指定的Id序列
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(Roles _rolesToDelete)
               throws WCMException
从接口 IRoleService 复制的描述
删除指定的角色集合

指定者：
接口 IRoleService 中的 delete
参数：
_rolesToDelete - 要删除的角色集合
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(Role _roleToDelete)
               throws WCMException
从接口 IRoleService 复制的描述
删除指定的角色

指定者：
接口 IRoleService 中的 delete
参数：
_roleToDelete - 需要删除的角色
返回：
@throws WCMException
抛出：
WCMException

addUser

public User addUser(User _dstUser,
                    Role _toRole)
             throws WCMException
从接口 IRoleService 复制的描述
添加指定的用户到指定的角色

指定者：
接口 IRoleService 中的 addUser
参数：
_dstUser - 指定的要添加的用户
_toRole - 指定的角色
返回：
@throws WCMException
抛出：
WCMException

removeUser

public boolean removeUser(User _dstUser,
                          Role _fromRole)
                   throws WCMException
从接口 IRoleService 复制的描述
从指定的角色中删除指定的用户

指定者：
接口 IRoleService 中的 removeUser
参数：
_dstUser - 指定要删除的用户
返回：
@throws WCMException
抛出：
WCMException

setRoleUsers

public void setRoleUsers(int _nDstRoleId,
                         java.lang.String _sUserIdsToAdd)
                  throws WCMException
指定者：
接口 IRoleService 中的 setRoleUsers
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScheduleService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 ScheduleService

java.lang.Object
    继承者  com.trs.service.impl.ScheduleService
所有已实现的接口：
IScheduleService
public class ScheduleService
extends java.lang.Object
implements IScheduleService

Title: TRS 内容协作平台（TRS WCM）
Description:
计划服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ScheduleService()
方法摘要
Schedule | deletePublishSchedule(BaseChannel _currChannel) 删除指定站点或频道的计划发布
Schedule | deletePublishSchedule(Document _currDocument) 删除指定文档的计划发布
Schedule | findPublishSchedule(BaseChannel _currChannel) 获取指定站点或频道的计划发布信息
Schedule | findPublishSchedule(Document _currDocument) 获取指定文档的计划发布信息
Schedule | savePublishSchedule(Schedule _currSchedule, BaseChannel _currChannel) 给指定的站点或频道设置计划发布属性
Schedule | savePublishSchedule(Schedule _currSchedule, Document _currDocument) 给指定的文档设置计划发布属性
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScheduleService

public ScheduleService()
方法详细信息

savePublishSchedule

public Schedule savePublishSchedule(Schedule _currSchedule,
                                    BaseChannel _currChannel)
                             throws WCMException
从接口 IScheduleService 复制的描述
给指定的站点或频道设置计划发布属性

指定者：
接口 IScheduleService 中的 savePublishSchedule
参数：
_currSchedule - 设置的计划内容（Schedule）
_currChannel - 设置的站点或频道对象（BaseChannel）
返回：
返回保存后的Schedule对象
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
保存信息时可能抛出异常

deletePublishSchedule

public Schedule deletePublishSchedule(BaseChannel _currChannel)
                               throws WCMException
从接口 IScheduleService 复制的描述
删除指定站点或频道的计划发布

指定者：
接口 IScheduleService 中的 deletePublishSchedule
参数：
_currChannel - 被删除计划发布的站点或发布
返回：
被删除后的计划发布对象
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
保存信息时可能抛出异常

findPublishSchedule

public Schedule findPublishSchedule(BaseChannel _currChannel)
                             throws WCMException
从接口 IScheduleService 复制的描述
获取指定站点或频道的计划发布信息

指定者：
接口 IScheduleService 中的 findPublishSchedule
参数：
_currChannel - 指定的站点或频道对象（BaseChannel）
返回：
如果设置了计划发布，返回计划对象；否则返回null
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
获取信息时可能抛出异常

savePublishSchedule

public Schedule savePublishSchedule(Schedule _currSchedule,
                                    Document _currDocument)
                             throws WCMException
从接口 IScheduleService 复制的描述
给指定的文档设置计划发布属性

指定者：
接口 IScheduleService 中的 savePublishSchedule
参数：
_currSchedule - 设置的计划内容（Schedule）
_currDocument - 设置的文档对象（Document）
返回：
返回保存后的Schedule对象
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
保存信息时可能抛出异常

deletePublishSchedule

public Schedule deletePublishSchedule(Document _currDocument)
                               throws WCMException
从接口 IScheduleService 复制的描述
删除指定文档的计划发布

指定者：
接口 IScheduleService 中的 deletePublishSchedule
参数：
_currDocument - 被删除计划发布的站点或发布
返回：
被删除后的计划发布对象
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
保存信息时可能抛出异常

findPublishSchedule

public Schedule findPublishSchedule(Document _currDocument)
                             throws WCMException
从接口 IScheduleService 复制的描述
获取指定文档的计划发布信息

指定者：
接口 IScheduleService 中的 findPublishSchedule
参数：
_currDocument - 指定的文档对象（Document）
返回：
如果设置了计划发布，返回计划对象；否则返回null
抛出：
WCMException - 如果传入的参数无效，抛出参数非法异常
获取信息时可能抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecurityService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 SecurityService

java.lang.Object
    继承者  com.trs.service.impl.SecurityService
所有已实现的接口：
ISecurityService
public class SecurityService
extends java.lang.Object
implements ISecurityService

作者：
Martin (Fu Chengrui) 密钥管理，以及加密、解密、签名、验证、摘要等操作的公共接口定义 函数返回值和异常的说明，所有的操作类型的函数（指不返回计算结果，只是执行某个动作的函数）都声明为要么操作成功，不返回任何内容，要么操作失败抛出异常 ， 而不是返回 boolean 类型的结果。所有可能抛出的异常，都使用 WCMException 进行封装，但是原始异常信息不应该被丢失。

构造方法摘要
SecurityService()
default constructor
方法摘要
byte[] | decrypt(java.lang.String sKeyName, byte[] bytes) 使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。
void | deleteKey(int _toDeleteId) 删除指定ID的密钥
void | deleteKey(java.lang.String _toDeleteIds) 删除指定ID的密钥 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经被删除的密钥不会回滚。
void | deleteKeyByName(java.lang.String _toDeleteName) 删除指定名称（名称：一般是密钥的用途）的密钥
byte[] | digest(java.lang.String sAlgorithm, byte[] data) 使用指定的算法计算指定数据的摘要
void | doDecrypt(java.lang.String sKeyName, java.io.InputStream is, java.io.OutputStream os) 使用指定名称的密钥，解密指定的输入流中的数据，并将明文写入指定的输出流。
byte[] | doDigest(java.lang.String sAlgorithm, java.io.InputStream is) 使用指定的算法计算指定数据源（输入流）的摘要
void | doEncrypt(java.lang.String sKeyName, java.io.InputStream is, java.io.OutputStream os) 使用指定名称的密钥，加密指定的输入流中的数据，并将密文写入指定的输出流。
byte[] | doSign(java.lang.String sKeyName, java.io.InputStream is) 使用指定名称的密钥计算指定的数据源的签名
boolean | doVerify(java.lang.String sKeyName, java.io.InputStream is, byte[] sign) 使用指定名称的密钥，验证指定数据源和签名是否相符
byte[] | encrypt(java.lang.String sKeyName, byte[] bytes) 使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。
java.lang.String | exportKey(boolean _zIsPrivate, int iKeyId) 导出指定的密钥
java.lang.String | exportKey(boolean _zIsPrivate, java.lang.String sKeyName) 导出指定的密钥
byte[] | exportKey(int _toExportId, boolean _zIsPrivate) 导出指定ID的密钥的原始数据
byte[] | exportKey(java.lang.String _toExportName, boolean _zIsPrivate) 导出指定名称的密钥的原始数据
void | exportKey(java.lang.String _toExportIds, java.io.Writer _writer) 以XML文件的形式导出指定的密钥
void | exportKey(java.io.Writer _writer) 以XML文件的形式导出系统内的全部密钥
java.util.List | extractKey(java.io.File _oXMLFile, java.lang.String _encoding) 从指定的XML文件中抽取全部可用的密钥
java.util.List | extractKey(java.io.Reader _oXMLReader) 从指定的XML文件输出流中抽取全部可用的密钥
SecureKey | findKey(int _iKeyId) 在系统内查找指定ID的密钥
SecureKey | findKey(java.lang.String _iKeyName) 在系统内查找指定名称的密钥
SecureKeys | getKeys(WCMFilter _filter) 获取当前系统中符合条件的密钥的集合
void | saveKey(SecureKey _oKey) 保存指定的密钥
byte[] | sign(java.lang.String sKeyName, byte[] data) 使用指定名称的密钥计算指定的数据的签名
boolean | verify(java.lang.String sKeyName, byte[] data, byte[] sign) 使用指定名称的密钥，验证指定数据和签名是否相符
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecurityService

public SecurityService()
default constructor

方法详细信息

deleteKey

public void deleteKey(int _toDeleteId)
               throws WCMException
从接口 ISecurityService 复制的描述
删除指定ID的密钥

指定者：
接口 ISecurityService 中的 deleteKey
参数：
_toDeleteId - 待删除密钥的ID
抛出：
WCMException - 如果操作失败

deleteKey

public void deleteKey(java.lang.String _toDeleteIds)
               throws WCMException
从接口 ISecurityService 复制的描述
删除指定ID的密钥 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经被删除的密钥不会回滚。

指定者：
接口 ISecurityService 中的 deleteKey
参数：
_toDeleteIds - 待删除密钥的ID列表，形如2,3,5,13
抛出：
WCMException - 如果操作失败

deleteKeyByName

public void deleteKeyByName(java.lang.String _toDeleteName)
                     throws WCMException
从接口 ISecurityService 复制的描述
删除指定名称（名称：一般是密钥的用途）的密钥

指定者：
接口 ISecurityService 中的 deleteKeyByName
参数：
_toDeleteName - 待删除密钥的名称
抛出：
WCMException - 如果操作失败

exportKey

public byte[] exportKey(int _toExportId,
                        boolean _zIsPrivate)
                 throws WCMException
从接口 ISecurityService 复制的描述
导出指定ID的密钥的原始数据

指定者：
接口 ISecurityService 中的 exportKey
参数：
_toExportId - 待导出密钥的ID
_zIsPrivate - 是否导出私钥。如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
返回：
密钥的原始数据
抛出：
WCMException - 如果操作失败

exportKey

public byte[] exportKey(java.lang.String _toExportName,
                        boolean _zIsPrivate)
                 throws WCMException
从接口 ISecurityService 复制的描述
导出指定名称的密钥的原始数据

指定者：
接口 ISecurityService 中的 exportKey
参数：
_toExportName - 待导出密钥的名称
_zIsPrivate - 是否导出私钥。如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
返回：
密钥的原始数据
抛出：
WCMException - 如果操作失败

exportKey

public void exportKey(java.lang.String _toExportIds,
                      java.io.Writer _writer)
               throws WCMException
从接口 ISecurityService 复制的描述
以XML文件的形式导出指定的密钥

指定者：
接口 ISecurityService 中的 exportKey
参数：
_toExportIds - 需要导出的密钥ID列表，形如2,3,5,13
_writer - 目标XML文件输出流
抛出：
WCMException - 如果操作失败

exportKey

public void exportKey(java.io.Writer _writer)
               throws WCMException
从接口 ISecurityService 复制的描述
以XML文件的形式导出系统内的全部密钥

指定者：
接口 ISecurityService 中的 exportKey
参数：
_writer - 目标XML文件输出流
抛出：
WCMException - 如果操作失败

extractKey

public java.util.List extractKey(java.io.Reader _oXMLReader)
                          throws WCMException
从接口 ISecurityService 复制的描述
从指定的XML文件输出流中抽取全部可用的密钥

指定者：
接口 ISecurityService 中的 extractKey
参数：
_oXMLReader - 指定的输入流
返回：
输入流中有效密钥的集合
抛出：
WCMException

extractKey

public java.util.List extractKey(java.io.File _oXMLFile,
                                 java.lang.String _encoding)
                          throws WCMException
从接口 ISecurityService 复制的描述
从指定的XML文件中抽取全部可用的密钥

指定者：
接口 ISecurityService 中的 extractKey
参数：
_oXMLFile - 指定的XML文件
_encoding - 指定的XML文件的编码方式
返回：
XML文件中有效密钥的集合
抛出：
WCMException

findKey

public SecureKey findKey(int _iKeyId)
                  throws WCMException
从接口 ISecurityService 复制的描述
在系统内查找指定ID的密钥

指定者：
接口 ISecurityService 中的 findKey
参数：
_iKeyId - 密钥的ID
返回：
指定ID的密钥
抛出：
WCMException - 如果操作失败

findKey

public SecureKey findKey(java.lang.String _iKeyName)
                  throws WCMException
从接口 ISecurityService 复制的描述
在系统内查找指定名称的密钥

指定者：
接口 ISecurityService 中的 findKey
参数：
_iKeyName - 密钥的名称
返回：
指定名称的密钥
抛出：
WCMException - 如果操作失败

getKeys

public SecureKeys getKeys(WCMFilter _filter)
                   throws WCMException
从接口 ISecurityService 复制的描述
获取当前系统中符合条件的密钥的集合

指定者：
接口 ISecurityService 中的 getKeys
返回：
过滤器，可选的查询条件，可以为 null
抛出：
WCMException - 如果操作失败

saveKey

public void saveKey(SecureKey _oKey)
             throws WCMException
从接口 ISecurityService 复制的描述
保存指定的密钥

指定者：
接口 ISecurityService 中的 saveKey
参数：
_oKey - 待保存的密钥
抛出：
WCMException - 如果操作失败

encrypt

public byte[] encrypt(java.lang.String sKeyName,
                      byte[] bytes)
               throws WCMException
从接口 ISecurityService 复制的描述
使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。

指定者：
接口 ISecurityService 中的 encrypt
参数：
sKeyName - 密钥的名称
bytes - 待加密的数据
返回：
密文数据
抛出：
WCMException - 如果发生错误

doEncrypt

public void doEncrypt(java.lang.String sKeyName,
                      java.io.InputStream is,
                      java.io.OutputStream os)
               throws WCMException
从接口 ISecurityService 复制的描述
使用指定名称的密钥，加密指定的输入流中的数据，并将密文写入指定的输出流。 如果指定的密钥是对称密钥，则一定使用公钥进行加密。

指定者：
接口 ISecurityService 中的 doEncrypt
参数：
sKeyName - 密钥的名称
is - 待加密的数据源
os - 密文输出流
抛出：
WCMException - 如果发生错误

decrypt

public byte[] decrypt(java.lang.String sKeyName,
                      byte[] bytes)
               throws WCMException
从接口 ISecurityService 复制的描述
使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。

指定者：
接口 ISecurityService 中的 decrypt
参数：
sKeyName - 密钥的名称
bytes - 待解密的密文数据
返回：
明文数据
抛出：
WCMException - 如果发生错误

doDecrypt

public void doDecrypt(java.lang.String sKeyName,
                      java.io.InputStream is,
                      java.io.OutputStream os)
               throws WCMException
从接口 ISecurityService 复制的描述
使用指定名称的密钥，解密指定的输入流中的数据，并将明文写入指定的输出流。 如果指定的密钥是对称密钥，则一定使用私钥进行解密。

指定者：
接口 ISecurityService 中的 doDecrypt
参数：
sKeyName - 密钥的名称
is - 待解密的数据源
os - 明文输出流
抛出：
WCMException - 如果发生错误

sign

public byte[] sign(java.lang.String sKeyName,
                   byte[] data)
            throws WCMException
从接口 ISecurityService 复制的描述
使用指定名称的密钥计算指定的数据的签名

指定者：
接口 ISecurityService 中的 sign
参数：
sKeyName - 密钥的名称
data - 待签名数据
返回：
签名数据
抛出：
WCMException - 如果发生错误

doSign

public byte[] doSign(java.lang.String sKeyName,
                     java.io.InputStream is)
              throws WCMException
从接口 ISecurityService 复制的描述
使用指定名称的密钥计算指定的数据源的签名

指定者：
接口 ISecurityService 中的 doSign
参数：
sKeyName - 密钥的名称
is - 待签名的数据源
返回：
签名数据
抛出：
WCMException - 如果发生错误

verify

public boolean verify(java.lang.String sKeyName,
                      byte[] data,
                      byte[] sign)
               throws WCMException
从接口 ISecurityService 复制的描述
使用指定名称的密钥，验证指定数据和签名是否相符

指定者：
接口 ISecurityService 中的 verify
参数：
sKeyName - 密钥的名称
data - 待验证的数据
sign - 签名数据
返回：
如果签名相符，返回 true ，否则返回 false
抛出：
WCMException - 如果发生错误

doVerify

public boolean doVerify(java.lang.String sKeyName,
                        java.io.InputStream is,
                        byte[] sign)
                 throws WCMException
从接口 ISecurityService 复制的描述
使用指定名称的密钥，验证指定数据源和签名是否相符

指定者：
接口 ISecurityService 中的 doVerify
参数：
sKeyName - 密钥的名称
is - 待验证的数据源
sign - 签名数据
返回：
如果签名相符，返回 true ，否则返回 false
抛出：
WCMException - 如果发生错误

digest

public byte[] digest(java.lang.String sAlgorithm,
                     byte[] data)
              throws WCMException
从接口 ISecurityService 复制的描述
使用指定的算法计算指定数据的摘要

指定者：
接口 ISecurityService 中的 digest
参数：
sAlgorithm - 摘要算法的名称，如果为 null ，则默认使用MD5
data - 原始数据
返回：
摘要计算结果
抛出：
WCMException - 如果发生错误

doDigest

public byte[] doDigest(java.lang.String sAlgorithm,
                       java.io.InputStream is)
                throws WCMException
从接口 ISecurityService 复制的描述
使用指定的算法计算指定数据源（输入流）的摘要

指定者：
接口 ISecurityService 中的 doDigest
参数：
sAlgorithm - 摘要算法的名称，如果为 null ，则默认使用MD5
is - 数据源
返回：
摘要计算结果
抛出：
WCMException - 如果发生错误

exportKey

public java.lang.String exportKey(boolean _zIsPrivate,
                                  java.lang.String sKeyName)
                           throws WCMException
从接口 ISecurityService 复制的描述
导出指定的密钥

指定者：
接口 ISecurityService 中的 exportKey
参数：
_zIsPrivate - 是否导出私钥。 如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
sKeyName - 指定的密钥名称
返回：
导出的文件名(符合WCM规范)
抛出：
WCMException

exportKey

public java.lang.String exportKey(boolean _zIsPrivate,
                                  int iKeyId)
                           throws WCMException
从接口 ISecurityService 复制的描述
导出指定的密钥

指定者：
接口 ISecurityService 中的 exportKey
参数：
_zIsPrivate - 是否导出私钥。 如果为 true ，则导出私钥，如果为 false， 则导出公钥，仅对成对的对称密钥有意义，如果是DES等非对称密钥，该参数将被忽略。
返回：
导出的文件名(符合WCM规范)
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SiteNameCreator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 SiteNameCreator

java.lang.Object
    继承者  com.trs.service.impl.SiteNameCreator
所有已实现的接口：
IInfoViewInitorValue
public class SiteNameCreator
extends java.lang.Object
implements IInfoViewInitorValue

构造方法摘要
SiteNameCreator()
方法摘要
 java.lang.Object getFieldValue(InfoViewContext _context, BindingBean _bindingBean)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SiteNameCreator

public SiteNameCreator()
方法详细信息

getFieldValue

public java.lang.Object getFieldValue(InfoViewContext _context,
                                      BindingBean _bindingBean)
                               throws WCMException
指定者：
接口 IInfoViewInitorValue 中的 getFieldValue
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPServiceImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 SOAPServiceImpl

java.lang.Object
    继承者  com.trs.service.impl.SOAPServiceImpl
所有已实现的接口：
ISOAPService
public class SOAPServiceImpl
extends java.lang.Object
implements ISOAPService

Title: TRS 内容协作平台（TRS WCM）
Description:
对外的SOAP接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SOAPServiceImpl()
方法摘要
java.lang.String | getAllChannelXML() 返回系统的站点和频道的所有信息
java.lang.String | getChannelChildrenXML(int _nSiteId, int _nChannelId, boolean _bAllChildren) 获取指定站点指定频道的配置信息
java.lang.String | getChannelXML(int _nChannelId) 获取指定频道的信息
int | getMajorVersion() 获取当前SOAP服务的版本
java.lang.String | getSiteXML(int _nSiteId) 获取指定站点的信息
java.lang.String | importDocuments(byte[] _pImportFileContent, java.lang.String _sFileExt) 从指定文件中导入文档集合
java.lang.String | importDocumentsByLocalFile(java.lang.String _sUserName, java.lang.String _sFileName)
java.lang.String | sendFileBase64(java.lang.String strData, java.lang.String Server, java.lang.String fileExt) 上传指定的文件
java.lang.String | uploadFile(byte[] _pUploadFileContent, java.lang.String _sFileExt, boolean _bOnlyReturnFileName) 上传指定的文件
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SOAPServiceImpl

public SOAPServiceImpl()
方法详细信息

importDocuments

public java.lang.String importDocuments(byte[] _pImportFileContent,
                                        java.lang.String _sFileExt)
从接口 ISOAPService 复制的描述
从指定文件中导入文档集合

指定者：
接口 ISOAPService 中的 importDocuments
参数：
_pImportFileContent - 需要导入的文件内容，为byte数组（不需要编码）
_sFileExt - 文件后缀名（默认为ZIP）
返回：
以XML形式组织的返回信息，如果失败也返回相同结构的信息，只是内容不一样

importDocumentsByLocalFile

public java.lang.String importDocumentsByLocalFile(java.lang.String _sUserName,
                                                   java.lang.String _sFileName)
参数：
_sUserName - 当前操作的用户，需要是WCM已经存在的用户名，可以是空串，默认是System
_sFileName - 已经上传到共享目录的文件，可以是ZIP也可以是一个XML
返回：
XML结构的返回信息

getAllChannelXML

public java.lang.String getAllChannelXML()
从接口 ISOAPService 复制的描述
返回系统的站点和频道的所有信息

指定者：
接口 ISOAPService 中的 getAllChannelXML
返回：
标准WCM XML字符串

uploadFile

public java.lang.String uploadFile(byte[] _pUploadFileContent,
                                   java.lang.String _sFileExt,
                                   boolean _bOnlyReturnFileName)
从接口 ISOAPService 复制的描述
上传指定的文件

指定者：
接口 ISOAPService 中的 uploadFile
参数：
_pUploadFileContent - 文件内容
_sFileExt - 文件后缀
_bOnlyReturnFileName - TODO
返回：

getChannelChildrenXML

public java.lang.String getChannelChildrenXML(int _nSiteId,
                                              int _nChannelId,
                                              boolean _bAllChildren)
从接口 ISOAPService 复制的描述
获取指定站点指定频道的配置信息

指定者：
接口 ISOAPService 中的 getChannelChildrenXML
参数：
_nSiteId - 指定站点ID
_nChannelId - 指定频道ID
_bAllChildren - 是否获取所有的子频道（false:表示只获取当前一级子频道列表 true:表示获取所有子频道列表）
返回：
标准的WCM XML字符串

getChannelXML

public java.lang.String getChannelXML(int _nChannelId)
从接口 ISOAPService 复制的描述
获取指定频道的信息

指定者：
接口 ISOAPService 中的 getChannelXML
参数：
_nChannelId - 指定的频道ID
返回：
标准的WCM XML字符串

getSiteXML

public java.lang.String getSiteXML(int _nSiteId)
从接口 ISOAPService 复制的描述
获取指定站点的信息

指定者：
接口 ISOAPService 中的 getSiteXML
参数：
_nSiteId - 指定的站点ID
返回：
标准的WCM XML字符串

getMajorVersion

public int getMajorVersion()
从接口 ISOAPService 复制的描述
获取当前SOAP服务的版本

指定者：
接口 ISOAPService 中的 getMajorVersion
返回：

sendFileBase64

public java.lang.String sendFileBase64(java.lang.String strData,
                                       java.lang.String Server,
                                       java.lang.String fileExt)
从接口 ISOAPService 复制的描述
上传指定的文件

指定者：
接口 ISOAPService 中的 sendFileBase64
参数：
strData - Base64编码的文件内容
Server - 服务器地址
fileExt - 文件后缀名
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 StatService

java.lang.Object
    继承者  com.trs.service.impl.StatService
所有已实现的接口：
IStatService
public class StatService
extends java.lang.Object
implements IStatService

Title: TRS 内容协作平台（TRS WCM）
Description:
实现统计服务接口提供的功能
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
StatService()
方法摘要
void | clearStatResult(int _nStatViewId) 清除特定统计视图对应临时表中的数据 只有模板类视图才有临时表
Reports | deleteStatHosts(java.lang.String _sDelStatHostIds) 删除统计类型
Reports | deleteStatView(int _nStatViewId) 删除一个统计视图
Reports | deleteStatView(StatView _delStatView) 删除一个统计视图
Reports | deleteStatViews(java.lang.String _sStatViewIds) 删除一个统计视图
StatView | findStatViewByName(java.lang.String _sName) 获取指定名称的统计视图.
void | generateTodayStat(int _nStatTempId) 产生特定统计模板当天的统计数据 统计数据记录在统计表中
CMyResultSets | getCurrentStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 统计在一个时间段内，符合特定条件的某个统计的结果 对数据库进行实时统计，而不是从统计临时表中取
StatViews | getEmbeddedViews(int _nMainViewId) 得到一个模板类视图的所有子视图（嵌入式）
StatFieldMaps | getStatFieldsByView(int _nStatTempId) 得到一个统计视图模板中的字段映射表（字段列表） 从统计映射表中获取，而不是从Select中自动识别
StatHosts | getStatHosts(WCMFilter _filter) 获得系统中提供的所有统计主体
CMyResultSets | getStatResult(int _nStatTempId) 获得一个统计模板对应的所有结果
CMyResultSets | getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate) 统计在一个时间段内，某个统计的结果
CMyResultSets | getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere) 统计在一个时间段内，符合特定条件的某个统计的结果
CMyResultSets | getStatResult(int _nStatTempId, CMyDateTime _fromDate, CMyDateTime _toDate, java.lang.String _sqlWhere, java.lang.String _sqlOrderBy)
CMyResultSets | getStatResult(java.lang.String _sqlStat, java.lang.String _sId) 进行用户定制的统计并返回统计结果
StatViews | getStatViews(java.lang.String _sStatHostName, int _nStatViewType, WCMFilter _filter) 获得特定查询主体的统计视图模板
StatHost | saveStatHost(StatHost _currStatHost) 保存统计主体（即按xxx查询）
StatView | saveStatView(StatView _currStatView, java.util.List _fieldMapList) 保存统计视图模板 其中包括保存视图模板和字段列表
void | setStatViewRelation(int _nMainViewId, java.lang.String _sEmbeddedViewIds) 设置模板视图和嵌入视图的关联关系
void | setStatViewRelation(StatView _mainView, StatViews _embeddedViews) 设置模板视图和嵌入视图的关联关系
boolean | testStatView(int _nStatTempId) 测试特定的统计模板是否能够运行通过
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StatService

public StatService()
方法详细信息

getStatViews

public StatViews getStatViews(java.lang.String _sStatHostName,
                              int _nStatViewType,
                              WCMFilter _filter)
                       throws WCMException
从接口 IStatService 复制的描述
获得特定查询主体的统计视图模板

指定者：
接口 IStatService 中的 getStatViews
参数：
_sStatHostName - 统计主体的名称，如CHANNEL
_nStatViewType - 统计视图模板类型，由常量维护，在StatView中，Type_All表示所有类型
返回：
@throws WCMException
抛出：
WCMException

getStatResult

public CMyResultSets getStatResult(int _nStatTempId)
                            throws WCMException
从接口 IStatService 复制的描述
获得一个统计模板对应的所有结果

指定者：
接口 IStatService 中的 getStatResult
参数：
_nStatTempId - 统计模板Id
返回：
统计结果集合
抛出：
WCMException

getStatResult

public CMyResultSets getStatResult(int _nStatTempId,
                                   CMyDateTime _fromDate,
                                   CMyDateTime _toDate)
                            throws WCMException
从接口 IStatService 复制的描述
统计在一个时间段内，某个统计的结果

指定者：
接口 IStatService 中的 getStatResult
参数：
_nStatTempId - 统计模板Id
_fromDate - 统计开始时间，如果为null，则表示包括所有结束之前的统计数据
_toDate - 统计结束时间，如果为null，则表示包含所有开始之后的统计诗句
返回：
统计结果集合
抛出：
WCMException

getStatResult

public CMyResultSets getStatResult(int _nStatTempId,
                                   CMyDateTime _fromDate,
                                   CMyDateTime _toDate,
                                   java.lang.String _sqlWhere)
                            throws WCMException
从接口 IStatService 复制的描述
统计在一个时间段内，符合特定条件的某个统计的结果

指定者：
接口 IStatService 中的 getStatResult
参数：
_nStatTempId - 统计模板Id
_fromDate - 统计开始时间，如果为null，则表示包括所有结束之前的统计数据
_toDate - 统计结束时间，如果为null，则表示包含所有开始之后的统计诗句
_sqlWhere - 附加的条件，比如名称为xx。或者数字小于多少的，等等。如果为null则表示没有附加查询条件
附件的条件不需要加AND
返回：
统计结果集合
抛出：
WCMException

getStatResult

public CMyResultSets getStatResult(java.lang.String _sqlStat,
                                   java.lang.String _sId)
                            throws WCMException
从接口 IStatService 复制的描述
进行用户定制的统计并返回统计结果

指定者：
接口 IStatService 中的 getStatResult
参数：
_sqlStat - 用户定制的统计语句，完整的SQL
返回：
统计结果集合
抛出：
WCMException

testStatView

public boolean testStatView(int _nStatTempId)
从接口 IStatService 复制的描述
测试特定的统计模板是否能够运行通过

指定者：
接口 IStatService 中的 testStatView
参数：
_nStatTempId - 统计模板Id
返回：
true为测试通过，否则抛出异常

getStatHosts

public StatHosts getStatHosts(WCMFilter _filter)
                       throws WCMException
从接口 IStatService 复制的描述
获得系统中提供的所有统计主体

指定者：
接口 IStatService 中的 getStatHosts
参数：
_filter - 查询条件
返回：
统计主体集合
抛出：
WCMException

getCurrentStatResult

public CMyResultSets getCurrentStatResult(int _nStatTempId,
                                          CMyDateTime _fromDate,
                                          CMyDateTime _toDate,
                                          java.lang.String _sqlWhere)
                                   throws WCMException
从接口 IStatService 复制的描述
统计在一个时间段内，符合特定条件的某个统计的结果
对数据库进行实时统计，而不是从统计临时表中取

指定者：
接口 IStatService 中的 getCurrentStatResult
参数：
_nStatTempId - 统计模板Id
_fromDate - 统计开始时间，如果为null，则表示包括所有结束之前的统计数据
_toDate - 统计结束时间，如果为null，则表示包含所有开始之后的统计诗句
_sqlWhere - 附加的条件，比如名称为xx。或者数字小于多少的，等等。如果为null则表示没有附加查询条件
附件的条件不需要加AND
返回：
统计结果集合
抛出：
WCMException

getStatFieldsByView

public StatFieldMaps getStatFieldsByView(int _nStatTempId)
                                  throws WCMException
从接口 IStatService 复制的描述
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别

指定者：
接口 IStatService 中的 getStatFieldsByView
参数：
_nStatTempId - 统计视图模板Id
返回：
统计模板中的字段映射表
抛出：
WCMException

generateTodayStat

public void generateTodayStat(int _nStatTempId)
                       throws WCMException
从接口 IStatService 复制的描述
产生特定统计模板当天的统计数据
统计数据记录在统计表中

指定者：
接口 IStatService 中的 generateTodayStat
参数：
_nStatTempId - 统计模板Id
抛出：
WCMException

saveStatView

public StatView saveStatView(StatView _currStatView,
                             java.util.List _fieldMapList)
                      throws WCMException
从接口 IStatService 复制的描述
保存统计视图模板
其中包括保存视图模板和字段列表

指定者：
接口 IStatService 中的 saveStatView
参数：
_currStatView - 统计视图模板
_fieldMapList - 视图字段映射表
返回：
@throws WCMException VIEWNAME、VIEWTYPE、STATHOST、TIMEFIELD、SELECT、FROM 、字段列表不能为空，且必须有效否则抛出异常
只有管理员有权限
抛出：
WCMException

saveStatHost

public StatHost saveStatHost(StatHost _currStatHost)
                      throws WCMException
从接口 IStatService 复制的描述
保存统计主体（即按xxx查询）

指定者：
接口 IStatService 中的 saveStatHost
参数：
_currStatHost - 统计主体
返回：
@throws WCMException
抛出：
WCMException

deleteStatView

public Reports deleteStatView(int _nStatViewId)
                       throws WCMException
从接口 IStatService 复制的描述
删除一个统计视图

指定者：
接口 IStatService 中的 deleteStatView
参数：
_nStatViewId - 欲删除的统计视图Id
返回：
TODO
抛出：
WCMException

deleteStatViews

public Reports deleteStatViews(java.lang.String _sStatViewIds)
                        throws WCMException
从接口 IStatService 复制的描述
删除一个统计视图

指定者：
接口 IStatService 中的 deleteStatViews
返回：
TODO
抛出：
WCMException

deleteStatView

public Reports deleteStatView(StatView _delStatView)
                       throws WCMException
从接口 IStatService 复制的描述
删除一个统计视图

指定者：
接口 IStatService 中的 deleteStatView
参数：
_delStatView - 欲删除的统计视图
返回：
TODO
抛出：
WCMException

setStatViewRelation

public void setStatViewRelation(int _nMainViewId,
                                java.lang.String _sEmbeddedViewIds)
                         throws WCMException
从接口 IStatService 复制的描述
设置模板视图和嵌入视图的关联关系

指定者：
接口 IStatService 中的 setStatViewRelation
参数：
_nMainViewId - 模板视图Id
_sEmbeddedViewIds - 嵌入视图Ids
抛出：
WCMException

setStatViewRelation

public void setStatViewRelation(StatView _mainView,
                                StatViews _embeddedViews)
                         throws WCMException
从接口 IStatService 复制的描述
设置模板视图和嵌入视图的关联关系

指定者：
接口 IStatService 中的 setStatViewRelation
参数：
_mainView - 模板视图
_embeddedViews - 嵌入视图集合
抛出：
WCMException

getStatResult

public CMyResultSets getStatResult(int _nStatTempId,
                                   CMyDateTime _fromDate,
                                   CMyDateTime _toDate,
                                   java.lang.String _sqlWhere,
                                   java.lang.String _sqlOrderBy)
                            throws WCMException
指定者：
接口 IStatService 中的 getStatResult
抛出：
WCMException

getEmbeddedViews

public StatViews getEmbeddedViews(int _nMainViewId)
                           throws WCMException
从接口 IStatService 复制的描述
得到一个模板类视图的所有子视图（嵌入式）

指定者：
接口 IStatService 中的 getEmbeddedViews
参数：
_nMainViewId - 主视图Id
返回：
嵌入视图集合
抛出：
WCMException

clearStatResult

public void clearStatResult(int _nStatViewId)
                     throws WCMException
从接口 IStatService 复制的描述
清除特定统计视图对应临时表中的数据
只有模板类视图才有临时表

指定者：
接口 IStatService 中的 clearStatResult
参数：
_nStatViewId - 统计视图
抛出：
WCMException

deleteStatHosts

public Reports deleteStatHosts(java.lang.String _sDelStatHostIds)
                        throws WCMException
从接口 IStatService 复制的描述
删除统计类型

指定者：
接口 IStatService 中的 deleteStatHosts
参数：
_sDelStatHostIds - 被删除的统计主体的Id
抛出：
WCMException

findStatViewByName

public StatView findStatViewByName(java.lang.String _sName)
                            throws WCMException
从接口 IStatService 复制的描述
获取指定名称的统计视图.

指定者：
接口 IStatService 中的 findStatViewByName
参数：
_sName - 指定的视图名称.
返回：
如果没有找到则返回 null.
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SureformService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 SureformService

java.lang.Object
    继承者  com.trs.service.impl.SureformService
所有已实现的接口：
ISureformService
public class SureformService
extends java.lang.Object
implements ISureformService

Title: TRS 内容协作平台（TRS WCM）
Description:
WCM为书生表单定制的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
SureformService()
方法摘要
void | distributeSureformFile(int _nChannelId) 将频道配置的书生表单发布到Web服务器上
Appendix | makeAppendix(java.lang.String _sFormFile) 根据书生表单数据，构造一个文档附件 规则是先将数据打包成为一个在WebPic下的文件，然后做成附件并构造List返回 注意返回后，需要将DocId设置上，否则保存附件时会报错
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SureformService

public SureformService()
方法详细信息

makeAppendix

public Appendix makeAppendix(java.lang.String _sFormFile)
                      throws WCMException
从接口 ISureformService 复制的描述
根据书生表单数据，构造一个文档附件
规则是先将数据打包成为一个在WebPic下的文件，然后做成附件并构造List返回
注意返回后，需要将DocId设置上，否则保存附件时会报错

指定者：
接口 ISureformService 中的 makeAppendix
参数：
_sFormFile - 本地可以访问的书生文件
返回：
构造的新建附件
抛出：
WCMException - 无法构造书生表单数据则抛错

distributeSureformFile

public void distributeSureformFile(int _nChannelId)
                            throws WCMException
从接口 ISureformService 复制的描述
将频道配置的书生表单发布到Web服务器上

指定者：
接口 ISureformService 中的 distributeSureformFile
参数：
_nChannelId - 频道Id
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateParseService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 TemplateParseService

java.lang.Object
    继承者  com.trs.service.impl.TemplateParseService
所有已实现的接口：
ITemplateParseService
public class TemplateParseService
extends java.lang.Object
implements ITemplateParseService

Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板解析接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateParseService()
方法摘要
 Report checkTemplate(Template _aTemplate)
解析模板语法
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateParseService

public TemplateParseService()
方法详细信息

checkTemplate

public Report checkTemplate(Template _aTemplate)
从接口 ITemplateParseService 复制的描述
解析模板语法

指定者：
接口 ITemplateParseService 中的 checkTemplate
返回：
模板语法解析结果
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 TemplateService

java.lang.Object
    继承者  com.trs.service.impl.TemplateService
所有已实现的接口：
ITemplateService
public class TemplateService
extends java.lang.Object
implements ITemplateService

Title: TRS 内容协作平台（TRS WCM）
Description:
模板服务提供对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateService()
constructor: default
方法摘要
void | addNestedParameters(IPublishElement _element, Template template, TemplateParameterList list)
boolean | delete(int _nDelTemplateId) 根据模板ID彻底删除模板
boolean | delete(java.lang.String _sDelTemplateIds) 根据模板Id列表彻底删除模板
boolean | delete(Template _template) 彻底删除模板
boolean | delete(Templates _currTemplatesToDelete) 彻底删除模板集合
boolean | deleteTemplateArgument(TemplateArgument _argument) 删除指定的TemplateArgument对象
void | deleteTemplateArguments(TemplateArguments _arguments) 删除指定的TemplateArguments对象集合
java.lang.String | export(int _nTemplateId) 根据Id导出模板到临时目录的文件中
java.lang.String | export(java.lang.String _sTemplateIds) 根据模板的Id列表导出模板集合到临时目录的文件中
java.lang.String | export(Template _currTemplate) 导出模板到固定的文件中
java.lang.String | export(Templates _currTemplates) 导出模板集合到临时目录的文件中
java.lang.String[] | extractTemplateNamesFromZip(java.lang.String _sZipFileName) 得到导入文件中可能的模板文件名列表
Template | findByName(int _nSiteId, java.lang.String _sTempName) 根据指定的SiteId，找到指定名称的模板
Template | getDetailTemplate(IPublishElement _publishElement) 获得指定频道的细览模板
Templates | getManagedTemplates(CMSObj _channelOrSite, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInChildren) 获取站点/频道下管理的模板集合
Templates | getNestedTemplates(Template _template) 获取当前模板中使用到的嵌套模板
Templates | getOptionalTemplates(IPublishFolder _folder, int _nTemplateType, WCMFilter _filter, boolean _bIncludingThoseInParent) 获取指定Folder中可选的模板集合
Templates | getOutlineTemplates(IPublishFolder _folder) 获得指定频道的概览模板
TemplateArguments | getTemplateArguments(IPublishElement _element) 返回指定发布对象上的全部有效模板参数列表
java.util.List | getTemplateEmployers(Template _template) 获取使用到当前模板的所有对象集合
java.util.List | getTemplateEmployers(Template _template, int _nEmployerType) 获取使用到当前模板的指定类型的对象集合
TemplateParameterList | getTemplateParameters(IPublishElement _element) 返回指定发布对象使用的所有模板中的全部形式参数列表
TemplateParameterList | getTemplateParameters(IPublishElement _element, boolean zRecursion) 返回指定发布对象使用的所有模板中的全部形式参数列表
Templates | getTemplatesNested(Template _template) 获取嵌套了当前模板的所有模板
Reports | importFromHTML(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, java.lang.String _sSrcName) 从html文件导入模板
Reports | importFromZip(CMSObj _siteOrChannel, java.lang.String _sFileName, int _nImportMode, int _nPicMode, java.lang.String[] _arSelected) 从zip文件中导入模板
java.lang.String | preview(int _nTemplateId) 预览指定id的模板
java.lang.String | preview(Template _template) 预览指定的模板
Reports | redistributeAppendixes(CMSObj _chnlOrSite, boolean _zRecursive) 重新分发指定站点或者频道下的所有模板的附件，并且如果_zRecursive 为true ，则会进一步地重新分发子频道下的模板的附件。
Template | save(Template _currTemplateToSave) 保存模板，包括新增和修改，此接口一般用于从源代码方式下保存模板
Template | save(Template _currTemplateToSave, boolean _bDowithAppendix, int _nPicMode) 保存模板，包括新增和修改
TemplateArgument | saveTemplateArgument(TemplateArgument _argument) 保存指定的TemplateArgument对象
void | setDetailTemplate(IPublishContent _content, int _nTemplateId)
void | setDetailTemplate(IPublishContent _content, int _nTemplateId, int _nDetailTemplateType) 为指定文档设定模板
void | setDetailTemplate(IPublishFolder _folder, int _nTemplateId, boolean _bResetChildren) 为指定频道设定细览模板
void | setOutlineTemplates(IPublishFolder _folder, java.lang.String _sTemplateIds, boolean _bResetChildren) 为指定频道设定概览模板
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateService

public TemplateService()
constructor: default

方法详细信息

save

public Template save(Template _currTemplateToSave,
                     boolean _bDowithAppendix,
                     int _nPicMode)
              throws WCMException
从接口 ITemplateService 复制的描述
保存模板，包括新增和修改

指定者：
接口 ITemplateService 中的 save
参数：
_currTemplateToSave - 待保存的模板
_bDowithAppendix - 是否处理附件，不处理表示不分析模板中可能的资源文件的地址（图片、CSS、js）
_nPicMode - 模板中图片重名后的处理方法，4种，参见WCMTypes.TEMPLATEAPD_xxxx
返回：
保存后的模板
抛出：
WCMException

save

public Template save(Template _currTemplateToSave)
              throws WCMException
从接口 ITemplateService 复制的描述
保存模板，包括新增和修改，此接口一般用于从源代码方式下保存模板

指定者：
接口 ITemplateService 中的 save
参数：
_currTemplateToSave - 待保存的模板
返回：
保存后的模板
抛出：
WCMException

delete

public boolean delete(java.lang.String _sDelTemplateIds)
               throws WCMException
从接口 ITemplateService 复制的描述
根据模板Id列表彻底删除模板

指定者：
接口 ITemplateService 中的 delete
参数：
_sDelTemplateIds - 待删除的模板Id列表，形如2,3,5,13
返回：
操作是否成功
抛出：
WCMException

delete

public boolean delete(Templates _currTemplatesToDelete)
               throws WCMException
从接口 ITemplateService 复制的描述
彻底删除模板集合

指定者：
接口 ITemplateService 中的 delete
参数：
_currTemplatesToDelete - 待删除的模板集合
返回：
操作是否成功，如果中间有一个模板没有删除成功，则立刻抛出异常，中止删除
抛出：
WCMException

delete

public boolean delete(int _nDelTemplateId)
               throws WCMException
从接口 ITemplateService 复制的描述
根据模板ID彻底删除模板

指定者：
接口 ITemplateService 中的 delete
参数：
_nDelTemplateId - 待删除的模板Id
返回：
操作是否成功
抛出：
WCMException

delete

public boolean delete(Template _template)
               throws WCMException
从接口 ITemplateService 复制的描述
彻底删除模板

指定者：
接口 ITemplateService 中的 delete
参数：
_template - 待删除的模板
返回：
操作是否成功
抛出：
WCMException

export

public java.lang.String export(java.lang.String _sTemplateIds)
                        throws WCMException
从接口 ITemplateService 复制的描述
根据模板的Id列表导出模板集合到临时目录的文件中

指定者：
接口 ITemplateService 中的 export
参数：
_sTemplateIds - 模板的Id列表
返回：
导出的文件名（不含路径，应是一个临时目录）
抛出：
WCMException

export

public java.lang.String export(Templates _currTemplates)
                        throws WCMException
从接口 ITemplateService 复制的描述
导出模板集合到临时目录的文件中

指定者：
接口 ITemplateService 中的 export
参数：
_currTemplates - 待导出的模板集合
返回：
导出的文件名（不含路径，应是一个临时目录）
抛出：
WCMException

export

public java.lang.String export(int _nTemplateId)
                        throws WCMException
从接口 ITemplateService 复制的描述
根据Id导出模板到临时目录的文件中

指定者：
接口 ITemplateService 中的 export
参数：
_nTemplateId - 待导出的模板Id
返回：
导出的文件名（不含路径，应是一个临时目录）
抛出：
WCMException

export

public java.lang.String export(Template _currTemplate)
                        throws WCMException
从接口 ITemplateService 复制的描述
导出模板到固定的文件中

指定者：
接口 ITemplateService 中的 export
参数：
_currTemplate - 待导出的模板
返回：
导出的文件名（不含路径，应是一个临时目录）
抛出：
WCMException

preview

public java.lang.String preview(int _nTemplateId)
                         throws WCMException
从接口 ITemplateService 复制的描述
预览指定id的模板

指定者：
接口 ITemplateService 中的 preview
参数：
_nTemplateId - 指定的模板Id
返回：
模板的内容
抛出：
WCMException

preview

public java.lang.String preview(Template _template)
                         throws WCMException
从接口 ITemplateService 复制的描述
预览指定的模板

指定者：
接口 ITemplateService 中的 preview
参数：
_template - 指定的模板
返回：
模板的内容
抛出：
WCMException

importFromZip

public Reports importFromZip(CMSObj _siteOrChannel,
                             java.lang.String _sFileName,
                             int _nImportMode,
                             int _nPicMode,
                             java.lang.String[] _arSelected)
                      throws WCMException
从接口 ITemplateService 复制的描述
从zip文件中导入模板

指定者：
接口 ITemplateService 中的 importFromZip
参数：
_siteOrChannel - 站点/频道对象
_sFileName - 文件名(规则的WCM文件名)
_nImportMode - 模板导入模式,模板重名的处理方式(WCMTypes.TEMPLATE_DEAL_MODE_UPDATE等)
_nPicMode - 模板附件导入模式,附件重名的处理方式(WCMTypes.TEMPLATEAPD_DEAL_MODE_UPDATE等)
_arSelected - 用户已经选择的是模板的文件的列表
返回：
导入成功的模板名
抛出：
WCMException

importFromHTML

public Reports importFromHTML(CMSObj _siteOrChannel,
                              java.lang.String _sFileName,
                              int _nImportMode,
                              java.lang.String _sSrcName)
                       throws WCMException
从接口 ITemplateService 复制的描述
从html文件导入模板

指定者：
接口 ITemplateService 中的 importFromHTML
参数：
_siteOrChannel - 站点/频道对象
_sFileName - 文件名(WCM规则的文件名)
_nImportMode - 模板导入模式,模板重名的处理方式(WCMTypes.TEMPLATE_DEAL_MODE_UPDATE等)
_sSrcName - 模板原文件名(模板的入库文件名)
返回：
抛出：
WCMException

extractTemplateNamesFromZip

public java.lang.String[] extractTemplateNamesFromZip(java.lang.String _sZipFileName)
                                               throws WCMException
从接口 ITemplateService 复制的描述
得到导入文件中可能的模板文件名列表

指定者：
接口 ITemplateService 中的 extractTemplateNamesFromZip
参数：
_sZipFileName - 待导入的模板文件，为ZIP格式
返回：
可能存在的模板名称列表
抛出：
WCMException

redistributeAppendixes

public Reports redistributeAppendixes(CMSObj _chnlOrSite,
                                      boolean _zRecursive)
                               throws WCMException
从接口 ITemplateService 复制的描述
重新分发指定站点或者频道下的所有模板的附件，并且如果_zRecursive 为true ，则会进一步地重新分发子频道下的模板的附件。

指定者：
接口 ITemplateService 中的 redistributeAppendixes
参数：
_chnlOrSite - 站点或者频道
_zRecursive - 是否递归子频道
返回：
执行结果
抛出：
WCMException - 如果发生异常

getDetailTemplate

public Template getDetailTemplate(IPublishElement _publishElement)
                           throws WCMException
从接口 ITemplateService 复制的描述
获得指定频道的细览模板

指定者：
接口 ITemplateService 中的 getDetailTemplate
参数：
_publishElement - a channel
返回：
细览模板，如果没有细览模板则返回null
抛出：
WCMException

getOutlineTemplates

public Templates getOutlineTemplates(IPublishFolder _folder)
                              throws WCMException
从接口 ITemplateService 复制的描述
获得指定频道的概览模板

指定者：
接口 ITemplateService 中的 getOutlineTemplates
参数：
_folder - channel or site
返回：
概览模板，如果没有概览模板则返回null
抛出：
WCMException

setDetailTemplate

public void setDetailTemplate(IPublishFolder _folder,
                              int _nTemplateId,
                              boolean _bResetChildren)
                       throws WCMException
从接口 ITemplateService 复制的描述
为指定频道设定细览模板

指定者：
接口 ITemplateService 中的 setDetailTemplate
_bResetChildren - 是否重设子频道的细览模板
如果为 true,则重设
抛出：
WCMException

setOutlineTemplates

public void setOutlineTemplates(IPublishFolder _folder,
                                java.lang.String _sTemplateIds,
                                boolean _bResetChildren)
                         throws WCMException
从接口 ITemplateService 复制的描述
为指定频道设定概览模板

指定者：
接口 ITemplateService 中的 setOutlineTemplates
_sTemplateIds - 模板ID列表；其中第一个为默认的概览模板。
_bResetChildren - 是否重设子频道的概览模板
如果为 true,则重设
抛出：
WCMException

setDetailTemplate

public void setDetailTemplate(IPublishContent _content,
                              int _nTemplateId,
                              int _nDetailTemplateType)
                       throws WCMException
从接口 ITemplateService 复制的描述
为指定文档设定模板

指定者：
接口 ITemplateService 中的 setDetailTemplate
抛出：
WCMException

setDetailTemplate

public void setDetailTemplate(IPublishContent _content,
                              int _nTemplateId)
                       throws WCMException
指定者：
接口 ITemplateService 中的 setDetailTemplate
抛出：
WCMException

getManagedTemplates

public Templates getManagedTemplates(CMSObj _channelOrSite,
                                     int _nTemplateType,
                                     WCMFilter _filter,
                                     boolean _bIncludingThoseInChildren)
                              throws WCMException
从接口 ITemplateService 复制的描述
获取站点/频道下管理的模板集合

指定者：
接口 ITemplateService 中的 getManagedTemplates
_nTemplateType - 模板类型(Template.ALL_TEMPLATE等)
_filter - 过滤器,额外的查询条件
_bIncludingThoseInChildren - 是否包括子频道的模板
返回：
模板集合
抛出：
WCMException
另请参见：
ITemplateService.getManagedTemplates(CMSObj, int, WCMFilter, boolean)

getOptionalTemplates

public Templates getOptionalTemplates(IPublishFolder _folder,
                                      int _nTemplateType,
                                      WCMFilter _filter,
                                      boolean _bIncludingThoseInParent)
                               throws WCMException
从接口 ITemplateService 复制的描述
获取指定Folder中可选的模板集合

指定者：
接口 ITemplateService 中的 getOptionalTemplates
参数：
_folder - 当前站点/频道
_nTemplateType - 模板类型
_filter - 过滤器,额外的查询条件
_bIncludingThoseInParent - 是否包含父频道的模板
返回：
模板集合
抛出：
WCMException
另请参见：
ITemplateService.getOptionalTemplates(IPublishFolder, int, WCMFilter, boolean)

getNestedTemplates

public Templates getNestedTemplates(Template _template)
                             throws WCMException
从接口 ITemplateService 复制的描述
获取当前模板中使用到的嵌套模板

指定者：
接口 ITemplateService 中的 getNestedTemplates
参数：
_template - 当前模板
返回：
抛出：
WCMException

getTemplatesNested

public Templates getTemplatesNested(Template _template)
                             throws WCMException
从接口 ITemplateService 复制的描述
获取嵌套了当前模板的所有模板

指定者：
接口 ITemplateService 中的 getTemplatesNested
参数：
_template - 当前模板
返回：
抛出：
WCMException

getTemplateEmployers

public java.util.List getTemplateEmployers(Template _template,
                                           int _nEmployerType)
                                    throws WCMException
从接口 ITemplateService 复制的描述
获取使用到当前模板的指定类型的对象集合

指定者：
接口 ITemplateService 中的 getTemplateEmployers
参数：
_template - 当前模板
_nEmployerType - 指定对象类型
返回：
抛出：
WCMException

getTemplateEmployers

public java.util.List getTemplateEmployers(Template _template)
                                    throws WCMException
从接口 ITemplateService 复制的描述
获取使用到当前模板的所有对象集合

指定者：
接口 ITemplateService 中的 getTemplateEmployers
参数：
_template - 当前模板
返回：
抛出：
WCMException
另请参见：
ITemplateService#getTemplateEmployer(Template)

findByName

public Template findByName(int _nSiteId,
                           java.lang.String _sTempName)
                    throws WCMException
从接口 ITemplateService 复制的描述
根据指定的SiteId，找到指定名称的模板

指定者：
接口 ITemplateService 中的 findByName
返回：
抛出：
WCMException

getTemplateArguments

public TemplateArguments getTemplateArguments(IPublishElement _element)
                                       throws WCMException
从接口 ITemplateService 复制的描述
返回指定发布对象上的全部有效模板参数列表

指定者：
接口 ITemplateService 中的 getTemplateArguments
返回：
有效的模板参数列表
抛出：
WCMException

deleteTemplateArgument

public boolean deleteTemplateArgument(TemplateArgument _argument)
                               throws WCMException
从接口 ITemplateService 复制的描述
删除指定的TemplateArgument对象

指定者：
接口 ITemplateService 中的 deleteTemplateArgument
参数：
_argument - 待删除的TemplateArgument对象
返回：
是否删除成功
抛出：
WCMException - 如果发生错误

deleteTemplateArguments

public void deleteTemplateArguments(TemplateArguments _arguments)
                             throws WCMException
从接口 ITemplateService 复制的描述
删除指定的TemplateArguments对象集合

指定者：
接口 ITemplateService 中的 deleteTemplateArguments
参数：
_arguments - 待删除的TemplateArguments对象集合
抛出：
WCMException - 如果发生错误

saveTemplateArgument

public TemplateArgument saveTemplateArgument(TemplateArgument _argument)
                                      throws WCMException
从接口 ITemplateService 复制的描述
保存指定的TemplateArgument对象

指定者：
接口 ITemplateService 中的 saveTemplateArgument
参数：
_argument - 待保存的TemplateArgument对象
返回：
保存后的TemplateArgument对象
抛出：
WCMException - 如果发生错误

getTemplateParameters

public TemplateParameterList getTemplateParameters(IPublishElement _element)
                                            throws WCMException
从接口 ITemplateService 复制的描述
返回指定发布对象使用的所有模板中的全部形式参数列表

指定者：
接口 ITemplateService 中的 getTemplateParameters
返回：
指定发布对象使用的所有模板中的全部形式参数列表
抛出：
WCMException

getTemplateParameters

public TemplateParameterList getTemplateParameters(IPublishElement _element,
                                                   boolean zRecursion)
                                            throws WCMException
从接口 ITemplateService 复制的描述
返回指定发布对象使用的所有模板中的全部形式参数列表

指定者：
接口 ITemplateService 中的 getTemplateParameters
参数：
_element - 指定的发布对象
zRecursion - 是否递归被嵌套的模板中变量
返回：
指定发布对象使用的所有模板中的全部形式参数列表
抛出：
WCMException - 如果发生错误

addNestedParameters

public void addNestedParameters(IPublishElement _element,
                                Template template,
                                TemplateParameterList list)
概述  软件包   类  使用  树  已过时  索引  帮助
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 UserService

java.lang.Object
    继承者  com.trs.service.impl.UserService
所有已实现的接口：
IUserService
public class UserService
extends java.lang.Object
implements IUserService

Title: TRS 内容协作平台（TRS WCM）
Description:

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
UserService()
方法摘要
boolean | delete(int _nUserId, boolean _bDrop) 删除指定的用户
boolean | delete(java.lang.String _sUserIds, boolean _bDrop) 根据用户id序列,批量删除指定的用户
boolean | delete(User _userToDelete, boolean _bDrop) 删除指定的用户
boolean | delete(Users _usersToDelete, boolean _bDrop) 批量删除指定的用户
boolean | disable(int _nUserId) 根据Id来禁用用户
boolean | disable(User _userToDisable) 设置一个用户为禁用状态
boolean | enable(int _nUserId) 根据ID恢复用户
boolean | enable(User _userToEnable) 开通一个用户
Users | getCanMgrUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所能管理的用户
Documents | getDocuments() 获取当前登录用户创建的有效文档集合
Documents | getDocuments(WCMFilter _filter) 获取当前登录用户创建的有效文档集合,设定查询条件
Documents | getDraft() 获取当前登录用户创建的草稿集合
Documents | getDraft(WCMFilter _filter) 获取当前登录用户创建的草稿集合,设定查询条件
Groups | getGroups() 获取当前登录用户所在的组织.
Groups | getGroups(User _currUser) 获取指定用户所在的组织集合
Users | getMyUsers(int _nUserRegStatus, WCMFilter _filter) 获取我所创建的用户列表
Documents | getRecycleDocuments() 获取当前登录用户创建的废稿集合
Documents | getRecycleDocuments(WCMFilter _filter) 获取当前登录用户创建的废稿集合,设定查询条件
Roles | getRoles() 获取当前登录用户所担任的角色.
Roles | getRoles(User _currUser) 获取指定用户所属的角色集合
Users | getUsers(int _nUserRegStatus, WCMFilter _filter) 获取系统中的某个注册状态的所有用户
boolean | isAdminOfGroup(User _user) 判断指定用户是否在系统中担任组管理员
boolean | isManagerOfRole(User _user) 判断指定用户是否在系统中担任角色维护员
boolean | resetPassword(User _dstUser) 重设指定用户的密码为缺省值(只能由系统管理员操作)
boolean | resetPassword(User _dstUser, java.lang.String _sNewPassword) 重置用户密码为新密码
boolean | resetPassword(User _dstUser, java.lang.String _sOldPassword, java.lang.String _sNewPassword) 重设指定用户的登录密码
boolean | restore(User _userToRestore) 恢复已删除的用户
boolean | restore(Users _usersToRestore) 恢复已删除的用户集合
User | save(User _userToSave) 保存一个用户
User | save(User _userToSave, Group _currGrp)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UserService

public UserService()
方法详细信息

getDocuments

public Documents getDocuments()
                       throws WCMException
从接口 IUserService 复制的描述
获取当前登录用户创建的有效文档集合

指定者：
接口 IUserService 中的 getDocuments
返回：
@throws WCMException
抛出：
WCMException

getDocuments

public Documents getDocuments(WCMFilter _filter)
                       throws WCMException
从接口 IUserService 复制的描述
获取当前登录用户创建的有效文档集合,设定查询条件

指定者：
接口 IUserService 中的 getDocuments
参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getDraft

public Documents getDraft()
                   throws WCMException
从接口 IUserService 复制的描述
获取当前登录用户创建的草稿集合

指定者：
接口 IUserService 中的 getDraft
返回：
@throws WCMException
抛出：
WCMException

getDraft

public Documents getDraft(WCMFilter _filter)
                   throws WCMException
从接口 IUserService 复制的描述
获取当前登录用户创建的草稿集合,设定查询条件

指定者：
接口 IUserService 中的 getDraft
参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getRecycleDocuments

public Documents getRecycleDocuments()
                              throws WCMException
从接口 IUserService 复制的描述
获取当前登录用户创建的废稿集合

指定者：
接口 IUserService 中的 getRecycleDocuments
返回：
@throws WCMException
抛出：
WCMException

getRecycleDocuments

public Documents getRecycleDocuments(WCMFilter _filter)
                              throws WCMException
从接口 IUserService 复制的描述
获取当前登录用户创建的废稿集合,设定查询条件

指定者：
接口 IUserService 中的 getRecycleDocuments
参数：
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getGroups

public Groups getGroups(User _currUser)
                 throws WCMException
从接口 IUserService 复制的描述
获取指定用户所在的组织集合

指定者：
接口 IUserService 中的 getGroups
参数：
_currUser - 指定的用户.
返回：
@throws WCMException
抛出：
WCMException

getGroups

public Groups getGroups()
                 throws WCMException
从接口 IUserService 复制的描述
获取当前登录用户所在的组织.

指定者：
接口 IUserService 中的 getGroups
返回：
@throws WCMException
抛出：
WCMException

getRoles

public Roles getRoles(User _currUser)
               throws WCMException
从接口 IUserService 复制的描述
获取指定用户所属的角色集合

指定者：
接口 IUserService 中的 getRoles
参数：
_currUser - 指定用户.
返回：
@throws WCMException
抛出：
WCMException

getRoles

public Roles getRoles()
               throws WCMException
从接口 IUserService 复制的描述
获取当前登录用户所担任的角色.

指定者：
接口 IUserService 中的 getRoles
返回：
@throws WCMException
抛出：
WCMException

save

public User save(User _userToSave)
          throws WCMException
从接口 IUserService 复制的描述
保存一个用户

指定者：
接口 IUserService 中的 save
参数：
_userToSave - 要保存的用户
返回：
@throws WCMException
抛出：
WCMException

save

public User save(User _userToSave,
                 Group _currGrp)
          throws WCMException
指定者：
接口 IUserService 中的 save
抛出：
WCMException

enable

public boolean enable(User _userToEnable)
               throws WCMException
从接口 IUserService 复制的描述
开通一个用户

指定者：
接口 IUserService 中的 enable
参数：
_userToEnable - 要开通的用户帐号
返回：
@throws WCMException
抛出：
WCMException

disable

public boolean disable(User _userToDisable)
                throws WCMException
从接口 IUserService 复制的描述
设置一个用户为禁用状态

指定者：
接口 IUserService 中的 disable
参数：
_userToDisable - 要禁用的用户
返回：
@throws WCMException
抛出：
WCMException

restore

public boolean restore(User _userToRestore)
                throws WCMException
从接口 IUserService 复制的描述
恢复已删除的用户

指定者：
接口 IUserService 中的 restore
参数：
_userToRestore - 要恢复的用户
返回：
@throws WCMException
抛出：
WCMException

restore

public boolean restore(Users _usersToRestore)
                throws WCMException
从接口 IUserService 复制的描述
恢复已删除的用户集合

指定者：
接口 IUserService 中的 restore
返回：
@throws WCMException
抛出：
WCMException

resetPassword

public boolean resetPassword(User _dstUser,
                             java.lang.String _sOldPassword,
                             java.lang.String _sNewPassword)
                      throws WCMException
从接口 IUserService 复制的描述
重设指定用户的登录密码

指定者：
接口 IUserService 中的 resetPassword
参数：
_dstUser - 指定的用户
_sOldPassword - 旧密码
_sNewPassword - 新密码
返回：
@throws WCMException
抛出：
WCMException

resetPassword

public boolean resetPassword(User _dstUser)
                      throws WCMException
从接口 IUserService 复制的描述
重设指定用户的密码为缺省值(只能由系统管理员操作)

指定者：
接口 IUserService 中的 resetPassword
返回：
@throws WCMException
抛出：
WCMException

resetPassword

public boolean resetPassword(User _dstUser,
                             java.lang.String _sNewPassword)
                      throws WCMException
重置用户密码为新密码

参数：
_dstUser -
_sNewPassword -
返回：
抛出：
WCMException

delete

public boolean delete(java.lang.String _sUserIds,
                      boolean _bDrop)
               throws WCMException
从接口 IUserService 复制的描述
根据用户id序列,批量删除指定的用户

指定者：
接口 IUserService 中的 delete
_bDrop - 是否删除数据库中的数据,true为删除,false为设置指定用户的注册状态为(User.USER_STATUS_DEL)
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(Users _usersToDelete,
                      boolean _bDrop)
               throws WCMException
从接口 IUserService 复制的描述
批量删除指定的用户

指定者：
接口 IUserService 中的 delete
参数：
_usersToDelete - 要删除的用户集合
_bDrop - 是否删除数据库中的数据,true为删除,false为设置指定用户的注册状态为(User.USER_STATUS_DEL)
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(int _nUserId,
                      boolean _bDrop)
               throws WCMException
从接口 IUserService 复制的描述
删除指定的用户

指定者：
接口 IUserService 中的 delete
参数：
_nUserId - 要删除的用户id
_bDrop - 是否删除数据库中的数据,true为删除,false为设置指定用户的注册状态为(User.USER_STATUS_DEL)
返回：
@throws WCMException
抛出：
WCMException

delete

public boolean delete(User _userToDelete,
                      boolean _bDrop)
               throws WCMException
从接口 IUserService 复制的描述
删除指定的用户

指定者：
接口 IUserService 中的 delete
参数：
_userToDelete - 要删除的用户
_bDrop - 是否删除数据库中的数据,true为删除,false为设置指定用户的注册状态为(User.USER_STATUS_DEL)
返回：
@throws WCMException
抛出：
WCMException

disable

public boolean disable(int _nUserId)
                throws WCMException
从接口 IUserService 复制的描述
根据Id来禁用用户

指定者：
接口 IUserService 中的 disable
抛出：
WCMException

enable

public boolean enable(int _nUserId)
               throws WCMException
从接口 IUserService 复制的描述
根据ID恢复用户

指定者：
接口 IUserService 中的 enable
参数：
_nUserId - 指定的用户id
抛出：
WCMException

getUsers

public Users getUsers(int _nUserRegStatus,
                      WCMFilter _filter)
               throws WCMException
从接口 IUserService 复制的描述
获取系统中的某个注册状态的所有用户

指定者：
接口 IUserService 中的 getUsers
参数：
_nUserRegStatus - 用户的注册状态(User.USER_STATUS_APPLY等)
_filter - 过滤器,额外的查询条件
返回：
@throws WCMException
抛出：
WCMException

getMyUsers

public Users getMyUsers(int _nUserRegStatus,
                        WCMFilter _filter)
                 throws WCMException
获取我所创建的用户列表

指定者：
接口 IUserService 中的 getMyUsers
参数：
_nUserRegStatus -
_filter -
返回：
抛出：
WCMException

getCanMgrUsers

public Users getCanMgrUsers(int _nUserRegStatus,
                            WCMFilter _filter)
                     throws WCMException
获取我所能管理的用户

指定者：
接口 IUserService 中的 getCanMgrUsers
参数：
_nUserRegStatus -
_filter -
返回：
抛出：
WCMException

isAdminOfGroup

public boolean isAdminOfGroup(User _user)
                       throws WCMException
判断指定用户是否在系统中担任组管理员

指定者：
接口 IUserService 中的 isAdminOfGroup
参数：
_user - 指定用户
返回：
如果有则返回 true
抛出：
WCMException

isManagerOfRole

public boolean isManagerOfRole(User _user)
                        throws WCMException
判断指定用户是否在系统中担任角色维护员

指定者：
接口 IUserService 中的 isManagerOfRole
参数：
_user - 指定用户
返回：
如果有则返回 true
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMProcessServiceImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 WCMProcessServiceImpl

java.lang.Object
    继承者  com.trs.service.impl.WCMProcessServiceImpl
所有已实现的接口：
IWCMProcessService
public class WCMProcessServiceImpl
extends java.lang.Object
implements IWCMProcessService

Title: TRS 内容协作平台（TRS WCM）
Description:
IWCMProcessService的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMProcessServiceImpl()
方法摘要
void | deleteFlows(java.lang.String _sFlowIds)
java.lang.String | exportFlow(int _nFlowId) 导出指定的工作流对象.
java.lang.String | exportFlows(java.lang.String _sFlowIds) 导出指定的工作流为XML文件格式的数据.
void | forceContentEndInFlow(int _nContentType, int _nContentId)
FlowDoc | getCurrentFlowDoc(int _nContentType, int _nContentId)
int | getCurrFlowFlag(int _nContentType, int _nContentId)
java.lang.String | getCurrFlowFlagDesc(int _nContentType, int _nContentId)
FlowDocs | getFlowDocs(int _nFlag, WCMFilter _filter)
FlowDocs | getFlowDocsOfContent(int _nContentType, int _nContentId) 获取当前内容的所有流转情况
Flow | getFlowOfEmployer(BaseObj _employer)
Flows | getFlows(WCMFilter _filter)
FlowDocs | getSubmitFlowDocs(User _operator, WCMFilter _filter) 获取用户[_operator]已经呈送的信息
Reports | importFlows(java.lang.String _sImportFile) 从XML文件中导入工作流配置.
Reports | importFlows(java.lang.String _sImportFile, java.lang.String _sXslFile) 从XML文件中导入工作流配置.
boolean | isCanInFlow(int _nContentType, int _nContentId)
Reports | saveFlow(java.lang.String _sFlowXML)
void | setFlowEmploy(BaseObj _employer, int _nFlowId)
FlowDoc | startContentInFlow(int _nContentType, int _nContentId)
void | submitAgain(User _postUser, int _nFlowDocId, java.lang.String _sOpinion)
void | submitBack(User _postUser, java.lang.String _sFromFlowDocId, java.lang.String _sOpinion) 指定的用户将指定的工作事项打回
void | submitTo(FlowParamers _currParamerts) 将内容按照指定的方式呈送
java.lang.String | toFlowsXMLString(java.lang.String _sFlowIds)
java.lang.String | toFlowXMLString(Flow _currFlow)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMProcessServiceImpl

public WCMProcessServiceImpl()
方法详细信息

getFlows

public Flows getFlows(WCMFilter _filter)
               throws WCMException
指定者：
接口 IWCMProcessService 中的 getFlows
抛出：
WCMException

deleteFlows

public void deleteFlows(java.lang.String _sFlowIds)
                 throws WCMException
指定者：
接口 IWCMProcessService 中的 deleteFlows
抛出：
WCMException

saveFlow

public Reports saveFlow(java.lang.String _sFlowXML)
                 throws WCMException
指定者：
接口 IWCMProcessService 中的 saveFlow
抛出：
WCMException

importFlows

public Reports importFlows(java.lang.String _sImportFile)
                    throws WCMException
从接口 IWCMProcessService 复制的描述
从XML文件中导入工作流配置.

指定者：
接口 IWCMProcessService 中的 importFlows
参数：
_sImportFile - 工作流的配置文件.
返回：
@throws WCMException
抛出：
WCMException

importFlows

public Reports importFlows(java.lang.String _sImportFile,
                           java.lang.String _sXslFile)
                    throws WCMException
从接口 IWCMProcessService 复制的描述
从XML文件中导入工作流配置.

指定者：
接口 IWCMProcessService 中的 importFlows
参数：
_sImportFile - 工作流配置文件.
_sXslFile - XML转换所需要的XSL文件.
返回：
@throws WCMException
抛出：
WCMException

exportFlow

public java.lang.String exportFlow(int _nFlowId)
                            throws WCMException
从接口 IWCMProcessService 复制的描述
导出指定的工作流对象.

指定者：
接口 IWCMProcessService 中的 exportFlow
参数：
_nFlowId - 指定的工作流对象ID.
返回：
@throws WCMException
抛出：
WCMException

exportFlows

public java.lang.String exportFlows(java.lang.String _sFlowIds)
                             throws WCMException
从接口 IWCMProcessService 复制的描述
导出指定的工作流为XML文件格式的数据.

指定者：
接口 IWCMProcessService 中的 exportFlows
参数：
_sFlowIds - 指定要导出的工作流对象的ID序列,必须以字符','分隔.
返回：
返回XML文件名,不包含路径.
抛出：
WCMException

getFlowDocs

public FlowDocs getFlowDocs(int _nFlag,
                            WCMFilter _filter)
                     throws WCMException
指定者：
接口 IWCMProcessService 中的 getFlowDocs
抛出：
WCMException

submitTo

public void submitTo(FlowParamers _currParamerts)
              throws WCMException
从接口 IWCMProcessService 复制的描述
将内容按照指定的方式呈送

指定者：
接口 IWCMProcessService 中的 submitTo
参数：
_currParamerts - 指定的方式(FlowParamers)
抛出：
WCMException

submitBack

public void submitBack(User _postUser,
                       java.lang.String _sFromFlowDocId,
                       java.lang.String _sOpinion)
                throws WCMException
从接口 IWCMProcessService 复制的描述
指定的用户将指定的工作事项打回

指定者：
接口 IWCMProcessService 中的 submitBack
参数：
_postUser - 指定的用户
_sFromFlowDocId - 指定的工作事项ID序列
_sOpinion - 意见
抛出：
WCMException

toFlowXMLString

public java.lang.String toFlowXMLString(Flow _currFlow)
                                 throws WCMException
指定者：
接口 IWCMProcessService 中的 toFlowXMLString
抛出：
WCMException

toFlowsXMLString

public java.lang.String toFlowsXMLString(java.lang.String _sFlowIds)
                                  throws WCMException
指定者：
接口 IWCMProcessService 中的 toFlowsXMLString
抛出：
WCMException

setFlowEmploy

public void setFlowEmploy(BaseObj _employer,
                          int _nFlowId)
                   throws WCMException
指定者：
接口 IWCMProcessService 中的 setFlowEmploy
抛出：
WCMException

getFlowOfEmployer

public Flow getFlowOfEmployer(BaseObj _employer)
                       throws WCMException
指定者：
接口 IWCMProcessService 中的 getFlowOfEmployer
抛出：
WCMException

startContentInFlow

public FlowDoc startContentInFlow(int _nContentType,
                                  int _nContentId)
                           throws WCMException
指定者：
接口 IWCMProcessService 中的 startContentInFlow
抛出：
WCMException

forceContentEndInFlow

public void forceContentEndInFlow(int _nContentType,
                                  int _nContentId)
                           throws WCMException
指定者：
接口 IWCMProcessService 中的 forceContentEndInFlow
抛出：
WCMException

getCurrentFlowDoc

public FlowDoc getCurrentFlowDoc(int _nContentType,
                                 int _nContentId)
指定者：
接口 IWCMProcessService 中的 getCurrentFlowDoc

getCurrFlowFlagDesc

public java.lang.String getCurrFlowFlagDesc(int _nContentType,
                                            int _nContentId)
                                     throws WCMException
指定者：
接口 IWCMProcessService 中的 getCurrFlowFlagDesc
抛出：
WCMException

getCurrFlowFlag

public int getCurrFlowFlag(int _nContentType,
                           int _nContentId)
                    throws WCMException
指定者：
接口 IWCMProcessService 中的 getCurrFlowFlag
抛出：
WCMException

getFlowDocsOfContent

public FlowDocs getFlowDocsOfContent(int _nContentType,
                                     int _nContentId)
                              throws WCMException
从接口 IWCMProcessService 复制的描述
获取当前内容的所有流转情况

指定者：
接口 IWCMProcessService 中的 getFlowDocsOfContent
参数：
_nContentType - 当前内容的类型
_nContentId - 当前内容的ID
返回：
FlowDocs
抛出：
WCMException

submitAgain

public void submitAgain(User _postUser,
                        int _nFlowDocId,
                        java.lang.String _sOpinion)
                 throws WCMException
指定者：
接口 IWCMProcessService 中的 submitAgain
抛出：
WCMException

getSubmitFlowDocs

public FlowDocs getSubmitFlowDocs(User _operator,
                                  WCMFilter _filter)
                           throws WCMException
从接口 IWCMProcessService 复制的描述
获取用户[_operator]已经呈送的信息

指定者：
接口 IWCMProcessService 中的 getSubmitFlowDocs
参数：
_operator - 操作用户
_filter - 检索条件
返回：
流转信息集合（FlowDoc）
抛出：
WCMException

isCanInFlow

public boolean isCanInFlow(int _nContentType,
                           int _nContentId)
                    throws WCMException
指定者：
接口 IWCMProcessService 中的 isCanInFlow
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMPublishElementServiceImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.service.impl
类 WCMPublishElementServiceImpl

java.lang.Object
    继承者  com.trs.service.impl.WCMPublishElementServiceImpl
所有已实现的接口：
IWCMPublishElementService
public class WCMPublishElementServiceImpl
extends java.lang.Object
implements IWCMPublishElementService

Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IWCMPublishElementService
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMPublishElementServiceImpl()
方法摘要
void | deletePublishDistributions(WebSite _currSite, java.lang.String _sPublishDistributionIds) 将当前站点的指定分发信息设置删除
WCMFolderPublishConfig | findFolderConfig(BaseChannel _currChannel) 获取当前站点或频道的发布配置信息
PublishDistributions | findPublishDistributions(WebSite _currSite, boolean _bExcludingDisabled, WCMFilter _filter) 获取当前站点所设置的分发目录集合
java.util.Iterator | getDistributionTargetTypes() Returns the distribution target type name collection iterator.
PublishDistributionTargetType | lookupDistributionTargetTypeByName(java.lang.String _sName) lookup the distribution target type by name.
WCMFolderPublishConfig | save(BaseChannel _currChannel, WCMFolderPublishConfig _currFolderConfig) 保存当前站点或频道的发布配置信息
PublishDistribution | save(WebSite _currSite, PublishDistribution _currPublishDistribution) 保存当前站点所设置的分发目录
void | setPubDistributionsEnable(WebSite _currSite, java.lang.String _sPublishDistributionIds, boolean _bEnable) 将当前站点的指定分发信息设置为无效
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMPublishElementServiceImpl

public WCMPublishElementServiceImpl()
方法详细信息

findFolderConfig

public WCMFolderPublishConfig findFolderConfig(BaseChannel _currChannel)
                                        throws WCMException
从接口 IWCMPublishElementService 复制的描述
获取当前站点或频道的发布配置信息

指定者：
接口 IWCMPublishElementService 中的 findFolderConfig
参数：
_currChannel - 当前站点或频道
返回：
站点或频道的发布配置信息（WCMFolderPublishConfig）
抛出：
WCMException

save

public WCMFolderPublishConfig save(BaseChannel _currChannel,
                                   WCMFolderPublishConfig _currFolderConfig)
                            throws WCMException
从接口 IWCMPublishElementService 复制的描述
保存当前站点或频道的发布配置信息

指定者：
接口 IWCMPublishElementService 中的 save
参数：
_currChannel - 当前站点或频道
_currFolderConfig - 站点或频道的发布配置信息
返回：
站点或频道的发布配置信息
抛出：
WCMException

findPublishDistributions

public PublishDistributions findPublishDistributions(WebSite _currSite,
                                                     boolean _bExcludingDisabled,
                                                     WCMFilter _filter)
                                              throws WCMException
从接口 IWCMPublishElementService 复制的描述
获取当前站点所设置的分发目录集合

指定者：
接口 IWCMPublishElementService 中的 findPublishDistributions
参数：
_currSite - 当前站点
_bExcludingDisabled - 是否只获取enable的
_filter - 过滤器,额外的查询条件
返回：
分发目录集合(PublishDistributions)
抛出：
WCMException

save

public PublishDistribution save(WebSite _currSite,
                                PublishDistribution _currPublishDistribution)
                         throws WCMException
从接口 IWCMPublishElementService 复制的描述
保存当前站点所设置的分发目录

指定者：
接口 IWCMPublishElementService 中的 save
参数：
_currSite - 当前站点
_currPublishDistribution - 需要保存的分发目录信息
返回：
成功保存的分发目录信息（PublishDistributionConfig）
抛出：
WCMException

setPubDistributionsEnable

public void setPubDistributionsEnable(WebSite _currSite,
                                      java.lang.String _sPublishDistributionIds,
                                      boolean _bEnable)
                               throws WCMException
从接口 IWCMPublishElementService 复制的描述
将当前站点的指定分发信息设置为无效

指定者：
接口 IWCMPublishElementService 中的 setPubDistributionsEnable
参数：
_currSite - 当前站点
_sPublishDistributionIds - 分发信息的ID序列
抛出：
WCMException

deletePublishDistributions

public void deletePublishDistributions(WebSite _currSite,
                                       java.lang.String _sPublishDistributionIds)
                                throws WCMException
从接口 IWCMPublishElementService 复制的描述
将当前站点的指定分发信息设置删除

指定者：
接口 IWCMPublishElementService 中的 deletePublishDistributions
参数：
_currSite - 当前站点
_sPublishDistributionIds - 需要删除的分发信息ID序列
抛出：
WCMException

getDistributionTargetTypes

public java.util.Iterator getDistributionTargetTypes()
                                              throws java.lang.Exception
从接口 IWCMPublishElementService 复制的描述
Returns the distribution target type name collection iterator.

指定者：
接口 IWCMPublishElementService 中的 getDistributionTargetTypes
返回：
the distribution target type name collection iterator.
抛出：
java.lang.Exception - if failed.

lookupDistributionTargetTypeByName

public PublishDistributionTargetType lookupDistributionTargetTypeByName(java.lang.String _sName)
                                                                 throws java.lang.Exception
从接口 IWCMPublishElementService 复制的描述
lookup the distribution target type by name.

指定者：
接口 IWCMPublishElementService 中的 lookupDistributionTargetTypeByName
参数：
_sName - the target type name.
返回：
the distribution target type if found, other null.
抛出：
java.lang.Exception - if the failed to load the configuration.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.service.impl.AutoDocBakService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.AutoDocBakService
的使用

没有 com.trs.service.impl.AutoDocBakService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.BookMarkService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.BookMarkService
的使用

没有 com.trs.service.impl.BookMarkService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.CDSServiceImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.CDSServiceImpl
的使用

没有 com.trs.service.impl.CDSServiceImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.ChannelService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.ChannelService
的使用

没有 com.trs.service.impl.ChannelService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.ContactService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.ContactService
的使用

没有 com.trs.service.impl.ContactService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.CustomizeService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.CustomizeService
的使用

没有 com.trs.service.impl.CustomizeService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.DBService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.DBService
的使用

没有 com.trs.service.impl.DBService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.DocumentService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.DocumentService
的使用

没有 com.trs.service.impl.DocumentService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.EventService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.EventService
的使用

没有 com.trs.service.impl.EventService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.FtpSoap4Radar 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.FtpSoap4Radar
的使用

没有 com.trs.service.impl.FtpSoap4Radar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.GroupService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.GroupService
的使用

没有 com.trs.service.impl.GroupService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.InfoViewDocImportService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.InfoViewDocImportService
的使用

没有 com.trs.service.impl.InfoViewDocImportService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.InfoViewEnumCreatorImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.InfoViewEnumCreatorImpl
的使用

没有 com.trs.service.impl.InfoViewEnumCreatorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.InfoViewInitorImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.InfoViewInitorImpl
的使用

没有 com.trs.service.impl.InfoViewInitorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.InfoViewService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.InfoViewService
的使用

没有 com.trs.service.impl.InfoViewService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.NetSnapTool 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.NetSnapTool
的使用

没有 com.trs.service.impl.NetSnapTool 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.OfficeDocumentService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.OfficeDocumentService
的使用

没有 com.trs.service.impl.OfficeDocumentService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.PublishService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.PublishService
的使用

没有 com.trs.service.impl.PublishService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.RecentService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.RecentService
的使用

没有 com.trs.service.impl.RecentService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.ResouceService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.ResouceService
的使用

没有 com.trs.service.impl.ResouceService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.RoleService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.RoleService
的使用

没有 com.trs.service.impl.RoleService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.ScheduleService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.ScheduleService
的使用

没有 com.trs.service.impl.ScheduleService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.SecurityService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.SecurityService
的使用

没有 com.trs.service.impl.SecurityService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.SiteNameCreator 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.SiteNameCreator
的使用

没有 com.trs.service.impl.SiteNameCreator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.SOAPServiceImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.SOAPServiceImpl
的使用

没有 com.trs.service.impl.SOAPServiceImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.StatService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.StatService
的使用

没有 com.trs.service.impl.StatService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.SureformService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.SureformService
的使用

没有 com.trs.service.impl.SureformService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.TemplateParseService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.TemplateParseService
的使用

没有 com.trs.service.impl.TemplateParseService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.TemplateService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.TemplateService
的使用

没有 com.trs.service.impl.TemplateService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.UserService 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.UserService
的使用

没有 com.trs.service.impl.UserService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.WCMProcessServiceImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.WCMProcessServiceImpl
的使用

没有 com.trs.service.impl.WCMProcessServiceImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.service.impl.WCMPublishElementServiceImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.service.impl.WCMPublishElementServiceImpl
的使用

没有 com.trs.service.impl.WCMPublishElementServiceImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CharSetFilter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.servlet
类 CharSetFilter

java.lang.Object
    继承者  com.trs.servlet.CharSetFilter
所有已实现的接口：
javax.servlet.Filter
public class CharSetFilter
extends java.lang.Object
implements javax.servlet.Filter

构造方法摘要
CharSetFilter()
方法摘要
void | destroy()
void | doFilter(javax.servlet.ServletRequest request, javax.servlet.ServletResponse response, javax.servlet.FilterChain chain)
void | init(javax.servlet.FilterConfig filterConfig)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CharSetFilter

public CharSetFilter()
方法详细信息

init

public void init(javax.servlet.FilterConfig filterConfig)
指定者：
接口 javax.servlet.Filter 中的 init

doFilter

public void doFilter(javax.servlet.ServletRequest request,
                     javax.servlet.ServletResponse response,
                     javax.servlet.FilterChain chain)
              throws java.io.IOException,
                     javax.servlet.ServletException
指定者：
接口 javax.servlet.Filter 中的 doFilter
抛出：
java.io.IOException
javax.servlet.ServletException

destroy

public void destroy()
指定者：
接口 javax.servlet.Filter 中的 destroy
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


JspDenyFilter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.servlet
类 JspDenyFilter

java.lang.Object
    继承者  com.trs.servlet.JspDenyFilter
所有已实现的接口：
javax.servlet.Filter
public class JspDenyFilter
extends java.lang.Object
implements javax.servlet.Filter

用户防止对指定资源的访问,以提供系统的安全性

作者：
Administrator

构造方法摘要
JspDenyFilter()
方法摘要
void | destroy()
void | doFilter(javax.servlet.ServletRequest request, javax.servlet.ServletResponse response, javax.servlet.FilterChain chain)
void | init(javax.servlet.FilterConfig config)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JspDenyFilter

public JspDenyFilter()
方法详细信息

destroy

public void destroy()
指定者：
接口 javax.servlet.Filter 中的 destroy

doFilter

public void doFilter(javax.servlet.ServletRequest request,
                     javax.servlet.ServletResponse response,
                     javax.servlet.FilterChain chain)
              throws java.io.IOException,
                     javax.servlet.ServletException
指定者：
接口 javax.servlet.Filter 中的 doFilter
抛出：
java.io.IOException
javax.servlet.ServletException

init

public void init(javax.servlet.FilterConfig config)
          throws javax.servlet.ServletException
指定者：
接口 javax.servlet.Filter 中的 init
抛出：
javax.servlet.ServletException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoginCheckFilter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.servlet
类 LoginCheckFilter

java.lang.Object
    继承者  com.trs.servlet.LoginCheckFilter
所有已实现的接口：
javax.servlet.Filter
public class LoginCheckFilter
extends java.lang.Object
implements javax.servlet.Filter

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

版本：
1.0
作者：
wyw

构造方法摘要
LoginCheckFilter()
方法摘要
void | destroy()
void | doFilter(javax.servlet.ServletRequest request, javax.servlet.ServletResponse response, javax.servlet.FilterChain chain)
void | init(javax.servlet.FilterConfig filterConfig)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LoginCheckFilter

public LoginCheckFilter()
方法详细信息

destroy

public void destroy()
指定者：
接口 javax.servlet.Filter 中的 destroy

doFilter

public void doFilter(javax.servlet.ServletRequest request,
                     javax.servlet.ServletResponse response,
                     javax.servlet.FilterChain chain)
              throws java.io.IOException,
                     javax.servlet.ServletException
指定者：
接口 javax.servlet.Filter 中的 doFilter
抛出：
java.io.IOException
javax.servlet.ServletException

init

public void init(javax.servlet.FilterConfig filterConfig)
          throws javax.servlet.ServletException
指定者：
接口 javax.servlet.Filter 中的 init
抛出：
javax.servlet.ServletException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.servlet
类
CharSetFilter
JspDenyFilter
LoginCheckFilter


com.trs.servlet

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.servlet

类摘要
CharSetFilter |
JspDenyFilter | 用户防止对指定资源的访问,以提供系统的安全性
LoginCheckFilter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn


com.trs.servlet 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.servlet 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.servlet.CharSetFilter (implements javax.servlet.Filter)
    • com.trs.servlet.JspDenyFilter (implements javax.servlet.Filter)
    • com.trs.servlet.LoginCheckFilter (implements javax.servlet.Filter)


软件包 com.trs.servlet 的使用

上一个 下一个 框架 无框架

软件包 com.trs.servlet
的使用

没有 com.trs.servlet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.servlet.CharSetFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.servlet.CharSetFilter
的使用

没有 com.trs.servlet.CharSetFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.servlet.JspDenyFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.servlet.JspDenyFilter
的使用

没有 com.trs.servlet.JspDenyFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.servlet.LoginCheckFilter 的使用

上一个 下一个 框架 无框架

类 com.trs.servlet.LoginCheckFilter
的使用

没有 com.trs.servlet.LoginCheckFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AbstractErrorMessage

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template
类 AbstractErrorMessage

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.template.AbstractErrorMessage
所有已实现的接口：
java.io.Serializable
public abstract class AbstractErrorMessage
extends java.lang.Exception

作者：
王纯刚 更改所生成类型注释的模板为 窗口 > 首选项 > Java > 代码生成 > 代码和注释
另请参见：
序列化表格

构造方法摘要
AbstractErrorMessage()
方法摘要
static AbstractErrorMessage | getAbstractErrorMessage(java.lang.String strClassName)
int | getCode() 获取错误号
java.lang.String | getDescription() 获取错误描述
java.lang.String | getSolution() 获取错误解决办法
void | setCode(int iCode) 设置错误号
void | setDescription(java.lang.String strDescription) 设置错误描述
void | setSolution(java.lang.String strSolution) 设置错误解决办法
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractErrorMessage

public AbstractErrorMessage()
方法详细信息

getAbstractErrorMessage

public static AbstractErrorMessage getAbstractErrorMessage(java.lang.String strClassName)
                                                    throws java.lang.Exception
抛出：
java.lang.Exception

getCode

public int getCode()
获取错误号

返回：
int 错误号

getDescription

public java.lang.String getDescription()
获取错误描述

返回：
String 错误描述

getSolution

public java.lang.String getSolution()
获取错误解决办法

返回：
String 错误解决办法

setCode

public void setCode(int iCode)
设置错误号

参数：
iCode - int 错误号

setDescription

public void setDescription(java.lang.String strDescription)
设置错误描述

参数：
strDescription - String 错误描述

setSolution

public void setSolution(java.lang.String strSolution)
设置错误解决办法

参数：
strSolution - String 错误解决办法
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DataTransferEncodeFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template
类 DataTransferEncodeFactory

java.lang.Object
    继承者  com.trs.template.DataTransferEncodeFactory

public class DataTransferEncodeFactory
extends java.lang.Object

作者：
Administrator TODO To change the template for this generated type comment go to Window - Preferences - Java - Code Generation - Code and Comments

构造方法摘要
DataTransferEncodeFactory()
方法摘要
static IDataTransferEncode createDataTransferEncode(java.lang.String strClassName)
创建IDataTransferEncode的实例
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataTransferEncodeFactory

public DataTransferEncodeFactory()
方法详细信息

createDataTransferEncode

public static IDataTransferEncode createDataTransferEncode(java.lang.String strClassName)
                                                    throws java.lang.Exception
创建IDataTransferEncode的实例

参数：
strClassName - 需要实例化的类名
返回：
实例化的类
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ErrorMessagesFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template
类 ErrorMessagesFactory

java.lang.Object
    继承者  com.trs.template.ErrorMessagesFactory

public class ErrorMessagesFactory
extends java.lang.Object

作者：
TRS应用产品开发部 更改所生成类型注释的模板为 窗口 > 首选项 > Java > 代码生成 > 代码和注释

构造方法摘要
ErrorMessagesFactory()
方法摘要
static IErrorMessages getIErrorMessages()
获取需要返回的错误信息集合的类
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ErrorMessagesFactory

public ErrorMessagesFactory()
方法详细信息

getIErrorMessages

public static IErrorMessages getIErrorMessages()
                                        throws java.lang.Exception
获取需要返回的错误信息集合的类

返回：
错误信息集合的类
抛出：
java.lang.Exception - 异常说明
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDataTransferEncode

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template
接口 IDataTransferEncode

public interface IDataTransferEncode

作者：
Administrator TODO To change the template for this generated type comment go to Window - Preferences - Java - Code Generation - Code and Comments

方法摘要
java.lang.String | encodeBytes(byte[] data) 对需要加密的数据进行加密
java.lang.String | encodeString(java.lang.String data) 对需要加密的数据进行加密

方法详细信息

encodeBytes

java.lang.String encodeBytes(byte[] data)
                             throws java.lang.Exception
对需要加密的数据进行加密

参数：
data - byte[] 需要加密的数据
返回：
加密后的数据
抛出：
java.lang.Exception - 异常说明

encodeString

java.lang.String encodeString(java.lang.String data)
                              throws java.lang.Exception
对需要加密的数据进行加密

参数：
data - String
返回：
加密后的数据
抛出：
java.lang.Exception - 异常说明
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IErrorMessages

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template
接口 IErrorMessages

public interface IErrorMessages

作者：
王纯刚 更改所生成类型注释的模板为 窗口 > 首选项 > Java > 代码生成 > 代码和注释

方法摘要
AbstractErrorMessage | getErrorMessage(int iCode) 根据错误号获取指定的错误信息
AbstractErrorMessage | getErrorMessageAt(int iIndex) 获取指定位置上的错误信息
void | open() 开放错误信息集合
int | size() 获取错误信息集合中错误信息的数量

方法详细信息

open

void open()
          throws java.lang.Exception
开放错误信息集合

抛出：
java.lang.Exception - 异常信息

getErrorMessage

AbstractErrorMessage getErrorMessage(int iCode)
根据错误号获取指定的错误信息

参数：
iCode - int 错误号
返回：
AbstractErrorMessage 错误信息

size

int size()
获取错误信息集合中错误信息的数量

返回：
int 错误信息的数量

getErrorMessageAt

AbstractErrorMessage getErrorMessageAt(int iIndex)
获取指定位置上的错误信息

参数：
iIndex - int 指定的位置
返回：
AbstractErrorMessage 错误信息
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InnerExceptionNum

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template
类 InnerExceptionNum

java.lang.Object
    继承者  com.trs.template.InnerExceptionNum

public class InnerExceptionNum
extends java.lang.Object

字段摘要
static int | ERR_CMYEXCEPTION
static int | ERR_LOADPROPERTY
static int | ERR_NOSUPPORTEDENCRYPTING
static int | ERR_PARAM_INVALID
static int | ERR_USER_INVALID
static int | ERR_USER_NOTEXIST
static int | ERR_USER_NOTLOGIN
static int | ERR_WCMEXCEPTION
static int | ERR_WRONG_PASSWORD
static int | TEST_NOEXCEPTION
构造方法摘要
InnerExceptionNum()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TEST_NOEXCEPTION

public static final int TEST_NOEXCEPTION
另请参见：
常量字段值

ERR_PARAM_INVALID

public static final int ERR_PARAM_INVALID
另请参见：
常量字段值

ERR_USER_NOTEXIST

public static final int ERR_USER_NOTEXIST
另请参见：
常量字段值

ERR_USER_INVALID

public static final int ERR_USER_INVALID
另请参见：
常量字段值

ERR_WRONG_PASSWORD

public static final int ERR_WRONG_PASSWORD
另请参见：
常量字段值

ERR_USER_NOTLOGIN

public static final int ERR_USER_NOTLOGIN
另请参见：
常量字段值

ERR_WCMEXCEPTION

public static final int ERR_WCMEXCEPTION
另请参见：
常量字段值

ERR_CMYEXCEPTION

public static final int ERR_CMYEXCEPTION
另请参见：
常量字段值

ERR_LOADPROPERTY

public static final int ERR_LOADPROPERTY
另请参见：
常量字段值

ERR_NOSUPPORTEDENCRYPTING

public static final int ERR_NOSUPPORTEDENCRYPTING
另请参见：
常量字段值
构造方法详细信息

InnerExceptionNum

public InnerExceptionNum()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.template
接口
IDataTransferEncode
IErrorMessages
类
DataTransferEncodeFactory
ErrorMessagesFactory
InnerExceptionNum
TemplateServiceConfig
TemplateServiceFactory
TRSTemplateFacade
异常
AbstractErrorMessage
TemplateRemoteException


com.trs.template

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.template

接口摘要
IDataTransferEncode
IErrorMessages

类摘要
DataTransferEncodeFactory
ErrorMessagesFactory
InnerExceptionNum
TemplateServiceConfig
TemplateServiceFactory
TRSTemplateFacade

异常摘要
AbstractErrorMessage
TemplateRemoteException


com.trs.template 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.template 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.template.DataTransferEncodeFactory
    • com.trs.template.ErrorMessagesFactory
    • com.trs.template.InnerExceptionNum
    • com.trs.template.TemplateServiceConfig
    • com.trs.template.TemplateServiceFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.template.AbstractErrorMessage
        • java.io.IOException
          • java.rmi.RemoteException
            • org.apache.axis.AxisFault
              • com.trs.template.TemplateRemoteException (implements java.io.Serializable)
    • com.trs.template.TRSTemplateFacade

接口分层结构

  • com.trs.template.IDataTransferEncode
  • com.trs.template.IErrorMessages


软件包 com.trs.template 的使用

上一个 下一个 框架 无框架

软件包 com.trs.template
的使用

使用 com.trs.template 的软件包
com.trs.template
com.trs.template.service
com.trs.template.service.impl

com.trs.template 使用的 com.trs.template 中的类
AbstractErrorMessage
IDataTransferEncode
IErrorMessages
TemplateRemoteException

com.trs.template.service 使用的 com.trs.template 中的类
TemplateRemoteException

com.trs.template.service.impl 使用的 com.trs.template 中的类
TemplateRemoteException

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TemplateRemoteException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template
类 TemplateRemoteException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  org.apache.axis.AxisFault
                        继承者  com.trs.template.TemplateRemoteException
所有已实现的接口：
java.io.Serializable
public class TemplateRemoteException
extends org.apache.axis.AxisFault
implements java.io.Serializable

作者：
王纯刚 更改所生成类型注释的模板为 窗口 > 首选项 > Java > 代码生成 > 代码和注释
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
TemplateRemoteException()
缺省的构造函数
TemplateRemoteException(java.lang.Exception ex)
构造函数，通过普通的Exception来构造TemplateRemoteException
TemplateRemoteException(int iFailCode, java.lang.String strFailDescription, java.lang.String strFailSolution)
直接构造函数
方法摘要
int | getFailCode() 获取错误号
java.lang.String | getFailDescription() 获取错误描述
java.lang.String | getFailSolution() 获取错误对应的推荐解决办法
static TemplateRemoteException | getRemoteException(int iCode) 根据错误号生成TemplateRemoteException对象
void | setFailCode(int iFailCode) 设置错误号
void | setFailDescription(java.lang.String strFailDescription) 设置错误描述
void | setFailSolution(java.lang.String strFailSolution) 设置错误对应的推荐解决办法
从类 org.apache.axis.AxisFault 继承的方法
addFaultDetail, addFaultDetail, addFaultDetailString, addFaultSubCode, addFaultSubCodeAsString, addHeader, addHostname, addHostnameIfNeeded, clearFaultDetails, clearFaultSubCodes, clearHeaders, dump, dumpToString, getFaultActor, getFaultCode, getFaultDetails, getFaultNode, getFaultReason, getFaultRole, getFaultString, getFaultSubCodes, getHeaders, lookupFaultDetail, makeFault, output, printStackTrace, printStackTrace, removeFaultDetail, removeHostname, setFaultActor, setFaultCode, setFaultCode, setFaultCodeAsString, setFaultDetail, setFaultDetailString, setFaultNode, setFaultReason, setFaultRole, setFaultString, toString, writeDetails
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TemplateRemoteException

public TemplateRemoteException()
缺省的构造函数

TemplateRemoteException

public TemplateRemoteException(java.lang.Exception ex)
构造函数，通过普通的Exception来构造TemplateRemoteException

参数：
ex - 普通的Exception

TemplateRemoteException

public TemplateRemoteException(int iFailCode,
                               java.lang.String strFailDescription,
                               java.lang.String strFailSolution)
直接构造函数

参数：
iFailCode - 错误号
strFailDescription - 错误描述
strFailSolution - 错误对应的推荐解决办法
方法详细信息

setFailCode

public void setFailCode(int iFailCode)
设置错误号

参数：
iFailCode - int 错误号

setFailDescription

public void setFailDescription(java.lang.String strFailDescription)
设置错误描述

参数：
strFailDescription - String 错误描述

setFailSolution

public void setFailSolution(java.lang.String strFailSolution)
设置错误对应的推荐解决办法

参数：
strFailSolution - String 错误对应的推荐解决办法

getFailCode

public int getFailCode()
获取错误号

返回：
int 错误号

getFailDescription

public java.lang.String getFailDescription()
获取错误描述

返回：
String 错误描述

getFailSolution

public java.lang.String getFailSolution()
获取错误对应的推荐解决办法

返回：
String 错误对应的推荐解决办法

getRemoteException

public static TemplateRemoteException getRemoteException(int iCode)
根据错误号生成TemplateRemoteException对象

参数：
iCode - 错误号
返回：
TemplateRemoteException 返回TemplateRemoteException
抛出：
java.lang.Exception - 异常说明
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateServiceConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template
类 TemplateServiceConfig

java.lang.Object
    继承者  com.trs.template.TemplateServiceConfig

public class TemplateServiceConfig
extends java.lang.Object

作者：
王纯刚 更改所生成类型注释的模板为 窗口 > 首选项 > Java > 代码生成 > 代码和注释

构造方法摘要
TemplateServiceConfig()
方法摘要
static java.util.Properties | getConfigs() 获取模板服务器交互接口的配置信息
static java.lang.String | getConfigValue(java.lang.String strConfigKey) 获取指定的主键对应的属性值
static void | main(java.lang.String[] args) 本类的测试函数
static void | reWriteConfigFile() 重写配置信息文件
static void | setInitStatus(int iInitStatus) 设置系统的初始化状态
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateServiceConfig

public TemplateServiceConfig()
方法详细信息

getConfigs

public static java.util.Properties getConfigs()
                                       throws java.lang.Exception
获取模板服务器交互接口的配置信息

返回：
Properties 模板服务器交互接口的配置信息
抛出：
java.lang.Exception - 异常说明

getConfigValue

public static java.lang.String getConfigValue(java.lang.String strConfigKey)
                                       throws java.lang.Exception
获取指定的主键对应的属性值

参数：
strConfigKey - String 指定的主键
返回：
String 主键对应的属性值，去掉了前后的空格
抛出：
java.lang.Exception - 异常说明

setInitStatus

public static void setInitStatus(int iInitStatus)
设置系统的初始化状态

参数：
iInitStatus -

main

public static void main(java.lang.String[] args)
本类的测试函数

参数：
args - String[] 测试时的参数

reWriteConfigFile

public static void reWriteConfigFile()
                              throws java.lang.Exception
重写配置信息文件

抛出：
java.lang.Exception - 出现异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateServiceFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template
类 TemplateServiceFactory

java.lang.Object
    继承者  com.trs.template.TemplateServiceFactory

public class TemplateServiceFactory
extends java.lang.Object

作者：
王纯刚 更改所生成类型注释的模板为 窗口 > 首选项 > Java > 代码生成 > 代码和注释

构造方法摘要
TemplateServiceFactory()
方法摘要
static ITemplateService createTemplateService(java.lang.String _sFactoryName)
创建ITemplateService实例
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateServiceFactory

public TemplateServiceFactory()
方法详细信息

createTemplateService

public static ITemplateService createTemplateService(java.lang.String _sFactoryName)
                                              throws java.lang.Exception
创建ITemplateService实例

参数：
_sFactoryName - 实例化的类名
返回：
ITemplateService
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSTemplateFacade

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template
类 TRSTemplateFacade

java.lang.Object
    继承者  com.trs.template.TRSTemplateFacade

public class TRSTemplateFacade
extends java.lang.Object

作者：
王纯刚 更改所生成类型注释的模板为 窗口 > 首选项 > Java > 代码生成 > 代码和注释

构造方法摘要
TRSTemplateFacade()
构造函数
方法摘要
boolean | checkin(java.lang.String sessionid, java.lang.String appname, java.lang.String primarykey, byte[] templatezipcontent) DW客户端上传模板
byte[] | checkout(java.lang.String sessionid, java.lang.String appname, java.lang.String primarykey) DW客户端下载模板
boolean | confirm(java.lang.String sessionid, java.lang.String appname, java.lang.String primarykey) DW客户端审核模板
byte[] | getAllSettings(java.lang.String sessionid) 获取所有的配置信息
java.lang.String[] | getAllSite(java.lang.String sessionid) 获取所有的项目称
byte[] | getSettingByType(java.lang.String sessionid, java.lang.String settingtype) 获取指定类型的配置信息
java.lang.String[] | getSettingTypeList(java.lang.String sessionid) 获取服务器端的配置信息的类别列表
java.lang.String | login(java.lang.String username, java.lang.String password, java.lang.String encrypttype, java.lang.String remoteip) DW客户端用户登录
boolean | logout(java.lang.String sessionid) DW客户端用户退出登录
static void | main(java.lang.String[] args) 测试一次本类
java.lang.String | preview(java.lang.String sessionid, java.lang.String appname, java.lang.String primarykey, byte[] templatezipcontent, java.lang.String query) DW客户端预览模板
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSTemplateFacade

public TRSTemplateFacade()
构造函数

方法详细信息

login

public java.lang.String login(java.lang.String username,
                              java.lang.String password,
                              java.lang.String encrypttype,
                              java.lang.String remoteip)
                       throws TemplateRemoteException
DW客户端用户登录

参数：
username - String 用户名
password - String 用户口令
encrypttype - String 用户口令加密方式
remoteip - String 客户端IP地址
返回：
String 用户登录后管理端分配的LocalSessionID
抛出：
TemplateRemoteException - 异常说明

logout

public boolean logout(java.lang.String sessionid)
               throws TemplateRemoteException
DW客户端用户退出登录

参数：
sessionid - String 用户登录后管理端分配的SessionID
返回：
boolean 成功返回true，失败返回false
抛出：
TemplateRemoteException - 异常说明

checkin

public boolean checkin(java.lang.String sessionid,
                       java.lang.String appname,
                       java.lang.String primarykey,
                       byte[] templatezipcontent)
                throws TemplateRemoteException
DW客户端上传模板

参数：
sessionid - String 用户登录后管理端分配的SessionID
appname - String 当前模板所在的项目ID
primarykey - String 模板对应的主键，相对于整个项目的相对路径，其中的分隔符为/
templatezipcontent - String 模板的内容
返回：
boolean 成功返回true，失败返回false
抛出：
TemplateRemoteException - 异常说明

confirm

public boolean confirm(java.lang.String sessionid,
                       java.lang.String appname,
                       java.lang.String primarykey)
                throws TemplateRemoteException
DW客户端审核模板

参数：
sessionid - String 用户登录后管理端分配的SessionID
appname - String 模板所在的项目
primarykey - String 模板对应的主键，相对于整个项目的相对路径，其中的分隔符为/
返回：
boolean 成功，返回true；失败返回false
抛出：
TemplateRemoteException - 异常说明

checkout

public byte[] checkout(java.lang.String sessionid,
                       java.lang.String appname,
                       java.lang.String primarykey)
                throws TemplateRemoteException
DW客户端下载模板

参数：
sessionid - String 用户登录后管理端分配的SessionID
appname - String 模板所在的项目
primarykey - String 模板对应的主键，相对于整个项目的相对路径，其中的分隔符为/
返回：
byte[] 模板的内容
抛出：
TemplateRemoteException - 异常说明

preview

public java.lang.String preview(java.lang.String sessionid,
                                java.lang.String appname,
                                java.lang.String primarykey,
                                byte[] templatezipcontent,
                                java.lang.String query)
                         throws TemplateRemoteException
DW客户端预览模板

参数：
sessionid - String 用户登录后管理端分配的SessionID
appname - 模板所在的项目
primarykey - String 模板对应的主键，相对于整个项目的相对路径，其中的分隔符为/
templatezipcontent - String 模板的内容
query - String 预览时的参数
返回：
String 预览模板的连接地址
抛出：
TemplateRemoteException - 异常说明

getAllSettings

public byte[] getAllSettings(java.lang.String sessionid)
                      throws TemplateRemoteException
获取所有的配置信息

参数：
sessionid - String 用户登录后管理端分配的SessionID
返回：
String 所有的配置信息
抛出：
TemplateRemoteException - 异常说明

getAllSite

public java.lang.String[] getAllSite(java.lang.String sessionid)
                              throws TemplateRemoteException
获取所有的项目称

参数：
sessionid - 用户登录后管理端分配的SessionID
返回：
所有的项目称
抛出：
TemplateRemoteException - 异常说明

getSettingByType

public byte[] getSettingByType(java.lang.String sessionid,
                               java.lang.String settingtype)
                        throws TemplateRemoteException
获取指定类型的配置信息

参数：
sessionid - String 用户登录后管理端分配的SessionID
settingtype - String 配置信息的类型
返回：
String 指定类型的配置信息
抛出：
TemplateRemoteException - 异常说明

getSettingTypeList

public java.lang.String[] getSettingTypeList(java.lang.String sessionid)
                                      throws TemplateRemoteException
获取服务器端的配置信息的类别列表

参数：
sessionid - String 用户登录后管理端分配的SessionID
返回：
String[] 服务器端的配置信息的类别列表
抛出：
TemplateRemoteException - 异常说明

main

public static void main(java.lang.String[] args)
测试一次本类

参数：
args - 测试用的参数
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.template.AbstractErrorMessage 的使用

上一个 下一个 框架 无框架

类 com.trs.template.AbstractErrorMessage
的使用

使用 AbstractErrorMessage 的软件包
com.trs.template

com.trs.template 中 AbstractErrorMessage 的使用

返回 AbstractErrorMessage 的 com.trs.template 中的方法
static AbstractErrorMessage | AbstractErrorMessage.getAbstractErrorMessage(java.lang.String strClassName)
AbstractErrorMessage | IErrorMessages.getErrorMessage(int iCode) 根据错误号获取指定的错误信息
AbstractErrorMessage | IErrorMessages.getErrorMessageAt(int iIndex) 获取指定位置上的错误信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.DataTransferEncodeFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.template.DataTransferEncodeFactory
的使用

没有 com.trs.template.DataTransferEncodeFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.ErrorMessagesFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.template.ErrorMessagesFactory
的使用

没有 com.trs.template.ErrorMessagesFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.template.IDataTransferEncode 的使用

上一个 下一个 框架 无框架

接口 com.trs.template.IDataTransferEncode
的使用

使用 IDataTransferEncode 的软件包
com.trs.template

com.trs.template 中 IDataTransferEncode 的使用

返回 IDataTransferEncode 的 com.trs.template 中的方法
static IDataTransferEncode DataTransferEncodeFactory.createDataTransferEncode(java.lang.String strClassName)
创建IDataTransferEncode的实例

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.template.IErrorMessages 的使用

上一个 下一个 框架 无框架

接口 com.trs.template.IErrorMessages
的使用

使用 IErrorMessages 的软件包
com.trs.template

com.trs.template 中 IErrorMessages 的使用

返回 IErrorMessages 的 com.trs.template 中的方法
static IErrorMessages ErrorMessagesFactory.getIErrorMessages()
获取需要返回的错误信息集合的类

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.InnerExceptionNum 的使用

上一个 下一个 框架 无框架

类 com.trs.template.InnerExceptionNum
的使用

没有 com.trs.template.InnerExceptionNum 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.TemplateRemoteException 的使用

上一个 下一个 框架 无框架

类 com.trs.template.TemplateRemoteException
的使用

使用 TemplateRemoteException 的软件包
com.trs.template
com.trs.template.service
com.trs.template.service.impl

com.trs.template 中 TemplateRemoteException 的使用

返回 TemplateRemoteException 的 com.trs.template 中的方法
static TemplateRemoteException TemplateRemoteException.getRemoteException(int iCode)
根据错误号生成TemplateRemoteException对象

抛出 TemplateRemoteException 的 com.trs.template 中的方法
boolean | TRSTemplateFacade.checkin(java.lang.String sessionid, java.lang.String appname, java.lang.String primarykey, byte[] templatezipcontent) DW客户端上传模板
byte[] | TRSTemplateFacade.checkout(java.lang.String sessionid, java.lang.String appname, java.lang.String primarykey) DW客户端下载模板
boolean | TRSTemplateFacade.confirm(java.lang.String sessionid, java.lang.String appname, java.lang.String primarykey) DW客户端审核模板
byte[] | TRSTemplateFacade.getAllSettings(java.lang.String sessionid) 获取所有的配置信息
java.lang.String[] | TRSTemplateFacade.getAllSite(java.lang.String sessionid) 获取所有的项目称
byte[] | TRSTemplateFacade.getSettingByType(java.lang.String sessionid, java.lang.String settingtype) 获取指定类型的配置信息
java.lang.String[] | TRSTemplateFacade.getSettingTypeList(java.lang.String sessionid) 获取服务器端的配置信息的类别列表
java.lang.String | TRSTemplateFacade.login(java.lang.String username, java.lang.String password, java.lang.String encrypttype, java.lang.String remoteip) DW客户端用户登录
boolean | TRSTemplateFacade.logout(java.lang.String sessionid) DW客户端用户退出登录
java.lang.String | TRSTemplateFacade.preview(java.lang.String sessionid, java.lang.String appname, java.lang.String primarykey, byte[] templatezipcontent, java.lang.String query) DW客户端预览模板

com.trs.template.service 中 TemplateRemoteException 的使用

抛出 TemplateRemoteException 的 com.trs.template.service 中的方法
boolean | ITemplateService.checkin(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey, byte[] strTemplateZipContent) DW客户端上传模板
byte[] | ITemplateService.checkout(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey) DW客户端下载模板
boolean | ITemplateService.confirm(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey) DW客户端启用模板
byte[] | ITemplateService.getAllSettings(java.lang.String strSessionID) 获取所有的配置信息
java.lang.String[] | ITemplateService.getAllSites(java.lang.String strSessionID) 从服务器端获取所有的项目
byte[] | ITemplateService.getSettingByType(java.lang.String strSessionID, java.lang.String strSettingType) 获取指定类型的配置信息
java.lang.String[] | ITemplateService.getSettingTypeList(java.lang.String strSessionID) 获取模板服务器端的配置的资源信息类型的列表
java.lang.String | ITemplateService.login(java.lang.String strUserName, java.lang.String strPassword, java.lang.String strEncryptType, java.lang.String strRemoteIP) DW客户端用户登录
boolean | ITemplateService.logout(java.lang.String strSessionID) DW客户端用户退出登录
java.lang.String | ITemplateService.preview(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey, byte[] bytesTemplateZipContent, java.lang.String strQuery) DW客户端预览模板

com.trs.template.service.impl 中 TemplateRemoteException 的使用

抛出 TemplateRemoteException 的 com.trs.template.service.impl 中的方法
boolean | TemplateServiceImpl.checkin(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey, byte[] strTemplateZipContent)
byte[] | TemplateServiceImpl.checkout(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey)
byte[] | TemplateServiceImpl.getAllSettings(java.lang.String strSessionID)
byte[] | TemplateServiceImpl.getSettingByType(java.lang.String strSessionID, java.lang.String strSettingType)
java.lang.String | TemplateServiceImpl.login(java.lang.String strUserName, java.lang.String strPassword, java.lang.String strEncryptType, java.lang.String strRemoteIP)
boolean | TemplateServiceImpl.logout(java.lang.String strSessionID)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.TemplateServiceConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.template.TemplateServiceConfig
的使用

没有 com.trs.template.TemplateServiceConfig 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.TemplateServiceFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.template.TemplateServiceFactory
的使用

没有 com.trs.template.TemplateServiceFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.TRSTemplateFacade 的使用

上一个 下一个 框架 无框架

类 com.trs.template.TRSTemplateFacade
的使用

没有 com.trs.template.TRSTemplateFacade 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


InfoEntityFinder

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain
类 InfoEntityFinder

java.lang.Object
    继承者  com.trs.template.domain.InfoEntityFinder

public class InfoEntityFinder
extends java.lang.Object

构造方法摘要
InfoEntityFinder()
方法摘要
InfoEntities | getBaseChannelEntities(int _nSiteId)
InfoEntities | getFieldEntities()
InfoEntities | getSiteEntities()
InfoEntities | getTemplateEntities()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoEntityFinder

public InfoEntityFinder()
方法详细信息

getBaseChannelEntities

public InfoEntities getBaseChannelEntities(int _nSiteId)
                                    throws WCMException
抛出：
WCMException

getSiteEntities

public InfoEntities getSiteEntities()
                             throws WCMException
抛出：
WCMException

getFieldEntities

public InfoEntities getFieldEntities()
                              throws WCMException
抛出：
WCMException

getTemplateEntities

public InfoEntities getTemplateEntities()
                                 throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.template.domain
类
InfoEntityFinder
SourcePathHelper
TemplateXmlGenerator
XTemplateExporter


com.trs.template.domain

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.template.domain

类摘要
InfoEntityFinder |
SourcePathHelper |
TemplateXmlGenerator |
XTemplateExporter | Title: TRS 内容协作平台（TRS WCM） Description: 负责管理模板导出相关的行为 模板导出过程中会涉及到模板附件的导出 由于目前顶已模板导出只伴随站点导出才导出，频道导出时不导出模板，所以模板附件的导出相对比较简单 以后再进行扩展 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.template.domain 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.template.domain 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.template.domain.InfoEntityFinder
    • com.trs.template.domain.SourcePathHelper
    • com.trs.template.domain.TemplateXmlGenerator
    • com.trs.template.domain.XTemplateExporter
    • com.trs.template.domain.XTemplateExporter.HierarchyEntity


软件包 com.trs.template.domain 的使用

上一个 下一个 框架 无框架

软件包 com.trs.template.domain
的使用

使用 com.trs.template.domain 的软件包
com.trs.template.domain

com.trs.template.domain 使用的 com.trs.template.domain 中的类
XTemplateExporter.HierarchyEntity

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


SourcePathHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain
类 SourcePathHelper

java.lang.Object
    继承者  com.trs.template.domain.SourcePathHelper

public class SourcePathHelper
extends java.lang.Object

构造方法摘要
SourcePathHelper()
方法摘要
static java.lang.String | getBaseChannelInfoFilePath(int _nSiteId)
static java.lang.String | getFieldInfoFilePath()
static java.lang.String | getFieldMockMappingFilePath()
static java.lang.String | getFormatedSettingFilesDir(java.lang.String _sZipFilePath)
static java.lang.String | getMappingFilePath()
static java.lang.String | getMockFieldInfoFilePath()
static java.lang.String | getSiteInfoFilePath()
static java.lang.String | getTemplateInfoFilePath()
static java.lang.String | getTemplatePackageDir()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SourcePathHelper

public SourcePathHelper()
方法详细信息

getTemplatePackageDir

public static java.lang.String getTemplatePackageDir()

getMappingFilePath

public static java.lang.String getMappingFilePath()
返回：

getFieldMockMappingFilePath

public static java.lang.String getFieldMockMappingFilePath()

getMockFieldInfoFilePath

public static java.lang.String getMockFieldInfoFilePath()

getSiteInfoFilePath

public static java.lang.String getSiteInfoFilePath()
返回：

getBaseChannelInfoFilePath

public static java.lang.String getBaseChannelInfoFilePath(int _nSiteId)

getFieldInfoFilePath

public static java.lang.String getFieldInfoFilePath()

getTemplateInfoFilePath

public static java.lang.String getTemplateInfoFilePath()

getFormatedSettingFilesDir

public static java.lang.String getFormatedSettingFilesDir(java.lang.String _sZipFilePath)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateXmlGenerator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain
类 TemplateXmlGenerator

java.lang.Object
    继承者  com.trs.template.domain.TemplateXmlGenerator

public class TemplateXmlGenerator
extends java.lang.Object

构造方法摘要
TemplateXmlGenerator()
方法摘要
java.util.ArrayList | getAllRelChannelsXmlFiles()
java.util.ArrayList | getAllRelFieldsXmlFiles()
java.util.ArrayList | getAllRelTemplatesXmlFiles()
static byte[] | zipFiles(java.util.List arFiles)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateXmlGenerator

public TemplateXmlGenerator()
方法详细信息

getAllRelChannelsXmlFiles

public java.util.ArrayList getAllRelChannelsXmlFiles()

getAllRelFieldsXmlFiles

public java.util.ArrayList getAllRelFieldsXmlFiles()

getAllRelTemplatesXmlFiles

public java.util.ArrayList getAllRelTemplatesXmlFiles()

zipFiles

public static byte[] zipFiles(java.util.List arFiles)
                       throws CMyException
参数：
arFiles -
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XTemplateExporter.HierarchyEntity

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain
类 XTemplateExporter.HierarchyEntity

java.lang.Object
    继承者  com.trs.template.domain.XTemplateExporter.HierarchyEntity
包容类：
XTemplateExporter
public class XTemplateExporter.HierarchyEntity
extends java.lang.Object

构造方法摘要
XTemplateExporter.HierarchyEntity()
XTemplateExporter.HierarchyEntity(java.lang.String _sBaseDir, java.lang.String _sFullDir)
方法摘要
java.lang.String | getBaseDir()
java.lang.String | getFullDir()
void | setBaseDir(java.lang.String baseDir)
void | setFullDir(java.lang.String fullDir)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XTemplateExporter.HierarchyEntity

public XTemplateExporter.HierarchyEntity()

XTemplateExporter.HierarchyEntity

public XTemplateExporter.HierarchyEntity(java.lang.String _sBaseDir,
                                         java.lang.String _sFullDir)
方法详细信息

getBaseDir

public java.lang.String getBaseDir()

setBaseDir

public void setBaseDir(java.lang.String baseDir)

getFullDir

public java.lang.String getFullDir()

setFullDir

public void setFullDir(java.lang.String fullDir)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


XTemplateExporter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain
类 XTemplateExporter

java.lang.Object
    继承者  com.trs.template.domain.XTemplateExporter

public class XTemplateExporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
负责管理模板导出相关的行为
模板导出过程中会涉及到模板附件的导出
由于目前顶已模板导出只伴随站点导出才导出，频道导出时不导出模板，所以模板附件的导出相对比较简单
以后再进行扩展
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

嵌套类摘要
 class XTemplateExporter.HierarchyEntity
构造方法摘要
XTemplateExporter()
constructor: default
方法摘要
java.lang.String | export(Templates _currTemplates) 导出模板集合
XTemplateExporter.HierarchyEntity | makeHierarchicalDir4Template(Template _oTemplate)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XTemplateExporter

public XTemplateExporter()
constructor: default

方法详细信息

export

public java.lang.String export(Templates _currTemplates)
                        throws WCMException
导出模板集合

参数：
_currTemplates - 要导出的模板集合
抛出：
WCMException

makeHierarchicalDir4Template

public XTemplateExporter.HierarchyEntity makeHierarchicalDir4Template(Template _oTemplate)
                                                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


类 com.trs.template.domain.InfoEntityFinder 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.InfoEntityFinder
的使用

没有 com.trs.template.domain.InfoEntityFinder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.domain.SourcePathHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.SourcePathHelper
的使用

没有 com.trs.template.domain.SourcePathHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.domain.TemplateXmlGenerator 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.TemplateXmlGenerator
的使用

没有 com.trs.template.domain.TemplateXmlGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.domain.XTemplateExporter.HierarchyEntity 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.XTemplateExporter.HierarchyEntity
的使用

使用 XTemplateExporter.HierarchyEntity 的软件包
com.trs.template.domain

com.trs.template.domain 中 XTemplateExporter.HierarchyEntity 的使用

返回 XTemplateExporter.HierarchyEntity 的 com.trs.template.domain 中的方法
 XTemplateExporter.HierarchyEntity XTemplateExporter.makeHierarchicalDir4Template(Template _oTemplate)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.domain.XTemplateExporter 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.XTemplateExporter
的使用

没有 com.trs.template.domain.XTemplateExporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AbstractTemplateSetting

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain.setting
类 AbstractTemplateSetting

java.lang.Object
    继承者  com.trs.template.domain.setting.AbstractTemplateSetting
所有已实现的接口：
ITemplateSetting
直接已知子类：
ChannelsTemplateSetting, FieldsTemplateSetting, TemplatesTemplateSetting
public abstract class AbstractTemplateSetting
extends java.lang.Object
implements ITemplateSetting

构造方法摘要
AbstractTemplateSetting()
方法摘要
byte[] | getContent()
java.util.List | getContentFiles()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractTemplateSetting

public AbstractTemplateSetting()
方法详细信息

getContent

public byte[] getContent()
                  throws WCMException
指定者：
接口 ITemplateSetting 中的 getContent
抛出：
WCMException

getContentFiles

public java.util.List getContentFiles()
指定者：
接口 ITemplateSetting 中的 getContentFiles
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ChannelsTemplateSetting

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain.setting
类 ChannelsTemplateSetting

java.lang.Object
    继承者  com.trs.template.domain.setting.AbstractTemplateSetting
        继承者  com.trs.template.domain.setting.ChannelsTemplateSetting
所有已实现的接口：
ITemplateSetting
public class ChannelsTemplateSetting
extends AbstractTemplateSetting

构造方法摘要
ChannelsTemplateSetting()
方法摘要
从类 com.trs.template.domain.setting.AbstractTemplateSetting 继承的方法
getContent, getContentFiles
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelsTemplateSetting

public ChannelsTemplateSetting()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldsTemplateSetting

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain.setting
类 FieldsTemplateSetting

java.lang.Object
    继承者  com.trs.template.domain.setting.AbstractTemplateSetting
        继承者  com.trs.template.domain.setting.FieldsTemplateSetting
所有已实现的接口：
ITemplateSetting
public class FieldsTemplateSetting
extends AbstractTemplateSetting

构造方法摘要
FieldsTemplateSetting()
方法摘要
从类 com.trs.template.domain.setting.AbstractTemplateSetting 继承的方法
getContent, getContentFiles
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FieldsTemplateSetting

public FieldsTemplateSetting()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ITemplateSetting

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain.setting
接口 ITemplateSetting

所有已知实现类：
AbstractTemplateSetting, ChannelsTemplateSetting, FieldsTemplateSetting, TemplatesTemplateSetting
public interface ITemplateSetting

方法摘要
byte[] | getContent()
java.util.List | getContentFiles()

方法详细信息

getContent

byte[] getContent()
                  throws WCMException
抛出：
WCMException

getContentFiles

java.util.List getContentFiles()
                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.template.domain.setting
接口
ITemplateSetting
类
AbstractTemplateSetting
ChannelsTemplateSetting
FieldsTemplateSetting
TemplateSettingFactory
TemplatesTemplateSetting


com.trs.template.domain.setting

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.template.domain.setting

接口摘要
ITemplateSetting

类摘要
AbstractTemplateSetting
ChannelsTemplateSetting
FieldsTemplateSetting
TemplateSettingFactory
TemplatesTemplateSetting


com.trs.template.domain.setting 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.template.domain.setting 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.template.domain.setting.AbstractTemplateSetting (implements com.trs.template.domain.setting.ITemplateSetting)
      • com.trs.template.domain.setting.ChannelsTemplateSetting
      • com.trs.template.domain.setting.FieldsTemplateSetting
      • com.trs.template.domain.setting.TemplatesTemplateSetting
    • com.trs.template.domain.setting.TemplateSettingFactory

接口分层结构

  • com.trs.template.domain.setting.ITemplateSetting


软件包 com.trs.template.domain.setting 的使用

上一个 下一个 框架 无框架

软件包 com.trs.template.domain.setting
的使用

使用 com.trs.template.domain.setting 的软件包
com.trs.template.domain.setting

com.trs.template.domain.setting 使用的 com.trs.template.domain.setting 中的类
AbstractTemplateSetting
ITemplateSetting
TemplateSettingFactory

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TemplateSettingFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain.setting
类 TemplateSettingFactory

java.lang.Object
    继承者  com.trs.template.domain.setting.TemplateSettingFactory

public class TemplateSettingFactory
extends java.lang.Object

字段摘要
static java.lang.String PROPERTY_NAME_SETTING
构造方法摘要
TemplateSettingFactory()
方法摘要
static TemplateSettingFactory | getInstance() 返回静态实例
java.lang.String[] | getSettingTypeClassz()
java.lang.String[] | getSettingTypes()
ITemplateSetting[] | makeAllSettings()
ITemplateSetting | makeSettingByType(java.lang.String _sSettingType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PROPERTY_NAME_SETTING

public static final java.lang.String PROPERTY_NAME_SETTING
另请参见：
常量字段值
构造方法详细信息

TemplateSettingFactory

public TemplateSettingFactory()
方法详细信息

makeSettingByType

public ITemplateSetting makeSettingByType(java.lang.String _sSettingType)
                                   throws WCMException
抛出：
WCMException

makeAllSettings

public ITemplateSetting[] makeAllSettings()
                                   throws WCMException
抛出：
WCMException

getInstance

public static TemplateSettingFactory getInstance()
返回静态实例

返回：

getSettingTypes

public java.lang.String[] getSettingTypes()

getSettingTypeClassz

public java.lang.String[] getSettingTypeClassz()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplatesTemplateSetting

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template.domain.setting
类 TemplatesTemplateSetting

java.lang.Object
    继承者  com.trs.template.domain.setting.AbstractTemplateSetting
        继承者  com.trs.template.domain.setting.TemplatesTemplateSetting
所有已实现的接口：
ITemplateSetting
public class TemplatesTemplateSetting
extends AbstractTemplateSetting

构造方法摘要
TemplatesTemplateSetting()
方法摘要
从类 com.trs.template.domain.setting.AbstractTemplateSetting 继承的方法
getContent, getContentFiles
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplatesTemplateSetting

public TemplatesTemplateSetting()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.template.domain.setting.AbstractTemplateSetting 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.setting.AbstractTemplateSetting
的使用

使用 AbstractTemplateSetting 的软件包
com.trs.template.domain.setting

com.trs.template.domain.setting 中 AbstractTemplateSetting 的使用

com.trs.template.domain.setting 中 AbstractTemplateSetting 的子类
class | ChannelsTemplateSetting
class | FieldsTemplateSetting
class | TemplatesTemplateSetting

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.domain.setting.ChannelsTemplateSetting 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.setting.ChannelsTemplateSetting
的使用

没有 com.trs.template.domain.setting.ChannelsTemplateSetting 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.domain.setting.FieldsTemplateSetting 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.setting.FieldsTemplateSetting
的使用

没有 com.trs.template.domain.setting.FieldsTemplateSetting 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.template.domain.setting.ITemplateSetting 的使用

上一个 下一个 框架 无框架

接口 com.trs.template.domain.setting.ITemplateSetting
的使用

使用 ITemplateSetting 的软件包
com.trs.template.domain.setting

com.trs.template.domain.setting 中 ITemplateSetting 的使用

实现 ITemplateSetting 的 com.trs.template.domain.setting 中的类
class | AbstractTemplateSetting
class | ChannelsTemplateSetting
class | FieldsTemplateSetting
class | TemplatesTemplateSetting

返回 ITemplateSetting 的 com.trs.template.domain.setting 中的方法
ITemplateSetting[] | TemplateSettingFactory.makeAllSettings()
ITemplateSetting | TemplateSettingFactory.makeSettingByType(java.lang.String _sSettingType)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.domain.setting.TemplateSettingFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.setting.TemplateSettingFactory
的使用

使用 TemplateSettingFactory 的软件包
com.trs.template.domain.setting

com.trs.template.domain.setting 中 TemplateSettingFactory 的使用

返回 TemplateSettingFactory 的 com.trs.template.domain.setting 中的方法
static TemplateSettingFactory TemplateSettingFactory.getInstance()
返回静态实例

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.domain.setting.TemplatesTemplateSetting 的使用

上一个 下一个 框架 无框架

类 com.trs.template.domain.setting.TemplatesTemplateSetting
的使用

没有 com.trs.template.domain.setting.TemplatesTemplateSetting 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseChannelInfoEntity

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template.persistent
类 BaseChannelInfoEntity

java.lang.Object
    继承者  com.trs.template.persistent.BaseChannelInfoEntity
所有已实现的接口：
IXmlPersistentObject, IInfoEntity
public class BaseChannelInfoEntity
extends java.lang.Object
implements IInfoEntity

构造方法摘要
BaseChannelInfoEntity()
方法摘要
java.lang.String | getChannelDesc()
int | getChannelId()
java.lang.String | getChannelName()
int | getChildren()
int | getIsRoot()
int | getParentId()
void | setChannelDesc(java.lang.String channelDesc)
void | setChannelId(int channelId)
void | setChannelName(java.lang.String channelName)
void | setChildren(int children)
void | setIsRoot(boolean _bIsRoot)
void | setParentId(int parentId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseChannelInfoEntity

public BaseChannelInfoEntity()
方法详细信息

getChannelDesc

public java.lang.String getChannelDesc()
返回：
the channelDesc

setChannelDesc

public void setChannelDesc(java.lang.String channelDesc)
参数：
channelDesc - the channelDesc to set

getChannelId

public int getChannelId()

setChannelId

public void setChannelId(int channelId)

getChildren

public int getChildren()

setChildren

public void setChildren(int children)

getParentId

public int getParentId()

setParentId

public void setParentId(int parentId)

getChannelName

public java.lang.String getChannelName()

setChannelName

public void setChannelName(java.lang.String channelName)

getIsRoot

public int getIsRoot()

setIsRoot

public void setIsRoot(boolean _bIsRoot)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IInfoEntity

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.persistent
接口 IInfoEntity

所有超级接口：
IXmlPersistentObject
所有已知实现类：
BaseChannelInfoEntity, TagFieldInfoEntity, TemplateInfoEntity, WebSiteInfoEntity
public interface IInfoEntity
extends IXmlPersistentObject

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InfoEntities

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.persistent
类 InfoEntities

java.lang.Object
    继承者  com.trs.template.persistent.InfoEntities
所有已实现的接口：
IXmlPersistentObject
public class InfoEntities
extends java.lang.Object
implements IXmlPersistentObject

构造方法摘要
InfoEntities()
方法摘要
void | add(IInfoEntity _oElement)
void | clear()
IInfoEntity | getAt(int _nIndex)
java.util.ArrayList | getInfoEntityColl()
void | setInfoEntityColl(java.util.ArrayList errorColl)
int | size()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InfoEntities

public InfoEntities()
方法详细信息

getInfoEntityColl

public java.util.ArrayList getInfoEntityColl()

setInfoEntityColl

public void setInfoEntityColl(java.util.ArrayList errorColl)

getAt

public IInfoEntity getAt(int _nIndex)

add

public void add(IInfoEntity _oElement)

clear

public void clear()

size

public int size()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.template.persistent
接口
IInfoEntity
类
BaseChannelInfoEntity
InfoEntities
TagFieldInfoEntity
TemplateInfoEntity
WebSiteInfoEntity


com.trs.template.persistent

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.template.persistent

接口摘要
IInfoEntity

类摘要
BaseChannelInfoEntity
InfoEntities
TagFieldInfoEntity
TemplateInfoEntity
WebSiteInfoEntity


com.trs.template.persistent 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.template.persistent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.template.persistent.BaseChannelInfoEntity (implements com.trs.template.persistent.IInfoEntity)
    • com.trs.template.persistent.InfoEntities (implements com.trs.infra.util.xml.IXmlPersistentObject)
    • com.trs.template.persistent.TagFieldInfoEntity (implements com.trs.template.persistent.IInfoEntity)
    • com.trs.template.persistent.TemplateInfoEntity (implements com.trs.template.persistent.IInfoEntity)
    • com.trs.template.persistent.WebSiteInfoEntity (implements com.trs.template.persistent.IInfoEntity)

接口分层结构

  • com.trs.infra.util.xml.IXmlPersistentObject
    • com.trs.template.persistent.IInfoEntity


软件包 com.trs.template.persistent 的使用

上一个 下一个 框架 无框架

软件包 com.trs.template.persistent
的使用

使用 com.trs.template.persistent 的软件包
com.trs.template.domain
com.trs.template.persistent

com.trs.template.domain 使用的 com.trs.template.persistent 中的类
InfoEntities

com.trs.template.persistent 使用的 com.trs.template.persistent 中的类
IInfoEntity

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TagFieldInfoEntity

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.persistent
类 TagFieldInfoEntity

java.lang.Object
    继承者  com.trs.template.persistent.TagFieldInfoEntity
所有已实现的接口：
IXmlPersistentObject, IInfoEntity
public class TagFieldInfoEntity
extends java.lang.Object
implements IInfoEntity

构造方法摘要
TagFieldInfoEntity()
TagFieldInfoEntity(int _nObjType, java.lang.String _sFields)
方法摘要
java.lang.String | getDescription()
java.lang.String | getFields()
int | getObjType()
void | setDescription(java.lang.String description)
void | setFields(java.lang.String detail)
void | setObjType(int num)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagFieldInfoEntity

public TagFieldInfoEntity()

TagFieldInfoEntity

public TagFieldInfoEntity(int _nObjType,
                          java.lang.String _sFields)
方法详细信息

getObjType

public int getObjType()

setObjType

public void setObjType(int num)

getFields

public java.lang.String getFields()

setFields

public void setFields(java.lang.String detail)

getDescription

public java.lang.String getDescription()

setDescription

public void setDescription(java.lang.String description)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplateInfoEntity

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.template.persistent
类 TemplateInfoEntity

java.lang.Object
    继承者  com.trs.template.persistent.TemplateInfoEntity
所有已实现的接口：
IXmlPersistentObject, IInfoEntity
public class TemplateInfoEntity
extends java.lang.Object
implements IInfoEntity

构造方法摘要
TemplateInfoEntity()
TemplateInfoEntity(int _nTemplateId, java.lang.String _sTemplateName)
方法摘要
int | getFolderId()
int | getFolderType()
int | getTemplateId()
java.lang.String | getTemplateName()
int | getTemplateType()
void | setFolderId(int folderId)
void | setFolderType(int folderType)
void | setTemplateId(int templateId)
void | setTemplateName(java.lang.String templateName)
void | setTemplateType(int temlateType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateInfoEntity

public TemplateInfoEntity()

TemplateInfoEntity

public TemplateInfoEntity(int _nTemplateId,
                          java.lang.String _sTemplateName)
方法详细信息

getFolderId

public int getFolderId()

setFolderId

public void setFolderId(int folderId)

getFolderType

public int getFolderType()

setFolderType

public void setFolderType(int folderType)

getTemplateType

public int getTemplateType()

setTemplateType

public void setTemplateType(int temlateType)

getTemplateId

public int getTemplateId()

setTemplateId

public void setTemplateId(int templateId)

getTemplateName

public java.lang.String getTemplateName()

setTemplateName

public void setTemplateName(java.lang.String templateName)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebSiteInfoEntity

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template.persistent
类 WebSiteInfoEntity

java.lang.Object
    继承者  com.trs.template.persistent.WebSiteInfoEntity
所有已实现的接口：
IXmlPersistentObject, IInfoEntity
public class WebSiteInfoEntity
extends java.lang.Object
implements IInfoEntity

构造方法摘要
WebSiteInfoEntity()
WebSiteInfoEntity(int _nSiteId, java.lang.String _sSiteName)
WebSiteInfoEntity(int _nSiteId, java.lang.String _sSiteName, java.lang.String _sSiteDesc)
方法摘要
java.lang.String | getSiteDesc()
int | getSiteId()
java.lang.String | getSiteName()
void | setSiteDesc(java.lang.String siteDesc)
void | setSiteId(int num)
void | setSiteName(java.lang.String detail)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebSiteInfoEntity

public WebSiteInfoEntity()

WebSiteInfoEntity

public WebSiteInfoEntity(int _nSiteId,
                         java.lang.String _sSiteName)

WebSiteInfoEntity

public WebSiteInfoEntity(int _nSiteId,
                         java.lang.String _sSiteName,
                         java.lang.String _sSiteDesc)
方法详细信息

getSiteId

public int getSiteId()

setSiteId

public void setSiteId(int num)

getSiteName

public java.lang.String getSiteName()

setSiteName

public void setSiteName(java.lang.String detail)

getSiteDesc

public java.lang.String getSiteDesc()
返回：
the siteDesc

setSiteDesc

public void setSiteDesc(java.lang.String siteDesc)
参数：
siteDesc - the siteDesc to set
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.template.persistent.BaseChannelInfoEntity 的使用

上一个 下一个 框架 无框架

类 com.trs.template.persistent.BaseChannelInfoEntity
的使用

没有 com.trs.template.persistent.BaseChannelInfoEntity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.template.persistent.IInfoEntity 的使用

上一个 下一个 框架 无框架

接口 com.trs.template.persistent.IInfoEntity
的使用

使用 IInfoEntity 的软件包
com.trs.template.persistent

com.trs.template.persistent 中 IInfoEntity 的使用

实现 IInfoEntity 的 com.trs.template.persistent 中的类
class | BaseChannelInfoEntity
class | TagFieldInfoEntity
class | TemplateInfoEntity
class | WebSiteInfoEntity

返回 IInfoEntity 的 com.trs.template.persistent 中的方法
 IInfoEntity InfoEntities.getAt(int _nIndex)

参数类型为 IInfoEntity 的 com.trs.template.persistent 中的方法
 void InfoEntities.add(IInfoEntity _oElement)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.persistent.InfoEntities 的使用

上一个 下一个 框架 无框架

类 com.trs.template.persistent.InfoEntities
的使用

使用 InfoEntities 的软件包
com.trs.template.domain

com.trs.template.domain 中 InfoEntities 的使用

返回 InfoEntities 的 com.trs.template.domain 中的方法
InfoEntities | InfoEntityFinder.getBaseChannelEntities(int _nSiteId)
InfoEntities | InfoEntityFinder.getFieldEntities()
InfoEntities | InfoEntityFinder.getSiteEntities()
InfoEntities | InfoEntityFinder.getTemplateEntities()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.persistent.TagFieldInfoEntity 的使用

上一个 下一个 框架 无框架

类 com.trs.template.persistent.TagFieldInfoEntity
的使用

没有 com.trs.template.persistent.TagFieldInfoEntity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.persistent.TemplateInfoEntity 的使用

上一个 下一个 框架 无框架

类 com.trs.template.persistent.TemplateInfoEntity
的使用

没有 com.trs.template.persistent.TemplateInfoEntity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.template.persistent.WebSiteInfoEntity 的使用

上一个 下一个 框架 无框架

类 com.trs.template.persistent.WebSiteInfoEntity
的使用

没有 com.trs.template.persistent.WebSiteInfoEntity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ITemplateService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template.service
接口 ITemplateService

所有已知实现类：
TemplateServiceImpl
public interface ITemplateService

Title: TRS 内容协作平台（TRS WCM）
Description:
模板编辑器服务器端代码 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
boolean | checkin(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey, byte[] strTemplateZipContent) DW客户端上传模板
byte[] | checkout(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey) DW客户端下载模板
boolean | confirm(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey) DW客户端启用模板
byte[] | getAllSettings(java.lang.String strSessionID) 获取所有的配置信息
java.lang.String[] | getAllSites(java.lang.String strSessionID) 从服务器端获取所有的项目
byte[] | getSettingByType(java.lang.String strSessionID, java.lang.String strSettingType) 获取指定类型的配置信息
java.lang.String[] | getSettingTypeList(java.lang.String strSessionID) 获取模板服务器端的配置的资源信息类型的列表
java.lang.String | login(java.lang.String strUserName, java.lang.String strPassword, java.lang.String strEncryptType, java.lang.String strRemoteIP) DW客户端用户登录
boolean | logout(java.lang.String strSessionID) DW客户端用户退出登录
java.lang.String | preview(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey, byte[] bytesTemplateZipContent, java.lang.String strQuery) DW客户端预览模板

方法详细信息

login

java.lang.String login(java.lang.String strUserName,
                       java.lang.String strPassword,
                       java.lang.String strEncryptType,
                       java.lang.String strRemoteIP)
                       throws TemplateRemoteException
DW客户端用户登录

参数：
strUserName - String 用户名
strPassword - String 用户口令
strEncryptType - String 用户口令加密方式
strRemoteIP - String 客户端IP地址
返回：
String 用户登录后管理端分配的LocalSessionID
抛出：
WCMException - TODO
TemplateRemoteException

logout

boolean logout(java.lang.String strSessionID)
               throws TemplateRemoteException
DW客户端用户退出登录

参数：
strSessionID - String 用户登录后管理端分配的SessionID
返回：
boolean 成功返回true，失败返回false
抛出：
TemplateRemoteException - 异常说明

checkin

boolean checkin(java.lang.String strSessionID,
                java.lang.String strAppName,
                java.lang.String strPrimaryKey,
                byte[] strTemplateZipContent)
                throws TemplateRemoteException
DW客户端上传模板

参数：
strSessionID - String 用户登录后管理端分配的SessionID
strPrimaryKey - String 模板对应的主键
strTemplateZipContent - String 模板的内容
currentfile -
返回：
boolean 成功返回true，失败返回false
抛出：
TemplateRemoteException - 异常说明

checkout

byte[] checkout(java.lang.String strSessionID,
                java.lang.String strAppName,
                java.lang.String strPrimaryKey)
                throws TemplateRemoteException
DW客户端下载模板

参数：
strSessionID - String 用户登录后管理端分配的SessionID
strPrimaryKey - String 模板对应的主键
返回：
String 模板的内容
抛出：
TemplateRemoteException - 异常说明

preview

java.lang.String preview(java.lang.String strSessionID,
                         java.lang.String strAppName,
                         java.lang.String strPrimaryKey,
                         byte[] bytesTemplateZipContent,
                         java.lang.String strQuery)
                         throws TemplateRemoteException
DW客户端预览模板

参数：
strSessionID - String 用户登录后管理端分配的SessionID
strPrimaryKey - String 模板对应的主键
bytesTemplateZipContent - String 模板的内容
currentfile -
iChannelID - int 频道号
返回：
String 预览模板的连接地址
抛出：
TemplateRemoteException - 异常说明

getAllSettings

byte[] getAllSettings(java.lang.String strSessionID)
                      throws TemplateRemoteException
获取所有的配置信息

参数：
strSessionID - String 用户登录后管理端分配的SessionID
返回：
String 所有的配置信息
抛出：
TemplateRemoteException - 异常说明

getSettingByType

byte[] getSettingByType(java.lang.String strSessionID,
                        java.lang.String strSettingType)
                        throws TemplateRemoteException
获取指定类型的配置信息

参数：
strSessionID - String 用户登录后管理端分配的SessionID
iSettingType - int 配置信息的类型
返回：
String 指定类型的配置信息
抛出：
TemplateRemoteException - 异常说明

confirm

boolean confirm(java.lang.String strSessionID,
                java.lang.String strAppName,
                java.lang.String strPrimaryKey)
                throws TemplateRemoteException
DW客户端启用模板

参数：
strSessionID - String 用户登录后管理端分配的SessionID
strPrimaryKey - String 模板对应的主键
currentfile -
返回：
boolean 如果启用模板成功，返回true；否则，返回false
抛出：
TemplateRemoteException - 异常说明

getSettingTypeList

java.lang.String[] getSettingTypeList(java.lang.String strSessionID)
                                      throws TemplateRemoteException
获取模板服务器端的配置的资源信息类型的列表

参数：
strSessionID - 用户登录后管理端分配的SessionID
返回：
模板服务器端的配置的资源信息类型的列表
抛出：
TemplateRemoteException - 异常说明

getAllSites

java.lang.String[] getAllSites(java.lang.String strSessionID)
                               throws TemplateRemoteException
从服务器端获取所有的项目

参数：
strSessionID - 用户登录后管理端分配的SessionID
返回：
获取所有的项目
抛出：
TemplateRemoteException - 异常说明
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.template.service
接口
ITemplateService


com.trs.template.service

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.template.service

接口摘要
ITemplateService Title: TRS 内容协作平台（TRS WCM）
Description:
模板编辑器服务器端代码 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.template.service 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.template.service 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • com.trs.template.service.ITemplateService


软件包 com.trs.template.service 的使用

上一个 下一个 框架 无框架

软件包 com.trs.template.service
的使用

使用 com.trs.template.service 的软件包
com.trs.template
com.trs.template.service.impl

com.trs.template 使用的 com.trs.template.service 中的类
ITemplateService
Title: TRS 内容协作平台（TRS WCM）
Description:
模板编辑器服务器端代码 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.template.service.impl 使用的 com.trs.template.service 中的类
ITemplateService
Title: TRS 内容协作平台（TRS WCM）
Description:
模板编辑器服务器端代码 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.template.service.ITemplateService 的使用

上一个 下一个 框架 无框架

接口 com.trs.template.service.ITemplateService
的使用

使用 ITemplateService 的软件包
com.trs.template
com.trs.template.service.impl

com.trs.template 中 ITemplateService 的使用

返回 ITemplateService 的 com.trs.template 中的方法
static ITemplateService TemplateServiceFactory.createTemplateService(java.lang.String _sFactoryName)
创建ITemplateService实例

com.trs.template.service.impl 中 ITemplateService 的使用

实现 ITemplateService 的 com.trs.template.service.impl 中的类
 class TemplateServiceImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
ITemplateService Implement Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.template.service.impl
类
TemplateServiceImpl


com.trs.template.service.impl

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.template.service.impl

类摘要
TemplateServiceImpl Title: TRS 内容协作平台（TRS WCM）
Description:
ITemplateService Implement Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.template.service.impl 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.template.service.impl 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.template.service.impl.TemplateServiceImpl (implements com.trs.template.service.ITemplateService)


软件包 com.trs.template.service.impl 的使用

上一个 下一个 框架 无框架

软件包 com.trs.template.service.impl
的使用

没有 com.trs.template.service.impl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TemplateServiceImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.template.service.impl
类 TemplateServiceImpl

java.lang.Object
    继承者  com.trs.template.service.impl.TemplateServiceImpl
所有已实现的接口：
ITemplateService
public class TemplateServiceImpl
extends java.lang.Object
implements ITemplateService

Title: TRS 内容协作平台（TRS WCM）
Description:
ITemplateService Implement Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TemplateServiceImpl()
方法摘要
boolean | checkin(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey, byte[] strTemplateZipContent) DW客户端上传模板
byte[] | checkout(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey) DW客户端下载模板
boolean | confirm(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey) DW客户端启用模板
byte[] | getAllSettings(java.lang.String strSessionID) 获取所有的配置信息
java.lang.String[] | getAllSites(java.lang.String strSessionID) 从服务器端获取所有的项目
byte[] | getSettingByType(java.lang.String strSessionID, java.lang.String strSettingType) 获取指定类型的配置信息
java.lang.String[] | getSettingTypeList(java.lang.String strSessionID) 获取模板服务器端的配置的资源信息类型的列表
java.lang.String | login(java.lang.String strUserName, java.lang.String strPassword, java.lang.String strEncryptType, java.lang.String strRemoteIP) DW客户端用户登录
boolean | logout(java.lang.String strSessionID) DW客户端用户退出登录
IPublishFolder | makeTemplateFolder(java.lang.String _sFormattedTempName, WebSite _oRootSite)
java.lang.String | preview(java.lang.String strSessionID, java.lang.String strAppName, java.lang.String strPrimaryKey, byte[] bytesTemplateZipContent, java.lang.String strQuery) DW客户端预览模板
static java.lang.String | writeFile(byte[] _pFileContent, java.lang.String _sFileExt) 将文件写入到Upload目录中
static void | writeSpecFile(byte[] _pFileContent, java.lang.String _sFilePath) 将文件写入到Upload目录中
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TemplateServiceImpl

public TemplateServiceImpl()
方法详细信息

login

public java.lang.String login(java.lang.String strUserName,
                              java.lang.String strPassword,
                              java.lang.String strEncryptType,
                              java.lang.String strRemoteIP)
                       throws TemplateRemoteException
从接口 ITemplateService 复制的描述
DW客户端用户登录

指定者：
接口 ITemplateService 中的 login
参数：
strUserName - String 用户名
strPassword - String 用户口令
strEncryptType - String 用户口令加密方式
strRemoteIP - String 客户端IP地址
返回：
String 用户登录后管理端分配的LocalSessionID
抛出：
TemplateRemoteException

logout

public boolean logout(java.lang.String strSessionID)
               throws TemplateRemoteException
从接口 ITemplateService 复制的描述
DW客户端用户退出登录

指定者：
接口 ITemplateService 中的 logout
参数：
strSessionID - String 用户登录后管理端分配的SessionID
返回：
boolean 成功返回true，失败返回false
抛出：
TemplateRemoteException - 异常说明

checkin

public boolean checkin(java.lang.String strSessionID,
                       java.lang.String strAppName,
                       java.lang.String strPrimaryKey,
                       byte[] strTemplateZipContent)
                throws TemplateRemoteException
从接口 ITemplateService 复制的描述
DW客户端上传模板

指定者：
接口 ITemplateService 中的 checkin
参数：
strSessionID - String 用户登录后管理端分配的SessionID
strPrimaryKey - String 模板对应的主键
strTemplateZipContent - String 模板的内容
返回：
boolean 成功返回true，失败返回false
抛出：
TemplateRemoteException - 异常说明

checkout

public byte[] checkout(java.lang.String strSessionID,
                       java.lang.String strAppName,
                       java.lang.String strPrimaryKey)
                throws TemplateRemoteException
从接口 ITemplateService 复制的描述
DW客户端下载模板

指定者：
接口 ITemplateService 中的 checkout
参数：
strSessionID - String 用户登录后管理端分配的SessionID
strPrimaryKey - String 模板对应的主键
返回：
String 模板的内容
抛出：
TemplateRemoteException - 异常说明

preview

public java.lang.String preview(java.lang.String strSessionID,
                                java.lang.String strAppName,
                                java.lang.String strPrimaryKey,
                                byte[] bytesTemplateZipContent,
                                java.lang.String strQuery)
从接口 ITemplateService 复制的描述
DW客户端预览模板

指定者：
接口 ITemplateService 中的 preview
参数：
strSessionID - String 用户登录后管理端分配的SessionID
strPrimaryKey - String 模板对应的主键
bytesTemplateZipContent - String 模板的内容
返回：
String 预览模板的连接地址

getAllSettings

public byte[] getAllSettings(java.lang.String strSessionID)
                      throws TemplateRemoteException
从接口 ITemplateService 复制的描述
获取所有的配置信息

指定者：
接口 ITemplateService 中的 getAllSettings
参数：
strSessionID - String 用户登录后管理端分配的SessionID
返回：
String 所有的配置信息
抛出：
TemplateRemoteException - 异常说明

getSettingByType

public byte[] getSettingByType(java.lang.String strSessionID,
                               java.lang.String strSettingType)
                        throws TemplateRemoteException
从接口 ITemplateService 复制的描述
获取指定类型的配置信息

指定者：
接口 ITemplateService 中的 getSettingByType
参数：
strSessionID - String 用户登录后管理端分配的SessionID
返回：
String 指定类型的配置信息
抛出：
TemplateRemoteException - 异常说明

confirm

public boolean confirm(java.lang.String strSessionID,
                       java.lang.String strAppName,
                       java.lang.String strPrimaryKey)
从接口 ITemplateService 复制的描述
DW客户端启用模板

指定者：
接口 ITemplateService 中的 confirm
参数：
strSessionID - String 用户登录后管理端分配的SessionID
strPrimaryKey - String 模板对应的主键
返回：
boolean 如果启用模板成功，返回true；否则，返回false

getSettingTypeList

public java.lang.String[] getSettingTypeList(java.lang.String strSessionID)
从接口 ITemplateService 复制的描述
获取模板服务器端的配置的资源信息类型的列表

指定者：
接口 ITemplateService 中的 getSettingTypeList
参数：
strSessionID - 用户登录后管理端分配的SessionID
返回：
模板服务器端的配置的资源信息类型的列表

getAllSites

public java.lang.String[] getAllSites(java.lang.String strSessionID)
从接口 ITemplateService 复制的描述
从服务器端获取所有的项目

指定者：
接口 ITemplateService 中的 getAllSites
参数：
strSessionID - 用户登录后管理端分配的SessionID
返回：
获取所有的项目

writeFile

public static java.lang.String writeFile(byte[] _pFileContent,
                                         java.lang.String _sFileExt)
                                  throws java.lang.Throwable
将文件写入到Upload目录中

参数：
_pFileContent - 文件内容
_sFileExt - 文件后缀名
返回：
包含路径的文件名
抛出：
java.lang.Throwable

writeSpecFile

public static void writeSpecFile(byte[] _pFileContent,
                                 java.lang.String _sFilePath)
                          throws java.lang.Throwable
将文件写入到Upload目录中

参数：
_pFileContent - 文件内容
_sFilePath - 文件名
抛出：
java.lang.Throwable

makeTemplateFolder

public IPublishFolder makeTemplateFolder(java.lang.String _sFormattedTempName,
                                         WebSite _oRootSite)
                                  throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.template.service.impl.TemplateServiceImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.template.service.impl.TemplateServiceImpl
的使用

没有 com.trs.template.service.impl.TemplateServiceImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ChineseFinder

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 ChineseFinder

java.lang.Object
    继承者  com.trs.tools.ChineseFinder

public class ChineseFinder
extends java.lang.Object

字段摘要
static java.util.Map | mFileEncodingMap
static java.lang.String | sDefaultEncoding
构造方法摘要
ChineseFinder()
方法摘要
static void | handleFile(java.lang.String sSrcFileName, java.lang.String sDestFileName)
static void | handleFolder(java.lang.String sSrcPath, java.lang.String sDestPath)
static void | handleFolder(java.lang.String sSrcPath, java.lang.String sDestPath, java.lang.String sFileExt)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

sDefaultEncoding

public static java.lang.String sDefaultEncoding

mFileEncodingMap

public static java.util.Map mFileEncodingMap
构造方法详细信息

ChineseFinder

public ChineseFinder()
方法详细信息

main

public static void main(java.lang.String[] args)
                 throws CMyException
抛出：
CMyException

handleFolder

public static void handleFolder(java.lang.String sSrcPath,
                                java.lang.String sDestPath)
                         throws CMyException
抛出：
CMyException

handleFolder

public static void handleFolder(java.lang.String sSrcPath,
                                java.lang.String sDestPath,
                                java.lang.String sFileExt)
                         throws CMyException
抛出：
CMyException

handleFile

public static void handleFile(java.lang.String sSrcFileName,
                              java.lang.String sDestFileName)
                       throws CMyException
抛出：
CMyException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CommonResourceBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 CommonResourceBuilder

java.lang.Object
    继承者  com.trs.tools.CommonResourceBuilder

public class CommonResourceBuilder
extends java.lang.Object

字段摘要
static java.lang.String locale
构造方法摘要
CommonResourceBuilder()
方法摘要
static void | build(java.lang.String wcmPath)
static java.lang.String | getCombineFile(java.lang.String[] arrDatas)
static java.util.ArrayList | getMapped(java.lang.String filename)
static void | main(java.lang.String[] args)
static void | outContent(java.lang.String fn, java.lang.StringBuffer out, boolean compress, boolean cur)
static void | replaceLocaleJS()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

locale

public static java.lang.String locale
构造方法详细信息

CommonResourceBuilder

public CommonResourceBuilder()
方法详细信息

outContent

public static void outContent(java.lang.String fn,
                              java.lang.StringBuffer out,
                              boolean compress,
                              boolean cur)
                       throws java.lang.Exception
抛出：
java.lang.Exception

getMapped

public static java.util.ArrayList getMapped(java.lang.String filename)

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception

replaceLocaleJS

public static void replaceLocaleJS()

build

public static void build(java.lang.String wcmPath)
                  throws java.lang.Exception
抛出：
java.lang.Exception

getCombineFile

public static java.lang.String getCombineFile(java.lang.String[] arrDatas)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Html2text

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 Html2text

java.lang.Object
    继承者  com.trs.tools.Html2text

public class Html2text
extends java.lang.Object

构造方法摘要
Html2text()
方法摘要
static java.lang.String html2text(java.lang.String html)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Html2text

public Html2text()
方法详细信息

html2text

public static java.lang.String html2text(java.lang.String html)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlCleaner

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 HtmlCleaner

java.lang.Object
    继承者  com.trs.tools.HtmlCleaner

public class HtmlCleaner
extends java.lang.Object

构造方法摘要
HtmlCleaner()
方法摘要
static java.lang.String parse(java.lang.String html)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HtmlCleaner

public HtmlCleaner()
方法详细信息

parse

public static java.lang.String parse(java.lang.String html)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LocaleChecker

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 LocaleChecker

java.lang.Object
    继承者  com.trs.tools.LocaleChecker

public class LocaleChecker
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
LocaleChecker()
方法摘要
static boolean | check(java.io.File f)
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LocaleChecker

public LocaleChecker()
方法详细信息

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception

check

public static boolean check(java.io.File f)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LocaleTools

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 LocaleTools

java.lang.Object
    继承者  com.trs.tools.LocaleTools

public class LocaleTools
extends java.lang.Object

构造方法摘要
LocaleTools()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LocaleTools

public LocaleTools()
方法详细信息

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Localizer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 Localizer

java.lang.Object
    继承者  com.trs.tools.Localizer

public class Localizer
extends java.lang.Object

构造方法摘要
Localizer(java.lang.String sRootPath, java.lang.String sLang)
方法摘要
java.lang.String[] | getToTransPaths()
void | localize()
void | localize1()
void | localizeFile(java.io.File oFile, java.lang.String _toFileName)
void | localizeNew(java.util.Date date)
void | localizeNew1(java.util.Date date)
void | localizePath(java.io.File oPath)
static void | main(java.lang.String[] args)
static void | mainTest(java.lang.String sRootPath, java.lang.String locale)
void | setToTransPaths(java.lang.String[] toTransPaths)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Localizer

public Localizer(java.lang.String sRootPath,
                 java.lang.String sLang)
方法详细信息

getToTransPaths

public java.lang.String[] getToTransPaths()

setToTransPaths

public void setToTransPaths(java.lang.String[] toTransPaths)

localize

public void localize()
              throws CMyException
抛出：
CMyException

localizeNew

public void localizeNew(java.util.Date date)
                 throws CMyException
抛出：
CMyException

localize1

public void localize1()
               throws CMyException
抛出：
CMyException

localizeNew1

public void localizeNew1(java.util.Date date)
                  throws CMyException
抛出：
CMyException

localizePath

public void localizePath(java.io.File oPath)
                  throws CMyException
抛出：
CMyException

localizeFile

public void localizeFile(java.io.File oFile,
                         java.lang.String _toFileName)
                  throws CMyException
抛出：
CMyException

mainTest

public static void mainTest(java.lang.String sRootPath,
                            java.lang.String locale)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Localizer2

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 Localizer2

java.lang.Object
    继承者  com.trs.tools.Localizer2

public class Localizer2
extends java.lang.Object

构造方法摘要
Localizer2(java.lang.String sRootPath, java.lang.String sTargetPath, java.lang.String sLang)
方法摘要
java.lang.String[] | getToTransPaths()
void | localize()
void | localize1()
void | localizeFile(java.io.File oFile, java.lang.String _toFileName)
void | localizeNew(java.util.Date date)
void | localizeNew1(java.util.Date date)
void | localizePath(java.io.File oPath)
static void | main(java.lang.String[] args)
static void | mainTest(java.lang.String sRootPath, java.lang.String sTargetPath, java.lang.String locale)
void | setToTransPaths(java.lang.String[] toTransPaths)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Localizer2

public Localizer2(java.lang.String sRootPath,
                  java.lang.String sTargetPath,
                  java.lang.String sLang)
方法详细信息

getToTransPaths

public java.lang.String[] getToTransPaths()

setToTransPaths

public void setToTransPaths(java.lang.String[] toTransPaths)

localize

public void localize()
              throws CMyException
抛出：
CMyException

localizeNew

public void localizeNew(java.util.Date date)
                 throws CMyException
抛出：
CMyException

localize1

public void localize1()
               throws CMyException
抛出：
CMyException

localizeNew1

public void localizeNew1(java.util.Date date)
                  throws CMyException
抛出：
CMyException

localizePath

public void localizePath(java.io.File oPath)
                  throws CMyException
抛出：
CMyException

localizeFile

public void localizeFile(java.io.File oFile,
                         java.lang.String _toFileName)
                  throws CMyException
抛出：
CMyException

mainTest

public static void mainTest(java.lang.String sRootPath,
                            java.lang.String sTargetPath,
                            java.lang.String locale)

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LocalServerAuto

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 LocalServerAuto

java.lang.Object
    继承者  com.trs.tools.LocalServerAuto

public class LocalServerAuto
extends java.lang.Object

构造方法摘要
LocalServerAuto(java.lang.String sRootPath, java.lang.String sLang)
方法摘要
void | analyze()
void | analyzeFile(java.io.File oFile)
void | analyzePath(java.io.File oPath)
java.lang.String[] | getToTransPaths()
static void | main(java.lang.String[] args)
void | setToTransPaths(java.lang.String[] toTransPaths)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LocalServerAuto

public LocalServerAuto(java.lang.String sRootPath,
                       java.lang.String sLang)
方法详细信息

getToTransPaths

public java.lang.String[] getToTransPaths()

setToTransPaths

public void setToTransPaths(java.lang.String[] toTransPaths)

analyze

public void analyze()
             throws CMyException
抛出：
CMyException

analyzePath

public void analyzePath(java.io.File oPath)
                 throws CMyException,
                        java.io.IOException
抛出：
CMyException
java.io.IOException

analyzeFile

public void analyzeFile(java.io.File oFile)
                 throws CMyException,
                        java.io.IOException
抛出：
CMyException
java.io.IOException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 MediaBuilder

java.lang.Object
    继承者  com.trs.tools.MediaBuilder

public class MediaBuilder
extends java.lang.Object

构造方法摘要
MediaBuilder()
方法摘要
static void | main(java.lang.String[] args)
static void | processJavaScript()
static void | processProperties()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MediaBuilder

public MediaBuilder()
方法详细信息

processJavaScript

public static void processJavaScript()
                              throws java.lang.Exception
抛出：
java.lang.Exception

processProperties

public static void processProperties()
                              throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.tools
类
ChineseFinder
CommonResourceBuilder
Html2text
HtmlCleaner
LocaleChecker
LocaleTools
Localizer
Localizer2
LocalServerAuto
MediaBuilder
ResourceAnalyzer
SQLBuilder
SymbolC2E
TablesCleaner
WCM61AutoList


com.trs.tools

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.tools

类摘要
ChineseFinder |
CommonResourceBuilder |
Html2text |
HtmlCleaner |
LocaleChecker | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
LocaleTools |
Localizer |
Localizer2 |
LocalServerAuto |
MediaBuilder |
ResourceAnalyzer |
SQLBuilder |
SymbolC2E |
TablesCleaner |
WCM61AutoList |


com.trs.tools 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.tools 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.tools.ChineseFinder
    • com.trs.tools.CommonResourceBuilder
    • com.trs.tools.Html2text
    • com.trs.tools.HtmlCleaner
    • com.trs.tools.LocaleChecker
    • com.trs.tools.LocaleTools
    • com.trs.tools.Localizer
    • com.trs.tools.Localizer2
    • com.trs.tools.LocalServerAuto
    • com.trs.tools.MediaBuilder
    • com.trs.tools.ResourceAnalyzer
    • com.trs.tools.SQLBuilder
    • com.trs.tools.SymbolC2E
    • com.trs.tools.TablesCleaner
    • com.trs.tools.WCM61AutoList


软件包 com.trs.tools 的使用

上一个 下一个 框架 无框架

软件包 com.trs.tools
的使用

没有 com.trs.tools 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ResourceAnalyzer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 ResourceAnalyzer

java.lang.Object
    继承者  com.trs.tools.ResourceAnalyzer

public class ResourceAnalyzer
extends java.lang.Object

字段摘要
static java.lang.String locale
构造方法摘要
ResourceAnalyzer()
方法摘要
static void | analyzer(java.lang.String[] args)
static void | analyzerFile(java.lang.String sFileName)
static void | analyzerFolder(java.lang.String sAbsFilePath)
static void | main(java.lang.String[] args)
static void | setRuntimePath(java.lang.String runtimePath)
static void | setSrcPath(java.lang.String srcPath)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

locale

public static java.lang.String locale
构造方法详细信息

ResourceAnalyzer

public ResourceAnalyzer()
方法详细信息

setSrcPath

public static void setSrcPath(java.lang.String srcPath)

setRuntimePath

public static void setRuntimePath(java.lang.String runtimePath)

analyzer

public static void analyzer(java.lang.String[] args)
                     throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception

analyzerFolder

public static void analyzerFolder(java.lang.String sAbsFilePath)
                           throws java.lang.Exception
抛出：
java.lang.Exception

analyzerFile

public static void analyzerFile(java.lang.String sFileName)
                         throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLBuilder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 SQLBuilder

java.lang.Object
    继承者  com.trs.tools.SQLBuilder

public class SQLBuilder
extends java.lang.Object

构造方法摘要
SQLBuilder()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SQLBuilder

public SQLBuilder()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SymbolC2E

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 SymbolC2E

java.lang.Object
    继承者  com.trs.tools.SymbolC2E

public class SymbolC2E
extends java.lang.Object

字段摘要
static java.util.regex.Pattern | normalPattern
static java.util.regex.Pattern | pagePattern
static char[][] | pageSymbols
static java.util.regex.Pattern | resourcePattern
static char[][] | resourceSymbols
static java.util.regex.Pattern | runtimePattern
static char[][] | runtimeSymbols
构造方法摘要
SymbolC2E()
方法摘要
static boolean | isExcludeDir(java.lang.String sDir)
static boolean | isExcludeFile(java.lang.String sFileName)
static void | main(java.lang.String[] args)
static char | replace(char cnChar)
static java.lang.String | replace(java.lang.String cnStr)
static void | replaceDir(java.lang.String sSourceDir, java.lang.String sDestDir)
static void | replaceFile(java.lang.String sSourceFile, java.lang.String sDestFile)
static void | replacePages(java.lang.String sSrcRootPath, java.lang.String sDestRootPath)
static void | replaceResources(java.lang.String sSrcRootPath, java.lang.String sDestRootPath)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

resourceSymbols

public static char[][] resourceSymbols

pageSymbols

public static char[][] pageSymbols

runtimeSymbols

public static char[][] runtimeSymbols

normalPattern

public static java.util.regex.Pattern normalPattern

resourcePattern

public static java.util.regex.Pattern resourcePattern

pagePattern

public static java.util.regex.Pattern pagePattern

runtimePattern

public static java.util.regex.Pattern runtimePattern
构造方法详细信息

SymbolC2E

public SymbolC2E()
方法详细信息

replace

public static char replace(char cnChar)

replace

public static java.lang.String replace(java.lang.String cnStr)

isExcludeDir

public static boolean isExcludeDir(java.lang.String sDir)

replaceDir

public static void replaceDir(java.lang.String sSourceDir,
                              java.lang.String sDestDir)
                       throws java.lang.Exception
抛出：
java.lang.Exception

isExcludeFile

public static boolean isExcludeFile(java.lang.String sFileName)

replaceFile

public static void replaceFile(java.lang.String sSourceFile,
                               java.lang.String sDestFile)
                        throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception

replaceResources

public static void replaceResources(java.lang.String sSrcRootPath,
                                    java.lang.String sDestRootPath)
                             throws java.lang.Exception
抛出：
java.lang.Exception

replacePages

public static void replacePages(java.lang.String sSrcRootPath,
                                java.lang.String sDestRootPath)
                         throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TablesCleaner

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 TablesCleaner

java.lang.Object
    继承者  com.trs.tools.TablesCleaner

public class TablesCleaner
extends java.lang.Object

构造方法摘要
TablesCleaner()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TablesCleaner

public TablesCleaner()
方法详细信息

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCM61AutoList

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.tools
类 WCM61AutoList

java.lang.Object
    继承者  com.trs.tools.WCM61AutoList

public class WCM61AutoList
extends java.lang.Object

构造方法摘要
WCM61AutoList(java.lang.String _sRootPath)
方法摘要
static boolean | copyFile(java.lang.String _sSrcFile, java.lang.String _sDstFile)
void | doOpersJs()
void | doQueryJsp()
void | loadConfig()
static java.util.HashMap | loadProps(java.lang.String _sFileName, java.lang.String _sEncoding)
static void | main(java.lang.String[] args)
void | makeNewFiles()
static java.lang.String | readFile(java.lang.String _sFileName, java.lang.String _sEncoding)
void | replaceStrs()
static boolean | writeFile(java.lang.String _sFileName, java.lang.String _sFileContent, java.lang.String sFileEncoding)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCM61AutoList

public WCM61AutoList(java.lang.String _sRootPath)
方法详细信息

loadConfig

public void loadConfig()

main

public static void main(java.lang.String[] args)

makeNewFiles

public void makeNewFiles()

doOpersJs

public void doOpersJs()

doQueryJsp

public void doQueryJsp()

replaceStrs

public void replaceStrs()

copyFile

public static boolean copyFile(java.lang.String _sSrcFile,
                               java.lang.String _sDstFile)

readFile

public static java.lang.String readFile(java.lang.String _sFileName,
                                        java.lang.String _sEncoding)
                                 throws java.lang.Exception
抛出：
java.lang.Exception

writeFile

public static boolean writeFile(java.lang.String _sFileName,
                                java.lang.String _sFileContent,
                                java.lang.String sFileEncoding)
                         throws java.lang.Exception
抛出：
java.lang.Exception

loadProps

public static java.util.HashMap loadProps(java.lang.String _sFileName,
                                          java.lang.String _sEncoding)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.tools.ChineseFinder 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.ChineseFinder
的使用

没有 com.trs.tools.ChineseFinder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.CommonResourceBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.CommonResourceBuilder
的使用

没有 com.trs.tools.CommonResourceBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.Html2text 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.Html2text
的使用

没有 com.trs.tools.Html2text 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.HtmlCleaner 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.HtmlCleaner
的使用

没有 com.trs.tools.HtmlCleaner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.LocaleChecker 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.LocaleChecker
的使用

没有 com.trs.tools.LocaleChecker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.LocaleTools 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.LocaleTools
的使用

没有 com.trs.tools.LocaleTools 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.Localizer 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.Localizer
的使用

没有 com.trs.tools.Localizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.Localizer2 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.Localizer2
的使用

没有 com.trs.tools.Localizer2 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.LocalServerAuto 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.LocalServerAuto
的使用

没有 com.trs.tools.LocalServerAuto 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.MediaBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.MediaBuilder
的使用

没有 com.trs.tools.MediaBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.ResourceAnalyzer 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.ResourceAnalyzer
的使用

没有 com.trs.tools.ResourceAnalyzer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.SQLBuilder 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.SQLBuilder
的使用

没有 com.trs.tools.SQLBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.SymbolC2E 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.SymbolC2E
的使用

没有 com.trs.tools.SymbolC2E 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.TablesCleaner 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.TablesCleaner
的使用

没有 com.trs.tools.TablesCleaner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.tools.WCM61AutoList 的使用

上一个 下一个 框架 无框架

类 com.trs.tools.WCM61AutoList
的使用

没有 com.trs.tools.WCM61AutoList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.upgrade
类
UpgradeObjectMember4SiteMember


com.trs.upgrade

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.upgrade

类摘要
UpgradeObjectMember4SiteMember


com.trs.upgrade 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.upgrade 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.upgrade.UpgradeObjectMember4SiteMember


软件包 com.trs.upgrade 的使用

上一个 下一个 框架 无框架

软件包 com.trs.upgrade
的使用

没有 com.trs.upgrade 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


UpgradeObjectMember4SiteMember

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.upgrade
类 UpgradeObjectMember4SiteMember

java.lang.Object
    继承者  com.trs.upgrade.UpgradeObjectMember4SiteMember

public class UpgradeObjectMember4SiteMember
extends java.lang.Object

构造方法摘要
UpgradeObjectMember4SiteMember()
方法摘要
 java.lang.String execute()
将系统中的站点成员（用户、组织或角色）转换成对象的访问控制; 因为对于wcm60，如果是站点成员，那么对该站点可以访问， 所以在wcm65中，需要将其转换成可访问
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UpgradeObjectMember4SiteMember

public UpgradeObjectMember4SiteMember()
方法详细信息

execute

public java.lang.String execute()
                         throws WCMException
将系统中的站点成员（用户、组织或角色）转换成对象的访问控制; 因为对于wcm60，如果是站点成员，那么对该站点可以访问， 所以在wcm65中，需要将其转换成可访问

抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.upgrade.UpgradeObjectMember4SiteMember 的使用

上一个 下一个 框架 无框架

类 com.trs.upgrade.UpgradeObjectMember4SiteMember
的使用

没有 com.trs.upgrade.UpgradeObjectMember4SiteMember 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DataOfV6To52

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.util
类 DataOfV6To52

java.lang.Object
    继承者  com.trs.util.DataOfV6To52

public class DataOfV6To52
extends java.lang.Object

构造方法摘要
DataOfV6To52()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataOfV6To52

public DataOfV6To52()
方法详细信息

main

public static void main(java.lang.String[] args)
                 throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.util
类
DataOfV6To52
ResetClassInfoOfViewData


com.trs.util

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.util

类摘要
DataOfV6To52
ResetClassInfoOfViewData


com.trs.util 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.util.DataOfV6To52
    • com.trs.util.ResetClassInfoOfViewData


软件包 com.trs.util 的使用

上一个 下一个 框架 无框架

软件包 com.trs.util
的使用

没有 com.trs.util 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ResetClassInfoOfViewData

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.util
类 ResetClassInfoOfViewData

java.lang.Object
    继承者  com.trs.util.ResetClassInfoOfViewData

public class ResetClassInfoOfViewData
extends java.lang.Object

字段摘要
int[] | aClassInfoRootId
java.lang.String[] | aFieldInfo
int | nCountForEach
int | nCurrIndex
int | nRecordTotalCount
构造方法摘要
ResetClassInfoOfViewData()
方法摘要
void | execute()
int | getCountOfViewDatas()
void | handleViewDatas()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

aFieldInfo

public java.lang.String[] aFieldInfo

aClassInfoRootId

public int[] aClassInfoRootId

nRecordTotalCount

public int nRecordTotalCount

nCurrIndex

public int nCurrIndex

nCountForEach

public int nCountForEach
构造方法详细信息

ResetClassInfoOfViewData

public ResetClassInfoOfViewData()
方法详细信息

execute

public void execute()
             throws WCMException
抛出：
WCMException

getCountOfViewDatas

public int getCountOfViewDatas()
                        throws WCMException
抛出：
WCMException

handleViewDatas

public void handleViewDatas()
                     throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.util.DataOfV6To52 的使用

上一个 下一个 框架 无框架

类 com.trs.util.DataOfV6To52
的使用

没有 com.trs.util.DataOfV6To52 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.util.ResetClassInfoOfViewData 的使用

上一个 下一个 框架 无框架

类 com.trs.util.ResetClassInfoOfViewData
的使用

没有 com.trs.util.ResetClassInfoOfViewData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Alertion

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2
类 Alertion

java.lang.Object
    继承者  com.trs.wcag2.Alertion

public class Alertion
extends java.lang.Object

字段摘要
static java.lang.String | FAIL
static java.lang.String | WARN
构造方法摘要
Alertion()
方法摘要
java.lang.String | getExample()
java.lang.String | getHTML()
java.lang.String | getKlass()
java.lang.String | getLevel()
int | getNum()
java.util.List | getRst()
java.lang.String | getWarning()
void | setExample(java.lang.String example)
void | setHTML(java.lang.String html)
void | setKlass(java.lang.String klass)
void | setLevel(java.lang.String level)
void | setNum(int i)
void | setRst(java.util.List rst)
void | setWarning(java.lang.String warning)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

FAIL

public static final java.lang.String FAIL

WARN

public static final java.lang.String WARN
构造方法详细信息

Alertion

public Alertion()
方法详细信息

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getKlass

public java.lang.String getKlass()

setKlass

public void setKlass(java.lang.String klass)

getWarning

public java.lang.String getWarning()

setWarning

public void setWarning(java.lang.String warning)

getHTML

public java.lang.String getHTML()

setHTML

public void setHTML(java.lang.String html)

getLevel

public java.lang.String getLevel()

setLevel

public void setLevel(java.lang.String level)

setExample

public void setExample(java.lang.String example)

setNum

public void setNum(int i)

getNum

public int getNum()

getRst

public java.util.List getRst()

setRst

public void setRst(java.util.List rst)

getExample

public java.lang.String getExample()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


HTMLUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2
类 HTMLUtil

java.lang.Object
    继承者  com.trs.wcag2.HTMLUtil

public class HTMLUtil
extends java.lang.Object

构造方法摘要
HTMLUtil()
方法摘要
static java.util.List | findTagOuterHTML(java.lang.String html, java.lang.String eleName)
static java.util.List | findTagStartHTML(java.lang.String html, java.lang.String eleName)
static java.lang.String | getEleAttrs(java.lang.String html, int[] pos, java.lang.String eleName)
static java.lang.String | getEleAttrs(java.lang.String html, java.lang.String eleName)
static java.lang.String | getEleInnerHTML(java.lang.String html, int[] pos)
static java.lang.String | getEleOuterHTML(java.lang.String html, int[] pos)
static int[] | getPosition(java.lang.String sHeader)
static boolean | isEmptyTag(java.lang.String eleName)
static void | main(java.lang.String[] args)
static java.util.HashMap | makeHsAttrs(java.lang.String attrs)
static java.lang.String | removeTags(java.lang.String html, java.lang.String eleName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLUtil

public HTMLUtil()
方法详细信息

main

public static void main(java.lang.String[] args)

getEleAttrs

public static java.lang.String getEleAttrs(java.lang.String html,
                                           int[] pos,
                                           java.lang.String eleName)

getEleOuterHTML

public static java.lang.String getEleOuterHTML(java.lang.String html,
                                               int[] pos)

getEleInnerHTML

public static java.lang.String getEleInnerHTML(java.lang.String html,
                                               int[] pos)

getPosition

public static int[] getPosition(java.lang.String sHeader)

getEleAttrs

public static java.lang.String getEleAttrs(java.lang.String html,
                                           java.lang.String eleName)

findTagStartHTML

public static java.util.List findTagStartHTML(java.lang.String html,
                                              java.lang.String eleName)

makeHsAttrs

public static java.util.HashMap makeHsAttrs(java.lang.String attrs)

isEmptyTag

public static boolean isEmptyTag(java.lang.String eleName)

findTagOuterHTML

public static java.util.List findTagOuterHTML(java.lang.String html,
                                              java.lang.String eleName)

removeTags

public static java.lang.String removeTags(java.lang.String html,
                                          java.lang.String eleName)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.wcag2
类
Alertion
HTMLUtil
WCAG2Helper


com.trs.wcag2

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcag2

类摘要
Alertion
HTMLUtil
WCAG2Helper


com.trs.wcag2 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcag2 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.wcag2.Alertion
    • com.trs.wcag2.HTMLUtil
    • com.trs.wcag2.WCAG2Helper


软件包 com.trs.wcag2 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcag2
的使用

没有 com.trs.wcag2 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCAG2Helper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2
类 WCAG2Helper

java.lang.Object
    继承者  com.trs.wcag2.WCAG2Helper

public class WCAG2Helper
extends java.lang.Object

构造方法摘要
WCAG2Helper()
方法摘要
static java.lang.Object | doValid(java.lang.String content)
static void | main(java.lang.String[] args)
static void | registerValidator(IValidator o)
static java.lang.String | toHTML(java.util.List alertions)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCAG2Helper

public WCAG2Helper()
方法详细信息

registerValidator

public static void registerValidator(IValidator o)

doValid

public static java.lang.Object doValid(java.lang.String content)

main

public static void main(java.lang.String[] args)

toHTML

public static java.lang.String toHTML(java.util.List alertions)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.wcag2.Alertion 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.Alertion
的使用

没有 com.trs.wcag2.Alertion 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.HTMLUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.HTMLUtil
的使用

没有 com.trs.wcag2.HTMLUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.WCAG2Helper 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.WCAG2Helper
的使用

没有 com.trs.wcag2.WCAG2Helper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AbstractValidator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 AbstractValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
所有已实现的接口：
IValidator
直接已知子类：
BiTagValidator, DocTypeValidator, EmbedAltValidator, EventsValidator, FormElementsValidator, FormSubmitValidator, FrameTitleValidator, HtmlCharsetValidator, HtmlH1_H6Validator, HtmlH1Validator, HtmlLangValidator, HtmlTitleValidator, ImgAltValidator, ObjectBodyValidator
public abstract class AbstractValidator
extends java.lang.Object
implements IValidator

构造方法摘要
AbstractValidator()
方法摘要
java.lang.String | getExample(java.lang.Object o)
abstract java.lang.Object | getExampleObj()
java.lang.String | getWarning(java.lang.Object o)
abstract java.lang.Object | getWarnObj()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.wcag2.validator.IValidator 继承的方法
doValid, getType

构造方法详细信息

AbstractValidator

public AbstractValidator()
方法详细信息

getWarnObj

public abstract java.lang.Object getWarnObj()

getWarning

public java.lang.String getWarning(java.lang.Object o)
指定者：
接口 IValidator 中的 getWarning

getExampleObj

public abstract java.lang.Object getExampleObj()

getExample

public java.lang.String getExample(java.lang.Object o)
指定者：
接口 IValidator 中的 getExample
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BiTagValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 BiTagValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.BiTagValidator
所有已实现的接口：
IValidator
public class BiTagValidator
extends AbstractValidator

构造方法摘要
BiTagValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BiTagValidator

public BiTagValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocTypeValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 DocTypeValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.DocTypeValidator
所有已实现的接口：
IValidator
public class DocTypeValidator
extends AbstractValidator

构造方法摘要
DocTypeValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocTypeValidator

public DocTypeValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EmbedAltValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 EmbedAltValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.EmbedAltValidator
所有已实现的接口：
IValidator
public class EmbedAltValidator
extends AbstractValidator

构造方法摘要
EmbedAltValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EmbedAltValidator

public EmbedAltValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventsValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 EventsValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.EventsValidator
所有已实现的接口：
IValidator
public class EventsValidator
extends AbstractValidator

构造方法摘要
EventsValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.String | getExample(java.lang.Object o)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.String | getWarning(java.lang.Object o)
java.lang.Object | getWarnObj()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventsValidator

public EventsValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getWarning

public java.lang.String getWarning(java.lang.Object o)
指定者：
接口 IValidator 中的 getWarning
覆盖：
类 AbstractValidator 中的 getWarning

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj

getExample

public java.lang.String getExample(java.lang.Object o)
指定者：
接口 IValidator 中的 getExample
覆盖：
类 AbstractValidator 中的 getExample
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FormElementsValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 FormElementsValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.FormElementsValidator
所有已实现的接口：
IValidator
public class FormElementsValidator
extends AbstractValidator

构造方法摘要
FormElementsValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FormElementsValidator

public FormElementsValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FormSubmitValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 FormSubmitValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.FormSubmitValidator
所有已实现的接口：
IValidator
public class FormSubmitValidator
extends AbstractValidator

构造方法摘要
FormSubmitValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FormSubmitValidator

public FormSubmitValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FrameTitleValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 FrameTitleValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.FrameTitleValidator
所有已实现的接口：
IValidator
public class FrameTitleValidator
extends AbstractValidator

构造方法摘要
FrameTitleValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FrameTitleValidator

public FrameTitleValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlCharsetValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 HtmlCharsetValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.HtmlCharsetValidator
所有已实现的接口：
IValidator
public class HtmlCharsetValidator
extends AbstractValidator

构造方法摘要
HtmlCharsetValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HtmlCharsetValidator

public HtmlCharsetValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlH1_H6Validator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 HtmlH1_H6Validator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.HtmlH1_H6Validator
所有已实现的接口：
IValidator
public class HtmlH1_H6Validator
extends AbstractValidator

构造方法摘要
HtmlH1_H6Validator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HtmlH1_H6Validator

public HtmlH1_H6Validator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlH1Validator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 HtmlH1Validator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.HtmlH1Validator
所有已实现的接口：
IValidator
public class HtmlH1Validator
extends AbstractValidator

构造方法摘要
HtmlH1Validator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.String | getExample(java.lang.Object o)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.String | getWarning(java.lang.Object o)
java.lang.Object | getWarnObj()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HtmlH1Validator

public HtmlH1Validator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getWarning

public java.lang.String getWarning(java.lang.Object o)
指定者：
接口 IValidator 中的 getWarning
覆盖：
类 AbstractValidator 中的 getWarning

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj

getExample

public java.lang.String getExample(java.lang.Object o)
指定者：
接口 IValidator 中的 getExample
覆盖：
类 AbstractValidator 中的 getExample
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlLangValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 HtmlLangValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.HtmlLangValidator
所有已实现的接口：
IValidator
public class HtmlLangValidator
extends AbstractValidator

构造方法摘要
HtmlLangValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HtmlLangValidator

public HtmlLangValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HtmlTitleValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 HtmlTitleValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.HtmlTitleValidator
所有已实现的接口：
IValidator
public class HtmlTitleValidator
extends AbstractValidator

构造方法摘要
HtmlTitleValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HtmlTitleValidator

public HtmlTitleValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImgAltValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 ImgAltValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.ImgAltValidator
所有已实现的接口：
IValidator
public class ImgAltValidator
extends AbstractValidator

构造方法摘要
ImgAltValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.String | getExample(java.lang.Object o)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.String | getWarning(java.lang.Object o)
java.lang.Object | getWarnObj()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImgAltValidator

public ImgAltValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getWarning

public java.lang.String getWarning(java.lang.Object o)
指定者：
接口 IValidator 中的 getWarning
覆盖：
类 AbstractValidator 中的 getWarning

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj

getExample

public java.lang.String getExample(java.lang.Object o)
指定者：
接口 IValidator 中的 getExample
覆盖：
类 AbstractValidator 中的 getExample
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
接口 IValidator

所有已知实现类：
AbstractValidator, BiTagValidator, DocTypeValidator, EmbedAltValidator, EventsValidator, FormElementsValidator, FormSubmitValidator, FrameTitleValidator, HtmlCharsetValidator, HtmlH1_H6Validator, HtmlH1Validator, HtmlLangValidator, HtmlTitleValidator, ImgAltValidator, ObjectBodyValidator
public interface IValidator

方法摘要
java.lang.Object | doValid(java.lang.String sContent, java.util.HashMap known)
java.lang.String | getExample(java.lang.Object o)
java.lang.String | getType()
java.lang.String | getWarning(java.lang.Object o)

方法详细信息

getType

java.lang.String getType()

getWarning

java.lang.String getWarning(java.lang.Object o)

doValid

java.lang.Object doValid(java.lang.String sContent,
                         java.util.HashMap known)

getExample

java.lang.String getExample(java.lang.Object o)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectBodyValidator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcag2.validator
类 ObjectBodyValidator

java.lang.Object
    继承者  com.trs.wcag2.validator.AbstractValidator
        继承者  com.trs.wcag2.validator.ObjectBodyValidator
所有已实现的接口：
IValidator
public class ObjectBodyValidator
extends AbstractValidator

构造方法摘要
ObjectBodyValidator()
方法摘要
java.lang.Object | doValid(java.lang.String content, java.util.HashMap known)
java.lang.Object | getExampleObj()
java.lang.String | getType()
java.lang.Object | getWarnObj()
从类 com.trs.wcag2.validator.AbstractValidator 继承的方法
getExample, getWarning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectBodyValidator

public ObjectBodyValidator()
方法详细信息

doValid

public java.lang.Object doValid(java.lang.String content,
                                java.util.HashMap known)

getWarnObj

public java.lang.Object getWarnObj()
指定者：
类 AbstractValidator 中的 getWarnObj

getType

public java.lang.String getType()

getExampleObj

public java.lang.Object getExampleObj()
指定者：
类 AbstractValidator 中的 getExampleObj
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.wcag2.validator
接口
IValidator
类
AbstractValidator
BiTagValidator
DocTypeValidator
EmbedAltValidator
EventsValidator
FormElementsValidator
FormSubmitValidator
FrameTitleValidator
HtmlCharsetValidator
HtmlH1_H6Validator
HtmlH1Validator
HtmlLangValidator
HtmlTitleValidator
ImgAltValidator
ObjectBodyValidator


com.trs.wcag2.validator

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcag2.validator

接口摘要
IValidator

类摘要
AbstractValidator
BiTagValidator
DocTypeValidator
EmbedAltValidator
EventsValidator
FormElementsValidator
FormSubmitValidator
FrameTitleValidator
HtmlCharsetValidator
HtmlH1_H6Validator
HtmlH1Validator
HtmlLangValidator
HtmlTitleValidator
ImgAltValidator
ObjectBodyValidator


com.trs.wcag2.validator 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcag2.validator 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.wcag2.validator.AbstractValidator (implements com.trs.wcag2.validator.IValidator)
      • com.trs.wcag2.validator.BiTagValidator
      • com.trs.wcag2.validator.DocTypeValidator
      • com.trs.wcag2.validator.EmbedAltValidator
      • com.trs.wcag2.validator.EventsValidator
      • com.trs.wcag2.validator.FormElementsValidator
      • com.trs.wcag2.validator.FormSubmitValidator
      • com.trs.wcag2.validator.FrameTitleValidator
      • com.trs.wcag2.validator.HtmlCharsetValidator
      • com.trs.wcag2.validator.HtmlH1_H6Validator
      • com.trs.wcag2.validator.HtmlH1Validator
      • com.trs.wcag2.validator.HtmlLangValidator
      • com.trs.wcag2.validator.HtmlTitleValidator
      • com.trs.wcag2.validator.ImgAltValidator
      • com.trs.wcag2.validator.ObjectBodyValidator

接口分层结构

  • com.trs.wcag2.validator.IValidator


软件包 com.trs.wcag2.validator 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcag2.validator
的使用

使用 com.trs.wcag2.validator 的软件包
com.trs.wcag2
com.trs.wcag2.validator

com.trs.wcag2 使用的 com.trs.wcag2.validator 中的类
IValidator

com.trs.wcag2.validator 使用的 com.trs.wcag2.validator 中的类
AbstractValidator
IValidator

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.AbstractValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.AbstractValidator
的使用

使用 AbstractValidator 的软件包
com.trs.wcag2.validator

com.trs.wcag2.validator 中 AbstractValidator 的使用

com.trs.wcag2.validator 中 AbstractValidator 的子类
class | BiTagValidator
class | DocTypeValidator
class | EmbedAltValidator
class | EventsValidator
class | FormElementsValidator
class | FormSubmitValidator
class | FrameTitleValidator
class | HtmlCharsetValidator
class | HtmlH1_H6Validator
class | HtmlH1Validator
class | HtmlLangValidator
class | HtmlTitleValidator
class | ImgAltValidator
class | ObjectBodyValidator

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.BiTagValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.BiTagValidator
的使用

没有 com.trs.wcag2.validator.BiTagValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.DocTypeValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.DocTypeValidator
的使用

没有 com.trs.wcag2.validator.DocTypeValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.EmbedAltValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.EmbedAltValidator
的使用

没有 com.trs.wcag2.validator.EmbedAltValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.EventsValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.EventsValidator
的使用

没有 com.trs.wcag2.validator.EventsValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.FormElementsValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.FormElementsValidator
的使用

没有 com.trs.wcag2.validator.FormElementsValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.FormSubmitValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.FormSubmitValidator
的使用

没有 com.trs.wcag2.validator.FormSubmitValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.FrameTitleValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.FrameTitleValidator
的使用

没有 com.trs.wcag2.validator.FrameTitleValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.HtmlCharsetValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.HtmlCharsetValidator
的使用

没有 com.trs.wcag2.validator.HtmlCharsetValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.HtmlH1_H6Validator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.HtmlH1_H6Validator
的使用

没有 com.trs.wcag2.validator.HtmlH1_H6Validator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.HtmlH1Validator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.HtmlH1Validator
的使用

没有 com.trs.wcag2.validator.HtmlH1Validator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.HtmlLangValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.HtmlLangValidator
的使用

没有 com.trs.wcag2.validator.HtmlLangValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.HtmlTitleValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.HtmlTitleValidator
的使用

没有 com.trs.wcag2.validator.HtmlTitleValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.ImgAltValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.ImgAltValidator
的使用

没有 com.trs.wcag2.validator.ImgAltValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.wcag2.validator.IValidator 的使用

上一个 下一个 框架 无框架

接口 com.trs.wcag2.validator.IValidator
的使用

使用 IValidator 的软件包
com.trs.wcag2
com.trs.wcag2.validator

com.trs.wcag2 中 IValidator 的使用

参数类型为 IValidator 的 com.trs.wcag2 中的方法
static void WCAG2Helper.registerValidator(IValidator o)

com.trs.wcag2.validator 中 IValidator 的使用

实现 IValidator 的 com.trs.wcag2.validator 中的类
class | AbstractValidator
class | BiTagValidator
class | DocTypeValidator
class | EmbedAltValidator
class | EventsValidator
class | FormElementsValidator
class | FormSubmitValidator
class | FrameTitleValidator
class | HtmlCharsetValidator
class | HtmlH1_H6Validator
class | HtmlH1Validator
class | HtmlLangValidator
class | HtmlTitleValidator
class | ImgAltValidator
class | ObjectBodyValidator

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcag2.validator.ObjectBodyValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcag2.validator.ObjectBodyValidator
的使用

没有 com.trs.wcag2.validator.ObjectBodyValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.wcm.config
类
PageOperator
PageOperators


com.trs.wcm.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcm.config

类摘要
PageOperator
PageOperators


com.trs.wcm.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcm.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.wcm.config.PageOperator
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.wcm.config.PageOperators


软件包 com.trs.wcm.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcm.config
的使用

使用 com.trs.wcm.config 的软件包
com.trs.ajaxservice
com.trs.wcm.config
com.trs.wcm.customize

com.trs.ajaxservice 使用的 com.trs.wcm.config 中的类
PageOperators

com.trs.wcm.config 使用的 com.trs.wcm.config 中的类
PageOperator
PageOperators

com.trs.wcm.customize 使用的 com.trs.wcm.config 中的类
PageOperators

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PageOperator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.config
类 PageOperator

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.wcm.config.PageOperator
所有已实现的接口：
java.lang.Cloneable
public class PageOperator
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
PageOperator()
构造函数：保留默认接口
方法摘要
static PageOperator | createNewInstance() 产生当前对象[PageOperator]的实例
static PageOperator | findById(int _nId) 提取指定ID的对象
static PageOperator | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 提取属性：Desc
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getIsDisplay() 提取属性：IsDisplay
java.lang.String | getName() 提取属性：Name
java.lang.String | getOprKey() 提取属性：OprKey
int | getOrder() 提取属性：Order
int | getRightIndex() 提取属性：Order
java.lang.String | getType() 提取属性：Type
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setDesc(java.lang.String _sDesc) 设置属性：Desc
boolean | setIsDisplay(int _nIsDisplay) 设置属性：IsDisplay
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setOprKey(java.lang.String _sOprKey) 设置属性：OprKey
boolean | setOrder(int _nOrder) 设置属性：Order
boolean | setRightIndex(int _nRightIndex) 设置属性：Order
boolean | setType(java.lang.String _sType) 设置属性：Type
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

PageOperator

public PageOperator()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
_sName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOprKey

public java.lang.String getOprKey()
提取属性：OprKey

返回：
OprKey

setOprKey

public boolean setOprKey(java.lang.String _sOprKey)
                  throws WCMException
设置属性：OprKey

参数：
_sOprKey - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
提取属性：Desc

返回：
Desc

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置属性：Desc

参数：
_sDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getType

public java.lang.String getType()
提取属性：Type

返回：
Type

setType

public boolean setType(java.lang.String _sType)
                throws WCMException
设置属性：Type

参数：
_sType - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getIsDisplay

public int getIsDisplay()
提取属性：IsDisplay

返回：
IsDisplay

setIsDisplay

public boolean setIsDisplay(int _nIsDisplay)
                     throws WCMException
设置属性：IsDisplay

参数：
_nIsDisplay - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getRightIndex

public int getRightIndex()
提取属性：Order

返回：
Order

setRightIndex

public boolean setRightIndex(int _nRightIndex)
                      throws WCMException
设置属性：Order

参数：
_nOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getOrder

public int getOrder()
提取属性：Order

返回：
Order

setOrder

public boolean setOrder(int _nOrder)
                 throws WCMException
设置属性：Order

参数：
_nOrder - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final PageOperator findById(int _nId)
                                   throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final PageOperator createNewInstance()
                                            throws WCMException
产生当前对象[PageOperator]的实例

返回：
当前对象的实例[PageOperator]
抛出：
WCMException

findByKey

public static final PageOperator findByKey(java.lang.Object _oKey)
                                    throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


PageOperators

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.config
类 PageOperators

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.wcm.config.PageOperators

public class PageOperators
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
PageOperators(User _currUser)
构造函数
PageOperators(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static PageOperators | createNewInstance(User _currUser) 产生当前集合对象[PageOperators]的实例
static PageOperators | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static PageOperators | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PageOperators]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PageOperators

public PageOperators(User _currUser)
构造函数

另请参见：
PageOperators( User _currUser, int _initCapacity, int _incCapacity );

PageOperators

public PageOperators(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final PageOperators findByIds(User _currUser,
                                            java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（PageOperators）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final PageOperators openWCMObjs(User _currUser,
                                              WCMFilter _filter)
                                       throws WCMException
通过指定一个Filter获取当前集合[PageOperators]

参数：
_filter - 指定的Filter
返回：
当前集合[PageOperators]
抛出：
WCMException

createNewInstance

public static PageOperators createNewInstance(User _currUser)
产生当前集合对象[PageOperators]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.wcm.config.PageOperator 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.config.PageOperator
的使用

使用 PageOperator 的软件包
com.trs.wcm.config

com.trs.wcm.config 中 PageOperator 的使用

返回 PageOperator 的 com.trs.wcm.config 中的方法
static PageOperator | PageOperator.createNewInstance() 产生当前对象[PageOperator]的实例
static PageOperator | PageOperator.findById(int _nId) 提取指定ID的对象
static PageOperator | PageOperator.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.config.PageOperators 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.config.PageOperators
的使用

使用 PageOperators 的软件包
com.trs.ajaxservice
com.trs.wcm.config
com.trs.wcm.customize

com.trs.ajaxservice 中 PageOperators 的使用

返回 PageOperators 的 com.trs.ajaxservice 中的方法
PageOperators | WebSiteServiceProvider.getDocumentOperators(MethodContext _methContext)
PageOperators | ChannelServiceProvider.getDocumentOperators(MethodContext _methContext) 获取进入当前栏目的文档列表时针对于当前栏目的操作
PageOperators | StatusServiceProvider.getOperators(MethodContext _methContext) 获取针对指定的单个或者多个状态的操作集合
PageOperators | WebSiteServiceProvider.getOperators(MethodContext _methContext)
PageOperators | ExtendFieldServiceProvider.getOperators(MethodContext _methContext) 获取扩展字段的操作
PageOperators | DocumentServiceProvider.getOperators(MethodContext _methContext)
PageOperators | SourceServiceProvider.getOperators(MethodContext _methContext) 获取针对指定的单个或者多个来源的操作集合
PageOperators | ChannelServiceProvider.getOperators(MethodContext _methContext) 获取针对指定的单个或者多个栏目的操作集合
PageOperators | TemplateServiceProvider.getOperators(MethodContext _methContext) 获取针对指定的单个或者多个模板的操作集合
PageOperators | ChannelServiceProvider.getOperatorsInChannel(MethodContext _methContext) 获取进入当前栏目的子栏目列表时针对于当前栏目的操作
PageOperators | WebSiteServiceProvider.getOperatorsInSite(MethodContext _methContext) 获取进入当前站点在进入子栏目列表时候的操作
PageOperators | WebSiteServiceProvider.getOperatorsInSiteRoot()
static PageOperators | PageOperatorsForServiceHelper.makeCMSBaseObjsOpertators(User _loginUser, java.lang.String _sObjectIds, CMSBaseObjs _objects)
static PageOperators | PageOperatorsForServiceHelper.makeCMSObjOpertators(User _loginUser, java.lang.String _sObjectKey, CMSObj channel)

com.trs.wcm.config 中 PageOperators 的使用

返回 PageOperators 的 com.trs.wcm.config 中的方法
static PageOperators | PageOperators.createNewInstance(User _currUser) 产生当前集合对象[PageOperators]的实例
static PageOperators | PageOperators.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static PageOperators | PageOperators.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[PageOperators]

com.trs.wcm.customize 中 PageOperators 的使用

返回 PageOperators 的 com.trs.wcm.customize 中的方法
PageOperators | ICustomizeMgr.getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter) 获取指定用户指定类型的操作
PageOperators | CustomizeMgrImpl.getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CustomizeMgrImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.customize
类 CustomizeMgrImpl

java.lang.Object
    继承者  com.trs.wcm.customize.CustomizeMgrImpl
所有已实现的接口：
ICustomizeMgr
public class CustomizeMgrImpl
extends java.lang.Object
implements ICustomizeMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
CustomizeMgrImpl()
方法摘要
 PageOperators getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter)
获取指定用户指定类型的操作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CustomizeMgrImpl

public CustomizeMgrImpl()
方法详细信息

getPageOpertators

public PageOperators getPageOpertators(User _user,
                                       java.lang.String _sOprType,
                                       WCMFilter _extraFilter)
                                throws WCMException
从接口 ICustomizeMgr 复制的描述
获取指定用户指定类型的操作

指定者：
接口 ICustomizeMgr 中的 getPageOpertators
参数：
_user - 指定用户
_sOprType - 指定类型的操作
_extraFilter - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ICustomizeMgr

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.customize
接口 ICustomizeMgr

所有已知实现类：
CustomizeMgrImpl
public interface ICustomizeMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
个性化设置管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 PageOperators getPageOpertators(User _user, java.lang.String _sOprType, WCMFilter _extraFilter)
获取指定用户指定类型的操作

方法详细信息

getPageOpertators

PageOperators getPageOpertators(User _user,
                                java.lang.String _sOprType,
                                WCMFilter _extraFilter)
                                throws WCMException
获取指定用户指定类型的操作

参数：
_user - 指定用户
_sOprType - 指定类型的操作
_extraFilter - TODO
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.wcm.customize
接口
ICustomizeMgr
类
CustomizeMgrImpl


com.trs.wcm.customize

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcm.customize

接口摘要
ICustomizeMgr Title: TRS 内容协作平台（TRS WCM）
Description:
个性化设置管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
CustomizeMgrImpl Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.wcm.customize 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcm.customize 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.wcm.customize.CustomizeMgrImpl (implements com.trs.wcm.customize.ICustomizeMgr)

接口分层结构

  • com.trs.wcm.customize.ICustomizeMgr


软件包 com.trs.wcm.customize 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcm.customize
的使用

使用 com.trs.wcm.customize 的软件包
com.trs.wcm.customize

com.trs.wcm.customize 使用的 com.trs.wcm.customize 中的类
ICustomizeMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
个性化设置管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.customize.CustomizeMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.customize.CustomizeMgrImpl
的使用

没有 com.trs.wcm.customize.CustomizeMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.wcm.customize.ICustomizeMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.wcm.customize.ICustomizeMgr
的使用

使用 ICustomizeMgr 的软件包
com.trs.wcm.customize

com.trs.wcm.customize 中 ICustomizeMgr 的使用

实现 ICustomizeMgr 的 com.trs.wcm.customize 中的类
 class CustomizeMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ImportDocsContext

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 ImportDocsContext

java.lang.Object
    继承者  com.trs.wcm.old.ImportDocsContext

public class ImportDocsContext
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ImportDocsContext()
方法摘要
void | addImportCount()
void | addImportCount(int _importCount) 记录导入的文档数
void | addNeedImportFile(java.lang.String _sNeedImportFile) 添加需要导入的ZIP文件
void | addUnImportCount()
void | addUnImportCount(int _unImportCount) 记录没有导入的文档数
void | clear() 清空所有的资源
void | clearCurrInfo() 清空当前相关的资源
java.lang.String | getAbsoluteAppFileName(java.lang.String _sAppFileName) 根据文件名获取附件在服务器存放的绝对地址
Channel | getCurrChannel() 返回当前栏目
java.lang.String | getCurrImportFile()
java.lang.String | getCurrTrueFileName() 当前导入的真实文件名
User | getCurrUser() 获取当前的交互用户
java.util.ArrayList | getErrorInfo()
int | getImportCount()
java.lang.String | getNeedImportFileAt(int _nIndex)
int | getNeedImportSize() 获取需要导入的文档数目
java.lang.String | getResult()
java.util.ArrayList | getSuccessInfo()
int | getUnImportCount()
boolean | isValid() 校验对象的属性是否有效
static void | main(java.lang.String[] args)
void | putAbsoluteAppFileName(java.lang.String _sAppFileName, java.lang.String _sAbsolutFileName) 设置附件名和附件地址的映射关系
void | setCurrChannel(Channel _currChannel) 设置当前栏目
void | setCurrImportFile(java.lang.String _currImportFile)
void | setCurrTrueFileName(java.lang.String _currTrueFileName) 当前导入的真实文件名
void | setCurrUser(User _currUser) 设置当前的交互用户
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImportDocsContext

public ImportDocsContext()
方法详细信息

clearCurrInfo

public void clearCurrInfo()
清空当前相关的资源

clear

public void clear()
清空所有的资源

getAbsoluteAppFileName

public java.lang.String getAbsoluteAppFileName(java.lang.String _sAppFileName)
根据文件名获取附件在服务器存放的绝对地址

返回：
如果导入的ZIP包中存在附件返回附件在服务器存放的绝对地址，否则返回null

putAbsoluteAppFileName

public void putAbsoluteAppFileName(java.lang.String _sAppFileName,
                                   java.lang.String _sAbsolutFileName)
设置附件名和附件地址的映射关系

参数：
_sAppFileName - 附件文件名
_sAbsolutFileName - 附件在服务器端存放的绝对地址

getCurrChannel

public Channel getCurrChannel()
返回当前栏目

返回：
当前栏目对象(Channel)

setCurrChannel

public void setCurrChannel(Channel _currChannel)
设置当前栏目

参数：
_currChannel - 当前栏目对象(Channel)

getCurrUser

public User getCurrUser()
获取当前的交互用户

返回：
当前的交互用户(User)

setCurrUser

public void setCurrUser(User _currUser)
设置当前的交互用户

参数：
_currUser - 当前的交互用户(User)

isValid

public boolean isValid()
校验对象的属性是否有效

返回：
校验参数的有效性

getCurrImportFile

public java.lang.String getCurrImportFile()
返回：
Returns the currImportFile.

setCurrImportFile

public void setCurrImportFile(java.lang.String _currImportFile)
参数：
_currImportFile - The currImportFile to set.

getNeedImportFileAt

public java.lang.String getNeedImportFileAt(int _nIndex)
返回：
Returns the needImportFile.

getNeedImportSize

public int getNeedImportSize()
获取需要导入的文档数目

返回：

addNeedImportFile

public void addNeedImportFile(java.lang.String _sNeedImportFile)
添加需要导入的ZIP文件

参数：
_needImportFile - The needImportFile to set.

main

public static void main(java.lang.String[] args)

getImportCount

public int getImportCount()
返回：
Returns the importCount.

addImportCount

public void addImportCount(int _importCount)
记录导入的文档数

参数：
_importCount - 导入的文档数（默认为1）

addImportCount

public void addImportCount()

getUnImportCount

public int getUnImportCount()
返回：
Returns the unImportCount.

addUnImportCount

public void addUnImportCount(int _unImportCount)
记录没有导入的文档数

参数：
_unImportCount - 导入的文档数(默认为1)

addUnImportCount

public void addUnImportCount()

getSuccessInfo

public java.util.ArrayList getSuccessInfo()
返回：
Returns the result.

getErrorInfo

public java.util.ArrayList getErrorInfo()
返回：
Returns the error.

getResult

public java.lang.String getResult()
返回：
Returns the result.

getCurrTrueFileName

public java.lang.String getCurrTrueFileName()
当前导入的真实文件名

返回：
Returns the currTrueFileName.

setCurrTrueFileName

public void setCurrTrueFileName(java.lang.String _currTrueFileName)
当前导入的真实文件名

参数：
_currTrueFileName - 当前导入的真实文件名
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ImportDocsFromFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 ImportDocsFromFile

java.lang.Object
    继承者  com.trs.wcm.old.ImportDocsFromFile
直接已知子类：
ImportDocsFromHTMLFile
public abstract class ImportDocsFromFile
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ImportDocsFromFile()
方法摘要
ImportDocsContext | getCurrContext() 返回上下文对象
abstract void | importDocs()
void | setCurrContext(ImportDocsContext _currContexxt) 设置上下文对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImportDocsFromFile

public ImportDocsFromFile()
方法详细信息

importDocs

public abstract void importDocs()
                         throws java.lang.Exception
抛出：
java.lang.Exception

getCurrContext

public ImportDocsContext getCurrContext()
返回上下文对象

返回：
导入过程中的上下文对象(ImportDocsContext)

setCurrContext

public void setCurrContext(ImportDocsContext _currContexxt)
设置上下文对象

参数：
_currContexxt - 导入过程中的上下文对象(ImportDocsContext)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImportDocsFromHTMLFile

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 ImportDocsFromHTMLFile

java.lang.Object
    继承者  com.trs.wcm.old.ImportDocsFromFile
        继承者  com.trs.wcm.old.ImportDocsFromHTMLFile

public class ImportDocsFromHTMLFile
extends ImportDocsFromFile

Created by IntelliJ IDEA. User: Administrator Date: 2004-6-2 Time: 14:30:06 To change this template use Options | File Templates.

构造方法摘要
ImportDocsFromHTMLFile()
方法摘要
boolean | importDocFromHTML()
void | importDocs()
static void | main(java.lang.String[] args)
从类 com.trs.wcm.old.ImportDocsFromFile 继承的方法
getCurrContext, setCurrContext
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImportDocsFromHTMLFile

public ImportDocsFromHTMLFile()
方法详细信息

importDocs

public void importDocs()
                throws java.lang.Exception
指定者：
类 ImportDocsFromFile 中的 importDocs
抛出：
java.lang.Exception

importDocFromHTML

public boolean importDocFromHTML()
                          throws java.lang.Exception
抛出：
java.lang.Exception

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.wcm.old
类
ImportDocsContext
ImportDocsFromFile
ImportDocsFromHTMLFile
WCMExcelData
WCMExcelDatas
WCMFormFields
WCMFormFieldses
WCMFormInfo
WCMFormInfos
WCMFormMgr


com.trs.wcm.old

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcm.old

类摘要
ImportDocsContext | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImportDocsFromFile | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImportDocsFromHTMLFile | Created by IntelliJ IDEA.
WCMExcelData | Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
WCMExcelDatas | Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
WCMFormFields |
WCMFormFieldses |
WCMFormInfo |
WCMFormInfos |
WCMFormMgr | Title: TRS 内容协作平台（TRS WCM） Description: 管理和自定义表单相关的行为 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.wcm.old 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcm.old 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.components.wcm.content.persistent.Document
          • com.trs.wcm.old.WCMExcelData
        • com.trs.wcm.old.WCMFormFields
        • com.trs.wcm.old.WCMFormInfo
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.wcm.old.WCMExcelDatas
        • com.trs.wcm.old.WCMFormFieldses
        • com.trs.wcm.old.WCMFormInfos
    • com.trs.wcm.old.ImportDocsContext
    • com.trs.wcm.old.ImportDocsFromFile
      • com.trs.wcm.old.ImportDocsFromHTMLFile
    • com.trs.wcm.old.WCMFormMgr


软件包 com.trs.wcm.old 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcm.old
的使用

使用 com.trs.wcm.old 的软件包
com.trs.wcm.old

com.trs.wcm.old 使用的 com.trs.wcm.old 中的类
ImportDocsContext
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImportDocsFromFile
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFormFieldses
WCMFormInfo
WCMFormInfos

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMExcelData

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 WCMExcelData

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.components.wcm.content.persistent.Document
                继承者  com.trs.wcm.old.WCMExcelData
所有已实现的接口：
java.lang.Cloneable
public class WCMExcelData
extends Document

Title: TRS内容协作平台（TRS WCM）

Description:

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: www.trs.com.cn

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象所对应的数据表名
static int | OBJ_TYPE 对象类型（定义在WCMTypes中）
从类 com.trs.components.wcm.content.persistent.Document 继承的字段
ALL_TYPES, DOC_FORM_AUDIO, DOC_FORM_LITERY, DOC_FORM_PIC, DOC_FORM_UNKNOWN, DOC_FORM_VIDEO, DOC_TYPE_FILE, DOC_TYPE_HTML, DOC_TYPE_LINK, DOC_TYPE_NORMAL, DOCUMENTS_GET_OPTIMIZE, FLAG_DEFAULT, FLAG_UNKNOWN, FLAG_USER_DEFINE, g_bXMLforTRS, GET_RELATEDDOC_BY_ALL, GET_RELATEDDOC_BY_KEYWORDS, GET_RELATEDDOC_BY_RELATION, GET_RELATEDDOC_BY_RELWORDS, m_bXMLOnlySelf, SYNCHRONIZE_PROPERTIES_TO_CHNLDOC, SYNCHRONIZED_FIELDS, TYPE_FILE, TYPE_HTML, TYPE_LINK, TYPE_NORMAL, TYPE_UNKNOWN
构造方法摘要
WCMExcelData()
方法摘要
Channel | getChannel() 取所属频道对象
int | getChannelId() 取所属的频道
java.lang.String | getDbTableName() 获得数据库中存储该对象的数据表名称。
Document | getDocument() 获取所属的文档对象
WCMFormInfo | getForm() 获得扩展数据所属表单对象
int | getFormId() 获得扩展数据所属表单ID
java.lang.String | getIdFieldName() 获得Id字段名。
int | getWCMType() 取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
boolean | isValid() 检查对象数据的有效性
boolean | setChannel(Channel _channel) 设置所属频道
boolean | setChannel(int _channelId) 设置所属频道
boolean | setForm(int _formId) 设置扩展数据所属表单
void | setPropertyByDocument(Document _doc) 使用文档对象给新的对象设置属性
从类 com.trs.components.wcm.content.persistent.Document 继承的方法
cloneToNewWCMObj, createNewInstance, delete, delete, findById, findById, findById, findByKey, getAbstract, getAuditor, getAuditorName, getAuthorName, getChannelName, getContent, getDocId, getEditor, getEditorName, getFlag, getFromVersion, getHitsCount, getHtmlContent, getHtmlContentWithImgFilter, getHtmlContentWithImgFilter, getHTMLFiles, getHTMLWCMFiles, getHTMLWCMFiles, getKeywords, getKind, getKindId, getOtherTableName, getOutUpId, getPeople, getPlace, getPubHtmlContent, getPubPathStartTime, getPubTime, getPubURL, getRandomSerial, getRelateWords, getReleaseTime, getSecurity, getSecurityId, getSource, getSourceId, getStatus, getStatusId, getStatusName, getSubTitle, getTitle, getTitleColor, getType, getTypeString, getTypeString, getValidTime, getVersion, getWordsCount, hasDocPro, insertOtherTable, isAttachPic, isDeleted, isDocumentObject, isDoDelete, isDoMove, isDoRecover, isDraft, isOutUp, isRightDefined, isSavePubFileByTime, isValidInstance, logicalDelete, logicalUndelete, main, setAbstract, setAttachPic, setAuditor, setAuditor, setAuthor, setContent, setDbTableName, setDeleted, setDocPro, setEditor, setEditor, setFlag, setFromVersion, setHitsCount, setHtmlContent, setId, setKeywords, setKind, setKind, setMyDocId, setOtherTableName, setOutUpId, setPeople, setPlace, setPubHtmlContent, setPubPathStartTime, setPubTime, setPubURL, setRandomSerial, setRelateWords, setReleaseTime, setRightDefined, setSecurity, setSecurity, setSource, setSource, setStatus, setStatus, setStatus, setSubTitle, setTitle, setTitleColor, setType, setValidTime, setVersion, toString, updateHitsCount
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型（定义在WCMTypes中）

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象所对应的数据表名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

WCMExcelData

public WCMExcelData()
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObj 复制的描述
获得Id字段名。如：wcmUser表中的UserId

覆盖：
类 Document 中的 getIdFieldName
返回：
Id字段名
另请参见：
WCMObj.getIdFieldName()

getDbTableName

public java.lang.String getDbTableName()
从类 BaseObj 复制的描述
获得数据库中存储该对象的数据表名称。 如：User对象对应的数据表是WCMUSER

覆盖：
类 Document 中的 getDbTableName
返回：
另请参见：
WCMObj.getDbTableName()

isValid

public boolean isValid()
                throws WCMException
从类 Document 复制的描述
检查对象数据的有效性

覆盖：
类 Document 中的 isValid
返回：
抛出：
WCMException - 新增模式下 ： 1、没有设置文档所属频道 2、没有设置文档标题
另请参见：
WCMObj.isValid()

getWCMType

public int getWCMType()
从类 BaseObj 复制的描述
取得该对象的类型（定义在WCMTypes中）

二次开发中定义在wcmx.common.WCMTypesX中

覆盖：
类 Document 中的 getWCMType
返回：
整型类型数
另请参见：
WCMObj.getWCMType()

getChannelId

public int getChannelId()
取所属的频道

覆盖：
类 Document 中的 getChannelId
返回：

getChannel

public Channel getChannel()
                   throws WCMException
取所属频道对象

覆盖：
类 Document 中的 getChannel
返回：
所属频道对象
抛出：
WCMException

setChannel

public boolean setChannel(int _channelId)
                   throws WCMException
设置所属频道

覆盖：
类 Document 中的 setChannel
参数：
_channelId - 所属频道ID
返回：
抛出：
WCMException

setChannel

public boolean setChannel(Channel _channel)
                   throws WCMException
设置所属频道

覆盖：
类 Document 中的 setChannel
参数：
_channel - 所属频道对象
返回：
抛出：
WCMException

setForm

public boolean setForm(int _formId)
                throws WCMException
设置扩展数据所属表单

参数：
_formId - 所属表单ID
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误，则抛出异常

getFormId

public int getFormId()
获得扩展数据所属表单ID

返回：
所属表单ID

getForm

public WCMFormInfo getForm()
                    throws WCMException
获得扩展数据所属表单对象

返回：
WCMFormInfo对象
抛出：
WCMException

setPropertyByDocument

public void setPropertyByDocument(Document _doc)
                           throws WCMException
使用文档对象给新的对象设置属性

参数：
_doc - 文档对象
抛出：
WCMException

getDocument

public Document getDocument()
                     throws WCMException
获取所属的文档对象

返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMExcelDatas

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 WCMExcelDatas

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.wcm.old.WCMExcelDatas

public class WCMExcelDatas
extends CMSBaseObjs

Title: TRS内容协作平台（TRS WCM）

Description:

Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司

Company: www.trs.com.cn

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WCMExcelDatas(User _currUser)
WCMExcelDatas(User _currUser, int _initCapacity, int _incCapacity)
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名。
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMExcelDatas

public WCMExcelDatas(User _currUser)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser)

WCMExcelDatas

public WCMExcelDatas(User _currUser,
                     int _initCapacity,
                     int _incCapacity)
另请参见：
CMSBaseObjs.CMSBaseObjs( User _currUser, int initialCapacity, int capacityIncrement )
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
从类 BaseObjs 复制的描述
取对象数据存储的ID字段名。

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

getElementClass

public java.lang.Class getElementClass()
从类 BaseObjs 复制的描述
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFormFields

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 WCMFormFields

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.wcm.old.WCMFormFields
所有已实现的接口：
java.lang.Cloneable
public class WCMFormFields
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
WCMFormFields()
构造函数：保留默认接口
方法摘要
java.lang.String | getDBName() 提取属性：DBName
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getFieldDesc() 提取属性：FieldDesc
FieldInfo | getFieldInfo() 获取表单元素所对应的数据库字段类型对象
java.lang.String | getFieldName() 提取属性：FieldName
int | getFormId() 提取属性：FormId
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
WCMFormInfo | getWCMForm() 获取所属WCMForm对象
int | getWCMType() 取得该对象的类型编号
boolean | isValid() 检验对象数据有效性
boolean | setDBName(java.lang.String _sDBName) 设置属性：DBName
boolean | setFieldDesc(java.lang.String _sFieldDesc) 设置属性：FieldDesc
boolean | setFieldName(java.lang.String _sFieldName) 设置属性：FieldName
boolean | setFormId(int _nFormId) 设置属性：FormId
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, insert, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

WCMFormFields

public WCMFormFields()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getFormId

public int getFormId()
提取属性：FormId

返回：
FormId

getWCMForm

public WCMFormInfo getWCMForm()
                       throws WCMException
获取所属WCMForm对象

返回：
抛出：
WCMException

setFormId

public boolean setFormId(int _nFormId)
                  throws WCMException
设置属性：FormId

参数：
FormId - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldName

public java.lang.String getFieldName()
提取属性：FieldName

返回：
FieldName

setFieldName

public boolean setFieldName(java.lang.String _sFieldName)
                     throws WCMException
设置属性：FieldName

参数：
FieldName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getFieldDesc

public java.lang.String getFieldDesc()
提取属性：FieldDesc

返回：
FieldDesc

setFieldDesc

public boolean setFieldDesc(java.lang.String _sFieldDesc)
                     throws WCMException
设置属性：FieldDesc

参数：
FieldDesc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDBName

public java.lang.String getDBName()
提取属性：DBName

返回：
DBName

getFieldInfo

public FieldInfo getFieldInfo()
                       throws java.lang.Exception
获取表单元素所对应的数据库字段类型对象

返回：
抛出：
java.lang.Exception

setDBName

public boolean setDBName(java.lang.String _sDBName)
                  throws WCMException
设置属性：DBName

参数：
DBName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFormFieldses

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 WCMFormFieldses

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.wcm.old.WCMFormFieldses

public class WCMFormFieldses
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WCMFormFieldses(User _currUser)
构造函数
WCMFormFieldses(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMFormFieldses

public WCMFormFieldses(User _currUser)
构造函数

另请参见：
WCMFormFieldss( User _currUser, int _initCapacity, int _incCapacity );

WCMFormFieldses

public WCMFormFieldses(User _currUser,
                       int _initCapacity,
                       int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFormInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 WCMFormInfo

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.wcm.old.WCMFormInfo
所有已实现的接口：
java.lang.Cloneable
public class WCMFormInfo
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
WCMFormInfo()
构造函数：保留默认接口
方法摘要
int | delete(User _currUser) 重载父类删除接口，同步删除其字段列表
CMSObj | getBean() 获得表单对象所对应的实例
Channel | getChannel() 获取表单的所属频道对象
int | getChannelId() 获取表单所属的频道ID
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getDesc() 提取属性：Desc
WCMFormFieldses | getFields() 获取表单字段列表集合
WCMFormFieldses | getFields(java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sOrder)
java.lang.String | getFormIdName() 获取表单处理对象对应的数据库表中ID名
java.lang.String | getFormTableName() 获取表单处理对象对应的数据库表名
java.util.Hashtable | getHFields() 获取表单字段列表的哈希表，key为数据库字段名
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
java.lang.String | getName() 提取属性：Name
java.lang.String | getObjName() 提取属性：ObjName
java.lang.String | getObjPath() 提取属性： ObjPath
java.lang.String | getObjsName() 提取属性：ObjsName
java.lang.String | getObjsPath() 提取属性： ObjsPath
WebSite | getSite() 设置表单所属的站点
int | getSiteId() 获得表单所属的站点编号
int | getType() 提取属性：Type
int | getWCMType() 取得该对象的类型编号
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
boolean | setChannelId(int _channelId) 设置表单所属的频道ID
boolean | setDesc(java.lang.String _sDesc) 设置属性：Desc
boolean | setName(java.lang.String _sName) 设置属性：Name
boolean | setObjName(java.lang.String _sObjName) 设置属性：ObjName
boolean | setObjPath(java.lang.String _sObjPath) 设置属性：ObjPath
boolean | setObjsName(java.lang.String _sObjsName) 设置属性：ObjsName
boolean | setObjsPath(java.lang.String _sObjsPath) 设置属性：ObjsPath
boolean | setSite(int _siteId) 设置表单的所属站点，仅添加表单时可用，不允许修改该属性。
boolean | setSite(WebSite _website) 设置表单的所属站点，仅添加表单时有效，不允许修改
boolean | setType(int _nType) 设置属性：Type
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, save, setCrUser, setCrUser, toString, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

WCMFormInfo

public WCMFormInfo()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getName

public java.lang.String getName()
提取属性：Name

返回：
Name

setName

public boolean setName(java.lang.String _sName)
                throws WCMException
设置属性：Name

参数：
Name - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getType

public int getType()
提取属性：Type

返回：
Type

setType

public boolean setType(int _nType)
                throws WCMException
设置属性：Type

参数：
Type - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjName

public java.lang.String getObjName()
提取属性：ObjName

返回：
ObjName

setObjName

public boolean setObjName(java.lang.String _sObjName)
                   throws WCMException
设置属性：ObjName

参数：
ObjName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjsName

public java.lang.String getObjsName()
提取属性：ObjsName

返回：
ObjsName

setObjsName

public boolean setObjsName(java.lang.String _sObjsName)
                    throws WCMException
设置属性：ObjsName

参数：
ObjsName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjPath

public java.lang.String getObjPath()
提取属性： ObjPath

返回：
ObjPath

setObjPath

public boolean setObjPath(java.lang.String _sObjPath)
                   throws WCMException
设置属性：ObjPath

参数：
ObjPath - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getObjsPath

public java.lang.String getObjsPath()
提取属性： ObjsPath

返回：
ObjsPath

setObjsPath

public boolean setObjsPath(java.lang.String _sObjsPath)
                    throws WCMException
设置属性：ObjsPath

参数：
ObjsPath - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getDesc

public java.lang.String getDesc()
提取属性：Desc

返回：
Desc

setDesc

public boolean setDesc(java.lang.String _sDesc)
                throws WCMException
设置属性：Desc

参数：
Desc - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getBean

public CMSObj getBean()
               throws java.lang.Exception
获得表单对象所对应的实例

返回：
抛出：
java.lang.Exception

getFormTableName

public java.lang.String getFormTableName()
                                  throws java.lang.Exception
获取表单处理对象对应的数据库表名

返回：
抛出：
java.lang.Exception - BeanPath设置有误时会抛出异常

getFormIdName

public java.lang.String getFormIdName()
                               throws java.lang.Exception
获取表单处理对象对应的数据库表中ID名

返回：
抛出：
java.lang.Exception - BeanPath设置有误时会抛出异常

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

delete

public int delete(User _currUser)
           throws WCMException
重载父类删除接口，同步删除其字段列表

覆盖：
类 CMSObj 中的 delete
参数：
_currUser -
返回：
抛出：
WCMException

getFields

public WCMFormFieldses getFields()
                          throws WCMException
获取表单字段列表集合

返回：
抛出：
WCMException

getFields

public WCMFormFieldses getFields(java.lang.String _sFrom,
                                 java.lang.String _sWhere,
                                 java.lang.String _sOrder)
                          throws WCMException
抛出：
WCMException

getHFields

public java.util.Hashtable getHFields()
                               throws java.lang.Exception
获取表单字段列表的哈希表，key为数据库字段名

返回：
抛出：
java.lang.Exception

getChannelId

public int getChannelId()
                 throws WCMException
获取表单所属的频道ID

返回：
表单所属的频道ID
抛出：
WCMException

setChannelId

public boolean setChannelId(int _channelId)
                     throws WCMException
设置表单所属的频道ID

参数：
_channelId - 表单所属的频道ID
返回：
设置成功返回true；否则返回false
抛出：
WCMException

getChannel

public Channel getChannel()
                   throws WCMException
获取表单的所属频道对象

返回：
表单的所属频道对象
抛出：
WCMException

getSiteId

public int getSiteId()
获得表单所属的站点编号

返回：
站点编号

getSite

public WebSite getSite()
                throws WCMException
设置表单所属的站点

返回：
站点对象
抛出：
WCMException - 如果发生错误，则抛出异常

setSite

public boolean setSite(int _siteId)
                throws WCMException
设置表单的所属站点，仅添加表单时可用，不允许修改该属性。

参数：
_siteId - 新的站点编号
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误，则抛出异常

setSite

public boolean setSite(WebSite _website)
                throws WCMException
设置表单的所属站点，仅添加表单时有效，不允许修改

参数：
_website - 所属站点
返回：
操作是否成功，true表示成功
抛出：
WCMException - 如果发生错误，则抛出异常
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFormInfos

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 WCMFormInfos

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.wcm.old.WCMFormInfos

public class WCMFormInfos
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
WCMFormInfos(User _currUser)
构造函数
WCMFormInfos(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static WCMFormInfos | openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 16:42:24 Last Modified: 2004-12-12/2004-12-12 Description:获取表单集合
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMFormInfos

public WCMFormInfos(User _currUser)
构造函数

另请参见：
WCMFormInfos( User _currUser, int _initCapacity, int _incCapacity );

WCMFormInfos

public WCMFormInfos(User _currUser,
                    int _initCapacity,
                    int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_app - 关联的Application对象
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
集合对象实例
抛出：
java.lang.Exception - 若创建失败，会抛出异常

openWCMObjs

public static WCMFormInfos openWCMObjs(User _currUser,
                                       WCMFilter _filter)
                                throws WCMException
Created: 2004-12-12 16:42:24 Last Modified: 2004-12-12/2004-12-12 Description:获取表单集合

参数：
_currUser - 当前操作用户
_filter - 过滤器,筛选条件
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCMFormMgr

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.old
类 WCMFormMgr

java.lang.Object
    继承者  com.trs.wcm.old.WCMFormMgr

public class WCMFormMgr
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
管理和自定义表单相关的行为
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMFormMgr()
方法摘要
 WCMFormInfos getForms(BaseChannel _oChannel, boolean _bChildren, WCMFilter _filter)
获取站点/频道的自定义表单
从ChannelMgr中移动过来的 hx@050328
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMFormMgr

public WCMFormMgr()
方法详细信息

getForms

public WCMFormInfos getForms(BaseChannel _oChannel,
                             boolean _bChildren,
                             WCMFilter _filter)
                      throws WCMException
获取站点/频道的自定义表单
从ChannelMgr中移动过来的 hx@050328

参数：
_oChannel - 当前站点/频道
_bChildren - 是否取子系表单(只对站点有效)
_filter - 过滤器,额外的查询条件
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.wcm.old.ImportDocsContext 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.ImportDocsContext
的使用

使用 ImportDocsContext 的软件包
com.trs.wcm.old

com.trs.wcm.old 中 ImportDocsContext 的使用

返回 ImportDocsContext 的 com.trs.wcm.old 中的方法
 ImportDocsContext ImportDocsFromFile.getCurrContext()
返回上下文对象

参数类型为 ImportDocsContext 的 com.trs.wcm.old 中的方法
 void ImportDocsFromFile.setCurrContext(ImportDocsContext _currContexxt)
设置上下文对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.ImportDocsFromFile 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.ImportDocsFromFile
的使用

使用 ImportDocsFromFile 的软件包
com.trs.wcm.old

com.trs.wcm.old 中 ImportDocsFromFile 的使用

com.trs.wcm.old 中 ImportDocsFromFile 的子类
 class ImportDocsFromHTMLFile
Created by IntelliJ IDEA.

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.ImportDocsFromHTMLFile 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.ImportDocsFromHTMLFile
的使用

没有 com.trs.wcm.old.ImportDocsFromHTMLFile 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.WCMExcelData 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.WCMExcelData
的使用

没有 com.trs.wcm.old.WCMExcelData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.WCMExcelDatas 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.WCMExcelDatas
的使用

没有 com.trs.wcm.old.WCMExcelDatas 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.WCMFormFields 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.WCMFormFields
的使用

没有 com.trs.wcm.old.WCMFormFields 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.WCMFormFieldses 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.WCMFormFieldses
的使用

使用 WCMFormFieldses 的软件包
com.trs.wcm.old

com.trs.wcm.old 中 WCMFormFieldses 的使用

返回 WCMFormFieldses 的 com.trs.wcm.old 中的方法
WCMFormFieldses | WCMFormInfo.getFields() 获取表单字段列表集合
WCMFormFieldses | WCMFormInfo.getFields(java.lang.String _sFrom, java.lang.String _sWhere, java.lang.String _sOrder)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.WCMFormInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.WCMFormInfo
的使用

使用 WCMFormInfo 的软件包
com.trs.wcm.old

com.trs.wcm.old 中 WCMFormInfo 的使用

返回 WCMFormInfo 的 com.trs.wcm.old 中的方法
WCMFormInfo | WCMExcelData.getForm() 获得扩展数据所属表单对象
WCMFormInfo | WCMFormFields.getWCMForm() 获取所属WCMForm对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.WCMFormInfos 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.WCMFormInfos
的使用

使用 WCMFormInfos 的软件包
com.trs.wcm.old

com.trs.wcm.old 中 WCMFormInfos 的使用

返回 WCMFormInfos 的 com.trs.wcm.old 中的方法
WCMFormInfos | WCMFormMgr.getForms(BaseChannel _oChannel, boolean _bChildren, WCMFilter _filter) 获取站点/频道的自定义表单 从ChannelMgr中移动过来的 hx@050328
static WCMFormInfos | WCMFormInfos.openWCMObjs(User _currUser, WCMFilter _filter) Created: 2004-12-12 16:42:24 Last Modified: 2004-12-12/2004-12-12 Description:获取表单集合

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.old.WCMFormMgr 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.old.WCMFormMgr
的使用

没有 com.trs.wcm.old.WCMFormMgr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DocumentLCLisenterForPhoto

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
类 DocumentLCLisenterForPhoto

java.lang.Object
    继承者  com.trs.wcm.photo.DocumentLCLisenterForPhoto
所有已实现的接口：
IObjectLCListener, IObjectLCListenerOnDel
public class DocumentLCLisenterForPhoto
extends java.lang.Object
implements IObjectLCListenerOnDel

Title: TRS 内容协作平台（TRS WCM）
Description:
图片删除监听器
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
DocumentLCLisenterForPhoto()
方法摘要
 void notifyOnDelObj(BaseObj _oObjDeleted, int _nEventType)
删除一个对象后通知所有的Cache
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentLCLisenterForPhoto

public DocumentLCLisenterForPhoto()
方法详细信息

notifyOnDelObj

public void notifyOnDelObj(BaseObj _oObjDeleted,
                           int _nEventType)
从接口 IObjectLCListenerOnDel 复制的描述
删除一个对象后通知所有的Cache

指定者：
接口 IObjectLCListenerOnDel 中的 notifyOnDelObj
参数：
_oObjDeleted - 被删除的对象
_nEventType - TODO
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IImageLibConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
接口 IImageLibConfig

所有已知实现类：
ImageLibConfigImpl
public interface IImageLibConfig

Title: TRS 内容协作平台（TRS WCM）
Description:
图片库配置信息管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | SCALE_STYLE_AUTO
static java.lang.String | SCALE_STYLE_HEIGHT
static java.lang.String | SCALE_STYLE_WIDTH
方法摘要
java.lang.String | getDefaultConvertImageFileExt() 获取默认转换的图片格式
Template | getDefaultDetailTemplate() 获取图片库分类默认的细览模板
int | getDefaultDetailTemplateId() 获取图片库分类默认的细览模板ID
Template | getDefaultOutlineTemplate() 获取图片库分类默认的概览模板
int | getDefaultOutlineTemplateId() 获取图片库分类默认的概览模板ID
int[] | getOtherRelatedKindIds() 获取其它的默认分类
java.lang.String | getRelatedConvertType() 获取bmp文件转换格式
int | getRelatedKindId() 获取默认主分类
int | getRelatedWaterMarkId() 获取水印
int[] | getRelatedWaterMarkPos() 获取水印位置
WebSite | getRelateSite() 获取与图片库相关的站点
int | getRelateSiteId() 获取与图片库相关的站点ID
java.lang.String | getScaleDescAt(int _nScaleIndex) 获取指定尺寸索引的描述
int[] | getScaleSizes() 获取图片库默认定义的各种缩放尺寸
java.lang.String | getScaleStyle()
java.lang.String[] | getSupportImageFileExt() 获取系统支持的各种图片文件格式
int | getWaterMarkSize(int _nImageWidth) 获取指定图片宽度设置的水印大小
boolean | isAutoEnable() 是否启动文档中的图片自动保存到图片库中
boolean | isCmdUsed()
boolean | isInstalled()
boolean | isOriginalMarked()
boolean | isSupportImageFileExt(java.lang.String _sImageFileExt) 判断当前图片文件格式是否在系统支持系列中
boolean | reloadConfig() 重新装载图片库配置信息
boolean | saveConfig() 保存图片库的设置
void | setAtuoEnable(boolean _enable) 设置是否启动文档中的图片自动保存到图片库中
void | setDefaultTemplateId(int _nOutlineTemplateId, int _nDetailTemplateId) 设置默认的模板信息
void | setImageFileExt(java.lang.String[] _pSupportFileExt, java.lang.String _sDefaultConvertFileExt) 设置支持的图片格式和默认的转换图片
void | setInstalled()
void | setOtherRelatedKindIds(java.lang.String _ids) 设置其它的默认分类
void | setRealtedKindId(int _id) 设置默认主分类
void | setRelatedConvertType(java.lang.String _type) 设置bmp文件转换格式
void | setRelatedWaterMarkId(int _id) 设置水印
void | setRelatedWaterMarkPos(java.lang.String _pos) 设置水印位置
void | setRelateSiteId(int _nRelateId) 设置相关站点
void | setScaleSizes(int[] _pScaleSize, java.lang.String[] _pScaleSizeDesc, int[] _pWaterMarkSize) 设置图片库自动缩放的图片尺寸、描述以及添加的水印大小

字段详细信息

SCALE_STYLE_WIDTH

static final java.lang.String SCALE_STYLE_WIDTH
另请参见：
常量字段值

SCALE_STYLE_HEIGHT

static final java.lang.String SCALE_STYLE_HEIGHT
另请参见：
常量字段值

SCALE_STYLE_AUTO

static final java.lang.String SCALE_STYLE_AUTO
另请参见：
常量字段值
方法详细信息

getRelateSite

WebSite getRelateSite()
                      throws WCMException
获取与图片库相关的站点

返回：
与图片库相关的站点对象(WebSite)
抛出：
WCMException

getRelateSiteId

int getRelateSiteId()
                    throws WCMException
获取与图片库相关的站点ID

返回：
与图片库相关的站点ID
抛出：
WCMException

setRelateSiteId

void setRelateSiteId(int _nRelateId)
                     throws WCMException
设置相关站点

参数：
_nRelateId -
抛出：
WCMException

getDefaultOutlineTemplate

Template getDefaultOutlineTemplate()
                                   throws WCMException
获取图片库分类默认的概览模板

返回：
图片库分类默认的概览模板对象(Template)
抛出：
WCMException

getDefaultOutlineTemplateId

int getDefaultOutlineTemplateId()
                                throws WCMException
获取图片库分类默认的概览模板ID

返回：
图片库分类默认的概览模板ID
抛出：
WCMException

getDefaultDetailTemplate

Template getDefaultDetailTemplate()
                                  throws WCMException
获取图片库分类默认的细览模板

返回：
图片库分类默认的细览模板对象(Template)
抛出：
WCMException

getDefaultDetailTemplateId

int getDefaultDetailTemplateId()
                               throws WCMException
获取图片库分类默认的细览模板ID

返回：
图片库分类默认的细览模板ID
抛出：
WCMException

setDefaultTemplateId

void setDefaultTemplateId(int _nOutlineTemplateId,
                          int _nDetailTemplateId)
                          throws WCMException
设置默认的模板信息

参数：
_nOutlineTemplateId -
_nDetailTemplateId -
抛出：
WCMException

getScaleSizes

int[] getScaleSizes()
                    throws WCMException
获取图片库默认定义的各种缩放尺寸

返回：
各种尺寸大小
抛出：
WCMException

setScaleSizes

void setScaleSizes(int[] _pScaleSize,
                   java.lang.String[] _pScaleSizeDesc,
                   int[] _pWaterMarkSize)
                   throws WCMException
设置图片库自动缩放的图片尺寸、描述以及添加的水印大小

参数：
_pScaleSize - 缩放的图片尺寸（宽度）
_pScaleSizeDesc - 缩放的图片尺寸描述
_pWaterMarkSize - 、 不同尺寸对应的水印大小
抛出：
WCMException

getScaleDescAt

java.lang.String getScaleDescAt(int _nScaleIndex)
                                throws WCMException
获取指定尺寸索引的描述

参数：
_nScaleIndex - 指定尺寸索引，从0开始，和配置文件中一一对应
返回：
描述信心（String）
抛出：
WCMException

getWaterMarkSize

int getWaterMarkSize(int _nImageWidth)
                     throws WCMException
获取指定图片宽度设置的水印大小

参数：
_nImageWidth - 指定的图片宽度
返回：
>=0的整数，如果指定的宽度没有允许加水印，返回0
抛出：
WCMException

getSupportImageFileExt

java.lang.String[] getSupportImageFileExt()
                                          throws WCMException
获取系统支持的各种图片文件格式

返回：
图片文件格式字符串数组
抛出：
WCMException

isSupportImageFileExt

boolean isSupportImageFileExt(java.lang.String _sImageFileExt)
                              throws WCMException
判断当前图片文件格式是否在系统支持系列中

参数：
_sImageFileExt - 图片文件格式后缀
返回：
如果支持，返回true；否则返回false
抛出：
WCMException

getDefaultConvertImageFileExt

java.lang.String getDefaultConvertImageFileExt()
                                               throws WCMException
获取默认转换的图片格式

返回：
抛出：
WCMException

setImageFileExt

void setImageFileExt(java.lang.String[] _pSupportFileExt,
                     java.lang.String _sDefaultConvertFileExt)
                     throws WCMException
设置支持的图片格式和默认的转换图片

参数：
_pSupportFileExt -
_sDefaultConvertFileExt -
抛出：
WCMException

reloadConfig

boolean reloadConfig()
                     throws WCMException
重新装载图片库配置信息

返回：
装载成功，返回true
抛出：
WCMException

saveConfig

boolean saveConfig()
                   throws WCMException
保存图片库的设置

返回：
抛出：
WCMException

isAutoEnable

boolean isAutoEnable()
                     throws WCMException
是否启动文档中的图片自动保存到图片库中

返回：
如果该功能启动,则返回true
抛出：
WCMException

setAtuoEnable

void setAtuoEnable(boolean _enable)
                   throws WCMException
设置是否启动文档中的图片自动保存到图片库中

参数：
_enable -
抛出：
WCMException

getRelatedKindId

int getRelatedKindId()
                     throws WCMException
获取默认主分类

返回：
抛出：
WCMException

setRealtedKindId

void setRealtedKindId(int _id)
                      throws WCMException
设置默认主分类

参数：
_id -
抛出：
WCMException

getOtherRelatedKindIds

int[] getOtherRelatedKindIds()
                             throws WCMException
获取其它的默认分类

返回：
抛出：
WCMException

setOtherRelatedKindIds

void setOtherRelatedKindIds(java.lang.String _ids)
                            throws WCMException
设置其它的默认分类

参数：
_ids -
抛出：
WCMException

getRelatedWaterMarkId

int getRelatedWaterMarkId()
                          throws WCMException
获取水印

返回：
抛出：
WCMException

setRelatedWaterMarkId

void setRelatedWaterMarkId(int _id)
                           throws WCMException
设置水印

参数：
_id -
抛出：
WCMException

getRelatedWaterMarkPos

int[] getRelatedWaterMarkPos()
                             throws WCMException
获取水印位置

返回：
抛出：
WCMException

setRelatedWaterMarkPos

void setRelatedWaterMarkPos(java.lang.String _pos)
                            throws WCMException
设置水印位置

参数：
_pos -
抛出：
WCMException

getRelatedConvertType

java.lang.String getRelatedConvertType()
                                       throws WCMException
获取bmp文件转换格式

返回：
抛出：
WCMException

setRelatedConvertType

void setRelatedConvertType(java.lang.String _type)
                           throws WCMException
设置bmp文件转换格式

参数：
_type -
抛出：
WCMException

isInstalled

boolean isInstalled()
                    throws WCMException
抛出：
WCMException

setInstalled

void setInstalled()
                  throws WCMException
抛出：
WCMException

isCmdUsed

boolean isCmdUsed()
                  throws WCMException
返回：
抛出：
WCMException

isOriginalMarked

boolean isOriginalMarked()
                         throws WCMException
抛出：
WCMException

getScaleStyle

java.lang.String getScaleStyle()
                               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IImageLibMgr

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
接口 IImageLibMgr

所有已知实现类：
ImageLibMgrImpl
public interface IImageLibMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
图片业务处理对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | deleteDocumentQuoteImage(int _nDocumentId) 删除指定文档的所有引用关系
void | deleteDocumentQuoteImage(int _nDocumentId, int _nImageId) 删除文档和指定图片引用关系
void | deleteDocumentQuoteImage(int _nDocumentId, java.lang.String _sExcludeImageIds) 删除指定文档的图片引用关系，不包括指定的图片ID
Documents | getDocumentsQuoteImage(int _nImageId) 获取使用指定图片的所有文档
Appendixes | getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片
ImageInfo | importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo) 导入指定的图片到图片库指定的分类中
void | recordDocumentQuoteImage(int _nDocumentId, int _nImageId) 记录文档和指定图片的引用关系
ImageInfo | saveImageInfo(ImageInfo _imageInfo)

方法详细信息

saveImageInfo

ImageInfo saveImageInfo(ImageInfo _imageInfo)
                        throws WCMException
参数：
_imageInfo -
返回：
抛出：
WCMException

recordDocumentQuoteImage

void recordDocumentQuoteImage(int _nDocumentId,
                              int _nImageId)
                              throws WCMException
记录文档和指定图片的引用关系

参数：
_nDocumentId - 文档ID
_nImageId - 图片ID
抛出：
WCMException

deleteDocumentQuoteImage

void deleteDocumentQuoteImage(int _nDocumentId,
                              int _nImageId)
                              throws WCMException
删除文档和指定图片引用关系

参数：
_nDocumentId - 指定文档ID
_nImageId - 指定图片ID
抛出：
WCMException

deleteDocumentQuoteImage

void deleteDocumentQuoteImage(int _nDocumentId,
                              java.lang.String _sExcludeImageIds)
                              throws WCMException
删除指定文档的图片引用关系，不包括指定的图片ID

参数：
_nDocumentId - 指定文档ID
_sExcludeImageIds - 排除的图片ＩＤ序列
抛出：
WCMException

deleteDocumentQuoteImage

void deleteDocumentQuoteImage(int _nDocumentId)
                              throws WCMException
删除指定文档的所有引用关系

参数：
_nDocumentId - 指定文档ID
抛出：
WCMException

getDocumentsQuoteImage

Documents getDocumentsQuoteImage(int _nImageId)
                                 throws WCMException
获取使用指定图片的所有文档

参数：
_nImageId - 指定图片ID
返回：
抛出：
WCMException

getImageAppendixes

Appendixes getImageAppendixes(WCMFilter _extraFilter,
                              BaseChannel _oChannelOrSite,
                              boolean _bIncludeImported)
                              throws WCMException
获取系统中已经存在的图片

参数：
_extraFilter - 额外的查询条件
_nImageKineId - 分类ID，如果为0，表示提取所有的分类ID
_bIncludeImported - 是否包含已经导入的 true:包含 false：不包含
返回：
抛出：
WCMException

importImageAppendix

ImageInfo importImageAppendix(User _currUser,
                              int _nAppendixId,
                              ImageInfo _imageInfo)
                              throws WCMException
导入指定的图片到图片库指定的分类中

参数：
_currUser - 当前的拥护
_nAppendixId - 指定的图片ID
_imageInfo - 图片处理机制
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IImageLibService

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
接口 IImageLibService

所有已知实现类：
ImageLibServiceImpl
public interface IImageLibService

Title: TRS 内容协作平台（TRS WCM）
Description:
图片选件服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | clearQuotedImages(int _nDocId)
void | deleteImage(java.lang.String _sDocIds) 从图片库中删除指定的图片
void | deleteImage(java.lang.String _sDocIds, int _nChannelId) 从指定的分类中删除图片
java.util.List | getChannels(User _user, int _nRightIndex) 获取指定用户可见的图片库的一级分类
java.util.List | getChannels(User _user, int _nRightIndex, Channel _channel) 获取指定用户在指定分类可见的子分类列表
java.util.List | getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter) 获取指定用户在指定分类可见的子分类列表
Documents | getDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前分类下所有的图片
Documents | getDocumentsQuoteImage(int _nImageId) 获取使用指定图片的所有文档
Appendixes | getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片
ImageInfo | importImageAppendix(int _nAppendixId, ImageInfo _imageInfo) 导入单个的图片到指定的分类中
ImageInfo[] | importImageAppendix(java.lang.String _sAppendixIds, ImageInfo _imageInfo) 导入指定的图片到指定的分类中
void | quoteImages(int _nDocId, java.lang.String _sQuoteImageIds) 保存指定文档引用图片的关系
Document | saveImageDetail(Document _document) 保存图片的标注信息(标题、作者、地点、人物、时间)
ImageInfo | saveImageInfo(ImageInfo _imageInfo) 保存图片信息到图片库中

方法详细信息

getChannels

java.util.List getChannels(User _user,
                           int _nRightIndex)
                           throws WCMException
获取指定用户可见的图片库的一级分类

参数：
_user - 指定用户
_nRightIndex - 指定的权限，定义在WCMRightTypes中
返回：
一级分类集合(Channels)
抛出：
WCMException

getChannels

java.util.List getChannels(User _user,
                           int _nRightIndex,
                           Channel _channel)
                           throws WCMException
获取指定用户在指定分类可见的子分类列表

参数：
_user - 指定用户
_nRightIndex - 指定的权限，定义在WCMRightTypes中
_channel - 指定的频道
返回：
抛出：
WCMException

getChannels

java.util.List getChannels(User _user,
                           int _nRightIndex,
                           Channel _channel,
                           WCMFilter _filter)
                           throws WCMException
获取指定用户在指定分类可见的子分类列表

参数：
_user - 指定用户
_nRightIndex - 指定的权限，定义在WCMRightTypes中
_channel - 指定的频道
_filter - 额外的检索条件
返回：
抛出：
WCMException

getDocuments

Documents getDocuments(BaseChannel _oChannel,
                       WCMFilter _filter)
                       throws WCMException
获取当前分类下所有的图片

参数：
_oChannel - 当前分类对象（所有或者指定分类）,如果null，表示所有分类
_filter - 过滤器,额外的查询条件
返回：
图片集合(Documents)
抛出：
WCMException

saveImageInfo

ImageInfo saveImageInfo(ImageInfo _imageInfo)
                        throws WCMException
保存图片信息到图片库中

参数：
_imageInfo - 用户上传的图片对象(ImageInfo) 包含自动操作控制对象
返回：
成功保存的对象描述对象(ImageInfo)
抛出：
WCMException

saveImageDetail

Document saveImageDetail(Document _document)
                         throws WCMException
保存图片的标注信息(标题、作者、地点、人物、时间)

参数：
_document -
返回：
抛出：
WCMException

deleteImage

void deleteImage(java.lang.String _sDocIds)
                 throws WCMException
从图片库中删除指定的图片

参数：
_sDocIds - 图片ID系列
抛出：
WCMException

deleteImage

void deleteImage(java.lang.String _sDocIds,
                 int _nChannelId)
                 throws WCMException
从指定的分类中删除图片

参数：
_sDocIds - 指定的图片ID序列
_nChannelId - 指定的分类
抛出：
WCMException

quoteImages

void quoteImages(int _nDocId,
                 java.lang.String _sQuoteImageIds)
                 throws WCMException
保存指定文档引用图片的关系

参数：
_nDocId - 指定文档ID
_sQuoteImageIds - 指定引用图片的ID序列
抛出：
WCMException

getDocumentsQuoteImage

Documents getDocumentsQuoteImage(int _nImageId)
                                 throws WCMException
获取使用指定图片的所有文档

参数：
_nImageId - 指定图片ID
返回：
抛出：
WCMException

getImageAppendixes

Appendixes getImageAppendixes(WCMFilter _extraFilter,
                              BaseChannel _oChannelOrSite,
                              boolean _bIncludeImported)
                              throws WCMException
获取系统中已经存在的图片

参数：
_extraFilter - 额外的查询条件
_oChannelOrSite - 站点或者频道，不指定表示获取系统所有的图片
_bIncludeImported - 是否包含已经导入的 true:包含 false：不包含
返回：
抛出：
WCMException

importImageAppendix

ImageInfo[] importImageAppendix(java.lang.String _sAppendixIds,
                                ImageInfo _imageInfo)
                                throws WCMException
导入指定的图片到指定的分类中

参数：
_sAppendixIds - 指定的图片ID序列
_imageInfo - 图片的处理机制
返回：
抛出：
WCMException

importImageAppendix

ImageInfo importImageAppendix(int _nAppendixId,
                              ImageInfo _imageInfo)
                              throws WCMException
导入单个的图片到指定的分类中

参数：
_nAppendixId - 指定的图片ID
_imageInfo - 图片的处理机制
返回：
抛出：
WCMException

clearQuotedImages

void clearQuotedImages(int _nDocId)
                       throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageInfo

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
类 ImageInfo

java.lang.Object
    继承者  com.trs.wcm.photo.ImageInfo
所有已实现的接口：
java.lang.Cloneable
public class ImageInfo
extends java.lang.Object
implements java.lang.Cloneable

Title: TRS 内容协作平台（TRS WCM）
Description:
新上传的图片信息描述对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ImageInfo()
方法摘要
java.lang.Object | clone()
java.lang.String | getConvertToImageType()
int | getId()
java.lang.String | getImageFileName()
int | getImageKindId()
java.lang.String | getImageTitle()
java.lang.String | getMarkImageFile()
int[] | getMarkPos()
int[] | getOtherImageKinedId()
java.lang.String | getSrcFileName()
boolean | isAddMark()
boolean | isAddMode()
void | setAddMark(boolean addMark)
void | setConvertToImageType(java.lang.String convertToImageType)
void | setId(int id)
void | setImageFileName(java.lang.String imageFileName)
void | setImageKindId(int imageKindId)
void | setImageTitle(java.lang.String imageTitle)
void | setMarkImageFile(java.lang.String markImageFile)
void | setMarkPos(int[] markPos)
void | setOtherImageKinedId(int[] otherImageKinedId)
void | setSrcFileName(java.lang.String srcFileName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageInfo

public ImageInfo()
方法详细信息

getImageTitle

public java.lang.String getImageTitle()
返回：

setImageTitle

public void setImageTitle(java.lang.String imageTitle)
参数：
imageTitle -

isAddMark

public boolean isAddMark()
返回：

setAddMark

public void setAddMark(boolean addMark)
参数：
addMark -

getId

public int getId()
返回：

setId

public void setId(int id)
参数：
id -

getImageKindId

public int getImageKindId()
返回：

setImageKindId

public void setImageKindId(int imageKindId)
参数：
imageKindId -

getMarkPos

public int[] getMarkPos()
返回：

setMarkPos

public void setMarkPos(int[] markPos)
参数：
markPos -

getOtherImageKinedId

public int[] getOtherImageKinedId()
返回：

setOtherImageKinedId

public void setOtherImageKinedId(int[] otherImageKinedId)
参数：
otherImageKinedId -

getConvertToImageType

public java.lang.String getConvertToImageType()
返回：

setConvertToImageType

public void setConvertToImageType(java.lang.String convertToImageType)
参数：
convertToImageType -

getImageFileName

public java.lang.String getImageFileName()
返回：

setImageFileName

public void setImageFileName(java.lang.String imageFileName)
参数：
imageFileName -

getMarkImageFile

public java.lang.String getMarkImageFile()
返回：

setMarkImageFile

public void setMarkImageFile(java.lang.String markImageFile)
参数：
markImageFile -

getSrcFileName

public java.lang.String getSrcFileName()
返回：

setSrcFileName

public void setSrcFileName(java.lang.String srcFileName)
参数：
srcFileName -

isAddMode

public boolean isAddMode()
返回：

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
覆盖：
类 java.lang.Object 中的 clone
抛出：
java.lang.CloneNotSupportedException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageKind

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
类 ImageKind

java.lang.Object
    继承者  com.trs.wcm.photo.ImageKind

public class ImageKind
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
图片分类对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ImageKind()
方法摘要
static ImageKind | findById(int _nImageKindId)
java.lang.String | getDataPath()
java.lang.String | getDesc()
int | getDetailTemplateId()
int | getImageKindId()
java.lang.String | getName()
int | getOutlineTemplateId()
int | getPreImageKindId()
Channel | getRelatedChannel()
void | setDataPath(java.lang.String dataPath)
void | setDesc(java.lang.String desc)
void | setDetailTemplateId(int detailTemplateId)
void | setImageKindId(int imageKindId)
void | setName(java.lang.String name)
void | setOutlineTemplateId(int outlineTemplateId)
void | setPreImageKindId(int preImageKindId)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageKind

public ImageKind()
方法详细信息

getDetailTemplateId

public int getDetailTemplateId()
返回：

setDetailTemplateId

public void setDetailTemplateId(int detailTemplateId)
参数：
detailTemplateId -

getOutlineTemplateId

public int getOutlineTemplateId()
返回：

setOutlineTemplateId

public void setOutlineTemplateId(int outlineTemplateId)
参数：
outlineTemplateId -

getPreImageKindId

public int getPreImageKindId()
返回：

setPreImageKindId

public void setPreImageKindId(int preImageKindId)
参数：
preImageKindId -

getDataPath

public java.lang.String getDataPath()
返回：

setDataPath

public void setDataPath(java.lang.String dataPath)
参数：
dataPath -

getDesc

public java.lang.String getDesc()
返回：

setDesc

public void setDesc(java.lang.String desc)
参数：
desc -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

getImageKindId

public int getImageKindId()
返回：

setImageKindId

public void setImageKindId(int imageKindId)
参数：
imageKindId -

getRelatedChannel

public Channel getRelatedChannel()
                          throws WCMException
抛出：
WCMException

findById

public static ImageKind findById(int _nImageKindId)
                          throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageLibConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
类 ImageLibConstants

java.lang.Object
    继承者  com.trs.wcm.photo.ImageLibConstants

public class ImageLibConstants
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
图片库常量定义对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String | FILENAME_CONFIG 图片库配置文件名
static int | MARKPOS_CENTER_MIDDLE 水印位置：居中
static int | MARKPOS_LEFT_TOP 水印位置：左上
static int | MARKPOS_RIGHT_BOTTOM 水印位置：右下
static int | TYPE_QUOTE_FILE 引用文件
static int | TYPE_QUOTE_NONE 没有引用任何图片库的图片
static int | TYPE_QUOTE_URL 直接引用地址
构造方法摘要
ImageLibConstants()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FILENAME_CONFIG

public static final java.lang.String FILENAME_CONFIG
图片库配置文件名

另请参见：
常量字段值

TYPE_QUOTE_NONE

public static final int TYPE_QUOTE_NONE
没有引用任何图片库的图片

另请参见：
常量字段值

TYPE_QUOTE_FILE

public static final int TYPE_QUOTE_FILE
引用文件

另请参见：
常量字段值

TYPE_QUOTE_URL

public static final int TYPE_QUOTE_URL
直接引用地址

另请参见：
常量字段值

MARKPOS_LEFT_TOP

public static int MARKPOS_LEFT_TOP
水印位置：左上

MARKPOS_CENTER_MIDDLE

public static int MARKPOS_CENTER_MIDDLE
水印位置：居中

MARKPOS_RIGHT_BOTTOM

public static int MARKPOS_RIGHT_BOTTOM
水印位置：右下

构造方法详细信息

ImageLibConstants

public ImageLibConstants()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageLibHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
类 ImageLibHelper

java.lang.Object
    继承者  com.trs.wcm.photo.ImageLibHelper

public class ImageLibHelper
extends java.lang.Object

构造方法摘要
ImageLibHelper()
方法摘要
static java.lang.String[] | getAllImageFiles(Document _document)
static java.lang.String | getImageFileNameByScale(Document _document, int _nScale)
static java.lang.String | getImageFileNameByScale(Document _document, int _nScale, boolean _bOnlyFileName)
static java.lang.String | getImageFileNameByScaleIndex(Document _document, int _nScaleIndex)
static java.lang.String | getImageFileNameByScaleIndex(Document _document, int _nScaleIndex, boolean _bOnlyFileName)
static java.lang.String | getOrigImageFileName(Document _document, boolean _bOnlyFileName)
static java.lang.String | getOrigImageFilePath(Document _document, boolean _bOnlyFileName) 返回图片的原图的图径，若文档已发布，则返回该图的发布路径
static int | getTypeQuotedImageLib(Appendix _appendix)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageLibHelper

public ImageLibHelper()
方法详细信息

getImageFileNameByScaleIndex

public static java.lang.String getImageFileNameByScaleIndex(Document _document,
                                                            int _nScaleIndex)
                                                     throws WCMException
参数：
_document -
_nScaleIndex -
返回：
抛出：
WCMException

getImageFileNameByScaleIndex

public static java.lang.String getImageFileNameByScaleIndex(Document _document,
                                                            int _nScaleIndex,
                                                            boolean _bOnlyFileName)
                                                     throws WCMException
抛出：
WCMException

getOrigImageFilePath

public static java.lang.String getOrigImageFilePath(Document _document,
                                                    boolean _bOnlyFileName)
                                             throws WCMException
返回图片的原图的图径，若文档已发布，则返回该图的发布路径

参数：
_document -
_bOnlyFileName - 是否返回发布路径
返回：
抛出：
WCMException

getOrigImageFileName

public static java.lang.String getOrigImageFileName(Document _document,
                                                    boolean _bOnlyFileName)
                                             throws WCMException
抛出：
WCMException

getAllImageFiles

public static java.lang.String[] getAllImageFiles(Document _document)
参数：
_document -
返回：
抛出：
WCMException

getImageFileNameByScale

public static java.lang.String getImageFileNameByScale(Document _document,
                                                       int _nScale)
                                                throws WCMException
参数：
_document -
_nScale -
返回：
抛出：
WCMException

getImageFileNameByScale

public static java.lang.String getImageFileNameByScale(Document _document,
                                                       int _nScale,
                                                       boolean _bOnlyFileName)
                                                throws WCMException
抛出：
WCMException

getTypeQuotedImageLib

public static int getTypeQuotedImageLib(Appendix _appendix)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMagicImage

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
接口 IMagicImage

所有已知实现类：
MagicImageImpl
public interface IMagicImage

Title: TRS 内容协作平台（TRS WCM）
Description:
图片处理对象（例如：缩放、锐化、凸起等）
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
byte[] | addWaterMark(java.lang.String _sWaterImageFile, int[] _pWarterMarkPos) 添加图片水印
byte[] | borderImage(java.lang.String _sBoderColor, int _nWidth, int _nHeight) 给图片加上边框
byte[] | convertImageFormat(java.lang.String _sNewImageFormat) 设置需要转换的图片格式
void | cropImage(int x, int y, int width, int height, java.lang.String _sDstFile) 裁剪图片
double | getHeight() 获取图片的高度
int | getSize() 获得图片大小
java.lang.String | getSrcImageFileName() 获取原始的图片文件名
double | getWidth() 获取图片的高度
void | initMagicImage(java.lang.String _sSrcFileName) 初始化图片处理对象
void | montageImages(java.lang.String[] _pImageFileName, java.lang.String _sImageTitle, java.lang.String _sDstImageFile, java.lang.String _sBgColor, java.lang.String _sBorderColor, int _nBorderWidth) 生成组图
byte[] | raiseImage(int _nWidth, int _nHeight, boolean _bRaised) 突起效果
byte[] | rotateImage(double _dDegrees) 按照指定的角度旋转突破
byte[] | scaleImage(int _nWidth, int _nHeight) 将指定的图片按照指定的宽度和高度缩放
void | scaleImage(int _nWidth, int _nHeight, java.lang.String _sDstFile)
void | setBackgroundColor(java.lang.String _sBgColor) 设置背景颜色
void | setImageAttribute(java.lang.String _sAttrName, java.lang.String _sValue) 设置图片的属性
void | setOutputImageFileExt(java.lang.String _sImageFileExt) 设置输出图片文件的后缀名
byte[] | sharpenImage(double raduis, double sigma) 锐化图片
void | writeImage() 将设定的效果写入原始图片文件中
void | writeImage(java.lang.String _sNewDstFileName) 将设定的效果写入新定义的图片文件中
java.lang.String | writeImageToSystemTemp() 将设定的效果写入到系统的临时目录中
java.lang.String | writeImageToWCMData(java.lang.String _sPathFlag) 将图片写入到WCMData指定类型的目录中

方法详细信息

initMagicImage

void initMagicImage(java.lang.String _sSrcFileName)
                    throws java.lang.Exception
初始化图片处理对象

参数：
_sSrcFileName - 服务器上绝对物理地址或WCM有规则的文件名
抛出：
WCMException
java.lang.Exception

writeImage

void writeImage()
                throws java.lang.Exception
将设定的效果写入原始图片文件中

抛出：
java.lang.Exception

writeImageToWCMData

java.lang.String writeImageToWCMData(java.lang.String _sPathFlag)
                                     throws java.lang.Exception
将图片写入到WCMData指定类型的目录中

参数：
_sPathFlag - WCMData目录类型，定义在FilesMan中
返回：
TODO
抛出：
java.lang.Exception

writeImage

void writeImage(java.lang.String _sNewDstFileName)
                throws java.lang.Exception
将设定的效果写入新定义的图片文件中

参数：
_sNewDstFileName - 新的图片文件(服务器上绝对物理地址或WCM有规则的文件名)
抛出：
java.lang.Exception

writeImageToSystemTemp

java.lang.String writeImageToSystemTemp()
                                        throws java.lang.Exception
将设定的效果写入到系统的临时目录中

返回：
绝对路径的文件名
抛出：
java.lang.Exception

scaleImage

byte[] scaleImage(int _nWidth,
                  int _nHeight)
                  throws java.lang.Exception
将指定的图片按照指定的宽度和高度缩放

参数：
_nWidth - 宽度(如果小于等于0，按照高度等比例缩放)
_nHeight - 高度(如果小于等于0，按照宽度等比例缩放)
返回：
TODO
抛出：
java.lang.Exception

rotateImage

byte[] rotateImage(double _dDegrees)
                   throws java.lang.Exception
按照指定的角度旋转突破

参数：
_dDegrees - 指定的角度
返回：
TODO
抛出：
java.lang.Exception

borderImage

byte[] borderImage(java.lang.String _sBoderColor,
                   int _nWidth,
                   int _nHeight)
                   throws java.lang.Exception
给图片加上边框

参数：
_sBoderColor - 边框颜色
_nWidth - 宽度
_nHeight - 高度
返回：
TODO
抛出：
java.lang.Exception

setBackgroundColor

void setBackgroundColor(java.lang.String _sBgColor)
                        throws java.lang.Exception
设置背景颜色

参数：
_sBgColor - 背景颜色
抛出：
java.lang.Exception

raiseImage

byte[] raiseImage(int _nWidth,
                  int _nHeight,
                  boolean _bRaised)
                  throws java.lang.Exception
突起效果

参数：
_nWidth - 宽度
_nHeight - 高度
_bRaised - 凸起(true)或凹下(false)
返回：
TODO
抛出：
java.lang.Exception

convertImageFormat

byte[] convertImageFormat(java.lang.String _sNewImageFormat)
                          throws java.lang.Exception
设置需要转换的图片格式

参数：
_sNewImageFormat - 图片格式（gif, jpeg, jpg）
返回：
TODO
抛出：
java.lang.Exception

addWaterMark

byte[] addWaterMark(java.lang.String _sWaterImageFile,
                    int[] _pWarterMarkPos)
                    throws java.lang.Exception
添加图片水印

参数：
_sWaterImageFile - 图片水印文件（绝对地址）
_pWarterMarkPos - 水印位置，定义在@see ImageLibConstants中
返回：
TODO
抛出：
java.lang.Exception

montageImages

void montageImages(java.lang.String[] _pImageFileName,
                   java.lang.String _sImageTitle,
                   java.lang.String _sDstImageFile,
                   java.lang.String _sBgColor,
                   java.lang.String _sBorderColor,
                   int _nBorderWidth)
                   throws java.lang.Exception
生成组图

参数：
_pImageFileName - 需要组合的图片文件名数组
_sImageTitle - TODO
_sDstImageFile - TODO
_sBgColor - TODO
_sBorderColor - TODO
_nBorderWidth - TODO
抛出：
java.lang.Exception

sharpenImage

byte[] sharpenImage(double raduis,
                    double sigma)
                    throws java.lang.Exception
锐化图片

参数：
raduis -
sigma -
返回：
TODO
抛出：
java.lang.Exception

setImageAttribute

void setImageAttribute(java.lang.String _sAttrName,
                       java.lang.String _sValue)
                       throws java.lang.Exception
设置图片的属性

参数：
_sAttrName - 属性名称，例如：Comment、Author等，符合IPTCC即可
_sValue - 属性值
抛出：
java.lang.Exception

getWidth

double getWidth()
                throws java.lang.Exception
获取图片的高度

返回：
图片的高度
抛出：
java.lang.Exception

getHeight

double getHeight()
                 throws java.lang.Exception
获取图片的高度

返回：
图片的高度
抛出：
java.lang.Exception

getSize

int getSize()
            throws java.lang.Exception
获得图片大小

返回：
抛出：
java.lang.Exception

setOutputImageFileExt

void setOutputImageFileExt(java.lang.String _sImageFileExt)
设置输出图片文件的后缀名

参数：
_sImageFileExt -

getSrcImageFileName

java.lang.String getSrcImageFileName()
获取原始的图片文件名

返回：
原始的图片文件名

scaleImage

void scaleImage(int _nWidth,
                int _nHeight,
                java.lang.String _sDstFile)
                throws java.lang.Exception
抛出：
java.lang.Exception

cropImage

void cropImage(int x,
               int y,
               int width,
               int height,
               java.lang.String _sDstFile)
               throws java.lang.Exception
裁剪图片

参数：
x -
y -
width -
height -
_sDstFile -
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.wcm.photo
接口
IImageLibConfig
IImageLibMgr
IImageLibService
IMagicImage
类
DocumentLCLisenterForPhoto
ImageInfo
ImageKind
ImageLibConstants
ImageLibHelper
Watermark
Watermarks


com.trs.wcm.photo

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcm.photo

接口摘要
IImageLibConfig | Title: TRS 内容协作平台（TRS WCM） Description: 图片库配置信息管理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IImageLibMgr | Title: TRS 内容协作平台（TRS WCM） Description: 图片业务处理对象的接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IImageLibService | Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务层接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IMagicImage | Title: TRS 内容协作平台（TRS WCM） Description: 图片处理对象（例如：缩放、锐化、凸起等） Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
DocumentLCLisenterForPhoto | Title: TRS 内容协作平台（TRS WCM） Description: 图片删除监听器 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ImageInfo | Title: TRS 内容协作平台（TRS WCM） Description: 新上传的图片信息描述对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImageKind | Title: TRS 内容协作平台（TRS WCM） Description: 图片分类对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImageLibConstants | Title: TRS 内容协作平台（TRS WCM） Description: 图片库常量定义对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImageLibHelper |
Watermark |
Watermarks |


com.trs.wcm.photo 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcm.photo 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.persistent.BaseObj (implements java.lang.Cloneable)
      • com.trs.cms.content.CMSObj
        • com.trs.wcm.photo.Watermark
    • com.trs.infra.persistent.BaseObjs
      • com.trs.cms.content.CMSBaseObjs
        • com.trs.wcm.photo.Watermarks
    • com.trs.wcm.photo.DocumentLCLisenterForPhoto (implements com.trs.infra.persistent.listener.IObjectLCListenerOnDel)
    • com.trs.wcm.photo.ImageInfo (implements java.lang.Cloneable)
    • com.trs.wcm.photo.ImageKind
    • com.trs.wcm.photo.ImageLibConstants
    • com.trs.wcm.photo.ImageLibHelper

接口分层结构

  • com.trs.wcm.photo.IImageLibConfig
  • com.trs.wcm.photo.IImageLibMgr
  • com.trs.wcm.photo.IImageLibService
  • com.trs.wcm.photo.IMagicImage


软件包 com.trs.wcm.photo 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcm.photo
的使用

使用 com.trs.wcm.photo 的软件包
com.trs.wcm.photo
com.trs.wcm.photo.impl

com.trs.wcm.photo 使用的 com.trs.wcm.photo 中的类
ImageInfo
Title: TRS 内容协作平台（TRS WCM）
Description:
新上传的图片信息描述对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImageKind
Title: TRS 内容协作平台（TRS WCM）
Description:
图片分类对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Watermark
Watermarks

com.trs.wcm.photo.impl 使用的 com.trs.wcm.photo 中的类
IImageLibConfig
Title: TRS 内容协作平台（TRS WCM）
Description:
图片库配置信息管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IImageLibMgr
Title: TRS 内容协作平台（TRS WCM）
Description:
图片业务处理对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IImageLibService
Title: TRS 内容协作平台（TRS WCM）
Description:
图片选件服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImageInfo
Title: TRS 内容协作平台（TRS WCM）
Description:
新上传的图片信息描述对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IMagicImage
Title: TRS 内容协作平台（TRS WCM）
Description:
图片处理对象（例如：缩放、锐化、凸起等）
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


Watermark

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
类 Watermark

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObj
        继承者  com.trs.cms.content.CMSObj
            继承者  com.trs.wcm.photo.Watermark
所有已实现的接口：
java.lang.Cloneable
public class Watermark
extends CMSObj

字段摘要
static java.lang.String | DB_ID_NAME 对象数据存储的ID字段名
static java.lang.String | DB_TABLE_NAME 对象数据存储的数据库名
static int | OBJ_TYPE 对象类型编号
构造方法摘要
Watermark()
构造函数：保留默认接口
方法摘要
static Watermark | createNewInstance() 产生当前对象[Watermark]的实例
int | delete(User _currUser) 从数据中删除对象信息
static Watermark | findById(int _nId) 提取指定ID的对象
static Watermark | findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象
java.lang.String | getDbTableName() 取对象数据存储的数据表名称
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
int | getLibId()
int | getWCMType() 取得该对象的类型编号
java.lang.String | getWMName() 提取属性：WMName
java.lang.String | getWMPicture() 提取属性：WMPicture
void | insert(User _currUser) 将对象数据写入数据库
boolean | isValid() 检验对象数据有效性
void | save(User _currUser) 对象保存自己
boolean | setLibId(int _nLibId)
boolean | setWMName(java.lang.String _sWMName) 设置属性：WMName
boolean | setWMPicture(java.lang.String _sWMPicture) 设置属性：WMPicture
java.lang.String | toString()
从类 com.trs.cms.content.CMSObj 继承的方法
cancelUpdate, canEdit, canEdit, delete, getCrUser, getCrUserName, getLocker, getLockerUser, getLockerUserName, isLocked, lock, lock, save, setCrUser, setCrUser, unlock, update, validCanDeleteAndLock, validCanEditAndLock, validCanEditAndLock
从类 com.trs.infra.persistent.BaseObj 继承的方法
cancelUpdate, checkExists, clone, cloneProperties, cloneToNewObj, cloneToNewWCMObj, containsNewProperty, containsProperty, createNewInstance, createNewInstance, equals, equals, findById, findById, findByKey, getAllProperty, getAttribute, getAttributesString, getAttributeValue, getCacheIndex, getClassName, getCrTime, getFinalPropertyAsString, getFinalPropertyAsString, getId, getKey, getNewAttribute, getNewAttributesString, getNewAttributeValue, getNewProperties, getNewProperty, getNewPropertyAsInt, getNewPropertyAsString, getProperties, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsDouble, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, getPropertyAsString, insert, isAddMode, isCached, isChangeProperty, isGetPropertyFromNew, isModified, isModified, isValidInstance, loadById, loadById, readFromRs, readFromRs, refreshProperty, refreshProperty, refreshProperty, refreshProperty, refreshProperty, releaseProperty, reload, removeProperty, setAttribute, setAttribute, setAttribute, setGetPropertyFromNew, setId, setLoadText, setNewProperties, setNextId, setProperties, setProperty, setProperty, setProperty, setProperty, setProperty, setPropertyWithString, setTextProperty, update
从类 java.lang.Object 继承的方法
getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJ_TYPE

public static final int OBJ_TYPE
对象类型编号

另请参见：
常量字段值

DB_TABLE_NAME

public static final java.lang.String DB_TABLE_NAME
对象数据存储的数据库名

另请参见：
常量字段值

DB_ID_NAME

public static final java.lang.String DB_ID_NAME
对象数据存储的ID字段名

另请参见：
常量字段值
构造方法详细信息

Watermark

public Watermark()
构造函数：保留默认接口

方法详细信息

getDbTableName

public java.lang.String getDbTableName()
取对象数据存储的数据表名称

指定者：
类 BaseObj 中的 getDbTableName
返回：
对象数据存储的数据表名称

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObj 中的 getIdFieldName
返回：
ID字段名

getWCMType

public int getWCMType()
取得该对象的类型编号

指定者：
类 BaseObj 中的 getWCMType
返回：
对象的类型编号

getWMName

public java.lang.String getWMName()
提取属性：WMName

返回：
WMName

setWMName

public boolean setWMName(java.lang.String _sWMName)
                  throws WCMException
设置属性：WMName

参数：
_sWMName - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getWMPicture

public java.lang.String getWMPicture()
提取属性：WMPicture

返回：
WMPicture

setWMPicture

public boolean setWMPicture(java.lang.String _sWMPicture)
                     throws WCMException
设置属性：WMPicture

参数：
_sWMPicture - 属性值
返回：
若指定属性值有效，且属性设置成功，则返回true；否则返回false.
抛出：
WCMException - 属性值无效或设置失败，会抛出异常。

getLibId

public int getLibId()

setLibId

public boolean setLibId(int _nLibId)
                 throws WCMException
抛出：
WCMException

isValid

public boolean isValid()
                throws WCMException
检验对象数据有效性

指定者：
类 BaseObj 中的 isValid
返回：
若对象数据设置有效，则返回true；否则返回false.
抛出：
WCMException - 对象属性设置不完整，或属性值不正确，或对象重复，会抛出异常。

insert

public void insert(User _currUser)
            throws WCMException
将对象数据写入数据库

覆盖：
类 CMSObj 中的 insert
参数：
_currUser - 当前操作用户
抛出：
WCMException - 写入数据失败，会抛出异常。

findById

public static final Watermark findById(int _nId)
                                throws WCMException
提取指定ID的对象

参数：
_nId - 指定的对象ID
返回：
若找到指定ID的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

createNewInstance

public static final Watermark createNewInstance()
                                         throws WCMException
产生当前对象[Watermark]的实例

返回：
当前对象的实例[Watermark]
抛出：
WCMException

findByKey

public static final Watermark findByKey(java.lang.Object _oKey)
                                 throws WCMException
提取指定缓冲区Key的对象

参数：
_oKey - 指定缓冲区的Key
返回：
若找到缓冲区Key的对象，则返回对象实体；否则，返回null。
抛出：
WCMException - 若提取对象失败，会抛出异常。

save

public void save(User _currUser)
          throws WCMException
从类 CMSObj 复制的描述
对象保存自己

覆盖：
类 CMSObj 中的 save
参数：
_currUser - 当前操作用户
抛出：
WCMException

toString

public java.lang.String toString()
覆盖：
类 CMSObj 中的 toString

delete

public int delete(User _currUser)
           throws WCMException
从类 CMSObj 复制的描述
从数据中删除对象信息

覆盖：
类 CMSObj 中的 delete
参数：
_currUser - 当前操作用户
返回：
返回值：删除的记录条数。为0时，表示没有找到
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Watermarks

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo
类 Watermarks

java.lang.Object
    继承者  com.trs.infra.persistent.BaseObjs
        继承者  com.trs.cms.content.CMSBaseObjs
            继承者  com.trs.wcm.photo.Watermarks

public class Watermarks
extends CMSBaseObjs

字段摘要
从类 com.trs.infra.persistent.BaseObjs 继承的字段
BOOKMARK_CURRENT, BOOKMARK_FIRST, BOOKMARK_LAST, DEBUG_USE_TIME, ID_NOT_LOAD, IS_DEBUG
构造方法摘要
Watermarks(User _currUser)
构造函数
Watermarks(User _currUser, int _initCapacity, int _incCapacity)
构造函数
方法摘要
static Watermarks | createNewInstance(User _currUser) 产生当前集合对象[Watermarks]的实例
void | deleteAll(boolean _bDrop)
static Watermarks | findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
java.lang.Class | getElementClass() 取集合元素类
java.lang.String | getIdFieldName() 取对象数据存储的ID字段名
BaseObjs | newInstance() 生成新的集合对象实例
static Watermarks | openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Watermarks]
从类 com.trs.cms.content.CMSBaseObjs 继承的方法
cancelUpdate, cancelUpdateAll, cancelUpdateAll, canEdit, canEdit, canEditAll, createInstance, createInstance, findWCMObjsByIds, findWCMObjsByIds, getCurrUser, openWCMObjs, openWCMObjs, setCurrUser
从类 com.trs.infra.persistent.BaseObjs 继承的方法
addElement, addElement, addElement, addElement, addElement, addElement, addElements, addNew, addWith, clear, createInstance, createInstance, filter, getAt, getById, getCacheIndex, getClassName, getCurrent, getCurrPage, getFilter, getIdAt, getIdListAsString, getIdListAsString, getMaxBufferSize, getMaxSize, getPageCount, getPageSize, getParent, getQueryCount, getRecCount, getSelectCount, indexOf, indexOf, indexOf, indexOf, isBOF, isCached, isEmpty, isEOF, isValidSQL, loadObjsOfCurrPage, minusWith, move, move, moveFirst, moveLast, moveNext, movePrevious, moveTo, open, position, refresh, reloadSpecailData, remove, remove, remove, remove, remove, remove, removeAll, removeAll, removeAt, removeAt, set, setCurrPage, setFilter, setLoadText, setMaxBufferSize, setMaxSize, setOrder, setPageSize, setRecCount, setSelect, size, update
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Watermarks

public Watermarks(User _currUser)
构造函数

另请参见：
Watermarks( User _currUser, int _initCapacity, int _incCapacity );

Watermarks

public Watermarks(User _currUser,
                  int _initCapacity,
                  int _incCapacity)
构造函数

参数：
_currUser - 当前操作用户
_initCapacity - 初始化容量
_incCapacity - 当容量不足时，每次增容量
方法详细信息

getIdFieldName

public java.lang.String getIdFieldName()
取对象数据存储的ID字段名

指定者：
类 BaseObjs 中的 getIdFieldName
返回：
ID字段名

getElementClass

public java.lang.Class getElementClass()
取集合元素类

指定者：
类 BaseObjs 中的 getElementClass
返回：
集合元素类

findByIds

public static final Watermarks findByIds(User _currUser,
                                         java.lang.String _sIds)
提取指定ID序列的对象集合

参数：
_sIds - 指定的对象ID序列
返回：
指定对象集合（Watermarks）
抛出：
WCMException - 若提取对象失败，会抛出异常。

openWCMObjs

public static final Watermarks openWCMObjs(User _currUser,
                                           WCMFilter _filter)
                                    throws WCMException
通过指定一个Filter获取当前集合[Watermarks]

参数：
_filter - 指定的Filter
返回：
当前集合[Watermarks]
抛出：
WCMException

createNewInstance

public static Watermarks createNewInstance(User _currUser)
产生当前集合对象[Watermarks]的实例

参数：
_currUser - 当前操作用户
返回：
抛出：
WCMException

newInstance

public BaseObjs newInstance()
                     throws java.lang.Exception
从类 BaseObjs 复制的描述
生成新的集合对象实例

指定者：
类 BaseObjs 中的 newInstance
返回：
子类必须重载，用于生成子集
抛出：
java.lang.Exception

deleteAll

public void deleteAll(boolean _bDrop)
               throws WCMException
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.wcm.photo.DocumentLCLisenterForPhoto 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.DocumentLCLisenterForPhoto
的使用

没有 com.trs.wcm.photo.DocumentLCLisenterForPhoto 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.wcm.photo.IImageLibConfig 的使用

上一个 下一个 框架 无框架

接口 com.trs.wcm.photo.IImageLibConfig
的使用

使用 IImageLibConfig 的软件包
com.trs.wcm.photo.impl

com.trs.wcm.photo.impl 中 IImageLibConfig 的使用

实现 IImageLibConfig 的 com.trs.wcm.photo.impl 中的类
 class ImageLibConfigImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
图片库配置信息管理默认实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.wcm.photo.IImageLibMgr 的使用

上一个 下一个 框架 无框架

接口 com.trs.wcm.photo.IImageLibMgr
的使用

使用 IImageLibMgr 的软件包
com.trs.wcm.photo.impl

com.trs.wcm.photo.impl 中 IImageLibMgr 的使用

实现 IImageLibMgr 的 com.trs.wcm.photo.impl 中的类
 class ImageLibMgrImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
图片库业务逻辑处理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.wcm.photo.IImageLibService 的使用

上一个 下一个 框架 无框架

接口 com.trs.wcm.photo.IImageLibService
的使用

使用 IImageLibService 的软件包
com.trs.wcm.photo.impl

com.trs.wcm.photo.impl 中 IImageLibService 的使用

实现 IImageLibService 的 com.trs.wcm.photo.impl 中的类
 class ImageLibServiceImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
图片服务的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.ImageInfo 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.ImageInfo
的使用

使用 ImageInfo 的软件包
com.trs.wcm.photo
com.trs.wcm.photo.impl

com.trs.wcm.photo 中 ImageInfo 的使用

返回 ImageInfo 的 com.trs.wcm.photo 中的方法
ImageInfo | IImageLibService.importImageAppendix(int _nAppendixId, ImageInfo _imageInfo) 导入单个的图片到指定的分类中
ImageInfo[] | IImageLibService.importImageAppendix(java.lang.String _sAppendixIds, ImageInfo _imageInfo) 导入指定的图片到指定的分类中
ImageInfo | IImageLibMgr.importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo) 导入指定的图片到图片库指定的分类中
ImageInfo | IImageLibService.saveImageInfo(ImageInfo _imageInfo) 保存图片信息到图片库中
ImageInfo | IImageLibMgr.saveImageInfo(ImageInfo _imageInfo)

参数类型为 ImageInfo 的 com.trs.wcm.photo 中的方法
ImageInfo | IImageLibService.importImageAppendix(int _nAppendixId, ImageInfo _imageInfo) 导入单个的图片到指定的分类中
ImageInfo[] | IImageLibService.importImageAppendix(java.lang.String _sAppendixIds, ImageInfo _imageInfo) 导入指定的图片到指定的分类中
ImageInfo | IImageLibMgr.importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo) 导入指定的图片到图片库指定的分类中
ImageInfo | IImageLibService.saveImageInfo(ImageInfo _imageInfo) 保存图片信息到图片库中
ImageInfo | IImageLibMgr.saveImageInfo(ImageInfo _imageInfo)

com.trs.wcm.photo.impl 中 ImageInfo 的使用

返回 ImageInfo 的 com.trs.wcm.photo.impl 中的方法
ImageInfo | ImageLibServiceImpl.importImageAppendix(int _nAppendixId, ImageInfo _imageInfo)
ImageInfo[] | ImageLibServiceImpl.importImageAppendix(java.lang.String _sAppendixIds, ImageInfo _imageInfo)
ImageInfo | ImageLibMgrImpl.importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo)
ImageInfo | ImageLibServiceImpl.saveImageInfo(ImageInfo _imageInfo)
ImageInfo | ImageLibMgrImpl.saveImageInfo(ImageInfo _imageInfo)

参数类型为 ImageInfo 的 com.trs.wcm.photo.impl 中的方法
ImageInfo | ImageLibServiceImpl.importImageAppendix(int _nAppendixId, ImageInfo _imageInfo)
ImageInfo[] | ImageLibServiceImpl.importImageAppendix(java.lang.String _sAppendixIds, ImageInfo _imageInfo)
ImageInfo | ImageLibMgrImpl.importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo)
ImageInfo | ImageLibServiceImpl.saveImageInfo(ImageInfo _imageInfo)
ImageInfo | ImageLibMgrImpl.saveImageInfo(ImageInfo _imageInfo)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.ImageKind 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.ImageKind
的使用

使用 ImageKind 的软件包
com.trs.wcm.photo

com.trs.wcm.photo 中 ImageKind 的使用

返回 ImageKind 的 com.trs.wcm.photo 中的方法
static ImageKind ImageKind.findById(int _nImageKindId)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.ImageLibConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.ImageLibConstants
的使用

没有 com.trs.wcm.photo.ImageLibConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.ImageLibHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.ImageLibHelper
的使用

没有 com.trs.wcm.photo.ImageLibHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.wcm.photo.IMagicImage 的使用

上一个 下一个 框架 无框架

接口 com.trs.wcm.photo.IMagicImage
的使用

使用 IMagicImage 的软件包
com.trs.wcm.photo.impl

com.trs.wcm.photo.impl 中 IMagicImage 的使用

实现 IMagicImage 的 com.trs.wcm.photo.impl 中的类
 class MagicImageImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.Watermark 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.Watermark
的使用

使用 Watermark 的软件包
com.trs.wcm.photo

com.trs.wcm.photo 中 Watermark 的使用

返回 Watermark 的 com.trs.wcm.photo 中的方法
static Watermark | Watermark.createNewInstance() 产生当前对象[Watermark]的实例
static Watermark | Watermark.findById(int _nId) 提取指定ID的对象
static Watermark | Watermark.findByKey(java.lang.Object _oKey) 提取指定缓冲区Key的对象

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.Watermarks 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.Watermarks
的使用

使用 Watermarks 的软件包
com.trs.wcm.photo

com.trs.wcm.photo 中 Watermarks 的使用

返回 Watermarks 的 com.trs.wcm.photo 中的方法
static Watermarks | Watermarks.createNewInstance(User _currUser) 产生当前集合对象[Watermarks]的实例
static Watermarks | Watermarks.findByIds(User _currUser, java.lang.String _sIds) 提取指定ID序列的对象集合
static Watermarks | Watermarks.openWCMObjs(User _currUser, WCMFilter _filter) 通过指定一个Filter获取当前集合[Watermarks]

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AutoImageLibUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 AutoImageLibUtil

java.lang.Object
    继承者  com.trs.wcm.photo.impl.AutoImageLibUtil

public class AutoImageLibUtil
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
自动保存图片进库
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

方法摘要
static void saveImage(java.lang.String _fn, User _user)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

saveImage

public static void saveImage(java.lang.String _fn,
                             User _user)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ImageLibConfigImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 ImageLibConfigImpl

java.lang.Object
    继承者  com.trs.wcm.photo.impl.ImageLibConfigImpl
所有已实现的接口：
IImageLibConfig
public class ImageLibConfigImpl
extends java.lang.Object
implements IImageLibConfig

Title: TRS 内容协作平台（TRS WCM）
Description:
图片库配置信息管理默认实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从接口 com.trs.wcm.photo.IImageLibConfig 继承的字段
SCALE_STYLE_AUTO, SCALE_STYLE_HEIGHT, SCALE_STYLE_WIDTH
构造方法摘要
ImageLibConfigImpl()
方法摘要
java.lang.String | getDefaultConvertImageFileExt() 获取默认转换的图片格式
Template | getDefaultDetailTemplate() 获取图片库分类默认的细览模板
int | getDefaultDetailTemplateId() 获取图片库分类默认的细览模板ID
Template | getDefaultOutlineTemplate() 获取图片库分类默认的概览模板
int | getDefaultOutlineTemplateId() 获取图片库分类默认的概览模板ID
int[] | getOtherRelatedKindIds() 获取其它的默认分类
java.lang.String | getRelatedConvertType() 获取bmp文件转换格式
int | getRelatedKindId() 获取默认主分类
int | getRelatedWaterMarkId() 获取水印
int[] | getRelatedWaterMarkPos() 获取水印位置
WebSite | getRelateSite() 获取与图片库相关的站点
int | getRelateSiteId() 获取与图片库相关的站点ID
java.lang.String | getScaleDescAt(int _nScaleIndex) 获取指定尺寸索引的描述
int[] | getScaleSizes() 获取图片库默认定义的各种缩放尺寸
java.lang.String | getScaleStyle()
java.lang.String[] | getSupportImageFileExt() 获取系统支持的各种图片文件格式
int | getWaterMarkSize(int _nImageWidth) 获取指定图片宽度设置的水印大小
boolean | isAutoEnable() 是否启动文档中的图片自动保存到图片库中
boolean | isCmdUsed()
boolean | isInstalled()
boolean | isOriginalMarked()
boolean | isSupportImageFileExt(java.lang.String _sImageFileExt) 判断当前图片文件格式是否在系统支持系列中
boolean | reloadConfig() 重新装载图片库配置信息
boolean | saveConfig() 保存图片库的设置
void | setAtuoEnable(boolean _enable) 设置是否启动文档中的图片自动保存到图片库中
void | setDefaultTemplateId(int _nOutlineTemplateId, int _nDetailTemplateId) 设置默认的模板信息
void | setImageFileExt(java.lang.String[] _pSupportFileExt, java.lang.String _sDefaultConvertFileExt) 设置支持的图片格式和默认的转换图片
void | setInstalled()
void | setOtherRelatedKindIds(java.lang.String _ids) 设置其它的默认分类
void | setRealtedKindId(int _id) 设置默认主分类
void | setRelatedConvertType(java.lang.String _type) 设置bmp文件转换格式
void | setRelatedWaterMarkId(int _id) 设置水印
void | setRelatedWaterMarkPos(java.lang.String _pos) 设置水印位置
void | setRelateSiteId(int _nRelateId) 设置相关站点
void | setScaleSizes(int[] _pScaleSize, java.lang.String[] _pScaleSizeDesc, int[] _pWaterMarkSize) 设置图片库自动缩放的图片尺寸、描述以及添加的水印大小
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageLibConfigImpl

public ImageLibConfigImpl()
方法详细信息

getRelateSite

public WebSite getRelateSite()
                      throws WCMException
从接口 IImageLibConfig 复制的描述
获取与图片库相关的站点

指定者：
接口 IImageLibConfig 中的 getRelateSite
返回：
与图片库相关的站点对象(WebSite)
抛出：
WCMException

getRelateSiteId

public int getRelateSiteId()
                    throws WCMException
从接口 IImageLibConfig 复制的描述
获取与图片库相关的站点ID

指定者：
接口 IImageLibConfig 中的 getRelateSiteId
返回：
与图片库相关的站点ID
抛出：
WCMException

getDefaultOutlineTemplate

public Template getDefaultOutlineTemplate()
                                   throws WCMException
从接口 IImageLibConfig 复制的描述
获取图片库分类默认的概览模板

指定者：
接口 IImageLibConfig 中的 getDefaultOutlineTemplate
返回：
图片库分类默认的概览模板对象(Template)
抛出：
WCMException

getDefaultOutlineTemplateId

public int getDefaultOutlineTemplateId()
                                throws WCMException
从接口 IImageLibConfig 复制的描述
获取图片库分类默认的概览模板ID

指定者：
接口 IImageLibConfig 中的 getDefaultOutlineTemplateId
返回：
图片库分类默认的概览模板ID
抛出：
WCMException

getDefaultDetailTemplate

public Template getDefaultDetailTemplate()
                                  throws WCMException
从接口 IImageLibConfig 复制的描述
获取图片库分类默认的细览模板

指定者：
接口 IImageLibConfig 中的 getDefaultDetailTemplate
返回：
图片库分类默认的细览模板对象(Template)
抛出：
WCMException

getDefaultDetailTemplateId

public int getDefaultDetailTemplateId()
                               throws WCMException
从接口 IImageLibConfig 复制的描述
获取图片库分类默认的细览模板ID

指定者：
接口 IImageLibConfig 中的 getDefaultDetailTemplateId
返回：
图片库分类默认的细览模板ID
抛出：
WCMException

getScaleSizes

public int[] getScaleSizes()
                    throws WCMException
从接口 IImageLibConfig 复制的描述
获取图片库默认定义的各种缩放尺寸

指定者：
接口 IImageLibConfig 中的 getScaleSizes
返回：
各种尺寸大小
抛出：
WCMException

getSupportImageFileExt

public java.lang.String[] getSupportImageFileExt()
                                          throws WCMException
从接口 IImageLibConfig 复制的描述
获取系统支持的各种图片文件格式

指定者：
接口 IImageLibConfig 中的 getSupportImageFileExt
返回：
图片文件格式字符串数组
抛出：
WCMException

isSupportImageFileExt

public boolean isSupportImageFileExt(java.lang.String _sImageFileExt)
                              throws WCMException
从接口 IImageLibConfig 复制的描述
判断当前图片文件格式是否在系统支持系列中

指定者：
接口 IImageLibConfig 中的 isSupportImageFileExt
参数：
_sImageFileExt - 图片文件格式后缀
返回：
如果支持，返回true；否则返回false
抛出：
WCMException

getDefaultConvertImageFileExt

public java.lang.String getDefaultConvertImageFileExt()
                                               throws WCMException
从接口 IImageLibConfig 复制的描述
获取默认转换的图片格式

指定者：
接口 IImageLibConfig 中的 getDefaultConvertImageFileExt
返回：
抛出：
WCMException

reloadConfig

public boolean reloadConfig()
                     throws WCMException
从接口 IImageLibConfig 复制的描述
重新装载图片库配置信息

指定者：
接口 IImageLibConfig 中的 reloadConfig
返回：
装载成功，返回true
抛出：
WCMException

getWaterMarkSize

public int getWaterMarkSize(int _nImageWidth)
                     throws WCMException
从接口 IImageLibConfig 复制的描述
获取指定图片宽度设置的水印大小

指定者：
接口 IImageLibConfig 中的 getWaterMarkSize
参数：
_nImageWidth - 指定的图片宽度
返回：
>=0的整数，如果指定的宽度没有允许加水印，返回0
抛出：
WCMException

getScaleDescAt

public java.lang.String getScaleDescAt(int _nScaleIndex)
                                throws WCMException
从接口 IImageLibConfig 复制的描述
获取指定尺寸索引的描述

指定者：
接口 IImageLibConfig 中的 getScaleDescAt
参数：
_nScaleIndex - 指定尺寸索引，从0开始，和配置文件中一一对应
返回：
描述信心（String）
抛出：
WCMException

saveConfig

public boolean saveConfig()
                   throws WCMException
从接口 IImageLibConfig 复制的描述
保存图片库的设置

指定者：
接口 IImageLibConfig 中的 saveConfig
返回：
抛出：
WCMException

setDefaultTemplateId

public void setDefaultTemplateId(int _nOutlineTemplateId,
                                 int _nDetailTemplateId)
                          throws WCMException
从接口 IImageLibConfig 复制的描述
设置默认的模板信息

指定者：
接口 IImageLibConfig 中的 setDefaultTemplateId
抛出：
WCMException

setImageFileExt

public void setImageFileExt(java.lang.String[] _pSupportFileExt,
                            java.lang.String _sDefaultConvertFileExt)
                     throws WCMException
从接口 IImageLibConfig 复制的描述
设置支持的图片格式和默认的转换图片

指定者：
接口 IImageLibConfig 中的 setImageFileExt
抛出：
WCMException

setScaleSizes

public void setScaleSizes(int[] _pScaleSize,
                          java.lang.String[] _pScaleSizeDesc,
                          int[] _pWaterMarkSize)
                   throws WCMException
从接口 IImageLibConfig 复制的描述
设置图片库自动缩放的图片尺寸、描述以及添加的水印大小

指定者：
接口 IImageLibConfig 中的 setScaleSizes
参数：
_pScaleSize - 缩放的图片尺寸（宽度）
_pScaleSizeDesc - 缩放的图片尺寸描述
_pWaterMarkSize - 、 不同尺寸对应的水印大小
抛出：
WCMException

setRelateSiteId

public void setRelateSiteId(int _nRelateId)
                     throws WCMException
从接口 IImageLibConfig 复制的描述
设置相关站点

指定者：
接口 IImageLibConfig 中的 setRelateSiteId
抛出：
WCMException

isAutoEnable

public boolean isAutoEnable()
                     throws WCMException
从接口 IImageLibConfig 复制的描述
是否启动文档中的图片自动保存到图片库中

指定者：
接口 IImageLibConfig 中的 isAutoEnable
返回：
如果该功能启动,则返回true
抛出：
WCMException

setAtuoEnable

public void setAtuoEnable(boolean _enable)
                   throws WCMException
从接口 IImageLibConfig 复制的描述
设置是否启动文档中的图片自动保存到图片库中

指定者：
接口 IImageLibConfig 中的 setAtuoEnable
抛出：
WCMException

getRelatedKindId

public int getRelatedKindId()
                     throws WCMException
从接口 IImageLibConfig 复制的描述
获取默认主分类

指定者：
接口 IImageLibConfig 中的 getRelatedKindId
返回：
抛出：
WCMException

setRealtedKindId

public void setRealtedKindId(int _id)
                      throws WCMException
从接口 IImageLibConfig 复制的描述
设置默认主分类

指定者：
接口 IImageLibConfig 中的 setRealtedKindId
抛出：
WCMException

getOtherRelatedKindIds

public int[] getOtherRelatedKindIds()
                             throws WCMException
从接口 IImageLibConfig 复制的描述
获取其它的默认分类

指定者：
接口 IImageLibConfig 中的 getOtherRelatedKindIds
返回：
抛出：
WCMException

setOtherRelatedKindIds

public void setOtherRelatedKindIds(java.lang.String _ids)
                            throws WCMException
从接口 IImageLibConfig 复制的描述
设置其它的默认分类

指定者：
接口 IImageLibConfig 中的 setOtherRelatedKindIds
抛出：
WCMException

getRelatedWaterMarkId

public int getRelatedWaterMarkId()
                          throws WCMException
从接口 IImageLibConfig 复制的描述
获取水印

指定者：
接口 IImageLibConfig 中的 getRelatedWaterMarkId
返回：
抛出：
WCMException

setRelatedWaterMarkId

public void setRelatedWaterMarkId(int _id)
                           throws WCMException
从接口 IImageLibConfig 复制的描述
设置水印

指定者：
接口 IImageLibConfig 中的 setRelatedWaterMarkId
抛出：
WCMException

getRelatedWaterMarkPos

public int[] getRelatedWaterMarkPos()
                             throws WCMException
从接口 IImageLibConfig 复制的描述
获取水印位置

指定者：
接口 IImageLibConfig 中的 getRelatedWaterMarkPos
返回：
抛出：
WCMException

setRelatedWaterMarkPos

public void setRelatedWaterMarkPos(java.lang.String _pos)
                            throws WCMException
从接口 IImageLibConfig 复制的描述
设置水印位置

指定者：
接口 IImageLibConfig 中的 setRelatedWaterMarkPos
抛出：
WCMException

getRelatedConvertType

public java.lang.String getRelatedConvertType()
                                       throws WCMException
从接口 IImageLibConfig 复制的描述
获取bmp文件转换格式

指定者：
接口 IImageLibConfig 中的 getRelatedConvertType
返回：
抛出：
WCMException

setRelatedConvertType

public void setRelatedConvertType(java.lang.String _type)
                           throws WCMException
从接口 IImageLibConfig 复制的描述
设置bmp文件转换格式

指定者：
接口 IImageLibConfig 中的 setRelatedConvertType
抛出：
WCMException

isInstalled

public boolean isInstalled()
                    throws WCMException
指定者：
接口 IImageLibConfig 中的 isInstalled
抛出：
WCMException

setInstalled

public void setInstalled()
                  throws WCMException
指定者：
接口 IImageLibConfig 中的 setInstalled
抛出：
WCMException

isCmdUsed

public boolean isCmdUsed()
                  throws WCMException
指定者：
接口 IImageLibConfig 中的 isCmdUsed
返回：
抛出：
WCMException

isOriginalMarked

public boolean isOriginalMarked()
                         throws WCMException
指定者：
接口 IImageLibConfig 中的 isOriginalMarked
抛出：
WCMException

getScaleStyle

public java.lang.String getScaleStyle()
                               throws WCMException
指定者：
接口 IImageLibConfig 中的 getScaleStyle
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageLibMgrImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 ImageLibMgrImpl

java.lang.Object
    继承者  com.trs.wcm.photo.impl.ImageLibMgrImpl
所有已实现的接口：
IImageLibMgr
public class ImageLibMgrImpl
extends java.lang.Object
implements IImageLibMgr

Title: TRS 内容协作平台（TRS WCM）
Description:
图片库业务逻辑处理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ImageLibMgrImpl()
方法摘要
void | deleteDocumentQuoteImage(int _nDocumentId) 删除指定文档的所有引用关系
void | deleteDocumentQuoteImage(int _nDocumentId, int _nImageId) 删除文档和指定图片引用关系
void | deleteDocumentQuoteImage(int _nDocumentId, java.lang.String _sExcludeImageIds) 删除指定文档的图片引用关系，不包括指定的图片ID
Documents | getDocumentsQuoteImage(int _nImageId) 获取使用指定图片的所有文档
Appendixes | getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片
ImageInfo | importImageAppendix(User _currUser, int _nAppendixId, ImageInfo _imageInfo) 导入指定的图片到图片库指定的分类中
void | recordDocumentQuoteImage(int _nDocumentId, int _nImageId) 记录文档和指定图片的引用关系
ImageInfo | saveImageInfo(ImageInfo _imageInfo)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageLibMgrImpl

public ImageLibMgrImpl()
方法详细信息

saveImageInfo

public ImageInfo saveImageInfo(ImageInfo _imageInfo)
                        throws WCMException
指定者：
接口 IImageLibMgr 中的 saveImageInfo
返回：
抛出：
WCMException

deleteDocumentQuoteImage

public void deleteDocumentQuoteImage(int _nDocumentId,
                                     int _nImageId)
                              throws WCMException
从接口 IImageLibMgr 复制的描述
删除文档和指定图片引用关系

指定者：
接口 IImageLibMgr 中的 deleteDocumentQuoteImage
参数：
_nDocumentId - 指定文档ID
_nImageId - 指定图片ID
抛出：
WCMException

deleteDocumentQuoteImage

public void deleteDocumentQuoteImage(int _nDocumentId,
                                     java.lang.String _sExcludeImageIds)
                              throws WCMException
从接口 IImageLibMgr 复制的描述
删除指定文档的图片引用关系，不包括指定的图片ID

指定者：
接口 IImageLibMgr 中的 deleteDocumentQuoteImage
参数：
_nDocumentId - 指定文档ID
_sExcludeImageIds - 排除的图片ＩＤ序列
抛出：
WCMException

deleteDocumentQuoteImage

public void deleteDocumentQuoteImage(int _nDocumentId)
                              throws WCMException
从接口 IImageLibMgr 复制的描述
删除指定文档的所有引用关系

指定者：
接口 IImageLibMgr 中的 deleteDocumentQuoteImage
参数：
_nDocumentId - 指定文档ID
抛出：
WCMException

getDocumentsQuoteImage

public Documents getDocumentsQuoteImage(int _nImageId)
                                 throws WCMException
从接口 IImageLibMgr 复制的描述
获取使用指定图片的所有文档

指定者：
接口 IImageLibMgr 中的 getDocumentsQuoteImage
参数：
_nImageId - 指定图片ID
返回：
抛出：
WCMException

recordDocumentQuoteImage

public void recordDocumentQuoteImage(int _nDocumentId,
                                     int _nImageId)
                              throws WCMException
从接口 IImageLibMgr 复制的描述
记录文档和指定图片的引用关系

指定者：
接口 IImageLibMgr 中的 recordDocumentQuoteImage
参数：
_nDocumentId - 文档ID
_nImageId - 图片ID
抛出：
WCMException

getImageAppendixes

public Appendixes getImageAppendixes(WCMFilter _extraFilter,
                                     BaseChannel _oChannelOrSite,
                                     boolean _bIncludeImported)
                              throws WCMException
从接口 IImageLibMgr 复制的描述
获取系统中已经存在的图片

指定者：
接口 IImageLibMgr 中的 getImageAppendixes
参数：
_extraFilter - 额外的查询条件
_bIncludeImported - 是否包含已经导入的 true:包含 false：不包含
返回：
抛出：
WCMException

importImageAppendix

public ImageInfo importImageAppendix(User _currUser,
                                     int _nAppendixId,
                                     ImageInfo _imageInfo)
                              throws WCMException
从接口 IImageLibMgr 复制的描述
导入指定的图片到图片库指定的分类中

指定者：
接口 IImageLibMgr 中的 importImageAppendix
参数：
_currUser - 当前的拥护
_nAppendixId - 指定的图片ID
_imageInfo - 图片处理机制
返回：
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageLibServiceImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 ImageLibServiceImpl

java.lang.Object
    继承者  com.trs.wcm.photo.impl.ImageLibServiceImpl
所有已实现的接口：
IImageLibService
public class ImageLibServiceImpl
extends java.lang.Object
implements IImageLibService

Title: TRS 内容协作平台（TRS WCM）
Description:
图片服务的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ImageLibServiceImpl()
方法摘要
void | clearQuotedImages(int _nDocId)
void | deleteImage(java.lang.String _sDocIds) 从图片库中删除指定的图片
void | deleteImage(java.lang.String _sDocIds, int _nChannelId) 从指定的分类中删除图片
java.util.List | getChannels(User _user, int _nRightIndex) 获取指定用户可见的图片库的一级分类
java.util.List | getChannels(User _user, int _nRightIndex, Channel _channel) 获取指定用户在指定分类可见的子分类列表
java.util.List | getChannels(User _user, int _nRightIndex, Channel _channel, WCMFilter _filter) 获取指定用户在指定分类可见的子分类列表
Documents | getDocuments(BaseChannel _oChannel, WCMFilter _filter) 获取当前分类下所有的图片
Documents | getDocumentsQuoteImage(int _nImageId) 获取使用指定图片的所有文档
Appendixes | getImageAppendixes(WCMFilter _extraFilter, BaseChannel _oChannelOrSite, boolean _bIncludeImported) 获取系统中已经存在的图片
ImageInfo | importImageAppendix(int _nAppendixId, ImageInfo _imageInfo) 导入单个的图片到指定的分类中
ImageInfo[] | importImageAppendix(java.lang.String _sAppendixIds, ImageInfo _imageInfo) 导入指定的图片到指定的分类中
void | quoteImages(int _nDocId, java.lang.String _sQuoteImageIds) 保存指定文档引用图片的关系
Document | saveImageDetail(Document _document) 保存图片的标注信息(标题、作者、地点、人物、时间)
ImageInfo | saveImageInfo(ImageInfo _imageInfo) 保存图片信息到图片库中
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageLibServiceImpl

public ImageLibServiceImpl()
方法详细信息

deleteImage

public void deleteImage(java.lang.String _sDocIds)
                 throws WCMException
从接口 IImageLibService 复制的描述
从图片库中删除指定的图片

指定者：
接口 IImageLibService 中的 deleteImage
参数：
_sDocIds - 图片ID系列
抛出：
WCMException

deleteImage

public void deleteImage(java.lang.String _sDocIds,
                        int _nChannelId)
                 throws WCMException
从接口 IImageLibService 复制的描述
从指定的分类中删除图片

指定者：
接口 IImageLibService 中的 deleteImage
参数：
_sDocIds - 指定的图片ID序列
_nChannelId - 指定的分类
抛出：
WCMException

getChannels

public java.util.List getChannels(User _user,
                                  int _nRightIndex)
                           throws WCMException
从接口 IImageLibService 复制的描述
获取指定用户可见的图片库的一级分类

指定者：
接口 IImageLibService 中的 getChannels
参数：
_user - 指定用户
_nRightIndex - 指定的权限，定义在WCMRightTypes中
返回：
一级分类集合(Channels)
抛出：
WCMException

getChannels

public java.util.List getChannels(User _user,
                                  int _nRightIndex,
                                  Channel _channel)
                           throws WCMException
从接口 IImageLibService 复制的描述
获取指定用户在指定分类可见的子分类列表

指定者：
接口 IImageLibService 中的 getChannels
参数：
_user - 指定用户
_nRightIndex - 指定的权限，定义在WCMRightTypes中
_channel - 指定的频道
返回：
抛出：
WCMException

getChannels

public java.util.List getChannels(User _user,
                                  int _nRightIndex,
                                  Channel _channel,
                                  WCMFilter _filter)
                           throws WCMException
从接口 IImageLibService 复制的描述
获取指定用户在指定分类可见的子分类列表

指定者：
接口 IImageLibService 中的 getChannels
参数：
_user - 指定用户
_nRightIndex - 指定的权限，定义在WCMRightTypes中
_channel - 指定的频道
_filter - 额外的检索条件
返回：
抛出：
WCMException

getDocuments

public Documents getDocuments(BaseChannel _oChannel,
                              WCMFilter _filter)
                       throws WCMException
从接口 IImageLibService 复制的描述
获取当前分类下所有的图片

指定者：
接口 IImageLibService 中的 getDocuments
参数：
_oChannel - 当前分类对象（所有或者指定分类）,如果null，表示所有分类
_filter - 过滤器,额外的查询条件
返回：
图片集合(Documents)
抛出：
WCMException

saveImageDetail

public Document saveImageDetail(Document _document)
                         throws WCMException
从接口 IImageLibService 复制的描述
保存图片的标注信息(标题、作者、地点、人物、时间)

指定者：
接口 IImageLibService 中的 saveImageDetail
返回：
抛出：
WCMException

saveImageInfo

public ImageInfo saveImageInfo(ImageInfo _imageInfo)
                        throws WCMException
从接口 IImageLibService 复制的描述
保存图片信息到图片库中

指定者：
接口 IImageLibService 中的 saveImageInfo
参数：
_imageInfo - 用户上传的图片对象(ImageInfo) 包含自动操作控制对象
返回：
成功保存的对象描述对象(ImageInfo)
抛出：
WCMException

quoteImages

public void quoteImages(int _nDocId,
                        java.lang.String _sQuoteImageIds)
                 throws WCMException
从接口 IImageLibService 复制的描述
保存指定文档引用图片的关系

指定者：
接口 IImageLibService 中的 quoteImages
参数：
_nDocId - 指定文档ID
_sQuoteImageIds - 指定引用图片的ID序列
抛出：
WCMException

getDocumentsQuoteImage

public Documents getDocumentsQuoteImage(int _nImageId)
                                 throws WCMException
从接口 IImageLibService 复制的描述
获取使用指定图片的所有文档

指定者：
接口 IImageLibService 中的 getDocumentsQuoteImage
参数：
_nImageId - 指定图片ID
返回：
抛出：
WCMException

getImageAppendixes

public Appendixes getImageAppendixes(WCMFilter _extraFilter,
                                     BaseChannel _oChannelOrSite,
                                     boolean _bIncludeImported)
                              throws WCMException
从接口 IImageLibService 复制的描述
获取系统中已经存在的图片

指定者：
接口 IImageLibService 中的 getImageAppendixes
参数：
_extraFilter - 额外的查询条件
_oChannelOrSite - 站点或者频道，不指定表示获取系统所有的图片
_bIncludeImported - 是否包含已经导入的 true:包含 false：不包含
返回：
抛出：
WCMException

importImageAppendix

public ImageInfo[] importImageAppendix(java.lang.String _sAppendixIds,
                                       ImageInfo _imageInfo)
                                throws WCMException
从接口 IImageLibService 复制的描述
导入指定的图片到指定的分类中

指定者：
接口 IImageLibService 中的 importImageAppendix
参数：
_sAppendixIds - 指定的图片ID序列
_imageInfo - 图片的处理机制
返回：
抛出：
WCMException

importImageAppendix

public ImageInfo importImageAppendix(int _nAppendixId,
                                     ImageInfo _imageInfo)
                              throws WCMException
从接口 IImageLibService 复制的描述
导入单个的图片到指定的分类中

指定者：
接口 IImageLibService 中的 importImageAppendix
参数：
_nAppendixId - 指定的图片ID
_imageInfo - 图片的处理机制
返回：
抛出：
WCMException

clearQuotedImages

public void clearQuotedImages(int _nDocId)
                       throws WCMException
指定者：
接口 IImageLibService 中的 clearQuotedImages
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageMagickCmd

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 ImageMagickCmd

java.lang.Object
    继承者  com.trs.wcm.photo.impl.ImageMagickCmd

public final class ImageMagickCmd
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

嵌套类摘要
static class ImageMagickCmd.ImageObj
构造方法摘要
ImageMagickCmd()
方法摘要
static int | addWaterkmark(java.lang.String watermarkfile, java.lang.String filename, int[] gravity)
static void | borderImg(ImageMagickCmd.ImageObj srcimg, java.lang.String color, int width, int height)
static void | convertBmp(ImageMagickCmd.ImageObj srcimg, java.lang.String bmp2type)
static void | crop(ImageMagickCmd.ImageObj srcimg, int x, int y, int width, int height)
static int[] | getImageSize(ImageMagickCmd.ImageObj img)
static void | raiseImg(ImageMagickCmd.ImageObj srcimg, int width, int height, boolean zRaised)
static void | roateImg(ImageMagickCmd.ImageObj srcimg, java.lang.String degree)
static int | scale(ImageMagickCmd.ImageObj _originalImage, ImageMagickCmd.ImageObj _dstImage)
static void | setCmds(java.util.Map cmds)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageMagickCmd

public ImageMagickCmd()
方法详细信息

setCmds

public static void setCmds(java.util.Map cmds)

scale

public static int scale(ImageMagickCmd.ImageObj _originalImage,
                        ImageMagickCmd.ImageObj _dstImage)
                 throws java.lang.Exception
抛出：
java.lang.Exception

addWaterkmark

public static int addWaterkmark(java.lang.String watermarkfile,
                                java.lang.String filename,
                                int[] gravity)
                         throws java.lang.Exception
抛出：
java.lang.Exception

roateImg

public static void roateImg(ImageMagickCmd.ImageObj srcimg,
                            java.lang.String degree)
                     throws java.lang.Exception
抛出：
java.lang.Exception

borderImg

public static void borderImg(ImageMagickCmd.ImageObj srcimg,
                             java.lang.String color,
                             int width,
                             int height)
                      throws java.lang.Exception
抛出：
java.lang.Exception

raiseImg

public static void raiseImg(ImageMagickCmd.ImageObj srcimg,
                            int width,
                            int height,
                            boolean zRaised)
                     throws java.lang.Exception
抛出：
java.lang.Exception

convertBmp

public static void convertBmp(ImageMagickCmd.ImageObj srcimg,
                              java.lang.String bmp2type)
                       throws java.lang.Exception
参数：
srcimg -
bmp2type -
抛出：
java.lang.Exception

crop

public static void crop(ImageMagickCmd.ImageObj srcimg,
                        int x,
                        int y,
                        int width,
                        int height)
                 throws java.lang.Exception
抛出：
java.lang.Exception

getImageSize

public static int[] getImageSize(ImageMagickCmd.ImageObj img)
                          throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageMagickCmd.ImageObj

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 ImageMagickCmd.ImageObj

java.lang.Object
    继承者  com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj
包容类：
ImageMagickCmd
public static class ImageMagickCmd.ImageObj
extends java.lang.Object

字段摘要
java.lang.String | filename
int | height
int | width
构造方法摘要
ImageMagickCmd.ImageObj()
ImageMagickCmd.ImageObj(java.lang.String fn)
ImageMagickCmd.ImageObj(java.lang.String fn, int width, int heigth)
方法摘要
void | setFilename(java.lang.String fn)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

filename

public java.lang.String filename

width

public int width

height

public int height
构造方法详细信息

ImageMagickCmd.ImageObj

public ImageMagickCmd.ImageObj()

ImageMagickCmd.ImageObj

public ImageMagickCmd.ImageObj(java.lang.String fn)
                        throws WCMException
抛出：
WCMException

ImageMagickCmd.ImageObj

public ImageMagickCmd.ImageObj(java.lang.String fn,
                               int width,
                               int heigth)
方法详细信息

setFilename

public void setFilename(java.lang.String fn)
                 throws java.lang.Exception
参数：
fn -
抛出：
java.lang.Exception

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JImageMarkUtil

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 JImageMarkUtil

java.lang.Object
    继承者  com.trs.wcm.photo.impl.JImageMarkUtil

public class JImageMarkUtil
extends java.lang.Object

构造方法摘要
JImageMarkUtil()
方法摘要
static byte[] | addImageMark(java.lang.String _sSrcImageFile, java.lang.String _sWaterMarkFile)
static byte[] | addImageMark(java.lang.String _sSrcImageFile, java.lang.String _sWaterMarkFile, int[] _pPosition)
static void | setCompositeOp(int _nCompositeOp) 设置水印合成时使用的模式
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JImageMarkUtil

public JImageMarkUtil()
方法详细信息

setCompositeOp

public static void setCompositeOp(int _nCompositeOp)
设置水印合成时使用的模式

参数：
_nCompositeOp - 必须是magic.CompositeOperator接口中定义的有效变量
另请参见：
CompositeOperator

addImageMark

public static byte[] addImageMark(java.lang.String _sSrcImageFile,
                                  java.lang.String _sWaterMarkFile)
                           throws java.lang.Exception
抛出：
java.lang.Exception

addImageMark

public static byte[] addImageMark(java.lang.String _sSrcImageFile,
                                  java.lang.String _sWaterMarkFile,
                                  int[] _pPosition)
                           throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMarkUtilX

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 JMarkUtilX

java.lang.Object
    继承者  com.trs.wcm.photo.impl.JMarkUtilX

public class JMarkUtilX
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
水印工具类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
JMarkUtilX()
方法摘要
static void addWatermark(java.lang.String filename, java.lang.String watermarkfile, int[] pos)
给图片添加指定的水印图片
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JMarkUtilX

public JMarkUtilX()
方法详细信息

addWatermark

public static void addWatermark(java.lang.String filename,
                                java.lang.String watermarkfile,
                                int[] pos)
                         throws java.lang.Exception
给图片添加指定的水印图片

参数：
filename - 要加水印的图片
watermarkfile - 水印图片
pos - 添加的位置
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MagicImageImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 MagicImageImpl

java.lang.Object
    继承者  com.trs.wcm.photo.impl.MagicImageImpl
所有已实现的接口：
IMagicImage
public class MagicImageImpl
extends java.lang.Object
implements IMagicImage

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MagicImageImpl()
方法摘要
byte[] | addWaterMark(java.lang.String _sWaterImageFile, int[] _pWarterMarkPos) 添加图片水印
byte[] | borderImage(java.lang.String _sBoderColor, int _nWidth, int _nHeight) 给图片加上边框
byte[] | convertImageFormat(java.lang.String _sNewImageFormat) 设置需要转换的图片格式
void | cropImage(int x, int y, int width, int height, java.lang.String _sDstFile) 裁剪图片
double | getHeight() 获取图片的高度
int | getSize() 获得图片大小
java.lang.String | getSrcImageFileName() 获取原始的图片文件名
double | getWidth() 获取图片的高度
void | initMagicImage(java.lang.String _sSrcFileName) 初始化图片处理对象
void | montageImages(java.lang.String[] _pImageFileName, java.lang.String _sImageTitle, java.lang.String _sDstImageFile, java.lang.String _sBgColor, java.lang.String _sBorderColor, int _nBorderWidth) 生成组图
byte[] | raiseImage(int _nWidth, int _nHeight, boolean _bRaised) 突起效果
byte[] | rotateImage(double _dDegrees) 按照指定的角度旋转突破
byte[] | scaleImage(int _nWidth, int _nHeight) 将指定的图片按照指定的宽度和高度缩放
void | scaleImage(int width, int height, java.lang.String dstFile)
void | setBackgroundColor(java.lang.String _sBgColor) 设置背景颜色
void | setImageAttribute(java.lang.String _sAttrName, java.lang.String _sValue) 设置图片的属性
void | setOutputImageFileExt(java.lang.String _sImageFileExt) 设置输出图片文件的后缀名
byte[] | sharpenImage(double raduis, double sigma) 锐化图片
void | writeImage() 将设定的效果写入原始图片文件中
void | writeImage(java.lang.String _sNewDstFileName) 将设定的效果写入新定义的图片文件中
java.lang.String | writeImageToSystemTemp() 将设定的效果写入到系统的临时目录中
java.lang.String | writeImageToWCMData(java.lang.String _sPathFlag) 将图片写入到WCMData指定类型的目录中
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MagicImageImpl

public MagicImageImpl()
方法详细信息

addWaterMark

public byte[] addWaterMark(java.lang.String _sWaterImageFile,
                           int[] _pWarterMarkPos)
                    throws java.lang.Exception
从接口 IMagicImage 复制的描述
添加图片水印

指定者：
接口 IMagicImage 中的 addWaterMark
参数：
_sWaterImageFile - 图片水印文件（绝对地址）
_pWarterMarkPos - 水印位置，定义在@see ImageLibConstants中
返回：
TODO
抛出：
java.lang.Exception

borderImage

public byte[] borderImage(java.lang.String _sBoderColor,
                          int _nWidth,
                          int _nHeight)
                   throws java.lang.Exception
从接口 IMagicImage 复制的描述
给图片加上边框

指定者：
接口 IMagicImage 中的 borderImage
参数：
_sBoderColor - 边框颜色
_nWidth - 宽度
_nHeight - 高度
返回：
TODO
抛出：
java.lang.Exception

getHeight

public double getHeight()
                 throws java.lang.Exception
从接口 IMagicImage 复制的描述
获取图片的高度

指定者：
接口 IMagicImage 中的 getHeight
返回：
图片的高度
抛出：
java.lang.Exception

getWidth

public double getWidth()
                throws java.lang.Exception
从接口 IMagicImage 复制的描述
获取图片的高度

指定者：
接口 IMagicImage 中的 getWidth
返回：
图片的高度
抛出：
java.lang.Exception

montageImages

public void montageImages(java.lang.String[] _pImageFileName,
                          java.lang.String _sImageTitle,
                          java.lang.String _sDstImageFile,
                          java.lang.String _sBgColor,
                          java.lang.String _sBorderColor,
                          int _nBorderWidth)
                   throws java.lang.Exception
从接口 IMagicImage 复制的描述
生成组图

指定者：
接口 IMagicImage 中的 montageImages
参数：
_pImageFileName - 需要组合的图片文件名数组
_sImageTitle - TODO
_sDstImageFile - TODO
_sBgColor - TODO
_sBorderColor - TODO
_nBorderWidth - TODO
抛出：
java.lang.Exception

raiseImage

public byte[] raiseImage(int _nWidth,
                         int _nHeight,
                         boolean _bRaised)
                  throws java.lang.Exception
从接口 IMagicImage 复制的描述
突起效果

指定者：
接口 IMagicImage 中的 raiseImage
参数：
_nWidth - 宽度
_nHeight - 高度
_bRaised - 凸起(true)或凹下(false)
返回：
TODO
抛出：
java.lang.Exception

rotateImage

public byte[] rotateImage(double _dDegrees)
                   throws java.lang.Exception
从接口 IMagicImage 复制的描述
按照指定的角度旋转突破

指定者：
接口 IMagicImage 中的 rotateImage
参数：
_dDegrees - 指定的角度
返回：
TODO
抛出：
java.lang.Exception

scaleImage

public byte[] scaleImage(int _nWidth,
                         int _nHeight)
                  throws java.lang.Exception
从接口 IMagicImage 复制的描述
将指定的图片按照指定的宽度和高度缩放

指定者：
接口 IMagicImage 中的 scaleImage
参数：
_nWidth - 宽度(如果小于等于0，按照高度等比例缩放)
_nHeight - 高度(如果小于等于0，按照宽度等比例缩放)
返回：
TODO
抛出：
java.lang.Exception

setBackgroundColor

public void setBackgroundColor(java.lang.String _sBgColor)
                        throws java.lang.Exception
从接口 IMagicImage 复制的描述
设置背景颜色

指定者：
接口 IMagicImage 中的 setBackgroundColor
参数：
_sBgColor - 背景颜色
抛出：
java.lang.Exception

convertImageFormat

public byte[] convertImageFormat(java.lang.String _sNewImageFormat)
                          throws java.lang.Exception
从接口 IMagicImage 复制的描述
设置需要转换的图片格式

指定者：
接口 IMagicImage 中的 convertImageFormat
参数：
_sNewImageFormat - 图片格式（gif, jpeg, jpg）
返回：
TODO
抛出：
java.lang.Exception

initMagicImage

public void initMagicImage(java.lang.String _sSrcFileName)
                    throws java.lang.Exception
从接口 IMagicImage 复制的描述
初始化图片处理对象

指定者：
接口 IMagicImage 中的 initMagicImage
参数：
_sSrcFileName - 服务器上绝对物理地址或WCM有规则的文件名
抛出：
WCMException
java.lang.Exception

setImageAttribute

public void setImageAttribute(java.lang.String _sAttrName,
                              java.lang.String _sValue)
                       throws java.lang.Exception
从接口 IMagicImage 复制的描述
设置图片的属性

指定者：
接口 IMagicImage 中的 setImageAttribute
参数：
_sAttrName - 属性名称，例如：Comment、Author等，符合IPTCC即可
_sValue - 属性值
抛出：
java.lang.Exception

sharpenImage

public byte[] sharpenImage(double raduis,
                           double sigma)
                    throws java.lang.Exception
从接口 IMagicImage 复制的描述
锐化图片

指定者：
接口 IMagicImage 中的 sharpenImage
返回：
TODO
抛出：
java.lang.Exception

writeImage

public void writeImage()
                throws java.lang.Exception
从接口 IMagicImage 复制的描述
将设定的效果写入原始图片文件中

指定者：
接口 IMagicImage 中的 writeImage
抛出：
java.lang.Exception

writeImage

public void writeImage(java.lang.String _sNewDstFileName)
                throws java.lang.Exception
从接口 IMagicImage 复制的描述
将设定的效果写入新定义的图片文件中

指定者：
接口 IMagicImage 中的 writeImage
参数：
_sNewDstFileName - 新的图片文件(服务器上绝对物理地址或WCM有规则的文件名)
抛出：
java.lang.Exception

writeImageToSystemTemp

public java.lang.String writeImageToSystemTemp()
                                        throws java.lang.Exception
从接口 IMagicImage 复制的描述
将设定的效果写入到系统的临时目录中

指定者：
接口 IMagicImage 中的 writeImageToSystemTemp
返回：
绝对路径的文件名
抛出：
java.lang.Exception

getSize

public int getSize()
            throws java.lang.Exception
从接口 IMagicImage 复制的描述
获得图片大小

指定者：
接口 IMagicImage 中的 getSize
返回：
抛出：
java.lang.Exception

setOutputImageFileExt

public void setOutputImageFileExt(java.lang.String _sImageFileExt)
从接口 IMagicImage 复制的描述
设置输出图片文件的后缀名

指定者：
接口 IMagicImage 中的 setOutputImageFileExt

writeImageToWCMData

public java.lang.String writeImageToWCMData(java.lang.String _sPathFlag)
                                     throws java.lang.Exception
从接口 IMagicImage 复制的描述
将图片写入到WCMData指定类型的目录中

指定者：
接口 IMagicImage 中的 writeImageToWCMData
参数：
_sPathFlag - WCMData目录类型，定义在FilesMan中
返回：
TODO
抛出：
java.lang.Exception

getSrcImageFileName

public java.lang.String getSrcImageFileName()
从接口 IMagicImage 复制的描述
获取原始的图片文件名

指定者：
接口 IMagicImage 中的 getSrcImageFileName
返回：
原始的图片文件名

scaleImage

public void scaleImage(int width,
                       int height,
                       java.lang.String dstFile)
                throws java.lang.Exception
指定者：
接口 IMagicImage 中的 scaleImage
抛出：
java.lang.Exception

cropImage

public void cropImage(int x,
                      int y,
                      int width,
                      int height,
                      java.lang.String _sDstFile)
               throws java.lang.Exception
从接口 IMagicImage 复制的描述
裁剪图片

指定者：
接口 IMagicImage 中的 cropImage
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.wcm.photo.impl
类
AutoImageLibUtil
ImageLibConfigImpl
ImageLibMgrImpl
ImageLibServiceImpl
ImageMagickCmd
ImageMagickCmd.ImageObj
JImageMarkUtil
JMarkUtilX
MagicImageImpl
PhotoImporter


com.trs.wcm.photo.impl

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcm.photo.impl

类摘要
AutoImageLibUtil | Title: TRS 内容协作平台（TRS WCM） Description: 自动保存图片进库 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ImageLibConfigImpl | Title: TRS 内容协作平台（TRS WCM） Description: 图片库配置信息管理默认实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImageLibMgrImpl | Title: TRS 内容协作平台（TRS WCM） Description: 图片库业务逻辑处理对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImageLibServiceImpl | Title: TRS 内容协作平台（TRS WCM） Description: 图片服务的实现 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ImageMagickCmd | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ImageMagickCmd.ImageObj |
JImageMarkUtil |
JMarkUtilX | Title: TRS 内容协作平台（TRS WCM） Description: 水印工具类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
MagicImageImpl | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PhotoImporter | Title: TRS 内容协作平台（TRS WCM） Description: 图片导入(项目定制) Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)


com.trs.wcm.photo.impl 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcm.photo.impl 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.wcm.photo.impl.AutoImageLibUtil
    • com.trs.wcm.photo.impl.ImageLibConfigImpl (implements com.trs.wcm.photo.IImageLibConfig)
    • com.trs.wcm.photo.impl.ImageLibMgrImpl (implements com.trs.wcm.photo.IImageLibMgr)
    • com.trs.wcm.photo.impl.ImageLibServiceImpl (implements com.trs.wcm.photo.IImageLibService)
    • com.trs.wcm.photo.impl.ImageMagickCmd
    • com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj
    • com.trs.wcm.photo.impl.JImageMarkUtil
    • com.trs.wcm.photo.impl.JMarkUtilX
    • com.trs.wcm.photo.impl.MagicImageImpl (implements com.trs.wcm.photo.IMagicImage)
    • com.trs.wcm.photo.impl.PhotoImporter


软件包 com.trs.wcm.photo.impl 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcm.photo.impl
的使用

使用 com.trs.wcm.photo.impl 的软件包
com.trs.wcm.photo.impl

com.trs.wcm.photo.impl 使用的 com.trs.wcm.photo.impl 中的类
ImageMagickCmd.ImageObj

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PhotoImporter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.impl
类 PhotoImporter

java.lang.Object
    继承者  com.trs.wcm.photo.impl.PhotoImporter

public class PhotoImporter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
图片导入(项目定制)
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

版本：
1.0
作者：
wenyh

构造方法摘要
PhotoImporter()
方法摘要
 void importViaZipFile(java.lang.String fn, Channel channel)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PhotoImporter

public PhotoImporter()
方法详细信息

importViaZipFile

public void importViaZipFile(java.lang.String fn,
                             Channel channel)
                      throws WCMException
参数：
fn -
channel -
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.wcm.photo.impl.AutoImageLibUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.AutoImageLibUtil
的使用

没有 com.trs.wcm.photo.impl.AutoImageLibUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.ImageLibConfigImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.ImageLibConfigImpl
的使用

没有 com.trs.wcm.photo.impl.ImageLibConfigImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.ImageLibMgrImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.ImageLibMgrImpl
的使用

没有 com.trs.wcm.photo.impl.ImageLibMgrImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.ImageLibServiceImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.ImageLibServiceImpl
的使用

没有 com.trs.wcm.photo.impl.ImageLibServiceImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.ImageMagickCmd 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.ImageMagickCmd
的使用

没有 com.trs.wcm.photo.impl.ImageMagickCmd 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj
的使用

使用 ImageMagickCmd.ImageObj 的软件包
com.trs.wcm.photo.impl

com.trs.wcm.photo.impl 中 ImageMagickCmd.ImageObj 的使用

参数类型为 ImageMagickCmd.ImageObj 的 com.trs.wcm.photo.impl 中的方法
static void | ImageMagickCmd.borderImg(ImageMagickCmd.ImageObj srcimg, java.lang.String color, int width, int height)
static void | ImageMagickCmd.convertBmp(ImageMagickCmd.ImageObj srcimg, java.lang.String bmp2type)
static void | ImageMagickCmd.crop(ImageMagickCmd.ImageObj srcimg, int x, int y, int width, int height)
static int[] | ImageMagickCmd.getImageSize(ImageMagickCmd.ImageObj img)
static void | ImageMagickCmd.raiseImg(ImageMagickCmd.ImageObj srcimg, int width, int height, boolean zRaised)
static void | ImageMagickCmd.roateImg(ImageMagickCmd.ImageObj srcimg, java.lang.String degree)
static int | ImageMagickCmd.scale(ImageMagickCmd.ImageObj _originalImage, ImageMagickCmd.ImageObj _dstImage)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.JImageMarkUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.JImageMarkUtil
的使用

没有 com.trs.wcm.photo.impl.JImageMarkUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.JMarkUtilX 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.JMarkUtilX
的使用

没有 com.trs.wcm.photo.impl.JMarkUtilX 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.MagicImageImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.MagicImageImpl
的使用

没有 com.trs.wcm.photo.impl.MagicImageImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcm.photo.impl.PhotoImporter 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.impl.PhotoImporter
的使用

没有 com.trs.wcm.photo.impl.PhotoImporter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.wcm.photo.publish
类
WCMTagParserImage


com.trs.wcm.photo.publish

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcm.photo.publish

类摘要
WCMTagParserImage Title: TRS 内容协作平台（TRS WCM）
Description:
解析图片库置标TRS_IMAGE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.wcm.photo.publish 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcm.photo.publish 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.components.common.publish.domain.tagparser.BaseTagParser (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
      • com.trs.wcm.photo.publish.WCMTagParserImage


软件包 com.trs.wcm.photo.publish 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcm.photo.publish
的使用

没有 com.trs.wcm.photo.publish 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


WCMTagParserImage

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcm.photo.publish
类 WCMTagParserImage

java.lang.Object
    继承者  com.trs.components.common.publish.domain.tagparser.BaseTagParser
        继承者  com.trs.wcm.photo.publish.WCMTagParserImage
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class WCMTagParserImage
extends BaseTagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
解析图片库置标TRS_IMAGE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
WCMTagParserImage()
方法摘要
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
从类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 继承的方法
analyzeQuotes, clear, setTagItem
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMTagParserImage

public WCMTagParserImage()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
覆盖：
类 BaseTagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.wcm.photo.publish.WCMTagParserImage 的使用

上一个 下一个 框架 无框架

类 com.trs.wcm.photo.publish.WCMTagParserImage
的使用

没有 com.trs.wcm.photo.publish.WCMTagParserImage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.wcmonline
类
TagParserVipMetaData
WCMOnlineService


com.trs.wcmonline

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.wcmonline

类摘要
TagParserVipMetaData | Title: TRS 内容协作平台（TRS WCM） Description: 嘉宾访谈数据信息 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WCMOnlineService | Title: TRS 内容协作平台（TRS WCM） Description: 嘉宾访谈的服务 Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)


com.trs.wcmonline 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.wcmonline 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.wcmonline.TagParserVipMetaData (implements com.trs.components.common.publish.domain.tagparser.ITagParser)
    • com.trs.wcmonline.WCMOnlineService


软件包 com.trs.wcmonline 的使用

上一个 下一个 框架 无框架

软件包 com.trs.wcmonline
的使用

没有 com.trs.wcmonline 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


TagParserVipMetaData

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcmonline
类 TagParserVipMetaData

java.lang.Object
    继承者  com.trs.wcmonline.TagParserVipMetaData
所有已实现的接口：
ITagParser, org.aton.container.IClearable
public class TagParserVipMetaData
extends java.lang.Object
implements ITagParser

Title: TRS 内容协作平台（TRS WCM）
Description:
嘉宾访谈数据信息
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
TagParserVipMetaData()
方法摘要
TemplateQuote[] | analyzeQuotes(IPublishFolder _root) Analyzes the quote relations between this template and folders.
void | clear()
TagBeanInfo | getBeanInfo() 返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
java.lang.String[] | parse(PublishTagContext _context) Parses the specified tag item and returns the result.
void | setTagItem(TagItem _item) Sets the tag item to parser.
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagParserVipMetaData

public TagParserVipMetaData()
方法详细信息

getBeanInfo

public TagBeanInfo getBeanInfo()
从接口 ITagParser 复制的描述
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。

指定者：
接口 ITagParser 中的 getBeanInfo
返回：
置标解析器的自我描述

setTagItem

public void setTagItem(TagItem _item)
从接口 ITagParser 复制的描述
Sets the tag item to parser.

指定者：
接口 ITagParser 中的 setTagItem
参数：
_item - a tag item.

analyzeQuotes

public TemplateQuote[] analyzeQuotes(IPublishFolder _root)
从接口 ITagParser 复制的描述
Analyzes the quote relations between this template and folders.

指定者：
接口 ITagParser 中的 analyzeQuotes
参数：
_root - the root folder
返回：
the TemplateQuote list.

parse

public java.lang.String[] parse(PublishTagContext _context)
                         throws WCMException
从接口 ITagParser 复制的描述
Parses the specified tag item and returns the result.
Memo: there may be more than one result in multi-pages mode.

指定者：
接口 ITagParser 中的 parse
参数：
_context - tag parse context
返回：
the parsed result list.
抛出：
WCMException - if failed to parse the tag item.

clear

public void clear()
指定者：
接口 org.aton.container.IClearable 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


WCMOnlineService

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.wcmonline
类 WCMOnlineService

java.lang.Object
    继承者  com.trs.wcmonline.WCMOnlineService

public class WCMOnlineService
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
嘉宾访谈的服务
Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
北京拓尔思(TRS)信息技术有限公司

构造方法摘要
WCMOnlineService()
方法摘要
java.lang.String | canPub(java.lang.String sVipId)
java.lang.String | checkExists(java.lang.String sVipName, java.lang.String sSiteId)
java.lang.String | createVip(java.lang.String sVipId, java.lang.String sVipName, java.lang.String sVisitUrl, java.lang.String sSiteId, java.lang.String sChnlId)
java.lang.String | getSiteTree()
java.lang.String | importPost(java.lang.String sVipId, java.lang.String sTitle, java.lang.String sContent)
java.lang.String | loadTree(java.lang.String parentid, java.lang.String siteid)
void | updateVisitUrl(java.lang.String sVisitUrl)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCMOnlineService

public WCMOnlineService()
方法详细信息

createVip

public java.lang.String createVip(java.lang.String sVipId,
                                  java.lang.String sVipName,
                                  java.lang.String sVisitUrl,
                                  java.lang.String sSiteId,
                                  java.lang.String sChnlId)

getSiteTree

public java.lang.String getSiteTree()

updateVisitUrl

public void updateVisitUrl(java.lang.String sVisitUrl)
                    throws java.lang.Exception
抛出：
java.lang.Exception

importPost

public java.lang.String importPost(java.lang.String sVipId,
                                   java.lang.String sTitle,
                                   java.lang.String sContent)
                            throws java.lang.Exception
抛出：
java.lang.Exception

loadTree

public java.lang.String loadTree(java.lang.String parentid,
                                 java.lang.String siteid)
                          throws java.lang.Exception
抛出：
java.lang.Exception

checkExists

public java.lang.String checkExists(java.lang.String sVipName,
                                    java.lang.String sSiteId)

canPub

public java.lang.String canPub(java.lang.String sVipId)
                        throws java.lang.Exception
抛出：
java.lang.Exception
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.wcmonline.TagParserVipMetaData 的使用

上一个 下一个 框架 无框架

类 com.trs.wcmonline.TagParserVipMetaData
的使用

没有 com.trs.wcmonline.TagParserVipMetaData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.wcmonline.WCMOnlineService 的使用

上一个 下一个 框架 无框架

类 com.trs.wcmonline.WCMOnlineService
的使用

没有 com.trs.wcmonline.WCMOnlineService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


AbstractLogger

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework
类 AbstractLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
所有已实现的接口：
ServiceExcuteLogger
直接已知子类：
BatchChannelCreateFromFileLogger, ChannelCreateFromLogger, ChannelImportLogger, ChannelMoveLogger, DefaultDeleteLogger, DefaultSaveLogger, DocCopyLogger, DocImportLogger, DocMoveLogger, DocPublishTaskLogger, DocStatusChangeLogger, EPressChannelCreateLogger, EPressHistoryPubLogger, FlowSaveLogger, FlowSetLogger, ImpartTemplateLogger, PublishConfigSaveLogger, PublishTaskLogger, RecycleClearLogger, RestoreObjLogger, ResyncTemplateApdLogger, SetEmployersOfTemplateLogger, SiteCreateFromLogger, SiteImportLogger, SiteRecycleClearLogger, TemplateImportLogger, TemplateSyncLogger, WebSiteRestoreLogger
public abstract class AbstractLogger
extends java.lang.Object
implements ServiceExcuteLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录器
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
AbstractLogger()
方法摘要
void | endLog(int _nLogId)
void | endLogWithFaliure(int _nLogId, java.lang.Throwable _throwable)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.webframework.ServiceExcuteLogger 继承的方法
startLog

构造方法详细信息

AbstractLogger

public AbstractLogger()
方法详细信息

endLog

public void endLog(int _nLogId)
指定者：
接口 ServiceExcuteLogger 中的 endLog

endLogWithFaliure

public void endLogWithFaliure(int _nLogId,
                              java.lang.Throwable _throwable)
指定者：
接口 ServiceExcuteLogger 中的 endLogWithFaliure
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DefaultDeleteLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework
类 DefaultDeleteLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.webframework.DefaultDeleteLogger
所有已实现的接口：
ServiceExcuteLogger
public class DefaultDeleteLogger
extends AbstractLogger
implements ServiceExcuteLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
默认的删除操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
DefaultDeleteLogger()
方法摘要
 int startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 com.trs.webframework.AbstractLogger 继承的方法
endLog, endLogWithFaliure
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 com.trs.webframework.ServiceExcuteLogger 继承的方法
endLog, endLogWithFaliure

构造方法详细信息

DefaultDeleteLogger

public DefaultDeleteLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
指定者：
接口 ServiceExcuteLogger 中的 startLog
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultSaveLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework
类 DefaultSaveLogger

java.lang.Object
    继承者  com.trs.webframework.AbstractLogger
        继承者  com.trs.webframework.DefaultSaveLogger
所有已实现的接口：
ServiceExcuteLogger
直接已知子类：
DocSaveLogger
public class DefaultSaveLogger
extends AbstractLogger
implements ServiceExcuteLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
默认的保存操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

构造方法摘要
DefaultSaveLogger()
方法摘要
void | endLog(int _nLogId)
void | endLogWithFaliure(int _nLogId, java.lang.Throwable _throwable)
int | startLog(MethodConfig _methodConf, MethodContext _methodContext)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultSaveLogger

public DefaultSaveLogger()
方法详细信息

startLog

public int startLog(MethodConfig _methodConf,
                    MethodContext _methodContext)
指定者：
接口 ServiceExcuteLogger 中的 startLog

endLog

public void endLog(int _nLogId)
指定者：
接口 ServiceExcuteLogger 中的 endLog
覆盖：
类 AbstractLogger 中的 endLog

endLogWithFaliure

public void endLogWithFaliure(int _nLogId,
                              java.lang.Throwable _throwable)
指定者：
接口 ServiceExcuteLogger 中的 endLogWithFaliure
覆盖：
类 AbstractLogger 中的 endLogWithFaliure
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FrameworkConstants

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework
类 FrameworkConstants

java.lang.Object
    继承者  com.trs.webframework.FrameworkConstants

public class FrameworkConstants
extends java.lang.Object

字段摘要
static java.lang.String | ATTR_NAME_CURRPAGE
static java.lang.String | ATTR_NAME_METHODCONTEXT
static java.lang.String | ATTR_NAME_NUM
static java.lang.String | ATTR_NAME_PAGER
static java.lang.String | ATTR_NAME_PAGESIZE
static java.lang.String | ATTR_NAME_RESULT
static int | ATTR_VALUE_FIRST_PAGE_INDEX
static int | CONVERTOR_TYPE_DEFAULT
static int | CONVERTOR_TYPE_JSON
static int | CONVERTOR_TYPE_URI
static int | CONVERTOR_TYPE_URL
static int | CONVERTOR_TYPE_XML
static java.lang.String | DATA_TYPE_BOOLEAN Comment for TYPE_BOOLEAN 布尔型
static int | DATA_TYPE_BOOLEAN_HASHCODE Comment for TYPE_BOOLEAN 布尔型
static java.lang.String | DATA_TYPE_DATE Comment for TYPE_DATE 日期型
static int | DATA_TYPE_DATE_HASHCODE Comment for TYPE_DATE 日期型
static java.lang.String | DATA_TYPE_DATETIME Comment for TYPE_DATETIME 日期时间型
static int | DATA_TYPE_DATETIME_HASHCODE Comment for TYPE_DATETIME 日期时间型
static java.lang.String | DATA_TYPE_DOUBLE Comment for TYPE_DOUBLE 双精度
static int | DATA_TYPE_DOUBLE_HASHCODE Comment for TYPE_DOUBLE 双精度
static java.lang.String | DATA_TYPE_FLOAT Comment for TYPE_FLOAT 浮点型
static int | DATA_TYPE_FLOAT_HASHCODE Comment for TYPE_FLOAT 浮点型
static java.lang.String | DATA_TYPE_INT Comment for TYPE_INT 整型
static int | DATA_TYPE_INT_HASHCODE Comment for TYPE_INT 整型
static java.lang.String | DATA_TYPE_LONG Comment for TYPE_LONG 长整型
static int | DATA_TYPE_LONG_HASHCODE Comment for TYPE_LONG 长整型
static java.lang.String | DATA_TYPE_PINT 多整型
static int | DATA_TYPE_PINT_HASHCODE 多整型
static java.lang.String | DATA_TYPE_STRING Comment for TYPE_STRING 字符型
static int | DATA_TYPE_STRING_HASHCODE Comment for TYPE_STRING 字符型
static java.lang.String | DATA_TYPE_TIME Comment for TYPE_TIME 时间型
static int | DATA_TYPE_TIME_HASHCODE Comment for TYPE_TIME 时间型
static java.lang.String[] | DATA_TYPES_SUPPORTED Comment for TYPES_SUPPORTED
static java.lang.String | FLAG_SELF_DEFINED_CONTENT_TYPE
static java.lang.String | FLAG_UPLOAD_FILE_EXT
static java.util.Map | KeywordedParams
static int | METHOD_TYPE_ALL
static int | METHOD_TYPE_DELETE
static int | METHOD_TYPE_FINDBYID
static int | METHOD_TYPE_FINDBYIDS
static int | METHOD_TYPE_QUERY
static int | METHOD_TYPE_SAVE
static int[] | METHOD_TYPES
static java.lang.String | NAME_PARAMETER_FROM_TABLE
static java.lang.String | NAME_PARAMETER_METHOD_NAME
static java.lang.String | NAME_PARAMETER_OBJECT_ID
static java.lang.String | NAME_PARAMETER_OBJECT_IDS
static java.lang.String | NAME_PARAMETER_ORDERBY_FIELD
static java.lang.String | NAME_PARAMETER_ORDERBY_TYPE
static java.lang.String[] | NAME_PARAMETER_RESERVE
static java.lang.String | NAME_PARAMETER_SELECTED_FIELDS
static java.lang.String | NAME_PARAMETER_SERVICE_ID
构造方法摘要
FrameworkConstants()
方法摘要
static boolean | isKeyWordedParam(java.lang.String _sParamName)
static boolean | isReserveParameterName(java.lang.String _sParameterName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

METHOD_TYPE_QUERY

public static final int METHOD_TYPE_QUERY
另请参见：
常量字段值

METHOD_TYPE_DELETE

public static final int METHOD_TYPE_DELETE
另请参见：
常量字段值

METHOD_TYPE_SAVE

public static final int METHOD_TYPE_SAVE
另请参见：
常量字段值

METHOD_TYPE_FINDBYIDS

public static final int METHOD_TYPE_FINDBYIDS
另请参见：
常量字段值

METHOD_TYPE_FINDBYID

public static final int METHOD_TYPE_FINDBYID
另请参见：
常量字段值

METHOD_TYPE_ALL

public static final int METHOD_TYPE_ALL
另请参见：
常量字段值

METHOD_TYPES

public static final int[] METHOD_TYPES

DATA_TYPE_STRING

public static final java.lang.String DATA_TYPE_STRING
Comment for TYPE_STRING 字符型

另请参见：
常量字段值

DATA_TYPE_INT

public static final java.lang.String DATA_TYPE_INT
Comment for TYPE_INT 整型

另请参见：
常量字段值

DATA_TYPE_LONG

public static final java.lang.String DATA_TYPE_LONG
Comment for TYPE_LONG 长整型

另请参见：
常量字段值

DATA_TYPE_FLOAT

public static final java.lang.String DATA_TYPE_FLOAT
Comment for TYPE_FLOAT 浮点型

另请参见：
常量字段值

DATA_TYPE_DOUBLE

public static final java.lang.String DATA_TYPE_DOUBLE
Comment for TYPE_DOUBLE 双精度

另请参见：
常量字段值

DATA_TYPE_DATE

public static final java.lang.String DATA_TYPE_DATE
Comment for TYPE_DATE 日期型

另请参见：
常量字段值

DATA_TYPE_TIME

public static final java.lang.String DATA_TYPE_TIME
Comment for TYPE_TIME 时间型

另请参见：
常量字段值

DATA_TYPE_DATETIME

public static final java.lang.String DATA_TYPE_DATETIME
Comment for TYPE_DATETIME 日期时间型

另请参见：
常量字段值

DATA_TYPE_BOOLEAN

public static final java.lang.String DATA_TYPE_BOOLEAN
Comment for TYPE_BOOLEAN 布尔型

另请参见：
常量字段值

DATA_TYPE_PINT

public static final java.lang.String DATA_TYPE_PINT
多整型

另请参见：
常量字段值

DATA_TYPE_PINT_HASHCODE

public static final int DATA_TYPE_PINT_HASHCODE
多整型

另请参见：
常量字段值

DATA_TYPE_STRING_HASHCODE

public static final int DATA_TYPE_STRING_HASHCODE
Comment for TYPE_STRING 字符型

另请参见：
常量字段值

DATA_TYPE_INT_HASHCODE

public static final int DATA_TYPE_INT_HASHCODE
Comment for TYPE_INT 整型

另请参见：
常量字段值

DATA_TYPE_LONG_HASHCODE

public static final int DATA_TYPE_LONG_HASHCODE
Comment for TYPE_LONG 长整型

另请参见：
常量字段值

DATA_TYPE_FLOAT_HASHCODE

public static final int DATA_TYPE_FLOAT_HASHCODE
Comment for TYPE_FLOAT 浮点型

另请参见：
常量字段值

DATA_TYPE_DOUBLE_HASHCODE

public static final int DATA_TYPE_DOUBLE_HASHCODE
Comment for TYPE_DOUBLE 双精度

另请参见：
常量字段值

DATA_TYPE_DATE_HASHCODE

public static final int DATA_TYPE_DATE_HASHCODE
Comment for TYPE_DATE 日期型

另请参见：
常量字段值

DATA_TYPE_TIME_HASHCODE

public static final int DATA_TYPE_TIME_HASHCODE
Comment for TYPE_TIME 时间型

另请参见：
常量字段值

DATA_TYPE_DATETIME_HASHCODE

public static final int DATA_TYPE_DATETIME_HASHCODE
Comment for TYPE_DATETIME 日期时间型

另请参见：
常量字段值

DATA_TYPE_BOOLEAN_HASHCODE

public static final int DATA_TYPE_BOOLEAN_HASHCODE
Comment for TYPE_BOOLEAN 布尔型

另请参见：
常量字段值

DATA_TYPES_SUPPORTED

public static final java.lang.String[] DATA_TYPES_SUPPORTED
Comment for TYPES_SUPPORTED

NAME_PARAMETER_SERVICE_ID

public static final java.lang.String NAME_PARAMETER_SERVICE_ID
另请参见：
常量字段值

NAME_PARAMETER_METHOD_NAME

public static final java.lang.String NAME_PARAMETER_METHOD_NAME
另请参见：
常量字段值

NAME_PARAMETER_OBJECT_IDS

public static final java.lang.String NAME_PARAMETER_OBJECT_IDS
另请参见：
常量字段值

NAME_PARAMETER_OBJECT_ID

public static final java.lang.String NAME_PARAMETER_OBJECT_ID
另请参见：
常量字段值

NAME_PARAMETER_SELECTED_FIELDS

public static final java.lang.String NAME_PARAMETER_SELECTED_FIELDS
另请参见：
常量字段值

NAME_PARAMETER_ORDERBY_FIELD

public static final java.lang.String NAME_PARAMETER_ORDERBY_FIELD
另请参见：
常量字段值

NAME_PARAMETER_ORDERBY_TYPE

public static final java.lang.String NAME_PARAMETER_ORDERBY_TYPE
另请参见：
常量字段值

NAME_PARAMETER_FROM_TABLE

public static final java.lang.String NAME_PARAMETER_FROM_TABLE
另请参见：
常量字段值

NAME_PARAMETER_RESERVE

public static java.lang.String[] NAME_PARAMETER_RESERVE

CONVERTOR_TYPE_DEFAULT

public static final int CONVERTOR_TYPE_DEFAULT
另请参见：
常量字段值

CONVERTOR_TYPE_URI

public static final int CONVERTOR_TYPE_URI
另请参见：
常量字段值

CONVERTOR_TYPE_URL

public static final int CONVERTOR_TYPE_URL
另请参见：
常量字段值

CONVERTOR_TYPE_XML

public static final int CONVERTOR_TYPE_XML
另请参见：
常量字段值

CONVERTOR_TYPE_JSON

public static final int CONVERTOR_TYPE_JSON
另请参见：
常量字段值

ATTR_NAME_CURRPAGE

public static final java.lang.String ATTR_NAME_CURRPAGE
另请参见：
常量字段值

ATTR_NAME_PAGESIZE

public static final java.lang.String ATTR_NAME_PAGESIZE
另请参见：
常量字段值

ATTR_NAME_NUM

public static final java.lang.String ATTR_NAME_NUM
另请参见：
常量字段值

ATTR_NAME_RESULT

public static final java.lang.String ATTR_NAME_RESULT
另请参见：
常量字段值

ATTR_NAME_PAGER

public static final java.lang.String ATTR_NAME_PAGER
另请参见：
常量字段值

KeywordedParams

public static java.util.Map KeywordedParams

ATTR_VALUE_FIRST_PAGE_INDEX

public static final int ATTR_VALUE_FIRST_PAGE_INDEX
另请参见：
常量字段值

ATTR_NAME_METHODCONTEXT

public static final java.lang.String ATTR_NAME_METHODCONTEXT
另请参见：
常量字段值

FLAG_SELF_DEFINED_CONTENT_TYPE

public static final java.lang.String FLAG_SELF_DEFINED_CONTENT_TYPE
另请参见：
常量字段值

FLAG_UPLOAD_FILE_EXT

public static final java.lang.String FLAG_UPLOAD_FILE_EXT
另请参见：
常量字段值
构造方法详细信息

FrameworkConstants

public FrameworkConstants()
方法详细信息

isReserveParameterName

public static boolean isReserveParameterName(java.lang.String _sParameterName)

isKeyWordedParam

public static boolean isKeyWordedParam(java.lang.String _sParamName)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework
接口
ServiceExcuteLogger
类
AbstractLogger
DefaultDeleteLogger
DefaultSaveLogger
FrameworkConstants
WebServiceHelper


com.trs.webframework

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework

接口摘要
ServiceExcuteLogger Title: TRS 内容协作平台（TRS WCM）
Description:
服务操作日志记录
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

类摘要
AbstractLogger | Title: TRS 内容协作平台（TRS WCM） Description: 日志记录器 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DefaultDeleteLogger | Title: TRS 内容协作平台（TRS WCM） Description: 默认的删除操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DefaultSaveLogger | Title: TRS 内容协作平台（TRS WCM） Description: 默认的保存操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
FrameworkConstants |
WebServiceHelper |


com.trs.webframework 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.AbstractLogger (implements com.trs.webframework.ServiceExcuteLogger)
      • com.trs.webframework.DefaultDeleteLogger (implements com.trs.webframework.ServiceExcuteLogger)
      • com.trs.webframework.DefaultSaveLogger (implements com.trs.webframework.ServiceExcuteLogger)
    • com.trs.webframework.FrameworkConstants
    • com.trs.webframework.WebServiceHelper

接口分层结构

  • com.trs.webframework.ServiceExcuteLogger


软件包 com.trs.webframework 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework
的使用

使用 com.trs.webframework 的软件包
com.trs.ajaxservice.logger
com.trs.components.wcm.epress
com.trs.webframework

com.trs.ajaxservice.logger 使用的 com.trs.webframework 中的类
AbstractLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录器
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DefaultSaveLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
默认的保存操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ServiceExcuteLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
服务操作日志记录
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.webframework 中的类
AbstractLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录器
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ServiceExcuteLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
服务操作日志记录
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.webframework 使用的 com.trs.webframework 中的类
AbstractLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录器
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ServiceExcuteLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
服务操作日志记录
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ServiceExcuteLogger

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework
接口 ServiceExcuteLogger

所有已知实现类：
AbstractLogger, BatchChannelCreateFromFileLogger, ChannelCreateFromLogger, ChannelImportLogger, ChannelMoveLogger, DefaultDeleteLogger, DefaultSaveLogger, DocCopyLogger, DocImportLogger, DocMoveLogger, DocPublishTaskLogger, DocSaveLogger, DocStatusChangeLogger, EPressChannelCreateLogger, EPressHistoryPubLogger, FlowSaveLogger, FlowSetLogger, ImpartTemplateLogger, PublishConfigSaveLogger, PublishTaskLogger, RecycleClearLogger, RestoreObjLogger, ResyncTemplateApdLogger, SetEmployersOfTemplateLogger, SiteCreateFromLogger, SiteImportLogger, SiteRecycleClearLogger, TemplateImportLogger, TemplateSyncLogger, WebSiteRestoreLogger
public interface ServiceExcuteLogger

Title: TRS 内容协作平台（TRS WCM）
Description:
服务操作日志记录
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
leafgray(温业辉)

方法摘要
void | endLog(int _nLogId)
void | endLogWithFaliure(int _nLogId, java.lang.Throwable _throwable)
int | startLog(MethodConfig _methodConf, MethodContext _methodContext)

方法详细信息

startLog

int startLog(MethodConfig _methodConf,
             MethodContext _methodContext)

endLog

void endLog(int _nLogId)

endLogWithFaliure

void endLogWithFaliure(int _nLogId,
                       java.lang.Throwable _throwable)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebServiceHelper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework
类 WebServiceHelper

java.lang.Object
    继承者  com.trs.webframework.WebServiceHelper

public class WebServiceHelper
extends java.lang.Object

构造方法摘要
WebServiceHelper()
方法摘要
static java.lang.Object | execute(MethodConfig _methodConfig, MethodContext _methodContext)
static java.lang.Object | execute(MethodConfig _methodConfig, MethodContext _methodContext, boolean _bNotConvertor)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WebServiceHelper

public WebServiceHelper()
方法详细信息

execute

public static java.lang.Object execute(MethodConfig _methodConfig,
                                       MethodContext _methodContext)

execute

public static java.lang.Object execute(MethodConfig _methodConfig,
                                       MethodContext _methodContext,
                                       boolean _bNotConvertor)
参数：
_methodConfig -
context -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.AbstractLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.AbstractLogger
的使用

使用 AbstractLogger 的软件包
com.trs.ajaxservice.logger
com.trs.components.wcm.epress
com.trs.webframework

com.trs.ajaxservice.logger 中 AbstractLogger 的使用

com.trs.ajaxservice.logger 中 AbstractLogger 的子类
class | BatchChannelCreateFromFileLogger Title: TRS 内容协作平台（TRS WCM） Description: 批量创建日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ChannelCreateFromLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ChannelImportLogger Title: TRS 内容协作平台（TRS WCM） Description: 导入频道操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ChannelMoveLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DocCopyLogger
class | DocImportLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DocMoveLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档移动日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DocPublishTaskLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档发布日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DocSaveLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档保存日志 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DocStatusChangeLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档状态改变日志记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | FlowSaveLogger Title: TRS 内容协作平台（TRS WCM） Description: 工作流保存日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | FlowSetLogger Title: TRS 内容协作平台（TRS WCM） Description: 分配工作流到栏目日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ImpartTemplateLogger
class | PublishConfigSaveLogger Title: TRS 内容协作平台（TRS WCM） Description: 发布相关属性日志操作记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | PublishTaskLogger Title: TRS 内容协作平台（TRS WCM） Description: 发布日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | RecycleClearLogger Title: TRS 内容协作平台（TRS WCM） Description: 回收站清空日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | RestoreObjLogger Title: TRS 内容协作平台（TRS WCM） Description: 恢复回收站日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ResyncTemplateApdLogger Title: TRS 内容协作平台（TRS WCM） Description: 同步模板附件操作日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | SetEmployersOfTemplateLogger
class | SiteCreateFromLogger Title: TRS 内容协作平台（TRS WCM） Description: 类似创建站点日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | SiteImportLogger Title: TRS 内容协作平台（TRS WCM） Description: 站点导入日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | SiteRecycleClearLogger Title: TRS 内容协作平台（TRS WCM） Description: 清空站点回收站日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | TemplateImportLogger Title: TRS 内容协作平台（TRS WCM） Description: 导入模板日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TemplateSyncLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | WebSiteRestoreLogger Title: TRS 内容协作平台（TRS WCM） Description: 站点恢复操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 AbstractLogger 的使用

com.trs.components.wcm.epress 中 AbstractLogger 的子类
class | EPressChannelCreateLogger Title: TRS 内容协作平台（TRS WCM） Description: 创建电子报栏目日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | EPressHistoryPubLogger Title: TRS 内容协作平台（TRS WCM） Description: 发布历史索引日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.webframework 中 AbstractLogger 的使用

com.trs.webframework 中 AbstractLogger 的子类
class | DefaultDeleteLogger Title: TRS 内容协作平台（TRS WCM） Description: 默认的删除操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DefaultSaveLogger Title: TRS 内容协作平台（TRS WCM） Description: 默认的保存操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.DefaultDeleteLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.DefaultDeleteLogger
的使用

没有 com.trs.webframework.DefaultDeleteLogger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.DefaultSaveLogger 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.DefaultSaveLogger
的使用

使用 DefaultSaveLogger 的软件包
com.trs.ajaxservice.logger

com.trs.ajaxservice.logger 中 DefaultSaveLogger 的使用

com.trs.ajaxservice.logger 中 DefaultSaveLogger 的子类
 class DocSaveLogger
Title: TRS 内容协作平台（TRS WCM）
Description:
文档保存日志
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.FrameworkConstants 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.FrameworkConstants
的使用

没有 com.trs.webframework.FrameworkConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.ServiceExcuteLogger 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.ServiceExcuteLogger
的使用

使用 ServiceExcuteLogger 的软件包
com.trs.ajaxservice.logger
com.trs.components.wcm.epress
com.trs.webframework

com.trs.ajaxservice.logger 中 ServiceExcuteLogger 的使用

实现 ServiceExcuteLogger 的 com.trs.ajaxservice.logger 中的类
class | BatchChannelCreateFromFileLogger Title: TRS 内容协作平台（TRS WCM） Description: 批量创建日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ChannelCreateFromLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ChannelImportLogger Title: TRS 内容协作平台（TRS WCM） Description: 导入频道操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ChannelMoveLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DocCopyLogger
class | DocImportLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DocMoveLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档移动日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DocPublishTaskLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档发布日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DocSaveLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档保存日志 Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | DocStatusChangeLogger Title: TRS 内容协作平台（TRS WCM） Description: 文档状态改变日志记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | FlowSaveLogger Title: TRS 内容协作平台（TRS WCM） Description: 工作流保存日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | FlowSetLogger Title: TRS 内容协作平台（TRS WCM） Description: 分配工作流到栏目日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | ImpartTemplateLogger
class | PublishConfigSaveLogger Title: TRS 内容协作平台（TRS WCM） Description: 发布相关属性日志操作记录 Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | PublishTaskLogger Title: TRS 内容协作平台（TRS WCM） Description: 发布日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | RecycleClearLogger Title: TRS 内容协作平台（TRS WCM） Description: 回收站清空日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | RestoreObjLogger Title: TRS 内容协作平台（TRS WCM） Description: 恢复回收站日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ResyncTemplateApdLogger Title: TRS 内容协作平台（TRS WCM） Description: 同步模板附件操作日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | SetEmployersOfTemplateLogger
class | SiteCreateFromLogger Title: TRS 内容协作平台（TRS WCM） Description: 类似创建站点日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | SiteImportLogger Title: TRS 内容协作平台（TRS WCM） Description: 站点导入日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | SiteRecycleClearLogger Title: TRS 内容协作平台（TRS WCM） Description: 清空站点回收站日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | TemplateImportLogger Title: TRS 内容协作平台（TRS WCM） Description: 导入模板日志记录 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | TemplateSyncLogger Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | WebSiteRestoreLogger Title: TRS 内容协作平台（TRS WCM） Description: 站点恢复操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 中 ServiceExcuteLogger 的使用

实现 ServiceExcuteLogger 的 com.trs.components.wcm.epress 中的类
class | EPressChannelCreateLogger Title: TRS 内容协作平台（TRS WCM） Description: 创建电子报栏目日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
class | EPressHistoryPubLogger Title: TRS 内容协作平台（TRS WCM） Description: 发布历史索引日志 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)

com.trs.webframework 中 ServiceExcuteLogger 的使用

实现 ServiceExcuteLogger 的 com.trs.webframework 中的类
class | AbstractLogger Title: TRS 内容协作平台（TRS WCM） Description: 日志记录器 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DefaultDeleteLogger Title: TRS 内容协作平台（TRS WCM） Description: 默认的删除操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | DefaultSaveLogger Title: TRS 内容协作平台（TRS WCM） Description: 默认的保存操作日志 Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.WebServiceHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.WebServiceHelper
的使用

没有 com.trs.webframework.WebServiceHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


HashCodeUtil

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 HashCodeUtil

java.lang.Object
    继承者  com.trs.webframework.config.HashCodeUtil

public class HashCodeUtil
extends java.lang.Object

构造方法摘要
HashCodeUtil()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HashCodeUtil

public HashCodeUtil()
方法详细信息

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


LoadingErrorReport

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 LoadingErrorReport

java.lang.Object
    继承者  com.trs.webframework.config.LoadingErrorReport

public class LoadingErrorReport
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LoadingErrorReport()
LoadingErrorReport(java.lang.String _sMsg)
LoadingErrorReport(java.lang.String _sMsg, java.lang.Throwable _ex)
方法摘要
void | add(java.lang.String _sMsg, java.lang.Throwable ex)
java.lang.Exception | getCause()
void | setCause(java.lang.RuntimeException cause)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LoadingErrorReport

public LoadingErrorReport()

LoadingErrorReport

public LoadingErrorReport(java.lang.String _sMsg)

LoadingErrorReport

public LoadingErrorReport(java.lang.String _sMsg,
                          java.lang.Throwable _ex)
方法详细信息

getCause

public java.lang.Exception getCause()

setCause

public void setCause(java.lang.RuntimeException cause)

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

add

public void add(java.lang.String _sMsg,
                java.lang.Throwable ex)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MethodConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 MethodConfig

java.lang.Object
    继承者  com.trs.webframework.config.MethodConfig

public class MethodConfig
extends java.lang.Object

构造方法摘要
MethodConfig(int _nMethodNameHashCode, ServiceConfig _ServiceConfig)
方法摘要
int | getConvertorType()
java.lang.String | getConvertorValue()
java.lang.String | getDesc()
java.lang.String | getLoggerName()
java.lang.String | getLogObjClassName()
int | getMethdoNameHashCode()
java.lang.reflect.Method | getMethod()
java.lang.String | getName()
TRSPageParameter[] | getPageParameter()
IServiceProvider | getProvider()
ServiceConfig | getServiceConfig()
java.lang.String | getTrueName()
java.lang.String | getUri()
java.lang.String | getUrl()
void | initFrom(org.dom4j.Element _elMethod, IServiceProvider _oDefaultProvider)
boolean | isDefaultURI()
boolean | isLogged()
boolean | isPageParametersEmpty()
boolean | isParamsRequired()
void | setMethdoNameHashCode(int methdoNameHashCode)
void | setMethod(java.lang.reflect.Method method)
void | setName(java.lang.String name)
void | setTrueName(java.lang.String trueName)
void | setUri(java.lang.String uri)
void | setUrl(java.lang.String url)
java.lang.String | toString()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MethodConfig

public MethodConfig(int _nMethodNameHashCode,
                    ServiceConfig _ServiceConfig)
方法详细信息

getProvider

public IServiceProvider getProvider()
返回：

getPageParameter

public TRSPageParameter[] getPageParameter()
返回：

initFrom

public void initFrom(org.dom4j.Element _elMethod,
                     IServiceProvider _oDefaultProvider)
              throws CMyException
抛出：
CMyException

isDefaultURI

public boolean isDefaultURI()

getMethdoNameHashCode

public int getMethdoNameHashCode()
返回：

getMethod

public java.lang.reflect.Method getMethod()
返回：

setMethod

public void setMethod(java.lang.reflect.Method method)
参数：
method -

getName

public java.lang.String getName()
返回：

setName

public void setName(java.lang.String name)
参数：
name -

getTrueName

public java.lang.String getTrueName()
返回：

setTrueName

public void setTrueName(java.lang.String trueName)
参数：
trueName -

setMethdoNameHashCode

public void setMethdoNameHashCode(int methdoNameHashCode)
参数：
methdoNameHashCode -

isPageParametersEmpty

public boolean isPageParametersEmpty()

toString

public java.lang.String toString()
覆盖：
类 java.lang.Object 中的 toString

getUri

public java.lang.String getUri()

setUri

public void setUri(java.lang.String uri)

getUrl

public java.lang.String getUrl()

setUrl

public void setUrl(java.lang.String url)

isParamsRequired

public boolean isParamsRequired()

getServiceConfig

public ServiceConfig getServiceConfig()
返回：

getConvertorType

public int getConvertorType()
返回：

getConvertorValue

public java.lang.String getConvertorValue()
返回：

getLoggerName

public java.lang.String getLoggerName()

isLogged

public boolean isLogged()

getLogObjClassName

public java.lang.String getLogObjClassName()

getDesc

public java.lang.String getDesc()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.config
类
HashCodeUtil
LoadingErrorReport
MethodConfig
ServiceConfig
ServiceConfigHelper
ServiceConfigStartServer
ServiceFilterConfig
ServiceFilterConfigs
ServiceListenerConfig
ServiceListenerConfigs
Test
TRSPageParameter
TRSParameter


com.trs.webframework.config

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.config

类摘要
HashCodeUtil |
LoadingErrorReport | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MethodConfig |
ServiceConfig |
ServiceConfigHelper |
ServiceConfigStartServer |
ServiceFilterConfig |
ServiceFilterConfigs |
ServiceListenerConfig |
ServiceListenerConfigs |
Test |
TRSPageParameter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
TRSParameter | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.webframework.config 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.config 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.config.BaseConfigServer
        • com.trs.webframework.config.ServiceConfigStartServer
    • com.trs.webframework.config.HashCodeUtil
    • com.trs.webframework.config.LoadingErrorReport
    • com.trs.webframework.config.MethodConfig
    • com.trs.webframework.config.ServiceConfig
    • com.trs.webframework.config.ServiceConfigHelper
    • com.trs.webframework.config.ServiceFilterConfig
    • com.trs.webframework.config.ServiceFilterConfigs
    • com.trs.webframework.config.ServiceListenerConfig
    • com.trs.webframework.config.ServiceListenerConfigs
    • com.trs.webframework.config.Test
    • com.trs.webframework.config.TRSParameter
      • com.trs.webframework.config.TRSPageParameter


软件包 com.trs.webframework.config 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.config
的使用

使用 com.trs.webframework.config 的软件包
com.trs.ajaxservice.listener
com.trs.ajaxservice.logger
com.trs.components.metadata.service.listener
com.trs.components.wcm.content.domain
com.trs.components.wcm.epress
com.trs.components.wcm.publish.region
com.trs.webframework
com.trs.webframework.config
com.trs.webframework.context
com.trs.webframework.controler
com.trs.webframework.controler.servlet
com.trs.webframework.provider

com.trs.ajaxservice.listener 使用的 com.trs.webframework.config 中的类
ServiceListenerConfig

com.trs.ajaxservice.logger 使用的 com.trs.webframework.config 中的类
MethodConfig

com.trs.components.metadata.service.listener 使用的 com.trs.webframework.config 中的类
ServiceListenerConfig

com.trs.components.wcm.content.domain 使用的 com.trs.webframework.config 中的类
ServiceListenerConfig

com.trs.components.wcm.epress 使用的 com.trs.webframework.config 中的类
MethodConfig

com.trs.components.wcm.publish.region 使用的 com.trs.webframework.config 中的类
ServiceListenerConfig

com.trs.webframework 使用的 com.trs.webframework.config 中的类
MethodConfig

com.trs.webframework.config 使用的 com.trs.webframework.config 中的类
LoadingErrorReport
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MethodConfig
ServiceConfig
ServiceFilterConfig
ServiceListenerConfig
TRSPageParameter
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSParameter
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.context 使用的 com.trs.webframework.config 中的类
MethodConfig

com.trs.webframework.controler 使用的 com.trs.webframework.config 中的类
MethodConfig

com.trs.webframework.controler.servlet 使用的 com.trs.webframework.config 中的类
MethodConfig

com.trs.webframework.provider 使用的 com.trs.webframework.config 中的类
ServiceFilterConfig
ServiceListenerConfig

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ServiceConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 ServiceConfig

java.lang.Object
    继承者  com.trs.webframework.config.ServiceConfig

public class ServiceConfig
extends java.lang.Object

构造方法摘要
ServiceConfig(java.lang.String _sServiceId)
方法摘要
MethodConfig | findMethodByName(java.lang.String _sName)
LoadingErrorReport | getLoadingErrorReport()
java.util.Map | getMethodConfigsMap()
java.lang.String | getObjKlassName()
java.lang.String | getServiceId()
IServiceProvider | getServiceProvider()
java.util.Collection | getServices()
void | loadFromFile(java.lang.String _sConfigFile)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceConfig

public ServiceConfig(java.lang.String _sServiceId)
方法详细信息

getServiceId

public java.lang.String getServiceId()

getServices

public java.util.Collection getServices()

findMethodByName

public MethodConfig findMethodByName(java.lang.String _sName)

loadFromFile

public void loadFromFile(java.lang.String _sConfigFile)

getLoadingErrorReport

public LoadingErrorReport getLoadingErrorReport()

getMethodConfigsMap

public java.util.Map getMethodConfigsMap()

getServiceProvider

public IServiceProvider getServiceProvider()

getObjKlassName

public java.lang.String getObjKlassName()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceConfigHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 ServiceConfigHelper

java.lang.Object
    继承者  com.trs.webframework.config.ServiceConfigHelper

public class ServiceConfigHelper
extends java.lang.Object

构造方法摘要
ServiceConfigHelper()
方法摘要
static MethodConfig | findMethodConfig(java.lang.String _sServiceId, java.lang.String _sMethodName)
static ServiceConfig | findServiceConfig(java.lang.String _sServiceId)
static ServiceFilterConfig[] | findServiceFilterConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取指定服务的所有过滤器
static ServiceListenerConfig[] | findServiceListenerConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取指定服务的所有监听器
static java.lang.String | getSeviceConfigRootPath()
static java.lang.String | getSevicesConfigFileName(java.lang.String _sServiceId)
static boolean | isSelfDefinedMethodName(int _nMethodNameHashCode)
static boolean | isSelfDefinedMethodName(java.lang.String _sMethodName)
static IServiceProvider | makeProvider(java.lang.String _sProviderClassName)
static IServiceProvider | makeProvider(java.lang.String _sProviderClassName, java.lang.String _sDecoratorClassName)
static IServiceProvider | validateProvider(int _nMethodType, IServiceProvider _service)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceConfigHelper

public ServiceConfigHelper()
方法详细信息

getSeviceConfigRootPath

public static java.lang.String getSeviceConfigRootPath()
返回：

getSevicesConfigFileName

public static java.lang.String getSevicesConfigFileName(java.lang.String _sServiceId)

findMethodConfig

public static MethodConfig findMethodConfig(java.lang.String _sServiceId,
                                            java.lang.String _sMethodName)

findServiceConfig

public static ServiceConfig findServiceConfig(java.lang.String _sServiceId)

makeProvider

public static IServiceProvider makeProvider(java.lang.String _sProviderClassName,
                                            java.lang.String _sDecoratorClassName)
参数：
_sProviderClassName -
返回：

findServiceFilterConfigs

public static ServiceFilterConfig[] findServiceFilterConfigs(java.lang.String _sServiceId,
                                                             java.lang.String _sMethodName)
获取指定服务的所有过滤器

参数：
_sServiceId -
_sMethodName -
返回：

findServiceListenerConfigs

public static ServiceListenerConfig[] findServiceListenerConfigs(java.lang.String _sServiceId,
                                                                 java.lang.String _sMethodName)
获取指定服务的所有监听器

参数：
_sServiceId -
_sMethodName -
返回：

makeProvider

public static IServiceProvider makeProvider(java.lang.String _sProviderClassName)

validateProvider

public static IServiceProvider validateProvider(int _nMethodType,
                                                IServiceProvider _service)

isSelfDefinedMethodName

public static boolean isSelfDefinedMethodName(java.lang.String _sMethodName)

isSelfDefinedMethodName

public static boolean isSelfDefinedMethodName(int _nMethodNameHashCode)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceConfigStartServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 ServiceConfigStartServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.config.BaseConfigServer
            继承者  com.trs.webframework.config.ServiceConfigStartServer
所有已实现的接口：
IServer
public class ServiceConfigStartServer
extends BaseConfigServer

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
ServiceConfigStartServer()
方法摘要
ServiceConfig | findServiceConfigById(java.lang.String _sServiceId)
ServiceFilterConfig[] | findServiceFilterConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取给指定服务设定的Filter
ServiceListenerConfig[] | findServiceListenerConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取指定服务设定的Listener
java.util.Map | getServiceConfigsMap()
从类 com.trs.infra.config.BaseConfigServer 继承的方法
getConfigPath, setConfigPath
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceConfigStartServer

public ServiceConfigStartServer()
方法详细信息

findServiceConfigById

public ServiceConfig findServiceConfigById(java.lang.String _sServiceId)

findServiceFilterConfigs

public ServiceFilterConfig[] findServiceFilterConfigs(java.lang.String _sServiceId,
                                                      java.lang.String _sMethodName)
获取给指定服务设定的Filter

参数：
_sServiceId -
_sMethodName -
返回：

findServiceListenerConfigs

public ServiceListenerConfig[] findServiceListenerConfigs(java.lang.String _sServiceId,
                                                          java.lang.String _sMethodName)
获取指定服务设定的Listener

参数：
_sServiceId -
_sMethodName -
返回：

getServiceConfigsMap

public java.util.Map getServiceConfigsMap()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceFilterConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 ServiceFilterConfig

java.lang.Object
    继承者  com.trs.webframework.config.ServiceFilterConfig

public class ServiceFilterConfig
extends java.lang.Object

构造方法摘要
ServiceFilterConfig(java.lang.String _sServiceId, java.lang.String _sMethodName, java.lang.String _sClassName)
方法摘要
java.lang.String | getClassName()
java.lang.String | getMethodName()
java.lang.String | getParameterValue(java.lang.String _sParameterName) 获取Filter的配置参数
IServiceFilter | getServiceFilter() 获取当前配置的Filter
java.lang.String | getServiceId()
void | setClassName(java.lang.String _className)
void | setParameter(java.lang.String _sParameterName, java.lang.String _sValue) 设置Filter的配置参数
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceFilterConfig

public ServiceFilterConfig(java.lang.String _sServiceId,
                           java.lang.String _sMethodName,
                           java.lang.String _sClassName)
                    throws WCMException
抛出：
WCMException
方法详细信息

setParameter

public void setParameter(java.lang.String _sParameterName,
                         java.lang.String _sValue)
设置Filter的配置参数

参数：
_sParameterName -
_sValue -

getParameterValue

public java.lang.String getParameterValue(java.lang.String _sParameterName)
获取Filter的配置参数

参数：
_sParameterName -
返回：

getServiceFilter

public IServiceFilter getServiceFilter()
获取当前配置的Filter

返回：
抛出：
WCMException

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String _className)
                  throws WCMException
参数：
_className -
抛出：
WCMException

getServiceId

public java.lang.String getServiceId()

getMethodName

public java.lang.String getMethodName()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceFilterConfigs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 ServiceFilterConfigs

java.lang.Object
    继承者  com.trs.webframework.config.ServiceFilterConfigs

public class ServiceFilterConfigs
extends java.lang.Object

构造方法摘要
ServiceFilterConfigs()
方法摘要
void | addFromFile(java.lang.String _sServiceIdPre, java.lang.String _sConfigFile)
ServiceFilterConfig[] | findServiceFilterConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName)
LoadingErrorReport | getLoadingErrorReport()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceFilterConfigs

public ServiceFilterConfigs()
方法详细信息

findServiceFilterConfigs

public ServiceFilterConfig[] findServiceFilterConfigs(java.lang.String _sServiceId,
                                                      java.lang.String _sMethodName)

addFromFile

public void addFromFile(java.lang.String _sServiceIdPre,
                        java.lang.String _sConfigFile)

getLoadingErrorReport

public LoadingErrorReport getLoadingErrorReport()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceListenerConfig

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 ServiceListenerConfig

java.lang.Object
    继承者  com.trs.webframework.config.ServiceListenerConfig

public class ServiceListenerConfig
extends java.lang.Object

构造方法摘要
ServiceListenerConfig(java.lang.String _sServiceId, java.lang.String _sMethodName, java.lang.String _sClassName)
方法摘要
java.lang.String | getClassName()
java.lang.String | getMethodName()
java.lang.String | getParameterValue(java.lang.String _sParameterName) 获取Listener的配置参数
java.lang.String | getServiceId()
IServiceListener | getServiceListener() 获取当前配置的Listener
void | setClassName(java.lang.String _className)
void | setParameter(java.lang.String _sParameterName, java.lang.String _sValue) 设置Listener的配置参数
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceListenerConfig

public ServiceListenerConfig(java.lang.String _sServiceId,
                             java.lang.String _sMethodName,
                             java.lang.String _sClassName)
                      throws WCMException
抛出：
WCMException
方法详细信息

setParameter

public void setParameter(java.lang.String _sParameterName,
                         java.lang.String _sValue)
设置Listener的配置参数

参数：
_sParameterName -
_sValue -

getParameterValue

public java.lang.String getParameterValue(java.lang.String _sParameterName)
获取Listener的配置参数

参数：
_sParameterName -
返回：

getServiceListener

public IServiceListener getServiceListener()
获取当前配置的Listener

返回：
抛出：
WCMException

getClassName

public java.lang.String getClassName()
返回：

setClassName

public void setClassName(java.lang.String _className)
                  throws WCMException
参数：
_className -
抛出：
WCMException

getServiceId

public java.lang.String getServiceId()

getMethodName

public java.lang.String getMethodName()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceListenerConfigs

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 ServiceListenerConfigs

java.lang.Object
    继承者  com.trs.webframework.config.ServiceListenerConfigs

public class ServiceListenerConfigs
extends java.lang.Object

构造方法摘要
ServiceListenerConfigs()
方法摘要
void | addFromFile(java.lang.String _sServiceIdPre, java.lang.String _sConfigFile)
ServiceListenerConfig[] | findServiceListenerConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName)
LoadingErrorReport | getLoadingErrorReport()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceListenerConfigs

public ServiceListenerConfigs()
方法详细信息

findServiceListenerConfigs

public ServiceListenerConfig[] findServiceListenerConfigs(java.lang.String _sServiceId,
                                                          java.lang.String _sMethodName)

addFromFile

public void addFromFile(java.lang.String _sServiceIdPre,
                        java.lang.String _sConfigFile)

getLoadingErrorReport

public LoadingErrorReport getLoadingErrorReport()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Test

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 Test

java.lang.Object
    继承者  com.trs.webframework.config.Test

public class Test
extends java.lang.Object

构造方法摘要
Test()
方法摘要
static void main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Test

public Test()
方法详细信息

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSPageParameter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 TRSPageParameter

java.lang.Object
    继承者  com.trs.webframework.config.TRSParameter
        继承者  com.trs.webframework.config.TRSPageParameter

public class TRSPageParameter
extends TRSParameter

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TRSPageParameter()
方法摘要
static TRSPageParameter | createPageParameterFromXML(org.dom4j.Element _elParameter) 通过一个XML数据产生一个PageParameter对象
boolean | fromXML(org.dom4j.Element _element) 从指定的XML Element导入参数数据 fromXMLElement(_element)
java.lang.String | getDefault() 获取默认值
boolean | getDefaultAsBoolean(boolean _bDefaultValue) 将默认值转换为布尔型
CMyDateTime | getDefaultAsDateTime() 将默认值转换为日期类型
double | getDefaultAsDouble(double _dDefaultValue) 将默认值转换为双精度
float | getDefaultAsFloat(float _fDefaultValue) 将默认值转换为浮点数
int | getDefaultAsInt(int _nDefaultValue) 将默认值转换为整型数
long | getDefaultAsLong(long _lDefaultValue) 将默认值转换为长整型
java.lang.String | getDesc() 获取参数描述
java.lang.String | getExcludeValue()
int | getMaxLength() 获取参数允许的最大长度，仅仅对字符类型数据有效
java.lang.String | getMaxValue() 获取允许的最大值，对非字符类型数据有效
int | getMinLength() 获取参数允许的最小长度，仅仅对字符类型数据有效
java.lang.String | getMinValue() 获取允许的最小值，对非字符类型数据有效
java.lang.String | getName() 获取名称
java.lang.String | getSearchExpress(int _nValuesCount)
java.lang.String | getSearchField()
java.lang.String | getSearchOperator()
java.lang.String | getSearchType()
java.lang.String | getType() 获取当前的参数类型
boolean | isExcludeValue(java.lang.String _sValue)
boolean | isFromTable() 参数是否为FromTable
boolean | isOrderBy()
boolean | isRequired() 参数是否需要传入
boolean | isSearch()
boolean | isSelectFields()
void | setDefault(java.lang.String default1) 设置默认值
void | setDesc(java.lang.String desc) 设置参数描述
void | setExcludeValue(java.lang.String excludeValue)
void | setMaxLength(int maxLength) 设置参数允许的最大长度，仅仅对字符类型数据有效
void | setMaxValue(java.lang.String maxValue) 设置允许的最大值，对非字符类型数据有效
void | setMinLength(int minLength) 设置参数允许的最小长度
void | setMinValue(java.lang.String minValue) 设置允许的最小值，对非字符类型数据有效
void | setName(java.lang.String name) 设置名称(必须为英文)
void | setRequired(boolean required) 设置参数是否需要传入
void | setSearch(boolean search)
void | setSearchField(java.lang.String searchField)
void | setSearchOperator(java.lang.String searchOperator)
void | setSearchType(java.lang.String searchType)
void | setType(java.lang.String _sType) 设置当前参数的类型，类型定义为：PageParameter.TYPE_STRING等
从类 com.trs.webframework.config.TRSParameter 继承的方法
getKeys, getProperty, getPropertyAsBoolean, getPropertyAsDateTime, getPropertyAsInt, getPropertyAsLong, getPropertyAsString, main, setPropertyWithString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSPageParameter

public TRSPageParameter()
方法详细信息

isRequired

public boolean isRequired()
参数是否需要传入

返回：
如果需要传入,返回true

setRequired

public void setRequired(boolean required)
设置参数是否需要传入

参数：
required - 如果需要传入:true

getType

public java.lang.String getType()
获取当前的参数类型

返回：

setType

public void setType(java.lang.String _sType)
             throws CMyException
设置当前参数的类型，类型定义为：PageParameter.TYPE_STRING等

参数：
_sType - 参数类型，整型数,类型定义为：PageParameter.TYPE_STRING等
抛出：
CMyException

getDesc

public java.lang.String getDesc()
获取参数描述

返回：
参数描述(String)

setDesc

public void setDesc(java.lang.String desc)
设置参数描述

参数：
desc - 参数描述(String)

getName

public java.lang.String getName()
获取名称

返回：
名称(String)

setName

public void setName(java.lang.String name)
设置名称(必须为英文)

参数：
name -

getMaxLength

public int getMaxLength()
获取参数允许的最大长度，仅仅对字符类型数据有效

返回：
参数允许的最大长度

setMaxLength

public void setMaxLength(int maxLength)
设置参数允许的最大长度，仅仅对字符类型数据有效

参数：
maxLength - 参数允许的最大长度

getMinLength

public int getMinLength()
获取参数允许的最小长度，仅仅对字符类型数据有效

返回：
参数允许的最小长度

setMinLength

public void setMinLength(int minLength)
设置参数允许的最小长度

参数：
minLength - 参数允许的最小长度

getDefault

public java.lang.String getDefault()
获取默认值

返回：
默认值

getDefaultAsInt

public int getDefaultAsInt(int _nDefaultValue)
将默认值转换为整型数

参数：
_nDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
CMyException

getDefaultAsLong

public long getDefaultAsLong(long _lDefaultValue)
将默认值转换为长整型

参数：
_lDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
CMyException

getDefaultAsFloat

public float getDefaultAsFloat(float _fDefaultValue)
将默认值转换为浮点数

参数：
_fDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
CMyException

getDefaultAsBoolean

public boolean getDefaultAsBoolean(boolean _bDefaultValue)
将默认值转换为布尔型

参数：
_bDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
CMyException

getDefaultAsDouble

public double getDefaultAsDouble(double _dDefaultValue)
将默认值转换为双精度

参数：
_dDefaultValue - 没有设置默认值时返回的值
返回：
抛出：
CMyException

getDefaultAsDateTime

public CMyDateTime getDefaultAsDateTime()
                                 throws CMyException
将默认值转换为日期类型

返回：
抛出：
CMyException

setDefault

public void setDefault(java.lang.String default1)
设置默认值

参数：
default1 - 默认值

getMaxValue

public java.lang.String getMaxValue()
获取允许的最大值，对非字符类型数据有效

返回：
允许的最大值 *

setMaxValue

public void setMaxValue(java.lang.String maxValue)
设置允许的最大值，对非字符类型数据有效

参数：
maxValue - 允许的最大值

getMinValue

public java.lang.String getMinValue()
获取允许的最小值，对非字符类型数据有效

返回：
允许的最小值

setMinValue

public void setMinValue(java.lang.String minValue)
设置允许的最小值，对非字符类型数据有效

参数：
minValue - 允许的最小值

fromXML

public boolean fromXML(org.dom4j.Element _element)
                throws CMyException
从类 TRSParameter 复制的描述
从指定的XML Element导入参数数据 fromXMLElement(_element)

覆盖：
类 TRSParameter 中的 fromXML
参数：
_element - 要导入数据的XML Element 元素；
返回：
boolean，若有数据导入，返回true;否则，返回false
抛出：
CMyException

createPageParameterFromXML

public static TRSPageParameter createPageParameterFromXML(org.dom4j.Element _elParameter)
                                                   throws CMyException
通过一个XML数据产生一个PageParameter对象

参数：
_elParameter - XML数据对象
返回：
页面参数对象(PageParameter)
抛出：
CMyException - 数据非法抛出异常

getSearchExpress

public java.lang.String getSearchExpress(int _nValuesCount)

isSearch

public boolean isSearch()
返回：

setSearch

public void setSearch(boolean search)
参数：
search -

getSearchOperator

public java.lang.String getSearchOperator()
返回：

setSearchOperator

public void setSearchOperator(java.lang.String searchOperator)
参数：
searchOperator -

getSearchField

public java.lang.String getSearchField()
返回：

setSearchField

public void setSearchField(java.lang.String searchField)
参数：
searchField -

getSearchType

public java.lang.String getSearchType()
返回：

setSearchType

public void setSearchType(java.lang.String searchType)
参数：
searchType -

getExcludeValue

public java.lang.String getExcludeValue()
返回：

isExcludeValue

public boolean isExcludeValue(java.lang.String _sValue)

setExcludeValue

public void setExcludeValue(java.lang.String excludeValue)
参数：
excludeValue -

isSelectFields

public boolean isSelectFields()
返回：

isFromTable

public boolean isFromTable()
参数是否为FromTable

返回：

isOrderBy

public boolean isOrderBy()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRSParameter

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.config
类 TRSParameter

java.lang.Object
    继承者  com.trs.webframework.config.TRSParameter
直接已知子类：
TRSPageParameter
public abstract class TRSParameter
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
TRSParameter()
方法摘要
boolean | fromXML(org.dom4j.Element _element) 从指定的XML Element导入参数数据 fromXMLElement(_element)
java.util.Enumeration | getKeys()
java.lang.Object | getProperty(java.lang.String _sName) 取对象属性值
boolean | getPropertyAsBoolean(java.lang.String _sName, boolean _bDefault) 取布尔型属性值 说明：0值为false，非0值为true
CMyDateTime | getPropertyAsDateTime(java.lang.String _sName) 取日期时间型属性值
int | getPropertyAsInt(java.lang.String _sName, int _nDefault) 取长整型属性值
long | getPropertyAsLong(java.lang.String _sName, long _lDefault) 取长整型属性值
java.lang.String | getPropertyAsString(java.lang.String _sName) 取字符串型属性值
static void | main(java.lang.String[] args)
boolean | setPropertyWithString(java.lang.String _sName, java.lang.String _sValue) 用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TRSParameter

public TRSParameter()
方法详细信息

getKeys

public java.util.Enumeration getKeys()

fromXML

public boolean fromXML(org.dom4j.Element _element)
                throws CMyException
从指定的XML Element导入参数数据 fromXMLElement(_element)

参数：
_element - 要导入数据的XML Element 元素；
返回：
boolean，若有数据导入，返回true;否则，返回false
抛出：
CMyException

setPropertyWithString

public boolean setPropertyWithString(java.lang.String _sName,
                                     java.lang.String _sValue)
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象

参数：
_sName - 属性名
_sValue - 属性值
返回：
抛出：
CMyException

getProperty

public java.lang.Object getProperty(java.lang.String _sName)
取对象属性值

参数：
_sName - 属性字段名称
返回：
返回属性对象(Object)，目前为String

getPropertyAsString

public java.lang.String getPropertyAsString(java.lang.String _sName)
取字符串型属性值

参数：
_sName - 属性字段名称
返回：
String对象

getPropertyAsDateTime

public CMyDateTime getPropertyAsDateTime(java.lang.String _sName)
                                  throws CMyException
取日期时间型属性值

参数：
_sName - 属性字段名称
返回：
CMyDateTime对象
抛出：
CMyException

getPropertyAsLong

public long getPropertyAsLong(java.lang.String _sName,
                              long _lDefault)
                       throws CMyException
取长整型属性值

参数：
_sName - 属性字段名称
_lDefault - 默认值
返回：
long类型的属性值
抛出：
CMyException

getPropertyAsInt

public int getPropertyAsInt(java.lang.String _sName,
                            int _nDefault)
                     throws CMyException
取长整型属性值

参数：
_sName - 属性字段名称
_nDefault - 默认值
返回：
int类型的属性值
抛出：
CMyException

getPropertyAsBoolean

public boolean getPropertyAsBoolean(java.lang.String _sName,
                                    boolean _bDefault)
                             throws CMyException
取布尔型属性值 说明：0值为false，非0值为true

参数：
_sName - 属性名
_bDefault - 默认值
返回：
boolean类型的属性值
抛出：
CMyException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.config.HashCodeUtil 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.HashCodeUtil
的使用

没有 com.trs.webframework.config.HashCodeUtil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.LoadingErrorReport 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.LoadingErrorReport
的使用

使用 LoadingErrorReport 的软件包
com.trs.webframework.config

com.trs.webframework.config 中 LoadingErrorReport 的使用

返回 LoadingErrorReport 的 com.trs.webframework.config 中的方法
LoadingErrorReport | ServiceListenerConfigs.getLoadingErrorReport()
LoadingErrorReport | ServiceConfig.getLoadingErrorReport()
LoadingErrorReport | ServiceFilterConfigs.getLoadingErrorReport()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.MethodConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.MethodConfig
的使用

使用 MethodConfig 的软件包
com.trs.ajaxservice.logger
com.trs.components.wcm.epress
com.trs.webframework
com.trs.webframework.config
com.trs.webframework.context
com.trs.webframework.controler
com.trs.webframework.controler.servlet

com.trs.ajaxservice.logger 中 MethodConfig 的使用

参数类型为 MethodConfig 的 com.trs.ajaxservice.logger 中的方法
int | WebSiteRestoreLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | TemplateSyncLogger.startLog(MethodConfig conf, MethodContext context)
int | TemplateImportLogger.startLog(MethodConfig conf, MethodContext context)
int | SiteRecycleClearLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | SiteImportLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | SiteCreateFromLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | SetEmployersOfTemplateLogger.startLog(MethodConfig _oConf, MethodContext _oContext)
int | ResyncTemplateApdLogger.startLog(MethodConfig conf, MethodContext context)
int | RestoreObjLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | RecycleClearLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | PublishTaskLogger.startLog(MethodConfig conf, MethodContext context)
int | PublishConfigSaveLogger.startLog(MethodConfig conf, MethodContext context)
int | ImpartTemplateLogger.startLog(MethodConfig _oConf, MethodContext _oContext)
int | FlowSetLogger.startLog(MethodConfig conf, MethodContext context)
int | FlowSaveLogger.startLog(MethodConfig conf, MethodContext context)
int | DocStatusChangeLogger.startLog(MethodConfig conf, MethodContext context)
int | DocSaveLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | DocPublishTaskLogger.startLog(MethodConfig conf, MethodContext context)
int | DocMoveLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | DocImportLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | DocCopyLogger.startLog(MethodConfig _oConf, MethodContext _oContext)
int | ChannelMoveLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | ChannelImportLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | ChannelCreateFromLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | BatchChannelCreateFromFileLogger.startLog(MethodConfig conf, MethodContext context)

com.trs.components.wcm.epress 中 MethodConfig 的使用

参数类型为 MethodConfig 的 com.trs.components.wcm.epress 中的方法
int | EPressHistoryPubLogger.startLog(MethodConfig conf, MethodContext context)
int | EPressChannelCreateLogger.startLog(MethodConfig conf, MethodContext context)

com.trs.webframework 中 MethodConfig 的使用

参数类型为 MethodConfig 的 com.trs.webframework 中的方法
static java.lang.Object | WebServiceHelper.execute(MethodConfig _methodConfig, MethodContext _methodContext)
static java.lang.Object | WebServiceHelper.execute(MethodConfig _methodConfig, MethodContext _methodContext, boolean _bNotConvertor)
int | DefaultSaveLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | DefaultDeleteLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | ServiceExcuteLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)

com.trs.webframework.config 中 MethodConfig 的使用

返回 MethodConfig 的 com.trs.webframework.config 中的方法
MethodConfig | ServiceConfig.findMethodByName(java.lang.String _sName)
static MethodConfig | ServiceConfigHelper.findMethodConfig(java.lang.String _sServiceId, java.lang.String _sMethodName)

com.trs.webframework.context 中 MethodConfig 的使用

返回 MethodConfig 的 com.trs.webframework.context 中的方法
 MethodConfig MethodContext.getMethodConfig()

参数类型为 MethodConfig 的 com.trs.webframework.context 中的构造方法
MethodContext(MethodConfig _methodConfig)

com.trs.webframework.controler 中 MethodConfig 的使用

参数类型为 MethodConfig 的 com.trs.webframework.controler 中的构造方法
JSPRequestParmasValidator(ServiceContext _requestContext, MethodConfig methoConfig)

com.trs.webframework.controler.servlet 中 MethodConfig 的使用

参数类型为 MethodConfig 的 com.trs.webframework.controler.servlet 中的构造方法
BaseValidator(MethodConfig methoConfig)
RequestParmasValidator(ServiceContext _requestContext, MethodConfig methoConfig)
XMLParamsValidator(java.util.Map _hParmasMap, MethodConfig methoConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.ServiceConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.ServiceConfig
的使用

使用 ServiceConfig 的软件包
com.trs.webframework.config

com.trs.webframework.config 中 ServiceConfig 的使用

返回 ServiceConfig 的 com.trs.webframework.config 中的方法
static ServiceConfig | ServiceConfigHelper.findServiceConfig(java.lang.String _sServiceId)
ServiceConfig | ServiceConfigStartServer.findServiceConfigById(java.lang.String _sServiceId)
ServiceConfig | MethodConfig.getServiceConfig()

参数类型为 ServiceConfig 的 com.trs.webframework.config 中的构造方法
MethodConfig(int _nMethodNameHashCode, ServiceConfig _ServiceConfig)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.ServiceConfigHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.ServiceConfigHelper
的使用

没有 com.trs.webframework.config.ServiceConfigHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.ServiceConfigStartServer 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.ServiceConfigStartServer
的使用

没有 com.trs.webframework.config.ServiceConfigStartServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.ServiceFilterConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.ServiceFilterConfig
的使用

使用 ServiceFilterConfig 的软件包
com.trs.webframework.config
com.trs.webframework.provider

com.trs.webframework.config 中 ServiceFilterConfig 的使用

返回 ServiceFilterConfig 的 com.trs.webframework.config 中的方法
static ServiceFilterConfig[] | ServiceConfigHelper.findServiceFilterConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取指定服务的所有过滤器
ServiceFilterConfig[] | ServiceConfigStartServer.findServiceFilterConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取给指定服务设定的Filter
ServiceFilterConfig[] | ServiceFilterConfigs.findServiceFilterConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName)

com.trs.webframework.provider 中 ServiceFilterConfig 的使用

参数类型为 ServiceFilterConfig 的 com.trs.webframework.provider 中的方法
boolean | ServiceFilterExample.doFilter(ServiceFilterConfig _oFilterConfig, MethodContext _oMethodContext)
boolean | IServiceFilter.doFilter(ServiceFilterConfig _oFilterConfig, MethodContext _oMethodContext) * 在执行服务之前，在这个方法中可以： 1、根据当前上下文参数，判断操作是否可以继续 2、如果不能继续，也可以通过MethodContext获取当前Servlet上下文参数，做重定向 3、也能够修改MethodContext

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.ServiceFilterConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.ServiceFilterConfigs
的使用

没有 com.trs.webframework.config.ServiceFilterConfigs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.ServiceListenerConfig 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.ServiceListenerConfig
的使用

使用 ServiceListenerConfig 的软件包
com.trs.ajaxservice.listener
com.trs.components.metadata.service.listener
com.trs.components.wcm.content.domain
com.trs.components.wcm.publish.region
com.trs.webframework.config
com.trs.webframework.provider

com.trs.ajaxservice.listener 中 ServiceListenerConfig 的使用

参数类型为 ServiceListenerConfig 的 com.trs.ajaxservice.listener 中的方法
void | SaveMembersListenerForObjectMember.afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
void | MoveChannelListenerForChannel.afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)

com.trs.components.metadata.service.listener 中 ServiceListenerConfig 的使用

参数类型为 ServiceListenerConfig 的 com.trs.components.metadata.service.listener 中的方法
void | ViewDocumentListenerForPubGovInfo.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
void | PublishListenerForPubGovInfo.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
void | ChannelCreateFromListenerForMetaView.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)

com.trs.components.wcm.content.domain 中 ServiceListenerConfig 的使用

参数类型为 ServiceListenerConfig 的 com.trs.components.wcm.content.domain 中的方法
 void DocumentMoveListenerForDocSiteRecode.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)

com.trs.components.wcm.publish.region 中 ServiceListenerConfig 的使用

参数类型为 ServiceListenerConfig 的 com.trs.components.wcm.publish.region 中的方法
void | TemplateSaveListenerForRegionEmploy.afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
void | CellsSaveListenerForPublish.afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)

com.trs.webframework.config 中 ServiceListenerConfig 的使用

返回 ServiceListenerConfig 的 com.trs.webframework.config 中的方法
static ServiceListenerConfig[] | ServiceConfigHelper.findServiceListenerConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取指定服务的所有监听器
ServiceListenerConfig[] | ServiceListenerConfigs.findServiceListenerConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName)
ServiceListenerConfig[] | ServiceConfigStartServer.findServiceListenerConfigs(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取指定服务设定的Listener

com.trs.webframework.provider 中 ServiceListenerConfig 的使用

参数类型为 ServiceListenerConfig 的 com.trs.webframework.provider 中的方法
void | ServiceListenerExample.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
void | IServiceListener.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult) 在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.ServiceListenerConfigs 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.ServiceListenerConfigs
的使用

没有 com.trs.webframework.config.ServiceListenerConfigs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.Test 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.Test
的使用

没有 com.trs.webframework.config.Test 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.TRSPageParameter 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.TRSPageParameter
的使用

使用 TRSPageParameter 的软件包
com.trs.webframework.config

com.trs.webframework.config 中 TRSPageParameter 的使用

返回 TRSPageParameter 的 com.trs.webframework.config 中的方法
static TRSPageParameter | TRSPageParameter.createPageParameterFromXML(org.dom4j.Element _elParameter) 通过一个XML数据产生一个PageParameter对象
TRSPageParameter[] | MethodConfig.getPageParameter()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.config.TRSParameter 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.config.TRSParameter
的使用

使用 TRSParameter 的软件包
com.trs.webframework.config

com.trs.webframework.config 中 TRSParameter 的使用

com.trs.webframework.config 中 TRSParameter 的子类
 class TRSPageParameter
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


MethodContext

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.context
类 MethodContext

java.lang.Object
    继承者  com.trs.webframework.context.MethodContext

public class MethodContext
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
MethodContext(MethodConfig _methodConfig)
方法摘要
boolean | containsParameter(java.lang.String paramName)
java.lang.Object | getContextCacheData(java.lang.Object key) 获取MethodContext对象中放入临时缓存的对象
BaseObj | getCurrHost()
WCMFilter | getExtraWCMFilter()
MethodConfig | getMethodConfig()
int | getObjectId()
java.lang.String | getObjectIds()
java.lang.Object | getObjectValue(java.lang.String _sParameterName)
int | getPageIndex() 获取当前的页码，从1开始；默认为第一页
int | getPageSize() 获取当前的分页大小，默认为20
java.util.Map | getParams()
java.lang.String[] | getParamValues(java.lang.String _sParamName)
QueryFilter | getQueryFilter()
ServiceContext | getServiceContext()
java.lang.String | getValue(java.lang.String _sParameterName)
boolean | getValue(java.lang.String _sParameterName, boolean _bDefaultValue)
CMyDateTime | getValue(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
double | getValue(java.lang.String _sParameterName, double _dDefaultValue)
float | getValue(java.lang.String _sParameterName, float _fDefaultValue)
int | getValue(java.lang.String _sParameterName, int _nDefaultValue)
long | getValue(java.lang.String _sParameterName, long _lDefaultValue)
java.util.Map | getValues()
boolean | isEmptyOfParameterValues()
boolean | isReturnHTML()
boolean | isReturnJSON() 判断当前返回值是否是JSON
boolean | isValidObjectId()
void | putContextCacheData(java.util.Map _oCacheData) 将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用
void | putContextCacheData(java.lang.Object key, java.lang.Object _value) 将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用
void | setContentType(java.lang.String _sContentType)
void | setContentTypeIsHTML()
void | setCurrHost(BaseObj _oCurrHost) 设置当前方法时候关联的主要对象
void | setObjectId(int _nId)
void | setObjectIds(java.lang.String _sObjectIds)
void | setParamValues(java.lang.String _sParamName, java.lang.String[] _arValues)
void | setQueryFilter(QueryFilter filter)
void | setReturnHTML(boolean returnHTML)
void | setReturnJSON(boolean _bReturnJSON) 设置返回值为JSON
void | setServiceContext(ServiceContext _serviceContext)
void | setValue(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
void | setValue(java.lang.String _sParameterName, double _dDefaultValue)
void | setValue(java.lang.String _sParameterName, float _fDefaultValue)
void | setValue(java.lang.String _sParameterName, int _nDefaultValue)
void | setValue(java.lang.String _sParameterName, long _lDefaultValue)
void | setValue(java.lang.String _sParameterName, java.lang.Object _oValue)
void | setValue(java.lang.String _sParameterName, java.lang.String _sValue)
void | setValues(java.util.Map values)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MethodContext

public MethodContext(MethodConfig _methodConfig)
方法详细信息

isReturnHTML

public boolean isReturnHTML()
返回：

setReturnHTML

public void setReturnHTML(boolean returnHTML)
参数：
returnHTML -

getQueryFilter

public QueryFilter getQueryFilter()
返回：

getExtraWCMFilter

public WCMFilter getExtraWCMFilter()

setQueryFilter

public void setQueryFilter(QueryFilter filter)
参数：
filter -

getObjectIds

public java.lang.String getObjectIds()
返回：

setObjectIds

public void setObjectIds(java.lang.String _sObjectIds)
参数：
deleteIds -

getObjectId

public int getObjectId()

setObjectId

public void setObjectId(int _nId)

getValue

public java.lang.String getValue(java.lang.String _sParameterName)

getObjectValue

public java.lang.Object getObjectValue(java.lang.String _sParameterName)

getValue

public boolean getValue(java.lang.String _sParameterName,
                        boolean _bDefaultValue)

getValue

public int getValue(java.lang.String _sParameterName,
                    int _nDefaultValue)

getValue

public long getValue(java.lang.String _sParameterName,
                     long _lDefaultValue)

getValue

public double getValue(java.lang.String _sParameterName,
                       double _dDefaultValue)

getValue

public float getValue(java.lang.String _sParameterName,
                      float _fDefaultValue)

getValue

public CMyDateTime getValue(java.lang.String _sParameterName,
                            CMyDateTime _dtDefaultValue)

setParamValues

public void setParamValues(java.lang.String _sParamName,
                           java.lang.String[] _arValues)

getParamValues

public java.lang.String[] getParamValues(java.lang.String _sParamName)

getParams

public java.util.Map getParams()

setValue

public void setValue(java.lang.String _sParameterName,
                     java.lang.Object _oValue)

setValue

public void setValue(java.lang.String _sParameterName,
                     java.lang.String _sValue)

setValue

public void setValue(java.lang.String _sParameterName,
                     int _nDefaultValue)

setValue

public void setValue(java.lang.String _sParameterName,
                     long _lDefaultValue)

setValue

public void setValue(java.lang.String _sParameterName,
                     float _fDefaultValue)

setValue

public void setValue(java.lang.String _sParameterName,
                     double _dDefaultValue)

setValue

public void setValue(java.lang.String _sParameterName,
                     CMyDateTime _dtDefaultValue)

getValues

public java.util.Map getValues()
返回：

setValues

public void setValues(java.util.Map values)
参数：
values -

containsParameter

public boolean containsParameter(java.lang.String paramName)
参数：
paramName -
返回：

isEmptyOfParameterValues

public boolean isEmptyOfParameterValues()
返回：

setServiceContext

public void setServiceContext(ServiceContext _serviceContext)
参数：
_serviceContext -

getServiceContext

public ServiceContext getServiceContext()
返回：

getMethodConfig

public MethodConfig getMethodConfig()
返回：

isValidObjectId

public boolean isValidObjectId()

isReturnJSON

public boolean isReturnJSON()
判断当前返回值是否是JSON

返回：

setReturnJSON

public void setReturnJSON(boolean _bReturnJSON)
设置返回值为JSON

参数：
_bReturnJSON -

setContentType

public void setContentType(java.lang.String _sContentType)

setContentTypeIsHTML

public void setContentTypeIsHTML()

putContextCacheData

public void putContextCacheData(java.util.Map _oCacheData)
将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用

参数：
_oCacheData - 需要Cache的数据

putContextCacheData

public void putContextCacheData(java.lang.Object key,
                                java.lang.Object _value)
将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用

参数：
key - Cache的Key
_value - 缓存的对象

getContextCacheData

public java.lang.Object getContextCacheData(java.lang.Object key)
获取MethodContext对象中放入临时缓存的对象

参数：
key -
返回：

getPageSize

public int getPageSize()
获取当前的分页大小，默认为20

返回：

getPageIndex

public int getPageIndex()
获取当前的页码，从1开始；默认为第一页

返回：

getCurrHost

public BaseObj getCurrHost()
返回：
当前方法时候关联的主要对象，系统持久化对象

setCurrHost

public void setCurrHost(BaseObj _oCurrHost)
设置当前方法时候关联的主要对象

参数：
_oCurrHost - 当前方法时候关联的主要对象，系统持久化对象
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MethodContextHelper

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.context
类 MethodContextHelper

java.lang.Object
    继承者  com.trs.webframework.context.MethodContextHelper

public class MethodContextHelper
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司 gronlet(gongfuchang)

字段摘要
static java.lang.String | ATTR_NAME_SEARCHKEY
static java.lang.String | ATTR_NAME_SEARCHVALUE
static java.lang.String | NAME_PARAMETER_ORDERBY_FIELD
static java.lang.String | NAME_PARAMETER_ORDERBY_TYPE
方法摘要
static WCMFilter mergeMoreFilter(MethodContext _context, WCMFilter _filter)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ATTR_NAME_SEARCHKEY

public static final java.lang.String ATTR_NAME_SEARCHKEY
另请参见：
常量字段值

ATTR_NAME_SEARCHVALUE

public static final java.lang.String ATTR_NAME_SEARCHVALUE
另请参见：
常量字段值

NAME_PARAMETER_ORDERBY_TYPE

public static final java.lang.String NAME_PARAMETER_ORDERBY_TYPE
另请参见：
常量字段值

NAME_PARAMETER_ORDERBY_FIELD

public static final java.lang.String NAME_PARAMETER_ORDERBY_FIELD
另请参见：
常量字段值
方法详细信息

mergeMoreFilter

public static WCMFilter mergeMoreFilter(MethodContext _context,
                                        WCMFilter _filter)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.context
类
MethodContext
MethodContextHelper
ServiceContext


com.trs.webframework.context

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.context

类摘要
MethodContext | Title: TRS 内容协作平台（TRS WCM） Description: Provider中方法上下文服务相关对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MethodContextHelper | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceContext | Title: TRS 内容协作平台（TRS WCM 6.0） Description: Service上下文信息记录对象 Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.webframework.context 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.context 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.context.MethodContext
    • com.trs.webframework.context.MethodContextHelper
    • com.trs.webframework.context.ServiceContext


软件包 com.trs.webframework.context 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.context
的使用

使用 com.trs.webframework.context 的软件包
com.trs.ajaxservice
com.trs.ajaxservice.listener
com.trs.ajaxservice.logger
com.trs.ajaxservice.xmlconvertors
com.trs.components.common.publish.widget
com.trs.components.filter
com.trs.components.infoview.helper
com.trs.components.infoview.mad
com.trs.components.metadata.service
com.trs.components.metadata.service.listener
com.trs.components.metadata.service.xmlconvertors
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.epress
com.trs.components.wcm.publish.region
com.trs.webframework
com.trs.webframework.context
com.trs.webframework.controler
com.trs.webframework.controler.servlet
com.trs.webframework.demo
com.trs.webframework.provider
com.trs.webframework.xmlserver
com.trs.webframework.xmlserver.convertors
com.trs.webframework.xmlserver.server
com.trsothers

com.trs.ajaxservice 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.ajaxservice.listener 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.ajaxservice.logger 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.ajaxservice.xmlconvertors 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.filter 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.helper 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.infoview.mad 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service.listener 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service.xmlconvertors 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.special 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.epress 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.context 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceContext
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.controler 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceContext
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.controler.servlet 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceContext
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.demo 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceContext
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.xmlserver 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.xmlserver.convertors 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.xmlserver.server 使用的 com.trs.webframework.context 中的类
ServiceContext
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trsothers 使用的 com.trs.webframework.context 中的类
MethodContext
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ServiceContext

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.context
类 ServiceContext

java.lang.Object
    继承者  com.trs.webframework.context.ServiceContext
直接已知子类：
JSPServiceContext
public class ServiceContext
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static boolean IS_CONSOLE_TEST
构造方法摘要
ServiceContext()
ServiceContext(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response)
方法摘要
static ServiceContext | create(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response)
static ServiceContext | getCurrentServiceContext()
java.io.InputStream | getInputStream()
ServletInputStreamWrapper | getInputStreamWrapper()
java.util.Enumeration | getParameterNames()
java.util.Map | getParameters()
java.lang.String | getParameterValue(java.lang.String _sParameterName)
java.lang.String[] | getParameterValues(java.lang.String _sParameterName)
javax.servlet.http.HttpServletRequest | getRequest()
javax.servlet.http.HttpServletResponse | getResponse()
java.lang.Object | getSessionValue(java.lang.String _sSessionKey)
boolean | isReturnHTML()
boolean | isReturnJSON()
void | setContentType(java.lang.String _sContentType)
void | setContentTypeIsHTML()
void | setInputStreamWrapper(ServletInputStreamWrapper _isw)
void | setReturnHTML(boolean returnHTML)
void | setReturnJSON(boolean returnJSON)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_CONSOLE_TEST

public static boolean IS_CONSOLE_TEST
构造方法详细信息

ServiceContext

public ServiceContext()

ServiceContext

public ServiceContext(javax.servlet.http.HttpServletRequest _request,
                      javax.servlet.http.HttpServletResponse _response)
方法详细信息

create

public static ServiceContext create(javax.servlet.http.HttpServletRequest _request,
                                    javax.servlet.http.HttpServletResponse _response)

getCurrentServiceContext

public static ServiceContext getCurrentServiceContext()

getParameterValues

public java.lang.String[] getParameterValues(java.lang.String _sParameterName)

getParameterValue

public java.lang.String getParameterValue(java.lang.String _sParameterName)

getParameterNames

public java.util.Enumeration getParameterNames()

getParameters

public java.util.Map getParameters()

getRequest

public javax.servlet.http.HttpServletRequest getRequest()

getResponse

public javax.servlet.http.HttpServletResponse getResponse()

getInputStreamWrapper

public ServletInputStreamWrapper getInputStreamWrapper()

setInputStreamWrapper

public void setInputStreamWrapper(ServletInputStreamWrapper _isw)

getInputStream

public java.io.InputStream getInputStream()

setContentTypeIsHTML

public void setContentTypeIsHTML()

setContentType

public void setContentType(java.lang.String _sContentType)

getSessionValue

public java.lang.Object getSessionValue(java.lang.String _sSessionKey)

isReturnJSON

public boolean isReturnJSON()
返回：

setReturnJSON

public void setReturnJSON(boolean returnJSON)
参数：
returnJSON -

isReturnHTML

public boolean isReturnHTML()
返回：

setReturnHTML

public void setReturnHTML(boolean returnHTML)
参数：
returnHTML -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.context.MethodContext 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.context.MethodContext
的使用

使用 MethodContext 的软件包
com.trs.ajaxservice
com.trs.ajaxservice.listener
com.trs.ajaxservice.logger
com.trs.ajaxservice.xmlconvertors
com.trs.components.common.publish.widget
com.trs.components.filter
com.trs.components.infoview.helper
com.trs.components.infoview.mad
com.trs.components.metadata.service
com.trs.components.metadata.service.listener
com.trs.components.metadata.service.xmlconvertors
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.epress
com.trs.components.wcm.publish.region
com.trs.webframework
com.trs.webframework.context
com.trs.webframework.controler
com.trs.webframework.controler.servlet
com.trs.webframework.demo
com.trs.webframework.provider
com.trs.webframework.xmlserver
com.trs.webframework.xmlserver.convertors
com.trsothers

com.trs.ajaxservice 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.ajaxservice 中的方法
void | InfoviewDataToolService.adapterHistory(MethodContext _context) 1.为系统所有视图创建表结构 2.替换视图的检索字段，概览字段，自动生成相应的DB字段 3.替换栏目的检索字段，自动生成相应的DB字段 4.同步文档的DocFlag到ChnlDoc表中
void | DocumentServiceProvider.addAppendixes(MethodContext _methodContext) 添加指定文档的相关文档 只做新增
java.lang.Object | PhotoServiceProvider.addBorder(MethodContext _context)
java.lang.Object | ContentLinkServiceProvider.addLinkInChannel(MethodContext _context)
void | InfoviewService.assertSignData(MethodContext _context)
int | WebSiteServiceProvider.autoCreate(MethodContext _methodContext) 智能建站
void | InfoviewDataToolService.autoCreateHistoryDocs(MethodContext _context) 遍历docflag>0的文档列表，保存相关的字段，生成新的表单数据
boolean | ProcessService.backTo(MethodContext _methodContext) 要求返工
java.lang.String | DocumentBakServiceProvider.backup(MethodContext _methodContext) 保存指定文档的版本
void | TemplateServiceProvider.cancelArgVal(MethodContext _context)
void | WebSiteServiceProvider.changeOrder(MethodContext _methodContext) 调整栏目顺序
void | DocumentServiceProvider.changeOrder(MethodContext _methodContext) 改变属性
void | ChannelServiceProvider.changeOrder(MethodContext _methodContext) 调整栏目顺序
java.lang.Object | ContentLinkServiceProvider.changeOrder(MethodContext _context)
void | ChnlDocServiceProvider.changeStatus(MethodContext _methodContext) 改变多篇文档的状态
void | ViewDocumentServiceProvider.changeStatus(MethodContext _methodContext) 改变多篇文档的状态
void | DocumentServiceProvider.changeStatus(MethodContext _methodContext) 改变多篇文档的状态
java.lang.String | TemplateServiceProvider.check(MethodContext _methodContext) 校验选中的模板
java.lang.String | ChannelServiceProvider.checkSQLValid(MethodContext _context)
void | InfoviewService.checkSysInfos(MethodContext _context)
java.lang.String | TemplateServiceProvider.checkTemplateText(MethodContext _methodContext) 校验指定的模板内容
java.lang.String | TemplateServiceProvider.checkWCAG2TemplateText(MethodContext _methodContext)
void | ViewDocumentServiceProvider.clearRecycle(MethodContext _methodContext) 清空回收站所有的文档
void | DocumentServiceProvider.clearRecycle(MethodContext _methodContext) 恢复回收站中的文档
void | ChannelServiceProvider.clearRecycle(MethodContext _methodContext) 清空子栏目回收站
java.lang.String | ViewDocumentServiceProvider.cloneFile(MethodContext _methodContext)
Documents | SceneServiceProvider.cloneFromOtherFlow(MethodContext _methodContext)
Reports | ChnlDocServiceProvider.copy(MethodContext _methodContext) 拷贝文档
Reports | ViewDocumentServiceProvider.copy(MethodContext _methodContext) 拷贝文档
Reports | DocumentServiceProvider.copy(MethodContext _methodContext) 拷贝文档
Reports | DocumentServiceProvider.copyAll(MethodContext _methodContext) 复制全部文档到
java.lang.String | ChannelServiceProvider.createChannelTreeHTMLOfIds(MethodContext _methodContext) 产生指定栏目ID的子栏目序列树HTML
java.lang.String | WebSiteServiceProvider.createFrom(MethodContext _MethodContext) 类似创建站点
java.lang.String | ProcessService.createFrom(MethodContext _methodContext) 类似创建工作流，省得为了类似创建工作流时要导入+导出
java.lang.String | ChannelServiceProvider.createFrom(MethodContext _MethodContext) 类似创建栏目
void | WebSiteServiceProvider.createFromFile(MethodContext _methodContext)
void | ChannelServiceProvider.createFromFile(MethodContext _methodContext)
void | ContentLinkServiceProvider.createFromFile(MethodContext _context) 导入txt文件来批量创建热词
java.lang.Object | PhotoServiceProvider.cropImage(MethodContext _context) 用于裁剪图片
void | StatusServiceProvider.delete(MethodContext _context)
void | DocumentSynServiceProvider.delete(MethodContext _methodContext)
void | UserServiceProvider.delete(MethodContext _methodContext)
void | ReplaceContentServiceProvider.delete(MethodContext _methodContext)
void | GroupServiceProvider.delete(MethodContext _methodContext)
void | ChnlDocServiceProvider.delete(MethodContext _methContext)
void | RoleServiceProvider.delete(MethodContext context)
void | IndividuationServiceProvider.delete(MethodContext _methodContext)
void | WebSiteServiceProvider.delete(MethodContext _methContext)
void | TemplateServiceHelperProvider.delete(MethodContext context)
void | ProcessService.delete(MethodContext _methodContext)
void | ExtendFieldServiceProvider.delete(MethodContext _methContext)
void | ViewDocumentServiceProvider.delete(MethodContext _methContext)
void | InfoviewService.delete(MethodContext context)
void | DocumentServiceProvider.delete(MethodContext _methContext)
void | DistributeServiceProvider.delete(MethodContext _methContext)
void | ObjectMemberServiceProvider.delete(MethodContext _oContext)
void | SourceServiceProvider.delete(MethodContext _methContext)
void | PhotoServiceProvider.delete(MethodContext _context)
void | DocumentBakServiceProvider.delete(MethodContext _methodContext)
void | ChannelServiceProvider.delete(MethodContext _methContext)
void | MessageServiceProvider.delete(MethodContext _methodContext)
void | TemplateServiceProvider.delete(MethodContext _methContext)
void | ContentLinkServiceProvider.delete(MethodContext _methodContext)
void | WatermarkServiceProvider.delete(MethodContext _context)
java.lang.String | AuthServiceProvider.deleteOperatorRight(MethodContext _methodContext)
void | ProcessService.disableFlowToChannel(MethodContext _methodContext) 取消给指定栏目启用的工作流
boolean | ProcessService.doAccept(MethodContext _MethodContext)
boolean | ProcessService.doReceive(MethodContext _MethodContext)
void | ViewDocumentServiceProvider.editDocuments(MethodContext _methContext) 批量修改文档属性
java.lang.Object | ContentLinkServiceProvider.editLinkInChannel(MethodContext _context)
void | ProcessService.enableFlowToChannel(MethodContext _methodContext) 给指定栏目启动启用指定的工作流
java.lang.Object | WebSiteServiceProvider.existsSimilarDataPath(MethodContext _methodContext) 在指定的站点或者栏目下是否存在相同存放路径的栏目
java.lang.Object | ChannelServiceProvider.existsSimilarDataPath(MethodContext _methodContext) 在指定的站点或者栏目下是否存在相同存放路径的栏目
boolean | ReplaceContentServiceProvider.existsSimilarName(MethodContext _methodContext) 是否存在相同名称的栏目
boolean | WebSiteServiceProvider.existsSimilarName(MethodContext _methodContext) 是否存在相同名称的站点
java.lang.String | ExtendFieldServiceProvider.existsSimilarName(MethodContext _methodContext) 判断指定扩展字段是否有效
boolean | ChannelServiceProvider.existsSimilarName(MethodContext _methodContext) 是否存在相同名称的栏目
boolean | TemplateServiceProvider.existsSimilarName(MethodContext _methodContext) 是否存在相同名称的模板
java.lang.String | ChnlDocServiceProvider.export(MethodContext _methodContext) 导出指定的文档
java.lang.String | WebSiteServiceProvider.export(MethodContext _MethodContext) 导出指定的站点
java.lang.String | ViewDocumentServiceProvider.export(MethodContext _methodContext) 导出指定的文档
java.lang.String | DocumentServiceProvider.export(MethodContext _methodContext) 导出指定的文档
java.lang.String | ChannelServiceProvider.export(MethodContext _MethodContext) 导出指定栏目
java.lang.String | TemplateServiceProvider.export(MethodContext _methodContext) 导出指定的栏目或者站点下的模板
java.lang.String | ProcessService.exportFlows(MethodContext _methodContext)
java.lang.Object | ChannelServiceProvider.filterChannels(MethodContext _context) 通过检索条件查找匹配的栏目 add by liuyou@2008-2-14 下午02:03:43
java.lang.Object | StatusServiceProvider.findById(MethodContext _context)
java.lang.Object | DocumentSynServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | UserServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | ReplaceContentServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | GroupServiceProvider.findById(MethodContext context)
java.lang.Object | RoleServiceProvider.findById(MethodContext context)
java.lang.Object | IndividuationServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | WebSiteServiceProvider.findById(MethodContext _context)
java.lang.Object | TemplateServiceHelperProvider.findById(MethodContext context)
java.lang.Object | ProcessService.findById(MethodContext _methodContext)
java.lang.Object | ExtendFieldServiceProvider.findById(MethodContext _methContext)
java.lang.Object | ViewDocumentServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | InfoviewService.findById(MethodContext context)
java.lang.Object | DocumentServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | DistributeServiceProvider.findById(MethodContext _methContext)
java.lang.Object | ObjectMemberServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | SourceServiceProvider.findById(MethodContext _methContext)
java.lang.Object | PhotoServiceProvider.findById(MethodContext _context)
java.lang.Object | DocumentBakServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | ChannelServiceProvider.findById(MethodContext _context)
java.lang.Object | MessageServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | TemplateServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | InfoViewDocumentServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | ContentLinkServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | WatermarkServiceProvider.findById(MethodContext _context)
java.lang.Object | StatusServiceProvider.findByIds(MethodContext _context)
java.lang.Object | DocumentSynServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | UserServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | ReplaceContentServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | GroupServiceProvider.findByIds(MethodContext context)
java.lang.Object | RoleServiceProvider.findByIds(MethodContext context)
java.lang.Object | IndividuationServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | WebSiteServiceProvider.findByIds(MethodContext _context)
java.lang.Object | TemplateServiceHelperProvider.findByIds(MethodContext context)
java.lang.Object | ProcessService.findByIds(MethodContext _methodContext)
java.lang.Object | ExtendFieldServiceProvider.findByIds(MethodContext _methContext)
java.lang.Object | InfoviewService.findByIds(MethodContext context)
java.lang.Object | DocumentServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | DistributeServiceProvider.findByIds(MethodContext _methContext)
java.lang.Object | ObjectMemberServiceProvider.findByIds(MethodContext _oContext)
java.lang.Object | SourceServiceProvider.findByIds(MethodContext _methContext)
java.lang.Object | PhotoServiceProvider.findByIds(MethodContext _context)
java.lang.Object | DocumentBakServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | ChannelServiceProvider.findByIds(MethodContext _context)
java.lang.Object | MessageServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | TemplateServiceProvider.findByIds(MethodContext _methContext)
java.lang.Object | ContentLinkServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | WatermarkServiceProvider.findByIds(MethodContext _context)
int | ViewDocumentServiceProvider.findChnlDocId(MethodContext _methodContext) 根据docid，channelid获取chnldocid
java.lang.String | SystemServiceProvider.findNodesByPath(MethodContext _methodContext) 根据用户输入的路径获取节点列表，路径以\分隔
java.lang.String | WebSiteServiceProvider.findSiteTypeDesc(MethodContext _MethodContext)
boolean | ProcessService.forceEnd(MethodContext _methodContext) 强制结束
Reports | ProcessService.fromXML(MethodContext _methodContext) 使用XML的方式保存工作流
java.lang.String | InfoviewService.generaterContent(MethodContext _context) _context 中参数 DocumentId InfoViewId/ChannelId TempIVType 缺省为detail Page 缺省为1
java.lang.String | ProcessService.getBranchInfo(MethodContext _methodContext)
Channels | ProcessService.getChannelsUseingFlow(MethodContext _methodContext) 获取使用了指定工作流的栏目列表
IFlowContent[] | ProcessService.getContentsInFlow(MethodContext _methodContext) 获取在指定的工作流中流转的内容列表
IFlowContent[] | ProcessService.getContentsOfUser(MethodContext _MethodContext) 获取需要用户处理的内容
java.lang.Object | PhotoServiceProvider.getDefaultBmpConverType(MethodContext _context)
PageOperators | WebSiteServiceProvider.getDocumentOperators(MethodContext _methContext)
PageOperators | ChannelServiceProvider.getDocumentOperators(MethodContext _methContext) 获取进入当前栏目的文档列表时针对于当前栏目的操作
java.lang.String | ViewDocumentServiceProvider.getDocumentRefrences(MethodContext _methContext)
java.lang.String | ProcessService.getEmploymentInfo(MethodContext _methContext)
java.lang.Object | PhotoServiceProvider.getExtendedProps(MethodContext _context)
FlowNodeFields | ProcessService.getFieldsInfoOfFlowDoc(MethodContext _methodContext) 获取当前轨迹处理中可读和可写的字段列表
FlowDocs | ProcessService.getFlowDocsOfContent(MethodContext _methodContext) 获取指定文档的流转轨迹
java.lang.String | FlowingDocQueryService.getFlowingDocBySNO(MethodContext _context)
java.lang.String | ApplyFormServiceProvider.getFlowingStat(MethodContext _context)
java.lang.String | FlowingDocQueryService.getFlowingStatByChnl(MethodContext _context)
java.lang.String | ProcessService.getFlowOptionAuth(MethodContext _context)
Flow | ProcessService.getFlowUsedByChannel(MethodContext _methodContext) 获取指定栏目正在使用的工作流
Groups | GroupServiceProvider.getGroupsForCurrUser(MethodContext context) 获取当前登录用户可以管理的组织,也就是作为组管理员的组织
Groups | GroupServiceProvider.getGroupsForRole(MethodContext context) 获取指定角色关联的组织
FlowNodes | ProcessService.getNextNodes(MethodContext _methodContext) 获取当前节点下一个节点集合
PageOperators | StatusServiceProvider.getOperators(MethodContext _methContext) 获取针对指定的单个或者多个状态的操作集合
PageOperators | WebSiteServiceProvider.getOperators(MethodContext _methContext)
PageOperators | ExtendFieldServiceProvider.getOperators(MethodContext _methContext) 获取扩展字段的操作
PageOperators | DocumentServiceProvider.getOperators(MethodContext _methContext)
PageOperators | SourceServiceProvider.getOperators(MethodContext _methContext) 获取针对指定的单个或者多个来源的操作集合
PageOperators | ChannelServiceProvider.getOperators(MethodContext _methContext) 获取针对指定的单个或者多个栏目的操作集合
PageOperators | TemplateServiceProvider.getOperators(MethodContext _methContext) 获取针对指定的单个或者多个模板的操作集合
PageOperators | ChannelServiceProvider.getOperatorsInChannel(MethodContext _methContext) 获取进入当前栏目的子栏目列表时针对于当前栏目的操作
PageOperators | WebSiteServiceProvider.getOperatorsInSite(MethodContext _methContext) 获取进入当前站点在进入子栏目列表时候的操作
Templates | TemplateServiceProvider.getOptionalTemplates(MethodContext _MethodContext) 获取指定的对象可选择的模板
java.lang.Object | PhotoServiceProvider.getOriginalUrls(MethodContext _context)
java.lang.String | IndividuationServiceProvider.getPageInfo(MethodContext _methodContext)
java.lang.String | DocumentServiceProvider.getPageInfo(MethodContext _methContext)
ContentProcessInfo | ProcessService.getProcessInfoOfContent(MethodContext _methodContext) 获取指定内容的流转信息（是否已经结束、发起人）
java.lang.Object | PublishServiceProvider.getPublishConfig(MethodContext _methodContext) 获取指定对象的发布信息,传入的参数： ObjectType ObjectId
java.lang.Object | PhotoServiceProvider.getPublishUrls(MethodContext _context) 得到一组图片的不同比例的发布路径
Channels | DocumentServiceProvider.getQuotedChannels(MethodContext _MethodContext) 获取所有引用指定文档的栏目集合
java.lang.Object | PhotoServiceProvider.getQuoteDocs(MethodContext _context)
java.lang.Object | PhotoServiceProvider.getQuoteKinds(MethodContext _context)
Channels | ChannelServiceProvider.getRecycleChannels(MethodContext _methodContext) 获取回收站的栏目列表
WebSites | WebSiteServiceProvider.getRecycleSites(MethodContext _methodContext) 获取回收站中的站点列表
Roles | RoleServiceProvider.getRolesForCurrUser(MethodContext context) 获取当前登录用户可以查看的所有角色信息
java.lang.Object | PhotoServiceProvider.getSacledImages(MethodContext _context)
java.util.Map | RoleServiceProvider.getSiteRoleUsersInfo(MethodContext _context) 获取指定用户的站点角色用户信息，map格式为：
WebSites | WebSiteServiceProvider.getSitesForCurrUser(MethodContext _methodContext) 获取当前登录用户可以操作（默认为设置权限）的站点
Roles | RoleServiceProvider.getSpecialRolesOfUser(MethodContext context) 获取指定用户的特定角色
java.lang.Object | PhotoServiceProvider.getSupportedFormat(MethodContext _context)
java.lang.Object | PhotoServiceProvider.getSysPics(MethodContext _context)
Roles | RoleServiceProvider.getSystemRolesOfUser(MethodContext context) 获取指定用户在指定站点上的系统级角色
java.lang.Object | PublishServiceProvider.getUnpubSchedule(MethodContext context)
Users | UserServiceProvider.getUsersByNames(MethodContext _context)
Users | UserServiceProvider.getUsersOfGroup(MethodContext _context) 获取指定组织下的用户集合,适用于角色的添加用户页面
Users | UserServiceProvider.getUsersOfRole(MethodContext _context) 获取指定角色和站点下的用户集合,兼容系统级角色和非系统级角色
Users | UserServiceProvider.getUsersOfSpecialRole(MethodContext _context) 获取指定特定角色下的用户集合
Users | UserServiceProvider.getUsersOfSystemRoleOnSite(MethodContext _context) 获取指定系统级角色和站点下的用户集合
boolean | MessageServiceProvider.hasUnreadMessage(MethodContext _methodContext) 获取当前用户没有阅读的消息
void | ExtendFieldServiceProvider.impartExtendFields(MethodContext _methodContext) 将扩展字段同步到指定对象的所有子对象上
void | TemplateServiceProvider.impartTemplateConfig(MethodContext _methodContext) 传递当前对象(站点/栏目)的模板配置到子对象上
java.lang.String | ChannelServiceProvider.importChannels(MethodContext _MethodContext) 导入栏目
java.lang.String | DocumentServiceProvider.importDocuments(MethodContext _methodContext) 导入文档
Reports | ProcessService.importFlows(MethodContext _methodContext)
java.lang.String | InfoviewService.importInfoViewData(MethodContext _context)
java.lang.String | InfoviewService.importInfoViewDataForCustom(MethodContext _context)
java.lang.String | WebSiteServiceProvider.importSites(MethodContext _MethodContext) 导入栏目
void | ContentLinkServiceProvider.importSysLinks(MethodContext _context)
java.lang.Object | PhotoServiceProvider.importSysPics(MethodContext _context)
java.lang.String | TemplateServiceProvider.importTemplates(MethodContext _methodContext) 导入文档
void | ExtendFieldServiceProvider.inheritExtendFields(MethodContext _methodContext) 将当前传入的对象，继承父对象的扩展字段信息
void | ExtendFieldServiceProvider.inhertSpecificFromParent(MethodContext _methodContext) 继承父对象指定ID的扩展字段信息
boolean | SystemServiceProvider.isValidChannelId(MethodContext _oMethodContext) 判断指定的栏目Id是否有效
java.lang.String | DocumentSynServiceProvider.isValidDocumentCollection(MethodContext _methodContext)
java.lang.String | DocumentSynServiceProvider.isValidDocumentSyn(MethodContext _methodContext) 校验同步创建是否有效，如果有效返回长度为0的字符串，如果无效返回以逗号分隔的Ids
boolean | SystemServiceProvider.isValidSiteId(MethodContext _oMethodContext) 判断指定的站点Id是否有效
int | NewChannelServiceProvider.list(MethodContext _sContext)
java.lang.Object | PhotoServiceProvider.loadLibConf(MethodContext _context)
java.lang.Object | PhotoServiceProvider.loadOriginImg(MethodContext _context) 获取原始图片的信息.
java.lang.Object | PhotoServiceProvider.loadSysPicProps(MethodContext _context)
static RightValue | TemplateAuthHelper.makeHostRightValue(MethodContext _context, User _loginUser, IPublishFolder _host)
static java.lang.String | WCMDocumentHelper.makeRightValue(MethodContext _methodContext, User _loginUser, Channel _currChannel, Document _document) 构造指定文档在指定栏目中的权限
static RightValue | TemplateAuthHelper.makeTemplateRightValue(MethodContext _context, User _loginUser, Template _template, IPublishFolder _host)
java.io.File | InfoviewService.makeTemplatesToZip(MethodContext _context)
Reports | ChnlDocServiceProvider.mirror(MethodContext _methodContext) 镜像文档
Reports | ViewDocumentServiceProvider.mirror(MethodContext _methodContext) 镜像文档
Reports | ChnlDocServiceProvider.move(MethodContext _methodContext) 移动文档
Reports | ViewDocumentServiceProvider.move(MethodContext _methodContext) 移动文档
Reports | DocumentServiceProvider.move(MethodContext _methodContext) 移动文档
Reports | ViewDocumentServiceProvider.moveAll(MethodContext _methodContext) 移动全部文档
void | ChannelServiceProvider.moveAsChild(MethodContext _methodContext) 移动栏目
java.lang.String | ViewDocumentServiceProvider.preview(MethodContext _methodContext)
java.lang.String | DocumentServiceProvider.preview(MethodContext _methodContext) 文档编辑时的预览
java.lang.String | PublishServiceProvider.preview(MethodContext _methodContext)
void | PreviewChannelServiceProvider.previewChild(MethodContext _methodContext)
void | ChnlDocServiceProvider.publish(MethodContext _methodContext)
Reports | ViewDocumentServiceProvider.publish(MethodContext _methodContext)
void | PublishServiceProvider.publish(MethodContext _methodContext) 发布指定的对象
void | PublishServiceProvider.publishContents(MethodContext _methodContext) 在指定的栏目中发布指定的文档
java.lang.Object | StatusServiceProvider.query(MethodContext _methContext)
java.lang.Object | DocumentSynServiceProvider.query(MethodContext _methodContext)
java.lang.Object | UserServiceProvider.query(MethodContext _methodContext)
java.lang.Object | ReplaceContentServiceProvider.query(MethodContext _methodContext)
java.lang.Object | GroupServiceProvider.query(MethodContext context)
java.lang.Object | RoleServiceProvider.query(MethodContext context)
java.lang.Object | IndividuationServiceProvider.query(MethodContext _methContext)
java.lang.Object | WebSiteServiceProvider.query(MethodContext _methContext)
java.lang.Object | TemplateServiceHelperProvider.query(MethodContext context)
java.lang.Object | ProcessService.query(MethodContext _methodContext)
java.lang.Object | ExtendFieldServiceProvider.query(MethodContext _methContext)
java.lang.Object | ViewDocumentServiceProvider.query(MethodContext _methContext) 获取指定站点或者指定频道下的文档
java.lang.Object | InfoviewService.query(MethodContext context)
java.lang.Object | DocumentServiceProvider.query(MethodContext _methContext)
java.lang.Object | DistributeServiceProvider.query(MethodContext _methContext)
java.lang.Object | ObjectMemberServiceProvider.query(MethodContext _oContext)
java.lang.Object | SourceServiceProvider.query(MethodContext _methContext)
java.lang.Object | PhotoServiceProvider.query(MethodContext _context)
java.lang.Object | DocumentBakServiceProvider.query(MethodContext _methodContext)
java.lang.Object | ChannelServiceProvider.query(MethodContext _methContext)
java.lang.Object | MessageServiceProvider.query(MethodContext _methodContext)
java.lang.Object | TemplateServiceProvider.query(MethodContext _methContext)
java.lang.Object | InfoViewDocumentServiceProvider.query(MethodContext _methContext)
java.lang.Object | ContentLinkServiceProvider.query(MethodContext _methodContext)
java.lang.Object | WatermarkServiceProvider.query(MethodContext _context)
Appendixes | ViewDocumentServiceProvider.queryAppendixes(MethodContext _methodContext) 获取指定文档指定类型的附件
Appendixes | DocumentServiceProvider.queryAppendixes(MethodContext _methodContext) 获取指定文档指定类型的附件
Appendixes | DocumentBakServiceProvider.queryAppendixes(MethodContext _methodContext) 获取指定文档版本指定类型的附件
java.lang.String | TemplateServiceProvider.queryArgs(MethodContext _methodContext) queryArgs
java.lang.String | InfoviewService.queryChannelUsableInfoviews(MethodContext _context)
java.lang.Object | IndividuationServiceProvider.queryCustomSite(MethodContext _methContext)
java.lang.String | InfoviewService.queryData(MethodContext _context)
java.lang.String | InfoviewService.queryData2(MethodContext _context)
java.lang.String | InfoviewService.queryData3(MethodContext _context)
Statuses | StatusServiceProvider.queryDocumentStatuses(MethodContext _methContext) 获取当前用户在指定频道下可以改变状态
TemplateEmploys | TemplateServiceProvider.queryEmployers(MethodContext _methodContext) 获取使用指定模板的对象
ExtendedFields | ExtendFieldServiceProvider.queryExtendFields(MethodContext _methodContext) 获取系统配置的物理字段
ContentExtendValues | ViewDocumentServiceProvider.queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息
ContentExtendValues | DocumentServiceProvider.queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息
ContentExtendValues | DocumentBakServiceProvider.queryExtendFields(MethodContext _methodContext) 获取文档的扩展字段信息
InfoViews | InfoviewService.queryFlowInfoviews(MethodContext _context)
java.lang.Object | ViewDocumentServiceProvider.queryForGroup(MethodContext _methContext)
java.lang.Object | ContentLinkServiceProvider.queryLinkType(MethodContext _context)
ObjectMembers | ObjectMemberServiceProvider.queryMembersOfObject(MethodContext _methodContext) 返回对指定对象可见可操作的所有成员
Templates | TemplateServiceProvider.queryNestedTemplates(MethodContext _methodContext) 获取使用指定模板使用了那些嵌套模板
ObjectMembers | ObjectMemberServiceProvider.queryObjectsOfMember(MethodContext _methodContext) 返回指定成员的所有可见可操作的对象
java.lang.Object | ProcessService.queryOptionalFlows(MethodContext _methodContext)
ViewDocuments | ViewDocumentServiceProvider.queryRecycle(MethodContext _methContext) 获取指定站点或者指定频道回收站下的文档
Documents | DocumentServiceProvider.queryRecycle(MethodContext _methContext) 获取回收站文档
ViewDocuments | PhotoServiceProvider.queryRecycle(MethodContext _context)
InfoViewDocuments | InfoViewDocumentServiceProvider.queryRecycle(MethodContext _methContext) 获取指定站点或者指定频道回收站下的文档
Relations | ViewDocumentServiceProvider.queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档
Relations | DocumentServiceProvider.queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档
Relations | DocumentBakServiceProvider.queryRelations(MethodContext _methodContext) 获取指定文档手工设定的相关文档
java.lang.String | InfoviewService.querySearchFields(MethodContext _context)
java.lang.Object | ContentLinkServiceProvider.querySysLinks(MethodContext _methodContext)
Templates | TemplateServiceProvider.queryTemplatesNested(MethodContext _methodContext) 获取使用指定嵌套模板的模板
java.lang.Object | ContentLinkServiceProvider.queryTypes(MethodContext _context)
Reports | ChnlDocServiceProvider.quote(MethodContext _methodContext) 引用文档
Reports | ViewDocumentServiceProvider.quote(MethodContext _methodContext) 引用文档
Reports | DocumentServiceProvider.quote(MethodContext _methodContext) 引用文档到...
java.lang.Object | PhotoServiceProvider.raiseImage(MethodContext _context)
void | InfoviewDataToolService.rebuildAllInfoViews(MethodContext _context) 为系统所有视图创建表结构
void | DocumentBakServiceProvider.recover(MethodContext _methodContext) 恢复文档的版本
java.lang.String | TemplateServiceProvider.redistributeAppendixes(MethodContext _methodContext) 重新分发模板的附件
boolean | ProcessService.refuse(MethodContext _methodContext) 拒绝请求
void | ProcessService.removeChannelEmployersOfFlow(MethodContext _methodContext) 批量取消工作流的配置情况
void | RoleServiceProvider.removeUsersFromCurrRole(MethodContext context) 在指定角色中删除指定用户，兼容系统级和特定角色
void | InfoviewDataToolService.renderAllChannelOutlineFields(MethodContext _context) 替换栏目的检索字段，自动生成相应的DB字段
void | InfoviewDataToolService.renderAllInfoViewSearchOutlineFields(MethodContext _context) 替换视图的检索字段，概览字段，自动生成相应的DB字段
Reports | ViewDocumentServiceProvider.replaceContentLink(MethodContext _methContext)
void | ViewDocumentServiceProvider.restore(MethodContext _methodContext) 恢复回收站中的文档
void | DocumentServiceProvider.restore(MethodContext _methodContext) 恢复回收站中的文档
void | ChannelServiceProvider.restoreChannels(MethodContext _methodContext) 恢复回收站中的栏目
void | WebSiteServiceProvider.restoreSites(MethodContext _methodContext) 恢复回收站中的站点
void | ProcessService.reSubmitTo(MethodContext _methodContext) 重新处理
java.lang.String | InfoviewService.retriveChannelInfo(MethodContext _context)
java.lang.Object | PhotoServiceProvider.rotateImage(MethodContext _context)
int | StatusServiceProvider.save(MethodContext _context)
int | DocumentSynServiceProvider.save(MethodContext _methodContext)
int | UserServiceProvider.save(MethodContext _methodContext)
int | ReplaceContentServiceProvider.save(MethodContext _methodContext)
int | GroupServiceProvider.save(MethodContext context)
int | RoleServiceProvider.save(MethodContext context)
int | IndividuationServiceProvider.save(MethodContext _methodContext)
int | WebSiteServiceProvider.save(MethodContext _methodContext)
int | TemplateServiceHelperProvider.save(MethodContext context)
int | ProcessService.save(MethodContext _methodContext)
int | ExtendFieldServiceProvider.save(MethodContext _methContext)
int | InfoviewService.save(MethodContext context)
int | DocumentServiceProvider.save(MethodContext _methodContext)
int | DistributeServiceProvider.save(MethodContext _methodContext)
int | ObjectMemberServiceProvider.save(MethodContext _methodContext)
int | NewChannelServiceProvider.save(MethodContext _sContext)
int | SourceServiceProvider.save(MethodContext _methodContext)
int | PhotoServiceProvider.save(MethodContext _context)
int | DocumentBakServiceProvider.save(MethodContext _methodContext)
int | ChannelServiceProvider.save(MethodContext _methodContext)
int | MessageServiceProvider.save(MethodContext _methodContext)
int | TemplateServiceProvider.save(MethodContext _methodContext)
int | ContentLinkServiceProvider.save(MethodContext _methodContext)
int | WatermarkServiceProvider.save(MethodContext _context)
void | DocumentServiceProvider.saveAppendixes(MethodContext _methodContext) 保存指定文档的相关文档
void | ApplyFormServiceProvider.saveAppendixes(MethodContext _methodContext)
int | TemplateServiceProvider.saveArgument(MethodContext _methodContext) 保存用户在当前站点或者栏目设置的变量
void | PhotoServiceProvider.saveExtif(MethodContext _context) 用于抽取图片Exit信息
int | ChannelServiceProvider.saveForSpecial(MethodContext _methContext)
void | GroupServiceProvider.saveGroups(MethodContext _methodContext) 保存用户新建和修改用户后的用户所属组织信息
java.lang.String | PhotoServiceProvider.saveImageInfo(MethodContext _context)
void | PhotoServiceProvider.saveLibConf(MethodContext _context)
void | ObjectMemberServiceProvider.saveMembersOfObject(MethodContext _methodContext) 保存指定对象对其可见、可操作的成员
void | ObjectMemberServiceProvider.saveObjectsOfMember(MethodContext _methodContext) 保存指定成员所拥有的可见、可操作对象
java.lang.String | AuthServiceProvider.saveOperatorRights(MethodContext _methodContext)
java.lang.Object | PhotoServiceProvider.saveOriginImg(MethodContext _context)
int | NewChannelServiceProvider.savepic(MethodContext _sContext)
int | NewChannelServiceProvider.savePro(MethodContext _sContext)
boolean | PublishServiceProvider.savePublishConfig(MethodContext _methodContext)
void | DocumentServiceProvider.saveRelation(MethodContext _methodContext) 保存指定文档的相关文档
void | RoleServiceProvider.saveRoles(MethodContext _methodContext) 已过时。
void | RoleServiceProvider.saveRoleUsers(MethodContext context) 绑定角色,站点和用户的关联，同时将清除原来的关联,兼容系统级和非系统级
void | RoleServiceProvider.saveSpecialRolesOfUser(MethodContext context) 保存指定用户的特定角色
void | RoleServiceProvider.saveSystemRolesOfUser(MethodContext context) 保存指定用户在指定站点上的系统级角色
void | ViewDocumentServiceProvider.saveTRSConfig(MethodContext _methContext)
void | RoleServiceProvider.saveUsersOfSpecialRole(MethodContext context) 将用户添加到特定的角色上，同时将清除原来的关联
void | RoleServiceProvider.saveUsersOfSystemRoleOnSite(MethodContext context) 将用户添加到指定站点的系统级角色上，同时将清除原来的关联
java.lang.Object | PhotoServiceProvider.scaleImage(MethodContext _context)
ChnlDocs | ChnlDocServiceProvider.search(MethodContext _methContext) 查询指定站点或者指定频道下的文档
int | MessageServiceProvider.sendMessage(MethodContext _methodContext) 发送消息
void | ProcessService.setChannelEmployersOfFlow(MethodContext _methodContext) 批量维护工作流的配置情况
void | TemplateServiceHelperProvider.setChannelEmployersOfTemplate(MethodContext _context)
void | TemplateServiceProvider.setDefaultTemplate(MethodContext _methodContext)
void | InfoviewService.setEmployedInfoView(MethodContext _context)
boolean | IndividuationServiceProvider.setIsChecked(MethodContext _methodContext)
void | ContentLinkServiceProvider.setLinkType(MethodContext _context)
static void | TemplateEmployMgrHelper.setOtherOutlinesOfChannels(MethodContext _context, Template _template)
void | TemplateServiceProvider.setOtherOutlineTemplates(MethodContext _methodContext)
Reports | DocumentServiceProvider.setQuote(MethodContext _methodContext) 为文档指定引用,用于编辑器中维护文档的所有引用关系
void | MessageServiceProvider.setReadFlag(MethodContext _methodContext) 将消息设置为已读
void | DocumentServiceProvider.setTopDocument(MethodContext _methodContext) 将文档置顶
void | PublishServiceProvider.setUnpubSchedule(MethodContext context)
static CMSObj | WCMAJAXServiceHelper.setWCMObjectProperties(User _loginUser, MethodContext _methodContext, CMSObj _oCMSObj, java.lang.String[] _pLogicFields) 更新指定的对象
static void | WCMApplyFormProcessServiceHelper.startApplyFormInFlow(User _postUser, ApplyForm _applyForm, MethodContext _oMethodContext)
void | ProcessService.startDocumentInFlow(MethodContext _methodContext) 让文档开始流转
void | DocumentServiceProvider.startDocumentInFlow(MethodContext _methodContext) 让文档开始流转
void | ApplyFormServiceProvider.startDocumentInFlow(MethodContext _methodContext) 让文档开始流转
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, Flow _oFlow, MethodContext _oMethodContext)
static void | WCMProcessServiceHelper.startDocumentInFlow(User _postUser, Document _document, MethodContext _oMethodContext)
void | ProcessService.submitTo(MethodContext _methodContext) 将需要处理的内容交给下一个环节处理
void | InfoviewDataToolService.syncChnlDocFlag(MethodContext _context) 同步文档的DocFlag到ChnlDoc表中
void | TemplateServiceProvider.synTemplates(MethodContext _methodContext) 传递当前对象(站点/栏目)的模板配置到子对象上
java.lang.String | ProcessService.toXML(MethodContext _methodContext) 将指定的工作流导出成XML
Reports | DocumentServiceProvider.transmit(MethodContext _methodContext) 转发文档
java.lang.Object | ViewDocumentServiceProvider.trsQuery(MethodContext _methContext)
void | DocumentServiceProvider.trsSaveToWCM(MethodContext _methodContext)
void | DistributeServiceProvider.updateStatus(MethodContext _methodContext) 启用/关闭 分发服务
void | DistributeServiceProvider.updateStatusAll(MethodContext _methodContext) 启用/关闭 所有分发服务
java.lang.String | ViewDocumentServiceProvider.uploadImg(MethodContext _methodContext)

com.trs.ajaxservice.listener 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.ajaxservice.listener 中的方法
void | SaveMembersListenerForObjectMember.afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
void | MoveChannelListenerForChannel.afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)

com.trs.ajaxservice.logger 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.ajaxservice.logger 中的方法
int | WebSiteRestoreLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | TemplateSyncLogger.startLog(MethodConfig conf, MethodContext context)
int | TemplateImportLogger.startLog(MethodConfig conf, MethodContext context)
int | SiteRecycleClearLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | SiteImportLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | SiteCreateFromLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | SetEmployersOfTemplateLogger.startLog(MethodConfig _oConf, MethodContext _oContext)
int | ResyncTemplateApdLogger.startLog(MethodConfig conf, MethodContext context)
int | RestoreObjLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | RecycleClearLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | PublishTaskLogger.startLog(MethodConfig conf, MethodContext context)
int | PublishConfigSaveLogger.startLog(MethodConfig conf, MethodContext context)
int | ImpartTemplateLogger.startLog(MethodConfig _oConf, MethodContext _oContext)
int | FlowSetLogger.startLog(MethodConfig conf, MethodContext context)
int | FlowSaveLogger.startLog(MethodConfig conf, MethodContext context)
int | DocStatusChangeLogger.startLog(MethodConfig conf, MethodContext context)
int | DocSaveLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | DocPublishTaskLogger.startLog(MethodConfig conf, MethodContext context)
int | DocMoveLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | DocImportLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | DocCopyLogger.startLog(MethodConfig _oConf, MethodContext _oContext)
int | ChannelMoveLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | ChannelImportLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | ChannelCreateFromLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | BatchChannelCreateFromFileLogger.startLog(MethodConfig conf, MethodContext context)

com.trs.ajaxservice.xmlconvertors 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.ajaxservice.xmlconvertors 中的方法
java.lang.String | WCMFolderPublishConfigToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | WCMContentPublishConfigToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | ReportsToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | FlowContentsToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | DistributionTargetTypeToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | DataTypeToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | ContentProcessInfoToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | BaseWCMObjectToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)

com.trs.components.common.publish.widget 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.common.publish.widget 中的方法
void | IWidgetParameterServiceProvider.changeOrder(MethodContext context) 改变资源变量的顺序
void | WidgetParameterServiceProvider.changeOrder(MethodContext context)
boolean | ContentStyleServiceProvider.checkCssFlag(MethodContext _context) 在指定的系统风格下校验CssFlag是否唯一
boolean | ResourceStyleServiceProvider.checkCssFlag(MethodContext _context) 在指定的页面风格下校验CssFlag是否唯一
boolean | ContentStyleServiceProvider.checkCssFlagOrNameCanUse(MethodContext _context) 判断指定的风格标识和风格名称是否在指定的页面风格下存在
boolean | ResourceStyleServiceProvider.checkCssFlagOrNameCanUse(MethodContext _context) 判断指定的风格标识和风格名称是否在指定的页面风格下存在
java.lang.String | PageStyleServiceProvider.checkExistPageStyle(MethodContext context) 检查当前上传的zip文件中的PageStyle对象名称是否已经存在！
boolean | PageStyleServiceProvider.checkStyleDesc(MethodContext context) 检查风格中文（显示）名称是否唯一
boolean | PageStyleServiceProvider.checkStyleName(MethodContext context) 检查风格英文名称是否唯一
java.lang.String | ContentStyleServiceProvider.copy(MethodContext context) 复制内容可用风格到页面页面风格或者系统内容风格下
java.lang.Object | IResourceStyleServiceProvider.copy(MethodContext context) 复制资源可用风格
java.lang.String | ResourceStyleServiceProvider.copy(MethodContext context) 复制资源可用风格到页面风格或者系统资源风格下
int | PageStyleServiceProvider.copy(MethodContext context) 类似创建风格,创建风格以及风格中的资源可用风格，内容可用风格等
java.lang.String | IContentStyleServiceProvider.copy(MethodContext context) 复制内容可用风格
int | IPageStyleServiceProvider.copy(MethodContext context) 类似创建风格,创建风格以及风格中的资源可用风格，内容可用风格等
Reports | VisualTemplateServiceProvider.copyVisualTemplate(MethodContext _context) 类似创建功能，在指定栏目下创建新的可视化模板
java.lang.String | IVisualTemplateServiceProvider.copyWidgetInstance(MethodContext _methodContext) 类似创建相同的资源实例，创建后的资源实例与原来的实例拥有相同的资源变量和值 返回创建后的资源实例的可视化编辑模板形式
java.lang.String | VisualTemplateServiceProvider.copyWidgetInstance(MethodContext context) 类似创建功能，创建的新的资源实例
void | ContentStyleServiceProvider.delete(MethodContext context) 删除指定的风格
void | IWidgetParameterServiceProvider.delete(MethodContext _context) 删除资源变量
void | ResourceStyleServiceProvider.delete(MethodContext context) 删除指定的风格
void | PageStyleServiceProvider.delete(MethodContext context) 删除指定的风格 context中需要传递参数ObjectIds，来指定待删除的风格id序列，多个id之间用逗号分隔
void | IWidgetServiceProvider.delete(MethodContext _context) 删除资源片段
void | WidgetServiceProvider.delete(MethodContext _context)
void | WidgetParameterServiceProvider.delete(MethodContext _context)
void | VisualTemplateServiceProvider.delete(MethodContext context)
void | ILayoutServiceProvider.delete(MethodContext context)
void | MasterServiceProvider.delete(MethodContext _oContext) 删除指定Id的母板
void | LayoutServiceProvider.delete(MethodContext context) 删除布局
void | PageStyleServiceProvider.deleteUploadImages(MethodContext _context) 删除页面风格下指定名称的上传图片
void | IVisualTemplateServiceProvider.deleteWidgetInstance(MethodContext _methodContext) 删除指定的资源块实例对象
void | VisualTemplateServiceProvider.deleteWidgetInstance(MethodContext context)
boolean | IMasterServiceProvider.existsMName(MethodContext _context) 检查母板名称是否已存在
boolean | MasterServiceProvider.existsMName(MethodContext _oContext) 校验母板名称是否已存在
boolean | IWidgetParameterServiceProvider.existsSimilarName(MethodContext context) 判断是否存在相同名称的资源变量
boolean | IWidgetServiceProvider.existsSimilarName(MethodContext _context) 检查是否有同名模板
boolean | WidgetServiceProvider.existsSimilarName(MethodContext _context)
boolean | WidgetParameterServiceProvider.existsSimilarName(MethodContext context)
java.lang.String | IWidgetServiceProvider.export(MethodContext _context) 导入资源
java.lang.String | WidgetServiceProvider.export(MethodContext _context)
java.lang.String | IMasterServiceProvider.export(MethodContext _context) 导出指定ID的母版
java.lang.String | MasterServiceProvider.export(MethodContext _oContext) 导出指定Id的母板
java.lang.String | ContentStyleServiceProvider.exportContentStyleZip(MethodContext context) 导出一个内容风格对象到zip文件中，zip文件中包含这个内容风格的所有相关文件
java.lang.String | PageStyleServiceProvider.exportCssFile(MethodContext context) 导出Css文件
java.lang.String | IPageStyleServiceProvider.exportCssFile(MethodContext context) 导出Css文件
java.lang.String | PageStyleServiceProvider.exportPageStyleZip(MethodContext context) 导出一个页面风格对象到zip文件中，zip文件中包含这个页面风格的所有相关文件 组织好的待导出的文件是存放在系统临时目录下
java.lang.String | ResourceStyleServiceProvider.exportResourceStyleZip(MethodContext context) 导出一个资源风格对象到zip文件中，zip文件中包含这个资源风格的所有相关文件
java.lang.Object | ContentStyleServiceProvider.findById(MethodContext context)
java.lang.Object | ResourceStyleServiceProvider.findById(MethodContext context)
java.lang.Object | PageStyleServiceProvider.findById(MethodContext context)
java.lang.Object | WidgetServiceProvider.findById(MethodContext context) 暂时没有用到，没有实现
java.lang.Object | WidgetParameterServiceProvider.findById(MethodContext context) 暂时没有用到，没有实现
java.lang.Object | VisualTemplateServiceProvider.findById(MethodContext context)
java.lang.Object | ILayoutServiceProvider.findById(MethodContext context)
java.lang.Object | MasterServiceProvider.findById(MethodContext _oContext) 获取指定Id的母板
java.lang.Object | LayoutServiceProvider.findById(MethodContext context) 获取某个布局
java.lang.Object | ContentStyleServiceProvider.findByIds(MethodContext context)
java.lang.Object | ResourceStyleServiceProvider.findByIds(MethodContext context)
java.lang.Object | PageStyleServiceProvider.findByIds(MethodContext context)
java.lang.Object | WidgetServiceProvider.findByIds(MethodContext context) 暂时没有用到，没有实现
java.lang.Object | WidgetParameterServiceProvider.findByIds(MethodContext context) 暂时没有用到，没有实现
java.lang.Object | VisualTemplateServiceProvider.findByIds(MethodContext context)
java.lang.Object | ILayoutServiceProvider.findByIds(MethodContext context)
java.lang.Object | MasterServiceProvider.findByIds(MethodContext _oContext) 获取指定的Id序列的母板集合
java.lang.Object | LayoutServiceProvider.findByIds(MethodContext context) 获取布局集合
java.util.HashMap | ContentStyleServiceProvider.findCssFlagUsedInfo(MethodContext _context) 校验CssFlag是否可用。
java.util.HashMap | ResourceStyleServiceProvider.findCssFlagUsedInfo(MethodContext _context) 校验CssFlag已经被使用的信息
java.lang.String | PageStyleServiceProvider.findStyleImageDir(MethodContext context) 获取风格中上传的图片路径(服务器端的物理地址)
java.util.HashMap | ContentStyleServiceProvider.findStyleNameUsedInfo(MethodContext _context) 校验StyleName已经被使用的信息
java.util.HashMap | ResourceStyleServiceProvider.findStyleNameUsedInfo(MethodContext _context) 校验StyleName已经被使用的信息
java.lang.String | ILayoutServiceProvider.getLayoutHtml(MethodContext context) 通过获取比例类型和比例值来直接返回相应的HTML内容
java.lang.String | LayoutServiceProvider.getLayoutHtml(MethodContext context) 通过web页面发送布局比例类型和布局比例信息来获取到相应的HTML代码,该服务需要将布局的样式信息写到HTML代码中
java.lang.String | ContentStyleServiceProvider.importContentStyleZip(MethodContext context) 从一个zip文件中导入内容风格的相关内容，包括该内容风格的所有相关内容 ContentStyleZipFile支持一个全路径
void | PageStyleServiceProvider.importCssFile(MethodContext context) 导入风格文件
java.lang.String | IMasterServiceProvider.importMasters(MethodContext _context) 导入母版
java.lang.String | MasterServiceProvider.importMasters(MethodContext _oContext) 导入母板
java.lang.String | PageStyleServiceProvider.importPageStyleZip(MethodContext context) 从一个zip文件中导入页面风格的相关内容，包括该页面风格的所有相关内容 其中参数PageStyleZipFile支持全路径
java.lang.String | ResourceStyleServiceProvider.importResourceStyleZip(MethodContext context) 从一个zip文件中导入资源风格的相关内容，包括该资源风格的所有相关内容 ResourceStyleZipFile支持一个全路径
java.lang.String | IWidgetServiceProvider.importWidgets(MethodContext _context) 导出资源
java.lang.String | WidgetServiceProvider.importWidgets(MethodContext _context)
java.lang.String | PageStyleServiceProvider.makeCssFile(MethodContext context) 生成Css文件,返回文件名称，生成一个风格英文名称+.css的文件到wcmdata下的template/style/style_css
java.lang.String | IPageStyleServiceProvider.makeCssFile(MethodContext context) 生成Css文件,返回文件名称
java.lang.String | ContentStyleServiceProvider.makePreviewCssContent(MethodContext _context) 获取预览时需要的样式内容 在列表中预览时调用的方法，返回当前内容风格的css样式代码
java.lang.String | ResourceStyleServiceProvider.makePreviewCssContent(MethodContext _context) 获取预览时需要的样式内容 在列表中预览时调用的方法，返回当前资源风格的css样式代码
java.lang.String | PageStyleServiceProvider.makePreviewCssContent(MethodContext _context) 获取预览时需要的样式内容
java.lang.String | IVisualTemplateServiceProvider.parseTemplate(MethodContext _methodContext) 将专题对应栏目的模板内容解析成可视化编辑模板形式的字符串
java.lang.String | VisualTemplateServiceProvider.parseTemplate(MethodContext context)
java.lang.String | IVisualTemplateServiceProvider.parseWidgetInstance(MethodContext _methodContext) 将某一个资源块实例解析成可视化编辑模板形式的字符串
java.lang.String | VisualTemplateServiceProvider.parseWidgetInstance(MethodContext context)
java.lang.String | IVisualTemplateServiceProvider.preview(MethodContext _methodContext) 获取指定栏目或文档对象在指定模板内容下的预览内容
java.lang.String | VisualTemplateServiceProvider.preview(MethodContext context)
java.lang.String | ContentStyleServiceProvider.previewStyle(MethodContext _context) 预览风格根据当前填写的风格设置项 其中参数StyleItemXML的格式为一段xml，格式类似于
java.lang.String | ResourceStyleServiceProvider.previewStyle(MethodContext _context) 预览风格根据当前填写的风格设置项 其中参数StyleItemXML的格式为一段xml，格式类似于
java.lang.String | PageStyleServiceProvider.previewStyle(MethodContext _context) 获取预览页面基本特性时需要的样式内容 参数为ObjectId和StyleItemXML(一个xml串) StyleItemXML格式类似于
java.lang.Object | ContentStyleServiceProvider.query(MethodContext context) 获取内容风格集合
java.lang.Object | IWidgetParameterServiceProvider.query(MethodContext _context) 获取资源变量对象集
java.lang.Object | ResourceStyleServiceProvider.query(MethodContext context) 获取资源风格集合
java.lang.Object | PageStyleServiceProvider.query(MethodContext context) 根据指定的条件获取页面风格集合
java.lang.Object | IWidgetServiceProvider.query(MethodContext _context) 获取资源片段集
java.lang.Object | WidgetServiceProvider.query(MethodContext _context)
java.lang.Object | WidgetParameterServiceProvider.query(MethodContext _context)
java.lang.Object | VisualTemplateServiceProvider.query(MethodContext context)
java.lang.Object | ILayoutServiceProvider.query(MethodContext context)
java.lang.Object | MasterServiceProvider.query(MethodContext _oContext) 查询母板
java.lang.Object | LayoutServiceProvider.query(MethodContext context) 查询布局
ContentStyles | ContentStyleServiceProvider.queryContentStyles(MethodContext context) 获取指定系统风格下的内容可用风格集合
java.lang.Object | MasterServiceProvider.queryMasterByContentType(MethodContext _oContext) 获取指定类型文件不为空的母版集合
PageStyles | PageStyleServiceProvider.queryPageStyles(MethodContext _context) 获取系统所有可供选择的系统风格
ResourceStyles | ResourceStyleServiceProvider.queryResourceStyles(MethodContext context) 获取指定页面风格下的资源可用风格集合
java.util.HashMap | StyleItemServiceProvider.queryStyleItemMap(MethodContext context) 获取指定风格对应的风格项集合
java.lang.Object | StyleItemServiceProvider.queryStyleItems(MethodContext context) 获取指定风格对应的风格项集合
java.util.ArrayList | PageStyleServiceProvider.queryUploadImageFileList(MethodContext _context) 获取指定页面风格下的所有上传的图片名称，图片名称放到一个ArrayList中
void | ContentStyleServiceProvider.resetContentStyle(MethodContext _oContext) 将当前 内容风格的设置 重置为 对应的系统级别的 内容风格的设置
void | ResourceStyleServiceProvider.resetResourceStyle(MethodContext _oContext) 将当前 资源风格的设置 重置为 对应的系统级别的 资源风格的设置
int | ContentStyleServiceProvider.save(MethodContext context) 保存当前风格
int | IWidgetParameterServiceProvider.save(MethodContext _context) 保存当前资源变量
int | ResourceStyleServiceProvider.save(MethodContext context) 保存当前风格
int | PageStyleServiceProvider.save(MethodContext context) 保存当前风格
int | IWidgetServiceProvider.save(MethodContext _context) 保存当前资源片段
int | WidgetServiceProvider.save(MethodContext _context)
int | WidgetParameterServiceProvider.save(MethodContext _context)
int | VisualTemplateServiceProvider.save(MethodContext context)
int | ILayoutServiceProvider.save(MethodContext _context)
int | MasterServiceProvider.save(MethodContext _oContext) 保存母板
int | LayoutServiceProvider.save(MethodContext context) 保存布局
int | PageStyleServiceProvider.saveBaseStyle(MethodContext context) 保存风格的页面特性 需要传递参数ObjectId和StyleItemXML是一个xml串， 格式类似于
int | PageStyleServiceProvider.saveCustomStyle(MethodContext context) 保存风格的自定义风格 服务中需要传递参数ObjectId和CustomStyle，CustomStyle是自定义的样式
int | PageStyleServiceProvider.savePageOtherStyle(MethodContext context) 保存风格的其他风格属性
int | ContentStyleServiceProvider.saveStyleThumb(MethodContext context) 保存上传的风格示意图，该缩略图必须已经上传到webpic下
int | ResourceStyleServiceProvider.saveStyleThumb(MethodContext context) 保存上传的风格示意图，该缩略图必须已经上传到webpic下
int | PageStyleServiceProvider.saveStyleThumb(MethodContext context) 保存上传的风格示意图，该缩略图必须已经上传到webpic下
int | IVisualTemplateServiceProvider.saveToTemplate(MethodContext _methodContext) 将传入的字符串文本，解析成模板，传入的文本为可视化设计的模板内容，解析之后将建立 资源块实例，资源块实例变量的关系
int | VisualTemplateServiceProvider.saveToTemplate(MethodContext context)
int | VisualTemplateServiceProvider.saveWidgetInstance(MethodContext context)
int | VisualTemplateServiceProvider.saveWidgetInstParameters(MethodContext context)
void | IVisualTemplateServiceProvider.synchronizeWidgetInstances(MethodContext _methodContext) 将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。
void | VisualTemplateServiceProvider.synchronizeWidgetInstances(MethodContext methodContext)
java.lang.String | IMasterServiceProvider.validateMasterFile(MethodContext _context) 校验母版文件的合法性
java.lang.String | MasterServiceProvider.validateMasterFile(MethodContext _oContext) 校验母板文件的合法性

com.trs.components.filter 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.filter 中的方法
 WCMFilter IQueryFilter.getFilter(MethodContext _mc)

com.trs.components.infoview.helper 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.infoview.helper 中的方法
static java.lang.String | InfoViewTemplateHelper.generateContent(MethodContext _oContext, User _currUser)
static InfoViewDocuments | InfoViewNewQueryHelper.queryData(MethodContext _methodContext)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML(MethodContext _context)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML2(MethodContext _context)
static java.lang.String | InfoViewNewQueryHelper.queryDataXML3(MethodContext _context)
static Documents | InfoViewNewQueryHelper.queryDocuments(MethodContext _methodContext)

com.trs.components.infoview.mad 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.infoview.mad 中的方法
int | InfoViewQueryHelper.findCurrDocIdBySNO(MethodContext _context)
int | InfoViewQueryHelperImpl.findCurrDocIdBySNO(MethodContext _context)
Documents | InfoViewQueryHelper.getDocuments(Channel _channel, MethodContext _context)
Documents | InfoViewQueryHelperImpl.getDocuments(Channel _channel, MethodContext _context)

com.trs.components.metadata.service 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.metadata.service 中的方法
java.lang.String | MetaDataDefServiceProvider.buildAllFromTextFile(MethodContext _methodContext) 根据文本文件的定义，创建系统
void | ClassInfoServiceProvider.changeOrder(MethodContext _methodContext) 调整分类法顺序
void | MetaDataDefServiceProvider.changeViewFieldOrder(MethodContext _methodContext) 改变视图字段的顺序
Reports | MetaDataCenterServiceProvider.copy(MethodContext _methodContext) 复制记录到...
Reports | GovInfoServiceProvider.copy(MethodContext _methodContext) 复制记录到...
Reports | MetaDataCenterServiceProviderForGB.copy(MethodContext _methodContext) 复制记录到...
Reports | MetaDataCenterServiceProviderForAgri.copy(MethodContext _methodContext) 复制记录到...
void | MetaDataCenterServiceProvider.copyViewDatas(MethodContext _methodContext) 将记录复制到另一个分类法下
java.lang.String | ClassInfoServiceProvider.createClassInfoTreeHTML(MethodContext _methodContext) 产生指定分类下所有子分类的HTML
java.lang.String | ClassInfoServiceProviderForGB.createClassInfoTreeHTMLForGB(MethodContext _methodContext) 产生指定分类下所有子分类的HTML
java.lang.String | ClassInfoServiceProvider.createClassInfoTreeHTMLOfIds(MethodContext _methodContext) 产生指定ID序列的HTML type表示产生的方式，type=0表示沿着一条链一直展开，用于定位到一个未展开的节点 传入的ids有父子关系;type!
java.lang.String | ClassInfoServiceProviderForGB.createClassInfoTreeHTMLOfIds(MethodContext _methodContext) 产生指定ID序列的HTML type表示产生的方式，type=0表示沿着一条链一直展开，用于定位到一个未展开的节点 传入的ids有父子关系;type!
Reports | MetaDataDefServiceProvider.createViewRelation(MethodContext _methodContext) 重新产生所有视图或者指定视图的应用
void | ClassInfoServiceProvider.deleteClassInfo(MethodContext _methodContext) 删除指定的分类
void | ClassInfoServiceProviderForGB.deleteClassInfo(MethodContext _methodContext) 删除指定的分类
Reports | MetaDataDefServiceProvider.deleteDBFieldInfo(MethodContext _methodContext) 删除元数据字段信息
Reports | MetaDataDefServiceProvider.deleteDBTableInfo(MethodContext _methodContext) 删除元数据结构信息
Reports | MetaDataDefServiceProvider.deleteView(MethodContext _methodContext) 删除多个视图信息
Reports | MetaDataCenterServiceProvider.deleteViewDatas(MethodContext _methodContext) 已过时。 改成Document的监听机制，转向调用ViewDocument.delete方法
Reports | GovInfoServiceProvider.deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
Reports | MetaDataCenterServiceProviderForGB.deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
Reports | MetaDataCenterServiceProviderForAgri.deleteViewDatas(MethodContext _methodContext) 删除视图数据信息
Reports | MetaDataDefServiceProvider.deleteViewField(MethodContext _methodContext) 删除视图字段信息信息
java.lang.Object | ClassInfoServiceProvider.exists(MethodContext _methodContext) 是否存在指定条件的分类信息
java.lang.Object | ClassInfoServiceProviderForGB.exists(MethodContext _methodContext) 是否存在指定条件的分类信息
java.lang.String | MetaDataCenterServiceProvider.exportAllViewDatas(MethodContext _methodContext) 导出指定视图或栏目下的所有元数据记录
java.lang.String | ClassInfoServiceProvider.exportClassInfos(MethodContext _oMethodContext) 导出指定的分类法
java.lang.String | MetaDataCenterServiceProvider.exportViewDatas(MethodContext _methodContext) 导出元数据
java.lang.String | GovInfoServiceProvider.exportViewDatas(MethodContext _methodContext) 导出元数据
java.lang.String | MetaDataCenterServiceProviderForGB.exportViewDatas(MethodContext _methodContext) 导出元数据
java.lang.String | MetaDataCenterServiceProviderForAgri.exportViewDatas(MethodContext _methodContext) 导出元数据
java.lang.String | MetaDataDefServiceProvider.exportViews(MethodContext _oMethodContext) 导出指定的视图
java.lang.Object | ClassInfoServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | ClassInfoServiceProviderForGB.findById(MethodContext _methodContext)
MetaDBField | MetaDataDefServiceProvider.findDBFieldInfoById(MethodContext _methodContext) 根据ID获取元数据对象
MetaDBTable | MetaDataDefServiceProvider.findDBTableInfoById(MethodContext _methodContext) 根据ID获取元数据结构对象
MetaDBTables | MetaDataDefServiceProvider.findDBTableInfosByIds(MethodContext _methodContext) 根据ID序列获取元数据集合
java.lang.String | MetaDataDefServiceProvider.findSynRule(MethodContext _methodContext) 为栏目设置同步文档的规则
MetaView | MetaDataDefServiceProvider.findViewByChannel(MethodContext _methodContext)
MetaView | MetaDataDefServiceProvider.findViewById(MethodContext _methodContext) 根据ID获取视图信息对象
MetaViewData | MetaDataCenterServiceProvider.findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
MetaViewData | GovInfoServiceProvider.findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
MetaViewData | MetaDataCenterServiceProviderForGB.findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
MetaViewData | MetaDataCenterServiceProviderForAgri.findViewDataById(MethodContext _methodContext) 根据ID获取指定视图数据的对象
MetaViewField | MetaDataDefServiceProvider.findViewFieldById(MethodContext _methodContext)
java.lang.String | ClassInfoServiceProvider.getPath(MethodContext _methodContext)
java.lang.String | ClassInfoServiceProviderForGB.getPath(MethodContext _methodContext)
MetaView | MetaDataDefServiceProvider.getViewFromChannel(MethodContext _methodContext)
Reports | ClassInfoServiceProvider.importClassInfos(MethodContext _methodContext) 从文件中导入分类法
Reports | ClassInfoServiceProviderForGB.importClassInfos(MethodContext _methodContext) 从文件中导入分类法
Reports | MetaDataCenterServiceProvider.importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
Reports | GovInfoServiceProvider.importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
Reports | MetaDataCenterServiceProviderForGB.importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
Reports | MetaDataCenterServiceProviderForAgri.importMetaViewDatas(MethodContext _methodContext) 在指定的栏目下导入指定的视图
MetaView | MetaDataDefServiceProvider.importViewFromXML(MethodContext _methodContext) 从XML文件创建视图
Reports | MetaDataDefServiceProvider.importViewsFromXML(MethodContext _oMethodContext) 从系统导出的XML创建视图（包括元数据表）
void | ClassInfoServiceProvider.moveAsChild(MethodContext _methodContext)
void | MetaDataCenterServiceProvider.moveViewDatas(MethodContext _methodContext) 将某些分类法下的记录移动到另一个分类法下
java.lang.String | ClassInfoViewServiceProvider.preview(MethodContext _methodContext)
void | ClassInfoViewServiceProvider.publish(MethodContext _methodContext)
void | ClassInfoPublishServiceProvider.publishClassInfo(MethodContext _oMethodContext)
ClassInfos | ClassInfoViewServiceProvider.queryClassInfos(MethodContext _methodContext) 根据文档的ids，获取在指定分类下的文档所在分类
ClassInfos | ClassInfoServiceProvider.queryClassInfos(MethodContext _methodContext) 获取指定的分类
ClassInfos | ClassInfoServiceProviderForGB.queryClassInfos(MethodContext _methodContext) 获取指定的分类
ClassInfos | ClassInfoViewServiceProvider.queryClassInfos1(MethodContext _methodContext)
ClassInfos | MetaDataDefServiceProvider.queryClassInfosUsingMetaView(MethodContext _methodContext) 获取系统所有使用了视图或指定视图的分类法树根
MetaDBFields | MetaDataDefServiceProvider.queryDBFieldInfos(MethodContext _methodContext) 查询指定表的字段集合
MetaDBTables | MetaDataDefServiceProvider.queryDBTableInfos(MethodContext _oMethodContext)
java.lang.String | ClassInfoViewServiceProvider.queryDocNumMapping(MethodContext _methodContext) 根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
java.lang.String | ClassInfoViewServiceProvider.queryDocNumMapping2(MethodContext _methodContext) 获取分类法和文档数目的一个隐射
Documents | ClassInfoViewServiceProvider.queryDocuments(MethodContext _methodContext)
java.lang.String | GovInfoServiceProvider.queryObjectsCountOfView(MethodContext _methodContext) 根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
java.lang.String | MetaDataCenterServiceProviderForGB.queryObjectsCountOfView(MethodContext _methodContext) 根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
java.lang.String | MetaDataCenterServiceProviderForAgri.queryObjectsCountOfView(MethodContext _methodContext) 根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
MetaViewDatas | GovInfoServiceProvider.queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | MetaDataCenterServiceProviderForGB.queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | MetaDataCenterServiceProviderForAgri.queryObjectsOfView(MethodContext _methodContext)
MetaViewDatas | MetaDataCenterServiceProvider.queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | GovInfoServiceProvider.queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | MetaDataCenterServiceProviderForGB.queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | MetaDataCenterServiceProviderForAgri.queryViewDatas(MethodContext _methodContext) 获取指定视图的数据
MetaViewDatas | MetaDataCenterServiceProvider.queryViewDatasNoView(MethodContext _methodContext)
MetaViewFields | MetaDataDefServiceProvider.queryViewFieldInfos(MethodContext _methodContext)
MetaViews | ClassInfoViewServiceProvider.queryViews(MethodContext _methodContext) 根据分类法信息获取视图信息
MetaViews | MetaDataDefServiceProvider.queryViews(MethodContext _methodContext) 获取系统所有视图
MetaViews | ClassInfoViewServiceProvider.queryViewsByClassInfo(MethodContext _methodContext) 获取使用了指定分类法的视图信息,如果分类法ID为0，则表示获取使用了分类法字段的所有视图
MetaViews | MetaDataDefServiceProvider.queryViewsUsingClassInfo(MethodContext _methodContext) 获取系统所有使用了分类法字段或指定分类法字段视图
MetaViews | MetaDataDefServiceProvider.queryViewsUsintTable(MethodContext _methodContext) 获取正在使用指定表的视图列表
void | MetaDataDefServiceProvider.recreateAllOfDBTableInfo(MethodContext _methodContext)
ClassInfo | ClassInfoServiceProvider.saveClassInfo(MethodContext _context)
ClassInfo | ClassInfoServiceProviderForGB.saveClassInfo(MethodContext _context)
ClassInfo | ClassInfoServiceProvider.saveClassInfo(MethodContext _methodContext, User _currUser, int _nCurrId, int _nParentId, int _nPreviousId, java.lang.String _sName, java.lang.String _sDesc, java.lang.String _sCCode) 这个方法实现不太好，但只是为了兼容wcm6，因为wcm6的实现，字段都是写死的， 不能根据外界传入什么字段，向数据库中保存什么
MetaDBField | MetaDataDefServiceProvider.saveDBFieldInfo(MethodContext _methodContext) 保存元数据字段信息
MetaDBTable | MetaDataDefServiceProvider.saveDBTableInfo(MethodContext _methodContext) 保存元数据表的信息
MetaViewData | MetaDataCenterServiceProvider.saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | GovInfoServiceProvider.saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | MetaDataCenterServiceProviderForGB.saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | MetaDataCenterServiceProviderForZJH.saveMetaViewData(MethodContext _methodContext) 保存来自政府的公开信息
MetaViewData | MetaDataCenterServiceProviderForAgri.saveMetaViewData(MethodContext _methodContext) 保存在指定视图下提交的数据信息
MetaViewData | GovInfoServiceProvider.saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
MetaViewData | MetaDataCenterServiceProviderForGB.saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
MetaViewData | MetaDataCenterServiceProviderForZJH.saveMetaViewDataOfGov(MethodContext _methodContext)
MetaViewData | MetaDataCenterServiceProviderForAgri.saveMetaViewDataOfGov(MethodContext _methodContext) 保存来自政府的公开信息
void | MetaDataDefServiceProvider.saveSynRule(MethodContext _methodContext) 为栏目设置同步文档的规则
MetaView | MetaDataDefServiceProvider.saveView(MethodContext _methodContext) 保存指定的视图信息
MetaViewField | MetaDataDefServiceProvider.saveViewField(MethodContext _methodContext) 保存视图字段信息
static MetaViewData | GovInfoServiceProvider.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForGB.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForZJH.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
static MetaViewData | MetaDataCenterServiceProviderForAgri.setViewDataProperties(MethodContext _methodContext, MetaViewData _oViewData)
void | MetaDataDefServiceProvider.setViewEmployerByChannel(MethodContext _methodContext) 给指定栏目分配视图
void | MetaDataDefServiceProvider.setViewFields(MethodContext _methodContext) 维护视图选择的字段：目前仅仅适合单表模式
void | MetaDataDefServiceProvider.setViewFieldsInfo(MethodContext _methodContext) 设置多个视图字段的信息

com.trs.components.metadata.service.listener 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.metadata.service.listener 中的方法
void | ViewDocumentListenerForPubGovInfo.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
void | PublishListenerForPubGovInfo.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
void | ChannelCreateFromListenerForMetaView.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)

com.trs.components.metadata.service.xmlconvertors 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.metadata.service.xmlconvertors 中的方法
 java.lang.String ViewDataToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)

com.trs.components.special 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.special 中的方法
boolean | SpecialServiceProvider.createFrom(MethodContext _context)
boolean | ISpecialServiceProvider.createFrom(MethodContext _methodContext) 专题的类似创建
void | SpecialServiceProvider.delete(MethodContext _context)
void | ISpecialServiceProvider.delete(MethodContext _context) 删除指定ID序列的专题
boolean | SpecialServiceProvider.existsSimilarName(MethodContext _context)
boolean | ISpecialServiceProvider.existsSimilarName(MethodContext _methodContext) 是否存在相同名称的专题
java.lang.Object | SpecialServiceProvider.findById(MethodContext context)
java.lang.Object | SpecialServiceProvider.findByIds(MethodContext context)
PageStyle | SpecialServiceProvider.getStyle(MethodContext _context)
PageStyle | ISpecialServiceProvider.getStyle(MethodContext _methodContext) 获取专题页面风格
java.lang.Object | SpecialServiceProvider.query(MethodContext _context)
java.lang.Object | ISpecialServiceProvider.query(MethodContext _context) 获取符合条件的专题
int | SpecialServiceProvider.save(MethodContext _context)
int | ISpecialServiceProvider.save(MethodContext _context) 保存当前专题对象
boolean | SpecialServiceProvider.setStyle(MethodContext _context)
boolean | ISpecialServiceProvider.setStyle(MethodContext _methodContext) 设置专题页面风格

com.trs.components.stat 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.stat 中的方法
void | BonusRuleServiceProvider.delete(MethodContext context)
void | UserLoginInfoServiceProvider.delete(MethodContext context)
java.lang.Object | BonusRuleServiceProvider.findById(MethodContext context)
java.lang.Object | UserLoginInfoServiceProvider.findById(MethodContext context)
java.lang.Object | BonusRuleServiceProvider.findByIds(MethodContext context)
java.lang.Object | UserLoginInfoServiceProvider.findByIds(MethodContext context)
java.lang.Object | BonusRuleServiceProvider.query(MethodContext context)
java.lang.Object | UserLoginInfoServiceProvider.query(MethodContext context) 查询指定条件的记录。
int | BonusRuleServiceProvider.save(MethodContext context)
int | UserLoginInfoServiceProvider.save(MethodContext context) 这里要实现的是存储一条当前用户登陆信息。

com.trs.components.wcm.content.domain 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.wcm.content.domain 中的方法
 void DocumentMoveListenerForDocSiteRecode.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)

com.trs.components.wcm.epress 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.wcm.epress 中的方法
boolean | EPressServiceProvider.checkUUID(MethodContext context)
int | EPressServiceProvider.createEPress(MethodContext context)
boolean | EPressServiceProvider.existsSimilarName(MethodContext context)
boolean | EPressServiceProvider.publishHistoryIndex(MethodContext context)
int | EPressHistoryPubLogger.startLog(MethodConfig conf, MethodContext context)
int | EPressChannelCreateLogger.startLog(MethodConfig conf, MethodContext context)

com.trs.components.wcm.publish.region 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.components.wcm.publish.region 中的方法
void | TemplateSaveListenerForRegionEmploy.afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
void | CellsSaveListenerForPublish.afterServiceExecuted(ServiceListenerConfig listenerConfig, MethodContext methodContext, java.lang.Object serviceResult)
void | RegionServiceProvider.delete(MethodContext _oContext)
void | RegionEmployServiceProvider.delete(MethodContext context)
void | CellServiceProvider.delete(MethodContext _oContext)
boolean | RegionServiceProvider.existsSimilarName(MethodContext _oContext) 判断该名称的导读是否已经存在
java.lang.Object | RegionServiceProvider.findById(MethodContext _oContext)
java.lang.Object | RegionEmployServiceProvider.findById(MethodContext context)
java.lang.Object | CellServiceProvider.findById(MethodContext _oContext)
java.lang.Object | RegionServiceProvider.findByIds(MethodContext _oContext)
java.lang.Object | RegionEmployServiceProvider.findByIds(MethodContext context)
java.lang.Object | CellServiceProvider.findByIds(MethodContext _oContext)
java.lang.Object | RegionServiceProvider.query(MethodContext _oContext)
java.lang.Object | RegionEmployServiceProvider.query(MethodContext context)
java.lang.Object | CellServiceProvider.query(MethodContext _oContext)
int | RegionServiceProvider.save(MethodContext _oContext)
int | RegionEmployServiceProvider.save(MethodContext context)
int | CellServiceProvider.save(MethodContext _oContext)
void | CellServiceProvider.saveCells(MethodContext _oContext) 保存指定导读的所有单元格信息

com.trs.webframework 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.webframework 中的方法
static java.lang.Object | WebServiceHelper.execute(MethodConfig _methodConfig, MethodContext _methodContext)
static java.lang.Object | WebServiceHelper.execute(MethodConfig _methodConfig, MethodContext _methodContext, boolean _bNotConvertor)
int | DefaultSaveLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | DefaultDeleteLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)
int | ServiceExcuteLogger.startLog(MethodConfig _methodConf, MethodContext _methodContext)

com.trs.webframework.context 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.webframework.context 中的方法
static WCMFilter MethodContextHelper.mergeMoreFilter(MethodContext _context, WCMFilter _filter)

com.trs.webframework.controler 中 MethodContext 的使用

返回 MethodContext 的 com.trs.webframework.controler 中的方法
 MethodContext JSPRequestParmasValidator.getMethodContext()

com.trs.webframework.controler.servlet 中 MethodContext 的使用

返回 MethodContext 的 com.trs.webframework.controler.servlet 中的方法
MethodContext | XMLParamsValidator.getMethodContext()
MethodContext | RequestParmasValidator.getMethodContext()
MethodContext | BaseValidator.getMethodContext()

com.trs.webframework.demo 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.webframework.demo 中的方法
void | StdDemoProviderImpl.delete(MethodContext _context)
java.lang.Object | StdDemoProviderImpl.findById(MethodContext _context)
java.lang.Object | StdDemoProviderImpl.findByIds(MethodContext _context)
java.lang.Object | StdDemoProviderImpl.query(MethodContext _context)
int | StdDemoProviderImpl.save(MethodContext _context)

com.trs.webframework.provider 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.webframework.provider 中的方法
void | ServiceListenerExample.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
void | IServiceListener.afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult) 在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
void | IDeleteServiceProvider.delete(MethodContext _methodContext)
void | BaseServiceDecorator.delete(MethodContext _context)
boolean | ServiceFilterExample.doFilter(ServiceFilterConfig _oFilterConfig, MethodContext _oMethodContext)
boolean | IServiceFilter.doFilter(ServiceFilterConfig _oFilterConfig, MethodContext _oMethodContext) * 在执行服务之前，在这个方法中可以： 1、根据当前上下文参数，判断操作是否可以继续 2、如果不能继续，也可以通过MethodContext获取当前Servlet上下文参数，做重定向 3、也能够修改MethodContext
java.lang.Object | IFindByIdServiceProvider.findById(MethodContext _methodContext)
java.lang.Object | BaseServiceDecorator.findById(MethodContext _context)
java.lang.Object | IFindByIdsServiceProvider.findByIds(MethodContext _methodContext)
java.lang.Object | BaseServiceDecorator.findByIds(MethodContext _context)
void | DefautlServiceProvider.forword(MethodContext _methodContext) 空方法，不做任何实现，做转发使用
java.lang.Object | IQueryServiceProvider.query(MethodContext _methodContext)
java.lang.Object | BaseServiceDecorator.query(MethodContext _context)
int | ISaveServiceProvider.save(MethodContext _methodContext)
int | BaseServiceDecorator.save(MethodContext _context)

com.trs.webframework.xmlserver 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.webframework.xmlserver 中的方法
 java.lang.String IXMLConvertor.toXmlString(MethodContext _methodContext, java.lang.Object _result)
将指定对象的所有属性转换为XML字符串

com.trs.webframework.xmlserver.convertors 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trs.webframework.xmlserver.convertors 中的方法
java.lang.String | StringXMLConvertorImpl.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | IntegerXMLConvertorImpl.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | BooleanXMLConvertorImpl.toXmlString(MethodContext _methodContext, java.lang.Object _result)

com.trsothers 中 MethodContext 的使用

参数类型为 MethodContext 的 com.trsothers 中的方法
 void LogServiceProvider.recordBrowserLog(MethodContext _methodContext)
记录客户端框架发过来的异常

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.context.MethodContextHelper 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.context.MethodContextHelper
的使用

没有 com.trs.webframework.context.MethodContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.context.ServiceContext 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.context.ServiceContext
的使用

使用 ServiceContext 的软件包
com.trs.webframework.context
com.trs.webframework.controler
com.trs.webframework.controler.servlet
com.trs.webframework.provider
com.trs.webframework.xmlserver.server

com.trs.webframework.context 中 ServiceContext 的使用

返回 ServiceContext 的 com.trs.webframework.context 中的方法
static ServiceContext | ServiceContext.create(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response)
static ServiceContext | ServiceContext.getCurrentServiceContext()
ServiceContext | MethodContext.getServiceContext()

参数类型为 ServiceContext 的 com.trs.webframework.context 中的方法
 void MethodContext.setServiceContext(ServiceContext _serviceContext)

com.trs.webframework.controler 中 ServiceContext 的使用

com.trs.webframework.controler 中 ServiceContext 的子类
 class JSPServiceContext
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 ServiceContext 的 com.trs.webframework.controler 中的构造方法
JSPRequestParmasValidator(ServiceContext _requestContext, MethodConfig methoConfig)

com.trs.webframework.controler.servlet 中 ServiceContext 的使用

参数类型为 ServiceContext 的 com.trs.webframework.controler.servlet 中的构造方法
RequestParmasValidator(ServiceContext _requestContext, MethodConfig methoConfig)

com.trs.webframework.provider 中 ServiceContext 的使用

参数类型为 ServiceContext 的 com.trs.webframework.provider 中的方法
 void BaseServiceDecorator.decorate(ServiceContext _serviceContext)

com.trs.webframework.xmlserver.server 中 ServiceContext 的使用

参数类型为 ServiceContext 的 com.trs.webframework.xmlserver.server 中的构造方法
InvocationObserver(ServiceContext _serviceContext)
RequestParamsProcessor(ServiceContext _serviceContext)
RequestXMLDataProcessor(ServiceContext _serviceContext, java.io.InputStream _in)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


JSPRequestParmasValidator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler
类 JSPRequestParmasValidator

java.lang.Object
    继承者  com.trs.webframework.controler.servlet.BaseValidator
        继承者  com.trs.webframework.controler.JSPRequestParmasValidator

public class JSPRequestParmasValidator
extends BaseValidator

字段摘要
从类 com.trs.webframework.controler.servlet.BaseValidator 继承的字段
PARAM_NAME_ORDER_FIELD, PARAM_NAME_ORDER_TYPE, PARAM_NAME_SEARCH_KEY, PARAM_NAME_SEARCH_TABLE, PARAM_NAME_SEARCH_VALUE
构造方法摘要
JSPRequestParmasValidator(ServiceContext _requestContext, MethodConfig methoConfig)
方法摘要
 MethodContext getMethodContext()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JSPRequestParmasValidator

public JSPRequestParmasValidator(ServiceContext _requestContext,
                                 MethodConfig methoConfig)
方法详细信息

getMethodContext

public MethodContext getMethodContext()
覆盖：
类 BaseValidator 中的 getMethodContext
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


JSPRequestProcessor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler
类 JSPRequestProcessor

java.lang.Object
    继承者  com.trs.webframework.controler.JSPRequestProcessor

public class JSPRequestProcessor
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
JSPRequestProcessor(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response)
方法摘要
java.lang.Object | excute(java.lang.String _sServiceId, java.lang.String _sMethodName) 使用Request中的参数执行指定的服务
java.lang.Object | excute(java.lang.String _sServiceId, java.lang.String _sMethodName, java.util.HashMap _parameters) 使用指定的参数执行指定的服务
java.lang.Object[] | excuteArrayMult(java.lang.String _sServiceId, java.lang.String _sMethodName) 执行一组中多个同名方法，并返回多个返回值
java.lang.Object | excuteMult(int _nServiceIndex) 指定MultCall中的指定顺序的服务，从0开始
java.lang.Object | excuteMult(java.lang.String _sServiceId, java.lang.String _sMethodName) 指定MultCall中的指定服务
java.lang.Object | getContextCacheData(java.lang.Object key) 获取MethodContext对象中放入临时缓存的对象
BaseObj | getCurrHost()
java.lang.String | getParam(java.lang.String _sParameterName)
boolean | getParam(java.lang.String _sParameterName, boolean _bDefaultValue)
CMyDateTime | getParam(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
double | getParam(java.lang.String _sParameterName, double _dDefaultValue)
float | getParam(java.lang.String _sParameterName, float _fDefaultValue)
int | getParam(java.lang.String _sParameterName, int _nDefaultValue)
long | getParam(java.lang.String _sParameterName, long _lDefaultValue)
java.util.HashMap | getServiceParameters()
void | putContextCacheData(java.util.Map _oCacheData) 将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用
void | putContextCacheData(java.lang.Object key, java.lang.Object _value) 将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用
void | reset() 重置当前Processor执行的上下文环境
void | setAppendParameters(java.lang.String[] _appendParameters) 设置追加的参数
void | setCurrHost(BaseObj _oCurrHost) 设置当前方法时候关联的主要对象
void | setEscapeParameters(java.lang.String[] _escapeParameters) 指定Request转义的参数
void | setSelectParameters(java.lang.String[] _selectParameters) 指定Request中使用的参数
void | setSelectParameters(java.lang.String[] _selectParameters, boolean _bIncludeAppend) 指定Request中使用的参数
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JSPRequestProcessor

public JSPRequestProcessor(javax.servlet.http.HttpServletRequest _request,
                           javax.servlet.http.HttpServletResponse _response)
方法详细信息

setSelectParameters

public void setSelectParameters(java.lang.String[] _selectParameters)
指定Request中使用的参数

参数：
_selectParameters -

setSelectParameters

public void setSelectParameters(java.lang.String[] _selectParameters,
                                boolean _bIncludeAppend)
指定Request中使用的参数

参数：
_selectParameters -

setEscapeParameters

public void setEscapeParameters(java.lang.String[] _escapeParameters)
                         throws WCMException
指定Request转义的参数

参数：
_escapeParameters -
抛出：
WCMException

setAppendParameters

public void setAppendParameters(java.lang.String[] _appendParameters)
                         throws WCMException
设置追加的参数

参数：
_appendParameters -
抛出：
WCMException

reset

public void reset()
重置当前Processor执行的上下文环境

excute

public java.lang.Object excute(java.lang.String _sServiceId,
                               java.lang.String _sMethodName)
                        throws WCMException
使用Request中的参数执行指定的服务

参数：
_sServiceId -
_sMethodName -
返回：
抛出：
WCMException

excute

public java.lang.Object excute(java.lang.String _sServiceId,
                               java.lang.String _sMethodName,
                               java.util.HashMap _parameters)
                        throws WCMException
使用指定的参数执行指定的服务

参数：
_sServiceId -
_sMethodName -
_parameters - 指定的参数
返回：
抛出：
WCMException

excuteMult

public java.lang.Object excuteMult(java.lang.String _sServiceId,
                                   java.lang.String _sMethodName)
                            throws WCMException
指定MultCall中的指定服务

参数：
_sServiceId -
_sMethodName -
返回：
抛出：
WCMException

excuteArrayMult

public java.lang.Object[] excuteArrayMult(java.lang.String _sServiceId,
                                          java.lang.String _sMethodName)
                                   throws WCMException
执行一组中多个同名方法，并返回多个返回值

参数：
_sServiceId -
_sMethodName -
返回：
抛出：
WCMException

excuteMult

public java.lang.Object excuteMult(int _nServiceIndex)
                            throws WCMException
指定MultCall中的指定顺序的服务，从0开始

参数：
_sServiceId -
_sMethodName -
返回：
抛出：
WCMException

getServiceParameters

public java.util.HashMap getServiceParameters()

getParam

public boolean getParam(java.lang.String _sParameterName,
                        boolean _bDefaultValue)

getParam

public CMyDateTime getParam(java.lang.String _sParameterName,
                            CMyDateTime _dtDefaultValue)

getParam

public double getParam(java.lang.String _sParameterName,
                       double _dDefaultValue)

getParam

public float getParam(java.lang.String _sParameterName,
                      float _fDefaultValue)

getParam

public int getParam(java.lang.String _sParameterName,
                    int _nDefaultValue)

getParam

public long getParam(java.lang.String _sParameterName,
                     long _lDefaultValue)

getParam

public java.lang.String getParam(java.lang.String _sParameterName)

setCurrHost

public void setCurrHost(BaseObj _oCurrHost)
设置当前方法时候关联的主要对象

参数：
_oCurrHost - 当前方法时候关联的主要对象，系统持久化对象

getCurrHost

public BaseObj getCurrHost()
返回：
当前方法时候关联的主要对象，系统持久化对象

putContextCacheData

public void putContextCacheData(java.util.Map _oCacheData)
将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用

参数：
_oCacheData - 需要Cache的数据

putContextCacheData

public void putContextCacheData(java.lang.Object key,
                                java.lang.Object _value)
将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用

参数：
key - Cache的Key
_value - 缓存的对象

getContextCacheData

public java.lang.Object getContextCacheData(java.lang.Object key)
获取MethodContext对象中放入临时缓存的对象

参数：
key -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSPServiceContext

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler
类 JSPServiceContext

java.lang.Object
    继承者  com.trs.webframework.context.ServiceContext
        继承者  com.trs.webframework.controler.JSPServiceContext

public class JSPServiceContext
extends ServiceContext

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.webframework.context.ServiceContext 继承的字段
IS_CONSOLE_TEST
构造方法摘要
JSPServiceContext(java.util.HashMap _parameters)
JSPServiceContext(javax.servlet.http.HttpServletRequest _request, javax.servlet.http.HttpServletResponse _response)
JSPServiceContext(JSPServiceContext _context)
方法摘要
java.lang.String | getParam(java.lang.String _sParameterName)
boolean | getParam(java.lang.String _sParameterName, boolean _bDefaultValue)
CMyDateTime | getParam(java.lang.String _sParameterName, CMyDateTime _dtDefaultValue)
double | getParam(java.lang.String _sParameterName, double _dDefaultValue)
float | getParam(java.lang.String _sParameterName, float _fDefaultValue)
int | getParam(java.lang.String _sParameterName, int _nDefaultValue)
long | getParam(java.lang.String _sParameterName, long _lDefaultValue)
java.util.Enumeration | getParameterNames()
java.util.Map | getParameters()
java.lang.String | getParameterValue(java.lang.String _sParameterName)
java.lang.String[] | getParameterValues(java.lang.String _sParameterName)
static java.util.Enumeration | iterator2Enumeration(java.util.Iterator iterator)
void | setMapParameters(java.util.HashMap _parameters)
从类 com.trs.webframework.context.ServiceContext 继承的方法
create, getCurrentServiceContext, getInputStream, getInputStreamWrapper, getRequest, getResponse, getSessionValue, isReturnHTML, isReturnJSON, setContentType, setContentTypeIsHTML, setInputStreamWrapper, setReturnHTML, setReturnJSON
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JSPServiceContext

public JSPServiceContext(JSPServiceContext _context)

JSPServiceContext

public JSPServiceContext(java.util.HashMap _parameters)

JSPServiceContext

public JSPServiceContext(javax.servlet.http.HttpServletRequest _request,
                         javax.servlet.http.HttpServletResponse _response)
方法详细信息

setMapParameters

public void setMapParameters(java.util.HashMap _parameters)

getParameterValues

public java.lang.String[] getParameterValues(java.lang.String _sParameterName)
覆盖：
类 ServiceContext 中的 getParameterValues

getParameterValue

public java.lang.String getParameterValue(java.lang.String _sParameterName)
覆盖：
类 ServiceContext 中的 getParameterValue

getParameterNames

public java.util.Enumeration getParameterNames()
覆盖：
类 ServiceContext 中的 getParameterNames

getParameters

public java.util.Map getParameters()
覆盖：
类 ServiceContext 中的 getParameters

iterator2Enumeration

public static java.util.Enumeration iterator2Enumeration(java.util.Iterator iterator)

getParam

public java.lang.String getParam(java.lang.String _sParameterName)

getParam

public boolean getParam(java.lang.String _sParameterName,
                        boolean _bDefaultValue)

getParam

public int getParam(java.lang.String _sParameterName,
                    int _nDefaultValue)

getParam

public long getParam(java.lang.String _sParameterName,
                     long _lDefaultValue)

getParam

public double getParam(java.lang.String _sParameterName,
                       double _dDefaultValue)

getParam

public float getParam(java.lang.String _sParameterName,
                      float _fDefaultValue)

getParam

public CMyDateTime getParam(java.lang.String _sParameterName,
                            CMyDateTime _dtDefaultValue)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.controler
类
JSPRequestParmasValidator
JSPRequestProcessor
JSPServiceContext
PostDataParser


com.trs.webframework.controler

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.controler

类摘要
JSPRequestParmasValidator |
JSPRequestProcessor | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
JSPServiceContext | Title: TRS 内容协作平台（TRS WCM 6.0） Description: Service上下文信息记录对象 Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
PostDataParser |


com.trs.webframework.controler 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.controler 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.controler.servlet.BaseValidator
      • com.trs.webframework.controler.JSPRequestParmasValidator
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.trs.webframework.controler.PostDataParser
    • com.trs.webframework.controler.JSPRequestProcessor
    • com.trs.webframework.context.ServiceContext
      • com.trs.webframework.controler.JSPServiceContext


软件包 com.trs.webframework.controler 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.controler
的使用

使用 com.trs.webframework.controler 的软件包
com.trs.webframework.controler

com.trs.webframework.controler 使用的 com.trs.webframework.controler 中的类
JSPServiceContext
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


PostDataParser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler
类 PostDataParser

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
        继承者  com.trs.webframework.controler.PostDataParser
所有已实现的接口：
org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class PostDataParser
extends org.xml.sax.helpers.DefaultHandler

作者：
Administrator

构造方法摘要
PostDataParser()
方法摘要
void | characters(char[] _ch, int _start, int _length)
void | endElement(java.lang.String _uri, java.lang.String _localName, java.lang.String _name)
java.util.HashMap[] | findArrayParameters(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取指定服务的参数(返回所有匹配的)
java.lang.String | findMethodName(int _nServiceIndex) 获取指定顺序的服务方法名
java.util.HashMap | findParameters(int _nServiceIndex)
java.util.HashMap | findParameters(java.lang.String _sServiceId, java.lang.String _sMethodName) 获取指定服务的参数(返回第一个匹配的)
java.lang.String | findServiceId(int _nServiceIndex) 获取指定顺序的服务ID
static void | main(java.lang.String[] args)
void | parse(org.xml.sax.InputSource _ins)
void | parse(java.lang.String _sXMLFile)
void | startElement(java.lang.String _uri, java.lang.String _localName, java.lang.String _name, org.xml.sax.Attributes _attributes)
从类 org.xml.sax.helpers.DefaultHandler 继承的方法
endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PostDataParser

public PostDataParser()
方法详细信息

parse

public void parse(java.lang.String _sXMLFile)
           throws WCMException
参数：
_sXMLFile -
抛出：
WCMException

parse

public void parse(org.xml.sax.InputSource _ins)
           throws WCMException
抛出：
WCMException

findParameters

public java.util.HashMap findParameters(java.lang.String _sServiceId,
                                        java.lang.String _sMethodName)
获取指定服务的参数(返回第一个匹配的)

参数：
_sServiceId -
_sMethodName -
返回：

findArrayParameters

public java.util.HashMap[] findArrayParameters(java.lang.String _sServiceId,
                                               java.lang.String _sMethodName)
获取指定服务的参数(返回所有匹配的)

参数：
_sServiceId -
_sMethodName -
返回：

findParameters

public java.util.HashMap findParameters(int _nServiceIndex)
参数：
_nServiceIndex -
返回：

findServiceId

public java.lang.String findServiceId(int _nServiceIndex)
获取指定顺序的服务ID

参数：
_nServiceIndex -
返回：

findMethodName

public java.lang.String findMethodName(int _nServiceIndex)
获取指定顺序的服务方法名

参数：
_nServiceIndex -
返回：

characters

public void characters(char[] _ch,
                       int _start,
                       int _length)
                throws org.xml.sax.SAXException
指定者：
接口 org.xml.sax.ContentHandler 中的 characters
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 characters
抛出：
org.xml.sax.SAXException

startElement

public void startElement(java.lang.String _uri,
                         java.lang.String _localName,
                         java.lang.String _name,
                         org.xml.sax.Attributes _attributes)
                  throws org.xml.sax.SAXException
指定者：
接口 org.xml.sax.ContentHandler 中的 startElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 startElement
抛出：
org.xml.sax.SAXException

endElement

public void endElement(java.lang.String _uri,
                       java.lang.String _localName,
                       java.lang.String _name)
                throws org.xml.sax.SAXException
指定者：
接口 org.xml.sax.ContentHandler 中的 endElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 endElement
抛出：
org.xml.sax.SAXException

main

public static void main(java.lang.String[] args)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.controler.JSPRequestParmasValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.JSPRequestParmasValidator
的使用

没有 com.trs.webframework.controler.JSPRequestParmasValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.JSPRequestProcessor 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.JSPRequestProcessor
的使用

没有 com.trs.webframework.controler.JSPRequestProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.JSPServiceContext 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.JSPServiceContext
的使用

使用 JSPServiceContext 的软件包
com.trs.webframework.controler

com.trs.webframework.controler 中 JSPServiceContext 的使用

参数类型为 JSPServiceContext 的 com.trs.webframework.controler 中的构造方法
JSPServiceContext(JSPServiceContext _context)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.PostDataParser 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.PostDataParser
的使用

没有 com.trs.webframework.controler.PostDataParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseValidator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 BaseValidator

java.lang.Object
    继承者  com.trs.webframework.controler.servlet.BaseValidator
直接已知子类：
JSPRequestParmasValidator, RequestParmasValidator, XMLParamsValidator
public abstract class BaseValidator
extends java.lang.Object

字段摘要
static java.lang.String | PARAM_NAME_ORDER_FIELD
static java.lang.String | PARAM_NAME_ORDER_TYPE
static java.lang.String | PARAM_NAME_SEARCH_KEY
static java.lang.String | PARAM_NAME_SEARCH_TABLE
static java.lang.String | PARAM_NAME_SEARCH_VALUE
构造方法摘要
BaseValidator(MethodConfig methoConfig)
方法摘要
 MethodContext getMethodContext()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PARAM_NAME_SEARCH_KEY

public static final java.lang.String PARAM_NAME_SEARCH_KEY
另请参见：
常量字段值

PARAM_NAME_SEARCH_TABLE

public static final java.lang.String PARAM_NAME_SEARCH_TABLE
另请参见：
常量字段值

PARAM_NAME_SEARCH_VALUE

public static final java.lang.String PARAM_NAME_SEARCH_VALUE
另请参见：
常量字段值

PARAM_NAME_ORDER_FIELD

public static final java.lang.String PARAM_NAME_ORDER_FIELD
另请参见：
常量字段值

PARAM_NAME_ORDER_TYPE

public static final java.lang.String PARAM_NAME_ORDER_TYPE
另请参见：
常量字段值
构造方法详细信息

BaseValidator

public BaseValidator(MethodConfig methoConfig)
方法详细信息

getMethodContext

public MethodContext getMethodContext()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FileUploader

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 FileUploader

java.lang.Object
    继承者  javax.servlet.GenericServlet
        继承者  javax.servlet.http.HttpServlet
            继承者  com.trs.webframework.controler.servlet.FileUploader
所有已实现的接口：
java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig
public class FileUploader
extends javax.servlet.http.HttpServlet

另请参见：
序列化表格

构造方法摘要
FileUploader()
方法摘要
从类 javax.servlet.http.HttpServlet 继承的方法
service
从类 javax.servlet.GenericServlet 继承的方法
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, init, log, log
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileUploader

public FileUploader()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ILoginValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
接口 ILoginValidator

所有已知实现类：
LoginValidatorDefaultImpl, LoginValidatorThreadLocalImpl
public interface ILoginValidator

方法摘要
 boolean isLogin(javax.servlet.http.HttpServletRequest request)
判断当前是否已经登录

方法详细信息

isLogin

boolean isLogin(javax.servlet.http.HttpServletRequest request)
判断当前是否已经登录

参数：
request -
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoginValidatorDefaultImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 LoginValidatorDefaultImpl

java.lang.Object
    继承者  com.trs.webframework.controler.servlet.LoginValidatorDefaultImpl
所有已实现的接口：
ILoginValidator
public class LoginValidatorDefaultImpl
extends java.lang.Object
implements ILoginValidator

构造方法摘要
LoginValidatorDefaultImpl()
方法摘要
 boolean isLogin(javax.servlet.http.HttpServletRequest request)
判断当前是否已经登录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LoginValidatorDefaultImpl

public LoginValidatorDefaultImpl()
方法详细信息

isLogin

public boolean isLogin(javax.servlet.http.HttpServletRequest request)
从接口 ILoginValidator 复制的描述
判断当前是否已经登录

指定者：
接口 ILoginValidator 中的 isLogin
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoginValidatorFactory

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 LoginValidatorFactory

java.lang.Object
    继承者  com.trs.webframework.controler.servlet.LoginValidatorFactory

public class LoginValidatorFactory
extends java.lang.Object

字段摘要
static java.lang.Class CLASS_VALIDATOR
构造方法摘要
LoginValidatorFactory()
方法摘要
static ILoginValidator createLoginValidator()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CLASS_VALIDATOR

public static java.lang.Class CLASS_VALIDATOR
构造方法详细信息

LoginValidatorFactory

public LoginValidatorFactory()
方法详细信息

createLoginValidator

public static ILoginValidator createLoginValidator()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoginValidatorThreadLocalImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 LoginValidatorThreadLocalImpl

java.lang.Object
    继承者  com.trs.webframework.controler.servlet.LoginValidatorThreadLocalImpl
所有已实现的接口：
ILoginValidator
public class LoginValidatorThreadLocalImpl
extends java.lang.Object
implements ILoginValidator

构造方法摘要
LoginValidatorThreadLocalImpl()
方法摘要
 boolean isLogin(javax.servlet.http.HttpServletRequest request)
判断当前是否已经登录
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LoginValidatorThreadLocalImpl

public LoginValidatorThreadLocalImpl()
方法详细信息

isLogin

public boolean isLogin(javax.servlet.http.HttpServletRequest request)
从接口 ILoginValidator 复制的描述
判断当前是否已经登录

指定者：
接口 ILoginValidator 中的 isLogin
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoLoginServiceControler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 NoLoginServiceControler

java.lang.Object
    继承者  javax.servlet.GenericServlet
        继承者  javax.servlet.http.HttpServlet
            继承者  com.trs.webframework.controler.servlet.NoLoginServiceControler
所有已实现的接口：
java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig
public class NoLoginServiceControler
extends javax.servlet.http.HttpServlet

Title: TRS 内容协作平台（TRS WCM）
Description:
不需要登录的控制器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
NoLoginServiceControler()
方法摘要
 void init()
从类 javax.servlet.http.HttpServlet 继承的方法
service
从类 javax.servlet.GenericServlet 继承的方法
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NoLoginServiceControler

public NoLoginServiceControler()
方法详细信息

init

public void init()
          throws javax.servlet.ServletException
覆盖：
类 javax.servlet.GenericServlet 中的 init
抛出：
javax.servlet.ServletException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.controler.servlet
接口
ILoginValidator
类
BaseValidator
FileUploader
LoginValidatorDefaultImpl
LoginValidatorFactory
LoginValidatorThreadLocalImpl
NoLoginServiceControler
RequestParmasValidator
ServiceControler
XMLParamsValidator


com.trs.webframework.controler.servlet

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.controler.servlet

接口摘要
ILoginValidator

类摘要
BaseValidator |
FileUploader |
LoginValidatorDefaultImpl |
LoginValidatorFactory |
LoginValidatorThreadLocalImpl |
NoLoginServiceControler | Title: TRS 内容协作平台（TRS WCM） Description: 不需要登录的控制器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RequestParmasValidator |
ServiceControler |
XMLParamsValidator |


com.trs.webframework.controler.servlet 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.controler.servlet 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.controler.servlet.BaseValidator
      • com.trs.webframework.controler.servlet.RequestParmasValidator
      • com.trs.webframework.controler.servlet.XMLParamsValidator
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • com.trs.webframework.controler.servlet.FileUploader
        • com.trs.webframework.controler.servlet.NoLoginServiceControler
        • com.trs.webframework.controler.servlet.ServiceControler
    • com.trs.webframework.controler.servlet.LoginValidatorDefaultImpl (implements com.trs.webframework.controler.servlet.ILoginValidator)
    • com.trs.webframework.controler.servlet.LoginValidatorFactory
    • com.trs.webframework.controler.servlet.LoginValidatorThreadLocalImpl (implements com.trs.webframework.controler.servlet.ILoginValidator)

接口分层结构

  • com.trs.webframework.controler.servlet.ILoginValidator


软件包 com.trs.webframework.controler.servlet 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.controler.servlet
的使用

使用 com.trs.webframework.controler.servlet 的软件包
com.trs.components.infoview.filter
com.trs.webframework.controler
com.trs.webframework.controler.servlet

com.trs.components.infoview.filter 使用的 com.trs.webframework.controler.servlet 中的类
ServiceControler

com.trs.webframework.controler 使用的 com.trs.webframework.controler.servlet 中的类
BaseValidator

com.trs.webframework.controler.servlet 使用的 com.trs.webframework.controler.servlet 中的类
BaseValidator
ILoginValidator

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RequestParmasValidator

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 RequestParmasValidator

java.lang.Object
    继承者  com.trs.webframework.controler.servlet.BaseValidator
        继承者  com.trs.webframework.controler.servlet.RequestParmasValidator

public class RequestParmasValidator
extends BaseValidator

字段摘要
从类 com.trs.webframework.controler.servlet.BaseValidator 继承的字段
PARAM_NAME_ORDER_FIELD, PARAM_NAME_ORDER_TYPE, PARAM_NAME_SEARCH_KEY, PARAM_NAME_SEARCH_TABLE, PARAM_NAME_SEARCH_VALUE
构造方法摘要
RequestParmasValidator(ServiceContext _requestContext, MethodConfig methoConfig)
方法摘要
 MethodContext getMethodContext()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RequestParmasValidator

public RequestParmasValidator(ServiceContext _requestContext,
                              MethodConfig methoConfig)
方法详细信息

getMethodContext

public MethodContext getMethodContext()
覆盖：
类 BaseValidator 中的 getMethodContext
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceControler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 ServiceControler

java.lang.Object
    继承者  javax.servlet.GenericServlet
        继承者  javax.servlet.http.HttpServlet
            继承者  com.trs.webframework.controler.servlet.ServiceControler
所有已实现的接口：
java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig
直接已知子类：
InfoviewDataImportFilter
public class ServiceControler
extends javax.servlet.http.HttpServlet

另请参见：
序列化表格

构造方法摘要
ServiceControler()
方法摘要
从类 javax.servlet.http.HttpServlet 继承的方法
service
从类 javax.servlet.GenericServlet 继承的方法
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, init, log, log
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceControler

public ServiceControler()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLParamsValidator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.controler.servlet
类 XMLParamsValidator

java.lang.Object
    继承者  com.trs.webframework.controler.servlet.BaseValidator
        继承者  com.trs.webframework.controler.servlet.XMLParamsValidator

public class XMLParamsValidator
extends BaseValidator

字段摘要
从类 com.trs.webframework.controler.servlet.BaseValidator 继承的字段
PARAM_NAME_ORDER_FIELD, PARAM_NAME_ORDER_TYPE, PARAM_NAME_SEARCH_KEY, PARAM_NAME_SEARCH_TABLE, PARAM_NAME_SEARCH_VALUE
构造方法摘要
XMLParamsValidator(java.util.Map _hParmasMap, MethodConfig methoConfig)
方法摘要
 MethodContext getMethodContext()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLParamsValidator

public XMLParamsValidator(java.util.Map _hParmasMap,
                          MethodConfig methoConfig)
方法详细信息

getMethodContext

public MethodContext getMethodContext()
覆盖：
类 BaseValidator 中的 getMethodContext
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.controler.servlet.BaseValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.BaseValidator
的使用

使用 BaseValidator 的软件包
com.trs.webframework.controler
com.trs.webframework.controler.servlet

com.trs.webframework.controler 中 BaseValidator 的使用

com.trs.webframework.controler 中 BaseValidator 的子类
 class JSPRequestParmasValidator

com.trs.webframework.controler.servlet 中 BaseValidator 的使用

com.trs.webframework.controler.servlet 中 BaseValidator 的子类
class | RequestParmasValidator
class | XMLParamsValidator

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.servlet.FileUploader 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.FileUploader
的使用

没有 com.trs.webframework.controler.servlet.FileUploader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.controler.servlet.ILoginValidator 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.controler.servlet.ILoginValidator
的使用

使用 ILoginValidator 的软件包
com.trs.webframework.controler.servlet

com.trs.webframework.controler.servlet 中 ILoginValidator 的使用

实现 ILoginValidator 的 com.trs.webframework.controler.servlet 中的类
class | LoginValidatorDefaultImpl
class | LoginValidatorThreadLocalImpl

返回 ILoginValidator 的 com.trs.webframework.controler.servlet 中的方法
static ILoginValidator LoginValidatorFactory.createLoginValidator()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.servlet.LoginValidatorDefaultImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.LoginValidatorDefaultImpl
的使用

没有 com.trs.webframework.controler.servlet.LoginValidatorDefaultImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.servlet.LoginValidatorFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.LoginValidatorFactory
的使用

没有 com.trs.webframework.controler.servlet.LoginValidatorFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.servlet.LoginValidatorThreadLocalImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.LoginValidatorThreadLocalImpl
的使用

没有 com.trs.webframework.controler.servlet.LoginValidatorThreadLocalImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.servlet.NoLoginServiceControler 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.NoLoginServiceControler
的使用

没有 com.trs.webframework.controler.servlet.NoLoginServiceControler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.servlet.RequestParmasValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.RequestParmasValidator
的使用

没有 com.trs.webframework.controler.servlet.RequestParmasValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.servlet.ServiceControler 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.ServiceControler
的使用

使用 ServiceControler 的软件包
com.trs.components.infoview.filter

com.trs.components.infoview.filter 中 ServiceControler 的使用

com.trs.components.infoview.filter 中 ServiceControler 的子类
 class InfoviewDataImportFilter
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.controler.servlet.XMLParamsValidator 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.controler.servlet.XMLParamsValidator
的使用

没有 com.trs.webframework.controler.servlet.XMLParamsValidator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.webframework.demo
类
StdDemoProviderImpl


com.trs.webframework.demo

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.demo

类摘要
StdDemoProviderImpl Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.webframework.demo 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.demo 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.demo.StdDemoProviderImpl (implements com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider)


软件包 com.trs.webframework.demo 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.demo
的使用

没有 com.trs.webframework.demo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


StdDemoProviderImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.demo
类 StdDemoProviderImpl

java.lang.Object
    继承者  com.trs.webframework.demo.StdDemoProviderImpl
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IQueryServiceProvider, ISaveServiceProvider, IServiceProvider
public class StdDemoProviderImpl
extends java.lang.Object
implements ISaveServiceProvider, IQueryServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IDeleteServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
StdDemoProviderImpl()
方法摘要
void | delete(MethodContext _context)
java.lang.Object | findById(MethodContext _context)
java.lang.Object | findByIds(MethodContext _context)
java.lang.Object | query(MethodContext _context)
int | save(MethodContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StdDemoProviderImpl

public StdDemoProviderImpl()
方法详细信息

save

public int save(MethodContext _context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable

delete

public void delete(MethodContext _context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.demo.StdDemoProviderImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.demo.StdDemoProviderImpl
的使用

没有 com.trs.webframework.demo.StdDemoProviderImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.webframework.entity
类
RedirectObject
VOIDObject


com.trs.webframework.entity

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.entity

类摘要
RedirectObject | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
VOIDObject | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.webframework.entity 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.entity 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.entity.RedirectObject
    • com.trs.webframework.entity.VOIDObject


软件包 com.trs.webframework.entity 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.entity
的使用

没有 com.trs.webframework.entity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RedirectObject

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.entity
类 RedirectObject

java.lang.Object
    继承者  com.trs.webframework.entity.RedirectObject

public class RedirectObject
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RedirectObject()
RedirectObject(java.lang.String _sUri, java.lang.String _sUrl)
方法摘要
java.lang.String | getTarget()
boolean | isWithinDomain()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RedirectObject

public RedirectObject()

RedirectObject

public RedirectObject(java.lang.String _sUri,
                      java.lang.String _sUrl)
方法详细信息

getTarget

public java.lang.String getTarget()

isWithinDomain

public boolean isWithinDomain()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


VOIDObject

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.entity
类 VOIDObject

java.lang.Object
    继承者  com.trs.webframework.entity.VOIDObject

public class VOIDObject
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
VOIDObject()
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VOIDObject

public VOIDObject()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.entity.RedirectObject 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.entity.RedirectObject
的使用

没有 com.trs.webframework.entity.RedirectObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.entity.VOIDObject 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.entity.VOIDObject
的使用

没有 com.trs.webframework.entity.VOIDObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


NoSuchServiceException

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.exception
类 NoSuchServiceException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.webframework.exception.ServiceInvocationException
                    继承者  com.trs.webframework.exception.NoSuchServiceException
所有已实现的接口：
java.io.Serializable
public class NoSuchServiceException
extends ServiceInvocationException

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

字段摘要
从类 com.trs.webframework.exception.ServiceInvocationException 继承的字段
ERROR_CODE_DEFAULT, SUGGESTION_DEFAULT
构造方法摘要
NoSuchServiceException()
NoSuchServiceException(java.lang.String message)
NoSuchServiceException(java.lang.String message, java.lang.Throwable cause)
NoSuchServiceException(java.lang.Throwable cause)
方法摘要
从类 com.trs.webframework.exception.ServiceInvocationException 继承的方法
getErrorCode, getSuggestion, printStackTrace, printStackTrace, setErrorCode, setSuggestion
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchServiceException

public NoSuchServiceException()

NoSuchServiceException

public NoSuchServiceException(java.lang.String message)

NoSuchServiceException

public NoSuchServiceException(java.lang.Throwable cause)

NoSuchServiceException

public NoSuchServiceException(java.lang.String message,
                              java.lang.Throwable cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.exception
异常
NoSuchServiceException
ServiceCreationFailException
ServiceInvocationException


com.trs.webframework.exception

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.exception

异常摘要
NoSuchServiceException | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceCreationFailException | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceInvocationException |


com.trs.webframework.exception 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.exception 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.trs.webframework.exception.ServiceInvocationException
            • com.trs.webframework.exception.NoSuchServiceException
            • com.trs.webframework.exception.ServiceCreationFailException


软件包 com.trs.webframework.exception 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.exception
的使用

使用 com.trs.webframework.exception 的软件包
com.trs.webframework.exception
com.trs.webframework.xmlserver.server

com.trs.webframework.exception 使用的 com.trs.webframework.exception 中的类
ServiceInvocationException

com.trs.webframework.xmlserver.server 使用的 com.trs.webframework.exception 中的类
ServiceInvocationException

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ServiceCreationFailException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.exception
类 ServiceCreationFailException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.webframework.exception.ServiceInvocationException
                    继承者  com.trs.webframework.exception.ServiceCreationFailException
所有已实现的接口：
java.io.Serializable
public class ServiceCreationFailException
extends ServiceInvocationException

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

字段摘要
从类 com.trs.webframework.exception.ServiceInvocationException 继承的字段
ERROR_CODE_DEFAULT, SUGGESTION_DEFAULT
构造方法摘要
ServiceCreationFailException()
ServiceCreationFailException(java.lang.String message)
ServiceCreationFailException(java.lang.String message, java.lang.Throwable cause)
ServiceCreationFailException(java.lang.Throwable cause)
方法摘要
从类 com.trs.webframework.exception.ServiceInvocationException 继承的方法
getErrorCode, getSuggestion, printStackTrace, printStackTrace, setErrorCode, setSuggestion
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServiceCreationFailException

public ServiceCreationFailException()

ServiceCreationFailException

public ServiceCreationFailException(java.lang.String message)

ServiceCreationFailException

public ServiceCreationFailException(java.lang.Throwable cause)

ServiceCreationFailException

public ServiceCreationFailException(java.lang.String message,
                                    java.lang.Throwable cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceInvocationException

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.exception
类 ServiceInvocationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.webframework.exception.ServiceInvocationException
所有已实现的接口：
java.io.Serializable
直接已知子类：
NoSuchServiceException, RequestParmasParseException, ServiceCreationFailException
public class ServiceInvocationException
extends java.lang.RuntimeException

另请参见：
序列化表格

字段摘要
static java.lang.String | ERROR_CODE_DEFAULT
static java.lang.String | SUGGESTION_DEFAULT
构造方法摘要
ServiceInvocationException()
ServiceInvocationException(java.lang.String message)
ServiceInvocationException(java.lang.String message, java.lang.Throwable cause)
ServiceInvocationException(java.lang.String message, java.lang.Throwable cause, java.lang.String suggestion)
ServiceInvocationException(java.lang.Throwable cause)
方法摘要
java.lang.String | getErrorCode()
java.lang.String | getSuggestion()
void | printStackTrace(java.io.PrintStream _ps) 向指定设备打印错误信息
void | printStackTrace(java.io.PrintWriter _pw) 向指定设备打印错误信息
void | setErrorCode(java.lang.String errorCode)
void | setSuggestion(java.lang.String suggestion)
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ERROR_CODE_DEFAULT

public static final java.lang.String ERROR_CODE_DEFAULT
另请参见：
常量字段值

SUGGESTION_DEFAULT

public static final java.lang.String SUGGESTION_DEFAULT
另请参见：
常量字段值
构造方法详细信息

ServiceInvocationException

public ServiceInvocationException()

ServiceInvocationException

public ServiceInvocationException(java.lang.String message)

ServiceInvocationException

public ServiceInvocationException(java.lang.Throwable cause)

ServiceInvocationException

public ServiceInvocationException(java.lang.String message,
                                  java.lang.Throwable cause)

ServiceInvocationException

public ServiceInvocationException(java.lang.String message,
                                  java.lang.Throwable cause,
                                  java.lang.String suggestion)
方法详细信息

getErrorCode

public java.lang.String getErrorCode()

setErrorCode

public void setErrorCode(java.lang.String errorCode)

getSuggestion

public java.lang.String getSuggestion()

setSuggestion

public void setSuggestion(java.lang.String suggestion)

printStackTrace

public void printStackTrace(java.io.PrintStream _ps)
向指定设备打印错误信息

覆盖：
类 java.lang.Throwable 中的 printStackTrace
参数：
_ps - 指定设备java.io.PrintStream对象

printStackTrace

public void printStackTrace(java.io.PrintWriter _pw)
向指定设备打印错误信息

覆盖：
类 java.lang.Throwable 中的 printStackTrace
参数：
_pw - 指定设备java.io.PrintWriter对象
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.exception.NoSuchServiceException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.exception.NoSuchServiceException
的使用

没有 com.trs.webframework.exception.NoSuchServiceException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.exception.ServiceCreationFailException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.exception.ServiceCreationFailException
的使用

没有 com.trs.webframework.exception.ServiceCreationFailException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.exception.ServiceInvocationException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.exception.ServiceInvocationException
的使用

使用 ServiceInvocationException 的软件包
com.trs.webframework.exception
com.trs.webframework.xmlserver.server

com.trs.webframework.exception 中 ServiceInvocationException 的使用

com.trs.webframework.exception 中 ServiceInvocationException 的子类
class | NoSuchServiceException Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ServiceCreationFailException Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.xmlserver.server 中 ServiceInvocationException 的使用

com.trs.webframework.xmlserver.server 中 ServiceInvocationException 的子类
 class RequestParmasParseException
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 ServiceInvocationException 的 com.trs.webframework.xmlserver.server 中的方法
 void XMLDataProcessingHandler.stopOnParsingError(ServiceInvocationException ex)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BaseServiceDecorator

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
类 BaseServiceDecorator

java.lang.Object
    继承者  com.trs.webframework.provider.BaseServiceDecorator
所有已实现的接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
public abstract class BaseServiceDecorator
extends java.lang.Object
implements IGlueServiceProvider

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BaseServiceDecorator()
BaseServiceDecorator(IServiceProvider _serviceProvider)
方法摘要
void | decorate(ServiceContext _serviceContext)
void | delete(MethodContext _context)
java.lang.Object | findById(MethodContext _context)
java.lang.Object | findByIds(MethodContext _context)
java.lang.Object | query(MethodContext _context)
int | save(MethodContext _context)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BaseServiceDecorator

public BaseServiceDecorator()

BaseServiceDecorator

public BaseServiceDecorator(IServiceProvider _serviceProvider)
方法详细信息

decorate

public void decorate(ServiceContext _serviceContext)

delete

public void delete(MethodContext _context)
            throws java.lang.Throwable
指定者：
接口 IDeleteServiceProvider 中的 delete
抛出：
java.lang.Throwable

save

public int save(MethodContext _context)
         throws java.lang.Throwable
指定者：
接口 ISaveServiceProvider 中的 save
抛出：
java.lang.Throwable

findById

public java.lang.Object findById(MethodContext _context)
                          throws java.lang.Throwable
指定者：
接口 IFindByIdServiceProvider 中的 findById
抛出：
java.lang.Throwable

query

public java.lang.Object query(MethodContext _context)
                       throws java.lang.Throwable
指定者：
接口 IQueryServiceProvider 中的 query
抛出：
java.lang.Throwable

findByIds

public java.lang.Object findByIds(MethodContext _context)
                           throws java.lang.Throwable
指定者：
接口 IFindByIdsServiceProvider 中的 findByIds
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DefautlServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
类 DefautlServiceProvider

java.lang.Object
    继承者  com.trs.webframework.provider.DefautlServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class DefautlServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
默认服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
DefautlServiceProvider()
方法摘要
 void forword(MethodContext _methodContext)
空方法，不做任何实现，做转发使用
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefautlServiceProvider

public DefautlServiceProvider()
方法详细信息

forword

public void forword(MethodContext _methodContext)
空方法，不做任何实现，做转发使用

参数：
_methodContext -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDeleteServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 IDeleteServiceProvider

所有超级接口：
IServiceProvider
所有已知子接口：
IContentStyleServiceProvider, IGlueServiceProvider, ILayoutServiceProvider, IMasterServiceProvider, IPageStyleServiceProvider, IResourceStyleServiceProvider, ISpecialServiceProvider, IVisualTemplateServiceProvider, IWidgetParameterServiceProvider, IWidgetServiceProvider
所有已知实现类：
BaseServiceDecorator, BonusRuleServiceProvider, CellServiceProvider, ChannelServiceProvider, ChnlDocServiceProvider, ContentLinkServiceProvider, ContentStyleServiceProvider, DistributeServiceProvider, DocumentBakServiceProvider, DocumentServiceProvider, DocumentSynServiceProvider, ExtendFieldServiceProvider, GroupServiceProvider, IndividuationServiceProvider, InfoviewService, LayoutServiceProvider, MasterServiceProvider, MessageServiceProvider, ObjectMemberServiceProvider, PageStyleServiceProvider, PhotoServiceProvider, ProcessService, RegionEmployServiceProvider, RegionServiceProvider, ReplaceContentServiceProvider, ResourceStyleServiceProvider, RoleServiceProvider, SourceServiceProvider, SpecialServiceProvider, StatusServiceProvider, StdDemoProviderImpl, TemplateServiceHelperProvider, TemplateServiceProvider, UserLoginInfoServiceProvider, UserServiceProvider, ViewDocumentServiceProvider, VisualTemplateServiceProvider, WatermarkServiceProvider, WebSiteServiceProvider, WidgetParameterServiceProvider, WidgetServiceProvider
public interface IDeleteServiceProvider
extends IServiceProvider

方法摘要
 void delete(MethodContext _methodContext)

方法详细信息

delete

void delete(MethodContext _methodContext)
            throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFindByIdServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 IFindByIdServiceProvider

所有超级接口：
IServiceProvider
所有已知子接口：
IContentStyleServiceProvider, IGlueServiceProvider, ILayoutServiceProvider, IMasterServiceProvider, IPageStyleServiceProvider, IResourceStyleServiceProvider, ISpecialServiceProvider, IVisualTemplateServiceProvider, IWidgetParameterServiceProvider, IWidgetServiceProvider
所有已知实现类：
BaseServiceDecorator, BonusRuleServiceProvider, CellServiceProvider, ChannelServiceProvider, ClassInfoServiceProvider, ClassInfoServiceProviderForGB, ContentLinkServiceProvider, ContentStyleServiceProvider, DistributeServiceProvider, DocumentBakServiceProvider, DocumentServiceProvider, DocumentSynServiceProvider, ExtendFieldServiceProvider, GroupServiceProvider, IndividuationServiceProvider, InfoViewDocumentServiceProvider, InfoviewService, LayoutServiceProvider, MasterServiceProvider, MessageServiceProvider, ObjectMemberServiceProvider, PageStyleServiceProvider, PhotoServiceProvider, ProcessService, RegionEmployServiceProvider, RegionServiceProvider, ReplaceContentServiceProvider, ResourceStyleServiceProvider, RoleServiceProvider, SourceServiceProvider, SpecialServiceProvider, StatusServiceProvider, StdDemoProviderImpl, TemplateServiceHelperProvider, TemplateServiceProvider, UserLoginInfoServiceProvider, UserServiceProvider, ViewDocumentServiceProvider, VisualTemplateServiceProvider, WatermarkServiceProvider, WebSiteServiceProvider, WidgetParameterServiceProvider, WidgetServiceProvider
public interface IFindByIdServiceProvider
extends IServiceProvider

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 java.lang.Object findById(MethodContext _methodContext)

方法详细信息

findById

java.lang.Object findById(MethodContext _methodContext)
                          throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IFindByIdsServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 IFindByIdsServiceProvider

所有超级接口：
IServiceProvider
所有已知子接口：
IContentStyleServiceProvider, IGlueServiceProvider, ILayoutServiceProvider, IMasterServiceProvider, IPageStyleServiceProvider, IResourceStyleServiceProvider, ISpecialServiceProvider, IVisualTemplateServiceProvider, IWidgetParameterServiceProvider, IWidgetServiceProvider
所有已知实现类：
BaseServiceDecorator, BonusRuleServiceProvider, CellServiceProvider, ChannelServiceProvider, ContentLinkServiceProvider, ContentStyleServiceProvider, DistributeServiceProvider, DocumentBakServiceProvider, DocumentServiceProvider, DocumentSynServiceProvider, ExtendFieldServiceProvider, GroupServiceProvider, IndividuationServiceProvider, InfoviewService, LayoutServiceProvider, MasterServiceProvider, MessageServiceProvider, ObjectMemberServiceProvider, PageStyleServiceProvider, PhotoServiceProvider, ProcessService, RegionEmployServiceProvider, RegionServiceProvider, ReplaceContentServiceProvider, ResourceStyleServiceProvider, RoleServiceProvider, SourceServiceProvider, SpecialServiceProvider, StatusServiceProvider, StdDemoProviderImpl, TemplateServiceHelperProvider, TemplateServiceProvider, UserLoginInfoServiceProvider, UserServiceProvider, VisualTemplateServiceProvider, WatermarkServiceProvider, WebSiteServiceProvider, WidgetParameterServiceProvider, WidgetServiceProvider
public interface IFindByIdsServiceProvider
extends IServiceProvider

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 java.lang.Object findByIds(MethodContext _methodContext)

方法详细信息

findByIds

java.lang.Object findByIds(MethodContext _methodContext)
                           throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IGlueServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 IGlueServiceProvider

所有超级接口：
IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IServiceProvider
所有已知子接口：
IContentStyleServiceProvider, ILayoutServiceProvider, IMasterServiceProvider, IPageStyleServiceProvider, IResourceStyleServiceProvider, ISpecialServiceProvider, IVisualTemplateServiceProvider, IWidgetParameterServiceProvider, IWidgetServiceProvider
所有已知实现类：
BaseServiceDecorator, BonusRuleServiceProvider, CellServiceProvider, ChannelServiceProvider, ContentLinkServiceProvider, ContentStyleServiceProvider, DistributeServiceProvider, DocumentBakServiceProvider, DocumentServiceProvider, DocumentSynServiceProvider, ExtendFieldServiceProvider, GroupServiceProvider, IndividuationServiceProvider, InfoviewService, LayoutServiceProvider, MasterServiceProvider, MessageServiceProvider, ObjectMemberServiceProvider, PageStyleServiceProvider, PhotoServiceProvider, ProcessService, RegionEmployServiceProvider, RegionServiceProvider, ReplaceContentServiceProvider, ResourceStyleServiceProvider, RoleServiceProvider, SourceServiceProvider, SpecialServiceProvider, StatusServiceProvider, TemplateServiceHelperProvider, TemplateServiceProvider, UserLoginInfoServiceProvider, UserServiceProvider, VisualTemplateServiceProvider, WatermarkServiceProvider, WebSiteServiceProvider, WidgetParameterServiceProvider, WidgetServiceProvider
public interface IGlueServiceProvider
extends IDeleteServiceProvider, IQueryServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider

方法摘要
从接口 com.trs.webframework.provider.IDeleteServiceProvider 继承的方法
delete
从接口 com.trs.webframework.provider.IQueryServiceProvider 继承的方法
query
从接口 com.trs.webframework.provider.ISaveServiceProvider 继承的方法
save
从接口 com.trs.webframework.provider.IFindByIdServiceProvider 继承的方法
findById
从接口 com.trs.webframework.provider.IFindByIdsServiceProvider 继承的方法
findByIds

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IQueryServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 IQueryServiceProvider

所有超级接口：
IServiceProvider
所有已知子接口：
IContentStyleServiceProvider, IGlueServiceProvider, ILayoutServiceProvider, IMasterServiceProvider, IPageStyleServiceProvider, IResourceStyleServiceProvider, ISpecialServiceProvider, IVisualTemplateServiceProvider, IWidgetParameterServiceProvider, IWidgetServiceProvider
所有已知实现类：
BaseServiceDecorator, BonusRuleServiceProvider, CellServiceProvider, ChannelServiceProvider, ContentLinkServiceProvider, ContentStyleServiceProvider, DistributeServiceProvider, DocumentBakServiceProvider, DocumentServiceProvider, DocumentSynServiceProvider, ExtendFieldServiceProvider, GroupServiceProvider, IndividuationServiceProvider, InfoViewDocumentServiceProvider, InfoviewService, LayoutServiceProvider, MasterServiceProvider, MessageServiceProvider, ObjectMemberServiceProvider, PageStyleServiceProvider, PhotoServiceProvider, ProcessService, RegionEmployServiceProvider, RegionServiceProvider, ReplaceContentServiceProvider, ResourceStyleServiceProvider, RoleServiceProvider, SourceServiceProvider, SpecialServiceProvider, StatusServiceProvider, StdDemoProviderImpl, TemplateServiceHelperProvider, TemplateServiceProvider, UserLoginInfoServiceProvider, UserServiceProvider, ViewDocumentServiceProvider, VisualTemplateServiceProvider, WatermarkServiceProvider, WebSiteServiceProvider, WidgetParameterServiceProvider, WidgetServiceProvider
public interface IQueryServiceProvider
extends IServiceProvider

方法摘要
 java.lang.Object query(MethodContext _methodContext)

方法详细信息

query

java.lang.Object query(MethodContext _methodContext)
                       throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ISaveServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 ISaveServiceProvider

所有超级接口：
IServiceProvider
所有已知子接口：
IContentStyleServiceProvider, IGlueServiceProvider, ILayoutServiceProvider, IMasterServiceProvider, IPageStyleServiceProvider, IResourceStyleServiceProvider, ISpecialServiceProvider, IVisualTemplateServiceProvider, IWidgetParameterServiceProvider, IWidgetServiceProvider
所有已知实现类：
BaseServiceDecorator, BonusRuleServiceProvider, CellServiceProvider, ChannelServiceProvider, ContentLinkServiceProvider, ContentStyleServiceProvider, DistributeServiceProvider, DocumentBakServiceProvider, DocumentServiceProvider, DocumentSynServiceProvider, ExtendFieldServiceProvider, GroupServiceProvider, IndividuationServiceProvider, InfoviewService, LayoutServiceProvider, MasterServiceProvider, MessageServiceProvider, NewChannelServiceProvider, ObjectMemberServiceProvider, PageStyleServiceProvider, PhotoServiceProvider, ProcessService, RegionEmployServiceProvider, RegionServiceProvider, ReplaceContentServiceProvider, ResourceStyleServiceProvider, RoleServiceProvider, SourceServiceProvider, SpecialServiceProvider, StatusServiceProvider, StdDemoProviderImpl, TemplateServiceHelperProvider, TemplateServiceProvider, UserLoginInfoServiceProvider, UserServiceProvider, VisualTemplateServiceProvider, WatermarkServiceProvider, WebSiteServiceProvider, WidgetParameterServiceProvider, WidgetServiceProvider
public interface ISaveServiceProvider
extends IServiceProvider

方法摘要
 int save(MethodContext _methodContext)

方法详细信息

save

int save(MethodContext _methodContext)
         throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ISelfDefinedServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 ISelfDefinedServiceProvider

所有超级接口：
IServiceProvider
所有已知子接口：
IContentStyleServiceProvider, IGlueServiceProvider, ILayoutServiceProvider, IMasterServiceProvider, IPageStyleServiceProvider, IResourceStyleServiceProvider, ISpecialServiceProvider, IVisualTemplateServiceProvider, IWidgetParameterServiceProvider, IWidgetServiceProvider
所有已知实现类：
ApplyFormServiceProvider, AuthServiceProvider, BaseServiceDecorator, BonusRuleServiceProvider, CellServiceProvider, ChannelServiceProvider, ChnlDocServiceProvider, ClassInfoPublishServiceProvider, ClassInfoServiceProvider, ClassInfoServiceProviderForGB, ClassInfoViewServiceProvider, ContentLinkServiceProvider, ContentStyleServiceProvider, DefautlServiceProvider, DistributeServiceProvider, DocumentBakServiceProvider, DocumentServiceProvider, DocumentSynServiceProvider, EPressServiceProvider, ExtendFieldServiceProvider, FlowingDocQueryService, GovInfoServiceProvider, GroupServiceProvider, IndividuationServiceProvider, InfoviewDataToolService, InfoViewDocumentServiceProvider, InfoviewService, LayoutServiceProvider, LogServiceProvider, MasterServiceProvider, MessageServiceProvider, MetaDataCenterServiceProvider, MetaDataCenterServiceProviderForAgri, MetaDataCenterServiceProviderForGB, MetaDataCenterServiceProviderForZJH, MetaDataDefServiceProvider, NewChannelServiceProvider, ObjectMemberServiceProvider, PageStyleServiceProvider, PhotoServiceProvider, PreviewChannelServiceProvider, ProcessService, PublishServiceProvider, RegionEmployServiceProvider, RegionServiceProvider, ReplaceContentServiceProvider, ResourceStyleServiceProvider, RoleServiceProvider, SceneServiceProvider, SourceServiceProvider, SpecialServiceProvider, StatusServiceProvider, StyleItemServiceProvider, SystemServiceProvider, TemplateServiceHelperProvider, TemplateServiceProvider, UserLoginInfoServiceProvider, UserServiceProvider, ViewDocumentServiceProvider, VisualTemplateServiceProvider, WatermarkServiceProvider, WebSiteServiceProvider, WidgetParameterServiceProvider, WidgetServiceProvider
public interface ISelfDefinedServiceProvider
extends IServiceProvider

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IServiceFilter

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 IServiceFilter

所有已知实现类：
ServiceFilterExample
public interface IServiceFilter

方法摘要
 boolean doFilter(ServiceFilterConfig _oFilterConfig, MethodContext _oMethodContext)
* 在执行服务之前，在这个方法中可以： 1、根据当前上下文参数，判断操作是否可以继续 2、如果不能继续，也可以通过MethodContext获取当前Servlet上下文参数，做重定向 3、也能够修改MethodContext

方法详细信息

doFilter

boolean doFilter(ServiceFilterConfig _oFilterConfig,
                 MethodContext _oMethodContext)
                 throws WCMException
* 在执行服务之前，在这个方法中可以： 1、根据当前上下文参数，判断操作是否可以继续 2、如果不能继续，也可以通过MethodContext获取当前Servlet上下文参数，做重定向 3、也能够修改MethodContext

参数：
_oFilterConfig - 当前Filter的配置对象
_oMethodContext - 当前的上下文参数
返回：
如果允许继续执行服务，返回true；否则返回false
抛出：
WCMException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IServiceListener

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 IServiceListener

所有已知实现类：
CellsSaveListenerForPublish, ChannelCreateFromListenerForMetaView, DocumentMoveListenerForDocSiteRecode, MoveChannelListenerForChannel, PublishListenerForPubGovInfo, SaveMembersListenerForObjectMember, ServiceListenerExample, TemplateSaveListenerForRegionEmploy, ViewDocumentListenerForPubGovInfo
public interface IServiceListener

方法摘要
 void afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

方法详细信息

afterServiceExecuted

void afterServiceExecuted(ServiceListenerConfig _oListenerConfig,
                          MethodContext _oMethodContext,
                          java.lang.Object _oServiceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

参数：
_oListenerConfig - 当前Lisntener的设置对象
_oMethodContext - 执行服务的当前上下文参数
_oServiceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IServiceProvider

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
接口 IServiceProvider

所有已知子接口：
IContentStyleServiceProvider, IDeleteServiceProvider, IFindByIdServiceProvider, IFindByIdsServiceProvider, IGlueServiceProvider, ILayoutServiceProvider, IMasterServiceProvider, IPageStyleServiceProvider, IQueryServiceProvider, IResourceStyleServiceProvider, ISaveServiceProvider, ISelfDefinedServiceProvider, ISpecialServiceProvider, IVisualTemplateServiceProvider, IWidgetParameterServiceProvider, IWidgetServiceProvider
所有已知实现类：
ApplyFormServiceProvider, AuthServiceProvider, BaseServiceDecorator, BonusRuleServiceProvider, CellServiceProvider, ChannelServiceProvider, ChnlDocServiceProvider, ClassInfoPublishServiceProvider, ClassInfoServiceProvider, ClassInfoServiceProviderForGB, ClassInfoViewServiceProvider, ContentLinkServiceProvider, ContentStyleServiceProvider, DefautlServiceProvider, DistributeServiceProvider, DocumentBakServiceProvider, DocumentServiceProvider, DocumentSynServiceProvider, EPressServiceProvider, ExtendFieldServiceProvider, FlowingDocQueryService, GovInfoServiceProvider, GroupServiceProvider, IndividuationServiceProvider, InfoviewDataToolService, InfoViewDocumentServiceProvider, InfoviewService, LayoutServiceProvider, LogServiceProvider, MasterServiceProvider, MessageServiceProvider, MetaDataCenterServiceProvider, MetaDataCenterServiceProviderForAgri, MetaDataCenterServiceProviderForGB, MetaDataCenterServiceProviderForZJH, MetaDataDefServiceProvider, NewChannelServiceProvider, ObjectMemberServiceProvider, PageStyleServiceProvider, PhotoServiceProvider, PreviewChannelServiceProvider, ProcessService, PublishServiceProvider, RegionEmployServiceProvider, RegionServiceProvider, ReplaceContentServiceProvider, ResourceStyleServiceProvider, RoleServiceProvider, SceneServiceProvider, SourceServiceProvider, SpecialServiceProvider, StatusServiceProvider, StdDemoProviderImpl, StyleItemServiceProvider, SystemServiceProvider, TemplateServiceHelperProvider, TemplateServiceProvider, UserLoginInfoServiceProvider, UserServiceProvider, ViewDocumentServiceProvider, VisualTemplateServiceProvider, WatermarkServiceProvider, WebSiteServiceProvider, WidgetParameterServiceProvider, WidgetServiceProvider
public interface IServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.provider
接口
IDeleteServiceProvider
IFindByIdServiceProvider
IFindByIdsServiceProvider
IGlueServiceProvider
IQueryServiceProvider
ISaveServiceProvider
ISelfDefinedServiceProvider
IServiceFilter
IServiceListener
IServiceProvider
类
BaseServiceDecorator
DefautlServiceProvider
ServiceFilterExample
ServiceListenerExample


com.trs.webframework.provider

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.provider

接口摘要
IDeleteServiceProvider |
IFindByIdServiceProvider | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IGlueServiceProvider |
IQueryServiceProvider |
ISaveServiceProvider |
ISelfDefinedServiceProvider |
IServiceFilter |
IServiceListener |
IServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 标志接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
BaseServiceDecorator | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DefautlServiceProvider | Title: TRS 内容协作平台（TRS WCM） Description: 默认服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceFilterExample | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceListenerExample | Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.webframework.provider 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.provider 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.provider.BaseServiceDecorator (implements com.trs.webframework.provider.IGlueServiceProvider)
    • com.trs.webframework.provider.DefautlServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.webframework.provider.ServiceFilterExample (implements com.trs.webframework.provider.IServiceFilter)
    • com.trs.webframework.provider.ServiceListenerExample (implements com.trs.webframework.provider.IServiceListener)

接口分层结构

  • com.trs.webframework.provider.IServiceFilter
  • com.trs.webframework.provider.IServiceListener
  • com.trs.webframework.provider.IServiceProvider
    • com.trs.webframework.provider.IDeleteServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.webframework.provider.IFindByIdServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.webframework.provider.IFindByIdsServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.webframework.provider.IQueryServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.ISaveServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.webframework.provider.ISaveServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISelfDefinedServiceProvider)
    • com.trs.webframework.provider.ISelfDefinedServiceProvider
      • com.trs.webframework.provider.IGlueServiceProvider (并 extends com.trs.webframework.provider.IDeleteServiceProvider, com.trs.webframework.provider.IFindByIdServiceProvider, com.trs.webframework.provider.IFindByIdsServiceProvider, com.trs.webframework.provider.IQueryServiceProvider, com.trs.webframework.provider.ISaveServiceProvider)


软件包 com.trs.webframework.provider 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.provider
的使用

使用 com.trs.webframework.provider 的软件包
com.trs.ajaxservice
com.trs.ajaxservice.listener
com.trs.components.common.publish.widget
com.trs.components.metadata.service
com.trs.components.metadata.service.listener
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.content.domain
com.trs.components.wcm.epress
com.trs.components.wcm.publish.region
com.trs.webframework.config
com.trs.webframework.demo
com.trs.webframework.provider
com.trsothers

com.trs.ajaxservice 使用的 com.trs.webframework.provider 中的类
IDeleteServiceProvider
IFindByIdServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IGlueServiceProvider
IQueryServiceProvider
ISaveServiceProvider
ISelfDefinedServiceProvider
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.ajaxservice.listener 使用的 com.trs.webframework.provider 中的类
IServiceListener

com.trs.components.common.publish.widget 使用的 com.trs.webframework.provider 中的类
IDeleteServiceProvider
IFindByIdServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IGlueServiceProvider
IQueryServiceProvider
ISaveServiceProvider
ISelfDefinedServiceProvider
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service 使用的 com.trs.webframework.provider 中的类
IFindByIdServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ISelfDefinedServiceProvider
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service.listener 使用的 com.trs.webframework.provider 中的类
IServiceListener

com.trs.components.special 使用的 com.trs.webframework.provider 中的类
IDeleteServiceProvider
IFindByIdServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IGlueServiceProvider
IQueryServiceProvider
ISaveServiceProvider
ISelfDefinedServiceProvider
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.stat 使用的 com.trs.webframework.provider 中的类
IDeleteServiceProvider
IFindByIdServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IGlueServiceProvider
IQueryServiceProvider
ISaveServiceProvider
ISelfDefinedServiceProvider
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 使用的 com.trs.webframework.provider 中的类
IServiceListener

com.trs.components.wcm.epress 使用的 com.trs.webframework.provider 中的类
ISelfDefinedServiceProvider
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 使用的 com.trs.webframework.provider 中的类
IDeleteServiceProvider
IFindByIdServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IGlueServiceProvider
IQueryServiceProvider
ISaveServiceProvider
ISelfDefinedServiceProvider
IServiceListener
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.config 使用的 com.trs.webframework.provider 中的类
IServiceFilter
IServiceListener
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.demo 使用的 com.trs.webframework.provider 中的类
IDeleteServiceProvider
IFindByIdServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IQueryServiceProvider
ISaveServiceProvider
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 使用的 com.trs.webframework.provider 中的类
IDeleteServiceProvider
IFindByIdServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IGlueServiceProvider
IQueryServiceProvider
ISaveServiceProvider
ISelfDefinedServiceProvider
IServiceFilter
IServiceListener
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trsothers 使用的 com.trs.webframework.provider 中的类
ISelfDefinedServiceProvider
IServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ServiceFilterExample

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
类 ServiceFilterExample

java.lang.Object
    继承者  com.trs.webframework.provider.ServiceFilterExample
所有已实现的接口：
IServiceFilter
public class ServiceFilterExample
extends java.lang.Object
implements IServiceFilter

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ServiceFilterExample()
方法摘要
 boolean doFilter(ServiceFilterConfig _oFilterConfig, MethodContext _oMethodContext)
* 在执行服务之前，在这个方法中可以： 1、根据当前上下文参数，判断操作是否可以继续 2、如果不能继续，也可以通过MethodContext获取当前Servlet上下文参数，做重定向 3、也能够修改MethodContext
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceFilterExample

public ServiceFilterExample()
方法详细信息

doFilter

public boolean doFilter(ServiceFilterConfig _oFilterConfig,
                        MethodContext _oMethodContext)
从接口 IServiceFilter 复制的描述
* 在执行服务之前，在这个方法中可以： 1、根据当前上下文参数，判断操作是否可以继续 2、如果不能继续，也可以通过MethodContext获取当前Servlet上下文参数，做重定向 3、也能够修改MethodContext

指定者：
接口 IServiceFilter 中的 doFilter
参数：
_oFilterConfig - 当前Filter的配置对象
_oMethodContext - 当前的上下文参数
返回：
如果允许继续执行服务，返回true；否则返回false
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceListenerExample

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.provider
类 ServiceListenerExample

java.lang.Object
    继承者  com.trs.webframework.provider.ServiceListenerExample
所有已实现的接口：
IServiceListener
public class ServiceListenerExample
extends java.lang.Object
implements IServiceListener

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
ServiceListenerExample()
方法摘要
 void afterServiceExecuted(ServiceListenerConfig _oListenerConfig, MethodContext _oMethodContext, java.lang.Object _oServiceResult)
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceListenerExample

public ServiceListenerExample()
方法详细信息

afterServiceExecuted

public void afterServiceExecuted(ServiceListenerConfig _oListenerConfig,
                                 MethodContext _oMethodContext,
                                 java.lang.Object _oServiceResult)
从接口 IServiceListener 复制的描述
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值

指定者：
接口 IServiceListener 中的 afterServiceExecuted
参数：
_oListenerConfig - 当前Lisntener的设置对象
_oMethodContext - 执行服务的当前上下文参数
_oServiceResult - 执行服务后的返回值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.provider.BaseServiceDecorator 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.provider.BaseServiceDecorator
的使用

没有 com.trs.webframework.provider.BaseServiceDecorator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.provider.DefautlServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.provider.DefautlServiceProvider
的使用

没有 com.trs.webframework.provider.DefautlServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.IDeleteServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.IDeleteServiceProvider
的使用

使用 IDeleteServiceProvider 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.widget
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.publish.region
com.trs.webframework.demo
com.trs.webframework.provider

com.trs.ajaxservice 中 IDeleteServiceProvider 的使用

实现 IDeleteServiceProvider 的 com.trs.ajaxservice 中的类
class | ChannelServiceProvider
class | ChnlDocServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContentLinkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DistributeServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentBakServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSynServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtendFieldServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupServiceProvider
class | IndividuationServiceProvider
class | InfoviewService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectMemberServiceProvider
class | PhotoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ProcessService Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceContentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleServiceProvider
class | SourceServiceProvider
class | StatusServiceProvider
class | TemplateServiceHelperProvider
class | TemplateServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | UserServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WatermarkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IDeleteServiceProvider 的使用

com.trs.components.common.publish.widget 中 IDeleteServiceProvider 的子接口
interface | IContentStyleServiceProvider 内容可用风格服务层接口
interface | ILayoutServiceProvider
interface | IMasterServiceProvider
interface | IPageStyleServiceProvider 风格服务层接口
interface | IResourceStyleServiceProvider 资源可用风格服务层接口
interface | IVisualTemplateServiceProvider
interface | IWidgetParameterServiceProvider
interface | IWidgetServiceProvider

实现 IDeleteServiceProvider 的 com.trs.components.common.publish.widget 中的类
class | ContentStyleServiceProvider 内容可用风格服务层
class | LayoutServiceProvider
class | MasterServiceProvider
class | PageStyleServiceProvider 页面风格服务层
class | ResourceStyleServiceProvider 资源可用风格服务层
class | VisualTemplateServiceProvider
class | WidgetParameterServiceProvider
class | WidgetServiceProvider

com.trs.components.special 中 IDeleteServiceProvider 的使用

com.trs.components.special 中 IDeleteServiceProvider 的子接口
 interface ISpecialServiceProvider

实现 IDeleteServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.stat 中 IDeleteServiceProvider 的使用

实现 IDeleteServiceProvider 的 com.trs.components.stat 中的类
class | BonusRuleServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | UserLoginInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

com.trs.components.wcm.publish.region 中 IDeleteServiceProvider 的使用

实现 IDeleteServiceProvider 的 com.trs.components.wcm.publish.region 中的类
class | CellServiceProvider
class | RegionEmployServiceProvider
class | RegionServiceProvider

com.trs.webframework.demo 中 IDeleteServiceProvider 的使用

实现 IDeleteServiceProvider 的 com.trs.webframework.demo 中的类
 class StdDemoProviderImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 中 IDeleteServiceProvider 的使用

com.trs.webframework.provider 中 IDeleteServiceProvider 的子接口
 interface IGlueServiceProvider

实现 IDeleteServiceProvider 的 com.trs.webframework.provider 中的类
 class BaseServiceDecorator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.IFindByIdServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.IFindByIdServiceProvider
的使用

使用 IFindByIdServiceProvider 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.widget
com.trs.components.metadata.service
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.publish.region
com.trs.webframework.demo
com.trs.webframework.provider

com.trs.ajaxservice 中 IFindByIdServiceProvider 的使用

实现 IFindByIdServiceProvider 的 com.trs.ajaxservice 中的类
class | ChannelServiceProvider
class | ContentLinkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DistributeServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentBakServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSynServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtendFieldServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupServiceProvider
class | IndividuationServiceProvider
class | InfoViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoviewService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectMemberServiceProvider
class | PhotoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ProcessService Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceContentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleServiceProvider
class | SourceServiceProvider
class | StatusServiceProvider
class | TemplateServiceHelperProvider
class | TemplateServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | UserServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WatermarkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IFindByIdServiceProvider 的使用

com.trs.components.common.publish.widget 中 IFindByIdServiceProvider 的子接口
interface | IContentStyleServiceProvider 内容可用风格服务层接口
interface | ILayoutServiceProvider
interface | IMasterServiceProvider
interface | IPageStyleServiceProvider 风格服务层接口
interface | IResourceStyleServiceProvider 资源可用风格服务层接口
interface | IVisualTemplateServiceProvider
interface | IWidgetParameterServiceProvider
interface | IWidgetServiceProvider

实现 IFindByIdServiceProvider 的 com.trs.components.common.publish.widget 中的类
class | ContentStyleServiceProvider 内容可用风格服务层
class | LayoutServiceProvider
class | MasterServiceProvider
class | PageStyleServiceProvider 页面风格服务层
class | ResourceStyleServiceProvider 资源可用风格服务层
class | VisualTemplateServiceProvider
class | WidgetParameterServiceProvider
class | WidgetServiceProvider

com.trs.components.metadata.service 中 IFindByIdServiceProvider 的使用

实现 IFindByIdServiceProvider 的 com.trs.components.metadata.service 中的类
class | ClassInfoServiceProvider
class | ClassInfoServiceProviderForGB

com.trs.components.special 中 IFindByIdServiceProvider 的使用

com.trs.components.special 中 IFindByIdServiceProvider 的子接口
 interface ISpecialServiceProvider

实现 IFindByIdServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.stat 中 IFindByIdServiceProvider 的使用

实现 IFindByIdServiceProvider 的 com.trs.components.stat 中的类
class | BonusRuleServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | UserLoginInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

com.trs.components.wcm.publish.region 中 IFindByIdServiceProvider 的使用

实现 IFindByIdServiceProvider 的 com.trs.components.wcm.publish.region 中的类
class | CellServiceProvider
class | RegionEmployServiceProvider
class | RegionServiceProvider

com.trs.webframework.demo 中 IFindByIdServiceProvider 的使用

实现 IFindByIdServiceProvider 的 com.trs.webframework.demo 中的类
 class StdDemoProviderImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 中 IFindByIdServiceProvider 的使用

com.trs.webframework.provider 中 IFindByIdServiceProvider 的子接口
 interface IGlueServiceProvider

实现 IFindByIdServiceProvider 的 com.trs.webframework.provider 中的类
 class BaseServiceDecorator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.IFindByIdsServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.IFindByIdsServiceProvider
的使用

使用 IFindByIdsServiceProvider 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.widget
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.publish.region
com.trs.webframework.demo
com.trs.webframework.provider

com.trs.ajaxservice 中 IFindByIdsServiceProvider 的使用

实现 IFindByIdsServiceProvider 的 com.trs.ajaxservice 中的类
class | ChannelServiceProvider
class | ContentLinkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DistributeServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentBakServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSynServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtendFieldServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupServiceProvider
class | IndividuationServiceProvider
class | InfoviewService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectMemberServiceProvider
class | PhotoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ProcessService Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceContentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleServiceProvider
class | SourceServiceProvider
class | StatusServiceProvider
class | TemplateServiceHelperProvider
class | TemplateServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | UserServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WatermarkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IFindByIdsServiceProvider 的使用

com.trs.components.common.publish.widget 中 IFindByIdsServiceProvider 的子接口
interface | IContentStyleServiceProvider 内容可用风格服务层接口
interface | ILayoutServiceProvider
interface | IMasterServiceProvider
interface | IPageStyleServiceProvider 风格服务层接口
interface | IResourceStyleServiceProvider 资源可用风格服务层接口
interface | IVisualTemplateServiceProvider
interface | IWidgetParameterServiceProvider
interface | IWidgetServiceProvider

实现 IFindByIdsServiceProvider 的 com.trs.components.common.publish.widget 中的类
class | ContentStyleServiceProvider 内容可用风格服务层
class | LayoutServiceProvider
class | MasterServiceProvider
class | PageStyleServiceProvider 页面风格服务层
class | ResourceStyleServiceProvider 资源可用风格服务层
class | VisualTemplateServiceProvider
class | WidgetParameterServiceProvider
class | WidgetServiceProvider

com.trs.components.special 中 IFindByIdsServiceProvider 的使用

com.trs.components.special 中 IFindByIdsServiceProvider 的子接口
 interface ISpecialServiceProvider

实现 IFindByIdsServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.stat 中 IFindByIdsServiceProvider 的使用

实现 IFindByIdsServiceProvider 的 com.trs.components.stat 中的类
class | BonusRuleServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | UserLoginInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

com.trs.components.wcm.publish.region 中 IFindByIdsServiceProvider 的使用

实现 IFindByIdsServiceProvider 的 com.trs.components.wcm.publish.region 中的类
class | CellServiceProvider
class | RegionEmployServiceProvider
class | RegionServiceProvider

com.trs.webframework.demo 中 IFindByIdsServiceProvider 的使用

实现 IFindByIdsServiceProvider 的 com.trs.webframework.demo 中的类
 class StdDemoProviderImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 中 IFindByIdsServiceProvider 的使用

com.trs.webframework.provider 中 IFindByIdsServiceProvider 的子接口
 interface IGlueServiceProvider

实现 IFindByIdsServiceProvider 的 com.trs.webframework.provider 中的类
 class BaseServiceDecorator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.IGlueServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.IGlueServiceProvider
的使用

使用 IGlueServiceProvider 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.widget
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.publish.region
com.trs.webframework.provider

com.trs.ajaxservice 中 IGlueServiceProvider 的使用

实现 IGlueServiceProvider 的 com.trs.ajaxservice 中的类
class | ChannelServiceProvider
class | ContentLinkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DistributeServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentBakServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSynServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtendFieldServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupServiceProvider
class | IndividuationServiceProvider
class | InfoviewService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectMemberServiceProvider
class | PhotoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ProcessService Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceContentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleServiceProvider
class | SourceServiceProvider
class | StatusServiceProvider
class | TemplateServiceHelperProvider
class | TemplateServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | UserServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WatermarkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IGlueServiceProvider 的使用

com.trs.components.common.publish.widget 中 IGlueServiceProvider 的子接口
interface | IContentStyleServiceProvider 内容可用风格服务层接口
interface | ILayoutServiceProvider
interface | IMasterServiceProvider
interface | IPageStyleServiceProvider 风格服务层接口
interface | IResourceStyleServiceProvider 资源可用风格服务层接口
interface | IVisualTemplateServiceProvider
interface | IWidgetParameterServiceProvider
interface | IWidgetServiceProvider

实现 IGlueServiceProvider 的 com.trs.components.common.publish.widget 中的类
class | ContentStyleServiceProvider 内容可用风格服务层
class | LayoutServiceProvider
class | MasterServiceProvider
class | PageStyleServiceProvider 页面风格服务层
class | ResourceStyleServiceProvider 资源可用风格服务层
class | VisualTemplateServiceProvider
class | WidgetParameterServiceProvider
class | WidgetServiceProvider

com.trs.components.special 中 IGlueServiceProvider 的使用

com.trs.components.special 中 IGlueServiceProvider 的子接口
 interface ISpecialServiceProvider

实现 IGlueServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.stat 中 IGlueServiceProvider 的使用

实现 IGlueServiceProvider 的 com.trs.components.stat 中的类
class | BonusRuleServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | UserLoginInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

com.trs.components.wcm.publish.region 中 IGlueServiceProvider 的使用

实现 IGlueServiceProvider 的 com.trs.components.wcm.publish.region 中的类
class | CellServiceProvider
class | RegionEmployServiceProvider
class | RegionServiceProvider

com.trs.webframework.provider 中 IGlueServiceProvider 的使用

实现 IGlueServiceProvider 的 com.trs.webframework.provider 中的类
 class BaseServiceDecorator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.IQueryServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.IQueryServiceProvider
的使用

使用 IQueryServiceProvider 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.widget
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.publish.region
com.trs.webframework.demo
com.trs.webframework.provider

com.trs.ajaxservice 中 IQueryServiceProvider 的使用

实现 IQueryServiceProvider 的 com.trs.ajaxservice 中的类
class | ChannelServiceProvider
class | ContentLinkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DistributeServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentBakServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSynServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtendFieldServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupServiceProvider
class | IndividuationServiceProvider
class | InfoViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoviewService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ObjectMemberServiceProvider
class | PhotoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ProcessService Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceContentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleServiceProvider
class | SourceServiceProvider
class | StatusServiceProvider
class | TemplateServiceHelperProvider
class | TemplateServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | UserServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WatermarkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IQueryServiceProvider 的使用

com.trs.components.common.publish.widget 中 IQueryServiceProvider 的子接口
interface | IContentStyleServiceProvider 内容可用风格服务层接口
interface | ILayoutServiceProvider
interface | IMasterServiceProvider
interface | IPageStyleServiceProvider 风格服务层接口
interface | IResourceStyleServiceProvider 资源可用风格服务层接口
interface | IVisualTemplateServiceProvider
interface | IWidgetParameterServiceProvider
interface | IWidgetServiceProvider

实现 IQueryServiceProvider 的 com.trs.components.common.publish.widget 中的类
class | ContentStyleServiceProvider 内容可用风格服务层
class | LayoutServiceProvider
class | MasterServiceProvider
class | PageStyleServiceProvider 页面风格服务层
class | ResourceStyleServiceProvider 资源可用风格服务层
class | VisualTemplateServiceProvider
class | WidgetParameterServiceProvider
class | WidgetServiceProvider

com.trs.components.special 中 IQueryServiceProvider 的使用

com.trs.components.special 中 IQueryServiceProvider 的子接口
 interface ISpecialServiceProvider

实现 IQueryServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.stat 中 IQueryServiceProvider 的使用

实现 IQueryServiceProvider 的 com.trs.components.stat 中的类
class | BonusRuleServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | UserLoginInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

com.trs.components.wcm.publish.region 中 IQueryServiceProvider 的使用

实现 IQueryServiceProvider 的 com.trs.components.wcm.publish.region 中的类
class | CellServiceProvider
class | RegionEmployServiceProvider
class | RegionServiceProvider

com.trs.webframework.demo 中 IQueryServiceProvider 的使用

实现 IQueryServiceProvider 的 com.trs.webframework.demo 中的类
 class StdDemoProviderImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 中 IQueryServiceProvider 的使用

com.trs.webframework.provider 中 IQueryServiceProvider 的子接口
 interface IGlueServiceProvider

实现 IQueryServiceProvider 的 com.trs.webframework.provider 中的类
 class BaseServiceDecorator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.ISaveServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.ISaveServiceProvider
的使用

使用 ISaveServiceProvider 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.widget
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.publish.region
com.trs.webframework.demo
com.trs.webframework.provider

com.trs.ajaxservice 中 ISaveServiceProvider 的使用

实现 ISaveServiceProvider 的 com.trs.ajaxservice 中的类
class | ChannelServiceProvider
class | ContentLinkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DistributeServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentBakServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSynServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtendFieldServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupServiceProvider
class | IndividuationServiceProvider
class | InfoviewService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | NewChannelServiceProvider
class | ObjectMemberServiceProvider
class | PhotoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ProcessService Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceContentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleServiceProvider
class | SourceServiceProvider
class | StatusServiceProvider
class | TemplateServiceHelperProvider
class | TemplateServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | UserServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WatermarkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 ISaveServiceProvider 的使用

com.trs.components.common.publish.widget 中 ISaveServiceProvider 的子接口
interface | IContentStyleServiceProvider 内容可用风格服务层接口
interface | ILayoutServiceProvider
interface | IMasterServiceProvider
interface | IPageStyleServiceProvider 风格服务层接口
interface | IResourceStyleServiceProvider 资源可用风格服务层接口
interface | IVisualTemplateServiceProvider
interface | IWidgetParameterServiceProvider
interface | IWidgetServiceProvider

实现 ISaveServiceProvider 的 com.trs.components.common.publish.widget 中的类
class | ContentStyleServiceProvider 内容可用风格服务层
class | LayoutServiceProvider
class | MasterServiceProvider
class | PageStyleServiceProvider 页面风格服务层
class | ResourceStyleServiceProvider 资源可用风格服务层
class | VisualTemplateServiceProvider
class | WidgetParameterServiceProvider
class | WidgetServiceProvider

com.trs.components.special 中 ISaveServiceProvider 的使用

com.trs.components.special 中 ISaveServiceProvider 的子接口
 interface ISpecialServiceProvider

实现 ISaveServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.stat 中 ISaveServiceProvider 的使用

实现 ISaveServiceProvider 的 com.trs.components.stat 中的类
class | BonusRuleServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | UserLoginInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

com.trs.components.wcm.publish.region 中 ISaveServiceProvider 的使用

实现 ISaveServiceProvider 的 com.trs.components.wcm.publish.region 中的类
class | CellServiceProvider
class | RegionEmployServiceProvider
class | RegionServiceProvider

com.trs.webframework.demo 中 ISaveServiceProvider 的使用

实现 ISaveServiceProvider 的 com.trs.webframework.demo 中的类
 class StdDemoProviderImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 中 ISaveServiceProvider 的使用

com.trs.webframework.provider 中 ISaveServiceProvider 的子接口
 interface IGlueServiceProvider

实现 ISaveServiceProvider 的 com.trs.webframework.provider 中的类
 class BaseServiceDecorator
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.ISelfDefinedServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.ISelfDefinedServiceProvider
的使用

使用 ISelfDefinedServiceProvider 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.widget
com.trs.components.metadata.service
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.epress
com.trs.components.wcm.publish.region
com.trs.webframework.provider
com.trsothers

com.trs.ajaxservice 中 ISelfDefinedServiceProvider 的使用

实现 ISelfDefinedServiceProvider 的 com.trs.ajaxservice 中的类
class | ApplyFormServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | AuthServiceProvider
class | ChannelServiceProvider
class | ChnlDocServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContentLinkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DistributeServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentBakServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSynServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtendFieldServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowingDocQueryService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupServiceProvider
class | IndividuationServiceProvider
class | InfoviewDataToolService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoviewService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | NewChannelServiceProvider
class | ObjectMemberServiceProvider
class | PhotoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | PreviewChannelServiceProvider
class | ProcessService Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 发布服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceContentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleServiceProvider
class | SceneServiceProvider
class | SourceServiceProvider
class | StatusServiceProvider
class | SystemServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 系统服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateServiceHelperProvider
class | TemplateServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | UserServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WatermarkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 ISelfDefinedServiceProvider 的使用

com.trs.components.common.publish.widget 中 ISelfDefinedServiceProvider 的子接口
interface | IContentStyleServiceProvider 内容可用风格服务层接口
interface | ILayoutServiceProvider
interface | IMasterServiceProvider
interface | IPageStyleServiceProvider 风格服务层接口
interface | IResourceStyleServiceProvider 资源可用风格服务层接口
interface | IVisualTemplateServiceProvider
interface | IWidgetParameterServiceProvider
interface | IWidgetServiceProvider

实现 ISelfDefinedServiceProvider 的 com.trs.components.common.publish.widget 中的类
class | ContentStyleServiceProvider 内容可用风格服务层
class | LayoutServiceProvider
class | MasterServiceProvider
class | PageStyleServiceProvider 页面风格服务层
class | ResourceStyleServiceProvider 资源可用风格服务层
class | StyleItemServiceProvider 风格项服务
class | VisualTemplateServiceProvider
class | WidgetParameterServiceProvider
class | WidgetServiceProvider

com.trs.components.metadata.service 中 ISelfDefinedServiceProvider 的使用

实现 ISelfDefinedServiceProvider 的 com.trs.components.metadata.service 中的类
class | ClassInfoPublishServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 分类法发布服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ClassInfoServiceProvider
class | ClassInfoServiceProviderForGB
class | ClassInfoViewServiceProvider
class | GovInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataCenterServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataCenterServiceProviderForAgri Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataCenterServiceProviderForGB Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataCenterServiceProviderForZJH Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataDefServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台定义服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.special 中 ISelfDefinedServiceProvider 的使用

com.trs.components.special 中 ISelfDefinedServiceProvider 的子接口
 interface ISpecialServiceProvider

实现 ISelfDefinedServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.stat 中 ISelfDefinedServiceProvider 的使用

实现 ISelfDefinedServiceProvider 的 com.trs.components.stat 中的类
class | BonusRuleServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | UserLoginInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

com.trs.components.wcm.epress 中 ISelfDefinedServiceProvider 的使用

实现 ISelfDefinedServiceProvider 的 com.trs.components.wcm.epress 中的类
 class EPressServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报频道的相关ajax服务提供者
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 中 ISelfDefinedServiceProvider 的使用

实现 ISelfDefinedServiceProvider 的 com.trs.components.wcm.publish.region 中的类
class | CellServiceProvider
class | RegionEmployServiceProvider
class | RegionServiceProvider

com.trs.webframework.provider 中 ISelfDefinedServiceProvider 的使用

com.trs.webframework.provider 中 ISelfDefinedServiceProvider 的子接口
 interface IGlueServiceProvider

实现 ISelfDefinedServiceProvider 的 com.trs.webframework.provider 中的类
class | BaseServiceDecorator Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DefautlServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 默认服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trsothers 中 ISelfDefinedServiceProvider 的使用

实现 ISelfDefinedServiceProvider 的 com.trsothers 中的类
 class LogServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
日志相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.IServiceFilter 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.IServiceFilter
的使用

使用 IServiceFilter 的软件包
com.trs.webframework.config
com.trs.webframework.provider

com.trs.webframework.config 中 IServiceFilter 的使用

返回 IServiceFilter 的 com.trs.webframework.config 中的方法
 IServiceFilter ServiceFilterConfig.getServiceFilter()
获取当前配置的Filter

com.trs.webframework.provider 中 IServiceFilter 的使用

实现 IServiceFilter 的 com.trs.webframework.provider 中的类
 class ServiceFilterExample
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.IServiceListener 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.IServiceListener
的使用

使用 IServiceListener 的软件包
com.trs.ajaxservice.listener
com.trs.components.metadata.service.listener
com.trs.components.wcm.content.domain
com.trs.components.wcm.publish.region
com.trs.webframework.config
com.trs.webframework.provider

com.trs.ajaxservice.listener 中 IServiceListener 的使用

实现 IServiceListener 的 com.trs.ajaxservice.listener 中的类
class | MoveChannelListenerForChannel
class | SaveMembersListenerForObjectMember

com.trs.components.metadata.service.listener 中 IServiceListener 的使用

实现 IServiceListener 的 com.trs.components.metadata.service.listener 中的类
class | ChannelCreateFromListenerForMetaView
class | PublishListenerForPubGovInfo Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ViewDocumentListenerForPubGovInfo Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.content.domain 中 IServiceListener 的使用

实现 IServiceListener 的 com.trs.components.wcm.content.domain 中的类
 class DocumentMoveListenerForDocSiteRecode

com.trs.components.wcm.publish.region 中 IServiceListener 的使用

实现 IServiceListener 的 com.trs.components.wcm.publish.region 中的类
class | CellsSaveListenerForPublish
class | TemplateSaveListenerForRegionEmploy

com.trs.webframework.config 中 IServiceListener 的使用

返回 IServiceListener 的 com.trs.webframework.config 中的方法
 IServiceListener ServiceListenerConfig.getServiceListener()
获取当前配置的Listener

com.trs.webframework.provider 中 IServiceListener 的使用

实现 IServiceListener 的 com.trs.webframework.provider 中的类
 class ServiceListenerExample
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.provider.IServiceProvider 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.provider.IServiceProvider
的使用

使用 IServiceProvider 的软件包
com.trs.ajaxservice
com.trs.components.common.publish.widget
com.trs.components.metadata.service
com.trs.components.special
com.trs.components.stat
com.trs.components.wcm.epress
com.trs.components.wcm.publish.region
com.trs.webframework.config
com.trs.webframework.demo
com.trs.webframework.provider
com.trsothers

com.trs.ajaxservice 中 IServiceProvider 的使用

实现 IServiceProvider 的 com.trs.ajaxservice 中的类
class | ApplyFormServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | AuthServiceProvider
class | ChannelServiceProvider
class | ChnlDocServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContentLinkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 热词相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DistributeServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentBakServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档版本相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 提供文档相关服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentSynServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 文档分发服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtendFieldServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowingDocQueryService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | GroupServiceProvider
class | IndividuationServiceProvider
class | InfoviewDataToolService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoviewService Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 消息中心服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | NewChannelServiceProvider
class | ObjectMemberServiceProvider
class | PhotoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片选件服务 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | PreviewChannelServiceProvider
class | ProcessService Title: TRS 内容协作平台（TRS WCM） Description: 工作流服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PublishServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 发布服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReplaceContentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 替换内容管理器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RoleServiceProvider
class | SceneServiceProvider
class | SourceServiceProvider
class | StatusServiceProvider
class | SystemServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 系统服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateServiceHelperProvider
class | TemplateServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 模板类相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | UserServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ViewDocumentServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: ChnlDoc相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WatermarkServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 图片库水印服务提供者 Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WebSiteServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 站点相关服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.common.publish.widget 中 IServiceProvider 的使用

com.trs.components.common.publish.widget 中 IServiceProvider 的子接口
interface | IContentStyleServiceProvider 内容可用风格服务层接口
interface | ILayoutServiceProvider
interface | IMasterServiceProvider
interface | IPageStyleServiceProvider 风格服务层接口
interface | IResourceStyleServiceProvider 资源可用风格服务层接口
interface | IVisualTemplateServiceProvider
interface | IWidgetParameterServiceProvider
interface | IWidgetServiceProvider

实现 IServiceProvider 的 com.trs.components.common.publish.widget 中的类
class | ContentStyleServiceProvider 内容可用风格服务层
class | LayoutServiceProvider
class | MasterServiceProvider
class | PageStyleServiceProvider 页面风格服务层
class | ResourceStyleServiceProvider 资源可用风格服务层
class | StyleItemServiceProvider 风格项服务
class | VisualTemplateServiceProvider
class | WidgetParameterServiceProvider
class | WidgetServiceProvider

com.trs.components.metadata.service 中 IServiceProvider 的使用

实现 IServiceProvider 的 com.trs.components.metadata.service 中的类
class | ClassInfoPublishServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 分类法发布服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ClassInfoServiceProvider
class | ClassInfoServiceProviderForGB
class | ClassInfoViewServiceProvider
class | GovInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataCenterServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataCenterServiceProviderForAgri Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataCenterServiceProviderForGB Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataCenterServiceProviderForZJH Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台驱动服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MetaDataDefServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 资源加工平台定义服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.special 中 IServiceProvider 的使用

com.trs.components.special 中 IServiceProvider 的子接口
 interface ISpecialServiceProvider

实现 IServiceProvider 的 com.trs.components.special 中的类
 class SpecialServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn

com.trs.components.stat 中 IServiceProvider 的使用

实现 IServiceProvider 的 com.trs.components.stat 中的类
class | BonusRuleServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 奖励规则的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn
class | UserLoginInfoServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 用户登录信息的服务层类 Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司 Company: www.trs.com.cn

com.trs.components.wcm.epress 中 IServiceProvider 的使用

实现 IServiceProvider 的 com.trs.components.wcm.epress 中的类
 class EPressServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报频道的相关ajax服务提供者
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)

com.trs.components.wcm.publish.region 中 IServiceProvider 的使用

实现 IServiceProvider 的 com.trs.components.wcm.publish.region 中的类
class | CellServiceProvider
class | RegionEmployServiceProvider
class | RegionServiceProvider

com.trs.webframework.config 中 IServiceProvider 的使用

返回 IServiceProvider 的 com.trs.webframework.config 中的方法
IServiceProvider | MethodConfig.getProvider()
IServiceProvider | ServiceConfig.getServiceProvider()
static IServiceProvider | ServiceConfigHelper.makeProvider(java.lang.String _sProviderClassName)
static IServiceProvider | ServiceConfigHelper.makeProvider(java.lang.String _sProviderClassName, java.lang.String _sDecoratorClassName)
static IServiceProvider | ServiceConfigHelper.validateProvider(int _nMethodType, IServiceProvider _service)

参数类型为 IServiceProvider 的 com.trs.webframework.config 中的方法
void | MethodConfig.initFrom(org.dom4j.Element _elMethod, IServiceProvider _oDefaultProvider)
static IServiceProvider | ServiceConfigHelper.validateProvider(int _nMethodType, IServiceProvider _service)

com.trs.webframework.demo 中 IServiceProvider 的使用

实现 IServiceProvider 的 com.trs.webframework.demo 中的类
 class StdDemoProviderImpl
Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.provider 中 IServiceProvider 的使用

com.trs.webframework.provider 中 IServiceProvider 的子接口
interface | IDeleteServiceProvider
interface | IFindByIdServiceProvider Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IFindByIdsServiceProvider Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
interface | IGlueServiceProvider
interface | IQueryServiceProvider
interface | ISaveServiceProvider
interface | ISelfDefinedServiceProvider

实现 IServiceProvider 的 com.trs.webframework.provider 中的类
class | BaseServiceDecorator Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DefautlServiceProvider Title: TRS 内容协作平台（TRS WCM） Description: 默认服务提供者 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 IServiceProvider 的 com.trs.webframework.provider 中的构造方法
BaseServiceDecorator(IServiceProvider _serviceProvider)

com.trsothers 中 IServiceProvider 的使用

实现 IServiceProvider 的 com.trsothers 中的类
 class LogServiceProvider
Title: TRS 内容协作平台（TRS WCM）
Description:
日志相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.provider.ServiceFilterExample 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.provider.ServiceFilterExample
的使用

没有 com.trs.webframework.provider.ServiceFilterExample 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.provider.ServiceListenerExample 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.provider.ServiceListenerExample
的使用

没有 com.trs.webframework.provider.ServiceListenerExample 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ConvertException

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver
类 ConvertException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  com.trs.infra.util.CMyException
                继承者  com.trs.webframework.xmlserver.ConvertException
所有已实现的接口：
java.io.Serializable
public class ConvertException
extends CMyException

Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
ConvertException(int _errNo)
ConvertException(int _errNo, java.lang.String _sMsg)
ConvertException(int _errNo, java.lang.String _sMsg, java.lang.Throwable _rootCause)
ConvertException(java.lang.String _sMsg)
ConvertException(java.lang.String _sMsg, java.lang.Throwable _rootCause)
方法摘要
从类 com.trs.infra.util.CMyException 继承的方法
getErrNo, getErrNoMsg, getLocalizedMessage, getMessage, getMyMessage, getRootCause, getStackTraceText, getStackTraceText, main, printStackTrace, printStackTrace, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getStackTrace, initCause, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConvertException

public ConvertException(int _errNo)
参数：
_errNo -

ConvertException

public ConvertException(int _errNo,
                        java.lang.String _sMsg)
参数：
_errNo -
_sMsg -

ConvertException

public ConvertException(java.lang.String _sMsg)
参数：
_sMsg -

ConvertException

public ConvertException(int _errNo,
                        java.lang.String _sMsg,
                        java.lang.Throwable _rootCause)
参数：
_errNo -
_sMsg -
_rootCause -

ConvertException

public ConvertException(java.lang.String _sMsg,
                        java.lang.Throwable _rootCause)
参数：
_sMsg -
_rootCause -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IXMLConvertor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver
接口 IXMLConvertor

所有已知实现类：
AppendixToXML, BaseWCMObjectToXML, BooleanXMLConvertorImpl, ChannelSynToXML, ChannelToXML, ChnlDocToXML, ContentExtFieldToXML, ContentLink2Xml, ContentProcessInfoToXML, DataTypeToXML, DefaultWCMObjectsToXML, DistributionTargetTypeToXML, DocumentToXML, ExtFieldToXML, FlowContentsToXML, FlowDocToXML, FlowToXML, InfoViewDocumentToXML, IntegerXMLConvertorImpl, MessageToXML, PageOpertatosToXML, RelationToXML, ReportsToXML, StringXMLConvertorImpl, TemplateEmployerToXML, TemplateToXML, ViewDataToXML, ViewDocumentToXML, Watermark2Xml, WCMContentPublishConfigToXML, WCMFolderPublishConfigToXML, WebSiteToXML
public interface IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
Java对象转换成XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串

方法详细信息

toXmlString

java.lang.String toXmlString(MethodContext _methodContext,
                             java.lang.Object _result)
                             throws ConvertException
将指定对象的所有属性转换为XML字符串

参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException

registerTargetClassName

java.lang.String[] registerTargetClassName()
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.xmlserver
接口
IXMLConvertor
类
XMLConvertorConfigStartServer
XMLConvertorFactory
异常
ConvertException


com.trs.webframework.xmlserver

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.xmlserver

接口摘要
IXMLConvertor Title: TRS 内容协作平台（TRS WCM）
Description:
Java对象转换成XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
XMLConvertorConfigStartServer | Title: TRS 内容协作平台（TRS WCM） Description: XML转换器配置信息读取服务 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XMLConvertorFactory |

异常摘要
ConvertException Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.webframework.xmlserver 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.xmlserver 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.infra.BaseServer (implements com.trs.infra.IServer)
      • com.trs.infra.config.BaseConfigServer
        • com.trs.webframework.xmlserver.XMLConvertorConfigStartServer
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.trs.infra.util.CMyException
          • com.trs.webframework.xmlserver.ConvertException
    • com.trs.webframework.xmlserver.XMLConvertorFactory

接口分层结构

  • com.trs.webframework.xmlserver.IXMLConvertor


软件包 com.trs.webframework.xmlserver 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.xmlserver
的使用

使用 com.trs.webframework.xmlserver 的软件包
com.trs.ajaxservice.xmlconvertors
com.trs.components.metadata.service.xmlconvertors
com.trs.webframework.xmlserver
com.trs.webframework.xmlserver.convertors

com.trs.ajaxservice.xmlconvertors 使用的 com.trs.webframework.xmlserver 中的类
ConvertException
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IXMLConvertor
Title: TRS 内容协作平台（TRS WCM）
Description:
Java对象转换成XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service.xmlconvertors 使用的 com.trs.webframework.xmlserver 中的类
ConvertException
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IXMLConvertor
Title: TRS 内容协作平台（TRS WCM）
Description:
Java对象转换成XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.xmlserver 使用的 com.trs.webframework.xmlserver 中的类
ConvertException
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IXMLConvertor
Title: TRS 内容协作平台（TRS WCM）
Description:
Java对象转换成XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.xmlserver.convertors 使用的 com.trs.webframework.xmlserver 中的类
ConvertException
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IXMLConvertor
Title: TRS 内容协作平台（TRS WCM）
Description:
Java对象转换成XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


XMLConvertorConfigStartServer

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver
类 XMLConvertorConfigStartServer

java.lang.Object
    继承者  com.trs.infra.BaseServer
        继承者  com.trs.infra.config.BaseConfigServer
            继承者  com.trs.webframework.xmlserver.XMLConvertorConfigStartServer
所有已实现的接口：
IServer
public class XMLConvertorConfigStartServer
extends BaseConfigServer

Title: TRS 内容协作平台（TRS WCM）
Description:
XML转换器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
从类 com.trs.infra.BaseServer 继承的字段
APP_BUILD, APP_BUILD_TIME, APP_VERSION, DB_BUILD
构造方法摘要
XMLConvertorConfigStartServer()
方法摘要
从类 com.trs.infra.config.BaseConfigServer 继承的方法
getConfigPath, setConfigPath
从类 com.trs.infra.BaseServer 继承的方法
getBuildTime, getDbBuild, getErrors, getServerBuild, getServerName, getVersion, isStarted, isStarting, restart, setServerName, shutdown, startup
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLConvertorConfigStartServer

public XMLConvertorConfigStartServer()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLConvertorFactory

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver
类 XMLConvertorFactory

java.lang.Object
    继承者  com.trs.webframework.xmlserver.XMLConvertorFactory

public class XMLConvertorFactory
extends java.lang.Object

构造方法摘要
XMLConvertorFactory()
方法摘要
static IXMLConvertor | createConvertor(java.lang.Class _objectClass) 根据指定的对象的class产生将指定对象转换为XML的转换器
static IXMLConvertor | createConvertor(java.lang.String _sObjectClassName) 根据指定的对象的class名称产生将指定对象转换为XML的转换器
static void | registerConvertor(IXMLConvertor convertor, java.lang.String _sTargetClassName)
static void | registerConvertor(java.lang.String _sConvertorClassName, java.lang.String _sTargetClassName) 为特定的对象[_sTargetClassName]注册一个Convertor
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLConvertorFactory

public XMLConvertorFactory()
方法详细信息

createConvertor

public static IXMLConvertor createConvertor(java.lang.Class _objectClass)
根据指定的对象的class产生将指定对象转换为XML的转换器

参数：
_objectClass -
返回：

createConvertor

public static IXMLConvertor createConvertor(java.lang.String _sObjectClassName)
                                     throws java.lang.Exception
根据指定的对象的class名称产生将指定对象转换为XML的转换器

参数：
_sObjectClassName - class名称
返回：
抛出：
java.lang.Exception

registerConvertor

public static void registerConvertor(java.lang.String _sConvertorClassName,
                                     java.lang.String _sTargetClassName)
                              throws java.lang.Exception
为特定的对象[_sTargetClassName]注册一个Convertor

参数：
_sConvertorClassName -
_sTargetClassName -
抛出：
java.lang.Exception

registerConvertor

public static void registerConvertor(IXMLConvertor convertor,
                                     java.lang.String _sTargetClassName)
参数：
convertor -
_sTargetClassName -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.xmlserver.ConvertException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.ConvertException
的使用

使用 ConvertException 的软件包
com.trs.ajaxservice.xmlconvertors
com.trs.components.metadata.service.xmlconvertors
com.trs.webframework.xmlserver
com.trs.webframework.xmlserver.convertors

com.trs.ajaxservice.xmlconvertors 中 ConvertException 的使用

抛出 ConvertException 的 com.trs.ajaxservice.xmlconvertors 中的方法
java.lang.String | WCMFolderPublishConfigToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | WCMContentPublishConfigToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | FlowContentsToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | ContentProcessInfoToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | BaseWCMObjectToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)

com.trs.components.metadata.service.xmlconvertors 中 ConvertException 的使用

抛出 ConvertException 的 com.trs.components.metadata.service.xmlconvertors 中的方法
 java.lang.String ViewDataToXML.toXmlString(MethodContext _methodContext, java.lang.Object _result)

com.trs.webframework.xmlserver 中 ConvertException 的使用

抛出 ConvertException 的 com.trs.webframework.xmlserver 中的方法
 java.lang.String IXMLConvertor.toXmlString(MethodContext _methodContext, java.lang.Object _result)
将指定对象的所有属性转换为XML字符串

com.trs.webframework.xmlserver.convertors 中 ConvertException 的使用

抛出 ConvertException 的 com.trs.webframework.xmlserver.convertors 中的方法
java.lang.String | StringXMLConvertorImpl.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | IntegerXMLConvertorImpl.toXmlString(MethodContext _methodContext, java.lang.Object _result)
java.lang.String | BooleanXMLConvertorImpl.toXmlString(MethodContext _methodContext, java.lang.Object _result)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.xmlserver.IXMLConvertor 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.xmlserver.IXMLConvertor
的使用

使用 IXMLConvertor 的软件包
com.trs.ajaxservice.xmlconvertors
com.trs.components.metadata.service.xmlconvertors
com.trs.webframework.xmlserver
com.trs.webframework.xmlserver.convertors

com.trs.ajaxservice.xmlconvertors 中 IXMLConvertor 的使用

实现 IXMLConvertor 的 com.trs.ajaxservice.xmlconvertors 中的类
class | AppendixToXML Title: TRS 内容协作平台（TRS WCM） Description: 附件的XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | BaseWCMObjectToXML
class | ChannelSynToXML Title: TRS 内容协作平台（TRS WCM） Description: 文档同步XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChannelToXML Title: TRS 内容协作平台（TRS WCM） Description: 栏目XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ChnlDocToXML Title: TRS 内容协作平台（TRS WCM） Description: 频道文档XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContentExtFieldToXML Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ContentLink2Xml Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | ContentProcessInfoToXML Title: TRS 内容协作平台（TRS WCM） Description: ContentProcessInfo的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DataTypeToXML Title: TRS 内容协作平台（TRS WCM） Description: DataType的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DefaultWCMObjectsToXML
class | DistributionTargetTypeToXML Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | DocumentToXML Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ExtFieldToXML Title: TRS 内容协作平台（TRS WCM） Description: 扩展字段XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowContentsToXML Title: TRS 内容协作平台（TRS WCM） Description: 将IFlowContent数组转换为XML Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowDocToXML Title: TRS 内容协作平台（TRS WCM） Description: 工作流轨迹XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | FlowToXML Title: TRS 内容协作平台（TRS WCM） Description: 工作流 To XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | InfoViewDocumentToXML Title: TRS 内容协作平台（TRS WCM） Description: ViewDocument的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | MessageToXML Title: TRS 内容协作平台（TRS WCM） Description: Message XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | PageOpertatosToXML
class | RelationToXML Title: TRS 内容协作平台（TRS WCM） Description: 相关文档XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ReportsToXML Title: TRS 内容协作平台（TRS WCM） Description: Reports的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateEmployerToXML Title: TRS 内容协作平台（TRS WCM） Description: 模板使用者XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | TemplateToXML Title: TRS 内容协作平台（TRS WCM） Description: 模板对象XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | ViewDocumentToXML Title: TRS 内容协作平台（TRS WCM） Description: ViewDocument的XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | Watermark2Xml Title: TRS 内容协作平台（TRS WCM） Description: TODO Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司 Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
class | WCMContentPublishConfigToXML Title: TRS 内容协作平台（TRS WCM） Description: WCMFolderPublishConfig XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WCMFolderPublishConfigToXML Title: TRS 内容协作平台（TRS WCM） Description: WCMFolderPublishConfig XML生成器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | WebSiteToXML Title: TRS 内容协作平台（TRS WCM） Description: 栏目XML转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.components.metadata.service.xmlconvertors 中 IXMLConvertor 的使用

实现 IXMLConvertor 的 com.trs.components.metadata.service.xmlconvertors 中的类
 class ViewDataToXML
Title: TRS 内容协作平台（TRS WCM）
Description:
ViewData的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

com.trs.webframework.xmlserver 中 IXMLConvertor 的使用

返回 IXMLConvertor 的 com.trs.webframework.xmlserver 中的方法
static IXMLConvertor | XMLConvertorFactory.createConvertor(java.lang.Class _objectClass) 根据指定的对象的class产生将指定对象转换为XML的转换器
static IXMLConvertor | XMLConvertorFactory.createConvertor(java.lang.String _sObjectClassName) 根据指定的对象的class名称产生将指定对象转换为XML的转换器

参数类型为 IXMLConvertor 的 com.trs.webframework.xmlserver 中的方法
static void XMLConvertorFactory.registerConvertor(IXMLConvertor convertor, java.lang.String _sTargetClassName)

com.trs.webframework.xmlserver.convertors 中 IXMLConvertor 的使用

实现 IXMLConvertor 的 com.trs.webframework.xmlserver.convertors 中的类
class | BooleanXMLConvertorImpl Title: TRS 内容协作平台（TRS WCM） Description: Boolean的ＸＭＬ转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | IntegerXMLConvertorImpl Title: TRS 内容协作平台（TRS WCM） Description: Boolean的ＸＭＬ转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | StringXMLConvertorImpl Title: TRS 内容协作平台（TRS WCM） Description: 将String处理成XML的Convertor Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.XMLConvertorConfigStartServer 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.XMLConvertorConfigStartServer
的使用

没有 com.trs.webframework.xmlserver.XMLConvertorConfigStartServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.XMLConvertorFactory 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.XMLConvertorFactory
的使用

没有 com.trs.webframework.xmlserver.XMLConvertorFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


BooleanXMLConvertorImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.convertors
类 BooleanXMLConvertorImpl

java.lang.Object
    继承者  com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl
所有已实现的接口：
IXMLConvertor
public class BooleanXMLConvertorImpl
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
Boolean的ＸＭＬ转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
BooleanXMLConvertorImpl()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BooleanXMLConvertorImpl

public BooleanXMLConvertorImpl()
方法详细信息

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IntegerXMLConvertorImpl

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.convertors
类 IntegerXMLConvertorImpl

java.lang.Object
    继承者  com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl
所有已实现的接口：
IXMLConvertor
public class IntegerXMLConvertorImpl
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
Boolean的ＸＭＬ转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
IntegerXMLConvertorImpl()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IntegerXMLConvertorImpl

public IntegerXMLConvertorImpl()
方法详细信息

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.xmlserver.convertors
类
BooleanXMLConvertorImpl
IntegerXMLConvertorImpl
StringXMLConvertorImpl


com.trs.webframework.xmlserver.convertors

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.xmlserver.convertors

类摘要
BooleanXMLConvertorImpl | Title: TRS 内容协作平台（TRS WCM） Description: Boolean的ＸＭＬ转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IntegerXMLConvertorImpl | Title: TRS 内容协作平台（TRS WCM） Description: Boolean的ＸＭＬ转换器 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
StringXMLConvertorImpl | Title: TRS 内容协作平台（TRS WCM） Description: 将String处理成XML的Convertor Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.webframework.xmlserver.convertors 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.xmlserver.convertors 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl (implements com.trs.webframework.xmlserver.IXMLConvertor)
    • com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl (implements com.trs.webframework.xmlserver.IXMLConvertor)


软件包 com.trs.webframework.xmlserver.convertors 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.xmlserver.convertors
的使用

没有 com.trs.webframework.xmlserver.convertors 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


StringXMLConvertorImpl

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.convertors
类 StringXMLConvertorImpl

java.lang.Object
    继承者  com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl
所有已实现的接口：
IXMLConvertor
public class StringXMLConvertorImpl
extends java.lang.Object
implements IXMLConvertor

Title: TRS 内容协作平台（TRS WCM）
Description:
将String处理成XML的Convertor
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
StringXMLConvertorImpl()
方法摘要
java.lang.String[] | registerTargetClassName()
java.lang.String | toXmlString(MethodContext _methodContext, java.lang.Object _result) 将指定对象的所有属性转换为XML字符串
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringXMLConvertorImpl

public StringXMLConvertorImpl()
方法详细信息

toXmlString

public java.lang.String toXmlString(MethodContext _methodContext,
                                    java.lang.Object _result)
                             throws ConvertException
从接口 IXMLConvertor 复制的描述
将指定对象的所有属性转换为XML字符串

指定者：
接口 IXMLConvertor 中的 toXmlString
参数：
_methodContext - TODO
_result - 指定对象
返回：
抛出：
ConvertException

registerTargetClassName

public java.lang.String[] registerTargetClassName()
指定者：
接口 IXMLConvertor 中的 registerTargetClassName
返回：
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl
的使用

没有 com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl
的使用

没有 com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl
的使用

没有 com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.webframework.xmlserver.parser
类
ServletInputStreamWrapper
StreamBuddy
XMLParsingInfoHolder
XMLParsingStatus
异常
XMLParseException


com.trs.webframework.xmlserver.parser

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.xmlserver.parser

类摘要
ServletInputStreamWrapper | Title: TRS 内容协作平台（TRS WCM 6.0） ServletInputStreamWrapper
StreamBuddy | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XMLParsingInfoHolder |
XMLParsingStatus | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
XMLParseException


com.trs.webframework.xmlserver.parser 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.xmlserver.parser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.io.InputStream (implements java.io.Closeable)
      • javax.servlet.ServletInputStream
        • com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper
    • com.trs.webframework.xmlserver.parser.StreamBuddy
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.trs.webframework.xmlserver.parser.XMLParseException
    • com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder
    • com.trs.webframework.xmlserver.parser.XMLParsingStatus


软件包 com.trs.webframework.xmlserver.parser 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.xmlserver.parser
的使用

使用 com.trs.webframework.xmlserver.parser 的软件包
com.trs.webframework.context
com.trs.webframework.xmlserver.server

com.trs.webframework.context 使用的 com.trs.webframework.xmlserver.parser 中的类
ServletInputStreamWrapper
Title: TRS 内容协作平台（TRS WCM 6.0）
ServletInputStreamWrapper

com.trs.webframework.xmlserver.server 使用的 com.trs.webframework.xmlserver.parser 中的类
XMLParsingInfoHolder

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


ServletInputStreamWrapper

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.parser
类 ServletInputStreamWrapper

java.lang.Object
    继承者  java.io.InputStream
        继承者  javax.servlet.ServletInputStream
            继承者  com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper
所有已实现的接口：
java.io.Closeable
public class ServletInputStreamWrapper
extends javax.servlet.ServletInputStream

Title: TRS 内容协作平台（TRS WCM 6.0）
ServletInputStreamWrapper

版本：
0.9
作者：
trs 应用产品开发部 ly

构造方法摘要
ServletInputStreamWrapper(java.io.InputStream _is)
方法摘要
int | available()
void | close()
java.io.InputStream | getInputSteam()
void | mark(int readlimit)
boolean | markSupported()
int | read()
void | reset()
long | skip(long n)
从类 javax.servlet.ServletInputStream 继承的方法
readLine
从类 java.io.InputStream 继承的方法
read, read
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServletInputStreamWrapper

public ServletInputStreamWrapper(java.io.InputStream _is)
方法详细信息

read

public int read()
         throws java.io.IOException
指定者：
类 java.io.InputStream 中的 read
抛出：
java.io.IOException

skip

public long skip(long n)
          throws java.io.IOException
覆盖：
类 java.io.InputStream 中的 skip
抛出：
java.io.IOException

available

public int available()
              throws java.io.IOException
覆盖：
类 java.io.InputStream 中的 available
抛出：
java.io.IOException

mark

public void mark(int readlimit)
覆盖：
类 java.io.InputStream 中的 mark

reset

public void reset()
           throws java.io.IOException
覆盖：
类 java.io.InputStream 中的 reset
抛出：
java.io.IOException

close

public void close()
           throws java.io.IOException
指定者：
接口 java.io.Closeable 中的 close
覆盖：
类 java.io.InputStream 中的 close
抛出：
java.io.IOException

markSupported

public boolean markSupported()
覆盖：
类 java.io.InputStream 中的 markSupported

getInputSteam

public java.io.InputStream getInputSteam()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


StreamBuddy

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.parser
类 StreamBuddy

java.lang.Object
    继承者  com.trs.webframework.xmlserver.parser.StreamBuddy

public class StreamBuddy
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static java.lang.String STREAM_ENCODING_DEFAULT
构造方法摘要
StreamBuddy()
方法摘要
static java.io.InputStream | copyRequestInputStream(java.io.InputStream _is)
static org.xml.sax.InputSource | getInputSource(java.io.InputStream _is, java.lang.String _sEncoding)
static byte[] | readFromInputStream(java.io.InputStream _is)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STREAM_ENCODING_DEFAULT

public static final java.lang.String STREAM_ENCODING_DEFAULT
另请参见：
常量字段值
构造方法详细信息

StreamBuddy

public StreamBuddy()
方法详细信息

copyRequestInputStream

public static java.io.InputStream copyRequestInputStream(java.io.InputStream _is)
                                                  throws java.io.IOException,
                                                         java.io.UnsupportedEncodingException
参数：
_is - TODO
返回：
抛出：
java.io.IOException
java.io.UnsupportedEncodingException

readFromInputStream

public static byte[] readFromInputStream(java.io.InputStream _is)
                                  throws java.io.IOException
参数：
_is -
返回：
抛出：
java.io.IOException

getInputSource

public static org.xml.sax.InputSource getInputSource(java.io.InputStream _is,
                                                     java.lang.String _sEncoding)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLParseException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.parser
类 XMLParseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.webframework.xmlserver.parser.XMLParseException
所有已实现的接口：
java.io.Serializable
public class XMLParseException
extends java.lang.RuntimeException

另请参见：
序列化表格

构造方法摘要
XMLParseException()
XMLParseException(java.lang.String message)
XMLParseException(java.lang.String message, java.lang.Throwable cause)
XMLParseException(java.lang.Throwable cause)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XMLParseException

public XMLParseException()

XMLParseException

public XMLParseException(java.lang.String message)

XMLParseException

public XMLParseException(java.lang.Throwable cause)

XMLParseException

public XMLParseException(java.lang.String message,
                         java.lang.Throwable cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLParsingInfoHolder

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.parser
类 XMLParsingInfoHolder

java.lang.Object
    继承者  com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder

public class XMLParsingInfoHolder
extends java.lang.Object

构造方法摘要
XMLParsingInfoHolder()
方法摘要
void | appendNamedParam(java.lang.String _sParmName, java.lang.String _sParamVal)
void | appendParam(java.lang.String strParamVal)
boolean | containsNamedParam(java.lang.String strParamKey)
boolean | containsParam(java.lang.String strParamVal)
java.lang.String | getInvocationId()
int | getInvocationType()
java.lang.String | getMethodName()
java.util.Map | getNamedParamsMap()
int | getObjectId()
java.lang.String | getObjectIds()
java.util.ArrayList | getParamsList()
java.lang.String | getValue(java.lang.String _sParamName)
void | setInvocationId(java.lang.String id)
void | setMethodName(java.lang.String _sMethodName)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLParsingInfoHolder

public XMLParsingInfoHolder()
方法详细信息

setInvocationId

public void setInvocationId(java.lang.String id)

getInvocationId

public java.lang.String getInvocationId()

getMethodName

public java.lang.String getMethodName()

setMethodName

public void setMethodName(java.lang.String _sMethodName)

containsParam

public boolean containsParam(java.lang.String strParamVal)

getParamsList

public java.util.ArrayList getParamsList()

appendParam

public void appendParam(java.lang.String strParamVal)

containsNamedParam

public boolean containsNamedParam(java.lang.String strParamKey)

getValue

public java.lang.String getValue(java.lang.String _sParamName)

getNamedParamsMap

public java.util.Map getNamedParamsMap()

appendNamedParam

public void appendNamedParam(java.lang.String _sParmName,
                             java.lang.String _sParamVal)

getObjectIds

public java.lang.String getObjectIds()

getObjectId

public int getObjectId()

getInvocationType

public int getInvocationType()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLParsingStatus

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.parser
类 XMLParsingStatus

java.lang.Object
    继承者  com.trs.webframework.xmlserver.parser.XMLParsingStatus

public class XMLParsingStatus
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | BEFORE_PARSING
static int | INVOCATION_DOCUMENTEND_DETECTED
static int | INVOCATION_NAME_DETECTED
static int | INVOCATION_PARAM_DETECTED
static int | INVOCATION_TYPE_DETECTED
方法摘要
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

BEFORE_PARSING

public static final int BEFORE_PARSING
另请参见：
常量字段值

INVOCATION_TYPE_DETECTED

public static final int INVOCATION_TYPE_DETECTED
另请参见：
常量字段值

INVOCATION_NAME_DETECTED

public static final int INVOCATION_NAME_DETECTED
另请参见：
常量字段值

INVOCATION_PARAM_DETECTED

public static final int INVOCATION_PARAM_DETECTED
另请参见：
常量字段值

INVOCATION_DOCUMENTEND_DETECTED

public static final int INVOCATION_DOCUMENTEND_DETECTED
另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper
的使用

使用 ServletInputStreamWrapper 的软件包
com.trs.webframework.context

com.trs.webframework.context 中 ServletInputStreamWrapper 的使用

返回 ServletInputStreamWrapper 的 com.trs.webframework.context 中的方法
 ServletInputStreamWrapper ServiceContext.getInputStreamWrapper()

参数类型为 ServletInputStreamWrapper 的 com.trs.webframework.context 中的方法
 void ServiceContext.setInputStreamWrapper(ServletInputStreamWrapper _isw)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.parser.StreamBuddy 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.parser.StreamBuddy
的使用

没有 com.trs.webframework.xmlserver.parser.StreamBuddy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.parser.XMLParseException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.parser.XMLParseException
的使用

没有 com.trs.webframework.xmlserver.parser.XMLParseException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder
的使用

使用 XMLParsingInfoHolder 的软件包
com.trs.webframework.xmlserver.server

com.trs.webframework.xmlserver.server 中 XMLParsingInfoHolder 的使用

返回 XMLParsingInfoHolder 的 com.trs.webframework.xmlserver.server 中的方法
 XMLParsingInfoHolder XMLDataProcessingHandler.getParsingInfo()

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.parser.XMLParsingStatus 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.parser.XMLParsingStatus
的使用

没有 com.trs.webframework.xmlserver.parser.XMLParsingStatus 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


DataAnalyzingException

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 DataAnalyzingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.webframework.xmlserver.server.DataAnalyzingException
所有已实现的接口：
java.io.Serializable
public class DataAnalyzingException
extends java.lang.RuntimeException

另请参见：
序列化表格

构造方法摘要
DataAnalyzingException()
DataAnalyzingException(java.lang.String message)
DataAnalyzingException(java.lang.String message, java.lang.Throwable cause)
DataAnalyzingException(java.lang.Throwable cause)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DataAnalyzingException

public DataAnalyzingException()

DataAnalyzingException

public DataAnalyzingException(java.lang.String message)

DataAnalyzingException

public DataAnalyzingException(java.lang.Throwable cause)

DataAnalyzingException

public DataAnalyzingException(java.lang.String message,
                              java.lang.Throwable cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InvocationObserver

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 InvocationObserver

java.lang.Object
    继承者  com.trs.webframework.xmlserver.server.InvocationObserver
所有已实现的接口：
IObserver
public class InvocationObserver
extends java.lang.Object
implements IObserver

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
InvocationObserver()
InvocationObserver(ServiceContext _serviceContext)
方法摘要
void | clear() 清除当前的信息
void | update(IObserverable _subject)
void | update(IObserverable _subject, java.lang.Object _arg)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InvocationObserver

public InvocationObserver()

InvocationObserver

public InvocationObserver(ServiceContext _serviceContext)
参数：
serviceContext -
方法详细信息

clear

public void clear()
从接口 IObserver 复制的描述
清除当前的信息

指定者：
接口 IObserver 中的 clear

update

public void update(IObserverable _subject)
指定者：
接口 IObserver 中的 update

update

public void update(IObserverable _subject,
                   java.lang.Object _arg)
指定者：
接口 IObserver 中的 update
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvocationTypes

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 InvocationTypes

java.lang.Object
    继承者  com.trs.webframework.xmlserver.server.InvocationTypes

public class InvocationTypes
extends java.lang.Object

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | DEFAULT
static int | DELETE
static int | FINDBYID
static int | FINDBYIDS
static int | QUERY
static int | SAVE
static int | SELF_DEFINED
static java.lang.String | STR_DELETE
static java.lang.String | STR_FINDBYID
static java.lang.String | STR_FINDBYIDS
static java.lang.String | STR_QUERY
static java.lang.String | STR_SAVE
static java.lang.String | STR_SELFDEFINED
方法摘要
static int | getMapedType(java.lang.String type)
static java.lang.String | getTypeAsString(int _nType)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STR_FINDBYIDS

public static final java.lang.String STR_FINDBYIDS
另请参见：
常量字段值

STR_FINDBYID

public static final java.lang.String STR_FINDBYID
另请参见：
常量字段值

STR_SELFDEFINED

public static final java.lang.String STR_SELFDEFINED
另请参见：
常量字段值

STR_DELETE

public static final java.lang.String STR_DELETE
另请参见：
常量字段值

STR_SAVE

public static final java.lang.String STR_SAVE
另请参见：
常量字段值

STR_QUERY

public static final java.lang.String STR_QUERY
另请参见：
常量字段值

DELETE

public static final int DELETE
另请参见：
常量字段值

SAVE

public static final int SAVE
另请参见：
常量字段值

QUERY

public static final int QUERY
另请参见：
常量字段值

SELF_DEFINED

public static final int SELF_DEFINED
另请参见：
常量字段值

FINDBYID

public static final int FINDBYID
另请参见：
常量字段值

DEFAULT

public static final int DEFAULT
另请参见：
常量字段值

FINDBYIDS

public static final int FINDBYIDS
另请参见：
常量字段值
方法详细信息

getMapedType

public static int getMapedType(java.lang.String type)

getTypeAsString

public static java.lang.String getTypeAsString(int _nType)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IObserver

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
接口 IObserver

所有已知实现类：
InvocationObserver
public interface IObserver

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | clear() 清除当前的信息
void | update(IObserverable _subject)
void | update(IObserverable _subject, java.lang.Object _arg)

方法详细信息

update

void update(IObserverable _subject)

update

void update(IObserverable _subject,
            java.lang.Object _arg)

clear

void clear()
清除当前的信息

概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IObserverable

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
接口 IObserverable

所有已知实现类：
XMLDataProcessingHandler
public interface IObserverable

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
void | attachObserver(IObserver _observer)
void | detachObserver(IObserver _observer)
void | notifyObservers(IObserverable _subject, int _statusCode)

方法详细信息

notifyObservers

void notifyObservers(IObserverable _subject,
                     int _statusCode)

attachObserver

void attachObserver(IObserver _observer)

detachObserver

void detachObserver(IObserver _observer)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IRequestProcessor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
接口 IRequestProcessor

所有已知实现类：
RequestParamsProcessor, RequestXMLDataProcessor
public interface IRequestProcessor

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

方法摘要
 java.lang.Object excute()

方法详细信息

excute

java.lang.Object excute()
                        throws java.lang.Throwable
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


 com.trs.webframework.xmlserver.server
接口
IObserver
IObserverable
IRequestProcessor
类
InvocationObserver
InvocationTypes
RequestParamsProcessor
RequestXMLDataProcessor
XMLDataProcessingHandler
异常
DataAnalyzingException
RequestParmasParseException
ResponseOutputException
XMLParsingPausedException


com.trs.webframework.xmlserver.server

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.webframework.xmlserver.server

接口摘要
IObserver | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IObserverable | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
IRequestProcessor | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

类摘要
InvocationObserver | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
InvocationTypes | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RequestParamsProcessor | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
RequestXMLDataProcessor |
XMLDataProcessingHandler | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)

异常摘要
DataAnalyzingException |
RequestParmasParseException | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
ResponseOutputException | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
XMLParsingPausedException | Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)


com.trs.webframework.xmlserver.server 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.webframework.xmlserver.server 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.trs.webframework.xmlserver.server.XMLDataProcessingHandler (implements com.trs.webframework.xmlserver.server.IObserverable)
    • com.trs.webframework.xmlserver.server.InvocationObserver (implements com.trs.webframework.xmlserver.server.IObserver)
    • com.trs.webframework.xmlserver.server.InvocationTypes
    • com.trs.webframework.xmlserver.server.RequestParamsProcessor (implements com.trs.webframework.xmlserver.server.IRequestProcessor)
    • com.trs.webframework.xmlserver.server.RequestXMLDataProcessor (implements com.trs.webframework.xmlserver.server.IRequestProcessor)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.trs.webframework.xmlserver.server.DataAnalyzingException
          • com.trs.webframework.xmlserver.server.ResponseOutputException
          • com.trs.webframework.exception.ServiceInvocationException
            • com.trs.webframework.xmlserver.server.RequestParmasParseException
          • com.trs.webframework.xmlserver.server.XMLParsingPausedException

接口分层结构

  • com.trs.webframework.xmlserver.server.IObserver
  • com.trs.webframework.xmlserver.server.IObserverable
  • com.trs.webframework.xmlserver.server.IRequestProcessor


软件包 com.trs.webframework.xmlserver.server 的使用

上一个 下一个 框架 无框架

软件包 com.trs.webframework.xmlserver.server
的使用

使用 com.trs.webframework.xmlserver.server 的软件包
com.trs.webframework.xmlserver.server

com.trs.webframework.xmlserver.server 使用的 com.trs.webframework.xmlserver.server 中的类
IObserver
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObserverable
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRequestProcessor
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLParsingPausedException
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RequestParamsProcessor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 RequestParamsProcessor

java.lang.Object
    继承者  com.trs.webframework.xmlserver.server.RequestParamsProcessor
所有已实现的接口：
IRequestProcessor
public class RequestParamsProcessor
extends java.lang.Object
implements IRequestProcessor

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
RequestParamsProcessor(ServiceContext _serviceContext)
方法摘要
 java.lang.Object excute()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RequestParamsProcessor

public RequestParamsProcessor(ServiceContext _serviceContext)
方法详细信息

excute

public java.lang.Object excute()
                        throws java.lang.Throwable
指定者：
接口 IRequestProcessor 中的 excute
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestParmasParseException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 RequestParmasParseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.webframework.exception.ServiceInvocationException
                    继承者  com.trs.webframework.xmlserver.server.RequestParmasParseException
所有已实现的接口：
java.io.Serializable
public class RequestParmasParseException
extends ServiceInvocationException

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

字段摘要
从类 com.trs.webframework.exception.ServiceInvocationException 继承的字段
ERROR_CODE_DEFAULT, SUGGESTION_DEFAULT
构造方法摘要
RequestParmasParseException()
RequestParmasParseException(java.lang.String message)
RequestParmasParseException(java.lang.String message, java.lang.Throwable cause)
RequestParmasParseException(java.lang.Throwable cause)
方法摘要
从类 com.trs.webframework.exception.ServiceInvocationException 继承的方法
getErrorCode, getSuggestion, printStackTrace, printStackTrace, setErrorCode, setSuggestion
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RequestParmasParseException

public RequestParmasParseException()

RequestParmasParseException

public RequestParmasParseException(java.lang.String message)

RequestParmasParseException

public RequestParmasParseException(java.lang.Throwable cause)

RequestParmasParseException

public RequestParmasParseException(java.lang.String message,
                                   java.lang.Throwable cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestXMLDataProcessor

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 RequestXMLDataProcessor

java.lang.Object
    继承者  com.trs.webframework.xmlserver.server.RequestXMLDataProcessor
所有已实现的接口：
IRequestProcessor
public class RequestXMLDataProcessor
extends java.lang.Object
implements IRequestProcessor

构造方法摘要
RequestXMLDataProcessor(java.io.InputStream _in)
RequestXMLDataProcessor(ServiceContext _serviceContext, java.io.InputStream _in)
方法摘要
 java.lang.Object excute()
分析Request信息，进行具体的处理工作
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RequestXMLDataProcessor

public RequestXMLDataProcessor(ServiceContext _serviceContext,
                               java.io.InputStream _in)

RequestXMLDataProcessor

public RequestXMLDataProcessor(java.io.InputStream _in)
方法详细信息

excute

public java.lang.Object excute()
                        throws java.lang.Throwable
分析Request信息，进行具体的处理工作

指定者：
接口 IRequestProcessor 中的 excute
返回：
处理后的记过数据
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResponseOutputException

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 ResponseOutputException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.webframework.xmlserver.server.ResponseOutputException
所有已实现的接口：
java.io.Serializable
public class ResponseOutputException
extends java.lang.RuntimeException

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
ResponseOutputException()
ResponseOutputException(java.lang.String message)
ResponseOutputException(java.lang.String message, java.lang.Throwable cause)
ResponseOutputException(java.lang.Throwable cause)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ResponseOutputException

public ResponseOutputException()

ResponseOutputException

public ResponseOutputException(java.lang.String message)

ResponseOutputException

public ResponseOutputException(java.lang.Throwable cause)

ResponseOutputException

public ResponseOutputException(java.lang.String message,
                               java.lang.Throwable cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLDataProcessingHandler

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 XMLDataProcessingHandler

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
        继承者  com.trs.webframework.xmlserver.server.XMLDataProcessingHandler
所有已实现的接口：
IObserverable, org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler
public class XMLDataProcessingHandler
extends org.xml.sax.helpers.DefaultHandler
implements IObserverable

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

字段摘要
static int | ATTR_TYPE
static int | TAG_METHOD
static int | TAG_PARAM
static int | TAG_PARAMS
static int | TAG_ROOT
构造方法摘要
XMLDataProcessingHandler()
XMLDataProcessingHandler(java.lang.Object _oHandlerArg)
方法摘要
void | attachObserver(IObserver _observer)
void | characters(char[] ch, int start, int length)
void | clear()
void | detachObserver(IObserver _observer)
void | endDocument()
void | endElement(java.lang.String uri, java.lang.String localName, java.lang.String qName)
XMLParsingInfoHolder | getParsingInfo()
int | getParsingStatus()
java.lang.Object | getResult()
void | notifyObservers(IObserverable _subject, int _status)
void | startDocument()
void | startElement(java.lang.String uri, java.lang.String localName, java.lang.String qName, org.xml.sax.Attributes attributes)
void | stopOnParsingCompleted(java.lang.Object result)
void | stopOnParsingError(ServiceInvocationException ex)
从类 org.xml.sax.helpers.DefaultHandler 继承的方法
endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startPrefixMapping, unparsedEntityDecl, warning
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TAG_ROOT

public static final int TAG_ROOT

TAG_METHOD

public static final int TAG_METHOD

ATTR_TYPE

public static final int ATTR_TYPE

TAG_PARAMS

public static final int TAG_PARAMS

TAG_PARAM

public static final int TAG_PARAM
构造方法详细信息

XMLDataProcessingHandler

public XMLDataProcessingHandler()

XMLDataProcessingHandler

public XMLDataProcessingHandler(java.lang.Object _oHandlerArg)
方法详细信息

clear

public void clear()

startDocument

public void startDocument()
指定者：
接口 org.xml.sax.ContentHandler 中的 startDocument
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 startDocument

startElement

public void startElement(java.lang.String uri,
                         java.lang.String localName,
                         java.lang.String qName,
                         org.xml.sax.Attributes attributes)
指定者：
接口 org.xml.sax.ContentHandler 中的 startElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 startElement

endElement

public void endElement(java.lang.String uri,
                       java.lang.String localName,
                       java.lang.String qName)
指定者：
接口 org.xml.sax.ContentHandler 中的 endElement
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 endElement

characters

public void characters(char[] ch,
                       int start,
                       int length)
指定者：
接口 org.xml.sax.ContentHandler 中的 characters
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 characters

endDocument

public void endDocument()
指定者：
接口 org.xml.sax.ContentHandler 中的 endDocument
覆盖：
类 org.xml.sax.helpers.DefaultHandler 中的 endDocument

getParsingInfo

public XMLParsingInfoHolder getParsingInfo()

getParsingStatus

public int getParsingStatus()

getResult

public java.lang.Object getResult()

notifyObservers

public void notifyObservers(IObserverable _subject,
                            int _status)
指定者：
接口 IObserverable 中的 notifyObservers

attachObserver

public void attachObserver(IObserver _observer)
指定者：
接口 IObserverable 中的 attachObserver

detachObserver

public void detachObserver(IObserver _observer)
指定者：
接口 IObserverable 中的 detachObserver

stopOnParsingError

public void stopOnParsingError(ServiceInvocationException ex)

stopOnParsingCompleted

public void stopOnParsingCompleted(java.lang.Object result)
                            throws XMLParsingPausedException
抛出：
XMLParsingPausedException
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLParsingPausedException

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.webframework.xmlserver.server
类 XMLParsingPausedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  com.trs.webframework.xmlserver.server.XMLParsingPausedException
所有已实现的接口：
java.io.Serializable
public class XMLParsingPausedException
extends java.lang.RuntimeException

Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司
另请参见：
序列化表格

构造方法摘要
XMLParsingPausedException()
XMLParsingPausedException(java.lang.String message)
XMLParsingPausedException(java.lang.String message, java.lang.Throwable cause)
XMLParsingPausedException(java.lang.Throwable cause)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XMLParsingPausedException

public XMLParsingPausedException()

XMLParsingPausedException

public XMLParsingPausedException(java.lang.String message)

XMLParsingPausedException

public XMLParsingPausedException(java.lang.Throwable cause)

XMLParsingPausedException

public XMLParsingPausedException(java.lang.String message,
                                 java.lang.Throwable cause)
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.webframework.xmlserver.server.DataAnalyzingException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.DataAnalyzingException
的使用

没有 com.trs.webframework.xmlserver.server.DataAnalyzingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.server.InvocationObserver 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.InvocationObserver
的使用

没有 com.trs.webframework.xmlserver.server.InvocationObserver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.server.InvocationTypes 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.InvocationTypes
的使用

没有 com.trs.webframework.xmlserver.server.InvocationTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.xmlserver.server.IObserver 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.xmlserver.server.IObserver
的使用

使用 IObserver 的软件包
com.trs.webframework.xmlserver.server

com.trs.webframework.xmlserver.server 中 IObserver 的使用

实现 IObserver 的 com.trs.webframework.xmlserver.server 中的类
 class InvocationObserver
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 IObserver 的 com.trs.webframework.xmlserver.server 中的方法
void | XMLDataProcessingHandler.attachObserver(IObserver _observer)
void | IObserverable.attachObserver(IObserver _observer)
void | XMLDataProcessingHandler.detachObserver(IObserver _observer)
void | IObserverable.detachObserver(IObserver _observer)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.xmlserver.server.IObserverable 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.xmlserver.server.IObserverable
的使用

使用 IObserverable 的软件包
com.trs.webframework.xmlserver.server

com.trs.webframework.xmlserver.server 中 IObserverable 的使用

实现 IObserverable 的 com.trs.webframework.xmlserver.server 中的类
 class XMLDataProcessingHandler
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

参数类型为 IObserverable 的 com.trs.webframework.xmlserver.server 中的方法
void | XMLDataProcessingHandler.notifyObservers(IObserverable _subject, int _status)
void | IObserverable.notifyObservers(IObserverable _subject, int _statusCode)
void | IObserver.update(IObserverable _subject)
void | InvocationObserver.update(IObserverable _subject)
void | IObserver.update(IObserverable _subject, java.lang.Object _arg)
void | InvocationObserver.update(IObserverable _subject, java.lang.Object _arg)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


接口 com.trs.webframework.xmlserver.server.IRequestProcessor 的使用

上一个 下一个 框架 无框架

接口 com.trs.webframework.xmlserver.server.IRequestProcessor
的使用

使用 IRequestProcessor 的软件包
com.trs.webframework.xmlserver.server

com.trs.webframework.xmlserver.server 中 IRequestProcessor 的使用

实现 IRequestProcessor 的 com.trs.webframework.xmlserver.server 中的类
class | RequestParamsProcessor Title: TRS 内容协作平台（TRS WCM 6.0） Description: TODO Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
class | RequestXMLDataProcessor

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.server.RequestParamsProcessor 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.RequestParamsProcessor
的使用

没有 com.trs.webframework.xmlserver.server.RequestParamsProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.server.RequestParmasParseException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.RequestParmasParseException
的使用

没有 com.trs.webframework.xmlserver.server.RequestParmasParseException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.server.RequestXMLDataProcessor 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.RequestXMLDataProcessor
的使用

没有 com.trs.webframework.xmlserver.server.RequestXMLDataProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.server.ResponseOutputException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.ResponseOutputException
的使用

没有 com.trs.webframework.xmlserver.server.ResponseOutputException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler
的使用

没有 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.webframework.xmlserver.server.XMLParsingPausedException 的使用

上一个 下一个 框架 无框架

类 com.trs.webframework.xmlserver.server.XMLParsingPausedException
的使用

使用 XMLParsingPausedException 的软件包
com.trs.webframework.xmlserver.server

com.trs.webframework.xmlserver.server 中 XMLParsingPausedException 的使用

抛出 XMLParsingPausedException 的 com.trs.webframework.xmlserver.server 中的方法
 void XMLDataProcessingHandler.stopOnParsingCompleted(java.lang.Object result)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trs.weblet.util.verfiycode
类
VerifyCode
VerifyCodeServlet


com.trs.weblet.util.verfiycode

上一个软件包 下一个软件包 框架 无框架

软件包 com.trs.weblet.util.verfiycode

类摘要
VerifyCode | 生成用于验证的BMP图片。
VerifyCodeServlet | 用于以图片的形式显示验证码。


com.trs.weblet.util.verfiycode 类分层结构

上一个 下一个 框架 无框架

软件包 com.trs.weblet.util.verfiycode 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • com.trs.weblet.util.verfiycode.VerifyCodeServlet
    • com.trs.weblet.util.verfiycode.VerifyCode


软件包 com.trs.weblet.util.verfiycode 的使用

上一个 下一个 框架 无框架

软件包 com.trs.weblet.util.verfiycode
的使用

没有 com.trs.weblet.util.verfiycode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


VerifyCode

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.weblet.util.verfiycode
类 VerifyCode

java.lang.Object
    继承者  com.trs.weblet.util.verfiycode.VerifyCode

public class VerifyCode
extends java.lang.Object

生成用于验证的BMP图片。

作者：
Martin (Fu Chengrui)

构造方法摘要
VerifyCode(java.lang.String sDigitImage, int iDigitWidth)
缺省构造方法
方法摘要
void | fastWriteImageTo(int iVerifyCode, java.io.OutputStream os) 将给定的验证码的图像数据输出到给定的输出流，较之writeImageTo速度更快， 但是消耗内存较多。
int | getCommonSize() 返回最终输出文件的文件长度，因为图像的高度和宽度都是固定的， 而且输出时不会采用压缩算法，所以最终输出的文件长度是固定的。
int | getDigitCount() 返回输出的验证码的宽度
java.lang.String | getDigitImage() 返回素材图片的文件名
java.lang.Exception | getErrMessage() 返回初始化发生的错误信息
byte[] | getImageData(int iVerifyCode) 返回给定的验证码的图像数据
int | getNoiseLevel() 返回噪声级别
static void | main(java.lang.String[] args) 用于启动测试代码，仅供测试使用。
void | setNoiseLevel(int i) 设置噪声级别 0：没有噪声，1：一个随机字节的噪声，2：两个字节相与后的噪声，3：三个字节相与后的噪声。
void | writeImageTo(int iVerifyCode, java.io.OutputStream os) 将给定的验证码的图像数据输出到给定的输出流
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VerifyCode

public VerifyCode(java.lang.String sDigitImage,
                  int iDigitWidth)
缺省构造方法

方法详细信息

main

public static void main(java.lang.String[] args)
用于启动测试代码，仅供测试使用。

参数：
args - 命令行参数

getErrMessage

public java.lang.Exception getErrMessage()
返回初始化发生的错误信息

返回：
初始化发生的错误信息

getDigitCount

public int getDigitCount()
返回输出的验证码的宽度

返回：
输出的验证码的宽度

getDigitImage

public java.lang.String getDigitImage()
返回素材图片的文件名

返回：
素材图片的文件名

getNoiseLevel

public int getNoiseLevel()
返回噪声级别

返回：
噪声级别

setNoiseLevel

public void setNoiseLevel(int i)
设置噪声级别 0：没有噪声，1：一个随机字节的噪声，2：两个字节相与后的噪声，3：三个字节相与后的噪声。 总之在级别大于0的情况下，级别越高，噪声越小。

参数：
i - 噪声级别

getCommonSize

public int getCommonSize()
返回最终输出文件的文件长度，因为图像的高度和宽度都是固定的， 而且输出时不会采用压缩算法，所以最终输出的文件长度是固定的。

返回：
最终输出文件的文件长度

getImageData

public byte[] getImageData(int iVerifyCode)
                    throws java.io.IOException
返回给定的验证码的图像数据

参数：
iVerifyCode - 给定的验证码
返回：
图像数据
抛出：
java.io.IOException

writeImageTo

public void writeImageTo(int iVerifyCode,
                         java.io.OutputStream os)
                  throws java.io.IOException
将给定的验证码的图像数据输出到给定的输出流

参数：
iVerifyCode - 给定的验证码
os - 给定的输出流
抛出：
java.io.IOException - 如果发生IO错误

fastWriteImageTo

public void fastWriteImageTo(int iVerifyCode,
                             java.io.OutputStream os)
                      throws java.io.IOException
将给定的验证码的图像数据输出到给定的输出流，较之writeImageTo速度更快， 但是消耗内存较多。

参数：
iVerifyCode - 给定的验证码
os - 给定的输出流
抛出：
java.io.IOException - 如果发生IO错误
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


VerifyCodeServlet

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trs.weblet.util.verfiycode
类 VerifyCodeServlet

java.lang.Object
    继承者  javax.servlet.GenericServlet
        继承者  javax.servlet.http.HttpServlet
            继承者  com.trs.weblet.util.verfiycode.VerifyCodeServlet
所有已实现的接口：
java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig
public class VerifyCodeServlet
extends javax.servlet.http.HttpServlet

用于以图片的形式显示验证码。 验证码，主要用在注册、登录和投票时，目的是为了防止使用注册机进行大量无效账号的注册， 使用程序模拟登录骗取积分，以及使用程序模拟投票进行作弊等行为。

作者：
Martin (Fu Chengrui)
另请参见：
序列化表格

构造方法摘要
VerifyCodeServlet()
缺省构造方法
方法摘要
void | destroy()
void | init()
从类 javax.servlet.http.HttpServlet 继承的方法
service
从类 javax.servlet.GenericServlet 继承的方法
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VerifyCodeServlet

public VerifyCodeServlet()
缺省构造方法

方法详细信息

init

public void init()
          throws javax.servlet.ServletException
覆盖：
类 javax.servlet.GenericServlet 中的 init
抛出：
javax.servlet.ServletException

destroy

public void destroy()
指定者：
接口 javax.servlet.Servlet 中的 destroy
覆盖：
类 javax.servlet.GenericServlet 中的 destroy
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trs.weblet.util.verfiycode.VerifyCode 的使用

上一个 下一个 框架 无框架

类 com.trs.weblet.util.verfiycode.VerifyCode
的使用

没有 com.trs.weblet.util.verfiycode.VerifyCode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trs.weblet.util.verfiycode.VerifyCodeServlet 的使用

上一个 下一个 框架 无框架

类 com.trs.weblet.util.verfiycode.VerifyCodeServlet
的使用

没有 com.trs.weblet.util.verfiycode.VerifyCodeServlet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


LogServiceProvider

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trsothers
类 LogServiceProvider

java.lang.Object
    继承者  com.trsothers.LogServiceProvider
所有已实现的接口：
ISelfDefinedServiceProvider, IServiceProvider
public class LogServiceProvider
extends java.lang.Object
implements ISelfDefinedServiceProvider

Title: TRS 内容协作平台（TRS WCM）
Description:
日志相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)

版本：
1.0
作者：
TRS信息技术有限公司

构造方法摘要
LogServiceProvider()
方法摘要
 void recordBrowserLog(MethodContext _methodContext)
记录客户端框架发过来的异常
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LogServiceProvider

public LogServiceProvider()
方法详细信息

recordBrowserLog

public void recordBrowserLog(MethodContext _methodContext)
                      throws java.lang.Throwable
记录客户端框架发过来的异常

参数：
_methodContext -
抛出：
java.lang.Throwable
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.trsothers
类
LogServiceProvider


com.trsothers

上一个软件包 下一个软件包 框架 无框架

软件包 com.trsothers

类摘要
LogServiceProvider Title: TRS 内容协作平台（TRS WCM）
Description:
日志相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)


com.trsothers 类分层结构

上一个 下一个 框架 无框架

软件包 com.trsothers 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trsothers.LogServiceProvider (implements com.trs.webframework.provider.ISelfDefinedServiceProvider)


软件包 com.trsothers 的使用

上一个 下一个 框架 无框架

软件包 com.trsothers
的使用

没有 com.trsothers 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.trsothers.LogServiceProvider 的使用

上一个 下一个 框架 无框架

类 com.trsothers.LogServiceProvider
的使用

没有 com.trsothers.LogServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


 com.trsupdate
类
RightUpdaterForUser


com.trsupdate

上一个软件包 下一个软件包 框架 无框架

软件包 com.trsupdate

类摘要
RightUpdaterForUser


com.trsupdate 类分层结构

上一个 下一个 框架 无框架

软件包 com.trsupdate 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.trsupdate.RightUpdaterForUser


软件包 com.trsupdate 的使用

上一个 下一个 框架 无框架

软件包 com.trsupdate
的使用

没有 com.trsupdate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


RightUpdaterForUser

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.trsupdate
类 RightUpdaterForUser

java.lang.Object
    继承者  com.trsupdate.RightUpdaterForUser

public class RightUpdaterForUser
extends java.lang.Object

构造方法摘要
RightUpdaterForUser(User _currUser, java.lang.String _sTableNameOfWCM52Right)
方法摘要
void | clear()
int | doResetRight()
static void | main(java.lang.String[] args)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RightUpdaterForUser

public RightUpdaterForUser(User _currUser,
                           java.lang.String _sTableNameOfWCM52Right)
方法详细信息

doResetRight

public int doResetRight()
                 throws WCMException
抛出：
WCMException

clear

public void clear()

main

public static void main(java.lang.String[] args)
参数：
args -
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


类 com.trsupdate.RightUpdaterForUser 的使用

上一个 下一个 框架 无框架

类 com.trsupdate.RightUpdaterForUser
的使用

没有 com.trsupdate.RightUpdaterForUser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


CreateThreadForPDF

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.wcm.pdf
类 CreateThreadForPDF

java.lang.Object
    继承者  com.wcm.pdf.CreateThreadForPDF

public class CreateThreadForPDF
extends java.lang.Object

构造方法摘要
CreateThreadForPDF(java.lang.String xmlfile, java.lang.String wordfile, java.lang.String pdffile, java.lang.String year)
方法摘要
 void createWord()
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CreateThreadForPDF

public CreateThreadForPDF(java.lang.String xmlfile,
                          java.lang.String wordfile,
                          java.lang.String pdffile,
                          java.lang.String year)
                   throws WCMException
抛出：
WCMException
方法详细信息

createWord

public void createWord()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CreateThreadForPDFOfWins

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

com.wcm.pdf
类 CreateThreadForPDFOfWins

java.lang.Object
    继承者  com.wcm.pdf.CreateThreadForPDFOfWins

public class CreateThreadForPDFOfWins
extends java.lang.Object

构造方法摘要
CreateThreadForPDFOfWins(java.lang.String xmlfile, java.lang.String wordfile, java.lang.String pdffile, java.lang.String year, javax.servlet.ServletContext application)
方法摘要
void | createWord()
void | initConfig(javax.servlet.ServletContext application)
从类 java.lang.Object 继承的方法
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CreateThreadForPDFOfWins

public CreateThreadForPDFOfWins(java.lang.String xmlfile,
                                java.lang.String wordfile,
                                java.lang.String pdffile,
                                java.lang.String year,
                                javax.servlet.ServletContext application)
                         throws java.lang.Exception
抛出：
java.lang.Exception
方法详细信息

initConfig

public void initConfig(javax.servlet.ServletContext application)
                throws java.lang.Exception
抛出：
java.lang.Exception

createWord

public void createWord()
概述 软件包 类 使用 树 已过时 索引 帮助
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


 com.wcm.pdf
类
CreateThreadForPDF
CreateThreadForPDFOfWins


com.wcm.pdf

上一个软件包 下一个软件包 框架 无框架

软件包 com.wcm.pdf

类摘要
CreateThreadForPDF
CreateThreadForPDFOfWins

概述 软件包 类 使用 树 已过时 索引 帮助
上一个软件包 下一个软件包 框架 无框架


com.wcm.pdf 类分层结构

上一个 下一个 框架 无框架

软件包 com.wcm.pdf 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • com.wcm.pdf.CreateThreadForPDF
    • com.wcm.pdf.CreateThreadForPDFOfWins
概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


软件包 com.wcm.pdf 的使用

上一个 下一个 框架 无框架

软件包 com.wcm.pdf
的使用

没有 com.wcm.pdf 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.wcm.pdf.CreateThreadForPDF 的使用

上一个 下一个 框架 无框架

类 com.wcm.pdf.CreateThreadForPDF
的使用

没有 com.wcm.pdf.CreateThreadForPDF 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


类 com.wcm.pdf.CreateThreadForPDFOfWins 的使用

上一个 下一个 框架 无框架

类 com.wcm.pdf.CreateThreadForPDFOfWins
的使用

没有 com.wcm.pdf.CreateThreadForPDFOfWins 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架


A - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

A

A - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
AbsHTMLMaker - com.trs.components.metadata.web 中的 类
AbsHTMLMaker() - 类 com.trs.components.metadata.web.AbsHTMLMaker 的构造方法
AbstractErrorMessage - com.trs.template 中的 异常
AbstractErrorMessage() - 异常 com.trs.template.AbstractErrorMessage 的构造方法
AbstractLogger - com.trs.webframework 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录器
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
AbstractLogger() - 类 com.trs.webframework.AbstractLogger 的构造方法
abstractPicSrc(String) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
AbstractTemplateSetting - com.trs.template.domain.setting 中的 类
AbstractTemplateSetting() - 类 com.trs.template.domain.setting.AbstractTemplateSetting 的构造方法
AbstractToUsersCreator - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AbstractToUsersCreator() - 类 com.trs.cms.process.engine.AbstractToUsersCreator 的构造方法
AbstractValidator - com.trs.wcag2.validator 中的 类
AbstractValidator() - 类 com.trs.wcag2.validator.AbstractValidator 的构造方法
AbstractXmlToObjConverter - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AbstractXmlToObjConverter(int) - 类 com.trs.infra.persistent.AbstractXmlToObjConverter 的构造方法
accept(Object) - 类 com.trs.components.metadata.service.ObjectsIterator 中的方法
判断当前传入的对象是否满足一定的条件
accept(String, IStatResult) - 接口 com.trs.components.stat.IStatResultFilter 中的方法
过滤结果集中的数据
accept(String, IStatResults) - 接口 com.trs.components.stat.IStatResultsFilter 中的方法
过滤结果集集合中的数据
accept(File) - 类 com.trs.components.wcm.content.domain.intelligence.FilePathFilter 中的方法
accept(File, String) - 类 com.trs.infra.util.CMyFilenameFilter 中的方法
accept(File, String) - 类 com.trs.infra.util.FileNameExtFilter 中的方法
aClassInfoRootId - 类 com.trs.util.ResetClassInfoOfViewData 中的变量
ACTION - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
ACTION_DELETE - 类 com.trs.cms.process.definition.FlowNode 中的静态变量
节点上可以进行的操作类型：删除 1
ACTION_EDIT - 类 com.trs.cms.process.definition.FlowNode 中的静态变量
节点上可以进行的操作类型：编辑 0
ACTION_FLAG_NORMAL - 类 com.trs.cms.process.FlowingDocLogger 中的静态变量
ACTION_FLAG_PREPROCESS - 类 com.trs.cms.process.FlowingDocLogger 中的静态变量
ACTION_PUBLISH - 类 com.trs.cms.process.definition.FlowNode 中的静态变量
节点上可以进行的操作类型：发布 2
ActionHandlerConfig - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ActionHandlerConfig() - 类 com.trs.cms.process.config.ActionHandlerConfig 的构造方法
ActionParametersAnalyser - com.trs.cms.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ActionParametersAnalyser(String) - 类 com.trs.cms.process.engine.handlers.ActionParametersAnalyser 的构造方法
ActorHelper - com.trs.presentation.ids 中的 类
ActorHelper() - 类 com.trs.presentation.ids.ActorHelper 的构造方法
adapterHistory(MethodContext) - 类 com.trs.ajaxservice.InfoviewDataToolService 中的方法
1.为系统所有视图创建表结构
2.替换视图的检索字段，概览字段，自动生成相应的DB字段
3.替换栏目的检索字段，自动生成相应的DB字段
4.同步文档的DocFlag到ChnlDoc表中
ADAPTIVE_CHAR - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
布局比例中表示自适应列的字符
ADAY_MILLIS - 类 com.trs.infra.util.CMyDateTime 中的静态变量
1 天的时间数（毫秒数）
ADCom - com.trs.components.common.trsad 中的 类
ADCom() - 类 com.trs.components.common.trsad.ADCom 的构造方法
构造函数：保留默认接口
ADComs - com.trs.components.common.trsad 中的 类
ADComs(User) - 类 com.trs.components.common.trsad.ADComs 的构造方法
构造函数
ADComs(User, int, int) - 类 com.trs.components.common.trsad.ADComs 的构造方法
构造函数
add(Object) - 接口 com.trs.components.common.publish.persistent.element.IPublishElements 中的方法
Adds an element into the collection.
add(Object) - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 中的方法
Adds an element into collection.
add(Object) - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 中的方法
Adds an element into collection.
add(Object) - 类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 中的方法
Adds an element into collection.
add(String, int) - 类 com.trs.components.wcm.epress.EPressConf 中的方法
add(int, int) - 类 com.trs.components.wcm.recent.RecentMgr 中的方法
根据对象类型和ID，将当前对象添加到最近访问的对象中
如果没有超过每个对象的记录个数，则新增。
add(ConfigFile) - 类 com.trs.infra.config.persistent.ConfigFiles 中的方法
add(double, double) - 类 com.trs.infra.util.CMyDecimalBuddy 中的静态方法
加法运算。
add(String) - 类 com.trs.infra.util.CMyErrors 中的方法
添加错误
add(Exception) - 类 com.trs.infra.util.CMyErrors 中的方法
添加错误
add(String, Exception) - 类 com.trs.infra.util.CMyErrors 中的方法
add(CMyErrors) - 类 com.trs.infra.util.CMyErrors 中的方法
添加错误
add(Reports) - 类 com.trs.infra.util.Reports 中的方法
add(Parameter) - 类 com.trs.presentation.util.AppAutoParameters 中的方法
add(Parameter) - 类 com.trs.presentation.util.Parameters 中的方法
添加参数对象
add(int, int) - 类 com.trs.service.impl.RecentService 中的方法
add(int, String) - 类 com.trs.service.impl.RecentService 中的方法
add(int, String) - 接口 com.trs.service.IRecentService 中的方法
添加最近访问的WCM对象
add(int, int) - 接口 com.trs.service.IRecentService 中的方法
添加最近访问的WCM对象
add(IInfoEntity) - 类 com.trs.template.persistent.InfoEntities 中的方法
add(String, Throwable) - 类 com.trs.webframework.config.LoadingErrorReport 中的方法
addAdministrator(User) - 类 com.trs.cms.auth.persistent.Group 中的方法
更新用户所属用户组缓冲区（添加）
addAppendix(User, String, boolean) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
添加一个模板附件
addAppendix(Document, Appendix) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
新增附件
addAppendixes(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
添加指定文档的相关文档 只做新增
addAttachedFile(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
addAttachedFile(String, String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
addAttrInfo(TagBeanAttrInfo) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
添加置标属性信息对象，如果相同名称的置标属性信息对象已经存在，则将被替换，并返回。
addAutoLink(String, String, String, PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
生成带有链接的HTML文本
addBeans(BeanConfig) - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
addBorder(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
addButton(MenuButton) - 类 com.trs.components.infoview.extract.manifest.MenuArea 中的方法
addChangeListener(DistributionChangeListener) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
增加监听配置信息改变的监听器
addChild(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
add a TagItem child
addChild(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
add a string child
addChild(DataType) - 类 com.trs.components.infoview.extract.DataType 中的方法
addChild(VChannel) - 类 com.trs.components.wcm.channel.VChannel 中的方法
addChild(String, XmlObject[]) - 类 com.trs.infra.persistent.XmlObject 中的方法
addChild(CMyXMLElement) - 类 com.trs.infra.util.CMyXMLElement 中的方法
addChild(TreeItem) - 类 com.trs.presentation.navigation.TreeItem 中的方法
addChildElements(Element, Element[]) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
addChildNode(String, int) - 类 com.trs.scene.tools.SceneNode 中的方法
添加一个子节点
addChildren(List) - 类 com.trs.components.wcm.channel.VChannel 中的方法
addChnlDoc(int, int) - 类 com.trs.service.impl.RecentService 中的方法
addChnlDoc(int, int) - 接口 com.trs.service.IRecentService 中的方法
添加最近访问的ChnlDoc
addColumn(Column) - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法
addColumn(Column, int) - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
添加比较结果的列
addConfigElements(IConfigElement) - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法
addContact(Contact, User) - 类 com.trs.components.common.address.ContactGrp 中的方法
添加新的非系统用户到该组 参数：_Contact：要添加的非系统用户对象；_opUser：操作者（添加该用户的用户） 返回值：若参数_Contact无效，则抛出异常； 若已存在，则返回false; 若成功，则返回true
addContact(Contact, ContactGrp) - 类 com.trs.components.common.address.ContactMgr 中的方法
添加联系人到指定的组中
addContact(String, int) - 接口 com.trs.service.IContactService 中的方法
添加联系人到指定的组中
addContact(int, int) - 接口 com.trs.service.IContactService 中的方法
添加联系人到指定的组中
addContact(Contact, ContactGrp) - 接口 com.trs.service.IContactService 中的方法
添加联系人到指定的组中
addContact(String, int) - 类 com.trs.service.impl.ContactService 中的方法
addContact(int, int) - 类 com.trs.service.impl.ContactService 中的方法
addContact(Contact, ContactGrp) - 类 com.trs.service.impl.ContactService 中的方法
addContactFromSystemUser(User) - 类 com.trs.components.common.address.ContactMgr 中的方法
导入系统用户为联系人
addContactFromSystemUser(int) - 接口 com.trs.service.IContactService 中的方法
导入系统用户为联系人
addContactFromSystemUser(User) - 接口 com.trs.service.IContactService 中的方法
导入系统用户为联系人
addContactFromSystemUser(int) - 类 com.trs.service.impl.ContactService 中的方法
addContactFromSystemUser(User) - 类 com.trs.service.impl.ContactService 中的方法
addContent(HtmlComment) - 类 com.trs.infra.util.html.HtmlDocument 中的方法
在文档内容列表中，添加一个注释对象
addContent(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
添加内容
addContent(HtmlElement) - 类 com.trs.infra.util.html.HtmlElement 中的方法
添加一个HtmlElement
addContent(HtmlComment) - 类 com.trs.infra.util.html.HtmlElement 中的方法
添加一个注释对象
addContentField(FlowContentField) - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
addContentTypeConfig(FlowContentTypeConfig) - 类 com.trs.cms.process.config.FlowConfigServer 中的方法
AddEditFieldTemplate - com.trs.components.metadata.web.impl 中的 类
AddEditFieldTemplate() - 类 com.trs.components.metadata.web.impl.AddEditFieldTemplate 的构造方法
addElement(int, String, String, String) - 类 com.trs.ajaxservice.ContentExtendValues 中的方法
addElement(BaseObj) - 类 com.trs.infra.persistent.BaseObjs 中的方法
添加一个元素
addElement(BaseObj, int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
addElement(String) - 类 com.trs.infra.persistent.BaseObjs 中的方法
addElement(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
addElement(Integer) - 类 com.trs.infra.persistent.BaseObjs 中的方法
addElement(int, int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
addElementById(int) - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
addElements(BaseObjs) - 类 com.trs.infra.persistent.BaseObjs 中的方法
addEnumItem(int, String, Object, int) - 类 com.trs.components.infoview.config.EnumsConfig 中的方法
addEnumValue(String) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
添加可选择变量值的枚举
addEnumValue(String, String) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
添加可选择变量值的枚举
addErrorLog(int, String, String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
记录发布过程中产生的错误日志
addErrorLog(int, String, Throwable) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
记录发布过程中产生的错误日志
addErrorLog(int, IPublishElement, String, String) - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
记录发布过程中产生的错误日志
addErrorLog(int, IPublishElement, String, Throwable) - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
记录发布过程中产生的错误日志
addErrorLog(User, IPublishElement, String, int, String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
add error log for a folder publish page task
addExtensions(ExtensionConfigs) - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
addExtField(CMSObj, ContentExtField, int) - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 中的方法
addExtFieldToChildren(CMSObj, ContentExtField) - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 中的方法
addExtFieldToSpeicficChildren(String, String, ContentExtField) - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 中的方法
addFailedReport(String, Throwable) - 类 com.trs.infra.util.Reports 中的方法
添加操作失败报告
当操作失败时使用
addField(InfoViewField) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
addFileExtFilters(String) - 类 com.trs.infra.util.CMyUnZipFile 中的方法
添加需要过滤的文件扩展名
addFromFile(String, String) - 类 com.trs.webframework.config.ServiceFilterConfigs 中的方法
addFromFile(String, String) - 类 com.trs.webframework.config.ServiceListenerConfigs 中的方法
addGroup(Group, Role) - 类 com.trs.cms.auth.domain.GroupRoleMgr 中的方法
addGroup(InfoViewGroup) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
addGroup(SSOGroup, HttpServletRequest) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
添加组织
addGroupsToSite(String, WebSite) - 接口 com.trs.service.IChannelService 中的方法
给指定的站点添加指定的用户组
addGroupsToSite(String, WebSite) - 类 com.trs.service.impl.ChannelService 中的方法
addImageMark(String, String) - 类 com.trs.wcm.photo.impl.JImageMarkUtil 中的静态方法
addImageMark(String, String, int[]) - 类 com.trs.wcm.photo.impl.JImageMarkUtil 中的静态方法
addImportCount(int) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
记录导入的文档数
addImportCount() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
addImportSource(String) - 类 com.trs.presentation.documetimport.xml.DocumentImportXmlHelper 中的静态方法
新建一个文档导入的映射文件 just for document/document_xml_add_dowith.jsp
addInfoViewField(String, String) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
在xml中增加一个不存在的普通节点
addInfoViewField(String, String) - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
增加一个普通的字段节点
addInfoViewRepeatData(String, HashMap) - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
增加重复表的一行或者一个完整的重复表结构
addItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 中的方法
add a TagItem item
addItem(String) - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 中的方法
add a string item
addJob(String, Class, String, CMyDateTime) - 类 com.trs.infra.util.job.JobScheduler 中的方法
addJob(String, Class, String, CMyDateTime, CMyDateTime, long) - 类 com.trs.infra.util.job.JobScheduler 中的方法
addJob(String, Class, String, long) - 类 com.trs.infra.util.job.JobScheduler 中的方法
addJob(String, Class, String, String) - 类 com.trs.infra.util.job.JobScheduler 中的方法
addJob(String, Class, String, String[]) - 类 com.trs.infra.util.job.JobScheduler 中的方法
addJob(String, Class, String, Trigger) - 类 com.trs.infra.util.job.JobScheduler 中的方法
addLinkInChannel(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
addMainObjs(IStatResult) - 类 com.trs.components.stat.StatResults 中的方法
添加主体对象
addManager(User, Group) - 接口 com.trs.service.IGroupService 中的方法
将指定用户设置为某个组的管理员
注意: 指定的用户必须在指定组中
addManager(User, Group) - 类 com.trs.service.impl.GroupService 中的方法
addMediaReminded(int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
给指定的媒体增加更新
addMenuArea(MenuArea) - 类 com.trs.components.infoview.extract.manifest.View 中的方法
addMsgEvent(User, Users, String, String, int) - 接口 com.trs.cms.process.IFlowNotifyWorker 中的方法
addMsgEvent(User, Users, String, String, String) - 接口 com.trs.cms.process.IFlowNotifyWorker 中的方法
addMsgEvent(User, User, String, String, String) - 接口 com.trs.cms.process.IFlowNotifyWorker 中的方法
addMsgEvent(User, Users, String, String, int) - 类 com.trs.components.wcm.process.FlowNotifyWorkerImpl 中的方法
addMsgEvent(User, Users, String, String, String) - 类 com.trs.components.wcm.process.FlowNotifyWorkerImpl 中的方法
addMsgEvent(User, User, String, String, String) - 类 com.trs.components.wcm.process.FlowNotifyWorkerImpl 中的方法
addNeedImportFile(String) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
添加需要导入的ZIP文件
addNestedParameters(IPublishElement, Template, TemplateParameterList) - 类 com.trs.service.impl.TemplateService 中的方法
addNestRecord(int, IPublishFolder, String) - 类 com.trs.components.common.publish.domain.template.TemplateNestMgr 中的方法
add a template nest record
addNestRecord(int, int) - 类 com.trs.components.common.publish.domain.template.TemplateNestMgr 中的方法
add a template nest record
addNew() - 类 com.trs.infra.persistent.BaseObjs 中的方法
新建一个对象元素
addNewDocKeywords(Document) - 类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 中的方法
addNewDocKeywords(Document) - 接口 com.trs.components.wcm.content.domain.IDocKeywordMgr 中的方法
增加指定文档的相关新闻记录
addNextConnector(SceneConnector) - 类 com.trs.scene.parser.SceneNode 中的方法
addOperatorConfig(OperatorConfig) - 类 com.trs.cms.process.config.ParamConfig 中的方法
addParamConfig(ParamConfig) - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法
addParamConfig(ParamConfig) - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法
addParameter(TemplateParameter) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 中的方法
向参数列表中增加参数
addParameterList(TemplateParameterList) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 中的方法
在批模式下，增加参数列表
addParameters(WidgetInstance, Map) - 接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr 中的方法
给资源块实例对象设置相应的资源库实例变量,设置这些变量值之前，将清除该实例之前的所有变量
addParameters(WidgetInstance, Map) - 类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 中的方法
addPubStatus(int) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
添加站点的可发布文档状态
addPubStatus(Status) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
添加站点的可发布文档状态
addRelation(int) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
增加模板和附件的关联
addRelation(Template) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
增加模板和附件的关联
addRemindedSource(User, int, int, int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态方法
指定的用户设置指定媒体提醒的频率
addRepeatFieldGroup(String, HashMap) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
增加一个重复表结构
addRepeatFieldLine(String, HashMap) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
将需要新增加的重复表的一行记录下来
addReport(Report) - 类 com.trs.infra.util.Reports 中的方法
增加一个Report
ADDRESS - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
addResult(IStatResult) - 接口 com.trs.components.stat.IStatResults 中的方法
向结果集的集合中添加结果集
addResult(IStatResult) - 类 com.trs.components.stat.StatResults 中的方法
添加每一个步长的结果集到总结果集中
addRolesToSite(String, WebSite) - 接口 com.trs.service.IChannelService 中的方法
给指定的站点添加指定的角色
addRolesToSite(String, WebSite) - 类 com.trs.service.impl.ChannelService 中的方法
addSearchValues(int, int) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(int) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(int, float) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(float) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(int, double) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(double) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(int, String) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(String) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(int, CMyDateTime) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(CMyDateTime) - 类 com.trs.infra.db.QueryFilter 中的方法
addSearchValues(int, int) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(int) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(long) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(int, float) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(float) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(int, double) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(double) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(int, String) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(String) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(int, CMyDateTime) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSearchValues(CMyDateTime) - 类 com.trs.infra.persistent.WCMFilter 中的方法
addSelectField(String, String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
addSiteGroup(WebSite, Group) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
添加站点用户组
将指定的用户组添加到指定的站点
addSiteMember(int, int, int) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
addSitesToGroup(String, Group) - 接口 com.trs.service.IChannelService 中的方法
给指定的用户组添加指定的站点
addSitesToGroup(String, Group) - 类 com.trs.service.impl.ChannelService 中的方法
addSitesToUser(String, User) - 接口 com.trs.service.IChannelService 中的方法
给指定的用户添加指定的站点
addSitesToUser(String, User) - 类 com.trs.service.impl.ChannelService 中的方法
addSiteUser(WebSite, User) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
添加站点用户
将指定的用户添加到指定的站点
addSpanStyleIfNeeded(PublishTagContext, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
如果有必要在文本外面套上
addSpanStyleIfNeeded(PublishTagContext, String[]) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
如果有必要在文本外面套上 <span class="CLASSNAME">xxx</span>
addStatus(int) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
addStatus(Status) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
addSucessedReport(String) - 类 com.trs.infra.util.Reports 中的方法
添加操作成功报告
当一个操作成功时使用
addToUser(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
添加呈送人员
addToUser(User) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
添加呈送人员
addToZip(String) - 类 com.trs.infra.util.CMyZip 中的方法
addToZip(String, String) - 类 com.trs.infra.util.CMyZip 中的方法
addToZip(String, boolean) - 类 com.trs.infra.util.CMyZip 中的方法
将指定文件或目录，添加到压缩包
addUnImportCount(int) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
记录没有导入的文档数
addUnImportCount() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
addUser(User, Group) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
将用户加到指定组织中去
addUser(User, Role) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
已过时。 权限模型调整，需要引入站点id.
addUser(Role, int, User) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
添加指定用户到指定的角色
addUser(int, User) - 类 com.trs.cms.auth.persistent.Group 中的方法
添加新的用户到该组
addUser(int, User, boolean) - 类 com.trs.cms.auth.persistent.Group 中的方法
addUser(User, User) - 类 com.trs.cms.auth.persistent.Group 中的方法
addUser(User, User, boolean) - 类 com.trs.cms.auth.persistent.Group 中的方法
添加新的用户到该组
addUser(SSOUser, HttpServletRequest) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
添加用户
addUser(User, Group) - 接口 com.trs.service.IGroupService 中的方法
将指定用户添加个指定的组中
addUser(User, Group) - 类 com.trs.service.impl.GroupService 中的方法
addUser(User, Role) - 类 com.trs.service.impl.RoleService 中的方法
addUser(User, Role) - 接口 com.trs.service.IRoleService 中的方法
添加指定的用户到指定的角色
addUsersToSite(String, WebSite) - 接口 com.trs.service.IChannelService 中的方法
给指定的站点添加指定的用户
addUsersToSite(String, WebSite) - 类 com.trs.service.impl.ChannelService 中的方法
addValueConfig(ValueConfig) - 类 com.trs.cms.process.config.ParamConfig 中的方法
addWarnedReport(String, Throwable) - 类 com.trs.infra.util.Reports 中的方法
添加操作警告报告
当操作不会导致失败,但需要告知操作者时使用
addWarning(String, int, String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
add warning
addWarning(String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
add warning
addWarning(String, int, String) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
addWarning(String) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
addWaterkmark(String, String, int[]) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法
addWaterMark(String, int[]) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
添加图片水印
addWatermark(String, String, int[]) - 类 com.trs.wcm.photo.impl.JMarkUtilX 中的静态方法
给图片添加指定的水印图片
addWaterMark(String, int[]) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
addWith(BaseObjs) - 类 com.trs.infra.persistent.BaseObjs 中的方法
与指定集合做加法运算
addXlabels(String) - 接口 com.trs.components.stat.IStatResults 中的方法
添加页面中走势图的下标集合
addXlabels(String) - 类 com.trs.components.stat.StatResults 中的方法
ADFile - com.trs.components.common.trsad 中的 类
ADFile() - 类 com.trs.components.common.trsad.ADFile 的构造方法
构造函数：保留默认接口
ADFilePos - com.trs.components.common.trsad 中的 类
ADFilePos() - 类 com.trs.components.common.trsad.ADFilePos 的构造方法
构造函数：保留默认接口
ADFilePoss - com.trs.components.common.trsad 中的 类
ADFilePoss(User) - 类 com.trs.components.common.trsad.ADFilePoss 的构造方法
构造函数
ADFilePoss(User, int, int) - 类 com.trs.components.common.trsad.ADFilePoss 的构造方法
构造函数
ADFiles - com.trs.components.common.trsad 中的 类
ADFiles(User) - 类 com.trs.components.common.trsad.ADFiles 的构造方法
构造函数
ADFiles(User, int, int) - 类 com.trs.components.common.trsad.ADFiles 的构造方法
构造函数
AdjustJsLCListenerWidget - com.trs.components.common.publish.widget 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
AdjustJsLCListenerWidget() - 类 com.trs.components.common.publish.widget.AdjustJsLCListenerWidget 的构造方法
Adler32 - com.trs.infra.util.jazzlib 中的 类
Computes Adler32 checksum for a stream of data.
Adler32() - 类 com.trs.infra.util.jazzlib.Adler32 的构造方法
Creates a new instance of the Adler32 class.
AdmanageConfigServiceImpl - com.trs.components.common.conjection.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AdmanageConfigServiceImpl() - 类 com.trs.components.common.conjection.service.AdmanageConfigServiceImpl 的构造方法
AdministratorCacheMgr - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理员角色用户缓冲管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AdministratorCacheMgr() - 类 com.trs.cms.auth.persistent.AdministratorCacheMgr 的构造方法
ADMINISTRATORS_ID - 类 com.trs.cms.auth.persistent.Role 中的静态变量
系统管理员固定的ID值
ADPos - com.trs.components.common.trsad 中的 类
ADPos() - 类 com.trs.components.common.trsad.ADPos 的构造方法
构造函数：保留默认接口
ADPoss - com.trs.components.common.trsad 中的 类
ADPoss(User) - 类 com.trs.components.common.trsad.ADPoss 的构造方法
构造函数
ADPoss(User, int, int) - 类 com.trs.components.common.trsad.ADPoss 的构造方法
构造函数
ADType - com.trs.components.common.trsad 中的 类
ADType() - 类 com.trs.components.common.trsad.ADType 的构造方法
构造函数：保留默认接口
ADTypes - com.trs.components.common.trsad 中的 类
ADTypes(User) - 类 com.trs.components.common.trsad.ADTypes 的构造方法
构造函数
ADTypes(User, int, int) - 类 com.trs.components.common.trsad.ADTypes 的构造方法
构造函数
AdvSearchNavHandler - com.trs.presentation.nav 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AdvSearchNavHandler() - 类 com.trs.presentation.nav.AdvSearchNavHandler 的构造方法
aFieldInfo - 类 com.trs.util.ResetClassInfoOfViewData 中的变量
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.ajaxservice.listener.MoveChannelListenerForChannel 中的方法
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.ajaxservice.listener.SaveMembersListenerForObjectMember 中的方法
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.components.metadata.service.listener.ChannelCreateFromListenerForMetaView 中的方法
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.components.metadata.service.listener.PublishListenerForPubGovInfo 中的方法
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.components.metadata.service.listener.ViewDocumentListenerForPubGovInfo 中的方法
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.components.wcm.content.domain.DocumentMoveListenerForDocSiteRecode 中的方法
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.components.wcm.publish.region.CellsSaveListenerForPublish 中的方法
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.components.wcm.publish.region.TemplateSaveListenerForRegionEmploy 中的方法
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 接口 com.trs.webframework.provider.IServiceListener 中的方法
在服务执行完以后执行指定的操作，可以： 1、结合给服务传入的参数和服务执行后的返回值，执行指定的业务行为 2、结合给服务传入的参数和服务执行后的返回值，处理返回值
afterServiceExecuted(ServiceListenerConfig, MethodContext, Object) - 类 com.trs.webframework.provider.ServiceListenerExample 中的方法
Alertion - com.trs.wcag2 中的 类
Alertion() - 类 com.trs.wcag2.Alertion 的构造方法
ALIGN - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
ALINK - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
ALL_BYPASS - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
不进行权限校验的索引值
ALL_REMIND_TYPES - 类 com.trs.components.common.calendar.Event 中的静态变量
ALL_TEMPLATE - 类 com.trs.components.common.publish.persistent.template.Template 中的静态变量
已过时。 please use PublishConstants.TEMPLATE_TYPE_ANY
ALL_TYPES - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
所有文档类型
AllDDLMaker - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
从sqserver数据库中得到其它数据库的ddl(包含建表/索引语句)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
AllDDLMaker(String[]) - 类 com.trs.database.util.AllDDLMaker 的构造方法
allFields() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
allGroups() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
allProgressMonitor() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 中的方法
以java.util.Iterator的形式返回所有的任务监控器
allProgressMonitor() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
以java.util.Iterator的形式返回所有的任务监控器， 包括发布任务自身的监控器和分解后子任务的监控器。
ALT - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
analyer() - 类 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer 中的方法
analyze() - 类 com.trs.tools.LocalServerAuto 中的方法
analyzeFile(File) - 类 com.trs.tools.LocalServerAuto 中的方法
analyzePath(File) - 类 com.trs.tools.LocalServerAuto 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.comment.publish.tagparser.XWCMTagParserComment 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 中的方法
analyzeQuotes(IPublishFolder) - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser 中的方法
Analyzes the quote relations between this template and folders.
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserCondition 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserDateTime 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserEcho 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserRepeat 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariable 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoView 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.metadata.publish.WCMTagParserAppendix 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.metadata.publish.WCMTagParserClassDocuments 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.metadata.publish.WCMTagParserClassIndexGener 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.metadata.publish.WCMTagParserViewDatas 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.epress.TagEBookDirParser 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.epress.TagMapAreaParser 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.epress.TagParserPageNav 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.epress.TagPreNextParser 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.region.WCMTagParserRegion 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.TagChannelChainParser 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.TagParserCRUser 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImage 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImages 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.TagWmlContentParser 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration 中的方法
analyzeQuotes(IPublishFolder) - 类 com.trs.wcmonline.TagParserVipMetaData 中的方法
analyzer(String[]) - 类 com.trs.tools.ResourceAnalyzer 中的静态方法
analyzerFile(String) - 类 com.trs.tools.ResourceAnalyzer 中的静态方法
analyzerFolder(String) - 类 com.trs.tools.ResourceAnalyzer 中的静态方法
and(CMyBitsValue) - 类 com.trs.infra.util.CMyBitsValue 中的方法
按位进行“与”运算
and(long) - 类 com.trs.infra.util.CMyBitsValue 中的方法
按位进行“与”运算
AndinOraDB - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Andin加密处理,Oracle数据库.
AndinOraDB() - 类 com.trs.infra.util.database.AndinOraDB 的构造方法
AndinOraDB(String, String) - 类 com.trs.infra.util.database.AndinOraDB 的构造方法
构造函数
注：支持存储过程
ApdHostLCListener - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ApdHostLCListener() - 类 com.trs.components.wcm.content.domain.ApdHostLCListener 的构造方法
APP_BUILD - 类 com.trs.infra.BaseServer 中的变量
系统内部版本号
APP_BUILD_TIME - 类 com.trs.infra.BaseServer 中的变量
Build时间
APP_VERSION - 类 com.trs.infra.BaseServer 中的静态变量
版本信息
APP_VERSION - 类 com.trs.infra.ServerControl 中的静态变量
AppAutoParameter - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
代码自动生工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AppAutoParameter() - 类 com.trs.presentation.util.AppAutoParameter 的构造方法
AppAutoParameters - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理应用程序自动化
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AppAutoParameters() - 类 com.trs.presentation.util.AppAutoParameters 的构造方法
AppAutoParameters(int) - 类 com.trs.presentation.util.AppAutoParameters 的构造方法
append(String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseResults 中的方法
Appends a string to each of current results
append(String[]) - 类 com.trs.components.common.publish.domain.tagparser.TagParseResults 中的方法
Appends the product of the specified results and current results.
append(Map) - 类 com.trs.components.web.BasePropertiesBuilder 中的方法
append(Map) - 接口 com.trs.components.web.IPropertiesBuilder 中的方法
追加一些属性对
appendDefaultFields(User, int) - 类 com.trs.components.infoview.db.InfoViewDBMgr 中的方法
appendDefaultFields(User, MetaDBTable) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
给自定的表追加默认的字段
appendDefaultFields(User, MetaDBTable) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
appendFile(String, String) - 类 com.trs.infra.util.CMyFile 中的静态方法
把指定的内容_sAddContent追加到文件_sFileName中
Appendix - com.trs.components.wcm.content.persistent 中的 类
Appendix() - 类 com.trs.components.wcm.content.persistent.Appendix 的构造方法
APPENDIX_FLAG_ALL - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
APPENDIX_FLAG_DOCAPD - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
APPENDIX_FLAG_DOCCON - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
APPENDIX_FLAG_DOCPIC - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
APPENDIX_FLAG_HTMLPIC - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
APPENDIX_FLAG_LINK - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
Appendixes - com.trs.components.wcm.content.persistent 中的 类
Appendixes(User) - 类 com.trs.components.wcm.content.persistent.Appendixes 的构造方法
Appendixes(User, int, int) - 类 com.trs.components.wcm.content.persistent.Appendixes 的构造方法
AppendixMgr - com.trs.components.wcm.content.domain 中的 类
AppendixMgr() - 类 com.trs.components.wcm.content.domain.AppendixMgr 的构造方法
AppendixToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
附件的XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AppendixToXML() - 类 com.trs.ajaxservice.xmlconvertors.AppendixToXML 的构造方法
appendJsAndCsses(String) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
appendNamedParam(String, String) - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法
appendParam(String) - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法
appendSendLogs(String) - 类 com.trs.infra.util.email.CMyMailLog 中的方法
在日志中添加一行，自动加上回车换行标志
APPLET - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
APPLY_CERTIFICATENAME_IDENTITY - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
APPLY_CERTIFICATENAME_OFFICER - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
APPLY_CERTIFICATENAME_STUDENT - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
证件类型
APPLY_CERTIFICATENAME_WORKER - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
APPLYER_TYPE_COMPANY - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
APPLYER_TYPE_PERSON - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
申请者类型
applyForLabor(int, int) - 接口 com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr 中的方法
apply for labor
applyForLabor(int, int) - 类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 中的方法
apply for labor
ApplyForm - com.trs.components.gkml.sqgk.persistent 中的 类
ApplyForm() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 的构造方法
构造函数：保留默认接口
ApplyFormConstants - com.trs.components.gkml.sqgk.constant 中的 类
ApplyFormConstants() - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 的构造方法
ApplyFormDealLog - com.trs.components.gkml.sqgk.persistent 中的 类
ApplyFormDealLog() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 的构造方法
构造函数：保留默认接口
ApplyFormDealLogs - com.trs.components.gkml.sqgk.persistent 中的 类
ApplyFormDealLogs(User) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 的构造方法
构造函数
ApplyFormDealLogs(User, int, int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 的构造方法
构造函数
ApplyFormReplyHandler - com.trs.components.gkml.sqgk.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ApplyFormReplyHandler() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler 的构造方法
ApplyForms - com.trs.components.gkml.sqgk.persistent 中的 类
ApplyForms(User) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForms 的构造方法
构造函数
ApplyForms(User, int, int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForms 的构造方法
构造函数
ApplyFormServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ApplyFormServiceProvider() - 类 com.trs.ajaxservice.ApplyFormServiceProvider 的构造方法
ApplyFormToUsersCreator - com.trs.components.gkml.sqgk.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ApplyFormToUsersCreator() - 类 com.trs.components.gkml.sqgk.process.engine.creators.ApplyFormToUsersCreator 的构造方法
ApplyFormTypeHandler - com.trs.components.gkml.sqgk.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ApplyFormTypeHandler() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler 的构造方法
ARCHIVE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
archiveLogs(CMyDateTime) - 类 com.trs.infra.support.log.LogServer 中的静态方法
对特定时间之前的所有日志进行归档
AREA - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
arExcludeClass - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
arExcludeClass - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
ARGUMENT - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType 中的静态变量
在开始置标和结束置标之间是置标的参数，不能为空
assertSignData(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
atFirstPage() - 类 com.trs.infra.util.CPager 中的方法
判断是否是在第一页
atLastPage() - 类 com.trs.infra.util.CPager 中的方法
判断是否是在最后一页
ATTACH_ALL_APPENDIX - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 中的静态变量
ATTACH_FIRST_APPENDIX - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 中的静态变量
attachObserver(IObserver) - 接口 com.trs.webframework.xmlserver.server.IObserverable 中的方法
attachObserver(IObserver) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法
ATTR_NAME_CURRPAGE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
ATTR_NAME_METHODCONTEXT - 类 com.trs.webframework.FrameworkConstants 中的静态变量
ATTR_NAME_NUM - 类 com.trs.webframework.FrameworkConstants 中的静态变量
ATTR_NAME_PAGER - 类 com.trs.webframework.FrameworkConstants 中的静态变量
ATTR_NAME_PAGESIZE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
ATTR_NAME_RESULT - 类 com.trs.webframework.FrameworkConstants 中的静态变量
ATTR_NAME_SEARCHKEY - 类 com.trs.webframework.context.MethodContextHelper 中的静态变量
ATTR_NAME_SEARCHVALUE - 类 com.trs.webframework.context.MethodContextHelper 中的静态变量
ATTR_TYPE - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的静态变量
ATTR_VALUE_FIRST_PAGE_INDEX - 类 com.trs.webframework.FrameworkConstants 中的静态变量
ATTRIBUTE_DELIM - 类 com.trs.infra.util.AttributesString 中的静态变量
属性之间的分割符
ATTRIBUTES_DILIM - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的静态变量
AttributesString - com.trs.infra.util 中的 类
AttributesString() - 类 com.trs.infra.util.AttributesString 的构造方法
AttributesString(String) - 类 com.trs.infra.util.AttributesString 的构造方法
直接使用属性字符串构造对象
ATTRNAME_CURR_NESTTAGITEM - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的静态变量
AuthHelper - com.trs.cms.auth 中的 类
AuthHelper() - 类 com.trs.cms.auth.AuthHelper 的构造方法
AuthServer - com.trs.cms.auth.domain 中的 类
AuthServer() - 类 com.trs.cms.auth.domain.AuthServer 的构造方法
AuthServerMgr - com.trs.components.metadata.right 中的 类
AuthServerMgr() - 类 com.trs.components.metadata.right.AuthServerMgr 的构造方法
AuthServiceProvider - com.trs.ajaxservice 中的 类
AuthServiceProvider() - 类 com.trs.ajaxservice.AuthServiceProvider 的构造方法
AUTO_SAVE_CHG_STATUS - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
允许自动保存版本的文档操作索引：改变状态(1)
AUTO_SAVE_EDIT - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
允许自动保存版本的文档操作索引：编辑文档(0)
AUTO_SAVE_KEY - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
站点保存版本配置关键字：允许自动保存的文档操作(SITE_AUTO_SAVE)
AUTO_SAVE_PUBLISH - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
允许自动保存版本的文档操作索引：发布文档(2)
AutoBakConfig - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
自动保存配置信息存储对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AutoBakConfig() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 的构造方法
构造函数：保留默认接口
AutoBakConfigs - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
版本自动保存配置信息集合对象 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AutoBakConfigs(User) - 类 com.trs.components.wcm.content.persistent.AutoBakConfigs 的构造方法
AutoBakConfigs(User, int, int) - 类 com.trs.components.wcm.content.persistent.AutoBakConfigs 的构造方法
autoBakDocument(Document, int) - 类 com.trs.components.wcm.content.domain.AutoDocBakMgr 中的方法
autoBakDocument(Document) - 类 com.trs.components.wcm.content.domain.AutoDocBakMgr 中的方法
autoCreate(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
智能建站
autoCreateHistoryDocs(MethodContext) - 类 com.trs.ajaxservice.InfoviewDataToolService 中的方法
遍历docflag>0的文档列表，保存相关的字段，生成新的表单数据
AutoDocBakMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档版本自动保存的控制类，对Document的生命周期进行监控，触发自动备份操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AutoDocBakMgr() - 类 com.trs.components.wcm.content.domain.AutoDocBakMgr 的构造方法
AutoDocBakService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
实现IAutoDocBakService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AutoDocBakService() - 类 com.trs.service.impl.AutoDocBakService 的构造方法
AutoFillApplyFormHandler - com.trs.components.gkml.sqgk.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AutoFillApplyFormHandler() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.AutoFillApplyFormHandler 的构造方法
AUTOFORMATTYPE_HTML - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态变量
AUTOFORMATTYPE_HTMLVALUE - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态变量
AUTOFORMATTYPE_JAVASCRIPT - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态变量
AUTOFORMATTYPE_XML - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态变量
AutoImageLibUtil - com.trs.wcm.photo.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
自动保存图片进库
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
autorunStat() - 类 com.trs.components.wcm.stat.StatMgr 中的方法
自动执行统计数据的工作
每天早上2:00开始进行统计，对所有模板型概览模板进行统计数据的生成
以system的身份运行此任务
autoToAbsoluteFilePath(String) - 类 com.trs.infra.util.CMyFileX 中的静态方法
AutoToNextHandler - com.trs.cms.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
自动流转到下一个节点的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AutoToNextHandler() - 类 com.trs.cms.process.engine.handlers.AutoToNextHandler 的构造方法
autoToNextNode(FlowContext, FlowNode) - 类 com.trs.cms.process.FlowServerImpl 中的方法
autoToNextNode(FlowContext, FlowNode, Users) - 类 com.trs.cms.process.FlowServerImpl 中的方法
autoToNextNode(FlowContext, FlowNode) - 接口 com.trs.cms.process.IFlowServer 中的方法
自动将当前轨迹呈送到下一个节点
autoToNextNode(FlowContext, FlowNode, Users) - 接口 com.trs.cms.process.IFlowServer 中的方法
自动将当前轨迹呈送到下一个节点
AutoTransmitMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档自动分发管理类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
AutoTransmitMgr() - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 的构造方法
available() - 类 com.trs.infra.util.BASE64DecoderStream 中的方法
available() - 类 com.trs.infra.util.jazzlib.InflaterInputStream 中的方法
Returns 0 once the end of the stream (EOF) has been reached.
available() - 类 com.trs.infra.util.jazzlib.ZipInputStream 中的方法
available() - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 中的方法
概述 软件包 类 使用 树 已过时 索引 帮助
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


J - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

J

JavaCABFileExtractor - com.trs.components.infoview.extract 中的 类
JavaCABFileExtractor() - 类 com.trs.components.infoview.extract.JavaCABFileExtractor 的构造方法
JavaScriptEscape - com.trs.infra.util.file 中的 类
TODO javadoc for com.trs.tools.file.JavaScriptEscape 已知的限制 注释中的汉字也会被转义 没有为转义后的字符串生成必要的注释，以便于该js以后的查看
JavaScriptEscape() - 类 com.trs.infra.util.file.JavaScriptEscape 的构造方法
JavaScriptVARProcessor - com.trs.infra.util 中的 类
JavaScriptVARProcessor(String, String, String, String) - 类 com.trs.infra.util.JavaScriptVARProcessor 的构造方法
JDBC_IS2 - 类 com.trs.infra.util.database.CDBText 中的静态变量
JdbcTypeMap - com.trs.infra.util.upgrade.dbcompare 中的 类
java.sql.Types的映射.通过反射从值反向获取值.
JdbcTypeMap() - 类 com.trs.infra.util.upgrade.dbcompare.JdbcTypeMap 的构造方法
JImageMarkUtil - com.trs.wcm.photo.impl 中的 类
JImageMarkUtil() - 类 com.trs.wcm.photo.impl.JImageMarkUtil 的构造方法
JMarkUtilX - com.trs.wcm.photo.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
水印工具类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
JMarkUtilX() - 类 com.trs.wcm.photo.impl.JMarkUtilX 的构造方法
JobFailedResult - com.trs.infra.util.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
计划任务执行失败记录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobFailedResult() - 类 com.trs.infra.util.job.JobFailedResult 的构造方法
JobFailedResult(int, Exception) - 类 com.trs.infra.util.job.JobFailedResult 的构造方法
JobFailedResults - com.trs.infra.util.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
计划任务执行失败记录集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobFailedResults() - 类 com.trs.infra.util.job.JobFailedResults 的构造方法
JobScheduler - com.trs.infra.util.job 中的 类
A "Cron-Expression" is a string comprised of 6 or 7 fields separated by white space.
JobScheduler() - 类 com.trs.infra.util.job.JobScheduler 的构造方法
JobScheduleServer - com.trs.components.common.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobScheduleServer() - 类 com.trs.components.common.job.JobScheduleServer 的构造方法
JobWorkerType - com.trs.components.common.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
系统Job的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobWorkerType() - 类 com.trs.components.common.job.JobWorkerType 的构造方法
默认的构造函数
JobWorkerTypeLCListenerForSchedule - com.trs.components.common.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
计划同步删除
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobWorkerTypeLCListenerForSchedule() - 类 com.trs.components.common.job.JobWorkerTypeLCListenerForSchedule 的构造方法
JobWorkerTypes - com.trs.components.common.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JobWorkerTypes(User) - 类 com.trs.components.common.job.JobWorkerTypes 的构造方法
JobWorkerTypes(User, int, int) - 类 com.trs.components.common.job.JobWorkerTypes 的构造方法
join(ArrayList, String) - 类 com.trs.infra.util.CMyString 中的静态方法
将一个数组按照给定的连接符联结起来
join(Object[], String) - 类 com.trs.infra.util.CMyString 中的静态方法
将一个数组按照给定的连接符联结起来
join(int[], String) - 类 com.trs.infra.util.CMyString 中的静态方法
JsCombineFilter - com.trs.devhelper 中的 类
JsCombineFilter() - 类 com.trs.devhelper.JsCombineFilter 的构造方法
JSONHelper - com.trs.ajaxservice 中的 类
JSONHelper() - 类 com.trs.ajaxservice.JSONHelper 的构造方法
JspChecker - com.trs.presentation.jsputil 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
JSP正确性验证对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JspChecker(String, String) - 类 com.trs.presentation.jsputil.JspChecker 的构造方法
JspChecker(String, String, String, int) - 类 com.trs.presentation.jsputil.JspChecker 的构造方法
JspDenyFilter - com.trs.servlet 中的 类
用户防止对指定资源的访问,以提供系统的安全性
JspDenyFilter() - 类 com.trs.servlet.JspDenyFilter 的构造方法
JSPRequestParmasValidator - com.trs.webframework.controler 中的 类
JSPRequestParmasValidator(ServiceContext, MethodConfig) - 类 com.trs.webframework.controler.JSPRequestParmasValidator 的构造方法
JSPRequestProcessor - com.trs.webframework.controler 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JSPRequestProcessor(HttpServletRequest, HttpServletResponse) - 类 com.trs.webframework.controler.JSPRequestProcessor 的构造方法
JSPServiceContext - com.trs.webframework.controler 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
JSPServiceContext(JSPServiceContext) - 类 com.trs.webframework.controler.JSPServiceContext 的构造方法
JSPServiceContext(HashMap) - 类 com.trs.webframework.controler.JSPServiceContext 的构造方法
JSPServiceContext(HttpServletRequest, HttpServletResponse) - 类 com.trs.webframework.controler.JSPServiceContext 的构造方法
JVoteConstant - com.trs.components.common.trsvote 中的 类
Title: JVote网上调查系统 Description: class JVoteConstant -- 调查系统常量 Copyright: Copyright (c) 2003 Company: TRS Tech.
JVoteConstant() - 类 com.trs.components.common.trsvote.JVoteConstant 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


K - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

K

KBD - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
KEY_CHANNEL_RIGHTVALUES - 类 com.trs.components.metadata.center.MetaViewData 中的静态变量
KEY_CHANNEL_RIGHTVALUES - 类 com.trs.components.wcm.content.ViewDocument 中的静态变量
KEY_CKM_ENABLE_AUTOCHECK - 类 com.trs.components.ckm.TRSCKMServer 中的静态变量
KEY_CKM_ENABLE_EXTRACT - 类 com.trs.components.ckm.TRSCKMServer 中的静态变量
KEY_CKM_ENABLE_SIMSEARCH - 类 com.trs.components.ckm.TRSCKMServer 中的静态变量
KEY_CKM_HAS_OPEN - 类 com.trs.components.ckm.TRSCKMServer 中的静态变量
KEY_CKM_PASSWORD - 类 com.trs.components.ckm.TRSCKMServer 中的静态变量
KEY_CKM_PORT - 类 com.trs.components.ckm.TRSCKMServer 中的静态变量
KEY_CKM_SERVER - 类 com.trs.components.ckm.TRSCKMServer 中的静态变量
KEY_CKM_USERNAME - 类 com.trs.components.ckm.TRSCKMServer 中的静态变量
KEY_CURR_HOST - 类 com.trs.components.metadata.center.MetaViewData 中的静态变量
KEY_CURR_HOST - 类 com.trs.components.wcm.content.ViewDocument 中的静态变量
KEY_DATASET_HEADER - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态变量
KEY_DATASET_VALUES - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态变量
KEY_DOM4J - 类 com.trs.components.infoview.InfoViewDataHelper 中的静态变量
KEY_HOSTID - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的静态变量
KEY_HTTP_URL - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的静态变量
KEY_INFOVIEW - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的静态变量
KEY_INFOVIEW_RESOURCE - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的静态变量
KEY_INFOVIEW_VIEW - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的静态变量
KEY_INFOVIEW_VIEW - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的静态变量
KEY_INFOVIEW_VIEWS - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的静态变量
KEY_LEN_LIMIT - 类 com.trs.infra.util.html.ContentLinkReplacer 中的静态变量
KEY_PRIVATE_LOGIN - 类 com.trs.presentation.util.LoginHelper 中的静态变量
KEY_PRIVATE_PLATFORM_LOGIN - 类 com.trs.presentation.util.LoginHelper 中的静态变量
KEY_PUBLIC_LOGIN - 类 com.trs.presentation.util.LoginHelper 中的静态变量
KEY_PUBLIC_PLATFORM_LOGIN - 类 com.trs.presentation.util.LoginHelper 中的静态变量
KEY_VIEW_INDEX - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的静态变量
keys() - 类 com.trs.components.wcm.epress.EPressConf 中的方法
Keyword - com.trs.components.wcm.resource 中的 类
Keyword() - 类 com.trs.components.wcm.resource.Keyword 的构造方法
构造函数：保留默认接口
KeywordedParams - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Keywords - com.trs.components.wcm.resource 中的 类
Keywords(User) - 类 com.trs.components.wcm.resource.Keywords 的构造方法
构造函数
Keywords(User, int, int) - 类 com.trs.components.wcm.resource.Keywords 的构造方法
构造函数
kickUser(User, User) - 类 com.trs.presentation.util.LoginHelper 中的静态方法
KingBaseDB - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
人大金仓数据库
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
KingBaseDB() - 类 com.trs.infra.util.database.KingBaseDB 的构造方法
KingBaseDB(String, String) - 类 com.trs.infra.util.database.KingBaseDB 的构造方法
KMTRSServer - com.trs.components.wcm.content.trsserver 中的 类
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


L - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

L

LaborResourceConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LaborResourceConfig() - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 的构造方法
LaborResourceMgrImpl - com.trs.components.common.publish.domain.taskdispatch 中的 类
LaborResourceMgrImpl() - 类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 的构造方法
constructor: default
LANG - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
LANGUAGE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
LawGovTousersCreator - com.trs.components.gkml.sqgk.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
法制办审核人构造器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LawGovTousersCreator() - 类 com.trs.components.gkml.sqgk.process.engine.creators.LawGovTousersCreator 的构造方法
Layout - com.trs.components.common.publish.widget 中的 类
Layout() - 类 com.trs.components.common.publish.widget.Layout 的构造方法
构造函数：保留默认接口
LAYOUT_CLASS - 接口 com.trs.components.common.publish.widget.ILayoutGenerator 中的静态变量
布局的class标识
LayoutGenerator - com.trs.components.common.publish.widget 中的 类
布局相关HTML代码和CSS样式生成类 实现接口：ILayoutGenerator
LayoutGenerator() - 类 com.trs.components.common.publish.widget.LayoutGenerator 的构造方法
LayoutMgr - com.trs.components.common.publish.widget 中的 类
专题布局业务层，处理布局保存，删除，查询等逻辑
LayoutMgr() - 类 com.trs.components.common.publish.widget.LayoutMgr 的构造方法
Layouts - com.trs.components.common.publish.widget 中的 类
Layouts(User) - 类 com.trs.components.common.publish.widget.Layouts 的构造方法
构造函数
Layouts(User, int, int) - 类 com.trs.components.common.publish.widget.Layouts 的构造方法
构造函数
LayoutServiceProvider - com.trs.components.common.publish.widget 中的 类
LayoutServiceProvider() - 类 com.trs.components.common.publish.widget.LayoutServiceProvider 的构造方法
LEFT_REGION_NUMBER - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
左边
length - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
列的长度
LENGTH_UNKOWN - 类 com.trs.infra.util.database.DataType 中的静态变量
未知长度的
LetterConvertor - com.trs.components.infoview.db 中的 类
LetterConvertor() - 类 com.trs.components.infoview.db.LetterConvertor 的构造方法
LI - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
License - com.trs.license 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
License
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LicenseException - com.trs.license 中的 异常
Title: TRS 内容协作平台（TRS WCM）
Description:
Top Exception of License validate
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LicenseException() - 异常 com.trs.license.LicenseException 的构造方法
LicenseException(String) - 异常 com.trs.license.LicenseException 的构造方法
LicenseException(String, Throwable) - 异常 com.trs.license.LicenseException 的构造方法
LicenseException(Throwable) - 异常 com.trs.license.LicenseException 的构造方法
LicenseMgr - com.trs.infra.persistent.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LicenseMgr() - 类 com.trs.infra.persistent.db.LicenseMgr 的构造方法
LicenseUtil - com.trs.license 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Encoder:Base64
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LicenseUtil() - 类 com.trs.license.LicenseUtil 的构造方法
LINK - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
LINK - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
LinkedEnumCreator - com.trs.components.infoview.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LinkedEnumCreator() - 类 com.trs.components.infoview.config.LinkedEnumCreator 的构造方法
list(MethodContext) - 类 com.trs.ajaxservice.NewChannelServiceProvider 中的方法
list() - 接口 com.trs.components.stat.IStatResult 中的方法
返回统计主体的集合
list() - 接口 com.trs.components.stat.IStatResults 中的方法
返回主体集合
list() - 类 com.trs.components.stat.StatResult 中的方法
list() - 类 com.trs.components.stat.StatResults 中的方法
LIST_ALL - 类 com.trs.infra.util.ftp.CMyFtp 中的静态变量
LIST_DIRS - 类 com.trs.infra.util.ftp.CMyFtp 中的静态变量
LIST_FILES - 类 com.trs.infra.util.ftp.CMyFtp 中的静态变量
listAll(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
获得FTP服务器上指定目录下的所有文件和文件夹，用","分割
listChildren(User, BaseChannel, int) - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
listChildren(User, BaseChannel, int[]) - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
listChildren(User, BaseChannel, int) - 接口 com.trs.components.wcm.content.persistent.IChildrenMgr 中的方法
获取子频道列表
listChildren(User, BaseChannel, int[]) - 接口 com.trs.components.wcm.content.persistent.IChildrenMgr 中的方法
获取子频道列表
listDirectory(String, int) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
列出FTP服务器上指定目录下的第一层子目录或所有文件，用","分割
listDirs(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
列出FTP服务器上指定目录下的所有第一层子目录，用","分割目录
LISTENER_NAMES - 类 com.trs.cluster.receiver.ObjectLCMsgReceiver 中的静态变量
ListFieldTemplate - com.trs.components.metadata.web.impl 中的 类
ListFieldTemplate() - 类 com.trs.components.metadata.web.impl.ListFieldTemplate 的构造方法
listFiles(String, String) - 类 com.trs.infra.util.CMyFile 中的静态方法
获取某一路径下的特殊文件
listFiles(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
获得FTP服务器上指定目录下哦的所有文件，用“,”分割
listLockedObjs(User, int) - 类 com.trs.presentation.util.CmsObjUnlockTools 中的静态方法
listSubDirectories(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
获取某一路径下的子文件夹
listTirggers() - 类 com.trs.infra.util.job.JobScheduler 中的方法
列出当前所有的调度任务,以方便查看计划执行的情况
ListUtil - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
utilities for value list.
load(int, int, int, int) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
载入指定操作者在指定操作对象的权限值
load(User, int, int) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
载入用户在指定对象的权限值（综合了用户所属角色的权限）
load(User, int, int, boolean) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
load(Role, int, int) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
载入角色在指定对象的权限值
load(Group, int, int) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
载入角色在指定对象的权限值
load() - 类 com.trs.infra.config.domain.ConfigObjectLoader 中的方法
加载
load(Connection, String) - 类 com.trs.infra.util.database.DBIdManager 中的方法
从数据库中装载ID信息
load(Connection, DBType, String) - 类 com.trs.infra.util.database.TableInfos 中的方法
从指定的数据库中读取所有字段的字段信息，构成字段信息列表
load(Connection, DBType, String, String) - 类 com.trs.infra.util.database.TableInfos 中的方法
load() - 类 com.trs.infra.util.upgrade.dbcompare.MetaDataLoader 中的方法
从连接中获取所有meta信息
load(String) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfoMap 中的静态方法
load(String) - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
从指定文件中读取配置
load(InputStream) - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
从指定输入流中读取配置
LOAD_BATCH_CONTENTS_BY_ITERATOR - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
LOAD_BATCH_CONTENTS_BY_OBJECTS - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
loadById(int) - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法
loadById(int) - 接口 com.trs.cms.content.ICMSObjSubstanceContent 中的方法
Loads the content data by the specified id.
loadById(int) - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法
loadById(int) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法
loadById(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
loadById(int) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
loadById(int) - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法
loadById(int) - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法
loadById(int) - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法
loadById(int) - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法
loadById(int) - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法
loadById(int) - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法
loadById(int) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
loadById(int) - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 中的方法
loadById(int) - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 中的方法
loadById(int) - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 中的方法
loadById(int) - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 中的方法
loadById(int) - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 中的方法
loadById(int) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
loadById(int) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
loadById(int) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
loadById(int) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
loadById(int) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
loadById(int, String) - 类 com.trs.infra.persistent.BaseObj 中的方法
指定ID装载数据
loadById(int, String, boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法
loadByStartId(long) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
loadByStartId(long) - 接口 com.trs.infra.support.log.ILog 中的方法
loadClass(String) - 类 com.trs.infra.util.Loader 中的静态方法
If running under JDK 1.2 load the specified class using the Thread contextClassLoader if that fails try Class.forname.
loadConfig() - 类 com.trs.tools.WCM61AutoList 中的方法
loadConfigs() - 类 com.trs.cluster.ClusterMsgCenterImpl 中的方法
loadConfigs() - 接口 com.trs.cluster.IClusterMsgCenter 中的方法
装载集群相关的配置
loadConfigs() - 类 com.trs.components.metadata.service.MailConfigsHelper 中的静态方法
Loader - com.trs.infra.util 中的 类
Load resources (or images) from various sources.
Loader() - 类 com.trs.infra.util.Loader 的构造方法
loadFirstLetter(String) - 类 com.trs.components.wcm.resource.Source 中的静态方法
loadFromFile(String) - 类 com.trs.infra.util.html.HtmlDocument 中的方法
从文件中装载
loadFromFile(String) - 类 com.trs.webframework.config.ServiceConfig 中的方法
loadImage(String) - 类 com.trs.infra.util.CImage 中的方法
LoadingErrorReport - com.trs.webframework.config 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LoadingErrorReport() - 类 com.trs.webframework.config.LoadingErrorReport 的构造方法
LoadingErrorReport(String) - 类 com.trs.webframework.config.LoadingErrorReport 的构造方法
LoadingErrorReport(String, Throwable) - 类 com.trs.webframework.config.LoadingErrorReport 的构造方法
loadLibConf(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
loadLinkMap(String) - 类 com.trs.infra.util.html.ContentLinkReplacer 中的方法
装载链接映射表
loadLoginUser(HttpServletRequest, SSOUser) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
用户登录
loadObjsOfCurrPage(int, int, WCMFilter, String) - 类 com.trs.infra.persistent.BaseObjs 中的方法
loadOriginImg(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
获取原始图片的信息.
loadParametersFromXML(String) - 类 com.trs.presentation.util.Parameters 中的方法
loadProps(String, String) - 类 com.trs.tools.WCM61AutoList 中的静态方法
loadSourceConfig() - 类 com.trs.components.wcm.resource.SourceTypeMgr 中的静态方法
loadSysPicProps(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
loadTree(String, String) - 类 com.trs.wcmonline.WCMOnlineService 中的方法
loadUnmarshallerRoot(File, Mapping) - 类 com.trs.infra.config.domain.ConfigObjectLoader 中的静态方法
依据一个配置文件，解组得到一个可配置根对象
loadViewDatas(WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
locale - 类 com.trs.tools.CommonResourceBuilder 中的静态变量
locale - 类 com.trs.tools.ResourceAnalyzer 中的静态变量
LocaleChecker - com.trs.tools 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
LocaleChecker() - 类 com.trs.tools.LocaleChecker 的构造方法
LocaleServer - com.trs.presentation.locale 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
i18n
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LocaleServer() - 类 com.trs.presentation.locale.LocaleServer 的构造方法
LocaleTools - com.trs.tools 中的 类
LocaleTools() - 类 com.trs.tools.LocaleTools 的构造方法
localize() - 类 com.trs.tools.Localizer 中的方法
localize() - 类 com.trs.tools.Localizer2 中的方法
localize1() - 类 com.trs.tools.Localizer 中的方法
localize1() - 类 com.trs.tools.Localizer2 中的方法
localizeFile(File, String) - 类 com.trs.tools.Localizer 中的方法
localizeFile(File, String) - 类 com.trs.tools.Localizer2 中的方法
localizeNew(Date) - 类 com.trs.tools.Localizer 中的方法
localizeNew(Date) - 类 com.trs.tools.Localizer2 中的方法
localizeNew1(Date) - 类 com.trs.tools.Localizer 中的方法
localizeNew1(Date) - 类 com.trs.tools.Localizer2 中的方法
localizePath(File) - 类 com.trs.tools.Localizer 中的方法
localizePath(File) - 类 com.trs.tools.Localizer2 中的方法
Localizer - com.trs.tools 中的 类
Localizer(String, String) - 类 com.trs.tools.Localizer 的构造方法
Localizer2 - com.trs.tools 中的 类
Localizer2(String, String, String) - 类 com.trs.tools.Localizer2 的构造方法
LocalServerAuto - com.trs.tools 中的 类
LocalServerAuto(String, String) - 类 com.trs.tools.LocalServerAuto 的构造方法
lock() - 类 com.trs.cms.content.ClusterLocker 中的方法
lock(User, int) - 类 com.trs.cms.content.CMSObj 中的方法
锁定对象，默认锁定时间在系统配置中可以设置
lock(User) - 类 com.trs.cms.content.CMSObj 中的方法
lock(User) - 类 com.trs.cms.content.Locker 中的方法
指定用户在默认的锁定时间内锁定对象
lock(User, int) - 类 com.trs.cms.content.Locker 中的方法
指定用户在指定的时间内锁定对象
Locker - com.trs.cms.content 中的 类
Locker() - 类 com.trs.cms.content.Locker 的构造方法
LockerMgr - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LockerMgr() - 类 com.trs.cms.content.LockerMgr 的构造方法
LockManager - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
群锁管理 (依赖数据库实现)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
lockUserIs(User) - 类 com.trs.cms.content.Locker 中的方法
判断指定用户是否为锁定人
Log - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Log() - 类 com.trs.infra.support.log.Log 的构造方法
构造函数：保留默认接口
log(String) - 类 com.trs.infra.util.file.JavaScriptEscape 中的静态方法
记录信息到日志,只是输出的标准输出
log2Monitor(String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
纪录信息到监控器
log2Monitor(String) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
纪录信息到监控器
log2Monitor(String) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
纪录信息到监控器
LOG_EXCEPTION - 类 com.trs.infra.common.WCMTypes 中的静态变量
操作异常日志
LOG_FLOW - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流日志
LOG_JOB - 类 com.trs.infra.common.WCMTypes 中的静态变量
Jobserver日志
LOG_OTHER - 类 com.trs.infra.common.WCMTypes 中的静态变量
其他应用日志
LOG_PUB - 类 com.trs.infra.common.WCMTypes 中的静态变量
发布日志
LOG_SCHEDULE_PUB - 类 com.trs.infra.common.WCMTypes 中的静态变量
LOG_SECURITY - 类 com.trs.infra.common.WCMTypes 中的静态变量
安全日志
LOG_SYSTEM - 类 com.trs.infra.common.WCMTypes 中的静态变量
系统日志
LOG_UNKOWN - 类 com.trs.infra.common.WCMTypes 中的静态变量
LogBak - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMLog的备份对象定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogBak() - 类 com.trs.infra.support.log.LogBak 的构造方法
LogBaks - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志备份对象集合的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogBaks() - 类 com.trs.infra.support.log.LogBaks 的构造方法
logicalDelete(User) - 类 com.trs.components.common.job.Schedule 中的方法
logicalDelete(User) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
逻辑删除
logicalUndelete(User) - 类 com.trs.components.common.job.Schedule 中的方法
logicalUndelete(User) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
恢复文档
login(String, String) - 类 com.trs.cms.auth.persistent.User 中的方法
用户登录处理
login(String, String) - 类 com.trs.presentation.util.LoginHelper 中的方法
用户登录处理
login(String, String, String, String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
login(String, String, String, String) - 接口 com.trs.template.service.ITemplateService 中的方法
DW客户端用户登录
login(String, String, String, String) - 类 com.trs.template.TRSTemplateFacade 中的方法
DW客户端用户登录
loginByIDS(String) - 类 com.trs.presentation.util.LoginHelper 中的方法
LoginCheckFilter - com.trs.servlet 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
LoginCheckFilter() - 类 com.trs.servlet.LoginCheckFilter 的构造方法
LogInfo - com.trs.cms.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志信息对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
LogInfo(int, String, String) - 类 com.trs.cms.logger.LogInfo 的构造方法
构造日志信息
LoginHelper - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM登录管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LoginHelper() - 类 com.trs.presentation.util.LoginHelper 的构造方法
LoginHelper(HttpServletRequest, ServletContext) - 类 com.trs.presentation.util.LoginHelper 的构造方法
LoginValidatorDefaultImpl - com.trs.webframework.controler.servlet 中的 类
LoginValidatorDefaultImpl() - 类 com.trs.webframework.controler.servlet.LoginValidatorDefaultImpl 的构造方法
LoginValidatorFactory - com.trs.webframework.controler.servlet 中的 类
LoginValidatorFactory() - 类 com.trs.webframework.controler.servlet.LoginValidatorFactory 的构造方法
LoginValidatorThreadLocalImpl - com.trs.webframework.controler.servlet 中的 类
LoginValidatorThreadLocalImpl() - 类 com.trs.webframework.controler.servlet.LoginValidatorThreadLocalImpl 的构造方法
LogListUtil - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志列表工具,方便文档列页调用,其它地方很少使用这个接口
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
LogListUtil() - 类 com.trs.infra.support.log.LogListUtil 的构造方法
LogMgr - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象(WCMLog)的管理对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogMgr() - 类 com.trs.infra.support.log.LogMgr 的构造方法
Logo - com.trs.components.wcm.publish.logo 中的 类
Logo() - 类 com.trs.components.wcm.publish.logo.Logo 的构造方法
构造函数：保留默认接口
Logos - com.trs.components.wcm.publish.logo 中的 类
Logos(User) - 类 com.trs.components.wcm.publish.logo.Logos 的构造方法
构造函数
Logos(User, int, int) - 类 com.trs.components.wcm.publish.logo.Logos 的构造方法
构造函数
logout() - 类 com.trs.cms.auth.persistent.User 中的方法
logout(HttpSession) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
登出
logout() - 类 com.trs.presentation.util.LoginHelper 中的方法
logout(String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
logout(String) - 接口 com.trs.template.service.ITemplateService 中的方法
DW客户端用户退出登录
logout(String) - 类 com.trs.template.TRSTemplateFacade 中的方法
DW客户端用户退出登录
Logs - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志对象(WCMLog)集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Logs() - 类 com.trs.infra.support.log.Logs 的构造方法
LogServer - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志服务提供者,提供系统日志的记录/查询/删除等操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogServer() - 类 com.trs.infra.support.log.LogServer 的构造方法
LogServiceProvider - com.trsothers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogServiceProvider() - 类 com.trsothers.LogServiceProvider 的构造方法
LogType - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogXmlConverter - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Log --> XML 转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LogXmlConverter() - 类 com.trs.infra.support.log.LogXmlConverter 的构造方法
LONG - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：LONG
LONGBLOB - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
LONGRAW - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：LONGRAW
LONGTEXT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
lookAround(int) - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
返回从指定的位置开始,到当前位置的一个描述
lookAround(int, int) - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
返回指定启止位置的描述
lookup(String, int) - 类 com.trs.infra.util.NamesRegister 中的方法
Returns the identity of the specified name if found in register;
other, returns the default value given.
lookupByClassName(String) - 接口 com.trs.infra.persistent.IObjTypeLookup 中的方法
lookup the object type by class name
lookupByClassName(String) - 类 com.trs.infra.persistent.ObjTypeLookupHelper 中的静态方法
lookup the object type by class name
lookupByClassName(String) - 类 com.trs.infra.persistent.ObjTypeLookupImpl 中的方法
lookupByName(IPublishFolder, String) - 类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 中的方法
find the template by name
lookupContent(int, int, IPublishFolder) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
lookup a publish content object
lookupDistributionTargetTypeByName(String) - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
lookup the distribution target type by name.
lookupDistributionTargetTypeByName(String) - 类 com.trs.service.impl.WCMPublishElementServiceImpl 中的方法
lookupDistributionTargetTypeByName(String) - 接口 com.trs.service.IWCMPublishElementService 中的方法
lookup the distribution target type by name.
lookupElement(int, int) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
lookup a publish element (folder/content)
lookupElements(int, String) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
lookup the contents collection by the specified type and ids.
lookupFtpMgr(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 中的方法
已过时。 Returns the ftp manager of the specified distribution.
lookupNextStatus(int, ScanContext) - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态方法
lookup the next status at the current condition.
lookupRealBackFlowDocAgain(FlowDoc) - 类 com.trs.cms.process.FlowServerImpl 中的静态方法
lookupSchemeForEvent(String) - 类 com.trs.components.common.message.notify.NotificationServer 中的方法
lookup the notification scheme for the specified event.
LoopException - com.trs.components.common.publish.domain.tagparser 中的 异常
Title: TRS 内容协作平台（TRS WCM）
Description:
回路异常标识
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
LoopException() - 异常 com.trs.components.common.publish.domain.tagparser.LoopException 的构造方法
LoopException(String) - 异常 com.trs.components.common.publish.domain.tagparser.LoopException 的构造方法
LoopException(Throwable) - 异常 com.trs.components.common.publish.domain.tagparser.LoopException 的构造方法
LoopException(String, Throwable) - 异常 com.trs.components.common.publish.domain.tagparser.LoopException 的构造方法
LOWSRC - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


M - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

M

m_bChecked - 类 com.trs.presentation.navigation.TreeItem 中的变量
m_bNotClearIdList - 类 com.trs.components.wcm.content.persistent.Documents 中的变量
m_bOpened - 类 com.trs.presentation.navigation.TreeItem 中的变量
m_bXMLOnlySelf - 类 com.trs.components.wcm.content.persistent.Document 中的变量
m_hTreeRes - 类 com.trs.presentation.navigation.TreeItem 中的静态变量
m_listExcludeFields - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 中的静态变量
m_nCurrFlowId - 类 com.trs.cms.process.xml.FlowImporter 中的变量
m_nStatModal - 类 com.trs.components.stat.StatDocCountByChannel 中的变量
m_nStatModal - 类 com.trs.components.stat.StatDocCountOfGroupByChannel 中的变量
m_nStatModal - 类 com.trs.components.stat.StatDocCountOfGroupByMetaClass 中的变量
m_nStatModal - 类 com.trs.components.stat.StatDocCountOfUserByMetaClass 中的变量
m_nType - 类 com.trs.presentation.navigation.TreeItem 中的变量
m_nX - 类 com.trs.scene.tools.SceneNode 中的变量
m_nY - 类 com.trs.scene.tools.SceneNode 中的变量
m_oAppendixMgr - 类 com.trs.service.impl.DocumentService 中的变量
m_oConfigServer - 类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 中的静态变量
m_oDocumentMgr - 类 com.trs.service.impl.DocumentService 中的变量
m_oParentNode - 类 com.trs.scene.tools.SceneNode 中的变量
m_oRelationMgr - 类 com.trs.service.impl.DocumentService 中的变量
m_oRootNode - 类 com.trs.scene.tools.SceneNode 中的变量
m_sCommonPath - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态变量
风格资源公共的路径
m_sCommonPath - 类 com.trs.components.common.publish.widget.WidgetPathHelper 中的静态变量
资源块内嵌JS的路径
m_sCssPath - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态变量
风格样式文件的路径
m_sCssTemplatePath - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态变量
风格样式文件的模板路径
m_sSpecialPath - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态变量
专题的路径
m_sSpecialPath - 类 com.trs.components.common.publish.widget.WidgetPathHelper 中的静态变量
专题的路径
m_sStylePath - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态变量
风格的路径
m_sStylePath - 类 com.trs.components.common.publish.widget.WidgetPathHelper 中的静态变量
资源块的路径
m_sWcmApp - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态变量
65应用的主要目录
m_sWcmApp - 类 com.trs.components.common.publish.widget.WidgetPathHelper 中的静态变量
65应用的主要目录
MacAddressHelper - com.trs.infra.util.key 中的 类
MacAddressHelper() - 类 com.trs.infra.util.key.MacAddressHelper 的构造方法
MachineCodeDetector - com.trs.infra.util.key 中的 类
MachineCodeDetector() - 类 com.trs.infra.util.key.MachineCodeDetector 的构造方法
MagicImageImpl - com.trs.wcm.photo.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MagicImageImpl() - 类 com.trs.wcm.photo.impl.MagicImageImpl 的构造方法
MAIL_HTML_SEPARATOR - 类 com.trs.infra.util.email.CMyEmail 中的静态变量
MAIL_SEPARATOR - 类 com.trs.infra.util.email.CMyEmail 中的静态变量
MailConfig - com.trs.components.gkml.sqgk.persistent 中的 类
MailConfig() - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 的构造方法
构造函数：保留默认接口
MailConfigs - com.trs.components.gkml.sqgk.persistent 中的 类
MailConfigs(User) - 类 com.trs.components.gkml.sqgk.persistent.MailConfigs 的构造方法
构造函数
MailConfigs(User, int, int) - 类 com.trs.components.gkml.sqgk.persistent.MailConfigs 的构造方法
构造函数
MailConfigsHelper - com.trs.components.metadata.service 中的 类
MailConfigsHelper() - 类 com.trs.components.metadata.service.MailConfigsHelper 的构造方法
MailContentHelper - com.trs.cms.process 中的 类
MailContentHelper() - 类 com.trs.cms.process.MailContentHelper 的构造方法
main(String[]) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
main(String[]) - 类 com.trs.ajaxservice.xmlconvertors.FlowContentsToXML 中的静态方法
main(String[]) - 类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 中的静态方法
main(String[]) - 类 com.trs.cms.auth.persistent.RightDefs 中的静态方法
main(String[]) - 类 com.trs.cms.auth.persistent.RightValue 中的静态方法
main(String[]) - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 中的静态方法
main(String[]) - 类 com.trs.cms.auth.persistent.User 中的静态方法
main(String[]) - 类 com.trs.cms.content.HTMLContent 中的静态方法
main(String[]) - 类 com.trs.cms.process.engine.handlers.ConditionHelper 中的静态方法
main(String[]) - 类 com.trs.cms.process.engine.handlers.ContentPropertyHandler 中的静态方法
main(String[]) - 类 com.trs.cms.process.engine.handlers.MsgSendHandler 中的静态方法
main(String[]) - 类 com.trs.cms.process.engine.handlers.OverTimeHandler 中的静态方法
main(String[]) - 类 com.trs.cms.process.FlowEngineHelper 中的静态方法
main(String[]) - 类 com.trs.cms.process.MailContentHelper 中的静态方法
main(String[]) - 类 com.trs.components.comment.domain.CommentUpdator 中的静态方法
for test
main(String[]) - 类 com.trs.components.comment.domain.NewsComment 中的静态方法
for test
main(String[]) - 类 com.trs.components.common.conjection.helper.HttpChecker 中的静态方法
main(String[]) - 类 com.trs.components.common.job.JobScheduleServer 中的静态方法
main(String[]) - 类 com.trs.components.common.message.SMSSocketSender 中的静态方法
main(String[]) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
main(String[]) - 类 com.trs.components.common.publish.domain.template.CSSResourceProcessor 中的静态方法
main(String[]) - 类 com.trs.components.common.reminder.Reminder 中的静态方法
main(String[]) - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态方法
main(String[]) - 类 com.trs.components.common.trsvote.Vote 中的静态方法
main(String[]) - 类 com.trs.components.common.trsvote.VoteSoapClient 中的静态方法
main(String[]) - 类 com.trs.components.common.trsvote.VoteSoapServer 中的静态方法
main(String[]) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 中的静态方法
main(String[]) - 类 com.trs.components.infoview.config.InfoViewEnumHelper 中的静态方法
main(String[]) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的静态方法
main(String[]) - 类 com.trs.components.infoview.db.LetterConvertor 中的静态方法
main(String[]) - 类 com.trs.components.infoview.extract.TestIPFD 中的静态方法
main(String[]) - 类 com.trs.components.infoview.helper.InfoViewQueryHelper 中的静态方法
main(String[]) - 类 com.trs.components.infoview.InfoViewReplyNoticeSender 中的静态方法
main(String[]) - 类 com.trs.components.infoview.persistent.InfoViewSerial 中的静态方法
main(String[]) - 类 com.trs.components.infoview.persistent.InfoViewSerialGenerator 中的静态方法
main(String[]) - 类 com.trs.components.metadata.center.MetaViewData 中的静态方法
main(String[]) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的静态方法
main(String[]) - 类 com.trs.components.metadata.definition.ClassInfoUtil 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.persistent.Documents 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的静态方法
main(String[]) - 类 com.trs.components.wcm.content.trsserver.TestTrsServer 中的静态方法
测试程序入口
main(String[]) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的静态方法
main(String[]) - 类 com.trs.components.wcm.contentlink.TxtFileParserForContentLink 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.EPressChannelWrapper 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.EPressHistoryGenerator 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.EPressImporter 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.EPressSoapService 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.EPressXPlusImporter 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.TagEBookDirParser 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.TagMapAreaParser 中的静态方法
main(String[]) - 类 com.trs.components.wcm.epress.WCMTagParserEPressNews 中的静态方法
main(String[]) - 类 com.trs.components.wcm.newshoo.DataFromNewshoo 中的静态方法
main(String[]) - 类 com.trs.components.wcm.newshoo.DataFromRadarClient 中的静态方法
main(String[]) - 类 com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr 中的静态方法
main(String[]) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply 中的静态方法
main(String[]) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews 中的静态方法
main(String[]) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 中的静态方法
main(String[]) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments 中的静态方法
main(String[]) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener 中的静态方法
main(String[]) - 类 com.trs.components.wcm.resource.Source 中的静态方法
main(String[]) - 类 com.trs.components.wcm.resource.SourceTypeMgr 中的静态方法
main(String[]) - 类 com.trs.components.wcm.stat.StatView 中的静态方法
main(String[]) - 类 com.trs.components.wcm.wcmx.help.WcmHelpUpdate 中的静态方法
main(String[]) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的静态方法
main(String[]) - 类 com.trs.ConfigFileTool4Refactor 中的静态方法
main(String[]) - 类 com.trs.database.util.AllDDLMaker 中的静态方法
main(String[]) - 类 com.trs.database.util.DataDictionary 中的静态方法
main(String[]) - 类 com.trs.database.util.DbDDLMaker 中的静态方法
main(String[]) - 类 com.trs.database.util.DDLMain 中的静态方法
main(String[]) - 类 com.trs.database.util.IndexDDLMaker 中的静态方法
main(String[]) - 类 com.trs.database.util.IndexList4Ora 中的静态方法
main(String[]) - 类 com.trs.database.util.Ora2DB2Convertor 中的静态方法
main(String[]) - 类 com.trs.database.util.OraImpExtractDDL 中的静态方法
main(String[]) - 类 com.trs.database.util.OTop 中的静态方法
main(String[]) - 类 com.trs.db.update.SQLServerUpdateSQL 中的静态方法
main(String[]) - 类 com.trs.db.update.UpdateSQLGenerator 中的静态方法
自动比较数据库更新信息, 并生成SQL更新脚本.
main(String[]) - 类 com.trs.DreamFactory 中的静态方法
main(String[]) - 类 com.trs.infra.common.WCMRightTypes 中的静态方法
main(String[]) - 类 com.trs.infra.config.ConfigConstants 中的静态方法
main(String[]) - 类 com.trs.infra.config.ConfigController 中的静态方法
main(String[]) - 类 com.trs.infra.config.DBTableConfig 中的静态方法
main(String[]) - 类 com.trs.infra.config.FileConfig 中的静态方法
main(String[]) - 类 com.trs.infra.config.TRSConfigServer 中的静态方法
main(String[]) - 类 com.trs.infra.config.XMLConfig 中的静态方法
main(String[]) - 类 com.trs.infra.db.QueryFilter 中的静态方法
main(String[]) - 类 com.trs.infra.persistent.db.ConnectPasswordEncrypter 中的静态方法
main(String[]) - 类 com.trs.infra.persistent.db.DBManager 中的静态方法
main(String[]) - 类 com.trs.infra.persistent.ObjTypeLookupHelper 中的静态方法
main(String[]) - 类 com.trs.infra.persistent.WCMFilter 中的静态方法
main(String[]) - 类 com.trs.infra.ServerControl 中的静态方法
main(String[]) - 类 com.trs.infra.support.config.ConfigServer 中的静态方法
main(String[]) - 类 com.trs.infra.support.security.SecureKey 中的静态方法
main(String[]) - 类 com.trs.infra.support.security.SecureKeyUtil 中的静态方法
main(String[]) - 类 com.trs.infra.util.AttributesString 中的静态方法
main(String[]) - 类 com.trs.infra.util.CharsetDetector 中的静态方法
main(String[]) - 类 com.trs.infra.util.CImage 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyBitsValue 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyDateTime 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyEncrypt 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyErrors 中的静态方法
main(String[]) - 异常 com.trs.infra.util.CMyException 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyFile 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyKeyGenerator 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyMemory 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMySign 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMySMS 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyString 中的静态方法
简单测试用例
main(String[]) - 类 com.trs.infra.util.CMyUnzip 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyUnZipFile 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
main(String[]) - 类 com.trs.infra.util.CMyZip 中的静态方法
main(String[]) - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法
main(String[]) - 类 com.trs.infra.util.CPager 中的静态方法
main(String[]) - 类 com.trs.infra.util.database.DB2UDB 中的静态方法
main(String[]) - 类 com.trs.infra.util.database.DB2UDB2 中的静态方法
main(String[]) - 类 com.trs.infra.util.database.DBTypes 中的静态方法
main(String[]) - 类 com.trs.infra.util.database.TableInfos 中的静态方法
main(String[]) - 类 com.trs.infra.util.file.JavaScriptEscape 中的静态方法
main(String[]) - 类 com.trs.infra.util.ftp.CMyFtp 中的静态方法
main(String[]) - 类 com.trs.infra.util.ftp.FtpMgrTest 中的静态方法
main(String[]) - 类 com.trs.infra.util.html.ContentLinkReplacer 中的静态方法
main(String[]) - 类 com.trs.infra.util.html.HTML 中的静态方法
main(String[]) - 类 com.trs.infra.util.html.HtmlAttribute 中的静态方法
main(String[]) - 类 com.trs.infra.util.html.HtmlComment 中的静态方法
main(String[]) - 类 com.trs.infra.util.html.HtmlDocument 中的静态方法
main(String[]) - 类 com.trs.infra.util.html.HtmlElement 中的静态方法
main(String[]) - 类 com.trs.infra.util.html.HtmlElementFinder 中的静态方法
main(String[]) - 类 com.trs.infra.util.HttpGet 中的静态方法
main(String[]) - 类 com.trs.infra.util.JavaScriptVARProcessor 中的静态方法
main(String[]) - 类 com.trs.infra.util.job.StatefulJobTest 中的静态方法
main(String[]) - 类 com.trs.infra.util.key.CKeyUtil 中的静态方法
main(String[]) - 类 com.trs.infra.util.key.MacAddressHelper 中的静态方法
main(String[]) - 类 com.trs.infra.util.key.MachineCodeDetector 中的静态方法
main(String[]) - 类 com.trs.infra.util.OrgnizeContextImports 中的静态方法
main(String[]) - 类 com.trs.infra.util.PinyinHelper 中的静态方法
main(String[]) - 类 com.trs.infra.util.PropertiesVARProcessor 中的静态方法
main(String[]) - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态方法
main(String[]) - 类 com.trs.infra.util.TRSJspAutoTool 中的静态方法
main(String[]) - 类 com.trs.infra.util.TRSLocaleAuto 中的静态方法
main(String[]) - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的静态方法
仅供内部测试使用
main(String[]) - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的静态方法
仅供内部测试使用
main(String[]) - 类 com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex 中的静态方法
main(String[]) - 类 com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole 中的静态方法
main(String[]) - 类 com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig 中的静态方法
main(String[]) - 类 com.trs.infra.util.upgrade.dataprocess.ScheduleOper 中的静态方法
main(String[]) - 类 com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit 中的静态方法
Main - com.trs.infra.util.upgrade 中的 类
Main() - 类 com.trs.infra.util.upgrade.Main 的构造方法
main(String[]) - 类 com.trs.infra.util.upgrade.Main 中的静态方法
main(String[]) - 类 com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker 中的静态方法
main(String[]) - 类 com.trs.infra.util.upgrade.sql.DiffSqlMaker 中的静态方法
main(String[]) - 类 com.trs.infra.util.upgrade.sql.UpdSqlMaker 中的静态方法
main(String[]) - 类 com.trs.infra.util.upgrade.WcmIdFieldInit 中的静态方法
main(String[]) - 类 com.trs.infra.util.URLCoder 中的静态方法
仅供测试使用
main(String[]) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法
main(String[]) - 类 com.trs.presentation.common.PageViewConstants 中的静态方法
main(String[]) - 类 com.trs.presentation.documetimport.xml.DocumentImportXmlHelper 中的静态方法
main(String[]) - 类 com.trs.presentation.nav.TreeCreator 中的静态方法
main(String[]) - 类 com.trs.presentation.navigation.TreeItem 中的静态方法
main(String[]) - 类 com.trs.presentation.portal.PortalHelper 中的静态方法
main(String[]) - 类 com.trs.presentation.util.AppAutoParameters 中的静态方法
main(String[]) - 类 com.trs.presentation.util.PageParameter 中的静态方法
main(String[]) - 类 com.trs.presentation.util.PageParameters 中的静态方法
main(String[]) - 类 com.trs.presentation.util.Parameter 中的静态方法
main(String[]) - 类 com.trs.presentation.util.Parameters 中的静态方法
main(String[]) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的静态方法
main(String[]) - 类 com.trs.scene.tools.SceneNodeParser 中的静态方法
main(String[]) - 类 com.trs.scene.tools.SceneNodeToXML 中的静态方法
main(String[]) - 类 com.trs.service.impl.InfoViewDocImportService 中的静态方法
main(String[]) - 类 com.trs.service.impl.NetSnapTool 中的静态方法
main(String[]) - 类 com.trs.service.InfoViewContext 中的静态方法
main(String[]) - 类 com.trs.template.TemplateServiceConfig 中的静态方法
本类的测试函数
main(String[]) - 类 com.trs.template.TRSTemplateFacade 中的静态方法
测试一次本类
main(String[]) - 类 com.trs.tools.ChineseFinder 中的静态方法
main(String[]) - 类 com.trs.tools.CommonResourceBuilder 中的静态方法
main(String[]) - 类 com.trs.tools.LocaleChecker 中的静态方法
main(String[]) - 类 com.trs.tools.LocaleTools 中的静态方法
main(String[]) - 类 com.trs.tools.Localizer 中的静态方法
main(String[]) - 类 com.trs.tools.Localizer2 中的静态方法
main(String[]) - 类 com.trs.tools.LocalServerAuto 中的静态方法
main(String[]) - 类 com.trs.tools.MediaBuilder 中的静态方法
main(String[]) - 类 com.trs.tools.ResourceAnalyzer 中的静态方法
main(String[]) - 类 com.trs.tools.SQLBuilder 中的静态方法
main(String[]) - 类 com.trs.tools.SymbolC2E 中的静态方法
main(String[]) - 类 com.trs.tools.TablesCleaner 中的静态方法
main(String[]) - 类 com.trs.tools.WCM61AutoList 中的静态方法
main(String[]) - 类 com.trs.util.DataOfV6To52 中的静态方法
main(String[]) - 类 com.trs.wcag2.HTMLUtil 中的静态方法
main(String[]) - 类 com.trs.wcag2.WCAG2Helper 中的静态方法
main(String[]) - 类 com.trs.wcm.old.ImportDocsContext 中的静态方法
main(String[]) - 类 com.trs.wcm.old.ImportDocsFromHTMLFile 中的静态方法
main(String[]) - 类 com.trs.webframework.config.HashCodeUtil 中的静态方法
main(String[]) - 类 com.trs.webframework.config.Test 中的静态方法
main(String[]) - 类 com.trs.webframework.config.TRSParameter 中的静态方法
main(String[]) - 类 com.trs.webframework.controler.PostDataParser 中的静态方法
main(String[]) - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的静态方法
用于启动测试代码，仅供测试使用。
main(String[]) - 类 com.trsupdate.RightUpdaterForUser 中的静态方法
mainTest(String, String) - 类 com.trs.tools.Localizer 中的静态方法
mainTest(String, String, String) - 类 com.trs.tools.Localizer2 中的静态方法
make() - 类 com.trs.database.util.AllDDLMaker 中的方法
make() - 类 com.trs.infra.util.upgrade.sql.DiffSqlMaker 中的方法
makeAllSettings() - 类 com.trs.template.domain.setting.TemplateSettingFactory 中的方法
makeAppendix(String) - 类 com.trs.service.impl.SureformService 中的方法
makeAppendix(String) - 接口 com.trs.service.ISureformService 中的方法
根据书生表单数据，构造一个文档附件
规则是先将数据打包成为一个在WebPic下的文件，然后做成附件并构造List返回
注意返回后，需要将DocId设置上，否则保存附件时会报错
makeBaseStyleContent(PageStyle) - 接口 com.trs.components.common.publish.widget.IPageStyleMgr 中的方法
生成页面风格基本特性样式
makeBaseStyleContent(PageStyle) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
生成页面基本特性样式
makeBlanks(int) - 类 com.trs.infra.util.CMyString 中的静态方法
构造指定长度的空格字符串
makeCacheKey(String, String) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的静态方法
使用指定的前缀和名称构造在缓存中用于标识对象的KEY
makeCaheKey(int, int) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的静态方法
使用FolderType和FolderID构造缓存中的KEY
makeChannelFilter(Channel, WCMFilter) - 类 com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper 中的方法
makeChannelFilter(Channel, WCMFilter, boolean, boolean) - 类 com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper 中的方法
makeChannelFilter(Channels, WCMFilter, boolean) - 类 com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper 中的方法
makeChannelFilter(Channel, WCMFilter) - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 中的方法
makeChannelFilter(Channel, WCMFilter, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 中的方法
makeChannelFilter(Channels, WCMFilter, boolean) - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 中的方法
makeChannelFilter(Channel, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
makeChannelFilter(Channel, WCMFilter, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
makeChannelFilter(Channel, WCMFilter, boolean, boolean, int) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
makeChannelFilter(Channels, WCMFilter, boolean) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
makeChartStyle(String, int, int, String, boolean) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的静态方法
makeCMSBaseObjsOpertators(User, String, CMSBaseObjs) - 类 com.trs.ajaxservice.PageOperatorsForServiceHelper 中的静态方法
makeCMSObjOpertators(User, String, CMSObj) - 类 com.trs.ajaxservice.PageOperatorsForServiceHelper 中的静态方法
makeComplexFieldData(String, String, String, String, InfoViewData) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
makeContentFrom(CMSObj, IPublishFolder) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
make a publish content from the specified CMS object.
makeCssContent(ContentStyle) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
makeCssContent(ContentStyle) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
生成指定PageStyle下可用的内容风格css文件
makeCssContent(ResourceStyle) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
生成资源的可用风格内容
makeCssContent(ResourceStyle) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
makeCSSContent(String, String, StyleItems) - 类 com.trs.components.common.publish.widget.StyleHelper 中的静态方法
根据风格模板替换其中的标记生成可以使用的风格内容
makeCssFile(MethodContext) - 接口 com.trs.components.common.publish.widget.IPageStyleServiceProvider 中的方法
生成Css文件,返回文件名称
makeCssFile(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
生成Css文件,返回文件名称，生成一个风格英文名称+.css的文件到wcmdata下的template/style/style_css
makeCurrChannel(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserViewDatas 中的方法
makeCustomCssContent(String, String) - 类 com.trs.components.common.publish.widget.StyleHelper 中的静态方法
产生自定义的风格内容
makeDatasetJSON(int, ChartOption) - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态方法
makeDatasetJSON(TimingChartData, ChartOption) - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态方法
makeDatasetJSON(TimingChartData) - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态方法
makeDatasetJSON(TimingChartData, int, String) - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态方法
makeDateTime(int) - 类 com.trs.ajaxservice.ServiceConstants 中的静态方法
makeDefaultChannel(User, int) - 类 com.trs.components.metadata.service.DefaultChannelMakerCenter 中的方法
构造用户在指定视图上默认存储的栏目
makeDefaultChannel(User, int) - 接口 com.trs.components.metadata.service.IDefaultChannelMaker 中的方法
构造当前用户默认的栏目
makeDefaultChannel(User, int) - 类 com.trs.components.metadata.service.UserRelateInfoMaker 中的方法
makeDefaultClassInfo(String, User) - 类 com.trs.components.metadata.service.UserRelateInfoMaker 中的静态方法
构造指定用户对应的机构分类
makeDefaultMainURL() - 类 com.trs.presentation.nav.AdvSearchNavHandler 中的方法
makeDefaultMainURL() - 类 com.trs.presentation.nav.ChannelNavHandler 中的方法
makeDefaultMainURL() - 类 com.trs.presentation.nav.ClassInfoNavHandler 中的方法
makeDefaultMainURL() - 接口 com.trs.presentation.nav.INavHandler 中的方法
构造主窗口的地址
makeDetailPageFileName(IPublishContent, String, int) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的静态方法
Returns the detail page file name of the specified content.
makeDetailPageFileName(IPublishContent) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的静态方法
Returns the detail page file name of the specified content.
makeDic() - 类 com.trs.database.util.DataDictionary 中的方法
makeDir(String, boolean) - 类 com.trs.infra.util.CMyFile 中的静态方法
创建目录
makeDirectory(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
根据指定的路径创建FTP目录
makeDistristributor(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr 中的静态方法
根据指定的分发点配置信息构造 IFileDistristributor 对象实例
makeElementFrom(CMSObj) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
make a publish element from the specified CMS object.
makeElementsFrom(CMSBaseObjs) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
Makes a publish elements collection from the specified CMS objects list.
makeEmailContent(Map) - 类 com.trs.cms.process.MailContentHelper 中的静态方法
makeFields(String) - 类 com.trs.components.stat.BaseStatHandler 中的方法
将sKey信息反解成统计SQL中的Select字段数组
makeFields(String) - 接口 com.trs.components.stat.IKeyMaker 中的方法
根据传入的sKey信息，返回构造之后的keys
makeFilter(WebSite, WCMFilter, boolean, boolean) - 类 com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper 中的方法
makeFilter(WebSites, WCMFilter, boolean, boolean) - 类 com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper 中的方法
makeFilter(WebSite, WCMFilter, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 中的方法
makeFilter(WebSites, WCMFilter, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 中的方法
makeFilter(WebSite, WCMFilter, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
makeFilter(WebSites, WCMFilter, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
makeFilterWithClassInfos(String, boolean) - 类 com.trs.components.metadata.center.MetaDataCenterHelper 中的静态方法
makeFilterWithRight(User, BaseObjs) - 类 com.trs.ajaxservice.DocumentAuthHelper 中的静态方法
构造当前用户在指定的栏目中带有权限的Filter
makeFlowContent(int, int) - 类 com.trs.cms.process.FlowContentFactory 中的静态方法
makeFlowContent(CMSObj) - 类 com.trs.cms.process.FlowContentFactory 中的静态方法
makeFlowContextInfo(Flow) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法
makeFlowContextInfoMap(String) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法
makeFrom(CMSObj) - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法
makeFrom(CMSObj) - 接口 com.trs.cms.content.ICMSObjSubstanceContent 中的方法
Makes this content from a CMS object.
makeFrom(CMSObj) - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
makeFrom(CMSObj) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
makeFrom(ApplyForm) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法
makeFrom(CMSObj) - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法
makeFrom(CMSObj) - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法
makeFrom(CMSObj) - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
makeFrom(CMSObj) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
makeHierarchicalDir4Template(Template) - 类 com.trs.template.domain.XTemplateExporter 中的方法
makeHostRightValue(MethodContext, User, IPublishFolder) - 类 com.trs.ajaxservice.TemplateAuthHelper 中的静态方法
makeHsAttrs(String) - 类 com.trs.wcag2.HTMLUtil 中的静态方法
makeHTML() - 接口 com.trs.components.metadata.web.HTMLMaker 中的方法
返回解析之后的视图字段资源片段
makeHTML() - 类 com.trs.components.metadata.web.impl.DefaultHTMLMaker 中的方法
makeKey(String[]) - 类 com.trs.components.stat.BaseStatHandler 中的方法
将keys信息构造成相应的Key
makeKey(String[]) - 接口 com.trs.components.stat.IKeyMaker 中的方法
根据传入的keys信息，返回构造之后的key
makeLogicRightValue(User, Channel, Document) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法
构造用户对于指定栏目的指定文档的权限值
makeLogOnAdd(BaseObj) - 类 com.trs.cms.auth.logger.RoleUserLogger 中的方法
makeLogOnAdd(BaseObj) - 接口 com.trs.cms.logger.IObjLogger 中的方法
根据指定的对象构造新增日志说明记录
makeLogOnAdd(BaseObj) - 类 com.trs.cms.logger.ObjLoggerBase 中的方法
makeLogOnAdd(BaseObj) - 类 com.trs.components.wcm.logger.ChnlDocLogger 中的方法
makeLogOnAdd(BaseObj) - 类 com.trs.components.wcm.logger.ConfigLogger 中的方法
makeLogOnAdd(BaseObj) - 类 com.trs.components.wcm.logger.FlowEmployLogger 中的方法
makeLogOnAdd(BaseObj) - 类 com.trs.components.wcm.logger.RegionCellInfoLogger 中的方法
makeLogOnAdd(BaseObj) - 类 com.trs.components.wcm.logger.TemplateEmployLogger 中的方法
makeLogOnDel(BaseObj) - 类 com.trs.cms.auth.logger.RoleUserLogger 中的方法
makeLogOnDel(BaseObj) - 接口 com.trs.cms.logger.IObjLogger 中的方法
根据指定的对象构造删除日志说明记录
makeLogOnDel(BaseObj) - 类 com.trs.cms.logger.ObjLoggerBase 中的方法
makeLogOnDel(BaseObj) - 类 com.trs.components.wcm.logger.ChnlDocLogger 中的方法
makeLogOnDel(BaseObj) - 类 com.trs.components.wcm.logger.ConfigLogger 中的方法
makeLogOnDel(BaseObj) - 类 com.trs.components.wcm.logger.FlowEmployLogger 中的方法
makeLogOnDel(BaseObj) - 类 com.trs.components.wcm.logger.RegionCellInfoLogger 中的方法
makeLogOnDel(BaseObj) - 类 com.trs.components.wcm.logger.TemplateEmployLogger 中的方法
makeLogOnModify(BaseObj) - 类 com.trs.cms.auth.logger.RoleUserLogger 中的方法
makeLogOnModify(BaseObj) - 接口 com.trs.cms.logger.IObjLogger 中的方法
根据指定的对象构造修改日志说明记录
makeLogOnModify(BaseObj) - 类 com.trs.cms.logger.ObjLoggerBase 中的方法
makeLogOnModify(BaseObj) - 类 com.trs.components.wcm.logger.ChnlDocLogger 中的方法
makeLogOnModify(BaseObj) - 类 com.trs.components.wcm.logger.ConfigLogger 中的方法
makeLogOnModify(BaseObj) - 类 com.trs.components.wcm.logger.FlowEmployLogger 中的方法
makeLogOnModify(BaseObj) - 类 com.trs.components.wcm.logger.RegionCellInfoLogger 中的方法
makeLogOnModify(BaseObj) - 类 com.trs.components.wcm.logger.TemplateEmployLogger 中的方法
makeMailData() - 类 com.trs.infra.util.email.CMyEmail 中的方法
makeNav(PublishPageContext, String, String, int, int) - 类 com.trs.components.common.publish.domain.publisher.PageNavHelper 中的静态方法
makeNestedIndentiy(String) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
makeNewFiles() - 类 com.trs.tools.WCM61AutoList 中的方法
makeNewHostInstance() - 类 com.trs.cms.auth.config.RightHostConfig 中的方法
构造一个新的RightHost实例
makeNewHostInstance() - 类 com.trs.cms.auth.config.RightObjectConfig 中的方法
构造一个新的RightHost实例
makeObjectNotFound(String[]) - 类 com.trs.infra.I18NMessage 中的静态方法
makePageFileName(String, String, int) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的静态方法
Makes a page file name.
makePageOtherStyleContent(PageStyle) - 接口 com.trs.components.common.publish.widget.IPageStyleMgr 中的方法
生成页面其他样式
makePageOtherStyleContent(PageStyle) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
生成页面其他样式
makePreviewCssContent(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
获取预览时需要的样式内容 在列表中预览时调用的方法，返回当前内容风格的css样式代码
makePreviewCssContent(ContentStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
获取内容可用风格预览时需要的样式内容
makePreviewCssContent(ResourceStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
获取资源可用风格预览时需要的样式内容
makePreviewCssContent(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
获取预览时需要的样式内容
makePreviewCssContent(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
获取预览时需要的样式内容 在列表中预览时调用的方法，返回当前资源风格的css样式代码
makePreviewCssContent(ContentStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
获取内容可用风格预览时需要的样式内容
makePreviewCssContent(ResourceStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
获取资源可用风格预览时需要的样式内容
makeProvider(String, String) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法
makeProvider(String) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法
makeQueryComparedHitsTimeRands(int) - 类 com.trs.components.stat.HitsCountHelper 中的静态方法
构造比较的时间段
makeQueryHitsTimeRands(int) - 类 com.trs.components.stat.HitsCountHelper 中的静态方法
构造原时间段
makeRightHost(int, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
通过指定的HostType和HostId构造IRightHost的实现
makeRightHostFrom(CMSObj) - 类 com.trs.cms.auth.domain.RightHostFactory 中的静态方法
makeRightHostFrom(int, int) - 类 com.trs.cms.auth.domain.RightHostFactory 中的静态方法
makeRightHostInstance(int) - 类 com.trs.cms.auth.config.RightConfigServer 中的方法
makeRightObjectFrom(CMSObj) - 类 com.trs.cms.auth.domain.RightObjectFactory 中的静态方法
makeRightObjectFrom(int, int) - 类 com.trs.cms.auth.domain.RightObjectFactory 中的静态方法
makeRightObjectInstance(int) - 类 com.trs.cms.auth.config.RightConfigServer 中的方法
makeRightValue(MethodContext, User, Channel, Document) - 类 com.trs.ajaxservice.WCMDocumentHelper 中的静态方法
构造指定文档在指定栏目中的权限
makeSelectFields(TagItem, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
makeSeperateComments(FlowDoc) - 类 com.trs.cms.process.FlowEngineHelper 中的静态方法
产生并联审批结束时后合并的处理意见
makeSettingByType(String) - 类 com.trs.template.domain.setting.TemplateSettingFactory 中的方法
makeSqlMaker(String) - 类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMakerFactory 中的静态方法
makeTemplateFolder(String, WebSite) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
makeTemplateRightValue(MethodContext, User, Template, IPublishFolder) - 类 com.trs.ajaxservice.TemplateAuthHelper 中的静态方法
makeTemplatesToZip(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
makeTogetherComments(int) - 类 com.trs.cms.process.FlowEngineHelper 中的静态方法
产生合并后的处理意见
makeTrueFieldName(int) - 类 com.trs.components.infoview.InfoViewConstants 中的静态方法
makeTrueTableName(int) - 类 com.trs.components.infoview.InfoViewConstants 中的静态方法
makeTrueTableName(String) - 类 com.trs.components.metadata.MetaDataConstants 中的静态方法
makeWhereSQL() - 类 com.trs.presentation.util.DefaultWhereSQLMaker 中的方法
makeWhereSQL(RequestHelper) - 类 com.trs.presentation.util.WhereSQLMaker 中的方法
makeXMLDocument(Element, String) - 类 com.trs.infra.util.CMyDOM4jHelper 中的静态方法
makeXMLNode(String, String) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法
makeXMLNode(String, String, boolean) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法
makeXYDataSet(Object, ChartOption) - 类 com.trs.components.wcm.stat.domain.TimingChartBuilder 中的方法
Management - com.trs.components.comment.domain 中的 类
在外交部项目中WCM和新闻评论以及邮件订阅协同时使用。
Management() - 类 com.trs.components.comment.domain.Management 的构造方法
缺省构造方法
Management(String) - 类 com.trs.components.comment.domain.Management 的构造方法
利用带有签名的数据构造“Management”对象
Manifest - com.trs.components.infoview.extract.manifest 中的 类
描述InfoPath文件解压后的manifest.xsf文件
Manifest() - 类 com.trs.components.infoview.extract.manifest.Manifest 的构造方法
缺省构造方法
MAP - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
mapClassFullPath(String) - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法
mapClassFullPath(String) - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态方法
mapFilePath(String, int) - 类 com.trs.infra.support.file.FilesMan 中的方法
目录映射：根据文件名映射文件所在的路径 文件所在路径 说明：不检查文件路径是否真正存在
MAPPINGPATH - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的静态变量
mapResouceFullPath(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
map the resource related path to full real path
mapResouceFullPath(String, Class) - 类 com.trs.infra.util.CMyFile 中的静态方法
MARGINHEIGHT - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
MARGINWIDTH - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
mark() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
标记当前位置
mark(int) - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 中的方法
MARK_CHARS - 类 com.trs.components.wcm.content.trsserver.TRSSearchUtil 中的静态变量
当作标点符号的字符集
MARK_FORCE_END - 类 com.trs.cms.process.FlowingDocOptMarkScouter 中的静态变量
强制结束标记: 特殊的文档操作标签
MarkKind - com.trs.components.common.bookmark 中的 类
MarkKind() - 类 com.trs.components.common.bookmark.MarkKind 的构造方法
MarkKinds - com.trs.components.common.bookmark 中的 类
MarkKinds(User) - 类 com.trs.components.common.bookmark.MarkKinds 的构造方法
MarkKinds(User, int, int) - 类 com.trs.components.common.bookmark.MarkKinds 的构造方法
MARKPOS_CENTER_MIDDLE - 类 com.trs.wcm.photo.ImageLibConstants 中的静态变量
水印位置：居中
MARKPOS_LEFT_TOP - 类 com.trs.wcm.photo.ImageLibConstants 中的静态变量
水印位置：左上
MARKPOS_RIGHT_BOTTOM - 类 com.trs.wcm.photo.ImageLibConstants 中的静态变量
水印位置：右下
MarkShare - com.trs.components.common.bookmark 中的 类
MarkShare() - 类 com.trs.components.common.bookmark.MarkShare 的构造方法
MARKSHARE_STATE_ALLUSER - 类 com.trs.components.common.bookmark.MarkShare 中的静态变量
MarkShares - com.trs.components.common.bookmark 中的 类
MarkShares(User) - 类 com.trs.components.common.bookmark.MarkShares 的构造方法
MarkShares(User, int, int) - 类 com.trs.components.common.bookmark.MarkShares 的构造方法
markSupported() - 类 com.trs.infra.util.BASE64DecoderStream 中的方法
markSupported() - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 中的方法
Master - com.trs.components.common.publish.widget 中的 类
Master() - 类 com.trs.components.common.publish.widget.Master 的构造方法
构造函数：保留默认接口
MASTER_DETAIL - 类 com.trs.components.common.publish.widget.Master 中的静态变量
专题下的文档页面模板
MASTER_INDEX - 类 com.trs.components.common.publish.widget.Master 中的静态变量
专题下的首页基准模板
MASTER_OUTLINE - 类 com.trs.components.common.publish.widget.Master 中的静态变量
专题下的分类首页模板
MasterMgr - com.trs.components.common.publish.widget 中的 类
MasterMgr() - 类 com.trs.components.common.publish.widget.MasterMgr 的构造方法
Masters - com.trs.components.common.publish.widget 中的 类
Masters(User) - 类 com.trs.components.common.publish.widget.Masters 的构造方法
构造函数
Masters(User, int, int) - 类 com.trs.components.common.publish.widget.Masters 的构造方法
构造函数
MasterServiceProvider - com.trs.components.common.publish.widget 中的 类
MasterServiceProvider() - 类 com.trs.components.common.publish.widget.MasterServiceProvider 的构造方法
MAX_BYTE_LENGTH_4_STRING - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的静态变量
MAX_CACHE_SIZE - 类 com.trs.cms.auth.persistent.GroupUserCacheMgr 中的静态变量
MAX_CACHE_SIZE - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigCacheMgr 中的静态变量
MAX_CACHE_SIZE - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的静态变量
MAX_COLUMNS - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
最大列数
MAX_DETAIL_NUM - 类 com.trs.components.common.trsad.ADPos 中的静态变量
MAX_FETCH_SIZE - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态变量
MAX_FETCH_SIZE - 类 com.trs.components.wcm.content.ViewDocuments 中的静态变量
MAX_OPERATION_COUNT - 类 com.trs.cms.auth.config.OperationConfig 中的静态变量
MAX_OUTLINE_NUM - 类 com.trs.components.common.trsad.ADPos 中的静态变量
MAX_PAGE_SIZE - 类 com.trs.infra.util.database.DBType 中的静态变量
MAX_READ_COUNT - 类 com.trs.components.wcm.publish.domain.PreNextDocumentsImpl 中的静态变量
MAX_RIGHT_CACHE_SIZE - 类 com.trs.cms.auth.domain.RightCacheMgr 中的静态变量
MAX_ROW_NUM - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态变量
MAX_USERNAME_CACHE_SIZE - 类 com.trs.cms.auth.persistent.UserCacheMgr 中的静态变量
MAXLENGTH - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
MAXTARGETS_EACHFOLDER - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr 中的静态变量
每个目录做多允许的分发点
MD5 - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MD5() - 类 com.trs.infra.util.MD5 的构造方法
MediaBuilder - com.trs.tools 中的 类
MediaBuilder() - 类 com.trs.tools.MediaBuilder 的构造方法
MediaRemindedAgent - com.trs.components.wcm.wcmx.media 中的 类
Created by IntelliJ IDEA.
MediaRemindedAgent() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 的构造方法
MediaRemindedInfo - com.trs.components.wcm.wcmx.media 中的 类
MediaRemindedInfo() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 的构造方法
构造函数：保留默认接口
MediaRemindedInfos - com.trs.components.wcm.wcmx.media 中的 类
MediaRemindedInfos(User) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfos 的构造方法
构造函数
MediaRemindedInfos(User, int, int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfos 的构造方法
构造函数
MEDIUBLOB - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
MEDIUMTEXT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
MENU - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
MenuArea - com.trs.components.infoview.extract.manifest 中的 类
/xsf:xDocumentClass/xsf:views/xsf:view/xsf:menuArea
MenuArea() - 类 com.trs.components.infoview.extract.manifest.MenuArea 的构造方法
MenuButton - com.trs.components.infoview.extract.manifest 中的 类
/xsf:xDocumentClass/xsf:views/xsf:view/xsf:menuArea/xsf:button
MenuButton() - 类 com.trs.components.infoview.extract.manifest.MenuButton 的构造方法
merge(Reports) - 类 com.trs.infra.util.Reports 中的方法
mergeMoreFilter(MethodContext, WCMFilter) - 类 com.trs.webframework.context.MethodContextHelper 中的静态方法
mergeWith(QueryFilter) - 类 com.trs.infra.db.QueryFilter 中的方法
过滤器的合并
mergeWith(WCMFilter) - 类 com.trs.infra.persistent.WCMFilter 中的方法
过滤器的合并
Message - com.trs.components.common.message 中的 类
Message() - 类 com.trs.components.common.message.Message 的构造方法
MESSAGE_FILE_MODIFIED - 类 com.trs.cluster.ClusterConstants 中的静态变量
文件更改消息
MESSAGE_FILE_WITHDRAW - 类 com.trs.cluster.ClusterConstants 中的静态变量
发布文件撤除消息
MESSAGE_METADATA_APPCREATE - 类 com.trs.cluster.ClusterConstants 中的静态变量
MESSAGE_RECEIVED - 类 com.trs.infra.common.WCMTypes 中的静态变量
已接收短消息
MESSAGE_RELOAD_TABLE - 类 com.trs.cluster.ClusterConstants 中的静态变量
重新装入表的结构
MESSAGE_REMOVE_TABLE - 类 com.trs.cluster.ClusterConstants 中的静态变量
删除表的结构
MESSAGE_RREFRESH_PROPERTY - 类 com.trs.cluster.ClusterConstants 中的静态变量
强制刷新Cache对象中的指定字段的值
MESSAGE_SENT - 类 com.trs.infra.common.WCMTypes 中的静态变量
已发送短消息
MESSAGE_STATE_CALLBOARD - 类 com.trs.components.common.message.Message 中的静态变量
MESSAGE_STATE_DELETE - 类 com.trs.components.common.message.Message 中的静态变量
MESSAGE_STATE_NODELETE - 类 com.trs.components.common.message.Message 中的静态变量
旧的常量，保留
MESSAGE_UNREAD - 类 com.trs.infra.common.WCMTypes 中的静态变量
未读短消息
Messages - com.trs.components.common.message 中的 类
Messages(User) - 类 com.trs.components.common.message.Messages 的构造方法
Messages(User, int, int) - 类 com.trs.components.common.message.Messages 的构造方法
MessageSendingConfig - com.trs.components.common.message 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MessageSendingConfig() - 类 com.trs.components.common.message.MessageSendingConfig 的构造方法
MessageSendingMapper - com.trs.components.common.message 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
通过名称查找到相应SenderWorker的散列查找表，封装了操作配置文件逻辑
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MessageSendingMapper() - 类 com.trs.components.common.message.MessageSendingMapper 的构造方法
MessageServer - com.trs.components.common.message 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
消息服务提供者：MessageServer
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MessageServer() - 类 com.trs.components.common.message.MessageServer 的构造方法
MessageServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
消息中心服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MessageServiceProvider() - 类 com.trs.ajaxservice.MessageServiceProvider 的构造方法
MessageToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Message XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MessageToXML() - 类 com.trs.ajaxservice.xmlconvertors.MessageToXML 的构造方法
META - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
MetaAppCreateMsgReceiver - com.trs.cluster.receiver 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
MetaAppCreateMsgReceiver() - 类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 的构造方法
MetaDataCenterClassInfoHelper - com.trs.components.metadata.center 中的 类
MetaDataCenterClassInfoHelper() - 类 com.trs.components.metadata.center.MetaDataCenterClassInfoHelper 的构造方法
MetaDataCenterHelper - com.trs.components.metadata.center 中的 类
MetaDataCenterHelper() - 类 com.trs.components.metadata.center.MetaDataCenterHelper 的构造方法
MetaDataCenterServiceProvider - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataCenterServiceProvider() - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 的构造方法
MetaDataCenterServiceProviderForAgri - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataCenterServiceProviderForAgri() - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 的构造方法
MetaDataCenterServiceProviderForGB - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataCenterServiceProviderForGB() - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 的构造方法
MetaDataCenterServiceProviderForZJH - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataCenterServiceProviderForZJH() - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH 的构造方法
MetaDataConstants - com.trs.components.metadata 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataConstants() - 类 com.trs.components.metadata.MetaDataConstants 的构造方法
MetaDataDDLImporter - com.trs.components.metadata.definition.xml 中的 类
MetaDataDDLImporter(User) - 类 com.trs.components.metadata.definition.xml.MetaDataDDLImporter 的构造方法
MetaDataDefCacheMgr - com.trs.components.metadata.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataDefCacheMgr() - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 的构造方法
MetaDataDefHelper - com.trs.components.metadata.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataDefHelper() - 类 com.trs.components.metadata.definition.MetaDataDefHelper 的构造方法
MetaDataDefMgr - com.trs.components.metadata.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataDefMgr() - 类 com.trs.components.metadata.definition.MetaDataDefMgr 的构造方法
MetaDataDefServiceProvider - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台定义服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataDefServiceProvider() - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 的构造方法
MetaDataLoader - com.trs.infra.util.upgrade.dbcompare 中的 类
数据库表描述对象
MetaDataLoader(Connection, String) - 类 com.trs.infra.util.upgrade.dbcompare.MetaDataLoader 的构造方法
构造函数
MetaDataType - com.trs.components.metadata.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据类型定义对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataType(int, String, String, int, int) - 类 com.trs.components.metadata.definition.MetaDataType 的构造方法
MetaDataTypes - com.trs.components.metadata.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据定义所支持的所有类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaDataTypes() - 类 com.trs.components.metadata.definition.MetaDataTypes 的构造方法
MetaDBField - com.trs.components.metadata.definition 中的 类
MetaDBField() - 类 com.trs.components.metadata.definition.MetaDBField 的构造方法
构造函数：保留默认接口
MetaDBFieldListenerForChannelSynRule - com.trs.components.metadata.definition 中的 类
MetaDBFieldListenerForChannelSynRule() - 类 com.trs.components.metadata.definition.MetaDBFieldListenerForChannelSynRule 的构造方法
MetaDBFields - com.trs.components.metadata.definition 中的 类
MetaDBFields(User) - 类 com.trs.components.metadata.definition.MetaDBFields 的构造方法
构造函数
MetaDBFields(User, int, int) - 类 com.trs.components.metadata.definition.MetaDBFields 的构造方法
构造函数
MetaDBFieldXMLConvertor - com.trs.components.metadata.definition.xml 中的 类
MetaDBFieldXMLConvertor() - 类 com.trs.components.metadata.definition.xml.MetaDBFieldXMLConvertor 的构造方法
MetaDBTable - com.trs.components.metadata.definition 中的 类
MetaDBTable() - 类 com.trs.components.metadata.definition.MetaDBTable 的构造方法
构造函数：保留默认接口
MetaDBTables - com.trs.components.metadata.definition 中的 类
MetaDBTables(User) - 类 com.trs.components.metadata.definition.MetaDBTables 的构造方法
构造函数
MetaDBTables(User, int, int) - 类 com.trs.components.metadata.definition.MetaDBTables 的构造方法
构造函数
MetaTableXMLConvertor - com.trs.components.metadata.definition.xml 中的 类
MetaTableXMLConvertor(MetaViews) - 类 com.trs.components.metadata.definition.xml.MetaTableXMLConvertor 的构造方法
MetaView - com.trs.components.metadata.definition 中的 类
MetaView() - 类 com.trs.components.metadata.definition.MetaView 的构造方法
构造函数：保留默认接口
MetaViewData - com.trs.components.metadata.center 中的 类
MetaViewData() - 类 com.trs.components.metadata.center.MetaViewData 的构造方法
MetaViewData(MetaView) - 类 com.trs.components.metadata.center.MetaViewData 的构造方法
MetaViewData(String) - 类 com.trs.components.metadata.center.MetaViewData 的构造方法
MetaViewData(String, String) - 类 com.trs.components.metadata.center.MetaViewData 的构造方法
MetaViewData(MetaView, HashMap) - 类 com.trs.components.metadata.center.MetaViewData 的构造方法
MetaViewDataExporter - com.trs.components.metadata.center.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewDataExporter(MetaView) - 类 com.trs.components.metadata.center.xml.MetaViewDataExporter 的构造方法
MetaViewDataImporter - com.trs.components.metadata.center.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewDataImporter(User, MetaView, Channel) - 类 com.trs.components.metadata.center.xml.MetaViewDataImporter 的构造方法
MetaViewDataRelateSource - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
获取相关文件
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
MetaViewDataRelateSource() - 类 com.trs.components.metadata.publish.MetaViewDataRelateSource 的构造方法
MetaViewDatas - com.trs.components.metadata.center 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewDatas(MetaView) - 类 com.trs.components.metadata.center.MetaViewDatas 的构造方法
MetaViewDatas(String) - 类 com.trs.components.metadata.center.MetaViewDatas 的构造方法
MetaViewDatas(String, String) - 类 com.trs.components.metadata.center.MetaViewDatas 的构造方法
MetaViewDatas(User, int, int) - 类 com.trs.components.metadata.center.MetaViewDatas 的构造方法
MetaViewDatas() - 类 com.trs.components.metadata.center.MetaViewDatas 的构造方法
MetaViewDataToExcel - com.trs.components.metadata.center.xml 中的 类
MetaViewDataToExcel(MetaView) - 类 com.trs.components.metadata.center.xml.MetaViewDataToExcel 的构造方法
MetaViewDataToXML - com.trs.components.metadata.center.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
将元数据转换成XML
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewDataToXML(MetaView) - 类 com.trs.components.metadata.center.xml.MetaViewDataToXML 的构造方法
MetaViewEmployer - com.trs.components.metadata.center 中的 类
MetaViewEmployer() - 类 com.trs.components.metadata.center.MetaViewEmployer 的构造方法
MetaViewEmployerMgr - com.trs.components.metadata.center 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据视图使用关系维护对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewEmployerMgr() - 类 com.trs.components.metadata.center.MetaViewEmployerMgr 的构造方法
MetaViewEmployers - com.trs.components.metadata.center 中的 类
MetaViewEmployers() - 类 com.trs.components.metadata.center.MetaViewEmployers 的构造方法
MetaViewEmplyerConverterForChannelImporter - com.trs.components.metadata.service.domain 中的 类
MetaViewEmplyerConverterForChannelImporter() - 类 com.trs.components.metadata.service.domain.MetaViewEmplyerConverterForChannelImporter 的构造方法
MetaViewExporter - com.trs.components.metadata.definition.xml 中的 类
MetaViewExporter() - 类 com.trs.components.metadata.definition.xml.MetaViewExporter 的构造方法
MetaViewField - com.trs.components.metadata.definition 中的 类
MetaViewField() - 类 com.trs.components.metadata.definition.MetaViewField 的构造方法
构造函数：保留默认接口
MetaViewFields - com.trs.components.metadata.definition 中的 类
MetaViewFields(User) - 类 com.trs.components.metadata.definition.MetaViewFields 的构造方法
构造函数
MetaViewFields(User, int, int) - 类 com.trs.components.metadata.definition.MetaViewFields 的构造方法
构造函数
MetaViewFieldXMLConvertor - com.trs.components.metadata.definition.xml 中的 类
MetaViewFieldXMLConvertor() - 类 com.trs.components.metadata.definition.xml.MetaViewFieldXMLConvertor 的构造方法
MetaViewHelper - com.trs.components.metadata.center 中的 类
MetaViewHelper() - 类 com.trs.components.metadata.center.MetaViewHelper 的构造方法
MetaViewImporter - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
视图定义导入器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MetaViewImporter(User, MetaView) - 类 com.trs.components.metadata.service.MetaViewImporter 的构造方法
MetaViews - com.trs.components.metadata.definition 中的 类
MetaViews(User) - 类 com.trs.components.metadata.definition.MetaViews 的构造方法
构造函数
MetaViews(User, int, int) - 类 com.trs.components.metadata.definition.MetaViews 的构造方法
构造函数
MetaViewXMLConvertor - com.trs.components.metadata.definition.xml 中的 类
MetaViewXMLConvertor() - 类 com.trs.components.metadata.definition.xml.MetaViewXMLConvertor 的构造方法
METHOD - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
METHOD_TYPE_ALL - 类 com.trs.webframework.FrameworkConstants 中的静态变量
METHOD_TYPE_DELETE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
METHOD_TYPE_FINDBYID - 类 com.trs.webframework.FrameworkConstants 中的静态变量
METHOD_TYPE_FINDBYIDS - 类 com.trs.webframework.FrameworkConstants 中的静态变量
METHOD_TYPE_QUERY - 类 com.trs.webframework.FrameworkConstants 中的静态变量
METHOD_TYPE_SAVE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
METHOD_TYPES - 类 com.trs.webframework.FrameworkConstants 中的静态变量
MethodConfig - com.trs.webframework.config 中的 类
MethodConfig(int, ServiceConfig) - 类 com.trs.webframework.config.MethodConfig 的构造方法
MethodContext - com.trs.webframework.context 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Provider中方法上下文服务相关对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MethodContext(MethodConfig) - 类 com.trs.webframework.context.MethodContext 的构造方法
MethodContextHelper - com.trs.webframework.context 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
mFileEncodingMap - 类 com.trs.tools.ChineseFinder 中的静态变量
MIDDLE_REGION_NUMBER - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
中部
MIMEBase64 - com.trs.infra.util.email 中的 类
MIMEBase64() - 类 com.trs.infra.util.email.MIMEBase64 的构造方法
minusWith(BaseObjs) - 类 com.trs.infra.persistent.BaseObjs 中的方法
与指定集合做减法运算
MINUTE - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日期/时间的各个部分标识：分（5）
mirror(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
镜像文档
mirror(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
镜像文档
mirrorTo(Document, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
将实体文档镜像转发到另一个频道
草稿箱中的文档无法转发
目标频道为空无法转发
mirrorTo(Document, Channel) - 接口 com.trs.service.IDocumentService 中的方法
将文档在另一个频道中建立一个同源异现的镜像
mirrorTo(String, String) - 接口 com.trs.service.IDocumentService 中的方法
镜像转发频道文档集合
将一堆文档镜像转发到某个频道 一堆文档可以是一个检索的结果
mirrorTo(String, int, String) - 接口 com.trs.service.IDocumentService 中的方法
将一组文档镜像转发到多个目标频道下
一般这样的操作是在文档列表页面执行的
mirrorTo(Document, Channel) - 类 com.trs.service.impl.DocumentService 中的方法
mirrorTo(String, String) - 类 com.trs.service.impl.DocumentService 中的方法
mirrorTo(String, int, String) - 类 com.trs.service.impl.DocumentService 中的方法
MODAL_ALL - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
定义ChnlDoc类型： 所有类型
MODAL_ENTITY - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
定义ChnlDoc类型：实体文档/源文档
MODAL_LINK - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
定义ChnlDoc类型：引用转发
MODAL_MIRROR - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
定义ChnlDoc类型：同源转发（镜像）
MODAL_STAT_NORM - 类 com.trs.components.stat.StatDocCountByChannel 中的静态变量
MODAL_STAT_NORM - 类 com.trs.components.stat.StatDocCountOfGroupByChannel 中的静态变量
MODAL_STAT_NORM - 类 com.trs.components.stat.StatDocCountOfGroupByMetaClass 中的静态变量
MODAL_STAT_NORM - 类 com.trs.components.stat.StatDocCountOfUserByMetaClass 中的静态变量
MODAL_STAT_SNAP - 类 com.trs.components.stat.StatDocCountByChannel 中的静态变量
MODAL_STAT_SNAP - 类 com.trs.components.stat.StatDocCountOfGroupByChannel 中的静态变量
MODAL_STAT_SNAP - 类 com.trs.components.stat.StatDocCountOfGroupByMetaClass 中的静态变量
MODAL_STAT_SNAP - 类 com.trs.components.stat.StatDocCountOfUserByMetaClass 中的静态变量
MODE_MORE_TIMES_DAY - 类 com.trs.components.common.job.Schedule 中的静态变量
模式类型：每天执行多次
MODE_NEXT - 类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 中的静态变量
MODE_ONE_TIME_DAY - 类 com.trs.components.common.job.Schedule 中的静态变量
模式类型：每天执行一次
MODE_ONE_TIME_ONLY - 类 com.trs.components.common.job.Schedule 中的静态变量
模式类型：仅仅运行一次
MODE_PRE - 类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 中的静态变量
MODULE_FLOW - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的静态变量
托管模块常量定义
MONEY - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：MONEY
MONEY - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：MONEY
MONEY - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：MONEY
MonitorHostConfig - com.trs.infra.persistent.listener 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MonitorHostConfig() - 类 com.trs.infra.persistent.listener.MonitorHostConfig 的构造方法
montageImages(String[], String, String, String, String, int) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
生成组图
montageImages(String[], String, String, String, String, int) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
MONTH - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日期/时间的各个部分标识：月（2）
MONTHS - 类 com.trs.infra.util.CMyDateTime 中的静态变量
move(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
移动文档
move(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
移动文档
move(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
移动文档
move(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
移动指针：从当前位置移动指定的步数
move(int, int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
移动指针：从指定起始位置移动指定步数
MOVE_AS_BROTHER - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道移动的方式：作为目标频道的兄弟移动
MOVE_AS_CHILD - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道移动的方式：作为目标频道的子节点移动
moveAll(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
移动全部文档
moveAllDocumentsToChannel(Channel, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
移动当前栏目下现有文档到指定的频道
moveAsChild(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
移动栏目
moveAsChild(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
moveBackward(int, int) - 接口 com.trs.service.IDocumentService 中的方法
将文档向后移动一位
需要将两篇文档对换顺序
如果文档已经是最后一篇，则不移动
置顶区域中的文档不能移动
moveBackward(int, int) - 类 com.trs.service.impl.DocumentService 中的方法
moveBookMark(BookMark, MarkKind) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
将一个书签从移动新的分类中
moveBookMark(int, int) - 接口 com.trs.service.IBookMarkService 中的方法
移动指定书签到目标书签文件夹下
moveBookMark(String, int) - 接口 com.trs.service.IBookMarkService 中的方法
移动指定书签集合到目标书签文件夹下
moveBookMark(int, int) - 类 com.trs.service.impl.BookMarkService 中的方法
moveBookMark(String, int) - 类 com.trs.service.impl.BookMarkService 中的方法
moveBookMarks(String, int) - 接口 com.trs.service.IBookMarkService 中的方法
移动指定的书签集合到目标书签夹下.
moveBookMarks(String, int) - 类 com.trs.service.impl.BookMarkService 中的方法
MoveChannelListenerForChannel - com.trs.ajaxservice.listener 中的 类
MoveChannelListenerForChannel() - 类 com.trs.ajaxservice.listener.MoveChannelListenerForChannel 的构造方法
moveDocumentInChannel(Document, Document, Channel, int) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
在频道中移动文档的顺序
如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
moveDocumentInChannel(Document, Document, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
在频道中移动文档的顺序
如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
moveDocumentInChannel(int, int, int) - 接口 com.trs.service.IDocumentService 中的方法
在频道中移动文档的顺序
如果是向前移动，则移动到目标文档之前；如果是向后移动，则移动到目标文档之后
通过Doc和Chnl得到ChnlDoc的顺序来完成移动操作
置顶区域和普通文档区域不能互相移动文档，置顶区域内部也不能移动文档
moveDocumentInChannel(int, int, int, int) - 接口 com.trs.service.IDocumentService 中的方法
moveDocumentInChannel(int, int, int) - 类 com.trs.service.impl.DocumentService 中的方法
moveDocumentInChannel(int, int, int, int) - 类 com.trs.service.impl.DocumentService 中的方法
moveDocumentsToChannel(ViewDocuments, Channel, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
moveFile(String, String, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
将指定文件移动到指定的目录
moveFile(String, String) - 类 com.trs.infra.util.CImage 中的方法
moveFile(String, String) - 类 com.trs.infra.util.CMyFile 中的静态方法
移动文件
moveFile(String, String, boolean) - 类 com.trs.infra.util.CMyFile 中的静态方法
移动文件
moveFirst() - 类 com.trs.infra.persistent.BaseObjs 中的方法
移动指针到第一个元素,若集合为空，置当前指针为POS_BOF
moveFirst(int, int) - 接口 com.trs.service.IDocumentService 中的方法
将文档移动到频道内第一的位置
需要将该移动文档前面的所有文档后移一位
如果文档已经是第一篇，则不移动
移动后的文档不进入置顶区域，是置顶区后的第一篇
置顶区域中的文档也不能移动
moveFirst(int, int) - 类 com.trs.service.impl.DocumentService 中的方法
moveForward(int, int) - 接口 com.trs.service.IDocumentService 中的方法
将文档向前移动一位
需要将两篇文档对换顺序
如果文档已经是第一篇，则不移动
移动后的文档不进入置顶区域，是置顶区后的第一篇
置顶区域中的文档也不能移动
moveForward(int, int) - 类 com.trs.service.impl.DocumentService 中的方法
---- ==== ---- Begin 文档拖动相关的操作 ---- vvvv ----
moveLast() - 类 com.trs.infra.persistent.BaseObjs 中的方法
移动指针到最后一个元素,若集合为空，置当前指针为POS_EOF
moveLast(int, int) - 接口 com.trs.service.IDocumentService 中的方法
将文档移动到最后的位置
需要将该移动文档后面的所有文档向前移一位
如果文档已经是最后一篇，则不移动
置顶区域中的文档也不能移动
moveLast(int, int) - 类 com.trs.service.impl.DocumentService 中的方法
moveMarkKind(MarkKind, MarkKind) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
移动一个书签类别
moveMarkKind(int, int) - 接口 com.trs.service.IBookMarkService 中的方法
移动指定书签文件夹到一个新的书签文件夹下
moveMarkKind(String, int) - 接口 com.trs.service.IBookMarkService 中的方法
移动指定书签文件夹集合到一个新的书签文件夹下
moveMarkKind(int, int) - 类 com.trs.service.impl.BookMarkService 中的方法
moveMarkKind(String, int) - 类 com.trs.service.impl.BookMarkService 中的方法
moveNext() - 类 com.trs.infra.persistent.BaseObjs 中的方法
移动指针到下一个元素
movePrevious() - 类 com.trs.infra.persistent.BaseObjs 中的方法
移动指针到前一个元素
moveTo(Channel, BaseChannel, int) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
moveTo(Channel, WebSite, int) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
将栏目移动到站点，作为兄弟或者子栏目
moveTo(Channel, Channel, int) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
将栏目移动到栏目，作为兄弟或者子栏目
moveTo(Document, Channel, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
将文档从一个频道移动到另一个频道
支持引用和镜像的移动
如果是草稿箱中的，则不支持移动；也不支持移动到草稿箱 如果目标频道下已经存在，则无法移动
moveTo(Document, Channel, Channel, String) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
moveTo(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
移动指针到指定位置
moveTo(Channel, WebSite, int) - 接口 com.trs.service.IChannelService 中的方法
将频道移动到站点下，作为站点的一级子频道
moveTo(Channel, Channel, int) - 接口 com.trs.service.IChannelService 中的方法
将频道移动到另一个频道下，作为该频道的子频道或者兄弟
moveTo(WebSite, WebSite, int) - 接口 com.trs.service.IChannelService 中的方法
将站点移动到另一个站点下，作为该站点的子站点或者兄弟
moveTo(String, int, String) - 接口 com.trs.service.IDocumentService 中的方法
将文档从指定的频道移动到多个目标频道下
一般这样的操作是在文档列表页面执行的
moveTo(String, String) - 接口 com.trs.service.IDocumentService 中的方法
移动文档集合
将一堆文档移动到某个频道 一堆文档可以是一个检索的结果
moveTo(Group, Group) - 接口 com.trs.service.IGroupService 中的方法
移动组织，将一个组织移动到另一个组织下
moveTo(Channel, WebSite, int) - 类 com.trs.service.impl.ChannelService 中的方法
moveTo(Channel, Channel, int) - 类 com.trs.service.impl.ChannelService 中的方法
moveTo(WebSite, WebSite, int) - 类 com.trs.service.impl.ChannelService 中的方法
moveTo(String, int, String) - 类 com.trs.service.impl.DocumentService 中的方法
moveTo(String, String) - 类 com.trs.service.impl.DocumentService 中的方法
moveTo(Group, Group) - 类 com.trs.service.impl.GroupService 中的方法
moveToCurrentPageInRs(ResultSet) - 类 com.trs.infra.util.CPager 中的方法
在记录集中定位到当前页
moveToGroup(SSOUser, SSOGroup) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
将用户添加到组织中去
moveUser(User, Group, Group) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
更改指定用户的组织
moveUser(User, Group, Group) - 接口 com.trs.service.IGroupService 中的方法
将指定用户从某个组移动到指定的另外一个组中
moveUser(User, Group, Groups) - 接口 com.trs.service.IGroupService 中的方法
将指定的用户从某个组移动到指定的多个组中
moveUser(User, Group, Group) - 类 com.trs.service.impl.GroupService 中的方法
moveUser(User, Group, Groups) - 类 com.trs.service.impl.GroupService 中的方法
moveViewDataByClassInfos(MetaViewData, ClassInfos, ClassInfo, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
moveViewDataByClassInfos(MetaViewData, MetaViewField, ClassInfos, ClassInfo, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
moveViewDataByClassInfos(MetaViewData, ClassInfos, ClassInfo, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录oViewData的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
moveViewDataByClassInfos(MetaViewData, MetaViewField, ClassInfos, ClassInfo, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录oViewData的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在oViewField字段中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
moveViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
将某些分类法下的记录移动到另一个分类法下
moveViewDatasByClassInfo(User, ClassInfo, int) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
moveViewDatasByClassInfo(User, ClassInfo, String) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
moveViewDatasByClassInfo(MetaViewData, ClassInfo, ClassInfo, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
moveViewDatasByClassInfo(MetaViewDatas, ClassInfo, ClassInfo, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
moveViewDatasByClassInfo(MetaViewData, MetaViewField, ClassInfo, ClassInfo, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
moveViewDatasByClassInfo(User, ClassInfo, String) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录的分类法由_oSrcClassInfo转换为_destClassInfoId 如果_destClassInfoId为null，则只删除记录的_oSrcClassInfo
moveViewDatasByClassInfo(User, ClassInfo, int) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录的分类法由_oSrcClassInfo转换为_nDestClassInfoId 如果_nDestClassInfoId为0，则只删除记录的_oSrcClassInfo
moveViewDatasByClassInfo(MetaViewData, ClassInfo, ClassInfo, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
获取指定记录oViewData的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
moveViewDatasByClassInfo(MetaViewDatas, ClassInfo, ClassInfo, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
获取指定记录集oViewDatas的满足oSrcClassInfo要求的分类法字段，将这些获取的分类法字段的值由原来的oSrcClassInfo 换成新的分类法值oDestClassInfo，如果oDestClassInfo为null，则仅删除oSrcClassInfo的值
moveViewDatasByClassInfo(MetaViewData, MetaViewField, ClassInfo, ClassInfo, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录oViewData的分类法字段oViewField，由原来的分类值oSrcClassInfo换成新的分类值oDestClassInfo 如果oDestClassInfo为空的话，则只删除原来的分类
moveViewDatasByClassInfos(MetaViewDatas, ClassInfos, ClassInfo, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
moveViewDatasByClassInfos(MetaViewDatas, MetaViewField, ClassInfos, ClassInfo, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
moveViewDatasByClassInfos(MetaViewDatas, ClassInfos, ClassInfo, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录集oViewDatas的所有可能分类字段由oSrcClassInfos转换成新的分类法oDestClassInfo，如果oSrcClassInfos 中的某个分类在当前记录字段中不存在，则忽略；如果oDestClassInfo为null，则仅删除oSrcClassInfos分类
moveViewDatasByClassInfos(MetaViewDatas, MetaViewField, ClassInfos, ClassInfo, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录集oViewDatas的分类字段oViewField由oSrcClassInfos转换成新的分类法oDestClassInfo；如果oSrcClassInfos 中的某个分类在字段oViewField中不存在，则忽略；如果oDestClassInfo 为null，则仅删除oSrcClassInfos分类
moveWCMFile(String, String, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
将指定文件移动到指定的目录
MSG_NOT_SET_DETAIL_TEMPLATE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
MSG_NOT_SET_OUTLINE_TEMPLATE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
MSG_NOT_SET_PUBLISH_PROPERTIES - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
MSG_SET_TO_CANNOT_PUBLISH - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
设置成不能发布
MSG_STATUS_CANNOT_PUBLISH - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
为成不能发布状态
MsgQueue - com.trs.components.common.message 中的 类
MsgQueue() - 类 com.trs.components.common.message.MsgQueue 的构造方法
MsgQueues - com.trs.components.common.message 中的 类
MsgQueues(User) - 类 com.trs.components.common.message.MsgQueues 的构造方法
MsgQueues(User, int, int) - 类 com.trs.components.common.message.MsgQueues 的构造方法
MsgReceiver - com.trs.components.common.message 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
消息接收者对象,记录消息与消息接收者的联系
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MsgReceiver() - 类 com.trs.components.common.message.MsgReceiver 的构造方法
MsgReceivers - com.trs.components.common.message 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
消息接收者集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MsgReceivers() - 类 com.trs.components.common.message.MsgReceivers 的构造方法
MsgSendHandler - com.trs.cms.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
发送消息操作者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MsgSendHandler() - 类 com.trs.cms.process.engine.handlers.MsgSendHandler 的构造方法
MsgSendWorker - com.trs.components.common.message 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
短消息发送者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MsgSendWorker() - 类 com.trs.components.common.message.MsgSendWorker 的构造方法
MssqlUpdSqlMaker - com.trs.infra.util.upgrade.sql 中的 类
MssqlUpdSqlMaker() - 类 com.trs.infra.util.upgrade.sql.MssqlUpdSqlMaker 的构造方法
mul(double, double) - 类 com.trs.infra.util.CMyDecimalBuddy 中的静态方法
乘法运算。
MULTI - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 中的静态变量
MULTI_MODE - 类 com.trs.presentation.nav.NavConstatns 中的静态变量
包含分类法在内的导航模式
MULTIPLE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
MyBaseObj - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MyBaseObj() - 类 com.trs.infra.persistent.MyBaseObj 的构造方法
MyBaseObjs - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MyBaseObjs() - 类 com.trs.infra.persistent.MyBaseObjs 的构造方法
MyBaseObjs(int, int) - 类 com.trs.infra.persistent.MyBaseObjs 的构造方法
MyDate - com.trs.infra.persistent.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MyDate() - 类 com.trs.infra.persistent.db.MyDate 的构造方法
MyDB - com.trs.components.wcm 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MyDB() - 类 com.trs.components.wcm.MyDB 的构造方法
MyFlowContentDocumentImpl - com.trs.components.wcm.process.element 中的 类
MyFlowContentDocumentImpl(Document) - 类 com.trs.components.wcm.process.element.MyFlowContentDocumentImpl 的构造方法
MyFlowContentDocumentImpl(int) - 类 com.trs.components.wcm.process.element.MyFlowContentDocumentImpl 的构造方法
MyFlowContentDocumentImpl() - 类 com.trs.components.wcm.process.element.MyFlowContentDocumentImpl 的构造方法
MyPlugin - com.trs.components.wcm 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MyPlugin() - 类 com.trs.components.wcm.MyPlugin 的构造方法
MySite - com.trs.components.wcm.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
时间处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MySite() - 类 com.trs.components.wcm.content.MySite 的构造方法
MYSQL - 类 com.trs.infra.util.database.DBTypes 中的静态变量
定义数据库类型：Mysql
MYSQLDB - 类 com.trs.infra.util.database.DBTypes 中的静态变量
数据库类型对象：Mysql
MysqlDB - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
msql 数据库,使用mysql-connector-java-5.0.4-bin.jar驱动
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
MysqlDB() - 类 com.trs.infra.util.database.MysqlDB 的构造方法
MysqlDB(String, String) - 类 com.trs.infra.util.database.MysqlDB 的构造方法
构造函数
注：支持存储过程
MySSLSocketFactory - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
MySSLSocketFactory() - 类 com.trs.infra.util.MySSLSocketFactory 的构造方法
MySSLSocketFactory.MyX509TrustManager - com.trs.infra.util 中的 类
MySSLSocketFactory.MyX509TrustManager() - 类 com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager 的构造方法
MySystemInfo - com.trs.components.wcm.content.persistent 中的 类
MySystemInfo() - 类 com.trs.components.wcm.content.persistent.MySystemInfo 的构造方法
MyTypes - com.trs.infra 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: 用以定义WCM中的对象类型编码常量、以及各个WCM系统中所用到的常量 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
MyTypes() - 类 com.trs.infra.MyTypes 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


N - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

N

N - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
NAME - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
name - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
列名
NAME_DATA_FIELD - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的静态变量
NAME_DATA_SECTION - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的静态变量
NAME_FILE_BEAN - 类 com.trs.infra.config.ConfigConstants 中的静态变量
NAME_FILE_CONFIG - 类 com.trs.infra.config.ConfigConstants 中的静态变量
NAME_FILE_MAPPING - 类 com.trs.infra.config.ConfigConstants 中的静态变量
NAME_IMAGE_BOX - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态变量
NAME_IMAGE_PREFIX - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态变量
NAME_PARAMETER_FROM_TABLE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAME_PARAMETER_METHOD_NAME - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAME_PARAMETER_OBJECT_ID - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAME_PARAMETER_OBJECT_IDS - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAME_PARAMETER_ORDERBY_FIELD - 类 com.trs.webframework.context.MethodContextHelper 中的静态变量
NAME_PARAMETER_ORDERBY_FIELD - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAME_PARAMETER_ORDERBY_TYPE - 类 com.trs.webframework.context.MethodContextHelper 中的静态变量
NAME_PARAMETER_ORDERBY_TYPE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAME_PARAMETER_RESERVE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAME_PARAMETER_SELECTED_FIELDS - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAME_PARAMETER_SERVICE_ID - 类 com.trs.webframework.FrameworkConstants 中的静态变量
NAMED_ID - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的静态变量
NAMED_MULTIPLETEMPLATE - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的静态变量
NAMED_PUBTIME - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的静态变量
nameIs(String) - 类 com.trs.cms.auth.persistent.User 中的方法
判断是否为指定的用户名
nameIs(String) - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
判断名称是否为指定的名字
nameIs(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
判断当前对象是否是指定的Html元素标记
NamesRegister - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
names register.
NamesRegister() - 类 com.trs.infra.util.NamesRegister 的构造方法
constructor: default
NavConstatns - com.trs.presentation.nav 中的 类
NavConstatns() - 类 com.trs.presentation.nav.NavConstatns 的构造方法
NavHandlerFactory - com.trs.presentation.nav 中的 类
NavHandlerFactory() - 类 com.trs.presentation.nav.NavHandlerFactory 的构造方法
NCHAR - 类 com.trs.infra.util.database.DamengDB 中的静态变量
NCHAR - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：NCHAR
NCHAR - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：NCHAR
NCHAR - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：NCHAR
NCLOB - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：NCLOB
nCountForEach - 类 com.trs.util.ResetClassInfoOfViewData 中的变量
nCurrIndex - 类 com.trs.util.ResetClassInfoOfViewData 中的变量
needAuth() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法
NeedInit(boolean) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
needNotifyForEvent(String) - 类 com.trs.components.common.message.notify.NotificationServer 中的方法
check if it needs to notify for the specified event.
needsDictionary() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Returns true, if a preset dictionary is needed to inflate the input.
needsInput() - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Returns true, if the input buffer is empty.
needsInput() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Returns true, if the input buffer is empty.
NESTED_TEMPLATE - 类 com.trs.infra.common.ContextParameters 中的静态变量
预留索引
嵌套模板环路检查使用.
NetSnapTool - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
NetSnapTool工具辅助
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
NetSnapTool() - 类 com.trs.service.impl.NetSnapTool 的构造方法
NEW_MODE - 类 com.trs.components.wcm.content.domain.ChnlSynWorker 中的静态变量
NewChannelServiceProvider - com.trs.ajaxservice 中的 类
NewChannelServiceProvider() - 类 com.trs.ajaxservice.NewChannelServiceProvider 的构造方法
newInstance() - 类 com.trs.ajaxservice.ContentExtendValues 中的方法
newInstance() - 类 com.trs.cms.auth.persistent.GroupRoles 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.cms.auth.persistent.Groups 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.cms.auth.persistent.GroupUsers 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.cms.auth.persistent.ObjectMembers 中的方法
newInstance() - 类 com.trs.cms.auth.persistent.RightDefs 中的方法
newInstance() - 类 com.trs.cms.auth.persistent.Rights 中的方法
newInstance() - 类 com.trs.cms.auth.persistent.Roles 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.cms.auth.persistent.RoleUsers 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.cms.auth.persistent.TrusteeInfos 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.cms.auth.persistent.Users 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.cms.content.DefaultObjs 中的方法
newInstance() - 类 com.trs.cms.content.ExtendedFields 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.cms.process.definition.FlowActions 中的方法
newInstance() - 类 com.trs.cms.process.definition.FlowConditions 中的方法
newInstance() - 类 com.trs.cms.process.definition.FlowdocLogs 中的方法
newInstance() - 类 com.trs.cms.process.definition.FlowEmploys 中的方法
newInstance() - 类 com.trs.cms.process.definition.FlowNodeBranchs 中的方法
newInstance() - 类 com.trs.cms.process.definition.FlowNodeFields 中的方法
newInstance() - 类 com.trs.cms.process.definition.FlowNodes 中的方法
newInstance() - 类 com.trs.cms.process.definition.FlowRules 中的方法
newInstance() - 类 com.trs.cms.process.definition.Flows 中的方法
newInstance() - 类 com.trs.cms.process.engine.FlowContentConfigs 中的方法
newInstance() - 类 com.trs.cms.process.engine.FlowDocBaks 中的方法
newInstance() - 类 com.trs.cms.process.engine.FlowDocs 中的方法
newInstance() - 类 com.trs.components.comment.persistent.DocumentTopics 中的方法
newInstance() - 类 com.trs.components.comment.persistent.TopicedDocRelations 中的方法
newInstance() - 类 com.trs.components.common.address.ContactGrps 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.address.Contacts 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.bookmark.BookMarks 中的方法
newInstance() - 类 com.trs.components.common.bookmark.MarkKinds 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.bookmark.MarkShares 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.calendar.Events 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.calendar.EventShares 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.calendar.EventTypes 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.conjection.persistent.EntryConfigs 中的方法
newInstance() - 类 com.trs.components.common.job.JobWorkerTypes 中的方法
newInstance() - 类 com.trs.components.common.job.Schedules 中的方法
newInstance() - 类 com.trs.components.common.message.Messages 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.message.MsgQueues 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.message.MsgReceivers 中的方法
newInstance() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 中的方法
newInstance() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 中的方法
newInstance() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTasks 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.publish.persistent.template.TagBeans 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.publish.persistent.template.TempApdRels 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.publish.persistent.template.TempAppendixes 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的方法
newInstance() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploys 中的方法
newInstance() - 类 com.trs.components.common.publish.persistent.template.TemplateQuotes 中的方法
newInstance() - 类 com.trs.components.common.publish.persistent.template.Templates 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.ContentStyles 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.Layouts 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.Masters 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.PageStyles 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.ResourceStyles 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.StyleAndResources 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.StyleItems 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.WidgetInstances 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.WidgetInstParameters 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.WidgetParameters 中的方法
newInstance() - 类 com.trs.components.common.publish.widget.Widgets 中的方法
newInstance() - 类 com.trs.components.common.trsad.ADComs 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsad.ADFilePoss 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsad.ADFiles 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsad.ADPoss 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsad.ADTypes 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsvote.VoteDatas 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsvote.VoteIPLogs 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsvote.VoteItems 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsvote.VoteOptions 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.common.trsvote.Votes 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 中的方法
newInstance() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForms 中的方法
newInstance() - 类 com.trs.components.gkml.sqgk.persistent.MailConfigs 中的方法
newInstance() - 类 com.trs.components.infoview.helper.ComplexFieldDatas 中的方法
newInstance() - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的方法
newInstance() - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.infoview.persistent.InfoViewEmploys 中的方法
newInstance() - 类 com.trs.components.infoview.persistent.InfoViewFields 中的方法
newInstance() - 类 com.trs.components.infoview.persistent.InfoViewGroups 中的方法
newInstance() - 类 com.trs.components.infoview.persistent.InfoViews 中的方法
newInstance() - 类 com.trs.components.infoview.persistent.InfoViewViews 中的方法
newInstance() - 类 com.trs.components.metadata.center.ClassInfoViews 中的方法
newInstance() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
newInstance() - 类 com.trs.components.metadata.center.MetaViewEmployers 中的方法
newInstance() - 类 com.trs.components.metadata.definition.ClassInfos 中的方法
newInstance() - 类 com.trs.components.metadata.definition.MetaDBFields 中的方法
newInstance() - 类 com.trs.components.metadata.definition.MetaDBTables 中的方法
newInstance() - 类 com.trs.components.metadata.definition.MetaViewFields 中的方法
newInstance() - 类 com.trs.components.metadata.definition.MetaViews 中的方法
newInstance() - 类 com.trs.components.special.Specials 中的方法
newInstance() - 类 com.trs.components.stat.BonusRules 中的方法
newInstance() - 类 com.trs.components.stat.ChnlDepts 中的方法
newInstance() - 类 com.trs.components.stat.DocumentHitsCounts 中的方法
newInstance() - 类 com.trs.components.stat.HostObjDomains 中的方法
newInstance() - 类 com.trs.components.stat.HostObjHitsCounts 中的方法
newInstance() - 类 com.trs.components.stat.UserLoginInfos 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.Appendixes 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.AutoBakConfigs 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.ChannelContentLinks 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.Channels 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.ChannelSyns 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.wcm.content.persistent.ChnlDocs 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.wcm.content.persistent.ContentExtFields 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.ContentLinks 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.ContentLinkTypes 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.DocBaks 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.DocReplys 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.DocumentSyns 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.HitsCounts 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.wcm.content.persistent.Relations 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.Replaces 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.SiteMembers 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.wcm.content.persistent.WebSites 中的方法
newInstance() - 类 com.trs.components.wcm.content.persistent.XDocuments 中的方法
newInstance() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
newInstance() - 类 com.trs.components.wcm.customize.UserSettings 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 中的方法
newInstance() - 类 com.trs.components.wcm.individuation.Individuations 中的方法
newInstance() - 类 com.trs.components.wcm.publish.logo.Logos 中的方法
newInstance() - 类 com.trs.components.wcm.publish.region.CellInfos 中的方法
newInstance() - 类 com.trs.components.wcm.publish.region.RegionEmploys 中的方法
newInstance() - 类 com.trs.components.wcm.publish.region.RegionInfos 中的方法
newInstance() - 类 com.trs.components.wcm.publish.WCMPubStatusConfigs 中的方法
newInstance() - 类 com.trs.components.wcm.recent.Recents 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.components.wcm.resource.DocKinds 中的方法
newInstance() - 类 com.trs.components.wcm.resource.FileTypes 中的方法
newInstance() - 类 com.trs.components.wcm.resource.Keywords 中的方法
newInstance() - 类 com.trs.components.wcm.resource.Securities 中的方法
newInstance() - 类 com.trs.components.wcm.resource.Sources 中的方法
newInstance() - 类 com.trs.components.wcm.resource.Statuses 中的方法
newInstance() - 类 com.trs.components.wcm.stat.StatFieldMaps 中的方法
newInstance() - 类 com.trs.components.wcm.stat.StatHosts 中的方法
newInstance() - 类 com.trs.components.wcm.stat.StatViewRels 中的方法
newInstance() - 类 com.trs.components.wcm.stat.StatViews 中的方法
newInstance() - 类 com.trs.components.wcm.wcmx.help.WCMHelps 中的方法
newInstance() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfos 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.db.update.DBUpdateLogs 中的方法
newInstance() - 类 com.trs.infra.persistent.BaseObjs 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.infra.persistent.CMyResultSets 中的方法
newInstance() - 类 com.trs.infra.persistent.MyBaseObjs 中的方法
newInstance() - 类 com.trs.infra.support.config.Configs 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.infra.support.log.LogBaks 中的方法
newInstance() - 类 com.trs.infra.support.log.Logs 中的方法
newInstance() - 类 com.trs.infra.support.log.OperTypes 中的方法
newInstance() - 类 com.trs.infra.support.security.SecureKeys 中的方法
newInstance() - 类 com.trs.infra.util.job.JobFailedResults 中的方法
newInstance() - 类 com.trs.wcm.config.PageOperators 中的方法
newInstance() - 类 com.trs.wcm.old.WCMExcelDatas 中的方法
newInstance() - 类 com.trs.wcm.old.WCMFormFieldses 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.wcm.old.WCMFormInfos 中的方法
生成新的集合对象实例
newInstance() - 类 com.trs.wcm.photo.Watermarks 中的方法
newRelativeURL(String, String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
NewRightSet - com.trs.cms.auth.domain 中的 类
NewRightSet(User, IRightHost, List, int[]) - 类 com.trs.cms.auth.domain.NewRightSet 的构造方法
newScanner() - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentScanner 中的静态方法
NewsComment - com.trs.components.comment.domain 中的 类
在外交部项目中WCM和新闻评论协同时使用 用于在WCM中生成新闻的ID、标题、所属频道的ID和站点的ID，以及 该新闻发言控制的数字签名。
NewsComment() - 类 com.trs.components.comment.domain.NewsComment 的构造方法
缺省构造方法
NewsComment(String) - 类 com.trs.components.comment.domain.NewsComment 的构造方法
利用带有签名的数据还原“NewsComment”对象
NewsComment.CommentEmitEnum - com.trs.components.comment.domain 中的 类
NewsComment.CommentEmitEnum() - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 的构造方法
next() - 类 com.trs.components.stat.TimeRange 中的方法
判断当前是否还能获取到下一步长的时间
next() - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 中的方法
NINT - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
NINT - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
NO - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM逻辑值常量，布尔假值
NO - 类 com.trs.infra.MyTypes 中的静态变量
WCM逻辑值常量，布尔假值
NO_COMPRESSION - 类 com.trs.infra.util.jazzlib.Deflater 中的静态变量
This level won't compress at all but output uncompressed blocks.
NODE_FIELD_TYPE_GROUP - 类 com.trs.cms.process.definition.FlowNodeField 中的静态变量
NODE_FIELD_TYPE_NORMAL - 类 com.trs.cms.process.definition.FlowNodeField 中的静态变量
NODE_FIELD_TYPE_VIEW - 类 com.trs.cms.process.definition.FlowNodeField 中的静态变量
NOFRAMES - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
NOHREF - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
NoLoginServiceControler - com.trs.webframework.controler.servlet 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
不需要登录的控制器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
NoLoginServiceControler() - 类 com.trs.webframework.controler.servlet.NoLoginServiceControler 的构造方法
NORESIZE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
normalize() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
normalPattern - 类 com.trs.tools.SymbolC2E 中的静态变量
NOSHADE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
NoSuchServiceException - com.trs.webframework.exception 中的 异常
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
NoSuchServiceException() - 异常 com.trs.webframework.exception.NoSuchServiceException 的构造方法
NoSuchServiceException(String) - 异常 com.trs.webframework.exception.NoSuchServiceException 的构造方法
NoSuchServiceException(Throwable) - 异常 com.trs.webframework.exception.NoSuchServiceException 的构造方法
NoSuchServiceException(String, Throwable) - 异常 com.trs.webframework.exception.NoSuchServiceException 的构造方法
NOT_ON_TOP - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
NOT_OPER_CHNL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
记录非普通频道禁止的操作
NotificationConfig - com.trs.components.common.message.notify 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
NotificationConfig() - 类 com.trs.components.common.message.notify.NotificationConfig 的构造方法
NotificationSchemeConfig - com.trs.components.common.message.notify 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
NotificationSchemeConfig() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 的构造方法
NotificationServer - com.trs.components.common.message.notify 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
notification server.
NotificationServer() - 类 com.trs.components.common.message.notify.NotificationServer 的构造方法
constructor: default
notificationsSize() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法
logic for Notifications Collection
Notifier - com.trs.components.common.message.notify 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
worker to execute notification.
Notifier() - 类 com.trs.components.common.message.notify.Notifier 的构造方法
constructor: default
notify(int, Object, Object[]) - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 中的方法
notify(int, Object, Object[]) - 接口 com.trs.infra.support.cache.ICacheServer 中的方法
缓冲同步通知
notifyAddTable(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
添加数据表
notifyAddTable(Connection, DBType, String, String) - 类 com.trs.infra.util.database.TableInfos 中的方法
notifyComplete() - 类 com.trs.components.stat.ChannelHitsCountHandler 中的方法
notifyComplete() - 类 com.trs.components.stat.DocumentHitsCountHandler 中的方法
notifyComplete() - 接口 com.trs.components.stat.IHitsCountHandler 中的方法
在批量更新完点击量之后，将进行的处理，主要用来记录完点击量之后，做一下统一的写操作。
notifyComplete() - 类 com.trs.components.stat.SiteHitsCountHandler 中的方法
notifyObservers(IObserverable, int) - 接口 com.trs.webframework.xmlserver.server.IObserverable 中的方法
notifyObservers(IObserverable, int) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.auth.domain.RightHostLCListenerForInherit 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.auth.persistent.AdministratorCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.auth.persistent.GroupUserCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.auth.persistent.UserCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.process.definition.FlowCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.ckm.DocumentLCListenerForSIMSearch 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.job.ScheduleLCListenerForServer 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 中的方法
已过时。
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanLCListener 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.govinfo.GovInfoLCListenerMetaView 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.metadata.center.DocumentListenerForMetaViewData 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.epress.ChannelLCListener4EPress 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.publish.ChnlDocLCListnerForPublish 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
notifyOnAddObj(BaseObj) - 接口 com.trs.infra.persistent.listener.IObjectLCListenerOnAdd 中的方法
新增一个对象后通知所有的Cache
notifyOnAddObj(BaseObj) - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.infra.support.config.ConfigServer 中的方法
notifyOnAddObj(BaseObj) - 类 com.trs.infra.support.file.PathConfigLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.AdministratorCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.GroupUserCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.UserCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.process.definition.FlowCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.process.definition.FlowEmployerLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.process.definition.RuleHostLCListnerForCache 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.process.engine.FlowContentLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.cms.process.engine.FlowNodeLCListenerForForceEnd 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.ckm.DocumentLCListenerForSIMSearch 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.calendar.EventLCListenerForRemind 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.job.JobWorkerTypeLCListenerForSchedule 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.job.ScheduleLCListenerForFaieldResult 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.job.ScheduleLCListenerForServer 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 中的方法
已过时。
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.element.PublishContentLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.element.PublishFolderLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.widget.AdjustJsLCListenerWidget 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.govinfo.GovInfoLCListenerMetaView 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.metadata.center.DocumentListenerForMetaViewData 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.metadata.definition.ClassInfoListenerForViewData 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ApdHostLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.BaseChannelLCListener4ExtField 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.BaseChannelLCListener4Region 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForChannelSyn 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForDocument 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForExtField 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForSpeical 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ContentExtFieldCListenerForDocProps 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ContentExtFieldLCListenerForDocFields 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocBakLCListenerForApd 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForDocBak 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForDocReply 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelation 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.SiteMemberLCListner 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.WebSiteLCListenerForAutoDocBak 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.WebSiteLCListenerForContentLink 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.WebSiteLCListenerForSiteUser 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.epress.ChannelLCListener4EPress 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.epress.DocumentLCListener4EPress 中的方法
notifyOnDelObj(BaseObj) - 类 com.trs.components.wcm.epress.EPressConf 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.publish.ChnlDocLCListnerForPublish 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.publish.region.ChannelListenerForPublish 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.publish.region.DocumentListenerForPublish 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.components.wcm.publish.WCMFolderLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
notifyOnDelObj(BaseObj, int) - 接口 com.trs.infra.persistent.listener.IObjectLCListenerOnDel 中的方法
删除一个对象后通知所有的Cache
notifyOnDelObj(BaseObj, int) - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.infra.support.config.ConfigServer 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.infra.support.file.PathConfigLCListener 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.presentation.login.UserLCListenerForLogin 中的方法
notifyOnDelObj(BaseObj, int) - 类 com.trs.wcm.photo.DocumentLCLisenterForPhoto 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.AdministratorCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.GroupUserCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.auth.persistent.UserCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.process.definition.FlowCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.ckm.DocumentLCListenerForSIMSearch 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.calendar.EventLCListenerForRemind 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.job.ScheduleLCListenerForServer 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 中的方法
已过时。
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanLCListener 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateLCListenerForNestedRename 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateLCListenerForTypeChanged 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.widget.AdjustJsLCListenerWidget 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.govinfo.GovInfoLCListenerMetaView 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.metadata.center.ChnlDocLCListenerForSynToMetaData 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.metadata.center.DocumentListenerForMetaViewData 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.metadata.definition.MetaDBFieldListenerForChannelSynRule 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ApdHostLCListener 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForDocument 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForAutoDocBak 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForAutoDocBak 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.epress.DocumentLCListener4EPress 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.process.ChannelLCListenerForFlow 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.process.ChnlDocLCListenerForFlow 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.process.FlowEmployLCListenerForChange 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.publish.ChnlDocLCListnerForPublish 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.publish.DocumentLCListenerForPublish 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.publish.region.ChannelDocListenerForPublish 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.publish.region.ChannelListenerForPublish 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.publish.region.DocumentListenerForPublish 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.publish.WCMFolderLCListener 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
notifyOnModifyObj(BaseObj, int) - 接口 com.trs.infra.persistent.listener.IObjectLCListenerOnModify 中的方法
修改一个对象后通知所有的Cache
notifyOnModifyObj(BaseObj, int) - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.infra.support.config.ConfigServer 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.infra.support.file.PathConfigLCListener 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.km.auth.UserListenerForRecordLogin 中的方法
notifyOnModifyObj(BaseObj, int) - 类 com.trs.presentation.login.UserLCListenerForLogin 中的方法
notifyOnTagBeanAdded(TagBean) - 类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 中的静态方法
Updates cache when a new tag bean is created.
notifyOnTagBeanDeleted(TagBean) - 类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 中的静态方法
Removes cache when a tag bean is deleted.
notifyOnTagBeanModified(TagBean) - 类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 中的静态方法
Updates cache when a tag bean is modified.
notifyPageTaskFinished(IPageTask) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher 中的方法
notify one page generating task has been finished
notifyPageTaskFinished(IPageTask) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法
Notifies one page task has finished
notifyPageTaskFinished(IPageTask) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
notifyPageTaskWorkerFinished(int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher 中的方法
notify that one PageTaskWorker has finished.
notifyPageTaskWorkerFinished(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
notifyRemoveTable(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
删除数据表
notifyRemoveTable(String) - 类 com.trs.infra.util.database.TableInfos 中的方法
notifyTemplateAdded(Template) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
Notifys template parse manager when a template is added.
notifyTemplateDeleted(Template) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
Notifys template parse manager wehn a template is deleted.
notifyTemplateModified(Template) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
Notifys template parse manager when a template is modified.
NOTLIMITED_OPEN_OPEN_RECORD_COUNT - 类 com.trs.infra.db.QueryFilter 中的静态变量
Comment for NOTLIMITED_OPEN_OPEN_RECORD_COUNT ：不限制集合的记录数
NOTLIMITED_OPEN_OPEN_RECORD_COUNT - 类 com.trs.infra.persistent.WCMFilter 中的静态变量
Comment for NOTLIMITED_OPEN_OPEN_RECORD_COUNT ：不限制集合的记录数
now() - 类 com.trs.infra.util.CMyDateTime 中的静态方法
获取值为系统当前时间的CMyDateTime对象
NOWRAP - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
nRecordTotalCount - 类 com.trs.util.ResetClassInfoOfViewData 中的变量
NS_XSL_URI - 类 com.trs.components.infoview.InfoViewMgr 中的静态变量
NTEXT - 类 com.trs.infra.util.database.DamengDB 中的静态变量
NTEXT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：NTEXT
NULL_ATTRIBUTE_VALUE - 类 com.trs.infra.util.html.HTML 中的静态变量
Fetch an integer attribute value.
nullAble - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
列是否允许空值
NullValue - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
NullValue(int) - 类 com.trs.infra.persistent.NullValue 的构造方法
NUMBER - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type 中的静态变量
数值类型的属性，属性值必须是10个数字、减号和小数点
NUMBER - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 中的静态变量
数值类型的变量，其值必须是10个数字、减号和小数点
NUMBER - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：NUMBER
NUMBER - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
numberToStr(int) - 类 com.trs.infra.util.CMyString 中的静态方法
将指定整型值转化为字符串
numberToStr(int, int) - 类 com.trs.infra.util.CMyString 中的静态方法
将指定整型值转化为字符串
numberToStr(int, int, char) - 类 com.trs.infra.util.CMyString 中的静态方法
将指定整型值转化为字符串
numberToStr(long) - 类 com.trs.infra.util.CMyString 中的静态方法
将指定长整数转化为字符串
numberToStr(long, int) - 类 com.trs.infra.util.CMyString 中的静态方法
将指定长整数转化为字符串
numberToStr(long, int, char) - 类 com.trs.infra.util.CMyString 中的静态方法
将指定长整数转化为字符串
NUMERIC - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义ASS400中的字段类型：NUMERIC
NUMERIC - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
NUMERIC - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
NUMERIC - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：NUMERIC
NUMERIC - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：NUMERIC
NUMERIC - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：NUMERIC
NVARCHAR - 类 com.trs.infra.util.database.DamengDB 中的静态变量
NVARCHAR - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
NVARCHAR - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
NVARCHAR - 类 com.trs.infra.util.database.KingBaseDB 中的静态变量
定义SQL Server中的字段类型：NVARCHAR
NVARCHAR - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
NVARCHAR - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：NVARCHAR 和SQLServer
NVARCHAR - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：NVARCHAR
NVARCHAR - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：NVARCHAR
NVARCHAR - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：NVARCHAR
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


O - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

O

OBJ_ACCESS - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
“访问”对象的权限
OBJ_ADCOM - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
广告发放公司 *
OBJ_ADDRESS - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_ADDRESSGRP - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_ADFILE - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
广告文件管理 *
OBJ_ADFILEPOS - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
广告文件和位置关系 *
OBJ_ADPOS - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
广告位置管理 *
OBJ_ADTYPE - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
广告类型 *
OBJ_APPENDIX - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_BASEVOTE - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
OBJ_BIGTABLE - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM自定义的表单信息
OBJ_BIGTABLEFIELD - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM自定义的表单中的字段信息
OBJ_BIGTABLEMPLOY - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM自定义的表单中的使用信息
OBJ_BOOKINFO - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
OBJ_BOOKMARK - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_BULLETIN - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_CHANNEL - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_CHANNELSYN - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_CHNLDOC - 类 com.trs.infra.common.WCMTypes 中的静态变量
记录文档逻辑信息对象*
OBJ_CONDITIONBEAN - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流条件系统配置对象
OBJ_CONFIG - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_CONTACT - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_CONTACTGRP - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_CONTENTLINK - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_DEMO - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
演示 *
OBJ_DOCBAK - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_DOCKIND - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_DOCREPLY - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_DOCUMENT - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_EVENT - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_EVENTTYPE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_EXPIRATION - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_EXTENDEDFIELD - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_EXTFIELD - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_FIELDINFO - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_FILETYPE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_FLOW - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_FLOWACTION - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_FLOWDOC - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流流转情况对象
OBJ_FLOWDOCBAK - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流流转情况对象
OBJ_FLOWEMPLOYBEAN - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流配置关系
OBJ_FLOWEVENTCONDITION - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流节点事件条件对象
OBJ_FLOWEVENTOPERATE - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流节点事件执行对象
OBJ_FLOWNODE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_FLOWNODEBRANCH - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_FLOWNODEEVENT - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流节点事件对象
OBJ_FORUMMSG - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
网上论坛帖子 *
OBJ_FORUMTOPIC - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
网上论坛话题 *
OBJ_GROUP - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_HITSCOUNT - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_HUMANSRC - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
对象类型：HumanSrc （用以演示）
OBJ_INFOVIEW - 类 com.trs.infra.common.WCMTypes 中的静态变量
结合 MS InfoPath 实现的自定义表单
OBJ_INFOVIEW_DATA - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
自定义表单型文档
OBJ_INFOVIEWEMPLOY - 类 com.trs.infra.common.WCMTypes 中的静态变量
结合 MS InfoPath 实现的自定义表单的雇佣关系（被频道使用）
OBJ_INFOVIEWFIELD - 类 com.trs.infra.common.WCMTypes 中的静态变量
结合 MS InfoPath 实现的自定义表单的数据项（字段）
OBJ_INFOVIEWGROUP - 类 com.trs.infra.common.WCMTypes 中的静态变量
结合 MS InfoPath 实现的自定义表单的数据区块（Section or Table）
OBJ_INFOVIEWVIEW - 类 com.trs.infra.common.WCMTypes 中的静态变量
结合 MS InfoPath 实现的自定义表单的视图
OBJ_JOB - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_LOG - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_LOGTYPE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_MARKKIND - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_MARKSHARE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_MEETINGCONT - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_MEETINGROOM - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_MEETINGUSER - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_MESSAGE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_MSGQUEUE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_MYTEST - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
对象类型：MyTest
OBJ_OPERATIONBEAN - 类 com.trs.infra.common.WCMTypes 中的静态变量
工作流执行系统配置对象
OBJ_OPERTYPE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_OTHER - 类 com.trs.infra.common.WCMTypes 中的静态变量
未定义的其他类型
OBJ_PUBLISHDISTRIBUTION - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_RECENT - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_REGIONCELL - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_REGIONINFO - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_RELATION - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_REPLACE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_RIGHT - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_RIGHTDEF - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_ROLE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_SCHEDULE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_SECURITY - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_SOURCE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_STATUS - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_TABLEINFO - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_TASK - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_TASKPOOL - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_TRSDOC - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
对象类型：TRSDoc
OBJ_TRSREGINFO - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
TRS产品注册信息 *
OBJ_TRUSTEEINFO - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_TYPE - 类 com.trs.cms.auth.persistent.Group 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.auth.persistent.GroupRole 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.auth.persistent.GroupUser 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.auth.persistent.ObjectMember 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.auth.persistent.Right 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.auth.persistent.RightDef 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.auth.persistent.Role 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.auth.persistent.RoleUser 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.auth.persistent.User 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.content.DefaultObj 中的静态变量
OBJ_TYPE - 类 com.trs.cms.content.ExtendedField 中的静态变量
对象类型
OBJ_TYPE - 类 com.trs.cms.content.WCMSystemObject 中的静态变量
OBJ_TYPE - 类 com.trs.cms.process.definition.Flow 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.process.definition.FlowAction 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.process.definition.FlowCondition 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.process.definition.FlowdocLog 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.process.definition.FlowEmploy 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.process.definition.FlowNode 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.process.definition.FlowNodeBranch 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.process.definition.FlowNodeField 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.process.definition.FlowRule 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.cms.process.engine.FlowContentConfig 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.cms.process.engine.FlowDoc 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.cms.process.engine.FlowDocBak 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.comment.persistent.DocumentTopic 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.common.address.Contact 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.common.address.ContactGrp 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.common.bookmark.BookMark 中的静态变量
OBJ_TYPE - 类 com.trs.components.common.bookmark.MarkKind 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.common.bookmark.MarkShare 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.common.calendar.Event 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.common.calendar.EventShare 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.calendar.EventType 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
对象类型
OBJ_TYPE - 类 com.trs.components.common.job.Schedule 中的静态变量
OBJ_TYPE - 类 com.trs.components.common.message.Message 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.common.message.MsgQueue 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.common.message.MsgReceiver 中的静态变量
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.template.TagBean 中的静态变量
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.template.Template 中的静态变量
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.ContentStyle 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.Master 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.PageStyle 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.ResourceStyle 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.StyleAndResource 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.StyleItem 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.Widget 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.WidgetInstance 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsad.ADCom 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsad.ADFile 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsad.ADFilePos 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsad.ADPos 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsad.ADType 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsvote.Vote 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsvote.VoteData 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsvote.VoteIPLog 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsvote.VoteItem 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.common.trsvote.VoteOption 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.infoview.helper.ComplexFieldData 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.infoview.persistent.InfoView 中的静态变量
TODO Add javadoc for field OBJ_TYPE
OBJ_TYPE - 类 com.trs.components.infoview.persistent.InfoViewData 中的静态变量
OBJ_TYPE - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的静态变量
TODO Add javadoc for field OBJ_TYPE
OBJ_TYPE - 类 com.trs.components.infoview.persistent.InfoViewField 中的静态变量
OBJ_TYPE - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的静态变量
OBJ_TYPE - 类 com.trs.components.infoview.persistent.InfoViewView 中的静态变量
OBJ_TYPE - 类 com.trs.components.metadata.center.ClassInfoView 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.metadata.center.MetaViewData 中的静态变量
OBJ_TYPE - 类 com.trs.components.metadata.center.MetaViewEmployer 中的静态变量
OBJ_TYPE - 类 com.trs.components.metadata.center.MetaViewEmployers 中的静态变量
OBJ_TYPE - 类 com.trs.components.metadata.definition.ClassInfo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.metadata.definition.MetaDBField 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.metadata.definition.MetaDBTable 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.metadata.definition.MetaView 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.metadata.definition.MetaViewField 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.special.Special 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.stat.BonusRule 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.stat.ChnlDept 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.stat.DocumentHitsCount 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.stat.HostObjDomain 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.stat.HostObjHitsCount 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.stat.UserLoginInfo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的静态变量
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.ContentLink 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.DocBak 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.DocReply 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
对象类型（605）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的静态变量
对象类型
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.HitsCount 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.Relation 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.Replace 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.SiteMember 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
常量定义
OBJ_TYPE - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.individuation.Individuation 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.publish.logo.Logo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.publish.region.CellInfo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.recent.Recent 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.resource.DocKind 中的静态变量
OBJ_TYPE - 类 com.trs.components.wcm.resource.FileType 中的静态变量
OBJ_TYPE - 类 com.trs.components.wcm.resource.Keyword 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.resource.Security 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.resource.Source 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.resource.Status 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.components.wcm.stat.StatFieldMap 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.stat.StatHost 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.stat.StatView 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.stat.StatViewRel 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的静态变量
TODO 需要定义 对象类型编号
OBJ_TYPE - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.db.update.DBUpdateLog 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.infra.persistent.CMyResultSet 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.infra.support.config.Config 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.infra.support.log.Log 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.infra.support.log.LogBak 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.infra.support.log.OperType 中的静态变量
OBJ_TYPE - 类 com.trs.infra.support.security.SecureKey 中的静态变量
OBJ_TYPE - 类 com.trs.wcm.config.PageOperator 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.wcm.old.WCMExcelData 中的静态变量
对象类型（定义在WCMTypes中）
OBJ_TYPE - 类 com.trs.wcm.old.WCMFormFields 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.wcm.old.WCMFormInfo 中的静态变量
对象类型编号
OBJ_TYPE - 类 com.trs.wcm.photo.Watermark 中的静态变量
对象类型编号
OBJ_UNKNOWN - 类 com.trs.infra.common.WCMTypes 中的静态变量
未知类型
OBJ_USER - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_USERDEF - 类 com.trs.infra.common.WCMTypes 中的静态变量
用户自定义对象的起始值
OBJ_USERSETTING - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_USERSIGN - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
个人签名 *
OBJ_VOTE - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
OBJ_VOTEDATA - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
OBJ_VOTEIPLOG - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
OBJ_VOTEITEM - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
OBJ_VOTEOPTION - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
OBJ_WCMDICT - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
常用字典 *
OBJ_WCMEXCELDATA - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_WCMFORMFIELDS - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM自定义的表单中的字段信息 (old)
OBJ_WCMFORMINFO - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM自定义的表单信息 (old)
OBJ_WCMID - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJ_WCMOBJTRIGGER - 类 com.trs.infra.common.WCMTypes 中的静态变量
管理WCMObj触发器的对象 *
OBJ_WCMRESULTSET - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCMRESULTSET对象类型
OBJ_WEBSITE - 类 com.trs.infra.common.WCMTypes 中的静态变量
OBJECT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
ObjectBodyValidator - com.trs.wcag2.validator 中的 类
ObjectBodyValidator() - 类 com.trs.wcag2.validator.ObjectBodyValidator 的构造方法
ObjectLCListenerConfig - com.trs.infra.persistent.listener 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectLCListenerConfig() - 类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 的构造方法
ObjectLCMonitorServer - com.trs.infra.persistent.listener 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
生命周期管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectLCMonitorServer() - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 的构造方法
ObjectLCMsgReceiver - com.trs.cluster.receiver 中的 类
ObjectLCMsgReceiver() - 类 com.trs.cluster.receiver.ObjectLCMsgReceiver 的构造方法
ObjectMember - com.trs.cms.auth.persistent 中的 类
ObjectMember() - 类 com.trs.cms.auth.persistent.ObjectMember 的构造方法
构造函数：保留默认接口
ObjectMemberMgr - com.trs.cms.auth.domain 中的 类
可见可操作对象的缓冲管理.
ObjectMemberMgr() - 类 com.trs.cms.auth.domain.ObjectMemberMgr 的构造方法
ObjectMemberMgrForCluster - com.trs.cms.auth.domain 中的 类
ObjectMember缓冲处理.接收集群消息,根据相应的操作刷新缓冲.
ObjectMemberMgrForCluster() - 类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 的构造方法
ObjectMembers - com.trs.cms.auth.persistent 中的 类
ObjectMembers(User) - 类 com.trs.cms.auth.persistent.ObjectMembers 的构造方法
构造函数
ObjectMembers(User, int, int) - 类 com.trs.cms.auth.persistent.ObjectMembers 的构造方法
构造函数
ObjectMemberServiceProvider - com.trs.ajaxservice 中的 类
ObjectMemberServiceProvider() - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 的构造方法
ObjectMonitored - com.trs.infra.persistent.listener 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectMonitored() - 类 com.trs.infra.persistent.listener.ObjectMonitored 的构造方法
ObjectMonitored(String, String) - 类 com.trs.infra.persistent.listener.ObjectMonitored 的构造方法
ObjectsIterator - com.trs.components.metadata.service 中的 类
遍历对象的时候，执行一定的处理，如用于递归迭代中，对每个元素进行必要的处理。
ObjectsIterator() - 类 com.trs.components.metadata.service.ObjectsIterator 的构造方法
ObjectToHtml(Object) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法
ObjectToHtmlValue(Object) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法
ObjectTypeConfig - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectTypeConfig() - 类 com.trs.infra.persistent.ObjectTypeConfig 的构造方法
ObjectTypeServer - com.trs.cms 中的 类
ObjectTypeServer() - 类 com.trs.cms.ObjectTypeServer 的构造方法
ObjectTypesFinder - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjectTypesFinder() - 类 com.trs.infra.persistent.ObjectTypesFinder 的构造方法
ObjLoggerBase - com.trs.cms.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Obj操作日志记录基础类
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ObjLoggerBase() - 类 com.trs.cms.logger.ObjLoggerBase 的构造方法
ObjSysLogger - com.trs.cms.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志总调度,通过Discovery得到需要记录的日志对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ObjToXmlConverter - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
BaseObj数据转换为XML格式的转换者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjToXmlConverter() - 类 com.trs.infra.persistent.ObjToXmlConverter 的构造方法
ObjToXmlConverterByDOM4j - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
BaseObj数据转换为XML格式的转换者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ObjToXmlConverterByDOM4j() - 类 com.trs.infra.persistent.ObjToXmlConverterByDOM4j 的构造方法
OBJTYPE_FLOWEMPLPOY - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OBJTYPE_FOLDERPUBLISHCONFIG - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: folder publish config
OBJTYPE_PUBLISHDISTRIBUTION - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: PublishDistributionConfig
OBJTYPE_PUBLISHLOG - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: publish log
OBJTYPE_PUBLISHTASK - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: publish task
OBJTYPE_TAGBEAN - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: tag paser bean
OBJTYPE_TEMPAPDREL - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: template appendix realation
OBJTYPE_TEMPAPPENDIX - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: template appendix
OBJTYPE_TEMPLATE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: template
OBJTYPE_TEMPLATE_ARGUMENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: template argument
OBJTYPE_TEMPLATEEMPLPOY - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: template employ record
OBJTYPE_TEMPLATEQUOTE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
object type: template quote record
ObjTypeLookupHelper - com.trs.infra.persistent 中的 类
ObjTypeLookupImpl - com.trs.infra.persistent 中的 类
ObjTypeLookupImpl() - 类 com.trs.infra.persistent.ObjTypeLookupImpl 的构造方法
constructor: default
OcrSoapClient - com.trs.infra.util.soap 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
智能创建文档的ConvertOfficeFile远程调用接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OcrSoapClient() - 类 com.trs.infra.util.soap.OcrSoapClient 的构造方法
OfficeDocumentService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OfficeDocumentService() - 类 com.trs.service.impl.OfficeDocumentService 的构造方法
OL - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
oldId - 类 com.trs.cms.content.ImgRec 中的变量
oldSrc - 类 com.trs.cms.content.ImgRec 中的变量
onChange(int) - 接口 com.trs.components.common.publish.domain.distribute.DistributionChangeListener 中的方法
指定ID的分发配置已经发生了实质性的改变，正在执行的分发任务，必须立即结束
onChange(int) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法
onDelete(int) - 接口 com.trs.components.common.publish.domain.distribute.DistributionChangeListener 中的方法
指定ID的分发配置已经删除（也可能是禁用）
onDelete(int) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法
onIdle() - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
在连接处于空闲状态时，会定时的访问服务器，以防止服务器端超时。
onIdle() - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的方法
onIdle() - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的方法
ONLINE_USER_VERSION - 类 com.trs.presentation.util.LoginHelper 中的静态变量
ONLY_SEARCH_SELF - 类 com.trs.infra.util.html.HtmlElement 中的变量
ONLY_SELF - 类 com.trs.components.metadata.service.ViewRangeConstants 中的静态变量
本栏目
open(int, boolean) - 类 com.trs.cms.auth.persistent.RightDefs 中的方法
open(Channels, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
open(Channel, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
open(WebSite, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
open(WebSites, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
open(CMSBaseObjs, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
open(WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
open(WCMFilter, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
open(String, int, WCMFilter, String) - 类 com.trs.components.wcm.content.persistent.XDocuments 中的方法
open(Channels, WCMFilter) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
open(Channel, WCMFilter) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
open(WebSite, WCMFilter) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
open(WebSites, WCMFilter) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
open(CMSBaseObjs, WCMFilter) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
open(WCMFilter) - 类 com.trs.infra.persistent.BaseObjs 中的方法
打开集合
open(String, String) - 类 com.trs.infra.persistent.CMyResultObjs 中的方法
打开集合
open(String, List, String) - 类 com.trs.infra.persistent.CMyResultObjs 中的方法
open(WCMFilter) - 类 com.trs.infra.persistent.CMyResultSets 中的方法
打开集合
open() - 接口 com.trs.template.IErrorMessages 中的方法
开放错误信息集合
OPEN_DELETE - 类 com.trs.infra.util.jazzlib.ZipFile 中的静态变量
Mode flag to delete a zip file after reading
OPEN_READ - 类 com.trs.infra.util.jazzlib.ZipFile 中的静态变量
Mode flag to open a zip file for reading
openDocs(User, WCMFilter, int, int) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
openDocs(User, TRSToWCMFilter, int, int) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
通过TRS构造一个Document集合
openDocsByLocal(User, TRSToWCMFilter, int, int) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
通过TRS构造一个Document集合
openTRSServerViewDocuments(TRSResultSet, TRSToWCMFilter, CPager) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
openViewDocs(User, TRSToWCMFilter, int, int) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
openViewDocuments(WCMFilter) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.GroupRoles 中的静态方法
通过指定一个Filter获取当前集合[RoleUsers]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.Groups 中的静态方法
通过指定一个Filter获取当前集合[Groups]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.GroupUsers 中的静态方法
通过指定一个Filter获取当前集合[GroupUsers]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.ObjectMembers 中的静态方法
通过指定一个Filter获取当前集合[ObjectMembers]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.RightDefs 中的静态方法
通过指定一个Filter获取当前集合[RightDefs]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.Rights 中的静态方法
通过指定一个Filter获取当前集合[Rights]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.Roles 中的静态方法
通过指定一个Filter获取当前集合[Roles]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.RoleUsers 中的静态方法
通过指定一个Filter获取当前集合[RoleUsers]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.auth.persistent.Users 中的静态方法
通过指定一个Filter获取当前集合[Users]
openWCMObjs(User, Class, WCMFilter) - 类 com.trs.cms.content.CMSBaseObjs 中的静态方法
根据指定的Filter打开指定的集合
openWCMObjs(User, String, WCMFilter) - 类 com.trs.cms.content.CMSBaseObjs 中的静态方法
根据指定的Filter打开指定的集合
openWCMObjs(User, WCMFilter, String, String) - 类 com.trs.cms.content.DefaultObjs 中的静态方法
通过指定一个Filter获取当前集合[DefaultObjs]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.content.ExtendedFields 中的静态方法
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowActions 中的静态方法
通过指定一个Filter获取当前集合[FlowActions]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowConditions 中的静态方法
通过指定一个Filter获取当前集合[FlowConditions]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowdocLogs 中的静态方法
通过指定一个Filter获取当前集合[FlowdocLogs]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowEmploys 中的静态方法
通过指定一个Filter获取当前集合[FlowEmploys]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowNodeBranchs 中的静态方法
通过指定一个Filter获取当前集合[FlowNodeBranchs]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowNodeFields 中的静态方法
通过指定一个Filter获取当前集合[FlowNodeFields]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowNodes 中的静态方法
通过指定一个Filter获取当前集合[FlowNodes]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowRules 中的静态方法
通过指定一个Filter获取当前集合[FlowRules]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.definition.Flows 中的静态方法
通过指定一个Filter获取当前集合[Flows]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.engine.FlowContentConfigs 中的静态方法
通过指定一个Filter获取当前集合[FlowContentConfigs]
openWCMObjs(User, WCMFilter) - 类 com.trs.cms.process.engine.FlowDocs 中的静态方法
通过指定一个Filter获取当前集合[FlowDocs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.comment.persistent.DocumentTopics 中的静态方法
通过指定一个Filter获取当前集合[DocumentTopics]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.comment.persistent.TopicedDocRelations 中的静态方法
通过指定一个Filter获取当前集合[TopicedDocRelations]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.address.ContactGrps 中的静态方法
通过指定一个Filter获取当前集合[ContactGrps]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.address.Contacts 中的静态方法
通过指定一个Filter获取当前集合[Contacts]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.bookmark.BookMarks 中的静态方法
通过指定一个Filter获取当前集合[BookMarks]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.bookmark.MarkKinds 中的静态方法
通过指定一个Filter获取当前集合[MarkKinds]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.bookmark.MarkShares 中的静态方法
通过指定一个Filter获取当前集合[MarkShares]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.calendar.Events 中的静态方法
通过指定一个Filter获取当前集合[Events]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.calendar.EventShares 中的静态方法
通过指定一个Filter获取当前集合[EventShares]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.conjection.persistent.EntryConfigs 中的静态方法
通过指定一个Filter获取当前集合[EntryConfigs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.job.JobWorkerTypes 中的静态方法
通过指定一个Filter获取当前集合[JobWorkers]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.job.Schedules 中的静态方法
通过指定一个Filter获取当前集合[Schedules]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.message.Messages 中的静态方法
通过指定一个Filter获取当前集合[Messages]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.message.MsgQueues 中的静态方法
通过指定一个Filter获取当前集合[MsgQueues]
openWCMObjs(WCMFilter) - 类 com.trs.components.common.message.MsgReceivers 中的静态方法
通过指定一个Filter获取当前集合[MsgReceivers]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 中的静态方法
通过指定一个Filter获取当前集合[PublishDistributions]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 中的静态方法
通过指定一个Filter获取当前集合[FolderPublishConfigs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.template.TempApdRels 中的静态方法
通过指定一个Filter获取当前集合[TempApdRels]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.template.TempAppendixes 中的静态方法
通过指定一个Filter获取当前集合[TempAppendixes]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的静态方法
通过指定一个Filter获取当前集合[TemplateEmploys]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploys 中的静态方法
通过指定一个Filter获取当前集合[TemplateEmploys]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.template.TemplateQuotes 中的静态方法
通过指定一个Filter获取当前集合[TemplateQuotes]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态方法
通过指定一个Filter获取当前集合[Templates]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.ContentStyles 中的静态方法
通过指定一个Filter获取当前集合[ContentStyles]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.Layouts 中的静态方法
通过指定一个Filter获取当前集合[Layouts]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.Masters 中的静态方法
通过指定一个Filter获取当前集合[Masters]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.PageStyles 中的静态方法
通过指定一个Filter获取当前集合[PageStyles]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.ResourceStyles 中的静态方法
通过指定一个Filter获取当前集合[ResourceStyles]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleAndResources 中的静态方法
通过指定一个Filter获取当前集合[StyleAndResources]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleItems 中的静态方法
通过指定一个Filter获取当前集合[StyleItems]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.WidgetInstances 中的静态方法
通过指定一个Filter获取当前集合[WidgetInstances]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.WidgetInstParameters 中的静态方法
通过指定一个Filter获取当前集合[WidgetInstParameters]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.WidgetParameters 中的静态方法
通过指定一个Filter获取当前集合[WidgetParameters]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.common.publish.widget.Widgets 中的静态方法
通过指定一个Filter获取当前集合[Widgets]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 中的静态方法
通过指定一个Filter获取当前集合[ApplyFormDealLogs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForms 中的静态方法
通过指定一个Filter获取当前集合[ApplyForms]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.gkml.sqgk.persistent.MailConfigs 中的静态方法
通过指定一个Filter获取当前集合[MailConfigs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.infoview.helper.ComplexFieldDatas 中的静态方法
通过指定一个Filter获取当前集合[ComplexFieldDatas]
openWCMObjs(int, WCMFilter) - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的静态方法
openWCMObjs(User, WCMFilter) - 类 com.trs.components.metadata.center.ClassInfoViews 中的静态方法
通过指定一个Filter获取当前集合[ClassInfoViews]
openWCMObjs(String, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态方法
通过指定一个Filter获取当前集合[MetaViewDatas]
openWCMObjs(MetaView, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态方法
openWCMObjs(WCMFilter) - 类 com.trs.components.metadata.center.MetaViewEmployers 中的静态方法
openWCMObjs(User, WCMFilter) - 类 com.trs.components.metadata.definition.ClassInfos 中的静态方法
通过指定一个Filter获取当前集合[ClassInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.metadata.definition.MetaDBFields 中的静态方法
通过指定一个Filter获取当前集合[DBFieldInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.metadata.definition.MetaDBTables 中的静态方法
通过指定一个Filter获取当前集合[TableInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.metadata.definition.MetaViewFields 中的静态方法
通过指定一个Filter获取当前集合[ViewFieldInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.metadata.definition.MetaViews 中的静态方法
通过指定一个Filter获取当前集合[ViewInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.special.Specials 中的静态方法
通过指定一个Filter获取当前集合[Specials]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.stat.BonusRules 中的静态方法
通过指定一个Filter获取当前集合[BonusRules]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.stat.ChnlDepts 中的静态方法
通过指定一个Filter获取当前集合[ChnlDepts]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.stat.DocumentHitsCounts 中的静态方法
通过指定一个Filter获取当前集合[DocumentHitsCounts]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.stat.HostObjDomains 中的静态方法
通过指定一个Filter获取当前集合[HostObjDomains]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.stat.HostObjHitsCounts 中的静态方法
通过指定一个Filter获取当前集合[HostObjHitsCounts]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.stat.UserLoginInfos 中的静态方法
通过指定一个Filter获取当前集合[UserLoginInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.Appendixes 中的静态方法
通过指定一个Filter获取当前集合[Appendixes]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.AutoBakConfigs 中的静态方法
通过指定一个Filter获取当前集合[AutoBakConfigs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.ChannelContentLinks 中的静态方法
通过指定一个Filter获取当前集合[ChannelContentLinks]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.Channels 中的静态方法
通过指定一个Filter获取当前集合[Channels]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.ChannelSyns 中的静态方法
Created: 2004-12-12 17:12:53 Last Modified: 2004-12-12/2004-12-12 Description:获取频道分发设置集合
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.ChnlDocs 中的静态方法
通过指定一个Filter获取当前集合[ChnlDocs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.ContentExtFields 中的静态方法
通过指定一个Filter获取当前集合[ContentExtFields]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.ContentLinks 中的静态方法
Created: 2004-12-12 17:19:37 Last Modified: 2004-12-12/2004-12-12 Description: 获取内容超链接对象集合
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.ContentLinkTypes 中的静态方法
通过指定一个Filter获取当前集合[ContentLinkTypes]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.DocBaks 中的静态方法
通过指定一个Filter获取当前集合[DocBaks]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.DocReplys 中的静态方法
通过指定一个Filter获取当前集合[DocReplys]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.Documents 中的静态方法
通过指定一个Filter获取当前集合[Documents]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.DocumentSyns 中的静态方法
通过指定一个Filter获取当前集合[TransmittedDocs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.Relations 中的静态方法
通过指定一个Filter获取当前集合[Relations]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.Replaces 中的静态方法
Created: 2004-12-12 17:23:52 Last Modified: 2004-12-12/2004-12-12 Description:获取内容替换对象集合
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.SiteMembers 中的静态方法
通过指定一个Filter获取当前集合[SiteUsers]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.content.persistent.WebSites 中的静态方法
通过指定一个Filter获取当前集合[WebSites]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.customize.UserSettings 中的静态方法
通过指定一个Filter获取当前集合[UserSettings]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 中的静态方法
通过指定一个Filter获取当前集合[CustomSiteCheckedInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.individuation.Individuations 中的静态方法
通过指定一个Filter获取当前集合[Individuations]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.publish.logo.Logos 中的静态方法
通过指定一个Filter获取当前集合[Logos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.publish.region.CellInfos 中的静态方法
通过指定一个Filter获取当前集合[CellInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.publish.region.RegionEmploys 中的静态方法
通过指定一个Filter获取当前集合[RegionEmploys]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.publish.region.RegionInfos 中的静态方法
通过指定一个Filter获取当前集合[RegionInfos]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.publish.WCMPubStatusConfigs 中的静态方法
通过指定一个Filter获取当前集合[WCMPubStatusConfigs]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.recent.Recents 中的静态方法
通过指定一个Filter获取当前集合[Recents]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.resource.Keywords 中的静态方法
通过指定一个Filter获取当前集合[Keywords]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.resource.Securities 中的静态方法
通过指定一个Filter获取当前集合[Securities]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.resource.Sources 中的静态方法
通过指定一个Filter获取当前集合[Sources]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.resource.Statuses 中的静态方法
通过指定一个Filter获取当前集合[Statuses]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.stat.StatFieldMaps 中的静态方法
通过指定一个Filter获取当前集合[StatFieldsMaps]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.stat.StatHosts 中的静态方法
通过指定一个Filter获取当前集合[StatHosts]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.stat.StatViewRels 中的静态方法
通过指定一个Filter获取当前集合[StatViewRels]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.stat.StatViews 中的静态方法
通过指定一个Filter获取当前集合[StatViews]
openWCMObjs(User, WCMFilter) - 类 com.trs.components.wcm.wcmx.help.WCMHelps 中的静态方法
通过指定一个Filter获取当前集合[WCMHelps]
openWCMObjs(WCMFilter) - 类 com.trs.db.update.DBUpdateLogs 中的静态方法
通过指定一个Filter获取当前集合[DBUpdateLogs]
openWCMObjs(WCMFilter) - 类 com.trs.infra.support.config.Configs 中的静态方法
通过指定一个Filter获取当前集合[Configs]
openWCMObjs(WCMFilter) - 类 com.trs.infra.support.log.LogBaks 中的静态方法
通过指定一个Filter获取当前集合[WCMLogBaks]
openWCMObjs(WCMFilter) - 类 com.trs.infra.support.log.Logs 中的静态方法
通过指定一个Filter获取当前集合[WCMLogs]
openWCMObjs(WCMFilter) - 类 com.trs.infra.support.log.OperTypes 中的静态方法
通过指定一个Filter获取当前集合[OperTypes]
openWCMObjs(WCMFilter) - 类 com.trs.infra.support.security.SecureKeys 中的静态方法
通过指定一个Filter获取当前集合[SecureKeys]
openWCMObjs(WCMFilter) - 类 com.trs.infra.util.job.JobFailedResults 中的静态方法
通过指定一个Filter获取当前集合[JobFailedResults]
openWCMObjs(User, WCMFilter) - 类 com.trs.wcm.config.PageOperators 中的静态方法
通过指定一个Filter获取当前集合[PageOperators]
openWCMObjs(User, WCMFilter) - 类 com.trs.wcm.old.WCMFormInfos 中的静态方法
Created: 2004-12-12 16:42:24 Last Modified: 2004-12-12/2004-12-12 Description:获取表单集合
openWCMObjs(User, WCMFilter) - 类 com.trs.wcm.photo.Watermarks 中的静态方法
通过指定一个Filter获取当前集合[Watermarks]
OPER_CHNL_ADD - 类 com.trs.infra.common.WCMTypes 中的静态变量
添加频道
OPER_CHNL_DEL - 类 com.trs.infra.common.WCMTypes 中的静态变量
彻底删除频道
OPER_CHNL_EDIT - 类 com.trs.infra.common.WCMTypes 中的静态变量
修改频道
OPER_CHNL_PUB - 类 com.trs.infra.common.WCMTypes 中的静态变量
发布频道
OPER_CHNL_RECYCLE - 类 com.trs.infra.common.WCMTypes 中的静态变量
假删除频道
OPER_CHNL_RESCOVER - 类 com.trs.infra.common.WCMTypes 中的静态变量
恢复频道
OPER_DOC_ADD - 类 com.trs.infra.common.WCMTypes 中的静态变量
添加文档
OPER_DOC_DEL - 类 com.trs.infra.common.WCMTypes 中的静态变量
删除文档
OPER_DOC_EDIT - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态变量
文档修改操作
OPER_DOC_EDIT - 类 com.trs.infra.common.WCMTypes 中的静态变量
修改文档
OPER_DOC_PUB - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态变量
文档发布操作
OPER_DOC_PUB - 类 com.trs.infra.common.WCMTypes 中的静态变量
发布文档
OPER_DOCSTATUS_CHANGE - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态变量
文档状态修改操作
OPER_DOCUMENT_COPY - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for OPER_DOCUMENT_COPY 操作类型：移动文档[20]
OPER_DOCUMENT_MIRROR - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for OPER_DOCUMENT_MIRROR 操作类型：镜像文档[40]
OPER_DOCUMENT_MOVE - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for OPER_DOCUMENT_MOVE 操作类型：移动文档[10]
OPER_DOCUMENT_QUOTE - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for OPER_DOCUMENT_QUOTE 操作类型：移动文档[30]
OPER_FLOW_ADD - 类 com.trs.infra.common.WCMTypes 中的静态变量
添加工作流
OPER_FLOW_DEL - 类 com.trs.infra.common.WCMTypes 中的静态变量
删除工作流
OPER_FLOW_EDIT - 类 com.trs.infra.common.WCMTypes 中的静态变量
修改工作流
OPER_NODE_URL_KEY - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
OPER_OTHER - 类 com.trs.infra.common.WCMTypes 中的静态变量
未定义的其他操作类型
OPER_ROOT_URL_KEY - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
OPER_SCHEDULE_PUB - 类 com.trs.infra.common.WCMTypes 中的静态变量
OPER_SITE_ADD - 类 com.trs.infra.common.WCMTypes 中的静态变量
添加站点
OPER_SITE_DEL - 类 com.trs.infra.common.WCMTypes 中的静态变量
测定删除站点
OPER_SITE_EDIT - 类 com.trs.infra.common.WCMTypes 中的静态变量
修改站点
OPER_SITE_PUB - 类 com.trs.infra.common.WCMTypes 中的静态变量
发布站点
OPER_SITE_RECYCLE - 类 com.trs.infra.common.WCMTypes 中的静态变量
假删除站点
OPER_SITE_RESCOVER - 类 com.trs.infra.common.WCMTypes 中的静态变量
恢复站点
OPER_SYSTEM_SET - 类 com.trs.infra.common.WCMTypes 中的静态变量
修改系统配置
OPER_SYSTEM_WARN - 类 com.trs.infra.common.WCMTypes 中的静态变量
Comment for OPER_SYSTEM_WARN 系统警告
OPER_TEMPLATE_ADD - 类 com.trs.infra.common.WCMTypes 中的静态变量
添加模板
OPER_TEMPLATE_DEL - 类 com.trs.infra.common.WCMTypes 中的静态变量
删除模板
OPER_TEMPLATE_EDIT - 类 com.trs.infra.common.WCMTypes 中的静态变量
修改模板
OPER_UNKOWN - 类 com.trs.infra.common.WCMTypes 中的静态变量
未知类型
OPER_USER_DEFINE - 类 com.trs.infra.common.WCMTypes 中的静态变量
用户指定义的操作类型起始值
OPER_USER_LOGIN - 类 com.trs.infra.common.WCMTypes 中的静态变量
用户登录
OPER_USER_LOGOUT - 类 com.trs.infra.common.WCMTypes 中的静态变量
用户退出
OPERATION_STR - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
OPERATION_STR - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
OperationConfig - com.trs.cms.auth.config 中的 类
OperationConfig() - 类 com.trs.cms.auth.config.OperationConfig 的构造方法
OperationDefineOnCurrChannelConfig - com.trs.cms.auth.config 中的 类
OperationDefineOnCurrChannelConfig() - 类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 的构造方法
OperationRelatedConfig - com.trs.cms.auth.config 中的 类
OperationRelatedConfig() - 类 com.trs.cms.auth.config.OperationRelatedConfig 的构造方法
OPERATOR_EUQALS - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OPERATOR_GREATER - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OPERATOR_GREATER_EUQALS - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OPERATOR_LENGTH - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OPERATOR_LESS - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OPERATOR_LESS_EUQALS - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OPERATOR_LIKE - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OPERATOR_NOT_EUQALS - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OPERATOR_NOT_LIKE - 类 com.trs.cms.process.ProcessConstants 中的静态变量
OperatorConfig - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OperatorConfig() - 类 com.trs.cms.process.config.OperatorConfig 的构造方法
OperType - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录的操作类型对象定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OperType() - 类 com.trs.infra.support.log.OperType 的构造方法
OPERTYPE_WCMTOTRS - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
OperType类型：WCM 数据到TRS的同步（用以演示Schedule的处理）
OperTypeHelper - com.trs.cms.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
操作日志类型标识工具类
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OperTypeHelper() - 类 com.trs.cms.logger.OperTypeHelper 的构造方法
OperTypes - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日志记录的操作类型集合对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OperTypes() - 类 com.trs.infra.support.log.OperTypes 的构造方法
OPRTYPE_GROUP - 类 com.trs.cms.auth.persistent.Right 中的静态变量
操作者类型:组
OPRTYPE_ROLE - 类 com.trs.cms.auth.persistent.Right 中的静态变量
操作者类型:角色
OPRTYPE_USER - 类 com.trs.cms.auth.persistent.Right 中的静态变量
操作者类型:单个用户
OptimizeSystemWorker - com.trs.components.common.job 中的 类
OptimizeSystemWorker() - 类 com.trs.components.common.job.OptimizeSystemWorker 的构造方法
OPTION - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
OptionConverter - com.trs.infra.util 中的 类
A convenience class to convert property values to specific types.
OptMarkParseException - com.trs.cms.process.definition 中的 异常
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OptMarkParseException(String) - 异常 com.trs.cms.process.definition.OptMarkParseException 的构造方法
or(CMyBitsValue) - 类 com.trs.infra.util.CMyBitsValue 中的方法
按位进行或运算
or(long) - 类 com.trs.infra.util.CMyBitsValue 中的方法
按位进行或运算
Ora2DB2Convertor - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
SQL脚本转换:Oracle --> DB2
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
Ora2DB2Convertor() - 类 com.trs.database.util.Ora2DB2Convertor 的构造方法
ORACLE - 类 com.trs.infra.util.database.DBTypes 中的静态变量
定义数据库类型：ORACLE
ORACLEDB - 类 com.trs.infra.util.database.DBTypes 中的静态变量
数据库类型对象：OracleDB
OracleDB - com.trs.infra.util.database 中的 类
OracleDB() - 类 com.trs.infra.util.database.OracleDB 的构造方法
OracleDB(String, String) - 类 com.trs.infra.util.database.OracleDB 的构造方法
构造函数
注：支持存储过程
OracleDB11G - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OracleDB11G() - 类 com.trs.infra.util.database.OracleDB11G 的构造方法
OracleUpdSqlMaker - com.trs.infra.util.upgrade.sql 中的 类
OracleUpdSqlMaker() - 类 com.trs.infra.util.upgrade.sql.OracleUpdSqlMaker 的构造方法
OraImpExtractDDL - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
imp system/orasysadmin touser=sichuan indexfile=sichuan.ddl full=y
获取到的文件抽取
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OraImpExtractDDL() - 类 com.trs.database.util.OraImpExtractDDL 的构造方法
orAll() - 类 com.trs.cms.auth.persistent.Rights 中的方法
将所有权限对象的权限值，做位或操作
order - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
列序号
ORDERBY_TYPE_ASC - 类 com.trs.presentation.util.PageViewUtil 中的静态变量
ORDERBY_TYPE_DESC - 类 com.trs.presentation.util.PageViewUtil 中的静态变量
OrderGroupAndRole - com.trs.infra.util.upgrade.dataprocess 中的 类
用户组/角色的排序
OrderGroupAndRole(String) - 类 com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole 的构造方法
OrgnizeContextImports - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OrgnizeContextImports() - 类 com.trs.infra.util.OrgnizeContextImports 的构造方法
OrignHomePublishException - com.trs.components.common.publish 中的 异常
OrignHomePublishException(int) - 异常 com.trs.components.common.publish.OrignHomePublishException 的构造方法
OrignHomePublishException(int, String) - 异常 com.trs.components.common.publish.OrignHomePublishException 的构造方法
OrignHomePublishException(String) - 异常 com.trs.components.common.publish.OrignHomePublishException 的构造方法
OrignHomePublishException(int, String, Throwable) - 异常 com.trs.components.common.publish.OrignHomePublishException 的构造方法
OrignHomePublishException(String, Throwable) - 异常 com.trs.components.common.publish.OrignHomePublishException 的构造方法
OTHER - 类 com.trs.infra.util.database.DBType 中的静态变量
其他数据类型
otherTableFieldType - 类 com.trs.components.metadata.web.FieldTemplate 中的静态变量
伪造的其它表视图字段类型
OTop - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Oracle Top Sql
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
OTop() - 类 com.trs.database.util.OTop 的构造方法
outContent(String, StringBuffer, boolean, boolean) - 类 com.trs.tools.CommonResourceBuilder 中的静态方法
OuterKMTRSServer - com.trs.components.wcm.content.trsserver 中的 类
OUTLINE_TEMPLATE - 类 com.trs.components.common.publish.persistent.template.Template 中的静态变量
已过时。 please use PublishConstants.TEMPLATE_TYPE_OUTLINE
OUTLINE_TEMPLATE - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态变量
OverTimeHandler - com.trs.cms.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
超时判断处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
OverTimeHandler() - 类 com.trs.cms.process.engine.handlers.OverTimeHandler 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


P - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

P

P - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
PackageFile - com.trs.components.infoview.extract.manifest 中的 类
/xsf:xDocumentClass/xsf:package/xsf:files/xsf:file
PackageFile() - 类 com.trs.components.infoview.extract.manifest.PackageFile 的构造方法
PAGE_OTHERSTYLE_WCMTYPE - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的静态变量
页面其他风格的wcmtype
PAGE_STYLE_TYPE - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
为了复用同一个页面，添加了风格类型的常量:页面风格
PageDestoryTask - com.trs.components.common.publish.domain.taskdispatch 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
撤销发布任务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PageDestoryTask(IPublishElement) - 类 com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask 的构造方法
PageDestroyer - com.trs.components.common.publish.domain.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
published page destroyer.
PageDestroyer() - 类 com.trs.components.common.publish.domain.publisher.PageDestroyer 的构造方法
PageGenerator - com.trs.components.common.publish.domain.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
page generator for publish task.
PageHelper - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
JSP列表页面的分页工具类 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PageHelper() - 类 com.trs.presentation.util.PageHelper 的构造方法
PageNavHelper - com.trs.components.common.publish.domain.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分页导航生成工具类,原来在PageGenerator类中。
PageNavHelper() - 类 com.trs.components.common.publish.domain.publisher.PageNavHelper 的构造方法
PageOperator - com.trs.wcm.config 中的 类
PageOperator() - 类 com.trs.wcm.config.PageOperator 的构造方法
构造函数：保留默认接口
PageOperators - com.trs.wcm.config 中的 类
PageOperators(User) - 类 com.trs.wcm.config.PageOperators 的构造方法
构造函数
PageOperators(User, int, int) - 类 com.trs.wcm.config.PageOperators 的构造方法
构造函数
PageOperatorsForServiceHelper - com.trs.ajaxservice 中的 类
PageOperatorsForServiceHelper() - 类 com.trs.ajaxservice.PageOperatorsForServiceHelper 的构造方法
PageOpertatosToXML - com.trs.ajaxservice.xmlconvertors 中的 类
PageOpertatosToXML() - 类 com.trs.ajaxservice.xmlconvertors.PageOpertatosToXML 的构造方法
PageParameter - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PageParameter() - 类 com.trs.presentation.util.PageParameter 的构造方法
PageParameters - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PageParameters() - 类 com.trs.presentation.util.PageParameters 的构造方法
PageParameters(int) - 类 com.trs.presentation.util.PageParameters 的构造方法
pagePattern - 类 com.trs.tools.SymbolC2E 中的静态变量
PagerHtmlGenerator(CPager, int) - 类 com.trs.presentation.util.PageHelper 中的静态方法
PagerHtmlGenerator(CPager, int, String, String) - 类 com.trs.presentation.util.PageHelper 中的静态方法
PagerHtmlGenerator(CPager, int, String, String, String, String) - 类 com.trs.presentation.util.PageHelper 中的静态方法
PagerHtmlGenerator(CPager, int, int) - 类 com.trs.presentation.util.PageHelper 中的静态方法
PagerHtmlGenerator(CPager, int, int, String, String) - 类 com.trs.presentation.util.PageHelper 中的静态方法
PagerHtmlGenerator(CPager, int, int, String, String, String, String) - 类 com.trs.presentation.util.PageHelper 中的静态方法
PageStyle - com.trs.components.common.publish.widget 中的 类
PageStyle() - 类 com.trs.components.common.publish.widget.PageStyle 的构造方法
构造函数：保留默认接口
PAGESTYLE_DEFAULT_TEMPLATENAME - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
页面特性默认模板名称
PAGESTYLE_OTHER_TEMPLATENAME - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
其他特性默认模板名称
PageStyleExporter - com.trs.components.common.publish.widget 中的 类
页面风格的导出类。
PageStyleExporter() - 类 com.trs.components.common.publish.widget.PageStyleExporter 的构造方法
构造方法
PageStyleImporter - com.trs.components.common.publish.widget 中的 类
PageStyleImporter() - 类 com.trs.components.common.publish.widget.PageStyleImporter 的构造方法
构造函数
PageStyleMgr - com.trs.components.common.publish.widget 中的 类
系统风格业务逻辑类
PageStyleMgr() - 类 com.trs.components.common.publish.widget.PageStyleMgr 的构造方法
构造方法
PageStyles - com.trs.components.common.publish.widget 中的 类
PageStyles(User) - 类 com.trs.components.common.publish.widget.PageStyles 的构造方法
构造函数
PageStyles(User, int, int) - 类 com.trs.components.common.publish.widget.PageStyles 的构造方法
构造函数
PageStyleServiceProvider - com.trs.components.common.publish.widget 中的 类
页面风格服务层
PageStyleServiceProvider() - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 的构造方法
构造方法
PageStyleXmlConverter - com.trs.components.common.publish.widget 中的 类
PageStyleXmlConverter() - 类 com.trs.components.common.publish.widget.PageStyleXmlConverter 的构造方法
构造函数
pageSymbols - 类 com.trs.tools.SymbolC2E 中的静态变量
PageTaskWorker - com.trs.components.common.publish.domain.taskdispatch 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
worker to execute the page task.
PageTaskWorker(IPageTaskDispatcher, PublishTaskContext) - 类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 的构造方法
constructor
PageTaskWorker(IPageTaskDispatcher, PublishTaskContext, IPublishProgressMonitor) - 类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 的构造方法
constructor
PageUtil - com.trs.components.wcm.wcmx.jsp 中的 类
PageUtil() - 类 com.trs.components.wcm.wcmx.jsp.PageUtil 的构造方法
PageViewConstants - com.trs.presentation.common 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PageViewConstants() - 类 com.trs.presentation.common.PageViewConstants 的构造方法
PageViewUtil - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PageViewUtil() - 类 com.trs.presentation.util.PageViewUtil 的构造方法
PARAM - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
PARAM_COMPAREDFIELD - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的静态变量
PARAM_COMPAREDFIELD - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的静态变量
PARAM_NAME_ORDER_FIELD - 类 com.trs.presentation.util.RequestHelper 中的静态变量
PARAM_NAME_ORDER_FIELD - 类 com.trs.webframework.controler.servlet.BaseValidator 中的静态变量
PARAM_NAME_ORDER_TYPE - 类 com.trs.presentation.util.RequestHelper 中的静态变量
PARAM_NAME_ORDER_TYPE - 类 com.trs.webframework.controler.servlet.BaseValidator 中的静态变量
PARAM_NAME_SEARCH_KEY - 类 com.trs.presentation.util.RequestHelper 中的静态变量
PARAM_NAME_SEARCH_KEY - 类 com.trs.webframework.controler.servlet.BaseValidator 中的静态变量
PARAM_NAME_SEARCH_TABLE - 类 com.trs.presentation.util.RequestHelper 中的静态变量
PARAM_NAME_SEARCH_TABLE - 类 com.trs.webframework.controler.servlet.BaseValidator 中的静态变量
PARAM_NAME_SEARCH_VALUE - 类 com.trs.presentation.util.RequestHelper 中的静态变量
PARAM_NAME_SEARCH_VALUE - 类 com.trs.webframework.controler.servlet.BaseValidator 中的静态变量
PARAM_TYPE_BOOLEAN - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态变量
PARAM_TYPE_ENUMER - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态变量
PARAM_TYPE_ENUMER_EXT - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态变量
PARAM_TYPE_INT - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态变量
PARAM_TYPE_LONGTEXT - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态变量
PARAM_TYPE_TEXT - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态变量
PARAM_UNIQUENAME - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的静态变量
PARAM_UNIQUENAME - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的静态变量
PARAM_VIEWID - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的静态变量
PARAM_VIEWID - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的静态变量
ParamConfig - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
参数配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ParamConfig() - 类 com.trs.cms.process.config.ParamConfig 的构造方法
Parameter - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Parameter() - 类 com.trs.presentation.util.Parameter 的构造方法
PARAMETER_END_FLAG - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态变量
资源块变量的开始标记
PARAMETER_FLAG - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态变量
资源块变量的标记
PARAMETER_START_FLAG - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态变量
资源块变量的开始标记
parameters() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 中的方法
便利所有的形式参数
Parameters - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Parameters() - 类 com.trs.presentation.util.Parameters 的构造方法
Parameters(int) - 类 com.trs.presentation.util.Parameters 的构造方法
parse(String) - 类 com.trs.ajaxservice.xmlconvertors.XMLToCMSObj 中的方法
parse(PublishTagContext) - 类 com.trs.components.comment.publish.tagparser.XWCMTagParserComment 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 中的方法
parse(PublishTagContext) - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser 中的方法
Parses the specified tag item and returns the result.
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserCondition 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserDateTime 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserEcho 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserRepeat 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariable 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet 中的方法
parse(Template) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
parse the specified template
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayoutCell 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserResources 中的方法
发布产生指定的资源
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix 中的方法
解析
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo 中的方法
解析
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator 中的方法
parse(PublishTagContext) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserWidget 中的方法
parse(PublishTagContext) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoView 中的方法
parse(PublishTagContext) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData 中的方法
parse(PublishTagContext) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper 中的方法
parse(PublishTagContext) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav 中的方法
parse(PublishTagContext) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的方法
parse(PublishTagContext) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage 中的方法
parse(PublishTagContext) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的方法
parse(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserAppendix 中的方法
parse(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserClassIndexGener 中的方法
parse(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserClassInfos 中的方法
parse(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo 中的方法
parse(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法
parse(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserViewData 中的方法
parse(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserViewDatas 中的方法
parse(String) - 接口 com.trs.components.stat.IURLParser 中的方法
根据Url信息，返回该Url对应的BaseObj对象。
parse(String) - 类 com.trs.components.stat.URLParser 中的方法
parse(String) - 接口 com.trs.components.wcm.channel.IVChannelParser 中的方法
从文件内容中解释得到需要创建的对象.
parse(String) - 类 com.trs.components.wcm.channel.TxtFileParser 中的方法
parse(String) - 接口 com.trs.components.wcm.contentlink.IVContentLinkParser 中的方法
从文件内容中解释得到需要创建的对象.
parse(String) - 类 com.trs.components.wcm.contentlink.TxtFileParserForContentLink 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.epress.TagEBookDirParser 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.epress.TagMapAreaParser 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.epress.TagParserPageNav 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.epress.TagPreNextParser 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.region.WCMTagParserRegion 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.TagChannelChainParser 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.TagParserCRUser 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImage 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImages 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.TagWmlContentParser 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.XTagParserObjsInChannelBase 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.XWCMContImgTagParser 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser 中的方法
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser 中的方法
通过图片全路径找到图片名称（带后缀名）
parse(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration 中的方法
parse(String, IPropertiesBuilder) - 类 com.trs.components.web.BaseFieldHTMLParser 中的方法
parse(String, IPropertiesBuilder) - 接口 com.trs.components.web.IFieldHTMLParser 中的方法
根据字段的内容，解析成相应的HTML代码
parse(String) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法
parse(String, String) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法
parse() - 类 com.trs.scene.parser.ScenePathsParser 中的方法
parse() - 类 com.trs.scene.parser.SceneXMLParser 中的方法
parse(String) - 类 com.trs.tools.HtmlCleaner 中的静态方法
parse(PublishTagContext) - 类 com.trs.wcm.photo.publish.WCMTagParserImage 中的方法
parse(PublishTagContext) - 类 com.trs.wcmonline.TagParserVipMetaData 中的方法
parse(String) - 类 com.trs.webframework.controler.PostDataParser 中的方法
parse(InputSource) - 类 com.trs.webframework.controler.PostDataParser 中的方法
parse2Json(Object) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
转换Object对象为Json对象,目前只支持List,Map和String三类,其余统一使用toString转换成String
parse4Children(TagItem, PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
parse4List(PublishTagContext, ITagParser4List) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
parse4List(TagItem, PublishTagContext, ITagParser4List) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Parses objects list tag, eg.
PARSE_MODE_EDIT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PARSE_MODE_KEY - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PARSE_MODE_NORM - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
parseAutoMore(IPublishFolder, PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 中的方法
Parses the auto more HTML text.
parseAutoMore(IPublishFolder, PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments 中的方法
parseChains2Script(String) - 类 com.trs.components.infoview.config.InfoViewEnumHelper 中的静态方法
转换级联菜单的xml内容为script内容
parseChnlRelatedEnum(PublishTagContext) - 类 com.trs.components.infoview.publish.tagparser.InfoviewSpecailTagParseHelper 中的静态方法
parseComments(FlowDoc) - 类 com.trs.cms.process.FlowEngineHelper 中的静态方法
解析处理过程中的意见，解析成偶数长度的数组
parseContent(IPublishElement, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
parseContent(IPublishElement, String, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
将一旦包含置标的文本解析
parseContent(String, HashMap) - 类 com.trs.components.common.publish.domain.template.CSSResourceProcessor 中的方法
已过时。 use processConent instead.
parseCssAndCopySrcFileAsTempAppedix(String, String, Template) - 类 com.trs.components.common.publish.domain.template.TemplateParseHelper 中的静态方法
ge add by gfc
parseCssContent(String) - 类 com.trs.components.common.publish.widget.StyleHelper 中的静态方法
将模板中的CSS内容解析成多个List对象
过滤了模板中的样式和多余的回车换行
parseCSSFile(String, HashMap) - 类 com.trs.components.common.publish.domain.template.CSSResourceProcessor 中的方法
parseDateFormat(String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Parses a date format string.
parseFlowingPath(String) - 类 com.trs.ajaxservice.ApplyFormServiceProvider 中的方法
parseFlowingPath(String) - 类 com.trs.ajaxservice.FlowingDocQueryService 中的方法
parseHTMLContent(String) - 类 com.trs.cms.content.HTMLContent 中的方法
parseHtmlContent(String, IPublishContent, PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
parseHTMLContentWihtMultImgPre(String[]) - 类 com.trs.cms.content.HTMLContent 中的方法
parseItem(TagItem, PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Parses a tag item and returns the results which may be more than one.
parseItems(List, PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Parses the tag items list and return the results which may be more than one.
parsePageVariables(String) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
parsePageVariables(String, Map) - 类 com.trs.components.infoview.process.SendEmailForInfoViewHandler 中的方法
parsePageVariables(String, Map) - 类 com.trs.infra.util.CMyString 中的静态方法
替换内容中的变量
parsePageVariables(String, Map, char[]) - 类 com.trs.infra.util.CMyString 中的静态方法
替换内容中的变量
parsePageVariables(String, Map, int) - 类 com.trs.infra.util.CMyString 中的静态方法
替换内容中的变量
parsePageVariables(String, Map, char[], int) - 类 com.trs.infra.util.CMyString 中的静态方法
替换内容中的变量
parseSubItems(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserViewData 中的方法
parseTemplate(MethodContext) - 接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider 中的方法
将专题对应栏目的模板内容解析成可视化编辑模板形式的字符串
parseTemplate(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
parseToDocument(String) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
parseToEditContent(IPublishElement, String) - 接口 com.trs.components.common.publish.widget.IWidgetServer 中的方法
将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
parseToEditContent(IPublishElement, Template) - 接口 com.trs.components.common.publish.widget.IWidgetServer 中的方法
将发布对象（一般为站点、栏目或文档）的发布页面解析成可编辑的状态
parseToEditContent(IPublishElement, WidgetInstance) - 接口 com.trs.components.common.publish.widget.IWidgetServer 中的方法
解析某一个资源块实例对象成可编辑的状态
parseToEditContent(IPublishElement, String) - 类 com.trs.components.common.publish.widget.WidgetServer 中的方法
parseToEditContent(IPublishElement, Template) - 类 com.trs.components.common.publish.widget.WidgetServer 中的方法
parseToEditContent(IPublishElement, WidgetInstance) - 类 com.trs.components.common.publish.widget.WidgetServer 中的方法
parseToTemplate(String) - 接口 com.trs.components.common.publish.widget.IWidgetServer 中的方法
将可视化模板的内容，解析成相应的模板
parseToTemplate(String) - 类 com.trs.components.common.publish.widget.WidgetServer 中的方法
parseWidgetInstance(MethodContext) - 接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider 中的方法
将某一个资源块实例解析成可视化编辑模板形式的字符串
parseWidgetInstance(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
passwordIs(String) - 类 com.trs.cms.auth.persistent.User 中的方法
判断密码是否正确
PATH_FTP - 类 com.trs.infra.support.file.FilesMan 中的静态变量
目录类型：Ftp目录，用于Ftp( for Client )
PATH_HTTP - 类 com.trs.infra.support.file.FilesMan 中的静态变量
目录类型：Http目录，用于Web( for Client )
PATH_LOCAL - 类 com.trs.infra.support.file.FilesMan 中的静态变量
目录类型：本地目录，用于Server( for Server )
PATH_OF_RESULT_MAIL_TEMPLATE - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
PATH_OF_SUBMIT_MAIL_TEMPLATE - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
PathConfig - com.trs.infra.support.config 中的 类
PathConfig() - 类 com.trs.infra.support.config.PathConfig 的构造方法
默认构造函数
PathConfig(PathConfig) - 类 com.trs.infra.support.config.PathConfig 的构造方法
使用目录配置对象构造对象
PathConfig(String) - 类 com.trs.infra.support.config.PathConfig 的构造方法
使用组合字符串构造对象 字符串格式：Flag;LocalPath;HttpPath;FtpPath
PathConfigLCListener - com.trs.infra.support.file 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
目录配置更新的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PathConfigLCListener() - 类 com.trs.infra.support.file.PathConfigLCListener 的构造方法
pathExists(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
检查指定文件的路径是否存在
pauseTask(PublishTask) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
暂停指定任务的执行
pauseTask(int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
暂停指定发布任务的执行,如果指定ID的发布任务还没有执行或者已经执行结束则什么都不作。
pauseTask(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
pauseTask(int) - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法
pauseTask(String) - 类 com.trs.service.impl.PublishService 中的方法
pauseTask(String) - 接口 com.trs.service.IPublishService 中的方法
暂停指定的发布任务集合，对其中不处于执行状态的任务不会产生影响
PERIOD_DAY - 类 com.trs.components.wcm.stat.domain.ChartOption 中的静态变量
PERIOD_MONTH - 类 com.trs.components.wcm.stat.domain.ChartOption 中的静态变量
PERIOD_WEEK - 类 com.trs.components.wcm.stat.domain.ChartOption 中的静态变量
PERIOD_YEAR - 类 com.trs.components.wcm.stat.domain.ChartOption 中的静态变量
PGVAR_ROOT_PATH - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
page variable: root path
PGVARNAME_CURREXTRA - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_HEADDESC - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_MAX_LENGTH - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
“PGVARNAME_*”系列参数的参数名称的最大长度，在替换这些参数为实际值时会用到
PGVARNAME_NAVEXTRA - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_NAVIDPRE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_NAVPAGES - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_NAVSHOWHEADTAIL - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_NAVSHOWPRENEXT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_NAVTARGET - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_NEXTDESC - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_OUTLINENAV - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_PAGECOUNT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
page variable name: pages count
PGVARNAME_PAGEEXT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
page variable name: pages ext
PGVARNAME_PAGEINDEX - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
page variable name: current page index
PGVARNAME_PAGENAME - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
page variable name: pages name
PGVARNAME_PREDESC - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_RECORDCOUNT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
page variable name: record count
PGVARNAME_ROOT_PATH - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
page variable name: root path
PGVARNAME_TAILDESC - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_WMLIMAGE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_WMLIMAGECOUNT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_WMLIMAGEDESC - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PGVARNAME_WMLIMAGEFILE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
PHOTO_SITE - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
PhotoImporter - com.trs.wcm.photo.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片导入(项目定制)
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
PhotoImporter() - 类 com.trs.wcm.photo.impl.PhotoImporter 的构造方法
PhotoLibConfig - com.trs.infra.util.upgrade.dataprocess 中的 类
处理图片库配置(将一些配置添加到wcmconfig表
PhotoLibConfig(String, String) - 类 com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig 的构造方法
构造函数
PhotoServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片选件服务
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
PhotoServiceProvider() - 类 com.trs.ajaxservice.PhotoServiceProvider 的构造方法
PieChartProducer - com.trs.components.wcm.stat.chart 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PieChartProducer() - 类 com.trs.components.wcm.stat.chart.PieChartProducer 的构造方法
PinyinHelper - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
汉字转拼音
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
PinyinHelper() - 类 com.trs.infra.util.PinyinHelper 的构造方法
PluginConfig - com.trs.infra.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PluginConfig() - 类 com.trs.infra.config.persistent.PluginConfig 的构造方法
PluginConfig - com.trs.presentation.plugin 中的 类
PluginConfig() - 类 com.trs.presentation.plugin.PluginConfig 的构造方法
PortalHelper - com.trs.presentation.portal 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PortalHelper() - 类 com.trs.presentation.portal.PortalHelper 的构造方法
PorterUtil - com.trs.components.wcm.content.service.portervisitors 中的 类
PorterUtil() - 类 com.trs.components.wcm.content.service.portervisitors.PorterUtil 的构造方法
PorterVisitorFactory - com.trs.components.wcm.content.service.portervisitors 中的 类
PorterVisitorFactory() - 类 com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory 的构造方法
position() - 类 com.trs.infra.persistent.BaseObjs 中的方法
取当前指针位置
POSITION_AFTER - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的静态变量
POSITION_AFTER - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的静态变量
POSITION_AFTER_NEW - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的静态变量
POSITION_BEFORE - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的静态变量
POSITION_BEFORE - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的静态变量
PositionComparator - com.trs.components.ckm 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
对CKM返回数组进行排序，按pos升序排列 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PositionComparator() - 类 com.trs.components.ckm.PositionComparator 的构造方法
PostDataParser - com.trs.webframework.controler 中的 类
PostDataParser() - 类 com.trs.webframework.controler.PostDataParser 的构造方法
PostUserNameCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PostUserNameCreator() - 类 com.trs.cms.process.engine.creators.PostUserNameCreator 的构造方法
PRE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
PREFIX_DBFIELD_NAME - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量
数据库中字段前缀名 增加前缀名便于记忆、管理；避免重名
PREFIX_DBRELATION_NAME - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
数据库中多表视图记录关联关系的前缀名 增加前缀名便于记忆、管理；避免重名
PREFIX_DBTABLE_NAME - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量
元数据物理表前缀名 增加前缀名便于记忆、管理；避免重名
PREFIX_DBTABLE_NAME - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
元数据物理表前缀名 增加前缀名便于记忆、管理；避免重名
PREFIX_DBVIEW_NAME - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
数据库中视图前缀名 增加前缀名便于记忆、管理；避免重名
PreNextDocumentsImpl - com.trs.components.wcm.publish.domain 中的 类
PreNextDocumentsImpl() - 类 com.trs.components.wcm.publish.domain.PreNextDocumentsImpl 的构造方法
PreNextDocumentsImplTest - com.trs.components.wcm.publish.domain 中的 类
PreNextDocumentsImplTest() - 类 com.trs.components.wcm.publish.domain.PreNextDocumentsImplTest 的构造方法
prevChar() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
返回前一个字符,但是不移动指针
preview(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
文档编辑时的预览
preview(MethodContext) - 类 com.trs.ajaxservice.PublishServiceProvider 中的方法
preview(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
preview(Template) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
预览指定的模板
preview(MethodContext) - 接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider 中的方法
获取指定栏目或文档对象在指定模板内容下的预览内容
preview(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
preview(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
preview(BaseChannel, String[]) - 类 com.trs.service.impl.PublishService 中的方法
preview(Document, String[]) - 类 com.trs.service.impl.PublishService 中的方法
preview(Document, Channel, String[]) - 类 com.trs.service.impl.PublishService 中的方法
preview(Document, Channel, String[], Template) - 类 com.trs.service.impl.PublishService 中的方法
preview(int) - 类 com.trs.service.impl.TemplateService 中的方法
preview(Template) - 类 com.trs.service.impl.TemplateService 中的方法
preview(BaseChannel, String[]) - 接口 com.trs.service.IPublishService 中的方法
预览指定的站点/频道，并返回预览页面的URL列表（若配置了多个概览模板，则可能有多个）。
preview(Document, String[]) - 接口 com.trs.service.IPublishService 中的方法
在文档的存放点上预览文档，并返回预览页面的URL。
preview(Document, Channel, String[]) - 接口 com.trs.service.IPublishService 中的方法
在指定的频道上预览文档，并返回预览页面的URL。
preview(int) - 接口 com.trs.service.ITemplateService 中的方法
预览指定id的模板
preview(Template) - 接口 com.trs.service.ITemplateService 中的方法
预览指定的模板
preview(String, String, String, byte[], String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
preview(String, String, String, byte[], String) - 接口 com.trs.template.service.ITemplateService 中的方法
DW客户端预览模板
preview(String, String, String, byte[], String) - 类 com.trs.template.TRSTemplateFacade 中的方法
DW客户端预览模板
PreviewChannelServiceProvider - com.trs.ajaxservice 中的 类
PreviewChannelServiceProvider() - 类 com.trs.ajaxservice.PreviewChannelServiceProvider 的构造方法
previewChild(MethodContext) - 类 com.trs.ajaxservice.PreviewChannelServiceProvider 中的方法
previewContent(IPublishContent, String[]) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
Previews a content and returns the URL of preview page.
previewContent(IPublishContent, String[], Template) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
previewFolder(IPublishFolder, String[]) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
Previews a content folder and returns the URLs of preview pages.
previewFolder(IPublishFolder, String[], Template) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
previewInfoviewPrint(Document, Channel, String[], int) - 类 com.trs.service.impl.PublishService 中的方法
previewInfoviewPrint(Document, Channel, String[], int) - 接口 com.trs.service.IPublishService 中的方法
previewStyle(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
预览风格根据当前填写的风格设置项 其中参数StyleItemXML的格式为一段xml，格式类似于 previewStyle(PageStyle, StyleItems) - 接口 com.trs.components.common.publish.widget.IPageStyleMgr 中的方法
获取预览时需要的样式内容
previewStyle(PageStyle, String, String, StyleItems, String) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
预览时，获取风格的内容
previewStyle(PageStyle, StyleItems) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
获取预览时需要的样式内容
previewStyle(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
获取预览页面基本特性时需要的样式内容 参数为ObjectId和StyleItemXML(一个xml串) StyleItemXML格式类似于previewStyle(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
预览风格根据当前填写的风格设置项 其中参数StyleItemXML的格式为一段xml，格式类似于 previewStyle(PageStyle, String, String, StyleItems, String) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
预览时，获取风格的内容
PRI_DOCS_SIZE - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
printDetail(Object, String) - 类 com.trs.infra.util.ConfigElementContentTester 中的静态方法
打印出配置对象的所有公开的"get"属性
printDetail(Object) - 类 com.trs.infra.util.ConfigElementContentTester 中的静态方法
打印出配置对象的所有公开的"get"属性
printStackTrace(PrintStream) - 异常 com.trs.infra.util.CMyException 中的方法
printStackTrace(PrintWriter) - 异常 com.trs.infra.util.CMyException 中的方法
向指定设备打印错误信息
printStackTrace(PrintStream) - 异常 com.trs.webframework.exception.ServiceInvocationException 中的方法
向指定设备打印错误信息
printStackTrace(PrintWriter) - 异常 com.trs.webframework.exception.ServiceInvocationException 中的方法
向指定设备打印错误信息
process() - 类 com.trs.infra.util.JavaScriptVARProcessor 中的方法
开始逐个处理文件
process(String, String) - 类 com.trs.infra.util.JavaScriptVARProcessor 中的方法
process() - 类 com.trs.infra.util.PropertiesVARProcessor 中的方法
开始逐个处理文件
process(String, String) - 类 com.trs.infra.util.PropertiesVARProcessor 中的方法
processAppendix(List, int) - 类 com.trs.service.impl.DocumentService 中的方法
processConent(String, Map, String) - 类 com.trs.components.common.publish.domain.template.CSSResourceProcessor 中的方法
处理css文件中的url文件.
ProcessConstants - com.trs.cms.process 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ProcessConstants() - 类 com.trs.cms.process.ProcessConstants 的构造方法
processCssFlag(String, int, int) - 类 com.trs.components.common.publish.widget.StyleRepeatNameHelper 中的静态方法
处理风格名称
processInfoViewAppendix(Document) - 类 com.trs.components.infoview.InfoviewDataProcessor 中的方法
processJavaScript() - 类 com.trs.tools.MediaBuilder 中的静态方法
processProperties() - 类 com.trs.tools.MediaBuilder 中的静态方法
ProcessService - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ProcessService() - 类 com.trs.ajaxservice.ProcessService 的构造方法
processStyleName(String, int, int) - 类 com.trs.components.common.publish.widget.StyleRepeatNameHelper 中的静态方法
处理风格名称
processTemplateAppendixes(Template, String, int) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
将指定的內容处理成模板的格式，如：将里面的图片资源进行处理
produceDataset(Map) - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的方法
produceDataset(Map) - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的方法
produceDataset(Map) - 类 com.trs.components.wcm.stat.domain.TimingChartProducer 中的方法
ProgressMonitorImpl - com.trs.components.common.publish.domain.taskdispatch 中的 类
发布进程监控器IPublishProgressMonitor的缺省实现
ProgressMonitorImpl() - 类 com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl 的构造方法
缺省构造方法
PROMPT - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
PROP_INDEX_UPLOAD - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
站点属性索引：上传文件(0)
PropertiesUtil - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
utilities for properties.
PropertiesVARProcessor - com.trs.infra.util 中的 类
PropertiesVARProcessor(String, String, String, String) - 类 com.trs.infra.util.PropertiesVARProcessor 的构造方法
PROPERTY_NAME_SETTING - 类 com.trs.template.domain.setting.TemplateSettingFactory 中的静态变量
publish(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
publish(MethodContext) - 类 com.trs.ajaxservice.PublishServiceProvider 中的方法
发布指定的对象
publish(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
publish(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
publish(BaseChannel, int) - 类 com.trs.service.impl.PublishService 中的方法
publish(Document, int) - 类 com.trs.service.impl.PublishService 中的方法
publish(Document, Channel, int) - 类 com.trs.service.impl.PublishService 中的方法
publish(Documents, int) - 类 com.trs.service.impl.PublishService 中的方法
publish(Documents, Channel, int) - 类 com.trs.service.impl.PublishService 中的方法
publish(ChnlDocs, int) - 类 com.trs.service.impl.PublishService 中的方法
publish(BaseChannel, int) - 接口 com.trs.service.IPublishService 中的方法
完全发布站点/频道
publish(Document, int) - 接口 com.trs.service.IPublishService 中的方法
发布文档
publish(Document, Channel, int) - 接口 com.trs.service.IPublishService 中的方法
发布文档
publish(Documents, int) - 接口 com.trs.service.IPublishService 中的方法
发布指定文档集合
publish(Documents, Channel, int) - 接口 com.trs.service.IPublishService 中的方法
发布指定文档集合
publish(ChnlDocs, int) - 接口 com.trs.service.IPublishService 中的方法
发布指定的ChnlDoc集合，用于“最近访问文档”的直接发布
PUBLISH_CHILD_NEED - 类 com.trs.infra.common.WCMTypes 中的静态变量
PUBLISH_CONTENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish type: publish a content
PUBLISH_CONTENT_DIRECT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
文档的直接发布，绕开关于发布状态的限制，直接单篇（将来也许多篇）发布文档
PUBLISH_FOLDER_FULLY - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish type: full-publish folder, include the outline pages and all the detailed pages.
PUBLISH_FOLDER_INCREASING - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish type：increasing-publish folder, include the outline pages and all the contents who have not been published but can be published.
PUBLISH_FOLDER_REFRESH - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish type: refresh folder published page, just refreshing the outline pages.
PUBLISH_FOLDER_REFRESH_ON_DEL_CONTENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
删除内容时候触发的栏目更新发布
PUBLISH_FOLDER_SYNC - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
准确的说是分发任务，目录同步
PUBLISH_MYSELF_ONLY - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish type: publish the pages of myself only; for a folder, they are the outline pages; for a content, it is the detailed page.
PUBLISH_NOT_NEED - 类 com.trs.infra.common.WCMTypes 中的静态变量
PUBLISH_RECALL - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish type: recall the published pages
PUBLISH_SCRIPT_PATH - 类 com.trs.components.infoview.InfoViewMgr 中的静态变量
表单发布后，所依赖的JavaScript文件和图片在根的images下的子目录名
PUBLISH_SELF_NEED - 类 com.trs.infra.common.WCMTypes 中的静态变量
PUBLISH_TYPES_OF_CONTENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
all content publish types list
PUBLISH_TYPES_OF_FOLDER - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
all folder publish types list
PUBLISH_UNKNOWN - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish type: unknown
publishClassInfo(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoPublishServiceProvider 中的方法
PublishConfigSaveLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
发布相关属性日志操作记录
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
PublishConfigSaveLogger() - 类 com.trs.ajaxservice.logger.PublishConfigSaveLogger 的构造方法
publishConfirm(IPublishFolder, String, String, String) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
确认（批准）发布，其内部行为： 1.删除备份文件 2.重名名正式文件为备份文件 3.重名名临时文件为备份文件
publishConfirm(BaseChannel, String, String, String) - 类 com.trs.service.impl.PublishService 中的方法
publishConfirm(BaseChannel, String, String, String) - 接口 com.trs.service.IPublishService 中的方法
确认（批准）发布 用于先将站点或频道的首页发布到一个临时文件，在确认没有错误后，再把临时文件重名为正式的站点或频道首页。
PublishConstants - com.trs.components.common.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
constants for publish components.
publishContent(IPublishContent, IPublishElements) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
忽略文档的状态，在指定的Folder下发布文档
publishContent(IPublishContent, int) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
publish a content in the specified folder with specified PubType
publishContent(IPublishContent) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
publish a content in the specified folder
PublishContentActionHandler - com.trs.cms.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
发布文档操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishContentActionHandler() - 类 com.trs.cms.process.engine.handlers.PublishContentActionHandler 的构造方法
PublishContentDefaultObjImpl - com.trs.components.common.publish.persistent.element 中的 类
PublishContentDefaultObjImpl() - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 的构造方法
PublishContentDefaultObjImpl(DefaultObj) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 的构造方法
PublishContentDocumentImpl - com.trs.components.wcm.publish.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
publis content implementation with document.
PublishContentDocumentImpl() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 的构造方法
constructor: default
PublishContentDocumentImpl(Document) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 的构造方法
constructor
PublishContentImplBase - com.trs.components.common.publish.persistent.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for publish content.
PublishContentImplBase() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 的构造方法
PublishContentLCListener - com.trs.components.common.publish.domain.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishContentLCListener() - 类 com.trs.components.common.publish.domain.element.PublishContentLCListener 的构造方法
publishContents(MethodContext) - 类 com.trs.ajaxservice.PublishServiceProvider 中的方法
在指定的栏目中发布指定的文档
publishContents(IPublishElements, IPublishFolder, int) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
publish the contents collection
PublishContentViewDataImpl - com.trs.components.metadata.publish 中的 类
PublishContentViewDataImpl() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 的构造方法
PublishContentViewFieldImpl - com.trs.components.metadata.publish 中的 类
PublishContentViewFieldImpl() - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 的构造方法
PublishContentViewImpl - com.trs.components.metadata.publish 中的 类
PublishContentViewImpl() - 类 com.trs.components.metadata.publish.PublishContentViewImpl 的构造方法
PublishContentWrapper - com.trs.components.common.publish.persistent.element 中的 类
IPublishContent的代理实现
PublishContentWrapper(IPublishContent) - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 的构造方法
使用给定的 IPublishContent 实例构造 PublishContentWrapper 代理对象
PublishDistribution - com.trs.components.common.publish.persistent.distribute 中的 类
PublishDistribution() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 的构造方法
构造函数：保留默认接口
PublishDistributionCacheMgr - com.trs.components.common.publish.domain.distribute 中的 类
FolderType,FolderId 到 PublishDistributionList 的缓存，加速给定目录分发点的查找
PublishDistributionCacheMgr() - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 的构造方法
缺省构造方法
PublishDistributionConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishDistributionConfig() - 类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig 的构造方法
PublishDistributionLCListener - com.trs.components.common.publish.domain.distribute 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分发的新增/修改监听,需要的话,做一次同步模板附件操作.
PublishDistributionLCListener() - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionLCListener 的构造方法
PublishDistributionList - com.trs.components.common.publish.domain.distribute 中的 类
用于描述给定的Folder下的所有的分发点列表
PublishDistributionList() - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionList 的构造方法
缺省构造方法
PublishDistributionMgr - com.trs.components.common.publish.domain.distribute 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
publish distribution manager.
PublishDistributionMgr() - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr 的构造方法
constructor: default
PublishDistributions - com.trs.components.common.publish.persistent.distribute 中的 类
PublishDistributions(User) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 的构造方法
构造函数
PublishDistributions(User, int, int) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 的构造方法
构造函数
PublishDistributionTargetType - com.trs.components.common.publish.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
publish distribute target type.
PublishDistributionTargetType() - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 的构造方法
constructor: default
publishDocuments(HttpSession, JspWriter, int, int) - 类 com.trs.components.wcm.publish.tagparser.DocumentsTemp 中的方法
PublishElementConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishElementConfig() - 类 com.trs.components.common.publish.config.persistent.PublishElementConfig 的构造方法
PublishElementFactory - com.trs.components.common.publish.persistent.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
factory of publish element instance.
PublishElementFactory() - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 的构造方法
PublishElementsCMSListImpl - com.trs.components.common.publish.persistent.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
PublishElements implementation with CMS object list.
PublishElementsCMSListImpl(List) - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 的构造方法
constructor
PublishElementsCMSObjsImpl - com.trs.components.common.publish.persistent.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
publish elements collection CMS implementation.
PublishElementsCMSObjsImpl(CMSBaseObjs) - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 的构造方法
constructor
PublishElementsIteratorDocumentsImpl - com.trs.components.wcm.publish.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishElementsIteratorDocumentsImpl(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 的构造方法
PublishElementsListImpl - com.trs.components.common.publish.persistent.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
IPublishElements implementation with list.
PublishElementsListImpl() - 类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 的构造方法
constructor: default
PublishElementType - com.trs.components.common.publish.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element type.
PublishElementType() - 类 com.trs.components.common.publish.config.PublishElementType 的构造方法
PublishElementWrapper - com.trs.components.common.publish.persistent.element 中的 类
IPublishElement的代理实现
PublishElementWrapper(IPublishElement) - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 的构造方法
使用给定的 IPublishElement 实例构造 PublishElementWrapper 代理对象
PublishErrorLog - com.trs.components.common.publish.persistent.taskdispatch 中的 类
PublishErrorLog() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 的构造方法
构造函数：保留默认接口
PublishErrorLogs - com.trs.components.common.publish.persistent.taskdispatch 中的 类
PublishErrorLogs(User) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs 的构造方法
构造函数
PublishErrorLogs(User, int, int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs 的构造方法
构造函数
publishFolder(IPublishFolder, int) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
publish the content folder
PublishFolderChannelImpl - com.trs.components.wcm.publish.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
channel implementation of IPublishFolder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishFolderChannelImpl() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 的构造方法
constructor: default
PublishFolderChannelImpl(Channel) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 的构造方法
constructor
PublishFolderClassImpl - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分类Folder的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishFolderClassImpl() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 的构造方法
PublishFolderImplBase - com.trs.components.common.publish.persistent.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation base for IPublishFolder.
PublishFolderImplBase() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 的构造方法
PublishFolderLCListener - com.trs.components.common.publish.domain.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板需要监控的其他相关对象的操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishFolderLCListener() - 类 com.trs.components.common.publish.domain.element.PublishFolderLCListener 的构造方法
PublishFolderWebSiteImpl - com.trs.components.wcm.publish.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
website implementation of folder.
PublishFolderWebSiteImpl() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 的构造方法
constructor: default
PublishFolderWebSiteImpl(WebSite) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 的构造方法
constructor
PublishFolderWrapper - com.trs.components.common.publish.persistent.element 中的 类
IPublishFolder的代理实现
PublishFolderWrapper(IPublishFolder) - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 的构造方法
使用给定的 IPublishFolder 实例构造 PublishFolderWrapper 代理对象
publishForcibly(int, String) - 类 com.trs.service.impl.PublishService 中的方法
publishForcibly(int, String) - 接口 com.trs.service.IPublishService 中的方法
强制在指定的频道中发布文档， 如果文档在指定的频道中状态为不允许发布状态，将会自动改为可发布的状态，然后再发不
publishHistoryIndex(MethodContext) - 类 com.trs.components.wcm.epress.EPressServiceProvider 中的方法
PublishJobWorker - com.trs.components.wcm.publish.domain.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
计划发布执行者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishJobWorker() - 类 com.trs.components.wcm.publish.domain.job.PublishJobWorker 的构造方法
构造函数，保留默认接口
PublishListenerForPubGovInfo - com.trs.components.metadata.service.listener 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishListenerForPubGovInfo() - 类 com.trs.components.metadata.service.listener.PublishListenerForPubGovInfo 的构造方法
PublishPageContext - com.trs.components.common.publish.domain.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
context during page generating
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishPageContext(PublishPageContext) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 的构造方法
constructor
PublishPageContext(IPublishElement, PublishTaskContext) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 的构造方法
constructor
PublishPageContext(IPublishElement, PublishTaskContext, IPublishProgressMonitor) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 的构造方法
constructor
PublishPathCompass - com.trs.components.common.publish.domain.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Compass who can tell you all the path infomation of a folder.
PublishPathCompass() - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 的构造方法
constructor: default
PublishServer - com.trs.components.common.publish.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishServer() - 类 com.trs.components.common.publish.domain.PublishServer 的构造方法
constructor: default
PublishServerConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishServerConfig() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 的构造方法
PublishServerConfigMapper - com.trs.components.common.publish.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
the publish server configuration.
PublishService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IPublishService.
PublishService() - 类 com.trs.service.impl.PublishService 的构造方法
constructor: default
PublishServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
发布服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishServiceProvider() - 类 com.trs.ajaxservice.PublishServiceProvider 的构造方法
PublishSyncGlobalTuner - com.trs.components.common.publish.domain.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
synchronization tuner for publish threads.
PublishTagContext - com.trs.components.common.publish.domain.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse context.
PublishTagContext(IPublishElement, Map, PublishPageContext) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 的构造方法
已过时。 constructor
PublishTagContext(IPublishElement, Map, PublishTagContext) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 的构造方法
已过时。 constructor
PublishTagContext(PublishPageContext) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 的构造方法
PublishTagContext(PublishTagContext, TagItem) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 的构造方法
PublishTagContext(PublishTagContext, TagItem, ITagParser4List) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 的构造方法
PublishTagContext(PublishTagContext, TagItem, IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 的构造方法
PublishTask - com.trs.components.common.publish.persistent.taskdispatch 中的 类
PublishTask() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 的构造方法
构造函数：保留默认接口
PublishTaskAnalyzer - com.trs.components.common.publish.domain.taskdispatch 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
publish task analyzer.
PublishTaskAnalyzer() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 的构造方法
constructor: default
PublishTaskContext - com.trs.components.common.publish.domain.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
context for publish task.
PublishTaskContext(PublishTask, IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 的构造方法
constructor
PublishTaskDispatcherImpl - com.trs.components.common.publish.domain.taskdispatch 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
the publish task dispatcher implementation.
PublishTaskDispatcherImpl() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 的构造方法
constructor: default
PublishTaskDocumentsCacheMgr - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM指定Folder文档集合在一次发布任务中的缓冲对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishTaskDocumentsCacheMgr() - 类 com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr 的构造方法
PublishTaskLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
发布日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
PublishTaskLogger() - 类 com.trs.ajaxservice.logger.PublishTaskLogger 的构造方法
PublishTaskMgrImpl - com.trs.components.common.publish.domain.taskdispatch 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IPublishTaskMgr
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishTaskMgrImpl() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 的构造方法
constructor: default
PublishTaskRuntime - com.trs.components.common.publish.domain.taskdispatch 中的 类
秒数发布任务的运行时状态
PublishTaskRuntime() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 的构造方法
缺省构造方法
PublishTasks - com.trs.components.common.publish.persistent.taskdispatch 中的 类
PublishTasks(User) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTasks 的构造方法
构造函数
PublishTasks(User, int, int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTasks 的构造方法
构造函数
PublishTaskWorker - com.trs.components.common.publish.domain.taskdispatch 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
worker to execute publish task.
PublishTaskWorker() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 的构造方法
constructor: default
PublishUpdateCommderImpl - com.trs.components.common.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
PublishUpdateCommderImpl() - 类 com.trs.components.common.publish.PublishUpdateCommderImpl 的构造方法
pubSrc - 类 com.trs.cms.content.ImgRec 中的变量
pushTask(PublishTask) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
push a publish task into the queue
pushTask(PublishTask) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
pushTask(PublishTask) - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法
put(IPublishFolder, WCMFilter, Documents) - 接口 com.trs.components.wcm.publish.tagparser.IPublishTaskDocumentsCacheMgr 中的方法
将Folder根据Filter获取到的Documents缓存起来
put(IPublishFolder, WCMFilter, Documents) - 类 com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr 中的方法
put(int, int, String) - 类 com.trs.infra.util.database.TypeNames 中的方法
set a type name for specified type key and capacity
put(int, String) - 类 com.trs.infra.util.database.TypeNames 中的方法
set a default type name for specified type key
put(String, TypeInfo) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfoMap 中的静态方法
putAbsoluteAppFileName(String, String) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
设置附件名和附件地址的映射关系
putAttributeValue(String, String) - 类 com.trs.infra.util.AttributesString 中的方法
设置指定名称的属性值
putAttributeValue(String, String, boolean) - 类 com.trs.infra.util.AttributesString 中的方法
putContextCacheData(Map) - 类 com.trs.webframework.context.MethodContext 中的方法
将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用
putContextCacheData(Object, Object) - 类 com.trs.webframework.context.MethodContext 中的方法
将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用
putContextCacheData(Map) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用
putContextCacheData(Object, Object) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
将当前方法执行过程中需要的对象缓存起来，以便供其它方法使用
putDistribution(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionList 中的方法
向列表中增加或者替换列表中的分发点设置
putElement(HtmlElement) - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法
在Html文本内容的当前位置，插入元素的内容
putEmploy(TemplateEmploy) - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
putEmploy(int, int, Template, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
putFieldInfo(String, FieldInfo) - 类 com.trs.infra.util.database.TableInfo 中的方法
在数据表字段信息集合中存入字段信息
putHTML(String) - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法
在Html文本内容的当前位置，插入HTML内容
putInCache(String, Object) - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
putInfoViewTemplateInfoOnePath(String) - 类 com.trs.ajaxservice.InfoviewService 中的方法
putLinkMap(String, String) - 类 com.trs.infra.util.html.ContentLinkReplacer 中的方法
putLinkMap(String, String, String) - 类 com.trs.infra.util.html.ContentLinkReplacer 中的方法
装入一个链接的映射项
备注：如果要考虑大小写的区分/不区分，请在装入时统一转化为大写/小写
putMediaRemindedInfoInCache(MediaRemindedInfo) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
将媒体提醒信息加入缓冲中
putNextEntry(ZipEntry) - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
Starts a new Zip entry.
putParam(String, String) - 类 com.trs.components.common.job.JobWorkerType 中的方法
putPathConfig(Config, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
装载指定目录配置信息 //why@2002-04-24
putPathConfig(String, String, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
putPathConfig(String, PathConfig, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
载入指定目录配置信息
putSession(Integer, HttpSession) - 类 com.trs.presentation.util.LoginHelper 中的静态方法
保存Session
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Q - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Q

QUATER - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日期/时间的各个部分标识：一刻钟（11）
query(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.DistributeServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.DocumentSynServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.GroupServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.IndividuationServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.InfoViewDocumentServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.ReplaceContentServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.SourceServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.StatusServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceHelperProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
获取指定站点或者指定频道下的文档
query(MethodContext) - 类 com.trs.ajaxservice.WatermarkServiceProvider 中的方法
query(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
query(PageStyle, WCMFilter) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
query(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
获取内容风格集合
query(PageStyle, WCMFilter) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
在指定PageStyle下获取ContentStyle集合
query(User, WCMFilter) - 接口 com.trs.components.common.publish.widget.ILayoutMgr 中的方法
查询布局
query(MethodContext) - 接口 com.trs.components.common.publish.widget.ILayoutServiceProvider 中的方法
query(User, WCMFilter) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
查询系统指定母版
query(WCMFilter) - 接口 com.trs.components.common.publish.widget.IPageStyleMgr 中的方法
获取页面风格集合
query(PageStyle, WCMFilter) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
获取指定页面风格下的ResourceStyle集合
query(User, WCMFilter) - 接口 com.trs.components.common.publish.widget.IWidgetMgr 中的方法
获取资源
query(User, WCMFilter) - 接口 com.trs.components.common.publish.widget.IWidgetParameterMgr 中的方法
获取某资源所具有的资源变量
query(Widget) - 接口 com.trs.components.common.publish.widget.IWidgetParameterMgr 中的方法
获取资源的所有资源变量
query(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetParameterServiceProvider 中的方法
获取资源变量对象集
query(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetServiceProvider 中的方法
获取资源片段集
query(User, WCMFilter) - 类 com.trs.components.common.publish.widget.LayoutMgr 中的方法
通过条件查询布局
query(MethodContext) - 类 com.trs.components.common.publish.widget.LayoutServiceProvider 中的方法
查询布局
query(User, WCMFilter) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
查询系统指定的母板
query(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
查询母板
query(WCMFilter) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
获取PageStyle集合
query(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
根据指定的条件获取页面风格集合
query(PageStyle, WCMFilter) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
query(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
获取资源风格集合
query(WCMFilter) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
获取风格元素集合
query(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
query(User, WCMFilter) - 类 com.trs.components.common.publish.widget.WidgetMgr 中的方法
query(User, WCMFilter) - 类 com.trs.components.common.publish.widget.WidgetParameterMgr 中的方法
query(Widget) - 类 com.trs.components.common.publish.widget.WidgetParameterMgr 中的方法
query(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 中的方法
query(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 中的方法
query(User, WCMFilter) - 接口 com.trs.components.special.ISpecialMgr 中的方法
查询符合当前条件的专题
query(MethodContext) - 接口 com.trs.components.special.ISpecialServiceProvider 中的方法
获取符合条件的专题
query(User, WCMFilter) - 类 com.trs.components.special.SpecialMgr 中的方法
query(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法
query(User, WCMFilter) - 类 com.trs.components.stat.BonusRuleMgr 中的方法
查询系统指定奖励规则
query(MethodContext) - 类 com.trs.components.stat.BonusRuleServiceProvider 中的方法
query(User, WCMFilter) - 接口 com.trs.components.stat.IBonusRuleMgr 中的方法
查询系统指定奖励规则
query(User, WCMFilter) - 接口 com.trs.components.stat.IUserLoginInfoMgr 中的方法
query(User, WCMFilter) - 类 com.trs.components.stat.UserLoginInfoMgr 中的方法
查询指定条件下的用户登录信息
query(MethodContext) - 类 com.trs.components.stat.UserLoginInfoServiceProvider 中的方法
查询指定条件的记录。
query(MethodContext) - 类 com.trs.components.wcm.publish.region.CellServiceProvider 中的方法
query(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionEmployServiceProvider 中的方法
query(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionServiceProvider 中的方法
query(MethodContext) - 类 com.trs.webframework.demo.StdDemoProviderImpl 中的方法
query(MethodContext) - 类 com.trs.webframework.provider.BaseServiceDecorator 中的方法
query(MethodContext) - 接口 com.trs.webframework.provider.IQueryServiceProvider 中的方法
QUERY - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量
QUERY_ACCORD_DOCUMENT_RIGHT - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态变量
QUERY_ACCORD_DOCUMENT_RIGHT - 类 com.trs.components.wcm.content.ViewDocuments 中的静态变量
QUERY_CHANNEL_CHILDINDEX_QUOTE - 类 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer 中的静态变量
queryAppendixes(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法
获取指定文档版本指定类型的附件
queryAppendixes(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
获取指定文档指定类型的附件
queryAppendixes(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
获取指定文档指定类型的附件
queryArgs(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
queryArgs
queryChannelUsableInfoviews(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
queryChildren(User, ClassInfo, WCMFilter) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
queryChildren(User, ClassInfo, WCMFilter) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
queryChildrenWithAllLevel(User, ClassInfo, WCMFilter) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列,以逗号分隔
queryChildrenWithAllLevel(User, ClassInfo, WCMFilter, char) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
得到满足条件的当前分类的所有子分类，包括子孙分类的Ids序列
queryChildrenWithAllLevel(User, int, WCMFilter) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
queryChildrenWithAllLevel(User, ClassInfo, WCMFilter) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
得到满足条件的当前分类的所有子分类，包括子孙分类Ids
queryChildrenWithAllLevel(User, int, WCMFilter) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
queryChildrenWithAllLevel(User, ClassInfo, WCMFilter, char) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
queryChildrenWithFirstLevel(User, ClassInfo, WCMFilter) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
得到满足条件的当前分类的一级子分类的Ids
queryChildrenWithFirstLevel(User, ClassInfo, WCMFilter, char) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
queryChildrenWithFirstLevel(User, ClassInfo, WCMFilter) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
得到满足条件的当前分类的一级子分类的Ids
queryChildrenWithFirstLevel(User, ClassInfo, WCMFilter, char) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
queryClassInfos(User, Document, WCMFilter) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
根据文档对象获取获取分类法信息集合
queryClassInfos(User, Documents, WCMFilter) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
queryClassInfos(User, Document, WCMFilter) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
根据文档对象获取获取分类法信息集合
queryClassInfos(User, Documents, WCMFilter) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
根据文档对象集合获取获取分类法信息集合
queryClassInfos(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
获取指定的分类
queryClassInfos(User, int, WCMFilter) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
queryClassInfos(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
获取指定的分类
queryClassInfos(User, int, WCMFilter) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
queryClassInfos(User, String, WCMFilter) - 类 com.trs.components.metadata.service.ClassInfoViewService 中的方法
根据分类法信息返回视图对象集合
queryClassInfos(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
根据文档的ids，获取在指定分类下的文档所在分类
queryClassInfos1(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
queryClassInfosUsingMetaView(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
获取系统所有使用了视图或指定视图的分类法树根
queryContenetStyles(PageStyle) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
获取指定系统风格下的内容可用风格集合
queryContenetStyles(PageStyle) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
获取指定系统风格下的内容可用风格集合
queryContentStyles(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
获取指定系统风格下的内容可用风格集合
queryCustomSite(MethodContext) - 类 com.trs.ajaxservice.IndividuationServiceProvider 中的方法
queryData(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
queryData(MethodContext) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryData(RequestHelper) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryData2(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
queryData3(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
queryDataXML(MethodContext) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryDataXML(RequestHelper) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryDataXML2(MethodContext) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryDataXML2(RequestHelper) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryDataXML3(MethodContext) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryDataXML3(RequestHelper) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryDBFieldInfos(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
查询指定表的字段集合
queryDBTableInfos(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
queryDocNumMapping(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
queryDocNumMapping2(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
获取分类法和文档数目的一个隐射
QueryDocumentCenter - com.trs.components.wcm.content 中的 类
QueryDocumentCenter() - 类 com.trs.components.wcm.content.QueryDocumentCenter 的构造方法
queryDocumentNum(User, ClassInfo) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
根据分类法对象返回相应的文档数目
queryDocumentNum(User, ClassInfo, WCMFilter) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
queryDocumentNum(User, ClassInfo) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
根据分类法对象返回相应的文档数目
queryDocumentNum(User, ClassInfo, WCMFilter) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
queryDocuments(MethodContext) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryDocuments(RequestHelper) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
queryDocuments(User, ClassInfo, WCMFilter) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
根据分类法对象得到相应的文档集合对象
queryDocuments(User, ClassInfos, WCMFilter) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
根据分类法集合对象得到相应的文档集合对象
queryDocuments(User, ClassInfos, WCMFilter) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
根据分类法集合对象得到相应的文档集合对象
queryDocuments(User, ClassInfo, WCMFilter) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
根据分类法对象得到相应的文档集合对象
queryDocuments(User, String, WCMFilter, boolean) - 类 com.trs.components.metadata.service.ClassInfoViewService 中的方法
根据传入的分类法对象获取文档集合对象
queryDocuments(User, String, WCMFilter) - 类 com.trs.components.metadata.service.ClassInfoViewService 中的方法
根据传入的分类法对象获取文档集合对象
queryDocuments(User, String, String, boolean) - 类 com.trs.components.metadata.service.ClassInfoViewService 中的方法
根据分类法的id序列和viewId得到文档集合对象
queryDocuments(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
queryDocumentsForUser(User, BaseChannel, String, int, int, boolean, WCMFilter) - 类 com.trs.components.wcm.content.QueryDocumentCenter 中的静态方法
queryDocumentsForUser(User, int, String, int, int) - 类 com.trs.components.wcm.content.QueryDocumentCenter 中的静态方法
queryDocumentsOfCurrPage(WCMFilter, String, int, int) - 类 com.trs.components.wcm.content.QueryDocumentCenter 中的静态方法
queryDocumentStatuses(MethodContext) - 类 com.trs.ajaxservice.StatusServiceProvider 中的方法
获取当前用户在指定频道下可以改变状态
queryEmployers(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
获取使用指定模板的对象
queryExtendFields(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法
获取文档的扩展字段信息
queryExtendFields(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
获取文档的扩展字段信息
queryExtendFields(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
获取系统配置的物理字段
queryExtendFields(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
获取文档的扩展字段信息
QueryFilter - com.trs.infra.db 中的 类
QueryFilter() - 类 com.trs.infra.db.QueryFilter 的构造方法
QueryFilter(QueryFilter) - 类 com.trs.infra.db.QueryFilter 的构造方法
QueryFilter(String, String, String) - 类 com.trs.infra.db.QueryFilter 的构造方法
QueryFilter(String, String, String, String) - 类 com.trs.infra.db.QueryFilter 的构造方法
过滤器构造函数
QueryFilter(String, String, String, String, String) - 类 com.trs.infra.db.QueryFilter 的构造方法
QueryFilter(String, String, String, String, int) - 类 com.trs.infra.db.QueryFilter 的构造方法
QueryFilterFactory - com.trs.components.filter 中的 类
QueryFlowDocContext - com.trs.cms.process 中的 类
QueryFlowDocContext() - 类 com.trs.cms.process.QueryFlowDocContext 的构造方法
queryFlowInfoviews(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
queryForGroup(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
queryLinkType(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
queryMasterByContentType(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
获取指定类型文件不为空的母版集合
queryMembersOfObject(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法
返回对指定对象可见可操作的所有成员
queryMetaViewDatas(MetaView, ClassInfos, boolean, WCMFilter) - 类 com.trs.components.metadata.center.ClassDocumentsHelper 中的静态方法
获取指定视图中同时属于指定的多个分类（含下面的子分类）的文档 子分类仅仅只叶子节点
queryNestedTemplates(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
获取使用指定模板使用了那些嵌套模板
queryObjectsCountOfClassInfo(MetaView, ClassInfo, WCMFilter) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
queryObjectsCountOfClassInfo(MetaView, ClassInfo, WCMFilter) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
queryObjectsCountOfClassInfo(MetaView, ClassInfo, WCMFilter) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
queryObjectsCountOfView(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
queryObjectsCountOfView(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
queryObjectsCountOfView(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
根据传入的分类法获取分类法和文档数目的一个隐射； 如果传入了classInfoIds，则获取指定classInfoIds的每个分类法的文档数； 否则如果传入了classInfoId，则获取classInfoId下每个子分类法的文档数； 如果没有传入任何参数，则获取所有根节点下的文档数，并同时返回文档总数。
queryObjectsOfMember(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法
返回指定成员的所有可见可操作的对象
queryObjectsOfView(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
queryObjectsOfView(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
queryObjectsOfView(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
queryOptionalFlows(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
queryPageOtherStyleItemMap(PageStyle, WCMFilter) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
获取页面其他风格样式项
queryPageOtherStyleItemMap(PageStyle, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
获取页面其他风格样式项
queryPageOtherStyleItems(PageStyle, WCMFilter) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
获取页面其他风格样式项
queryPageOtherStyleItems(PageStyle, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
获取页面其他风格样式项
queryPageStyles(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
获取系统所有可供选择的系统风格
queryRecycle(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
获取回收站文档
queryRecycle(MethodContext) - 类 com.trs.ajaxservice.InfoViewDocumentServiceProvider 中的方法
获取指定站点或者指定频道回收站下的文档
queryRecycle(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
queryRecycle(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
获取指定站点或者指定频道回收站下的文档
queryRelations(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法
获取指定文档手工设定的相关文档
queryRelations(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
获取指定文档手工设定的相关文档
queryRelations(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
获取指定文档手工设定的相关文档
queryResourceStyles(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
获取指定页面风格下的资源可用风格集合
querySearchFields(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
queryStyleItemMap(BaseStyle, WCMFilter) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
获取指定风格的风格项
queryStyleItemMap(BaseStyle, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
获取指定风格的风格项
queryStyleItemMap(MethodContext) - 类 com.trs.components.common.publish.widget.StyleItemServiceProvider 中的方法
获取指定风格对应的风格项集合
queryStyleItems(BaseStyle, WCMFilter) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
获取某种（页面风格，资源可用风格，内容可用风格）风格下的StyleItem集合
queryStyleItems(BaseStyle, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
获取指定风格的风格项
queryStyleItems(MethodContext) - 类 com.trs.components.common.publish.widget.StyleItemServiceProvider 中的方法
获取指定风格对应的风格项集合
querySysLinks(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
queryTargetTypes() - 类 com.trs.ajaxservice.DistributeServiceProvider 中的方法
获取系统支持的分发目标类型
queryTemplatesNested(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
获取使用指定嵌套模板的模板
queryTypes(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
queryUploadImageFileList(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
获取指定页面风格下的所有上传的图片名称，图片名称放到一个ArrayList中
queryViewDatas(User, ClassInfo, MetaView) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
queryViewDatas(User, ClassInfo, MetaView) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
获取指定视图指定分类法下的数据集合
queryViewDatas(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
获取指定视图的数据
queryViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
获取指定视图的数据
queryViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
获取指定视图的数据
queryViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
获取指定视图的数据
queryViewDatasNoView(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
queryViewFieldInfos(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
queryViews(User, ClassInfos, WCMFilter) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
根据分类法集合对象返回相应的视图对象集合
queryViews(User, ClassInfos, WCMFilter) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
根据分类法ID序列返回视图对象集合
queryViews(User, String, WCMFilter, boolean) - 类 com.trs.components.metadata.service.ClassInfoViewService 中的方法
根据分类法信息返回视图对象集合
queryViews(User, String, WCMFilter) - 类 com.trs.components.metadata.service.ClassInfoViewService 中的方法
根据分类法信息返回视图对象集合
queryViews(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
根据分类法信息获取视图信息
queryViews(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
获取系统所有视图
queryViewsByClassInfo(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 中的方法
获取使用了指定分类法的视图信息,如果分类法ID为0，则表示获取使用了分类法字段的所有视图
queryViewsUsingClassInfo(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
获取系统所有使用了分类法字段或指定分类法字段视图
queryViewsUsintTable(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
获取正在使用指定表的视图列表
quote(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
引用文档
quote(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
引用文档到...
quote(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
引用文档
QUOTE_FAMILYINDEX_MIN - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
child index minimum value
QUOTE_FAMILYINDEX_PARENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
child index value when the quoted folder is the parent of current folder
QUOTE_FAMILYINDEX_SELF - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
child index value when the quoted folder is its self
QUOTE_TYPE_ANY - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
template quote type: any
QUOTE_TYPE_CONTENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
template quote type: using content information
QUOTE_TYPE_FOLDER - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
template quote type: using folder infomation
quoteImages(int, String) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
保存指定文档引用图片的关系
quoteImages(int, String) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
quoteTo(Document, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
将实体文档引用转发到另一个频道
草稿箱中的文档无法转发
目标频道为空无法转发
quoteTo(Document, Channel, String) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
quoteTo(Document, String) - 接口 com.trs.service.IDocumentService 中的方法
维护单篇文档的引用转发关系
将单篇文档引用转发到目标频道列表中
一般用于在文档采编页面中，设置一篇文档的引用转发
这里的维护中包括删除所有无用的引用转发关系
quoteTo(String, int, String) - 接口 com.trs.service.IDocumentService 中的方法
将一组文档转发（引用转发）到多个目标频道下
一般这样的操作是在文档列表页面执行的
quoteTo(String, String) - 接口 com.trs.service.IDocumentService 中的方法
引用转发频道文档集合
将一堆频道文档移动到某个频道 一堆文档可以是一个检索的结果
quoteTo(Document, String) - 类 com.trs.service.impl.DocumentService 中的方法
quoteTo(String, int, String) - 类 com.trs.service.impl.DocumentService 中的方法
quoteTo(String, String) - 类 com.trs.service.impl.DocumentService 中的方法
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


R - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

R

RadarTreeCreator - com.trs.presentation.nav 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
为雷达/NetSnap提供站点/栏目树.
RadarTreeCreator(String, int, String, int) - 类 com.trs.presentation.nav.RadarTreeCreator 的构造方法
raiseImage(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
raiseImage(int, int, boolean) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
突起效果
raiseImage(int, int, boolean) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
raiseImg(ImageMagickCmd.ImageObj, int, int, boolean) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法
RANGE_ADMINISTRATOR - 类 com.trs.cms.auth.persistent.Role 中的静态变量
仅对管理员可见的角色
RANGE_ALL - 类 com.trs.cms.auth.persistent.Role 中的静态变量
对所有组织都可见的角色
RANGE_DEFAULT - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量
RANGE_GROUP - 类 com.trs.cms.auth.persistent.Role 中的静态变量
仅对部分组织可见的角色
RANGE_HIT - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量
RANGE_TIME - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量
RASDecrypt(String) - 类 com.trs.infra.util.CMyEncrypt 中的静态方法
RASEncrypt(String) - 类 com.trs.infra.util.CMyEncrypt 中的静态方法
RATE_OF_FIELD_LENGTH - 类 com.trs.components.infoview.db.InfoViewDBMgr 中的静态变量
RATIO_FIXED_WIDTH - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
布局固定比宽度单位
RATIO_PERCENTAGE_WIDTH - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
布局百分比单位
RATIO_SEPERATE - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
布局比例值间隔字符
RATIO_TYPE_FIXED - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
布局比例类型，固定比
RATIO_TYPE_PERCENTAGE - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
布局比例类型，百分比
RAW - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：RAW
read(String) - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态方法
read a tag document from the specified content.
read() - 类 com.trs.infra.util.BASE64DecoderStream 中的方法
read(byte[], int, int) - 类 com.trs.infra.util.BASE64DecoderStream 中的方法
read() - 类 com.trs.infra.util.jazzlib.CheckedInputStream 中的方法
Reads one byte, updates the checksum and returns the read byte (or -1 when the end of file was reached).
read(byte[], int, int) - 类 com.trs.infra.util.jazzlib.CheckedInputStream 中的方法
Reads at most len bytes in the supplied buffer and updates the checksum with it.
read(byte[], int, int) - 类 com.trs.infra.util.jazzlib.GZIPInputStream 中的方法
Reads uncompressed data into an array of bytes
read() - 类 com.trs.infra.util.jazzlib.InflaterInputStream 中的方法
Reads one byte of decompressed data.
read(byte[], int, int) - 类 com.trs.infra.util.jazzlib.InflaterInputStream 中的方法
Decompresses data into the byte array
read() - 类 com.trs.infra.util.jazzlib.ZipInputStream 中的方法
Reads a byte from the current zip entry.
read(byte[], int, int) - 类 com.trs.infra.util.jazzlib.ZipInputStream 中的方法
Reads a block of bytes from the current zip entry.
read() - 类 com.trs.infra.util.XmlCharCheckedInputStream 中的方法
read() - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 中的方法
readBytesFromFile(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
readChnlDocPropertyFromRs(ResultSet, ResultSetMetaData) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
readChnlDocPropertyFromRs(ResultSet, ResultSetMetaData) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
readFile(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
读取文件的内容，返回字符串类型的文件内容
readFile(String, String) - 类 com.trs.infra.util.CMyFile 中的静态方法
读取文件的内容，返回字符串类型的文件内容
readFile(String, String) - 类 com.trs.tools.WCM61AutoList 中的静态方法
readFromInputStream(InputStream) - 类 com.trs.webframework.xmlserver.parser.StreamBuddy 中的静态方法
readFromRs(ResultSet, ResultSetMetaData) - 类 com.trs.infra.persistent.BaseObj 中的方法
从记录集当前行读取对象信息 注意：（1）ResultSet的列序号从1开始 （2）Hashtable.put(key,value)函数中，要求value!
readFromRs(ResultSet, ResultSetMetaData, String) - 类 com.trs.infra.persistent.BaseObj 中的方法
readFromRs(ResultSet, String) - 类 com.trs.infra.util.database.CDBText 中的方法
从数据库中读取Clob/Text型字段的值
readFromRs(ResultSet, int) - 类 com.trs.infra.util.database.CDBText 中的方法
从数据库中读取Clob/Text型字段的值
REAL - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：REAL
REAL - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：REAL
REAL - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：REAL
REAL - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：REAL
REAL - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：REAL
REAL - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：REAL
realParameters2QueryString() - 类 com.trs.presentation.util.RequestHelper 中的方法
将参数以URL参数信息方式输出
rebuild(Document) - 类 com.trs.components.infoview.extract.XSLTViewConstrainter 中的方法
rebuildAllInfoViews(MethodContext) - 类 com.trs.ajaxservice.InfoviewDataToolService 中的方法
为系统所有视图创建表结构
rebuildXSLT(InfoView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
rebuildXSLT(InfoView) - 接口 com.trs.service.IInfoViewService 中的方法
rebuildXSLT(InfoView) - 类 com.trs.service.impl.InfoViewService 中的方法
rebuildXSLTByFields(InfoView, List) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
rebuildXSLTByFields(InfoView, List) - 接口 com.trs.service.IInfoViewService 中的方法
rebuildXSLTByFields(InfoView, List) - 类 com.trs.service.impl.InfoViewService 中的方法
rebuildXSLTByGroups(InfoView, List) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
receive(int, int, int) - 类 com.trs.cluster.ClusterMsgCenterImpl 中的方法
receive(int, int, int, Hashtable) - 类 com.trs.cluster.ClusterMsgCenterImpl 中的方法
receive(String, String[]) - 类 com.trs.cluster.ClusterMsgCenterImpl 中的方法
receive(int, int, int) - 接口 com.trs.cluster.IClusterMsgCenter 中的方法
响应基于持久化对象拟定的消息
receive(int, int, int, Hashtable) - 接口 com.trs.cluster.IClusterMsgCenter 中的方法
响应基于持久化对象拟定的消息
receive(String, String[]) - 接口 com.trs.cluster.IClusterMsgCenter 中的方法
响应自定义协议的消息
receive(BaseObj, int) - 接口 com.trs.cluster.IClusterMsgReceiver 中的方法
响应基于持久化对象拟定的消息
receive(String, String[]) - 接口 com.trs.cluster.IClusterMsgReceiver 中的方法
响应自定义协议的消息
receive(BaseObj, int) - 类 com.trs.cluster.receiver.DBMsgReceiver 中的方法
receive(String, String[]) - 类 com.trs.cluster.receiver.DBMsgReceiver 中的方法
receive(BaseObj, int) - 类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 中的方法
receive(String, String[]) - 类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 中的方法
receive(BaseObj, int) - 类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 中的方法
receive(String, String[]) - 类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 中的方法
receive(BaseObj, int) - 类 com.trs.cluster.receiver.ObjectLCMsgReceiver 中的方法
receive(String, String[]) - 类 com.trs.cluster.receiver.ObjectLCMsgReceiver 中的方法
receive(BaseObj, int) - 类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 中的方法
receive(String, String[]) - 类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 中的方法
receive(BaseObj, int) - 类 com.trs.cluster.receiver.TableInfosMsgReceiver 中的方法
receive(String, String[]) - 类 com.trs.cluster.receiver.TableInfosMsgReceiver 中的方法
receive(BaseObj, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 中的方法
receive(String, String[]) - 类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 中的方法
receive(BaseObj, int) - 类 com.trs.components.stat.ChnlDeptMgrForCluster 中的方法
receive(String, String[]) - 类 com.trs.components.stat.ChnlDeptMgrForCluster 中的方法
receiveFileByBase64(String, String, String) - 类 com.trs.components.wcm.soap.WordFileService 中的静态方法
通过Base64编码的方式接收数据
receiveFileByBytes(byte[], String, String) - 类 com.trs.components.wcm.soap.WordFileService 中的静态方法
通过Bytes方式接收数据
Recent - com.trs.components.wcm.recent 中的 类
Recent() - 类 com.trs.components.wcm.recent.Recent 的构造方法
构造函数：保留默认接口
RecentMgr - com.trs.components.wcm.recent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
“我最近访问”的对象的平台管理层
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RecentMgr() - 类 com.trs.components.wcm.recent.RecentMgr 的构造方法
Recents - com.trs.components.wcm.recent 中的 类
Recents(User) - 类 com.trs.components.wcm.recent.Recents 的构造方法
构造函数
Recents(User, int, int) - 类 com.trs.components.wcm.recent.Recents 的构造方法
构造函数
RecentService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
为“最近处理的对象” 提供的服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RecentService() - 类 com.trs.service.impl.RecentService 的构造方法
reConnectTRS() - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的静态方法
recordBrowserLog(MethodContext) - 类 com.trsothers.LogServiceProvider 中的方法
记录客户端框架发过来的异常
recordDocumentQuoteImage(int, int) - 接口 com.trs.wcm.photo.IImageLibMgr 中的方法
记录文档和指定图片的引用关系
recordDocumentQuoteImage(int, int) - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 中的方法
recordSendLogs(String, int) - 类 com.trs.infra.util.email.CMyMailLog 中的方法
根据类型，记录邮件日志
recover(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法
恢复文档的版本
recoverDocument(DocBak, Document) - 类 com.trs.components.wcm.content.domain.DocBakMgr 中的方法
恢复当前文档的数据到某个(备份)版本
recoverDocument(DocBak, Document) - 接口 com.trs.service.IDocumentService 中的方法
从文档备份版本中恢复文档
recoverDocument(DocBak, Document) - 类 com.trs.service.impl.DocumentService 中的方法
recreateAll(User, MetaDBTables) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
重新产生所有的表结构和相关视图的应用
recreateAll(User, MetaDBTables) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
recreateAllOfDBTableInfo(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
RecycleClearLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
回收站清空日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
RecycleClearLogger() - 类 com.trs.ajaxservice.logger.RecycleClearLogger 的构造方法
RedirectObject - com.trs.webframework.entity 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RedirectObject() - 类 com.trs.webframework.entity.RedirectObject 的构造方法
RedirectObject(String, String) - 类 com.trs.webframework.entity.RedirectObject 的构造方法
redistributeAppendixes(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
重新分发模板的附件
redistributeAppendixes(IPublishFolder, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
重新分发指定站点或者频道下的所有模板的附件，并且如果 _zRecursive 为 true ，则会进一步地重新分发子频道下的模板的附件。
redistributeAppendixes(Templates) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
重新分发模板的所有附件
redistributeAppendixes(CMSObj, boolean) - 类 com.trs.service.impl.TemplateService 中的方法
redistributeAppendixes(CMSObj, boolean) - 接口 com.trs.service.ITemplateService 中的方法
重新分发指定站点或者频道下的所有模板的附件，并且如果_zRecursive 为true ，则会进一步地重新分发子频道下的模板的附件。
redoTask(PublishTask) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
re-start a publish task
redoTask(PublishTasks) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
re-execute each publish task in the collection
redoTasks(String) - 类 com.trs.service.impl.PublishService 中的方法
redoTasks(String) - 接口 com.trs.service.IPublishService 中的方法
重新执行指定的发布任务集合
REFERENCE_XML - 类 com.trs.components.wcm.content.domain.DocumentExporter 中的静态变量
reform(int) - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法
重构所有的的XSLT文件
reformTemplateXml() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法
重构所有的的Template.xml文件
refresh() - 类 com.trs.components.common.message.notify.NotificationServer 中的方法
refresh the server configuration.
refresh() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的方法
load and refresh the configuration from XML file.
refresh() - 类 com.trs.components.common.publish.domain.tagparser.TagFormatHelper 中的方法
Refreshs the tag formatters config.
refresh() - 类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 中的方法
Refreshs the cache in factory.
refresh() - 类 com.trs.infra.BaseConfig 中的方法
refresh() - 类 com.trs.infra.config.domain.ConfigFilesFinder 中的方法
刷新
refresh() - 类 com.trs.infra.persistent.BaseObjs 中的方法
刷新函数：用以重新执行过滤函数，刷新对象集
refresh() - 类 com.trs.infra.persistent.CMyResultObjs 中的方法
刷新函数：用以重新执行过滤函数，刷新对象集 由于处理机制与缓冲集合不一样需重载父类的接口
refreshPathConfig(Config) - 类 com.trs.infra.support.file.FilesMan 中的方法
刷新目录配置缓冲
refreshProperty(String, Object) - 类 com.trs.infra.persistent.BaseObj 中的方法
刷新对象指定属性值 //why:2002-04-01 为保持对象和数据库一致性 注意：不同类型的属性，必须使用相应匹配的对象作为属性值 说明：刷新是指更新对象在数据库中的存储值，与更改对象属性值不同 说明：不检测锁定；要求非新增模式使用（暂未检测）
refreshProperty(String, Object, boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法
refreshProperty(String, long) - 类 com.trs.infra.persistent.BaseObj 中的方法
refreshProperty(String, boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法
refreshProperty(BaseObj) - 类 com.trs.infra.persistent.BaseObj 中的方法
RefreshPropertyMsgReceiver - com.trs.cluster.receiver 中的 类
RefreshPropertyMsgReceiver() - 类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 的构造方法
refuse(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
拒绝请求
refuse(FlowContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法
refuse(FlowContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
拒绝
REG_REMOVE_COMMENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
RegFromConfig - com.trs.presentation.ids 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RegFromConfig() - 类 com.trs.presentation.ids.RegFromConfig 的构造方法
RegionCellInfoLogger - com.trs.components.wcm.logger 中的 类
RegionCellInfoLogger() - 类 com.trs.components.wcm.logger.RegionCellInfoLogger 的构造方法
RegionEmploy - com.trs.components.wcm.publish.region 中的 类
RegionEmploy() - 类 com.trs.components.wcm.publish.region.RegionEmploy 的构造方法
构造函数：保留默认接口
RegionEmployMgr - com.trs.components.wcm.publish.region 中的 类
RegionEmployMgr() - 类 com.trs.components.wcm.publish.region.RegionEmployMgr 的构造方法
RegionEmploys - com.trs.components.wcm.publish.region 中的 类
RegionEmploys(User) - 类 com.trs.components.wcm.publish.region.RegionEmploys 的构造方法
构造函数
RegionEmploys(User, int, int) - 类 com.trs.components.wcm.publish.region.RegionEmploys 的构造方法
构造函数
RegionEmployServiceProvider - com.trs.components.wcm.publish.region 中的 类
RegionEmployServiceProvider() - 类 com.trs.components.wcm.publish.region.RegionEmployServiceProvider 的构造方法
RegionInfo - com.trs.components.wcm.publish.region 中的 类
RegionInfo() - 类 com.trs.components.wcm.publish.region.RegionInfo 的构造方法
构造函数：保留默认接口
RegionInfoLogger - com.trs.components.wcm.logger 中的 类
RegionInfoLogger() - 类 com.trs.components.wcm.logger.RegionInfoLogger 的构造方法
RegionInfos - com.trs.components.wcm.publish.region 中的 类
RegionInfos(User) - 类 com.trs.components.wcm.publish.region.RegionInfos 的构造方法
构造函数
RegionInfos(User, int, int) - 类 com.trs.components.wcm.publish.region.RegionInfos 的构造方法
构造函数
RegionServiceProvider - com.trs.components.wcm.publish.region 中的 类
RegionServiceProvider() - 类 com.trs.components.wcm.publish.region.RegionServiceProvider 的构造方法
register(String) - 类 com.trs.cms.ObjectTypeServer 中的方法
register(Class) - 类 com.trs.cms.ObjectTypeServer 中的静态方法
register(int, String) - 类 com.trs.cms.ObjectTypeServer 中的静态方法
register(int, Class) - 类 com.trs.cms.ObjectTypeServer 中的静态方法
register(Integer, Class) - 类 com.trs.cms.ObjectTypeServer 中的静态方法
register(int, Class) - 接口 com.trs.components.filter.IQueryFilterFactory 中的方法
注册查询过滤器
register(int, Class) - 类 com.trs.components.filter.QueryFilterFactory 中的方法
register(int, Class) - 类 com.trs.components.metadata.web.HTMLMakerFactory 中的静态方法
注册视图字段HTMLMaker
register(String, int) - 类 com.trs.infra.util.NamesRegister 中的方法
Registers a name with the specified id
registerCalendar(String, Calendar) - 类 com.trs.infra.util.job.JobScheduler 中的方法
registerContent(int, Class) - 类 com.trs.cms.process.engine.FlowContentHelper 中的静态方法
registerConverter(Object) - 类 com.trs.components.metadata.service.domain.MetaViewEmplyerConverterForChannelImporter 中的方法
registerConverter(Object) - 接口 com.trs.components.wcm.content.domain.IChannelImporterConverter 中的方法
registerConverter(Object) - 接口 com.trs.components.wcm.content.domain.IDocumentImporterConverter 中的方法
registerConverter(Object) - 类 com.trs.components.wcm.process.service.domain.FlowConverterForWebsiteImporter 中的方法
registerConvertor(String, String) - 类 com.trs.webframework.xmlserver.XMLConvertorFactory 中的静态方法
为特定的对象[_sTargetClassName]注册一个Convertor
registerConvertor(IXMLConvertor, String) - 类 com.trs.webframework.xmlserver.XMLConvertorFactory 中的静态方法
RegisterDemo() - 类 com.trs.infra.util.key.CRegister 中的静态方法
registerDocumentFieldsSyn(String, String) - 类 com.trs.components.metadata.center.DocumentFieldsSynFactory 中的静态方法
注册和元数据关联处理的IDocumentFieldsSyn对象
registerDocumentFieldsSyn(String, Class) - 类 com.trs.components.metadata.center.DocumentFieldsSynFactory 中的静态方法
注册和元数据关联处理的IDocumentFieldsSyn对象
registerMetaDataType(int, String, String, int, int) - 类 com.trs.components.infoview.db.InfoViewDataTypes 中的方法
注册新的数据类型
registerMetaDataType(int, String, String, int, int) - 类 com.trs.components.metadata.definition.MetaDataTypes 中的方法
注册新的数据类型
registerMoniterMessages() - 接口 com.trs.cluster.IClusterMsgReceiver 中的方法
注册监听的消息内容，采用持久化对象消息协议通信的可以不注册监听的消息内容
registerMoniterMessages() - 类 com.trs.cluster.receiver.DBMsgReceiver 中的方法
registerMoniterMessages() - 类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 中的方法
registerMoniterMessages() - 类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 中的方法
registerMoniterMessages() - 类 com.trs.cluster.receiver.ObjectLCMsgReceiver 中的方法
registerMoniterMessages() - 类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 中的方法
registerMoniterMessages() - 类 com.trs.cluster.receiver.TableInfosMsgReceiver 中的方法
registerMoniterMessages() - 类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 中的方法
registerMoniterMessages() - 类 com.trs.components.stat.ChnlDeptMgrForCluster 中的方法
registerMoniterWCMObjTypesOnAdd() - 接口 com.trs.cluster.IClusterMsgReceiver 中的方法
当新增那些持久化对象时候触发操作
registerMoniterWCMObjTypesOnAdd() - 类 com.trs.cluster.receiver.DBMsgReceiver 中的方法
registerMoniterWCMObjTypesOnAdd() - 类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 中的方法
registerMoniterWCMObjTypesOnAdd() - 类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 中的方法
registerMoniterWCMObjTypesOnAdd() - 类 com.trs.cluster.receiver.ObjectLCMsgReceiver 中的方法
registerMoniterWCMObjTypesOnAdd() - 类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 中的方法
registerMoniterWCMObjTypesOnAdd() - 类 com.trs.cluster.receiver.TableInfosMsgReceiver 中的方法
registerMoniterWCMObjTypesOnAdd() - 类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 中的方法
registerMoniterWCMObjTypesOnAdd() - 类 com.trs.components.stat.ChnlDeptMgrForCluster 中的方法
registerMoniterWCMObjTypesOnDel() - 接口 com.trs.cluster.IClusterMsgReceiver 中的方法
当删除那些持久化对象时候触发操作
registerMoniterWCMObjTypesOnDel() - 类 com.trs.cluster.receiver.DBMsgReceiver 中的方法
registerMoniterWCMObjTypesOnDel() - 类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 中的方法
registerMoniterWCMObjTypesOnDel() - 类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 中的方法
registerMoniterWCMObjTypesOnDel() - 类 com.trs.cluster.receiver.ObjectLCMsgReceiver 中的方法
registerMoniterWCMObjTypesOnDel() - 类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 中的方法
registerMoniterWCMObjTypesOnDel() - 类 com.trs.cluster.receiver.TableInfosMsgReceiver 中的方法
registerMoniterWCMObjTypesOnDel() - 类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 中的方法
registerMoniterWCMObjTypesOnDel() - 类 com.trs.components.stat.ChnlDeptMgrForCluster 中的方法
registerMoniterWCMObjTypesOnModify() - 接口 com.trs.cluster.IClusterMsgReceiver 中的方法
当修改那些持久化对象时候触发操作
registerMoniterWCMObjTypesOnModify() - 类 com.trs.cluster.receiver.DBMsgReceiver 中的方法
registerMoniterWCMObjTypesOnModify() - 类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 中的方法
registerMoniterWCMObjTypesOnModify() - 类 com.trs.cluster.receiver.MetaAppCreateMsgReceiver 中的方法
registerMoniterWCMObjTypesOnModify() - 类 com.trs.cluster.receiver.ObjectLCMsgReceiver 中的方法
registerMoniterWCMObjTypesOnModify() - 类 com.trs.cluster.receiver.RefreshPropertyMsgReceiver 中的方法
registerMoniterWCMObjTypesOnModify() - 类 com.trs.cluster.receiver.TableInfosMsgReceiver 中的方法
registerMoniterWCMObjTypesOnModify() - 类 com.trs.cms.auth.domain.ObjectMemberMgrForCluster 中的方法
registerMoniterWCMObjTypesOnModify() - 类 com.trs.components.stat.ChnlDeptMgrForCluster 中的方法
registerPorterVisitor(IPorterVisitor, String) - 类 com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory 中的静态方法
注册wcm对象导入/导出访问器
registerPorterVisitor(String, String) - 类 com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory 中的静态方法
注册wcm对象导入/导出访问器
registerRelateInfoViews() - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
注册值产生器相关的表单id列表
registerRelateTables() - 接口 com.trs.components.metadata.center.IMetaDataFieldValueCreator 中的方法
注册值产生器相关的物理表列表
registerRelateTables() - 类 com.trs.components.metadata.service.GovInfoIndexCreator 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.AppendixToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ChannelSynToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ChannelToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ChnlDocToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ContentExtFieldToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ContentLink2Xml 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.DataTypeToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.DefaultWCMObjectsToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.DocumentToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ExtFieldToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.FlowContentsToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.FlowDocToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.FlowToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.InfoViewDocumentToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.MessageToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.PageOpertatosToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.RelationToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ReportsToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.TemplateEmployerToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.TemplateToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.ViewDocumentToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.Watermark2Xml 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML 中的方法
registerTargetClassName() - 类 com.trs.ajaxservice.xmlconvertors.WebSiteToXML 中的方法
registerTargetClassName() - 类 com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView 中的方法
registerTargetClassName() - 类 com.trs.components.metadata.service.xmlconvertors.ViewDataToXML 中的方法
registerTargetClassName() - 接口 com.trs.components.wcm.content.service.portervisitors.IPorterVisitor 中的方法
registerTargetClassName() - 类 com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow 中的方法
registerTargetClassName() - 类 com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl 中的方法
registerTargetClassName() - 类 com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl 中的方法
registerTargetClassName() - 类 com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl 中的方法
registerTargetClassName() - 接口 com.trs.webframework.xmlserver.IXMLConvertor 中的方法
registerValidator(IValidator) - 类 com.trs.wcag2.WCAG2Helper 中的静态方法
registerValueCreator(String, int) - 类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory 中的静态方法
registerValueCreator(BaseInfoViewFieldValueCreator, int) - 类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory 中的静态方法
registerValueCreator(String, String) - 类 com.trs.components.metadata.center.FieldValueCreatorFactory 中的静态方法
registerValueCreator(IMetaDataFieldValueCreator, String) - 类 com.trs.components.metadata.center.FieldValueCreatorFactory 中的静态方法
registerViewIds() - 接口 com.trs.components.metadata.service.IDefaultChannelMaker 中的方法
注册构造器相关的视图ID
registerViewIds() - 类 com.trs.components.metadata.service.UserRelateInfoMaker 中的方法
registerWidgetParameterType(int, String, String) - 类 com.trs.components.common.publish.widget.WidgetParameterTypes 中的方法
注册新的资源变量类型
registPersistentObj(String, Class) - 类 com.trs.infra.persistent.AbstractXmlToObjConverter 中的方法
注册TagName 与相应对象的映射
registPersistentObj(String, Class) - 类 com.trs.infra.persistent.XmlToObjConverter 中的方法
注册TagName 与相应对象的映射
registPersistentObj(String, Class) - 类 com.trs.infra.persistent.XmlToObjConverterByDOM4j 中的方法
注册TagName 与相应对象的映射
reinit() - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
reinit() - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法
reinit() - 类 com.trs.cms.auth.persistent.AdministratorCacheMgr 中的方法
reinit() - 类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 中的方法
reinit() - 类 com.trs.cms.auth.persistent.GroupUserCacheMgr 中的方法
reinit() - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 中的方法
reinit() - 类 com.trs.cms.auth.persistent.UserCacheMgr 中的方法
reinit() - 类 com.trs.cms.process.definition.FlowCacheMgr 中的方法
reinit() - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 中的方法
reinit() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 中的方法
已过时。
reinit() - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
reinit() - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
reinit() - 类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 中的方法
reinit() - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法
reinit() - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法
reinit() - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法
reinit() - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
reinit() - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
reinit() - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
reinit() - 类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 中的方法
reinit() - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 中的方法
reinit() - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
reinit() - 接口 com.trs.infra.support.cache.ICacheMgr 中的方法
REL - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
Relation - com.trs.components.wcm.content.persistent 中的 类
Relation() - 类 com.trs.components.wcm.content.persistent.Relation 的构造方法
RelationMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description: 相关文档的行为管理
目前只描述文档和文档之间的关联关系，即相关文档
如果经过调整，可以描述相同类型对象间的关联关系，如相关频道、相关附件等概念

Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RelationMgr() - 类 com.trs.components.wcm.content.domain.RelationMgr 的构造方法
Relations - com.trs.components.wcm.content.persistent 中的 类
Relations(User) - 类 com.trs.components.wcm.content.persistent.Relations 的构造方法
Relations(User, int, int) - 类 com.trs.components.wcm.content.persistent.Relations 的构造方法
RelationToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
相关文档XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RelationToXML() - 类 com.trs.ajaxservice.xmlconvertors.RelationToXML 的构造方法
release() - 类 com.trs.components.wcm.util.CRightUtil 中的方法
releaseLabor(int, int) - 接口 com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr 中的方法
release the labor who has finished its work
releaseLabor(int, int) - 类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 中的方法
release the labor who has finished its work
releaseProperty(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
reload() - 类 com.trs.cms.auth.domain.DepartmentMgrImpl 中的方法
reload() - 接口 com.trs.cms.auth.domain.IDepartmentMgr 中的方法
重新加载相关信息
reload() - 类 com.trs.components.wcm.epress.EPressConf 中的方法
reload() - 类 com.trs.infra.persistent.BaseObj 中的方法
从数据库中重新装载对象数据
reloadAppAutoParameters(String) - 类 com.trs.presentation.util.AppAutoParameters 中的静态方法
再次装载指定页面文件的页面配置参数信息
reloadConfig() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
重新装载图片库配置信息
reloadConfig() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
reloadPageConfig() - 类 com.trs.presentation.util.RequestHelper 中的方法
重新装载页面配置信息
reloadParametersOfPageName(String, String) - 类 com.trs.presentation.util.PageParameters 中的静态方法
再次装载指定页面文件的页面配置参数信息
reloadProperties() - 类 com.trs.infra.util.database.CDBKeyWords 中的静态方法
reloadProperties() - 类 com.trs.presentation.common.PageViewConstants 中的静态方法
reloadRuleCache(BaseObj) - 类 com.trs.cms.process.definition.FlowRuleCacheServerImpl 中的方法
reloadRuleCache(BaseObj) - 接口 com.trs.cms.process.definition.IFlowRuleCacheServer 中的方法
重新装载指定对象(工作流/节点)的规则缓冲
reloadSpecailData(String, String, String) - 类 com.trs.infra.persistent.BaseObjs 中的方法
从数据库中重新装载指定的数据
reloadTableInfo(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
重新装载指定的表信息
reloadTableInfo(String, boolean) - 类 com.trs.infra.persistent.db.DBManager 中的方法
reloadTimeRangeConfig() - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 中的方法
reloadTimeRangeConfig() - 接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr 中的方法
重新装载文档集合提取时间约束
reloadViewCache(int) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法
reloadViewCache(int) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法
REMIND_BYEMAIL - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM提醒类别：Email提醒
REMIND_BYMOBILE - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM提醒类别：手机提醒
REMIND_DONE - 类 com.trs.infra.common.WCMTypes 中的静态变量
有关提醒设置：已经完成提醒
REMIND_NO - 类 com.trs.infra.common.WCMTypes 中的静态变量
有关提醒设置：不提醒
REMIND_ONLINE - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM提醒类别：在线提醒
REMIND_YES - 类 com.trs.infra.common.WCMTypes 中的静态变量
有关提醒设置：提醒
Reminder - com.trs.components.common.reminder 中的 类
Reminder() - 类 com.trs.components.common.reminder.Reminder 的构造方法
保留默认构造函数
RemoteAddrUtil - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
获取IP地址工具类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
RemoteAddrUtil() - 类 com.trs.infra.util.RemoteAddrUtil 的构造方法
remove(int) - 接口 com.trs.components.common.publish.persistent.element.IPublishElements 中的方法
remove(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 中的方法
remove(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 中的方法
remove(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 中的方法
remove() - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 中的方法
remove(BaseObj, boolean) - 类 com.trs.infra.persistent.BaseObjs 中的方法
从集合中删除指定元素 说明：若指定元素不在集合中，则返回false
remove(BaseObj) - 类 com.trs.infra.persistent.BaseObjs 中的方法
remove(int, boolean) - 类 com.trs.infra.persistent.BaseObjs 中的方法
从集合中删除ID为指定值的元素
remove(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
remove(boolean) - 类 com.trs.infra.persistent.BaseObjs 中的方法
从集合中删除当前元素
remove() - 类 com.trs.infra.persistent.BaseObjs 中的方法
remove(int) - 类 com.trs.presentation.util.Parameters 中的方法
删除指定位置的参数对象
remove(Parameter) - 类 com.trs.presentation.util.Parameters 中的方法
删除指定的参数对象
removeAdministrator(User) - 类 com.trs.cms.auth.persistent.Group 中的方法
更新用户所属用户组缓冲区（删除）
removeAll(boolean) - 类 com.trs.infra.persistent.BaseObjs 中的方法
删除集合中的所有元素
removeAll() - 类 com.trs.infra.persistent.BaseObjs 中的方法
removeAt(int, boolean) - 类 com.trs.infra.persistent.BaseObjs 中的方法
从集合中删除指定位置的元素
removeAt(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
removeAttribute(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
Removes a specified attribute and returns the old value if the attribute is removed.
removeAttribute(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
删除指定的属性
removeChangeListener(DistributionChangeListener) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
删除监听配置信息改变的监听器
removeChannelEmployersOfFlow(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
批量取消工作流的配置情况
removeColumn(Column) - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法
removeConfig(WebSite) - 类 com.trs.components.wcm.content.domain.AutoDocBakMgr 中的方法
removeConfig(int) - 接口 com.trs.service.IAutoDocBakService 中的方法
删除指定站点上所有关于文档版本自动保存的配置信息
removeConfig(int) - 类 com.trs.service.impl.AutoDocBakService 中的方法
removeContact(Contact, User) - 类 com.trs.components.common.address.ContactGrp 中的方法
从非系统用户组中删除指定的非系统用户 参数：_Contact:要删除的非系统用户；_opUser:执行操作的用户
removeContact(Contact, ContactGrp) - 类 com.trs.components.common.address.ContactMgr 中的方法
将指定的联系人从指定的联系人分组中删除
removeContact(int, int) - 接口 com.trs.service.IContactService 中的方法
将指定的联系人从指定的联系人分组中删除
removeContact(Contact, ContactGrp) - 接口 com.trs.service.IContactService 中的方法
将指定的联系人从指定的联系人分组中删除
removeContact(int, int) - 类 com.trs.service.impl.ContactService 中的方法
removeContact(Contact, ContactGrp) - 类 com.trs.service.impl.ContactService 中的方法
removeContacts(String, int) - 接口 com.trs.service.IContactService 中的方法
将指定的联系人从指定的联系人分组中删除
removeContacts(String, int) - 类 com.trs.service.impl.ContactService 中的方法
removeContent(int) - 类 com.trs.cms.process.engine.FlowContentHelper 中的静态方法
removeContent(HtmlComment) - 类 com.trs.infra.util.html.HtmlElement 中的方法
删除注释对象
removeContent(HtmlElement) - 类 com.trs.infra.util.html.HtmlElement 中的方法
删除一个HTMLElement对象
removeDefaultDetailTemplate() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
removeDefaultInfoviewPrintTemplate() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
removeDefaultOutlineTemplate() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
removeDirectory(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
删除FTP服务器上指定的目录
removeDocKeywords(Document) - 类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 中的方法
removeDocKeywords(Document) - 接口 com.trs.components.wcm.content.domain.IDocKeywordMgr 中的方法
删除指定文档的相关新闻记录
removeEmploy(TemplateEmploy) - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
removeField(InfoViewField) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
removeFieldInfo(String) - 类 com.trs.infra.util.database.TableInfo 中的方法
在数据表字段信息集合中清除字段信息
removeFile(String, boolean) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
删除当前目录下的文件
removeFile(String) - 类 com.trs.infra.util.ftp.FtpMgr 中的方法
removeFile(String) - 接口 com.trs.infra.util.ftp.IFtpMgr 中的方法
Removes a file from the ftp server.
removeFlowDoc(int, int) - 类 com.trs.cms.process.FlowServer 中的方法
removeFlowDoc(int, int, User) - 类 com.trs.cms.process.FlowServer 中的方法
从FlowServer移去指定的FlowDoc对象
removeFlowDoc(IFlowContent, User) - 类 com.trs.cms.process.FlowServer 中的方法
从FlowServer移去指定的FlowDoc对象
removeFlowDoc(IFlowContent) - 类 com.trs.cms.process.FlowServer 中的方法
removeFromGroup(SSOUser, SSOGroup) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
将用户添加到组织中去
removeGroup(Group, Role) - 类 com.trs.cms.auth.domain.GroupRoleMgr 中的方法
removeGroupsFromSite(String, WebSite) - 接口 com.trs.service.IChannelService 中的方法
删除指定的站点中的指定用户组
removeGroupsFromSite(String, WebSite) - 类 com.trs.service.impl.ChannelService 中的方法
removeLinkMap(String) - 类 com.trs.infra.util.html.ContentLinkReplacer 中的方法
从链接映射表中删除一个链接项
removeLocker(CMSObj) - 类 com.trs.cms.content.LockerMgr 中的方法
从缓冲区中移去指定WCMObj对象的Locker
removeLocker(int, int) - 类 com.trs.cms.content.LockerMgr 中的方法
removeLocker(CMSObj) - 类 com.trs.cms.content.LockManager 中的方法
从缓冲区中移去指定WCMObj对象的Locker
removeLocker(int, int) - 类 com.trs.cms.content.LockManager 中的方法
removeManager(User, Group) - 接口 com.trs.service.IGroupService 中的方法
取消指定用户在某个组的管理员身份
注意: 指定的用户必须在指定组中
removeManager(User, Group) - 类 com.trs.service.impl.GroupService 中的方法
removeMediaRemindedInfoFromCache(int, int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
将媒体提醒信息从缓冲中删除
removeNoRightChannel(User, Channels, int) - 类 com.trs.ajaxservice.ChannelHelper 中的静态方法
removePageConfig(String) - 类 com.trs.presentation.util.RequestHelper 中的方法
删除指定Page的配置，以便重新载入
removeParametersOfPageName(String) - 类 com.trs.presentation.util.PageParameters 中的静态方法
删除指定Page的配置，以便重新载入
removePath(String) - 类 com.trs.infra.util.ftp.FtpMgr 中的方法
removePath(String) - 接口 com.trs.infra.util.ftp.IFtpMgr 中的方法
Removes a path from the ftp server.
removePathConfig(String) - 类 com.trs.infra.support.file.FilesMan 中的方法
从目录配置项中删除指定配置项
removeProperty(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
removeRolesFromSite(String, WebSite) - 接口 com.trs.service.IChannelService 中的方法
removeRolesFromSite(String, WebSite) - 类 com.trs.service.impl.ChannelService 中的方法
removeRuleCache(BaseObj) - 类 com.trs.cms.process.definition.FlowRuleCacheServerImpl 中的方法
removeRuleCache(BaseObj) - 接口 com.trs.cms.process.definition.IFlowRuleCacheServer 中的方法
删除指定对象(工作流/节点)的规则缓冲
removeSession(HttpSession, Integer) - 类 com.trs.presentation.util.LoginHelper 中的静态方法
removeSiteGroup(WebSite, Group) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
删除站点用户组
将指定的用户组从指定的站点删除
removeSiteMember(int, int, int) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
removeSitesFromGroup(String, Group) - 接口 com.trs.service.IChannelService 中的方法
删除指定的用户组上指定的站点
removeSitesFromGroup(String, Group) - 类 com.trs.service.impl.ChannelService 中的方法
removeSitesFromUser(String, User) - 接口 com.trs.service.IChannelService 中的方法
删除指定的用户上指定的站点
removeSitesFromUser(String, User) - 类 com.trs.service.impl.ChannelService 中的方法
removeSiteUser(WebSite, User) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
删除站点用户
将指定的用户从指定的站点删除
removeTableInfo(String) - 类 com.trs.infra.util.database.TableInfos 中的方法
removeTableInfo(String, boolean) - 类 com.trs.infra.util.database.TableInfos 中的方法
删除指定表
removeTags(String, String) - 类 com.trs.wcag2.HTMLUtil 中的静态方法
removeToppedDocument(Channel, Document) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
取消特定频道下某文档的置顶标志
该文档将成为普通文档
注意，不是删除文档！
removeToppedDocument(Document, Channel) - 接口 com.trs.service.IDocumentService 中的方法
取消特定频道下某文档的置顶标志
该文档将成为普通文档
注意，不是删除文档！
removeToppedDocument(Document, Channel) - 类 com.trs.service.impl.DocumentService 中的方法
removeUser(User, Group) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
删除组织中的某个用户
removeUser(User, Role) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
已过时。
removeUser(Role, int, User) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
将指定的用户从指定的角色和站点中删除
removeUser(SSOUser, HttpServletRequest) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
removeUser(User, Group) - 接口 com.trs.service.IGroupService 中的方法
将指定组从指定的组中删除
removeUser(User, Group, boolean) - 接口 com.trs.service.IGroupService 中的方法
removeUser(User, Group) - 类 com.trs.service.impl.GroupService 中的方法
removeUser(User, Group, boolean) - 类 com.trs.service.impl.GroupService 中的方法
removeUser(User, Role) - 类 com.trs.service.impl.RoleService 中的方法
removeUser(User, Role) - 接口 com.trs.service.IRoleService 中的方法
从指定的角色中删除指定的用户
removeUsersFromCurrRole(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
在指定角色中删除指定用户，兼容系统级和特定角色
removeUsersFromSite(String, WebSite) - 接口 com.trs.service.IChannelService 中的方法
删除指定的站点中的指定用户
removeUsersFromSite(String, WebSite) - 类 com.trs.service.impl.ChannelService 中的方法
renameFile(IPublishFolder, String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
renameFile(IPublishFolder, String, String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
renameFile(String, String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 中的方法
已过时。
renameFile(String, String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 中的方法
renameFile(String, String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 中的方法
renameFile(String, String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法
renameFile(String, String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 中的方法
已过时。
renameFile(String, String, String) - 接口 com.trs.components.common.publish.domain.distribute.IFileDistristributor 中的方法
rename '_sSourceFile' to '_sTargetFile' in '_sFullDataPath' ?
renameFile(String, String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
根据指定的路径创建FTP目录
renameFile(String, String) - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
重命名远程服务器上的文件
renameFile(String, String) - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的方法
renameFile(String, String) - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的方法
render(InfoViewData, String, String[]) - 类 com.trs.components.infoview.db.XMLContentRender 中的方法
render(InfoViewData, Document, String[]) - 类 com.trs.components.infoview.db.XMLContentRender 中的方法
renderAllChannelOutlineFields(MethodContext) - 类 com.trs.ajaxservice.InfoviewDataToolService 中的方法
替换栏目的检索字段，自动生成相应的DB字段
renderAllInfoViewSearchOutlineFields(MethodContext) - 类 com.trs.ajaxservice.InfoviewDataToolService 中的方法
替换视图的检索字段，概览字段，自动生成相应的DB字段
renderClassInfoFields(MetaViewData) - 类 com.trs.components.metadata.center.MetaDataCenterClassInfoHelper 中的静态方法
对元数据记录里面的分类法字段进行格式化处理，如：把分类法字段名称改成分类法id.
renderImage(String, String, String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
组合生成HTML [image] 元素
renderImage(String, String, String, String, String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
组合生成HTML [image] 元素
renderLink(String, String, String, String, String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
组合生成HTML 元素
renderLink(String, String, String, String, String, String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
rendHtmlFields(MetaViewData) - 类 com.trs.components.metadata.center.MetaDataCenterHelper 中的静态方法
reopenAllConnection() - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的方法
reorgTable(String) - 类 com.trs.infra.util.database.DB2ReorgUtil 中的静态方法
执行DB2 reorg table tabname命令.
Replace - com.trs.components.wcm.content.persistent 中的 类
Replace() - 类 com.trs.components.wcm.content.persistent.Replace 的构造方法
构造函数：保留默认接口
replace(int, String) - 类 com.trs.components.wcm.content.persistent.Replace 中的静态方法
替换指定的内容
replace(char) - 类 com.trs.tools.SymbolC2E 中的静态方法
replace(String) - 类 com.trs.tools.SymbolC2E 中的静态方法
ReplaceCacheMgr - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
替换内容的缓冲
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ReplaceCacheMgr() - 类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 的构造方法
replaceContentLink(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
ReplaceContentServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
替换内容管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ReplaceContentServiceProvider() - 类 com.trs.ajaxservice.ReplaceContentServiceProvider 的构造方法
replaceDir(String, String) - 类 com.trs.tools.SymbolC2E 中的静态方法
replaceFile(String, String) - 类 com.trs.tools.SymbolC2E 中的静态方法
replaceLink(String) - 类 com.trs.infra.util.html.ContentLinkReplacer 中的方法
使用指定的链接映射表，替换指定内容中的字符串
replaceLink(String, String) - 类 com.trs.infra.util.html.ContentLinkReplacer 中的方法
使用指定的链接映射表，替换指定内容中的字符串
replaceLocaleJS() - 类 com.trs.tools.CommonResourceBuilder 中的静态方法
ReplaceMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理和替换内容相关的行为
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ReplaceMgr() - 类 com.trs.components.wcm.content.domain.ReplaceMgr 的构造方法
replacePages(String, String) - 类 com.trs.tools.SymbolC2E 中的静态方法
replaceParasStartEndSpaces(String) - 类 com.trs.infra.util.CMyString 中的静态方法
先拆分成段，再分别替换各段段首和段尾的空格
replaceResources(String, String) - 类 com.trs.tools.SymbolC2E 中的静态方法
Replaces - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: 替换内容对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Replaces(User) - 类 com.trs.components.wcm.content.persistent.Replaces 的构造方法
Replaces(User, int, int) - 类 com.trs.components.wcm.content.persistent.Replaces 的构造方法
replaceStartEndSpaces(String) - 类 com.trs.infra.util.CMyString 中的静态方法
替换段首和段尾的空格
replaceStr(String, String, String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串替换函数：用于将指定字符串中指定的字符串替换为新的字符串。
replaceStr(StringBuffer, String, String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串替换函数：用于将指定字符串中指定的字符串替换为新的字符串。
replaceStrs() - 类 com.trs.tools.WCM61AutoList 中的方法
replaceWidgetInstParameters(WidgetInstance) - 接口 com.trs.components.common.publish.widget.IWidgetServer 中的方法
通过资源实例，获取资源实例的内容，并替换其中的资源实例变量
replaceWidgetInstParameters(WidgetInstance) - 类 com.trs.components.common.publish.widget.WidgetServer 中的方法
ReplyAppendixNotifyHandler - com.trs.components.gkml.sqgk.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ReplyAppendixNotifyHandler() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 的构造方法
ReplyNotifyHandler - com.trs.components.gkml.sqgk.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
出具通知书的处理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ReplyNotifyHandler() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler 的构造方法
Report - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
给一个逻辑操作的产生操作报告
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Report(String, Throwable) - 类 com.trs.infra.util.Report 的构造方法
构造函数
Report(String) - 类 com.trs.infra.util.Report 的构造方法
构造函数
Reports - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
报告汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Reports(String) - 类 com.trs.infra.util.Reports 的构造方法
ReportsToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Reports的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ReportsToXML() - 类 com.trs.ajaxservice.xmlconvertors.ReportsToXML 的构造方法
RequestHelper - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
解析Web交互的参数，构造Where条件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RequestHelper() - 类 com.trs.presentation.util.RequestHelper 的构造方法
RequestHelper(HttpServletRequest, HttpServletResponse, ServletContext) - 类 com.trs.presentation.util.RequestHelper 的构造方法
RequestHelper(HttpServletRequest, HttpServletResponse, ServletContext, boolean) - 类 com.trs.presentation.util.RequestHelper 的构造方法
RequestParamsProcessor - com.trs.webframework.xmlserver.server 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RequestParamsProcessor(ServiceContext) - 类 com.trs.webframework.xmlserver.server.RequestParamsProcessor 的构造方法
RequestParmasParseException - com.trs.webframework.xmlserver.server 中的 异常
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RequestParmasParseException() - 异常 com.trs.webframework.xmlserver.server.RequestParmasParseException 的构造方法
RequestParmasParseException(String) - 异常 com.trs.webframework.xmlserver.server.RequestParmasParseException 的构造方法
RequestParmasParseException(Throwable) - 异常 com.trs.webframework.xmlserver.server.RequestParmasParseException 的构造方法
RequestParmasParseException(String, Throwable) - 异常 com.trs.webframework.xmlserver.server.RequestParmasParseException 的构造方法
RequestParmasValidator - com.trs.webframework.controler.servlet 中的 类
RequestParmasValidator(ServiceContext, MethodConfig) - 类 com.trs.webframework.controler.servlet.RequestParmasValidator 的构造方法
RequestXMLDataProcessor - com.trs.webframework.xmlserver.server 中的 类
RequestXMLDataProcessor(ServiceContext, InputStream) - 类 com.trs.webframework.xmlserver.server.RequestXMLDataProcessor 的构造方法
RequestXMLDataProcessor(InputStream) - 类 com.trs.webframework.xmlserver.server.RequestXMLDataProcessor 的构造方法
reset() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
重置当前位置为上一次标记的位置
reset() - 类 com.trs.infra.util.jazzlib.Adler32 中的方法
Resets the Adler32 checksum to the initial value.
reset() - 接口 com.trs.infra.util.jazzlib.Checksum 中的方法
Resets the data checksum as if no update was ever called.
reset() - 类 com.trs.infra.util.jazzlib.CRC32 中的方法
Resets the CRC32 data checksum as if no update was ever called.
reset() - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Resets the deflater.
reset() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Resets the inflater so that a new stream can be decompressed.
reset() - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
重置当前Processor执行的上下文环境
reset() - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 中的方法
resetChildern(IPublishFolder, String, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
resetChildern(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
resetClassInfoChannelRight(WebSite, Group) - 类 com.trs.components.metadata.service.ClassInfoChannelRightHelper 中的静态方法
ResetClassInfoOfViewData - com.trs.util 中的 类
ResetClassInfoOfViewData() - 类 com.trs.util.ResetClassInfoOfViewData 的构造方法
resetContentStyle(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
将当前 内容风格的设置 重置为 对应的系统级别的 内容风格的设置
resetDocumentProperties(MetaView) - 接口 com.trs.components.metadata.center.IDocumentFieldsSyn 中的方法
给所有视图数据对象设置关联的document对象的值
resetFieldValueOnMetaData() - 接口 com.trs.components.metadata.center.IMetaDataFieldValueCreator 中的方法
给所有相关的元数据记录重新设置新的值
resetFieldValueOnMetaData() - 类 com.trs.components.metadata.service.GovInfoIndexCreator 中的方法
resetPassword(User, String, String) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
重设指定用户的密码
resetPassword(User) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
系统管理员重设指定用户的密码为默认密码,用于密码恢复
resetPassword(User, String) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
重置用户密码为新密码
resetPassword(User, String, String) - 类 com.trs.service.impl.UserService 中的方法
resetPassword(User) - 类 com.trs.service.impl.UserService 中的方法
resetPassword(User, String) - 类 com.trs.service.impl.UserService 中的方法
重置用户密码为新密码
resetPassword(User, String, String) - 接口 com.trs.service.IUserService 中的方法
重设指定用户的登录密码
resetPassword(User) - 接口 com.trs.service.IUserService 中的方法
重设指定用户的密码为缺省值(只能由系统管理员操作)
resetResourceStyle(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
将当前 资源风格的设置 重置为 对应的系统级别的 资源风格的设置
resetStyle(BaseStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置
resetStyle(BaseStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
将当前 资源（内容）风格的设置 重置为 对应的系统级别的 资源（内容）风格的设置
resetTitleField(MetaViewField) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
根据oMetaViewField的TitleField状态决定是否重置该视图下的标题字段
如果是新建一个标题字段，则需要清除原来的标题字段；
如果是修改一个字段,并且它的TitleField属性由0变成1，即由非标题字段变成标题字段，
则也需求清除原来的标题字段
ResouceService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ResouceService() - 类 com.trs.service.impl.ResouceService 的构造方法
RESOURCE_STYLE_TYPE - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
为了复用同一个页面，添加了风格类型的常量:资源风格
RESOURCE_XML - 类 com.trs.components.wcm.content.domain.DocumentExporter 中的静态变量
ResourceAnalyzer - com.trs.tools 中的 类
ResourceAnalyzer() - 类 com.trs.tools.ResourceAnalyzer 的构造方法
ResourceMgr - com.trs.components.wcm.resource 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ResourceMgr() - 类 com.trs.components.wcm.resource.ResourceMgr 的构造方法
resourcePattern - 类 com.trs.tools.SymbolC2E 中的静态变量
ResourceStyle - com.trs.components.common.publish.widget 中的 类
ResourceStyle() - 类 com.trs.components.common.publish.widget.ResourceStyle 的构造方法
构造函数：保留默认接口
ResourceStyleExporter - com.trs.components.common.publish.widget 中的 类
ResourceStyleExporter() - 类 com.trs.components.common.publish.widget.ResourceStyleExporter 的构造方法
构造函数
ResourceStyleImporter - com.trs.components.common.publish.widget 中的 类
资源风格的导入器
ResourceStyleImporter() - 类 com.trs.components.common.publish.widget.ResourceStyleImporter 的构造方法
构造函数
ResourceStyleMgr - com.trs.components.common.publish.widget 中的 类
资源可用风格业务逻辑实现类
ResourceStyleMgr() - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 的构造方法
构造方法
ResourceStyles - com.trs.components.common.publish.widget 中的 类
ResourceStyles(User) - 类 com.trs.components.common.publish.widget.ResourceStyles 的构造方法
构造函数
ResourceStyles(User, int, int) - 类 com.trs.components.common.publish.widget.ResourceStyles 的构造方法
构造函数
ResourceStyleServiceProvider - com.trs.components.common.publish.widget 中的 类
资源可用风格服务层
ResourceStyleServiceProvider() - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 的构造方法
构造方法
ResourceStyleXmlConverter - com.trs.components.common.publish.widget 中的 类
ResourceStyleXmlConverter() - 类 com.trs.components.common.publish.widget.ResourceStyleXmlConverter 的构造方法
构造函数
resourceSymbols - 类 com.trs.tools.SymbolC2E 中的静态变量
ResponseBuddy - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ResponseBuddy(HttpMethod) - 类 com.trs.infra.util.ResponseBuddy 的构造方法
ResponseHelper - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ResponseHelper(HttpServletResponse) - 类 com.trs.presentation.util.ResponseHelper 的构造方法
ResponseOutputException - com.trs.webframework.xmlserver.server 中的 异常
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ResponseOutputException() - 异常 com.trs.webframework.xmlserver.server.ResponseOutputException 的构造方法
ResponseOutputException(String) - 异常 com.trs.webframework.xmlserver.server.ResponseOutputException 的构造方法
ResponseOutputException(Throwable) - 异常 com.trs.webframework.xmlserver.server.ResponseOutputException 的构造方法
ResponseOutputException(String, Throwable) - 异常 com.trs.webframework.xmlserver.server.ResponseOutputException 的构造方法
restart() - 类 com.trs.infra.BaseServer 中的方法
restart() - 接口 com.trs.infra.IServer 中的方法
重新启动应用
restart() - 类 com.trs.infra.ServerControl 中的方法
restart() - 类 com.trs.infra.util.job.JobScheduler 中的方法
restore(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
恢复回收站中的文档
restore(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
恢复回收站中的文档
restore(BaseChannel) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
恢复回收站中的站点/栏目
restore(BaseChannel, boolean) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
restore(Document, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
还原频道回收站中的一篇频道文档
restore(ChnlDoc) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
恢复指定的ChnlDoc
restore(boolean) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
恢复站点/频道到正常状态(STATUS_NORM)
restore(BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
恢复站点/频道
restore(Channels) - 接口 com.trs.service.IChannelService 中的方法
恢复频道集合
restore(WebSites) - 接口 com.trs.service.IChannelService 中的方法
恢复站点集合
restore(Document, Channel) - 接口 com.trs.service.IDocumentService 中的方法
恢复回收站中的文档
restore(Documents) - 接口 com.trs.service.IDocumentService 中的方法
批量恢复回收站中的文档
restore(String, int) - 接口 com.trs.service.IDocumentService 中的方法
批量恢复回收站中的文档
restore(BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法
恢复站点/频道
restore(Channels) - 类 com.trs.service.impl.ChannelService 中的方法
restore(WebSites) - 类 com.trs.service.impl.ChannelService 中的方法
restore(Document, Channel) - 类 com.trs.service.impl.DocumentService 中的方法
restore(Documents) - 类 com.trs.service.impl.DocumentService 中的方法
restore(String, int) - 类 com.trs.service.impl.DocumentService 中的方法
restore(User) - 类 com.trs.service.impl.UserService 中的方法
restore(Users) - 类 com.trs.service.impl.UserService 中的方法
restore(User) - 接口 com.trs.service.IUserService 中的方法
恢复已删除的用户
restore(Users) - 接口 com.trs.service.IUserService 中的方法
恢复已删除的用户集合
restoreAll(User, BaseChannel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
restoreAllInRecycleBin(int) - 接口 com.trs.service.IChannelService 中的方法
还原指定频道回收站中的所有文档
restoreAllInRecycleBin(int) - 类 com.trs.service.impl.ChannelService 中的方法
还原指定频道回收站中的所有文档
restoreChannels(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
恢复回收站中的栏目
restoreComplexFields(List, int) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
重建立复合表单字段所对应的数据纪录
RestoreObjLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
恢复回收站日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
RestoreObjLogger() - 类 com.trs.ajaxservice.logger.RestoreObjLogger 的构造方法
restoreSites(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
恢复回收站中的站点
reSubmitTo(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
重新处理
resubmitTo(FlowContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法
resubmitTo(FlowContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
重新指派
RESULT_CONTINUE - 接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTask 中的静态变量
执行结果，可以继续执行
RESULT_FAILED - 接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTask 中的静态变量
执行结果，已经执行失败
RESULT_OK - 类 com.trs.presentation.util.LoginHelper 中的静态变量
登录成功
RESULT_SUSPEND - 接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTask 中的静态变量
执行结果，需要暂时挂起
resumeTask(PublishTask) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
暂停指定任务的执行
resumeTask(int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
恢复指定的已经暂停的发布任务的执行,如果指定的并不是处于暂停状态则什么都不作。
resumeTask(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
resumeTask(int) - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法
resumeTask(String) - 类 com.trs.service.impl.PublishService 中的方法
resumeTask(String) - 接口 com.trs.service.IPublishService 中的方法
恢复指定的发布任务集合，对其中不处于暂停状态的任务不会产生影响
ResyncTemplateApdLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
同步模板附件操作日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ResyncTemplateApdLogger() - 类 com.trs.ajaxservice.logger.ResyncTemplateApdLogger 的构造方法
retriveChannelInfo(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
retriveChannelInfo(String, String, String) - 类 com.trs.service.impl.InfoViewDocImportService 中的方法
RETURN_HTML - 类 com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator 中的静态变量
RETURN_NAME - 类 com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator 中的静态变量
RETURN_NONE - 类 com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator 中的静态变量
REV - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
reWriteConfigFile() - 类 com.trs.template.TemplateServiceConfig 中的静态方法
重写配置信息文件
Right - com.trs.cms.auth.persistent 中的 类
Right() - 类 com.trs.cms.auth.persistent.Right 的构造方法
RIGHT_INDEXS_WORKFLOW - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
工作流权限列表
RIGHT_REGION_NUMBER - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
右边
RightCacheMgr - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightCacheMgr() - 类 com.trs.cms.auth.domain.RightCacheMgr 的构造方法
RightConfigServer - com.trs.cms.auth.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
权限配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightConfigServer() - 类 com.trs.cms.auth.config.RightConfigServer 的构造方法
RightDef - com.trs.cms.auth.persistent 中的 类
RightDef() - 类 com.trs.cms.auth.persistent.RightDef 的构造方法
RightDefs - com.trs.cms.auth.persistent 中的 类
RightDefs(User) - 类 com.trs.cms.auth.persistent.RightDefs 的构造方法
RightDefs(User, int, int) - 类 com.trs.cms.auth.persistent.RightDefs 的构造方法
RightHelper - com.trs.presentation.right 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用于表现层权限构造相关的管理方法
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightHelper() - 类 com.trs.presentation.right.RightHelper 的构造方法
RightHostConfig - com.trs.cms.auth.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Right Object实现配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostConfig() - 类 com.trs.cms.auth.config.RightHostConfig 的构造方法
RightHostFactory - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostFactory() - 类 com.trs.cms.auth.domain.RightHostFactory 的构造方法
RightHostIndexsConfig - com.trs.cms.auth.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostIndexsConfig() - 类 com.trs.cms.auth.config.RightHostIndexsConfig 的构造方法
RightHostInfoViewField - com.trs.components.infoview 中的 类
RightHostInfoViewField() - 类 com.trs.components.infoview.RightHostInfoViewField 的构造方法
RightHostInfoViewField(InfoViewField) - 类 com.trs.components.infoview.RightHostInfoViewField 的构造方法
RightHostInfoViewGroup - com.trs.components.infoview 中的 类
RightHostInfoViewGroup() - 类 com.trs.components.infoview.RightHostInfoViewGroup 的构造方法
RightHostInfoViewGroup(InfoViewGroup) - 类 com.trs.components.infoview.RightHostInfoViewGroup 的构造方法
RightHostInfoViewView - com.trs.components.infoview 中的 类
RightHostInfoViewView() - 类 com.trs.components.infoview.RightHostInfoViewView 的构造方法
RightHostInfoViewView(InfoViewView) - 类 com.trs.components.infoview.RightHostInfoViewView 的构造方法
RightHostLCListenerForInherit - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
权限对象新增创建监听器，为了继承父对象的权限权限
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightHostLCListenerForInherit() - 类 com.trs.cms.auth.domain.RightHostLCListenerForInherit 的构造方法
RightLCListenerForSynSiteMember - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightLCListenerForSynSiteMember() - 类 com.trs.components.wcm.content.domain.RightLCListenerForSynSiteMember 的构造方法
RightLogger - com.trs.cms.auth.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
权限对象操作日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
RightLogger() - 类 com.trs.cms.auth.logger.RightLogger 的构造方法
RightMgr - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
权限管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightMgr() - 类 com.trs.cms.auth.domain.RightMgr 的构造方法
RightObjectConfig - com.trs.cms.auth.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Right Object实现配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightObjectConfig() - 类 com.trs.cms.auth.config.RightObjectConfig 的构造方法
RightObjectFactory - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RightObjectFactory() - 类 com.trs.cms.auth.domain.RightObjectFactory 的构造方法
Rights - com.trs.cms.auth.persistent 中的 类
Rights(User) - 类 com.trs.cms.auth.persistent.Rights 的构造方法
Rights(User, int, int) - 类 com.trs.cms.auth.persistent.Rights 的构造方法
RightSet - com.trs.cms.auth.domain 中的 类
RightSet() - 类 com.trs.cms.auth.domain.RightSet 的构造方法
RightUpdaterForUser - com.trsupdate 中的 类
RightUpdaterForUser(User, String) - 类 com.trsupdate.RightUpdaterForUser 的构造方法
RightValue - com.trs.cms.auth.persistent 中的 类
RightValue() - 类 com.trs.cms.auth.persistent.RightValue 的构造方法
使用权限值为0的整数构造对象
RightValue(long) - 类 com.trs.cms.auth.persistent.RightValue 的构造方法
使用长整型数构造对象
RightValue(String) - 类 com.trs.cms.auth.persistent.RightValue 的构造方法
使用0或1表示的权限字符串构造对象
RightValue(RightValue) - 类 com.trs.cms.auth.persistent.RightValue 的构造方法
使用权限值对象构造对象
RIGHTVALUE_WHEN_NOT_EXISTS - 类 com.trs.cms.auth.persistent.RightValue 中的静态变量
RIGHTVALUE_WHEN_NOT_EXISTS - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
roateImg(ImageMagickCmd.ImageObj, String) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法
Role - com.trs.cms.auth.persistent 中的 类
Role() - 类 com.trs.cms.auth.persistent.Role 的构造方法
ROLE_ADD_USER - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
添加用户
ROLE_DEL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除角色的权限
ROLE_DEL_USER - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除用户
ROLE_SAVE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
保存角色的权限
RoleAsToUsersCreator - com.trs.cms.process.engine.creators 中的 类
RoleAsToUsersCreator() - 类 com.trs.cms.process.engine.creators.RoleAsToUsersCreator 的构造方法
RoleAuthServer - com.trs.cms.auth.domain 中的 类
RoleAuthServer() - 类 com.trs.cms.auth.domain.RoleAuthServer 的构造方法
ROLEMANAGERS_NAME - 类 com.trs.cms.auth.persistent.Role 中的静态变量
RoleManagers角色固定的名称, 固定Name，不固定id主要是避免升级困难， by huxiejin 2010-01-07
RoleMgr - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
RoleMgr() - 类 com.trs.cms.auth.domain.RoleMgr 的构造方法
ROLENAME_SFX_MGR - 类 com.trs.components.metadata.service.ClassInfoToGroupCreator 中的静态变量
Roles - com.trs.cms.auth.persistent 中的 类
Roles(User) - 类 com.trs.cms.auth.persistent.Roles 的构造方法
构造函数
Roles(User, int, int) - 类 com.trs.cms.auth.persistent.Roles 的构造方法
构造函数
RoleService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
角色相关服务接口的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RoleService() - 类 com.trs.service.impl.RoleService 的构造方法
RoleServiceProvider - com.trs.ajaxservice 中的 类
RoleServiceProvider() - 类 com.trs.ajaxservice.RoleServiceProvider 的构造方法
RoleUser - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
角色/用户关联对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RoleUser() - 类 com.trs.cms.auth.persistent.RoleUser 的构造方法
构造函数：保留默认接口
RoleUserCacheMgr - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
组织用户的缓冲.
RoleUserCacheMgr() - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 的构造方法
RoleUserIdsMan - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RoleUserIdsMan(int) - 类 com.trs.cms.auth.domain.RoleUserIdsMan 的构造方法
RoleUserLogger - com.trs.cms.auth.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
角色用户日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
RoleUserLogger() - 类 com.trs.cms.auth.logger.RoleUserLogger 的构造方法
RoleUsers - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
角色/用户关联对象集合的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RoleUsers(User) - 类 com.trs.cms.auth.persistent.RoleUsers 的构造方法
构造函数
RoleUsers(User, int, int) - 类 com.trs.cms.auth.persistent.RoleUsers 的构造方法
构造函数
RoleXmlConverter - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
角色对象转换为XML数据格式对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RoleXmlConverter() - 类 com.trs.cms.auth.persistent.RoleXmlConverter 的构造方法
RollDocumentsChannelsFinder - com.trs.components.wcm.publish.tagparser 中的 类
RollDocumentsChannelsFinder(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.RollDocumentsChannelsFinder 的构造方法
ROOT_MARK - 类 com.trs.components.infoview.config.GatewayConfig 中的静态变量
ROOTIMG_DATAPATH - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
data path of images in root
rotateImage(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
rotateImage(double) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
按照指定的角度旋转突破
rotateImage(double) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
round(double, int) - 类 com.trs.infra.util.CMyDecimalBuddy 中的静态方法
小数位四舍五入
ROWID - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：ROWID
ROWS - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
ROWSPAN - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
RULE_TRIGGER_ON_ACCEPT - 类 com.trs.cms.process.ProcessConstants 中的静态变量
签收时触发的规则
RULE_TRIGGER_ON_BACK - 类 com.trs.cms.process.ProcessConstants 中的静态变量
打回时触发的规则
RULE_TRIGGER_ON_DOING - 类 com.trs.cms.process.ProcessConstants 中的静态变量
处理过程中触发的规则
RULE_TRIGGER_ON_END - 类 com.trs.cms.process.ProcessConstants 中的静态变量
结束处理时触发的规则
RULE_TRIGGER_ON_ENTER - 类 com.trs.cms.process.ProcessConstants 中的静态变量
进入节点时候触发的规则
RULE_TRIGGER_ON_RECEIVE - 类 com.trs.cms.process.ProcessConstants 中的静态变量
收到时候触发的规则
RULE_TRIGGER_ON_REFUSE - 类 com.trs.cms.process.ProcessConstants 中的静态变量
拒绝时触发的规则
RULE_TRIGGERS - 类 com.trs.cms.process.ProcessConstants 中的静态变量
定义的所有触发规则
RuleExecuteHelper - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RuleExecuteHelper() - 类 com.trs.cms.process.engine.RuleExecuteHelper 的构造方法
RuleHostLCListnerForCache - com.trs.cms.process.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流规则所属对象监听器，为了删除对象时候同步规则缓冲
由于修改和新增的时候规则可能还没有建立起来，所以需要在创建的逻辑中使用硬代码
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
RuleHostLCListnerForCache() - 类 com.trs.cms.process.definition.RuleHostLCListnerForCache 的构造方法
run() - 类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 中的方法
run() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
override Thread.run
run() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
interface implementation：Runnable
run() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法
run() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskWorker 中的方法
run() - 类 com.trs.components.common.publish.domain.template.TemplateParseAngel 中的方法
run() - 类 com.trs.components.metadata.service.util.WCMJSPChecker 中的方法
run() - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的方法
初始化数据库连接缓冲池
run() - 类 com.trs.infra.util.CMyTimer 中的方法
运行
run() - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
run() - 类 com.trs.infra.util.ftp.FtpConnectionPool 中的方法
初始化FTP连接缓冲池
run() - 类 com.trs.infra.util.ftp.FtpMgrTest 中的方法
run() - 类 com.trs.presentation.jsputil.JspChecker 中的方法
RUN_IN_ECLISPE - 类 com.trs.infra.config.domain.ConfigHelper 中的静态变量
RUN_INTERVAL - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的静态变量
running interval time when to wait
RUN_INTERVAL - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的静态变量
interval time when running
RUN_INTERVAL - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的静态变量
interval time during running
runIt(Runnable) - 类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 中的方法
runtimePattern - 类 com.trs.tools.SymbolC2E 中的静态变量
runtimeSymbols - 类 com.trs.tools.SymbolC2E 中的静态变量
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


S - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

S

S - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
s_logger - 类 com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB 中的静态变量
s_logger - 类 com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel 中的静态变量
SAME_VIEW_CONTAIN_ALL - 类 com.trs.components.metadata.service.ViewRangeConstants 中的静态变量
所有具有相同视图的栏目
SAME_VIEW_CONTAIN_CHILDREN - 类 com.trs.components.metadata.service.ViewRangeConstants 中的静态变量
本栏目及子栏目下所有具有相同视图的栏目
SAMP - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
save(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.DistributeServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.DocumentSynServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.GroupServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.IndividuationServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.NewChannelServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.ReplaceContentServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.SourceServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.StatusServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceHelperProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.WatermarkServiceProvider 中的方法
save(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
save(Group) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
保存组织（新建、编辑）
save() - 类 com.trs.cms.auth.domain.NewRightSet 中的方法
save(Role) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
保存指定的角色
save(User) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
保存用户
save(User) - 类 com.trs.cms.content.CMSObj 中的方法
对象保存自己
save() - 类 com.trs.cms.content.CMSObj 中的方法
save(Event) - 类 com.trs.components.common.calendar.EventMgr 中的方法
保存日程安排
save(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr 中的方法
Saves the distribution setting.
save(PublishTask) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
save the publish task which is created or updated
save(PublishTask) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
save(TemplateArgument) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentMgr 中的方法
保存指定的TemplateArgument对象
save(Template, String, boolean, int) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
保存模板
save(Template, HashMap, boolean, int, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
保存模板
save(TemplateQuote) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr 中的方法
save a template quote
save(List) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr 中的方法
saves the specified template quotes list.
save(TemplateQuote) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310 中的方法
save a template quote
save(List) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310 中的方法
saves the specified template quotes list.
save(User) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
save(User, ContentStyle) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
save(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
保存当前风格
save(User, ContentStyle) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
保存（新增、编辑）ContentStyle
save(User, Layout) - 接口 com.trs.components.common.publish.widget.ILayoutMgr 中的方法
新建或者保存布局
save(MethodContext) - 接口 com.trs.components.common.publish.widget.ILayoutServiceProvider 中的方法
save(User, String, String) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
保存当前母版
save(User, Master) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
save(String, String) - 接口 com.trs.components.common.publish.widget.IMasterServiceProvider 中的方法
创建或者更新母板
save(User, PageStyle) - 接口 com.trs.components.common.publish.widget.IPageStyleMgr 中的方法
保存（新增、编辑）页面风格
save(User, ResourceStyle) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
保存（新增、编辑）资源风格
save(User, StyleAndResource) - 接口 com.trs.components.common.publish.widget.IStyleAndResourceMgr 中的方法
保存修改StyleAndResource
save(User, BaseStyle, StyleItem) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
保存（新增、编辑）StyleItem
save(User, WidgetInstance) - 接口 com.trs.components.common.publish.widget.IWidgetInstanceMgr 中的方法
对指定的模板，根据资源块对象，及资源块的相应属性，产生一个资源块的实例对象
save(WidgetInstance, Map) - 接口 com.trs.components.common.publish.widget.IWidgetInstanceMgr 中的方法
修改指定的资源块实例的变量信息
save(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetParameterServiceProvider 中的方法
保存当前资源变量
save(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetServiceProvider 中的方法
保存当前资源片段
save(User, Layout) - 类 com.trs.components.common.publish.widget.LayoutMgr 中的方法
保存当前布局，若ID为0则为创建布局,将样式文件写到文件上，不保存到HTML代码中
save(MethodContext) - 类 com.trs.components.common.publish.widget.LayoutServiceProvider 中的方法
保存布局
save(User, String, String) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
保存当前母板
save(User, Master) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
保存当前母板
save(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
保存母板
save(String, String) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
根据母板名称以及母板的文件名保存母板
save(User, PageStyle) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
只保存风格的基本属性，不负责保存关联对象
save(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
保存当前风格
save(User, ResourceStyle) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
保存（新增、编辑）ResourceStyle
save(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
保存当前风格
save(User, StyleAndResource) - 类 com.trs.components.common.publish.widget.StyleAndResourceMgr 中的方法
save(User, BaseStyle, StyleItem) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
save(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
save(User, WidgetInstance) - 类 com.trs.components.common.publish.widget.WidgetInstanceMgr 中的方法
save(WidgetInstance, Map) - 类 com.trs.components.common.publish.widget.WidgetInstanceMgr 中的方法
save(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 中的方法
save(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 中的方法
save(InfoView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
save(InfoViewView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
save(InfoViewGroup) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
save(InfoViewField) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
save(User, MetaViewData) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录
save(User, MetaViewData) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
保存视图字段数据时，如果此记录中包含分类法字段，则同步保存ClassInfoView记录
save() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
save(User, MetaDBTable) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
新增或者修改系统表
save(User, MetaDBTable, MetaDBField) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
在指定表上，新增或者修改指定字段信息
save(User, MetaView) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
新增或修改视图信息
save(User, MetaView, MetaViewField) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
在指定视图上，新增或者修改指定字段信息
save(User, MetaDBTable) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
save(User, MetaDBTable, MetaDBField) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
save(User, MetaView) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
save(User, MetaView, MetaViewField) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
save(User) - 类 com.trs.components.metadata.definition.MetaView 中的方法
save(User, Special, String) - 接口 com.trs.components.special.ISpecialMgr 中的方法
保存当前专题
save(MethodContext) - 接口 com.trs.components.special.ISpecialServiceProvider 中的方法
保存当前专题对象
save(User, Special, String) - 类 com.trs.components.special.SpecialMgr 中的方法
save(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法
save(User, int, String, float) - 类 com.trs.components.stat.BonusRuleMgr 中的方法
保存当前奖励规则
save(User, BonusRule) - 类 com.trs.components.stat.BonusRuleMgr 中的方法
save(MethodContext) - 类 com.trs.components.stat.BonusRuleServiceProvider 中的方法
save(User, int, String, float) - 接口 com.trs.components.stat.IBonusRuleMgr 中的方法
保存当前奖励规则
save(User, BonusRule) - 接口 com.trs.components.stat.IBonusRuleMgr 中的方法
save(UserLoginInfo, User) - 接口 com.trs.components.stat.IUserLoginInfoMgr 中的方法
save(UserLoginInfo, User) - 类 com.trs.components.stat.UserLoginInfoMgr 中的方法
保存当前用户登录信息
save(MethodContext) - 类 com.trs.components.stat.UserLoginInfoServiceProvider 中的方法
这里要实现的是存储一条当前用户登陆信息。
save(WebSite, VChannel) - 类 com.trs.components.wcm.channel.VChannelManager 中的方法
save(Channel, VChannel) - 类 com.trs.components.wcm.channel.VChannelManager 中的方法
save(WCMSystemObject, VChannel) - 类 com.trs.components.wcm.channel.VChannelManager 中的方法
save(AutoBakConfig) - 类 com.trs.components.wcm.content.domain.AutoDocBakMgr 中的方法
save(ChannelSyn) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法
save(BaseChannel) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
保存（新增、编辑）栏目或者站点
save(CMSObj, ContentExtField, boolean) - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 中的方法
save(ContentLink) - 类 com.trs.components.wcm.content.domain.ContentLinkMgr 中的方法
保存一个内容超链接
save(Document) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
在频道下保存/修改一篇文档
文档的频道属性不能在此被修改，而应该通过移动操作进行修改
文档的假删除、恢复 都需要调用相关接口，而不该通过修改接口
修改文档状态时，需要同步修改ChnlDoc的状态
save(Replace) - 类 com.trs.components.wcm.content.domain.ReplaceMgr 中的方法
保存指定的Replace对象
save(int) - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
保存定制的功能模块
save(User, Channel) - 类 com.trs.components.wcm.epress.EPressChannelWrapper 中的方法
save(MethodContext) - 类 com.trs.components.wcm.publish.region.CellServiceProvider 中的方法
save(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionEmployServiceProvider 中的方法
save(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionServiceProvider 中的方法
save(User) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
save() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
save(User, CMSObj) - 类 com.trs.components.wcm.resource.ResourceMgr 中的方法
保存指定的配置资源对象
save() - 类 com.trs.infra.BaseConfig 中的方法
save(ServletRequest) - 类 com.trs.infra.config.ConfigController 中的方法
save() - 类 com.trs.infra.config.DBTableConfig 中的方法
save() - 类 com.trs.infra.config.FileConfig 中的方法
save() - 类 com.trs.infra.config.XMLConfig 中的方法
save() - 类 com.trs.infra.persistent.BaseObj 中的方法
对象保存自己
save(SecureKey) - 类 com.trs.infra.support.security.SecureKeyMgr 中的方法
保存指定的密钥
save(AutoBakConfig) - 接口 com.trs.service.IAutoDocBakService 中的方法
保存站点上关于文档版本自动保存的配置信息
save(BookMark) - 接口 com.trs.service.IBookMarkService 中的方法
保存一个BookMark
save(MarkKind) - 接口 com.trs.service.IBookMarkService 中的方法
保存一个MarkKind
save(BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
保存指定的站点/频道
save(int) - 接口 com.trs.service.ICustomizeService 中的方法
保存当前登录用户定制的模块
save(Document, List, List) - 接口 com.trs.service.IDocumentService 中的方法
添加文档、修改文档时的保存操作 由于对对象进行了重新划分，将AppendixList等从Document对象中提取出来
保持了Document对象和各个对象的独立性
save(Document, List, List, Map) - 接口 com.trs.service.IDocumentService 中的方法
save(Document, List, List, String) - 接口 com.trs.service.IDocumentService 中的方法
save(Document, List, List, int) - 接口 com.trs.service.IDocumentService 中的方法
save(Event) - 接口 com.trs.service.IEventService 中的方法
保存一个Event
save(Group) - 接口 com.trs.service.IGroupService 中的方法
保存指定的组织
save(InfoView) - 接口 com.trs.service.IInfoViewService 中的方法
保存指定的自定义表单
save(InfoViewField) - 接口 com.trs.service.IInfoViewService 中的方法
保存指定的自定义表单字段
save(InfoViewGroup) - 接口 com.trs.service.IInfoViewService 中的方法
保存指定的自定义表单数据节
save(InfoViewView) - 接口 com.trs.service.IInfoViewService 中的方法
保存指定的自定义表单视图
save(AutoBakConfig) - 类 com.trs.service.impl.AutoDocBakService 中的方法
save(BookMark) - 类 com.trs.service.impl.BookMarkService 中的方法
save(MarkKind) - 类 com.trs.service.impl.BookMarkService 中的方法
save(BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法
保存指定的站点/频道
save(int) - 类 com.trs.service.impl.CustomizeService 中的方法
save(Document, List, List) - 类 com.trs.service.impl.DocumentService 中的方法
save(Document, List, List, String) - 类 com.trs.service.impl.DocumentService 中的方法
save(Document, List, List, int) - 类 com.trs.service.impl.DocumentService 中的方法
save(Document, List, List, Map) - 类 com.trs.service.impl.DocumentService 中的方法
save(Document, List, List, Map, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
save(Event) - 类 com.trs.service.impl.EventService 中的方法
save(Group) - 类 com.trs.service.impl.GroupService 中的方法
save(InfoView) - 类 com.trs.service.impl.InfoViewService 中的方法
save(InfoViewField) - 类 com.trs.service.impl.InfoViewService 中的方法
save(InfoViewGroup) - 类 com.trs.service.impl.InfoViewService 中的方法
save(InfoViewView) - 类 com.trs.service.impl.InfoViewService 中的方法
save(CMSObj) - 类 com.trs.service.impl.ResouceService 中的方法
save(Role) - 类 com.trs.service.impl.RoleService 中的方法
save(Template, boolean, int) - 类 com.trs.service.impl.TemplateService 中的方法
save(Template) - 类 com.trs.service.impl.TemplateService 中的方法
save(User) - 类 com.trs.service.impl.UserService 中的方法
save(User, Group) - 类 com.trs.service.impl.UserService 中的方法
save(BaseChannel, WCMFolderPublishConfig) - 类 com.trs.service.impl.WCMPublishElementServiceImpl 中的方法
save(WebSite, PublishDistribution) - 类 com.trs.service.impl.WCMPublishElementServiceImpl 中的方法
save(CMSObj) - 接口 com.trs.service.IResourceService 中的方法
保存资源配置
save(Role) - 接口 com.trs.service.IRoleService 中的方法
保存指定的角色
save(Template, boolean, int) - 接口 com.trs.service.ITemplateService 中的方法
保存模板，包括新增和修改
save(Template) - 接口 com.trs.service.ITemplateService 中的方法
保存模板，包括新增和修改，此接口一般用于从源代码方式下保存模板
save(User) - 接口 com.trs.service.IUserService 中的方法
保存一个用户
save(User, Group) - 接口 com.trs.service.IUserService 中的方法
save(BaseChannel, WCMFolderPublishConfig) - 接口 com.trs.service.IWCMPublishElementService 中的方法
保存当前站点或频道的发布配置信息
save(WebSite, PublishDistribution) - 接口 com.trs.service.IWCMPublishElementService 中的方法
保存当前站点所设置的分发目录
save(User) - 类 com.trs.wcm.photo.Watermark 中的方法
save(MethodContext) - 类 com.trs.webframework.demo.StdDemoProviderImpl 中的方法
save(MethodContext) - 类 com.trs.webframework.provider.BaseServiceDecorator 中的方法
save(MethodContext) - 接口 com.trs.webframework.provider.ISaveServiceProvider 中的方法
SAVE - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量
SAVE_STATUS_KEY - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
站点保存版本配置关键字：允许保存的文档状态(SITE_SAVE_STATUS)
saveAppendixes(MethodContext) - 类 com.trs.ajaxservice.ApplyFormServiceProvider 中的方法
saveAppendixes(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
保存指定文档的相关文档
saveAppendixes(Document, List) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
保存特定的附件列表，包括添加、删除或者更新其中的具体附件
从private方法变成public方法，要小心
注意：保存文档相关的附件时，需要删除已经不再属于该文档的附件
050321，OO调整时进行的
saveArgument(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
保存用户在当前站点或者栏目设置的变量
saveBaseStyle(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
保存风格的页面特性 需要传递参数ObjectId和StyleItemXML是一个xml串， 格式类似于saveBookMark(BookMark) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
保存一个书签
saveCells(MethodContext) - 类 com.trs.components.wcm.publish.region.CellServiceProvider 中的方法
保存指定导读的所有单元格信息
saveChannels(int[]) - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
保存定制的频道
saveChannels(String) - 接口 com.trs.service.ICustomizeService 中的方法
保存个人定制的频道
saveChannels(String) - 类 com.trs.service.impl.CustomizeService 中的方法
saveChannelSyn(ChannelSyn) - 接口 com.trs.service.IChannelService 中的方法
saveChannelSyn(ChannelSyn) - 类 com.trs.service.impl.ChannelService 中的方法
saveChannelSyns(ChannelSyn, String) - 接口 com.trs.service.IChannelService 中的方法
saveChannelSyns(ChannelSyn, String) - 类 com.trs.service.impl.ChannelService 中的方法
saveClassInfo(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
saveClassInfo(User, int, int, int, String, String, String) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
保存分类法设置
saveClassInfo(MethodContext, User, int, int, int, String, String, String) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
这个方法实现不太好，但只是为了兼容wcm6，因为wcm6的实现，字段都是写死的， 不能根据外界传入什么字段，向数据库中保存什么
saveClassInfo(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
saveClassInfo(User, int, int, int, String, String) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
保存分类法设置
saveComponentConfigInfo(EntryConfig) - 类 com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl 中的方法
saveComponentConfigInfo(EntryConfig) - 接口 com.trs.components.common.conjection.service.IComponentEntryConfigService 中的方法
saveConfig() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
保存图片库的设置
saveConfig() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
saveContact(Contact) - 类 com.trs.components.common.address.ContactMgr 中的方法
保存一个联系人
saveContact(Contact) - 接口 com.trs.service.IContactService 中的方法
保存一个联系人
saveContact(Contact) - 类 com.trs.service.impl.ContactService 中的方法
saveContactGroup(ContactGrp) - 类 com.trs.components.common.address.ContactMgr 中的方法
保存一个联系人分组
saveContactGroup(ContactGrp) - 接口 com.trs.service.IContactService 中的方法
保存一个联系人分组
saveContactGroup(ContactGrp) - 类 com.trs.service.impl.ContactService 中的方法
saveContentLink(ContentLink) - 接口 com.trs.service.IChannelService 中的方法
saveContentLink(ContentLink) - 类 com.trs.service.impl.ChannelService 中的方法
saveCustomStyle(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
保存风格的自定义风格 服务中需要传递参数ObjectId和CustomStyle，CustomStyle是自定义的样式
SAVED_OBJID - 类 com.trs.infra.common.ContextParameters 中的静态变量
预留索引
保存日志使用
saveDBFieldInfo(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
保存元数据字段信息
saveDBTableInfo(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
保存元数据表的信息
saveDocReply(Document, DocReply) - 类 com.trs.components.wcm.content.domain.DocReplyMgr 中的方法
保存文档的一个回复
saveDocTopicRelation(int, int, int[]) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法
saveDocTopicRelation(int, int, String) - 类 com.trs.components.comment.service.CommentService 中的方法
saveDocTopicRelation(int, int, String) - 接口 com.trs.components.comment.service.ICommentService 中的方法
saveDocumentSyn(DocumentSyn) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法
saveExtField(BaseChannel, ContentExtField, boolean) - 接口 com.trs.service.IChannelService 中的方法
保存指定的扩展字段
saveExtField(BaseChannel, ContentExtField, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
保存指定的扩展字段
saveExtif(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
用于抽取图片Exit信息
saveFlow(String) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
saveFlow(String) - 接口 com.trs.service.IWCMProcessService 中的方法
saveForSpecial(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
saveGroup(SSOGroup, Group, int) - 类 com.trs.presentation.ids.ActorHelper 中的静态方法
本地应用的保存组织操作
saveGroups(MethodContext) - 类 com.trs.ajaxservice.GroupServiceProvider 中的方法
保存用户新建和修改用户后的用户所属组织信息
saveHtmlContent(String) - 类 com.trs.cms.content.HTMLContent 中的静态方法
saveHtmlContent(String, boolean, boolean) - 类 com.trs.cms.content.HTMLContent 中的静态方法
saveHTMLContentFromOut(String, HashMap) - 类 com.trs.cms.content.HTMLContent 中的静态方法
以外部资源为Src，保存HTMLContent中的资源
saveImage(String, User) - 类 com.trs.wcm.photo.impl.AutoImageLibUtil 中的静态方法
saveImageDetail(Document) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
保存图片的标注信息(标题、作者、地点、人物、时间)
saveImageDetail(Document) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
saveImageInfo(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
saveImageInfo(ImageInfo) - 接口 com.trs.wcm.photo.IImageLibMgr 中的方法
saveImageInfo(ImageInfo) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
保存图片信息到图片库中
saveImageInfo(ImageInfo) - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 中的方法
saveImageInfo(ImageInfo) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
saveInfoViewData(int, Document) - 类 com.trs.components.infoview.db.InfoViewDBStoreServer 中的方法
saveInfoViewDocument(Document, Document) - 接口 com.trs.service.IDocumentService 中的方法
saveInfoViewDocument(Document, Document, Map) - 接口 com.trs.service.IDocumentService 中的方法
saveInfoViewDocument(Document, Document, String) - 接口 com.trs.service.IDocumentService 中的方法
saveInfoViewDocument(Document, InfoView, Map) - 接口 com.trs.service.IDocumentService 中的方法
saveInfoViewDocument(Document, Document) - 类 com.trs.service.impl.DocumentService 中的方法
saveInfoViewDocument(Document, Document, String) - 类 com.trs.service.impl.DocumentService 中的方法
saveInfoViewDocument(Document, InfoView, Map) - 类 com.trs.service.impl.DocumentService 中的方法
saveInfoViewDocument(Document, Document, Map) - 类 com.trs.service.impl.DocumentService 中的方法
saveKey(SecureKey) - 类 com.trs.service.impl.SecurityService 中的方法
saveKey(SecureKey) - 接口 com.trs.service.ISecurityService 中的方法
保存指定的密钥
saveLibConf(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
saveLog() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
saveLog() - 接口 com.trs.infra.support.log.ILog 中的方法
saveMarkKind(MarkKind) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
保存一个书类别
SaveMembersListenerForObjectMember - com.trs.ajaxservice.listener 中的 类
SaveMembersListenerForObjectMember() - 类 com.trs.ajaxservice.listener.SaveMembersListenerForObjectMember 的构造方法
saveMembersOfObject(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法
保存指定对象对其可见、可操作的成员
saveMetaViewData(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
保存在指定视图下提交的数据信息
saveMetaViewData(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
保存在指定视图下提交的数据信息
saveMetaViewData(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
保存在指定视图下提交的数据信息
saveMetaViewData(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
保存在指定视图下提交的数据信息
saveMetaViewData(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH 中的方法
保存来自政府的公开信息
saveMetaViewDataOfGov(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
保存来自政府的公开信息
saveMetaViewDataOfGov(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
保存来自政府的公开信息
saveMetaViewDataOfGov(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
保存来自政府的公开信息
saveMetaViewDataOfGov(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH 中的方法
saveNestTemplateContext() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
保存当前嵌套模板的状态
saveObjectsOfMember(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法
保存指定成员所拥有的可见、可操作对象
saveOperatorRights(MethodContext) - 类 com.trs.ajaxservice.AuthServiceProvider 中的方法
saveOriginImg(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
savePageOtherStyle(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
保存风格的其他风格属性
savePageOtherStyleItem(User, PageStyle, StyleItem) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
保存页面风格对应的其他风格属性
savePageOtherStyleItem(User, PageStyle, StyleItem) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
保存页面风格对应的其他风格属性
saveParameters(WidgetInstance, Map) - 接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr 中的方法
给资源块实例对象设置相应的资源库实例变量，仅仅只是设置这些传入了的变量的值
saveParameters(WidgetInstance, Map) - 类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 中的方法
savepic(MethodContext) - 类 com.trs.ajaxservice.NewChannelServiceProvider 中的方法
savePro(MethodContext) - 类 com.trs.ajaxservice.NewChannelServiceProvider 中的方法
savePublishConfig(MethodContext) - 类 com.trs.ajaxservice.PublishServiceProvider 中的方法
savePublishSchedule(Schedule, BaseChannel) - 类 com.trs.service.impl.ScheduleService 中的方法
savePublishSchedule(Schedule, Document) - 类 com.trs.service.impl.ScheduleService 中的方法
savePublishSchedule(Schedule, BaseChannel) - 接口 com.trs.service.IScheduleService 中的方法
给指定的站点或频道设置计划发布属性
savePublishSchedule(Schedule, Document) - 接口 com.trs.service.IScheduleService 中的方法
给指定的文档设置计划发布属性
saveRelation(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
保存指定文档的相关文档
saveRelations(Document, List) - 类 com.trs.components.wcm.content.domain.RelationMgr 中的方法
保存相关文档的信息，可能是添加或者修改时调用
saveReplace(Replace) - 接口 com.trs.service.IChannelService 中的方法
保存替换内容对象
saveReplace(Replace) - 类 com.trs.service.impl.ChannelService 中的方法
saveRight(Right) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法
保存权限
saveRight(Right) - 类 com.trs.cms.auth.domain.RightMgr 中的方法
saveRoles(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
已过时。
saveRoleUsers(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
绑定角色,站点和用户的关联，同时将清除原来的关联,兼容系统级和非系统级
saveSchedule(JobWorkerType, Schedule, CMSObj) - 类 com.trs.components.common.job.JobScheduleServer 中的静态方法
saveSetting(BaseObj, int, int) - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
保存一个定制
saveSetting(BaseObj, int, int, String) - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
保存一个定制
saveSites(int[]) - 接口 com.trs.service.ICustomizeService 中的方法
保存个人定制的站点集合
saveSites(int[]) - 类 com.trs.service.impl.CustomizeService 中的方法
saveSpecialRolesOfUser(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
保存指定用户的特定角色
saveStatHost(StatHost) - 类 com.trs.service.impl.StatService 中的方法
saveStatHost(StatHost) - 接口 com.trs.service.IStatService 中的方法
保存统计主体（即按xxx查询）
saveStatView(StatView, List) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
保存统计视图模板
其中包括保存视图模板和字段列表
saveStatView(StatView, List) - 类 com.trs.service.impl.StatService 中的方法
saveStatView(StatView, List) - 接口 com.trs.service.IStatService 中的方法
保存统计视图模板
其中包括保存视图模板和字段列表
saveStyleThumb(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
保存上传的风格示意图，该缩略图必须已经上传到webpic下
saveStyleThumb(String) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
保存上传的缩略图
saveStyleThumb(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
保存上传的风格示意图，该缩略图必须已经上传到webpic下
saveStyleThumb(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
保存上传的风格示意图，该缩略图必须已经上传到webpic下
saveStyleThumb(String) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
保存上传的缩略图
saveSynRule(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
为栏目设置同步文档的规则
saveSystemRolesOfUser(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
保存指定用户在指定站点上的系统级角色
saveTemplateArgument(TemplateArgument) - 类 com.trs.service.impl.TemplateService 中的方法
saveTemplateArgument(TemplateArgument) - 接口 com.trs.service.ITemplateService 中的方法
保存指定的TemplateArgument对象
saveToFile(String) - 类 com.trs.infra.util.html.HtmlDocument 中的方法
将Html文档内容保存到文件
saveToTemplate(MethodContext) - 接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider 中的方法
将传入的字符串文本，解析成模板，传入的文本为可视化设计的模板内容，解析之后将建立 资源块实例，资源块实例变量的关系
saveToTemplate(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
saveTRSConfig(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
saveUsersOfSpecialRole(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
将用户添加到特定的角色上，同时将清除原来的关联
saveUsersOfSystemRoleOnSite(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
将用户添加到指定站点的系统级角色上，同时将清除原来的关联
saveView(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
保存指定的视图信息
saveViewByFields(InfoView, List) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
saveViewByFields(InfoView, List) - 接口 com.trs.service.IInfoViewService 中的方法
saveViewByFields(InfoView, List) - 类 com.trs.service.impl.InfoViewService 中的方法
saveViewField(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
保存视图字段信息
saveWidget(User, Widget) - 接口 com.trs.components.common.publish.widget.IWidgetMgr 中的方法
保存资源
saveWidget(User, Widget) - 类 com.trs.components.common.publish.widget.WidgetMgr 中的方法
saveWidgetInstance(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
saveWidgetInstParameters(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
saveWidgetParameter(User, WidgetParameter) - 接口 com.trs.components.common.publish.widget.IWidgetParameterMgr 中的方法
保存资源变量
saveWidgetParameter(User, WidgetParameter) - 类 com.trs.components.common.publish.widget.WidgetParameterMgr 中的方法
scale - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
列的精度
scale(ImageMagickCmd.ImageObj, ImageMagickCmd.ImageObj) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法
SCALE_STYLE_AUTO - 接口 com.trs.wcm.photo.IImageLibConfig 中的静态变量
SCALE_STYLE_HEIGHT - 接口 com.trs.wcm.photo.IImageLibConfig 中的静态变量
SCALE_STYLE_WIDTH - 接口 com.trs.wcm.photo.IImageLibConfig 中的静态变量
scaleImage(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
scaleImage(int, int) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
将指定的图片按照指定的宽度和高度缩放
scaleImage(int, int, String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
scaleImage(int, int) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
scaleImage(int, int, String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
scan(String) - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentScanner 中的方法
scan(Template) - 类 com.trs.components.common.publish.domain.template.TemplateParseAngel 中的静态方法
Scans and parses a template.
scanAll() - 类 com.trs.components.common.publish.domain.template.TemplateParseAngel 中的静态方法
Scans and parses all the unparsed templates in the system.
ScanContext - com.trs.components.common.publish.domain.tagparser 中的 类
扫描模板正文，把正文解析成为置标树的辅助类。
ScanContext(String) - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 的构造方法
构造方法
scanIn(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateParseAngel 中的静态方法
Scans and parses the unparsed templates in the folder.
SceneAutoCreator - com.trs.scene.tools 中的 类
SceneAutoCreator() - 类 com.trs.scene.tools.SceneAutoCreator 的构造方法
SceneConnector - com.trs.scene.parser 中的 类
SceneConnector(int, String) - 类 com.trs.scene.parser.SceneConnector 的构造方法
SceneNode - com.trs.scene.parser 中的 类
SceneNode(int, String) - 类 com.trs.scene.parser.SceneNode 的构造方法
SceneNode - com.trs.scene.tools 中的 类
SceneNode(String, int) - 类 com.trs.scene.tools.SceneNode 的构造方法
SceneNodeAction - com.trs.scene.tools 中的 类
SceneNodeAction(SceneNode) - 类 com.trs.scene.tools.SceneNodeAction 的构造方法
构造函数
SceneNodeParser - com.trs.scene.tools 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分类法定义工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SceneNodeParser() - 类 com.trs.scene.tools.SceneNodeParser 的构造方法
SceneNodeToXML - com.trs.scene.tools 中的 类
SceneNodeToXML() - 类 com.trs.scene.tools.SceneNodeToXML 的构造方法
ScenePathsParser - com.trs.scene.parser 中的 类
ScenePathsParser(SceneNode) - 类 com.trs.scene.parser.ScenePathsParser 的构造方法
SceneServiceProvider - com.trs.ajaxservice 中的 类
SceneServiceProvider() - 类 com.trs.ajaxservice.SceneServiceProvider 的构造方法
SceneXMLParser - com.trs.scene.parser 中的 类
SceneXMLParser(String) - 类 com.trs.scene.parser.SceneXMLParser 的构造方法
Schedule - com.trs.components.common.job 中的 类
Schedule() - 类 com.trs.components.common.job.Schedule 的构造方法
构造函数：保留默认接口
SCHEDULE_PUBTASK - 类 com.trs.infra.common.ContextParameters 中的静态变量
预留索引
计划发布任务使用
ScheduleLCListenerForFaieldResult - com.trs.components.common.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ScheduleLCListenerForFaieldResult() - 类 com.trs.components.common.job.ScheduleLCListenerForFaieldResult 的构造方法
ScheduleLCListenerForServer - com.trs.components.common.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ScheduleLCListenerForServer() - 类 com.trs.components.common.job.ScheduleLCListenerForServer 的构造方法
ScheduleLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ScheduleLogger() - 类 com.trs.components.wcm.logger.ScheduleLogger 的构造方法
ScheduleOper - com.trs.infra.util.upgrade.dataprocess 中的 类
新添加的计划任务
ScheduleOper(String) - 类 com.trs.infra.util.upgrade.dataprocess.ScheduleOper 的构造方法
构造函数
Schedules - com.trs.components.common.job 中的 类
Schedules(User) - 类 com.trs.components.common.job.Schedules 的构造方法
Schedules(User, int, int) - 类 com.trs.components.common.job.Schedules 的构造方法
ScheduleService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
计划服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ScheduleService() - 类 com.trs.service.impl.ScheduleService 的构造方法
scheduleUpdUserRelatedInfo(User, User) - 类 com.trs.cms.auth.domain.UpdUserScheduleCreator 中的静态方法
SchemaCompare - com.trs.infra.util.upgrade.dbcompare 中的 类
数据库比较对象
SchemaCompare(MetaDataLoader, MetaDataLoader) - 类 com.trs.infra.util.upgrade.dbcompare.SchemaCompare 的构造方法
构造函数
SchemaUpdSqlMaker - com.trs.infra.util.upgrade.sql 中的 类
根据比较的差异结果产生更新SQL
SchemaUpdSqlMaker() - 类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker 的构造方法
SchemaUpdSqlMakerFactory - com.trs.infra.util.upgrade.sql 中的 类
sql产生者的工厂类
SchemaUpdSqlMakerFactory() - 类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMakerFactory 的构造方法
sContent - 类 com.trs.infra.util.CMySMS 中的变量
短信息内容
SCRIPT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
SCROLLING - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
sDefaultEncoding - 类 com.trs.tools.ChineseFinder 中的静态变量
search(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
查询指定站点或者指定频道下的文档
SEARCHSCOPE_CONTAINSCHILDREN - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的静态变量
SEARCHSCOPE_SINGLE - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的静态变量
SECOND - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日期/时间的各个部分标识：秒（6）
SecureKey - com.trs.infra.support.security 中的 类
TODO Add javadoc for SecureKeys 描述系统中的密钥对象， 属性有：密钥算法、密钥长度、公钥数据、私钥数据等 关于名称：SecureKey，因为“SecretKey”是一个通用名称，在很多系统API中被采用，虽然在不同的包中使用相同的类名是可以的， 但是为了避免不必要的歧义，故意选择了这个错误的类型名称“SecureKey”。
SecureKey() - 类 com.trs.infra.support.security.SecureKey 的构造方法
SecureKeyMgr - com.trs.infra.support.security 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
SecureKey管理者对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SecureKeyMgr() - 类 com.trs.infra.support.security.SecureKeyMgr 的构造方法
SecureKeys - com.trs.infra.support.security 中的 类
TODO Add javadoc for SecureKeys 密钥对 SecureKey 象的集合
SecureKeys() - 类 com.trs.infra.support.security.SecureKeys 的构造方法
SecureKeys(int, int) - 类 com.trs.infra.support.security.SecureKeys 的构造方法
SecureKeyUtil - com.trs.infra.support.security 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
SecureKeyUtil:工具函数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Securities - com.trs.components.wcm.resource 中的 类
Securities(User) - 类 com.trs.components.wcm.resource.Securities 的构造方法
Securities(User, int, int) - 类 com.trs.components.wcm.resource.Securities 的构造方法
Security - com.trs.components.wcm.resource 中的 类
Security() - 类 com.trs.components.wcm.resource.Security 的构造方法
SecurityService - com.trs.service.impl 中的 类
SecurityService() - 类 com.trs.service.impl.SecurityService 的构造方法
default constructor
SELECT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
selectAndConfigure(URL, String, LoggerRepository) - 类 com.trs.infra.util.OptionConverter 中的静态方法
Configure log4j given a URL.
SELECTED - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
SELF_DEFINED - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量
send(int, int, int, Hashtable) - 类 com.trs.cluster.ClusterMsgCenterImpl 中的方法
发送包含持久化对象的消息 仅仅只有非Cache对象删除时候需要传入Properties
send(String, String[]) - 类 com.trs.cluster.ClusterMsgCenterImpl 中的方法
send(BaseObj, int) - 类 com.trs.cluster.ClusterMsgCenterImpl 中的方法
send(String) - 类 com.trs.cluster.FileMsgProcessor 中的静态方法
更改消息发送
send(int, int, int, Hashtable) - 接口 com.trs.cluster.IClusterMsgCenter 中的方法
发送出指定的消息，消息协议为基于持久化对象拟定
send(BaseObj, int) - 接口 com.trs.cluster.IClusterMsgCenter 中的方法
send(String, String[]) - 接口 com.trs.cluster.IClusterMsgCenter 中的方法
发送出指定的消息，消息协议为自定义
send(int, int, int) - 接口 com.trs.cluster.IClusterMsgSender 中的方法
发送出指定的消息，消息协议为基于持久化对象拟定
send(String, int) - 接口 com.trs.cluster.IClusterMsgSender 中的方法
发送出指定的消息，消息协议为自定义
send(String, String, String, Contact) - 类 com.trs.components.common.address.ContactMsgSender 中的静态方法
给联系人发送消息
send(Message, User) - 类 com.trs.components.common.message.EmailSendWorker 中的方法
send(String, String, String, boolean, boolean) - 接口 com.trs.components.common.message.IMessageService 中的方法
发送短消息给特定的用户集合
send(Message, User) - 接口 com.trs.components.common.message.ISendWorker 中的方法
发送消息
send(Message) - 类 com.trs.components.common.message.MessageServer 中的静态方法
发送消息
send(Message, User) - 类 com.trs.components.common.message.MsgSendWorker 中的方法
send(Message, User) - 类 com.trs.components.common.message.SMSSendWorker 中的方法
send() - 类 com.trs.infra.util.CMySMS 中的方法
发送短消息
send(BufferedWriter, String) - 类 com.trs.infra.util.email.MIMEBase64 中的静态方法
send(CMyEmail) - 类 com.trs.infra.util.email.TRSMailer 中的方法
通过默认的邮件服务器发送邮件
send(CMyEmail, CMySMTPServer) - 类 com.trs.infra.util.email.TRSMailer 中的方法
通过线程去发送邮件
send0(CMyEmail, CMySMTPServer) - 类 com.trs.infra.util.email.TRSMailer 中的方法
通过邮件服务器发送邮件
SendEmailForInfoViewHandler - com.trs.components.infoview.process 中的 类
SendEmailForInfoViewHandler() - 类 com.trs.components.infoview.process.SendEmailForInfoViewHandler 的构造方法
sendFile(byte[], String, String) - 类 com.trs.components.wcm.soap.FileService 中的静态方法
sendFileBase64(String, String, String) - 类 com.trs.components.wcm.soap.WordFileService 中的静态方法
已过时。 表达的意思和执行的操作不一致,已经使用新的接口[receiveFileByBase64]替代
sendFileBase64(String, String, String) - 类 com.trs.service.impl.SOAPServiceImpl 中的方法
sendFileBase64(String, String, String) - 接口 com.trs.service.ISOAPService 中的方法
上传指定的文件
sendMessage(MethodContext) - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法
发送消息
sendMsg(Serializable) - 类 com.trs.cluster.TRSWCMClusterServer 中的方法
发送消息
sendNotice() - 类 com.trs.components.infoview.InfoViewReplyNoticeSender 中的方法
sendRedirect(String) - 类 com.trs.presentation.util.RequestHelper 中的方法
借助“..
sendRemindMessage(int, int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
给指定的用户发送指定媒体的消息
sendReplyNotice(int, int, int, boolean, boolean) - 接口 com.trs.service.IInfoViewService 中的方法
发送表单文档的回复通知
优先使用表单上的设置
sendReplyNotice(InfoView, Document, DocReply, boolean, boolean) - 接口 com.trs.service.IInfoViewService 中的方法
发送表单文档的回复通知
优先使用表单上的设置
sendReplyNotice(int, int, int, boolean, boolean) - 类 com.trs.service.impl.InfoViewService 中的方法
sendReplyNotice(InfoView, Document, DocReply, boolean, boolean) - 类 com.trs.service.impl.InfoViewService 中的方法
sendWarning(String, String, User, Object, String) - 接口 com.trs.components.wcm.util.ISystemWarner 中的方法
发送警告信息到指定用户
sendWarning(String, String, User, Object, String) - 类 com.trs.components.wcm.util.SystemWarnerMsgImpl 中的方法
separatePages(String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Separate pages from the specified text
separatePages(PublishTagContext, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPages 中的方法
separatePages(PublishTagContext, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 中的方法
separatePagesOld(String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
已过时。
SERIAL_PERIOD_DAY - 类 com.trs.components.infoview.persistent.InfoViewSerial 中的静态变量
序号跳变精度标识:每天
SERIAL_PERIOD_FORERVER - 类 com.trs.components.infoview.persistent.InfoViewSerial 中的静态变量
序号跳变精度标识:从不
SERIAL_PERIOD_MONTH - 类 com.trs.components.infoview.persistent.InfoViewSerial 中的静态变量
序号跳变精度标识:每月
SERIAL_PERIOD_YEAR - 类 com.trs.components.infoview.persistent.InfoViewSerial 中的静态变量
序号跳变精度标识:每年
SERIALNUM - 类 com.trs.components.wcm.content.persistent.MySystemInfo 中的静态变量
ServerConfig - com.trs.infra 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
服务器对象的配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServerConfig() - 类 com.trs.infra.ServerConfig 的构造方法
ServerControl - com.trs.infra 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
服务器控制器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServerControl() - 类 com.trs.infra.ServerControl 的构造方法
SERVICE_ID - 类 com.trs.components.metadata.service.DefaultChannelMakerCenter 中的静态变量
SERVICE_REQEUST_ENCODING - 类 com.trs.infra.util.HttpClientBuddy 中的静态变量
向wcm发送数据时的流写编码
ServiceConfig - com.trs.webframework.config 中的 类
ServiceConfig(String) - 类 com.trs.webframework.config.ServiceConfig 的构造方法
ServiceConfigHelper - com.trs.webframework.config 中的 类
ServiceConfigHelper() - 类 com.trs.webframework.config.ServiceConfigHelper 的构造方法
ServiceConfigStartServer - com.trs.webframework.config 中的 类
ServiceConfigStartServer() - 类 com.trs.webframework.config.ServiceConfigStartServer 的构造方法
ServiceConstants - com.trs.ajaxservice 中的 类
ServiceConstants() - 类 com.trs.ajaxservice.ServiceConstants 的构造方法
ServiceContext - com.trs.webframework.context 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
Service上下文信息记录对象
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceContext() - 类 com.trs.webframework.context.ServiceContext 的构造方法
ServiceContext(HttpServletRequest, HttpServletResponse) - 类 com.trs.webframework.context.ServiceContext 的构造方法
ServiceControler - com.trs.webframework.controler.servlet 中的 类
ServiceControler() - 类 com.trs.webframework.controler.servlet.ServiceControler 的构造方法
ServiceCreationFailException - com.trs.webframework.exception 中的 异常
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceCreationFailException() - 异常 com.trs.webframework.exception.ServiceCreationFailException 的构造方法
ServiceCreationFailException(String) - 异常 com.trs.webframework.exception.ServiceCreationFailException 的构造方法
ServiceCreationFailException(Throwable) - 异常 com.trs.webframework.exception.ServiceCreationFailException 的构造方法
ServiceCreationFailException(String, Throwable) - 异常 com.trs.webframework.exception.ServiceCreationFailException 的构造方法
ServiceExcuteLogger - com.trs.webframework 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
服务操作日志记录
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ServiceFilterConfig - com.trs.webframework.config 中的 类
ServiceFilterConfig(String, String, String) - 类 com.trs.webframework.config.ServiceFilterConfig 的构造方法
ServiceFilterConfigs - com.trs.webframework.config 中的 类
ServiceFilterConfigs() - 类 com.trs.webframework.config.ServiceFilterConfigs 的构造方法
ServiceFilterExample - com.trs.webframework.provider 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceFilterExample() - 类 com.trs.webframework.provider.ServiceFilterExample 的构造方法
ServiceHelper - com.trs.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Service解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceHelper() - 类 com.trs.service.ServiceHelper 的构造方法
ServiceInvocationException - com.trs.webframework.exception 中的 异常
ServiceInvocationException() - 异常 com.trs.webframework.exception.ServiceInvocationException 的构造方法
ServiceInvocationException(String) - 异常 com.trs.webframework.exception.ServiceInvocationException 的构造方法
ServiceInvocationException(Throwable) - 异常 com.trs.webframework.exception.ServiceInvocationException 的构造方法
ServiceInvocationException(String, Throwable) - 异常 com.trs.webframework.exception.ServiceInvocationException 的构造方法
ServiceInvocationException(String, Throwable, String) - 异常 com.trs.webframework.exception.ServiceInvocationException 的构造方法
ServiceListenerConfig - com.trs.webframework.config 中的 类
ServiceListenerConfig(String, String, String) - 类 com.trs.webframework.config.ServiceListenerConfig 的构造方法
ServiceListenerConfigs - com.trs.webframework.config 中的 类
ServiceListenerConfigs() - 类 com.trs.webframework.config.ServiceListenerConfigs 的构造方法
ServiceListenerExample - com.trs.webframework.provider 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ServiceListenerExample() - 类 com.trs.webframework.provider.ServiceListenerExample 的构造方法
ServletInputStreamWrapper - com.trs.webframework.xmlserver.parser 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
ServletInputStreamWrapper
ServletInputStreamWrapper(InputStream) - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 的构造方法
SESSION_NAME_USER - 类 com.trs.presentation.util.LoginHelper 中的静态变量
当前登录用户在Session中存放的名称
SessionListener - com.trs.presentation.login 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SessionListener(Integer) - 类 com.trs.presentation.login.SessionListener 的构造方法
set(String, String) - 类 com.trs.components.wcm.channel.VChannel 中的方法
set(int, Object) - 类 com.trs.infra.common.ContextParameters 中的静态方法
在指定的索引位置上设置参数
set(String, Object) - 类 com.trs.infra.persistent.BaseObjs 中的方法
设置集合当前元素的属性
set(String) - 类 com.trs.infra.support.config.PathConfig 中的方法
使用组合字符串设置属性值 字符串格式：Flag;LocalPath;HttpPath;FtpPath
set0(Object) - 类 com.trs.infra.common.ContextParameters 中的静态方法
快速设置第一个参数，等价于set(0, parameter)。
set1(Object) - 类 com.trs.infra.common.ContextParameters 中的静态方法
快速设置第二个参数，等价于set(1, parameter)。
set2(Object) - 类 com.trs.infra.common.ContextParameters 中的静态方法
快速设置第三个参数，等价于set(2, parameter)。
SET_CANPUB - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：是否能够发布(2)
SET_CHNL_USER - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：文档流转是否考虑频道上的权限(9)
SET_CLICK_PREVIEW - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：点击文档直接打开预览页面(8)
SET_FLOW_EMPLOY_RIGHTS - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
SET_INHERIT_DETAIL - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：是否继承细览模板(4)
SET_INHERIT_EXTEND - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：是否继承父对象的扩展字段(7)
SET_INHERIT_OUTLINE - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：是否继承概览模板(5)
SET_INHERIT_RIGHT - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：是否继承权限设置(6)
SET_ONLYMANAGER - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：是否仅仅用于管理(3)
SET_ONLYSEARCH - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：是否只使用检索条件检索(1)
setAbstract(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置摘要
setAccepted() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置签收
setAcceptTime() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
使用当前时间设置确认处理时间
setAction(String) - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法
setActionDesc(String) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：ActionDesc
setActionFlag(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：ActionFlag
setAdAction(String) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdAction
setAdAttribute(String) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdAttribute
setAdBegin(CMyDateTime) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdBegin
setAdBegin(CMyDateTime) - 类 com.trs.components.common.trsad.ADFilePos 中的方法
设置属性：AdBegin
setAdCompany(int) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdCompany
setAdCrTime(CMyDateTime) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdCrTime
setAdCrUser(String) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdCrUser
setAddEditFields(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法
setAdden(int) - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法
setAdDesc(String) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdDesc
setAdditionalData(String) - 类 com.trs.components.comment.domain.NewsComment 中的方法
setAddMark(boolean) - 类 com.trs.wcm.photo.ImageInfo 中的方法
setAddMode(boolean) - 类 com.trs.cms.content.DefaultObj 中的方法
setAddMode(boolean) - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
setAddMode(boolean) - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
setAddMode(boolean) - 类 com.trs.infra.persistent.MyBaseObj 中的方法
setAddress(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置联系地址
setAddress(String) - 类 com.trs.components.common.address.Contact 中的方法
setAddress(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：Address
setAddRoot(boolean) - 类 com.trs.presentation.nav.RadarTreeCreator 中的方法
setAddVersion(boolean) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
setAdEnd(CMyDateTime) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdEnd
setAdEnd(CMyDateTime) - 类 com.trs.components.common.trsad.ADFilePos 中的方法
设置属性：AdEnd
setAdExt(String) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdExt
setAdFileId(int) - 类 com.trs.components.common.trsad.ADFilePos 中的方法
设置属性：AdFileId
setAdFileKind(int) - 类 com.trs.components.common.trsad.ADType 中的方法
设置属性：AdFileKind
setAdFileName(String) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdFileName广告文件名
setAdFlag(int) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdFlag
setAdHeight(int) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdHeight
setAdHit(int) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdHit
setAdIsWork(int) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdIsWork
setAdName(String) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdName广告名称
setAdPosId(int) - 类 com.trs.components.common.trsad.ADFilePos 中的方法
设置属性：AdPosId
setAdPrice(int) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdPrice
setAdTagHit(int) - 类 com.trs.components.common.trsad.ADFilePos 中的方法
设置属性：AdTagHit
setAdType(int) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdType
setAdTypeName(String) - 类 com.trs.components.common.trsad.ADType 中的方法
设置属性：AdTypeName
setAdUrl(String) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdUrl
setAdWidth(int) - 类 com.trs.components.common.trsad.ADFile 中的方法
设置属性：AdWidth
setAheadRemindTime(int) - 类 com.trs.components.common.calendar.Event 中的方法
setAlgorithm(String) - 类 com.trs.infra.support.security.SecureKey 中的方法
设定密钥算法
setAllFileList(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
setAlt(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件显示的ALT
setAnalyzeError(String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：AnalyzeError
setAnonymous(boolean) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：ANONYMFTP，是否在FTP登录中使用匿名方式 为了避免在某些数据库中可能存在的冲突，所以没有使用“Anonymous”作为字段名，而是使用了“ANONYMFTP”
setAnonymous(boolean) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置在FTP登录中是否使用匿名方式
setAnotherChar(String) - 类 com.trs.infra.util.CMyEncrypt 中的静态方法
设置另一种加密算法
setAnotherName(String) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：AnotherName
setAnotherName(String) - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
设置属性：AnotherName
setAnotherName(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：AnotherName
setApdModified(boolean) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板附件是否被修改的标记
setApdProperty(int) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件的属性
setAppendixField(String, String, int) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
给指定的附件类型设置字段值
setAppendixId(int) - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
设置属性：APPENDIXID
setAppendParameters(String[]) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
设置追加的参数
setApplyDesc(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：ApplyDesc
setApplyDesc(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
设置属性：APPLYDESC
setApplyerName(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：ApplyerName
setApplyerName(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
设置属性：ApplyerName
setApplyerType(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：ApplyerType
setApplyType(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：_nApplyType
setArg(int, Object) - 类 com.trs.cms.ContextHelper 中的静态方法
在扩展参数列表的第_nIndex个位置设置参数对象_currObj 处理策略：
1.
setArg(int, Object) - 类 com.trs.infra.common.BaseContextHelper 中的静态方法
在扩展参数列表的第_nIndex个位置设置参数对象_currObj 处理策略：
1.
setArg(int, Object) - 类 com.trs.infra.common.ContextTL 中的方法
在扩展参数列表的第_nIndex个位置设置参数 处理逻辑：
setArgs(ArrayList) - 类 com.trs.infra.common.ContextTL 中的方法
设置用户自定义的扩展参数列表 处理逻辑：
1.
setArgumentName(String) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
设置属性：ArgumentName
setArgumentValue(String) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
设置属性：ArgumentValue
setArgumentValue(int) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
设置属性：ArgumentValue
setArgumentValue(boolean) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
设置属性：ArgumentValue
setAssociationPerson(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：AssociationPerson
setAsyncMode(boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
setAttachedFile(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
添加附件
setAttachedFile(String, String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
setAttachPic(boolean) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
setAttribute(String) - 类 com.trs.cms.content.ExtendedField 中的方法
设置扩展字段的扩展属性
setAttribute(String, String) - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法
setAttribute(String) - 类 com.trs.cms.process.definition.Flow 中的方法
setAttribute(String) - 类 com.trs.components.common.address.Contact 中的方法
setAttribute(String) - 类 com.trs.components.common.address.ContactGrp 中的方法
setAttribute(String) - 类 com.trs.components.common.bookmark.BookMark 中的方法
setAttribute(String) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
setAttribute(String) - 类 com.trs.components.common.bookmark.MarkShare 中的方法
setAttribute(String) - 类 com.trs.components.common.calendar.Event 中的方法
setAttribute(String) - 类 com.trs.components.common.message.Message 中的方法
setAttribute(String, String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
Sets the value of a attribute
setAttribute(String, int) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
Sets the value of a attribute
setAttribute(String, boolean) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
Sets the value of a boolean property.
setAttribute(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件的属性
setAttribute(String) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
设置扩展字段的扩展属性
setAttribute(String) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
setAttribute(String) - 类 com.trs.components.wcm.individuation.Individuation 中的方法
设置属性：Attribute
setAttribute(String) - 类 com.trs.components.wcm.resource.DocKind 中的方法
setAttribute(String) - 类 com.trs.components.wcm.resource.Source 中的方法
设置属性（用于扩展）
setAttribute(String) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
设置属性：Attribute
setAttribute(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
共用接口：属性创建扩展属性Attribute写操作 说明：子类可以通过重载禁止使用
setAttribute(AttributesString) - 类 com.trs.infra.persistent.BaseObj 中的方法
setAttribute(String, String) - 类 com.trs.infra.persistent.BaseObj 中的方法
设置扩展属性
setAttribute(String, String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
设置指定属性的值
setAttribute(String, String, char) - 类 com.trs.infra.util.html.HtmlElement 中的方法
setAttribute(HtmlAttribute) - 类 com.trs.infra.util.html.HtmlElement 中的方法
设置属性
setAttributes(String) - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法
setAttributes(HashMap) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
setAttributes(String) - 类 com.trs.infra.util.AttributesString 中的方法
直接用属性字符串设置属性
setAttributes(List) - 类 com.trs.infra.util.html.HtmlElement 中的方法
设置元素的属性
setAtuoEnable(boolean) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置是否启动文档中的图片自动保存到图片库中
setAtuoEnable(boolean) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
setAuditor(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置审稿者(可能有多个)
setAuditor(User) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置审稿者(可能有多个)
setAuth(boolean) - 类 com.trs.infra.util.email.CMySMTPServer 中的方法
setAuth(boolean) - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法
setAuthDetail(String, String, String) - 类 com.trs.components.metadata.service.util.WCMJSPChecker 中的方法
setAuthDetail(String, String, String) - 类 com.trs.presentation.jsputil.JspChecker 中的方法
setAuthor(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件的作者
setAuthor(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置作者
setAuthor(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法
设置作者信息
setAutoPublishDocInHomeWhenNeeded(boolean) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setBackgroundColor(String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
设置背景颜色
setBackgroundColor(String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
setBackReadOnly(boolean) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setBakUser(String) - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
设置备份用户
setBakUser(User) - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
设置备份用户
setBakUser(String) - 类 com.trs.infra.support.log.LogBak 中的方法
设置备份用户
setBaseDir(String) - 类 com.trs.template.domain.XTemplateExporter.HierarchyEntity 中的方法
setBaseName(String) - 类 com.trs.components.infoview.extract.DataType 中的方法
setBaseType(DataType) - 类 com.trs.components.infoview.extract.DataType 中的方法
setBatchMode(boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
setBcc(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置密送地址
setBeanId(String) - 类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 中的方法
setBeanId(String) - 类 com.trs.infra.ServerConfig 中的方法
setBeanId(String) - 类 com.trs.infra.support.cache.CacheMgrConfig 中的方法
setBeans(ArrayList) - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
setBeginColumn(int) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
设置置标的开始位置在模板正文中的列号
setBeginIndex(int) - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法
setBeginLineNo(int) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
设置置标的开始位置在模板正文中的行号
setBindName(String) - 类 com.trs.components.infoview.extract.DataType 中的方法
setBit(long, int, boolean) - 类 com.trs.infra.util.CMyBitsValue 中的静态方法
设置长整型数据中指定位置的bit值
setBit(int, boolean) - 类 com.trs.infra.util.CMyBitsValue 中的方法
设置指定bit位置的值
setBody(String) - 类 com.trs.components.common.message.Message 中的方法
setBody(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置邮件内容
setBody(byte[]) - 类 com.trs.infra.util.ResponseBuddy 中的方法
setBonusType(int) - 类 com.trs.components.stat.BonusRule 中的方法
设置属性：BonusType。
setBranchId(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：BranchId
setBranchSerialNum(long) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
setButton(ArrayList) - 类 com.trs.components.infoview.extract.manifest.MenuArea 中的方法
setCacheMaxSize(int) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
set the maximum size of the cache
setCacheScheme(String) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setCacheSize(int) - 类 com.trs.infra.util.database.DBIdManager.IdSeq 中的方法
设置缓冲池大小
setCancel(boolean) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
setCanCustom(boolean) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置是否可以定制变量取值，不能定制变量取值，即只能从现有的枚举值中选择。
setCanPub(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置是否允许发布
setCanSavedDocStatus(String) - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
设置可以自动保存的文档状态
setCaption(String) - 类 com.trs.components.infoview.extract.manifest.FileNew 中的方法
已过时。
setCaption(String) - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法
setCaption(String) - 类 com.trs.components.infoview.extract.manifest.View 中的方法
setCategory(int) - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
设置属性：Category
setCause(RuntimeException) - 类 com.trs.webframework.config.LoadingErrorReport 中的方法
setCc(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置抄送地址
setCDefaultStyle(int) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：CDefaultStyle
setCellIndex(int) - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
设置属性：CellIndex
setCellNum(int) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
设置属性：CellNum
setCeneterX(int) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设置X坐标（用于可视化编辑）
setCeneterY(int) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设置Y坐标（用于可视化编辑）
setCertificateCode(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：CertificateCode
setCertificateName(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：CertificateName
setChangeStatus(Status) - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法
setChannel(int, String) - 类 com.trs.components.comment.domain.Management 中的方法
设置WCM中的频道ID和频道名(可选的)
setChannel(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档所属频道
setChannel(Channel) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档所属频道
setChannel(int) - 类 com.trs.wcm.old.WCMExcelData 中的方法
设置所属频道
setChannel(Channel) - 类 com.trs.wcm.old.WCMExcelData 中的方法
设置所属频道
setChannelDesc(String) - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
setChannelEmployersOfFlow(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
批量维护工作流的配置情况
setChannelEmployersOfTemplate(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceHelperProvider 中的方法
setChannelId(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：ChannelId
setChannelId(int) - 类 com.trs.components.comment.domain.NewsComment 中的方法
设置频道 ID
setChannelId(int) - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
设置属性：ChannelId
setChannelId(int) - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法
setChannelId(int) - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
setChannelID(int) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setChannelId(int) - 类 com.trs.components.stat.ChnlDept 中的方法
设置属性：ChannelId
setChannelId(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置属性：ChannelId
setChannelId(int) - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的方法
setChannelId(int) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
设置属性：ChannelId
setChannelId(int) - 类 com.trs.service.InfoViewContext 中的方法
setChannelId(int) - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
setChannelId(int) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置表单所属的频道ID
setChannelName(String) - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
setCharSet(String) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板的字符集属性,应该模板内容中的charset一致.
setChartCategory(int) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
setChartFileExt(String) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
setChartHeight(int) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
setChartSubtitle(String) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
setChartTitle(String) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
setChartWidth(int) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
setCheckedSiteId(boolean) - 类 com.trs.components.wcm.resource.Source 中的方法
设置校验来源重名时是否需要校验所属站点属性 默认为不校验
setCheckedUser(int) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法
设置属性：CheckedUser
setCheckWriteAuth(boolean) - 类 com.trs.infra.util.ftp.FtpMgr 中的方法
设置初始化的时候是否需要校验写权限
setChildren(List) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
setChildren(int) - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
setChnlDocProperty(String, Object) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
setChnlDocProperty(String, Object) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
setChnlId(int) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
设置属性：ChnlId 栏目ID
setChnlId(int) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
设置所属栏目
setChnlId(int) - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
设置所属频道
setChnlId(int) - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
设置属性：CHNLID
setChnlName(String) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
设置属性：ChnlName 栏目名称
setChnlProperty(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道属性
setCKMServer(String, String, String, String) - 接口 com.trs.components.ckm.ICKMServer 中的方法
设置CKM服务器
setCKMServer(String, String, String, String) - 类 com.trs.components.ckm.TRSCKMServer 中的方法
setClassField(String) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
setClassId(int) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：CLASSID
setClassId(int) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setClassId(int) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：ClassId
setClassId(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：ClassId
setClassInfoId(int) - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
设置属性：ClassInfoId
setClassInfoIds(String) - 类 com.trs.components.metadata.service.GovInfoToXML 中的静态方法
设置要处理的分类法序列，如：214，349表示处理分类法id为214和349的分类法
setClassName(String) - 类 com.trs.cms.auth.config.RightHostConfig 中的方法
setClassName(String) - 类 com.trs.cms.auth.config.RightObjectConfig 中的方法
setClassName(String) - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法
setClassName(String) - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法
setClassName(String) - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
setClassName(String) - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法
setClassName(String) - 类 com.trs.components.common.publish.config.persistent.PublishElementConfig 中的方法
setClassName(String) - 类 com.trs.components.common.publish.config.persistent.TagFormatterConfig 中的方法
setClassName(String) - 类 com.trs.components.common.publish.config.PublishElementType 中的方法
setClassName(String) - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
设置属性：ClassName
setClassname(String) - 类 com.trs.components.infoview.config.BindingBean 中的方法
setClassName(String) - 类 com.trs.infra.config.persistent.BeanConfig 中的方法
setClassName(String) - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法
setClassName(String) - 类 com.trs.infra.persistent.cache.CachedObjectConfig 中的方法
setClassName(String) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setClassName(String) - 类 com.trs.infra.persistent.listener.MonitorHostConfig 中的方法
setClassName(String) - 类 com.trs.webframework.config.ServiceFilterConfig 中的方法
setClassName(String) - 类 com.trs.webframework.config.ServiceListenerConfig 中的方法
setClassNsme(String) - 类 com.trs.infra.persistent.listener.ObjectMonitored 中的方法
setClassValue(String) - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
设置属性：ClassValue
setClickPreview(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置点击文档时是否直接预览页面
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.CAS400CLOB 中的静态方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String) - 类 com.trs.infra.util.database.CAS400CLOB 中的静态方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.CAS400CLOB 中的静态方法
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.CDB2DBCLOB 中的静态方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String) - 类 com.trs.infra.util.database.CDB2DBCLOB 中的静态方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.CDB2DBCLOB 中的静态方法
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.CDB2DBCLOB2 中的静态方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String) - 类 com.trs.infra.util.database.CDB2DBCLOB2 中的静态方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.CDB2DBCLOB2 中的静态方法
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
setClob(Connection, String, String, String) - 类 com.trs.infra.util.database.CMysqlText 中的静态方法
根据更新语句设置Clob/text字段内容
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.CMysqlText 中的静态方法
根据条件写入Clob/text内容
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.CMysqlText 中的静态方法
根据条件同时写入多个Clob/text内容
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.COracleCLOB 中的静态方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String) - 类 com.trs.infra.util.database.COracleCLOB 中的静态方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.COracleCLOB 中的静态方法
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.DB2UDB 中的方法
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.DB2UDB2 中的方法
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.DBType 中的方法
将Clob/Text型字段值写入数据库
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.DBType 中的方法
将Clob/Text型字段值写入数据库 适用：同时改写多个CLOB字段的情况
setClob(Connection, String, String, int, String, String) - 类 com.trs.infra.util.database.DBType 中的方法
setClob(Connection, String, String, int, String[]) - 类 com.trs.infra.util.database.DBType 中的方法
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.MysqlDB 中的方法
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.OracleDB 中的方法
setClob(Connection, String, String, int, String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法
setClob(Connection, String, String, int, String[]) - 类 com.trs.infra.util.database.OracleDB 中的方法
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.OracleDB11G 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.OracleDB11G 中的方法
setClob(Connection, String, String, int, String[]) - 类 com.trs.infra.util.database.OracleDB11G 中的方法
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.SybaseASE 中的方法
setClob(Connection, String, String, String) - 类 com.trs.infra.util.database.SybaseASEText 中的静态方法
根据更新语句设置Clob/text字段内容
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.SybaseASEText 中的静态方法
根据条件写入Clob/text内容
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.SybaseASEText 中的静态方法
根据条件同时写入多个Clob/text内容
setClob(Connection, String, String, String, String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
setClob(Connection, String, String, String, String[]) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
setCloseColumn(int) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
设置置标的结束位置在模板正文中的列号
setCloseLineNo(int) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
设置置标的结束位置在模板正文中的行号
setCluster(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
setCmds(Map) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法
setCode(String) - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
设置属性：Code
setCode(String) - 类 com.trs.components.wcm.resource.DocKind 中的方法
setCode(int) - 异常 com.trs.template.AbstractErrorMessage 中的方法
设置错误号
setColumns(int) - 类 com.trs.components.common.publish.widget.Layout 中的方法
设置属性：Columns
setColumns(SortedMap) - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法
setComAddress(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComAddress公司联系地址
setComContact(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComContact联系人
setComConTit(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComConTit
setComCrtime(CMyDateTime) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComCrtime记录创建时间
setComCruser(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComCruser记录创建人
setComDesc(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComDesc公司介绍信息
setComEmail(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComEmail公司Email
setCommanderClassName(String) - 类 com.trs.infra.update.UpdateCommanderConfig 中的方法
setComment(String) - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Sets the entry comment.
setComment(String) - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
Set the zip file comment.
setComMobile(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComMobile 公司联系人移动电话
setComName(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComName公司名称
setComPeople(int) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComPeople
setComplexType(boolean) - 类 com.trs.components.infoview.extract.DataType 中的方法
setCompositeOp(int) - 类 com.trs.wcm.photo.impl.JImageMarkUtil 中的静态方法
设置水印合成时使用的模式
setCompressedSize(long) - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Sets the size of the compressed data.
setComPubN(int) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComPubN 该公司发布广告的数量
setComTel(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComTel公司联系电话
setComUrl(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComUrl公司网址
setComZipcode(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComZipcode公司邮编
setComZo(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComZo
setComZone(String) - 类 com.trs.components.common.trsad.ADCom 中的方法
设置属性：ComZone公司区域
setConfig(CacheMgrConfig[]) - 类 com.trs.infra.support.cache.CacheServer 中的方法
setConfigClass(Class) - 类 com.trs.infra.util.CMyXMLHandler 中的方法
setConfigElements(ArrayList) - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法
setConfigKey(String) - 类 com.trs.infra.support.config.Config 中的方法
设置配置主键 要求：相同Type的配置记录不重名； 处理：区分大小写，由isValid函数检查
setConfigPath(String) - 类 com.trs.infra.config.BaseConfigServer 中的方法
setConnectionInfo(String, String, String, String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
设置FTP服务器的连接信息
setConnectionInfo(String, String, String, String, boolean) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
setConnectionPassword(String) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setConnectionURL(String) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setConnectionUser(String) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setContainsChildren(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
setContainsChildrenChnl(boolean) - 类 com.trs.components.stat.ChnlDept 中的方法
设置属性：ContainsChildrenChnl
setContent(IFlowContent) - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
setContent(int, int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置相关内容
setContent(IFlowContent) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置相关内容
setContent(int, int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
set the property of ContentTypeConfig
setContent(IPublishContent) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
set the property of ContentTypeConfig
setContent(int, String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
set the property of ContentTypeConfig
setContent(IPublishContent) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
set the property of ContentTypeConfig
setContent(String) - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
设置回复内容
setContent(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档的文本正文
setContent(String) - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
设置替换内容
setContent(String) - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
设置属性：Content
setContent(String) - 类 com.trs.infra.util.CMySMS 中的方法
设置短信息内容
setContent(List) - 类 com.trs.infra.util.html.HtmlDocument 中的方法
设置Html文档内容,要求：有且仅有一个根元素
setContentFields(FlowContentField[]) - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
setContentFlow(Flow) - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
setContentId(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
setContentStyle(String) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：ContentStyle
setContentType(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
setContentType(int) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法
setContentType(String) - 类 com.trs.infra.util.ResponseBuddy 中的方法
setContentType(String) - 类 com.trs.webframework.context.MethodContext 中的方法
setContentType(String) - 类 com.trs.webframework.context.ServiceContext 中的方法
setContentTypeConfig(FlowContentTypeConfig) - 类 com.trs.cms.process.config.FlowContentField 中的方法
setContentTypeConfigs(FlowContentTypeConfig[]) - 类 com.trs.cms.process.config.FlowConfigServer 中的方法
setContentTypeIsHTML() - 类 com.trs.webframework.context.MethodContext 中的方法
setContentTypeIsHTML() - 类 com.trs.webframework.context.ServiceContext 中的方法
setContentTypes(ArrayList) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setContextMenuArea(MenuArea) - 类 com.trs.components.infoview.extract.manifest.View 中的方法
setContextMenuMap(HashMap) - 类 com.trs.components.infoview.extract.manifest.View 中的方法
setConvertToImageType(String) - 类 com.trs.wcm.photo.ImageInfo 中的方法
setCrc(long) - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Sets the crc of the uncompressed data.
setCrTime(CMyDateTime) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
设置属性：CrTime
setCrTime(CMyDateTime) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：CrTime
setCrtParamsCount(int) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法
setCrUser(String) - 类 com.trs.cms.content.CMSObj 中的方法
共用接口：属性创建用户CrUser写操作 说明：子类可以通过重载禁止使用
setCrUser(User) - 类 com.trs.cms.content.CMSObj 中的方法
setCrUserId(int) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
设置属性：CrUserId
setCrUserId(int) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：CrUserId
setCssFlag(String) - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
设置属性：风格标识
setCssFlag(String) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
设置属性：风格标识
setCssFlag(String) - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
设置属性：CssFlag
setCurrChannel(Channel) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
设置当前栏目
setCurrContext(ImportDocsContext) - 类 com.trs.wcm.old.ImportDocsFromFile 中的方法
设置上下文对象
setCurrentObj(BaseObj) - 类 com.trs.infra.persistent.XmlObject 中的方法
setCurrentPageIndex(int) - 类 com.trs.infra.util.CPager 中的方法
设置目前的所在的页面
setCurrentStartIndex(int) - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
setCurrFlowContext(FlowContext) - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法
setCurrFlowDoc(FlowDoc) - 类 com.trs.cms.process.engine.FlowContext 中的方法
setCurrFlowDoc(FlowDoc) - 类 com.trs.cms.process.engine.FlowParamers 中的方法
setCurrHost(BaseObj) - 类 com.trs.webframework.context.MethodContext 中的方法
设置当前方法时候关联的主要对象
setCurrHost(BaseObj) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
设置当前方法时候关联的主要对象
setCurrImportFile(String) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
setCurrMediaCount(int, int, int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
给指定媒体指定用户累计的条数
setCurrMediaCount(int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
设置属性：CurrMediaCount
setCurrNode(FlowNode) - 类 com.trs.cms.process.engine.FlowContext 中的方法
设置当前节点
setCurrPage(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
属性设置：当前页码
setCurrStageField(String) - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
setCurrTrueFileName(String) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
当前导入的真实文件名
setCurrUser(User) - 类 com.trs.cms.content.CMSBaseObjs 中的方法
setCurrUser(User) - 类 com.trs.cms.process.engine.FlowContext 中的方法
setCurrUser(User) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法
setCurrUser(User) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
设置当前的交互用户
setCustomizedChannels(String) - 接口 com.trs.service.ICustomizeService 中的方法
设置定制的频道
setCustomizedChannels(String) - 类 com.trs.service.impl.CustomizeService 中的方法
setCustomStyle(String) - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
设置属性：自定义样式
setCustomStyle(String) - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
设置属性：自定义样式
setCustomStyle(String) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
设置属性：自定义的风格样式
setCutSize(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
设置CutSize
setData(Map) - 类 com.trs.components.wcm.stat.domain.StatDataItem 中的方法
setDataControl(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setDataName(String) - 类 com.trs.components.infoview.extract.DataType 中的方法
setDataPath(String) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：DataPath
setDataPath(String) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
设置属性：DataPath
setDataPath(String) - 类 com.trs.components.wcm.channel.VChannel 中的方法
setDataPath(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置数据存放的本地路径（相对路径）
setDataPath(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：DataPath
setDataPath(String) - 类 com.trs.wcm.photo.ImageKind 中的方法
setDataPattern(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setDataset(TimingChartData) - 类 com.trs.components.wcm.stat.domain.TimingChartProducer 中的方法
setDataType(String) - 类 com.trs.components.infoview.config.BindingBean 中的方法
setDataType(DataType) - 类 com.trs.components.infoview.extract.DataType 中的方法
setDataType(int) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setDataType(int) - 类 com.trs.infra.persistent.NullValue 中的方法
setDate(Date) - 类 com.trs.infra.util.CMyDateTime 中的方法
设置日期值
说明：若当前日期时间非空，则仅改变日期值，时间值保持不变
setDateTime(Date) - 类 com.trs.infra.util.CMyDateTime 中的方法
使用 java.util.Date 对象设置日期和时间
setDateTimeFormat(String) - 类 com.trs.infra.util.CMyDateTime 中的方法
设置日期时间字符串格式
setDateTimeWithCurrentTime() - 类 com.trs.infra.util.CMyDateTime 中的方法
设置日期和时间为系统当前日期时间
setDateTimeWithRs(ResultSet, int) - 类 com.trs.infra.util.CMyDateTime 中的方法
从记录集当前行读取指定日期/时间字段的值
setDateTimeWithRs(ResultSet, String) - 类 com.trs.infra.util.CMyDateTime 中的方法
从记录集当前行读取指定日期/时间字段的值
setDateTimeWithString(String, String) - 类 com.trs.infra.util.CMyDateTime 中的方法
使用字符串设置日期和时间
setDateTimeWithString(String) - 类 com.trs.infra.util.CMyDateTime 中的方法
使用未知格式的字符串值设置日期时间
setDateTimeWithTimestamp(Timestamp) - 类 com.trs.infra.util.CMyDateTime 中的方法
使用Timestamp对象设置日期和时间
setDateWithString(String, int) - 类 com.trs.infra.util.CMyDateTime 中的方法
使用字符串设置日期值
setDB2SQL(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：DB2SQL
setDBConfig(DBConnectionConfig) - 类 com.trs.infra.persistent.db.DBManager 中的方法
设置当前所使用的数据库配置
setDBConnectionConfigColl(ArrayList) - 类 com.trs.infra.persistent.db.DBConnectionConfigs 中的方法
setDBField(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：DBField
setDBName(String) - 类 com.trs.cms.process.config.FlowContentField 中的方法
setDBName(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：物理字段名称
setDBName(String) - 类 com.trs.wcm.old.WCMFormFields 中的方法
设置属性：DBName
setDbTableName(String) - 类 com.trs.cms.content.DefaultObj 中的方法
setDbTableName(String) - 类 com.trs.cms.content.DefaultObjs 中的方法
setDBTableName(String) - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
setDbTableName(String) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
setDbTableName(String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
setDbTableName(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置当前对象相关的数据表名
setDbTableName(String) - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
设置当前对象相关的数据表名
setDbTableName(String) - 类 com.trs.components.wcm.content.persistent.XDocuments 中的方法
setDbTableName(String) - 类 com.trs.infra.persistent.MyBaseObj 中的方法
setDbTableName(String) - 类 com.trs.infra.persistent.MyBaseObjs 中的方法
setDBType(int) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：DBType
setDBType(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：DBType
setDBType(DBType) - 类 com.trs.infra.util.database.CDBText 中的方法
setDealContent(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
设置属性：DealContent
setDealTime(CMyDateTime) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：DEALTIME
setDealType(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：DealType
setDebug(boolean) - 类 com.trs.components.metadata.service.GovInfoToXML 中的方法
设置是否输出状态信息
setDefault(boolean) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
设置属性:IsDefault
setDefault(String) - 类 com.trs.presentation.util.PageParameter 中的方法
设置默认值
setDefault(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置默认值
setDefaultCols(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
设置本次检索的检索字段
setDefaultConnection(String) - 类 com.trs.infra.persistent.db.DBConnectionConfigs 中的方法
setDefaultEncoding(String) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setDefaultOutline(IPublishFolder, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
setDefaultSMTPServer(String) - 类 com.trs.infra.util.email.SMTPServerConfigs 中的方法
setDefaultTemplate(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
setDefaultTemplateId(int, int) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置默认的模板信息
setDefaultTemplateId(int, int) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
setDefaultValue(String) - 类 com.trs.cms.process.config.ParamConfig 中的方法
setDefaultValue(String) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
设置属性的缺省值
setDefaultValue(String) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：DefaultValue
setDefaultValue(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setDefaultValue(String) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：DefaultValue
setDefaultValue(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：DefaultValue
setDefaultView(boolean) - 类 com.trs.components.infoview.extract.manifest.View 中的方法
setDefaultView(boolean) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置该视图是否缺省视图
setDefineFileRule(boolean) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：DefineFileRule
setDefineSchedule(boolean) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：DefineSchedule
setDefineStatus(boolean) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：DefineStatus
setDelcols(List) - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
设置被删除的列
setDeleted(boolean) - 类 com.trs.cms.auth.persistent.User 中的方法
设置属性:ISDELETED
setDeleted(boolean) - 类 com.trs.components.common.job.Schedule 中的方法
逻辑接口：设置计划设是否为已删除状态 说明：对于正常状态下的计划，setDeleted( true )将计划改为已删除（逻辑删除）；
对于已删除的计划，setDeleted( false )将计划恢复为正常状态
setDeleted(boolean) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
设置站点/频道为已删除状态
setDeleted(boolean) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
将文档设为已删除状态 说明：对于正常状态下的文档，setDeleted( true )将ChnlDoc改为已删除（逻辑删除）； 对于已删除的文档，setDeleted( false )将文档恢复为正常状态
setDeleted(boolean) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
将文档设为已删除状态 说明：对于正常状态下的文档，setDeleted( true )将文档改为已删除（逻辑删除）； 对于已删除的文档，setDeleted( false )将文档恢复为正常状态
setDeletedBySender() - 类 com.trs.components.common.message.Message 中的方法
删除已发送消息
setDeleteFlag(boolean) - 类 com.trs.components.comment.domain.CommentUpdator 中的方法
setDelim(String) - 类 com.trs.infra.util.AttributesString 中的方法
setDepartment(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：Department
setDepends(OperationRelatedConfig) - 类 com.trs.cms.auth.config.OperationConfig 中的方法
setDesc(String) - 类 com.trs.cms.auth.config.OperationConfig 中的方法
setDesc(String) - 类 com.trs.cms.auth.persistent.Group 中的方法
设置组的描述
setDesc(String) - 类 com.trs.cms.auth.persistent.RightDef 中的方法
setDesc(String) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色描述
setDesc(String) - 类 com.trs.cms.content.ExtendedField 中的方法
设置扩展字段描述信息
setDesc(String) - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法
setDesc(String) - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法
setDesc(String) - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
setDesc(String) - 类 com.trs.cms.process.config.ParamConfig 中的方法
setDesc(String) - 类 com.trs.cms.process.config.ValueConfig 中的方法
setDesc(String) - 类 com.trs.cms.process.definition.Flow 中的方法
设置工作流描述
setDesc(String) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设置节点描述
setDesc(String) - 类 com.trs.components.common.address.Contact 中的方法
setDesc(String) - 类 com.trs.components.common.address.ContactGrp 中的方法
setDesc(String) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
setDesc(String) - 类 com.trs.components.common.calendar.Event 中的方法
setDesc(String) - 类 com.trs.components.common.calendar.EventType 中的方法
setDesc(String) - 类 com.trs.components.common.job.JobWorkerType 中的方法
setDesc(String) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：描述
setDesc(String) - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 中的方法
setDesc(String) - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
setDesc(String) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
设置属性的详细描述
setDesc(String) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
设置置标的详细描述
setDesc(String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
设置属性：Desc
setDesc(String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：Desc
setDesc(String) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板的描述
setDesc(String) - 类 com.trs.components.infoview.config.BindingBean 中的方法
setDesc(String) - 类 com.trs.components.infoview.config.GatewayPage 中的方法
setDesc(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
setDesc(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setDesc(String) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法
setDesc(String) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置视图的描述
setDesc(String) - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
设置属性：Desc
setDesc(String) - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
设置属性：Desc
setDesc(String) - 类 com.trs.components.metadata.definition.MetaView 中的方法
设置属性：Desc
setDesc(String) - 类 com.trs.components.wcm.channel.VChannel 中的方法
setDesc(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件描述
setDesc(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道描述
setDesc(String) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
设置属性：LogicFieldDesc
setDesc(String) - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
设置描述
setDesc(String) - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法
setDesc(String) - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法
setDesc(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点的描述
setDesc(String) - 类 com.trs.components.wcm.resource.DocKind 中的方法
setDesc(String) - 类 com.trs.components.wcm.resource.FileType 中的方法
setDesc(String) - 类 com.trs.components.wcm.resource.Security 中的方法
设置描述
setDesc(String) - 类 com.trs.components.wcm.resource.Source 中的方法
设置来源描述
setDesc(String) - 类 com.trs.components.wcm.resource.Status 中的方法
设置状态描述
setDesc(String) - 类 com.trs.infra.support.config.Config 中的方法
设置配置描述信息
setDesc(String) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志描述
setDesc(String) - 接口 com.trs.infra.support.log.ILog 中的方法
设置日志描述
setDesc(String) - 类 com.trs.infra.support.log.OperType 中的方法
setDesc(String) - 类 com.trs.presentation.util.PageParameter 中的方法
设置参数描述
setDesc(String) - 类 com.trs.wcm.config.PageOperator 中的方法
设置属性：Desc
setDesc(String) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置属性：Desc
setDesc(String) - 类 com.trs.wcm.photo.ImageKind 中的方法
setDesc(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置参数描述
setDescription(String) - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
设置属性：Description
setDescription(String) - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
设置属性：Description
setDescription(String) - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
设置属性：Description
setDescription(String) - 类 com.trs.components.common.message.MessageSendingConfig 中的方法
setDescription(String) - 异常 com.trs.template.AbstractErrorMessage 中的方法
设置错误描述
setDescription(String) - 类 com.trs.template.persistent.TagFieldInfoEntity 中的方法
setDetailExt(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置细览页面的扩展名
setDetailFields(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法
setDetailFile(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道细览文件名
setDetailFileExt(String) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
设置属性：DetailFileName
setDetailFileExt(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：DetailFileExt
setDetailPageCount(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置共计发布了多少细览页面
setDetailPageSeperateTo51Style(boolean) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setDetailTemplate(IPublishElement, int, boolean, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
set detail template of the specified element.
setDetailTemplate(IPublishElement, int, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
setDetailTemplate(IPublishFolder, int, boolean) - 类 com.trs.service.impl.TemplateService 中的方法
setDetailTemplate(IPublishContent, int, int) - 类 com.trs.service.impl.TemplateService 中的方法
setDetailTemplate(IPublishContent, int) - 类 com.trs.service.impl.TemplateService 中的方法
setDetailTemplate(IPublishFolder, int, boolean) - 接口 com.trs.service.ITemplateService 中的方法
为指定频道设定细览模板
setDetailTemplate(IPublishContent, int, int) - 接口 com.trs.service.ITemplateService 中的方法
为指定文档设定模板
setDetailTemplate(IPublishContent, int) - 接口 com.trs.service.ITemplateService 中的方法
setDetailTemplateId(int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：DetailTemplateId
setDetailTemplateId(int) - 类 com.trs.wcm.photo.ImageKind 中的方法
setDetailTemplateType(int) - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
setDetialTemplate(int) - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 中的方法
setDictionary(byte[]) - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Sets the dictionary which should be used in the deflate process.
setDictionary(byte[], int, int) - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Sets the dictionary which should be used in the deflate process.
setDictionary(byte[]) - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Sets the preset dictionary.
setDictionary(byte[], int, int) - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Sets the preset dictionary.
setDirDividedByDate(boolean) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setDirDividedByDateFormat(String) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setDirection(int) - 类 com.trs.cms.process.engine.FlowParamers 中的方法
设置流转方向
setDisp(String) - 类 com.trs.components.wcm.resource.Security 中的方法
设置显示名称
setDisp(String) - 类 com.trs.components.wcm.resource.Status 中的方法
设置状态显示内容
setDisplayFieldType(String) - 类 com.trs.components.infoview.extract.DataType 中的方法
setDisplayName(String) - 类 com.trs.components.infoview.extract.DataType 中的方法
setDispName(String) - 类 com.trs.cms.auth.config.OperationConfig 中的方法
setDistributor(String) - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 中的方法
setDistributorClassName(String) - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
setDocActions(int) - 类 com.trs.cms.process.definition.FlowNode 中的方法
使用整型值设置节点上允许的操作
setDocActions(int, boolean) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设定指定类型的文档操作许可
setDocChannel(Channel) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
setDocChannelId(int) - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
设置属性：DocChannelId
setDocContentPattern(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
设置正文构造器字段
setDocCrTime(CMyDateTime) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
设置属性：DocCrTime 文档创建时间
setDocCrUser(String) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
设置属性：DocCrUser 文档创建者
setDocEndTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
setDocId(int) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
设置属性：DocId 文档ID
setDocId(int) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件所属文档编号
setDocId(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置属性：DocId
setDocId(int) - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
设置备份文档的ID
setDocId(Document) - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
设置备份的文档
setDocId(int) - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
设置回复所属的文档ID
setDocId(int) - 类 com.trs.components.wcm.content.persistent.Relation 中的方法
设置相关文档对象所属文档的ID
setDocId(int) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
setDocId(int) - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
设置属性：DocId
setDocIdFieldName(String) - 类 com.trs.components.wcm.content.persistent.XDocuments 中的方法
setDocOrder(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置属性：DocOrder
setDocOrderPri(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置文档的置顶顺序，不判断是否大于系统允许最大的有效范围
setDocPro(int, boolean) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
setDocPubTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置属性：DocPubTime
setDocPubURL(String) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置属性：DocPubURL
setDocSerial(boolean) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
setDocStartTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
属性设置：文档执行时间
setDocTitle(String) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
设置属性：DocTitle 文档标题
setDocTitle(String) - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
设置属性：DocTitle
setDocTopPriOrder(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置文档的置顶位置.
setDocument(Document) - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
setDocument(Document, boolean) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
setDocument(HtmlDocument) - 类 com.trs.infra.util.html.HtmlComment 中的方法
直接设定了Document对象，表示为根元素
setDocument(HtmlDocument) - 类 com.trs.infra.util.html.HtmlElement 中的方法
设定所在的文档对象
setDocumentId(int) - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
设置属性：DocumentId
setDocumentId(int) - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
setDocumentId(int) - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的方法
setDocumentId(int) - 类 com.trs.service.InfoViewContext 中的方法
setDocumentProperties(Document, MetaViewData) - 接口 com.trs.components.metadata.center.IDocumentFieldsSyn 中的方法
根据视图数据对象设置关联的document对象的值
setDocumentsCount(int) - 类 com.trs.components.wcm.content.trsserver.TreeNode 中的方法
setDocumentsGetOptimize(boolean) - 类 com.trs.components.wcm.WCMAppConfig 中的方法
setDocumentSynChnlDoc(boolean) - 类 com.trs.components.wcm.WCMAppConfig 中的方法
setDocumentSynChnlDocFields(String) - 类 com.trs.components.wcm.WCMAppConfig 中的方法
setDoDeptFilter(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
栏目文档列表是否做所属部门的过滤
setDOM4JDocument(Document) - 类 com.trs.components.infoview.extract.manifest.View 中的方法
setDomCacheMaxSize(int) - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法
setDoOperation(boolean) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
设置属性：DoOperation
setDowithClob(boolean) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setDowithTemplateFile(String) - 类 com.trs.infra.util.TRSJspAutoTool 中的方法
setDriverClass(String) - 类 com.trs.infra.util.database.DBType 中的方法
设置数据库默认的驱动程序库
setEachTaskLaborsMax(int) - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法
setEditable(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
setEditFile(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置编辑文件名
setEditor(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件的修改人
setEditor(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置修改者
setEditor(User) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置修改者
setElement(IPublishElement) - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
设置被代理的实际对象，可以将参数设置为null，以清除对实际被代理对象的引用。
setElement(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法
setElements(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法
setEmail(String) - 类 com.trs.cms.auth.persistent.Group 中的方法
设置组的邮件地址 说明：若有多个邮件地址，则用";"分割
setEmail(String) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色Email地址
setEmail(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置用户Email 邮件地址，若有多个，用";"分割
setEmail(String) - 类 com.trs.components.common.address.Contact 中的方法
setEmail(String) - 类 com.trs.components.common.address.ContactGrp 中的方法
setEmail(String) - 类 com.trs.components.common.calendar.Event 中的方法
setEmail(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：Email
setEmbedViewId(int) - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
设置属性：EmbedViewId
setEmployedInfoView(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
setEmployedInfoView(CMSObj, int) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
TODO Add javadoc for field setEmployedInfoView
setEmployedInfoView(CMSObj, InfoView) - 接口 com.trs.service.IInfoViewService 中的方法
设置雇主（通常是频道）雇佣的自定义表单的ID列表
setEmployedInfoView(CMSObj, InfoView) - 类 com.trs.service.impl.InfoViewService 中的方法
setEmployedInfoViews(CMSObj, int[]) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
注意： 在该函数执行后，参数数组_iInfoViewIDs的数据可能被破坏，因此如果需要，请调用该函数前备份
setEmployedInfoViews(CMSObj, String) - 接口 com.trs.service.IInfoViewService 中的方法
设置雇主（通常是频道）雇佣的自定义表单的ID列表
setEmployedInfoViews(CMSObj, String) - 类 com.trs.service.impl.InfoViewService 中的方法
setEmployer(int, int) - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
set the employer
setEmployer(BaseObj) - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
set the employer
setEmployer(int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
set the employer
setEmployer(IPublishElement) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
set the employer
setEmployer(int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
set the employer
setEmployer(IPublishElement) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
set the employer
setEmployer(CMSObj) - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法
setEmployer(int, int) - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法
setEmployer(User, Channel, MetaView) - 接口 com.trs.components.metadata.center.IMetaViewEmployerMgr 中的方法
给指定的栏目配置指定的视图
setEmployer(User, Channel, MetaView) - 类 com.trs.components.metadata.center.MetaViewEmployerMgr 中的方法
setEmployersOfFlow(User, int, int, int[]) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
批量维护指定工作流的配置关系
SetEmployersOfTemplateLogger - com.trs.ajaxservice.logger 中的 类
SetEmployersOfTemplateLogger() - 类 com.trs.ajaxservice.logger.SetEmployersOfTemplateLogger 的构造方法
setEmployType(int) - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
设置属性：EmployType
setEnable(boolean) - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
设置属性：Enable
setEnabled(boolean) - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法
setEnabled(boolean) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：Enabled
setEnabled(boolean) - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
Sets the value of property Enabled.
setEnabled(boolean) - 类 com.trs.infra.util.CMyTimer 中的方法
设置是否允许使用
setEncoding(String) - 类 com.trs.infra.util.CMyUnzip 中的方法
设置字符编码集
setEncoding(String) - 类 com.trs.infra.util.CMyZip 中的方法
设置字符编码集
setEncoding(String) - 类 com.trs.infra.util.jazzlib.ZipFile 中的方法
设置字符编码集
setEncoding(String) - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
设置字符编码集
setEncoding(String) - 类 com.trs.presentation.nav.RadarTreeCreator 中的方法
setEnd(boolean) - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
setEndIndex(int) - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法
setEndNodeName(String) - 类 com.trs.cms.process.definition.Flow 中的方法
设置结束节点名称
setEndStatTime(CMyDateTime) - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
setEndTime(CMyDateTime) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
设置属性：EndTime
setEndTime(CMyDateTime) - 类 com.trs.components.common.calendar.Event 中的方法
setEndTime(CMyDateTime) - 类 com.trs.components.common.job.Schedule 中的方法
setEndTime(CMyDateTime) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：EndTime
setEndTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道文档列表的结束时间
setEndTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
setEndTime(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：EndTime
setEndTimeMillis(long) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
setEndTimeMillis(long) - 接口 com.trs.infra.support.log.ILog 中的方法
setEnmvalue(String) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：Enmvalue
setEnmValue(String) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：EnmValue
setEnmValue(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：EnmValue
setEnterDirectly(boolean) - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
设置属性：EnterDirectly
setEnumsConfigFile(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法
setEnumSplit(char) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置枚举值的分隔字符
setEnumValue(String[]) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
设置有效的属性值的列表数组，如果属性值不是枚举类型，则可以设置为null。
setEnumValue(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setErrorCode(String) - 异常 com.trs.webframework.exception.ServiceInvocationException 中的方法
setErrorDetail(String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
设置属性：ExeDetail
setEscapeParameters(String[]) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
指定Request转义的参数
setEvent(String) - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法
setEventId(int) - 类 com.trs.components.common.calendar.EventShare 中的方法
设置属性：EventId
setEventType(String) - 类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 中的方法
setExample(String) - 类 com.trs.wcag2.Alertion 中的方法
setExcludeValue(String) - 类 com.trs.presentation.util.PageParameter 中的方法
setExcludeValue(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
setExecTime(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：ExecTime
setExecTime(long) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
setExecTime(long) - 接口 com.trs.infra.support.log.ILog 中的方法
setExeTime(CMyDateTime) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：执行时间
setExpression(String) - 类 com.trs.components.infoview.extract.manifest.CalculatedField 中的方法
setExt(String) - 类 com.trs.components.wcm.resource.FileType 中的方法
setExtension(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
设置自动扩展
setExtensions(ArrayList) - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
setExtFieldProperty(String, String) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
setExtra(byte[]) - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Sets the extra data.
setExtraAttribute(String, String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
setExtraAttribute(String, String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
设置置标的扩展属性(非置标原有属性，为逻辑属性)
setExtraAttributes(Map) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Sets the display styles.
setExtractProgram(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法
setExtraData(ArrayList) - 类 com.trs.infra.util.Reports 中的方法
setExtraFilter(WCMFilter) - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
setFailCode(int) - 异常 com.trs.template.TemplateRemoteException 中的方法
设置错误号
setFailDescription(String) - 异常 com.trs.template.TemplateRemoteException 中的方法
设置错误描述
setFailSolution(String) - 异常 com.trs.template.TemplateRemoteException 中的方法
设置错误对应的推荐解决办法
setFavorLanguage(User, String) - 类 com.trs.presentation.locale.LocaleServer 中的静态方法
设置个人偏好
setFavorLocale(User, Locale) - 类 com.trs.presentation.locale.LocaleServer 中的静态方法
设置用户选用的Locale
setFax(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：Fax
setFieldDesc(String) - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
设置属性：FieldDesc
setFieldDesc(String) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
设置属性：FieldDesc
setFieldDesc(String) - 类 com.trs.wcm.old.WCMFormFields 中的方法
设置属性：FieldDesc
setFieldId(String) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
设置属性：FieldId
setFieldLength(int) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
设置属性：FieldLength
setFieldName(String) - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
设置属性：FieldName
setFieldName(String) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
设置属性：FieldName
setFieldname(String) - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法
setFieldName(String) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
设置属性：FieldName
setFieldName(String) - 类 com.trs.wcm.old.WCMFormFields 中的方法
设置属性：FieldName
setFieldOrder(int) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
setFieldPos(int) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
设置属性：FieldPos
setFields(String) - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法
setFields(String) - 类 com.trs.template.persistent.TagFieldInfoEntity 中的方法
setFieldsReadOnly(InfoView, InfoViewFields, boolean) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
setFieldsReadOnly(InfoView, InfoViewFields, boolean) - 接口 com.trs.service.IInfoViewService 中的方法
setFieldsReadOnly(InfoView, InfoViewFields, boolean) - 类 com.trs.service.impl.InfoViewService 中的方法
setFieldTemplate(FieldTemplate) - 类 com.trs.components.metadata.web.AbsHTMLMaker 中的方法
setFieldTemplate(FieldTemplate) - 接口 com.trs.components.metadata.web.HTMLMaker 中的方法
设置当前对象的视图字段资源模板
setFieldTop(int) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
设置属性：FieldPos
setFieldType(int) - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
设置字段类型,Field/Group/View
setFieldType(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setFieldType(String) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
设置属性：FieldType
setFieldValue(String) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
设置属性：FieldValue
setFieldValueBeforeSaveMetaData(MetaViewData) - 接口 com.trs.components.metadata.center.IMetaDataFieldValueCreator 中的方法
给当前元数据对象的相关属性设置上自动产生的值
setFieldValueBeforeSaveMetaData(MetaViewData) - 类 com.trs.components.metadata.service.GovInfoIndexCreator 中的方法
setFile(String) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
设置模板附件的文件名
setFile(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件文件名
setFileAction(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setFileExt(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件的源文件名后缀名
setFileExt(String) - 类 com.trs.infra.util.FileNameExtFilter 中的方法
setFileName(String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
setFileName(String) - 类 com.trs.components.common.publish.widget.Master 中的方法
设置属性：FileName
setFileName(String) - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
设置属性：FileName
setFilename(String) - 类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 中的方法
setFileNameByBaseObj(boolean) - 类 com.trs.infra.util.TRSJspAutoTool 中的方法
setFileNameEncoding(String) - 类 com.trs.infra.util.CMyUnZipFile 中的方法
setFilter(WCMFilter) - 类 com.trs.infra.persistent.BaseObjs 中的方法
setFixLength(int) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setFlag(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置文档流转状态
setFlag(int) - 类 com.trs.components.common.message.Message 中的方法
setFlag(int) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
设置模板附件的标记
setFlag(int) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件类型
setFlag(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档标志 目前系统只支持一种风格（对外发布的文档），其余风格的文档可在二次开发中定义
setFlow(int) - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
设置属性：FlowId
setFlow(Flow) - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
set the flow used
setFlow(BaseObj, int) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
set the flow of the specified employer.
setFlow(int, int, int) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
setFlow(int) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设置节点所在工作流
setFlow(Flow) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设置节点所在工作流
setFlow(Flow) - 接口 com.trs.cms.process.IFlowContent 中的方法
setFlow(Flow) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
setFlow(Flow) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
setFlowContent(IFlowContent) - 类 com.trs.cms.process.engine.FlowContext 中的方法
setFlowContent(int, int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
setFlowContent(IFlowContent) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置所属文档
setFlowContent(IFlowContent) - 类 com.trs.cms.process.engine.FlowParamers 中的方法
setFlowContent(int, int) - 类 com.trs.cms.process.engine.FlowParamers 中的方法
setFlowContext(FlowContext) - 类 com.trs.cms.process.engine.ExecuteContext 中的方法
setFlowDoc(FlowDoc) - 接口 com.trs.cms.process.IFlowContent 中的方法
设置FlowContent相关的FlowDoc
setFlowDoc(FlowDoc) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
setFlowDoc(FlowDoc) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
setFlowdocId(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：FlowdocId
setFlowEmploy(BaseObj, int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
setFlowEmploy(BaseObj, int) - 接口 com.trs.service.IWCMProcessService 中的方法
setFlowId(int) - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
设置属性：FlowId
setFlowId(int) - 类 com.trs.service.InfoViewContext 中的方法
setFlowStatus(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：_nStatusId
setFolder(int, int) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：FolderTypeConfig
setFolder(IPublishFolder) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
setFolder(IPublishFolder) - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Sets the folder where this content currently lies.
setFolder(IPublishFolder) - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
setFolder(IPublishFolder) - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法
setFolder(int, int) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
设置属性：FolderId
setFolder(IPublishFolder) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
set the publish folder
setFolder(int, int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
设置属性：FolderTypeConfig
setFolder(IPublishFolder) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
set the property of FolderTypeConfig
setFolder(int, int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：FolderTypeConfig
setFolder(IPublishFolder) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
set the property of FolderTypeConfig
setFolder(int, int, int, int) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
set the folder where the template is located
setFolder(IPublishFolder, IPublishFolder) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
set the folder where the template is located
setFolder(int, int) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
set the folder id
setFolder(IPublishFolder) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
set the folder where the template is located
setFolder(IPublishFolder) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
setFolderId(int) - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法
setFolders(IPublishElements) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
get the property of ContentIds
setFolders(String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
get the property of ContentIds
setFolderType(int, int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：FolderTypeConfig
setFolderType(BaseChannel) - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
setFolderType(int, int) - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
setFolderType(int) - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法
setFolderTypes(ArrayList) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setForceFirstLoadIds(boolean) - 类 com.trs.infra.db.QueryFilter 中的方法
setForceFirstLoadIds(boolean) - 类 com.trs.infra.persistent.WCMFilter 中的方法
setForceKick(boolean) - 类 com.trs.presentation.util.LoginHelper 中的方法
setForm(String) - 类 com.trs.components.wcm.resource.FileType 中的方法
setForm(int) - 类 com.trs.wcm.old.WCMExcelData 中的方法
设置扩展数据所属表单
setFormAction(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setFormat(String) - 类 com.trs.components.infoview.config.BindingBean 中的方法
setFormEncoding(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setFormExtra(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setFormId(int) - 类 com.trs.wcm.old.WCMFormFields 中的方法
设置属性：FormId
setFreqReminded(int, int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
设置用户设置的提醒频率
setFreqReminded(int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
设置属性：FreqReminded
setFrom(String) - 类 com.trs.infra.db.QueryFilter 中的方法
设置表名称列表，多个表用","分割
setFrom(String) - 类 com.trs.infra.persistent.WCMFilter 中的方法
设置表名称列表，多个表用","分割
setFrom(String) - 类 com.trs.infra.util.CMySMS 中的方法
设置发信人
setFrom(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置发邮件人地址
setFromMainTable(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置是否来自于主表
setFromRecycle(boolean) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
setFromRecycle(boolean) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
setFromRule(boolean) - 类 com.trs.cms.process.engine.FlowContext 中的方法
setFromUser(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置发件人的显示名称
setFromVersion(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档是从哪个版本恢复回来的
setFtpFolder(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置ftp目录
setFtpPassword(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置ftp用户密码
setFtpPath(String) - 类 com.trs.infra.support.config.PathConfig 中的方法
设置Ftp路径
setFtpServer(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点对应的ftp服务器地址
setFtpUpload(boolean) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点是否需要上传文件
setFtpUser(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点对应的ftp服务器用户
setFullDir(String) - 类 com.trs.template.domain.XTemplateExporter.HierarchyEntity 中的方法
setGateWayBinding(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setGatewayConfig(GatewayConfig) - 类 com.trs.components.infoview.InfoViewConfig 中的方法
setGateWayInitPage(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setGatewayPageProperties(Map) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setGatewayPageProperty(String, String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setGetPropertyFromNew(boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法
setGroupBy(String) - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
setGroupId(int) - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
设置属性：GroupId
setGroupId(int) - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
设置属性：GroupId
setGroupId(int) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：GroupId
setGroupId(int) - 类 com.trs.components.stat.ChnlDept 中的方法
设置属性：GroupId
setGroupId(int) - 类 com.trs.presentation.ids.RegFromConfig 中的方法
设置所属组织ID
setGroupIds(String) - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法
setGroupManager(User, Group, boolean) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
设置组管理员(设置或取消指定用户的组管理员身份)
setGroupOrder(int) - 类 com.trs.cms.auth.persistent.Group 中的方法
设置属性：GroupOrder
setGroupRange(Group) - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法
setGroups(Role, Groups) - 类 com.trs.cms.auth.domain.GroupRoleMgr 中的方法
绑定角色role和组织groups的关联，同时将清除原来的关联
setGroupUsers(int, String) - 接口 com.trs.service.IGroupService 中的方法
维护指定用户组的用户列表
setGroupUsers(int, String) - 类 com.trs.service.impl.GroupService 中的方法
setHandler(String) - 类 com.trs.cms.process.definition.FlowAction 中的方法
设置属性：Handler
setHandler(Class) - 类 com.trs.cms.process.definition.FlowAction 中的方法
setHandler(String) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
设置属性：Handler
setHandler(Class) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
setHasMapping(boolean) - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的方法
determine if the mashall/unmarshall has mapping src
setHasRight(int, boolean) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
设置指定权限索引的权限
setHasWarnings(boolean) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：HasWarnings
setHeaders(Header[]) - 类 com.trs.infra.util.ResponseBuddy 中的方法
setHidden(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
setHiddenAppendix(boolean) - 类 com.trs.components.metadata.definition.MetaView 中的方法
setHighPriorityLaborsMax(int) - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法
setHitsCount(int) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
设置属性：HitsCount 点击量
setHitsCount(int) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
设置属性：HitsCount
setHitsCount(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档的点击数
setHitsTime(CMyDateTime) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
设置属性：HitsTime 点击时间
setHitsTime(CMyDateTime) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
设置属性：HitsTime
setHost(IPublishElement) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
setHost(String) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置FTP服务器的主机名或者IP地址
setHostDesc(String) - 类 com.trs.components.wcm.stat.StatHost 中的方法
设置属性：HostDesc
setHostFilePath(String) - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
setHostId(int) - 类 com.trs.cms.process.definition.FlowRule 中的方法
设置属性：HostId
setHostId(int) - 类 com.trs.components.special.Special 中的方法
设置属性：HostId
setHostId(int) - 类 com.trs.components.stat.HostObjDomain 中的方法
设置属性：HostId
setHostId(int) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
设置属性：HostId
setHostId(int) - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
设置属性：HostId
setHostName(String) - 类 com.trs.components.wcm.stat.StatHost 中的方法
设置属性：HostName
setHostType(int) - 类 com.trs.cms.process.definition.FlowRule 中的方法
设置属性：HostType
setHostType(int) - 类 com.trs.components.special.Special 中的方法
设置属性：HostType
setHostType(int) - 类 com.trs.components.stat.HostObjDomain 中的方法
设置属性：HostType
setHostType(int) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
设置属性：HostType
setHostType(int) - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
设置属性：HostType
setHostType(int) - 类 com.trs.components.wcm.stat.StatHost 中的方法
设置属性：HostType
setHtml(String) - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
设置属性：Html
setHTML(String) - 类 com.trs.wcag2.Alertion 中的方法
setHtmlContent(String) - 类 com.trs.components.common.publish.widget.Layout 中的方法
设置属性：HtmlContent
setHtmlContent(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
setHtmlSrc(String) - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法
设置Html文本源
setHtmlSrc(char[]) - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法
设置Html文本源
setHttpPath(String) - 类 com.trs.infra.support.config.PathConfig 中的方法
设置Http路径
setIcon(String) - 类 com.trs.components.common.bookmark.BookMark 中的方法
setIcon(String) - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法
setId(int) - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法
setId(int) - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
setId(int) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
setId(int) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
setId(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
setId(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
setId(int) - 类 com.trs.components.wcm.content.persistent.XDocument 中的方法
setId(int) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
setId(String) - 类 com.trs.infra.config.persistent.BeanConfig 中的方法
setId(String) - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法
setId(String) - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
setId(int) - 类 com.trs.infra.persistent.BaseObj 中的方法
设置对象ID
setId(int) - 类 com.trs.infra.persistent.CMyResultSet 中的方法
setId(int) - 类 com.trs.infra.persistent.MyBaseObj 中的方法
setId(int) - 类 com.trs.scene.parser.SceneConnector 中的方法
setId(int) - 类 com.trs.scene.parser.SceneNode 中的方法
setId(int) - 类 com.trs.wcm.photo.ImageInfo 中的方法
setIdentityField(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：IdentityField
setIdFieldName(String) - 类 com.trs.cms.content.DefaultObj 中的方法
setIdFieldName(String) - 类 com.trs.cms.content.DefaultObjs 中的方法
setIdFieldName(String) - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
setIdFieldName(String) - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的方法
setIdFieldName(String) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
setIdFieldName(String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
setIDFieldName(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
setIdFieldName(String) - 类 com.trs.infra.persistent.MyBaseObj 中的方法
setIdFieldName(String) - 类 com.trs.infra.persistent.MyBaseObjs 中的方法
setIdleTimestamp() - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
设置空闲时间戳
setIdList(Vector, WCMFilter, boolean) - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
setIdName(String) - 类 com.trs.components.wcm.content.persistent.XDocument 中的方法
setIgnoreIfHostNotFound(boolean) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setImageAttribute(String, String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
设置图片的属性
setImageAttribute(String, String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
setImageFileExt(String[], String) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置支持的图片格式和默认的转换图片
setImageFileExt(String[], String) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
setImageFileName(String) - 类 com.trs.wcm.photo.ImageInfo 中的方法
setImageKindId(int) - 类 com.trs.wcm.photo.ImageInfo 中的方法
setImageKindId(int) - 类 com.trs.wcm.photo.ImageKind 中的方法
setImageTitle(String) - 类 com.trs.wcm.photo.ImageInfo 中的方法
setImport(int) - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法
setImportToCurrChannel(boolean) - 类 com.trs.components.metadata.center.xml.MetaViewDataImporter 中的方法
设置是否导入到当前栏目
setImportWithFlowNodeFields(boolean) - 类 com.trs.cms.process.xml.FlowImporter 中的方法
setImportWithInfoviewId(boolean) - 类 com.trs.cms.process.xml.FlowImporter 中的方法
setImportWithOptMarkEnum(boolean) - 类 com.trs.cms.process.xml.FlowImporter 中的方法
setIncludeOperations(OperationRelatedConfig) - 类 com.trs.cms.auth.config.OperationConfig 中的方法
setInDetail(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：InDetail
setIndex(int) - 类 com.trs.cms.auth.config.OperationConfig 中的方法
setIndex(int) - 类 com.trs.cms.auth.persistent.RightDef 中的方法
setIndexCode(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：IndexCode
setIndexes(List) - 类 com.trs.infra.util.upgrade.dbcompare.MetaDataLoader 中的方法
设置索引
setIndexs(int[]) - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法
setIndividuationId(int) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法
设置属性：IndividuationId
setInfoEntityColl(ArrayList) - 类 com.trs.template.persistent.InfoEntities 中的方法
setInfoGetType(long) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：InfoGetType
setInfoPathFile(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
setInfoProviderType(long) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：InfoProviderType
setInfoView(InfoView) - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法
setInfoView(InfoView) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法
setInfoviewDataId(int) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
设置属性：InfoviewDataId
setInfoViewFieldValue(String, String) - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
给一个普通的字段设置值
setInfoViewFieldValueBeforeSaveDoc() - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
给当前表单数据对象的相关属性设置上自动产生的值
setInfoViewId(int) - 类 com.trs.components.infoview.config.EnumCreator 中的方法
setInfoViewId(int) - 类 com.trs.components.infoview.config.LinkedEnumCreator 中的方法
setInfoviewId(int) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
设置属性：InfoviewId
setInfoViewId(int) - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
setInfoViewId(int) - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的方法
setInfoViewId(int) - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法
setInfoViewId(int) - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法
setInfoViewID(int) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setInfoViewID(int) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法
setInfoViewID(int) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置视图所属表单的ID
setInfoViewId(int) - 类 com.trs.service.InfoViewContext 中的方法
setInfoViewPath(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
setInfoviewPrintTemplateId(int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：_nInfoviewPrintTemplateId
setInfoViewRepeatFieldValue(String, String, int) - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
给指定位置的重复表字段设置值
setInfoviewTitle(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setInfoViewViewName(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
setInheritDetail(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置是否继承父频道的细览模板
setInheritExtend(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置是否继承父系的扩展字段
setInheritOutline(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置是否继承父频道的概览模板
setInitConnects(int) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setInitProperties(String, String) - 类 com.trs.infra.support.config.ConfigServer 中的方法
setInitProperties(Map) - 类 com.trs.infra.support.config.ConfigServer 中的方法
setInitStatus(int) - 类 com.trs.template.TemplateServiceConfig 中的静态方法
设置系统的初始化状态
setInMultiTable(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
setInnerFilloutAction(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法
setInnerIPBegin(String) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：InnerIPBegin
setInnerIPEnd(String) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：InnerIPEnd
setInnerMulti(boolean) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：InnerMulti
setInnerMultiCount(int) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：InnerMultiCount
setInnerType(boolean) - 类 com.trs.components.infoview.extract.DataType 中的方法
setInOutline(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：InOutline
setInput(byte[]) - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Sets the data which should be compressed next.
setInput(byte[], int, int) - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Sets the data which should be compressed next.
setInput(byte[]) - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Sets the input.
setInput(byte[], int, int) - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Sets the input.
setInputFile(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置输入文件名
setInputStreamWrapper(ServletInputStreamWrapper) - 类 com.trs.webframework.context.ServiceContext 中的方法
setInstalled() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
setInstalled() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
setInterval(int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：Interval
setInterval(int) - 类 com.trs.infra.util.CMyTimer 中的方法
设置间隔运行时间
setInvalidTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置文档置顶的有效时间（截止时间）
setInvocationId(String) - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法
setIP(String) - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
设置属性：IP
setIpAddress(String) - 类 com.trs.components.stat.UserLoginInfo 中的方法
设置属性：IpAddress，登陆的IP地址
setIsAdministrator(int) - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
设置属性：IsAdministrator
setIsAndOperator(boolean) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
设置属性：LogicOperator
setIsChecked(MethodContext) - 类 com.trs.ajaxservice.IndividuationServiceProvider 中的方法
setIsChecked(boolean) - 类 com.trs.components.wcm.individuation.Individuation 中的方法
设置属性：IsChecked
setIsDisplay(int) - 类 com.trs.wcm.config.PageOperator 中的方法
设置属性：IsDisplay
setIsFolder(boolean) - 类 com.trs.components.common.publish.config.PublishElementType 中的方法
setIsImport(int) - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
设置属性：是否是导入的对象
setIsPrivate(int) - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
设置属性：是否是私有对象
setIsPrivate(int) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
设置属性：是否是私有对象
setIsPublish(int) - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
设置属性：是否发布
setIsResetChildrenTemplates(boolean) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性:isResetChildrenTemplates
setIsRoot(boolean) - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
setIsShared(boolean) - 类 com.trs.components.wcm.individuation.Individuation 中的方法
设置属性：IsChecked
setItemCount(int) - 类 com.trs.infra.util.CPager 中的方法
设定元素总数：直接指定
setItemCount(Statement, String) - 类 com.trs.infra.util.CPager 中的方法
设定元素总数：通过指定查询SQL语句，在数据库中检索
setItemId(int) - 类 com.trs.components.common.trsvote.VoteOption 中的方法
设置属性：ItemId
setJdbcType(int) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法
setJdbcTypeName(String) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法
setJspUrl(String) - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
设置属性：JspUrl
setKeepAlive(boolean) - 类 com.trs.infra.util.soap.CMySoapClient 中的方法
setKey(String) - 类 com.trs.components.infoview.config.EnumCreator 中的方法
setKeyName(String) - 类 com.trs.infra.support.security.SecureKey 中的方法
设定密钥名
setKeySize(int) - 类 com.trs.infra.support.security.SecureKey 中的方法
设定密钥长度
setKeywords(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置关键词
setKeywords(String) - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
设置属性：Keywords
setKFREQ(int) - 类 com.trs.components.wcm.resource.Keyword 中的方法
设置属性：KFREQ
setKind(int) - 类 com.trs.components.common.bookmark.BookMark 中的方法
setKind(MarkKind) - 类 com.trs.components.common.bookmark.BookMark 中的方法
setKind(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档分类
setKind(DocKind) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档分类
setKlass(String) - 类 com.trs.wcag2.Alertion 中的方法
setKNAME(String) - 类 com.trs.components.wcm.resource.Keyword 中的方法
设置属性：KNAME
setLaborResource(LaborResourceConfig) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setLastExeResult(int) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：上次执行结果
setLastExeTime() - 类 com.trs.components.common.job.Schedule 中的方法
设置上次执行时间为当前时间
setLastExeTime(CMyDateTime) - 类 com.trs.components.common.job.Schedule 中的方法
设置上次执行时间为指定时间
setLastTimeUsed(int) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：上次执行所用时间
setLegalPerson(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：LegalPerson
setLength(int) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：Length
setLength(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：Length
setLevel(int) - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Sets the compression level.
setLevel(int) - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
Sets default compression level.
setLevel(String) - 类 com.trs.wcag2.Alertion 中的方法
setLibId(int) - 类 com.trs.wcm.photo.Watermark 中的方法
setLimit(int) - 类 com.trs.components.comment.domain.NewsComment 中的方法
设置发言控制
setLink(String) - 类 com.trs.components.common.bookmark.BookMark 中的方法
setLink(String) - 类 com.trs.components.wcm.resource.Source 中的方法
设置来源链接
setLinkPath(String) - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
设置属性：LinkPath
setLinkTitle(String) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
设置链接中的标题
setLinkTitle(String) - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
设置链接中的标题
setLinkType(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
setLinkType(int) - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
setLinkUrl(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
Sets the link url of this folder.
setLinkUrl(String) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
获取链接
setLinkUrl(String) - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
获取链接
setListeners(ArrayList) - 类 com.trs.infra.persistent.listener.MonitorHostConfig 中的方法
setLiteralPrefix(String) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法
setLiteralSuffix(String) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法
setLoadAllDatas(boolean) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
是否一次载入所有数据，而不进行分页
setLoadBatchContentsModal(int) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setLoadBatchContentsPageSize(int) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
setLoadText(boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法
设置是否在第一次的时候载入元素的大字段信息
setLoadText(boolean) - 类 com.trs.infra.persistent.BaseObjs 中的方法
设置是否在第一次的时候载入元素的大字段信息
setLocalFile(String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 中的方法
设置本地文件
setLocalPath(String) - 类 com.trs.infra.support.config.PathConfig 中的方法
设置本地路径
setLocalPath(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
设置本地的默认路径
setLocalPubPath(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
设置FTP登录的本地路径信息
setLocation(String) - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法
setLog(String) - 类 com.trs.infra.util.email.CMyMailLog 中的方法
setLogId(int) - 类 com.trs.infra.support.log.LogBak 中的方法
setLoginPassword(String) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：LoginPassword
setLoginTime(CMyDateTime) - 类 com.trs.components.stat.UserLoginInfo 中的方法
设置属性：LoginTime，用户登录时间
setLoginUser(User) - 类 com.trs.cms.ContextHelper 中的静态方法
设置当前线程的登录用户
setLoginUser(String) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：LoginUser
setLogoOrder(int) - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
设置属性：LogoOrder
setLogTime(CMyDateTime) - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
设置属性：LogTime
setLogType(int) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志类型
setLogType(LogType) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志类型
setLogType(LogType) - 接口 com.trs.infra.support.log.ILog 中的方法
设置日志类型
setLogType(int) - 接口 com.trs.infra.support.log.ILog 中的方法
setLogUserIP(String) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
setLogUserIP(String) - 接口 com.trs.infra.support.log.ILog 中的方法
设置触发日志记录的用户的登录IP
setLowPriorityLaborsMax(int) - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法
setMailBody(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：MailBody
setMailFormat(int) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置邮件格式
setMailTitle(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：MailTitle
setMainFileExt(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置主页面的扩展名
setMainFileName(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置主页面的文件名
setMainTable(MetaDBTable) - 类 com.trs.components.metadata.definition.MetaView 中的方法
setMainTableId(int, String) - 类 com.trs.components.metadata.definition.MetaView 中的方法
setMainViewId(int) - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
设置属性：MainViewId
setMapParameters(HashMap) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法
setMapping(File) - 类 com.trs.infra.config.persistent.ConfigFile 中的方法
setMappingSrc(String) - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的方法
set the mapping file src
setMarkImageFile(String) - 类 com.trs.wcm.photo.ImageInfo 中的方法
setMarkPos(int[]) - 类 com.trs.wcm.photo.ImageInfo 中的方法
setMasteId(int) - 类 com.trs.components.special.Special 中的方法
设置属性：MasteId
setMaxBufferSize(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
属性设置：缓冲区最大容量
setMaxCacheSize(int) - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
设置最大缓冲大小
setMaxClient(int) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置所允许的最大客户端连接数
setMaxConnects(int) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setMaxIdleTime(int) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setMaxIdleTime(int) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置连接有效的最大空闲时间
setMaxLength(int) - 类 com.trs.components.infoview.extract.DataType 中的方法
setMaxLength(int) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setMaxLength(int) - 类 com.trs.presentation.util.PageParameter 中的方法
设置参数允许的最大长度，仅仅对字符类型数据有效
setMaxLength(int) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置参数允许的最大长度，仅仅对字符类型数据有效
setMaxOrphanTime(int) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setMaxRowNumber(int) - 类 com.trs.infra.db.QueryFilter 中的方法
设置查询的最大行数
setMaxRowNumber(int) - 类 com.trs.infra.persistent.WCMFilter 中的方法
设置查询的最大行数
setMaxSize(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
设置集合载入的最大数
setMaxTargetsEachFolder(int) - 类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig 中的方法
setMaxValue(String) - 类 com.trs.presentation.util.PageParameter 中的方法
设置允许的最大值，对非字符类型数据有效
setMaxValue(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置允许的最大值，对非字符类型数据有效
setMDesc(String) - 类 com.trs.components.common.publish.widget.Master 中的方法
设置属性：MDesc
setMember(int, int) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
setMemberId(int) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
设置属性：MemberId
setMemberType(int) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
设置属性：MemberType
setMemo(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：Memo
setMergeFile(boolean) - 类 com.trs.infra.util.TRSJspAutoTool 中的方法
setMessage(int) - 类 com.trs.components.common.message.MsgQueue 中的方法
setMessage(Message) - 类 com.trs.components.common.message.MsgQueue 中的方法
setMessageReaded(Message, User, boolean) - 类 com.trs.components.common.message.MessageServer 中的静态方法
设置接收到的消息的已读状态
setMetaDataID(int) - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
设置属性：MetaDataID
setMetaDataId(int) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
setMetaSynFields(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
setMetaView(MetaView) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
setMetaView(MetaView) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
setMetaViewId(int) - 类 com.trs.components.metadata.service.GovInfoToXML 中的静态方法
设置要处理的视图Id
setMethdoNameHashCode(int) - 类 com.trs.webframework.config.MethodConfig 中的方法
setMethod(int) - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Sets the compression method.
setMethod(int) - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
Sets default compression method.
setMethod(Method) - 类 com.trs.webframework.config.MethodConfig 中的方法
setMethodName(String) - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法
setMimeMail(boolean) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置是否对邮件进行MIME编码
setMinLength(int) - 类 com.trs.components.infoview.extract.DataType 中的方法
setMinLength(int) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
setMinLength(int) - 类 com.trs.presentation.util.PageParameter 中的方法
设置参数允许的最小长度
setMinLength(int) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置参数允许的最小长度
setMinValue(String) - 类 com.trs.presentation.util.PageParameter 中的方法
设置允许的最小值，对非字符类型数据有效
setMinValue(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置允许的最小值，对非字符类型数据有效
setMName(String) - 类 com.trs.components.common.publish.widget.Master 中的方法
设置属性：MName
setMobile(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置移动通讯联系地址
setMobile(String) - 类 com.trs.components.common.address.Contact 中的方法
setModal(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置ChnlDoc的类型
setMode(int) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：计划执行类型
setModule(int) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
设置属性：Module
setMonitorInterval(int) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
setMsgBody(String) - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法
setMsgId(int) - 类 com.trs.components.common.message.MsgReceiver 中的方法
设置对应的Message的ID
setMsgInterval(int) - 类 com.trs.cms.auth.persistent.User 中的方法
获取用户信息刷新时间
setMsgType(int) - 类 com.trs.components.common.message.MsgQueue 中的方法
setMyDocId(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
文档HTML内容过滤处理，用于文档HTML正文的显示处理
处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于：
[1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?
setMysqlSQL(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：MysqlSQL
setName(String) - 类 com.trs.cms.auth.config.OperationConfig 中的方法

setName(String) - 类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 中的方法

setName(String) - 类 com.trs.cms.auth.config.OperationRelatedConfig 中的方法

setName(String) - 类 com.trs.cms.auth.config.RightHostConfig 中的方法

setName(String) - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法

setName(String) - 类 com.trs.cms.auth.config.RightObjectConfig 中的方法

setName(String) - 类 com.trs.cms.auth.persistent.Group 中的方法
设置组的名称 要求：名称不重复 处理：名称区分大小写。
setName(String) - 类 com.trs.cms.auth.persistent.RightDef 中的方法

setName(String) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色名称
setName(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置用户名
setName(String) - 类 com.trs.cms.content.ExtendedField 中的方法
设置扩展字段名称
setName(String) - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法

setName(String) - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法

setName(String) - 类 com.trs.cms.process.config.FlowContentField 中的方法

setName(String) - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法

setName(String) - 类 com.trs.cms.process.config.OperatorConfig 中的方法

setName(String) - 类 com.trs.cms.process.config.ParamConfig 中的方法

setName(String) - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法

setName(String) - 类 com.trs.cms.process.config.ValueConfig 中的方法

setName(String) - 类 com.trs.cms.process.definition.Flow 中的方法
设置工作流名称
setName(String) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设置节点名称
setName(String) - 类 com.trs.cms.process.definition.FlowRule 中的方法
设置属性：Name
setName(String) - 类 com.trs.components.common.address.ContactGrp 中的方法

setName(String) - 类 com.trs.components.common.bookmark.BookMark 中的方法
名称要求不重复 处理：由函数isValid()检查，并区分大小写
setName(String) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
名称要求不重复 处理：由函数isValid()检查，区分大小写
setName(String) - 类 com.trs.components.common.calendar.EventType 中的方法
名称要求不重 处理：由函数isValid()检查，并区分大小写
setName(String) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：名称（要求名称不重复；区分大小写，由isValid处理）
setName(String) - 类 com.trs.components.common.message.MessageSendingConfig 中的方法

setName(String) - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

setName(String) - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法

setName(String) - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法

setName(String) - 类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig 中的方法

setName(String) - 类 com.trs.components.common.publish.config.persistent.PublishElementConfig 中的方法

setName(String) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

setName(String) - 类 com.trs.components.common.publish.config.persistent.TagFormatterConfig 中的方法

setName(String) - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 中的方法

setName(String) - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

setName(String) - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法

setName(String) - 类 com.trs.components.common.publish.config.PublishElementType 中的方法

setName(String) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
设置属性名称
setName(String) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
设置置标的名称
setName(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法

setName(String) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板的名称
setName(String) - 类 com.trs.components.common.publish.widget.Layout 中的方法
设置属性：Name
setName(String) - 类 com.trs.components.infoview.config.BindingBean 中的方法

setName(String) - 类 com.trs.components.infoview.config.GatewayPage 中的方法

setName(String) - 类 com.trs.components.infoview.extract.DataType 中的方法

setName(String) - 类 com.trs.components.infoview.extract.manifest.FileProperty 中的方法

setName(String) - 类 com.trs.components.infoview.extract.manifest.MenuArea 中的方法

setName(String) - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

setName(String) - 类 com.trs.components.infoview.extract.manifest.PackageFile 中的方法

setName(String) - 类 com.trs.components.infoview.extract.manifest.View 中的方法

setName(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setName(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setName(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setName(String) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

setName(String) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置视图的名称
setName(String) - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
设置属性：Name
setName(String) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：Name
setName(String) - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
设置属性：Name
setName(String) - 类 com.trs.components.metadata.definition.MetaView 中的方法
设置属性：Name
setName(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：Name
setName(String) - 类 com.trs.components.wcm.channel.VChannel 中的方法

setName(String) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
设置对象的名称
setName(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道的名称 名称要求：同一级（即相同父频道）的频道，名称不重复 处理：由函数isValid()检查，区分大小写
setName(String) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
设置名称
setName(String) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
设置扩展字段名称
setName(String) - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
设置名称
setName(String) - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法

setName(String) - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法

setName(String) - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
设置替换名称
setName(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点名称
setName(String) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
设置属性：Name
setName(String) - 类 com.trs.components.wcm.resource.DocKind 中的方法

setName(String) - 类 com.trs.components.wcm.resource.FileType 中的方法

setName(String) - 类 com.trs.components.wcm.resource.Security 中的方法
设置名称
setName(String) - 类 com.trs.components.wcm.resource.Source 中的方法
设置来源名称
setName(String) - 类 com.trs.components.wcm.resource.Status 中的方法
设置状态名称
setName(String) - 类 com.trs.components.wcm.WCMAppConfig 中的方法

setName(String) - 类 com.trs.infra.config.persistent.BeanConfig 中的方法

setName(String) - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法

setName(String) - 接口 com.trs.infra.config.persistent.IConfigElement 中的方法
设置配置对象的名称
setName(String) - 类 com.trs.infra.config.persistent.PluginConfig 中的方法

setName(String) - 类 com.trs.infra.persistent.cache.CachedObjectConfig 中的方法

setName(String) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

setName(String) - 类 com.trs.infra.persistent.db.DBConnectionConfigs 中的方法

setName(String) - 类 com.trs.infra.persistent.listener.MonitorHostConfig 中的方法

setName(String) - 类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 中的方法

setName(String) - 类 com.trs.infra.persistent.listener.ObjectMonitored 中的方法

setName(String) - 类 com.trs.infra.persistent.ObjectTypeConfig 中的方法

setName(String) - 类 com.trs.infra.ServerConfig 中的方法

setName(String) - 类 com.trs.infra.support.cache.CacheMgrConfig 中的方法

setName(String) - 类 com.trs.infra.support.config.SystemCollocationConfig 中的方法

setName(String) - 类 com.trs.infra.support.log.OperType 中的方法

setName(String) - 类 com.trs.infra.update.UpdateCommanderConfig 中的方法

setName(String) - 类 com.trs.infra.util.CMyXMLElement 中的方法

setName(String) - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

setName(String) - 类 com.trs.infra.util.email.SMTPServerConfigs 中的方法

setName(String) - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
设置属性名称
setName(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
设置Html元素标记
setName(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setName(String) - 类 com.trs.presentation.ids.RegFromConfig 中的方法

setName(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法

setName(String) - 类 com.trs.presentation.util.PageParameter 中的方法
设置名称(必须为英文)
setName(String) - 类 com.trs.scene.parser.SceneConnector 中的方法

setName(String) - 类 com.trs.scene.parser.SceneNode 中的方法

setName(String) - 类 com.trs.wcm.config.PageOperator 中的方法
设置属性：Name
setName(String) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置属性：Name
setName(String) - 类 com.trs.wcm.photo.ImageKind 中的方法

setName(String) - 类 com.trs.webframework.config.MethodConfig 中的方法

setName(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置名称(必须为英文)
setNameCacheMaxSize(int) - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

setNamespace(String) - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

setNeedPostTogether(boolean) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设置是否需要会签属性
setNeedWithAuthFilter(User, boolean) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

setNeedWithAuthFilter(User, boolean) - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 中的方法

setNeedWithAuthFilter(User, boolean) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

setNestParsed(boolean) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 中的方法
设置是否已经设置过被嵌套模板的变量
setNewBindName(String) - 类 com.trs.components.infoview.extract.DataType 中的方法

setNewcols(List) - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
设置新添加的列
setNewFile(String) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置重整之后的XSL文件的文件名
setNewProperties(Hashtable) - 类 com.trs.infra.persistent.BaseObj 中的方法

setNews(int, String) - 类 com.trs.components.comment.domain.Management 中的方法
设置WCM中的文档ID和文档标题(可选的)
setNewsId(int) - 类 com.trs.components.comment.domain.Management 中的方法
已过时。 被 setNews(int, String) 替代
setNewsId(int) - 类 com.trs.components.comment.domain.NewsComment 中的方法
设置新闻的ID
setNewSiteDesc(String) - 类 com.trs.components.wcm.content.domain.ChannelImporter 中的方法

setNewSiteName(String) - 类 com.trs.components.wcm.content.domain.ChannelImporter 中的方法
设置新的站点名称
setNewsTitle(String) - 类 com.trs.components.comment.domain.NewsComment 中的方法
设置新闻的标题
setNewTransform(String) - 类 com.trs.components.infoview.extract.manifest.View 中的方法

setNewXSLTFilet(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setNextId() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

setNextId() - 类 com.trs.infra.persistent.BaseObj 中的方法
Created: 2004-12-22 11:48:34 Last Modified: 2004-12-22/2004-12-22 Description: 设置对象的ID值
setNextId(int) - 类 com.trs.infra.util.database.DBIdManager.IdSeq 中的方法
设置下一个有效的ID值
setNextNode(FlowNode) - 类 com.trs.cms.process.engine.FlowContext 中的方法

setNextNode(FlowNode) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setNextNode(int) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setNextNode(SceneNode) - 类 com.trs.scene.parser.SceneConnector 中的方法

setNextNodeName(String) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
设置下一个节点名称
setNickName(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置昵称
setNickName(String) - 类 com.trs.components.common.address.Contact 中的方法

setNillable(String) - 类 com.trs.components.infoview.extract.DataType 中的方法

setNillable(boolean) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setNode(FlowNode) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
设置第一个节点
setNode(int) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
设置第一个节点
setNode(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置所在的节点
setNode(FlowNode) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置所在的节点
setNodeId(int) - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
设置属性：NodeId
setNoiseLevel(int) - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
设置噪声级别 0：没有噪声，1：一个随机字节的噪声，2：两个字节相与后的噪声，3：三个字节相与后的噪声。
setNoOverWrite(boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 中的方法
设置是否禁止改写
setNotEdit(int) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：NotEdit
setNoticeContentPattern(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
设置回复主题模板
setNoticeRelatedField(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取回复通知目标的相关表单项
setNoticeSubjectPattern(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
设置回复主题模板
setNotifications(ArrayList) - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

setNotify(long) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
设置通知方式
setNotifyBy(int, boolean) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
设定指定的通知方式
setNotifyType(int) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setNotifyTypes(String) - 类 com.trs.cms.process.engine.FlowContext 中的方法

setNotifyTypes(String) - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法

setNotnull(int) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：Notnull
setNotNull(boolean) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：NotNull
setNotNull(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：NotNull
setNum(int) - 类 com.trs.wcag2.Alertion 中的方法

setObj(int, int) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法

setObj(CMSObj) - 类 com.trs.components.common.message.MsgQueue 中的方法

setObj(CMSObj) - 类 com.trs.components.wcm.recent.Recent 中的方法
设置属性：ObjType
setObj(BaseObj) - 类 com.trs.infra.support.log.BaseDBLog 中的方法

setObj(BaseObj) - 接口 com.trs.infra.support.log.ILog 中的方法

setObjClass(String) - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
设置属性：ObjClass
setObjCrTime(CMyDateTime) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
设置属性：ObjCrTime
setObjCrUser(String) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
设置属性：ObjCrUser
setObjDesc(String) - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
设置属性：ObjDesc
setObject(CMSObj) - 类 com.trs.cms.auth.persistent.Right 中的方法
设置操作对象（WCMObj）
setObject(int, int) - 类 com.trs.cms.auth.persistent.Right 中的方法

setObjectClass(Class) - 类 com.trs.infra.persistent.ObjectTypeConfig 中的方法

setObjectClassName(String) - 类 com.trs.infra.persistent.ObjectTypeConfig 中的方法

setObjectId(int) - 类 com.trs.webframework.context.MethodContext 中的方法

setObjectIds(String) - 类 com.trs.webframework.context.MethodContext 中的方法

setObjectIdsValue(String) - 类 com.trs.components.wcm.individuation.Individuation 中的方法
设置属性：ObjectIdsValue
setObjectType(int) - 类 com.trs.infra.persistent.ObjectTypeConfig 中的方法

setObjId(int) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
设置属性：ObjId
setObjId(int) - 类 com.trs.cms.auth.persistent.Right 中的方法
设置操作对象（WCMObj）ID
setObjId(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：ObjId
setObjId(int) - 类 com.trs.components.common.bookmark.MarkShare 中的方法

setObjId(int) - 类 com.trs.components.common.calendar.EventShare 中的方法
设置属性：ObjId
setObjId(int) - 类 com.trs.components.common.message.MsgQueue 中的方法

setObjId(int) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
设置属性：ObjId
setObjId(int) - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
设置属性：ObjId
setObjId(int) - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法

setObjId(int) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
设置对象ID号，允许为空
setObjId(int) - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
设置属性：ObjId
setObjId(int) - 类 com.trs.components.wcm.recent.Recent 中的方法
设置属性：ObjId
setObjId(int) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志操作对象编号
setObjId(int) - 接口 com.trs.infra.support.log.ILog 中的方法
设置日志操作对象编号
setObjName(String) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
设置属性：ObjName
setObjName(String) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志操作对象名称
setObjName(String) - 接口 com.trs.infra.support.log.ILog 中的方法
设置日志操作对象名称
setObjName(String) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置属性：ObjName
setObjPath(String) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置属性：ObjPath
setObjsName(String) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置属性：ObjsName
setObjsPath(String) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置属性：ObjsPath
setObjType(int) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
设置属性：ObjType
setObjType(int) - 类 com.trs.cms.auth.persistent.Right 中的方法
设置操作对象（WCMObj）类型（定义在WCMTypes中）
setObjType(int) - 类 com.trs.cms.auth.persistent.RightDef 中的方法

setObjType(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：ObjType
setObjType(int) - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
设置属性：ObjType
setObjType(int) - 类 com.trs.components.common.bookmark.MarkShare 中的方法
setObjType允许的对象类型为两类 OBJ_BOOKMARK OBJ_MARKKIND
setObjType(int) - 类 com.trs.components.common.calendar.EventShare 中的方法
设置属性：ObjType
setObjType(int) - 类 com.trs.components.common.message.MsgQueue 中的方法

setObjType(int) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
设置属性：ObjType
setObjType(int) - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
设置属性：ObjType
setObjType(int) - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法

setObjType(int) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
设置对象类型
setObjType(int) - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
设置属性：ObjType
setObjType(int) - 类 com.trs.components.wcm.recent.Recent 中的方法
设置属性：ObjType
setObjType(int) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志操作对象类型
setObjType(int) - 接口 com.trs.infra.support.log.ILog 中的方法
设置日志操作对象类型
setObjType(int) - 类 com.trs.template.persistent.TagFieldInfoEntity 中的方法

setObjTypeId(int) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志操作类型
setObjTypeId(int) - 接口 com.trs.infra.support.log.ILog 中的方法
设置日志操作类型
setOldFile(String) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置该视图原始XSL文件的文件名
setOnlyCached(boolean) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setOnlyManager(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置是否只作为管理节点
setOnlySearch(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置是否只使用检索条件
setOpArgs(String) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志操作参数
setOpArgs(String) - 接口 com.trs.infra.support.log.ILog 中的方法
设置日志操作参数
setOpenMode(int) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

setOpenWith(String) - 类 com.trs.components.wcm.resource.FileType 中的方法

setOperArgs(String) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：操作参数
setOperations(ArrayList) - 类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 中的方法

setOperations(ArrayList) - 类 com.trs.cms.auth.config.OperationRelatedConfig 中的方法

setOperator(CMSObj) - 类 com.trs.cms.auth.persistent.Right 中的方法
设置权限操作者对象（用户或角色） 说明：仅添加时可用
setOperator(int, int) - 类 com.trs.cms.auth.persistent.Right 中的方法

setOperatorConfigs(OperatorConfig[]) - 类 com.trs.cms.process.config.ParamConfig 中的方法

setOperatorId(int) - 类 com.trs.cms.auth.persistent.Right 中的方法
设置权限操作者（用户/角色）ID
setOperatorType(int) - 类 com.trs.cms.auth.persistent.Right 中的方法
设置权限操作者（用户/角色）类型(定义在WCMTypes)
setOperTime() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
记录站点/频道删除(恢复)操作的执行时间
setOperTime() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置操作时间
setOperType(String) - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
设置可以触发自动保存的操作类型
setOperUser(User) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
记录站点/频道删除(恢复)的操作者
setOperUser(String) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
记录站点/频道删除(恢复)的操作者
setOperUser(User) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置删除操作的用户
setOperUser(String) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置删除操作的用户名
setOpinion(String) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setOprKey(String) - 类 com.trs.wcm.config.PageOperator 中的方法
设置属性：OprKey
setOpTime(CMyDateTime) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置操作时间
setOpTime() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置操作时间
setOpTime(CMyDateTime) - 接口 com.trs.infra.support.log.ILog 中的方法
设置操作时间
setOpTime() - 接口 com.trs.infra.support.log.ILog 中的方法
设置操作时间
setOption(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
设置检索时的检索选项掩码
setOption(ChartOption) - 类 com.trs.components.wcm.stat.domain.TimingChartProducer 中的方法

setOptionId(int) - 类 com.trs.components.common.trsvote.VoteData 中的方法
设置属性：OptionId
setOpType(int) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置日志操作类型
setOpType(int) - 接口 com.trs.infra.support.log.ILog 中的方法
设置日志操作类型
setOracleSQL(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：OracleSQL
setOrder(int) - 类 com.trs.cms.process.definition.FlowAction 中的方法
设置属性：Order
setOrder(int) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
设置属性：Order
setOrder(int) - 类 com.trs.cms.process.definition.FlowRule 中的方法
设置属性：Order
setOrder(int) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：Order
setOrder(int) - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
设置分类顺序
setOrder(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：Order
setOrder(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道排序序号
setOrder(int) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
设置排序
setOrder(int) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点的排序序号
setOrder(String) - 类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 中的方法
设置排序条件
setOrder(int) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
设置排列顺序
setOrder(int) - 类 com.trs.components.wcm.resource.Source 中的方法
设置的排序序号
setOrder(String) - 类 com.trs.infra.db.QueryFilter 中的方法
设置排序条件
setOrder(String) - 类 com.trs.infra.persistent.BaseObjs 中的方法

setOrder(String) - 类 com.trs.infra.persistent.WCMFilter 中的方法
设置排序条件
setOrder(int) - 类 com.trs.wcm.config.PageOperator 中的方法
设置属性：Order
setOrderBy(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道默认的排序方式
setOrderBy(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点的默认的排序方式 说明：目前没有体现
setOrderField(String) - 类 com.trs.presentation.util.RequestHelper 中的方法

setOrderSelect(String) - 类 com.trs.infra.db.QueryFilter 中的方法

setOrderSelect(String) - 类 com.trs.infra.persistent.WCMFilter 中的方法

setOrderType(String) - 类 com.trs.presentation.util.RequestHelper 中的方法

setOrganizeCode(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：OrganizeCode
setOtherImageKinedId(int[]) - 类 com.trs.wcm.photo.ImageInfo 中的方法

setOtherOutlines(User, IPublishFolder, String) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法

setOtherOutlinesOfChannels(MethodContext, Template) - 类 com.trs.ajaxservice.TemplateEmployMgrHelper 中的静态方法

setOtherOutlinesOfSite(IPublishElement, Template) - 类 com.trs.ajaxservice.TemplateEmployMgrHelper 中的静态方法

setOtherOutlineTemplates(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法

setOtherRelatedKindIds(String) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置其它的默认分类
setOtherRelatedKindIds(String) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

setOtherTableIds(String) - 类 com.trs.components.metadata.definition.MetaView 中的方法

setOtherTableName(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法

setOuterMulti(boolean) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：OuterMulti
setOuterMultiCount(int) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：OuterMultiCount
setOuterPublic(boolean) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：OuterPublic
setOutlineDBFields(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
设置概览DB字段
setOutlineExt(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置概览页面的扩展名
setOutlineField(boolean) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setOutlineFields(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
设置概览字段
setOutlineFields(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置取该在频道概览页面需要显示的字段列表，以逗号分隔
setOutlineFields(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法

setOutlineFile(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道概览文件名
setOutlineFileName(String) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
设置属性：OutlineFileName
setOutlineFileName(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：OutlineFileName
setOutlineName(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置概览页面的文件名
setOutlinePageCount(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置共计发布了多少概览页面
setOutlineTemplateId(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：OutlineTemplateId
setOutlineTemplateId(int) - 类 com.trs.wcm.photo.ImageKind 中的方法

setOutlineTemplates(IPublishFolder, String, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
set outline template of the specified folder
setOutlineTemplates(IPublishFolder, String, boolean) - 类 com.trs.service.impl.TemplateService 中的方法

setOutlineTemplates(IPublishFolder, String, boolean) - 接口 com.trs.service.ITemplateService 中的方法
为指定频道设定概览模板
setOutputFileExt(String) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板的扩展名
setOutputFileName(String) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板发布后的输出文件名
setOutputImageFileExt(String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
设置输出图片文件的后缀名
setOutputImageFileExt(String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法

setOutString(String) - 类 com.trs.components.common.trsad.ADType 中的方法
设置属性：OutString
setOutUpId(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置外部上传ID
setOwner(int, int) - 类 com.trs.cms.process.definition.Flow 中的方法

setOwner(CMSObj) - 类 com.trs.cms.process.xml.FlowImporter 中的方法

setOwner(String) - 类 com.trs.components.common.calendar.Event 中的方法

setOwner(User) - 类 com.trs.components.common.calendar.Event 中的方法

setOwner(int, int) - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
设置视图所属对象
setOwner(int, int) - 类 com.trs.components.metadata.definition.MetaView 中的方法
设置视图所属对象
setOwnerId(int) - 类 com.trs.cms.process.definition.Flow 中的方法

setOwnerType(int) - 类 com.trs.cms.process.definition.Flow 中的方法

setPackage(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法

setPageEncoding(String) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
设置站点的页面编码
setPageEncoding(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置站点的页面编码
setPageHrefPre(String) - 类 com.trs.infra.util.CPager 中的方法
设置页面链接的前面部分
如：".
setPager(CPager) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

setPageSize(int) - 类 com.trs.infra.db.QueryFilter 中的方法

setPageSize(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
属性设置：分页大小
setPageSize(int) - 类 com.trs.infra.persistent.WCMFilter 中的方法

setPageSize(int) - 类 com.trs.infra.util.CPager 中的方法
设置页面大小
setPageStyleId(int) - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
设置属性：页面风格ID
setPageStyleId(int) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
设置属性：页面风格ID
setPageTaskCount(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：PageTaskCount
setParam(int) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：参数
setParamConfigs(ParamConfig[]) - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法

setParamConfigs(ParamConfig[]) - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法

setParameter(String, String) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

setParameter(String, int) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

setParameter(String, CMyDateTime) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

setParameter(String, String) - 类 com.trs.components.common.message.notify.Notifier 中的方法
set parameter value
setParameter(String, String) - 类 com.trs.webframework.config.ServiceFilterConfig 中的方法
设置Filter的配置参数
setParameter(String, String) - 类 com.trs.webframework.config.ServiceListenerConfig 中的方法
设置Listener的配置参数
setParameterDefault(String) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置形式参数的缺省值
setParameterName(String) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置形式参数的名称
setParameters(String) - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 中的方法

setParameters(String) - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
set the parameters config
setParameters(PreparedStatement, List) - 类 com.trs.infra.persistent.db.DBManager 中的静态方法

setParameters(PreparedStatement, WCMFilter) - 类 com.trs.infra.persistent.db.DBManager 中的静态方法

setParameterType(TemplateParameter.Type) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置形式参数的类型
setParameterType(String) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置形式参数的类型
setParameterValue(String, Object) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

setParamName(String) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
设置属性：ParamName
setParamName(String) - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
设置属性：ParamName
setParamName(String) - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
设置属性：ParamName
setParamName(String) - 类 com.trs.components.wcm.individuation.Individuation 中的方法
设置属性：ParamName
setParamNameContent(String) - 类 com.trs.infra.util.CMySMS 中的静态方法
设置参数Content的名称
setParamNameTo(String) - 类 com.trs.infra.util.CMySMS 中的静态方法
设置参数To的名称
setParams(String) - 类 com.trs.cms.process.definition.FlowAction 中的方法
设置属性：Params
setParamValue(String) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
设置属性：ParamValue
setParamValue(String) - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
设置属性：ParamValue
setParamValue(String) - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
设置属性：ParamValue
setParamValue(String) - 类 com.trs.components.wcm.individuation.Individuation 中的方法
设置属性：ParamValue
setParamValues(String, String[]) - 类 com.trs.webframework.context.MethodContext 中的方法

setParent(int) - 类 com.trs.cms.auth.persistent.Group 中的方法
设置父对象：仅新增模式下有效
setParent(Group) - 类 com.trs.cms.auth.persistent.Group 中的方法
设置父对象：仅新增模式下有效
setParent(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置所属事务轨迹
setParent(int) - 类 com.trs.components.common.address.ContactGrp 中的方法
设置父对象
setParent(ContactGrp) - 类 com.trs.components.common.address.ContactGrp 中的方法

setParent(int) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
设置父对象
setParent(MarkKind) - 类 com.trs.components.common.bookmark.MarkKind 中的方法

setParent(PublishTagContext) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Sets the parent tag parse context.
setParent(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
设置父tagitem
setParent(VChannel) - 类 com.trs.components.wcm.channel.VChannel 中的方法

setParent(int) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法

setParent(BaseChannel) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
Sets the parent of this channel.
setParent(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置父频道
setParent(int) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

setParent(WebSite) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

setParent(int) - 类 com.trs.components.wcm.resource.DocKind 中的方法

setParent(DocKind) - 类 com.trs.components.wcm.resource.DocKind 中的方法

setParent(HtmlElement) - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
设置
setParent(HtmlElement) - 类 com.trs.infra.util.html.HtmlComment 中的方法
设置父元素对象
setParent(HtmlElement) - 类 com.trs.infra.util.html.HtmlElement 中的方法
设置父元素对象
setParentFlag(String) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
设置属性：ParentFlag
setParentId(int) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
setParentId：设置父对象Id（为保证以前版本兼容而保留）
setParentId(int) - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
设置属性：ParentId
setParentId(int) - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法

setParsed(boolean) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
set the property of Parsed.
setPassive(boolean) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置是否使用Passve模式
setPassiveMode(boolean) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：PASSIVEMODE，禁用或者启用FTP协议中的Passive模式
setPassword(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置密码 密码长度不少于8个字符
setPassword(String) - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

setPassword(String) - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

setPassWord(String) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置登陆FTP服务器的用户口令
setPasswordLev(int) - 类 com.trs.cms.auth.persistent.User 中的方法
保存用户密码的安全级别
setPattern(String) - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法

setPAttribute(String) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PAttribute
setPChnlId(int) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PChnlId
setPChnlName(String) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PChnlName
setPClass(int) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PClass
setPDesc(String) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PDesc
setPeople(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置人物
setPeriodInterval(int) - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

setPeriodType(int) - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

setPHeight(int) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PHeight
setPicFileName(String) - 类 com.trs.components.common.publish.widget.Master 中的方法
设置属性：PicFileName
setPlace(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置地点
setPlugin(File) - 类 com.trs.infra.config.persistent.ConfigFile 中的方法

setPNo(int) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PNo
setPNum(int) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PNum
setPort(int) - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

setPort(int) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置FTP服务器的端口号
setPosition(int) - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法
设置Html检索的起始位置
setPositionX(int) - 类 com.trs.scene.tools.SceneNode 中的方法
设置X坐标
setPositionY(int) - 类 com.trs.scene.tools.SceneNode 中的方法
设置Y坐标
setPostCode(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：PostCode
setPostDesc(String) - 类 com.trs.cms.process.engine.FlowContext 中的方法

setPostDesc(String) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置递交说明
setPostTime(CMyDateTime) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置递交时间
setPostTime(CMyDateTime) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法

setPostUser(String) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：PostUser
setPostUser(User) - 类 com.trs.cms.process.engine.FlowContext 中的方法

setPostUser(String) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置递交用户
setPostUser(User) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置递交用户
setPostUser(User) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setPPrice(int) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PPrice
setPreDeclared(TemplateParameter) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置预先声明同名变量时使用的对象
setPrefix(String) - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法

setPrefixOfArgument(String) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
设置模板变量名称的前缀
setPrefixOfName(String) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
设置属性：PrefixOfName
setPreFlowDoc(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置上一次事务轨迹
setPreFlowDoc(FlowDoc) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置前一个轨迹
setPreImageKindId(int) - 类 com.trs.wcm.photo.ImageKind 中的方法

setPreNode(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置前一个节点
setPreNode(FlowNode) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置前一个节点
setPreNode(FlowNode) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setPreNode(int) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setPreNode(SceneNode) - 类 com.trs.scene.parser.SceneConnector 中的方法

setPrepareStatments(TRSToWCMFilter, PreparedStatement) - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的方法

setPrice(int) - 类 com.trs.cms.auth.persistent.User 中的方法
设置用户个人的稿件单价
setPrice(int) - 类 com.trs.components.wcm.resource.Source 中的方法
设置来源的稿件单价
setPricePerUnit(float) - 类 com.trs.components.stat.BonusRule 中的方法
设置属性：PricePerUnit
setPrimaryKey(String[]) - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法

setPriority(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
set the property of Priority
setProperties(Map) - 类 com.trs.components.metadata.center.MetaViewData 中的方法

setProperties(Hashtable) - 类 com.trs.infra.persistent.BaseObj 中的方法
将指定的属性列表数据拷贝到本对象中
setProperties(HashMap) - 类 com.trs.infra.util.CMyXMLElement 中的方法

setProperty(String, String) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法

setProperty(String, Object) - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法

setProperty(String, Object) - 类 com.trs.components.wcm.content.persistent.XDocument 中的方法

setProperty(String, long) - 类 com.trs.infra.persistent.BaseObj 中的方法
设置属性值 注意：不同类型的属性，必须使用相应匹配的对象作为属性值
setProperty(String, boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法

setProperty(String, Object, boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法

setProperty(String, Object) - 类 com.trs.infra.persistent.BaseObj 中的方法

setProperty(String, double) - 类 com.trs.infra.persistent.BaseObj 中的方法
导出数据到XML文件
setProperty(String, Object) - 类 com.trs.infra.persistent.CMyResultSet 中的方法

setProperty(String, Object) - 类 com.trs.infra.support.log.LogBak 中的方法

setProperty(String, String) - 类 com.trs.infra.util.CMyXMLElement 中的方法

setPropertyByDocument(Document) - 类 com.trs.wcm.old.WCMExcelData 中的方法
使用文档对象给新的对象设置属性
setPropertyWithString(String, String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

setPropertyWithString(String, String) - 类 com.trs.infra.persistent.BaseObj 中的方法
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象
setPropertyWithString(String, String) - 类 com.trs.presentation.util.Parameter 中的方法
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象
setPropertyWithString(String, String) - 类 com.trs.webframework.config.TRSParameter 中的方法
用字符串设置属性值 注意：根据属性的不同类型，将字符串型的属性值转化为对应的属性值对象
setProtocol(String) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置协议名称，在目前实现中为空方法，什么都不做。
setProxyInfo(String, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
设置代理服务器信息
setPStyle(String) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PStyle
setPType(int) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PType
setPubDistributionsEnable(WebSite, String, boolean) - 类 com.trs.service.impl.WCMPublishElementServiceImpl 中的方法

setPubDistributionsEnable(WebSite, String, boolean) - 接口 com.trs.service.IWCMPublishElementService 中的方法
将当前站点的指定分发信息设置为无效
setPubHtmlContent(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档的Html文本
setPublicCache(HashMap) - 类 com.trs.components.metadata.center.MetaViewData 中的方法

setPublicCache(HashMap) - 类 com.trs.components.wcm.content.ViewDocument 中的方法

setPublicFill(boolean) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setPublicFill(boolean) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

setPublicFill(boolean) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置该视图是否公共可填写，即是否发布到公网
setPublicPasswordField(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setPublicPasswordPattern(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setPublicPasswordRequired(boolean) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setPublicRandomSerialPattern(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setPublicRandomSerialRequired(boolean) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setPublicView(boolean) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setPublicView(boolean) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

setPublicView(boolean) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置该视图的数据是否任何人都可以查看 注意：到2006.07.13，尚未实现
setPublishAllViews(boolean) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setPublishDistribution(PublishDistributionConfig) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

setPublishedStatus(int) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

setPublishElement(IPublishElement) - 类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 中的方法

setPublishElement(IPublishElement) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPageTask 中的方法

setPublishElement(IPublishElement) - 类 com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask 中的方法

setPublishElement(IPublishElement) - 类 com.trs.components.common.publish.domain.taskdispatch.SinglePageTask 中的方法

setPublishInRootPath(boolean) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

setPublishSrvId(String) - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法

setPublishStatus(int) - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Sets the publish status of this content in the specified folder
setPublishStatus(int) - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
Sets the publish status of this folder
setPublishStatus(int) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

setPublishStatus(int) - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

setPublishStatus(int) - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

setPublishStatus(int) - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

setPublishStatus(int) - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

setPublishStatus(int) - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

setPublishStatus(int) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

setPublishStatus(int) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

setPublishStatus(int) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

setPublishStatus(int) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

setPublishStatus(int) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

setPublishTask(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
设置属性：PublishTaskId
setPublishTask(PublishTask) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
set the property of PublishTask
setPublishTime(CMyDateTime) - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
设置当前内容的发布时间
setPublishTime(CMyDateTime) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

setPublishTime(CMyDateTime) - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

setPublishTime(CMyDateTime) - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

setPublishTime(CMyDateTime) - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

setPublishTime(CMyDateTime) - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

setPublishTime(CMyDateTime) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

setPublishTimeAndURL(CMyDateTime, String) - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
设置当前内容发布后的URL，如果时间或者URL设置为null，则意味着页面被取消
setPublishTimeAndURL(CMyDateTime, String) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

setPublishTimeAndURL(CMyDateTime, String) - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

setPublishTimeAndURL(CMyDateTime, String) - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

setPublishTimeAndURL(CMyDateTime, String) - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

setPublishTimeAndURL(CMyDateTime, String) - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

setPublishTimeAndURL(CMyDateTime, String) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

setPublishType(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：PublishType
setPubMyInfo(boolean) - 类 com.trs.cms.auth.persistent.User 中的方法
设置是否公开个人信息
setPubPathStartTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法
设置发布文件按照日期存放的起始时间
setPubScriptURI(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setPubStatus(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点的可发布文档状态
setPubStyleURI(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setPubTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置发布时间
setPubTimeAndURLFieldName(String, String) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

setPubURL(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档发布后的地址
setPurpose(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：Purpose
setPWidth(int) - 类 com.trs.components.common.trsad.ADPos 中的方法
设置属性：PWidth
setQuery(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道的查询条件
setQueryCode(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：QueryCode
setQueryFilter(QueryFilter) - 类 com.trs.webframework.context.MethodContext 中的方法

setQuote(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
为文档指定引用,用于编辑器中维护文档的所有引用关系
setQuotedFolder(int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
Sets the quoted folder with a specified folder.
setQuotedFolder(int, int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
Sets the quoted folder property.
setQuotedFolderWithChild(int) - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
Sets the quoted folder with the child of current folder who employs this template.
setQuotedFolderWithParent() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
Set the quoted folder with the parent of current folder who employs this template.
setQuoteType(int) - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
设置属性：QuoteType
setRadioOrCheck(boolean) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：radioOrCheck
setRadioOrCheck(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：radioOrCheck
setRadorchk(int) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：Radorchk
setRandomSerial(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法

setRange(String) - 类 com.trs.components.stat.BonusRule 中的方法
设置属性：Range
setRangeIndexs(String) - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法

setRatio(String) - 类 com.trs.components.common.publish.widget.Layout 中的方法
设置属性：Ratio
setRatioType(int) - 类 com.trs.components.common.publish.widget.Layout 中的方法
设置属性：RatioType
setRead(boolean) - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法

setReaded(boolean) - 类 com.trs.components.common.message.MsgQueue 中的方法

setReadField(boolean) - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
设置字段为可读
setReadFileURL(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setReadFlag(MethodContext) - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法
将消息设置为已读
setReadOnly(boolean) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setRealtedKindId(int) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置默认主分类
setRealtedKindId(int) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

setRecCount(int) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
设置本次查询的记录个数
setRecCount(int) - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
设置本次查询的记录个数
setRecCount(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
设置本次查询的记录个数
setReceiverId(int) - 类 com.trs.components.common.message.MsgReceiver 中的方法
设置接收者ID
setReceiverName(String) - 类 com.trs.components.common.message.MsgReceiver 中的方法
设置接收者的名称
setReceivers(int, String) - 类 com.trs.components.common.message.Message 中的方法
设置消息的接收者
setReceiverType(int) - 类 com.trs.components.common.message.MsgReceiver 中的方法
设置接收者的类型
setReceiveTime() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
使用当前时间设置接收时间
setRecordNum(int) - 类 com.trs.components.wcm.content.trsserver.ClassInfo 中的方法
设置分类的记录数
setRecordUsedTime(boolean) - 类 com.trs.presentation.util.LoginHelper 中的方法
属性设置：是否记录操作所用时间
setRecursive(boolean) - 类 com.trs.infra.util.ConfigElementContentTester 中的静态方法

setRefName(String) - 类 com.trs.components.infoview.extract.DataType 中的方法

setRefresh(String) - 类 com.trs.components.infoview.extract.manifest.CalculatedField 中的方法

setRefType(DataType) - 类 com.trs.components.infoview.extract.DataType 中的方法

setRegFrom(String) - 类 com.trs.presentation.ids.RegFromConfig 中的方法
设置注册来源
setRegion(int) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
设置定制的布局区域号
setRegionEmployId(int) - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
设置属性：RegionEmployId
setRegionId(int) - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
设置属性：RegionId
setRegionInfoId(int) - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
设置属性：RegionInfoId
setRelatedColumn(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

setRelatedConvertType(String) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置bmp文件转换格式
setRelatedConvertType(String) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

setRelatedDocIds(String) - 类 com.trs.components.comment.domain.CommentUpdator 中的方法

setRelatedWaterMarkId(int) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置水印
setRelatedWaterMarkId(int) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

setRelatedWaterMarkPos(String) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置水印位置
setRelatedWaterMarkPos(String) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

setRelateObject(Object) - 类 com.trs.infra.util.Report 中的方法

setRelateSiteId(int) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置相关站点
setRelateSiteId(int) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

setRelateWords(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置相关词（用于相关文档搜索）
setRelationDoc() - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法

setRelationForDocs(Documents, Documents) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法

setRelationOperator(String) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
设置属性：RelationOperator
setRelDocId(int) - 类 com.trs.components.wcm.content.persistent.Relation 中的方法
设置相关文档的ID
setReleaseTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置撰写时间
setRemindBy(int, boolean) - 类 com.trs.components.common.calendar.Event 中的方法

setRemindDone(int) - 类 com.trs.components.common.calendar.Event 中的方法
置指定类型的提醒已经完成 说明：若当前提醒设置不是WCMTypes.YES，则抛出无效操作异常
setReminderAnswer(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置找回密码时的答案
setReminderQuestion(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置找回密码时的问题
setRemotePath(String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 中的方法
设置远程（目标）文件或者目录
setRemotePath(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
设置FTP服务器的默认路径
setRemoveable(boolean) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色是否可以删除
setRepeatField(String, String, int) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法

setReplyNoticeRequired(boolean) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
设置是否需要回复通知
setReplyTo(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置回复地址
setRequest(HttpServletRequest) - 类 com.trs.presentation.util.RequestHelper 中的方法
获取当前J2EE容器中的Request对象
setRequired(boolean) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
设置对于当前置标该属性是不是必须的
setRequired(boolean) - 类 com.trs.presentation.util.PageParameter 中的方法
设置参数是否需要传入
setRequired(boolean) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置参数是否需要传入
setResetButton(boolean) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setResoruceStylePrivate(ContentStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。
setResoruceStylePrivate(ContentStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
设置内容可用风格的属性为私有风格，用于删除系统级的内容可用风格时。
setResourceId(int) - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
设置属性：ResourceId
setResourceStylePrivate(ResourceStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。
setResourceStylePrivate(ResourceStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
设置资源可用风格的属性为私有风格，用于删除系统级的资源可用风格时。
setResponse(HttpServletResponse) - 类 com.trs.presentation.util.RequestHelper 中的方法

setResubmit(boolean) - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法

setResult(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
设置属性：Result
setResult(boolean) - 类 com.trs.components.metadata.service.util.WCMJSPChecker 中的方法

setResult(int) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置操作结果
setResult(int) - 接口 com.trs.infra.support.log.ILog 中的方法
设置操作结果
setResult(boolean) - 类 com.trs.presentation.jsputil.JspChecker 中的方法

setResultIds(int[]) - 类 com.trs.infra.util.Reports 中的方法
设置Reports记录的处理对象的Id数组
setResultTable(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ResultTable
setRetryInterval(int) - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法

setRetryTimeLimit(int) - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法

setReturnHTML(boolean) - 类 com.trs.webframework.context.MethodContext 中的方法

setReturnHTML(boolean) - 类 com.trs.webframework.context.ServiceContext 中的方法

setReturnJSON(boolean) - 类 com.trs.webframework.context.MethodContext 中的方法
设置返回值为JSON
setReturnJSON(boolean) - 类 com.trs.webframework.context.ServiceContext 中的方法

setRight(int, boolean) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
设置指定权限索引的权限，并返回自身以支持链式操作
setRightDefined(boolean) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置是否单独定义了用户的权限属性
setRightDefs(RightDefs) - 类 com.trs.components.wcm.util.CRightUtil 中的方法

setRightIndex(int) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

setRightIndex(int) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

setRightIndex(int) - 类 com.trs.components.wcm.resource.Status 中的方法
设置状态相关权限值
setRightIndex(int) - 类 com.trs.wcm.config.PageOperator 中的方法
设置属性：Order
setRights(User, IRightHost, List, boolean) - 类 com.trs.cms.auth.domain.RightSet 中的方法

setRightValue(long) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色的权限（可以做的所有操作）
setRoleId(int) - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
设置属性：RoleId
setRoleId(int) - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
设置属性：RoleId
setRoleIds(String) - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法

setRoleOrder(int) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置属性：RoleOrder
setRoleRange(int) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色所属范围，默认为0，
setRoleType(int) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色所属类型，默认为0，
setRoleUsers(Role, int, Users) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
绑定角色,站点和用户的关联，同时将清除原来的关联
setRoleUsers(int, String) - 类 com.trs.service.impl.RoleService 中的方法

setRoleUsers(int, String) - 接口 com.trs.service.IRoleService 中的方法

setRoot(IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法

setRoot(int, int) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
设置模板附件的所属文件夹根目录
setRoot(IPublishFolder) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
设置模板附件的所属文件夹根目录
setRoot(int, int) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板的所属文件夹根目录，仅添加模板时可用，不允许修改该属性。
setRoot(IPublishFolder) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

setRootConfig(CMyXMLElement) - 类 com.trs.infra.util.CMyXMLHandler 中的方法

setRootDomain(String) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法

setRootDomain(String) - 类 com.trs.components.wcm.channel.VChannel 中的方法

setRootDomain(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：RootDomain
setRootElement(String) - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

setRootElement(HtmlElement) - 类 com.trs.infra.util.html.HtmlDocument 中的方法
设置根元素 操作：检查是否已经存在根元素。
setRootId(int) - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
设置属性：RootId
setRootId(int) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

setRootPath(String) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置远端文件所在的路径
setRootSchema(String) - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

setRowIndex(int) - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
设置属性：RowIndex
setRowNumber(int) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
设置属性：ROWNUMBER
setRportDetail(String) - 类 com.trs.infra.util.Report 中的方法
设置详细内容
setRportTitle(String) - 类 com.trs.infra.util.Report 中的方法
设置标题
setRst(List) - 类 com.trs.wcag2.Alertion 中的方法

setRuleId(int) - 类 com.trs.cms.process.definition.FlowAction 中的方法
设置属性：RuleId
setRuleId(int) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
设置属性：RuleId
setRuntimePath(String) - 类 com.trs.tools.ResourceAnalyzer 中的静态方法

setSavePublishConfig(boolean) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法

setScale(int) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：Scale
setScale(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：Scale
setScaleSizes(int[], String[], int[]) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
设置图片库自动缩放的图片尺寸、描述以及添加的水印大小
setScaleSizes(int[], String[], int[]) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

setScheduleMode(int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：ScheduleMode
setSchedulePublish(CMyDateTime) - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 中的方法

setSchedulePublishTask(boolean) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置ISSCHEDULEDTASK属性,是否为计划发布
setSchemaFile(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setScriptURI(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setSearch(boolean) - 类 com.trs.presentation.util.PageParameter 中的方法

setSearch(boolean) - 类 com.trs.webframework.config.TRSPageParameter 中的方法

setSearchDBFields(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
设置检索DB字段
setSearchField(boolean) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setSearchField(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：SearchField
setSearchField(String) - 类 com.trs.presentation.util.PageParameter 中的方法

setSearchField(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法

setSearchFields(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
设置检索字段
setSearchFields(String) - 类 com.trs.infra.util.TRSJspAutoTool 中的方法

setSearchKey(String) - 类 com.trs.presentation.util.RequestHelper 中的方法

setSearchKeys(String) - 类 com.trs.presentation.util.AppAutoParameter 中的方法

setSearchOperator(String) - 类 com.trs.presentation.util.PageParameter 中的方法

setSearchOperator(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法

setSearchTableName(String) - 类 com.trs.presentation.util.RequestHelper 中的方法

setSearchType(String) - 类 com.trs.presentation.util.PageParameter 中的方法

setSearchType(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法

setSearchValue(String) - 类 com.trs.presentation.util.RequestHelper 中的方法

setSearchValues(List) - 类 com.trs.infra.db.QueryFilter 中的方法

setSearchValues(List) - 类 com.trs.infra.persistent.WCMFilter 中的方法

setSearchValues(List) - 类 com.trs.presentation.util.DefaultWhereSQLMaker 中的方法

setSecurity(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置安全级别
setSecurity(Security) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置安全级别
setSecurity(int) - 类 com.trs.components.wcm.resource.Source 中的方法
设置与来源有关的安全级别
setSecurity(Security) - 类 com.trs.components.wcm.resource.Source 中的方法
设置与来源有关的安全级别
setSelect(String) - 类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 中的方法
设置抽取的字段名列表
setSelect(String, String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

setSelect(String) - 类 com.trs.infra.db.QueryFilter 中的方法
设置抽取的字段名列表
setSelect(String) - 类 com.trs.infra.persistent.BaseObjs 中的方法

setSelect(String) - 类 com.trs.infra.persistent.WCMFilter 中的方法
设置抽取的字段名列表
setSelectFields(String, String, String) - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法

setSelectFields(String, String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

setSelectFields(String, String) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

setSelectFieldsFromChnlDoc(String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

setSelectFieldsFromChnlDoc(String) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

setSelectFieldsFromDocument(String) - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

setSelectFieldsFromInfoView(String) - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法

setSelectFieldsOfMetaTable(String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

setSelectParameters(String[]) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
指定Request中使用的参数
setSelectParameters(String[], boolean) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
指定Request中使用的参数
setSelfURL(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setSendEmail(boolean) - 类 com.trs.components.infoview.InfoViewReplyNoticeSender 中的方法

setSender(int, int) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：发送者
setSender(CMSObj) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：发送者
setSendMessage(boolean) - 类 com.trs.components.infoview.InfoViewReplyNoticeSender 中的方法

setSendType(String) - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法

setSendTypes(String) - 类 com.trs.components.common.message.Message 中的方法
设置消息发送类型
setSendTypes(String[]) - 类 com.trs.components.common.message.Message 中的方法
设置消息发送类型
setSendUrlPre(String) - 类 com.trs.infra.util.CMySMS 中的静态方法
设置用于发送短信息的Url前半部分
eg."
setSendWarningIfFileNotFound(boolean) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

setSequenceNumber(int) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

setSerialField(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setSerialNo(int) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

setSerialNum(long) - 类 com.trs.cms.process.engine.FlowContext 中的方法

setSerialNum(long) - 类 com.trs.cms.process.engine.FlowDoc 中的方法

setSerialNum(long) - 接口 com.trs.cms.process.IFlowContent 中的方法
设置内容被发起时候的SerialNum
setSerialNum(long) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

setSerialNum(long) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

setSerialPattern(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setSerialPeriod(int) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setServer(String, String, String) - 类 com.trs.infra.util.soap.CMySoapClient 中的方法

setServerName(String) - 类 com.trs.infra.BaseServer 中的方法

setServerName(String) - 接口 com.trs.infra.IServer 中的方法
设置服务名称
setServerName(String) - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

setServerPort(int) - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

setServiceContext(ServiceContext) - 类 com.trs.webframework.context.MethodContext 中的方法

setShare(boolean) - 类 com.trs.components.common.calendar.Event 中的方法

setShowIf(String) - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

setShowLegend(boolean) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法

setSimpleType(boolean) - 类 com.trs.components.infoview.extract.DataType 中的方法

setSingleton(boolean) - 类 com.trs.infra.config.persistent.BeanConfig 中的方法

setSite(int, String) - 类 com.trs.components.comment.domain.Management 中的方法
设置WCM中站点ID和站点名(必须的)
setSite(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置所属站点：仅添加频道时可用，不允许修改该属性
setSite(WebSite) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置所属站点：仅添加频道时可用，不允许修改该属性
setSite(int) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置表单的所属站点，仅添加表单时可用，不允许修改该属性。
setSite(WebSite) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置表单的所属站点，仅添加表单时有效，不允许修改
setSiteDesc(String) - 类 com.trs.template.persistent.WebSiteInfoEntity 中的方法

setSiteId(int) - 类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 中的方法
设置相关站点ID
setSiteId(int) - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
设置属性：SiteId
setSiteId(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：SiteId
setSiteId(int) - 类 com.trs.components.comment.domain.NewsComment 中的方法
设置站点 ID
setSiteId(int) - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

setSiteId(int) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：SITEID
setSiteID(int) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setSiteID(int) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setSiteId(int) - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
设置站点ID
setSiteId(int) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
设置所属站点
setSiteId(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置属性：SiteId
setSiteId(int) - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
设置所属站点
setSiteId(int) - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法
设置属性：SiteId
setSITEID(int) - 类 com.trs.components.wcm.resource.Keyword 中的方法
设置属性：SITEID
setSiteId(int) - 类 com.trs.template.persistent.WebSiteInfoEntity 中的方法

setSiteLanguage(int) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
设置站点的语言选项
setSiteLanguage(int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置站点的语言选项
setSiteMembers(int, int, String) - 接口 com.trs.service.IChannelService 中的方法
设置站点成员,一个站点成员可以是系统中的一个用户或一个组织
setSiteMembers(WebSite, int, String) - 接口 com.trs.service.IChannelService 中的方法
设置站点成员,一个站点成员可以是系统中的一个用户或一个组织
setSiteMembers(int, int, String) - 类 com.trs.service.impl.ChannelService 中的方法
设置站点成员,一个站点成员可以是系统中的一个用户或一个组织
setSiteMembers(WebSite, int, String) - 类 com.trs.service.impl.ChannelService 中的方法
设置站点成员,一个站点成员可以是系统中的一个用户或一个组织
setSiteName(String) - 类 com.trs.template.persistent.WebSiteInfoEntity 中的方法

setSiteProp(int, boolean) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置站点指定索引的属性
setSITETYPE(int) - 类 com.trs.components.wcm.resource.Keyword 中的方法
设置属性：SITETYPE
setSiteType(int) - 类 com.trs.presentation.nav.RadarTreeCreator 中的方法

setSize(long) - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Sets the size of the uncompressed data.
setSkipValid(boolean) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
是否跳过校验
setSMTPConfig(SMTPServerConfig) - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

setSMTPServerConfigColl(ArrayList) - 类 com.trs.infra.util.email.SMTPServerConfigs 中的方法

setSocketTimeOut(int) - 类 com.trs.infra.util.email.TRSMailer 中的方法

setSolution(String) - 异常 com.trs.template.AbstractErrorMessage 中的方法
设置错误解决办法
setSource(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档来源
setSource(Source) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档来源
setSourceId(int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
设置属性：SourceId
setSpecailRolesOfUser(User, Roles) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
设置用户的特定角色，同时将清除原来的特定角色d关联
setSpecial(boolean) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
设置属性：IsSpecial
setSpecialDesc(String) - 类 com.trs.components.special.Special 中的方法
设置属性：SpecialDesc
setSpecialName(String) - 类 com.trs.components.special.Special 中的方法
设置属性：SpecialName
setSpecialRight(boolean) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setSpecialRight(boolean) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

setSpecialRight(boolean) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置该视图是否单独设置过权限
setSplitBy(String) - 类 com.trs.components.infoview.config.EnumCreator 中的方法

setSQLServerSQL(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：SQLServerSQL
setSrcChannelId(int) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
设置属性：SrcChannelId
setSrcContentStyleId(int) - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
设置属性：源内容风格ID
setSrcFile(String) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件的源文件名
setSrcFileName(String) - 类 com.trs.wcm.photo.ImageInfo 中的方法

setSrcPageStyleId(int) - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
设置属性：源页面风格
setSrcPath(String) - 类 com.trs.tools.ResourceAnalyzer 中的静态方法

setSrcResourceStyleId(int) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
设置属性：源资源风格ID
setSSLServer(boolean) - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

setStartFolder(IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法

setStarting(boolean) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：Starting
setStartNodeName(String) - 类 com.trs.cms.process.definition.Flow 中的方法
设置起始节点名称
setStartPos(int) - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 中的方法

setStartPos(int) - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser4List 中的方法
Sets the start position
setStartPos(int) - 类 com.trs.components.metadata.publish.WCMTagParserClassInfos 中的方法

setStartPos(int) - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法

setStartPos(int) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 中的方法

setStartPos(int) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法

setStartPos(int) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法

setStartStatTime(CMyDateTime) - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

setStartTime(CMyDateTime) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
设置属性：StartTime
setStartTime(CMyDateTime) - 接口 com.trs.cms.process.IFlowContent 中的方法
设置内容被发起的时间
setStartTime(CMyDateTime) - 类 com.trs.components.common.calendar.Event 中的方法

setStartTime(CMyDateTime) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：开始执行时间
setStartTime(CMyDateTime) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：StartTime
setStartTime(CMyDateTime) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

setStartTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道文档列表的开始时间
setStartTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
属性设置：开始执行时间
setStartTime(CMyDateTime) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

setStartTime(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：StartTime
setStartTimeMillis(long) - 类 com.trs.infra.support.log.BaseDBLog 中的方法

setStartTimeMillis(long) - 接口 com.trs.infra.support.log.ILog 中的方法

setStartup(boolean) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：Startup
setStartUser(User) - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法

setStartUserName(String) - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法

setStatFieldMaps(StatFieldMaps) - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的方法

setStatFieldMaps(StatFieldMaps) - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的方法

setStatHost(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：StatHost
setStatResults(CMyResultSets) - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的方法

setStatResults(CMyResultSets) - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的方法

setStatTempId(int) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
设置属性：StatTempId
setStatTime(CMyDateTime) - 类 com.trs.components.wcm.stat.domain.StatDataItem 中的方法

setStatTimeField(String) - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

setStatus(int) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
设置属性：Status
setStatus(int) - 类 com.trs.cms.auth.persistent.User 中的方法
设置用户当前状态
setStatus(int) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
设置文档经过此分支时自动改变后的状态
setStatus(Status) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
设置文档经过此分支时自动改变后的状态
setStatus(int) - 类 com.trs.components.common.job.Schedule 中的方法
属性设置：计划状态
setStatus(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
set the property of Status
setStatus(int) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
设置站点/频道的状态值(STATUS_NORM等)
setStatus(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道状态（Channel.STATUS_NORM等）
setStatus(String) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法

setStatus(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档状态
setStatus(Status) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档状态
setStatus(Status, boolean) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档状态
setStatusCode(int) - 类 com.trs.infra.util.ResponseBuddy 中的方法

setStatusesCanDoPub(String) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：StatusesCanDoPub
setStatusesCanDoPub(String) - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
设置属性：StatusesCanDoPub
setStatusFieldName(String) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

setStatusId(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
设置属性：StatusId
setStatusIdAfterModify(int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
设置属性：StatusIdAfterModify
setStatusIdAfterModify(int) - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
设置属性：StatusIdAfterModify
setStatViewRelation(StatView, StatViews) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
设置模板视图和嵌入视图的关联关系
setStatViewRelation(int, String) - 类 com.trs.service.impl.StatService 中的方法

setStatViewRelation(StatView, StatViews) - 类 com.trs.service.impl.StatService 中的方法

setStatViewRelation(int, String) - 接口 com.trs.service.IStatService 中的方法
设置模板视图和嵌入视图的关联关系
setStatViewRelation(StatView, StatViews) - 接口 com.trs.service.IStatService 中的方法
设置模板视图和嵌入视图的关联关系
setStopNoop(boolean) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法

setStrategy(int) - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Sets the compression strategy.
setStrEndWith(String, char) - 类 com.trs.infra.util.CMyString 中的静态方法
设置字符串最后一位为指定的字符
setStringFieldValue(PreparedStatement, int, String) - 类 com.trs.infra.util.database.DBType 中的方法

setStringFieldValue(PreparedStatement, int, String, boolean) - 类 com.trs.infra.util.database.DBType 中的方法
设置字符类型的列值 Important Notes:添加此方法,主要是为了兼容Sybase的情况.
setStringFieldValue(PreparedStatement, int, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法

setStringFieldValue(PreparedStatement, int, String) - 类 com.trs.infra.util.database.OracleDB 中的方法

setStringFieldValue(PreparedStatement, int, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法
覆写:在Sybase中,设置一个空串会默认插入一个空格.
setStringFieldValue(PreparedStatement, int, String, boolean) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
覆写:在Sybase中,设置一个空串会默认插入一个空格.
setStyle(int) - 类 com.trs.components.common.trsvote.VoteItem 中的方法
设置属性：Style
setStyle(int) - 类 com.trs.components.common.trsvote.VoteOption 中的方法
设置属性：Style
setStyle(Special, PageStyle) - 接口 com.trs.components.special.ISpecialMgr 中的方法
设置专题风格
setStyle(MethodContext) - 接口 com.trs.components.special.ISpecialServiceProvider 中的方法
设置专题页面风格
setStyle(Special, PageStyle) - 类 com.trs.components.special.SpecialMgr 中的方法

setStyle(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法

setStyleDesc(String) - 类 com.trs.components.common.publish.widget.BaseStyle 中的方法
设置属性：风格描述
setStyleName(String) - 类 com.trs.components.common.publish.widget.BaseStyle 中的方法
设置属性：风格名称
setStyleName(String) - 类 com.trs.components.special.Special 中的方法
设置属性：StyleName
setStyleObjId(int) - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
设置属性：StyleObjId
setStyleObjId(int) - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
设置属性：StyleObjId
setStyleObjType(int) - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
设置属性：StyleObjType
setStyleObjType(int) - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
设置属性：StyleObjType
setStyleThumb(String) - 类 com.trs.components.common.publish.widget.BaseStyle 中的方法
设置属性：风格缩略图
setStyleThumb(String) - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
设置属性：风格缩略图
setStyleThumb(String) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
设置属性：风格缩略图
setStyleURI(String) - 类 com.trs.components.infoview.InfoViewConfig 中的方法

setSubinstance(int) - 接口 com.trs.cms.process.IFlowContent 中的方法
设置当前Content的关联ID
setSubinstance(CMSObj) - 接口 com.trs.cms.process.IFlowContent 中的方法

setSubinstance(int) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

setSubinstance(ApplyForm) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

setSubinstance(CMSObj) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

setSubinstance(int) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

setSubinstance(CMSObj) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

setSubject(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置邮件主题
setSubmitButtonHTML(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setSubmitor(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：Submitor
setSubstance(CMSObj) - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法

setSubstance(CMSObj) - 接口 com.trs.cms.content.ICMSObjSubstanceContent 中的方法
Sets the substantce
setSubstance(CMSObj) - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

setSubstance(ApplyForm) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法

setSubstance(CMSObj) - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法

setSubstance(CMSObj) - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法

setSubstance(CMSObj) - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

setSubstance(CMSObj) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

setSubTitle(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档副标题
setSuggestion(String) - 异常 com.trs.webframework.exception.ServiceInvocationException 中的方法

setSupportedApdExts(String) - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

setSupportedExts(String) - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

setSureFormFile(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置书生表单文件名称
setSysbaseSQL(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：SysbaseSQL
setSysContentLinkId(int) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法

setSysDefined(boolean) - 类 com.trs.cms.auth.persistent.RightDef 中的方法

setSysDefined(boolean) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色系统预定义的属性
setSystemMgrRights(int, List) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法

setSystemRolesOfUser(User, int, Roles) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
设置用户在指定站点上的系统级角色，同时将清除原来的关联
setTable(String) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置存储频道中文档的数据表的名称
setTableId(int) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：TableId
setTableId(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：TableId
setTableName(String) - 类 com.trs.cms.content.ExtendedField 中的方法
设置扩展字段所属数据表名称
setTableName(String) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：TableName
setTableName(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：TableName
setTableName(String) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
设置扩展字段所属数据表名称
setTableName(String) - 类 com.trs.components.wcm.content.persistent.XDocument 中的方法

setTableName(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：TableName
setTableName(String) - 类 com.trs.infra.util.database.TableInfo 中的方法
设置数据表名称
setTableName(String) - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法

setTables(Map) - 类 com.trs.infra.util.upgrade.dbcompare.MetaDataLoader 中的方法
设置表对象
setTag(String) - 类 com.trs.components.wcm.resource.FileType 中的方法

setTagBean(String) - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
设置TRS置标解析组件的组件名
setTagDesc(String) - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
设置TRS置标解析组件的描述
setTagFormatters(ArrayList) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

setTagItem(TagItem) - 类 com.trs.components.comment.publish.tagparser.XWCMTagParserComment 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 中的方法

setTagItem(TagItem) - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser 中的方法
Sets the tag item to parser.
setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserCondition 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserDateTime 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserEcho 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserRepeat 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariable 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum 中的方法

setTagItem(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet 中的方法

setTagItem(TagItem) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoView 中的方法

setTagItem(TagItem) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData 中的方法

setTagItem(TagItem) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper 中的方法

setTagItem(TagItem) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav 中的方法

setTagItem(TagItem) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的方法

setTagItem(TagItem) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage 中的方法

setTagItem(TagItem) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的方法

setTagItem(TagItem) - 类 com.trs.components.metadata.publish.WCMTagParserAppendix 中的方法

setTagItem(TagItem) - 类 com.trs.components.metadata.publish.WCMTagParserClassDocuments 中的方法

setTagItem(TagItem) - 类 com.trs.components.metadata.publish.WCMTagParserClassIndexGener 中的方法

setTagItem(TagItem) - 类 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo 中的方法

setTagItem(TagItem) - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法

setTagItem(TagItem) - 类 com.trs.components.metadata.publish.WCMTagParserViewDatas 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.epress.TagEBookDirParser 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.epress.TagMapAreaParser 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.epress.TagParserPageNav 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.epress.TagPreNextParser 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.region.WCMTagParserRegion 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.TagChannelChainParser 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.TagParserCRUser 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImage 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImages 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.TagWmlContentParser 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser 中的方法

setTagItem(TagItem) - 类 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration 中的方法

setTagItem(TagItem) - 类 com.trs.wcmonline.TagParserVipMetaData 中的方法

setTagName(String) - 类 com.trs.components.common.publish.config.persistent.TagFormatterConfig 中的方法

setTagName(String) - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
设置TRS置标解析组件负责解析的置标名称
setTagsHavingSrc(String) - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

setTagSrcAttributeNames(String) - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

setTarget(String) - 类 com.trs.components.infoview.extract.manifest.CalculatedField 中的方法

setTargetPort(int) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：TargetPort，目标服务器的端口号
setTargetRoot(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 中的方法
已过时。
setTargetRoot(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 中的方法

setTargetRoot(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 中的方法

setTargetRoot(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法

setTargetRoot(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 中的方法
已过时。
setTargetRoot(PublishDistribution) - 接口 com.trs.components.common.publish.domain.distribute.IFileDistristributor 中的方法
Sets the target root.
setTargetServer(String) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：TargetServer
setTargetType(String) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
设置属性：TargetTypeConfig
setTargetTypes(ArrayList) - 类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig 中的方法

setTask(PublishTask) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
set the task to execute
setTaskPriority(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 中的方法
设置发布任务的优先级
setTaskRuntime(PublishTaskRuntime) - 类 com.trs.components.common.publish.domain.taskdispatch.TaskWorker 中的方法

setTel(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置联系电话
setTel(String) - 类 com.trs.components.common.address.Contact 中的方法

setTelephone(String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
设置属性：Telephone
setTempAppendixId(int) - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
设置属性：TempAppendixId
setTemplate(Template) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
设置相关模板
setTemplate(Template) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
set the template
setTemplate(int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
设置属性：TemplateId
setTemplate(Template) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
set the template used
setTemplate(int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
设置属性：TemplateId
setTemplate(String) - 类 com.trs.components.common.publish.widget.BaseStyle 中的方法
设置属性：风格样式模板
setTemplate(String) - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
设置属性：样式模板
setTemplate(String) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
设置属性：风格样式模板
setTemplate(String) - 类 com.trs.components.infoview.extract.manifest.FileNew 中的方法
已过时。
setTemplateContent(String) - 类 com.trs.components.infoview.config.EnumCreator 中的方法

setTemplateContent(String) - 类 com.trs.components.infoview.config.LinkedEnumCreator 中的方法

setTemplateFile(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setTemplateFile(String) - 类 com.trs.infra.util.TRSJspAutoTool 中的方法

setTemplateId(int) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置模板的ID
setTemplateId(int) - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
设置属性：TemplateId
setTemplateId(int) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
设置属性：TemplateId
setTemplateId(int) - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
设置属性：TemplateId
setTemplateId(int) - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法

setTemplateName(String) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
设置模板的名称
setTemplateName(String) - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法

setTemplateParameters(TemplateParameterList) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板中的形式参数的列表 该方法仅供类型'TemplateParseMgr'调用，本来模板中的形式参数列表应该在模板类内部完成， 但是因为还涉及到参数实际值的清除，以及模板修改后形式参数列表的替换等问题，所以将形式 参数列表的构造移动到类型'TemplateParseMgr'中。
setTemplateParse(TemplateParseConfig) - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

setTemplateType(int) - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法

setTestOnAssign(boolean) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

setTestOnIdle(boolean) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

setTestSQL(String) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

setTestValues(HashTable) - 类 com.trs.cms.ContextHelper 中的静态方法
设置当前线程的登录用户
setText(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
Returns the first child if it is a string.
setText(String) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板正文
setText(String) - 类 com.trs.infra.util.database.CDBText 中的方法
设置文本内容
setText(String) - 类 com.trs.infra.util.html.HtmlComment 中的方法
设置注释内容
setTextProperty(String, String) - 类 com.trs.infra.persistent.BaseObj 中的方法
set the value of the property whose type is text.
setThreadSafe(boolean) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
设置相关联的ITagParser 实现是否线程安全
setTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置附件的时间
setTime(Time) - 类 com.trs.infra.util.CMyDateTime 中的方法
设置时间值
说明：若当前日期时间非空，则仅改变时间值，日期值保持不变
setTime(long) - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Sets the time of last modification of the entry.
setTimeBegin(CMyDateTime) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：TimeBegin
setTimeEnd(CMyDateTime) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：TimeEnd
setTimeLimitedMode(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

setTimeout(int) - 类 com.trs.infra.util.CMy3WLib 中的静态方法

setTimeRange(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置本频道提取文档的时间范围（单位：天）
setTimeToLiveOverUse(int) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

setTimeUsed(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：TimeUsed
setTimeWithString(String, int) - 类 com.trs.infra.util.CMyDateTime 中的方法
使用字符串设置时间值
setTitile(String) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：Titile
setTitle(String) - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
设置属性：Title
setTitle(String) - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

setTitle(String) - 类 com.trs.components.common.calendar.Event 中的方法

setTitle(String) - 类 com.trs.components.common.message.Message 中的方法

setTitle(String) - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

setTitle(String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：Title
setTitle(String) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：Title
setTitle(String) - 类 com.trs.components.common.trsvote.VoteItem 中的方法
设置属性：Title
setTitle(String) - 类 com.trs.components.common.trsvote.VoteOption 中的方法
设置属性：Title
setTitle(String) - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
设置回复标题
setTitle(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档标题
setTitle(String) - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
设置属性：Title
setTitle(String) - 类 com.trs.infra.util.Reports 中的方法

setTitleColor(String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置标题颜色
setTitleField(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：TitleField
setTitlePattern(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setTo(String) - 类 com.trs.infra.util.CMySMS 中的方法
设置收信人
setTo(String) - 类 com.trs.infra.util.email.CMyEmail 中的方法
设置收信人地址
setToChannelId(int) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
设置属性：ToChannelId
setToChnlUser(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
判断文档流转时是否考虑频道的权限
setToFirst(boolean) - 类 com.trs.cms.process.definition.FlowNode 中的方法

setToken(String) - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法

setTooltip(String) - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

setTopDocument(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
将文档置顶
setTopDocument(Channel, Document, int, CMyDateTime) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
将特定频道下的一篇文档设置为置顶
如果特定的位置已经存在文档，则需要将该位置及其后的所有置顶向后移动一位
如果最后一个置顶项目也有占用，则自动将置顶位置扩展一位！
setTopDocument(Channel, Document, Document, int, CMyDateTime) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法

setTopDocument(Document, Channel, int, CMyDateTime) - 接口 com.trs.service.IDocumentService 中的方法
将特定频道下的一篇文档设置为置顶
setTopDocument(Document, Channel, int, CMyDateTime) - 类 com.trs.service.impl.DocumentService 中的方法

setTopedDocument(Document, Channel, int, CMyDateTime) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法

setTopicId(int) - 类 com.trs.components.comment.domain.CommentUpdator 中的方法

setTopicId(int) - 类 com.trs.components.comment.domain.Management 中的方法

setTopicId(int) - 类 com.trs.components.comment.domain.NewsComment 中的方法

setTopicId(int) - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
设置属性：TopicId
setTopicId(int) - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

setTopicTitle(String) - 类 com.trs.components.comment.domain.Management 中的方法

setTopicTitle(String) - 类 com.trs.components.comment.domain.NewsComment 中的方法

setTopicTitle(String) - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

setTopLogId(int) - 类 com.trs.infra.support.log.BaseDBLog 中的方法

setTopLogId(int) - 接口 com.trs.infra.support.log.ILog 中的方法
设置触发日志记录操作所记录的第一条日志的ID
如果当前日志是第一条记录(或独立的一条日志)则TopId为0
setToTransPaths(String[]) - 类 com.trs.tools.Localizer 中的方法

setToTransPaths(String[]) - 类 com.trs.tools.Localizer2 中的方法

setToTransPaths(String[]) - 类 com.trs.tools.LocalServerAuto 中的方法

setToUser(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置接收者
setToUser(User) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置接收者
setToUsers(Users) - 类 com.trs.cms.process.engine.FlowContext 中的方法

setToUsers(String) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置呈送人员
setToUsers(Users) - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法

setToUsers(Users) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setToUsers(String) - 类 com.trs.cms.process.engine.FlowParamers 中的方法

setTraceAssign(boolean) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

setTransform(String) - 类 com.trs.components.infoview.extract.manifest.View 中的方法

setTransmitType(int) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法

setTRSDocDBName(String) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的静态方法
设置WCM数据库中WCMDocument与TRS库中的表映射名
setTRSDocIdDBName(String) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的静态方法
设置WCM数据库WCMDocument表DocId字段与TRS库中的表映射名
setTRSFrom(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

setTRSObjectID(int) - 类 com.trs.components.infoview.extract.DataGroup 中的方法

setTRSObjectID(int) - 类 com.trs.components.infoview.extract.DataType 中的方法

setTRSObjectID(int) - 类 com.trs.components.infoview.extract.manifest.View 中的方法

setTRSOrder(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

setTRSWhere(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

setTrueFieldName(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setTrueName(String) - 类 com.trs.cms.auth.persistent.User 中的方法
设置真实姓名
setTrueName(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setTrueName(String) - 类 com.trs.webframework.config.MethodConfig 中的方法

setTrustee(int) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
设置属性：Trustee
setType(String) - 类 com.trs.cms.auth.config.OperationConfig 中的方法

setType(String, int) - 类 com.trs.cms.content.ExtendedField 中的方法

setType(String, int, boolean, String) - 类 com.trs.cms.content.ExtendedField 中的方法
设置扩展字段数据类型
setType(String, int, boolean, String, int) - 类 com.trs.cms.content.ExtendedField 中的方法

setType(String) - 类 com.trs.cms.process.config.ParamConfig 中的方法

setType(int) - 类 com.trs.cms.process.definition.FlowRule 中的方法
设置属性：Type
setType(int) - 类 com.trs.components.common.calendar.Event 中的方法

setType(EventType) - 类 com.trs.components.common.calendar.Event 中的方法

setType(int) - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
设置属性：Type
setType(int) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 中的方法
设置分发类型
setType(TagBeanAttrInfo.Type) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
设置属性类型
setType(TagBeanInfo.BodyType) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
设置置标的类型
setType(int) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板的类型
setType(String) - 类 com.trs.components.infoview.extract.manifest.FileProperty 中的方法

setType(int) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：Type
setType(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：Type
setType(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
设置频道类型(Channel.TYPE_NORM等)
setType(String, int) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法

setType(String, int, boolean, String) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
设置扩展字段数据类型
setType(String, int, boolean, String, int) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法

setType(int) - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法

setType(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档类型
setType(int) - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法

setType(int) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

setType(String) - 类 com.trs.components.wcm.resource.Source 中的方法
设置来源类型
setType(int) - 类 com.trs.db.update.DBUpdateLog 中的方法
设置属性：Type
setType(int) - 类 com.trs.infra.support.config.Config 中的方法
获取配置类别（定义在Config中）
setType(int) - 类 com.trs.infra.util.Report 中的方法
设置Report类型
setType(String) - 类 com.trs.presentation.util.PageParameter 中的方法
设置当前参数的类型，类型定义为：PageParameter.TYPE_STRING等
setType(String) - 类 com.trs.wcm.config.PageOperator 中的方法
设置属性：Type
setType(int) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置属性：Type
setType(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
设置当前参数的类型，类型定义为：PageParameter.TYPE_STRING等
setTypeCrTime(CMyDateTime) - 类 com.trs.components.common.trsad.ADType 中的方法
设置属性：CrTime
setTypeCrUser(String) - 类 com.trs.components.common.trsad.ADType 中的方法
设置属性：CrUser
setTypeDesc(String) - 类 com.trs.components.common.trsad.ADType 中的方法
设置属性：TypeDesc
setTypeDesc(String) - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
设置属性：TYPEDESC
setTypeId(int) - 类 com.trs.infra.support.config.SystemCollocationConfig 中的方法

setTypeName(String) - 类 com.trs.components.infoview.extract.DataType 中的方法

setTypeName(String) - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
设置属性：TYPENAME
setTypeName(String) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法

setUnit(String) - 类 com.trs.cms.process.config.ParamConfig 中的方法

setUnitValue(String) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
设置属性：UnitValue
setUnpubSchedule(MethodContext) - 类 com.trs.ajaxservice.PublishServiceProvider 中的方法

setUnZipPath(String) - 类 com.trs.infra.util.CMyUnZipFile 中的方法
设置解压路径
setUpdated(boolean) - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
设置属性：Updated
setUpdcols(List) - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
设置更新的列
setUpperFolder(IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
设置当前置标正在发布对象的所在目录 该方法只应该在一类地方调用，就是在TRS_DOCUMENTS等概览置标切换了目录之后， 其他任何地方都不应该使用该方法。
setUpperHost(IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Sets the upper host object.
setUri(String) - 类 com.trs.webframework.config.MethodConfig 中的方法

setUrl(String) - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
设置属性：Url
setURL(String[]) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
设置属性：URL
setUrl(String) - 类 com.trs.components.infoview.config.GatewayPage 中的方法

setUrl(String) - 类 com.trs.components.stat.HostObjDomain 中的方法
设置属性：Url
setUrl(String) - 类 com.trs.webframework.config.MethodConfig 中的方法

setUrn(String) - 类 com.trs.infra.util.soap.CMySoapClient 中的方法

setUsed(boolean) - 类 com.trs.components.wcm.resource.Status 中的方法
设置是否使用
setUsedByVersion(int, boolean) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置指定的版本是否使用此附件
setUsedInChildren(boolean) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法

setUsedVersions(long) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
设置使用该附件的文档的版本号
setUser(int, String) - 类 com.trs.components.comment.domain.Management 中的方法
设置WCM中登录用户的用户ID和用户名(必须的)
setUser(int) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
设置登录用户ID号
setUser(User) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
设置登录用户
setUser(String) - 类 com.trs.infra.support.log.BaseDBLog 中的方法
设置用户
setUser(String) - 接口 com.trs.infra.support.log.ILog 中的方法
设置用户
setUser(User) - 类 com.trs.service.InfoViewContext 中的方法

setUserAddress(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setUserEmail(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setUserGroupId(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
设置属性：UserGroupId
setUserId(int) - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
设置属性：UserId
setUserId(int) - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
设置属性：UserId
setUserId(int) - 类 com.trs.components.stat.UserLoginInfo 中的方法
设置属性：UserId，用户ID
setUserId(int) - 类 com.trs.components.wcm.individuation.Individuation 中的方法
设置属性：UserId
setUserID(int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
设置属性：UserID
setUserIdcardNum(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setUserIdcode(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setUserMobile(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setUserName(String) - 类 com.trs.components.common.address.Contact 中的方法

setUserName(String) - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

setUserName(String) - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

setUserName(String) - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
设置登陆FTP服务器的用户名
setUserNames(String) - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法

setUserPhone(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setUserTitle(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

setValidator(String) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：Validator
setValidator(String) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
设置属性：Validator
setValidator(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：Validator
setValidFileExts(String) - 类 com.trs.components.wcm.soap.WordFileService 中的静态方法
设置允许导入的文件后缀名
setValidNum(int) - 类 com.trs.components.wcm.content.trsserver.ClassInfo 中的方法
设置可读取的记录数
setValidTime(CMyDateTime) - 类 com.trs.components.common.message.Message 中的方法

setValidTime(CMyDateTime) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档的有效时间
setValidVerifycodeUrl(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setValue(RightValue) - 类 com.trs.cms.auth.persistent.Right 中的方法
使用RightValue对象定权限值
setValue(long) - 类 com.trs.cms.auth.persistent.Right 中的方法
使用长整型数设定权限值
setValue(String) - 类 com.trs.cms.process.config.OperatorConfig 中的方法

setValue(String) - 类 com.trs.components.infoview.extract.manifest.FileProperty 中的方法

setValue(String) - 类 com.trs.components.wcm.content.trsserver.ClassInfo 中的方法
设置当前分类字段对应的Value
setValue(String) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
设置定制的值
setValue(int) - 类 com.trs.components.wcm.resource.Security 中的方法
设置安全级别的值
setValue(String) - 类 com.trs.infra.support.config.Config 中的方法
设置配置值
setValue(String, boolean) - 类 com.trs.infra.support.config.Config 中的方法
设置配置值
setValue(long) - 类 com.trs.infra.util.CMyBitsValue 中的方法
用整型值指定权限
setValue(String) - 类 com.trs.infra.util.CMyBitsValue 中的方法
用0/1字符串序列指定权限值 每位字符代表一种权限，'1'为1，其他为0
setValue(String) - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
设置属性值
setValue(String, String) - 类 com.trs.presentation.util.RequestHelper 中的方法

setValue(String, Object) - 类 com.trs.webframework.context.MethodContext 中的方法

setValue(String, String) - 类 com.trs.webframework.context.MethodContext 中的方法

setValue(String, int) - 类 com.trs.webframework.context.MethodContext 中的方法

setValue(String, long) - 类 com.trs.webframework.context.MethodContext 中的方法

setValue(String, float) - 类 com.trs.webframework.context.MethodContext 中的方法

setValue(String, double) - 类 com.trs.webframework.context.MethodContext 中的方法

setValue(String, CMyDateTime) - 类 com.trs.webframework.context.MethodContext 中的方法

setValueConfigs(ValueConfig[]) - 类 com.trs.cms.process.config.ParamConfig 中的方法

setValues(Map) - 类 com.trs.webframework.context.MethodContext 中的方法

setValueSplitBy(String) - 类 com.trs.components.infoview.config.EnumCreator 中的方法

setVariable(boolean) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
设置属性值是不是可变的
setVariableAttribute(String, String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
给指定的变量赋值
setVerifyCodeEnable(boolean) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setVerifyCodeURL(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

setVersion(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
设置文档的版本号
setVersion(String) - 类 com.trs.infra.config.persistent.PluginConfig 中的方法

setView(InfoViewView) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

setView(MetaView) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
设置当前对象相关的视图
setView(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置属性：OwnerView
setViewable(boolean) - 类 com.trs.cms.auth.persistent.Role 中的方法
设置角色是否在应用可见
setViewAttribute(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewAttribute
setViewDataProperties(MethodContext, MetaViewData) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的静态方法

setViewDataProperties(MethodContext, MetaViewData) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的静态方法

setViewDataProperties(MethodContext, MetaViewData) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的静态方法

setViewDataProperties(MethodContext, MetaViewData) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForZJH 中的静态方法

setViewDesc(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewDesc
setViewEmployerByChannel(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
给指定栏目分配视图
setViewer(CMSObj) - 类 com.trs.components.common.bookmark.MarkShare 中的方法
设置Viewer（User,Group,Role,Contact,ContactGrp）对象
setViewerId(int) - 类 com.trs.components.common.bookmark.MarkShare 中的方法

setViewerType(int) - 类 com.trs.components.common.bookmark.MarkShare 中的方法
setViewerType允许的对象类型常量为6种 OBJ_USER OBJ_GROUP OBJ_ROLE OBJ_CONTACT OBJ_CONTACTGRP MARKSHARE_STATE_ALLUSER
setViewField(MetaViewField) - 类 com.trs.components.metadata.web.AbsHTMLMaker 中的方法

setViewField(MetaViewField) - 接口 com.trs.components.metadata.web.HTMLMaker 中的方法
设置当前HTMLMaker关联的MetaViewField对象
setViewFields(User, MetaView, MetaDBFields) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
设置
setViewFields(User, MetaView, MetaDBFields) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法

setViewFields(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
维护视图选择的字段：目前仅仅适合单表模式
setViewFieldsInfo(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
设置多个视图字段的信息
setViewFrom(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewFrom
setViewGroupBy(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewGroupBy
setViewID(int) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

setViewID(int) - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
设置属性：ViewID
setViewInterval(int) - 类 com.trs.cms.auth.persistent.User 中的方法
设置ViewInterval:视图刷新时间（秒）
setViewName(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewName
setViewOrderBy(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewOrderBy
setViewSelect(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewSelect
setViewThumb(String) - 类 com.trs.components.special.Special 中的方法
设置属性：ViewThumb
setViewType(int) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewType
setViewWhere(String) - 类 com.trs.components.wcm.stat.StatView 中的方法
设置属性：ViewWhere
setViewWidth(String) - 类 com.trs.components.infoview.extract.manifest.View 中的方法

setViewWidth(String) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
设置视图的宽度（HTML页面中有效区域的宽度）
setVisible(boolean) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
设置属性：Visible
setVoteId(int) - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
设置属性：VoteId
setVoteId(int) - 类 com.trs.components.common.trsvote.VoteItem 中的方法
设置属性：VoteId
setWaitIfBusy(boolean) - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

setWarning(String) - 类 com.trs.wcag2.Alertion 中的方法

setWCMDocId(int) - 类 com.trs.components.common.trsvote.Vote 中的方法
设置属性：WCMDocId
setWCMObjectProperties(User, MethodContext, CMSObj, String[]) - 类 com.trs.ajaxservice.WCMAJAXServiceHelper 中的静态方法
更新指定的对象
setWcmOutlineContentsMaxNum(int) - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

setWCMTableId(String) - 类 com.trs.components.wcm.stat.StatHost 中的方法
设置属性：WCMTableId
setWCMTableName(String) - 类 com.trs.components.wcm.stat.StatHost 中的方法
设置属性：WCMTableName
setWDefaultStyle(String) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：WDefaultStyle
setWdesc(String) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：Wdesc
setWebHttp(String) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
设置Web站点Http地址
setWebSiteId(int) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
设置属性：ChannelId
setWhere(String) - 类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 中的方法
设置查询条件
setWhere(String) - 类 com.trs.infra.db.QueryFilter 中的方法
设置查询条件
setWhere(String) - 类 com.trs.infra.persistent.WCMFilter 中的方法
设置查询条件
setWhereSql(String) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
设置属性：WhereSql
setWhereSQL(String) - 类 com.trs.presentation.util.DefaultWhereSQLMaker 中的方法

setWidgetAttrURL(String) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：WidgetAttrURL
setWidgetcontent(String) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：Widgetcontent
setWidgetId(int) - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
设置属性：WidgetId
setWidgetId(int) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：WidgetId
setWidgetInstId(int) - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
设置属性：WidgetInstId
setWidgetParamDesc(String) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：WidgetParamDesc
setWidgetParamName(String) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：WidgetParamName
setWidgetParamType(int) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
设置属性：WidgetParamType
setWidgetpic(String) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：Widgetpic
setWidgetType(int) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：WidgetType
setWidth(int) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
设置属性：Width
setWithAppendix(boolean) - 类 com.trs.components.wcm.content.persistent.DocumentXmlConverter 中的方法

setWithChildren(boolean) - 类 com.trs.cms.auth.persistent.GroupXmlConverter 中的方法

setWithChildren(boolean) - 类 com.trs.components.wcm.content.persistent.ChannelXmlConverter 中的方法
设置是否导出子对象(频道)
默认为false,不导出
setWithExtField(boolean) - 类 com.trs.components.wcm.content.persistent.ChannelXmlConverter 中的方法
设置是否导出扩展字段对象
setWithTemp(boolean, String) - 类 com.trs.components.wcm.content.persistent.ChannelXmlConverter 中的方法
设置是否导出模板
因为导出模板的同时,会导出模板所使用的文件(JS,CSS等)
因此,需要指定文件的导出位置
默认为不导出
setWMName(String) - 类 com.trs.wcm.photo.Watermark 中的方法
设置属性：WMName
setWMPicture(String) - 类 com.trs.wcm.photo.Watermark 中的方法
设置属性：WMPicture
setWname(String) - 类 com.trs.components.common.publish.widget.Widget 中的方法
设置属性：Wname
setWorked(boolean) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置流转轨迹是否处理过
setWorker(String) - 类 com.trs.components.common.message.MessageSendingConfig 中的方法

setWorkerClass(String) - 类 com.trs.components.common.job.JobWorkerType 中的方法

setWorkerClass(Class) - 类 com.trs.components.common.job.JobWorkerType 中的方法

setWorkerName(String) - 类 com.trs.components.common.job.JobWorkerType 中的方法

setWorkerType(int) - 类 com.trs.components.common.job.Schedule 中的方法

setWorkerType(JobWorkerType) - 类 com.trs.components.common.job.Schedule 中的方法

setWorkModal(int) - 类 com.trs.cms.process.definition.FlowNode 中的方法
设置节点上的流转模式
setWorkModal(int) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
设置事务处理模式
setWrite(boolean) - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法

setWriteField(boolean) - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
设置字段为可写
setXDesc(String) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法

setXMLEncoding(String) - 类 com.trs.components.common.publish.widget.ContentStyleExporter 中的方法
设置导出文件的编码格式
setXMLEncoding(String) - 类 com.trs.components.common.publish.widget.PageStyleExporter 中的方法
设置导出文件的编码格式
setXMLEncoding(String) - 类 com.trs.components.common.publish.widget.ResourceStyleExporter 中的方法
设置导出文件的编码格式
setXMLEncoding(String) - 类 com.trs.components.wcm.content.domain.ChannelExporter 中的方法

setXmlEncoding(String) - 类 com.trs.infra.persistent.AbstractXmlToObjConverter 中的方法
设置XML的输出字符编码
setXmlEncoding(String) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
设置XML的输出字符编码
setXmlEncoding(String) - 类 com.trs.infra.persistent.XmlToObjConverter 中的方法
设置XML的输出字符编码
setXmlEncoding(String) - 类 com.trs.infra.persistent.XmlToObjConverterByDOM4j 中的方法
设置XML的输出字符编码
setXMLToEdit(String) - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

setXPath(String) - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

setXSLPrefix(String) - 类 com.trs.components.infoview.extract.manifest.View 中的方法

setXSLPrefix(String) - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法

setXSLTFilet(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法

setXYAxisDescs(String, String) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法

setYDesc(String) - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法

setYearSpan(String) - 类 com.trs.components.metadata.service.GovInfoToXML 中的静态方法
设置要处理的年份范围。
setZipFile(String) - 类 com.trs.infra.util.CMyUnzip 中的方法
设置zip文件
setZipFile(String) - 类 com.trs.infra.util.CMyUnZipFile 中的方法
设置需要解压的文件
setZipFileName(String) - 类 com.trs.infra.util.CMyZip 中的方法
设置压缩后的目标Zip文件名
setZipWithChildDirPath(boolean) - 类 com.trs.infra.util.CMyZip 中的方法
设置在不包含路径压缩时是否包含子目录的路径,默认为不包含
例如:要压缩目录src目录下的文件,src下包含images目录和1.txt文件
如果设置为 true 则把images目录包含.
sFrom - 类 com.trs.infra.util.CMySMS 中的变量
发信人
SHAPE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

SHAPES - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

shareEventTo(Event, String, int) - 类 com.trs.service.impl.EventService 中的方法
共享日程给指定的共享者
shareTo(int, CMSBaseObjs, int, String) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法

shareTo(Event, CMSObj) - 类 com.trs.components.common.calendar.EventMgr 中的方法

shareTo(int, String, int, String) - 接口 com.trs.service.IBookMarkService 中的方法
设置共享
shareTo(Event, User) - 接口 com.trs.service.IEventService 中的方法
当前用户把一个Event指派给另外一个用户
shareTo(Event, Users) - 接口 com.trs.service.IEventService 中的方法
把一个Event指派给一个用户集合
shareTo(Event, String) - 接口 com.trs.service.IEventService 中的方法

shareTo(Event, Group) - 接口 com.trs.service.IEventService 中的方法
当前用户把一个Event指派给一个组织
shareTo(Event, Groups) - 接口 com.trs.service.IEventService 中的方法

shareTo(int, String, int, String) - 类 com.trs.service.impl.BookMarkService 中的方法

shareTo(Event, User) - 类 com.trs.service.impl.EventService 中的方法

shareTo(Event, Groups) - 类 com.trs.service.impl.EventService 中的方法

shareTo(Event, Group) - 类 com.trs.service.impl.EventService 中的方法

shareTo(Event, Users) - 类 com.trs.service.impl.EventService 中的方法

shareTo(Event, String) - 类 com.trs.service.impl.EventService 中的方法

sharpenImage(double, double) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
锐化图片
sharpenImage(double, double) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法

showEmpty(String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串显示处理函数：若为空对象，则返回指定的字符串
showEmpty(String, String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串显示处理函数：若为空对象或者空串，则返回指定的字符串
showNull(String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串显示处理函数：若为空对象，则返回指定的字符串
showNull(String, String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串显示处理函数：若为空对象，则返回指定的字符串
showObjNull(Object) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串显示处理函数：若为空对象，则返回指定的字符串
showObjNull(Object, String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串显示处理函数：若为空对象，则返回指定的字符串
showOrdImg(String) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法

shutdown() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
shutdown the dispatcher
shutdown() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法

shutdown() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法

shutdown() - 类 com.trs.infra.BaseServer 中的方法

shutdown() - 接口 com.trs.infra.IServer 中的方法
关闭应用
shutdown() - 类 com.trs.infra.ServerControl 中的方法

shutDown() - 类 com.trs.infra.util.job.JobScheduler 中的方法

shutdownWCMForTRS() - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的静态方法

sign(String, byte[]) - 类 com.trs.infra.support.security.SecureKeyMgr 中的方法
使用指定名称的密钥计算指定的数据的签名
sign(byte[]) - 类 com.trs.infra.util.CMySign 中的方法
进行数字签名。
sign(String, byte[]) - 类 com.trs.service.impl.SecurityService 中的方法

sign(String, byte[]) - 接口 com.trs.service.ISecurityService 中的方法
使用指定名称的密钥计算指定的数据的签名
SignUtil - com.trs.components.comment.domain 中的 类
签名和编码，仅供包内使用
SIMPLE_MODE - 类 com.trs.presentation.nav.NavConstatns 中的静态变量
仅有高级检索和栏目树构成的导航模式
simSearch(int, String) - 接口 com.trs.components.ckm.ICKMServer 中的方法

simSearch(int, String) - 类 com.trs.components.ckm.TRSCKMServer 中的方法

SinglePageTask - com.trs.components.common.publish.domain.taskdispatch 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
interface of page task.
SinglePageTask(IPublishElement) - 类 com.trs.components.common.publish.domain.taskdispatch.SinglePageTask 的构造方法
constructor: default
SITE_ADD - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
添加站点
SITE_ADD_USER - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
设定站点用户
SITE_DEL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除站点
SITE_EDIT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
修改站点
SITE_MAX_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
站点权限index最大值
SITE_MIN_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
站点权限Index最小值
SITE_PREVIEW - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
预览站点首页
SITE_PUB_ALL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
完全发布站点
SITE_PUB_INC - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
增量发布站点
Site_SETRIGHT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
设置站点的权限
SITE_SETTEMPLATE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
设置站点的模板
SITE_TYPES - 类 com.trs.ajaxservice.SystemServiceProvider 中的静态变量

SiteCreateFromLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
类似创建站点日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
SiteCreateFromLogger() - 类 com.trs.ajaxservice.logger.SiteCreateFromLogger 的构造方法

SiteExporterForFlow - com.trs.components.wcm.process.service.flowexporter 中的 类

SiteExporterForFlow() - 类 com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow 的构造方法

SiteHitsCountHandler - com.trs.components.stat 中的 类

SiteHitsCountHandler() - 类 com.trs.components.stat.SiteHitsCountHandler 的构造方法

SITEID_FOR_ALL_SITES - 类 com.trs.cms.auth.persistent.RoleUser 中的静态变量
作用于所有站点的siteid标识
SITEID_FOR_SPECIAL_ROLE - 类 com.trs.cms.auth.persistent.RoleUser 中的静态变量
特定角色使用的siteid标识
SiteImportLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点导入日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
SiteImportLogger() - 类 com.trs.ajaxservice.logger.SiteImportLogger 的构造方法

SiteLicenseMgr - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SiteLicenseMgr() - 类 com.trs.components.wcm.content.persistent.SiteLicenseMgr 的构造方法

SiteMember - com.trs.components.wcm.content.persistent 中的 类

SiteMember() - 类 com.trs.components.wcm.content.persistent.SiteMember 的构造方法
构造函数：保留默认接口
SiteMemberIdsMan - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点用户关联处理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SiteMemberIdsMan(WebSite, int) - 类 com.trs.components.wcm.content.domain.SiteMemberIdsMan 的构造方法

SiteMemberLCListner - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SiteMemberLCListner() - 类 com.trs.components.wcm.content.domain.SiteMemberLCListner 的构造方法

SiteMemberMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点用户/用户组管理者对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SiteMemberMgr() - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 的构造方法

SiteMembers - com.trs.components.wcm.content.persistent 中的 类

SiteMembers(User) - 类 com.trs.components.wcm.content.persistent.SiteMembers 的构造方法
构造函数
SiteMembers(User, int, int) - 类 com.trs.components.wcm.content.persistent.SiteMembers 的构造方法
构造函数
SiteNameCreator - com.trs.service.impl 中的 类

SiteNameCreator() - 类 com.trs.service.impl.SiteNameCreator 的构造方法

SiteRecycleClearLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
清空站点回收站日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
SiteRecycleClearLogger() - 类 com.trs.ajaxservice.logger.SiteRecycleClearLogger 的构造方法

size() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法
返回聚合中的分发点的个数
size() - 类 com.trs.components.common.publish.domain.tagparser.TagParseResults 中的方法
Returns the number of parsed results.
size() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 中的方法
返回其中形式参数的个数
size() - 接口 com.trs.components.common.publish.persistent.element.IPublishElements 中的方法
Returns the number of elements in this collection.
size() - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 中的方法

size() - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 中的方法

size() - 类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 中的方法

size() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

size() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法

size() - 类 com.trs.infra.config.persistent.ConfigFiles 中的方法

size() - 类 com.trs.infra.persistent.BaseObjs 中的方法
获取集合的大小
size() - 类 com.trs.infra.persistent.db.DBConnectionConfigs 中的方法
logic for Collection Options
size() - 类 com.trs.infra.util.AttributesString 中的方法

size() - 类 com.trs.infra.util.cabfile.CabFile 中的方法

size() - 类 com.trs.infra.util.CMyErrors 中的方法
取错误总数
size() - 类 com.trs.infra.util.email.SMTPServerConfigs 中的方法
logic for Collection Options
SIZE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

size() - 类 com.trs.infra.util.jazzlib.ZipFile 中的方法
Returns the number of entries in this zip file.
size() - 类 com.trs.presentation.util.Parameters 中的方法
获取参数的个数
size() - 接口 com.trs.template.IErrorMessages 中的方法
获取错误信息集合中错误信息的数量
size() - 类 com.trs.template.persistent.InfoEntities 中的方法

skip(long) - 类 com.trs.infra.util.jazzlib.CheckedInputStream 中的方法
Skips n bytes by reading them in a temporary buffer and updating the the checksum with that buffer.
skip(long) - 类 com.trs.infra.util.jazzlib.InflaterInputStream 中的方法
Skip specified number of bytes of uncompressed data
skip(long) - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 中的方法

skipChar() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
移动指针到下一个字符
SMALL - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

SMALLDATETIME - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：SMALLDATETIME
SMALLDATETIME - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：SMALLDATETIME
SMALLDATETIME - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：SMALLDATETIME
SMALLINT - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：SMALLINT
SMALLINT - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：SMALLINT
SMALLINT - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：SMALLINT
SMALLINT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量

SMALLINT - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：SMALLINT
SMALLINT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：SMALLINT
SMALLINT - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：SMALLINT
SMALLINT - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：SMALLINT
SMALLMONEY - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：SMALLMONEY
SMALLMONEY - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：SMALLMONEY
SMALLMONEY - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：SMALLMONEY
SMSSendWorker - com.trs.components.common.message 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
手机短信发送者的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SMSSendWorker() - 类 com.trs.components.common.message.SMSSendWorker 的构造方法

SMSSocketSender - com.trs.components.common.message 中的 类
Title: 网站内容管理（TRSWCM） Description: Copyright: Copyright (c) 2001 Company: www.trs.com.cn
SMSSocketSender(String, int) - 类 com.trs.components.common.message.SMSSocketSender 的构造方法
SMS短信发送者的默认构造函数
SMTPServerConfig - com.trs.infra.util.email 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SMTPServerConfig() - 类 com.trs.infra.util.email.SMTPServerConfig 的构造方法

SMTPServerConfigMapper - com.trs.infra.util.email 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SMTPServerConfigMapper() - 类 com.trs.infra.util.email.SMTPServerConfigMapper 的构造方法
Constructor
SMTPServerConfigs - com.trs.infra.util.email 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
SMTPServer config 的集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SMTPServerConfigs() - 类 com.trs.infra.util.email.SMTPServerConfigs 的构造方法

SOAPServiceImpl - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
对外的SOAP接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SOAPServiceImpl() - 类 com.trs.service.impl.SOAPServiceImpl 的构造方法

sort(boolean) - 接口 com.trs.components.stat.IStatResult 中的方法
对第1条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序
sort(int, String, boolean) - 接口 com.trs.components.stat.IStatResult 中的方法
对第nSQLIndex条统计结果集中的，第3位key的sKeyValue值进行排序
sort(int, int, String, boolean) - 接口 com.trs.components.stat.IStatResult 中的方法
对第nSQLIndex条统计结果集中的，第nKeyIndex位key的sKeyValue值进行排序
sort(int, boolean) - 类 com.trs.components.stat.StatBonusResultForUser 中的方法
根据指定的奖金类型进行对结果进行排序
sort(boolean) - 类 com.trs.components.stat.StatResult 中的方法

sort(int, int, String, boolean) - 类 com.trs.components.stat.StatResult 中的方法

sort(int, String, boolean) - 类 com.trs.components.stat.StatResult 中的方法

sortByMajorObject(boolean) - 接口 com.trs.components.stat.IStatResult 中的方法
对第1条统计结果集中的，按主体对象进行排序
sortByMajorObject(boolean) - 类 com.trs.components.stat.StatResult 中的方法

sortWithSQLIndex(int, boolean) - 接口 com.trs.components.stat.IStatResult 中的方法
对第nSQLIndex条统计结果集中的，第1位select字段[统计总数(DataCount)]进行排序
一般仅对select包含两个字段有效
sortWithSQLIndex(int, boolean) - 类 com.trs.components.stat.StatResult 中的方法

Source - com.trs.components.wcm.resource 中的 类

Source() - 类 com.trs.components.wcm.resource.Source 的构造方法

SOURCE_MGRER_ID_ARRAY - 类 com.trs.components.wcm.resource.SourceTypeMgr 中的静态变量

SOURCE_SUPPORT_TYPE - 类 com.trs.components.wcm.resource.SourceTypeMgr 中的静态变量

SOURCE_TYPE_ARRAY - 类 com.trs.components.wcm.resource.SourceTypeMgr 中的静态变量

SourcePathHelper - com.trs.template.domain 中的 类

SourcePathHelper() - 类 com.trs.template.domain.SourcePathHelper 的构造方法

Sources - com.trs.components.wcm.resource 中的 类

Sources(User) - 类 com.trs.components.wcm.resource.Sources 的构造方法

Sources(User, int, int) - 类 com.trs.components.wcm.resource.Sources 的构造方法

SourceServiceProvider - com.trs.ajaxservice 中的 类

SourceServiceProvider() - 类 com.trs.ajaxservice.SourceServiceProvider 的构造方法

SourceTypeMgr - com.trs.components.wcm.resource 中的 类

SourceTypeMgr() - 类 com.trs.components.wcm.resource.SourceTypeMgr 的构造方法

SPAN - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

Special - com.trs.components.special 中的 类

Special() - 类 com.trs.components.special.Special 的构造方法
构造函数：保留默认接口
SPECIAL_ADD - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
新建专题的权限
SPECIAL_BROWSE - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
查看专题的权限
SPECIAL_CHNL_COUNT - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
记录非普通频道的数目
SPECIAL_DELETE - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
删除专题的权限
SPECIAL_EDIT - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
修改专题的权限
SPECIAL_PUBLISH - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
发布专题的权限
SpecialAuthServer - com.trs.components.common.publish.widget 中的 类
专题制作选件权限判断相关类，定义了一些权限索引位及权限判断接口;
按照使用专题制作选件的三类用户进行权限划分：
1.网站编辑，进行专题维护
2.美工，进行风格维护
3.技术人员，进行资源，布局及母板的扩展
SpecialAuthServer() - 类 com.trs.components.common.publish.widget.SpecialAuthServer 的构造方法

SpecialMgr - com.trs.components.special 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
SpecialMgr() - 类 com.trs.components.special.SpecialMgr 的构造方法

Specials - com.trs.components.special 中的 类

Specials(User) - 类 com.trs.components.special.Specials 的构造方法
构造函数
Specials(User, int, int) - 类 com.trs.components.special.Specials 的构造方法
构造函数
SpecialServiceProvider - com.trs.components.special 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-${year} 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
SpecialServiceProvider() - 类 com.trs.components.special.SpecialServiceProvider 的构造方法

SPEICAL_ROLENAME - 类 com.trs.components.special.SpecialMgr 中的静态变量

SPEICAL_SITEDATAPATH - 类 com.trs.components.special.SpecialMgr 中的静态变量

SPEICAL_SITENAME - 类 com.trs.components.special.SpecialMgr 中的静态变量

split(String, String) - 类 com.trs.infra.util.CMyString 中的静态方法

split2AttrMap(String) - 类 com.trs.components.infoview.InfoViewMgr 中的静态方法

split2AttrMap(String) - 类 com.trs.infra.util.CMyString 中的静态方法

split2Options(String, String, String, String) - 类 com.trs.components.infoview.config.InfoViewEnumHelper 中的静态方法

split2Options(String, String) - 类 com.trs.components.infoview.config.InfoViewEnumHelper 中的静态方法

splitSelectFields(String, String) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法

splitToInt(String, String) - 类 com.trs.infra.util.CMyString 中的静态方法

SpringBean - com.trs 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SpringBean() - 类 com.trs.SpringBean 的构造方法

SQL_ESCAPE - 类 com.trs.infra.util.upgrade.Constants 中的静态变量

SQL_QUERY_FLOW_USED - 类 com.trs.cms.process.definition.FlowEmployMgr 中的静态变量

SQL_QUERY_USEING_FLOW - 类 com.trs.cms.process.definition.FlowEmployMgr 中的静态变量

SQL_SEPCHAR - 类 com.trs.infra.util.upgrade.Constants 中的静态变量

SQL_VARIRANT - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：SQL_VARIRANT
SQL_VARIRANT - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：SQL_VARIRANT
SQL_VARIRANT - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：SQL_VARIRANT
SQL_VARIRANT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：SQL_VARIRANT
sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.DamengDB 中的方法

sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlAddField(String, String, int, int, boolean, String, int) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlAddField(String, String, int, int, boolean, String, int) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlAddField(String, String, String, int, boolean) - 类 com.trs.infra.util.database.DBType 中的方法

sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.DBType 中的方法
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
sqlAddField(String, String, int, int, boolean, String, int) - 类 com.trs.infra.util.database.DBType 中的方法
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlAddField(String, String, int, int, boolean, String, int) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.MysqlDB 中的方法
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.OracleDB 中的方法
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
构造添加字段的SQL语句
特别注意：_sDefaultValue 若指定的是字符串值，则必须带有''。
sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlAddField(String, String, String, int, boolean, String, int) - 类 com.trs.infra.util.database.XuguDB 中的方法

SQLBuilder - com.trs.tools 中的 类

SQLBuilder() - 类 com.trs.tools.SQLBuilder 的构造方法

sqlConcatStr(String, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlConcatStr(String[]) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlConcatStr(String, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlConcatStr(String[]) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlConcatStr(String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlConcatStr(String[]) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlConcatStr(String, String) - 类 com.trs.infra.util.database.DBType 中的方法
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.DBType 中的方法
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
sqlConcatStr(String[]) - 类 com.trs.infra.util.database.DBType 中的方法
字符串连接函数
sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlConcatStr(String, String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlConcatStr(String[]) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlConcatStr(String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法

sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
sqlConcatStr(String[]) - 类 com.trs.infra.util.database.MysqlDB 中的方法
字符串连接函数
sqlConcatStr(String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法

sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
sqlConcatStr(String[]) - 类 com.trs.infra.util.database.OracleDB 中的方法
字符串连接函数
sqlConcatStr(String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
SQL字符串连接函数
例如：String sUserSql ="("+ _getDBManager().getDBType().sqlConcatStr("','","wcmFlowDoc.ToUsers" ,"','")
+" like '%,"+_currUser.getId()+",%'";
sqlConcatStr(String[]) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
字符串连接函数
sqlConcatStr(String, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlConcatStr(String[]) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlConcatStr(String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlConcatStr(String[]) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlConcatStr(String, String, String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlConcatStr(String, String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlConcatStr(String[]) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlCreateTable() - 类 com.trs.infra.util.database.DBType 中的方法
产生Create Table的SQL
sqlCreateTableWithPrimary(String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlCreateTableWithPrimary(String, String) - 类 com.trs.infra.util.database.DBType 中的方法
构造一个带有PrimaryKey字段的表的SQL
sqlCreateTableWithPrimary(String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.DBType 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.MysqlDB 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.OracleDB 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlDate(String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.DBType 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.MysqlDB 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.OracleDB 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlDateField(String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlDateTime(String, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlDateTime(String, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlDateTime(String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlDateTime(String, String) - 类 com.trs.infra.util.database.DBType 中的方法
构造SQL语句，用以表示日期时间值
sqlDateTime(String, String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlDateTime(String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法
构造SQL语句，用以表示日期时间值
sqlDateTime(String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法
构造SQL语句，用以表示日期时间值
sqlDateTime(String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
构造SQL语句，用以表示日期时间值
sqlDateTime(String, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlDateTime(String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlDateTime(String, String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlDropField(String, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
sqlDropField(String, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
sqlDropField(String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlDropField(String, String) - 类 com.trs.infra.util.database.DB2UDBV9 中的方法

sqlDropField(String, String) - 类 com.trs.infra.util.database.DBType 中的方法
构造删除字段的SQL语句
实例：ALTER TABLE _table DROP COLUMN _column1,_column2
sqlDropField(String, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlDropField(String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlDropTable(String) - 类 com.trs.infra.util.database.DBType 中的方法
删除指定的物理表
sqlEscapeString(String) - 类 com.trs.infra.util.database.DBType 中的方法
字符串转义函数，把字符串转义为可以直接用于SQL语句中的形式。
sqlExecUpdateProcedure(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
执行指定的存储过程语句
sqlExecuteCountQuery(WCMFilter) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteIntQuery(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
caohui@2003.09.27 新增 获取指定SQL语句的第一行第一个整型数据
sqlExecuteIntQuery(WCMFilter) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteIntQuery(String, List) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteIntQuery(String, int[]) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteIntsQuery(WCMFilter) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteQuery(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
已过时。 错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。
sqlExecuteQuery(String, int) - 类 com.trs.infra.persistent.db.DBManager 中的方法
已过时。 错误的方法，或者返回的结果集对象所依赖的Connection已经关闭， 导致 ResultSet对象无效，或者数据库连接泄露。 获取指定SQL语句的字符集
sqlExecuteQuery(String, List, long) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteQuery(String, List, int) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteStringQuery(String, int[]) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteUpdate(String[]) - 类 com.trs.infra.persistent.db.DBManager 中的方法
执行指定的SQL Update语句
sqlExecuteUpdate(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
执行指定的SQL Update语句
sqlExecuteUpdate(String[], int[]) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlExecuteUpdate(String[], Object[]) - 类 com.trs.infra.persistent.db.DBManager 中的方法

sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.DBType 中的方法
大字段检索函数
sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法
大字段检索函数
sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法
大字段检索函数
sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
大字段检索函数
sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlFilterForClob(String, String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.DBType 中的方法
构造SQL语句，用以筛选指定日期
sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法
构造SQL语句，用以筛选指定日期
sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法
构造SQL语句，用以筛选指定日期
sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
构造SQL语句，用以筛选指定日期
sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlFilterOneDay(String, String, String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.DamengDB 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.DBType 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.MysqlDB 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.OracleDB 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.SQLServerDB 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlGetNextId() - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlGetSysDate() - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
取系统时间的内部函数
sqlGetSysDate() - 类 com.trs.infra.util.database.DB2UDB 中的方法
取系统时间的内部函数
sqlGetSysDate() - 类 com.trs.infra.util.database.DB2UDB2 中的方法
取系统时间的内部函数
sqlGetSysDate() - 类 com.trs.infra.util.database.DBType 中的方法
取系统时间的内部函数
sqlGetSysDate() - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlGetSysDate() - 类 com.trs.infra.util.database.MysqlDB 中的方法
取系统时间的内部函数
sqlGetSysDate() - 类 com.trs.infra.util.database.OracleDB 中的方法
取系统时间的内部函数
sqlGetSysDate() - 类 com.trs.infra.util.database.SQLServerDB 中的方法
取系统时间的内部函数
sqlGetSysDate() - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlGetSysDate() - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlGetSysDate() - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlModifyField(String, String, int, int, boolean, int) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlModifyField(String, String, int, int, boolean, int) - 类 com.trs.infra.util.database.DB2UDBV9 中的方法

sqlModifyField(String, String, int, int, boolean, int) - 类 com.trs.infra.util.database.DBType 中的方法
修改指定表指定字段的属性
sqlModifyField(String, String, int, int, boolean, int) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlModifyField(String, String, int, int, boolean, int) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.DamengDB 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.DBType 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlQueryTableInfo(String, String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.DamengDB 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.DB2UDB 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.DBType 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.MysqlDB 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.OracleDB 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.SybaseASE 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlQueryTableInfos(String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.DB2UDBV9 中的方法

sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.DBType 中的方法
重命名指定表的指定字段
sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法

sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法

sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法

sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlRenameField(String, String, String) - 类 com.trs.infra.util.database.XuguDB 中的方法

sqlRenameTable(String, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

sqlRenameTable(String, String) - 类 com.trs.infra.util.database.DB2UDBV9 中的方法

sqlRenameTable(String, String) - 类 com.trs.infra.util.database.DBType 中的方法
重命名指定的表
sqlRenameTable(String, String) - 类 com.trs.infra.util.database.KingBaseDB 中的方法

sqlRenameTable(String, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法

sqlRenameTable(String, String) - 类 com.trs.infra.util.database.OracleDB 中的方法

sqlRenameTable(String, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法

sqlRenameTable(String, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

sqlRenameTable(String, String) - 类 com.trs.infra.util.database.XuguDB 中的方法

SQLSERVER - 类 com.trs.infra.util.database.DBTypes 中的静态变量
定义数据库类型：SQL Server
SQLSERVERDB - 类 com.trs.infra.util.database.DBTypes 中的静态变量
数据库类型对象：SQLServerDB
SQLServerDB - com.trs.infra.util.database 中的 类

SQLServerDB() - 类 com.trs.infra.util.database.SQLServerDB 的构造方法

SQLServerDB(String, String) - 类 com.trs.infra.util.database.SQLServerDB 的构造方法

SQLServerUpdateSQL - com.trs.db.update 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SQLServerUpdateSQL() - 类 com.trs.db.update.SQLServerUpdateSQL 的构造方法

src - 类 com.trs.cms.content.ImgRec 中的变量

SRC - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

ST_ATTRNAME - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on reading attribute name
ST_ATTRNAME_END - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on attribute name end
ST_ATTRVALUE_END - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on attribute value end
ST_ATTRVALUE_HASQUOTE - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on reading attribute value having quote
ST_ATTRVALUE_HASQUOTE_BEGIN - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on begining to read attribute value having quote
ST_ATTRVALUE_HASQUOTE_ENDCHECK - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on to check attribute value end having quote
ST_ATTRVALUE_NOQUOTE - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on reading attribute value with no quote
ST_CHILD_BEGIN - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on begining to read a child
ST_CHILD_STRING - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on reading String child
ST_CHILD_STRING_END - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on a String child end
ST_CHILD_TAGITEM - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on reading TagItem child
ST_ENDTAG_CHECK - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on to check the endtag
ST_SELFCLOSEDTAG_CHECK - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on to check the self-closed tag
ST_STARTTAG_END - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on start-tag end
ST_TAGNAME - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on reading tag name
ST_TAGNAME_END - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
status: on tag name end
standardize(TagItem) - 接口 com.trs.components.common.publish.domain.tagparser.ITagFormatter 中的方法
Converts the tag item to standard format.
standardize(TagItem) - 类 com.trs.components.common.publish.domain.tagparser.TagFormatHelper 中的静态方法
Standardizes a specified tag item with the formatter configurated.
standardize(TagItem) - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterAllCata 中的方法

standardize(TagItem) - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChannel 中的方法

standardize(TagItem) - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChnlName 中的方法

standardize(TagItem) - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterColumn 中的方法

standardize(TagItem) - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase 中的方法

standardize(TagItem) - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicture 中的方法

standardize(TagItem) - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRecPath 中的方法

standardize(TagItem) - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterTemplate 中的方法

STANDBY - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

start() - 类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 中的方法

start(PublishTask) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法
start to analyze the publish task.
start() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法

start() - 类 com.trs.infra.config.TRSConfigServer 中的静态方法
启动配置服务器
start() - 类 com.trs.infra.util.DebugTimer 中的方法

START - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

start() - 类 com.trs.infra.util.job.JobScheduler 中的方法

startApplyFormInFlow(User, ApplyForm, MethodContext) - 类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 中的静态方法

startApplyFormInFlow(User, ApplyForm, boolean) - 类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 中的静态方法

startApplyFormInFlow(User, ApplyForm, Map) - 类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 中的静态方法

startContentInFlow(User, IFlowContent) - 类 com.trs.cms.process.FlowServer 中的方法

startContentInFlow(User, IFlowContent, String) - 类 com.trs.cms.process.FlowServer 中的方法
为文档对象添加新的FlowDoc对象，使文档进入工作流流转
startContentInFlow(int, int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法

startContentInFlow(int, int) - 接口 com.trs.service.IWCMProcessService 中的方法

startDocument() - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法

startDocumentInFlow(MethodContext) - 类 com.trs.ajaxservice.ApplyFormServiceProvider 中的方法
让文档开始流转
startDocumentInFlow(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
让文档开始流转
startDocumentInFlow(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
让文档开始流转
startDocumentInFlow(User, Document, MethodContext) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法

startDocumentInFlow(User, Document, Flow, MethodContext) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法

startDocumentInFlow(User, Document, boolean) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法

startDocumentInFlow(User, Document, Map) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法

started() - 类 com.trs.infra.config.BeanConfigServer 中的静态方法
判断BeanConfigServer是否已经启动，即所有的Bean配置文件都已经被加载了
startElement(String, String, String, Attributes) - 类 com.trs.cms.content.WCMHandler 中的方法

startElement(String, String, String, Attributes) - 类 com.trs.cms.content.WCMObjsHandler 中的方法

startElement(String, String, String, Attributes) - 类 com.trs.infra.persistent.BaseObjHandler 中的方法

startElement(String, String, String, Attributes) - 类 com.trs.infra.persistent.BaseObjsHandler 中的方法

startElement(String, String, String, Attributes) - 类 com.trs.infra.util.CMyXMLHandler 中的方法

startElement(String, String, String, Attributes) - 类 com.trs.webframework.controler.PostDataParser 中的方法

startElement(String, String, String, Attributes) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.BatchChannelCreateFromFileLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.ChannelCreateFromLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.ChannelImportLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.ChannelMoveLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.DocCopyLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.DocImportLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.DocMoveLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.DocPublishTaskLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.DocSaveLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.DocStatusChangeLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.FlowSaveLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.FlowSetLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.ImpartTemplateLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.PublishConfigSaveLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.PublishTaskLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.RecycleClearLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.RestoreObjLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.ResyncTemplateApdLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.SetEmployersOfTemplateLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.SiteCreateFromLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.SiteImportLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.SiteRecycleClearLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.TemplateImportLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.TemplateSyncLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.ajaxservice.logger.WebSiteRestoreLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.components.wcm.epress.EPressChannelCreateLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.components.wcm.epress.EPressHistoryPubLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.webframework.DefaultDeleteLogger 中的方法

startLog(MethodConfig, MethodContext) - 类 com.trs.webframework.DefaultSaveLogger 中的方法

startLog(MethodConfig, MethodContext) - 接口 com.trs.webframework.ServiceExcuteLogger 中的方法

startLogDeleting(User, BaseObj) - 类 com.trs.cms.logger.ObjSysLogger 中的方法
开始记录一个删除记录的日志
startLogInserting(User, BaseObj) - 类 com.trs.cms.logger.ObjSysLogger 中的方法
开始记录一个新增记录的日志
startLogModifying(User, BaseObj) - 类 com.trs.cms.logger.ObjSysLogger 中的方法
开始记录一个修改记录的日志
startRecord(String, String, String, BaseObj, int) - 类 com.trs.infra.support.log.LogServer 中的静态方法
开始记录日志
startRecord(String, String, String, BaseObj) - 类 com.trs.infra.support.log.LogServer 中的静态方法

startup() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
startup the dispatcher
startup() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法

startup() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法

startup(int) - 类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 中的方法

startup() - 类 com.trs.infra.BaseServer 中的方法

startup() - 接口 com.trs.infra.IServer 中的方法
启动应用
startup() - 类 com.trs.infra.ServerControl 中的方法

StartupServlet - com.trs.infra 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
系统服务器启动Servlet
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StartupServlet() - 类 com.trs.infra.StartupServlet 的构造方法

startWCMForTRS() - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的静态方法
启动WCMForTRS
stat(String, String) - 类 com.trs.components.stat.StatAnalysisTool 中的方法
对指定的开始时间sStartDate与结束时间sEndDate进行统计，返回统计的结果集对象
stat(CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatAnalysisTool 中的方法
对指定的开始时间startDate与结束时间endDate进行统计，返回统计的结果集对象
stat(CMyDateTime, CMyDateTime, int) - 类 com.trs.components.stat.StatAnalysisTool 中的方法
对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。
stat(String, String, int) - 类 com.trs.components.stat.StatAnalysisTool 中的方法
对指定的开始时间startDate与结束时间endDate进行统计，统计过程中，将把开始时间与结束时间分成多个区间， 区间的长度根据nStepType的类型决定。
stat(CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatBonusDataForUser 中的方法
产生指定时间段的统计结果
stat(CMyDateTime, CMyDateTime, int, boolean) - 类 com.trs.components.stat.StatBonusDataForUser 中的方法
产生指定时间段的统计结果
stat(int, CMyDateTime) - 类 com.trs.components.stat.StatDocCountByChannel 中的方法
产生指定时间指定站点的统计结果
stat(int, CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatDocCountByChannel 中的方法
产生指定时间段的统计结果
stat(int, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfGroupByChannel 中的方法
产生指定时间指定站点的统计结果
stat(int, CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfGroupByChannel 中的方法
产生指定时间段的统计结果
stat(int, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfGroupByMetaClass 中的方法
产生指定时间指定站点的统计结果
stat(int, CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfGroupByMetaClass 中的方法
产生指定时间段的统计结果
stat(int, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfUserByMetaClass 中的方法
产生指定时间指定分类下的统计结果
stat(int, CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfUserByMetaClass 中的方法
产生指定时间段的统计结果
STAT_STEP_DAY - 类 com.trs.components.stat.HitsCountConstant 中的静态变量

STAT_STEP_MONTH - 类 com.trs.components.stat.HitsCountConstant 中的静态变量

STAT_STEP_YEAR - 类 com.trs.components.stat.HitsCountConstant 中的静态变量

StatAnalysisTool - com.trs.components.stat 中的 类
执行统计分析的工具类.
StatAnalysisTool(String[]) - 类 com.trs.components.stat.StatAnalysisTool 的构造方法
使用默认的IStatHandler对象构造统计分析对象
StatAnalysisTool(String[], IStatHandler) - 类 com.trs.components.stat.StatAnalysisTool 的构造方法
使用指定的IStatHandler对象构造统计分析对象
StatAutoRunWorker - com.trs.components.wcm.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
自动统计数据到临时表的Worker
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StatAutoRunWorker() - 类 com.trs.components.wcm.stat.StatAutoRunWorker 的构造方法

StatBonusDataForUser - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户奖金统计类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
StatBonusDataForUser(String) - 类 com.trs.components.stat.StatBonusDataForUser 的构造方法

StatBonusDataForUser(String[]) - 类 com.trs.components.stat.StatBonusDataForUser 的构造方法

StatBonusResultForUser - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
StatBonusResultForUser(int) - 类 com.trs.components.stat.StatBonusResultForUser 的构造方法

StatDataItem - com.trs.components.wcm.stat.domain 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StatDataItem(CMyDateTime, Map) - 类 com.trs.components.wcm.stat.domain.StatDataItem 的构造方法

StatDocCountByChannel - com.trs.components.stat 中的 类

StatDocCountByChannel(String) - 类 com.trs.components.stat.StatDocCountByChannel 的构造方法

StatDocCountOfGroupByChannel - com.trs.components.stat 中的 类

StatDocCountOfGroupByChannel(String, int) - 类 com.trs.components.stat.StatDocCountOfGroupByChannel 的构造方法

StatDocCountOfGroupByMetaClass - com.trs.components.stat 中的 类

StatDocCountOfGroupByMetaClass(String, int) - 类 com.trs.components.stat.StatDocCountOfGroupByMetaClass 的构造方法

StatDocCountOfUserByMetaClass - com.trs.components.stat 中的 类

StatDocCountOfUserByMetaClass(String) - 类 com.trs.components.stat.StatDocCountOfUserByMetaClass 的构造方法

StatefulJobTest - com.trs.infra.util.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StatefulJobTest() - 类 com.trs.infra.util.job.StatefulJobTest 的构造方法

StatFieldMap - com.trs.components.wcm.stat 中的 类

StatFieldMap() - 类 com.trs.components.wcm.stat.StatFieldMap 的构造方法
构造函数：保留默认接口
StatFieldMaps - com.trs.components.wcm.stat 中的 类

StatFieldMaps(User) - 类 com.trs.components.wcm.stat.StatFieldMaps 的构造方法
构造函数
StatFieldMaps(User, int, int) - 类 com.trs.components.wcm.stat.StatFieldMaps 的构造方法
构造函数
statHitsBonusByMonth(CMyDateTime, CMyDateTime, boolean) - 类 com.trs.components.stat.StatBonusDataForUser 中的方法
获取指定时间段的点击量奖金的统计结果
StatHost - com.trs.components.wcm.stat 中的 类

StatHost() - 类 com.trs.components.wcm.stat.StatHost 的构造方法
构造函数：保留默认接口
StatHosts - com.trs.components.wcm.stat 中的 类

StatHosts(User) - 类 com.trs.components.wcm.stat.StatHosts 的构造方法
构造函数
StatHosts(User, int, int) - 类 com.trs.components.wcm.stat.StatHosts 的构造方法
构造函数
statIssuedAmountBonusByMonth(CMyDateTime, CMyDateTime, boolean) - 类 com.trs.components.stat.StatBonusDataForUser 中的方法
获取发稿量奖金按月统计的结果
STATISTIC_MAX_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
统计分析最大权限值
STATISTIC_MIN_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
统计分析最小权限值
StatMgr - com.trs.components.wcm.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
统计
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StatMgr() - 类 com.trs.components.wcm.stat.StatMgr 的构造方法

StatMgrName - 类 com.trs.components.wcm.stat.StatMgr 中的静态变量

StatResult - com.trs.components.stat 中的 类
执行一批SQL之后，返回的统计结果集对象，该对象一般为StatAnalysisTool.stat的返回结果
StatResult(List, List, IKeyMaker) - 类 com.trs.components.stat.StatResult 的构造方法

StatResultHolder - com.trs.components.wcm.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Cached StatResult.
StatResults - com.trs.components.stat 中的 类

StatResults() - 类 com.trs.components.stat.StatResults 的构造方法

StatResults(List, List, List) - 类 com.trs.components.stat.StatResults 的构造方法

StatService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
实现统计服务接口提供的功能
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StatService() - 类 com.trs.service.impl.StatService 的构造方法

Status - com.trs.components.wcm.resource 中的 类

Status() - 类 com.trs.components.wcm.resource.Status 的构造方法

STATUS_CANCELED - 类 com.trs.components.common.job.Schedule 中的静态变量

STATUS_DEL - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的静态变量

STATUS_DELETED - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish status: has been deleted
STATUS_DONE - 类 com.trs.components.common.job.Schedule 中的静态变量

STATUS_EXPIRED - 类 com.trs.components.common.job.Schedule 中的静态变量

STATUS_FAILED - 类 com.trs.components.common.job.Schedule 中的静态变量

STATUS_FORBIDDEN - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish status: is forbidden to publish
STATUS_ID_AGAIN - 类 com.trs.components.wcm.resource.Status 中的静态变量
系统预先设定的状态对象ID：返工状态 3
STATUS_ID_EDITED - 类 com.trs.components.wcm.resource.Status 中的静态变量
系统预先设定的状态对象ID：已编状态 2
STATUS_ID_NEW - 类 com.trs.components.wcm.resource.Status 中的静态变量
系统预先设定的状态对象ID：新稿状态 1
STATUS_ID_NO - 类 com.trs.components.wcm.resource.Status 中的静态变量
系统预先设定的状态对象ID：已否状态 15
STATUS_ID_PUBLISHED - 类 com.trs.components.wcm.resource.Status 中的静态变量
系统预先设定的状态对象ID：已发状态 10
STATUS_ID_SIGN - 类 com.trs.components.wcm.resource.Status 中的静态变量
系统预先设定的状态对象ID：已签状态 16
STATUS_ID_UNKNOWN - 类 com.trs.components.wcm.resource.Status 中的静态变量
状态对象ID：未知
STATUS_ID_USERDEF - 类 com.trs.components.wcm.resource.Status 中的静态变量
用户定义的状态对象，ID起始值 30
STATUS_ID_VERIFY - 类 com.trs.components.wcm.resource.Status 中的静态变量
系统预先设定的状态对象ID：正审状态 18
STATUS_NORM - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的静态变量

STATUS_NORMAL - 类 com.trs.components.common.job.Schedule 中的静态变量
计划状态：正常
STATUS_NOTSTART - 类 com.trs.components.common.job.Schedule 中的静态变量

STATUS_OPEN - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish status: is open and can be published
STATUS_PARAM_INVALID - 类 com.trs.components.common.job.Schedule 中的静态变量

STATUS_PARENT_DEL - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的静态变量

STATUS_PUBLISHED - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish status: has been published
STATUS_PUBLISHING - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish status: is during publishing process
STATUS_RUN - 类 com.trs.components.common.job.Schedule 中的静态变量

STATUS_UNKNOWN - 类 com.trs.components.common.job.Schedule 中的静态变量

STATUS_UNKNOWN - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
publish status: unknown
STATUS_WAIT - 类 com.trs.components.common.job.Schedule 中的静态变量

Statuses - com.trs.components.wcm.resource 中的 类

Statuses(User) - 类 com.trs.components.wcm.resource.Statuses 的构造方法

Statuses(User, int, int) - 类 com.trs.components.wcm.resource.Statuses 的构造方法

StatusServiceProvider - com.trs.ajaxservice 中的 类

StatusServiceProvider() - 类 com.trs.ajaxservice.StatusServiceProvider 的构造方法

StatView - com.trs.components.wcm.stat 中的 类

StatView() - 类 com.trs.components.wcm.stat.StatView 的构造方法
构造函数：保留默认接口
StatViewRel - com.trs.components.wcm.stat 中的 类

StatViewRel() - 类 com.trs.components.wcm.stat.StatViewRel 的构造方法
构造函数：保留默认接口
StatViewRels - com.trs.components.wcm.stat 中的 类

StatViewRels(User) - 类 com.trs.components.wcm.stat.StatViewRels 的构造方法
构造函数
StatViewRels(User, int, int) - 类 com.trs.components.wcm.stat.StatViewRels 的构造方法
构造函数
StatViews - com.trs.components.wcm.stat 中的 类

StatViews(User) - 类 com.trs.components.wcm.stat.StatViews 的构造方法
构造函数
StatViews(User, int, int) - 类 com.trs.components.wcm.stat.StatViews 的构造方法
构造函数
statVote(String, String) - 类 com.trs.components.common.trsvote.VoteSoapServer 中的方法

StdDemoProviderImpl - com.trs.webframework.demo 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
演示如果在框架中实现保存、查询、根据ID或者序列提取数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StdDemoProviderImpl() - 类 com.trs.webframework.demo.StdDemoProviderImpl 的构造方法

STEP_DAY - 类 com.trs.components.stat.TimeRange 中的静态变量

STEP_MONTH - 类 com.trs.components.stat.TimeRange 中的静态变量

STEP_QUARTER - 类 com.trs.components.stat.TimeRange 中的静态变量

STEP_YEAR - 类 com.trs.components.stat.TimeRange 中的静态变量

sTo - 类 com.trs.infra.util.CMySMS 中的变量
收信人
stop() - 类 com.trs.infra.util.DebugTimer 中的方法

stopOnParsingCompleted(Object) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法

stopOnParsingError(ServiceInvocationException) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法

STORED - 类 com.trs.infra.util.jazzlib.ZipEntry 中的静态变量
Compression method.
STORED - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的静态变量
Compression method.
STR_DELETE - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量

STR_FINDBYID - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量

STR_FINDBYIDS - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量

STR_QUERY - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量

STR_SAVE - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量

STR_SELFDEFINED - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量

STREAM_ENCODING_DEFAULT - 类 com.trs.webframework.xmlserver.parser.StreamBuddy 中的静态变量

StreamBuddy - com.trs.webframework.xmlserver.parser 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StreamBuddy() - 类 com.trs.webframework.xmlserver.parser.StreamBuddy 的构造方法

streamToElement(InputStream, Class, String) - 类 com.trs.infra.util.CMyXMLParser 中的静态方法

STRIKE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

STRING - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type 中的静态变量
字符串类型的属性，属性值可以是任意字符串
STRING - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 中的静态变量
字符串类型的变量，其值可以是任意字符串
StringXMLConvertorImpl - com.trs.webframework.xmlserver.convertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
将String处理成XML的Convertor
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
StringXMLConvertorImpl() - 类 com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl 的构造方法

STRONG - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

strToElement(String) - 类 com.trs.infra.util.CMyXMLParser 中的静态方法

strToElement(String, Class) - 类 com.trs.infra.util.CMyXMLParser 中的静态方法

strToElement(String, Class, String) - 类 com.trs.infra.util.CMyXMLParser 中的静态方法

strToTagItem(String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Converts a string to TagItem.
STYLE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

STYLE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

STYLE_ADD - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
新建风格的权限
STYLE_BROWSE - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
查看风格的权限
STYLE_CHECKBOX - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量

STYLE_CHECKBOX_INT - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量

STYLE_DEAL_MODE_CHANGE - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
fromXML时出现风格重名的处理方式 : 更名
STYLE_DEAL_MODE_IGNORE - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
fromXML时出现风格重名的处理方式 : 忽略
STYLE_DEAL_MODE_QUIT - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
fromXML时出现风格重名的处理方式 : 退出
STYLE_DEAL_MODE_UPDATE - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
fromXML时出现风格重名的处理方式 : 覆盖
STYLE_DELETE - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
删除风格的权限
STYLE_EDIT - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
修改风格的权限
STYLE_IPDISPLAY_COMPLETE - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量

STYLE_IPDISPLAY_DEFAULT - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量

STYLE_IPDISPLAY_HIDDENALL - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量

STYLE_IPDISPLAY_HIDDENLAST - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量

STYLE_IS_PRIVATE - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的静态变量
风格是私有的值
STYLE_NOT_IS_PRIVATE - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的静态变量
风格不是私有的值
STYLE_RADIO - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量

STYLE_RADIO_INT - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量

StyleAndResource - com.trs.components.common.publish.widget 中的 类

StyleAndResource() - 类 com.trs.components.common.publish.widget.StyleAndResource 的构造方法
构造函数：保留默认接口
StyleAndResourceMgr - com.trs.components.common.publish.widget 中的 类

StyleAndResourceMgr() - 类 com.trs.components.common.publish.widget.StyleAndResourceMgr 的构造方法

StyleAndResources - com.trs.components.common.publish.widget 中的 类

StyleAndResources(User) - 类 com.trs.components.common.publish.widget.StyleAndResources 的构造方法
构造函数
StyleAndResources(User, int, int) - 类 com.trs.components.common.publish.widget.StyleAndResources 的构造方法
构造函数
StyleCenterMgr - com.trs.components.common.publish.widget 中的 类

StyleCenterMgr() - 类 com.trs.components.common.publish.widget.StyleCenterMgr 的构造方法
构造方法
StyleConstants - com.trs.components.common.publish.widget 中的 类
定义风格所有常量
StyleConstants() - 类 com.trs.components.common.publish.widget.StyleConstants 的构造方法

styleDocument(Document, String) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法

StyleHelper - com.trs.components.common.publish.widget 中的 类
风格设计辅助类
StyleHelper() - 类 com.trs.components.common.publish.widget.StyleHelper 的构造方法

StyleItem - com.trs.components.common.publish.widget 中的 类

StyleItem() - 类 com.trs.components.common.publish.widget.StyleItem 的构造方法
构造函数：保留默认接口
StyleItemMgr - com.trs.components.common.publish.widget 中的 类
风格项业务逻辑类
StyleItemMgr() - 类 com.trs.components.common.publish.widget.StyleItemMgr 的构造方法

StyleItems - com.trs.components.common.publish.widget 中的 类

StyleItems(User) - 类 com.trs.components.common.publish.widget.StyleItems 的构造方法
构造函数
StyleItems(User, int, int) - 类 com.trs.components.common.publish.widget.StyleItems 的构造方法
构造函数
StyleItemServiceProvider - com.trs.components.common.publish.widget 中的 类
风格项服务
StyleItemServiceProvider() - 类 com.trs.components.common.publish.widget.StyleItemServiceProvider 的构造方法
构造方法
StylePathHelper - com.trs.components.common.publish.widget 中的 类

StylePathHelper() - 类 com.trs.components.common.publish.widget.StylePathHelper 的构造方法

StyleRepeatNameHelper - com.trs.components.common.publish.widget 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
StyleRepeatNameHelper() - 类 com.trs.components.common.publish.widget.StyleRepeatNameHelper 的构造方法

sub(double, double) - 类 com.trs.infra.util.CMyDecimalBuddy 中的静态方法
减法运算。
SUB - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

SubjectDataInitHelper - com.trs.components.common.publish.widget 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
SubjectDataInitHelper() - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 的构造方法

submitAgain(User, int, String) - 类 com.trs.cms.process.FlowServer 中的方法

submitAgain(User, int, String) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法

submitAgain(User, int, String) - 接口 com.trs.service.IWCMProcessService 中的方法

submitBack(User, IFlowContent, String) - 类 com.trs.cms.process.FlowServer 中的方法

submitBack(User, IFlowContent, String, int) - 类 com.trs.cms.process.FlowServer 中的方法
将文档返回到上一个节点，并返回给指定的用户
submitBack(User, String, String) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法

submitBack(User, String, String) - 接口 com.trs.service.IWCMProcessService 中的方法
指定的用户将指定的工作事项打回
submitTo(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
将需要处理的内容交给下一个环节处理
submitTo(FlowParamers) - 类 com.trs.cms.process.FlowServer 中的方法
按照指定的方式处理文档
submitTo(FlowContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法

submitTo(FlowContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
处理内容
submitTo(FlowParamers) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法

submitTo(FlowParamers) - 接口 com.trs.service.IWCMProcessService 中的方法
将内容按照指定的方式呈送
submitVote(String, String, String, String) - 类 com.trs.components.common.trsvote.VoteSoapServer 中的方法

substantiateContext(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 中的方法

substantiateContext(PublishTagContext) - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser4List 中的方法
实体化指定的PublishTagContext对象
substantiateContext(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserClassInfos 中的方法

substantiateContext(PublishTagContext) - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法

substantiateContext(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 中的方法

substantiateContext(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法

substantiateContext(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法

substVars(String, Properties) - 类 com.trs.infra.util.OptionConverter 中的静态方法
Perform variable substitution in string val from the values of keys found in the system propeties.
SUGGESTION_DEFAULT - 异常 com.trs.webframework.exception.ServiceInvocationException 中的静态变量

SUP - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

SUPPORT_DEFINE_DOCUMENT_RIGHT - 类 com.trs.ajaxservice.DocumentServiceProvider 中的静态变量

SUREFORM_ATTR - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量

SureformService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM为书生表单定制的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SureformService() - 类 com.trs.service.impl.SureformService 的构造方法

SybaseASE - 类 com.trs.infra.util.database.DBTypes 中的静态变量
定义数据库类型：Sybase ASE
SybaseASE - com.trs.infra.util.database 中的 类

SybaseASE() - 类 com.trs.infra.util.database.SybaseASE 的构造方法

SybaseASE(String, String, boolean) - 类 com.trs.infra.util.database.SybaseASE 的构造方法

SybaseASEText - com.trs.infra.util.database 中的 类

SybaseASEText() - 类 com.trs.infra.util.database.SybaseASEText 的构造方法

SybaseASEWithJtds - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
SybaseASE 数据库,使用jtds驱动
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
SybaseASEWithJtds() - 类 com.trs.infra.util.database.SybaseASEWithJtds 的构造方法

SybaseASEWithJtds(String, String, boolean) - 类 com.trs.infra.util.database.SybaseASEWithJtds 的构造方法

SymbolC2E - com.trs.tools 中的 类

SymbolC2E() - 类 com.trs.tools.SymbolC2E 的构造方法

SYNC_FIELD_NAMES - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量

syncChnlDocFlag(MethodContext) - 类 com.trs.ajaxservice.InfoviewDataToolService 中的方法
同步文档的DocFlag到ChnlDoc表中
SynChildrenExecutorBase - com.trs.infra.persistent.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SynChildrenExecutorBase(BaseObj) - 类 com.trs.infra.persistent.util.SynChildrenExecutorBase 的构造方法

SynChildrenExecutorBase(BaseObj, boolean) - 类 com.trs.infra.persistent.util.SynChildrenExecutorBase 的构造方法

SynChildrenExecutorForViewEmploy - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SynChildrenExecutorForViewEmploy(BaseChannel, MetaView, boolean) - 类 com.trs.components.metadata.service.SynChildrenExecutorForViewEmploy 的构造方法

SynChildrenExecutorForViewEmploy(BaseChannel, MetaView, boolean, boolean) - 类 com.trs.components.metadata.service.SynChildrenExecutorForViewEmploy 的构造方法

SynChildrenOfChannelExecutorBase - com.trs.components.wcm.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SynChildrenOfChannelExecutorBase(BaseChannel) - 类 com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase 的构造方法

SynChildrenOfChannelExecutorBase(BaseChannel, boolean) - 类 com.trs.components.wcm.content.SynChildrenOfChannelExecutorBase 的构造方法

SYNCHRONIZE_PROPERTIES_TO_CHNLDOC - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
是否通过WCMDocument中的数据到WCMChnlDoc中
SYNCHRONIZED_FIELDS - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量

synchronizeWidgetInstances(MethodContext) - 接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider 中的方法
将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。
synchronizeWidgetInstances(Template) - 接口 com.trs.components.common.publish.widget.IWidgetServer 中的方法
将模板中使用的资源实例和模板的真实内容相一致，从而去掉资源实例表以及资源实例变量表中的垃圾数据。
synchronizeWidgetInstances(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法

synchronizeWidgetInstances(Template) - 类 com.trs.components.common.publish.widget.WidgetServer 中的方法

synDocumentFieldValueWithRule(Document) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
按照栏目上设置的同步规则进行字段同步。
synTemplates(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
传递当前对象(站点/栏目)的模板配置到子对象上
SYS_CONTENTLINK - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
管理热词和热词分类*
SYS_DOCSOURCE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
维护文档来源*
SYS_DOCSTATUS - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
维护文档状态*
SYS_EVENTTYPE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
管理日程事件类型*
SYS_MAX_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
最大系统属性权限*
SYS_MIN_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
最小系统属性权限*
SYS_OPERTYPE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
管理操作类型*
SYS_RIGHT_SET - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
给对象设置权限
SYS_RIGHTDEF - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
管理权限定义*
SYS_SECURITY - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
管理安全级别*
SYS_STATISTIC - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
统计分析权限
SYS_WCMBEAN - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
管理发布组件*
SYSTEM_FIELD_NAMES - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量

SYSTEM_FIELD_NAMESMAP - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量

SYSTEM_USERNAME - 类 com.trs.cms.auth.persistent.User 中的静态变量
系统用户（虚拟的）名称
SystemCollocationConfig - com.trs.infra.support.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SystemCollocationConfig() - 类 com.trs.infra.support.config.SystemCollocationConfig 的构造方法

SystemContentStyleMgr - com.trs.components.common.publish.widget 中的 类
系统级别资源可用风格
SystemContentStyleMgr() - 类 com.trs.components.common.publish.widget.SystemContentStyleMgr 的构造方法

SystemResourceStyleMgr - com.trs.components.common.publish.widget 中的 类

SystemResourceStyleMgr() - 类 com.trs.components.common.publish.widget.SystemResourceStyleMgr 的构造方法

SystemServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
系统服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
SystemServiceProvider() - 类 com.trs.ajaxservice.SystemServiceProvider 的构造方法

SystemWarnerMsgImpl - com.trs.components.wcm.util 中的 类

SystemWarnerMsgImpl() - 类 com.trs.components.wcm.util.SystemWarnerMsgImpl 的构造方法
构造函数
概述  软件包  类  使用  树  已过时   索引  帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


B - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

B

B - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
b2iu(byte) - 类 com.trs.infra.util.CMyEncrypt 中的静态方法
把byte值按照不考虑正负号的原则的＂升位＂
b2iu(byte) - 类 com.trs.infra.util.MD5 中的静态方法
把byte值按照不考虑正负号的原则的＂升位＂
BACKGROUND - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
backTo(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
要求返工
backTo(FlowContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法
backTo(FlowContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
要求返工
backup(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法
保存指定文档的版本
backup(Document) - 接口 com.trs.service.IDocumentService 中的方法
备份当前文档,产生当前文档的一个版本
备份只针对实体文档，不针对引用转发或者镜像文档，所以只提供一个Document参数
backup(Document) - 类 com.trs.service.impl.DocumentService 中的方法
bakupDocument(Document) - 类 com.trs.components.wcm.content.domain.DocBakMgr 中的方法
备份当前文档
bakupLogs(BaseObjs) - 接口 com.trs.infra.support.log.ILogMgr 中的方法
bakupLogs(BaseObjs) - 类 com.trs.infra.support.log.LogMgr 中的方法
BarChartProducer - com.trs.components.wcm.stat.chart 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BarChartProducer() - 类 com.trs.components.wcm.stat.chart.BarChartProducer 的构造方法
BASE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
BASE64DecoderStream - com.trs.infra.util 中的 类
BASE64 解码输入流。
BASE64DecoderStream(InputStream) - 类 com.trs.infra.util.BASE64DecoderStream 的构造方法
使用指定的输入流创建BASE64DecoderStream对象， 即对输入流in进行解码。
BASE64EncoderStream - com.trs.infra.util 中的 类
BASE64 编码输入流。
BASE64EncoderStream(OutputStream) - 类 com.trs.infra.util.BASE64EncoderStream 的构造方法
使用指定的输出流和缺省的最大行长（76字符换行）创建BASE64编码流对象
BASE64EncoderStream(OutputStream, int) - 类 com.trs.infra.util.BASE64EncoderStream 的构造方法
使用指定的输出流和指定的最大行长创建BASE64编码流对象
Base64Util - com.trs.infra.util 中的 类
Base64编码/解码工具类,编码后会加上特征前缀__encoded__;
Base64Util() - 类 com.trs.infra.util.Base64Util 的构造方法
BaseChannel - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
BaseChannel() - 类 com.trs.components.wcm.content.persistent.BaseChannel 的构造方法
BaseChannelInfoEntity - com.trs.template.persistent 中的 类
BaseChannelInfoEntity() - 类 com.trs.template.persistent.BaseChannelInfoEntity 的构造方法
BaseChannelLCListener4ExtField - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
BaseChannelLCListener4ExtField() - 类 com.trs.components.wcm.content.domain.BaseChannelLCListener4ExtField 的构造方法
BaseChannelLCListener4Region - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
BaseChannelLCListener4Region() - 类 com.trs.components.wcm.content.domain.BaseChannelLCListener4Region 的构造方法
BaseConfig - com.trs.infra 中的 类
BaseConfig() - 类 com.trs.infra.BaseConfig 的构造方法
BaseConfigServer - com.trs.infra.config 中的 类
BaseConfigServer() - 类 com.trs.infra.config.BaseConfigServer 的构造方法
BaseContextHelper - com.trs.infra.common 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
使用ThreadLocal方式在各个功能模块间传递参数的管理模块
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseContextHelper() - 类 com.trs.infra.common.BaseContextHelper 的构造方法
BaseDBLog - com.trs.infra.support.log 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMLog,ILog的一个具体实现.日志对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseDBLog() - 类 com.trs.infra.support.log.BaseDBLog 的构造方法
构造函数：保留默认接口
BaseFieldHTMLParser - com.trs.components.web 中的 类
BaseFieldHTMLParser() - 类 com.trs.components.web.BaseFieldHTMLParser 的构造方法
BASEFONT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
BaseIdsMan - com.trs.infra.common 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
关联对象的处理基本管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseIdsMan() - 类 com.trs.infra.common.BaseIdsMan 的构造方法
BaseInfoViewFieldValueCreator - com.trs.components.infoview.helper 中的 类
BaseInfoViewFieldValueCreator() - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 的构造方法
BaseJob - com.trs.infra.util.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseJob() - 类 com.trs.infra.util.job.BaseJob 的构造方法
BaseObj - com.trs.infra.persistent 中的 类
BaseObj() - 类 com.trs.infra.persistent.BaseObj 的构造方法
BaseObjHandler - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjHandler(BaseObj) - 类 com.trs.infra.persistent.BaseObjHandler 的构造方法
BaseObjHelper - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjHelper() - 类 com.trs.infra.persistent.BaseObjHelper 的构造方法
BaseObjs - com.trs.infra.persistent 中的 类
BaseObjs() - 类 com.trs.infra.persistent.BaseObjs 的构造方法
构造函数
BaseObjs(int, int) - 类 com.trs.infra.persistent.BaseObjs 的构造方法
构造函数（默认不指定容量，建立指定）
BaseObjsHandler - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjsHandler(BaseObj, String) - 类 com.trs.infra.persistent.BaseObjsHandler 的构造方法
BaseObjsHandler(BaseObj) - 类 com.trs.infra.persistent.BaseObjsHandler 的构造方法
BaseObjToXmlConverter - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
对象到XML文件(WCM格式)转换实现
只能转换BaseObj/BaseObjs及其子类的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseObjToXmlConverter() - 类 com.trs.infra.persistent.BaseObjToXmlConverter 的构造方法
BaseObjToXmlConverterForSpecialProperty - com.trs.infra.persistent 中的 类
BaseObjToXmlConverterForSpecialProperty() - 类 com.trs.infra.persistent.BaseObjToXmlConverterForSpecialProperty 的构造方法
BasePropertiesBuilder - com.trs.components.web 中的 类
BasePropertiesBuilder(BaseObj) - 类 com.trs.components.web.BasePropertiesBuilder 的构造方法
BaseScheduleWorker - com.trs.components.common.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseScheduleWorker() - 类 com.trs.components.common.job.BaseScheduleWorker 的构造方法
BaseServer - com.trs.infra 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Server基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseServer() - 类 com.trs.infra.BaseServer 的构造方法
BaseServiceDecorator - com.trs.webframework.provider 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseServiceDecorator() - 类 com.trs.webframework.provider.BaseServiceDecorator 的构造方法
BaseServiceDecorator(IServiceProvider) - 类 com.trs.webframework.provider.BaseServiceDecorator 的构造方法
BaseStatefulJob - com.trs.infra.util.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulJob() - 类 com.trs.infra.util.job.BaseStatefulJob 的构造方法
BaseStatefulScheduleWorker - com.trs.components.common.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
线程安全的Job
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseStatefulScheduleWorker() - 类 com.trs.components.common.job.BaseStatefulScheduleWorker 的构造方法
BaseStatHandler - com.trs.components.stat 中的 类
屏蔽key构造及反解的细节；屏蔽统计结果的数据存储结构
BaseStatHandler() - 类 com.trs.components.stat.BaseStatHandler 的构造方法
BaseStyle - com.trs.components.common.publish.widget 中的 类
风格抽象类
BaseStyle() - 类 com.trs.components.common.publish.widget.BaseStyle 的构造方法
BaseTagParser - com.trs.components.common.publish.domain.tagparser 中的 类
BaseTagParser() - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 的构造方法
BaseTagParser4List - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseTagParser4List() - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 的构造方法
BaseTagParserDefaultObjects - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BaseTagParserDefaultObjects() - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParserDefaultObjects 的构造方法
BaseValidator - com.trs.webframework.controler.servlet 中的 类
BaseValidator(MethodConfig) - 类 com.trs.webframework.controler.servlet.BaseValidator 的构造方法
BaseWCMObjectToXML - com.trs.ajaxservice.xmlconvertors 中的 类
BaseWCMObjectToXML() - 类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 的构造方法
BaseWCMTagParserPreNextDocuments - com.trs.components.wcm.publish.tagparser 中的 类
BaseWCMTagParserPreNextDocuments() - 类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 的构造方法
BatchChannelCreateFromFileLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
批量创建日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
BatchChannelCreateFromFileLogger() - 类 com.trs.ajaxservice.logger.BatchChannelCreateFromFileLogger 的构造方法
BatchDetailPageTask - com.trs.components.common.publish.domain.taskdispatch 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
batch page task.
BatchDetailPageTask(IPublishFolder, boolean) - 类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 的构造方法
Constructor.
BatchDetailPageTask(IPublishFolder, boolean, int) - 类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 的构造方法
BeanConfig - com.trs.infra.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BeanConfig() - 类 com.trs.infra.config.persistent.BeanConfig 的构造方法
BeanConfigHelper - com.trs.infra.config.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
SpringBean对象配置信息的管理类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BeanConfigHelper(List) - 类 com.trs.infra.config.domain.BeanConfigHelper 的构造方法
BeanConfigServer - com.trs.infra.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
为SpringBean的配置提供服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BEFORE_PARSING - 类 com.trs.webframework.xmlserver.parser.XMLParsingStatus 中的静态变量
BEST_COMPRESSION - 类 com.trs.infra.util.jazzlib.Deflater 中的静态变量
The best and slowest compression level.
BEST_SPEED - 类 com.trs.infra.util.jazzlib.Deflater 中的静态变量
The worst but fastest compression level.
BFILE - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：BFILE
BGCOLOR - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
BIG - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
BIGINT - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：BIGINT
BIGINT - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：BIGINT
BIGINT - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：BIGINT
BIGINT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
BIGINT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：BIGINT
BINARY - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：BINARY
BINARY - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：BINARY
BINARY - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：BINARY
BindingBean - com.trs.components.infoview.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BindingBean() - 类 com.trs.components.infoview.config.BindingBean 的构造方法
BIT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
BIT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：BIT
BIT - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：BIT
BIT - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：BIT
BiTagValidator - com.trs.wcag2.validator 中的 类
BiTagValidator() - 类 com.trs.wcag2.validator.BiTagValidator 的构造方法
BLOB - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：BLOB
BLOB - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：BLOB
BLOB - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：BLOB
BLOB - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
BLOB - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：BLOB
BLOCKQUOTE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
BODY - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
BonusCalculator - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
BonusCalculator() - 类 com.trs.components.stat.BonusCalculator 的构造方法
BonusRule - com.trs.components.stat 中的 类
BonusRule() - 类 com.trs.components.stat.BonusRule 的构造方法
构造函数：保留默认接口
BonusRuleMgr - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
奖励规则的业务逻辑处理类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
BonusRuleMgr() - 类 com.trs.components.stat.BonusRuleMgr 的构造方法
BonusRules - com.trs.components.stat 中的 类
BonusRules(User) - 类 com.trs.components.stat.BonusRules 的构造方法
构造函数
BonusRules(User, int, int) - 类 com.trs.components.stat.BonusRules 的构造方法
构造函数
BonusRuleServiceProvider - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
奖励规则的服务层类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
BonusRuleServiceProvider() - 类 com.trs.components.stat.BonusRuleServiceProvider 的构造方法
BookMark - com.trs.components.common.bookmark 中的 类
BookMark() - 类 com.trs.components.common.bookmark.BookMark 的构造方法
BOOKMARK_CURRENT - 类 com.trs.infra.persistent.BaseObjs 中的静态变量
BOOKMARK_FIRST - 类 com.trs.infra.persistent.BaseObjs 中的静态变量
BOOKMARK_LAST - 类 com.trs.infra.persistent.BaseObjs 中的静态变量
BookMarkMgr - com.trs.components.common.bookmark 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
BookMarkMgr Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BookMarkMgr() - 类 com.trs.components.common.bookmark.BookMarkMgr 的构造方法
BookMarks - com.trs.components.common.bookmark 中的 类
BookMarks(User) - 类 com.trs.components.common.bookmark.BookMarks 的构造方法
BookMarks(User, int, int) - 类 com.trs.components.common.bookmark.BookMarks 的构造方法
BookMarkService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
实现IBookMarkService Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BookMarkService() - 类 com.trs.service.impl.BookMarkService 的构造方法
BOOLEAN - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 中的静态变量
逻辑类型的变量，其值必须是10个数字和减号
BOOLEAN - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
BooleanXMLConvertorImpl - com.trs.webframework.xmlserver.convertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Boolean的ＸＭＬ转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
BooleanXMLConvertorImpl() - 类 com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl 的构造方法
BORDER - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
borderImage(String, int, int) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
给图片加上边框
borderImage(String, int, int) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
borderImg(ImageMagickCmd.ImageObj, String, int, int) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法
BOTTOM_REGION_NUMBER - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
底部
BR - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
breakBeforeBegin() - 类 com.trs.infra.util.html.HTML.Tag 中的方法
breakBeforeEnd() - 类 com.trs.infra.util.html.HTML.Tag 中的方法
breaksFlow() - 类 com.trs.infra.util.html.HTML.Tag 中的方法
If the tag causes a line break, to the flow of data, then this method will return true.
BT_DATA_EDIT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
表单数据项的修改（包括删除）权限
BT_DATA_FILL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
表单数据项的填写权限
BT_DATA_VIEW - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
表单数据项的查看权限
buffer() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor 中的方法
以java.util.Iterator的形式返回被缓存的信息，从 java.util.Iterator 中迭代得到对象是java.lang.String。
buffer() - 类 com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl 中的方法
build(String) - 类 com.trs.components.infoview.config.EnumsConfig 中的静态方法
build(Document) - 类 com.trs.components.infoview.extract.DataTypeBuilder 中的方法
build(String, HashMap, InfoViewConfig) - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法
build(Document) - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
使用manifest.xsf的Document对象构造Manifest对象
build(Element) - 类 com.trs.components.infoview.extract.manifest.MenuArea 中的方法
build(View) - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的方法
build() - 类 com.trs.components.web.BasePropertiesBuilder 中的方法
build() - 类 com.trs.components.web.document.DocumentPropertiesBuilder 中的方法
build() - 接口 com.trs.components.web.IPropertiesBuilder 中的方法
根据內部obj对象，返回想要的Properties
build(String) - 类 com.trs.tools.CommonResourceBuilder 中的静态方法
buildAllFromTextFile(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
根据文本文件的定义，创建系统
buildChart(TimingChartData, ChartStyle, ChartOption) - 接口 com.trs.components.wcm.stat.domain.IChartBuilder 中的方法
buildChart(TimingChartData, ChartStyle, ChartOption) - 类 com.trs.components.wcm.stat.domain.TimingChartBuilder 中的方法
buildComplexFields(List, int) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
新建复合表单字段所对应的数据纪录
buildComplexFields(List, int, boolean) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
建立复合表单字段所对应的数据纪录
buildContent(InfoView, Document, Document) - 类 com.trs.components.infoview.InfoViewDataHelper 中的静态方法
buildContent(InfoView, Document, Document) - 接口 com.trs.components.infoview.mad.InfoViewDataHelper 中的方法
buildContent(InfoView, Document, Document) - 类 com.trs.components.infoview.mad.InfoViewDataHelperImpl 中的方法
buildDOM4JDocument(String) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
构造指定XML文件的DOM4J的Document对象
buildSearcher() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
构造当前TRS检索器的检索环境
buildSearcher(RequestHelper, User) - 类 com.trs.components.wcm.content.trsserver.TRSSearcherFactory 中的静态方法
构造TRS检索条件Searcher
buildXmlFile(String, String) - 类 com.trs.infra.util.CMyDOM4jHelper 中的静态方法
byteHEX(byte) - 类 com.trs.infra.util.CMyEncrypt 中的静态方法
用来把一个byte类型的数转换成十六进制的ASCII表示，
byteHEX(byte) - 类 com.trs.infra.util.MD5 中的静态方法
用来把一个byte类型的数转换成十六进制的ASCII表示，
byteToHexString(byte[]) - 类 com.trs.infra.util.CMyString 中的静态方法
将字节数据输出为16进制数表示的字符串
byteToHexString(byte[], char) - 类 com.trs.infra.util.CMyString 中的静态方法
将字节数据输出为16进制无符号数表示的字符串
byteToString(byte[], char, int) - 类 com.trs.infra.util.CMyString 中的静态方法
将字节数据输出为指定进制数表示的字符串（注意：负数带有负号）
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


T - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

T

TABLE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
Table - com.trs.infra.util.upgrade.dbcompare 中的 类
数据库表描述对象
Table(String) - 类 com.trs.infra.util.upgrade.dbcompare.Table 的构造方法
Table(String, String[]) - 类 com.trs.infra.util.upgrade.dbcompare.Table 的构造方法
TableDiff - com.trs.infra.util.upgrade.dbcompare 中的 类
两个同名表比较后的差异
TableDiff(String) - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 的构造方法
构造函数
TableDiff(Table) - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 的构造方法
构造函数
TableInfo - com.trs.infra.util.database 中的 类
TableInfo() - 类 com.trs.infra.util.database.TableInfo 的构造方法
构造函数
TableInfos - com.trs.infra.util.database 中的 类
TableInfos() - 类 com.trs.infra.util.database.TableInfos 的构造方法
构造函数
TableInfosMsgReceiver - com.trs.cluster.receiver 中的 类
TableInfosMsgReceiver() - 类 com.trs.cluster.receiver.TableInfosMsgReceiver 的构造方法
TablesCleaner - com.trs.tools 中的 类
TablesCleaner() - 类 com.trs.tools.TablesCleaner 的构造方法
TAG_ALONE - 类 com.trs.infra.util.html.HtmlElement 中的静态变量
TAG_ATTRIBUTE_BEANCLASSNAME - 类 com.trs.infra.config.ConfigConstants 中的静态变量
TAG_ATTRIBUTE_BEANID - 类 com.trs.infra.config.ConfigConstants 中的静态变量
TAG_ATTRIBUTE_BEANISSINGLETON - 类 com.trs.infra.config.ConfigConstants 中的静态变量
TAG_ELEMENT_BEAN - 类 com.trs.infra.config.ConfigConstants 中的静态变量
TAG_ELEMENT_BEANS - 类 com.trs.infra.config.ConfigConstants 中的静态变量
TAG_END - 类 com.trs.infra.util.html.HtmlComment 中的静态变量
TAG_METHOD - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的静态变量
TAG_PARAM - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的静态变量
TAG_PARAMS - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的静态变量
TAG_ROOT - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的静态变量
TAG_SHORT - 类 com.trs.infra.util.html.HtmlElement 中的静态变量
TAG_START - 类 com.trs.infra.util.html.HtmlComment 中的静态变量
TagBean - com.trs.components.common.publish.persistent.template 中的 类
TagBean() - 类 com.trs.components.common.publish.persistent.template.TagBean 的构造方法
系统默认的TRS置标解析组件的构造函数
TagBeanAttrInfo - com.trs.components.common.publish.domain.tagparser 中的 类
用于描述 ITagParser 置标的属性的特性
TagBeanAttrInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 的构造方法
缺省构造方法
TagBeanAttrInfo(String, TagBeanAttrInfo.Type, String, String[]) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 的构造方法
构造方法
TagBeanAttrInfo.Type - com.trs.components.common.publish.domain.tagparser 中的 类
TagBeanInfo - com.trs.components.common.publish.domain.tagparser 中的 类
用于描述 ITagParser 置标的特性
TagBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 的构造方法
缺省构造方法
TagBeanInfo(String, String, TagBeanInfo.BodyType) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 的构造方法
构造方法
TagBeanInfo.BodyType - com.trs.components.common.publish.domain.tagparser 中的 类
TagBeanInfoHelper - com.trs.components.common.publish.domain.tagparser 中的 类
TagBeanInfo的辅助类
TagBeanLCListener - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
life cycel listener for TagBean.
TagBeanLCListener() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanLCListener 的构造方法
TagBeans - com.trs.components.common.publish.persistent.template 中的 类
TagBeans(User) - 类 com.trs.components.common.publish.persistent.template.TagBeans 的构造方法
置标解析组件集合的构造函数
TagBeans(User, int, int) - 类 com.trs.components.common.publish.persistent.template.TagBeans 的构造方法
置标解析组件集合的构造函数
TagChannelChainParser - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
获取栏目父子链属性
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagChannelChainParser() - 类 com.trs.components.wcm.publish.tagparser.TagChannelChainParser 的构造方法
TagDocbakParser - com.trs.components.wcm.publish.tagparser 中的 类
TagDocbakParser() - 类 com.trs.components.wcm.publish.tagparser.TagDocbakParser 的构造方法
TagDocument - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
the tag document for template DOM.
TagDocument() - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 的构造方法
contructor: default
TagDocumentReader - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Tag Document reader.
TagDocumentScanner - com.trs.components.common.publish.domain.tagparser 中的 类
模板正文的文法分析器
TagDocumentScanner() - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentScanner 的构造方法
TagEBookDirParser - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
电子书目录置标(地方志等)
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
TagEBookDirParser() - 类 com.trs.components.wcm.epress.TagEBookDirParser 的构造方法
TagFieldInfoEntity - com.trs.template.persistent 中的 类
TagFieldInfoEntity() - 类 com.trs.template.persistent.TagFieldInfoEntity 的构造方法
TagFieldInfoEntity(int, String) - 类 com.trs.template.persistent.TagFieldInfoEntity 的构造方法
TagFormatHelper - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
helper for tag format
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagFormatterConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagFormatterConfig() - 类 com.trs.components.common.publish.config.persistent.TagFormatterConfig 的构造方法
TAGID_ATTRIBUTE_FLAG - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
flag for CMSObj attribute in tag
TAGID_OWNER - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
property id: myself
TAGID_OWNER_HASHCODE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
hash code for TAGID_OWNER
TAGID_PARENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
property id: my parent
TAGID_PARENT_HASHCODE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
hash code for TAGID_PARENT
TAGID_RECURL - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
property id: record path
TAGID_SITE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
property id: site
TAGID_SITE_HASHCODE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
hash code for TAGID_SITE
TagItem - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagItem() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 的构造方法
constructor: default
TagMapAreaParser - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
生成电子报map area相关信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagMapAreaParser() - 类 com.trs.components.wcm.epress.TagMapAreaParser 的构造方法
TAGNAME_COMMENT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
TAGNAME_EXISTSDATA - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
tag name: ExistsData
TAGNAME_NOTEXISTSDATA - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
tag name: NotExistsData
TAGNAME_PAGE_SEPARATOR - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
TAGNAME_PAGE_SEPARATOR_DETAIL - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
TAGNAME_RECORD - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
tag name: record
TAGNAME_TEMPLATE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
tag name: nested template
TAGNAME_VARIABLE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
tag name: variable
TAGNAME_VARIABLE_ENUM - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
tag name: variable enum
TagParseHelper - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
helper for tag parsing
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserCMSObj - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
default implementation for CMSObj tag parser.
TagParserCMSObj() - 类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObj 的构造方法
constructor: default
TagParserCMSObjBase - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
parser implementation base for CMSObj tag.
TagParserCMSObjBase() - 类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 的构造方法
TagParserCondition - com.trs.components.common.publish.domain.tagparser 中的 类
条件执行置标，如果指定的条件为真，则继续执行解析该置标下的模板，如果指定的条件为假，则忽略其下的模板。
TagParserCondition() - 类 com.trs.components.common.publish.domain.tagparser.TagParserCondition 的构造方法
缺省构造方法
TagParserCondition.Operator - com.trs.components.common.publish.domain.tagparser 中的 类
比较运算符的抽象
TagParserCondition.Operator() - 类 com.trs.components.common.publish.domain.tagparser.TagParserCondition.Operator 的构造方法
TagParserContentBase - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserContentBase() - 类 com.trs.components.common.publish.domain.tagparser.TagParserContentBase 的构造方法
TagParserCRUser - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
创建者属性发布置标
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagParserCRUser() - 类 com.trs.components.wcm.publish.tagparser.TagParserCRUser 的构造方法
TagParserDateTime - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Tag Parser For TRS_DATETIME
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserDateTime() - 类 com.trs.components.common.publish.domain.tagparser.TagParserDateTime 的构造方法
TagParserDefaultObjects - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_DefObjects的解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserDefaultObjects() - 类 com.trs.components.common.publish.domain.tagparser.TagParserDefaultObjects 的构造方法
TagParserDetailPage - com.trs.components.common.publish.domain.tagparser 中的 类
TagParserDetailPage() - 类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPage 的构造方法
TagParserDetailPages - com.trs.components.common.publish.domain.tagparser 中的 类
TagParserDetailPages() - 类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPages 的构造方法
TagParserEcho - com.trs.components.common.publish.domain.tagparser 中的 类
用于输出指定的内容到生成的文件中，在和模板变量配合使用时才有意义。
TagParserEcho() - 类 com.trs.components.common.publish.domain.tagparser.TagParserEcho 的构造方法
缺省构造方法
TagParseResults - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parse result
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParseResults() - 类 com.trs.components.common.publish.domain.tagparser.TagParseResults 的构造方法
constructor: default
TagParserFactory - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser factory.
TagParserFolderBase - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserFolderBase() - 类 com.trs.components.common.publish.domain.tagparser.TagParserFolderBase 的构造方法
TagParserInfoView - com.trs.components.infoview.publish.tagparser 中的 类
用于发布自定义表单的置标
TagParserInfoView() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoView 的构造方法
缺省构造方法
TagParserInfoViewData - com.trs.components.infoview.publish.tagparser 中的 类
TagParserInfoViewData() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData 的构造方法
TagParserInfoViewHelper - com.trs.components.infoview.publish.tagparser 中的 类
用于发布自定义表单的置标
TagParserInfoViewHelper() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper 的构造方法
缺省构造方法
TagParserInfoViewNav - com.trs.components.infoview.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserInfoViewNav() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav 的构造方法
缺省构造方法
TagParserInfoViewNavs - com.trs.components.infoview.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserInfoViewNavs() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 的构造方法
缺省构造方法
TagParserInfoViewPage - com.trs.components.infoview.publish.tagparser 中的 类
用于发布自定义表单的置标
TagParserInfoViewPage() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage 的构造方法
缺省构造方法
TagParserInfoViews - com.trs.components.infoview.publish.tagparser 中的 类
用于发布自定义表单的置标
TagParserInfoViews() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 的构造方法
缺省构造方法
TagParserNestedTemplate - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for nested template.
TagParserNestedTemplate() - 类 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate 的构造方法
constructor: default
TagParserNewIcon - com.trs.components.common.publish.domain.tagparser 中的 类
该置标为比较新的文档（也可以是其他对象）增加是新文档的标志。
TagParserNewIcon() - 类 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon 的构造方法
缺省构造方法
TagParserOddOrEven - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
奇偶然样式置标
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
TagParserOddOrEven() - 类 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven 的构造方法
TagParserOnlyLogic - com.trs.components.common.publish.domain.tagparser 中的 类
TagParserOnlyLogic() - 类 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic 的构造方法
TagParserPageNav - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分页置标
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
TagParserPageNav() - 类 com.trs.components.wcm.epress.TagParserPageNav 的构造方法
TagParserPageNav4Detail - com.trs.components.common.publish.domain.tagparser 中的 类
TagParserPageNav4Detail() - 类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 的构造方法
TagParserRepeat - com.trs.components.common.publish.domain.tagparser 中的 类
TODO javadoc for com.trs.components.common.publish.domain.tagparser.TagParserRepeat
TagParserRepeat() - 类 com.trs.components.common.publish.domain.tagparser.TagParserRepeat 的构造方法
缺省构造方法
TagParserSequenceNumber - com.trs.components.common.publish.domain.tagparser 中的 类
TagParserSequenceNumber() - 类 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber 的构造方法
TagParserSystemConfig - com.trs.components.common.publish.domain.tagparser 中的 类
返回配置的属性字段的值
TagParserSystemConfig() - 类 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig 的构造方法
TagParserUnimpl - com.trs.components.common.publish.domain.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TagParserUnimpl() - 类 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl 的构造方法
TagParserUser - com.trs.components.common.publish.domain.tagparser 中的 类
TagParserUser() - 类 com.trs.components.common.publish.domain.tagparser.TagParserUser 的构造方法
TagParserVariable - com.trs.components.common.publish.domain.tagparser 中的 类
用于在使用变量前，进行变量的声明。
TagParserVariable() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariable 的构造方法
缺省构造方法
TagParserVariableEnum - com.trs.components.common.publish.domain.tagparser 中的 类
在声明变量时，枚举变量的可用值
TagParserVariableEnum() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum 的构造方法
缺省构造方法
TagParserVariableSet - com.trs.components.common.publish.domain.tagparser 中的 类
给模板变量赋值的置标，一般情况下所赋之值来自其子置标的解析结果
TagParserVariableSet() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet 的构造方法
TagParserVipMetaData - com.trs.wcmonline 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
嘉宾访谈数据信息
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
TagParserVipMetaData() - 类 com.trs.wcmonline.TagParserVipMetaData 的构造方法
TagParserWmlImage - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagParserWmlImage() - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImage 的构造方法
TagParserWmlImages - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagParserWmlImages() - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImages 的构造方法
TagPreNextParser - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
TagPreNextParser() - 类 com.trs.components.wcm.epress.TagPreNextParser 的构造方法
TAGS_TOSKIP - 类 com.trs.infra.util.html.HtmlElement 中的静态变量
可以跳过的标记列表
TagWmlContentParser - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TagWmlContentParser() - 类 com.trs.components.wcm.publish.tagparser.TagWmlContentParser 的构造方法
TAMPLATE - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType 中的静态变量
在开始置标和结束置标之间，可以是模板内容，既可以包括WCM置标
TARGET - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
TargetTypeConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TargetTypeConfig() - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 的构造方法
TASK_PRIORITY_HIGH - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task level: urgent
TASK_PRIORITY_LOW - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task level: low
TASK_PRIORITY_NORM - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task level: normal
TASK_PRIORITY_REAL - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
必须马上执行的任务
TASK_STATUS_CANCELED - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: has been canceled
TASK_STATUS_EXPIRED - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: time is expired
TASK_STATUS_FAILED - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: failed
TASK_STATUS_FINISHED - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: has been done
TASK_STATUS_FINISHED_WITHWARNINGS - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: has been done but with warnings
TASK_STATUS_PARAM_INVALID - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: parameter is invalid
TASK_STATUS_PAUSED - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: has been paused
TASK_STATUS_RUNNING - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: is running
TASK_STATUS_UNKNOWN - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: unknown
TASK_STATUS_WAITING - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
task status: is waiting
TaskDispatcher - com.trs.components.common.publish.domain.taskdispatch 中的 类
IPublishTaskDispatcher的新实现，用以替换 PublishTaskDispatcherImpl。
TaskDispatcher() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 的构造方法
缺省构造方法
TaskWorker - com.trs.components.common.publish.domain.taskdispatch 中的 类
执行任务的Worker，执行原子任务 IAtomTask 的对象
TaskWorker() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskWorker 的构造方法
缺省构造方法
TBODY - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
tcompBAD - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
tcompMASK_TYPE - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
tcompTYPE_LZX - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
tcompTYPE_MSZIP - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
tcompTYPE_NONE - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
tcompTYPE_QUANTUM - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
TD - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
TempApdRel - com.trs.components.common.publish.persistent.template 中的 类
TempApdRel() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 的构造方法
构造函数：保留默认接口
TempApdRels - com.trs.components.common.publish.persistent.template 中的 类
TempApdRels(User) - 类 com.trs.components.common.publish.persistent.template.TempApdRels 的构造方法
构造函数
TempApdRels(User, int, int) - 类 com.trs.components.common.publish.persistent.template.TempApdRels 的构造方法
构造函数
TempAppendix - com.trs.components.common.publish.persistent.template 中的 类
TempAppendix() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 的构造方法
构造函数：保留默认接口
TempAppendixes - com.trs.components.common.publish.persistent.template 中的 类
TempAppendixes(User) - 类 com.trs.components.common.publish.persistent.template.TempAppendixes 的构造方法
指定用户和应用服务器的构造函数
TempAppendixes(User, int, int) - 类 com.trs.components.common.publish.persistent.template.TempAppendixes 的构造方法
指定用户和应用服务器的构造函数
TempAppendixXmlConverter - com.trs.components.common.publish.persistent.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板附件导出成为WCM的XML格式的转换管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TempAppendixXmlConverter() - 类 com.trs.components.common.publish.persistent.template.TempAppendixXmlConverter 的构造方法
constructor: default
Template - com.trs.components.common.publish.persistent.template 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class Template —— 模板对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
Template() - 类 com.trs.components.common.publish.persistent.template.Template 的构造方法
TEMPLATE_ADD - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
添加模板
TEMPLATE_BACKUP - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
备份模板
TEMPLATE_CHECK - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
校验模板
TEMPLATE_COLUMN_TAG - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATE_DEAL_MODE_CHANGE - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATE_DEAL_MODE_IGNORE - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATE_DEAL_MODE_QUIT - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATE_DEAL_MODE_UPDATE - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATE_DEL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除模板
TEMPLATE_EDIT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
修改模板
TEMPLATE_EXPORT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
导出模板
TEMPLATE_IMPORT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
导入模板
TEMPLATE_MAX_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
模板权限index最大值
TEMPLATE_MIN_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
模板权限Index最小值
TEMPLATE_OUTLINE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
查看模板列表
TEMPLATE_OUTLINE_TAG - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATE_PREVIEW - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
预览模板
TEMPLATE_RECORD_TAG - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATE_SAVE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
模板保存
TEMPLATE_SETARGS - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
管理模板变量
TEMPLATE_SYN_APPENDIX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
同步模板附件
TEMPLATE_TYPE_ADDEDIT - 类 com.trs.components.metadata.web.impl.FieldTemplateFactory 中的静态变量
新建修改页面类型的资源模板,addedit.hashCode
TEMPLATE_TYPE_ANY - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
template type: any type
TEMPLATE_TYPE_DETAIL - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
template type: detail template
TEMPLATE_TYPE_INFOVIEWPRINT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
template type: infoview print template
TEMPLATE_TYPE_LSIT - 类 com.trs.components.metadata.web.impl.FieldTemplateFactory 中的静态变量
列表页面类型的资源模板,list.hashCode
TEMPLATE_TYPE_NESTED - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
template type: nested template who will be included by other template
TEMPLATE_TYPE_OUTLINE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
template type: outline template
TEMPLATE_TYPE_VIEW - 类 com.trs.components.metadata.web.impl.FieldTemplateFactory 中的静态变量
查看页面类型的资源模板,view.hashCode
TEMPLATE_VIEW - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
查看模板
TEMPLATEAPD_DEAL_MODE_CHANGE - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATEAPD_DEAL_MODE_IGNORE - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATEAPD_DEAL_MODE_QUIT - 类 com.trs.infra.common.WCMTypes 中的静态变量
TEMPLATEAPD_DEAL_MODE_UPDATE - 类 com.trs.infra.common.WCMTypes 中的静态变量
TemplateArgument - com.trs.components.common.publish.persistent.template 中的 类
模板中的形式参数的实际值
TemplateArgument() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 的构造方法
缺省构造方法
TemplateArgumentCacheMgr - com.trs.components.common.publish.domain.template 中的 类
缓存TemplateArguments对象，并监听TemplateArgument的增删改
TemplateArgumentCacheMgr() - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 的构造方法
缺省构造方法
TemplateArgumentLCListenerForEmployChanged - com.trs.components.common.publish.domain.template 中的 类
在模板和频道的雇佣关系发生变化时，清除已经设置的模板变量
TemplateArgumentLCListenerForEmployChanged() - 类 com.trs.components.common.publish.domain.template.TemplateArgumentLCListenerForEmployChanged 的构造方法
缺省构造方法
TemplateArgumentMgr - com.trs.components.common.publish.domain.template 中的 类
模板参数实际值的管理器
TemplateArgumentMgr() - 类 com.trs.components.common.publish.domain.template.TemplateArgumentMgr 的构造方法
缺省构造方法
TemplateArguments - com.trs.components.common.publish.persistent.template 中的 类
TemplateArgument对象的集合
TemplateArguments(User) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 的构造方法
TemplateArguments(User, int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 的构造方法
TemplateAuthHelper - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板权限解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateAuthHelper() - 类 com.trs.ajaxservice.TemplateAuthHelper 的构造方法
TemplateCacheMgr - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
template cache manaager implementation.
TemplateCacheMgr() - 类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 的构造方法
constructor: default
TemplateEmploy - com.trs.components.common.publish.persistent.template 中的 类
TemplateEmploy() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 的构造方法
构造函数：保留默认接口
TemplateEmployCacheMgrImpl - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板和发布元素的配置缓冲管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployCacheMgrImpl() - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 的构造方法
TemplateEmployDetail - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployDetail() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 的构造方法
缺省构造方法
TemplateEmployDetail(TemplateEmploy) - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 的构造方法
TemplateEmployDetail(int, int, Template, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 的构造方法
TemplateEmployerIdsMan - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Template Employee Ids manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployerIdsMan(IPublishElement, TemplateEmployMgr, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployerIdsMan 的构造方法
TemplateEmployerToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板使用者XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployerToXML() - 类 com.trs.ajaxservice.xmlconvertors.TemplateEmployerToXML 的构造方法
TemplateEmployLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板配置日志记录
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TemplateEmployLogger() - 类 com.trs.components.wcm.logger.TemplateEmployLogger 的构造方法
TemplateEmployMgr - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
template employ records manager.
TemplateEmployMgr() - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 的构造方法
TemplateEmployMgrHelper - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateEmployMgrHelper() - 类 com.trs.ajaxservice.TemplateEmployMgrHelper 的构造方法
TemplateEmploys - com.trs.components.common.publish.persistent.template 中的 类
TemplateEmploys(User) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploys 的构造方法
构造函数
TemplateEmploys(User, int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploys 的构造方法
构造函数
TemplateExporter - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
负责管理模板导出相关的行为
模板导出过程中会涉及到模板附件的导出
由于目前顶已模板导出只伴随站点导出才导出，频道导出时不导出模板，所以模板附件的导出相对比较简单
以后再进行扩展
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateExporter() - 类 com.trs.components.common.publish.domain.template.TemplateExporter 的构造方法
constructor: default
TemplateImporter - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理和模板导入相关的行为
目前模板的导入只支持随着站点的导入一起进行，不支持单独的模板导入
目前提供的独立的模板导入、导出是通过独立的处理逻辑进行的，和XML的导入、导出没有关系
模板导入时，还需要考虑模板附件的导入
由于上面的约束，所以模板附件的导入相对比较简单，不需要考虑重名的处理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateImporter() - 类 com.trs.components.common.publish.domain.template.TemplateImporter 的构造方法
constructor: default
TemplateImportLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
导入模板日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TemplateImportLogger() - 类 com.trs.ajaxservice.logger.TemplateImportLogger 的构造方法
TemplateInfoEntity - com.trs.template.persistent 中的 类
TemplateInfoEntity() - 类 com.trs.template.persistent.TemplateInfoEntity 的构造方法
TemplateInfoEntity(int, String) - 类 com.trs.template.persistent.TemplateInfoEntity 的构造方法
TemplateLCListenerForNestedRename - com.trs.components.common.publish.domain.template 中的 类
如果修改了模板的名称，则要检查模板是否被嵌套，如果模板被嵌套使用，则要同步修改所有的引用。
TemplateLCListenerForNestedRename() - 类 com.trs.components.common.publish.domain.template.TemplateLCListenerForNestedRename 的构造方法
缺省构造方法
TemplateLCListenerForTypeChanged - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
监听模板类型的变化,更新模板的使用情况
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateLCListenerForTypeChanged() - 类 com.trs.components.common.publish.domain.template.TemplateLCListenerForTypeChanged 的构造方法
TemplateLCListenerVisualTemplate - com.trs.components.common.publish.widget 中的 类
当可视化模板进行保存或修改的时候，需要将模板和资源实例建立去关联关系。
TemplateLCListenerVisualTemplate() - 类 com.trs.components.common.publish.widget.TemplateLCListenerVisualTemplate 的构造方法
TemplateLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TemplateLogger() - 类 com.trs.components.wcm.logger.TemplateLogger 的构造方法
TemplateMgr - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TemplateMgr() - 类 com.trs.components.common.publish.domain.template.TemplateMgr 的构造方法
constructor: default
TemplateNestMgr - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
template nest record manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateNestMgr() - 类 com.trs.components.common.publish.domain.template.TemplateNestMgr 的构造方法
TemplateParameter - com.trs.components.common.publish.domain.tagparser 中的 类
描述模板置标中的形式参数 因为按照目前的设计，置标中的形式参数不保存到数据库，而是解析后存在于缓存中，所以没有把该类放在包 “com.trs.components.common.publish.persistent.template”中。
TemplateParameter() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 的构造方法
缺省构造方法
TemplateParameter.Token - com.trs.components.common.publish.domain.tagparser 中的 类
形式参数的候选值
TemplateParameter.Type - com.trs.components.common.publish.domain.tagparser 中的 类
形式参数的类型
TemplateParameterList - com.trs.components.common.publish.domain.tagparser 中的 类
对象TemplateParameter的集合类
TemplateParameterList() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 的构造方法
缺省构造方法
TemplateParameterList(boolean) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 的构造方法
构造方法
TemplateParseAngel - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
template parse agel which runs background.
TemplateParseConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseConfig() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 的构造方法
TemplateParseHelper - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
file distribute ship
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseHelper() - 类 com.trs.components.common.publish.domain.template.TemplateParseHelper 的构造方法
TemplateParseMgr - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
template parse manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseMgr() - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 的构造方法
constructor: default
TemplateParseService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板解析接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateParseService() - 类 com.trs.service.impl.TemplateParseService 的构造方法
TemplateQuote - com.trs.components.common.publish.persistent.template 中的 类
TemplateQuote() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 的构造方法
构造函数：保留默认接口
TemplateQuoteMgr - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
template quote records manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateQuoteMgr() - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr 的构造方法
constructor: default
TemplateQuoteMgr0310 - com.trs.components.common.publish.domain.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
template quote records manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateQuoteMgr0310() - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310 的构造方法
constructor: default
TemplateQuotes - com.trs.components.common.publish.persistent.template 中的 类
TemplateQuotes(User) - 类 com.trs.components.common.publish.persistent.template.TemplateQuotes 的构造方法
构造函数
TemplateQuotes(User, int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateQuotes 的构造方法
构造函数
TemplateRemoteException - com.trs.template 中的 异常
TemplateRemoteException() - 异常 com.trs.template.TemplateRemoteException 的构造方法
缺省的构造函数
TemplateRemoteException(Exception) - 异常 com.trs.template.TemplateRemoteException 的构造方法
构造函数，通过普通的Exception来构造TemplateRemoteException
TemplateRemoteException(int, String, String) - 异常 com.trs.template.TemplateRemoteException 的构造方法
直接构造函数
TemplateRightObjImpl - com.trs.components.common.publish.domain.auth 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板权限判断的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateRightObjImpl() - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 的构造方法
TemplateRightObjImpl(int) - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 的构造方法
TemplateRightObjImpl(CMSObj) - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 的构造方法
Templates - com.trs.components.common.publish.persistent.template 中的 类
Templates(User) - 类 com.trs.components.common.publish.persistent.template.Templates 的构造方法
Templates(User, int, int) - 类 com.trs.components.common.publish.persistent.template.Templates 的构造方法
TemplateSaveListenerForRegionEmploy - com.trs.components.wcm.publish.region 中的 类
TemplateSaveListenerForRegionEmploy() - 类 com.trs.components.wcm.publish.region.TemplateSaveListenerForRegionEmploy 的构造方法
TemplateService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板服务提供对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateService() - 类 com.trs.service.impl.TemplateService 的构造方法
constructor: default
TemplateServiceConfig - com.trs.template 中的 类
TemplateServiceConfig() - 类 com.trs.template.TemplateServiceConfig 的构造方法
TemplateServiceFactory - com.trs.template 中的 类
TemplateServiceFactory() - 类 com.trs.template.TemplateServiceFactory 的构造方法
TemplateServiceHelperProvider - com.trs.ajaxservice 中的 类
TemplateServiceHelperProvider() - 类 com.trs.ajaxservice.TemplateServiceHelperProvider 的构造方法
TemplateServiceImpl - com.trs.template.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ITemplateService Implement Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateServiceImpl() - 类 com.trs.template.service.impl.TemplateServiceImpl 的构造方法
TemplateServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板类相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateServiceProvider() - 类 com.trs.ajaxservice.TemplateServiceProvider 的构造方法
TemplateSettingFactory - com.trs.template.domain.setting 中的 类
TemplateSettingFactory() - 类 com.trs.template.domain.setting.TemplateSettingFactory 的构造方法
TemplatesTemplateSetting - com.trs.template.domain.setting 中的 类
TemplatesTemplateSetting() - 类 com.trs.template.domain.setting.TemplatesTemplateSetting 的构造方法
TemplateSyncLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TemplateSyncLogger() - 类 com.trs.ajaxservice.logger.TemplateSyncLogger 的构造方法
TemplateToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板对象XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateToXML() - 类 com.trs.ajaxservice.xmlconvertors.TemplateToXML 的构造方法
TEMPLATETYPEINFOS_XMLFILE - 类 com.trs.components.common.publish.domain.template.TemplateExporter 中的静态变量
TemplateXmlConverter - com.trs.components.common.publish.persistent.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
将模板导入、导出成为WCM的XML对象
目前模板的导入只支持随着站点的导入一起进行，不支持单独的模板导入
目前提供的独立的模板导入、导出是通过独立的处理逻辑进行的，和XML的导入、导出没有关系
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TemplateXmlConverter() - 类 com.trs.components.common.publish.persistent.template.TemplateXmlConverter 的构造方法
constructor: default
TemplateXmlGenerator - com.trs.template.domain 中的 类
TemplateXmlGenerator() - 类 com.trs.template.domain.TemplateXmlGenerator 的构造方法
TempPathCleaner - com.trs.components.common.job 中的 类
TempPathCleaner() - 类 com.trs.components.common.job.TempPathCleaner 的构造方法
构造函数，保留默认接口
Test - com.trs.webframework.config 中的 类
Test() - 类 com.trs.webframework.config.Test 的构造方法
TEST_NOEXCEPTION - 类 com.trs.template.InnerExceptionNum 中的静态变量
testBuildXML() - 类 com.trs.components.metadata.center.xml.XMLToMetaViewDataTest 中的方法
testCase1() - 类 com.trs.components.infoview.helper.InfoViewQueryHelper 中的静态方法
testCollate() - 类 com.trs.components.ckm.ICKMServerTest 中的方法
testCreateDBDataInsertSQL() - 类 com.trs.db.schema.TRSDBSchemaTest 中的方法
testDateFormat(String) - 类 com.trs.infra.util.CMyDateTime 中的方法
测试日期格式是否合法
testEnableCKMService() - 类 com.trs.components.ckm.ICKMServerTest 中的方法
testExtractAbstract() - 类 com.trs.components.ckm.ICKMServerTest 中的方法
testFtpServer(String, String, String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
使用默认端口"21"测试FTP服务器连接正常
testFtpServer(String, String, String, String, boolean) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
测试默认端口"21"测试FTP服务器连接正常以及指定的目录是否具有可写权限
testGetPreNextDocuments() - 类 com.trs.components.wcm.publish.domain.PreNextDocumentsImplTest 中的方法
TestIPFD - com.trs.components.infoview.extract 中的 类
TestIPFD() - 类 com.trs.components.infoview.extract.TestIPFD 的构造方法
testJspFiles() - 类 com.trs.components.metadata.service.util.WCMJSPCheckerTest 中的方法
testNewsHoo() - 类 com.trs.components.wcm.newshoo.DataFromNewshoo 中的静态方法
testQueryMetaViewDatas() - 类 com.trs.components.metadata.center.ClassDocumentsHelperTest 中的方法
testSetCKMServer() - 类 com.trs.components.ckm.ICKMServerTest 中的方法
testSimSearch() - 类 com.trs.components.ckm.ICKMServerTest 中的方法
testStatView(int) - 类 com.trs.service.impl.StatService 中的方法
testStatView(int) - 接口 com.trs.service.IStatService 中的方法
测试特定的统计模板是否能够运行通过
TestTrsServer - com.trs.components.wcm.content.trsserver 中的 类
TestTrsServer() - 类 com.trs.components.wcm.content.trsserver.TestTrsServer 的构造方法
testValidateCKMServer() - 类 com.trs.components.ckm.ICKMServerTest 中的方法
testVoteSoapServer(String) - 类 com.trs.components.common.trsvote.VoteSoapServer 中的方法
testWriteHTMLOfAPath() - 类 com.trs.presentation.nav.TreeCreatorTest 中的方法
testWriteTreeHTML() - 类 com.trs.presentation.nav.TreeCreatorTest 中的方法
TEXT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
TEXT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：TEXT
TEXT - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：TEXT
TEXT - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：TEXT
TEXT - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
TEXTAREA - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
TH - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
ThreadPool - com.trs.components.common.publish.domain.taskdispatch 中的 类
线程池
ThreadPool() - 类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 的构造方法
TIME - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：TIME
TIME - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：TIME
TIME - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：TIME
TIME - 类 com.trs.infra.util.database.KingBaseDB 中的静态变量
定义SQL Server中的字段类型：TIME
TIME - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
TIME_EXEC_WARN - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments 中的静态变量
TIME_LIMITED_DEFAULT - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
TIME_LIMITED_NOT - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
TIME_LIMITED_SPECIAL_POINT - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
TIME_LIMITED_SPECIAL_RANGE - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
TimeRange - com.trs.components.stat 中的 类
用于按照指定的步长，处理开始时间与结束时间
TimeRange(CMyDateTime, CMyDateTime, int) - 类 com.trs.components.stat.TimeRange 的构造方法
TIMESTAMP - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：TIMESTAMP
TIMESTAMP - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：TIMESTAMP
TIMESTAMP - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：TIMESTAMP
TIMESTAMP - 类 com.trs.infra.util.database.KingBaseDB 中的静态变量
定义SQL Server中的字段类型：TIMESTAMP
TIMESTAMP - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
TIMESTAMP - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：TIMESTAMP
TIMESTAMP - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：TIMESTAMP
TIMESTAMP - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：TIMESTAMP
TimingChartBuilder - com.trs.components.wcm.stat.domain 中的 类
TimingChartBuilder() - 类 com.trs.components.wcm.stat.domain.TimingChartBuilder 的构造方法
TimingChartData - com.trs.components.wcm.stat.domain 中的 类
TimingChartData(int, ChartOption) - 类 com.trs.components.wcm.stat.domain.TimingChartData 的构造方法
TimingChartProducer - com.trs.components.wcm.stat.domain 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TimingChartProducer() - 类 com.trs.components.wcm.stat.domain.TimingChartProducer 的构造方法
TINYBLOB - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
TINYINT - 类 com.trs.infra.util.database.KingBaseDB 中的静态变量
TINYINT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
TINYINT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：TINYINT
TINYINT - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：TINYINT
TINYINT - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：TINYINT
TINYTEXT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
TITLE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
TITLE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
TITLE_LENGTH_MAX - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的静态变量
标题最大长度
toAbsolutePath(String) - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
把指定的相对路径转换为绝对路径，
toAbsolutePath(String) - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的方法
toAbsolutePath(String) - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的方法
toAbsolutePathName(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
将文件/路径名称转化为绝对路径名
toBoolean(String, boolean) - 类 com.trs.infra.util.OptionConverter 中的静态方法
If value is "true", then true is returned.
toCountQueryInfo() - 类 com.trs.infra.persistent.WCMFilter 中的方法
toCountSQL() - 类 com.trs.infra.persistent.WCMFilter 中的方法
toDate() - 类 com.trs.infra.util.CMyDateTime 中的方法
转化为java.sq.Date型数据
toDBInfo() - 类 com.trs.infra.persistent.db.DBManager 中的方法
返回数据库信息
toFile(Document, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
toFile(Document, String, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
toFileSize(String, long) - 类 com.trs.infra.util.OptionConverter 中的静态方法
toFlowsXMLString(String) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
toFlowsXMLString(String) - 接口 com.trs.service.IWCMProcessService 中的方法
toFlowXMLString(Flow) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
toFlowXMLString(Flow) - 接口 com.trs.service.IWCMProcessService 中的方法
toHandlerkey() - 类 com.trs.presentation.nav.AdvSearchNavHandler 中的方法
toHandlerkey() - 类 com.trs.presentation.nav.ChannelNavHandler 中的方法
toHandlerkey() - 类 com.trs.presentation.nav.ClassInfoNavHandler 中的方法
toHandlerkey() - 接口 com.trs.presentation.nav.INavHandler 中的方法
产生指定Handler的Key
toHashMapForCache() - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的方法
将列表转化为“参数key/参数值”的HashMap对象
toHashMapForCheck() - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的方法
将列表转化为“参数key/参数对象(TemplateArgument)”的HashMap对象， 用于在用户界面中检查相应的参数是否进行了设置。
toHtml(Connection, int, String) - 类 com.trs.infra.util.database.TableInfos 中的方法
将数据库信息，输出到Html文本中
toHTML() - 类 com.trs.presentation.navigation.TreeItem 中的方法
toHtml(String) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法
toHtml(String, boolean, boolean) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法
toHtml(CMyDateTime) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法
toHtml(CMyDateTime, String) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法
toHTML(List) - 类 com.trs.wcag2.WCAG2Helper 中的静态方法
toHTMLHidden() - 类 com.trs.presentation.util.RequestHelper 中的方法
将参数以Hidden元素的形式输出
toHtmlValue(String) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法
toIdsString(List) - 类 com.trs.cms.content.WCMObjHelper 中的静态方法
将WCMObj数组转换为以逗号隔开的Id序列
toIdsString(List, String) - 类 com.trs.cms.content.WCMObjHelper 中的静态方法
将WCMObj数组转换为Id序列
toIdsString(List) - 类 com.trs.infra.persistent.BaseObjHelper 中的静态方法
将WCMObj数组转换为以逗号隔开的Id序列
toIdsString(List, String) - 类 com.trs.infra.persistent.BaseObjHelper 中的静态方法
将WCMObj数组转换为Id序列
toInitSearchJavaScript() - 类 com.trs.presentation.util.RequestHelper 中的方法
toInt(String, int) - 类 com.trs.infra.util.OptionConverter 中的静态方法
toISO_8859(String) - 类 com.trs.infra.util.CMyString 中的静态方法
将指定的字符串转化为ISO-8859-1编码的字符串
toIterator() - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 中的方法
toIterator() - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 中的方法
toIterator() - 类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 中的方法
toJSON(Object, String, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
根据传入的对象,返回JSON表达式
toJSON(Object[], int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
toJSON(String, String, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
toJSON(HashMap, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
将HashMap转换成一个JSON表达的JavaScript对象 HashMap中的Value支持String、String[]
toJSON(String[], String, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
将一个字符串数组转换成JSON表达的数组
toJSON(String[][], int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
将一个二维字符串[*][2]转换成一个JSON表达的JavaScript对象
toJSONXML() - 类 com.trs.infra.util.Report 中的方法
toJSONXML() - 类 com.trs.infra.util.Reports 中的方法
toLevel(String, Level) - 类 com.trs.infra.util.OptionConverter 中的静态方法
Converts a standard or custom priority level to a Level object.
toMemoryInfo() - 类 com.trs.infra.util.CMyMemory 中的静态方法
toNavInfoJSON(Map) - 类 com.trs.presentation.nav.AdvSearchNavHandler 中的方法
toNavInfoJSON(Map) - 类 com.trs.presentation.nav.ChannelNavHandler 中的方法
toNavInfoJSON(Map) - 类 com.trs.presentation.nav.ClassInfoNavHandler 中的方法
toNavInfoJSON(Map) - 接口 com.trs.presentation.nav.INavHandler 中的方法
返回一个可能包含navMode,mainFirstLink的HashMap对象
TOP_REGION_NUMBER - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
顶部
TOPIC_MOCK_CHANNELID - 类 com.trs.components.comment.CommentConstants 中的静态变量
TOPIC_MOCK_CHANNELTITLE - 类 com.trs.components.comment.CommentConstants 中的静态变量
TOPIC_MOCK_SITEDESC - 类 com.trs.components.comment.CommentConstants 中的静态变量
TOPIC_MOCK_SITEID - 类 com.trs.components.comment.CommentConstants 中的静态变量
TOPIC_NULL_CHANNELID - 类 com.trs.components.comment.CommentConstants 中的静态变量
TOPIC_TOKEN_IDSEPERATOR - 类 com.trs.components.comment.CommentConstants 中的静态变量
TopicedDocRelation - com.trs.components.comment.persistent 中的 类
TopicedDocRelation() - 类 com.trs.components.comment.persistent.TopicedDocRelation 的构造方法
构造函数：保留默认接口
TopicedDocRelations - com.trs.components.comment.persistent 中的 类
TopicedDocRelations(User) - 类 com.trs.components.comment.persistent.TopicedDocRelations 的构造方法
构造函数
TopicedDocRelations(User, int, int) - 类 com.trs.components.comment.persistent.TopicedDocRelations 的构造方法
构造函数
toSimpleJSON(Object, String, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
toSimpleJSON(Object[], String, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
toSimpleJSON(HashMap, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
toSimpleJSON(String[], String, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
toSimpleJSON2(HashMap, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
与toSimpleJson同参方法的区别在于对String[][]的处理改为对Object[]的处理 对Object[]和Object以及递归HashMap的处理方法由toSimpleJSON==>toSimpleJSON2
toSimpleJSON2(Object[], String, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
与toSimpleJson同参方法的区别在于对Object[]中的Object的处理方法由toSimpleJSON==>toSimpleJSON2
toSimpleJSON2(Object, String, int) - 类 com.trs.ajaxservice.JSONHelper 中的静态方法
与toSimpleJson同参方法的区别在于对String[][]的处理改为对Object[]的处理
toSQL() - 类 com.trs.infra.db.QueryFilter 中的方法
创建SQL语句
toSQL() - 类 com.trs.infra.persistent.WCMFilter 中的方法
创建SQL语句
toStop() - 类 com.trs.infra.util.CMyTimer 中的方法
中止线程
toStrArray() - 类 com.trs.components.common.publish.domain.tagparser.TagParseResults 中的方法
Returns the parsed result as string array
toString() - 类 com.trs.cms.auth.config.OperationConfig 中的方法
toString() - 类 com.trs.cms.auth.persistent.Group 中的方法
toString() - 类 com.trs.cms.auth.persistent.Right 中的方法
toString() - 类 com.trs.cms.auth.persistent.Role 中的方法
toString() - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
toString() - 类 com.trs.cms.auth.persistent.User 中的方法
toString() - 类 com.trs.cms.content.CMSObj 中的方法
toString() - 类 com.trs.cms.content.ExtendedField 中的方法
toString() - 类 com.trs.cms.content.Locker 中的方法
toString() - 类 com.trs.cms.content.WCMSystemObject 中的方法
toString() - 类 com.trs.cms.logger.LogInfo 中的方法
toString() - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
toString() - 类 com.trs.cms.process.definition.Flow 中的方法
toString() - 类 com.trs.cms.process.definition.FlowNode 中的方法
toString() - 类 com.trs.components.comment.domain.CommentUpdator 中的方法
toString() - 类 com.trs.components.comment.domain.Management 中的方法
toString() - 类 com.trs.components.comment.domain.NewsComment 中的方法
toString() - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法
toString() - 类 com.trs.components.common.bookmark.BookMark 中的方法
toString() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
toString() - 类 com.trs.components.common.job.Schedule 中的方法
toString() - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法
toString() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法
toString() - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
toString() - 类 com.trs.components.common.publish.config.PublishElementType 中的方法
toString() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type 中的方法
toString() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType 中的方法
toString() - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 中的方法
toString() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
toString() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Token 中的方法
toString() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 中的方法
toString() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
toString() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
toString() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
toString() - 类 com.trs.components.infoview.extract.DataType 中的方法
toString() - 类 com.trs.components.infoview.extract.manifest.CalculatedField 中的方法
toString() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法
toString() - 类 com.trs.components.infoview.extract.manifest.FileProperty 中的方法
toString() - 类 com.trs.components.infoview.extract.manifest.MenuArea 中的方法
toString() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法
toString() - 类 com.trs.components.infoview.extract.manifest.PackageFile 中的方法
toString() - 类 com.trs.components.infoview.extract.manifest.View 中的方法
toString() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
toString() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法
toString() - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法
toString() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
toString() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法
toString() - 类 com.trs.components.infoview.persistent.InfoViewSerial 中的方法
toString() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
toString() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
toString() - 类 com.trs.components.wcm.channel.VChannel 中的方法
toString() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
toString() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
toString() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
toString() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
toString() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
toString() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
toString() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
toString() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
toString() - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的方法
获取数据库连接的信息
toString() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
toString() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
toString() - 类 com.trs.components.wcm.stat.StatHost 中的方法
toString() - 类 com.trs.components.wcm.stat.StatView 中的方法
toString() - 类 com.trs.db.update.DBUpdateLog 中的方法
toString() - 类 com.trs.infra.config.persistent.ConfigFile 中的方法
toString() - 类 com.trs.infra.db.QueryFilter 中的方法
toString() - 类 com.trs.infra.persistent.listener.MonitorHostConfig 中的方法
toString() - 类 com.trs.infra.persistent.listener.ObjectMonitored 中的方法
toString() - 类 com.trs.infra.persistent.WCMFilter 中的方法
toString() - 类 com.trs.infra.support.config.PathConfig 中的方法
将属性值输出为格式化的字符串
toString() - 类 com.trs.infra.support.security.SecureKey 中的方法
toString() - 类 com.trs.infra.util.AttributesString 中的方法
获得属性字符串
toString() - 类 com.trs.infra.util.CMyBeanConfig 中的方法
toString() - 类 com.trs.infra.util.CMyBitsValue 中的方法
将权限值按实际位数以二进制序列字符串输出
toString(int) - 类 com.trs.infra.util.CMyBitsValue 中的方法
将权限值按实际位数以二进制序列字符串输出
toString() - 类 com.trs.infra.util.CMyClassConfig 中的方法
toString() - 类 com.trs.infra.util.CMyDateTime 中的方法
toString(String) - 类 com.trs.infra.util.CMyDateTime 中的方法
将日期数据转化为指定格式的字符串
toString(String, String, String) - 类 com.trs.infra.util.CMyDateTime 中的方法
toString() - 类 com.trs.infra.util.CMyErrors 中的方法
toString(boolean) - 类 com.trs.infra.util.CMyErrors 中的方法
输出错误信息
toString() - 异常 com.trs.infra.util.CMyException 中的方法
将异常信息输出为字符串
toString(Document) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
根据DOM树，生成字符串
toString(Element) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
根据DOM树，生成字符串
toString(Document, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
根据DOM树，生成字符串
toString(Element, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
根据DOM树，生成字符串
toString() - 类 com.trs.infra.util.database.CDBText 中的方法
字符串输出
toString() - 类 com.trs.infra.util.database.ConnectionPool 中的方法
获取数据库连接的信息
toString() - 类 com.trs.infra.util.database.DataType 中的方法
字符串输出
toString() - 类 com.trs.infra.util.database.FieldInfo 中的方法
获取字段信息
toString() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法
toString() - 类 com.trs.infra.util.ftp.FtpConnectionPool 中的方法
获取FTP连接的信息
toString() - 类 com.trs.infra.util.html.HTML.Attribute 中的方法
toString() - 类 com.trs.infra.util.html.HTML.Tag 中的方法
Return the string representation of the tag.
toString() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
字符串导出
toString() - 类 com.trs.infra.util.html.HtmlComment 中的方法
字符串导出
toString() - 类 com.trs.infra.util.html.HtmlDocument 中的方法
将文档内容输出为字符串
toString() - 类 com.trs.infra.util.html.HtmlElement 中的方法
toString(boolean, boolean, String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
字符串导出
toString(boolean, boolean) - 类 com.trs.infra.util.html.HtmlElement 中的方法
toString() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the string representation of this ZipEntry.
toString() - 类 com.trs.infra.util.Report 中的方法
toString() - 类 com.trs.infra.util.Reports 中的方法
toString() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
toString() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法
toString() - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的方法
toString() - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法
toString() - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
toString() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法
toString() - 类 com.trs.presentation.util.Parameters 中的方法
toString() - 类 com.trs.presentation.util.RequestHelper 中的方法
toString() - 类 com.trs.scene.tools.SceneNode 中的方法
toString() - 类 com.trs.wcag2.Alertion 中的方法
toString() - 类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 中的方法
toString() - 类 com.trs.wcm.photo.Watermark 中的方法
toString() - 类 com.trs.webframework.config.LoadingErrorReport 中的方法
toString() - 类 com.trs.webframework.config.MethodConfig 中的方法
totalConnections() - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的方法
获取缓冲池中连接总数
totalConnections() - 类 com.trs.infra.util.ftp.FtpConnectionPool 中的方法
获取缓冲池中连接总数
totalMemory() - 类 com.trs.infra.util.CMyMemory 中的静态方法
toTemplateCode(int, String) - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态方法
根据指定置标模板ID及传入的参数数据XML构造一份置标代码
toTemplateCode(String, String) - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态方法
根据指定置标代码样例及传入的参数数据XML构造一份置标代码
toTime() - 类 com.trs.infra.util.CMyDateTime 中的方法
转化为java.sql.Time型数据
toTimestamp() - 类 com.trs.infra.util.CMyDateTime 中的方法
转化为java.sql.Timestamp型数据
toTRSFilter(WCMFilter) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
toTRSRequestParam() - 类 com.trs.presentation.util.RequestHelper 中的方法
以TRS Page 参数形式输出
toTypeDescription(DataType) - 类 com.trs.infra.util.database.DataType 中的静态方法
toUnicode(String) - 类 com.trs.infra.util.CMyString 中的静态方法
已过时。 含义模糊，已经使用toISO_8859替换
toURL() - 类 com.trs.presentation.util.RequestHelper 中的方法
将参数以URL参数信息方式输出
toURLParameters() - 类 com.trs.presentation.util.RequestHelper 中的方法
将参数以URL参数信息方式输出
ToUsersCreatorConfig - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ToUsersCreatorConfig() - 类 com.trs.cms.process.config.ToUsersCreatorConfig 的构造方法
toWCMObj(String, CMSObj) - 类 com.trs.cms.content.WCMObjHelper 中的静态方法
解析传入的XML内容，生成传入WCMOBJ对象。
toWCMObj(String, User, int, Class) - 类 com.trs.cms.content.WCMObjHelper 中的静态方法
解析传入的XML内容，生成传入WCMOBJ对象。
toWCMObj(String, BaseObj) - 类 com.trs.infra.persistent.BaseObjHelper 中的静态方法
解析传入的XML内容，生成传入WCMOBJ对象。
toWCMObj(String, int, Class) - 类 com.trs.infra.persistent.BaseObjHelper 中的静态方法
解析传入的XML内容，生成传入WCMOBJ对象。
toWCMObjList(String, CMSObj, User) - 类 com.trs.cms.content.WCMObjHelper 中的静态方法
解析传入的XML内容，生成包含指定类型WCMObj的List。
toWCMObjList(String, BaseObj) - 类 com.trs.infra.persistent.BaseObjHelper 中的静态方法
解析传入的XML内容，生成包含指定类型WCMObj的List。
toXML(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
将指定的工作流导出成XML
toXML() - 类 com.trs.components.metadata.service.GovInfoToXML 中的静态方法
产生书对应的xml串
toXml(String) - 类 com.trs.components.wcm.epress.EPressConf 中的方法
toXML() - 类 com.trs.infra.util.Report 中的方法
toXML() - 类 com.trs.infra.util.Reports 中的方法
toXML(boolean) - 类 com.trs.infra.util.Reports 中的方法
toXML(SceneNode) - 类 com.trs.scene.tools.SceneNodeToXML 中的静态方法
toXMLDocument(File) - 类 com.trs.infra.config.domain.ConfigHelper 中的静态方法
将指定的xml文件流转化文档模型
toXMLDocument(String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
将XML文件解析成DOM结构，返回XML Document对象
toXMLDocument(String, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
将XML文件解析成DOM结构，返回XML Document对象
toXmlElement(BaseObjs, String) - 类 com.trs.components.metadata.center.xml.MetaViewDataToExcel 中的方法
为什么要重载这个方法？
toXmlElement(BaseObjs, String) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
toXmlElement(List, String) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
toXmlElement(BaseObj) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
toXMLElement(boolean) - 类 com.trs.infra.util.Report 中的方法
toXMLElement(String) - 类 com.trs.presentation.util.Parameters 中的方法
toXMLElement() - 类 com.trs.presentation.util.Parameters 中的方法
toXMLElment(String) - 类 com.trs.presentation.util.Parameter 中的方法
toXMLElment() - 类 com.trs.presentation.util.Parameter 中的方法
toXMLFile(Object, String) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
toXMLFile(Object, String, String) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
toXMLFile(Object, String, String, String) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
将对象输出为XML文件
toXMLFile(Element, String, String, String) - 类 com.trs.infra.util.CMyDOM4jHelper 中的静态方法
toXMLFile(Document, String, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
根据DOM 树生成XML文件
toXMLFile(Document, String, String, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
根据DOM 树生成XML文件
toXMLFile(String) - 类 com.trs.presentation.util.AppAutoParameters 中的方法
toXMLFile(String, String, String) - 类 com.trs.presentation.util.Parameters 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.ajaxservice.xmlconvertors.BaseWCMObjectToXML 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.ajaxservice.xmlconvertors.DataTypeToXML 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.ajaxservice.xmlconvertors.FlowContentsToXML 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.ajaxservice.xmlconvertors.ReportsToXML 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.components.metadata.service.xmlconvertors.ViewDataToXML 中的方法
toXMLString(Object) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
toXMLString(Object, String) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
toXMLString(Object, String, String) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
将对象输出为XML字串
toXmlString(MethodContext, Object) - 类 com.trs.webframework.xmlserver.convertors.BooleanXMLConvertorImpl 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl 中的方法
toXmlString(MethodContext, Object) - 类 com.trs.webframework.xmlserver.convertors.StringXMLConvertorImpl 中的方法
toXmlString(MethodContext, Object) - 接口 com.trs.webframework.xmlserver.IXMLConvertor 中的方法
将指定对象的所有属性转换为XML字符串
TR - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
transDisplay(String) - 类 com.trs.infra.util.CMyString 中的静态方法
用于在Html中显示文本内容
transDisplay(String, boolean) - 类 com.trs.infra.util.CMyString 中的静态方法
用于在Html中显示文本内容。
transDisplay_bbs(String, String) - 类 com.trs.infra.util.CMyString 中的静态方法
transDisplay_bbs(String, String, boolean) - 类 com.trs.infra.util.CMyString 中的静态方法
将指定文本内容，格式化为bbs风格的Html文本字符串。
transDisplayMark(String, char) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串的掩码显示：用指定的掩码构造与指定字符串相同长度的字符串 用于：密码显示等需要掩码处理的场合
transform(String, String, String) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法
transform(String, String, String, String) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法
TransformCoding(String) - 类 com.trs.infra.util.CMyTransformCoding 中的方法
转换汉字内码：GB <=>BIG5.输入字符串的内码自动识别
transformPathToClassPath(String) - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法
transformPathToClassPath(String) - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态方法
transformXML(String, String, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
根据XSL模板文件生成XML文件
transformXML(String, String, String, String) - 类 com.trs.infra.util.CMyXMLDoc 中的静态方法
根据XSL模板文件生成XML文件
transJsDisplay(String) - 类 com.trs.infra.util.CMyString 中的静态方法
javascript显示处理，用于处理javascript中的文本字符串显示
translateFields() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
由于视图字段的名称和元数据字段的名称可能不统一，在此方法中将视图字段的属性转化为元数据字段的属性, 在导入、复制视图数据的时候，可能需要用到这种功能
transmit(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
转发文档
transPrettyUrl(String, int) - 类 com.trs.infra.util.CMyString 中的静态方法
transPrettyUrl(String, int, String) - 类 com.trs.infra.util.CMyString 中的静态方法
TREE_OPERATION_DOCUMENT - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_DOCUMENT 树形结构操作类型：文档管理 1
TREE_OPERATION_GROUP_SEL - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_GROUP_SEL 树形结构操作类型：组织选择
TREE_OPERATION_GRPUSER_MGR - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_GRPUSER_MGR 树形结构操作类型：组织内用户管理 12
TREE_OPERATION_GRPUSER_SEL - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_GRPUSER_SEL 树形结构操作类型：组织内用户选择 11
TREE_OPERATION_GRPUSER_SEL_SPECIAL - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_GRPUSER_SEL_SPECIAL 树形结构操作类型：组织内用户选择 23
TREE_OPERATION_OTHER - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_OTHER 树形结构操作类型：其它 0
TREE_OPERATION_PORTAL - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_TEMPLATE 树形结构操作类型：门户导航 4
TREE_OPERATION_ROLEUSER_MGR - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_ROLEUSER_MGR 树形结构操作类型：组织内用户管理 14
TREE_OPERATION_ROLEUSER_SEL - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_ROLEUSER_SEL 树形结构操作类型：角色内用户选择 13
TREE_OPERATION_SITE - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_SITE 树形结构操作类型：站点管理 2
TREE_OPERATION_SYSUSER_MGR - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_SYSUSER_MGR 树形结构操作类型：系统所有用户管理 10
TREE_OPERATION_TEMPLATE - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_OPERATION_TEMPLATE 树形结构操作类型：模板管理 3
TREE_TYPE_CHECKBOX - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_TYPE_CHECKBOX 树形结构类型：多选[1]
TREE_TYPE_NORMAL - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_TYPE_NORMAL 栏目树类型：普通[0]
TREE_TYPE_RADIOBOX - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
Comment for TREE_TYPE_RADIOBOX 树形结构类型：单选[2]
TreeCreator - com.trs.presentation.nav 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
导航树的产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TreeCreator(User, RequestHelper, JspWriter) - 类 com.trs.presentation.nav.TreeCreator 的构造方法
TreeCreatorTest - com.trs.presentation.nav 中的 类
TreeCreatorTest() - 类 com.trs.presentation.nav.TreeCreatorTest 的构造方法
TreeItem - com.trs.presentation.navigation 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TreeItem(int, String, String, String, String, TreeItem, boolean) - 类 com.trs.presentation.navigation.TreeItem 的构造方法
TreeNode - com.trs.components.wcm.content.trsserver 中的 类
TreeNode(User, int[]) - 类 com.trs.components.wcm.content.trsserver.TreeNode 的构造方法
构造函数
TreeNode(User, String) - 类 com.trs.components.wcm.content.trsserver.TreeNode 的构造方法
TreeNode(Channel, int) - 类 com.trs.components.wcm.content.trsserver.TreeNode 的构造方法
TreeNodeCalctor - com.trs.presentation.nav 中的 类
TreeNodeCalctor(String, User) - 类 com.trs.presentation.nav.TreeNodeCalctor 的构造方法
TreeNodeCalctor(WebSite, Channels) - 类 com.trs.presentation.nav.TreeNodeCalctor 的构造方法
TreeNodeCalctor(int, int) - 类 com.trs.presentation.nav.TreeNodeCalctor 的构造方法
TRS_PAGE_SEPARATOR - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
page separator flag
TRSCKMServer - com.trs.components.ckm 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
智能信息处理服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSCKMServer() - 类 com.trs.components.ckm.TRSCKMServer 的构造方法
TRSClusterExtensionImpl - com.trs.cluster 中的 类
TRSClusterExtensionImpl(String) - 类 com.trs.cluster.TRSClusterExtensionImpl 的构造方法
TRSConfigServer - com.trs.infra.config 中的 类
TRSConfigServer() - 类 com.trs.infra.config.TRSConfigServer 的构造方法
TRSConnectionPool - com.trs.components.wcm.content.trsserver 中的 类
TRSConnectionPool() - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 的构造方法
TRSConnectionPool(String, String, String, String, int, int, boolean) - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 的构造方法
TRSDBSchema - com.trs.db.schema 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSDBSchema(int) - 类 com.trs.db.schema.TRSDBSchema 的构造方法
TRSDBSchemaTest - com.trs.db.schema 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSDBSchemaTest() - 类 com.trs.db.schema.TRSDBSchemaTest 的构造方法
TRSImportsOrgnize - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
JSP Import自动产生工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSImportsOrgnize() - 类 com.trs.infra.util.TRSImportsOrgnize 的构造方法
TRSJspAutoTool - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
应用层自动化工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSJspAutoTool(String, String, String, String, String) - 类 com.trs.infra.util.TRSJspAutoTool 的构造方法
TRSLocaleAuto - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSLocaleAuto() - 类 com.trs.infra.util.TRSLocaleAuto 的构造方法
TRSMailer - com.trs.infra.util.email 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模拟邮件客户端工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSMailer() - 类 com.trs.infra.util.email.TRSMailer 的构造方法
TRSPageParameter - com.trs.webframework.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSPageParameter() - 类 com.trs.webframework.config.TRSPageParameter 的构造方法
TRSParameter - com.trs.webframework.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
TRSParameter() - 类 com.trs.webframework.config.TRSParameter 的构造方法
trsQuery(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
trsSaveToWCM(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
TRSSearcher - com.trs.components.wcm.content.trsserver 中的 类
默认的检索条件，基于TRS数据库 创建时间：2006-12-27 14:57:49
TRSSearcherFactory - com.trs.components.wcm.content.trsserver 中的 类
TRS检索条件Searcher构造的工厂类 创建时间：2006-12-27 14:57:29
TRSSearcherFactory() - 类 com.trs.components.wcm.content.trsserver.TRSSearcherFactory 的构造方法
TRSSearchUtil - com.trs.components.wcm.content.trsserver 中的 类
类说明 创建时间：2006-12-12 13:54:50
TRSSearchUtil() - 类 com.trs.components.wcm.content.trsserver.TRSSearchUtil 的构造方法
TRSTemplateFacade - com.trs.template 中的 类
TRSTemplateFacade() - 类 com.trs.template.TRSTemplateFacade 的构造方法
构造函数
TRSToWCMFilter - com.trs.components.wcm.content.trsserver 中的 类
Created by IntelliJ IDEA.
TRSToWCMFilter(int) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 的构造方法
TRSToWCMFilter() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 的构造方法
TRSWCMClusterServer - com.trs.cluster 中的 类
TRSWCMClusterServer() - 类 com.trs.cluster.TRSWCMClusterServer 的构造方法
truncateStr(String, int) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串截断函数：取指定字符串前部指定长度的字符串； 说明：英文和数字字符长度记1；中文字符长度记2。
truncateStr(String, int, String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串截断函数：取指定字符串前部指定长度的字符串； 说明：英文和数字字符长度记1；中文字符长度记2。
truncateTextIfNeeded(TagItem, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
已过时。 Truncates the text length if needed (when NUM>0).
Related properties in tag item: NUM, TRUNCATEDFLAG
if NUM>0, to truncate the text with the flag as tail.
truncateTextIfNeeded(PublishTagContext, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Truncates the text length if needed (when NUM>0).
TrusteeInfo - com.trs.cms.auth.persistent 中的 类
TrusteeInfo() - 类 com.trs.cms.auth.persistent.TrusteeInfo 的构造方法
构造函数：保留默认接口
TrusteeInfos - com.trs.cms.auth.persistent 中的 类
TrusteeInfos(User) - 类 com.trs.cms.auth.persistent.TrusteeInfos 的构造方法
构造函数
TrusteeInfos(User, int, int) - 类 com.trs.cms.auth.persistent.TrusteeInfos 的构造方法
构造函数
TRY_INTERVAL - 类 com.trs.infra.util.HttpGet 中的静态变量
重试间隔时间，单位：毫秒
TT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
TxtFileParser - com.trs.components.wcm.channel 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
普通文本解释
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
TxtFileParser() - 类 com.trs.components.wcm.channel.TxtFileParser 的构造方法
TxtFileParserForContentLink - com.trs.components.wcm.contentlink 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
TxtFileParserForContentLink() - 类 com.trs.components.wcm.contentlink.TxtFileParserForContentLink 的构造方法
TYPE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
type - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
列类型值:java.sql.Types
TYPE_1DAY - 类 com.trs.components.stat.HitsCountConstant 中的静态变量
TYPE_1MONTH - 类 com.trs.components.stat.HitsCountConstant 中的静态变量
TYPE_1YEAR - 类 com.trs.components.stat.HitsCountConstant 中的静态变量
TYPE_3MONTH - 类 com.trs.components.stat.HitsCountConstant 中的静态变量
TYPE_ADD - 类 com.trs.db.update.DBUpdateLog 中的静态变量
TYPE_ADVERTISEMENT - 类 com.trs.components.common.conjection.ComponentEntryConfigConstants 中的静态变量
TYPE_ALL - 类 com.trs.components.stat.HitsCountConstant 中的静态变量
TYPE_ALL - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的静态变量
TYPE_BOOLEAN - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_BOOLEAN 布尔型
TYPE_BOOLEAN_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_BOOLEAN 布尔型
TYPE_BOOLEAN_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_BOOLEAN 布尔型
TYPE_CLUSTER_META - 类 com.trs.infra.support.config.Config 中的静态变量
配置信息类别：集群相关配置
TYPE_CODE_END - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
TYPE_CODE_END - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
TYPE_CODE_START - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
TYPE_CODE_START - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
TYPE_COLDEL - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的静态变量
删除的列的标识
TYPE_COLNEW - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的静态变量
新添加列的标识
TYPE_COLUPD - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的静态变量
更新的列的标识
TYPE_COMMENT - 类 com.trs.components.common.conjection.ComponentEntryConfigConstants 中的静态变量
TYPE_COMMENT - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
TYPE_COMMENT - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
TYPE_CUSTOM_ADD - 类 com.trs.infra.support.config.Config 中的静态变量
配置信息类别：用户新增的配置(非系统自带的配置)
TYPE_DATA_FIELD - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的静态变量
TYPE_DATA_SECTION - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的静态变量
TYPE_DATE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_DATE 日期型
TYPE_DATE_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_DATE 日期型
TYPE_DATE_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_DATE 日期型
TYPE_DATETIME - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_DATETIME 日期时间型
TYPE_DATETIME_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_DATETIME 日期时间型
TYPE_DATETIME_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_DATETIME 日期时间型
TYPE_DEBUG - 类 com.trs.infra.util.Report 中的静态变量
TYPE_DEFAULT - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量
TYPE_DEFINE_MAX - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道类型：用户自定义类型的起始值(20)
TYPE_DOUBLE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_DOUBLE 双精度
TYPE_DOUBLE_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_DOUBLE 双精度
TYPE_DOUBLE_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_DOUBLE 双精度
TYPE_ERROR - 类 com.trs.infra.util.Report 中的静态变量
TYPE_FILE - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
文档类型：外部文件
TYPE_FILE_PATH - 类 com.trs.infra.support.config.Config 中的静态变量
配置信息类别：文件目录配置
TYPE_FLOAT - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_FLOAT 浮点型
TYPE_FLOAT_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_FLOAT 浮点型
TYPE_FLOAT_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_FLOAT 浮点型
TYPE_FLOW_EVENT - 类 com.trs.components.common.calendar.EventType 中的静态变量
TYPE_FLOW_MSG - 类 com.trs.components.common.message.MsgQueue 中的静态变量
TYPE_HTML - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
文档类型：HTML文档
TYPE_HTML_VALUE - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
TYPE_HTML_VALUE - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
TYPE_INCLUDE - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
TYPE_INCLUDE - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
TYPE_INFO - 类 com.trs.infra.util.Report 中的静态变量
TYPE_INFOGATE - 类 com.trs.components.common.conjection.ComponentEntryConfigConstants 中的静态变量
TYPE_INFOVIEW - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道类型:TRS自定义表单
TYPE_INT - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_INT 整型
TYPE_INT_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_INT 整型
TYPE_INT_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_INT 整型
TYPE_INTERVIEW - 类 com.trs.components.common.conjection.ComponentEntryConfigConstants 中的静态变量
TYPE_ITEM - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
TYPE_JOB_SERVER - 类 com.trs.infra.support.config.Config 中的静态变量
配置信息类别：Job Server中的Worker配置
TYPE_JS - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量
TYPE_LINE - 类 com.trs.scene.tools.SceneNode 中的静态变量
TYPE_LINK - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道类型:链接型频道(3)
TYPE_LINK - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
文档类型：链接文档
TYPE_LONG - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_LONG 长整型
TYPE_LONG_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_LONG 长整型
TYPE_LONG_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_LONG 长整型
TYPE_NOFLAG - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
TYPE_NOFLAG - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
TYPE_NORM - 类 com.trs.components.common.message.Message 中的静态变量
TYPE_NORM - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道类型：一般频道(0)
TYPE_NORM - 类 com.trs.infra.support.config.Config 中的静态变量
配置信息类别：系统配置
TYPE_NORM - 类 com.trs.scene.tools.SceneNode 中的静态变量
TYPE_NORMAL - 类 com.trs.cms.auth.persistent.Role 中的静态变量
TYPE_NORMAL - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
文档类型：纯文本
TYPE_NORMAL_MSG - 类 com.trs.components.common.message.MsgQueue 中的静态变量
Msg类型，暂时为俩种 一般和工作流
TYPE_OPTION - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
TYPE_PAGE_START - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
TYPE_PAGE_START - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
TYPE_POLL - 类 com.trs.components.common.conjection.ComponentEntryConfigConstants 中的静态变量
TYPE_PUBLISH - 类 com.trs.components.common.message.Message 中的静态变量
TYPE_QUOTE_FILE - 类 com.trs.wcm.photo.ImageLibConstants 中的静态变量
引用文件
TYPE_QUOTE_NONE - 类 com.trs.wcm.photo.ImageLibConstants 中的静态变量
没有引用任何图片库的图片
TYPE_QUOTE_URL - 类 com.trs.wcm.photo.ImageLibConstants 中的静态变量
直接引用地址
TYPE_RECEIVE_LOG - 类 com.trs.infra.util.email.CMyMailLog 中的静态变量
接收日志类型
TYPE_SCHEDULE_SERVER - 类 com.trs.infra.support.config.Config 中的静态变量
配置信息类别：Schedule Server中的Worker配置
TYPE_SEND_LOG - 类 com.trs.infra.util.email.CMyMailLog 中的静态变量
发送日志类型
TYPE_SITE - 类 com.trs.cms.auth.persistent.Role 中的静态变量
目前已经废弃
TYPE_SPECIAL - 类 com.trs.cms.auth.persistent.Role 中的静态变量
TYPE_SPECIAL这个名字更能表达实际涵义，但为了兼容，所以让其等于TYPE_NORMAL
TYPE_START - 类 com.trs.scene.tools.SceneNode 中的静态变量
开始节点
TYPE_STRING - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_STRING 字符型
TYPE_STRING_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_STRING 字符型
TYPE_STRING_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_STRING 字符型
TYPE_SUBSCRIBE - 类 com.trs.components.common.conjection.ComponentEntryConfigConstants 中的静态变量
TYPE_SUREFORM - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道类型:链接型频道(3)
TYPE_SYSTEM - 类 com.trs.cms.auth.persistent.Role 中的静态变量
TYPE_TEXT - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量
TYPE_TIME - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_TIME 时间型
TYPE_TIME_HASHCODE - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPE_TIME 时间型
TYPE_TIME_HASHCODE - 类 com.trs.presentation.util.WhereSQLMaker 中的静态变量
Comment for TYPE_TIME 时间型
TYPE_TOP_NEWS - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道类型：头条新闻(2)
TYPE_TOP_PICS - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道类型：图片新闻(1)
TYPE_UNKNOWN - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
文档类型：未知
TYPE_UPDATE - 类 com.trs.db.update.DBUpdateLog 中的静态变量
TYPE_WARN - 类 com.trs.infra.util.Report 中的静态变量
TYPE_WARNING - 类 com.trs.components.common.message.MsgQueue 中的静态变量
TYPE_WORKFLOW - 类 com.trs.components.common.message.Message 中的静态变量
TYPE_XML - 类 com.trs.components.comment.domain.NewsComment.CommentEmitEnum 中的静态变量
TypeInfo - com.trs.infra.util.upgrade.dbcompare 中的 类
TypeInfo() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 的构造方法
TypeInfoMap - com.trs.infra.util.upgrade.dbcompare 中的 类
类型映射.
TypeInfoMap() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfoMap 的构造方法
typeName - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
列类型名
TypeNames - com.trs.infra.util.database 中的 类
This class maps a type to names.
TypeNames() - 类 com.trs.infra.util.database.TypeNames 的构造方法
TYPES_SUPPORTED - 类 com.trs.presentation.util.PageParameter 中的静态变量
Comment for TYPES_SUPPORTED
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


U - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

U

U - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
UftpConnectionCacheManager - com.trs.components.common.publish.domain.distribute 中的 类
集中管理FTP协议和FTP类似协议连接的缓冲池
UftpConnectionCacheManager() - 类 com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager 的构造方法
缺省构造方法
UL - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
unfilterForHTMLValue(String) - 类 com.trs.infra.util.CMyString 中的静态方法
将_sContent做filterForHTMLValue的逆处理
UNIQUEIDENTIFIER - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：UNIQUEIDENTIFIER
UNIQUEIDENTIFIER - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：UNIQUEIDENTIFIER
UNIQUEIDENTIFIER - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：UNIQUEIDENTIFIER
UNIQUEIDENTIFIER - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：UNIQUEIDENTIFIER
UNKNOWN_OPERTYPE_ID - 类 com.trs.infra.support.log.OperType 中的静态变量
UNKOWN - 类 com.trs.infra.util.database.DBTypes 中的静态变量
定义数据库类型：未知
unload() - 类 com.trs.infra.config.domain.BeanConfigHelper 中的方法
回收
unlock() - 类 com.trs.cms.content.ClusterLocker 中的方法
unlock() - 类 com.trs.cms.content.CMSObj 中的方法
给对象解锁
unlock() - 类 com.trs.cms.content.Locker 中的方法
强制解锁
unlock(int, int, User) - 类 com.trs.cms.content.WCMObjHelper 中的静态方法
指定的用户给指定的对象解锁
unzip(String, boolean) - 类 com.trs.infra.util.CMyUnzip 中的方法
解压缩操作
unzip(String, String, boolean) - 类 com.trs.infra.util.CMyUnzip 中的静态方法
将指定的压缩文件解压缩到指定目录
update(User) - 类 com.trs.cms.auth.persistent.User 中的方法
update(User) - 类 com.trs.cms.content.CMSObj 中的方法
更新修改。
update(User) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
重载父类的update函数，实现下一个节点修改的同步
update(User) - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
update(User) - 类 com.trs.components.common.calendar.Event 中的方法
重载父类接口，以处理提醒Job
update(String[]) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
update(User) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
update() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
update(User) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
update(User) - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
update(User) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
update() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
update(User) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
重载父对象的update，执行缓冲区的更新操作
update() - 类 com.trs.infra.persistent.BaseObj 中的方法
更新修改。
update() - 类 com.trs.infra.persistent.BaseObjs 中的方法
更新集合中当前的对象
update() - 类 com.trs.infra.support.config.Config 中的方法
update() - 类 com.trs.infra.support.log.LogBak 中的方法
update() - 类 com.trs.infra.support.security.SecureKey 中的方法
update(int) - 类 com.trs.infra.util.jazzlib.Adler32 中的方法
Updates the checksum with the byte b.
update(byte[]) - 类 com.trs.infra.util.jazzlib.Adler32 中的方法
Updates the checksum with the bytes taken from the array.
update(byte[], int, int) - 类 com.trs.infra.util.jazzlib.Adler32 中的方法
Updates the checksum with the bytes taken from the array.
update(int) - 接口 com.trs.infra.util.jazzlib.Checksum 中的方法
Adds one byte to the data checksum.
update(byte[], int, int) - 接口 com.trs.infra.util.jazzlib.Checksum 中的方法
Adds the byte array to the data checksum.
update(int) - 类 com.trs.infra.util.jazzlib.CRC32 中的方法
Updates the checksum with the int bval.
update(byte[], int, int) - 类 com.trs.infra.util.jazzlib.CRC32 中的方法
Adds the byte array to the data checksum.
update(byte[]) - 类 com.trs.infra.util.jazzlib.CRC32 中的方法
Adds the complete byte array to the data checksum.
update() - 类 com.trs.infra.util.job.JobFailedResult 中的方法
update(IObserverable) - 类 com.trs.webframework.xmlserver.server.InvocationObserver 中的方法
update(IObserverable, Object) - 类 com.trs.webframework.xmlserver.server.InvocationObserver 中的方法
update(IObserverable) - 接口 com.trs.webframework.xmlserver.server.IObserver 中的方法
update(IObserverable, Object) - 接口 com.trs.webframework.xmlserver.server.IObserver 中的方法
UPDATE_FROM_DB - 类 com.trs.components.wcm.content.ContentUpdateCommanderImpl 中的静态变量
updateAdManageService() - 类 com.trs.components.common.conjection.service.AdmanageConfigServiceImpl 中的方法
updateAdManageService() - 接口 com.trs.components.common.conjection.service.IAdmanageConfigService 中的方法
updateAppendixStatus() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
设置模板Text属性（Html文本格式）
UpdateCommanderConfig - com.trs.infra.update 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commander
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
UpdateCommanderConfig() - 类 com.trs.infra.update.UpdateCommanderConfig 的构造方法
updateConfigValue(String, String) - 类 com.trs.infra.support.config.ConfigServer 中的方法
更新系统的配置信息
updateDemoDataWidgetParamtersAndRegion() - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法
updateDocKeywords(Document, String, String) - 类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 中的方法
updateDocKeywords(Document, String, String) - 接口 com.trs.components.wcm.content.domain.IDocKeywordMgr 中的方法
更新指定文档的相关文档记录信息
updateDocument() - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
更新document内容
updateFile(String, byte[]) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
updateFile(String, File) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
上传文件，获取返回对象
updateGroup(SSOGroup, HttpServletRequest) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
更新组织
updateHitsCount(User) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
需要改变频道的名称，故重载toXMLElement接口
updateInstance(IXmlPersistentObject, String, String) - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的方法
update the persistent object
updateInstance(IXmlPersistentObject, String) - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的方法
updateMediaRemindedCache(MediaRemindedInfo) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
更新媒体提醒信息的缓冲
updateNestedTemplateName(Templates, String, String) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
updateOperationMark(FlowContext) - 类 com.trs.cms.process.FlowingDocOptMarkScouter 中的静态方法
updateOperationMark(FlowContext, String) - 类 com.trs.cms.process.FlowingDocOptMarkScouter 中的静态方法
updatePreOperationMark(FlowContext, String) - 类 com.trs.cms.process.FlowingDocOptMarkScouter 中的静态方法
UpdateServer - com.trs.infra.update 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Server
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
UpdateServer() - 类 com.trs.infra.update.UpdateServer 的构造方法
updateSimIndex(Document) - 接口 com.trs.components.ckm.ICKMServer 中的方法
updateSimIndex(int, String) - 接口 com.trs.components.ckm.ICKMServer 中的方法
updateSimIndex(Document) - 类 com.trs.components.ckm.TRSCKMServer 中的方法
updateSimIndex(int, String) - 类 com.trs.components.ckm.TRSCKMServer 中的方法
UpdateSQLGenerator - com.trs.db.update 中的 类
自动生成SQL更新脚本的工具.
UpdateSQLGenerator() - 类 com.trs.db.update.UpdateSQLGenerator 的构造方法
updateStatus(MethodContext) - 类 com.trs.ajaxservice.DistributeServiceProvider 中的方法
启用/关闭 分发服务
updateStatus(User, int) - 接口 com.trs.cms.process.IFlowContent 中的方法
更新当前内容的工作流状态
updateStatus(User, int) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
updateStatus(User, int) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
updateStatusAll(MethodContext) - 类 com.trs.ajaxservice.DistributeServiceProvider 中的方法
启用/关闭 所有分发服务
updateToDB(Connection, String, String, String, String) - 类 com.trs.infra.util.database.CDBText 中的方法
将Clob/Text型字段值写入数据库
updateUser(SSOUser, HttpServletRequest) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
updateVisitUrl(String) - 类 com.trs.wcmonline.WCMOnlineService 中的方法
UpdSqlMaker - com.trs.infra.util.upgrade.sql 中的 类
UpdSqlMaker() - 类 com.trs.infra.util.upgrade.sql.UpdSqlMaker 的构造方法
UpdUserScheduleCreator - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
UpdUserScheduleCreator() - 类 com.trs.cms.auth.domain.UpdUserScheduleCreator 的构造方法
UpgradeObjectMember4SiteMember - com.trs.upgrade 中的 类
UpgradeObjectMember4SiteMember() - 类 com.trs.upgrade.UpgradeObjectMember4SiteMember 的构造方法
upload(String, String) - 类 com.trs.infra.util.ftp.FtpMgr 中的方法
upload(String, String) - 接口 com.trs.infra.util.ftp.IFtpMgr 中的方法
Uploads a local file to the ftp server.
UPLOAD_FILE - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue 中的静态变量
分发文件
UPLOAD_RETRY_TIMES - 类 com.trs.infra.util.ftp.CMyFtp 中的静态变量
uploadAppendixes(Template, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
Uploads the appendixes of the specified template.
uploadDirectory(String, String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
上传指定目录下的所有文件到FTP服务器的指定目录
uploadFile(String, String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
上传指定的本地文件到FTP服务器 首先检查FTP链接是否正常，如果已经断开则自动重新链接一次。
uploadFile(String, String) - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
上传文件到远程服务器
uploadFile(String, String) - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的方法
uploadFile(String, String) - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的方法
uploadFile(byte[], String, boolean) - 类 com.trs.service.impl.SOAPServiceImpl 中的方法
uploadFile(byte[], String, boolean) - 接口 com.trs.service.ISOAPService 中的方法
上传指定的文件
uploadImg(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
URLCoder - com.trs.infra.util 中的 类
URL的编码和解码 是从“com.trs.util.net”中移植过来的一个类，因为目前还不太方便直接使用“com.trs.util.net” 中的工具类。
URLEncode(String) - 类 com.trs.infra.util.CMyString 中的静态方法
处理Get方式的字符串
URLParser - com.trs.components.stat 中的 类
URLParser() - 类 com.trs.components.stat.URLParser 的构造方法
USEMAP - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
useNull - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
User - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
User() - 类 com.trs.cms.auth.persistent.User 的构造方法
构造函数：保留默认接口
USER_DEFAULT_PASSWORD - 类 com.trs.cms.auth.domain.UserMgr 中的静态变量
USER_DEL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除用户的权限
USER_DROPED_NAME_FLAG - 类 com.trs.cms.auth.persistent.User 中的静态变量
USER_SAVE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
保存用户的权限
USER_STATUS_ALL - 类 com.trs.cms.auth.persistent.User 中的静态变量
用户状态: 所有定义的用户状态(新用户、已删除、停用、正常等)
USER_STATUS_APPLY - 类 com.trs.cms.auth.persistent.User 中的静态变量
用户状态：正在申请（新用户）
USER_STATUS_DEL - 类 com.trs.cms.auth.persistent.User 中的静态变量
用户状态：已经删除（用户已删除）
USER_STATUS_DROPED - 类 com.trs.cms.auth.persistent.User 中的静态变量
USER_STATUS_FORBID - 类 com.trs.cms.auth.persistent.User 中的静态变量
用户状态：禁止使用（用户停用）
USER_STATUS_REG - 类 com.trs.cms.auth.persistent.User 中的静态变量
用户状态：已经注册（正常状态）
UserCacheMgr - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户名缓冲器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
UserCacheMgr() - 类 com.trs.cms.auth.persistent.UserCacheMgr 的构造方法
UserDocumentMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
UserDocumentMgr() - 类 com.trs.components.wcm.content.domain.UserDocumentMgr 的构造方法
userExist(SSOUser) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
UserInfoSyncUpdater - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
UserInfoSyncUpdater() - 类 com.trs.cms.auth.domain.UserInfoSyncUpdater 的构造方法
UserLCListenerForLogin - com.trs.presentation.login 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
UserLCListenerForLogin() - 类 com.trs.presentation.login.UserLCListenerForLogin 的构造方法
UserLicenseMgr - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
License protected validator
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
UserLicenseMgr() - 类 com.trs.cms.auth.persistent.UserLicenseMgr 的构造方法
UserListenerForRecordLogin - com.trs.km.auth 中的 类
UserListenerForRecordLogin() - 类 com.trs.km.auth.UserListenerForRecordLogin 的构造方法
UserLoginInfo - com.trs.components.stat 中的 类
UserLoginInfo() - 类 com.trs.components.stat.UserLoginInfo 的构造方法
构造函数：保留默认接口
UserLoginInfoMgr - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户登录信息的业务逻辑处理类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
UserLoginInfoMgr() - 类 com.trs.components.stat.UserLoginInfoMgr 的构造方法
UserLoginInfos - com.trs.components.stat 中的 类
UserLoginInfos(User) - 类 com.trs.components.stat.UserLoginInfos 的构造方法
构造函数
UserLoginInfos(User, int, int) - 类 com.trs.components.stat.UserLoginInfos 的构造方法
构造函数
UserLoginInfoServiceProvider - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户登录信息的服务层类
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
UserLoginInfoServiceProvider() - 类 com.trs.components.stat.UserLoginInfoServiceProvider 的构造方法
UserMgr - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
UserMgr() - 类 com.trs.cms.auth.domain.UserMgr 的构造方法
UserRelateInfoMaker - com.trs.components.metadata.service 中的 类
UserRelateInfoMaker() - 类 com.trs.components.metadata.service.UserRelateInfoMaker 的构造方法
Users - com.trs.cms.auth.persistent 中的 类
Users(User) - 类 com.trs.cms.auth.persistent.Users 的构造方法
构造函数
Users(User, int, int) - 类 com.trs.cms.auth.persistent.Users 的构造方法
构造函数
UserService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
UserService() - 类 com.trs.service.impl.UserService 的构造方法
UserServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
UserServiceProvider() - 类 com.trs.ajaxservice.UserServiceProvider 的构造方法
UserSetting - com.trs.components.wcm.customize 中的 类
UserSetting() - 类 com.trs.components.wcm.customize.UserSetting 的构造方法
UserSettings - com.trs.components.wcm.customize 中的 类
UserSettings(User) - 类 com.trs.components.wcm.customize.UserSettings 的构造方法
UserSettings(User, int, int) - 类 com.trs.components.wcm.customize.UserSettings 的构造方法
UserUtil - com.trs.components.wcm.wcmx.jsp 中的 类
UserUtil(User) - 类 com.trs.components.wcm.wcmx.jsp.UserUtil 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


V - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

V

validate() - 类 com.trs.cms.process.engine.FlowContext 中的方法
校验上下文参数是否有效
validate() - 类 com.trs.cms.process.engine.FlowParamers 中的方法
validate(Layout) - 接口 com.trs.components.common.publish.widget.ILayoutMgr 中的方法
验证布局的各属性是否符合规范，包括布局比例值和布局的HTML代码 注：布局HTML代码的验证斩不实现，为用户提交HTML内容代码提供验证功能
validate(Layout) - 类 com.trs.components.common.publish.widget.LayoutMgr 中的方法
验证布局属性信息，包括比例和HTML内容
validate() - 类 com.trs.components.wcm.content.MySite 中的方法
validate() - 类 com.trs.components.wcm.MyDB 中的方法
validate() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
validate() - 类 com.trs.infra.persistent.db.MyDate 中的方法
validate() - 类 com.trs.infra.util.email.CMyEmail 中的方法
验证邮件是否合法
validate() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法
判断当前配置的服务器参数是否正确
只判断参数，不进行实际的服务器尝试
validate() - 接口 com.trs.license.License 中的方法
校验注册码是否有效，如果有效，返回null字符串； 如果无效，返回无效信息
validateCanDoPreview() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
断言发布元素是否可以预览，如果不可以预览，则必须抛出异常，可以预览，则什么都不作。
validateCanDoPreview() - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法
validateCanDoPreview() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
validateCanDoPreview() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法
validateCanDoPreview() - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法
validateCanDoPreview() - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法
validateCanDoPreview() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
validateCanDoPreview() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
validateCanDoPreview() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
validateCanDoPreview() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
validateCanDoPreview() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
validateCanDoPub() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
Returns true if the folder is can be published.
validateCanDoPub() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
validateCanDoPub() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
validateCanDoPub() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
validateCanDoPub() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
validateCanDoPub() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
validateCanDoPub() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
validateCanDoPub() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
validateCanDoSetRight(User) - 接口 com.trs.cms.auth.domain.IRightHost 中的方法
判断指定的用户是否有权给当前对象设置权限
validateCanDoSetRight(User) - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法
validateCanDoSetRight(User) - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法
validateCanDoSetRight(User) - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法
validateCanDoSetRight(User) - 类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 中的方法
validateCanDoSetRight(User) - 类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 中的方法
validateCanDoSetRight(User) - 类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 中的方法
validateCKMServer(String, String, String, String) - 接口 com.trs.components.ckm.ICKMServer 中的方法
校验CKM Service是否有效
validateCKMServer() - 接口 com.trs.components.ckm.ICKMServer 中的方法
校验系统配置的CKMServer是否有效
validateCKMServer(String, String, String, String) - 类 com.trs.components.ckm.TRSCKMServer 中的方法
validateCKMServer() - 类 com.trs.components.ckm.TRSCKMServer 中的方法
validateElement(int, int) - 类 com.trs.components.common.publish.domain.PublishServer 中的静态方法
校验指定的发布对象是否有效
validateElement(IPublishElement) - 类 com.trs.components.common.publish.domain.PublishServer 中的静态方法
校验指定的发布对象是否有效
validateFile(String) - 类 com.trs.ajaxservice.WCMAJAXServiceHelper 中的静态方法
validateHtml(Layout) - 接口 com.trs.components.common.publish.widget.ILayoutGenerator 中的方法
对用户上传的HTML代码进行验证，查看是否符合相关规范，如果不允许用户上传，可以直接返回true
validateHtml(Layout) - 类 com.trs.components.common.publish.widget.LayoutGenerator 中的方法
验证布局的HTML内容是否符合规范 （扩展用，暂不实现）
validateMasterFile(String) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
校验母版文件的合法性
validateMasterFile(MethodContext) - 接口 com.trs.components.common.publish.widget.IMasterServiceProvider 中的方法
校验母版文件的合法性
validateMasterFile(String) - 接口 com.trs.components.common.publish.widget.IMasterServiceProvider 中的方法
校验母版文件的合法性
validateMasterFile(String) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
校验母版文件的合法性
validateMasterFile(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
校验母板文件的合法性
validateMasterFile(String) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
校验母板文件的合法性
validateProvider(int, IServiceProvider) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法
validateRatio(Layout) - 类 com.trs.components.common.publish.widget.LayoutMgr 中的方法
验证布局比例是否符合规范(包括比例类型和比例值)
validateSiteLicense() - 类 com.trs.components.wcm.content.persistent.SiteLicenseMgr 中的方法
validateUserLicense() - 类 com.trs.cms.auth.persistent.UserLicenseMgr 中的方法
validateWorkFlowRight(User, BaseObj, int, int, String) - 类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 中的静态方法
validateWorkFlowRight(User, BaseObj, int, int, String) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法
validCanDeleteAndLock(User) - 类 com.trs.cms.content.CMSObj 中的方法
validCanEditAndLock(User, int) - 类 com.trs.cms.content.CMSObj 中的方法
validCanEditAndLock(User) - 类 com.trs.cms.content.CMSObj 中的方法
validEditModeChannel(Channel) - 类 com.trs.components.wcm.content.persistent.ChannelLoopValidator 中的方法
validHasExistsChannel(Channel) - 类 com.trs.components.wcm.content.persistent.ChannelLoopValidator 中的方法
validLoop() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
validParameterValue(PageParameter, String) - 接口 com.trs.presentation.valid.IValidator 中的方法
validWCMObjClass(String) - 类 com.trs.presentation.util.AppAutoParameter 中的静态方法
VALIGN - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
VALUE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
VALUE_ADMINISTRATOR - 类 com.trs.cms.auth.persistent.RightValue 中的静态变量
VALUE_ONLY_BROWSER - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
仅仅只是设置了浏览的权限
valueBound(HttpSessionBindingEvent) - 类 com.trs.presentation.login.SessionListener 中的方法
ValueConfig - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
操作配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ValueConfig() - 类 com.trs.cms.process.config.ValueConfig 的构造方法
VALUETYPE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
valueUnbound(HttpSessionBindingEvent) - 类 com.trs.presentation.login.SessionListener 中的方法
VAR - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
VARBINARY - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
VARBINARY - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：VARBINARY
VARBINARY - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：VARBINARY
VARBINARY - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：VARBINARY
VARCHAR - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：VARCHAR
VARCHAR - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：VARCHAR
VARCHAR - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：VARCHAR
VARCHAR - 类 com.trs.infra.util.database.KingBaseDB 中的静态变量
定义SQL Server中的字段类型：VARCHAR
VARCHAR - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
VARCHAR - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：VARCHAR
VARCHAR - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：VARCHAR
VARCHAR - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：VARCHAR
VARCHAR2 - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：VARCHAR2
VARCHAR2 - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
VARNAME_CONTENTTITLE - 类 com.trs.cms.process.ProcessConstants 中的静态变量
内容标题
VARNAME_CURRDATETIME - 类 com.trs.cms.process.ProcessConstants 中的静态变量
当前时间
VARNAME_RECEIVERNAME - 类 com.trs.cms.process.ProcessConstants 中的静态变量
接受人名称
VARNAME_SENDERNAME - 类 com.trs.cms.process.ProcessConstants 中的静态变量
发送者名称
VChannel - com.trs.components.wcm.channel 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
批量创建栏目,虚拟的栏目对象
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
VChannel() - 类 com.trs.components.wcm.channel.VChannel 的构造方法
VChannelManager - com.trs.components.wcm.channel 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
批量创建栏目
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
VChannelManager() - 类 com.trs.components.wcm.channel.VChannelManager 的构造方法
verify(byte[], int) - 类 com.trs.components.comment.domain.SignUtil 中的方法
此处插入方法说明。
verify(String, byte[], byte[]) - 类 com.trs.infra.support.security.SecureKeyMgr 中的方法
使用指定名称的密钥，验证指定数据和签名是否相符
verify(byte[], int) - 类 com.trs.infra.util.CMySign 中的方法
此处插入方法说明。
verify(String, byte[], byte[]) - 类 com.trs.service.impl.SecurityService 中的方法
verify(String, byte[], byte[]) - 接口 com.trs.service.ISecurityService 中的方法
使用指定名称的密钥，验证指定数据和签名是否相符
VerifyCode - com.trs.weblet.util.verfiycode 中的 类
生成用于验证的BMP图片。
VerifyCode(String, int) - 类 com.trs.weblet.util.verfiycode.VerifyCode 的构造方法
缺省构造方法
VerifyCodeServlet - com.trs.weblet.util.verfiycode 中的 类
用于以图片的形式显示验证码。
VerifyCodeServlet() - 类 com.trs.weblet.util.verfiycode.VerifyCodeServlet 的构造方法
缺省构造方法
verifyConfig(FtpConfig, String[]) - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的静态方法
测试指定的FTP配置是否可用，测试的项目包括：连接、登录、建立临时目录、建立数据通道四项。
VERSION - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
VIDEO_SITE - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
View - com.trs.components.infoview.extract.manifest 中的 类
/xsf:xDocumentClass/xsf:views/xsf:view
View() - 类 com.trs.components.infoview.extract.manifest.View 的构造方法
VIEW_TYPE_ALL - 类 com.trs.components.wcm.stat.StatView 中的静态变量
VIEW_TYPE_CHECKBOX - 类 com.trs.presentation.nav.TreeCreator 中的静态变量
VIEW_TYPE_FIELD - 类 com.trs.components.wcm.stat.StatView 中的静态变量
统计视图——字段类，即可以被模板类嵌套，但是不能进行最终显示
VIEW_TYPE_MAX - 类 com.trs.components.wcm.stat.StatView 中的静态变量
最大的有效统计视图类型
VIEW_TYPE_MIN - 类 com.trs.components.wcm.stat.StatView 中的静态变量
最小的有效统计视图类型
VIEW_TYPE_NORMAL - 类 com.trs.presentation.nav.TreeCreator 中的静态变量
VIEW_TYPE_QUERY - 类 com.trs.components.wcm.stat.StatView 中的静态变量
统计视图——即时查询类，即可以直接生成统计结果，不通过临时表
VIEW_TYPE_RADIO - 类 com.trs.presentation.nav.TreeCreator 中的静态变量
VIEW_TYPE_TEMPLATE - 类 com.trs.components.wcm.stat.StatView 中的静态变量
统计视图——模板类，即可以进行嵌套和最终显示
ViewDataToXML - com.trs.components.metadata.service.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ViewData的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDataToXML() - 类 com.trs.components.metadata.service.xmlconvertors.ViewDataToXML 的构造方法
ViewDocument - com.trs.components.wcm.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档元素对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocument(HashMap) - 类 com.trs.components.wcm.content.ViewDocument 的构造方法
ViewDocumentListenerForPubGovInfo - com.trs.components.metadata.service.listener 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocumentListenerForPubGovInfo() - 类 com.trs.components.metadata.service.listener.ViewDocumentListenerForPubGovInfo 的构造方法
ViewDocuments - com.trs.components.wcm.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
视图文档集合对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocuments(User) - 类 com.trs.components.wcm.content.ViewDocuments 的构造方法
ViewDocuments(User, int, int) - 类 com.trs.components.wcm.content.ViewDocuments 的构造方法
ViewDocumentServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocumentServiceProvider() - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 的构造方法
ViewDocumentToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ViewDocument的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ViewDocumentToXML() - 类 com.trs.ajaxservice.xmlconvertors.ViewDocumentToXML 的构造方法
ViewFieldTemplate - com.trs.components.metadata.web.impl 中的 类
ViewFieldTemplate() - 类 com.trs.components.metadata.web.impl.ViewFieldTemplate 的构造方法
ViewRangeConstants - com.trs.components.metadata.service 中的 类
ViewRangeConstants() - 类 com.trs.components.metadata.service.ViewRangeConstants 的构造方法
visitEnd(int) - 类 com.trs.components.stat.BaseStatHandler 中的方法
visitEnd(int) - 接口 com.trs.components.stat.IStatHandler 中的方法
在遍历完所有统计结果之后，需要执行的处理
visitStart(ResultSet, int) - 类 com.trs.components.stat.BaseStatHandler 中的方法
visitStart(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4ChannelOfGroup 中的方法
visitStart(ResultSet, int) - 类 com.trs.components.stat.DocstatHandler4ChannelOfUser 中的方法
visitStart(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4SiteOfGroup 中的方法
visitStart(ResultSet, int) - 类 com.trs.components.stat.DocstatHandler4SiteOfUser 中的方法
visitStart(ResultSet, int) - 接口 com.trs.components.stat.IStatHandler 中的方法
在遍历每一条统计处理之前，需要执行的处理
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DefaultStatHandler 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4Channel 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4ChannelOfGroup 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocstatHandler4ChannelOfUser 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4ChnlDept 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4ChnlDeptChannel 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4ChnlDeptSite 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4SiteOfGroup 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocstatHandler4SiteOfUser 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4UserChannel 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4UserDept 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4UserDeptChannel 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4UserDeptSite 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.DocStatHandler4UserSite 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.HitsStatHandler4Channel 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.HitsStatHandler4ChnlDept 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.HitsStatHandler4User 中的方法
visitStatItem(ResultSet, int) - 类 com.trs.components.stat.HitsStatHandler4UserDept 中的方法
visitStatItem(ResultSet, int) - 接口 com.trs.components.stat.IStatHandler 中的方法
根据传入的resultSet做一些额外的处理动作，从而累积自身状态，达到构造统计结果集。
VisualTemplateServiceProvider - com.trs.components.common.publish.widget 中的 类
VisualTemplateServiceProvider() - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 的构造方法
VLINK - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
VOIDObject - com.trs.webframework.entity 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
VOIDObject() - 类 com.trs.webframework.entity.VOIDObject 的构造方法
Vote - com.trs.components.common.trsvote 中的 类
Vote() - 类 com.trs.components.common.trsvote.Vote 的构造方法
构造函数：保留默认接口
VoteData - com.trs.components.common.trsvote 中的 类
VoteData() - 类 com.trs.components.common.trsvote.VoteData 的构造方法
构造函数：保留默认接口
VoteDatas - com.trs.components.common.trsvote 中的 类
VoteDatas(User) - 类 com.trs.components.common.trsvote.VoteDatas 的构造方法
构造函数
VoteDatas(User, int, int) - 类 com.trs.components.common.trsvote.VoteDatas 的构造方法
构造函数
VoteIPLog - com.trs.components.common.trsvote 中的 类
VoteIPLog() - 类 com.trs.components.common.trsvote.VoteIPLog 的构造方法
构造函数：保留默认接口
VoteIPLogs - com.trs.components.common.trsvote 中的 类
VoteIPLogs(User) - 类 com.trs.components.common.trsvote.VoteIPLogs 的构造方法
构造函数
VoteIPLogs(User, int, int) - 类 com.trs.components.common.trsvote.VoteIPLogs 的构造方法
构造函数
VoteItem - com.trs.components.common.trsvote 中的 类
VoteItem() - 类 com.trs.components.common.trsvote.VoteItem 的构造方法
构造函数：保留默认接口
VoteItems - com.trs.components.common.trsvote 中的 类
VoteItems(User) - 类 com.trs.components.common.trsvote.VoteItems 的构造方法
构造函数
VoteItems(User, int, int) - 类 com.trs.components.common.trsvote.VoteItems 的构造方法
构造函数
VoteOption - com.trs.components.common.trsvote 中的 类
VoteOption() - 类 com.trs.components.common.trsvote.VoteOption 的构造方法
构造函数：保留默认接口
VoteOptions - com.trs.components.common.trsvote 中的 类
VoteOptions(User) - 类 com.trs.components.common.trsvote.VoteOptions 的构造方法
构造函数
VoteOptions(User, int, int) - 类 com.trs.components.common.trsvote.VoteOptions 的构造方法
构造函数
Votes - com.trs.components.common.trsvote 中的 类
Votes(User) - 类 com.trs.components.common.trsvote.Votes 的构造方法
构造函数
Votes(User, int, int) - 类 com.trs.components.common.trsvote.Votes 的构造方法
构造函数
VoteSoapClient - com.trs.components.common.trsvote 中的 类
VoteSoapClient() - 类 com.trs.components.common.trsvote.VoteSoapClient 的构造方法
VoteSoapServer - com.trs.components.common.trsvote 中的 类
VoteSoapServer() - 类 com.trs.components.common.trsvote.VoteSoapServer 的构造方法
VSPACE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


W - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

W

waitForWorker() - 类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 中的方法
WARN - 类 com.trs.infra.support.log.LogType 中的静态变量
日志类型:警告
WARN - 类 com.trs.wcag2.Alertion 中的静态变量
Watermark - com.trs.wcm.photo 中的 类
Watermark() - 类 com.trs.wcm.photo.Watermark 的构造方法
构造函数：保留默认接口
Watermark2Xml - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
Watermark2Xml() - 类 com.trs.ajaxservice.xmlconvertors.Watermark2Xml 的构造方法
Watermarks - com.trs.wcm.photo 中的 类
Watermarks(User) - 类 com.trs.wcm.photo.Watermarks 的构造方法
构造函数
Watermarks(User, int, int) - 类 com.trs.wcm.photo.Watermarks 的构造方法
构造函数
WatermarkServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片库水印服务提供者
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WatermarkServiceProvider() - 类 com.trs.ajaxservice.WatermarkServiceProvider 的构造方法
WCAG2Helper - com.trs.wcag2 中的 类
WCAG2Helper() - 类 com.trs.wcag2.WCAG2Helper 的构造方法
WCM52Actor - com.trs.presentation.ids 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用于同步IDS的用户和组织到WCM中
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCM52Actor() - 类 com.trs.presentation.ids.WCM52Actor 的构造方法
WCM61AutoList - com.trs.tools 中的 类
WCM61AutoList(String) - 类 com.trs.tools.WCM61AutoList 的构造方法
WCMAJAXServiceHelper - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM AJAX服务器端工具类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMAJAXServiceHelper() - 类 com.trs.ajaxservice.WCMAJAXServiceHelper 的构造方法
WCMAppConfig - com.trs.components.wcm 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMAppConfig() - 类 com.trs.components.wcm.WCMAppConfig 的构造方法
WCMAppendixGenerator - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
helper for WCM tag parser
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMApplyFormProcessServiceHelper - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流服务辅助解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMApplyFormProcessServiceHelper() - 类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 的构造方法
WCMContentPublishConfig - com.trs.components.wcm.publish 中的 类
WCMContentPublishConfig(User, IPublishContent) - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 的构造方法
WCMContentPublishConfigToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMFolderPublishConfig XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMContentPublishConfigToXML() - 类 com.trs.ajaxservice.xmlconvertors.WCMContentPublishConfigToXML 的构造方法
WCMDatainvalidException - com.trs.infra.common 中的 异常
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMDatainvalidException(int) - 异常 com.trs.infra.common.WCMDatainvalidException 的构造方法
WCMDatainvalidException(int, String) - 异常 com.trs.infra.common.WCMDatainvalidException 的构造方法
WCMDatainvalidException(String) - 异常 com.trs.infra.common.WCMDatainvalidException 的构造方法
WCMDatainvalidException(int, String, Throwable) - 异常 com.trs.infra.common.WCMDatainvalidException 的构造方法
WCMDatainvalidException(String, Throwable) - 异常 com.trs.infra.common.WCMDatainvalidException 的构造方法
WCMDiscoveryFactory - com.trs.infra.util 中的 类
WCMDiscoveryFactory() - 类 com.trs.infra.util.WCMDiscoveryFactory 的构造方法
WCMDocAppendixesParserForImporter - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
导入非WCM导出的文档时,文档附件的解释
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMDocAppendixesParserForImporter() - 类 com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter 的构造方法
WCMDocumentHelper - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档相关公用行为提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMDocumentHelper() - 类 com.trs.ajaxservice.WCMDocumentHelper 的构造方法
WCMExcelData - com.trs.wcm.old 中的 类
Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
WCMExcelData() - 类 com.trs.wcm.old.WCMExcelData 的构造方法
WCMExcelDatas - com.trs.wcm.old 中的 类
Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
WCMExcelDatas(User) - 类 com.trs.wcm.old.WCMExcelDatas 的构造方法
WCMExcelDatas(User, int, int) - 类 com.trs.wcm.old.WCMExcelDatas 的构造方法
WCMException - com.trs.infra.common 中的 异常
Title: TRS 内容协作平台（TRS WCM） Description: WCM异常处理对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMException(int) - 异常 com.trs.infra.common.WCMException 的构造方法
WCMException(int, String) - 异常 com.trs.infra.common.WCMException 的构造方法
WCMException(String) - 异常 com.trs.infra.common.WCMException 的构造方法
WCMException(int, String, Throwable) - 异常 com.trs.infra.common.WCMException 的构造方法
构造函数
WCMException(String, Throwable) - 异常 com.trs.infra.common.WCMException 的构造方法
构造函数
WCMFilter - com.trs.infra.persistent 中的 类
WCMFilter() - 类 com.trs.infra.persistent.WCMFilter 的构造方法
WCMFilter(WCMFilter) - 类 com.trs.infra.persistent.WCMFilter 的构造方法
WCMFilter(String, String, String) - 类 com.trs.infra.persistent.WCMFilter 的构造方法
WCMFilter(String, String, String, String) - 类 com.trs.infra.persistent.WCMFilter 的构造方法
过滤器构造函数
WCMFilter(String, String, String, String, String) - 类 com.trs.infra.persistent.WCMFilter 的构造方法
WCMFilter(String, String, String, String, int) - 类 com.trs.infra.persistent.WCMFilter 的构造方法
WCMFilter(QueryFilter) - 类 com.trs.infra.persistent.WCMFilter 的构造方法
WCMFilterMakerForContainsChildren - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFilterMakerForContainsChildren(BaseChannel) - 类 com.trs.components.metadata.service.WCMFilterMakerForContainsChildren 的构造方法
WCMFilterMakerForContainsChildren(BaseChannel, boolean) - 类 com.trs.components.metadata.service.WCMFilterMakerForContainsChildren 的构造方法
WCMFolderLCListener - com.trs.components.wcm.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点或频道的删除同步撤除发布目录监听器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFolderLCListener() - 类 com.trs.components.wcm.publish.WCMFolderLCListener 的构造方法
WCMFolderPublishConfig - com.trs.components.wcm.publish 中的 类
WCMFolderPublishConfig() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 的构造方法
构造函数：保留默认接口
WCMFolderPublishConfig(IPublishFolder) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 的构造方法
WCMFolderPublishConfigLCListener - com.trs.components.wcm.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Folder发布的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFolderPublishConfigLCListener() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfigLCListener 的构造方法
WCMFolderPublishConfigToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMFolderPublishConfig XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFolderPublishConfigToXML() - 类 com.trs.ajaxservice.xmlconvertors.WCMFolderPublishConfigToXML 的构造方法
WCMFormFields - com.trs.wcm.old 中的 类
WCMFormFields() - 类 com.trs.wcm.old.WCMFormFields 的构造方法
构造函数：保留默认接口
WCMFormFieldses - com.trs.wcm.old 中的 类
WCMFormFieldses(User) - 类 com.trs.wcm.old.WCMFormFieldses 的构造方法
构造函数
WCMFormFieldses(User, int, int) - 类 com.trs.wcm.old.WCMFormFieldses 的构造方法
构造函数
WCMFormInfo - com.trs.wcm.old 中的 类
WCMFormInfo() - 类 com.trs.wcm.old.WCMFormInfo 的构造方法
构造函数：保留默认接口
WCMFormInfos - com.trs.wcm.old 中的 类
WCMFormInfos(User) - 类 com.trs.wcm.old.WCMFormInfos 的构造方法
构造函数
WCMFormInfos(User, int, int) - 类 com.trs.wcm.old.WCMFormInfos 的构造方法
构造函数
WCMFormMgr - com.trs.wcm.old 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理和自定义表单相关的行为
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMFormMgr() - 类 com.trs.wcm.old.WCMFormMgr 的构造方法
WCMHandler - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMHandler(CMSObj) - 类 com.trs.cms.content.WCMHandler 的构造方法
WCMHelp - com.trs.components.wcm.wcmx.help 中的 类
WCMHelp() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 的构造方法
WCMHelps - com.trs.components.wcm.wcmx.help 中的 类
WCMHelps(User) - 类 com.trs.components.wcm.wcmx.help.WCMHelps 的构造方法
构造函数
WCMHelps(User, int, int) - 类 com.trs.components.wcm.wcmx.help.WCMHelps 的构造方法
构造函数
WcmHelpUpdate - com.trs.components.wcm.wcmx.help 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Import wcmhelp data for WCM51-->WCM52
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WcmHelpUpdate() - 类 com.trs.components.wcm.wcmx.help.WcmHelpUpdate 的构造方法
WcmIdFieldInit - com.trs.infra.util.upgrade.dataprocess 中的 类
处理wcmid表的IDFIELDNAME
WcmIdFieldInit(String) - 类 com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit 的构造方法
WcmIdFieldInit - com.trs.infra.util.upgrade 中的 类
WCMID.IDFIELDNAME
WcmIdFieldInit() - 类 com.trs.infra.util.upgrade.WcmIdFieldInit 的构造方法
WCMJSPChecker - com.trs.components.metadata.service.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
JSP正确性验证对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMJSPChecker(String) - 类 com.trs.components.metadata.service.util.WCMJSPChecker 的构造方法
WCMJSPChecker(String, String, String, int, String) - 类 com.trs.components.metadata.service.util.WCMJSPChecker 的构造方法
WCMJSPCheckerTest - com.trs.components.metadata.service.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
检查Jsp文件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMJSPCheckerTest() - 类 com.trs.components.metadata.service.util.WCMJSPCheckerTest 的构造方法
WCMObjHelper - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMObjHelper() - 类 com.trs.cms.content.WCMObjHelper 的构造方法
WCMObjsHandler - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMObjsHandler(CMSObj, String) - 类 com.trs.cms.content.WCMObjsHandler 的构造方法
WCMObjsHandler(CMSObj) - 类 com.trs.cms.content.WCMObjsHandler 的构造方法
WCMOnlineService - com.trs.wcmonline 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
嘉宾访谈的服务
Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WCMOnlineService() - 类 com.trs.wcmonline.WCMOnlineService 的构造方法
WCMProcessServiceHelper - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流服务辅助解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMProcessServiceHelper() - 类 com.trs.ajaxservice.WCMProcessServiceHelper 的构造方法
WCMProcessServiceImpl - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
IWCMProcessService的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMProcessServiceImpl() - 类 com.trs.service.impl.WCMProcessServiceImpl 的构造方法
WCMPublishElementServiceImpl - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
implementation for IWCMPublishElementService
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMPublishElementServiceImpl() - 类 com.trs.service.impl.WCMPublishElementServiceImpl 的构造方法
WCMPublishHelper - com.trs.components.wcm.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMPublishHelper() - 类 com.trs.components.wcm.publish.WCMPublishHelper 的构造方法
WCMPubStatusConfig - com.trs.components.wcm.publish 中的 类
WCMPubStatusConfig() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 的构造方法
构造函数：保留默认接口
WCMPubStatusConfigs - com.trs.components.wcm.publish 中的 类
WCMPubStatusConfigs(User) - 类 com.trs.components.wcm.publish.WCMPubStatusConfigs 的构造方法
构造函数
WCMPubStatusConfigs(User, int, int) - 类 com.trs.components.wcm.publish.WCMPubStatusConfigs 的构造方法
构造函数
WCMRightTypes - com.trs.infra.common 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: 定义权限认证中权限索引常量 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMRightTypes() - 类 com.trs.infra.common.WCMRightTypes 的构造方法
WCMSystemObject - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
系统级虚对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMSystemObject(int) - 类 com.trs.cms.content.WCMSystemObject 的构造方法
WCMTagFormatterAllCata - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSALLCATA
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterAllCata() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterAllCata 的构造方法
constructor: default
WCMTagFormatterBigNews - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSBigNews
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterBigNews() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterBigNews 的构造方法
WCMTagFormatterChannel - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterChannel() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChannel 的构造方法
WCMTagFormatterChnlName - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag formater for _TRSCHNLNAME
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterChnlName() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterChnlName 的构造方法
constructor: default
WCMTagFormatterColumn - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for PICCONTENT
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterColumn() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterColumn 的构造方法
constructor: default
WCMTagFormatterDocumentsBase - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM Tag格式化工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterDocumentsBase() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterDocumentsBase 的构造方法
WCMTagFormatterOutline - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterOutline() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterOutline 的构造方法
WCMTagFormatterPicNews - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSPicNews
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterPicNews() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicNews 的构造方法
WCMTagFormatterPicture - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSPCITURE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterPicture() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterPicture 的构造方法
constructor: default
WCMTagFormatterRecPath - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag formatter for _TRSRECPATH
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterRecPath() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRecPath 的构造方法
constructor: default
WCMTagFormatterRelNews - com.trs.components.wcm.publish.tagparser.formater 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagFormatterRelNews() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterRelNews 的构造方法
WCMTagFormatterTemplate - com.trs.components.wcm.publish.tagparser.formater 中的 类
将name_of_template格式化为 的形式。
WCMTagFormatterTemplate() - 类 com.trs.components.wcm.publish.tagparser.formater.WCMTagFormatterTemplate 的构造方法
缺省构造方法
WCMTagParser4FolderHostBase - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
base implementation of tag parser for channel host in WCM
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParser4FolderHostBase() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4FolderHostBase 的构造方法
constructor: default
WCMTagParser4ObjsInChannelBase - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_OUTLINE
Grammer:
<TRS_*** [[ID="频道名称"] [CHILDINDEX="子频道的序号"]
 [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"]
 [STARTPOS="开始位置"]
[AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"]
 [ALINK="链接字段"]
 [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"]
 [ICO="图标文件"]
[AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"]
 [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ]
 [MOREEXTRA="用于更多内容链接中的附加属性"]
 [MORETARGET="更多内容的链接目标类型"]> <column_block></TRS_***>

 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParser4ObjsInChannelBase() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 的构造方法
WCMTagParserAppendix - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_APPENDIX解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserAppendix() - 类 com.trs.components.metadata.publish.WCMTagParserAppendix 的构造方法
WCMTagParserAppendix - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_APPENDIX解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserAppendix() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix 的构造方法
WCMTagParserBaseOperation - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserBaseOperation() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 的构造方法
WCMTagParserBaseOperation.TBI - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserBaseOperation.TBI() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation.TBI 的构造方法
WCMTagParserChannel - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
The Parser For TRS_CHANNEL
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserChannel() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannel 的构造方法
constructor: default
WCMTagParserChannelLogo - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserChannelLogo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannelLogo 的构造方法
WCMTagParserChannels - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_ALLCATA
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserChannels() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 的构造方法
constructor: default
WCMTagParserChnlInChnlOperation - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserChnlInChnlOperation() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlInChnlOperation 的构造方法
WCMTagParserChnlOperation - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserChnlOperation() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlOperation 的构造方法
WCMTagParserClassDocuments - com.trs.components.metadata.publish 中的 类
WCMTagParserClassDocuments() - 类 com.trs.components.metadata.publish.WCMTagParserClassDocuments 的构造方法
WCMTagParserClassIndexGener - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
在指定栏目或者站点中产生分类法首页
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserClassIndexGener() - 类 com.trs.components.metadata.publish.WCMTagParserClassIndexGener 的构造方法
WCMTagParserClassInfo - com.trs.components.metadata.publish 中的 类
WCMTagParserClassInfo() - 类 com.trs.components.metadata.publish.WCMTagParserClassInfo 的构造方法
WCMTagParserClassInfos - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_ClassInfos 置标解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserClassInfos() - 类 com.trs.components.metadata.publish.WCMTagParserClassInfos 的构造方法
WCMTagParserCurPage - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for <_TRSCURPAGE>.
WCMTagParserCurPage() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage 的构造方法
WCMTagParserDefaultObjectsInChannel - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserDefaultObjectsInChannel() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannel 的构造方法
WCMTagParserDefaultObjectsInChannelBase - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserDefaultObjectsInChannelBase() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDefaultObjectsInChannelBase 的构造方法
WCMTagParserDocInChnlOperation - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserDocInChnlOperation() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation 的构造方法
WCMTagParserDocOperation - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserDocOperation() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocOperation 的构造方法
WCMTagParserDocReply - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档回复的发布置标解释器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocReply() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply 的构造方法
WCMTagParserDocument - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
parser for
Grammer:
<TRS_COLUMN ID="字段名" [[NUM="最大长度" [TRUNCATEDFLAG="长度裁减标记"]] [DATEFORMAT="日期格式"][AUTOFORMAT="自动格式化"] [AUTOLINK="是否自动产生链接 "][TARGET="窗口目标"][EXTRA="扩展HTML内容"] ]>通用细览 </TRS_COLUMN> Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocument() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocument 的构造方法
constructor: default
WCMTagParserDocumentChannels - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserDocumentChannels() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentChannels 的构造方法
WCMTagParserDocumentForBJGOV - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocumentForBJGOV() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentForBJGOV 的构造方法
WCMTagParserDocumentLogo - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserDocumentLogo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentLogo 的构造方法
WCMTagParserDocuments - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_OUTLINE
Grammer:
<TRS_OUTLINE [[ID="频道名称"] [CHILDINDEX="子频道的序号"]
 [WHERE="额外的检索条件"] [ORDER="排序方式"] [NUM="记录条数"]
 [STARTPOS="开始位置"]
[AUTOLINK="是否自动产生HTML链接"] [TARGET="窗口目标"]
 [ALINK="链接字段"]
 [LINKTEXT="链接表面文字"][EXTRA="扩展HTML内容"]
 [ICO="图标文件"]
[AUTOMORE="是否自动显示更多内容"] [BEGINMORE="放在更多内容前面的HTML"]
 [ENDMORE="放在更多内容后面的HTML"] [MORETEXT="更多内容的HTML"] ]
 [MOREEXTRA="用于更多内容链接中的附加属性"]
 [MORETARGET="更多内容的链接目标类型"]>
 <column_block></TRS_OUTLINE>

 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserDocuments() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments 的构造方法
WCMTagParserEPressNews - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报版面图
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserEPressNews() - 类 com.trs.components.wcm.epress.WCMTagParserEPressNews 的构造方法
WCMTagParserEPressNews - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报版面图
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserEPressNews() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews 的构造方法
WCMTagParserExistDataOfClassInfo - com.trs.components.metadata.publish 中的 类
WCMTagParserExistDataOfClassInfo() - 类 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo 的构造方法
WCMTagParserExpertNews - com.trs.components.wcm.epress 中的 类
WCMTagParserExpertNews() - 类 com.trs.components.wcm.epress.WCMTagParserExpertNews 的构造方法
WCMTagParserHelper - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMTagParser解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserHelper() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 的构造方法
WCMTagParserIcon - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMTagParser For TRS_ICON
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserIcon() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon 的构造方法
WCMTagParserImage - com.trs.wcm.photo.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
解析图片库置标TRS_IMAGE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserImage() - 类 com.trs.wcm.photo.publish.WCMTagParserImage 的构造方法
WCMTagParserLayout - com.trs.components.common.publish.widget.tagparser 中的 类
用于TRS_Layout置标生成HTML代码，一般用在母板中
WCMTagParserLayout() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout 的构造方法
WCMTagParserLayoutCell - com.trs.components.common.publish.widget.tagparser 中的 类
TRS_LayoutCell用于TRS_Layout置标内部，其发布产生的html代码，将作为布局列的内容，填充到布局对应的列中，一般用在母板中
WCMTagParserLayoutCell() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayoutCell 的构造方法
WCMTagParserLogoBase - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserLogoBase() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase 的构造方法
WCMTagParserMapArea - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
生成电子报map area相关信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserMapArea() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 的构造方法
WCMTagParserMyViewDatas - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TRS_MyViewDatas解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserMyViewDatas() - 类 com.trs.components.metadata.publish.WCMTagParserMyViewDatas 的构造方法
WCMTagParserNextDocuments - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserNextDocuments() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserNextDocuments 的构造方法
WCMTagParserPageStyle - com.trs.components.common.publish.widget.tagparser 中的 类
页面风格的置标解析 该置标是用于分发风格的样式文件以及图片文件
WCMTagParserPageStyle() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle 的构造方法
WCMTagParserPreDocuments - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserPreDocuments() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserPreDocuments 的构造方法
WCMTagParserPrev - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM TagParser For TRS_PREV
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserPrev() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev 的构造方法
WCMTagParserPreWidget - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserPreWidget() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget 的构造方法
WCMTagParserRegion - com.trs.components.wcm.publish.region 中的 类
WCMTagParserRegion() - 类 com.trs.components.wcm.publish.region.WCMTagParserRegion 的构造方法
WCMTagParserRelNews - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_RELNEWS
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserRelNews() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 的构造方法
constructor: default
WCMTagParserRelNewsForViewData - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser for TRS_RELNEWS
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserRelNewsForViewData() - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 的构造方法
constructor: default
WCMTagParserReplace - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM Tag Parser For TRS_REPLACE
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserReplace() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace 的构造方法
WCMTagParserResources - com.trs.components.common.publish.widget.tagparser 中的 类
用于在设计页面及发布页面引入相应的资源文件（包括js及css），如：设计页面引入的layout.js,widget.js等关于布局和资源块操作的js。
WCMTagParserResources() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserResources 的构造方法
WCMTagParserRollDocuments - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserRollDocuments() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments 的构造方法
WCMTagParserSpecialAppendix - com.trs.components.common.publish.widget.tagparser 中的 类
用于处理专题中的附件发布
WCMTagParserSpecialAppendix() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix 的构造方法
WCMTagParserSpecialLogo - com.trs.components.common.publish.widget.tagparser 中的 类
专题LOGO置标解析 WCMTagParserSpecialLogo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo 的构造方法
WCMTagParserTagCreator - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserTagCreator() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator 的构造方法
WCMTagparserTopIcon - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
置顶文档标识
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
WCMTagparserTopIcon() - 类 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon 的构造方法
WCMTagParserViewData - com.trs.components.metadata.publish 中的 类
WCMTagParserViewData() - 类 com.trs.components.metadata.publish.WCMTagParserViewData 的构造方法
WCMTagParserViewDatas - com.trs.components.metadata.publish 中的 类
WCMTagParserViewDatas() - 类 com.trs.components.metadata.publish.WCMTagParserViewDatas 的构造方法
WCMTagParserViewField - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserViewField() - 类 com.trs.components.metadata.publish.WCMTagParserViewField 的构造方法
WCMTagParserViewFields - com.trs.components.metadata.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTagParserViewFields() - 类 com.trs.components.metadata.publish.WCMTagParserViewFields 的构造方法
WCMTagParserWebSite - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserWebSite() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSite 的构造方法
WCMTagParserWebSites - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserWebSites() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSites 的构造方法
WCMTagParserWidget - com.trs.components.common.publish.widget.tagparser 中的 类
WCMTagParserWidget() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserWidget 的构造方法
WCMTagParserXDcouments - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WCMTagParserXDcouments() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments 的构造方法
WCMTagParserXDocument - com.trs.components.wcm.publish.tagparser 中的 类
WCMTagParserXDocument() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDocument 的构造方法
WCMTemplateChildIndexAnalyer - com.trs.components.wcm.publish.tagparser 中的 类
WCMTemplateChildIndexAnalyer(Template) - 类 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer 的构造方法
WCMTemplateChildIndexAnalyer(IPublishFolder) - 类 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer 的构造方法
WCMTypes - com.trs.infra.common 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: 用以定义WCM中的对象类型编码常量、以及各个WCM系统中所用到的常量 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
WCMTypes() - 类 com.trs.infra.common.WCMTypes 的构造方法
WCMTypesX - com.trs.components.wcm.wcmx.common 中的 类
WCMTypesX() - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 的构造方法
WEB_OUTLINE_PCLASS - 类 com.trs.components.common.trsad.ADPos 中的静态变量
WebServiceHelper - com.trs.webframework 中的 类
WebServiceHelper() - 类 com.trs.webframework.WebServiceHelper 的构造方法
WebSite - com.trs.components.wcm.content.persistent 中的 类
WebSite() - 类 com.trs.components.wcm.content.persistent.WebSite 的构造方法
WebSiteHelper - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点相关的工具函数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteHelper() - 类 com.trs.ajaxservice.WebSiteHelper 的构造方法
WebSiteInfoEntity - com.trs.template.persistent 中的 类
WebSiteInfoEntity() - 类 com.trs.template.persistent.WebSiteInfoEntity 的构造方法
WebSiteInfoEntity(int, String) - 类 com.trs.template.persistent.WebSiteInfoEntity 的构造方法
WebSiteInfoEntity(int, String, String) - 类 com.trs.template.persistent.WebSiteInfoEntity 的构造方法
WebSiteLCListenerForAutoDocBak - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteLCListenerForAutoDocBak() - 类 com.trs.components.wcm.content.domain.WebSiteLCListenerForAutoDocBak 的构造方法
WebSiteLCListenerForContentLink - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteLCListenerForContentLink() - 类 com.trs.components.wcm.content.domain.WebSiteLCListenerForContentLink 的构造方法
WebSiteLCListenerForSiteUser - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点用户/用户组监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteLCListenerForSiteUser() - 类 com.trs.components.wcm.content.domain.WebSiteLCListenerForSiteUser 的构造方法
WebSiteLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
WebSiteLogger() - 类 com.trs.components.wcm.logger.WebSiteLogger 的构造方法
WebSiteRestoreLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点恢复操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
WebSiteRestoreLogger() - 类 com.trs.ajaxservice.logger.WebSiteRestoreLogger 的构造方法
WebSiteRightHostImpl - com.trs.components.wcm.content.domain.auth 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteRightHostImpl() - 类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 的构造方法
WebSiteRightHostImpl(int) - 类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 的构造方法
WebSiteRightHostImpl(CMSObj) - 类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 的构造方法
WebSiteRightObjImpl - com.trs.components.wcm.auth 中的 类
WebSiteRightObjImpl() - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 的构造方法
WebSites - com.trs.components.wcm.content.persistent 中的 类
WebSites(User) - 类 com.trs.components.wcm.content.persistent.WebSites 的构造方法
WebSites(User, int, int) - 类 com.trs.components.wcm.content.persistent.WebSites 的构造方法
WebSiteServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteServiceProvider() - 类 com.trs.ajaxservice.WebSiteServiceProvider 的构造方法
WebSiteSubstanceImplBase - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteSubstanceImplBase() - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 的构造方法
WebSiteSubstanceImplBase(int) - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 的构造方法
WebSiteSubstanceImplBase(CMSObj) - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 的构造方法
WebSiteToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
栏目XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WebSiteToXML() - 类 com.trs.ajaxservice.xmlconvertors.WebSiteToXML 的构造方法
WEEK - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日期/时间的各个部分标识：一周（12）
WEEK_OF_MONTH - 类 com.trs.infra.util.CMyDateTime 中的静态变量
当月周数（14）
WEEK_OF_YEAR - 类 com.trs.infra.util.CMyDateTime 中的静态变量
当月周数（16）
WEEKS - 类 com.trs.infra.util.CMyDateTime 中的静态变量
WEN_INDEX_PCLASS - 类 com.trs.components.common.trsad.ADPos 中的静态变量
WhereSQLMaker - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
WhereSQLMaker(PageParameters) - 类 com.trs.presentation.util.WhereSQLMaker 的构造方法
Widget - com.trs.components.common.publish.widget 中的 类
Widget() - 类 com.trs.components.common.publish.widget.Widget 的构造方法
构造函数：保留默认接口
WIDGET_ADD - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
新建资源的权限
WIDGET_BROWSE - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
查看资源的权限
WIDGET_DEAL_MODE_CHANGE - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
导入时出现资源重名的处理方式 : 更名
WIDGET_DEAL_MODE_IGNORE - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
导入时出现资源重名的处理方式 : 忽略
WIDGET_DEAL_MODE_UPDATE - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
导入时出现资源重名的处理方式 : 覆盖
WIDGET_DELETE - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
删除资源的权限
WIDGET_EDIT - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态变量
修改资源的权限
WIDGET_STYLE_PARAMETER - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
资源风格固有变量
WidgetConstants - com.trs.components.common.publish.widget 中的 类
WidgetConstants() - 类 com.trs.components.common.publish.widget.WidgetConstants 的构造方法
WidgetInstance - com.trs.components.common.publish.widget 中的 类
WidgetInstance() - 类 com.trs.components.common.publish.widget.WidgetInstance 的构造方法
构造函数：保留默认接口
WidgetInstanceMgr - com.trs.components.common.publish.widget 中的 类
WidgetInstanceMgr() - 类 com.trs.components.common.publish.widget.WidgetInstanceMgr 的构造方法
WidgetInstances - com.trs.components.common.publish.widget 中的 类
WidgetInstances(User) - 类 com.trs.components.common.publish.widget.WidgetInstances 的构造方法
构造函数
WidgetInstances(User, int, int) - 类 com.trs.components.common.publish.widget.WidgetInstances 的构造方法
构造函数
WidgetInstParameter - com.trs.components.common.publish.widget 中的 类
WidgetInstParameter() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 的构造方法
构造函数：保留默认接口
WidgetInstParameterMgr - com.trs.components.common.publish.widget 中的 类
WidgetInstParameterMgr() - 类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 的构造方法
WidgetInstParameters - com.trs.components.common.publish.widget 中的 类
WidgetInstParameters(User) - 类 com.trs.components.common.publish.widget.WidgetInstParameters 的构造方法
构造函数
WidgetInstParameters(User, int, int) - 类 com.trs.components.common.publish.widget.WidgetInstParameters 的构造方法
构造函数
WidgetMgr - com.trs.components.common.publish.widget 中的 类
WidgetMgr() - 类 com.trs.components.common.publish.widget.WidgetMgr 的构造方法
WidgetParameter - com.trs.components.common.publish.widget 中的 类
WidgetParameter() - 类 com.trs.components.common.publish.widget.WidgetParameter 的构造方法
构造函数：保留默认接口
WidgetParameter_TYPES - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
WidgetParameterMgr - com.trs.components.common.publish.widget 中的 类
WidgetParameterMgr() - 类 com.trs.components.common.publish.widget.WidgetParameterMgr 的构造方法
WidgetParameters - com.trs.components.common.publish.widget 中的 类
WidgetParameters(User) - 类 com.trs.components.common.publish.widget.WidgetParameters 的构造方法
构造函数
WidgetParameters(User, int, int) - 类 com.trs.components.common.publish.widget.WidgetParameters 的构造方法
构造函数
WidgetParameterServiceProvider - com.trs.components.common.publish.widget 中的 类
WidgetParameterServiceProvider() - 类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 的构造方法
WidgetParameterType - com.trs.components.common.publish.widget 中的 类
WidgetParameterType(int, String, String) - 类 com.trs.components.common.publish.widget.WidgetParameterType 的构造方法
WidgetParameterTypes - com.trs.components.common.publish.widget 中的 类
WidgetParameterTypes() - 类 com.trs.components.common.publish.widget.WidgetParameterTypes 的构造方法
WidgetPathHelper - com.trs.components.common.publish.widget 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
WidgetPathHelper() - 类 com.trs.components.common.publish.widget.WidgetPathHelper 的构造方法
Widgets - com.trs.components.common.publish.widget 中的 类
Widgets(User) - 类 com.trs.components.common.publish.widget.Widgets 的构造方法
构造函数
Widgets(User, int, int) - 类 com.trs.components.common.publish.widget.Widgets 的构造方法
构造函数
WidgetServer - com.trs.components.common.publish.widget 中的 类
WidgetServer() - 类 com.trs.components.common.publish.widget.WidgetServer 的构造方法
WidgetServiceProvider - com.trs.components.common.publish.widget 中的 类
WidgetServiceProvider() - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 的构造方法
WidgetXmlConverter - com.trs.components.common.publish.widget 中的 类
WidgetXmlConverter() - 类 com.trs.components.common.publish.widget.WidgetXmlConverter 的构造方法
WIDTH - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
WIDTH - 类 com.trs.scene.tools.SceneNode 中的静态变量
节点长度
width - 类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 中的变量
WinCABFileExtractor - com.trs.components.infoview.extract 中的 类
WinCABFileExtractor() - 类 com.trs.components.infoview.extract.WinCABFileExtractor 的构造方法
withdraw(IPublishFolder, PublishTaskContext) - 类 com.trs.components.common.publish.domain.publisher.PageDestroyer 中的静态方法
Withdraws all the files in a specified folder.
withdraw(IPublishContent, PublishTaskContext) - 类 com.trs.components.common.publish.domain.publisher.PageDestroyer 中的静态方法
Withdraws the detail pages of the specified content.
withdraw(Document) - 接口 com.trs.service.IDocumentService 中的方法
撤稿 ?
withdraw(Document) - 类 com.trs.service.impl.DocumentService 中的方法
withdrawFile(String, IPublishElement) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
Withdraws a file.
withdrawFile(String, IPublishElement, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
withdrawFile(String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 中的方法
已过时。
withdrawFile(String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 中的方法
withdrawFile(String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 中的方法
withdrawFile(String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法
withdrawFile(String, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 中的方法
已过时。
withdrawFile(String, String) - 接口 com.trs.components.common.publish.domain.distribute.IFileDistristributor 中的方法
Withdraws a specified file in the path.
withdrawFolder(IPublishFolder) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
Withdraws a folder.
withdrawFolder(IPublishFolder, List) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
撤除指定folder的指定子目录
WithDrawJobWorker - com.trs.components.wcm.publish.domain.job 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
定时撤稿
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
WithDrawJobWorker() - 类 com.trs.components.wcm.publish.domain.job.WithDrawJobWorker 的构造方法
构造函数，保留默认接口
withdrawPath(String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 中的方法
已过时。
withdrawPath(String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 中的方法
withdrawPath(String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 中的方法
withdrawPath(String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法
withdrawPath(String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 中的方法
已过时。
withdrawPath(String) - 接口 com.trs.components.common.publish.domain.distribute.IFileDistristributor 中的方法
Withdraws a specified file path.
withDrawSelfOnly(IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PageDestroyer 中的静态方法
只撤除指定folder本身的内容,不包括子对象的内容.
WordFileService - com.trs.components.wcm.soap 中的 类
WordFileService() - 类 com.trs.components.wcm.soap.WordFileService 的构造方法
WORKMODAL_NORM - 类 com.trs.cms.process.ProcessConstants 中的静态变量
一般处理模式，其中一个人处理，就可以继续流转
WORKMODAL_SEPERATOR_END - 类 com.trs.cms.process.ProcessConstants 中的静态变量
并联审批处理结束模式，处理完以后，汇总后继续流转
WORKMODAL_SEPERATOR_START - 类 com.trs.cms.process.ProcessConstants 中的静态变量
并联审批处理开始模式，各自处理，看不见对方处理记录
WORKMODAL_TOGETHER - 类 com.trs.cms.process.ProcessConstants 中的静态变量
会签处理模式，需要都处理完，才能继续留转
write(byte[], int, int) - 类 com.trs.infra.util.BASE64EncoderStream 中的方法
write(byte[]) - 类 com.trs.infra.util.BASE64EncoderStream 中的方法
write(int) - 类 com.trs.infra.util.BASE64EncoderStream 中的方法
write(int) - 类 com.trs.infra.util.jazzlib.CheckedOutputStream 中的方法
Writes one byte to the OutputStream and updates the Checksum.
write(byte[], int, int) - 类 com.trs.infra.util.jazzlib.CheckedOutputStream 中的方法
Writes the byte array to the OutputStream and updates the Checksum.
write(int) - 类 com.trs.infra.util.jazzlib.DeflaterOutputStream 中的方法
Writes a single byte to the compressed output stream.
write(byte[], int, int) - 类 com.trs.infra.util.jazzlib.DeflaterOutputStream 中的方法
Writes a len bytes from an array to the compressed stream.
write(byte[], int, int) - 类 com.trs.infra.util.jazzlib.GZIPOutputStream 中的方法
write(byte[], int, int) - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
Writes the given buffer to the current entry.
write(String, String, String, String, String) - 类 com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker 中的方法
write(Document, String) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法
write(Document, String, String) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法
write(Document, String, String, String) - 类 com.trs.infra.util.XmlDocWithDom4j 中的静态方法
WRITE_STR_ENCODING - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
writeDOM4JDocument(Document, String) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
writeFile(String, String) - 类 com.trs.infra.util.CMyFile 中的静态方法
以指定内容_sFileContent生成新的文件_sFileName
writeFile(String, String, String) - 类 com.trs.infra.util.CMyFile 中的静态方法
以指定内容_sFileContent生成新的文件_sFileName
writeFile(String, String, String, boolean) - 类 com.trs.infra.util.CMyFile 中的静态方法
writeFile(String, byte[]) - 类 com.trs.infra.util.CMyFileX 中的静态方法
writeFile(byte[], String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的静态方法
将文件写入到Upload目录中
writeFile(String, String, String) - 类 com.trs.tools.WCM61AutoList 中的静态方法
writeHTMLContainsChannels() - 类 com.trs.presentation.nav.TreeCreator 中的方法
产生包含指定栏目的HTML
writeHTMLOfAPath() - 类 com.trs.presentation.nav.TreeCreator 中的方法
输出当前节点路径的HTML 节点路径有逗号(,)分割的节点ID组成 通过NodeIds参数传入
writeImage() - 接口 com.trs.wcm.photo.IMagicImage 中的方法
将设定的效果写入原始图片文件中
writeImage(String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
将设定的效果写入新定义的图片文件中
writeImage() - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
writeImage(String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
writeImageTo(int, OutputStream) - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
将给定的验证码的图像数据输出到给定的输出流
writeImageToSystemTemp() - 接口 com.trs.wcm.photo.IMagicImage 中的方法
将设定的效果写入到系统的临时目录中
writeImageToSystemTemp() - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
writeImageToWCMData(String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
将图片写入到WCMData指定类型的目录中
writeImageToWCMData(String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
writeSpecFile(byte[], String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的静态方法
将文件写入到Upload目录中
writeTopChildrenHTML() - 类 com.trs.presentation.nav.TreeCreator 中的方法
根据父结点的载入子对象的HTML信息
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


X - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

X

X_DISTANCE - 类 com.trs.scene.tools.SceneNode 中的静态变量
水平距离
XDocument - com.trs.components.wcm.content.persistent 中的 类
XDocument() - 类 com.trs.components.wcm.content.persistent.XDocument 的构造方法
XDocuments - com.trs.components.wcm.content.persistent 中的 类
XDocuments() - 类 com.trs.components.wcm.content.persistent.XDocuments 的构造方法
XML_IMPORT_NEW - 类 com.trs.infra.common.WCMTypes 中的静态变量
XML导入类型，从XML导入新的对象
XML_IMPORT_RESTORE - 类 com.trs.infra.common.WCMTypes 中的静态变量
XML导入类型，从XML导入数据，恢复对象（若没有对象则创建，否则修改）
XML_IMPORT_UPDATE - 类 com.trs.infra.common.WCMTypes 中的静态变量
XML导入类型，从XML导入数据，修改对象
XmlCharCheckedInputStream - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Xml有效字符检查输入流
java.io.InputStream的一个简单封装,read方法检查每一个byte.
XmlCharCheckedInputStream(InputStream) - 类 com.trs.infra.util.XmlCharCheckedInputStream 的构造方法
XMLConfig - com.trs.infra.config 中的 类
XMLConfig(String, String) - 类 com.trs.infra.config.XMLConfig 的构造方法
XMLConfigServer - com.trs.infra.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
对可配置对象的顶层管理类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLContentRender - com.trs.components.infoview.db 中的 类
XMLContentRender() - 类 com.trs.components.infoview.db.XMLContentRender 的构造方法
XMLConvertorConfigStartServer - com.trs.webframework.xmlserver 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
XML转换器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLConvertorConfigStartServer() - 类 com.trs.webframework.xmlserver.XMLConvertorConfigStartServer 的构造方法
XMLConvertorFactory - com.trs.webframework.xmlserver 中的 类
XMLConvertorFactory() - 类 com.trs.webframework.xmlserver.XMLConvertorFactory 的构造方法
XMLDataProcessingHandler - com.trs.webframework.xmlserver.server 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLDataProcessingHandler() - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 的构造方法
XMLDataProcessingHandler(Object) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 的构造方法
XmlDocWithDom4j - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Test dom4j
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XmlDocWithDom4j() - 类 com.trs.infra.util.XmlDocWithDom4j 的构造方法
XmlObject - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
XML节点对应对象的定义和实现:
当前节点对应的对象及其子节点所对应的对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XmlObject() - 类 com.trs.infra.persistent.XmlObject 的构造方法
XmlObjectPersistentor - com.trs.infra.util.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
The tool for getting or serializing a xml object
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XmlObjectPersistentor() - 类 com.trs.infra.util.xml.XmlObjectPersistentor 的构造方法
XMLParamsValidator - com.trs.webframework.controler.servlet 中的 类
XMLParamsValidator(Map, MethodConfig) - 类 com.trs.webframework.controler.servlet.XMLParamsValidator 的构造方法
XMLParseException - com.trs.webframework.xmlserver.parser 中的 异常
XMLParseException() - 异常 com.trs.webframework.xmlserver.parser.XMLParseException 的构造方法
XMLParseException(String) - 异常 com.trs.webframework.xmlserver.parser.XMLParseException 的构造方法
XMLParseException(Throwable) - 异常 com.trs.webframework.xmlserver.parser.XMLParseException 的构造方法
XMLParseException(String, Throwable) - 异常 com.trs.webframework.xmlserver.parser.XMLParseException 的构造方法
XMLParsingInfoHolder - com.trs.webframework.xmlserver.parser 中的 类
XMLParsingInfoHolder() - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 的构造方法
XMLParsingPausedException - com.trs.webframework.xmlserver.server 中的 异常
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLParsingPausedException() - 异常 com.trs.webframework.xmlserver.server.XMLParsingPausedException 的构造方法
XMLParsingPausedException(String) - 异常 com.trs.webframework.xmlserver.server.XMLParsingPausedException 的构造方法
XMLParsingPausedException(Throwable) - 异常 com.trs.webframework.xmlserver.server.XMLParsingPausedException 的构造方法
XMLParsingPausedException(String, Throwable) - 异常 com.trs.webframework.xmlserver.server.XMLParsingPausedException 的构造方法
XMLParsingStatus - com.trs.webframework.xmlserver.parser 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLToCMSObj - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
将XML转换成CMSObj对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLToCMSObj(User, CMSObj) - 类 com.trs.ajaxservice.xmlconvertors.XMLToCMSObj 的构造方法
XmlToDocumentConverter - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Xml-->Document(WCM)对象的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XmlToDocumentConverter(int) - 类 com.trs.components.wcm.content.domain.XmlToDocumentConverter 的构造方法
XMLToMetaDBTablesConvertor - com.trs.components.metadata.definition.xml 中的 类
XMLToMetaDBTablesConvertor(int) - 类 com.trs.components.metadata.definition.xml.XMLToMetaDBTablesConvertor 的构造方法
XMLToMetaViewData - com.trs.components.metadata.center.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
XML to MetaViewData转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XMLToMetaViewData(int) - 类 com.trs.components.metadata.center.xml.XMLToMetaViewData 的构造方法
XMLToMetaViewDataTest - com.trs.components.metadata.center.xml 中的 类
XMLToMetaViewDataTest() - 类 com.trs.components.metadata.center.xml.XMLToMetaViewDataTest 的构造方法
XmlToObjConverter - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XmlToObjConverter(int) - 类 com.trs.infra.persistent.XmlToObjConverter 的构造方法
XmlToObjConverterByDOM4j - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
XML文件到BaseObj的转换
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XmlToObjConverterByDOM4j(int) - 类 com.trs.infra.persistent.XmlToObjConverterByDOM4j 的构造方法
XmlToRightConvertor - com.trs.ajaxservice 中的 类
XmlToRightConvertor(int) - 类 com.trs.ajaxservice.XmlToRightConvertor 的构造方法
XSLTViewBuilder - com.trs.components.infoview.extract 中的 类
XSLTViewBuilder() - 类 com.trs.components.infoview.extract.XSLTViewBuilder 的构造方法
XSLTViewConstrainter - com.trs.components.infoview.extract 中的 类
XSLTViewConstrainter() - 类 com.trs.components.infoview.extract.XSLTViewConstrainter 的构造方法
XTagParserObjsInChannelBase - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XTagParserObjsInChannelBase() - 类 com.trs.components.wcm.publish.tagparser.XTagParserObjsInChannelBase 的构造方法
XTemplateExporter - com.trs.template.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
负责管理模板导出相关的行为
模板导出过程中会涉及到模板附件的导出
由于目前顶已模板导出只伴随站点导出才导出，频道导出时不导出模板，所以模板附件的导出相对比较简单
以后再进行扩展
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XTemplateExporter() - 类 com.trs.template.domain.XTemplateExporter 的构造方法
constructor: default
XTemplateExporter.HierarchyEntity - com.trs.template.domain 中的 类
XTemplateExporter.HierarchyEntity() - 类 com.trs.template.domain.XTemplateExporter.HierarchyEntity 的构造方法
XTemplateExporter.HierarchyEntity(String, String) - 类 com.trs.template.domain.XTemplateExporter.HierarchyEntity 的构造方法
XuguDB - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
虚谷数据库
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
XuguDB() - 类 com.trs.infra.util.database.XuguDB 的构造方法
XuguDB(String, String) - 类 com.trs.infra.util.database.XuguDB 的构造方法
XWCMContImgTagParser - com.trs.components.wcm.publish.tagparser 中的 类
XWCMContImgTagParser() - 类 com.trs.components.wcm.publish.tagparser.XWCMContImgTagParser 的构造方法
XWCMFileAppendixTagParser - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
解析文档包含的文件附件：支持自定义文件名
Copyright: Copyright (c) 2009-2010 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XWCMFileAppendixTagParser() - 类 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser 的构造方法
XWCMImageAppendixTagParser - com.trs.components.wcm.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
解析文档包含的图片附件：支持图片自动缩放
Copyright: Copyright (c) 2009-2010 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XWCMImageAppendixTagParser() - 类 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser 的构造方法
XWCMTagParserComment - com.trs.components.comment.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCM TagParser For Comment
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
XWCMTagParserComment() - 类 com.trs.components.comment.publish.tagparser.XWCMTagParserComment 的构造方法
XWCMTagParserPageGeneration - com.trs.components.wcm.publish.tagparser 中的 类
XWCMTagParserPageGeneration() - 类 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Y - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Y

Y_DISTANCE - 类 com.trs.scene.tools.SceneNode 中的静态变量
垂直距离
YEAR - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日期/时间的各个部分标识：年（1）
YES - 类 com.trs.infra.common.WCMTypes 中的静态变量
WCM逻辑值常量，布尔真值
YES - 类 com.trs.infra.MyTypes 中的静态变量
WCM逻辑值常量，布尔真值
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Z - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Z

zip(String, String) - 类 com.trs.infra.util.CMyZip 中的方法
ZipEntry - com.trs.infra.util.jazzlib 中的 类
This class represents a member of a zip archive.
ZipEntry(String) - 类 com.trs.infra.util.jazzlib.ZipEntry 的构造方法
Creates a zip entry with the given name.
ZipEntry(ZipEntry) - 类 com.trs.infra.util.jazzlib.ZipEntry 的构造方法
Creates a copy of the given zip entry.
ZipException - com.trs.infra.util.jazzlib 中的 异常
Is thrown during the creation or input of a zip file.
ZipException() - 异常 com.trs.infra.util.jazzlib.ZipException 的构造方法
ZipException(String) - 异常 com.trs.infra.util.jazzlib.ZipException 的构造方法
ZipFile - com.trs.infra.util.jazzlib 中的 类
This class represents a Zip archive.
ZipFile(String) - 类 com.trs.infra.util.jazzlib.ZipFile 的构造方法
Opens a Zip file with the given name for reading.
ZipFile(String, String) - 类 com.trs.infra.util.jazzlib.ZipFile 的构造方法
Opens a Zip file with the given name for reading.
ZipFile(File) - 类 com.trs.infra.util.jazzlib.ZipFile 的构造方法
Opens a Zip file reading the given File.
ZipFile(File, int) - 类 com.trs.infra.util.jazzlib.ZipFile 的构造方法
Opens a Zip file reading the given File in the given mode.
zipFiles(List) - 类 com.trs.template.domain.TemplateXmlGenerator 中的静态方法
ZipInputStream - com.trs.infra.util.jazzlib 中的 类
This is a FilterInputStream that reads the files in an zip archive one after another.
ZipInputStream(InputStream) - 类 com.trs.infra.util.jazzlib.ZipInputStream 的构造方法
Creates a new Zip input stream, reading a zip archive.
ZipOutputStream - com.trs.infra.util.jazzlib 中的 类
This is a FilterOutputStream that writes the files into a zip archive one after another.
ZipOutputStream(OutputStream) - 类 com.trs.infra.util.jazzlib.ZipOutputStream 的构造方法
Creates a new Zip output stream, writing a zip archive.
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


_ - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

_

_A_ARCH - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
_A_EXEC - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
_A_HIDDEN - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
_A_NAME_IS_UTF - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
_A_RDONLY - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
_A_SYSTEM - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
_getUserByName(String) - 接口 com.trs.cms.auth.persistent.IUserCacheMgr 中的方法
通过指定的用户名获取用户对象
_getUserByName(String) - 类 com.trs.cms.auth.persistent.UserCacheMgr 中的方法
概述 软件包 类 使用 树 已过时 索引 帮助
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


C - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

C

CabConstants - com.trs.infra.util.cabfile 中的 接口
CabEntry - com.trs.infra.util.cabfile 中的 类
CabFile - com.trs.infra.util.cabfile 中的 类
CabFile(File) - 类 com.trs.infra.util.cabfile.CabFile 的构造方法
CabFile(String) - 类 com.trs.infra.util.cabfile.CabFile 的构造方法
CABFileExtractor - com.trs.components.infoview 中的 类
TODO Add javadoc for CABFileExtractor
CABFileExtractor() - 类 com.trs.components.infoview.CABFileExtractor 的构造方法
TODO Add javadoc for CABFileExtractor
cachedLogtype(OperType) - 类 com.trs.infra.support.log.LogServer 中的静态方法
CachedObjectConfig - com.trs.infra.persistent.cache 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CachedObjectConfig() - 类 com.trs.infra.persistent.cache.CachedObjectConfig 的构造方法
CachedPOMgr - com.trs.infra.persistent.cache 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
被缓冲的持久化对象的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CachedPOMgr() - 类 com.trs.infra.persistent.cache.CachedPOMgr 的构造方法
CacheMgrConfig - com.trs.infra.support.cache 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CacheMgrConfig() - 类 com.trs.infra.support.cache.CacheMgrConfig 的构造方法
cacheResults(int, CMyResultSets) - 类 com.trs.components.wcm.stat.StatResultHolder 中的方法
CacheServer - com.trs.infra.support.cache 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
系统缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CacheServer() - 类 com.trs.infra.support.cache.CacheServer 的构造方法
CACHESIZE_DEFAULT - 类 com.trs.infra.util.database.DBIdManager.IdSeq 中的静态变量
caclulateHitsBonus(int) - 类 com.trs.components.stat.BonusCalculator 中的方法
根据点击量，计算点击量所获奖金
caclulateHitsBonus(int) - 接口 com.trs.components.stat.IBonusCalculator 中的方法
根据点击量，计算点击量所获奖金
caclulateIssuedAmountBonus(int) - 类 com.trs.components.stat.BonusCalculator 中的方法
根据发稿量，计算发稿量所获奖金
caclulateIssuedAmountBonus(int) - 接口 com.trs.components.stat.IBonusCalculator 中的方法
根据发稿量，计算发稿量所获奖金
CalculatedField - com.trs.components.infoview.extract.manifest 中的 类
/xsf:xDocumentClass/xsf:calculations/xsf:calculatedField
CalculatedField() - 类 com.trs.components.infoview.extract.manifest.CalculatedField 的构造方法
calFullDataPath(IPublishElement, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的静态方法
Returns the full data path from the specified element to root.
calFullDataPath(IPublishFolder, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的静态方法
Returns the full data path from the specified folder to root.
calFullDataPath(IPublishContent, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的静态方法
Returns the full data path from the specified content to folder root.
callByCluster(Object, Member) - 类 com.trs.cluster.TRSClusterExtensionImpl 中的方法
calMaxLaborNeeded(int, int) - 接口 com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr 中的方法
calculate the maximum count of the labor needed to finish the specified task
calMaxLaborNeeded(int, int) - 类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 中的方法
calculate the maximum count of the labor needed to finish the specified task
calParentRelativePath(String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
Calculates the parent relative path of current child.
calRelativePath(String, String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
Calculates the relative path between two urls.
calSubDirectory(IPublishContent, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的静态方法
Calculates the sub directory of the specified content in its home.
canAuth() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法
判断SMTP服务器的设置，是否能够进行身份验证
cancel() - 类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 中的方法
cancel the task work
cancel() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法
cancel the analyzer
cancel() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
cancel the task work
cancelArgVal(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
cancelDocTopicRelation(int, int) - 类 com.trs.components.comment.service.CommentService 中的方法
cancelDocTopicRelation(int, int) - 接口 com.trs.components.comment.service.ICommentService 中的方法
cancelShare(Event, CMSObj) - 类 com.trs.components.common.calendar.EventMgr 中的方法
取消对象某用户/组织的一个日程安排
cancelShare(Event, User) - 接口 com.trs.service.IEventService 中的方法
取消指派给另外一个用户的Event
cancelShare(Event, Users) - 接口 com.trs.service.IEventService 中的方法
取消指派给一个用户集合的Event
cancelShare(Event, Group) - 接口 com.trs.service.IEventService 中的方法
取消指派给另外一个组织的Event
cancelShare(Event, User) - 类 com.trs.service.impl.EventService 中的方法
cancelShare(Event, Users) - 类 com.trs.service.impl.EventService 中的方法
cancelShare(Event, Group) - 类 com.trs.service.impl.EventService 中的方法
cancelShares(int, CMSBaseObjs) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
cancelShares(Event) - 类 com.trs.components.common.calendar.EventMgr 中的方法
取消指定的Event所有指派
cancelShares(int, String) - 接口 com.trs.service.IBookMarkService 中的方法
取消共享
cancelShares(Event) - 接口 com.trs.service.IEventService 中的方法
取消所有共享
cancelShares(int, String) - 类 com.trs.service.impl.BookMarkService 中的方法
cancelShares(Event) - 类 com.trs.service.impl.EventService 中的方法
cancelTask(PublishTask) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
cancel the publish task if it has not been finished
cancelTask(PublishTasks) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
cancel each publish task in the collection
cancelTask(int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
cancel a publish task by the specified id
cancelTask(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
cancelTask(int) - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法
cancelTasks(String) - 类 com.trs.service.impl.PublishService 中的方法
cancelTasks(String) - 接口 com.trs.service.IPublishService 中的方法
取消指定的发布任务集合
cancelUpdate() - 类 com.trs.ajaxservice.xmlconvertors.XMLToCMSObj 中的方法
cancelUpdate() - 类 com.trs.cms.content.CMSBaseObjs 中的方法
取消当前元素的修改操作
cancelUpdate(User) - 类 com.trs.cms.content.CMSObj 中的方法
撤销更新操作，清除更新缓冲区
cancelUpdate(User) - 接口 com.trs.cms.process.IFlowContent 中的方法
取消本次更新
cancelUpdate(User) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
cancelUpdate(User) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
cancelUpdate() - 类 com.trs.infra.persistent.BaseObj 中的方法
撤销更新操作，清除更新缓冲区
cancelUpdate() - 类 com.trs.infra.persistent.BaseObjs 中的方法
取消当前元素的修改操作
cancelUpdateAll(int) - 类 com.trs.cms.content.CMSBaseObjs 中的方法
取消集合中指定数量的元素的修改记录
cancelUpdateAll() - 类 com.trs.cms.content.CMSBaseObjs 中的方法
cancelUpdateAll(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
取消集合中指定数量的元素的修改记录
cancelUpdateAll() - 类 com.trs.infra.persistent.BaseObjs 中的方法
canDelDoc() - 类 com.trs.cms.process.definition.FlowNode 中的方法
判断是否可以在此节点上删除文档
canDoAddDoc() - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
canDoBatchDetailPageTask() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
canDoBatchDetailPageTask() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
canDoBatchDetailPageTask() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
canDoBatchDetailPageTask() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
canDoBatchDetailPageTask() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
canDoBatchDetailPageTask() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
canDoDetailPageTask() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
check if can create detail page task
canDoDetailPageTask() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
canDoDetailPageTask() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
canDoDetailPageTask() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
canDoDetailPageTask() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
canDoDetailPageTask() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
canDoOperteOnNotEmpty(int) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
canDoOutlinePageTask() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
check if can create outline page task
canDoOutlinePageTask() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
canDoOutlinePageTask() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
canDoOutlinePageTask() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
canDoOutlinePageTask() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
canDoOutlinePageTask() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
canDoPreview() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
判断发布元素是否可以预览
canDoPreview() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
canDoPreview() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
canDoPreview() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法
canDoPreview() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
canDoPreview() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
canDoPreview() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
canDoPreview() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
canDoPreview(Document) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
canDoPub() - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
canDoSetRight(User) - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法
canDoSetRight(User) - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法
canDoSetRight(User) - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法
canDropField() - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
canDropField() - 类 com.trs.infra.util.database.DB2UDB 中的方法
canDropField() - 类 com.trs.infra.util.database.DB2UDB2 中的方法
canDropField() - 类 com.trs.infra.util.database.DB2UDBV9 中的方法
canDropField() - 类 com.trs.infra.util.database.DBType 中的方法
使用的数据数据库是否可以删除某个表中的列.
canDropField() - 类 com.trs.infra.util.database.MysqlDB 中的方法
canDropField() - 类 com.trs.infra.util.database.OracleDB 中的方法
canDropField() - 类 com.trs.infra.util.database.SQLServerDB 中的方法
canDropField() - 类 com.trs.infra.util.database.SybaseASE 中的方法
canDropField() - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
canEdit() - 类 com.trs.cms.content.CMSBaseObjs 中的方法
检查当前元素是否可以修改；若可以修改，则锁定该元素
canEdit(int) - 类 com.trs.cms.content.CMSBaseObjs 中的方法
检查当前元素是否可以修改；若可以修改，则锁定该元素
canEdit(User, int) - 类 com.trs.cms.content.CMSObj 中的方法
检测是否允许编辑，在指定的时间内锁定对象
canEdit(User) - 类 com.trs.cms.content.CMSObj 中的方法
canEdit(User) - 接口 com.trs.cms.process.IFlowContent 中的方法
判断当前操作用户是否可以对当前流转的内容进行修改
canEdit(User) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
canEdit(User) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
canEdit(User) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
canEditAll() - 类 com.trs.cms.content.CMSBaseObjs 中的方法
检查当前集合中是否都可以进行编辑；若可以修改，则锁定该集合中所有元素
canEditDoc() - 类 com.trs.cms.process.definition.FlowNode 中的方法
判断是否可以在此节点上修改文档
canFtpUpload() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
判断站点是否需要上传文件
canInFlow() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
canOperate(User, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
判断当前用户对于指定对象是否可操作
canOperate(Group, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
判断当前组织对于指定对象是否可操作
canOperate(Role, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
判断当前角色对于指定对象是否可操作
canOperate(CMSObj, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
判断当前操作者对于指定对象是否可操作
canOperate(User, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
canOperate(Group, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
canOperate(Role, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
canOperate(CMSObj, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
canPub(String) - 类 com.trs.wcmonline.WCMOnlineService 中的方法
canPubDoc() - 类 com.trs.cms.process.definition.FlowNode 中的方法
判断是否可以在此节点上发布文档
canReInFlow() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
canReLogin(User, String, String) - 类 com.trs.presentation.util.LoginHelper 中的方法
canSort() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
是否排序有效
canSort() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
是否排序有效
canStopFlow() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
canWriteTextDirectly() - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
判断是否可以直接写入大文本
canWriteTextDirectly() - 类 com.trs.infra.util.database.DB2UDB 中的方法
判断是否可以直接写入大文本
canWriteTextDirectly() - 类 com.trs.infra.util.database.DB2UDB2 中的方法
判断是否可以直接写入大文本
canWriteTextDirectly() - 类 com.trs.infra.util.database.DBType 中的方法
判断是否可以直接写入大文本
canWriteTextDirectly() - 类 com.trs.infra.util.database.MysqlDB 中的方法
判断是否可以直接写入大文本
canWriteTextDirectly() - 类 com.trs.infra.util.database.OracleDB 中的方法
判断是否可以直接写入大文本
canWriteTextDirectly() - 类 com.trs.infra.util.database.SQLServerDB 中的方法
判断是否可以直接写入大文本
canWriteTextDirectly() - 类 com.trs.infra.util.database.SybaseASE 中的方法
canWriteTextDirectly() - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
capitalize(String) - 类 com.trs.infra.util.CMyString 中的静态方法
CAPTION - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
CAS400CLOB - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CAS400CLOB() - 类 com.trs.infra.util.database.CAS400CLOB 的构造方法
默认构造函数
catchException(String, Exception, boolean) - 异常 com.trs.infra.common.WCMException 中的静态方法
CATEGORY_BAR - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态变量
CATEGORY_PIE - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态变量
CAUserSync - com.trs.presentation.ids 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
园林局项目定制:CA用户信息同步实现
Copyright: Copyright (c) 2002-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
CAUserSync() - 类 com.trs.presentation.ids.CAUserSync 的构造方法
CAUserSync.UserInfo - com.trs.presentation.ids 中的 类
用户的相关信息.
CAUserSync.UserInfo(String) - 类 com.trs.presentation.ids.CAUserSync.UserInfo 的构造方法
CDB2DBCLOB - com.trs.infra.util.database 中的 类
CDB2DBCLOB() - 类 com.trs.infra.util.database.CDB2DBCLOB 的构造方法
默认构造函数
CDB2DBCLOB2 - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CDB2DBCLOB2() - 类 com.trs.infra.util.database.CDB2DBCLOB2 的构造方法
默认构造函数
CDBKeyWords - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
从配置文件中读取数据库关键字，提供相关的有效性检验等操作 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CDBKeyWords() - 类 com.trs.infra.util.database.CDBKeyWords 的构造方法
CDBText - com.trs.infra.util.database 中的 类
CDBText(int) - 类 com.trs.infra.util.database.CDBText 的构造方法
构造函数
CDBText(int, String) - 类 com.trs.infra.util.database.CDBText 的构造方法
构造函数
CDBText(DBType, String) - 类 com.trs.infra.util.database.CDBText 的构造方法
CDBText(DBType) - 类 com.trs.infra.util.database.CDBText 的构造方法
CDSServiceImpl - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
CDS Service
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CDSServiceImpl() - 类 com.trs.service.impl.CDSServiceImpl 的构造方法
CellInfo - com.trs.components.wcm.publish.region 中的 类
CellInfo() - 类 com.trs.components.wcm.publish.region.CellInfo 的构造方法
构造函数：保留默认接口
CellInfos - com.trs.components.wcm.publish.region 中的 类
CellInfos(User) - 类 com.trs.components.wcm.publish.region.CellInfos 的构造方法
构造函数
CellInfos(User, int, int) - 类 com.trs.components.wcm.publish.region.CellInfos 的构造方法
构造函数
CELLPADDING - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
CellServiceProvider - com.trs.components.wcm.publish.region 中的 类
CellServiceProvider() - 类 com.trs.components.wcm.publish.region.CellServiceProvider 的构造方法
CELLSPACING - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
CellsSaveListenerForPublish - com.trs.components.wcm.publish.region 中的 类
CellsSaveListenerForPublish() - 类 com.trs.components.wcm.publish.region.CellsSaveListenerForPublish 的构造方法
CENTER - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
cfhdrNEXT_CABINET - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
cfhdrPREV_CABINET - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
cfhdrRESERVE_PRESENT - 接口 com.trs.infra.util.cabfile.CabConstants 中的静态变量
changeChnnlOfInfoviewDatasaveInfoViewData(int, Document, ChnlDoc) - 类 com.trs.components.infoview.db.InfoViewDBStoreServer 中的方法
changeDir(String, boolean) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
更改本地或FTP服务器上的当前默认目录
changeDirs(String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
更改FTP服务器的当前目录，如果包含的子目录不存在，则自动创建子目录
changeDocumentsStatus(Documents, Channel, Status) - 接口 com.trs.service.IDocumentService 中的方法
修改指定文档的文档状态(新稿、已发等)
changeDocumentsStatus(Documents, Channel, Status) - 类 com.trs.service.impl.DocumentService 中的方法
changeDocumentStatus(Document, Channel, Status) - 接口 com.trs.service.IDocumentService 中的方法
修改指定文档的文档状态(新稿、已发等)
changeDocumentStatus(Document, Channel, Status) - 类 com.trs.service.impl.DocumentService 中的方法
changeGroup(Contact, ContactGrp, ContactGrp) - 类 com.trs.components.common.address.ContactMgr 中的方法
更改联系人所在的分组
changeGroup(int, int, int) - 接口 com.trs.service.IContactService 中的方法
更改联系人所在的分组
changeGroup(Contact, ContactGrp, ContactGrp) - 接口 com.trs.service.IContactService 中的方法
更改联系人所在的分组
changeGroup(int, int, int) - 类 com.trs.service.impl.ContactService 中的方法
changeGroup(Contact, ContactGrp, ContactGrp) - 类 com.trs.service.impl.ContactService 中的方法
changeOrder(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
调整栏目顺序
changeOrder(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
changeOrder(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
改变属性
changeOrder(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
调整栏目顺序
changeOrder(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetParameterServiceProvider 中的方法
改变资源变量的顺序
changeOrder(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 中的方法
changeOrder(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
调整分类法顺序
changeStatus(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
改变多篇文档的状态
changeStatus(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
改变多篇文档的状态
changeStatus(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
改变多篇文档的状态
changeStatus(Document, Channel, Status) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
修改ChnlDoc中对应的状态
如果是实体文档，则同步状态
changeStatus(Document, Channel, int) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
changeStatus(int, ChnlDoc) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
改变文档在指定频道下的状态
changeTaskPriority(int, int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
改变任务的优先级别，如果任务不是正在执行则什么都不作
changeTaskPriority(int, int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
changeTaskPriority(int, int) - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法
changeTempName() - 类 com.trs.scene.tools.SceneAutoCreator 中的方法
changeUserRegStatus(User, int) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
更改用户的注册状态
changeViewFieldOrder(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
改变视图字段的顺序
Channel - com.trs.components.wcm.content.persistent 中的 类
Channel() - 类 com.trs.components.wcm.content.persistent.Channel 的构造方法
构造函数：保留默认接口
CHANNEL_GROUP_TYPE - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
ChannelAuthHelper - com.trs.components.wcm.auth 中的 类
ChannelAuthHelper() - 类 com.trs.components.wcm.auth.ChannelAuthHelper 的构造方法
ChannelContentLink - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelContentLink() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 的构造方法
构造函数：保留默认接口
ChannelContentLinks - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelContentLinks(User) - 类 com.trs.components.wcm.content.persistent.ChannelContentLinks 的构造方法
ChannelContentLinks(User, int, int) - 类 com.trs.components.wcm.content.persistent.ChannelContentLinks 的构造方法
ChannelCreateFromListenerForMetaView - com.trs.components.metadata.service.listener 中的 类
ChannelCreateFromListenerForMetaView() - 类 com.trs.components.metadata.service.listener.ChannelCreateFromListenerForMetaView 的构造方法
ChannelCreateFromLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelCreateFromLogger() - 类 com.trs.ajaxservice.logger.ChannelCreateFromLogger 的构造方法
ChannelDocListenerForPublish - com.trs.components.wcm.publish.region 中的 类
ChannelDocListenerForPublish() - 类 com.trs.components.wcm.publish.region.ChannelDocListenerForPublish 的构造方法
ChannelExporter - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点/导出对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelExporter() - 类 com.trs.components.wcm.content.domain.ChannelExporter 的构造方法
ChannelExporter(String, String) - 类 com.trs.components.wcm.content.domain.ChannelExporter 的构造方法
ChannelHelper - com.trs.ajaxservice 中的 类
ChannelHelper() - 类 com.trs.ajaxservice.ChannelHelper 的构造方法
ChannelHitsCountHandler - com.trs.components.stat 中的 类
ChannelHitsCountHandler() - 类 com.trs.components.stat.ChannelHitsCountHandler 的构造方法
ChannelImporter - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
从XML文件中导入站点/频道数据
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelImporter() - 类 com.trs.components.wcm.content.domain.ChannelImporter 的构造方法
ChannelImportLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
导入频道操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelImportLogger() - 类 com.trs.ajaxservice.logger.ChannelImportLogger 的构造方法
ChannelLCListener4EPress - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
栏目删除监听
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ChannelLCListener4EPress() - 类 com.trs.components.wcm.epress.ChannelLCListener4EPress 的构造方法
ChannelLCListenerForChannelSyn - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
监控频道被删除时，同步删除与该频道相关的频道分发设置 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelLCListenerForChannelSyn() - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForChannelSyn 的构造方法
ChannelLCListenerForDocument - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
与文档相关的栏目生命周期监听处理.
ChannelLCListenerForDocument() - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForDocument 的构造方法
ChannelLCListenerForExtField - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelLCListenerForExtField() - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForExtField 的构造方法
ChannelLCListenerForFlow - com.trs.components.wcm.process 中的 类
在频道假删除（频道即如回收站）时，删除所有正在流转和已经流转结束的文档
ChannelLCListenerForFlow() - 类 com.trs.components.wcm.process.ChannelLCListenerForFlow 的构造方法
缺省构造方法
ChannelLCListenerForSpeical - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
ChannelLCListenerForSpeical() - 类 com.trs.components.wcm.content.domain.ChannelLCListenerForSpeical 的构造方法
ChannelListenerForPublish - com.trs.components.wcm.publish.region 中的 类
ChannelListenerForPublish() - 类 com.trs.components.wcm.publish.region.ChannelListenerForPublish 的构造方法
ChannelLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
栏目对象操作日志记录者
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ChannelLogger() - 类 com.trs.components.wcm.logger.ChannelLogger 的构造方法
ChannelLoopValidator - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
父子关系的回路检测器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelLoopValidator() - 类 com.trs.components.wcm.content.persistent.ChannelLoopValidator 的构造方法
ChannelMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理栏目/站点相关的行为和操作
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelMgr() - 类 com.trs.components.wcm.content.domain.ChannelMgr 的构造方法
constructor: default
ChannelMoveLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ChannelMoveLogger() - 类 com.trs.ajaxservice.logger.ChannelMoveLogger 的构造方法
ChannelNameMgr - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
频道名称缓冲管理(LRU缓冲算法)
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelNameMgr() - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 的构造方法
构造函数
ChannelNavHandler - com.trs.presentation.nav 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelNavHandler() - 类 com.trs.presentation.nav.ChannelNavHandler 的构造方法
ChannelPorterVisitorForMetaView - com.trs.components.metadata.service.portervisitors 中的 类
ChannelPorterVisitorForMetaView() - 类 com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView 的构造方法
ChannelRelated - com.trs.components.wcm.wcmx.websites 中的 类
ChannelRelated() - 类 com.trs.components.wcm.wcmx.websites.ChannelRelated 的构造方法
ChannelRightHostImpl - com.trs.components.wcm.content.domain.auth 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelRightHostImpl() - 类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 的构造方法
ChannelRightHostImpl(int) - 类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 的构造方法
ChannelRightHostImpl(CMSObj) - 类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 的构造方法
ChannelRightObjImpl - com.trs.components.wcm.auth 中的 类
ChannelRightObjImpl() - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 的构造方法
Channels - com.trs.components.wcm.content.persistent 中的 类
Channels(User) - 类 com.trs.components.wcm.content.persistent.Channels 的构造方法
Channels(User, int, int) - 类 com.trs.components.wcm.content.persistent.Channels 的构造方法
ChannelService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ChannelService() - 类 com.trs.service.impl.ChannelService 的构造方法
ChannelServiceProvider - com.trs.ajaxservice 中的 类
ChannelServiceProvider() - 类 com.trs.ajaxservice.ChannelServiceProvider 的构造方法
ChannelServiceProviderHelper - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelServiceProviderHelper() - 类 com.trs.ajaxservice.ChannelServiceProviderHelper 的构造方法
ChannelsTemplateSetting - com.trs.template.domain.setting 中的 类
ChannelsTemplateSetting() - 类 com.trs.template.domain.setting.ChannelsTemplateSetting 的构造方法
ChannelSubstanceImplBase - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelSubstanceImplBase() - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 的构造方法
ChannelSubstanceImplBase(int) - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 的构造方法
ChannelSubstanceImplBase(CMSObj) - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 的构造方法
ChannelsWithRightMaker - com.trs.components.wcm.content.trsserver 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户具有指定权限的栏目构造器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelsWithRightMaker(User, int) - 类 com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker 的构造方法
ChannelSyn - com.trs.components.wcm.content.persistent 中的 类
ChannelSyn() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 的构造方法
构造函数：保留默认接口
ChannelSyns - com.trs.components.wcm.content.persistent 中的 类
ChannelSyns(User) - 类 com.trs.components.wcm.content.persistent.ChannelSyns 的构造方法
构造函数
ChannelSyns(User, int, int) - 类 com.trs.components.wcm.content.persistent.ChannelSyns 的构造方法
构造函数
ChannelSynToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档同步XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelSynToXML() - 类 com.trs.ajaxservice.xmlconvertors.ChannelSynToXML 的构造方法
ChannelToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
栏目XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelToXML() - 类 com.trs.ajaxservice.xmlconvertors.ChannelToXML 的构造方法
ChannelXmlConverter - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
站点/频道到XML转换的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChannelXmlConverter(String, String) - 类 com.trs.components.wcm.content.persistent.ChannelXmlConverter 的构造方法
CHAR - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：CHAR
CHAR - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：CHAR
CHAR - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：CHAR
CHAR - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
CHAR - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：CHAR
CHAR - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：CHAR
CHAR - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：CHAR
CHAR - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：CHAR
char2hex(int) - 类 com.trs.infra.util.file.JavaScriptEscape 中的静态方法
characters(char[], int, int) - 类 com.trs.cms.content.WCMHandler 中的方法
characters(char[], int, int) - 类 com.trs.cms.content.WCMObjsHandler 中的方法
characters(char[], int, int) - 类 com.trs.infra.persistent.BaseObjHandler 中的方法
characters(char[], int, int) - 类 com.trs.infra.persistent.BaseObjsHandler 中的方法
characters(char[], int, int) - 类 com.trs.infra.util.CMyXMLHandler 中的方法
characters(char[], int, int) - 类 com.trs.webframework.controler.PostDataParser 中的方法
characters(char[], int, int) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法
CharsetDetector - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文件编码探测工具依赖于(chardet.jar)Mozzila的算法实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CharsetDetector() - 类 com.trs.infra.util.CharsetDetector 的构造方法
CharSetFilter - com.trs.servlet 中的 类
CharSetFilter() - 类 com.trs.servlet.CharSetFilter 的构造方法
ChartBuildException - com.trs.components.wcm.stat.domain 中的 异常
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChartBuildException() - 异常 com.trs.components.wcm.stat.domain.ChartBuildException 的构造方法
ChartBuildException(String) - 异常 com.trs.components.wcm.stat.domain.ChartBuildException 的构造方法
ChartBuildException(Throwable) - 异常 com.trs.components.wcm.stat.domain.ChartBuildException 的构造方法
ChartBuildException(String, Throwable) - 异常 com.trs.components.wcm.stat.domain.ChartBuildException 的构造方法
ChartConstants - com.trs.components.wcm.stat.domain 中的 类
ChartOption - com.trs.components.wcm.stat.domain 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChartOption(CMyDateTime, CMyDateTime, int, String) - 类 com.trs.components.wcm.stat.domain.ChartOption 的构造方法
ChartOption(CMyDateTime, CMyDateTime, int, String, String, String) - 类 com.trs.components.wcm.stat.domain.ChartOption 的构造方法
ChartStyle - com.trs.components.wcm.stat.domain 中的 类
ChartStyle() - 类 com.trs.components.wcm.stat.domain.ChartStyle 的构造方法
ChartWriter - com.trs.components.wcm.stat.domain 中的 类
ChartWriter() - 类 com.trs.components.wcm.stat.domain.ChartWriter 的构造方法
check(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
校验选中的模板
check(File) - 类 com.trs.tools.LocaleChecker 中的静态方法
checkChannelName(IPublishFolder, TagItem, StringBuffer) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfoHelper 中的静态方法
检查指定置标中使用的频道名称是否存在
checkClientTrusted(X509Certificate[], String) - 类 com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager 中的方法
checkConfigCounter(Class) - 类 com.trs.infra.util.ConfigElementContentTester 中的静态方法
检查指定Class的配置类的数目（即extension的直接子节点个数）
checkCssFlag(PageStyle, ContentStyle, String) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
在指定的系统风格下校验CssFlag是否唯一
checkCssFlag(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
在指定的系统风格下校验CssFlag是否唯一
checkCssFlag(PageStyle, ContentStyle, String) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
在指定的页面风格下校验当前内容风格的风格标识（CssFlag）是否唯一
checkCssFlag(PageStyle, ResourceStyle, String) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
在指定的系统风格下校验指定资源的风格标识（CssFlag）是否唯一
checkCssFlag(PageStyle, ResourceStyle, String) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
在指定的系统风格下校验CssFlag是否唯一
checkCssFlag(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
在指定的页面风格下校验CssFlag是否唯一
checkCssFlagOrNameCanUse(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
判断指定的风格标识和风格名称是否在指定的页面风格下存在
checkCssFlagOrNameCanUse(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
判断指定的风格标识和风格名称是否在指定的页面风格下存在
CHECKED - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
CheckedInputStream - com.trs.infra.util.jazzlib 中的 类
InputStream that computes a checksum of the data being read using a supplied Checksum object.
CheckedInputStream(InputStream, Checksum) - 类 com.trs.infra.util.jazzlib.CheckedInputStream 的构造方法
Creates a new CheckInputStream on top of the supplied OutputStream using the supplied Checksum.
CheckedOutputStream - com.trs.infra.util.jazzlib 中的 类
OutputStream that computes a checksum of data being written using a supplied Checksum object.
CheckedOutputStream(OutputStream, Checksum) - 类 com.trs.infra.util.jazzlib.CheckedOutputStream 的构造方法
Creates a new CheckInputStream on top of the supplied OutputStream using the supplied Checksum.
checkEncodeInfo(String, String) - 类 com.trs.presentation.util.LoginHelper 中的方法
checkEncodeInfoFromKey(String) - 类 com.trs.presentation.util.LoginHelper 中的方法
checkExistPageStyle(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
检查当前上传的zip文件中的PageStyle对象名称是否已经存在！
checkExists(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
在数据库中检查对象是否已经存在
checkExists(String, String) - 类 com.trs.wcmonline.WCMOnlineService 中的方法
checkGrammar(TagDocument, Report) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
检查模板置标树的语法
checkin(String, String, String, byte[]) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
checkin(String, String, String, byte[]) - 接口 com.trs.template.service.ITemplateService 中的方法
DW客户端上传模板
checkin(String, String, String, byte[]) - 类 com.trs.template.TRSTemplateFacade 中的方法
DW客户端上传模板
checkIsBeanValid(String, String) - 类 com.trs.infra.config.domain.BeanConfigHelper 中的静态方法
校验指定的beanId对应的SpringBean是否存在，
通常在设置和某一SpringBean相关联的配置对象属性时进行
checkIsBeanValid(String) - 类 com.trs.infra.config.domain.BeanConfigHelper 中的静态方法
校验指定的beanId对应的SpringBean是否存在，
通常在设置和某一SpringBean相关联的配置对象属性时进行
checkLexical(Template, Report) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
对模板的正文进行文法检查，如果没有文法错误，则返回模板置标树，如果存在文法错误， 则通过传入参数 _report 报告错误信息。
checkLocalLogin(HttpSession) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
checkLogin() - 类 com.trs.presentation.util.LoginHelper 中的方法
checkLogin(boolean) - 类 com.trs.presentation.util.LoginHelper 中的方法
checkOnlineUserUpdate() - 类 com.trs.presentation.util.LoginHelper 中的方法
checkout(String, String, String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
checkout(String, String, String) - 接口 com.trs.template.service.ITemplateService 中的方法
DW客户端下载模板
checkout(String, String, String) - 类 com.trs.template.TRSTemplateFacade 中的方法
DW客户端下载模板
checkPageStyleNameExists(String) - 类 com.trs.components.common.publish.widget.PageStyleImporter 中的方法
检查当前上传的zip文件中的PageStyle对象名称是否已经存在
checkPluginLogin() - 类 com.trs.presentation.util.LoginHelper 中的方法
checkSemantic(IPublishFolder, TagItem, StringBuffer) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
检查指定的置标实例的静态语义，如果有静态语义错误，则通过传入的StringBuffer对象返回错误信息。
checkSemantic(IPublishFolder, TagItem, StringBuffer) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation.TBI 中的方法
checkServerTrusted(X509Certificate[], String) - 类 com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager 中的方法
checkSQLValid(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
checkStyleDesc(PageStyle) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
判断是否已经存在同名的风格
checkStyleDesc(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
检查风格中文（显示）名称是否唯一
checkStyleName(PageStyle, ContentStyle, String) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
在指定的系统风格下校验风格名称是否唯一
checkStyleName(PageStyle, ContentStyle, String) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
在指定的页面风格下校验当前内容风格的风格名称（CssFlag）是否唯一
checkStyleName(PageStyle, ResourceStyle, String) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
在指定的系统风格下校验指定资源的风格名称（StyleName）是否唯一
checkStyleName(PageStyle) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
判断是否已经存在同名的风格
checkStyleName(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
检查风格英文名称是否唯一
checkStyleName(PageStyle, ResourceStyle, String) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
在指定的系统风格下校验风格名称是否唯一
Checksum - com.trs.infra.util.jazzlib 中的 接口
Interface to compute a data checksum used by checked input/output streams.
checkSysInfos(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
checkSysInfos(String, String) - 类 com.trs.service.impl.InfoViewDocImportService 中的方法
checkTagIn(String, String) - 类 com.trs.infra.util.html.HtmlElement 中的静态方法
判断指定的元素标记，是否在指定的标记列表中
checkTemplate(Template) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
检查模板语法正确性
checkTemplate(Template, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
checkTemplate(Template) - 类 com.trs.service.impl.TemplateParseService 中的方法
checkTemplate(Template) - 接口 com.trs.service.ITemplateParseService 中的方法
解析模板语法
checkTemplateText(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
校验指定的模板内容
checkUUID(MethodContext) - 类 com.trs.components.wcm.epress.EPressServiceProvider 中的方法
checkWCAG2TemplateText(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
ChildrenCacheMgr - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
子栏目管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChildrenCacheMgr() - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 的构造方法
ChineseFinder - com.trs.tools 中的 类
ChineseFinder() - 类 com.trs.tools.ChineseFinder 的构造方法
CHNL_ADD - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
添加频道
CHNL_BROWSE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
浏览频道
CHNL_DEL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除频道
CHNL_EDIT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
修改频道
CHNL_EXTEND - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
扩展字段
CHNL_MAX_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
频道权限index最大值
CHNL_MIN_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
频道权限Index最小值
CHNL_MOVE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
移动频道
CHNL_PREVIEW - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
预览频道首页
CHNL_PUB_ALL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
完全发布频道
CHNL_PUB_INC - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
增量发布频道 *
CHNL_RECYCLE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
废稿管理
CHNL_SETRIGHT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
设置频道的权限
CHNL_SETTEMPLATE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
设置频道的模板
CHNL_TYPE_NEWS - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
频道类型：头条新闻
CHNL_TYPE_PICS - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
频道类型：图片新闻
CHNL_TYPE_TRSKEY - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
CHNL_TYPE_X - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
频道类型：扩展类型频道
CHNL_TYPES - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态变量
系统中定义的所有的频道类型（不包括一般频道）
ChnlDept - com.trs.components.stat 中的 类
ChnlDept() - 类 com.trs.components.stat.ChnlDept 的构造方法
构造函数：保留默认接口
ChnlDeptMgr - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
ChnlDeptMgr() - 类 com.trs.components.stat.ChnlDeptMgr 的构造方法
ChnlDeptMgrForCluster - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDept缓冲处理.接收集群消息,根据相应的操作刷新缓冲.
ChnlDeptMgrForCluster() - 类 com.trs.components.stat.ChnlDeptMgrForCluster 的构造方法
ChnlDepts - com.trs.components.stat 中的 类
ChnlDepts(User) - 类 com.trs.components.stat.ChnlDepts 的构造方法
构造函数
ChnlDepts(User, int, int) - 类 com.trs.components.stat.ChnlDepts 的构造方法
构造函数
ChnlDoc - com.trs.components.wcm.content.persistent 中的 类
ChnlDoc() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 的构造方法
构造函数：保留默认接口
ChnlDocLCListener4ClassInfo - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ChnlDocLCListener4ClassInfo() - 类 com.trs.components.wcm.content.domain.ChnlDocLCListener4ClassInfo 的构造方法
ChnlDocLCListenerForAutoDocBak - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
监听ChnlDoc状态的修改,在满足一定条件时保存一个文档版本
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocLCListenerForAutoDocBak() - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForAutoDocBak 的构造方法
ChnlDocLCListenerForFlow - com.trs.components.wcm.process 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocLCListenerForFlow() - 类 com.trs.components.wcm.process.ChnlDocLCListenerForFlow 的构造方法
ChnlDocLCListenerForInfoViewDB - com.trs.components.infoview.db 中的 类
ChnlDocLCListenerForInfoViewDB() - 类 com.trs.components.infoview.db.ChnlDocLCListenerForInfoViewDB 的构造方法
ChnlDocLCListenerForPri - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc LC Listener For Document Pri
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocLCListenerForPri() - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForPri 的构造方法
ChnlDocLCListenerForRecordNotEntity - com.trs.components.wcm.content.domain 中的 类
ChnlDocLCListenerForRecordNotEntity() - 类 com.trs.components.wcm.content.domain.ChnlDocLCListenerForRecordNotEntity 的构造方法
ChnlDocLCListenerForSynToMetaData - com.trs.components.metadata.center 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocLCListenerForSynToMetaData() - 类 com.trs.components.metadata.center.ChnlDocLCListenerForSynToMetaData 的构造方法
ChnlDocLCListnerForPublish - com.trs.components.wcm.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc发布内容同步删除监控器，监控ChnlDoc修改前、修改后和删除后
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocLCListnerForPublish() - 类 com.trs.components.wcm.publish.ChnlDocLCListnerForPublish 的构造方法
ChnlDocLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
chnldoc日志记录(主要是记录顺序变更)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ChnlDocLogger() - 类 com.trs.components.wcm.logger.ChnlDocLogger 的构造方法
ChnlDocs - com.trs.components.wcm.content.persistent 中的 类
ChnlDocs(User) - 类 com.trs.components.wcm.content.persistent.ChnlDocs 的构造方法
构造函数
ChnlDocs(User, int, int) - 类 com.trs.components.wcm.content.persistent.ChnlDocs 的构造方法
构造函数
ChnlDocServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocServiceProvider() - 类 com.trs.ajaxservice.ChnlDocServiceProvider 的构造方法
ChnlDocToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
频道文档XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ChnlDocToXML() - 类 com.trs.ajaxservice.xmlconvertors.ChnlDocToXML 的构造方法
ChnlInit(Channel, User) - 类 com.trs.components.common.trsad.ADPos 中的方法
初始化栏目
ChnlInit(WebSite, User) - 类 com.trs.components.common.trsad.ADPos 中的方法
初始化站点
ChnlSynWorker - com.trs.components.wcm.content.domain 中的 类
ChnlSynWorker() - 类 com.trs.components.wcm.content.domain.ChnlSynWorker 的构造方法
解析参数
CImage - com.trs.infra.util 中的 类
Title: photo manager Description: Your description Copyright: Copyright (c) 1998 Company: trs
CImage() - 类 com.trs.infra.util.CImage 的构造方法
circleStr(String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串翻转：对于给定的字符串，按相反的顺序输出
CITE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
CKeyUtil - com.trs.infra.util.key 中的 类
Title: 网站内容管理（TRSWCM） Description: Copyright: Copyright (c) 2001 Company: www.trs.com.cn
CKeyUtil() - 类 com.trs.infra.util.key.CKeyUtil 的构造方法
CLASS - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
CLASS_NAME - 类 com.trs.components.wcm.util.SystemWarnerMsgImpl 中的静态变量
class full name
CLASS_VALIDATOR - 类 com.trs.webframework.controler.servlet.LoginValidatorFactory 中的静态变量
ClassDocumentsHelper - com.trs.components.metadata.center 中的 类
ClassDocumentsHelper() - 类 com.trs.components.metadata.center.ClassDocumentsHelper 的构造方法
ClassDocumentsHelperTest - com.trs.components.metadata.center 中的 类
ClassDocumentsHelperTest() - 类 com.trs.components.metadata.center.ClassDocumentsHelperTest 的构造方法
CLASSES_PATH_FLAG - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
CLASSES_PATH_FLAG - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
CLASSID - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
ClassInfo - com.trs.components.metadata.definition 中的 类
ClassInfo() - 类 com.trs.components.metadata.definition.ClassInfo 的构造方法
构造函数：保留默认接口
ClassInfo - com.trs.components.wcm.content.trsserver 中的 类
ClassInfo(ClassInfo) - 类 com.trs.components.wcm.content.trsserver.ClassInfo 的构造方法
构造函数
ClassInfoCacheMgr - com.trs.components.metadata.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
子栏目管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoCacheMgr() - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 的构造方法
ClassInfoChannelRightHelper - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分类法产生的栏目权限维护工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoChannelRightHelper() - 类 com.trs.components.metadata.service.ClassInfoChannelRightHelper 的构造方法
ClassInfoCountCacheForPublishImpl - com.trs.components.metadata.publish 中的 类
ClassInfoCountCacheForPublishImpl() - 类 com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl 的构造方法
ClassInfoImporter - com.trs.components.metadata.definition.xml 中的 类
ClassInfoImporter(User) - 类 com.trs.components.metadata.definition.xml.ClassInfoImporter 的构造方法
ClassInfoListenerForViewData - com.trs.components.metadata.definition 中的 类
ClassInfoListenerForViewData() - 类 com.trs.components.metadata.definition.ClassInfoListenerForViewData 的构造方法
ClassInfoMgr - com.trs.components.metadata.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoMgr() - 类 com.trs.components.metadata.definition.ClassInfoMgr 的构造方法
ClassInfoNavHandler - com.trs.presentation.nav 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoNavHandler() - 类 com.trs.presentation.nav.ClassInfoNavHandler 的构造方法
ClassInfoPublishServiceProvider - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分类法发布服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoPublishServiceProvider() - 类 com.trs.components.metadata.service.ClassInfoPublishServiceProvider 的构造方法
ClassInfos - com.trs.components.metadata.definition 中的 类
ClassInfos(User) - 类 com.trs.components.metadata.definition.ClassInfos 的构造方法
构造函数
ClassInfos(User, int, int) - 类 com.trs.components.metadata.definition.ClassInfos 的构造方法
构造函数
ClassInfoServiceProvider - com.trs.components.metadata.service 中的 类
ClassInfoServiceProvider() - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 的构造方法
ClassInfoServiceProviderForGB - com.trs.components.metadata.service 中的 类
ClassInfoServiceProviderForGB() - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 的构造方法
ClassInfoToChannelHelper - com.trs.components.metadata.service 中的 类
ClassInfoToChannelHelper() - 类 com.trs.components.metadata.service.ClassInfoToChannelHelper 的构造方法
ClassInfoToGroupCreator - com.trs.components.metadata.service 中的 类
ClassInfoToGroupCreator() - 类 com.trs.components.metadata.service.ClassInfoToGroupCreator 的构造方法
ClassInfoUtil - com.trs.components.metadata.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分类法定义工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoUtil() - 类 com.trs.components.metadata.definition.ClassInfoUtil 的构造方法
ClassInfoView - com.trs.components.metadata.center 中的 类
ClassInfoView() - 类 com.trs.components.metadata.center.ClassInfoView 的构造方法
构造函数：保留默认接口
ClassInfoViewMgr - com.trs.components.metadata.center 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理视图数据和分类法的关联影射
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ClassInfoViewMgr() - 类 com.trs.components.metadata.center.ClassInfoViewMgr 的构造方法
ClassInfoViews - com.trs.components.metadata.center 中的 类
ClassInfoViews(User) - 类 com.trs.components.metadata.center.ClassInfoViews 的构造方法
构造函数
ClassInfoViews(User, int, int) - 类 com.trs.components.metadata.center.ClassInfoViews 的构造方法
构造函数
ClassInfoViewService - com.trs.components.metadata.service 中的 类
ClassInfoViewService() - 类 com.trs.components.metadata.service.ClassInfoViewService 的构造方法
ClassInfoViewServiceProvider - com.trs.components.metadata.service 中的 类
ClassInfoViewServiceProvider() - 类 com.trs.components.metadata.service.ClassInfoViewServiceProvider 的构造方法
ClassInfoXMLConvertor - com.trs.components.metadata.definition.xml 中的 类
ClassInfoXMLConvertor() - 类 com.trs.components.metadata.definition.xml.ClassInfoXMLConvertor 的构造方法
cleanup() - 类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 中的方法
clear() - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
clear() - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法
clear() - 类 com.trs.cms.auth.persistent.AdministratorCacheMgr 中的方法
clear() - 类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 中的方法
clear() - 类 com.trs.cms.auth.persistent.GroupUserCacheMgr 中的方法
clear() - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 中的方法
clear() - 类 com.trs.cms.auth.persistent.UserCacheMgr 中的方法
clear() - 类 com.trs.cms.ContextHelper 中的静态方法
clear() - 类 com.trs.cms.process.definition.FlowCacheMgr 中的方法
clear() - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 中的方法
clear() - 类 com.trs.components.comment.publish.tagparser.XWCMTagParserComment 中的方法
clear() - 类 com.trs.components.common.message.MessageSendingMapper 中的方法
clear() - 类 com.trs.components.common.message.notify.NotificationServer 中的方法
clear() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的方法
clear() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
clear() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 中的方法
已过时。
clear() - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
clear() - 类 com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager 中的方法
clear() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
clear() - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
clear() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObjBase 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserCondition 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserDateTime 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserEcho 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParseResults 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserRepeat 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariable 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum 中的方法
clear() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet 中的方法
clear() - 类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 中的方法
clear() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishElementsIterator 中的方法
clear() - 类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 中的方法
clear the object
clear() - 类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 中的方法
clear() - 类 com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl 中的方法
clear() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法
clear() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
clear the resouce
clear() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
clear object data
clear() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法
clear() - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
clear() - 类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 中的方法
clear() - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法
clear() - 接口 com.trs.components.common.publish.persistent.element.IPublishElements 中的方法
Removes all the elements from this collection.
clear() - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 中的方法
clear() - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 中的方法
clear() - 类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 中的方法
clear() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoView 中的方法
clear() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData 中的方法
clear() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper 中的方法
clear() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav 中的方法
clear() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的方法
clear() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage 中的方法
clear() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的方法
clear() - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法
clear() - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法
clear() - 类 com.trs.components.metadata.publish.WCMTagParserAppendix 中的方法
clear() - 类 com.trs.components.metadata.publish.WCMTagParserClassIndexGener 中的方法
clear() - 类 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo 中的方法
clear() - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法
clear() - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
clear() - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
clear() - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
clear() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
clear() - 类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 中的方法
clear() - 类 com.trs.components.wcm.epress.TagEBookDirParser 中的方法
clear() - 类 com.trs.components.wcm.epress.TagMapAreaParser 中的方法
clear() - 类 com.trs.components.wcm.epress.TagParserPageNav 中的方法
clear() - 类 com.trs.components.wcm.epress.TagPreNextParser 中的方法
clear() - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 中的方法
clear() - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 中的方法
clear() - 类 com.trs.components.wcm.publish.region.WCMTagParserRegion 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.TagChannelChainParser 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.TagParserCRUser 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImage 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImages 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.TagWmlContentParser 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser 中的方法
clear() - 类 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration 中的方法
clear() - 类 com.trs.infra.common.BaseContextHelper 中的静态方法
clear() - 类 com.trs.infra.common.ContextTL 中的方法
clear() - 类 com.trs.infra.config.domain.ConfigObjectLoader 中的方法
回收
clear() - 类 com.trs.infra.db.QueryFilter 中的方法
清除过滤器的所有参数
clear() - 类 com.trs.infra.persistent.BaseObjs 中的方法
清空集合
clear() - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
clear() - 类 com.trs.infra.persistent.db.DBConnectionMapper 中的方法
clear() - 类 com.trs.infra.persistent.WCMFilter 中的方法
清除过滤器的所有参数
clear() - 接口 com.trs.infra.support.cache.ICacheMgr 中的方法
清除系统所有的Cache
clear() - 接口 com.trs.infra.support.cache.ICacheServer 中的方法
清除系统所有的Cache
clear() - 类 com.trs.infra.support.config.ConfigServer 中的方法
clear() - 类 com.trs.infra.support.config.PathConfig 中的方法
清除所有属性值
clear() - 类 com.trs.infra.util.CMyErrors 中的方法
清除错误列表
clear() - 类 com.trs.infra.util.CMyXMLElement 中的方法
clear() - 类 com.trs.infra.util.database.TableInfo 中的方法
清除所有数据
clear() - 类 com.trs.infra.util.database.TableInfos 中的方法
清除所有数据
clear() - 类 com.trs.infra.util.email.SMTPServerConfigMapper 中的方法
clear() - 类 com.trs.infra.util.ftp.FtpConnectionPool 中的方法
clear() - 类 com.trs.infra.util.ftp.FtpMgr 中的方法
clear() - 类 com.trs.infra.util.html.ContentLinkReplacer 中的方法
清除所有的链接映射项
CLEAR - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
clear() - 类 com.trs.infra.util.NamesRegister 中的方法
clear() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法
clear() - 类 com.trs.presentation.navigation.TreeItem 中的方法
clear() - 类 com.trs.template.persistent.InfoEntities 中的方法
clear() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
清空所有的资源
clear() - 类 com.trs.wcmonline.TagParserVipMetaData 中的方法
clear() - 类 com.trs.webframework.xmlserver.server.InvocationObserver 中的方法
clear() - 接口 com.trs.webframework.xmlserver.server.IObserver 中的方法
清除当前的信息
clear() - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法
clear() - 类 com.trsupdate.RightUpdaterForUser 中的方法
clearAll(User, BaseChannel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
清空回收站
clearAppendixes() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
clear all appendxes of this template
clearByEmployer(CMSObj) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
clearByEmployer(int, int) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
clearByInfoView(InfoView) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
clearByInfoView(int) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
clearCache() - 类 com.trs.cms.process.definition.FlowRule 中的方法
清除缓存
clearComplexFieldDatas(int) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
清除指定表单纪录所属的所有复合表单字段记录
clearCurrInfo() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
清空当前相关的资源
clearEmployer(User, Channel) - 接口 com.trs.components.metadata.center.IMetaViewEmployerMgr 中的方法
清除指定栏目所配置的视图关系
clearEmployer(User, MetaView) - 接口 com.trs.components.metadata.center.IMetaViewEmployerMgr 中的方法
清除指定视图所配置的使用关系
clearEmployer(User, Channel) - 类 com.trs.components.metadata.center.MetaViewEmployerMgr 中的方法
clearEmployer(User, MetaView) - 类 com.trs.components.metadata.center.MetaViewEmployerMgr 中的方法
clearEmploymentOfEmployer(IPublishElement, Template) - 类 com.trs.ajaxservice.TemplateEmployMgrHelper 中的静态方法
clearEmploysOfEmployer(BaseObj) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
clear all the employ records of the specified element
clearEmploysOfEmployer(int, int) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
clear all the employ records of the specified element
clearEmploysOfEmployer(IPublishElement) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
clear all the employ records of the specified element
clearEmploysOfEmployer(int, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
clear all the employ records of the specified element
clearEmploysOfFlow(Flow) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
clear all the employ records of the specified flow
clearEmploysOfFlow(int) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
clear all the employ records of the specified flow
clearEmploysOfTemplate(Template) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
clear all the employ records of the specified template
clearEmploysOfTemplate(int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
clear all the employ records of the specified template
clearInbox() - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法
清空收件箱
clearLogBaks() - 接口 com.trs.infra.support.log.ILogMgr 中的方法
clearLogBaks() - 类 com.trs.infra.support.log.LogMgr 中的方法
clearLogBaks() - 类 com.trs.infra.support.log.LogServer 中的静态方法
清空归档日志
警告:请慎重进行此操作,确定需要删除所有的归档日志
clearLoginErrNum(User) - 类 com.trs.presentation.util.LoginHelper 中的静态方法
将指定用户的登录失败次数清零
clearLogs() - 接口 com.trs.infra.support.log.ILogMgr 中的方法
clearLogs() - 类 com.trs.infra.support.log.LogMgr 中的方法
clearLogs() - 类 com.trs.infra.support.log.LogServer 中的静态方法
清空所有日志
警告:请慎重进行此操作,确定需要删除所有的日志
clearNestRecordsOf(Template) - 类 com.trs.components.common.publish.domain.template.TemplateNestMgr 中的方法
clear the nest records of the specified template
clearNestTemplateeContext() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
清空上一次保存的模板状态
clearOutbox() - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法
清空发件箱
clearQuotedImages(int) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
clearQuotedImages(int) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
clearQuotesOfFolder(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr 中的方法
Clears the quotes of the specified folder.
clearQuotesOfFolder(int, int) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr 中的方法
Clears the quotes of the specified folder.
clearQuotesOfFolder(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310 中的方法
Clears the quotes of the specified folder.
clearQuotesOfFolder(int, int) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310 中的方法
Clears the quotes of the specified folder.
clearRecycle(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
清空子栏目回收站
clearRecycle(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
恢复回收站中的文档
clearRecycle(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
清空回收站所有的文档
clearRecycle() - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
清空站点回收站
clearStatResult(int) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
删除统计视图对应的临时表中的数据
只有模板类视图才有临时表
clearStatResult(int) - 类 com.trs.service.impl.StatService 中的方法
clearStatResult(int) - 接口 com.trs.service.IStatService 中的方法
清除特定统计视图对应临时表中的数据
只有模板类视图才有临时表
clearTitleField(MetaView) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
清除视图oView下的标题字段,即原来是标题字段的，将不再作为标题字段
CLOB - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：CLOB
CLOB - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：CLOB
CLOB - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：CLOB
CLOB - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：CLOB
CLOB - 类 com.trs.infra.util.database.XuguDB 中的静态变量
clone() - 类 com.trs.components.common.job.Schedule 中的方法
对象复制
clone() - 类 com.trs.infra.db.QueryFilter 中的方法
过滤器的克隆
clone() - 类 com.trs.infra.persistent.BaseObj 中的方法
对象复制
clone() - 类 com.trs.infra.persistent.WCMFilter 中的方法
过滤器的克隆
clone() - 类 com.trs.infra.support.config.PathConfig 中的方法
对象克隆
clone() - 类 com.trs.infra.util.CMyBitsValue 中的方法
对象克隆
clone() - 类 com.trs.infra.util.CMyDateTime 中的方法
对象克隆
clone() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
对象克隆
clone() - 类 com.trs.infra.util.html.HtmlComment 中的方法
对象克隆
clone() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Clones the entry.
clone() - 类 com.trs.wcm.photo.ImageInfo 中的方法
cloneDocumentProperties(Document) - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法
cloneDocumentProperties(MetaViewData) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
cloneDocumentProperties(ViewDocument) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
cloneFile(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
cloneFromOtherFlow(MethodContext) - 类 com.trs.ajaxservice.SceneServiceProvider 中的方法
cloneProperties() - 类 com.trs.infra.persistent.BaseObj 中的方法
复制对象所有的属性
cloneToNewObj() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
由于视图字段的名称和元数据字段的名称可能不统一，在查看（findById)的时候，用 的是视图字段名称，而在保存（save）的时候用的是元数据字段名称，所以在此需要将视图字段的属性转化为元数据字段的属性
cloneToNewObj() - 类 com.trs.infra.persistent.BaseObj 中的方法
由对象复制成一个新对象
cloneToNewWCMObj() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
由对象复制成一个新对象
cloneToNewWCMObj() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
cloneToNewWCMObj() - 类 com.trs.infra.persistent.BaseObj 中的方法
已过时。
close() - 类 com.trs.infra.util.BASE64EncoderStream 中的方法
close() - 类 com.trs.infra.util.cabfile.CabFile 中的方法
close() - 类 com.trs.infra.util.database.ConnectionPool 中的方法
关闭所有连接
close() - 类 com.trs.infra.util.jazzlib.DeflaterOutputStream 中的方法
Calls finish () and closes the stream.
close() - 类 com.trs.infra.util.jazzlib.GZIPInputStream 中的方法
Closes the input stream
close() - 类 com.trs.infra.util.jazzlib.GZIPOutputStream 中的方法
Writes remaining compressed output data to the output stream and closes it.
close() - 类 com.trs.infra.util.jazzlib.InflaterInputStream 中的方法
Closes the input stream
close() - 类 com.trs.infra.util.jazzlib.ZipFile 中的方法
Closes the ZipFile.
close() - 类 com.trs.infra.util.jazzlib.ZipInputStream 中的方法
Closes the zip file.
close() - 类 com.trs.infra.util.XmlCharCheckedInputStream 中的方法
close() - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 中的方法
closeAllConnections() - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的方法
关闭所有连接
closeEntry() - 类 com.trs.infra.util.jazzlib.ZipInputStream 中的方法
Closes the current zip entry and moves to the next one.
closeEntry() - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
Closes the current entry.
ClusterConfigHelper - com.trs.cluster 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ClusterConfigHelper() - 类 com.trs.cluster.ClusterConfigHelper 的构造方法
ClusterConstants - com.trs.cluster 中的 类
ClusterConstants() - 类 com.trs.cluster.ClusterConstants 的构造方法
ClusterDBIdManager - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
集群对象ID获取(Compare and Write)
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ClusterDBIdManager() - 类 com.trs.infra.util.database.ClusterDBIdManager 的构造方法
ClusterLocker - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
集群对象锁定
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ClusterLocker(User, CMSObj) - 类 com.trs.cms.content.ClusterLocker 的构造方法
ClusterMsgCenterImpl - com.trs.cluster 中的 类
ClusterMsgCenterImpl() - 类 com.trs.cluster.ClusterMsgCenterImpl 的构造方法
ClusterSessionFileter - com.trs.infra 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
集群session管理
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ClusterSessionFileter() - 类 com.trs.infra.ClusterSessionFileter 的构造方法
CMSBaseObjs - com.trs.cms.content 中的 类
CMSBaseObjs() - 类 com.trs.cms.content.CMSBaseObjs 的构造方法
缺省构造函数
CMSBaseObjs(User) - 类 com.trs.cms.content.CMSBaseObjs 的构造方法
构造函数
CMSBaseObjs(User, int, int) - 类 com.trs.cms.content.CMSBaseObjs 的构造方法
构造函数（默认不指定容量，建立指定）
CMSConstants - com.trs.cms 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMSObj - com.trs.cms.content 中的 类
CMSObj() - 类 com.trs.cms.content.CMSObj 的构造方法
CMSObjDefaultImpl - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMSObjDefaultImpl(String, String) - 类 com.trs.cms.content.CMSObjDefaultImpl 的构造方法
CmsObjUnlockTools - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
unlock tools .
CmsObjUnlockTools() - 类 com.trs.presentation.util.CmsObjUnlockTools 的构造方法
CMy3WLib - com.trs.infra.util 中的 类
CMy3WLib() - 类 com.trs.infra.util.CMy3WLib 的构造方法
CMyBeanConfig - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyBeanConfig() - 类 com.trs.infra.util.CMyBeanConfig 的构造方法
CMyBitsValue - com.trs.infra.util 中的 类
CMyBitsValue() - 类 com.trs.infra.util.CMyBitsValue 的构造方法
默认构造函数，用0初始化
CMyBitsValue(long) - 类 com.trs.infra.util.CMyBitsValue 的构造方法
使用长整型数初始化的构造函数
CMyBitsValue(String) - 类 com.trs.infra.util.CMyBitsValue 的构造方法
使用字符串初始化的构造函数
CMyBitsValue(CMyBitsValue) - 类 com.trs.infra.util.CMyBitsValue 的构造方法
使用CMyBitsValue初始化的构造函数
CMyClassConfig - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyClassConfig() - 类 com.trs.infra.util.CMyClassConfig 的构造方法
CMyDateTime - com.trs.infra.util 中的 类
CMyDateTime() - 类 com.trs.infra.util.CMyDateTime 的构造方法
默认构造函数
CMyDateTime(long) - 类 com.trs.infra.util.CMyDateTime 的构造方法
使用长整型的数构造日期对象
CMyDecimalBuddy - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
提供浮点数的四则运算
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyDOM4jHelper - com.trs.infra.util 中的 类
CMyDOM4jHelper() - 类 com.trs.infra.util.CMyDOM4jHelper 的构造方法
CMyEmail - com.trs.infra.util.email 中的 类
CMyEmail() - 类 com.trs.infra.util.email.CMyEmail 的构造方法
默认构造函数
CMyEncrypt - com.trs.infra.util 中的 类
CMyEncrypt() - 类 com.trs.infra.util.CMyEncrypt 的构造方法
默认的构造函数
CMyErrors - com.trs.infra.util 中的 类
CMyErrors() - 类 com.trs.infra.util.CMyErrors 的构造方法
默认构造函数
CMyException - com.trs.infra.util 中的 异常
Title: TRS 内容协作平台（TRS WCM） Description: class CMyException —— 异常对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyException(int) - 异常 com.trs.infra.util.CMyException 的构造方法
构造函数
CMyException(int, String) - 异常 com.trs.infra.util.CMyException 的构造方法
构造函数
CMyException(String) - 异常 com.trs.infra.util.CMyException 的构造方法
构造函数
CMyException(int, String, Throwable) - 异常 com.trs.infra.util.CMyException 的构造方法
构造函数
CMyException(String, Throwable) - 异常 com.trs.infra.util.CMyException 的构造方法
构造函数
CMyFile - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class CMyFile —— 文件操作通用函数的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyFile() - 类 com.trs.infra.util.CMyFile 的构造方法
构造函数
CMyFilenameFilter - com.trs.infra.util 中的 类
CMyFilenameFilter(String) - 类 com.trs.infra.util.CMyFilenameFilter 的构造方法
CMyFileX - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyFileX() - 类 com.trs.infra.util.CMyFileX 的构造方法
CMyFtp - com.trs.infra.util.ftp 中的 类
CMyFtp() - 类 com.trs.infra.util.ftp.CMyFtp 的构造方法
默认构造函数
CMyKeyGenerator - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
密钥生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyKeyGenerator() - 类 com.trs.infra.util.CMyKeyGenerator 的构造方法
CMyMailException - com.trs.infra.util.email 中的 异常
Title: TRS 内容协作平台（TRS WCM）
Description:
邮件相关的异常信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyMailException() - 异常 com.trs.infra.util.email.CMyMailException 的构造方法
CMyMailException(String) - 异常 com.trs.infra.util.email.CMyMailException 的构造方法
CMyMailLog - com.trs.infra.util.email 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
邮件相关的日志信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyMailLog() - 类 com.trs.infra.util.email.CMyMailLog 的构造方法
CMyMemory - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyMemory() - 类 com.trs.infra.util.CMyMemory 的构造方法
CMyParameter - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
参数对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyParameter() - 类 com.trs.infra.persistent.CMyParameter 的构造方法
CMyParameter(String, String) - 类 com.trs.infra.persistent.CMyParameter 的构造方法
CMyResultObjs - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMResult基类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyResultObjs() - 类 com.trs.infra.persistent.CMyResultObjs 的构造方法
CMyResultObjs(int, int) - 类 com.trs.infra.persistent.CMyResultObjs 的构造方法
CMyResultSet - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
WCMResultSet
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyResultSet() - 类 com.trs.infra.persistent.CMyResultSet 的构造方法
构造函数：保留默认接口
CMyResultSets - com.trs.infra.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyResultSets() - 类 com.trs.infra.persistent.CMyResultSets 的构造方法
CMyResultSets(int, int) - 类 com.trs.infra.persistent.CMyResultSets 的构造方法
构造函数
CMySign - com.trs.infra.util 中的 类
签名和编码，仅供包内使用
CMySMS - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class CMySMS —— 用于手机发送短信息 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMySMS() - 类 com.trs.infra.util.CMySMS 的构造方法
默认的构造函数
CMySMTPServer - com.trs.infra.util.email 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
SMTP服务器及其的相关属性设置管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMySMTPServer() - 类 com.trs.infra.util.email.CMySMTPServer 的构造方法
CMySoapClient - com.trs.infra.util.soap 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
简易Soap请求
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMySoapClient() - 类 com.trs.infra.util.soap.CMySoapClient 的构造方法
CMysqlText - com.trs.infra.util.database 中的 类
CMysqlText() - 类 com.trs.infra.util.database.CMysqlText 的构造方法
CMyString - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class CMyString —— 字符串处理对象 Copyright: Copyright (c) 2001 Company: www.trs.com.cn
CMyString() - 类 com.trs.infra.util.CMyString 的构造方法
CMyTemplateWizard - com.trs.presentation.publish.template 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
模板置标添加向导
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyTemplateWizard() - 类 com.trs.presentation.publish.template.CMyTemplateWizard 的构造方法
CMyTimer - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class CMyFile —— 定时器对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CMyTimer(Runnable) - 类 com.trs.infra.util.CMyTimer 的构造方法
构造函数
CMyTransformCoding - com.trs.infra.util 中的 类
Title: 网站内容管理（TRSWCM） Description: Copyright: Copyright (c) 2001 Company: www.trs.com.cn
CMyTransformCoding() - 类 com.trs.infra.util.CMyTransformCoding 的构造方法
CMyUnzip - com.trs.infra.util 中的 类
CMyUnzip() - 类 com.trs.infra.util.CMyUnzip 的构造方法
CMyUnZipFile - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Zip文件解压对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyUnZipFile(String, String) - 类 com.trs.infra.util.CMyUnZipFile 的构造方法
CMyURLEncoder - com.trs.infra.util 中的 类
Utility class for HTML form encoding.
CMyXMLDoc - com.trs.infra.util 中的 类
CMyXMLDoc() - 类 com.trs.infra.util.CMyXMLDoc 的构造方法
CMyXMLElement - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
定义解析XML格式的配置文件后，各配置属性的存储数据结构 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyXMLElement() - 类 com.trs.infra.util.CMyXMLElement 的构造方法
CMyXMLHandler - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
处理XML配置文件，解析成为CMyXMLConfig Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyXMLHandler() - 类 com.trs.infra.util.CMyXMLHandler 的构造方法
CMyXMLHandler(Class) - 类 com.trs.infra.util.CMyXMLHandler 的构造方法
CMyXMLParser - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
根据XML配置文件解析成为CMyXMLConfig Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CMyXMLParser() - 类 com.trs.infra.util.CMyXMLParser 的构造方法
CMyZip - com.trs.infra.util 中的 类
CMyZip() - 类 com.trs.infra.util.CMyZip 的构造方法
CODE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
CODE - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
CODEBASE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
CODETYPE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
collateText(String) - 接口 com.trs.components.ckm.ICKMServer 中的方法
collateText(String) - 类 com.trs.components.ckm.TRSCKMServer 中的方法
COLOR - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
COLS - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
COLSPAN - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
Column - com.trs.infra.util.upgrade.dbcompare 中的 类
数据库表列描述对象
Column(String, int, String) - 类 com.trs.infra.util.upgrade.dbcompare.Column 的构造方法
构造函数
COLUMN_CLASS - 接口 com.trs.components.common.publish.widget.ILayoutGenerator 中的静态变量
布局列的class标识
com.trs.ajaxservice.listener - 软件包 com.trs.ajaxservice.listener
com.trs.ajaxservice.logger - 软件包 com.trs.ajaxservice.logger
com.trs.ajaxservice.xmlconvertors - 软件包 com.trs.ajaxservice.xmlconvertors
com.trs.cluster.receiver - 软件包 com.trs.cluster.receiver
com.trs.cms.auth.logger - 软件包 com.trs.cms.auth.logger
com.trs.cms.logger - 软件包 com.trs.cms.logger
com.trs.components.comment.domain - 软件包 com.trs.components.comment.domain
com.trs.components.comment.persistent - 软件包 com.trs.components.comment.persistent
com.trs.components.comment.publish.helper - 软件包 com.trs.components.comment.publish.helper
com.trs.components.comment.service - 软件包 com.trs.components.comment.service
com.trs.components.common.conjection.helper - 软件包 com.trs.components.common.conjection.helper
com.trs.components.common.conjection.service - 软件包 com.trs.components.common.conjection.service
com.trs.components.common.job - 软件包 com.trs.components.common.job
com.trs.components.common.publish.config.persistent - 软件包 com.trs.components.common.publish.config.persistent
com.trs.components.common.publish.domain.auth - 软件包 com.trs.components.common.publish.domain.auth
com.trs.components.common.publish.domain.element - 软件包 com.trs.components.common.publish.domain.element
com.trs.components.common.publish.persistent.distribute - 软件包 com.trs.components.common.publish.persistent.distribute
com.trs.components.common.publish.persistent.publisher - 软件包 com.trs.components.common.publish.persistent.publisher
com.trs.components.common.publish.persistent.taskdispatch - 软件包 com.trs.components.common.publish.persistent.taskdispatch
com.trs.components.common.publish.persistent.template - 软件包 com.trs.components.common.publish.persistent.template
com.trs.components.common.reminder - 软件包 com.trs.components.common.reminder
com.trs.components.common.trsad - 软件包 com.trs.components.common.trsad
com.trs.components.common.trsvote - 软件包 com.trs.components.common.trsvote
com.trs.components.filter - 软件包 com.trs.components.filter
com.trs.components.gkml.sqgk.constant - 软件包 com.trs.components.gkml.sqgk.constant
com.trs.components.gkml.sqgk.persistent - 软件包 com.trs.components.gkml.sqgk.persistent
com.trs.components.gkml.sqgk.process.element - 软件包 com.trs.components.gkml.sqgk.process.element
com.trs.components.gkml.sqgk.process.engine.creators - 软件包 com.trs.components.gkml.sqgk.process.engine.creators
com.trs.components.gkml.sqgk.process.engine.handlers - 软件包 com.trs.components.gkml.sqgk.process.engine.handlers
com.trs.components.govinfo - 软件包 com.trs.components.govinfo
com.trs.components.infoview.config - 软件包 com.trs.components.infoview.config
com.trs.components.infoview.filter - 软件包 com.trs.components.infoview.filter
com.trs.components.infoview.helper - 软件包 com.trs.components.infoview.helper
com.trs.components.infoview.mad - 软件包 com.trs.components.infoview.mad
com.trs.components.infoview.process - 软件包 com.trs.components.infoview.process
com.trs.components.metadata.right - 软件包 com.trs.components.metadata.right
com.trs.components.metadata.service.domain - 软件包 com.trs.components.metadata.service.domain
com.trs.components.metadata.service.listener - 软件包 com.trs.components.metadata.service.listener
com.trs.components.metadata.service.portervisitors - 软件包 com.trs.components.metadata.service.portervisitors
com.trs.components.metadata.service.util - 软件包 com.trs.components.metadata.service.util
com.trs.components.metadata.service.xmlconvertors - 软件包 com.trs.components.metadata.service.xmlconvertors
com.trs.components.metadata.web - 软件包 com.trs.components.metadata.web
com.trs.components.metadata.web.impl - 软件包 com.trs.components.metadata.web.impl
com.trs.components.wcm.auth - 软件包 com.trs.components.wcm.auth
com.trs.components.wcm.channel - 软件包 com.trs.components.wcm.channel
com.trs.components.wcm.content.service.portervisitors - 软件包 com.trs.components.wcm.content.service.portervisitors
com.trs.components.wcm.contentlink - 软件包 com.trs.components.wcm.contentlink
com.trs.components.wcm.customize - 软件包 com.trs.components.wcm.customize
com.trs.components.wcm.epress - 软件包 com.trs.components.wcm.epress
com.trs.components.wcm.individuation - 软件包 com.trs.components.wcm.individuation
com.trs.components.wcm.logger - 软件包 com.trs.components.wcm.logger
com.trs.components.wcm.newshoo - 软件包 com.trs.components.wcm.newshoo
com.trs.components.wcm.process.service.domain - 软件包 com.trs.components.wcm.process.service.domain
com.trs.components.wcm.process.service.flowexporter - 软件包 com.trs.components.wcm.process.service.flowexporter
com.trs.components.wcm.publish.domain - 软件包 com.trs.components.wcm.publish.domain
com.trs.components.wcm.publish.domain.job - 软件包 com.trs.components.wcm.publish.domain.job
com.trs.components.wcm.publish.logo - 软件包 com.trs.components.wcm.publish.logo
com.trs.components.wcm.publish.region - 软件包 com.trs.components.wcm.publish.region
com.trs.components.wcm.publish.tagparser.formater - 软件包 com.trs.components.wcm.publish.tagparser.formater
com.trs.components.wcm.recent - 软件包 com.trs.components.wcm.recent
com.trs.components.wcm.soap - 软件包 com.trs.components.wcm.soap
com.trs.components.wcm.stat.chart - 软件包 com.trs.components.wcm.stat.chart
com.trs.components.wcm.stat.domain - 软件包 com.trs.components.wcm.stat.domain
com.trs.components.wcm.util - 软件包 com.trs.components.wcm.util
com.trs.components.wcm.wcmx.common - 软件包 com.trs.components.wcm.wcmx.common
com.trs.components.wcm.wcmx.help - 软件包 com.trs.components.wcm.wcmx.help
com.trs.components.wcm.wcmx.jsp - 软件包 com.trs.components.wcm.wcmx.jsp
com.trs.components.wcm.wcmx.media - 软件包 com.trs.components.wcm.wcmx.media
com.trs.components.wcm.wcmx.util - 软件包 com.trs.components.wcm.wcmx.util
com.trs.components.wcm.wcmx.websites - 软件包 com.trs.components.wcm.wcmx.websites
com.trs.database.util - 软件包 com.trs.database.util
com.trs.db.schema - 软件包 com.trs.db.schema
com.trs.db.update - 软件包 com.trs.db.update
com.trs.devhelper - 软件包 com.trs.devhelper
com.trs.infra.common - 软件包 com.trs.infra.common
com.trs.infra.config - 软件包 com.trs.infra.config
com.trs.infra.config.domain - 软件包 com.trs.infra.config.domain
com.trs.infra.config.persistent - 软件包 com.trs.infra.config.persistent
com.trs.infra.db - 软件包 com.trs.infra.db
com.trs.infra.persistent.cache - 软件包 com.trs.infra.persistent.cache
com.trs.infra.persistent.util - 软件包 com.trs.infra.persistent.util
com.trs.infra.support.cache - 软件包 com.trs.infra.support.cache
com.trs.infra.support.config - 软件包 com.trs.infra.support.config
com.trs.infra.support.security - 软件包 com.trs.infra.support.security
定义和安全相关的一些对象和操作，诸如密钥的存储和管理。
com.trs.infra.update - 软件包 com.trs.infra.update
com.trs.infra.util.file - 软件包 com.trs.infra.util.file
com.trs.infra.util.ftp - 软件包 com.trs.infra.util.ftp
com.trs.infra.util.jazzlib - 软件包 com.trs.infra.util.jazzlib
com.trs.infra.util.job - 软件包 com.trs.infra.util.job
com.trs.infra.util.soap - 软件包 com.trs.infra.util.soap
com.trs.infra.util.uftp - 软件包 com.trs.infra.util.uftp
提供一个使用FTP、及FTP类似协议进行远程发布的统一接口.
com.trs.infra.util.upgrade - 软件包 com.trs.infra.util.upgrade
com.trs.infra.util.upgrade.dataprocess - 软件包 com.trs.infra.util.upgrade.dataprocess
com.trs.infra.util.upgrade.dbcompare - 软件包 com.trs.infra.util.upgrade.dbcompare
com.trs.infra.util.upgrade.sql - 软件包 com.trs.infra.util.upgrade.sql
com.trs.infra.util.xml - 软件包 com.trs.infra.util.xml
com.trs.km.auth - 软件包 com.trs.km.auth
com.trs.presentation.common - 软件包 com.trs.presentation.common
com.trs.presentation.documetimport.xml - 软件包 com.trs.presentation.documetimport.xml
com.trs.presentation.ids - 软件包 com.trs.presentation.ids
com.trs.presentation.login - 软件包 com.trs.presentation.login
com.trs.presentation.nav - 软件包 com.trs.presentation.nav
com.trs.presentation.navigation - 软件包 com.trs.presentation.navigation
com.trs.presentation.portal - 软件包 com.trs.presentation.portal
com.trs.presentation.right - 软件包 com.trs.presentation.right
com.trs.presentation.valid - 软件包 com.trs.presentation.valid
com.trs.servlet - 软件包 com.trs.servlet
com.trs.template.persistent - 软件包 com.trs.template.persistent
com.trs.upgrade - 软件包 com.trs.upgrade
com.trs.wcag2 - 软件包 com.trs.wcag2
com.trs.wcag2.validator - 软件包 com.trs.wcag2.validator
com.trs.wcm.config - 软件包 com.trs.wcm.config
com.trs.wcm.customize - 软件包 com.trs.wcm.customize
com.trs.wcm.old - 软件包 com.trs.wcm.old
com.trs.wcm.photo - 软件包 com.trs.wcm.photo
com.trs.wcm.photo.impl - 软件包 com.trs.wcm.photo.impl
com.trs.wcm.photo.publish - 软件包 com.trs.wcm.photo.publish
com.trs.wcmonline - 软件包 com.trs.wcmonline
com.trs.webframework.context - 软件包 com.trs.webframework.context
com.trs.webframework.controler - 软件包 com.trs.webframework.controler
com.trs.webframework.controler.servlet - 软件包 com.trs.webframework.controler.servlet
com.trs.webframework.entity - 软件包 com.trs.webframework.entity
com.trs.webframework.exception - 软件包 com.trs.webframework.exception
com.trs.webframework.provider - 软件包 com.trs.webframework.provider
com.trs.webframework.xmlserver.convertors - 软件包 com.trs.webframework.xmlserver.convertors
com.trs.webframework.xmlserver.parser - 软件包 com.trs.webframework.xmlserver.parser
com.trs.webframework.xmlserver.server - 软件包 com.trs.webframework.xmlserver.server
com.trs.weblet.util.verfiycode - 软件包 com.trs.weblet.util.verfiycode
com.trsothers - 软件包 com.trsothers
com.trsupdate - 软件包 com.trsupdate
com.wcm.pdf - 软件包 com.wcm.pdf
COMMENT - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
COMMENT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
All comments are labeled with this tag.
CommentConstants - com.trs.components.comment 中的 类
CommentConstants() - 类 com.trs.components.comment.CommentConstants 的构造方法
CommentParserEntity - com.trs.components.comment.publish.helper 中的 类
CommentParserEntity() - 类 com.trs.components.comment.publish.helper.CommentParserEntity 的构造方法
CommentParserEntity(int, int, int, String, int, String) - 类 com.trs.components.comment.publish.helper.CommentParserEntity 的构造方法
CommentParserUtil - com.trs.components.comment.publish.helper 中的 类
CommentParserUtil() - 类 com.trs.components.comment.publish.helper.CommentParserUtil 的构造方法
COMMENTS_DELIM - 类 com.trs.cms.process.ProcessConstants 中的静态变量
轨迹为会签用户同时产生意见标示
CommentService - com.trs.components.comment.service 中的 类
CommentService() - 类 com.trs.components.comment.service.CommentService 的构造方法
CommentUpdator - com.trs.components.comment.domain 中的 类
在外交部项目中WCM和新闻评论协同时使用 用于在WCM中生成新闻的ID、标题、所属频道的ID和站点的ID，以及 该新闻发言控制的数字签名。
CommentUpdator() - 类 com.trs.components.comment.domain.CommentUpdator 的构造方法
缺省构造方法
CommentUpdator(String) - 类 com.trs.components.comment.domain.CommentUpdator 的构造方法
利用带有签名的数据还原“NewsComment”对象
COMMON_SITE - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
CommonResourceBuilder - com.trs.tools 中的 类
CommonResourceBuilder() - 类 com.trs.tools.CommonResourceBuilder 的构造方法
COMPACT - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
compare(String, String, int) - 类 com.trs.cms.process.engine.handlers.ConditionHelper 中的静态方法
compare(long, long, int) - 类 com.trs.cms.process.engine.handlers.ConditionHelper 中的静态方法
compare(Object, Object) - 类 com.trs.components.ckm.PositionComparator 中的方法
compare(boolean) - 类 com.trs.infra.util.upgrade.dbcompare.SchemaCompare 中的方法
进行比较运算
compareTo(Date) - 类 com.trs.infra.util.CMyDateTime 中的方法
时间比较
compareTo(CMyDateTime) - 类 com.trs.infra.util.CMyDateTime 中的方法
时间比较
ComplexFieldData - com.trs.components.infoview.helper 中的 类
ComplexFieldData() - 类 com.trs.components.infoview.helper.ComplexFieldData 的构造方法
构造函数：保留默认接口
ComplexFieldDatas - com.trs.components.infoview.helper 中的 类
ComplexFieldDatas(User) - 类 com.trs.components.infoview.helper.ComplexFieldDatas 的构造方法
构造函数
ComplexFieldDatas(User, int, int) - 类 com.trs.components.infoview.helper.ComplexFieldDatas 的构造方法
构造函数
ComponentEntryConfigConstants - com.trs.components.common.conjection 中的 类
ComponentEntryConfigConstants() - 类 com.trs.components.common.conjection.ComponentEntryConfigConstants 的构造方法
ComponentEntryConfigServiceImpl - com.trs.components.common.conjection.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ComponentEntryConfigServiceImpl() - 类 com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl 的构造方法
composeMail() - 类 com.trs.infra.util.email.CMyEmail 中的方法
通过邮件已经设置的信息，构造邮件头和邮件正文
CON_COMMENT - 类 com.trs.infra.util.html.HtmlElement 中的静态变量
内容类型：HtmlComment(注释)
CON_ELEMENT - 类 com.trs.infra.util.html.HtmlElement 中的静态变量
内容类型：HtmlElement(HTML元素)
CON_TEXT - 类 com.trs.infra.util.html.HtmlElement 中的静态变量
内容类型：Text(纯文本)
conBuffer - 类 com.trs.infra.util.html.HtmlElementFinder 中的变量
内容缓冲区
concatanateArrays(String[], String[]) - 类 com.trs.infra.util.OptionConverter 中的静态方法
concatProperties(BaseObjs, String) - 类 com.trs.cms.content.WCMObjHelper 中的静态方法
将WCMObjects中的指定属性转换为以逗号隔开的字符串序列
concatProperties(BaseObjs, String, String) - 类 com.trs.cms.content.WCMObjHelper 中的静态方法
将WCMObjects中的指定属性转换为以逗号隔开的字符串序列
ConditionHandlerConfig - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流支持的条件配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConditionHandlerConfig() - 类 com.trs.cms.process.config.ConditionHandlerConfig 的构造方法
ConditionHelper - com.trs.cms.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConditionHelper() - 类 com.trs.cms.process.engine.handlers.ConditionHelper 的构造方法
Config - com.trs.infra.support.config 中的 类
Config() - 类 com.trs.infra.support.config.Config 的构造方法
构造函数：保留默认接口
CONFIG_FILE - 类 com.trs.infra.persistent.ObjTypeLookupImpl 中的静态变量
config file
ConfigConstants - com.trs.infra.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Config 的常量定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigConstants() - 类 com.trs.infra.config.ConfigConstants 的构造方法
ConfigController - com.trs.infra.config 中的 类
ConfigController() - 类 com.trs.infra.config.ConfigController 的构造方法
ConfigElementContentTester - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
帮助类，为了更方便地对配置文件进行初步检验
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigElementContentTester() - 类 com.trs.infra.util.ConfigElementContentTester 的构造方法
ConfigFile - com.trs.infra.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigFile(File, File) - 类 com.trs.infra.config.persistent.ConfigFile 的构造方法
ConfigFiles - com.trs.infra.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigFiles() - 类 com.trs.infra.config.persistent.ConfigFiles 的构造方法
ConfigFilesFinder - com.trs.infra.config.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
按照指定方式读写文件的工具类
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigFilesFinder(String, String) - 类 com.trs.infra.config.domain.ConfigFilesFinder 的构造方法
ConfigFilesFinder(ArrayList, String) - 类 com.trs.infra.config.domain.ConfigFilesFinder 的构造方法
ConfigFileTool4Refactor - com.trs 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
for copy config file.
ConfigFileTool4Refactor() - 类 com.trs.ConfigFileTool4Refactor 的构造方法
ConfigHelper - com.trs.infra.config.domain 中的 类
ConfigHelper() - 类 com.trs.infra.config.domain.ConfigHelper 的构造方法
ConfigLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
系统配置修改日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ConfigLogger() - 类 com.trs.components.wcm.logger.ConfigLogger 的构造方法
ConfigObjectLoader - com.trs.infra.config.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
配置文件的编组与解组工具
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConfigObjectLoader() - 类 com.trs.infra.config.domain.ConfigObjectLoader 的构造方法
Configs - com.trs.infra.support.config 中的 类
Configs() - 类 com.trs.infra.support.config.Configs 的构造方法
构造函数
Configs(int, int) - 类 com.trs.infra.support.config.Configs 的构造方法
构造函数
ConfigServer - com.trs.infra.support.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ConfigServer() - 类 com.trs.infra.support.config.ConfigServer 的构造方法
configure(IConfigElement) - 接口 com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr 中的方法
configure the manager
configure(IConfigElement) - 类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 中的方法
confirm(String, String, String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
confirm(String, String, String) - 接口 com.trs.template.service.ITemplateService 中的方法
DW客户端启用模板
confirm(String, String, String) - 类 com.trs.template.TRSTemplateFacade 中的方法
DW客户端审核模板
confirmPosition(SceneNode) - 类 com.trs.scene.tools.SceneNodeAction 中的方法
确定该树中所有节点的位置
confirmPositionX(SceneNode) - 类 com.trs.scene.tools.SceneNodeAction 中的方法
通过先确定叶子节点的X位置，然后从下往上依次计算出非叶子节点X位置
confirmPositionY(SceneNode) - 类 com.trs.scene.tools.SceneNodeAction 中的方法
通过每一层节点的深度，确定每个节点的Y坐标
Connect() - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
根据设置的配置信息，连接到FTP服务器
Connect(boolean) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
ConnectionPool - com.trs.infra.util.database 中的 类
com.trs.util.dbcp.ConnectionCache的一个代理
ConnectionPool(DBConnectionConfig) - 类 com.trs.infra.util.database.ConnectionPool 的构造方法
构造方法
ConnectPasswordEncrypter - com.trs.infra.persistent.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库连接密码加密/解密.
ConnectPasswordEncrypter() - 类 com.trs.infra.persistent.db.ConnectPasswordEncrypter 的构造方法
connectTRS(String, String, String, String) - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的静态方法
Constants - com.trs.infra.util.upgrade 中的 类
Constants() - 类 com.trs.infra.util.upgrade.Constants 的构造方法
Contact - com.trs.components.common.address 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人对象的定义及实现,用于通讯录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Contact() - 类 com.trs.components.common.address.Contact 的构造方法
ContactGrp - com.trs.components.common.address 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
联系入组对象的定义及实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrp() - 类 com.trs.components.common.address.ContactGrp 的构造方法
ContactGrps - com.trs.components.common.address 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人组集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactGrps(User) - 类 com.trs.components.common.address.ContactGrps 的构造方法
ContactGrps(User, int, int) - 类 com.trs.components.common.address.ContactGrps 的构造方法
ContactMgr - com.trs.components.common.address 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人管理对象定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactMgr() - 类 com.trs.components.common.address.ContactMgr 的构造方法
ContactMsgSender - com.trs.components.common.address 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
给联系人发送消息的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactMsgSender() - 类 com.trs.components.common.address.ContactMsgSender 的构造方法
Contacts - com.trs.components.common.address 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人集合对象的定义和实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
Contacts(User) - 类 com.trs.components.common.address.Contacts 的构造方法
Contacts(User, int, int) - 类 com.trs.components.common.address.Contacts 的构造方法
ContactService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人服务接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContactService() - 类 com.trs.service.impl.ContactService 的构造方法
contains(String) - 类 com.trs.infra.util.NamesRegister 中的方法
Returns true if this register contains the specified name.
containsBean(String) - 类 com.trs.infra.config.BeanConfigServer 中的方法
检验指定id标识的Bean配置对象是否存在
containsCDATAStr(String) - 类 com.trs.infra.util.CMyString 中的静态方法
containsChild(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
Returns true if this tag contains a child with the specified name; false, otherwise.
containsName(String) - 类 com.trs.infra.util.AttributesString 中的方法
containsNamedParam(String) - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法
containsNewProperty(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
containsParam(String) - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法
containsParameter(String) - 类 com.trs.webframework.context.MethodContext 中的方法
containsProperty(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
containsSelectFields(String) - 类 com.trs.infra.persistent.WCMFilter 中的方法
CONTENT - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
CONTENT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
All text content is labeled with this tag.
CONTENT_BODY_FILE - 类 com.trs.cms.CMSConstants 中的静态变量
content body type: external file
CONTENT_BODY_HTML - 类 com.trs.cms.CMSConstants 中的静态变量
content body type：HTML
CONTENT_BODY_LINK - 类 com.trs.cms.CMSConstants 中的静态变量
content body type：link
CONTENT_BODY_NORMAL - 类 com.trs.cms.CMSConstants 中的静态变量
content body type：normal (text)
CONTENT_BODY_UNKNOWN - 类 com.trs.cms.CMSConstants 中的静态变量
content body type：unknown
CONTENT_MODAL_COPY - 类 com.trs.cms.CMSConstants 中的静态变量
CONTENT_MODAL_ENTITY - 类 com.trs.cms.CMSConstants 中的静态变量
content modal: as an entity, whose substance is stored in the current folder
CONTENT_MODAL_LINK - 类 com.trs.cms.CMSConstants 中的静态变量
content modal: as a link in the current folder, whose substance is stored in another folder and has the same view.
CONTENT_MODAL_MIRROR - 类 com.trs.cms.CMSConstants 中的静态变量
content modal: as a mirror, whose substance is stored in another folder but has different views.
CONTENT_MODAL_QUOTE - 类 com.trs.cms.CMSConstants 中的静态变量
CONTENT_MODAL_UNKNOWN - 类 com.trs.cms.CMSConstants 中的静态变量
content modal: unknown
CONTENT_STYLE_PARAMETER - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
内容风格固有变量
CONTENT_STYLE_TYPE - 类 com.trs.components.common.publish.widget.StyleConstants 中的静态变量
为了复用同一个页面，添加了风格类型的常量:内容风格
ContentExtendValue - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
虚对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentExtendValue() - 类 com.trs.ajaxservice.ContentExtendValue 的构造方法
ContentExtendValue(int, String, String, String) - 类 com.trs.ajaxservice.ContentExtendValue 的构造方法
ContentExtendValues - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentExtendValues(User) - 类 com.trs.ajaxservice.ContentExtendValues 的构造方法
ContentExtendValues(User, int, int) - 类 com.trs.ajaxservice.ContentExtendValues 的构造方法
ContentExtField - com.trs.components.wcm.content.persistent 中的 类
ContentExtField() - 类 com.trs.components.wcm.content.persistent.ContentExtField 的构造方法
构造函数：保留默认接口
ContentExtFieldCListenerForDocProps - com.trs.components.wcm.content.domain 中的 类
ContentExtFieldCListenerForDocProps() - 类 com.trs.components.wcm.content.domain.ContentExtFieldCListenerForDocProps 的构造方法
ContentExtFieldLCListenerForDocFields - com.trs.components.wcm.content.domain 中的 类
ContentExtFieldLCListenerForDocFields() - 类 com.trs.components.wcm.content.domain.ContentExtFieldLCListenerForDocFields 的构造方法
ContentExtFieldMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
内容扩展字段管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentExtFieldMgr() - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 的构造方法
ContentExtFields - com.trs.components.wcm.content.persistent 中的 类
ContentExtFields(User) - 类 com.trs.components.wcm.content.persistent.ContentExtFields 的构造方法
构造函数
ContentExtFields(User, int, int) - 类 com.trs.components.wcm.content.persistent.ContentExtFields 的构造方法
构造函数
ContentExtFieldToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
扩展字段XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentExtFieldToXML() - 类 com.trs.ajaxservice.xmlconvertors.ContentExtFieldToXML 的构造方法
ContentExtFieldXmlConverter - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentExtFieldXmlConverter() - 类 com.trs.components.wcm.content.persistent.ContentExtFieldXmlConverter 的构造方法
ContentLink - com.trs.components.wcm.content.persistent 中的 类
ContentLink() - 类 com.trs.components.wcm.content.persistent.ContentLink 的构造方法
构造函数：保留默认接口
ContentLink2Xml - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
ContentLink2Xml() - 类 com.trs.ajaxservice.xmlconvertors.ContentLink2Xml 的构造方法
ContentLinkMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理和内容超链接相关的行为
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentLinkMgr() - 类 com.trs.components.wcm.content.domain.ContentLinkMgr 的构造方法
ContentLinkReplacer - com.trs.infra.util.html 中的 类
ContentLinkReplacer() - 类 com.trs.infra.util.html.ContentLinkReplacer 的构造方法
构造函数
ContentLinks - com.trs.components.wcm.content.persistent 中的 类
ContentLinks(User) - 类 com.trs.components.wcm.content.persistent.ContentLinks 的构造方法
ContentLinks(User, int, int) - 类 com.trs.components.wcm.content.persistent.ContentLinks 的构造方法
ContentLinkServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
热词相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentLinkServiceProvider() - 类 com.trs.ajaxservice.ContentLinkServiceProvider 的构造方法
ContentLinkType - com.trs.components.wcm.content.persistent 中的 类
ContentLinkType() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 的构造方法
构造函数：保留默认接口
ContentLinkTypes - com.trs.components.wcm.content.persistent 中的 类
ContentLinkTypes(User) - 类 com.trs.components.wcm.content.persistent.ContentLinkTypes 的构造方法
构造函数
ContentLinkTypes(User, int, int) - 类 com.trs.components.wcm.content.persistent.ContentLinkTypes 的构造方法
构造函数
ContentProcessInfo - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentProcessInfo(boolean, Flow, User) - 类 com.trs.cms.process.engine.ContentProcessInfo 的构造方法
ContentProcessInfo(boolean, Flow, String) - 类 com.trs.cms.process.engine.ContentProcessInfo 的构造方法
ContentProcessInfo(boolean, IFlowContent, String) - 类 com.trs.cms.process.engine.ContentProcessInfo 的构造方法
ContentProcessInfoToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ContentProcessInfo的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentProcessInfoToXML() - 类 com.trs.ajaxservice.xmlconvertors.ContentProcessInfoToXML 的构造方法
ContentPropertyHandler - com.trs.cms.process.engine.handlers 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
内容属性是否符合条件判断其
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentPropertyHandler() - 类 com.trs.cms.process.engine.handlers.ContentPropertyHandler 的构造方法
ContentStyle - com.trs.components.common.publish.widget 中的 类
ContentStyle() - 类 com.trs.components.common.publish.widget.ContentStyle 的构造方法
构造函数：保留默认接口
ContentStyleExporter - com.trs.components.common.publish.widget 中的 类
内容风格导出器
ContentStyleExporter() - 类 com.trs.components.common.publish.widget.ContentStyleExporter 的构造方法
构造函数
ContentStyleImporter - com.trs.components.common.publish.widget 中的 类
内容风格的导入代码
ContentStyleImporter() - 类 com.trs.components.common.publish.widget.ContentStyleImporter 的构造方法
构造函数
ContentStyleMgr - com.trs.components.common.publish.widget 中的 类
内容可用风格业务逻辑实现类
ContentStyleMgr() - 类 com.trs.components.common.publish.widget.ContentStyleMgr 的构造方法
构造方法
ContentStyles - com.trs.components.common.publish.widget 中的 类
ContentStyles(User) - 类 com.trs.components.common.publish.widget.ContentStyles 的构造方法
构造函数
ContentStyles(User, int, int) - 类 com.trs.components.common.publish.widget.ContentStyles 的构造方法
构造函数
ContentStyleServiceProvider - com.trs.components.common.publish.widget 中的 类
内容可用风格服务层
ContentStyleServiceProvider() - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 的构造方法
构造方法
ContentStyleXmlConverter - com.trs.components.common.publish.widget 中的 类
内容风格导出xml转换器
ContentStyleXmlConverter() - 类 com.trs.components.common.publish.widget.ContentStyleXmlConverter 的构造方法
构造函数
ContentTypeConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentTypeConfig() - 类 com.trs.components.common.publish.config.persistent.ContentTypeConfig 的构造方法
ContentUpdateCommanderImpl - com.trs.components.wcm.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContentUpdateCommanderImpl() - 类 com.trs.components.wcm.content.ContentUpdateCommanderImpl 的构造方法
CONTEXT_INDEX_IP - 类 com.trs.infra.support.log.LogServer 中的静态变量
CONTEXT_INDEX_TOPID - 类 com.trs.infra.support.log.LogServer 中的静态变量
contextDestroyed(ServletContextEvent) - 类 com.trs.infra.I18NMessageStartUp 中的方法
ContextHelper - com.trs.cms 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
使用ThreadLocal方式在各个功能模块间传递参数的管理模块
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContextHelper() - 类 com.trs.cms.ContextHelper 的构造方法
contextInitialized(ServletContextEvent) - 类 com.trs.infra.I18NMessageStartUp 中的方法
ContextParameters - com.trs.infra.common 中的 类
为了在不改变现有接口的情况下可以向下层函数传递新增加的参数 借助TLS实现，TLS:Thread Local Storage。
ContextParameters() - 类 com.trs.infra.common.ContextParameters 的构造方法
ContextTL - com.trs.infra.common 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
利用ThreadLocal传递参数的具体实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ContextTL() - 类 com.trs.infra.common.ContextTL 的构造方法
convert(String) - 类 com.trs.infra.util.PinyinHelper 中的静态方法
转换
convert(String, String) - 类 com.trs.infra.util.PinyinHelper 中的静态方法
转换
convert2Html(String) - 类 com.trs.service.impl.OfficeDocumentService 中的方法
convert2Html(String) - 接口 com.trs.service.IOfficeDocumentService 中的方法
Soap调用OfficeConverter处理文件，转换成HTML文件的zip包
convertBmp(ImageMagickCmd.ImageObj, String) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法
ConvertException - com.trs.webframework.xmlserver 中的 异常
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ConvertException(int) - 异常 com.trs.webframework.xmlserver.ConvertException 的构造方法
ConvertException(int, String) - 异常 com.trs.webframework.xmlserver.ConvertException 的构造方法
ConvertException(String) - 异常 com.trs.webframework.xmlserver.ConvertException 的构造方法
ConvertException(int, String, Throwable) - 异常 com.trs.webframework.xmlserver.ConvertException 的构造方法
ConvertException(String, Throwable) - 异常 com.trs.webframework.xmlserver.ConvertException 的构造方法
convertImageFormat(String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
设置需要转换的图片格式
convertImageFormat(String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
converToAbsoluteFileName(String) - 类 com.trs.components.metadata.center.xml.MetaViewDataImporter 中的静态方法
ConvertOfficeFile(String) - 类 com.trs.infra.util.soap.OcrSoapClient 中的方法
CONVERTOR_TYPE_DEFAULT - 类 com.trs.webframework.FrameworkConstants 中的静态变量
CONVERTOR_TYPE_JSON - 类 com.trs.webframework.FrameworkConstants 中的静态变量
CONVERTOR_TYPE_URI - 类 com.trs.webframework.FrameworkConstants 中的静态变量
CONVERTOR_TYPE_URL - 类 com.trs.webframework.FrameworkConstants 中的静态变量
CONVERTOR_TYPE_XML - 类 com.trs.webframework.FrameworkConstants 中的静态变量
convertSpecialChars(String) - 类 com.trs.infra.util.OptionConverter 中的静态方法
convertToFirstLetter(String) - 类 com.trs.components.infoview.db.LetterConvertor 中的静态方法
convertToFirstLetter(String, boolean, int) - 类 com.trs.components.infoview.db.LetterConvertor 中的静态方法
convertToFlowDocNotFlags(FlowDoc, int[]) - 类 com.trs.cms.process.FlowServerImpl 中的静态方法
convertXml(String, String, String) - 类 com.trs.infra.persistent.AbstractXmlToObjConverter 中的方法
parse the xml file
convertXml(String, String, String) - 类 com.trs.infra.persistent.XmlToObjConverter 中的方法
parse the xml file
convertXml(String, String) - 类 com.trs.infra.persistent.XmlToObjConverter 中的方法
convertXml(String, String, String) - 类 com.trs.infra.persistent.XmlToObjConverterByDOM4j 中的方法
parse the xml file
convertXml(String, String) - 类 com.trs.infra.persistent.XmlToObjConverterByDOM4j 中的方法
COORDS - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
copy(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
拷贝文档
copy(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
拷贝文档
copy(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
拷贝文档
copy(RightValue) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
权限值的复制
copy() - 类 com.trs.components.common.publish.persistent.template.TagBeans 中的方法
copy(User, PageStyle, ContentStyle) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
copy(User, PageStyle, ContentStyle, int, Reports) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
copy(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
复制内容可用风格到页面页面风格或者系统内容风格下
copy(User, PageStyle, ContentStyle) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
copy(User, PageStyle, ContentStyle, int, Reports) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
仿照_sourceContentStyle为_targetPageStyle创建一个新的ContentStyle
copy(MethodContext) - 接口 com.trs.components.common.publish.widget.IContentStyleServiceProvider 中的方法
复制内容可用风格
copy(User, PageStyle, PageStyle) - 接口 com.trs.components.common.publish.widget.IPageStyleMgr 中的方法
仿照指定的页面风格创建一份新的风格
copy(MethodContext) - 接口 com.trs.components.common.publish.widget.IPageStyleServiceProvider 中的方法
类似创建风格,创建风格以及风格中的资源可用风格，内容可用风格等
copy(User, PageStyle, ResourceStyle, int, Reports) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
copy(User, PageStyle, ResourceStyle) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
copy(MethodContext) - 接口 com.trs.components.common.publish.widget.IResourceStyleServiceProvider 中的方法
复制资源可用风格
copy(User, PageStyle, PageStyle) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
仿照PageStyle创建一份新的风格
copy(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
类似创建风格,创建风格以及风格中的资源可用风格，内容可用风格等
copy(User, PageStyle, ResourceStyle) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
copy(User, PageStyle, ResourceStyle, int, Reports) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
仿照_sourceResourceStyle为_targetPageStyle创建一个新的ResourceStyle
copy(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
复制资源可用风格到页面风格或者系统资源风格下
copy(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
复制记录到...
copy(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
复制记录到...
copy(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
复制记录到...
copy(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
复制记录到...
copy(QueryFilter) - 类 com.trs.infra.db.QueryFilter 中的方法
过滤器复制函数
copy(WCMFilter) - 类 com.trs.infra.persistent.WCMFilter 中的方法
过滤器复制函数
copy(CMyBitsValue) - 类 com.trs.infra.util.CMyBitsValue 中的方法
对象复制
copy(File, File) - 类 com.trs.scene.tools.SceneAutoCreator 中的静态方法
拷贝一个目录或者文件到指定路径下
copyAll(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
复制全部文档到
copyAppendixes(Document, Document) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
复制某个特定文档的所有附件到一个新文档中
copyDocReplys(Document, Document) - 类 com.trs.components.wcm.content.domain.DocReplyMgr 中的方法
复制文档回复
copyDocument(Document, Channel, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
复制文档到另一个频道上
不负责非依赖型关联对象的复制，如附件和相关文档
不能将一个文档从草稿箱或者复制到草稿箱
复制引用转发的文档相当于创建一个新的引用转发
复制实体文档，则需要在目标频道下创建一个新的实体文档
copyFile(String, String, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
将指定文件复制到指定的目录
copyFile(String, String) - 类 com.trs.infra.util.CMyFile 中的静态方法
复制文件
copyFile(String, String, boolean) - 类 com.trs.infra.util.CMyFile 中的静态方法
copyFile(String, String, boolean, boolean) - 类 com.trs.infra.util.CMyFile 中的静态方法
copyFile(String, String) - 类 com.trs.tools.WCM61AutoList 中的静态方法
copyFileDir(String, String, boolean) - 类 com.trs.infra.util.CMyFile 中的静态方法
拷贝文件夹到指定的文件夹
copyFor(User, PageStyle) - 接口 com.trs.components.common.publish.widget.ISystemContentStyleMgr 中的方法
根据系统默认的内容可用风格为指定的系统风格创建
copyFor(User, PageStyle) - 接口 com.trs.components.common.publish.widget.ISystemResourceStyleMgr 中的方法
根据系统默认的资源可用风格为指定的系统风格创建
copyFor(User, PageStyle) - 类 com.trs.components.common.publish.widget.SystemContentStyleMgr 中的方法
根据系统默认的内容可用风格为指定的系统风格创建
copyFor(User, PageStyle) - 类 com.trs.components.common.publish.widget.SystemResourceStyleMgr 中的方法
根据系统默认的资源可用风格为指定的系统风格创建
copyImage() - 类 com.trs.scene.tools.SceneAutoCreator 中的方法
将模板中所用到的图片和部分flash文件拷贝到preview/pub中，防止zip上传时造成的文件丢失，预览效果差。
CopyOfTRSImportsOrgnize - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CopyOfTRSImportsOrgnize() - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 的构造方法
copyRelationListByObj(BaseObj) - 类 com.trs.components.wcm.content.domain.RelationMgr 中的方法
以List方式获得文档所属关联文档集合
在处理文档时是个有用的接口
该接口应该是获得对象的关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用
以后扩展应该也比较方便，增加一个对象类型ID即可
copyRelations(Document, Document) - 类 com.trs.components.wcm.content.domain.RelationMgr 中的方法
复制某个特定文档的所有相关文档到一个新文档中
copyRequestInputStream(InputStream) - 类 com.trs.webframework.xmlserver.parser.StreamBuddy 中的静态方法
copySystemStyle(User, PageStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
在新建页面风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格
copySystemStyle(User, PageStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
在新建风格时，为风格拷贝默认的页面特性，资源可用风格，内容可用风格
copyTo(String, int, String) - 接口 com.trs.service.IDocumentService 中的方法
将一组文档从指定的频道复制到多个目标频道下
一般这样的操作是在文档列表页面执行的
copyTo(String, String) - 接口 com.trs.service.IDocumentService 中的方法
复制文档集合 将一堆文档复制到某个频道 一堆文档可以是一个检索的结果
copyTo(String, int, String) - 类 com.trs.service.impl.DocumentService 中的方法
copyTo(String, String) - 类 com.trs.service.impl.DocumentService 中的方法
copyToAllPageSylte(ContentStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
给所有的风格下面都要建立当前这个内容风格
copyToAllPageSylte(ResourceStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
给所有的页面风格下面都要建立当前这个资源风格
copyToAllPageSylte(ResourceStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
给所有的风格下面都要建立当前这个资源风格
copyToAllPageSylte(ContentStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
给所有的风格下面都要建立当前这个内容风格
copyViewDataByClassInfos(MetaViewData, ClassInfos, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
copyViewDataByClassInfos(MetaViewData, MetaViewField, ClassInfos, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
copyViewDataByClassInfos(MetaViewData, ClassInfos, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录oViewData的所有可能分类字段复制到新的分类oDestClassInfos
copyViewDataByClassInfos(MetaViewData, MetaViewField, ClassInfos, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录oViewData的分类字段oViewField复制到新的分类oDestClassInfos
copyViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
将记录复制到另一个分类法下
copyViewDatasByClassInfos(MetaViewDatas, ClassInfos, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
copyViewDatasByClassInfos(MetaViewDatas, MetaViewField, ClassInfos, User) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
copyViewDatasByClassInfos(MetaViewDatas, ClassInfos, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录集oViewDatas的所有可能分类字段复制到新的分类oDestClassInfos
copyViewDatasByClassInfos(MetaViewDatas, MetaViewField, ClassInfos, User) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
将记录集oViewDatas的分类字段oViewField复制到新的分类oDestClassInfos
copyVisualTemplate(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
类似创建功能，在指定栏目下创建新的可视化模板
copyVisualTempToChnls(Channels, Template) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
在指定栏目下，类似创建可视化模板
copyWCMFile(String, String) - 类 com.trs.infra.support.file.FilesMan 中的方法
将指定WCM文件复制到目标目录
copyWidgetInstance(MethodContext) - 接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider 中的方法
类似创建相同的资源实例，创建后的资源实例与原来的实例拥有相同的资源变量和值 返回创建后的资源实例的可视化编辑模板形式
copyWidgetInstance(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
类似创建功能，创建的新的资源实例
COracleCLOB - com.trs.infra.util.database 中的 类
COracleCLOB() - 类 com.trs.infra.util.database.COracleCLOB 的构造方法
COUNTER_DIRCACHEFILES - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态变量
countTokens(String, String) - 类 com.trs.infra.util.CMyString 中的静态方法
获取按照指定的分隔符截取到的字符个数
CPager - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class CPager —— 分页对象，为解决Web中集合的分页显示而设
* 支持两种方式下的分页问题：
（1）java.sql.ResultSet的分页；
（2）列表集合的分页（如：Vector list）
* 注意：页面、记录的序号均从1开始 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
CPager() - 类 com.trs.infra.util.CPager 的构造方法
构造函数
CPager(int) - 类 com.trs.infra.util.CPager 的构造方法
构造函数
CRC32 - com.trs.infra.util.jazzlib 中的 类
Computes CRC32 data checksum of a data stream.
CRC32() - 类 com.trs.infra.util.jazzlib.CRC32 的构造方法
CreatChnlTree(Channels) - 类 com.trs.components.wcm.wcmx.util.CWasTree 中的方法
Create() - 类 com.trs.scene.tools.SceneAutoCreator 中的方法
create(HttpServletRequest, HttpServletResponse) - 类 com.trs.service.InfoViewContext 中的静态方法
create(HttpServletRequest, HttpServletResponse) - 类 com.trs.webframework.context.ServiceContext 中的静态方法
createAutoDocBakService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IAutoDocBakService的实例
createBean() - 类 com.trs.components.common.publish.config.PublishElementType 中的方法
create a new bean instance
createBookMarkService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IBookMarkService的实例
createCDSService() - 类 com.trs.service.ServiceHelper 中的静态方法
createChannels(ClassInfo, BaseChannel, MetaView, int) - 类 com.trs.components.metadata.service.ClassInfoToChannelHelper 中的静态方法
createChannelService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IChannelService的实例
createChannelTreeHTMLOfIds(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
产生指定栏目ID的子栏目序列树HTML
createClassInfoTreeHTML(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
产生指定分类下所有子分类的HTML
createClassInfoTreeHTML(User, int) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
产生指定父节点的分类信息
createClassInfoTreeHTML(User, int) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
产生指定父节点的分类信息
createClassInfoTreeHTMLForGB(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
产生指定分类下所有子分类的HTML
createClassInfoTreeHTMLOfIds(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
产生指定ID序列的HTML type表示产生的方式，type=0表示沿着一条链一直展开，用于定位到一个未展开的节点 传入的ids有父子关系;type!
createClassInfoTreeHTMLOfIds(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
产生指定ID序列的HTML type表示产生的方式，type=0表示沿着一条链一直展开，用于定位到一个未展开的节点 传入的ids有父子关系;type!
createContactService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IContactService的实例
createContentPublishTask(IPublishContent, int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
create a content publish task
createContentPublishTask(IPublishElements, IPublishFolder, int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
create a content publish task
createContentPublishTask(IPublishContent, IPublishFolder, IPublishElements) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
createContentPublishTask(IPublishContent, int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
createContentPublishTask(IPublishElements, IPublishFolder, int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
createContentPublishTask(IPublishContent, IPublishFolder, IPublishElements) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
创建文档的直接发布任务（PublishConstants.PUBLISH_CONTENT_DIRECT）
createConvertor(Class) - 类 com.trs.webframework.xmlserver.XMLConvertorFactory 中的静态方法
根据指定的对象的class产生将指定对象转换为XML的转换器
createConvertor(String) - 类 com.trs.webframework.xmlserver.XMLConvertorFactory 中的静态方法
根据指定的对象的class名称产生将指定对象转换为XML的转换器
createCustomizeService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生ICustomizeService的实例
createDataTransferEncode(String) - 类 com.trs.template.DataTransferEncodeFactory 中的静态方法
创建IDataTransferEncode的实例
createDBDataInsertSQL(String) - 类 com.trs.db.schema.TRSDBSchema 中的方法
createDBField(User, InfoView, InfoViewField) - 接口 com.trs.components.infoview.db.IInfoViewDBMgr 中的方法
给当前表单的指定字段在数据库中创建对应物理字段
createDBField(User, InfoView, InfoViewField) - 类 com.trs.components.infoview.db.InfoViewDBMgr 中的方法
createDBTable(User, int) - 接口 com.trs.components.infoview.db.IInfoViewDBMgr 中的方法
新增或者修改系统表
createDBTable(User, int) - 类 com.trs.components.infoview.db.InfoViewDBMgr 中的方法
createDDLSQL(MetaDBTable) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
产生指定表的定义SQL
createDDLSQL(MetaView) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
产生指定视图的定义SQL
createDDLSQL(MetaDBTable) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
createDDLSQL(MetaView) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
createDeleteContentsSynPublishTask(IPublishFolder, IPublishElements) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
createDeleteContentsSynPublishTask(IPublishFolder, IPublishContent) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
createDeleteContentsSynPublishTask(IPublishFolder, IPublishElements) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
createDeleteContentsSynPublishTask(IPublishFolder, IPublishContent) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
createDestroyPublishTask(IPublishElements, IPublishFolder, IPublishElements) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
createDestroyPublishTask(IPublishElements, IPublishFolder, IPublishElements) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
创建文档的撤销发布任务（PublishConstants.PUBLISH_RECALL）
createDistributor() - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
create a distributor instance
createDocumentService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IDocumentService的实例
createElementOfType(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
create an element instance for the specified type
createEncodeUserInfo() - 类 com.trs.presentation.util.LoginHelper 中的方法
createEncodeUserInfo(User, String) - 类 com.trs.presentation.util.LoginHelper 中的方法
createEncodeUserInfo(User, String, String) - 类 com.trs.presentation.util.LoginHelper 中的方法
createEPress(MethodContext) - 类 com.trs.components.wcm.epress.EPressServiceProvider 中的方法
createEventService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IEventService的实例
createFile() - 类 com.trs.infra.util.TRSJspAutoTool 中的方法
createFlowContent(int, int) - 类 com.trs.cms.process.engine.FlowContentHelper 中的静态方法
createFlowContent(CMSObj) - 类 com.trs.cms.process.engine.FlowContentHelper 中的静态方法
createFolderPublishTask(IPublishFolder, int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
create a folder publish task
createFolderPublishTask(IPublishFolder, int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
createFrom(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
类似创建栏目
createFrom(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
类似创建工作流，省得为了类似创建工作流时要导入+导出
createFrom(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
类似创建站点
createFrom(Special) - 接口 com.trs.components.special.ISpecialMgr 中的方法
根据源专题，类似创建新的专题
createFrom(MethodContext) - 接口 com.trs.components.special.ISpecialServiceProvider 中的方法
专题的类似创建
createFrom(Special) - 类 com.trs.components.special.SpecialMgr 中的方法
createFrom(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法
createFrom(int, boolean) - 接口 com.trs.service.IChannelService 中的方法
站点的类似创建的实现
createFrom(WebSite, boolean) - 接口 com.trs.service.IChannelService 中的方法
站点的类似创建的实现
从指定的站点获取站点的相关属性,创建一个新的站点.
createFrom(int, BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
频道的类似创建的实现
createFrom(Channel, BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
频道的类似创建的实现
从指定的频道获取频道的相关属性,创建一个新的频道
新频道与源频道有基本相同的属性.
createFrom(int, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
createFrom(WebSite, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
createFrom(int, BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法
createFrom(Channel, BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法
createFromFile(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
createFromFile(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
导入txt文件来批量创建热词
createFromFile(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
createGroups(ClassInfo, Group, int) - 类 com.trs.components.metadata.service.ClassInfoToGroupCreator 中的方法
createGroupService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IGroupService的实例
createImgesDir(PageStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
创建页面风格图片的存放目录
createImgesDir(PageStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
创建资源风格图片的存放目录
createInfoViewService() - 类 com.trs.service.ServiceHelper 中的静态方法
createInfoviewXMLDataUpdator() - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
createInitValue(FlowContext) - 类 com.trs.cms.process.engine.creators.CurrentDateCreator 中的方法
createInitValue(FlowContext) - 类 com.trs.cms.process.engine.creators.CurrentDocStatusCreator 中的方法
createInitValue(FlowContext) - 类 com.trs.cms.process.engine.creators.CurrentTimeCreator 中的方法
createInitValue(FlowContext) - 类 com.trs.cms.process.engine.creators.CurrentUserNameCreator 中的方法
createInitValue(FlowContext) - 类 com.trs.cms.process.engine.creators.PostUserNameCreator 中的方法
createInitValue(FlowContext) - 接口 com.trs.cms.process.engine.IInitValueCreator 中的方法
根据当前上下文信息产生初始值
createInstance(User, String) - 类 com.trs.cms.content.CMSBaseObjs 中的静态方法
产生指定集合对象的实例
createInstance(User, Class) - 类 com.trs.cms.content.CMSBaseObjs 中的静态方法
产生指定集合对象的实例
createInstance(String) - 类 com.trs.infra.persistent.BaseObjs 中的静态方法
产生指定集合对象的实例
createInstance(Class) - 类 com.trs.infra.persistent.BaseObjs 中的静态方法
产生指定集合对象的实例
createInstance() - 类 com.trs.infra.ServerControl 中的静态方法
createInstance() - 类 com.trs.infra.support.config.ConfigServer 中的静态方法
createJSPLocal(String, String, String, String, String) - 类 com.trs.infra.util.TRSLocaleAuto 中的静态方法
createLocal(String, String) - 类 com.trs.infra.util.TRSLocaleAuto 中的静态方法
createLocal(String, String, String) - 类 com.trs.infra.util.TRSLocaleAuto 中的静态方法
createLocal(String, String, String, String, String) - 类 com.trs.infra.util.TRSLocaleAuto 中的静态方法
createLoginValidator() - 类 com.trs.webframework.controler.servlet.LoginValidatorFactory 中的静态方法
createNewInstance() - 类 com.trs.cms.auth.persistent.Group 中的静态方法
产生当前对象[Group]的实例
createNewInstance() - 类 com.trs.cms.auth.persistent.GroupRole 中的静态方法
产生当前对象[GroupRole]的实例
createNewInstance(User) - 类 com.trs.cms.auth.persistent.Groups 中的静态方法
产生当前集合对象[Groups]的实例
createNewInstance() - 类 com.trs.cms.auth.persistent.GroupUser 中的静态方法
产生当前对象[GroupUser]的实例
createNewInstance() - 类 com.trs.cms.auth.persistent.ObjectMember 中的静态方法
产生当前对象[ObjectMember]的实例
createNewInstance(User) - 类 com.trs.cms.auth.persistent.ObjectMembers 中的静态方法
产生当前集合对象[ObjectMembers]的实例
createNewInstance() - 类 com.trs.cms.auth.persistent.Right 中的静态方法
产生当前对象[Right]的实例
createNewInstance() - 类 com.trs.cms.auth.persistent.RightDef 中的静态方法
产生当前对象[RightDef]的实例
createNewInstance(User) - 类 com.trs.cms.auth.persistent.RightDefs 中的静态方法
产生一个当前集合对象[RightDefs]的实例
createNewInstance(User) - 类 com.trs.cms.auth.persistent.Rights 中的静态方法
产生当前集合对象[Rights]的实例
createNewInstance() - 类 com.trs.cms.auth.persistent.Role 中的静态方法
产生当前对象[Role]的实例
createNewInstance(User) - 类 com.trs.cms.auth.persistent.Roles 中的静态方法
产生当前集合对象[Roles]的实例
createNewInstance() - 类 com.trs.cms.auth.persistent.RoleUser 中的静态方法
产生当前对象[RoleUser]的实例
createNewInstance() - 类 com.trs.cms.auth.persistent.User 中的静态方法
产生当前对象[User]的实例
createNewInstance(User) - 类 com.trs.cms.auth.persistent.Users 中的静态方法
产生当前集合对象[Users]的实例
createNewInstance(User) - 类 com.trs.cms.content.DefaultObjs 中的静态方法
产生当前集合对象[DefaultObjs]的实例
createNewInstance() - 类 com.trs.cms.content.ExtendedField 中的静态方法
产生当前对象[ExtendedField]的实例
createNewInstance(User) - 类 com.trs.cms.content.ExtendedFields 中的静态方法
产生当前集合对象[ExtendedFields]的实例
createNewInstance() - 类 com.trs.cms.process.definition.Flow 中的静态方法
产生当前对象[Flow]的实例
createNewInstance() - 类 com.trs.cms.process.definition.FlowAction 中的静态方法
产生当前对象[FlowAction]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.FlowActions 中的静态方法
产生当前集合对象[FlowActions]的实例
createNewInstance() - 类 com.trs.cms.process.definition.FlowCondition 中的静态方法
产生当前对象[FlowCondition]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.FlowConditions 中的静态方法
产生当前集合对象[FlowConditions]的实例
createNewInstance() - 类 com.trs.cms.process.definition.FlowdocLog 中的静态方法
产生当前对象[FlowdocLog]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.FlowdocLogs 中的静态方法
产生当前集合对象[FlowdocLogs]的实例
createNewInstance() - 类 com.trs.cms.process.definition.FlowEmploy 中的静态方法
产生当前对象[FlowEmploy]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.FlowEmploys 中的静态方法
产生当前集合对象[FlowEmploys]的实例
createNewInstance() - 类 com.trs.cms.process.definition.FlowNode 中的静态方法
产生当前对象[FlowNode]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.FlowNodeBranchs 中的静态方法
产生当前集合对象[FlowNodeBranchs]的实例
createNewInstance() - 类 com.trs.cms.process.definition.FlowNodeField 中的静态方法
产生当前对象[FlowNodeField]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.FlowNodeFields 中的静态方法
产生当前集合对象[FlowNodeFields]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.FlowNodes 中的静态方法
产生当前集合对象[FlowNodes]的实例
createNewInstance() - 类 com.trs.cms.process.definition.FlowRule 中的静态方法
产生当前对象[FlowRule]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.FlowRules 中的静态方法
产生当前集合对象[FlowRules]的实例
createNewInstance(User) - 类 com.trs.cms.process.definition.Flows 中的静态方法
产生当前集合对象[Flows]的实例
createNewInstance() - 类 com.trs.cms.process.engine.FlowContentConfig 中的静态方法
产生当前对象[FlowContentConfig]的实例
createNewInstance(User) - 类 com.trs.cms.process.engine.FlowContentConfigs 中的静态方法
产生当前集合对象[FlowContentConfigs]的实例
createNewInstance() - 类 com.trs.cms.process.engine.FlowDoc 中的静态方法
产生当前对象[FlowDoc]的实例
createNewInstance(User) - 类 com.trs.cms.process.engine.FlowDocs 中的静态方法
产生当前集合对象[FlowDocs]的实例
createNewInstance() - 类 com.trs.components.comment.persistent.DocumentTopic 中的静态方法
产生当前对象[DocumentTopic]的实例
createNewInstance(User) - 类 com.trs.components.comment.persistent.DocumentTopics 中的静态方法
产生当前集合对象[DocumentTopics]的实例
createNewInstance() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的静态方法
产生当前对象[TopicedDocRelation]的实例
createNewInstance(User) - 类 com.trs.components.comment.persistent.TopicedDocRelations 中的静态方法
产生当前集合对象[TopicedDocRelations]的实例
createNewInstance() - 类 com.trs.components.common.address.Contact 中的静态方法
产生当前对象[Contact]的实例
createNewInstance() - 类 com.trs.components.common.address.ContactGrp 中的静态方法
产生当前对象[ContactGrp]的实例
createNewInstance(User) - 类 com.trs.components.common.address.ContactGrps 中的静态方法
产生当前集合对象[ContactGrps]的实例
createNewInstance(User) - 类 com.trs.components.common.address.Contacts 中的静态方法
产生一个当前集合对象[Contacts]的实例
createNewInstance() - 类 com.trs.components.common.bookmark.BookMark 中的静态方法
产生当前对象[BookMark]的实例
createNewInstance(User) - 类 com.trs.components.common.bookmark.BookMarks 中的静态方法
产生一个当前集合对象[BookMarks]的实例
createNewInstance() - 类 com.trs.components.common.bookmark.MarkKind 中的静态方法
产生当前对象[MarkKind]的实例
createNewInstance(User) - 类 com.trs.components.common.bookmark.MarkKinds 中的静态方法
产生一个当前集合对象[MarkKinds]的实例
createNewInstance(User) - 类 com.trs.components.common.bookmark.MarkShares 中的静态方法
产生一个当前集合对象[MarkShares]的实例
createNewInstance() - 类 com.trs.components.common.calendar.Event 中的静态方法
产生当前对象[Event]的实例
createNewInstance(User) - 类 com.trs.components.common.calendar.Events 中的静态方法
产生一个当前集合对象[Events]的实例
createNewInstance() - 类 com.trs.components.common.calendar.EventShare 中的静态方法
产生当前对象[EventShare]的实例
createNewInstance() - 类 com.trs.components.common.calendar.EventType 中的静态方法
产生当前对象[EventType]的实例
createNewInstance() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的静态方法
产生当前对象[EntryConfig]的实例
createNewInstance(User) - 类 com.trs.components.common.conjection.persistent.EntryConfigs 中的静态方法
产生当前集合对象[EntryConfigs]的实例
createNewInstance() - 类 com.trs.components.common.job.JobWorkerType 中的静态方法
产生当前对象[JobWorker]的实例
createNewInstance(User) - 类 com.trs.components.common.job.JobWorkerTypes 中的静态方法
产生当前集合对象[JobWorkers]的实例
createNewInstance() - 类 com.trs.components.common.job.Schedule 中的静态方法
产生当前对象[Schedule]的实例
createNewInstance(User) - 类 com.trs.components.common.job.Schedules 中的静态方法
产生当前集合对象[Schedules]的实例
createNewInstance() - 类 com.trs.components.common.message.Message 中的静态方法
产生当前对象[Message]的实例
createNewInstance(User) - 类 com.trs.components.common.message.Messages 中的静态方法
产生一个当前集合对象[Messages]的实例
createNewInstance() - 类 com.trs.components.common.message.MsgQueue 中的静态方法
产生当前对象[MsgQueue]的实例
createNewInstance(User) - 类 com.trs.components.common.message.MsgQueues 中的静态方法
产生一个当前集合对象[MsgQueues]的实例
createNewInstance() - 类 com.trs.components.common.message.MsgReceiver 中的静态方法
产生当前对象[MsgReceiver]的实例
createNewInstance() - 类 com.trs.components.common.message.MsgReceivers 中的静态方法
产生当前集合对象[MsgReceivers]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的静态方法
产生当前对象[PublishDistributionConfig]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 中的静态方法
产生当前集合对象[PublishDistributions]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的静态方法
产生当前对象[FolderPublishConfig]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 中的静态方法
产生当前集合对象[FolderPublishConfigs]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的静态方法
产生当前对象[PublishLog]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的静态方法
产生当前对象[PublishTask]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的静态方法
产生当前对象[TagBean]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的静态方法
产生当前对象[TempApdRel]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.persistent.template.TempApdRels 中的静态方法
产生一个当前集合对象[TempApdRels]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态方法
产生当前对象[TempAppendix]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.persistent.template.TempAppendixes 中的静态方法
产生一个当前集合对象[TempAppendixes]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.template.Template 中的静态方法
产生当前对象[Template]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的静态方法
产生当前对象[TemplateArgument]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的静态方法
TemplateArguments的对象实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的静态方法
产生当前对象[TemplateEmploy]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploys 中的静态方法
产生当前集合对象[TemplateEmploys]的实例
createNewInstance() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的静态方法
产生当前对象[TemplateQuote]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.persistent.template.TemplateQuotes 中的静态方法
产生当前集合对象[TemplateQuotes]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态方法
产生当前集合对象[Templates]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.ContentStyle 中的静态方法
产生当前对象[ContentStyle]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.ContentStyles 中的静态方法
产生当前集合对象[ContentStyles]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.Layout 中的静态方法
产生当前对象[Layout]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.Layouts 中的静态方法
产生当前集合对象[Layouts]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.Master 中的静态方法
产生当前对象[Master]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.Masters 中的静态方法
产生当前集合对象[Masters]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.PageStyle 中的静态方法
产生当前对象[PageStyle]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.PageStyles 中的静态方法
产生当前集合对象[PageStyles]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的静态方法
产生当前对象[ResourceStyle]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.ResourceStyles 中的静态方法
产生当前集合对象[ResourceStyles]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的静态方法
产生当前对象[StyleAndResource]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.StyleAndResources 中的静态方法
产生当前集合对象[StyleAndResources]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.StyleItem 中的静态方法
产生当前对象[StyleItem]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.StyleItems 中的静态方法
产生当前集合对象[StyleItems]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.Widget 中的静态方法
产生当前对象[Widget]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.WidgetInstance 中的静态方法
产生当前对象[WidgetInstance]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.WidgetInstances 中的静态方法
产生当前集合对象[WidgetInstances]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的静态方法
产生当前对象[WidgetInstParameter]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.WidgetInstParameters 中的静态方法
产生当前集合对象[WidgetInstParameters]的实例
createNewInstance() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态方法
产生当前对象[WidgetParameter]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.WidgetParameters 中的静态方法
产生当前集合对象[WidgetParameters]的实例
createNewInstance(User) - 类 com.trs.components.common.publish.widget.Widgets 中的静态方法
产生当前集合对象[Widgets]的实例
createNewInstance() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的静态方法
产生当前对象[ApplyForm]的实例
createNewInstance() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的静态方法
产生当前对象[ApplyFormDealLog]的实例
createNewInstance(User) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 中的静态方法
产生当前集合对象[ApplyFormDealLogs]的实例
createNewInstance(User) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForms 中的静态方法
产生当前集合对象[ApplyForms]的实例
createNewInstance() - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的静态方法
产生当前对象[MailConfig]的实例
createNewInstance(User) - 类 com.trs.components.gkml.sqgk.persistent.MailConfigs 中的静态方法
产生当前集合对象[MailConfigs]的实例
createNewInstance() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的静态方法
产生当前对象[ComplexFieldData]的实例
createNewInstance(User) - 类 com.trs.components.infoview.helper.ComplexFieldDatas 中的静态方法
产生当前集合对象[ComplexFieldDatas]的实例
createNewInstance() - 类 com.trs.components.infoview.persistent.InfoView 中的静态方法
产生对象InfoView的实例
createNewInstance() - 类 com.trs.components.infoview.persistent.InfoViewData 中的静态方法
产生当前对象[MetaViewData]的实例
createNewInstance(int, int) - 类 com.trs.components.infoview.persistent.InfoViewData 中的静态方法
createNewInstance(int) - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的静态方法
createNewInstance(User) - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的静态方法
产生一个当前集合对象[ChnlDocs]的实例
createNewInstance() - 类 com.trs.components.infoview.persistent.InfoViewField 中的静态方法
产生对象InfoView的实例
createNewInstance() - 类 com.trs.components.metadata.center.ClassInfoView 中的静态方法
产生当前对象[ClassInfoView]的实例
createNewInstance(User) - 类 com.trs.components.metadata.center.ClassInfoViews 中的静态方法
产生当前集合对象[ClassInfoViews]的实例
createNewInstance() - 类 com.trs.components.metadata.center.MetaViewData 中的静态方法
产生当前对象[MetaViewData]的实例
createNewInstance(String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态方法
产生当前集合对象[MetaViewDatas]的实例
createNewInstance() - 类 com.trs.components.metadata.definition.ClassInfo 中的静态方法
产生当前对象[ClassInfo]的实例
createNewInstance(User) - 类 com.trs.components.metadata.definition.ClassInfos 中的静态方法
产生当前集合对象[ClassInfos]的实例
createNewInstance() - 类 com.trs.components.metadata.definition.MetaDBField 中的静态方法
产生当前对象[DBFieldInfo]的实例
createNewInstance(User) - 类 com.trs.components.metadata.definition.MetaDBFields 中的静态方法
产生当前集合对象[DBFieldInfos]的实例
createNewInstance() - 类 com.trs.components.metadata.definition.MetaDBTable 中的静态方法
产生当前对象[TableInfo]的实例
createNewInstance(User) - 类 com.trs.components.metadata.definition.MetaDBTables 中的静态方法
产生当前集合对象[TableInfos]的实例
createNewInstance() - 类 com.trs.components.metadata.definition.MetaView 中的静态方法
产生当前对象[ViewInfo]的实例
createNewInstance() - 类 com.trs.components.metadata.definition.MetaViewField 中的静态方法
产生当前对象[ViewFieldInfo]的实例
createNewInstance(User) - 类 com.trs.components.metadata.definition.MetaViewFields 中的静态方法
产生当前集合对象[ViewFieldInfos]的实例
createNewInstance(User) - 类 com.trs.components.metadata.definition.MetaViews 中的静态方法
产生当前集合对象[ViewInfos]的实例
createNewInstance() - 类 com.trs.components.special.Special 中的静态方法
产生当前对象[Special]的实例
createNewInstance(User) - 类 com.trs.components.special.Specials 中的静态方法
产生当前集合对象[Specials]的实例
createNewInstance() - 类 com.trs.components.stat.BonusRule 中的静态方法
产生当前对象[BonusRule]的实例
createNewInstance(User) - 类 com.trs.components.stat.BonusRules 中的静态方法
产生当前集合对象[BonusRules]的实例
createNewInstance() - 类 com.trs.components.stat.ChnlDept 中的静态方法
产生当前对象[ChnlDept]的实例
createNewInstance(User) - 类 com.trs.components.stat.ChnlDepts 中的静态方法
产生当前集合对象[ChnlDepts]的实例
createNewInstance() - 类 com.trs.components.stat.DocumentHitsCount 中的静态方法
产生当前对象[DocumentHitsCount]的实例
createNewInstance(User) - 类 com.trs.components.stat.DocumentHitsCounts 中的静态方法
产生当前集合对象[DocumentHitsCounts]的实例
createNewInstance() - 类 com.trs.components.stat.HostObjDomain 中的静态方法
产生当前对象[HostObjDomain]的实例
createNewInstance(User) - 类 com.trs.components.stat.HostObjDomains 中的静态方法
产生当前集合对象[HostObjDomains]的实例
createNewInstance() - 类 com.trs.components.stat.HostObjHitsCount 中的静态方法
产生当前对象[HostObjHitsCount]的实例
createNewInstance(User) - 类 com.trs.components.stat.HostObjHitsCounts 中的静态方法
产生当前集合对象[HostObjHitsCounts]的实例
createNewInstance() - 类 com.trs.components.stat.UserLoginInfo 中的静态方法
产生当前对象[UserLoginInfo]的实例
createNewInstance(User) - 类 com.trs.components.stat.UserLoginInfos 中的静态方法
产生当前集合对象[UserLoginInfos]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态方法
产生当前对象[Appendix]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.Appendixes 中的静态方法
产生一个当前集合对象[Appendixes]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态方法
产生当前对象[AutoBakConfig]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.AutoBakConfigs 中的静态方法
产生当前集合对象[AutoBakConfigs]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.Channel 中的静态方法
产生当前对象[Channel]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的静态方法
产生当前对象[ChannelContentLink]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.ChannelContentLinks 中的静态方法
产生当前集合对象[ChannelContentLinks]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.Channels 中的静态方法
产生一个当前集合对象[Channels]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的静态方法
产生当前对象[ChannelSyn]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.ChannelSyns 中的静态方法
产生当前集合对象[ChannelSyns]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态方法
产生当前对象[ChnlDoc]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.ChnlDocs 中的静态方法
产生一个当前集合对象[ChnlDocs]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的静态方法
产生当前对象[ContentExtField]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.ContentExtFields 中的静态方法
产生当前集合对象[ContentExtFields]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的静态方法
产生当前对象[ContentLink]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.ContentLinks 中的静态方法
产生当前集合对象[ContentLinks]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的静态方法
产生当前对象[ContentLinkType]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.ContentLinkTypes 中的静态方法
产生当前集合对象[ContentLinkTypes]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.DocBak 中的静态方法
产生当前对象[DocBak]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.DocBaks 中的静态方法
产生一个当前集合对象[DocBaks]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.DocReply 中的静态方法
产生当前对象[DocReply]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.DocReplys 中的静态方法
产生一个当前集合对象[DocReplys]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法
产生当前对象[Document]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.Documents 中的静态方法
产生当前集合对象[Documents]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的静态方法
产生当前对象[TransmittedDoc]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.DocumentSyns 中的静态方法
产生当前集合对象[TransmittedDocs]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.Relation 中的静态方法
产生当前对象[Relation]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.Relations 中的静态方法
产生当前集合对象[Relations]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.Replace 中的静态方法
产生当前对象[Replace]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.Replaces 中的静态方法
产生当前集合对象[Replaces]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.SiteMember 中的静态方法
产生当前对象[SiteUser]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.SiteMembers 中的静态方法
产生一个当前集合对象[SiteUsers]的实例
createNewInstance() - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态方法
产生当前对象[WebSite]的实例
createNewInstance(User) - 类 com.trs.components.wcm.content.persistent.WebSites 中的静态方法
产生当前集合对象[WebSites]的实例
createNewInstance() - 类 com.trs.components.wcm.customize.UserSetting 中的静态方法
产生当前对象[UserSetting]的实例
createNewInstance(User) - 类 com.trs.components.wcm.customize.UserSettings 中的静态方法
产生一个当前集合对象[UserSettings]的实例
createNewInstance(User) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 中的静态方法
产生当前集合对象[CustomSiteCheckedInfos]的实例
createNewInstance() - 类 com.trs.components.wcm.individuation.Individuation 中的静态方法
产生当前对象[Individuation]的实例
createNewInstance(User) - 类 com.trs.components.wcm.individuation.Individuations 中的静态方法
产生当前集合对象[Individuations]的实例
createNewInstance() - 类 com.trs.components.wcm.publish.logo.Logo 中的静态方法
产生当前对象[Logo]的实例
createNewInstance(User) - 类 com.trs.components.wcm.publish.logo.Logos 中的静态方法
产生当前集合对象[Logos]的实例
createNewInstance() - 类 com.trs.components.wcm.publish.region.CellInfo 中的静态方法
产生当前对象[CellInfo]的实例
createNewInstance(User) - 类 com.trs.components.wcm.publish.region.CellInfos 中的静态方法
产生当前集合对象[CellInfos]的实例
createNewInstance() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的静态方法
产生当前对象[RegionEmploy]的实例
createNewInstance(User) - 类 com.trs.components.wcm.publish.region.RegionEmploys 中的静态方法
产生当前集合对象[RegionEmploys]的实例
createNewInstance() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态方法
产生当前对象[RegionInfo]的实例
createNewInstance(User) - 类 com.trs.components.wcm.publish.region.RegionInfos 中的静态方法
产生当前集合对象[RegionInfos]的实例
createNewInstance() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的静态方法
产生当前对象[WCMFolderPublishConfig]的实例
createNewInstance() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的静态方法
产生当前对象[WCMPubStatusConfig]的实例
createNewInstance(User) - 类 com.trs.components.wcm.publish.WCMPubStatusConfigs 中的静态方法
产生当前集合对象[WCMPubStatusConfigs]的实例
createNewInstance() - 类 com.trs.components.wcm.recent.Recent 中的静态方法
产生当前对象[Recent]的实例
createNewInstance() - 类 com.trs.components.wcm.resource.DocKind 中的静态方法
产生当前对象[DocKind]的实例
createNewInstance() - 类 com.trs.components.wcm.resource.FileType 中的静态方法
产生当前对象[FileType]的实例
createNewInstance() - 类 com.trs.components.wcm.resource.Keyword 中的静态方法
产生当前对象[Keyword]的实例
createNewInstance(User) - 类 com.trs.components.wcm.resource.Keywords 中的静态方法
产生当前集合对象[Keywords]的实例
createNewInstance(User) - 类 com.trs.components.wcm.resource.Securities 中的静态方法
产生当前集合对象[Securities]的实例
createNewInstance() - 类 com.trs.components.wcm.resource.Security 中的静态方法
产生当前对象[Security]的实例
createNewInstance() - 类 com.trs.components.wcm.resource.Source 中的静态方法
产生当前对象[Source]的实例
createNewInstance(User) - 类 com.trs.components.wcm.resource.Sources 中的静态方法
产生当前集合对象[Sources]的实例
createNewInstance() - 类 com.trs.components.wcm.resource.Status 中的静态方法
产生当前对象[Status]的实例
createNewInstance(User) - 类 com.trs.components.wcm.resource.Statuses 中的静态方法
产生当前集合对象[Statuses]的实例
createNewInstance() - 类 com.trs.components.wcm.stat.StatFieldMap 中的静态方法
产生当前对象[StatFieldsMap]的实例
createNewInstance(User) - 类 com.trs.components.wcm.stat.StatFieldMaps 中的静态方法
产生当前集合对象[StatFieldsMaps]的实例
createNewInstance() - 类 com.trs.components.wcm.stat.StatHost 中的静态方法
产生当前对象[StatHost]的实例
createNewInstance(User) - 类 com.trs.components.wcm.stat.StatHosts 中的静态方法
产生当前集合对象[StatHosts]的实例
createNewInstance() - 类 com.trs.components.wcm.stat.StatView 中的静态方法
产生当前对象[StatView]的实例
createNewInstance() - 类 com.trs.components.wcm.stat.StatViewRel 中的静态方法
产生当前对象[StatViewRel]的实例
createNewInstance(User) - 类 com.trs.components.wcm.stat.StatViewRels 中的静态方法
产生当前集合对象[StatViewRels]的实例
createNewInstance(User) - 类 com.trs.components.wcm.stat.StatViews 中的静态方法
产生当前集合对象[StatViews]的实例
createNewInstance() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的静态方法
产生当前对象[WCMHelp]的实例
createNewInstance(User) - 类 com.trs.components.wcm.wcmx.help.WCMHelps 中的静态方法
产生当前集合对象[WCMHelps]的实例
createNewInstance() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态方法
产生当前对象[MediaRemindedInfo]的实例
createNewInstance() - 类 com.trs.db.update.DBUpdateLog 中的静态方法
产生当前对象[DBUpdateLog]的实例
createNewInstance() - 类 com.trs.db.update.DBUpdateLogs 中的静态方法
产生当前集合对象[DBUpdateLogs]的实例
createNewInstance(Class) - 类 com.trs.infra.persistent.BaseObj 中的静态方法
产生指定的WCM元素对象的实例
createNewInstance(String) - 类 com.trs.infra.persistent.BaseObj 中的静态方法
产生指定的WCM元素对象的实例
createNewInstance() - 类 com.trs.infra.support.config.Config 中的静态方法
产生当前对象[Config]的实例
createNewInstance() - 类 com.trs.infra.support.config.Configs 中的静态方法
产生当前集合对象[Configs]的实例
createNewInstance() - 类 com.trs.infra.support.log.Log 中的静态方法
产生当前对象[WCMLog]的实例
createNewInstance() - 类 com.trs.infra.support.log.LogBak 中的静态方法
产生当前对象[LogBak]的实例
createNewInstance() - 类 com.trs.infra.support.log.LogBaks 中的静态方法
产生当前集合对象[WCMLogBaks]的实例
createNewInstance() - 类 com.trs.infra.support.log.Logs 中的静态方法
产生当前集合对象[WCMLogs]的实例
createNewInstance() - 类 com.trs.infra.support.log.OperType 中的静态方法
产生当前对象[OperType]的实例
createNewInstance() - 类 com.trs.infra.support.log.OperTypes 中的静态方法
产生当前集合对象[OperTypes]的实例
createNewInstance() - 类 com.trs.infra.support.security.SecureKey 中的静态方法
产生当前对象[SecureKey]的实例
createNewInstance() - 类 com.trs.infra.support.security.SecureKeys 中的静态方法
产生当前集合对象[SecureKeys]的实例
createNewInstance() - 类 com.trs.infra.util.job.JobFailedResult 中的静态方法
产生当前对象[JobFailedResult]的实例
createNewInstance() - 类 com.trs.infra.util.job.JobFailedResults 中的静态方法
产生当前集合对象[JobFailedResults]的实例
createNewInstance() - 类 com.trs.wcm.config.PageOperator 中的静态方法
产生当前对象[PageOperator]的实例
createNewInstance(User) - 类 com.trs.wcm.config.PageOperators 中的静态方法
产生当前集合对象[PageOperators]的实例
createNewInstance() - 类 com.trs.wcm.photo.Watermark 中的静态方法
产生当前对象[Watermark]的实例
createNewInstance(User) - 类 com.trs.wcm.photo.Watermarks 中的静态方法
产生当前集合对象[Watermarks]的实例
createNewSiteFrom(String, String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 中的方法
从指定站点指定样式中创建新的站点
createNewSiteFrom(String, String, String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 中的方法
createNewSiteFrom(String, String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 中的方法
createNewSiteFrom(String, String, String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 中的方法
createObjectById(String) - 类 com.trs.DreamFactory 中的静态方法
产生指定对象的实例
createOfficeDocumentService() - 类 com.trs.service.ServiceHelper 中的静态方法
createOracleUpateSQL(CMyDateTime) - 类 com.trs.db.update.SQLServerUpdateSQL 中的静态方法
createPageParameterFromXML(Element) - 类 com.trs.presentation.util.PageParameter 中的静态方法
通过一个XML数据产生一个PageParameter对象
createPageParameterFromXML(Element) - 类 com.trs.webframework.config.TRSPageParameter 中的静态方法
通过一个XML数据产生一个PageParameter对象
createParameterInstance() - 类 com.trs.presentation.util.AppAutoParameters 中的方法
createParameterInstance() - 类 com.trs.presentation.util.PageParameters 中的方法
createParameterInstance() - 类 com.trs.presentation.util.Parameters 中的方法
产生当前参数对象的实例
createParserByName(String) - 类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 中的静态方法
Creates a parser instance for the specified tag.
createPluginEncodeUserInfo() - 类 com.trs.presentation.util.LoginHelper 中的方法
createPluginEncodeUserInfo(String) - 类 com.trs.presentation.util.LoginHelper 中的方法
createPorterVisitor(String) - 类 com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory 中的静态方法
获取已注册的wcm对象导入/导出访问器
createPorterVisotor(Class) - 类 com.trs.components.wcm.content.service.portervisitors.PorterVisitorFactory 中的静态方法
获取已注册的wcm对象导入/导出访问器
createQueryFilter(int) - 接口 com.trs.components.filter.IQueryFilterFactory 中的方法
通过类型构造查询过滤器
createQueryFilter(int) - 类 com.trs.components.filter.QueryFilterFactory 中的方法
createRecentService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IRecentService的实例
createRelatedEmployes(Channel, Channel) - 类 com.trs.ajaxservice.ChannelServiceProviderHelper 中的静态方法
createRelatedEmployes(String, BaseChannel) - 类 com.trs.ajaxservice.ChannelServiceProviderHelper 中的静态方法
createResourceService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IResourceService的实例
createRoleService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IRoleService的实例
createSchedule(Message, CMyDateTime) - 类 com.trs.components.common.reminder.Reminder 中的静态方法
创建一个消息提醒
createScheduleService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IScheduleService的实例
createSites(ClassInfo, MetaView, int, String) - 类 com.trs.components.metadata.service.ClassInfoToChannelHelper 中的静态方法
createSmallImage(String, String, int) - 类 com.trs.infra.util.CImage 中的方法
createSocket() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法
createSocket(String, int, InetAddress, int) - 类 com.trs.infra.util.MySSLSocketFactory 中的方法
createSocket(String, int, InetAddress, int, HttpConnectionParams) - 类 com.trs.infra.util.MySSLSocketFactory 中的方法
createSocket(String, int) - 类 com.trs.infra.util.MySSLSocketFactory 中的方法
createSQLServerUpateSQL(CMyDateTime) - 类 com.trs.db.update.SQLServerUpdateSQL 中的静态方法
createStatDataInTempTableByDay(CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatDocCountByChannel 中的方法
createStatDataInTempTableByDay(CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfGroupByChannel 中的方法
createStatDataInTempTableByDay(CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfGroupByMetaClass 中的方法
createStatDataInTempTableByDay(CMyDateTime, CMyDateTime) - 类 com.trs.components.stat.StatDocCountOfUserByMetaClass 中的方法
createStatService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IStatService的实例
createStyleFile(User, PageStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
生成风格文件
createStyleFile(User, PageStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
createSureformService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生ISureformService的实例
createTableSQL(int) - 类 com.trs.components.infoview.db.InfoViewDBMgr 中的方法
createTemplateFromMaster(IPublishFolder, Master, int) - 接口 com.trs.components.common.publish.widget.IWidgetServer 中的方法
根据母版内容，创建新的模板
createTemplateFromMaster(IPublishFolder, Master, int) - 类 com.trs.components.common.publish.widget.WidgetServer 中的方法
createTemplateParseService() - 类 com.trs.service.ServiceHelper 中的静态方法
createTemplateService() - 类 com.trs.service.ServiceHelper 中的静态方法
createTemplateService(String) - 类 com.trs.template.TemplateServiceFactory 中的静态方法
创建ITemplateService实例
CreateThreadForPDF - com.wcm.pdf 中的 类
CreateThreadForPDF(String, String, String, String) - 类 com.wcm.pdf.CreateThreadForPDF 的构造方法
CreateThreadForPDFOfWins - com.wcm.pdf 中的 类
CreateThreadForPDFOfWins(String, String, String, String, ServletContext) - 类 com.wcm.pdf.CreateThreadForPDFOfWins 的构造方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.CrUserAsToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.DeptMgrAsToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.GroupAdminsAsToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.GroupAdminsFromChnlAsToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.GroupAdminsFromFlowAsToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.GroupAdminsFromSupportPartAsToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.RoleAsToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 接口 com.trs.cms.process.engine.IToUsersCreator 中的方法
根据当前上下文信息产生处理者信息
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.components.gkml.sqgk.process.engine.creators.ApplyFormToUsersCreator 中的方法
createToUsers(FlowContext, ToUsersCreatorConfig) - 类 com.trs.components.gkml.sqgk.process.engine.creators.LawGovTousersCreator 中的方法
createUserService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IUserService的实例
createValueCreator(int) - 类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory 中的静态方法
createValueCreator(String) - 类 com.trs.components.metadata.center.FieldValueCreatorFactory 中的静态方法
根据指定的对象的class产生将指定对象转换为XML的转换器
createViewApplication(MetaView, String, String) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8
createViewApplication(MetaView, String, String) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
视图+模板目录中所有的文件在应用目录产生文件，写入编码为UTF-8
createViewRelation(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
重新产生所有视图或者指定视图的应用
createViewRelations(User, MetaView) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
createViewRelations(User, MetaView, boolean) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
视图定义完成，产生视图相关的信息（DB视图、相关的JSP）
createViewRelations(User, MetaView) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
createViewRelations(User, MetaView, boolean) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
createVip(String, String, String, String, String) - 类 com.trs.wcmonline.WCMOnlineService 中的方法
createWCMProcessService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IWCMProcessService的实例
createWCMPublishElementService() - 类 com.trs.service.ServiceHelper 中的静态方法
产生IWCMPublishElementSetting的实例
createWord() - 类 com.wcm.pdf.CreateThreadForPDF 中的方法
createWord() - 类 com.wcm.pdf.CreateThreadForPDFOfWins 中的方法
CreatHeadPart() - 类 com.trs.components.wcm.wcmx.util.CWasTree 中的方法
CreatNavTree(Channels, int) - 类 com.trs.components.wcm.wcmx.util.CWasTree 中的方法
creatNewInstance(User) - 类 com.trs.cms.auth.persistent.GroupRoles 中的静态方法
产生一个当前集合对象[RoleUsers]的实例
creatNewInstance(User) - 类 com.trs.cms.auth.persistent.GroupUsers 中的静态方法
产生一个当前集合对象[GroupUsers]的实例
creatNewInstance(User) - 类 com.trs.cms.auth.persistent.RoleUsers 中的静态方法
产生一个当前集合对象[RoleUsers]的实例
creatNewInstance(User) - 类 com.trs.components.common.calendar.EventShares 中的静态方法
产生一个当前集合对象[EventShares]的实例
CreatStylePart() - 类 com.trs.components.wcm.wcmx.util.CWasTree 中的方法
CRegister - com.trs.infra.util.key 中的 类
CRegister() - 类 com.trs.infra.util.key.CRegister 的构造方法
CRightUtil - com.trs.components.wcm.util 中的 类
CRightUtil() - 类 com.trs.components.wcm.util.CRightUtil 的构造方法
CRightUtil(RightDefs) - 类 com.trs.components.wcm.util.CRightUtil 的构造方法
CRightUtil(RightDefs, Rights, Rights, Rights) - 类 com.trs.components.wcm.util.CRightUtil 的构造方法
crop(ImageMagickCmd.ImageObj, int, int, int, int) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法
cropImage(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
用于裁剪图片
cropImage(int, int, int, int, String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
裁剪图片
cropImage(int, int, int, int, String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
CRT_PARAMS_COUNT_NONE - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的静态变量
CRT_PARAMS_COUNT_ONE - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的静态变量
CRT_PARAMS_COUNT_TWO - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的静态变量
CrUserAsToUsersCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CrUserAsToUsersCreator() - 类 com.trs.cms.process.engine.creators.CrUserAsToUsersCreator 的构造方法
CSQLText - com.trs.infra.util.database 中的 类
CSQLText() - 类 com.trs.infra.util.database.CSQLText 的构造方法
默认构造函数
CSSResourceProcessor - com.trs.components.common.publish.domain.template 中的 类
CSSResourceProcessor() - 类 com.trs.components.common.publish.domain.template.CSSResourceProcessor 的构造方法
CurrentDateCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CurrentDateCreator() - 类 com.trs.cms.process.engine.creators.CurrentDateCreator 的构造方法
CurrentDocStatusCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
CurrentDocStatusCreator() - 类 com.trs.cms.process.engine.creators.CurrentDocStatusCreator 的构造方法
CurrentTimeCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CurrentTimeCreator() - 类 com.trs.cms.process.engine.creators.CurrentTimeCreator 的构造方法
CurrentUserNameCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CurrentUserNameCreator() - 类 com.trs.cms.process.engine.creators.CurrentUserNameCreator 的构造方法
CustomizedChannelIdsMan - com.trs.components.wcm.customize 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户个性化定制频道的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CustomizedChannelIdsMan(User) - 类 com.trs.components.wcm.customize.CustomizedChannelIdsMan 的构造方法
CustomizeMgr - com.trs.components.wcm.customize 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CustomizeMgr() - 类 com.trs.components.wcm.customize.CustomizeMgr 的构造方法
CustomizeMgrImpl - com.trs.wcm.customize 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CustomizeMgrImpl() - 类 com.trs.wcm.customize.CustomizeMgrImpl 的构造方法
CustomizeService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制服务提供对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
CustomizeService() - 类 com.trs.service.impl.CustomizeService 的构造方法
CustomSiteCheckedInfo - com.trs.components.wcm.individuation 中的 类
CustomSiteCheckedInfo() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 的构造方法
构造函数：保留默认接口
CustomSiteCheckedInfos - com.trs.components.wcm.individuation 中的 类
CustomSiteCheckedInfos(User) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 的构造方法
构造函数
CustomSiteCheckedInfos(User, int, int) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 的构造方法
构造函数
cutStr(String, int) - 类 com.trs.infra.util.CMyString 中的静态方法
已过时。 已经由函数truncateStr替代
CWasTree - com.trs.components.wcm.wcmx.util 中的 类
Title: Description: Copyright: Copyright (c) 2003 Company:
CWasTree() - 类 com.trs.components.wcm.wcmx.util.CWasTree 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


D - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

D

DamengDB - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
达梦
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DamengDB() - 类 com.trs.infra.util.database.DamengDB 的构造方法
DamengDB(String, String) - 类 com.trs.infra.util.database.DamengDB 的构造方法
DATA - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
DATA_TYPE_BOOLEAN - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_BOOLEAN 布尔型
DATA_TYPE_BOOLEAN_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_BOOLEAN 布尔型
DATA_TYPE_DATE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_DATE 日期型
DATA_TYPE_DATE_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_DATE 日期型
DATA_TYPE_DATETIME - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_DATETIME 日期时间型
DATA_TYPE_DATETIME_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_DATETIME 日期时间型
DATA_TYPE_DOUBLE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_DOUBLE 双精度
DATA_TYPE_DOUBLE_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_DOUBLE 双精度
DATA_TYPE_FLOAT - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_FLOAT 浮点型
DATA_TYPE_FLOAT_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_FLOAT 浮点型
DATA_TYPE_INT - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_INT 整型
DATA_TYPE_INT_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_INT 整型
DATA_TYPE_LONG - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_LONG 长整型
DATA_TYPE_LONG_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_LONG 长整型
DATA_TYPE_PINT - 类 com.trs.webframework.FrameworkConstants 中的静态变量
多整型
DATA_TYPE_PINT_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
多整型
DATA_TYPE_STRING - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_STRING 字符型
DATA_TYPE_STRING_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_STRING 字符型
DATA_TYPE_TIME - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_TIME 时间型
DATA_TYPE_TIME_HASHCODE - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPE_TIME 时间型
DATA_TYPES - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
DATA_TYPES_SUPPORTED - 类 com.trs.webframework.FrameworkConstants 中的静态变量
Comment for TYPES_SUPPORTED
DataAnalyzingException - com.trs.webframework.xmlserver.server 中的 异常
DataAnalyzingException() - 异常 com.trs.webframework.xmlserver.server.DataAnalyzingException 的构造方法
DataAnalyzingException(String) - 异常 com.trs.webframework.xmlserver.server.DataAnalyzingException 的构造方法
DataAnalyzingException(Throwable) - 异常 com.trs.webframework.xmlserver.server.DataAnalyzingException 的构造方法
DataAnalyzingException(String, Throwable) - 异常 com.trs.webframework.xmlserver.server.DataAnalyzingException 的构造方法
DataDictionary - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
数据字典
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DataDictionary(String, String, String) - 类 com.trs.database.util.DataDictionary 的构造方法
DataFormatException - com.trs.infra.util.jazzlib 中的 异常
Exception thrown when compressed data is corrupt.
DataFormatException() - 异常 com.trs.infra.util.jazzlib.DataFormatException 的构造方法
DataFormatException(String) - 异常 com.trs.infra.util.jazzlib.DataFormatException 的构造方法
DataFromNewshoo - com.trs.components.wcm.newshoo 中的 类
Title: 网站内容管理（TRSWCM） Description: Copyright: Copyright (c) 2001 Company: www.trs.com.cn
DataFromNewshoo() - 类 com.trs.components.wcm.newshoo.DataFromNewshoo 的构造方法
DataFromRadar - com.trs.components.wcm.newshoo 中的 类
DataFromRadar() - 类 com.trs.components.wcm.newshoo.DataFromRadar 的构造方法
DataFromRadarClient - com.trs.components.wcm.newshoo 中的 类
DataFromRadarClient() - 类 com.trs.components.wcm.newshoo.DataFromRadarClient 的构造方法
DataGroup - com.trs.components.infoview.extract 中的 类
DataOfV6To52 - com.trs.util 中的 类
DataOfV6To52() - 类 com.trs.util.DataOfV6To52 的构造方法
DatasFromTRSServer - com.trs.components.wcm.content.trsserver 中的 类
DatasFromTRSServer() - 类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 的构造方法
构造函数
DatasWithChnlDocFilterHelper - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
单表提取文档集合的功能对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DatasWithChnlDocFilterHelper() - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 的构造方法
DatasWithChnlDocFilterHelper(String, String) - 类 com.trs.components.wcm.content.domain.DatasWithChnlDocFilterHelper 的构造方法
DataTransferEncodeFactory - com.trs.template 中的 类
DataTransferEncodeFactory() - 类 com.trs.template.DataTransferEncodeFactory 的构造方法
DataType - com.trs.components.infoview.extract 中的 类
DataType - com.trs.infra.util.database 中的 类
DataType(String, int) - 类 com.trs.infra.util.database.DataType 的构造方法
构造函数
DataType(String, int, int) - 类 com.trs.infra.util.database.DataType 的构造方法
构造函数
DataTypeBuilder - com.trs.components.infoview.extract 中的 类
DataTypeBuilder() - 类 com.trs.components.infoview.extract.DataTypeBuilder 的构造方法
DataTypeToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
DataType的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DataTypeToXML() - 类 com.trs.ajaxservice.xmlconvertors.DataTypeToXML 的构造方法
DataUtil - com.trs.components.wcm.wcmx.jsp 中的 类
DataUtil() - 类 com.trs.components.wcm.wcmx.jsp.DataUtil 的构造方法
DATE - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：DATE
DATE - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：DATE
DATE - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：DATE
DATE - 类 com.trs.infra.util.database.KingBaseDB 中的静态变量
定义SQL Server中的字段类型：DATE
DATE - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
DATE - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：DATE
DATE - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
dateAdd(int, int) - 类 com.trs.infra.util.CMyDateTime 中的方法
日期时间增/减函数
dateDiff(int, CMyDateTime) - 类 com.trs.infra.util.CMyDateTime 中的方法
取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差
dateDiff(int, Date) - 类 com.trs.infra.util.CMyDateTime 中的方法
取与指定时间之间的（年/月/日/小时/分/秒/季度/周）差
dateDiff_month(Date) - 类 com.trs.infra.util.CMyDateTime 中的方法
计算当前时间对象与指定时间的【月】差
DATETIME - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
DATETIME - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
DATETIME - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
DATETIME - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：DATE
DATETIME - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：DATETIME
DATETIME - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：DATETIME
DATETIME - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：DATETIME
DAY - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日期/时间的各个部分标识：日（3）
DAY_OF_MONTH - 类 com.trs.infra.util.CMyDateTime 中的静态变量
当月天数（13）
DAY_OF_YEAR - 类 com.trs.infra.util.CMyDateTime 中的静态变量
当年天数（15）
DB2AS400 - 类 com.trs.infra.util.database.DBTypes 中的静态变量
定义数据库类型：DB2 UDB AS400
db2AS400 - 类 com.trs.infra.util.database.DBTypes 中的静态变量
数据库类型对象：DB2AS400DB(DB2 Type4)
DB2AS400DB - com.trs.infra.util.database 中的 类
DB2AS400DB() - 类 com.trs.infra.util.database.DB2AS400DB 的构造方法
DB2AS400DB(String, String, boolean) - 类 com.trs.infra.util.database.DB2AS400DB 的构造方法
构造函数
注：支持存储过程
db2Instance - 类 com.trs.infra.util.database.DBTypes 中的静态变量
数据库类型对象：DB2UDB
db2Instance2 - 类 com.trs.infra.util.database.DBTypes 中的静态变量
数据库类型对象：DB2UDB2(DB2 Type4)
DB2ReorgUtil - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
执行db2 reorg table 命令的工具类.
DB2ReorgUtil() - 类 com.trs.infra.util.database.DB2ReorgUtil 的构造方法
DB2UDB - com.trs.infra.util.database 中的 类
DB2UDB() - 类 com.trs.infra.util.database.DB2UDB 的构造方法
DB2UDB(String, String, boolean) - 类 com.trs.infra.util.database.DB2UDB 的构造方法
构造函数
注：支持存储过程
DB2UDB - 类 com.trs.infra.util.database.DBTypes 中的静态变量
定义数据库类型：DB2 UDB
DB2UDB2 - com.trs.infra.util.database 中的 类
DB2UDB2() - 类 com.trs.infra.util.database.DB2UDB2 的构造方法
DB2UDB2(String, String, boolean) - 类 com.trs.infra.util.database.DB2UDB2 的构造方法
构造函数
注：支持存储过程
DB2UDB2 - 类 com.trs.infra.util.database.DBTypes 中的静态变量
DB2UDBV9 - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
DB2 UDB V9+
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DB2UDBV9() - 类 com.trs.infra.util.database.DB2UDBV9 的构造方法
DB2UDBV9(String, String, boolean) - 类 com.trs.infra.util.database.DB2UDBV9 的构造方法
DB2UpdSqlMaker - com.trs.infra.util.upgrade.sql 中的 类
DB2UpdSqlMaker() - 类 com.trs.infra.util.upgrade.sql.DB2UpdSqlMaker 的构造方法
DB_AUTO_COMMIT - 类 com.trs.db.update.DBUpdateLog 中的静态变量
DB_BUILD - 类 com.trs.infra.BaseServer 中的变量
当前连接的数据库版本信息
DB_DATA_TYPES - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量
DB_DATA_TYPES - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
DB_DOCUMENT_FIELDS - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
DB_FIELD_DBNAME_NAME - 类 com.trs.components.metadata.definition.MetaDBField 中的静态变量
对象数据存储物理字段名的字段
DB_FIELD_DBTYPE_NAME - 类 com.trs.components.metadata.definition.MetaDBField 中的静态变量
对象数据存储物理字段类型的字段
DB_FIELD_DBTYPE_NAME - 类 com.trs.components.metadata.definition.MetaViewField 中的静态变量
对象数据存储物理字段类型的字段
DB_FIELD_ITEMID - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_FIELD_OPTIONID - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_FIELD_STYLE - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_FIELD_TITLE - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_FIELD_VOTEID - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_ID_NAME - 类 com.trs.cms.auth.persistent.Group 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.GroupRole 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.GroupUser 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.ObjectMember 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.Right 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.RightDef 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.Role 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.RoleUser 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.auth.persistent.User 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.content.ExtendedField 中的静态变量
对象所对应的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.Flow 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.FlowAction 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.FlowCondition 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.FlowdocLog 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.FlowEmploy 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.FlowNode 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.FlowNodeBranch 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.FlowNodeField 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.definition.FlowRule 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.engine.FlowContentConfig 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.engine.FlowDoc 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.cms.process.engine.FlowDocBak 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.comment.persistent.DocumentTopic 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.address.Contact 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.address.ContactGrp 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.bookmark.BookMark 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.bookmark.MarkKind 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.bookmark.MarkShare 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.calendar.Event 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.calendar.EventShare 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.calendar.EventType 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
数据表的ID字段名称
DB_ID_NAME - 类 com.trs.components.common.job.Schedule 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.message.Message 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.message.MsgQueue 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.message.MsgReceiver 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.template.TagBean 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.template.Template 中的静态变量
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.ContentStyle 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.Master 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.PageStyle 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.ResourceStyle 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.StyleAndResource 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.StyleItem 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.Widget 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.WidgetInstance 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsad.ADCom 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsad.ADFile 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsad.ADFilePos 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsad.ADPos 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsad.ADType 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsvote.Vote 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsvote.VoteData 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsvote.VoteIPLog 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsvote.VoteItem 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.common.trsvote.VoteOption 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.infoview.helper.ComplexFieldData 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.infoview.persistent.InfoView 中的静态变量
TODO Add javadoc for field DB_ID_NAME
DB_ID_NAME - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的静态变量
TODO Add javadoc for field DB_ID_NAME
DB_ID_NAME - 类 com.trs.components.infoview.persistent.InfoViewField 中的静态变量
DB_ID_NAME - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的静态变量
DB_ID_NAME - 类 com.trs.components.infoview.persistent.InfoViewView 中的静态变量
DB_ID_NAME - 类 com.trs.components.metadata.center.ClassInfoView 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.metadata.center.MetaViewEmployer 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.metadata.center.MetaViewEmployers 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.metadata.definition.ClassInfo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.metadata.definition.MetaDBField 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.metadata.definition.MetaDBTable 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.metadata.definition.MetaView 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.metadata.definition.MetaViewField 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.special.Special 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.stat.BonusRule 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.stat.ChnlDept 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.stat.DocumentHitsCount 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.stat.HostObjDomain 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.stat.HostObjHitsCount 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.stat.UserLoginInfo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.ContentLink 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.DocBak 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.DocReply 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的静态变量
数据表的ID字段名称
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.HitsCount 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.Relation 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.Replace 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.SiteMember 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
DB_ID_NAME - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.individuation.Individuation 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.publish.logo.Logo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.publish.region.CellInfo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.recent.Recent 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.resource.DocKind 中的静态变量
DB_ID_NAME - 类 com.trs.components.wcm.resource.FileType 中的静态变量
DB_ID_NAME - 类 com.trs.components.wcm.resource.Keyword 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.resource.Security 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.resource.Source 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.resource.Status 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.stat.StatFieldMap 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.stat.StatHost 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.stat.StatView 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.stat.StatViewRel 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.db.update.DBUpdateLog 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.infra.persistent.CMyResultSet 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.infra.support.config.Config 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.infra.support.log.Log 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.infra.support.log.LogBak 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.infra.support.log.OperType 中的静态变量
DB_ID_NAME - 类 com.trs.infra.support.security.SecureKey 中的静态变量
对象表的主键列
DB_ID_NAME - 类 com.trs.infra.util.job.JobFailedResult 中的静态变量
DB_ID_NAME - 类 com.trs.wcm.config.PageOperator 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.wcm.old.WCMExcelData 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.wcm.old.WCMFormFields 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.wcm.old.WCMFormInfo 中的静态变量
对象数据存储的ID字段名
DB_ID_NAME - 类 com.trs.wcm.photo.Watermark 中的静态变量
对象数据存储的ID字段名
DB_KEYWORDS_RESOURCE - 类 com.trs.infra.util.database.CDBKeyWords 中的静态变量
DB_PREFIX - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_TABLE_DATA - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_TABLE_GRPUSER - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_TABLE_IPLOG - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_TABLE_ITEM - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.Group 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.GroupRole 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.GroupUser 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.ObjectMember 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.Right 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.RightDef 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.Role 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.RoleUser 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.auth.persistent.User 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.content.ExtendedField 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.Flow 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.FlowAction 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.FlowCondition 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.FlowdocLog 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.FlowEmploy 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.FlowNode 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.FlowNodeBranch 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.FlowNodeField 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.process.definition.FlowRule 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.process.engine.FlowContentConfig 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.cms.process.engine.FlowDoc 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.cms.process.engine.FlowDocBak 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.comment.persistent.DocumentTopic 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.address.Contact 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.address.ContactGrp 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.bookmark.BookMark 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.bookmark.MarkKind 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.bookmark.MarkShare 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.calendar.Event 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.calendar.EventShare 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.calendar.EventType 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
对象所使用的数据表
DB_TABLE_NAME - 类 com.trs.components.common.job.Schedule 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.message.Message 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.message.MsgQueue 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.message.MsgReceiver 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.template.TagBean 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.template.Template 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.ContentStyle 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.Layout 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.Master 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.PageStyle 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.ResourceStyle 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.StyleAndResource 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.StyleItem 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.Widget 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.WidgetInstance 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsad.ADCom 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsad.ADFile 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsad.ADFilePos 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsad.ADPos 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsad.ADType 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsvote.Vote 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsvote.VoteData 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsvote.VoteIPLog 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsvote.VoteItem 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.common.trsvote.VoteOption 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.infoview.helper.ComplexFieldData 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.infoview.persistent.InfoView 中的静态变量
TODO Add javadoc for field DB_TABLE_NAME
DB_TABLE_NAME - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的静态变量
TODO Add javadoc for field DB_TABLE_NAME
DB_TABLE_NAME - 类 com.trs.components.infoview.persistent.InfoViewField 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.infoview.persistent.InfoViewView 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.metadata.center.ClassInfoView 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.metadata.center.MetaViewEmployer 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.metadata.center.MetaViewEmployers 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.metadata.definition.ClassInfo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.metadata.definition.MetaDBField 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.metadata.definition.MetaDBTable 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.metadata.definition.MetaView 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.metadata.definition.MetaViewField 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.special.Special 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.stat.BonusRule 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.stat.ChnlDept 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.stat.DocumentHitsCount 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.stat.HostObjDomain 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.stat.HostObjHitsCount 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.stat.UserLoginInfo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.ContentLink 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.DocBak 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.DocReply 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的静态变量
对象所使用的数据表
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.HitsCount 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.Relation 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.Replace 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.SiteMember 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.content.ViewDocument 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.wcm.content.ViewDocuments 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.wcm.customize.UserSetting 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.individuation.Individuation 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.publish.logo.Logo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.publish.region.CellInfo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.recent.Recent 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.resource.DocKind 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.wcm.resource.FileType 中的静态变量
DB_TABLE_NAME - 类 com.trs.components.wcm.resource.Keyword 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.resource.Security 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.resource.Source 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.resource.Status 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.components.wcm.stat.StatFieldMap 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.stat.StatHost 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.stat.StatView 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.stat.StatViewRel 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.db.update.DBUpdateLog 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.infra.persistent.CMyResultSet 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.infra.support.config.Config 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.infra.support.log.Log 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.infra.support.log.LogBak 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.infra.support.log.OperType 中的静态变量
DB_TABLE_NAME - 类 com.trs.infra.support.security.SecureKey 中的静态变量
对象在WCM中对应的数据表名
DB_TABLE_NAME - 类 com.trs.infra.util.job.JobFailedResult 中的静态变量
DB_TABLE_NAME - 类 com.trs.wcm.config.PageOperator 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.wcm.old.WCMExcelData 中的静态变量
对象所对应的数据表名
DB_TABLE_NAME - 类 com.trs.wcm.old.WCMFormFields 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.wcm.old.WCMFormInfo 中的静态变量
对象数据存储的数据库名
DB_TABLE_NAME - 类 com.trs.wcm.photo.Watermark 中的静态变量
对象数据存储的数据库名
DB_TABLE_OPTION - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_TABLE_USER - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_TABLE_VOTE - 类 com.trs.components.common.trsvote.JVoteConstant 中的静态变量
DB_TYPE_DB2 - 类 com.trs.db.update.DBUpdateLog 中的静态变量
DB_TYPE_MYSQL - 类 com.trs.db.update.DBUpdateLog 中的静态变量
DB_TYPE_ORACLE - 类 com.trs.db.update.DBUpdateLog 中的静态变量
DB_TYPE_SQL - 类 com.trs.db.update.DBUpdateLog 中的静态变量
DB_TYPE_SYBASE - 类 com.trs.db.update.DBUpdateLog 中的静态变量
DBCLOB - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：DBCLOB
DBCLOB - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：DBCLOB
DBCLOB - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：DBCLOB
DbConfig - com.trs.infra.util.upgrade 中的 类
数据库配置信息对象
DbConfig() - 类 com.trs.infra.util.upgrade.DbConfig 的构造方法
DBConnectionConfig - com.trs.infra.persistent.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库连接特性的配置对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DBConnectionConfig() - 类 com.trs.infra.persistent.db.DBConnectionConfig 的构造方法
DBConnectionConfigs - com.trs.infra.persistent.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库连接配置对象的集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DBConnectionConfigs() - 类 com.trs.infra.persistent.db.DBConnectionConfigs 的构造方法
DBConnectionMapper - com.trs.infra.persistent.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
DBConnectionConfig 的散列查找表
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DBConnectionMapper() - 类 com.trs.infra.persistent.db.DBConnectionMapper 的构造方法
Constructor
DbDDLMaker - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
从SQLServer中获取DDL
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DbDDLMaker() - 类 com.trs.database.util.DbDDLMaker 的构造方法
DBIdManager - com.trs.infra.util.database 中的 类
DBIdManager() - 类 com.trs.infra.util.database.DBIdManager 的构造方法
DBIdManager.IdSeq - com.trs.infra.util.database 中的 类
Title: 网站内容管理（TRSWCM） Description: 单个对象的ID管理者 Copyright: Copyright (c) 2001 Company: www.trs.com.cn
DBIdManager.IdSeq() - 类 com.trs.infra.util.database.DBIdManager.IdSeq 的构造方法
DBIdManager.IdSeq(int) - 类 com.trs.infra.util.database.DBIdManager.IdSeq 的构造方法
DBIdManager.IdSeq(int, int) - 类 com.trs.infra.util.database.DBIdManager.IdSeq 的构造方法
构造函数
DBManager - com.trs.infra.persistent.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DBManager() - 类 com.trs.infra.persistent.db.DBManager 的构造方法
DBMsgReceiver - com.trs.cluster.receiver 中的 类
DBMsgReceiver() - 类 com.trs.cluster.receiver.DBMsgReceiver 的构造方法
DBService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库相关操作服务层接口实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DBService() - 类 com.trs.service.impl.DBService 的构造方法
dbSybaseASE - 类 com.trs.infra.util.database.DBTypes 中的静态变量
数据库类型对象：SybaseASE
DBTableConfig - com.trs.infra.config 中的 类
DBTableConfig(String, String) - 类 com.trs.infra.config.DBTableConfig 的构造方法
DBType - com.trs.infra.util.database 中的 类
DBType(String, String, boolean) - 类 com.trs.infra.util.database.DBType 的构造方法
构造函数
DBTypes - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class DBTypes —— 支持的数据类型对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
DBTypes() - 类 com.trs.infra.util.database.DBTypes 的构造方法
DBUpdateLog - com.trs.db.update 中的 类
DBUpdateLog() - 类 com.trs.db.update.DBUpdateLog 的构造方法
构造函数：保留默认接口
DBUpdateLogMgr - com.trs.db.update 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理和数据库更新相关的行为s
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DBUpdateLogMgr() - 类 com.trs.db.update.DBUpdateLogMgr 的构造方法
DBUpdateLogs - com.trs.db.update 中的 类
DBUpdateLogs() - 类 com.trs.db.update.DBUpdateLogs 的构造方法
构造函数
DBUpdateLogs(int, int) - 类 com.trs.db.update.DBUpdateLogs 的构造方法
构造函数
DbUpdSqlLogMaker - com.trs.infra.util.upgrade.sql 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
产生更新SQL语句.
DD - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
DDLMain - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DDLMain() - 类 com.trs.database.util.DDLMain 的构造方法
DEAL_MODE_CHGNAME - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态变量
DEAL_MODE_IGNORE - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态变量
DEAL_MODE_QUIT - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态变量
DEAL_MODE_UPDATE - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态变量
DEAL_TYPE_DEALED - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
DEAL_TYPE_DEALING - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
申请的处理类型
DEAL_TYPE_REJECT - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
dealWithFieldsOfEnumValue() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
处理新添加的枚举值
DEBUG - 类 com.trs.infra.support.log.LogType 中的静态变量
日志类型:调试
DEBUG_USE_TIME - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 中的静态变量
DEBUG_USE_TIME - 类 com.trs.infra.persistent.BaseObjs 中的静态变量
DebugTimer - com.trs.infra.util 中的 类
DebugTimer() - 类 com.trs.infra.util.DebugTimer 的构造方法
DECIMAL - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：DECIMAL
DECIMAL - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：DECIMAL
DECIMAL - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：DECIMAL
DECIMAL - 类 com.trs.infra.util.database.MysqlDB 中的静态变量
DECIMAL - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：DECIMAL
DECIMAL - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：DECIMAL
DECIMAL - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：DECIMAL
DECLARE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
decode(byte[]) - 类 com.trs.infra.util.BASE64DecoderStream 中的静态方法
解码BASE64数组，输入的字节数组中不能含有BASE64字符以外的字符。
decode(String) - 类 com.trs.infra.util.BASE64DecoderStream 中的静态方法
解码BASE64编码的字符串，输入的字符串中不能含有BASE64字符以外的字符。
decode(String) - 类 com.trs.infra.util.Base64Util 中的静态方法
解码指定的字符串
decode(String) - 类 com.trs.infra.util.URLCoder 中的静态方法
使用缺省字符集解码URL字符串
decode(String, String) - 类 com.trs.infra.util.URLCoder 中的静态方法
使用指定的字符集解码URL
decodeForCDATA(String) - 类 com.trs.infra.util.CMyString 中的静态方法
处理XML内容
如果有经过@see #encodeForCDATA(String)替换的CDATA嵌套则还原
DecodeKey(String) - 类 com.trs.infra.util.key.CKeyUtil 中的静态方法
decodeRadix64(byte[]) - 类 com.trs.components.comment.domain.SignUtil 中的方法
decodeRadix64(byte[]) - 类 com.trs.infra.util.CMySign 中的方法
decodeRadix64(String) - 类 com.trs.license.LicenseUtil 中的静态方法
decorate(ServiceContext) - 类 com.trs.webframework.provider.BaseServiceDecorator 中的方法
decrypt(String, byte[]) - 类 com.trs.infra.support.security.SecureKeyMgr 中的方法
使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。
decrypt(String, byte[]) - 类 com.trs.service.impl.SecurityService 中的方法
decrypt(String, byte[]) - 接口 com.trs.service.ISecurityService 中的方法
使用指定名称的密钥解密指定的密文数据，并返回明文数据 如果指定的密钥是对称密钥，则一定使用私钥进行解密。
deEncrypt(String) - 类 com.trs.infra.persistent.db.ConnectPasswordEncrypter 中的静态方法
DEF_DATE_FORMAT - 类 com.trs.components.wcm.stat.domain.ChartOption 中的静态变量
DEF_DATE_FORMAT_PRG - 类 com.trs.infra.util.CMyDateTime 中的静态变量
默认日期字符串格式 "yyyy-MM-dd" （用于java程序）
DEF_DATETIME_FORMAT_DB - 类 com.trs.infra.util.CMyDateTime 中的静态变量
默认日时字符串格式 "YYYY-MM-DD HH24:MI:SS" （用于Oracle DB）
DEF_DATETIME_FORMAT_PRG - 类 com.trs.infra.util.CMyDateTime 中的静态变量
默认日时字符串格式 "yyyy-MM-dd HH:mm:ss" （用于java程序）
DEF_LOCKTIMEOUT - 类 com.trs.cms.content.Locker 中的静态变量
默认锁定时间为20分钟 20*60=1200
DEF_PAGE_FILEEXT - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
default file extent of detail pages
DEF_PAGE_FILENAME_OUTLINE - 类 com.trs.components.common.publish.PublishConstants 中的静态变量
default file name of outline pages
DEF_TIME_FORMAT_PRG - 类 com.trs.infra.util.CMyDateTime 中的静态变量
默认时间字符串格式 "HH:mm:ss" （用于java程序）
DEFAULT - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量
DEFAULT_CATEGORY - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的静态变量
DEFAULT_COMPRESSION - 类 com.trs.infra.util.jazzlib.Deflater 中的静态变量
The default compression level.
DEFAULT_CONTENT_ENCODING - 类 com.trs.infra.util.HttpClientBuddy 中的静态变量
DEFAULT_CONTENTADDEDITPAGE - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
DEFAULT_CONTENTLISTPAGE - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
DEFAULT_CONTENTSHOWPAGE - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
DEFAULT_DOCUMENT_SELECTFIELDS - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的静态变量
DEFAULT_ENCODING - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的静态变量
DEFAULT_FIELDS - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量
DEFAULT_FIELDS - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
DEFAULT_HEIGHT - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的静态变量
DEFAULT_LENGTH - 类 com.trs.infra.util.database.DBType 中的静态变量
DEFAULT_LINKCHANNELPAGE - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
DEFAULT_OPEN_RECORD_COUNT - 类 com.trs.infra.db.QueryFilter 中的静态变量
Comment for MAX_OPEN_RECORD_COUNT ：打开的最大记录数
DEFAULT_OPEN_RECORD_COUNT - 类 com.trs.infra.persistent.WCMFilter 中的静态变量
Comment for MAX_OPEN_RECORD_COUNT ：打开的最大记录数
DEFAULT_PAGE_SIZE - 类 com.trs.infra.util.CPager 中的静态变量
DEFAULT_PRECISION - 类 com.trs.infra.util.database.DBType 中的静态变量
DEFAULT_SCALE - 类 com.trs.infra.util.database.DBType 中的静态变量
DEFAULT_STRATEGY - 类 com.trs.infra.util.jazzlib.Deflater 中的静态变量
The default strategy.
DEFAULT_TRUNCLENGTH - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态变量
DEFAULT_WIDTH - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的静态变量
DefaultChannelMakerCenter - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DefaultChannelMakerCenter() - 类 com.trs.components.metadata.service.DefaultChannelMakerCenter 的构造方法
DefaultDeleteLogger - com.trs.webframework 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
默认的删除操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DefaultDeleteLogger() - 类 com.trs.webframework.DefaultDeleteLogger 的构造方法
DefaultHTMLMaker - com.trs.components.metadata.web.impl 中的 类
DefaultHTMLMaker() - 类 com.trs.components.metadata.web.impl.DefaultHTMLMaker 的构造方法
DefaultObj - com.trs.cms.content 中的 类
DefaultObj() - 类 com.trs.cms.content.DefaultObj 的构造方法
DefaultObj(String, String) - 类 com.trs.cms.content.DefaultObj 的构造方法
DefaultObjs - com.trs.cms.content 中的 类
DefaultObjs(User) - 类 com.trs.cms.content.DefaultObjs 的构造方法
DefaultObjs(User, String, String) - 类 com.trs.cms.content.DefaultObjs 的构造方法
DefaultObjs(User, int, int) - 类 com.trs.cms.content.DefaultObjs 的构造方法
DefaultPropertiesBuilder - com.trs.components.web 中的 类
DefaultPropertiesBuilder(BaseObj) - 类 com.trs.components.web.DefaultPropertiesBuilder 的构造方法
DefaultSaveLogger - com.trs.webframework 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
默认的保存操作日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DefaultSaveLogger() - 类 com.trs.webframework.DefaultSaveLogger 的构造方法
DefaultStatHandler - com.trs.components.stat 中的 类
默认的统计处理类
DefaultStatHandler() - 类 com.trs.components.stat.DefaultStatHandler 的构造方法
defaultValue - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的变量
列默认值
DefaultWCMObjectsToXML - com.trs.ajaxservice.xmlconvertors 中的 类
DefaultWCMObjectsToXML() - 类 com.trs.ajaxservice.xmlconvertors.DefaultWCMObjectsToXML 的构造方法
DefaultWhereSQLMaker - com.trs.presentation.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DefaultWhereSQLMaker(String, String, String) - 类 com.trs.presentation.util.DefaultWhereSQLMaker 的构造方法
DefautlServiceProvider - com.trs.webframework.provider 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
默认服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DefautlServiceProvider() - 类 com.trs.webframework.provider.DefautlServiceProvider 的构造方法
defDistTree - 类 com.trs.infra.util.jazzlib.InflaterHuffmanTree 中的静态变量
deflate(byte[]) - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Deflates the current input block to the given array.
deflate(byte[], int, int) - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Deflates the current input block to the given array.
DEFLATED - 类 com.trs.infra.util.jazzlib.Deflater 中的静态变量
The compression method.
DEFLATED - 类 com.trs.infra.util.jazzlib.ZipEntry 中的静态变量
Compression method.
DEFLATED - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的静态变量
Compression method.
Deflater - com.trs.infra.util.jazzlib 中的 类
This is the Deflater class.
Deflater() - 类 com.trs.infra.util.jazzlib.Deflater 的构造方法
Creates a new deflater with default compression level.
Deflater(int) - 类 com.trs.infra.util.jazzlib.Deflater 的构造方法
Creates a new deflater with given compression level.
Deflater(int, boolean) - 类 com.trs.infra.util.jazzlib.Deflater 的构造方法
Creates a new deflater with given compression level.
DeflaterOutputStream - com.trs.infra.util.jazzlib 中的 类
This is a special FilterOutputStream deflating the bytes that are written through it.
DeflaterOutputStream(OutputStream) - 类 com.trs.infra.util.jazzlib.DeflaterOutputStream 的构造方法
Creates a new DeflaterOutputStream with a default Deflater and default buffer size.
DeflaterOutputStream(OutputStream, Deflater) - 类 com.trs.infra.util.jazzlib.DeflaterOutputStream 的构造方法
Creates a new DeflaterOutputStream with the given Deflater and default buffer size.
DeflaterOutputStream(OutputStream, Deflater, int) - 类 com.trs.infra.util.jazzlib.DeflaterOutputStream 的构造方法
Creates a new DeflaterOutputStream with the given Deflater and buffer size.
defLitLenTree - 类 com.trs.infra.util.jazzlib.InflaterHuffmanTree 中的静态变量
DEL_DETAIL_PCLASS - 类 com.trs.components.common.trsad.ADPos 中的静态变量
delDistribution(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionList 中的方法
从列表中删除指定的分发点设置
delete(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.DistributeServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法
delete(String, int) - 类 com.trs.ajaxservice.DocumentPublishHelper 中的静态方法
delete(Documents, Channel) - 类 com.trs.ajaxservice.DocumentPublishHelper 中的静态方法
delete(Documents, Channel, boolean) - 类 com.trs.ajaxservice.DocumentPublishHelper 中的静态方法
delete(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.DocumentSynServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.GroupServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.IndividuationServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.ReplaceContentServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.SourceServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.StatusServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceHelperProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.WatermarkServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
delete(Group) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
删除组织
delete(Role, boolean) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
删除角色
delete(User, boolean) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
删除一个用户
delete() - 类 com.trs.cms.content.CMSObj 中的方法
建议使用delete(User)
delete(User) - 类 com.trs.cms.content.CMSObj 中的方法
从数据中删除对象信息
delete(User) - 类 com.trs.cms.content.ExtendedField 中的方法
删除扩展字段对象，重载父类接口：删除该对象之前，必须确保无任何频道使用该字段
delete(User) - 类 com.trs.cms.process.definition.Flow 中的方法
重载父类delete函数，删除与工作流相关的信息（流转中的文档、节点、频道中工作流的设置等）
delete(Flow) - 类 com.trs.cms.process.definition.FlowMgr 中的方法
delete(User) - 类 com.trs.cms.process.definition.FlowNode 中的方法
重载父类delete函数，删除与工作流节点相关的信息（流转中的文档、节点操作者、分支等）
delete(Event) - 类 com.trs.components.common.calendar.EventMgr 中的方法
删除指定的Event
delete(Message) - 接口 com.trs.components.common.message.IMessageService 中的方法
删除短消息
delete(int) - 接口 com.trs.components.common.message.IMessageService 中的方法
根据短消息ID删除短消息
delete(Messages) - 接口 com.trs.components.common.message.IMessageService 中的方法
删除短消息集合
delete(String) - 接口 com.trs.components.common.message.IMessageService 中的方法
根据对象的ID列表删除短消息集合
delete(User) - 类 com.trs.components.common.message.Message 中的方法
删除对象 重载父类接口：同时删除相关数据
delete(User, String) - 类 com.trs.components.common.message.MessageServer 中的静态方法
删除消息集合
删除消息时，如果用户为发件人，则在Message表中做逻辑删除的标志
如果用户为收件人，则从关联关系表中删除该记录
如果用户既是发件人，又是收件人，则两个操作都做
删除时，如果关联表中已没有和Message关联的记录，Message中也时逻辑删除，则从Message中彻底删除该消息。
delete(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr 中的方法
Deletes a publish distribution.
delete(PublishTask) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
delete a publish task
delete(PublishTask) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法
delete(TemplateArgument) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentMgr 中的方法
删除指定的TemplateArgument对象
delete(Template) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
删除指定的模板
delete(User) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
delete(User, ContentStyle) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
delete(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
删除指定的风格
delete(User, ContentStyle) - 接口 com.trs.components.common.publish.widget.IContentStyleMgr 中的方法
删除ContentStyle
delete(User, Layouts) - 接口 com.trs.components.common.publish.widget.ILayoutMgr 中的方法
删除布局
delete(MethodContext) - 接口 com.trs.components.common.publish.widget.ILayoutServiceProvider 中的方法
delete(User, Masters) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
删除指定的母版
delete(User, PageStyle) - 接口 com.trs.components.common.publish.widget.IPageStyleMgr 中的方法
删除指定的页面风格
delete(User, ResourceStyle) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
删除ResourceStyle
delete(User, StyleAndResource) - 接口 com.trs.components.common.publish.widget.IStyleAndResourceMgr 中的方法
删除风格与资源的关联关系
delete(User, StyleItem) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
删除StyleItem
delete(User, BaseStyle) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
删除指定风格对应的风格项（StyleItem）
delete(WidgetInstance) - 接口 com.trs.components.common.publish.widget.IWidgetInstanceMgr 中的方法
删除资源块实例和其下的所有变量
delete(WidgetInstance) - 接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr 中的方法
清除某个资源实例下的所有资源实例的变量信息
delete(User, Widget) - 接口 com.trs.components.common.publish.widget.IWidgetMgr 中的方法
删除资源
delete(User, WidgetParameter) - 接口 com.trs.components.common.publish.widget.IWidgetParameterMgr 中的方法
删除资源变量
delete(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetParameterServiceProvider 中的方法
删除资源变量
delete(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetServiceProvider 中的方法
删除资源片段
delete(User, Layout) - 类 com.trs.components.common.publish.widget.LayoutMgr 中的方法
删除指定的布局
delete(User, Layouts) - 类 com.trs.components.common.publish.widget.LayoutMgr 中的方法
删除布局的集合
delete(MethodContext) - 类 com.trs.components.common.publish.widget.LayoutServiceProvider 中的方法
删除布局
delete(User, Masters) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
删除母板
delete(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
删除指定Id的母板
delete(User, PageStyle) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
删除PageStyle
delete(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
删除指定的风格 context中需要传递参数ObjectIds，来指定待删除的风格id序列，多个id之间用逗号分隔
delete(User, ResourceStyle) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
delete(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
删除指定的风格
delete(User, StyleAndResource) - 类 com.trs.components.common.publish.widget.StyleAndResourceMgr 中的方法
delete(User, StyleItem) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
delete(User, BaseStyle) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
删除风格对应的风格项
delete(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
delete(WidgetInstance) - 类 com.trs.components.common.publish.widget.WidgetInstanceMgr 中的方法
delete(WidgetInstance) - 类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 中的方法
delete(User, Widget) - 类 com.trs.components.common.publish.widget.WidgetMgr 中的方法
delete(User, WidgetParameter) - 类 com.trs.components.common.publish.widget.WidgetParameterMgr 中的方法
delete(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 中的方法
delete(User) - 类 com.trs.components.common.trsad.ADCom 中的方法
删除公司同时删除该公司的所有广告
delete(User) - 类 com.trs.components.common.trsad.ADFile 中的方法
delete(User) - 类 com.trs.components.common.trsad.ADPos 中的方法
重载父类方法删除属于广告位的所有广告记录
delete(InfoView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
delete(InfoViewView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
delete(InfoViewGroup) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
delete(InfoViewField) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
delete(User, MetaViewData) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
删除ClassInfoView中满足MetaDataID的记录
delete(User, ClassInfo) - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
delete(User, MetaViewData) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
删除ClassInfoView中满足MetaDataID的记录
delete(User, ClassInfo) - 接口 com.trs.components.metadata.center.IClassInfoViewMgr 中的方法
删除_oClassInfo下的文档关联
delete(User) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
delete(User, MetaDBField) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
删除指定字段
delete(User, MetaDBTable) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
删除指定表
delete(User, MetaViewField) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
删除指定视图字段
delete(User, MetaView) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
删除指定表
delete(User, MetaDBField) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
delete(User, MetaDBTable) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
删除元数据的操作步骤如下：
删除元数据物理字段；
删除元数据对应物理表里的数据；
删除元数据物理表；
删除元数据；
删除所有以此元数据作为主表的视图；
获取所有以此元数据作为附表的视图；
删除附表视图和此元数据的关系；
删除附表视图中此元数据的字段；
如果此视图由多表变成单表，则删除此物理视图，并修改视图的viewName
重新生成视图；
delete(User, MetaViewField) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
delete(User, MetaView) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
delete(User, Special) - 接口 com.trs.components.special.ISpecialMgr 中的方法
删除指定的专题
delete(MethodContext) - 接口 com.trs.components.special.ISpecialServiceProvider 中的方法
删除指定ID序列的专题
delete(User, Special) - 类 com.trs.components.special.SpecialMgr 中的方法
delete(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法
delete(User, BonusRules) - 类 com.trs.components.stat.BonusRuleMgr 中的方法
删除指定的奖励规则
delete(MethodContext) - 类 com.trs.components.stat.BonusRuleServiceProvider 中的方法
delete(User, BonusRules) - 接口 com.trs.components.stat.IBonusRuleMgr 中的方法
删除指定的奖励规则
delete(MethodContext) - 类 com.trs.components.stat.UserLoginInfoServiceProvider 中的方法
delete(ChannelSyn) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法
delete(BaseChannel, boolean) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
delete(CMSObj, ContentExtField, boolean) - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 中的方法
delete(ContentLink) - 类 com.trs.components.wcm.content.domain.ContentLinkMgr 中的方法
删除内容超链接
delete(ContentLinks) - 类 com.trs.components.wcm.content.domain.ContentLinkMgr 中的方法
删除内容超链接集合
delete(Document, Channel, boolean) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
从某个频道下删除一篇文档
频道为一个真实频道，暂时不支持从回收站、草稿箱或其它特殊频道中删除。
delete(Replace) - 类 com.trs.components.wcm.content.domain.ReplaceMgr 中的方法
删除指定的Replace对象
delete(User) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
delete(User) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
delete(User) - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
重载父类delete函数 删除该版本的备份，同时需要删除该版本在相关附件上的引用关系
delete() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
delete(User) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
delete(int) - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
删除定制的模块
delete(MethodContext) - 类 com.trs.components.wcm.publish.region.CellServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionEmployServiceProvider 中的方法
delete(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionServiceProvider 中的方法
delete(User, CMSObj) - 类 com.trs.components.wcm.resource.ResourceMgr 中的方法
删除指定的配置资源对象
delete(User) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
delete() - 类 com.trs.infra.persistent.BaseObj 中的方法
从数据中删除对象信息
delete() - 类 com.trs.infra.support.config.Config 中的方法
delete(int) - 接口 com.trs.infra.support.log.ILogMgr 中的方法
delete(String) - 接口 com.trs.infra.support.log.ILogMgr 中的方法
delete(WCMFilter) - 接口 com.trs.infra.support.log.ILogMgr 中的方法
delete(int) - 类 com.trs.infra.support.log.LogMgr 中的方法
delete(String) - 类 com.trs.infra.support.log.LogMgr 中的方法
delete(WCMFilter) - 类 com.trs.infra.support.log.LogMgr 中的方法
delete(ILog) - 类 com.trs.infra.support.log.LogServer 中的静态方法
删除一个日志记录
delete(int) - 类 com.trs.infra.support.log.LogServer 中的静态方法
根据日志ID删除一个日志记录
delete(BaseObjs) - 类 com.trs.infra.support.log.LogServer 中的静态方法
删除日志集合
delete(String) - 类 com.trs.infra.support.log.LogServer 中的静态方法
根据日志ID序列，删除日志集合
delete(CMyDateTime) - 类 com.trs.infra.support.log.LogServer 中的静态方法
删除特定日期之前的所有日志
delete(CMyDateTime, CMyDateTime) - 类 com.trs.infra.support.log.LogServer 中的静态方法
删除特定时间段的所有日志
delete(String, boolean) - 接口 com.trs.service.IChannelService 中的方法
根据频道id列表，删除频道集合
delete(Channels, boolean) - 接口 com.trs.service.IChannelService 中的方法
删除频道集合
delete(BaseChannel, boolean) - 接口 com.trs.service.IChannelService 中的方法
删除站点/频道
delete(int) - 接口 com.trs.service.ICustomizeService 中的方法
删除个人定制模块
delete(String, Channel, boolean) - 接口 com.trs.service.IDocumentService 中的方法
根据文档id序列批量删除当前频道下的文档
delete(Documents, Channel, boolean) - 接口 com.trs.service.IDocumentService 中的方法
批量删除当前频道下的文档
delete(int, Channel, boolean) - 接口 com.trs.service.IDocumentService 中的方法
删除当前频道下的一个文档
delete(Document, Channel, boolean) - 接口 com.trs.service.IDocumentService 中的方法
删除当前频道的一个文档
delete(ChnlDocs, boolean) - 接口 com.trs.service.IDocumentService 中的方法
批量删除当前频道下的文档
delete(int) - 接口 com.trs.service.IEventService 中的方法
根据提供的Event ID进行删除操作, 直接进行彻底删除操作
delete(Event) - 接口 com.trs.service.IEventService 中的方法
根据指定的Event对象进行删除操作
delete(String) - 接口 com.trs.service.IEventService 中的方法
根据制定的ID序列，进行删除操作
delete(Events) - 接口 com.trs.service.IEventService 中的方法
根据指定的Events对象进行删除操作
delete(Group) - 接口 com.trs.service.IGroupService 中的方法
删除某个特定的组织
delete(int) - 接口 com.trs.service.IGroupService 中的方法
根据组ID，删除一个组织
delete(Groups) - 接口 com.trs.service.IGroupService 中的方法
删除一批组织（在组织列表页面中用到）
delete(String) - 接口 com.trs.service.IGroupService 中的方法
根据组织Id，删除一批组织（在组织列表页面中用到）
delete(InfoView) - 接口 com.trs.service.IInfoViewService 中的方法
彻底删除指定的自定义表单
delete(InfoViews) - 接口 com.trs.service.IInfoViewService 中的方法
彻底删除指定的自定义表单集合 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。
delete(int) - 接口 com.trs.service.IInfoViewService 中的方法
根据自定义表单的ID彻底删除自定义表单
delete(String) - 接口 com.trs.service.IInfoViewService 中的方法
根据自定义表单的ID列表彻底删除自定义表单， 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经删除的不会会滚。
delete(String, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
根据频道id列表，删除频道集合
delete(Channels, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
删除频道集合
delete(BaseChannel, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
删除站点/频道
delete(int) - 类 com.trs.service.impl.CustomizeService 中的方法
delete(String, Channel, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
delete(Documents, Channel, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
delete(int, Channel, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
delete(Document, Channel, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
delete(ChnlDocs, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
delete(int) - 类 com.trs.service.impl.EventService 中的方法
delete(Event) - 类 com.trs.service.impl.EventService 中的方法
delete(String) - 类 com.trs.service.impl.EventService 中的方法
delete(Events) - 类 com.trs.service.impl.EventService 中的方法
delete(int) - 类 com.trs.service.impl.GroupService 中的方法
delete(String) - 类 com.trs.service.impl.GroupService 中的方法
delete(Groups) - 类 com.trs.service.impl.GroupService 中的方法
delete(Group) - 类 com.trs.service.impl.GroupService 中的方法
delete(InfoView) - 类 com.trs.service.impl.InfoViewService 中的方法
delete(InfoViews) - 类 com.trs.service.impl.InfoViewService 中的方法
delete(int) - 类 com.trs.service.impl.InfoViewService 中的方法
delete(String) - 类 com.trs.service.impl.InfoViewService 中的方法
delete(BaseChannel) - 类 com.trs.service.impl.PublishService 中的方法
已过时。 根本就没有没有使用，声明为废弃的，以标识
delete(Document) - 类 com.trs.service.impl.PublishService 中的方法
已过时。 根本就没有没有使用，声明为废弃的，以标识
delete(Document, Channel) - 类 com.trs.service.impl.PublishService 中的方法
已过时。 根本就没有没有使用，声明为废弃的，以标识
delete(Documents) - 类 com.trs.service.impl.PublishService 中的方法
已过时。 根本就没有没有使用，声明为废弃的，以标识
delete(Documents, Channel) - 类 com.trs.service.impl.PublishService 中的方法
delete(CMSObj) - 类 com.trs.service.impl.ResouceService 中的方法
delete(int) - 类 com.trs.service.impl.RoleService 中的方法
delete(String) - 类 com.trs.service.impl.RoleService 中的方法
delete(Roles) - 类 com.trs.service.impl.RoleService 中的方法
delete(Role) - 类 com.trs.service.impl.RoleService 中的方法
delete(String) - 类 com.trs.service.impl.TemplateService 中的方法
delete(Templates) - 类 com.trs.service.impl.TemplateService 中的方法
delete(int) - 类 com.trs.service.impl.TemplateService 中的方法
delete(Template) - 类 com.trs.service.impl.TemplateService 中的方法
delete(String, boolean) - 类 com.trs.service.impl.UserService 中的方法
delete(Users, boolean) - 类 com.trs.service.impl.UserService 中的方法
delete(int, boolean) - 类 com.trs.service.impl.UserService 中的方法
delete(User, boolean) - 类 com.trs.service.impl.UserService 中的方法
delete(BaseChannel) - 接口 com.trs.service.IPublishService 中的方法
删除指定站点/频道的发布页面
delete(Document) - 接口 com.trs.service.IPublishService 中的方法
删除指定文档已发布的页面
delete(Document, Channel) - 接口 com.trs.service.IPublishService 中的方法
从指定频道上删除指定文档已发布的页面
delete(Documents) - 接口 com.trs.service.IPublishService 中的方法
删除指定文档集合已发布的页面
delete(Documents, Channel) - 接口 com.trs.service.IPublishService 中的方法
从指定频道上删除指定文档集合已发布的页面
delete(CMSObj) - 接口 com.trs.service.IResourceService 中的方法
删除资源配置
delete(Role) - 接口 com.trs.service.IRoleService 中的方法
删除指定的角色
delete(int) - 接口 com.trs.service.IRoleService 中的方法
根据Id删除指定的角色
delete(Roles) - 接口 com.trs.service.IRoleService 中的方法
删除指定的角色集合
delete(String) - 接口 com.trs.service.IRoleService 中的方法
根据Id序列删除多个角色
delete(String) - 接口 com.trs.service.ITemplateService 中的方法
根据模板Id列表彻底删除模板
delete(Templates) - 接口 com.trs.service.ITemplateService 中的方法
彻底删除模板集合
delete(int) - 接口 com.trs.service.ITemplateService 中的方法
根据模板ID彻底删除模板
delete(Template) - 接口 com.trs.service.ITemplateService 中的方法
彻底删除模板
delete(String, boolean) - 接口 com.trs.service.IUserService 中的方法
根据用户id序列,批量删除指定的用户
delete(Users, boolean) - 接口 com.trs.service.IUserService 中的方法
批量删除指定的用户
delete(int, boolean) - 接口 com.trs.service.IUserService 中的方法
删除指定的用户
delete(User, boolean) - 接口 com.trs.service.IUserService 中的方法
删除指定的用户
delete(User) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
重载父类删除接口，同步删除其字段列表
delete(User) - 类 com.trs.wcm.photo.Watermark 中的方法
delete(MethodContext) - 类 com.trs.webframework.demo.StdDemoProviderImpl 中的方法
delete(MethodContext) - 类 com.trs.webframework.provider.BaseServiceDecorator 中的方法
delete(MethodContext) - 接口 com.trs.webframework.provider.IDeleteServiceProvider 中的方法
DELETE - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量
DELETE_FILE - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue 中的静态变量
删除文件
DELETE_PATH - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue 中的静态变量
删除目录
deleteAll() - 类 com.trs.scene.tools.SceneAutoCreator 中的方法
deleteAll(boolean) - 类 com.trs.wcm.photo.Watermarks 中的方法
deleteAppendix(TempAppendix) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
删除一个模板附件，仅仅删除附件关联
deleteAppendix(int) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
删除一个模板附件，仅仅删除附件关联
deleteBookMark(BookMark) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
删除一个书签
deleteBookMark(int) - 接口 com.trs.service.IBookMarkService 中的方法
删除指定的书签
deleteBookMark(String) - 接口 com.trs.service.IBookMarkService 中的方法
删除指定的书签集合
deleteBookMark(int) - 类 com.trs.service.impl.BookMarkService 中的方法
deleteBookMark(String) - 类 com.trs.service.impl.BookMarkService 中的方法
deleteChannels(int[]) - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
删除定制的频道
deleteChannels(int[]) - 接口 com.trs.service.ICustomizeService 中的方法
删除个人定制的频道
deleteChannels(int[]) - 类 com.trs.service.impl.CustomizeService 中的方法
deleteChannelSyn(int) - 接口 com.trs.service.IChannelService 中的方法
deleteChannelSyn(int) - 类 com.trs.service.impl.ChannelService 中的方法
deleteChannelSyns(String) - 接口 com.trs.service.IChannelService 中的方法
deleteChannelSyns(String) - 类 com.trs.service.impl.ChannelService 中的方法
deleteClassInfo(User, ClassInfo) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
deleteClassInfo(User, ClassInfo) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
删除指定的分类
deleteClassInfo(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
删除指定的分类
deleteClassInfo(User, int) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
deleteClassInfo(User, String) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
deleteClassInfo(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
删除指定的分类
deleteClassInfo(User, int) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
deleteClassInfo(User, String) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
deleteContact(Contact) - 类 com.trs.components.common.address.ContactMgr 中的方法
删除指定的联系人
deleteContact(int) - 接口 com.trs.service.IContactService 中的方法
删除指定的联系人
deleteContact(Contact) - 接口 com.trs.service.IContactService 中的方法
删除指定的联系人
deleteContact(int) - 类 com.trs.service.impl.ContactService 中的方法
deleteContact(Contact) - 类 com.trs.service.impl.ContactService 中的方法
deleteContactGroup(ContactGrp) - 类 com.trs.components.common.address.ContactMgr 中的方法
删除指定的联系人分组
deleteContactGroup(int) - 接口 com.trs.service.IContactService 中的方法
删除指定的联系人分组
deleteContactGroup(ContactGrp) - 接口 com.trs.service.IContactService 中的方法
删除指定的联系人分组
deleteContactGroup(int) - 类 com.trs.service.impl.ContactService 中的方法
deleteContactGroup(ContactGrp) - 类 com.trs.service.impl.ContactService 中的方法
deleteContactGroups(String) - 接口 com.trs.service.IContactService 中的方法
删除指定的联系人分组
deleteContactGroups(ContactGrps) - 接口 com.trs.service.IContactService 中的方法
删除指定的联系人分组
deleteContactGroups(String) - 类 com.trs.service.impl.ContactService 中的方法
deleteContactGroups(ContactGrps) - 类 com.trs.service.impl.ContactService 中的方法
deleteContacts(String) - 接口 com.trs.service.IContactService 中的方法
删除指定的联系人
deleteContacts(Contacts) - 接口 com.trs.service.IContactService 中的方法
删除指定的联系人集合
deleteContacts(String) - 类 com.trs.service.impl.ContactService 中的方法
deleteContacts(Contacts) - 类 com.trs.service.impl.ContactService 中的方法
deleteContent(IPublishContent) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
delete a published content from the specified folder
deleteContentLink(ContentLink) - 接口 com.trs.service.IChannelService 中的方法
deleteContentLink(ContentLink) - 类 com.trs.service.impl.ChannelService 中的方法
deleteContentLinks(WebSite) - 类 com.trs.components.wcm.content.domain.ContentLinkMgr 中的方法
deleteContentLinks(ContentLinks) - 接口 com.trs.service.IChannelService 中的方法
deleteContentLinks(ContentLinks) - 类 com.trs.service.impl.ChannelService 中的方法
deleteContents(IPublishElements, IPublishFolder) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
delete the published contents from the specified folder
deleteContents(IPublishElements, IPublishFolder, IPublishElements) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
deleteContents(IPublishElements, IPublishFolder, IPublishElements, boolean) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
deleteContentsWithMirror(IPublishElements, IPublishFolder, IPublishElements) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
deleteCss(Layout) - 接口 com.trs.components.common.publish.widget.ILayoutGenerator 中的方法
删除当前布局对应的CSS样式内容
deleteCss(Layout) - 类 com.trs.components.common.publish.widget.LayoutGenerator 中的方法
删除当前布局对应的css样式
deleteDBField(User, InfoView, InfoViewField) - 接口 com.trs.components.infoview.db.IInfoViewDBMgr 中的方法
删除指定字段
deleteDBField(User, InfoView, InfoViewField) - 类 com.trs.components.infoview.db.InfoViewDBMgr 中的方法
deleteDBFieldInfo(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
删除元数据字段信息
deleteDBTable(User, int) - 接口 com.trs.components.infoview.db.IInfoViewDBMgr 中的方法
删除指定表
deleteDBTable(User, int) - 类 com.trs.components.infoview.db.InfoViewDBMgr 中的方法
deleteDBTableInfo(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
删除元数据结构信息
deleteDir(String, boolean) - 类 com.trs.infra.util.CMyFile 中的静态方法
已过时。 to use deleteDir(String _sPath) or deleteDir(File _path) instead.
deleteDir(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
Deletes a file path, and all the files and subdirectories in this path will also be deleted.
deleteDir(File) - 类 com.trs.infra.util.CMyFile 中的静态方法
Deletes a file path, and all the files and subdirectories in this path will also be deleted.
deleteDirectory(String) - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
删除远程服务器上的目录
deleteDirectory(String) - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的方法
deleteDirectory(String) - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的方法
deleteDistribution(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager 中的方法
删除和指定的PublishDistribution相关的FTP连接缓存管理器
deleteDocBak(DocBak) - 类 com.trs.components.wcm.content.domain.DocBakMgr 中的方法
删除一个文档备份(版本)
deleteDocBak(int) - 接口 com.trs.service.IDocumentService 中的方法
删除指定的文档版本
deleteDocBak(DocBak) - 接口 com.trs.service.IDocumentService 中的方法
删除指定的文档版本
deleteDocBak(int) - 类 com.trs.service.impl.DocumentService 中的方法
deleteDocBak(DocBak) - 类 com.trs.service.impl.DocumentService 中的方法
deleteDocBaks(String) - 接口 com.trs.service.IDocumentService 中的方法
删除指定的文档版本
deleteDocBaks(DocBaks) - 接口 com.trs.service.IDocumentService 中的方法
删除指定的文档版本集合
deleteDocBaks(String) - 类 com.trs.service.impl.DocumentService 中的方法
deleteDocBaks(DocBaks) - 类 com.trs.service.impl.DocumentService 中的方法
deleteDocQuotes(Document, String) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
根据频道排除Id，删除所有特定类型的文档转发关系
deleteDocumentQuoteImage(int, int) - 接口 com.trs.wcm.photo.IImageLibMgr 中的方法
删除文档和指定图片引用关系
deleteDocumentQuoteImage(int, String) - 接口 com.trs.wcm.photo.IImageLibMgr 中的方法
删除指定文档的图片引用关系，不包括指定的图片ID
deleteDocumentQuoteImage(int) - 接口 com.trs.wcm.photo.IImageLibMgr 中的方法
删除指定文档的所有引用关系
deleteDocumentQuoteImage(int, int) - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 中的方法
deleteDocumentQuoteImage(int, String) - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 中的方法
deleteDocumentQuoteImage(int) - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 中的方法
deleteDocumentSyn(DocumentSyn) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法
deleteExtFields(BaseChannel, String, boolean) - 接口 com.trs.service.IChannelService 中的方法
删除指定站点/频道下的指定扩展字段
deleteExtFields(BaseChannel, String, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
删除指定站点/频道下的指定扩展字段
deleteExtFiled(BaseChannel, ContentExtField, boolean) - 接口 com.trs.service.IChannelService 中的方法
删除指定站点/频道下的指定扩展字段
deleteExtFiled(BaseChannel, ContentExtField, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
删除指定站点/频道下的指定扩展字段
deleteFile(String) - 类 com.trs.infra.support.file.FilesMan 中的方法
删除指定的文件
deleteFile(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
删除指定的文件
deleteFile(String) - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
删除远程服务器上的文件
deleteFile(String) - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的方法
deleteFile(String) - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的方法
deleteFlows(String) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
deleteFlows(String) - 接口 com.trs.service.IWCMProcessService 中的方法
deleteFolder(IPublishFolder) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
delete the content folder
deleteFolder(IPublishFolder, boolean) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
deleteFolderSelfOnly(IPublishFolder) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
deleteImage(String) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
从图片库中删除指定的图片
deleteImage(String, int) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
从指定的分类中删除图片
deleteImage(String) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
deleteImage(String, int) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
deleteInfoViewData(int, Document) - 类 com.trs.components.infoview.db.InfoViewDBStoreServer 中的方法
deleteJob(String) - 类 com.trs.infra.util.job.JobScheduler 中的方法
deleteKey(int) - 类 com.trs.service.impl.SecurityService 中的方法
deleteKey(String) - 类 com.trs.service.impl.SecurityService 中的方法
deleteKey(int) - 接口 com.trs.service.ISecurityService 中的方法
删除指定ID的密钥
deleteKey(String) - 接口 com.trs.service.ISecurityService 中的方法
删除指定ID的密钥 不支持事务，如果在删除过程中发生错误，将立即抛出异常，终止操作，但是已经被删除的密钥不会回滚。
deleteKeyByName(String) - 类 com.trs.service.impl.SecurityService 中的方法
deleteKeyByName(String) - 接口 com.trs.service.ISecurityService 中的方法
删除指定名称（名称：一般是密钥的用途）的密钥
deleteLog() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
deleteLog() - 接口 com.trs.infra.support.log.ILog 中的方法
deleteLogBaks(WCMFilter) - 接口 com.trs.infra.support.log.ILogMgr 中的方法
deleteLogBaks(WCMFilter) - 类 com.trs.infra.support.log.LogMgr 中的方法
deleteLogBaks(CMyDateTime) - 类 com.trs.infra.support.log.LogServer 中的静态方法
删除特定日期前的所有归档日志
deleteLogBaks(CMyDateTime, CMyDateTime) - 类 com.trs.infra.support.log.LogServer 中的静态方法
删除特定时间段的所有归档日志
deleteMarkKind(MarkKind) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
删除一个书签分类
deleteMarkKind(int) - 接口 com.trs.service.IBookMarkService 中的方法
删除指定的书签文件夹
deleteMarkKind(String) - 接口 com.trs.service.IBookMarkService 中的方法
删除指定的书签文件夹集合
deleteMarkKind(int) - 类 com.trs.service.impl.BookMarkService 中的方法
deleteMarkKind(String) - 类 com.trs.service.impl.BookMarkService 中的方法
deleteOperatorRight(MethodContext) - 类 com.trs.ajaxservice.AuthServiceProvider 中的方法
deleteOthersBeforeDelete() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
deletePageStyleInfos(User, PageStyle) - 接口 com.trs.components.common.publish.widget.IPageStyleMgr 中的方法
删除指定的页面风格的关联信息
deletePageStyleInfos(User, PageStyle) - 类 com.trs.components.common.publish.widget.PageStyleMgr 中的方法
删除页面风格的关联信息
deletePublishDistributions(WebSite, String) - 类 com.trs.service.impl.WCMPublishElementServiceImpl 中的方法
deletePublishDistributions(WebSite, String) - 接口 com.trs.service.IWCMPublishElementService 中的方法
将当前站点的指定分发信息设置删除
deletePublishSchedule(BaseChannel) - 类 com.trs.service.impl.ScheduleService 中的方法
deletePublishSchedule(Document) - 类 com.trs.service.impl.ScheduleService 中的方法
deletePublishSchedule(BaseChannel) - 接口 com.trs.service.IScheduleService 中的方法
删除指定站点或频道的计划发布
deletePublishSchedule(Document) - 接口 com.trs.service.IScheduleService 中的方法
删除指定文档的计划发布
deleteRelation(Template) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
删除模板和附件的关联
deleteRelation(int) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
删除模板和附件的关联
deleteRelations(Document) - 类 com.trs.components.wcm.content.domain.RelationMgr 中的方法
deleteReplace(Replace) - 接口 com.trs.service.IChannelService 中的方法
删除替换内容对象
deleteReplace(Replaces) - 接口 com.trs.service.IChannelService 中的方法
删除替换内容对象集合
deleteReplace(Replace) - 类 com.trs.service.impl.ChannelService 中的方法
deleteReplace(Replaces) - 类 com.trs.service.impl.ChannelService 中的方法
deleteRight(Right) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法
删除指定的权限
deleteRight(Right) - 类 com.trs.cms.auth.domain.RightMgr 中的方法
deleteSchedule(JobWorkerType, CMSObj) - 类 com.trs.components.common.job.JobScheduleServer 中的静态方法
deleteSimIndex(Document) - 接口 com.trs.components.ckm.ICKMServer 中的方法
deleteSimIndex(Document) - 类 com.trs.components.ckm.TRSCKMServer 中的方法
deleteSites(int[]) - 接口 com.trs.service.ICustomizeService 中的方法
删除个人定制的站点集合
deleteSites(int[]) - 类 com.trs.service.impl.CustomizeService 中的方法
deleteStatHost(StatHost) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
删除统计主体
deleteStatHosts(String) - 类 com.trs.service.impl.StatService 中的方法
deleteStatHosts(String) - 接口 com.trs.service.IStatService 中的方法
删除统计类型
deleteStatView(StatView) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
删除一个统计视图
deleteStatView(int) - 类 com.trs.service.impl.StatService 中的方法
deleteStatView(StatView) - 类 com.trs.service.impl.StatService 中的方法
deleteStatView(int) - 接口 com.trs.service.IStatService 中的方法
删除一个统计视图
deleteStatView(StatView) - 接口 com.trs.service.IStatService 中的方法
删除一个统计视图
deleteStatViews(String) - 类 com.trs.service.impl.StatService 中的方法
deleteStatViews(String) - 接口 com.trs.service.IStatService 中的方法
删除一个统计视图
deleteTask(PublishTask) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
删除单个任务
deleteTasks(String) - 类 com.trs.service.impl.PublishService 中的方法
deleteTasks(String) - 接口 com.trs.service.IPublishService 中的方法
deleteTemplateArgument(TemplateArgument) - 类 com.trs.service.impl.TemplateService 中的方法
deleteTemplateArgument(TemplateArgument) - 接口 com.trs.service.ITemplateService 中的方法
删除指定的TemplateArgument对象
deleteTemplateArguments(TemplateArguments) - 类 com.trs.service.impl.TemplateService 中的方法
deleteTemplateArguments(TemplateArguments) - 接口 com.trs.service.ITemplateService 中的方法
删除指定的TemplateArguments对象集合
deleteTopicDocRelation(int, int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法
deleteTopicDocRelation(int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法
deleteUnuseAppendixes(Document, String, int) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
删除指定文档指定类型没有使用的附件
deleteUnuseCSRItems(Widget, String) - 接口 com.trs.components.common.publish.widget.IStyleAndResourceMgr 中的方法
删除资源与内容风格关联中没有使用的对象
deleteUnuseCSRItems(Widget, String) - 类 com.trs.components.common.publish.widget.StyleAndResourceMgr 中的方法
删除资源与内容风格关联中没有使用的对象
deleteUnusePageOtherStyleItems(PageStyle, String) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
删除页面style对应的没有使用的其他风格项
deleteUnusePageOtherStyleItems(PageStyle, String) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
删除页面style对应的没有使用的其他风格项
deleteUnuseRelations(String, Document) - 类 com.trs.components.wcm.content.domain.RelationMgr 中的方法
deleteUnuseStyleItems(BaseStyle, String) - 接口 com.trs.components.common.publish.widget.IStyleItemMgr 中的方法
删除指定风格没有使用的风格项
deleteUnuseStyleItems(BaseStyle, String) - 类 com.trs.components.common.publish.widget.StyleItemMgr 中的方法
删除指定风格没有使用的风格项
deleteUploadImages(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
删除页面风格下指定名称的上传图片
deleteView(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
删除多个视图信息
deleteViewDataAndDoc(User) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
deleteViewDatas(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
删除视图数据信息
deleteViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
已过时。 改成Document的监听机制，转向调用ViewDocument.delete方法
deleteViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
删除视图数据信息
deleteViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
删除视图数据信息
deleteViewField(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
删除视图字段信息信息
deleteWidgetInstance(MethodContext) - 接口 com.trs.components.common.publish.widget.IVisualTemplateServiceProvider 中的方法
删除指定的资源块实例对象
deleteWidgetInstance(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法
delGroup(SSOGroup, HttpServletRequest) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
删除组织
DELIM - 类 com.trs.infra.support.config.PathConfig 中的静态变量
属性分割符
delStyleThumb(String) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
删除上传的缩略图
delStyleThumb(String) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
删除上传的缩略图
DepartmentMgrImpl - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DepartmentMgrImpl() - 类 com.trs.cms.auth.domain.DepartmentMgrImpl 的构造方法
DeptMgrAsToUsersCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DeptMgrAsToUsersCreator() - 类 com.trs.cms.process.engine.creators.DeptMgrAsToUsersCreator 的构造方法
destory() - 类 com.trs.components.metadata.center.MetaDataCenterClassInfoHelper 中的静态方法
清除掉缓冲的资源
destroy() - 类 com.trs.devhelper.JsCombineFilter 中的方法
destroy() - 类 com.trs.DreamFactory 中的静态方法
destroy() - 类 com.trs.infra.StartupServlet 中的方法
destroy() - 类 com.trs.servlet.CharSetFilter 中的方法
destroy() - 类 com.trs.servlet.JspDenyFilter 中的方法
destroy() - 类 com.trs.servlet.LoginCheckFilter 中的方法
destroy() - 类 com.trs.SpringBean 中的方法
销毁资源
destroy() - 类 com.trs.weblet.util.verfiycode.VerifyCodeServlet 中的方法
detachObserver(IObserver) - 接口 com.trs.webframework.xmlserver.server.IObserverable 中的方法
detachObserver(IObserver) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法
DETAIL_TEMPLATE - 类 com.trs.components.common.publish.persistent.template.Template 中的静态变量
已过时。 please use PublishConstants.TEMPLATE_TYPE_DETAIL
DETAIL_TEMPLATE - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态变量
detect(String) - 类 com.trs.infra.util.CharsetDetector 中的静态方法
DFN - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
DiffSqlMaker - com.trs.infra.util.upgrade.sql 中的 类
DiffSqlMaker(String, String) - 类 com.trs.infra.util.upgrade.sql.DiffSqlMaker 的构造方法
digest(String, byte[]) - 类 com.trs.service.impl.SecurityService 中的方法
digest(String, byte[]) - 接口 com.trs.service.ISecurityService 中的方法
使用指定的算法计算指定数据的摘要
digestHexStr - 类 com.trs.infra.util.CMyEncrypt 中的变量
digestHexStr - 类 com.trs.infra.util.MD5 中的变量
DIR - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
DIR - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
DIR_APPROOT - 类 com.trs.infra.config.ConfigConstants 中的静态变量
DIR_CLASSROOT - 类 com.trs.infra.config.ConfigConstants 中的静态变量
disable(User) - 类 com.trs.service.impl.UserService 中的方法
disable(int) - 类 com.trs.service.impl.UserService 中的方法
disable(User) - 接口 com.trs.service.IUserService 中的方法
设置一个用户为禁用状态
disable(int) - 接口 com.trs.service.IUserService 中的方法
根据Id来禁用用户
disableFlowToChannel(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
取消给指定栏目启用的工作流
disableSocketTimeOut() - 类 com.trs.infra.util.email.TRSMailer 中的方法
禁用服务器超时设置：设置超时为-1
disableUser(SSOUser) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
禁用用户
Disconnect() - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
断开和FTP服务器的连接
DiscoveryFactoryBuddy - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DiscoveryFactoryBuddy() - 类 com.trs.infra.util.DiscoveryFactoryBuddy 的构造方法
display() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfoMap 中的静态方法
distributeFile(String, IPublishElement) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
Distributes a file to the specified folder.
distributeFile(String, IPublishElement, String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
Distributes a file to the specified folder.
distributeFile(String, IPublishElement, String, boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
distributeFile(String, String, boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 中的方法
已过时。
distributeFile(String, String, boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 中的方法
distributeFile(String, String, boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 中的方法
distributeFile(String, String, boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法
distributeFile(String, String, boolean) - 类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 中的方法
已过时。
distributeFile(String, String, boolean) - 接口 com.trs.components.common.publish.domain.distribute.IFileDistristributor 中的方法
Distributes a file.
distributeFile(String, IPublishElement) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
Distributes a specified file to the folder.
DistributeServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
扩展字段服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DistributeServiceProvider() - 类 com.trs.ajaxservice.DistributeServiceProvider 的构造方法
distributeSureformFile(int) - 类 com.trs.service.impl.SureformService 中的方法
distributeSureformFile(int) - 接口 com.trs.service.ISureformService 中的方法
将频道配置的书生表单发布到Web服务器上
DistributionChangeListener - com.trs.components.common.publish.domain.distribute 中的 接口
在修改分发设置时（尤其是禁用），为了使已经在执行的分发任务获得即时的响应，而增加的接口
distributionHTMLContentFiles(IPublishContent, PublishTagContext, List) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
DistributionTargetTypeToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DistributionTargetTypeToXML() - 类 com.trs.ajaxservice.xmlconvertors.DistributionTargetTypeToXML 的构造方法
div(double, double) - 类 com.trs.infra.util.CMyDecimalBuddy 中的静态方法
除法运算，以默认的精度（小数点后六位）进行四舍五入
div(double, double, int) - 类 com.trs.infra.util.CMyDecimalBuddy 中的静态方法
除法运算，以指定的精度进行四舍五入
DIV - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
DL - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
DO_DEPT_FILTER - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道属性索引：栏目文档列表是否做所属部门的过滤
doAccept(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
doAccept(FlowContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法
doAccept(FlowContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
签收
doAction() - 类 com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex 中的方法
doAction() - 类 com.trs.infra.util.upgrade.dataprocess.OrderGroupAndRole 中的方法
doAction() - 类 com.trs.infra.util.upgrade.dataprocess.PhotoLibConfig 中的方法
处理相应数据
doAction() - 类 com.trs.infra.util.upgrade.dataprocess.ScheduleOper 中的方法
处理相应数据
doAction() - 类 com.trs.infra.util.upgrade.dataprocess.WcmIdFieldInit 中的方法
doAction(Connection) - 类 com.trs.infra.util.upgrade.WcmIdFieldInit 中的方法
DOC_ADD - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
添加文档
DOC_AGAIN - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
否定、要求返工文档
DOC_BROWSE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
查看细览
Doc_ChannelName - 类 com.trs.components.wcm.content.domain.XmlToDocumentConverter 中的变量
DOC_COPY - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
复制文档
DOC_COPY_ALL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
DOC_DEL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除文档
DOC_DELALL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除全部文档
DOC_EDIT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
修改文档
DOC_FORM_AUDIO - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOC_FORM_LITERY - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOC_FORM_PIC - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOC_FORM_UNKNOWN - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOC_FORM_VIDEO - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOC_MAX_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
文档权限index最大值
DOC_MIN_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
文档权限Index最小值
DOC_MIRROR - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
镜像转发文档
DOC_MOVE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
移动文档
DOC_NEWEDIT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
DOC_OUTLINE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
浏览文档
DOC_POSITIONSET - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
调整顺序
DOC_PREVIEW - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
预览文档
DOC_PUBLISH - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
发布文档
DOC_QUOTE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
引用转发文档
DOC_RESTORE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
恢复文档
DOC_RIGTH_SET - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
设置文档权限
DOC_SAVE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
改变文档的状态为新稿、已编
DOC_SIGN - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
签发文档
DOC_TYPE_FILE - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOC_TYPE_HTML - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOC_TYPE_LINK - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOC_TYPE_NORMAL - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DocBak - com.trs.components.wcm.content.persistent 中的 类
DocBak() - 类 com.trs.components.wcm.content.persistent.DocBak 的构造方法
DocBakLCListenerForApd - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocBakLCListenerForApd() - 类 com.trs.components.wcm.content.domain.DocBakLCListenerForApd 的构造方法
DocBakMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档备份相关的行为
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocBakMgr() - 类 com.trs.components.wcm.content.domain.DocBakMgr 的构造方法
DocBaks - com.trs.components.wcm.content.persistent 中的 类
DocBaks(User) - 类 com.trs.components.wcm.content.persistent.DocBaks 的构造方法
DocBaks(User, int, int) - 类 com.trs.components.wcm.content.persistent.DocBaks 的构造方法
DocCopyLogger - com.trs.ajaxservice.logger 中的 类
DocCopyLogger() - 类 com.trs.ajaxservice.logger.DocCopyLogger 的构造方法
DocImportLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DocImportLogger() - 类 com.trs.ajaxservice.logger.DocImportLogger 的构造方法
DocKeywordMgrImpl - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocKeywordMgrImpl() - 类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 的构造方法
DocKind - com.trs.components.wcm.resource 中的 类
DocKind() - 类 com.trs.components.wcm.resource.DocKind 的构造方法
DocKinds - com.trs.components.wcm.resource 中的 类
DocKinds(User) - 类 com.trs.components.wcm.resource.DocKinds 的构造方法
DocKinds(User, int, int) - 类 com.trs.components.wcm.resource.DocKinds 的构造方法
DocMoveLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档移动日志
Copyright: Copyright (c) 2004-2008 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DocMoveLogger() - 类 com.trs.ajaxservice.logger.DocMoveLogger 的构造方法
DocOperDefine - com.trs.components.wcm.wcmx.jsp 中的 类
DocOperDefine() - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 的构造方法
DocPriDisableWorker - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
根据文档置顶的截止时间撤销文档置顶的计划任务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocPriDisableWorker() - 类 com.trs.components.wcm.content.domain.DocPriDisableWorker 的构造方法
保留默认构造函数
DocPublishTaskLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档发布日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocPublishTaskLogger() - 类 com.trs.ajaxservice.logger.DocPublishTaskLogger 的构造方法
DocReply - com.trs.components.wcm.content.persistent 中的 类
DocReply() - 类 com.trs.components.wcm.content.persistent.DocReply 的构造方法
DocReplyMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description: 文档回复相关行为的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocReplyMgr() - 类 com.trs.components.wcm.content.domain.DocReplyMgr 的构造方法
DocReplys - com.trs.components.wcm.content.persistent 中的 类
DocReplys(User) - 类 com.trs.components.wcm.content.persistent.DocReplys 的构造方法
DocReplys(User, int, int) - 类 com.trs.components.wcm.content.persistent.DocReplys 的构造方法
DocRightSetRightIndex - com.trs.infra.util.upgrade.dataprocess 中的 类
设置文档权限的权限值变化 原有值为54,更改为61.原值用作问券调查的管理权限.
DocRightSetRightIndex(String) - 类 com.trs.infra.util.upgrade.dataprocess.DocRightSetRightIndex 的构造方法
DocSaveLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档保存日志
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocSaveLogger() - 类 com.trs.ajaxservice.logger.DocSaveLogger 的构造方法
DocsFromTRSServer - com.trs.components.wcm.content.trsserver 中的 类
Created by IntelliJ IDEA.
DocsFromTRSServer() - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 的构造方法
构造函数
DocStatHandler4Channel - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4Channel() - 类 com.trs.components.stat.DocStatHandler4Channel 的构造方法
DocStatHandler4ChannelOfGroup - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4ChannelOfGroup(int) - 类 com.trs.components.stat.DocStatHandler4ChannelOfGroup 的构造方法
DocstatHandler4ChannelOfUser - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocstatHandler4ChannelOfUser(String) - 类 com.trs.components.stat.DocstatHandler4ChannelOfUser 的构造方法
DocStatHandler4ChnlDept - com.trs.components.stat 中的 类
DocStatHandler4ChnlDept() - 类 com.trs.components.stat.DocStatHandler4ChnlDept 的构造方法
DocStatHandler4ChnlDeptChannel - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4ChnlDeptChannel(int) - 类 com.trs.components.stat.DocStatHandler4ChnlDeptChannel 的构造方法
DocStatHandler4ChnlDeptSite - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4ChnlDeptSite(int) - 类 com.trs.components.stat.DocStatHandler4ChnlDeptSite 的构造方法
DocStatHandler4SiteOfGroup - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4SiteOfGroup(int) - 类 com.trs.components.stat.DocStatHandler4SiteOfGroup 的构造方法
DocstatHandler4SiteOfUser - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocstatHandler4SiteOfUser(String) - 类 com.trs.components.stat.DocstatHandler4SiteOfUser 的构造方法
DocStatHandler4UserChannel - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4UserChannel(int) - 类 com.trs.components.stat.DocStatHandler4UserChannel 的构造方法
DocStatHandler4UserDept - com.trs.components.stat 中的 类
DocStatHandler4UserDept() - 类 com.trs.components.stat.DocStatHandler4UserDept 的构造方法
DocStatHandler4UserDeptChannel - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4UserDeptChannel(int) - 类 com.trs.components.stat.DocStatHandler4UserDeptChannel 的构造方法
DocStatHandler4UserDeptSite - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4UserDeptSite(int) - 类 com.trs.components.stat.DocStatHandler4UserDeptSite 的构造方法
DocStatHandler4UserSite - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
DocStatHandler4UserSite(int) - 类 com.trs.components.stat.DocStatHandler4UserSite 的构造方法
DocStatusChangeLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档状态改变日志记录
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocStatusChangeLogger() - 类 com.trs.ajaxservice.logger.DocStatusChangeLogger 的构造方法
DocTypeValidator - com.trs.wcag2.validator 中的 类
DocTypeValidator() - 类 com.trs.wcag2.validator.DocTypeValidator 的构造方法
Document - com.trs.components.wcm.content.persistent 中的 类
Document() - 类 com.trs.components.wcm.content.persistent.Document 的构造方法
构造函数：保留默认接口
DocumentAuthHelper - com.trs.ajaxservice 中的 类
DocumentAuthHelper() - 类 com.trs.ajaxservice.DocumentAuthHelper 的构造方法
DocumentAuthServer - com.trs.components.wcm.content.domain.auth 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档权限判断对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentAuthServer() - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 的构造方法
DocumentBakServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档版本相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentBakServiceProvider() - 类 com.trs.ajaxservice.DocumentBakServiceProvider 的构造方法
DocumentExporter - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档导出,将文档(集合)导出为Zip/Xml文件
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentExporter() - 类 com.trs.components.wcm.content.domain.DocumentExporter 的构造方法
DocumentFieldConfig - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentFieldConfig() - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 的构造方法
DocumentFieldHTMLParser - com.trs.components.web.document 中的 类
DocumentFieldsSynFactory - com.trs.components.metadata.center 中的 类
DocumentFieldsSynFactory() - 类 com.trs.components.metadata.center.DocumentFieldsSynFactory 的构造方法
DocumentHitsCount - com.trs.components.stat 中的 类
DocumentHitsCount() - 类 com.trs.components.stat.DocumentHitsCount 的构造方法
构造函数：保留默认接口
DocumentHitsCountHandler - com.trs.components.stat 中的 类
处理文档对象的点击量更新
DocumentHitsCountHandler() - 类 com.trs.components.stat.DocumentHitsCountHandler 的构造方法
DocumentHitsCounts - com.trs.components.stat 中的 类
DocumentHitsCounts(User) - 类 com.trs.components.stat.DocumentHitsCounts 的构造方法
构造函数
DocumentHitsCounts(User, int, int) - 类 com.trs.components.stat.DocumentHitsCounts 的构造方法
构造函数
DocumentImporter - com.trs.components.wcm.content.domain 中的 类
DocumentImporter() - 类 com.trs.components.wcm.content.domain.DocumentImporter 的构造方法
DocumentImportXmlHelper - com.trs.presentation.documetimport.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentImportXmlHelper() - 类 com.trs.presentation.documetimport.xml.DocumentImportXmlHelper 的构造方法
DocumentLCLisenterForPhoto - com.trs.wcm.photo 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片删除监听器
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
DocumentLCLisenterForPhoto() - 类 com.trs.wcm.photo.DocumentLCLisenterForPhoto 的构造方法
DocumentLCListener4EPress - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
修改重发相应的历史索引
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocumentLCListener4EPress() - 类 com.trs.components.wcm.epress.DocumentLCListener4EPress 的构造方法
DocumentLCListenerForAutoDocBak - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForAutoDocBak() - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForAutoDocBak 的构造方法
DocumentLCListenerForDocBak - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForDocBak() - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForDocBak 的构造方法
DocumentLCListenerForDocReply - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForDocReply() - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForDocReply 的构造方法
DocumentLCListenerForExternalFile - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
外部文档的文件处理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForExternalFile() - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForExternalFile 的构造方法
DocumentLCListenerForInfoViewDB - com.trs.components.infoview.db 中的 类
DocumentLCListenerForInfoViewDB() - 类 com.trs.components.infoview.db.DocumentLCListenerForInfoViewDB 的构造方法
缺省构造方法
DocumentLCListenerForKeyword - com.trs.components.wcm.content.domain 中的 类
DocumentLCListenerForKeyword() - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForKeyword 的构造方法
DocumentLCListenerForPublish - com.trs.components.wcm.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
为发布的相关同步监听文档的修改
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForPublish() - 类 com.trs.components.wcm.publish.DocumentLCListenerForPublish 的构造方法
DocumentLCListenerForRelation - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForRelation() - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelation 的构造方法
DocumentLCListenerForRelDocs - com.trs.components.wcm.content.domain 中的 类
DocumentLCListenerForRelDocs() - 类 com.trs.components.wcm.content.domain.DocumentLCListenerForRelDocs 的构造方法
DocumentLCListenerForSIMSearch - com.trs.components.ckm 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentLCListenerForSIMSearch() - 类 com.trs.components.ckm.DocumentLCListenerForSIMSearch 的构造方法
DocumentListenerForMetaViewData - com.trs.components.metadata.center 中的 类
DocumentListenerForMetaViewData() - 类 com.trs.components.metadata.center.DocumentListenerForMetaViewData 的构造方法
DocumentListenerForPublish - com.trs.components.wcm.publish.region 中的 类
DocumentListenerForPublish() - 类 com.trs.components.wcm.publish.region.DocumentListenerForPublish 的构造方法
DocumentLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档对象日志记录者
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
DocumentLogger() - 类 com.trs.components.wcm.logger.DocumentLogger 的构造方法
DocumentMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档的管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentMgr() - 类 com.trs.components.wcm.content.domain.DocumentMgr 的构造方法
DocumentMoveListenerForDocSiteRecode - com.trs.components.wcm.content.domain 中的 类
DocumentMoveListenerForDocSiteRecode() - 类 com.trs.components.wcm.content.domain.DocumentMoveListenerForDocSiteRecode 的构造方法
DocumentPriMgr - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
管理和文档置顶相关的所有行为，包括监控生命周期的变化
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentPriMgr() - 类 com.trs.components.wcm.content.domain.DocumentPriMgr 的构造方法
DocumentPropertiesBuilder - com.trs.components.web.document 中的 类
DocumentPropertiesBuilder(Document) - 类 com.trs.components.web.document.DocumentPropertiesBuilder 的构造方法
DocumentPublishHelper - com.trs.ajaxservice 中的 类
DocumentPublishHelper() - 类 com.trs.ajaxservice.DocumentPublishHelper 的构造方法
DocumentRightHostImpl - com.trs.components.wcm.content.domain.auth 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentRightHostImpl() - 类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 的构造方法
DocumentRightHostImpl(int) - 类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 的构造方法
DocumentRightHostImpl(CMSObj) - 类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 的构造方法
Documents - com.trs.components.wcm.content.persistent 中的 类
Documents(User) - 类 com.trs.components.wcm.content.persistent.Documents 的构造方法
Documents(User, int, int) - 类 com.trs.components.wcm.content.persistent.Documents 的构造方法
DOCUMENTS_GET_OPTIMIZE - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
DOCUMENTS_TIMERANGE_INI - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 中的静态变量
DocumentSchema - com.trs.components.infoview.extract.manifest 中的 类
/xsf:xDocumentClass/xsf:documentSchemas/xsf:documentSchema
DocumentSchema() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 的构造方法
DocumentService - com.trs.service.impl 中的 类
DocumentService() - 类 com.trs.service.impl.DocumentService 的构造方法
构造函数：保留默认接口
DocumentServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
提供文档相关服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentServiceProvider() - 类 com.trs.ajaxservice.DocumentServiceProvider 的构造方法
DocumentsGetHelper - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
单表提取文档集合的功能对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentsGetHelper() - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 的构造方法
DocumentShowFieldConfig - com.trs.components.wcm.content.persistent 中的 类
DocumentShowFieldConfig() - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 的构造方法
DocumentsPageHelper - com.trs.presentation.wcm.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档列表页面业务逻辑管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentsPageHelper(User, RequestHelper, Channel) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 的构造方法
DocumentsPageHelper(User, RequestHelper, WebSite) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 的构造方法
DocumentsPageHelper(User, RequestHelper) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 的构造方法
DocumentsPageHelper(User, RequestHelper, BaseChannel) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 的构造方法
DocumentsTemp - com.trs.components.wcm.publish.tagparser 中的 类
DocumentsTemp() - 类 com.trs.components.wcm.publish.tagparser.DocumentsTemp 的构造方法
DocumentsTimeRangeMgrImpl - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentsTimeRangeMgrImpl() - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 的构造方法
DocumentSubstanceImplBase - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentSubstanceImplBase() - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 的构造方法
DocumentSubstanceImplBase(int) - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 的构造方法
DocumentSubstanceImplBase(CMSObj) - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 的构造方法
DocumentSyn - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
已经自动转发过的文档的记录
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentSyn() - 类 com.trs.components.wcm.content.persistent.DocumentSyn 的构造方法
默认的构造函数
DocumentSyns - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
已经转发过的文档记录集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentSyns(User) - 类 com.trs.components.wcm.content.persistent.DocumentSyns 的构造方法
DocumentSyns(User, int, int) - 类 com.trs.components.wcm.content.persistent.DocumentSyns 的构造方法
DocumentSynServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档分发服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentSynServiceProvider() - 类 com.trs.ajaxservice.DocumentSynServiceProvider 的构造方法
DocumentTopic - com.trs.components.comment.persistent 中的 类
DocumentTopic() - 类 com.trs.components.comment.persistent.DocumentTopic 的构造方法
构造函数：保留默认接口
DocumentTopicRelationMgr - com.trs.components.comment.domain 中的 类
DocumentTopicRelationMgr() - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 的构造方法
DocumentTopics - com.trs.components.comment.persistent 中的 类
DocumentTopics(User) - 类 com.trs.components.comment.persistent.DocumentTopics 的构造方法
构造函数
DocumentTopics(User, int, int) - 类 com.trs.components.comment.persistent.DocumentTopics 的构造方法
构造函数
DocumentToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentToXML() - 类 com.trs.ajaxservice.xmlconvertors.DocumentToXML 的构造方法
DocumentXmlConverter - com.trs.components.wcm.content.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
负责和Document以XML方式导入、导出的方法
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DocumentXmlConverter() - 类 com.trs.components.wcm.content.persistent.DocumentXmlConverter 的构造方法
doDecrypt(String, InputStream, OutputStream) - 类 com.trs.service.impl.SecurityService 中的方法
doDecrypt(String, InputStream, OutputStream) - 接口 com.trs.service.ISecurityService 中的方法
使用指定名称的密钥，解密指定的输入流中的数据，并将明文写入指定的输出流。
doDigest(String, InputStream) - 类 com.trs.service.impl.SecurityService 中的方法
doDigest(String, InputStream) - 接口 com.trs.service.ISecurityService 中的方法
使用指定的算法计算指定数据源（输入流）的摘要
doEncrypt(String, InputStream, OutputStream) - 类 com.trs.service.impl.SecurityService 中的方法
doEncrypt(String, InputStream, OutputStream) - 接口 com.trs.service.ISecurityService 中的方法
使用指定名称的密钥，加密指定的输入流中的数据，并将密文写入指定的输出流。
doExport(BaseObj, Object) - 类 com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView 中的方法
doExport(BaseObj, Object) - 接口 com.trs.components.wcm.content.service.portervisitors.IPorterVisitor 中的方法
在导出_baseObj对象时,根据_baseObj对象做一些额外处理
doExport(BaseObj, Object) - 类 com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow 中的方法
doExports(BaseObj, Object) - 类 com.trs.components.wcm.content.service.portervisitors.PorterUtil 中的静态方法
根据注册的导入/导出访问器类,在导出_baseObj时,执行所有已注册的访问器的导出定制操作
doFilter(ServletRequest, ServletResponse, FilterChain) - 类 com.trs.devhelper.JsCombineFilter 中的方法
doFilter(ServletRequest, ServletResponse, FilterChain) - 类 com.trs.servlet.CharSetFilter 中的方法
doFilter(ServletRequest, ServletResponse, FilterChain) - 类 com.trs.servlet.JspDenyFilter 中的方法
doFilter(ServletRequest, ServletResponse, FilterChain) - 类 com.trs.servlet.LoginCheckFilter 中的方法
doFilter(ServiceFilterConfig, MethodContext) - 接口 com.trs.webframework.provider.IServiceFilter 中的方法
* 在执行服务之前，在这个方法中可以： 1、根据当前上下文参数，判断操作是否可以继续 2、如果不能继续，也可以通过MethodContext获取当前Servlet上下文参数，做重定向 3、也能够修改MethodContext
doFilter(ServiceFilterConfig, MethodContext) - 类 com.trs.webframework.provider.ServiceFilterExample 中的方法
doFilterRight(RightValue, Channel) - 类 com.trs.ajaxservice.xmlconvertors.ChannelToXML 中的静态方法
doForwardIfNeed() - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
doGet(String, Map) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
向指定的sURL发送一个get请求
doGet(String, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
向指定的sURL发送一个get请求
doGet(String, String) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
以GET方式发送请求，获取返回对象
doGet(String, Map) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
doImport(BaseObj, XmlObject, Object) - 类 com.trs.components.metadata.service.portervisitors.ChannelPorterVisitorForMetaView 中的方法
doImport(BaseObj, XmlObject, Object) - 接口 com.trs.components.wcm.content.service.portervisitors.IPorterVisitor 中的方法
在导入_baseObj对象时,根据当前xml串做一些额外处理
doImport(BaseObj, XmlObject, Object) - 类 com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow 中的方法
doImports(BaseObj, XmlObject, Object) - 类 com.trs.components.wcm.content.service.portervisitors.PorterUtil 中的静态方法
根据注册的导入/导出访问器类,在导入_baseObj时,执行所有已注册的访问器的导入定制操作
DoingRuleHandler - com.trs.cms.process.engine.handlers 中的 类
DoingRuleHandler() - 类 com.trs.cms.process.engine.handlers.DoingRuleHandler 的构造方法
done() - 类 com.trs.infra.util.CMyZip 中的方法
doOpersJs() - 类 com.trs.tools.WCM61AutoList 中的方法
doPageVariablesParse(String, ExecuteContext) - 类 com.trs.cms.process.engine.handlers.MsgSendHandler 中的方法
替换内容中的变量
doPageVariablesParse(String, ExecuteContext) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler 中的方法
替换内容中的变量
doPageVariablesParse(String, ExecuteContext) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler 中的方法
替换内容中的变量
doPageVariablesParse(String, ExecuteContext) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 中的方法
替换内容中的变量
doPageVariablesParse(String, ExecuteContext) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler 中的方法
替换内容中的变量
doPost(String, Map) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
向指定的sURL发送一个post请求
doPost(String, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
doPost(String, Map, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
doPost(String, String, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
doPost(String, String) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
以POST方式发送请求，获取返回对象
doPost(String, byte[]) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
以POST方式发送请求，获取返回对象
doPost(String, String, boolean) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
以POST方式发送请求，获取返回对象
doPost(String, Map, boolean) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
doPost(String, byte[], boolean) - 类 com.trs.infra.util.HttpClientBuddy 中的方法
以POST方式发送请求，获取返回对象
doQueryJsp() - 类 com.trs.tools.WCM61AutoList 中的方法
doReceive(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
doReceive(FlowContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法
doReceive(FlowContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
接收
doResetRight() - 类 com.trsupdate.RightUpdaterForUser 中的方法
doSend(String) - 类 com.trs.components.common.message.SMSSocketSender 中的方法
发送短信给指定的接受者
doSign(String, InputStream) - 类 com.trs.service.impl.SecurityService 中的方法
doSign(String, InputStream) - 接口 com.trs.service.ISecurityService 中的方法
使用指定名称的密钥计算指定的数据源的签名
doUnZipAnd() - 类 com.trs.infra.util.CMyUnZipFile 中的方法
doUpdate() - 类 com.trs.components.common.publish.PublishUpdateCommderImpl 中的方法
doUpdate() - 类 com.trs.components.wcm.content.ContentUpdateCommanderImpl 中的方法
doUpdate() - 类 com.trs.components.wcm.wcmx.help.WcmHelpUpdate 中的方法
doUpdate() - 接口 com.trs.infra.update.IUpdateCommander 中的方法
doUserAdd(CAUserSync.UserInfo) - 类 com.trs.presentation.ids.CAUserSync 中的方法
同步用户添加
doUserDel(CAUserSync.UserInfo) - 类 com.trs.presentation.ids.CAUserSync 中的方法
同步用户删除
doUserModify(CAUserSync.UserInfo) - 类 com.trs.presentation.ids.CAUserSync 中的方法
同步用户修改
doValid() - 类 com.trs.presentation.util.RequestHelper 中的方法
doValid(boolean) - 类 com.trs.presentation.util.RequestHelper 中的方法
根据当前页面的配置文件,解析当前传入页面的参数
doValid(String, HashMap) - 类 com.trs.wcag2.validator.BiTagValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.DocTypeValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.EmbedAltValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.EventsValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.FormElementsValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.FormSubmitValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.FrameTitleValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.HtmlCharsetValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.HtmlH1_H6Validator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.HtmlH1Validator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.HtmlLangValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.HtmlTitleValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.ImgAltValidator 中的方法
doValid(String, HashMap) - 接口 com.trs.wcag2.validator.IValidator 中的方法
doValid(String, HashMap) - 类 com.trs.wcag2.validator.ObjectBodyValidator 中的方法
doValid(String) - 类 com.trs.wcag2.WCAG2Helper 中的静态方法
doVerify(String, InputStream, byte[]) - 类 com.trs.service.impl.SecurityService 中的方法
doVerify(String, InputStream, byte[]) - 接口 com.trs.service.ISecurityService 中的方法
使用指定名称的密钥，验证指定数据源和签名是否相符
dowithFile(String) - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法
dowithFile(String) - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态方法
dowithIds(String) - 类 com.trs.infra.common.BaseIdsMan 中的方法
处理Ids
dowithLine(String) - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法
dowithPath(String) - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法
dowithPath(String) - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态方法
downloadFile(String, String) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
从远程FTP服务器上下载指定的文件到本地
DRAFT_CHANNEL - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
DRAFT_CHANNEL_ID - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
drawWatermark(Image, Color, String, String) - 类 com.trs.infra.util.CImage 中的方法
public int getSize(Image p_Image){ }
drawWatermark(Image, Color, String, String, String, int) - 类 com.trs.infra.util.CImage 中的方法
给图片加上水印
DreamFactory - com.trs 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
获取BeansConfig中配置的Bean实例
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
DreamFactory() - 类 com.trs.DreamFactory 的构造方法
DT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
dtAddList - 类 com.trs.components.common.job.Schedule 中的变量
DUMMY - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
duplicate(User, boolean) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
copy from this publish task and create a new one.
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


E - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

E

editAppendix(Document, Appendix) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
修改附件
editDocuments(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
批量修改文档属性
editImportSource(String, String, String, String) - 类 com.trs.presentation.documetimport.xml.DocumentImportXmlHelper 中的静态方法
编辑一个文档导入所需的xml映射文件 just for document/document_xml_edit_dowith.jsp
editLinkInChannel(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
EM - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
EmailSendWorker - com.trs.components.common.message 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Email(邮件)发送者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
EmailSendWorker() - 类 com.trs.components.common.message.EmailSendWorker 的构造方法
EmbedAltValidator - com.trs.wcag2.validator 中的 类
EmbedAltValidator() - 类 com.trs.wcag2.validator.EmbedAltValidator 的构造方法
EMPTY - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType 中的静态变量
在开始置标和结束置标之间不能有任何内容
EMPTY_COLUMN_HTML - 接口 com.trs.components.common.publish.widget.ILayoutGenerator 中的静态变量
列的初始内容
emptyInbox(User) - 类 com.trs.components.common.message.MessageServer 中的静态方法
清空用户的收件箱
将用户接收到的消息都删除掉
参照delete的逻辑
emptyOutbox(User) - 类 com.trs.components.common.message.MessageServer 中的静态方法
清空用户的已发消息
将用户接发送的消息都删除掉
参照delete的逻辑
emptyRecycleBin(int) - 接口 com.trs.service.IChannelService 中的方法
清空指定频道的文档回收站
删除指定频道回收站中的所有文档.
emptyRecycleBin(int) - 类 com.trs.service.impl.ChannelService 中的方法
清空指定频道的文档回收站
删除指定频道回收站中的所有文档.
enable(User) - 类 com.trs.service.impl.UserService 中的方法
enable(int) - 类 com.trs.service.impl.UserService 中的方法
enable(User) - 接口 com.trs.service.IUserService 中的方法
开通一个用户
enable(int) - 接口 com.trs.service.IUserService 中的方法
根据ID恢复用户
enableCKMService(boolean, boolean, boolean) - 接口 com.trs.components.ckm.ICKMServer 中的方法
开启CKM服务器的某些服务
enableCKMService(boolean, boolean, boolean) - 类 com.trs.components.ckm.TRSCKMServer 中的方法
enableFlowToChannel(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
给指定栏目启动启用指定的工作流
enablePublish(boolean) - 类 com.trs.components.infoview.extract.DataGroup 中的方法
enableUser(SSOUser) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
开通用户
encode(byte[]) - 类 com.trs.infra.util.BASE64EncoderStream 中的静态方法
使用BASE64编码一个字节数组，输出数组中不会加入非BASE64字符。
encode(String) - 类 com.trs.infra.util.Base64Util 中的静态方法
编码指定的字符串 注意:如果字符串以__encoded__开头,则认为是已编码的
encode(String) - 类 com.trs.infra.util.CMyURLEncoder 中的静态方法
已过时。 The resulting string may vary depending on the platform's default encoding. Instead, use the encode(String,String) method to specify the encoding.
encode(String, String) - 类 com.trs.infra.util.CMyURLEncoder 中的静态方法
Translates a string into application/x-www-form-urlencoded format using a specific encoding scheme.
encode(String, BufferedWriter) - 类 com.trs.infra.util.email.MIMEBase64 中的静态方法
encode(String) - 类 com.trs.infra.util.URLCoder 中的静态方法
使用缺省字符集编码URL
encode(String, String) - 类 com.trs.infra.util.URLCoder 中的静态方法
使用指定的字符集编码URL
encodeBytes(byte[]) - 接口 com.trs.template.IDataTransferEncode 中的方法
对需要加密的数据进行加密
encodeForCDATA(String) - 类 com.trs.infra.util.CMyString 中的静态方法
处理XML内容时
如果有CDATA嵌套则替换
encodeForRegExp(String) - 类 com.trs.infra.util.CMyString 中的静态方法
对输入字符串中的正则表达式特殊字符进行转义，转成普通字符
encodeRadix64(byte[]) - 类 com.trs.infra.util.CMySign 中的方法
进行Base64编码，但是与标准的Base64不同，'-'代替'+'，'_'代替'/'进行转换，用'.'
encodeString(String) - 接口 com.trs.template.IDataTransferEncode 中的方法
对需要加密的数据进行加密
encodeStrToWrite(String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
将指定字符串编码为数据库能够正确接受的字符串
encodeStrToWrite(String) - 类 com.trs.infra.util.database.DB2UDB 中的方法
将指定字符串编码为数据库能够正确接受的字符串
encodeStrToWrite(String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法
将指定字符串编码为数据库能够正确接受的字符串
encodeStrToWrite(String) - 类 com.trs.infra.util.database.DBType 中的方法
将指定字符串编码为数据库能够正确接受的字符串
encodeStrToWrite(String) - 类 com.trs.infra.util.database.MysqlDB 中的方法
将指定字符串编码为数据库能够正确接受的字符串
Oracle不需额外处理
encodeStrToWrite(String) - 类 com.trs.infra.util.database.OracleDB 中的方法
将指定字符串编码为数据库能够正确接受的字符串
Oracle不需额外处理
encodeStrToWrite(String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
将指定字符串编码为数据库能够正确接受的字符串
使用SQLServerDB.WRITE_STR_ENCODING进行编码，默认为(ISO-8859-1)
encodeStrToWrite(String) - 类 com.trs.infra.util.database.SybaseASE 中的方法
encodeStrToWrite(String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
ENCODING_DEFAULT - 类 com.trs.infra.util.CMyString 中的静态变量
默认字符编码集
encrypt(String, byte[]) - 类 com.trs.infra.support.security.SecureKeyMgr 中的方法
使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。
encrypt(String, byte[]) - 类 com.trs.service.impl.SecurityService 中的方法
encrypt(String, byte[]) - 接口 com.trs.service.ISecurityService 中的方法
使用指定名称的密钥加密指定的明文数据，并返回密文数据 如果指定的密钥是对称密钥，则一定使用公钥进行加密。
ENCTYPE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
end() - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
已过时。 Just clear all references to deflater instead.
end() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
已过时。 Just clear all references to inflater instead.
end(int, String) - 类 com.trs.infra.util.upgrade.sql.DbUpdSqlLogMaker 中的方法
endDocument() - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法
endElement(String, String, String) - 类 com.trs.cms.content.WCMHandler 中的方法
endElement(String, String, String) - 类 com.trs.cms.content.WCMObjsHandler 中的方法
endElement(String, String, String) - 类 com.trs.infra.persistent.BaseObjHandler 中的方法
endElement(String, String, String) - 类 com.trs.infra.persistent.BaseObjsHandler 中的方法
endElement(String, String, String) - 类 com.trs.infra.util.CMyXMLHandler 中的方法
endElement(String, String, String) - 类 com.trs.webframework.controler.PostDataParser 中的方法
endElement(String, String, String) - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法
endLog(int) - 类 com.trs.webframework.AbstractLogger 中的方法
endLog(int) - 类 com.trs.webframework.DefaultSaveLogger 中的方法
endLog(int) - 接口 com.trs.webframework.ServiceExcuteLogger 中的方法
endLogWithFaliure(int, Throwable) - 类 com.trs.webframework.AbstractLogger 中的方法
endLogWithFaliure(int, Throwable) - 类 com.trs.webframework.DefaultSaveLogger 中的方法
endLogWithFaliure(int, Throwable) - 接口 com.trs.webframework.ServiceExcuteLogger 中的方法
endRecordFailedOperation(long, Throwable) - 类 com.trs.infra.support.log.LogServer 中的静态方法
endRecordSucceedOperation(long) - 类 com.trs.infra.support.log.LogServer 中的静态方法
endRecordSucceedOperation(long, int) - 类 com.trs.infra.support.log.LogServer 中的静态方法
记录一个成功的操作日志
同时更新该记录的logobjid属性.
ENDTAG - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
entries() - 类 com.trs.infra.util.cabfile.CabFile 中的方法
entries() - 类 com.trs.infra.util.jazzlib.ZipFile 中的方法
Returns an enumeration of all Zip entries in this Zip file.
EntryConfig - com.trs.components.common.conjection.persistent 中的 类
EntryConfig() - 类 com.trs.components.common.conjection.persistent.EntryConfig 的构造方法
构造函数：保留默认接口
EntryConfigs - com.trs.components.common.conjection.persistent 中的 类
EntryConfigs(User) - 类 com.trs.components.common.conjection.persistent.EntryConfigs 的构造方法
构造函数
EntryConfigs(User, int, int) - 类 com.trs.components.common.conjection.persistent.EntryConfigs 的构造方法
构造函数
ENUM_TYPE_LINKED - 类 com.trs.components.infoview.config.EnumsConfig 中的静态变量
ENUM_TYPE_NORMAL - 类 com.trs.components.infoview.config.EnumsConfig 中的静态变量
EnumCreator - com.trs.components.infoview.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
EnumCreator() - 类 com.trs.components.infoview.config.EnumCreator 的构造方法
EnumsConfig - com.trs.components.infoview.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
enumScript(InfoViewContext) - 接口 com.trs.service.IInfoViewEnumCreator 中的方法
enumScript(InfoViewContext) - 类 com.trs.service.impl.InfoViewEnumCreatorImpl 中的方法
EPressChannelCreateLogger - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
创建电子报栏目日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
EPressChannelCreateLogger() - 类 com.trs.components.wcm.epress.EPressChannelCreateLogger 的构造方法
EPressChannelWrapper - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
栏目包装
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressChannelWrapper(int, String) - 类 com.trs.components.wcm.epress.EPressChannelWrapper 的构造方法
EPressConf - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报相关配置
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EpressFolderWrapper - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EpressFolderWrapper(IPublishFolder) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 的构造方法
EpressFolderWrapper(IPublishFolder, CMyDateTime) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 的构造方法
EPressHistoryGenerator - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报历史数据概览索引产生者
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressHistoryGenerator(Channel) - 类 com.trs.components.wcm.epress.EPressHistoryGenerator 的构造方法
EPressHistoryGenerator(Channel, boolean) - 类 com.trs.components.wcm.epress.EPressHistoryGenerator 的构造方法
EPressHistoryIndexWorker - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
计划发布产生概览索引(当天的数据)
Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressHistoryIndexWorker() - 类 com.trs.components.wcm.epress.EPressHistoryIndexWorker 的构造方法
EPressHistoryPubLogger - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
发布历史索引日志
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
EPressHistoryPubLogger() - 类 com.trs.components.wcm.epress.EPressHistoryPubLogger 的构造方法
EPressImporter - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报数据导入
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressImporter() - 类 com.trs.components.wcm.epress.EPressImporter 的构造方法
EPressServiceProvider - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
电子报频道的相关ajax服务提供者
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressServiceProvider() - 类 com.trs.components.wcm.epress.EPressServiceProvider 的构造方法
EPressSoapService - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressSoapService() - 类 com.trs.components.wcm.epress.EPressSoapService 的构造方法
EPressXPlusImporter - com.trs.components.wcm.epress 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
XPlus数据文件导入
Copyright: Copyright (c) 2004-2006 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
EPressXPlusImporter() - 类 com.trs.components.wcm.epress.EPressXPlusImporter 的构造方法
equals(Object) - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法
equals(Object) - 类 com.trs.cms.auth.persistent.User 中的方法
用户对象比较
equals(Object) - 类 com.trs.cms.content.ExtendedField 中的方法
equals(Object) - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法
equals(Object) - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
equals(Object) - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
equals(Object) - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法
equals(Object) - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 中的方法
equals(Object) - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 中的方法
equals(Object) - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 中的方法
equals(int) - 类 com.trs.infra.persistent.BaseObj 中的方法
在id标识对象的条件下，判断对象是否为指定id标识的对象
equals(Object) - 类 com.trs.infra.persistent.BaseObj 中的方法
判定本对象是否与指定对象相同
equals(Object) - 类 com.trs.infra.util.CMyDateTime 中的方法
Returns true if this datetime equals with the specified one.
equals(Object) - 类 com.trs.infra.util.database.CDBText 中的方法
equals(Object) - 类 com.trs.infra.util.database.DataType 中的方法
对象比较判断
equals(Object) - 类 com.trs.infra.util.html.HTML.UnknownTag 中的方法
Compares this object to the specifed object.
equals(Object) - 类 com.trs.infra.util.MySSLSocketFactory 中的方法
equals(Object) - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的方法
ERR_CLASS_CONFIG - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号：类配置错误
ERR_CLASS_NOTFOUND - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号：class未找到
ERR_CMYEXCEPTION - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_CONFIG_MISSING - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号：缺少配置
ERR_CONNECTION_GETFAIL - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:取数据库连接失败
ERR_DATACONVERT - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:数据转化错误
ERR_DBOP_FAIL - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:数据库操作失败
ERR_DOC_DUPLICATED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
文档无法移动或转发到自身所在频道
ERR_FACTORY_CONFIG - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
工厂文件配置错误
ERR_FILE_NOTFOUND - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:文件未找到
ERR_FILEOP_CLOSE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:关闭文件失败
ERR_FILEOP_FAIL - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:文件操作失败
ERR_FILEOP_MOVE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:移动文件失败
ERR_FILEOP_OPEN - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:打开文件失败
ERR_FILEOP_READ - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:读文件失败
ERR_FILEOP_WRITE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:写文件失败
ERR_FORMAT_INVALID - 类 com.trs.infra.config.ConfigConstants 中的静态变量
ERR_HOST_NOT_FOUND - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
ERR_IMPORTFILE_INVALID - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
导入的文件格式不支持
ERR_INSTANCE_INVALID - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
通过Class.newInstance,创建BaseObj对象实例失败
ERR_LOADPROPERTY - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_MESSAGE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
消息
ERR_MESSAGE_UNKNOWN_SENDTYPE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
unknown message send type
ERR_MYEXCEPTION - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:数据转化错误
ERR_NET_OPENSTREAM - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:打开网络数据流失败
ERR_NEW_INSTANCE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量：实例话对象失败
ERR_NEWOBJ_INVALID - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
新建对象无效
ERR_NO_LOCAL_FILE - 类 com.trs.infra.util.ftp.CMyFtp 中的变量
ERR_NOSUPPORTEDENCRYPTING - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_NUMOP_FAIL - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:数学运算错误
ERR_OBJ_LOCKED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
对象已被其他用户锁定
ERR_OBJ_NOTFOUND - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
ERR_OBJ_NOTLOCKED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
对象未锁定
ERR_OBJ_NULL - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量: 空指针
ERR_PARAM_INVALID - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:无效参数
ERR_PARAM_INVALID - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_PROPERTY_NOT_EXIST - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
不存在该属性
ERR_PROPERTY_NOT_MODIFIED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
对象属性没有修改
ERR_PROPERTY_NOT_SET - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
对象属性没有设置
ERR_PROPERTY_NOTALLOW_EDIT - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
属性不允许修改
ERR_PROPERTY_TYPE_INVALID - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
属性类型不匹配
ERR_PROPERTY_VALUE_DUPLICATED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
属性值重复
ERR_PROPERTY_VALUE_INVALID - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
属性值无效
ERR_PUBLISH - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error
ERR_PUBLISH_ANALYZE_DETAIL_PAGE_TASK - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: failed to analyze the detail page tasks
ERR_PUBLISH_CANCEL_TASK - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: failed to cancel the publish task
ERR_PUBLISH_CREATE_TASK - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: failed to create publish task
ERR_PUBLISH_DETAIL_TEMPLATE_REQUIRED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: detail template required
ERR_PUBLISH_FIlE_DISTRIBUTE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: failed to distribute the file
ERR_PUBLISH_OUTLINE_TEMPLATE_REQUIRED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: outline template required
ERR_PUBLISH_PAGE_GENERATE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: failed to generate page
ERR_PUBLISH_SERVER_NOTSTARTED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: the publish server has not been started
ERR_PUBLISH_TAG_PARSE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: failed to parse the specified tag
ERR_PUBLISH_TAG_PROPERTY_VALUE_INVALID - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: invalid tag property value
ERR_PUBLISH_TAGDOC_GRAMMAR_ILLEGAL - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: tag document grammar is illegal
ERR_PUBLISH_TASK_STILLOPEN - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: the publish task is still open (has not been executed)
ERR_PUBLISH_TEMPLATE_SEMANTIC_ANALYSE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: failed to analyze the semantic relations in template
ERR_PUBLISH_UNKNOWN_CONTENT_TYPE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: unknown publish content type
ERR_PUBLISH_UNKNOWN_FOLDER_TYPE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: unknown publish folder type
ERR_PUBLISH_UNKNOWN_PUBLISH_TYPE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: unknown publish type
ERR_PUBLISH_UPDATE_QUOTING_FOLDERS - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
publish error: fails to update the quoting folders
ERR_PWD_WRONG - 类 com.trs.presentation.util.LoginHelper 中的静态变量
密码错误
ERR_REFRESH_NOTIFICATION_SERVER - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
failed to refresh the notification server
ERR_RUNTIME_CONFIG - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号：运行时配置错误
ERR_SEND_NOTIFICATION - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
failed to send notification
ERR_SYS_OBJECT_NOT_FOUND - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
ERR_SYS_PARAM_INVALID - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
ERR_SYS_PARAM_NOT_SET - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
ERR_SYS_RUNTIME - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
ERR_TEMPLATE_HOST_NOT_FOUND - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
ERR_TEMPLATE_NOT_FOUND - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
ERR_UNKNOWN - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:不明错误
ERR_URL_MALFORMED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
错误编号常量:无效URL
ERR_USER_DELETED - 类 com.trs.presentation.util.LoginHelper 中的静态变量
用户已删除
ERR_USER_FORBID - 类 com.trs.presentation.util.LoginHelper 中的静态变量
用户已禁止
ERR_USER_INVALID - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_USER_LOCKED - 类 com.trs.presentation.util.LoginHelper 中的静态变量
用户已锁定
ERR_USER_LOGINED - 类 com.trs.presentation.util.LoginHelper 中的静态变量
用户已经登录
ERR_USER_NOREG - 类 com.trs.presentation.util.LoginHelper 中的静态变量
用户未批准
ERR_USER_NORIGHT - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
用户没有操作权限
ERR_USER_NOTEXIST - 类 com.trs.presentation.util.LoginHelper 中的静态变量
用户不存在
ERR_USER_NOTEXIST - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_USER_NOTLOGIN - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
用户未登录或超时
ERR_USER_NOTLOGIN - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_USERDEF_FROM - 类 com.trs.presentation.util.LoginHelper 中的静态变量
用户自定义错误起始编号（负数，递减1）
ERR_WCMEXCEPTION - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
WCM Exception
ERR_WCMEXCEPTION - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_WRONG_PASSWORD - 类 com.trs.template.InnerExceptionNum 中的静态变量
ERR_XML_PROPERTY_REQUIRED - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
xml error: the specified property is requried
ERR_XMLELEMENT_NOTFOUND - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
XML解析错误：指定XML元素没有找到
ERR_XMLFILE_PARSE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
Comment for ERR_XMLFILE_PARSE
XML文件解析的异常，错误编号：150
ERR_XMLSTRING_PARSE - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
XML字符串解析异常
ERR_XMLSTRUCTURE_NOTROOT - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
Comment for ERR_XMLSTRUCTURE_NOTROOT
XML结构错误，没有定义根元素，错误编号：151
ERR_ZIP_UNZIP - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
Comment for ERR_ZIP_UNZIP
解压文件异常，错误编号：200
ERRNUM_MAX - 类 com.trs.presentation.util.LoginHelper 中的静态变量
最多允许密码错误次数；默认10次。
ERROR - 类 com.trs.infra.support.log.LogType 中的静态变量
日志类型:错误
ERROR_CODE_DEFAULT - 异常 com.trs.webframework.exception.ServiceInvocationException 中的静态变量
ErrorMessagesFactory - com.trs.template 中的 类
ErrorMessagesFactory() - 类 com.trs.template.ErrorMessagesFactory 的构造方法
ESCAPE_CHAR - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的静态变量
Event - com.trs.components.common.calendar 中的 类
Event() - 类 com.trs.components.common.calendar.Event 的构造方法
EVENT_TYPE_ADD - 类 com.trs.cluster.ClusterConstants 中的静态变量
新增一个对象
EVENT_TYPE_ADD - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的静态变量
EVENT_TYPE_DELETE - 类 com.trs.cluster.ClusterConstants 中的静态变量
删除指定对象
EVENT_TYPE_DELETE_AFTER - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的静态变量
EVENT_TYPE_DELETE_BEFORE - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的静态变量
EVENT_TYPE_EDIT - 类 com.trs.cluster.ClusterConstants 中的静态变量
修改指定对象
EVENT_TYPE_EDIT_AFTER - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的静态变量
EVENT_TYPE_EDIT_BEFORE - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的静态变量
EVENT_TYPE_TALBE_RELOAD - 类 com.trs.cluster.ClusterConstants 中的静态变量
表结构重新载入
EVENT_TYPES - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的静态变量
EVENT_TYPES_DEFAULT - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的静态变量
EventLCListenerForRemind - com.trs.components.common.calendar 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日程提醒消息的监听
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
EventLCListenerForRemind() - 类 com.trs.components.common.calendar.EventLCListenerForRemind 的构造方法
EventMgr - com.trs.components.common.calendar 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日程管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
EventMgr() - 类 com.trs.components.common.calendar.EventMgr 的构造方法
Events - com.trs.components.common.calendar 中的 类
Events(User) - 类 com.trs.components.common.calendar.Events 的构造方法
Events(User, int, int) - 类 com.trs.components.common.calendar.Events 的构造方法
EventService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日程服务提供对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
EventService() - 类 com.trs.service.impl.EventService 的构造方法
EventShare - com.trs.components.common.calendar 中的 类
EventShare() - 类 com.trs.components.common.calendar.EventShare 的构造方法
构造函数：保留默认接口
EventShareIdsMan - com.trs.components.common.calendar 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
日程共享管理:处理共享日程时,维护指定的日程安排与共享者的关联关系
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
EventShareIdsMan(int, int) - 类 com.trs.components.common.calendar.EventShareIdsMan 的构造方法
EventShares - com.trs.components.common.calendar 中的 类
EventShares(User) - 类 com.trs.components.common.calendar.EventShares 的构造方法
构造函数
EventShares(User, int, int) - 类 com.trs.components.common.calendar.EventShares 的构造方法
构造函数
EventsValidator - com.trs.wcag2.validator 中的 类
EventsValidator() - 类 com.trs.wcag2.validator.EventsValidator 的构造方法
EventType - com.trs.components.common.calendar 中的 类
EventType() - 类 com.trs.components.common.calendar.EventType 的构造方法
EventTypes - com.trs.components.common.calendar 中的 类
EventTypes(User) - 类 com.trs.components.common.calendar.EventTypes 的构造方法
EventTypes(User, int, int) - 类 com.trs.components.common.calendar.EventTypes 的构造方法
EVERYONE_ID - 类 com.trs.cms.auth.persistent.Role 中的静态变量
Everyone角色固定的ID值
ExceptionMessages - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ExceptionNumber - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
异常编号及描述汇总
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ExceptionNumber() - 类 com.trs.infra.util.ExceptionNumber 的构造方法
EXCLUDE_FROM_ORDER_MAX - 类 com.trs.components.wcm.content.persistent.Channel 中的静态变量
频道类型：不参与排序的频道类型的最大值（10）
EXCLUDE_PATH - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
EXCLUDE_PATH - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
excludeFileExt(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
排除文件的扩展名,只保留路径(如果存在)和主文件名
excute(String, String) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
使用Request中的参数执行指定的服务
excute(String, String, HashMap) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
使用指定的参数执行指定的服务
excute() - 接口 com.trs.webframework.xmlserver.server.IRequestProcessor 中的方法
excute() - 类 com.trs.webframework.xmlserver.server.RequestParamsProcessor 中的方法
excute() - 类 com.trs.webframework.xmlserver.server.RequestXMLDataProcessor 中的方法
分析Request信息，进行具体的处理工作
excuteArrayMult(String, String) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
执行一组中多个同名方法，并返回多个返回值
excuteMult(String, String) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
指定MultCall中的指定服务
excuteMult(int) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
指定MultCall中的指定顺序的服务，从0开始
execute(ExecuteContext, FlowAction) - 类 com.trs.cms.process.engine.handlers.AutoToNextHandler 中的方法
execute() - 类 com.trs.cms.process.engine.handlers.DoingRuleHandler 中的方法
execute(ExecuteContext, FlowAction) - 类 com.trs.cms.process.engine.handlers.MsgSendHandler 中的方法
execute(ExecuteContext, FlowAction) - 类 com.trs.cms.process.engine.handlers.PublishContentActionHandler 中的方法
execute(ExecuteContext, FlowAction) - 接口 com.trs.cms.process.engine.IActionHandler 中的方法
execute(JobExecutionContext) - 类 com.trs.components.common.job.BaseScheduleWorker 中的方法
execute(NotificationSchemeConfig) - 类 com.trs.components.common.message.notify.Notifier 中的方法
execute the specified notification scheme.
execute() - 接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTask 中的方法
执行该原子任务并返回执行结果 该方法的实现因该在其内部处理所有的异常信息，该方法抛出任何异常，都意味着整个发布任务失败。
execute(ExecuteContext, FlowAction) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler 中的方法
execute(ExecuteContext, FlowAction) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler 中的方法
execute(ExecuteContext, FlowAction) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.AutoFillApplyFormHandler 中的方法
execute(ExecuteContext, FlowAction) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 中的方法
execute(ExecuteContext, FlowAction) - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler 中的方法
execute(ExecuteContext, FlowAction) - 类 com.trs.components.infoview.process.SendEmailForInfoViewHandler 中的方法
execute(Object) - 类 com.trs.components.metadata.service.ObjectsIterator 中的方法
对当前传入的对象执行一定的处理
execute() - 类 com.trs.components.wcm.epress.EPressHistoryIndexWorker 中的方法
execute() - 类 com.trs.components.wcm.wcmx.util.CWasTree 中的方法
execute(User) - 类 com.trs.infra.persistent.util.SynChildrenExecutorBase 中的方法
execute(JobExecutionContext) - 类 com.trs.infra.util.job.BaseJob 中的方法
execute() - 类 com.trs.upgrade.UpgradeObjectMember4SiteMember 中的方法
将系统中的站点成员（用户、组织或角色）转换成对象的访问控制; 因为对于wcm60，如果是站点成员，那么对该站点可以访问， 所以在wcm65中，需要将其转换成可访问
execute() - 类 com.trs.util.ResetClassInfoOfViewData 中的方法
execute(MethodConfig, MethodContext) - 类 com.trs.webframework.WebServiceHelper 中的静态方法
execute(MethodConfig, MethodContext, boolean) - 类 com.trs.webframework.WebServiceHelper 中的静态方法
ExecuteContext - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流在驱动过程中上下文对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ExecuteContext(FlowContext) - 类 com.trs.cms.process.engine.ExecuteContext 的构造方法
ExecuteContext(FlowDoc) - 类 com.trs.cms.process.engine.ExecuteContext 的构造方法
executeOnEvent(String) - 类 com.trs.components.common.message.notify.Notifier 中的方法
execute the notification on the specified event.
executeRules(ExecuteContext, FlowRule[]) - 类 com.trs.cms.process.engine.RuleExecuteHelper 中的静态方法
exists(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
是否存在指定条件的分类信息
exists(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
是否存在指定条件的分类信息
existsEPress(String) - 类 com.trs.components.wcm.epress.EPressConf 中的方法
existsEPress(int) - 类 com.trs.components.wcm.epress.EPressConf 中的方法
existSimilarWidget(Widget) - 类 com.trs.components.common.publish.widget.WidgetMgr 中的方法
判断是否已经存在同名的资源
existsLogType(String) - 类 com.trs.infra.support.log.LogServer 中的静态方法
existsMName(int, String) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
校验母板名称是否已存在
existsMName(MethodContext) - 接口 com.trs.components.common.publish.widget.IMasterServiceProvider 中的方法
检查母板名称是否已存在
existsMName(int, String) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
校验母板名称是否已存在
existsMName(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
校验母板名称是否已存在
existsSimilarDataPath(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
在指定的站点或者栏目下是否存在相同存放路径的栏目
existsSimilarDataPath(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
在指定的站点或者栏目下是否存在相同存放路径的栏目
existsSimilarName(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
是否存在相同名称的栏目
existsSimilarName(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
判断指定扩展字段是否有效
existsSimilarName(MethodContext) - 类 com.trs.ajaxservice.ReplaceContentServiceProvider 中的方法
是否存在相同名称的栏目
existsSimilarName(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
是否存在相同名称的模板
existsSimilarName(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
是否存在相同名称的站点
existsSimilarName(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetParameterServiceProvider 中的方法
判断是否存在相同名称的资源变量
existsSimilarName(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetServiceProvider 中的方法
检查是否有同名模板
existsSimilarName(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 中的方法
existsSimilarName(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 中的方法
existsSimilarName(int, String) - 接口 com.trs.components.special.ISpecialMgr 中的方法
是否存在相同名称的专题
existsSimilarName(MethodContext) - 接口 com.trs.components.special.ISpecialServiceProvider 中的方法
是否存在相同名称的专题
existsSimilarName(int, String) - 类 com.trs.components.special.SpecialMgr 中的方法
existsSimilarName(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法
existsSimilarName(MethodContext) - 类 com.trs.components.wcm.epress.EPressServiceProvider 中的方法
existsSimilarName(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionServiceProvider 中的方法
判断该名称的导读是否已经存在
existWidgetParameter(Widget, WidgetParameter) - 接口 com.trs.components.common.publish.widget.IWidgetParameterMgr 中的方法
判断是否已经存在同名资源变量
existWidgetParameter(Widget, WidgetParameter) - 类 com.trs.components.common.publish.widget.WidgetParameterMgr 中的方法
expandStr(String, int, char, boolean) - 类 com.trs.infra.util.CMyString 中的静态方法
扩展字符串长度；若长度不足，则是用指定的字符串填充
export(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
导出指定栏目
export(MethodContext) - 类 com.trs.ajaxservice.ChnlDocServiceProvider 中的方法
导出指定的文档
export(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
导出指定的文档
export(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
导出指定的栏目或者站点下的模板
export(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
导出指定的文档
export(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
导出指定的站点
export(Templates) - 类 com.trs.components.common.publish.domain.template.TemplateExporter 中的方法
导出模板集合
export(ContentStyles, boolean) - 类 com.trs.components.common.publish.widget.ContentStyleExporter 中的方法
导出一个内容风格到xml文件中。
export(Masters) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
导出指定的母版
export(MethodContext) - 接口 com.trs.components.common.publish.widget.IMasterServiceProvider 中的方法
导出指定ID的母版
export(PageStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
导出指定页面风格的样式文件
export(Widgets) - 接口 com.trs.components.common.publish.widget.IWidgetMgr 中的方法
导出资源
export(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetServiceProvider 中的方法
导入资源
export(Masters) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
导出母板
export(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
导出指定Id的母板
export(PageStyles, boolean) - 类 com.trs.components.common.publish.widget.PageStyleExporter 中的方法
导出一个页面风格到xml文件中。
export(ResourceStyles, boolean) - 类 com.trs.components.common.publish.widget.ResourceStyleExporter 中的方法
导出一个页面风格到xml文件中。
export(PageStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
导出系统样式文件
export(Widgets) - 类 com.trs.components.common.publish.widget.WidgetMgr 中的方法
export(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 中的方法
export(MetaViews) - 类 com.trs.components.metadata.definition.xml.MetaViewExporter 中的方法
导出指定的视图
export(MetaViews, String) - 类 com.trs.components.metadata.definition.xml.MetaViewExporter 中的方法
导出指定的视图
export(Channels, boolean, boolean) - 类 com.trs.components.wcm.content.domain.ChannelExporter 中的方法
export(WebSites, boolean, boolean) - 类 com.trs.components.wcm.content.domain.ChannelExporter 中的方法
export(BaseChannel, boolean, boolean) - 类 com.trs.components.wcm.content.domain.ChannelExporter 中的方法
export(Object, boolean, boolean) - 类 com.trs.components.wcm.content.domain.ChannelExporter 中的方法
export(Object, boolean, boolean, boolean) - 类 com.trs.components.wcm.content.domain.ChannelExporter 中的方法
export(Object, boolean, boolean, boolean, boolean) - 类 com.trs.components.wcm.content.domain.ChannelExporter 中的方法
export(int, String, boolean) - 类 com.trs.components.wcm.content.domain.DocumentExporter 中的方法
导出指定的文档
export(Document, String, boolean) - 类 com.trs.components.wcm.content.domain.DocumentExporter 中的方法
导出指定的文档
export(String, String, boolean) - 类 com.trs.components.wcm.content.domain.DocumentExporter 中的方法
根据指定的ID序列导出文档
export(Documents, String, boolean) - 类 com.trs.components.wcm.content.domain.DocumentExporter 中的方法
导出文档集合
export(String) - 类 com.trs.infra.support.log.LogServer 中的静态方法
根据日志ID序列导出日志
export(BaseObjs) - 类 com.trs.infra.support.log.LogServer 中的静态方法
根据日志对象集合导出日志
export(BaseChannel, boolean, boolean) - 接口 com.trs.service.IChannelService 中的方法
将WCM的站点、频道导出成为WCM XML标准格式的字符串
export(WebSites, boolean, boolean) - 接口 com.trs.service.IChannelService 中的方法
export(Channels, boolean, boolean) - 接口 com.trs.service.IChannelService 中的方法
export(Document, String, boolean) - 接口 com.trs.service.IDocumentService 中的方法
导出指定的文档
export(int, String, boolean) - 接口 com.trs.service.IDocumentService 中的方法
导出指定的文档
export(String, String, boolean) - 接口 com.trs.service.IDocumentService 中的方法
根据指定的ID序列导出文档
export(Documents, String, boolean) - 接口 com.trs.service.IDocumentService 中的方法
导出文档集合
export(BaseChannel, boolean, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
export(WebSites, boolean, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
export(Channels, boolean, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
export(Document, String, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
export(int, String, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
export(String, String, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
export(Documents, String, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
export(String, String, boolean, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
export(String) - 类 com.trs.service.impl.TemplateService 中的方法
export(Templates) - 类 com.trs.service.impl.TemplateService 中的方法
export(int) - 类 com.trs.service.impl.TemplateService 中的方法
export(Template) - 类 com.trs.service.impl.TemplateService 中的方法
export(String) - 接口 com.trs.service.ITemplateService 中的方法
根据模板的Id列表导出模板集合到临时目录的文件中
export(Templates) - 接口 com.trs.service.ITemplateService 中的方法
导出模板集合到临时目录的文件中
export(int) - 接口 com.trs.service.ITemplateService 中的方法
根据Id导出模板到临时目录的文件中
export(Template) - 接口 com.trs.service.ITemplateService 中的方法
导出模板到固定的文件中
export(Templates) - 类 com.trs.template.domain.XTemplateExporter 中的方法
导出模板集合
exportAllViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
导出指定视图或栏目下的所有元数据记录
exportChannels(String, boolean, boolean) - 接口 com.trs.service.IChannelService 中的方法
exportChannels(String, boolean, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
exportClassInfos(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
导出指定的分类法
exportContentStyleZip(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
导出一个内容风格对象到zip文件中，zip文件中包含这个内容风格的所有相关文件
exportCssFile(MethodContext) - 接口 com.trs.components.common.publish.widget.IPageStyleServiceProvider 中的方法
导出Css文件
exportCssFile(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
导出Css文件
exportFlow(int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
exportFlow(int) - 接口 com.trs.service.IWCMProcessService 中的方法
导出指定的工作流对象.
exportFlows(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
exportFlows(String) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
exportFlows(String) - 接口 com.trs.service.IWCMProcessService 中的方法
导出指定的工作流为XML文件格式的数据.
exportFlowsOfSite(WebSite, Object) - 类 com.trs.components.wcm.process.service.flowexporter.SiteExporterForFlow 中的方法
exportKey(String, boolean) - 类 com.trs.infra.support.security.SecureKeyMgr 中的方法
exportKey(int, boolean) - 类 com.trs.infra.support.security.SecureKeyMgr 中的方法
exportKey(int, boolean) - 类 com.trs.service.impl.SecurityService 中的方法
exportKey(String, boolean) - 类 com.trs.service.impl.SecurityService 中的方法
exportKey(String, Writer) - 类 com.trs.service.impl.SecurityService 中的方法
exportKey(Writer) - 类 com.trs.service.impl.SecurityService 中的方法
exportKey(boolean, String) - 类 com.trs.service.impl.SecurityService 中的方法
exportKey(boolean, int) - 类 com.trs.service.impl.SecurityService 中的方法
exportKey(int, boolean) - 接口 com.trs.service.ISecurityService 中的方法
导出指定ID的密钥的原始数据
exportKey(String, boolean) - 接口 com.trs.service.ISecurityService 中的方法
导出指定名称的密钥的原始数据
exportKey(String, Writer) - 接口 com.trs.service.ISecurityService 中的方法
以XML文件的形式导出指定的密钥
exportKey(Writer) - 接口 com.trs.service.ISecurityService 中的方法
以XML文件的形式导出系统内的全部密钥
exportKey(boolean, String) - 接口 com.trs.service.ISecurityService 中的方法
导出指定的密钥
exportKey(boolean, int) - 接口 com.trs.service.ISecurityService 中的方法
导出指定的密钥
exportPageStyleZip(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
导出一个页面风格对象到zip文件中，zip文件中包含这个页面风格的所有相关文件 组织好的待导出的文件是存放在系统临时目录下
exportResourceStyleZip(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
导出一个资源风格对象到zip文件中，zip文件中包含这个资源风格的所有相关文件
exportSites(String, boolean, boolean) - 接口 com.trs.service.IChannelService 中的方法
exportSites(String, boolean, boolean) - 类 com.trs.service.impl.ChannelService 中的方法
exportToExcelZip(MetaViewDatas, String, boolean) - 类 com.trs.components.metadata.center.xml.MetaViewDataExporter 中的方法
将指定视图下的数据连同附件导出成ZIP文件
exportToExcelZip(MetaViewDatas) - 类 com.trs.components.metadata.center.xml.MetaViewDataExporter 中的方法
将指定视图下的数据连同附件导出成ZIP文件
exportToXMLContent(Object, boolean, boolean) - 类 com.trs.components.wcm.content.domain.ChannelExporter 中的方法
exportToXMLFile(Template) - 类 com.trs.components.common.publish.domain.template.TemplateExporter 中的方法
将WCM的模板导出成为WCM XML标准格式的文件
exportToXMLFile(Templates) - 类 com.trs.components.common.publish.domain.template.TemplateExporter 中的方法
将WCM的模板集合导出成为WCM XML标准格式的文件
exportToXMLString(int) - 类 com.trs.infra.support.log.LogServer 中的静态方法
根据日志ID导出日志
导出的格式，符合WCMXML格式
exportToXMLString(ILog) - 类 com.trs.infra.support.log.LogServer 中的静态方法
根据日志对象导出日志
导出的格式，符合WCMXML格式
exportToZip(MetaViewDatas, String, boolean) - 类 com.trs.components.metadata.center.xml.MetaViewDataExporter 中的方法
将指定视图下的数据连同附件导出成ZIP文件
exportToZip(MetaViewDatas) - 类 com.trs.components.metadata.center.xml.MetaViewDataExporter 中的方法
将指定视图下的数据连同附件导出成ZIP文件
exportViewDatas(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
导出元数据
exportViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
导出元数据
exportViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
导出元数据
exportViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
导出元数据
exportViews(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
导出指定的视图
EXT_ADMANAGE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
广告管理
EXT_APTITUDE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
智能信息处理
EXT_COMMENT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
在线评论权限
EXT_FILE_CONFIG - 类 com.trs.infra.config.ConfigConstants 中的静态变量
EXT_GOVREFER_DEPT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
处理部门的咨询和信访
EXT_GOVREFER_SITE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
处理全站的咨询和信访
EXT_INFOGATE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
数据网关的权限
EXT_INFOVIEW_MGR - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
ge add by gfc @2008-4-10 下午08:38:06 表单管理 TODO 暂时没有空余的权限位，所以只能和信访重合，但基本上可以确定这两个东东不会放在一块使用
EXT_INTERVIEW - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
嘉宾访谈的权限
EXT_INVESTMENT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
问卷调查管理
EXT_MAX_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
扩展功能最大权限值
EXT_MIN_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
扩展功能最小权限值
EXT_SUBSCRIBE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
邮件订阅的权限
ExtendedField - com.trs.cms.content 中的 类
ExtendedField() - 类 com.trs.cms.content.ExtendedField 的构造方法
ExtendedFieldLCListenerForDocBak - com.trs.components.wcm.content.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ExtendedFieldLCListenerForDocBak() - 类 com.trs.components.wcm.content.domain.ExtendedFieldLCListenerForDocBak 的构造方法
ExtendedFields - com.trs.cms.content 中的 类
ExtendedFields(User) - 类 com.trs.cms.content.ExtendedFields 的构造方法
ExtendedFields(User, int, int) - 类 com.trs.cms.content.ExtendedFields 的构造方法
ExtendFieldServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
扩展字段服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ExtendFieldServiceProvider() - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 的构造方法
ExtensionConfigs - com.trs.infra.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ExtensionConfigs() - 类 com.trs.infra.config.persistent.ExtensionConfigs 的构造方法
ExtFieldToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
扩展字段XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ExtFieldToXML() - 类 com.trs.ajaxservice.xmlconvertors.ExtFieldToXML 的构造方法
extract(String, String) - 类 com.trs.components.infoview.CABFileExtractor 中的方法
TODO Add javadoc for field extract
extract(String, String) - 类 com.trs.components.infoview.extract.JavaCABFileExtractor 中的方法
extract(String, String) - 类 com.trs.components.infoview.extract.WinCABFileExtractor 中的方法
extract(File) - 类 com.trs.infra.util.cabfile.CabFile 中的方法
extractAbstractAndKeywords(String) - 接口 com.trs.components.ckm.ICKMServer 中的方法
extractAbstractAndKeywords(String) - 类 com.trs.components.ckm.TRSCKMServer 中的方法
extractDateFormat(String) - 类 com.trs.infra.util.CMyDateTime 中的静态方法
提取 日期 字符串数据的格式
extractDateTimeFormat(String) - 类 com.trs.infra.util.CMyDateTime 中的静态方法
提取 日期时间 字符串数据的格式
extractFileCrDate(String) - 类 com.trs.infra.support.file.FilesMan 中的静态方法
提取创建日期值
extractFileCrDateTime(String) - 类 com.trs.infra.support.file.FilesMan 中的静态方法
提取文件创建的日期时间值
extractFileCrDateValue(String) - 类 com.trs.infra.support.file.FilesMan 中的静态方法
提取日期值
extractFileCrTimeValue(String) - 类 com.trs.infra.support.file.FilesMan 中的静态方法
从文件名中提取创建时间值
extractFileDrive(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
从文件的完整路径名（路径+文件名）中提取文件所在驱动器
注意：区分两种类型的文件名表示
[1] d:\path\filename.ext --> return "d:"
[2] \\host\shareDrive\shareDir\filename.ext --> return "\\host\shareDrive"
extractFileExt(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
从文件的完整路径名（路径+文件名）中提取: 文件扩展名
extractFileName(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
从文件的完整路径名（路径+文件名）中提取文件名(包含扩展名)
如：d:\path\file.ext --> file.ext
extractFileName(String, String) - 类 com.trs.infra.util.CMyFile 中的静态方法
从文件的完整路径名（路径+文件名）中提取文件名(包含扩展名)
如：d:\path\file.ext --> file.ext
extractFilePath(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
从文件的完整路径名（路径+文件名）中提取 路径（包括：Drive+Directroy )
extractHttpFileName(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
从EB路径地址中提取: 文件名
extractKey(Reader) - 类 com.trs.service.impl.SecurityService 中的方法
extractKey(File, String) - 类 com.trs.service.impl.SecurityService 中的方法
extractKey(Reader) - 接口 com.trs.service.ISecurityService 中的方法
从指定的XML文件输出流中抽取全部可用的密钥
extractKey(File, String) - 接口 com.trs.service.ISecurityService 中的方法
从指定的XML文件中抽取全部可用的密钥
extractMainFileName(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
从文件的完整路径名（路径+文件名）中提取:主文件名（不包括路径和扩展名）
extractProtocolInURL(String, String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
Retuns protocol name in the specified URL if it includes protocol part;
other, returns the default protocol given.
extractTemplateNamesFromZip(String) - 类 com.trs.components.common.publish.domain.template.TemplateImporter 中的方法
得到模板名称列表
extractTemplateNamesFromZip(String) - 类 com.trs.service.impl.TemplateService 中的方法
extractTemplateNamesFromZip(String) - 接口 com.trs.service.ITemplateService 中的方法
得到导入文件中可能的模板文件名列表
extractTimeFormat(String) - 类 com.trs.infra.util.CMyDateTime 中的静态方法
提取 时间 字符串数据的格式
extractUserName(HttpServletRequest) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
extractUserPwd(HttpServletRequest) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


F - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

F

FACE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
FAIL - 类 com.trs.wcag2.Alertion 中的静态变量
fastWriteImageTo(int, OutputStream) - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
将给定的验证码的图像数据输出到给定的输出流，较之writeImageTo速度更快， 但是消耗内存较多。
FATAL - 类 com.trs.infra.support.log.LogType 中的静态变量
日志类型:致命
FIELD_NAME_TABLE - 类 com.trs.components.metadata.definition.MetaDBTable 中的静态变量
对象的字段名称：表名
FIELD_ROOTELEMENT - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量
XML文档的根节点的元素名称字段的字段名
FIELD_TYPE_APPENDIX - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
附件类型变量
FIELD_TYPE_APPENDIX - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_CHECKBOX - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
多选类型变量
FIELD_TYPE_CHECKBOX - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_CLASS - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
分类法类型变量
FIELD_TYPE_CLASS - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_ENUMVALUE - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
枚举类型变量
FIELD_TYPE_ENUMVALUE - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_HTML - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
复杂编辑器类型变量
FIELD_TYPE_HTML - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_HTML_CHAR - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
编辑器类型变量
FIELD_TYPE_HTML_CHAR - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_INPUT_SELECT - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
可输入下拉类型变量
FIELD_TYPE_INPUT_SELECT - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_INT - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
整数类型变量
FIELD_TYPE_MULTITEXT - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
多行文本类型变量
FIELD_TYPE_MULTITEXT - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_NORMALTEXT - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
普通文本类型变量
FIELD_TYPE_NORMALTEXT - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_PASSWORD - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
密码类型变量
FIELD_TYPE_PASSWORD - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_RADIO - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
单选类型变量
FIELD_TYPE_RADIO - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_RELDOC - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
相关文档类型变量
FIELD_TYPE_RELDOC - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_SELCHANNEL - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
栏目选择类型变量
FIELD_TYPE_SELECT - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
下拉选择类型变量
FIELD_TYPE_SELECT - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_SELFDEFINE - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
自定义类型变量
FIELD_TYPE_SELFDEFINE - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_SUGGESTION - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
suggestion类型变量
FIELD_TYPE_SUGGESTION - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_TIMESTAMP - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
日期类型变量
FIELD_TYPE_TIMESTAMP - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELD_TYPE_TRUEORFALSE - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
是否类型变量
FIELD_TYPE_TRUEORFALSE - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FieldInfo - com.trs.infra.util.database 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class FieldInfo —— 数据库字段信息对象 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FieldInfo(DBType, String, int, boolean, int, String, int) - 类 com.trs.infra.util.database.FieldInfo 的构造方法
构造函数
FIELDNAME_CHANNEL_ID - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量
FIELDNAME_CHANNEL_ID - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELDNAME_INFOVIEW_ID - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量
FIELDNAME_INFOVIEWDATA_ID - 类 com.trs.components.infoview.InfoViewConstants 中的静态变量
FIELDNAME_METADATA_ID - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
FIELDS_DEFAULT_LIST - 类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 中的静态变量
FIELDS_MAP - 类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 中的静态变量
FieldsTemplateSetting - com.trs.template.domain.setting 中的 类
FieldsTemplateSetting() - 类 com.trs.template.domain.setting.FieldsTemplateSetting 的构造方法
FieldTemplate - com.trs.components.metadata.web 中的 类
FieldTemplate() - 类 com.trs.components.metadata.web.FieldTemplate 的构造方法
FieldTemplateFactory - com.trs.components.metadata.web.impl 中的 类
FieldTemplateFactory() - 类 com.trs.components.metadata.web.impl.FieldTemplateFactory 的构造方法
FieldValueCreatorConfigStartServer - com.trs.components.metadata.center 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
值产生器配置信息读取服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FieldValueCreatorConfigStartServer() - 类 com.trs.components.metadata.center.FieldValueCreatorConfigStartServer 的构造方法
FieldValueCreatorFactory - com.trs.components.metadata.center 中的 类
FieldValueCreatorFactory() - 类 com.trs.components.metadata.center.FieldValueCreatorFactory 的构造方法
FIEXED_PARAMETERS - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态变量
FILE_ENCODING - 类 com.trs.infra.common.ContextParameters 中的静态变量
预留索引
文件编码检测使用.
FILE_VIEW_CONFIG - 类 com.trs.presentation.common.PageViewConstants 中的静态变量
FILE_WRITING_ENCODING - 类 com.trs.infra.util.CMyString 中的静态变量
FileConfig - com.trs.infra.config 中的 类
FileConfig(String, String) - 类 com.trs.infra.config.FileConfig 的构造方法
FileDistributeQueue - com.trs.components.common.publish.domain.distribute 中的 类
TODO javadoc for com.trs.components.common.publish.domain.distribute.FileDistributeQueue
FileDistributeQueue(int) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue 的构造方法
缺省构造方法
FileDistributeQueue(String) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue 的构造方法
缺省构造方法
FileDistributeQueue.Item - com.trs.components.common.publish.domain.distribute 中的 类
描述一个待分发的文件,及分发类型
FileDistributeQueue.Item() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 的构造方法
缺省构造方法
FileDistributeShip - com.trs.components.common.publish.domain.distribute 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
file distribute ship
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FileDistributeShip() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 的构造方法
constructor: default
FileDistributeShip(PublishPathCompass) - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 的构造方法
constructor
FileDistributorFtpCacheMgr - com.trs.components.common.publish.domain.distribute 中的 类
已过时。 使用 UftpConnectionCacheManager 代替 Title: TRS 内容协作平台（TRS WCM）
Description:
ftp cache manager for file distribution.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FileDistributorFtpCacheMgr() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 的构造方法
已过时。 constructor: defafult
FileDistributorFtpImpl - com.trs.components.common.publish.domain.distribute 中的 类
已过时。 使用 FileDistributorImpFtpByTRS 代替 Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor implementation on ftp
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FileDistributorFtpImpl() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 的构造方法
已过时。 constructor: default
FileDistributorImpFileLocal - com.trs.components.common.publish.domain.distribute 中的 类
IFileDistristributor的一个实现，使用本地文件系统进行分发。
FileDistributorImpFileLocal() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 的构造方法
缺省构造方法
FileDistributorImpFtpByTRS - com.trs.components.common.publish.domain.distribute 中的 类
IFileDistristributor的一个实现，使用FTP或者类似FTP的协议进行远程分发。
FileDistributorImpFtpByTRS() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 的构造方法
缺省构造方法
FileDistributorImpUnion - com.trs.components.common.publish.domain.distribute 中的 类
分发点的聚合,以简化分发的客户端代码,并在分发点的配置发生变化时,实现实时地响应
FileDistributorLocalImpl - com.trs.components.common.publish.domain.distribute 中的 类
已过时。 使用 FileDistributorImpFileLocal 代替,其实只是启用了新的名称,并没有实质性变化 Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor implementation on local disk.
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FileDistributorLocalImpl() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 的构造方法
已过时。 constructor: default
fileExists(String) - 类 com.trs.infra.support.file.FilesMan 中的方法
根据FilesMan的规则，判断文件对应的实际文件物理是否存在
不抛出异常，只返回true/false
fileExists(String) - 类 com.trs.infra.util.CMyFile 中的静态方法
检查指定文件是否存在
FileMsgProcessor - com.trs.cluster 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文件更改集群消息处理工具类:没有在ClusterMsgCenterImpl处理是为了调用方便
一般地,修改文件后需要重启应用.
FileMsgProcessor() - 类 com.trs.cluster.FileMsgProcessor 的构造方法
filename - 类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 中的变量
FILENAME_APP_PROPERTIES - 类 com.trs.infra.config.TRSConfigServer 中的静态变量
FILENAME_CONFIG - 类 com.trs.wcm.photo.ImageLibConstants 中的静态变量
图片库配置文件名
FILENAME_DATE_LENGTH - 类 com.trs.infra.support.file.FilesMan 中的静态变量
日期长度
FILENAME_FLAG_LENGTH - 类 com.trs.infra.support.file.FilesMan 中的静态变量
目录标识长度
FILENAME_MIN_LENGTH - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件名称最小值
FILENAME_RANDOM_LENGTH - 类 com.trs.infra.support.file.FilesMan 中的静态变量
随机数长度
FILENAME_TIME_LENGTH - 类 com.trs.infra.support.file.FilesMan 中的静态变量
时间值长度
FileNamedStyle - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
表征文件的命名规则，采用“三段式” ：前缀 + 标示体 + 附加字段
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FileNamedStyle() - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 的构造方法
constructor: default
FileNamedStyle(String, String, int) - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 的构造方法
FileNameExtFilter - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文档扩展名过滤器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FileNameExtFilter(String) - 类 com.trs.infra.util.FileNameExtFilter 的构造方法
FileNew - com.trs.components.infoview.extract.manifest 中的 类
已过时。 实际并没有使用 /xsf:xDocumentClass/xsf:fileNew/xsf:initialXmlDocument
FileNew() - 类 com.trs.components.infoview.extract.manifest.FileNew 的构造方法
已过时。
FilePathFilter - com.trs.components.wcm.content.domain.intelligence 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FilePathFilter() - 类 com.trs.components.wcm.content.domain.intelligence.FilePathFilter 的构造方法
FileProperty - com.trs.components.infoview.extract.manifest 中的 类
/xsf:xDocumentClass/xsf:package/xsf:files/xsf:file/xsf:fileProperties/xsf:property
FileProperty() - 类 com.trs.components.infoview.extract.manifest.FileProperty 的构造方法
FileService - com.trs.components.wcm.soap 中的 类
FileService() - 类 com.trs.components.wcm.soap.FileService 的构造方法
FilesMan - com.trs.infra.support.file 中的 类
fileToElement(String) - 类 com.trs.infra.util.CMyXMLParser 中的静态方法
fileToElement(String, Class) - 类 com.trs.infra.util.CMyXMLParser 中的静态方法
FileType - com.trs.components.wcm.resource 中的 类
FileType() - 类 com.trs.components.wcm.resource.FileType 的构造方法
FileTypes - com.trs.components.wcm.resource 中的 类
FileTypes(User) - 类 com.trs.components.wcm.resource.FileTypes 的构造方法
FileTypes(User, int, int) - 类 com.trs.components.wcm.resource.FileTypes 的构造方法
FileUploader - com.trs.webframework.controler.servlet 中的 类
FileUploader() - 类 com.trs.webframework.controler.servlet.FileUploader 的构造方法
FileWithdrawMsgReceiver - com.trs.cluster.receiver 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
文件撤除消息处理
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FileWithdrawMsgReceiver() - 类 com.trs.cluster.receiver.FileWithdrawMsgReceiver 的构造方法
fill() - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的方法
fill(int) - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的方法
filter(IStatResultFilter) - 接口 com.trs.components.stat.IStatResult 中的方法
使用过滤规则resultFilter对结果集进行过滤，返回过滤之后的新的结果集
filter(IStatResultsFilter) - 接口 com.trs.components.stat.IStatResults 中的方法
使用过滤规则resultFilter对结果集集合进行过滤，返回过滤之后的新的结果集集合
filter(IStatResultFilter) - 类 com.trs.components.stat.StatResult 中的方法
filter(IStatResultsFilter) - 类 com.trs.components.stat.StatResults 中的方法
filter(WCMFilter) - 类 com.trs.infra.persistent.BaseObjs 中的方法
使用指定的过滤器筛选子集
FILTER_TYPE_1MONTH - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_1WEEK - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_3DAYS - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_ALL - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_DETAIL_TEMPLATE - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_EDITEDDOCUMENTS - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_NESTED_TEMPLATE - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_NEWDOCUMENTS - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_NODOCUMENTS - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_OUTLINE_TEMPLATE - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_PUBLISHDOCUMENTS - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_PUBLISHEDDOCUMENTS - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_SELF - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_UNUSE_TEMPLATE - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
FILTER_TYPE_USEING_TEMPLATE - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量
filterByFlow(InfoViewViews, int) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
通过工作流过滤可查看的表单视图
filterChannels(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
通过检索条件查找匹配的栏目 add by liuyou@2008-2-14 下午02:03:43
filterContentInFlow(InfoView, String, int) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
在工作流转中过滤文档中的不可读字段
filterContentInFlow(InfoView, String, int) - 接口 com.trs.service.IInfoViewService 中的方法
filterContentInFlow(InfoView, String, int) - 类 com.trs.service.impl.InfoViewService 中的方法
FILTERED - 类 com.trs.infra.util.jazzlib.Deflater 中的静态变量
This strategy will only allow longer string repetitions.
filterForHTMLValue(String) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的静态方法
HTML元素value值过滤处理函数：将 & < >\ 等特殊字符作转化处理
filterForHTMLValue(String) - 类 com.trs.infra.util.CMyString 中的静态方法
HTML元素value值过滤处理函数：将 & < >\ 等特殊字符作转化处理
filterForJava(String) - 类 com.trs.infra.util.CMyString 中的静态方法
可能有置标内容输出到java代码中作为参数。
filterForJDOM(String) - 类 com.trs.infra.util.CMyString 中的静态方法
过滤掉XML不接受的字符
filterForJs(String) - 类 com.trs.infra.util.CMyString 中的静态方法
JavaScript过滤处理函数：将指定文本中的 " \ \r \n 等特殊字符做转化处理
filterForSQL(String) - 类 com.trs.infra.util.CMyString 中的静态方法
SQL语句特殊字符过滤处理函数 用于：构造SQL语句时，填充字符串参数时使用 如： String strSQL = "select * from tbName where Name='"+CMyString.filterForSQL("a'bc")+"'" 说明：需要处理的特殊字符及对应转化规则：如： ' --->'' 不允许使用的特殊字符： !
filterForSQL2(String) - 类 com.trs.infra.util.CMyString 中的静态方法

filterForUrl(String) - 类 com.trs.infra.util.CMyString 中的静态方法
URL过滤处理函数：将 # & 等特殊字符作转化处理
filterForXML(String) - 类 com.trs.infra.util.CMyString 中的静态方法
XML文本过滤处理函数：将 & < >\ 等特殊字符做转化处理
filterForXsltValue(String) - 类 com.trs.infra.util.CMyString 中的静态方法

FILTERS_DOCUMENTS_DEFAULT - 类 com.trs.ajaxservice.ServiceConstants 中的静态变量

filtToElement(String, Class, String) - 类 com.trs.infra.util.CMyXMLParser 中的静态方法

finalize() - 类 com.trs.infra.config.FileConfig 中的方法

find(User, int) - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法

find(TagItem) - 类 com.trs.components.wcm.publish.tagparser.RollDocumentsChannelsFinder 中的方法

find(int) - 接口 com.trs.infra.support.log.ILogMgr 中的方法

find(String) - 接口 com.trs.infra.support.log.ILogMgr 中的方法

find(int) - 类 com.trs.infra.support.log.LogMgr 中的方法

find(String) - 类 com.trs.infra.support.log.LogMgr 中的方法

findAdministrators() - 类 com.trs.cms.auth.persistent.Users 中的静态方法

findAndSubst(String, Properties) - 类 com.trs.infra.util.OptionConverter 中的静态方法
Find the value corresponding to key in props.
findAppendixesByObj(BaseObj) - 类 com.trs.components.wcm.content.persistent.Appendixes 中的静态方法
获得文档所属附件集合
该接口应该是获得对象所属附件集合，由于Appendix对象目前只和Document对象耦合，所以先暂时这样使用
以后扩展应该也比较方便，增加一个对象类型ID即可
findArrayParameters(String, String) - 类 com.trs.webframework.controler.PostDataParser 中的方法
获取指定服务的参数(返回所有匹配的)
findBy(int, int, int, int) - 类 com.trs.cms.auth.persistent.Right 中的静态方法

findBy(InfoView) - 类 com.trs.components.infoview.persistent.InfoViewFields 中的静态方法

findBy(InfoView) - 类 com.trs.components.infoview.persistent.InfoViewGroups 中的静态方法

findBy(InfoView) - 类 com.trs.components.infoview.persistent.InfoViewViews 中的静态方法

findByChannelId(int) - 类 com.trs.components.metadata.center.MetaViewEmployer 中的静态方法

findByChannelId(int, int) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态方法
获取指定栏目指定位置的Region
findByChannelId(int, String) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态方法
获取指定栏目指定名称的Region
findByChannelId(int) - 类 com.trs.components.wcm.publish.region.RegionInfos 中的静态方法
查询指定栏目的导读
findByChannelId(int, WCMFilter) - 类 com.trs.components.wcm.publish.region.RegionInfos 中的静态方法

findByClassName(String) - 类 com.trs.components.common.job.JobWorkerType 中的静态方法

findByCssFlagAndPageStyle(String, PageStyle) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 内容风格集合
findByCssFlagAndPageStyle(User, String, int) - 类 com.trs.components.common.publish.widget.ContentStyles 中的静态方法
根据指定的风格标识和页面风格来获取内容风格
findByCssFlagAndPageStyle(String, PageStyle) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
根据 风格标识(_sCssFlag) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 标识为_sCssFlag的 资源风格集合
findByCssFlagAndPageStyle(User, String, int) - 类 com.trs.components.common.publish.widget.ResourceStyles 中的静态方法
根据指定的风格标识和页面风格来获取资源风格
findByDocAndChnl(Document, Channel) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态方法
根据文档和频道，找到对应的ChnlDoc
findByDocAndChnl(int, int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态方法

findByDocIds(User, int, String) - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的静态方法

findByDocument(Document) - 类 com.trs.components.infoview.persistent.InfoViewData 中的静态方法

findByDocument(Document, String, String, String) - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的静态方法

findByDocument(Document) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态方法
根据文档，找到对应的ChnlDoc，只找实体文档本身对应的频道
findById(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.DistributeServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.DocumentSynServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.GroupServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.IndividuationServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.InfoViewDocumentServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.ReplaceContentServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.SourceServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.StatusServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceHelperProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.WatermarkServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法

findById(int) - 类 com.trs.cms.auth.persistent.Group 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.auth.persistent.GroupRole 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.auth.persistent.GroupUser 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.auth.persistent.ObjectMember 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.auth.persistent.Right 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.auth.persistent.RightDef 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.auth.persistent.Role 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.auth.persistent.RoleUser 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.auth.persistent.User 中的静态方法
提取指定ID的对象
findById(int, String, String) - 类 com.trs.cms.content.DefaultObj 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.content.ExtendedField 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.definition.Flow 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.definition.FlowAction 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.definition.FlowCondition 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.definition.FlowdocLog 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.definition.FlowEmploy 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.definition.FlowNode 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.definition.FlowNodeField 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.definition.FlowRule 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.engine.FlowContentConfig 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.cms.process.engine.FlowDoc 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.comment.persistent.DocumentTopic 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.address.Contact 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.address.ContactGrp 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.bookmark.BookMark 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.bookmark.MarkKind 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.calendar.Event 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.calendar.EventShare 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.calendar.EventType 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.job.JobWorkerType 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.job.Schedule 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.message.Message 中的静态方法
提取指定ID的对象
findById(User, int) - 类 com.trs.components.common.message.MessageServer 中的静态方法

findById(int) - 类 com.trs.components.common.message.MsgQueue 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.message.MsgReceiver 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.template.TagBean 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.template.Template 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.widget.ContentStyle 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法

findById(MethodContext) - 接口 com.trs.components.common.publish.widget.ILayoutServiceProvider 中的方法

findById(int) - 类 com.trs.components.common.publish.widget.Layout 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.common.publish.widget.LayoutServiceProvider 中的方法
获取某个布局
findById(int) - 类 com.trs.components.common.publish.widget.Master 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
获取指定Id的母板
findById(int) - 类 com.trs.components.common.publish.widget.PageStyle 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法

findById(int) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法

findById(int) - 类 com.trs.components.common.publish.widget.StyleAndResource 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.widget.StyleItem 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法

findById(int) - 类 com.trs.components.common.publish.widget.Widget 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.widget.WidgetInstance 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 中的方法
暂时没有用到，没有实现
findById(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 中的方法
暂时没有用到，没有实现
findById(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.infoview.persistent.InfoView 中的静态方法
提取指定ID的对象
findById(InfoView, int) - 类 com.trs.components.infoview.persistent.InfoViewData 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.infoview.persistent.InfoViewData 中的静态方法

findById(BaseChannel, int, String, String, int, String) - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的静态方法
获取指定Id的ViewDocument
findById(int) - 类 com.trs.components.infoview.persistent.InfoViewField 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.infoview.persistent.InfoViewView 中的静态方法
返回指定ID的表单视图对象
findById(int) - 类 com.trs.components.metadata.center.ClassInfoView 中的静态方法
提取指定ID的对象
findById(String, int) - 类 com.trs.components.metadata.center.MetaViewData 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.metadata.center.MetaViewData 中的静态方法

findById(int) - 类 com.trs.components.metadata.definition.ClassInfo 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.metadata.definition.MetaDBField 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.metadata.definition.MetaDBTable 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.metadata.definition.MetaView 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.metadata.definition.MetaViewField 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法

findById(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法

findById(int) - 类 com.trs.components.special.Special 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法

findById(int) - 类 com.trs.components.stat.BonusRule 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.stat.BonusRuleServiceProvider 中的方法

findById(int) - 类 com.trs.components.stat.ChnlDept 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.stat.DocumentHitsCount 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.stat.HostObjDomain 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.stat.HostObjHitsCount 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.stat.UserLoginInfo 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.stat.UserLoginInfoServiceProvider 中的方法

findById(int) - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.Channel 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.ContentLink 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.DocBak 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.DocReply 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法
提取指定ID的对象
findById(int, String) - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法

findById(int, String, String) - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法

findById(int) - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.Relation 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.Replace 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.SiteMember 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态方法
提取指定ID的对象
findById(BaseChannel, int, String, String) - 类 com.trs.components.wcm.content.ViewDocument 中的静态方法
获取指定Id的ViewDocument
findById(int) - 类 com.trs.components.wcm.customize.UserSetting 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.individuation.Individuation 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.publish.logo.Logo 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.publish.region.CellInfo 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.wcm.publish.region.CellServiceProvider 中的方法

findById(int) - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionEmployServiceProvider 中的方法

findById(int) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionServiceProvider 中的方法

findById(int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.recent.Recent 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.resource.DocKind 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.resource.FileType 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.resource.Keyword 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.resource.Security 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.resource.Source 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.resource.Status 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.stat.StatFieldMap 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.stat.StatHost 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.stat.StatView 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.stat.StatViewRel 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的静态方法
提取指定ID的对象
findById(User, int, String) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.db.update.DBUpdateLog 中的静态方法
提取指定ID的对象
findById(int, int) - 类 com.trs.infra.persistent.BaseObj 中的静态方法

findById(Class, int) - 类 com.trs.infra.persistent.BaseObj 中的静态方法

findById(int) - 类 com.trs.infra.support.config.Config 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.infra.support.log.Log 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.infra.support.log.LogBak 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.infra.support.log.LogType 中的静态方法
根据ID获取日志类型
findById(int) - 类 com.trs.infra.support.log.OperType 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.infra.support.security.SecureKey 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.infra.util.job.JobFailedResult 中的静态方法
提取指定ID的对象
findById(int) - 接口 com.trs.service.IInfoViewService 中的方法
在指定的站点下查找指定ID的自定义表单
findById(int) - 类 com.trs.service.impl.InfoViewService 中的方法

findById(int) - 类 com.trs.wcm.config.PageOperator 中的静态方法
提取指定ID的对象
findById(int) - 类 com.trs.wcm.photo.ImageKind 中的静态方法

findById(int) - 类 com.trs.wcm.photo.Watermark 中的静态方法
提取指定ID的对象
findById(MethodContext) - 类 com.trs.webframework.demo.StdDemoProviderImpl 中的方法

findById(MethodContext) - 类 com.trs.webframework.provider.BaseServiceDecorator 中的方法

findById(MethodContext) - 接口 com.trs.webframework.provider.IFindByIdServiceProvider 中的方法

FINDBYID - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量

findById2(int, int) - 类 com.trs.components.infoview.persistent.InfoViewData 中的静态方法

findByIdentity(String, String) - 类 com.trs.components.metadata.definition.MetaView 中的静态方法
根据唯一标识属性，获取第一个视图对象，由于视图名称和视图描述是唯一的，所以一般情况下可以作为sIdentityName
findByIds(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.DistributeServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.DocumentBakServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.DocumentSynServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.GroupServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.IndividuationServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.ObjectMemberServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.ReplaceContentServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.SourceServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.StatusServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceHelperProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.WatermarkServiceProvider 中的方法

findByIds(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.cms.auth.persistent.GroupRoles 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.auth.persistent.Groups 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.auth.persistent.GroupUsers 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.auth.persistent.ObjectMembers 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.auth.persistent.RightDefs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.auth.persistent.Rights 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.auth.persistent.Roles 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.auth.persistent.RoleUsers 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.auth.persistent.Users 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String, String, String) - 类 com.trs.cms.content.DefaultObjs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.content.ExtendedFields 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.FlowActions 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.FlowConditions 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.FlowdocLogs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.FlowEmploys 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.FlowNodeBranchs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.FlowNodeFields 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.FlowNodes 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.FlowRules 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.definition.Flows 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.engine.FlowContentConfigs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.cms.process.engine.FlowDocs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.comment.persistent.DocumentTopics 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.comment.persistent.TopicedDocRelations 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.address.ContactGrps 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.address.Contacts 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.bookmark.BookMarks 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.bookmark.MarkKinds 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.bookmark.MarkShares 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.calendar.Events 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.calendar.EventShares 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.conjection.persistent.EntryConfigs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.job.JobWorkerTypes 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.job.Schedules 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.message.Messages 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.message.MessageServer 中的静态方法

findByIds(User, String) - 类 com.trs.components.common.message.MsgQueues 中的静态方法
提取指定ID序列的对象集合
findByIds(String) - 类 com.trs.components.common.message.MsgReceivers 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTasks 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.template.TempApdRels 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.template.TempAppendixes 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploys 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.template.TemplateQuotes 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.widget.ContentStyles 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法

findByIds(MethodContext) - 接口 com.trs.components.common.publish.widget.ILayoutServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.common.publish.widget.Layouts 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.common.publish.widget.LayoutServiceProvider 中的方法
获取布局集合
findByIds(User, String) - 类 com.trs.components.common.publish.widget.Masters 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
获取指定的Id序列的母板集合
findByIds(User, String) - 类 com.trs.components.common.publish.widget.PageStyles 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.common.publish.widget.ResourceStyles 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.common.publish.widget.StyleAndResources 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.widget.StyleItems 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.common.publish.widget.VisualTemplateServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.common.publish.widget.WidgetInstances 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.widget.WidgetInstParameters 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.common.publish.widget.WidgetParameters 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetParameterServiceProvider 中的方法
暂时没有用到，没有实现
findByIds(User, String) - 类 com.trs.components.common.publish.widget.Widgets 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 中的方法
暂时没有用到，没有实现
findByIds(User, String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForms 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.gkml.sqgk.persistent.MailConfigs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.infoview.helper.ComplexFieldDatas 中的静态方法
提取指定ID序列的对象集合
findByIds(User, int, String) - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的静态方法

findByIds(User, String) - 类 com.trs.components.infoview.persistent.InfoViewEmploys 中的静态方法

findByIds(User, String) - 类 com.trs.components.infoview.persistent.InfoViewFields 中的静态方法

findByIds(User, String) - 类 com.trs.components.infoview.persistent.InfoViews 中的静态方法
TODO Add javadoc for field findByIds
findByIds(User, String) - 类 com.trs.components.metadata.center.ClassInfoViews 中的静态方法
提取指定ID序列的对象集合
findByIds(String, String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态方法
提取指定ID序列的对象集合
findByIds(MetaView, String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态方法

findByIds(String) - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态方法
返回一个MetaViewData的集合，注意sIds对应得视图必须相同
findByIds(User, String) - 类 com.trs.components.metadata.definition.ClassInfos 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.metadata.definition.MetaDBFields 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.metadata.definition.MetaDBTables 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.metadata.definition.MetaViewFields 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.metadata.definition.MetaViews 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.special.Specials 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.stat.BonusRules 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.stat.BonusRuleServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.stat.ChnlDepts 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.stat.DocumentHitsCounts 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.stat.HostObjDomains 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.stat.HostObjHitsCounts 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.stat.UserLoginInfos 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.stat.UserLoginInfoServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.Appendixes 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.AutoBakConfigs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.ChannelContentLinks 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.Channels 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.ChannelSyns 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.ChnlDocs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.ContentExtFields 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.ContentLinks 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.ContentLinkTypes 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.DocBaks 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.DocReplys 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.Documents 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.DocumentSyns 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.Relations 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.Replaces 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.SiteMembers 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.content.persistent.WebSites 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.customize.UserSettings 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.individuation.Individuations 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.publish.logo.Logos 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.publish.region.CellInfos 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.wcm.publish.region.CellServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.wcm.publish.region.RegionEmploys 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionEmployServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.wcm.publish.region.RegionInfos 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.components.wcm.publish.region.RegionServiceProvider 中的方法

findByIds(User, String) - 类 com.trs.components.wcm.publish.WCMPubStatusConfigs 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.recent.Recents 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.resource.Keywords 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.resource.Securities 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.resource.Sources 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.resource.Statuses 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.stat.StatFieldMaps 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.stat.StatHosts 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.stat.StatViewRels 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.stat.StatViews 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.components.wcm.wcmx.help.WCMHelps 中的静态方法
提取指定ID序列的对象集合
findByIds(String) - 类 com.trs.db.update.DBUpdateLogs 中的静态方法
提取指定ID序列的对象集合
findByIds(String) - 类 com.trs.infra.support.config.Configs 中的静态方法
提取指定ID序列的对象集合
findByIds(String) - 类 com.trs.infra.support.log.LogBaks 中的静态方法
提取指定ID序列的对象集合
findByIds(String) - 类 com.trs.infra.support.log.Logs 中的静态方法
提取指定ID序列的对象集合
findByIds(String) - 类 com.trs.infra.support.log.OperTypes 中的静态方法
提取指定ID序列的对象集合
findByIds(String) - 类 com.trs.infra.support.security.SecureKeys 中的静态方法
提取指定ID序列的对象集合
findByIds(String) - 类 com.trs.infra.util.job.JobFailedResults 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.wcm.config.PageOperators 中的静态方法
提取指定ID序列的对象集合
findByIds(User, String) - 类 com.trs.wcm.photo.Watermarks 中的静态方法
提取指定ID序列的对象集合
findByIds(MethodContext) - 类 com.trs.webframework.demo.StdDemoProviderImpl 中的方法

findByIds(MethodContext) - 类 com.trs.webframework.provider.BaseServiceDecorator 中的方法

findByIds(MethodContext) - 接口 com.trs.webframework.provider.IFindByIdsServiceProvider 中的方法

FINDBYIDS - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态变量

findByIdsOfDealer(User, String, User) - 类 com.trs.cms.process.engine.FlowDocs 中的静态方法
根据处理者或者与其相关的FlowDocs
findByIdsOfPoster(User, String, User) - 类 com.trs.cms.process.engine.FlowDocs 中的静态方法

findByKey(Object) - 类 com.trs.cms.auth.persistent.Group 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.auth.persistent.GroupRole 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.auth.persistent.GroupUser 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.auth.persistent.ObjectMember 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.auth.persistent.Right 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.auth.persistent.RightDef 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.auth.persistent.Role 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.auth.persistent.RoleUser 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.auth.persistent.User 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.content.ExtendedField 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.definition.Flow 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.definition.FlowAction 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.definition.FlowCondition 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.definition.FlowdocLog 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.definition.FlowEmploy 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.definition.FlowNode 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.definition.FlowNodeField 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.definition.FlowRule 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.engine.FlowContentConfig 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.cms.process.engine.FlowDoc 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.comment.persistent.DocumentTopic 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.address.Contact 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.address.ContactGrp 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.bookmark.BookMark 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.bookmark.MarkKind 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.calendar.Event 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.calendar.EventShare 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.calendar.EventType 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.job.JobWorkerType 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.job.Schedule 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.message.Message 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.message.MsgQueue 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.message.MsgReceiver 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.template.TagBean 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.template.Template 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.ContentStyle 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.Layout 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.Master 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.PageStyle 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.StyleAndResource 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.StyleItem 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.Widget 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.WidgetInstance 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.infoview.persistent.InfoViewData 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.metadata.center.ClassInfoView 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.metadata.center.MetaViewData 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.metadata.definition.ClassInfo 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.metadata.definition.MetaDBField 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.metadata.definition.MetaDBTable 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.metadata.definition.MetaView 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.metadata.definition.MetaViewField 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.special.Special 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.stat.BonusRule 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.stat.ChnlDept 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.stat.DocumentHitsCount 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.stat.HostObjDomain 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.stat.HostObjHitsCount 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.stat.UserLoginInfo 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.Channel 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.ContentLink 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.DocBak 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.DocReply 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.Relation 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.Replace 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.SiteMember 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.content.persistent.WebSite 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.customize.UserSetting 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.individuation.Individuation 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.publish.logo.Logo 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.publish.region.CellInfo 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.recent.Recent 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.resource.DocKind 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.resource.FileType 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.resource.Keyword 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.resource.Security 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.resource.Source 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.resource.Status 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.stat.StatFieldMap 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.stat.StatHost 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.stat.StatView 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.stat.StatViewRel 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.db.update.DBUpdateLog 中的静态方法
提取指定缓冲区Key的对象
findByKey(Class, Object) - 类 com.trs.infra.persistent.BaseObj 中的静态方法

findByKey(Object) - 类 com.trs.infra.support.config.Config 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.infra.support.log.Log 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.infra.support.log.LogBak 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.infra.support.log.OperType 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.infra.support.security.SecureKey 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.infra.util.job.JobFailedResult 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.wcm.config.PageOperator 中的静态方法
提取指定缓冲区Key的对象
findByKey(Object) - 类 com.trs.wcm.photo.Watermark 中的静态方法
提取指定缓冲区Key的对象
findByMemberObj(int, int, int, int) - 类 com.trs.cms.auth.persistent.ObjectMember 中的静态方法

findByName(String) - 类 com.trs.cms.auth.persistent.User 中的静态方法

findByName(int, String) - 类 com.trs.cms.process.definition.FlowNode 中的静态方法

findByName(String) - 类 com.trs.components.common.publish.persistent.template.Templates 中的方法
根据模板名称从模板集合中查找模板
findByName(String) - 类 com.trs.components.common.publish.widget.PageStyle 中的静态方法
获取指定名称的风格
findByName(String, int) - 类 com.trs.components.infoview.persistent.InfoViewFields 中的静态方法

findByName(String, int) - 类 com.trs.components.infoview.persistent.InfoViewGroups 中的静态方法

findByName(String) - 类 com.trs.components.metadata.definition.ClassInfo 中的静态方法
根据名称获取分类
findByName(int, String) - 类 com.trs.components.wcm.content.persistent.Channel 中的静态方法

findByName(int, String) - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
提取指定站点、指定名称的频道
findByName(int, String) - 接口 com.trs.components.wcm.content.persistent.IChannelNameMgr 中的方法
提取指定站点、指定名称的频道
findByName(String) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态方法
获取指定名称的Region
findByName(String) - 类 com.trs.infra.support.security.SecureKey 中的静态方法

findByName(int, String) - 类 com.trs.service.impl.TemplateService 中的方法

findByName(int, String) - 接口 com.trs.service.ITemplateService 中的方法
根据指定的SiteId，找到指定名称的模板
findBySender(int, BaseObj) - 类 com.trs.components.common.job.Schedule 中的静态方法
获取在指定对象上定义的指定类型的调度（Schedule）
findBySiteId(int, int) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态方法
获取指定站点指定位置的Region
findBySiteId(int, String) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的静态方法
获取指定站点指定名称的Region
findBySiteId(int, WCMFilter) - 类 com.trs.components.wcm.publish.region.RegionInfos 中的静态方法

findByStyleNameAndPageStyle(String, PageStyle) - 类 com.trs.components.common.publish.widget.ContentStyleMgr 中的方法
根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 内容风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 内容风格集合
findByStyleNameAndPageStyle(User, String, int) - 类 com.trs.components.common.publish.widget.ContentStyles 中的静态方法
根据指定的风格名称和页面风格来获取内容风格
findByStyleNameAndPageStyle(String, PageStyle) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
根据 风格名称(_sStyleName) 获取 特定 页面风格(_oPageStyle) 下的 资源风格集合； _oPageStyle 为空的话，表示获取 系统中 所有 名称为_sStyleName的 资源风格集合
findByUrl(User, String) - 类 com.trs.components.wcm.wcmx.help.WCMHelps 中的静态方法
提取指定ID序列的对象集合
findByUserAndSrc(User, int, int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的静态方法
提取指定ID的对象
findCellInfos(RegionInfo, WCMFilter) - 类 com.trs.components.wcm.publish.region.CellInfos 中的静态方法
获取指定区域中所有的单元格，默认按照行、列排序
findCellInfos(RegionInfo, WCMFilter, User) - 类 com.trs.components.wcm.publish.region.CellInfos 中的静态方法
获取指定区域中所有的单元格，默认按照行、列排序.
findChnlDoc(Document, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
根据文档和频道，找到对应的ChnlDoc
findChnldoc(int, int) - 接口 com.trs.service.IDocumentService 中的方法
根据频道和文档，找到对应的ChnlDoc
findChnldoc(int, int) - 类 com.trs.service.impl.DocumentService 中的方法

findChnlDocId(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
根据docid，channelid获取chnldocid
findClassInfoByName(String) - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法
根据分类法名称获取分类法
findClassInfoByName(String) - 接口 com.trs.components.metadata.definition.IClassInfoCacheMgr 中的方法

findConfigServerById(String) - 类 com.trs.infra.config.TRSConfigServer 中的静态方法

findContentTypeConfig(int) - 类 com.trs.cms.process.config.FlowConfigServer 中的方法
根据类型获取指定的内容配置信息
findCssFlagUsedInfo(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
校验CssFlag是否可用。
findCssFlagUsedInfo(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
校验CssFlag已经被使用的信息
findCssFlagUsedStyles(PageStyle, BaseStyle, String) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。
findCssFlagUsedStyles(PageStyle, BaseStyle, String) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
当前页面风格(_oPageStyle)下,除自己以外，标识为_sCssFlag的资源风格以及内容风格。
findCurrDocIdBySNO(MethodContext) - 接口 com.trs.components.infoview.mad.InfoViewQueryHelper 中的方法

findCurrDocIdBySNO(MethodContext) - 类 com.trs.components.infoview.mad.InfoViewQueryHelperImpl 中的方法

findDataType(String, String) - 类 com.trs.components.infoview.extract.DataType 中的方法

findDBFieldInfoById(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
根据ID获取元数据对象
findDBTableInfoById(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
根据ID获取元数据结构对象
findDBTableInfosByIds(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
根据ID序列获取元数据集合
findDefaultBy(InfoView) - 类 com.trs.components.infoview.persistent.InfoViewViews 中的静态方法

findDocBaks(Document) - 类 com.trs.components.wcm.content.domain.DocBakMgr 中的方法
取文档的备份集合
findDocBaks(Document, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocBakMgr 中的方法
取当前文档的备份集合
findDocumentHost(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 中的静态方法

findFlowNodeByName(int, String) - 类 com.trs.cms.process.definition.FlowCacheMgr 中的方法

findFlowNodeByName(int, String) - 接口 com.trs.cms.process.IFlowCacheMgr 中的方法

findFolderConfig(BaseChannel) - 类 com.trs.service.impl.WCMPublishElementServiceImpl 中的方法

findFolderConfig(BaseChannel) - 接口 com.trs.service.IWCMPublishElementService 中的方法
获取当前站点或频道的发布配置信息
findFolderHost(TagItem, PublishTagContext, boolean) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 中的静态方法
Returns the current host as a channel.
findFolderHost(TagItem, PublishTagContext, boolean, boolean) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 中的静态方法

findFolderHostByOldModal(TagItem, PublishTagContext, boolean) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 中的静态方法

findHost(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannelLogo 中的方法

findHost(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocumentLogo 中的方法

findHost(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserLogoBase 中的方法

findItems(String) - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 中的方法

findItems(String[]) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
从子节点(TagItem)开始往下找指定名称的节点 如果没有指定名称,则应该返回所有子孙节点
findKey(int) - 类 com.trs.service.impl.SecurityService 中的方法

findKey(String) - 类 com.trs.service.impl.SecurityService 中的方法

findKey(int) - 接口 com.trs.service.ISecurityService 中的方法
在系统内查找指定ID的密钥
findKey(String) - 接口 com.trs.service.ISecurityService 中的方法
在系统内查找指定名称的密钥
findLayoutByName(User, String) - 接口 com.trs.components.common.publish.widget.ILayoutMgr 中的方法
根据传入的布局名称，返回找到的第一个布局对象，如果没有找到合适的布局对象，则返回null。
findLayoutByName(User, String) - 类 com.trs.components.common.publish.widget.LayoutMgr 中的方法

findLockedObj(int, int) - 类 com.trs.presentation.util.CmsObjUnlockTools 中的静态方法

findMetaViewOfChildGovInfo(User) - 类 com.trs.components.govinfo.GovInfoViewFinder 中的静态方法

findMetaViewOfGovInfo(User) - 类 com.trs.components.govinfo.GovInfoViewFinder 中的静态方法

findMethodByName(String) - 类 com.trs.webframework.config.ServiceConfig 中的方法

findMethodConfig(String, String) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法

findMethodName(int) - 类 com.trs.webframework.controler.PostDataParser 中的方法
获取指定顺序的服务方法名
findNestedTemplate(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Returns the template defined in the specified nested template tag item.
findNestedTemplate(TagItem, IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
已过时。 Returns the template defined in the specified nested template tag item.
findNestedTemplate(String, IPublishFolder) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Returns the template defined in the specified nested template tag item.
findNextElement(String) - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法
找到下一个指定名称的元素
findNextElement(String, boolean, String) - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法
找到下一个指定名称的元素
findNextElement(String, boolean) - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法

findNodesByPath(MethodContext) - 类 com.trs.ajaxservice.SystemServiceProvider 中的方法
根据用户输入的路径获取节点列表，路径以\分隔
findObjectClassByType(int) - 类 com.trs.infra.persistent.ObjectTypesFinder 中的静态方法

findOf(User, FlowNode) - 类 com.trs.cms.process.definition.FlowNodeFields 中的静态方法

findOf(User, CMSObj) - 类 com.trs.cms.process.definition.FlowRules 中的静态方法
根据Host获取相关的规则
findOf(User, int, int) - 类 com.trs.cms.process.definition.FlowRules 中的静态方法
根据Host获取相关的规则
findOf(int, int) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的静态方法
根据Folder的类型和Id获取配置信息
findOf(IPublishFolder) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的静态方法
find the publish config of the specified folder
findOf(String, String) - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的静态方法

findOf(IPublishElement) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的静态方法
提取指定ID序列的对象集合
findOf(int, int) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的静态方法
提取指定ID序列的对象集合
findOf(User, int, int) - 类 com.trs.components.wcm.customize.UserSetting 中的静态方法
获取指定类型指定ID的个性化配置
findOf(User, int, WCMFilter) - 类 com.trs.components.wcm.customize.UserSettings 中的静态方法

findOf(int, int, int) - 类 com.trs.components.wcm.publish.logo.Logo 中的静态方法
获取指定对象的指定Logo
findOf(User, int, int, WCMFilter) - 类 com.trs.components.wcm.publish.logo.Logos 中的静态方法
获取指定对象的指定Logo集合
findOf(int, int) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的静态方法
获取站点或频道的发布配置信息
findOf(int, int) - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的静态方法

findOfContent(User, int, int, WCMFilter) - 类 com.trs.cms.process.engine.FlowDocs 中的静态方法
获取与指定内容相关的轨迹
findParameter(WidgetInstParameter) - 接口 com.trs.components.common.publish.widget.IWidgetParameterMgr 中的方法
根据资源变量实例获取到资源变量
findParameter(WidgetInstParameter) - 类 com.trs.components.common.publish.widget.WidgetParameterMgr 中的方法

findParameterByName(Widget, String) - 接口 com.trs.components.common.publish.widget.IWidgetParameterMgr 中的方法
获取指定资源下，指定名称的资源变量
findParameterByName(Widget, String) - 类 com.trs.components.common.publish.widget.WidgetParameterMgr 中的方法

findParameters(String, String) - 类 com.trs.webframework.controler.PostDataParser 中的方法
获取指定服务的参数(返回第一个匹配的)
findParameters(int) - 类 com.trs.webframework.controler.PostDataParser 中的方法

findParent(CMSObj) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
根据当前对象，获取当前对象的父对象
findParentItems() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
获取祖先tagitems列表 从父元素开始回溯,直到第一个父元素结束
findPublishDistributions(WebSite, boolean, WCMFilter) - 类 com.trs.service.impl.WCMPublishElementServiceImpl 中的方法

findPublishDistributions(WebSite, boolean, WCMFilter) - 接口 com.trs.service.IWCMPublishElementService 中的方法
获取当前站点所设置的分发目录集合
findPublishSchedule(BaseChannel) - 类 com.trs.service.impl.ScheduleService 中的方法

findPublishSchedule(Document) - 类 com.trs.service.impl.ScheduleService 中的方法

findPublishSchedule(BaseChannel) - 接口 com.trs.service.IScheduleService 中的方法
获取指定站点或频道的计划发布信息
findPublishSchedule(Document) - 接口 com.trs.service.IScheduleService 中的方法
获取指定文档的计划发布信息
findRegionEmployByInfo(int, int, int) - 类 com.trs.components.wcm.publish.region.RegionEmployMgr 中的方法
根据当前参数唯一返回一条记录信息
findRelationsByObj(BaseObj) - 类 com.trs.components.wcm.content.persistent.Relations 中的静态方法
获得文档所属关联文档集合
该接口应该是获得对象所属关联对象集合，由于Relation对象目前只表示Document的关联关系，所以先暂时这样使用
以后扩展应该也比较方便，增加一个对象类型ID即可
findRoleByName(String) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
根据角色名称，获取到第一个匹配的角色，优先获取id值更大的角色
findRootClassInfos() - 类 com.trs.components.metadata.definition.ClassInfo 中的静态方法
获取所有根节点
findRootClassInfos(boolean) - 类 com.trs.components.metadata.definition.ClassInfo 中的静态方法

findSameCssFlagStyles(String) - 类 com.trs.components.common.publish.widget.ContentStyles 中的静态方法
根据指定的风格标识来获取内容风格集合
findSameCssFlagStyles(String) - 类 com.trs.components.common.publish.widget.ResourceStyles 中的静态方法
根据指定的风格标识来获取资源风格集合
findSameNameStyles(String) - 类 com.trs.components.common.publish.widget.ContentStyles 中的静态方法
根据指定的风格名称来获取资源风格集合
findSameNameStyles(String) - 类 com.trs.components.common.publish.widget.ResourceStyles 中的静态方法
根据指定的风格名称来获取资源风格集合
findSchedule(JobWorkerType, CMSObj) - 类 com.trs.components.common.job.JobScheduleServer 中的静态方法

findSchedule(ChnlDoc) - 类 com.trs.components.wcm.content.domain.DocumentPriMgr 中的方法
查找文档置顶计划中，当前ChnlDoc对应的计划发布任务
findSelectField(String) - 类 com.trs.infra.db.QueryFilter 中的方法
在Select子句中查找指定的字段。
findSelectField(String) - 类 com.trs.infra.persistent.WCMFilter 中的方法
在Select子句中查找指定的字段。
findSelfByDocument(Document) - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的静态方法

findServiceConfig(String) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法

findServiceConfigById(String) - 类 com.trs.webframework.config.ServiceConfigStartServer 中的方法

findServiceFilterConfigs(String, String) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法
获取指定服务的所有过滤器
findServiceFilterConfigs(String, String) - 类 com.trs.webframework.config.ServiceConfigStartServer 中的方法
获取给指定服务设定的Filter
findServiceFilterConfigs(String, String) - 类 com.trs.webframework.config.ServiceFilterConfigs 中的方法

findServiceId(int) - 类 com.trs.webframework.controler.PostDataParser 中的方法
获取指定顺序的服务ID
findServiceListenerConfigs(String, String) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法
获取指定服务的所有监听器
findServiceListenerConfigs(String, String) - 类 com.trs.webframework.config.ServiceConfigStartServer 中的方法
获取指定服务设定的Listener
findServiceListenerConfigs(String, String) - 类 com.trs.webframework.config.ServiceListenerConfigs 中的方法

findSiteKinds(String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellResLocator 中的方法
从指定的路径中获取站点的类型
findSiteKinds(String) - 类 com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl 中的方法

findSiteStylesOfKind(String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellResLocator 中的方法
从指定路径中获取指定类型的样式
findSiteStylesOfKind(String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl 中的方法

findSiteTypeDesc(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法

findSiteTypeDesc(int) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的静态方法

findSpecialByChnlId(User, int) - 接口 com.trs.components.special.ISpecialMgr 中的方法
根据栏目的Id，获取栏目对应的专题对象
findSpecialByChnlId(User, int) - 类 com.trs.components.special.SpecialMgr 中的方法

findStatusesCanDoIncreasePub(int, int) - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 中的方法

findStatusesCanDoIncreasePub(int, int) - 接口 com.trs.components.wcm.publish.IFolderPubStatusCacheMgr 中的方法
获取指定Folder的可增量发布的状态
findStatusesCanDoPub(int, int) - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 中的方法

findStatusesCanDoPub(int, int) - 接口 com.trs.components.wcm.publish.IFolderPubStatusCacheMgr 中的方法
获取指定Folder的可完全发布的状态
findStatViewByName(String) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
根据统计视图的名称定位统计元素
findStatViewByName(String) - 类 com.trs.service.impl.StatService 中的方法

findStatViewByName(String) - 接口 com.trs.service.IStatService 中的方法
获取指定名称的统计视图.
findStyleImageDir(PageStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
获取指定页面风格的图片所在目录
findStyleImageDir(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
获取风格中上传的图片路径(服务器端的物理地址)
findStyleImageDir(PageStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法

findStyleNameUsedInfo(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
校验StyleName已经被使用的信息
findStyleNameUsedInfo(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
校验StyleName已经被使用的信息
findStyleNameUsedStyles(PageStyle, BaseStyle, String) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
当前页面风格(_oPageStyle)下,除自己以外，名称为_sStyleName的资源风格以及内容风格。
findStyleNameUsedStyles(PageStyle, BaseStyle, String) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
当前页面风格(_oPageStyle)下,除自己以外，名称为_sCssFlag的资源风格以及内容风格。
findSynRule(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
为栏目设置同步文档的规则
findTagOuterHTML(String, String) - 类 com.trs.wcag2.HTMLUtil 中的静态方法

findTagStartHTML(String, String) - 类 com.trs.wcag2.HTMLUtil 中的静态方法

findTopNewsOrPicChannel(BaseChannel, int) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 中的静态方法

findUnfinishedSchedules(User, CMyDateTime) - 类 com.trs.components.common.job.Schedules 中的静态方法

findViewByChannel(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法

findViewById(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
根据ID获取视图信息对象
findViewById(int) - 接口 com.trs.service.IInfoViewService 中的方法
查找指定ID的自定义表单视图
findViewById(int) - 类 com.trs.service.impl.InfoViewService 中的方法

findViewDataById(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
根据ID获取指定视图数据的对象
findViewDataById(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
根据ID获取指定视图数据的对象
findViewDataById(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
根据ID获取指定视图数据的对象
findViewDataById(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
根据ID获取指定视图数据的对象
findViewDocumentsByIds(User, String) - 类 com.trs.ajaxservice.WCMDocumentHelper 中的静态方法

findViewFieldById(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法

findViews(User) - 类 com.trs.components.metadata.center.MetaViewHelper 中的静态方法

findWCMObjsByIds(User, Class, String) - 类 com.trs.cms.content.CMSBaseObjs 中的静态方法

findWCMObjsByIds(User, String, String) - 类 com.trs.cms.content.CMSBaseObjs 中的静态方法
根据ID序列获取一个指定的集合
findWidgetByName(User, String) - 接口 com.trs.components.common.publish.widget.IWidgetMgr 中的方法
根据传入的资源块名称，返回找到的第一个资源块对象，如果没有找到合适的资源块对象，则返回null。
findWidgetByName(User, String) - 类 com.trs.components.common.publish.widget.WidgetMgr 中的方法

finish() - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Finishes the deflater with the current input block.
finish() - 类 com.trs.infra.util.jazzlib.DeflaterOutputStream 中的方法
Finishes the stream by calling finish() on the deflater.
finish() - 类 com.trs.infra.util.jazzlib.GZIPOutputStream 中的方法

finish() - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
Finishes the stream.
finished() - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Returns true iff the stream was finished and no more output bytes are available.
finished() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Returns true, if the inflater has finished.
finishLog(int) - 类 com.trs.cms.logger.ObjSysLogger 中的方法
日志记录结束
finishLog(int, int) - 类 com.trs.cms.logger.ObjSysLogger 中的方法
结束日志记录
finishLog(int, Throwable) - 类 com.trs.cms.logger.ObjSysLogger 中的方法
结束记录日志
FLAG_ALL - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
附件类型标识：所有类型的附件
FLAG_ALL_APD - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
附件类型标识：文档所有附件
FLAG_AUTOTO - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：自动流转产生
FLAG_BACK - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：要求返工
FLAG_BIGTABLE - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：BigTable（稀疏数据）的存储路径
FLAG_CALLBOARD - 类 com.trs.components.common.message.Message 中的静态变量

FLAG_DEFAULT - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
文档标志：默认文档 0
FLAG_DELETE - 类 com.trs.components.common.message.Message 中的静态变量

FLAG_DELETED - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态变量
附件标志：删除 1
FLAG_DOCAPD - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
附件类型标识：文档附件
FLAG_DOCCON - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
附件类型标识：正文附件
FLAG_DOCPIC - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
附件类型标识：文档图片
FLAG_DOCUMENTSOURCE - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：文档导出导入相关资源文件的存放路径
FLAG_EXCEPTION - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：工作流发生异常
FLAG_FINISHED - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：已经结束
FLAG_FORCEEND - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：强行结束
FLAG_FORWARD - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：向前流转
FLAG_HELPSEARCH - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：HelpSearchIndex（帮助文件索引）的存储路径
FLAG_HTMLPIC - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
附件类型标识：HTML
FLAG_INFOVIEW - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：InfoView（自定义表单，借助MS InfoPath实现）的存储路径
FLAG_JOIN_AND_AGREE - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：参与会签并且同意
FLAG_JOIN_AND_LAST - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：会签最后一个人提交处理
FLAG_JOIN_SEPERATOR_AND_AGREE - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：参与并联审批并且同意
FLAG_LINK - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态变量
附件类型标识：链接附件
FLAG_LOCALPREVIEW - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：本地存放预览文件的路径
FLAG_LOCALPUB - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：本地存放发布文件的路径
FLAG_MAX_NEED_DOWITH - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：需要人处理的Flag最大值
FLAG_NEW - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态变量
附件标志：新增 0
FLAG_NODELETE - 类 com.trs.components.common.message.Message 中的静态变量

FLAG_NORMAL - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：普通文件目录
FLAG_OTHER_DOWITH - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：别人已经处理
FLAG_PAGE_START - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量

FLAG_PAGE_START - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量

FLAG_PASSED - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：已经经过
FLAG_PROTECTED - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：受保护文件目录
FLAG_PUBLISHED - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态变量
附件标志：发布 3
FLAG_REFUSED - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：拒绝
FLAG_RESUBMIT - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：重新处理
FLAG_SELF_DEFINED_CONTENT_TYPE - 类 com.trs.webframework.FrameworkConstants 中的静态变量

FLAG_SITEFROM - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：智能建站预设路径
FLAG_START - 类 com.trs.cms.process.ProcessConstants 中的静态变量
文档流转标志：起始位置
FLAG_SYSTEMTEMP - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：系统用临时文件目录
FLAG_TEMPLATE - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：模板文件目录
FLAG_TRANSFORMER - 类 com.trs.infra.support.file.FilesMan 中的静态变量
系统中XSL文件的存放路径
FLAG_TRS_OBJ_ID - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的静态变量

FLAG_TRS_OBJ_PUB - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的静态变量

FLAG_TRS_OBJ_TYPE - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的静态变量

FLAG_TRS_OBJ_TYPENAME - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的静态变量

FLAG_UNKNOWN - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
文档标志：未知
FLAG_UNKOWN - 类 com.trs.components.common.message.Message 中的静态变量
属性Flag有3种状态
FLAG_UPDATED - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的静态变量
附件标志：更新 2
FLAG_UPLOAD - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：上传的临时文件目录
FLAG_UPLOAD_FILE_EXT - 类 com.trs.webframework.FrameworkConstants 中的静态变量

FLAG_USER_DEFINE - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
文档标志：用户自定义的起始值 20
FLAG_USERTEMP - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：用户用临时文件目录
FLAG_WEBFILE - 类 com.trs.infra.support.file.FilesMan 中的静态变量
文件标识类型：可通过http协议访问的文件的路径
FLOAT - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：FLOAT
FLOAT - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：FLOAT
FLOAT - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：FLOAT
FLOAT - 类 com.trs.infra.util.database.MysqlDB 中的静态变量

FLOAT - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：INT 和SQLServer
FLOAT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：FLOAT
FLOAT - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：FLOAT
FLOAT - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：FLOAT
Flow - com.trs.cms.process.definition 中的 类

Flow() - 类 com.trs.cms.process.definition.Flow 的构造方法
构造函数：保留默认接口
FLOW_ADD - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
添加工作流
FLOW_DEL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除工作流
FLOW_EDIT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
修改工作流
FLOW_EXPORT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
导出工作流
FLOW_IMPORT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
导入工作流
FLOW_MAX_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
工作流权限index最大值
FLOW_MIN_INDEX - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
工作流权限Index最小值
FLOW_MON - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
工作流监控
FLOW_SETRIGHT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量

FLOW_STAT - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
工作流统计
FlowAction - com.trs.cms.process.definition 中的 类

FlowAction() - 类 com.trs.cms.process.definition.FlowAction 的构造方法
构造函数：保留默认接口
FlowActions - com.trs.cms.process.definition 中的 类

FlowActions(User) - 类 com.trs.cms.process.definition.FlowActions 的构造方法
构造函数
FlowActions(User, int, int) - 类 com.trs.cms.process.definition.FlowActions 的构造方法
构造函数
FlowCacheMgr - com.trs.cms.process.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流缓冲管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowCacheMgr() - 类 com.trs.cms.process.definition.FlowCacheMgr 的构造方法

FlowCondition - com.trs.cms.process.definition 中的 类

FlowCondition() - 类 com.trs.cms.process.definition.FlowCondition 的构造方法
构造函数：保留默认接口
FlowConditions - com.trs.cms.process.definition 中的 类

FlowConditions(User) - 类 com.trs.cms.process.definition.FlowConditions 的构造方法
构造函数
FlowConditions(User, int, int) - 类 com.trs.cms.process.definition.FlowConditions 的构造方法
构造函数
FlowConfigServer - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流配置服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowConfigServer() - 类 com.trs.cms.process.config.FlowConfigServer 的构造方法

FlowContentApplyFormImpl - com.trs.components.gkml.sqgk.process.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Document的FlowContent的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentApplyFormImpl(ApplyForm) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 的构造方法

FlowContentApplyFormImpl(int, int) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 的构造方法

FlowContentApplyFormImpl() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 的构造方法

FlowContentConfig - com.trs.cms.process.engine 中的 类

FlowContentConfig() - 类 com.trs.cms.process.engine.FlowContentConfig 的构造方法
构造函数：保留默认接口
FlowContentConfig(int, String, String) - 类 com.trs.cms.process.engine.FlowContentConfig 的构造方法

FlowContentConfigs - com.trs.cms.process.engine 中的 类

FlowContentConfigs(User) - 类 com.trs.cms.process.engine.FlowContentConfigs 的构造方法
构造函数
FlowContentConfigs(User, int, int) - 类 com.trs.cms.process.engine.FlowContentConfigs 的构造方法
构造函数
FlowContentDocumentImpl - com.trs.components.wcm.process.element 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Document的FlowContent的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentDocumentImpl(Document) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 的构造方法

FlowContentDocumentImpl(int) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 的构造方法

FlowContentDocumentImpl() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 的构造方法

FlowContentFactory - com.trs.cms.process 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
产生可以流转的内容
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentFactory() - 类 com.trs.cms.process.FlowContentFactory 的构造方法

FlowContentField - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
流转的内容字段描述对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentField(FlowContentTypeConfig) - 类 com.trs.cms.process.config.FlowContentField 的构造方法

FlowContentHelper - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
comment@2008-06-12 createFlowContent替换为新的实现
FlowContentHelper() - 类 com.trs.cms.process.engine.FlowContentHelper 的构造方法

FlowContentLCListener - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Flow Content生命周期监听器,只监听删除前
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentLCListener() - 类 com.trs.cms.process.engine.FlowContentLCListener 的构造方法

FlowContentsToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
将IFlowContent数组转换为XML
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentsToXML() - 类 com.trs.ajaxservice.xmlconvertors.FlowContentsToXML 的构造方法

FlowContentTypeConfig - com.trs.cms.process.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
可以流转的对象配置信息
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContentTypeConfig() - 类 com.trs.cms.process.config.FlowContentTypeConfig 的构造方法

FlowContext - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流驱动过程上下文对象
Copyright: Copyright (c) 2004-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowContext() - 类 com.trs.cms.process.engine.FlowContext 的构造方法

FlowContext(User, IFlowContent, String, Users, Flow) - 类 com.trs.cms.process.engine.FlowContext 的构造方法
内容开始流转时候的FlowContext构造函数
FlowContext(User, IFlowContent) - 类 com.trs.cms.process.engine.FlowContext 的构造方法
内容开始流转时候的FlowContext构造函数
FlowContextOld - com.trs.cms.process.engine 中的 类

FlowContextOld() - 类 com.trs.cms.process.engine.FlowContextOld 的构造方法

FlowContextOld(IFlowContent, FlowNode, User) - 类 com.trs.cms.process.engine.FlowContextOld 的构造方法
工作流环境变量记录对象的构造函数
FlowConverterForWebsiteImporter - com.trs.components.wcm.process.service.domain 中的 类

FlowConverterForWebsiteImporter() - 类 com.trs.components.wcm.process.service.domain.FlowConverterForWebsiteImporter 的构造方法

FlowDoc - com.trs.cms.process.engine 中的 类

FlowDoc() - 类 com.trs.cms.process.engine.FlowDoc 的构造方法
构造函数：保留默认接口
FlowDocBak - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: 文档流转对象的定义和实现 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
FlowDocBak() - 类 com.trs.cms.process.engine.FlowDocBak 的构造方法

FlowDocBaks - com.trs.cms.process.engine 中的 类

FlowDocBaks(User) - 类 com.trs.cms.process.engine.FlowDocBaks 的构造方法

FlowDocBaks(User, int, int) - 类 com.trs.cms.process.engine.FlowDocBaks 的构造方法

FlowdocLog - com.trs.cms.process.definition 中的 类

FlowdocLog() - 类 com.trs.cms.process.definition.FlowdocLog 的构造方法
构造函数：保留默认接口
FlowdocLogs - com.trs.cms.process.definition 中的 类

FlowdocLogs(User) - 类 com.trs.cms.process.definition.FlowdocLogs 的构造方法
构造函数
FlowdocLogs(User, int, int) - 类 com.trs.cms.process.definition.FlowdocLogs 的构造方法
构造函数
FlowDocs - com.trs.cms.process.engine 中的 类

FlowDocs(User) - 类 com.trs.cms.process.engine.FlowDocs 的构造方法

FlowDocs(User, int, int) - 类 com.trs.cms.process.engine.FlowDocs 的构造方法

FlowDocToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流轨迹XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowDocToXML() - 类 com.trs.ajaxservice.xmlconvertors.FlowDocToXML 的构造方法

FlowEmploy - com.trs.cms.process.definition 中的 类

FlowEmploy() - 类 com.trs.cms.process.definition.FlowEmploy 的构造方法
构造函数：保留默认接口
FlowEmployCacheMgr - com.trs.cms.process.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Template Employ缓冲管理器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowEmployCacheMgr() - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 的构造方法

FlowEmployerLCListener - com.trs.cms.process.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Flow Employer监听器,只监听删除前
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowEmployerLCListener() - 类 com.trs.cms.process.definition.FlowEmployerLCListener 的构造方法
缺省构造方法
FlowEmployLCListenerForChange - com.trs.components.wcm.process 中的 类
监听频道工作流设置的改变
FlowEmployLCListenerForChange() - 类 com.trs.components.wcm.process.FlowEmployLCListenerForChange 的构造方法

FlowEmployLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工件流分配日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FlowEmployLogger() - 类 com.trs.components.wcm.logger.FlowEmployLogger 的构造方法

FlowEmployMgr - com.trs.cms.process.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
flow employ records manager.
FlowEmployMgr() - 类 com.trs.cms.process.definition.FlowEmployMgr 的构造方法

FlowEmploys - com.trs.cms.process.definition 中的 类

FlowEmploys(User) - 类 com.trs.cms.process.definition.FlowEmploys 的构造方法

FlowEmploys(User, int, int) - 类 com.trs.cms.process.definition.FlowEmploys 的构造方法

FlowEngineHelper - com.trs.cms.process 中的 类

FlowEngineHelper() - 类 com.trs.cms.process.FlowEngineHelper 的构造方法

FlowImporter - com.trs.cms.process.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
从XML导入工作流的配置的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowImporter(int) - 类 com.trs.cms.process.xml.FlowImporter 的构造方法

FlowImporter(User, int) - 类 com.trs.cms.process.xml.FlowImporter 的构造方法

FLOWING_DOC_OPT_MARK - 类 com.trs.cms.process.FlowingDocOptMarkScouter 中的静态变量
文档操作标签: WCMDocument表的FlowOperationMark字段
FLOWING_DOC_OPT_MARK_ENUM - 类 com.trs.cms.process.FlowingDocOptMarkScouter 中的静态变量
工作流文档操作标签枚举值: WCMDocument表的FlowOperationMaskEnum字段
FLOWING_DOC_PRE_OPT_MARK - 类 com.trs.cms.process.FlowingDocOptMarkScouter 中的静态变量
文档前置操作标签(例如“收到”、“签收”等操作，暂时没有用到): WCMDocument表的FlowPreOperationMark字段
FlowingDocLogger - com.trs.cms.process 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowingDocOptMarkScouter - com.trs.cms.process 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
流转中文档的操作标签监控器
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowingDocQueryService - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2007 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowingDocQueryService() - 类 com.trs.ajaxservice.FlowingDocQueryService 的构造方法

FlowMgr - com.trs.cms.process.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Flow Manager
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowMgr() - 类 com.trs.cms.process.definition.FlowMgr 的构造方法

FlowNextBranchInfo - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
描述下一个节点
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowNextBranchInfo(User, FlowDoc, int, boolean) - 类 com.trs.cms.process.engine.FlowNextBranchInfo 的构造方法

FlowNode - com.trs.cms.process.definition 中的 类

FlowNode() - 类 com.trs.cms.process.definition.FlowNode 的构造方法
构造函数：保留默认接口
FlowNodeBranch - com.trs.cms.process.definition 中的 类

FlowNodeBranch() - 类 com.trs.cms.process.definition.FlowNodeBranch 的构造方法
构造函数：保留默认接口
FlowNodeBranchs - com.trs.cms.process.definition 中的 类

FlowNodeBranchs(User) - 类 com.trs.cms.process.definition.FlowNodeBranchs 的构造方法

FlowNodeBranchs(User, int, int) - 类 com.trs.cms.process.definition.FlowNodeBranchs 的构造方法

FlowNodeField - com.trs.cms.process.definition 中的 类

FlowNodeField() - 类 com.trs.cms.process.definition.FlowNodeField 的构造方法
构造函数：保留默认接口
FlowNodeFields - com.trs.cms.process.definition 中的 类

FlowNodeFields(User) - 类 com.trs.cms.process.definition.FlowNodeFields 的构造方法
构造函数
FlowNodeFields(User, int, int) - 类 com.trs.cms.process.definition.FlowNodeFields 的构造方法
构造函数
FlowNodeLCListenerForForceEnd - com.trs.cms.process.engine 中的 类
监听工作流节点的删除
FlowNodeLCListenerForForceEnd() - 类 com.trs.cms.process.engine.FlowNodeLCListenerForForceEnd 的构造方法

FlowNodes - com.trs.cms.process.definition 中的 类

FlowNodes(User) - 类 com.trs.cms.process.definition.FlowNodes 的构造方法

FlowNodes(User, int, int) - 类 com.trs.cms.process.definition.FlowNodes 的构造方法

FlowNodeXmlConverter - com.trs.cms.process.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流节点对象到XML转换的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowNodeXmlConverter() - 类 com.trs.cms.process.xml.FlowNodeXmlConverter 的构造方法

FlowNotifyWorkerImpl - com.trs.components.wcm.process 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowNotifyWorkerImpl() - 类 com.trs.components.wcm.process.FlowNotifyWorkerImpl 的构造方法

FlowOptMarkEnumParser - com.trs.cms.process.definition 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowParamers - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
内容流转时的参数
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowParamers() - 类 com.trs.cms.process.engine.FlowParamers 的构造方法

FlowRule - com.trs.cms.process.definition 中的 类

FlowRule() - 类 com.trs.cms.process.definition.FlowRule 的构造方法
构造函数：保留默认接口
FlowRuleCacheServerImpl - com.trs.cms.process.definition 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流规则缓冲维护器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowRuleCacheServerImpl() - 类 com.trs.cms.process.definition.FlowRuleCacheServerImpl 的构造方法

FlowRules - com.trs.cms.process.definition 中的 类

FlowRules(User) - 类 com.trs.cms.process.definition.FlowRules 的构造方法
构造函数
FlowRules(User, int, int) - 类 com.trs.cms.process.definition.FlowRules 的构造方法
构造函数
FlowRuleXMLConvertor - com.trs.cms.process.xml 中的 类

FlowRuleXMLConvertor() - 类 com.trs.cms.process.xml.FlowRuleXMLConvertor 的构造方法

Flows - com.trs.cms.process.definition 中的 类

Flows(User) - 类 com.trs.cms.process.definition.Flows 的构造方法

Flows(User, int, int) - 类 com.trs.cms.process.definition.Flows 的构造方法

FlowSaveLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流保存日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FlowSaveLogger() - 类 com.trs.ajaxservice.logger.FlowSaveLogger 的构造方法

FlowServer - com.trs.cms.process 中的 类

FlowServer() - 类 com.trs.cms.process.FlowServer 的构造方法
构造函数
FlowServerImpl - com.trs.cms.process 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
FlowServer的默认实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowServerImpl() - 类 com.trs.cms.process.FlowServerImpl 的构造方法

FlowSetLogger - com.trs.ajaxservice.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
分配工作流到栏目日志记录
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FlowSetLogger() - 类 com.trs.ajaxservice.logger.FlowSetLogger 的构造方法

FlowToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流 To XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowToXML() - 类 com.trs.ajaxservice.xmlconvertors.FlowToXML 的构造方法

FlowUserHelper - com.trs.cms.process.engine 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流用户相关解析器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowUserHelper() - 类 com.trs.cms.process.engine.FlowUserHelper 的构造方法

FlowXmlConverter - com.trs.cms.process.xml 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流对象到XML转换对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FlowXmlConverter() - 类 com.trs.cms.process.xml.FlowXmlConverter 的构造方法

flush() - 类 com.trs.infra.util.BASE64EncoderStream 中的方法

flush() - 类 com.trs.infra.util.jazzlib.DeflaterOutputStream 中的方法
Flushes the stream by calling flush() on the deflater and then on the underlying stream.
FolderPublishConfig - com.trs.components.common.publish.persistent.publisher 中的 类

FolderPublishConfig() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 的构造方法
构造函数：保留默认接口
FolderPublishConfigCacheMgr - com.trs.components.common.publish.persistent.publisher 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FolderPublishConfigCacheMgr() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigCacheMgr 的构造方法

FolderPublishConfigLogger - com.trs.components.wcm.logger 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
FolderPublishConfigLogger() - 类 com.trs.components.wcm.logger.FolderPublishConfigLogger 的构造方法

FolderPublishConfigs - com.trs.components.common.publish.persistent.publisher 中的 类

FolderPublishConfigs(User) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 的构造方法
构造函数
FolderPublishConfigs(User, int, int) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 的构造方法
构造函数
FolderPubStatusCacheMgrImpl - com.trs.components.wcm.publish 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FolderPubStatusCacheMgrImpl() - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 的构造方法

FolderTypeConfig - com.trs.components.common.publish.config.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FolderTypeConfig() - 类 com.trs.components.common.publish.config.persistent.FolderTypeConfig 的构造方法

FONT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

forceContentEndInFlow(int, int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法

forceContentEndInFlow(int, int) - 接口 com.trs.service.IWCMProcessService 中的方法

forceDocToEnd(IFlowContent, User) - 类 com.trs.cms.process.FlowServer 中的方法

forceEnd(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
强制结束
forceEnd(FlowContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法

forceEnd(FlowContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
强制结束
forceUnLocke(User, CMSObj) - 类 com.trs.presentation.util.CmsObjUnlockTools 中的静态方法

forFillOut(InfoView, InfoViewView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
为了在WCM内部填写表单而生成HTML页面
forFillOut(InfoView, InfoViewView) - 接口 com.trs.service.IInfoViewService 中的方法
为了在WCM内部填写表单而生成HTML页面 事实上生成的HTML页面不仅用于内部填写表单、还用在表单预览、表单数据察看。
forFillOut(InfoView, InfoViewView) - 类 com.trs.service.impl.InfoViewService 中的方法

forFillOutInFlow(InfoView, InfoViewView, int) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
工作流转中xsl转化成html的过程
forFillOutInFlow(InfoView, InfoViewView, int) - 接口 com.trs.service.IInfoViewService 中的方法

forFillOutInFlow(InfoView, InfoViewView, int) - 类 com.trs.service.impl.InfoViewService 中的方法

forFillOutInner(InfoView, InfoViewView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
为了在WCM内部填写表单而生成HTML页面
forFillOutInner(InfoView, InfoViewView, boolean) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
为了在WCM内部填写表单而生成HTML页面
forFillOutInner(InfoView, InfoViewView) - 接口 com.trs.service.IInfoViewService 中的方法

forFillOutInner(InfoView, InfoViewView, boolean) - 接口 com.trs.service.IInfoViewService 中的方法

forFillOutInner(InfoView, InfoViewView) - 类 com.trs.service.impl.InfoViewService 中的方法

forFillOutInner(InfoView, InfoViewView, boolean) - 类 com.trs.service.impl.InfoViewService 中的方法

forInfoGate(InfoView, FormProperty) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

FORM - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

format(String, String[]) - 类 com.trs.infra.util.CMyString 中的静态方法
用数组_args里面的第i个变量替换掉_sFormat中的{i}
format(String, Object[]) - 类 com.trs.infra.util.CMyString 中的静态方法
用数组_args里面的第i个变量替换掉_sFormat中的{i}
format(String, int[]) - 类 com.trs.infra.util.CMyString 中的静态方法
用数组_args里面的第i个变量替换掉_sFormat中的{i}
format(Element) - 类 com.trs.scene.tools.SceneNodeToXML 中的静态方法

FORMAT_DEFAULT - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日时字符串格式：默认格式
FORMAT_HTML - 类 com.trs.infra.util.email.CMyEmail 中的静态变量

FORMAT_LONG - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日时字符串格式：长格式（如：年份用4位表示）
FORMAT_SHORT - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日时字符串格式：短格式（如：年份用2位表示）
FORMAT_TEXT - 类 com.trs.infra.util.email.CMyEmail 中的静态变量

formatLogicRightValue(User, Document, String) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法

formatOfEnumValue(int) - 类 com.trs.components.metadata.MetaDataConstants 中的静态方法

formatTextIfNeeded(TagItem, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
已过时。 Formats the text if AUTOFORMAT=true.
Related tag attributes: AUTOFORMAT, AUTOFORMATTYPE
formatTextIfNeeded(PublishTagContext, String) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
Formats the text if AUTOFORMAT=true.
formatTimeUsed(long) - 类 com.trs.infra.util.CMyDateTime 中的静态方法
把以毫秒计算的使用时间格式化为“xxx分xx秒”的格式
FormElementsValidator - com.trs.wcag2.validator 中的 类

FormElementsValidator() - 类 com.trs.wcag2.validator.FormElementsValidator 的构造方法

FormProperty - com.trs.components.infoview.publish.tagparser 中的 类
描述发布后表单FORM的一些属性 TODO;这个类应该放在哪一个package中
FormProperty() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 的构造方法

FormSubmitValidator - com.trs.wcag2.validator 中的 类

FormSubmitValidator() - 类 com.trs.wcag2.validator.FormSubmitValidator 的构造方法

forMultiView(InfoView, InfoViewView, List) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

forPreview(InfoView, FormProperty, List) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

forPreviewMultiView(InfoView, InfoViewView, FormProperty, List) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

forPublish(InfoView, FormProperty, List) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

forPublishMultiView(InfoView, InfoViewView, FormProperty, List) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

forward(String) - 类 com.trs.presentation.util.RequestHelper 中的方法
页面带参数跳转到_sURL
forword(MethodContext) - 类 com.trs.webframework.provider.DefautlServiceProvider 中的方法
空方法，不做任何实现，做转发使用
FRAME - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

FRAMEBORDER - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

FRAMESET - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

FrameTitleValidator - com.trs.wcag2.validator 中的 类

FrameTitleValidator() - 类 com.trs.wcag2.validator.FrameTitleValidator 的构造方法

FrameworkConstants - com.trs.webframework 中的 类

FrameworkConstants() - 类 com.trs.webframework.FrameworkConstants 的构造方法

free(TRSConnection) - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的方法
释放连接
free(Connection) - 类 com.trs.infra.util.database.ConnectionPool 中的方法
释放连接
free(CMyFtp) - 类 com.trs.infra.util.ftp.FtpConnectionPool 中的方法

freeConnection(TRSConnection) - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的方法
释放数据库连接
freeConnection(TRSConnection) - 类 com.trs.components.wcm.content.trsserver.OuterKMTRSServer 中的方法
释放数据库连接
freeConnection(Connection) - 类 com.trs.infra.persistent.db.DBManager 中的方法
释放数据库连接
freeDeadLock() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
消除死锁
freeLockedObjBy(User) - 类 com.trs.cms.content.LockerMgr 中的方法
释放所有由特定用户锁定的对象.
freeLockedObjBy(User) - 类 com.trs.cms.content.LockManager 中的方法
释放所有由特定用户锁定的对象.
freeMemory() - 类 com.trs.infra.util.CMyMemory 中的静态方法

fromConfigElement(TargetTypeConfig) - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
read from a XML element
fromConfigElement(PublishElementConfig) - 类 com.trs.components.common.publish.config.PublishElementType 中的方法
read properties from CMyBaseConfig, which may be imported from a XML file.
fromString(String) - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
字符串导入 字符串格式：属性名=属性值
fromString(String) - 类 com.trs.infra.util.html.HtmlComment 中的方法
字符串导入，字符串格式： fromString(String) - 类 com.trs.infra.util.html.HtmlDocument 中的方法
从字符串导入 处理方式：构造虚拟的HtmlElement元素，由其解释
fromString(String, String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
字符串导入,字符串格式：<名称 属性列表> 内容|子元素列表 </名称>
fromString(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法

fromString(char[], int, String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
从指定的字符串中导入元素信息
fromString(char[], int) - 类 com.trs.infra.util.html.HtmlElement 中的方法

fromXML(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
使用XML的方式保存工作流
fromXML(Element) - 类 com.trs.presentation.util.PageParameter 中的方法

fromXML(Element) - 类 com.trs.presentation.util.Parameter 中的方法
从指定的XML Element导入参数数据 fromXMLElement(_element)
fromXML(Element) - 类 com.trs.webframework.config.TRSPageParameter 中的方法

fromXML(Element) - 类 com.trs.webframework.config.TRSParameter 中的方法
从指定的XML Element导入参数数据 fromXMLElement(_element)
fromXMLFile(String) - 类 com.trs.infra.util.CMyBeanConfig 中的静态方法

fromXMLFile(String) - 类 com.trs.infra.util.CMyClassConfig 中的静态方法

FtpConfig - com.trs.infra.util.uftp 中的 类
集中存放FTP相关的配置信息
FtpConfig() - 类 com.trs.infra.util.uftp.FtpConfig 的构造方法
缺省构造方法
FtpConnection - com.trs.infra.util.uftp 中的 类
抽象类，所有FTP和FTP类似协议实现的封装接口。
FtpConnection() - 类 com.trs.infra.util.uftp.FtpConnection 的构造方法
缺省构造方法
FtpConnectionCache - com.trs.infra.util.uftp 中的 类
FTP客户端连接的缓冲池，除了维护连接以外，还会后台的线程定期地检查连接的有效性
FtpConnectionCache(FtpConfig) - 类 com.trs.infra.util.uftp.FtpConnectionCache 的构造方法
缺省构造方法
FtpConnectionImpFtp - com.trs.infra.util.uftp 中的 类
使用普通的FTP协议实现 FtpConnection 抽象类， 其中FTP协议部分的实现采用TRS公司的实现。
FtpConnectionImpFtp() - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 的构造方法
缺省构造方法
FtpConnectionImpSSH - com.trs.infra.util.uftp 中的 类
使用SSH的SFTP协议实现FtpConnection抽象类， 其中SFTP协议部分的实现采用www.jcraft.com的实现。
FtpConnectionImpSSH() - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 的构造方法
缺省构造方法
FtpConnectionPool - com.trs.infra.util.ftp 中的 类

FtpConnectionPool(String, String, String, String, boolean, int) - 类 com.trs.infra.util.ftp.FtpConnectionPool 的构造方法
Constructor
FtpMgr - com.trs.infra.util.ftp 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ftp manager implementation for IFtpMgr
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FtpMgr() - 类 com.trs.infra.util.ftp.FtpMgr 的构造方法

FtpMgrTest - com.trs.infra.util.ftp 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
FtpMgrTest(IFtpMgr, int) - 类 com.trs.infra.util.ftp.FtpMgrTest 的构造方法

FtpSoap4Radar - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
通过FTP配合接收雷达的数据(SOAP),需要配置类路径中的ftpsoap4radar.properties
Copyright: Copyright (c) 2004-2007 北京拓尔思(TRS)信息技术有限公司
Company: 北京拓尔思(TRS)信息技术有限公司(www.trs.com.cn)
FtpSoap4Radar() - 类 com.trs.service.impl.FtpSoap4Radar 的构造方法

fw - 类 com.trs.components.wcm.wcmx.util.CWasTree 中的静态变量

概述  软件包  类  使用  树  已过时   索引  帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


G - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

G

g_bXMLforTRS - 类 com.trs.components.wcm.content.persistent.Document 中的变量
GATEWAY_FILE_UPLOAD_URL - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的静态变量
GATEWAY_FORM_ACTION - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的静态变量
GATEWAY_INIT_PAGE - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的静态变量
GATEWAY_READ_FILE_URL - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的静态变量
GATEWAY_RESERVED_PAGES - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的静态变量
GATEWAY_VALID_VERIFY_CODE_URL - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的静态变量
GATEWAY_VERIFY_CODE_URL - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的静态变量
GatewayConfig - com.trs.components.infoview.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GatewayConfig() - 类 com.trs.components.infoview.config.GatewayConfig 的构造方法
GatewayPage - com.trs.components.infoview.config 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2007-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GatewayPage() - 类 com.trs.components.infoview.config.GatewayPage 的构造方法
generate() - 类 com.trs.components.wcm.epress.EPressHistoryGenerator 中的方法
generate(CMyDateTime) - 类 com.trs.components.wcm.epress.EPressHistoryGenerator 中的方法
generateAppendix(Appendix, IPublishContent, PublishTagContext, int) - 类 com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator 中的静态方法
Generates a document appendix.
generateAppendixes(Document, int, PublishTagContext, int) - 类 com.trs.components.wcm.publish.tagparser.WCMAppendixGenerator 中的静态方法
Generate the appendixes of a document.
generateChart(String, JFreeChart) - 类 com.trs.components.wcm.stat.domain.ChartWriter 中的静态方法
generateChart(String, JFreeChart, ChartStyle) - 类 com.trs.components.wcm.stat.domain.ChartWriter 中的静态方法
generateChart(OutputStream, JFreeChart) - 类 com.trs.components.wcm.stat.domain.ChartWriter 中的静态方法
generateChart(OutputStream, JFreeChart, ChartStyle) - 类 com.trs.components.wcm.stat.domain.ChartWriter 中的静态方法
generateContent(PublishPageContext, Template) - 类 com.trs.components.common.publish.domain.publisher.PageGenerator 中的静态方法
generateContent(MethodContext, User) - 类 com.trs.components.infoview.helper.InfoViewTemplateHelper 中的静态方法
generateDetail(PublishPageContext) - 类 com.trs.components.common.publish.domain.publisher.PageGenerator 中的静态方法
generate the content detail page file
generateHtml(Layout, boolean) - 接口 com.trs.components.common.publish.widget.ILayoutGenerator 中的方法
生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可
generateHtml(Layout, boolean, boolean) - 接口 com.trs.components.common.publish.widget.ILayoutGenerator 中的方法
生成布局对应的HTML代码，需要实现另一种结构的代码，实现该接口即可
generateHtml(Layout, boolean, boolean) - 类 com.trs.components.common.publish.widget.LayoutGenerator 中的方法
产生布局的HTML代码和CSS代码
generateHtml(Layout, boolean) - 类 com.trs.components.common.publish.widget.LayoutGenerator 中的方法
产生布局的相关HTML代码
generateOutlines(PublishPageContext) - 类 com.trs.components.common.publish.domain.publisher.PageGenerator 中的静态方法
generate the content folder outline page file
generatePage(PublishPageContext, Template) - 类 com.trs.components.common.publish.domain.publisher.PageGenerator 中的静态方法
Generates page with the specified template in the specified page context.
generatePage(PublishPageContext, Template, boolean) - 类 com.trs.components.common.publish.domain.publisher.PageGenerator 中的静态方法
generaterContent(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
_context 中参数 DocumentId InfoViewId/ChannelId TempIVType 缺省为detail Page 缺省为1
generateTodayStat(int) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
产生特定统计视图模板当天的统计数据
统计数据记录在统计表中
可以由定时任务触发，也可以由初始化统计表格触发
generateTodayStat(int) - 类 com.trs.service.impl.StatService 中的方法
generateTodayStat(int) - 接口 com.trs.service.IStatService 中的方法
产生特定统计模板当天的统计数据
统计数据记录在统计表中
generatorKey(String, String) - 类 com.trs.infra.util.CMyKeyGenerator 中的静态方法
get(int) - 类 com.trs.cms.ObjectTypeServer 中的静态方法
get(int) - 类 com.trs.components.common.publish.domain.tagparser.TagParseResults 中的方法
Returns the parse result at the specified position.
get(int) - 接口 com.trs.components.common.publish.persistent.element.IPublishElements 中的方法
Returns the element at the specified position in this collection.
get(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 中的方法
get(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 中的方法
get(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 中的方法
get(String) - 类 com.trs.components.wcm.channel.VChannel 中的方法
get(IPublishFolder, WCMFilter) - 接口 com.trs.components.wcm.publish.tagparser.IPublishTaskDocumentsCacheMgr 中的方法
get(IPublishFolder, WCMFilter) - 类 com.trs.components.wcm.publish.tagparser.PublishTaskDocumentsCacheMgr 中的方法
get(int) - 类 com.trs.infra.common.ContextParameters 中的静态方法
返回指定索引序号的参数，返回后相关联位置的参数会被清除，以TLS节约内存
get(int, boolean) - 类 com.trs.infra.common.ContextParameters 中的静态方法
返回指定索引序号的参数，并根据keep的值决定是否清楚该参数
get(int) - 类 com.trs.infra.config.persistent.ConfigFiles 中的方法
get(Class, String, String) - 类 com.trs.infra.I18NMessage 中的静态方法
get(int) - 类 com.trs.infra.persistent.db.DBConnectionConfigs 中的方法
get(int) - 类 com.trs.infra.util.CMyDateTime 中的方法
日期/时间的分解
get(int) - 类 com.trs.infra.util.database.TypeNames 中的方法
get default type name for specified type
get(int, int, int, int) - 类 com.trs.infra.util.database.TypeNames 中的方法
get type name for specified type and size
get(int) - 类 com.trs.infra.util.email.SMTPServerConfigs 中的方法
get(String) - 类 com.trs.infra.util.HttpGet 中的静态方法
get(String, int) - 类 com.trs.infra.util.HttpGet 中的静态方法
get(String, int, boolean) - 类 com.trs.infra.util.HttpGet 中的静态方法
get(int) - 类 com.trs.infra.util.upgrade.dbcompare.JdbcTypeMap 中的静态方法
根据jdbcType获取得到jdbcTypeName.
get(String) - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfoMap 中的静态方法
get(int) - 类 com.trs.presentation.util.Parameters 中的方法
获取指定位置的参数对象
get0() - 类 com.trs.infra.common.ContextParameters 中的静态方法
快速返回第一个参数，等价于get(0, false)。
get1() - 类 com.trs.infra.common.ContextParameters 中的静态方法
快速返回第二个参数，等价于get(1, false)。
get2() - 类 com.trs.infra.common.ContextParameters 中的静态方法
快速返回第三个参数，等价于get(2, false)。
GET_ENCODING_DEFAULT - 类 com.trs.infra.util.CMyString 中的静态变量
GET_FROM_TRSSERVER - 类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 中的静态变量
GET_RELATEDDOC_BY_ALL - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
取相关文档时所用的类型：任意类型的相关
GET_RELATEDDOC_BY_KEYWORDS - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
取相关文档时所用的类型：通过关键字
GET_RELATEDDOC_BY_RELATION - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
取相关文档时所用的类型：通过相关表
GET_RELATEDDOC_BY_RELWORDS - 类 com.trs.components.wcm.content.persistent.Document 中的静态变量
取相关文档时所用的类型：通过相关词
getAbsoluteAppFileName(String) - 类 com.trs.wcm.old.ImportDocsContext 中的方法
根据文件名获取附件在服务器存放的绝对地址
getAbsoluteFileNameOfCoreBeansXML() - 类 com.trs.infra.config.ConfigConstants 中的静态方法
getAbsoluteFileNameOfCoreConfigXML() - 类 com.trs.infra.config.ConfigConstants 中的静态方法
getAbsoluteFileNameOfCoreMapping() - 类 com.trs.infra.config.ConfigConstants 中的静态方法
getAbsoluteHttpPath(IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the http path of the specified element.
getAbsoluteHttpPath(IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the http path of the specified folder.
getAbsoluteHttpPath(IPublishContent) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the http path without file name of the specified content.
getAbsolutePath(InfoView, String) - 类 com.trs.ajaxservice.InfoviewService 中的方法
getAbsolutePath(InfoView, String) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
getAbstract() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取摘要
getAbstractErrorMessage(String) - 异常 com.trs.template.AbstractErrorMessage 中的静态方法
getAcceptedIssuers() - 类 com.trs.infra.util.MySSLSocketFactory.MyX509TrustManager 中的方法
getAcceptTime() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
getAction() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法
getActionDesc() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：ActionDesc
getActionFlag() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：ActionFlag
getActionHandlerConfigs() - 类 com.trs.cms.process.config.FlowConfigServer 中的方法
getActions(User) - 类 com.trs.cms.process.definition.FlowRule 中的方法
获取规则中设定的所有操作
getAdAction() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdAction
getAdAttribute() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdAttribute
getAdBegin() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdBegin
getAdBegin() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
提取属性：AdBegin
getADCom() - 类 com.trs.components.common.trsad.ADFile 中的方法
getAdCompany() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdCompany
getAdCrTime() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdCrTime
getAdCrUser() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdCrUser
getAddEditFields() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
编辑页面字段列表
getAdden() - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法
getAdDesc() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdDesc
getAdditionalData() - 类 com.trs.components.comment.domain.NewsComment 中的方法
getAddOp(BaseObj) - 类 com.trs.cms.logger.OperTypeHelper 中的静态方法
getAddress() - 类 com.trs.cms.auth.persistent.User 中的方法
获取联系地址
getAddress() - 类 com.trs.components.common.address.Contact 中的方法
属性: Address 地址
getAddress() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：Address
getAdEnd() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdEnd
getAdEnd() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
提取属性：AdEnd
getAdExt() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdExt
getADFile() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
getAdFileId() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
提取属性：AdFileId
getAdFileKind() - 类 com.trs.components.common.trsad.ADType 中的方法
提取属性：AdFileKind
getAdFileName() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdFileName广告文件名
getADFiles() - 类 com.trs.components.common.trsad.ADCom 中的方法
得到ADFiles集合对象
getADFiles() - 类 com.trs.components.common.trsad.ADPos 中的方法
得到本广告位的广告的记录集
getADFiles() - 类 com.trs.components.common.trsad.ADType 中的方法
getAdFlag() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdFlag
getAdHeight() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdHeight
getAdHit() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdHit
getAdIsWork() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdIsWork
getAdler() - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Gets the current adler checksum of the data that was processed so far.
getAdler() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Gets the adler checksum.
getAdManagerLinkPath() - 类 com.trs.components.common.conjection.service.AdmanageConfigServiceImpl 中的方法
getAdManagerLinkPath() - 接口 com.trs.components.common.conjection.service.IAdmanageConfigService 中的方法
getAdministrator(User) - 类 com.trs.cms.auth.persistent.Group 中的方法
取用户所属组对象集合
getAdministratorRightValue() - 类 com.trs.cms.auth.persistent.RightValue 中的静态方法
getAdministratorValues() - 类 com.trs.cms.auth.persistent.RightValue 中的静态方法
getAdmins(Group) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
获取指定组织的管理员集合
getAdmins(Group) - 类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 中的方法
获取指定用户组的管理员集合
getAdmins(Group) - 接口 com.trs.service.IGroupService 中的方法
获取指定组的管理员集合
getAdmins(Group) - 类 com.trs.service.impl.GroupService 中的方法
getAdminUsers() - 类 com.trs.cms.auth.persistent.AdministratorCacheMgr 中的方法
getAdminUsers() - 接口 com.trs.cms.auth.persistent.IAdministratorCacheMgr 中的方法
getAdName() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdName广告名称
getADPos() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
getAdPosId() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
提取属性：AdPosId
getAdPrice() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdPrice
getAdTagHit() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
提取属性：AdTagHit
getAdType() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdType
getAdTypeName() - 类 com.trs.components.common.trsad.ADType 中的方法
提取属性：AdTypeName
getAdUrl() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdUrl
getAdWidth() - 类 com.trs.components.common.trsad.ADFile 中的方法
提取属性：AdWidth
getAheadRemindTime() - 类 com.trs.components.common.calendar.Event 中的方法
属性: AheadRemindTime 提前提醒的时间
getAlgorithm() - 类 com.trs.infra.support.security.SecureKey 中的方法
获取密钥算法
getAlias() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 中的方法
返回变量类型的别名
getAllAttributeKeys() - 类 com.trs.infra.util.html.HTML 中的静态方法
This is the set of html attributes recognized.
getAllChannelsXML(boolean) - 接口 com.trs.service.ICDSService 中的方法
获取系统树状结构信息
getAllChannelsXML(boolean) - 类 com.trs.service.impl.CDSServiceImpl 中的方法
getAllChannelXML() - 类 com.trs.service.impl.SOAPServiceImpl 中的方法
getAllChannelXML() - 接口 com.trs.service.ISOAPService 中的方法
返回系统的站点和频道的所有信息
getAllChildren(User) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
getAllChildrenNodeIds() - 类 com.trs.components.wcm.content.trsserver.TreeNode 中的方法
getAllContents(WCMFilter) - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
Returns all the contents to publish
getAllContents(WCMFilter) - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
getAllContents(WCMFilter) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
getAllContents(WCMFilter) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
getAllContents(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
getAllContents(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
getAllContentsIterator(WCMFilter) - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
getAllContentsIterator(WCMFilter) - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
getAllContentsIterator(WCMFilter) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
getAllContentsIterator(WCMFilter) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
getAllContentsIterator(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
getAllContentsIterator(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
getAllDataTypes() - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.DB2UDB 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.DB2UDB2 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.DBType 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.KingBaseDB 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.MysqlDB 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.OracleDB 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.SQLServerDB 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.SybaseASE 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
取所有的字段数据类型
getAllDataTypes() - 类 com.trs.infra.util.database.XuguDB 中的方法
getAllDocuments(BaseChannel, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
获取当前站点/频道下的所有文档
getAllFileList() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法
getAllFileList() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
getAllFileNameIndex() - 类 com.trs.infra.util.CMyUnZipFile 中的方法
获取ZIP中所有文件的文件名索引
getAllImageFiles(Document) - 类 com.trs.wcm.photo.ImageLibHelper 中的静态方法
getAllIndexes() - 类 com.trs.cms.auth.persistent.RightDefs 中的方法
getAllNodes() - 类 com.trs.scene.tools.SceneNodeAction 中的方法
获取所有node
getAllProperty() - 类 com.trs.infra.persistent.BaseObj 中的方法
获取对象的属性表
getAllRelatedDocumentsByKeywords(String, int, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 中的方法
getAllRelatedDocumentsByKeywords(String, int, WCMFilter) - 接口 com.trs.components.wcm.content.domain.IDocKeywordMgr 中的方法
获取指定文档的所有相关文档
getAllRelatedDocumentsByKeywords(String, int, WCMFilter) - 接口 com.trs.service.IDocumentService 中的方法
getAllRelatedDocumentsByKeywords(String, int, WCMFilter) - 类 com.trs.service.impl.DocumentService 中的方法
getAllRelatedDocumentsByKeywordsFromTRSServer(String, WCMFilter, int) - 类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 中的方法
getAllRelChannelsXmlFiles() - 类 com.trs.template.domain.TemplateXmlGenerator 中的方法
getAllRelFieldsXmlFiles() - 类 com.trs.template.domain.TemplateXmlGenerator 中的方法
getAllRelTemplatesXmlFiles() - 类 com.trs.template.domain.TemplateXmlGenerator 中的方法
getAllSchemas() - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
返回InfoPath模版中定义的全部Schema，存储在一个HashMap中，以XSD文件的文件名作为KEY。
getAllSettings(String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
getAllSettings(String) - 接口 com.trs.template.service.ITemplateService 中的方法
获取所有的配置信息
getAllSettings(String) - 类 com.trs.template.TRSTemplateFacade 中的方法
获取所有的配置信息
getAllSite(String) - 类 com.trs.template.TRSTemplateFacade 中的方法
获取所有的项目称
getAllSites(String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法
getAllSites(String) - 接口 com.trs.template.service.ITemplateService 中的方法
从服务器端获取所有的项目
getAllTags() - 类 com.trs.infra.util.html.HTML 中的静态方法
This is the set of actual html tags that are known about the the default html reader.
getAllTasks(WCMFilter) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
get all the publish tasks in the system
getAllTasks(WCMFilter) - 类 com.trs.service.impl.PublishService 中的方法
getAllTasks(WCMFilter) - 接口 com.trs.service.IPublishService 中的方法
提取所有的发布任务；要求当前用户必须具有管理权限
getAllTaskStatuses() - 类 com.trs.components.common.publish.PublishConstants 中的静态方法
getAllViews() - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
返回包括所有视图的HashMap对象
getAllViewsInOrder() - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
getAlt() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件显示的ALT
getAnalyzeError() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：AnalyzeError
getAnonymous() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回在FTP登录中是否使用匿名方式
getAnotherName() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：AnotherName
getAnotherName() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
提取属性：AnotherName
getAnotherName() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：AnotherName
getApdFilePubHttpPath() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
取附件文件发布后的Http路径，如：/site1/image/
getApdProperty() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件的属性
getApdRels(WCMFilter) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
get the template appendix relations
getAppAutoParameterByName(String) - 类 com.trs.presentation.util.AppAutoParameters 中的方法
根据配置名称获取指定的配置
getAppAutoParameters(String) - 类 com.trs.presentation.util.AppAutoParameters 中的静态方法
根据页面文件获取页面配置参数信息
getAppendixById(int) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
getAppendixDoc(String) - 类 com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter 中的静态方法
getAppendixes(User) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
取模板的附件集合
getAppendixes(User, int[]) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
取模板的附件集合
getAppendixes(WCMFilter) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
根据条件获得当前附件
getAppendixes(Document, int) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
获取当前文档某种类型的附件
getAppendixes(Document, int, WCMFilter) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
获取当前文档某种类型的附件
getAppendixes(Document, WCMFilter) - 类 com.trs.components.wcm.content.domain.AppendixMgr 中的方法
获取当前文档的附件(符合筛选条件)
getAppendixes(Document) - 接口 com.trs.service.IDocumentService 中的方法
获取当前文档的所有附件
getAppendixes(Document, int) - 接口 com.trs.service.IDocumentService 中的方法
获取当前文档的某种类型的附件
getAppendixes(Document, int, WCMFilter) - 接口 com.trs.service.IDocumentService 中的方法
获取当前文档的某种类型的附件
getAppendixes(Document, WCMFilter) - 接口 com.trs.service.IDocumentService 中的方法
获取当前文档的某种类型的附件
getAppendixes(Document) - 类 com.trs.service.impl.DocumentService 中的方法
getAppendixes(Document, int) - 类 com.trs.service.impl.DocumentService 中的方法
getAppendixes(Document, int, WCMFilter) - 类 com.trs.service.impl.DocumentService 中的方法
getAppendixes(Document, WCMFilter) - 类 com.trs.service.impl.DocumentService 中的方法
getAppenDixFieldSize(String) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
获取附件类型的字段中上传了几个附件
getAppendixId() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
提取属性：APPENDIXID
getAppendixList(Document) - 接口 com.trs.service.IInfoViewService 中的方法
从org.dom4j.Document对象中抽取附件信息 作为输入的org.dom4j.Document对象，在抽取附件信息，其中的附件标示信息已经被删除。
getAppendixList(String) - 接口 com.trs.service.IInfoViewService 中的方法
从XML文件中抽取附件信息
getAppendixList(Document) - 类 com.trs.service.impl.InfoViewService 中的方法
getAppendixList(String) - 类 com.trs.service.impl.InfoViewService 中的方法
getAppendixProperty(String, int) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getAppFiles() - 类 com.trs.components.metadata.center.xml.MetaViewDataToExcel 中的方法
getAppFiles() - 类 com.trs.components.metadata.center.xml.MetaViewDataToXML 中的方法
getApplyDesc() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：ApplyDesc
getApplyDesc() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
提取属性：APPLYDESC
getApplyerName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：ApplyerName
getApplyerName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
提取属性：ApplyerName
getApplyerType() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：ApplyerType
getApplyForm() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
getApplyType() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：ApplyType
getAppRootPath() - 类 com.trs.infra.config.TRSConfigServer 中的静态方法
getArg(int) - 类 com.trs.cms.ContextHelper 中的静态方法
获得扩展参数列表中第_nIndex位置上的参数 处理策略：
1.
getArg(int) - 类 com.trs.infra.common.BaseContextHelper 中的静态方法
获得扩展参数列表中第_nIndex位置上的参数 处理策略：
1.
getArg(int) - 类 com.trs.infra.common.ContextTL 中的方法
获取扩展参数列表中第_nIndex个位置上的参数
getArgs() - 类 com.trs.infra.common.ContextTL 中的方法
获得用户自定义的扩展参数列表 处理逻辑：
1.
getArgument(IPublishElement, String) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
getArgument(int, int, String) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
getArgument(String, String) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的方法
getArgumentName() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
提取属性：ArgumentName
getArguments(IPublishElement) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
getArguments(int, int) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法
getArguments(IPublishElement) - 类 com.trs.components.common.publish.domain.template.TemplateArgumentMgr 中的方法
返回指定发布对象上的全部有效模板参数列表
getArgumentValue() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
提取属性：ArgumentValue
getArgumentValue(String, String) - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的方法
getAssociationPerson() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：AssociationPerson
getAsyncMode() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
getAt(int) - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
getAt(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
通过指定索引获取对象
getAt(int) - 类 com.trs.infra.util.CMyErrors 中的方法
取指定位置的错误信息对象
getAt(int) - 类 com.trs.template.persistent.InfoEntities 中的方法
getAttachedFile() - 类 com.trs.infra.util.email.CMyEmail 中的方法
getAttatchedFileList() - 类 com.trs.infra.util.email.CMyEmail 中的方法
getAttribute() - 类 com.trs.cms.content.ExtendedField 中的方法
获得扩展字段的扩展属性
getAttribute(String) - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法
getAttribute() - 类 com.trs.cms.process.definition.Flow 中的方法
getAttribute() - 类 com.trs.components.common.address.Contact 中的方法
属性: Attribute 扩展属性
getAttribute() - 类 com.trs.components.common.address.ContactGrp 中的方法
属性: Attribute 扩展属性
getAttribute() - 类 com.trs.components.common.bookmark.BookMark 中的方法
属性: Attribute 扩展属性
getAttribute() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
属性: Attribute 扩展属性
getAttribute() - 类 com.trs.components.common.bookmark.MarkShare 中的方法
属性: Attribute 扩展属性
getAttribute() - 类 com.trs.components.common.calendar.Event 中的方法
属性: Attribute 扩展属性
getAttribute() - 类 com.trs.components.common.message.Message 中的方法
属性: Attribute 扩展属性
getAttribute(String) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
get a attribute value
getAttribute(String, int) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
get the integer attribute value
getAttribute(String, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
get the boolean attribute value
getAttribute(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
get a attribute value
getAttribute() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件的属性
getAttribute() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
获得扩展字段的扩展属性
getAttribute() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
属性：Attribute 扩展属性
getAttribute() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
提取属性：Attribute
getAttribute(IPublishElement, TagItem, String, int) - 类 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer 中的静态方法
getAttribute() - 类 com.trs.components.wcm.resource.DocKind 中的方法
getAttribute() - 类 com.trs.components.wcm.resource.Source 中的方法
获取属性（用于扩展）
getAttribute() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
提取属性：Attribute
getAttribute() - 类 com.trs.infra.persistent.BaseObj 中的方法
getAttribute() - 类 com.trs.infra.util.cabfile.CabEntry 中的方法
getAttribute(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取指定名称的属性对象
getAttributeKey(String) - 类 com.trs.infra.util.html.HTML 中的静态方法
Fetch an attribute constant for a well-known attribute name (i.e. one of the attributes in the set allAttributes).
getAttributes() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
getAttributes() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
getAttributes() - 类 com.trs.infra.util.AttributesString 中的方法
获得属性字符串
getAttributes() - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取元素中所有的属性对象列表
getAttributesMap() - 类 com.trs.infra.util.AttributesString 中的方法
getAttributesString() - 类 com.trs.infra.persistent.BaseObj 中的方法
共用接口：属性创建扩展属性Attribute读操作 说明：子类可以通过重载禁止使用
getAttributeTrim(String) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
get the timmed value of a attribute
getAttributeTrim(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
get the timmed value of a attribute
getAttributeValue(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
获取扩展属性的值
getAttributeValue(String) - 类 com.trs.infra.util.AttributesString 中的方法
取指定名称的属性值 若没有找到该属性，则返回null.
getAttributeValue(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取元素中指定属性的值
getAttributeValues(String) - 类 com.trs.infra.util.AttributesString 中的方法
getAttrInfo(String) - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
返回指定名称的置标属性信息对象。
getAttrInfoCount() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
返回置标属性的个数
getAttrInfos() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
返回置标属性信息对象的，如果该置标没有属性，可以返回null。
getAuditor() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取审稿者(可能有多个)
getAuditorName() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取审稿者(可能有多个)
getAuthor() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件的作者
getAuthor() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
获取作者信息
getAuthorName() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取作者
getAutoSaveConfig(WebSite) - 类 com.trs.components.wcm.content.domain.AutoDocBakMgr 中的方法
getAutoSaveConfig(int) - 接口 com.trs.service.IAutoDocBakService 中的方法
获取指定站点上所有关于文档版本自动保存的配置信息
getAutoSaveConfig(int) - 类 com.trs.service.impl.AutoDocBakService 中的方法
getAvailableChannels(User, int) - 类 com.trs.components.metadata.service.DefaultChannelMakerCenter 中的方法
获取当前用户在指定视图下可用的栏目,根据视图，获取视图绑定的栏目，在过滤到没有权限的栏目
getBakTable4WcmRight() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
getBakTime() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
获取备份时间
getBakTime() - 类 com.trs.infra.support.log.LogBak 中的方法
获取备份时间
getBakUser() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
获取备份用户对象
getBakUserName() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
获取备份用户
getBakUserName() - 类 com.trs.infra.support.log.LogBak 中的方法
获取备份用户
getBaseChannelEntities(int) - 类 com.trs.template.domain.InfoEntityFinder 中的方法
getBaseChannelInfoFilePath(int) - 类 com.trs.template.domain.SourcePathHelper 中的静态方法
getBaseDir() - 类 com.trs.template.domain.XTemplateExporter.HierarchyEntity 中的方法
getBaseName() - 类 com.trs.components.infoview.extract.DataType 中的方法
getBaseType() - 类 com.trs.components.infoview.extract.DataType 中的方法
getBatchMode() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeShip 中的方法
getBcc() - 类 com.trs.infra.util.email.CMyEmail 中的方法
getBean() - 类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 中的方法
getBean() - 类 com.trs.infra.ServerConfig 中的方法
根据 beanId得到对应bean
getBean() - 类 com.trs.infra.util.CMyBeanConfig 中的方法
getBean() - 类 com.trs.infra.util.CMyClassConfig 中的方法
getBean(String) - 类 com.trs.SpringBean 中的方法
getBean() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
获得表单对象所对应的实例
getBeanClass(String) - 类 com.trs.SpringBean 中的方法
getBeanClassName(String) - 类 com.trs.DreamFactory 中的静态方法
getBeanClassName(String) - 类 com.trs.SpringBean 中的方法
getBeanConfigCollection() - 类 com.trs.infra.config.BeanConfigServer 中的方法
得到所有Bean的集合[BeanConfig]
getBeanConfigCollection(String) - 类 com.trs.infra.config.BeanConfigServer 中的方法
得到指定Id的Plugin下的Bean的集合[BeanConfig]
getBeanConfigXmlInputStream() - 类 com.trs.infra.config.domain.BeanConfigHelper 中的方法
得到所有SpringBeand的inputStream，特用于SpringBean的创建
getBeanDefinitionNames() - 类 com.trs.DreamFactory 中的静态方法
getBeanDefinitionNames() - 类 com.trs.SpringBean 中的方法
getBeanId() - 类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 中的方法
getBeanId() - 类 com.trs.infra.ServerConfig 中的方法
getBeanId() - 类 com.trs.infra.support.cache.CacheMgrConfig 中的方法
getBeanId() - 类 com.trs.infra.util.CMyBeanConfig 中的方法
getBeanInfo() - 类 com.trs.components.comment.publish.tagparser.XWCMTagParserComment 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser 中的方法
getBeanInfo() - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser 中的方法
返回置标解析器的自我描述 实现建议，置标解析器的实现应该定义一个静态成员变量，并通过该方法返回，以避免不必要的对象创建。
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserCMSObj 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserCondition 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserDateTime 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPage 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserDetailPages 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserEcho 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserNestedTemplate 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserNewIcon 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserOddOrEven 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserOnlyLogic 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserPageNav4Detail 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserRepeat 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserSequenceNumber 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserSystemConfig 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserUnimpl 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserUser 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariable 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableEnum 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.domain.tagparser.TagParserVariableSet 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlInChnlOperation 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserChnlOperation 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocOperation 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserLayout 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPageStyle 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserPreWidget 中的方法
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserResources 中的方法
置标属性定义
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialAppendix 中的方法
置标属性定义
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserSpecialLogo 中的方法
置标属性定义
getBeanInfo() - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserTagCreator 中的方法
getBeanInfo() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoView 中的方法
getBeanInfo() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewData 中的方法
getBeanInfo() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewHelper 中的方法
getBeanInfo() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNav 中的方法
getBeanInfo() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的方法
getBeanInfo() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewPage 中的方法
getBeanInfo() - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的方法
getBeanInfo() - 类 com.trs.components.metadata.publish.WCMTagParserAppendix 中的方法
getBeanInfo() - 类 com.trs.components.metadata.publish.WCMTagParserClassIndexGener 中的方法
getBeanInfo() - 类 com.trs.components.metadata.publish.WCMTagParserClassInfo 中的方法
getBeanInfo() - 类 com.trs.components.metadata.publish.WCMTagParserExistDataOfClassInfo 中的方法
getBeanInfo() - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法
getBeanInfo() - 类 com.trs.components.metadata.publish.WCMTagParserViewData 中的方法
getBeanInfo() - 类 com.trs.components.metadata.publish.WCMTagParserViewField 中的方法
getBeanInfo() - 类 com.trs.components.wcm.epress.TagEBookDirParser 中的方法
getBeanInfo() - 类 com.trs.components.wcm.epress.TagMapAreaParser 中的方法
getBeanInfo() - 类 com.trs.components.wcm.epress.TagParserPageNav 中的方法
getBeanInfo() - 类 com.trs.components.wcm.epress.TagPreNextParser 中的方法
getBeanInfo() - 类 com.trs.components.wcm.epress.WCMTagParserEPressNews 中的方法
getBeanInfo() - 类 com.trs.components.wcm.epress.WCMTagParserExpertNews 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.region.WCMTagParserRegion 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.BaseWCMTagParserPreNextDocuments 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.TagChannelChainParser 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.TagParserCRUser 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImage 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.TagParserWmlImages 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.TagWmlContentParser 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserAppendix 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannel 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserCurPage 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocReply 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocument 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocuments 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserEPressNews 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserIcon 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserMapArea 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserPrev 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserReplace 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRollDocuments 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagparserTopIcon 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSite 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserWebSites 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDcouments 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserXDocument 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.XWCMFileAppendixTagParser 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.XWCMImageAppendixTagParser 中的方法
getBeanInfo() - 类 com.trs.components.wcm.publish.tagparser.XWCMTagParserPageGeneration 中的方法
getBeanInfo() - 类 com.trs.wcm.photo.publish.WCMTagParserImage 中的方法
getBeanInfo() - 类 com.trs.wcmonline.TagParserVipMetaData 中的方法
getBeans() - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
getBeginColumn() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
返回置标的开始位置在模板正文中的列号
getBeginIndex() - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法
getBeginLineNo() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
返回置标的开始位置在模板正文中的行号
getBindAction() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法
getBindElement() - 类 com.trs.components.infoview.extract.DataType 中的方法
getBindname() - 类 com.trs.components.infoview.extract.DataGroup 中的方法
getBindName() - 类 com.trs.components.infoview.extract.DataType 中的方法
getBit(long, int) - 类 com.trs.infra.util.CMyBitsValue 中的静态方法
取指定整型值（int/long）的指定bit位的值
getBit(int) - 类 com.trs.infra.util.CMyBitsValue 中的方法
取指定位置的二进制值
getBitOfInt(int, int) - 类 com.trs.infra.util.CMyBitsValue 中的静态方法
取指定整型值（int/long）的指定bit位的值
getBody() - 类 com.trs.components.common.message.Message 中的方法
属性: Body 内容
getBody() - 类 com.trs.infra.util.email.CMyEmail 中的方法
getBodyAsStream() - 类 com.trs.infra.util.ResponseBuddy 中的方法
getBodyAsString() - 类 com.trs.infra.util.ResponseBuddy 中的方法
getBodyCablet(String, TRSResultSet, String) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的静态方法
getBodyContent(String) - 类 com.trs.cms.content.HTMLContent 中的静态方法
getBodyType() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Returns the content body type
getBodyType() - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法
getBodyType() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法
getBodyType() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法
getBodyType() - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法
getBodyType() - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法
getBodyType() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
getBonus(String, int) - 类 com.trs.components.stat.StatBonusResultForUser 中的方法
获取指定用户所获得的指定类型的奖金
getBonusType() - 类 com.trs.components.stat.BonusRule 中的方法
提取属性：BonusType，奖金类型：其中1表示发稿量奖金，2表示点击量奖金
getBookMarks(int, WCMFilter) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
获取当前登录用户的书签
getBookMarks(MarkKind, WCMFilter) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
getBookMarks(WCMFilter) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
getBookMarks(User) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
取所有该类别的书签集合
getBookMarks(int, WCMFilter) - 接口 com.trs.service.IBookMarkService 中的方法
根据传入的MarkKind ID，获取它所包含的BookMarks
getBookMarks(WCMFilter) - 接口 com.trs.service.IBookMarkService 中的方法
获取BookMarks集合
getBookMarks(int) - 接口 com.trs.service.IBookMarkService 中的方法
根据传入的MarkKind ID，获取它所包含的BookMarks
getBookMarks(int) - 类 com.trs.service.impl.BookMarkService 中的方法
getBookMarks(int, WCMFilter) - 类 com.trs.service.impl.BookMarkService 中的方法
getBookMarks(WCMFilter) - 类 com.trs.service.impl.BookMarkService 中的方法
getBoolean(String, boolean) - 类 com.trs.presentation.util.RequestHelper 中的方法
取布尔型属性值 说明：0值为false，非0值为true
getBooleanAttribute(String, boolean) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
get the boolean attribute value
getBooleanExtraAttribute(String, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Returns the boolean extra property.
getBooleanProperty(Map, String, boolean) - 类 com.trs.infra.util.PropertiesUtil 中的静态方法
get the boolean property value
getBooleanValue() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
将属性值转化为boolean值
getBranch() - 类 com.trs.cms.process.engine.FlowContext 中的方法
获取当前操作轨迹的分支
getBranch() - 类 com.trs.cms.process.engine.FlowParamers 中的方法
getBranchComeFrom(User) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取文档流转到当前状态经过的分支
getBranchId() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：BranchId
getBranchInfo(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
getBranchs(User) - 类 com.trs.cms.process.definition.FlowNode 中的方法
取得节点上的所有工作流分支集合
getBranchSerialNum() - 类 com.trs.cms.process.engine.FlowContext 中的方法
getBranchSerialNum() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
getBranchTo(User, FlowNode) - 类 com.trs.cms.process.definition.FlowNode 中的方法
获得当前节点到指定节点的分支
getBuffer(int) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
取指定缓冲区
getBuffer(Class) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
getBuffer(Class) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法
getBuffer(int) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法
getBuildTime() - 类 com.trs.infra.BaseServer 中的方法
getBuildTime() - 接口 com.trs.infra.IServer 中的方法
build时间
getBusyCount() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法
getButton() - 类 com.trs.components.infoview.extract.manifest.MenuArea 中的方法
getById(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
通过指定Id获取对象
getByName(String) - 类 com.trs.cms.auth.persistent.Users 中的方法
通过用户名从集合中获取用户对象
getByName(String) - 类 com.trs.cms.process.definition.Flows 中的方法
根据工作流名称获取工作流
getByName(String, int) - 类 com.trs.components.common.address.ContactGrps 中的方法
通过名字取得ContactGrp对象
getByName(String, int) - 类 com.trs.components.common.bookmark.BookMarks 中的方法
通过名称从集合中获取用户对象 若成功，集合指针定位到该元素； 否则，指针指向POS_EOF
getByName(String, int) - 类 com.trs.components.common.bookmark.MarkKinds 中的方法
通过名称从集合中获取对象 若成功，集合指针定位到该元素； 否则，指针指向POS_EOF
getByName(String) - 类 com.trs.components.common.job.Schedules 中的方法
getBytesLength(String) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserDocument 中的静态方法
getBytesLength(String) - 类 com.trs.infra.util.CMyString 中的静态方法
计算字符串所占的字节数； 说明：英文和数字字符长度记1；中文字符长度记2。
getCache() - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
getCachedObjectClass() - 类 com.trs.infra.persistent.cache.CachedObjectConfig 中的方法
getCachedResults(int) - 类 com.trs.components.wcm.stat.StatResultHolder 中的方法
getCacheIndex() - 类 com.trs.infra.persistent.BaseObj 中的方法
返回当前对象的CacheIndex
getCacheIndex() - 类 com.trs.infra.persistent.BaseObjs 中的方法
getCacheIndex(Class) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
getCacheIndex(String) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
getCacheIndex(Class) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法
getCacheIndex(String) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法
getCacheKey() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
返回用于在缓存标识当前对象的key，因为和BaseObj.getKey()的缺省返回类型不同,为了避免不必要的错误， 没有覆盖BaseObj.getKey()方法，而是使用了新的方法名称。
getCacheKey() - 类 com.trs.components.infoview.config.EnumCreator 中的方法
getCacheKey() - 类 com.trs.components.infoview.config.LinkedEnumCreator 中的方法
getCacheMaxSize() - 类 com.trs.components.common.publish.domain.template.TemplateParseMgr 中的方法
Returns the maximum size of the cache.
getCacheScheme() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
getCacheSize() - 类 com.trs.infra.util.database.DBIdManager.IdSeq 中的方法
获得缓冲区大小
getCachObject(String) - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
getCalculatedField(String) - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
返回计算目标为指定数据项的表达式，如果没有表达式以指定的数据项为目标，则返回null。
getCanCustom() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回是否可以定制变量取值
getCanMgrUsers(int, WCMFilter) - 类 com.trs.service.impl.UserService 中的方法
获取我所能管理的用户
getCanMgrUsers(int, WCMFilter) - 接口 com.trs.service.IUserService 中的方法
获取我可管理的用户
getCanSavedDocStatus(User) - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
获取可以进行自动保存的文档状态
getCanSavedDocStatusIds() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
获取可以进行自动保存的文档状态ID序列
getCaption() - 类 com.trs.components.infoview.extract.manifest.FileNew 中的方法
已过时。
getCaption() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法
getCaption() - 类 com.trs.components.infoview.extract.manifest.View 中的方法
getCastTypeName(int) - 类 com.trs.infra.util.database.DBType 中的方法
Get the name of the database type appropriate for casting operations (via the CAST() SQL function) for the given Types typecode.
getCaSvrURL() - 类 com.trs.presentation.ids.CAUserSync 中的方法
从系统设置中获取CA服务回调的URL设置.
getCategory() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
提取属性：Category
getCause() - 类 com.trs.webframework.config.LoadingErrorReport 中的方法
getCc() - 类 com.trs.infra.util.email.CMyEmail 中的方法
getCDefaultStyle() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：CDefaultStyle
getCellIndex() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
提取属性：CellIndex
getCellNum() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
提取属性：CellNum
getCenterX() - 类 com.trs.cms.process.definition.FlowNode 中的方法
获取X坐标（用于可视化编辑）
getCenterY() - 类 com.trs.cms.process.definition.FlowNode 中的方法
获取Y坐标（用于可视化编辑）
getCertificateCode() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：CertificateCode
getCertificateName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：CertificateName
getChangeStatus() - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法
getChannel() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
取主题所属频道对象
getChannel() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
getChannel() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
获取文档当前所处的栏目
getChannel() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
获取所属栏目
getChannel() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
取文档所属频道对象
getChannel() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
取文档所属频道对象
getChannel() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
获取所属频道
getChannel() - 类 com.trs.components.wcm.content.trsserver.TreeNode 中的方法
getChannel() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取文档当前所处的栏目
getChannel() - 类 com.trs.service.InfoViewContext 中的方法
getChannel() - 类 com.trs.wcm.old.WCMExcelData 中的方法
取所属频道对象
getChannel() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
获取表单的所属频道对象
getChannelByName(int, String) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
根据栏目名称取栏目
getChannelChildrenXML(int, int, boolean) - 类 com.trs.service.impl.SOAPServiceImpl 中的方法
getChannelChildrenXML(int, int, boolean) - 接口 com.trs.service.ISOAPService 中的方法
获取指定站点指定频道的配置信息
getChannelDesc() - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
getChannelId() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：ChannelId
getChannelID() - 类 com.trs.components.comment.domain.Management 中的方法
返回WCM中的频道ID
getChannelId() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
提取属性：ChannelId
getChannelId() - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法
getChannelId() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
getChannelID() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
getChannelId() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getChannelId() - 类 com.trs.components.stat.ChnlDept 中的方法
提取属性：ChannelId
getChannelId() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
提取属性：ChannelId
getChannelId() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
取使用此文档的所在的频道
getChannelId() - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的方法
getChannelId() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getChannelId() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
提取属性：ChannelId
getChannelId() - 类 com.trs.presentation.nav.TreeNodeCalctor 中的方法
getChannelId() - 类 com.trs.service.InfoViewContext 中的方法
getChannelId() - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
getChannelId() - 类 com.trs.wcm.old.WCMExcelData 中的方法
取所属的频道
getChannelId() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
获取表单所属的频道ID
getChannelIds() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
getChannelIdsWithRight(String) - 类 com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker 中的方法
getChannelIdsWithRight() - 类 com.trs.components.wcm.content.trsserver.ChannelsWithRightMaker 中的方法
getChannelName() - 类 com.trs.components.comment.domain.Management 中的方法
返回WCM中的频道名
getChannelName() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取所属栏目
getChannelName() - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
getChannelRightValue(User, BaseChannel) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserBaseOperation 中的方法
获取栏目的权限
getChannels(int, int, boolean) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
取当前站点下某类型的栏目集合
getChannels(int, WCMFilter) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
取符合一定条件的栏目集合
getChannels(Document, int, String) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
获取所有与文档相关的频道
getChannels() - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
获取当前登录用户定制的频道集合
getChannels(String) - 类 com.trs.components.wcm.epress.EPressConf 中的方法
getChannels(int) - 类 com.trs.components.wcm.epress.EPressConf 中的方法
getChannels(WCMFilter, boolean) - 类 com.trs.components.wcm.recent.RecentMgr 中的方法
获得用户最近访问的频道列表，按访问时间逆序排列
getChannels() - 接口 com.trs.service.ICustomizeService 中的方法
获取当前用户定制的频道集合
getChannels(int) - 接口 com.trs.service.ICustomizeService 中的方法
获取当前用户定制的并且有指定操作权限的频道集合
getChannels(Document) - 接口 com.trs.service.IDocumentService 中的方法
获得实体文档相关的引用、镜像等对应的所有频道
getChannels() - 类 com.trs.service.impl.CustomizeService 中的方法
getChannels(int) - 类 com.trs.service.impl.CustomizeService 中的方法
getChannels(Document) - 类 com.trs.service.impl.DocumentService 中的方法
getChannels(WCMFilter) - 类 com.trs.service.impl.RecentService 中的方法
getChannels(WCMFilter, boolean) - 类 com.trs.service.impl.RecentService 中的方法
getChannels(WCMFilter, boolean, int) - 类 com.trs.service.impl.RecentService 中的方法
getChannels(WCMFilter) - 接口 com.trs.service.IRecentService 中的方法
返回用户最近访问的频道列表
按照访问的时间顺序排序
getChannels(WCMFilter, boolean) - 接口 com.trs.service.IRecentService 中的方法
返回用户最近访问的频道列表
按照访问的时间顺序排序
getChannels(WCMFilter, boolean, int) - 接口 com.trs.service.IRecentService 中的方法
获取用户最近访问的频道集合,并校验访问指定权限.
getChannels(User, int) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
获取指定用户可见的图片库的一级分类
getChannels(User, int, Channel) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
获取指定用户在指定分类可见的子分类列表
getChannels(User, int, Channel, WCMFilter) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
获取指定用户在指定分类可见的子分类列表
getChannels(User, int) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
getChannels(User, int, Channel) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
getChannels(User, int, Channel, WCMFilter) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
getChannelsUseingFlow(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
获取使用了指定工作流的栏目列表
getChannelsUseingFlow(Flow, BaseObjs, int, String, WCMFilter) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
获取使用指定工作的指定类型的对象
getChannelsWithRight(WCMFilter) - 类 com.trs.service.impl.RecentService 中的方法
getChannelsWithRight(WCMFilter) - 接口 com.trs.service.IRecentService 中的方法
获取用户最近访问的频道集合,并校验访问权限.
getChannelsXML(BaseChannel, boolean) - 接口 com.trs.service.ICDSService 中的方法
获取指定站点或频道的树状结构信息
getChannelsXML(BaseChannel, boolean) - 类 com.trs.service.impl.CDSServiceImpl 中的方法
getChannelSyns(Channel, WCMFilter) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法
getChannelSyns(Channel, WCMFilter, boolean) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法
getChannelSyns(int, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
getChannelSyns(int, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
getChannelXML(String) - 类 com.trs.components.wcm.newshoo.DataFromRadar 中的方法
getChannelXML(int) - 类 com.trs.service.impl.SOAPServiceImpl 中的方法
getChannelXML(int) - 接口 com.trs.service.ISOAPService 中的方法
获取指定频道的信息
getChar() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
返回当前字符,但是不移动指针
getCharSet() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获取模板的charset设置,如果模板本身没有设置,则返回从所属Folder所设置的发布语言.
getCharset() - 类 com.trs.infra.util.ResponseBuddy 中的方法
getChartCategory() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
getChartCategoryNames() - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态方法
getChartFileExt() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
getChartHeight() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
getChartMineTypeNames() - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态方法
getChartSubtitle() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
getChartTitle() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
getChartWidth() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法
getCharViewWidth(int) - 类 com.trs.infra.util.CMyString 中的静态方法
返回指定字符的显示宽度，在目前的实现中，认为一个英文字符的显示宽度是1，一个汉字的显示宽度是2。
getCheckedUserId() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法
提取属性：CheckedUser
getChecksum() - 类 com.trs.infra.util.jazzlib.CheckedInputStream 中的方法
Returns the Checksum object used.
getChecksum() - 类 com.trs.infra.util.jazzlib.CheckedOutputStream 中的方法
Returns the Checksum object used.
getChild(String) - 类 com.trs.infra.persistent.XmlObject 中的方法
getChild(String) - 类 com.trs.infra.util.CMyXMLElement 中的方法
getChild(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取第一个指定名称的子元素
getChildAt(int) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
getChildAt(BaseChannel, int) - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
getChildAt(BaseChannel, int) - 接口 com.trs.components.wcm.content.persistent.IChildrenMgr 中的方法
getChildIndex(PublishTagContext) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 中的静态方法
Returns the value of property ChildIndex in tag item.
getChildIndex(TagItem) - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserHelper 中的静态方法
Returns the value of property ChildIndex in tag item.
getChildren(User, BaseChannel, WCMFilter) - 类 com.trs.ajaxservice.ChannelHelper 中的静态方法
getChildren(Group) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
获取子组织
getChildren(Group, WCMFilter) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
获取子组织
getChildren() - 接口 com.trs.cms.auth.domain.IRightHost 中的方法
获取当前对象的一级子对象
getChildren(User) - 类 com.trs.cms.auth.persistent.Group 中的方法
取组的子组集合
getChildren(User, String) - 类 com.trs.cms.auth.persistent.Group 中的方法
获取按照指定的排序方式排序的组的子组集合
getChildren(User, WCMFilter) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取当前轨迹的子轨迹列表
getChildren() - 类 com.trs.components.common.address.ContactGrp 中的方法
取组的子对象
getChildren(MarkKind, WCMFilter) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
获取当前书签分类的子分类
getChildren() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
getChildren() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
get the children folders
getChildren() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
getChildren() - 类 com.trs.components.infoview.extract.DataType 中的方法
getChildren() - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法
getChildren() - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法
getChildren() - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法
getChildren() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
获取当前对象的一级子分类
getChildren(boolean) - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
getChildren(int) - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法
获取指定分类的所有一级子分类
getChildren(int, boolean) - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法
getChildren(int, boolean) - 接口 com.trs.components.metadata.definition.IClassInfoCacheMgr 中的方法
getChildren(int) - 接口 com.trs.components.metadata.definition.IClassInfoCacheMgr 中的方法
getChildren() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
getChildren() - 类 com.trs.components.wcm.channel.VChannel 中的方法
getChildren() - 类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 中的方法
getChildren() - 类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 中的方法
getChildren() - 类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 中的方法
getChildren(BaseChannel, int, boolean, WCMFilter) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
getChildren(User, int) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
获取当前对象某种类型的子频道
getChildren(User, int[]) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
获取当前对象某几种类型的子频道
getChildren(User) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
getChildren() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
getChildren() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法
getChildren() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
getChildren(User) - 类 com.trs.components.wcm.resource.DocKind 中的方法
getChildren() - 类 com.trs.infra.util.CMyXMLElement 中的方法
getChildren(String) - 类 com.trs.infra.util.CMyXMLElement 中的方法
getChildren() - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取所有的子元素
getChildren(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取指定名称的子元素列表
getChildren() - 类 com.trs.scene.tools.SceneNode 中的方法
获取子节点
getChildren(int, WCMFilter) - 接口 com.trs.service.IBookMarkService 中的方法
根据传入的MarkKind ID，获取它的子MarkKinds
getChildren(BaseChannel, int, int) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道的子频道集合(不包含已删除的子频道)
getChildren(BaseChannel, int, int[]) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道的子频道集合(不包含已删除的子频道)
getChildren(BaseChannel, int, int[], StringBuffer) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道的子频道集合(不包含已删除的子频道)
getChildren(BaseChannel, int) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)
getChildren(BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限
getChildren(Group) - 接口 com.trs.service.IGroupService 中的方法
获取某个组的子组集合
getChildren(Group, boolean, WCMFilter) - 接口 com.trs.service.IGroupService 中的方法
getChildren(Group, boolean) - 接口 com.trs.service.IGroupService 中的方法
getChildren(int, WCMFilter) - 类 com.trs.service.impl.BookMarkService 中的方法
getChildren(BaseChannel, int, int) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道的子频道集合(不包含已删除的子频道)
getChildren(BaseChannel, int, int[]) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道的子频道集合(不包含已删除的子频道)
getChildren(BaseChannel, int, int[], StringBuffer) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道的子频道集合(不包含已删除的子频道)
getChildren(BaseChannel, int) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道)
getChildren(BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道的子频道集合(所有类型,但不包含已删除的子频道);不具体校验用户所拥有的权限
getChildren(Group) - 类 com.trs.service.impl.GroupService 中的方法
getChildren(Group, boolean) - 类 com.trs.service.impl.GroupService 中的方法
getChildren(Group, boolean, WCMFilter) - 类 com.trs.service.impl.GroupService 中的方法
getChildren() - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法
getChildrenCount() - 类 com.trs.components.wcm.content.trsserver.TreeNode 中的方法
getChildrenNodeIds() - 类 com.trs.components.wcm.content.trsserver.TreeNode 中的方法
getChildrenNodes() - 类 com.trs.components.wcm.content.trsserver.TreeNode 中的方法
getChildrenOf(int) - 类 com.trs.components.wcm.content.persistent.Channels 中的方法
取当前集合ParentId为指定值的子集
getChildrenSize(User) - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
getChildrenSize(User, BaseChannel) - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法
getChildrenSize(User, BaseChannel) - 接口 com.trs.components.wcm.content.persistent.IChildrenMgr 中的方法
获取当前站点/频道的子频道数目
getChildrenSize() - 类 com.trs.infra.persistent.XmlObject 中的方法
getChildTagNames() - 类 com.trs.infra.persistent.XmlObject 中的方法
getChilrenNodes(ArrayList) - 类 com.trs.scene.tools.SceneNodeAction 中的方法
获取当前层节点的所有子节点
getChnlDefaultName(int) - 类 com.trs.components.wcm.wcmx.websites.ChannelRelated 中的静态方法
获取指定的频道类型的默认名称
getChnlDoc() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法
getChnlDoc() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getChnlDocId() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getChnlDocProperties() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getChnlDocProperties() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getChnlDocProperty(String, int) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getChnlDocProperty(String) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getChnlDocProperty(String, int) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getChnlDocProperty(String) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getChnlDocs(WCMFilter, boolean) - 类 com.trs.components.wcm.recent.RecentMgr 中的方法
返回用户最近访问的频道文档列表
按照访问的时间顺序排序
getChnlDocs(WCMFilter) - 类 com.trs.service.impl.RecentService 中的方法
getChnlDocs(WCMFilter, boolean) - 类 com.trs.service.impl.RecentService 中的方法
getChnlDocs(WCMFilter) - 接口 com.trs.service.IRecentService 中的方法
返回用户最近访问的频道文档列表
按照访问的时间顺序排序
getChnlDocs(WCMFilter, boolean) - 接口 com.trs.service.IRecentService 中的方法
返回用户最近访问的频道文档列表
按照访问的时间顺序排序
getChnlId() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
提取属性：ChnlId 栏目ID
getChnlId() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
获取所属栏目Id
getChnlId() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
获取所属频道ID
getChnlId() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
提取属性：CHNLID
getChnlIdsByDep(Group) - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
根据组织获取组织相关的栏目ID列表
getChnlIdsByDep(Group) - 接口 com.trs.components.stat.IChnlDeptMgr 中的方法
根据组织返回栏目的id数组
getChnlIdsByDepts(Groups) - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
通过组织集合查找所有组织相关的栏目
getChnlIdsByDepts(Groups) - 接口 com.trs.components.stat.IChnlDeptMgr 中的方法
根据组织返回栏目的id数组
getChnlName() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
提取属性：ChnlName 栏目名称
getChnlOrderHtml(Channel, User) - 类 com.trs.components.wcm.wcmx.websites.ChannelRelated 中的静态方法
获取设置频道顺序的HTML代码
getChnlProperty() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道属性
getChnlType(int) - 类 com.trs.components.wcm.wcmx.websites.ChannelRelated 中的静态方法
获取频道类型的描述
getCKMServerIP() - 接口 com.trs.components.ckm.ICKMServer 中的方法
getCKMServerIP() - 类 com.trs.components.ckm.TRSCKMServer 中的方法
getCKMServerPassword() - 接口 com.trs.components.ckm.ICKMServer 中的方法
获取CKMServer的Password
getCKMServerPassword() - 类 com.trs.components.ckm.TRSCKMServer 中的方法
getCKMServerPort() - 接口 com.trs.components.ckm.ICKMServer 中的方法
获取CKMServer的IP
getCKMServerPort() - 类 com.trs.components.ckm.TRSCKMServer 中的方法
getCKMServerUserName() - 接口 com.trs.components.ckm.ICKMServer 中的方法
获取CKMServer的UserName
getCKMServerUserName() - 类 com.trs.components.ckm.TRSCKMServer 中的方法
getClassField() - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
getClassId() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：CLASSID
getClassId() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getClassId() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：ClassId
getClassId() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：ClassId
getClassInfo(String) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
getClassInfo(String, String) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
getClassInfo(String, String) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
根据分类法路径查找到指定的分类法
getClassInfo(String) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
根据分类法路径查找到指定的分类法
getClassInfoAsString() - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
getClassInfoDataCountOfChannel(int, int) - 类 com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl 中的方法
getClassInfoDataCountOfChannel(int, int) - 接口 com.trs.components.metadata.publish.IClassInfoCountCacheForPublish 中的方法
getClassInfoDataCountOfSite(int, int) - 类 com.trs.components.metadata.publish.ClassInfoCountCacheForPublishImpl 中的方法
getClassInfoDataCountOfSite(int, int) - 接口 com.trs.components.metadata.publish.IClassInfoCountCacheForPublish 中的方法
getClassInfoId() - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
提取属性：ClassInfoId
getClassInfoMgr() - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法
getClassInfos() - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
获取本次检索的分类统计信息
getClassInfosByName(String) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
通过名称获取分类法对象集合
getClassInfosByName(int, String) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
通过名称获取分类法对象集合
getClassInfosByName(String) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
通过名称获取分类法对象集合
getClassInfosByName(int, String) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
通过名称获取分类法对象集合
getClassInfosUsingMetaView(User, MetaView) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
查询视图oMetaView使用了的所有分类法集合
getClassInfosUsingMetaView(User, MetaView) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
getClassInfoViewMgr() - 类 com.trs.components.metadata.definition.ClassInfoListenerForViewData 中的静态方法
getClassName() - 类 com.trs.cms.auth.config.RightHostConfig 中的方法
getClassName() - 类 com.trs.cms.auth.config.RightObjectConfig 中的方法
getClassName() - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法
getClassName() - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法
getClassName() - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
getClassName() - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法
getClassName() - 类 com.trs.components.common.publish.config.persistent.PublishElementConfig 中的方法
getClassName() - 类 com.trs.components.common.publish.config.persistent.TagFormatterConfig 中的方法
getClassName() - 类 com.trs.components.common.publish.config.PublishElementType 中的方法
getClassName() - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
提取属性：ClassName
getClassname() - 类 com.trs.components.infoview.config.BindingBean 中的方法
getClassName() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：ClassName
getClassName() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：ClassName
getClassName() - 类 com.trs.infra.config.persistent.BeanConfig 中的方法
getClassName() - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法
getClassName(boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法
取该对象的类别名称
getClassName(boolean) - 类 com.trs.infra.persistent.BaseObjs 中的方法
取该对象的类别名称
getClassName() - 类 com.trs.infra.persistent.cache.CachedObjectConfig 中的方法
getClassName() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
getClassName() - 类 com.trs.infra.persistent.listener.MonitorHostConfig 中的方法
getClassName() - 类 com.trs.infra.util.CMyClassConfig 中的方法
getClassName() - 类 com.trs.webframework.config.ServiceFilterConfig 中的方法
getClassName() - 类 com.trs.webframework.config.ServiceListenerConfig 中的方法
getClassNsme() - 类 com.trs.infra.persistent.listener.ObjectMonitored 中的方法
getClassPaths() - 类 com.trs.infra.config.domain.ConfigHelper 中的静态方法
getClassRootFilePath() - 类 com.trs.infra.util.WCMDiscoveryFactory 中的静态方法
获取Class文件的根路径
getClassValue() - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
提取属性：ClassValue
getClob(ResultSet, String) - 类 com.trs.infra.util.database.CAS400CLOB 中的静态方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, int) - 类 com.trs.infra.util.database.CAS400CLOB 中的静态方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, String) - 类 com.trs.infra.util.database.CDB2DBCLOB 中的静态方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, int) - 类 com.trs.infra.util.database.CDB2DBCLOB 中的静态方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, String) - 类 com.trs.infra.util.database.CDB2DBCLOB2 中的静态方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, int) - 类 com.trs.infra.util.database.CDB2DBCLOB2 中的静态方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, String) - 类 com.trs.infra.util.database.CMysqlText 中的静态方法
从数据库中读取Text型字段的值
getClob(ResultSet, int) - 类 com.trs.infra.util.database.CMysqlText 中的静态方法
从数据库中读取Text型字段的值
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.COracleCLOB 中的静态方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.COracleCLOB 中的静态方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.DB2UDB 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.DB2UDB 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.DB2UDB2 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.DB2UDB2 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.DBType 中的方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.DBType 中的方法
从数据库中读取Clob/Text型字段的值
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.MysqlDB 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.MysqlDB 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.OracleDB 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.OracleDB 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.OracleDB11G 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.OracleDB11G 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.SybaseASE 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.SybaseASE 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.SybaseASEText 中的静态方法
根据字段序号提取Clob/text字段内容
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.SybaseASEText 中的静态方法
根据字段名称提取Clob/text字段内容
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
getClob(ResultSet, boolean, int) - 类 com.trs.infra.util.database.XuguDB 中的方法
getClob(ResultSet, boolean, String) - 类 com.trs.infra.util.database.XuguDB 中的方法
getCloseColumn() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
返回置标的结束位置在模板正文中的列号
getCloseLineNo() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
返回置标的结束位置在模板正文中的行号
getCMSObjs() - 类 com.trs.ajaxservice.xmlconvertors.XMLToCMSObj 中的方法
getCode() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
提取属性：CODE
getCode() - 类 com.trs.components.wcm.resource.DocKind 中的方法
getCode() - 异常 com.trs.template.AbstractErrorMessage 中的方法
获取错误号
getColumn() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
返回当前字符的列号
getColumnID() - 类 com.trs.infra.util.database.FieldInfo 中的方法
获取字段的编号
getColumns() - 类 com.trs.components.common.publish.widget.Layout 中的方法
提取属性：Columns
getColumns() - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法
getComAddress() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComAddress公司联系地址
getCombineFile(String[]) - 类 com.trs.tools.CommonResourceBuilder 中的静态方法
getComContact() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComContact联系人
getComConTit() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComConTit
getComCrtime() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComCrtime记录创建时间
getComCruser() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComCruser记录创建人
getComDesc() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComDesc公司介绍信息
getComEmail() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComEmail公司Email
getCommander() - 类 com.trs.infra.update.UpdateCommanderConfig 中的方法
getCommanderClassName() - 类 com.trs.infra.update.UpdateCommanderConfig 中的方法
getComment() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the comment.
getCommentParserEntity(Document, TagItem) - 类 com.trs.components.comment.publish.helper.CommentParserUtil 中的静态方法
getComMobile() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComMobile 公司联系人移动电话
getCommonSize() - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
返回最终输出文件的文件长度，因为图像的高度和宽度都是固定的， 而且输出时不会采用压缩算法，所以最终输出的文件长度是固定的。
getComName() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComName公司名称
getComPeople() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComPeople
getComplexFieldDatas() - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
getComplexFieldDatas() - 类 com.trs.components.infoview.db.XMLContentRender 中的方法
getComplexType() - 类 com.trs.components.infoview.extract.DataType 中的静态方法
getCompressedSize() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the size of the compressed data.
getCompressLength(int) - 类 com.trs.components.metadata.MetaDataConstants 中的静态方法
传入一个数据库字段的长度，获取该字段能存储的数据长度
getComPubN() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComPubN
getComTel() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComTel公司联系电话
getComUrl() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComUrl公司网址
getComZipcode() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComZipcode公司邮编
getComZo() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComZo
getComZone() - 类 com.trs.components.common.trsad.ADCom 中的方法
提取属性：ComZone公司区域
getConditionHandlerConfigs() - 类 com.trs.cms.process.config.FlowConfigServer 中的方法
getConditions(User) - 类 com.trs.cms.process.definition.FlowRule 中的方法
获取规则中设定的所有条件
getConfig() - 类 com.trs.cluster.ClusterConfigHelper 中的静态方法
getConfig(String) - 类 com.trs.components.metadata.service.MailConfigsHelper 中的静态方法
getConfigClass() - 类 com.trs.infra.util.CMyXMLHandler 中的方法
getConfigContent() - 类 com.trs.ajaxservice.ProcessService 中的方法
获取工作流的配置信息
getConfigElements() - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法
getConfigFileContent() - 类 com.trs.cms.process.config.FlowConfigServer 中的方法
获取配置文件的内容
getConfigFileRootElement() - 类 com.trs.cms.process.config.FlowConfigServer 中的方法
getConfigFiles() - 类 com.trs.infra.config.domain.ConfigFilesFinder 中的方法
得到已经组织好的配置文件集合
getConfigID() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpImpl 中的方法
已过时。
getConfigID() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFileLocal 中的方法
getConfigID() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpFtpByTRS 中的方法
getConfigID() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorImpUnion 中的方法
getConfigID() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorLocalImpl 中的方法
已过时。
getConfigID() - 接口 com.trs.components.common.publish.domain.distribute.IFileDistristributor 中的方法
返回相关配置项目的ID
getConfigKey() - 类 com.trs.infra.support.config.Config 中的方法
获取配置主键
getConfigObjects(Class) - 类 com.trs.infra.config.XMLConfigServer 中的方法
依据可配置对象类型，得到对应的配置信息
getConfigObjects(String) - 类 com.trs.infra.config.XMLConfigServer 中的方法
依据可配置对象在配置文件中的ID，得到对应的配置信息
getConfigPath() - 类 com.trs.infra.config.BaseConfigServer 中的方法
getConfigRootFilePath() - 类 com.trs.infra.util.WCMDiscoveryFactory 中的静态方法
获取配置文件的根路径
getConfigRootPath() - 类 com.trs.infra.config.ConfigConstants 中的静态方法
getConfigRootPath() - 类 com.trs.infra.config.TRSConfigServer 中的静态方法
获取配置服务器的根路径
getConfigs() - 类 com.trs.components.metadata.service.MailConfigsHelper 中的静态方法
getConfigs() - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法
getConfigs() - 类 com.trs.infra.support.cache.CacheServer 中的方法
getConfigs() - 类 com.trs.template.TemplateServiceConfig 中的静态方法
获取模板服务器交互接口的配置信息
getConfigServer() - 类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 中的静态方法
getConfigServer() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的静态方法
getConfigValue(String) - 类 com.trs.template.TemplateServiceConfig 中的静态方法
获取指定的主键对应的属性值
getConnection() - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的方法
返回默认的TRSWCM数据库链接
getConnection() - 类 com.trs.components.wcm.content.trsserver.OuterKMTRSServer 中的方法
返回默认的TRSWCM数据库链接
getConnection() - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的方法
取得有效的数据库连接
getConnection() - 类 com.trs.infra.persistent.db.DBManager 中的方法
获取有效的数据库连接
getConnection() - 类 com.trs.infra.util.database.ConnectionPool 中的方法
取得有效的数据库连接
getConnection() - 类 com.trs.infra.util.ftp.FtpConnectionPool 中的方法
getConnectionCache(PublishDistribution) - 类 com.trs.components.common.publish.domain.distribute.UftpConnectionCacheManager 中的方法
返回和指定的PublishDistribution相关的FTP连接缓存管理器
getConnectionCache() - 类 com.trs.infra.persistent.db.DBManager 中的方法
返回实际的连接缓冲池对象，便于监控连接缓冲池的状态
getConnectionCache() - 类 com.trs.infra.util.database.ConnectionPool 中的方法
返回实际的连接缓冲池对象，便于监控连接缓冲池的状态
getConnectionPassword() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
getConnectionURL() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
getConnectionUser() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
getConnectionWrapper() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法
返回FTP连接的封装，使用该封装，不需要考虑向缓冲池还回的问题
getConsignUsers(int) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
获取当前用户的托管人
getConsignUsers(User, int) - 类 com.trs.cms.process.FlowServer 中的静态方法
获得指定模块的所有的委托人，默认为公文管理(TrusteeInfo.MODULE_FLOW)
getContactGroups(WCMFilter) - 类 com.trs.components.common.address.ContactMgr 中的方法
获取当前用户的所有联系人分组
getContactGroups(WCMFilter) - 接口 com.trs.service.IContactService 中的方法
获取当前用户的所有联系人分组
getContactGroups(WCMFilter) - 类 com.trs.service.impl.ContactService 中的方法
getContacts(WCMFilter, ContactGrp) - 类 com.trs.components.common.address.ContactMgr 中的方法
获取当前登录用户某个分组的联系人
getContacts(WCMFilter) - 类 com.trs.components.common.address.ContactMgr 中的方法
获取当前登录用户所有的联系人
getContacts(WCMFilter, ContactGrp) - 接口 com.trs.service.IContactService 中的方法
获取当前登录用户某个分组的联系人
getContacts(WCMFilter) - 接口 com.trs.service.IContactService 中的方法
获取当前登录用户所有的联系人
getContacts(WCMFilter, ContactGrp) - 类 com.trs.service.impl.ContactService 中的方法
getContacts(WCMFilter) - 类 com.trs.service.impl.ContactService 中的方法
getContent() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
getContent(int, String, String) - 类 com.trs.components.infoview.helper.InfoViewTemplateHelper 中的静态方法
getContent() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getContent() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
获取回复内容
getContent() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档的文本正文
getContent() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
获取替换内容
getContent() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取文档的文本正文
getContent() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
提取属性：Content
getContent() - 类 com.trs.infra.util.CMySMS 中的方法
获取短信息内容
getContent() - 类 com.trs.infra.util.html.HtmlDocument 中的方法
获取内容
getContent() - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取元素中所有内容列表
getContent() - 类 com.trs.infra.util.html.HtmlElementFinder 中的方法
取Html内容
getContent() - 类 com.trs.template.domain.setting.AbstractTemplateSetting 中的方法
getContent() - 接口 com.trs.template.domain.setting.ITemplateSetting 中的方法
getContentAddEditPage() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取内容的编辑页面
getContentAddEditPage() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
getContentAddEditPage() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
getContentAddEditPage() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
getContentClass() - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
getContentFields() - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
getContentFiles() - 类 com.trs.template.domain.setting.AbstractTemplateSetting 中的方法
getContentFiles() - 接口 com.trs.template.domain.setting.ITemplateSetting 中的方法
getContentFlow() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
getContentFlowId() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法
getContentId() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
getContentId() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
get the property of ContentId
getContentIds() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
get the property of ContentIds
getContentLength() - 类 com.trs.infra.util.ResponseBuddy 中的方法
getContentLinks(WebSite, WCMFilter) - 类 com.trs.components.wcm.content.domain.ContentLinkMgr 中的方法
获取当前站点的所有内容超链接
getContentLinks(int, WCMFilter) - 类 com.trs.components.wcm.content.domain.ContentLinkMgr 中的方法
获取指定站点下的内容超链接
getContentLinks(WebSite, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
getContentLinks(WebSite, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
getContentListPage() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
getContents() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
获取Task所关联的内容集合
getContentShowPage() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取内容的查看页面
getContentShowPage() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
getContentShowPage() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
getContentShowPage() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
getContentsInFlow(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
获取在指定的工作流中流转的内容列表
getContentsOfUser(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
获取需要用户处理的内容
getContentStyle() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：ContentStyle
getContentStyleAndResource(Widget, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleAndResourceMgr 中的方法
获取内容风格和资源的关系
getContentStyleAndResourceMap(Widget, WCMFilter) - 接口 com.trs.components.common.publish.widget.IStyleAndResourceMgr 中的方法
getContentStyleAndResourceMap(Widget, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleAndResourceMgr 中的方法
获取内容风格和资源的关系
getContentStyles(Widget, WCMFilter) - 接口 com.trs.components.common.publish.widget.IStyleAndResourceMgr 中的方法
获取资源对应的内容可用风格
getContentStyles(Widget, WCMFilter) - 类 com.trs.components.common.publish.widget.StyleAndResourceMgr 中的方法
getContentType() - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
getContentType() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
getContentType() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取当前流转内容的类型
getContentType() - 类 com.trs.cms.process.QueryFlowDocContext 中的方法
getContentType() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
get the property of ContentTypeConfig
getContentType() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
get the property of ContentTypeConfig
getContentType() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
getContentType() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
getContentType() - 类 com.trs.infra.util.ResponseBuddy 中的方法
getContentTypeConfig() - 类 com.trs.cms.process.config.FlowContentField 中的方法
getContentTypeConfigs() - 类 com.trs.cms.process.config.FlowConfigServer 中的方法
getContentTypes() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
getContext() - 类 com.trs.cluster.TRSWCMClusterServer 中的方法
getContextCacheData(Object) - 类 com.trs.webframework.context.MethodContext 中的方法
获取MethodContext对象中放入临时缓存的对象
getContextCacheData(Object) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
获取MethodContext对象中放入临时缓存的对象
getContextMenuArea() - 类 com.trs.components.infoview.extract.manifest.View 中的方法
getContextMenuForBinding(String) - 类 com.trs.components.infoview.extract.manifest.View 中的方法
getContextMenuForXMLToEdit(String) - 类 com.trs.components.infoview.extract.manifest.View 中的方法
getContextMenuMap() - 类 com.trs.components.infoview.extract.manifest.View 中的方法
getConvertorType() - 类 com.trs.webframework.config.MethodConfig 中的方法
getConvertorValue() - 类 com.trs.webframework.config.MethodConfig 中的方法
getConvertToImageType() - 类 com.trs.wcm.photo.ImageInfo 中的方法
getCount() - 类 com.trs.presentation.login.SessionListener 中的静态方法
getCountOfViewDatas() - 类 com.trs.util.ResetClassInfoOfViewData 中的方法
getCrc() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the crc of the uncompressed data.
getCreatedTime() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Returns the created time of this content.
getCreatedTime() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
getCreatedTime() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法
getCreatedTime() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
getCreatorName() - 接口 com.trs.components.metadata.center.IMetaDataFieldValueCreator 中的方法
产生器的名称
getCreatorName() - 类 com.trs.components.metadata.service.GovInfoIndexCreator 中的方法
getCrTime() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
提取属性：CrTime
getCrTime() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：CrTime
getCrTime() - 类 com.trs.infra.persistent.BaseObj 中的方法
共有接口：获取创建时间crtime 说明：子类可以通过重载禁止使用
getCrtParamsCount() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法
getCrUser() - 类 com.trs.cms.content.CMSObj 中的方法
getCrUser() - 接口 com.trs.cms.process.IFlowContent 中的方法
getCrUser() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
getCrUser() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
getCrUserById() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
getCrUserId() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
提取属性：CrUserId
getCrUserId() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：CrUserId
getCrUserName() - 类 com.trs.cms.content.CMSObj 中的方法
共用接口：属性创建用户CrUser读操作 说明：子类可以通过重载禁止使用
getCryptoImpls(String) - 类 com.trs.infra.support.security.SecureKeyUtil 中的静态方法
getCryptoImplsBy(String, String) - 类 com.trs.infra.support.security.SecureKeyUtil 中的静态方法
getCssFlag() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
提取属性：风格标识
getCssFlag() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
提取属性：风格标识
getCssFlag() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
提取属性：CssFlag
getCssTemplateFilePath() - 类 com.trs.components.common.publish.widget.StyleHelper 中的静态方法
获取样式模板所在路径
getCssTemplateFilePath() - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态方法
获取风格样式文件的模板文件路径
getCurrADFiles() - 类 com.trs.components.common.trsad.ADPos 中的方法
得到本广告位的当前可用广告的记录集
getCurrChannel() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
返回当前栏目
getCurrChannelOrSite() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getCurrChannelOrSite() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
getCurrChannelOrSite() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getCurrChannelOrSite() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
getCurrChannels() - 类 com.trs.components.metadata.service.WCMFilterMakerForContainsChildren 中的方法
getCurrContext() - 类 com.trs.wcm.old.ImportDocsFromFile 中的方法
返回上下文对象
getCurrent() - 类 com.trs.infra.persistent.BaseObjs 中的方法
获得当前元素对象
getCurrentFlowDoc(int, int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
getCurrentFlowDoc(int, int) - 接口 com.trs.service.IWCMProcessService 中的方法
getCurrentInfoViewContext() - 类 com.trs.service.InfoViewContext 中的静态方法
getCurrentLocale() - 类 com.trs.presentation.locale.LocaleServer 中的静态方法
getCurrentObj() - 类 com.trs.infra.persistent.XmlObject 中的方法
getCurrentPageIndex() - 类 com.trs.infra.util.CPager 中的方法
获取目前所在的页
getCurrentPageSize() - 类 com.trs.infra.util.CPager 中的方法
获取目前页面的记录数
getCurrentServiceContext() - 类 com.trs.webframework.context.ServiceContext 中的静态方法
getCurrentStartIndex() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
getCurrentStatResult(int, CMyDateTime, CMyDateTime, String) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
做一个即时统计.模板统计视图不允许.
getCurrentStatResult(int, CMyDateTime, CMyDateTime, String) - 类 com.trs.service.impl.StatService 中的方法
getCurrentStatResult(int, CMyDateTime, CMyDateTime, String) - 接口 com.trs.service.IStatService 中的方法
统计在一个时间段内，符合特定条件的某个统计的结果
对数据库进行实时统计，而不是从统计临时表中取
getCurrentWorker() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 中的方法
返回当前的工作线程数
getCurrFilter() - 类 com.trs.components.metadata.service.WCMFilterMakerForContainsChildren 中的方法
getCurrFlow() - 类 com.trs.cms.process.engine.FlowContext 中的方法
getCurrFlowContext() - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法
getCurrFlowDoc() - 类 com.trs.cms.process.engine.ExecuteContext 中的方法
获取当前相关的工作流轨迹
getCurrFlowDoc() - 类 com.trs.cms.process.engine.FlowContext 中的方法
getCurrFlowDoc() - 类 com.trs.cms.process.engine.FlowParamers 中的方法
getCurrFlowFlag(int, int) - 类 com.trs.cms.process.FlowServer 中的方法
getCurrFlowFlag(int, int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
getCurrFlowFlag(int, int) - 接口 com.trs.service.IWCMProcessService 中的方法
getCurrFlowFlagDesc(int, int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
getCurrFlowFlagDesc(int, int) - 接口 com.trs.service.IWCMProcessService 中的方法
getCurrHost() - 类 com.trs.webframework.context.MethodContext 中的方法
getCurrHost() - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法
getCurrImportFile() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
getCurrMediaCount(int, int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
获取指定媒体指定用户累计的条数
getCurrMediaCount() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
提取属性：CurrMediaCount
getCurrNode() - 类 com.trs.cms.process.engine.ExecuteContext 中的方法
获取当前所处节点
getCurrNode() - 类 com.trs.cms.process.engine.FlowContext 中的方法
getCurrPage() - 类 com.trs.infra.persistent.BaseObjs 中的方法
属性提取：当前页码
getCurrSearch() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
getCurrStageField() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
getCurrTrueFileName() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
当前导入的真实文件名
getCurrUser() - 类 com.trs.cms.content.CMSBaseObjs 中的方法
获得CurrUser：当前用户
getCurrUser() - 类 com.trs.cms.process.engine.FlowContext 中的方法
getCurrUser() - 类 com.trs.cms.process.QueryFlowDocContext 中的方法
getCurrUser(User) - 接口 com.trs.components.stat.IUserLoginInfoMgr 中的方法
获取普通用户自己的条件构造
getCurrUser(User) - 类 com.trs.components.stat.UserLoginInfoMgr 中的方法
获取用户自己的构造条件，返回用户名的userId
getCurrUser() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
获取当前的交互用户
getCustomSiteCheckInfo(int, User) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的静态方法
getCustomSiteCheckInfoByIndividuationId(int, User) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的静态方法
getCustomStyle() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
提取属性：自定义样式
getCustomStyle() - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
提取属性：自定义样式
getCustomStyle() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
提取属性：自定义的风格样式
getCutSize() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
获取CutSize
getDailyEvents(CMyDateTime, WCMFilter) - 类 com.trs.components.common.calendar.EventMgr 中的方法
获取当前用户在指定日期的日程安排
getData(String) - 类 com.trs.components.wcm.stat.domain.StatDataItem 中的方法
getDataControl() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getDataDefault() - 类 com.trs.infra.util.database.FieldInfo 中的方法
取默认值，注意：默认值用字符串型表示
getDataId() - 类 com.trs.components.common.trsvote.VoteData 中的方法
提取属性：DataId
getDataLength() - 类 com.trs.infra.util.database.FieldInfo 中的方法
取数据长度
说明：字符串类型的数据有效
getDataMap() - 类 com.trs.components.wcm.stat.domain.StatDataItem 中的方法
getDataMapStr(Map) - 类 com.trs.components.wcm.stat.domain.StatDataItem 中的静态方法
getDataName() - 类 com.trs.components.infoview.extract.DataType 中的方法
getDataPath() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：DataPath
getDataPath() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
getDataPath() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法
getDataPath() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
getDataPath() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
提取属性：DataPath
getDataPath() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
getDataPath() - 类 com.trs.components.wcm.channel.VChannel 中的方法
getDataPath() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取数据存放的本地路径（相对路径）
getDataPath() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
getDataPath() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：DataPath
getDataPath(BaseChannel) - 类 com.trs.components.wcm.publish.WCMPublishHelper 中的静态方法
getDataPath() - 类 com.trs.wcm.photo.ImageKind 中的方法
getDataPattern() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getDataScale() - 类 com.trs.infra.util.database.FieldInfo 中的方法
getDataSet() - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的方法
getDataset() - 类 com.trs.components.wcm.stat.domain.TimingChartProducer 中的方法
getDatasFromTRSServer(int, int) - 类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 中的方法
getDatasFromTRSServer(String, int, int) - 类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 中的方法
getDataType() - 类 com.trs.components.infoview.config.BindingBean 中的方法
getDataType() - 类 com.trs.components.infoview.db.InfoViewDataType 中的方法
getDataType() - 类 com.trs.components.infoview.extract.DataType 中的方法
getDataType() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getDataType() - 类 com.trs.components.metadata.definition.MetaDataType 中的方法
getDataType() - 类 com.trs.infra.persistent.NullValue 中的方法
getDataType(String) - 类 com.trs.infra.util.database.DBType 中的方法
取指定名字的字段数据类型
getDataType() - 类 com.trs.infra.util.database.FieldInfo 中的方法
取数据类型编号
getDataTypeAsInt() - 类 com.trs.components.infoview.extract.DataType 中的方法
getDataTypeAsString() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getDataTypeAt(int) - 类 com.trs.components.infoview.db.InfoViewDataTypes 中的方法
getDataTypeAt(int) - 类 com.trs.components.metadata.definition.MetaDataTypes 中的方法
getDataTypeById(int) - 类 com.trs.components.infoview.db.InfoViewDataTypes 中的方法
getDataTypeById(int) - 类 com.trs.components.metadata.definition.MetaDataTypes 中的方法
getDataTypeDesc() - 类 com.trs.components.infoview.db.InfoViewDataType 中的方法
getDataTypeDesc() - 类 com.trs.components.metadata.definition.MetaDataType 中的方法
getDataTypeName() - 类 com.trs.infra.util.database.FieldInfo 中的方法
取数据类型名称
getDataTypesCount() - 类 com.trs.components.infoview.db.InfoViewDataTypes 中的方法
getDataTypesCount() - 类 com.trs.components.metadata.definition.MetaDataTypes 中的方法
getDataWithSign() - 类 com.trs.components.comment.domain.CommentUpdator 中的方法
返回带有数字签名的数据
getDataWithSign() - 类 com.trs.components.comment.domain.Management 中的方法
返回带有数字签名的数据
getDataWithSign() - 类 com.trs.components.comment.domain.NewsComment 中的方法
返回带有数字签名的数据
getDateTime() - 类 com.trs.infra.util.CMyDateTime 中的方法
将当前对象转换为java.util.Date对象
getDateTime(String, boolean) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
getDateTime(String) - 类 com.trs.presentation.locale.LocaleServer 中的静态方法
已过时。 no need?
getDateTime(String) - 类 com.trs.presentation.util.RequestHelper 中的方法
取日期时间型属性值
getDateTime(String, String) - 类 com.trs.presentation.util.RequestHelper 中的方法
取日期时间型属性值
getDateTimeAsString(String) - 类 com.trs.infra.util.CMyDateTime 中的方法
获取格式化的日期时间字符串
getDateTimeAsString() - 类 com.trs.infra.util.CMyDateTime 中的方法
输出格式化的日期时间字符串
格式：由setDateTimeFormat指定
getDateType() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
getDay() - 类 com.trs.infra.util.CMyDateTime 中的方法
获取当前对象中的【日】的部分
getDayOfWeek() - 类 com.trs.infra.util.CMyDateTime 中的方法
取当前日期是所在week的第几天
说明：一个礼拜的第一天为Monday(0)，最后一天为Sunday(6)
getDB2SQL() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：DB2SQL
getDbBuild() - 类 com.trs.infra.BaseServer 中的方法
getDbBuild() - 接口 com.trs.infra.IServer 中的方法
数据库版本号
getDBConnConfig() - 类 com.trs.infra.persistent.db.DBManager 中的方法
获取当前所使用的数据库配置
getDBConnectionConfigByName(String) - 类 com.trs.infra.persistent.db.DBConnectionMapper 中的方法
依据连接名获取指定的配置信息
getDBConnectionConfigColl() - 类 com.trs.infra.persistent.db.DBConnectionConfigs 中的方法
getDBField() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
getDBFieldByField(int, String, boolean) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
getDBFieldId() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：DBField
getDBFieldsByFields(InfoView, String, boolean) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
获取InfoPath字段名对应的数据库字段名
getDBFieldsByFields(InfoView, String[], boolean) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法
getDBIdManager() - 类 com.trs.infra.persistent.db.DBManager 中的方法
获取数据表ID管理器
getDBKeywords() - 类 com.trs.infra.persistent.db.DBManager 中的方法
getDBManager() - 类 com.trs.infra.persistent.db.DBManager 中的静态方法
getDBName() - 类 com.trs.cms.process.config.FlowContentField 中的方法
getDBName() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：物理字段名称
getDBName() - 类 com.trs.wcm.old.WCMFormFields 中的方法
提取属性：DBName
getDbTableName() - 类 com.trs.ajaxservice.ContentExtendValue 中的方法
getDbTableName() - 类 com.trs.cms.auth.persistent.Group 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.auth.persistent.Right 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.auth.persistent.RightDef 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.auth.persistent.Role 中的方法
获取对象所对应的数据表名
getDbTableName() - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.auth.persistent.User 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.content.CMSObjDefaultImpl 中的方法
getDbTableName() - 类 com.trs.cms.content.DefaultObj 中的方法
getDbTableName() - 类 com.trs.cms.content.ExtendedField 中的方法
对象所对应的数据表名
getDbTableName() - 类 com.trs.cms.content.WCMSystemObject 中的方法
getDBTableName() - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
getDbTableName() - 类 com.trs.cms.process.definition.Flow 中的方法
getDbTableName() - 类 com.trs.cms.process.definition.FlowAction 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.process.definition.FlowNode 中的方法
getDbTableName() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
getDbTableName() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.process.definition.FlowRule 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
getDbTableName() - 类 com.trs.cms.process.engine.FlowDocBak 中的方法
getDbTableName() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.address.Contact 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.common.address.ContactGrp 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.common.bookmark.BookMark 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.common.bookmark.MarkShare 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.common.calendar.Event 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.common.calendar.EventShare 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.calendar.EventType 中的方法
重载父类中的抽象接口函数
getDbTableName() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.job.JobWorkerType 中的方法
getDbTableName() - 类 com.trs.components.common.job.Schedule 中的方法
getDbTableName() - 类 com.trs.components.common.message.Message 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.common.message.MsgQueue 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.common.message.MsgReceiver 中的方法
getDbTableName() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
返回TRS置标解析组件的数据库表名：TagBeans
getDbTableName() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
获得模板附件的数据存储
getDbTableName() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获得模板的数据表
getDbTableName() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
getDbTableName() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.Layout 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.Master 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.Widget 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsad.ADCom 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsad.ADFile 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsad.ADPos 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsad.ADType 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsvote.Vote 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsvote.VoteData 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsvote.VoteItem 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.common.trsvote.VoteOption 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
getDbTableName() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
getDbTableName() - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的方法
getDbTableName() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法
getDbTableName() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getDbTableName() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法
getDbTableName() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
getDbTableName() - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getDbTableName() - 类 com.trs.components.metadata.center.MetaViewEmployer 中的方法
getDbTableName() - 类 com.trs.components.metadata.center.MetaViewEmployers 中的方法
getDbTableName() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.metadata.definition.MetaView 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.special.Special 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.stat.BonusRule 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.stat.ChnlDept 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.stat.HostObjDomain 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.stat.UserLoginInfo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.content.persistent.Relation 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.XDocument 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.persistent.XDocuments 中的方法
getDbTableName() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getDbTableName() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
重载父类中定义的抽象接口函数
getDbTableName() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 中的方法
getDbTableName() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.recent.Recent 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.resource.DocKind 中的方法
getDbTableName() - 类 com.trs.components.wcm.resource.FileType 中的方法
getDbTableName() - 类 com.trs.components.wcm.resource.Keyword 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.resource.Security 中的方法
getDbTableName() - 类 com.trs.components.wcm.resource.Source 中的方法
getDbTableName() - 类 com.trs.components.wcm.resource.Status 中的方法
getDbTableName() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.stat.StatHost 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.stat.StatView 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.db.update.DBUpdateLog 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.infra.persistent.BaseObj 中的方法
获得数据库中存储该对象的数据表名称。
getDbTableName() - 类 com.trs.infra.persistent.CMyResultSet 中的方法
getDbTableName() - 类 com.trs.infra.persistent.MyBaseObj 中的方法
getDbTableName() - 类 com.trs.infra.support.config.Config 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.infra.support.log.Log 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.infra.support.log.LogBak 中的方法
getDbTableName() - 类 com.trs.infra.support.log.OperType 中的方法
getDbTableName() - 类 com.trs.infra.support.security.SecureKey 中的方法
getDbTableName() - 类 com.trs.infra.util.job.JobFailedResult 中的方法
getDbTableName() - 类 com.trs.wcm.config.PageOperator 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.wcm.old.WCMExcelData 中的方法
getDbTableName() - 类 com.trs.wcm.old.WCMFormFields 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
取对象数据存储的数据表名称
getDbTableName() - 类 com.trs.wcm.photo.Watermark 中的方法
取对象数据存储的数据表名称
getDBType() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：DBType
getDBType() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：DBType
getDBType() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法
依据当前连接配置对象的className属性，获取DBType对象实例
getDBType() - 类 com.trs.infra.persistent.db.DBManager 中的方法
获取当前的数据库类型对象的实现（对象的路径由配置文件中定义）
getDBType() - 类 com.trs.infra.util.database.CDBText 中的方法
获取数据库类型对象
getDBType(int) - 类 com.trs.infra.util.database.DBTypes 中的静态方法
通过指定数据库类型获取数据库类型对象
getDbtype() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
getDBTypeAsInt() - 类 com.trs.infra.persistent.db.DBManager 中的方法
getDBTypeDesc() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：DBTypeDesc
getDBTypeDesc() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：DBTypeDesc
getDealContent() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
提取属性：DealContent
getDealTime() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：DEALTIME
getDealType() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：DEALTYPE
getDefault() - 类 com.trs.presentation.util.PageParameter 中的方法
获取默认值
getDefault() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
获取默认值
getDefaultAsBoolean(boolean) - 类 com.trs.presentation.util.PageParameter 中的方法
将默认值转换为布尔型
getDefaultAsBoolean(boolean) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
将默认值转换为布尔型
getDefaultAsDateTime() - 类 com.trs.presentation.util.PageParameter 中的方法
将默认值转换为日期类型
getDefaultAsDateTime() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
将默认值转换为日期类型
getDefaultAsDouble(double) - 类 com.trs.presentation.util.PageParameter 中的方法
将默认值转换为双精度
getDefaultAsDouble(double) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
将默认值转换为双精度
getDefaultAsFloat(float) - 类 com.trs.presentation.util.PageParameter 中的方法
将默认值转换为浮点数
getDefaultAsFloat(float) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
将默认值转换为浮点数
getDefaultAsInt(int) - 类 com.trs.presentation.util.PageParameter 中的方法
将默认值转换为整型数
getDefaultAsInt(int) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
将默认值转换为整型数
getDefaultAsLong(long) - 类 com.trs.presentation.util.PageParameter 中的方法
将默认值转换为长整型
getDefaultAsLong(long) - 类 com.trs.webframework.config.TRSPageParameter 中的方法
将默认值转换为长整型
getDefaultBmpConverType(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
getDefaultCols() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
获取默认检索字段
getDefaultCols() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
获取本次检索的检索字段
getDefaultConnection() - 类 com.trs.infra.persistent.db.DBConnectionConfigs 中的方法
getDefaultConvertImageFileExt() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取默认转换的图片格式
getDefaultConvertImageFileExt() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
getDefaultDBConnectionConfig() - 类 com.trs.infra.persistent.db.DBConnectionMapper 中的方法
获取当前选择的连接的配置信息
getDefaultDetailTemplate() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
getDefaultDetailTemplate() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取图片库分类默认的细览模板
getDefaultDetailTemplate() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
getDefaultDetailTemplateId() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取图片库分类默认的细览模板ID
getDefaultDetailTemplateId() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
getDefaultEncoding() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
getDefaultEncoding() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the default file encoding.
getDefaultInfoviewPrintTemplate() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
getDefaultOutlineTemplate(IPublishFolder) - 接口 com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr 中的方法
getDefaultOutlineTemplate(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法
getDefaultOutlineTemplate() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法
getDefaultOutlineTemplate(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
Returns the default outline template of the specified folder.
getDefaultOutlineTemplate() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取图片库分类默认的概览模板
getDefaultOutlineTemplate() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
getDefaultOutlineTemplateId() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
getDefaultOutlineTemplateId() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取图片库分类默认的概览模板ID
getDefaultOutlineTemplateId() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法
getDefaultSMTPServer() - 类 com.trs.infra.util.email.CMySMTPServer 中的静态方法
从配置文件中，得到默认的SMTP服务器的配置
getDefaultSMTPServer() - 类 com.trs.infra.util.email.SMTPServerConfigs 中的方法
getDefaultSMTPServerConfig() - 类 com.trs.infra.util.email.SMTPServerConfigMapper 中的方法
获取当前选择的SMTP服务器配置信息
getDefaultStyle() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的静态方法
getDefaultValue() - 类 com.trs.cms.content.ExtendedField 中的方法
获取扩展字段的默认值
getDefaultValue() - 类 com.trs.cms.process.config.ParamConfig 中的方法
getDefaultValue() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
返回属性的缺省值
getDefaultValue() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：DefaultValue
getDefaultValue() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getDefaultValue() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：DefaultValue
getDefaultValue() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：DefaultValue
getDefaultValue() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
获取扩展字段的默认值
getDefaultValueAsInt(int) - 类 com.trs.cms.content.ExtendedField 中的方法
取整型默认值
getDefaultValueAsInt(int) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
取整型默认值
getDefaultView() - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
返回缺省视图对象
getDelcols() - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
获取被删除的列
getDelegatedContext() - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 中的方法
getDelegatedContext() - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser4List 中的方法
返回被托管的（下一个）PublishTagContext对象，如果已经没有下一个对象， 即游标已经移动到最后，则返回或者 null。
getDelegatedContext() - 类 com.trs.components.metadata.publish.WCMTagParserClassInfos 中的方法
getDelegatedContext() - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法
getDelegatedContext() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 中的方法
getDelegatedContext() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法
getDelegatedContext() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法
getDeleteOp(BaseObj) - 类 com.trs.cms.logger.OperTypeHelper 中的静态方法
getDeletePage() - 接口 com.trs.cms.process.IFlowContent 中的方法
getDeletePage() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
getDeletePage() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
getDelFunc(Document, Channel) - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 中的静态方法
获取删除文件的Javascript
getDelim() - 类 com.trs.infra.util.AttributesString 中的方法
getDepartment() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：Department
getDepartmentInfo(User) - 类 com.trs.cms.auth.domain.DepartmentMgrImpl 中的方法
getDepartmentInfo(User, String) - 类 com.trs.cms.auth.domain.DepartmentMgrImpl 中的方法
getDepartmentInfo(User) - 接口 com.trs.cms.auth.domain.IDepartmentMgr 中的方法
获取指定用户的所属部门描述信息，多级默认以/分隔
getDepartmentInfo(User, String) - 接口 com.trs.cms.auth.domain.IDepartmentMgr 中的方法
获取指定用户的所属部门描述信息，多级以_sDelimit指定的分隔符分开，默认为\
getDependIndexs(int) - 类 com.trs.cms.auth.config.RightConfigServer 中的方法
getDependIndexs() - 类 com.trs.cms.auth.config.RightConfigServer 中的方法
getDepends() - 类 com.trs.cms.auth.config.OperationConfig 中的方法
getDepIdsByChannel(Channel) - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
通过栏目获取组织的ID序列
getDepIdsByChannel(Channel) - 接口 com.trs.components.stat.IChnlDeptMgr 中的方法
根据栏目返回组织的id数组
getDepNamesByChannel(Channel, User) - 类 com.trs.components.stat.ChnlDeptMgr 中的方法
通过栏目或用户获取组织名称
getDepNamesByChannel(Channel, User) - 接口 com.trs.components.stat.IChnlDeptMgr 中的方法
根据栏目获取组织名称或者用户获取组织
getDeptGroups(User) - 类 com.trs.cms.auth.domain.DepartmentMgrImpl 中的方法
getDeptGroups(User) - 接口 com.trs.cms.auth.domain.IDepartmentMgr 中的方法
获取指定用户所属的组织结构
getDeptGroupTree(User) - 类 com.trs.cms.auth.domain.DepartmentMgrImpl 中的方法
getDeptGroupTree(User) - 接口 com.trs.cms.auth.domain.IDepartmentMgr 中的方法
获取指定用户的所属部门组织树，按照树形结构组织
getDeptMgrsByGrpIds(String) - 类 com.trs.cms.process.engine.FlowUserHelper 中的静态方法
获取指定部门的部门经理(管理员)
getDeptMgrsByGrpName(String) - 类 com.trs.cms.process.engine.FlowUserHelper 中的静态方法
获取指定部门的部门经理(管理员)
getDeptMgrsOfUserx(User) - 类 com.trs.cms.process.engine.FlowUserHelper 中的静态方法
获取用户所属部门的部门经理(管理员)
getDesc() - 类 com.trs.cms.auth.config.OperationConfig 中的方法
getDesc() - 类 com.trs.cms.auth.persistent.Group 中的方法
获取组的描述
getDesc() - 类 com.trs.cms.auth.persistent.RightDef 中的方法
getDesc() - 类 com.trs.cms.auth.persistent.Role 中的方法
获取角色描述
getDesc() - 类 com.trs.cms.content.ExtendedField 中的方法
获得扩展字段描述信息
getDesc() - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法
getDesc() - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法
getDesc() - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法
getDesc() - 类 com.trs.cms.process.config.ParamConfig 中的方法
getDesc() - 类 com.trs.cms.process.config.ValueConfig 中的方法
getDesc() - 类 com.trs.cms.process.definition.Flow 中的方法
获取工作流描述
getDesc() - 类 com.trs.cms.process.definition.FlowNode 中的方法
获取节点描述
getDesc() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取当前流转内容的简要描述
getDesc() - 类 com.trs.components.common.address.Contact 中的方法
属性: Desc 详细描述
getDesc() - 类 com.trs.components.common.address.ContactGrp 中的方法
属性: Desc 详细描述
getDesc() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
属性: Desc 详细描述
getDesc() - 类 com.trs.components.common.calendar.Event 中的方法
属性: Desc 详细描述
getDesc() - 类 com.trs.components.common.calendar.EventType 中的方法
Desc: 详细描述
getDesc() - 类 com.trs.components.common.job.JobWorkerType 中的方法
getDesc() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：描述
getDesc() - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 中的方法
getDesc() - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
getDesc() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
返回属性的详细描述
getDesc() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
返回置标的详细描述
getDesc() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
提取属性：Desc
getDesc() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：Desc
getDesc() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获得模板的描述
getDesc() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
getDesc() - 类 com.trs.components.infoview.config.BindingBean 中的方法
getDesc() - 类 com.trs.components.infoview.config.GatewayPage 中的方法
getDesc() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
getDesc() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getDesc() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法
getDesc() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回视图的描述
getDesc() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
提取属性：Desc
getDesc() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
提取属性：Desc
getDesc() - 类 com.trs.components.metadata.definition.MetaView 中的方法
提取属性：Desc
getDesc() - 类 com.trs.components.wcm.channel.VChannel 中的方法
getDesc() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件描述
getDesc() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
获取对象的描述
getDesc() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道描述
getDesc() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
提取属性：LogicFieldDesc
getDesc() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
获取描述
getDesc() - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法
getDesc() - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法
getDesc() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取站点的描述
getDesc() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
getDesc() - 类 com.trs.components.wcm.process.element.MyFlowContentDocumentImpl 中的方法
getDesc() - 类 com.trs.components.wcm.resource.DocKind 中的方法
getDesc() - 类 com.trs.components.wcm.resource.FileType 中的方法
getDesc() - 类 com.trs.components.wcm.resource.Security 中的方法
获取描述
getDesc() - 类 com.trs.components.wcm.resource.Source 中的方法
获取来源描述
getDesc() - 类 com.trs.components.wcm.resource.Status 中的方法
获取状态描述
getDesc() - 类 com.trs.infra.persistent.CMyParameter 中的方法
getDesc() - 类 com.trs.infra.support.config.Config 中的方法
获取配置描述信息
getDesc() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取日志描述
getDesc() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志描述
getDesc() - 类 com.trs.infra.support.log.LogType 中的方法
获取描述
getDesc() - 类 com.trs.infra.support.log.OperType 中的方法
getDesc() - 类 com.trs.presentation.util.PageParameter 中的方法
获取参数描述
getDesc() - 类 com.trs.wcm.config.PageOperator 中的方法
提取属性：Desc
getDesc() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
提取属性：Desc
getDesc() - 类 com.trs.wcm.photo.ImageKind 中的方法
getDesc() - 类 com.trs.webframework.config.MethodConfig 中的方法
getDesc() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
获取参数描述
getDescription() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
提取属性：Description
getDescription() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
提取属性：Description
getDescription() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
提取属性：Description
getDescription() - 类 com.trs.components.common.message.MessageSendingConfig 中的方法
getDescription() - 异常 com.trs.template.AbstractErrorMessage 中的方法
获取错误描述
getDescription() - 类 com.trs.template.persistent.TagFieldInfoEntity 中的方法
getDescWithPos() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
返回置标的名称并附加上置标的开始位置在模板正文中的行和列信息的字符串描述
getDesiredWorker() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 中的方法
返回完成发布任务所预期的最佳工作线程数
getDetailExt() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取细览页面的扩展名
getDetailFields() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
细览页面字段列表
getDetailFile() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道细览文件名
getDetailFileExt() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
提取属性：DetailFileName
getDetailFileExt() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：DetailFileExt
getDetailFileNamedStyle(String) - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
getDetailFileNamedStyle() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
getDetailOpenType() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
getDetailPageCount() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
getDetailPageCount() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
getDetailPageCount() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
返回共计发布了多少细览页面
getDetailTemplate(IPublishElement) - 接口 com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr 中的方法
getDetailTemplate(int, int) - 接口 com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr 中的方法
getDetailTemplate(IPublishElement) - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法
getDetailTemplate(int, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法
getDetailTemplate(IPublishElement) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
Returns the detail template of the specified publish element.
getDetailTemplate(int, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
getDetailTemplate(IPublishElement, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
getDetailTemplate() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Returns the detail template of this content.
getDetailTemplate() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
get the detail template of the current folder.
getDetailTemplate() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
getDetailTemplate() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法
getDetailTemplate() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法
getDetailTemplate() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
getDetailTemplate(PublishPageContext) - 类 com.trs.components.infoview.helper.InfoViewTemplateHelper 中的静态方法
getDetailTemplate() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
getDetailTemplate() - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 中的方法
getDetailTemplate(IPublishElement) - 类 com.trs.service.impl.TemplateService 中的方法
getDetailTemplate(IPublishElement) - 接口 com.trs.service.ITemplateService 中的方法
获得指定频道的细览模板
getDetailTemplateId() - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 中的方法
getDetailTemplateId() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：DetailTemplateId
getDetailTemplateId() - 类 com.trs.wcm.photo.ImageKind 中的方法
getDetailTemplateType() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
getDFieldInfos(User, MetaDBTable, WCMFilter) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
获取指定表的指定字段列表
getDFieldInfos(User, MetaDBTable, WCMFilter) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法
getDiff4Dest() - 类 com.trs.infra.util.upgrade.dbcompare.SchemaCompare 中的方法
获取目标库相对于源库的差异
只会计算一次,缓存比较结果.
getDiff4Source() - 类 com.trs.infra.util.upgrade.dbcompare.SchemaCompare 中的方法
获取源库相对于目标库的差异
只会计算一次,缓存比较结果.
getDigitCount() - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
返回输出的验证码的宽度
getDigitImage() - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
返回素材图片的文件名
getDirDividedByDateFormat() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
getDirDividedByDateFormat(boolean) - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the format to divide publish directory.
getDirection() - 类 com.trs.cms.process.engine.FlowParamers 中的方法
返回流转方向，只有两种可能：前向或者打回
getDiscovery() - 类 com.trs.infra.util.WCMDiscoveryFactory 中的静态方法
获取当前系统的Discovery
getDisp() - 类 com.trs.components.wcm.resource.Security 中的方法
获取显示名称
getDisp() - 类 com.trs.components.wcm.resource.Status 中的方法
获取状态显示内容
getDispDesc() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
返回频道/站点的页面显示 说明：如果Desc为空则提取Name
getDisplay() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Token 中的方法
返回可用值的显示信息
getDisplayFieldType() - 类 com.trs.components.infoview.extract.DataType 中的方法
getDisplayName() - 类 com.trs.components.infoview.extract.DataType 中的方法
getDispName() - 类 com.trs.cms.auth.config.OperationConfig 中的方法
getDistributionConfig() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the distribution configuration.
getDistributionsOf(IPublishFolder, boolean, WCMFilter) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionMgr 中的方法
get the publish distributions of the specified folder.
getDistributionTargetTypes() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the distribution target types mapping.
getDistributionTargetTypes() - 类 com.trs.service.impl.WCMPublishElementServiceImpl 中的方法
getDistributionTargetTypes() - 接口 com.trs.service.IWCMPublishElementService 中的方法
Returns the distribution target type name collection iterator.
getDistributor() - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 中的方法
getDistributorClassName() - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
getDistributorUnion(IPublishFolder) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
返回指定目录上的分发点的聚合
getDistributorUnion(int, int) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
返回指定目录上的分发点的聚合
getDistributorUnion() - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionList 中的方法
返回有效分发点的聚合
getDocActions() - 类 com.trs.cms.process.definition.FlowNode 中的方法
获取在节点上定义的能够进行的文档操作（CMyBitsValue）
getDocActionsAsInt() - 类 com.trs.cms.process.definition.FlowNode 中的方法
获取在节点上定义的能够进行的文档操作（int）
getDocBak(Document, int) - 类 com.trs.components.wcm.content.domain.DocBakMgr 中的方法
取文档某个版本的备份
getDocBak(Document, int) - 接口 com.trs.service.IDocumentService 中的方法
获取当前文档指定版本的备份
getDocBak(Document, int) - 类 com.trs.service.impl.DocumentService 中的方法
getDocBaks(Document) - 接口 com.trs.service.IDocumentService 中的方法
获取当前文档的备份
getDocBaks(Document, WCMFilter) - 接口 com.trs.service.IDocumentService 中的方法
获取当前文档的备份
getDocBaks(Document) - 类 com.trs.service.impl.DocumentService 中的方法
getDocBaks(Document, WCMFilter) - 类 com.trs.service.impl.DocumentService 中的方法
getDocChannel() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getDocChannel() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getDocChannel(Document) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
getDocChannelId() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
提取属性：DocChannelId
getDocChannelId() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getDocChannelId() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getDocContentPattern() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取正文构造器字段
getDocContentString() - 类 com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter 中的静态方法
getDocCrTime() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
提取属性：DocCrTime 文档创建时间
getDocCrUser() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
提取属性：DocCrUser 文档创建者
getDocEndTime() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
属性提取：文档结束时间
getDocId() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法
getDocId() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
提取属性：DocId 文档ID
getDocId() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件所属文档编号
getDocId() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
提取属性：DocId
getDocId() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
获取备份的文档ID
getDocId() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
获取回复所属的文档ID
getDocId() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
getDocId() - 类 com.trs.components.wcm.content.persistent.Relation 中的方法
获取相关文档对象所属文档的ID
getDocId() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
getDocId() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
提取属性：DocId
getDocIdFieldName() - 类 com.trs.components.wcm.content.persistent.XDocuments 中的方法
getDocIds() - 类 com.trs.components.stat.StatBonusResultForUser 中的方法
getDocOrder() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
提取属性：DocOrder
getDocOrderPri() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
获得置顶的顺序，如果没有置顶，则返回产量NOT_ON_TOP
getDocOrderPri(boolean) - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
getDocPubTime() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
提取属性：DocPubTime
getDocPubURL() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
提取属性：DocPubURL
getDocStartTime() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
属性提取：文档执行时间
getDocStatus(Document, int) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
获取当前文档在所有频道下的状态
getDocTitle() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
提取属性：DocTitle 文档标题
getDocTitle() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
提取属性：DocTitle
getDocument() - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
getDocument() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
getDocument() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法
getDocument() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getDocument() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
取文档所属频道对象
getDocument() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法
getDocument() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
getDocument() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
取属性所属文档对象
getDocument() - 类 com.trs.infra.util.html.HtmlComment 中的方法
获取所在的HtmlDocument
getDocument() - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取所在的文档对象
getDocument() - 类 com.trs.service.InfoViewContext 中的方法
getDocument() - 类 com.trs.wcm.old.WCMExcelData 中的方法
获取所属的文档对象
getDocumentFieldSyn(String) - 类 com.trs.components.metadata.center.DocumentFieldsSynFactory 中的静态方法
根据关键字获取IDocumentFieldsSyn对象
getDocumentId() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
提取属性：DocumentId
getDocumentId() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法
getDocumentId() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getDocumentId() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
getDocumentId() - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的方法
getDocumentId() - 类 com.trs.service.InfoViewContext 中的方法
getDocumentMgr() - 类 com.trs.service.impl.InfoViewDocImportService 中的方法
getDocumentOperators(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
获取进入当前栏目的文档列表时针对于当前栏目的操作
getDocumentOperators(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
getDocumentRefrences(MethodContext) - 类 com.trs.ajaxservice.ViewDocumentServiceProvider 中的方法
getDocuments(Channel, MethodContext) - 接口 com.trs.components.infoview.mad.InfoViewQueryHelper 中的方法
getDocuments(Channel, MethodContext) - 类 com.trs.components.infoview.mad.InfoViewQueryHelperImpl 中的方法
getDocuments(BaseChannel, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
取站点/频道的(除了回收站外的)文档集合
getDocuments(Channel, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
getDocuments(Channel, WCMFilter, boolean) - 类 com.trs.components.wcm.content.domain.DocumentsGetHelper 中的静态方法
getDocuments(WCMFilter) - 类 com.trs.components.wcm.content.domain.UserDocumentMgr 中的方法
获取个人的所有有效文档
getDocuments(WCMFilter, boolean) - 类 com.trs.components.wcm.recent.RecentMgr 中的方法
获得用户最近访问的文档列表，按访问时间逆序排列
getDocuments(String, String) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
getDocuments(int) - 接口 com.trs.service.IChannelService 中的方法
获取当前频道下的有效文档
getDocuments(int, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取当前频道下的有效文档
getDocuments(BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道下的有效文档
getDocuments(BaseChannel, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道下的有效文档
getDocuments(int) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前频道下的有效文档
getDocuments(int, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前频道下的有效文档
getDocuments(BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道下的有效文档
getDocuments(BaseChannel, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道下的有效文档
getDocuments(WCMFilter) - 类 com.trs.service.impl.RecentService 中的方法
getDocuments(WCMFilter, boolean) - 类 com.trs.service.impl.RecentService 中的方法
getDocuments() - 类 com.trs.service.impl.UserService 中的方法
getDocuments(WCMFilter) - 类 com.trs.service.impl.UserService 中的方法
getDocuments(WCMFilter) - 接口 com.trs.service.IRecentService 中的方法
返回用户最近访问的文档列表
由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
getDocuments(WCMFilter, boolean) - 接口 com.trs.service.IRecentService 中的方法
返回用户最近访问的文档列表
由于需要按照时间的顺序排序，所以需要提供单独的接口进行查询
getDocuments() - 接口 com.trs.service.IUserService 中的方法
获取当前登录用户创建的有效文档集合
getDocuments(WCMFilter) - 接口 com.trs.service.IUserService 中的方法
获取当前登录用户创建的有效文档集合,设定查询条件
getDocuments(BaseChannel, WCMFilter) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
获取当前分类下所有的图片
getDocuments(BaseChannel, WCMFilter) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
getDocumentsByChannelId(int, int, int) - 类 com.trs.presentation.portal.PortalHelper 中的静态方法
得到频道的文档 for portal/portal_documents_of_channel.jsp
getDocumentsCount() - 类 com.trs.components.wcm.content.trsserver.TreeNode 中的方法
getDocumentsQuoteImage(int) - 接口 com.trs.wcm.photo.IImageLibMgr 中的方法
获取使用指定图片的所有文档
getDocumentsQuoteImage(int) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
获取使用指定图片的所有文档
getDocumentsQuoteImage(int) - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 中的方法
getDocumentsQuoteImage(int) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
getDocumentStatus(String) - 类 com.trs.components.infoview.helper.InfoViewQueryHelper 中的静态方法
getDocumentSynChnlDocFields() - 类 com.trs.components.wcm.WCMAppConfig 中的方法
getDocumentTitle(InfoView, Document) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
getDocumentTitle(InfoView, Document, String) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
getDocumentTitle(InfoView, Document) - 接口 com.trs.service.IInfoViewService 中的方法
按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题
getDocumentTitle(InfoView, String) - 接口 com.trs.service.IInfoViewService 中的方法
按照相关表单的设定从XML文件抽取文档的标题
getDocumentTitle(InfoView, Document, String) - 接口 com.trs.service.IInfoViewService 中的方法
按照相关表单的设定从XML内容（org.dom4j.Document对象）抽取文档的标题
getDocumentTitle(InfoView, Document) - 类 com.trs.service.impl.InfoViewService 中的方法
getDocumentTitle(InfoView, String) - 类 com.trs.service.impl.InfoViewService 中的方法
getDocumentTitle(InfoView, Document, String) - 类 com.trs.service.impl.InfoViewService 中的方法
getDocumentTitle(InfoView, String, String) - 类 com.trs.service.impl.InfoViewService 中的方法
getDocumentTitleForUserName(InfoView, Document, String) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
getDocumentTopic(int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法
getDocumentTopic(int, int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法
getDocumentTopic(int) - 类 com.trs.components.comment.service.CommentService 中的方法
getDocumentTopic(int, int) - 类 com.trs.components.comment.service.CommentService 中的方法
getDocumentTopic(int) - 接口 com.trs.components.comment.service.ICommentService 中的方法
getDocumentTopic(int, int) - 接口 com.trs.components.comment.service.ICommentService 中的方法
getDocumentTopTime(Document, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
获得文档置顶的截止时间
如果文档没有置顶，则直接返回null
如果置顶文档没有设置截止时间则返回null
getDocumnent() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
getDOM4JDocument() - 类 com.trs.components.infoview.extract.manifest.View 中的方法
getDOM4JDocument(String) - 接口 com.trs.service.IInfoViewService 中的方法
将XML文件的内容转化为org.dom4j.Document对象
getDOM4JDocument(String) - 类 com.trs.service.impl.InfoViewService 中的方法
getDomainConfigPaths() - 类 com.trs.infra.config.domain.ConfigHelper 中的静态方法
getDomCacheMaxSize() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法
getDoubleValue() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
将属性值转化为双精度数
getDowithTemplateFile() - 类 com.trs.infra.util.TRSJspAutoTool 中的方法
getDraft(WCMFilter) - 类 com.trs.components.wcm.content.domain.UserDocumentMgr 中的方法
获取个人草稿
getDraft() - 类 com.trs.service.impl.UserService 中的方法
getDraft(WCMFilter) - 类 com.trs.service.impl.UserService 中的方法
getDraft() - 接口 com.trs.service.IUserService 中的方法
获取当前登录用户创建的草稿集合
getDraft(WCMFilter) - 接口 com.trs.service.IUserService 中的方法
获取当前登录用户创建的草稿集合,设定查询条件
getDriverClass() - 类 com.trs.infra.util.database.DBType 中的方法
取数据库默认的驱动程序库
getEachTaskLaborsMax() - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法
getEditFile() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取编辑文件名
getEditFunc(Document, Channel) - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 中的静态方法
获取编辑文档的Javascript
getEditor() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件的修改人
getEditor() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取修改者
getEditorName() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取修改者名称
getEleAttrs(String, int[], String) - 类 com.trs.wcag2.HTMLUtil 中的静态方法
getEleAttrs(String, String) - 类 com.trs.wcag2.HTMLUtil 中的静态方法
getEleInnerHTML(String, int[]) - 类 com.trs.wcag2.HTMLUtil 中的静态方法
getElement() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
返回被代理的实际对象
getElement() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
元素名称
getElementClass() - 类 com.trs.ajaxservice.ContentExtendValues 中的方法
getElementClass() - 类 com.trs.cms.auth.persistent.GroupRoles 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.auth.persistent.Groups 中的方法
获取用户组的Class(Group.class)
getElementClass() - 类 com.trs.cms.auth.persistent.GroupUsers 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.auth.persistent.ObjectMembers 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.auth.persistent.RightDefs 中的方法
getElementClass() - 类 com.trs.cms.auth.persistent.Rights 中的方法
getElementClass() - 类 com.trs.cms.auth.persistent.Roles 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.auth.persistent.RoleUsers 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.auth.persistent.TrusteeInfos 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.auth.persistent.Users 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.content.DefaultObjs 中的方法
getElementClass() - 类 com.trs.cms.content.ExtendedFields 中的方法
获得扩展字段对象的Class
getElementClass() - 类 com.trs.cms.process.definition.FlowActions 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.process.definition.FlowConditions 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.process.definition.FlowdocLogs 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.process.definition.FlowEmploys 中的方法
getElementClass() - 类 com.trs.cms.process.definition.FlowNodeBranchs 中的方法
getElementClass() - 类 com.trs.cms.process.definition.FlowNodeFields 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.process.definition.FlowNodes 中的方法
getElementClass() - 类 com.trs.cms.process.definition.FlowRules 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.process.definition.Flows 中的方法
getElementClass() - 类 com.trs.cms.process.engine.FlowContentConfigs 中的方法
取集合元素类
getElementClass() - 类 com.trs.cms.process.engine.FlowDocBaks 中的方法
getElementClass() - 类 com.trs.cms.process.engine.FlowDocs 中的方法
getElementClass() - 类 com.trs.components.comment.persistent.DocumentTopics 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.comment.persistent.TopicedDocRelations 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.address.ContactGrps 中的方法
getElementClass() - 类 com.trs.components.common.address.Contacts 中的方法
getElementClass() - 类 com.trs.components.common.bookmark.BookMarks 中的方法
getElementClass() - 类 com.trs.components.common.bookmark.MarkKinds 中的方法
getElementClass() - 类 com.trs.components.common.bookmark.MarkShares 中的方法
getElementClass() - 类 com.trs.components.common.calendar.Events 中的方法
getElementClass() - 类 com.trs.components.common.calendar.EventShares 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.calendar.EventTypes 中的方法
getElementClass() - 类 com.trs.components.common.conjection.persistent.EntryConfigs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.job.JobWorkerTypes 中的方法
getElementClass() - 类 com.trs.components.common.job.Schedules 中的方法
getElementClass() - 类 com.trs.components.common.message.Messages 中的方法
getElementClass() - 类 com.trs.components.common.message.MsgQueues 中的方法
getElementClass() - 类 com.trs.components.common.message.MsgReceivers 中的方法
getElementClass() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTasks 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.persistent.template.TagBeans 中的方法
重载函数：返回置标解析组件的Class
getElementClass() - 类 com.trs.components.common.publish.persistent.template.TempApdRels 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.persistent.template.TempAppendixes 中的方法
获得模板附件的Class
getElementClass() - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的方法
getElementClass() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploys 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.persistent.template.TemplateQuotes 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.persistent.template.Templates 中的方法
getElementClass() - 类 com.trs.components.common.publish.widget.ContentStyles 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.Layouts 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.Masters 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.PageStyles 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.ResourceStyles 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.StyleAndResources 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.StyleItems 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.WidgetInstances 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.WidgetInstParameters 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.WidgetParameters 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.publish.widget.Widgets 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsad.ADComs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsad.ADFilePoss 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsad.ADFiles 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsad.ADPoss 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsad.ADTypes 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsvote.VoteDatas 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsvote.VoteIPLogs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsvote.VoteItems 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsvote.VoteOptions 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.common.trsvote.Votes 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForms 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.gkml.sqgk.persistent.MailConfigs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.infoview.helper.ComplexFieldDatas 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的方法
getElementClass() - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.infoview.persistent.InfoViewEmploys 中的方法
getElementClass() - 类 com.trs.components.infoview.persistent.InfoViewFields 中的方法
getElementClass() - 类 com.trs.components.infoview.persistent.InfoViewGroups 中的方法
getElementClass() - 类 com.trs.components.infoview.persistent.InfoViews 中的方法
getElementClass() - 类 com.trs.components.infoview.persistent.InfoViewViews 中的方法
getElementClass() - 类 com.trs.components.metadata.center.ClassInfoViews 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
getElementClass() - 类 com.trs.components.metadata.center.MetaViewEmployers 中的方法
getElementClass() - 类 com.trs.components.metadata.definition.ClassInfos 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.metadata.definition.MetaDBFields 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.metadata.definition.MetaDBTables 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.metadata.definition.MetaViewFields 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.metadata.definition.MetaViews 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.special.Specials 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.stat.BonusRules 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.stat.ChnlDepts 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.stat.DocumentHitsCounts 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.stat.HostObjDomains 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.stat.HostObjHitsCounts 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.stat.UserLoginInfos 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.content.persistent.Appendixes 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.AutoBakConfigs 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.ChannelContentLinks 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.Channels 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.ChannelSyns 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.content.persistent.ChnlDocs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.content.persistent.ContentExtFields 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.content.persistent.ContentLinks 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.ContentLinkTypes 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.content.persistent.DocBaks 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.DocReplys 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.DocumentSyns 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.HitsCounts 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.content.persistent.Relations 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.Replaces 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.SiteMembers 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.content.persistent.WebSites 中的方法
getElementClass() - 类 com.trs.components.wcm.content.persistent.XDocuments 中的方法
getElementClass() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法
getElementClass() - 类 com.trs.components.wcm.customize.UserSettings 中的方法
getElementClass() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.individuation.Individuations 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.publish.logo.Logos 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.publish.region.CellInfos 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.publish.region.RegionEmploys 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.publish.region.RegionInfos 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.publish.WCMPubStatusConfigs 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.recent.Recents 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.resource.DocKinds 中的方法
getElementClass() - 类 com.trs.components.wcm.resource.FileTypes 中的方法
getElementClass() - 类 com.trs.components.wcm.resource.Keywords 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.resource.Securities 中的方法
getElementClass() - 类 com.trs.components.wcm.resource.Sources 中的方法
getElementClass() - 类 com.trs.components.wcm.resource.Statuses 中的方法
getElementClass() - 类 com.trs.components.wcm.stat.StatFieldMaps 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.stat.StatHosts 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.stat.StatViewRels 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.stat.StatViews 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.wcmx.help.WCMHelps 中的方法
取集合元素类
getElementClass() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfos 中的方法
取集合元素类
getElementClass() - 类 com.trs.db.update.DBUpdateLogs 中的方法
取集合元素类
getElementClass() - 类 com.trs.infra.persistent.BaseObjs 中的方法
取集合元素类
getElementClass() - 类 com.trs.infra.persistent.CMyResultSets 中的方法
getElementClass() - 类 com.trs.infra.persistent.MyBaseObjs 中的方法
getElementClass() - 类 com.trs.infra.support.config.Configs 中的方法
getElementClass() - 类 com.trs.infra.support.log.LogBaks 中的方法
getElementClass() - 类 com.trs.infra.support.log.Logs 中的方法
getElementClass() - 类 com.trs.infra.support.log.OperTypes 中的方法
getElementClass() - 类 com.trs.infra.support.security.SecureKeys 中的方法
getElementClass() - 类 com.trs.infra.util.job.JobFailedResults 中的方法
getElementClass() - 类 com.trs.wcm.config.PageOperators 中的方法
取集合元素类
getElementClass() - 类 com.trs.wcm.old.WCMExcelDatas 中的方法
getElementClass() - 类 com.trs.wcm.old.WCMFormFieldses 中的方法
取集合元素类
getElementClass() - 类 com.trs.wcm.old.WCMFormInfos 中的方法
取集合元素类
getElementClass() - 类 com.trs.wcm.photo.Watermarks 中的方法
取集合元素类
getElementInstance() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
getElements() - 类 com.trs.infra.util.TRSLocaleAuto 中的静态方法
getElements() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
集合名称
getElementsByName(String) - 类 com.trs.infra.util.html.HtmlDocument 中的方法
取文档中指定名字的所有元素
getElementsByName(String) - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取所有指定名字的元素（包括多级子元素）
getElementTag(BaseObj) - 类 com.trs.components.metadata.center.xml.MetaViewDataToExcel 中的方法
getElementTag(BaseObjs) - 类 com.trs.components.metadata.center.xml.MetaViewDataToExcel 中的方法
getElementTag(BaseObj) - 类 com.trs.components.metadata.center.xml.MetaViewDataToXML 中的方法
getElementTag(BaseObjs) - 类 com.trs.components.metadata.center.xml.MetaViewDataToXML 中的方法
getElementTag(BaseObjs) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
getElementTag(BaseObj) - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
getElementType(int) - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
lookup the folder type by type number
getEleOuterHTML(String, int[]) - 类 com.trs.wcag2.HTMLUtil 中的静态方法
getEmail() - 类 com.trs.cms.auth.persistent.Group 中的方法
获取组的邮件地址 说明：若有多个邮件地址，则用";"分割
getEmail() - 类 com.trs.cms.auth.persistent.Role 中的方法
获取角色的邮件（String） 说明：如果有多个邮件，邮件之间通过“;”进行分割。
getEmail() - 类 com.trs.cms.auth.persistent.User 中的方法
获取Email 邮件地址，若有多个，用";"分割
getEmail() - 类 com.trs.components.common.address.Contact 中的方法
属性: Email 邮件 说明：若有多个邮件地址，则不同邮件地址之间用","分割
getEmail() - 类 com.trs.components.common.address.ContactGrp 中的方法
属性: Email
getEmail() - 类 com.trs.components.common.calendar.Event 中的方法
属性: Email 若有多个邮件，则用","分割
getEmail() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：Email
getEmails() - 类 com.trs.cms.auth.persistent.Role 中的方法
获取角色的邮件（StringTokenizer）
getEmbeddedViews(StatView) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
得到一个模板类视图的所有子视图（嵌入式）
getEmbeddedViews(int) - 类 com.trs.service.impl.StatService 中的方法
getEmbeddedViews(int) - 接口 com.trs.service.IStatService 中的方法
得到一个模板类视图的所有子视图（嵌入式）
getEmbedViewId() - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
提取属性：EmbedViewId
getEmployedFlows(BaseObj) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
get the flows collection employed by the publish element.
getEmployedInfoViews(CMSObj) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
getEmployedInfoViews(int, int) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
TODO Add javadoc for field getEmployedInfoViews
getEmployedInfoViews(int, int, WCMFilter) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法
TODO Add javadoc for field getEmployedInfoViews
getEmployedInfoViews(CMSObj) - 接口 com.trs.service.IInfoViewService 中的方法
获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合
getEmployedInfoViews(int, int) - 接口 com.trs.service.IInfoViewService 中的方法
获取指定的雇主（通常是频道）雇佣的全部自定义表单的集合
getEmployedInfoViews(CMSObj) - 类 com.trs.service.impl.InfoViewService 中的方法
getEmployedInfoViews(int, int) - 类 com.trs.service.impl.InfoViewService 中的方法
getEmployer() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
get the employer instance
getEmployer() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
get the employer instance
getEmployer() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
get the employer instance
getEmployer() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法
getEmployerId() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
提取属性：EmployerId
getEmployerId() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
提取属性：EmployerId
getEmployerId() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
提取属性：EmployerId
getEmployerId() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法
getEmployers(Flow, WCMFilter) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
get the employers who use the specified flow.
getEmployers(Template, WCMFilter) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
get the employers who use the specified template.
getEmployers(Template, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
Returns the employers list of the specified type.
getEmployers(MetaView, WCMFilter) - 接口 com.trs.components.metadata.center.IMetaViewEmployerMgr 中的方法
获取使用了指定视图的所有栏目
getEmployers(MetaView, WCMFilter) - 类 com.trs.components.metadata.center.MetaViewEmployerMgr 中的方法
getEmployerType() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
提取属性：EmployerType
getEmployerType() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
提取属性：EmployerType
getEmployerType() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
提取属性：EmployerType
getEmployerType() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法
getEmploymentInfo(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
getEmploysOf(BaseObj) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
Returns the employ records of the specified employer, which may be a folder or a content.
getEmploysOf(IPublishElement, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
Returns the employ records of the specified employer, which may be a folder or a content.
getEmploysOf(IPublishElement) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
getEmploysOfEmployer(int, int) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
Returns the employ records of the specified employer, which may be a folder or a content.
getEmploysOfEmployer(int, int, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
Returns the employ records of the specified employer, which may be a folder or a content.
getEmploysOfEmployer(int, int) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
getEmployType() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
提取属性：EmployType
getEncoding() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
Returns the file encoding of this element.
getEncoding() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
getEncoding() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
getEncoding() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法
getEncoding() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
getEncoding() - 类 com.trs.infra.util.CMyUnzip 中的方法
取当前字符编码集
getEncoding() - 类 com.trs.infra.util.CMyZip 中的方法
取当前字符编码集
getEncoding() - 类 com.trs.infra.util.jazzlib.ZipFile 中的方法
取当前字符编码集
getEncoding() - 类 com.trs.infra.util.jazzlib.ZipOutputStream 中的方法
取当前字符编码集
getEndIndex() - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法
getEndNode() - 类 com.trs.cms.process.definition.Flow 中的方法
获取结束节点
getEndNodeName() - 类 com.trs.cms.process.definition.Flow 中的方法
设置结束节点名称
getEndStatTime() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
getEndStatTimeAsString() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
getEndTime() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
提取属性：EndTime
getEndTime() - 类 com.trs.components.common.calendar.Event 中的方法
property: EndTime 结束时间
getEndTime() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：执行结束时间，与开始时间共同指定计划执行所在的时间段。
getEndTime() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：EndTime
getEndTime() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道指定的结束时间 *
getEndTime() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
属性提取：执行结束时间
getEndTime() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
getEndTime() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：EndTime
getEnmvalue() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：Enmvalue
getEnmValue() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：EnmValue
getEnmValue() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：EnmValue
getEnmValueMap(boolean) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
获得枚举止的HashMap对象
getEnmValueMap(boolean) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
获得枚举止的HashMap对象
getEntry(String) - 类 com.trs.infra.util.cabfile.CabFile 中的方法
getEntry(String) - 类 com.trs.infra.util.jazzlib.ZipFile 中的方法
Searches for a zip entry in this archive with the given name.
getEntryConfig(int) - 类 com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl 中的方法
getEntryConfig(int) - 接口 com.trs.components.common.conjection.service.IComponentEntryConfigService 中的方法
getEnumCreator(int, String) - 类 com.trs.components.infoview.config.EnumsConfig 中的方法
getEnumCreators(int) - 类 com.trs.components.infoview.config.EnumsConfig 中的方法
getEnumsConfig() - 类 com.trs.components.infoview.InfoViewConfig 中的方法
getEnumsConfigFile() - 类 com.trs.components.infoview.InfoViewConfig 中的方法
getEnumSplit() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回枚举值的分隔字符
getEnumValue() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
返回有效的属性值的列表数组，如果属性值不是枚举类型，则返回null。
getEnumValue() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回有效的变量值的列表数组，如果变量值不是枚举类型，则返回 null。
getEnumValue() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getEnumValueDisplay(String) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回和指定的枚举值相关联的枚举显示名称，如果没有显示名称和该枚举值相关联， 则返回 null。
getEnumValueString() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
返回由有效的属性值构成的字符串，或者null。
getEPressChannels() - 类 com.trs.components.wcm.epress.EPressSoapService 中的方法
getErrMessage() - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
返回初始化发生的错误信息
getErrNo() - 异常 com.trs.infra.util.CMyException 中的方法
获取错误编号
getErrNoMsg() - 异常 com.trs.infra.util.CMyException 中的方法
getErrNoMsg(int) - 类 com.trs.infra.util.ExceptionNumber 中的静态方法
取错误编号对应的错误信息
getErrorCode() - 异常 com.trs.webframework.exception.ServiceInvocationException 中的方法
getErrorDetail() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
提取属性：ErrorDetail
getErrorInfo() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
getErrorLogs(User, WCMFilter) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
get the error logs of this task
getErrorMessage(int) - 接口 com.trs.template.IErrorMessages 中的方法
根据错误号获取指定的错误信息
getErrorMessageAt(int) - 接口 com.trs.template.IErrorMessages 中的方法
获取指定位置上的错误信息
getErrorMsg(int) - 类 com.trs.presentation.util.LoginHelper 中的静态方法
提取错误信息
getErrorMsg(int, String) - 类 com.trs.presentation.util.LoginHelper 中的静态方法
提取错误信息
getErrors() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法
Returns the analyzing erros.
getErrors() - 类 com.trs.infra.BaseServer 中的方法
getErrors() - 接口 com.trs.infra.IServer 中的方法
获取错误信息
getErrors() - 类 com.trs.infra.util.CMyErrors 中的方法
取所有错误列表
getEvent() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法
getEventId() - 类 com.trs.components.common.calendar.EventShare 中的方法
提取属性：EventId
getEvents(User, CMyDateTime, boolean, WCMFilter) - 类 com.trs.components.common.calendar.EventMgr 中的方法
getEvents(WCMFilter) - 类 com.trs.components.common.calendar.EventMgr 中的方法
获取系统中的日程安排
getEvents(WCMFilter) - 接口 com.trs.service.IEventService 中的方法
根据指定的filter获取Events
getEvents(WCMFilter) - 类 com.trs.service.impl.EventService 中的方法
getEventType() - 类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 中的方法
getExample() - 类 com.trs.wcag2.Alertion 中的方法
getExample(Object) - 类 com.trs.wcag2.validator.AbstractValidator 中的方法
getExample(Object) - 类 com.trs.wcag2.validator.EventsValidator 中的方法
getExample(Object) - 类 com.trs.wcag2.validator.HtmlH1Validator 中的方法
getExample(Object) - 类 com.trs.wcag2.validator.ImgAltValidator 中的方法
getExample(Object) - 接口 com.trs.wcag2.validator.IValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.AbstractValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.BiTagValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.DocTypeValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.EmbedAltValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.EventsValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.FormElementsValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.FormSubmitValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.FrameTitleValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.HtmlCharsetValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.HtmlH1_H6Validator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.HtmlH1Validator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.HtmlLangValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.HtmlTitleValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.ImgAltValidator 中的方法
getExampleObj() - 类 com.trs.wcag2.validator.ObjectBodyValidator 中的方法
getExcludeValue() - 类 com.trs.presentation.util.PageParameter 中的方法
getExcludeValue() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
getExecTime() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：ExecTime
getExecTime() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
getExecTime() - 接口 com.trs.infra.support.log.ILog 中的方法
getExeTime() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：执行时间
getExistedMapingFiles(User) - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的静态方法
getExistedXslFiles(User) - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的静态方法
getExitedMappingFiles() - 接口 com.trs.service.IDocumentService 中的方法
获取当前用户已定义的XML映射文件
getExitedMappingFiles() - 类 com.trs.service.impl.DocumentService 中的方法
getExitedXslFiles() - 接口 com.trs.service.IDocumentService 中的方法
获取当前用户已上传的xsl文件
getExitedXslFiles() - 类 com.trs.service.impl.DocumentService 中的方法
getExpandLength(int) - 类 com.trs.components.metadata.MetaDataConstants 中的静态方法
传入一个长度整数，获取数据库存储该长度时，需要的字段长度
getExpandNodeById(int) - 类 com.trs.components.wcm.content.trsserver.TreeNode 中的方法
getExpandNodeById(int) - 类 com.trs.presentation.nav.TreeNodeCalctor 中的方法
getExpression() - 类 com.trs.components.infoview.extract.manifest.CalculatedField 中的方法
getExt() - 类 com.trs.components.wcm.resource.FileType 中的方法
getExtendedProps(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
getExtension() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
getExtension() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
获取自动扩展
getExtensionalObjects(Class) - 类 com.trs.infra.config.domain.ConfigObjectLoader 中的方法
依据可配置对象类型，得到所有该类型的配置信息
getExtensionalObjects(String) - 类 com.trs.infra.config.domain.ConfigObjectLoader 中的方法
依据可配置对象ID标示，得到所有该类型的配置信息
getExtensionId() - 类 com.trs.cluster.TRSClusterExtensionImpl 中的方法
getExtensions() - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
getExtFieldId() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
getExtFieldProperty(String) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
getExtFields(BaseChannel, WCMFilter) - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 中的方法
getExtFields(CMSObj, WCMFilter, boolean) - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 中的方法
getExtFields(BaseChannel, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取指定站点/频道下的扩展字段.
getExtFields(BaseChannel, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
获取指定站点/频道下的扩展字段.
getExtMaxIndex() - 类 com.trs.infra.common.WCMRightTypes 中的静态方法
返回扩展功能最大权限值 为什么增加这个方法，而不是直接使用常量EXT_MAX_INDEX？
getExtMinIndex() - 类 com.trs.infra.common.WCMRightTypes 中的静态方法
返回扩展功能最小权限值 为什么增加这个方法，而不是直接使用常量EXT_MIN_INDEX？
getExtra() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the extra data.
getExtraAttribute(String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
Returns the specified extra attribute.
getExtraAttribute(String) - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Returns the specified extra attribute.
getExtraAttributes() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Returns the display styles.
getExtraAttributeValue(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
getExtractProgram() - 类 com.trs.components.infoview.InfoViewConfig 中的方法
getExtraData() - 类 com.trs.infra.util.Reports 中的方法
getExtraFilter() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
getExtraWCMFilter() - 类 com.trs.webframework.context.MethodContext 中的方法
getFailCode() - 异常 com.trs.template.TemplateRemoteException 中的方法
获取错误号
getFailDescription() - 异常 com.trs.template.TemplateRemoteException 中的方法
获取错误描述
getFailedReporter() - 类 com.trs.infra.util.Reports 中的方法
获取报告中的所有失败报告
getFailedReporterAt(int) - 类 com.trs.infra.util.Reports 中的方法
获取一个失败报告
getFailSolution() - 异常 com.trs.template.TemplateRemoteException 中的方法
获取错误对应的推荐解决办法
getFamilyIndex() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
提取属性：ChildIndex
getFavorite(HttpServletRequest) - 类 com.trs.components.wcm.content.trsserver.TRSSearchUtil 中的静态方法
获取用户的检索使用偏好
getFavorLanguageKey() - 类 com.trs.presentation.locale.LocaleServer 中的静态方法
getFax() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：Fax
getField(String) - 类 com.trs.components.infoview.persistent.InfoView 中的方法
getFieldCount() - 类 com.trs.infra.util.database.TableInfo 中的方法
取字段总数
getFieldDesc() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
提取属性：FieldDesc
getFieldDesc() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
提取属性：FieldDesc
getFieldDesc() - 类 com.trs.wcm.old.WCMFormFields 中的方法
提取属性：FieldDesc
getFieldDisplay(String[]) - 类 com.trs.components.infoview.helper.InfoViewQueryHelper 中的静态方法
getFieldEntities() - 类 com.trs.template.domain.InfoEntityFinder 中的方法
getFieldId() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
提取属性：FieldId
getFieldInfo(String, String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
取得值定数据表中指定字段信息
getFieldInfo(String) - 类 com.trs.infra.util.database.TableInfo 中的方法
根据字段名，提取字段信息对象
getFieldInfo(String, String) - 类 com.trs.infra.util.database.TableInfos 中的方法
取指定数据表中指定字段信息
getFieldInfo() - 类 com.trs.wcm.old.WCMFormFields 中的方法
获取表单元素所对应的数据库字段类型对象
getFieldInfoFilePath() - 类 com.trs.template.domain.SourcePathHelper 中的静态方法
getFieldLength() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
提取属性：FieldPos
getFieldList() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法
getFieldMockMappingFilePath() - 类 com.trs.template.domain.SourcePathHelper 中的静态方法
getFieldName() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
提取属性：FieldName
getFieldName() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
提取属性：FieldName
getFieldname() - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法
getFieldName() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
提取属性：FieldName
getFieldName() - 类 com.trs.wcm.old.WCMFormFields 中的方法
提取属性：FieldName
getFieldNames(InfoView, String) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
getFieldNames() - 类 com.trs.infra.util.database.TableInfo 中的方法
取所有的字段名称
getFieldOrder() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
getFieldPos() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
提取属性：FieldPos
getFields() - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法
getFields() - 类 com.trs.template.persistent.TagFieldInfoEntity 中的方法
getFields() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
获取表单字段列表集合
getFields(String, String, String) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
getFieldsDisplay(String[]) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
getFieldsInfoOfFlowDoc(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
获取当前轨迹处理中可读和可写的字段列表
getFieldSize(String) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
获取一个重复表中某个字段的个数，其实就是返回这个字段所在的组的行数
getFieldTemplate() - 类 com.trs.components.metadata.web.AbsHTMLMaker 中的方法
getFieldTemplate() - 接口 com.trs.components.metadata.web.HTMLMaker 中的方法
获取视图字段的资源模板
getFieldTemplate(String) - 类 com.trs.components.metadata.web.impl.FieldTemplateFactory 中的静态方法
根据视图资源类型，获取相应的视图资源模版
getFieldTop() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
提取属性：IsTop
getFieldType() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
返回字段类型
getFieldType() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getFieldType() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
提取属性：FieldType
getFieldTypes() - 接口 com.trs.components.metadata.web.HTMLMaker 中的方法
获取当前HTMLMaker需要处理的字段类型
getFieldTypes() - 类 com.trs.components.metadata.web.impl.DefaultHTMLMaker 中的方法
getFieldValue(String) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
获取某个节点的值
getFieldValue() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
提取属性：FieldValue
getFieldValue(InfoViewDocument, String) - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法
getFieldValue(Document, String) - 类 com.trs.components.infoview.InfoViewDataHelper 中的静态方法
getFieldValue(Document, String) - 接口 com.trs.components.infoview.mad.InfoViewDataHelper 中的方法
getFieldValue(Document, String) - 类 com.trs.components.infoview.mad.InfoViewDataHelperImpl 中的方法
getFieldValue(InfoViewContext, BindingBean) - 接口 com.trs.service.IInfoViewInitorValue 中的方法
getFieldValue(InfoViewContext, BindingBean) - 类 com.trs.service.impl.InfoViewInitorImpl 中的方法
getFieldValue(InfoViewContext, BindingBean) - 类 com.trs.service.impl.SiteNameCreator 中的方法
getFile() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
获得模板附件的文件名
getFile() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件文件名（不包含）
getFile(URL) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
访问指定的URL
getFile(URL, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
获取指定URL的源文件，并保存到本地目标文件 说明：若不指定目标文件，则抛弃获取结果
getFile(String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
访WEB链接
getFile(String, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
获取WEB上文件
getFile(String, String, String, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
获取WEB上文件
getFile(String, String, int, String, String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
获取WEB上文件
getFileAction() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
getFileContent(String) - 类 com.trs.components.infoview.extract.InfoPathFileData 中的静态方法
getFileContent(String) - 类 com.trs.components.infoview.InfoViewMgr 中的静态方法
getFileDistributeShip() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
getFileDistributeShip() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
getFileDistributeShip() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
Returns the file distribute ship.
getFiledNameFromSelect(int) - 类 com.trs.components.wcm.stat.StatView 中的方法
从Select中获得字段名称
getFileExt() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件的源文件名后缀名
getFileExt() - 类 com.trs.infra.util.FileNameExtFilter 中的方法
getFileExtFilters() - 类 com.trs.infra.util.CMyUnZipFile 中的方法
获取需要过滤的文件扩展名列表
getFileFlag(String) - 类 com.trs.infra.support.file.FilesMan 中的方法
根据文件名，返回文件所在路径的Flag标识，如FilesMan.Flag_Protected
getFileHashtable(String) - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法
getFileHashtable(String) - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态方法
getFileName() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
getFileName() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
getFileName() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
getFileName() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法
getFileName() - 类 com.trs.components.common.publish.widget.Master 中的方法
提取属性：FileName
getFileName() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法
getFileName() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
提取属性：FileName
getFileNamedStyle() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
getFileNamedStyle() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
getFileNamedStyle() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法
getFileNameEncoding() - 类 com.trs.infra.util.CMyUnZipFile 中的方法
getFileNewCaption() - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
新填写表单的表单数据的缺省标题 暂时没有使用
getFileNewTemplate() - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
返回填写表单用的XML模版文件的文件名
getFileProperties() - 类 com.trs.components.infoview.extract.manifest.PackageFile 中的方法
getFileProperty(String) - 类 com.trs.components.infoview.extract.manifest.PackageFile 中的方法
getFiles() - 类 com.trs.cms.content.HTMLContent 中的方法
获取HTML内容中的所有文件
getFiles(String) - 类 com.trs.ConfigFileTool4Refactor 中的方法
getFileSize(String, boolean) - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
获得指定文件名文件的大小
getFilesMan() - 类 com.trs.infra.support.file.FilesMan 中的静态方法
getFileType() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件文档类型对象
getFileTypeId() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件的文件所属类型
getFilter(MethodContext) - 接口 com.trs.components.filter.IQueryFilter 中的方法
getFilter() - 类 com.trs.infra.persistent.BaseObjs 中的方法
获得集合的过滤器
getFilteredFiles() - 类 com.trs.infra.util.CMyUnZipFile 中的方法
获取按照后缀名过滤器的设置过滤后的文件列表
getFilterForDocuments(BaseChannel, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
getFinalPropertyAsString(String) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取
getFinalPropertyAsString(String, String) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取
getFinalPropertyAsString(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取
getFinalPropertyAsString(String, String) - 类 com.trs.infra.persistent.BaseObj 中的方法
根据当前的状态，返回适当的值，如新建的时候，从properties获取，修改的时候，从newProperties获取
getFirstChildId() - 类 com.trs.scene.tools.SceneNode 中的方法
getFirstChnlDoc(ChnlDoc, boolean) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
得到频道内的第一个频道文档。
getFirstItemIndex() - 类 com.trs.infra.util.CPager 中的方法
取第一个元素的索引号
getFirstLetter(String, String) - 类 com.trs.components.wcm.resource.Source 中的静态方法
getFirstLetter(String) - 类 com.trs.infra.util.CMyString 中的静态方法
getFirstLetter(String, boolean) - 类 com.trs.infra.util.PinyinHelper 中的静态方法
获取首字母
getFixLength() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getFlag() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取文档流转状态
getFlag() - 类 com.trs.components.common.message.Message 中的方法
属性Flag有3种状态1与0和2 MESSAGE_STATE_DELETE MESSAGE_STATE_NODELETE MESSAGE_STATE_CALLBOARD
getFlag() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
获得模板附件的标记
getFlag() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取
getFlag() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档标志 目前系统只支持一种风格（对外发布的文档），其余风格的文档可在二次开发中定义
getFlagDesc() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取文档流转状态描述
getFlagDesc(int) - 类 com.trs.cms.process.ProcessConstants 中的静态方法
显示文档在工作流中的状态描述
getFlagString() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
取类型标识字符串（用于显示）
getFlagString(int) - 类 com.trs.components.wcm.content.persistent.Appendix 中的静态方法
获取附件类型的描述
getFloatValue() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
将属性值转化为浮点数
getFlow() - 类 com.trs.ajaxservice.WCMApplyFormProcessServiceHelper 中的静态方法
getFlow() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
getFlow(BaseObj) - 类 com.trs.cms.process.definition.FlowEmployMgr 中的方法
get the detail flow of the specified element.
getFlow() - 类 com.trs.cms.process.definition.FlowNode 中的方法
节点所在工作流对象
getFlowContent() - 类 com.trs.cms.process.engine.ExecuteContext 中的方法
获取当前正在处理的内容
getFlowContent() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
getFlowContent() - 类 com.trs.cms.process.engine.FlowContext 中的方法
getFlowContent() - 类 com.trs.cms.process.engine.FlowContextOld 中的方法
获取当前处理的流转对象（WCMObj），可以是文档，也可以是其它的类
getFlowContent() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
getFlowContent() - 类 com.trs.cms.process.engine.FlowParamers 中的方法
getFlowContentsDoneByUser(User) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsDoneByUser(User, CPager) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsDoneByUser(QueryFlowDocContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsDoneByUser(User) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户已经处理过的内容
getFlowContentsDoneByUser(User, CPager) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户已经处理过的内容
getFlowContentsDoneByUser(QueryFlowDocContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户已经处理过的内容
getFlowContentsInFlow(Flow) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsInFlow(Flow) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取在指定流程中正在流转的内容
getFlowContentsOfUser(User) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsOfUser(User, CPager) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsOfUser(QueryFlowDocContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsOfUser(User) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户可以处理的内容
getFlowContentsOfUser(User, CPager) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户可以处理的内容
getFlowContentsOfUser(QueryFlowDocContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户可以处理的内容
getFlowContentsStartByUser(User, CPager) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsStartByUser(User) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsStartByUser(QueryFlowDocContext) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowContentsStartByUser(User) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户已经启动的内容
getFlowContentsStartByUser(User, CPager) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户已经启动的内容
getFlowContentsStartByUser(QueryFlowDocContext) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定用户已经启动的内容
getFlowContext() - 类 com.trs.cms.process.engine.ExecuteContext 中的方法
getFlowDoc(int, int) - 类 com.trs.cms.process.FlowServer 中的方法
取指定文档对应的FlowDoc对象
getFlowDoc(IFlowContent) - 类 com.trs.cms.process.FlowServer 中的方法
取指定文档对应的FlowDoc对象
getFlowDoc() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取FlowContent相关的FlowDoc
getFlowDoc() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法
getFlowDoc() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法
getFlowdocId() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：FlowdocId
getFlowDocs(User, int, WCMFilter) - 类 com.trs.cms.process.FlowServer 中的方法
getFlowDocs(IFlowContent, WCMFilter) - 类 com.trs.cms.process.FlowServerImpl 中的方法
getFlowDocs(IFlowContent, WCMFilter) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定内容的流转轨迹
getFlowDocs(int, WCMFilter) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
getFlowDocs(int, WCMFilter) - 接口 com.trs.service.IWCMProcessService 中的方法
getFlowDocsOfContent(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
获取指定文档的流转轨迹
getFlowDocsOfContent(int, int) - 类 com.trs.cms.process.FlowServer 中的方法
getFlowDocsOfContent(int, int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
getFlowDocsOfContent(int, int) - 接口 com.trs.service.IWCMProcessService 中的方法
获取当前内容的所有流转情况
getFlowId() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
提取属性：FlowId
getFlowId() - 类 com.trs.cms.process.definition.FlowNode 中的方法
节点所在工作流ID
getFlowId() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
提取属性：FlowId
getFlowId() - 类 com.trs.service.InfoViewContext 中的方法
getFlowingDocBySNO(MethodContext) - 类 com.trs.ajaxservice.FlowingDocQueryService 中的方法
getFlowingStat(MethodContext) - 类 com.trs.ajaxservice.ApplyFormServiceProvider 中的方法
getFlowingStatByChnl(MethodContext) - 类 com.trs.ajaxservice.FlowingDocQueryService 中的方法
getFlowNode() - 类 com.trs.cms.process.engine.FlowContextOld 中的方法
获取当前处理的节点
getFlowNodes(User) - 类 com.trs.cms.process.definition.Flow 中的方法
取得工作流节点集合
getFlowOfEmployer(BaseObj) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
getFlowOfEmployer(BaseObj) - 接口 com.trs.service.IWCMProcessService 中的方法
getFlowOptionAuth(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
getFlowOptMarkEnum(Flow) - 类 com.trs.cms.process.definition.FlowOptMarkEnumParser 中的静态方法
getFlows(WCMFilter) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
getFlows(WCMFilter) - 接口 com.trs.service.IWCMProcessService 中的方法
getFlowServer() - 类 com.trs.cms.process.FlowServer 中的静态方法
getFlowStatusId() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：FlowStatusId
getFlowType() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
提取属性：FlowType
getFlowUsedByChannel(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
获取指定栏目正在使用的工作流
getFolder() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法
getFolder() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
getFolder() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
Returns the folder where this element currently lies.
getFolder() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法
getFolder() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法
getFolder() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法
getFolder() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
getFolder() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
get the folder where the template is located.
getFolder() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法
getFolder() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
getFolder() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
getFolderId() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：FolderId
getFolderId() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
提取属性：FolderId
getFolderId() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
提取属性：FolderId
getFolderId() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：FolderId
getFolderId() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
getFolderId() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：FolderId
getFolderId() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
提取属性：FolderId
getFolderId() - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法
getFolderIds() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：FolderIds
getFolders() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
get the property of ContentIds
getFoldersQuotingMe() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
Returns the content folders who are quoting this folder
getFoldersQuotingMe() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法
getFoldersQuotingMe() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法
getFoldersQuotingMe() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法
getFoldersQuotingMe() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法
getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr 中的方法
find the folders whose outline quotes the contents of the specified folder.
getFoldersWhoseOutlineQuotesContentsOf(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateQuoteMgr0310 中的方法
find the folders whose outline quotes the contents of the specified folder.
getFolderType() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：FolderTypeConfig
getFolderType() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
提取属性：FolderTypeConfig
getFolderType() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
提取属性：FolderTypeConfig
getFolderType() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：FolderTypeConfig
getFolderType() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
getFolderType() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：FolderTypeConfig
getFolderType() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
提取属性：FolderTypeConfig
getFolderType() - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法
getFolderTypes() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法
getForm() - 类 com.trs.components.wcm.resource.FileType 中的方法
getForm() - 类 com.trs.wcm.old.WCMExcelData 中的方法
获得扩展数据所属表单对象
getFormAction() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
初始化wcm与网关的交互页配置 开始
getFormat() - 类 com.trs.components.infoview.config.BindingBean 中的方法
getFormatedSettingFilesDir(String) - 类 com.trs.template.domain.SourcePathHelper 中的静态方法
getFormatter(String) - 类 com.trs.components.common.publish.domain.tagparser.TagFormatHelper 中的静态方法
Returns the tag formmater of the specified tag.
getFormEncoding() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
getFormExtra() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
getFormId() - 类 com.trs.wcm.old.WCMExcelData 中的方法
获得扩展数据所属表单ID
getFormId() - 类 com.trs.wcm.old.WCMFormFields 中的方法
提取属性：FormId
getFormIdName() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
获取表单处理对象对应的数据库表中ID名
getForms(BaseChannel, boolean, WCMFilter) - 类 com.trs.wcm.old.WCMFormMgr 中的方法
获取站点/频道的自定义表单
从ChannelMgr中移动过来的 hx@050328
getFormTableName() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
获取表单处理对象对应的数据库表名
getFreqReminded(int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
获取用户设置的提醒频率
getFreqReminded() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
提取属性：FreqReminded
getFrom() - 类 com.trs.infra.db.QueryFilter 中的方法
获取表名称列表，多个表用","分割
getFrom() - 类 com.trs.infra.persistent.WCMFilter 中的方法
获取表名称列表，多个表用","分割
getFrom() - 类 com.trs.infra.util.CMySMS 中的方法
获取发信人
getFrom() - 类 com.trs.infra.util.email.CMyEmail 中的方法
getFromUser() - 类 com.trs.infra.util.email.CMyEmail 中的方法
获取发件人的显示名称
getFromVersion() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档是从哪个版本恢复回来的
如果没有备份过，则返回0
getFtpConfig() - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
返回当前连接的配置信息
getFtpConfig() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法
返回FTP连接的配置信息
getFtpConnection() - 类 com.trs.infra.util.ftp.CMyFtp 中的静态方法
getFtpFolder() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取站点ftp目录
getFtpPassword() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取ftp用户密码
getFtpPath() - 类 com.trs.infra.support.config.PathConfig 中的方法
获取Ftp路径
getFtpServer() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取站点对应的ftp服务器地址
getFtpUser() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取站点对应的ftp服务器用户
getFullDataPath(IPublishElement, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the full data path of the specified element.
getFullDataPath(IPublishFolder, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the full data path of the specified folder.
getFullDataPath(IPublishContent, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the full data path of the specified content.
getFullDir() - 类 com.trs.template.domain.XTemplateExporter.HierarchyEntity 中的方法
getGateWayBinding() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法
getGatewayBindings() - 类 com.trs.components.infoview.config.GatewayConfig 中的方法
getGatewayConfig() - 类 com.trs.components.infoview.InfoViewConfig 中的方法
getGateWayInitPage() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
getGatewayPageProperties() - 类 com.trs.components.infoview.config.GatewayConfig 中的方法
getGatewayPageProperties() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
getGatewayPageProperty(String) - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法
初始化wcm与网关的交互页配置 结束
getGatewayPages() - 类 com.trs.components.infoview.config.GatewayConfig 中的方法
getGrade() - 类 com.trs.components.wcm.resource.DocKind 中的方法
getGroupBy() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法
getGroupByPath(String[]) - 类 com.trs.presentation.ids.WCM52Actor 中的方法
从路径中获取组织
getGroupFromSSOGroup(SSOGroup) - 类 com.trs.presentation.ids.ActorHelper 中的静态方法
从IDS的组织中获取当前应用的组织
getGroupId() - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
提取属性：GroupId
getGroupId() - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
提取属性：GroupId
getGroupId() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：GroupId
getGroupId() - 类 com.trs.components.stat.ChnlDept 中的方法
提取属性：GroupId
getGroupId() - 类 com.trs.presentation.ids.RegFromConfig 中的方法
获取所属组织ID
getGroupIds() - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法
getGroupInfos(String) - 类 com.trs.presentation.ids.ActorHelper 中的静态方法
从grouppath中获取组织的信息，包括ID和组织名
getGroupList() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法
getGroupMgr() - 类 com.trs.presentation.ids.ActorHelper 中的静态方法
获取GroupMgr
getGroupNameById(String) - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态方法
getGroupOrder() - 类 com.trs.cms.auth.persistent.Group 中的方法
提取属性：GroupOrder
getGroupRange(FlowContext) - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法
getGroupRange(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.AbstractToUsersCreator 中的方法
getGroupRange(FlowContext, ToUsersCreatorConfig) - 类 com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator 中的方法
getGroupRange() - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法
getGroupRange(FlowContext, ToUsersCreatorConfig) - 接口 com.trs.cms.process.engine.IToUsersCreator 中的方法
限定了用户选择范围（在特定组内选择）
getGroups(User, WCMFilter) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织
getGroups(Role, WCMFilter) - 类 com.trs.cms.auth.domain.GroupRoleMgr 中的方法
获取指定角色的关联的组织
getGroups(User) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
获取当前用户所在的所有组织
getGroups() - 类 com.trs.cms.auth.persistent.User 中的方法
取用户所属组对象集合
getGroups(Contact) - 类 com.trs.components.common.address.ContactMgr 中的方法
获取一个联系人所在的所有分组
getGroups(Event) - 类 com.trs.components.common.calendar.EventMgr 中的方法
获取共享指定日程安排的所有组织
getGroups(Contact) - 接口 com.trs.service.IContactService 中的方法
获取指定联系人所属的所有联系人分组
getGroups(Contact) - 类 com.trs.service.impl.ContactService 中的方法
getGroups(User) - 类 com.trs.service.impl.UserService 中的方法
getGroups() - 类 com.trs.service.impl.UserService 中的方法
getGroups(User) - 接口 com.trs.service.IUserService 中的方法
获取指定用户所在的组织集合
getGroups() - 接口 com.trs.service.IUserService 中的方法
获取当前登录用户所在的组织.
getGroupsForCurrUser(MethodContext) - 类 com.trs.ajaxservice.GroupServiceProvider 中的方法
获取当前登录用户可以管理的组织,也就是作为组管理员的组织
getGroupsForRole(MethodContext) - 类 com.trs.ajaxservice.GroupServiceProvider 中的方法
获取指定角色关联的组织
getGroupsWithRight(User, int, int, boolean) - 类 com.trs.cms.auth.persistent.Right 中的静态方法
获取在指定对象上设置了权限（/没有设置权限）的角色集合
getGroupUsers(Group, WCMFilter) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
获取指定组织所有的用户(用户组织关联对象)
getHandler() - 类 com.trs.cms.process.definition.FlowAction 中的方法
提取属性：Handler
getHandler() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
提取属性：Handler
getHeader(String) - 类 com.trs.infra.util.ResponseBuddy 中的方法
getHeaders() - 类 com.trs.infra.util.ResponseBuddy 中的方法
getHeadTitle(String, String, String, String) - 类 com.trs.presentation.util.PageViewUtil 中的静态方法
getHeight(Image) - 类 com.trs.infra.util.CImage 中的方法
getHeight() - 接口 com.trs.wcm.photo.IMagicImage 中的方法
获取图片的高度
getHeight() - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法
getHFields() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
获取表单字段列表的哈希表，key为数据库字段名
getHighPriorityLaborsMax() - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法
getHitsBonusOfMonth(String, int, CMyDateTime) - 类 com.trs.components.stat.StatBonusResultForUser 中的方法
获取指定用户所发的指定文档，在指定月份的点击量奖金
getHitsCount() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
提取属性：HitsCount 点击量
getHitsCount() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
提取属性：HitsCount
getHitsCount() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档的点击数
getHitsCountOfMonth(String, int, CMyDateTime) - 类 com.trs.components.stat.StatBonusResultForUser 中的方法
获取指定用户所发的指定文档，在指定月份的点击量
getHitsTime() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
提取属性：HitsTime 点击时间
getHitsTime() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
提取属性：HitsTime
getHomePath() - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
返回登陆远程服务器后的初始目录
getHost() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法
getHost(BaseChannel) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
获取栏目的父栏目,如果栏目是一级栏目,则返回该栏目所在的站点
getHost() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
得到当前频道的父频道，在Channel和Site中分别定义
getHost() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
getHost() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
getHost() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
getHost() - 类 com.trs.infra.util.soap.CMySoapClient 中的方法
getHost() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回FTP服务器的主机名或者IP地址
getHostDesc() - 类 com.trs.components.wcm.stat.StatHost 中的方法
提取属性：HostDesc
getHostFilePath() - 类 com.trs.infra.config.persistent.PluginConfig 中的方法
getHostId() - 类 com.trs.cms.process.definition.FlowRule 中的方法
提取属性：HostId
getHostId() - 类 com.trs.components.special.Special 中的方法
提取属性：HostId
getHostId() - 类 com.trs.components.stat.HostObjDomain 中的方法
提取属性：HostId
getHostId() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
提取属性：HostId
getHostId() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
提取属性：HostId
getHostName() - 类 com.trs.components.wcm.stat.StatHost 中的方法
提取属性：HostName
getHostType() - 类 com.trs.cms.process.definition.FlowRule 中的方法
提取属性：HostType
getHostType() - 类 com.trs.components.special.Special 中的方法
提取属性：HostType
getHostType() - 类 com.trs.components.stat.HostObjDomain 中的方法
提取属性：HostType
getHostType() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
提取属性：HostType
getHostType() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
提取属性：HostType
getHostType() - 类 com.trs.components.wcm.stat.StatHost 中的方法
提取属性：HostType
getHour() - 类 com.trs.infra.util.CMyDateTime 中的方法
获取当前对象中的【小时】的部分
getHtml() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
提取属性：Html
getHTML() - 类 com.trs.wcag2.Alertion 中的方法
getHtmlContent() - 类 com.trs.components.common.publish.widget.Layout 中的方法
提取属性：HtmlContent
getHtmlContent() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档的Html文本
getHtmlContent() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取文档的Html文本
getHtmlContentWithImgFilter(String, boolean) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
文档HTML内容过滤处理，用于文档HTML正文的显示处理
处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于：
[1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?
getHtmlContentWithImgFilter(String, boolean, boolean) - 类 com.trs.components.wcm.content.persistent.Document 中的方法

getHtmlContentWithImgFilter(String, boolean) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
文档HTML内容过滤处理，用于文档HTML正文的显示处理
处理过程：对文档HTML正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于：
[1]文档HTML正文显示，使用 getTextWithImgFilter( "show-pic.jsp?
getHtmlContentWithImgFilter(String, boolean, boolean) - 类 com.trs.components.wcm.content.ViewDocument 中的方法

getHTMLFiles() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取当前文档所包含的HTML文件列表
getHTMLMaker(int) - 类 com.trs.components.metadata.web.HTMLMakerFactory 中的静态方法
根据视图字段的类型，返回指定的HTMLMaker
getHTMLWCMFiles() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法

getHTMLWCMFiles() - 类 com.trs.components.wcm.content.persistent.Document 中的方法

getHTMLWCMFiles(boolean) - 类 com.trs.components.wcm.content.persistent.Document 中的方法

getHttpPath() - 类 com.trs.infra.support.config.PathConfig 中的方法
获取Http路径
getHttpUrl(IPublishContent, int) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the http path including file name of the specified content.
getIcon() - 类 com.trs.components.common.bookmark.BookMark 中的方法
属性: Icon 图标
getIcon() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

getId() - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法

getId() - 接口 com.trs.cms.content.ICMSObjSubstanceContent 中的方法
Returns the publish content id.
getId() - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

getId() - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法

getId() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor 中的方法
返回监控器对象的标识，一般是线程的名称
getId() - 类 com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl 中的方法

getId() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

getId() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

getId() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
提取属性：RecId
getId() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getId() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法

getId() - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法

getId() - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法

getId() - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法

getId() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getId() - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 中的方法

getId() - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 中的方法

getId() - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 中的方法

getId() - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 中的方法

getId() - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 中的方法

getId() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getId() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getId() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

getId() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getId() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getId() - 类 com.trs.infra.config.persistent.BeanConfig 中的方法

getId() - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法

getId() - 类 com.trs.infra.config.persistent.PluginConfig 中的方法

getId() - 类 com.trs.infra.persistent.BaseObj 中的方法
获取对象的ID
getId() - 类 com.trs.infra.support.log.LogType 中的方法
获取ID
getId() - 类 com.trs.scene.parser.SceneConnector 中的方法

getId() - 类 com.trs.scene.parser.SceneNode 中的方法

getId() - 类 com.trs.scene.tools.SceneNode 中的方法

getId() - 类 com.trs.wcm.photo.ImageInfo 中的方法

getIdAt(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
取指定索引位置的元素ID
getIdentityFlag(String) - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取唯一标识：IdentityFlag
getIdFieldName() - 类 com.trs.ajaxservice.ContentExtendValue 中的方法

getIdFieldName() - 类 com.trs.ajaxservice.ContentExtendValues 中的方法

getIdFieldName() - 类 com.trs.cms.auth.persistent.Group 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.GroupRoles 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.Groups 中的方法
获取用户组对象的ID名称
getIdFieldName() - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.GroupUsers 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.ObjectMembers 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.Right 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.RightDef 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.RightDefs 中的方法

getIdFieldName() - 类 com.trs.cms.auth.persistent.Rights 中的方法

getIdFieldName() - 类 com.trs.cms.auth.persistent.Role 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.Roles 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.RoleUsers 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.TrusteeInfos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.User 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.auth.persistent.Users 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.content.CMSObjDefaultImpl 中的方法

getIdFieldName() - 类 com.trs.cms.content.DefaultObj 中的方法

getIdFieldName() - 类 com.trs.cms.content.DefaultObjs 中的方法

getIdFieldName() - 类 com.trs.cms.content.ExtendedField 中的方法
对象所对应的ID字段名
getIdFieldName() - 类 com.trs.cms.content.ExtendedFields 中的方法
获得扩展字段所对应的ID字段名
getIdFieldName() - 类 com.trs.cms.content.WCMSystemObject 中的方法

getIdFieldName() - 类 com.trs.cms.process.definition.Flow 中的方法

getIdFieldName() - 类 com.trs.cms.process.definition.FlowAction 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowActions 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowConditions 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowdocLogs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowEmploys 中的方法

getIdFieldName() - 类 com.trs.cms.process.definition.FlowNode 中的方法

getIdFieldName() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法

getIdFieldName() - 类 com.trs.cms.process.definition.FlowNodeBranchs 中的方法

getIdFieldName() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowNodeFields 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowNodes 中的方法

getIdFieldName() - 类 com.trs.cms.process.definition.FlowRule 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.FlowRules 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.definition.Flows 中的方法

getIdFieldName() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.engine.FlowContentConfigs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.cms.process.engine.FlowDoc 中的方法

getIdFieldName() - 类 com.trs.cms.process.engine.FlowDocBak 中的方法

getIdFieldName() - 类 com.trs.cms.process.engine.FlowDocBaks 中的方法

getIdFieldName() - 类 com.trs.cms.process.engine.FlowDocs 中的方法

getIdFieldName() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.comment.persistent.DocumentTopics 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.comment.persistent.TopicedDocRelations 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.address.Contact 中的方法

getIdFieldName() - 类 com.trs.components.common.address.ContactGrp 中的方法

getIdFieldName() - 类 com.trs.components.common.address.ContactGrps 中的方法

getIdFieldName() - 类 com.trs.components.common.address.Contacts 中的方法

getIdFieldName() - 类 com.trs.components.common.bookmark.BookMark 中的方法

getIdFieldName() - 类 com.trs.components.common.bookmark.BookMarks 中的方法

getIdFieldName() - 类 com.trs.components.common.bookmark.MarkKind 中的方法

getIdFieldName() - 类 com.trs.components.common.bookmark.MarkKinds 中的方法

getIdFieldName() - 类 com.trs.components.common.bookmark.MarkShare 中的方法

getIdFieldName() - 类 com.trs.components.common.bookmark.MarkShares 中的方法

getIdFieldName() - 类 com.trs.components.common.calendar.Event 中的方法

getIdFieldName() - 类 com.trs.components.common.calendar.Events 中的方法

getIdFieldName() - 类 com.trs.components.common.calendar.EventShare 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.calendar.EventShares 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.calendar.EventType 中的方法

getIdFieldName() - 类 com.trs.components.common.calendar.EventTypes 中的方法

getIdFieldName() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.conjection.persistent.EntryConfigs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.job.JobWorkerType 中的方法

getIdFieldName() - 类 com.trs.components.common.job.JobWorkerTypes 中的方法

getIdFieldName() - 类 com.trs.components.common.job.Schedule 中的方法

getIdFieldName() - 类 com.trs.components.common.job.Schedules 中的方法

getIdFieldName() - 类 com.trs.components.common.message.Message 中的方法

getIdFieldName() - 类 com.trs.components.common.message.Messages 中的方法

getIdFieldName() - 类 com.trs.components.common.message.MsgQueue 中的方法

getIdFieldName() - 类 com.trs.components.common.message.MsgQueues 中的方法

getIdFieldName() - 类 com.trs.components.common.message.MsgReceiver 中的方法

getIdFieldName() - 类 com.trs.components.common.message.MsgReceivers 中的方法

getIdFieldName() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistributions 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfigs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLogs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTasks 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
返回TRS置标解析组件数据库表的标识字段名：TAGEBEANID
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TagBeans 中的方法
重载函数：返回置标解析组件的数据表标识字段
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TempApdRels 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
获得模板附件的数据存储的标识字段
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TempAppendixes 中的方法
获得模板附件的数据库标识字段
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获得模板数据表的ID字段
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法

getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TemplateArguments 中的方法

getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploys 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.TemplateQuotes 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.persistent.template.Templates 中的方法

getIdFieldName() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.ContentStyles 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.Layout 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.Layouts 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.Master 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.Masters 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.PageStyles 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.ResourceStyles 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.StyleAndResources 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.StyleItems 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.Widget 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.WidgetInstances 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.WidgetInstParameters 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.WidgetParameters 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.publish.widget.Widgets 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADCom 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADComs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADFile 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADFilePoss 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADFiles 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADPos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADPoss 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADType 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsad.ADTypes 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.Vote 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.VoteData 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.VoteDatas 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.VoteIPLogs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.VoteItem 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.VoteItems 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.VoteOption 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.VoteOptions 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.common.trsvote.Votes 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLogs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForms 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.gkml.sqgk.persistent.MailConfigs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.infoview.helper.ComplexFieldDatas 中的方法
取对象数据存储的ID字段名
getIdFieldName(String) - 类 com.trs.components.infoview.InfoViewConstants 中的静态方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewEmploys 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewFields 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewGroups 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViews 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法

getIdFieldName() - 类 com.trs.components.infoview.persistent.InfoViewViews 中的方法

getIdFieldName() - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.center.ClassInfoViews 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getIdFieldName() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

getIdFieldName() - 类 com.trs.components.metadata.center.MetaViewEmployer 中的方法

getIdFieldName() - 类 com.trs.components.metadata.center.MetaViewEmployers 中的方法

getIdFieldName() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.ClassInfos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.MetaDBFields 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.MetaDBTables 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.MetaView 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.MetaViewFields 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.metadata.definition.MetaViews 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.special.Special 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.special.Specials 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.BonusRule 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.BonusRules 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.ChnlDept 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.ChnlDepts 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.DocumentHitsCounts 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.HostObjDomain 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.HostObjDomains 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.HostObjHitsCounts 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.UserLoginInfo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.stat.UserLoginInfos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Appendixes 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.AutoBakConfigs 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ChannelContentLinks 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Channels 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ChannelSyns 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ChnlDocs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ContentExtFields 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ContentLinks 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.ContentLinkTypes 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.DocBaks 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.DocReplys 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Document 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.DocumentSyns 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.HitsCounts 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Relation 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Relations 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.Replaces 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.SiteMembers 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.WebSites 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.XDocument 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.persistent.XDocuments 中的方法

getIDFieldName() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.ViewDocument 中的方法

getIdFieldName() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

getIdFieldName() - 类 com.trs.components.wcm.customize.UserSetting 中的方法

getIdFieldName() - 类 com.trs.components.wcm.customize.UserSettings 中的方法

getIdFieldName() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.individuation.Individuations 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 中的方法

getIdFieldName() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.logo.Logos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.region.CellInfos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.region.RegionEmploys 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.region.RegionInfos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.publish.WCMPubStatusConfigs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.recent.Recent 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.recent.Recents 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.resource.DocKind 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.DocKinds 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.FileType 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.FileTypes 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.Keyword 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.resource.Keywords 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.resource.Securities 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.Security 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.Source 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.Sources 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.Status 中的方法

getIdFieldName() - 类 com.trs.components.wcm.resource.Statuses 中的方法

getIdFieldName() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.stat.StatFieldMaps 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.stat.StatHost 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.stat.StatHosts 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.stat.StatView 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.stat.StatViewRels 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.stat.StatViews 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.wcmx.help.WCMHelps 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.db.update.DBUpdateLog 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.db.update.DBUpdateLogs 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.infra.persistent.BaseObj 中的方法
获得Id字段名。
getIdFieldName() - 类 com.trs.infra.persistent.BaseObjs 中的方法
取对象数据存储的ID字段名。
getIdFieldName() - 类 com.trs.infra.persistent.CMyResultSet 中的方法

getIdFieldName() - 类 com.trs.infra.persistent.CMyResultSets 中的方法

getIdFieldName() - 类 com.trs.infra.persistent.MyBaseObj 中的方法

getIdFieldName() - 类 com.trs.infra.persistent.MyBaseObjs 中的方法

getIdFieldName() - 类 com.trs.infra.support.config.Config 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.infra.support.config.Configs 中的方法

getIdFieldName() - 类 com.trs.infra.support.log.Log 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.infra.support.log.LogBak 中的方法

getIdFieldName() - 类 com.trs.infra.support.log.LogBaks 中的方法

getIdFieldName() - 类 com.trs.infra.support.log.Logs 中的方法

getIdFieldName() - 类 com.trs.infra.support.log.OperType 中的方法

getIdFieldName() - 类 com.trs.infra.support.log.OperTypes 中的方法

getIdFieldName() - 类 com.trs.infra.support.security.SecureKey 中的方法

getIdFieldName() - 类 com.trs.infra.support.security.SecureKeys 中的方法

getIdFieldName() - 类 com.trs.infra.util.job.JobFailedResult 中的方法

getIdFieldName() - 类 com.trs.infra.util.job.JobFailedResults 中的方法

getIdFieldName() - 类 com.trs.wcm.config.PageOperator 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.wcm.config.PageOperators 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.wcm.old.WCMExcelData 中的方法

getIdFieldName() - 类 com.trs.wcm.old.WCMExcelDatas 中的方法

getIdFieldName() - 类 com.trs.wcm.old.WCMFormFields 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.wcm.old.WCMFormFieldses 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.wcm.old.WCMFormInfos 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.wcm.photo.Watermark 中的方法
取对象数据存储的ID字段名
getIdFieldName() - 类 com.trs.wcm.photo.Watermarks 中的方法
取对象数据存储的ID字段名
getIdleCount() - 类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 中的方法

getIdleCount() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法

getIdleimestamp() - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
获取空闲时间戳
getIdleTimemills() - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
获取连接的空闲时间(ms)
getIdList() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法

getIdListAsIntArr(List) - 类 com.trs.infra.util.CMyString 中的静态方法

getIdListAsString(char) - 类 com.trs.infra.persistent.BaseObjs 中的方法
将集合中的所有元素的Id，链接构成字符串； 不同Id之间，以分割符 _chrDelim 分割。
getIdListAsString() - 类 com.trs.infra.persistent.BaseObjs 中的方法

getIdListAsString(List, char) - 类 com.trs.infra.util.CMyString 中的静态方法

getIds(int) - 类 com.trs.components.wcm.recent.RecentMgr 中的方法
取得当前用户对特定类型对象的最新访问列表Id序列
getIds(int) - 类 com.trs.service.impl.RecentService 中的方法

getIds(int) - 接口 com.trs.service.IRecentService 中的方法
根据对象的类型，得到最近访问的该对象的集合Ids
getIErrorMessages() - 类 com.trs.template.ErrorMessagesFactory 中的静态方法
获取需要返回的错误信息集合的类
getImageAppendixes(WCMFilter, BaseChannel, boolean) - 接口 com.trs.wcm.photo.IImageLibMgr 中的方法
获取系统中已经存在的图片
getImageAppendixes(WCMFilter, BaseChannel, boolean) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
获取系统中已经存在的图片
getImageAppendixes(WCMFilter, BaseChannel, boolean) - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 中的方法

getImageAppendixes(WCMFilter, BaseChannel, boolean) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法

getImageData(int) - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
返回给定的验证码的图像数据
getImageFileName() - 类 com.trs.wcm.photo.ImageInfo 中的方法

getImageFileNameByScale(Document, int) - 类 com.trs.wcm.photo.ImageLibHelper 中的静态方法

getImageFileNameByScale(Document, int, boolean) - 类 com.trs.wcm.photo.ImageLibHelper 中的静态方法

getImageFileNameByScaleIndex(Document, int) - 类 com.trs.wcm.photo.ImageLibHelper 中的静态方法

getImageFileNameByScaleIndex(Document, int, boolean) - 类 com.trs.wcm.photo.ImageLibHelper 中的静态方法

getImageKindId() - 类 com.trs.wcm.photo.ImageInfo 中的方法

getImageKindId() - 类 com.trs.wcm.photo.ImageKind 中的方法

getImageSize(ImageMagickCmd.ImageObj) - 类 com.trs.wcm.photo.impl.ImageMagickCmd 中的静态方法

getImageTitle() - 类 com.trs.wcm.photo.ImageInfo 中的方法

getImplementor(Class) - 类 com.trs.infra.util.DiscoveryFactoryBuddy 中的静态方法

getImplementors() - 类 com.trs.components.wcm.content.domain.ChannelImporter 中的静态方法

getImplementors() - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的静态方法

getImport() - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法

getImportCount() - 类 com.trs.wcm.old.ImportDocsContext 中的方法

getImportReports() - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的方法

getImportSources(String) - 类 com.trs.presentation.documetimport.xml.DocumentImportXmlHelper 中的静态方法
取得一个文档导入需要的xml文件信息 just for document/document_xml_edit.jsp
getIncludeOperations() - 类 com.trs.cms.auth.config.OperationConfig 中的方法

getIncreasedContents(WCMFilter) - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
Returns the increased contents to publish
getIncreasedContents(WCMFilter) - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getIncreasedContents(WCMFilter) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getIncreasedContents(WCMFilter) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getIncreasedContents(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getIncreasedContents(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getIncreasedContentsIterator(WCMFilter) - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法

getIncreasedContentsIterator(WCMFilter) - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getIncreasedContentsIterator(WCMFilter) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getIncreasedContentsIterator(WCMFilter) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getIncreasedContentsIterator(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getIncreasedContentsIterator(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getIndex() - 类 com.trs.cms.auth.config.OperationConfig 中的方法

getIndex() - 类 com.trs.cms.auth.persistent.RightDef 中的方法

getIndexCode() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：IndexCode
getIndexes() - 类 com.trs.infra.util.upgrade.dbcompare.MetaDataLoader 中的方法
获取索引
getIndexs() - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法

getIndividuationId() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法
提取属性：IndividuationId
getInerval() - 类 com.trs.infra.util.CMyTimer 中的方法
获取间隔运行时间
getInfo() - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法

getInfo() - 接口 com.trs.cms.content.ICMSObjSubstanceContent 中的方法
Gets the information of the folder.
getInfo() - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法

getInfo() - 类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 中的方法

getInfo() - 接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTaskList 中的方法
返回该任务列表的描述信息
getInfo() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPageTask 中的方法
Returns this page task information.
getInfo() - 类 com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask 中的方法

getInfo() - 类 com.trs.components.common.publish.domain.taskdispatch.SinglePageTask 中的方法

getInfo() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

getInfo() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

getInfo() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法

getInfo() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
Returns the template information.
getInfo() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getInfo() - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法

getInfo() - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法

getInfo() - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法

getInfo() - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 中的方法

getInfo() - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 中的方法

getInfo() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
Returns the object inforamtion
getInfo() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

getInfo() - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 中的方法

getInfo() - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 中的方法

getInfo() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

getInfo() - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 中的方法

getInfo() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getInfo() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getInfoEntityColl() - 类 com.trs.template.persistent.InfoEntities 中的方法

getInfoGetType() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：InfoGetType
getInfoPathFile() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getInfoProviderType() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：InfoProviderType
getInfoView(Channel) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法

getInfoView() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法

getInfoView() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

getInfoView() - 类 com.trs.service.InfoViewContext 中的方法

getInfoviewBindings() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getInfoViewChnlDocFilterHelper() - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法

getInfoViewConfig() - 类 com.trs.components.infoview.InfoViewMgr 中的方法

getInfoViewData() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法

getInfoviewDataId() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
提取属性：InfoviewDataId
getInfoViewEmployers(InfoView) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法

getInfoViewEmployers(int) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法

getInfoViewEmployers(int, WCMFilter) - 类 com.trs.components.infoview.InfoViewEmployMgr 中的方法

getInfoViewEmployers(InfoView) - 接口 com.trs.service.IInfoViewService 中的方法
获取指定自定义表单的所有雇主（频道对象）的集合
getInfoViewEmployers(int) - 接口 com.trs.service.IInfoViewService 中的方法
获取指定自定义表单的所有雇主（频道对象）的集合
getInfoViewEmployers(InfoView) - 类 com.trs.service.impl.InfoViewService 中的方法

getInfoViewEmployers(int) - 类 com.trs.service.impl.InfoViewService 中的方法

getInfoViewEmployMgr() - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 中的静态方法

getInfoViewEmployMgr() - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法

getInfoViewFieldValue(String) - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
获取指定字段的值，因为可能是重复表字段，返回一个List
getInfoViewId() - 类 com.trs.components.infoview.config.EnumCreator 中的方法

getInfoViewId() - 类 com.trs.components.infoview.config.LinkedEnumCreator 中的方法

getInfoviewId() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
提取属性：InfoviewId
getInfoViewId() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法

getInfoViewId() - 类 com.trs.components.infoview.persistent.InfoViewDatas 中的方法

getInfoViewId() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法

getInfoViewId() - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法

getInfoViewId() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法

getInfoViewID() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

getInfoViewID() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

getInfoViewID() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回视图所属表单的ID
getInfoViewId() - 类 com.trs.service.InfoViewContext 中的方法

getInfoViewPath() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getInfoviewPrintTemplateId() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：DetailTemplateId
getInfoViews() - 类 com.trs.ajaxservice.InfoviewService 中的方法

getInfoViews(WCMFilter) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

getInfoViews(WCMFilter) - 接口 com.trs.service.IInfoViewService 中的方法
获取所有符合条件的自定义表单
getInfoViews(WCMFilter) - 类 com.trs.service.impl.InfoViewService 中的方法

getInfoViewSerial(int) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

getInfoViewSerial(InfoView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

getInfoViewSerial(int) - 接口 com.trs.service.IInfoViewService 中的方法
获取指定表单的编号
getInfoViewSerial(InfoView) - 接口 com.trs.service.IInfoViewService 中的方法
获取指定表单的编号
getInfoViewSerial(int) - 类 com.trs.service.impl.InfoViewService 中的方法

getInfoViewSerial(InfoView) - 类 com.trs.service.impl.InfoViewService 中的方法

getInfoViewTemPath(InfoView) - 类 com.trs.ajaxservice.InfoviewService 中的方法

getInfoviewTitle() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getInfoViewViewName() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getInitConnects() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

getInitProperty(String) - 类 com.trs.infra.support.config.ConfigServer 中的方法

getInnerFilloutAction() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getInnerIPBegin() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：InnerIPBegin
getInnerIPEnd() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：InnerIPEnd
getInnerMultiCount() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：InnerMultiCount
getInnerType() - 类 com.trs.components.infoview.extract.DataType 中的静态方法

getInputFile() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取输入文件名
getInputSource(InputStream, String) - 类 com.trs.webframework.xmlserver.parser.StreamBuddy 中的静态方法

getInputSteam() - 类 com.trs.webframework.xmlserver.parser.ServletInputStreamWrapper 中的方法

getInputStream(CabEntry) - 类 com.trs.infra.util.cabfile.CabFile 中的方法

getInputStream(ZipEntry) - 类 com.trs.infra.util.jazzlib.ZipFile 中的方法
Creates an input stream reading the given zip entry as uncompressed data.
getInputStream() - 类 com.trs.webframework.context.ServiceContext 中的方法

getInputStreamWrapper() - 类 com.trs.webframework.context.ServiceContext 中的方法

getInstance() - 类 com.trs.cms.auth.config.RightConfigServer 中的静态方法

getInstance() - 类 com.trs.cms.auth.persistent.UserLicenseMgr 中的静态方法

getInstance() - 类 com.trs.components.ckm.TRSCKMServer 中的静态方法

getInstance() - 类 com.trs.components.common.message.MessageSendingMapper 中的静态方法

getInstance() - 类 com.trs.components.common.message.notify.NotificationServer 中的静态方法

getInstance() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
get the instance
getInstance() - 类 com.trs.components.common.publish.domain.PublishServer 中的静态方法
get the publish server instance
getInstance() - 类 com.trs.components.common.publish.domain.tagparser.TagFormatHelper 中的静态方法
Returns the tag formmater helper instance.
getInstance() - 类 com.trs.components.filter.QueryFilterFactory 中的静态方法
获取一个Factory
getInstance() - 类 com.trs.components.infoview.persistent.InfoViewSerialGenerator 中的静态方法

getInstance() - 类 com.trs.components.metadata.service.DefaultChannelMakerCenter 中的静态方法
获取Center的实例
getInstance() - 类 com.trs.components.wcm.content.persistent.SiteLicenseMgr 中的静态方法

getInstance() - 类 com.trs.components.wcm.stat.StatResultHolder 中的静态方法

getInstance() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的静态方法
获取媒体提醒工具类的实例（一种Singlton的模式）
getInstance() - 类 com.trs.components.web.document.DocumentFieldHTMLParser 中的静态方法

getInstance() - 类 com.trs.infra.config.BeanConfigServer 中的静态方法

getInstance() - 类 com.trs.infra.config.XMLConfigServer 中的静态方法

getInstance() - 类 com.trs.infra.persistent.db.DBConnectionMapper 中的静态方法

getInstance() - 类 com.trs.infra.persistent.db.LicenseMgr 中的静态方法

getInstance() - 类 com.trs.infra.util.email.SMTPServerConfigMapper 中的静态方法

getInstance() - 类 com.trs.template.domain.setting.TemplateSettingFactory 中的静态方法
返回静态实例
getInt(String, int) - 类 com.trs.presentation.util.RequestHelper 中的方法
取长整型属性值
getIntAttribute(String, int) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
get the integer attribute value
getInterval() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：Interval
getIntProperty(Map, String, int) - 类 com.trs.infra.util.PropertiesUtil 中的静态方法
get the integer property value
getIntValue() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
将属性值转化为整型
getInvalidTime() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
获取文档置顶的有效时间（截止时间）
getInvocationId() - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法

getInvocationType() - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法

getIP() - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
提取属性：IP
getIpAddress() - 类 com.trs.components.stat.UserLoginInfo 中的方法
提取属性：IpAddress，登录的IP地址
getIPLogId() - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
提取属性：IPLogId
getIPLogs(User) - 类 com.trs.components.common.trsvote.Vote 中的方法
取得调查IP记录
getIsAdministrator() - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
提取属性：IsAdministrator
getIsDisplay() - 类 com.trs.wcm.config.PageOperator 中的方法
提取属性：IsDisplay
getIsImport() - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
提取属性：是否是导入的对象
getIsPrivate() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
提取属性：是否是私有对象
getIsPrivate() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
提取属性：是否是私有对象
getIsPublish() - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
提取属性：是否发布
getIsRoot() - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法

getIssuedAmountOfMonth(String, CMyDateTime) - 类 com.trs.components.stat.StatBonusResultForUser 中的方法
获取指定用户在指定月份的发稿量 (该方法用在按月份统计的时候，奖金的类型已经确定)
getIssuesAmountBonusOfMonth(String, CMyDateTime) - 类 com.trs.components.stat.StatBonusResultForUser 中的方法
获取指定用户在指定月份所获的奖金 (该方法在按月份统计的时候使用，这时奖金的类型已经确定)
getItem() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue 中的方法

getItem(String) - 类 com.trs.infra.util.CMyUnzip 中的方法
提取指定压缩项信息
getItemAt(int) - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 中的方法
get the item at the specified position.
getItemCount() - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 中的方法

getItemCount() - 类 com.trs.infra.util.CPager 中的方法
获取记录数
getItemId() - 类 com.trs.components.common.trsvote.VoteItem 中的方法
提取属性：ItemId
getItemId() - 类 com.trs.components.common.trsvote.VoteOption 中的方法
提取属性：ItemId
getItems() - 类 com.trs.components.common.publish.domain.tagparser.TagDocument 中的方法

getItems() - 类 com.trs.infra.util.CMyUnzip 中的方法
提取zip文件中的压缩项
getJdbcDriver() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法

getJdbcType() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法

getJdbcTypeName() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法

getJspUrl() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
提取属性：JspUrl
getKey() - 类 com.trs.components.common.publish.widget.WidgetParameterType 中的方法
获取注册的变量的key
getKey() - 类 com.trs.components.infoview.config.EnumCreator 中的方法

getKey() - 类 com.trs.components.infoview.db.InfoViewDataType 中的方法

getKey() - 类 com.trs.components.metadata.definition.MetaDataType 中的方法

getKey() - 类 com.trs.infra.persistent.BaseObj 中的方法
获得对象的标示关键字，用在Hashtable中索引对象
getKey() - 类 com.trs.scene.parser.SceneNode 中的方法

getKEY_DOM4J() - 接口 com.trs.components.infoview.mad.InfoViewDataHelper 中的方法

getKEY_DOM4J() - 类 com.trs.components.infoview.mad.InfoViewDataHelperImpl 中的方法

getKeyName() - 类 com.trs.infra.support.security.SecureKey 中的方法
获取密钥名
getKeyNum(String) - 类 com.trs.infra.util.key.CKeyUtil 中的静态方法

getKeys(WCMFilter) - 类 com.trs.infra.support.security.SecureKeyMgr 中的方法
获取当前系统中符合条件的密钥的集合
getKeys() - 类 com.trs.presentation.util.Parameter 中的方法

getKeys(WCMFilter) - 类 com.trs.service.impl.SecurityService 中的方法

getKeys(WCMFilter) - 接口 com.trs.service.ISecurityService 中的方法
获取当前系统中符合条件的密钥的集合
getKeys() - 类 com.trs.webframework.config.TRSParameter 中的方法

getKeySize() - 类 com.trs.infra.support.security.SecureKey 中的方法
获取密钥长度
getKeywords() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取关键词
getKeywords() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
提取属性：Keywords
getKFREQ() - 类 com.trs.components.wcm.resource.Keyword 中的方法
提取属性：KFREQ
getKind() - 类 com.trs.components.common.bookmark.BookMark 中的方法
取标签类型对象
getKind() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档分类对象
getKindId() - 类 com.trs.components.common.bookmark.BookMark 中的方法
属性: Kind 类别
getKindId() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档分类ID
getKlass() - 类 com.trs.wcag2.Alertion 中的方法

getKMTRSServer() - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的静态方法
单体引用器
getKNAME() - 类 com.trs.components.wcm.resource.Keyword 中的方法
提取属性：KNAME
getLaborResource() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

getLaborResourceConfig() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
get the labor resource configurator.
getLanguageKeys() - 类 com.trs.presentation.locale.LocaleServer 中的静态方法
获取系统所有支持语种对应的Key
getLasExeResult() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：上次执行结果
getLastChnlDoc(ChnlDoc, boolean) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
得到频道内的最后一个频道文档。
getLastExeTime() - 类 com.trs.components.common.job.Schedule 中的方法
取上次执行时间
getLastItemIndex() - 类 com.trs.infra.util.CPager 中的方法
取最后一个元素的索引号
getLastLoginTime() - 类 com.trs.cms.auth.persistent.User 中的方法
取上次登录时间
getLastSearch() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法

getLastTimeUsed() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：上次执行所用时间
getLayoutHtml(MethodContext) - 接口 com.trs.components.common.publish.widget.ILayoutServiceProvider 中的方法
通过获取比例类型和比例值来直接返回相应的HTML内容
getLayoutHtml(MethodContext) - 类 com.trs.components.common.publish.widget.LayoutServiceProvider 中的方法
通过web页面发送布局比例类型和布局比例信息来获取到相应的HTML代码,该服务需要将布局的样式信息写到HTML代码中
getLeaveNos(int, int) - 类 com.trs.components.common.trsad.ADPoss 中的方法
getLeaveNos取得没有连续的广告位置；
getLegalPerson() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：LegalPerson
getLength() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
返回正文的长度
getLength() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：Length
getLength() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：Length
getLength() - 类 com.trs.infra.util.database.CDBText 中的方法
取文本长度
getLevel() - 类 com.trs.infra.util.html.HtmlElement 中的方法
获得该元素的层次（根元素层次为0）
getLevel() - 类 com.trs.scene.tools.SceneNode 中的方法

getLevel() - 类 com.trs.wcag2.Alertion 中的方法

getLibId() - 类 com.trs.wcm.photo.Watermark 中的方法

getLimitCount() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法

getLineNo() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
返回当前字符的行号
getLink() - 类 com.trs.components.common.bookmark.BookMark 中的方法
属性: Link 链接
getLink() - 类 com.trs.components.wcm.resource.Source 中的方法
获取来源链接
getLinkedEnums(int) - 类 com.trs.components.infoview.config.EnumsConfig 中的方法

getLinkPath() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
提取属性：LinkPath
getLinkTitle() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
获取链接中的标题
getLinkTitle() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
获取链接中的标题
getLinkType() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法

getLinkTypeName() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法

getLinkUrl() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法

getLinkUrl() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

getLinkUrl() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

getLinkUrl() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getLinkUrl() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
Returns the link url of this folder if its type is link.
getLinkUrl() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
获取链接
getLinkUrl() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
获取链接
getLinkUrl() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getLinkUrl() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

getLinkUrl() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getLinkUrl() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getListeners() - 类 com.trs.infra.persistent.listener.MonitorHostConfig 中的方法

getListeners(int, BaseObj) - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的方法

getListeners(int, Class) - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的方法

getListenersMap() - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的方法

getLiteralPrefix() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法

getLiteralSuffix() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法

getLoadBatchContentsModal() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

getLoadBatchContentsModal() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法

getLoadBatchContentsPageSize() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

getLoadBatchContentsPageSize() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法

getLoadingErrorReport() - 类 com.trs.webframework.config.ServiceConfig 中的方法

getLoadingErrorReport() - 类 com.trs.webframework.config.ServiceFilterConfigs 中的方法

getLoadingErrorReport() - 类 com.trs.webframework.config.ServiceListenerConfigs 中的方法

getLocalFile() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 中的方法
返回本地文件
getLocalFtpPath() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取应用服务器上站点的FTP路径
getLocalHttpPath() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取应用服务器上站点的HTTP路径
getLocalizedMessage() - 异常 com.trs.infra.util.CMyException 中的方法
取错误消息，若rootCause非空，则同时输出rootCause的错误消息
getLocalPath(IPublishElement, boolean) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the element local path.
getLocalPath() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取应用服务器上存放站点页面的绝对物理路径
getLocalPath() - 类 com.trs.infra.support.config.PathConfig 中的方法
获取本地路径
getLocation() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

getLockedObjIds(int) - 类 com.trs.cms.content.LockerMgr 中的方法
获取已被锁定的对象id序列
getLockedObjIds(int) - 类 com.trs.cms.content.LockManager 中的方法
获取已被锁定的对象id序列
getLocker() - 类 com.trs.cms.content.CMSObj 中的方法
取本对象的加锁对象
getLocker(CMSObj, boolean) - 类 com.trs.cms.content.LockerMgr 中的方法
取指定WCMObj对象的加锁对象
getLocker(int, int, boolean) - 类 com.trs.cms.content.LockerMgr 中的方法

getLocker(CMSObj, boolean) - 类 com.trs.cms.content.LockManager 中的方法
取指定WCMObj对象的加锁对象
getLocker(int, int, boolean) - 类 com.trs.cms.content.LockManager 中的方法

getLockerUser() - 类 com.trs.cms.content.CMSObj 中的方法
取本对象的加锁人
getLockerUserName() - 类 com.trs.cms.content.CMSObj 中的方法
取对象的加锁人的用户名
getLockTimeOut() - 类 com.trs.cms.content.Locker 中的方法
获取锁定的有效时间，单位：秒；0 值表示永远锁定
getLockUser() - 类 com.trs.cms.content.Locker 中的方法
获取锁定的用户
getLog() - 类 com.trs.infra.util.email.CMyMailLog 中的方法

getLogBaks(WCMFilter) - 接口 com.trs.infra.support.log.ILogMgr 中的方法

getLogBaks(WCMFilter, int) - 接口 com.trs.infra.support.log.ILogMgr 中的方法

getLogBaks(WCMFilter) - 类 com.trs.infra.support.log.LogMgr 中的方法

getLogBaks(WCMFilter, int) - 类 com.trs.infra.support.log.LogMgr 中的方法

getLogBaks(WCMFilter) - 类 com.trs.infra.support.log.LogServer 中的静态方法
获取所有符合条件的归档日志
getLogBaks(int, WCMFilter) - 类 com.trs.infra.support.log.LogServer 中的静态方法
获取所有符合条件的归档日志，可直接指定日志类型ID
getLoggerName() - 类 com.trs.webframework.config.MethodConfig 中的方法

getLogicalRightValue(CMSObj, User, int[]) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
获取当前逻辑权限值，包含了继承关系
getLogicRightValue() - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法

getLogicRightValue(Document) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法

getLogId() - 类 com.trs.infra.support.log.LogBak 中的方法

getLoginErrNum(User) - 类 com.trs.presentation.util.LoginHelper 中的方法
提取指定用户登录失败的次数
getLoginIP() - 类 com.trs.cms.auth.persistent.User 中的方法

getLoginPassword() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：LoginPassword
getLoginTime() - 类 com.trs.cms.auth.persistent.User 中的方法
获取当前登录时间
getLoginTime() - 类 com.trs.components.stat.UserLoginInfo 中的方法
提取属性：LoginTime，用户登录时间
getLoginTimes() - 类 com.trs.cms.auth.persistent.User 中的方法
获取登录次数
getLoginUser() - 类 com.trs.cms.ContextHelper 中的静态方法
获得当前线程的登录用户，委托给ContextTL 处理策略：
1.
getLoginUser() - 接口 com.trs.components.common.message.IMessageService 中的方法
获得当前登录用户
getLoginUser() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：LoginUser
getLoginUser() - 类 com.trs.presentation.util.LoginHelper 中的方法

getLoginUser() - 接口 com.trs.service.ICustomizeService 中的方法
获取使用service的当前用户
getLoginUser() - 接口 com.trs.service.IDocumentService 中的方法
返回当前登录用户
getLoginUser() - 接口 com.trs.service.IEventService 中的方法
获取当前登录用户
getLoginUser() - 类 com.trs.service.impl.CustomizeService 中的方法

getLoginUser() - 类 com.trs.service.impl.DocumentService 中的方法

getLoginUser() - 类 com.trs.service.impl.EventService 中的方法

getLoginUser() - 类 com.trs.service.impl.PublishService 中的方法

getLoginUser() - 类 com.trs.service.impl.RecentService 中的方法

getLoginUser() - 类 com.trs.service.impl.ResouceService 中的方法

getLoginUser() - 接口 com.trs.service.IPublishService 中的方法

getLoginUser() - 接口 com.trs.service.IRecentService 中的方法
获得当前登录用户
getLoginUser() - 接口 com.trs.service.IResourceService 中的方法
返回当前登录用户
getLoginUserIndividuationConfigs(String[], boolean) - 类 com.trs.components.wcm.individuation.IndividuationMgr 中的方法

getLoginUserName() - 类 com.trs.service.impl.DocumentService 中的方法

getLogObjClassName() - 类 com.trs.webframework.config.MethodConfig 中的方法

getLogObjs(boolean) - 类 com.trs.infra.support.log.LogListUtil 中的静态方法

getLogObjType() - 类 com.trs.cms.auth.logger.RightLogger 中的方法

getLogObjType() - 类 com.trs.cms.auth.logger.RoleUserLogger 中的方法

getLogObjType() - 接口 com.trs.cms.logger.IObjLogger 中的方法
获取该日志是记录那个对象的
getLogObjType() - 类 com.trs.cms.logger.ObjLoggerBase 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.ChannelLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.ChnlDocLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.ConfigLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.DocumentLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.FlowEmployLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.FolderPublishConfigLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.RegionCellInfoLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.RegionInfoLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.ScheduleLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.TemplateEmployLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.TemplateLogger 中的方法

getLogObjType() - 类 com.trs.components.wcm.logger.WebSiteLogger 中的方法

getLogoOrder() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
提取属性：LogoOrder
getLogOpTypes(boolean) - 类 com.trs.infra.support.log.LogListUtil 中的静态方法

getLogs(WCMFilter) - 接口 com.trs.infra.support.log.ILogMgr 中的方法

getLogs(WCMFilter, int) - 接口 com.trs.infra.support.log.ILogMgr 中的方法

getLogs(WCMFilter) - 类 com.trs.infra.support.log.LogMgr 中的方法

getLogs(WCMFilter, int) - 类 com.trs.infra.support.log.LogMgr 中的方法

getLogs(WCMFilter) - 类 com.trs.infra.support.log.LogServer 中的静态方法
获取所有符合条件的日志
getLogs(int, WCMFilter) - 类 com.trs.infra.support.log.LogServer 中的静态方法
获取所有符合条件的日志，可直接指定日志类型ID
getLogsByTopId(WCMFilter, int) - 接口 com.trs.infra.support.log.ILogMgr 中的方法

getLogsByTopId(WCMFilter, int) - 类 com.trs.infra.support.log.LogMgr 中的方法

getLogsByTopId(int, WCMFilter) - 类 com.trs.infra.support.log.LogServer 中的静态方法
获取属于一个逻辑操作（TopId）的日志集合
TopId标识日志的起始触发操作，相同TopId的操作都是一个操作触发的。
getLogTime() - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
提取属性：LogTime
getLogType() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取日志类型对象
getLogType() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志类型对象
getLogTypeName(String) - 类 com.trs.infra.support.log.LogServer 中的静态方法
根据日志类型常量获得日志类型名称
getLogTypes() - 类 com.trs.infra.support.log.LogServer 中的静态方法
获取系统定义的所有日志类型
getLogUserIP() - 类 com.trs.infra.support.log.BaseDBLog 中的方法

getLogUserIP() - 接口 com.trs.infra.support.log.ILog 中的方法
获取触发日志记录的用户登录IP
getLong(String, long) - 类 com.trs.presentation.util.RequestHelper 中的方法
取长整型属性值
getLongValue() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
将属性值转化为长整型
getLowerObjName(int) - 类 com.trs.infra.common.WCMTypes 中的静态方法

getLowerSynName(boolean) - 类 com.trs.infra.common.WCMTypes 中的静态方法

getLowPriorityLaborsMax() - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法

getMailBody() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：MailBody
getMailFormat() - 类 com.trs.infra.util.email.CMyEmail 中的方法

getMailLog() - 类 com.trs.infra.util.email.TRSMailer 中的方法

getMailLogString() - 类 com.trs.infra.util.email.TRSMailer 中的方法

getMailTitle() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：MailTitle
getMainDBTableInfo() - 类 com.trs.components.metadata.definition.MetaView 中的方法

getMainFileExt() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取主页面的扩展名
getMainFileName() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取主页面的文件名
getMainTable() - 类 com.trs.components.metadata.definition.MetaView 中的方法

getMainTableId() - 类 com.trs.components.metadata.definition.MetaView 中的方法
获取主表ID
getMainTableName() - 类 com.trs.components.metadata.definition.MetaView 中的方法
提取属性：MainTableName
getMainViewId() - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
提取属性：MainViewId
getMajorVersion() - 类 com.trs.components.wcm.newshoo.DataFromRadar 中的方法

getMajorVersion() - 类 com.trs.service.impl.SOAPServiceImpl 中的方法

getMajorVersion() - 接口 com.trs.service.ISOAPService 中的方法
获取当前SOAP服务的版本
getManagedTemplates(IPublishFolder, int, WCMFilter, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
get the managed tempaltes in the specified folder
getManagedTemplates(CMSObj, int, WCMFilter, boolean) - 类 com.trs.service.impl.TemplateService 中的方法

getManagedTemplates(CMSObj, int, WCMFilter, boolean) - 接口 com.trs.service.ITemplateService 中的方法
获取站点/频道下管理的模板集合
getMapedType(String) - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态方法

getMapped(String) - 类 com.trs.tools.CommonResourceBuilder 中的静态方法

getMappedLink(String) - 类 com.trs.infra.util.html.ContentLinkReplacer 中的方法
取指定字符串映射链接
getMapping() - 类 com.trs.infra.config.persistent.ConfigFile 中的方法

getMappingFilePath() - 类 com.trs.template.domain.SourcePathHelper 中的静态方法

getMappingSource(ConfigFiles) - 类 com.trs.infra.config.domain.ConfigHelper 中的静态方法
组织所有的映射文件，形成一个文件流，用于Mapping对象的创建
getMappingSource(String) - 类 com.trs.infra.config.domain.ConfigHelper 中的静态方法
通过文件名得到 Mapping 的输入流
getMappingSrc() - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的方法
get the mapping src
getMarkImageFile() - 类 com.trs.wcm.photo.ImageInfo 中的方法

getMarkKinds(WCMFilter) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
获取当前登录用户的顶级书签分类
getMarkPos() - 类 com.trs.wcm.photo.ImageInfo 中的方法

getMarkShares(User) - 类 com.trs.components.common.bookmark.BookMark 中的方法
得到MarkShares
getMarkShares(User) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
得到MarkShares
getMasterFileContent(Master, int) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
获取指定母板中指定文件类型的文件内容
getMasterFileContent(Master, int) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
获取指定母板中指定文件类型的文件内容
getMasterId() - 类 com.trs.components.special.Special 中的方法
提取属性：MasteId
getMaxBufferSize() - 类 com.trs.infra.persistent.BaseObjs 中的方法
提取属性：缓冲区最大容量
getMaxCacheSize() - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法
取最大缓冲大小
getMaxClient() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回所允许的最大客户端连接数
getMaxConnects() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

getMaxId() - 类 com.trs.infra.util.database.DBIdManager.IdSeq 中的方法
属性：MaxId 最大ID值
getMaxIdleMills() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法

getMaxIdleTime() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

getMaxIndex() - 类 com.trs.infra.common.ContextParameters 中的静态方法
返回所允许的最大的参数索引值
getMaxLength() - 类 com.trs.cms.content.ExtendedField 中的方法
获得扩展字段最大长度
getMaxLength() - 类 com.trs.components.infoview.db.InfoViewDataType 中的方法

getMaxLength() - 类 com.trs.components.infoview.extract.DataType 中的方法

getMaxLength() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

getMaxLength() - 类 com.trs.components.metadata.definition.MetaDataType 中的方法

getMaxLength() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
获得扩展字段最大长度
getMaxLength() - 类 com.trs.infra.util.database.DataType 中的方法
获取最大长度
getMaxLength() - 类 com.trs.presentation.util.PageParameter 中的方法
获取参数允许的最大长度，仅仅对字符类型数据有效
getMaxLength() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
获取参数允许的最大长度，仅仅对字符类型数据有效
getMaxLimit() - 类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 中的方法

getMaxNum() - 类 com.trs.components.wcm.recent.Recent 中的静态方法
从配置文件中查询当前类型对象所能保存的最大数目
getMaxOrder(CMSObj) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法

getMaxOrder(int) - 类 com.trs.components.metadata.definition.ClassInfo 中的静态方法

getMaxOrder(CMSObj) - 类 com.trs.components.wcm.content.domain.ContentExtFieldMgr 中的方法

getMaxOrphanTime() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

getMaxPNo(int, int) - 类 com.trs.components.common.trsad.ADPoss 中的方法

getMaxRowNumber() - 类 com.trs.infra.db.QueryFilter 中的方法
获取查询的最大行数
getMaxRowNumber() - 类 com.trs.infra.persistent.WCMFilter 中的方法
获取查询的最大行数
getMaxSiteNum() - 类 com.trs.components.wcm.content.MySite 中的方法

getMaxSiteNum() - 类 com.trs.components.wcm.MyDB 中的方法

getMaxSiteNum() - 类 com.trs.infra.persistent.db.MyDate 中的方法

getMaxSiteNum() - 接口 com.trs.license.License 中的方法
获取最大站点数
getMaxSize() - 类 com.trs.infra.persistent.BaseObjs 中的方法
获取最大允许集合大小（元素个数） select top筛选
getMaxTargetsEachFolder() - 类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig 中的方法

getMaxToppedNum() - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
获得允许置顶的文档的总数
是从系统配置中获取，整个系统中有一个数值记录
getMaxToppedNum() - 接口 com.trs.service.IDocumentService 中的方法
获得允许置顶的文档的总数
是从系统配置中获取，整个系统中有一个数值记录
getMaxToppedNum() - 类 com.trs.service.impl.DocumentService 中的方法
---- ==== ---- Begin 置顶相关的操作 ---- ==== ----
getMaxUserNum() - 类 com.trs.cms.auth.persistent.UserLicenseMgr 中的方法

getMaxUserNum() - 类 com.trs.components.wcm.content.MySite 中的方法

getMaxUserNum() - 类 com.trs.components.wcm.MyDB 中的方法

getMaxUserNum() - 类 com.trs.infra.persistent.db.MyDate 中的方法

getMaxUserNum() - 接口 com.trs.license.License 中的方法
获取最大用户数
getMaxValue() - 类 com.trs.presentation.util.PageParameter 中的方法
获取允许的最大值，对非字符类型数据有效
getMaxValue() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
获取允许的最大值，对非字符类型数据有效
getMD5OfStr(String) - 类 com.trs.infra.util.CMyEncrypt 中的方法
获取经过MD5加密后的结果
getMD5OfStr(String) - 类 com.trs.infra.util.MD5 中的方法
获取经过MD5加密后的结果
getMDesc() - 类 com.trs.components.common.publish.widget.Master 中的方法
提取属性：MDesc
getMemberId() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
提取属性：MemberId
getMemberType() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
提取属性：MemberType
getMemo() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：Memo
getMessage(User) - 类 com.trs.components.common.message.MsgQueue 中的方法
取得Message对象
getMessage() - 异常 com.trs.infra.util.CMyException 中的方法
取错误消息，若rootCause非空，则同时输出rootCause的错误消息
getMessageId() - 类 com.trs.components.common.message.MsgQueue 中的方法
属性: Message 消息对象 取消息对象ID
getMessages(int, WCMFilter) - 接口 com.trs.components.common.message.IMessageService 中的方法
获取WCM中特定的类型的消息，如已读消息、已发消息
getMessages(int, User, WCMFilter) - 类 com.trs.components.common.message.MessageServer 中的静态方法
根据指定的类型(未读/已收/已发)获取消息集合
getMetaDataDefCacheMgr() - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法

getMetaDataDefMgr() - 类 com.trs.components.metadata.center.ClassInfoViewMgr 中的方法

getMetaDataID() - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
提取属性：MetaDataID
getMetaDataId() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getMetaDatasFilter(ClassInfo) - 类 com.trs.components.metadata.service.GovInfoToXML 中的静态方法

getMetaDBTable() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法

getMetaSynFields() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

getMetaView() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getMetaView() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

getMetaViewField(int, String) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法

getMetaViewField(MetaView, int) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法

getMetaViewField(int, String) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

getMetaViewField(MetaView, int) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法

getMetaViewFields(int) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法
获得指定视图下的所有视图字段
getMetaViewFields(int, int) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法
获取指定视图下，指定类型的视图字段
getMetaViewFields(int) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

getMetaViewFields(int, int) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

getMetaViewsUsingClassInfo(User, ClassInfo) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
查询使用了分类法oClassInfo的所有视图集合
getMetaViewsUsingClassInfo(User, ClassInfo) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法

getMethdoNameHashCode() - 类 com.trs.webframework.config.MethodConfig 中的方法

getMethod() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the compression method.
getMethod() - 类 com.trs.webframework.config.MethodConfig 中的方法

getMethodConfig() - 类 com.trs.webframework.context.MethodContext 中的方法

getMethodConfigsMap() - 类 com.trs.webframework.config.ServiceConfig 中的方法

getMethodContext() - 类 com.trs.webframework.controler.JSPRequestParmasValidator 中的方法

getMethodContext() - 类 com.trs.webframework.controler.servlet.BaseValidator 中的方法

getMethodContext() - 类 com.trs.webframework.controler.servlet.RequestParmasValidator 中的方法

getMethodContext() - 类 com.trs.webframework.controler.servlet.XMLParamsValidator 中的方法

getMethodName() - 类 com.trs.webframework.config.ServiceFilterConfig 中的方法

getMethodName() - 类 com.trs.webframework.config.ServiceListenerConfig 中的方法

getMethodName() - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法

getMimeMail() - 类 com.trs.infra.util.email.CMyEmail 中的方法

getMinLength() - 类 com.trs.components.infoview.extract.DataType 中的方法

getMinLength() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

getMinLength() - 类 com.trs.presentation.util.PageParameter 中的方法
获取参数允许的最小长度，仅仅对字符类型数据有效
getMinLength() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
获取参数允许的最小长度，仅仅对字符类型数据有效
getMinute() - 类 com.trs.infra.util.CMyDateTime 中的方法
获取当前对象中的【分】的部分
getMinValue() - 类 com.trs.presentation.util.PageParameter 中的方法
获取允许的最小值，对非字符类型数据有效
getMinValue() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
获取允许的最小值，对非字符类型数据有效
getMirrorChannels(Document) - 接口 com.trs.service.IDocumentService 中的方法
获得源文档所有存在同源异现镜像的频道
getMirrorChannels(Document) - 类 com.trs.service.impl.DocumentService 中的方法

getMName() - 类 com.trs.components.common.publish.widget.Master 中的方法
提取属性：MName
getMobile() - 类 com.trs.cms.auth.persistent.User 中的方法
获取移动通讯联系地址
getMobile() - 类 com.trs.components.common.address.Contact 中的方法
属性: Mobile 手机号
getMockFieldInfoFilePath() - 类 com.trs.template.domain.SourcePathHelper 中的静态方法

getModal() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Returns the content modal in the curernt folder
getModal() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

getModal() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

getModal() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

getModal() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
获得ChnlDoc的类型，包括实体、引用、镜像
getModal() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

getMode() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：计划执行类型
getModifyOp(BaseObj) - 类 com.trs.cms.logger.OperTypeHelper 中的静态方法

getModule() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
提取属性：Module
getModuleName() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法

getMonitorGroups(User) - 类 com.trs.cms.process.definition.Flow 中的方法
取工作流的监控用户组
getMonitorInterval() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

getMonitorServer() - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的静态方法

getMonitorUsers(User) - 类 com.trs.cms.process.definition.Flow 中的方法
取工作流的监控用户
getMonth() - 类 com.trs.infra.util.CMyDateTime 中的方法
获取当前对象中的【月】的部分
getMoudels() - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
获取定制的模块(不包定制的频道/站点)
getMoudels() - 接口 com.trs.service.ICustomizeService 中的方法
获取当前用户定制的模块集合
getMoudels() - 类 com.trs.service.impl.CustomizeService 中的方法

getMsgBody() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

getMsgId() - 类 com.trs.components.common.message.MsgReceiver 中的方法
获取对应的Message的ID
getMsgInterval() - 类 com.trs.cms.auth.persistent.User 中的方法
设置用户信息刷新时间
getMsgQueues(User) - 类 com.trs.components.common.message.Message 中的方法
得到消息队列
getMsgSendingConfigs() - 类 com.trs.components.common.message.MessageSendingMapper 中的方法
得到所有消息发送服务器关于message发送方式的配置信息
getMsgType() - 类 com.trs.components.common.message.MsgQueue 中的方法
MsgType有两种类型1、2
getMyDocumentImportSourceFilePath(User) - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的静态方法

getMyDocumentImportSourceFilePath() - 接口 com.trs.service.IDocumentService 中的方法
获取当前登录用户导入文档时,XSL文件的存放位置
getMyDocumentImportSourceFilePath() - 类 com.trs.service.impl.DocumentService 中的方法

getMyFlowDocs(int, int) - 类 com.trs.presentation.portal.PortalHelper 中的静态方法
得到需要我处理的文档 for portal/portal_mywork_flowdoc.jsp
getMyMac(int) - 类 com.trs.infra.util.key.MacAddressHelper 中的静态方法

getMyMacAsLong(int) - 类 com.trs.infra.util.key.MacAddressHelper 中的静态方法

getMyMacAsLong() - 类 com.trs.infra.util.key.MacAddressHelper 中的静态方法

getMyMacAsLong(String) - 类 com.trs.infra.util.key.MacAddressHelper 中的静态方法

getMyMessage() - 异常 com.trs.infra.util.CMyException 中的方法
仅仅取该异常自身的消息
getMyRights(int, int, int) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
获取指定操作者在某类对象上的操作权限
getMyRights(int) - 类 com.trs.cms.auth.persistent.Role 中的方法
取角色在指定类型的操作对象上的权限集合
getMyRights(int) - 类 com.trs.cms.auth.persistent.User 中的方法
取用户在指定类型的操作对象上的权限集合
getMyRightValue(CMSObj) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
取用户在指定对象上的操作权限值
getMyRightValue(int, int) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
取用户在指定对象上的操作权限值
getMyRightValue(CMSObj) - 类 com.trs.cms.auth.persistent.Role 中的方法
取角色在指定对象上的操作权限值
getMyRightValue(int, int) - 类 com.trs.cms.auth.persistent.Role 中的方法

getMyRightValue(CMSObj) - 类 com.trs.cms.auth.persistent.User 中的方法
取用户在指定对象上的操作权限值
getMyRightValue(int, int) - 类 com.trs.cms.auth.persistent.User 中的方法
取用户在指定对象上的操作权限值
getMysqlSQL() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：MysqlSQL
getMyTasks(WCMFilter) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
get the publish tasks of the specified user
getMyTasks(WCMFilter) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
get the publish tasks created by the specified user
getMyTasks(WCMFilter) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法

getMyTasks(WCMFilter) - 类 com.trs.service.impl.PublishService 中的方法

getMyTasks(WCMFilter) - 接口 com.trs.service.IPublishService 中的方法
提取我的发布任务
getMyUsers(int, WCMFilter) - 类 com.trs.service.impl.UserService 中的方法
获取我所创建的用户列表
getMyUsers(int, WCMFilter) - 接口 com.trs.service.IUserService 中的方法
获取我所创建的用户列表
getName() - 类 com.trs.cms.auth.config.OperationConfig 中的方法

getName() - 类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 中的方法

getName() - 类 com.trs.cms.auth.config.OperationRelatedConfig 中的方法

getName() - 类 com.trs.cms.auth.config.RightHostConfig 中的方法

getName() - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法

getName() - 类 com.trs.cms.auth.config.RightObjectConfig 中的方法

getName() - 类 com.trs.cms.auth.persistent.Group 中的方法
获取组的名称
getName() - 类 com.trs.cms.auth.persistent.RightDef 中的方法

getName() - 类 com.trs.cms.auth.persistent.Role 中的方法
获取角色名称
getName() - 类 com.trs.cms.auth.persistent.User 中的方法
获取用户名
getName() - 类 com.trs.cms.content.ExtendedField 中的方法
扩展字段名称
getName() - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法

getName() - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法

getName() - 类 com.trs.cms.process.config.FlowContentField 中的方法

getName() - 类 com.trs.cms.process.config.FlowContentTypeConfig 中的方法

getName() - 类 com.trs.cms.process.config.OperatorConfig 中的方法

getName() - 类 com.trs.cms.process.config.ParamConfig 中的方法

getName() - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法

getName() - 类 com.trs.cms.process.config.ValueConfig 中的方法

getName() - 类 com.trs.cms.process.definition.Flow 中的方法
获取工作流名称
getName() - 类 com.trs.cms.process.definition.FlowNode 中的方法
获取节点名称
getName() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
获取分支描述
getName() - 类 com.trs.cms.process.definition.FlowRule 中的方法
提取属性：Name
getName() - 类 com.trs.components.common.address.ContactGrp 中的方法
属性: Name,名称 （可以修改）
getName() - 类 com.trs.components.common.bookmark.BookMark 中的方法
属性: Name,名称
getName() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
属性: Name 名称
getName() - 类 com.trs.components.common.calendar.EventType 中的方法
Name: 名称
getName() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：名称
getName() - 类 com.trs.components.common.message.MessageSendingConfig 中的方法

getName() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

getName() - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法

getName() - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法

getName() - 类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig 中的方法

getName() - 类 com.trs.components.common.publish.config.persistent.PublishElementConfig 中的方法

getName() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

getName() - 类 com.trs.components.common.publish.config.persistent.TagFormatterConfig 中的方法

getName() - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 中的方法

getName() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

getName() - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法

getName() - 类 com.trs.components.common.publish.config.PublishElementType 中的方法

getName() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
返回属性名称
getName() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type 中的方法
返回属性类型的名称
getName() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType 中的方法
返回属性类型的名称
getName() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
返回置标的名称
getName() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法

getName() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 中的方法
返回变量类型的名称
getName() - 类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 中的方法

getName() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法

getName() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获得模板的名称
getName() - 类 com.trs.components.common.publish.widget.Layout 中的方法
提取属性：Name
getName() - 类 com.trs.components.infoview.config.BindingBean 中的方法

getName() - 类 com.trs.components.infoview.config.GatewayPage 中的方法

getName() - 类 com.trs.components.infoview.extract.DataGroup 中的方法

getName() - 类 com.trs.components.infoview.extract.DataType 中的方法

getName() - 类 com.trs.components.infoview.extract.manifest.FileProperty 中的方法

getName() - 类 com.trs.components.infoview.extract.manifest.MenuArea 中的方法

getName() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

getName() - 类 com.trs.components.infoview.extract.manifest.PackageFile 中的方法

getName() - 类 com.trs.components.infoview.extract.manifest.View 中的方法

getName() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getName() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getName() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

getName() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

getName() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回视图的名称
getName() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
提取属性：Name
getName() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：Name
getName() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
提取属性：Name
getName() - 类 com.trs.components.metadata.definition.MetaView 中的方法
提取属性：Name
getName() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：Name
getName() - 类 com.trs.components.wcm.channel.VChannel 中的方法

getName() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
获取对象的名称
getName() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道的名称
getName() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
获取名称
getName() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
扩展字段名称
getName() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
获取名称
getName() - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法

getName() - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法

getName() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
获取替换名称
getName() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取站点名称
getName() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
提取属性：Name
getName() - 类 com.trs.components.wcm.resource.DocKind 中的方法

getName() - 类 com.trs.components.wcm.resource.FileType 中的方法

getName() - 类 com.trs.components.wcm.resource.Security 中的方法
获取名称
getName() - 类 com.trs.components.wcm.resource.Source 中的方法
获取来源名称
getName() - 类 com.trs.components.wcm.resource.Status 中的方法
获取状态名称
getName() - 类 com.trs.components.wcm.WCMAppConfig 中的方法

getName() - 类 com.trs.infra.config.persistent.BeanConfig 中的方法

getName() - 类 com.trs.infra.config.persistent.ExtensionConfigs 中的方法

getName() - 接口 com.trs.infra.config.persistent.IConfigElement 中的方法
获取配置对象的名称
getName() - 类 com.trs.infra.config.persistent.PluginConfig 中的方法

getName() - 类 com.trs.infra.persistent.cache.CachedObjectConfig 中的方法

getName() - 类 com.trs.infra.persistent.CMyParameter 中的方法

getName() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

getName() - 类 com.trs.infra.persistent.db.DBConnectionConfigs 中的方法

getName() - 类 com.trs.infra.persistent.listener.MonitorHostConfig 中的方法

getName() - 类 com.trs.infra.persistent.listener.ObjectLCListenerConfig 中的方法

getName() - 类 com.trs.infra.persistent.listener.ObjectMonitored 中的方法

getName() - 类 com.trs.infra.persistent.ObjectTypeConfig 中的方法

getName() - 类 com.trs.infra.ServerConfig 中的方法

getName() - 类 com.trs.infra.support.cache.CacheMgrConfig 中的方法

getName() - 类 com.trs.infra.support.config.SystemCollocationConfig 中的方法

getName() - 类 com.trs.infra.support.log.OperType 中的方法

getName() - 类 com.trs.infra.update.UpdateCommanderConfig 中的方法

getName() - 类 com.trs.infra.util.cabfile.CabEntry 中的方法

getName() - 类 com.trs.infra.util.cabfile.CabFile 中的方法

getName() - 类 com.trs.infra.util.CMyBeanConfig 中的方法

getName() - 类 com.trs.infra.util.CMyClassConfig 中的方法

getName() - 类 com.trs.infra.util.CMyXMLElement 中的方法

getName() - 类 com.trs.infra.util.database.DataType 中的方法
获取类型名称
getName() - 类 com.trs.infra.util.database.DBType 中的方法
取数据库类型名称
getName() - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

getName() - 类 com.trs.infra.util.email.SMTPServerConfigs 中的方法

getName() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
获取名称
getName() - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取Html元素标记
getName() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Returns the entry name.
getName() - 类 com.trs.infra.util.jazzlib.ZipFile 中的方法
Returns the name of this zip file.
getName() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getName() - 类 com.trs.presentation.ids.RegFromConfig 中的方法

getName() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
模块名称
getName() - 类 com.trs.presentation.util.PageParameter 中的方法
获取名称
getName() - 类 com.trs.scene.parser.SceneConnector 中的方法

getName() - 类 com.trs.scene.parser.SceneNode 中的方法

getName() - 类 com.trs.scene.tools.SceneNode 中的方法

getName() - 类 com.trs.wcm.config.PageOperator 中的方法
提取属性：Name
getName() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
提取属性：Name
getName() - 类 com.trs.wcm.photo.ImageKind 中的方法

getName() - 类 com.trs.webframework.config.MethodConfig 中的方法

getName() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
获取名称
getNameAt(int) - 类 com.trs.infra.util.AttributesString 中的方法

getNameCacheMaxSize() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

getNamedParamsMap() - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法

getNameList() - 类 com.trs.infra.util.AttributesString 中的方法

getNameMaps() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 中的方法
返回含有所有形式参数名的HashMap对象
getNamePath(ClassInfos) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
由指定的分类法得到从根节点到这个分类法节点的id序列
getNamePath(ClassInfo) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
由指定的分类法得到从根节点到这个分类法节点的id序列
getNamePath(ClassInfos) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法

getNamePath(ClassInfo) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法

getNamespace() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

getNavHandler(String) - 类 com.trs.presentation.nav.NavHandlerFactory 中的静态方法

getNeedExpandTreeNodes() - 类 com.trs.presentation.nav.TreeNodeCalctor 中的方法

getNeedImportFileAt(int) - 类 com.trs.wcm.old.ImportDocsContext 中的方法

getNeedImportSize() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
获取需要导入的文档数目
getNeedInit() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getNestedTemplate(IPublishElement, String) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法

getNestedTemplates(Template) - 类 com.trs.components.common.publish.domain.template.TemplateNestMgr 中的方法
get the nested templates
getNestedTemplates(Template) - 类 com.trs.service.impl.TemplateService 中的方法

getNestedTemplates(Template) - 接口 com.trs.service.ITemplateService 中的方法
获取当前模板中使用到的嵌套模板
getNestParsed() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 中的方法
判断是否已经设置过被嵌套模板的变量
getNewAttribute() - 类 com.trs.infra.persistent.BaseObj 中的方法

getNewAttributesString() - 类 com.trs.infra.persistent.BaseObj 中的方法
共用接口：属性创建扩展属性Attribute读操作 说明：子类可以通过重载禁止使用
getNewAttributeValue(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
获取扩展属性的值（编辑模式下的新值）
getNewBindName() - 类 com.trs.components.infoview.extract.DataType 中的方法

getNewcols() - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
获取新增加的列
getNewFile() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回该视图的，经过系统修改、重整之后的XSL文件的文件名
getNewInfoPathFile() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getNewPasswd() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
获取新的数据库用户密码
getNewProperties() - 类 com.trs.infra.persistent.BaseObj 中的方法

getNewProperty(String) - 类 com.trs.infra.persistent.BaseObj 中的方法

getNewPropertyAsInt(String, int) - 类 com.trs.infra.persistent.BaseObj 中的方法

getNewPropertyAsString(String) - 类 com.trs.infra.persistent.BaseObj 中的方法

getNewSchema() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法

getNewsID() - 类 com.trs.components.comment.domain.Management 中的方法
返回WCM中的文档ID
getNewSiteDesc() - 类 com.trs.components.wcm.content.domain.ChannelImporter 中的方法

getNewSiteName() - 类 com.trs.components.wcm.content.domain.ChannelImporter 中的方法

getNewsTitle() - 类 com.trs.components.comment.domain.Management 中的方法
返回WCM中的文档标题
getNewSureFormFileName() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
在编辑模式下，获得用户新增加的书生表单文件名称
getNewTransform() - 类 com.trs.components.infoview.extract.manifest.View 中的方法

getNewUrl() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
获取新的数据库连接URL
getNewUser() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
获取新的数据库用户
getNewUserInfos() - 类 com.trs.components.metadata.service.ClassInfoToGroupCreator 中的方法

getNewXSLTFile() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getNext() - 类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 中的方法
Returns the next page task to execute.
getNextChnlDoc(ChnlDoc, boolean) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
得到频道内，当前频道文档的后一个频道文档。
getNextConnectors() - 类 com.trs.scene.parser.SceneNode 中的方法

getNextEntry() - 类 com.trs.infra.util.jazzlib.ZipInputStream 中的方法
Open the next entry from the zip archive, and return its description.
getNextEntry(String) - 类 com.trs.infra.util.jazzlib.ZipInputStream 中的方法

getNextFileName(String, String, CMyDateTime, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
获取下一个可用的文件名称 构造说明： [1]构造文件名时，自动检测文件名是否重复。
getNextFileName(String, String) - 类 com.trs.infra.support.file.FilesMan 中的方法
获取下一个可用的文件名称
getNextFileName(String, String, CMyDateTime) - 类 com.trs.infra.support.file.FilesMan 中的方法
获取下一个可用的文件名称
getNextFilePathName(String, String) - 类 com.trs.infra.support.file.FilesMan 中的方法
获取下一个可用的文件名称
getNextFilePathName(String, String, CMyDateTime) - 类 com.trs.infra.support.file.FilesMan 中的方法
获取下一个可用的文件名称
getNextFlowNodes(FlowDoc, boolean) - 类 com.trs.cms.process.FlowServerImpl 中的方法

getNextFlowNodes(FlowDoc, boolean) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取当前轨迹的下一个处理节点
getNextId(String, String) - 类 com.trs.infra.util.database.ClusterDBIdManager 中的静态方法
获取指定表的下一个可用ID.
getNextId(BaseObj, Connection, boolean) - 类 com.trs.infra.util.database.DBIdManager 中的方法

getNextId(String, String, Connection, boolean) - 类 com.trs.infra.util.database.DBIdManager 中的方法

getNextId() - 类 com.trs.infra.util.database.DBIdManager.IdSeq 中的方法
取下一个有效的Id值 若已经达到最大值，则返回-1； 若为0，则表示需要从对应数据表中获取最大ID值
getNextId() - 类 com.trs.scene.tools.SceneNode 中的方法

getNextIndex() - 类 com.trs.infra.common.BaseContextHelper 中的静态方法

getNextNode(User) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
取下一个节点对象
getNextNode() - 类 com.trs.cms.process.engine.FlowContext 中的方法

getNextNode() - 类 com.trs.cms.process.engine.FlowParamers 中的方法

getNextNode() - 类 com.trs.scene.parser.SceneConnector 中的方法

getNextNodeName() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
获取下一个节点名称
getNextNodes(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
获取当前节点下一个节点集合
getNextNodes(User) - 类 com.trs.cms.process.definition.FlowNode 中的方法
获取下一个节点集合
getNextNodes(User, WCMFilter) - 类 com.trs.cms.process.definition.FlowNode 中的方法

getNextPageIndex() - 类 com.trs.infra.util.CPager 中的方法
取下一页的页号
getNextPageTask() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPageTaskDispatcher 中的方法
Returns the next task to execute.
getNextPageTask() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法
Fetchs next page task to execute.
getNextPageTask() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法

getNextRecordContext() - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 中的方法

getNextRecordContext() - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser4List 中的方法
Returns the tag parse context of the next record.
getNextRecordContext() - 类 com.trs.components.metadata.publish.WCMTagParserClassInfos 中的方法

getNextRecordContext() - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法

getNextRecordContext() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 中的方法

getNextRecordContext() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法

getNextRecordContext() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法

getNextSerial() - 类 com.trs.components.infoview.persistent.InfoViewSerial 中的方法
获取下一个可用序号
getNextSerial(int, int, int) - 类 com.trs.components.infoview.persistent.InfoViewSerialGenerator 中的方法
获取指定表单的下一个编号
getNextTask() - 接口 com.trs.components.common.publish.domain.taskdispatch.IAtomTaskList 中的方法
返回列表中的下一个任务，如果列表中为空或者已经没有任务，则返回null。
getNickName() - 类 com.trs.cms.auth.persistent.User 中的方法
获取昵称
getNickName() - 类 com.trs.components.common.address.Contact 中的方法
属性: NickName 昵称
getNillable() - 类 com.trs.components.infoview.extract.DataType 中的方法

getNode() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
获取第一个节点对象
getNode() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取所在的节点对象
getNodeHref(int, int) - 类 com.trs.presentation.navigation.TreeItem 中的静态方法

getNodeId() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
获取第一个节点的ID
getNodeId() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
提取属性：NodeId
getNodeId() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取所在的节点ID
getNodeList(String) - 类 com.trs.components.wcm.content.domain.WCMDocAppendixesParserForImporter 中的静态方法

getNodes(SceneNode) - 类 com.trs.scene.tools.SceneNodeAction 中的方法
获取所有的节点ArrayList 所有保存在一个大ArrayList中,每一层又保存在一个ArrayList中
getNoiseLevel() - 类 com.trs.weblet.util.verfiycode.VerifyCode 中的方法
返回噪声级别
getNoneRelatedDocIds(int, int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法

getNoneRelatedDocIds(int, int) - 类 com.trs.components.comment.service.CommentService 中的方法

getNoneRelatedDocIds(int, int) - 接口 com.trs.components.comment.service.ICommentService 中的方法

getNonReservedGatewayPageProps() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getNoOverWrite() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 中的方法
返回是否禁止改写
getNotEdit() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：NotEdit
getNoticeContentPattern() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取回复内容模板
getNoticeRelatedField() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取回复通知目标相关联的表单项
getNoticeSubjectPattern() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取回复主题的模板
getNotification(int) - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

getNotifications() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

getNotify() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
设置通知方式
getNotifyRootPath() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler 中的静态方法

getNotifyType() - 类 com.trs.cms.process.engine.FlowParamers 中的方法

getNotifyTypes() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
获取通知的方式
getNotifyTypes() - 类 com.trs.cms.process.engine.FlowContext 中的方法

getNotifyTypes() - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法

getNotnull() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：Notnull
getNum() - 类 com.trs.wcag2.Alertion 中的方法

getObj() - 类 com.trs.components.web.BasePropertiesBuilder 中的方法

getObjAsChannel(User) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
若定制对象为频道，则取其对应的频道对象 //why: 2002-04-02 扩展接口 说明：若不是频道对象，则返回null.
getObjClass() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法

getObjClassName() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
提取属性：ObjClass
getObjCrTime() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
提取属性：ObjCrTime
getObjCrUser() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
提取属性：ObjCrUser
getObjDesc() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
提取属性：ObjDesc
getObject(User) - 类 com.trs.components.common.bookmark.MarkShare 中的方法
取共享的对象（ BookMark / MarkKind ）
getObjectAsString(Object, int) - 类 com.trs.components.wcm.wcmx.jsp.DataUtil 中的静态方法
将指定类型的数据转换为字符串
getObjectClass() - 类 com.trs.infra.persistent.ObjectTypeConfig 中的方法

getObjectClassName() - 类 com.trs.infra.persistent.ObjectTypeConfig 中的方法

getObjectId() - 类 com.trs.webframework.context.MethodContext 中的方法

getObjectId() - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法

getObjectIds() - 类 com.trs.ajaxservice.xmlconvertors.XMLToCMSObj 中的方法

getObjectIds() - 类 com.trs.webframework.context.MethodContext 中的方法

getObjectIds() - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法

getObjectIdsAsString(int) - 类 com.trs.components.wcm.individuation.IndividuationMgr 中的方法
得到当前登陆用户的自定义站点或栏目id字符串序列
getObjectIdsHashtable(int) - 类 com.trs.components.wcm.individuation.IndividuationMgr 中的方法
得到当前登陆用户的自定义站点或栏目id的Hasttable对象(key:objectId,value:true)
getObjectIdsValue() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
提取属性：ObjectIdsValue
getObjectMember(int, int, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
获取可访问可操作对象
getObjectMember(int, int, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法
获取ObjectMember
getObjectType() - 类 com.trs.infra.persistent.ObjectTypeConfig 中的方法

getObjectValue(String) - 类 com.trs.webframework.context.MethodContext 中的方法

getObjFromBuffer(String, int) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法

getObjFromBuffer(Class, int) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法

getObjFromBuffer(Class, Object) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法

getObjFromBuffer(String, int) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法

getObjFromBuffer(Class, int) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法

getObjFromBuffer(Class, Object) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法

getObjId() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
提取属性：ObjId
getObjId() - 类 com.trs.cms.auth.persistent.Right 中的方法
获取操作对象（WCMObj）ID
getObjId() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：ObjId
getObjId() - 类 com.trs.components.common.bookmark.MarkShare 中的方法
属性: ObjId 对象ID
getObjId() - 类 com.trs.components.common.calendar.EventShare 中的方法
提取属性：ObjId
getObjId() - 类 com.trs.components.common.message.MsgQueue 中的方法
属性: ObjId
getObjId() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
提取属性：ObjId
getObjId() - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
提取属性：ObjId
getObjId() - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法

getObjId() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
属性: ObjId, 对象ID，只读
getObjId() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
提取属性：ObjId
getObjId() - 类 com.trs.components.wcm.recent.Recent 中的方法
提取属性：ObjId
getObjId() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取日志操作对象编号
getObjId() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志操作对象编号
getObjKlassName() - 类 com.trs.webframework.config.ServiceConfig 中的方法

getObjName() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
提取属性：ObjName
getObjName(int, boolean) - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态方法
取指定类型的对象名称
getObjName(int, boolean) - 类 com.trs.infra.common.WCMTypes 中的静态方法
取指定类型的对象名称
getObjName() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取日志操作对象名称
getObjName() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志操作对象名称
getObjName() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
提取属性：ObjName
getObjPath() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
提取属性： ObjPath
getObjsName() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
提取属性：ObjsName
getObjsPath() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
提取属性： ObjsPath
getObjType() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
提取属性：ObjType
getObjType() - 类 com.trs.cms.auth.persistent.Right 中的方法
获取操作对象（WCMObj）类型（定义在WCMTypes中）
getObjType() - 类 com.trs.cms.auth.persistent.RightDef 中的方法

getObjType() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：ObjType
getObjType() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
提取属性：ObjType
getObjType() - 类 com.trs.components.common.bookmark.MarkShare 中的方法
属性: ObjType 对象类型
getObjType() - 类 com.trs.components.common.calendar.EventShare 中的方法
提取属性：ObjType
getObjType() - 类 com.trs.components.common.message.MsgQueue 中的方法
属性: ObjType
getObjType() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
提取属性：ObjType
getObjType() - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
提取属性：ObjType
getObjType() - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法

getObjType() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
属性: ObjType，只读，对象类型
getObjType() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
提取属性：ObjType
getObjType() - 类 com.trs.components.wcm.recent.Recent 中的方法
提取属性：ObjType
getObjType() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取日志操作对象类型
getObjType() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志操作对象类型
getObjType() - 类 com.trs.template.persistent.TagFieldInfoEntity 中的方法

getOderSelect() - 类 com.trs.infra.db.QueryFilter 中的方法

getOderSelect() - 类 com.trs.infra.persistent.WCMFilter 中的方法

getOffset() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
返回当前字符的偏移位置
getOffspringGroupIds(String, boolean) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
返回所有的子孙组IDs,确定是否包含自身
getOffspringGroups(Group, boolean, WCMFilter) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
返回所有的子孙组,确定是否包含自身
getOffspringGroups(User, WCMFilter) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
根据用户_user获取，_user可以管理的所有组织,也就是_user作为组管理员的组织,同时包含子孙组织
getOldFile() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回该视图的、原始的、InfoPath中的、XSL文件的文件名
getOldPasswd() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
获取旧的数据库用户密码
getOldSchema() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法

getOldUrl() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
获取旧的数据库连接URL
getOldUser() - 类 com.trs.infra.util.upgrade.DbConfig 中的方法
获取旧的数据库用户
getOnlineUserCount() - 类 com.trs.presentation.util.LoginHelper 中的静态方法

getOnlineUsers() - 类 com.trs.ajaxservice.UserServiceProvider 中的方法
获取系统在线用户
getOnlineUsers() - 类 com.trs.presentation.login.SessionListener 中的静态方法

getOnlineUsers() - 类 com.trs.presentation.util.LoginHelper 中的静态方法

getOpArgs() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取日志操作参数
getOpArgs() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志操作参数
getOpenMode() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

getOpenProgram() - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的方法

getOpenWith() - 类 com.trs.components.wcm.resource.FileType 中的方法

getOperArgNames() - 类 com.trs.components.common.job.Schedule 中的方法
获取所有的参数名称列表
getOperArgs() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：操作参数
getOperArgValue(String) - 类 com.trs.components.common.job.Schedule 中的方法
获取指定参数的数据
getOperationConfigs(String) - 类 com.trs.cms.auth.config.RightConfigServer 中的方法

getOperationMark() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法

getOperations() - 类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 中的方法

getOperations() - 类 com.trs.cms.auth.config.OperationRelatedConfig 中的方法

getOperator() - 类 com.trs.cms.auth.persistent.Right 中的方法
获取权限操作者对象（用户/角色）
getOperatorConfigs() - 类 com.trs.cms.process.config.ParamConfig 中的方法

getOperatorId() - 类 com.trs.cms.auth.persistent.Right 中的方法
获取权限操作者（用户/角色）ID
getOperators(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
获取针对指定的单个或者多个栏目的操作集合
getOperators(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法

getOperators(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
获取扩展字段的操作
getOperators(MethodContext) - 类 com.trs.ajaxservice.SourceServiceProvider 中的方法
获取针对指定的单个或者多个来源的操作集合
getOperators(MethodContext) - 类 com.trs.ajaxservice.StatusServiceProvider 中的方法
获取针对指定的单个或者多个状态的操作集合
getOperators(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
获取针对指定的单个或者多个模板的操作集合
getOperators(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法

getOperatorsInChannel(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
获取进入当前栏目的子栏目列表时针对于当前栏目的操作
getOperatorsInSite(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
获取进入当前站点在进入子栏目列表时候的操作
getOperatorsInSiteRoot() - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法

getOperatorType() - 类 com.trs.cms.auth.persistent.Right 中的方法
获取权限操作者（用户/角色）类型(定义在WCMTypes)
getOperGroups(User) - 类 com.trs.cms.process.definition.FlowNode 中的方法
取节点上的操作用户组
getOperName(int) - 类 com.trs.infra.common.WCMTypes 中的静态方法
取指定操作类型的名称
getOperNodeURL(int) - 类 com.trs.presentation.common.PageViewConstants 中的静态方法

getOperRootURL(int) - 类 com.trs.presentation.common.PageViewConstants 中的静态方法

getOpers() - 类 com.trs.infra.util.TRSLocaleAuto 中的静态方法

getOperTime() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
获得操作时间
getOperTypeDesc() - 类 com.trs.infra.support.log.BaseDBLog 中的方法

getOperTypeDesc() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志操作类型的具体描述
getOperTypes() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
获取触发自动保存的操作类型
getOperUser() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
获得OperUser
getOperUserName() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
获得操作用户的名字
getOperUsers(User) - 类 com.trs.cms.process.definition.FlowNode 中的方法
取节点上的操作用户集合
getOperUsers(User, boolean) - 类 com.trs.cms.process.definition.FlowNode 中的方法

getOperUsers(User, boolean, String, String, String) - 类 com.trs.cms.process.definition.FlowNode 中的方法
返回节点上定义的用户
getOpinion() - 类 com.trs.cms.process.engine.FlowParamers 中的方法

getOprKey() - 类 com.trs.wcm.config.PageOperator 中的方法
提取属性：OprKey
getOpTime() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取操作时间
getOpTime() - 接口 com.trs.infra.support.log.ILog 中的方法
获取操作时间
getOption() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法

getOption() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法
获取检索时的检索选项掩码
getOption() - 类 com.trs.components.wcm.stat.domain.TimingChartProducer 中的方法

getOptionalTemplates(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
获取指定的对象可选择的模板
getOptionalTemplates(IPublishFolder, int, WCMFilter, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
get the managed tempaltes in the specified folder
getOptionalTemplates(IPublishFolder, int, WCMFilter, boolean) - 类 com.trs.service.impl.TemplateService 中的方法

getOptionalTemplates(IPublishFolder, int, WCMFilter, boolean) - 接口 com.trs.service.ITemplateService 中的方法
获取指定Folder中可选的模板集合
getOptionId() - 类 com.trs.components.common.trsvote.VoteData 中的方法
提取属性：OptionId
getOptionId() - 类 com.trs.components.common.trsvote.VoteOption 中的方法
提取属性：OptionId
getOpType() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取日志操作类型
getOpType() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志操作类型
getOpTypeId() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取日志操作类型
getOpTypeId() - 接口 com.trs.infra.support.log.ILog 中的方法
获取日志操作类型
getOracleSQL() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：OracleSQL
getOrder() - 类 com.trs.cms.process.definition.FlowAction 中的方法
提取属性：Order
getOrder() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
提取属性：Order
getOrder() - 类 com.trs.cms.process.definition.FlowRule 中的方法
提取属性：Order
getOrder() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：Order
getOrder() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
分类顺序
getOrder() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：Order
getOrder() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法

getOrder() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道排序序号
getOrder() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
获取排序序号
getOrder() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取站点排序序号
getOrder() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
属性: RangeIndex，只读，排列顺序
getOrder() - 类 com.trs.components.wcm.resource.Source 中的方法
获取排序序号
getOrder() - 类 com.trs.infra.db.QueryFilter 中的方法
获取排序条件
getOrder() - 类 com.trs.infra.persistent.WCMFilter 中的方法
获取排序条件
getOrder() - 类 com.trs.wcm.config.PageOperator 中的方法
提取属性：Order
getOrderBy() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道默认的排序方式
getOrderBy() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取站点默认的排序方式
getOrderBy() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法

getOrderField() - 类 com.trs.presentation.util.RequestHelper 中的方法

getOrderSQL() - 类 com.trs.presentation.util.RequestHelper 中的方法
获取当前条件下的排序语句
getOrderType() - 类 com.trs.presentation.util.RequestHelper 中的方法

getOrganizeCode() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：OrganizeCode
getOrigImageFileName(Document, boolean) - 类 com.trs.wcm.photo.ImageLibHelper 中的静态方法

getOrigImageFilePath(Document, boolean) - 类 com.trs.wcm.photo.ImageLibHelper 中的静态方法
返回图片的原图的图径，若文档已发布，则返回该图的发布路径
getOriginalHome() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Returns the folder where this content originally lies.
getOriginalHome() - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

getOriginalHome() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

getOriginalHome() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

getOriginalHome() - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

getOriginalHome() - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

getOriginalHome() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

getOriginalUrls(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法

getOtherImageKinedId() - 类 com.trs.wcm.photo.ImageInfo 中的方法

getOtherOutlineTemplateIds() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法

getOtherOutlineTemplates(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
获取当前folder的其它概览模板集.
getOtherRelatedKindIds() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取其它的默认分类
getOtherRelatedKindIds() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getOtherTableIds() - 类 com.trs.components.metadata.definition.MetaView 中的方法
获取其它相关的表
getOtherTableName() - 类 com.trs.components.wcm.content.persistent.Document 中的方法

getOtherTables(User, WCMFilter) - 类 com.trs.components.metadata.definition.MetaView 中的方法

getOuterKMTRSServer(String, String, String, String) - 类 com.trs.components.wcm.content.trsserver.OuterKMTRSServer 中的静态方法
单体引用器
getOuterMultiCount() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：OuterMultiCount
getOutlineDBFields() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取概览DB字段
getOutlineExt() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取概览页面的扩展名
getOutlineFields() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取概览字段
getOutlineFields(InfoView) - 类 com.trs.components.infoview.persistent.InfoViewFields 中的静态方法

getOutlineFields() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取该在频道概览页面需要显示的字段列表，以逗号分隔
getOutlineFields() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
概览页面字段列表
getOutlineFile() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道概览文件名
getOutlineFileName() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
提取属性：OutlineFileName
getOutlineFileName() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：OutlineFileName
getOutlineName() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取概览页面的文件名
getOutlinePageCount() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法

getOutlinePageCount() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法

getOutlinePageCount() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
返回共计发布了多少概览页面
getOutlineTemplateId() - 类 com.trs.wcm.photo.ImageKind 中的方法

getOutlineTemplateIds() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：OutlineTemplateId
getOutlineTemplates(IPublishFolder) - 接口 com.trs.components.common.publish.domain.template.ITemplateEmployCacheMgr 中的方法

getOutlineTemplates(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法

getOutlineTemplates() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法

getOutlineTemplates(IPublishFolder) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法
get the outline templates of the specified folder.
getOutlineTemplates() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
get the outline templates of the current folder.
getOutlineTemplates() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法

getOutlineTemplates() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getOutlineTemplates() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getOutlineTemplates(IPublishFolder) - 类 com.trs.service.impl.TemplateService 中的方法

getOutlineTemplates(IPublishFolder) - 接口 com.trs.service.ITemplateService 中的方法
获得指定频道的概览模板
getOutputFileExt() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获得模板的扩展名；若没有设置，则返回htm(PublishConstants.DEF_PAGE_FILEEXT)
getOutputFileName() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获取模板发布后生成的文件名(不含扩展名)；仅当模板为概览模板时有效。
getOutString() - 类 com.trs.components.common.trsad.ADType 中的方法
提取属性：OutString
getOutUpId() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取外部上传ID
getOwner() - 类 com.trs.cms.process.definition.Flow 中的方法
获取工作流所属的对象
getOwner() - 类 com.trs.cms.process.xml.FlowImporter 中的方法

getOwner() - 类 com.trs.components.common.calendar.Event 中的方法

getOwner() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
获取视图所属对象
getOwner() - 类 com.trs.components.metadata.definition.MetaView 中的方法
获取视图所属对象
getOwner() - 类 com.trs.components.wcm.customize.UserSetting 中的方法

getOwnerFlow() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取当前所属对象的工作流对象
getOwnerFlow() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getOwnerFlow() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getOwnerId() - 类 com.trs.cms.process.definition.Flow 中的方法

getOwnerId() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
获取视图所属对象ID
getOwnerId() - 类 com.trs.components.metadata.definition.MetaView 中的方法
获取视图所属对象ID
getOwnerName() - 类 com.trs.components.common.calendar.Event 中的方法
属性：Owner 拥有者
getOwnerType() - 类 com.trs.cms.process.definition.Flow 中的方法

getOwnerType() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
获取视图所属对象Type
getOwnerType() - 类 com.trs.components.metadata.definition.MetaView 中的方法
获取视图所属对象Type
getPackage() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
元素和集合存放的Package路径
getPageContext() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Returns the page generate context
getPageCount() - 类 com.trs.infra.persistent.BaseObjs 中的方法
取集合的总页数
getPageCount() - 类 com.trs.infra.util.CPager 中的方法
获取页数
getPageElement() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
Returns the element (a folder or a content) of this page to publish.
getPageElement() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

getPageEncoding() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
获取站点的页面编码
发布产生的静态页面使用的页面编码,默认为GBK
getPageEncoding() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
获取站点的页面编码
发布产生的静态页面使用的页面编码
getPageFilter(WCMFilter) - 类 com.trs.presentation.util.RequestHelper 中的方法

getPageFolder() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
Returns the folder where the current page lies.
getPageFolder() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

getPageHref(int) - 类 com.trs.infra.util.CPager 中的方法
取页面链接
getPageHttpPath() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
Returns the http path of current page.
getPageHttpPath() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

getPageHttpURL() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
Returns the http URL of current page.
getPageIndex() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法

getPageIndex() - 类 com.trs.webframework.context.MethodContext 中的方法
获取当前的页码，从1开始；默认为第一页
getPageInfo(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法

getPageInfo(MethodContext) - 类 com.trs.ajaxservice.IndividuationServiceProvider 中的方法

getPageNextHtml(CPager, String) - 类 com.trs.components.wcm.wcmx.jsp.PageUtil 中的静态方法

getPageNextHtml(CPager, String, String, String, String, String, String) - 类 com.trs.components.wcm.wcmx.jsp.PageUtil 中的静态方法
获取翻页的HTML代码
getPageNumHtml(CPager) - 类 com.trs.components.wcm.wcmx.jsp.PageUtil 中的静态方法

getPageNumHtml(CPager, String, String) - 类 com.trs.components.wcm.wcmx.jsp.PageUtil 中的静态方法

getPageOpertators(User, String, WCMFilter) - 类 com.trs.wcm.customize.CustomizeMgrImpl 中的方法

getPageOpertators(User, String, WCMFilter) - 接口 com.trs.wcm.customize.ICustomizeMgr 中的方法
获取指定用户指定类型的操作
getPageParameter() - 类 com.trs.webframework.config.MethodConfig 中的方法

getPager() - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

getPages() - 类 com.trs.presentation.util.PageParameters 中的静态方法

getPageSize() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法

getPageSize() - 类 com.trs.infra.db.QueryFilter 中的方法

getPageSize() - 类 com.trs.infra.persistent.BaseObjs 中的方法
属性提取：分页大小
getPageSize() - 类 com.trs.infra.persistent.WCMFilter 中的方法

getPageSize() - 类 com.trs.infra.util.CPager 中的方法
获取页面大小
getPageSize() - 类 com.trs.webframework.context.MethodContext 中的方法
获取当前的分页大小，默认为20
getPageStyleId() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
提取属性：页面风格ID
getPageStyleId() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
提取属性：页面风格ID
getPageTaskCount() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法

getPageTaskCount() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：PageTaskCount
getParam() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：参数
getParam(String, boolean) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法

getParam(String, CMyDateTime) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法

getParam(String, double) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法

getParam(String, float) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法

getParam(String, int) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法

getParam(String, long) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法

getParam(String) - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法

getParam(String) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParam(String, boolean) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParam(String, int) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParam(String, long) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParam(String, double) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParam(String, float) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParam(String, CMyDateTime) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParamConfigs() - 类 com.trs.cms.process.config.ActionHandlerConfig 中的方法

getParamConfigs() - 类 com.trs.cms.process.config.ConditionHandlerConfig 中的方法

getParamCount() - 类 com.trs.components.common.job.JobWorkerType 中的方法

getParamDisp(String) - 类 com.trs.components.common.job.JobWorkerType 中的方法

getParameter(String) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

getParameter(String, String) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

getParameter(String, int) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

getParameter(String, CMyDateTime) - 类 com.trs.cms.process.QueryFlowDocContext 中的方法

getParameter(String) - 类 com.trs.components.common.message.notify.Notifier 中的方法
get the parameter value
getParameter(String) - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameterList 中的方法
返回指定名称的形式参数对象
getParameterDefault() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回形式参数缺省值的完全设置
getParameterDefaultDisplay() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回形式参数缺省值的显示值
getParameterDefaultValue() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回形式参数缺省值的有效值
getParameterName() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回形式参数的名称
getParameterNames() - 类 com.trs.webframework.context.ServiceContext 中的方法

getParameterNames() - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParameters() - 类 com.trs.components.common.publish.config.persistent.TargetTypeConfig 中的方法

getParameters() - 类 com.trs.components.common.publish.config.PublishDistributionTargetType 中的方法
Returns the parameters config.
getParameters(WidgetInstance) - 接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr 中的方法
根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写 修改说明：先取资源默认的资源变量值，再用资源变量实例值覆盖，防止添加资源变量后 在解析资源代码时有些变量不能替换的问题
getParameters(WidgetInstance, String) - 接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr 中的方法
根据资源块实例获取到指定的资源块实例变量对象,Map中的key为变量名的大写
getParameters(WidgetInstance) - 类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 中的方法

getParameters(WidgetInstance, String) - 类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 中的方法

getParameters(int) - 类 com.trs.presentation.publish.template.CMyTemplateWizard 中的静态方法
获取指定置标代码样例中的参数列表
getParameters() - 类 com.trs.webframework.context.ServiceContext 中的方法

getParameters() - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParametersOfPage(String, String) - 类 com.trs.presentation.util.PageParameters 中的静态方法
根据页面文件获取页面配置参数信息
getParameterType() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回形式参数的类型
getParameterTypesCount() - 类 com.trs.components.common.publish.widget.WidgetParameterTypes 中的方法
获取类型的个数
getParameterValue(String) - 类 com.trs.cms.process.engine.handlers.ActionParametersAnalyser 中的方法
获取指定参数的值
getParameterValue(String) - 类 com.trs.webframework.config.ServiceFilterConfig 中的方法
获取Filter的配置参数
getParameterValue(String) - 类 com.trs.webframework.config.ServiceListenerConfig 中的方法
获取Listener的配置参数
getParameterValue(String) - 类 com.trs.webframework.context.ServiceContext 中的方法

getParameterValue(String) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParameterValues(String) - 类 com.trs.webframework.context.ServiceContext 中的方法

getParameterValues(String) - 类 com.trs.webframework.controler.JSPServiceContext 中的方法

getParamName() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
提取属性：ParamName
getParamName(int) - 类 com.trs.components.common.job.JobWorkerType 中的方法

getParamName() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
提取属性：ParamName
getParamName() - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
提取属性：ParamName
getParamName() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
提取属性：ParamName
getParams() - 类 com.trs.cms.process.definition.FlowAction 中的方法
提取属性：Params
getParams() - 类 com.trs.webframework.context.MethodContext 中的方法

getParamsList() - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法

getParamValue() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
提取属性：ParamValue
getParamValue() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
提取属性：ParamValue
getParamValue() - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
提取属性：ParamValue
getParamValue() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
提取属性：ParamValue
getParamValues(String) - 类 com.trs.webframework.context.MethodContext 中的方法

getParent() - 接口 com.trs.cms.auth.domain.IRightHost 中的方法
获取父对象
getParent() - 类 com.trs.cms.auth.persistent.Group 中的方法
获取组的父对象（Group）
getParent() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取事务轨迹
getParent() - 类 com.trs.components.common.address.ContactGrp 中的方法
取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。
getParent() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
取组的父对象 说明：没有指定访问者对象，是因为返回的是单个对象。
getParent() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Returns the parent tag parse context.
getParent() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
获取父tagitem
getParent() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法

getParent() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getParent() - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法

getParent() - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法

getParent() - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法

getParent() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法

getParent() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getParent() - 类 com.trs.components.wcm.channel.VChannel 中的方法

getParent() - 类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 中的方法

getParent() - 类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 中的方法

getParent() - 类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 中的方法

getParent() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取父频道对象
getParent() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

getParent() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getParent() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getParent() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getParent() - 类 com.trs.components.wcm.resource.DocKind 中的方法

getParent() - 类 com.trs.infra.persistent.BaseObjs 中的方法
获得父集合
getParent() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
获取所属元素对象
getParent() - 类 com.trs.infra.util.html.HtmlComment 中的方法
获取父元素对象
getParent() - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取父元素对象
getParentChannelWhere(int, WCMFilter) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法

getParentFlag() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
提取属性：ParentFlag
getParentId() - 类 com.trs.cms.auth.persistent.Group 中的方法
获取组的父对象ID
getParentId() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取事务轨迹ID
getParentId() - 类 com.trs.components.common.address.ContactGrp 中的方法
属性: Parent 父对象
getParentId() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
属性: ParentId 父对象
getParentId() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
提取属性：ParentId
getParentId() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法

getParentId() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取父频道ID
getParentId() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

getParentId() - 类 com.trs.components.wcm.resource.DocKind 中的方法

getParentId() - 类 com.trs.scene.tools.SceneNode 中的方法

getParentId() - 类 com.trs.template.persistent.BaseChannelInfoEntity 中的方法

getParentNode() - 类 com.trs.scene.tools.SceneNode 中的方法

getParentX(SceneNode) - 类 com.trs.scene.tools.SceneNodeAction 中的方法
通过该节点的子节点获得其x坐标
getParsedInstance(String, String) - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的方法
get the Parsed Instance from a certain xml file
getParsedInstance(String) - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的方法

getParsingInfo() - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法

getParsingStatus() - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法

getPassive() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回是否使用Passve模式
getPassiveMode() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：PASSIVEMODE，是否启用FTP协议中的Passive模式
getPassword() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

getPassword() - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

getPassWord() - 类 com.trs.infra.util.soap.CMySoapClient 中的方法

getPassWord() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回登陆FTP服务器的用户口令
getPasswordLev() - 类 com.trs.cms.auth.persistent.User 中的方法
获取用户密码的安全级别 0 ： 安全级别未标记 >=1 ： 用户安全级别，值越高越安全
getPath() - 类 com.trs.components.common.publish.widget.WidgetPathHelper 中的静态方法

getPath(ClassInfos) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
由指定的分类法得到从根节点到这个分类法节点的id序列
getPath(ClassInfo) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法
由指定的分类法得到从根节点到这个分类法节点的id序列
getPath(ClassInfos) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法

getPath(ClassInfo) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法

getPath(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法

getPath(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法

getPathCompass() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法

getPathCompass() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

getPathCompass() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
Returns the folder path cache box.
getPathConfig(String) - 类 com.trs.infra.support.file.FilesMan 中的方法
取指定目录标识的配置信息
getPathConfigValue(String, int) - 类 com.trs.infra.support.file.FilesMan 中的方法
获取指定目录标识的配置信息值
getPathKey() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
获取指定Folder的Path Key，有存储在不同路径下的时候，Folder的实现覆写
getPathKey() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法

getPathKey() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getPathKey() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getPathKey() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getPattern() - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法

getPAttribute() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PAttribute
getPChnlId() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PChnlId
getPChnlName() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PChnlName
getPClass() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PClass
getPDesc() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PDesc
getPeople() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取人物
getPeriodInterval() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

getPeriodType() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

getPHeight() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PHeight
getPicFileName() - 类 com.trs.components.common.publish.widget.Master 中的方法
提取属性：PicFileName
getPlace() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取地点
getPlugin() - 类 com.trs.infra.config.persistent.ConfigFile 中的方法

getPluginCode() - 类 com.trs.components.wcm.content.MySite 中的方法

getPluginCode() - 类 com.trs.components.wcm.MyDB 中的方法

getPluginCode() - 类 com.trs.components.wcm.MyPlugin 中的静态方法

getPluginCode() - 类 com.trs.infra.persistent.db.MyDate 中的方法

getPluginCode() - 接口 com.trs.license.License 中的方法
获取选件的注册码
getPluginMap() - 类 com.trs.infra.config.domain.ConfigObjectLoader 中的方法
得到所有的配置文件的格式为 散列集
getPluginMap() - 类 com.trs.infra.config.XMLConfigServer 中的方法

getPluginParams() - 类 com.trs.presentation.util.LoginHelper 中的方法

getPNo() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PNo
getPNum() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PNum
getPort() - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

getPort() - 类 com.trs.infra.util.soap.CMySoapClient 中的方法

getPort() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回FTP服务器的端口号
getPosition(String) - 类 com.trs.wcag2.HTMLUtil 中的静态方法

getPositionX() - 类 com.trs.scene.tools.SceneNode 中的方法
获取X坐标
getPositionY() - 类 com.trs.scene.tools.SceneNode 中的方法
获取Y坐标
getPostCode() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：PostCode
getPostDesc() - 类 com.trs.cms.process.engine.FlowContext 中的方法

getPostDesc() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取递交说明
getPostTime() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取递交时间
getPostTime() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法

getPostUser() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：PostUser
getPostUser() - 类 com.trs.cms.process.engine.ExecuteContext 中的方法
获取处理人
getPostUser() - 类 com.trs.cms.process.engine.FlowContext 中的方法

getPostUser() - 类 com.trs.cms.process.engine.FlowContextOld 中的方法
获取呈送文档的用户
getPostUser() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取递交用户
getPostUser() - 类 com.trs.cms.process.engine.FlowParamers 中的方法

getPostUserName() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取递交用户的用户名
getPostUserTrueName() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取递交用户的真实用户名
getPPrice() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PPrice
getPreDeclared() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回预先声明同名变量时使用的对象
getPrefix() - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法

getPrefixOfArgument() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
返回模板变量名称的前缀
getPrefixOfName() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
提取属性：PrefixOfName
getPreFlowDoc() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取上一次事务轨迹
getPreFlowDocId() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取上一次事务轨迹ID
getPreImageKindId() - 类 com.trs.wcm.photo.ImageKind 中的方法

getPreNextDocuments(Channel, Document, int) - 接口 com.trs.components.wcm.publish.domain.IPreNextDocuments 中的方法
获取前/后N篇文档集合
getPreNextDocuments(Channel, Document, int) - 类 com.trs.components.wcm.publish.domain.PreNextDocumentsImpl 中的方法

getPreNode() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取前一个节点
getPreNode() - 类 com.trs.cms.process.engine.FlowParamers 中的方法

getPreNode() - 类 com.trs.scene.parser.SceneConnector 中的方法

getPreNodeId() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取前一个节点ID
getPrePageIndex() - 类 com.trs.infra.util.CPager 中的方法
取前一页的页号
getPreviewHttpPath(IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the http path for the previewed pages of the specified element.
getPreviewHttpUrl(IPublishContent, int) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
获取指定Content的预览地址
getPreviewLocalPath(IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the local path for the previewed pages of the specified element.
getPreviewLocalPath(IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the local path for the previewed pages of the specified folder.
getPreviewLocalPath(IPublishContent) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the local path for the previewed pages of the specified content.
getPrevious(User, boolean) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
取前一个流转经过的FlowDoc对象 Sample: A->B->C，然后两次打回 C->B->A，在B处打回时需要将参数_bGoBack置为true
getPrevious(User, boolean) - 类 com.trs.cms.process.engine.FlowDocBak 中的方法
该方法与其父类中的同签名方法的行为定义有所不同。
getPreviousChnlDoc(ChnlDoc, boolean) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
得到频道内，当前频道文档的前一个频道文档。
getPrice() - 类 com.trs.cms.auth.persistent.User 中的方法
获得用户个人的稿件单价
getPrice() - 类 com.trs.components.wcm.resource.Source 中的方法
获取来源的稿件单价
getPricePerUnit() - 类 com.trs.components.stat.BonusRule 中的方法
提取属性：PricePerUnit 单篇奖金
getPrimaryKey() - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法

getPriority() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
get the property of Priority
getPrivateKey() - 类 com.trs.infra.support.security.SecureKey 中的方法
获取密钥的私钥
getProcessInfoOfContent(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
获取指定内容的流转信息（是否已经结束、发起人）
getProcessInfoOfContent(IFlowContent) - 类 com.trs.cms.process.FlowServerImpl 中的方法

getProcessInfoOfContent(IFlowContent) - 接口 com.trs.cms.process.IFlowServer 中的方法
获取指定内容的流转情况
getProducerId() - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的方法

getProducerId() - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的方法

getProducerId() - 类 com.trs.components.wcm.stat.domain.TimingChartProducer 中的方法

getProgressMonitor() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法

getProgressMonitor() - 类 com.trs.components.common.publish.domain.taskdispatch.PageTaskWorker 中的方法

getProgressMonitor() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法
返回发布任务自身的监控
getProperties() - 类 com.trs.components.wcm.channel.VChannel 中的方法

getProperties() - 类 com.trs.infra.persistent.BaseObj 中的方法

getProperties() - 类 com.trs.infra.util.CMyXMLElement 中的方法

getPropertiesList() - 类 com.trs.infra.util.CMyXMLElement 中的方法

getProperty(String) - 接口 com.trs.cms.process.IFlowContent 中的方法
获取指定属性的名称
getProperty(String) - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getProperty(Document, String) - 类 com.trs.components.infoview.InfoViewDataHelper 中的静态方法
返回指定表单文档的指定数据项的值 数据项的名称，可以只包括名称部分，也可以是完整的XPATH表述
getProperty(Document, String) - 接口 com.trs.components.infoview.mad.InfoViewDataHelper 中的方法

getProperty(Document, String) - 类 com.trs.components.infoview.mad.InfoViewDataHelperImpl 中的方法

getProperty(String) - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getProperty(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
取对象属性值
getProperty(String) - 类 com.trs.infra.util.CMyXMLElement 中的方法
get the value of the specified property.
getProperty(Map, String) - 类 com.trs.infra.util.PropertiesUtil 中的静态方法
get a property value
getProperty(String) - 类 com.trs.presentation.util.Parameter 中的方法
取对象属性值
getProperty(String) - 类 com.trs.webframework.config.TRSParameter 中的方法
取对象属性值
getPropertyAsBoolean(String, boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法
取布尔型属性值 说明：0值为false，非0值为true
getPropertyAsBoolean(String, boolean) - 类 com.trs.infra.util.CMyXMLElement 中的方法
get the boolean property value
getPropertyAsBoolean(String, boolean) - 类 com.trs.presentation.util.Parameter 中的方法
取布尔型属性值 说明：0值为false，非0值为true
getPropertyAsBoolean(String, boolean) - 类 com.trs.webframework.config.TRSParameter 中的方法
取布尔型属性值 说明：0值为false，非0值为true
getPropertyAsDateTime(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
取日期时间型属性值
getPropertyAsDateTime(String) - 类 com.trs.presentation.util.Parameter 中的方法
取日期时间型属性值
getPropertyAsDateTime(String) - 类 com.trs.webframework.config.TRSParameter 中的方法
取日期时间型属性值
getPropertyAsDouble(String, double) - 类 com.trs.infra.persistent.BaseObj 中的方法
取浮点型数据属性值
getPropertyAsInt(String, int) - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getPropertyAsInt(String, int) - 类 com.trs.infra.persistent.BaseObj 中的方法
取长整型属性值
getPropertyAsInt(String, int) - 类 com.trs.infra.util.CMyXMLElement 中的方法

getPropertyAsInt(String, int) - 类 com.trs.presentation.util.Parameter 中的方法
取长整型属性值
getPropertyAsInt(String, int) - 类 com.trs.webframework.config.TRSParameter 中的方法
取长整型属性值
getPropertyAsLong(String, long) - 类 com.trs.infra.persistent.BaseObj 中的方法
取长整型属性值
getPropertyAsLong(String, long) - 类 com.trs.presentation.util.Parameter 中的方法
取长整型属性值
getPropertyAsLong(String, long) - 类 com.trs.webframework.config.TRSParameter 中的方法
取长整型属性值
getPropertyAsString(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
取字符串型属性值
getPropertyAsString(String, String) - 类 com.trs.infra.persistent.BaseObj 中的方法

getPropertyAsString(String) - 类 com.trs.presentation.util.Parameter 中的方法
取字符串型属性值
getPropertyAsString(String) - 类 com.trs.webframework.config.TRSParameter 中的方法
取字符串型属性值
getPropertyNames() - 类 com.trs.infra.util.CMyXMLElement 中的方法

getPropertyNames() - 类 com.trs.presentation.common.PageViewConstants 中的静态方法

getPropertyTrim(String) - 类 com.trs.infra.util.CMyXMLElement 中的方法
get the trimed value of the specified property.
getPropertyTrim(String, String) - 类 com.trs.infra.util.CMyXMLElement 中的方法
get the trimed value of the specified property.
getPropertyTrim(Map, String) - 类 com.trs.infra.util.PropertiesUtil 中的静态方法
get the timmed value of a property
getProtocol() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回协议名称，恒定返回“ftp”
getProvider() - 类 com.trs.webframework.config.MethodConfig 中的方法

getPStyle() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PStyle
getPType() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PType
getPubHtmlContent() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档的Html文本
getPubHtmlContent() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取文档的Html文本
getPublicCache() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getPublicCache() - 类 com.trs.components.wcm.content.ViewDocument 中的方法

getPublicCache() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

getPublicKey() - 类 com.trs.infra.support.security.SecureKey 中的方法
获取密钥的公钥
getPublicPassword() - 类 com.trs.components.infoview.InfoViewMgr 中的方法
获取表单文档外部查询随机密码
getPublicPasswordField() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getPublicPasswordPattern() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getPublicRandomSerialPattern() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getPublicRandomSerialRequired() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getPublishConfig(MethodContext) - 类 com.trs.ajaxservice.PublishServiceProvider 中的方法
获取指定对象的发布信息,传入的参数： ObjectType ObjectId
getPublishDistribution() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

getPublishDistributionList(int, int) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
返回指定目录上的分发点的列表
getPublishDistributionList(String) - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法
返回和指定的缓存KEY绑定的分发点的列表
getPublishedContents(WCMFilter) - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
Returns the contents which have been published.
getPublishedContents(WCMFilter) - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getPublishedContents(WCMFilter) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getPublishedContents(WCMFilter) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getPublishedContents(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getPublishedContents(WCMFilter) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getPublishElement() - 类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 中的方法

getPublishElement() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPageTask 中的方法

getPublishElement() - 类 com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask 中的方法

getPublishElement() - 类 com.trs.components.common.publish.domain.taskdispatch.SinglePageTask 中的方法
Returns the element to publish.
getPublishHttpPath(IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法

getPublishHttpUrl(IPublishContent, int) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法

getPublishLocalPath(IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the local path for the published pages of the specified element.
getPublishLocalPath(IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the local path for the published pages of the specified folder.
getPublishLocalPath(IPublishContent) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the local path (without file name) for the published pages of the specified content in the folder.
getPublishPage() - 接口 com.trs.cms.process.IFlowContent 中的方法

getPublishPage() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getPublishPage() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getPublishSrvId() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法

getPublishTask() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 中的方法

getPublishTaskId() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
提取属性：PublishTaskId
getPublishType() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：PublishType
getPublishTypeName(int, String) - 类 com.trs.components.common.publish.PublishConstants 中的静态方法
get the name of a publish type
getPublishTypeName(int, String, boolean) - 类 com.trs.components.common.publish.PublishConstants 中的静态方法

getPublishUrls(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
得到一组图片的不同比例的发布路径
getPublishViews(InfoView, boolean, String) - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViews 中的方法

getPubPathStartTime() - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法
获取发布文件按照日期存放的起始时间
getPubScriptURI() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getPubStatuses(User) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
取所有允许发布的文档状态对象集合
getPubStatusIds() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
取所有允许发布的文档状态对象ID集合（字符串，不同ID之间移字符','分割）
getPubStyleURI() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getPubText() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
取模板发布正文，用于模板解析
getPubTime() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取发布时间
getPubURL() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档发布后的地址
getPurpose() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：Purpose
getPWidth() - 类 com.trs.components.common.trsad.ADPos 中的方法
提取属性：PWidth
getQuery() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道的查询条件
getQueryCode() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：QueryCode
getQueryCount() - 类 com.trs.infra.persistent.BaseObjs 中的方法
获取本次查询的记录数
getQueryFilter() - 类 com.trs.webframework.context.MethodContext 中的方法

getQuoteChannels(Document) - 接口 com.trs.service.IDocumentService 中的方法
获取引用了当前指定文档的所有频道
getQuoteChannels(int) - 接口 com.trs.service.IDocumentService 中的方法
获取引用了当前指定文档的所有频道
getQuoteChannels(Document) - 类 com.trs.service.impl.DocumentService 中的方法

getQuoteChannels(int) - 类 com.trs.service.impl.DocumentService 中的方法

getQuotedChannels(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
获取所有引用指定文档的栏目集合
getQuotedFolderId() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
提取属性：QuotedFolderId
getQuotedFolderType() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
提取属性：QuotedFolderType
getQuoteDocs(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法

getQuoteKinds(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法

getQuoteType() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
提取属性：QuoteType
getQutoedChannels(Document, int, String) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
获得实体文档对应的特定类型的频道集合
包括所有转发的频道、镜像的频道、实体频道和所有频道
getQutoedChannels(Document, int, String, boolean) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法

getRadorchk() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：Radorchk
getRandomSerial() - 类 com.trs.components.infoview.InfoViewMgr 中的方法

getRandomSerial() - 类 com.trs.components.wcm.content.persistent.Document 中的方法

getRange() - 类 com.trs.components.stat.BonusRule 中的方法
提取属性：Range 奖励范围，如0到500，用0,500表示
getRangeEnd() - 类 com.trs.components.stat.TimeRange 中的方法
获取当前位置下，指定步长之内，跨度的结束时间
getRangeIndexs() - 类 com.trs.cms.auth.config.RightHostIndexsConfig 中的方法

getRangeStart() - 类 com.trs.components.stat.TimeRange 中的方法
获取当前位置下，指定步长之内，跨度的开始时间
getRatio() - 类 com.trs.components.common.publish.widget.Layout 中的方法
提取属性：Ratio
getRatioType() - 类 com.trs.components.common.publish.widget.Layout 中的方法
提取属性：RatioType
getReadFileURL() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getRealHome() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Returns the folder where this content currently lies.
getRealHome() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

getRealHome() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

getRealLength() - 类 com.trs.infra.util.CMyBitsValue 中的方法
取二进制位的实际长度
getRealPostUserNames() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
返回真实的处理用户
getRealProperty(String) - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getRecCount() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法
获取本次查询的记录个数
getRecCount() - 类 com.trs.components.wcm.content.persistent.Documents 中的方法
获取本次查询的记录个数
getRecCount() - 类 com.trs.infra.persistent.BaseObjs 中的方法
获取本次查询的记录个数
getReceivedMsgs(User, WCMFilter) - 类 com.trs.components.common.message.MessageServer 中的静态方法
获得某用户的所有接收到的消息
接收的判断是所有用户为接收者的消息
getReceiverId() - 类 com.trs.components.common.message.MsgReceiver 中的方法
获取接收者ID
getReceiverName() - 类 com.trs.components.common.message.MsgReceiver 中的方法
获取接收者的名称
getReceiverNames(Message, int) - 类 com.trs.components.common.message.MessageServer 中的静态方法
获取消息接收者名
getReceivers() - 类 com.trs.components.common.message.Message 中的方法
获取消息的接收者集合
getReceiverType() - 类 com.trs.components.common.message.MsgReceiver 中的方法
获取接收者的类型
getReceiveTime() - 类 com.trs.cms.process.engine.FlowDoc 中的方法

getRecentChannels(int) - 类 com.trs.presentation.portal.PortalHelper 中的静态方法
得到我最近访问的频道 for portal/portal_recent_channel.jsp
getRecentDocs(int, int) - 类 com.trs.presentation.portal.PortalHelper 中的静态方法
我最近处理的文档信息 for portal/portal_recent_doc.jsp
getRecordNum() - 类 com.trs.components.wcm.content.trsserver.ClassInfo 中的方法
获取分类的记录数
getRecordSize() - 类 com.trs.components.common.publish.domain.tagparser.BaseTagParser4List 中的方法

getRecordSize() - 接口 com.trs.components.common.publish.domain.tagparser.ITagParser4List 中的方法
Returns the records number in thes list.
getRecordSize() - 类 com.trs.components.metadata.publish.WCMTagParserClassInfos 中的方法

getRecordSize() - 类 com.trs.components.metadata.publish.WCMTagParserRelNewsForViewData 中的方法

getRecordSize() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParser4ObjsInChannelBase 中的方法

getRecordSize() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserChannels 中的方法

getRecordSize() - 类 com.trs.components.wcm.publish.tagparser.WCMTagParserRelNews 中的方法

getRecycleChannels(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
获取回收站的栏目列表
getRecycleChannels(BaseChannel, WCMFilter) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
获取符合一定条件的被删除的栏目
getRecycleChannels(BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道下的废弃频道集合
getRecycleChannels(BaseChannel, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道下的废弃频道集合
getRecycleChannels(BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道下的废弃频道集合
getRecycleChannels(BaseChannel, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道下的废弃频道集合
getRecycleDocuments(BaseChannel, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
取频道的废稿
getRecycleDocuments(WCMFilter) - 类 com.trs.components.wcm.content.domain.UserDocumentMgr 中的方法
获取个人回收站里的文档
getRecycleDocuments(int) - 接口 com.trs.service.IChannelService 中的方法
获取当前频道下的废稿
getRecycleDocuments(int, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取当前频道下的废稿
getRecycleDocuments(BaseChannel, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取当前站点/频道下的废稿
getRecycleDocuments(BaseChannel, WCMFilter) - 接口 com.trs.service.IDocumentService 中的方法
获取当前站点或频道的回收站的文档
getRecycleDocuments(int) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前频道下的废稿
getRecycleDocuments(int, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前频道下的废稿
getRecycleDocuments(BaseChannel, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前站点/频道下的废稿
getRecycleDocuments(BaseChannel, WCMFilter) - 类 com.trs.service.impl.DocumentService 中的方法

getRecycleDocuments() - 类 com.trs.service.impl.UserService 中的方法

getRecycleDocuments(WCMFilter) - 类 com.trs.service.impl.UserService 中的方法

getRecycleDocuments() - 接口 com.trs.service.IUserService 中的方法
获取当前登录用户创建的废稿集合
getRecycleDocuments(WCMFilter) - 接口 com.trs.service.IUserService 中的方法
获取当前登录用户创建的废稿集合,设定查询条件
getRecycleSites(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
获取回收站中的站点列表
getRecycleSites(WCMFilter) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法

getRecycleSites(WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取系统回收站中的站点集合
getRecycleSites(WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法

getRefName() - 类 com.trs.components.infoview.extract.DataType 中的方法

getRefresh() - 类 com.trs.components.infoview.extract.manifest.CalculatedField 中的方法

getRefType() - 类 com.trs.components.infoview.extract.DataType 中的方法

getRegFrom() - 类 com.trs.presentation.ids.RegFromConfig 中的方法
获取注册来源
getRegion() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
获取定制的布局区域号
getRegionEmployId() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
提取属性：RegionEmployId
getRegionEmploysByObj(int, int) - 类 com.trs.components.wcm.publish.region.RegionEmployMgr 中的方法
根据配置对象返回配置关系
getRegionEmploysByRegion(RegionInfo) - 类 com.trs.components.wcm.publish.region.RegionEmployMgr 中的方法
根据导读返回导读配置信息
getRegionEmploysByRegionAndType(int, int[]) - 类 com.trs.components.wcm.publish.region.RegionEmployMgr 中的方法

getRegionId() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
提取属性：RegionId
getRegionInfoId() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
提取属性：RegionInfoId
getRegisterTables() - 接口 com.trs.components.metadata.center.IDocumentFieldsSyn 中的方法
返回需要注册的相关表
getRegTime() - 类 com.trs.cms.auth.persistent.User 中的方法
获取注册时间
getRelatedChannel() - 类 com.trs.wcm.photo.ImageKind 中的方法

getRelatedChannelSyns(Channel, WCMFilter) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法

getRelatedColumn() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

getRelatedConvertType() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取bmp文件转换格式
getRelatedConvertType() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getRelatedDocIds() - 类 com.trs.components.comment.domain.CommentUpdator 中的方法

getRelatedDocIds(int, int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法

getRelatedDocIds(int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法

getRelatedDocIds(int, int) - 类 com.trs.components.comment.service.CommentService 中的方法

getRelatedDocIds(int) - 类 com.trs.components.comment.service.CommentService 中的方法

getRelatedDocIds(int) - 接口 com.trs.components.comment.service.ICommentService 中的方法

getRelatedDocIds(int, int) - 接口 com.trs.components.comment.service.ICommentService 中的方法

getRelatedDocs(int, WCMFilter) - 类 com.trs.components.comment.service.CommentService 中的方法

getRelatedDocs(int, WCMFilter) - 接口 com.trs.components.comment.service.ICommentService 中的方法

getRelatedDocuments(Document, int, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
相关文档的相关方法
getRelatedDocuments(Document, int, WCMFilter, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
获取与当前文档相关的文档集合(指定获取的方式:相关表/关键词/相关词等)
getRelatedDocuments(Document, int) - 接口 com.trs.service.IDocumentService 中的方法
指定检索条件获取与当前文档相关的文档
getRelatedDocuments(Document, int, WCMFilter) - 接口 com.trs.service.IDocumentService 中的方法
指定检索条件获取与当前文档相关的文档
getRelatedDocuments(Document, int, WCMFilter, boolean, boolean) - 接口 com.trs.service.IDocumentService 中的方法
指定检索条件获取与当前文档相关的文档
getRelatedDocuments(Document, int, WCMFilter, boolean, boolean) - 类 com.trs.service.impl.DocumentService 中的方法

getRelatedDocuments(Document, int) - 类 com.trs.service.impl.DocumentService 中的方法

getRelatedDocuments(Document, int, WCMFilter) - 类 com.trs.service.impl.DocumentService 中的方法

getRelatedDocumentsByKeywords(Document, int, String, int[], boolean, ArrayList) - 类 com.trs.components.wcm.content.domain.DocKeywordMgrImpl 中的方法
根据标题排重 add by ly
getRelatedDocumentsByKeywords(Document, int, String, int[], boolean, ArrayList) - 接口 com.trs.components.wcm.content.domain.IDocKeywordMgr 中的方法
获取指定文档的相关文档
getRelatedKindId() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取默认主分类
getRelatedKindId() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getRelatedResources() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
获取Content相关的资源文件(如附件等)
getRelatedResources() - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

getRelatedResources() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

getRelatedResources() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

getRelatedResources() - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

getRelatedResources() - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

getRelatedResources() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

getRelatedWaterMarkId() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取水印
getRelatedWaterMarkId() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getRelatedWaterMarkPos() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取水印位置
getRelatedWaterMarkPos() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getRelateFiles() - 类 com.trs.components.common.publish.domain.template.CSSResourceProcessor 中的方法

getRelateObject() - 类 com.trs.infra.util.Report 中的方法

getRelateSite() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取与图片库相关的站点
getRelateSite() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getRelateSiteId() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取与图片库相关的站点ID
getRelateSiteId() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getRelateWords() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取相关词（用于相关文档搜索）
getRelationOperator() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
提取属性：RelationOperator
getRelations(Document) - 类 com.trs.components.wcm.content.domain.RelationMgr 中的方法

getRelations(Document, WCMFilter) - 类 com.trs.components.wcm.content.domain.RelationMgr 中的方法

getRelations(WCMFilter) - 类 com.trs.components.wcm.content.domain.RelationMgr 中的方法
根据条件获得相关文档
getRelations(Document) - 接口 com.trs.service.IDocumentService 中的方法
获取当前文档的Relations集合，即手工设定的相关文档
getRelations(Document) - 类 com.trs.service.impl.DocumentService 中的方法

getRelativeTarget() - 类 com.trs.components.infoview.extract.manifest.CalculatedField 中的方法

getRelDocId() - 类 com.trs.components.wcm.content.persistent.Relation 中的方法
获取相关文档的ID
getReleaseTime() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取撰写时间
getRemaining() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Gets the number of unprocessed input.
getReminderAnswer() - 类 com.trs.cms.auth.persistent.User 中的方法
获取找回密码时的答案
getReminderQuestion() - 类 com.trs.cms.auth.persistent.User 中的方法
获取找回密码时的问题
getRemindMsgId() - 类 com.trs.components.common.calendar.Event 中的方法

getRemoteAddr(HttpServletRequest) - 类 com.trs.infra.util.RemoteAddrUtil 中的静态方法

getRemoteException(int) - 异常 com.trs.template.TemplateRemoteException 中的静态方法
根据错误号生成TemplateRemoteException对象
getRemotePath() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 中的方法
返回远程（目标）文件或者目录
getRemoveRightIndexs() - 类 com.trs.infra.common.WCMRightTypes 中的静态方法

getRepalceCache() - 类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 中的方法

getRepeatFieldElementSize(Element, String) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法

getRepeatFieldIndex(String, String) - 类 com.trs.components.infoview.helper.BaseInfoViewFieldValueCreator 中的方法
获取指定字段和值的序号位置
getRepeatFieldSize(String) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 中的方法
获取一个指定的重复表名称的行数 传递的参数是每行数据的GROUP NAME
getReplaces(Channel, WCMFilter) - 类 com.trs.components.wcm.content.domain.ReplaceMgr 中的方法
获取当前频道下的替换内容
getReplaces(User) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道上所有的替换内容对象
getReplaces(Channel, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取指定频道下的替换内容对象集合
getReplaces(Channel, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法

getReplyFunc(Document) - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 中的静态方法
获取回复文档的Javascript
getReplys(Document) - 类 com.trs.components.wcm.content.domain.DocReplyMgr 中的方法
获取文档的所有回复
getReplys(Document, int) - 类 com.trs.components.wcm.content.domain.DocReplyMgr 中的方法
获取当前文档某种类型的回复
getReplyTo() - 类 com.trs.infra.util.email.CMyEmail 中的方法

getReports() - 类 com.trs.components.metadata.definition.xml.ClassInfoImporter 中的方法

getReports() - 类 com.trs.presentation.util.RequestHelper 中的方法

getReportsNum() - 类 com.trs.infra.util.Reports 中的方法

getRequest() - 类 com.trs.presentation.util.RequestHelper 中的方法

getRequest() - 类 com.trs.service.InfoViewContext 中的方法

getRequest() - 类 com.trs.webframework.context.ServiceContext 中的方法

getRequired() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
返回对于当前置标该属性是不是必须的
getRequiredAttr() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
返回该置标必须的属性数组
getRequiredAttribute(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
get a required attribute value
getRequiredAttributeTrim(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
get the trimmed value of a required attribute.
getRequiredProperty(Map, String) - 类 com.trs.infra.util.PropertiesUtil 中的静态方法
get a required property value
getRequiredPropertyTrim(String) - 类 com.trs.infra.util.CMyXMLElement 中的方法
get the trimed value of a required property
getRequiredPropertyTrim(Map, String) - 类 com.trs.infra.util.PropertiesUtil 中的静态方法
get the trimmed value of a required property.
getResource(String) - 类 com.trs.infra.util.Loader 中的静态方法
This method will search for resource in different places.
getResourceId() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
提取属性：ResourceId
getResourceNames(IPublishContent) - 类 com.trs.components.metadata.publish.MetaViewDataRelateSource 中的方法

getResourceNames(IPublishContent) - 接口 com.trs.components.wcm.publish.element.IRelateResource 中的方法
获取当前IPublishContent对象的相关文件(如正文中的图片等)
注意:实现时,即使没有相关的文件,也不能返回null.在没有相关文件的情况下,返回空集
getResourceStyles(PageStyle) - 接口 com.trs.components.common.publish.widget.IResourceStyleMgr 中的方法
获取指定页面风格下的资源可用风格集合
getResourceStyles(PageStyle) - 类 com.trs.components.common.publish.widget.ResourceStyleMgr 中的方法
获取指定系统风格下的资源可用风格集合
getResponse() - 类 com.trs.presentation.util.RequestHelper 中的方法

getResponse() - 类 com.trs.service.InfoViewContext 中的方法

getResponse() - 类 com.trs.webframework.context.ServiceContext 中的方法

getResponseCodeForHttp(String) - 类 com.trs.components.common.conjection.helper.HttpChecker 中的静态方法

getResult() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
提取属性：Result
getResult() - 类 com.trs.components.stat.BaseStatHandler 中的方法

getResult() - 接口 com.trs.components.stat.IStatHandler 中的方法
返回visitStatItem累积之后的结果集
getResult(String) - 接口 com.trs.components.stat.IStatResult 中的方法
返回第1条统计SQL在key下的统计信息
getResult(int, String) - 接口 com.trs.components.stat.IStatResult 中的方法
返回第nIndex条统计SQL在key下的统计信息
getResult(String[]) - 接口 com.trs.components.stat.IStatResult 中的方法
返回第1条统计SQL在keys下的统计信息
getResult(int, String[]) - 接口 com.trs.components.stat.IStatResult 中的方法
返回第nIndex条统计SQL在keys下的统计信息
getResult(String) - 接口 com.trs.components.stat.IStatResults 中的方法
从结果集中根据所给的参数 sKey，返回该参数所对应的结果list
getResult(int, String) - 接口 com.trs.components.stat.IStatResults 中的方法
从结果集中根据所给的参数 sKey，返回第nIndex条SQL对应的结果list
getResult(int, String[]) - 接口 com.trs.components.stat.IStatResults 中的方法
返回第n条SQL的，Key为数组的结果集
getResult(String[]) - 接口 com.trs.components.stat.IStatResults 中的方法
返回第一条SQL的，以key为关键数组的值
getResult(String[]) - 类 com.trs.components.stat.StatResult 中的方法

getResult(int, String[]) - 类 com.trs.components.stat.StatResult 中的方法

getResult(int, String) - 类 com.trs.components.stat.StatResult 中的方法

getResult(String) - 类 com.trs.components.stat.StatResult 中的方法

getResult(String) - 类 com.trs.components.stat.StatResults 中的方法

getResult(int, String) - 类 com.trs.components.stat.StatResults 中的方法

getResult(int, String[]) - 类 com.trs.components.stat.StatResults 中的方法

getResult(String[]) - 类 com.trs.components.stat.StatResults 中的方法

getResult() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获取操作结果
getResult() - 接口 com.trs.infra.support.log.ILog 中的方法
获取操作结果
getResult() - 类 com.trs.wcm.old.ImportDocsContext 中的方法

getResult() - 类 com.trs.webframework.xmlserver.server.XMLDataProcessingHandler 中的方法

getResultIds() - 类 com.trs.infra.util.Reports 中的方法
获取Reports记录的处理对象Id数组
getResultTable() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ResultTable
getRetryInterval() - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法

getRetryTimeLimit() - 类 com.trs.components.common.publish.config.persistent.LaborResourceConfig 中的方法

getRight(int, int, int, int) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法
获取指定对象指定操作者的权限对象
getRight(CMSObj, CMSObj) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法
获取指定对象指定操作者的权限对象
getRight(int, int, int, int) - 类 com.trs.cms.auth.domain.RightMgr 中的方法

getRight(CMSObj, CMSObj) - 类 com.trs.cms.auth.domain.RightMgr 中的方法

getRightHost() - 类 com.trs.cms.auth.config.RightHostConfig 中的方法

getRightIndex() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

getRightIndex() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

getRightIndex() - 类 com.trs.components.wcm.resource.Status 中的方法
获取状态相关设置权限索引
getRightIndex() - 类 com.trs.wcm.config.PageOperator 中的方法
提取属性：Order
getRightIndexByOperName(String) - 类 com.trs.cms.auth.config.RightConfigServer 中的方法

getRightIndexDefineOnCurrChannel(int) - 类 com.trs.cms.auth.config.RightConfigServer 中的方法

getRightObject() - 类 com.trs.cms.auth.config.RightObjectConfig 中的方法

getRights(CMSObj, String, String) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法
获取指定对象指定群和组织的权限对象
getRights(CMSObj, int) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法

getRights(CMSObj) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法

getRights(int, int) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法

getRights(CMSObj, int) - 类 com.trs.cms.auth.domain.RightMgr 中的方法

getRights(CMSObj) - 类 com.trs.cms.auth.domain.RightMgr 中的方法

getRights(CMSObj, String, String) - 类 com.trs.cms.auth.domain.RightMgr 中的方法

getRights(int, int) - 类 com.trs.cms.auth.domain.RightMgr 中的方法

getRightTypeIds() - 接口 com.trs.cms.auth.domain.IRightHost 中的方法
获取可以在这类对象上支持的权限类别Id
getRightTypeIds() - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法

getRightTypeIds() - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法

getRightTypeIds() - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法

getRightTypeIds() - 类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 中的方法

getRightTypeIds() - 类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 中的方法

getRightTypeIds() - 类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 中的方法

getRightTypeNames() - 接口 com.trs.cms.auth.domain.IRightHost 中的方法
获取可以在这类对象上支持的权限类别名称
getRightTypeNames() - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法

getRightTypeNames() - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法

getRightTypeNames() - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法

getRightTypeNames() - 类 com.trs.components.wcm.content.domain.auth.ChannelRightHostImpl 中的方法

getRightTypeNames() - 类 com.trs.components.wcm.content.domain.auth.DocumentRightHostImpl 中的方法

getRightTypeNames() - 类 com.trs.components.wcm.content.domain.auth.WebSiteRightHostImpl 中的方法

getRightValue(CMSObj, User) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
获取当前权限值
getRightValue(CMSObj, CMSObj) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
获取当前操作权限值
getRightValue(CMSObj, CMSObj) - 接口 com.trs.cms.auth.domain.IRightMgr 中的方法

getRightValue(int, int, int, int) - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法

getRightValue(int, int, int, int, long) - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法

getRightValue(CMSObj, CMSObj) - 类 com.trs.cms.auth.domain.RightMgr 中的方法

getRightValue() - 类 com.trs.cms.auth.persistent.Role 中的方法
获取角色的权限（可以做的所有操作）
getRightValue(CMSObj, CMSObj) - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态方法
获取指定用户在指定对象上的权限值
getRightValue(CMSObj, Class) - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态方法
获取指定用户在指定对象类型上的权限值，如是否能新建，导入等
getRightValue(User) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
获取当前ViewDocument的RightValue
getRightValue(User) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取当前ViewDocument的RightValue
getRoleId() - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
提取属性：RoleId
getRoleId() - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
提取属性：RoleId
getRoleIds() - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法

getRoleOrder() - 类 com.trs.cms.auth.persistent.Role 中的方法
提取属性：RoleOrder
getRoleRange() - 类 com.trs.cms.auth.persistent.Role 中的方法
获取角色所属范围
getRoles(Group, WCMFilter) - 类 com.trs.cms.auth.domain.GroupRoleMgr 中的方法
获取指定组织的所有角色
getRoles() - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取系统中的所有角色集合
getRoles(User) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
获取当前用户担任的所有角色
getRoles(User, WebSite) - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 中的方法

getRoles() - 类 com.trs.cms.auth.persistent.User 中的方法
获取用户所属的特定角色以及作用于所有站点的角色.
getRoles(User) - 类 com.trs.service.impl.UserService 中的方法

getRoles() - 类 com.trs.service.impl.UserService 中的方法

getRoles(User) - 接口 com.trs.service.IUserService 中的方法
获取指定用户所属的角色集合
getRoles() - 接口 com.trs.service.IUserService 中的方法
获取当前登录用户所担任的角色.
getRolesForCurrUser(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
获取当前登录用户可以查看的所有角色信息
getRolesForUser(User, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取指定用户可见的角色
getRolesWithRight(User, int, int, boolean) - 类 com.trs.cms.auth.persistent.Right 中的静态方法
获取在指定对象上设置了权限（/没有设置权限）的角色集合
getRoleType() - 类 com.trs.cms.auth.persistent.Role 中的方法
获取角色所属类型
getRoleUsers(Role, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取指定角色下的角色用户信息
getRoleUsers(User, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取指定用户下的角色用户信息
getRoot() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法

getRoot() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

getRoot() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
Returns the root of the published folder.
getRoot() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法

getRoot() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getRoot() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
获得模板附件所属的站点
getRoot() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
get the root folder where the template is located.
getRoot() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getRoot() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getRoot() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getRoot() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getRoot() - 类 com.trs.presentation.nav.TreeNodeCalctor 中的方法

getRootCause() - 异常 com.trs.infra.util.CMyException 中的方法
获取异常对象
getRootConfig() - 类 com.trs.infra.util.CMyXMLHandler 中的方法

getRootDepartmentGroup() - 类 com.trs.cms.auth.domain.DepartmentMgrImpl 中的方法

getRootDepartmentGroup() - 接口 com.trs.cms.auth.domain.IDepartmentMgr 中的方法
获取描述组织结构的根组织
getRootDomain(IPublishFolder) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the root domain of the specified folder.
getRootDomain() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
Returns the root domain of current folder.
getRootDomain() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法

getRootDomain() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getRootDomain() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法

getRootDomain() - 类 com.trs.components.wcm.channel.VChannel 中的方法

getRootDomain() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getRootDomain() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：RootDomain
getRootElement() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

getRootElement() - 类 com.trs.infra.util.html.HtmlDocument 中的方法
取根元素 操作：从content中查找第一个HtmlElement元素，即看作根元素
getRootHref(int, int) - 类 com.trs.presentation.navigation.TreeItem 中的静态方法

getRootHttpPathFrom(IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the root http path from the specified publish element.
getRootId() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
获得模板附件所属的文件夹根目录
getRootId() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获得模板所属的文件夹根目录编号
getRootId() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
提取属性：RootId
getRootImageHttpPath(IPublishElement) - 类 com.trs.components.common.publish.domain.publisher.PublishPathCompass 中的方法
Returns the http path of the images in root.
getRootPath() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回远端文件所在的路径，或者零长度的字符串。
getRootSchema() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

getRootSchema() - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
返回根Schema
getRootSchemaURI() - 类 com.trs.components.infoview.extract.manifest.Manifest 中的方法
返回根Schema的URI定义
getRootType() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法

getRootType() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法

getRowIndex() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
提取属性：RowIndex
getRowNumber() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
提取属性：ROWNUMBER
getRportDetail() - 类 com.trs.infra.util.Report 中的方法
获取详细内容
getRportTitle() - 类 com.trs.infra.util.Report 中的方法
获取标题
getRst() - 类 com.trs.wcag2.Alertion 中的方法

getRuleId() - 类 com.trs.cms.process.definition.FlowAction 中的方法
提取属性：RuleId
getRuleId() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
提取属性：RuleId
getRules(FlowNode, int) - 类 com.trs.cms.process.definition.FlowRuleCacheServerImpl 中的方法

getRules(int, int, int) - 类 com.trs.cms.process.definition.FlowRuleCacheServerImpl 中的方法

getRules(FlowNode, int) - 接口 com.trs.cms.process.definition.IFlowRuleCacheServer 中的方法
获取定义在指定节点上指定类型的规则
getRules(int, int, int) - 接口 com.trs.cms.process.definition.IFlowRuleCacheServer 中的方法
获取在指定对象上定义的指定类型的规则
getRunningMonitors(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法

getRunningTask(int) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
返回指定ID的正在执行的发布任务对象
getRunningTask(int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
返回指定ID的正在执行的发布任务对象
getRunningTask(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法

getRunningTask(int) - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法

getRunningTask(int) - 类 com.trs.service.impl.PublishService 中的方法

getRunningTask(int) - 接口 com.trs.service.IPublishService 中的方法
返回指定ID的正在执行的发布任务对象
getRunningTasks() - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
返回所有的正在执行的任务
getRunningTasks() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
返回所有的正在执行的任务
getRunningTasks() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法

getRunningTasks() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法

getRunningTasks() - 类 com.trs.service.impl.PublishService 中的方法

getRunningTasks() - 接口 com.trs.service.IPublishService 中的方法
返回所有的正在执行的任务
getRunningWorker(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法
返回和指定的发布任务ID相关联的 PublishTaskWorker 对象，如果该发布任务当前正在运行的话。
getSacledImages(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法

getSaveBakFunc(Document, Channel) - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 中的静态方法
获取保存版本的Javascript
getSaveStatuses(User) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取站点上允许发布的文档状态
getSaveStatusIds() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
站点上允许发布的文档状态对象ID集合（字符串，不同ID之间移字符','分割）
getScale() - 类 com.trs.cms.content.ExtendedField 中的方法

getScale() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：Scale
getScale() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：Scale
getScale() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法

getScaleDescAt(int) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取指定尺寸索引的描述
getScaleDescAt(int) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getScaleSizes() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取图片库默认定义的各种缩放尺寸
getScaleSizes() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getScaleStyle() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法

getScaleStyle() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getSchedule() - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 中的方法

getScheduleId() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法

getScheduleMode() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：ScheduleMode
getScheduleTime() - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 中的方法

getSchema(String) - 类 com.trs.components.infoview.extract.DataTypeBuilder 中的方法

getSchemaFile() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法

getSchemaFile() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getSchemaRootElement() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法

getSchemaURI() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法

getScriptURI() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getSearchDBFields() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取检索DB字段
getSearchExpress(int) - 类 com.trs.webframework.config.TRSPageParameter 中的方法

getSearchField() - 类 com.trs.presentation.util.PageParameter 中的方法

getSearchField() - 类 com.trs.webframework.config.TRSPageParameter 中的方法

getSearchFields() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
获取检索字段
getSearchFields(InfoView) - 类 com.trs.components.infoview.persistent.InfoViewFields 中的静态方法

getSearchFields() - 类 com.trs.infra.util.TRSJspAutoTool 中的方法

getSearchGroupName(String) - 接口 com.trs.components.stat.IUserLoginInfoMgr 中的方法
获取部门名称检索的条件构造
getSearchGroupName(String) - 类 com.trs.components.stat.UserLoginInfoMgr 中的方法
部门名称检索,返回所属部门所有用户的userId
getSearchKey() - 类 com.trs.presentation.util.RequestHelper 中的方法

getSearchKeys() - 类 com.trs.presentation.util.AppAutoParameter 中的方法
概览页面检索字段列表
getSearchOperator() - 类 com.trs.presentation.util.PageParameter 中的方法

getSearchOperator() - 类 com.trs.webframework.config.TRSPageParameter 中的方法

getSearchScope() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
获取检索范围
getSearchTableName() - 类 com.trs.presentation.util.RequestHelper 中的方法

getSearchTime() - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的方法
获取本次检索的花费时间
getSearchType() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法

getSearchType() - 类 com.trs.presentation.util.PageParameter 中的方法

getSearchType() - 类 com.trs.webframework.config.TRSPageParameter 中的方法

getSearchUserName(String) - 接口 com.trs.components.stat.IUserLoginInfoMgr 中的方法
获取用户名称检索的条件构造
getSearchUserName(String) - 类 com.trs.components.stat.UserLoginInfoMgr 中的方法
用户名称检索,返回用户名的userId
getSearchValue() - 类 com.trs.presentation.util.RequestHelper 中的方法

getSearchValues() - 类 com.trs.infra.db.QueryFilter 中的方法

getSearchValues() - 类 com.trs.infra.persistent.WCMFilter 中的方法

getSearchValues() - 类 com.trs.presentation.util.DefaultWhereSQLMaker 中的方法

getSearchValues() - 类 com.trs.presentation.util.WhereSQLMaker 中的方法

getSearchWord() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
获取当前检索词
getSecond() - 类 com.trs.infra.util.CMyDateTime 中的方法
获取当前对象中的【秒】的部分
getSecurity() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取安全级别
getSecurity() - 类 com.trs.components.wcm.resource.Source 中的方法
获取与来源有关的安全级别对象
getSecurityId() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取安全级别
getSecurityId() - 类 com.trs.components.wcm.resource.Source 中的方法
获取与来源有关的安全级别对象ID
getSelect() - 类 com.trs.infra.db.QueryFilter 中的方法
获取抽取的字段名列表
getSelect() - 类 com.trs.infra.persistent.WCMFilter 中的方法
获取抽取的字段名列表
getSelectCount() - 类 com.trs.infra.persistent.BaseObjs 中的方法
根据获取集合的Filter指定的条件,得到这一次查询的所有行数 select count(*)
getSelectFields() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getSelectFieldsFromDocument() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

getSelectFieldsFromInfoView() - 类 com.trs.components.infoview.persistent.InfoViewDocuments 中的方法

getSelfURL() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getSenderId() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：发送者ID
getSenderType() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：发送者类型
getSendType() - 类 com.trs.components.common.message.Message 中的方法

getSendType() - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法

getSendTypes() - 类 com.trs.components.common.calendar.Event 中的方法

getSentMsgs(User, WCMFilter) - 类 com.trs.components.common.message.MessageServer 中的静态方法
获得某用户的所有已发消息
已发的判断是从Message表中查询得到
getSequenceNumber() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

getSerialField() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getSerialNo() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取序号 说明：序号由系统自动生成
getSerialNo() - 类 com.trs.components.wcm.content.persistent.Relation 中的方法
获取序号
getSerialNum() - 类 com.trs.cms.process.engine.FlowContext 中的方法

getSerialNum() - 类 com.trs.cms.process.engine.FlowDoc 中的方法

getSerialNum() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取内容被发起的SerialNum
getSerialNum() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getSerialNum() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getSerialPattern() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getSerialPeriod() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getServer() - 类 com.trs.infra.support.config.ConfigServer 中的静态方法

getServerBuild() - 类 com.trs.infra.BaseServer 中的方法

getServerBuild() - 接口 com.trs.infra.IServer 中的方法
系统内部版本号
getServerCount() - 类 com.trs.infra.ServerControl 中的方法

getServerHost() - 类 com.trs.infra.util.ftp.FtpMgr 中的方法

getServerHost() - 接口 com.trs.infra.util.ftp.IFtpMgr 中的方法
Returns the server host addres.
getServerName() - 类 com.trs.infra.BaseServer 中的方法

getServerName() - 接口 com.trs.infra.IServer 中的方法
获取服务名称
getServerName() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

getServerName() - 类 com.trs.presentation.util.RequestHelper 中的方法
获取服务器名
getServerPort() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

getServerPort() - 类 com.trs.presentation.util.RequestHelper 中的方法
获取服务器端口
getServers() - 类 com.trs.infra.ServerControl 中的方法

getServiceConfig() - 类 com.trs.webframework.config.MethodConfig 中的方法

getServiceConfigPaths() - 类 com.trs.infra.config.domain.ConfigHelper 中的静态方法

getServiceConfigsMap() - 类 com.trs.webframework.config.ServiceConfigStartServer 中的方法

getServiceContext() - 类 com.trs.webframework.context.MethodContext 中的方法

getServiceFilter() - 类 com.trs.webframework.config.ServiceFilterConfig 中的方法
获取当前配置的Filter
getServiceId() - 类 com.trs.webframework.config.ServiceConfig 中的方法

getServiceId() - 类 com.trs.webframework.config.ServiceFilterConfig 中的方法

getServiceId() - 类 com.trs.webframework.config.ServiceListenerConfig 中的方法

getServiceListener() - 类 com.trs.webframework.config.ServiceListenerConfig 中的方法
获取当前配置的Listener
getServiceParameters() - 类 com.trs.webframework.controler.JSPRequestProcessor 中的方法

getServiceProvider() - 类 com.trs.webframework.config.ServiceConfig 中的方法

getServices() - 类 com.trs.webframework.config.ServiceConfig 中的方法

getServiceTypes() - 类 com.trs.infra.support.security.SecureKeyUtil 中的静态方法

getSessionById(String) - 类 com.trs.presentation.util.LoginHelper 中的静态方法

getSessionByUser(User) - 类 com.trs.presentation.util.LoginHelper 中的静态方法

getSessionValue(String) - 类 com.trs.webframework.context.ServiceContext 中的方法

getSetRightTbl(RightDefs, Rights, Rights, Rights, String) - 类 com.trs.components.wcm.util.CRightUtil 中的方法

getSetRightTbl(RightDefs, String) - 类 com.trs.components.wcm.util.CRightUtil 中的方法

getSetRightTbl(String) - 类 com.trs.components.wcm.util.CRightUtil 中的方法

getSettingByType(String, String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法

getSettingByType(String, String) - 接口 com.trs.template.service.ITemplateService 中的方法
获取指定类型的配置信息
getSettingByType(String, String) - 类 com.trs.template.TRSTemplateFacade 中的方法
获取指定类型的配置信息
getSettingTypeClassz() - 类 com.trs.template.domain.setting.TemplateSettingFactory 中的方法

getSettingTypeList(String) - 类 com.trs.template.service.impl.TemplateServiceImpl 中的方法

getSettingTypeList(String) - 接口 com.trs.template.service.ITemplateService 中的方法
获取模板服务器端的配置的资源信息类型的列表
getSettingTypeList(String) - 类 com.trs.template.TRSTemplateFacade 中的方法
获取服务器端的配置信息的类别列表
getSettingTypes() - 类 com.trs.template.domain.setting.TemplateSettingFactory 中的方法

getSeviceConfigRootPath() - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法

getSevicesConfigFileName(String) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法

getSharedBookMarks(User, WCMFilter) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
获取共享给当前登录用户的书签
getSharedBookMarks(User, WCMFilter) - 接口 com.trs.service.IBookMarkService 中的方法
获取所有共享的书签
getSharedBookMarks(User, WCMFilter) - 类 com.trs.service.impl.BookMarkService 中的方法

getSharedEvents(User, CMyDateTime) - 接口 com.trs.service.IEventService 中的方法
获取用户在指定日期内被Assign的所有Events
getSharedEvents(User, CMyDateTime, boolean) - 接口 com.trs.service.IEventService 中的方法
获取用户在指定日期内私有的或公有的Events
getSharedEvents(User, CMyDateTime, boolean, WCMFilter) - 接口 com.trs.service.IEventService 中的方法
获取用户在指定filter限制下被Assign的Events
getSharedEvents(User, CMyDateTime, boolean) - 类 com.trs.service.impl.EventService 中的方法

getSharedEvents(User, CMyDateTime) - 类 com.trs.service.impl.EventService 中的方法

getSharedEvents(User, CMyDateTime, boolean, WCMFilter) - 类 com.trs.service.impl.EventService 中的方法

getSharedGroups(int, CMSObj) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法

getSharedGroups(int, int) - 接口 com.trs.service.IBookMarkService 中的方法
获取共享组织
getSharedGroups(Event) - 接口 com.trs.service.IEventService 中的方法
获取一个Event被AssignTo的Group
getSharedGroups(int, int) - 类 com.trs.service.impl.BookMarkService 中的方法

getSharedGroups(Event) - 类 com.trs.service.impl.EventService 中的方法

getSharedMarkKinds(User, WCMFilter) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
获取共享给当前登录用户的书签分类
getSharedMarkKinds(User, WCMFilter) - 接口 com.trs.service.IBookMarkService 中的方法
获取所有共享的书签文件夹
getSharedMarkKinds(User, WCMFilter) - 类 com.trs.service.impl.BookMarkService 中的方法

getSharedUsers(int, CMSObj) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法

getSharedUsers(int, int) - 接口 com.trs.service.IBookMarkService 中的方法
获取共享用户
getSharedUsers(Event) - 接口 com.trs.service.IEventService 中的方法
获取一个Event被AssignTo的Users
getSharedUsers(int, int) - 类 com.trs.service.impl.BookMarkService 中的方法

getSharedUsers(Event) - 类 com.trs.service.impl.EventService 中的方法

getShareMarks(WCMFilter) - 类 com.trs.components.common.bookmark.BookMarkMgr 中的方法
获取当前登录用户可访问的共享书签
getShowBakFunc(Document, Channel) - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 中的静态方法
获取管理版本的Javascript
getShowIf() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

getSiblingIndex() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
Retuns index of this folder in its siblings.
getSiblingIndex() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

getSiblingIndex() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getSiblingIndex() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
获取当前频道或站点的位置
getSiblingIndex(BaseChannel) - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法

getSiblingIndex(BaseChannel) - 接口 com.trs.components.wcm.content.persistent.IChildrenMgr 中的方法
获取指定频道/站点在其同级目录中的位置
getSiblingIndex() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getSiblingIndex() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getSiblingIndex() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getSign(String) - 类 com.trs.infra.util.CMySign 中的静态方法
返回唯一的实例
getSimilarIndexs(int) - 类 com.trs.cms.auth.config.RightConfigServer 中的方法

getSimilarIndexs() - 类 com.trs.cms.auth.config.RightConfigServer 中的方法

getSimpleType() - 类 com.trs.components.infoview.extract.DataType 中的静态方法

getSite(int, int) - 类 com.trs.cms.auth.persistent.RightValue 中的静态方法
由于角色和站点绑定，所以这个地方需要获取站点的id，将RightValue和站点依赖不太好，目前没有找到相应的解决办法, 除非每一个对象实现一个getHost的方法
getSite() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法

getSite() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
获取站点对象
getSite() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法

getSite() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
频道所属的站点对象
getSite() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
获取所属站点对象
getSite() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

getSite() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
设置表单所属的站点
getSiteDataFile(String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 中的方法
获取指定站点指定样式的数据文件
getSiteDataFile(String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 中的方法

getSiteDemoLink(String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 中的方法
获取指定站点指定样式的演示地址
getSiteDemoLink(String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 中的方法

getSiteDesc() - 类 com.trs.template.persistent.WebSiteInfoEntity 中的方法

getSiteEntities() - 类 com.trs.template.domain.InfoEntityFinder 中的方法

getSiteGroups(WebSite, WCMFilter) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
获取站点中的用户组集合
getSiteGroups(WebSite, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取指定站点的所属用户组集合
getSiteGroups(WebSite, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法

getSiteId() - 类 com.trs.cms.auth.config.OperationDefineOnCurrChannelConfig 中的方法
获取相关站点ID
getSiteId() - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
提取属性：SiteId
getSiteId() - 类 com.trs.cms.process.definition.Flow 中的方法
获取工作流所属的站点ID
getSiteId() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：SiteId
getSiteID() - 类 com.trs.components.comment.domain.Management 中的方法
返回WCM中站点ID
getSiteId() - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

getSiteId() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：SITEID
getSiteID() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getSiteID() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getSiteId() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法
获取站点ID
getSiteId() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法

getSiteId() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道所属的站点ID
getSiteId() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法
获取所属站点Id
getSiteId() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
提取属性：SiteId
getSiteId() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
获取所属站点ID
getSiteId() - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法
提取属性：SiteId
getSiteId() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

getSITEID() - 类 com.trs.components.wcm.resource.Keyword 中的方法
提取属性：SITEID
getSiteId() - 类 com.trs.template.persistent.WebSiteInfoEntity 中的方法

getSiteId() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
获得表单所属的站点编号
getSiteIds() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法
获取检索条件对应的站点号
getSiteInfoFilePath() - 类 com.trs.template.domain.SourcePathHelper 中的静态方法

getSiteIntroduceContent(String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 中的方法
获取指定站点指定样式的介绍内容
getSiteIntroduceContent(String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 中的方法

getSiteIntroduceImgFilePath(String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 中的方法
获取指定站点指定样式的介绍图片
getSiteIntroduceImgFilePath(String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 中的方法

getSiteKindPath(String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellResLocator 中的方法
根据给定路径下的类型得到真实的路径
getSiteKindPath(String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl 中的方法

getSiteKinds() - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 中的方法
获取所有站点类型
getSiteKinds() - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 中的方法

getSiteKindStylePath(String, String, String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellResLocator 中的方法
根据给定路径下的类型和样式得到真实的路径
getSiteKindStylePath(String, String, String) - 类 com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl 中的方法

getSiteLanguage() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
获取站点的语言选项
发布产生的静态页面使用的语言
getSiteLanguage() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
获取站点的语言选项
发布产生的静态页面使用的语言
getSiteName() - 类 com.trs.components.comment.domain.Management 中的方法
返回WCM中的站点名
getSiteName() - 类 com.trs.template.persistent.WebSiteInfoEntity 中的方法

getSiteProp(int) - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
判断站点是否具有指定索引的属性
getSiteRoles(WebSite, WCMFilter) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法

getSiteRoles(WebSite, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取指定站点的所属角色集合
getSiteRoles(WebSite, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法

getSiteRoleUsersInfo(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
获取指定用户的站点角色用户信息，map格式为：
getSites() - 类 com.trs.presentation.nav.TreeNodeCalctor 中的方法

getSitesForCurrUser(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
获取当前登录用户可以操作（默认为设置权限）的站点
getSiteStyles(String) - 接口 com.trs.components.wcm.content.domain.intelligence.IIntellMgr 中的方法
获取指定类型的所有样式
getSiteStyles(String) - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 中的方法

getSiteTree() - 类 com.trs.wcmonline.WCMOnlineService 中的方法

getSITETYPE() - 类 com.trs.components.wcm.resource.Keyword 中的方法
提取属性：SITETYPE
getSiteTypeDesc(String) - 类 com.trs.ajaxservice.SystemServiceProvider 中的静态方法

getSiteUsers(WebSite, WCMFilter) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
获取站点中的用户集合
getSiteUsers(WebSite, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取指定站点的所属用户集合
getSiteUsers(WebSite, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法

getSiteXML(int) - 类 com.trs.service.impl.SOAPServiceImpl 中的方法

getSiteXML(int) - 接口 com.trs.service.ISOAPService 中的方法
获取指定站点的信息
getSize() - 类 com.trs.infra.util.cabfile.CabEntry 中的方法

getSize() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the size of the uncompressed data.
getSize() - 接口 com.trs.wcm.photo.IMagicImage 中的方法
获得图片大小
getSize() - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法

getSMTPServerByName(String) - 类 com.trs.infra.util.email.CMySMTPServer 中的静态方法
从配置文件中，根据邮件服务器的名称，得到邮件服务器的配置
getSMTPServerConfigByName(String) - 类 com.trs.infra.util.email.SMTPServerConfigMapper 中的方法
依据SMTP服务器名获取指定的配置信息
getSMTPServerConfigColl() - 类 com.trs.infra.util.email.SMTPServerConfigs 中的方法

getSocketTimeOut() - 类 com.trs.infra.util.email.TRSMailer 中的方法

getSolution() - 异常 com.trs.template.AbstractErrorMessage 中的方法
获取错误解决办法
getSortedMetaViewFields(int) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法

getSortedMetaViewFields(int) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

getSource() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档来源
getSource() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取文档来源
getSourceId() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档来源
getSourceId() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取文档来源
getSourceId() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
提取属性：SourceId
getSourcesRemided(User) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
获取用户需要提醒的媒体集合
getSpecCategory(String) - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态方法

getSpecFileExt(String) - 类 com.trs.components.wcm.stat.domain.ChartConstants 中的静态方法

getSpecialDesc() - 类 com.trs.components.special.Special 中的方法
提取属性：SpecialDesc
getSpecialInitDataPath(HttpServletRequest) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法

getSpecialName() - 类 com.trs.components.special.Special 中的方法
提取属性：SpecialName
getSpecialRolesOfUser(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
获取指定用户的特定角色
getSpecialRolesOfUser(User, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取指定用户上设置的特定角色
getSplitBy() - 类 com.trs.components.infoview.config.EnumCreator 中的方法

getSQL(int) - 类 com.trs.db.update.DBUpdateLog 中的方法

getSql(TableDiff) - 类 com.trs.infra.util.upgrade.sql.SchemaUpdSqlMaker 中的方法
获取SQL
getSqlDataType() - 类 com.trs.components.infoview.db.InfoViewDataType 中的方法

getSqlDataType() - 类 com.trs.components.metadata.definition.MetaDataType 中的方法

getSQLServerSQL() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：SQLServerSQL
getSqlType() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法

getSrcChannel() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
获取源频道
getSrcChannelId() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
提取属性：SrcChannelId
getSrcContentStyleId() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
提取属性：源内容风格ID
getSrcFile() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件的源文件名
getSrcFileName() - 类 com.trs.wcm.photo.ImageInfo 中的方法

getSrcImageFileName() - 接口 com.trs.wcm.photo.IMagicImage 中的方法
获取原始的图片文件名
getSrcImageFileName() - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法

getSrcPageStyleId() - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
提取属性：源页面风格ID
getSrcResourceStyleId() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
提取属性：源资源风格ID
getStackTraceText() - 异常 com.trs.infra.util.CMyException 中的方法

getStackTraceText(Throwable) - 异常 com.trs.infra.util.CMyException 中的静态方法
取异常堆栈信息
getStartDateTime(int) - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 中的方法

getStartDateTime(int, int) - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 中的方法

getStartDateTime(int) - 接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr 中的方法
获取指定频道提取文档的开始时间
getStartDateTime(int, int) - 接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr 中的方法
获取指定对象提取文档的开始时间
getStartFolder() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法

getStartId() - 类 com.trs.infra.support.log.BaseDBLog 中的方法

getStartId() - 接口 com.trs.infra.support.log.ILog 中的方法

getStartNode() - 类 com.trs.cms.process.definition.Flow 中的方法
获取起始节点
getStartNodeName() - 类 com.trs.cms.process.definition.Flow 中的方法
获取起始节点名称
getStartStatTime() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

getStartStatTimeAsString() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

getStartTime() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
提取属性：StartTime
getStartTime() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取内容被发起的时间
getStartTime() - 类 com.trs.components.common.calendar.Event 中的方法
property: StartTime 开始时间
getStartTime() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：开始执行时间，与结束时间共同指定计划执行所在的时间段。
getStartTime() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：StartTime
getStartTime() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getStartTime() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道指定的开始时间 *
getStartTime() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
属性提取：开始执行时间
getStartTime() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法

getStartTime() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getStartTime() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：StartTime
getStartTimeMillis() - 类 com.trs.infra.support.log.BaseDBLog 中的方法

getStartTimeMillis() - 接口 com.trs.infra.support.log.ILog 中的方法

getStartUser() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法

getStartUserName() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法

getStatFieldMaps() - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的方法

getStatFieldMaps() - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的方法

getStatFieldsByView(int) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别
getStatFieldsByView(int) - 类 com.trs.service.impl.StatService 中的方法

getStatFieldsByView(int) - 接口 com.trs.service.IStatService 中的方法
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别
getStatHost() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：StatHost
getStatHosts(WCMFilter) - 类 com.trs.service.impl.StatService 中的方法

getStatHosts(WCMFilter) - 接口 com.trs.service.IStatService 中的方法
获得系统中提供的所有统计主体
getStatisticMaxIndex() - 类 com.trs.infra.common.WCMRightTypes 中的静态方法
返回统计分析最大权限值 为什么增加这个方法，而不是直接使用常量EXT_MAX_INDEX？
getStatisticMinIndex() - 类 com.trs.infra.common.WCMRightTypes 中的静态方法
返回统计分析最小权限值 为什么增加这个方法，而不是直接使用常量EXT_MIN_INDEX？
getStatResult(String, String) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
进行用户定制的统计并返回统计结果
getStatResult(int, CMyDateTime, CMyDateTime, String, String) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
统计在一个时间段内，符合特定条件的某个统计的结果
从临时统计表中查询，所以时间条件都是以DEF_STATTIME为准
Id需要从表中构造
Notes:
The view shoulb be a Template View.
getStatResult(int) - 类 com.trs.service.impl.StatService 中的方法

getStatResult(int, CMyDateTime, CMyDateTime) - 类 com.trs.service.impl.StatService 中的方法

getStatResult(int, CMyDateTime, CMyDateTime, String) - 类 com.trs.service.impl.StatService 中的方法

getStatResult(String, String) - 类 com.trs.service.impl.StatService 中的方法

getStatResult(int, CMyDateTime, CMyDateTime, String, String) - 类 com.trs.service.impl.StatService 中的方法

getStatResult(int) - 接口 com.trs.service.IStatService 中的方法
获得一个统计模板对应的所有结果
getStatResult(int, CMyDateTime, CMyDateTime) - 接口 com.trs.service.IStatService 中的方法
统计在一个时间段内，某个统计的结果
getStatResult(int, CMyDateTime, CMyDateTime, String) - 接口 com.trs.service.IStatService 中的方法
统计在一个时间段内，符合特定条件的某个统计的结果
getStatResult(int, CMyDateTime, CMyDateTime, String, String) - 接口 com.trs.service.IStatService 中的方法

getStatResult(String, String) - 接口 com.trs.service.IStatService 中的方法
进行用户定制的统计并返回统计结果
getStatResults() - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的方法

getStatResults() - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的方法

getStatTempId() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
提取属性：StatTempId
getStatTime() - 类 com.trs.components.wcm.stat.domain.StatDataItem 中的方法

getStatTimeAsString() - 类 com.trs.components.wcm.stat.domain.StatDataItem 中的方法

getStatTimeAsString(String) - 类 com.trs.components.wcm.stat.domain.StatDataItem 中的方法

getStatTimeField() - 类 com.trs.components.wcm.stat.domain.ChartOption 中的方法

getStatus() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
提取属性：Status
getStatus() - 类 com.trs.cms.auth.persistent.User 中的方法
获取用户当前状态
getStatus() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
获取文档经过此分支时自动改变后的状态
getStatus() - 类 com.trs.components.common.job.Schedule 中的方法
属性提取：计划状态（注意：删除的计划，状态为负值）
getStatus() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
get the property of Status
getStatus() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
获取文档状态
getStatus() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getStatus() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
获取站点/频道的状态值(STATUS_NORM等)
getStatus() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道状态（Channel.STATUS_NORM等）
getStatus() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
提取ChnlDoc的状态
getStatus() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档状态
getStatus() - 类 com.trs.components.wcm.content.ViewDocument 中的方法

getStatusCode() - 类 com.trs.infra.util.ResponseBuddy 中的方法

getStatusDesc() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取状态的描述
getStatusDesc() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getStatusDesc() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getStatuses(User) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法

getStatusesCanDoPub() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：StatusesCanDoPub
getStatusesCanDoPub() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
提取属性：StatusesCanDoPub
getStatusId() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
获取文档经过此分支时自动改变后的状态的ID
getStatusId() - 接口 com.trs.cms.process.IFlowContent 中的方法

getStatusId() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法

getStatusId() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getStatusId() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getStatusId() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
提取属性：StatusId
getStatusId() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档状态
getStatusId() - 类 com.trs.components.wcm.content.ViewDocument 中的方法

getStatusId() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getStatusIdAfterModify() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：StatusIdAfterModify
getStatusIdAfterModify() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
提取属性：StatusIdAfterModify
getStatusIds() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法

getStatusName() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法

getStatusName(int) - 类 com.trs.components.infoview.helper.InfoViewQueryHelper 中的静态方法

getStatusName() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
获取状态名称
getStatusName() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取状态名称
getStatusString() - 类 com.trs.cms.auth.persistent.User 中的方法
获取用户当前状态信息
getStatusString(int) - 类 com.trs.cms.auth.persistent.User 中的静态方法
获得用户状态描述
getStatViews(String, int, WCMFilter) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
获取指定统计主体下的统计视图.
getStatViews(String, int, WCMFilter) - 类 com.trs.service.impl.StatService 中的方法

getStatViews(String, int, WCMFilter) - 接口 com.trs.service.IStatService 中的方法
获得特定查询主体的统计视图模板
getStatVote(String, String, String) - 类 com.trs.components.common.trsvote.VoteSoapClient 中的方法

getStr(Object, String) - 类 com.trs.infra.util.CMyDateTime 中的静态方法

getStr(String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串编码转换函数，用于将指定编码的字符串转换为标准（Unicode）字符串
getStr(String, boolean) - 类 com.trs.infra.util.CMyString 中的静态方法
字符转换函数，处理中文问题
getStr(String, String) - 类 com.trs.infra.util.CMyString 中的静态方法
字符串编码转换函数，用于将指定编码的字符串转换为标准（Unicode）字符串 Purpose: 转换字符串内码，用于解决中文显示问题 Usage： 在页面切换时，获取并显示中文字符串参数时可用。
getString(int) - 类 com.trs.infra.util.ExceptionMessages 中的静态方法

getString(String, String) - 类 com.trs.presentation.locale.LocaleServer 中的静态方法
获取特定语种资源配置中的资源值（数值型）
getString(String) - 类 com.trs.presentation.util.RequestHelper 中的方法
取字符串型属性值
getStringViewWidth(String) - 类 com.trs.infra.util.CMyString 中的静态方法
返回指定字符串的显示宽度
getStringWithCutsize(String, TRSHitPoint[], int, String, String) - 类 com.trs.components.wcm.content.trsserver.TRSSearchUtil 中的静态方法
根据命中点进行截断
getStyle() - 类 com.trs.components.common.trsvote.VoteItem 中的方法
提取属性：Style
getStyle() - 类 com.trs.components.common.trsvote.VoteOption 中的方法
提取属性：Style
getStyle(Special) - 接口 com.trs.components.special.ISpecialMgr 中的方法
获取专题风格
getStyle(MethodContext) - 接口 com.trs.components.special.ISpecialServiceProvider 中的方法
获取专题页面风格
getStyle(Special) - 类 com.trs.components.special.SpecialMgr 中的方法

getStyle(MethodContext) - 类 com.trs.components.special.SpecialServiceProvider 中的方法

getStyleCommonDir() - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态方法
获取风格资源文件所在的路径
getStyleCommonDir(String) - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态方法
获取指定风格资源文件所在的路径
getStyleCssDir() - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态方法
获取生成的风格样式文件路径
getStyleDesc() - 类 com.trs.components.common.publish.widget.BaseStyle 中的方法
提取属性：风格描述
getStyleFile(PageStyle) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
获取风格对应的样式文件
getStyleFile(PageStyle) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法

getStyleName() - 类 com.trs.components.common.publish.widget.BaseStyle 中的方法
提取属性：风格名称
getStyleName() - 类 com.trs.components.special.Special 中的方法
提取属性：StyleName
getStyleObjId() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
提取属性：StyleObjId
getStyleObjId() - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
提取属性：StyleObjId
getStyleObjType() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
提取属性：StyleObjType
getStyleObjType() - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
提取属性：StyleObjType
getStyleThumb() - 类 com.trs.components.common.publish.widget.BaseStyle 中的方法
提取属性：风格缩略图
getStyleThumb() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
提取属性：风格缩略图
getStyleThumb() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
提取属性：风格缩略图
getStyleURI() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

getSubChannelsByParentId(int) - 类 com.trs.components.wcm.content.persistent.Channels 中的方法
取当前集合ParentId为指定值的子集
getSubinstance() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取流转内容关联的对象
getSubinstance() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getSubinstance() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getSubinstanceId() - 接口 com.trs.cms.process.IFlowContent 中的方法
获取当前流转内容的ID
getSubinstanceId() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getSubinstanceId() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getSubject() - 类 com.trs.infra.util.email.CMyEmail 中的方法

getSubmitAgainFunc(Document) - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 中的静态方法
获取再次呈送文档的Javascript
getSubmitButtonHTML() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getSubmitFlowDocs(User, WCMFilter) - 类 com.trs.cms.process.FlowServer 中的方法

getSubmitFlowDocs(User, WCMFilter) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法

getSubmitFlowDocs(User, WCMFilter) - 接口 com.trs.service.IWCMProcessService 中的方法
获取用户[_operator]已经呈送的信息
getSubmitFunc(Document) - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 中的静态方法
获取呈送文档的Javascript
getSubmitor() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：Submitor
getSubmitVote(String, String, String, String, String) - 类 com.trs.components.common.trsvote.VoteSoapClient 中的方法

getSubstance() - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法

getSubstance() - 接口 com.trs.cms.content.ICMSObjSubstanceContent 中的方法
Returns the substance object which is an instance of CMSObj.
getSubstance() - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法

getSubstance() - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

getSubstance() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

getSubstance() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getSubstance() - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法

getSubstance() - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法

getSubstance() - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法

getSubstance() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

getSubstance() - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

getSubstance() - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

getSubstance() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getSubstance() - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 中的方法

getSubstance() - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 中的方法

getSubstance() - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 中的方法

getSubstance() - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 中的方法

getSubstance() - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 中的方法

getSubstance() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getSubstance() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getSubstance() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

getSubstance() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getSubstance() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getSubTitle() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档副标题
getSuccessInfo() - 类 com.trs.wcm.old.ImportDocsContext 中的方法

getSucessedReporter() - 类 com.trs.infra.util.Reports 中的方法
获取所有成功的报告
getSucessedReporterAt(int) - 类 com.trs.infra.util.Reports 中的方法
获取一个成功的报告
getSuggestion() - 异常 com.trs.webframework.exception.ServiceInvocationException 中的方法

getSupportedApdExts() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

getSupportedDataTypes() - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
获取系统支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.DB2UDB 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.DB2UDB2 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.DBType 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.MysqlDB 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.OracleDB 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.SQLServerDB 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.SybaseASE 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
取系统处理可以支持的数据类型
getSupportedDataTypes() - 类 com.trs.infra.util.database.XuguDB 中的方法

getSupportedDataTypes() - 接口 com.trs.service.IDBService 中的方法

getSupportedDataTypes() - 类 com.trs.service.impl.DBService 中的方法

getSupportedExts() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

getSupportedFormat(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法

getSupportedTemplateFileExt() - 类 com.trs.components.common.publish.domain.template.TemplateImporter 中的静态方法
获取系统支持的模板文件类型.
getSupportImageFileExt() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取系统支持的各种图片文件格式
getSupportImageFileExt() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getSureFormFileName() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
得到书生表单文件名称
getSymbol(StreamManipulator) - 类 com.trs.infra.util.jazzlib.InflaterHuffmanTree 中的方法
Reads the next symbol from input.
getSynSrcChannel(Channel) - 接口 com.trs.service.IChannelService 中的方法
获取给当前频道分发文档的频道集合
getSynSrcChannel(Channel) - 类 com.trs.service.impl.ChannelService 中的方法
获取给当前频道分发文档的频道集合
getSynSrcChannels(Channel) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法
获取给当前频道分发文档的频道集合
getSynToChannel(Channel) - 接口 com.trs.service.IChannelService 中的方法
获取当前频道分发文档的目标频道集合
getSynToChannel(Channel) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前频道分发文档的目标频道集合
getSynToChannels(Channel) - 类 com.trs.components.wcm.content.domain.AutoTransmitMgr 中的方法
获取当前频分发文档的目标频道集合
getSysbaseSQL() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：SysbaseSQL
getSysConfig(String) - 类 com.trs.infra.support.config.ConfigServer 中的方法
取指定的系统配置信息
getSysConfigValue(String, String) - 类 com.trs.infra.support.config.ConfigServer 中的方法

getSysContentLinkId() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法

getSysMaxIndex() - 类 com.trs.infra.common.WCMRightTypes 中的静态方法
返回扩展功能最大权限值 为什么增加这个方法，而不是直接使用常量SYS_MAX_INDEX？
getSysMinIndex() - 类 com.trs.infra.common.WCMRightTypes 中的静态方法
返回扩展功能最小权限值 为什么增加这个方法，而不是直接使用常量SYS_MIN_INDEX？
getSysPics(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法

getSystem() - 类 com.trs.cms.auth.persistent.User 中的静态方法

getSystemContentStyles() - 类 com.trs.components.common.publish.widget.SystemContentStyleMgr 中的方法
获取系统级资源可用风格
getSystemInfo(String, int, int, String, String) - 接口 com.trs.service.ICDSService 中的方法
根据CDS传入的参数，获取指定的系统信息
getSystemInfo(String, int, int) - 接口 com.trs.service.ICDSService 中的方法
根据CDS传入的参数，获取指定的系统信息
getSystemInfo(String, int, int) - 类 com.trs.service.impl.CDSServiceImpl 中的方法

getSystemInfo(String, int, int, String, String) - 类 com.trs.service.impl.CDSServiceImpl 中的方法

getSystemProperty(String, String) - 类 com.trs.infra.util.OptionConverter 中的静态方法
Very similar to System.getProperty except that the SecurityException is hidden.
getSystemResourceStyles() - 类 com.trs.components.common.publish.widget.SystemResourceStyleMgr 中的方法
获取系统级资源可用风格
getSystemRolesOfUser(MethodContext) - 类 com.trs.ajaxservice.RoleServiceProvider 中的方法
获取指定用户在指定站点上的系统级角色
getSystemRolesOfUser(User, int, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取指定用户在指定站点上设置的角色信息
getSystemUserId() - 类 com.trs.components.common.address.Contact 中的方法

getTabCount() - 类 com.trs.scene.tools.SceneNode 中的方法

getTable() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取存储频道中文档的数据表的名称
getTable() - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
获取表对象
getTableCount() - 类 com.trs.infra.util.database.TableInfos 中的方法
取数据表的总数
getTableId() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：TableId
getTableId() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：TableId
getTableInfo(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
取指定数据表的信息
getTableInfo(String) - 类 com.trs.infra.util.database.TableInfos 中的方法
取指定数据表的字段信息
getTableInfos() - 类 com.trs.infra.persistent.db.DBManager 中的方法

getTableName() - 类 com.trs.cms.content.ExtendedField 中的方法
扩展字段所属数据表名称
getTableName() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：TableName
getTableName() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：TableName
getTableName() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
扩展字段所属数据表名称
getTableName() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：TableName
getTableName() - 类 com.trs.infra.util.database.TableInfo 中的方法
获取数据表名称
getTableName() - 类 com.trs.infra.util.upgrade.dbcompare.Table 中的方法

getTableName() - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
获取表名
getTableNames() - 类 com.trs.infra.util.database.TableInfos 中的方法
取所有的数据表名称列表
getTables() - 类 com.trs.infra.util.upgrade.dbcompare.MetaDataLoader 中的方法
获取所有表对象
getTag() - 类 com.trs.components.wcm.resource.FileType 中的方法

getTag(String) - 类 com.trs.infra.util.html.HTML 中的静态方法
Fetch a tag constant for a well-known tag name (i.e. one of the tags in the set allTags).
getTag() - 类 com.trs.infra.util.html.HtmlElement 中的方法
获取Tag对象
getTagBean() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
返回TRS置标解析组件的组件名
getTagDesc() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
获得TRS置标解析组件的描述
getTagFormatters() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

getTagFormattersConfigs() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the tag formatter config.
getTagItem() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

getTagName() - 类 com.trs.components.common.publish.config.persistent.TagFormatterConfig 中的方法

getTagName() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
返回TRS置标解析组件负责解析的置标名称
getTagParser4List() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
返回相关联的ITagParser4List对象
getTagParserClass(String) - 类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 中的方法
Returns the parser class of the specified tag.
getTagsHavingSrc() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

getTagSrcAttributeNames() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

getTagsToSkip() - 类 com.trs.infra.util.html.ContentLinkReplacer 中的静态方法
取处理时可以跳过的元素标记
getTarget() - 类 com.trs.components.infoview.extract.manifest.CalculatedField 中的方法

getTarget() - 类 com.trs.webframework.entity.RedirectObject 中的方法

getTargetPort() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：TargetPort，目标服务器的端口号
getTargetServer() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：TargetServer
getTargetType() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：TargetTypeConfig
getTargetTypes() - 类 com.trs.components.common.publish.config.persistent.PublishDistributionConfig 中的方法

getTask() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法

getTask() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskWorker 中的方法

getTaskContext() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
Returns the current publish task context.
getTaskContext() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 中的方法

getTaskPriority() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 中的方法
返回发布任务的优先级
getTaskRuntime(int) - 类 com.trs.components.common.publish.domain.PublishServer 中的方法
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
getTaskRuntime(int) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskDispatcher 中的方法
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
getTaskRuntime(int) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法

getTaskRuntime(int) - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法

getTaskRuntime() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskWorker 中的方法

getTaskRuntime(int) - 类 com.trs.service.impl.PublishService 中的方法

getTaskRuntime(int) - 接口 com.trs.service.IPublishService 中的方法
返回指定ID的发布任务对象的运行时对象PublishTaskRuntime。
getTasks(WCMFilter) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
get the tasks collection with the specified filter
getTasks(WCMFilter) - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法

getTel() - 类 com.trs.cms.auth.persistent.User 中的方法
获取联系电话
getTel() - 类 com.trs.components.common.address.Contact 中的方法
属性: Tel 电话
getTelephone() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
提取属性：Telephone
getTempAppendixesInRoot(int, int, WCMFilter) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法
get the template appendixes in the specified root
getTempAppendixFilePath(int, int, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
已过时。 to use getTemplateAppendixPath(WebSite.OBJ_TYPE, _nSiteId, _nPathType, _bCreateWhenNotExists) instead please.
getTempAppendixId() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
提取属性：TempAppendixId
getTempFileName(String, String) - 类 com.trs.components.wcm.newshoo.DataFromNewshoo 中的方法

getTempFileName(String, String) - 类 com.trs.components.wcm.newshoo.DataFromRadar 中的方法

getTempFileName() - 类 com.trs.infra.util.CMyFile 中的静态方法
返回一个临时的文件名(通常用作目录)
getTemplate() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
获取相关模板
getTemplate() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回形式参数所在的模板
getTemplate() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
get the Template instance
getTemplate() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法

getTemplate() - 类 com.trs.components.common.publish.widget.BaseStyle 中的方法
提取属性：风格的样式模板类型
getTemplate() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
提取属性：样式模板
getTemplate() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
提取属性：风格样式模板
getTemplate() - 类 com.trs.components.infoview.extract.manifest.FileNew 中的方法
已过时。
getTemplate(String) - 类 com.trs.components.web.BaseFieldHTMLParser 中的方法
根据字段名称，返回该字段对应的HTML模板资源
getTemplateAppendixPath(int, int, int, boolean) - 类 com.trs.infra.support.file.FilesMan 中的方法
Returns the template appendix file path of the sepcified root.
getTemplateArguments() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
返回该发布对象已经进行了有效设置的全部模板参数列表
getTemplateArguments() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

getTemplateArguments() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

getTemplateArguments() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法

getTemplateArguments() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getTemplateArguments(IPublishElement) - 类 com.trs.service.impl.TemplateService 中的方法

getTemplateArguments(IPublishElement) - 接口 com.trs.service.ITemplateService 中的方法
返回指定发布对象上的全部有效模板参数列表
getTemplateByName(String) - 类 com.trs.components.common.publish.persistent.template.Templates 中的方法
根据模板名称查找模板
getTemplateContent() - 类 com.trs.components.infoview.config.EnumCreator 中的方法

getTemplateContent() - 类 com.trs.components.infoview.config.LinkedEnumCreator 中的方法

getTemplateContent(MetaViewField) - 类 com.trs.components.metadata.web.FieldTemplate 中的方法
获取该视图字段对应的模板内容
getTemplateEmployers(Template, WCMFilter) - 类 com.trs.components.common.publish.domain.template.TemplateEmployMgr 中的方法

getTemplateEmployers(Template, int) - 类 com.trs.service.impl.TemplateService 中的方法

getTemplateEmployers(Template) - 类 com.trs.service.impl.TemplateService 中的方法

getTemplateEmployers(Template) - 接口 com.trs.service.ITemplateService 中的方法
获取使用到当前模板的所有对象集合
getTemplateEmployers(Template, int) - 接口 com.trs.service.ITemplateService 中的方法
获取使用到当前模板的指定类型的对象集合
getTemplateEncoding(String) - 类 com.trs.components.web.BaseFieldHTMLParser 中的方法
返回文件对应的编码信息
getTemplateEntities() - 类 com.trs.template.domain.InfoEntityFinder 中的方法

getTemplateFile() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法

getTemplateFile() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getTemplateFile() - 类 com.trs.infra.util.TRSJspAutoTool 中的方法

getTemplateFileContent(InfoView) - 类 com.trs.components.infoview.InfoViewMgr 中的方法

getTemplateFileContent() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getTemplateId() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回形式参数所在模板的ID
getTemplateId() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
提取属性：TemplateId
getTemplateId() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法
提取属性：TemplateId
getTemplateId() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
提取属性：TemplateId
getTemplateId() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
提取属性：TemplateId
getTemplateId() - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
提取属性：TemplateId
getTemplateId() - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法

getTemplateInfoFilePath() - 类 com.trs.template.domain.SourcePathHelper 中的静态方法

getTemplateKey(String) - 类 com.trs.components.web.BaseFieldHTMLParser 中的方法
返回文件对应的key信息
getTemplateName() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter 中的方法
返回形式参数所在模板的名称
getTemplateName() - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法

getTemplatePackageDir() - 类 com.trs.template.domain.SourcePathHelper 中的静态方法

getTemplateParameters() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
返回模板中所有形式参数的列表
getTemplateParameters(boolean) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
返回模板中所有形式参数的列表
getTemplateParameters(IPublishElement) - 类 com.trs.service.impl.TemplateService 中的方法

getTemplateParameters(IPublishElement, boolean) - 类 com.trs.service.impl.TemplateService 中的方法

getTemplateParameters(IPublishElement) - 接口 com.trs.service.ITemplateService 中的方法
返回指定发布对象使用的所有模板中的全部形式参数列表
getTemplateParameters(IPublishElement, boolean) - 接口 com.trs.service.ITemplateService 中的方法
返回指定发布对象使用的所有模板中的全部形式参数列表
getTemplateParse() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

getTemplateParseConfig() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
get the template parse configuration.
getTemplatePath() - 类 com.trs.components.metadata.web.impl.AddEditFieldTemplate 中的方法

getTemplatePath() - 类 com.trs.components.metadata.web.impl.ListFieldTemplate 中的方法

getTemplatePath() - 类 com.trs.components.metadata.web.impl.ViewFieldTemplate 中的方法

getTemplatePath() - 类 com.trs.components.web.BaseFieldHTMLParser 中的方法
返回模板存放的根路径
getTemplatePath() - 类 com.trs.components.web.document.DocumentFieldHTMLParser 中的方法

getTemplates(WCMFilter) - 类 com.trs.components.wcm.recent.RecentMgr 中的方法
获得用户最近访问的模板列表，按访问时间逆序排列
getTemplates(WCMFilter) - 类 com.trs.service.impl.RecentService 中的方法

getTemplates(WCMFilter) - 接口 com.trs.service.IRecentService 中的方法
返回用户最近访问的模板列表
按照访问的时间顺序排序
getTemplatesNested(Template) - 类 com.trs.components.common.publish.domain.template.TemplateNestMgr 中的方法
返回获取嵌套了指定模板的所有模板
getTemplatesNested(Template) - 类 com.trs.service.impl.TemplateService 中的方法

getTemplatesNested(Template) - 接口 com.trs.service.ITemplateService 中的方法
获取嵌套了当前模板的所有模板
getTemplateSupportedApdExts() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the supported template appendix extends.
getTemplateSupportedExts() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the supported template extends.
getTemplateTagsHavingSrc() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the names list of those tags having src.
getTemplateTagSrcAttributeNames() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns the src attribute names of those tags having src.
getTemplateType() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
提取属性：TemplateType
getTemplateType() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
提取属性：TemplateType
getTemplateType() - 类 com.trs.template.persistent.TemplateInfoEntity 中的方法

getTempPathDeleteSchedules(WCMFilter) - 类 com.trs.components.wcm.resource.ResourceMgr 中的方法

getTestSQL() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

getTestValues() - 类 com.trs.cms.ContextHelper 中的静态方法
获得当前线程的登录用户，委托给ContextTL 处理策略：
1.
getText() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
Returns the first child if it is a string.
getText() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获得模板内容文本
getText() - 类 com.trs.infra.util.database.CDBText 中的方法
获取文本内容
getText(ResultSet, String) - 类 com.trs.infra.util.database.CSQLText 中的静态方法
从数据库中读取Text型字段的值
getText(ResultSet, int) - 类 com.trs.infra.util.database.CSQLText 中的静态方法
从数据库中读取Text型字段的值
getText() - 类 com.trs.infra.util.html.HtmlComment 中的方法
获取注释内容
getText() - 类 com.trs.infra.util.html.HtmlElement 中的方法
取元素内容中的文本部分
说明：文本部分，仅仅包括String对象；不包括HtmlComment和HtmlElement部分
getTextWithImgFilter(Template, String, boolean) - 类 com.trs.components.common.publish.domain.template.TemplateMgr 中的方法

getTextWithImgFilter(String, boolean) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
模板文本图片过滤处理，用于模板正文的显示处理
处理过程：对模板正文中的图片文件进行过滤处理，使用指定的图片src构造法则构造图片src 可以用于：
[1]模板正文显示，使用 getTextWithImgFilter( "show-pic.jsp?
getThreadSafe() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
返回相关联的ITagParser 实现是否线程安全，对于线程安全安全的实现， 可以不必为每一次解析都创建新的实例。
getTime() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取附件的时间
getTime() - 类 com.trs.infra.util.cabfile.CabEntry 中的方法

getTime() - 类 com.trs.infra.util.DebugTimer 中的方法

getTime() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the time of last modification of the entry.
getTimeBegin() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：TimeBegin
getTimeEnd() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：TimeEnd
getTimeInMillis() - 类 com.trs.infra.util.CMyDateTime 中的方法
获取时间值（毫秒数）
getTimeLimitedMode() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

getTimeRange(int) - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 中的方法

getTimeRange(int, int) - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 中的方法

getTimeRange(int) - 接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr 中的方法
获取指定频道的限定时间(单位:天)
getTimeRange(int, int) - 接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr 中的方法
获取指定对象的限定时间(单位:天)
getTimeRange() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道指定的时间范围 *
getTimeRange(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道指定的时间范围 *
getTimeToLiveOverUse() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

getTimeUsed() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：TimeUsed
getTimeWhere() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

getTimeZoneRawOffset() - 类 com.trs.infra.util.CMyDateTime 中的静态方法
取当前时区差值(单位：毫秒)
如：东8区，getTimeZoneRawOffset()=1000*60*60*8=28800000
getTitle() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
提取属性：Title
getTitle() - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

getTitle() - 类 com.trs.components.common.calendar.Event 中的方法
属性: Title 标题
getTitle() - 类 com.trs.components.common.message.Message 中的方法
属性: Title 标题
getTitle() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

getTitle() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：Title
getTitle() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：Title
getTitle() - 类 com.trs.components.common.trsvote.VoteItem 中的方法
提取属性：Title
getTitle() - 类 com.trs.components.common.trsvote.VoteOption 中的方法
提取属性：Title
getTitle() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getTitle() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
获取回复标题
getTitle() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档标题
getTitle() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
提取属性：Title
getTitle() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：Titile
getTitle() - 类 com.trs.infra.util.Reports 中的方法

getTitleColor() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取标题颜色
getTitleField() - 类 com.trs.components.metadata.definition.MetaView 中的方法
返回视图的标题字段
getTitlePattern() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getTo() - 类 com.trs.infra.util.CMySMS 中的方法
获取收信人
getTo() - 类 com.trs.infra.util.email.CMyEmail 中的方法

getToChannel() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
获取目标频道
getToChannelId() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
提取属性：ToChannelId
getToken() - 类 com.trs.components.common.publish.config.persistent.FileNamedStyle 中的方法

getTooltip() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

getTopicId() - 类 com.trs.components.comment.domain.CommentUpdator 中的方法

getTopicId() - 类 com.trs.components.comment.domain.Management 中的方法

getTopicId() - 类 com.trs.components.comment.domain.NewsComment 中的方法

getTopicId() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
提取属性：TopicId
getTopicId() - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

getTopicTitle() - 类 com.trs.components.comment.domain.Management 中的方法

getTopicTitle() - 类 com.trs.components.comment.domain.NewsComment 中的方法

getTopicTitle() - 类 com.trs.components.comment.publish.helper.CommentParserEntity 中的方法

getTopLogId() - 类 com.trs.infra.support.log.BaseDBLog 中的方法

getTopLogId() - 接口 com.trs.infra.support.log.ILog 中的方法
获取触发日志记录操作所记录的第一条日志的ID
如果当前日志是第一条记录(或独立的一条日志)则TopId为0
getToppedDocuments(Channel, WCMFilter) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
获得特定频道下已设置为置顶的所有文档
getToppedDocuments(Channel, WCMFilter) - 接口 com.trs.service.IDocumentService 中的方法
获得特定频道下已设置为置顶的所有文档
getToppedDocuments(Channel, WCMFilter) - 类 com.trs.service.impl.DocumentService 中的方法

getTopPosition(Channel, Document) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
得到频道下文档的置顶位置
getTopPosition(Document, Channel) - 接口 com.trs.service.IDocumentService 中的方法
得到当前频道下的特定文档的置顶位置
getTopPosition(Document, Channel) - 类 com.trs.service.impl.DocumentService 中的方法

getTopTime(Document, Channel) - 接口 com.trs.service.IDocumentService 中的方法
获得文档置顶的截止时间
如果文档没有置顶，则直接返回null
如果置顶文档没有设置截止时间则返回null
getTopTime(Document, Channel) - 类 com.trs.service.impl.DocumentService 中的方法

getTotalBonus(String) - 类 com.trs.components.stat.StatBonusResultForUser 中的方法
获取指定用户所获得的总奖金
getTotalCount() - 类 com.trs.components.common.publish.domain.taskdispatch.ThreadPool 中的方法

getTotalCount() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法

getTotalIn() - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Gets the number of input bytes processed so far.
getTotalIn() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Gets the total number of processed compressed input bytes.
getTotalOut() - 类 com.trs.infra.util.jazzlib.Deflater 中的方法
Gets the number of output bytes so far.
getTotalOut() - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Gets the total number of output bytes returned by inflate().
getToTransPaths() - 类 com.trs.tools.Localizer 中的方法

getToTransPaths() - 类 com.trs.tools.Localizer2 中的方法

getToTransPaths() - 类 com.trs.tools.LocalServerAuto 中的方法

getToUser() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取接收者
getToUserId() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取所在的节点ID
getToUserIds() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取所有呈送人员ID字符串（不同ID之间移字符','分割）
getToUserNames() - 类 com.trs.cms.process.engine.FlowDoc 中的方法

getToUsers(FlowContext) - 类 com.trs.cms.process.config.ToUsersCreatorConfig 中的方法
根据当前的配置获取处理者
getToUsers() - 类 com.trs.cms.process.engine.FlowContext 中的方法

getToUsers(User) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取所有呈送人员集合
getToUsers() - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法

getToUsers() - 类 com.trs.cms.process.engine.FlowParamers 中的方法

getToUsersCreatorConfigByName(String) - 类 com.trs.cms.process.config.FlowConfigServer 中的方法

getToUsersCreatorConfigByName(String, String) - 类 com.trs.cms.process.config.FlowConfigServer 中的方法

getToUsersCreatorConfigs() - 类 com.trs.cms.process.config.FlowConfigServer 中的方法

getToUserTrueNames() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
添加了返回toUser的真实姓名的方法
getTransform() - 类 com.trs.components.infoview.extract.manifest.View 中的方法

getTransmitFunc(Document, Channel) - 类 com.trs.components.wcm.wcmx.jsp.DocOperDefine 中的静态方法
获取转发文档的Javascript
getTransmitType() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法

getTraverseNodes(SceneNode) - 类 com.trs.scene.tools.SceneNodeAction 中的方法
获取所有的叶子节点，叶子节点按从左到右的顺序加入到ArrayList中 算法：后续遍历，只保存叶子节点
getTreeInfo() - 类 com.trs.presentation.nav.RadarTreeCreator 中的方法

getTreeInfo(String, int, int, boolean) - 类 com.trs.service.impl.NetSnapTool 中的静态方法

getTreeInfo2(String, int, int, boolean) - 类 com.trs.service.impl.NetSnapTool 中的静态方法

getTRSDocDBName() - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的静态方法
获取WCM数据库中WCMDocument与TRS库中的表映射名
getTRSDocIdDBName() - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的静态方法
获取WCM数据库WCMDocument表DocId字段与TRS库中的表映射名
getTRSFields() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getTRSFrom() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getTRSOrder() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getTRSSearcher(RequestHelper, User) - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的静态方法
从当前请求中获取TRS检索对象
getTRSSelect() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getTRSTypeName() - 类 com.trs.components.infoview.extract.DataType 中的方法

getTRSWhere(HttpServletRequest) - 类 com.trs.components.wcm.content.trsserver.DocsFromTRSServer 中的静态方法

getTRSWhere() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getTrueFieldName() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

getTrueName() - 类 com.trs.cms.auth.persistent.User 中的方法
获取真实姓名
getTrueName() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getTrueName() - 类 com.trs.webframework.config.MethodConfig 中的方法

getTrueTableName() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getTrueTableName() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法

getTrueTableName() - 类 com.trs.components.metadata.definition.MetaView 中的方法

getTrustee() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法

getTrusteeId() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
提取属性：Trustee
getType() - 类 com.trs.cms.auth.config.OperationConfig 中的方法

getType() - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法

getType() - 类 com.trs.cms.content.ExtendedField 中的方法
获取扩展字段类型对象
getType() - 接口 com.trs.cms.content.ICMSObjSubstanceContent 中的方法
Returns the publish content type.
getType() - 类 com.trs.cms.process.config.ParamConfig 中的方法

getType() - 类 com.trs.cms.process.definition.FlowRule 中的方法
提取属性：Type
getType() - 类 com.trs.components.common.calendar.Event 中的方法

getType() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
提取属性：Type
getType() - 类 com.trs.components.common.publish.config.PublishElementType 中的方法

getType() - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法

getType() - 类 com.trs.components.common.publish.domain.distribute.FileDistributeQueue.Item 中的方法
返回分发类型
getType() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
返回属性类型
getType() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo 中的方法
返回置标的类型
getType() - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

getType() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

getType() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
获得模板的类型
getType() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

getType() - 类 com.trs.components.infoview.extract.manifest.FileProperty 中的方法

getType() - 类 com.trs.components.infoview.RightHostInfoViewField 中的方法

getType() - 类 com.trs.components.infoview.RightHostInfoViewGroup 中的方法

getType() - 类 com.trs.components.infoview.RightHostInfoViewView 中的方法

getType() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：Type
getType() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：Type
getType() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

getType() - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

getType() - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

getType() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

getType() - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 中的方法

getType() - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 中的方法

getType() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
获取频道类型(Channel.TYPE_NORM等)
getType() - 类 com.trs.components.wcm.content.persistent.ChannelSubstanceImplBase 中的方法

getType() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
获取扩展字段类型对象
getType() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法

getType() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档类型
getType() - 类 com.trs.components.wcm.content.persistent.DocumentFieldConfig 中的方法

getType() - 类 com.trs.components.wcm.content.persistent.DocumentSubstanceImplBase 中的方法

getType() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

getType() - 类 com.trs.components.wcm.content.persistent.WebSiteSubstanceImplBase 中的方法

getType() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取文档类型
getType() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

getType() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

getType() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

getType() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

getType() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

getType() - 类 com.trs.components.wcm.resource.Source 中的方法
获取来源类型
getType() - 类 com.trs.db.update.DBUpdateLog 中的方法
提取属性：Type
getType() - 类 com.trs.infra.support.config.Config 中的方法
获取配置类别
getType() - 类 com.trs.infra.util.database.DataType 中的方法
获取类型，由java.sql.Types.INTEGER等定义
getType() - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

getType() - 类 com.trs.infra.util.database.DB2UDB 中的方法

getType() - 类 com.trs.infra.util.database.DB2UDB2 中的方法

getType() - 类 com.trs.infra.util.database.DBType 中的方法
获取当前的类型
getType() - 类 com.trs.infra.util.database.MysqlDB 中的方法

getType() - 类 com.trs.infra.util.database.OracleDB 中的方法

getType() - 类 com.trs.infra.util.database.SQLServerDB 中的方法

getType() - 类 com.trs.infra.util.database.SybaseASE 中的方法

getType() - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法

getType() - 类 com.trs.infra.util.Report 中的方法
获取Report类型（定义在Report.TYPE_INFO...）
getType() - 类 com.trs.presentation.util.PageParameter 中的方法
获取当前的参数类型
getType() - 类 com.trs.scene.tools.SceneNode 中的方法

getType() - 类 com.trs.wcag2.validator.BiTagValidator 中的方法

getType() - 类 com.trs.wcag2.validator.DocTypeValidator 中的方法

getType() - 类 com.trs.wcag2.validator.EmbedAltValidator 中的方法

getType() - 类 com.trs.wcag2.validator.EventsValidator 中的方法

getType() - 类 com.trs.wcag2.validator.FormElementsValidator 中的方法

getType() - 类 com.trs.wcag2.validator.FormSubmitValidator 中的方法

getType() - 类 com.trs.wcag2.validator.FrameTitleValidator 中的方法

getType() - 类 com.trs.wcag2.validator.HtmlCharsetValidator 中的方法

getType() - 类 com.trs.wcag2.validator.HtmlH1_H6Validator 中的方法

getType() - 类 com.trs.wcag2.validator.HtmlH1Validator 中的方法

getType() - 类 com.trs.wcag2.validator.HtmlLangValidator 中的方法

getType() - 类 com.trs.wcag2.validator.HtmlTitleValidator 中的方法

getType() - 类 com.trs.wcag2.validator.ImgAltValidator 中的方法

getType() - 接口 com.trs.wcag2.validator.IValidator 中的方法

getType() - 类 com.trs.wcag2.validator.ObjectBodyValidator 中的方法

getType() - 类 com.trs.wcm.config.PageOperator 中的方法
提取属性：Type
getType() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
提取属性：Type
getType() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
获取当前的参数类型
getTypeAsString(int) - 类 com.trs.webframework.xmlserver.server.InvocationTypes 中的静态方法

getTypeCrTime() - 类 com.trs.components.common.trsad.ADType 中的方法
提取属性：CrTime
getTypeCrUser() - 类 com.trs.components.common.trsad.ADType 中的方法
提取属性：CrUser
getTypedEntryConfig(int) - 类 com.trs.components.common.conjection.service.ComponentEntryConfigServiceImpl 中的方法

getTypedEntryConfig(int) - 接口 com.trs.components.common.conjection.service.IComponentEntryConfigService 中的方法

getTypeDesc() - 类 com.trs.cms.content.ExtendedField 中的方法

getTypeDesc() - 类 com.trs.components.common.trsad.ADType 中的方法
提取属性：TypeDesc
getTypeDesc() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：TypeDesc
getTypeDesc() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：TypeDesc
getTypeDesc() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

getTypeDesc() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
获取类型的描述
getTypeDesc() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
提取属性：TYPEDESC
getTypeDesc() - 类 com.trs.db.update.DBUpdateLog 中的方法

getTypeId() - 类 com.trs.components.common.calendar.Event 中的方法
属性: Type 类型
getTypeId() - 类 com.trs.infra.support.config.SystemCollocationConfig 中的方法

getTypeIds() - 类 com.trs.infra.support.config.ConfigServer 中的方法

getTypeName() - 类 com.trs.cms.content.ExtendedField 中的方法
获取扩展字段类型名称
getTypeName() - 类 com.trs.components.infoview.extract.DataType 中的方法

getTypeName() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
获取扩展字段类型名称
getTypeName() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
提取属性：TYPENAME
getTypeName() - 类 com.trs.infra.support.config.Config 中的方法

getTypeName(int) - 类 com.trs.infra.support.config.ConfigServer 中的方法

getTypeName(int, int, int, int) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法

getTypeName(int, int, int, int) - 类 com.trs.infra.util.database.DB2UDB2 中的方法

getTypeName(int) - 类 com.trs.infra.util.database.DBType 中的方法
Get the name of the database type associated with the given Types typecode.
getTypeName(int, int, int, int) - 类 com.trs.infra.util.database.DBType 中的方法
Get the name of the database type associated with the given Types typecode with the given storage specification parameters.
getTypeName() - 类 com.trs.infra.util.upgrade.dbcompare.TypeInfo 中的方法

getTypeNames() - 类 com.trs.infra.support.config.ConfigServer 中的方法

getTypeQuotedImageLib(Appendix) - 类 com.trs.wcm.photo.ImageLibHelper 中的静态方法

getTypeString(int) - 类 com.trs.components.wcm.content.persistent.Document 中的静态方法
静态函数：取文档类型名称
getTypeString() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档类型描述
getTypeString() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
获取文档类型描述
getUnfinishedTasks() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishTaskMgr 中的方法
get the tasks collection who have not been finished.
getUnfinishedTasks() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskMgrImpl 中的方法

getUnImportCount() - 类 com.trs.wcm.old.ImportDocsContext 中的方法

getUnit() - 类 com.trs.cms.process.config.ParamConfig 中的方法

getUnitValue() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
提取属性：UnitValue
getUnpubSchedule(MethodContext) - 类 com.trs.ajaxservice.PublishServiceProvider 中的方法

getUnreadMessages(User, WCMFilter) - 类 com.trs.components.common.message.MessageServer 中的静态方法
获得用户所有未读的消息
未读的定义即_currMsgUser为接收者，且消息的已读属性为false
getUnZipPath() - 类 com.trs.infra.util.CMyUnZipFile 中的方法
返回解压路径
getUpdateSql(int, String, boolean, boolean, boolean, CMyDateTime) - 类 com.trs.db.update.DBUpdateLogMgr 中的方法
获得完整的数据库更新脚本
getUpdcols() - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
获取更新的列
getUpperFolder() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Returns the nearest upper folder in current context link.
getUpperHost() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法
Returns the upper host object.
getUri() - 类 com.trs.webframework.config.MethodConfig 中的方法

getUrl() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
提取属性：Url
getUrl() - 类 com.trs.components.infoview.config.GatewayPage 中的方法

getUrl() - 类 com.trs.components.stat.HostObjDomain 中的方法
提取属性：Url
getURL() - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 中的方法

getURL() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法

getURL(String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
获取URL对象
getUrl() - 类 com.trs.webframework.config.MethodConfig 中的方法

getURLContent(String) - 类 com.trs.infra.util.CMy3WLib 中的静态方法
获取指定URL的源文件，并保存到本地目标文件 说明：若不指定目标文件，则抛弃获取结果
getURLs() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：URL
getUrn() - 类 com.trs.infra.util.soap.CMySoapClient 中的方法

getUsedVersions() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
获取使用该附件的文档的版本号列表
getUser() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
属性：UserId，只读，用户ID号
getUser() - 类 com.trs.service.InfoViewContext 中的方法

getUserAddress() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getUserCacheMgr() - 类 com.trs.cms.auth.persistent.User 中的静态方法

getUserEmail() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getUserFromSSOUser(SSOUser) - 类 com.trs.presentation.ids.ActorHelper 中的静态方法
从IDS的用户中获取当前应用的用户
getUserGroupId() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：UserGroupId
getUserId() - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
提取属性：UserId
getUserId() - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
提取属性：UserId
getUserID() - 类 com.trs.components.comment.domain.Management 中的方法
返回WCM中的用户ID和用户名
getUserId() - 类 com.trs.components.stat.UserLoginInfo 中的方法
提取属性：UserId，用户ID
getUserId() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
提取属性：UserId
getUserID() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
提取属性：UserID
getUserIdcardNum() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getUserIdcode() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getUserMgr() - 类 com.trs.presentation.ids.ActorHelper 中的静态方法
获取UserMgr
getUserMobile() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getUserName() - 类 com.trs.components.comment.domain.Management 中的方法
返回WCM中的和用户名
getUserName() - 类 com.trs.components.common.address.Contact 中的方法
属性: UserName 姓名
getUserName() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
获得日志用户名
getUserName() - 接口 com.trs.infra.support.log.ILog 中的方法
获得日志用户名
getUserName() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

getUserName() - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

getUserName() - 类 com.trs.infra.util.soap.CMySoapClient 中的方法

getUserName() - 类 com.trs.infra.util.uftp.FtpConfig 中的方法
返回登陆FTP服务器的用户名
getUserNameById(String) - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态方法

getUserNames() - 类 com.trs.components.common.message.notify.NotificationConfig 中的方法

getUserNames() - 类 com.trs.components.stat.StatBonusResultForUser 中的方法

getUserPhone() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getUserRightsOnWCMObj(int) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
获取当前用户在指定类型的对象上的权限集合
getUsers(Group, WCMFilter) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
获取属于某组织的所有用户集合
getUsers(Group, WCMFilter, boolean) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
获取指定组织所有的用户(用户组织关联对象),包含所有的子组织的用户
getUsers(Role, int, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取某角色在某站点下的所有用户集合
getUsers(Role, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取担任某角色的所有用户集合
getUsers(User) - 类 com.trs.cms.auth.persistent.Group 中的方法
取组内所有用户集合（Users）
getUsers(User, String) - 类 com.trs.cms.auth.persistent.Group 中的方法
获取按照一定排序方式取组内所有用户集合（Users）
getUsers(User) - 类 com.trs.cms.auth.persistent.Role 中的方法
取属于该角色的所有用户
getUsers(Event) - 类 com.trs.components.common.calendar.EventMgr 中的方法
获取共享指定日程安排的所有用户
getUsers(Group, WCMFilter) - 接口 com.trs.service.IGroupService 中的方法
获取指定组中的所有用户
getUsers(Group, WCMFilter, boolean) - 接口 com.trs.service.IGroupService 中的方法

getUsers(Group, WCMFilter) - 类 com.trs.service.impl.GroupService 中的方法

getUsers(Group, WCMFilter, boolean) - 类 com.trs.service.impl.GroupService 中的方法

getUsers(Role, WCMFilter) - 类 com.trs.service.impl.RoleService 中的方法

getUsers(int, WCMFilter) - 类 com.trs.service.impl.UserService 中的方法

getUsers(Role, WCMFilter) - 接口 com.trs.service.IRoleService 中的方法
获取指定角色的所有用户
getUsers(int, WCMFilter) - 接口 com.trs.service.IUserService 中的方法
获取系统中的某个注册状态的所有用户
getUsersByMediaReminded(int) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
根据媒体ID获取设置了提醒的用户集合
getUsersByNames(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法

getUsersBySpecailForUser(Role, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取当前登录用户可以查看的某特定角色的所有用户集合
getUsersBySystemRoleForUser(Role, int, WCMFilter) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
获取当前登录用户可以查看的某系统级角色的所有用户集合
getUsersForGrpAdmin(User) - 接口 com.trs.components.stat.IUserLoginInfoMgr 中的方法
获取组管理员所在组的所有用户的条件构造
getUsersForGrpAdmin(User) - 类 com.trs.components.stat.UserLoginInfoMgr 中的方法
获取组管理员所管理组的所有用户，返回所有用戶的userId
getUserSites(User, WCMFilter) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
获取当前用户所在站点集合
getUserSites(User, WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取指定用户所属的站点集合
getUserSites(User, WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法

getUsersOfGroup(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法
获取指定组织下的用户集合,适用于角色的添加用户页面
getUsersOfRole(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法
获取指定角色和站点下的用户集合,兼容系统级角色和非系统级角色
getUsersOfSpecialRole(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法
获取指定特定角色下的用户集合
getUsersOfSystemRoleOnSite(MethodContext) - 类 com.trs.ajaxservice.UserServiceProvider 中的方法
获取指定系统级角色和站点下的用户集合
getUsersPassed() - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法

getUsersWithRight(User, int, int, boolean) - 类 com.trs.cms.auth.persistent.Right 中的静态方法
获取在指定对象上设置了权限（/没有设置权限）的集合用户
getUserTitle() - 类 com.trs.presentation.ids.CAUserSync.UserInfo 中的方法

getUTF8Bytes(String) - 类 com.trs.infra.util.CMyString 中的静态方法
提取字符串UTF8编码的字节流 说明：等价于 _string.getBytes("UTF8")
getUTF8String(byte[]) - 类 com.trs.infra.util.CMyString 中的静态方法

getUTF8String(byte[], int, int) - 类 com.trs.infra.util.CMyString 中的静态方法
从指定的字节数组中提取UTF8编码的字符串 说明：函数等价于 new String(b,"UTF8")
getValidator() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：Validator
getValidator() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：Validator
getValidator() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：Validator
getValidConnection(String, String, String, String) - 类 com.trs.components.wcm.content.trsserver.DatasFromTRSServer 中的方法

getValidFileExts() - 类 com.trs.components.wcm.soap.WordFileService 中的静态方法
返回允许导入的文件后缀名
getValidNum() - 类 com.trs.components.wcm.content.trsserver.ClassInfo 中的方法
获取可读取的记录数
getValidSignResult() - 类 com.trs.infra.support.log.Log 中的方法
获取校验日志签名的结果
getValidTime() - 类 com.trs.components.common.message.Message 中的方法
property: ValidTime 有效期
getValidTime() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档的有效时间
getValidVerifycodeUrl() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getValue() - 类 com.trs.cms.auth.persistent.Right 中的方法
获得权限值对象
getValue() - 类 com.trs.cms.process.config.OperatorConfig 中的方法

getValue() - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Token 中的方法
返回可用值的值
getValue() - 类 com.trs.components.infoview.extract.manifest.FileProperty 中的方法

getValue() - 类 com.trs.components.wcm.content.trsserver.ClassInfo 中的方法
获取当前分类字段对应的Value
getValue() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
获取定制的值
getValue() - 类 com.trs.components.wcm.resource.Security 中的方法
获取安全级别的值
getValue() - 类 com.trs.infra.persistent.CMyParameter 中的方法

getValue() - 类 com.trs.infra.support.config.Config 中的方法
获取配置值
getValue() - 类 com.trs.infra.util.CMyBitsValue 中的方法
取二进制序列对应的长整型值
getValue() - 类 com.trs.infra.util.html.HtmlAttribute 中的方法
获取属性值
getValue() - 类 com.trs.infra.util.jazzlib.Adler32 中的方法
Returns the Adler32 data checksum computed so far.
getValue() - 接口 com.trs.infra.util.jazzlib.Checksum 中的方法
Returns the data checksum computed so far.
getValue() - 类 com.trs.infra.util.jazzlib.CRC32 中的方法
Returns the CRC32 data checksum computed so far.
getValue(String) - 类 com.trs.webframework.context.MethodContext 中的方法

getValue(String, boolean) - 类 com.trs.webframework.context.MethodContext 中的方法

getValue(String, int) - 类 com.trs.webframework.context.MethodContext 中的方法

getValue(String, long) - 类 com.trs.webframework.context.MethodContext 中的方法

getValue(String, double) - 类 com.trs.webframework.context.MethodContext 中的方法

getValue(String, float) - 类 com.trs.webframework.context.MethodContext 中的方法

getValue(String, CMyDateTime) - 类 com.trs.webframework.context.MethodContext 中的方法

getValue(String) - 类 com.trs.webframework.xmlserver.parser.XMLParsingInfoHolder 中的方法

getValueAsInt() - 类 com.trs.cms.auth.persistent.Right 中的方法
获得整型的权限值
getValueAsInt() - 类 com.trs.infra.util.CMyBitsValue 中的方法
取二进制序列对应的int值
getValueAsLong() - 类 com.trs.cms.auth.persistent.Right 中的方法
获取长整型的权限值
getValueConfigs() - 类 com.trs.cms.process.config.ParamConfig 中的方法

getValueFromLabel(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
由枚举值的label获得枚举值的value
getValues() - 类 com.trs.webframework.context.MethodContext 中的方法

getValuesFromLabel(String) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
由枚举值的label获得枚举值的value
getValueSplitBy() - 类 com.trs.components.infoview.config.EnumCreator 中的方法

getVariable() - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo 中的方法
返回设置属性值是不是可变的
getVariableAttribute(String) - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
返回指定变量的赋值
getVariableParameter(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
返回指定名称的可变模板参数对象
getVariableParameters() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
以java.util.HashMap的形式返回所有的可变模板参数
getVarValues() - 类 com.trs.cms.process.engine.handlers.MsgSendHandler 中的方法

getVarValues() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormReplyHandler 中的方法

getVarValues() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ApplyFormTypeHandler 中的方法

getVarValues() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyAppendixNotifyHandler 中的方法

getVarValues() - 类 com.trs.components.gkml.sqgk.process.engine.handlers.ReplyNotifyHandler 中的方法

getVerify() - 类 com.trs.components.comment.domain.SignUtil 中的静态方法
此处插入方法说明。
getVerify(String) - 类 com.trs.infra.util.CMySign 中的静态方法
此处插入方法说明。
getVerifyCodeURL() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

getVersion() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取文档的版本号
getVersion() - 类 com.trs.infra.BaseServer 中的方法

getVersion() - 类 com.trs.infra.config.persistent.PluginConfig 中的方法

getVersion() - 接口 com.trs.infra.IServer 中的方法
当前系统版本号
getVersion() - 类 com.trs.presentation.login.SessionListener 中的静态方法

getView() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

getViewApplicationPath(int) - 类 com.trs.components.metadata.definition.MetaDataDefHelper 中的静态方法

getViewApplicationRootPath() - 类 com.trs.components.metadata.definition.MetaDataDefHelper 中的静态方法

getViewAttribute() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewAttribute
getViewConfigValue(String) - 类 com.trs.presentation.common.PageViewConstants 中的静态方法

getViewDesc() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewDesc
getViewer(User) - 类 com.trs.components.common.bookmark.MarkShare 中的方法
取得Viewer对象(User,Group,Role,Contact,ContactGrp)
getViewerId() - 类 com.trs.components.common.bookmark.MarkShare 中的方法
属性: ViewerId 浏览者ID
getViewerType() - 类 com.trs.components.common.bookmark.MarkShare 中的方法
属性: ViewerType 浏览者类型
getViewField() - 类 com.trs.components.metadata.web.AbsHTMLMaker 中的方法

getViewField() - 接口 com.trs.components.metadata.web.HTMLMaker 中的方法
获取当前HTMLMaker关联的MetaViewField对象
getViewFields(User, MetaView, WCMFilter) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法

getViewFields(User, MetaView, WCMFilter) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法

getViewFields(User, WCMFilter) - 类 com.trs.components.metadata.definition.MetaView 中的方法

getViewFields(int) - 类 com.trs.components.wcm.stat.StatMgr 中的方法
得到一个统计视图模板中的字段映射表（字段列表）
从统计映射表中获取，而不是从Select中自动识别
getViewFrom() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewFrom
getViewFromChannel(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法

getViewGroupBy() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewGroupBy
getViewID() - 类 com.trs.components.infoview.extract.DataGroup 中的方法

getViewID() - 类 com.trs.components.infoview.extract.manifest.View 中的方法

getViewID() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

getViewID() - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
提取属性：ViewID
getViewId() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：OwnerView
getViewInterval() - 类 com.trs.cms.auth.persistent.User 中的方法
获取ViewInterval:视图刷新时间（秒）
getViewList() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法

getViewMaps() - 类 com.trs.components.infoview.extract.InfoPathFileData 中的方法

getViewName() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewName
getViewOfEmployer(Channel) - 接口 com.trs.components.metadata.center.IMetaViewEmployerMgr 中的方法
获取指定栏目配置的视图
getViewOfEmployer(Channel) - 类 com.trs.components.metadata.center.MetaViewEmployerMgr 中的方法

getViewOrderBy() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewOrderBy
getViewsContainsTable(MetaDBTable) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
获取使用指定表作为附表的视图
getViewsContainsTable(MetaDBTable) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法

getViewSelect() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewSelect
getViewsUsingField(User, MetaDBField) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
获取使用了物理字段_oDBFieldInfo的所有视图
getViewsUsingField(User, MetaDBField) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法

getViewsUsingTable(MetaDBTable) - 接口 com.trs.components.metadata.definition.IMetaDataDefMgr 中的方法
获取正在使用指定表的视图
getViewsUsingTable(MetaDBTable) - 类 com.trs.components.metadata.definition.MetaDataDefMgr 中的方法

getViewThumb() - 类 com.trs.components.special.Special 中的方法
提取属性：ViewThumb
getViewType() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewType
getViewWhere() - 类 com.trs.components.wcm.stat.StatView 中的方法
提取属性：ViewWhere
getViewWidth() - 类 com.trs.components.infoview.extract.manifest.View 中的方法

getViewWidth() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回视图的宽度（HTML页面中有效区域的宽度）
getVote(User) - 类 com.trs.components.common.trsvote.VoteItem 中的方法
取得所属调查
getVoteDatas(User) - 类 com.trs.components.common.trsvote.VoteOption 中的方法
取得调查选项的投票结果
getVoteId() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：VoteId
getVoteId() - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
提取属性：VoteId
getVoteId() - 类 com.trs.components.common.trsvote.VoteItem 中的方法
提取属性：VoteId
getVoteItem(User) - 类 com.trs.components.common.trsvote.VoteOption 中的方法
取得调查选项所属的调查事项
getVoteItems(User) - 类 com.trs.components.common.trsvote.Vote 中的方法
取得调查事项
getVoteOption(User) - 类 com.trs.components.common.trsvote.VoteData 中的方法
取得调查数据所属的调查选项
getVoteOptions(User) - 类 com.trs.components.common.trsvote.VoteItem 中的方法
取得调查选项
getWaitingPageTaskCount() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法

getWantingWorker() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskRuntime 中的方法
返回欠缺的工作线程数，即还需要补充的工作线程数
getWarnedReporter() - 类 com.trs.infra.util.Reports 中的方法
获取所有警告报告
getWarnedReporterAt(int) - 类 com.trs.infra.util.Reports 中的方法
获取一个警告报告
getWarning() - 类 com.trs.wcag2.Alertion 中的方法

getWarning(Object) - 类 com.trs.wcag2.validator.AbstractValidator 中的方法

getWarning(Object) - 类 com.trs.wcag2.validator.EventsValidator 中的方法

getWarning(Object) - 类 com.trs.wcag2.validator.HtmlH1Validator 中的方法

getWarning(Object) - 类 com.trs.wcag2.validator.ImgAltValidator 中的方法

getWarning(Object) - 接口 com.trs.wcag2.validator.IValidator 中的方法

getWarnings() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
Returns the warnings as string; returns null if no warnings.
getWarnObj() - 类 com.trs.wcag2.validator.AbstractValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.BiTagValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.DocTypeValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.EmbedAltValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.EventsValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.FormElementsValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.FormSubmitValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.FrameTitleValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.HtmlCharsetValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.HtmlH1_H6Validator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.HtmlH1Validator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.HtmlLangValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.HtmlTitleValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.ImgAltValidator 中的方法

getWarnObj() - 类 com.trs.wcag2.validator.ObjectBodyValidator 中的方法

getWaterMarkSize(int) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
获取指定图片宽度设置的水印大小
getWaterMarkSize(int) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

getWcmdataTemplatePath() - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态方法
获取WCMDATA中的template所在的目录，风格的一些资源图片以及样式存放在此
getWCMDocId() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：WCMDocId
getWCMField(String) - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getWCMFields() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getWCMFiles() - 类 com.trs.cms.content.HTMLContent 中的方法
获取HTML内容中的WCM文件
getWCMForm() - 类 com.trs.wcm.old.WCMFormFields 中的方法
获取所属WCMForm对象
getWCMObj() - 类 com.trs.cms.content.WCMHandler 中的方法

getWCMObj() - 类 com.trs.infra.persistent.BaseObjHandler 中的方法

getWCMObj(String) - 类 com.trs.presentation.util.AppAutoParameter 中的静态方法

getWCMObjList() - 类 com.trs.cms.content.WCMObjsHandler 中的方法

getWCMObjList() - 类 com.trs.infra.persistent.BaseObjsHandler 中的方法

getWcmOutlineContentsMaxNum() - 类 com.trs.components.common.publish.config.persistent.TemplateParseConfig 中的方法

getWCMSelect() - 类 com.trs.components.wcm.content.trsserver.TRSToWCMFilter 中的方法

getWcmServerDir() - 类 com.trs.components.common.publish.widget.StylePathHelper 中的静态方法
获取WCM应用所在的路径，通过WCM_PATH获取
getWCMTableId() - 类 com.trs.components.wcm.stat.StatHost 中的方法
提取属性：WCMTableId
getWCMTableName() - 类 com.trs.components.wcm.stat.StatHost 中的方法
提取属性：WCMTableName
getWCMType() - 类 com.trs.ajaxservice.ContentExtendValue 中的方法

getWCMType() - 类 com.trs.cms.auth.persistent.Group 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.auth.persistent.Right 中的方法
取得该对象的类型编号（定义在WCMTypes中）
getWCMType() - 类 com.trs.cms.auth.persistent.RightDef 中的方法
取得该对象的类型编号（定义在WCMTypes中）
getWCMType() - 类 com.trs.cms.auth.persistent.Role 中的方法
取得该对象的类型编号（定义在WCMTypes中）
getWCMType() - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
取得该对象的类型编号（定义在WCMTypes中）
getWCMType() - 类 com.trs.cms.auth.persistent.User 中的方法
取得该对象的类型编号（定义在WCMTypes中）
getWCMType() - 类 com.trs.cms.content.CMSObjDefaultImpl 中的方法

getWCMType() - 类 com.trs.cms.content.DefaultObj 中的方法

getWCMType() - 类 com.trs.cms.content.ExtendedField 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.cms.content.WCMSystemObject 中的方法

getWCMType() - 类 com.trs.cms.process.definition.Flow 中的方法

getWCMType() - 类 com.trs.cms.process.definition.FlowAction 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.process.definition.FlowNode 中的方法

getWCMType() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法

getWCMType() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.process.definition.FlowRule 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.cms.process.engine.FlowDoc 中的方法

getWCMType() - 类 com.trs.cms.process.engine.FlowDocBak 中的方法

getWCMType() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.address.Contact 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.address.ContactGrp 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.bookmark.BookMark 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.bookmark.MarkShare 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.calendar.Event 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.calendar.EventShare 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.calendar.EventType 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.job.JobWorkerType 中的方法

getWCMType() - 类 com.trs.components.common.job.Schedule 中的方法

getWCMType() - 类 com.trs.components.common.message.Message 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.message.MsgQueue 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.message.MsgReceiver 中的方法

getWCMType() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
获得TRS置标解析组件的对象类型（WCMTypes.OBJ_TAGBEAN）
getWCMType() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
获得模板附件对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法

getWCMType() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.Layout 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.Master 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.Widget 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsad.ADCom 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsad.ADFile 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsad.ADPos 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsad.ADType 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsvote.Vote 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsvote.VoteData 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsvote.VoteItem 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.common.trsvote.VoteOption 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getWCMType() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法

getWCMType() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法

getWCMType() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

getWCMType() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

getWCMType() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法

getWCMType() - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

getWCMType() - 类 com.trs.components.metadata.center.MetaViewEmployer 中的方法

getWCMType() - 类 com.trs.components.metadata.center.MetaViewEmployers 中的方法

getWCMType() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.metadata.definition.MetaView 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.special.Special 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.stat.BonusRule 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.stat.ChnlDept 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.stat.HostObjDomain 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.stat.UserLoginInfo 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.Document 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.content.persistent.Relation 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

getWCMType() - 类 com.trs.components.wcm.content.persistent.XDocument 中的方法

getWCMType() - 类 com.trs.components.wcm.content.ViewDocument 中的方法

getWCMType() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
取得该对象的类型（定义在WCMTypes中）
getWCMType() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法

getWCMType() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.recent.Recent 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.resource.DocKind 中的方法

getWCMType() - 类 com.trs.components.wcm.resource.FileType 中的方法

getWCMType() - 类 com.trs.components.wcm.resource.Keyword 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.resource.Security 中的方法

getWCMType() - 类 com.trs.components.wcm.resource.Source 中的方法

getWCMType() - 类 com.trs.components.wcm.resource.Status 中的方法

getWCMType() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.stat.StatHost 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.stat.StatView 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.db.update.DBUpdateLog 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.infra.persistent.BaseObj 中的方法
取得该对象的类型（定义在WCMTypes中） 二次开发中定义在wcmx.common.WCMTypesX中
getWCMType() - 类 com.trs.infra.persistent.CMyResultSet 中的方法

getWCMType() - 类 com.trs.infra.persistent.MyBaseObj 中的方法

getWCMType() - 类 com.trs.infra.support.config.Config 中的方法
取得该对象的类型编号（定义在WCMTypes中）
getWCMType() - 类 com.trs.infra.support.log.Log 中的方法
取得该对象的类型编号（定义在WCMTypes中）
getWCMType() - 类 com.trs.infra.support.log.LogBak 中的方法

getWCMType() - 类 com.trs.infra.support.log.OperType 中的方法

getWCMType() - 类 com.trs.infra.support.security.SecureKey 中的方法

getWCMType() - 类 com.trs.infra.util.job.JobFailedResult 中的方法

getWCMType() - 类 com.trs.wcm.config.PageOperator 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.wcm.old.WCMExcelData 中的方法

getWCMType() - 类 com.trs.wcm.old.WCMFormFields 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
取得该对象的类型编号
getWCMType() - 类 com.trs.wcm.photo.Watermark 中的方法
取得该对象的类型编号
getWDefaultStyle() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：WDefaultStyle
getWdesc() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：Wdesc
getWebHttp() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
获取Web站点Http地址
getWebObj() - 类 com.trs.components.common.trsad.ADPos 中的方法
得到站点或频道对象
getWebSiteId() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
提取属性：ChannelId
getWebSites(WCMFilter, boolean) - 类 com.trs.components.wcm.content.domain.ChannelMgr 中的方法
获取系统中的所有站点
getWebSites(int, int, String) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
获取某个对象（用户、组织、角色）可以管理的站点
getWebSites(WCMFilter) - 类 com.trs.components.wcm.recent.RecentMgr 中的方法
获得用户最近访问的模板列表，按访问时间逆序排列
getWebSites(int) - 类 com.trs.presentation.nav.TreeCreator 中的方法

getWebSites(WCMFilter) - 接口 com.trs.service.IChannelService 中的方法
获取当前用户可以看见的站点
getWebSites() - 接口 com.trs.service.ICustomizeService 中的方法
获取个人定制的站点集合
getWebSites(WCMFilter) - 类 com.trs.service.impl.ChannelService 中的方法
获取当前用户可以看见的站点
getWebSites() - 类 com.trs.service.impl.CustomizeService 中的方法

getWebSites(WCMFilter) - 类 com.trs.service.impl.RecentService 中的方法

getWebSites(WCMFilter) - 接口 com.trs.service.IRecentService 中的方法
返回用户最近访问的站点列表
按照访问的时间顺序排序
getWebSitesByRightIndex(User, int, WCMFilter, Hashtable, boolean) - 类 com.trs.ajaxservice.WebSiteHelper 中的静态方法
获取某个用户能操作的站点集合
getWebSitesByType(User, int, WCMFilter) - 类 com.trs.ajaxservice.WebSiteHelper 中的静态方法

getWebSitesByTypeWithIndividual(User, int, WCMFilter, Hashtable, boolean) - 类 com.trs.ajaxservice.WebSiteHelper 中的静态方法

getWeekCountsOfMonth(boolean) - 类 com.trs.infra.util.CMyDateTime 中的方法

getWhere() - 类 com.trs.components.wcm.content.trsserver.TRSSearcher 中的方法

getWhere() - 类 com.trs.infra.db.QueryFilter 中的方法
获取查询条件
getWhere() - 类 com.trs.infra.persistent.WCMFilter 中的方法
获取查询条件
getWhereSql() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
提取属性：WhereSql
getWhereSQL() - 类 com.trs.presentation.util.DefaultWhereSQLMaker 中的方法

getWhereSQL() - 类 com.trs.presentation.util.RequestHelper 中的方法
获取当前条件下的检索语句
getWhereSQL() - 类 com.trs.presentation.util.WhereSQLMaker 中的方法

getWidget() - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法

getWidgetAttrURL() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：WidgetAttrURL
getWidgetcontent() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：Widgetcontent
getWidgetId() - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
提取属性：WidgetId
getWidgetId() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：WidgetId
getWidgetInstId() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
提取属性：WidgetInstId
getWidgetInstParameter(WidgetInstance, String) - 接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr 中的方法
获取指定资源块实例下的资源块实例变量
getWidgetInstParameter(WidgetInstance, String) - 类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 中的方法

getWidgetInstParameters(WidgetInstance, WCMFilter) - 接口 com.trs.components.common.publish.widget.IWidgetInstParameterMgr 中的方法
获取资源块实例关联的资源块实例变量对象集合
getWidgetInstParameters(WidgetInstance, WCMFilter) - 类 com.trs.components.common.publish.widget.WidgetInstParameterMgr 中的方法

getWidgetParamDesc() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：WidgetParamDesc
getWidgetParameterType() - 类 com.trs.components.common.publish.widget.WidgetParameterType 中的方法
获取变量类型
getWidgetParameterTypeAt(int) - 类 com.trs.components.common.publish.widget.WidgetParameterTypes 中的方法
根据索引获取变量类型对象
getWidgetParameterTypeById(int) - 类 com.trs.components.common.publish.widget.WidgetParameterTypes 中的方法
根据变量类型的TypeId，获取变量类型对象
getWidgetParameterTypeDesc() - 类 com.trs.components.common.publish.widget.WidgetParameterType 中的方法
获取变量类型描述
getWidgetParamName() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：WidgetParamName
getWidgetParamType() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
提取属性：WidgetParamType
getWidgetpic() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：Widgetpic
getWidgetType() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：WidgetType
getWidth() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
提取属性：Width
getWidth(Image) - 类 com.trs.infra.util.CImage 中的方法

getWidth() - 接口 com.trs.wcm.photo.IMagicImage 中的方法
获取图片的高度
getWidth() - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法

getWMName() - 类 com.trs.wcm.photo.Watermark 中的方法
提取属性：WMName
getWMPicture() - 类 com.trs.wcm.photo.Watermark 中的方法
提取属性：WMPicture
getWname() - 类 com.trs.components.common.publish.widget.Widget 中的方法
提取属性：Wname
getWordsCount() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
获取正文字数
getWorker() - 类 com.trs.components.common.job.JobWorkerType 中的方法

getWorker() - 类 com.trs.components.common.message.MessageSendingConfig 中的方法

getWorker(String) - 类 com.trs.components.common.message.MessageSendingMapper 中的方法
依据 SenderName 得到指定的 SendWorker 的名称
getWorkerClass() - 类 com.trs.components.common.job.JobWorkerType 中的方法

getWorkerClassAsString() - 类 com.trs.components.common.job.JobWorkerType 中的方法

getWorkerName() - 类 com.trs.components.common.job.JobWorkerType 中的方法

getWorkerType() - 类 com.trs.components.common.job.Schedule 中的方法

getWorkerTypeId() - 类 com.trs.components.common.job.Schedule 中的方法

getWorkModal() - 类 com.trs.cms.process.definition.FlowNode 中的方法
节点上的流转模式
getWorkModal() - 类 com.trs.cms.process.engine.FlowContext 中的方法

getWorkModal() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取处理模式
getWorkModalDesc() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取处理模式显示
getWorkModalDesc(int) - 类 com.trs.cms.process.ProcessConstants 中的静态方法
获取处理模式描述
getXDesc() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法

getXlabel() - 类 com.trs.components.stat.TimeRange 中的方法
根据当前的开始时间和结束时间获取X的坐标内容
getXlabels() - 接口 com.trs.components.stat.IStatResults 中的方法
获取走势图的X下标内容
getXlabels() - 类 com.trs.components.stat.StatResults 中的方法

getXmlEncoding() - 类 com.trs.infra.persistent.AbstractXmlToObjConverter 中的方法
获取XML的输出字符编码设置
getXmlEncoding() - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法
获取XML的输出字符编码设置
getXmlEncoding() - 类 com.trs.infra.persistent.XmlToObjConverter 中的方法
获取XML的输出字符编码设置
getXmlEncoding() - 类 com.trs.infra.persistent.XmlToObjConverterByDOM4j 中的方法
获取XML的输出字符编码设置
getXMLToEdit() - 类 com.trs.components.infoview.extract.manifest.MenuButton 中的方法

getXPath() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

getXSDFile() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

getXSDTypeName() - 类 com.trs.components.infoview.extract.DataType 中的方法

getXSDURI() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

getXSLPrefix() - 类 com.trs.components.infoview.extract.manifest.View 中的方法

getXSLPrefix() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法

getXSLTFile() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

getYDesc() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法

getYear() - 类 com.trs.infra.util.CMyDateTime 中的方法
获取当前对象中的【年】的部分
getZipFile() - 类 com.trs.infra.util.CMyUnZipFile 中的方法
获取需要解压的文件
GovInfoIndexCreator - com.trs.components.metadata.service 中的 类

GovInfoIndexCreator() - 类 com.trs.components.metadata.service.GovInfoIndexCreator 的构造方法

GovInfoLCListenerMetaView - com.trs.components.govinfo 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
GovInfoLCListenerMetaView() - 类 com.trs.components.govinfo.GovInfoLCListenerMetaView 的构造方法

GovInfoServiceProvider - com.trs.components.metadata.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
资源加工平台驱动服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GovInfoServiceProvider() - 类 com.trs.components.metadata.service.GovInfoServiceProvider 的构造方法

GovInfoToXML - com.trs.components.metadata.service 中的 类

GovInfoToXML() - 类 com.trs.components.metadata.service.GovInfoToXML 的构造方法

GovInfoViewFinder - com.trs.components.govinfo 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
GovInfoViewFinder() - 类 com.trs.components.govinfo.GovInfoViewFinder 的构造方法

Group - com.trs.cms.auth.persistent 中的 类

Group() - 类 com.trs.cms.auth.persistent.Group 的构造方法

GROUP_ADD_USER - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
添加用户的权限
GROUP_DEL - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除组织的权限
GROUP_DEL_USER - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
删除用户的权限
GROUP_SAVE - 类 com.trs.infra.common.WCMRightTypes 中的静态变量
保存组织的权限
GroupAdminsAsToUsersCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAdminsAsToUsersCreator() - 类 com.trs.cms.process.engine.creators.GroupAdminsAsToUsersCreator 的构造方法

GroupAdminsCacheMgr - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
用户组织管理员缓冲管理
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAdminsCacheMgr() - 类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 的构造方法

GroupAdminsFromChnlAsToUsersCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
根据频道名获取跟其名称一样的组织的管理员
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAdminsFromChnlAsToUsersCreator() - 类 com.trs.cms.process.engine.creators.GroupAdminsFromChnlAsToUsersCreator 的构造方法

GroupAdminsFromFlowAsToUsersCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupAdminsFromFlowAsToUsersCreator() - 类 com.trs.cms.process.engine.creators.GroupAdminsFromFlowAsToUsersCreator 的构造方法

GroupAdminsFromSupportPartAsToUsersCreator - com.trs.cms.process.engine.creators 中的 类

GroupAdminsFromSupportPartAsToUsersCreator() - 类 com.trs.cms.process.engine.creators.GroupAdminsFromSupportPartAsToUsersCreator 的构造方法

GroupAuthServer - com.trs.cms.auth.domain 中的 类

GroupAuthServer() - 类 com.trs.cms.auth.domain.GroupAuthServer 的构造方法

GROUPBY_DEFAULT - 类 com.trs.components.wcm.stat.domain.ChartOption 中的静态变量

GroupMembersAsToUsersCreator - com.trs.cms.process.engine.creators 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupMembersAsToUsersCreator() - 类 com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator 的构造方法

GroupMgr - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
GroupMgr() - 类 com.trs.cms.auth.domain.GroupMgr 的构造方法

GroupRightObjImpl - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupRightObjImpl() - 类 com.trs.cms.auth.domain.GroupRightObjImpl 的构造方法

GroupRightObjImpl(int) - 类 com.trs.cms.auth.domain.GroupRightObjImpl 的构造方法

GroupRightObjImpl(CMSObj) - 类 com.trs.cms.auth.domain.GroupRightObjImpl 的构造方法

GroupRole - com.trs.cms.auth.persistent 中的 类

GroupRole() - 类 com.trs.cms.auth.persistent.GroupRole 的构造方法
构造函数：保留默认接口
GroupRoleMgr - com.trs.cms.auth.domain 中的 类

GroupRoleMgr() - 类 com.trs.cms.auth.domain.GroupRoleMgr 的构造方法

GroupRoles - com.trs.cms.auth.persistent 中的 类

GroupRoles(User) - 类 com.trs.cms.auth.persistent.GroupRoles 的构造方法
构造函数
GroupRoles(User, int, int) - 类 com.trs.cms.auth.persistent.GroupRoles 的构造方法
构造函数
Groups - com.trs.cms.auth.persistent 中的 类

Groups(User) - 类 com.trs.cms.auth.persistent.Groups 的构造方法

Groups(User, int, int) - 类 com.trs.cms.auth.persistent.Groups 的构造方法

GroupService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
组织管理的服务接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupService() - 类 com.trs.service.impl.GroupService 的构造方法

GroupServiceProvider - com.trs.ajaxservice 中的 类

GroupServiceProvider() - 类 com.trs.ajaxservice.GroupServiceProvider 的构造方法

GroupUser - com.trs.cms.auth.persistent 中的 类

GroupUser() - 类 com.trs.cms.auth.persistent.GroupUser 的构造方法
构造函数：保留默认接口
GroupUserCacheMgr - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
组织用户的缓冲.
GroupUserCacheMgr() - 类 com.trs.cms.auth.persistent.GroupUserCacheMgr 的构造方法

GroupUsers - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
组织用户关联对象集合
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupUsers(User) - 类 com.trs.cms.auth.persistent.GroupUsers 的构造方法
构造函数
GroupUsers(User, int, int) - 类 com.trs.cms.auth.persistent.GroupUsers 的构造方法
构造函数
GroupXmlConverter - com.trs.cms.auth.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
组织对象到XML转换对象的定义与实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GroupXmlConverter() - 类 com.trs.cms.auth.persistent.GroupXmlConverter 的构造方法

GrpUserIdsMan - com.trs.cms.auth.domain 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
GrpUserIdsMan(int) - 类 com.trs.cms.auth.domain.GrpUserIdsMan 的构造方法

guessTypeByName(String) - 类 com.trs.components.common.publish.persistent.template.Template 中的静态方法
根据模板名称的特点，自动选择模板类型
GZIPInputStream - com.trs.infra.util.jazzlib 中的 类
This filter stream is used to decompress a "GZIP" format stream.
GZIPInputStream(InputStream) - 类 com.trs.infra.util.jazzlib.GZIPInputStream 的构造方法
Creates a GZIPInputStream with the default buffer size
GZIPInputStream(InputStream, int) - 类 com.trs.infra.util.jazzlib.GZIPInputStream 的构造方法
Creates a GZIPInputStream with the specified buffer size
GZIPOutputStream - com.trs.infra.util.jazzlib 中的 类
This filter stream is used to compress a stream into a "GZIP" stream.
GZIPOutputStream(OutputStream) - 类 com.trs.infra.util.jazzlib.GZIPOutputStream 的构造方法

GZIPOutputStream(OutputStream, int) - 类 com.trs.infra.util.jazzlib.GZIPOutputStream 的构造方法

概述  软件包  类  使用  树  已过时   索引  帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


H - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

H

H1 - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
H2 - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
H3 - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
H4 - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
H5 - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
H6 - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
H_DB_DOCUMENT_PROPERTIES - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
HALIGN - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
handle(BaseObj, Map) - 类 com.trs.components.stat.ChannelHitsCountHandler 中的方法
handle(BaseObj, Map) - 类 com.trs.components.stat.DocumentHitsCountHandler 中的方法
handle(BaseObj, Map) - 接口 com.trs.components.stat.IHitsCountHandler 中的方法
更新指定对象obj的点击量
handle(BaseObj, Map) - 类 com.trs.components.stat.SiteHitsCountHandler 中的方法
handleFile(String, String) - 类 com.trs.tools.ChineseFinder 中的静态方法
handleFolder(String, String) - 类 com.trs.tools.ChineseFinder 中的静态方法
handleFolder(String, String, String) - 类 com.trs.tools.ChineseFinder 中的静态方法
handleOpReports(String, Reports) - 类 com.trs.presentation.util.RequestHelper 中的方法
handleViewDatas() - 类 com.trs.util.ResetClassInfoOfViewData 中的方法
hasAttributeRight(User) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
判断当前用户对于系统属性是否具有进入权限
hasChar() - 类 com.trs.components.common.publish.domain.tagparser.ScanContext 中的方法
判断是否还有未获取的字符
hasChild(String) - 类 com.trs.infra.persistent.XmlObject 中的方法
hasChildren() - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的方法
Returns true if this tag item has children; false, otherwise.
hasChildren() - 类 com.trs.infra.persistent.XmlObject 中的方法
hasChildren() - 类 com.trs.infra.util.html.HtmlElement 中的方法
判断是否含有子元素
hasCustomized() - 类 com.trs.components.wcm.customize.CustomizeMgr 中的方法
判断当前登录用户是否有个性化定制内容
hasCustomized() - 接口 com.trs.service.ICustomizeService 中的方法
当前用户是否有个性化定制
hasCustomized() - 类 com.trs.service.impl.CustomizeService 中的方法
hasDocPro(int) - 类 com.trs.components.wcm.content.persistent.Document 中的方法
hasDocSerial() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
hasExpired(Map, Date) - 类 com.trs.components.wcm.stat.chart.BarChartProducer 中的方法
hasExpired(Map, Date) - 类 com.trs.components.wcm.stat.chart.PieChartProducer 中的方法
hasExpired(Map, Date) - 类 com.trs.components.wcm.stat.domain.TimingChartProducer 中的方法
hasExtendedRight(User) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasExtendedRight(User, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasFlowDocRight(User, Document, int) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法
hasFlowingActionRight(User, int, int) - 类 com.trs.ajaxservice.WCMProcessServiceHelper 中的静态方法
hasFreeLabor(int) - 接口 com.trs.components.common.publish.domain.taskdispatch.ILaborResourceMgr 中的方法
hasFreeLabor(int) - 类 com.trs.components.common.publish.domain.taskdispatch.LaborResourceMgrImpl 中的方法
hashCode() - 类 com.trs.infra.util.html.HTML.UnknownTag 中的方法
hashCode() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets the hashCode of this ZipEntry.
hashCode() - 类 com.trs.infra.util.MySSLSocketFactory 中的方法
hashCode() - 类 com.trs.infra.util.upgrade.dbcompare.Column 中的方法
HashCodeUtil - com.trs.webframework.config 中的 类
HashCodeUtil() - 类 com.trs.webframework.config.HashCodeUtil 的构造方法
hasMgrDocSourceRight(User) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
添加一个判断是否有管理文档来源的权限判断方法
hasNext() - 类 com.trs.components.wcm.publish.element.PublishElementsIteratorDocumentsImpl 中的方法
hasRight(User, CMSObj, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
判断当前用户对于指定的频道对象是否具有指定索引的权限
hasRight(CMSObj, CMSObj, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasRight(RightValue, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasRight(long, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasRight(User, CMSObj) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
判断用户对特定对象是否有“访问权限”
hasRight(User, Group, int) - 类 com.trs.cms.auth.domain.GroupAuthServer 中的静态方法
hasRight(User, int) - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的方法
hasRight(User, int) - 接口 com.trs.cms.auth.domain.IRightObj 中的方法
判断用户对于指定的对象是否具有指定的权限
hasRight(User, Role, int) - 类 com.trs.cms.auth.domain.RoleAuthServer 中的静态方法
hasRight(User, int) - 类 com.trs.components.common.publish.domain.auth.TemplateRightObjImpl 中的方法
hasRight(CMSObj, CMSObj, int) - 类 com.trs.components.common.publish.widget.SpecialAuthServer 中的静态方法
判断当前操作者operator在对象obj上是否有权限nRightIndex
hasRight(User, int) - 类 com.trs.components.metadata.center.MetaViewData 中的方法
判断当前用户对于ViewDocument是否具有指定的权限
hasRight(User, MetaDBTable) - 类 com.trs.components.metadata.right.AuthServerMgr 中的静态方法
hasRight(User, MetaView) - 类 com.trs.components.metadata.right.AuthServerMgr 中的静态方法
hasRight(User, Channel, int) - 类 com.trs.components.wcm.auth.ChannelAuthHelper 中的静态方法
hasRight(User, int) - 类 com.trs.components.wcm.auth.ChannelRightObjImpl 中的方法
hasRight(User, int) - 类 com.trs.components.wcm.auth.WebSiteRightObjImpl 中的方法
hasRight(User, ChnlDoc, int) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法
hasRight(User, BaseChannel, Document, int) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法
判断指定用户在指定频道中对于指定的文档是否具有指定的权限
hasRight(User, BaseChannel, Documents, int) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法
hasRight(User, int) - 类 com.trs.components.wcm.content.ViewDocument 中的方法
判断当前用户对于ViewDocument是否具有指定的权限
hasRight(Channel) - 类 com.trs.presentation.nav.TreeCreator 中的方法
hasRight(User, CMSObj, int[]) - 类 com.trs.presentation.right.RightHelper 中的静态方法
判断用户对某个对象是否具有具有一系列权限中的一个
hasRight(int) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
hasRight(int, Document) - 类 com.trs.presentation.wcm.content.DocumentsPageHelper 中的方法
hasRightInObjects(User, CMSBaseObjs, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasRightOnSelf(User, CMSObj, int[]) - 类 com.trs.cms.auth.AuthHelper 中的静态方法
hasRightOnSelf(User, int, int, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
判断当前用户对指定的对象是否具有指定权限
hasRightOnSelf(User, CMSObj, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasStatisticRight(User) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasStatisticRight(User, int) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
hasSuperRight(User, CMSObj) - 类 com.trs.cms.auth.AuthHelper 中的静态方法
hasSuperRight(User, CMSObj) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
Created: 2004-11-25 17:27:12 Last Modified: 2004-11-25/2004-11-25 Description: class AuthServer.java 判断当前用户是否有特权(用户是管理员,对象创建者等) wenyh
hasSuperRight(BaseChannel, CMSObj) - 类 com.trs.components.common.publish.widget.tagparser.WCMTagParserDocInChnlOperation 中的方法
判断当前Operator对于指定结点是否有Super权限
hasSuperRight(BaseChannel, CMSObj) - 类 com.trs.presentation.nav.TreeCreator 中的方法
判断当前Operator对于指定结点是否有Super权限
hasTheFile(String) - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
判断远程服务器上是否存在指定的文件
hasTheFile(String) - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的方法
hasTheFile(String) - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的方法
hasUnreadMessage(MethodContext) - 类 com.trs.ajaxservice.MessageServiceProvider 中的方法
获取当前用户没有阅读的消息
hasUnreadMessage(User) - 类 com.trs.components.common.message.MessageServer 中的静态方法
判断用户是否有没有阅读的消息
hasUnreadMessage(User, int[]) - 类 com.trs.components.common.message.MessageServer 中的静态方法
判断用户是否有没有阅读指定类型的消息
hasWarnings() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
Returns true if there is warnings.
HEAD - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
HEIGHT - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
HEIGHT - 类 com.trs.scene.tools.SceneNode 中的静态变量
节点高度
height - 类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 中的变量
HITS_BONUS - 类 com.trs.components.stat.BonusRule 中的静态变量
点击量类型
HitsCount - com.trs.components.wcm.content.persistent 中的 类
HitsCount() - 类 com.trs.components.wcm.content.persistent.HitsCount 的构造方法
构造函数：保留默认接口
HitsCountConstant - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
HitsCountConstant() - 类 com.trs.components.stat.HitsCountConstant 的构造方法
HitsCountHelper - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
HitsCountHelper() - 类 com.trs.components.stat.HitsCountHelper 的构造方法
HitsCountParserSchedule - com.trs.components.stat 中的 类
HitsCountParserSchedule() - 类 com.trs.components.stat.HitsCountParserSchedule 的构造方法
HitsCounts - com.trs.components.wcm.content.persistent 中的 类
HitsCounts(User) - 类 com.trs.components.wcm.content.persistent.HitsCounts 的构造方法
构造函数
HitsCounts(User, int, int) - 类 com.trs.components.wcm.content.persistent.HitsCounts 的构造方法
构造函数
HitsStatHandler4Channel - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
HitsStatHandler4Channel() - 类 com.trs.components.stat.HitsStatHandler4Channel 的构造方法
HitsStatHandler4ChnlDept - com.trs.components.stat 中的 类
HitsStatHandler4ChnlDept() - 类 com.trs.components.stat.HitsStatHandler4ChnlDept 的构造方法
HitsStatHandler4ChnlDept(Channels) - 类 com.trs.components.stat.HitsStatHandler4ChnlDept 的构造方法
HitsStatHandler4User - com.trs.components.stat 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
HitsStatHandler4User() - 类 com.trs.components.stat.HitsStatHandler4User 的构造方法
HitsStatHandler4User(Documents) - 类 com.trs.components.stat.HitsStatHandler4User 的构造方法
HitsStatHandler4UserDept - com.trs.components.stat 中的 类
HitsStatHandler4UserDept() - 类 com.trs.components.stat.HitsStatHandler4UserDept 的构造方法
HitsStatHandler4UserDept(Documents) - 类 com.trs.components.stat.HitsStatHandler4UserDept 的构造方法
HostObjDomain - com.trs.components.stat 中的 类
HostObjDomain() - 类 com.trs.components.stat.HostObjDomain 的构造方法
构造函数：保留默认接口
HostObjDomains - com.trs.components.stat 中的 类
HostObjDomains(User) - 类 com.trs.components.stat.HostObjDomains 的构造方法
构造函数
HostObjDomains(User, int, int) - 类 com.trs.components.stat.HostObjDomains 的构造方法
构造函数
HostObjHitsCount - com.trs.components.stat 中的 类
HostObjHitsCount() - 类 com.trs.components.stat.HostObjHitsCount 的构造方法
构造函数：保留默认接口
HostObjHitsCounts - com.trs.components.stat 中的 类
HostObjHitsCounts(User) - 类 com.trs.components.stat.HostObjHitsCounts 的构造方法
构造函数
HostObjHitsCounts(User, int, int) - 类 com.trs.components.stat.HostObjHitsCounts 的构造方法
构造函数
HOUR - 类 com.trs.infra.util.CMyDateTime 中的静态变量
日期/时间的各个部分标识：时（4）
HR - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
HREF - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
HSPACE - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
HTMFILE_DOCUMENT_LIST_EXPORT - 类 com.trs.components.wcm.content.domain.DocumentExporter 中的静态变量
HTMFILE_DOCUMENT_VIEW_EXPORT - 类 com.trs.components.wcm.content.domain.DocumentExporter 中的静态变量
HTML - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType 中的静态变量
在开始置标和结束置标之间是普通的HTML代码
HTML - com.trs.infra.util.html 中的 类
HTML() - 类 com.trs.infra.util.html.HTML 的构造方法
HTML - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
HTML.Attribute - com.trs.infra.util.html 中的 类
Title: TRS内容协作平台（TRS WCM） Description: Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: www.trs.com.cn
HTML.Tag - com.trs.infra.util.html 中的 类
Typesafe enumeration for an html tag.
HTML.Tag() - 类 com.trs.infra.util.html.HTML.Tag 的构造方法
HTML.UnknownTag - com.trs.infra.util.html 中的 类
HTML.UnknownTag(String) - 类 com.trs.infra.util.html.HTML.UnknownTag 的构造方法
Html2text - com.trs.tools 中的 类
Html2text() - 类 com.trs.tools.Html2text 的构造方法
html2text(String) - 类 com.trs.tools.Html2text 中的静态方法
HtmlAttribute - com.trs.infra.util.html 中的 类
HtmlAttribute(String, String) - 类 com.trs.infra.util.html.HtmlAttribute 的构造方法
构造函数
HtmlAttribute(String, String, char) - 类 com.trs.infra.util.html.HtmlAttribute 的构造方法
构造函数
HtmlAttribute(String) - 类 com.trs.infra.util.html.HtmlAttribute 的构造方法
构造函数
HtmlCharsetValidator - com.trs.wcag2.validator 中的 类
HtmlCharsetValidator() - 类 com.trs.wcag2.validator.HtmlCharsetValidator 的构造方法
HtmlCleaner - com.trs.tools 中的 类
HtmlCleaner() - 类 com.trs.tools.HtmlCleaner 的构造方法
HtmlComment - com.trs.infra.util.html 中的 类
Title: TRS 内容协作平台（TRS WCM） Description: class HtmlComment —— 解析HTML中注释部分 Copyright: Copyright (c) 2001-2002 TRS信息技术有限公司 Company: TRS信息技术有限公司(www.trs.com.cn)
HtmlComment(String) - 类 com.trs.infra.util.html.HtmlComment 的构造方法
构造函数
HTMLContent - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
HTMLContent(String) - 类 com.trs.cms.content.HTMLContent 的构造方法
HtmlDocument - com.trs.infra.util.html 中的 类
HtmlDocument() - 类 com.trs.infra.util.html.HtmlDocument 的构造方法
构造函数
HtmlDocument(HtmlElement) - 类 com.trs.infra.util.html.HtmlDocument 的构造方法
构造函数
HtmlElement - com.trs.infra.util.html 中的 类
HtmlElement() - 类 com.trs.infra.util.html.HtmlElement 的构造方法
构造函数
HtmlElement(String) - 类 com.trs.infra.util.html.HtmlElement 的构造方法
构造函数
HtmlElementFinder - com.trs.infra.util.html 中的 类
HtmlElementFinder() - 类 com.trs.infra.util.html.HtmlElementFinder 的构造方法
构造函数
HtmlElementFinder(String) - 类 com.trs.infra.util.html.HtmlElementFinder 的构造方法
构造函数
HtmlElementFinder(char[]) - 类 com.trs.infra.util.html.HtmlElementFinder 的构造方法
构造函数
HtmlH1_H6Validator - com.trs.wcag2.validator 中的 类
HtmlH1_H6Validator() - 类 com.trs.wcag2.validator.HtmlH1_H6Validator 的构造方法
HtmlH1Validator - com.trs.wcag2.validator 中的 类
HtmlH1Validator() - 类 com.trs.wcag2.validator.HtmlH1Validator 的构造方法
HtmlLangValidator - com.trs.wcag2.validator 中的 类
HtmlLangValidator() - 类 com.trs.wcag2.validator.HtmlLangValidator 的构造方法
HTMLMaker - com.trs.components.metadata.web 中的 接口
HTMLMakerFactory - com.trs.components.metadata.web 中的 类
HTMLMakerFactory() - 类 com.trs.components.metadata.web.HTMLMakerFactory 的构造方法
HtmlTitleValidator - com.trs.wcag2.validator 中的 类
HtmlTitleValidator() - 类 com.trs.wcag2.validator.HtmlTitleValidator 的构造方法
HtmlUtil - com.trs.infra.util.html 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
HTML text render utilities.
HTMLUtil - com.trs.wcag2 中的 类
HTMLUtil() - 类 com.trs.wcag2.HTMLUtil 的构造方法
hTRSClasses - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态变量
hTRSClasses - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态变量
HttpChecker - com.trs.components.common.conjection.helper 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
HttpChecker() - 类 com.trs.components.common.conjection.helper.HttpChecker 的构造方法
HttpClientBuddy - com.trs.infra.util 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
HttpClientBuddy() - 类 com.trs.infra.util.HttpClientBuddy 的构造方法
HttpClientBuddy(String) - 类 com.trs.infra.util.HttpClientBuddy 的构造方法
HttpClientBuddy(String, String[][]) - 类 com.trs.infra.util.HttpClientBuddy 的构造方法
HTTPEQUIV - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
HttpGet - com.trs.infra.util 中的 类
HttpGet() - 类 com.trs.infra.util.HttpGet 的构造方法
HUFFMAN_ONLY - 类 com.trs.infra.util.jazzlib.Deflater 中的静态变量
This strategy will not look for string repetitions at all.
概述 软件包 类 使用 树 已过时 索引 帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


I - 索引

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

I

I - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
I18NMessage - com.trs.infra 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
国际化消息处理
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
I18NMessage() - 类 com.trs.infra.I18NMessage 的构造方法
I18NMessageStartUp - com.trs.infra 中的 类
I18NMessageStartUp() - 类 com.trs.infra.I18NMessageStartUp 的构造方法
IActionHandler - com.trs.cms.process.engine 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
触发的操作处理器接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IAdmanageConfigService - com.trs.components.common.conjection.service 中的 接口
IAdministratorCacheMgr - com.trs.cms.auth.persistent 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
IAdministratorCacheMgr,接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IAppendix - com.trs.components.common.publish.persistent.element 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IAppendixes - com.trs.components.common.publish.persistent.element 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IAtomTask - com.trs.components.common.publish.domain.taskdispatch 中的 接口
原子任务。
IAtomTaskList - com.trs.components.common.publish.domain.taskdispatch 中的 接口
批量原子任务的列表
IAutoDocBakService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
文档版本自动保存接口设计
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IBonusCalculator - com.trs.components.stat 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
IBonusRuleMgr - com.trs.components.stat 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
奖励规则的业务逻辑层接口
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
IBookMarkService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
IBookMarkServic接口定义 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICachedPOMgr - com.trs.infra.persistent.cache 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
缓冲对象管理器接口的定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICacheMgr - com.trs.infra.support.cache 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache管理者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICacheServer - com.trs.infra.support.cache 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
Cache调度者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICDSService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IChannelImporterConverter - com.trs.components.wcm.content.domain 中的 接口
IChannelNameMgr - com.trs.components.wcm.content.persistent 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
频道名称缓冲管理对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IChannelService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
站点/频道服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IChartBuilder - com.trs.components.wcm.stat.domain 中的 接口
IChildrenMgr - com.trs.components.wcm.content.persistent 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
子频道获取管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IChnlDeptMgr - com.trs.components.stat 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
ICKMServer - com.trs.components.ckm 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICKMServerTest - com.trs.components.ckm 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICKMServerTest() - 类 com.trs.components.ckm.ICKMServerTest 的构造方法
IClassInfoCacheMgr - com.trs.components.metadata.definition 中的 接口
IClassInfoCountCacheForPublish - com.trs.components.metadata.publish 中的 接口
IClassInfoMgr - com.trs.components.metadata.definition 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
分类业务定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IClassInfoViewMgr - com.trs.components.metadata.center 中的 接口
IClusterMsgCenter - com.trs.cluster 中的 接口
IClusterMsgReceiver - com.trs.cluster 中的 接口
IClusterMsgSender - com.trs.cluster 中的 接口
ICMSObjSubstanceContent - com.trs.cms.content 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
以CMSObj为核心的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICommentService - com.trs.components.comment.service 中的 接口
IComponentEntryConfigService - com.trs.components.common.conjection.service 中的 接口
IConditionHandler - com.trs.cms.process.engine 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
条件处理器接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IConfigElement - com.trs.infra.config.persistent 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
所有配置对象的接口声明
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IContactService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
联系人服务接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IContentStyleMgr - com.trs.components.common.publish.widget 中的 接口
内容可用风格业务逻辑层接口
IContentStyleServiceProvider - com.trs.components.common.publish.widget 中的 接口
内容可用风格服务层接口
ICustomizeMgr - com.trs.wcm.customize 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
个性化设置管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ICustomizeService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
个性化定制服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ID - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量
ID_CHANNEL_SYN - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
操作类型：频道分发
ID_CLEAN_TEMPPATH_SCHEDULE - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
操作类型：删除临时文件的计划执行
ID_DEBUG - 类 com.trs.infra.support.log.LogType 中的静态变量
ID_DOCUMENT_TOP - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
操作类型：文档置顶
ID_ERROR - 类 com.trs.infra.support.log.LogType 中的静态变量
ID_FATAL - 类 com.trs.infra.support.log.LogType 中的静态变量
ID_FIELD_NAME - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态变量
ID_FIELD_NAME - 类 com.trs.components.wcm.content.ViewDocument 中的静态变量
ID_FIELD_NAME - 类 com.trs.components.wcm.content.ViewDocuments 中的静态变量
ID_INFO - 类 com.trs.infra.support.log.LogType 中的静态变量
ID_NOT_LOAD - 类 com.trs.components.metadata.center.MetaViewDatas 中的静态变量
ID_NOT_LOAD - 类 com.trs.components.wcm.content.ViewDocuments 中的静态变量
ID_NOT_LOAD - 类 com.trs.infra.persistent.BaseObjs 中的静态变量
ID_PUBLISH_SCHEDULE - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
操作类型：文档/频道/站点 的计划发布
ID_REMIND_JOB - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
操作类型：消息提醒
ID_STAT_AUTORUN - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
操作类型：统计数据自动生成
ID_USERDEF_FROM - 类 com.trs.components.common.job.JobWorkerType 中的静态变量
操作类型：用户自定义操作类型的ID起始值
ID_WARN - 类 com.trs.infra.support.log.LogType 中的静态变量
IDataTransferEncode - com.trs.template 中的 接口
IDBService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
数据库相关操作服务层接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IDefaultChannelMaker - com.trs.components.metadata.service 中的 接口
IDeleteServiceProvider - com.trs.webframework.provider 中的 接口
identifyHost() - 类 com.trs.infra.util.key.MachineCodeDetector 中的静态方法
获取机器码.
IDepartmentMgr - com.trs.cms.auth.domain 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
组织结构管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IDocKeywordMgr - com.trs.components.wcm.content.domain 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IDocumentFieldsSyn - com.trs.components.metadata.center 中的 接口
IDocumentImporterConverter - com.trs.components.wcm.content.domain 中的 接口
IDocumentService - com.trs.service 中的 接口
IDocumentsTimeRangeMgr - com.trs.components.wcm.content.domain 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IErrorMessages - com.trs.template 中的 接口
IEventService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
Event Service Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFieldHTMLParser - com.trs.components.web 中的 接口
IFileDistristributor - com.trs.components.common.publish.domain.distribute 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
file distributor interface.
IFindByIdServiceProvider - com.trs.webframework.provider 中的 接口
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFindByIdsServiceProvider - com.trs.webframework.provider 中的 接口
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFlowCacheMgr - com.trs.cms.process 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFlowContent - com.trs.cms.process 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFLOWCONTENT_APPLYFORM_CLASSNAME - 类 com.trs.cms.process.FlowingDocOptMarkScouter 中的静态变量
依申请公开的实现的类名
IFlowNotifyWorker - com.trs.cms.process 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFlowRuleCacheServer - com.trs.cms.process.definition 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
规则缓冲服务器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFlowServer - com.trs.cms.process 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
工作流流转驱动器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFolderPubStatusCacheMgr - com.trs.components.wcm.publish 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IFtpMgr - com.trs.infra.util.ftp 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
interface of ftp manager.
IGlueServiceProvider - com.trs.webframework.provider 中的 接口
IGNORE - 类 com.trs.components.common.publish.domain.tagparser.TagBeanInfo.BodyType 中的静态变量
在开始置标和结束置标之间的任何内容都回忽略
IGroupService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
组织服务提供对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IHitsCountHandler - com.trs.components.stat 中的 接口
IImageLibConfig - com.trs.wcm.photo 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
图片库配置信息管理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IImageLibMgr - com.trs.wcm.photo 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
图片业务处理对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IImageLibService - com.trs.wcm.photo 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
图片选件服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoEntity - com.trs.template.persistent 中的 接口
IInfoViewDBMgr - com.trs.components.infoview.db 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewEnumCreator - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewInitor - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IInfoViewInitorValue - com.trs.service 中的 接口
IInfoViewService - com.trs.service 中的 接口
自定义表单管理的公共接口定义
IInitValueCreator - com.trs.cms.process.engine 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IIntellMgr - com.trs.components.wcm.content.domain.intelligence 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IIntellResLocator - com.trs.components.wcm.content.domain.intelligence 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IKeyMaker - com.trs.components.stat 中的 接口
用于根据统计SQL中的select字段，构造统计存储结构中的Key信息
ILaborResourceMgr - com.trs.components.common.publish.domain.taskdispatch 中的 接口
ILayoutGenerator - com.trs.components.common.publish.widget 中的 接口
ILayoutMgr - com.trs.components.common.publish.widget 中的 接口
ILayoutServiceProvider - com.trs.components.common.publish.widget 中的 接口
ILog - com.trs.infra.support.log 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
日志相关接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ILoginValidator - com.trs.webframework.controler.servlet 中的 接口
ILogMgr - com.trs.infra.support.log 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
日志管理相关接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IMAGE - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：IMAGE
IMAGE - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：IMAGE
IMAGE - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：IMAGE
ImageInfo - com.trs.wcm.photo 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
新上传的图片信息描述对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImageInfo() - 类 com.trs.wcm.photo.ImageInfo 的构造方法
ImageKind - com.trs.wcm.photo 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片分类对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImageKind() - 类 com.trs.wcm.photo.ImageKind 的构造方法
ImageLibConfigImpl - com.trs.wcm.photo.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片库配置信息管理默认实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImageLibConfigImpl() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 的构造方法
ImageLibConstants - com.trs.wcm.photo 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片库常量定义对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImageLibConstants() - 类 com.trs.wcm.photo.ImageLibConstants 的构造方法
ImageLibHelper - com.trs.wcm.photo 中的 类
ImageLibHelper() - 类 com.trs.wcm.photo.ImageLibHelper 的构造方法
ImageLibMgrImpl - com.trs.wcm.photo.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片库业务逻辑处理对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImageLibMgrImpl() - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 的构造方法
ImageLibServiceImpl - com.trs.wcm.photo.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
图片服务的实现
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImageLibServiceImpl() - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 的构造方法
ImageMagickCmd - com.trs.wcm.photo.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
ImageMagickCmd() - 类 com.trs.wcm.photo.impl.ImageMagickCmd 的构造方法
ImageMagickCmd.ImageObj - com.trs.wcm.photo.impl 中的 类
ImageMagickCmd.ImageObj() - 类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 的构造方法
ImageMagickCmd.ImageObj(String) - 类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 的构造方法
ImageMagickCmd.ImageObj(String, int, int) - 类 com.trs.wcm.photo.impl.ImageMagickCmd.ImageObj 的构造方法
IMagicImage - com.trs.wcm.photo 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
图片处理对象（例如：缩放、锐化、凸起等）
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IMasterMgr - com.trs.components.common.publish.widget 中的 接口
IMasterServiceProvider - com.trs.components.common.publish.widget 中的 接口
IMessageService - com.trs.components.common.message 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
在线短消息管理的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IMetaDataDefCacheMgr - com.trs.components.metadata.definition 中的 接口
IMetaDataDefMgr - com.trs.components.metadata.definition 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IMetaDataFieldValueCreator - com.trs.components.metadata.center 中的 接口
IMetaViewEmployerMgr - com.trs.components.metadata.center 中的 接口
IMG - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
ImgAltValidator - com.trs.wcag2.validator 中的 类
ImgAltValidator() - 类 com.trs.wcag2.validator.ImgAltValidator 的构造方法
ImgRec - com.trs.cms.content 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
从DocMgr中的setHtmlContent中提出来的一个类，目前方法都是公有的
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImgRec() - 类 com.trs.cms.content.ImgRec 的构造方法
IMPART_MODE_ADD - 类 com.trs.cms.auth.domain.NewRightSet 中的静态变量
IMPART_MODE_ALL - 类 com.trs.cms.auth.domain.NewRightSet 中的静态变量
IMPART_MODE_DELETE - 类 com.trs.cms.auth.domain.NewRightSet 中的静态变量
IMPART_MODE_MODIFY - 类 com.trs.cms.auth.domain.NewRightSet 中的静态变量
IMPART_MODE_NODE - 类 com.trs.cms.auth.domain.NewRightSet 中的静态变量
impartExtendFields(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
将扩展字段同步到指定对象的所有子对象上
impartTemplateConfig(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
传递当前对象(站点/栏目)的模板配置到子对象上
ImpartTemplateLogger - com.trs.ajaxservice.logger 中的 类
ImpartTemplateLogger() - 类 com.trs.ajaxservice.logger.ImpartTemplateLogger 的构造方法
IMPLIED - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量
All text content must be in a paragraph element.
importChannels(MethodContext) - 类 com.trs.ajaxservice.ChannelServiceProvider 中的方法
导入栏目
importClassInfos(String, String, boolean, int) - 类 com.trs.components.metadata.definition.ClassInfoUtil 中的方法
importClassInfos(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProvider 中的方法
从文件中导入分类法
importClassInfos(MethodContext) - 类 com.trs.components.metadata.service.ClassInfoServiceProviderForGB 中的方法
从文件中导入分类法
importContentStyleZip(MethodContext) - 类 com.trs.components.common.publish.widget.ContentStyleServiceProvider 中的方法
从一个zip文件中导入内容风格的相关内容，包括该内容风格的所有相关内容 ContentStyleZipFile支持一个全路径
importCssFile(PageStyle, String) - 接口 com.trs.components.common.publish.widget.IStyleCenterMgr 中的方法
导入风格文件
importCssFile(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
导入风格文件
importCssFile(PageStyle, String) - 类 com.trs.components.common.publish.widget.StyleCenterMgr 中的方法
导入风格文件
importData(String, String) - 类 com.trs.components.wcm.newshoo.DataFromNewshoo 中的方法
importData(String, String) - 类 com.trs.components.wcm.newshoo.DataFromRadar 中的方法
importData2(DataHandler, String, String) - 类 com.trs.components.wcm.newshoo.DataFromRadar 中的方法
importDemoDatasContentStyle(String) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法
importDemoDatasDocument(String) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法
importDemoDatasMaster(String) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法
importDemoDatasPageStyle(String) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法
importDemoDatasResourceStyle(String) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法
importDemoDatasWebSite(String) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法
初始化测试数据站点
importDemoDatasWidget(String) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法
importDocFromHTML() - 类 com.trs.wcm.old.ImportDocsFromHTMLFile 中的方法
importDocs() - 类 com.trs.wcm.old.ImportDocsFromFile 中的方法
importDocs() - 类 com.trs.wcm.old.ImportDocsFromHTMLFile 中的方法
ImportDocsContext - com.trs.wcm.old 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImportDocsContext() - 类 com.trs.wcm.old.ImportDocsContext 的构造方法
ImportDocsFromFile - com.trs.wcm.old 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ImportDocsFromFile() - 类 com.trs.wcm.old.ImportDocsFromFile 的构造方法
ImportDocsFromHTMLFile - com.trs.wcm.old 中的 类
Created by IntelliJ IDEA.
ImportDocsFromHTMLFile() - 类 com.trs.wcm.old.ImportDocsFromHTMLFile 的构造方法
importDocuments(MethodContext) - 类 com.trs.ajaxservice.DocumentServiceProvider 中的方法
导入文档
importDocuments(String) - 类 com.trs.components.wcm.epress.EPressImporter 中的方法
importDocuments(String, Channel) - 类 com.trs.components.wcm.epress.EPressImporter 中的方法
importDocuments(String, String) - 类 com.trs.components.wcm.epress.EPressImporter 中的方法
importDocuments(String, int, String, boolean, boolean) - 接口 com.trs.service.IDocumentService 中的方法
从文件中导入文档
支持从zip,xml,html,htm文件导入
importDocuments(String, int, String, boolean, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
importDocuments(byte[], String) - 类 com.trs.service.impl.SOAPServiceImpl 中的方法
importDocuments(byte[], String) - 接口 com.trs.service.ISOAPService 中的方法
从指定文件中导入文档集合
importDocumentsByLocalFile(String, String) - 类 com.trs.service.impl.SOAPServiceImpl 中的方法
importEPressData(byte[], String) - 类 com.trs.components.wcm.epress.EPressSoapService 中的方法
importFlows(MethodContext) - 类 com.trs.ajaxservice.ProcessService 中的方法
importFlows(String) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
importFlows(String, String) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法
importFlows(String) - 接口 com.trs.service.IWCMProcessService 中的方法
从XML文件中导入工作流配置.
importFlows(String, String) - 接口 com.trs.service.IWCMProcessService 中的方法
从XML文件中导入工作流配置.
importFormFileByCode(String, String, int) - 类 com.trs.components.metadata.definition.ClassInfoUtil 中的方法
从文件中导入分类法，依靠分类法代码表示层次关系
importFormFileByName(String, String, int) - 类 com.trs.components.metadata.definition.ClassInfoUtil 中的方法
importFormFileByName(String) - 类 com.trs.scene.tools.SceneNodeParser 中的方法
importFromFile(String, String) - 类 com.trs.cms.process.xml.FlowImporter 中的方法
importFromFile(String, int) - 类 com.trs.components.common.publish.widget.ContentStyleImporter 中的方法
从zip文件中导入PageStyle的信息。
importFromFile(String) - 类 com.trs.components.common.publish.widget.PageStyleImporter 中的方法
从zip文件中导入PageStyle的信息。
importFromFile(String, int) - 类 com.trs.components.common.publish.widget.ResourceStyleImporter 中的方法
从zip文件中导入PageStyle的信息。
importFromFile(int, String, String) - 类 com.trs.components.metadata.center.xml.MetaViewDataImporter 中的方法
importFromFile(String, String, BaseChannel) - 类 com.trs.components.wcm.content.domain.ChannelImporter 中的方法
importFromFile(String, Channel, String, boolean, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的方法
importFromFile(String, Channel, String, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的方法
从文件中导入文档
支持从zip,xml,html,htm文件导入
importFromFile(String, String, BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
从zip/xml文件中导入站点/频道
importFromFile(String, String, BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法
站点、频道导出、类似创建相关的方法
importFromFileByName(String, Channel, String, boolean, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的方法
importFromHTML(IPublishFolder, String, int, String) - 类 com.trs.components.common.publish.domain.template.TemplateImporter 中的方法
从html文件导入模板
importFromHTML(CMSObj, String, int, String) - 类 com.trs.service.impl.TemplateService 中的方法
importFromHTML(CMSObj, String, int, String) - 接口 com.trs.service.ITemplateService 中的方法
从html文件导入模板
importFromTRSFile(String, Channel, String, boolean, boolean) - 类 com.trs.components.wcm.content.domain.DocumentImporter 中的方法
从TRS文件中导入文档
支持从zip,xml,html,htm文件导入
importFromXML(String, int) - 类 com.trs.components.metadata.definition.xml.ClassInfoImporter 中的方法
importFromXML(String, int, Reports) - 类 com.trs.components.metadata.definition.xml.MetaDataDDLImporter 中的方法
importFromXML(String) - 类 com.trs.components.metadata.service.MetaViewImporter 中的方法
从一个XML中导入视图的定义
importFromXMLContent(String) - 类 com.trs.cms.process.xml.FlowImporter 中的方法
importFromXMLObj(XmlObject) - 类 com.trs.cms.process.xml.FlowImporter 中的方法
importFromXPlus(String, String, Channel) - 类 com.trs.components.wcm.epress.EPressXPlusImporter 中的方法
importFromZip(IPublishFolder, String, int, int, String[]) - 类 com.trs.components.common.publish.domain.template.TemplateImporter 中的方法
从zip文件中导入模板
importFromZip(CMSObj, String, int, int, String[]) - 类 com.trs.service.impl.TemplateService 中的方法
importFromZip(CMSObj, String, int, int, String[]) - 接口 com.trs.service.ITemplateService 中的方法
从zip文件中导入模板
importImageAppendix(User, int, ImageInfo) - 接口 com.trs.wcm.photo.IImageLibMgr 中的方法
导入指定的图片到图片库指定的分类中
importImageAppendix(String, ImageInfo) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
导入指定的图片到指定的分类中
importImageAppendix(int, ImageInfo) - 接口 com.trs.wcm.photo.IImageLibService 中的方法
导入单个的图片到指定的分类中
importImageAppendix(User, int, ImageInfo) - 类 com.trs.wcm.photo.impl.ImageLibMgrImpl 中的方法
importImageAppendix(String, ImageInfo) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
importImageAppendix(int, ImageInfo) - 类 com.trs.wcm.photo.impl.ImageLibServiceImpl 中的方法
importInfoViewData(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
importInfoViewData(byte[], byte[], String, String) - 类 com.trs.service.impl.InfoViewDocImportService 中的方法
importInfoViewData(byte[], byte[], String, String, String, String) - 类 com.trs.service.impl.InfoViewDocImportService 中的方法
importInfoViewDataForCustom(MethodContext) - 类 com.trs.ajaxservice.InfoviewService 中的方法
importInfoViewDataForCustom(Document, String, String, String, HashMap) - 类 com.trs.service.impl.InfoViewDocImportService 中的方法
importMasters(User, String) - 接口 com.trs.components.common.publish.widget.IMasterMgr 中的方法
导入母版
importMasters(MethodContext) - 接口 com.trs.components.common.publish.widget.IMasterServiceProvider 中的方法
导入母版
importMasters(User, String) - 类 com.trs.components.common.publish.widget.MasterMgr 中的方法
导入母板
importMasters(MethodContext) - 类 com.trs.components.common.publish.widget.MasterServiceProvider 中的方法
导入母板
importMetaViewDatas(MethodContext) - 类 com.trs.components.metadata.service.GovInfoServiceProvider 中的方法
在指定的栏目下导入指定的视图
importMetaViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProvider 中的方法
在指定的栏目下导入指定的视图
importMetaViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForAgri 中的方法
在指定的栏目下导入指定的视图
importMetaViewDatas(MethodContext) - 类 com.trs.components.metadata.service.MetaDataCenterServiceProviderForGB 中的方法
在指定的栏目下导入指定的视图
importPageStyleZip(MethodContext) - 类 com.trs.components.common.publish.widget.PageStyleServiceProvider 中的方法
从一个zip文件中导入页面风格的相关内容，包括该页面风格的所有相关内容 其中参数PageStyleZipFile支持全路径
importPost(String, String, String) - 类 com.trs.wcmonline.WCMOnlineService 中的方法
importResourceStyleZip(MethodContext) - 类 com.trs.components.common.publish.widget.ResourceStyleServiceProvider 中的方法
从一个zip文件中导入资源风格的相关内容，包括该资源风格的所有相关内容 ResourceStyleZipFile支持一个全路径
importSites(MethodContext) - 类 com.trs.ajaxservice.WebSiteServiceProvider 中的方法
导入栏目
importSysLinks(MethodContext) - 类 com.trs.ajaxservice.ContentLinkServiceProvider 中的方法
importSysPics(MethodContext) - 类 com.trs.ajaxservice.PhotoServiceProvider 中的方法
importTemplates(MethodContext) - 类 com.trs.ajaxservice.TemplateServiceProvider 中的方法
导入文档
importTRSDocuments(String, int, String, boolean, boolean) - 接口 com.trs.service.IDocumentService 中的方法
从TRS文件中导入文档
支持从zip,xml,html,htm文件导入
importTRSDocuments(String, int, String, boolean, boolean) - 类 com.trs.service.impl.DocumentService 中的方法
importViaFtp(String) - 类 com.trs.service.impl.FtpSoap4Radar 中的方法
importViaZipFile(String, Channel) - 类 com.trs.wcm.photo.impl.PhotoImporter 中的方法
importViewFromXML(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
从XML文件创建视图
importViewsFromXML(MethodContext) - 类 com.trs.components.metadata.service.MetaDataDefServiceProvider 中的方法
从系统导出的XML创建视图（包括元数据表）
importWidgets(String, int) - 接口 com.trs.components.common.publish.widget.IWidgetMgr 中的方法
导入资源
importWidgets(MethodContext) - 接口 com.trs.components.common.publish.widget.IWidgetServiceProvider 中的方法
导出资源
importWidgets(String, int) - 类 com.trs.components.common.publish.widget.WidgetMgr 中的方法
importWidgets(MethodContext) - 类 com.trs.components.common.publish.widget.WidgetServiceProvider 中的方法
INavHandler - com.trs.presentation.nav 中的 接口
incDetailPageCount() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
increase the detailPageCount.
incDetailPageCount() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
increase the detailPageCount.
incOutlinePageCount() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法
increase the outlinePageCount.
incOutlinePageCount() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
increase the outlinePageCount.
INCREASE_FIELD_LENGTH_FACTOR - 类 com.trs.cms.process.FlowServerImpl 中的静态变量
INCREASE_FIELD_LENGTH_FACTOR - 类 com.trs.components.infoview.InfoViewMgr 中的静态变量
INCREASE_FIELD_LENGTH_FACTOR - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
INCREASE_FIELD_LENGTH_LIMIT - 类 com.trs.components.metadata.MetaDataConstants 中的静态变量
IndexDDLMaker - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
从MSSQL数据库中获取所有*WCM*表的索引
利用了sysobjects系统表及sp_helpindex系统存储过程
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
IndexDDLMaker() - 类 com.trs.database.util.IndexDDLMaker 的构造方法

INDEXES_OWNER_HAS - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态变量

IndexList4Ora - com.trs.database.util 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
通过user_ind_columns列出所有的索引
Copyright: Copyright (c) 2004-2008 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
IndexList4Ora() - 类 com.trs.database.util.IndexList4Ora 的构造方法

indexOf(CMSObj, CMSObj) - 类 com.trs.cms.auth.persistent.Rights 中的方法
获取指定操作者对于指定对象权限在集合中的索引
indexOf(int, int, int, int) - 类 com.trs.cms.auth.persistent.Rights 中的方法
获取指定操作者对于指定对象权限在集合中的索引
indexOf(int) - 类 com.trs.infra.persistent.BaseObjs 中的方法
通过整型标识id索引对象
indexOf(int, int) - 类 com.trs.infra.persistent.BaseObjs 中的方法

indexOf(Integer) - 类 com.trs.infra.persistent.BaseObjs 中的方法
通过整型标识id索引对象
indexOf(BaseObj) - 类 com.trs.infra.persistent.BaseObjs 中的方法
获取指定对象所在的序号 注意：索引对象并不改变集合的当前指针位置，故需要在检索后恢复旧的指针位置
indexOf(int, int[]) - 类 com.trs.infra.util.ListUtil 中的静态方法
find the index of a value in the specified array
indexOfChnlTypes(int) - 类 com.trs.components.wcm.wcmx.common.WCMTypesX 中的静态方法
定位频道类型的索引（编号）
Individuation - com.trs.components.wcm.individuation 中的 类

Individuation() - 类 com.trs.components.wcm.individuation.Individuation 的构造方法
构造函数：保留默认接口
IndividuationMgr - com.trs.components.wcm.individuation 中的 类

IndividuationMgr() - 类 com.trs.components.wcm.individuation.IndividuationMgr 的构造方法

Individuations - com.trs.components.wcm.individuation 中的 类

Individuations(User) - 类 com.trs.components.wcm.individuation.Individuations 的构造方法
构造函数
Individuations(User, int, int) - 类 com.trs.components.wcm.individuation.Individuations 的构造方法
构造函数
IndividuationServiceProvider - com.trs.ajaxservice 中的 类

IndividuationServiceProvider() - 类 com.trs.ajaxservice.IndividuationServiceProvider 的构造方法

inflate(byte[]) - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Inflates the compressed stream to the output buffer.
inflate(byte[], int, int) - 类 com.trs.infra.util.jazzlib.Inflater 中的方法
Inflates the compressed stream to the output buffer.
Inflater - com.trs.infra.util.jazzlib 中的 类
Inflater is used to decompress data that has been compressed according to the "deflate" standard described in rfc1950.
Inflater() - 类 com.trs.infra.util.jazzlib.Inflater 的构造方法
Creates a new inflater.
Inflater(boolean) - 类 com.trs.infra.util.jazzlib.Inflater 的构造方法
Creates a new inflater.
InflaterHuffmanTree - com.trs.infra.util.jazzlib 中的 类

InflaterHuffmanTree(byte[]) - 类 com.trs.infra.util.jazzlib.InflaterHuffmanTree 的构造方法
Constructs a Huffman tree from the array of code lengths.
InflaterInputStream - com.trs.infra.util.jazzlib 中的 类
This filter stream is used to decompress data compressed in the "deflate" format.
InflaterInputStream(InputStream) - 类 com.trs.infra.util.jazzlib.InflaterInputStream 的构造方法
Create an InflaterInputStream with the default decompresseor and a default buffer size.
InflaterInputStream(InputStream, Inflater) - 类 com.trs.infra.util.jazzlib.InflaterInputStream 的构造方法
Create an InflaterInputStream with the specified decompresseor and a default buffer size.
InflaterInputStream(InputStream, Inflater, int) - 类 com.trs.infra.util.jazzlib.InflaterInputStream 的构造方法
Create an InflaterInputStream with the specified decompresseor and a specified buffer size.
info(FlowContext, String) - 类 com.trs.cms.process.FlowingDocLogger 中的静态方法

info(String) - 接口 com.trs.components.common.publish.domain.taskdispatch.IPublishProgressMonitor 中的方法
纪录或者输出运行时的信息
info(String) - 类 com.trs.components.common.publish.domain.taskdispatch.ProgressMonitorImpl 中的方法

INFO - 类 com.trs.infra.support.log.LogType 中的静态变量
日志类型:信息
INFO_ERROR_MSG - 类 com.trs.infra.util.ExceptionNumber 中的静态变量
使用该错误号以告知应用代码,信息提示需要特殊处理.
INFO_GET_TYPE_BYSELF - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量

INFO_GET_TYPE_EMAIL - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量

INFO_GET_TYPE_FIXMAIL - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量

INFO_GET_TYPE_POSTMAIL - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
获取信息的方式
INFO_GET_TYPE_QUICKPOST - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量

INFO_PROVIDER_TYPE_CD - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量

INFO_PROVIDER_TYPE_DISK - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量

INFO_PROVIDER_TYPE_EMAIL - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量

INFO_PROVIDER_TYPE_PAGE - 类 com.trs.components.gkml.sqgk.constant.ApplyFormConstants 中的静态变量
所需信息的指定提供方式
InfoEntities - com.trs.template.persistent 中的 类

InfoEntities() - 类 com.trs.template.persistent.InfoEntities 的构造方法

InfoEntityFinder - com.trs.template.domain 中的 类

InfoEntityFinder() - 类 com.trs.template.domain.InfoEntityFinder 的构造方法

InfoPathFileData - com.trs.components.infoview.extract 中的 类

InfoPathFileData() - 类 com.trs.components.infoview.extract.InfoPathFileData 的构造方法

infoPathToFieldName(String) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法

InfoView - com.trs.components.infoview.persistent 中的 类
TODO Add javadoc for InfoView
InfoView() - 类 com.trs.components.infoview.persistent.InfoView 的构造方法
TODO Add javadoc for InfoView
INFOVIEW_NAVS_ID - 类 com.trs.components.infoview.publish.tagparser.TagParserInfoViewNavs 中的静态变量

InfoViewChnlDocFilterHelper - com.trs.components.infoview.helper 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
单表提取文档集合的功能对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewChnlDocFilterHelper(int) - 类 com.trs.components.infoview.helper.InfoViewChnlDocFilterHelper 的构造方法

InfoViewConfig - com.trs.components.infoview 中的 类

InfoViewConfig() - 类 com.trs.components.infoview.InfoViewConfig 的构造方法

InfoViewConstants - com.trs.components.infoview 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewConstants() - 类 com.trs.components.infoview.InfoViewConstants 的构造方法

InfoViewContext - com.trs.service 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewContext(HttpServletRequest, HttpServletResponse) - 类 com.trs.service.InfoViewContext 的构造方法

InfoViewData - com.trs.components.infoview.persistent 中的 类

InfoViewData() - 类 com.trs.components.infoview.persistent.InfoViewData 的构造方法

InfoViewDataHelper - com.trs.components.infoview 中的 类
获取表单数据项的工具类
InfoViewDataHelper - com.trs.components.infoview.mad 中的 接口
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDataHelperImpl - com.trs.components.infoview.mad 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDataHelperImpl() - 类 com.trs.components.infoview.mad.InfoViewDataHelperImpl 的构造方法

InfoviewDataImportFilter - com.trs.components.infoview.filter 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoviewDataImportFilter() - 类 com.trs.components.infoview.filter.InfoviewDataImportFilter 的构造方法

InfoviewDataProcessor - com.trs.components.infoview 中的 类

InfoviewDataProcessor(User, String) - 类 com.trs.components.infoview.InfoviewDataProcessor 的构造方法

InfoViewDatas - com.trs.components.infoview.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDatas() - 类 com.trs.components.infoview.persistent.InfoViewDatas 的构造方法

InfoViewDatas(int) - 类 com.trs.components.infoview.persistent.InfoViewDatas 的构造方法

InfoViewDatas(User, int, int) - 类 com.trs.components.infoview.persistent.InfoViewDatas 的构造方法

InfoviewDataToolService - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoviewDataToolService() - 类 com.trs.ajaxservice.InfoviewDataToolService 的构造方法

InfoViewDataType - com.trs.components.infoview.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据类型定义对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDataType(int, String, String, int, int) - 类 com.trs.components.infoview.db.InfoViewDataType 的构造方法

InfoViewDataTypes - com.trs.components.infoview.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据定义所支持的所有类型
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDataTypes() - 类 com.trs.components.infoview.db.InfoViewDataTypes 的构造方法

InfoViewDBMgr - com.trs.components.infoview.db 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
元数据结构定义业务对象
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDBMgr() - 类 com.trs.components.infoview.db.InfoViewDBMgr 的构造方法

InfoViewDBStoreServer - com.trs.components.infoview.db 中的 类
TODO Add javadoc for BigTableServer
InfoViewDBStoreServer() - 类 com.trs.components.infoview.db.InfoViewDBStoreServer 的构造方法

InfoViewDocImportService - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
从网关中转过来的数据导入
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDocImportService() - 类 com.trs.service.impl.InfoViewDocImportService 的构造方法

InfoViewDocument - com.trs.components.infoview.persistent 中的 类

InfoViewDocument(HashMap) - 类 com.trs.components.infoview.persistent.InfoViewDocument 的构造方法

InfoViewDocuments - com.trs.components.infoview.persistent 中的 类

InfoViewDocuments(User) - 类 com.trs.components.infoview.persistent.InfoViewDocuments 的构造方法
构造函数
InfoViewDocuments(User, int, int) - 类 com.trs.components.infoview.persistent.InfoViewDocuments 的构造方法
构造函数
InfoViewDocumentServiceProvider - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ChnlDoc相关服务提供者
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDocumentServiceProvider() - 类 com.trs.ajaxservice.InfoViewDocumentServiceProvider 的构造方法

InfoViewDocumentToXML - com.trs.ajaxservice.xmlconvertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
ViewDocument的XML转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewDocumentToXML() - 类 com.trs.ajaxservice.xmlconvertors.InfoViewDocumentToXML 的构造方法

InfoViewEmploy - com.trs.components.infoview.persistent 中的 类
TODO Add javadoc for InfoViewEmploy
InfoViewEmploy() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 的构造方法
TODO Add javadoc for InfoViewEmploy
InfoViewEmployLCListenerForChannel - com.trs.components.wcm.content.domain 中的 类

InfoViewEmployLCListenerForChannel() - 类 com.trs.components.wcm.content.domain.InfoViewEmployLCListenerForChannel 的构造方法

InfoViewEmployMgr - com.trs.components.infoview 中的 类

InfoViewEmployMgr() - 类 com.trs.components.infoview.InfoViewEmployMgr 的构造方法

InfoViewEmploys - com.trs.components.infoview.persistent 中的 类
TODO Add javadoc for InfoViewEmploys
InfoViewEmploys(User) - 类 com.trs.components.infoview.persistent.InfoViewEmploys 的构造方法
TODO Add javadoc for InfoViewEmploys
InfoViewEmploys(User, int, int) - 类 com.trs.components.infoview.persistent.InfoViewEmploys 的构造方法
TODO Add javadoc for InfoViewEmploys
InfoViewEnumCreatorImpl - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewEnumCreatorImpl() - 类 com.trs.service.impl.InfoViewEnumCreatorImpl 的构造方法

InfoViewEnumHelper - com.trs.components.infoview.config 中的 类
InfoView 下拉框,级联菜单相关的工具类，定义了一些全局的静态方法
InfoViewField - com.trs.components.infoview.persistent 中的 类

InfoViewField() - 类 com.trs.components.infoview.persistent.InfoViewField 的构造方法

InfoViewFields - com.trs.components.infoview.persistent 中的 类

InfoViewFields(User) - 类 com.trs.components.infoview.persistent.InfoViewFields 的构造方法

InfoViewFields(User, int, int) - 类 com.trs.components.infoview.persistent.InfoViewFields 的构造方法

InfoViewFieldValueCreatorConfigStartServer - com.trs.components.infoview.helper 中的 类

InfoViewFieldValueCreatorConfigStartServer() - 类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorConfigStartServer 的构造方法

InfoViewFieldValueCreatorFactory - com.trs.components.infoview.helper 中的 类

InfoViewFieldValueCreatorFactory() - 类 com.trs.components.infoview.helper.InfoViewFieldValueCreatorFactory 的构造方法

InfoViewGroup - com.trs.components.infoview.persistent 中的 类
描述自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table
InfoViewGroup() - 类 com.trs.components.infoview.persistent.InfoViewGroup 的构造方法

InfoViewGroups - com.trs.components.infoview.persistent 中的 类

InfoViewGroups(User) - 类 com.trs.components.infoview.persistent.InfoViewGroups 的构造方法

InfoViewGroups(User, int, int) - 类 com.trs.components.infoview.persistent.InfoViewGroups 的构造方法

InfoViewHelper - com.trs.components.infoview 中的 类
InfoView的工具类，定义了一些全局的静态方法
InfoViewInitorImpl - com.trs.service.impl 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewInitorImpl() - 类 com.trs.service.impl.InfoViewInitorImpl 的构造方法

InfoViewMgr - com.trs.components.infoview 中的 类

InfoViewMgr() - 类 com.trs.components.infoview.InfoViewMgr 的构造方法

InfoViewNewQueryHelper - com.trs.components.infoview.helper 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewNewQueryHelper() - 类 com.trs.components.infoview.helper.InfoViewNewQueryHelper 的构造方法

InfoViewQueryHelper - com.trs.components.infoview.helper 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewQueryHelper() - 类 com.trs.components.infoview.helper.InfoViewQueryHelper 的构造方法

InfoViewQueryHelper - com.trs.components.infoview.mad 中的 接口
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewQueryHelperImpl - com.trs.components.infoview.mad 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2002-2008 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewQueryHelperImpl() - 类 com.trs.components.infoview.mad.InfoViewQueryHelperImpl 的构造方法

InfoViewReplyNoticeSender - com.trs.components.infoview 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
表单文档回复通知发送者
如果需要发送邮件,setSendEmail(true);
如果需要发送系统短消息,setSendMessage(true) Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewReplyNoticeSender(InfoView, Document, DocReply) - 类 com.trs.components.infoview.InfoViewReplyNoticeSender 的构造方法

InfoViews - com.trs.components.infoview.persistent 中的 类
TODO Add javadoc for InfoViews
InfoViews(User) - 类 com.trs.components.infoview.persistent.InfoViews 的构造方法
TODO Add javadoc for InfoViews
InfoViews(User, int, int) - 类 com.trs.components.infoview.persistent.InfoViews 的构造方法
TODO Add javadoc for InfoViews
InfoViewSerial - com.trs.components.infoview.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
表单序号
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewSerialGenerator - com.trs.components.infoview.persistent 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
表单编号产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoviewService - com.trs.ajaxservice 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoviewService() - 类 com.trs.ajaxservice.InfoviewService 的构造方法

InfoViewService - com.trs.service.impl 中的 类
自定义表单管理的公共接口定义IInfoViewService的实现
InfoViewService() - 类 com.trs.service.impl.InfoViewService 的构造方法
缺省构造方法
InfoviewSpecailTagParseHelper - com.trs.components.infoview.publish.tagparser 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewTemplateHelper - com.trs.components.infoview.helper 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InfoViewTemplateHelper() - 类 com.trs.components.infoview.helper.InfoViewTemplateHelper 的构造方法

InfoViewView - com.trs.components.infoview.persistent 中的 类
描述自定义表单的一个视图
InfoViewView() - 类 com.trs.components.infoview.persistent.InfoViewView 的构造方法
缺省构造方法
InfoViewViews - com.trs.components.infoview.persistent 中的 类

InfoViewViews(User) - 类 com.trs.components.infoview.persistent.InfoViewViews 的构造方法

InfoViewViews(User, int, int) - 类 com.trs.components.infoview.persistent.InfoViewViews 的构造方法

InfoviewXMLDataUpdator - com.trs.components.infoview.db 中的 类

InfoviewXMLDataUpdator(String) - 类 com.trs.components.infoview.db.InfoviewXMLDataUpdator 的构造方法

INHERIT_ROOT_DETAIL_TEMPLATE - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的静态变量

inheritDBFieldInfo(MetaDBField) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
设置物理字段的信息
inheritExtendFields(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
将当前传入的对象，继承父对象的扩展字段信息
inheritObjectMembers(Channel) - 类 com.trs.cms.auth.domain.RightHostLCListenerForInherit 中的方法

inheritRights(User, IRightHost, boolean) - 类 com.trs.cms.auth.domain.NewRightSet 中的方法
继承父对象的权限
inheritRights(User, IRightHost, boolean) - 类 com.trs.cms.auth.domain.RightSet 中的方法
继承父对象的权限
inhertSpecificFromParent(MethodContext) - 类 com.trs.ajaxservice.ExtendFieldServiceProvider 中的方法
继承父对象指定ID的扩展字段信息
INI_FILENAME - 类 com.trs.infra.support.config.ConfigServer 中的静态变量

init() - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法

init() - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法

init() - 类 com.trs.cms.auth.persistent.AdministratorCacheMgr 中的方法

init() - 类 com.trs.cms.auth.persistent.GroupAdminsCacheMgr 中的方法

init() - 类 com.trs.cms.auth.persistent.GroupUserCacheMgr 中的方法

init() - 类 com.trs.cms.auth.persistent.RoleUserCacheMgr 中的方法

init() - 类 com.trs.cms.auth.persistent.UserCacheMgr 中的方法

init() - 类 com.trs.cms.process.definition.FlowCacheMgr 中的方法

init() - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 中的方法

init() - 类 com.trs.components.common.publish.domain.distribute.FileDistributorFtpCacheMgr 中的方法
已过时。
init() - 类 com.trs.components.common.publish.domain.distribute.PublishDistributionCacheMgr 中的方法

init() - 类 com.trs.components.common.publish.domain.template.TemplateArgumentCacheMgr 中的方法

init() - 类 com.trs.components.common.publish.domain.template.TemplateCacheMgr 中的方法

init() - 类 com.trs.components.common.publish.domain.template.TemplateEmployCacheMgrImpl 中的方法

init(InfoViewConfig) - 类 com.trs.components.infoview.CABFileExtractor 中的方法
TODO Add javadoc for field init
init(InfoViewConfig, Manifest, List, DataType, List) - 类 com.trs.components.infoview.extract.XSLTViewBuilder 中的方法

init(InfoView, InfoViewView) - 类 com.trs.components.infoview.extract.XSLTViewConstrainter 中的方法

init(InfoView, InfoViewView, List, List) - 类 com.trs.components.infoview.extract.XSLTViewConstrainter 中的方法

init() - 类 com.trs.components.metadata.center.MetaDataCenterClassInfoHelper 中的静态方法

init() - 类 com.trs.components.metadata.definition.ClassInfoCacheMgr 中的方法

init() - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

init() - 类 com.trs.components.stat.ChnlDeptMgr 中的方法

init() - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法

init() - 类 com.trs.components.wcm.content.persistent.ChildrenCacheMgr 中的方法

init() - 类 com.trs.components.wcm.content.persistent.ReplaceCacheMgr 中的方法

init() - 类 com.trs.components.wcm.publish.FolderPubStatusCacheMgrImpl 中的方法

init() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedAgent 中的方法
初始化缓冲信息
init(FilterConfig) - 类 com.trs.devhelper.JsCombineFilter 中的方法

init() - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法

init(ServletConfig) - 类 com.trs.infra.StartupServlet 中的方法

init() - 接口 com.trs.infra.support.cache.ICacheMgr 中的方法
初始化当前的Cache
init() - 接口 com.trs.infra.support.cache.ICacheServer 中的方法
初始化系统所有的Cache
init(String, String, String, String, boolean, int) - 类 com.trs.infra.util.ftp.FtpMgr 中的方法

init(String, String, String, String, boolean, int) - 接口 com.trs.infra.util.ftp.IFtpMgr 中的方法
Initiates this ftp manager.
init() - 类 com.trs.infra.util.ResponseBuddy 中的方法

init(String, boolean, String) - 类 com.trs.infra.util.TRSJspAutoTool 中的方法

init(InfoViewContext) - 接口 com.trs.service.IInfoViewInitor 中的方法

init(InfoViewContext) - 类 com.trs.service.impl.InfoViewInitorImpl 中的方法

init(FilterConfig) - 类 com.trs.servlet.CharSetFilter 中的方法

init(FilterConfig) - 类 com.trs.servlet.JspDenyFilter 中的方法

init(FilterConfig) - 类 com.trs.servlet.LoginCheckFilter 中的方法

init() - 类 com.trs.webframework.controler.servlet.NoLoginServiceControler 中的方法

init() - 类 com.trs.weblet.util.verfiycode.VerifyCodeServlet 中的方法

initConfig(ServletContext) - 类 com.wcm.pdf.CreateThreadForPDFOfWins 中的方法

initConnectionPool() - 类 com.trs.components.wcm.content.trsserver.KMTRSServer 中的静态方法

initContext(User) - 类 com.trs.cms.ContextHelper 中的静态方法
初始化时，同时初始化登录用户参数
initConverter(int, int, String) - 类 com.trs.components.common.publish.persistent.template.TempAppendixXmlConverter 中的方法
使用converter时必须初始化一些参数，否则无法正常进行相关操作
initCurrentPage(HttpServletRequest) - 类 com.trs.presentation.util.ResponseHelper 中的方法

initCurrentPage(HttpServletRequest, String, int, int) - 类 com.trs.presentation.util.ResponseHelper 中的方法

initData(HttpServletRequest) - 类 com.trs.components.common.publish.widget.SubjectDataInitHelper 中的静态方法

initDiscovery(File[], File[]) - 类 com.trs.infra.util.WCMDiscoveryFactory 中的静态方法

initExcludeClass() - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法

initFrom(Element, IServiceProvider) - 类 com.trs.webframework.config.MethodConfig 中的方法

initialize() - 类 com.trs.infra.util.uftp.FtpConnectionCache 中的方法
执行初始化操作
initInfoViewTemFileUrls() - 类 com.trs.ajaxservice.InfoviewService 中的方法

initMagicImage(String) - 接口 com.trs.wcm.photo.IMagicImage 中的方法
初始化图片处理对象
initMagicImage(String) - 类 com.trs.wcm.photo.impl.MagicImageImpl 中的方法

initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.DB2AS400DB 中的方法
生成查询一页数据的sql语句
initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.DB2UDB 中的方法
生成查询一页数据的sql语句
initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.DB2UDB2 中的方法
生成查询一页数据的sql语句
initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.DBType 中的方法

initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.MysqlDB 中的方法
生成查询一页数据的sql语句
initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.OracleDB 中的方法
生成查询一页数据的sql语句
initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.SQLServerDB 中的方法
生成查询一页数据的sql语句
initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.SybaseASE 中的方法
生成查询一页数据的sql语句
initQuerySQL(String, int, int) - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的方法
生成查询一页数据的sql语句
InitSetRightScript - 类 com.trs.components.wcm.util.CRightUtil 中的变量

initState() - 类 com.trs.components.stat.BaseStatHandler 中的方法

initState() - 接口 com.trs.components.stat.IStatHandler 中的方法
由于统计Handler处理过程中，需要累积状态，为了能够重复利用此handler，需要在此接口中对已经累积的状态进行清零处理
initTemplateInFlow(InfoView, int) - 类 com.trs.components.infoview.InfoViewMgr 中的方法
在工作流转中初始化表单的模板数据
InnerExceptionNum - com.trs.template 中的 类

InnerExceptionNum() - 类 com.trs.template.InnerExceptionNum 的构造方法

innerText(String) - 类 com.trs.infra.util.CMyString 中的静态方法

INPUT - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

INPUT_TEMPLATE - 类 com.trs.components.common.publish.persistent.template.Template 中的静态变量
已过时。 please use PublishConstants.TEMPLATE_TYPE_NESTED
INPUT_TEMPLATE - 类 com.trs.components.common.publish.persistent.template.Templates 中的静态变量

insert(User) - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.auth.persistent.RightDef 中的方法

insert(User) - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.auth.persistent.User 中的方法
添加用户记录到数据库
insert(User) - 类 com.trs.cms.content.CMSObj 中的方法
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
insert(User) - 类 com.trs.cms.content.ExtendedField 中的方法
添加对象到数据库，重载WCMObj接口
insert(User) - 类 com.trs.cms.process.definition.FlowAction 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.process.definition.FlowCondition 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.process.definition.FlowNode 中的方法
重载父类的insert函数，以便设置产生时间
insert(User) - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.process.definition.FlowRule 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.cms.process.engine.FlowDoc 中的方法
重载父类的insert函数，以便设置产生时间
insert(User) - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.address.Contact 中的方法
添加对象到数据库
insert(User) - 类 com.trs.components.common.address.ContactGrp 中的方法
添加对象到数据库
insert(User) - 类 com.trs.components.common.bookmark.BookMark 中的方法
添加对象到数据库
insert(User) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
添加对象到数据库
insert(User) - 类 com.trs.components.common.bookmark.MarkShare 中的方法
添加对象到数据库
insert(User) - 类 com.trs.components.common.calendar.Event 中的方法
添加对象到数据库
insert(User) - 类 com.trs.components.common.calendar.EventShare 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.calendar.EventType 中的方法

insert(User) - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.job.Schedule 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.message.Message 中的方法
添加对象到数据库
insert(User) - 类 com.trs.components.common.message.MsgQueue 中的方法

insert(User) - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
添加模板附件对象到数据库
insert(User) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
添加模板对象到数据库
insert(User) - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.Layout 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.Master 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.Widget 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.trsad.ADCom 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.trsad.ADFile 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.trsad.ADFilePos 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.trsad.ADPos 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.common.trsad.ADType 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.metadata.center.MetaViewData 中的方法

insert() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

insert(User) - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.metadata.definition.MetaView 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.special.Special 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.stat.BonusRule 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.stat.ChnlDept 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.stat.DocumentHitsCount 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.stat.HostObjDomain 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.stat.HostObjHitsCount 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.stat.UserLoginInfo 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

insert(User) - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.content.persistent.DocBak 中的方法

insert(User) - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
添加记录到数据库 为了设置产生时间特重载
insert(User) - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.content.persistent.Relation 中的方法

insert(User) - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.customize.UserSetting 中的方法
添加对象到数据库
insert(User) - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.individuation.Individuation 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法

insert() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法

insert(User) - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.recent.Recent 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.resource.DocKind 中的方法

insert(User) - 类 com.trs.components.wcm.resource.FileType 中的方法

insert(User) - 类 com.trs.components.wcm.resource.Keyword 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.resource.Security 中的方法

insert(User) - 类 com.trs.components.wcm.resource.Source 中的方法

insert(User) - 类 com.trs.components.wcm.resource.Status 中的方法

insert(User) - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.stat.StatHost 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.stat.StatView 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
将对象数据写入数据库
insert() - 类 com.trs.infra.persistent.BaseObj 中的方法
添加对象记录到数据库 说明：子类可以重载此函数，用以做额外处理
insert() - 类 com.trs.infra.support.config.Config 中的方法

insert() - 类 com.trs.infra.support.log.Log 中的方法
将记录添加到数据库中
insert() - 类 com.trs.infra.support.log.LogBak 中的方法

insert() - 类 com.trs.infra.util.job.JobFailedResult 中的方法

insert(User) - 类 com.trs.wcm.config.PageOperator 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.wcm.old.WCMFormInfo 中的方法
将对象数据写入数据库
insert(User) - 类 com.trs.wcm.photo.Watermark 中的方法
将对象数据写入数据库
INSERT_CHANNEL_CHILDINDEX_QUOTE - 类 com.trs.components.wcm.publish.tagparser.WCMTemplateChildIndexAnalyer 中的静态变量

insertOtherTable(User, String) - 类 com.trs.components.wcm.content.persistent.Document 中的方法

insertOtherTable(User, String) - 类 com.trs.components.wcm.content.persistent.Documents 中的方法

insertStyleTag(Special, Template) - 接口 com.trs.components.common.publish.widget.IWidgetServer 中的方法
专题设置页面风格时所触发的逻辑，将专题所属的首页模板插入含当前页面风格标识的置标，发布时完成风格的切换
insertStyleTag(Special, Template) - 类 com.trs.components.common.publish.widget.WidgetServer 中的方法

instance() - 类 com.trs.cms.content.LockManager 中的静态方法

instance() - 类 com.trs.cms.logger.ObjSysLogger 中的静态方法

instance() - 类 com.trs.components.wcm.epress.EPressConf 中的静态方法

instantiateByClassName(String, Class, Object) - 类 com.trs.infra.util.OptionConverter 中的静态方法
Instantiate an object given a class name.
instantiateByKey(Properties, String, Class, Object) - 类 com.trs.infra.util.OptionConverter 中的静态方法

insureLocalPathExists(String) - 类 com.trs.components.common.publish.domain.publisher.PublishSyncGlobalTuner 中的静态方法
insure the specified path exists
INT - 类 com.trs.infra.util.database.DB2AS400DB 中的静态变量
定义SQL Server中的字段类型：INT
INT - 类 com.trs.infra.util.database.DB2UDB 中的静态变量
定义SQL Server中的字段类型：INT
INT - 类 com.trs.infra.util.database.DB2UDB2 中的静态变量
定义SQL Server中的字段类型：INT
INT - 类 com.trs.infra.util.database.OracleDB 中的静态变量
定义Oracle中的字段类型：INT 和SQLServer
INT - 类 com.trs.infra.util.database.SQLServerDB 中的静态变量
定义SQL Server中的字段类型：INT
INT - 类 com.trs.infra.util.database.SybaseASE 中的静态变量
定义SQL Server中的字段类型：INT
INT - 类 com.trs.infra.util.database.SybaseASEWithJtds 中的静态变量
定义SQL Server中的字段类型：INT
INT - 类 com.trs.infra.util.database.XuguDB 中的静态变量

INTEGER - 类 com.trs.components.common.publish.domain.tagparser.TagBeanAttrInfo.Type 中的静态变量
整数类型的属性，属性值必须是10个数字和减号
INTEGER - 类 com.trs.components.common.publish.domain.tagparser.TemplateParameter.Type 中的静态变量
整数类型的变量，其值必须是10个数字和减号
INTEGER - 类 com.trs.infra.util.database.KingBaseDB 中的静态变量
定义SQL Server中的字段类型：INT
INTEGER - 类 com.trs.infra.util.database.MysqlDB 中的静态变量

INTEGER - 类 com.trs.infra.util.database.XuguDB 中的静态变量

IntegerXMLConvertorImpl - com.trs.webframework.xmlserver.convertors 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
Boolean的ＸＭＬ转换器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IntegerXMLConvertorImpl() - 类 com.trs.webframework.xmlserver.convertors.IntegerXMLConvertorImpl 的构造方法

IntellResLocatorImpl - com.trs.components.wcm.content.domain.intelligence 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IntellResLocatorImpl() - 类 com.trs.components.wcm.content.domain.intelligence.IntellResLocatorImpl 的构造方法

IntelMgrImpl - com.trs.components.wcm.content.domain.intelligence 中的 类
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IntelMgrImpl() - 类 com.trs.components.wcm.content.domain.intelligence.IntelMgrImpl 的构造方法

INVOCATION_DOCUMENTEND_DETECTED - 类 com.trs.webframework.xmlserver.parser.XMLParsingStatus 中的静态变量

INVOCATION_NAME_DETECTED - 类 com.trs.webframework.xmlserver.parser.XMLParsingStatus 中的静态变量

INVOCATION_PARAM_DETECTED - 类 com.trs.webframework.xmlserver.parser.XMLParsingStatus 中的静态变量

INVOCATION_TYPE_DETECTED - 类 com.trs.webframework.xmlserver.parser.XMLParsingStatus 中的静态变量

InvocationObserver - com.trs.webframework.xmlserver.server 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
InvocationObserver() - 类 com.trs.webframework.xmlserver.server.InvocationObserver 的构造方法

InvocationObserver(ServiceContext) - 类 com.trs.webframework.xmlserver.server.InvocationObserver 的构造方法

InvocationTypes - com.trs.webframework.xmlserver.server 中的 类
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListener - com.trs.infra.persistent.listener 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnAdd - com.trs.infra.persistent.listener 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnDel - com.trs.infra.persistent.listener 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectLCListenerOnModify - com.trs.infra.persistent.listener 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObjectMemberMgr - com.trs.cms.auth.domain 中的 接口

IObjLogger - com.trs.cms.logger 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
对象日志对象接口定义
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
IObjTypeLookup - com.trs.infra.persistent 中的 接口

IObserver - com.trs.webframework.xmlserver.server 中的 接口
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IObserverable - com.trs.webframework.xmlserver.server 中的 接口
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IOfficeDocumentService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
Office文档的相关服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IPageStyleMgr - com.trs.components.common.publish.widget 中的 接口
PageStyle业务逻辑层接口
IPageStyleServiceProvider - com.trs.components.common.publish.widget 中的 接口
风格服务层接口
IPageTask - com.trs.components.common.publish.domain.taskdispatch 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
page task interface.
IPageTaskDispatcher - com.trs.components.common.publish.domain.taskdispatch 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
page task dispatcher interface.
IPorterVisitor - com.trs.components.wcm.content.service.portervisitors 中的 接口

IPreNextDocuments - com.trs.components.wcm.publish.domain 中的 接口

IPropertiesBuilder - com.trs.components.web 中的 接口

IPublishContent - com.trs.components.common.publish.persistent.element 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
publish content interface, which is one kind of IPublishElement.
IPublishElement - com.trs.components.common.publish.persistent.element 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
the base interface of publish element, including IPublishFolder and IPublishContent.
IPublishElements - com.trs.components.common.publish.persistent.element 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
publish element collection.
IPublishElementsIterator - com.trs.components.common.publish.domain.taskdispatch 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IPublishFolder - com.trs.components.common.publish.persistent.element 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
publish folder interface, which is one kind of IPublishElement.
IPublishProgressMonitor - com.trs.components.common.publish.domain.taskdispatch 中的 接口
用于监控发布任务的执行进程，其实现应该缓存至少10条信息以供察看。
IPublishService - com.trs.service 中的 接口

IPublishTaskDispatcher - com.trs.components.common.publish.domain.taskdispatch 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
interface for publish task dispatcher.
IPublishTaskDocumentsCacheMgr - com.trs.components.wcm.publish.tagparser 中的 接口

IPublishTaskMgr - com.trs.components.common.publish.domain.taskdispatch 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IQueryFilter - com.trs.components.filter 中的 接口

IQueryFilterFactory - com.trs.components.filter 中的 接口

IQueryServiceProvider - com.trs.webframework.provider 中的 接口

IRecentService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
为“最近处理的对象” 提供的服务层接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRelateResource - com.trs.components.wcm.publish.element 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
相关文件
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
IRequestProcessor - com.trs.webframework.xmlserver.server 中的 接口
Title: TRS 内容协作平台（TRS WCM 6.0）
Description:
TODO
Copyright: Copyright (c) 2005-2006 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IResourceService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
配置资源服务提供对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IResourceStyleMgr - com.trs.components.common.publish.widget 中的 接口
资源可用风格业务逻辑层接口
IResourceStyleServiceProvider - com.trs.components.common.publish.widget 中的 接口
资源可用风格服务层接口
IRightHost - com.trs.cms.auth.domain 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
可设置权限的对象接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRightMgr - com.trs.cms.auth.domain 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRightObj - com.trs.cms.auth.domain 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IRoleService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
角色相关服务提供对象的接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IS_CONSOLE_TEST - 类 com.trs.webframework.context.ServiceContext 中的静态变量

IS_DEBUG - 类 com.trs.cms.process.FlowServer 中的静态变量
调试开关
IS_DEBUG - 类 com.trs.components.common.publish.domain.tagparser.TagDocumentReader 中的静态变量
debug modal switch
IS_DEBUG - 类 com.trs.components.wcm.content.trsserver.OuterKMTRSServer 中的变量

IS_DEBUG - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的变量

IS_DEBUG - 类 com.trs.components.wcm.stat.domain.TimingChartData 中的静态变量

IS_DEBUG - 类 com.trs.infra.persistent.BaseObjs 中的静态变量
调试模式开关
IS_DEBUG - 类 com.trs.infra.util.CMyUnzip 中的静态变量
调试开关
IS_DEBUG - 类 com.trs.infra.util.CMyZip 中的静态变量
Debug 模式开关
IS_DEBUG - 类 com.trs.infra.util.key.MacAddressHelper 中的静态变量

IS_ORDER_BY_PRI - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的静态变量
记录是否支持置顶功能
IS_WITH_PARENT - 类 com.trs.cms.auth.domain.GroupRightObjImpl 中的静态变量
是否开启子组控制
isAbsoluteURL(String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
判断指定的URL是不是站内地址，即是不是“http://www.abc.com/abc/abc.htm”的形式
isAbsoluteURLinSite(String) - 类 com.trs.infra.util.html.HtmlUtil 中的静态方法
判断指定的URL是不是站内绝对地址，即是不是“/abc/abc.htm”的形式
isAccepted() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
用户是否已经签收
isAccessibleFrom(IPublishFolder) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
判断从指定目录是否可以访问当前模板
isAccordWith(ExecuteContext, FlowCondition) - 类 com.trs.cms.process.engine.handlers.ContentPropertyHandler 中的方法

isAccordWith(ExecuteContext, FlowCondition) - 类 com.trs.cms.process.engine.handlers.OverTimeHandler 中的方法

isAccordWith(ExecuteContext, FlowCondition) - 接口 com.trs.cms.process.engine.IConditionHandler 中的方法
是否与设定的条件相符合?
isAddMark() - 类 com.trs.wcm.photo.ImageInfo 中的方法

isAddMode() - 类 com.trs.infra.persistent.BaseObj 中的方法
检测当前对象是否处于新增模式。
isAddMode() - 类 com.trs.wcm.photo.ImageInfo 中的方法

isAddVersion() - 类 com.trs.components.metadata.center.xml.MetaViewDataToExcel 中的方法

isAddVersion() - 类 com.trs.infra.persistent.BaseObjToXmlConverter 中的方法

isAdManagerEnable() - 类 com.trs.components.common.conjection.service.AdmanageConfigServiceImpl 中的方法

isAdManagerEnable() - 接口 com.trs.components.common.conjection.service.IAdmanageConfigService 中的方法

isAdministrator(Group, User, boolean) - 类 com.trs.cms.auth.domain.GroupMgr 中的方法
判断某个用户是否为某个组织的组管理员
isAdministrator(User) - 类 com.trs.cms.auth.persistent.Group 中的方法
判断用户是否是本组的管理员
isAdministrator() - 类 com.trs.cms.auth.persistent.GroupUser 中的方法

isAdministrator() - 类 com.trs.cms.auth.persistent.User 中的方法
判断用户是否是系统管理员
isAdministrators() - 类 com.trs.cms.auth.persistent.Role 中的方法
判断角色是否为系统管理员 说明：判断的依据，是固定ID=1(由系统预定义的)
isAdminOfGroup(User) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
判断指定用户是否在系统中担任组管理员
isAdminOfGroup(User) - 类 com.trs.service.impl.UserService 中的方法
判断指定用户是否在系统中担任组管理员
isAdminOfGroup(User) - 接口 com.trs.service.IUserService 中的方法
判断指定用户是否在系统中担任组管理员
isAloneTag(String) - 类 com.trs.infra.util.html.HtmlElement 中的静态方法
判断指定的Html元素标记，是否为独立（即自封闭）标记
isAncestor(int, int) - 类 com.trs.components.metadata.definition.ClassInfoMgr 中的方法

isAncestor(int, int) - 接口 com.trs.components.metadata.definition.IClassInfoMgr 中的方法
判断nAncestorId是否为nDescendantId的祖先id
isAncestorOf(HtmlElement) - 类 com.trs.infra.util.html.HtmlElement 中的方法
判断当前元素是否为指定元素的祖先
isAndOperator() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
提取属性：LogicOperator
isAnonymous() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：ANONYMFTP，是否在FTP登录中使用匿名方式 为了避免在某些数据库中可能存在的冲突，所以没有使用“Anonymous”作为字段名，而是使用了“ANONYMFTP”
isApdModified() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
判断模板附件是否修改
isAttachPic() - 类 com.trs.components.wcm.content.persistent.Document 中的方法

isAuth() - 类 com.trs.infra.util.email.SMTPServerConfig 中的方法

isAutoEnable() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
是否启动文档中的图片自动保存到图片库中
isAutoEnable() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

isAutoPublishDocInHomeWhenNeeded() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

isAutoPublishDocInHomeWhenNeeded() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns true if to publish automatically the document who has not been published in its home folder when to publish the link of it.
ISaveServiceProvider - com.trs.webframework.provider 中的 接口

isBackReadOnly() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isBatch() - 类 com.trs.components.common.publish.domain.taskdispatch.BatchDetailPageTask 中的方法

isBatch() - 接口 com.trs.components.common.publish.domain.taskdispatch.IPageTask 中的方法
Returns true if this task is a batch task.
isBatch() - 类 com.trs.components.common.publish.domain.taskdispatch.PageDestoryTask 中的方法

isBatch() - 类 com.trs.components.common.publish.domain.taskdispatch.SinglePageTask 中的方法

isBelongToSite(User, WebSite) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
判断指定的用户是否属于指定的站点
isBelongToSite(Group, WebSite) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
判断指定的用户组是否属于指定的站点
isBelongToSite(Role, WebSite) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
判断指定的角色是否属于指定的站点
isBelongToSite(CMSObj, WebSite) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法
判断指定的对象是否属于指定的站点
isBlock() - 类 com.trs.infra.util.html.HTML.Tag 中的方法
Block tags are tags that add structure to a document.
isBOF() - 类 com.trs.infra.persistent.BaseObjs 中的方法
判断当前位置是否为POS_BOF
isCached() - 类 com.trs.infra.persistent.BaseObj 中的方法
是否为缓冲对象
isCached() - 类 com.trs.infra.persistent.BaseObjs 中的方法
是否为缓冲对象
isCached(Class) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法

isCached(String) - 类 com.trs.infra.persistent.cache.CachedPOMgr 中的方法

isCached(Class) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法

isCached(String) - 接口 com.trs.infra.persistent.cache.ICachedPOMgr 中的方法

isCancel() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法

isCanceld() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskAnalyzer 中的方法
Returns true if this analyzer has been canceled.
isCanDoSave(User) - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
指定用户是否可以保存当前对象
isCanDoSave(User) - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

isCanDoSave(User) - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

isCanDoSave(User) - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

isCanDoSave(User) - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

isCanDoSave(User) - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

isCanDoSave(User) - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

isCanDoSave(User) - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

isCanDoSave(User) - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

isCanDoSave(User) - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

isCanDoSave(User) - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

isCanDoWithDoc(int) - 类 com.trs.cms.process.definition.FlowNode 中的方法
判断能够进行指定类型的文档操作
isCanInFlow(IFlowContent) - 类 com.trs.cms.process.FlowServer 中的方法

isCanInFlow(int, int) - 类 com.trs.service.impl.WCMProcessServiceImpl 中的方法

isCanInFlow(int, int) - 接口 com.trs.service.IWCMProcessService 中的方法

isCanPub() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
判断是否允许发布
isChangeProperty(String) - 类 com.trs.infra.persistent.BaseObj 中的方法
Returns true if the value of the specified property is changed.
isCharData() - 类 com.trs.infra.util.database.DataType 中的方法
判定是否为字符类型
isCheckWriteAuth() - 类 com.trs.infra.util.ftp.FtpMgr 中的方法
获取初始化的时候是否需要校验写权限
IScheduleService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
计划调度服务
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
isChineseChar(int) - 类 com.trs.infra.util.CMyString 中的静态方法
判断指定的字符是不是汉字，目前是通过判断其值是否大于7FH实现的。
isClickPreview() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
判断点击文档时是否直接预览页面
isCluster() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

isCmdUsed() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法

isCmdUsed() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

isComplexType() - 类 com.trs.components.infoview.extract.DataType 中的方法

isConnected() - 类 com.trs.infra.util.ftp.CMyFtp 中的方法
判断当前的连接是否存在或有效
isContainChineseChar(String) - 类 com.trs.infra.util.CMyString 中的静态方法
判断字符串中是否包含中文字符
如果包含,则返回 true
isContainsChildren() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

isContainsChildrenChnl() - 类 com.trs.components.stat.ChnlDept 中的方法
提取属性：ContainsChildrenChnl
isContentType(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
Returns true if the specified type is a content.
isDBKeyWords(String) - 类 com.trs.infra.util.database.CDBKeyWords 中的静态方法

ISDEBUG - 类 com.trs.infra.util.database.DBIdManager 中的静态变量

ISDEBUG - 类 com.trs.infra.util.html.HtmlElement 中的静态变量
调试模式开关
isDefault() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
提取属性:IsDefault
isDefaultNotNullType() - 类 com.trs.components.infoview.extract.DataType 中的方法

isDefaultURI() - 类 com.trs.webframework.config.MethodConfig 中的方法

isDefaultView() - 类 com.trs.components.infoview.extract.manifest.View 中的方法

isDefaultView() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回该视图是否缺省视图
isDefineFileRule() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：DefineFileRule
isDefineRightOnDocument(Document) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法
判断当前文档是否自定义了权限
isDefineRightOnDocument(int) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法

isDefineSchedule() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：DefineSchedule
isDefineStatus() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性：DefineStatus
isDeleted() - 类 com.trs.cms.auth.persistent.User 中的方法
提取属性:ISDELETED
isDeleted() - 接口 com.trs.cms.process.IFlowContent 中的方法

isDeleted() - 类 com.trs.components.common.job.Schedule 中的方法
判断计划是否已经被删除
isDeleted() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法
是否已经被假删除
isDeleted() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

isDeleted() - 类 com.trs.components.gkml.sqgk.process.element.FlowContentApplyFormImpl 中的方法

isDeleted() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

isDeleted() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
是否为被删除的附件
isDeleted() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
判断站点/频道是否已被删除(在回收站中)
isDeleted() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
是否为被删除了的ChnlDoc
isDeleted() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
判断文档是否已经被删除
isDeleted() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

isDeleted() - 类 com.trs.components.wcm.process.element.FlowContentDocumentImpl 中的方法

isDeleted() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

isDeleted() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

isDeleteFlag() - 类 com.trs.components.comment.domain.CommentUpdator 中的方法

isDepartmentAdmin(User) - 类 com.trs.cms.auth.domain.DepartmentMgrImpl 中的方法

isDepartmentAdmin(User) - 接口 com.trs.cms.auth.domain.IDepartmentMgr 中的方法
判断用户是否是所在用户组的管理员
isDetailPageSeperateTo51Style() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

isDetailPageSeperateTo51Style() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法

isDirDividedByDate() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

isDirDividedByDate() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns true if the publish directory is divided by date.
isDirectory() - 类 com.trs.infra.util.jazzlib.ZipEntry 中的方法
Gets true, if the entry is a directory.
isDocumentObject() - 类 com.trs.components.wcm.content.persistent.Document 中的方法

isDocumentsGetOptimize() - 类 com.trs.components.wcm.WCMAppConfig 中的方法

isDocumentSynChnlDoc() - 类 com.trs.components.wcm.WCMAppConfig 中的方法

isDocumentTopped(Document, Channel) - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
判断一个频道下的文档是否是处于置顶状态
isDocumentTopped(Document, Channel) - 接口 com.trs.service.IDocumentService 中的方法
判断一个频道下的文档是否是处于置顶状态
应用层可以利用这个接口，在文档列表前加上图片标识
isDocumentTopped(Document, Channel) - 类 com.trs.service.impl.DocumentService 中的方法

isDocumentTopScheduled(Document, Channel) - 接口 com.trs.service.IDocumentService 中的方法
判断频道下的文档如果置顶的话，是否已经加入了计划调度
isDocumentTopScheduled(Document, Channel) - 类 com.trs.service.impl.DocumentService 中的方法

isDoDelete() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
判断文档是否正在进行删除的操作
即判断文档是否从未删除状态变为了已删除状态
实际的判断逻辑是：如果前后状态的乘积小于0，且文档原先不是已删除状态，则为正在删除
isDoDeptFilter() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
栏目文档列表是否做所属部门的过滤
isDoMove() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
判断文档是否正在进移动的操作
即判断文档频道是否发生了修改
isDoNotify(int, Object, Object[]) - 类 com.trs.cms.process.definition.FlowEmployCacheMgr 中的方法

isDoNotify(BaseObj) - 类 com.trs.components.wcm.content.persistent.ChannelNameMgr 中的方法

isDoNotify(int, BaseObj) - 类 com.trs.infra.persistent.listener.ObjectLCMonitorServer 中的方法

isDoOperation() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
提取属性：DoOperation
isDoRecover() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
判断文档是否正在进行从回收站中恢复的操作
即判断文档是否从已删除状态变为了未删除状态
实际的判断逻辑是：如果前后状态的乘积小于0，且文档原先是已删除状态，则为正在恢复
isDowithClob() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

isDraft() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
hanxiao@041012 判断文档是否是草稿
ISecurityService - com.trs.service 中的 接口

isEditable() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法

isEditorField(MetaViewField) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法
判断是否为编辑器字段
isEditorField(int, String) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法
判断是否为编辑器字段
isEditorField(MetaViewField) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

isEditorField(int, String) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

ISelfDefinedServiceProvider - com.trs.webframework.provider 中的 接口

isEmpty() - 类 com.trs.components.common.publish.domain.template.TemplateEmployDetail 中的方法

isEmpty() - 接口 com.trs.components.common.publish.persistent.element.IPublishElements 中的方法
Returns true if this collection contains no elements.
isEmpty() - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSListImpl 中的方法

isEmpty() - 类 com.trs.components.common.publish.persistent.element.PublishElementsCMSObjsImpl 中的方法

isEmpty() - 类 com.trs.components.common.publish.persistent.element.PublishElementsListImpl 中的方法

isEmpty() - 类 com.trs.infra.persistent.BaseObjs 中的方法
判断集合是否存在元素
isEmpty() - 类 com.trs.infra.util.CMyErrors 中的方法
判断是否为空
isEmpty(String) - 类 com.trs.infra.util.CMyString 中的静态方法
判断指定字符串是否为空
isEmptyOfParameterValues() - 类 com.trs.webframework.context.MethodContext 中的方法

isEmptyStr(String) - 类 com.trs.infra.util.CMyString 中的静态方法
已过时。 由函数 isEmpty 替换
isEmptyTag(String) - 类 com.trs.wcag2.HTMLUtil 中的静态方法

isEnable() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
提取属性：Enable
isEnableAutoCheck() - 接口 com.trs.components.ckm.ICKMServer 中的方法
是否开启自动校对
isEnableAutoCheck() - 类 com.trs.components.ckm.TRSCKMServer 中的方法

isEnableAutoExtract() - 接口 com.trs.components.ckm.ICKMServer 中的方法
是否开启自动抽取
isEnableAutoExtract() - 类 com.trs.components.ckm.TRSCKMServer 中的方法

isEnabled() - 类 com.trs.components.common.message.notify.NotificationSchemeConfig 中的方法

isEnabled() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
提取属性：Enabled
isEnabled() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
Returns the value of property Enabled.
isEnabled() - 类 com.trs.infra.util.CMyTimer 中的方法
判断是否允许使用
isEnableSimSearch() - 接口 com.trs.components.ckm.ICKMServer 中的方法
是否开启相似性检索
isEnableSimSearch() - 类 com.trs.components.ckm.TRSCKMServer 中的方法

isEncrypted() - 类 com.trs.infra.support.config.Config 中的方法
判断配置是否加密
isEnd() - 类 com.trs.cms.process.engine.ContentProcessInfo 中的方法

isEndNode() - 类 com.trs.cms.process.definition.FlowNode 中的方法
判断该节点是否为所在工作流的结束节点
ISendWorker - com.trs.components.common.message 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
发送者接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
isEnterDirectly() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
提取属性：EnterDirectly
isEntity() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
判断当前ChnlDoc是否为实体
isEOF() - 类 com.trs.infra.persistent.BaseObjs 中的方法
判断当前位置是否为POS_EOF
IServer - com.trs.infra 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IServiceFilter - com.trs.webframework.provider 中的 接口

IServiceListener - com.trs.webframework.provider 中的 接口

IServiceProvider - com.trs.webframework.provider 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
标志接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
isEveryone() - 类 com.trs.cms.auth.persistent.Role 中的方法
判断角色是否为Everyone角色，默认包含所有的人 说明：判断的依据，是固定ID=2(由系统预定义的)
isExcludeClass(String) - 类 com.trs.infra.util.CopyOfTRSImportsOrgnize 中的静态方法

isExcludeClass(String) - 类 com.trs.infra.util.TRSImportsOrgnize 中的静态方法

isExcludeDir(String) - 类 com.trs.tools.SymbolC2E 中的静态方法

isExcludeFile(String) - 类 com.trs.tools.SymbolC2E 中的静态方法

isExcludeValue(String) - 类 com.trs.webframework.config.TRSPageParameter 中的方法

isExecuted() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
check if this task has been executed
isExistsRight(int, int) - 类 com.trs.cms.auth.domain.RightCacheMgr 中的方法

isField(String) - 类 com.trs.infra.util.database.TableInfo 中的方法
检测某个字段是否存在于指定的表
isField(String, String) - 类 com.trs.infra.util.database.TableInfos 中的方法
检测某个字段是否存在于指定的表
isFieldWithType(int, String, int) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法
判断当前字段类型是否符合指定的类型
isFieldWithType(int, String, int) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

isFile() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法

isFile() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

isFile() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

isFile() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

isFileNameByBaseObj() - 类 com.trs.infra.util.TRSJspAutoTool 中的方法

isFinished() - 类 com.trs.components.common.job.Schedule 中的方法
判断任务是否已经执行结束
isFixedParameter(String) - 类 com.trs.components.common.publish.widget.WidgetConstants 中的静态方法
判断是否是固有变量
isFolder() - 类 com.trs.components.common.publish.config.PublishElementType 中的方法
Returns true if this type is a folder.
isFolder() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
Returns true if current element is a folder.
isFolder() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

isFolder() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

isFolder() - 类 com.trs.components.common.publish.persistent.element.PublishFolderImplBase 中的方法

isFolder() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

isFolderType(int) - 类 com.trs.components.common.publish.persistent.element.PublishElementFactory 中的静态方法
Returns true if the specified type is a folder.
isForbidden() - 类 com.trs.cms.auth.persistent.User 中的方法
判断用户是否被停用
isForceFirstLoadIds() - 类 com.trs.infra.db.QueryFilter 中的方法

isForceFirstLoadIds() - 类 com.trs.infra.persistent.WCMFilter 中的方法

isForceKick() - 类 com.trs.presentation.util.LoginHelper 中的方法

isFromMainTable() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
是否来自于主表
isFromMultiTable() - 类 com.trs.infra.persistent.WCMFilter 中的方法

isFromRecycle() - 类 com.trs.components.metadata.center.MetaViewDatas 中的方法

isFromRecycle() - 类 com.trs.components.wcm.content.ViewDocuments 中的方法

isFromRule() - 类 com.trs.cms.process.engine.FlowContext 中的方法

isFromTable() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
参数是否为FromTable
isGetPropertyFromNew() - 类 com.trs.infra.persistent.BaseObj 中的方法

isGovInfoView(MetaView) - 类 com.trs.components.govinfo.GovInfoViewFinder 中的静态方法

isHasMapping() - 类 com.trs.infra.util.xml.XmlObjectPersistentor 中的方法
mack it known that if the mashall/unmarshall has mapping src
isHasRight(int) - 类 com.trs.cms.auth.persistent.RightValue 中的方法
判断对指定权限索引是否具有权限
isHasWarnings() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
提取属性：HasWarnings
isHaveRelation(Connection, int) - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
判断模板与附件是否关联
isHidden() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法

isHidden() - 类 com.trs.infra.util.cabfile.CabEntry 中的方法

isHiddenAppendix() - 类 com.trs.components.metadata.definition.MetaView 中的方法

isIdentityField() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：IdentityField
isIgnoreIfHostNotFound() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

isIgnoreIfHostNotFound() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns true if to ignore the error when the host is not found in tag item; false otherwise.
isImportToCurrChannel() - 类 com.trs.components.metadata.center.xml.MetaViewDataImporter 中的方法

isImportWithFlowNodeFields() - 类 com.trs.cms.process.xml.FlowImporter 中的方法

isImportWithInfoviewId() - 类 com.trs.cms.process.xml.FlowImporter 中的方法

isImportWithOptMarkEnum() - 类 com.trs.cms.process.xml.FlowImporter 中的方法

isInDetail() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：InDetail
ISINDEX - 类 com.trs.infra.util.html.HTML.Tag 中的静态变量

isInfoGetType(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
判断是否是某种获取信息的方试
isInfoProviderType(int) - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
判断是否是某种所需信息的指定提供方式
isInfoViewDefaultField(String) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法

isInfoViewDocument() - 类 com.trs.components.infoview.persistent.InfoViewDocument 中的方法

isInheritDetail() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
是否继承父频道的细览模板
isInheritExtend() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
是否继承父系的扩展字段
isInheritOutline() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
是否继承父频道的概览模板
isInheritRight() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
是否继承父系的权限
isInMultiTable() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法

isInnerMulti() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：InnerMulti
isInnerType() - 类 com.trs.components.infoview.extract.DataType 中的方法

isInOutline() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：InOutline
isInRelatedTopic(int, int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法

isInRelatedTopic(String, int) - 类 com.trs.components.comment.domain.DocumentTopicRelationMgr 中的方法

isInRelatedTopic(String, int) - 类 com.trs.components.comment.service.CommentService 中的方法

isInRelatedTopic(String, int) - 接口 com.trs.components.comment.service.ICommentService 中的方法

isInstalled() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法

isInstalled() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

isIPAddress(String) - 类 com.trs.infra.util.RemoteAddrUtil 中的静态方法

isIsChecked() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
提取属性：IsChecked
isIsShared() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
提取属性：IsChecked
isJava1() - 类 com.trs.infra.util.Loader 中的静态方法
Are we running under JDK 1.x?
isKeyWordedParam(String) - 类 com.trs.webframework.FrameworkConstants 中的静态方法

isKeywords(String) - 类 com.trs.infra.persistent.db.DBManager 中的方法
校验当前字段名是否为数据库关键字
isLast() - 类 com.trs.presentation.navigation.TreeItem 中的方法

isLeaf() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
是否是叶子节点
isLeapYear() - 类 com.trs.infra.util.CMyDateTime 中的方法

isLengthDefinedByUser() - 类 com.trs.infra.util.database.DataType 中的方法
判定长度是否由用户定义
isLink() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法

isLink() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

isLink() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

isLink() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

isLink() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
Returns true if the type of this channel is link.
isLink() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

isLink() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

isLink() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

isLink() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

isListByTimeRange() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法

isListByTimeRange(boolean) - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
判断频道是否指定了时间约束 *
isLoaded() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的方法

isLoaded() - 类 com.trs.infra.util.database.CDBText 中的方法
判断是否装载了数据
isLocked() - 类 com.trs.cms.content.CMSObj 中的方法
检测当前是否已经锁定
isLocked() - 类 com.trs.cms.content.Locker 中的方法
检测当前是否已经锁定； 注意：如果上次加锁超时，自动解锁
isLogged() - 类 com.trs.webframework.config.MethodConfig 中的方法

isLogin(HttpServletRequest) - 接口 com.trs.webframework.controler.servlet.ILoginValidator 中的方法
判断当前是否已经登录
isLogin(HttpServletRequest) - 类 com.trs.webframework.controler.servlet.LoginValidatorDefaultImpl 中的方法

isLogin(HttpServletRequest) - 类 com.trs.webframework.controler.servlet.LoginValidatorThreadLocalImpl 中的方法

isLogined() - 类 com.trs.cms.auth.persistent.User 中的方法
判断用户是否已经登录
isManagerOfRole(User) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
判断指定用户是否在系统中担任角色维护员
isManagerOfRole(User) - 类 com.trs.service.impl.UserService 中的方法
判断指定用户是否在系统中担任角色维护员
isManagerOfRole(User) - 接口 com.trs.service.IUserService 中的方法
判断指定用户是否在系统中担任角色维护员
isManagerOfUser(User, User) - 类 com.trs.cms.auth.domain.AuthServer 中的静态方法
判断当前用户loginUser是否可以管理用户_dstUser
isManagerOfUser(User) - 类 com.trs.cms.auth.domain.UserMgr 中的方法
判断当前登录用户是否能够管理指定的用户
ISMAP - 类 com.trs.infra.util.html.HTML.Attribute 中的静态变量

isMark(char) - 类 com.trs.components.wcm.content.trsserver.TRSSearchUtil 中的静态方法
返回当前字符是否为标点符号
isMergeFile() - 类 com.trs.infra.util.TRSJspAutoTool 中的方法

isMessageReaded(Message, User) - 类 com.trs.components.common.message.MessageServer 中的静态方法
获得用户所接收消息的状态
状态包括已读和未读，通过状态标志来返回
isModified(boolean) - 类 com.trs.components.metadata.definition.MetaView 中的方法

isModified() - 类 com.trs.infra.persistent.BaseObj 中的方法

isModified(boolean) - 类 com.trs.infra.persistent.BaseObj 中的方法

isModifyColumnProperties(boolean) - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
是否修改了栏目属性（长度、默认值、是否为空、位数）
isMultiTable() - 类 com.trs.components.metadata.definition.MetaView 中的方法
是否为多表
isNeedPostTogether() - 类 com.trs.cms.process.definition.FlowNode 中的方法
判断是否需要会签
isNeedStartup() - 接口 com.trs.components.ckm.ICKMServer 中的方法

isNeedStartup() - 类 com.trs.components.ckm.TRSCKMServer 中的方法

isNestedTemplateTag(String) - 类 com.trs.components.common.publish.domain.tagparser.TagParserFactory 中的静态方法
Returns true if the specified tag is nested template.
isNewtable() - 类 com.trs.infra.util.upgrade.dbcompare.TableDiff 中的方法
是否是新建的表
isNillable() - 类 com.trs.components.infoview.extract.DataType 中的方法

isNillable() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isNormType() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
判断是否是普通频道
isNotifyBy(int) - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
判断是否设定了指定的通知方式
isNotNull() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：NotNull
isNotNull() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：NotNull
isNotUsed() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法

isNull() - 类 com.trs.infra.util.CMyDateTime 中的方法
判断时间对象是否为空
isNull() - 类 com.trs.infra.util.database.CDBText 中的方法
判断文本内容是否为空
isNullable() - 类 com.trs.cms.content.ExtendedField 中的方法
判断扩展字段是否允许为空
isNullable() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
判断扩展字段是否允许为空
isNullable() - 类 com.trs.infra.util.database.FieldInfo 中的方法
判断是否允许空
ISOAPService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
isOnDetailPage() - 类 com.trs.components.common.publish.domain.taskdispatch.SinglePageTask 中的方法

isOnlyCached() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

isOnlyManager() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
是否只作为管理节点
isOnlySearch() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
是否只使用检索条件
isOpenCKMServer() - 类 com.trs.components.ckm.TRSCKMServer 中的方法

isOperationMarkEnable() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法

isOrderBy() - 类 com.trs.webframework.config.TRSPageParameter 中的方法

isOriginalMarked() - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法

isOriginalMarked() - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

isOuterMulti() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：OuterMulti
isOuterPublic() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：OuterPublic
isOutlineField() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isOutUp() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
判别文档是否来自外部上传
isOverMaxErrNum(int) - 类 com.trs.presentation.util.LoginHelper 中的方法
判断用户有登录错误次数是否超过系统配置的最大次数 系统配置小于等于0，则不限制错误次数
isPageParametersEmpty() - 类 com.trs.webframework.config.MethodConfig 中的方法

isParamsRequired() - 类 com.trs.webframework.config.MethodConfig 中的方法

isParsed() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法

ISpecialMgr - com.trs.components.special 中的 接口

ISpecialServiceProvider - com.trs.components.special 中的 接口

isPreformatted() - 类 com.trs.infra.util.html.HTML.Tag 中的方法

isPreview() - 类 com.trs.components.common.publish.domain.publisher.PublishPageContext 中的方法

isPreview() - 类 com.trs.components.common.publish.domain.publisher.PublishTagContext 中的方法

isPreview() - 类 com.trs.components.common.publish.domain.publisher.PublishTaskContext 中的方法
Returns true if on preview mode.
isPublicFill() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isPublicFill() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

isPublicFill() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回该视图是否公共可填写，即是否发布到公网
isPublicPasswordRequired() - 类 com.trs.components.infoview.InfoViewConfig 中的方法

isPublicView() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isPublicView() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

isPublicView() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回该视图的数据是否任何人都可以查看 注意：到2006.07.13，尚未实现
isPublishAllViews() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

isPublishContent() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法

isPublished() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法

isPublishedInHome() - 接口 com.trs.components.common.publish.persistent.element.IPublishContent 中的方法
Returns true if this content has been published in its home folder.
isPublishedInHome() - 类 com.trs.components.common.publish.persistent.element.PublishContentDefaultObjImpl 中的方法

isPublishedInHome() - 类 com.trs.components.common.publish.persistent.element.PublishContentWrapper 中的方法

isPublishedInHome() - 类 com.trs.components.metadata.publish.PublishContentViewDataImpl 中的方法

isPublishedInHome() - 类 com.trs.components.metadata.publish.PublishContentViewFieldImpl 中的方法

isPublishedInHome() - 类 com.trs.components.metadata.publish.PublishContentViewImpl 中的方法

isPublishedInHome() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

isPublishFolder() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法

isPublishInRootPath() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

isPublishInRootPath() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
是否直接将文件发布到站点的根目录下
isPublishTypeOfContent(int) - 类 com.trs.components.common.publish.PublishConstants 中的静态方法
check if a publish type is a folder publish type
isPublishTypeOfFolder(int) - 类 com.trs.components.common.publish.PublishConstants 中的静态方法
check if a publish type is a folder publish type
isPubMyInfo() - 类 com.trs.cms.auth.persistent.User 中的方法
判断是否公开个人信息
isQueue(User) - 类 com.trs.components.common.message.Message 中的方法
判断消息是否在队列中
isRadioOrCheck() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
提取属性：radioOrCheck
isRadioOrCheck() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：radioOrCheck
isRangedFromGroup() - 类 com.trs.cms.process.engine.AbstractToUsersCreator 中的方法

isRangedFromGroup() - 类 com.trs.cms.process.engine.creators.GroupMembersAsToUsersCreator 中的方法

isRangedFromGroup() - 接口 com.trs.cms.process.engine.IToUsersCreator 中的方法
指定是否需要从特定组内选择
isRead() - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法

isReaded() - 类 com.trs.components.common.message.MsgQueue 中的方法
属性: Readed 允许的值有两种 MSGQUEUE_STATE_NOREAD 和 MSGQUEUE_STATE_READ
isReadField() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
判断当前字段是否可读
isReadOnly() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isReadonly() - 类 com.trs.infra.util.cabfile.CabEntry 中的方法

isReadOnly() - 类 com.trs.infra.util.uftp.FtpConnection 中的方法
判断当前连接是不是只读的，即是否可以上传文件
isReadOnly() - 类 com.trs.infra.util.uftp.FtpConnectionImpFtp 中的方法

isReadOnly() - 类 com.trs.infra.util.uftp.FtpConnectionImpSSH 中的方法

isReceived() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
是否已经接收到
isRecordNeeded(BaseObj) - 类 com.trs.infra.support.log.LogServer 中的静态方法

isRecordUsedTime() - 类 com.trs.presentation.util.LoginHelper 中的方法
属性提取：是否记录操作所用时间
isRecursive() - 类 com.trs.infra.util.ConfigElementContentTester 中的静态方法

isRemindBy(int) - 类 com.trs.components.common.calendar.Event 中的方法
是否按指定类型提醒 参数：_nRemindType 提醒类型（常量定义：WCMTypes.REMIND_ONLINE等）
isRemindDone(int) - 类 com.trs.components.common.calendar.Event 中的方法
指定类型的提醒是否已经完成 参数：_nRemindType 提醒类型（常量定义：WCMTypes.REMIND_ONLINE等）
isRemoveable() - 类 com.trs.cms.auth.persistent.Role 中的方法
角色是否可以删除
isReplyNoticeRequired() - 类 com.trs.components.infoview.persistent.InfoView 中的方法
是否需要回复通知
isRequired() - 类 com.trs.presentation.util.PageParameter 中的方法
参数是否需要传入
isRequired() - 接口 com.trs.presentation.valid.IValidator 中的方法
All validators must implement a required property.
isRequired() - 类 com.trs.webframework.config.TRSPageParameter 中的方法
参数是否需要传入
isReserveParameterName(String) - 类 com.trs.webframework.FrameworkConstants 中的静态方法

isResetButton() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

isResetChildrenTemplates() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
提取属性:isResetChildrenTemplates
isResubmit() - 类 com.trs.cms.process.engine.FlowNextBranchInfo 中的方法

isReturnHTML() - 类 com.trs.webframework.context.MethodContext 中的方法

isReturnHTML() - 类 com.trs.webframework.context.ServiceContext 中的方法

isReturnJSON() - 类 com.trs.webframework.context.MethodContext 中的方法
判断当前返回值是否是JSON
isReturnJSON() - 类 com.trs.webframework.context.ServiceContext 中的方法

isRightDefined() - 类 com.trs.components.metadata.center.MetaViewData 中的方法
判断当前文档是否自定义了权限
isRightDefined() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
判断是否单独定义了用户的权限
isRightDefined() - 类 com.trs.components.wcm.content.ViewDocument 中的方法
判断当前文档是否自定义了权限
isRightIndexDefineOnChannel(int, Channel) - 类 com.trs.components.wcm.content.domain.auth.DocumentAuthServer 中的静态方法
判断指定的权限值是否是从当前所属频道进行判断的权限
isRoleManagers(User) - 类 com.trs.cms.auth.domain.RoleMgr 中的方法
判断指定用户是否为角色管理员
isRoleManagers() - 类 com.trs.cms.auth.persistent.Role 中的方法
判断角色是否为角色维护人员角色
isRoot() - 接口 com.trs.components.common.publish.persistent.element.IPublishFolder 中的方法

isRoot() - 类 com.trs.components.common.publish.persistent.element.PublishFolderWrapper 中的方法

isRoot() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法

isRoot() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

isRoot() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

isRoot() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

isRoot() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

isRootComment() - 类 com.trs.infra.util.html.HtmlComment 中的方法
判断是否为根元素
isRootElement() - 类 com.trs.infra.util.html.HtmlElement 中的方法
判断该元素是否为根元素
isRootSchema() - 类 com.trs.components.infoview.extract.manifest.DocumentSchema 中的方法

isRunning() - 类 com.trs.components.common.publish.domain.taskdispatch.PublishTaskDispatcherImpl 中的方法

isRunning() - 类 com.trs.components.common.publish.domain.taskdispatch.TaskDispatcher 中的方法
返回是否正在运行
isSavePubFileByTime() - 类 com.trs.components.wcm.content.persistent.Document 中的方法

isSavePublishConfig() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法

isScheduled() - 类 com.trs.components.wcm.publish.WCMContentPublishConfig 中的方法

isSchedulePublishTask() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
获取ISSCHEDULEDTASK属性,是否为计划发布
isSearch() - 类 com.trs.presentation.util.PageParameter 中的方法

isSearch() - 类 com.trs.webframework.config.TRSPageParameter 中的方法

isSearchField() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isSearchField() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：SearchField
isSelectFields() - 类 com.trs.webframework.config.TRSPageParameter 中的方法

isSelfDefinedMethodName(String) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法

isSelfDefinedMethodName(int) - 类 com.trs.webframework.config.ServiceConfigHelper 中的静态方法

isSendEmail() - 类 com.trs.components.infoview.InfoViewReplyNoticeSender 中的方法

isSendMessage() - 类 com.trs.components.infoview.InfoViewReplyNoticeSender 中的方法

isSendWarningIfFileNotFound() - 类 com.trs.components.common.publish.config.persistent.PublishServerConfig 中的方法

isSendWarningIfFileNotFound() - 类 com.trs.components.common.publish.config.PublishServerConfigMapper 中的静态方法
Returns true if to send warning when file is not found.
isSetTimeRange(int) - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 中的方法

isSetTimeRange(int, int) - 类 com.trs.components.wcm.content.domain.DocumentsTimeRangeMgrImpl 中的方法

isSetTimeRange(int) - 接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr 中的方法
判断是否给指定的频道限定了时间范围
isSetTimeRange(int, int) - 接口 com.trs.components.wcm.content.domain.IDocumentsTimeRangeMgr 中的方法
判断是否给指定的对象限定了时间范围
isShared(User) - 类 com.trs.components.common.bookmark.BookMark 中的方法
是否被共享
isShared(User) - 类 com.trs.components.common.bookmark.MarkKind 中的方法
是否被共享
isShared() - 类 com.trs.components.common.calendar.Event 中的方法
属性: isShareed 是否共享
isShowLegend() - 类 com.trs.components.wcm.stat.domain.ChartStyle 中的方法

isSimpleType() - 类 com.trs.components.infoview.extract.DataType 中的方法

isSingleton() - 类 com.trs.infra.config.persistent.BeanConfig 中的方法

isSinglton(String) - 类 com.trs.DreamFactory 中的静态方法

isSinglton(String) - 类 com.trs.SpringBean 中的方法

ISSITE - 类 com.trs.components.common.trsad.ADPos 中的静态变量

isSite() - 类 com.trs.components.wcm.content.persistent.BaseChannel 中的方法
判断当前对象是否为站点
isSite() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
判断当前对象是否为站点
isSite() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法
判断当前对象是否为站点
isSourceMgr(User) - 类 com.trs.components.wcm.resource.SourceTypeMgr 中的静态方法

isSpecial() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
提取属性：IsSpecial
isSpecialRight() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isSpecialRight() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

isSpecialRight() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法
返回该视图是否单独设置过权限
isSSLServer() - 类 com.trs.infra.util.email.CMySMTPServer 中的方法

isStarted() - 类 com.trs.cluster.ClusterMsgCenterImpl 中的方法

isStarted() - 接口 com.trs.cluster.IClusterMsgCenter 中的方法

isStarted() - 接口 com.trs.components.ckm.ICKMServer 中的方法

isStarted() - 类 com.trs.infra.BaseServer 中的方法
判断Server是否已经启动
isStarted(String) - 类 com.trs.infra.util.HttpGet 中的静态方法

isStarting() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
提取属性：Starting
isStarting() - 类 com.trs.cms.process.engine.FlowContext 中的方法

isStarting() - 类 com.trs.infra.BaseServer 中的方法

isStartNode() - 类 com.trs.cms.process.definition.FlowNode 中的方法
判定该节点是否为所在工作流的起始节点
isStartPhoto() - 类 com.trs.presentation.plugin.PluginConfig 中的静态方法

isStartup() - 类 com.trs.components.common.trsvote.Vote 中的方法
提取属性：Startup
isStartVideo() - 类 com.trs.presentation.plugin.PluginConfig 中的静态方法

isStopped() - 类 com.trs.infra.util.CMyTimer 中的方法
判断是否已经停止
isString() - 类 com.trs.components.metadata.definition.MetaDataType 中的方法

isStringField() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法

ISSUEDAMOUNT_BONUS - 类 com.trs.components.stat.BonusRule 中的静态变量
发稿量类型
isSupportImageFileExt(String) - 接口 com.trs.wcm.photo.IImageLibConfig 中的方法
判断当前图片文件格式是否在系统支持系列中
isSupportImageFileExt(String) - 类 com.trs.wcm.photo.impl.ImageLibConfigImpl 中的方法

isSupportStoredProc() - 类 com.trs.infra.util.database.DBType 中的方法
判断是否支持存储过程
isSysDefined() - 类 com.trs.cms.auth.persistent.RightDef 中的方法

isSysDefined() - 类 com.trs.cms.auth.persistent.Role 中的方法
判断角色是否是系统预定义的
isSystem() - 类 com.trs.cms.auth.persistent.User 中的方法
判断用户是否是系统自定义的用户
isSystem() - 类 com.trs.infra.util.cabfile.CabEntry 中的方法

isSystemField(String) - 类 com.trs.components.infoview.InfoViewHelper 中的静态方法

isSystemRole() - 类 com.trs.cms.auth.persistent.Role 中的方法
判断当前角色是否是系统级角色
isSystemUser() - 类 com.trs.components.common.address.Contact 中的方法

isTaskExecuted(int) - 类 com.trs.components.common.publish.PublishConstants 中的静态方法
check if a task has been executed
isTaskFailed(int) - 类 com.trs.components.common.publish.PublishConstants 中的静态方法
check if a task is failed.
IStatHandler - com.trs.components.stat 中的 接口
StatAnalysisTool工具统计时将调用的工具类，StatAnalysisTool在处理统计结果中的每一条记录时， 将调用visitStatItem接口，同时在该接口调用过程中累积自身状态，最后将通过getResult接口返回统计结果
IStatResult - com.trs.components.stat 中的 接口

IStatResultFilter - com.trs.components.stat 中的 接口
结果集过滤器，用于过滤统计结果集中符合条件的数据
IStatResults - com.trs.components.stat 中的 接口

IStatResultsFilter - com.trs.components.stat 中的 接口

IStatService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
统计应用相关的服务接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
isTestOnAssign() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

isTestOnIdle() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

isTimeOut() - 类 com.trs.cms.content.Locker 中的方法
判断锁定在当前时间是否失效
isTimeOut(Date) - 类 com.trs.cms.content.Locker 中的方法
判断锁定在指定时间内是否失效
isTitleField() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
提取属性：TitleField
isTitleFieldName(int, String) - 接口 com.trs.components.metadata.definition.IMetaDataDefCacheMgr 中的方法

isTitleFieldName(int, String) - 类 com.trs.components.metadata.definition.MetaDataDefCacheMgr 中的方法

isToChnlUser() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
判断文档流转时是否考虑频道的权限
isToday() - 类 com.trs.infra.util.CMyDateTime 中的方法

isToFirst() - 类 com.trs.cms.process.definition.FlowNode 中的方法

isToGetAll() - 类 com.trs.infra.db.QueryFilter 中的方法
判断是否为全集，即没有设定任何筛选条件
isToGetAll() - 类 com.trs.infra.persistent.WCMFilter 中的方法
判断是否为全集，即没有设定任何筛选条件
isTopEnabled() - 类 com.trs.components.wcm.content.domain.DocumentMgr 中的方法
判断置顶功能是否已经激活
> 从系统配置中获取，如果找不到，则从ChnlDoc的缺省配置中取
isTopped() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

isTopped() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法

isTopped() - 类 com.trs.components.wcm.content.ViewDocument 中的方法

isTraceAssign() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

IStyleAndResourceMgr - com.trs.components.common.publish.widget 中的 接口
风格与资源的关联关系业务逻辑类
IStyleCenterMgr - com.trs.components.common.publish.widget 中的 接口

IStyleItemMgr - com.trs.components.common.publish.widget 中的 接口
风格内容项业务逻辑层接口
isUpdated() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
提取属性：Updated
ISureformService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
书生表单服务层
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
isUsed() - 类 com.trs.components.wcm.resource.Status 中的方法
获取是否使用
isUsedByVersion(int) - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
判断该附件是否被指定版本使用
isUsedInChildren() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法

isValid() - 类 com.trs.ajaxservice.ContentExtendValue 中的方法

isValid() - 类 com.trs.cms.auth.persistent.Group 中的方法
检查对象数据的有效性
isValid() - 类 com.trs.cms.auth.persistent.GroupRole 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.auth.persistent.GroupUser 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.auth.persistent.Right 中的方法
效验数据的有效性
isValid() - 类 com.trs.cms.auth.persistent.RightDef 中的方法

isValid() - 类 com.trs.cms.auth.persistent.Role 中的方法
更新前检验数据是否有效
isValid() - 类 com.trs.cms.auth.persistent.RoleUser 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.auth.persistent.TrusteeInfo 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.auth.persistent.User 中的方法
检查对象数据的有效性
isValid() - 类 com.trs.cms.content.CMSObjDefaultImpl 中的方法

isValid() - 类 com.trs.cms.content.DefaultObj 中的方法

isValid() - 类 com.trs.cms.content.ExtendedField 中的方法
检查数据的有效性
isValid() - 类 com.trs.cms.content.WCMSystemObject 中的方法

isValid() - 类 com.trs.cms.process.definition.Flow 中的方法
检查对象数据是否有效
isValid() - 类 com.trs.cms.process.definition.FlowAction 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.process.definition.FlowCondition 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.process.definition.FlowdocLog 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.process.definition.FlowEmploy 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.process.definition.FlowNode 中的方法
实现父类的isValid函数，进行数据的效验
isValid() - 类 com.trs.cms.process.definition.FlowNodeBranch 中的方法
实现父类的isValid函数，进行数据的效验
isValid() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.process.definition.FlowRule 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.process.engine.FlowContentConfig 中的方法
检验对象数据有效性
isValid() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
实现父类的isValid函数，进行数据的效验
isValid() - 类 com.trs.components.comment.persistent.DocumentTopic 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.comment.persistent.TopicedDocRelation 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.address.Contact 中的方法
检查对象数据的有效性
isValid() - 类 com.trs.components.common.address.ContactGrp 中的方法
验证对象数据的有效性
isValid() - 类 com.trs.components.common.bookmark.BookMark 中的方法
验证对象数据的有效性
isValid() - 类 com.trs.components.common.bookmark.MarkKind 中的方法
验证对象数据的有效性
isValid() - 类 com.trs.components.common.bookmark.MarkShare 中的方法
有效性检验
isValid() - 类 com.trs.components.common.calendar.Event 中的方法
TITLE暂时定为可以重复
isValid() - 类 com.trs.components.common.calendar.EventShare 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.calendar.EventType 中的方法
检查对象数据的有效性
isValid() - 类 com.trs.components.common.conjection.persistent.EntryConfig 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.job.JobWorkerType 中的方法

isValid() - 类 com.trs.components.common.job.Schedule 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.message.Message 中的方法
数据有效性检验
isValid() - 类 com.trs.components.common.message.MsgQueue 中的方法
验证有效性
isValid() - 类 com.trs.components.common.message.MsgReceiver 中的方法

isValid() - 类 com.trs.components.common.publish.persistent.distribute.PublishDistribution 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.persistent.publisher.FolderPublishConfig 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.persistent.taskdispatch.PublishTask 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.persistent.template.TagBean 中的方法
验证TRS置标解析组件是否有效
isValid() - 类 com.trs.components.common.publish.persistent.template.TempApdRel 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.persistent.template.TempAppendix 中的方法
检查模板附件对象数据的有效性
isValid() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法
检查数据的有效性
isValid() - 类 com.trs.components.common.publish.persistent.template.TemplateArgument 中的方法

isValid() - 类 com.trs.components.common.publish.persistent.template.TemplateEmploy 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.persistent.template.TemplateQuote 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.ContentStyle 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.Layout 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.Master 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.PageStyle 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.ResourceStyle 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.StyleAndResource 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.StyleItem 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.Widget 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.WidgetInstance 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.WidgetInstParameter 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.publish.widget.WidgetParameter 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsad.ADCom 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsad.ADFile 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsad.ADFilePos 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsad.ADPos 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsad.ADType 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsvote.Vote 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsvote.VoteData 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsvote.VoteIPLog 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsvote.VoteItem 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.common.trsvote.VoteOption 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.gkml.sqgk.persistent.ApplyForm 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.gkml.sqgk.persistent.ApplyFormDealLog 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.gkml.sqgk.persistent.MailConfig 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.infoview.helper.ComplexFieldData 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.infoview.persistent.InfoView 中的方法

isValid() - 类 com.trs.components.infoview.persistent.InfoViewData 中的方法

isValid() - 类 com.trs.components.infoview.persistent.InfoViewEmploy 中的方法

isValid() - 类 com.trs.components.infoview.persistent.InfoViewField 中的方法

isValid() - 类 com.trs.components.infoview.persistent.InfoViewGroup 中的方法

isValid() - 类 com.trs.components.infoview.persistent.InfoViewView 中的方法

isValid() - 类 com.trs.components.metadata.center.ClassInfoView 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.metadata.center.MetaViewData 中的方法

isValid() - 类 com.trs.components.metadata.center.MetaViewEmployer 中的方法

isValid() - 类 com.trs.components.metadata.definition.ClassInfo 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.metadata.definition.MetaDBField 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.metadata.definition.MetaDBTable 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.metadata.definition.MetaView 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.metadata.definition.MetaViewField 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.special.Special 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.stat.BonusRule 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.stat.ChnlDept 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.stat.DocumentHitsCount 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.stat.HostObjDomain 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.stat.HostObjHitsCount 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.stat.UserLoginInfo 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
检查对象数据的有效性
isValid() - 类 com.trs.components.wcm.content.persistent.AutoBakConfig 中的方法

isValid() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
对象的有效性校验
isValid() - 类 com.trs.components.wcm.content.persistent.ChannelContentLink 中的方法

isValid() - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的方法
检验对象数据有效性
isValid(int, int) - 类 com.trs.components.wcm.content.persistent.ChannelSyn 中的静态方法
校验当前分发是否有效
isValid() - 类 com.trs.components.wcm.content.persistent.ChnlDoc 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.content.persistent.ContentExtField 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.content.persistent.ContentLink 中的方法
效验数据的有效性
isValid() - 类 com.trs.components.wcm.content.persistent.ContentLinkType 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.content.persistent.DocReply 中的方法
检查对象数据的有效性
isValid() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
检查对象数据的有效性
isValid() - 类 com.trs.components.wcm.content.persistent.DocumentSyn 中的方法

isValid() - 类 com.trs.components.wcm.content.persistent.HitsCount 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.content.persistent.Relation 中的方法
检查数据的有效性
isValid() - 类 com.trs.components.wcm.content.persistent.Replace 中的方法
效验数据的有效性
isValid() - 类 com.trs.components.wcm.content.persistent.SiteMember 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.content.persistent.WebSite 中的方法

isValid() - 类 com.trs.components.wcm.content.persistent.XDocument 中的方法

isValid(TRSConnection) - 类 com.trs.components.wcm.content.trsserver.TRSConnectionPool 中的方法

isValid() - 类 com.trs.components.wcm.content.ViewDocument 中的方法

isValid() - 类 com.trs.components.wcm.customize.UserSetting 中的方法
验证对象数据的有效性
isValid() - 类 com.trs.components.wcm.individuation.CustomSiteCheckedInfo 中的方法

isValid() - 类 com.trs.components.wcm.individuation.Individuation 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.publish.logo.Logo 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.publish.region.CellInfo 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.publish.region.RegionEmploy 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.publish.region.RegionInfo 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.publish.WCMPubStatusConfig 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.recent.Recent 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.resource.DocKind 中的方法

isValid() - 类 com.trs.components.wcm.resource.FileType 中的方法

isValid() - 类 com.trs.components.wcm.resource.Keyword 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.resource.Security 中的方法
效验数据的有效性
isValid() - 类 com.trs.components.wcm.resource.Source 中的方法
效验数据的有效性
isValid() - 类 com.trs.components.wcm.resource.Status 中的方法
检查对象数据的有效性
isValid() - 类 com.trs.components.wcm.stat.StatFieldMap 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.stat.StatHost 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.stat.StatView 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.stat.StatViewRel 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.wcmx.help.WCMHelp 中的方法
检验对象数据有效性
isValid() - 类 com.trs.components.wcm.wcmx.media.MediaRemindedInfo 中的方法
检验对象数据有效性
isValid() - 类 com.trs.db.update.DBUpdateLog 中的方法
检验对象数据有效性
isValid() - 类 com.trs.infra.persistent.BaseObj 中的方法
检测对象属性是否有效 注意：子类必须重载！！
isValid() - 类 com.trs.infra.persistent.CMyResultSet 中的方法

isValid() - 类 com.trs.infra.persistent.MyBaseObj 中的方法

isValid() - 类 com.trs.infra.support.config.Config 中的方法
效验数据是否有效
isValid() - 类 com.trs.infra.support.log.BaseDBLog 中的方法
效验数据的有效性
isValid() - 类 com.trs.infra.support.log.OperType 中的方法

isValid() - 类 com.trs.infra.support.security.SecureKey 中的方法

isValid() - 类 com.trs.infra.util.job.JobFailedResult 中的方法

isValid() - 类 com.trs.wcm.config.PageOperator 中的方法
检验对象数据有效性
isValid() - 类 com.trs.wcm.old.ImportDocsContext 中的方法
校验对象的属性是否有效
isValid() - 类 com.trs.wcm.old.WCMExcelData 中的方法

isValid() - 类 com.trs.wcm.old.WCMFormFields 中的方法
检验对象数据有效性
isValid() - 类 com.trs.wcm.old.WCMFormInfo 中的方法
检验对象数据有效性
isValid() - 类 com.trs.wcm.photo.Watermark 中的方法
检验对象数据有效性
isValidateElement(IPublishElement) - 类 com.trs.components.common.publish.domain.PublishServer 中的静态方法
校验指定的发布元素合法性
isValidateElement(int, int) - 类 com.trs.components.common.publish.domain.PublishServer 中的静态方法
校验指定的发布元素合法性
isValidChannelId(MethodContext) - 类 com.trs.ajaxservice.SystemServiceProvider 中的方法
判断指定的栏目Id是否有效
isValidCharOfXML(char) - 类 com.trs.infra.util.CMyString 中的静态方法
校验当前字符是否是合法的XML字符
isValidContentType(String) - 类 com.trs.components.comment.domain.NewsComment 中的静态方法

isValidDocumentCollection(MethodContext) - 类 com.trs.ajaxservice.DocumentSynServiceProvider 中的方法

isValidDocumentSyn(MethodContext) - 类 com.trs.ajaxservice.DocumentSynServiceProvider 中的方法
校验同步创建是否有效，如果有效返回长度为0的字符串，如果无效返回以逗号分隔的Ids
isValidElement() - 接口 com.trs.components.common.publish.persistent.element.IPublishElement 中的方法
判断是否为有效的发布元素
isValidElement() - 类 com.trs.components.common.publish.persistent.element.PublishContentImplBase 中的方法

isValidElement() - 类 com.trs.components.common.publish.persistent.element.PublishElementWrapper 中的方法

isValidElement() - 类 com.trs.components.metadata.publish.PublishFolderClassImpl 中的方法

isValidElement() - 类 com.trs.components.wcm.epress.EpressFolderWrapper 中的方法

isValidElement() - 类 com.trs.components.wcm.publish.element.PublishContentDocumentImpl 中的方法

isValidElement() - 类 com.trs.components.wcm.publish.element.PublishFolderChannelImpl 中的方法

isValidElement() - 类 com.trs.components.wcm.publish.element.PublishFolderWebSiteImpl 中的方法

isValidFile(String, String) - 类 com.trs.infra.support.file.FilesMan 中的静态方法

isValidInstance() - 类 com.trs.cms.auth.persistent.User 中的方法
检测当前对象是否是一个已经存在的实例对象
isValidInstance() - 类 com.trs.components.wcm.content.persistent.Appendix 中的方法
检测当前对象是否是一个已经存在的实例对象
isValidInstance() - 类 com.trs.components.wcm.content.persistent.Document 中的方法
检测当前对象是否是一个已经存在的实例对象
isValidInstance() - 类 com.trs.components.wcm.publish.WCMFolderPublishConfig 中的方法

isValidInstance() - 类 com.trs.infra.persistent.BaseObj 中的方法
检测当前对象是否是一个已经存在的实例对象
isValidMac(long) - 类 com.trs.infra.util.key.MacAddressHelper 中的静态方法

isValidMobile(String) - 类 com.trs.infra.util.CMySMS 中的静态方法
判断指定的手机号是否有效
有效手机号：11位，且不是130/133型
isValidObjectId() - 类 com.trs.webframework.context.MethodContext 中的方法

isValidSignLog() - 类 com.trs.infra.support.log.Log 中的方法
是否为合法的签名日志
isValidSiteId(MethodContext) - 类 com.trs.ajaxservice.SystemServiceProvider 中的方法
判断指定的站点Id是否有效
isValidSQL() - 类 com.trs.infra.persistent.BaseObjs 中的方法
效验SQL语句的合法性
isValidTopRange(String) - 类 com.trs.components.comment.domain.NewsComment 中的静态方法

isVariableDeclare(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的静态方法
判断指定的置标名称是不是变量声名
isVariableParameter(String) - 类 com.trs.components.common.publish.domain.tagparser.TagItem 中的静态方法
判断指定的值是不是模板变量
isVerifyCodeEnable() - 类 com.trs.components.infoview.publish.tagparser.FormProperty 中的方法

isViewable() - 类 com.trs.cms.auth.persistent.Role 中的方法
角色是否在应用可见
isVirtual() - 类 com.trs.components.wcm.content.persistent.Channel 中的方法
判断频道是否是虚拟频道（例如头条新闻、图片新闻等）
isVisible(User, WebSite) - 类 com.trs.ajaxservice.WebSiteHelper 中的静态方法
判断用户对于指定站点是否可见
isVisible(User, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
判断当前用户对于指定对象是否可见
isVisible(Group, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
判断当前组织对于指定对象是否可见
isVisible(Role, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
判断当前角色对于指定对象是否可见
isVisible(CMSObj, int, int) - 接口 com.trs.cms.auth.domain.IObjectMemberMgr 中的方法
判断当前操作者对于指定对象是否可见
isVisible(User, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法

isVisible(Group, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法

isVisible(Role, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法

isVisible(CMSObj, int, int) - 类 com.trs.cms.auth.domain.ObjectMemberMgr 中的方法

isVisible() - 类 com.trs.cms.auth.persistent.ObjectMember 中的方法
提取属性：Visible
isVisible(User, WebSite) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法

isVisible(CMSObj, WebSite) - 类 com.trs.components.wcm.content.domain.SiteMemberMgr 中的方法

isVisible(User, BaseChannel) - 接口 com.trs.service.IChannelService 中的方法
判断指定的频道对象对于用户是否可见
isVisible(User, BaseChannel, int) - 接口 com.trs.service.IChannelService 中的方法
判断在指定的权限值下，指定的频道对象对于用户是否可见
isVisible(User, BaseChannel) - 类 com.trs.service.impl.ChannelService 中的方法

isVisible(User, BaseChannel, int) - 类 com.trs.service.impl.ChannelService 中的方法

isVisualParseMode(PublishTagContext) - 类 com.trs.components.common.publish.domain.tagparser.TagParseHelper 中的静态方法
判断当前是否为可视化设计模式
isWaitIfBusy() - 类 com.trs.infra.persistent.db.DBConnectionConfig 中的方法

isWithAppendix() - 类 com.trs.components.wcm.content.persistent.DocumentXmlConverter 中的方法

isWithChildren() - 类 com.trs.cms.auth.persistent.GroupXmlConverter 中的方法

isWithChildren() - 类 com.trs.components.wcm.content.persistent.ChannelXmlConverter 中的方法

isWithExtField() - 类 com.trs.components.wcm.content.persistent.ChannelXmlConverter 中的方法

isWithinDomain() - 类 com.trs.webframework.entity.RedirectObject 中的方法

isWithTemplates() - 类 com.trs.components.wcm.content.persistent.ChannelXmlConverter 中的方法

isWorked() - 类 com.trs.cms.process.engine.FlowDoc 中的方法
获取当前的轨迹是否处理过
isWrite() - 类 com.trs.components.wcm.content.persistent.DocumentShowFieldConfig 中的方法

isWriteField() - 类 com.trs.cms.process.definition.FlowNodeField 中的方法
判断当前字段是否可写
ISystemContentStyleMgr - com.trs.components.common.publish.widget 中的 接口

ISystemResourceStyleMgr - com.trs.components.common.publish.widget 中的 接口

ISystemWarner - com.trs.components.wcm.util 中的 接口

ITagFormatter - com.trs.components.common.publish.domain.tagparser 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
tag item format converter.
ITagParser - com.trs.components.common.publish.domain.tagparser 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
tag parser interface.
ITagParser4List - com.trs.components.common.publish.domain.tagparser 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
interface for those who support tag TRS_RECORD.
ITemplateEmployCacheMgr - com.trs.components.common.publish.domain.template 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateParseService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板解析接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
提供模板管理的接口
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateService - com.trs.template.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
模板编辑器服务器端代码 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
ITemplateSetting - com.trs.template.domain.setting 中的 接口

iterateNestedIdentity() - 类 com.trs.components.common.publish.persistent.template.Template 中的方法

iterator2Enumeration(Iterator) - 类 com.trs.webframework.controler.JSPServiceContext 中的静态方法

iteratorKeywords() - 类 com.trs.infra.persistent.db.DBManager 中的方法

IToUsersCreator - com.trs.cms.process.engine 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
处理人产生器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IUpdateCommander - com.trs.infra.update 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
Update Commonder
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IURLParser - com.trs.components.stat 中的 接口

IUserCacheMgr - com.trs.cms.auth.persistent 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
用户缓冲管理接口定义
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IUserLoginInfoMgr - com.trs.components.stat 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
用户登录信息的业务逻辑层接口
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
IUserService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
用户管理的各种接口 Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IValidator - com.trs.presentation.valid 中的 接口
An object that works with an IFormComponentto format output (convert object values to strings values) and to process input (convert strings to object values and validate them).
IValidator - com.trs.wcag2.validator 中的 接口

IVChannelParser - com.trs.components.wcm.channel 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
解释器
Copyright: Copyright (c) 2004-2009 北京拓尔思信息技术股份有限公司
Company: 北京拓尔思信息技术股份有限公司(www.trs.com.cn)
IVContentLinkParser - com.trs.components.wcm.contentlink 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2010 北京拓尔思信息技术股份有限公司
Company: www.trs.com.cn
IVisualTemplateServiceProvider - com.trs.components.common.publish.widget 中的 接口

IWCMProcessService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
TODO
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IWCMPublishElementService - com.trs.service 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
service interface for publish element settings in WCM.
IWidgetInstanceMgr - com.trs.components.common.publish.widget 中的 接口

IWidgetInstParameterMgr - com.trs.components.common.publish.widget 中的 接口

IWidgetMgr - com.trs.components.common.publish.widget 中的 接口

IWidgetParameterMgr - com.trs.components.common.publish.widget 中的 接口

IWidgetParameterServiceProvider - com.trs.components.common.publish.widget 中的 接口

IWidgetServer - com.trs.components.common.publish.widget 中的 接口

IWidgetServiceProvider - com.trs.components.common.publish.widget 中的 接口

IXMLConvertor - com.trs.webframework.xmlserver 中的 接口
Title: TRS 内容协作平台（TRS WCM）
Description:
Java对象转换成XML生成器
Copyright: Copyright (c) 2004-2005 TRS信息技术有限公司
Company: TRS信息技术有限公司(www.trs.com.cn)
IXmlPersistentObject - com.trs.infra.util.xml 中的 接口

概述  软件包  类  使用  树  已过时   索引  帮助
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


生成的文档（无标题）

框架警报

请使用框架功能查看此文档。如果看到此消息，则表明您使用的是不支持框架的 Web 客户机。
链接到非框架版本。